Image Font Extractor 1.0

OCVMax ツールを設定するには、このツールで検証する各文字のレイアウトを定義したフォントファイルを指定する必要があります。 OCVMax ツールは欧米言語の TrueType ASCII 文字フォントをすべてサポートしていますので、これに対応するフォントファイルはすべて指定して使用できます。

さまざまな印刷検査に適した共通フォントのライブラリも提供しています。 デフォルトでは、これらのフォントはインストールユーティリティにより、ディレクトリ C:¥Program Files¥Cognex¥VisionPro¥Fonts にインストールされます。『OCVMax アプリケーションガイド』(日本語版は弊社サポート Web サイトをご覧ください) には、印刷した文字列との比較に使用できる、すべての文字が記載されたプルーフシートがあります。このガイド (英語版) は、[スタート] → [プログラム] → [Cognex] → [VisionPro] → [OCVMax Application Guide] を選択すると表示されます。

文字列に弊社から提供されていないフォントが使用されている場合、そのフォントファイルを別途入手する必要があります。 使用している画像処理アプリケーションに適したフォントファイルを見つけるために、次のことを提案します。

  • 使用している印刷機器の製造元に連絡します。

    製造元は、その印刷機器で使用されているフォント名を教えてくれるはずです。フォントファイルそのものを提供してもらえる可能性もあります。

  • フォント名がわかっている場合は、使用している PC の ¥WINDOWS¥Fonts ディレクトリを検索します。

    印刷機器で TrueType フォントを使用している場合、Microsoft Word の [フォント] ダイアログボックスを使用して、すべての TrueType フォントをプレビューすることができます。

  • Web サイト http://www.myfonts.com/WhatTheFont を調べてみます。これはフォントを検索、試用、購入するためのオンラインソースです。 この Web サイトは 41,680 種類のフォントを取り扱っており、ここで印刷文字列に一致する適切なフォントを検索し、購入できます。

  • Image Font Extractor を使用して、独自のフォントファイルを作成します。

    このオンラインドキュメントでは、Image Font Extractor の使用方法について説明します。

詳細については、次のトピックを参照してください。

  • 画像ベースのフォント

  • 画像からの文字フォントの抽出

  • フォントの変更

  • 個々の文字の変更

  • OCV ツールで使用されるフォントファイルの作成


著作権

本書に記載されているソフトウェアは、使用権許諾の態様で提供され、またかかる使用権許諾の条件に従ってかつ本ページに示されている著作権文言を記載した上で使用または複製することができます。本ソフトウェア、本書、またはこれらの複製物は、使用権者以外のいかなる者に対しても提供され利用に供されることはありません。本ソフトウェアの所有権およびその他の権利は Cognex Corporation または Cognex Corporation への使用権許諾者が留保します。

  • Cognex Corporation


Cognex Corporation

Cognex Corporation は、同社が提供してしない装置における同社製ソフトウェアの使用または信頼性についていかなる責任も負いません。Cognex Corporation は、本書で記述されているソフトウェアの内容、商品価値、または特定の使用目的に対する責任に関して、明示または黙示にかかわらずいかなる保証も行いません。

本書の内容は、予告なしに変更することがあります。内容の変更について、Cognex Corporation はいかなる責任も負いません。本書あるいは関連ソフトウェアにおける誤りにおいて、Cognex Corporation はいかなる責任も負いません。

Copyright © 2007 Cognex Corporation All Rights Reserved

本書の内容の一部、または全部を Cognex Corporation の書面による許可なく複製、他のメディアに送信すること、 および他の言語に翻訳することを禁じます。

本書で説明しているハードウェアおよびソフトウェアの一部については、Cognex ウェブサイト http://www.cognex.com/patents.asp に示す 1 つまたは複数の米国特許で保護されていることがあります。その他の米国および他国の特許については申請中です。

下記は Cognex Corporation の登録商標です。

acuCoder | acuFinder | acuReader | acuWin | BGAII
CheckPoint | Cognex | Cognex, Vision for Industry | CVC-1000 | CVL
DisplayInspect | ID Expert | ID Max | PasteInspect | PatFind
PatInspect | PatMax | PatQuick | PixelProbe | SMD 4
Virtual Checksum | VisionLinx | VisionPro | VisionX |

他の Cognex 製品、ツール、またはその他の商標名は、慣習法による Cognex Corporation の商標とみなされることがあります。これらの商標には "TM" がつけられている場合があります。その他の製品名および企業名は、各所有者に帰属する商標です。

この製品には、RSA Security, Inc. よりライセンスされたコードが含まれています。

IBM よりライセンスされたコードの一部には、http://oss.software.ibm.com/icu4j/ から入手可能なものもあります。


ユーザーズガイドの操作と印刷

このヘルプシステム内のトピックを表示するには、[Contents] タブで目的のトピックをクリックします。また、次のナビゲーションボタンを使用することもできます。

  • 次のヘルプトピック、または現在のトピックの次のサブトピックに移動します。

  • 前のヘルプトピック、または現在のトピックを含むトピックに移動します。

  • 最後に表示したトピックに移動します。ハイパーリンクをたどってきた場合は、最後に表示したトピックに戻ります。

  • 現在のトピックを印刷します。

をクリックし、[Print the heading and all subtopics] を選択して、現在のトピックと、そのサブトピックをすべて印刷することもできます。

このユーザーズガイド全体を印刷するには、「Image Font Extractor」を選択し、[Print] ダイアログボックスで [Print the heading and all subtopics] を選択します。


画像ベースのフォント

画像内の文字のレイアウトを定義したフォントファイルを見つけられない場合、VisionPro に同梱されている Image Font Extractor を使用して、OCVMax ツールで検証する必要のある文字の例が含まれる画像から、独自のフォントファイルを作成することができます。

最終的に、Image Font Extractor を使用して生成したフォントファイルすべてに、文字キーのコレクションが含まれます。次の図にあるように、個々の文字は複数の定義により表現されています。

一般に、文字キーの生成に使用される文字には必ず、次の特徴があります。

  • 寸法は 10 × 10 ～ 64 × 64 ピクセル

  • ストローク幅は 3 ～ 8 ピクセル

  • 文字の周りの空白部分は、ストローク幅と同じ

  • 直線に沿って位置を定義するモデル原点。Image Font Extractor は、大半の文字キーについて正しい位置のモデル原点を自動的に検出します。

画像ベースのフォントを作成するとき、固定幅フォントとプロポーショナルフォントのどちらを作成するか選択できます。固定幅フォントでは、各文字キーのモデルの高さとモデル幅は常に一定です。文字ごとに異なるモデルの高さとモデル幅を使用できるようにすると、生成したフォントはプロポーショナルになります。

画像ベースのフォントに関する詳細については、次のトピックを参照してください。

  • スペース文字

  • 文字キーの名前

  • プルーフシート

  • Image Font Extractor の起動


スペース文字

OCVMax ツールのアプリケーションの中には、1 つ以上の空白スペースの検証を必要とするものも多数あります。Image Font Extractor を使用して、文字ピクセルを含まないスペース文字を定義することもできますが、通常は、次の図にあるように、スペース文字の幅、高さ、名前、回転、および原点により定義します。

OCVMax ツールの設定時に、ほかの文字と同様に <SP> 文字を指定します。次の図にあるように、<SP> 文字もほかの文字キーと同様に検証されます。

[注] 注

スペース文字の文字キー名は <SP> で、これは変更できません。


文字キーの名前

Image Font Extractor で作成された各文字キーには固有の名前が割り当てられています。OCVMax ツールで有効な文字であると認識するために、Image Font Extractor では、各文字に対して明確な名前付け規則が使用されていますので注意してください。具体的には、各文字キーは、次の名前のいずれかになります。

  • A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
  • a b c d e f g h i j k l m n o p q r s t u v w x y z
  • 0 1 2 3 4 5 6 7 8 9
  • <SP> ! " # $ % & ' ) ( * + , - . /


プルーフシート

Image Font Extractor を使ってフォントファイルを構築するには、OCVMax ツールで検証する文字列の画像が必要です。Image Font Extractor では、どのような画像を使用する場合でも、次の項目に対応することができます。

  • 連続印刷、またはドットマトリックス印刷

  • 固定幅フォント、またはプロポーショナルフォント

  • 黒地に白、または白地に黒印刷

  • スペース文字

  • 複数行のテキスト

    行はすべて平行で、それぞれ上の行の真下にある必要があります。

  • 句読点

検証の対象となる文字列に現れる可能性のあるすべての文字を 1 つの画像にまとめた、プルーフシートの使用を推奨します。次の画像は、プルーフシートのサンプルです。

プルーフシートには、すべての文字について、次の特徴があります。

  • アプリケーションの動作に従って取得される実際の画像と同じサイズおよびスケールである

    プルーフシート内の文字に対する検証対象文字列内の文字のスケール変化が 0.8 ～ 1.2 倍の範囲内である。

  • 回転が同じである (回転はないことが望ましい)

    Image Font Extractor は、せん断の現れている文字と同様、回転している文字も補正できます。

  • 検証の対象となる文字列の画像を照らすために使用するのと同じ照明方法で照らされている

    通常、プルーフシートと実際の文字列で照明が異なると、結果の精度が低下します。

プルーフシートを入手または生成できない場合、複数の取り込み画像を使用して、フォントファイルを生成することができます。ただし、これらの画像は全体として、1 つのプルーフシートと同じ特性を備えている必要があります。例えば、OCVMax ツールでの検証の対象となる各文字の画像を取り込めない場合、またはフォントの生成に使用する画像に含まれる照明量に大きなばらつきがある場合、画像ベースのフォントを正しく構築し、使用することはできません。

次の文字列画像は、Image Font Extractor には適していない画像の例です。


Image Font Extractor の起動

Image Font Extractor を起動するには、[スタート] → [プログラム] → [Cognex] → [VisionPro] → [Utilities] → [Image Font Extractor] を順に選択します。

次の図は、Image Font Extractor のさまざまなコンポーネントを表しています。


画像からの文字フォントの抽出

通常、画像ベースのフォントに対する文字キーは簡単な手順で抽出できます。

  1. OCVMax ツールで検証する必要のある文字サンプルが入った文字列を含む画像を選択します。

    使用を推奨している画像のタイプについては、「プルーフシート」を参照してください。

  2. 使用する必要のある画像内の文字の範囲を表すには、抽出矩形を表すグラフィックスを使用します。

  3. 抽出矩形で囲まれた文字を表す文字列を入力します。

  4. [Extract] をクリックし、Image Font Extractor により、必要な文字キーが作成されたことを確認します。

次の図は、抽出矩形で囲まれた文字列から文字キーを生成するために、ユーザが [Extract] をクリックする直前の Image Font Extractor を表しています。

Image Font Extractor では、文字キー作成のためのモードが 2 つサポートされています。

  • Automatic モード

    デフォルトでは、Image Font Extractor は Automatic モードで動作します。このモードでは、ユーザは設定をほとんど変更することなく、文字キーを抽出できます。最初は、Automatic モードで画像ベースフォントを生成してみることを推奨します。

    次の図にあるように、Automatic モードでは、Image Font Extractor で文字キーを抽出する前に実行する必要があるのは、抽出矩形で文字を囲む手順のみです。

    Automatic モードの使用方法については、「Automatic モードの使用」を参照してください。Automatic モードでは、「詳細パラメータの使用」で説明されているように、特殊な状況での詳細パラメータの設定もサポートされています。

  • Manual モード

    Manual モードはデフォルトのモードではありません。画像から文字キーを正常に抽出できるようにするには、通常、Automatic モードよりも多くのユーザ操作が必要になります。Automatic モードを使用しているときに、Image Font Extractor から文字キーの作成に関する問題が報告された場合は、Manual モードを試してください。

    Manual モードでは、次の図にあるように、抽出矩形に個々の文字を区別するための垂直線が表示されます。

    固定幅フォントのフォントファイルを作成している場合、上の図にあるように、垂直線は文字ごとに固定されています。一方、プロポーショナルフォントを作成している場合は、次の図にあるように、垂直線を個々に調節することができます。

    Manual モードの使用方法については、「Manual モードの使用」を参照してください。Manual モードでは、「詳細パラメータの使用」で説明されているとおり、特殊な状況での詳細パラメータの設定もサポートされています。

画像からの文字キーの抽出に関する詳細については、次のトピックを参照してください。

  • 画像ファイルの選択

  • 抽出矩形の配置

  • Automatic モードの使用

  • Manual モードの使用

  • 詳細パラメータの使用


画像ファイルの選択

Image Font Extractor は、ビットマップファイル、コグネックスデータベース (.CDB) ファイル、または画像データベース (.IDB) ファイルとして格納された画像をロードすることができます。

フォントファイルの生成に使用する文字を含むファイルを選択するには、Image Font Extractor の Image 領域を使用します。次の図では、該当する設定項目をハイライトしています。


抽出矩形の配置

Automatic モードを使用しているか、Manual モードを使用しているかに関わらず、文字キーの作成に使用する文字の周りに抽出矩形を配置する、つまり文字を抽出矩形で囲む必要があります。画像に抽出矩形を配置するときには、次の条件に注意してください。

  • 次の図でハイライトされているように、抽出矩形には、サイズや、表示される回転量およびせん断量を制御するためのハンドルが付いています。

    ほとんどの場合、これらのグラフィックハンドルを使用して、抽出矩形を配置できます。ただし、現在文字に表示されている回転角度やせん断量と正確に合うように抽出矩形を変更する必要はありません。実際には、抽出矩形における回転やせん断は約 15 度まで許容されます。ただし、可能な限り画像内の回転やせん断に近くなるように矩形を調整してみてください。例えば、次の画像には 3 行の文字列が表示されていますが、これらの文字のせん断に合うように、抽出矩形が調節されています。

    また、次の図でハイライトされているように、Image Font Extractor の設定項目を使用して矩形を正確な値で指定することもできます。

    例えば、ある画像では、文字が特定の角度で表示されていることに気付いた場合は、[Rotation] の値を正確に設定することができます。

  • 文字以外の画像情報は入力しないでください。

    例えば、次のように抽出矩形にバーコード記号情報が含まれているのは適切ではありません。

  • 抽出矩形には、生成する文字数と同じ数の文字が含まれている必要があります。

    例えば、次の画像には文字列 "0781-8842-01" を囲む抽出矩形が含まれています。

    この文字列について、Image Font Extractor により、一致する文字列 "0781-8842-01" に対する文字キーが作成されるように指定する必要があります。"0781" など、一致しない文字列を入力した場合、Font Image Extractor は文字キーを生成できません。


Automatic モードの使用

Automatic モードは Image Font Extractor のデフォルトのモードです。画像ベースフォントの文字キーを作成するには、まず、Automatic モードを使用してみてください。

Automatic モードを使用して、次の手順を実行します。

  1. 画像ベースフォントの作成に使用する文字を含む画像ファイルを選択します。

    画像ファイルの選択に関する詳細については、「画像ファイルの選択」を参照してください。

  2. 使用する必要のある文字を抽出矩形で囲み、この矩形のサイズを適切に変更して、回転とせん断を調整します。

    抽出矩形の使用に関する詳細については、「抽出矩形の配置」を参照してください。

  3. 次の図にあるように、[Extract] タブを使用して、抽出矩形で囲まれている文字を入力します。

  4. [Extract] をクリックします。

Image Font Extractor での作業が正常に終了すると、次の図のように、文字グリッドに新しい文字キーが表示されます。

さらに複数の画像を使用して、ほかの文字キーの作成を続けることができます。または、OCVMax ツールで使用できるようにフォントを保存することもできます。

文字キーの抽出に失敗すると、Image Font Extractor から次のメッセージが表示されます。

次のいずれかの操作を実行して、問題を解決します。

  • 画像内の文字のサイズ、形状、回転、せん断に合わせて、抽出矩形を調整します。

    抽出矩形の使用に関する詳細については、「抽出矩形の配置」を参照してください。

  • Image Font Extractor のしきい値 (文字を表すピクセルと、背景を表すピクセルの判別に使用される値) などの詳細パラメータを設定してみます。

    詳細パラメータに関する詳細については、「詳細パラメータの使用」を参照してください。

  • Manual モードを使用してみます。「Manual モードの使用」を参照してください。


Manual モードの使用

Manual モードは Image Font Extractor のデフォルトのモードではありません。Automatic モードで必要な文字キーを生成できない場合に、Manual モードを試してください。

[注] 注

Manual モードを使用している場合、抽出できる文字は 1 行のみですので注意してください。

Manual モードを使用して、次の手順を実行します。

  1. 画像ベースフォントの作成に使用する文字を含む画像ファイルを選択します。

    画像ファイルの選択に関する詳細については、「画像ファイルの選択」を参照してください。

  2. 抽出矩形で使用する必要のある文字を 1 行囲み、この矩形のサイズを適切に変更して、回転とせん断を調整します。

    抽出矩形の使用方法に関する詳細については、「抽出矩形の配置」を参照してください。

    次の図にあるように、抽出矩形内の垂直セパレータを使用して、文字を 1 つ 1 つ区切ります。

  3. 次の図にあるように、[Extract] タブを使用して、抽出矩形で囲まれている文字を入力します。

  4. [Extract] をクリックします。

Image Font Extractor での作業が正常に終了すると、次の図のように、文字グリッドに新しい文字キーが表示されます。

文字キーの抽出に失敗すると、Image Font Extractor から次のメッセージが表示されます。

次のいずれかの操作を実行して、問題を解決します。

  • 画像内の文字のサイズ、形状、回転、せん断に合わせて、抽出矩形を調整します。

    抽出矩形の使用方法に関する詳細については、「抽出矩形の配置」を参照してください。

  • Image Font Extractor のしきい値 (文字を表すピクセルと、背景を表すピクセルの判別に使用される値) などの詳細パラメータを設定してみます。

    詳細パラメータに関する詳細については、「詳細パラメータの使用」を参照してください。


詳細パラメータの使用

[Extract] タブでは、Automatic モードまたは Manual モードで満足する結果が得られなかった場合に、必要な文字キーを生成できるようにする詳細パラメータがサポートされています。画像ベースのフォントの大半では、詳細パラメータを使用する必要はありません。[Show advanced params] をクリックすると、次の図のような詳細パラメータが表示されます。

ここでは、それぞれの詳細パラメータついて、デフォルト値の変更が必要となる場合の理由について説明します。

詳細機能

用途

Specify baseline

デフォルトでは、Image Font Extractor により、1 本の線に沿ったすべての文字で使用できるベースラインが適切に判断されますが、この詳細パラメータを有効にすると、文字を囲む矩形の底辺から、このツールで使用されるベースラインまでのピクセル数を指定することができます。

引用符やアポストロフィなど、文字列に含まれる文字のいくつかがベースラインよりもかなり上に表示され、これらの文字の外観が原因で、Image Font Extractor による適切なベースラインの位置の判断が困難な場合、ベースラインの値を正確に指定する必要があります。

Fix baseline jitter

ここでジッタを設定することにより、Image Font Extractor は、デセンダを使用する文字のベースラインを正しく判断できるようになります。デセンダとは、通常、ベースラインよりも下に出る文字の部分です。例えば、"Q" や "g" などの文字を印刷すると、通常、ベースラインの下に印刷される部分があります。

デフォルト値の 10% は大半のフォントに有効で、画像にデセンダを持つ文字が含まれていても、Image Font Extractor は自動的に正しいベースラインを判断することができます。画像に大きなデセンダを持つ文字が含まれている場合は、この値を大きくする必要があることもあります。画像に大きなデセンダを持つ文字が含まれていない場合は、この値を 0 に設定できます。

Keep font single height

デフォルトでは、Image Font Extractor は文字列内の文字はすべて同じ高さであると想定します。文字列の中に、ほかの文字とは異なる高さの文字が含まれている場合は、このパラメータを無効にできます。

Allow nonuniform background

文字の背景の外観が均一である場合、このパラメータを無効にできます。

Auto accept all

Image Font Extractor では、どのような文字でも、文字 1 つにつき 1 つの文字キーのみ生成されます。同じ文字が何度も現れる文字列については、次のパラメータを使用して、Image Font Extractor がどのように、どの文字キーをフォントファイルに追加するかを設定することができます。

  • Keep first: この文字のインスタンスがまだフォントに含まれていない場合のみ、この文字の最初のインスタンスをフォントに追加します。フォントに既にこの文字が含まれている場合、フォントは変更されず、新しいインスタンスは無視されます。

  • Keep first new: 文字列中の文字の最初のインスタンスをフォントに追加します。フォントに既にこの文字が含まれている場合、新しいインスタンスで置き換えられます。

  • Keep last: この文字のインスタンスがまだフォントに含まれていない場合のみ、この文字の最後のインスタンスをフォントに追加します。フォントに既にこの文字が含まれている場合、フォントは変更されず、新しいインスタンスは無視されます。

  • Keep last new (デフォルト): 文字列中の文字の最後のインスタンスをフォントに追加します。フォントに既にこの文字が含まれている場合、新しいインスタンスで置き換えられます。

Character color

文字の色は黒であるか白であるかを正確に指定できます。

Automatic

Image Font Extractor では、Automatic モード特有の詳細パラメータがサポートされています。

  • Specify threshold: デフォルトでは、Image Font Extractor はグレー値 128 を基準に文字ピクセルと背景ピクセルを区別します。画像に含まれる文字と背景のグレー値に大きな差がない場合、このパラメータを有効して、具体的なグレー値を設定できます。

  • Refine baseline angle: デフォルトでは、文字列内の微小な回転は抽出矩形により補正されます。ただし、画像に表示されている文字の回転におおよそ一致するように、抽出矩形を回転させる必要があります。自動的に判断された角度が間違っているとはっきりわかる場合、このパラメータを無効にできます。

  • Refine shear: デフォルトでは、文字列内の微小なせん断は抽出矩形により補正されます。ただし、画像に表示されている文字のせん断におおよそ一致するように、抽出矩形を操作する必要があります。自動的に判断されたせん断の値が間違っているとはっきりわかる場合、このパラメータを無効にできます。

  • Use full vertical extent: デフォルトでは、Image Font Extractor により、文字の上下に小さな垂直パディングが挿入され、文字の妥当な高さが決定されます。この詳細パラメータを有効にした場合、各文字キーの高さは抽出矩形の高さと同じになります。

Manual

Manual モードを使用している場合は、互いにプロポーショナルな文字キーが抽出されるように Image Font Extractor を設定します。画像内の文字が固定幅フォントである場合は、[Fixed-width] を選択します。


フォントの変更

画像から文字キーを正常に抽出すると、次の図のように、Image Font Extractor の文字グリッドに現在の文字キーが表示されます。

文字グリッドでは、次のグラフィックスが使用されます。

  • 赤色の線は、Cell min (ベースラインからの距離をピクセル単位で表したもの) を示しています。

  • 青色の線は、Image Font Extractor により計算された、またはユーザにより詳細パラメータを使って正確に指定されたベースラインを表します。

    OCVMax ツールのパフォーマンスを最大限引き出すには、すべての文字はベースライン上に載っている必要がありますが、ベースラインの下に延びるデセンダを持つ文字、およびアポストロフィのようにベースラインに触れない文字は例外となります。

  • 緑色のマーカは文字キーの原点を示します。

    最適な OCVMax ツールパフォーマンスを得るには、アポストロフィのようにベースラインに触れない文字を除いて、原点は各文字下部のリーディング (左端) 部分に表示される必要があります。

  • 緑色の線は、ベースラインからの距離をピクセル単位で表した Cell max を示しています。

  • 現在選択されている文字キーは青色のボックス内に表示されます。

    選択されていない文字キーは水色のボックス内に表示されます。

現在のフォントファイルの変更については、次のトピックを参照してください。

  • フォントプロパティの変更

  • 文字キーの削除

  • フォントファイルの保存とロード


フォントプロパティの変更

使用しているフォントに含まれるすべての文字キーに関連するパラメータを変更するには、[Font] タブを選択します。次の画像は [Font] タブをハイライトしたものです。

[Font] タブにはさまざまな用途があります。

  • [Font] タブの上部では、フォント名を付けたり、フォントファイルのそのほかの特性を変更したりすることができます。

    [Font] タブに値を入力して、[Cell min] や [Cell max] などのフォントプロパティを変更できますが、文字グリッドに表示されているグラフィックスを使用して、[Trim] をクリックした方が簡単です。

  • 文字グリッドでの文字キーの表示方法を変更できます。

  • 文字グリッドに表示されるグラフィックスを切り替えられます。


文字キーの削除

現在のフォントファイルから 1 つ以上の文字キーを削除するには、[Delete chars] または [Delect all chars] をクリックします。[Delete chars] をクリックすると、次の例にあるように、[Font] タブに、文字キーを個別に削除する手順が表示されます。


フォントファイルの保存とロード

画像ベースの新しいフォントファイルを OCVMax ツールにロードするには、まず、このファイルを保存する必要があります。[Font] タブの [Save] をクリックし、次のダイアログボックスを使用してフォントファイルを保存します。

OCVMax ツールのパフォーマンスを最大限引き出すには、フォントファイルを .ocm 形式で保存します。

[注] 注

Image Font Extractor では、既存のフォントファイルや、OCV ツールとともに使用されるフォントファイルの作成に備えて、従来の .ocf 形式もサポートされています。

また、[Font] タブを使用して、文字キーを追加したり、フォント全体や特定の文字キーのプロパティを変更したりするために必要な既存のフォントファイルをロードすることもできます。フォントファイルの特性の変更については、トピック「フォントプロパティの変更」を、特定の文字キーの変更については、「個々の文字の変更」を参照してください。


個々の文字の変更

Image Font Extractor の [Character] タブでは、画像ベースのフォントに含まれる各文字に固有の情報を表示するとともに、任意の文字に対する詳細な設定を変更することができます。次の図は、[Character] タブの例です。

文字グリッド内の文字キーを選択すると、[Character] タブにその特性が表示されます。これは次のように、さまざまな方法で使用できます。

  • 文字の幅、高さ、色を表示する方法については、次の例を参照してください。

    また、[Edit image] をクリックして、任意の文字ピクセルのグレー値を変更できます。詳細については、このトピックで後述します。

  • 文字の Unicode 識別子を表示し、タブの次の部分を使用して、名前のほかに説明を入力します。

  • タブの次の部分を使用して、モデルの原点や文字送りの位置を変更します。

[Character] タブの [Edit image] をクリックすると、次の例にあるように、Image Font Extractor のエディタ内に文字が開き、文字キーの部分を変更できるようになります。

[Pen mode] コントロールとマウスを使用して、文字グリッドの内側に表示されている文字ピクセルのグレー値を変更します。使用するペンのサイズを決定するには、[Pen size] コントロールを使用します。


OCV ツールで使用されるフォントファイルの作成

Image Font Extractor を使用して、OCVMax ツールおよび OCV ツールの両方に対応したフォントファイルを作成することができます。OCVMax ツールと同様、OCV ツールを使用して、画像内の 1 つ以上の文字が、各位置に予想されている文字と一致するかどうかを検証できます。これらのツールの違いに注意すると、使用しているビジョンアプリケーションに適したツールを選択し易くなります。

  • サーチ信頼性

    OCVMax ツールは、Cognex PatMax テクノロジを使用して、各文字列をサーチします。これにより、連続画像で文字列の位置が変化する場合でも、各文字列を検出する際の信頼性を高くすることができます。

  • 歪み

    OCVMax ツールでは、OCV ツールよりもはるかに多くの画像間文字歪みに対応できます。

  • 画像ベースの登録

    OCV ツールを直接使用して、このツール用のフォントファイルを生成できます。Image Font Extractor を起動する必要はありません。この画像ベースの登録機能により、OCV ツールは欧米以外の言語のフォントをサポートできるようになります。

最後に、Image Font Extractor を使用して、OCV ツールで使用されるフォントファイルを作成する場合、このファイルは .ocf 形式で保存する必要があります。OCV ツールでは、.ocm 形式はサポートされていません。