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Legal Notices 

The software described in this document is furnished under license, and may be used or 

copied only in accordance with the terms of such license and with the inclusion of the 

copyright notice shown on this page. Neither the software, this document, nor any copies 

thereof may be provided to, or otherwise made available to, anyone other than the licensee. 

Title to, and ownership of, this software remains with Cognex Corporation or its licensor. 

Cognex Corporation assumes no responsibility for the use or reliability of its software on 

equipment that is not supplied by Cognex Corporation. Cognex Corporation makes no 

warranties, either express or implied, regarding the described software, its merchantability, 

non-infringement or its fitness for any particular purpose. 

The information in this document is subject to change without notice and should not be 

construed as a commitment by Cognex Corporation. Cognex Corporation is not responsible 

for any errors that may be present in either this document or the associated software. 

No part of this document may be reproduced or transmitted in any form or by any means, 

electronic or mechanical, for any purpose, nor transferred to any other media or language 

without the written permission of Cognex Corporation. 

Copyright © 2013 Cognex Corporation. All Rights Reserved. 

Portions of the hardware and software provided by Cognex may be covered by one or more 

of the U.S. and foreign patents listed below as well as pending U.S. and foreign patents.  

Such pending U.S. and foreign patents issued after the date of this document are listed on 

Cognex web site at http://www.cognex.com/patents.  

VisionPro 

5481712, 5495537, 5548326, 5583954, 5602937, 5640200, 5751853, 5768443, 5825913, 

5850466, 5872870, 5901241, 5943441, 5978080, 5978521, 5987172, 6005978, 6039254, 

6064388, 6075881, 6137893, 6141033, 6167150, 6215915, 6240208, 6324299, 6381366, 

6381375, 6411734, 6421458, 6459820, 6490375, 6516092, 6563324, 6658145, 6687402, 

6690842, 6697535, 6718074, 6748110, 6771808, 6804416, 6836567, 6850646, 6856698, 

6920241, 6959112, 6963338, 6973207, 6975764, 6985625, 6993177, 6993192, 7006712, 

7016539, 7043081, 7058225, 7065262, 7088862, 7164796, 7190834, 7242801, 7251366, 

7313761, EP0713593, JP3522280, JP3927239 

DataMan 

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 

6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, 

US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, 

US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, 

US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, 

US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, 

US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1, EP1687752 

CVL 

5495537, 5548326, 5583954, 5602937, 5640200, 5717785, 5751853, 5768443, 5825483, 

5825913, 5850466, 5859923, 5872870, 5901241, 5943441, 5949905, 5978080, 5987172, 

5995648, 6002793, 6005978, 6064388, 6067379, 6075881, 6137893, 6141033, 6157732, 

6167150, 6215915, 6240208, 6240218, 6324299, 6381366, 6381375, 6408109, 6411734, 

6421458, 6457032, 6459820, 6490375, 6516092, 6563324, 6658145, 6687402, 6690842, 

6718074, 6748110, 6751361, 6771808, 6798925, 6804416, 6836567, 6850646, 6856698, 

http://www.cognex.com/patents
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6920241, 6959112, 6975764, 6985625, 6993177, 6993192, 7006712, 7016539, 7043081, 

7058225, 7065262, 7088862, 7164796, 7190834, 7242801, 7251366, EP0713593, 

JP3522280,  JP3927239 

VGR 

5495537, 5602937, 5640200, 5768443, 5825483, 5850466, 5859923, 5949905, 5978080, 

5995648, 6002793, 6005978, 6075881, 6137893, 6141033, 6157732, 6167150, 6215915, 

6324299, 6381375, 6408109, 6411734, 6421458, 6457032, 6459820, 6490375, 6516092, 

6563324, 6658145, 6690842, 6748110, 6751361, 6771808, 6804416, 6836567, 6850646, 

6856698, 6959112, 6975764, 6985625, 6993192, 7006712, 7016539, 7043081, 7058225, 

7065262, 7088862, 7164796, 7190834, 7242801, 7251366 

OMNIVIEW 

6215915, 6381375, 6408109, 6421458, 6457032, 6459820, 6594623, 6804416, 6959112, 

7383536 

CVL Vision Library 

5495537, 5548326, 5583954, 5602937, 5640200, 5717785, 5751853, 5768443, 5825483, 

5825913, 5850466, 5859923, 5872870, 5901241, 5943441, 5949905, 5978080, 5987172, 

5995648, 6002793, 6005978, 6064388, 6067379, 6075881, 6137893, 6141033, 6157732, 
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6421458, 6457032, 6459820, 6490375, 6516092, 6563324, 6658145, 6687402, 6690842, 

6718074, 6748110, 6751361, 6771808, 6798925, 6804416, 6836567, 6850646, 6856698, 

6920241, 6959112, 6975764, 6985625, 6993177, 6993192, 7006712, 7016539, 7043081, 

7058225, 7065262, 7088862, 7164796, 7190834, 7242801, 7251366, EP0713593, 

JP3522280,  JP3927239 

SMD 4 

5995648, 5850466, 6751361, 6690842, 6563324, 6490375, 5949905, 5978080, 6137893, 6167150, 6075881, 6748110, 5859923, 6411734, 6324299, 
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6215915, 6381375, 6457032, 6157732, 6408109, 6141033, 6026176, 6442291, 6151406, 6396942, 6614926, 5371690, 5845007, 5943441, 6963338, 
5805722, 5909504, 5933523, 5964844, 5974169, 5987172, 6078700, 6252986, 6278796, 6307210, 6408429, 6424734, 6526165, 6571006, 6639624, 
6681039, 6748104, 6813377, 6853751, 6898333, 6950548, 6993177, 7139421, 5757956 
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5495537, 5602937, 5640200, 5768443, 5801966, 5825483, 5850466, 5859923, 5949905, 5978080, 5995648, 6002793, 6005978, 6026176, 6055328, 
6075881, 6115042, 6118893, 6130959, 6137893, 6141009, 6141033, 6151406, 6157732, 6167150, 6215915, 6289117, 6324299, 6353676, 6381375, 
6396942, 6408109, 6411734, 6421458, 6442291, 6457032, 6459820, 6490375, 6516092, 6563324, 6577775, 6614926, 6658145, 6690842, 6748110, 
6751361, 6771808, 6804416, 6836567, 6850646, 6856698, 6959112, 6975764, 6985625, 6993192, 7006712, 7016539, 7043081, 7058225, 7065262, 
7088862, 7164796, 7190834, 7242801, 7251366 

Wire Bonder 

5495537, 5532739, 5581632, 5602937, 5640199, 5640200, 5642158, 5676302, 5754679, 5757956, 5768443, 5825483, 5835622, 5850466, 5859923, 
5861909, 5949905, 5978080, 5991436, 5995648, 6002793, 6005978, 6035066, 6061467, 6075881, 6137893, 6141033, 6157732, 6167150, 6215915, 
6289492, 6324299, 6381375, 6408109, 6411734, 6421458, 6457032, 6459820, 6490375, 6516092, 6563324, 6658145, 6690842, 6748110, 6751361, 
6771808, 6804416, 6836567, 6850646, 6856698, 6959112, 6975764, 6985625, 6993192, 7006712, 7016539, 7043081, 7058225, 7065262, 7088862, 
7164796, 7171036, 7190834, 7242801, 7251366 

The following are registered trademarks of Cognex Corporation:  

acuReader® BGAII® Check it with Checker® Checker® Cognex Vision for Industry CVC-

1000® CVL® DataMan® DisplayInspect® DVT® EasyBuilder® IDMax® In-SightIn-Sight 

2000® In-Sight® (insignia with cross-hairs) MVS-8000® OmniView® PatFind® PatFlex®  

PatInspect® PatMax®  PatQuick® SensorView® SmartLearn® SmartView® SMD4® 

UltraLight® Vision Solutions®  VisionPro® VisionView®  

The following are trademarks of Cognex Corporation:  

3D-Locate™ 3DMax™ CheckPoint™ Cognex VSoC™ FFD™ iLearn™ InspectEdge™ Legend™ LineMax™ NotchMax™ ProofRead™ SmartAdvisor™ 
SmartSync™ SmartSystem™  

Other product and company names mentioned herein are the trademarks, or registered trademarks, of their respective owners.  
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Preface 

Preface 

The 3D-Locate API extends the capabilities of VisionPro by providing a .NET API you can 

use to create 3D applications.  

Audience 
This document is written for engineers who are familiar with VisionPro software and want to 

create 3D-Locate vision applications using the VisionPro 3D-Locate API.  

Organization 
This document lists the prerequisites to using the 3D-Locate features of VisionPro. In 

addition, this document describes the VisionPro 3D-Locate Starter Kit and the sample 

application included with VisionPro.  

Conventions Used in This Guide 
This document uses the following style conventions: 

boldface  Indicates a specific component of the VisionPro 3D-Locate graphics 
user interface. 

italic Used for variables, arguments, file names, program names, book 
section names, and for emphasis. 

Courier Used for program output. 

bold courier Used in illustrations to show what you would type on a keyboard. 

<italic> When enclosed in brackets, used to indicate keyboard keys such as 
<Tab> or <Enter>. 
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Introduction 
VisionPro supports a graphical as well as a .NET programming interface that provides 

functionality for:  

 Acquiring and displaying images 

 Analyzing images with 2D vision tools 

 Linking your application to input/output lines or a TCP/IP connection to network 

hardware 

Meanwhile, the 3D-Locate API adds functionality for:  

 3D calibration for a single camera, multiple cameras, and robot (hand-eye) systems.  

 3D triangulation based on found 2D features  

 3D Model generation 

 Part Correspondence 

 3D pose estimation 

Starter Kit 
VisionPro supports an optional 3D-Locate Starter Kit with the hardware (cameras, camera 

lenses, GigE network adapter, cables, camera stand, calibration plate and sample part) 

needed to assemble a multi-camera 3D system, excluding a qualified PC. The VisionPro 

installation includes the source code for a sample application and project files that run with 

the Starter Kit hardware.  

Be aware that the 3D-Locate Starter Kit sample application will not run 
without an optional security bit not included in all VisionPro 
installations. Contact your Cognex sales engineer about using the 3D-Locate 
Starter Kit with the sample application.  

Available Documentation 
Choose Start->Cognex->VisionPro->Documentation->English for a list of available 

titles besides this document, including:  

 VisionPro Online Documentation 

The online documentation for VisionPro includes a User’s Guide, a Control Reference 

and a Programming Reference for creating VisionPro applications.  

 VisionPro 3D-Locate Developer’s Guide 

This developer’s guide provides a comprehensive overview of the three-dimensional 

vision tools that take the information from two-dimensional images and generate 

information about objects in three-dimensional space.  

 GigE Vision Cameras User’s Guide 

The Hardware subdirectory of the Documentation directory contains a user’s guide 

on configuring and using GigE Vision cameras.  

In addition, you can view any of these titles before installing VisionPro by browsing the 

\doc directory of the VisionPro installation media.  
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PC Requirements 
Refer to the VisionPro Quick Reference for a list of operating systems and compilers that 

VisionPro supports, as well as a list of minimum PC requirements.  

Be aware, however, that most 3D-Locate applications are computationally intensive, and 

for these applications Cognex recommends a PC that uses:  

 An Intel® Core™2 Quad processor or better 

 A minimum of 3GB physical memory 

In addition, your PC must have a PCI-Express slot available for a dual-port GigE network 

adapter included in the 3D-Locate Starter Kit.  

Download the latest video driver for your video card to avoid any display issues with the 

images acquired from your GigE Vision cameras. Refer to the manufacturer’s web site for 

details. 

Deploying a VisionPro 3D Application 
Cognex makes the following recommendations for deploying a VisionPro 3D application:  

 Always enable the eBus Universal Pro Driver for your GigE Vision cameras.  

 If the part you are inspecting is moving during inspection, use hardware triggered 

acquisition to ensure all cameras acquire images simultaneously.  

 You can improve the cycle of your application by modifying all the tools in all the 

CogToolBlocks so that they do not generate any graphics.  
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Hardware Installation 
The 3D-Locate Starter Kit includes the following components: 

 Tripod 

 Camera mounting plate, mounting screws, and Allen wrenches 

 Dual-port GigE network adapter 

 Cognex 10 mm calibration plate 

 Two Basler 2.0 MP cameras (acA1600-20gm) and Power over Ethernet (PoE) injectors 

 Two 9 mm camera lenses 

 4 Ethernet cables 

 Two sample parts 

Installing the hardware is optional, as the sample application supports image acquisition 

from an image-database file of the same part included in the Starter Kit.  

If you are using a PC, perform the following steps to install the hardware for the starter kit: 

1. Turn off the PC and install the dual-port GigE network adapter. 

Refer to the User’s Manual shipped with the network adapter for hardware installation 

instructions.  

If you are installing VisionPro on a laptop, use a Gigabit Ethernet ExpressCard to 

connect to a network switch, which will then connect to the cameras. The Starter Kit 

sample application supports a feature that allows you to use sequential acquisition 

with this type of setup.  

2. Attach a 9 mm lens to each camera and tighten firmly.  

3. Mount the two Basler Ace cameras on the camera mounting plate using six M3-5 

screws and the holes highlighted in the following figure:  
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4. Insert the screws from the counter-bored side of the mounting plate to attach the 

cameras, and mount the cameras vertically, pointed down: 

Adjust the vertical center column of the tripod so that it lies horizontal, as 

shown:

 

 Refer to the documentation for the tripod for instructions on how to position the 

legs of the tripod as well as adjust the height of the vertical center column. 

 Do not raise the height of the tripod by extending the legs.  

 Orient the center column so all the legs are clear of the intended field of view from 

the cameras and allow room to position the calibration plate to be used later.  

5. Remove the three screws from the head of the vertical center column.  
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The screws can be accessed from the back of the head, as highlighted in the following 

figure: 

 

6. Attach the mounting plate to the head of the vertical center column using three M6-12 

screws using the locations highlighted in the following figure: 

 

7. Connect the Basler cameras to their respective PoE (Power over Ethernet) injectors: 

 Connect one cable from the camera to the OUT port of the injector 

 Connect the other cable from the IN port of the injector to one port of the dual-

port GigE network adapter.  

8. Connect the PoE injectors to AC power.  

9. Install any security key (dongle) supplied with your 3D-Locate Starter Kit.  

The security key contains the security bit necessary to use the 3D-Locate API.  

10. Turn on the PC.  

11. Install the manufacturer’s drivers for the dual-port GigE network adapter. Refer to the 

manufacturer’s web site for details.  
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The Starter Kit 
VisionPro supports a 3D-Locate Starter Kit with the hardware needed to assemble and 

demonstrate a multi-camera 3D system. VisionPro also includes a Visual Studio solution 

containing a sample application that allows you to use the 3D system to accomplish the 

following tasks:  

 Generate a 3D calibration for your GigE Vision cameras.  

 Configure VisionPro CogToolBlocks to perform coarse location of your part under 

inspection. 

 Configure the type of 2D features you want the application to locate.  

 Generate a 3D Model of the part. 

 Locate one or more part instances across multiple cameras. 

 Use the 2D features to estimate the pose of the part. 

 Display graphics indicating the pose of the part. 

The section Hardware Installation on page 9 describes how to install and connect the 

hardware associated with the Starter Kit. You do not need to install the hardware to use 

the sample application, as the sample application included with VisionPro supports image 

acquisition from an image-database file.  

Configuring the GigE Vision Cameras 
Perform the following steps to configure the GigE Vision cameras included in the Starter 

Kit:   

1. Ensure the cameras are available by opening a command window and entering the 

following command:  

cogtool --print 

The camera type and serial numbers should appear similar to what is shown in the 

following figure: 

 

2. Close the command window.  

3. Choose Cognex->VisionPro->Utilities->GigE Vision Configuration Tool to launch 

the GigE Vision Configuration Tool.  
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The GigE Vision Configuration Tool displays a Local Area Connection for any network 

adapter used by your corporate network and a Local Area Connection for each port 

on the GigE Vision network adapter (the adapter included in the Starter Kit supports 

two ports).  

The tool associates each adapter port with its connected camera. For example, the 

following figure shows the Local Area Connections for a PC with one corporate 

network adapter and two GigE Vision ports: 

 

4. Set the IP addresses for the two network adapter ports and the two GigE Vision 

cameras.  

Refer to the Q&A on the right side of the utility for help in setting the IP addresses. In 

addition, refer to the GigE Vision Cameras User’s Guide, available from Start->All 

Programs->Cognex->VisionPro->Documentation->Hardware Manuals, for 

other steps that might be necessary for you to acquire images with the GigE Vision 

cameras. These steps can include: 

 Disabling the Windows firewall 

 Enabling jumbo frames 

 Disabling unused network clients 

Corporate network adapter 

GigE Vision adapter port 

and connected camera 
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5. Exit the GigE Vision Configuration Tool once the IP addresses for the two GigE vision 

adapter ports and the two GigE Vision cameras are set.  

6. Use VisionPro QuickBuild to verify that both GigE Vision cameras can acquire images: 

a. Choose Start->All Programs->Cognex->VisionPro-

>VisionPro (R) QuickBuild to launch VisionPro QuickBuild: 

 

b. Double-click the Image Source for CogJob1: 
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c. Click Camera, choose one of the connected GigE Vision cameras and select the 

Generic GigE Vision (Mono) format as shown: 

 

d. Click Initialize Acquisition.  

e. Click the Show Live Display icon along the top of the Image Source dialog box 

and verify that display shows live images from the GigE Vision camera.  

You do not need to adjust camera hardware settings or acquisition settings at this 

time. Close the live display when you are satisfied that the camera is acquiring live 

images.  

f. Select the other GigE Vision camera from the Image Acquisition Device/Frame 

Grabber list, and confirm that it can also acquire live images.  

g. Close all open dialog boxes and quit QuickBuild.  

You do not need to save the QuickBuild application.  

Launching the StarterKitApp 
Perform the following steps to use the StarterKitApp:  

1. Copy the StarterKit folder %VPRO_ROOT%\samples3D\Applications\StarterKit to a 

folder where you have write permission. 

2. Launch Microsoft Visual Studio 2010. 

3. Locate and open the solution StarterKit.sln installed in the directory 

<yourDirectory>\StarterKit. 

4. Set the Startup project in the solution to StarterKitGUI, change to a release 

configuration and choose Build->Build Solution to build the project.  

5. Press F5 to start the application.  
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The application automatically creates the subdirectories \Parts, \Setup and \ToolBlock 

Templates under the %HOMEDRIVE%\VisionPro3DStarterKit directory.  

The application prompts you to configure the cameras and then launches as shown in the 

following figure: 

 

Configuring the GigE Vision Cameras 

The application uses two cameras, Camera 0 and Camera 1, to capture ViewSets, which are 

multiple images of the same scene acquired simultaneously. By default, each camera is 

preconfigured with the correct settings for one of the GigE Vision cameras. Perform the 

following steps to prepare both cameras for use:  

1. Place a sample part in view of both cameras in a typical pose (position/orientation). 

2. Click Configure Cameras, select Camera 0, and enable a live display: 
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3. Adjust the settings for Exposure, Brightness and Contrast, as well as the aperture 

and focus settings for the camera lens itself, until the display shows clear images with 

consistent brightness and good contrast between the block and the background.   

Close the Configure Camera 0 dialog box when you are finished.  

4. Click Configure Cameras, select Camera 1.  

Enable a live display and use settings similar to the parameters you used for Camera 

0 until the display shows similarly suitable images of the block.  

5. If you installed VisionPro on a laptop and are using a network switch for your GigE 

Vision cameras, click Configure Cameras and enable Use Sequential Acq.  

6. Click Start Acquiring to display live images from both cameras.  

7. Make final adjustments to the aperture and focus settings on the cameras until both 

displays show clear images of the sample part against the background.  

Check the focus of the images as you move and rotate the sample part within the field 

of view.  

8. Tighten the focus set screw and the aperture set screw when you are satisfied with the 

quality of the images the cameras acquire.  

Take care not to change the current settings for the camera as you tighten the screws. 

9. Click Stop Acquiring.  

Performing a Camera Calibration 

Three-dimensional calibration is a process that establishes a mathematical relationship 

between the 2D coordinate system associated with the pixels in an acquired image and a 

3D coordinate system associated with the physical world in front of the camera. 

For any three-dimensional vision environment, 3D calibration must be performed for each 

camera, whose configuration is defined by the physical location of the camera in addition to 

the optical system used to form an image on the image sensor. Once 3D calibration has 

been performed, the camera is 3D-calibrated and has an associated 3D calibration object of 

type Cog3DCameraCalibration.  

To perform calibration, you must acquire a series of ViewSets of a Cognex calibration plate 

with the plate at different locations and orientations within your 3D environment. For more 

information about calibration, see the VisionPro 3D-Locate Developer’s Guide, available 

through the Start->Cognex->VisionPro->Documentation->English menu.  
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Perform the calibration using the following steps: 

1. Click Calibrate Cameras and select Calibrate Cameras: 

 

The minimum number of ViewSets you can use to calibrate your cameras is 5. This is 

acceptable for this sample application, but Cognex recommends you capture a total of 

9 ViewSets for best results. See the VisionPro 3D-Locate Developer’s Guide for details.  

The 3ParamRadial type for the distortion model is appropriate for most camera 

lenses. Choose SineTangentLaw if you are using camera lenses with a wide-angle or 

fish-eye lens in which the distortion effects are severe, usually occurring for lenses 

with focal lengths such as 4 mm or shorter. This option can require more time for the 

3D Calibration Wizard to generate a calibration object.  

Use the Telecentric option if you are using telecentric cameras, such as cameras with 

high-magnification lenses (such as microscope lenses) where lens 

distortion/perspective is usually miniscule. Telecentric cameras require a working 

environment where the calibration plate cannot undergo a change in translation or tilt. 

For calibration purposes, you must use appropriate hardware that allows the plate to 

undergo a change only within the Z axis. 

2. Enter a grid pitch of 10 for both the X and Y axes and click OK.  

The Cognex calibration plate supplied with the Starter Kit contains a vertex at every 

10 millimeters in the (X,Y) grid.  

If you are using a different calibration plate, then enter its Grid Pitch in millimeters. 

The StarterKitApp assumes all physical dimensions and coordinates are specified in 

millimeters.  
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The StarterKitApp displays an interface for capturing the ViewSets you will need to 

generate the 3D calibration information: 

 

The Camera Calibration dialog box displays a live image across the top and contains 

a row for each of the ViewSets it is configured to accept.  

3. Position the calibration plate under the cameras, flat on your work surface, and click 

Acquire New ViewSet for ViewSet Index 0. The position of the calibration plate in 

ViewSet index 0 defines the World3D coordinate space. See the VisionPro 3D-Locate 

Developer’s Guide for more information on coordinate spaces in VisionPro.   

Each image of the ViewSet must show the fiducial mark near the center of the 

calibration plate, as shown: 

 

4. Click Extract Features from ViewSet on the row for ViewSet Index 0.  
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The calibration method will generate calibration data from this ViewSet and indicates a 

successful result with green graphics over the ViewSet and a Status of 

Feature extraction done: 

 

If the calibration process does not generate a successful result, adjust the position of 

the calibration plate, acquire a new ViewSet, and try again.  

5. Lift one side of the calibration plate and place an object under the edge so that the 

plate is raised by approximately 50 mm, and click Acquire New ViewSet for 

ViewSet Index 1.  

This captures a tilted ViewSet. The calibration process needs at least four tilted 

ViewSets, rotated about the optical axis of the cameras, to generate accurate 

calibration information. Refer to the following figure: 

 

The plate needs to be tilted at an angle greater than 15 degrees to the cameras’ 

optical axes. 

6. Click Extract Features From ViewSet on the row for ViewSet Index 1.  

If the feature extraction does not generate a successful result, adjust the position of 

the calibration plate, acquire a new ViewSet, and try again.  

7. Rotate the calibration plate (along with whatever method you are using to tilt the 

plate) by 90 degrees (roughly), keeping the same edge lifted, and then capture and 

process a tilted ViewSet for ViewSet Index 2.  

8. Rotate the tilted plate again by 90 degrees and then capture and process a ViewSet 

for ViewSet Index 3. 

9. Rotate the tilted plate a final time by 90 degrees and capture the last tilted ViewSet 

for ViewSet Index 4.  
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With 5 ViewSets captured and processed by the StarterKitApp, the Camera 

Calibration dialog box should appear similar to the following figure: 

 

10. Click Calibrate to generate the camera calibrations the StarterKitApp will use.   
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The calibration process can take a few minutes. Upon completion, it displays the 

results in a dialog box similar to the following: 

 

11. Examine the quality of the calibration results. 

A good calibration will have overall residuals less than or equal to 0.5 pels RMS. If the 

quality of the calibration is in the Poor range, you must recalibrate.  

 Try re-acquiring your ViewSets with the calibration plate tilted more or try 

capturing ViewSets where the calibration plate is completely in the field of view of 

one of the two cameras.  

 Replace any particular ViewSet where the residuals are greater than 0.5 pels RMS. 

 Check the focus and aperture settings of the cameras to ensure you are acquiring 

well-lit and well-focused images.  

 Ensure that each ViewSet includes the fiducial mark at the center.  

 Ensure there are 0 or only a small number of checkers in saturation (intensity 

value = 255). 

 See the VisionPro 3D-Locate Developer’s Guide for more details on generating 

good camera calibrations. 

Re-calibrate until you receive calibration results in the OK range.  

12. Close the Camera Calibration Result dialog box.  
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The Starter Kit prompts you to save this camera calibration result: 

 

13. Click Yes to save and use this calibration result for your application.  

14. Close the Camera Calibration dialog box and remove the calibration plate from the 

field of view.  

Using Elevated Calibration Plate Poses 

Although the StarterKitApp can produce a valid 3D calibration object with 5 ViewSets, 

Cognex recommends you use 9 ViewSets, 4 of which use elevated calibration plate poses.  

Elevated calibration plate poses are captured by changing the height of the calibration plate 

relative to the cameras by an accurate, known amount.  

To capture elevated calibration plate poses in addition to the four tilted calibration plate 

poses, specify a greater Number of Calibration ViewSets when you click Calibrate 

Cameras, and then choose Elevated for the Pose Type, as shown: 

 

For more information about elevated calibration plate poses, see the VisionPro 3D-Locate 

Developer’s Guide, available through the  

Start->Cognex->VisionPro->Documentation->English menu.  

Locating the Sample Part 

The next step is to configure the application to perform a coarse 2D location of a sample 

part provided with your Starter Kit. As you work with the sample part throughout the 

StarterKitApp, Cognex recommends the following:  

 Provide lighting that evenly illuminates the part in both cameras with few specular 

reflections or harsh shadows.  

 Provide a background that provides good contrast against the sample part.  A black 

background works very well with the sample part. 

Perform the following steps to configure the application to locate the sample part in each 

camera image:  

1. Place a sample part in the field of view of both cameras.  

2. Click Configure 2D Part Locators and select Part Locator 0. 
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The application displays a CogToolBlock that contains the input image from Camera 0 

and a CogPMAlign tool:  

 

Refer to your VisionPro documentation for details on using a CogToolBlock.  

3. Run the CogToolBlock once to pass the image from Camera 0 to the CogPMAlign tool.  

4. Open the CogPMAlign edit control and train it to locate the sample part.  
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Refer to your VisionPro documentation for details on how to use a CogPMAlign tool edit 

control. The following shows a CogPMAlign tool configured to locate the part: 

 

The Train Params tab has been pre-configured with an Elasticity of 10. 

The Run Params tab has been pre-configured with the Angle degree of freedom for a 

range of -180 to +180 degrees and a Scale degree of freedom with a range of 0.9 to 

1.1. In addition, it has been configured to locate up to two sample parts.  

Note that a CogPMalign tool can often handle more tilt of your part by setting the 

Scale degree of freedom to 1 and the ScaleX and ScaleY degrees of freedom to a 

range of 0.9 to 1.1. 

5. Close the CogPMAlign tool edit control and the partLocator0 CogToolBlock. 

6. Click Configure 2D Part Locators again and select Copy Part Locator 0 to Part 

Locator 1.  

This copies the CogToolBlock associated with Camera 0 to the CogToolBlock associated 

with Camera 1, which allows you to skip the necessary configuration steps that allow a 

CogPMAlign tool to locate the sample parts in images acquired from Camera 1.  

You can skip the configuration of this second CogPMAlign tool because the part images 

very similar to the way it images in Camera 0.  If you ever have cameras that are 

angled inward so that the optical axes are not parallel, then you would need to 

completely configure the second CogPMAlign tool. 

7. Click Configure 2D Part Locators and choose Part Locator 1 and examine the 

CogToolBlock to confirm that it locates the sample part as expected.  

Close the CogToolBlock when you are finished.  

8. Return to the main form of the StarterKitApp and click Run 2D Part Location.  

The application should acquire live images and locate the sample part as you move it 

around the field of view, indicating that it has found the part with the CogPMAlign tool,  
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as shown in the following example: 

 

Ensure that your 2D part location works robustly over the expected pose uncertainty 

range, which is the range of positions and rotations where the sample part can appear. 

The rotation uncertainty range in this application is 360 degrees about the Z-axis and 

roughly 15 degrees about the (X,Y) axes.  The position uncertainty range in this 

application is the intersection of the field of views of the cameras. 
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9. Add a second sample part to the field of view.  

The application should consistently locate both parts over your pose uncertainty range 

as shown in the following example: 

 

10. Click Stop 2D Part Location when you have finished testing the part location feature.  

11. Choose File->Save Part and save your progress so far.  

Saving and Loading Part Files 

As you use the StarterKitApp you should choose File->Save Part to save your work. The 

StarterKitApp stores part files in the directory 

%HOMEDRIVE%\VisionPro3DStarterKit\Parts.   

Choose File->Load Part to load an existing part file, or choose File->New Part to start a 

new part file.  

Locating 2D Features for the 3D Model  

Once the application can locate the sample part from each camera in 2D space, the next 

step is to decide on a set of 3D model features and configure the StarterKitApp to locate 

the corresponding 2D features on the part from each camera.  See the VisionPro 3D-Locate 

Developer’s Guide for more information on 3D model features and 3D models.  

For our example, we will use the 5 edges (line segments) of the part as the 3D model. 
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In general, adding more features to your 3D Model allows your application to perform more 

accurate 3D pose estimations, while also allowing situations where 3D pose estimations can 

still be performed even when one or more expected 2D features cannot be located in any 

particular ViewSet. Using more features, however, can increase the time necessary to 

perform the 3D pose estimation.  

You should use at least five 3D features in your 3D model.   Most applications require five 

or more for accuracy and for robust 3D pose estimations.  

Place a single sample part in view of the cameras and click Acquire Once to capture a 

ViewSet of the part.  
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Click Configure 3D and 2D Features to specify the type of 3D model features in your 3D 

model as well as to configure the 2D feature locators.  

 

Locating the Bottom Edge of the Sample Part 

Perform the following steps to specify the 3D model feature and to locate the 2D feature 

corresponding to the bottom of the sample part, as shown in a previous figure:  

1. Choose Add->3D LineSeg from the top of the dialog box. 

The Add pull down menu includes options for 3D Point and 3D Circle, depending on 

your part.  

The dialog box displays a row of parameters whose values will vary based on 

parameters you set later: 

 

2. Enter the string “Bottom” for the 3D Model Feature Name: 
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Keep enabled both options for 3D Model Feature Flags:  

 Display this 3D feature when rendering part 

Display graphics representing this 3D feature whenever the part is rendered.  

 Use this 3D feature for pose estimation  

As you develop your application you might create a large number of 3D Model 

features and then test which ones generate the most accurate 3D pose 

estimations. This option allows you to test 3D pose estimation with or without this 

3D Model feature, rather than deleting it and re-creating it again later.  

3. Under 2D Feature Location ToolBlocks, click New ToolBlock: 

 

This opens a CogToolBlock configured with the input image passed to a CogFindLine 

tool: 

 

4. Open the CogFindLine tool edit control and configure it to locate the bottom of the 

sample part.  

Refer to your VisionPro online documentation for details on how to configure a 

CogFindLine tool through its edit control. When configuring the CogFindLine tool, the 
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endpoints of the expected line segment should be close to the actual endpoints of the 

sample part edge, as shown:  

 

Run the CogFindLine tool to verify that it returns a line segment along the bottom of 

the sample part: 

Adjust the parameters of the CogFindLine tool until the result tightly fits the edge of 

the sample part.  

5. Close the CogFindLine tool edit control.  

6. Close the CogToolBlock.  



 

VisionPro 3D-Locate Getting Started 

1/31/2013  

P a g e  | 32 

The Starter Kit 

At this point Camera 0 has a CogToolBlock to locate the bottom of the sample part, as 

reflected in the ToolBlock Status of the dialog box: 

 

The Configure 3D Model Features and 2D Feature Location ToolBlocks dialog 

box provides a quick way of copying the configured CogToolBlock for Camera 0 to  

Camera 1. 

7. Under 2D Feature Location ToolBlocks, click Copy Camera 0 ToolBlock to this 

ToolBlock: 

 

This makes a copy of the CogToolBlock used to locate the edge feature in Camera 0 to 

Camera 1, allowing the same CogFindLine tool parameters to find the bottom of the 

sample part in the image from Camera 1. The copied CogToolBlock (CogToolBlock for 

Camera 1) will automatically appear in a CogToolBlock edit control. 

8. Confirm that the CogToolBlock for Camera 1 finds the edge at the bottom of the 

sample part.  

9. Close the CogToolBlock for Camera 1.  

At this point, the dialog box reflects a complete 3D feature:  

 

Before you can generate a 3D Model, you must add the other four 3D features 

corresponding to the remaining edges of the sample part.  

Finding Remaining Edges 

Use the same procedure outlined in the previous section (Locating the Bottom Edge of the 

Sample Part starting on page 29) to find the Left, Right, Top Left and Top Right edges of 

the sample part. In general, creating a new 3D feature involves:  
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 Adding a new entry for a 3D Point, 3D LineSeg, or 3D Circle using the Add menu.  

 Giving the 3D feature a name using the 3D Model Feature Name property 

 Defining a CogToolBlock for Camera 0 to locate the 2D feature corresponding to the 

3D feature you are adding 

 Copying the settings of the CogToolBlock for Camera 0 to the CogToolBlock for 

Camera 1 

The following figure shows the Configure 3D Model Features and 2D Feature Location 

ToolBlocks dialog box after all five 3D features have been configured for this sample part: 

 

3D Model Feature Parameters 

During 3D model feature generation, performed in the next step, the parameters (e.g. the 

3D endpoints for a 3D lineSeg) for each 3D model feature are computed.  You can disable 

the computation of the parameters for the currently selected 3D model feature by clearing 

the checkbox for 3D Model Feature Parameters. 

You should clear the checkbox for 3D Model Feature Parameters if you want to manually 

enter the 3D model feature parameters in Model3D space. This can be suitable for parts 

where the parameters of 3D model features are known or easily measured.  
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For example, the following figure shows a spacer block made to precise measurements, 

and the same spacer block resting at the origin of Model3D space:  

 

If the spacer block is known to be 25 mm in height, 50 mm in width and 75 mm in length, 

you can enter the parameters of the 3D model features manually after clearing the 

checkbox for 3D Model Feature Parameters. For example, you could create 3D Point 

features for the four corners along the top of the block and manually enter the Model3D 

coordinates for each point. The following figure highlights a point and the X, Y, Z 

coordinates for it: 

 

3D Line Segments and 3D Circles can be manually configured in a similar manner.  

Using 3D Points and 3D Circles 

In addition to 3D LineSeg features, the Configure 3D Model Features and 2D Feature 

Location ToolBlocks dialog box allows you to also choose 3D Points and 3D Circles.  

If you use 3D Circles, the associated CogToolBlock uses a CogFindCircle tool to locate the 

circular 2D feature.  

If you use 3D Points, creating a new CogToolBlock allows you to choose between the 

following 2D feature locators to generate a point: 

 PMAlign: A CogPMAlign tool.  Note that the Search Region for this PMAlign tool should 

be sized about 50% larger than the PMAlign model and centered on the PMAlign 

model.  (There is no need to search the entire image for the 2D feature being located 

by the PMAlign tool since the PMAlign tool runs in a fixtured space based on the 2D 

part location) 

 IntersectLineLine: An intersection point found by running two CogFindLine tools and 

passing their results to a CogIntersectLineLine tool 
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 Blank: An empty CogToolBlock to define your own vision solution to locating a 2D 

point feature on the sample part.   You must ensure the CogToolBlock has the 

following output terminals (just like the PMAlign CogToolBlock): 

 Point0_X  (type must be Double) 

 Point0_Y  (type must be Double) 

 Valid  (type must be Boolean) 

Locating the 2D Features 
Confirm the application can reliably locate all the 2D features: 

1. Close the Configure 3D Model Features and 2D Feature Location ToolBlocks 

dialog box and return to the main form of the StarterKitApp.  

2. Click Run 2D Feature Location. 

The application begins acquiring ViewSets continually and running all the 2D feature 

locators.  

3. Move the sample part in the field of view.  

The application should locate the sample part using the PMAlign tool configured in 2D 

Part Location, and then locate the desired 2D features on the part using the configured 

2D feature locators.  

The following figure shows the display window for Camera 0 where the five line 

segments have been located on the sample part:  

 

4. Try moving the sample part around the field of view and changing its angle with 

respect to the cameras.  

5. Add a second sample part to the field of view and confirm that the application reliably 

locates both.  

6. Click Stop 2D Feature Location.   If you are satisfied that the StarterKitApp reliably 

locates the sample parts and their 2D features, go on to the next step.  If you are not 

satisfied, then reconfigure your 3D model features and 2D feature locators.   
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7. Choose File->Save Part to save your progress.  

Creating the 3D Model 
Click Generate 3D Model Features and select Best Practices For 3D Model Feature 

Generation to review a list of best practices recommended by Cognex for creating a 3D 

Model. The procedure outlined in this document uses those best practices, which includes 

generating an image-database of five ViewSets, each with a different Pose.  

Creating an Image-Database for 3D Model Generation 

Perform the following steps to create the image-database (IDB) file:  

1. Choose File->Save Part to save the current part file.  

2. Choose IDB->Enable IDB Recording->Record User Specified ViewSets. 

3. Enter a name for the IDB recording and click OK: 

 

4. Click Start Acquiring. 

5. Place the sample part in the field of view with no rotation, near the origin of Phys3D 

space.  The Phys3D space is indicated by the purple coordinate frame that appears 

when running the 2D feature locators. 

See the VisionPro 3D-Locate Developer’s Guide for more information on the coordinate 

spaces generated by 3D calibration.  

6. Choose IDB->Record Currently Displayed ViewSet to add Pose 0 to the IDB file.  

7. Move the sample part to the upper-left corner of the field of view and rotate the part 

about 20 degrees about the Z axis as compared to the rotation in Pose 0. Then, 

choose IDB->Record Currently Displayed ViewSet to add Pose 1 to the IDB file.  

8. Move the sample part to the upper-right corner of the field of view and rotate the part 

about 45 degrees about the Z axis as compared to the rotation in Pose 0. Then, 

choose IDB->Record Currently Displayed ViewSet to add Pose 2 to the IDB file.  
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9. Move the sample part to the lower-right corner of the field of view and rotate the part 

about ~67 degrees about the Z axis as compared to the rotation in Pose 0. Then, 

choose IDB->Record Currently Displayed ViewSet to add Pose 3 to the IDB file.  

10. Move the sample part to the lower-left corner of the field of view and rotate the part 

about 90 degrees about the Z axis as compared to the rotation in Pose 0. Then, 

choose IDB->Record Currently Displayed ViewSet to add Pose 4 to the IDB file.  

11. Choose IDB->Disable IDB Recording to stop recording ViewSets.  

Verify that you have captured all five Poses by viewing the images in the IDB file:  

1. Choose IDB->Enable IDB Playback and select the IDB file you just created. 

2. Click Acquire Once repeatedly to cycle through the images in the IDB file.  

3. Choose IDB->Disable IDB Playback after you have confirmed that the IDB file 

contains the five Poses for 3D Model generation.  

If you did not capture all five Poses, overwrite or capture a new IDB file using the 

procedure outlined previously.  

Running the 3D Model Feature Generator 

Perform the following steps to create the 3D Model:  

1. Click Generate 3D Model Features and choose Generate 3D Model Features 

From IDB.  

2. Select the IDB file containing the five ViewSets and click OK: 

 

The StarterKitApp generates a 3D Model using the ViewSets stored in the image 

database and displays a set of 3D Model Feature Generation Results, as shown:  
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3. Examine the results.  

In general, Raw2D residuals should be less than or equal to 1.5 pels RMS.  If you have 

a feature or features with residuals greater than 1.5 pels RMS, it may be an indication 

that there is a problem with the feature’s 2D part locator(s).  Investigate this by 

enabling IDB playback of the image-database you created and running the 2D feature 

locators for each ViewSet where a high residual occurred. 

4. Close the results display.  

The application prompts you to update the part file with this 3D Model.  

5. Choose File->Save Part to save your progress.  

Perform a 3D Pose Estimation  
With the 3D Model generated, you can perform 3D pose estimation on any ViewSet after 

configuring the 3D pose estimator.  
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Click Configure Pose Estimator to choose a pose estimation strategy: 

 

The StarterKitApp offers two pose estimation strategies:  

 Use all the 2D to 3D feature correspondence Cog3DCrsp2D3D objects.  

The StarterKitApp creates a set of Cog3DCrsp2D3D objects based on the 2D feature 

locators you used to find the five edges of the sample part.  

See the VisionPro 3D-Locate Developer’s Guide for a description of how your 

application must generate Cog3DCrsp2D3D objects.  

 Use only the inlier Cog3DCrsp2D3D objects that meet a set of robust pose estimation 

criteria. This strategy removes the Cog3DCrsp2D3D objects that are considered to be 

outliers based on the Robust Pose Estimation Parameters. 

Select a strategy and close the dialog box. Click Run or Run Once to perform 3D pose 

estimation on the sample part currently in the field of view. The display window for Camera 
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0 includes 3D pose result information, as shown in the following example: 

 

Test your completed configuration by moving your part around the field of view and tilting 

it.  If you find a problem, record an image-database of the part in the problem pose. Then, 

starting with 2D part location, determine the source of the problem and correct. 

Place a second sample part in the field of view and enable the Corresponder Diags option 

at the bottom of the interface. When you click Run Once or Run, the StarterKitApp 

performs a 3D pose for both parts and labels the individual sample parts across the 

ViewSet, as shown: 

 

The StarterKitApp includes a set of options for graphics you can display over each sample 

part after 3D pose estimation:  

 Part Location Diags: Display a graphic indicating where the sample part was found 

 2D Feature Location Diags: Display graphics indicating all the found 2D features 

over each image. 

 Crsp2D3Ds: Display graphics representing the 2D features in the Cog3DCrsp2D3D 

objects used for 3D pose estimation. 

 Corresponder Diags: Display the part instance index over each part in the ViewSet.  
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 Pose Est. Diags: Display mapped model features using different colors: green for 

good matching features (inliers), red for outliers, and dark red for 3D features not 

being used for 3D pose estimation. 

 Final Pose: Display the pose graphics for each part in each image.  Green indicates 

parts with residuals less than 2.0 pels RMS.  Yellow indicates parts with residuals 

between 2.0 and 5.0 pels RMS.  Orange indicates parts with residuals greater than 5.0 

pels RMS. 

Loading a Complete Part File 
Your VisionPro installation includes a complete part file for the sample part. To load and 

examine the file, perform the following steps:  

1. Launch the StarterKitApp. 

2. Choose File->Load Part. 

3. Choose CognexPivotPlate from the Load Part dialog box.  

The CognexPivotPlate part file includes three IDBs of the sample part: 

 3DModelFeatureGeneration: Five ViewSets for creating a 3D Model 

 MultipleParts: ViewSets with multiple part instances in the field of view 

 OnePart: ViewSets with a single part instance in the field of view 

4. Choose IDB->Enable IDB Playback and select an IDB file.   

With IDB playback, any ViewSet acquisition occurs from the IDB and not from any 

connected cameras.  

5. Run the 3D Pose estimation on any IDB. The following figure shows the StarterKitApp 

using the images in the MultipleParts IDB, generating a 3D pose for each of the five 
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instances of the sample part: 

 

 

 

 

 

 



 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 


