OCVMax コントロールリファレンス

メインページ

このページは、OCVMax コントロールリファレンスのメインページです。

完全なオンラインドキュメンテーションについては、VisionPro .NET マニュアルコレクション英語版を参照してください。

日本語オンラインマニュアルについて

このオンラインマニュアルは、日本における多くのユーザが、コグネックスの製品を使用するにあたって役立つように企画されたものです。

技術的に正確な訳となるよう努力いたしておりますが、原本とのバージョンの違いやリリース時期に完全には対応していない場合もありますので、この日本語オンラインマニュアルは参考資料としてご使用ください。

このオンラインマニュアルでは、グラフィカルユーザインタフェースを英語版のままで説明しております。

内容に疑問が生じた場合は、英語の原本のオンラインマニュアルも併せてご参照ください。

不明な点については、弊社テクニカルサポートまでご連絡ください。

テクニカルサポートの連絡先は次のとおりです。

コグネックス株式会社

〒113-6591

東京都文京区本駒込 2-28-8 文京グリーンコート 23 階

サポートホットライン: 03-5977-5410 (月～金: 9:00 ～ 17:30)

E-mail: support.jp@cognex.com

© 2005 Cognex Corporation.All rights reserved.


OCV ツールエディットコントロール

OCV ツールエディットコントロールは、CogOCVTool ツールへのグラフィカルユーザインタフェースを提供します。このツールは、取り込まれた画像内に、英数字文字列、ロゴ、またはそのほかのシンボルが存在することを確認するために使用します。このエディットコントロールを使用すると、個別のフォントモデルを作成して、検査中の対象物上に出現する可能性のあるフォントモデルのフォントを構築し、検証する文字列を定義して、文字列中での各フォントモデル相互間の予想される位置を定義することができます。次の図に、OCV ツールエディットコントロールを示します。

このエディットコントロールは、次の機能を提供します。

  • 一般的な操作の大半は、左上にあるコントロールボタンを使用します。
  • 一連の機能タブでは、フォントを定義し、文字パターンを登録し、表示グラフィックスを選択し、結果を表示することができます。
  • 画像ディスプレイウィンドウには、取り込まれた画像と、OCV ツールの結果をグラフィックスで表したものが表示されます。

VisionPro QuickStart ソフトウェアを使用して、CogOCV ツールを作成し、エディットコントロールを試してみることができます。新しい CogOCV ツールは、次の図に示す入力ターミナルとともに表示されます。

このエディットコントロールをカスタムビジョンアプリケーションに組み込むには、最初に、このコントロールを Visual Studio.NET 開発環境に追加する必要があります。詳細については、「コントロールの追加」を参照してください。

コントロールボタン

次の表に、各ボタンの機能に関する説明をまとめます。

表1. コントロールボタン
ボタン 説明 機能

実行

Current.InputImage バッファに格納された画像を、登録された文字パターンを使用してサーチします。

エレクトリックモード

エレクトリックモードを切り替えます。エレクトリックモードでは、特定のコンフィグレーションパラメータが変更されたときに OCV ツールが自動的に画像を解析します。エレクトリックモードでは、各エレクトリックプロパティの隣に稲妻アイコンが表示されます。

ローカル画像ディスプレイ

ローカル画像ディスプレイウィンドウを開いたり閉じたりします。OCV ツールは、次の画像バッファをサポートします。

  • Current.InputImage バッファは、現在の画像と、文字パターングラフィックスを保持します。
  • Current.PatternReferenceImage バッファは、パターン原点を設定するためのグラフィックス、およびユーザが作成する必要があるフォントモデルとともに、基準画像を保持します。
  • LastRun.InputImage バッファは、OCV ツールが文字パターンについて画像をサーチした後の結果を保持します。

フローティング画像ディスプレイ

1 つ以上のフローティング画像ウィンドウを開きます。このウィンドウは、ローカル画像ディスプレイと同じ画像バッファをサポートします。

開く

OCV ツールのために保存されている一連のプロパティを含む VisionPro パーシスタンス (.vpp) ファイルを開きます。ほかのオブジェクトタイプの .vpp ファイルを開こうとすると、VisionPro はエラーを報告します。

上書き保存

このビジョンツールの現在のプロパティを、VisionPro パーシスタンス (.vpp) ファイルに上書き保存します。[Save] ダイアログボックスでは、ビジョンツールを保存するときに画像バッファとツール結果も一緒に保存するかどうかを選択することができます。

名前を付けて保存

このビジョンツールの現在のプロパティを、新しい VisionPro パーシスタンス (.vpp) ファイルに保存します。

リセット

OCV ツールをデフォルトの状態にリセットします。これによって、OCV ツールは次を削除します。

  • OCV ツールのすべての画像バッファに保持されているすべての画像
  • 現在のフォント
  • すべての登録パターン

現在、存在はしているが、現在のフォントにはまだ追加されていないフォントモデルは、OCV ツールをリセットしても削除されません。同様に、まだフォントに追加されていない、ブランクのフォントモデルに関する情報も、リセットの後にそのまま残ります。

フローティング結果

[Results] タブに表示されるのと同じ内容を含む、別の結果ウィンドウを開きます。

Font Editor

Font Editor を開きます。Font Editor は、フォントモデルを作成し、検査する対象物上に現れる可能性がある文字のフォントを構築するために使用します。フォントモデルの使用の詳細については、「Font Editor の使用方法」を参照してください。

新しいフォント

現在のフォントを破棄して、ブランクのフォントで開始します。すべての変更を破棄しようとしていることが、ダイアログボックスによって警告されます。フォントモデルの作成の詳細については、「Font Editor の使用方法」を参照してください。

既存のフォントをロード

既存のフォントを、.vpp または .ocf ファイルからロードします。ロードされたら、[Font] タブに新しいフォントが表示されます。

フォントを上書き保存

現在のフォントを、最後に指定したフォントファイルに保存します。そのフォントがまだ保存されていない場合は、[Save As] ダイアログボックスが表示されます。

名前を付けてフォントを保存

現在のフォントを、VisionPro (.vpp) または CVL (.ocf) フォーマットのいずれかの新しいファイルに保存します。

フォントをコンパイル

現在のフォントをコンパイルして、フォントモデル、文字インスタンス、およびコンフュージョン得点を論理的なコレクションにマージします。この論理的なコレクションを使用することによって、連続する実行時画像内に、ツールがサーチする文字パターンを指定できるようになります。フォントモデルの作成の詳細については、「Font Editor の使用方法」を参照してください。

パターンを CVL アーカイブにエクスポート

現在の文字パターンを、CVL (Cognex Vision Library) 形式で保存することによって、CVL アプリケーションで使用できるようにします。

ツールヒントの表示

このエディットコントロールにある個々の項目に関するツールヒントを表示または非表示にします。

ヘルプ

この VisionPro オンラインヘルプファイルを開きます。

[Font] タブ

[Font] タブは、現在のフォントのフォントモデルを表示するために使用します。フォントを構築するには、Font Editor を使用します。次の図に示す [Font] タブには、9 つの個別の文字フォントが表示されています (そのうちの 3 つには、第 2 の文字インスタンスがあります)。

[Font] タブは、フォントの各フォントモデルに関する次の情報を提供します。

表2. フォント情報
フィールド | 説明
[Font Description] | Font Editor の [Font Description] フィールドにユーザが入力したフォントの説明が表示されます。フォントの説明を入力していない場合、このフィールドには何も表示されません。
[Font Models] | このフレームには、現在のフォントで定義された最初の 14 の文字モデルのための、14 のサムネール領域が含まれています。14 よりも多くのフォントモデルがフォントに含まれる場合は、フレームの横にあるスクロールバーを使用すると、全体をスクロールできます。現在選択されているフォントモデルは、タブの下半分にある大きな画像に表示されます。この大きな画像には、モデル原点および定義済みのマスクも表示されます。
[Name] | このフォントモデルの名前は、フォントモデルの作成時に定義します。通常は、その文字の名前か、または「ロゴ」などの名前 (モデルがグラフィックスを定義する場合) を、フォントモデルに与えます。
[Instance] | 同じ名前を持つ複数のフォントモデルには、インスタンス番号が与えられます。OCV ツールは、各文字インスタンスに、インデックス 0 から開始される番号を自動的に付けますが、アプリケーションに対して必要な場合には、異なる開始インデックスをユーザが選択することもできます。
[Model Type] | ユーザが作成する各フォントモデルは、ノーマルなフォントモデルまたはブランクのフォントモデルである必要があります。
[Width] | このツールは、フォントモデルの幅をピクセル単位で格納します。
[Height] | このツールは、フォントモデルの高さをピクセル単位で格納します。

[Pattern Characters] タブ

[Pattern Characters] タブは、OCV ツールがサーチする文字のパターンを定義します。次の図に、[Pattern Characters] タブの例を示します。

[Train]

基準画像に各フォントモデルの予想される位置が示され、ユーザがパターン原点を望ましい位置 (できれば最初の文字の近く、または最初の文字のフォントモデル原点の上) に配置したら、[Train] ボタンを使用します。パターンを登録すると、現在のフォントと文字パターンが、各フォントモデルの予想される位置およびパターン原点とともにグループ化されます。文字パターンのサイズ、およびユーザが提供した [Default Uncertainties] によっては、パターンの登録に数秒かかる場合があります。パターンが登録されたら、OCV エディットコントロールの下部に、「Pattern Trained」というメッセージが表示されます。詳細については、「文字列パターンの登録方法」を参照してください。登録パターンの特徴を変更すると、パターンは登録解除されます。

[Grab Reference Image]

[Grab Reference Image] ボタンは、Current.InputImage バッファに現在格納されている画像を、Current.PatternReferenceImage バッファにコピーするために使用します。フォントがロードされ、ユーザが文字パターンを入力したら、ユーザは基準画像を使用して、各フォントモデル相互間についての予想される位置を正確に検出し、さらに、取り込まれた各画像内でのパターン全体の位置関係を報告するためにツールによって使用されるパターン原点を配置します。

Current.PatternReferenceImage バッファは、文字列パターン内で、各フォントモデル相互間の予想される位置を視覚的に配置する方法を提供するためにのみ存在します。取り込まれた各画像上における文字列の予想される位置を指定するために存在するためのものではありません。Current.InputImage バッファは、取り込まれた各画像についての文字列パターンの予想される位置を設定するために使用します。詳細については、「文字列パターンの登録方法」を参照してください。

[Show/Hide Advanced Items] ボタン

[Show/Hide Advanced Items] ボタンは、1 つ以上の文字位置に対して複数のフォントモデルを指定できる設定項目を有効にするために使用します。これらの設定項目を使用する必要があるのは、文字列中の 1 つ以上の文字が変化可能な文字列 (例えば「A123」や「B123」など) を OCV ツールに検証させる場合です。この例では、文字列の最初の文字は「A」または「B」のいずれかであることが可能です。

高度な項目が有効にされると、[Pattern Characters] タブは次の図に示すように表示されます。

単純な文字列および高度な文字列の両方を定義する方法の詳細については、「文字列パターンの登録方法」を参照してください。

[Verification Characters]

左側のテキストボックスは、ツールが検証するように設定された現在の文字列パターンを示します。「A0221」などの単純な文字列の場合、テキストボックスには、次の図に示すように表示されます。

高度な文字列を設定した場合、エディットコントロールは「*」を使用して、文字列中のどの文字が変化可能かを示します。例えば、次の図は、最初の文字が変化可能な文字列を示します。

[Edit and Layout]

文字列中のどの文字もフォントモデル間で変化することができない、単純な文字列パターンを作成するには、[Edit and Layout] ボタンをクリックします。単純な文字列を定義する方法の詳細については、「文字列パターンの登録方法」を参照してください。

文字位置の設定

[Default Uncertainties] フィールドは、次の不確定度パラメータを設定するために使用します。

表3. [Default Uncertainties]
パラメータ | 説明
[Translation] | 任意文字の移動において、画像間での変化の予想される範囲を、Selected Space Name の単位で入力します。
[Scale] | 任意文字の全体的な倍率において、画像間での変化の予想される範囲を入力します。
[Rotation] | パターン原点を基準にした任意文字の全体的な回転についての、画像間での変化の予想される範囲をラジアン単位または度単位で入力します。

[Default Thresholds] フィールドは、次のしきい値を設定するために使用します。

表4. [Default Thresholds]
しきい値 | 説明
[Accept] | 各文字位置に適用するアクセプトしきい値を入力します。
[Confidence] | 各文字位置に適用する信頼性しきい値を入力します。

[Advanced Parameters] ボタンは、個々の文字に対してさまざまなしきい値、不確定度、および位置の値を指定するために使用します。例えば、次の図に示す [Advanced Character Position Settings] ダイアログボックスでは、フォントモデル「A」に対するアクセプトしきい値が、ほかのフォントモデルに対するデフォルトのアクセプトしきい値よりも高い値に設定されています。

グレー表示されたフィールドは、デフォルト値を使用します。グレー表示された値を変更することも可能ですが、適切なチェックボックスを有効にするまで、それらの値は有効になりません。

高度な項目

上部にあるフォントモデルテキストボックスには、文字列パターン内で現在設定されている現在のフォントモデルが表示されます (存在する場合)。例えば、次の図は、文字列パターンが「A02211」 (これは実際には単純な文字列パターンです) の場合のタブの表示を示します。

特定の文字が複数の文字インスタンスによって定義されることを示すには、次の図のように、ボックスに矢印が使用されます。

最後に、文字列中の特定の文字が、異なる文字間で変化可能な場合は、次の図のように、その文字のボックスに「*」が使用されます。

高度な文字列の作成の詳細については、「文字列パターンの登録方法」を参照してください。

[Origin / Run Params] タブ

[Origin / Run Params] タブは、パターン原点の正確な位置、および各実行時画像内でのパターンの予想される位置を設定するために使用します。次の図に、[Origin / Run Params] タブの例を示します。

[Train] ボタン

基準画像に、各フォントモデルの正確な位置が、パターン原点の望ましい位置とともに示されたら、[Train] ボタンを使用します。パターンを登録すると、現在のフォントと文字パターンが、各フォントモデルの予想される位置およびパターン原点とともにグループ化されます。文字パターンのサイズ、およびユーザが提供した不確定度の値によっては、パターンの登録に数秒かかる場合があります。パターンが登録されたら、OCV エディットコントロールの下部に、「Pattern Trained」というメッセージが表示されます。詳細については、「文字列パターンの登録方法」を参照してください。登録パターンの特徴を変更すると、パターンは登録解除されます。

[Pattern Origin]

サーチする文字を基準にして、パターン原点の位置を設定する最も簡単な方法は、基準画像上のグラフィックスを使用することです。このタブの [Pattern Origin] 領域は、パターン原点のさまざまなパラメータを、そのデフォルトの (x, y) 座標に加えて明示的に設定するために使用します。最適な結果を得るために、Cognex では、パターンにおける最初の文字の原点または中心に、パターン原点を定義することを推奨します。パターン原点を文字列パターンから離れたところに配置すると、パターンが回転した場合にエラーが発生することがあります。また、文字列が発生する可能性がある画像の領域を正確に検出するために、PMAlign ツールと Fixture ツールの組み合わせに依存する必要がある場合があります。

次の表は、ユーザが変更できるパラメータを示しています。

表 5. [Pattern Origin] のパラメータ
パラメータ | 説明
[Selected Name Space] | 予想されるパターン原点を定義するために、入力画像座標空間ツリーのどの空間をツールが使用するかを指定します。
[Translation X] および [Translation Y] | パターン原点に関して、予想される (x, y) 座標を指定します。
[Scaling] | 基準画像のスケールが、アプリケーションのために取り込む画像と一致しないことがわかっている場合に、異なる倍率を指定します。
[Aspect ratio] | カメラが取り込むピクセルが正方形でない場合に、異なるアスペクト比を指定します。
[Rotation] | パターン原点の回転についての正確な計測値を指定します。
[Skew] | 取り込まれた画像が矩形を平行四辺形に歪ませる可能性がある場合は、0 以外の値を使用します。

[Timeout] パラメータ

[RunTimeTimeout] パラメータを有効にして、OCV 検査の実行のために許容される最大実行時間を、ミリ秒単位で入力します。タイムアウト時間の終わりまでにツールが終了していない場合、ツールはエラーを返します。

[Runtime Position] パラメータ

[Runtime Position] パラメータは、登録したパターンが入力画像にどのように関係するか、およびそのパターンをサーチする範囲を指定するために使用します。次の表は、ユーザが変更できるパラメータを示しています。

表 6. パターンの位置
パラメータ | 説明
[Selected Space Name] | パターンの予想される位置を定義するために、入力画像座標空間ツリーのどの空間をツールが使用するかを指定します。
[Translation X] および [Translation Y] | パターン全体に関して、予想される (x, y) 座標を指定します。
[Scaling] | 基準画像のスケールが、アプリケーションのために取り込む画像と一致しないことがわかっている場合に、異なる倍率を指定します。
[Aspect ratio] | カメラが取り込むピクセルが正方形でない場合に、異なるアスペクト比を指定します。
[Rotation] | パターン原点の回転についての正確な計測値を指定します。
[Skew] | 取り込まれた画像が矩形を平行四辺形に歪ませる可能性がある場合は、0 以外の値を使用します。

[Uncertainties] フィールドは、パターン全体に対する次の不確定度パラメータを設定するために使用します。

表7. [Default Uncertainties]
パラメータ | 説明
[Translation] | パターンの移動において、画像間での変化の予想される範囲を、選択空間名の単位で入力します。
[Scale] | パターンの全体的な倍率において、画像間での変化の予想される範囲を入力します。
[Rotation] | 入力画像の選択空間名を基準にしたパターンの全体的な回転についての、画像間での変化の予想される範囲を、ラジアン単位または度単位で入力します。

[Graphics] タブ

[Graphics] タブは、任意の画像バッファ上に、どのグラフィックスが表示されるかを選択するために使用します。次の図に、[Graphics] タブを示します。

[Results] タブ

[Results] タブは、OCV ツールが検証文字列について Current.InputImage をサーチした後の結果を表示します。次の図に、正常に実行された後の [Results] タブの例を示します。

[Results] タブには、次の情報が示されます。

表8. [Result] タブ
結果 | 説明
[Pattern Status] | この OCV 検査の全体的なステータス (「Verified」または「Failed」) を表示します。
[Pattern Score] | この OCV 結果の総合得点を表示します。これは、パターン内にある文字すべての得点の平均です。得点の範囲は 0.0 (一致しない) ～ 1.0 (完全一致) です。
[Found Pattern Position] | OCV ツールがパターンを検出した場所に関する情報と、選択空間名を基準にしたスケール、アスペクト比、回転、およびスキューの変化が表示されます。
[Character Results] | 検証文字列中の個別の各文字に関する結果情報の一覧表を表示します。位置の値は、検出されたパターンを基準にした各文字の結果です。これによって、実際の検出位置を、パターンの登録時に指定した値と比較することが容易になる場合があります。

© 2005 Cognex Corporation.All rights reserved.


OCVMax ツールエディットコントロール

OCVMax ツールエディットコントロールは、CogOCVMaxTool ツールへのグラフィカルユーザインタフェースを提供します。このツールは、画像内の 1 つ以上の文字列が、各位置において予想される文字を含んでいることを確認するために使用します。ビジョンアプリケーションは、通常、OCV を使用して、製品またはパッケージに印刷された製造ロット番号、製造日、有効期限、およびそのほかの情報を検査します。

OCVMax ツールエディットコントロールにより、ユーザは、フォントファイルの選択、検証する文字列の指定、およびさまざまな画像サーチパラメータの変更が可能になるため、取り込まれた各画像内にある文字列全体と、文字列中にある個別の文字の両方を正しく検出できます。次の図に、OCVMax ツールエディットコントロールを示します。

このエディットコントロールは、次の機能を提供します。

  • コントロールの上部にある一連のコントロールボタン。
  • 適切なフォントを選択し、文字列を指定し、サーチパラメータを変更し、結果を表示するための一連の機能タブ。
  • 取り込まれた画像と、OCVMax ツールの結果をグラフィックスで表したものを表示するための画像ディスプレイウィンドウ。

VisionPro QuickStart または QuickBuild ソフトウェアを使用して、CogOCVMax ツールを作成し、エディットコントロールを試してみることができます。次の図に示すように、新しい CogOCVMax ツールは、InputImage 用の入力ターミナルと、配置内にあるすべての文字位置が検証されたかどうかに加えて、文字列の総合検証得点も示す、結果用の出力ターミナルとともに表示されます。

このエディットコントロールをカスタムビジョンアプリケーションに組み込むには、最初に、このコントロールを Visual Studio.NET 開発環境に追加する必要があります。詳細については、「コントロールの追加」を参照してください。

コントロールボタン

表1. OCVMax エディットコントロールのコントロールボタン
ボタン 説明 機能

実行

Current.InputImage を、設定された文字列についてサーチし、その文字列に含まれる文字の OCVMax 検証を実行します。

ローカル画像ディスプレイ

ローカル画像ディスプレイウィンドウを開いたり閉じたりします。OCVMax ツールは、次の画像バッファをサポートします。

  • Current.InputImage バッファは、OCVMax ツールが解析する文字列を含む、次の画像を保持します。この画像には、ユーザが有効にする検証グラフィックスも含まれます (グラフィックスがある場合)。
  • LastRun.InputImage バッファは、OCVMax ツールを使用して解析された最後の画像を含みます。

フローティング画像ディスプレイ

1 つ以上のフローティング画像ウィンドウを開きます。このウィンドウは、ローカル画像ディスプレイウィンドウと同じ画像バッファをサポートします。

開く

このビジョンツールオブジェクトタイプのために保存されている一連のプロパティを含む VisionPro パーシスタンス (.vpp) ファイルを開きます。ほかのオブジェクトタイプの .vpp ファイルを開こうとすると、VisionPro はエラーを報告します。

上書き保存

このビジョンツールの現在のプロパティを、VisionPro パーシスタンス (.vpp) ファイルに上書き保存します。このエディットコントロールでは、ビジョンツールを保存するときに画像バッファとツール結果も一緒に保存するかどうかを選択することができます。

名前を付けて保存

このビジョンツールの現在のプロパティを、新しい VisionPro パーシスタンス (.vpp) ファイルに保存します。

リセット

ビジョンツールをデフォルトの状態にリセットします。

このツールでは、Visual Studio.NET アプリケーションでの使用に適したデフォルト構築状態にリセットするか、QuickStart アプリケーションに適したテンプレート初期化状態にリセットするかを選択することができます。

フローティング結果の表示

[Results] タブに表示されるのと同じ内容を含む、別の結果ウィンドウを開きます。

ツールヒントの表示

このエディットコントロールにある個々の項目に関するツールヒントを表示または非表示にします。

ヘルプ

この VisionPro オンラインヘルプファイルを開きます。

[Font] タブ

[Font] タブは、検証する文字列で使用されるフォントを選択するために使用します。次の図に、デフォルトの [Font] タブを示します。

次の設定項目を使用して、文字列のための正しいフォントを選択します。

表2. [Font] タブ
設定項目 説明

[Selected Font File]

[Browse] をクリックして、1 つのフォントまたは複数のフォントを含むファイルの選択を可能にするダイアログボックスを開きます。/WINDOWS/Fonts ディレクトリからはフォントを選択できないことに注意してください。このディレクトリからのフォントファイルが必要な場合は、最初に、ほかの任意のディレクトリにそのフォントファイルをコピーして、そのディレクトリから選択してください。

[Selected Font]

複数のフォントを含むフォントファイルを選択した場合に、使用する特定のフォントファイルを選びます。選択したフォントファイルがフォントを 1 つだけ含む場合、このフィールドには「Single Font File」と表示されます。

[Selected Alphabet]

エディットコントロールは、フォント内の各文字キーを表示します。検証する文字列中に現れる可能性がある文字キーを有効にしてください。文字列中に現れる可能性がある文字のみにキーのセットを制限することによって、ツールは、関係のない文字と検証する文字を比較する必要がなくなります。これにより、紛らわしさが発生する可能性が減り、ツールの全体的な性能が向上します。

特定の文字キーのグループをすべて一度に選択するには、次のボタンを使用します。

  • [Upper]:すべての大文字のアルファベット
  • [Lower]:すべての小文字のアルファベット
  • [Numbers]:すべての数字
  • [All]:フォント内のすべての文字キー
  • [Clear]:フォント内のすべての文字キーを選択解除

句読記号は個別に有効にする必要があります。

[Polarity]

文字列中の文字が、明るい背景上の暗い文字か、暗い背景上の明るい文字かを選択します。

[Tune After Train]

検証する文字列を使用してツールが登録された後で、チューニング処理を実行します。

[Train]

利用する文字列を使用して OCVMax ツールを登録します。ツールを登録する前に、[Text] タブで文字列を指定する必要があります。

[Text] タブ

[Text] タブは、検証する文字列を指定するために使用します。次の図に、デフォルトの [Text] タブを示します。

表 3. [Text] タブ
設定項目 説明

[String and Position]

検証する文字列を、Current.InputImage に現れているとおりに入力します。文字列を入力したら、[Adjust Position] をクリックして、文字列を表すグラフィックスを、Current.InputImage 内にある実際の文字列の上に配置します。

[Rendering Parameters]

次のパラメータを使用して、検証する文字列を表すグラフィックスを、Current.InputImage: の上に、ツールが表示する方法を変更します。

  • [Spot Size Scale]:ドットマトリックスフォントのスポットをスケール変更します。デフォルト値の 1.0 では、描画されるテキストに変化は生成されません。
  • [Added Stroke Width]:指定されたフォントのテキストの標準ストローク幅に追加します。正の値によってストローク幅は増加し、負の値によってストローク幅は減少します。このプロパティは、通常、非ドットマトリックスフォント、つまりアウトラインフォントにのみ役立ちます。
  • [Spot Spacing Scale, X]:ドットマトリックスフォントの描画スポットの、x 軸に沿った間隔をスケール変更します。デフォルト値の 1.0 では、描画されるテキストに変化は生成されません。
  • [Added Char Spacing, X]:1 つの文字と、同じ行にある次の文字の間における、x 軸に沿った間隔を追加します。正の値によって文字間の間隔は増加し、負の値によって文字間の間隔は減少します。
  • [Spot Spacing Scale, Y]:ドットマトリックスフォントの描画スポットの、y 軸に沿った間隔をスケール変更します。デフォルト値の 1.0 では、描画されるテキストに変化は生成されません。
  • [Added Char Spacing, Y]:1 つの文字と、同じ行にある次の文字の間における、y 軸に沿った間隔を追加します。ゼロ以外の値によって、階段状のテキスト行が生成され、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。このプロパティは、まれにしか使用されません。

[Noise Level]

Current.InputImage 内において、検証する文字列の周囲にある背景ノイズの量を指定します。OCVMax ツールは、実行時画像内の文字列が同じノイズレベルを持つと予想します。

[Tune After Train]

検証する文字列を使用してツールが登録された後で、チューニング処理を実行します。

[Train]

利用する文字列を使用して OCVMax ツールを登録します。ツールを登録する前に、[Text] タブで文字列を指定する必要があります。

[Image Params] タブ

[Image Params] タブは、OCVMax ツールで使用するサーチモードと、文字列を検出するためのアクセプトしきい値を設定するために使用します。また、取り込んだ画像内の文字列が画像間でどのように変化する可能性があるかによって、追加の自由度 を有効にするために使用します。次の図に、デフォルトの [Image Params] タブを示します。

表 4. [Image Params] タブ
設定項目 説明

[Search Mode]

各画像内の文字列を検出するために OCVMax ツールが使用する、サーチモードを選択します。

[Accept Threshold]

画像内の文字列全体を検出するためのアクセプトしきい値を設定します。

[Additional Search Parameters]

連続する画像内の文字列を確実に検出するために、ツールは、次の自由度をサポートします。

  • [Angle]:実行時画像内の文字列が少量の正確な回転角度を持つことがわかっている場合は、標準値を指定します。それ以外の場合は、角度の範囲を指定します。
  • [Scale, Uniform]:画像が少量の正確な均等スケールの変化を持つことがわかっている場合は、標準値を指定します。それ以外の場合は、文字列が示す可能性があるスケール量の変化の範囲を指定します。
  • [Scale, X]:画像が x 軸に沿った少量の正確なスケールの変化を持つことがわかっている場合は、標準値を指定します。それ以外の場合は、スケールの範囲を指定します。
  • [Scale, Y]:画像が y 軸に沿った少量の正確なスケールの変化を持つことがわかっている場合は、標準値を指定します。それ以外の場合は、スケールの範囲を指定します。
  • [Shear]:文字列が少量の正確なせん断を受けることがわかっている場合は、標準値を指定します。せん断は、文字列中の文字が、高さが減ることなしに、傾いて見えるようになる変形です。OCVMax ツールは、せん断を考慮して画像を解析する場合、せん断を考慮せずに同じ画像を解析する場合よりもはるかに長い時間を要することがあるため、可能なせん断角度の範囲を有効にする際は注意してください。

チューニング処理は、これらの追加サーチパラメータ用の良好な開始値を生成できますが、それらの値は、検証する文字列のサンプル画像を使用した OCVMax ツールのテストに基づいて、必要に応じてユーザが変更する必要があります。

[Character Params] タブ

[Character Params] タブは、OCVMax ツールが、文字列中にある個別の文字を検出する際に使用可能な、サーチパラメータを指定するために使用します。次の図に、[Character Params] タブの例を示します。

表 5. [Character Params] タブ
設定項目 説明

[Search Parameters]

このツールは、次の文字サーチパラメータをサポートしています。

  • [X-Shift]: 登録画像内の文字列と比較して、文字列中の各文字が、連続する実行時画像内で左または右にシフトできるピクセル数を指定します。チューニングを有効にすると、OCVMax ツールは良好な開始値を提供することができます。テスト画像内の文字列を OCVMax ツールが確実に検出できる場合は、ツールの性能を向上させるために、このシフト値を減らしてみてください。ただし、可能な実行時画像内の文字列をツールが確実に検出できなくなる値まで、このパラメータ値を減らさないでください。
  • [Y-Shift]:登録画像内の文字列に比較して、文字列中の各文字が、連続する実行時画像内で上または下にシフトできるピクセル数を指定します。チューニングを有効にすると、OCVMax ツールは良好な開始値を提供することができます。テスト画像内の文字列を OCVMax ツールが確実に検出できる場合は、ツールの性能を向上させるために、このシフト値を減らしてみてください。ただし、可能な実行時画像内の文字列をツールが確実に検出できなくなる値まで、このパラメータ値を減らさないでください。
  • [Accept Threshold]:文字列中にある各個別の文字のアクセプトしきい値を指定します。OCVMax ツールが文字列中の 1 つまたは 2 つの文字の検証には失敗したものの、ほかの文字は正確に検証される場合は、このしきい値を低下させてみてください。検証されるべきすべての文字について動作するアクセプトしきい値を検出したら、ツールの実行速度を向上させるために、このしきい値を少し上昇させてみてください。
  • [Angle]:1 つ以上の文字が、同じ文字列中のほかの文字と比較して、異なる角度を持つ可能性がある場合の、角度範囲を提供します。この現象は、湾曲した表面上に印刷された文字列で頻繁に発生することがあります。
  • [Scale, Uniform]:均等スケールの範囲を提供します。
  • [Scale, X]:x 軸のみに沿った文字のスケールの範囲を提供します。
  • [Scale, Y]:y 軸のみに沿った文字のスケールの範囲を提供します。
  • [Shear]:1 つ以上の文字が、同じ文字列中のほかの文字と比較して、異なるせん断値を持つ可能性がある場合の、せん断の範囲を提供します。OCVMax ツールは、せん断を考慮に入れる場合、文字列の解析にはるかに長い時間を要することがあるため、せん断を有効にする際は注意してください。

[Confusion]

[Character Params] タブは、この文字列のためのコンフュージョンマトリックスを表示し、次のコンフュージョンマトリックスパラメータを変更することを可能にします。

  • [Confusion Threshold]
  • [Confidence Threshold]

[Advanced Params] タブ

[Advanced Params] タブは、実行タイムアウトを有効にするため、またはツールの全体的な実行速度を向上できる詳細パラメータを設定するために使用します。次の図に、デフォルトの [Advanced Params] タブを示します。

表 6. [Advanced Params] タブ
設定項目 | 説明
[Timeout Enabled] | 実行タイムアウトを有効にします。
[Timeout, ms] | [Timeout Enabled] がチェックされている場合、これは最大許容時間 (ミリ秒単位) です。この制限時間を超えると、ツールは、どの文字も検証に合格しなかったことを報告します。
[Contrast Threshold] | これは、容認されるために結果が持つ必要のある、グレーレベルでのコントラストの量です。
[XY Overlap] | これは XY オーバラップの量であり、この量を超えると 2 つの結果は同じであるとみなされます。
[Early Accept Threshold] | 画像内にある行の実際のインスタンスとしての潜在的な行一致を、早期容認するためのしきい値です。行内の一致している (つまり、Verified または Confused の) 文字キーのパーセンテージが、このしきい値よりも大きい場合は、行に対するサーチはこれ以上実行されません。実行時画像内に不要な文字がないことがわかっている場合 (例えば、画像内のテキストは、検証される文字列のみであることがわかっている場合)、これによりサーチ処理が高速化されます。
[Early Fail Threshold] | 画像内にある行の実際のインスタンスとしての潜在的な行一致を、早期エラーとするためのしきい値です。行内の一致している (つまり、Verified または Confused の) 文字キーのパーセンテージが、このしきい値よりも小さい場合は、潜在的な行を含む画像の部分はこれ以上考慮されません。画像が、欠落した文字や大きく損傷した文字がない、完全な画像である必要があるとわかっている場合は、これによりサーチ処理が高速化されます。

[Results] タブ

[Results] タブは、OCVMax ツールの前回の実行結果を表示するために使用します。次の図に、[Results] タブの例を示します。

表7. [Results] タブ
設定項目 説明

[Overall Results]

このタブには、次の結果が示されます。

  • [Status]:文字列中のすべての文字が検証された場合、ツールは Verified と報告します。それ以外の場合は、Failed の状態を報告します。
  • [Score]:配置の総合得点です。これは、OCVMax ツールが検証を試みたすべての文字キーの得点を平均した値です。
  • [Diagnostics]:

[Character Results]

このタブは、文字列中の各文字についての結果を表示します。なんらかの理由で文字の検証に失敗した場合は、[Character Params] タブで有効にする必要がある、または範囲を増加させる必要がある自由度についてのヒントが、[Diagnostic] 列の対応するセルに表示されます。

  • A:Angle
  • X:X-Shift
  • Y:Y-Shift
  • S:Scale, Uniform
  • SX:Scale, X
  • SY:Scale, Y
  • SH:Shear

c 2005 Cognex Corporation.All rights reserved.


OCVMax ユーザーズガイド

メインページ

このページは、OCVMax ユーザーズガイドのメインページです。

完全なオンラインドキュメンテーションについては、VisionPro .NET マニュアルコレクション英語版を参照してください。

日本語オンラインマニュアルについて

このオンラインマニュアルは、日本における多くのユーザが、コグネックスの製品を使用するにあたって役立つように企画されたものです。

技術的に正確な訳となるよう努力いたしておりますが、原本とのバージョンの違いやリリース時期に完全には対応していない場合もありますので、この日本語オンラインマニュアルは参考資料としてご使用ください。

このオンラインマニュアルでは、グラフィカルユーザインタフェースを英語版のままで説明しております。

内容に疑問が生じた場合は、英語の原本のオンラインマニュアルも併せてご参照ください。

不明な点については、弊社テクニカルサポートまでご連絡ください。

テクニカルサポートの連絡先は次のとおりです。

コグネックス株式会社

〒113-6591

東京都文京区本駒込 2-28-8 文京グリーンコート 23 階

サポートホットライン: 03-5977-5410 (月～金: 9:00 ～ 17:30)

E-mail: support.jp@cognex.com

© 2005 Cognex Corporation.All rights reserved.


OCVMax ツール

CogOCVMaxTool ツールは、「光学文字検証 (OCV)」を実行します。OCVは、画像内にある 1 つ以上の文字列が、各位置において、予測される文字を含んでいることを検証するためのプロセスです。ビジョンアプリケーションは、通常、OCV を使用して、製品またはパッケージに印刷された製造ロット番号、製造日、有効期限、およびそのほかの情報を検査します。ビジョンアプリケーションで使用できるように、OCVMax ツールを追加および設定する場合の例については、「OCVMax ツールの使用」を参照してください。

次の図は、7 × 7 ドットマトリックスフォントによって構成される文字列を検証するために OCVMax ツールが使用された場合の画像の例を示します。

設定された OCVMax ツールは、次のタイプの画像のばらつきを許容することができます。

  • 照明
  • 画質
  • コントラスト
  • フォントのストローク幅
  • 文字列全体の位置、回転、およびスケール
  • 文字間の位置、回転、およびスケール

一般に、OCVMax ツールを使用するには、ビジョンアプリケーションで次のタスクを実行する必要があります。

  1. 検証する文字列を含む登録画像を取り込みます。

    画像の取り込みの詳細については、「VisionPro での画像取り込み」を参照してください。

  2. 検証する文字列内に現れる文字に対するフォントファイルを指定します。

    フォントファイルの詳細については、「フォントファイル」を参照してください。

  3. アプリケーションの目的に基づいた文字列を指定します。

    詳細については、「パラグラフ」を参照してください。

  4. フォントファイルによって説明されるフォントを使用して、文字列の例を描画します。

    文字列の描画の詳細については、「フォント描画」を参照してください。

  5. OCVMax ツールが Cognex PatMax テクノロジを使用して、連続した実行時画像内の文字列を確実に検出するための、 実行可能で最適なサーチパラメータを決定できるようにします。

    入力画像と実行時画像の間で、文字列の外観がどのように変化する可能性があるかについては、「自由度」を参照してください。OCVMax のチューニングの詳細については、「教示およびチューニング」を参照してください。

  6. 連続したテスト画像について、設定した OCVMax ツールをテストして、各文字列内の文字が確実に検証されることを確認します。OCVMax ツールをテストする際に、文字列の外観の画像間でのばらつきを補正するために、いくつかのサーチパラメータを必要に応じて変更することができます。

  7. テスト画像内の文字列を検出および検証するために OCVMax ツールが動作することを確認し、次に、各画像についての実行時間を改善するために、さまざまなサーチパラメータの範囲を縮小します。OCVMax ツールによって提供されるヒントを使用して、許容できる最適な時間内でのツールの実行に成功するまで、さまざまなサーチパラメータを有効化、無効化するか、または小さくします。

フォントファイル

OCVMax ツールは、画像をベースにした登録はサポートしていません。つまり、一連のサンプル画像を取り込んで、次に、そのサンプル画像に含まれる文字を使用して、検証する文字用のフォントファイルを構築することはできません。その代わりに、OCVMax ツールを設定するには、各「文字キー」のレイアウトを定義した、特定のフォントファイルが必要です。

OCVMax ツールとともに使用するために、任意のフォントファイルを指定できます。OCVMax ツールでは、すべての西洋言語の TrueType ASCII および Unicode 文字フォントがサポートされています。そのほかのフォントタイプも OCVMax ツールとともに動作する可能性はありますが、取り込んだ画像と OCVMax ツールパラメータについて実験を行い、どの程度動作するか確認する必要があります。

レーザジェットプリンタ (ビデオジェットプリンタとも呼ばれます) またはサーマルプリンタによって適用される文字列には、多くの場合、共通のフォントが使用されます。VisionPro では、さまざまな印刷検査に適した共通のフォントのライブラリを提供しています。デフォルトでは、これらのフォントは、VisionPro インストールユーティリティによって C:¥Program Files¥Cognex¥VisionPro¥Fonts ディレクトリに配置されます。[スタート] → [プログラム] → [Cognex] → [VisionPro] → [OCVMax Application Guide] を選択することによって「OCV Application Guide」と表示されます。『OCVMax Application Guide』では、各フォントのすべての文字キーを示すシートが、印刷された文字列と比較するために表示されます。

使用する文字列に、VisionPro で提供されないフォントの文字キーが使用されている場合は、フォントファイルを別に取り込む必要があります。ビジョンアプリケーション用の正しいフォントファイルを探すために、Cognex では、次の事項を行うことを推奨します。

  • 印刷装置の製造元に問い合わせてください。

    製造元は、印刷装置が使用するフォントの名前を提供できる場合があります。また、場合によっては、フォントファイルそのものも提供できる可能性があります。

  • フォントの名前がわかっている場合は、ご使用の PC の ¥WINDOWS¥Fonts ディレクトリを調べてください。

    印刷装置が TrueType フォントを使用する場合は、Microsoft Word の [フォント] ダイアログボックスを使用することによって、すべての TrueType フォントをプレビューすることができます。

    注: Microsoft Windows では、¥WINDOWS¥Fonts ディレクトリのフォントファイルを直接開くことはできないようになっています。¥WINDOWS¥Fonts のフォントを使用する必要がある場合は、最初に、ほかの任意のディレクトリにそのフォントをコピーしてください。

  • Web サイト http://www.myfonts.com/WhatTheFont (フォントを検索、試用、購入するためのオンラインのソース) にアクセスしてみてください。この Web サイトには、41,680 のフォントが検索ツールとともに置かれているため、印刷された文字列に一致する正しいフォントを見つけて購入することができます。

パラグラフ

OCVMax ツールの設定時に、「パラグラフ」を指定する必要があります。パラグラフは、OCVMax ツールに検証させる文字列のセットです。パラグラフは、1 つの文字列または文字列のセットを含むことができます。例えば、次の図は、2 つの文字列を含む 1 つのパラグラフの画像を示します。

さらに、1 つの OCVMax ツールが複数のパラグラフを含むことも可能です。1 つのパラグラフでは、1 つのフォントのみを参照できますが、同じ OCVMax ツール内の複数のパラグラフでは、異なるフォントを参照することが可能です。

OCVMax ツールの設定時に、OCVMax ツールに含まれるパラグラフを指定します。次に、パラメータ (連続する画像内における文字列の予想される位置、発生する可能性がある文字列位置の変化のタイプと量、実行時画像で示される可能性のある、文字間での角度とスケールに関して予想される差など) を指定します。

キーセット

文字列の各位置において、OCVMax ツールは、「キーセット」を使用して、検証することが予想される 1 つ以上の文字を指定します。例えば、10 文字の文字列に、10 のキーセットを使用します。

一定の文字列の場合、各キーセットには、1 つの文字キーが含まれます。特定の位置における 1 つ以上の文字キーが、実行時画像間で変化する可能性がある文字列を検証する場合は、複数の文字キーを持つキーセットを作成します。例えば、次の図に示す 2 つの文字列は両方とも、同じ OCVMax ツールを使用して検証できます。これは、3 番目の位置にあるキーセットが 2 つの文字キーを指定しているためです。

さらに、OCVMax ツールは、「登録時キーセット」および「実行時キーセット」をサポートしています。登録時キーセットは、特定の位置において可能なすべての文字キーを指定するために使用し、実行時キーセットは、次の実行時画像でその位置に予想される文字キーを指定するために使用します。例えば、ビジョンアプリケーションは、文字列内の 1 つ以上の位置における値がインクリメンタルに増加する、数字文字列を検証する場合があります。OCVMax ツールの設定時に、文字列内の位置において、0 ～ 9 のすべての数値文字キーを持つ登録時キーセットを指定します。アプリケーションの動作時に、OCVMax ツールによって解析された最後の画像に基づいて予想される、次の文字キーの実行時キーセットを使用します。実行時キーセットを使用すると、登録時キーセットの各文字と現在検証中の文字をツールに比較させる場合よりも、ツールの実行速度は一般に向上します。

フォント描画

OCVMax ツールは、Cognex PatMax テクノロジを使用して、取り込まれた各画像内の文字列をサーチします。必要なキーセットを指定した後で、各文字列の例をグラフィカルに生成して、検証する必要のある実際の文字列を示す登録画像上に、キーセットを配置することができます。このような文字列グラフィックスを登録画像上に配置することによって、PatMax アルゴリズムに役立つ、各サーチの論理的な開始位置と、サイズ、回転、文字間隔の良好な初期値が提供されます。良好なサーチパラメータを使用して OCVMax ツールをチューニングし、連続した実行時画像内で各文字を確実に検出するために、これらの初期値は PatMax アルゴリズムによって必要とされます。

注: 検証する各文字列の例のグラフィカルな描画は必須ではありませんが、OCVMax ツールの実行速度と信頼性を一般に向上させます。

例えば、次の図は、1 つの文字列を含む画像であり、OCVMax ツールを使用して、希望するフォントで同じ文字列を描画する前の状態を示しています。

次の図は、ユーザが文字列を描画し、OCVMax ツールグラフィックスを使用して登録画像内の対応する文字上にその文字列を配置した後の、同じ画像を示します。

文字列を描画して登録画像上に配置する際に、正しいフォントを選択したにもかかわらず、画像内の文字キーが、指定したフォントの文字キーとわずかに異なる特性を示していることに気付くことがあります。例えば、画像内の印刷された文字列に、ドットの形状が対称ではないドットマトリックスフォントが使用されている場合があります。または、画像内の印刷された文字列が、フォントによって指定された大きさよりもわずかに大きい場合もあります。

これらのタイプに関する文字キーの差は、次の高度なフォントパラメータを使用して補正することができます。

  • 文字間隔の追加

    水平方向および垂直方向の両方について、文字キー間の間隔を、ピクセル単位で指定して追加することができます。

  • 行間隔の追加

    複数行の文字列を指定する場合、文字キーの行間の間隔の追加を、ピクセル単位で指定することができます。

  • 文字の特徴

    主にドットマトリックスフォントについて、画像内のドットと、使用するフォントによって指定されるドットの間の大きさの差を指定することができます。または、非ドットマトリックスフォントのストローク幅を増加させることができます。

これらのパラメータは、描画した文字列を登録画像上に配置する際に設定できます。ただし、OCVMax ツールのチューニング機能を有効にしている場合は、これらの高度なパラメータに対する良好な開始値はツールそのものによって設定されることが可能という点に注意してください (性能や実行速度を改善するために、後でいつでもこれらの値を変更できます)。

自由度

パラグラフの外観は、ある画像と次の画像では、さまざまな形で変化します。これらの各タイプの変形は「自由度」と呼ばれ、単一の数値 (1 つの画像と次の画像間で文字に発生する回転の量など) によって特徴付けられます。

表 1. 自由度
自由度 | 例
X シフト |
Y シフト |
角度 |
均等スケール |
スケール X |
スケール Y |
せん断 |

通常、自由度の変化は、個々の文字キーではなく、文字列全体に影響します。例えば、次の図では、角度および均等スケールの両方の変化が、文字列全体に発生しています。

ただし、ご使用の印刷装置または表面の素材によっては、文字列において、特定の由度が文字ごとに発生する場合があります。例えば、次の図に示す文字列では、文字列中の後続の各文字キーで均等スケールの減少が発生しています。

このような文字列の場合、OCVMax ツールは、文字ごとの均等スケールの変化について認識する必要があります。

OCVMax ツールの設定時に、検証する文字列の登録画像を取り込んでから、対応するフォントファイルの文字キーを使用して、文字列の例を作成する必要があります。この登録画像および描画された文字列を使用することによって、OCVMax ツールは、そのチューニング機能を使用して、後で取り込む画像に対する初期テストのために、どの自由度を有効にする必要があるかを自動的に検出します。

チューニング機能は、Cognex PatMax テクノロジを使用して、各自由度について広範な値をテストし、検証する文字列と適用対象の画像例の間における最適な一致を決定します。OCVMax のチューニングの詳細については、「教示およびチューニング」を参照してください。

チューニングのプロセスが完了すると、OCVMax ツールが持つパラメータのセットは、アプリケーションの配備時に使用する最終的なパラメータのセット用の良好な基礎となります。さまざまなサンプル画像に対して OCVMax ツールをテストする際に、OCVMax ツールは、さまざまな自由度の範囲を変更するために、追加で推奨を行う場合があります。また、ほかのサーチパラメータについてのヒントを提供する場合もあります。ただし、ユーザが手動で無効にした自由度については、OCVMax ツールは推奨を行わないので注意してください。

ユーザは、OCVMax ツールのチューニング機能を無効にして、どの自由度をツールに考慮させるかを手動で設定できますが、この場合、最適な結果が提供される設定を決定する際に、多大な時間を要することがあります。Cognex では、さまざまなサンプル画像に対するツールのテストに進む際に、OCVMax ツールのチューニング機能を使用して、最適なパラメータのセットを生成することを推奨します。

一般に、有効にする自由度の数が増えると、OCVMax ツールが画像を十分に解析して検証を実行するために要する時間は増加します。無効にする自由度を追加すると実行時間は改善されますが、特定の文字キーについては、その特定の文字が示す自由度が原因で、検証に失敗する危険性もあります。

単に自由度を有効にしても、連続した実行時画像内の文字キーを確実に検証する、OCVMax ツールの能力が向上するわけではないことに注意してください。OCVMax ツールが文字列中の特定の文字キーの検証を試みる場合、現在有効にされている自由度によって決定されるのは、全体的な一致の強さです。例えば、均等スケール自由度が有効にされている場合よりも無効にされている場合に、同じ文字キーがより良く一致していると認識されることがあります。

これは、特定の自由度が有効にされているにもかかわらず、検出された文字キーは現在の範囲外の変形を示している場合に、特にあてはまります。有効にされた自由度が、OCVMax ツールによる文字キーの検証能力に悪影響を及ぼすのを防止するには、文字キーに発生する可能性のあるさまざまな変形は、その自由度の設定範囲に含まれている必要があります。

教示およびチューニング

検証する文字列内の文字を確実に検出するためには、OCVMax ツールが教示されている必要があります。VisionPro では、Cognex PatMax テクノロジを使用して、文字列の実際の画像をベースにして OCVMax ツールを教示します。OCVMax ツールを設定する前に、ビジョンアプリケーションを製造現場に配備した場合にツールによって検出されると予想される特性を示す、文字列の画像を取り込む必要があります。

OCVMax ツールの教示時に、教示画像に含まれるノイズ、つまり誤り画像データの量を選択します。画像ノイズは、不適切な照明やカメラレンズなどのさまざまな原因により発生します。照明が適切でコントラストが良好な画像は、通常、低いノイズ値を保持しています。実際に、画像の質が高ければ、より良好な結果が、より高速に得られます。

教示に加えて、取り込まれた画像内にある文字列の特性を調べることによって、OCVMax ツールに特定のパラメータの自動チューニングを実行させることもできます。OCVMax ツールのチューニングでは、Cognex PatMax テクノロジを使用して、さまざまなパラメータを実験し、文字列中の文字に発生する可能性のある自由度をベースにして、最適な設定を決定することができます。

OCVMax ツールがチューニングのために必要とする時間は、使用する文字数とフォントのタイプによって異なります。文字列によっては、OCVMax ツールをチューニングする際に、かなりの時間を要することがあります。

大規模な文字列、または複数の小規模な文字列の教示およびチューニングには、かなりの時間を要する場合があるので注意してください。時間を要する場合があるため、OCVMax ツールのグラフィカルインタフェースでは、1 つのチューニング動作がどの程度進んだか、およびチューニング動作の完了までに、後どれだけの処理時間が必要かを示すメカニズムが提供されています。

チューニングはオプションです。OCVMax ツールの教示時に自動チューニングを無効にすることも可能ですが、ユーザがさまざまな画像および文字間パラメータの最適な設定を決定して、PatMax テクノロジによって、連続する画像内の文字列が検出されるようにすることは、困難な場合があります。

チューニング動作は、必ずしも成功するとは限りません。場合によっては、OCVMax ツールにより、チューニングの試みに失敗したことが報告される場合があります。一般に、チューニングは、次の 2 つの理由のいずれかにより失敗します。

  • OCVMax ツールの教示のために設定した文字列が、教示画像の文字列と一致していない場合。

  • 文字列のグラフィックスが、教示画像内の実際の文字列に十分に近くないため、Cognex PatMax テクノロジでその文字列を検出することができない場合。

OCVMax ツールは、チューニング動作が完了すると、有効な文字列内の文字を確実に検出および検証できます。ただし、検証の実行に要する時間が非常にかかる場合があるので注意してください。チューニング動作により、良好なパラメータが割り当てられた後、さまざまなサーチパラメータを手動で調整することで、通常は、取り込んだ画像内の文字列を検出および検証するために OCVMax ツールが必要とする時間を減らすことができます。

得点としきい値

OCVMax ツールは、さまざまな得点を生成し、文字列中の各文字を検証するために、さまざまなしきい値と比較します。詳細については、次のトピックを参照してください。

  • 一致得点とアクセプトしきい値

  • コンフュージョン得点とコンフュージョンしきい値

一致得点とアクセプトしきい値

OCVMax ツールは、調べる各文字キーについて「一致得点」を生成します。この得点は、画像内の実際の文字キーが、この位置に対して予想される文字キーにどの程度一致しているかを、任意のキーセットを考慮に入れて示します。一致得点の範囲は 0.0 ～ 1.0 であり、1.0 は完全な一致を示します。

OCVMax ツールは、この一致得点を「アクセプトしきい値」と比較して、一致得点がアクセプトしきい値を超えている場合は、予備合格結果を文字キーに与えます。デフォルトでは、OCVMax ツールはアクセプトしきい値として 0.50 を使用しますが、ビジョンアプリケーションの必要に応じて、ユーザはこの値を増減させることができます。

アクセプトしきい値により、文字および画像の変化に対する OCVMax ツールの感度を変化させることができます。アクセプトしきい値を増加させるにつれて、予想される文字キーと、実行時画像内にある実際の文字キー間のより良好な一致が、OCVMax ツールによって要求されるようになります。

ビジョンアプリケーションによって取り込まれる、検証する文字列の画像が良好でかつ、文字キーの印刷品質も一貫して良好であり、さらに、さまざまな自由度がほとんど変化を示さない場合は、アクセプトしきい値を増加させます。アクセプトしきい値が高ければ、OCVMax ツールの実行速度は向上します。ただし、しきい値を高くしすぎると、OCVMax ツールは、画像内の有効な文字キーをほとんどまたはすべて破棄します。

各文字キーの一定した外観が製造現場で保証されない場合、または、文字キーに 1 つ以上の自由度の変化が発生する可能性がある場合は、アクセプトしきい値を減少させます。アプリケーションの開発時に、OCVMax ツールが正しい文字キーの検証に失敗する場合は、アクセプトしきい値を減少させてみてください。

OCVMax ツールは、2 つのアクセプトしきい値を使用します。1 つ目は各文字キーのためのアクセプトしきい値であり、2 つ目は文字列全体のためのアクセプトしきい値です。一般に、2 つのしきい値は同じ値を使用します。チューニング機能を有効にすると、OCVMax ツールは、各アクセプトしきい値の良好な値を自動的に生成することができます。アクセプトしきい値をさらに変更することによって、性能または信頼性を向上させることができます。

コンフュージョン得点とコンフュージョンしきい値

OCVMax ツールの登録時に、このツールは、ユーザが使用するフォントにおいて有効にする各文字キーに関するコンフュージョン得点のセットを作成します。コンフュージョン得点は、文字キーの各ペア間の類似性の程度を表し、同じ位置、角度、スケールにおける文字キーを比較することによって生成されます。OCVMax ツールは、次の例に示すようなコンフュージョンマトリックスに、コンフュージョン得点を保存します。

コンフュージョンマトリックスの上部に示されている文字キーは、現在のフォントで有効にされているすべての文字キーを表し、左側の列に示されている文字キーは、検証する文字列内のすべて文字キーを、数値の順に表しています。例えば、このコンフュージョンマトリックスは、数のみが有効にされているフォントによる文字列「322104」を表す場合があります。複数の文字列を検証するように OCVMax ツールを設定すると、各文字列は独自のコンフュージョン得点のセットを生成します。

任意の 2 つの文字キー間のコンフュージョン得点を確認するには、左側の列から開始します。前のコンフュージョンマトリックスで、文字キー「3」を文字キー「5」に対して比較すると、コンフュージョン得点は 0.45 であることがわかり、「3」を「8」に対して比較すると、コンフュージョン得点は 0.83 であることがわかります。

赤色で示す得点は、現在の「コンフュージョンしきい値」を超えているコンフュージョン得点を表します。これは、紛らわしくなる可能性が高い文字キーのペアを示します。OCVMax ツールは、各文字キーの検証を試みる際に、紛らわしくなる可能性がある文字キーを除外するための追加処理を実行します。前のコンフュージョンマトリックスを例として使用すると、文字キー「0」に対して、文字列内の文字キーの検証を試みている OCVMax ツールは、文字キー「0」、および文字キー「6」、「8」、「9」についての一致得点を生成します。「0」についての一致得点は、紛らわしくなる可能性があるほかの文字キーについての一致得点よりも大きい必要があります。さらに、新しいしきい値である[Confidence]によって設定される許容値分だけ、ほかの得点よりも大きい必要があります。通常、信頼性しきい値は、0.1 などの低い値に設定されます。

文字キーが受け取る一致得点が、紛らわしくなる可能性があるほかのすべての得点を、信頼性しきい値によって設定される許容値分超えない場合、OCVMax ツールはその文字キーを検証せず、その代わりに、対象となる文字キーを Confused として報告します。

コンフュージョンしきい値を減少させるにつれて、OCVMax ツールは、紛らわしくなる可能性がある、より多くの文字キーについて一致得点を生成し、検証を試みている各文字キーの一致得点と比較します。これによって検証結果は向上しますが、ツールの実行にさらに多くの時間を要するようになります。また、文字キーは、紛らわしさが原因で誤って破棄される可能性が大きくなります。コンフュージョンしきい値を増加させるにつれて、OCVMax ツールは、紛らわしくなる可能性のある文字キーについての一致得点をさらに少なく生成するようになります。この結果、実行時間は高速になりますが、ツールが文字キーを間違って検証する可能性も大きくなります。

信頼性しきい値も、デフォルトの低い値から調整することができます。OCVMax ツールが、文字キーを間違って検証していると思われる場合 (例えば、取り込まれた画像内で文字キーが「8」と表示されている場合に、その文字キーを「3」であるとして検証しているなど) は、信頼性しきい値を増加させてください。

文字検証

文字列内の 1 つの文字キーを検証するために、OCVMax ツールは次の手順を実行します。

  1. OCVMax ツールは、予想される文字キーと検証される文字キーを比較して、一致得点を生成します。詳細については、「一致得点とアクセプトしきい値」を参照してください。検証を継続するには、一致得点がアクセプトしきい値を超えている必要があります。一致得点がアクセプトしきい値よりも小さい場合、文字キーは直ちに検証に失敗します。

  2. コンフュージョンマトリックスを使用して、OCVMax ツールは、一致得点を、紛らわしくなる可能性があるすべての文字キーについて生成されたマッチング得点と比較します。詳細については、「コンフュージョン得点とコンフュージョンしきい値」を参照してください。コンフュージョンしきい値よりも大きいコンフュージョン得点がない場合、文字キーは直ちに検証に合格します。

  3. OCVMax ツールは、紛らわしくなる可能性がある最も高い得点を、一致得点から減算し、その結果の値を信頼性しきい値と比較します。その値が正の場合、文字キーは検証に合格します。その値が負の場合、ツールにより、識別中の文字キーは現在、ほかの文字キーと紛らわしくなっていると報告されます。

検証プロセスは、次の図を使用して模式的に示すことができます。

実行タイムアウト

OCVMax ツールの設定時に、実行タイムアウト値を設定することができます。実行タイムアウト値によって、文字列内にある検証される文字キーに関する最適な結果を返すために、OCVMax ツールが許容される時間 (ミリ秒単位) が決定されます。

OCVMax ツールは、文字列中の各文字キーを検出および検証しようとする試みすべてにおいて、実行タイムアウト値を考慮に入れます。実行タイムアウト値が小さすぎる場合、ほとんどの文字列は検証に失敗します。ユーザが、OCVMax ツールがさまざまなサーチパラメータに関する良好な値にツールそのものをチューニングするように設定すると、OCVMax ツールは、実行タイムアウトの良好な開始値を生成します。

さらに、特定の実行タイムアウト値を使用して文字列は検証に合格する場合がありますが、より大きな実行タイムアウト値を可能にすると、文字列中の各文字キーに関するより正確なサーチ得点を生成することができます。一部の画像では、より正確なサーチ得点が要因となり、検証される文字列と検証に失敗する文字列の差が出る場合があります。一般には、ビジョンアプリケーションの各検査について、許容できる限り大きな実行タイムアウト値を使用する必要があります。

場合によっては、OCVMax ツールは、設定した実行タイムアウト値を超過して、成功した結果を返すことがあります。ビジョンアプリケーションによって、特定の割り当て時間内に OCVMax ツールの解析完了が要求される場合には、実行タイムアウト値を数ミリ秒小さく設定することで、この種の状況に対処してください。

サーチモード

取り込んだ各画像について、OCVMax ツールは、検証する文字列を検出する必要があります。OCVMax ツールは、次の 3 つのサーチモードをサポートすることができます。

  • Position + Shift Uncertainty

    OCVMax ツールは、登録画像内の文字列が検出された位置に基づいて、x 軸および y 軸に沿って一定のピクセル量だけ外部に拡張して、各文字列についてのサーチを開始するように設定できます。OCVMax ツールは、次の図に示すように、X Shift および Y Shift パラメータを使用してサーチ領域の境界を定義します。

    3 つのサーチモードのうち、このモードが最も高速なサーチアルゴリズムを提供します。Cognex は、可能な限り Position + Shift Uncertainty を使用することを推奨します。

    OCVMax ツールのチューニング機能では、Position + Shift Uncertainty が自動的に使用されます。チューニングが完了し、サンプル画像に対して現在の OCVMax ツールパラメータのセットをテストする際に、アプリケーションに対して適切なほかのサーチモードに切り替えることを選択できます。

  • Region

    各画像の特定の領域内にある文字列をサーチするように、OCVMax ツールを設定することができます。このモードを選択すると、OCVMax ツールによって、文字列が現れる可能性がある登録画像の領域の周囲に、ユーザが配置し、サイズを変更し、回転させることが可能な領域グラフィックスが提供されます。

  • Whole Image

    検証する文字列のために、各画像の全体をサーチするように、OCVMax ツールを設定することができます。OCVMax ツールは、Cognex PatMax テクノロジを使用してサーチを実行します。

    3 つのサーチモードのうち、Whole Image のサーチには最も時間がかかります。Cognex では、文字列の位置が画像全体にわたって変化する可能性がある場合にのみ、このオプションを使用することを推奨します。

さらに、Fixture ツールを使用すると、Position + Shift Uncertainty サーチモード使用時に指定する必要のある X Shift および Y Shift の量が大幅に減少する可能性があります。また、Region サーチモード使用時に指定する必要のある領域のサイズが減少する可能性があります。Whole Image サーチモード使用時には、Fixture ツールを使用してもサーチに影響はないので注意してください。

サーチパラメータ

OCVMax ツールは、さまざまなサーチパラメータを使用して、取り込んだ画像内の文字列を検出します。OCVMax ツールは、「画像サーチパラメータ」を使用して各文字列を検出および識別し、「文字サーチパラメータ」を使用して文字列内の各文字を検出します。

チューニング機能を有効にすると、OCVMax ツールは、これらのサーチパラメータのための良好な値を生成できます。この値を必要に応じて有効化、無効化、変更することによって、OCVMax ツールは、良好な文字列を検出および検証する機能を向上させることができます。または、OCVMax ツールが正常に機能するために必要とする時間を減らすことができます。最適化に関する推奨事項については、「OCVMax の最適化」を参照してください。

画像サーチパラメータ

OCVMax ツールは、次の画像サーチパラメータを使用して、検証する文字列を検出します。

表 2. 画像サーチパラメータ
パラメータ | 説明
Search Mode | OCVMax ツールによって、各文字列を検出するために、3 つの異なるサーチモードのうちのいずれかが選択できるようになります。さまざまなサーチモードの詳細については、「サーチモード」を参照してください。
Accept Threshold | OCVMax ツールによって、文字列と、その文字列に類似する可能性がある画像内のさまざまな特徴間の類似性を計測するための、アクセプトしきい値を設定できるようになります。詳細については、「一致得点とアクセプトしきい値」を参照してください。
Degrees of Freedom | OCVMax ツールによって、連続する画像間で文字列に発生する可能性がある自由度について、さまざまな値を設定できるようになります。自由度の詳細については、「自由度」を参照してください。

文字サーチパラメータ

OCVMax ツールは、次の文字キーサーチパラメータを使用して、文字列中の個々の文字キーを区別します。

表 3. 文字サーチパラメータ
パラメータ | 説明
Accept Threshold | OCVMax ツールは、文字列全体に対してアクセプトしきい値を使用するのと同様に、文字列内の個々の文字キーに対しても別のアクセプトしきい値を使用します。詳細については、「一致得点とアクセプトしきい値」を参照してください。
Degrees of Freedom | 文字列には、文字ごとに、さまざまな自由度の変化が発生する場合があります。これは、湾曲した表面に印刷された文字列の場合に、特にあてはまります。このような文字列では、連続した文字キーを相互に比較すると、回転とせん断が変化しているように見えることがあります。自由度の詳細については、「自由度」を参照してください。
Confusion Values | コンフュージョン値は、どの文字キーが、同じフォントのほかの文字キーに外観が類似しているかを示します。これらの値に対するコンフュージョンしきい値を設定することによって、類似した外観を持つ文字キーを、OCVMax ツールがどの程度厳密に調べるかを決定できます。詳細については、「コンフュージョン得点とコンフュージョンしきい値」を参照してください。

OCVMax の最適化

Cognex では、OCVMax ツールに関して次の事項を推奨します。

  • Fixture ツールとサーチモード Position + Shift Uncertainty を使用してください。

    Fixture ツールを使用することにより、ビジョンアプリケーションは、連続した実行時画像内のシンボルおよびパラグラフの位置を自動的に補正できるようになります。

    サーチモード Position + Shift Uncertainty では、登録画像内でパラグラフが検出された位置に基づいて、各パラグラフのサーチが開始されます。

    Fixture ツール用の適切な候補が画像に含まれておらず、文字列の位置が画像間で大幅に変化する可能性がある場合は、X Shift および Y Shift に、チューニング機能によって返されるデフォルト値よりも大きな値を指定してください。大きな値を指定しても OCVMax ツールがパラグラフを確実に検出できない場合は、ほかのサーチモードに切り替えてください。

  • 回転する面上に、パラグラフ内の文字キーが現れている場合は、文字サーチパラメータを有効にして使用してください。

    回転する面上に現れた文字を相互に比較すると、多くの場合、角度、位置、およびせん断の変化が示されます。

  • OCVMax ツールを登録する際に、適切なレベルの画像ノイズを選択してください。

    低いノイズレベルを使用して登録画像上にパラグラフを描画して登録すると、OCVMax ツールは、実行時画像に、類似した量のノイズが示されることを予想します。無関係な画像データが実行時画像に多く含まれている場合、OCVMax ツールは低い一致得点を生成する可能性があります。これにより、文字列に正しい文字が含まれている場合でも、ツールが文字列を正しく検証する可能性は少なくなります。

  • ビジョンアプリケーションが取り込む可能性のあるサンプル画像に対してツールをテストする場合、画像サーチパラメータおよび文字サーチパラメータの両方で、せん断自由度を有効にしてください。

    デフォルトでは、OCVMax ツールのチューニング機能は、さまざまな自由度の良好な開始値を決定する際に、せん断のファクタを有効にしません。これは、せん断を有効にすると、通常、画像を解析するためにツールによって必要とされる時間が増加するためです。

  • OCVMax ツールが使用するフォントを設定する際に、OCVMax ツールが対象とするフォントの文字を有効にしてください。相互に排他的な文字間で紛らわしくなる可能性が高い、一定したパラグラフに対しては、別の OCVMax ツールを使用してください。

    例えば、あるパラグラフが文字「O」を含み、別のパラグラフが文字「Q」を含む場合、もうひとつの OCVMax ツールを使用して一方の文字を有効にし、もう一方の文字は対象から除外します。

  • 検証するパラグラフのタイプと数によっては、チューニング機能にかなりの時間を要する場合があります。

    一般に、OCVMax ツールのチューニングプロセスは、複数のパラグラフについて 1 つの OCVMax ツールを使用する場合よりも、1 つのパラグラフについて別の OCVMax ツールを使用する場合の方が高速に完了します。

OCVMax ツールエディットコントロール

OCVMax ツールは、OCVMax エディットコントロールをサポートします。このエディットコントロールは、OCVMax ツール API によってサポートされる機能のサブセットをサポートします。特に、このエディットコントロールは、次の機能をサポートしません。

  • 複数文字キーセット

    OCVMax エディットコントロールを使用して、複数文字のキーセットを指定することはできません。

  • 複数パラグラフ

    OCVMax エディットコントロールは、1 つのパラグラフのみを含むことができます。

  • 複数行パラグラフ

    OCVMax エディットコントロールで指定するパラグラフは、単一の文字列のみを含むことができます。

  • グラフィックスの選択

    OCVMax エディットコントロールは、結果を表示するために、定められたグラフィックスのセットをサポートします。

  • チューニング実行パラメータ

    チューニング実行パラメータの設定には、OCVMax ツール API を使用する必要があります。

OCV ツール

VisionPro は、OCV ツールをサポートします。OCV ツールは、OCVMax ツールと同様に、画像内の 1 つ以上の文字が、各位置において予想される文字に一致することを検証するために使用されます。ツール間の違いを認識していれば、ビジョンアプリケーション用の適切なツールを選択する際に役立ちます。

  • 画像ベースの登録

    OCV ツールでは、ビジョンアプリケーションが検証する必要のある各文字について、取り込まれた 1 つ以上の画像からサンプリングされたフォントモデルを生成する必要があります。OCVMax ツールでは、既存のフォントファイルを使用して、各文字用のモデルを定義します。検証する文字列中の文字に対するフォントファイルがある場合は、OCV ツールの設定よりも、OCVMax ツールの設定の方が、通常はより高速に行うことができます。ただし、OCV ツールは画像ベースなので、西洋語ではないフォントもサポートすることができます。

  • サーチの信頼性

    OCVMax ツールは、Cognex PatMax テクノロジを使用して各文字列のサーチを行うため、連続した画像内において文字列の位置が変化する場合に、より高い信頼性で、各文字列を検出できます。

  • 歪み

    OCVMax ツールでは、OCV ツールで処理可能な画像間での文字の歪みよりも、はるかに大きな歪みを処理できます。

© 2005 Cognex Corporation.All rights reserved.


OCVMax ツールの使用

CogOCVMaxTool ツールは、「光学文字検証 (OCV)」を実行します。OCV は、画像内にある 1 つ以上の文字列が、各位置において、予測される文字を含んでいることを検証するためのプロセスです。ビジョンアプリケーションは、通常、OCV を使用して、製品またはパッケージに印刷された製造ロット番号、製造日、有効期限、およびそのほかの情報を検査します。例えば次の図は、7 × 7 ドットマトリックスフォントによって構成される文字列を検証するために、OCVMax ツールが使用された場合の画像の例を示します。

OCVMax エディットコントロール

OCVMax ツールは、OCVMax ツールの実験を行い、ビジョンアプリケーション用の最適な画像サーチパラメータおよび文字サーチパラメータを決定するためのエディットコントロールをサポートしています。ただし、このエディットコントロールは、OCVMax API のすべての機能をサポートするわけではありません。特に、このエディットコントロールは、複数文字列、および複数行文字列をサポートしません。また、多くのチューニング実行パラメータもサポートしません。このエディットコントロールの制限の詳細については、「OCVMax ツール」を参照してください。

アプリケーション例

次の手順では、OCVMax ツールを使用して画像データベースファイル内の文字を検証するアプリケーションを作成します。

  1. QuickStart.NET を起動します。

  2. 次の図に示すように、CogImageFile ツールを作成して、Cognex¥VisionPro¥Images¥TestDataBase.idb ファイル内の画像を読み込むように設定します。

  3. 次の図に示すように、CogOCVMax ツールを作成し、このツールに、Image File ツールからの OutputImage を与えます。

  4. Image File ツールを一度実行して、OCVMax ツールに入力画像を与えます。

  5. OCVMax ツールを開きます。OCVMax ツールが、次の図に示すように表示されます。

    この画像データベースファイル内の文字列には、Arial Bold フォントが使用されています。このフォントは、通常、ほとんどの PC の /WINDOWS/Fonts ディレクトリに格納されています。

    注: OCVMax エディットコントロールは、/WINDOWS/Fonts ディレクトリからフォントファイルを選択することはできません。このディレクトリからフォントを選択する必要がある場合は、最初にフォントファイルをほかのディレクトリにコピーして、エディットコントロールがそのフォントファイルを選択できるようにしてください。

  6. [Browse] をクリックして、/WINDOWS/Fonts ディレクトリからコピーした、任意のディレクトリにある Arial Bold のフォントファイルを選択します。

    選択すると、[Font] タブは次の図に示すように表示されます。

    ツールで検証するパラグラフを指定する前に、フォントのどの文字キーが文字列に対して有効かを選択する必要があります。デフォルトでは、このエディットコントロールは、どの文字キーも自動的には有効にしません。

  7. タブの [Selected Alphabet] セクションで、[Numbers] をクリックします。

    これにより、フォントのすべての数字が自動的に選択されます。選択したら、任意の数字までスクロールすることができ、次の図に示すように、その数字が選択された文字として表示されます。

  8. [Text] タブを選択します。

  9. 次の図に示すように、[Current.InputImage] ウィンドウに現在表示されている文字列に一致するように、文字列を入力します。

    OCVMax エディットコントロールは、ユーザが入力した文字列を表すグラフィックスを生成し、入力画像上にそのグラフィックスを配置します。

  10. [Adjust Position] をクリックし、次に、文字列を表すグラフィックスをクリックします。

    次の図に示すように、グラフィックスのサイズ変更、位置の変更、および回転を可能にするハンドルが表示されます。

  11. ハンドルを使用して、入力画像の文字列上にグラフィックスを配置し、文字列になるべく一致するようにグラフィックスを適合させます。

    グラフィックスを文字列に一致させるために、画像上でズームインしなければならない場合があります。次の図は、適用対象の文字列に厳密に一致した文字列グラフィックスを示しています。

  12. グラフィックスが文字列に問題なく一致したら、[Lock Position] をクリックします。

    [Rendering Parameters] を使用して、文字列を表すグラフィックスに間隔とスケールを追加することもできますが、この例の画像内の文字列には追加のパラメータは必要ありません。

  13. [Tune After Train] チェックボックスをチェックし、次に、[Train] をクリックして、この OCVMax ツールを、検証する文字列とともに登録します。チューニング機能は、Cognex PatMax テクノロジを使用して、各自由度について広範な値をテストし、検証する文字列と適用対象の画像例の間における最適な一致を決定します。

    チューニング動作が完了するまで、しばらく時間がかかる場合があります。完了すると、[Train] ボタンのラベルは [Untrain] になります。

  14. OCVMax ツールを実行し、画像ウィンドウを LastRun.InputImage に切り替えて、ツールが現在のサーチパラメータのセットを使用して文字列を検証するか確認します。

    ツールは、文字列中の各文字を検証できる必要があります。検証された各文字には、次の図に示すように、緑色のグラフィックスが使用されます。

    OCVMax ツールは、文字列中のすべての文字が検証されたかどうかにかかわらず、正常に実行されたことを報告することができます。前の図では、ツールは、すべての文字が検証されたことを報告しています。

  15. QuickStart.NET アプリケーション全体を繰り返し実行します。次の図に示すように、文字列中の最後の数字が変化した画像については、その文字は検証されないことがツールによって報告されます。

  16. アプリケーションの実行を継続します。次の画像ではすべての文字が検証されます。ツールの実行に要する時間に注意してください。次の例では、OCVMax は 155.41 ミリ秒で画像を解析しています。

  17. ツールの実行に要する時間を減らすには、まず、[Image Params] タブに切り替えます。

  18. [Search Mode] を [Postion +/- Shift] に切り替えます。

    デフォルトでは、ツールは、文字列を検出するために [Whole Image] モードを使用します。文字列が現れる位置は画像間で一貫しているため、[Position +/- Shift] モードに切り替えることによって、ツールの実行時間を改善することができます。

  19. 同じ画像に対して OCVMax ツールを再度実行します。

    ツールの実行に要する時間が大幅に減少します。例えば、次の図は、前の図で使用したのと同じ OCVMax ツールにより、画像の解析と文字列の検証が 76.67 ミリ秒で行われるようになったことを示しています。

  20. 最初の入力画像の文字列と比較して、該当の文字列の位置において、すべての可能なシフトを含むように、[X-Shift] および [Y-Shift] パラメータを増加させます。

    画像データベースファイルにあるすべての画像の文字列をツールが検出できるまで、[X-Shift] および [Y-Shift] のさまざまな値を使用して実験する必要がある可能性があります。パラメータの大きさが十分でなければ、次の図に示すように、グラフィックスの位置ずれが発生する場合があります。

  21. テストに基づいて、ほかのパラメータを調整する必要がある場合があります。例えば、次の図では、文字列の最後の文字「9」が間違って「3」として検証されています。

    [Results] タブを確認すると、次の図に示すように、最後の文字の一致スコアは「0.51」と表示されています。

    この問題を修正するには、[Character Params] タブに切り替えて、[Accept Threshold] を増加させます。この値を一致スコアよりも大きくすることによって、正しい結果が生成されます。特に、ツールは、次の図に示すように、文字列中の最後の位置にある文字「3」の検証に失敗します。

© 2005 Cognex Corporation.All rights reserved.


index

OCVMax プログラミングリファレンス

メインページ

このページは、OCVMax プログラミングリファレンスのメインページです。

完全なオンラインドキュメンテーションについては、VisionPro .NET マニュアルコレクション英語版を参照してください。

日本語オンラインマニュアルについて

このオンラインマニュアルは、日本における多くのユーザが、コグネックスの製品を使用するにあたって役立つように企画されたものです。

技術的に正確な訳となるよう努力いたしておりますが、原本とのバージョンの違いやリリース時期に完全には対応していない場合もありますので、この日本語オンラインマニュアルは参考資料としてご使用ください。

このオンラインマニュアルでは、グラフィカルインターフェースを英語版のまま説明しております。

内容に疑問が生じた場合は、英語の原本のオンラインマニュアルも併せてご参照ください。

不明な点については、弊社テクニカルサポートまでご連絡ください。

テクニカルサポートの連絡先は次のとおりです。

コグネックス株式会社

〒113-6591

東京都文京区本駒込 2-28-8 文京グリーンコート 23 階

サポートホットライン: 03-5977-5410 (月～金: 9:00 ～ 17:30)

E-mail: support.jp@cognex.com

© 2005 Cognex Corporation.All rights reserved.


ICogChangedEvent インタフェース

このインタフェースは、Changed イベント、および Changed イベントを一時停止したり再開したりするためのメソッドを含みます。

このタイプのメンバすべてのリストについては、「ICogChangedEvent メンバ」を参照してください。

Cognex.VisionPro.ICogChangedEvent
派生インタフェース

public interface ICogChangedEvent

ICogChangedEvent を実装するタイプ

タイプ | 説明
CogBarcode | Barcode 実行パラメータを含むクラスです。
CogBarcodeParamsCode128 | Code 128 パラメータを含むクラスです。
CogBarcodeParamsCode39 | Code 39 パラメータを含むクラスです。
CogBarcodeParamsCode93 | Code 93 パラメータを含むクラスです。
CogBarcodeParamsFourState | 4-ステートパラメータを含むクラスです。
CogBarcodeParamsI2Of5 | Interleaved 2 Of 5 パラメータを含むクラスです。
CogBarcodeParamsPlanet | PLANET パラメータを含むクラスです。
CogBarcodeParamsPostnet | POSTNET パラメータを含むクラスです。
CogBarcodeParamsRSS | RSS パラメータを含むクラスです。
CogBarcodeParamsUpcEan | UPC/EAN パラメータを含むクラスです。
CogBarcodeTool | 1 つ以上のシンボルを検出、デコードし、オプションでグレード付けも行うツールです。
CogBlob | ブロブ解析の設定および実行のためのクラスです。ブロブ実行時パラメータは、セグメンテーション、連結性、モフォロジィ、マスキング、フィルタリング、およびソートのための設定を含みます (ただし、これらに限定されません)。
CogBlobMeasure | 指定した計測値が、ブロブ解析の実行中に使用される方法を示すクラスです。ブロブ計測値は、フィルタ基準として使用されること、または、計測値の計算に要する時間がブロブ解析実行時間の一部となるようにあらかじめ計算されることが可能です。
CogBlobMeasureCollection | 指定した計測値が、ブロブ解析の実行中に使用される方法を示すコレクションです。ブロブ計測値は、フィルタ基準として使用されること、または、計測値の計算に要する時間がブロブ実行時間の一部となるようにあらかじめ計算されることが可能です。
CogBlobMorphologyCollection | 区分画像に対して実行されるモフォロジィ操作を示す CogBlobMorphologyConstants のコレクションです。操作は、コレクションに追加された順に実行されます。操作は複数回追加することが可能です。
CogBlobSegmentationParams | 画像セグメンテーションパラメータを保持するクラスです。ブロブ解析は、画像を対象物ピクセルと背景ピクセルに区分する多数のメソッドを提供します。このクラスのプライマリインタフェースは、セグメンテーションのメソッドをユーザが選択および設定することを可能にします。
CogBlobTool | これは、CogBlobTool のためのクラスです。CogBlobTool は、ブロブ解析検査を実行するために必要なすべてのクラスをカプセル化します。
CogCalibCheckerboard | CogCalibCheckerboard オブジェクトは、チェッカボードキャリブレーションプレートの画像を使用して、キャリブレーション後の座標空間を定義します。これは、キャリブレーション後の空間を画像に接続することを可能にします。また、その画像の非線形ワーピングも実行できます。
CogCalibCheckerboardRunParams | チェッカボードキャリブレーションのために必要な実行時パラメータです。このパラメータは、キャリブレーション後の空間の名前、キャリブレーション後の画像の選択空間を指定する列挙体、および非線形ワーピングの後で発生する可能性がある空のピクセルのための設定を含みます。
CogCalibCheckerboardTool | このツールは、チェッカボードプレートの画像を使用して、キャリブレーション後の空間を定義します。実行時に、このツールは、その入力画像を (場合によっては非線形ワーピングを介して) 出力画像に変換し、下流のツールによる使用のために、キャリブレーション後の空間を出力画像に接続します。
CogCalibNPointToNPoint | CogCalibNPointToNPoint オブジェクトは、N ペアの点を使用してキャリブレーション後の座標空間を定義します。また、ユーザがこの空間を画像に接続することを可能にします。
CogCalibNPointToNPointRunParams | N ポイントキャリブレーションのために必要な実行時パラメータです。このパラメータは、キャリブレーション後の空間の名前、およびキャリブレーション後の画像の選択空間を指定する列挙体を含みます。
CogCalibNPointToNPointTool | このツールは、N ペアの点を使用して、新しくキャリブレーションされた座標空間を定義します。実行時に、このツールは、キャリブレーション後の (調整済み) 空間を入力画像の座標ツリーに接続し、更新された画像を、下流のツールによる使用のために、出力として提供します。
CogFixture | このオブジェクトは、単純なフィクスチャのために必要なパラメータを保持します。このオブジェクトの Execute 関数は、指定された入力画像にフィクスチャ座標空間を接続し、更新された画像を、下流のツールによる使用のために、出力として提供します。
CogFixtureNPointToNPoint | CogFixtureNPointToNPoint オブジェクトは、N ペアの点を使用してフィクスチャ座標空間を定義します。また、ユーザがこの空間を画像に接続することを可能にします。
CogFixtureNPointToNPointTool | 実行時に、このツールは、N ペアの点を使用して、新しいフィクスチャ座標空間を定義します。このツールは、(調整済み) フィクスチャ空間を入力画像の座標ツリーに接続し、更新された画像を、下流のツールによる使用のために、出力として提供します。
CogFixtureTool | CogFixtureTool は、その入力画像にユーザ定義のフィクスチャ座標空間を接続し、更新された画像を、下流のツールによる使用のために、出力として提供します。
CogNPointToNPoint | CogNPointToNPoint オブジェクトは、一連の N 個の「グループ B」の点から一連の N 個の「グループ A」の点へのマッピングを行う、最適な (最小二乗誤差) 変換を計算します。
CogCaliper | エッジベースのキャリパオブジェクトです。
CogCaliperScorerContrast | 候補エッジのコントラストに得点を与える得点付け関数です。
CogCaliperScorerPosition | 候補エッジまたはエッジペアの絶対位置を使用する得点付け関数です。
CogCaliperScorerPositionNeg | 候補エッジまたはエッジペアの位置を使用する得点付け関数です。負の値が許可されています。
CogCaliperScorerPositionNorm | 候補エッジまたはエッジペアの正規化された絶対位置を使用する得点付け関数です。
CogCaliperScorerPositionNormNeg | エッジペアの正規化された位置を使用する得点付け関数です。負の値が許可されています。
CogCaliperScorers | キャリパ得点付け関数のコレクションです。
CogCaliperScorerSizeDiffNorm | エッジペアの候補サイズとエッジペアの予想されるサイズの差の正規化されたサイズを使用する得点付け関数です。
CogCaliperScorerSizeDiffNormAsym | エッジペアの正規化されたサイズを、両側をマッピングして使用する得点付け関数です。
CogCaliperScorerSizeNorm | エッジペアの正規化されたサイズを使用する得点付け関数です。
CogCaliperScorerStraddle | 候補エッジペアが、検出された位置をまたがっている場合は 1 を、それ以外の場合は 0 を返します。
CogCaliperTool | エッジベースの Caliper ツールです。
CogFindCircle | 円検出の実行パラメータを含むクラスです。
CogFindCircleTool | 一連のキャリパによって検出された最高得点のエッジ点をフィットさせることにより、指定された画像内の円を検出するツールです。このツールには、円検出検査を実行するために必要なすべてのインタフェースが含まれています。
CogFindLine | ライン検出の実行パラメータを含むクラスです。
CogFindLineTool | 一連のキャリパによって検出された最高得点のエッジ点をフィットさせることにより、指定された画像内の直線を検出するツールです。このツールには、線検出検査を実行するために必要なすべてのインタフェースが含まれています。
CogCNLSearchPattern | 画像内に含まれる特徴の検出に使用される CNLSearch パターンを 1 つ保持するクラスです。プライマリインタフェースは、登録パラメータ、パターン登録のためのメソッド、パターン登録の結果、および検査を実行するためのメソッドへのアクセスを提供します。
CogCNLSearchRunParams | CNLSearch 実行パラメータを保持するクラスです。この実行パラメータは、実行時画像内の一致するパターンを CNLSearch が検出する方法を制御するために使用されます。
CogCNLSearchTool | CNLSearch パターンを使用して特徴を検出するツールです。このツールには、CNLSearch 検査を実行するために必要なすべてのクラスが含まれています。
CogAcqFifoTool | フレームグラバ上で取り込み FIFO を使用して画像を取り込むツールです。
CogCADFile | GetShape メソッドを使用して形状のコレクションを取得するために、CAD ファイルを読み取るクラスで、オプションで、開いている形状を、より長い輪郭に接続できます。このメソッドを使用する前に、ファイルが開いている必要があります。スプラインはすべて概算されます。
CogCircle | 円を表すクラスです。
CogCircularAnnulusSection | 真円の円環セクションは、2 つの円弧と 2 本の放射状の直線で囲まれた、4 つの辺を持つ形状です。これらの円弧は互いに相似形です。「開始」円弧を指定し、次に、「終了」円弧を定義する RadialScale を指定します。
CogCircularArc | 円弧は円の一部です。この形状を指定するには、通常の円パラメータのほか、さらに、AngleStart と AngleSpan の 2 つのパラメータも使用します。AngleStart は円弧の開始角度を、AngleSpan は円弧の角度範囲を定義します。
CogCompositeShape | 合成形状を表すクラスです。合成形状は、多数の子形状から構成されます。
CogCoordinateAxes | 1 対の座標軸を表すクラスです。
CogCoordinateSpaceTree | ユーザ座標空間およびその間のマッピングのツリーです。
CogDataAnalysis | 一連のデータ解析チャネルにわたって許容値設定、統計解析、およびデータ値のバッファリングを行うオブジェクトです。
CogDataAnalysisTool | CogDataAnalysisTool は、一連のデータ解析チャネルにわたって許容値設定、統計解析、およびデータのバッファリングを行うために必要な、すべてのオブジェクトをカプセル化します。
CogDataBinding | このクラスは、オブジェクトまたはそのサブオブジェクトの 1 つの、入力プロパティの結合を表します。
CogDataBindingsCollection | 変更が行われた場合にイベントを発生させる CogDataBinding オブジェクトの、順序付きコレクションです。
CogDictionary | キー - 値ペアの順序なしコレクションを格納し、変更が行われた場合はイベントを発生させる、コンテナです。
CogEllipse | 楕円を表すクラスです。
CogEllipticalAnnulusSection | 楕円の円環セクションは、2 つの楕円弧と 2 本の直線で囲まれた、4 つの辺を持つ形状です。これらの円弧は互いに相似形です。「開始」円弧を指定し、次に、「終了」円弧を定義する RadialScale を指定します。
CogEllipticalArc | 楕円弧は楕円の一部です。この形状を指定するには、通常の楕円パラメータのほか、AngleStart と AngleSpan の 2 つのパラメータも使用します。AngleStart は円弧の開始角度を、AngleSpan は円弧の角度範囲を定義します。
CogFitCircle | 一連の点に、円をフィット処理するクラスです。
CogFitCircleTool | 一連の点に、円をフィット処理するツールです。
CogFitEllipse | 一連の点に、楕円をフィット処理するクラスです。
CogFitEllipseTool | 一連の点に、楕円をフィット処理するツールです。
CogFitLine | 一連の点に、線をフィット処理するクラスです。
CogFitLineTool | 一連の点に、線をフィット処理するツールです。
CogGeneralContour | 一般的な輪郭は、輪郭の「始点」から「終点」に向かって順番に連続して並ぶ有向直線および円弧の切片から構成される形状です。形状を構築するには、切片を追加し、各切片の幾何計測値および始点/終点の連結性を指定します。
CogGraphicChildren | 子グラフィックスのコレクションです。
CogGraphicCollection | グラフィックスのコレクションです。
CogGraphicInteractiveCollection | 対話型グラフィックスのコレクションです。
CogGraphicLabel | グラフィカルテキストラベルを表すクラスです。
CogImage24PlanarColor | 8 ビットピクセルの 3 つの重なる矩形配列 (つまり平面) を記述するオブジェクトです。
CogImage8Grey | 8 ビットグレースケールピクセルの矩形配列を記述するオブジェクトです。
CogInputLine | ディスクリート入力ラインのための仮想 (作成可能ではない) クラスです。
CogLine | 直線を表すクラスです。
CogLineSegment | 線分を表すクラスです。
CogMaskGraphic | マスクグラフィックスを表すクラスです。
CogOutputLine | ディスクリート出力ラインのための仮想 (作成可能ではない) クラスです。
CogPointMarker | グラフィカル点マーカを表すクラスです。
CogPolygon | ポリゴンを表すクラスです。
CogPropertyWatcher | このクラスは、オブジェクトのプロパティまたはサブプロパティを監視して、プロパティの値が変化した場合に Changed イベントを発生させます。
CogRectangle | 矩形を表すクラスです。
CogRectangleAffine | アフィン矩形を表すクラスです。
CogRLEBuffer | 画像のランレングスエンコード表現を保持するクラスです。
CogShapeExtract | 形状抽出オペレータは、画像から輪郭を抽出するのに使用されます。各輪郭は、輪郭の幾何計測値と極性を記述する形状モデルに変換されます。フィルタ処理され、ランク付けされた形状モデルのコレクションが返されます。
CogShapeModelCollection | CogShapeModel オブジェクトのコレクションです。
CogShapePolarize | 形状極性付与オペレータは、画像データに基づいて形状に沿って極性情報を決定するのに使用します。極性情報は、形状境界のどちら側が明るくどちら側が暗いかを示します。
CogStatistics | 統計情報を計算し、許容値の結果を生成するために連続値をバッファ処理するオブジェクトです。スタンドアローンで使用するためのもので、CogDataAnalysisTool と連動して使用するものではありません。
CogStringCollection | 文字列のコレクションです。
CogToolCollection | 変更が加えられるたびにイベントを発生させる VisionPro ツールの順序付きコレクションです。
CogTransform2DComposed | CogTransform2DComposed は、異なるタイプの変換を合成することのできる変換オブジェクトです。合成された変換は、それに含まれるすべての変換を介して (「右」から「左」へ) 点をマッピングします。このマッピングによって、その変換の合成として動作します。
CogTransform2DLinear | 線形 2D 座標変換です。
CogTransform2DPerspectiveAndRadial | CogTransform2DPerspectiveAndRadial 変換は、平面遠近変換と、それに続く放射状変換、さらにそれに続く線形変換 (回転なし) で構成されます。この変換は、カメラの設定で一般的な非線形効果を補正するために使用できます。
CogAngleLineLineTool | 2 本の直線の間の角度を計測するツールです。
CogAnglePointPointTool | 2 つの点の間の角度を計測するツールです。
CogCreateCircleTool | 円を作成するツールです。
CogCreateEllipseTool | 楕円を作成するツールです。
CogCreateLineBisectPointsTool | 2 点を結ぶ線分の垂直二等分線になる直線を作成するツールです。
CogCreateLineParallelTool | 指定された直線に平行で指定された点を通る直線を作成するツールです。
CogCreateLinePerpendicularTool | 指定された直線に垂直で指定された点を通る直線を作成するツールです。
CogCreateLineTool | 直線を作成するツールです。
CogCreateSegmentAvgSegsTool | 指定された 2 本の線分を平均することによって、線分を作成するツールです。
CogCreateSegmentTool | 線分を作成するツールです。
CogDistanceCircleCircleTool | 2 つの円の間の距離を計測するツールです。
CogDistanceLineCircleTool | 直線と円の間の距離を計測するツールです。
CogDistanceLineEllipseTool | 直線と楕円の間の距離を計測するツールです。
CogDistancePointCircleTool | 点から円までの距離を計測するツールです。
CogDistancePointEllipseTool | 点と楕円の間の距離を計算するツールです。
CogDistancePointLineTool | 点と直線の間の距離を計測するツールです。
CogDistancePointPointTool | 指定された 2 点間の距離と角度を計算するツールです。
CogDistancePointSegmentTool | 点から線分までの距離を計測するツールです。
CogDistanceSegmentCircleTool | 線分から円までの距離を計測するツールです。
CogDistanceSegmentEllipseTool | 線分と楕円の間の距離を計測するツールです。
CogDistanceSegmentLineTool | 線分から直線までの距離を計測するツールです。
CogDistanceSegmentSegmentTool | 2 本の線分間の距離を計測するツールです。
CogIntersectCircleCircleTool | 2 つの円の交点を求めるツールです。
CogIntersectLineCircleTool | このオブジェクトについてのヘルプはまだありません。
CogIntersectLineEllipseTool | 直線と楕円の交点を求めるツールです。
CogIntersectLineLineTool | 2 本の直線の交点を求めるツールです。
CogIntersectSegmentCircleTool | 線分と円の交点を求めるツールです。
CogIntersectSegmentEllipseTool | 線分と楕円の交点を求めるツールです。
CogIntersectSegmentLineTool | 線分と直線の交点を求めるツールです。
CogIntersectSegmentSegmentTool | 2 本の線分の交点を求めるツールです。
CogAcqFifo1394DCAM | このオブジェクトは、CogFrameGrabber1394DCAM クラスからのみ作成できます。
CogAcqFifo8100 | このオブジェクトは、CogFrameGrabber8100 クラスからのみ作成できます。
CogAcqFifo8100D | このオブジェクトは、CogFrameGrabber8100d クラスからのみ作成できます。
CogAcqFifo8100L | このオブジェクトは、CogFrameGrabber8100l クラスからのみ作成できます。
CogAcqFifo8120 | このオブジェクトは、CogFrameGrabber8120 クラスからのみ作成できます。
CogAcqFifo8501 | このオブジェクトは、CogFrameGrabber8501 クラスからのみ作成できます。
CogAcqFifo8504 | このオブジェクトは、CogFrameGrabber8504 クラスからのみ作成できます。
CogAcqFifo8600 | このオブジェクトは、CogFrameGrabber8600 クラスからのみ作成できます。
CogImageFile | 画像ファイルへのアクセスをサポートするオブジェクトです。
CogImageFileBMP | .bmp ファイルへのアクセスをサポートするオブジェクトです。
CogImageFileCDB | .cdb /.idb ファイルへのアクセスをサポートするオブジェクトです。
CogImageFileTIFF | .tif ファイルへのアクセスをサポートするオブジェクトです。
CogImageFileTool | 画像ファイルツールです。
CogAffineTransform | CogRectangleAffine によって定義された画像の一部を、新しい矩形画像に変換するクラスです。
CogAffineTransformTool | CogRectangleAffine によって定義された画像の一部を、新しい矩形画像に変換するツールです。
CogCopyRegion | ピクセルの領域をデスティネーション画像にコピーするクラスです。
CogCopyRegionTool | ピクセルの領域をデスティネーション画像にコピーするツールです。
CogHistogram | ヒストグラムを生成するクラスです。
CogHistogramTool | 1 つの入力画像からヒストグラムを生成するツールです。
CogImageAverage | 画像平均処理の実行パラメータを含むクラスです。
CogImageAverageTool | 画像平均を実行するツールです。
CogImageConvertRunParams | このクラスは、CogImageConvertTool::Run メソッドによって使用される実行時パラメータをカプセル化します。
CogImageConvertTool | 主として特定のカラーフォーマットから特定の非カラーフォーマットに、画像を変換するツールです。
CogImageSharpness | 画像鮮鋭度処理の実行パラメータを含むクラスです。
CogImageSharpnessTool | 画像鮮鋭度を計算するツールです。
CogIPOneImageAddSubtractConstant | 画像に対して定数値を加算または減算するクラスです。
CogIPOneImageConvolve3x3 | 画像に対して 3 × 3 畳み込みを実行するクラスです。
CogIPOneImageEqualize | 画像に対してヒストグラム平坦化操作を実行するクラスです。平坦化とは、ヒストグラムの積分によって画像を再マッピングすることです。
CogIPOneImageExpand | X および Y 方向に画像のピクセルを複製することによって画像のサイズを拡大するクラスです。
CogIPOneImageFlipRotate | 反転と回転の両方またはどちらかを画像に適用するクラスです。
CogIPOneImageGaussSampler | 2 次元ガウス分布を近似する画像に、カーネルを適用するクラスです。このカーネルのサイズを変えることによって、ノイズの強度を低下させたり、特定のサイズを下回る画像特徴を減衰させたりすることができます。
CogIPOneImageGreyMorphology | 画像に対してグレースケールモフォロジィ操作を実行するクラスです。
CogIPOneImageGreyMorphology3x3Element | グレーモフォロジィ要素を保持するクラスです。各要素は、プライマリエレメントを生成するために CogIPOneImageGreyMorphology オブジェクトによって使用される、3 × 3 マトリックスです。
CogIPOneImageGreyMorphology3x3Elements | 3 × 3 グレーモフォロジィ要素のコレクションです。各グレーモフォロジィ要素は、モフォロジィ操作でプライマリエレメントの構成に使用される 3 × 3 マトリックスです。
CogIPOneImageHighPassFilter | 画像に対してハイパスフィルタリングを実行するクラスです。ハイパス操作は、入力画像から、ガウスフィルタをかけた入力画像を減算することによって実行されます。
CogIPOneImageMedian3x3 | 画像に対して 3 × 3 メジアン操作を実行するクラスです。3 × 3 メジアンフィルタは、ソースピクセルをソースピクセルを中心とする 3 × 3 近傍のメジアン値に差し替えます。
CogIPOneImageMultiplyConstant | 画像のピクセル値に定数値を乗算するクラスです。
CogIPOneImageOperators | 1 つの画像用オペレータのコレクションです。
CogIPOneImagePixelMap | このクラスは、ユーザが定義したマップを使用して画像の全ピクセルを変換します。デフォルトでは、このクラスは等価マップを作成します。
CogIPOneImageQuantize | 量子化を実行して、画像の情報の維持を試みつつ、画像に含まれるグレーレベルの数を減らすクラスです。この操作は、画像の少数の輝度によって容易に記述されるシーンで便利です。
CogIPOneImageSubSampler | SampleX と SampleY で指定されたブロックによって画像のピクセルをサブサンプリングして、サイズを縮小した画像を生成するクラスです。SpatialAverage が有効にされている場合、選択されたピクセルは各ブロックの中央または平均ピクセル値に最も近くなります。
CogIPOneImageTool | 1 つの入力画像に対して適用され、 1 つの出力画像を生成するツールです。
CogIPTwoImageAdd | 2 つの画像を加算して新しい画像を生成するクラスです。
CogIPTwoImageAddTool | 2 つの入力画像を加算して 1 つの出力画像を生成するツールです。
CogIPTwoImageMinMax | 2 つの入力画像の最小または最大ピクセルに基づいて画像を生成するクラスです。
CogIPTwoImageMinMaxTool | 2 つの画像から取得した最小ピクセル値または最大ピクセル値に基づいて新しい画像を生成するツールです。
CogIPTwoImageSubtract | ある画像を別の画像から減算して新しい画像を生成するクラスです。具体的には、InputImageB を InputImageA から減算して新しい画像を生成します。
CogIPTwoImageSubtractTool | InputImageB を InputImageA から減算して 1 つの出力画像を生成するツールです。
CogPolarUnwrap | 環状のピクセル領域をデスティネーション画像に伸ばすクラスです。
CogPolarUnwrapTool | 環状のピクセル領域を矩形のデスティネーション画像に伸ばすツールです。
CogSobelEdge | ソベルエッジ処理の実行パラメータを含むクラスです。
CogSobelEdgeTool | ソベルエッジ検出を実行するツールです。オプションで、ピクセル全体のピーク検出またはヒステリシスの 2 値化を後処理として実行できます。
CogChangedEventBase | ICogChangedEvent インタフェースを実装する基底クラスです。このクラスから派生したオブジェクトは、オブジェクトの部分の状態が変化すると Changed イベントを発生させます。
CogChangedEventComponentBase | ICogChangedEvent インタフェースを実装するコンポーネントの基底クラスです。このクラスから派生したオブジェクトは、オブジェクトの部分の状態が変化すると Changed イベントを発生させます。
CogCollectionBase | 変更が行われた場合にイベントを発生させる値の、汎用順序付きコレクションの基底クラスです。
CogRecord | ツールの状態についての情報を保持するクラスです。
CogRecords | CogRecord オブジェクトのコレクションを保持するクラスです。
CogRunStatus | このクラスは、ICogRunStatus インタフェースの実装を提供します。
CogSerializableChangedEventBase | ICogChangedEvent インタフェースを実装するコンポーネントの基底クラスです。このクラスから派生したオブジェクトは、オブジェクトの部分の状態が変化すると Changed イベントを発生させます。
CogSerializableChangedEventComponentBase | ICogChangedEvent インタフェースを実装するコンポーネントの基底クラスです。このクラスから派生したオブジェクトは、オブジェクトの部分の状態が変化すると Changed イベントを発生させます。
CogSerializableCollectionBase | 変更が行われた場合にイベントを発生させる値の、シリアル化可能な汎用順序付きコレクションの基底クラスです。
CogSerializableDictionaryBase | 変更が行われた場合にイベントを発生させる、キー - 値ペアの汎用順序なしコレクションの基底クラスです。
CogToolBase | ICogTool インタフェースを実装する基底クラスです。ツールは ICogTool インタフェースをほかの方法で実装することもでき、このクラスから派生する必要はありません。
CogChangedEventFunnel |
CogModelFeatureIteratorGC | この形状モデル繰り返し指定子オブジェクトは、CogGeneralContour 形状モデルの CreateSubFeatureIterator メソッドを使用してのみ作成できます。
CogShapeModelCircle | この形状モデルオブジェクトは、CogCircle の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelEllipse | この形状モデルオブジェクトは、CogEllipse の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelEllipticalArc | この形状モデルオブジェクトは、CogEllipticalArc の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelGeneralContour | この形状モデルオブジェクトは、CogGeneralContour の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelLine | この形状モデルオブジェクトは、CogLine の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelLineSegment | この形状モデルオブジェクトは、CogLineSegment の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelPolygon | この形状モデルオブジェクトは、CogPolygon の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelPropCollection | CogShapeModel オブジェクトのコレクションです。このコレクションは、含まれる形状モデルオブジェクトからの変更イベントを、ICogEventInfo インタフェースを使用して伝播します。
CogShapeModelRectangleAffine | この形状モデルオブジェクトは、CogRectangleAffine の MakeShapeModel メソッドを使用してのみ作成できます。
CogUserTool | ほかのツールのコレクションを持つツールの、基底クラスです。
CogOCFont | このクラスのデフォルトインタフェースは、光学文字フォントのプロパティ、Compile メソッド、Uncompile メソッド、およびフォントをコンパイルした結果へのアクセスを提供します。
CogOCFontModel | 光学文字フォントモデルのプロパティへのアクセスを提供します。このフォントモデルは、文字の存在を調べるのに使用するノーマルなフォントモデルでも、文字が一切存在しないことを調べるのに使用するブランクのフォントモデルでもかまいません。
CogOCFontModels | 光学文字フォントモデルのコレクションです。
CogOCVCharacterPosition | このクラスのデフォルトインタフェースは、文字位置パラメータへのアクセスを提供します。検証する文字モデル、それらの文字モデルの予想位置と位置不確定度、およびそれらの文字モデルのアクセプトしきい値と信頼性しきい値を指定することができます。
CogOCVCharacterPositions | OCV で検証する文字位置のコレクションです。文字位置は、コレクション内でリストされている順に検証されます。例外はブランクのモデルで、これは非ブランクのモデルの検証がすべて終わった後にのみ検証されます。
CogOCVPattern | OCV パターンのプロパティ、およびそのパターンの登録結果へのアクセスを提供します。パターンは、Execute メソッドを呼び出すことによって行われる OCV 検査を実行する前に、Train メソッドを介して登録されている必要があります。
CogOCVPatternPosition | デフォルトインタフェースは、実行時のパターン予想位置、および予想位置の不確定度を設定するプロパティへのアクセスを提供します。パターン内の文字位置は、パターンの予想位置に対して相対的に指定されます。
CogOCVTool | 画像内の文字パターンの検証に使用できる光学文字検証 (OCV) ツールです。このツールには、OCV 検査を実行するために必要なすべてのクラスが含まれています。
CogOCVMaxFont | このクラスは、1 つのフォントに関連付けられた幾何学文字ディスクリプションのセットを表します。幾何学ディスクリプションデータは、定義済みのフォントファイルから読み取ります。通常、ユーザはフォントファイルを作成しません。ただし、サイズや行間隔など、特定のフォント特性を調整することは可能です。
CogOCVMaxFontRenderParams | このクラスは、特定のフォントでのテキストの描画、または描画ベースの処理を制御するために通常使用される、プロパティをカプセル化します。これらのプロパティは、CogOCVMaxFont と、カメラで実際に観察されるものの間の対応付けを微調整することを可能にします。
CogOCVMaxPattern | このクラスは、Cognex.VisionPro.OCVMax アセンブリの主力となるものであり、実際の光学文字検証を実行します。このクラスには、登録パラメータと登録状態情報が含まれます。このクラスまたは CogOCVMaxTool ツールを使用すると、文字検証を実行することができます。 登録が必要なほかのビジョンツールとは異なり、OCVMax では、登録画像も登録領域も使用されません。このクラスの登録は、CogOCVMaxFont によって、人工的に生成された画像に基づきます。
CogOCVMaxPoseHelper | このクラスは、テキスト文字列のポーズを定義する際のサポートを提供します。一般的な使用モデルでは、ユーザが a) 対象となっている実際のテキストを描いた画像、b) フォントオブジェクト、c) テキスト (1 つ以上の文字列) を保持していること、および、ユーザがこれらからポーズ (CogOCVMax オペレータまたはツールは、このポーズにおいて画像処理を行う可能性がある) を決定したいと考えていることが前提となっています。次の 5 つの基本的な手順があります。第 1 に、Font および Text プロパティを設定することによって (およびオプションで、FontRenderParams プロパティを変更することによって)、CogOCVMaxPoseHelper オブジェクトを設定します。第 2 に、InitialPoseEstimate() メソッドを呼び出して、望ましいポーズがどのようなものであるかについて、最初の推測を行います。第 3 に、FinalPosePrepare() メソッドを呼び出して、推測された初期ポーズを使用して CogCompositeShape グラフィックスを作成します。第 4 に、グラフィックスを対話型ディスプレイに追加して、このグラフィックスの位置、回転、サイズ、スケール、またはスキューをユーザがダイナミックに調整可能にすることで、グラフィックスを画像内の対応するテキストにスーパーインポーズできるようにします。第 5 に、FinalPoseComplete() メソッドを、(ユーザが変更した) CogCompositeShape グラフィックスとともに呼び出します。最後の手順により、ユーザが指定したポーズを記述する CogTransform2DLinear が得られます。
CogOCVMaxRunParams | このクラスは、CogOCVMaxPattern::Execute メソッドによって使用される実行時パラメータをカプセル化します。
CogOCVMaxSearchParams | このクラスは、配置サーチと文字サーチの両方またはどちらかを実行するために使用されるすべてのパラメータをカプセル化します。
CogOCVMaxTool | このクラスは、CogOCVMaxPattern オペレータへのツールレベルのアクセスを提供します。このクラスは、OCVMax 検査を実行するために必要なすべてのクラスをカプセル化します。
CogOCVMaxTuneParams | このクラスは、CogOCVMaxPattern オブジェクトをチューニングするために使用されるプロパティをカプセル化します。
CogPatInspectPattern | 登録時パラメータへの、および PatInspect パターンの登録結果へのアクセスを提供します。パターンは、Execute メソッドを呼び出すことによって行われる検査を実行する前に、Train メソッドを介して登録されている必要があります。
CogPatInspectRunParams | PatInspect 実行時パラメータへのアクセスを提供します。実行時パラメータは、PatInspect 検査の実行方法、および PatInspect の結果の一部としてどのようなデータが生成されるかを指定するために使用されます。
CogPatInspectTool | PatInspect ツールは、入力画像の希望する領域を、ツールのパターン内に格納されたテンプレート画像と比較することによって、欠陥を検出するために使用できます。テンプレート画像は、欠陥を含まない 1 つ以上の良好な画像から登録できます。
CogPMAlignPattern | 画像内に含まれる特徴の検出に使用される PMAlign パターンを 1 つ保持するクラスです。プライマリインタフェースは、登録パラメータ、パターン登録のためのメソッド、パターン登録の結果、および検査を実行するためのメソッドへのアクセスを提供します。
CogPMAlignRunParams | PMAlign 実行パラメータを保持するクラスです。この実行パラメータは、実行時画像内の一致するパターンを PMAlign が検出する方法を制御するために使用されます。
CogPMAlignTool | PMAlign パターンを使用して特徴を検出するツールです。このツールには、PMAlign 検査を実行するために必要なすべてのクラスが含まれています。
CogPMAlignZoneAngle | 角度の自由度 (DOF) 情報を保持するクラスです。PMAlign は、登録パターンから角度が変更されたパターンを検出することができます。このクラスは、パターンの配置角度を表します。
CogPMAlignZoneScale | スケールの自由度 (DOF) 情報を保持するクラスです。PMAlign は、登録パターンからスケールが変更されたパターンを検出することができます。このクラスは、パターンの配置スケールを表します。
CogJob | CogJob クラスは QuickBuild の作業単位です。画像取り込み FIFO とビジョンツールのコレクションで構成されています。各 CogJob は個別のカメラチャネルに関連付けられており、カメラチャネルからビジョンツールに画像が提供され、処理されます。
CogJobManager | CogJobManager クラスは QuickBuild のトップレベルのクラスです。CogJob のグローバル情報の管理と提供を行います。
CogInputImageTool | CogInputImageTool。内部でのみ使用されます。
CogProxyObject | ProxyObject。内部でのみ使用されます。
CogToolGroup | 一連の VisionPro ツールを含む VisionPro ツールです。CogToolGroup を実行すると、CogToolGroup に含まれる各ツールが暗黙的に実行されます。CogToolGroup の実行状態とレコードは、CogToolGroup に含まれるすべてのツールの集計に基づきます。
Cog2DSymbolPattern | 画像内のシンボルのデコードに使用される 2D シンボルパターンを 1 つ保持するクラスです。登録パラメータ、パターン登録のためのメソッド、パターン登録の結果、および検出とデコードの操作を実行するためのメソッドへのアクセスを提供します。
Cog2DSymbolRunParams | 2D シンボルデコードのパラメータを格納するオブジェクトです。Cog2DSymbolPattern::Execute が正常にシンボルを検出およびデコードするために必要なパラメータを指定します。
Cog2DSymbolTool | データマトリックスまたは QR コードシンボルをデコードする 2D シンボルツールです。ツールは最初登録されていないので、シンボルをデコードする前に登録が必要です。
Cog2DSymbolVerify | 2D シンボル検証の実行パラメータを含むクラスです。
Cog2DSymbolVerifyTool | 2D シンボル検証を実行するツールです。
CogPDF417 | PDF417 デコードを実行するオペレータです。プライマリインタフェースは、RegionMode パラメータ、Timeout パラメータ、および検出とデコードの操作を実行するメソッドへのアクセスを提供します。
CogPDF417Tool | PDF417 Stacked バーコードシンボルを検出してデコードするツールです。結果オブジェクトを介して結果を返します。PDF417 シンボルツールは、エンコードされた情報を画像から直接検出することができます。そのため、デコードの前に学習段階を必要としません。

必要条件

名前空間: Cognex.VisionPro

アセンブリ: Cognex.VisionPro (Cognex.VisionPro.dll 内)

参照

ICogChangedEvent メンバ | Cognex.VisionPro 名前空間

このページへのコメント。

Copyright © 2005 Cognex Corporation


ICogHasChanged インタフェース

変更可能、シリアル化可能なオブジェクトの HasChanged プロパティに対するインタフェースです。

このタイプのメンバすべてのリストについては、「ICogHasChanged メンバ」を参照してください。

public interface ICogHasChanged

ICogHasChanged を実装するタイプ

タイプ | 説明
CogBarcode | Barcode 実行パラメータを含むクラスです。
CogBarcodeParamsCode128 | Code 128 パラメータを含むクラスです。
CogBarcodeParamsCode39 | Code 39 パラメータを含むクラスです。
CogBarcodeParamsCode93 | Code 93 パラメータを含むクラスです。
CogBarcodeParamsFourState | 4-ステートパラメータを含むクラスです。
CogBarcodeParamsI2Of5 | Interleaved 2 Of 5 パラメータを含むクラスです。
CogBarcodeParamsPlanet | PLANET パラメータを含むクラスです。
CogBarcodeParamsPostnet | POSTNET パラメータを含むクラスです。
CogBarcodeParamsRSS | RSS パラメータを含むクラスです。
CogBarcodeParamsUpcEan | UPC/EAN パラメータを含むクラスです。
CogBarcodeTool | 1 つ以上のシンボルを検出、デコードし、オプションでグレード付けも行うツールです。
CogBlob | ブロブ解析の設定および実行のためのクラスです。ブロブ実行時パラメータは、セグメンテーション、連結性、モフォロジィ、マスキング、フィルタリング、およびソートのための設定を含みます (ただし、これらに限定されません)。
CogBlobMeasure | 指定した計測値が、ブロブ解析の実行中に使用される方法を示すクラスです。ブロブ計測値は、フィルタ基準として使用されること、または、計測値の計算に要する時間がブロブ解析実行時間の一部となるようにあらかじめ計算されることが可能です。
CogBlobMeasureCollection | 指定した計測値が、ブロブ解析の実行中に使用される方法を示すコレクションです。ブロブ計測値は、フィルタ基準として使用されること、または、計測値の計算に要する時間がブロブ実行時間の一部となるようにあらかじめ計算されることが可能です。
CogBlobMorphologyCollection | 区分画像に対して実行されるモフォロジィ操作を示す CogBlobMorphologyConstants のコレクションです。操作は、コレクションに追加された順に実行されます。操作は複数回追加することが可能です。
CogBlobSegmentationParams | 画像セグメンテーションパラメータを保持するクラスです。ブロブ解析は、画像を対象物ピクセルと背景ピクセルに区分する多数のメソッドを提供します。このクラスのプライマリインタフェースは、セグメンテーションのメソッドをユーザが選択および設定することを可能にします。
CogBlobTool | これは、CogBlobTool のためのクラスです。CogBlobTool は、ブロブ解析検査を実行するために必要なすべてのクラスをカプセル化します。
CogCalibCheckerboard | CogCalibCheckerboard オブジェクトは、チェッカボードキャリブレーションプレートの画像を使用して、キャリブレーション後の座標空間を定義します。これは、キャリブレーション後の空間を画像に接続することを可能にします。また、その画像の非線形ワーピングも実行できます。
CogCalibCheckerboardRunParams | チェッカボードキャリブレーションのために必要な実行時パラメータです。このパラメータは、キャリブレーション後の空間の名前、キャリブレーション後の画像の選択空間を指定する列挙体、および非線形ワーピングの後で発生する可能性がある空のピクセルのための設定を含みます。
CogCalibCheckerboardTool | このツールは、チェッカボードプレートの画像を使用して、キャリブレーション後の空間を定義します。実行時に、このツールは、その入力画像を (場合によっては非線形ワーピングを介して) 出力画像に変換し、下流のツールによる使用のために、キャリブレーション後の空間を出力画像に接続します。
CogCalibNPointToNPoint | CogCalibNPointToNPoint オブジェクトは、N ペアの点を使用してキャリブレーション後の座標空間を定義します。また、ユーザがこの空間を画像に接続することを可能にします。
CogCalibNPointToNPointRunParams | N ポイントキャリブレーションのために必要な実行時パラメータです。このパラメータは、キャリブレーション後の空間の名前、およびキャリブレーション後の画像の選択空間を指定する列挙体を含みます。
CogCalibNPointToNPointTool | このツールは、N ペアの点を使用して、新しくキャリブレーションされた座標空間を定義します。実行時に、このツールは、キャリブレーション後の (調整済み) 空間を入力画像の座標ツリーに接続し、更新された画像を、下流のツールによる使用のために、出力として提供します。
CogFixture | このオブジェクトは、単純なフィクスチャのために必要なパラメータを保持します。このオブジェクトの Execute 関数は、指定された入力画像にフィクスチャ座標空間を接続し、更新された画像を、下流のツールによる使用のために、出力として提供します。
CogFixtureNPointToNPoint | CogFixtureNPointToNPoint オブジェクトは、N ペアの点を使用してフィクスチャ座標空間を定義します。また、ユーザがこの空間を画像に接続することを可能にします。
CogFixtureNPointToNPointTool | 実行時に、このツールは、N ペアの点を使用して、新しいフィクスチャ座標空間を定義します。このツールは、(調整済み) フィクスチャ空間を入力画像の座標ツリーに接続し、更新された画像を、下流のツールによる使用のために、出力として提供します。
CogFixtureTool | CogFixtureTool は、その入力画像にユーザ定義のフィクスチャ座標空間を接続し、更新された画像を、下流のツールによる使用のために、出力として提供します。
CogNPointToNPoint | CogNPointToNPoint オブジェクトは、一連の N 個の「グループ B」の点から一連の N 個の「グループ A」の点へのマッピングを行う、最適な (最小二乗誤差) 変換を計算します。
CogCaliper | エッジベースのキャリパオブジェクトです。
CogCaliperScorerContrast | 候補エッジのコントラストに得点を与える得点付け関数です。
CogCaliperScorerPosition | 候補エッジまたはエッジペアの絶対位置を使用する得点付け関数です。
CogCaliperScorerPositionNeg | 候補エッジまたはエッジペアの位置を使用する得点付け関数です。負の値が許可されています。
CogCaliperScorerPositionNorm | 候補エッジまたはエッジペアの正規化された絶対位置を使用する得点付け関数です。
CogCaliperScorerPositionNormNeg | エッジペアの正規化された位置を使用する得点付け関数です。負の値が許可されています。
CogCaliperScorers | キャリパ得点付け関数のコレクションです。
CogCaliperScorerSizeDiffNorm | エッジペアの候補サイズとエッジペアの予想されるサイズの差の正規化されたサイズを使用する得点付け関数です。
CogCaliperScorerSizeDiffNormAsym | エッジペアの正規化されたサイズを、両側をマッピングして使用する得点付け関数です。
CogCaliperScorerSizeNorm | エッジペアの正規化されたサイズを使用する得点付け関数です。
CogCaliperScorerStraddle | 候補エッジペアが、検出された位置をまたがっている場合は 1 を、それ以外の場合は 0 を返します。
CogCaliperTool | エッジベースの Caliper ツールです。
CogFindCircle | 円検出の実行パラメータを含むクラスです。
CogFindCircleTool | 一連のキャリパによって検出された最高得点のエッジ点をフィットさせることにより、指定された画像内の円を検出するツールです。このツールには、円検出検査を実行するために必要なすべてのインタフェースが含まれています。
CogFindLine | ライン検出の実行パラメータを含むクラスです。
CogFindLineTool | 一連のキャリパによって検出された最高得点のエッジ点をフィットさせることにより、指定された画像内の直線を検出するツールです。このツールには、線検出検査を実行するために必要なすべてのインタフェースが含まれています。
CogCNLSearchPattern | 画像内に含まれる特徴の検出に使用される CNLSearch パターンを 1 つ保持するクラスです。プライマリインタフェースは、登録パラメータ、パターン登録のためのメソッド、パターン登録の結果、および検査を実行するためのメソッドへのアクセスを提供します。
CogCNLSearchRunParams | CNLSearch 実行パラメータを保持するクラスです。この実行パラメータは、実行時画像内の一致するパターンを CNLSearch が検出する方法を制御するために使用されます。
CogCNLSearchTool | CNLSearch パターンを使用して特徴を検出するツールです。このツールには、CNLSearch 検査を実行するために必要なすべてのクラスが含まれています。
CogAcqFifoTool | フレームグラバ上で取り込み FIFO を使用して画像を取り込むツールです。
CogCADFile | GetShape メソッドを使用して形状のコレクションを取得するために、CAD ファイルを読み取るクラスで、オプションで、開いている形状を、より長い輪郭に接続できます。このメソッドを使用する前に、ファイルが開いている必要があります。スプラインはすべて概算されます。
CogCircle | 円を表すクラスです。
CogCircularAnnulusSection | 真円の円環セクションは、2 つの円弧と 2 本の放射状の直線で囲まれた、4 つの辺を持つ形状です。これらの円弧は互いに相似形です。「開始」円弧を指定し、次に、「終了」円弧を定義する RadialScale を指定します。
CogCircularArc | 円弧は円の一部です。この形状を指定するには、通常の円パラメータのほか、さらに、AngleStart と AngleSpan の 2 つのパラメータも使用します。AngleStart は円弧の開始角度を、AngleSpan は円弧の角度範囲を定義します。
CogCompositeShape | 合成形状を表すクラスです。合成形状は、多数の子形状から構成されます。
CogCoordinateAxes | 1 対の座標軸を表すクラスです。
CogCoordinateSpaceTree | ユーザ座標空間およびその間のマッピングのツリーです。
CogDataAnalysis | 一連のデータ解析チャネルにわたって許容値設定、統計解析、およびデータ値のバッファリングを行うオブジェクトです。
CogDataAnalysisTool | CogDataAnalysisTool は、一連のデータ解析チャネルにわたって許容値設定、統計解析、およびデータのバッファリングを行うために必要な、すべてのオブジェクトをカプセル化します。
CogDataBinding | このクラスは、オブジェクトまたはそのサブオブジェクトの 1 つの、入力プロパティの結合を表します。
CogDataBindingsCollection | 変更が行われた場合にイベントを発生させる CogDataBinding オブジェクトの、順序付きコレクションです。
CogDictionary | キー - 値ペアの順序なしコレクションを格納し、変更が行われた場合はイベントを発生させる、コンテナです。
CogEllipse | 楕円を表すクラスです。
CogEllipticalAnnulusSection | 楕円の円環セクションは、2 つの楕円弧と 2 本の直線で囲まれた、4 つの辺を持つ形状です。これらの円弧は互いに相似形です。「開始」円弧を指定し、次に、「終了」円弧を定義する RadialScale を指定します。
CogEllipticalArc | 楕円弧は楕円の一部です。この形状を指定するには、通常の楕円パラメータのほか、AngleStart と AngleSpan の 2 つのパラメータも使用します。AngleStart は円弧の開始角度を、AngleSpan は円弧の角度範囲を定義します。
CogFitCircle | 一連の点に、円をフィット処理するクラスです。
CogFitCircleTool | 一連の点に、円をフィット処理するツールです。
CogFitEllipse | 一連の点に、楕円をフィット処理するクラスです。
CogFitEllipseTool | 一連の点に、楕円をフィット処理するツールです。
CogFitLine | 一連の点に、線をフィット処理するクラスです。
CogFitLineTool | 一連の点に、線をフィット処理するツールです。
CogGeneralContour | 一般的な輪郭は、輪郭の「始点」から「終点」に向かって順番に連続して並ぶ有向直線および円弧の切片から構成される形状です。形状を構築するには、切片を追加し、各切片の幾何計測値および始点/終点の連結性を指定します。
CogGraphicChildren | 子グラフィックスのコレクションです。
CogGraphicCollection | グラフィックスのコレクションです。
CogGraphicInteractiveCollection | 対話型グラフィックスのコレクションです。
CogGraphicLabel | グラフィカルテキストラベルを表すクラスです。
CogImage24PlanarColor | 8 ビットピクセルの 3 つの重なる矩形配列 (つまり平面) を記述するオブジェクトです。
CogImage8Grey | 8 ビットグレースケールピクセルの矩形配列を記述するオブジェクトです。
CogLine | 直線を表すクラスです。
CogLineSegment | 線分を表すクラスです。
CogMaskGraphic | マスクグラフィックスを表すクラスです。
CogPointMarker | グラフィカル点マーカを表すクラスです。
CogPolygon | ポリゴンを表すクラスです。
CogPropertyWatcher | このクラスは、オブジェクトのプロパティまたはサブプロパティを監視して、プロパティの値が変化した場合に Changed イベントを発生させます。
CogRectangle | 矩形を表すクラスです。
CogRectangleAffine | アフィン矩形を表すクラスです。
CogRLEBuffer | 画像のランレングスエンコード表現を保持するクラスです。
CogShapeExtract | 形状抽出オペレータは、画像から輪郭を抽出するのに使用されます。各輪郭は、輪郭の幾何計測値と極性を記述する形状モデルに変換されます。フィルタ処理され、ランク付けされた形状モデルのコレクションが返されます。
CogShapeModelCollection | CogShapeModel オブジェクトのコレクションです。
CogShapePolarize | 形状極性付与オペレータは、画像データに基づいて形状に沿って極性情報を決定するのに使用します。極性情報は、形状境界のどちら側が明るくどちら側が暗いかを示します。
CogStatistics | 統計情報を計算し、許容値の結果を生成するために連続値をバッファ処理するオブジェクトです。スタンドアローンで使用するためのもので、CogDataAnalysisTool と連動して使用するものではありません。
CogStringCollection | 文字列のコレクションです。
CogToolCollection | 変更が加えられるたびにイベントを発生させる VisionPro ツールの順序付きコレクションです。
CogTransform2DComposed | CogTransform2DComposed は、異なるタイプの変換を合成することのできる変換オブジェクトです。合成された変換は、それに含まれるすべての変換を介して (「右」から「左」へ) 点をマッピングします。このマッピングによって、その変換の合成として動作します。
CogTransform2DLinear | 線形 2D 座標変換です。
CogTransform2DPerspectiveAndRadial | CogTransform2DPerspectiveAndRadial 変換は、平面遠近変換と、それに続く放射状変換、さらにそれに続く線形変換 (回転なし) で構成されます。この変換は、カメラの設定で一般的な非線形効果を補正するために使用できます。
CogAngleLineLineTool | 2 本の直線の間の角度を計測するツールです。
CogAnglePointPointTool | 2 つの点の間の角度を計測するツールです。
CogCreateCircleTool | 円を作成するツールです。
CogCreateEllipseTool | 楕円を作成するツールです。
CogCreateLineBisectPointsTool | 2 点を結ぶ線分の垂直二等分線になる直線を作成するツールです。
CogCreateLineParallelTool | 指定された直線に平行で指定された点を通る直線を作成するツールです。
CogCreateLinePerpendicularTool | 指定された直線に垂直で指定された点を通る直線を作成するツールです。
CogCreateLineTool | 直線を作成するツールです。
CogCreateSegmentAvgSegsTool | 指定された 2 本の線分を平均することによって、線分を作成するツールです。
CogCreateSegmentTool | 線分を作成するツールです。
CogDistanceCircleCircleTool | 2 つの円の間の距離を計測するツールです。
CogDistanceLineCircleTool | 直線と円の間の距離を計測するツールです。
CogDistanceLineEllipseTool | 直線と楕円の間の距離を計測するツールです。
CogDistancePointCircleTool | 点から円までの距離を計測するツールです。
CogDistancePointEllipseTool | 点と楕円の間の距離を計算するツールです。
CogDistancePointLineTool | 点と直線の間の距離を計測するツールです。
CogDistancePointPointTool | 指定された 2 点間の距離と角度を計算するツールです。
CogDistancePointSegmentTool | 点から線分までの距離を計測するツールです。
CogDistanceSegmentCircleTool | 線分から円までの距離を計測するツールです。
CogDistanceSegmentEllipseTool | 線分と楕円の間の距離を計測するツールです。
CogDistanceSegmentLineTool | 線分から直線までの距離を計測するツールです。
CogDistanceSegmentSegmentTool | 2 本の線分間の距離を計測するツールです。
CogIntersectCircleCircleTool | 2 つの円の交点を求めるツールです。
CogIntersectLineCircleTool | このオブジェクトについてのヘルプはまだありません。
CogIntersectLineEllipseTool | 直線と楕円の交点を求めるツールです。
CogIntersectLineLineTool | 2 本の直線の交点を求めるツールです。
CogIntersectSegmentCircleTool | 線分と円の交点を求めるツールです。
CogIntersectSegmentEllipseTool | 線分と楕円の交点を求めるツールです。
CogIntersectSegmentLineTool | 線分と直線の交点を求めるツールです。
CogIntersectSegmentSegmentTool | 2 本の線分の交点を求めるツールです。
CogAcqFifo1394DCAM | このオブジェクトは、CogFrameGrabber1394DCAM クラスからのみ作成できます。
CogAcqFifo8100 | このオブジェクトは、CogFrameGrabber8100 クラスからのみ作成できます。
CogAcqFifo8100D | このオブジェクトは、CogFrameGrabber8100d クラスからのみ作成できます。
CogAcqFifo8100L | このオブジェクトは、CogFrameGrabber8100l クラスからのみ作成できます。
CogAcqFifo8120 | このオブジェクトは、CogFrameGrabber8120 クラスからのみ作成できます。
CogAcqFifo8501 | このオブジェクトは、CogFrameGrabber8501 クラスからのみ作成できます。
CogAcqFifo8504 | このオブジェクトは、CogFrameGrabber8504 クラスからのみ作成できます。
CogAcqFifo8600 | このオブジェクトは、CogFrameGrabber8600 クラスからのみ作成できます。
CogImageFile | 画像ファイルへのアクセスをサポートするオブジェクトです。
CogImageFileBMP | .bmp ファイルへのアクセスをサポートするオブジェクトです。
CogImageFileCDB | .cdb /.idb ファイルへのアクセスをサポートするオブジェクトです。
CogImageFileTIFF | .tif ファイルへのアクセスをサポートするオブジェクトです。
CogImageFileTool | 画像ファイルツールです。
CogAffineTransform | CogRectangleAffine によって定義された画像の一部を、新しい矩形画像に変換するクラスです。
CogAffineTransformTool | CogRectangleAffine によって定義された画像の一部を、新しい矩形画像に変換するツールです。
CogCopyRegion | ピクセルの領域をデスティネーション画像にコピーするクラスです。
CogCopyRegionTool | ピクセルの領域をデスティネーション画像にコピーするツールです。
CogHistogram | ヒストグラムを生成するクラスです。
CogHistogramTool | 1 つの入力画像からヒストグラムを生成するツールです。
CogImageAverage | 画像平均処理の実行パラメータを含むクラスです。
CogImageAverageTool | 画像平均を実行するツールです。
CogImageConvertRunParams | このクラスは、CogImageConvertTool::Run メソッドによって使用される実行時パラメータをカプセル化します。
CogImageConvertTool | 主として特定のカラーフォーマットから特定の非カラーフォーマットに、画像を変換するツールです。
CogImageSharpness | 画像鮮鋭度処理の実行パラメータを含むクラスです。
CogImageSharpnessTool | 画像鮮鋭度を計算するツールです。
CogIPOneImageAddSubtractConstant | 画像に対して定数値を加算または減算するクラスです。
CogIPOneImageConvolve3x3 | 画像に対して 3 × 3 畳み込みを実行するクラスです。
CogIPOneImageEqualize | 画像に対してヒストグラム平坦化操作を実行するクラスです。平坦化とは、ヒストグラムの積分によって画像を再マッピングすることです。
CogIPOneImageExpand | X および Y 方向に画像のピクセルを複製することによって画像のサイズを拡大するクラスです。
CogIPOneImageFlipRotate | 反転と回転の両方またはどちらかを画像に適用するクラスです。
CogIPOneImageGaussSampler | 2 次元ガウス分布を近似する画像に、カーネルを適用するクラスです。このカーネルのサイズを変えることによって、ノイズの強度を低下させたり、特定のサイズを下回る画像特徴を減衰させたりすることができます。
CogIPOneImageGreyMorphology | 画像に対してグレースケールモフォロジィ操作を実行するクラスです。
CogIPOneImageGreyMorphology3x3Element | グレーモフォロジィ要素を保持するクラスです。各要素は、プライマリエレメントを生成するために CogIPOneImageGreyMorphology オブジェクトによって使用される、3 × 3 マトリックスです。
CogIPOneImageGreyMorphology3x3Elements | 3 × 3 グレーモフォロジィ要素のコレクションです。各グレーモフォロジィ要素は、モフォロジィ操作でプライマリエレメントの構成に使用される 3 × 3 マトリックスです。
CogIPOneImageHighPassFilter | 画像に対してハイパスフィルタリングを実行するクラスです。ハイパス操作は、入力画像から、ガウスフィルタをかけた入力画像を減算することによって実行されます。
CogIPOneImageMedian3x3 | 画像に対して 3 × 3 メジアン操作を実行するクラスです。3 × 3 メジアンフィルタは、ソースピクセルをソースピクセルを中心とする 3 × 3 近傍のメジアン値に差し替えます。
CogIPOneImageMultiplyConstant | 画像のピクセル値に定数値を乗算するクラスです。
CogIPOneImageOperators | 1 つの画像用オペレータのコレクションです。
CogIPOneImagePixelMap | このクラスは、ユーザが定義したマップを使用して画像の全ピクセルを変換します。デフォルトでは、このクラスは等価マップを作成します。
CogIPOneImageQuantize | 量子化を実行して、画像の情報の維持を試みつつ、画像に含まれるグレーレベルの数を減らすクラスです。この操作は、画像の少数の輝度によって容易に記述されるシーンで便利です。
CogIPOneImageSubSampler | SampleX と SampleY で指定されたブロックによって画像のピクセルをサブサンプリングして、サイズを縮小した画像を生成するクラスです。SpatialAverage が有効にされている場合、選択されたピクセルは各ブロックの中央または平均ピクセル値に最も近くなります。
CogIPOneImageTool | 1 つの入力画像に対して適用され、 1 つの出力画像を生成するツールです。
CogIPTwoImageAdd | 2 つの画像を加算して新しい画像を生成するクラスです。
CogIPTwoImageAddTool | 2 つの入力画像を加算して 1 つの出力画像を生成するツールです。
CogIPTwoImageMinMax | 2 つの入力画像の最小または最大ピクセルに基づいて画像を生成するクラスです。
CogIPTwoImageMinMaxTool | 2 つの画像から取得した最小ピクセル値または最大ピクセル値に基づいて新しい画像を生成するツールです。
CogIPTwoImageSubtract | ある画像を別の画像から減算して新しい画像を生成するクラスです。具体的には、InputImageB を InputImageA から減算して新しい画像を生成します。
CogIPTwoImageSubtractTool | InputImageB を InputImageA から減算して 1 つの出力画像を生成するツールです。
CogPolarUnwrap | 環状のピクセル領域をデスティネーション画像に伸ばすクラスです。
CogPolarUnwrapTool | 環状のピクセル領域を矩形のデスティネーション画像に伸ばすツールです。
CogSobelEdge | ソベルエッジ処理の実行パラメータを含むクラスです。
CogSobelEdgeTool | ソベルエッジ検出を実行するツールです。オプションで、ピクセル全体のピーク検出またはヒステリシスの 2 値化を後処理として実行できます。
CogRecord | ツールの状態についての情報を保持するクラスです。
CogRecords | CogRecord オブジェクトのコレクションを保持するクラスです。
CogRunStatus | このクラスは、ICogRunStatus インタフェースの実装を提供します。
CogSerializableChangedEventBase | ICogChangedEvent インタフェースを実装するコンポーネントの基底クラスです。このクラスから派生したオブジェクトは、オブジェクトの部分の状態が変化すると Changed イベントを発生させます。
CogSerializableChangedEventComponentBase | ICogChangedEvent インタフェースを実装するコンポーネントの基底クラスです。このクラスから派生したオブジェクトは、オブジェクトの部分の状態が変化すると Changed イベントを発生させます。
CogSerializableCollectionBase | 変更が行われた場合にイベントを発生させる値の、シリアル化可能な汎用順序付きコレクションの基底クラスです。
CogSerializableDictionaryBase | 変更が行われた場合にイベントを発生させる、キー - 値ペアの汎用順序なしコレクションの基底クラスです。
CogToolBase | ICogTool インタフェースを実装する基底クラスです。ツールは ICogTool インタフェースをほかの方法で実装することもでき、このクラスから派生する必要はありません。
CogChangedEventFunnel |
CogShapeModelCircle | この形状モデルオブジェクトは、CogCircle の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelEllipse | この形状モデルオブジェクトは、CogEllipse の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelEllipticalArc | この形状モデルオブジェクトは、CogEllipticalArc の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelGeneralContour | この形状モデルオブジェクトは、CogGeneralContour の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelLine | この形状モデルオブジェクトは、CogLine の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelLineSegment | この形状モデルオブジェクトは、CogLineSegment の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelPolygon | この形状モデルオブジェクトは、CogPolygon の MakeShapeModel メソッドを使用してのみ作成できます。
CogShapeModelPropCollection | CogShapeModel オブジェクトのコレクションです。このコレクションは、含まれる形状モデルオブジェクトからの変更イベントを、ICogEventInfo インタフェースを使用して伝播します。
CogShapeModelRectangleAffine | この形状モデルオブジェクトは、CogRectangleAffine の MakeShapeModel メソッドを使用してのみ作成できます。
CogUserTool | ほかのツールのコレクションを持つツールの、基底クラスです。
CogOCFont | このクラスのデフォルトインタフェースは、光学文字フォントのプロパティ、Compile メソッド、Uncompile メソッド、およびフォントをコンパイルした結果へのアクセスを提供します。
CogOCFontModel | 光学文字フォントモデルのプロパティへのアクセスを提供します。このフォントモデルは、文字の存在を調べるのに使用するノーマルなフォントモデルでも、文字が一切存在しないことを調べるのに使用するブランクのフォントモデルでもかまいません。
CogOCFontModels | 光学文字フォントモデルのコレクションです。
CogOCVCharacterPosition | このクラスのデフォルトインタフェースは、文字位置パラメータへのアクセスを提供します。検証する文字モデル、それらの文字モデルの予想位置と位置不確定度、およびそれらの文字モデルのアクセプトしきい値と信頼性しきい値を指定することができます。
CogOCVCharacterPositions | OCV で検証する文字位置のコレクションです。文字位置は、コレクション内でリストされている順に検証されます。例外はブランクのモデルで、これは非ブランクのモデルの検証がすべて終わった後にのみ検証されます。
CogOCVPattern | OCV パターンのプロパティ、およびそのパターンの登録結果へのアクセスを提供します。パターンは、Execute メソッドを呼び出すことによって行われる OCV 検査を実行する前に、Train メソッドを介して登録されている必要があります。
CogOCVPatternPosition | デフォルトインタフェースは、実行時のパターン予想位置、および予想位置の不確定度を設定するプロパティへのアクセスを提供します。パターン内の文字位置は、パターンの予想位置に対して相対的に指定されます。
CogOCVTool | 画像内の文字パターンの検証に使用できる光学文字検証 (OCV) ツールです。このツールには、OCV 検査を実行するために必要なすべてのクラスが含まれています。
CogOCVMaxFont | このクラスは、1 つのフォントに関連付けられた幾何学文字ディスクリプションのセットを表します。幾何学ディスクリプションデータは、定義済みのフォントファイルから読み取ります。通常、ユーザはフォントファイルを作成しません。ただし、サイズや行間隔など、特定のフォント特性を調整することは可能です。
CogOCVMaxFontRenderParams | このクラスは、特定のフォントでのテキストの描画、または描画ベースの処理を制御するために通常使用される、プロパティをカプセル化します。これらのプロパティは、CogOCVMaxFont と、カメラで実際に観察されるものの間の対応付けを微調整することを可能にします。
CogOCVMaxPattern | このクラスは、Cognex.VisionPro.OCVMax アセンブリの主力となるものであり、実際の光学文字検証を実行します。このクラスには、登録パラメータと登録状態情報が含まれます。このクラスまたは CogOCVMaxTool ツールを使用すると、文字検証を実行することができます。 登録が必要なほかのビジョンツールとは異なり、OCVMax では、登録画像も登録領域も使用されません。このクラスの登録は、CogOCVMaxFont によって、人工的に生成された画像に基づきます。
CogOCVMaxPoseHelper | このクラスは、テキスト文字列のポーズを定義する際のサポートを提供します。一般的な使用モデルでは、ユーザが a) 対象となっている実際のテキストを描いた画像、b) フォントオブジェクト、c) テキスト (1 つ以上の文字列) を保持していること、および、ユーザがこれらからポーズ (CogOCVMax オペレータまたはツールは、このポーズにおいて画像処理を行う可能性がある) を決定したいと考えていることが前提となっています。次の 5 つの基本的な手順があります。第 1 に、Font および Text プロパティを設定することによって (およびオプションで、FontRenderParams プロパティを変更することによって)、CogOCVMaxPoseHelper オブジェクトを設定します。第 2 に、InitialPoseEstimate() メソッドを呼び出して、望ましいポーズがどのようなものであるかについて、最初の推測を行います。第 3 に、FinalPosePrepare() メソッドを呼び出して、推測された初期ポーズを使用して CogCompositeShape グラフィックスを作成します。第 4 に、グラフィックスを対話型ディスプレイに追加して、このグラフィックスの位置、回転、サイズ、スケール、またはスキューをユーザがダイナミックに調整することで、グラフィックスを画像内の対応するテキストにスーパーインポーズできるようにします。第 5 に、FinalPoseComplete() メソッドを、(ユーザが変更した) CogCompositeShape グラフィックスとともに呼び出します。最後の手順により、ユーザが指定したポーズを記述する CogTransform2DLinear が得られます。
CogOCVMaxRunParams | このクラスは、CogOCVMaxPattern::Execute メソッドによって使用される実行時パラメータをカプセル化します。
CogOCVMaxSearchParams | このクラスは、配置サーチと文字サーチの両方またはどちらかを実行するために使用されるすべてのパラメータをカプセル化します。
CogOCVMaxTool | このクラスは、CogOCVMaxPattern オペレータへのツールレベルのアクセスを提供します。このクラスは、OCVMax 検査を実行するために必要なすべてのクラスをカプセル化します。
CogOCVMaxTuneParams | このクラスは、CogOCVMaxPattern オブジェクトをチューニングするために使用されるプロパティをカプセル化します。
CogPatInspectPattern | 登録時パラメータへの、および PatInspect パターンの登録結果へのアクセスを提供します。パターンは、Execute メソッドを呼び出すことによって行われる検査を実行する前に、Train メソッドを介して登録されている必要があります。
CogPatInspectRunParams | PatInspect 実行時パラメータへのアクセスを提供します。実行時パラメータは、PatInspect 検査の実行方法、および PatInspect の結果の一部としてどのようなデータが生成されるかを指定するために使用されます。
CogPatInspectTool | PatInspect ツールは、入力画像の希望する領域を、ツールのパターン内に格納されたテンプレート画像と比較することによって、欠陥を検出するために使用できます。テンプレート画像は、欠陥を含まない 1 つ以上の良好な画像から登録できます。
CogPMAlignPattern | 画像内に含まれる特徴の検出に使用される PMAlign パターンを 1 つ保持するクラスです。プライマリインタフェースは、登録パラメータ、パターン登録のためのメソッド、パターン登録の結果、および検査を実行するためのメソッドへのアクセスを提供します。
CogPMAlignRunParams | PMAlign 実行パラメータを保持するクラスです。この実行パラメータは、実行時画像内の一致するパターンを PMAlign が検出する方法を制御するために使用されます。
CogPMAlignTool | PMAlign パターンを使用して特徴を検出するツールです。このツールには、PMAlign 検査を実行するために必要なすべてのクラスが含まれています。
CogPMAlignZoneAngle | 角度の自由度 (DOF) 情報を保持するクラスです。PMAlign は、登録パターンから角度が変更されたパターンを検出することができます。このクラスは、パターンの配置角度を表します。
CogPMAlignZoneScale | スケールの自由度 (DOF) 情報を保持するクラスです。PMAlign は、登録パターンからスケールが変更されたパターンを検出することができます。このクラスは、パターンの配置スケールを表します。
CogJob | CogJob クラスは QuickBuild の作業単位です。画像取り込み FIFO とビジョンツールのコレクションで構成されています。各 CogJob は個別のカメラチャネルに関連付けられており、カメラチャネルからビジョンツールに画像が提供され、処理されます。
CogJobManager | CogJobManager クラスは QuickBuild のトップレベルのクラスです。CogJob のグローバル情報の管理と提供を行います。
CogInputImageTool | CogInputImageTool。内部でのみ使用されます。
CogToolGroup | 一連の VisionPro ツールを含む VisionPro ツールです。CogToolGroup を実行すると、CogToolGroup に含まれる各ツールが暗黙的に実行されます。CogToolGroup の実行状態とレコードは、CogToolGroup に含まれるすべてのツールの集計に基づきます。
Cog2DSymbolPattern | 画像内のシンボルのデコードに使用される 2D シンボルパターンを 1 つ保持するクラスです。登録パラメータ、パターン登録のためのメソッド、パターン登録の結果、および検出とデコードの操作を実行するためのメソッドへのアクセスを提供します。
Cog2DSymbolRunParams | 2D シンボルデコードのパラメータを格納するオブジェクトです。Cog2DSymbolPattern::Execute が正常にシンボルを検出およびデコードするために必要なパラメータを指定します。
Cog2DSymbolTool | データマトリックスまたは QR コードシンボルをデコードする 2D シンボルツールです。ツールは最初登録されていないので、シンボルをデコードする前に登録が必要です。
Cog2DSymbolVerify | 2D シンボル検証の実行パラメータを含むクラスです。
Cog2DSymbolVerifyTool | 2D シンボル検証を実行するツールです。
CogPDF417 | PDF417 デコードを実行するオペレータです。プライマリインタフェースは、RegionMode パラメータ、Timeout パラメータ、および検出とデコードの操作を実行するメソッドへのアクセスを提供します。
CogPDF417Tool | PDF417 Stacked バーコードシンボルを検出してデコードするツールです。結果オブジェクトを介して結果を返します。PDF417 シンボルツールは、エンコードされた情報を画像から直接検出することができます。そのため、デコードの前に学習段階を必要としません。

必要条件

名前空間: Cognex.VisionPro.Implementation

アセンブリ: Cognex.VisionPro (Cognex.VisionPro.dll 内)

参照

ICogHasChanged メンバ | Cognex.VisionPro.Implementation 名前空間


Cognex.VisionPro.OCVMax

VisionPro プログラミングリファレンス

Cognex.VisionPro.OCVMax 名前空間

クラス

クラス | 説明
CogOCVMaxCharacterIterator | このクラスは、CogOCVMaxPattern オブジェクトの文字レベルのプロパティおよびメソッドへの容易なアクセスを提供します。このクラスを使用すると、1 つのパラグラフ内にある 1 つの行内のすべての文字位置にわたって移動することができます。このオブジェクトは、直接構築することはできません。その代わりに、包含行の繰り返し指定子、またはトップレベルの CogOCVMaxPattern オブジェクトに対して、CreateCharacterIterator メソッドを使用してください。また、このクラスをアーカイブに格納することはできないことに注意してください。
CogOCVMaxCharacterResult | このクラスは、1 つの文字についての結果情報のすべてを保持します。
CogOCVMaxFont | このクラスは、1 つのフォントに関連付けられた幾何学文字ディスクリプションのセットを表します。幾何学ディスクリプションデータは、定義済みのフォントファイルから読み取ります。通常、ユーザはフォントファイルを作成しません。ただし、サイズや行間隔など、特定のフォント特性を調整することは可能です。
CogOCVMaxFontRenderParams | このクラスは、特定のフォントでのテキストの描画、または描画ベースの処理を制御するために通常使用される、プロパティをカプセル化します。これらのプロパティは、CogOCVMaxFont と、カメラで実際に観察されたものの間の対応付けを微調整することを可能にします。
CogOCVMaxLineIterator | このクラスは、CogOCVMaxPattern オブジェクトの行レベルのプロパティおよびメソッドへの容易なアクセスを提供します。このクラスを使用すると、1 つのパラグラフ内のすべての行にわたって移動することができます。このオブジェクトは、直接構築することはできません。その代わりに、包含パラグラフの繰り返し指定子、またはトップレベルの CogOCVMaxPattern オブジェクトに対して、CreateLineIterator メソッドを使用してください。また、このクラスをアーカイブに格納することはできないことに注意してください。
CogOCVMaxLineResult | このクラスは、1 つの行についての結果情報のすべてを保持します。
CogOCVMaxParagraphIterator | このクラスは、CogOCVMaxPattern オブジェクトのパラグラフレベルのプロパティおよびメソッドへの容易なアクセスを提供します。このクラスを使用すると、配置内のすべてのパラグラフにわたって移動することができます。このオブジェクトは、直接構築することはできません。その代わりに、トップレベルの CogOCVMaxPattern オブジェクトに対して CreateParagraphIterator メソッドを使用してください。また、このクラスをアーカイブに格納することはできないことに注意してください。
CogOCVMaxParagraphResult | このクラスは、1 つのパラグラフについての結果情報のすべてを保持します。
CogOCVMaxPattern | このクラスは、Cognex.VisionPro.OCVMax アセンブリの主力となるものであり、実際の光学文字検証を実行します。このクラスには、登録パラメータと登録状態情報が含まれます。このクラスまたは CogOCVMaxTool ツールを使用すると、文字検証を実行することができます。 登録が必要なほかのビジョンツールとは異なり、OCVMax では、登録画像も登録領域も使用されません。このクラスの登録は、CogOCVMaxFont によって、人工的に生成された画像に基づきます。
CogOCVMaxPatternCharacterAddedEventArgs | このクラスは、CharacterAdded イベントによって提供されたデータを保持します。CharacterAdded イベントは、1 つ以上の文字が配置に追加された後に、標準の Changed イベントに加えて発生します。
CogOCVMaxPatternCharacterChangedEventArgs | このクラスは、CharacterChanged イベントによって提供されたデータを保持します。CharacterChanged イベントは、配置内にある文字のなんらかの側面が変更された後に、標準の Changed イベントに加えて発生します。
CogOCVMaxPatternCharacterRemovedEventArgs | このクラスは、CharacterRemoved イベントによって提供されたデータを保持します。CharacterRemoved イベントは、配置内の 1 つ以上の文字が削除された後に、標準の Changed イベントに加えて発生します。
CogOCVMaxPatternLineAddedEventArgs | このクラスは、LineAdded イベントによって提供されたデータを保持します。LineAdded イベントは、1 つ以上の行が配置に追加された後に、標準の Changed イベントに加えて発生します。
CogOCVMaxPatternLineChangedEventArgs | このクラスは、LineChanged イベントによって提供されたデータを保持します。LineChanged イベントは、配置内にある行のなんらかの側面が変更された後に、標準の Changed イベントに加えて発生します。
CogOCVMaxPatternLineRemovedEventArgs | このクラスは、LineRemoved イベントによって提供されたデータを保持します。LineRemoved イベントは、配置内の 1 つ以上の行が削除された後に、標準の Changed イベントに加えて発生します。
CogOCVMaxPatternParagraphAddedEventArgs | このクラスは、ParagraphAdded イベントによって提供されたデータを保持します。ParagraphAdded イベントは、1 つ以上のパラグラフが配置に追加された後に、標準の Changed イベントに加えて発生します。
CogOCVMaxPatternParagraphChangedEventArgs | このクラスは、ParagraphChanged イベントによって提供されたデータを保持します。ParagraphChanged イベントは、配置内にあるパラグラフのなんらかの側面が変更された後に、標準の Changed イベントに加えて発生します。
CogOCVMaxPatternParagraphRemovedEventArgs | このクラスは、ParagraphRemoved イベントによって提供されたデータを保持します。ParagraphRemoved イベントは、配置内の 1 つ以上のパラグラフが削除された後に、標準の Changed イベントに加えて発生します。
CogOCVMaxPatternTrainProgressEventArgs | このクラスは、TrainProgress イベントによって提供されたデータを保持します。TrainProgress イベントは、登録中に定期的に発生します。
CogOCVMaxPatternTuneProgressEventArgs | このクラスは、TuneProgress イベントによって提供されたデータを保持します。TuneProgress イベントは、チューニング中に定期的に発生します。
CogOCVMaxPoseHelper | このクラスは、テキスト文字列のポーズを定義する際のサポートを提供します。一般的な使用モデルでは、ユーザが、a) 対象となっている実際のテキストを描いた画像、b) フォントオブジェクト、および c) テキスト (1 つ以上の文字列) を保持していること、および、ユーザはこれらからポーズ (CogOCVMax オペレータまたはツールは、このポーズにおいて画像処理を行う可能性がある) を決定したいと考えていることが前提となっています。次の 5 つの基本的な手順があります。第 1 に、Font および Text プロパティを設定することによって (およびオプションで、FontRenderParams プロパティを変更することによって)、CogOCVMaxPoseHelper オブジェクトを設定します。第 2 に、InitialPoseEstimate() メソッドを呼び出して、望ましいポーズがどのようなものであるかについて、最初の推測を行います。第 3 に、FinalPosePrepare() メソッドを呼び出して、推測された初期ポーズを使用して CogCompositeShape グラフィックスを作成します。第 4 に、グラフィックスを対話型ディスプレイに追加して、このグラフィックスの位置、回転、サイズ、スケール、またはスキューをユーザがダイナミックに調整可能にすることで、グラフィックスを画像内の対応するテキストにスーパーインポーズできるようにします。第 5 に、FinalPoseComplete() メソッドを、(ユーザが変更した) CogCompositeShape グラフィックスとともに呼び出します。最後の手順により、ユーザが指定したポーズを説明する CogTransform2DLinear が得られます。
CogOCVMaxResult | このクラスは、パターン全体についての結果情報のすべてを保持します。
CogOCVMaxRunParams | このクラスは、CogOCVMaxPattern::Execute メソッドによって使用される実行時パラメータをカプセル化します。
CogOCVMaxSearchParams | このクラスは、配置サーチと文字サーチの両方またはどちらかを実行するために使用されるすべてのパラメータをカプセル化します。
CogOCVMaxSharedResult |
CogOCVMaxTool | このクラスは、CogOCVMaxPattern オペレータへのツールレベルのアクセスを提供します。このクラスは、OCVMax 検査を実行するために必要なすべてのクラスをカプセル化します。
CogOCVMaxTuneParams | このクラスは、CogOCVMaxPattern オブジェクトをチューニングするために使用されるプロパティをカプセル化します。

デリゲート

デリゲート | 説明
CogOCVMaxPatternCharacterAddedEventHandler |
CogOCVMaxPatternCharacterChangedEventHandler |
CogOCVMaxPatternCharacterRemovedEventHandler |
CogOCVMaxPatternLineAddedEventHandler |
CogOCVMaxPatternLineChangedEventHandler |
CogOCVMaxPatternLineRemovedEventHandler |
CogOCVMaxPatternParagraphAddedEventHandler |
CogOCVMaxPatternParagraphChangedEventHandler |
CogOCVMaxPatternParagraphRemovedEventHandler |
CogOCVMaxPatternTrainProgressEventHandler |
CogOCVMaxPatternTuneProgressEventHandler |

列挙体

列挙体 | 説明
CogOCVMaxCharacterRegistrationConstants | 検出された各文字に対して実行されるレジストレーション (フィット処理) のタイプを選択するために使用される定数です。
CogOCVMaxCharacterStatusConstants | 1 つの文字の検査に対する総合的な結果を説明する定数です。
CogOCVMaxCharacterTypeConstants | 特定のパラグラフのアルファベットに、指定されたフォント内のどの文字を組み込むかを指定する際に役立つ定数です。この定数は、各文字を明示的にリストするよりも容易な、アルファベット指定方法を提供するために有効です。
CogOCVMaxComputePosesConstants | どのポーズを実行時に計算するかを指定するために使用される定数です。ポーズの計算は、追加の実行時間を要するため、すべてのアプリケーションで必要とされるとは限りません。個別の文字のポーズは、必ず計算されることに注意してください。
CogOCVMaxCurrentRecordConstants | ツールの CurrentRecord に含まれることが可能なデータの列挙体です。
CogOCVMaxCustomizationTypeConstants | CogOCVMaxPattern オブジェクトのカスタマイズに使用される定数です。
CogOCVMaxDOFAttributeConstants | 特定のサーチ自由度 (DOF) のどの側面がアクセスされるかを指定するために役立つ定数です。そのような属性は、一度に 1 つだけアクセスされることが可能です。
CogOCVMaxDOFConstants | サーチ自由度 (DOF) を指定するために使用される定数です。
CogOCVMaxFontTypeConstants | インポートされたフォントのタイプを識別するために使用される定数です。
CogOCVMaxLastRunRecordConstants | ツールの LastRunRecord に含めることができる非診断データの列挙体です。
CogOCVMaxLastRunRecordDiagConstants | ツールの LastRunRecord に含めることができる診断データの列挙体です。
CogOCVMaxParagraphResultGraphicConstants | CogOCVMaxParagraphResult::CreateResultGraphics() に対して、希望するリザルトグラフィックスを指定するために使用される定数です。
CogOCVMaxPolarityConstants | 背景を基準にして、検査される文字の明るさまたは暗さを指定するための定数です。
CogOCVMaxRefinementConstants | 特定の文字の変位を表す変換に対して行われる、最適化の量を指定するために使用される定数です。
CogOCVMaxScoreModeConstants | 各文字の得点を計算する方法を指定するために使用される定数です。注:より信頼性の高いコンフュージョンの計算を可能にするために通常望ましいモードは ScoreUsingClutter ですが、ノイズの多い画像では、ScoreWithoutClutter が必要な場合もあります。
CogOCVMaxTuneConstants | どのパターンプロパティをチューニングするかを指定するために使用される定数です。
CogOCVMaxVerificationTypeConstants | 各文字に対して実行される検証のタイプを選択するために使用される定数です。


CogOCVMaxCharacterIterator クラス

このクラスは、CogOCVMaxPattern オブジェクトの文字レベルのプロパティおよびメソッドへの容易なアクセスを提供します。このクラスを使用すると、1 つのパラグラフ内にある 1 つの行内のすべての文字位置にわたって移動することができます。このオブジェクトは、直接構築することはできません。その代わりに、包含行の繰り返し指定子、またはトップレベルの CogOCVMaxPattern オブジェクトに対して、CreateCharacterIterator メソッドを使用してください。また、このクラスをアーカイブに格納することはできないことに注意してください。

このタイプのメンバすべてのリストについては、「CogOCVMaxCharacterIterator メンバ」を参照してください。

System.Object
CogOCVMaxCharacterIterator

public class CogOCVMaxCharacterIterator

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxCharacterIterator メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator メンバ

CogOCVMaxCharacterIterator の概要

パブリックインスタンスプロパティ

IsEnd | この繰り返し指定子が、包含行の最後の文字を超えて配置されているかどうかを示します。
IsFirst | この文字位置が、包含行内の最初の文字位置であるかどうかを示します。
IsInvalid | この繰り返し指定子が、正当な文字に配置されていないかどうかを示します。true の場合 (つまり、配置されていない場合)、文字レベルのプロパティまたはメソッドにアクセスしようとすると、エラーが生成されます。
LinePosition | 包含パラグラフ内での包含行の相対位置を示します。番号付けはゼロベースなので、値 0 は、この文字が包含パラグラフの最初の行内に存在することを示します。
ParagraphPosition | CogOCVMaxPattern オブジェクト内での包含パラグラフの相対位置を示します。番号付けはゼロベースなので、値 0 は、この文字が CogOCVMaxPattern オブジェクトの最初のパラグラフ内に存在することを示します。
Position | 包含行内での、この文字の相対位置を示します。番号付けはゼロベースなので、値 0 は、これが包含行の最初の文字であることを示します。
VerificationType | 対応する文字位置に対して実行される検証のタイプを取得または設定します。可能な値は、Normal、AlwaysVerified、および Ignore です。Normal は、標準の OCV です。Normal モードでは、文字は Verified、Confused、または Failed と判定される可能性があります。AlwaysVerified モードでは、この文字位置に関連付けられたキーセット内の各キーに得点を与え、最も得点の高いキーを選択し、文字を常に Verified と判定します。Ignore モードでは、対象の文字に対して処理を一切行いません。Ignore モードでは、文字は常に Verified と判定されます。これは登録時プロパティとみなすことができますが、CogOCVMaxRunParams::GetVerificationType(...) および CogOCVMaxRunParams::SetVerificationType(...) メソッドを介してアクセス可能な、類似した実行時プロパティが存在することに注意してください。通常、登録時と実行時の値は同じ値に設定しますが、これは常に必要なわけではありません。登録時の値 (この値) を Ignore に設定せず、次に、実行時の値を Ignore 以外の値に設定すると実行時エラーが発生します。

パブリックインスタンスメソッド

Copy | オーバロードされます。このメソッドと機能的に同一の、新しく作成された文字繰り返し指定子を返します。新しく作成された文字繰り返し指定子は、同じ包囲パラグラフ内、同じ包囲行内の、同じ文字位置を持ちます。
CreateLineIterator | 包含行に対応する、新しく作成された行繰り返し指定子を返します。このメソッドは、新しく作成されたこの文字繰り返し指定子の親へのアクセスを提供します。
GetDisplayCharacter | この文字繰り返し指定子によって指定される位置に対して、グラフィカルユーザインタフェースで表示される文字を取得します。これは、(登録時) キーセットが 2 つ以上の値を持つ文字位置に有効です。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。
GetDisplayCharacterKey | この文字繰り返し指定子によって指定される位置に対して、グラフィカルユーザインタフェースで表示される文字のキーを取得します。これは、(登録時) キーセットが 2 つ以上の値を持つ文字位置に有効です。
GetKeysetCharacterKeys | この文字繰り返し指定子によって指定される文字位置に対する (登録時) キーセットに対応する、System::Int32 の配列を取得します。この配列の各要素は、この位置で発生する可能性がある文字のキー値です。
GetKeysetCharacters | この文字繰り返し指定子によって指定される文字位置に対する (登録時) キーセットに対応する、文字列を取得します。この文字列内の各個別の文字が、この位置で発生する可能性があります。
MoveToNext | 文字繰り返し指定子を、包含行内の次の文字位置に移動します。この呼び出しの前に、繰り返し指定子が既に最後の位置にある場合、MoveToNext は例外を生成します。エラーを避けるには、MoveToNext を呼び出す前に IsEnd プロパティをチェックしてください。
MoveToPosition | 文字繰り返し指定子を、包含行内の指定された位置に移動します。引数が 0 の場合は、行内の最初の文字位置に移動します。引数が -1 の場合は、行内の最後の文字位置に移動します。引数が正当でない場合は、例外が生成されます。
MoveToPrevious | 文字繰り返し指定子を、包含行内の前の文字位置に移動します。この呼び出しの前に、繰り返し指定子が既に最初の位置にある場合、MoveToPrevious は例外を生成します。エラーを避けるには、MoveToPrevious を呼び出す前に IsFirst プロパティをチェックしてください。
SetDisplay | オーバロードされます。この文字繰り返し指定子によって指定される位置に対して、グラフィカルユーザインタフェースで表示される文字のキーを設定します。これは、(登録時) キーセットが 2 つ以上の値を持つ文字位置に有効です。
SetKeyset | オーバロードされます。この文字繰り返し指定子によって指定される文字位置に対する、(登録時) キーセットを設定します。キー値は System::Int32 の配列として渡され、その配列の各要素は、この位置で発生する可能性がある文字のキー値です。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator プロパティ

CogOCVMaxCharacterIterator クラスのプロパティを次に示します。CogOCVMaxCharacterIterator クラスメンバの完全なリストについては、「CogOCVMaxCharacterIterator メンバ」を参照してください。

パブリックインスタンスプロパティ

IsEnd | この繰り返し指定子が、包含行の最後の文字を超えて配置されているかどうかを示します。
IsFirst | この文字位置が、包含行内の最初の文字位置であるかどうかを示します。
IsInvalid | この繰り返し指定子が、正当な文字に配置されていないかどうかを示します。true の場合 (つまり、配置されていない場合)、文字レベルのプロパティまたはメソッドにアクセスしようとすると、エラーが生成されます。
LinePosition | 包含パラグラフ内での包含行の相対位置を示します。番号付けはゼロベースなので、値 0 は、この文字が包含パラグラフの最初の行内に存在することを示します。
ParagraphPosition | CogOCVMaxPattern オブジェクト内での包含パラグラフの相対位置を示します。番号付けはゼロベースなので、値 0 は、この文字が CogOCVMaxPattern オブジェクトの最初のパラグラフ内に存在することを示します。
Position | 包含行内での、この文字の相対位置を示します。番号付けはゼロベースなので、値 0 は、これが包含行の最初の文字であることを示します。
VerificationType | 対応する文字位置に対して実行される検証のタイプを取得または設定します。可能な値は、Normal、AlwaysVerified、および Ignore です。Normal は、標準の OCV です。Normal モードでは、文字は Verified、Confused、または Failed と判定される可能性があります。AlwaysVerified モードでは、この文字位置に関連付けられたキーセット内の各キーに得点を与え、最も得点の高いキーを選択し、文字を常に Verified と判定します。Ignore モードでは、対象の文字に対して処理を一切行いません。Ignore モードでは、文字は常に Verified と判定されます。これは登録時プロパティとみなすことができますが、CogOCVMaxRunParams::GetVerificationType(...) および CogOCVMaxRunParams::SetVerificationType(...) メソッドを介してアクセス可能な、類似した実行時プロパティが存在することに注意してください。通常、登録時と実行時の値は同じ値に設定しますが、これは常に必要なわけではありません。登録時の値 (この値) を Ignore に設定せず、次に、実行時の値を Ignore 以外の値に設定すると実行時エラーが発生します。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.IsEnd プロパティ

この繰り返し指定子が、包含行の最後の文字を超えて配置されているかどうかを示します。

public bool IsEnd {get;}

プロパティ値

この読み取り専用プロパティは、System::Boolean タイプです。

例外

例外タイプ | 条件
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.IsFirst プロパティ

この文字位置が、包含行内の最初の文字位置であるかどうかを示します。

public bool IsFirst {get;}

プロパティ値

この読み取り専用プロパティは、System::Boolean タイプです。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.IsInvalid プロパティ

この繰り返し指定子が、正当な文字に配置されていないかどうかを示します。true の場合 (つまり、配置されていない場合)、文字レベルのプロパティまたはメソッドにアクセスしようとすると、エラーが生成されます。

public bool IsInvalid {get;}

プロパティ値

この読み取り専用プロパティは、System::Boolean タイプです。

例外

例外タイプ | 条件
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.LinePosition プロパティ

包含パラグラフ内での包含行の相対位置を示します。番号付けはゼロベースなので、値 0 は、この文字が包含パラグラフの最初の行内に存在することを示します。

public int LinePosition {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.ParagraphPosition プロパティ

CogOCVMaxPattern オブジェクト内での包含パラグラフの相対位置を示します。番号付けはゼロベースなので、値 0 は、この文字が CogOCVMaxPattern オブジェクトの最初のパラグラフ内に存在することを示します。

public int ParagraphPosition {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

例外

例外タイプ | 条件
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.Position プロパティ

包含行内での、この文字の相対位置を示します。番号付けはゼロベースなので、値 0 は、これが包含行の最初の文字であることを示します。

public int Position {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

例外

例外タイプ | 条件
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.VerificationType プロパティ

対応する文字位置に対して実行される検証のタイプを取得または設定します。可能な値は、Normal、AlwaysVerified、および Ignore です。Normal は、標準の OCV です。Normal モードでは、文字は Verified、Confused、または Failed と判定される可能性があります。AlwaysVerified モードでは、この文字位置に関連付けられたキーセット内の各キーに得点を与え、最も得点の高いキーを選択し、文字を常に Verified と判定します。Ignore モードでは、対象の文字に対して処理を一切行いません。Ignore モードでは、文字は常に Verified と判定されます。これは登録時プロパティとみなすことができますが、CogOCVMaxRunParams::GetVerificationType(...) および CogOCVMaxRunParams::SetVerificationType(...) メソッドを介してアクセス可能な、類似した実行時プロパティが存在することに注意してください。通常、登録時と実行時の値は同じ値に設定しますが、これは常に必要なわけではありません。登録時の値 (この値) を Ignore に設定せず、次に、実行時の値を Ignore 以外の値に設定すると実行時エラーが発生します。

public CogOCVMaxVerificationTypeConstants VerificationType {get; set;}

プロパティ値

CogOCVMaxVerificationTypeConstants タイプの、この読み取り/書き込みプロパティは、Normal、AlwaysVerified、または Ignore のいずれかであることが可能です。

イベント

イベントタイプ | 理由
CharacterChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | この文字繰り返し指定子が、正当な文字位置を参照していない場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator メソッド

CogOCVMaxCharacterIterator クラスのメソッドを次に示します。CogOCVMaxCharacterIterator クラスメンバの完全なリストについては、「CogOCVMaxCharacterIterator メンバ」を参照してください。

パブリックインスタンスメソッド

Copy | オーバロードされます。このメソッドと機能的に同一の、新しく作成された文字繰り返し指定子を返します。新しく作成された文字繰り返し指定子は、同じ包囲パラグラフ内、同じ包囲行内の、同じ文字位置を持ちます。
CreateLineIterator | 包含行に対応する、新しく作成された行繰り返し指定子を返します。このメソッドは、新しく作成されたこの文字繰り返し指定子の親へのアクセスを提供します。
GetDisplayCharacter | この文字繰り返し指定子によって指定される位置に対して、グラフィカルユーザインタフェースで表示される文字を取得します。これは、(登録時) キーセットが 2 つ以上の値を持つ文字位置に有効です。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。
GetDisplayCharacterKey | この文字繰り返し指定子によって指定される位置に対して、グラフィカルユーザインタフェースで表示される文字のキーを取得します。これは、(登録時) キーセットが 2 つ以上の値を持つ文字位置に有効です。
GetKeysetCharacterKeys | この文字繰り返し指定子によって指定される文字位置に対する (登録時) キーセットに対応する、System::Int32 の配列を取得します。この配列の各要素は、この位置で発生する可能性がある文字のキー値です。
GetKeysetCharacters | この文字繰り返し指定子によって指定される文字位置に対する (登録時) キーセットに対応する、文字列を取得します。この文字列内の各個別の文字が、この位置で発生する可能性があります。
MoveToNext | 文字繰り返し指定子を、包含行内の次の文字位置に移動します。この呼び出しの前に、繰り返し指定子が既に最後の位置にある場合、MoveToNext は例外を生成します。エラーを避けるには、MoveToNext を呼び出す前に IsEnd プロパティをチェックしてください。
MoveToPosition | 文字繰り返し指定子を、包含行内の指定された位置に移動します。引数が 0 の場合は、行内の最初の文字位置に移動します。引数が -1 の場合は、行内の最後の文字位置に移動します。引数が正当でない場合は、例外が生成されます。
MoveToPrevious | 文字繰り返し指定子を、包含行内の前の文字位置に移動します。この呼び出しの前に、繰り返し指定子が既に最初の位置にある場合、MoveToPrevious は例外を生成します。エラーを避けるには、MoveToPrevious を呼び出す前に IsFirst プロパティをチェックしてください。
SetDisplay | オーバロードされます。この文字繰り返し指定子によって指定される位置に対して、グラフィカルユーザインタフェースで表示される文字のキーを設定します。これは、(登録時) キーセットが 2 つ以上の値を持つ文字位置に有効です。
SetKeyset | オーバロードされます。この文字繰り返し指定子によって指定される文字位置に対する、(登録時) キーセットを設定します。キー値は System::Int32 の配列として渡され、その配列の各要素は、この位置で発生する可能性がある文字のキー値です。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


Copy メソッド

VisionPro プログラミングリファレンス

CogOCVMaxCharacterIterator.Copy メソッド

このメソッドと機能的に同一の、新しく作成された文字繰り返し指定子を返します。新しく作成された文字繰り返し指定子は、同じ包囲パラグラフ内、同じ包囲行内の、同じ文字位置を持ちます。

オーバロードリスト

このメソッドと機能的に同一の、新しく作成された文字繰り返し指定子を返します。新しく作成された文字繰り返し指定子は、同じ包囲パラグラフ内、同じ包囲行内の、同じ文字位置を持ちます。

public CogOCVMaxCharacterIterator Copy();

この文字繰り返し指定子と同じ包囲行内および同じパラグラフ内にある指定された文字位置に対応する、新しく作成された文字繰り返し指定子を返します。引数は、現在の文字位置からの位置オフセットです。したがって、値 0 によって、このメソッドと機能的に同一な新しい文字繰り返し指定子が得られます。

public CogOCVMaxCharacterIterator Copy(int);

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.Copy メソッド ()

このメソッドと機能的に同一の、新しく作成された文字繰り返し指定子を返します。新しく作成された文字繰り返し指定子は、同じ包囲パラグラフ内、同じ包囲行内の、同じ文字位置を持ちます。

public CogOCVMaxCharacterIterator Copy();

戻り値

この文字繰り返し指定子と同じパラグラフ位置、行位置、および文字位置を持つ CogOCVMaxCharacterIterator。

例外

例外タイプ | 条件
InvalidOperationException | この文字繰り返し指定子を検出できない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxCharacterIterator.Copy オーバロードリスト


CogOCVMaxCharacterIterator.Copy メソッド (Int32)

この文字繰り返し指定子と同じ包囲パラグラフおよび同じ包囲行内にある指定された文字位置に対応する、新しく作成された文字繰り返し指定子を返します。引数は、現在の文字位置からの位置オフセットです。したがって、値 0 によって、このメソッドと機能的に同一な新しい文字繰り返し指定子が得られます。

public CogOCVMaxCharacterIterator Copy(
int PositionOffset
);

パラメータ

PositionOffset
包囲行内の新しい文字位置インデックスを得るために、この文字繰り返し指定子の文字位置インデックスに追加される System::Int32。文字位置インデックスの計算結果が正当でない場合は、例外が生成されます。

戻り値

包含パラグラフ内にある包囲行の指定された文字位置に対応する CogOCVMaxCharacterIterator。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | この文字繰り返し指定子を検出できない場合。
ArgumentOutOfRangeException | 指定された引数から計算される文字位置インデックスが 0 より小さいか、または包囲行内の文字数より大きい場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxCharacterIterator.Copy オーバロードリスト


CogOCVMaxCharacterIterator.CreateLineIterator メソッド

包含行に対応する、新しく作成された行繰り返し指定子を返します。このメソッドは、新しく作成されたこの文字繰り返し指定子の親へのアクセスを提供します。

public CogOCVMaxLineIterator CreateLineIterator();

戻り値

包含行に対応する CogOCVMaxLineIterator。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | この文字繰り返し指定子を検出できない場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.GetDisplayCharacter メソッド

この文字繰り返し指定子によって指定される位置に対して、グラフィカルユーザインタフェースで表示される文字を取得します。これは、(登録時) キーセットが 2 つ以上の値を持つ文字位置に有効です。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

public char GetDisplayCharacter();

戻り値

System::Char。フォント内の文字キーは Unicode コードポイント値に対応するという前提に基づいて、この文字位置に対する表示値として識別される文字キーは System::Char に変換されます。

例外

例外タイプ | 条件
InvalidOperationException | この文字繰り返し指定子を検出できない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.GetDisplayCharacterKey メソッド

この文字繰り返し指定子によって指定される位置に対して、グラフィカルユーザインタフェースで表示される文字のキーを取得します。これは、(登録時) キーセットが 2 つ以上の値を持つ文字位置に有効です。

public int GetDisplayCharacterKey();

戻り値

System::Int32。この文字位置に対する表示値として識別される文字キーです。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | この文字繰り返し指定子を検出できない場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.GetKeysetCharacterKeys メソッド

この文字繰り返し指定子によって指定される文字位置に対する (登録時) キーセットに対応する、System::Int32 の配列を取得します。この配列の各要素は、この位置で発生する可能性がある文字のキー値です。

public int[] GetKeysetCharacterKeys();

戻り値

System::Int32 の配列。この配列のサイズは、この位置で発生する可能性がある異なる文字の数に一致します。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | この文字繰り返し指定子を検出できない場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.GetKeysetCharacters メソッド

この文字繰り返し指定子によって指定される文字位置に対する (登録時) キーセットに対応する、文字列を取得します。この文字列内の各個別の文字が、この位置で発生する可能性があります。

public string GetKeysetCharacters();

戻り値

System::String。この中の各文字は、この位置に対する (登録時) キーセットのメンバに対応しています。つまり、返される文字列内の任意の 1 文字が、この位置で観察される可能性があります。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

例外

例外タイプ | 条件
InvalidOperationException | この文字繰り返し指定子を検出できない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.MoveToNext メソッド

文字繰り返し指定子を、包含行内の次の文字位置に移動します。この呼び出しの前に、繰り返し指定子が既に最後の位置にある場合、MoveToNext は例外を生成します。エラーを避けるには、MoveToNext を呼び出す前に IsEnd プロパティをチェックしてください。

public void MoveToNext();

例外

例外タイプ | 条件
InvalidOperationException | この文字繰り返し指定子を、End を超えてインクリメントしようとした場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.MoveToPosition メソッド

文字繰り返し指定子を、包含行内の指定された位置に移動します。引数が 0 の場合は、行内の最初の文字位置に移動します。引数が -1 の場合は、行内の最後の文字位置に移動します。引数が正当でない場合は、例外が生成されます。

public void MoveToPosition(
int Position
);

パラメータ

Position
包囲行内への System::Int32 インデックス。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | 引数が 0 より小さいか、または包囲行内の文字数より大きい場合。
InvalidOperationException | この文字繰り返し指定子を検出できない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.MoveToPrevious メソッド

文字繰り返し指定子を、包含行内の前の文字位置に移動します。この呼び出しの前に、繰り返し指定子が既に最初の位置にある場合、MoveToPrevious は例外を生成します。エラーを避けるには、MoveToPrevious を呼び出す前に IsFirst プロパティをチェックしてください。

public void MoveToPrevious();

例外

例外タイプ | 条件
InvalidOperationException | この文字繰り返し指定子を検出できない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


SetDisplay メソッド

VisionPro プログラミングリファレンス

CogOCVMaxCharacterIterator.SetDisplay メソッド

この文字繰り返し指定子によって指定される位置に対して、グラフィカルユーザインタフェースで表示される文字を設定します。これは、(登録時) キーセットが 2 つ以上の値を持つ文字位置に有効です。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

オーバロードリスト

この文字繰り返し指定子によって指定される位置に対して、グラフィカルユーザインタフェースで表示される文字を設定します。これは、(登録時) キーセットが 2 つ以上の値を持つ文字位置に有効です。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

public void SetDisplay(char);

この文字繰り返し指定子によって指定される位置に対して、グラフィカルユーザインタフェースで表示される文字のキーを設定します。これは、(登録時) キーセットが 2 つ以上の値を持つ文字位置に有効です。

public void SetDisplay(int);

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.SetDisplay メソッド (Char)

この文字繰り返し指定子によって指定される位置に対して、グラフィカルユーザインタフェースで表示される文字を設定します。これは、(登録時) キーセットが 2 つ以上の値を持つ文字位置に有効です。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

public void SetDisplay(
char NewValue
);

パラメータ

NewValue
System::Char。これは、この文字位置に対して表示される文字です。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。
CharacterChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。

例外

例外タイプ | 条件
InvalidOperationException | この文字繰り返し指定子を検出できない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxCharacterIterator.SetDisplay オーバロードリスト


CogOCVMaxCharacterIterator.SetDisplay メソッド (Int32)

この文字繰り返し指定子によって指定される位置に対して、グラフィカルユーザインタフェースで表示される文字のキーを設定します。これは、(登録時) キーセットが 2 つ以上の値を持つ文字位置に有効です。

public void SetDisplay(
int NewValue
);

パラメータ

NewValue
System::Int32。これは、この文字位置に対して表示される文字のキーです。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。
CharacterChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | この文字繰り返し指定子を検出できない場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxCharacterIterator.SetDisplay オーバロードリスト


SetKeyset メソッド

VisionPro プログラミングリファレンス

CogOCVMaxCharacterIterator.SetKeyset メソッド

この文字繰り返し指定子によって指定される文字位置に対する、(登録時) キーセットを設定します。キー値は System::Int32 の配列として渡され、その配列の各要素は、この位置で発生する可能性がある文字のキー値です。

オーバロードリスト

この文字繰り返し指定子によって指定される文字位置に対する、(登録時) キーセットを設定します。キー値は System::Int32 の配列として渡され、その配列の各要素は、この位置で発生する可能性がある文字のキー値です。

public void SetKeyset(int[]);

この文字繰り返し指定子によって指定される文字位置に対する、(登録時) キーセットを設定します。キー値は System::String として渡され、その中の各文字は、この位置に対するキーセットのメンバに対応しています。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

public void SetKeyset(string);

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterIterator.SetKeyset メソッド (Int32[])

この文字繰り返し指定子によって指定される文字位置に対する、(登録時) キーセットを設定します。キー値は System::Int32 の配列として渡され、その配列の各要素は、この位置で発生する可能性がある文字のキー値です。

public void SetKeyset(
int[] NewValue
);

パラメータ

NewValue
System::Int32 の配列。この配列の各要素は、この位置で発生する可能性がある文字のキー値です。

イベント

イベントタイプ | 理由
CharacterChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | この文字繰り返し指定子を検出できない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxCharacterIterator.SetKeyset オーバロードリスト


CogOCVMaxCharacterIterator.SetKeyset メソッド (String)

この文字繰り返し指定子によって指定される文字位置に対する、(登録時) キーセットを設定します。キー値は System::String として渡され、その中の各文字は、この位置に対するキーセットのメンバに対応しています。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

public void SetKeyset(
string NewValue
);

パラメータ

NewValue
System::String。この中の各文字は、この位置に対する (登録時) キーセットのメンバに対応しています。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

イベント

イベントタイプ | 理由
CharacterChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | この文字繰り返し指定子を検出できない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxCharacterIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxCharacterIterator.SetKeyset オーバロードリスト


CogOCVMaxCharacterRegistrationConstants 列挙体

検出された各文字に対して実行されるレジストレーション (フィット処理) のタイプを選択するために使用される定数です。

public enum CogOCVMaxCharacterRegistrationConstants

メンバ

メンバ名 | 説明
Nonlinear | レジストレーションは、実行時文字の大幅な変位をモデル化することが可能な、非線形変換を使用してすべて実行されます。この実行には、最も長い時間を要します。
Bent | レジストレーションは、アフィン変換を使用して実行され、次に、少量のワーピングをモデル化するためにさらに最適化されます。
Standard | レジストレーションは、5 つの自由度 (アフィンのみ、スキューなし) を使用して実行されます。この実行には、最も短い時間を要します。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult クラス

このクラスは、1 つの文字についての結果情報のすべてを保持します。

このタイプのメンバすべてのリストについては、「CogOCVMaxCharacterResult メンバ」を参照してください。

System.Object
MarshalByRefObject
CogObjectBase
CogSerializableObjectBase
CogOCVMaxCharacterResult

public class CogOCVMaxCharacterResult :CogSerializableObjectBase

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxCharacterResult メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult メンバ

CogOCVMaxCharacterResult の概要

パブリックインスタンスコンストラクタ

CogOCVMaxCharacterResult オーバロードされます。CogOCVMaxCharacterResult クラスの新しいインスタンスを初期化します。

パブリックインスタンスプロパティ

Character | この位置で検出された文字です。何かが実際に検出されたと仮定されています (例えば、CharacterKey が -1 ではないということなど)。また、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。
CharacterArrangementPose | 配置空間内での、この文字のポーズです。このプロパティは、CharacterArrangementPoseValid が true の場合のみ有効であることに注意してください。
CharacterArrangementPoseValid | 配置空間内での、この文字のポーズが、正常に計算されたかどうかを示します。
CharacterIndex | ゼロベースの文字インデックスです。これは、包含行内のどの文字が、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。
CharacterKey | この位置で検出された文字のキーです。VerificationStatus が Failed である場合、またはサーチに対する検証タイプが CogOCVMaxVerificationTypeConstants::Ignore であった場合、このプロパティは -1 になります。
CharacterParagraphPose | パラグラフ空間内での、この文字のポーズです。このプロパティは、CharacterParagraphPoseValid が true の場合のみ有効であることに注意してください。
CharacterParagraphPoseValid | パラグラフ空間内での、この文字のポーズが、正常に計算されたかどうかを示します。
CharacterSelectedBounds | 選択空間内での、検出された文字の外接アフィン矩形です。このプロパティは、CharacterSelectedBoundsValid が true の場合のみ有効であることに注意してください。
CharacterSelectedBoundsValid | 選択空間内での、この文字の境界が、正常に計算されたかどうかを示します。
CharacterSelectedPose | 選択空間内での、この文字のポーズです。このプロパティは、CharacterSelectedPoseValid が true の場合のみ有効であることに注意してください。
CharacterSelectedPoseValid | 選択空間内での、この文字のポーズが、正常に計算されたかどうかを示します。
ConfidenceScore | この文字の信頼性得点です。この得点は、この文字の検証得点から最高の ConfusionScore の得点を減算した値ですが、0 より小さくなることはありません。
ConfusionKeys | VerificationStatus が Confused の場合は、この文字との紛らわしさを発生させている文字の文字キーです。VerificationStatus が Confused でない場合、このプロパティは空の配列になります。この配列の要素は、ConfusionScores 配列の要素に対応します。
ConfusionScores | VerificationStatus が Confused の場合は、この文字との紛らわしさを発生させている文字のコンフュージョン得点です。VerificationStatus が Confused でない場合、このプロパティは空の配列になります。この配列の要素は、ConfusionKeys 配列の要素に対応します。
Empty | この文字位置が空 (つまり、Failed で、かつ違反情報を持っていない) であったかどうかを示します。
FitError | この文字の一致誤差です。0 が可能な最良の値であり、値が大きくなるにつれて悪くなります。理論的な上限はありませんが、実際の値としては、通常、10 未満です。値が得られない場合は、-1 になります。
LineIndex | ゼロベースの行インデックスです。これは、包含パラグラフ内のどの行が、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。
ParagraphIndex | ゼロベースのパラグラフインデックスです。これは、配置内のどのパラグラフが、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。
VerificationDOFScore | この文字の検証 DOF 得点です。
VerificationFullViolations | 検証フル違反を示します。この検証フル違反は、違反したフルサーチパラメータ (つまり、画像または起点ポーズ) の自由度 (DOF) です。したがって、この文字についての VerificationDOFScore が減少します。
VerificationKeyViolations | 検証キー違反を示します。この検証キー違反は、違反したキーサーチパラメータの自由度 (DOF) です。したがって、この文字についての VerificationDOFScore が減少します。
VerificationMatchScore | この文字の検証一致得点です。
VerificationScore | この文字の検証得点です。
VerificationStatus | この文字の検証ステータスです。可能な値としては、Verified、Confused、および Failed があります。

プロテクトインスタンスコンストラクタ

CogOCVMaxCharacterResult オーバロードされます。CogOCVMaxCharacterResult クラスの新しいインスタンスを初期化します。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult コンストラクタ

オーバロードリスト

指定された CogOCVMaxCharacterResult オブジェクトのディープコピーを構築します。

public CogOCVMaxCharacterResult(CogOCVMaxCharacterResult);

protected CogOCVMaxCharacterResult(SerializationInfo,StreamingContext);

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult コンストラクタ (SerializationInfo, StreamingContext)

protected CogOCVMaxCharacterResult(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxCharacterResult コンストラクタオーバロードリスト


CogOCVMaxCharacterResult コンストラクタ (CogOCVMaxCharacterResult)

指定された CogOCVMaxCharacterResult オブジェクトのディープコピーを構築します。

public CogOCVMaxCharacterResult(
CogOCVMaxCharacterResult pOther
);

パラメータ

pOther
コピーされる CogOCVMaxCharacterResult オブジェクト。NULL であってはなりません。

例外

例外タイプ | 条件
OutOfMemoryException | このオブジェクトにメモリを割り当てることができない場合。
ArgumentNullException | 入力引数が NULL の場合。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxCharacterResult コンストラクタオーバロードリスト


CogOCVMaxCharacterResult プロパティ

CogOCVMaxCharacterResult クラスのプロパティを次に示します。CogOCVMaxCharacterResult クラスメンバの完全なリストについては、「CogOCVMaxCharacterResult メンバ」を参照してください。

パブリックインスタンスプロパティ

Character | この位置で検出された文字です。何かが実際に検出されたと仮定されています (例えば、CharacterKey が -1 ではないということなど)。また、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。
CharacterArrangementPose | 配置空間内での、この文字のポーズです。このプロパティは、CharacterArrangementPoseValid が true の場合のみ有効であることに注意してください。
CharacterArrangementPoseValid | 配置空間内での、この文字のポーズが、正常に計算されたかどうかを示します。
CharacterIndex | ゼロベースの文字インデックスです。これは、包含行内のどの文字が、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。
CharacterKey | この位置で検出された文字のキーです。VerificationStatus が Failed である場合、またはサーチに対する検証タイプが CogOCVMaxVerificationTypeConstants::Ignore であった場合、このプロパティは -1 になります。
CharacterParagraphPose | パラグラフ空間内での、この文字のポーズです。このプロパティは、CharacterParagraphPoseValid が true の場合のみ有効であることに注意してください。
CharacterParagraphPoseValid | パラグラフ空間内での、この文字のポーズが、正常に計算されたかどうかを示します。
CharacterSelectedBounds | 選択空間内での、検出された文字の外接アフィン矩形です。このプロパティは、CharacterSelectedBoundsValid が true の場合のみ有効であることに注意してください。
CharacterSelectedBoundsValid | 選択空間内での、この文字の境界が、正常に計算されたかどうかを示します。
CharacterSelectedPose | 選択空間内での、この文字のポーズです。このプロパティは、CharacterSelectedPoseValid が true の場合のみ有効であることに注意してください。
CharacterSelectedPoseValid | 選択空間内での、この文字のポーズが、正常に計算されたかどうかを示します。
ConfidenceScore | この文字の信頼性得点です。この得点は、この文字の検証得点から最高の ConfusionScore の得点を減算した値ですが、0 より小さくなることはありません。
ConfusionKeys | VerificationStatus が Confused の場合は、この文字との紛らわしさを発生させている文字の文字キーです。VerificationStatus が Confused でない場合、このプロパティは空の配列になります。この配列の要素は、ConfusionScores 配列の要素に対応します。
ConfusionScores | VerificationStatus が Confused の場合は、この文字との紛らわしさを発生させている文字のコンフュージョン得点です。VerificationStatus が Confused でない場合、このプロパティは空の配列になります。この配列の要素は、ConfusionKeys 配列の要素に対応します。
Empty | この文字位置が空 (つまり、Failed で、かつ違反情報を持っていない) であったかどうかを示します。
FitError | この文字の一致誤差です。0 が可能な最良の値であり、値が大きくなるにつれて悪くなります。理論的な上限はありませんが、実際の値としては、通常、10 未満です。値が得られない場合は、-1 になります。
LineIndex | ゼロベースの行インデックスです。これは、包含パラグラフ内のどの行が、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。
ParagraphIndex | ゼロベースのパラグラフインデックスです。これは、配置内のどのパラグラフが、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。
VerificationDOFScore | この文字の検証 DOF 得点です。
VerificationFullViolations | 検証フル違反を示します。この検証フル違反は、違反したフルサーチパラメータ (つまり、画像または起点ポーズ) の自由度 (DOF) です。したがって、この文字についての VerificationDOFScore が減少します。
VerificationKeyViolations | 検証キー違反を示します。この検証キー違反は、違反したキーサーチパラメータの自由度 (DOF) です。したがって、この文字についての VerificationDOFScore が減少します。
VerificationMatchScore | この文字の検証一致得点です。
VerificationScore | この文字の検証得点です。
VerificationStatus | この文字の検証ステータスです。可能な値としては、Verified、Confused、および Failed があります。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.Character プロパティ

この位置で検出された文字です。何かが実際に検出されたと仮定されています (例えば、CharacterKey が -1 ではないということなど)。また、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。

public char Character {get;}

プロパティ値

この読み取り専用プロパティは、System::Char タイプです。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.CharacterArrangementPose プロパティ

配置空間内での、この文字のポーズです。このプロパティは、CharacterArrangementPoseValid が true の場合のみ有効であることに注意してください。

public Cognex.VisionPro.CogTransform2DLinear CharacterArrangementPose {get;}

プロパティ値

この読み取り専用プロパティは、CogTransform2DLinear タイプです。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.CharacterArrangementPoseValid プロパティ

配置空間内での、この文字のポーズが、正常に計算されたかどうかを示します。

public bool CharacterArrangementPoseValid {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.CharacterIndex プロパティ

ゼロベースの文字インデックスです。これは、包含行内のどの文字が、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。

public int CharacterIndex {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.CharacterKey プロパティ

この位置で検出された文字のキーです。VerificationStatus が Failed である場合、またはサーチに対する検証タイプが CogOCVMaxVerificationTypeConstants::Ignore であった場合、このプロパティは -1 になります。

public int CharacterKey {get;}

プロパティ値

System::Int32 タイプの、この読み取り専用プロパティは、文字が正常に検出されなかった場合は -1 になります。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.CharacterParagraphPose プロパティ

パラグラフ空間内での、この文字のポーズです。このプロパティは、CharacterParagraphPoseValid が true の場合のみ有効であることに注意してください。

public Cognex.VisionPro.CogTransform2DLinear CharacterParagraphPose {get;}

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.CharacterParagraphPoseValid プロパティ

パラグラフ空間内での、この文字のポーズが、正常に計算されたかどうかを示します。

public bool CharacterParagraphPoseValid {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.CharacterSelectedBounds プロパティ

選択空間内での、検出された文字の外接アフィン矩形です。このプロパティは、CharacterSelectedBoundsValid が true の場合のみ有効であることに注意してください。

public Cognex.VisionPro.CogRectangleAffine CharacterSelectedBounds {get;}

プロパティ値

この読み取り専用プロパティは、CogRectangleAffine タイプです。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.CharacterSelectedBoundsValid プロパティ

選択空間内での、この文字の境界が、正常に計算されたかどうかを示します。

public bool CharacterSelectedBoundsValid {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.CharacterSelectedPose プロパティ

選択空間内での、この文字のポーズです。このプロパティは、CharacterSelectedPoseValid が true の場合のみ有効であることに注意してください。

public Cognex.VisionPro.CogTransform2DLinear CharacterSelectedPose {get;}

プロパティ値

この読み取り専用プロパティは、CogTransform2DLinear タイプです。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.CharacterSelectedPoseValid プロパティ

選択空間内での、この文字のポーズが、正常に計算されたかどうかを示します。

public bool CharacterSelectedPoseValid {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.ConfidenceScore プロパティ

この文字の信頼性得点です。この得点は、この文字の検証得点から最高の ConfusionScore の得点を減算した値ですが、0 より小さくなることはありません。

public double ConfidenceScore {get;}

プロパティ値

System::Double タイプの、この読み取り専用プロパティは、0 ～ 1 の範囲になります。この文字の検証タイプが Ignore である場合、このプロパティは 1 になります。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.ConfusionKeys プロパティ

VerificationStatus が Confused の場合は、この文字との紛らわしさを発生させている文字の文字キーです。VerificationStatus が Confused でない場合、このプロパティは空の配列になります。この配列の要素は、ConfusionScores 配列の要素に対応します。

public int[] ConfusionKeys {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 の System::Array タイプです。VerificationStatus が Confused でない場合、このプロパティは空の配列になります。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.ConfusionScores プロパティ

VerificationStatus が Confused の場合は、この文字との紛らわしさを発生させている文字のコンフュージョン得点です。VerificationStatus が Confused でない場合、このプロパティは空の配列になります。この配列の要素は、ConfusionKeys 配列の要素に対応します。

public double[] ConfusionScores {get;}

プロパティ値

この読み取り専用プロパティは、System::Double の System::Array タイプです。VerificationStatus が Confused でない場合、このプロパティは空の配列になります。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.Empty プロパティ

この文字位置が空 (つまり、Failed で、かつ違反情報を持っていない) であったかどうかを示します。

public bool Empty {get;}

プロパティ値

この読み取り専用プロパティは、System::Boolean タイプです。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.FitError プロパティ

この文字の一致誤差です。0 が可能な最良の値であり、値が大きくなるにつれて悪くなります。理論的な上限はありませんが、実際の値としては、通常、10 未満です。値が得られない場合は、-1 になります。

public double FitError {get;}

プロパティ値

System::Double タイプの、この読み取り専用プロパティは、0.0 (最良) ～ 無限大 (最悪) の範囲になります。値が得られない場合は、-1.0 になります。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.LineIndex プロパティ

ゼロベースの行インデックスです。これは、包含パラグラフ内のどの行が、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。

public int LineIndex {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.ParagraphIndex プロパティ

ゼロベースのパラグラフインデックスです。これは、配置内のどのパラグラフが、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。

public int ParagraphIndex {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.VerificationDOFScore プロパティ

この文字の検証 DOF 得点です。

public double VerificationDOFScore {get;}

プロパティ値

System::Double タイプの、この読み取り専用プロパティは、0 (最悪) ～ 1 (最良) の範囲になります。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.VerificationFullViolations プロパティ

検証フル違反を示します。この検証フル違反は、違反したフルサーチパラメータ (つまり、画像または起点ポーズ) の自由度 (DOF) です。したがって、この文字についての VerificationDOFScore が減少します。

public CogOCVMaxDOFConstants VerificationFullViolations {get;}

プロパティ値

この読み取り専用プロパティは、CogOCVMaxDOFConstants のビット単位の OR です。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.VerificationKeyViolations プロパティ

検証キー違反を示します。この検証キー違反は、違反したキーサーチパラメータの自由度 (DOF) です。したがって、この文字についての VerificationDOFScore が減少します。

public CogOCVMaxDOFConstants VerificationKeyViolations {get;}

プロパティ値

この読み取り専用プロパティは、CogOCVMaxDOFConstants のビット単位の OR です。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.VerificationMatchScore プロパティ

この文字の検証一致得点です。

public double VerificationMatchScore {get;}

プロパティ値

System::Double タイプの、この読み取り専用プロパティは、0 (最悪) ～ 1 (最良) の範囲になります。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.VerificationScore プロパティ

この文字の検証得点です。

public double VerificationScore {get;}

プロパティ値

System::Double タイプの、この読み取り専用プロパティは、0 (最悪) ～ 1 (最良) の範囲になります。この文字の検証タイプが Ignore である場合、このプロパティは 1 になります。この得点は、検証一致得点に検証 DOF 得点を乗算した値に等しくなります。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterResult.VerificationStatus プロパティ

この文字の検証ステータスです。可能な値としては、Verified、Confused、および Failed があります。

public CogOCVMaxCharacterStatusConstants VerificationStatus {get;}

プロパティ値

CogOCVMaxCharacterStatusConstants タイプの、この読み取り専用プロパティは、Verified、Confused、または Failed のいずれかであることが可能です。

参照

CogOCVMaxCharacterResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterStatusConstants 列挙体

1 つの文字の検査に対する総合的な結果を記述する定数です。

public enum CogOCVMaxCharacterStatusConstants

メンバ

メンバ名 | 説明
Failed | 対象の文字が、すべての検査基準を満たしてはいません。
Confused | 対象の文字が、ほかの文字と紛らわしくなっている可能性があります。
Verified | 対象の文字が、すべての検査基準を満たしています。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCharacterTypeConstants 列挙体

特定のパラグラフのアルファベットに、指定されたフォント内のどの文字を組み込むかを指定する際に役立つ定数です。この定数は、各文字を明示的にリストするよりも容易な、アルファベット指定方法を提供するために有効です。

この列挙体は、メンバ値のビットごとの組み合わせを可能にする FlagsAttribute 属性を持っています。

public enum CogOCVMaxCharacterTypeConstants

メンバ

メンバ名 | 説明 | 値
All | 利用可能なすべての文字を、対象のパラグラフのアルファベットに使用します。これによって、登録および検査の両方の実行が必要以上に遅くなる可能性があります。 | -1
UppercaseLetter | 大文字として識別される文字 (A、B、C、など) を、対象のパラグラフのアルファベットに使用します。 | 4
LowercaseLetter | 小文字として識別される文字 (a、b、c、など) を、対象のパラグラフのアルファベットに使用します。 | 2
DecimalDigitNumber | 10 進数の数字として識別される文字 (0、1、2、など) を、対象のパラグラフのアルファベットに使用します。 | 1
None | 利用可能な文字のいずれも、対象のパラグラフのアルファベットに使用しません。 | 0

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxComputePosesConstants 列挙体

どのポーズを実行時に計算するかを指定するために使用される定数です。ポーズの計算は、追加の実行時間を要するため、すべてのアプリケーションで必要とされるとは限りません。個別の文字のポーズは、必ず計算されることに注意してください。

この列挙体は、メンバ値のビットごとの組み合わせを可能にする FlagsAttribute 属性を持っています。

public enum CogOCVMaxComputePosesConstants

メンバ

メンバ名 | 説明 | 値
All | すべてのポーズを計算します。 | -1
Line | 行のポーズを計算します。 | 1
Arrangement | 配置のポーズを計算します。 | 4
Paragraph | パラグラフのポーズを計算します。 | 2
None | オプションのポーズ (行、パラグラフ、または配置) のいずれも計算しません。 | 0

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCurrentRecordConstants 列挙体

ツールの CurrentRecord に含まれることが可能なデータの列挙体です。

この列挙体は、メンバ値のビットごとの組み合わせを可能にする FlagsAttribute 属性を持っています。

public enum CogOCVMaxCurrentRecordConstants

メンバ

メンバ名 | 説明 | 値
All | すべての可能なレコードを CurrentRecord に含めます。 | -1
Region | 処理される領域を CurrentRecord に含めます。 | 2
InputImage | 入力画像を CurrentRecord に含めます。 | 1
None | どのレコードも CurrentRecord に含めません。 | 0

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxCustomizationTypeConstants 列挙体

CogOCVMaxPattern オブジェクトのカスタマイズに使用される定数です。

public enum CogOCVMaxCustomizationTypeConstants

メンバ

メンバ名 | 説明
KeySearch | キー - キーサーチアルゴリズムにカスタマイズが適用されます。
ImageSearch | 画像サーチアルゴリズムにカスタマイズが適用されます。
OCVMaxTool | OCVMax ツールそのものにカスタマイズが適用されます。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxDOFAttributeConstants 列挙体

特定のサーチ自由度 (DOF) のどの側面がアクセスされるかを指定するために役立つ定数です。そのような属性は、一度に 1 つだけアクセスされることが可能です。

public enum CogOCVMaxDOFAttributeConstants

メンバ

メンバ名 | 説明
Overlap | 特定の DOF の Overlap 値を選択します。この値は、2 つのインスタンスが同じ結果であるとみなされるために、オーバラップしている必要がある量です。
UpperLimit | 特定の DOF の UpperLimit 値を選択します。この値は、対象の DOF が有効にされている場合にサーチされる範囲の上限です。
LowerLimit | 特定の DOF の LowerLimit 値を選択します。この値は、対象の DOF が有効にされている場合にサーチされる範囲の下限です。
Nominal | 特定の DOF の標準値を選択します。この値は、対象の DOF が有効にされていない場合に使用される値です。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxDOFConstants 列挙体

サーチ自由度 (DOF) を指定するために使用される定数です。

この列挙体は、メンバ値のビットごとの組み合わせを可能にする FlagsAttribute 属性を持っています。

public enum CogOCVMaxDOFConstants

メンバ

メンバ名 | 説明 | 値
All | すべてのサーチ自由度。 | -1
TranslationY | Y 方向の移動。文字、行、結果、または配置結果の DOF 違反をレポートするためにのみ使用されます。CogOCVMaxSearchParams::DOFEnabled プロパティによって無視されます。 | 32768
TranslationX | X 方向の移動。文字、行、結果、または配置結果の DOF 違反をレポートするためにのみ使用されます。CogOCVMaxSearchParams::DOFEnable プロパティによって無視されます。 | 16384
Aspect | アスペクト比。文字、行、結果、または配置結果の DOF 違反をレポートするためにのみ使用されます。CogOCVMaxSearchParams::DOFEnable プロパティによって無視されます。 | 8192
Shear | せん断のサーチ自由度。 | 16
ScaleY | Y 方向のスケールのサーチ自由度。 | 8
ScaleX | X 方向のスケールのサーチ自由度。 | 4
Scale | 均等スケールのサーチ自由度。 | 2
Rotation | 角度のサーチ自由度。 | 1
None | サーチ自由度なし。 | 0

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont クラス

このクラスは、1 つのフォントに関連付けられた幾何学文字ディスクリプションのセットを表します。幾何学ディスクリプションデータは、定義済みのフォントファイルから読み取ります。通常、ユーザはフォントファイルを作成しません。ただし、サイズや行間隔など、特定のフォント特性を調整することは可能です。

このタイプのメンバすべてのリストについては、「CogOCVMaxFont メンバ」を参照してください。

System.Object
MarshalByRefObject
CogObjectBase
CogSerializableObjectBase
CogSerializableChangedEventBase
CogOCVMaxFont

public class CogOCVMaxFont :CogSerializableChangedEventBase, IDisposable

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxFont メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont メンバ

CogOCVMaxFont の概要

パブリックスタティックフィールド

SfFontName
SfFontType
SfGetAvailableCharacters
SfGetCharacterFullBounds
SfGetCharacterMarkBounds
SfGetCharacterPoses
SfGetDefaultBlankCharacter
SfHasBlank
SfImported
SfLineSpacingX
SfLineSpacingY
SfProportional
SfSpotSize
SfSpotSizeUsed
SfSpotSpacingUsed

パブリックスタティックメソッド

GetAvailableFontNames 指定されたフォントファイル内で入手可能な、各フォントの名前をリストします。

プロテクトスタティックフィールド

SfNextSf

パブリックインスタンスコンストラクタ

CogOCVMaxFont オーバロードされます。CogOCVMaxFont クラスの新しいインスタンスを初期化します。

パブリックインスタンスプロパティ

FontName | インポートされたフォントファイル内で定義された、このフォントの名前です。フォントファイルをインポートする前に、この読み取り専用プロパティがアクセスされると、例外が生成されます。
FontType | このフォントの固有スタイル (Raster、Stroke、または Outline) です。
HasBlank | このフォントがブランクの文字を持つかどうかを示します。すべてのフォントがブランクの文字を持つわけではありません。
Imported | このフォントがフォントファイルからインポートされているかどうかを示します。インポートされている場合は true、インポートされていない場合は false になります。ほかの CogOCVMaxFont プロパティおよびメソッドのほとんどは、このプロパティが true である必要があります。
LineSpacingX | このプロパティは、このフォントにおいて隣接する行の原点間の (水平) 間隔です。
LineSpacingY | このプロパティは、このフォントにおいて隣接する行の原点間の (垂直) 間隔です。
Proportional | このフォントがプロポーショナルであるかどうかを示します。文字がすべて同じアドバンス値を持つわけではない場合、フォントはプロポーショナルです。
SpotSize | レーザプリンタでは、レーザビームが感光性ドラムを横切って掃引されます。ドラム表面における、レーザビームのマイクロメートル単位の直径が、スポットサイズです。そのほかの印刷プロセスには、固有のスポットサイズ定義があります。すべてのフォントがスポットサイズを使用するわけではないことに注意してください。SpotSize プロパティへのアクセスを試みる前に、最初に SpotSizeUsed プロパティをチェックしてください。
SpotSizeUsed | このフォントがスポットサイズを使用するかどうかを示します。このプロパティが false の場合は、スポットサイズを取得または設定することはできません (試みると例外がスローされます)。ほとんどのフォントプロパティと同様に、フォントファイルをインポートする前に、この読み取り専用プロパティがアクセスされると、例外が生成されます。
SpotSpacingUsed | このフォントがスポット間隔を使用するかどうかを示します。通常、ラスタフォントおよびストロークフォントはスポット間隔を使用できますが、アウトラインフォントはスポット間隔を使用することはできません。ほとんどのフォントプロパティと同様に、フォントファイルをインポートする前に、この読み取り専用プロパティがアクセスされると、例外が生成されます。

パブリックインスタンスメソッド

Dispose | オーバロードされます。
GetAvailableCharacterKeys | このフォントで利用可能な各文字キーのリストを提供します。
GetAvailableCharacters | このフォントで利用可能な各文字のリストを提供します。
GetCharacterFullBounds | オーバロードされます。指定されたテキスト内の各文字の、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのフル境界は、このフォントおよび指定されたパラメータを使用して決定されます。
GetCharacterMarkBounds | オーバロードされます。指定されたテキスト内の各文字マークの、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのマーク境界は、このフォントおよび指定されたパラメータを使用して決定されます。
GetCharacterPoses | オーバロードされます。指定されたテキスト内の各文字の、個別の選択空間ポーズに対応する、CogTransform2DLinear の System::Array を作成します。これらのポーズは、このフォントおよび指定されたパラメータを使用して決定されます。
GetDefaultBlankCharacter | このフォントの、デフォルトのブランクの文字を提供します。多くのフォントがブランクの文字を複数持つため、このメソッドは、デフォルトのブランクとして使用されるものを 1 つ識別します。
GetDefaultBlankCharacterKey | このフォントの、デフォルトのブランクの文字のキーを提供します。多くのフォントがブランクの文字を複数持つため、このメソッドは、デフォルトのブランクとして使用されるものを 1 つ識別します。
GetLineSpacingX | このメソッドは、指定された CogOCVMaxFontRenderParams オブジェクトを使用して解釈される、このフォントにおいて隣接する行の原点間の (水平) 間隔です。通常、これは、LineSpacingX プロパティゲッタによって返される値と同じになります。ただし、このフォントについての SpotSpacingUsed が true の場合、このメソッドによって返される値は、LineSpacingX ゲッタによって返される値に、指定された render params オブジェクトの SpotSpacingScaleX プロパティを乗算した値になります。
GetLineSpacingY | このメソッドは、指定された CogOCVMaxFontRenderParams オブジェクトを使用して解釈される、このフォントにおいて隣接する行の原点間の (垂直) 間隔です。通常、これは、LineSpacingY プロパティゲッタによって返される値と同じになります。ただし、このフォントについての SpotSpacingUsed が true の場合、このメソッドによって返される値は、LineSpacingY ゲッタによって返される値に、指定された render params オブジェクトの SpotSpacingScaleY プロパティを乗算した値になります。
Import | オーバロードされます。指定されたファイル内の最初のフォントディスクリプションを読み取ります。このフォントディスクリプションによって、以前にインポートされたフォントディスクリプションは差し替えられます。現在ロードされているフォント内で、SpotSize と LineSpacing の両方またはどちらかを変更した場合、これらの設定は失われます。
IsBlank | オーバロードされます。指定された文字キーに対応する文字がこのフォント内でブランクとみなされるかどうかを判定します。多くのフォントがブランクの文字を複数持つことに注意してください。
RenderCompositeShape | オーバロードされます。指定されたテキストがそのアウトラインによってグラフィカルに表された、CogCompositeShape を作成します。このアウトラインは、このフォントおよび指定されたパラメータを使用して、描画時に、テキストから導出されます。
RenderImage | オーバロードされます。指定されたテキストがこのフォントおよび指定されたパラメータを使用して描画された、画像を作成します。

プロテクトインスタンスコンストラクタ

CogOCVMaxFont オーバロードされます。CogOCVMaxFont クラスの新しいインスタンスを初期化します。

プロテクトインスタンスメソッド

__dtor |
Dispose | オーバロードされます。
Finalize |
GetObjectData |

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont コンストラクタ

オーバロードリスト

CogOCVMaxFont クラスの新しいインスタンスを初期化します。

public CogOCVMaxFont();

public CogOCVMaxFont(CogOCVMaxFont);

protected CogOCVMaxFont(SerializationInfo,StreamingContext);

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont コンストラクタ (SerializationInfo, StreamingContext)

protected CogOCVMaxFont(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont コンストラクタオーバロードリスト


CogOCVMaxFont コンストラクタ (CogOCVMaxFont)

public CogOCVMaxFont(
CogOCVMaxFont pOther
);

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont コンストラクタオーバロードリスト


CogOCVMaxFont コンストラクタ ()

CogOCVMaxFont クラスの新しいインスタンスを初期化します。

public CogOCVMaxFont();

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont コンストラクタオーバロードリスト


CogOCVMaxFont フィールド

CogOCVMaxFont クラスのフィールドを次に示します。CogOCVMaxFont クラスメンバの完全なリストについては、「CogOCVMaxFont メンバ」を参照してください。

パブリックスタティックフィールド

SfFontName
SfFontType
SfGetAvailableCharacters
SfGetCharacterFullBounds
SfGetCharacterMarkBounds
SfGetCharacterPoses
SfGetDefaultBlankCharacter
SfHasBlank
SfImported
SfLineSpacingX
SfLineSpacingY
SfProportional
SfSpotSize
SfSpotSizeUsed
SfSpotSpacingUsed

プロテクトスタティックフィールド

SfNextSf

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfFontName フィールド

public const long SfFontName;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfFontType フィールド

public const long SfFontType;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfGetAvailableCharacters フィールド

public const long SfGetAvailableCharacters;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfGetCharacterFullBounds フィールド

public const long SfGetCharacterFullBounds;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfGetCharacterMarkBounds フィールド

public const long SfGetCharacterMarkBounds;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfGetCharacterPoses フィールド

public const long SfGetCharacterPoses;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfGetDefaultBlankCharacter フィールド

public const long SfGetDefaultBlankCharacter;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfHasBlank フィールド

public const long SfHasBlank;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfImported フィールド

public const long SfImported;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfLineSpacingX フィールド

public const long SfLineSpacingX;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfLineSpacingY フィールド

public const long SfLineSpacingY;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfNextSf フィールド

new protected const long SfNextSf;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfProportional フィールド

public const long SfProportional;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfSpotSize フィールド

public const long SfSpotSize;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfSpotSizeUsed フィールド

public const long SfSpotSizeUsed;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SfSpotSpacingUsed フィールド

public const long SfSpotSpacingUsed;

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont プロパティ

CogOCVMaxFont クラスのプロパティを次に示します。CogOCVMaxFont クラスメンバの完全なリストについては、「CogOCVMaxFont メンバ」を参照してください。

パブリックインスタンスプロパティ

FontName | インポートされたフォントファイル内で定義された、このフォントの名前です。フォントファイルをインポートする前に、この読み取り専用プロパティがアクセスされると、例外が生成されます。
FontType | このフォントの固有スタイル (Raster、Stroke、または Outline) です。
HasBlank | このフォントがブランクの文字を持つかどうかを示します。すべてのフォントがブランクの文字を持つわけではありません。
Imported | このフォントがフォントファイルからインポートされているかどうかを示します。インポートされている場合は true、インポートされていない場合は false になります。ほかの CogOCVMaxFont プロパティおよびメソッドのほとんどは、このプロパティが true である必要があります。
LineSpacingX | このプロパティは、このフォントにおいて隣接する行の原点間の (水平) 間隔です。
LineSpacingY | このプロパティは、このフォントにおいて隣接する行の原点間の (垂直) 間隔です。
Proportional | このフォントがプロポーショナルであるかどうかを示します。文字がすべて同じアドバンス値を持つわけではない場合、フォントはプロポーショナルです。
SpotSize | レーザプリンタでは、レーザビームが感光性ドラムを横切って掃引されます。ドラム表面における、レーザビームのマイクロメートル単位の直径が、スポットサイズです。そのほかの印刷プロセスには、固有のスポットサイズ定義があります。すべてのフォントがスポットサイズを使用するわけではないことに注意してください。SpotSize プロパティへのアクセスを試みる前に、最初に SpotSizeUsed プロパティをチェックしてください。
SpotSizeUsed | このフォントがスポットサイズを使用するかどうかを示します。このプロパティが false の場合は、スポットサイズを取得または設定することはできません (試みると例外がスローされます)。ほとんどのフォントプロパティと同様に、フォントファイルをインポートする前に、この読み取り専用プロパティがアクセスされると、例外が生成されます。
SpotSpacingUsed | このフォントがスポット間隔を使用するかどうかを示します。通常、ラスタフォントおよびストロークフォントはスポット間隔を使用できますが、アウトラインフォントはスポット間隔を使用することはできません。ほとんどのフォントプロパティと同様に、フォントファイルをインポートする前に、この読み取り専用プロパティがアクセスされると、例外が生成されます。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.FontName プロパティ

インポートされたフォントファイル内で定義された、このフォントの名前です。フォントファイルをインポートする前に、この読み取り専用プロパティがアクセスされると、例外が生成されます。

public string FontName {get;}

プロパティ値

この読み取り専用プロパティは、String タイプです。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.FontType プロパティ

このフォントの固有スタイル (Raster、Stroke、または Outline) です。

public CogOCVMaxFontTypeConstants FontType {get;}

プロパティ値

CogOCVMaxFontTypeConstants タイプの、この読み取り専用プロパティは、Raster、Stroke、または Outline のいずれかであることが可能です。この値は、インポートされたフォントファイル内で定義されています。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.HasBlank プロパティ

このフォントがブランクの文字を持つかどうかを示します。すべてのフォントがブランクの文字を持つわけではありません。

public bool HasBlank {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.Imported プロパティ

このフォントがフォントファイルからインポートされているかどうかを示します。インポートされている場合は true、インポートされていない場合は false になります。ほかの CogOCVMaxFont プロパティおよびメソッドのほとんどは、このプロパティが true である必要があります。

public bool Imported {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

例外

例外タイプ | 条件
InvalidOperationException | 内部エラーが発生した場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.LineSpacingX プロパティ

このプロパティは、このフォントにおいて隣接する行の原点間の (水平) 間隔です。

public double LineSpacingX {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、通常はゼロです。ゼロ以外の値では、1 つの行が次の行を基準にしてずれます。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.LineSpacingY プロパティ

このプロパティは、このフォントにおいて隣接する行の原点間の (垂直) 間隔です。

public double LineSpacingY {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、通常は正数です。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.Proportional プロパティ

このフォントがプロポーショナルであるかどうかを示します。文字がすべて同じアドバンス値を持つわけではない場合、フォントはプロポーショナルです。

public bool Proportional {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SpotSize プロパティ

レーザプリンタでは、レーザビームが感光性ドラムを横切って掃引されます。ドラム表面における、レーザビームのマイクロメートル単位の直径が、スポットサイズです。そのほかの印刷プロセスには、固有のスポットサイズ定義があります。すべてのフォントがスポットサイズを使用するわけではないことに注意してください。SpotSize プロパティへのアクセスを試みる前に、最初に SpotSizeUsed プロパティをチェックしてください。

public double SpotSize {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、ゼロより大きい必要があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | このプロパティをゼロ以下の値に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | このフォントがスポットサイズを使用しない場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SpotSizeUsed プロパティ

このフォントがスポットサイズを使用するかどうかを示します。このプロパティが false の場合は、スポットサイズを取得または設定することはできません (試みると例外がスローされます)。ほとんどのフォントプロパティと同様に、フォントファイルをインポートする前に、この読み取り専用プロパティがアクセスされると、例外が生成されます。

public bool SpotSizeUsed {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

例外

例外タイプ | 条件
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.SpotSpacingUsed プロパティ

このフォントがスポット間隔を使用するかどうかを示します。通常、ラスタフォントおよびストロークフォントはスポット間隔を使用できますが、アウトラインフォントはスポット間隔を使用することはできません。ほとんどのフォントプロパティと同様に、フォントファイルをインポートする前に、この読み取り専用プロパティがアクセスされると、例外が生成されます。

public bool SpotSpacingUsed {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

例外

例外タイプ | 条件
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont メソッド

CogOCVMaxFont クラスのメソッドを次に示します。CogOCVMaxFont クラスメンバの完全なリストについては、「CogOCVMaxFont メンバ」を参照してください。

パブリックスタティックメソッド

GetAvailableFontNames 指定されたフォントファイル内で入手可能な、各フォントの名前をリストします。

パブリックインスタンスメソッド

Dispose | オーバロードされます。
GetAvailableCharacterKeys | このフォントで利用可能な各文字キーのリストを提供します。
GetAvailableCharacters | このフォントで利用可能な各文字のリストを提供します。
GetCharacterFullBounds | オーバロードされます。指定されたテキスト内の各文字の、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのフル境界は、このフォントおよび指定されたパラメータを使用して決定されます。
GetCharacterMarkBounds | オーバロードされます。指定されたテキスト内の各文字マークの、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのマーク境界は、このフォントおよび指定されたパラメータを使用して決定されます。
GetCharacterPoses | オーバロードされます。指定されたテキスト内の各文字の、個別の選択空間ポーズに対応する、CogTransform2DLinear の System::Array を作成します。これらのポーズは、このフォントおよび指定されたパラメータを使用して決定されます。
GetDefaultBlankCharacter | このフォントの、デフォルトのブランクの文字を提供します。多くのフォントがブランクの文字を複数持つため、このメソッドは、デフォルトのブランクとして使用されるものを 1 つ識別します。
GetDefaultBlankCharacterKey | このフォントの、デフォルトのブランクの文字のキーを提供します。多くのフォントがブランクの文字を複数持つため、このメソッドは、デフォルトのブランクとして使用されるものを 1 つ識別します。
GetLineSpacingX | このメソッドは、指定された CogOCVMaxFontRenderParams オブジェクトを使用して解釈される、このフォントにおいて隣接する行の原点間の (水平) 間隔です。通常、これは、LineSpacingX プロパティゲッタによって返される値と同じになります。ただし、このフォントについての SpotSpacingUsed が true の場合、このメソッドによって返される値は、LineSpacingX ゲッタによって返される値に、指定された render params オブジェクトの SpotSpacingScaleX プロパティを乗算した値になります。
GetLineSpacingY | このメソッドは、指定された CogOCVMaxFontRenderParams オブジェクトを使用して解釈される、このフォントにおいて隣接する行の原点間の (垂直) 間隔です。通常、これは、LineSpacingY プロパティゲッタによって返される値と同じになります。ただし、このフォントについての SpotSpacingUsed が true の場合、このメソッドによって返される値は、LineSpacingY ゲッタによって返される値に、指定された render params オブジェクトの SpotSpacingScaleY プロパティを乗算した値になります。
Import | オーバロードされます。指定されたファイル内の最初のフォントディスクリプションを読み取ります。このフォントディスクリプションによって、以前にインポートされたフォントディスクリプションは差し替えられます。現在ロードされているフォント内で、SpotSize と LineSpacing の両方またはどちらかを変更した場合、これらの設定は失われます。
IsBlank | オーバロードされます。指定された文字キーに対応する文字が、このフォント内でブランクとみなされるかどうかを判定します。多くのフォントがブランクの文字を複数持つことに注意してください。
RenderCompositeShape | オーバロードされます。指定されたテキストがそのアウトラインによってグラフィカルに表された、CogCompositeShape を作成します。このアウトラインは、このフォントおよび指定されたパラメータを使用して、描画時に、テキストから導出されます。
RenderImage | オーバロードされます。指定されたテキストがこのフォントおよび指定されたパラメータを使用して描画された、画像を作成します。

プロテクトインスタンスメソッド

__dtor |
Dispose | オーバロードされます。
Finalize |
GetObjectData |

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.__dtor メソッド

protected void __dtor();

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


Dispose メソッド

VisionPro プログラミングリファレンス

CogOCVMaxFont.Dispose メソッド

オーバロードリスト

public override void Dispose();

protected virtual void Dispose(bool);

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.Dispose メソッド ()

public override void Dispose();

実装

IDisposable.Dispose

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.Dispose オーバロードリスト


CogOCVMaxFont.Dispose メソッド (Boolean)

protected virtual void Dispose(
bool bDisposing
);

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.Dispose オーバロードリスト


CogOCVMaxFont.Finalize メソッド

protected override void Finalize();

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.GetAvailableCharacterKeys メソッド

このフォントで利用可能な各文字キーのリストを提供します。

public int[] GetAvailableCharacterKeys();

戻り値

利用可能な各文字キーに対応する、System::Int32 の System::Array。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.GetAvailableCharacters メソッド

このフォントで利用可能な各文字のリストを提供します。

public string GetAvailableCharacters();

戻り値

System::String。この中の各文字は、利用可能な文字のいずれかに対応しています。このフォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.GetAvailableFontNames メソッド

指定されたフォントファイル内で入手可能な、各フォントの名前をリストします。

public static string[] GetAvailableFontNames(
string fileName
);

パラメータ

fileName
調べられるファイルの名前。

戻り値

System::String の System::Array。この中の各文字列は、指定されたファイル内で定義されたフォントの名前です。

例外

例外タイプ | 条件
InvalidOperationException | エラーが発生した場合。指定されたファイルが検出されない、または開くことができない場合を含みます。
ArgumentNullException | fileName 引数が NULL の場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


GetCharacterFullBounds メソッド

VisionPro プログラミングリファレンス

CogOCVMaxFont.GetCharacterFullBounds メソッド

指定されたテキスト内の各文字の、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのフル境界は、このフォントおよび指定されたパラメータを使用して決定されます。

オーバロードリスト

指定されたテキスト内の各文字の、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのフル境界は、このフォントおよび指定されたパラメータを使用して決定されます。

public CogRectangleAffine[] GetCharacterFullBounds(int[],CogTransform2DLinear,CogOCVMaxFontRenderParams);

指定されたテキスト内の各文字の、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのフル境界は、このフォントおよび指定されたパラメータを使用して決定されます。

public CogRectangleAffine[] GetCharacterFullBounds(string,CogTransform2DLinear,CogOCVMaxFontRenderParams);

指定されたテキスト内の各文字の、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのフル境界は、このフォントおよび指定されたパラメータを使用して決定されます。

public CogRectangleAffine[] GetCharacterFullBounds(string[],CogTransform2DLinear,CogOCVMaxFontRenderParams);

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.GetCharacterFullBounds メソッド (Int32[], CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキスト内の各文字の、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのフル境界は、このフォントおよび指定されたパラメータを使用して決定されます。

public CogRectangleAffine[] GetCharacterFullBounds(
int[] srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
評価されるテキスト。この整数の配列は文字キーのシーケンスとして解釈され、対応するテキストは 1 つのパラグラフ内の 1 つの行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの評価に使用する CogOCVMaxFontRenderParams。

戻り値

指定されたテキスト内の文字の、個別の選択空間境界にそれぞれが対応する、CogTransform2DLinear の System::Array。

例外

例外タイプ | 条件
ArgumentNullException | いずれかの引数が NULL である場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.GetCharacterFullBounds オーバロードリスト


CogOCVMaxFont.GetCharacterFullBounds メソッド (String, CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキスト内の各文字の、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのフル境界は、このフォントおよび指定されたパラメータを使用して決定されます。

public CogRectangleAffine[] GetCharacterFullBounds(
string srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
評価されるテキスト。この文字列は、1 つのパラグラフ内の 1 つの行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの評価に使用する CogOCVMaxFontRenderParams。

戻り値

指定されたテキスト内の文字の、個別の選択空間境界にそれぞれが対応する、CogTransform2DLinear の System::Array。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
ArgumentNullException | いずれかの引数が NULL である場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.GetCharacterFullBounds オーバロードリスト


CogOCVMaxFont.GetCharacterFullBounds メソッド (String[], CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキスト内の各文字の、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのフル境界は、このフォントおよび指定されたパラメータを使用して決定されます。

public CogRectangleAffine[] GetCharacterFullBounds(
string[] srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
評価されるテキスト。各配列要素は、1 つのパラグラフ内の別の行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの評価に使用する CogOCVMaxFontRenderParams。

戻り値

指定されたテキスト内の文字の、個別の選択空間境界にそれぞれが対応する、CogRectangleAffine の System::Array。

例外

例外タイプ | 条件
ArgumentNullException | いずれかの引数が NULL である場合。
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.GetCharacterFullBounds オーバロードリスト


GetCharacterMarkBounds メソッド

VisionPro プログラミングリファレンス

CogOCVMaxFont.GetCharacterMarkBounds メソッド

指定されたテキスト内の各文字マークの、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのマーク境界は、このフォントおよび指定されたパラメータを使用して決定されます。

オーバロードリスト

指定されたテキスト内の各文字マークの、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのマーク境界は、このフォントおよび指定されたパラメータを使用して決定されます。

public CogRectangleAffine[] GetCharacterMarkBounds(int[],CogTransform2DLinear,CogOCVMaxFontRenderParams);

指定されたテキスト内の各文字マークの、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのマーク境界は、このフォントおよび指定されたパラメータを使用して決定されます。

public CogRectangleAffine[] GetCharacterMarkBounds(string,CogTransform2DLinear,CogOCVMaxFontRenderParams);

指定されたテキスト内の各文字マークの、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのマーク境界は、このフォントおよび指定されたパラメータを使用して決定されます。

public CogRectangleAffine[] GetCharacterMarkBounds(string[],CogTransform2DLinear,CogOCVMaxFontRenderParams);

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.GetCharacterMarkBounds メソッド (Int32[], CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキスト内の各文字マークの、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのマーク境界は、このフォントおよび指定されたパラメータを使用して決定されます。

public CogRectangleAffine[] GetCharacterMarkBounds(
int[] srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
評価されるテキスト。この整数の配列は文字キーのシーケンスとして解釈され、対応するテキストは 1 つのパラグラフ内の 1 つの行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの評価に使用する CogOCVMaxFontRenderParams。

戻り値

指定されたテキスト内の文字の、個別の選択空間マーク境界にそれぞれが対応する、CogTransform2DLinear の System::Array。

例外

例外タイプ | 条件
ArgumentNullException | いずれかの引数が NULL である場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.GetCharacterMarkBounds オーバロードリスト


CogOCVMaxFont.GetCharacterMarkBounds メソッド (String, CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキスト内の各文字マークの、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのマーク境界は、このフォントおよび指定されたパラメータを使用して決定されます。

public CogRectangleAffine[] GetCharacterMarkBounds(
string srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
評価されるテキスト。この文字列は、1 つのパラグラフ内の 1 つの行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの評価に使用する CogOCVMaxFontRenderParams。

戻り値

指定されたテキスト内の文字の、個別の選択空間マーク境界にそれぞれが対応する、CogTransform2DLinear の System::Array。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
ArgumentNullException | いずれかの引数が NULL である場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.GetCharacterMarkBounds オーバロードリスト


CogOCVMaxFont.GetCharacterMarkBounds メソッド (String[], CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキスト内の各文字マークの、個別の選択空間境界に対応する、CogRectangleAffine の System::Array を作成します。これらのマーク境界は、このフォントおよび指定されたパラメータを使用して決定されます。

public CogRectangleAffine[] GetCharacterMarkBounds(
string[] srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
評価されるテキスト。各配列要素は、1 つのパラグラフ内の別の行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの評価に使用する CogOCVMaxFontRenderParams。

戻り値

指定されたテキスト内の文字の、個別の選択空間マーク境界にそれぞれが対応する、CogRectangleAffine の System::Array。

例外

例外タイプ | 条件
ArgumentNullException | いずれかの引数が NULL である場合。
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.GetCharacterMarkBounds オーバロードリスト


GetCharacterPoses メソッド

VisionPro プログラミングリファレンス

CogOCVMaxFont.GetCharacterPoses メソッド

指定されたテキスト内の各文字の、個別の選択空間ポーズに対応する、CogTransform2DLinear の System::Array を作成します。これらのポーズは、このフォントおよび指定されたパラメータを使用して決定されます。

オーバロードリスト

指定されたテキスト内の各文字の、個別の選択空間ポーズに対応する、CogTransform2DLinear の System::Array を作成します。これらのポーズは、このフォントおよび指定されたパラメータを使用して決定されます。

public CogTransform2DLinear[] GetCharacterPoses(int[],CogTransform2DLinear,CogOCVMaxFontRenderParams);

指定されたテキスト内の各文字の、個別の選択空間ポーズに対応する、CogTransform2DLinear の System::Array を作成します。これらのポーズは、このフォントおよび指定されたパラメータを使用して決定されます。

public CogTransform2DLinear[] GetCharacterPoses(string,CogTransform2DLinear,CogOCVMaxFontRenderParams);

指定されたテキスト内の各文字の、個別の選択空間ポーズに対応する、CogTransform2DLinear の System::Array を作成します。これらのポーズは、このフォントおよび指定されたパラメータを使用して決定されます。

public CogTransform2DLinear[] GetCharacterPoses(string[],CogTransform2DLinear,CogOCVMaxFontRenderParams);

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.GetCharacterPoses メソッド (Int32[], CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキスト内の各文字の、個別の選択空間ポーズに対応する、CogTransform2DLinear の System::Array を作成します。これらのポーズは、このフォントおよび指定されたパラメータを使用して決定されます。

public CogTransform2DLinear[] GetCharacterPoses(
int[] srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
評価されるテキスト。この整数の配列は文字キーのシーケンスとして解釈され、対応するテキストは 1 つのパラグラフ内の 1 つの行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの評価に使用する CogOCVMaxFontRenderParams。

戻り値

指定されたテキスト内の文字の、個別の選択空間ポーズにそれぞれが対応する、CogTransform2DLinear の System::Array。

例外

例外タイプ | 条件
ArgumentNullException | いずれかの引数が NULL である場合。
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.GetCharacterPoses オーバロードリスト


CogOCVMaxFont.GetCharacterPoses メソッド (String, CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキスト内の各文字の、個別の選択空間ポーズに対応する、CogTransform2DLinear の System::Array を作成します。これらのポーズは、このフォントおよび指定されたパラメータを使用して決定されます。

public CogTransform2DLinear[] GetCharacterPoses(
string srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
評価されるテキスト。この文字列は、1 つのパラグラフ内の 1 つの行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの評価に使用する CogOCVMaxFontRenderParams。

戻り値

指定されたテキスト内の文字の、個別の選択空間ポーズにそれぞれが対応する、CogTransform2DLinear の System::Array。

例外

例外タイプ | 条件
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。
ArgumentNullException | いずれかの引数が NULL である場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.GetCharacterPoses オーバロードリスト


CogOCVMaxFont.GetCharacterPoses メソッド (String[], CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキスト内の各文字の、個別の選択空間ポーズに対応する、CogTransform2DLinear の System::Array を作成します。これらのポーズは、このフォントおよび指定されたパラメータを使用して決定されます。

public CogTransform2DLinear[] GetCharacterPoses(
string[] srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
評価されるテキスト。各配列要素は、1 つのパラグラフ内の別の行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの評価に使用する CogOCVMaxFontRenderParams。

戻り値

指定されたテキスト内の文字の、個別の選択空間ポーズにそれぞれが対応する、CogTransform2DLinear の System::Array。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ArgumentNullException | いずれかの引数が NULL である場合。
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.GetCharacterPoses オーバロードリスト


CogOCVMaxFont.GetDefaultBlankCharacter メソッド

このフォントの、デフォルトのブランクの文字を提供します。多くのフォントがブランクの文字を複数持つため、このメソッドは、デフォルトのブランクとして使用されるものを 1 つ識別します。

public char GetDefaultBlankCharacter();

戻り値

デフォルトのブランクの文字に対応する System::Char。このフォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、またはこのフォントがブランクの文字を持たない場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.GetDefaultBlankCharacterKey メソッド

このフォントの、デフォルトのブランクの文字のキーを提供します。多くのフォントがブランクの文字を複数持つため、このメソッドは、デフォルトのブランクとして使用されるものを 1 つ識別します。

public int GetDefaultBlankCharacterKey();

戻り値

デフォルトのブランクの文字のキーに対応する System::Int32。

例外

例外タイプ | 条件
InvalidOperationException | フォントがまだインポートされていない場合、またはこのフォントがブランクの文字を持たない場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.GetLineSpacingX メソッド

このメソッドは、指定された CogOCVMaxFontRenderParams オブジェクトを使用して解釈される、このフォントにおいて隣接する行の原点間の (水平) 間隔です。通常、これは、LineSpacingX プロパティゲッタによって返される値と同じになります。ただし、このフォントについての SpotSpacingUsed が true の場合、このメソッドによって返される値は、LineSpacingX ゲッタによって返される値に、指定された render params オブジェクトの SpotSpacingScaleX プロパティを乗算した値になります。

public double GetLineSpacingX(
CogOCVMaxFontRenderParams renderParams
);

パラメータ

renderParams
キャッシュ内に保持された LineSpacingX の値を解釈するために使用される、CogOCVMaxFontRenderParams オブジェクト。

戻り値

System::Double。これは、通常はゼロです。ゼロ以外の値は、行が、次の行を基準にしてずれることを意味します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
ArgumentNullException | renderParams 引数が NULL の場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.GetLineSpacingY メソッド

このメソッドは、指定された CogOCVMaxFontRenderParams オブジェクトを使用して解釈される、このフォントにおいて隣接する行の原点間の (垂直) 間隔です。通常、これは、LineSpacingY プロパティゲッタによって返される値と同じになります。ただし、このフォントについての SpotSpacingUsed が true の場合、このメソッドによって返される値は、LineSpacingY ゲッタによって返される値に、指定された render params オブジェクトの SpotSpacingScaleY プロパティを乗算した値になります。

public double GetLineSpacingY(
CogOCVMaxFontRenderParams renderParams
);

パラメータ

renderParams
キャッシュ内に保持された LineSpacingY の値を解釈するために使用される、CogOCVMaxFontRenderParams オブジェクト。

戻り値

System::Double。これは、通常は正数です。

例外

例外タイプ | 条件
ArgumentNullException | renderParams 引数が NULL の場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.GetObjectData メソッド

protected override void GetObjectData(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


Import メソッド

VisionPro プログラミングリファレンス

CogOCVMaxFont.Import メソッド

指定されたファイル内の最初のフォントディスクリプションを読み取ります。このフォントディスクリプションによって、以前にインポートされたフォントディスクリプションは差し替えられます。現在ロードされているフォント内で、SpotSize と LineSpacing の両方またはどちらかを変更した場合、これらの設定は失われます。

オーバロードリスト

指定されたファイル内の最初のフォントディスクリプションを読み取ります。このフォントディスクリプションによって、以前にインポートされたフォントディスクリプションは差し替えられます。現在ロードされているフォント内で、SpotSize と LineSpacing の両方またはどちらかを変更した場合、これらの設定は失われます。

public void Import(string);

指定されたファイルから、指定された名前を持つ新しいフォントディスクリプションを読み取ります。このフォントディスクリプションによって、以前にインポートされたフォントディスクリプションは差し替えられます。現在ロードされているフォント内で、SpotSize と LineSpacing の両方またはどちらかを変更した場合、これらの設定は失われます。

public void Import(string,string);

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.Import メソッド (String)

指定されたファイル内の最初のフォントディスクリプションを読み取ります。このフォントディスクリプションによって、以前にインポートされたフォントディスクリプションは差し替えられます。現在ロードされているフォント内で、SpotSize と LineSpacing の両方またはどちらかを変更した場合、これらの設定は失われます。

public void Import(
string fileName
);

パラメータ

fileName
インポートされるフォントファイルの名前。

イベント

イベントタイプ | 理由
Changed | すべての定義済み状態フラグが設定された場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
ArgumentNullException | fileName 引数が NULL の場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.Import オーバロードリスト


CogOCVMaxFont.Import メソッド (String, String)

指定されたファイルから、指定された名前を持つ新しいフォントディスクリプションを読み取ります。このフォントディスクリプションによって、以前にインポートされたフォントディスクリプションは差し替えられます。現在ロードされているフォント内で、SpotSize と LineSpacing の両方またはどちらかを変更した場合、これらの設定は失われます。

public void Import(
string fileName,
string fontName
);

パラメータ

fileName
インポートされるフォントファイルの名前。
fontName
インポートされるフォントの名前。

イベント

イベントタイプ | 理由
Changed | すべての定義済み状態フラグが設定された場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
ArgumentNullException | fontName 引数が NULL の場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.Import オーバロードリスト


IsBlank メソッド

VisionPro プログラミングリファレンス

CogOCVMaxFont.IsBlank メソッド

指定された文字がこのフォント内でブランクとみなされるかどうかを判定します。多くのフォントがブランクの文字を複数持つことに注意してください。

オーバロードリスト

指定された文字がこのフォント内でブランクとみなされるかどうかを判定します。多くのフォントがブランクの文字を複数持つことに注意してください。

public bool IsBlank(char);

指定された文字キーに対応する文字が、このフォント内でブランクとみなされるかどうかを判定します。多くのフォントがブランクの文字を複数持つことに注意してください。

public bool IsBlank(int);

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.IsBlank メソッド (Char)

指定された文字がこのフォント内でブランクとみなされるかどうかを判定します。多くのフォントがブランクの文字を複数持つことに注意してください。

public bool IsBlank(
char cVal
);

パラメータ

cVal
評価される文字。

戻り値

System::Boolean。指定された文字がこのフォント内でブランクとみなされる場合は true、それ以外の場合は false になります。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.IsBlank オーバロードリスト


CogOCVMaxFont.IsBlank メソッド (Int32)

指定された文字キーに対応する文字が、このフォント内でブランクとみなされるかどうかを判定します。多くのフォントがブランクの文字を複数持つことに注意してください。

public bool IsBlank(
int iVal
);

パラメータ

iVal
評価される文字キー。

戻り値

System::Boolean。指定された文字キーに対応する文字がこのフォント内でブランクとみなされる場合は true、それ以外の場合は false になります。

例外

例外タイプ | 条件
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.IsBlank オーバロードリスト


RenderCompositeShape メソッド

VisionPro プログラミングリファレンス

CogOCVMaxFont.RenderCompositeShape メソッド

指定されたテキストがそのアウトラインによってグラフィカルに表された、CogCompositeShape を作成します。このアウトラインは、このフォントおよび指定されたパラメータを使用して、描画時に、テキストから導出されます。

オーバロードリスト

指定されたテキストがそのアウトラインによってグラフィカルに表された、CogCompositeShape を作成します。このアウトラインは、このフォントおよび指定されたパラメータを使用して、描画時に、テキストから導出されます。

public CogCompositeShape RenderCompositeShape(int[],CogTransform2DLinear,CogOCVMaxFontRenderParams);

指定されたテキストがそのアウトラインによってグラフィカルに表された、CogCompositeShape を作成します。このアウトラインは、このフォントおよび指定されたパラメータを使用して、描画時に、テキストから導出されます。

public CogCompositeShape RenderCompositeShape(string,CogTransform2DLinear,CogOCVMaxFontRenderParams);

指定されたテキストがそのアウトラインによってグラフィカルに表された、CogCompositeShape を作成します。このアウトラインは、このフォントおよび指定されたパラメータを使用して、描画時に、テキストから導出されます。

public CogCompositeShape RenderCompositeShape(string[],CogTransform2DLinear,CogOCVMaxFontRenderParams);

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.RenderCompositeShape メソッド (Int32[], CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキストがそのアウトラインによってグラフィカルに表された、CogCompositeShape を作成します。このアウトラインは、このフォントおよび指定されたパラメータを使用して、描画時に、テキストから導出されます。

public CogCompositeShape RenderCompositeShape(
int[] srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
描画されるテキスト。この整数の配列は文字キーのシーケンスとして解釈され、対応するテキストは 1 つのパラグラフ内の 1 つの行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの描画で使用する CogOCVMaxFontRenderParams。

戻り値

描画されたテキストを表す CogCompositeShape。

例外

例外タイプ | 条件
ArgumentNullException | いずれかの引数が NULL である場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.RenderCompositeShape オーバロードリスト


CogOCVMaxFont.RenderCompositeShape メソッド (String, CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキストがそのアウトラインによってグラフィカルに表された、CogCompositeShape を作成します。このアウトラインは、このフォントおよび指定されたパラメータを使用して、描画時に、テキストから導出されます。

public CogCompositeShape RenderCompositeShape(
string srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
描画されるテキスト。この文字列は、1 つのパラグラフ内の 1 つの行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの描画で使用する CogOCVMaxFontRenderParams。

戻り値

描画されたテキストを表す CogCompositeShape。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ArgumentNullException | いずれかの引数が NULL である場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.RenderCompositeShape オーバロードリスト


CogOCVMaxFont.RenderCompositeShape メソッド (String[], CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキストがそのアウトラインによってグラフィカルに表された、CogCompositeShape を作成します。このアウトラインは、このフォントおよび指定されたパラメータを使用して、描画時に、テキストから導出されます。

public CogCompositeShape RenderCompositeShape(
string[] srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
描画されるテキスト。各配列要素は、1 つのパラグラフ内の別の行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの描画で使用する CogOCVMaxFontRenderParams。

戻り値

描画されたテキストを表す CogCompositeShape。

例外

例外タイプ | 条件
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
ArgumentNullException | いずれかの引数が NULL である場合。
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.RenderCompositeShape オーバロードリスト


RenderImage メソッド

VisionPro プログラミングリファレンス

CogOCVMaxFont.RenderImage メソッド

指定されたテキストがこのフォントおよび指定されたパラメータを使用して描画された、画像を作成します。

オーバロードリスト

指定されたテキストがこのフォントおよび指定されたパラメータを使用して描画された、画像を作成します。

public CogImage8Grey RenderImage(int[],CogTransform2DLinear,CogOCVMaxFontRenderParams);

指定されたテキストがこのフォントおよび指定されたパラメータを使用して描画された、画像を作成します。

public CogImage8Grey RenderImage(string,CogTransform2DLinear,CogOCVMaxFontRenderParams);

指定されたテキストがこのフォントおよび指定されたパラメータを使用して描画された、画像を作成します。

public CogImage8Grey RenderImage(string[],CogTransform2DLinear,CogOCVMaxFontRenderParams);

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFont.RenderImage メソッド (Int32[], CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキストがこのフォントおよび指定されたパラメータを使用して描画された、画像を作成します。

public CogImage8Grey RenderImage(
int[] srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
描画されるテキスト。この整数の配列は文字キーのシーケンスとして解釈され、対応するテキストは 1 つのパラグラフ内の 1 つの行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの描画で使用する CogOCVMaxFontRenderParams。

戻り値

描画されたテキストを含む CogImage8Grey。

例外

例外タイプ | 条件
ArgumentNullException | いずれかの引数が NULL である場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.RenderImage オーバロードリスト


CogOCVMaxFont.RenderImage メソッド (String, CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキストがこのフォントおよび指定されたパラメータを使用して描画された、画像を作成します。

public CogImage8Grey RenderImage(
string srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
描画されるテキスト。この文字列は、1 つのパラグラフ内の 1 つの行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの描画で使用する CogOCVMaxFontRenderParams。

戻り値

描画されたテキストを含む CogImage8Grey。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ArgumentNullException | いずれかの引数が NULL である場合。
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.RenderImage オーバロードリスト


CogOCVMaxFont.RenderImage メソッド (String[], CogTransform2DLinear, CogOCVMaxFontRenderParams)

指定されたテキストがこのフォントおよび指定されたパラメータを使用して描画された、画像を作成します。

public CogImage8Grey RenderImage(
string[] srcText,
CogTransform2DLinear selectedFromFont,
CogOCVMaxFontRenderParams renderParams
);

パラメータ

srcText
描画されるテキスト。各配列要素は、1 つのパラグラフ内の別の行として解釈されます。
selectedFromFont
インポートされたフォントディスクリプションから選択空間への線形マッピング。通常は、スケーリングを指定するために使用されます。
renderParams
このテキストの描画で使用する CogOCVMaxFontRenderParams。

戻り値

描画されたテキストを含む CogImage8Grey。

例外

例外タイプ | 条件
ArgumentNullException | いずれかの引数が NULL である場合。
ArgumentOutOfRangeException | srcText 引数が、少なくとも 1 つの文字を記述していない場合。
InvalidOperationException | フォントがまだインポートされていない場合、または内部エラーが発生した場合。
ObjectDisposedException | この CogOCVMaxFont オブジェクトが既に破棄されている場合。

参照

CogOCVMaxFont クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFont.RenderImage オーバロードリスト


CogOCVMaxFontRenderParams クラス

このクラスは、特定のフォントでのテキストの描画、または描画ベースの処理を制御するために通常使用される、プロパティをカプセル化します。これらのプロパティは、CogOCVMaxFont と、カメラで実際に観察されるものの間の対応付けを微調整することを可能にします。

このタイプのメンバすべてのリストについては、「CogOCVMaxFontRenderParams メンバ」を参照してください。

System.Object
MarshalByRefObject
CogObjectBase
CogSerializableObjectBase
CogSerializableChangedEventBase
CogOCVMaxFontRenderParams

public class CogOCVMaxFontRenderParams :CogSerializableChangedEventBase

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxFontRenderParams メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams メンバ

CogOCVMaxFontRenderParams の概要

パブリックスタティックフィールド

SfBackgroundGrey
SfCharacterSpacingAddedX
SfCharacterSpacingAddedY
SfForegroundGrey
SfImagePelPadding
SfLineSpacingAddedX
SfLineSpacingAddedY
SfSpotSizeScale
SfSpotSpacingScaleX
SfSpotSpacingScaleY
SfStrokeWidthAdded

プロテクトスタティックフィールド

SfNextSf

パブリックインスタンスコンストラクタ

CogOCVMaxFontRenderParams オーバロードされます。CogOCVMaxFontRenderParams クラスの新しいインスタンスを初期化します。

パブリックインスタンスプロパティ

BackgroundGrey | なんらかのテキストを囲んでいる空き領域の描画に使用される、背景のグレースケール値です。ペルバッファ内に実際に描画しない操作では、このプロパティは無視されます。
CharacterSpacingAddedX | 1 つの文字の原点と、同じ行にある次の文字の原点間の、X 軸距離を変更します。正の値によって文字間隔は増加し、負の値によって文字間隔は減少します。また、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。
CharacterSpacingAddedY | 1 つの文字の原点と、同じ行にある次の文字の原点間の、Y 軸距離を変更します。ゼロ以外の値によって、階段状のテキスト行が生成され、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。このプロパティは、まれにしか使用されません。
ForegroundGrey | テキストの描画に使用される、前景のグレースケール値です。ペルバッファ内に実際に描画しない操作では、このプロパティは無視されます。
ImagePelPadding | 描画されるなんらかのテキスト画像の両側を変更する、背景のペルの数です。値 0 は、パディングを行わないことを意味します。
LineSpacingAddedX | 1 つの行の原点と、同じパラグラフ内にある次の行の原点間の、X 軸距離を変更します。ゼロ以外の値によって、行が階段状にずれたパラグラフが生成され、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。このプロパティは、まれにしか使用されません。
LineSpacingAddedY | 1 つの行の原点と、同じパラグラフ内にある次の行の原点間の、Y 軸距離を変更します。正の値によって行間隔は増加し、負の値によって行間隔は減少します。また、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。
SpotSizeScale | 描画されるテキストのスポットサイズを、この値によってスケール変更 (乗算) します。SpotSizeUsed が false であるフォント (例えば、アウトラインフォント) では無視されます。デフォルト値の 1.0 では、描画されるテキストに変化は生成されません。
SpotSpacingScaleX | 描画されるテキストのスポットの、X 軸に沿った間隔を、この値によってスケール変更 (乗算) します。SpotSpacingUsed が false であるフォント (例えば、アウトラインフォント) では無視されます。デフォルト値の 1.0 では、描画されるテキストに変化は生成されません。
SpotSpacingScaleY | 描画されるテキストのスポットの、Y 軸に沿った間隔を、この値によってスケール変更 (乗算) します。SpotSpacingUsed が false であるフォント (例えば、アウトラインフォント) では無視されます。デフォルト値の 1.0 では、描画されるテキストに変化は生成されません。
StrokeWidthAdded | 指定されたフォントのテキストの標準ストローク幅を、モフォロジィを使用して変更します。正の値によってストローク幅は増加し、負の値によってストローク幅は減少します。また、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。このプロパティは、通常、アウトラインフォントなどの、SpotSizeScale が適用されないフォントにのみ有効です。

プロテクトインスタンスコンストラクタ

CogOCVMaxFontRenderParams オーバロードされます。CogOCVMaxFontRenderParams クラスの新しいインスタンスを初期化します。

プロテクトインスタンスメソッド

GetObjectData

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams コンストラクタ

オーバロードリスト

CogOCVMaxFontRenderParams クラスの新しいインスタンスを初期化します。

public CogOCVMaxFontRenderParams();

public CogOCVMaxFontRenderParams(CogOCVMaxFontRenderParams);

protected CogOCVMaxFontRenderParams(SerializationInfo,StreamingContext);

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams コンストラクタ (SerializationInfo, StreamingContext)

protected CogOCVMaxFontRenderParams(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFontRenderParams コンストラクタオーバロードリスト


CogOCVMaxFontRenderParams コンストラクタ (CogOCVMaxFontRenderParams)

public CogOCVMaxFontRenderParams(
CogOCVMaxFontRenderParams pOther
);

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFontRenderParams コンストラクタオーバロードリスト


CogOCVMaxFontRenderParams コンストラクタ ()

CogOCVMaxFontRenderParams クラスの新しいインスタンスを初期化します。

public CogOCVMaxFontRenderParams();

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxFontRenderParams コンストラクタオーバロードリスト


CogOCVMaxFontRenderParams フィールド

CogOCVMaxFontRenderParams クラスのフィールドを次に示します。CogOCVMaxFontRenderParams クラスメンバの完全なリストについては、「CogOCVMaxFontRenderParams メンバ」を参照してください。

パブリックスタティックフィールド

SfBackgroundGrey
SfCharacterSpacingAddedX
SfCharacterSpacingAddedY
SfForegroundGrey
SfImagePelPadding
SfLineSpacingAddedX
SfLineSpacingAddedY
SfSpotSizeScale
SfSpotSpacingScaleX
SfSpotSpacingScaleY
SfStrokeWidthAdded

プロテクトスタティックフィールド

SfNextSf

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SfBackgroundGrey フィールド

public const long SfBackgroundGrey;

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SfCharacterSpacingAddedX フィールド

public const long SfCharacterSpacingAddedX;

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SfCharacterSpacingAddedY フィールド

public const long SfCharacterSpacingAddedY;

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SfForegroundGrey フィールド

public const long SfForegroundGrey;

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SfImagePelPadding フィールド

public const long SfImagePelPadding;

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SfLineSpacingAddedX フィールド

public const long SfLineSpacingAddedX;

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SfLineSpacingAddedY フィールド

public const long SfLineSpacingAddedY;

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SfNextSf フィールド

new protected const long SfNextSf;

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SfSpotSizeScale フィールド

public const long SfSpotSizeScale;

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SfSpotSpacingScaleX フィールド

public const long SfSpotSpacingScaleX;

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SfSpotSpacingScaleY フィールド

public const long SfSpotSpacingScaleY;

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SfStrokeWidthAdded フィールド

public const long SfStrokeWidthAdded;

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams プロパティ

CogOCVMaxFontRenderParams クラスのプロパティを次に示します。CogOCVMaxFontRenderParams クラスメンバの完全なリストについては、「CogOCVMaxFontRenderParams メンバ」を参照してください。

パブリックインスタンスプロパティ

BackgroundGrey | なんらかのテキストを囲んでいる空き領域の描画に使用される、背景のグレースケール値です。ペルバッファ内に実際に描画しない操作では、このプロパティは無視されます。
CharacterSpacingAddedX | 1 つの文字の原点と、同じ行にある次の文字の原点間の、X 軸距離を変更します。正の値によって文字間隔は増加し、負の値によって文字間隔は減少します。また、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。
CharacterSpacingAddedY | 1 つの文字の原点と、同じ行にある次の文字の原点間の、Y 軸距離を変更します。ゼロ以外の値によって、階段状のテキスト行が生成され、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。このプロパティは、まれにしか使用されません。
ForegroundGrey | テキストの描画に使用される、前景のグレースケール値です。ペルバッファ内に実際に描画しない操作では、このプロパティは無視されます。
ImagePelPadding | 描画されるなんらかのテキスト画像の両側に追加する、背景のペルの数です。値 0 は、パディングを行わないことを意味します。
LineSpacingAddedX | 1 つの行の原点と、同じパラグラフ内にある次の行の原点間の、X 軸距離を変更します。ゼロ以外の値によって、行が階段状にずれたパラグラフが生成され、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。このプロパティは、まれにしか使用されません。
LineSpacingAddedY | 1 つの行の原点と、同じパラグラフ内にある次の行の原点間の、Y 軸距離を変更します。正の値によって行間隔は増加し、負の値によって行間隔は減少します。また、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。
SpotSizeScale | 描画されるテキストのスポットサイズを、この値によってスケール変更 (乗算) します。SpotSizeUsed が false であるフォント (例えば、アウトラインフォント) では無視されます。デフォルト値の 1.0 では、描画されるテキストに変化は生成されません。
SpotSpacingScaleX | 描画されるテキストのスポットの、X 軸に沿った間隔を、この値によってスケール変更 (乗算) します。SpotSpacingUsed が false であるフォント (例えば、アウトラインフォント) では無視されます。デフォルト値の 1.0 では、描画されるテキストに変化は生成されません。
SpotSpacingScaleY | 描画されるテキストのスポットの、Y 軸に沿った間隔を、この値によってスケール変更 (乗算) します。SpotSpacingUsed が false であるフォント (例えば、アウトラインフォント) では無視されます。デフォルト値の 1.0 では、描画されるテキストに変化は生成されません。
StrokeWidthAdded | 指定されたフォントのテキストの標準ストローク幅を、モフォロジィを使用して変更します。正の値によってストローク幅は増加し、負の値によってストローク幅は減少します。また、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。このプロパティは、通常、アウトラインフォントなどの、SpotSizeScale が適用されないフォントにのみ有効です。

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.BackgroundGrey プロパティ

なんらかのテキストを囲んでいる空き領域の描画に使用される、背景のグレースケール値です。ペルバッファ内に実際に描画しない操作では、このプロパティは無視されます。

public byte BackgroundGrey {get; set;}

プロパティ値

Byte タイプの、この読み取り/書き込みプロパティは、0 (黒) ～ 255 (白) の値を持ちます。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.CharacterSpacingAddedX プロパティ

1 つの文字の原点と、同じ行にある次の文字の原点間の、X 軸距離を変更します。正の値によって文字間隔は増加し、負の値によって文字間隔は減少します。また、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。

public double CharacterSpacingAddedX {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、正、負、またはゼロであることが可能です。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.CharacterSpacingAddedY プロパティ

1 つの文字の原点と、同じ行にある次の文字の原点間の、Y 軸距離を変更します。ゼロ以外の値によって、階段状のテキスト行が生成され、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。このプロパティは、まれにしか使用されません。

public double CharacterSpacingAddedY {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、正、負、またはゼロであることが可能です。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.ForegroundGrey プロパティ

テキストの描画に使用される、前景のグレースケール値です。ペルバッファ内に実際に描画しない操作では、このプロパティは無視されます。

public byte ForegroundGrey {get; set;}

プロパティ値

Byte タイプの、この読み取り/書き込みプロパティは、0 (黒) ～ 255 (白) の値を持ちます。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.ImagePelPadding プロパティ

描画されるなんらかのテキスト画像の両側に追加する、背景のペルの数です。値 0 は、パディングを行わないことを意味します。

public int ImagePelPadding {get; set;}

プロパティ値

Int32 タイプの、この読み取り/書き込みプロパティは、ゼロ以上である必要があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | このプロパティをゼロ未満の値に設定しようとした場合。

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.LineSpacingAddedX プロパティ

1 つの行の原点と、同じパラグラフ内にある次の行の原点間の、X 軸距離を変更します。ゼロ以外の値によって、行が階段状にずれたパラグラフが生成され、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。このプロパティは、まれにしか使用されません。

public double LineSpacingAddedX {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、正、負、またはゼロであることが可能です。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.LineSpacingAddedY プロパティ

1 つの行の原点と、同じパラグラフ内にある次の行の原点間の、Y 軸距離を変更します。正の値によって行間隔は増加し、負の値によって行間隔は減少します。また、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。

public double LineSpacingAddedY {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、正、負、またはゼロであることが可能です。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SpotSizeScale プロパティ

描画されるテキストのスポットサイズを、この値によってスケール変更 (乗算) します。SpotSizeUsed が false であるフォント (例えば、アウトラインフォント) では無視されます。デフォルト値の 1.0 では、描画されるテキストに変化は生成されません。

public double SpotSizeScale {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、ゼロより大きい必要があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | このプロパティをゼロ以下の値に設定しようとした場合。

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SpotSpacingScaleX プロパティ

描画されるテキストのスポットの、X 軸に沿った間隔を、この値によってスケール変更 (乗算) します。SpotSpacingUsed が false であるフォント (例えば、アウトラインフォント) では無視されます。デフォルト値の 1.0 では、描画されるテキストに変化は生成されません。

public double SpotSpacingScaleX {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、ゼロより大きい必要があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | このプロパティをゼロ以下の値に設定しようとした場合。

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.SpotSpacingScaleY プロパティ

描画されるテキストのスポットの、Y 軸に沿った間隔を、この値によってスケール変更 (乗算) します。SpotSpacingUsed が false であるフォント (例えば、アウトラインフォント) では無視されます。デフォルト値の 1.0 では、描画されるテキストに変化は生成されません。

public double SpotSpacingScaleY {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、ゼロより大きい必要があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | このプロパティをゼロ以下の値に設定しようとした場合。

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.StrokeWidthAdded プロパティ

指定されたフォントのテキストの標準ストローク幅を、モフォロジィを使用して変更します。正の値によってストローク幅は増加し、負の値によってストローク幅は減少します。また、デフォルト値の 0.0 では、描画されるテキストに変化は生成されません。このプロパティは、通常、アウトラインフォントなどの、SpotSizeScale が適用されないフォントにのみ有効です。

public double StrokeWidthAdded {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、正、負、またはゼロであることが可能です。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams メソッド

CogOCVMaxFontRenderParams クラスのメソッドを次に示します。CogOCVMaxFontRenderParams クラスメンバの完全なリストについては、「CogOCVMaxFontRenderParams メンバ」を参照してください。

プロテクトインスタンスメソッド

GetObjectData

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontRenderParams.GetObjectData メソッド

protected override void GetObjectData(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxFontRenderParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxFontTypeConstants 列挙体

インポートされたフォントのタイプを識別するために使用される定数です。

public enum CogOCVMaxFontTypeConstants

メンバ

メンバ名 | 説明
Stroke | これはストロークフォントです。文字は、ペンまたはビームパスによって描かれます。
Raster | これはラスタフォント、つまりビットマップフォントです。各文字は、ピクセルの配列によって描かれます。このスタイルフォントは、一部のドットマトリックスプリンタによって使用されます。
Outline | これはアウトラインフォントです。プリンタフォントと呼ばれることもあります。これは、各文字の外観の数学的ディスクリプションによって構成されます。文字は、品質の低下なしに、任意の大きさで描画することができます。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLastRunRecordConstants 列挙体

ツールの LastRunRecord に含めることができる非診断データの列挙体です。

この列挙体は、メンバ値のビットごとの組み合わせを可能にする FlagsAttribute 属性を持っています。

public enum CogOCVMaxLastRunRecordConstants

メンバ

メンバ名 | 説明 | 値
All | すべての非診断データを、LastRunRecord に含めます。 | -1
ParagraphCharactersLabel | 検出された各文字にラベル (例えば、A、B、C) を付けます。 | 4
ParagraphCharactersBounds | 検出された各文字の周囲に外接アフィン矩形を描画します。 | 2
ParagraphBounds | 各パラグラフの周囲に外接アフィン矩形を描画します。 | 1
None | LastRunRecord に、非診断データを何も含めません。 | 0

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLastRunRecordDiagConstants 列挙体

ツールの LastRunRecord に含めることができる診断データの列挙体です。

この列挙体は、メンバ値のビットごとの組み合わせを可能にする FlagsAttribute 属性を持っています。

public enum CogOCVMaxLastRunRecordDiagConstants

メンバ

メンバ名 | 説明 | 値
All | すべての診断データを、LastRunRecord に含めます。 | -1
Region | Region を含むレコードを生成します。 | 4
TransformedRegionPixels | Region 内にピクセルを含むレコードを生成します。 | 8
InputImageDeepCopy | 入力画像のディープコピーを、LastRunRecord に含めます。 | 2
InputImageByReference | 入力画像への参照を、LastRunRecord に含めます。 | 1
None | LastRunRecord に、診断データを何も含めません。 | 0

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator クラス

このクラスは、CogOCVMaxPattern オブジェクトの行レベルのプロパティおよびメソッドへの容易なアクセスを提供します。このクラスを使用すると、1 つのパラグラフ内のすべての行にわたって移動することができます。このオブジェクトは、直接構築することはできません。その代わりに、包含パラグラフの繰り返し指定子、またはトップレベルの CogOCVMaxPattern オブジェクトに対して、CreateLineIterator メソッドを使用してください。また、このクラスをアーカイブに格納することはできないことに注意してください。

このタイプのメンバすべてのリストについては、「CogOCVMaxLineIterator メンバ」を参照してください。

System.Object
CogOCVMaxLineIterator

public class CogOCVMaxLineIterator

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxLineIterator メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator メンバ

CogOCVMaxLineIterator の概要

パブリックインスタンスプロパティ

CharacterCount | この繰り返し指定子によって参照される行に現在含まれている文字の数です。
IsEnd | この繰り返し指定子が、包含パラグラフの最後の行を超えて配置されているかどうかを示します。
IsFirst | この行位置が、包含パラグラフ内の最初の行位置であるかどうかを示します。
IsInvalid | この繰り返し指定子が、正当な行に配置されていないかどうかを示します。true の場合 (つまり、配置されていない場合)、行レベルのプロパティまたはメソッドにアクセスしようとすると、エラーが生成されます。
ParagraphPosition | CogOCVMaxPattern オブジェクト内での包含パラグラフの相対位置を示します。番号付けはゼロベースなので、値 0 は、この行が CogOCVMaxPattern オブジェクトの最初のパラグラフ内に存在することを示します。
Position | 包含パラグラフ内での、この行の相対位置を示します。番号付けはゼロベースなので、値 0 は、これが包含パラグラフの最初の行であることを示します。

パブリックインスタンスメソッド

Copy | オーバロードされます。このメソッドと機能的に同一の、新しく作成された行繰り返し指定子を返します。新しく作成された行繰り返し指定子は、同じ包囲パラグラフ内の、同じ行位置を持ちます。
CreateCharacterIterator | この行の最初の文字位置に対応する、新しく作成された文字繰り返し指定子を返します。
CreateParagraphIterator | 包含パラグラフに対応する、新しく作成されたパラグラフ繰り返し指定子を返します。これは、この行繰り返し指定子の親へのアクセスを提供します。
MoveToNext | 行繰り返し指定子を、包含パラグラフ内の次の行位置に移動します。繰り返し指定子が、この呼び出しの前に既に最後の位置にある場合、MoveToNext は例外を生成します。エラーを避けるには、MoveToNext を呼び出す前に IsEnd プロパティをチェックしてください。
MoveToPosition | 行繰り返し指定子を、包含パラグラフ内の指定された位置に移動します。引数が 0 の場合は、パラグラフ内の最初の行位置に移動します。引数が -1 の場合は、パラグラフ内の最後の行位置に移動します。引数が正当でない場合は、例外が生成されます。
MoveToPrevious | 行繰り返し指定子を、包含パラグラフ内の前の行位置に移動します。繰り返し指定子が、この呼び出しの前に既に最初の位置にある場合、MoveToPrevious は例外を生成します。エラーを避けるには、MoveToPrevious を呼び出す前に IsFirst プロパティをチェックしてください。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator プロパティ

CogOCVMaxLineIterator クラスのプロパティを次に示します。CogOCVMaxLineIterator クラスメンバの完全なリストについては、「CogOCVMaxLineIterator メンバ」を参照してください。

パブリックインスタンスプロパティ

CharacterCount | この繰り返し指定子によって参照される行に現在含まれている文字の数です。
IsEnd | この繰り返し指定子が、包含パラグラフの最後の行を超えて配置されているかどうかを示します。
IsFirst | この行位置が、包含パラグラフ内の最初の行位置であるかどうかを示します。
IsInvalid | この繰り返し指定子が、正当な行に配置されていないかどうかを示します。true の場合 (つまり、配置されていない場合)、行レベルのプロパティまたはメソッドにアクセスしようとすると、エラーが生成されます。
ParagraphPosition | CogOCVMaxPattern オブジェクト内での包含パラグラフの相対位置を示します。番号付けはゼロベースなので、値 0 は、この行が CogOCVMaxPattern オブジェクトの最初のパラグラフ内に存在することを示します。
Position | 包含パラグラフ内での、この行の相対位置を示します。番号付けはゼロベースなので、値 0 は、これが包含パラグラフの最初の行であることを示します。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator.CharacterCount プロパティ

この繰り返し指定子によって参照される行に現在含まれている文字の数です。

public int CharacterCount {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | この行繰り返し指定子が、正当な行を現在参照していない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator.IsEnd プロパティ

この繰り返し指定子が、包含パラグラフの最後の行を超えて配置されているかどうかを示します。

public bool IsEnd {get;}

プロパティ値

この読み取り専用プロパティは、System::Boolean タイプです。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator.IsFirst プロパティ

この行位置が、包含パラグラフ内の最初の行位置であるかどうかを示します。

public bool IsFirst {get;}

プロパティ値

この読み取り専用プロパティは、System::Boolean タイプです。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator.IsInvalid プロパティ

この繰り返し指定子が、正当な行に配置されていないかどうかを示します。true の場合 (つまり、配置されていない場合)、行レベルのプロパティまたはメソッドにアクセスしようとすると、エラーが生成されます。

public bool IsInvalid {get;}

プロパティ値

この読み取り専用プロパティは、System::Boolean タイプです。

例外

例外タイプ | 条件
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator.ParagraphPosition プロパティ

CogOCVMaxPattern オブジェクト内での包含パラグラフの相対位置を示します。番号付けはゼロベースなので、値 0 は、この行が CogOCVMaxPattern オブジェクトの最初のパラグラフ内に存在することを示します。

public int ParagraphPosition {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator.Position プロパティ

包含パラグラフ内での、この行の相対位置を示します。番号付けはゼロベースなので、値 0 は、これが包含パラグラフの最初の行であることを示します。

public int Position {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

例外

例外タイプ | 条件
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator メソッド

CogOCVMaxLineIterator クラスのメソッドを次に示します。CogOCVMaxLineIterator クラスメンバの完全なリストについては、「CogOCVMaxLineIterator メンバ」を参照してください。

パブリックインスタンスメソッド

Copy | オーバロードされます。このメソッドと機能的に同一の、新しく作成された行繰り返し指定子を返します。新しく作成された行繰り返し指定子は、同じ包囲パラグラフ内の、同じ行位置を持ちます。
CreateCharacterIterator | この行の最初の文字位置に対応する、新しく作成された文字繰り返し指定子を返します。
CreateParagraphIterator | 包含パラグラフに対応する、新しく作成されたパラグラフ繰り返し指定子を返します。これは、この行繰り返し指定子の親へのアクセスを提供します。
MoveToNext | 行繰り返し指定子を、包含パラグラフ内の次の行位置に移動します。繰り返し指定子が、この呼び出しの前に既に最後の位置にある場合、MoveToNext は例外を生成します。エラーを避けるには、MoveToNext を呼び出す前に IsEnd プロパティをチェックしてください。
MoveToPosition | 行繰り返し指定子を、包含パラグラフ内の指定された位置に移動します。引数が 0 の場合は、パラグラフ内の最初の行位置に移動します。引数が -1 の場合は、パラグラフ内の最後の行位置に移動します。引数が正当でない場合は、例外が生成されます。
MoveToPrevious | 行繰り返し指定子を、包含パラグラフ内の前の行位置に移動します。繰り返し指定子が、この呼び出しの前に既に最初の位置にある場合、MoveToPrevious は例外を生成します。エラーを避けるには、MoveToPrevious を呼び出す前に IsFirst プロパティをチェックしてください。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


Copy メソッド

VisionPro プログラミングリファレンス

CogOCVMaxLineIterator.Copy メソッド

このメソッドと機能的に同一の、新しく作成された行繰り返し指定子を返します。新しく作成された行繰り返し指定子は、同じ包囲パラグラフ内の、同じ行位置を持ちます。

オーバロードリスト

このメソッドと機能的に同一の、新しく作成された行繰り返し指定子を返します。新しく作成された行繰り返し指定子は、同じ包囲パラグラフ内の、同じ行位置を持ちます。

public CogOCVMaxLineIterator Copy();

この行繰り返し指定子と同じ包囲パラグラフ内の、指定された行位置に対応する、新しく作成された行繰り返し指定子を返します。引数は、現在の行位置からの位置オフセットです。したがって、値 0 によって、これと機能的に同一な新しい行繰り返し指定子が得られます。

public CogOCVMaxLineIterator Copy(int);

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator.Copy メソッド ()

このメソッドと機能的に同一の、新しく作成された行繰り返し指定子を返します。新しく作成された行繰り返し指定子は、同じ包囲パラグラフ内の、同じ行位置を持ちます。

public CogOCVMaxLineIterator Copy();

戻り値

この行繰り返し指定子と同じパラグラフ位置および行位置を持つ CogOCVMaxLineIterator。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | この行繰り返し指定子を検出できない場合。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxLineIterator.Copy オーバロードリスト


CogOCVMaxLineIterator.Copy メソッド (Int32)

この行繰り返し指定子と同じ包囲パラグラフ内の、指定された行位置に対応する、新しく作成された行繰り返し指定子を返します。引数は、現在の行位置からの位置オフセットです。したがって、値 0 によって、これと機能的に同一な新しい行繰り返し指定子が得られます。

public CogOCVMaxLineIterator Copy(
int PositionOffset
);

パラメータ

PositionOffset
包囲パラグラフ内の新しい行位置インデックスを得るために、この行繰り返し指定子の行位置インデックスに追加される System::Int32。行位置インデックスのこの計算結果が正当でない場合は、例外が生成されます。

戻り値

包含パラグラフ内の指定された行位置に対応する CogOCVMaxLineIterator。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | 指定された引数から計算される行位置インデックスが、0 より小さいか、または包囲パラグラフ内の行数より大きい場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | この行繰り返し指定子を検出できない場合。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxLineIterator.Copy オーバロードリスト


CogOCVMaxLineIterator.CreateCharacterIterator メソッド

この行の最初の文字位置に対応する、新しく作成された文字繰り返し指定子を返します。

public CogOCVMaxCharacterIterator CreateCharacterIterator();

戻り値

この行の最初の文字位置に対応する、CogOCVMaxCharacter 繰り返し指定子。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | この行繰り返し指定子を検出できない場合。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator.CreateParagraphIterator メソッド

包含パラグラフに対応する、新しく作成されたパラグラフ繰り返し指定子を返します。これは、この行繰り返し指定子の親へのアクセスを提供します。

public CogOCVMaxParagraphIterator CreateParagraphIterator();

戻り値

包含パラグラフに対応する CogOCVMaxParagraphIterator。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | この行繰り返し指定子を検出できない場合。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator.MoveToNext メソッド

行繰り返し指定子を、包含パラグラフ内の次の行位置に移動します。繰り返し指定子が、この呼び出しの前に既に最後の位置にある場合、MoveToNext は例外を生成します。エラーを避けるには、MoveToNext を呼び出す前に IsEnd プロパティをチェックしてください。

public void MoveToNext();

例外

例外タイプ | 条件
InvalidOperationException | この行繰り返し指定子を検出できない場合。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator.MoveToPosition メソッド

行繰り返し指定子を、包含パラグラフ内の指定された位置に移動します。引数が 0 の場合は、パラグラフ内の最初の行位置に移動します。引数が -1 の場合は、パラグラフ内の最後の行位置に移動します。引数が正当でない場合は、例外が生成されます。

public void MoveToPosition(
int Position
);

パラメータ

Position
包囲パラグラフ内への System::Int32 インデックス。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | 引数が 0 より小さいか、または包囲パラグラフ内の行数より大きい場合。
InvalidOperationException | この行繰り返し指定子を検出できない場合。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineIterator.MoveToPrevious メソッド

行繰り返し指定子を、包含パラグラフ内の前の行位置に移動します。繰り返し指定子が、この呼び出しの前に既に最初の位置にある場合、MoveToPrevious は例外を生成します。エラーを避けるには、MoveToPrevious を呼び出す前に IsFirst プロパティをチェックしてください。

public void MoveToPrevious();

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | この行繰り返し指定子を、First を超えてデクリメントしようとした場合。

参照

CogOCVMaxLineIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult クラス

このクラスは、1 つの行についての結果情報のすべてを保持します。

このタイプのメンバすべてのリストについては、「CogOCVMaxLineResult メンバ」を参照してください。

System.Object
MarshalByRefObject
CogObjectBase
CogSerializableObjectBase
CogOCVMaxLineResult

public class CogOCVMaxLineResult :CogSerializableObjectBase

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxLineResult メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult メンバ

CogOCVMaxLineResult の概要

パブリックインスタンスコンストラクタ

CogOCVMaxLineResult オーバロードされます。CogOCVMaxLineResult クラスの新しいインスタンスを初期化します。

パブリックインスタンスプロパティ

CharacterResults | 文字結果の System::Array です。この行内の各文字について 1 つ存在します。
LineArrangementPose | 配置空間内での、この行のポーズです。このプロパティは、LineArrangementPoseValid が true の場合のみ有効であることに注意してください。
LineArrangementPoseValid | 配置空間内での、この行のポーズが、正常に計算されたかどうかを示します。
LineIndex | ゼロベースの行インデックスです。これは、包含パラグラフ内のどの行が、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。
LineParagraphPose | パラグラフ空間内での、この行のポーズです。このプロパティは、LineParagraphPoseValid が true の場合のみ有効であることに注意してください。
LineParagraphPoseValid | パラグラフ空間内での、この行のポーズが、正常に計算されたかどうかを示します。
LineSelectedPose | 選択空間内での、この行のポーズです。このプロパティは、LineSelectedPoseValid が true の場合のみ有効であることに注意してください。
LineSelectedPoseValid | 選択空間内での、この行のポーズが、正常に計算されたかどうかを示します。
NumCharactersEmpty | この行内の、空であった文字の数です。
NumCharactersVerified | この行内の、検証された文字の数です。
ParagraphIndex | ゼロベースのパラグラフインデックスです。これは、配置内のどのパラグラフが、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。
VerificationFullViolations | 検証フル違反を示します。
VerificationKeyViolations | 検証キー違反を示します。
VerificationScore | 行の総合得点です。これは、行内にあるすべての文字の得点を平均した値です。
Verified | この行内にあるすべての文字位置が検証されたかどうかを示します。

プロテクトインスタンスコンストラクタ

CogOCVMaxLineResult オーバロードされます。CogOCVMaxLineResult クラスの新しいインスタンスを初期化します。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult コンストラクタ

オーバロードリスト

指定された CogOCVMaxLineResult オブジェクトのディープコピーを構築します。

public CogOCVMaxLineResult(CogOCVMaxLineResult);

protected CogOCVMaxLineResult(SerializationInfo,StreamingContext);

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult コンストラクタ (SerializationInfo, StreamingContext)

protected CogOCVMaxLineResult(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxLineResult コンストラクタオーバロードリスト


CogOCVMaxLineResult コンストラクタ (CogOCVMaxLineResult)

指定された CogOCVMaxLineResult オブジェクトのディープコピーを構築します。

public CogOCVMaxLineResult(
CogOCVMaxLineResult pOther
);

パラメータ

pOther
コピーされる CogOCVMaxLineResult オブジェクト。NULL であってはなりません。

例外

例外タイプ | 条件
ArgumentNullException | 入力引数が NULL の場合。
OutOfMemoryException | このオブジェクトにメモリを割り当てることができない場合。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxLineResult コンストラクタオーバロードリスト


CogOCVMaxLineResult プロパティ

CogOCVMaxLineResult クラスのプロパティを次に示します。CogOCVMaxLineResult クラスメンバの完全なリストについては、「CogOCVMaxLineResult メンバ」を参照してください。

パブリックインスタンスプロパティ

CharacterResults | 文字結果の System::Array です。この行内の各文字について 1 つ存在します。
LineArrangementPose | 配置空間内での、この行のポーズです。このプロパティは、LineArrangementPoseValid が true の場合のみ有効であることに注意してください。
LineArrangementPoseValid | 配置空間内での、この行のポーズが、正常に計算されたかどうかを示します。
LineIndex | ゼロベースの行インデックスです。これは、包含パラグラフ内のどの行が、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。
LineParagraphPose | パラグラフ空間内での、この行のポーズです。このプロパティは、LineParagraphPoseValid が true の場合のみ有効であることに注意してください。
LineParagraphPoseValid | パラグラフ空間内での、この行のポーズが、正常に計算されたかどうかを示します。
LineSelectedPose | 選択空間内での、この行のポーズです。このプロパティは、LineSelectedPoseValid が true の場合のみ有効であることに注意してください。
LineSelectedPoseValid | 選択空間内での、この行のポーズが、正常に計算されたかどうかを示します。
NumCharactersEmpty | この行内の、空であった文字の数です。
NumCharactersVerified | この行内の、検証された文字の数です。
ParagraphIndex | ゼロベースのパラグラフインデックスです。これは、配置内のどのパラグラフが、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。
VerificationFullViolations | 検証フル違反を示します。
VerificationKeyViolations | 検証キー違反を示します。
VerificationScore | 行の総合得点です。これは、行内にあるすべての文字の得点を平均した値です。
Verified | この行内にあるすべての文字位置が検証されたかどうかを示します。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.CharacterResults プロパティ

文字結果の System::Array です。この行内の各文字について 1 つ存在します。

public CogOCVMaxCharacterResult[] CharacterResults {get;}

プロパティ値

この読み取り専用プロパティは、CogOCVMaxCharacterResult の System::Array タイプです。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.LineArrangementPose プロパティ

配置空間内での、この行のポーズです。このプロパティは、LineArrangementPoseValid が true の場合のみ有効であることに注意してください。

public Cognex.VisionPro.CogTransform2DLinear LineArrangementPose {get;}

プロパティ値

この読み取り専用プロパティは、CogTransform2DLinear タイプです。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.LineArrangementPoseValid プロパティ

配置空間内での、この行のポーズが、正常に計算されたかどうかを示します。

public bool LineArrangementPoseValid {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.LineIndex プロパティ

ゼロベースの行インデックスです。これは、包含パラグラフ内のどの行が、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。

public int LineIndex {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.LineParagraphPose プロパティ

パラグラフ空間内での、この行のポーズです。このプロパティは、LineParagraphPoseValid が true の場合のみ有効であることに注意してください。

public Cognex.VisionPro.CogTransform2DLinear LineParagraphPose {get;}

プロパティ値

この読み取り専用プロパティは、CogTransform2DLinear タイプです。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.LineParagraphPoseValid プロパティ

パラグラフ空間内での、この行のポーズが、正常に計算されたかどうかを示します。

public bool LineParagraphPoseValid {get;}

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.LineSelectedPose プロパティ

選択空間内での、この行のポーズです。このプロパティは、LineSelectedPoseValid が true の場合のみ有効であることに注意してください。

public Cognex.VisionPro.CogTransform2DLinear LineSelectedPose {get;}

プロパティ値

この読み取り専用プロパティは、CogTransform2DLinear タイプです。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.LineSelectedPoseValid プロパティ

選択空間内での、この行のポーズが、正常に計算されたかどうかを示します。

public bool LineSelectedPoseValid {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.NumCharactersEmpty プロパティ

この行内の、空であった文字の数です。

public int NumCharactersEmpty {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.NumCharactersVerified プロパティ

この行内の、検証された文字の数です。

public int NumCharactersVerified {get;}

プロパティ値

System::Int32 タイプの、この読み取り専用プロパティは、ゼロ以上になります。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.ParagraphIndex プロパティ

ゼロベースのパラグラフインデックスです。これは、配置内のどのパラグラフが、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。

public int ParagraphIndex {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.VerificationFullViolations プロパティ

検証フル違反を示します。

public CogOCVMaxDOFConstants VerificationFullViolations {get;}

プロパティ値

この読み取り専用プロパティは、この行内にあるすべての文字に関する、CogOCVMaxDOFConstants のビット単位の OR です。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.VerificationKeyViolations プロパティ

検証キー違反を示します。

public CogOCVMaxDOFConstants VerificationKeyViolations {get;}

プロパティ値

この読み取り専用プロパティは、この行内にあるすべての文字に関する、CogOCVMaxDOFConstants のビット単位の OR です。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.VerificationScore プロパティ

行の総合得点です。これは、行内にあるすべての文字の得点を平均した値です。

public double VerificationScore {get;}

プロパティ値

System::Double タイプの、この読み取り専用プロパティは、0 (最悪) ～ 1 (最良) の範囲になります。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxLineResult.Verified プロパティ

この行内にあるすべての文字位置が検証されたかどうかを示します。

public bool Verified {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

参照

CogOCVMaxLineResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator クラス

このクラスは、CogOCVMaxPattern オブジェクトのパラグラフレベルのプロパティおよびメソッドへの容易なアクセスを提供します。このクラスを使用すると、配置内のすべてのパラグラフにわたって移動することができます。このオブジェクトは、直接構築することはできません。その代わりに、トップレベルの CogOCVMaxPattern オブジェクトに対して CreateParagraphIterator メソッドを使用してください。また、このクラスをアーカイブに格納することはできないことに注意してください。

このタイプのメンバすべてのリストについては、「CogOCVMaxParagraphIterator メンバ」を参照してください。

System.Object
CogOCVMaxParagraphIterator

public class CogOCVMaxParagraphIterator

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxParagraphIterator メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator メンバ

CogOCVMaxParagraphIterator の概要

パブリックインスタンスプロパティ

ConfusionThreshold | このパラグラフのコンフュージョンしきい値を取得または設定します。各パラグラフは、登録時にコンフュージョンマトリックスを構築します。この 2 次元配列が持つ 1 つの次元の要素数は、このパラグラフ内でサーチされる一意のキー (サーチキーと呼びます) の数と同じです。もう 1 つの次元の要素数は、(現在の) アルファベット内にあるキー (アルファベットキーと呼びます) の数と同じです。サーチキーとアルファベットキーの任意の組み合わせについて、対応するコンフュージョン値があります。その値は、2 つのキーで、どの程度紛らわしさが発生しやすいかを示します。1 に近い値では、紛らわしさが非常に発生しやすく (例えば、「5」と「S」)、0 に近い値では、紛らわしさは発生しやすくありません (例えば、「5」と「1」)。ConfusionThreshold プロパティで指定される値未満では、オペレータが、紛らわしさを検査するために、ほかのキーを考慮することはありません。したがって、ConfusionThreshold が 0 の場合は、すべてのキーが試されます。
Font | このパラグラフのフォントを取得または設定します。
FontRenderParams | このパラグラフのフォント描画パラメータを取得または設定します。
IsEnd | この繰り返し指定子が、包含 CogOCVMaxPattern オブジェクト内の最後のパラグラフを超えて配置されているかどうかを示します。
IsFirst | このパラグラフ位置が、包含 CogOCVMaxPattern オブジェクト内の最初のパラグラフ位置であるかどうかを示します。
IsInvalid | この繰り返し指定子が、正当なパラグラフに配置されていないかどうかを示します。true の場合 (つまり、配置されていない場合)、パラグラフレベルのプロパティまたはメソッドにアクセスしようとすると、エラーが生成されます。
LineCount | この繰り返し指定子によって参照されるパラグラフに現在含まれている行の数です。
Origin | このパラグラフの原点を取得または設定します。
Pattern |
Polarity | このパラグラフの極性を取得または設定します。
Pose | このパラグラフのポーズを取得または設定します。
Position | CogOCVMaxPattern オブジェクト内でのこのパラグラフの相対位置を示します。番号付けはゼロベースなので、値 0 は、このパラグラフが CogOCVMaxPattern オブジェクトの最初のパラグラフであることを示します。
TuneParams | このパラグラフのチューニングパラメータを取得または設定します。

パブリックインスタンスメソッド

AreConfusable | オーバロードされます。指定されたサーチ文字キーと、指定されたアルファベット文字キーの間の、計算されたコンフュージョン得点が、このパラグラフのコンフュージョンしきい値よりも小さい場合、false を返します (つまり、このペアでは、紛らわしさが発生しやすいとはみなされません)。それ以外の場合は、true を返します (つまり、このペアでは、紛らわしさが発生しやすいとみなされます)。
Copy | オーバロードされます。このメソッドと機能的に同一の、新しく作成されたパラグラフ繰り返し指定子を返します。新しく作成されたパラグラフ繰り返し指定子は、同じ包囲 CogOCVMaxPattern オブジェクト内の、同じパラグラフ位置を持ちます。
CreateLineIterator | このパラグラフの最初の行位置に対応する、新しく作成された行繰り返し指定子を返します。
GetAlphabetCharacterKeys | このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字キーのリストを提供します。サーチされる一意の文字のそれぞれについて、この文字キーのセットに対するコンフュージョンが計算されます。このリストが空の場合は、フォント内の各文字が使用されることに注意してください。
GetAlphabetCharacters | このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを提供します。サーチされる一意の文字のそれぞれについて、この文字のセットに対するコンフュージョンが計算されます。このリストが空の場合は、フォント内の各文字が使用されることに注意してください。
GetConfusion | オーバロードされます。指定されたサーチ文字キーと、指定されたアルファベット文字キーの間の、計算されたコンフュージョンを取得します。
GetConfusionAlphabetCharacterKeys | コンフュージョンアルファベット文字キーを取得します。これは、このパラグラフのためのアルファベットキーと同じです。これらの文字キーは、このパラグラフについてのコンフュージョンマトリックスの 1 つの次元を形成します。
GetConfusionAlphabetCharacters | コンフュージョンアルファベット文字を取得します。これは、このパラグラフのためのアルファベットと同じです。これらの文字は、このパラグラフについてのコンフュージョンマトリックスの 1 つの次元を形成します。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提となっているため注意してください。
GetConfusionSearchCharacterKeys | コンフュージョンサーチ文字キーを取得します。これは、このパラグラフ内のテキストを構成する一意の文字キー (サーチする文字キー) のセットです。これらの文字キーは、このパラグラフについてのコンフュージョンマトリックスの 1 つの次元を形成します。
GetConfusionSearchCharacters | コンフュージョンサーチ文字を取得します。これは、このパラグラフ内のテキストを構成する一意の文字 (サーチする文字) のセットです。これらの文字は、このパラグラフについてのコンフュージョンマトリックスの 1 つの次元を形成します。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提となっているため注意してください。
GetNextLineOrigin | このパラグラフ内にある最後の行の後の行における、パラグラフ座標内での予想位置を取得します。つまり、このパラグラフに行を追加する場合、行はその位置に置かれます。
GetNextParagraphOrigin | このパラグラフの後にある次のパラグラフにおける、パラグラフ座標内での予想位置を取得します。これは、各パラグラフ内の最初の行 (の垂直位置) が揃えられ、また、第 2 のパラグラフが第 1 のパラグラフを上書きしないような位置になります (つまり、第 2 のパラグラフは、第 1 のパラグラフの最も長い行の末尾を水平方向に超えたところに配置されます)。
MoveToNext | パラグラフ繰り返し指定子を、包含 CogOCVMaxPattern オブジェクト内の次のパラグラフ位置に移動します。繰り返し指定子が、この呼び出しの前に既に最後の位置にある場合、MoveToNext は例外を生成します。エラーを避けるには、MoveToNext を呼び出す前に IsEnd プロパティをチェックしてください。
MoveToPosition | パラグラフ繰り返し指定子を、包含 CogOCVMaxPattern オブジェクト内の指定された位置に移動します。引数が 0 の場合は、CogOCVMaxPattern オブジェクト内の最初のパラグラフ位置に移動します。引数が -1 の場合は、CogOCVMaxPattern オブジェクト内の最後のパラグラフ位置に移動します。引数が正当でない場合は、例外が生成されます。
MoveToPrevious | パラグラフ繰り返し指定子を、包含 CogOCVMaxPattern オブジェクト内の前のパラグラフ位置に移動します。繰り返し指定子が、この呼び出しの前に既に最初の位置にある場合、MoveToPrevious は例外を生成します。エラーを避けるには、MoveToPrevious を呼び出す前に IsFirst プロパティをチェックしてください。
SetAlphabet | オーバロードされます。このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを設定します。特に、指定された System::Int32 の配列内にキーが存在する文字に一致するように、リストを設定します。この配列が要素を持たない場合、その結果として設定される空のアルファベットリストは、利用可能なすべての文字の使用を意味すると解釈されます。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator プロパティ

CogOCVMaxParagraphIterator クラスのプロパティを次に示します。CogOCVMaxParagraphIterator クラスメンバの完全なリストについては、「CogOCVMaxParagraphIterator メンバ」を参照してください。

パブリックインスタンスプロパティ

ConfusionThreshold | このパラグラフのコンフュージョンしきい値を取得または設定します。各パラグラフは、登録時にコンフュージョンマトリックスを構築します。この 2 次元配列が持つ 1 つの次元の要素数は、このパラグラフ内でサーチされる一意のキー (サーチキーと呼びます) の数と同じです。もう 1 つの次元の要素数は、(現在の) アルファベット内にあるキー (アルファベットキーと呼びます) の数と同じです。サーチキーとアルファベットキーの任意の組み合わせについて、対応するコンフュージョン値があります。その値は、2 つのキーで、どの程度紛らわしさが発生しやすいかを示します。1 に近い値では、紛らわしさが非常に発生しやすく (例えば、「5」と「S」)、0 に近い値では、紛らわしさは発生しやすくありません (例えば、「5」と「1」)。ConfusionThreshold プロパティで指定される値未満では、オペレータが、紛らわしさを検査するために、ほかのキーを考慮することはありません。したがって、ConfusionThreshold が 0 の場合は、すべてのキーが試されます。
Font | このパラグラフのフォントを取得または設定します。
FontRenderParams | このパラグラフのフォント描画パラメータを取得または設定します。
IsEnd | この繰り返し指定子が、包含 CogOCVMaxPattern オブジェクト内の最後のパラグラフを超えて配置されているかどうかを示します。
IsFirst | このパラグラフ位置が、包含 CogOCVMaxPattern オブジェクト内の最初のパラグラフ位置であるかどうかを示します。
IsInvalid | この繰り返し指定子が、正当なパラグラフに配置されていないかどうかを示します。true の場合 (つまり、配置されていない場合)、パラグラフレベルのプロパティまたはメソッドにアクセスしようとすると、エラーが生成されます。
LineCount | この繰り返し指定子によって参照されるパラグラフに現在含まれている行の数です。
Origin | このパラグラフの原点を取得または設定します。
Pattern |
Polarity | このパラグラフの極性を取得または設定します。
Pose | このパラグラフのポーズを取得または設定します。
Position | CogOCVMaxPattern オブジェクト内でのこのパラグラフの相対位置を示します。番号付けはゼロベースなので、値 0 は、このパラグラフが CogOCVMaxPattern オブジェクトの最初のパラグラフであることを示します。
TuneParams | このパラグラフのチューニングパラメータを取得または設定します。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.ConfusionThreshold プロパティ

このパラグラフのコンフュージョンしきい値を取得または設定します。各パラグラフは、登録時にコンフュージョンマトリックスを構築します。この 2 次元配列が持つ 1 つの次元の要素数は、このパラグラフ内でサーチされる一意のキー (サーチキーと呼びます) の数と同じです。もう 1 つの次元の要素数は、(現在の) アルファベット内にあるキー (アルファベットキーと呼びます) の数と同じです。サーチキーとアルファベットキーの任意の組み合わせについて、対応するコンフュージョン値があります。その値は、2 つのキーでどの程度紛らわしさが発生しやすいかを示します。1 に近い値では、紛らわしさが非常に発生しやすく (例えば、「5」と「S」)、0 に近い値では、紛らわしさは発生しやすくありません (例えば、「5」と「1」)。ConfusionThreshold プロパティで指定される値未満では、オペレータが、紛らわしさを検査するために、ほかのキーを考慮することはありません。したがって、ConfusionThreshold が 0 の場合は、すべてのキーが試されます。

public double ConfusionThreshold {get; set;}

プロパティ値

System::Double タイプの、この読み取り/書き込みプロパティは、0 ～ 1 の範囲である必要があります。

イベント

イベントタイプ | 理由
ParagraphChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。
ArgumentOutOfRangeException | このプロパティを 0 未満または 1 より大きな値に設定しようとした場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.Font プロパティ

このパラグラフのフォントを取得または設定します。

public CogOCVMaxFont Font {get; set;}

プロパティ値

CogOCVMaxFont タイプの、この読み取り/書き込みプロパティは、NULL であることが可能です。

イベント

イベントタイプ | 理由
ParagraphChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | このパラグラフ繰り返し指定子が、正当なパラグラフを現在参照していない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.FontRenderParams プロパティ

このパラグラフのフォント描画パラメータを取得または設定します。

public CogOCVMaxFontRenderParams FontRenderParams {get; set;}

プロパティ値

CogOCVMaxFontRenderParams タイプの、この読み取り/書き込みプロパティは、NULL であってはなりません。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。
ParagraphChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。

例外

例外タイプ | 条件
ArgumentNullException | このプロパティを NULL に設定しようとした場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.IsEnd プロパティ

この繰り返し指定子が、包含 CogOCVMaxPattern オブジェクト内の最後のパラグラフを超えて配置されているかどうかを示します。

public bool IsEnd {get;}

プロパティ値

この読み取り専用プロパティは、System::Boolean タイプです。

例外

例外タイプ | 条件
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.IsFirst プロパティ

このパラグラフ位置が、包含 CogOCVMaxPattern オブジェクト内の最初のパラグラフ位置であるかどうかを示します。

public bool IsFirst {get;}

プロパティ値

この読み取り専用プロパティは、System::Boolean タイプです。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.IsInvalid プロパティ

この繰り返し指定子が、正当なパラグラフに配置されていないかどうかを示します。true の場合 (つまり、配置されていない場合)、パラグラフレベルのプロパティまたはメソッドにアクセスしようとすると、エラーが生成されます。

public bool IsInvalid {get;}

プロパティ値

この読み取り専用プロパティは、System::Boolean タイプです。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.LineCount プロパティ

この繰り返し指定子によって参照されるパラグラフに現在含まれている行の数です。

public int LineCount {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

例外

例外タイプ | 条件
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | このパラグラフ繰り返し指定子が、正当なパラグラフを現在参照していない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.Origin プロパティ

このパラグラフの原点を取得または設定します。

public Cognex.VisionPro.CogTransform2DLinear Origin {get; set;}

プロパティ値

CogTransform2DLinear タイプの、この読み取り/書き込みプロパティは、NULL であってはなりません。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。
ParagraphChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。

例外

例外タイプ | 条件
InvalidOperationException | このパラグラフ繰り返し指定子が、正当なパラグラフを現在参照していない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentNullException | このプロパティを NULL に設定しようとした場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.Pattern プロパティ

public CogOCVMaxPattern Pattern {get;}

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.Polarity プロパティ

このパラグラフの極性を取得または設定します。

public CogOCVMaxPolarityConstants Polarity {get; set;}

プロパティ値

CogOCVMaxPolarityConstants タイプの、この読み取り/書き込みプロパティは、DarkOnLight、LightOnDark、または Unknown のいずれかであることが可能です。

イベント

イベントタイプ | 理由
ParagraphChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | このパラグラフ繰り返し指定子が、正当なパラグラフを現在参照していない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.Pose プロパティ

このパラグラフのポーズを取得または設定します。

public Cognex.VisionPro.CogTransform2DLinear Pose {get; set;}

プロパティ値

CogTransform2DLinear タイプの、この読み取り/書き込みプロパティは、NULL であってはなりません。

イベント

イベントタイプ | 理由
ParagraphChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。
ArgumentNullException | このプロパティを NULL に設定しようとした場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.Position プロパティ

CogOCVMaxPattern オブジェクト内でのこのパラグラフの相対位置を示します。番号付けはゼロベースなので、値 0 は、このパラグラフが CogOCVMaxPattern オブジェクトの最初のパラグラフであることを示します。

public int Position {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.TuneParams プロパティ

このパラグラフのチューニングパラメータを取得または設定します。

public CogOCVMaxTuneParams TuneParams {get; set;}

プロパティ値

CogOCVMaxTuneParams タイプの、この読み取り/書き込みプロパティは、NULL であってはなりません。

イベント

イベントタイプ | 理由
ParagraphChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | このプロパティを NULL に設定しようとした場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | このパラグラフ繰り返し指定子が、正当なパラグラフを現在参照していない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator メソッド

CogOCVMaxParagraphIterator クラスのメソッドを次に示します。CogOCVMaxParagraphIterator クラスメンバの完全なリストについては、「CogOCVMaxParagraphIterator メンバ」を参照してください。

パブリックインスタンスメソッド

AreConfusable | オーバロードされます。指定されたサーチ文字キーと、指定されたアルファベット文字キーの間の、計算されたコンフュージョン得点が、このパラグラフのコンフュージョンしきい値よりも小さい場合、false を返します (つまり、このペアでは、紛らわしさが発生しやすいとはみなされません)。それ以外の場合は、true を返します (つまり、このペアでは、紛らわしさが発生しやすいとみなされます)。
Copy | オーバロードされます。このメソッドと機能的に同一の、新しく作成されたパラグラフ繰り返し指定子を返します。新しく作成されたパラグラフ繰り返し指定子は、同じ包囲 CogOCVMaxPattern オブジェクト内の、同じパラグラフ位置を持ちます。
CreateLineIterator | このパラグラフの最初の行位置に対応する、新しく作成された行繰り返し指定子を返します。
GetAlphabetCharacterKeys | このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字キーのリストを提供します。サーチされる一意の文字のそれぞれについて、この文字キーのセットに対するコンフュージョンが計算されます。このリストが空の場合は、フォント内の各文字が使用されることに注意してください。
GetAlphabetCharacters | このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを提供します。サーチされる一意の文字のそれぞれについて、この文字のセットに対するコンフュージョンが計算されます。このリストが空の場合は、フォント内の各文字が使用されることに注意してください。
GetConfusion | オーバロードされます。指定されたサーチ文字キーと、指定されたアルファベット文字キーの間の、計算されたコンフュージョンを取得します。
GetConfusionAlphabetCharacterKeys | コンフュージョンアルファベット文字キーを取得します。これは、このパラグラフのためのアルファベットキーと同じです。これらの文字キーは、このパラグラフについてのコンフュージョンマトリックスの 1 つの次元を形成します。
GetConfusionAlphabetCharacters | コンフュージョンアルファベット文字を取得します。これは、このパラグラフのためのアルファベットと同じです。これらの文字は、このパラグラフについてのコンフュージョンマトリックスの 1 つの次元を形成します。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提となっているため注意してください。
GetConfusionSearchCharacterKeys | コンフュージョンサーチ文字キーを取得します。これは、このパラグラフ内のテキストを構成する一意の文字キー (サーチする文字キー) のセットです。これらの文字キーは、このパラグラフについてのコンフュージョンマトリックスの 1 つの次元を形成します。
GetConfusionSearchCharacters | コンフュージョンサーチ文字を取得します。これは、このパラグラフ内のテキストを構成する一意の文字 (サーチする文字) のセットです。これらの文字は、このパラグラフについてのコンフュージョンマトリックスの 1 つの次元を形成します。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提となっているため注意してください。
GetNextLineOrigin | このパラグラフ内にある最後の行の後の行における、パラグラフ座標内での予想位置を取得します。つまり、このパラグラフに行を追加する場合、行はその位置に置かれます。
GetNextParagraphOrigin | このパラグラフの後にある次のパラグラフにおける、パラグラフ座標内での予想位置を取得します。これは、各パラグラフ内の最初の行 (の垂直位置) が揃えられ、また、第 2 のパラグラフが第 1 のパラグラフを上書きしないような位置になります (つまり、第 2 のパラグラフは、第 1 のパラグラフの最も長い行の末尾を水平方向に超えたところに配置されます)。
MoveToNext | パラグラフ繰り返し指定子を、包含 CogOCVMaxPattern オブジェクト内の次のパラグラフ位置に移動します。繰り返し指定子が、この呼び出しの前に既に最後の位置にある場合、MoveToNext は例外を生成します。エラーを避けるには、MoveToNext を呼び出す前に IsEnd プロパティをチェックしてください。
MoveToPosition | パラグラフ繰り返し指定子を、包含 CogOCVMaxPattern オブジェクト内の指定された位置に移動します。引数が 0 の場合は、CogOCVMaxPattern オブジェクト内の最初のパラグラフ位置に移動します。引数が -1 の場合は、CogOCVMaxPattern オブジェクト内の最後のパラグラフ位置に移動します。引数が正当でない場合は、例外が生成されます。
MoveToPrevious | パラグラフ繰り返し指定子を、包含 CogOCVMaxPattern オブジェクト内の前のパラグラフ位置に移動します。繰り返し指定子が、この呼び出しの前に既に最初の位置にある場合、MoveToPrevious は例外を生成します。エラーを避けるには、MoveToPrevious を呼び出す前に IsFirst プロパティをチェックしてください。
SetAlphabet | オーバロードされます。このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを設定します。特に、指定された System::Int32 の配列内にキーが存在する文字に一致するように、リストを設定します。この配列が要素を持たない場合、その結果として設定される空のアルファベットリストは、利用可能なすべての文字の使用を意味すると解釈されます。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


AreConfusable メソッド

VisionPro プログラミングリファレンス

CogOCVMaxParagraphIterator.AreConfusable メソッド

指定されたサーチ文字と指定されたアルファベット文字の間の、計算されたコンフュージョン得点が、このパラグラフのコンフュージョンしきい値よりも小さい場合、false を返します (つまり、このペアでは、紛らわしさが発生しやすいとはみなされません)。それ以外の場合は、true を返します (つまり、このペアでは、紛らわしさが発生しやすいとみなされます)。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。

オーバロードリスト

指定されたサーチ文字と指定されたアルファベット文字の間の、計算されたコンフュージョン得点が、このパラグラフのコンフュージョンしきい値よりも小さい場合、false を返します (つまり、このペアでは、紛らわしさが発生しやすいとはみなされません)。それ以外の場合は、true を返します (つまり、このペアでは、紛らわしさが発生しやすいとみなされます)。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。

public bool AreConfusable(char,char);

指定されたサーチ文字キーと、指定されたアルファベット文字キーの間の、計算されたコンフュージョン得点が、このパラグラフのコンフュージョンしきい値よりも小さい場合、false を返します (つまり、このペアでは、紛らわしさが発生しやすいとはみなされません)。それ以外の場合は、true を返します (つまり、このペアでは、紛らわしさが発生しやすいとみなされます)。

public bool AreConfusable(int,int);

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.AreConfusable メソッド (Char, Char)

指定されたサーチ文字と指定されたアルファベット文字の間の、計算されたコンフュージョン得点が、このパラグラフのコンフュージョンしきい値よりも小さい場合、false を返します (つまり、このペアでは、紛らわしさが発生しやすいとはみなされません)。それ以外の場合は、true を返します (つまり、このペアでは、紛らわしさが発生しやすいとみなされます)。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。

public bool AreConfusable(
char searchCharacter,
char alphabetCharacter
);

パラメータ

searchCharacter
対象のサーチ文字。この文字は、このパラグラフのテキスト内にある文字のいずれかである必要があります。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。
alphabetCharacter
対象のアルファベット文字。この文字は、このパラグラフのためのアルファベット文字のいずれかである必要があります。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。

戻り値

System::Boolean。文字に紛らわしさが発生しやすい場合は true、文字に紛らわしさが発生しやすくない場合は false になります。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxParagraphIterator.AreConfusable オーバロードリスト


CogOCVMaxParagraphIterator.AreConfusable メソッド (Int32, Int32)

指定されたサーチ文字キーと、指定されたアルファベット文字キーの間の、計算されたコンフュージョン得点が、このパラグラフのコンフュージョンしきい値よりも小さい場合、false を返します (つまり、このペアでは、紛らわしさが発生しやすいとはみなされません)。それ以外の場合は、true を返します (つまり、このペアでは、紛らわしさが発生しやすいとみなされます)。

public bool AreConfusable(
int searchKey,
int alphabetKey
);

パラメータ

searchKey
対象のサーチ文字キー。この文字キーは、このパラグラフのテキスト内にある文字キーのいずれかである必要があります。
alphabetKey
対象のアルファベット文字キー。この文字キーは、このパラグラフのためのアルファベット文字キーのいずれかである必要があります。

戻り値

System::Boolean。文字に紛らわしさが発生しやすい場合は true、文字に紛らわしさが発生しやすくない場合は false になります。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | CogOCVMaxPattern オブジェクトがまだ登録されていない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxParagraphIterator.AreConfusable オーバロードリスト


Copy メソッド

VisionPro プログラミングリファレンス

CogOCVMaxParagraphIterator.Copy メソッド

このメソッドと機能的に同一の、新しく作成されたパラグラフ繰り返し指定子を返します。新しく作成されたパラグラフ繰り返し指定子は、同じ包囲 CogOCVMaxPattern オブジェクト内の、同じパラグラフ位置を持ちます。

オーバロードリスト

このメソッドと機能的に同一の、新しく作成されたパラグラフ繰り返し指定子を返します。新しく作成されたパラグラフ繰り返し指定子は、同じ包囲 CogOCVMaxPattern オブジェクト内の、同じパラグラフ位置を持ちます。

public CogOCVMaxParagraphIterator Copy();

このパラグラフ繰り返し指定子と同じ包囲 CogOCVMaxPattern オブジェクト内の、指定されたパラグラフ位置に対応する、新しく作成されたパラグラフ繰り返し指定子を返します。引数は、現在のパラグラフ位置からの位置オフセットです。したがって、値 0 によって、これと機能的に同一な新しいパラグラフ繰り返し指定子が得られます。

public CogOCVMaxParagraphIterator Copy(int);

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.Copy メソッド ()

このメソッドと機能的に同一の、新しく作成されたパラグラフ繰り返し指定子を返します。新しく作成されたパラグラフ繰り返し指定子は、同じ包囲 CogOCVMaxPattern オブジェクト内の、同じパラグラフ位置を持ちます。

public CogOCVMaxParagraphIterator Copy();

戻り値

このパラグラフ繰り返し指定子と同じパラグラフ位置を持つ CogOCVMaxParagraphIterator。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxParagraphIterator.Copy オーバロードリスト


CogOCVMaxParagraphIterator.Copy メソッド (Int32)

このパラグラフ繰り返し指定子と同じ包囲 CogOCVMaxPattern オブジェクト内の、指定されたパラグラフ位置に対応する、新しく作成されたパラグラフ繰り返し指定子を返します。引数は、現在のパラグラフ位置からの位置オフセットです。したがって、値 0 によって、これと機能的に同一な新しいパラグラフ繰り返し指定子が得られます。

public CogOCVMaxParagraphIterator Copy(
int PositionOffset
);

パラメータ

PositionOffset
包囲 CogOCVMaxPattern オブジェクト内の新しいパラグラフ位置インデックスを得るために、このパラグラフ繰り返し指定子のパラグラフ位置インデックスに追加される System::Int32。パラグラフ位置インデックスのこの計算結果が正当でない場合は、例外が生成されます。

戻り値

包含 CogOCVMaxPattern オブジェクト内の指定されたパラグラフ位置に対応する CogOCVMaxParagraphIterator。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | 指定された引数から計算されるパラグラフ位置インデックスが、0 より小さいか、または包囲 CogOCVMaxPattern オブジェクト内のパラグラフ数より大きい場合。
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxParagraphIterator.Copy オーバロードリスト


CogOCVMaxParagraphIterator.CreateLineIterator メソッド

このパラグラフの最初の行位置に対応する、新しく作成された行繰り返し指定子を返します。

public CogOCVMaxLineIterator CreateLineIterator();

戻り値

このパラグラフの最初の行位置に対応する、CogOCVMaxLine 繰り返し指定子。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.GetAlphabetCharacterKeys メソッド

このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字キーのリストを提供します。サーチされる一意の文字のそれぞれについて、この文字キーのセットに対するコンフュージョンが計算されます。このリストが空の場合は、フォント内のすべての文字が使用されることに注意してください。

public int[] GetAlphabetCharacterKeys();

戻り値

このパラグラフに対して定義される各アルファベット文字キーに対応する、System::Int32 の System::Array。

例外

例外タイプ | 条件
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.GetAlphabetCharacters メソッド

このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを提供します。サーチされる一意の文字のそれぞれについて、この文字のセットに対するコンフュージョンが計算されます。このリストが空の場合は、フォント内のすべての文字が使用されることに注意してください。

public string GetAlphabetCharacters();

戻り値

System::String。この中の各文字は、このパラグラフに対するアルファベット文字のいずれかに対応しています。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


GetConfusion メソッド

VisionPro プログラミングリファレンス

CogOCVMaxParagraphIterator.GetConfusion メソッド

指定されたサーチ文字と、指定されたアルファベット文字の間の、計算されたコンフュージョンを取得します。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。

オーバロードリスト

指定されたサーチ文字と、指定されたアルファベット文字の間の、計算されたコンフュージョンを取得します。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。

public double GetConfusion(char,char);

指定されたサーチ文字キーと、指定されたアルファベット文字キーの間の、計算されたコンフュージョンを取得します。

public double GetConfusion(int,int);

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.GetConfusion メソッド (Char, Char)

指定されたサーチ文字と、指定されたアルファベット文字の間の、計算されたコンフュージョンを取得します。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。

public double GetConfusion(
char searchCharacter,
char alphabetCharacter
);

パラメータ

searchCharacter
対象のサーチ文字。この文字は、このパラグラフのテキスト内にある文字のいずれかである必要があります。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。
alphabetCharacter
対象のアルファベット文字。この文字は、このパラグラフのためのアルファベット文字のいずれかである必要があります。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。

戻り値

0 ～ 1 の範囲の System::Double。これは、指定されたサーチ文字と、指定されたアルファベット文字の間の、計算されたコンフュージョン値です。要求されたコンフュージョン得点をオペレータが計算しなかった場合、この値は負になります。1 に近い値は、紛らわしさが非常に発生しやすいことを意味し (例えば、「5」と「S」)、0 に近い値は、紛らわしさが発生しやすくないことを意味します (例えば、「5」と「1」)。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | CogOCVMaxPattern オブジェクトがまだ登録されていない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxParagraphIterator.GetConfusion オーバロードリスト


CogOCVMaxParagraphIterator.GetConfusion メソッド (Int32, Int32)

指定されたサーチ文字キーと、指定されたアルファベット文字キーの間の、計算されたコンフュージョンを取得します。

public double GetConfusion(
int searchKey,
int alphabetKey
);

パラメータ

searchKey
対象のサーチ文字キー。この文字キーは、このパラグラフのテキスト内にある文字キーのいずれかである必要があります。
alphabetKey
対象のアルファベット文字キー。この文字キーは、このパラグラフのためのアルファベット文字キーのいずれかである必要があります。

戻り値

0 ～ 1 の範囲の System::Double。これは、指定されたサーチ文字キーと、指定されたアルファベット文字キーの間の、計算されたコンフュージョン値です。要求されたコンフュージョン得点をオペレータが計算しなかった場合、この値は負になります。1 に近い値は、紛らわしさが非常に発生しやすいことを意味し (例えば、「5」と「S」)、0 に近い値は、紛らわしさが発生しやすくないことを意味します (例えば、「5」と「1」)。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | CogOCVMaxPattern オブジェクトがまだ登録されていない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxParagraphIterator.GetConfusion オーバロードリスト


CogOCVMaxParagraphIterator.GetConfusionAlphabetCharacterKeys メソッド

コンフュージョンアルファベット文字キーを取得します。これは、このパラグラフのためのアルファベットキーと同じです。これらの文字キーは、このパラグラフについてのコンフュージョンマトリックスの 1 つの次元を形成します。

public int[] GetConfusionAlphabetCharacterKeys();

戻り値

System::Int32 の System::Array。この中の各要素は、このパラグラフのためのコンフュージョンアルファベット文字キーのいずれかに対応しています。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.GetConfusionAlphabetCharacters メソッド

コンフュージョンアルファベット文字を取得します。これは、このパラグラフのためのアルファベットと同じです。これらの文字は、このパラグラフについてのコンフュージョンマトリックスの 1 つの次元を形成します。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提となっているため注意してください。

public string GetConfusionAlphabetCharacters();

戻り値

System::String。この中の各文字は、このパラグラフのためのコンフュージョンアルファベット文字のいずれかに対応しています。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提となっているため注意してください。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.GetConfusionSearchCharacterKeys メソッド

コンフュージョンサーチ文字キーを取得します。これは、このパラグラフ内のテキストを構成する一意の文字キー (サーチする文字キー) のセットです。これらの文字キーは、このパラグラフについてのコンフュージョンマトリックスの 1 つの次元を形成します。

public int[] GetConfusionSearchCharacterKeys();

戻り値

System::Int32 の System::Array。この中の各要素は、このパラグラフのためのコンフュージョンサーチ文字キーのいずれかに対応しています。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.GetConfusionSearchCharacters メソッド

コンフュージョンサーチ文字を取得します。これは、このパラグラフ内のテキストを構成する一意の文字 (サーチする文字) のセットです。これらの文字は、このパラグラフについてのコンフュージョンマトリックスの 1 つの次元を形成します。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提となっているため注意してください。

public string GetConfusionSearchCharacters();

戻り値

System::String。この中の各文字は、このパラグラフのためのコンフュージョンサーチ文字のいずれかに対応しています。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提となっているため注意してください。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.GetNextLineOrigin メソッド

このパラグラフ内にある最終行の後の行における、パラグラフ座標内での予想位置を取得します。つまり、このパラグラフに行を追加する場合、行はその位置に置かれます。

public CogTransform2DLinear GetNextLineOrigin();

戻り値

パラグラフ空間内での次の行の原点を指定する CogTransform2DLinear。

例外

例外タイプ | 条件
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.GetNextParagraphOrigin メソッド

このパラグラフの後にある次のパラグラフにおける、パラグラフ座標内での予想位置を取得します。これは、各パラグラフ内の最初の行 (の垂直位置) が揃えられ、また、第 2 のパラグラフが第 1 のパラグラフを上書きしないような位置になります (つまり、第 2 のパラグラフは、第 1 のパラグラフの最も長い行の末尾を水平方向に超えたところに配置されます)。

public CogTransform2DLinear GetNextParagraphOrigin();

戻り値

パラグラフ空間内での次のパラグラフの原点を指定する CogTransform2DLinear。

例外

例外タイプ | 条件
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.MoveToNext メソッド

パラグラフ繰り返し指定子を、包含 CogOCVMaxPattern オブジェクト内の次のパラグラフ位置に移動します。繰り返し指定子が、この呼び出しの前に既に最後の位置にある場合、MoveToNext は例外を生成します。エラーを避けるには、MoveToNext を呼び出す前に IsEnd プロパティをチェックしてください。

public void MoveToNext();

例外

例外タイプ | 条件
InvalidOperationException | このパラグラフ繰り返し指定子を、End を超えてインクリメントしようとした場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.MoveToPosition メソッド

パラグラフ繰り返し指定子を、包含 CogOCVMaxPattern オブジェクト内の指定された位置に移動します。引数が 0 の場合は、CogOCVMaxPattern オブジェクト内の最初のパラグラフ位置に移動します。引数が -1 の場合は、CogOCVMaxPattern オブジェクト内の最後のパラグラフ位置に移動します。引数が正当でない場合は、例外が生成されます。

public void MoveToPosition(
int Position
);

パラメータ

Position
包囲 CogOCVMaxPattern オブジェクト内への System::Int32 インデックス。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | 引数が -1 より小さいか、または包囲 CogOCVMaxPattern オブジェクト内のパラグラフ数より大きい場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.MoveToPrevious メソッド

パラグラフ繰り返し指定子を、包含 CogOCVMaxPattern オブジェクト内の前のパラグラフ位置に移動します。繰り返し指定子が、この呼び出しの前に既に最初の位置にある場合、MoveToPrevious は例外を生成します。エラーを避けるには、MoveToPrevious を呼び出す前に IsFirst プロパティをチェックしてください。

public void MoveToPrevious();

例外

例外タイプ | 条件
InvalidOperationException | このパラグラフ繰り返し指定子を検出できない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


SetAlphabet メソッド

VisionPro プログラミングリファレンス

CogOCVMaxParagraphIterator.SetAlphabet メソッド

このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを、フォント内で利用可能なすべての文字となるように設定します。サーチされる一意の文字のそれぞれについて、この文字のセットに対するコンフュージョンが計算されます。

オーバロードリスト

このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを、フォント内で利用可能なすべての文字となるように設定します。サーチされる一意の文字のそれぞれについて、この文字のセットに対するコンフュージョンが計算されます。

public void SetAlphabet();

このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを設定します。特に、入力ビットフィールドによって指定されたカテゴリに一致する、現在のフォント内の文字に対応するように、リストを設定します。カテゴリとしては、DecimalDigitNumber、LowercaseLetter、UppercaseLetter、All、および None があります。None の設定を介して作成された空のアルファベットリストは、利用可能なすべての文字の使用を意味すると解釈されることに注意してください。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値であることが前提になっています。

public void SetAlphabet(CogOCVMaxCharacterTypeConstants);

このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを設定します。特に、指定された System::Int32 の配列内にキーが存在する文字に一致するように、リストを設定します。この配列が要素を持たない場合、その結果として設定される空のアルファベットリストは、利用可能なすべての文字の使用を意味すると解釈されます。

public void SetAlphabet(int[]);

このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを設定します。特に、指定された文字列引数内の文字に一致するように、リストを設定します。文字列引数が空の文字列である場合、その結果として設定される空のアルファベットリストは、利用可能なすべての文字の使用を意味すると解釈されます。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値であることが前提になっています。

public void SetAlphabet(string);

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphIterator.SetAlphabet メソッド ()

このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを、フォント内で利用可能なすべての文字となるように設定します。サーチされる一意の文字のそれぞれについて、この文字のセットに対するコンフュージョンが計算されます。

public void SetAlphabet();

イベント

イベントタイプ | 理由
ParagraphChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | このパラグラフ繰り返し指定子が、正当なパラグラフを現在参照していない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxParagraphIterator.SetAlphabet オーバロードリスト


CogOCVMaxParagraphIterator.SetAlphabet メソッド (CogOCVMaxCharacterTypeConstants)

このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを設定します。特に、入力ビットフィールドによって指定されたカテゴリに一致する、現在のフォント内の文字に対応するように、リストを設定します。カテゴリとしては、DecimalDigitNumber、LowercaseLetter、UppercaseLetter、All、および None があります。None の設定を介して作成された空のアルファベットリストは、利用可能なすべての文字の使用を意味すると解釈されることに注意してください。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値であることが前提になっています。

public void SetAlphabet(
CogOCVMaxCharacterTypeConstants NewValue
);

パラメータ

NewValue
CogOCVMaxCharacterTypeConstants のビット単位の OR。これは、DecimalDigitNumber、LowercaseLetter、または UppercaseLetter の任意の組み合わせであることが可能です。あるいは、All または None であることも可能です。

イベント

イベントタイプ | 理由
ParagraphChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | このパラグラフ繰り返し指定子が、正当なパラグラフを現在参照していない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxParagraphIterator.SetAlphabet オーバロードリスト


CogOCVMaxParagraphIterator.SetAlphabet メソッド (Int32[])

このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを設定します。特に、指定された System::Int32 の配列内にキーが存在する文字に一致するように、リストを設定します。この配列が要素を持たない場合、その結果として設定される空のアルファベットリストは、利用可能なすべての文字の使用を意味すると解釈されます。

public void SetAlphabet(
int[] NewValue
);

パラメータ

NewValue
System::Int32 の System::Array。これらは望ましい文字キーです。

イベント

イベントタイプ | 理由
ParagraphChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | 対応する CogOCVMaxPattern オブジェクトがこの繰り返し指定子を認識しない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxParagraphIterator.SetAlphabet オーバロードリスト


CogOCVMaxParagraphIterator.SetAlphabet メソッド (String)

このパラグラフ内で正確に、または不正確に観察される可能性がある、現在のフォント内の各文字のリストを設定します。特に、指定された文字列引数内の文字に一致するように、リストを設定します。文字列引数が空の文字列である場合、その結果として設定される空のアルファベットリストは、利用可能なすべての文字の使用を意味すると解釈されます。このメソッドでは、関連するフォントの文字キーは、Unicode のコードポイント値であることが前提になっています。

public void SetAlphabet(
string NewValue
);

パラメータ

NewValue
System::String。この中の個別の文字は、望ましいアルファベットを構成します。

イベント

イベントタイプ | 理由
ParagraphChanged | このプロパティが変化した場合に発生します。Changed イベントよりも詳しい情報を提供します。
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | このパラグラフが、正当なフォントを現在参照していない場合。
ObjectDisposedException | 対応する CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxParagraphIterator クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxParagraphIterator.SetAlphabet オーバロードリスト


CogOCVMaxParagraphResult クラス

このクラスは、1 つのパラグラフについての結果情報のすべてを保持します。

このタイプのメンバすべてのリストについては、「CogOCVMaxParagraphResult メンバ」を参照してください。

System.Object
MarshalByRefObject
CogObjectBase
CogSerializableObjectBase
CogOCVMaxParagraphResult

public class CogOCVMaxParagraphResult :CogSerializableObjectBase

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxParagraphResult メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult メンバ

CogOCVMaxParagraphResult の概要

パブリックインスタンスコンストラクタ

CogOCVMaxParagraphResult オーバロードされます。CogOCVMaxParagraphResult クラスの新しいインスタンスを初期化します。

パブリックインスタンスプロパティ

LineResults | 行結果の System::Array です。このパラグラフ内の各行について 1 つ存在します。
NumLinesVerified | このパラグラフ内の、検証された行の数です。
ParagraphArrangementPose | 配置空間内での、このパラグラフのポーズです。このプロパティは、ParagraphArrangementPoseValid が true の場合のみ有効であることに注意してください。
ParagraphArrangementPoseValid | 配置空間内での、このパラグラフのポーズが、正常に計算されたかどうかを示します。
ParagraphIndex | ゼロベースのパラグラフインデックスです。これは、配置内のどのパラグラフが、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。
ParagraphSelectedPose | 選択空間内での、このパラグラフのポーズです。このプロパティは、ParagraphSelectedPoseValid が true の場合のみ有効であることに注意してください。
ParagraphSelectedPoseValid | 選択空間内での、このパラグラフのポーズが、正常に計算されたかどうかを示します。
VerificationFullViolations | 検証フル違反を示します。
VerificationKeyViolations | 検証キー違反を示します。
VerificationScore | パラグラフの総合得点です。これは、パラグラフ内にあるすべての文字の得点を平均した値です。
Verified | このパラグラフ内にあるすべての文字位置が検証されたかどうかを示します。

パブリックインスタンスメソッド

CreateResultGraphics このパラグラフ結果オブジェクトに関する、要求されたリザルトグラフィックスを含む、CogCompositeShape を作成します。

プロテクトインスタンスコンストラクタ

CogOCVMaxParagraphResult オーバロードされます。CogOCVMaxParagraphResult クラスの新しいインスタンスを初期化します。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult コンストラクタ

オーバロードリスト

指定された CogOCVMaxParagraphResult オブジェクトのディープコピーを構築します。

public CogOCVMaxParagraphResult(CogOCVMaxParagraphResult);

protected CogOCVMaxParagraphResult(SerializationInfo,StreamingContext);

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult コンストラクタ (SerializationInfo, StreamingContext)

protected CogOCVMaxParagraphResult(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxParagraphResult コンストラクタオーバロードリスト


CogOCVMaxParagraphResult コンストラクタ (CogOCVMaxParagraphResult)

指定された CogOCVMaxParagraphResult オブジェクトのディープコピーを構築します。

public CogOCVMaxParagraphResult(
CogOCVMaxParagraphResult pOther
);

パラメータ

pOther
コピーされる CogOCVMaxParagraphResult オブジェクト。NULL であってはなりません。

例外

例外タイプ | 条件
ArgumentNullException | 入力引数が NULL の場合。
OutOfMemoryException | このオブジェクトにメモリを割り当てることができない場合。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxParagraphResult コンストラクタオーバロードリスト


CogOCVMaxParagraphResult プロパティ

CogOCVMaxParagraphResult クラスのプロパティを次に示します。CogOCVMaxParagraphResult クラスメンバの完全なリストについては、「CogOCVMaxParagraphResult メンバ」を参照してください。

パブリックインスタンスプロパティ

LineResults | 行結果の System::Array です。このパラグラフ内の各行について 1 つ存在します。
NumLinesVerified | このパラグラフ内の、検証された行の数です。
ParagraphArrangementPose | 配置空間内での、このパラグラフのポーズです。このプロパティは、ParagraphArrangementPoseValid が true の場合のみ有効であることに注意してください。
ParagraphArrangementPoseValid | 配置空間内での、このパラグラフのポーズが、正常に計算されたかどうかを示します。
ParagraphIndex | ゼロベースのパラグラフインデックスです。これは、配置内のどのパラグラフが、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。
ParagraphSelectedPose | 選択空間内での、このパラグラフのポーズです。このプロパティは、ParagraphSelectedPoseValid が true の場合のみ有効であることに注意してください。
ParagraphSelectedPoseValid | 選択空間内での、このパラグラフのポーズが、正常に計算されたかどうかを示します。
VerificationFullViolations | 検証フル違反を示します。
VerificationKeyViolations | 検証キー違反を示します。
VerificationScore | パラグラフの総合得点です。これは、パラグラフ内にあるすべての文字の得点を平均した値です。
Verified | このパラグラフ内にあるすべての文字位置が検証されたかどうかを示します。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult.LineResults プロパティ

行結果の System::Array です。このパラグラフ内の各行について 1 つ存在します。

public CogOCVMaxLineResult[] LineResults {get;}

プロパティ値

この読み取り専用プロパティは、CogOCVMaxLineResult の System::Array タイプです。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult.NumLinesVerified プロパティ

このパラグラフ内の、検証された行の数です。

public int NumLinesVerified {get;}

プロパティ値

System::Int32 タイプの、この読み取り専用プロパティは、ゼロ以上になります。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult.ParagraphArrangementPose プロパティ

配置空間内での、このパラグラフのポーズです。このプロパティは、ParagraphArrangementPoseValid が true の場合のみ有効であることに注意してください。

public Cognex.VisionPro.CogTransform2DLinear ParagraphArrangementPose {get;}

プロパティ値

この読み取り専用プロパティは、CogTransform2DLinear タイプです。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult.ParagraphArrangementPoseValid プロパティ

配置空間内での、このパラグラフのポーズが、正常に計算されたかどうかを示します。

public bool ParagraphArrangementPoseValid {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult.ParagraphIndex プロパティ

ゼロベースのパラグラフインデックスです。これは、配置内のどのパラグラフが、この特定の結果を生成したかを示します。このインデックスは、この結果の生成時に存在していた配置を反映することに注意してください。その後配置が変更された場合、このインデックスは正当ではなくなっている可能性があります。

public int ParagraphIndex {get;}

プロパティ値

この読み取り専用プロパティは、System::Int32 タイプです。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult.ParagraphSelectedPose プロパティ

選択空間内での、このパラグラフのポーズです。このプロパティは、ParagraphSelectedPoseValid が true の場合のみ有効であることに注意してください。

public Cognex.VisionPro.CogTransform2DLinear ParagraphSelectedPose {get;}

プロパティ値

この読み取り専用プロパティは、CogTransform2DLinear タイプです。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult.ParagraphSelectedPoseValid プロパティ

選択空間内での、このパラグラフのポーズが、正常に計算されたかどうかを示します。

public bool ParagraphSelectedPoseValid {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult.VerificationFullViolations プロパティ

検証フル違反を示します。

public CogOCVMaxDOFConstants VerificationFullViolations {get;}

プロパティ値

この読み取り専用プロパティは、このパラグラフ内にあるすべての行内におけるすべての文字に関する、CogOCVMaxDOFConstants のビット単位の OR です。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult.VerificationKeyViolations プロパティ

検証キー違反を示します。

public CogOCVMaxDOFConstants VerificationKeyViolations {get;}

プロパティ値

この読み取り専用プロパティは、このパラグラフ内にあるすべての行内におけるすべての文字に関する、CogOCVMaxDOFConstants のビット単位の OR です。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult.VerificationScore プロパティ

パラグラフの総合得点です。これは、パラグラフ内にあるすべての文字の得点を平均した値です。

public double VerificationScore {get;}

プロパティ値

System::Double タイプの、この読み取り専用プロパティは、0 (最悪) ～ 1 (最良) の範囲になります。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult.Verified プロパティ

このパラグラフ内にあるすべての文字位置が検証されたかどうかを示します。

public bool Verified {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult メソッド

CogOCVMaxParagraphResult クラスのメソッドを次に示します。CogOCVMaxParagraphResult クラスメンバの完全なリストについては、「CogOCVMaxParagraphResult メンバ」を参照してください。

パブリックインスタンスメソッド

CreateResultGraphics このパラグラフ結果オブジェクトに関する、要求されたリザルトグラフィックスを含む、CogCompositeShape を作成します。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResult.CreateResultGraphics メソッド

このパラグラフ結果オブジェクトに関する、要求されたリザルトグラフィックスを含む、CogCompositeShape を作成します。

public CogCompositeShape CreateResultGraphics(
CogOCVMaxParagraphResultGraphicConstants graphicOptions
);

パラメータ

graphicOptions
CogOCVMaxParagraphResultGraphicConstants のビット単位の OR。オプションとしては、ParagraphBounds、CharactersBounds、CharactersLabel、および TipText があります。ParagraphBounds は、このパラグラフの周囲にパラグラフポーズアライメント境界ボックスを描画します。CharactersBounds は、各文字の周囲に文字ポーズアライメント境界ボックスを描画します。ParagraphBounds および CharactersBounds グラフィックスの両方は、verified は緑色、confused は黄色、failed は赤色に色分けされます。CharactersLabel は、各文字のグラフィックスバージョンを、検出された各文字の少し下に描画します。TipText は、マウスによってアクティブにされるヒントテキストが、要求された任意のグラフィックスについて得られるようにします。

戻り値

要求されたグラフィックスを含む CogCompositeShape。

例外

例外タイプ | 条件
InvalidOperationException | 内部共有結果フィールドが NULL の場合。

参照

CogOCVMaxParagraphResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxParagraphResultGraphicConstants 列挙体

CogOCVMaxParagraphResult::CreateResultGraphics() に対して、希望するリザルトグラフィックスを指定するために使用される定数です。

この列挙体は、メンバ値のビットごとの組み合わせを可能にする FlagsAttribute 属性を持っています。

public enum CogOCVMaxParagraphResultGraphicConstants

メンバ

メンバ名 | 説明 | 値
All | パラグラフリザルトグラフィックスのすべてを描画します。 | -1
TipText | このパラグラフにツールヒントのテキストを追加します。 | 1
CharactersLabel | 検出された各文字にラベル (例えば、A、B、C) を付けます。 | 8
CharactersBounds | このパラグラフ内で検出された各文字の周囲に外接アフィン矩形を描画します。 | 4
ParagraphBounds | パラグラフ全体の周囲に外接アフィン矩形を描画します。 | 2
None | このパラグラフについてのリザルトグラフィックスを何も描画しません。 | 0

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern クラス

このクラスは、Cognex.VisionPro.OCVMax アセンブリの主力となるものであり、実際の光学文字検証を実行します。このクラスには、登録パラメータと登録状態情報が含まれます。このクラスまたは CogOCVMaxTool ツールを使用すると、文字検証を実行することができます。

登録が必要なほかのビジョンツールとは異なり、OCVMax では、登録画像も登録領域も使用されません。このクラスの登録は、CogOCVMaxFont によって、人工的に生成された画像に基づきます。

このタイプのメンバすべてのリストについては、「CogOCVMaxPattern メンバ」を参照してください。

System.Object
MarshalByRefObject
CogObjectBase
CogSerializableObjectBase
CogSerializableChangedEventBase
CogOCVMaxPattern

public class CogOCVMaxPattern :CogSerializableChangedEventBase, IDisposable, IDeserializationCallback

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxPattern メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern メンバ

CogOCVMaxPattern の概要

パブリックスタティックフィールド

SfCharacterRegistration
SfCreateCharacterIterator
SfCreateLineIterator
SfCreateParagraphIterator
SfCustomization
SfExpectedDeformationRate
SfGetCharacterCount
SfGetLineCount
SfGetParagraphCount
SfGetTunedRunParams
SfOrigin
SfScoreMode
SfTrained
SfTrainTimeout
SfTrainTimeoutEnabled
SfTrainTransform
SfTuned
SfTunedRunTimeout
SfTuneImage
SfTuneRegion
SfTuneResult
SfTuneRunParams

プロテクトスタティックフィールド

SfNextSf

パブリックインスタンスコンストラクタ

CogOCVMaxPattern オーバロードされます。CogOCVMaxPattern クラスの新しいインスタンスを初期化します。

パブリックインスタンスプロパティ

CharacterRegistration | 検出された各文字に対して実行されるレジストレーション (フィット処理) のタイプを取得または設定します。
ExpectedDeformationRate | レジストレーションのために使用される非線形フィットの、予想される変位レートを取得または設定します。
Origin | 配置の原点を取得または設定します。
ScoreMode | 各文字の得点を計算するために使用されるモードを取得または設定します。
Trained | このパターンが登録されたかどうかを取得します。
TrainTimeout | TrainTimeoutEnabled が true の場合、このプロパティは、TrainTimeoutEnabled で実行可能な最大限の時間 (ミリ秒単位) です。
TrainTimeoutEnabled | 登録中に、パターンがタイムアウトできるかどうかを取得または設定します。
TrainTransform | 人工的に生成された登録画像からのマッピングを指定する変換を、取得または設定します。
Tuned | パターンがチューニングされた場合は true になります。
TunedRunTimeout | 最後に行われた Tune の呼び出し中に生成された、実行タイムアウト値 (ミリ秒単位) を取得します。
TuneImage | チューニング中に使用される画像を取得します。
TuneRegion | TuneImage のどの部分がチューニング中に使用されるかを指定する、オプションの領域を取得または設定します。このプロパティが NULL の場合は、TuneImage 全体が使用されます。
TuneResult | 最後に行われた Tune の呼び出し中に生成された、最終 CogOCVMaxResult を取得します。
TuneRunParams | チューニングのために使用される実行パラメータを取得または設定します。

パブリックインスタンスメソッド

AddText | オーバロードされます。指定された文字繰り返し指定子によって指定された文字位置に、1 つ以上の文字を挿入します。
CreateCharacterIterator | オーバロードされます。指定されたパラグラフ内、指定された行内の、最初の文字位置に対応する、文字繰り返し指定子を作成します。
CreateLineIterator | オーバロードされます。配置に関して、指定されたパラグラフ内の、最初の行位置に対応する、行繰り返し指定子を作成します。
CreateParagraphIterator | オーバロードされます。配置内の、最初のパラグラフに対応する、パラグラフ繰り返し指定子を作成します。
Dispose | オーバロードされます。
Execute | 指定された実行パラメータを使用して、指定された画像に対して検査を実行します。
GetCharacterCount | 行内の文字の数を取得します。
GetCustomization | 指定されたタイプのカスタマイズ文字列を取得します。
GetLineCount | パラグラフ内の行の数を取得します。
GetParagraphCount | 配置内のパラグラフの数を取得します。
GetTunedRunParams | チューニングされた実行パラメータを取得します。
OnDeserialization |
RemoveCharacter | 指定された文字繰り返し指定子によって指定される文字を、配置から削除します。
RemoveLine | 指定された行繰り返し指定子によって指定される行を、配置から削除します。
RemoveParagraph | パラグラフ繰り返し指定子によって指定されるパラグラフを、配置から削除します。
RenderImage | 配置全体のグラフィカル描画を含む画像を作成します。
SetCustomization | 指定されたカスタマイズタイプのための、カスタマイズ文字列を設定します。
SetCustomizationFromFile | 指定されたカスタマイズタイプのための、カスタマイズ文字列を、指定されたファイルから設定します。
Train | 現在の配置を登録します。
TrainProgressReport |
Tune | オーバロードされます。指定された、ゼロベースのパラグラフインデックスの配列リストによって指定されるパラグラフのみをチューニングします。
TuneProgressReport |
Untrain | 登録されているデータがあれば、すべて破棄します。

パブリックインスタンスイベント

CharacterAdded
CharacterChanged
CharacterRemoved
LineAdded
LineChanged
LineRemoved
ParagraphAdded
ParagraphChanged
ParagraphRemoved
TrainProgress
TuneProgress

プロテクトインスタンスコンストラクタ

CogOCVMaxPattern オーバロードされます。CogOCVMaxPattern クラスの新しいインスタンスを初期化します。

プロテクトインスタンスメソッド

__dtor |
Dispose | オーバロードされます。
Finalize |
GetObjectData |
OnCharacterAdded |
OnCharacterChanged |
OnCharacterRemoved |
OnLineAdded |
OnLineChanged |
OnLineRemoved |
OnParagraphAdded |
OnParagraphChanged |
OnParagraphRemoved |
OnTrainProgress |
OnTuneProgress |

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern コンストラクタ

オーバロードリスト

CogOCVMaxPattern クラスの新しいインスタンスを初期化します。

public CogOCVMaxPattern();

public CogOCVMaxPattern(CogOCVMaxPattern);

protected CogOCVMaxPattern(SerializationInfo,StreamingContext);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern コンストラクタ (SerializationInfo, StreamingContext)

protected CogOCVMaxPattern(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern コンストラクタオーバロードリスト


CogOCVMaxPattern コンストラクタ (CogOCVMaxPattern)

public CogOCVMaxPattern(
CogOCVMaxPattern pOther
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern コンストラクタオーバロードリスト


CogOCVMaxPattern コンストラクタ ()

CogOCVMaxPattern クラスの新しいインスタンスを初期化します。

public CogOCVMaxPattern();

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern コンストラクタオーバロードリスト


CogOCVMaxPattern フィールド

CogOCVMaxPattern クラスのフィールドを次に示します。CogOCVMaxPattern クラスメンバの完全なリストについては、「CogOCVMaxPattern メンバ」を参照してください。

パブリックスタティックフィールド

SfCharacterRegistration
SfCreateCharacterIterator
SfCreateLineIterator
SfCreateParagraphIterator
SfCustomization
SfExpectedDeformationRate
SfGetCharacterCount
SfGetLineCount
SfGetParagraphCount
SfGetTunedRunParams
SfOrigin
SfScoreMode
SfTrained
SfTrainTimeout
SfTrainTimeoutEnabled
SfTrainTransform
SfTuned
SfTunedRunTimeout
SfTuneImage
SfTuneRegion
SfTuneResult
SfTuneRunParams

プロテクトスタティックフィールド

SfNextSf

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfCharacterRegistration フィールド

public const long SfCharacterRegistration;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfCreateCharacterIterator フィールド

public const long SfCreateCharacterIterator;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfCreateLineIterator フィールド

public const long SfCreateLineIterator;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfCreateParagraphIterator フィールド

public const long SfCreateParagraphIterator;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfCustomization フィールド

public const long SfCustomization;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfExpectedDeformationRate フィールド

public const long SfExpectedDeformationRate;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfGetCharacterCount フィールド

public const long SfGetCharacterCount;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfGetLineCount フィールド

public const long SfGetLineCount;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfGetParagraphCount フィールド

public const long SfGetParagraphCount;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfGetTunedRunParams フィールド

public const long SfGetTunedRunParams;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfNextSf フィールド

new protected const long SfNextSf;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfOrigin フィールド

public const long SfOrigin;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfScoreMode フィールド

public const long SfScoreMode;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfTrained フィールド

public const long SfTrained;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfTrainTimeout フィールド

public const long SfTrainTimeout;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfTrainTimeoutEnabled フィールド

public const long SfTrainTimeoutEnabled;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfTrainTransform フィールド

public const long SfTrainTransform;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfTuned フィールド

public const long SfTuned;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfTunedRunTimeout フィールド

public const long SfTunedRunTimeout;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfTuneImage フィールド

public const long SfTuneImage;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfTuneRegion フィールド

public const long SfTuneRegion;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfTuneResult フィールド

public const long SfTuneResult;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SfTuneRunParams フィールド

public const long SfTuneRunParams;

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern プロパティ

CogOCVMaxPattern クラスのプロパティを次に示します。CogOCVMaxPattern クラスメンバの完全なリストについては、「CogOCVMaxPattern メンバ」を参照してください。

パブリックインスタンスプロパティ

CharacterRegistration | 検出された各文字に対して実行されるレジストレーション (フィット処理) のタイプを取得または設定します。
ExpectedDeformationRate | レジストレーションのために使用される非線形フィットの、予想される変位レートを取得または設定します。
Origin | 配置の原点を取得または設定します。
ScoreMode | 各文字の得点を計算するために使用されるモードを取得または設定します。
Trained | このパターンが登録されたかどうかを取得します。
TrainTimeout | TrainTimeoutEnabled が true の場合、このプロパティは、TrainTimeoutEnabled で実行可能な最大限の時間 (ミリ秒単位) です。
TrainTimeoutEnabled | パターン登録中に、タイムアウトさせるかどうかを取得または設定します。
TrainTransform | 人工的に生成された登録画像からのマッピングを指定する変換を、取得または設定します。
Tuned | パターンがチューニングされた場合は true になります。
TunedRunTimeout | 最後に行われた Tune の呼び出し中に生成された、実行タイムアウト値 (ミリ秒単位) を取得します。
TuneImage | チューニング中に使用される画像を取得します。
TuneRegion | TuneImage のどの部分がチューニング中に使用されるかを指定する、オプションの領域を取得または設定します。このプロパティが NULL の場合は、TuneImage 全体が使用されます。
TuneResult | 最後に行われた Tune の呼び出し中に生成された、最終 CogOCVMaxResult を取得します。
TuneRunParams | チューニングのために使用される実行パラメータを取得または設定します。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.CharacterRegistration プロパティ

検出された各文字に対して実行されるレジストレーション (フィット処理) のタイプを取得または設定します。

public CogOCVMaxCharacterRegistrationConstants CharacterRegistration {get; set;}

プロパティ値

検出された各文字に対して実行されるレジストレーション (フィット処理) のタイプ。

解説

レジストレーションタイプが Standard の場合、レジストレーションは、5 つの自由度 (アフィンのみ、スキューなし) を使用して実行されます。このレジストレーションタイプの実行には、最も短い時間を要します。

レジストレーションタイプが Bent の場合、レジストレーションはアフィン変換を使用して実行され、次に、実行時最適化値によって設定された限界まで、少量のワーピングをモデル化するために、さらに最適化されます。

レジストレーションタイプが Nonlinear の場合、レジストレーションは、実行時文字の大幅な変位をモデル化することが可能な、非線形変換を使用して実行されます。このレジストレーションタイプの実行には、最も長い時間を要します。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.ExpectedDeformationRate プロパティ

レジストレーションのために使用される非線形フィットの、予想される変位レートを取得または設定します。

public double ExpectedDeformationRate {get; set;}

プロパティ値

レジストレーションのために使用される非線形フィットの、予想される変位レート。

解説

大きな値によって、各文字内のより大きな変位がモデル化されますが、その結果、文字間の紛らわしさが増加し、実行時間も長くなります。値 0 でも、ある程度の変位は許容されます。

CharacterRegistration が Nonlinear の場合、このプロパティは効果を持ちません。

人工的に生成された登録画像内で文字が小さい場合、または文字の構造が非常に単純な場合、このプロパティは、ほとんど、またはまったく効果を持たない可能性があります。大きな漢字の文字については、変位レートの増加による利点が得られる可能性がありますが、文字「I」については、利点が得られることはおそらくありません。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | このプロパティを 0 未満または 1 より大きな値に設定しようとした場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.Origin プロパティ

配置の原点を取得または設定します。

public Cognex.VisionPro.CogTransform2DLinear Origin {get; set;}

プロパティ値

配置の原点。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentNullException | このプロパティを NULL 値に設定しようとした場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.ScoreMode プロパティ

各文字の得点を計算するために使用されるモードを取得または設定します。

public CogOCVMaxScoreModeConstants ScoreMode {get; set;}

プロパティ値

各文字の得点を計算するために使用されるモード。

解説

モードが ScoreUsingClutter の場合、余分な特徴 (クラッタ) が存在すると、得点は低下します。

モードが ScoreUsingOptimizedClutter の場合、余分な特徴が存在すると得点は低下しますが、比較的低いコントラストのクラッタに対しては得点が最適化されます。

モードが ScoreWithoutClutter の場合、得点は予想される特徴の存在のみに基づき、余分な特徴 (クラッタ) はすべて無視されます。

より信頼性の高いコンフュージョンの計算を可能にするために通常望ましいモードは、ScoreUsingClutter です。ただし、ノイズが多い画像では、ScoreWithoutClutter が必要な場合もあります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.Trained プロパティ

このパターンが登録されたかどうかを取得します。

public bool Trained {get;}

プロパティ値

パターンが登録された場合は true。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.TrainTimeout プロパティ

TrainTimeoutEnabled が true の場合、このプロパティは、TrainTimeoutEnabled で実行可能な最大限の時間 (ミリ秒単位) です。

public double TrainTimeout {get; set;}

プロパティ値

パターンを登録するための最大限の時間 (ミリ秒単位)

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | タイムアウト値がゼロ以下の場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.TrainTimeoutEnabled プロパティ

登録中に、パターンがタイムアウトさせるかどうかを取得または設定します。

public bool TrainTimeoutEnabled {get; set;}

プロパティ値

登録中に、パターンがタイムアウトさせる場合は true。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.TrainTransform プロパティ

人工的に生成された登録画像からのマッピングを指定する変換を、取得または設定します。

public Cognex.VisionPro.CogTransform2DLinear TrainTransform {get; set;}

プロパティ値

人工的に生成された登録画像からのマッピングを指定する変換。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | このプロパティを NULL 値に設定しようとした場合。
ObjectDisposedException | このオブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.Tuned プロパティ

パターンがチューニングされた場合は true になります。

public bool Tuned {get;}

プロパティ値

パターンがチューニングされた場合は true。

解説

これは、NULL 以外の TuneResult が存在するかどうかを示すコンビニエンスプロパティです。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.TunedRunTimeout プロパティ

最後に行われた Tune の呼び出し中に生成された、実行タイムアウト値 (ミリ秒単位) を取得します。

public double TunedRunTimeout {get;}

プロパティ値

最後に行われた Tune の呼び出し中に生成された、実行タイムアウト値 (ミリ秒単位)。

解説

Tune が呼び出されていない場合、このプロパティの値は、デフォルトの実行タイムアウトになります。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.TuneImage プロパティ

チューニング中に使用される画像を取得します。

public Cognex.VisionPro.CogImage8Grey TuneImage {get; set;}

プロパティ値

チューニング中に使用される画像。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.TuneRegion プロパティ

TuneImage のどの部分がチューニング中に使用されるかを指定する、オプションの領域を取得または設定します。このプロパティが NULL の場合は、TuneImage 全体が使用されます。

public Cognex.VisionPro.ICogRegion TuneRegion {get; set;}

プロパティ値

TuneImage のどの部分がチューニング中に使用されるかを指定する、オプションの領域。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.TuneResult プロパティ

最後に行われた Tune の呼び出し中に生成された、最終 CogOCVMaxResult を取得します。

public CogOCVMaxResult TuneResult {get;}

プロパティ値

最後に行われた Tune の呼び出し中に生成された、最終 CogOCVMaxResult。

解説

Tune が呼び出されていない場合、このプロパティの値は NULL になります。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.TuneRunParams プロパティ

チューニングのために使用される実行パラメータを取得または設定します。

public CogOCVMaxRunParams TuneRunParams {get; set;}

プロパティ値

チューニングのために使用される実行パラメータ。

解説

チューニングは、パターンの調整、登録、および実行の反復処理です。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern メソッド

CogOCVMaxPattern クラスのメソッドを次に示します。CogOCVMaxPattern クラスメンバの完全なリストについては、「CogOCVMaxPattern メンバ」を参照してください。

パブリックインスタンスメソッド

AddText | オーバロードされます。指定された文字繰り返し指定子によって指定された文字位置に、1 つ以上の文字を挿入します。
CreateCharacterIterator | オーバロードされます。指定されたパラグラフ内、指定された行内の、最初の文字位置に対応する、文字繰り返し指定子を作成します。
CreateLineIterator | オーバロードされます。配置に関して、指定されたパラグラフ内の、最初の行位置に対応する、行繰り返し指定子を作成します。
CreateParagraphIterator | オーバロードされます。配置内の、最初のパラグラフに対応する、パラグラフ繰り返し指定子を作成します。
Dispose | オーバロードされます。
Execute | 指定された実行パラメータを使用して、指定された画像に対して検査を実行します。
GetCharacterCount | 行内の文字の数を取得します。
GetCustomization | 指定されたタイプのカスタマイズ文字列を取得します。
GetLineCount | パラグラフ内の行の数を取得します。
GetParagraphCount | 配置内のパラグラフの数を取得します。
GetTunedRunParams | チューニングされた実行パラメータを取得します。
OnDeserialization |
RemoveCharacter | 指定された文字繰り返し指定子によって指定される文字を、配置から削除します。
RemoveLine | 指定された行繰り返し指定子によって指定される行を、配置から削除します。
RemoveParagraph | パラグラフ繰り返し指定子によって指定されるパラグラフを、配置から削除します。
RenderImage | 配置全体のグラフィカル描画を含む画像を作成します。
SetCustomization | 指定されたカスタマイズタイプのための、カスタマイズ文字列を設定します。
SetCustomizationFromFile | 指定されたカスタマイズタイプのための、カスタマイズ文字列を、指定されたファイルから設定します。
Train | 現在の配置を登録します。
TrainProgressReport |
Tune | オーバロードされます。指定された、ゼロベースのパラグラフインデックスの配列リストによって指定されるパラグラフのみをチューニングします。
TuneProgressReport |
Untrain | 登録されているデータがあれば、すべて破棄します。

プロテクトインスタンスメソッド

__dtor |
Dispose | オーバロードされます。
Finalize |
GetObjectData |
OnCharacterAdded |
OnCharacterChanged |
OnCharacterRemoved |
OnLineAdded |
OnLineChanged |
OnLineRemoved |
OnParagraphAdded |
OnParagraphChanged |
OnParagraphRemoved |
OnTrainProgress |
OnTuneProgress |

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.__dtor メソッド

protected void __dtor();

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


AddText メソッド

VisionPro プログラミングリファレンス

CogOCVMaxPattern.AddText メソッド

新しいパラグラフを作成して、現在の配置の最後に追加します。

オーバロードリスト

新しいパラグラフを作成して、現在の配置の最後に追加します。

public void AddText(int[]);

指定された文字繰り返し指定子によって指定された文字位置に、1 つ以上の文字を挿入します。

public void AddText(int[],CogOCVMaxCharacterIterator);

新しい行を作成して、行繰り返し指定子によって指定された行位置に挿入します。

public void AddText(int[],CogOCVMaxLineIterator);

新しいパラグラフを作成して、配置内の、パラグラフ繰り返し指定子によって指定された位置に挿入します。

public void AddText(int[],CogOCVMaxParagraphIterator);

新しいパラグラフを作成して、現在の配置の最後に追加します。

public void AddText(string);

文字繰り返し指定子によって指定された文字位置に、1 つ以上の文字を挿入します。

public void AddText(string,CogOCVMaxCharacterIterator);

新しい行を作成して、行繰り返し指定子によって指定された行位置に挿入します。

public void AddText(string,CogOCVMaxLineIterator);

新しいパラグラフを作成して、配置内の、パラグラフ繰り返し指定子によって指定された位置に挿入します。

public void AddText(string,CogOCVMaxParagraphIterator);

新しいパラグラフを作成して、現在の配置の最後に追加します。

public void AddText(string[]);

1 つ以上の新しい行を作成して、行繰り返し指定子によって指定された行位置に挿入します。

public void AddText(string[],CogOCVMaxLineIterator);

新しいパラグラフを作成して、配置内の、パラグラフ繰り返し指定子によって指定された位置に挿入します。

public void AddText(string[],CogOCVMaxParagraphIterator);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.AddText メソッド (Int32[])

新しいパラグラフを作成して、現在の配置の最後に追加します。

public void AddText(
int[] srcText
);

パラメータ

srcText
System::Int32 の System::Array。NULL であってはなりません。この配列内の各要素は、配置に追加される新しいパラグラフの 1 つの行を構成するテキストの文字のキー値です。

解説

この新しいパラグラフは、srcText 整数配列によってキー値が指定される文字から構成される 1 つの行を持ちます。空の入力整数配列は、空白行と解釈されます。

イベント

イベントタイプ | 理由
ParagraphAdded | パターンオブジェクトにパラグラフが追加された場合に発生します。
Changed | パターンオブジェクトが変更された場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentNullException | srcText 引数が NULL の場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.AddText オーバロードリスト


CogOCVMaxPattern.AddText メソッド (Int32[], CogOCVMaxCharacterIterator)

指定された文字繰り返し指定子によって指定された文字位置に、1 つ以上の文字を挿入します。

public void AddText(
int[] srcText,
CogOCVMaxCharacterIterator pNext
);

パラメータ

srcText
System::Int32 の System::Array。NULL であってはなりません。この配列内の各要素は、挿入されるテキストの文字のキー値です。
pNext
新しい文字が挿入される文字位置を指定する CogOCVMaxCharacterIterator。NULL であってはなりません。

解説

文字は、入力整数配列によって指定されるキー値を持ちます。

イベント

イベントタイプ | 理由
Changed | パターンオブジェクトが変更された場合に発生します。
CharacterAdded | パターンオブジェクトに文字が追加された場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 文字繰り返し指定子が、正当な位置を指定していない場合。
ArgumentException | 指定された文字繰り返し指定子が、この CogOCVMaxPattern オブジェクトを参照していない場合。
ArgumentNullException | srcText 引数が NULL の場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.AddText オーバロードリスト


CogOCVMaxPattern.AddText メソッド (Int32[], CogOCVMaxLineIterator)

新しい行を作成して、行繰り返し指定子によって指定された行位置に挿入します。

public void AddText(
int[] srcText,
CogOCVMaxLineIterator pNext
);

パラメータ

srcText
System::Int32 の System::Array。NULL であってはなりません。この配列内の各要素は、挿入される 1 つの行を構成するテキストの文字のキー値です。
pNext
新しい行が挿入される行位置を指定する CogOCVMaxLineIterator。NULL であってはなりません。

解説

この新しい行は、配列によってキー値が指定される文字を含みます。空の入力整数配列は、空白行と解釈されます。

イベント

イベントタイプ | 理由
Changed | パターンオブジェクトが変更された場合に発生します。
LineAdded | パターンオブジェクトに行が追加された場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentNullException | pNext 引数が NULL の場合。
InvalidOperationException | 行繰り返し指定子が、正当な位置を指定していない場合。
ArgumentException | 指定された行繰り返し指定子が、この CogOCVMaxPattern オブジェクトを参照していない場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.AddText オーバロードリスト


CogOCVMaxPattern.AddText メソッド (Int32[], CogOCVMaxParagraphIterator)

新しいパラグラフを作成して、配置内の、パラグラフ繰り返し指定子によって指定された位置に挿入します。

public void AddText(
int[] srcText,
CogOCVMaxParagraphIterator pNext
);

パラメータ

srcText
System::Int32 の System::Array。NULL であってはなりません。この配列内の各要素は、配置に追加される新しいパラグラフの 1 つの行を構成するテキストの文字のキー値です。
pNext
現在の配置内の新しいパラグラフが挿入される位置を指定する CogOCVMaxParagraphIterator。NULL であってはなりません。

解説

この新しいパラグラフは、入力整数配列によってキー値が指定される文字から構成される 1 つの行を持ちます。空の入力整数配列は、空白行と解釈されます。

イベント

イベントタイプ | 理由
Changed | パターンオブジェクトが変更された場合に発生します。
ParagraphAdded | パターンオブジェクトにパラグラフが追加された場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | srcText 引数が NULL の場合。
InvalidOperationException | パラグラフ繰り返し指定子が、正当な位置を指定していない場合。
ArgumentException | 指定されたパラグラフ繰り返し指定子が、この CogOCVMaxPattern オブジェクトを参照していない場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.AddText オーバロードリスト


CogOCVMaxPattern.AddText メソッド (String)

新しいパラグラフを作成して、現在の配置の最後に追加します。

public void AddText(
string srcText
);

パラメータ

srcText
新しいパラグラフの 1 つの行に対応する 1 つの文字列。NULL であってはなりません。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。

解説

この新しいパラグラフは、srcText によって指定される 1 つの行を持ちます。空の文字列 (長さ 0) は、空白行と解釈されます。

イベント

イベントタイプ | 理由
ParagraphAdded | パターンオブジェクトにパラグラフが追加された場合に発生します。
Changed | パターンオブジェクトが変更された場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentNullException | srcText 引数が NULL の場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.AddText オーバロードリスト


CogOCVMaxPattern.AddText メソッド (String, CogOCVMaxCharacterIterator)

文字繰り返し指定子によって指定された文字位置に、1 つ以上の文字を挿入します。

public void AddText(
string srcText,
CogOCVMaxCharacterIterator pNext
);

パラメータ

srcText
挿入される文字を含む文字列。NULL であってはなりません。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。
pNext
新しい文字が挿入される文字位置を指定する CogOCVMaxCharacterIterator。NULL であってはなりません。

イベント

イベントタイプ | 理由
CharacterAdded | パターンオブジェクトに文字が追加された場合に発生します。
Changed | パターンオブジェクトが変更された場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | 文字繰り返し指定子が、正当な位置を指定していない場合。
ArgumentException | 指定された文字繰り返し指定子が、この CogOCVMaxPattern オブジェクトを参照していない場合。
ArgumentNullException | srcText 引数が NULL の場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.AddText オーバロードリスト


CogOCVMaxPattern.AddText メソッド (String, CogOCVMaxLineIterator)

新しい行を作成して、行繰り返し指定子によって指定された行位置に挿入します。

public void AddText(
string srcText,
CogOCVMaxLineIterator pNext
);

パラメータ

srcText
挿入される 1 つの行に対応する 1 つの文字列。NULL であってはなりません。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。
pNext
新しい行が挿入される行位置を指定する CogOCVMaxLineIterator。NULL であってはなりません。

解説

この新しい行は、srcText によって指定される文字を含みます。空の文字列 (長さ 0) は、空白行と解釈されます。

イベント

イベントタイプ | 理由
Changed | パターンオブジェクトが変更された場合に発生します。
LineAdded | パターンオブジェクトに行が追加された場合に発生します。

例外

例外タイプ | 条件
ArgumentException | 指定された行繰り返し指定子が、この CogOCVMaxPattern オブジェクトを参照していない場合。
ArgumentNullException | srcText 引数が NULL の場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 行繰り返し指定子が、正当な位置を指定していない場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.AddText オーバロードリスト


CogOCVMaxPattern.AddText メソッド (String, CogOCVMaxParagraphIterator)

新しいパラグラフを作成して、配置内の、パラグラフ繰り返し指定子によって指定された位置に挿入します。

public void AddText(
string srcText,
CogOCVMaxParagraphIterator pNext
);

パラメータ

srcText
新しいパラグラフの 1 つの行に対応する 1 つの文字列。NULL であってはなりません。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。
pNext
現在の配置内の新しいパラグラフが挿入される位置を指定する CogOCVMaxParagraphIterator。NULL であってはなりません。

解説

この新しいパラグラフは、srcText によって指定される 1 つの行を持ちます。空の文字列 (長さ 0) は、空白行と解釈されます。

イベント

イベントタイプ | 理由
ParagraphAdded | パターンオブジェクトにパラグラフが追加された場合に発生します。
Changed | パターンオブジェクトが変更された場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | パラグラフ繰り返し指定子が、正当な位置を指定していない場合。
ArgumentNullException | pNext 引数が NULL の場合。
ArgumentException | 指定されたパラグラフ繰り返し指定子が、この CogOCVMaxPattern オブジェクトを参照していない場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.AddText オーバロードリスト


CogOCVMaxPattern.AddText メソッド (String[])

新しいパラグラフを作成して、現在の配置の最後に追加します。

public void AddText(
string[] srcText
);

パラメータ

srcText
文字列の配列。各文字列は、新しいパラグラフの行に対応しています。NULL であってはなりません。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。

解説

指定された文字列配列内の各文字列は、新しいパラグラフの個別の行に対応しています。空の文字列 (長さ 0) は、空白行と解釈されます。

イベント

イベントタイプ | 理由
Changed | パターンオブジェクトが変更された場合に発生します。
ParagraphAdded | パターンオブジェクトにパラグラフが追加された場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentNullException | srcText 引数が NULL の場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.AddText オーバロードリスト


CogOCVMaxPattern.AddText メソッド (String[], CogOCVMaxLineIterator)

1 つ以上の新しい行を作成して、行繰り返し指定子によって指定された行位置に挿入します。

public void AddText(
string[] srcText,
CogOCVMaxLineIterator pNext
);

パラメータ

srcText
文字列の配列。各文字列は、テキストの行に対応しています。NULL であってはなりません。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。
pNext
新しい行が挿入される行位置を指定する CogOCVMaxLineIterator。NULL であってはなりません。

解説

srcText 配列内の各文字列は、個別の行に対応しています。空の文字列 (長さ 0) は、空白行と解釈されます。

イベント

イベントタイプ | 理由
Changed | パターンオブジェクトが変更された場合に発生します。
LineAdded | パターンオブジェクトに行が追加された場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | pNext 引数が NULL の場合。
ArgumentException | 指定された行繰り返し指定子が、この CogOCVMaxPattern オブジェクトを参照していない場合。
InvalidOperationException | 行繰り返し指定子が、正当な位置を指定していない場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.AddText オーバロードリスト


CogOCVMaxPattern.AddText メソッド (String[], CogOCVMaxParagraphIterator)

新しいパラグラフを作成して、配置内の、パラグラフ繰り返し指定子によって指定された位置に挿入します。

public void AddText(
string[] srcText,
CogOCVMaxParagraphIterator pNext
);

パラメータ

srcText
文字列の配列。各文字列は、新しいパラグラフの行に対応しています。NULL であってはなりません。関連するフォントの文字キーは、Unicode のコードポイント値に対応することが前提になっています。
pNext
現在の配置内の新しいパラグラフが挿入される位置を指定する CogOCVMaxParagraphIterator。NULL であってはなりません。

解説

srcText 文字列配列内の各文字列は、この新しいパラグラフの個別の行に対応しています。空の文字列 (長さ 0) は、空白行と解釈されます。

イベント

イベントタイプ | 理由
ParagraphAdded | パターンオブジェクトにパラグラフが追加された場合に発生します。
Changed | パターンオブジェクトが変更された場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentNullException | pNext 引数が NULL の場合。
ArgumentException | 指定されたパラグラフ繰り返し指定子が、この CogOCVMaxPattern オブジェクトを参照していない場合。
InvalidOperationException | パラグラフ繰り返し指定子が、正当な位置を指定していない場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.AddText オーバロードリスト


CreateCharacterIterator メソッド

VisionPro プログラミングリファレンス

CogOCVMaxPattern.CreateCharacterIterator メソッド

指定されたパラグラフ内、指定された行内の、最初の文字位置に対応する、文字繰り返し指定子を作成します。

オーバロードリスト

指定されたパラグラフ内、指定された行内の、最初の文字位置に対応する、文字繰り返し指定子を作成します。

public CogOCVMaxCharacterIterator CreateCharacterIterator(int,int);

配置に関して、指定されたパラグラフ内、指定された行内の、指定された文字に対応する、文字繰り返し指定子を作成します。

public CogOCVMaxCharacterIterator CreateCharacterIterator(int,int,int);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.CreateCharacterIterator メソッド (Int32, Int32)

指定されたパラグラフ内、指定された行内の、最初の文字位置に対応する、文字繰り返し指定子を作成します。

public CogOCVMaxCharacterIterator CreateCharacterIterator(
int paragraphPosition,
int linePosition
);

パラメータ

paragraphPosition
パラグラフを指定する、ゼロベースのインデックス。
linePosition
行を指定する、ゼロベースのインデックス。

戻り値

指定された文字に対応する文字繰り返し指定子。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.CreateCharacterIterator オーバロードリスト


CogOCVMaxPattern.CreateCharacterIterator メソッド (Int32, Int32, Int32)

配置に関して、指定されたパラグラフ内、指定された行内の、指定された文字に対応する、文字繰り返し指定子を作成します。

public CogOCVMaxCharacterIterator CreateCharacterIterator(
int paragraphPosition,
int linePosition,
int characterPosition
);

パラメータ

paragraphPosition
パラグラフを指定する、ゼロベースのインデックス。
linePosition
行を指定する、ゼロベースのインデックス。
characterPosition
文字を指定する、ゼロベースのインデックス。-1 は特別な値で、行の最後を意味すると解釈されます。

戻り値

指定された文字に対応する文字繰り返し指定子。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | 指定された characterPosition 引数が、正当な文字位置を参照していない場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.CreateCharacterIterator オーバロードリスト


CreateLineIterator メソッド

VisionPro プログラミングリファレンス

CogOCVMaxPattern.CreateLineIterator メソッド

配置に関して、指定されたパラグラフ内の、最初の行位置に対応する、行繰り返し指定子を作成します。

オーバロードリスト

配置に関して、指定されたパラグラフ内の、最初の行位置に対応する、行繰り返し指定子を作成します。

public CogOCVMaxLineIterator CreateLineIterator(int);

配置に関して、指定されたパラグラフ内の、指定された行に対応する、行繰り返し指定子を作成します。

public CogOCVMaxLineIterator CreateLineIterator(int,int);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.CreateLineIterator メソッド (Int32)

配置に関して、指定されたパラグラフ内の、最初の行位置に対応する、行繰り返し指定子を作成します。

public CogOCVMaxLineIterator CreateLineIterator(
int paragraphPosition
);

パラメータ

paragraphPosition
パラグラフを指定する、ゼロベースのインデックス。

戻り値

指定された行に対応する行繰り返し指定子。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.CreateLineIterator オーバロードリスト


CogOCVMaxPattern.CreateLineIterator メソッド (Int32, Int32)

配置に関して、指定されたパラグラフ内の、指定された行に対応する、行繰り返し指定子を作成します。

public CogOCVMaxLineIterator CreateLineIterator(
int paragraphPosition,
int linePosition
);

パラメータ

paragraphPosition
パラグラフを指定する、ゼロベースのインデックス。
linePosition
行を指定する、ゼロベースのインデックス。-1 は特別な値で、パラグラフの最後を意味すると解釈されます。

戻り値

指定された行に対応する行繰り返し指定子。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | 指定された linePosition 引数が、正当な行位置を参照していない場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.CreateLineIterator オーバロードリスト


CreateParagraphIterator メソッド

VisionPro プログラミングリファレンス

CogOCVMaxPattern.CreateParagraphIterator メソッド

配置内の、最初のパラグラフに対応する、パラグラフ繰り返し指定子を作成します。

オーバロードリスト

配置内の、最初のパラグラフに対応する、パラグラフ繰り返し指定子を作成します。

public CogOCVMaxParagraphIterator CreateParagraphIterator();

配置に関して、指定されたパラグラフに対応する、パラグラフ繰り返し指定子を作成します。

public CogOCVMaxParagraphIterator CreateParagraphIterator(int);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.CreateParagraphIterator メソッド ()

配置内の、最初のパラグラフに対応する、パラグラフ繰り返し指定子を作成します。

public CogOCVMaxParagraphIterator CreateParagraphIterator();

戻り値

最初のパラグラフに対応するパラグラフ繰り返し指定子。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.CreateParagraphIterator オーバロードリスト


CogOCVMaxPattern.CreateParagraphIterator メソッド (Int32)

配置に関して、指定されたパラグラフに対応する、パラグラフ繰り返し指定子を作成します。

public CogOCVMaxParagraphIterator CreateParagraphIterator(
int paragraphPosition
);

パラメータ

paragraphPosition
System::Int32。パラグラフを指定する、ゼロベースのインデックスです。-1 は特別な値で、「この配置の最後」を意味すると解釈されます。

戻り値

指定されたパラグラフに対応するパラグラフ繰り返し指定子。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | 指定された paragraphPosition 引数が、正当なパラグラフ位置を参照していない場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.CreateParagraphIterator オーバロードリスト


Dispose メソッド

VisionPro プログラミングリファレンス

CogOCVMaxPattern.Dispose メソッド

オーバロードリスト

public override void Dispose();

protected virtual void Dispose(bool);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.Dispose メソッド ()

public override void Dispose();

実装

IDisposable.Dispose

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.Dispose オーバロードリスト


CogOCVMaxPattern.Dispose メソッド (Boolean)

protected virtual void Dispose(
bool isDisposing
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.Dispose オーバロードリスト


CogOCVMaxPattern.Execute メソッド

指定された実行パラメータを使用して、指定された画像に対して検査を実行します。

public CogOCVMaxResult Execute(
CogImage8Grey pImg,
ICogRegion pRegion,
CogOCVMaxRunParams pRunParams
);

パラメータ

pImg
検査する画像。NULL であってはなりません。
pRegion
オプションの領域。NULL であることも可能です。指定されている場合、この領域は、入力画像に対して実行される処理の量を制限するために使用されます。この制限は、PixelAlignedBoundingBox または AffineTransform のいずれかであることが可能な、実行パラメータ RegionMode と連動して行われます。RegionMode が AffineTransform の場合、この領域は CogRectangleAffine に対応している必要があります。領域が指定されていない場合は、入力画像全体が処理されます。
pRunParams
この検査の実行方法を指定する実行パラメータ。

戻り値

この検査の結果。検査がタイムアウトした場合、これは不完全な結果となる可能性もあることに注意してください。必ず、CogOCVMaxResult.TimedOut プロパティをチェックしてください。

解説

オプションの領域は、使用する画像の部分を制限します。このメソッドを呼び出す前に、パターンが登録されている必要があることに注意してください。

例外

例外タイプ | 条件
InvalidOperationException | このオペレータがまだ登録されていない場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
CogSecurityViolationException | このオペレータのライセンスを確認できない場合。
ArgumentNullException | 指定された CogOCVMaxRunParams 引数が NULL の場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.Finalize メソッド

protected override void Finalize();

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.GetCharacterCount メソッド

行内の文字の数を取得します。

public int GetCharacterCount(
int paragraphPosition,
int linePosition
);

パラメータ

paragraphPosition
使用するパラグラフを指定する、ゼロベースのインデックス。
linePosition
パラグラフ内の使用する行を指定する、ゼロベースのインデックス。

戻り値

指定された行内の、文字の数。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | 指定された linePosition 引数が、0 より小さいか、または行の数以上である場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.GetCustomization メソッド

指定されたタイプのカスタマイズ文字列を取得します。

public string GetCustomization(
CogOCVMaxCustomizationTypeConstants type
);

パラメータ

type
希望するタイプのカスタマイズ文字列を指定する CogOCVMaxCustomizationTypeConstants。オプションとしては、KeySearch、ImageSearch、および OCVMaxTool があります。

戻り値

要求されたタイプのカスタマイズ情報を含む文字列。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.GetLineCount メソッド

パラグラフ内の行の数を取得します。

public int GetLineCount(
int paragraphPosition
);

パラメータ

paragraphPosition
使用するパラグラフを指定する、ゼロベースのインデックス。

戻り値

指定されたパラグラフ内の行の数。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | 指定された paragraphPosition 引数が、0 より小さいか、またはパラグラフの数以上である場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.GetObjectData メソッド

protected override void GetObjectData(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.GetParagraphCount メソッド

配置内のパラグラフの数を取得します。

public int GetParagraphCount();

戻り値

配置内のパラグラフの数。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.GetTunedRunParams メソッド

チューニングされた実行パラメータを取得します。

public CogOCVMaxRunParams GetTunedRunParams();

戻り値

最後に行われた Tune の呼び出しによって生成された実行パラメータ。NULL であることも可能です。

解説

実行パラメータは、最後に行われた Tune の呼び出しによって生成されたものです。Tune が呼び出されていない場合、このメソッドは NULL を返すことがあります。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.OnCharacterAdded メソッド

protected virtual void OnCharacterAdded(
CogOCVMaxPatternCharacterAddedEventArgs evntArgs
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.OnCharacterChanged メソッド

protected virtual void OnCharacterChanged(
CogOCVMaxPatternCharacterChangedEventArgs evntArgs
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.OnCharacterRemoved メソッド

protected virtual void OnCharacterRemoved(
CogOCVMaxPatternCharacterRemovedEventArgs evntArgs
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.OnDeserialization メソッド

public override void OnDeserialization(
object sender
);

実装

IDeserializationCallback.OnDeserialization

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.OnLineAdded メソッド

protected virtual void OnLineAdded(
CogOCVMaxPatternLineAddedEventArgs evntArgs
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.OnLineChanged メソッド

protected virtual void OnLineChanged(
CogOCVMaxPatternLineChangedEventArgs evntArgs
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.OnLineRemoved メソッド

protected virtual void OnLineRemoved(
CogOCVMaxPatternLineRemovedEventArgs evntArgs
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.OnParagraphAdded メソッド

protected virtual void OnParagraphAdded(
CogOCVMaxPatternParagraphAddedEventArgs evntArgs
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.OnParagraphChanged メソッド

protected virtual void OnParagraphChanged(
CogOCVMaxPatternParagraphChangedEventArgs evntArgs
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.OnParagraphRemoved メソッド

protected virtual void OnParagraphRemoved(
CogOCVMaxPatternParagraphRemovedEventArgs evntArgs
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.OnTrainProgress メソッド

protected virtual void OnTrainProgress(
CogOCVMaxPatternTrainProgressEventArgs evntArgs
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.OnTuneProgress メソッド

protected virtual void OnTuneProgress(
CogOCVMaxPatternTuneProgressEventArgs evntArgs
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.RemoveCharacter メソッド

指定された文字繰り返し指定子によって指定される文字を、配置から削除します。

public void RemoveCharacter(
CogOCVMaxCharacterIterator pTarget
);

パラメータ

pTarget
削除する文字を指定する CogOCVMaxCharacterIterator。NULL であってはなりません。

解説

文字繰り返し指定子が、行内の唯一の文字を参照する場合は、その行が配置から削除されます。その行がパラグラフ内の唯一の行である場合は、そのパラグラフが配置から削除されます。

イベント

イベントタイプ | 理由
LineRemoved | パターンオブジェクトから行が削除された場合に発生します。
CharacterRemoved | パターンオブジェクトから文字が削除された場合に発生します。
Changed | パターンオブジェクトが変更された場合に発生します。
ParagraphRemoved | パターンオブジェクトからパラグラフが削除された場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | pTarget 引数が NULL の場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentException | 指定された文字繰り返し指定子が、この CogOCVMaxPattern オブジェクトを参照していない場合。
InvalidOperationException | 文字繰り返し指定子が、正当な位置を指定していない場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.RemoveLine メソッド

指定された行繰り返し指定子によって指定される行を、配置から削除します。

public void RemoveLine(
CogOCVMaxLineIterator pTarget
);

パラメータ

pTarget
削除する行を指定する CogOCVMaxLineIterator。NULL であってはなりません。

解説

行繰り返し指定子が、パラグラフ内の唯一の行を参照する場合は、そのパラグラフ全体が配置から削除されます。

イベント

イベントタイプ | 理由
Changed | パターンオブジェクトが変更された場合に発生します。
ParagraphRemoved | パターンオブジェクトからパラグラフが削除された場合に発生します。
LineRemoved | パターンオブジェクトから行が削除された場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | pTarget 引数が NULL の場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentException | 指定された行繰り返し指定子が、この CogOCVMaxPattern オブジェクトを参照していない場合。
InvalidOperationException | 行繰り返し指定子が、正当な位置を指定していない場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.RemoveParagraph メソッド

パラグラフ繰り返し指定子によって指定されるパラグラフを、配置から削除します。

public void RemoveParagraph(
CogOCVMaxParagraphIterator pTarget
);

パラメータ

pTarget
削除するパラグラフを指定する CogOCVMaxParagraphIterator。NULL であってはなりません。

イベント

イベントタイプ | 理由
ParagraphRemoved | パターンオブジェクトからパラグラフが削除された場合に発生します。
Changed | パターンオブジェクトが変更された場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
ArgumentException | 指定されたパラグラフ繰り返し指定子が、この CogOCVMaxPattern オブジェクトを参照していない場合。
ArgumentNullException | pTarget 引数が NULL の場合。
InvalidOperationException | パラグラフ繰り返し指定子が、正当な位置を指定していない場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.RenderImage メソッド

配置全体のグラフィカル描画を含む画像を作成します。

public CogImage8Grey RenderImage(
CogTransform2DLinear pPose,
byte foregroundGrey,
byte backgroundGrey
);

パラメータ

pPose
配置空間から選択空間へのマッピングを定義する CogTransform2DLinear。
foregroundGrey
テキストの標準グレースケール値。
backgroundGrey
テキスト以外のすべての標準グレースケール値。

戻り値

現在の配置のグラフィカル描画を含む画像。この画像は、描画全体を含むようにサイズが調整されています。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SetCustomization メソッド

指定されたカスタマイズタイプのための、カスタマイズ文字列を設定します。

public string SetCustomization(
string customization,
CogOCVMaxCustomizationTypeConstants type
);

パラメータ

customization
希望するカスタマイズ情報を含む System::String。
type
希望するカスタマイズタイプを指定する CogOCVMaxCustomizationTypeConstants。オプションとしては、KeySearch、ImageSearch、および OCVMaxTool があります。

戻り値

指定されたタイプのための、新しいカスタマイズ文字列。変更がなかった場合は、「No change」が返されます。

イベント

イベントタイプ | 理由
Changed | パターンオブジェクトが変更された場合に発生します。

例外

例外タイプ | 条件
ArgumentException | カスタマイズ文字列のフォーマットが正当でない場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 内部エラーが発生した場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.SetCustomizationFromFile メソッド

指定されたカスタマイズタイプのための、カスタマイズ文字列を、指定されたファイルから設定します。

public string SetCustomizationFromFile(
string filename,
CogOCVMaxCustomizationTypeConstants type
);

パラメータ

filename
希望するカスタマイズ情報を含むファイルの名前を保持する、System::String。
type
希望するカスタマイズタイプを指定する CogOCVMaxCustomizationTypeConstants。オプションとしては、KeySearch、ImageSearch、および OCVMaxTool があります。

戻り値

指定されたタイプのための、新しいカスタマイズ文字列。

イベント

イベントタイプ | 理由
Changed | パターンオブジェクトが変更された場合に発生します。

例外

例外タイプ | 条件
ArgumentException | ファイルを開くことができない場合、またはカスタマイズ文字列のフォーマットが正当でない場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
InvalidOperationException | 内部エラーが発生した場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.Train メソッド

現在の配置を登録します。

public void Train();

解説

Execute を呼び出す前に、パターンを登録する必要があります。

イベント

イベントタイプ | 理由
TrainProgress | 登録の進行状況を報告するため、およびオプションでの登録のキャンセルに役立つように、登録中に定期的に発生します。
Changed | パターンオブジェクトが変更された場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
CogSecurityViolationException | このオペレータのライセンスを確認できない場合。
CogTimeoutExpiredException | TrainTimeoutEnabled が true で、オペレータが TrainTimeout ミリ秒以内に登録を完了しない場合は、この例外が生成されます。この例外は、TrainProgress イベントを介して登録がキャンセルされた場合にも生成されることに注意してください。
InvalidOperationException | 登録中に内部エラーが発生した場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.TrainProgressReport メソッド

public bool TrainProgressReport(
double dFraction
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


Tune メソッド

VisionPro プログラミングリファレンス

CogOCVMaxPattern.Tune メソッド

配置全体をチューニングします。

オーバロードリスト

配置全体をチューニングします。

public void Tune();

パラグラフ繰り返し指定子によって指定されるパラグラフのみをチューニングします。

public void Tune(CogOCVMaxParagraphIterator);

指定された、ゼロベースのパラグラフインデックスの配列リストによって指定されるパラグラフのみをチューニングします。

public void Tune(ArrayList);

指定された、ゼロベースのパラグラフインデックスによって指定されるパラグラフのみをチューニングします。

public void Tune(int);

指定された、ゼロベースのパラグラフインデックスの配列によって指定されるパラグラフのみをチューニングします。

public void Tune(int[]);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.Tune メソッド ()

配置全体をチューニングします。

public void Tune();

解説

このオプションのステップは、配置 (登録済みプロパティ) と実行パラメータの両方の登録、実行、および調整を繰り返すことにより構成されます。

イベント

イベントタイプ | 理由
LineChanged | 行が変更された場合に発生します。
CharacterChanged | 文字が変更された場合に発生します。
ParagraphChanged | パラグラフが変更された場合に発生します。
TuneProgress | チューニングの進行状況を報告するため、およびオプションでのチューニングのキャンセルに役立つように、チューニング中に定期的に発生します。
Changed | パターンオブジェクトが変更された場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | TuneImage プロパティが NULL の場合。
CogTimeoutExpiredException | TuneRunParams.TimeoutEnabled が true で、オペレータが TuneRunParams.Timeout ミリ秒以内にチューニングを完了しない場合は、この例外が生成されます。この例外は、TuneProgress イベントを介してチューニングがキャンセルされた場合にも生成されることに注意してください。
CogSecurityViolationException | このオペレータのライセンスを確認できない場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.Tune オーバロードリスト


CogOCVMaxPattern.Tune メソッド (CogOCVMaxParagraphIterator)

パラグラフ繰り返し指定子によって指定されるパラグラフのみをチューニングします。

public void Tune(
CogOCVMaxParagraphIterator pTarget
);

パラメータ

pTarget
n/a

解説

このオプションのステップは、配置 (登録済みプロパティ) と実行パラメータの両方の登録、実行、および調整を繰り返すことにより構成されます。

イベント

イベントタイプ | 理由
LineChanged | 行が変更された場合に発生します。
CharacterChanged | 文字が変更された場合に発生します。
TuneProgress | チューニングの進行状況を報告するため、およびオプションでのチューニングのキャンセルに役立つように、チューニング中に定期的に発生します。
Changed | パターンオブジェクトが変更された場合に発生します。
ParagraphChanged | パラグラフが変更された場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | 登録中に内部エラーが発生した場合。
ArgumentNullException | 指定されたパラグラフ繰り返し指定子引数が NULL の場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
CogSecurityViolationException | このオペレータのライセンスを確認できない場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.Tune オーバロードリスト


CogOCVMaxPattern.Tune メソッド (ArrayList)

指定された、ゼロベースのパラグラフインデックスの配列リストによって指定されるパラグラフのみをチューニングします。

public void Tune(
ArrayList paragraphIndices
);

パラメータ

paragraphIndices
n/a

解説

このオプションのステップは、配置 (登録済みプロパティ) と実行パラメータの両方の登録、実行、および調整を繰り返すことにより構成されます。

イベント

イベントタイプ | 理由
Changed | パターンオブジェクトが変更された場合に発生します。
TuneProgress | チューニングの進行状況を報告するため、およびオプションでのチューニングのキャンセルに役立つように、チューニング中に定期的に発生します。
ParagraphChanged | パラグラフが変更された場合に発生します。
LineChanged | 行が変更された場合に発生します。
CharacterChanged | 文字が変更された場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | このオペレータがまだ登録されていない場合。
CogSecurityViolationException | このオペレータのライセンスを確認できない場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.Tune オーバロードリスト


CogOCVMaxPattern.Tune メソッド (Int32)

指定された、ゼロベースのパラグラフインデックスによって指定されるパラグラフのみをチューニングします。

public void Tune(
int paragraphIndex
);

パラメータ

paragraphIndex
n/a

解説

このオプションのステップは、配置 (登録済みプロパティ) と実行パラメータの両方の登録、実行、および調整を繰り返すことにより構成されます。

イベント

イベントタイプ | 理由
LineChanged | 行が変更された場合に発生します。
TuneProgress | チューニングの進行状況を報告するため、およびオプションでのチューニングのキャンセルに役立つように、チューニング中に定期的に発生します。
Changed | パターンオブジェクトが変更された場合に発生します。
ParagraphChanged | パラグラフが変更された場合に発生します。
CharacterChanged | 文字が変更された場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | このオペレータがまだ登録されていない場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。
CogSecurityViolationException | このオペレータのライセンスを確認できない場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.Tune オーバロードリスト


CogOCVMaxPattern.Tune メソッド (Int32[])

指定された、ゼロベースのパラグラフインデックスの配列によって指定されるパラグラフのみをチューニングします。

public void Tune(
int[] paragraphIndices
);

パラメータ

paragraphIndices
n/a

解説

このオプションのステップは、配置 (登録済みプロパティ) と実行パラメータの両方の登録、実行、および調整を繰り返すことにより構成されます。

イベント

イベントタイプ | 理由
LineChanged | 行が変更された場合に発生します。
ParagraphChanged | パラグラフが変更された場合に発生します。
CharacterChanged | 文字が変更された場合に発生します。
TuneProgress | チューニングの進行状況を報告するため、およびオプションでのチューニングのキャンセルに役立つように、チューニング中に定期的に発生します。
Changed | パターンオブジェクトが変更された場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | 登録中に内部エラーが発生した場合。
CogSecurityViolationException | このオペレータのライセンスを確認できない場合。
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPattern.Tune オーバロードリスト


CogOCVMaxPattern.TuneProgressReport メソッド

public bool TuneProgressReport(
double dFraction
);

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.Untrain メソッド

登録されているデータがあれば、すべて破棄します。

public void Untrain();

解説

このメソッドが呼び出された後で、Trained が false に設定されます。Trained が false の場合、このメソッドは効果を持ちません。

イベント

イベントタイプ | 理由
Changed | パターンオブジェクトが変更された場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxPattern オブジェクトが既に破棄されている場合。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern イベント

CogOCVMaxPattern クラスのイベントを次に示します。CogOCVMaxPattern クラスメンバの完全なリストについては、「CogOCVMaxPattern メンバ」を参照してください。

パブリックインスタンスイベント

CharacterAdded
CharacterChanged
CharacterRemoved
LineAdded
LineChanged
LineRemoved
ParagraphAdded
ParagraphChanged
ParagraphRemoved
TrainProgress
TuneProgress

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.CharacterAdded イベント

public event CogOCVMaxPatternCharacterAddedEventHandler CharacterAdded;

イベントデータ

イベントハンドラは、このイベントに関連するデータを含む CogOCVMaxPatternCharacterAddedEventArgs タイプの引数を受け取ります。次の CogOCVMaxPatternCharacterAddedEventArgs プロパティは、このイベント固有の情報を提供します。

プロパティ | 説明
CharacterPosition | 追加された文字のうち、最初の文字の、ゼロベースの文字インデックスです。
LinePosition | 追加された文字の、ゼロベースの行インデックスです。
NumCharacters | 追加された文字の数です。
ParagraphPosition | 追加された文字の、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.CharacterChanged イベント

public event CogOCVMaxPatternCharacterChangedEventHandler CharacterChanged;

イベントデータ

イベントハンドラは、このイベントに関連するデータを含む CogOCVMaxPatternCharacterChangedEventArgs タイプの引数を受け取ります。次の CogOCVMaxPatternCharacterChangedEventArgs プロパティは、このイベント固有の情報を提供します。

プロパティ | 説明
CharacterPosition | 変更された文字の、ゼロベースの文字インデックスです。
LinePosition | 変更された文字の、ゼロベースの行インデックスです。
ParagraphPosition | 変更された文字の、ゼロベースのパラグラフインデックスです。
PositionValid | このイベントによって報告された位置が正当かどうかを示します。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.CharacterRemoved イベント

public event CogOCVMaxPatternCharacterRemovedEventHandler CharacterRemoved;

イベントデータ

イベントハンドラは、このイベントに関連するデータを含む CogOCVMaxPatternCharacterRemovedEventArgs タイプの引数を受け取ります。次の CogOCVMaxPatternCharacterRemovedEventArgs プロパティは、このイベント固有の情報を提供します。

プロパティ | 説明
CharacterPosition | 削除された文字のうち、最初の文字の、ゼロベースの文字インデックスです。
LinePosition | 削除された文字の、ゼロベースの行インデックスです。
NumCharacters | 削除された文字の数です。
ParagraphPosition | 削除された文字の、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.LineAdded イベント

public event CogOCVMaxPatternLineAddedEventHandler LineAdded;

イベントデータ

イベントハンドラは、このイベントに関連するデータを含む CogOCVMaxPatternLineAddedEventArgs タイプの引数を受け取ります。次の CogOCVMaxPatternLineAddedEventArgs プロパティは、このイベント固有の情報を提供します。

プロパティ | 説明
LinePosition | 追加された行のうち、最初の行の、ゼロベースの行インデックスです。
NumLines | 追加された行の数です。
ParagraphPosition | 追加された行の、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.LineChanged イベント

public event CogOCVMaxPatternLineChangedEventHandler LineChanged;

イベントデータ

イベントハンドラは、このイベントに関連するデータを含む CogOCVMaxPatternLineChangedEventArgs タイプの引数を受け取ります。次の CogOCVMaxPatternLineChangedEventArgs プロパティは、このイベント固有の情報を提供します。

プロパティ | 説明
LinePosition | 変更された行の、ゼロベースの行インデックスです。
ParagraphPosition | 変更された行の、ゼロベースのパラグラフインデックスです。
PositionValid | このイベントによって報告された位置が正当かどうかを示します。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.LineRemoved イベント

public event CogOCVMaxPatternLineRemovedEventHandler LineRemoved;

イベントデータ

イベントハンドラは、このイベントに関連するデータを含む CogOCVMaxPatternLineRemovedEventArgs タイプの引数を受け取ります。次の CogOCVMaxPatternLineRemovedEventArgs プロパティは、このイベント固有の情報を提供します。

プロパティ | 説明
LinePosition | 削除された行のうち、最初の行の、ゼロベースの行インデックス。
NumLines | 削除された行の数。
ParagraphPosition | 削除された行の、ゼロベースのパラグラフインデックス。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.ParagraphAdded イベント

public event CogOCVMaxPatternParagraphAddedEventHandler ParagraphAdded;

イベントデータ

イベントハンドラは、このイベントに関連するデータを含む CogOCVMaxPatternParagraphAddedEventArgs タイプの引数を受け取ります。次の CogOCVMaxPatternParagraphAddedEventArgs プロパティは、このイベント固有の情報を提供します。

プロパティ | 説明
NumParagraphs | 追加されたパラグラフの数です。
ParagraphPosition | 追加されたパラグラフのうち、最初のパラグラフの、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.ParagraphChanged イベント

public event CogOCVMaxPatternParagraphChangedEventHandler ParagraphChanged;

イベントデータ

イベントハンドラは、このイベントに関連するデータを含む CogOCVMaxPatternParagraphChangedEventArgs タイプの引数を受け取ります。次の CogOCVMaxPatternParagraphChangedEventArgs プロパティは、このイベント固有の情報を提供します。

プロパティ | 説明
ParagraphPosition | 変更されたパラグラフの、ゼロベースのパラグラフインデックス。
PositionValid | このイベントによって報告された位置が正当かどうかを示します。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.ParagraphRemoved イベント

public event CogOCVMaxPatternParagraphRemovedEventHandler ParagraphRemoved;

イベントデータ

イベントハンドラは、このイベントに関連するデータを含む CogOCVMaxPatternParagraphRemovedEventArgs タイプの引数を受け取ります。次の CogOCVMaxPatternParagraphRemovedEventArgs プロパティは、このイベント固有の情報を提供します。

プロパティ | 説明
NumParagraphs | 削除されたパラグラフの数。
ParagraphPosition | 削除されたパラグラフのうち、最初のパラグラフの、ゼロベースのパラグラフインデックス。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.TrainProgress イベント

public event CogOCVMaxPatternTrainProgressEventHandler TrainProgress;

イベントデータ

イベントハンドラは、このイベントに関連するデータを含む CogOCVMaxPatternTrainProgressEventArgs タイプの引数を受け取ります。次の CogOCVMaxPatternTrainProgressEventArgs プロパティは、このイベント固有の情報を提供します。

プロパティ | 説明
Progress | 現在までの登録の進行状況です。この System::Double は 0 ～ 1 の範囲になります。ここで、0 はどの登録もまだ完了していないことを意味し、1 はすべての登録が完了したことを意味します。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPattern.TuneProgress イベント

public event CogOCVMaxPatternTuneProgressEventHandler TuneProgress;

イベントデータ

イベントハンドラは、このイベントに関連するデータを含む CogOCVMaxPatternTuneProgressEventArgs タイプの引数を受け取ります。次の CogOCVMaxPatternTuneProgressEventArgs プロパティは、このイベント固有の情報を提供します。

プロパティ | 説明
Progress | 現在までのチューニングの進行状況です。この System::Double は 0 ～ 1 の範囲になります。ここで、0 はどのチューニングもまだ完了していないことを意味し、1 はすべてのチューニングが完了したことを意味します。

参照

CogOCVMaxPattern クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterAddedEventArgs クラス

このクラスは、CharacterAdded イベントによって提供されたデータを保持します。CharacterAdded イベントは、1 つ以上の文字が配置に追加された後に、標準の Changed イベントに加えて発生します。

このタイプのメンバすべてのリストについては、「CogOCVMaxPatternCharacterAddedEventArgs メンバ」を参照してください。

System.Object
EventArgs
CogOCVMaxPatternCharacterAddedEventArgs

public class CogOCVMaxPatternCharacterAddedEventArgs :EventArgs

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxPatternCharacterAddedEventArgs メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterAddedEventArgs メンバ

CogOCVMaxPatternCharacterAddedEventArgs の概要

パブリックインスタンスコンストラクタ

CogOCVMaxPatternCharacterAddedEventArgs コンストラクタ 指定されたパラグラフインデックス、行インデックス、文字インデックス、および追加された文字のカウントを持つ、CogOCVMaxPatternCharacterAddedEventArgs オブジェクトを構築します。

パブリックインスタンスプロパティ

CharacterPosition | 追加された文字のうち、最初の文字の、ゼロベースの文字インデックスです。
LinePosition | 追加された文字の、ゼロベースの行インデックスです。
NumCharacters | 追加された文字の数です。
ParagraphPosition | 追加された文字の、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPatternCharacterAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterAddedEventArgs コンストラクタ

指定されたパラグラフインデックス、行インデックス、文字インデックス、および追加された文字のカウントを持つ、CogOCVMaxPatternCharacterAddedEventArgs オブジェクトを構築します。

public CogOCVMaxPatternCharacterAddedEventArgs(
int iP,
int iL,
int iC,
int nC
);

パラメータ

iP
System::Int32。パラグラフインデックスです。
iL
System::Int32。行インデックスです。
iC
System::Int32。文字インデックスです。
nC
System::Int32。追加された文字のカウントです。

参照

CogOCVMaxPatternCharacterAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterAddedEventArgs プロパティ

CogOCVMaxPatternCharacterAddedEventArgs クラスのプロパティを次に示します。CogOCVMaxPatternCharacterAddedEventArgs クラスメンバの完全なリストについては、「CogOCVMaxPatternCharacterAddedEventArgs メンバ」を参照してください。

パブリックインスタンスプロパティ

CharacterPosition | 追加された文字のうち、最初の文字の、ゼロベースの文字インデックスです。
LinePosition | 追加された文字の、ゼロベースの行インデックスです。
NumCharacters | 追加された文字の数です。
ParagraphPosition | 追加された文字の、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPatternCharacterAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterAddedEventArgs.CharacterPosition プロパティ

追加された文字のうち、最初の文字の、ゼロベースの文字インデックスです。

public int CharacterPosition {get;}

参照

CogOCVMaxPatternCharacterAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterAddedEventArgs.LinePosition プロパティ

追加された文字の、ゼロベースの行インデックスです。

public int LinePosition {get;}

参照

CogOCVMaxPatternCharacterAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterAddedEventArgs.NumCharacters プロパティ

追加された文字の数です。

public int NumCharacters {get;}

参照

CogOCVMaxPatternCharacterAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterAddedEventArgs.ParagraphPosition プロパティ

追加された文字の、ゼロベースのパラグラフインデックスです。

public int ParagraphPosition {get;}

参照

CogOCVMaxPatternCharacterAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterAddedEventHandler デリゲート

public delegate void CogOCVMaxPatternCharacterAddedEventHandler(
object sender,
CogOCVMaxPatternCharacterAddedEventArgs e
);

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ: Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterChangedEventArgs クラス

このクラスは、CharacterChanged イベントによって提供されたデータを保持します。CharacterChanged イベントは、配置内にある文字のなんらかの側面が変更された後に、標準の Changed イベントに加えて発生します。

このタイプのメンバすべてのリストについては、「CogOCVMaxPatternCharacterChangedEventArgs メンバ」を参照してください。

System.Object
EventArgs
CogOCVMaxPatternCharacterChangedEventArgs

public class CogOCVMaxPatternCharacterChangedEventArgs :EventArgs

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxPatternCharacterChangedEventArgs メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterChangedEventArgs メンバ

CogOCVMaxPatternCharacterChangedEventArgs の概要

パブリックインスタンスコンストラクタ

CogOCVMaxPatternCharacterChangedEventArgs コンストラクタ 指定されたパラグラフインデックス、行インデックス、文字インデックス、および位置正当値を持つ、CogOCVMaxPatternCharacterChangedEventArgs オブジェクトを構築します。

パブリックインスタンスプロパティ

CharacterPosition | 変更された文字の、ゼロベースの文字インデックスです。
LinePosition | 変更された文字の、ゼロベースの行インデックスです。
ParagraphPosition | 変更された文字の、ゼロベースのパラグラフインデックスです。
PositionValid | このイベントによって報告された位置が正当かどうかを示します。

参照

CogOCVMaxPatternCharacterChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterChangedEventArgs コンストラクタ

指定されたパラグラフインデックス、行インデックス、文字インデックス、および位置正当値を持つ、CogOCVMaxPatternCharacterChangedEventArgs オブジェクトを構築します。

public CogOCVMaxPatternCharacterChangedEventArgs(
int iP,
int iL,
int iC,
bool posValid
);

パラメータ

iP
System::Int32。パラグラフインデックスです。
iL
System::Int32。行インデックスです。
iC
System::Int32。文字インデックスです。
posValid
このイベントによって報告された位置が正当かどうかを示します。

参照

CogOCVMaxPatternCharacterChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterChangedEventArgs プロパティ

CogOCVMaxPatternCharacterChangedEventArgs クラスのプロパティを次に示します。CogOCVMaxPatternCharacterChangedEventArgs クラスメンバの完全なリストについては、「CogOCVMaxPatternCharacterChangedEventArgs メンバ」を参照してください。

パブリックインスタンスプロパティ

CharacterPosition | 変更された文字の、ゼロベースの文字インデックスです。
LinePosition | 変更された文字の、ゼロベースの行インデックスです。
ParagraphPosition | 変更された文字の、ゼロベースのパラグラフインデックスです。
PositionValid | このイベントによって報告された位置が正当かどうかを示します。

参照

CogOCVMaxPatternCharacterChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterChangedEventArgs.CharacterPosition プロパティ

変更された文字の、ゼロベースの文字インデックスです。

public int CharacterPosition {get;}

参照

CogOCVMaxPatternCharacterChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterChangedEventArgs.LinePosition プロパティ

変更された文字の、ゼロベースの行インデックスです。

public int LinePosition {get;}

参照

CogOCVMaxPatternCharacterChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterChangedEventArgs.ParagraphPosition プロパティ

変更された文字の、ゼロベースのパラグラフインデックスです。

public int ParagraphPosition {get;}

参照

CogOCVMaxPatternCharacterChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterChangedEventArgs.PositionValid プロパティ

このイベントによって報告された位置が正当かどうかを示します。

public bool PositionValid {get;}

参照

CogOCVMaxPatternCharacterChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterChangedEventHandler デリゲート

public delegate void CogOCVMaxPatternCharacterChangedEventHandler(
object sender,
CogOCVMaxPatternCharacterChangedEventArgs e
);

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterRemovedEventArgs クラス

このクラスは、CharacterRemoved イベントによって提供されたデータを保持します。CharacterRemoved イベントは、配置内の 1 つ以上の文字が削除された後に、標準の Changed イベントに加えて発生します。

このタイプのメンバすべてのリストについては、「CogOCVMaxPatternCharacterRemovedEventArgs メンバ」を参照してください。

System.Object
EventArgs
CogOCVMaxPatternCharacterRemovedEventArgs

public class CogOCVMaxPatternCharacterRemovedEventArgs :EventArgs

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxPatternCharacterRemovedEventArgs メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterRemovedEventArgs メンバ

CogOCVMaxPatternCharacterRemovedEventArgs の概要

パブリックインスタンスコンストラクタ

CogOCVMaxPatternCharacterRemovedEventArgs コンストラクタ 指定されたパラグラフインデックス、行インデックス、文字インデックス、および削除された文字のカウントを持つ、CogOCVMaxPatternCharacterRemovedEventArgs オブジェクトを構築します。

パブリックインスタンスプロパティ

CharacterPosition | 削除された文字のうち、最初の文字の、ゼロベースの文字インデックスです。
LinePosition | 削除された文字の、ゼロベースの行インデックスです。
NumCharacters | 削除された文字の数です。
ParagraphPosition | 削除された文字の、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPatternCharacterRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterRemovedEventArgs コンストラクタ

指定されたパラグラフインデックス、行インデックス、文字インデックス、および削除された文字のカウントを持つ、CogOCVMaxPatternCharacterRemovedEventArgs オブジェクトを構築します。

public CogOCVMaxPatternCharacterRemovedEventArgs(
int iP,
int iL,
int iC,
int nC
);

パラメータ

iP
System::Int32。パラグラフインデックスです。
iL
System::Int32。行インデックスです。
iC
System::Int32。文字インデックスです。
nC
System::Int32。削除された文字のカウントです。

参照

CogOCVMaxPatternCharacterRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterRemovedEventArgs プロパティ

CogOCVMaxPatternCharacterRemovedEventArgs クラスのプロパティを次に示します。CogOCVMaxPatternCharacterRemovedEventArgs クラスメンバの完全なリストについては、「CogOCVMaxPatternCharacterRemovedEventArgs メンバ」を参照してください。

パブリックインスタンスプロパティ

CharacterPosition | 削除された文字のうち、最初の文字の、ゼロベースの文字インデックスです。
LinePosition | 削除された文字の、ゼロベースの行インデックスです。
NumCharacters | 削除された文字の数です。
ParagraphPosition | 削除された文字の、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPatternCharacterRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterRemovedEventArgs.CharacterPosition プロパティ

削除された文字のうち、最初の文字の、ゼロベースの文字インデックスです。

public int CharacterPosition {get;}

参照

CogOCVMaxPatternCharacterRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterRemovedEventArgs.LinePosition プロパティ

削除された文字の、ゼロベースの行インデックスです。

public int LinePosition {get;}

参照

CogOCVMaxPatternCharacterRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterRemovedEventArgs.NumCharacters プロパティ

削除された文字の数です。

public int NumCharacters {get;}

参照

CogOCVMaxPatternCharacterRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterRemovedEventArgs.ParagraphPosition プロパティ

削除された文字の、ゼロベースのパラグラフインデックスです。

public int ParagraphPosition {get;}

参照

CogOCVMaxPatternCharacterRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternCharacterRemovedEventHandler デリゲート

public delegate void CogOCVMaxPatternCharacterRemovedEventHandler(
object sender,
CogOCVMaxPatternCharacterRemovedEventArgs e
);

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineAddedEventArgs クラス

このクラスは、LineAdded イベントによって提供されたデータを保持します。LineAdded イベントは、1 つ以上の行が配置に追加された後に、標準の Changed イベントに加えて発生します。

このタイプのメンバすべてのリストについては、「CogOCVMaxPatternLineAddedEventArgs メンバ」を参照してください。

System.Object
EventArgs
CogOCVMaxPatternLineAddedEventArgs

public class CogOCVMaxPatternLineAddedEventArgs :EventArgs

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxPatternLineAddedEventArgs メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineAddedEventArgs メンバ

CogOCVMaxPatternLineAddedEventArgs の概要

パブリックインスタンスコンストラクタ

CogOCVMaxPatternLineAddedEventArgs コンストラクタ 指定されたパラグラフインデックス、行インデックス、および追加された行のカウントを持つ、CogOCVMaxPatternLineAddedEventArgs オブジェクトを構築します。

パブリックインスタンスプロパティ

LinePosition | 追加された行のうち、最初の行の、ゼロベースの行インデックスです。
NumLines | 追加された行の数です。
ParagraphPosition | 追加された行の、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPatternLineAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineAddedEventArgs コンストラクタ

指定されたパラグラフインデックス、行インデックス、および追加された行のカウントを持つ、CogOCVMaxPatternLineAddedEventArgs オブジェクトを構築します。

public CogOCVMaxPatternLineAddedEventArgs(
int iP,
int iL,
int nL
);

パラメータ

iP
System::Int32。パラグラフインデックスです。
iL
System::Int32。行インデックスです。
nL
System::Int32。追加された行のカウントです。

参照

CogOCVMaxPatternLineAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineAddedEventArgs プロパティ

CogOCVMaxPatternLineAddedEventArgs クラスのプロパティを次に示します。CogOCVMaxPatternLineAddedEventArgs クラスメンバの完全なリストについては、「CogOCVMaxPatternLineAddedEventArgs メンバ」を参照してください。

パブリックインスタンスプロパティ

LinePosition | 追加された行のうち、最初の行の、ゼロベースの行インデックスです。
NumLines | 追加された行の数です。
ParagraphPosition | 追加された行の、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPatternLineAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineAddedEventArgs.LinePosition プロパティ

追加された行のうち、最初の行の、ゼロベースの行インデックスです。

public int LinePosition {get;}

参照

CogOCVMaxPatternLineAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineAddedEventArgs.NumLines プロパティ

追加された行の数です。

public int NumLines {get;}

参照

CogOCVMaxPatternLineAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineAddedEventArgs.ParagraphPosition プロパティ

追加された行の、ゼロベースのパラグラフインデックスです。

public int ParagraphPosition {get;}

参照

CogOCVMaxPatternLineAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineAddedEventHandler デリゲート

public delegate void CogOCVMaxPatternLineAddedEventHandler(
object sender,
CogOCVMaxPatternLineAddedEventArgs e
);

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineChangedEventArgs クラス

このクラスは、LineChanged イベントによって提供されたデータを保持します。LineChanged イベントは、配置内にある行のなんらかの側面が変更された後に、標準の Changed イベントに加えて発生します。

このタイプのメンバすべてのリストについては、「CogOCVMaxPatternLineChangedEventArgs メンバ」を参照してください。

System.Object
EventArgs
CogOCVMaxPatternLineChangedEventArgs

public class CogOCVMaxPatternLineChangedEventArgs :EventArgs

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxPatternLineChangedEventArgs メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineChangedEventArgs メンバ

CogOCVMaxPatternLineChangedEventArgs の概要

パブリックインスタンスコンストラクタ

CogOCVMaxPatternLineChangedEventArgs コンストラクタ 指定されたパラグラフインデックス、行インデックス、および位置正当値を持つ、CogOCVMaxPatternLineChangedEventArgs オブジェクトを構築します。

パブリックインスタンスプロパティ

LinePosition | 変更された行の、ゼロベースの行インデックスです。
ParagraphPosition | 変更された行の、ゼロベースのパラグラフインデックスです。
PositionValid | このイベントによって報告された位置が正当かどうかを示します。

参照

CogOCVMaxPatternLineChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineChangedEventArgs コンストラクタ

指定されたパラグラフインデックス、行インデックス、および位置正当値を持つ、CogOCVMaxPatternLineChangedEventArgs オブジェクトを構築します。

public CogOCVMaxPatternLineChangedEventArgs(
int iP,
int iL,
bool posValid
);

パラメータ

iP
System::Int32。パラグラフインデックスです。
iL
System::Int32。行インデックスです。
posValid
このイベントによって報告された位置が正当かどうかを示します。

参照

CogOCVMaxPatternLineChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineChangedEventArgs プロパティ

CogOCVMaxPatternLineChangedEventArgs クラスのプロパティを次に示します。CogOCVMaxPatternLineChangedEventArgs クラスメンバの完全なリストについては、「CogOCVMaxPatternLineChangedEventArgs メンバ」を参照してください。

パブリックインスタンスプロパティ

LinePosition | 変更された行の、ゼロベースの行インデックスです。
ParagraphPosition | 変更された行の、ゼロベースのパラグラフインデックスです。
PositionValid | このイベントによって報告された位置が正当かどうかを示します。

参照

CogOCVMaxPatternLineChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineChangedEventArgs.LinePosition プロパティ

変更された行の、ゼロベースの行インデックスです。

public int LinePosition {get;}

参照

CogOCVMaxPatternLineChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineChangedEventArgs.ParagraphPosition プロパティ

変更された行の、ゼロベースのパラグラフインデックスです。

public int ParagraphPosition {get;}

参照

CogOCVMaxPatternLineChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineChangedEventArgs.PositionValid プロパティ

このイベントによって報告された位置が正当かどうかを示します。

public bool PositionValid {get;}

参照

CogOCVMaxPatternLineChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineChangedEventHandler デリゲート

public delegate void CogOCVMaxPatternLineChangedEventHandler(
object sender,
CogOCVMaxPatternLineChangedEventArgs e
);

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineRemovedEventArgs クラス

このクラスは、LineRemoved イベントによって提供されたデータを保持します。LineRemoved イベントは、配置内の 1 つ以上の行が削除された後に、標準の Changed イベントに加えて発生します。

このタイプのメンバすべてのリストについては、「CogOCVMaxPatternLineRemovedEventArgs メンバ」を参照してください。

System.Object
EventArgs
CogOCVMaxPatternLineRemovedEventArgs

public class CogOCVMaxPatternLineRemovedEventArgs :EventArgs

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxPatternLineRemovedEventArgs メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineRemovedEventArgs メンバ

CogOCVMaxPatternLineRemovedEventArgs の概要

パブリックインスタンスコンストラクタ

CogOCVMaxPatternLineRemovedEventArgs コンストラクタ 指定されたパラグラフインデックス、行インデックス、および削除された行のカウントを持つ、CogOCVMaxPatternLineRemovedEventArgs オブジェクトを構築します。

パブリックインスタンスプロパティ

LinePosition | 削除された行のうち、最初の行の、ゼロベースの行インデックスです。
NumLines | 削除された行の数です。
ParagraphPosition | 削除された行の、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPatternLineRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineRemovedEventArgs コンストラクタ

指定されたパラグラフインデックス、行インデックス、および削除された行のカウントを持つ、CogOCVMaxPatternLineRemovedEventArgs オブジェクトを構築します。

public CogOCVMaxPatternLineRemovedEventArgs(
int iP,
int iL,
int nL
);

パラメータ

iP
System::Int32。パラグラフインデックスです。
iL
System::Int32。行インデックスです。
nL
System::Int32。削除された行のカウントです。

参照

CogOCVMaxPatternLineRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineRemovedEventArgs プロパティ

CogOCVMaxPatternLineRemovedEventArgs クラスのプロパティを次に示します。CogOCVMaxPatternLineRemovedEventArgs クラスメンバの完全なリストについては、「CogOCVMaxPatternLineRemovedEventArgs メンバ」を参照してください。

パブリックインスタンスプロパティ

LinePosition | 削除された行のうち、最初の行の、ゼロベースの行インデックスです。
NumLines | 削除された行の数です。
ParagraphPosition | 削除された行の、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPatternLineRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineRemovedEventArgs.LinePosition プロパティ

削除された行のうち、最初の行の、ゼロベースの行インデックスです。

public int LinePosition {get;}

参照

CogOCVMaxPatternLineRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineRemovedEventArgs.NumLines プロパティ

削除された行の数です。

public int NumLines {get;}

参照

CogOCVMaxPatternLineRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineRemovedEventArgs.ParagraphPosition プロパティ

削除された行の、ゼロベースのパラグラフインデックスです。

public int ParagraphPosition {get;}

参照

CogOCVMaxPatternLineRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternLineRemovedEventHandler デリゲート

public delegate void CogOCVMaxPatternLineRemovedEventHandler(
object sender,
CogOCVMaxPatternLineRemovedEventArgs e
);

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphAddedEventArgs クラス

このクラスは、ParagraphAdded イベントによって提供されたデータを保持します。ParagraphAdded イベントは、1 つ以上のパラグラフが配置に追加された後に、標準の Changed イベントに加えて発生します。

このタイプのメンバすべてのリストについては、「CogOCVMaxPatternParagraphAddedEventArgs メンバ」を参照してください。

System.Object
EventArgs
CogOCVMaxPatternParagraphAddedEventArgs

public class CogOCVMaxPatternParagraphAddedEventArgs :EventArgs

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxPatternParagraphAddedEventArgs メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphAddedEventArgs メンバ

CogOCVMaxPatternParagraphAddedEventArgs の概要

パブリックインスタンスコンストラクタ

CogOCVMaxPatternParagraphAddedEventArgs コンストラクタ 指定されたパラグラフインデックス、および追加されたパラグラフのカウントを持つ、CogOCVMaxPatternParagraphAddedEventArgs オブジェクトを構築します。

パブリックインスタンスプロパティ

NumParagraphs | 追加されたパラグラフの数です。
ParagraphPosition | 追加されたパラグラフのうち、最初のパラグラフの、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPatternParagraphAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphAddedEventArgs コンストラクタ

指定されたパラグラフインデックス、および追加されたパラグラフのカウントを持つ、CogOCVMaxPatternParagraphAddedEventArgs オブジェクトを構築します。

public CogOCVMaxPatternParagraphAddedEventArgs(
int iP,
int nP
);

パラメータ

iP
System::Int32。パラグラフインデックスです。
nP
System::Int32。追加されたパラグラフのカウントです。

参照

CogOCVMaxPatternParagraphAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphAddedEventArgs プロパティ

CogOCVMaxPatternParagraphAddedEventArgs クラスのプロパティを次に示します。CogOCVMaxPatternParagraphAddedEventArgs クラスメンバの完全なリストについては、「CogOCVMaxPatternParagraphAddedEventArgs メンバ」を参照してください。

パブリックインスタンスプロパティ

NumParagraphs | 追加されたパラグラフの数です。
ParagraphPosition | 追加されたパラグラフのうち、最初のパラグラフの、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPatternParagraphAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphAddedEventArgs.NumParagraphs プロパティ

追加されたパラグラフの数です。

public int NumParagraphs {get;}

参照

CogOCVMaxPatternParagraphAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphAddedEventArgs.ParagraphPosition プロパティ

追加されたパラグラフのうち、最初のパラグラフの、ゼロベースのパラグラフインデックスです。

public int ParagraphPosition {get;}

参照

CogOCVMaxPatternParagraphAddedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphAddedEventHandler デリゲート

public delegate void CogOCVMaxPatternParagraphAddedEventHandler(
object sender,
CogOCVMaxPatternParagraphAddedEventArgs e
);

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphChangedEventArgs クラス

このクラスは、ParagraphChanged イベントによって提供されたデータを保持します。ParagraphChanged イベントは、配置内にあるパラグラフのなんらかの側面が変更された後に、標準の Changed イベントに加えて発生します。

このタイプのメンバすべてのリストについては、「CogOCVMaxPatternParagraphChangedEventArgs メンバ」を参照してください。

System.Object
EventArgs
CogOCVMaxPatternParagraphChangedEventArgs

public class CogOCVMaxPatternParagraphChangedEventArgs :EventArgs

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxPatternParagraphChangedEventArgs メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphChangedEventArgs メンバ

CogOCVMaxPatternParagraphChangedEventArgs の概要

パブリックインスタンスコンストラクタ

CogOCVMaxPatternParagraphChangedEventArgs コンストラクタ 指定されたパラグラフインデックス、および位置正当値を持つ、CogOCVMaxPatternParagraphChangedEventArgs オブジェクトを構築します。

パブリックインスタンスプロパティ

ParagraphPosition | 変更されたパラグラフの、ゼロベースのパラグラフインデックスです。
PositionValid | このイベントによって報告された位置が正当かどうかを示します。

参照

CogOCVMaxPatternParagraphChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphChangedEventArgs コンストラクタ

指定されたパラグラフインデックス、および位置正当値を持つ、CogOCVMaxPatternParagraphChangedEventArgs オブジェクトを構築します。

public CogOCVMaxPatternParagraphChangedEventArgs(
int iP,
bool posValid
);

パラメータ

iP
System::Int32。パラグラフインデックスです。
posValid
このイベントによって報告された位置が正当かどうかを示します。

参照

CogOCVMaxPatternParagraphChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphChangedEventArgs プロパティ

CogOCVMaxPatternParagraphChangedEventArgs クラスのプロパティを次に示します。CogOCVMaxPatternParagraphChangedEventArgs クラスメンバの完全なリストについては、「CogOCVMaxPatternParagraphChangedEventArgs メンバ」を参照してください。

パブリックインスタンスプロパティ

ParagraphPosition | 変更されたパラグラフの、ゼロベースのパラグラフインデックスです。
PositionValid | このイベントによって報告された位置が正当かどうかを示します。

参照

CogOCVMaxPatternParagraphChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphChangedEventArgs.ParagraphPosition プロパティ

変更されたパラグラフの、ゼロベースのパラグラフインデックスです。

public int ParagraphPosition {get;}

参照

CogOCVMaxPatternParagraphChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphChangedEventArgs.PositionValid プロパティ

このイベントによって報告された位置が正当かどうかを示します。

public bool PositionValid {get;}

参照

CogOCVMaxPatternParagraphChangedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphChangedEventHandler デリゲート

public delegate void CogOCVMaxPatternParagraphChangedEventHandler(
object sender,
CogOCVMaxPatternParagraphChangedEventArgs e
);

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphRemovedEventArgs クラス

このクラスは、ParagraphRemoved イベントによって提供されたデータを保持します。ParagraphRemoved イベントは、配置内の 1 つ以上のパラグラフが削除された後に、標準の Changed イベントに加えて発生します。

このタイプのメンバすべてのリストについては、「CogOCVMaxPatternParagraphRemovedEventArgs メンバ」を参照してください。

System.Object
EventArgs
CogOCVMaxPatternParagraphRemovedEventArgs

public class CogOCVMaxPatternParagraphRemovedEventArgs :EventArgs

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxPatternParagraphRemovedEventArgs メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphRemovedEventArgs メンバ

CogOCVMaxPatternParagraphRemovedEventArgs の概要

パブリックインスタンスコンストラクタ

CogOCVMaxPatternParagraphRemovedEventArgs コンストラクタ 指定されたパラグラフインデックス、および削除されたパラグラフのカウントを持つ、CogOCVMaxPatternParagraphRemovedEventArgs オブジェクトを構築します。

パブリックインスタンスプロパティ

NumParagraphs | 削除されたパラグラフの数です。
ParagraphPosition | 削除されたパラグラフのうち、最初のパラグラフの、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPatternParagraphRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphRemovedEventArgs コンストラクタ

指定されたパラグラフインデックス、および削除されたパラグラフのカウントを持つ、CogOCVMaxPatternParagraphRemovedEventArgs オブジェクトを構築します。

public CogOCVMaxPatternParagraphRemovedEventArgs(
int iP,
int nP
);

パラメータ

iP
System::Int32。パラグラフインデックスです。
nP
System::Int32。削除されたパラグラフのカウントです。

参照

CogOCVMaxPatternParagraphRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphRemovedEventArgs プロパティ

CogOCVMaxPatternParagraphRemovedEventArgs クラスのプロパティを次に示します。CogOCVMaxPatternParagraphRemovedEventArgs クラスメンバの完全なリストについては、「CogOCVMaxPatternParagraphRemovedEventArgs メンバ」を参照してください。

パブリックインスタンスプロパティ

NumParagraphs | 削除されたパラグラフの数です。
ParagraphPosition | 削除されたパラグラフのうち、最初のパラグラフの、ゼロベースのパラグラフインデックスです。

参照

CogOCVMaxPatternParagraphRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphRemovedEventArgs.NumParagraphs プロパティ

削除されたパラグラフの数です。

public int NumParagraphs {get;}

参照

CogOCVMaxPatternParagraphRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphRemovedEventArgs.ParagraphPosition プロパティ

削除されたパラグラフのうち、最初のパラグラフの、ゼロベースのパラグラフインデックスです。

public int ParagraphPosition {get;}

参照

CogOCVMaxPatternParagraphRemovedEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternParagraphRemovedEventHandler デリゲート

public delegate void CogOCVMaxPatternParagraphRemovedEventHandler(
object sender,
CogOCVMaxPatternParagraphRemovedEventArgs e
);

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTrainProgressEventArgs クラス

このクラスは、TrainProgress イベントによって提供されたデータを保持します。TrainProgress イベントは、登録中に定期的に発生します。

このタイプのメンバすべてのリストについては、「CogOCVMaxPatternTrainProgressEventArgs メンバ」を参照してください。

System.Object
EventArgs
CogOCVMaxPatternTrainProgressEventArgs

public class CogOCVMaxPatternTrainProgressEventArgs :EventArgs

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxPatternTrainProgressEventArgs メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTrainProgressEventArgs メンバ

CogOCVMaxPatternTrainProgressEventArgs の概要

パブリックインスタンスコンストラクタ

CogOCVMaxPatternTrainProgressEventArgs コンストラクタ 指定された進行状況値を持つ、CogOCVMaxPatternTrainProgressEventArgs オブジェクトを構築します。

パブリックインスタンスプロパティ

Progress 現在までの登録の進行状況です。この System::Double は 0 ～ 1 の範囲になります。ここで、0 はどの登録もまだ完了していないことを意味し、1 はすべての登録が完了したことを意味します。

パブリックインスタンスメソッド

CancelRequested | この登録に対してキャンセルが要求されたかどうかを示します。
RequestCancel | 登録がキャンセルされるように要求します。

参照

CogOCVMaxPatternTrainProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTrainProgressEventArgs コンストラクタ

指定された進行状況値を持つ、CogOCVMaxPatternTrainProgressEventArgs オブジェクトを構築します。

public CogOCVMaxPatternTrainProgressEventArgs(
double fractionComplete
);

パラメータ

fractionComplete
System::Double。進行状況値です。この値は、0 ～ 1 の範囲である必要があります。

参照

CogOCVMaxPatternTrainProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTrainProgressEventArgs プロパティ

CogOCVMaxPatternTrainProgressEventArgs クラスのプロパティを次に示します。CogOCVMaxPatternTrainProgressEventArgs クラスメンバの完全なリストについては、「CogOCVMaxPatternTrainProgressEventArgs メンバ」を参照してください。

パブリックインスタンスプロパティ

Progress 現在までの登録の進行状況です。この System::Double は 0 ～ 1 の範囲になります。ここで、0 はどの登録もまだ完了していないことを意味し、1 はすべての登録が完了したことを意味します。

参照

CogOCVMaxPatternTrainProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTrainProgressEventArgs.Progress プロパティ

現在までの登録の進行状況です。この System::Double は 0 ～ 1 の範囲になります。ここで、0 はどの登録もまだ完了していないことを意味し、1 はすべての登録が完了したことを意味します。

public double Progress {get;}

参照

CogOCVMaxPatternTrainProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTrainProgressEventArgs メソッド

CogOCVMaxPatternTrainProgressEventArgs クラスのメソッドを次に示します。CogOCVMaxPatternTrainProgressEventArgs クラスメンバの完全なリストについては、「CogOCVMaxPatternTrainProgressEventArgs メンバ」を参照してください。

パブリックインスタンスメソッド

CancelRequested | この登録に対してキャンセルが要求されたかどうかを示します。
RequestCancel | 登録がキャンセルされるように要求します。

参照

CogOCVMaxPatternTrainProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTrainProgressEventArgs.CancelRequested メソッド

この登録に対してキャンセルが要求されたかどうかを示します。

public bool CancelRequested();

戻り値

System::Boolean。キャンセルが要求された場合は true、それ以外の場合は false になります。

参照

CogOCVMaxPatternTrainProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTrainProgressEventArgs.RequestCancel メソッド

登録がキャンセルされるように要求します。

public void RequestCancel();

参照

CogOCVMaxPatternTrainProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTrainProgressEventHandler デリゲート

public delegate void CogOCVMaxPatternTrainProgressEventHandler(
object sender,
CogOCVMaxPatternTrainProgressEventArgs e
);

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTuneProgressEventArgs クラス

このクラスは、TuneProgress イベントによって提供されたデータを保持します。TuneProgress イベントは、チューニング中に定期的に発生します。

このタイプのメンバすべてのリストについては、「CogOCVMaxPatternTuneProgressEventArgs メンバ」を参照してください。

System.Object
EventArgs
CogOCVMaxPatternTuneProgressEventArgs

public class CogOCVMaxPatternTuneProgressEventArgs :EventArgs

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxPatternTuneProgressEventArgs メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTuneProgressEventArgs メンバ

CogOCVMaxPatternTuneProgressEventArgs の概要

パブリックインスタンスコンストラクタ

CogOCVMaxPatternTuneProgressEventArgs コンストラクタ 指定された進行状況値を持つ、CogOCVMaxPatternTuneProgressEventArgs オブジェクトを構築します。

パブリックインスタンスプロパティ

Progress 現在までのチューニングの進行状況です。この System::Double は 0 ～ 1 の範囲になります。ここで、0 はどのチューニングもまだ完了していないことを意味し、1 はすべてのチューニングが完了したことを意味します。

パブリックインスタンスメソッド

CancelRequested | このチューニングに対してキャンセルが要求されたかどうかを示します。
RequestCancel | チューニングがキャンセルされるように要求します。

参照

CogOCVMaxPatternTuneProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTuneProgressEventArgs コンストラクタ

指定された進行状況値を持つ、CogOCVMaxPatternTuneProgressEventArgs オブジェクトを構築します。

public CogOCVMaxPatternTuneProgressEventArgs(
double fractionComplete
);

パラメータ

fractionComplete
System::Double。進行状況値です。この値は、0 ～ 1 の範囲である必要があります。

参照

CogOCVMaxPatternTuneProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTuneProgressEventArgs プロパティ

CogOCVMaxPatternTuneProgressEventArgs クラスのプロパティを次に示します。CogOCVMaxPatternTuneProgressEventArgs クラスメンバの完全なリストについては、「CogOCVMaxPatternTuneProgressEventArgs メンバ」を参照してください。

パブリックインスタンスプロパティ

Progress 現在までのチューニングの進行状況です。この System::Double は 0 ～ 1 の範囲になります。ここで、0 はどのチューニングもまだ完了していないことを意味し、1 はすべてのチューニングが完了したことを意味します。

参照

CogOCVMaxPatternTuneProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTuneProgressEventArgs.Progress プロパティ

現在までのチューニングの進行状況です。この System::Double は 0 ～ 1 の範囲になります。ここで、0 はどのチューニングもまだ完了していないことを意味し、1 はすべてのチューニングが完了したことを意味します。

public double Progress {get;}

参照

CogOCVMaxPatternTuneProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTuneProgressEventArgs メソッド

CogOCVMaxPatternTuneProgressEventArgs クラスのメソッドを次に示します。CogOCVMaxPatternTuneProgressEventArgs クラスメンバの完全なリストについては、「CogOCVMaxPatternTuneProgressEventArgs メンバ」を参照してください。

パブリックインスタンスメソッド

CancelRequested | このチューニングに対してキャンセルが要求されたかどうかを示します。
RequestCancel | チューニングがキャンセルされるように要求します。

参照

CogOCVMaxPatternTuneProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTuneProgressEventArgs.CancelRequested メソッド

このチューニングに対してキャンセルが要求されたかどうかを示します。

public bool CancelRequested();

戻り値

System::Boolean。キャンセルが要求された場合は true、それ以外の場合は false になります。

参照

CogOCVMaxPatternTuneProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTuneProgressEventArgs.RequestCancel メソッド

チューニングがキャンセルされるように要求します。

public void RequestCancel();

参照

CogOCVMaxPatternTuneProgressEventArgs クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPatternTuneProgressEventHandler デリゲート

public delegate void CogOCVMaxPatternTuneProgressEventHandler(
object sender,
CogOCVMaxPatternTuneProgressEventArgs e
);

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPolarityConstants 列挙体

背景を基準にして、検査される文字の明るさまたは暗さを指定するための定数です。

public enum CogOCVMaxPolarityConstants

メンバ

メンバ名 | 説明
Unknown | 背景を基準にした文字の明るさまたは暗さは不明です。
LightOnDark | 暗い背景上の明るい文字です。
DarkOnLight | 明るい背景上の暗い文字です。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper クラス

このクラスは、テキスト文字列のポーズを定義する際のサポートを提供します。一般的な使用モデルでは、ユーザが、a) 対象となっている実際のテキストを描いた画像、b) フォントオブジェクト、および c) テキスト (1 つ以上の文字列) を保持していること、および、ユーザはこれらからポーズ (CogOCVMax オペレータまたはツールは、このポーズにおいて画像処理を行う可能性がある) を決定したいと考えていることが前提となっています。次の 5 つの基本的な手順があります。第 1 に、Font および Text プロパティを設定することによって (およびオプションで、FontRenderParams プロパティを変更することによって)、CogOCVMaxPoseHelper オブジェクトを設定します。第 2 に、InitialPoseEstimate() メソッドを呼び出して、望ましいポーズがどのようなものであるかについて、最初の推測を行います。第 3 に、FinalPosePrepare() メソッドを呼び出して、推測された初期ポーズを使用して CogCompositeShape グラフィックスを作成します。第 4 に、グラフィックスを対話型ディスプレイに追加して、このグラフィックスの位置、回転、サイズ、スケール、またはスキューをユーザがダイナミックに調整可能にすることで、グラフィックスを画像内の対応するテキストにスーパーインポーズできるようにします。第 5 に、FinalPoseComplete() メソッドを、(ユーザが変更した) CogCompositeShape グラフィックスとともに呼び出します。最後の手順により、ユーザが指定したポーズを説明する CogTransform2DLinear が得られます。

このタイプのメンバすべてのリストについては、「CogOCVMaxPoseHelper メンバ」を参照してください。

System.Object
MarshalByRefObject
CogObjectBase
CogSerializableObjectBase
CogSerializableChangedEventBase
CogOCVMaxPoseHelper

public class CogOCVMaxPoseHelper :CogSerializableChangedEventBase, IDeserializationCallback

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxPoseHelper メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper メンバ

CogOCVMaxPoseHelper の概要

パブリックスタティックフィールド

SfFinalPoseData
SfFinalPosePrepared
SfFont
SfFontRenderParams
SfInitialPose
SfText

プロテクトスタティックフィールド

SfNextSf

パブリックインスタンスコンストラクタ

CogOCVMaxPoseHelper オーバロードされます。CogOCVMaxPoseHelper クラスの新しいインスタンスを初期化します。

パブリックインスタンスプロパティ

FinalPosePrepared | キャッシュ内に保存された内部データの正当性を取得します。このデータでは、最終ポーズを指定するためにユーザが操作するグラフィカルオブジェクトの初期状態が説明されています。このプロパティは、FinalPosePrepare() が正常に呼び出されることによって、true に設定されます。このプロパティは、Font が変更または修正された場合、FontRenderParams が変更または修正された場合、Text が変更された場合、および InitialPose が変更または修正された場合は、false に設定されます。FinalPoseComplete() を呼び出す前には、このプロパティは true である必要があります。
Font | 希望するポーズを計算するために使用されるフォントを取得または設定します。
FontRenderParams | 希望するポーズを計算するために使用される CogOCVMaxFontRenderParams を取得または設定します。
InitialPose | キャッシュ内に保存された InitialPose を取得または設定します。このプロパティ値は直接設定することもできますが、通常は、InitialPoseEstimate() メソッドの呼び出しによって設定されるようにすることが多いので注意してください。
Text | 希望するポーズを計算するために使用される実際のテキストを取得または設定します。このテキストは、Int32 の ArrayList (1 つ以上) の ArrayList として表されることに注意してください。外側の配列リストは 1 つ以上のエントリを保持し、各エントリは、1 つのパラグラフ内のテキスト行に対応しています。そのような各エントリそのものが ArrayList です。内側の各 ArrayList は、0 個以上の Int32 を保持します。各 Int32 エントリは、文字のキー値です。1 つの行は 0 個のエントリを持つこと (つまり、空であること) が可能ですが、パラグラフ内には少なくとも 1 つの文字がある必要があります。このセッタと同じ機能を提供し、希望するテキストのより便利な表現 (例えば、文字列の配列、1 つの文字列、または Int32 の配列) を受け入れる、いくつかの SetText メソッドがあることに注意してください。

パブリックインスタンスメソッド

FinalPoseComplete | オーバロードされます。対話型グラフィックスの、キャッシュ内に保存された初期状態と、指定されたグラフィックスの現在の状態における差に基づいて、最終ポーズを計算します。入力 CogRectangleAffine のグラフィカルな操作をユーザが完了した後で、このメソッドの呼び出しが行われる、ということを前提としています。
FinalPosePrepare | 適切な対話型グラフィックスを作成し、その初期状態を説明する特定のデータをキャッシュに格納することによって、最終ポーズを計算するための準備を行います。
FinalPosePrepareRectangleAffine | 対話型アフィン矩形グラフィックスを作成し、その初期状態を説明する特定のデータをキャッシュに格納することによって、最終ポーズを計算するための準備を行います。
InitialPoseEstimate | 現在設定されている Font、FontRenderParams、および Text を使用して、希望するポーズの初期予測を計算します。この予測されたポーズは、指定された画像の中央内部に現在のテキストが容易に適合するように、現在のテキストのサイズ調整および位置決めを行います。計算されたポーズは、このメソッドによって返されるだけでなく、キャッシュ内にも保存されます。
OnDeserialization |
SetText | オーバロードされます。指定された文字列を使用して Text プロパティを設定します。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

プロテクトインスタンスコンストラクタ

CogOCVMaxPoseHelper オーバロードされます。CogOCVMaxPoseHelper クラスの新しいインスタンスを初期化します。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper コンストラクタ

オーバロードリスト

CogOCVMaxPoseHelper クラスの新しいインスタンスを初期化します。

public CogOCVMaxPoseHelper();

public CogOCVMaxPoseHelper(CogOCVMaxPoseHelper);

protected CogOCVMaxPoseHelper(SerializationInfo,StreamingContext);

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper コンストラクタ (SerializationInfo, StreamingContext)

protected CogOCVMaxPoseHelper(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPoseHelper コンストラクタオーバロードリスト


CogOCVMaxPoseHelper コンストラクタ (CogOCVMaxPoseHelper)

public CogOCVMaxPoseHelper(
CogOCVMaxPoseHelper pOther
);

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPoseHelper コンストラクタオーバロードリスト


CogOCVMaxPoseHelper コンストラクタ ()

CogOCVMaxPoseHelper クラスの新しいインスタンスを初期化します。

public CogOCVMaxPoseHelper();

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPoseHelper コンストラクタオーバロードリスト


CogOCVMaxPoseHelper フィールド

CogOCVMaxPoseHelper クラスのフィールドを次に示します。CogOCVMaxPoseHelper クラスメンバの完全なリストについては、「CogOCVMaxPoseHelper メンバ」を参照してください。

パブリックスタティックフィールド

SfFinalPoseData
SfFinalPosePrepared
SfFont
SfFontRenderParams
SfInitialPose
SfText

プロテクトスタティックフィールド

SfNextSf

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.SfFinalPoseData フィールド

public const long SfFinalPoseData;

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.SfFinalPosePrepared フィールド

public const long SfFinalPosePrepared;

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.SfFont フィールド

public const long SfFont;

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.SfFontRenderParams フィールド

public const long SfFontRenderParams;

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.SfInitialPose フィールド

public const long SfInitialPose;

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.SfNextSf フィールド

new protected const long SfNextSf;

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.SfText フィールド

public const long SfText;

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper プロパティ

CogOCVMaxPoseHelper クラスのプロパティを次に示します。CogOCVMaxPoseHelper クラスメンバの完全なリストについては、「CogOCVMaxPoseHelper メンバ」を参照してください。

パブリックインスタンスプロパティ

FinalPosePrepared | キャッシュ内に保存された内部データの正当性を取得します。このデータでは、最終ポーズを指定するためにユーザが操作するグラフィカルオブジェクトの初期状態が説明されています。このプロパティは、FinalPosePrepare() が正常に呼び出されることによって、true に設定されます。このプロパティは、Font が変更または修正された場合、FontRenderParams が変更または修正された場合、Text が変更された場合、および InitialPose が変更または修正された場合は、false に設定されます。FinalPoseComplete() を呼び出す前には、このプロパティは true である必要があります。
Font | 希望するポーズを計算するために使用されるフォントを取得または設定します。
FontRenderParams | 希望するポーズを計算するために使用される CogOCVMaxFontRenderParams を取得または設定します。
InitialPose | キャッシュ内に保存された InitialPose を取得または設定します。このプロパティ値は直接設定することもできますが、通常は、InitialPoseEstimate() メソッドの呼び出しによって設定されるようにすることが多いので注意してください。
Text | 希望するポーズを計算するために使用される実際のテキストを取得または設定します。このテキストは、Int32 の ArrayList (1 つ以上) の ArrayList として表されることに注意してください。外側の配列リストは 1 つ以上のエントリを保持し、各エントリは、1 つのパラグラフ内のテキスト行に対応しています。そのような各エントリそのものが ArrayList です。内側の各 ArrayList は、0 個以上の Int32 を保持します。各 Int32 エントリは、文字のキー値です。1 つの行は 0 個のエントリを持つこと (つまり、空であること) が可能ですが、パラグラフ内には少なくとも 1 つの文字がある必要があります。このセッタと同じ機能を提供し、希望するテキストのより便利な表現 (例えば、文字列の配列、1 つの文字列、または Int32 の配列) を受け入れる、いくつかの SetText メソッドがあることに注意してください。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.FinalPosePrepared プロパティ

キャッシュ内に保存された内部データの正当性を取得します。このデータでは、最終ポーズを指定するためにユーザが操作するグラフィカルオブジェクトの初期状態が説明されています。このプロパティは、FinalPosePrepare() が正常に呼び出されることによって、true に設定されます。このプロパティは、Font が変更または修正された場合、FontRenderParams が変更または修正された場合、Text が変更された場合、および InitialPose が変更または修正された場合は、false に設定されます。FinalPoseComplete() を呼び出す前には、このプロパティは true である必要があります。

public bool FinalPosePrepared {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.Font プロパティ

希望するポーズを計算するために使用されるフォントを取得または設定します。

public CogOCVMaxFont Font {get; set;}

プロパティ値

この読み取り/書き込みプロパティは、NULL であってはなりません。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | このプロパティを NULL に設定しようとした場合。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.FontRenderParams プロパティ

希望するポーズを計算するために使用される CogOCVMaxFontRenderParams を取得または設定します。

public CogOCVMaxFontRenderParams FontRenderParams {get; set;}

プロパティ値

この読み取り/書き込みプロパティは、NULL であってはなりません。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | このプロパティを NULL に設定しようとした場合。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.InitialPose プロパティ

キャッシュ内に保存された InitialPose を取得または設定します。このプロパティ値は直接設定することもできますが、通常は、InitialPoseEstimate() メソッドの呼び出しによって設定されるようにすることが多いので注意してください。

public Cognex.VisionPro.CogTransform2DLinear InitialPose {get; set;}

プロパティ値

この読み取り/書き込みプロパティは、CogTransform2DLinear タイプです。NULL であってはなりません。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | このプロパティを NULL に設定しようとした場合。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.Text プロパティ

希望するポーズを計算するために使用される実際のテキストを取得または設定します。このテキストは、Int32 の ArrayList (1 つ以上) の ArrayList として表されることに注意してください。外側の配列リストは 1 つ以上のエントリを保持し、各エントリは、1 つのパラグラフ内のテキスト行に対応しています。そのような各エントリそのものが ArrayList です。内側の各 ArrayList は、0 個以上の Int32 を保持します。各 Int32 エントリは、文字のキー値です。1 つの行は 0 個のエントリを持つこと (つまり、空であること) が可能ですが、パラグラフ内には少なくとも 1 つの文字がある必要があります。このセッタと同じ機能を提供し、希望するテキストのより便利な表現 (例えば、文字列の配列、1 つの文字列、または Int32 の配列) を受け入れる、いくつかの SetText メソッドがあることに注意してください。

public System.Collections.ArrayList Text {get; set;}

プロパティ値

この読み取り/書き込みプロパティは、Int32 の ArrayList (1 つ以上) の ArrayList である必要があります。少なくとも 1 つの Int32 エントリがある必要があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | このプロパティを NULL に設定しようとした場合。
ArgumentException | この引数に、指定外の構造の問題がある場合。
ArgumentOutOfRangeException | 少なくとも 1 つの Int32 (文字) エントリがない場合。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper メソッド

CogOCVMaxPoseHelper クラスのメソッドを次に示します。CogOCVMaxPoseHelper クラスメンバの完全なリストについては、「CogOCVMaxPoseHelper メンバ」を参照してください。

パブリックインスタンスメソッド

FinalPoseComplete | オーバロードされます。対話型グラフィックスの、キャッシュ内に保存された初期状態と、指定されたグラフィックスの現在の状態における差に基づいて、最終ポーズを計算します。入力 CogRectangleAffine のグラフィカルな操作をユーザが完了した後で、このメソッドの呼び出しが行われる、ということを前提としています。
FinalPosePrepare | 適切な対話型グラフィックスを作成し、その初期状態を説明する特定のデータをキャッシュに格納することによって、最終ポーズを計算するための準備を行います。
FinalPosePrepareRectangleAffine | 対話型アフィン矩形グラフィックスを作成し、その初期状態を説明する特定のデータをキャッシュに格納することによって、最終ポーズを計算するための準備を行います。
InitialPoseEstimate | 現在設定されている Font、FontRenderParams、および Text を使用して、希望するポーズの初期予測を計算します。この予測されたポーズは、指定された画像の中央内部に現在のテキストが容易に適合するように、現在のテキストのサイズ調整および位置決めを行います。計算されたポーズは、このメソッドによって返されるだけでなく、キャッシュ内にも保存されます。
OnDeserialization |
SetText | オーバロードされます。指定された文字列を使用して Text プロパティを設定します。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


FinalPoseComplete メソッド

VisionPro プログラミングリファレンス

CogOCVMaxPoseHelper.FinalPoseComplete メソッド

対話型グラフィックスの、キャッシュ内に保存された初期状態と、指定されたグラフィックスの現在の状態における差に基づいて、最終ポーズを計算します。入力 CogCompositeShape のグラフィカルな操作をユーザが完了した後で、このメソッドの呼び出しが行われる、ということを前提としています。

オーバロードリスト

対話型グラフィックスの、キャッシュ内に保存された初期状態と、指定されたグラフィックスの現在の状態における差に基づいて、最終ポーズを計算します。入力 CogCompositeShape のグラフィカルな操作をユーザが完了した後で、このメソッドの呼び出しが行われる、ということを前提としています。

public CogTransform2DLinear FinalPoseComplete(CogCompositeShape);

対話型グラフィックスの、キャッシュ内に保存された初期状態と、指定されたグラフィックスの現在の状態における差に基づいて、最終ポーズを計算します。入力 CogRectangleAffine のグラフィカルな操作をユーザが完了した後で、このメソッドの呼び出しが行われる、ということを前提としています。

public CogTransform2DLinear FinalPoseComplete(CogRectangleAffine);

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.FinalPoseComplete メソッド (CogCompositeShape)

対話型グラフィックスの、キャッシュ内に保存された初期状態と、指定されたグラフィックスの現在の状態における差に基づいて、最終ポーズを計算します。入力 CogCompositeShape のグラフィカルな操作をユーザが完了した後で、このメソッドの呼び出しが行われる、ということを前提としています。

public CogTransform2DLinear FinalPoseComplete(
CogCompositeShape pUpdatedGraphic
);

パラメータ

pUpdatedGraphic
FinalPosePrepare() の呼び出しによって生成され、次に、ユーザによってグラフィカルに操作された、CogCompositeShape。

戻り値

画像内でのテキストのサイジングおよび位置検出に使用される最終ポーズである CogTransform2DLinear。

例外

例外タイプ | 条件
ArgumentNullException | pUpdatedGraphic 引数が NULL の場合。
InvalidOperationException | 指定されたグラフィックスオブジェクトから、さまざまな参照データを抽出できない場合。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPoseHelper.FinalPoseComplete オーバロードリスト


CogOCVMaxPoseHelper.FinalPoseComplete メソッド (CogRectangleAffine)

対話型グラフィックスの、キャッシュ内に保存された初期状態と、指定されたグラフィックスの現在の状態における差に基づいて、最終ポーズを計算します。入力 CogRectangleAffine のグラフィカルな操作をユーザが完了した後で、このメソッドの呼び出しが行われる、ということを前提としています。

public CogTransform2DLinear FinalPoseComplete(
CogRectangleAffine pUpdatedGraphic
);

パラメータ

pUpdatedGraphic
FinalPosePrepareRectangleAffine() の呼び出しによって生成され、次に、ユーザによってグラフィカルに操作された、CogRectangleAffine。

戻り値

画像内でのテキストのサイジングおよび位置検出に使用される最終ポーズである CogTransform2DLinear。

例外

例外タイプ | 条件
InvalidOperationException | 最終ポーズを計算できない場合。
ArgumentNullException | pUpdatedGraphic 引数が NULL の場合。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPoseHelper.FinalPoseComplete オーバロードリスト


CogOCVMaxPoseHelper.FinalPosePrepare メソッド

適切な対話型グラフィックスを作成し、その初期状態を説明する特定のデータをキャッシュに格納することによって、最終ポーズを計算するための準備を行います。

public CogCompositeShape FinalPosePrepare();

戻り値

現在の Font および FontRenderParams プロパティを使用して描画される、Text プロパティのアウトラインを表す CogCompositeShape。このグラフィックスは、InitialPose プロパティに従って、サイズ調整および位置決めされています。

イベント

イベントタイプ | 理由
Changed | このメソッドが、対話型グラフィックスの初期状態を説明するキャッシュ内に保存されたデータと、FinalPosePrepared プロパティの両方またはどちらかを変更した場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | Font が (まだ) インポートされていない場合。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.FinalPosePrepareRectangleAffine メソッド

対話型アフィン矩形グラフィックスを作成し、その初期状態を説明する特定のデータをキャッシュに格納することによって、最終ポーズを計算するための準備を行います。

public CogRectangleAffine FinalPosePrepareRectangleAffine();

戻り値

現在の Font および FontRenderParams プロパティを使用して描画される、Text プロパティの境界を表す CogRectangleAffine。このグラフィックスは、InitialPose プロパティに従って、サイズ調整および位置決めされています。

イベント

イベントタイプ | 理由
Changed | このメソッドが、対話型グラフィックスの初期状態を説明するキャッシュ内に保存されたデータと、FinalPosePrepared プロパティの両方またはどちらかを変更した場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | Text プロパティがまだ設定されていない場合。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.InitialPoseEstimate メソッド

現在設定されている Font、FontRenderParams、および Text を使用して、希望するポーズの初期予測を計算します。この予測されたポーズは、指定された画像の中央内部に現在のテキストが容易に適合するように、現在のテキストのサイズ調整および位置決めを行います。計算されたポーズは、このメソッドによって返されるだけでなく、キャッシュ内にも保存されます。

public CogTransform2DLinear InitialPoseEstimate(
CogImage8Grey pImage
);

パラメータ

pImage
このポーズを計算するために使用される画像。これは、CogImage8Grey である必要があります。この上に、FinalPosePrepare または FinalPosePrepareRectangleAffine によって作成された対話型グラフィックスを表示します。

戻り値

FinalPosePrepare または FinalPosePrepareRectangleAffine のいずれかによって作成されたグラフィックスを、指定された画像の中央に入るようにサイズ調整および位置決めする、CogTransform2DLinear。

イベント

イベントタイプ | 理由
Changed | このメソッドが、InitialPose と FinalPosePrepared の両方またはどちらかのプロパティを変更した場合に発生します。

例外

例外タイプ | 条件
InvalidOperationException | Font が (まだ) インポートされていない場合。
ArgumentNullException | 指定された画像引数が NULL の場合。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.OnDeserialization メソッド

public override void OnDeserialization(
object sender
);

実装

IDeserializationCallback.OnDeserialization

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


SetText メソッド

VisionPro プログラミングリファレンス

CogOCVMaxPoseHelper.SetText メソッド

指定された文字列を使用して Text プロパティを設定します。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

オーバロードリスト

指定された文字列を使用して Text プロパティを設定します。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

public void SetText(int[]);

指定された文字列を使用して Text プロパティを設定します。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

public void SetText(string);

指定された文字列の配列を使用して Text プロパティを設定します。各配列要素は、パラグラフ内の行に対応しています。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

public void SetText(string[]);

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxPoseHelper.SetText メソッド (Int32[])

指定された文字列を使用して Text プロパティを設定します。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

public void SetText(
int[] srcText
);

パラメータ

srcText
ポーズの決定に使用されるテキスト。この整数の配列は文字キーのシーケンスとして解釈され、対応するテキストは 1 つのパラグラフ内の 1 つの行として解釈されます。

イベント

イベントタイプ | 理由
Changed | このメソッドが Text プロパティの変化を引き起こした場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | 表されている文字が少なくとも 1 つない場合。
ArgumentNullException | Text を NULL に設定しようとした場合。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPoseHelper.SetText オーバロードリスト


CogOCVMaxPoseHelper.SetText メソッド (String)

指定された文字列を使用して Text プロパティを設定します。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

public void SetText(
string srcText
);

パラメータ

srcText
ポーズの決定に使用されるテキスト。少なくとも 1 つの文字が含まれている必要があります。

イベント

イベントタイプ | 理由
Changed | このメソッドが Text プロパティの変化を引き起こした場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | 表されている文字が少なくとも 1 つない場合。
ArgumentNullException | Text を NULL に設定しようとした場合。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPoseHelper.SetText オーバロードリスト


CogOCVMaxPoseHelper.SetText メソッド (String[])

指定された文字列の配列を使用して Text プロパティを設定します。各配列要素は、パラグラフ内の行に対応しています。フォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

public void SetText(
string[] srcText
);

パラメータ

srcText
ポーズの決定に使用されるテキスト。各配列要素は、1 つのパラグラフ内の別の行として解釈されます。

イベント

イベントタイプ | 理由
Changed | このメソッドが Text プロパティの変化を引き起こした場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | 入力引数によって表される行の数が 1 未満の場合。
ArgumentNullException | Text を NULL に設定しようとした場合。

参照

CogOCVMaxPoseHelper クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxPoseHelper.SetText オーバロードリスト


CogOCVMaxRefinementConstants 列挙体

特定の文字の変位を表す変換に対して行われる、最適化の量を指定するために使用される定数です。

public enum CogOCVMaxRefinementConstants

メンバ

メンバ名 | 説明
Fine | Stretch を使用する場合と同様に変換は最適化されますが、高い精度までさらに最適化されます。
Stretch | Coarse を使用する場合と同様に変換は最適化されますが、高レベルの不正確さ (文字の極端なワーピング) を解決するようにさらに最適化されます。
Coarse | 変換は、限られた精度まで最適化されます。
None | 最適化を実行しません。変換に少量のエラーが含まれる場合があります。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxResult クラス

このクラスは、パターン全体についての結果情報のすべてを保持します。

このタイプのメンバすべてのリストについては、「CogOCVMaxResult メンバ」を参照してください。

System.Object
MarshalByRefObject
CogObjectBase
CogSerializableObjectBase
CogOCVMaxResult

public class CogOCVMaxResult :CogSerializableObjectBase, ICogRecordConstructor

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxResult メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxResult メンバ

CogOCVMaxResult の概要

パブリックインスタンスコンストラクタ

CogOCVMaxResult オーバロードされます。CogOCVMaxResult クラスの新しいインスタンスを初期化します。

パブリックインスタンスプロパティ

ArrangementSelectedPose | 選択空間内での、配置全体のポーズです。このプロパティは、ArrangementSelectedPoseValid が true の場合のみ有効であることに注意してください。
ArrangementSelectedPoseValid | 選択空間内での、配置全体のポーズが、正常に計算されたかどうかを示します。
NumParagraphsVerified | この配置内の、検証されたパラグラフの数です。
ParagraphResults | パラグラフ結果の System::Array です。検証が試みられた各パラグラフについて 1 つ存在します。
TimedOut | この結果の生成中にオペレータがタイムアウトしたかどうかを示します。true の場合、これらの結果は不完全とみなされる必要があります。
VerificationFullViolations | 検証フル違反を示します。
VerificationKeyViolations | 検証キー違反を示します。
VerificationScore | 配置の総合得点です。これは、オペレータが検証を試みたすべてのパラグラフの得点を平均した値です。
Verified | この配置内のすべての文字位置が検証されたかどうかを示します。

プロテクトインスタンスコンストラクタ

CogOCVMaxResult オーバロードされます。CogOCVMaxResult クラスの新しいインスタンスを初期化します。

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxResult コンストラクタ

オーバロードリスト

指定された CogOCVMaxResult オブジェクトのディープコピーを構築します。

public CogOCVMaxResult(CogOCVMaxResult);

protected CogOCVMaxResult(SerializationInfo,StreamingContext);

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxResult コンストラクタ (SerializationInfo, StreamingContext)

protected CogOCVMaxResult(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxResult コンストラクタオーバロードリスト


CogOCVMaxResult コンストラクタ (CogOCVMaxResult)

指定された CogOCVMaxResult オブジェクトのディープコピーを構築します。

public CogOCVMaxResult(
CogOCVMaxResult pOther
);

パラメータ

pOther
コピーされる CogOCVMaxResult オブジェクト。NULL であってはなりません。

例外

例外タイプ | 条件
OutOfMemoryException | このオブジェクトにメモリを割り当てることができない場合。
ArgumentNullException | 入力引数が NULL の場合。

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxResult コンストラクタオーバロードリスト


CogOCVMaxResult プロパティ

CogOCVMaxResult クラスのプロパティを次に示します。CogOCVMaxResult クラスメンバの完全なリストについては、「CogOCVMaxResult メンバ」を参照してください。

パブリックインスタンスプロパティ

ArrangementSelectedPose | 選択空間内での、配置全体のポーズです。このプロパティは、ArrangementSelectedPoseValid が true の場合のみ有効であることに注意してください。
ArrangementSelectedPoseValid | 選択空間内での、配置全体のポーズが、正常に計算されたかどうかを示します。
NumParagraphsVerified | この配置内の、検証されたパラグラフの数です。
ParagraphResults | パラグラフ結果の System::Array です。検証が試みられた各パラグラフについて 1 つ存在します。
TimedOut | この結果の生成中にオペレータがタイムアウトしたかどうかを示します。true の場合、これらの結果は不完全とみなされる必要があります。
VerificationFullViolations | 検証フル違反を示します。
VerificationKeyViolations | 検証キー違反を示します。
VerificationScore | 配置の総合得点です。これは、オペレータが検証を試みたすべてのパラグラフの得点を平均した値です。
Verified | この配置内のすべての文字位置が検証されたかどうかを示します。

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxResult.ArrangementSelectedPose プロパティ

選択空間内での、配置全体のポーズです。このプロパティは、ArrangementSelectedPoseValid が true の場合のみ有効であることに注意してください。

public Cognex.VisionPro.CogTransform2DLinear ArrangementSelectedPose {get;}

プロパティ値

この読み取り専用プロパティは、CogTransform2DLinear タイプです。

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxResult.ArrangementSelectedPoseValid プロパティ

選択空間内での、配置全体のポーズが、正常に計算されたかどうかを示します。

public bool ArrangementSelectedPoseValid {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxResult.NumParagraphsVerified プロパティ

この配置内の、検証されたパラグラフの数です。

public int NumParagraphsVerified {get;}

プロパティ値

System::Int32 タイプの、この読み取り専用プロパティは、ゼロ以上になります。

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxResult.ParagraphResults プロパティ

パラグラフ結果の System::Array です。検証が試みられた各パラグラフについて 1 つ存在します。

public CogOCVMaxParagraphResult[] ParagraphResults {get;}

プロパティ値

この読み取り専用プロパティは、CogOCVMaxParagraph の System::Array タイプです。

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxResult.TimedOut プロパティ

この結果の生成中にオペレータがタイムアウトしたかどうかを示します。true の場合、これらの結果は不完全とみなされる必要があります。

public bool TimedOut {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxResult.VerificationFullViolations プロパティ

検証フル違反を示します。

public CogOCVMaxDOFConstants VerificationFullViolations {get;}

プロパティ値

この読み取り専用プロパティは、この配置内における、すべてのパラグラフ内にあるすべての行内の、文字のすべてに関する、CogOCVMaxDOFConstants のビット単位の OR です。

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxResult.VerificationKeyViolations プロパティ

検証キー違反を示します。

public CogOCVMaxDOFConstants VerificationKeyViolations {get;}

プロパティ値

この読み取り専用プロパティは、この配置内における、すべてのパラグラフ内にあるすべての行内の、文字のすべてに関する、CogOCVMaxDOFConstants のビット単位の OR です。

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxResult.VerificationScore プロパティ

配置の総合得点です。これは、オペレータが検証を試みたすべてのパラグラフの得点を平均した値です。

public double VerificationScore {get;}

プロパティ値

System::Double タイプの、この読み取り専用プロパティは、0 (最悪) ～ 1 (最良) の範囲になります。

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxResult.Verified プロパティ

この配置内のすべての文字位置が検証されたかどうかを示します。

public bool Verified {get;}

プロパティ値

この読み取り専用プロパティは、Boolean タイプです。

参照

CogOCVMaxResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams クラス

このクラスは、CogOCVMaxPattern::Execute メソッドによって使用される実行時パラメータをカプセル化します。

このタイプのメンバすべてのリストについては、「CogOCVMaxRunParams メンバ」を参照してください。

System.Object
MarshalByRefObject
CogObjectBase
CogSerializableObjectBase
CogSerializableChangedEventBase
CogOCVMaxRunParams

public class CogOCVMaxRunParams :CogSerializableChangedEventBase, IDisposable

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxRunParams メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams メンバ

CogOCVMaxRunParams の概要

パブリックスタティックフィールド

SfComputePoses
SfEarlyAcceptThreshold
SfEarlyFailThreshold
SfGetCharacterCount
SfGetConfidenceThreshold
SfGetConfusionThreshold
SfGetKeysetCharacterKeys
SfGetLineCount
SfGetParagraphCount
SfGetVerificationType
SfImageSearchParams
SfKeySearchParams
SfRegionMode
SfRunPose
SfStartPoseSearchParams
SfTimeout
SfTimeoutEnabled

プロテクトスタティックフィールド

SfNextSf

パブリックインスタンスコンストラクタ

CogOCVMaxRunParams オーバロードされます。CogOCVMaxRunParams クラスの新しいインスタンスを初期化します。

パブリックインスタンスプロパティ

ComputePoses | 計算される結果ポーズを取得または設定します。
EarlyAcceptThreshold | 画像内にある行の実際のインスタンスとしての潜在的な行一致を、早期容認するためのしきい値を取得または設定します。
EarlyFailThreshold | 画像内にある行の実際のインスタンスとしての潜在的な行一致を、早期エラーとするためのしきい値を取得または設定します。
ImageSearchParams | 画像内のパターンアライメントのために使用されるサーチパラメータを取得または設定します。
KeySearchParams | 隣接する文字を基準にした、各キーセットのアライメントに使用されるサーチパラメータを取得または設定します。
RegionMode | Execute の pRegion パラメータが、入力画像に適用される方法を取得または設定します。
RunPose | このプロパティが NULL ではない場合、サーチ処理では、このポーズの非常に近くで文字列が検出されると仮定されます。
StartPoseSearchParams | 実行ポーズが使用されている場合に、画像内のパターンアライメントのために使用されるサーチパラメータを取得または設定します。
Timeout | チューニング実行の所要時間として可能な、最大限の時間 (ミリ秒単位) を取得または設定します。
TimeoutEnabled | これらの実行パラメータを使用して実行中またはチューニング中の場合に、パターンがタイムアウトできるかどうかを取得または設定します。

パブリックインスタンスメソッド

Dispose | オーバロードされます。
GetCharacterCount | オーバロードされます。このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフの、指定された行内にある文字の数を取得します。
GetConfidenceThreshold | オーバロードされます。指定されたパラグラフの信頼性しきい値を取得します。
GetConfusionThreshold | オーバロードされます。指定されたパラグラフのコンフュージョンしきい値を取得します。
GetKeysetCharacterKeys | オーバロードされます。指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、整数配列を取得します。この配列の各要素は、この位置で発生する可能性がある文字のキー値です。
GetKeysetCharacters | オーバロードされます。指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、文字列を取得します。この文字列内の各個別の文字が、この位置で発生する可能性があります。
GetLineCount | オーバロードされます。このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフ内にある行の数を取得します。
GetParagraphCount | この実行パラメータオブジェクトによって説明されているパラグラフの数を取得します。
GetVerificationType | オーバロードされます。指定された文字位置に対して実行される検証のタイプを取得します。
SetArrangementFromPattern | 指定されたパターンから、この実行パラメータオブジェクト内に、配置をコピーします。
SetConfidenceThreshold | オーバロードされます。指定されたパラグラフの信頼性しきい値を設定します。
SetConfusionThreshold | オーバロードされます。指定されたパラグラフのコンフュージョンしきい値を設定します。
SetKeyset | オーバロードされます。指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットを設定します。
SetVerificationType | オーバロードされます。指定された文字位置に対して実行される検証のタイプを設定します。

プロテクトインスタンスコンストラクタ

CogOCVMaxRunParams オーバロードされます。CogOCVMaxRunParams クラスの新しいインスタンスを初期化します。

プロテクトインスタンスメソッド

__dtor |
Dispose | オーバロードされます。
Finalize |
GetObjectData |

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams コンストラクタ

オーバロードリスト

CogOCVMaxRunParams クラスの新しいインスタンスを初期化します。

public CogOCVMaxRunParams();

public CogOCVMaxRunParams(CogOCVMaxRunParams);

protected CogOCVMaxRunParams(SerializationInfo,StreamingContext);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams コンストラクタ (SerializationInfo, StreamingContext)

protected CogOCVMaxRunParams(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams コンストラクタオーバロードリスト


CogOCVMaxRunParams コンストラクタ (CogOCVMaxRunParams)

public CogOCVMaxRunParams(
CogOCVMaxRunParams pOther
);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams コンストラクタオーバロードリスト


CogOCVMaxRunParams コンストラクタ ()

CogOCVMaxRunParams クラスの新しいインスタンスを初期化します。

public CogOCVMaxRunParams();

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams コンストラクタオーバロードリスト


CogOCVMaxRunParams フィールド

CogOCVMaxRunParams クラスのフィールドを次に示します。CogOCVMaxRunParams クラスメンバの完全なリストについては、「CogOCVMaxRunParams メンバ」を参照してください。

パブリックスタティックフィールド

SfComputePoses
SfEarlyAcceptThreshold
SfEarlyFailThreshold
SfGetCharacterCount
SfGetConfidenceThreshold
SfGetConfusionThreshold
SfGetKeysetCharacterKeys
SfGetLineCount
SfGetParagraphCount
SfGetVerificationType
SfImageSearchParams
SfKeySearchParams
SfRegionMode
SfRunPose
SfStartPoseSearchParams
SfTimeout
SfTimeoutEnabled

プロテクトスタティックフィールド

SfNextSf

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfComputePoses フィールド

public const long SfComputePoses;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfEarlyAcceptThreshold フィールド

public const long SfEarlyAcceptThreshold;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfEarlyFailThreshold フィールド

public const long SfEarlyFailThreshold;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfGetCharacterCount フィールド

public const long SfGetCharacterCount;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfGetConfidenceThreshold フィールド

public const long SfGetConfidenceThreshold;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfGetConfusionThreshold フィールド

public const long SfGetConfusionThreshold;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfGetKeysetCharacterKeys フィールド

public const long SfGetKeysetCharacterKeys;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfGetLineCount フィールド

public const long SfGetLineCount;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfGetParagraphCount フィールド

public const long SfGetParagraphCount;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfGetVerificationType フィールド

public const long SfGetVerificationType;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfImageSearchParams フィールド

public const long SfImageSearchParams;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfKeySearchParams フィールド

public const long SfKeySearchParams;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfNextSf フィールド

new protected const long SfNextSf;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfRegionMode フィールド

public const long SfRegionMode;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfRunPose フィールド

public const long SfRunPose;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfStartPoseSearchParams フィールド

public const long SfStartPoseSearchParams;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfTimeout フィールド

public const long SfTimeout;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SfTimeoutEnabled フィールド

public const long SfTimeoutEnabled;

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams プロパティ

CogOCVMaxRunParams クラスのプロパティを次に示します。CogOCVMaxRunParams クラスメンバの完全なリストについては、「CogOCVMaxRunParams メンバ」を参照してください。

パブリックインスタンスプロパティ

ComputePoses | 計算される結果ポーズを取得または設定します。
EarlyAcceptThreshold | 画像内にある行の実際のインスタンスとしての潜在的な行一致を、早期容認するためのしきい値を取得または設定します。
EarlyFailThreshold | 画像内にある行の実際のインスタンスとしての潜在的な行一致を、早期エラーとするためのしきい値を取得または設定します。
ImageSearchParams | 画像内のパターンアライメントのために使用されるサーチパラメータを取得または設定します。
KeySearchParams | 隣接する文字を基準にした、各キーセットのアライメントに使用されるサーチパラメータを取得または設定します。
RegionMode | Execute の pRegion パラメータが、入力画像に適用される方法を取得または設定します。
RunPose | このプロパティが NULL ではない場合、サーチ処理では、このポーズの非常に近くで文字列が検出されると仮定されます。
StartPoseSearchParams | 実行ポーズが使用されている場合に、画像内のパターンアライメントのために使用されるサーチパラメータを取得または設定します。
Timeout | チューニング実行の所要時間として可能な、最大限の時間 (ミリ秒単位) を取得または設定します。
TimeoutEnabled | これらの実行パラメータを使用して実行中またはチューニング中の場合に、パターンがタイムアウトできるかどうかを取得または設定します。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.ComputePoses プロパティ

計算される結果ポーズを取得または設定します。

public CogOCVMaxComputePosesConstants ComputePoses {get; set;}

プロパティ値

計算される結果ポーズ。

解説

計算するポーズは、CogOCVMaxComputePosesConstants 値のビット単位の OR として指定されます。文字位置は必ず計算されます。

ポーズの計算は、追加の実行時間を要するため、すべてのアプリケーションで必要とされるとは限りません。

計算されないポーズによって、対応する「PoseValid」プロパティは false を返すようになります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.EarlyAcceptThreshold プロパティ

画像内にある行の実際のインスタンスとしての潜在的な行一致を、早期容認するためのしきい値を取得または設定します。

public double EarlyAcceptThreshold {get; set;}

プロパティ値

画像内にある行の実際のインスタンスとしての潜在的な行一致を、早期容認するためのしきい値。

解説

行内の一致している (つまり、Verified または Confused の) キーのパーセンテージが、このしきい値よりも大きい場合は、行に対するサーチはこれ以上実行されません。実行時画像内に不要な文字がないことがわかっている場合 (例えば、画像内のテキストは、検証される文字列のみであることがわかっている場合)、これによりサーチ処理が高速化されます。

この値は、0.0 ～ 1.0 の範囲である必要があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | このプロパティを 0 未満または 1 より大きな値に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.EarlyFailThreshold プロパティ

画像内にある行の実際のインスタンスとしての潜在的な行一致を、早期エラーとするためのしきい値を取得または設定します。

public double EarlyFailThreshold {get; set;}

プロパティ値

画像内にある行の実際のインスタンスとしての潜在的な行一致を、早期エラーとするためのしきい値。

解説

行内の一致している (つまり、Verified または Confused の) キーのパーセンテージが、このしきい値よりも小さい場合は、潜在的な行を含む画像の部分はこれ以上考慮されません。画像が完全で、欠落した文字や大きく損傷した文字がないことがわかっている場合は、これによりサーチ処理が高速化されます。

この値は、0.0 ～ 1.0 の範囲である必要があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | このプロパティを 0 未満または 1 より大きな値に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.ImageSearchParams プロパティ

画像内のパターンアライメントのために使用されるサーチパラメータを取得または設定します。

public CogOCVMaxSearchParams ImageSearchParams {get; set;}

プロパティ値

画像内のパターンアライメントのために使用されるサーチパラメータ。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | このプロパティを NULL に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.KeySearchParams プロパティ

隣接する文字を基準にした、各キーセットのアライメントに使用されるサーチパラメータを取得または設定します。

public CogOCVMaxSearchParams KeySearchParams {get; set;}

プロパティ値

隣接する文字を基準にした、各キーセットのアライメントに使用されるサーチパラメータ。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | このプロパティを NULL に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.RegionMode プロパティ

Execute の pRegion パラメータが、入力画像に適用される方法を取得または設定します。

public Cognex.VisionPro.CogRegionModeConstants RegionMode {get; set;}

プロパティ値

CogRegionModeConstants タイプの、この読み取り/書き込みプロパティは、PixelAlignedBoundingBox または AffineTransform のいずれかであることが可能です。

解説

領域モードは、PixelAlignedBoundingBox または AffineTransform のいずれかであることが可能です。

領域が NULL の場合、このプロパティは無視されます。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | このプロパティを、PixelAlignedBounding または AffineTransform 以外の値に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.RunPose プロパティ

このプロパティが NULL ではない場合、サーチ処理では、このポーズの非常に近くで文字列が検出されると仮定されます。

public Cognex.VisionPro.CogTransform2DLinear RunPose {get; set;}

プロパティ値

文字列に非常に近いポーズ。

解説

実行ポーズを提供すると、OCVMax ツールは、最初に画像全体をサーチする必要がなくなるため、はるかに高速に実行できるようになります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.StartPoseSearchParams プロパティ

実行ポーズが使用されている場合に、画像内のパターンアライメントのために使用されるサーチパラメータを取得または設定します。

public CogOCVMaxSearchParams StartPoseSearchParams {get; set;}

プロパティ値

実行ポーズが使用されている場合に、画像内のパターンアライメントのために使用されるサーチパラメータ。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | このプロパティを NULL に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.Timeout プロパティ

チューニング実行の所要時間として可能な、最大限の時間 (ミリ秒単位) を取得または設定します。

public double Timeout {get; set;}

プロパティ値

チューニング実行の所要時間として可能な、最大限の時間 (ミリ秒単位)。

解説

TimeoutEnabled の場合、このプロパティは、Execute または Tune によるチューニング実行の最大限の時間 (ミリ秒単位) であり、この時間を超えると処理は停止します。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | このプロパティをゼロ以下の値に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.TimeoutEnabled プロパティ

これらの実行パラメータを使用して実行中またはチューニング中の場合に、パターンがタイムアウトできるかどうかを取得または設定します。

public bool TimeoutEnabled {get; set;}

プロパティ値

パターンがタイムアウトできるかどうか。

解説

実行がタイムアウトした場合、Execute は不完全な結果を返すことがあります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams メソッド

CogOCVMaxRunParams クラスのメソッドを次に示します。CogOCVMaxRunParams クラスメンバの完全なリストについては、「CogOCVMaxRunParams メンバ」を参照してください。

パブリックインスタンスメソッド

Dispose | オーバロードされます。
GetCharacterCount | オーバロードされます。このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフの、指定された行内にある文字の数を取得します。
GetConfidenceThreshold | オーバロードされます。指定されたパラグラフの信頼性しきい値を取得します。
GetConfusionThreshold | オーバロードされます。指定されたパラグラフのコンフュージョンしきい値を取得します。
GetKeysetCharacterKeys | オーバロードされます。指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、整数配列を取得します。この配列の各要素は、この位置で発生する可能性がある文字のキー値です。
GetKeysetCharacters | オーバロードされます。指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、文字列を取得します。この文字列内の各個別の文字が、この位置で発生する可能性があります。
GetLineCount | オーバロードされます。このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフ内にある行の数を取得します。
GetParagraphCount | この実行パラメータオブジェクトによって説明されているパラグラフの数を取得します。
GetVerificationType | オーバロードされます。指定された文字位置に対して実行される検証のタイプを取得します。
SetArrangementFromPattern | 指定されたパターンから、この実行パラメータオブジェクト内に、配置をコピーします。
SetConfidenceThreshold | オーバロードされます。指定されたパラグラフの信頼性しきい値を設定します。
SetConfusionThreshold | オーバロードされます。指定されたパラグラフのコンフュージョンしきい値を設定します。
SetKeyset | オーバロードされます。指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットを設定します。
SetVerificationType | オーバロードされます。指定された文字位置に対して実行される検証のタイプを設定します。

プロテクトインスタンスメソッド

__dtor |
Dispose | オーバロードされます。
Finalize |
GetObjectData |

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.__dtor メソッド

protected void __dtor();

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


Dispose メソッド

VisionPro プログラミングリファレンス

CogOCVMaxRunParams.Dispose メソッド

オーバロードリスト

public override void Dispose();

protected virtual void Dispose(bool);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.Dispose メソッド ()

public override void Dispose();

実装

IDisposable.Dispose

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.Dispose オーバロードリスト


CogOCVMaxRunParams.Dispose メソッド (Boolean)

protected virtual void Dispose(
bool bDisposing
);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.Dispose オーバロードリスト


CogOCVMaxRunParams.Finalize メソッド

protected override void Finalize();

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


GetCharacterCount メソッド

VisionPro プログラミングリファレンス

CogOCVMaxRunParams.GetCharacterCount メソッド

このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフの、指定された行内にある文字の数を取得します。

オーバロードリスト

このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフの、指定された行内にある文字の数を取得します。

public int GetCharacterCount(CogOCVMaxLineIterator);

このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフの、指定された行内にある文字の数を取得します。

public int GetCharacterCount(int,int);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.GetCharacterCount メソッド (CogOCVMaxLineIterator)

このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフの、指定された行内にある文字の数を取得します。

public int GetCharacterCount(
CogOCVMaxLineIterator pLI
);

パラメータ

pLI
対象の行を示す行繰り返し指定子。

戻り値

行内の文字の数。

解説

この値は、通常、SetArrangementFromPattern の呼び出しによって設定されます。

例外

例外タイプ | 条件
ArgumentNullException | 指定された引数が NULL の場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetCharacterCount オーバロードリスト


CogOCVMaxRunParams.GetCharacterCount メソッド (Int32, Int32)

このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフの、指定された行内にある文字の数を取得します。

public int GetCharacterCount(
int paragraphPosition,
int linePosition
);

パラメータ

paragraphPosition
対象のパラグラフの位置を指定する、ゼロベースのインデックス。
linePosition
対象のパラグラフ内にある、対象の行の位置を指定する、ゼロベースのインデックス。

戻り値

行内の文字の数。

解説

この値は、通常、SetArrangementFromPattern の呼び出しによって設定されます。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | paragraphPosition 引数が、0 より小さいか、またはこの CogOCVMaxRunParams オブジェクト内で説明されているパラグラフの数以上である場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetCharacterCount オーバロードリスト


GetConfidenceThreshold メソッド

VisionPro プログラミングリファレンス

CogOCVMaxRunParams.GetConfidenceThreshold メソッド

指定されたパラグラフの信頼性しきい値を取得します。

オーバロードリスト

指定されたパラグラフの信頼性しきい値を取得します。

public double GetConfidenceThreshold(CogOCVMaxParagraphIterator);

指定されたパラグラフの信頼性しきい値を取得します。

public double GetConfidenceThreshold(int);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.GetConfidenceThreshold メソッド (CogOCVMaxParagraphIterator)

指定されたパラグラフの信頼性しきい値を取得します。

public double GetConfidenceThreshold(
CogOCVMaxParagraphIterator pPI
);

パラメータ

pPI
対象のパラグラフを示すパラグラフ繰り返し指定子。

戻り値

0.0 ～ 1.0 の範囲の信頼性しきい値。

解説

このしきい値は、現在のキーセット内にある最高得点の文字の得点が、キーセット内の任意の文字とのコンフュージョン得点 (ゼロ以外) を持つ、最高得点の文字を超えている必要がある量です。

紛らわしさが発生する可能性のある文字が、最高得点のキーセットメンバよりも高い得点を持っている場合、ステータス結果は常に「Confused」となりますが、返されるキーは、紛らわしさが発生しているキーではなく、依然としてキーセットからのキーになることに注意してください。ConfusionThreshold テストに合格したキーのみが、この得点付けまたは検証ステップで考慮されることに注意してください。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentNullException | 指定された引数が NULL の場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetConfidenceThreshold オーバロードリスト


CogOCVMaxRunParams.GetConfidenceThreshold メソッド (Int32)

指定されたパラグラフの信頼性しきい値を取得します。

public double GetConfidenceThreshold(
int paragraphPosition
);

パラメータ

paragraphPosition
対象のパラグラフの位置を指定する、ゼロベースのインデックス。

戻り値

0.0 ～ 1.0 の範囲の信頼性しきい値。

解説

このしきい値は、現在のキーセット内にある最高得点の文字の得点が、キーセット内の任意の文字とのコンフュージョン得点 (ゼロ以外) を持つ、最高得点の文字を超えている必要がある量です。

紛らわしさが発生する可能性のある文字が、最高得点のキーセットメンバよりも高い得点を持っている場合、ステータス結果は常に「Confused」となりますが、返されるキーは、紛らわしさが発生しているキーではなく、依然としてキーセットからのキーになることに注意してください。ConfusionThreshold テストに合格したキーのみが、この得点付けまたは検証ステップで考慮されることに注意してください。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | paragraphPosition 引数が、0 より小さいか、またはこの CogOCVMaxRunParams オブジェクト内で説明されているパラグラフの数以上である場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetConfidenceThreshold オーバロードリスト


GetConfusionThreshold メソッド

VisionPro プログラミングリファレンス

CogOCVMaxRunParams.GetConfusionThreshold メソッド

指定されたパラグラフのコンフュージョンしきい値を取得します。

オーバロードリスト

指定されたパラグラフのコンフュージョンしきい値を取得します。

public double GetConfusionThreshold(CogOCVMaxParagraphIterator);

指定されたパラグラフのコンフュージョンしきい値を取得します。

public double GetConfusionThreshold(int);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.GetConfusionThreshold メソッド (CogOCVMaxParagraphIterator)

指定されたパラグラフのコンフュージョンしきい値を取得します。

public double GetConfusionThreshold(
CogOCVMaxParagraphIterator pPI
);

パラメータ

pPI
対象のパラグラフを示すパラグラフ繰り返し指定子。

戻り値

0.0 ～ 1.0 の範囲のコンフュージョンしきい値。

解説

各パラグラフは、登録時にコンフュージョンマトリックスを構築します。このマトリックスは、パラグラフのフォントアルファベットの各キーペアについて、2 つのキーでどの程度紛らわしさが発生しやすいかを示す数を保持します。1.0 に近い値では、紛らわしさが非常に発生しやすく (例えば、「5」と「S」)、0 に近い値では、紛らわしさは発生しやすくありません (「1」と「5」)。

コンフュージョンしきい値で指定される値未満では、OCVMax が、紛らわしさを検査するために、ほかのキーを考慮することはありません。例えば、OCVMax は、「5」の検出を予想している場合、ほかの紛らわしさが発生する可能性のあるキーもチェックして、それらのキーもよく一致しているか確認します。コンフュージョンしきい値 0.9 では、「S」および「6」のキーは試される可能性がありますが、「1」は試されません。しきい値 0.4 では、「E」や「8」など、ある程度類似した多くのキーが試されます。しきい値が 0 の場合は、すべてのキーが試されます。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentNullException | 指定された引数が NULL の場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetConfusionThreshold オーバロードリスト


CogOCVMaxRunParams.GetConfusionThreshold メソッド (Int32)

指定されたパラグラフのコンフュージョンしきい値を取得します。

public double GetConfusionThreshold(
int paragraphPosition
);

パラメータ

paragraphPosition
対象のパラグラフの位置を指定する、ゼロベースのインデックス。

戻り値

0.0 ～ 1.0 の範囲のコンフュージョンしきい値。

解説

各パラグラフは、登録時にコンフュージョンマトリックスを構築します。このマトリックスは、パラグラフのフォントアルファベットの各キーペアについて、2 つのキーでどの程度紛らわしさが発生しやすいかを示す数を保持します。1.0 に近い値では、紛らわしさが非常に発生しやすく (例えば、「5」と「S」)、0 に近い値では、紛らわしさは発生しやすくありません (「1」と「5」)。

コンフュージョンしきい値で指定される値未満では、OCVMax が、紛らわしさを検査するために、ほかのキーを考慮することはありません。例えば、OCVMax は、「5」の検出を予想している場合、ほかの紛らわしさが発生する可能性のあるキーもチェックして、それらのキーもよく一致しているか確認します。コンフュージョンしきい値 0.9 では、「S」および「6」のキーは試される可能性がありますが、「1」は試されません。しきい値 0.4 では、「E」や「8」など、ある程度類似した多くのキーが試されます。しきい値が 0 の場合は、すべてのキーが試されます。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | paragraphPosition 引数が、0 より小さいか、またはこの CogOCVMaxRunParams オブジェクト内で説明されているパラグラフの数以上である場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetConfusionThreshold オーバロードリスト


GetKeysetCharacterKeys メソッド

VisionPro プログラミングリファレンス

CogOCVMaxRunParams.GetKeysetCharacterKeys メソッド

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、整数配列を取得します。この配列の各要素は、この位置で発生する可能性がある文字のキー値です。

オーバロードリスト

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、整数配列を取得します。この配列の各要素は、この位置で発生する可能性がある文字のキー値です。

public int[] GetKeysetCharacterKeys(CogOCVMaxCharacterIterator);

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、整数配列を取得します。この配列の各要素は、この位置で発生する可能性がある文字のキー値です。

public int[] GetKeysetCharacterKeys(int,int,int);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.GetKeysetCharacterKeys メソッド (CogOCVMaxCharacterIterator)

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、整数配列を取得します。この配列の各要素は、この位置で発生する可能性がある文字のキー値です。

public int[] GetKeysetCharacterKeys(
CogOCVMaxCharacterIterator pCI
);

パラメータ

pCI
対象の文字位置を指定する文字繰り返し指定子。

戻り値

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、整数配列。この配列のサイズは、この位置で発生する可能性がある異なる文字の数に一致します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentNullException | 指定された引数が NULL の場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetKeysetCharacterKeys オーバロードリスト


CogOCVMaxRunParams.GetKeysetCharacterKeys メソッド (Int32, Int32, Int32)

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、整数配列を取得します。この配列の各要素は、この位置で発生する可能性がある文字のキー値です。

public int[] GetKeysetCharacterKeys(
int paragraphPosition,
int linePosition,
int characterPosition
);

パラメータ

paragraphPosition
対象のパラグラフの位置を指定する、ゼロベースのインデックス。
linePosition
対象のパラグラフ内にある、対象の行の位置を指定する、ゼロベースのインデックス。
characterPosition
対象のパラグラフ内、対象の行内の、対象の文字位置を指定する、ゼロベースのインデックス。

戻り値

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、整数配列。この配列のサイズは、この位置で発生する可能性がある異なる文字の数に一致します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | characterPosition 引数が、0 より小さいか、またはこの CogOCVMaxRunParams オブジェクト内で説明されている、指定されたパラグラフ内、指定された行内の文字数以上である場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetKeysetCharacterKeys オーバロードリスト


GetKeysetCharacters メソッド

VisionPro プログラミングリファレンス

CogOCVMaxRunParams.GetKeysetCharacters メソッド

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、文字列を取得します。この文字列内の各個別の文字が、この位置で発生する可能性があります。

オーバロードリスト

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、文字列を取得します。この文字列内の各個別の文字が、この位置で発生する可能性があります。

public string GetKeysetCharacters(CogOCVMaxCharacterIterator);

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、文字列を取得します。この文字列内の各個別の文字が、この位置で発生する可能性があります。

public string GetKeysetCharacters(int,int,int);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.GetKeysetCharacters メソッド (CogOCVMaxCharacterIterator)

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、文字列を取得します。この文字列内の各個別の文字が、この位置で発生する可能性があります。

public string GetKeysetCharacters(
CogOCVMaxCharacterIterator pCI
);

パラメータ

pCI
対象の文字位置を指定する文字繰り返し指定子。

戻り値

文字列。この中の各文字は、この位置のためのキーセットのメンバに対応しています。

解説

返される文字列内の任意の 1 文字が、指定された位置で観察される可能性があります。このメソッドでは、このフォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentNullException | 指定された引数が NULL の場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetKeysetCharacters オーバロードリスト


CogOCVMaxRunParams.GetKeysetCharacters メソッド (Int32, Int32, Int32)

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットに対応する、文字列を取得します。この文字列内の各個別の文字が、この位置で発生する可能性があります。

public string GetKeysetCharacters(
int paragraphPosition,
int linePosition,
int characterPosition
);

パラメータ

paragraphPosition
対象のパラグラフの位置を指定する、ゼロベースのインデックス。
linePosition
対象のパラグラフ内にある、対象の行の位置を指定する、ゼロベースのインデックス。
characterPosition
対象のパラグラフ内、対象の行内の、対象の文字位置を指定する、ゼロベースのインデックス。

戻り値

文字列。この中の各文字は、この位置のためのキーセットのメンバに対応しています。

解説

返される文字列内の任意の 1 文字が、指定された位置で観察される可能性があります。このメソッドでは、このフォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | characterPosition 引数が、0 より小さいか、またはこの CogOCVMaxRunParams オブジェクト内で説明されている、指定されたパラグラフ内、指定された行内の文字数以上である場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetKeysetCharacters オーバロードリスト


GetLineCount メソッド

VisionPro プログラミングリファレンス

CogOCVMaxRunParams.GetLineCount メソッド

このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフ内にある行の数を取得します。

オーバロードリスト

このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフ内にある行の数を取得します。

public int GetLineCount(CogOCVMaxParagraphIterator);

このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフ内にある行の数を取得します。

public int GetLineCount(int);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.GetLineCount メソッド (CogOCVMaxParagraphIterator)

このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフ内にある行の数を取得します。

public int GetLineCount(
CogOCVMaxParagraphIterator pPI
);

パラメータ

pPI
対象のパラグラフを指定するパラグラフ繰り返し指定子。

戻り値

パラグラフ内の行の数を表す System::Int32。

解説

行の数は、通常、SetArrangementFromPattern の呼び出しによって設定されます。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentNullException | 指定された引数が NULL の場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetLineCount オーバロードリスト


CogOCVMaxRunParams.GetLineCount メソッド (Int32)

このオブジェクトの内部配置ディスクリプションの、指定されたパラグラフ内にある行の数を取得します。

public int GetLineCount(
int paragraphPosition
);

パラメータ

paragraphPosition
対象のパラグラフの位置を指定する、ゼロベースのインデックス。

戻り値

パラグラフ内の行の数。

解説

行の数は、通常、SetArrangementFromPattern の呼び出しによって設定されます。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | paragraphPosition 引数が、0 より小さいか、またはこの CogOCVMaxRunParams オブジェクト内で説明されているパラグラフの数以上である場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetLineCount オーバロードリスト


CogOCVMaxRunParams.GetObjectData メソッド

protected override void GetObjectData(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.GetParagraphCount メソッド

この実行パラメータオブジェクトによって説明されているパラグラフの数を取得します。

public int GetParagraphCount();

戻り値

パラグラフの数。

解説

パラグラフの数は、最初はゼロであり、SetArrangementFromPattern の呼び出しによって設定されます。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


GetVerificationType メソッド

VisionPro プログラミングリファレンス

CogOCVMaxRunParams.GetVerificationType メソッド

指定された文字位置に対して実行される検証のタイプを取得します。

オーバロードリスト

指定された文字位置に対して実行される検証のタイプを取得します。

public CogOCVMaxVerificationTypeConstants GetVerificationType(CogOCVMaxCharacterIterator);

指定された文字位置に対して実行される検証のタイプを取得します。

public CogOCVMaxVerificationTypeConstants GetVerificationType(int,int,int);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.GetVerificationType メソッド (CogOCVMaxCharacterIterator)

指定された文字位置に対して実行される検証のタイプを取得します。

public CogOCVMaxVerificationTypeConstants GetVerificationType(
CogOCVMaxCharacterIterator pCI
);

パラメータ

pCI
対象の文字位置を指定する文字繰り返し指定子。

戻り値

検証タイプ。

解説

Normal モードでは、文字は Verified、Confused、または Failed と判定される可能性があります。

AlwaysVerified モードでは、OCVMax は、指定された文字位置に関連付けられたキーセット内の各キーに得点を与え、最も得点の高いキーを選択し、文字を常に Verified と判定します。

Ignore モードでは、OCVMax は、対象の文字に対して処理を一切行わず、文字は常に Verified と判定されます。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentNullException | 指定された文字繰り返し指定子引数が NULL の場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetVerificationType オーバロードリスト


CogOCVMaxRunParams.GetVerificationType メソッド (Int32, Int32, Int32)

指定された文字位置に対して実行される検証のタイプを取得します。

public CogOCVMaxVerificationTypeConstants GetVerificationType(
int paragraphPosition,
int linePosition,
int characterPosition
);

パラメータ

paragraphPosition
対象のパラグラフの位置を指定する、ゼロベースのインデックス。
linePosition
対象のパラグラフ内にある、対象の行の位置を指定する、ゼロベースのインデックス。
characterPosition
対象のパラグラフ内、対象の行内の、対象の文字位置を指定する、ゼロベースのインデックス。

戻り値

検証タイプ。

解説

Normal モードでは、文字は Verified、Confused、または Failed と判定される可能性があります。

AlwaysVerified モードでは、OCVMax は、指定された文字位置に関連付けられたキーセット内の各キーに得点を与え、最も得点の高いキーを選択し、文字を常に Verified と判定します。

Ignore モードでは、OCVMax は、対象の文字に対して処理を一切行わず、文字は常に Verified と判定されます。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.GetVerificationType オーバロードリスト


CogOCVMaxRunParams.SetArrangementFromPattern メソッド

指定されたパターンから、この実行パラメータオブジェクト内に、配置をコピーします。

public void SetArrangementFromPattern(
CogOCVMaxPattern pPattern
);

パラメータ

pPattern
コピーするパターンオブジェクト。

解説

このメソッドは、実行パラメータを設定するプロセスの初期に使用します。パターンからコピーできない、文字固有、行固有、またはパラグラフ固有のプロパティ (パラグラフごとの信頼性しきい値やコンフュージョンしきい値など) は、デフォルト値に設定されます。

イベント

イベントタイプ | 理由
Changed | このメソッドが呼び出された場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | 指定された引数が NULL の場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


SetConfidenceThreshold メソッド

VisionPro プログラミングリファレンス

CogOCVMaxRunParams.SetConfidenceThreshold メソッド

指定されたパラグラフの信頼性しきい値を設定します。

オーバロードリスト

指定されたパラグラフの信頼性しきい値を設定します。

public void SetConfidenceThreshold(CogOCVMaxParagraphIterator,double);

指定されたパラグラフの信頼性しきい値を設定します。

public void SetConfidenceThreshold(int,double);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SetConfidenceThreshold メソッド (CogOCVMaxParagraphIterator, Double)

指定されたパラグラフの信頼性しきい値を設定します。

public void SetConfidenceThreshold(
CogOCVMaxParagraphIterator pPI,
double dNewVal
);

パラメータ

pPI
対象のパラグラフを示すパラグラフ繰り返し指定子。
dNewVal
n/a

戻り値

0.0 ～ 1.0 の範囲の信頼性しきい値。

解説

信頼性しきい値は、現在のキーセット内にある最高得点の文字の得点が、キーセット内の任意の文字とのコンフュージョン得点 (ゼロ以外) を持つ、最高得点の文字を超えている必要がある量です。

紛らわしさが発生する可能性のある文字が、最高得点のキーセットメンバよりも高い得点を持っている場合、結果のステータスは常に「Confused」となりますが、返されるキーは、紛らわしさが発生しているキーからではなく、依然としてキーセットからのキーになります。

コンフュージョンしきい値のテストに合格したキーのみが、この得点付けまたは検証ステップで考慮されます。

イベント

イベントタイプ | 理由
Changed | このメソッドが、指定されたパラグラフの信頼性しきい値を変更した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentNullException | 指定されたパラグラフ繰り返し指定子引数が NULL の場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.SetConfidenceThreshold オーバロードリスト


CogOCVMaxRunParams.SetConfidenceThreshold メソッド (Int32, Double)

指定されたパラグラフの信頼性しきい値を設定します。

public void SetConfidenceThreshold(
int paragraphPosition,
double dNewVal
);

パラメータ

paragraphPosition
対象のパラグラフの位置を指定する、ゼロベースのインデックス。
dNewVal
n/a

戻り値

0.0 ～ 1.0 の範囲の信頼性しきい値。

解説

信頼性しきい値は、現在のキーセット内にある最高得点の文字の得点が、キーセット内の任意の文字とのコンフュージョン得点 (ゼロ以外) を持つ、最高得点の文字を超えている必要がある量です。

紛らわしさが発生する可能性のある文字が、最高得点のキーセットメンバよりも高い得点を持っている場合、結果のステータスは常に「Confused」となりますが、返されるキーは、紛らわしさが発生しているキーからではなく、依然としてキーセットからのキーになります。

コンフュージョンしきい値のテストに合格したキーのみが、この得点付けまたは検証ステップで考慮されます。

イベント

イベントタイプ | 理由
Changed | このメソッドが、指定されたパラグラフの信頼性しきい値を変更した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | paragraphPosition 引数が、0 より小さいか、またはこの CogOCVMaxRunParams オブジェクト内で説明されているパラグラフの数以上である場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.SetConfidenceThreshold オーバロードリスト


SetConfusionThreshold メソッド

VisionPro プログラミングリファレンス

CogOCVMaxRunParams.SetConfusionThreshold メソッド

指定されたパラグラフのコンフュージョンしきい値を設定します。

オーバロードリスト

指定されたパラグラフのコンフュージョンしきい値を設定します。

public void SetConfusionThreshold(CogOCVMaxParagraphIterator,double);

指定されたパラグラフのコンフュージョンしきい値を設定します。

public void SetConfusionThreshold(int,double);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SetConfusionThreshold メソッド (CogOCVMaxParagraphIterator, Double)

指定されたパラグラフのコンフュージョンしきい値を設定します。

public void SetConfusionThreshold(
CogOCVMaxParagraphIterator pPI,
double dNewVal
);

パラメータ

pPI
対象のパラグラフを示すパラグラフ繰り返し指定子。
dNewVal
0.0 ～ 1.0 の範囲のコンフュージョンしきい値。

解説

各パラグラフは、登録時にコンフュージョンマトリックスを構築します。このマトリックスは、パラグラフのフォントアルファベットの各キーペアについて、2 つのキーでどの程度紛らわしさが発生しやすいかを示す数を保持します。1.0 に近い値では、紛らわしさが非常に発生しやすく (例えば、「5」と「S」)、0 に近い値では、紛らわしさは発生しやすくありません (「1」と「5」)。

コンフュージョンしきい値で指定される値未満では、OCVMax が、紛らわしさを検査するために、ほかのキーを考慮することはありません。例えば、OCVMax は、「5」の検出を予想している場合、ほかの紛らわしさが発生する可能性のあるキーもチェックして、それらのキーもよく一致しているか確認します。コンフュージョンしきい値 0.9 では、「S」および「6」のキーは試される可能性がありますが、「1」は試されません。しきい値 0.4 では、「E」や「8」など、ある程度類似した多くのキーが試されます。しきい値が 0 の場合は、すべてのキーが試されます。

イベント

イベントタイプ | 理由
Changed | このメソッドが、指定されたパラグラフのコンフュージョンしきい値を変更した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentNullException | 指定されたパラグラフ繰り返し指定子引数が NULL の場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.SetConfusionThreshold オーバロードリスト


CogOCVMaxRunParams.SetConfusionThreshold メソッド (Int32, Double)

指定されたパラグラフのコンフュージョンしきい値を設定します。

public void SetConfusionThreshold(
int paragraphPosition,
double dNewVal
);

パラメータ

paragraphPosition
対象のパラグラフの位置を指定する、ゼロベースのインデックス。
dNewVal
0.0 ～ 1.0 の範囲のコンフュージョンしきい値。

解説

各パラグラフは、登録時にコンフュージョンマトリックスを構築します。このマトリックスは、パラグラフのフォントアルファベットの各キーペアについて、2 つのキーでどの程度紛らわしさが発生しやすいかを示す数を保持します。1.0 に近い値では、紛らわしさが非常に発生しやすく (例えば、「5」と「S」)、0 に近い値では、紛らわしさは発生しやすくありません (「1」と「5」)。

コンフュージョンしきい値で指定される値未満では、OCVMax が、紛らわしさを検査するために、ほかのキーを考慮することはありません。例えば、OCVMax は、「5」の検出を予想している場合、ほかの紛らわしさが発生する可能性のあるキーもチェックして、それらのキーもよく一致しているか確認します。コンフュージョンしきい値 0.9 では、「S」および「6」のキーは試される可能性がありますが、「1」は試されません。しきい値 0.4 では、「E」や「8」など、ある程度類似した多くのキーが試されます。しきい値が 0 の場合は、すべてのキーが試されます。

イベント

イベントタイプ | 理由
Changed | このメソッドが、指定されたパラグラフのコンフュージョンしきい値を変更した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | paragraphPosition 引数が、0 より小さいか、またはこの CogOCVMaxRunParams オブジェクト内で説明されているパラグラフの数以上である場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.SetConfusionThreshold オーバロードリスト


SetKeyset メソッド

VisionPro プログラミングリファレンス

CogOCVMaxRunParams.SetKeyset メソッド

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットを設定します。

オーバロードリスト

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットを設定します。

public void SetKeyset(CogOCVMaxCharacterIterator,int[]);

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットを設定します。

public void SetKeyset(CogOCVMaxCharacterIterator,string);

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットを設定します。

public void SetKeyset(int,int,int,int[]);

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットを設定します。

public void SetKeyset(int,int,int,string);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SetKeyset メソッド (CogOCVMaxCharacterIterator, Int32[])

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットを設定します。

public void SetKeyset(
CogOCVMaxCharacterIterator pCI,
int[] NewValue
);

パラメータ

pCI
対象の文字位置を指定する CogOCVMaxCharacterIterator。
NewValue
この配列の各要素は、この位置で発生する可能性がある文字のキー値です。

解説

キー値は、NewValue 整数配列の中で渡されます。この配列の各要素は、指定された位置で発生する可能性がある文字のキー値です。

イベント

イベントタイプ | 理由
Changed | このメソッドが、対象のキーセットを変更した場合に発生します。

例外

例外タイプ | 条件
ArgumentNullException | 指定された文字繰り返し指定子引数が NULL の場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.SetKeyset オーバロードリスト


CogOCVMaxRunParams.SetKeyset メソッド (CogOCVMaxCharacterIterator, String)

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットを設定します。

public void SetKeyset(
CogOCVMaxCharacterIterator pCI,
string NewValue
);

パラメータ

pCI
対象の文字位置を指定する文字繰り返し指定子。
NewValue
文字列。この中の各文字は、この位置のためのキーセットのメンバに対応しています。

解説

キー値は、NewValue 文字列の中で渡されます。この文字列内の各文字は、指定された位置で発生する可能性がある文字のキー値です。このメソッドでは、このフォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

イベント

イベントタイプ | 理由
Changed | このメソッドが、対象のキーセットを変更した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。
ArgumentNullException | 指定された文字繰り返し指定子引数が NULL の場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.SetKeyset オーバロードリスト


CogOCVMaxRunParams.SetKeyset メソッド (Int32, Int32, Int32, Int32[])

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットを設定します。

public void SetKeyset(
int paragraphPosition,
int linePosition,
int characterPosition,
int[] NewValue
);

パラメータ

paragraphPosition
対象のパラグラフの位置、つまりインデックスを指定する、ゼロベースのインデックス。
linePosition
対象のパラグラフ内にある、対象の行の位置、つまりインデックスを指定する、ゼロベースのインデックス。
characterPosition
対象のパラグラフ内、対象の行内の、対象の文字位置を指定する、ゼロベースのインデックス。
NewValue
この配列の各要素は、この位置で発生する可能性がある文字のキー値です。

解説

キー値は、NewValue 整数配列の中で渡されます。この配列の各要素は、指定された位置で発生する可能性がある文字のキー値です。

イベント

イベントタイプ | 理由
Changed | このメソッドが、対象のキーセットを変更した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | characterPosition 引数が、0 より小さいか、またはこの CogOCVMaxRunParams オブジェクト内で説明されている、指定されたパラグラフ内、指定された行内の文字数以上である場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.SetKeyset オーバロードリスト


CogOCVMaxRunParams.SetKeyset メソッド (Int32, Int32, Int32, String)

指定されたパラグラフ内、指定された行内の、指定された文字位置のためのキーセットを設定します。

public void SetKeyset(
int paragraphPosition,
int linePosition,
int characterPosition,
string NewValue
);

パラメータ

paragraphPosition
対象のパラグラフの位置を指定する、ゼロベースのインデックス。
linePosition
対象のパラグラフ内にある、対象の行の位置を指定する、ゼロベースのインデックス。
characterPosition
対象のパラグラフ内、対象の行内の、対象の文字位置を指定する、ゼロベースのインデックス。
NewValue
文字列。この中の各文字は、この位置のためのキーセットのメンバに対応しています。

解説

キー値は、NewValue 文字列の中で渡されます。この文字列内の各文字は、指定された位置で発生する可能性がある文字のキー値です。このメソッドでは、このフォント内の文字キーは、Unicode のコードポイント値に対応することが前提になっているため注意してください。

イベント

イベントタイプ | 理由
Changed | このメソッドが、対象のキーセットを変更した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | paragraphPosition 引数が、0 より小さいか、またはこの CogOCVMaxRunParams オブジェクト内で説明されているパラグラフの数以上である場合。
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.SetKeyset オーバロードリスト


SetVerificationType メソッド

VisionPro プログラミングリファレンス

CogOCVMaxRunParams.SetVerificationType メソッド

指定された文字位置に対して実行される検証のタイプを設定します。

オーバロードリスト

指定された文字位置に対して実行される検証のタイプを設定します。

public void SetVerificationType(CogOCVMaxCharacterIterator,CogOCVMaxVerificationTypeConstants);

指定された文字位置に対して実行される検証のタイプを設定します。

public void SetVerificationType(int,int,int,CogOCVMaxVerificationTypeConstants);

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxRunParams.SetVerificationType メソッド (CogOCVMaxCharacterIterator, CogOCVMaxVerificationTypeConstants)

指定された文字位置に対して実行される検証のタイプを設定します。

public void SetVerificationType(
CogOCVMaxCharacterIterator pCI,
CogOCVMaxVerificationTypeConstants eNewVal
);

パラメータ

pCI
対象の文字位置を指定する文字繰り返し指定子。
eNewVal
n/a

解説

Normal モードでは、文字は Verified、Confused、または Failed と判定される可能性があります。

AlwaysVerified モードでは、OCVMax は、指定された文字位置に関連付けられたキーセット内の各キーに得点を与え、最も得点の高いキーを選択し、文字を常に Verified と判定します。

Ignore モードでは、OCVMax は、対象の文字に対して処理を一切行わず、文字は常に Verified と判定されます。

イベント

イベントタイプ | 理由
Changed | このメソッドが、指定された文字の検証タイプを変更した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.SetVerificationType オーバロードリスト


CogOCVMaxRunParams.SetVerificationType メソッド (Int32, Int32, Int32, CogOCVMaxVerificationTypeConstants)

指定された文字位置に対して実行される検証のタイプを設定します。

public void SetVerificationType(
int paragraphPosition,
int linePosition,
int characterPosition,
CogOCVMaxVerificationTypeConstants eNewVal
);

パラメータ

paragraphPosition
対象のパラグラフの位置を指定する、ゼロベースのインデックス。
linePosition
対象のパラグラフ内にある、対象の行の位置を指定する、ゼロベースのインデックス。
characterPosition
対象のパラグラフ内、対象の行内の、対象の文字位置を指定する、ゼロベースのインデックス。
eNewVal
n/a

解説

Normal モードでは、文字は Verified、Confused、または Failed と判定される可能性があります。

AlwaysVerified モードでは、OCVMax は、指定された文字位置に関連付けられたキーセット内の各キーに得点を与え、最も得点の高いキーを選択し、文字を常に Verified と判定します。

Ignore モードでは、OCVMax は、対象の文字に対して処理を一切行わず、文字は常に Verified と判定されます。

イベント

イベントタイプ | 理由
Changed | このメソッドが、指定された文字の検証タイプを変更した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxRunParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxRunParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxRunParams.SetVerificationType オーバロードリスト


CogOCVMaxScoreModeConstants 列挙体

各文字の得点を計算する方法を指定するために使用される定数です。注:より信頼性の高いコンフュージョンの計算を可能にするために通常望ましいモードは ScoreUsingClutter ですが、ノイズの多い画像では、ScoreWithoutClutter が必要な場合もあります。

public enum CogOCVMaxScoreModeConstants

メンバ

メンバ名 | 説明
ScoreUsingOptimizedClutter | 余分な特徴 (クラッタ) が存在する場合は文字得点を低下させますが、比較的低コントラストのクラッタに対しては得点を最適化します。
ScoreWithoutClutter | 予想される特徴の存在のみに基づいて得点を計算し、余分な特徴 (クラッタ) はすべて無視します。
ScoreUsingClutter | 余分な特徴 (クラッタ) が存在する場合は文字得点を低下させます。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams クラス

このクラスは、配置サーチと文字サーチの両方またはどちらかを実行するために使用されるすべてのパラメータをカプセル化します。

このタイプのメンバすべてのリストについては、「CogOCVMaxSearchParams メンバ」を参照してください。

System.Object
MarshalByRefObject
CogObjectBase
CogSerializableObjectBase
CogSerializableChangedEventBase
CogOCVMaxSearchParams

public class CogOCVMaxSearchParams :CogSerializableChangedEventBase, IDisposable

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxSearchParams メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams メンバ

CogOCVMaxSearchParams の概要

パブリックスタティックフィールド

SfAcceptThreshold
SfContrastThreshold
SfDeformationRate
SfDOFEnable
SfGetDOFRotation
SfGetDOFScale
SfGetDOFScaleX
SfGetDOFScaleY
SfGetDOFShear
SfRefinement
SfUncertaintyX
SfUncertaintyY
SfXYOverlap

プロテクトスタティックフィールド

SfNextSf

パブリックインスタンスコンストラクタ

CogOCVMaxSearchParams オーバロードされます。CogOCVMaxSearchParams クラスの新しいインスタンスを初期化します。

パブリックインスタンスプロパティ

AcceptThreshold | このしきい値は、実行時画像内の文字形状を検出するために使用されます。
ContrastThreshold | これは、容認されるために結果が持っている必要のある (実行時画像のグレーレベルでの) コントラストの量です。
DeformationRate | 文字の柔軟なアライメントで対応される最大変位レートです。より大きな値によって、実行時間が増加する場合があるほか、ツールにとって、類似した外観を持つ文字間で紛らわしさが発生しやすくなるということに注意してください。例えば、十分に高い変位レートを許容する場合、U が V に収縮されること、または 5 が S に収縮されることが可能です。このプロパティは、ご使用のアプリケーションの特定の変位に対して効果のある、最小の値に設定してください。値 0 でも、ある程度の変位は許容されます。
DOFEnable | サーチされる自由度 (DOF) です。Rotation、(Uniform) Scale、ScaleX、ScaleY、および Shear という 5 つの自由度があります。これらの任意の組み合わせ (None を含む) をサーチできます。特定の DOF が有効にされている場合は、その DOF の LowerLimit 値と UpperLimit 値の間でサーチが実行されます。有効にされていない場合は、その DOF の Nominal 値を使用してサーチが実行されます。
Refinement | 特定の文字の変位を表す変換に対して行われる、最適化の量です。None が選択された場合は、変位に少量のエラーが含まれる可能性があります。Coarse が選択された場合は、使用される粗粒度限界による精度の限界まで変換は最適化されます。Stretch が選択された場合は、一部のアプリケーションで発生する可能性がある高レベルの不正確さ (文字の極端なワーピング) を解決するために、変換はさらに最適化されます。Fine が選択された場合は、使用される微粒度限界による精度の限界まで、変換はさらに最適化されます。画像内の文字のサイズが非常に小さくない限り、Fine の使用は、おそらくほとんどの場合で、OCV に必要な精度を超えています。最適化の量が少ないほど、ツールは高速に実行されます。
UncertaintyX | これは、選択空間座標における、X 次元での起点ポーズの不確定度です。この値は、CogOCVMaxRunParams::KeySearchParams と CogOCVMaxRunParams::StartPoseSearchParams の両方によって使用されます。この値は、CogOCVMaxRunParams::ImageSearchParams では無視されます。
UncertaintyY | これは、選択空間座標における、Y 次元での起点ポーズの不確定度です。この値は、CogOCVMaxRunParams::KeySearchParams と CogOCVMaxRunParams::StartPoseSearchParams の両方によって使用されます。この値は、CogOCVMaxRunParams::ImageSearchParams では無視されます。
XYOverlap | これは XY オーバラップの量であり、この量を超えると 2 つの結果は同じであるとみなされます。

パブリックインスタンスメソッド

Dispose | オーバロードされます。
GetDOFRotation | Rotation 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。すべての Rotation 属性の単位はラジアンです。
GetDOFScale | (Uniform) Scale 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。
GetDOFScaleX | ScaleX 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。
GetDOFScaleY | ScaleY 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。
GetDOFShear | Shear 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。すべての Shear 属性の単位はラジアンです。
SetDOFRotation | Rotation 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。すべての Rotation 属性の単位はラジアンです。
SetDOFScale | (Uniform) Scale 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。
SetDOFScaleX | ScaleX 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。
SetDOFScaleY | ScaleY 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。
SetDOFShear | Shear 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。すべての Shear 属性の単位はラジアンです。

プロテクトインスタンスコンストラクタ

CogOCVMaxSearchParams オーバロードされます。CogOCVMaxSearchParams クラスの新しいインスタンスを初期化します。

プロテクトインスタンスメソッド

__dtor |
Dispose | オーバロードされます。
Finalize |
GetObjectData |

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams コンストラクタ

オーバロードリスト

CogOCVMaxSearchParams クラスの新しいインスタンスを初期化します。

public CogOCVMaxSearchParams();

public CogOCVMaxSearchParams(CogOCVMaxSearchParams);

protected CogOCVMaxSearchParams(SerializationInfo,StreamingContext);

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams コンストラクタ (SerializationInfo, StreamingContext)

protected CogOCVMaxSearchParams(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxSearchParams コンストラクタオーバロードリスト


CogOCVMaxSearchParams コンストラクタ (CogOCVMaxSearchParams)

public CogOCVMaxSearchParams(
CogOCVMaxSearchParams pOther
);

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxSearchParams コンストラクタオーバロードリスト


CogOCVMaxSearchParams コンストラクタ ()

CogOCVMaxSearchParams クラスの新しいインスタンスを初期化します。

public CogOCVMaxSearchParams();

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxSearchParams コンストラクタオーバロードリスト


CogOCVMaxSearchParams フィールド

CogOCVMaxSearchParams クラスのフィールドを次に示します。CogOCVMaxSearchParams クラスメンバの完全なリストについては、「CogOCVMaxSearchParams メンバ」を参照してください。

パブリックスタティックフィールド

SfAcceptThreshold
SfContrastThreshold
SfDeformationRate
SfDOFEnable
SfGetDOFRotation
SfGetDOFScale
SfGetDOFScaleX
SfGetDOFScaleY
SfGetDOFShear
SfRefinement
SfUncertaintyX
SfUncertaintyY
SfXYOverlap

プロテクトスタティックフィールド

SfNextSf

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfAcceptThreshold フィールド

public const long SfAcceptThreshold;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfContrastThreshold フィールド

public const long SfContrastThreshold;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfDeformationRate フィールド

public const long SfDeformationRate;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfDOFEnable フィールド

public const long SfDOFEnable;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfGetDOFRotation フィールド

public const long SfGetDOFRotation;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfGetDOFScale フィールド

public const long SfGetDOFScale;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfGetDOFScaleX フィールド

public const long SfGetDOFScaleX;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfGetDOFScaleY フィールド

public const long SfGetDOFScaleY;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfGetDOFShear フィールド

public const long SfGetDOFShear;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfNextSf フィールド

new protected const long SfNextSf;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfRefinement フィールド

public const long SfRefinement;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfUncertaintyX フィールド

public const long SfUncertaintyX;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfUncertaintyY フィールド

public const long SfUncertaintyY;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SfXYOverlap フィールド

public const long SfXYOverlap;

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams プロパティ

CogOCVMaxSearchParams クラスのプロパティを次に示します。CogOCVMaxSearchParams クラスメンバの完全なリストについては、「CogOCVMaxSearchParams メンバ」を参照してください。

パブリックインスタンスプロパティ

AcceptThreshold | このしきい値は、実行時画像内の文字形状を検出するために使用されます。
ContrastThreshold | これは、容認されるために結果が持っている必要のある (実行時画像のグレーレベルでの) コントラストの量です。
DeformationRate | 文字の柔軟なアライメントで対応される最大変位レートです。より大きな値によって、実行時間が増加する場合があるほか、ツールにとって、類似した外観を持つ文字間で紛らわしさが発生しやすくなるということに注意してください。例えば、十分に高い変位レートを許容する場合、U が V に収縮されること、または 5 が S に収縮されることが可能です。このプロパティは、ご使用のアプリケーションの特定の変位に対して効果のある、最小の値に設定してください。値 0 でも、ある程度の変位は許容されます。
DOFEnable | サーチされる自由度 (DOF) です。Rotation、(Uniform) Scale、ScaleX、ScaleY、および Shear という 5 つの自由度があります。これらの任意の組み合わせ (None を含む) をサーチできます。特定の DOF が有効にされている場合は、その DOF の LowerLimit 値と UpperLimit 値の間でサーチが実行されます。有効にされていない場合は、その DOF の Nominal 値を使用してサーチが実行されます。
Refinement | 特定の文字の変位を表す変換に対して行われる、最適化の量です。None が選択された場合は、変位に少量のエラーが含まれる可能性があります。Coarse が選択された場合は、使用される粗粒度限界による精度の限界まで変換は最適化されます。Stretch が選択された場合は、一部のアプリケーションで発生する可能性がある高レベルの不正確さ (文字の極端なワーピング) を解決するために、変換はさらに最適化されます。Fine が選択された場合は、使用される微粒度限界による精度の限界まで、変換はさらに最適化されます。画像内の文字のサイズが非常に小さくない限り、Fine の使用は、おそらくほとんどの場合で、OCV に必要な精度を超えています。最適化の量が少ないほど、ツールは高速に実行されます。
UncertaintyX | これは、選択空間座標における、X 次元での起点ポーズの不確定度です。この値は、CogOCVMaxRunParams::KeySearchParams と CogOCVMaxRunParams::StartPoseSearchParams の両方によって使用されます。この値は、CogOCVMaxRunParams::ImageSearchParams では無視されます。
UncertaintyY | これは、選択空間座標における、Y 次元での起点ポーズの不確定度です。この値は、CogOCVMaxRunParams::KeySearchParams と CogOCVMaxRunParams::StartPoseSearchParams の両方によって使用されます。この値は、CogOCVMaxRunParams::ImageSearchParams では無視されます。
XYOverlap | これは XY オーバラップの量であり、この量を超えると 2 つの結果は同じであるとみなされます。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.AcceptThreshold プロパティ

このしきい値は、実行時画像内の文字形状を検出するために使用されます。

public double AcceptThreshold {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、0 ～ 1 の値を持っていなければなりません。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | このプロパティを 0 未満または 1 より大きな値に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.ContrastThreshold プロパティ

これは、容認されるために結果が持っている必要のある (実行時画像のグレーレベルでの) コントラストの量です。

public double ContrastThreshold {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、ゼロ以上である必要があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | このプロパティをゼロ未満の値に設定しようとした場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.DeformationRate プロパティ

文字の柔軟なアライメントで対応される最大変位レートです。より大きな値によって、実行時間が増加する場合があるほか、ツールにとって、類似した外観を持つ文字間で紛らわしさが発生しやすくなるということに注意してください。例えば、十分に高い変位レートを許容する場合、U が V に収縮されること、または 5 が S に収縮されることがあります。このプロパティは、ご使用のアプリケーションの特定の変位に対して効果のある、最小の値に設定してください。値 0 でも、ある程度の変位は許容されます。

public double DeformationRate {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、0 ～ 1 である必要があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | このプロパティを 0 未満または 1 より大きな値に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.DOFEnable プロパティ

サーチされる自由度 (DOF) です。Rotation、(Uniform) Scale、ScaleX、ScaleY、および Shear という 5 つの自由度があります。これらの任意の組み合わせ (None を含む) をサーチできます。特定の DOF が有効にされている場合は、その DOF の LowerLimit 値と UpperLimit 値の間でサーチが実行されます。有効にされていない場合は、その DOF の Nominal 値を使用してサーチが実行されます。

public CogOCVMaxDOFConstants DOFEnable {get; set;}

プロパティ値

この読み取り/書き込みプロパティは、0 (DOF は何も有効にされない) であるか、または列挙値 CogOCVMaxDOFConstants::Rotation、::Scale、::ScaleX、::ScaleY、::Shear のビット単位の OR であるかのいずれかです。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.Refinement プロパティ

特定の文字の変位を表す変換に対して行われる、最適化の量です。None が選択された場合は、変位に少量のエラーが含まれる可能性があります。Coarse が選択された場合は、使用される粗粒度限界による精度の限界まで変換は最適化されます。Stretch が選択された場合は、一部のアプリケーションで発生する可能性がある高レベルの不正確さ (文字の極端なワーピング) を解決するために、変換はさらに最適化されます。Fine が選択された場合は、使用される微粒度限界による精度の限界まで、変換はさらに最適化されます。画像内の文字のサイズが非常に小さくない限り、Fine の使用は、おそらくほとんどの場合で、OCV に必要な精度を超えています。最適化の量が少ないほど、ツールは高速に実行されます。

public CogOCVMaxRefinementConstants Refinement {get; set;}

プロパティ値

CogOCVMaxRefinementConstants タイプの、この読み取り/書き込みプロパティは、None (最小の最適化)、Coarse、Stretch、または Fine (最大の最適化) のいずれかであることが可能です。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.UncertaintyX プロパティ

これは、選択空間座標における、X 次元での起点ポーズの不確定度です。この値は、CogOCVMaxRunParams::KeySearchParams と CogOCVMaxRunParams::StartPoseSearchParams の両方によって使用されます。この値は、CogOCVMaxRunParams::ImageSearchParams では無視されます。

public double UncertaintyX {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、ゼロ以上である必要があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | このプロパティをゼロ未満の値に設定しようとした場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.UncertaintyY プロパティ

これは、選択空間座標における、Y 次元での起点ポーズの不確定度です。この値は、CogOCVMaxRunParams::KeySearchParams と CogOCVMaxRunParams::StartPoseSearchParams の両方によって使用されます。この値は、CogOCVMaxRunParams::ImageSearchParams では無視されます。

public double UncertaintyY {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、ゼロ以上である必要があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | このプロパティをゼロ未満の値に設定しようとした場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.XYOverlap プロパティ

これは XY オーバラップの量であり、この量を超えると 2 つの結果は同じであるとみなされます。

public double XYOverlap {get; set;}

プロパティ値

Double タイプの、この読み取り/書き込みプロパティは、ゼロ以上である必要があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | このプロパティをゼロ未満の値に設定しようとした場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams メソッド

CogOCVMaxSearchParams クラスのメソッドを次に示します。CogOCVMaxSearchParams クラスメンバの完全なリストについては、「CogOCVMaxSearchParams メンバ」を参照してください。

パブリックインスタンスメソッド

Dispose | オーバロードされます。
GetDOFRotation | Rotation 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。すべての Rotation 属性の単位はラジアンです。
GetDOFScale | (Uniform) Scale 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。
GetDOFScaleX | ScaleX 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。
GetDOFScaleY | ScaleY 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。
GetDOFShear | Shear 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。すべての Shear 属性の単位はラジアンです。
SetDOFRotation | Rotation 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。すべての Rotation 属性の単位はラジアンです。
SetDOFScale | (Uniform) Scale 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。
SetDOFScaleX | ScaleX 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。
SetDOFScaleY | ScaleY 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。
SetDOFShear | Shear 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。すべての Shear 属性の単位はラジアンです。

プロテクトインスタンスメソッド

__dtor |
Dispose | オーバロードされます。
Finalize |
GetObjectData |

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.__dtor メソッド

protected void __dtor();

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


Dispose メソッド

VisionPro プログラミングリファレンス

CogOCVMaxSearchParams.Dispose メソッド

オーバロードリスト

public override void Dispose();

protected virtual void Dispose(bool);

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.Dispose メソッド ()

public override void Dispose();

実装

IDisposable.Dispose

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxSearchParams.Dispose オーバロードリスト


CogOCVMaxSearchParams.Dispose メソッド (Boolean)

protected virtual void Dispose(
bool bDisposing
);

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxSearchParams.Dispose オーバロードリスト


CogOCVMaxSearchParams.Finalize メソッド

protected override void Finalize();

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.GetDOFRotation メソッド

Rotation 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。すべての Rotation 属性の単位はラジアンです。

public double GetDOFRotation(
CogOCVMaxDOFAttributeConstants selector
);

パラメータ

selector
希望する属性。CogOCVMaxDOFAttributeConstants::LowerLimit、::Nominal、::UpperLimit、または ::Overlap のいずれかであることが可能です。

戻り値

指定された Rotation 属性をラジアン単位で表す System::Double。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.GetDOFScale メソッド

(Uniform) Scale 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。

public double GetDOFScale(
CogOCVMaxDOFAttributeConstants selector
);

パラメータ

selector
希望する属性。CogOCVMaxDOFAttributeConstants::LowerLimit、::Nominal、::UpperLimit、または ::Overlap のいずれかであることが可能です。

戻り値

指定された (Uniform) Scale 属性を表す System::Double。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.GetDOFScaleX メソッド

ScaleX 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。

public double GetDOFScaleX(
CogOCVMaxDOFAttributeConstants selector
);

パラメータ

selector
希望する属性。CogOCVMaxDOFAttributeConstants::LowerLimit、::Nominal、::UpperLimit、または ::Overlap のいずれかであることが可能です。

戻り値

指定された ScaleX 属性を表す System::Double。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.GetDOFScaleY メソッド

ScaleY 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。

public double GetDOFScaleY(
CogOCVMaxDOFAttributeConstants selector
);

パラメータ

selector
希望する属性。CogOCVMaxDOFAttributeConstants::LowerLimit、::Nominal、::UpperLimit、または ::Overlap のいずれかであることが可能です。

戻り値

指定された ScaleY 属性を表す System::Double。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.GetDOFShear メソッド

Shear 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を取得します。selector 引数を使用して、どの属性かを指定します。すべての Shear 属性の単位はラジアンです。

public double GetDOFShear(
CogOCVMaxDOFAttributeConstants selector
);

パラメータ

selector
希望する属性。CogOCVMaxDOFAttributeConstants::LowerLimit、::Nominal、::UpperLimit、または ::Overlap のいずれかであることが可能です。

戻り値

指定された Shear 属性をラジアン単位で表す System::Double。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.GetObjectData メソッド

protected override void GetObjectData(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SetDOFRotation メソッド

Rotation 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。すべての Rotation 属性の単位はラジアンです。

public void SetDOFRotation(
CogOCVMaxDOFAttributeConstants selector,
double dNewVal
);

パラメータ

selector
希望する属性。CogOCVMaxDOFAttributeConstants::LowerLimit、::Nominal、::UpperLimit、または ::Overlap のいずれかであることが可能です。
dNewVal
新しい属性値 (ラジアン単位)。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | Rotation Overlap を負の値に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SetDOFScale メソッド

(Uniform) Scale 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。

public void SetDOFScale(
CogOCVMaxDOFAttributeConstants selector,
double dNewVal
);

パラメータ

selector
希望する属性。CogOCVMaxDOFAttributeConstants::LowerLimit、::Nominal、::UpperLimit、または ::Overlap のいずれかであることが可能です。
dNewVal
新しい属性値。Scale Overlap は 1 以上である必要があることに注意してください。Scale LowerLimit、Nominal、および UpperLimit は、すべて 0 より大きい必要があることに注意してください。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | Scale Overlap を 1 未満の値に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SetDOFScaleX メソッド

ScaleX 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。

public void SetDOFScaleX(
CogOCVMaxDOFAttributeConstants selector,
double dNewVal
);

パラメータ

selector
希望する属性。CogOCVMaxDOFAttributeConstants::LowerLimit、::Nominal、::UpperLimit、または ::Overlap のいずれかであることが可能です。
dNewVal
新しい属性値。ScaleX Overlap は 1 以上である必要があることに注意してください。ScaleX LowerLimit、Nominal、および UpperLimit は、すべて 0 より大きい必要があることに注意してください。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | ScaleX Overlap を 1 未満の値に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SetDOFScaleY メソッド

ScaleY 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。

public void SetDOFScaleY(
CogOCVMaxDOFAttributeConstants selector,
double dNewVal
);

パラメータ

selector
希望する属性。CogOCVMaxDOFAttributeConstants::LowerLimit、::Nominal、::UpperLimit、または ::Overlap のいずれかであることが可能です。
dNewVal
新しい属性値。ScaleY Overlap は 1 以上である必要があることに注意してください。ScaleY LowerLimit、Nominal、および UpperLimit は、すべて 0 より大きい必要があることに注意してください。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。
ArgumentOutOfRangeException | ScaleY Overlap を 1 未満の値に設定しようとした場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSearchParams.SetDOFShear メソッド

Shear 自由度 (DOF) の、特定の属性 (LowerLimit、Nominal、UpperLimit、または Overlap) を設定します。selector 引数を使用して、どの属性かを指定します。すべての Shear 属性の単位はラジアンです。

public void SetDOFShear(
CogOCVMaxDOFAttributeConstants selector,
double dNewVal
);

パラメータ

selector
希望する属性。CogOCVMaxDOFAttributeConstants::LowerLimit、::Nominal、::UpperLimit、または ::Overlap のいずれかであることが可能です。
dNewVal
新しい属性値 (ラジアン単位)。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

例外

例外タイプ | 条件
ArgumentOutOfRangeException | Shear Overlap を負の値に設定しようとした場合。
ObjectDisposedException | この CogOCVMaxSearchParams オブジェクトが既に破棄されている場合。

参照

CogOCVMaxSearchParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSharedResult クラス

このタイプのメンバすべてのリストについては、「CogOCVMaxSharedResult メンバ」を参照してください。

System.Object
MarshalByRefObject
CogObjectBase
CogSerializableObjectBase
CogOCVMaxSharedResult

public class CogOCVMaxSharedResult :CogSerializableObjectBase

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxSharedResult メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSharedResult メンバ

CogOCVMaxSharedResult の概要

パブリックインスタンスコンストラクタ

CogOCVMaxSharedResult オーバロードされます。CogOCVMaxSharedResult クラスの新しいインスタンスを初期化します。

パブリックインスタンスプロパティ

SelectedSpaceName

プロテクトインスタンスコンストラクタ

CogOCVMaxSharedResult オーバロードされます。CogOCVMaxSharedResult クラスの新しいインスタンスを初期化します。

参照

CogOCVMaxSharedResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSharedResult コンストラクタ

オーバロードリスト

public CogOCVMaxSharedResult(CogOCVMaxSharedResult);

protected CogOCVMaxSharedResult(SerializationInfo,StreamingContext);

参照

CogOCVMaxSharedResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSharedResult コンストラクタ (SerializationInfo, StreamingContext)

protected CogOCVMaxSharedResult(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxSharedResult クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxSharedResult コンストラクタオーバロードリスト


CogOCVMaxSharedResult コンストラクタ (CogOCVMaxSharedResult)

public CogOCVMaxSharedResult(
CogOCVMaxSharedResult pOther
);

参照

CogOCVMaxSharedResult クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxSharedResult コンストラクタオーバロードリスト


CogOCVMaxSharedResult プロパティ

CogOCVMaxSharedResult クラスのプロパティを次に示します。CogOCVMaxSharedResult クラスメンバの完全なリストについては、「CogOCVMaxSharedResult メンバ」を参照してください。

パブリックインスタンスプロパティ

SelectedSpaceName

参照

CogOCVMaxSharedResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxSharedResult.SelectedSpaceName プロパティ

public string SelectedSpaceName {get;}

参照

CogOCVMaxSharedResult クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool クラス

このクラスは、CogOCVMaxPattern オペレータへのツールレベルのアクセスを提供します。このクラスは、OCVMax 検査を実行するために必要なすべてのクラスをカプセル化します。

このタイプのメンバすべてのリストについては、「CogOCVMaxTool メンバ」を参照してください。

System.Object
MarshalByRefObject
Component
CogComponentBase
CogSerializableComponentBase
CogSerializableChangedEventComponentBase
CogToolBase
CogOCVMaxTool

public class CogOCVMaxTool :CogToolBase

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxTool メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool メンバ

CogOCVMaxTool の概要

パブリックスタティックフィールド

SfCurrentRecordEnable
SfInputImage
SfLastRunRecordDiagEnable
SfLastRunRecordEnable
SfPattern
SfRegion
SfResult
SfRunParams

プロテクトスタティックフィールド

SfNextSf

パブリックインスタンスコンストラクタ

CogOCVMaxTool オーバロードされます。CogOCVMaxTool クラスの新しいインスタンスを初期化します。

パブリックインスタンスプロパティ

CurrentRecordEnable | 適切な CogOCVMaxCurrentRecordConstants のビット単位の OR 演算によるレコードの作成を有効にします。
InputImage | OCVMax 解析の実行に使用される画像です。Region プロパティを使用して、この解析が InputImage の部分に対してのみ実行されるように指定することができます。Region が Nothing の場合、OCVMax 解析は InputImage 全体に対して実行されます。
LastRunRecordDiagEnable | 適切な CogOCVMaxLastRunRecordDiagConstants のビット単位の OR 演算によるレコードの作成を有効にします。
LastRunRecordEnable | 適切な CogOCVMaxLastRunRecordConstants のビット単位の OR 演算によるレコードの作成を有効にします。
Pattern | OCVMax パターンです。これは、検査されるテキストのすべての登録時情報を組み込んでいます。
Region | OCVMax 解析の実行に使用される、InputImage の領域を指定します。CogOCVMaxRunParams::RegionMode プロパティは、InputImage に ROI が適用される方法を厳密に指定します。
Result | Run メソッドの前回の呼び出しからの結果です。各検査について、CogOCVMaxResult の新しいインスタンスが作成されます。
RunParams | この OCVMax ツールのための実行パラメータです。

プロテクトインスタンスメソッド

Clone
InternalCreateCurrentRecord
InternalCreateLastRunRecord
InternalRun

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool コンストラクタ

オーバロードリスト

CogOCVMaxTool クラスの新しいインスタンスを初期化します。

public CogOCVMaxTool();

public CogOCVMaxTool(CogOCVMaxTool);

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool コンストラクタ (CogOCVMaxTool)

public CogOCVMaxTool(
CogOCVMaxTool pOther
);

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxTool コンストラクタオーバロードリスト


CogOCVMaxTool コンストラクタ ()

CogOCVMaxTool クラスの新しいインスタンスを初期化します。

public CogOCVMaxTool();

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxTool コンストラクタオーバロードリスト


CogOCVMaxTool スタティックコンストラクタ

CogOCVMaxTool クラスのスタティックフィールドを初期化します。

static CogOCVMaxTool();

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool フィールド

CogOCVMaxTool クラスのフィールドを次に示します。CogOCVMaxTool クラスメンバの完全なリストについては、「CogOCVMaxTool メンバ」を参照してください。

パブリックスタティックフィールド

SfCurrentRecordEnable
SfInputImage
SfLastRunRecordDiagEnable
SfLastRunRecordEnable
SfPattern
SfRegion
SfResult
SfRunParams

プロテクトスタティックフィールド

SfNextSf

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.SfCurrentRecordEnable フィールド

public const long SfCurrentRecordEnable;

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.SfInputImage フィールド

public const long SfInputImage;

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.SfLastRunRecordDiagEnable フィールド

public const long SfLastRunRecordDiagEnable;

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.SfLastRunRecordEnable フィールド

public const long SfLastRunRecordEnable;

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.SfNextSf フィールド

new protected const long SfNextSf;

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.SfPattern フィールド

public const long SfPattern;

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.SfRegion フィールド

public const long SfRegion;

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.SfResult フィールド

public const long SfResult;

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.SfRunParams フィールド

public const long SfRunParams;

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool プロパティ

CogOCVMaxTool クラスのプロパティを次に示します。CogOCVMaxTool クラスメンバの完全なリストについては、「CogOCVMaxTool メンバ」を参照してください。

パブリックインスタンスプロパティ

CurrentRecordEnable | 適切な CogOCVMaxCurrentRecordConstants のビット単位の OR 演算によるレコードの作成を有効にします。
InputImage | OCVMax 解析の実行に使用される画像です。Region プロパティを使用して、この解析が InputImage の部分に対してのみ実行されるように指定することができます。Region が Nothing の場合、OCVMax 解析は InputImage 全体に対して実行されます。
LastRunRecordDiagEnable | 適切な CogOCVMaxLastRunRecordDiagConstants のビット単位の OR 演算によるレコードの作成を有効にします。
LastRunRecordEnable | 適切な CogOCVMaxLastRunRecordConstants のビット単位の OR 演算によるレコードの作成を有効にします。
Pattern | OCVMax パターンです。これは、検査されるテキストのすべての登録時情報を組み込んでいます。
Region | OCVMax 解析の実行に使用される、InputImage の領域を指定します。CogOCVMaxRunParams::RegionMode プロパティは、InputImage に ROI が適用される方法を厳密に指定します。
Result | Run メソッドの前回の呼び出しからの結果です。各検査について、CogOCVMaxResult の新しいインスタンスが作成されます。
RunParams | この OCVMax ツールのための実行パラメータです。

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.CurrentRecordEnable プロパティ

適切な CogOCVMaxCurrentRecordConstants のビット単位の OR 演算によるレコードの作成を有効にします。

public CogOCVMaxCurrentRecordConstants CurrentRecordEnable {get; set;}

プロパティ値

この読み取り/書き込みプロパティは、CogOCVMaxCurrentRecordConstants のビットごとの組み合わせです。オプションとしては、None、InputImage、Region、All があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.InputImage プロパティ

OCVMax 解析の実行に使用される画像です。Region プロパティを使用して、この解析が InputImage の部分に対してのみ実行されるように指定することができます。Region が Nothing の場合、OCVMax 解析は InputImage 全体に対して実行されます。

public Cognex.VisionPro.CogImage8Grey InputImage {get; set;}

プロパティ値

OCVMax 解析の実行対象となる画像。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.LastRunRecordDiagEnable プロパティ

適切な CogOCVMaxLastRunRecordDiagConstants のビット単位の OR 演算によるレコードの作成を有効にします。

public CogOCVMaxLastRunRecordDiagConstants LastRunRecordDiagEnable {get; set;}

プロパティ値

この読み取り/書き込みプロパティは、CogOCVMaxLastRunRecordDiagConstants のビットごとの組み合わせです。オプションとしては、None、InputImageByReference、InputImageDeepCopy、Region、TransformedRegionPixels、All があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.LastRunRecordEnable プロパティ

適切な CogOCVMaxLastRunRecordConstants のビット単位の OR 演算によるレコードの作成を有効にします。

public CogOCVMaxLastRunRecordConstants LastRunRecordEnable {get; set;}

プロパティ値

この読み取り/書き込みプロパティは、CogOCVMaxLastRunRecordConstants のビットごとの組み合わせです。オプションとしては、None、ParagraphBounds、ParagraphCharactersBounds、ParagraphCharactersLabel、All があります。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.Pattern プロパティ

OCVMax パターンです。これは、検査されるテキストのすべての登録時情報を組み込んでいます。

public CogOCVMaxPattern Pattern {get; set;}

プロパティ値

この読み取り/書き込みプロパティは、CogOCVMaxPattern タイプです。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.Region プロパティ

OCVMax 解析の実行に使用される、InputImage の領域を指定します。CogOCVMaxRunParams::RegionMode プロパティは、InputImage に ROI が適用される方法を厳密に指定します。

public Cognex.VisionPro.ICogRegion Region {get; set;}

プロパティ値

この読み取り/書き込みプロパティは、ICogRegion タイプです。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.Result プロパティ

Run メソッドの前回の呼び出しからの結果です。各検査について、CogOCVMaxResult の新しいインスタンスが作成されます。

public CogOCVMaxResult Result {get;}

プロパティ値

この読み取り専用プロパティは、CogOCVMaxResult タイプです。

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.RunParams プロパティ

この OCVMax ツールのための実行パラメータです。

public CogOCVMaxRunParams RunParams {get; set;}

プロパティ値

この読み取り/書き込みプロパティは、CogOCVMaxRunParams タイプです。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool メソッド

CogOCVMaxTool クラスのメソッドを次に示します。CogOCVMaxTool クラスメンバの完全なリストについては、「CogOCVMaxTool メンバ」を参照してください。

プロテクトインスタンスメソッド

Clone
InternalCreateCurrentRecord
InternalCreateLastRunRecord
InternalRun

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.Clone メソッド

protected override object Clone();

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.InternalCreateCurrentRecord メソッド

protected override void InternalCreateCurrentRecord(
ICogRecord pNewRecord,
int currentRecordEnable
);

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.InternalCreateLastRunRecord メソッド

protected override void InternalCreateLastRunRecord(
ICogRecord pNewRecord,
int lastRunRecordEnable,
int lastRunRecordDiagEnable
);

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTool.InternalRun メソッド

protected override CogToolResultConstants InternalRun(
ref string pMsg
);

参照

CogOCVMaxTool クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTuneConstants 列挙体

どのパターンプロパティをチューニングするかを指定するために使用される定数です。

この列挙体は、メンバ値のビットごとの組み合わせを可能にする FlagsAttribute 属性を持っています。

public enum CogOCVMaxTuneConstants

メンバ

メンバ名 | 説明 | 値
All | すべての利用可能なパターンプロパティをチューニングします。 | -1
PoseShear | この配置内において、指定されたパラグラフ (1 つ以上) の PoseShear をチューニングします。 | 4096
PoseRotation | この配置内において、指定されたパラグラフ (1 つ以上) の PoseRotation をチューニングします。 | 2048
PoseAspect | この配置内において、指定されたパラグラフ (1 つ以上) の PoseAspect をチューニングします。 | 1024
PoseScale | この配置内において、指定されたパラグラフ (1 つ以上) の Pose (Uniform) Scale をチューニングします。 | 512
Polarity | この配置内において、指定されたパラグラフ (1 つ以上) の Polarity をチューニングします。 | 256
SpotSpacingScaleY | この配置内において、指定されたパラグラフ (1 つ以上) の SpotSpacingScaleY をチューニングします。 | 128
SpotSpacingScaleX | この配置内において、指定されたパラグラフ (1 つ以上) の SpotSpacingScaleX をチューニングします。 | 64
StrokeWidthAdded | この配置内において、指定されたパラグラフ (1 つ以上) の StrokeWidthAdded をチューニングします。 | 32
LineSpacingAddedY | この配置内において、指定されたパラグラフ (1 つ以上) の LineSpacingAddedY をチューニングします。 | 16
LineSpacingAddedX | この配置内において、指定されたパラグラフ (1 つ以上) の LineSpacingAddedX をチューニングします。 | 8
CharacterSpacingAddedY | この配置内において、指定されたパラグラフ (1 つ以上) の CharacterSpacingAddedY をチューニングします。 | 4
CharacterSpacingAddedX | この配置内において、指定されたパラグラフ (1 つ以上) の CharacterSpacingAddedX をチューニングします。 | 2
SpotSizeScale | この配置内において、各パラグラフの SpotSizeScale をチューニングします。関連付けられたフォントがスポットサイズを使用しないパラグラフ (SpotSizeUsed が false) については無視されます。 | 1
None | どのパターンプロパティもチューニングしません。 | 0

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTuneParams クラス

このクラスは、CogOCVMaxPattern オブジェクトをチューニングするために使用されるプロパティをカプセル化します。

このタイプのメンバすべてのリストについては、「CogOCVMaxTuneParams メンバ」を参照してください。

System.Object
MarshalByRefObject
CogObjectBase
CogSerializableObjectBase
CogSerializableChangedEventBase
CogOCVMaxTuneParams

public class CogOCVMaxTuneParams :CogSerializableChangedEventBase

スレッドの安全性

このタイプの public static (Visual Basic で共有) メンバは、マルチスレッド操作で問題なく使用できます。インスタンスメンバは、スレッドセーフであることは保証されません。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

CogOCVMaxTuneParams メンバ | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTuneParams メンバ

CogOCVMaxTuneParams の概要

パブリックスタティックフィールド

SfFlags

プロテクトスタティックフィールド

SfNextSf

パブリックインスタンスコンストラクタ

CogOCVMaxTuneParams オーバロードされます。CogOCVMaxTuneParams クラスの新しいインスタンスを初期化します。

パブリックインスタンスプロパティ

Flags チューニング中にどのプロパティ (1 つ以上) が変更されるかを示します。

プロテクトインスタンスコンストラクタ

CogOCVMaxTuneParams オーバロードされます。CogOCVMaxTuneParams クラスの新しいインスタンスを初期化します。

プロテクトインスタンスメソッド

GetObjectData

参照

CogOCVMaxTuneParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTuneParams コンストラクタ

オーバロードリスト

CogOCVMaxTuneParams クラスの新しいインスタンスを初期化します。

public CogOCVMaxTuneParams();

public CogOCVMaxTuneParams(CogOCVMaxTuneParams);

protected CogOCVMaxTuneParams(SerializationInfo,StreamingContext);

参照

CogOCVMaxTuneParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTuneParams コンストラクタ (SerializationInfo, StreamingContext)

protected CogOCVMaxTuneParams(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxTuneParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxTuneParams コンストラクタオーバロードリスト


CogOCVMaxTuneParams コンストラクタ (CogOCVMaxTuneParams)

public CogOCVMaxTuneParams(
CogOCVMaxTuneParams pOther
);

参照

CogOCVMaxTuneParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxTuneParams コンストラクタオーバロードリスト


CogOCVMaxTuneParams コンストラクタ ()

CogOCVMaxTuneParams クラスの新しいインスタンスを初期化します。

public CogOCVMaxTuneParams();

参照

CogOCVMaxTuneParams クラス | Cognex.VisionPro.OCVMax 名前空間 | CogOCVMaxTuneParams コンストラクタオーバロードリスト


CogOCVMaxTuneParams フィールド

CogOCVMaxTuneParams クラスのフィールドを次に示します。CogOCVMaxTuneParams クラスメンバの完全なリストについては、「CogOCVMaxTuneParams メンバ」を参照してください。

パブリックスタティックフィールド

SfFlags

プロテクトスタティックフィールド

SfNextSf

参照

CogOCVMaxTuneParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTuneParams.SfFlags フィールド

public const long SfFlags;

参照

CogOCVMaxTuneParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTuneParams.SfNextSf フィールド

new protected const long SfNextSf;

参照

CogOCVMaxTuneParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTuneParams プロパティ

CogOCVMaxTuneParams クラスのプロパティを次に示します。CogOCVMaxTuneParams クラスメンバの完全なリストについては、「CogOCVMaxTuneParams メンバ」を参照してください。

パブリックインスタンスプロパティ

Flags チューニング中にどのプロパティ (1 つ以上) が変更されるかを示します。

参照

CogOCVMaxTuneParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTuneParams.Flags プロパティ

チューニング中にどのプロパティ (1 つ以上) が変更されるかを示します。

public CogOCVMaxTuneConstants Flags {get; set;}

プロパティ値

CogOCVMaxTuneConstants タイプの、この読み取り/書き込みプロパティは、チューニング中に変更されることが可能な各プロパティ (1 つ以上) を識別します。これは、定義された列挙値のビット単位の OR です。

イベント

イベントタイプ | 理由
Changed | このプロパティが変化した場合に発生します。

参照

CogOCVMaxTuneParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTuneParams メソッド

CogOCVMaxTuneParams クラスのメソッドを次に示します。CogOCVMaxTuneParams クラスメンバの完全なリストについては、「CogOCVMaxTuneParams メンバ」を参照してください。

プロテクトインスタンスメソッド

GetObjectData

参照

CogOCVMaxTuneParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxTuneParams.GetObjectData メソッド

protected override void GetObjectData(
SerializationInfo info,
StreamingContext ctxt
);

参照

CogOCVMaxTuneParams クラス | Cognex.VisionPro.OCVMax 名前空間


CogOCVMaxVerificationTypeConstants 列挙体

各文字に対して実行される検証のタイプを選択するために使用される定数です。

public enum CogOCVMaxVerificationTypeConstants

メンバ

メンバ名 | 説明
Ignore | 対象の文字に対して処理を一切行いません。文字は常に Verified と判定されます。
AlwaysVerified | この文字 (位置) に関連付けられたキーセット内の各キーに得点を与え、最も得点の高いキーを選択し、文字を常に Verified と判定します。
Normal | これは標準の OCV です。このモードでは、文字は Verified、Confused、または Failed と判定される可能性があります。

必要条件

名前空間: Cognex.VisionPro.OCVMax

アセンブリ:Cognex.VisionPro.OCVMax (Cognex.VisionPro.OCVMax.dll 内)

参照

Cognex.VisionPro.OCVMax 名前空間


著作権、商標、および特許

著作権、商標、および特許

本書に記載されているソフトウェアは、使用権許諾の態様で提供され、またかかる使用権許諾の条件に従ってかつ本ページに示されている著作権文言を記載した上で使用または複製することができます。本ソフトウェア、本書、またはこれらの複製物は、使用権者以外のいかなる者に対しても提供され使用に供されることはありません。本ソフトウェアの所有権およびその他の権利は Cognex Corporation または Cognex Corporation への使用権許諾者が留保します。

Cognex Corporation の契約条件およびライセンス契約書に従って、本ソフトウェアおよび / または変更したソフトウェアを Cognex マシンビジョンシステムのみと使用する場合に限り、必要に応じて本書に記載されているソースコードを使用および変更することができます。Cognex Corporation は、ソフトウェアのソースコードの使用についていかなる保証も行わず、いかなる義務または責任も負いません。

Cognex Corporation は、同社が提供してしない装置における同社製ソフトウェアの使用または信頼性についていかなる責任も負いません。Cognex Corporation は、本書で記述されているソフトウェアの内容、商品価値、または特定の使用目的に対する責任に関して、明示または黙示にかかわらずいかなる保証も行いません。

Copyright 2005 Cognex Corporation All Rights Reserved

本書の内容の一部、または全部を Cognex Corporation の書面による許可なく複製、他のメディアに送信すること、および他の言語に翻訳することを禁じます。

本書に説明しているハードウェアおよびソフトウェアの一部については、Cognex ウェブサイト http://www.cognex.com/patents.asp. に示す 1 つまたは複数の米国特許で保護されていることがあります。その他の米国および他国の特許については申請中です。

下記は Cognex Corporation の登録商標です。

表 1
acuCoder | acuFinder | acuReader | acuWin
BGAII | Checkpoint | Cognex | Cognex, Vision for Industry
CVC-1000 | CVL | DisplayInspect | ID Expert
PasteInspect | PatFind | PatInspect | PatMax
PatQuick | PixelProbe | SMD4 | Virtual Checksum
VisionLinx | VisionPro | VisionX

他の Cognex 製品、ツール、またはその他の商標名は、慣習法による Congnex Corporation の商標とみなされることがあります。これらの商標には "TM" がつけられている場合があります。

© 2005 Cognex Corporation.All rights reserved.