Cognex CIT DCAM ヘルプインデックス

IEEE1394 DCAM カメラ用 Cognex カメラ統合ツール

Cognex CIT DCAM ユーティリティは主に、IEEE1394 DCAM 準拠カメラ用 CCF (Camera Configuration File) を作成および変更するために使用される GUI です。CCF は、特定のモードでカメラを制御するためのパラメータ設定が記述されたテキストファイルです。この CCF は、IEEE1394 DCAM カメラからの画像取り込みを設定するときに、CVL (Cognex Vision Library)、または VisionPro によって使用されます。このユーティリティは、CCF ファイルの操作のほか、DCAM を扱うときに便利な情報やツールも提供します。例えば、システムに接続されたすべての DCAM のトポロジ情報を取得できます。また、特定のカメラレジスタのダンプを取得することもできます。これは、問題のデバッグに便利です。

ゲッティングスターテッド

CCF の作成や変更を開始するには、CIT DCAM を使用するモードを決定します。操作モードには 2 種類あります。 1 つはオンラインモード、もう 1 つはオフラインモードです。 オンラインモードはスマートモードで、下位のカメラでサポートされている場合のみ、GUI 選択肢が示されます。オフラインモードはより汎用的で、カメラの既知の仕様に基づいて CCF を作成するために使用されます。

操作モード (オフライン、オンライン)
CCF 作成プロセスとパラメータ情報
ツール
  • レジスタアクセスコントロール
  • DCAM レジスタダンプ
  • DCAM トポロジビューア

最低システム条件:
オフラインモード
Windows 2000、Windows XP、Windows NT (未テスト)

オンラインモード
Windows 2000、Windows XP
システムにプラグインされた DCAM カメラ用にインストールされた最新の Cognex DCAM ドライバ


CIT DCAM - 操作モード

 Cognex CIT DCAM ユーティリティの動作モードには、次の 2 種類があります。
  1. オフラインモード (DCAM が接続されていない場合)
  2. オンラインモード (特定の DCAM が接続されている場合)


CIT DCAM - オフラインモード

オフラインモード

このモードでは、DCAM をシステムに接続せずに、CCF を作成できます。


CIT DCAM - オンラインモード

オンラインモード
このスマートモードでは、接続されているカメラで何がサポートされているかがフィードバックされるので、より簡単に CCF を作成できます。このモードを使用するには、PC にカメラが接続され、このカメラ用の Cognex ドライバがインストールされている必要があります。

オンラインモードに切り替えるには

  1. [Go Online - Target DCAM] ボックスで [+] ボタンを選択します。
  2. [Select DCAM] ダイアログボックスで、CCF の作成対象となる、接続済み DCAM を選択します。[OK] をクリックします。
  3. 選択した DCAM がテキストボックスに表示されます。
    4.
これで、オンラインになりました。


CIT DCAM - CCF パラメータ

CCF の作成およびパラメータ

ここでは、DCAM CCF の作成および編集方法について説明します。

操作モード (オンラインまたはオフライン) を選択したら、実際に CCF の作成に進むことができます。

[Format Name]

これは、CVL または VisionPro で画像取り込みを設定するときに、ビデオフォーマットを表すために使用される文字列です。これはユーザ定義が可能です。

[Manufacturer]

(DCAM 仕様で定義されているビデオフォーマットを使用した) Non Format 7 ベースの CCF では、値「Generic」を使用します。
 Format 7 ベースの CCF では、カメラそのものから読み込んだ実際の名前、または名前の一部を表す文字列にスペースを付けて使用します。

例えば、Camera Manufacturer は「Basler」です。

この場合、CCF の [Manufacturer] 文字列は、「Basler」または「Basl 」になります。後者には、末尾にスペースが付いていることに注意してください。

オンラインモードでの注: サイドにある [+] ボタンを押すと、カメラから自動的に文字列が取得されます。

[Model]

(DCAM 仕様で定義されているビデオフォーマットを使用した) Non Format 7 ベースの CCF では、値「1394DCAM」または空白を使用します。
Format 7 ベースの CCF では、カメラそのものから読み込んだ実際のモデル名、または名前の一部を表す文字列にスペースを付けて使用します。

例えば、Camera Manufacturer は「A602fc」です。
この場合、CCF の [Manufacturer] 文字列は、「A602fc」または「A602f 」になります。後者には、末尾にスペースが付いていることに注意してください。

オンラインモードでの注: サイドにある [+] ボタンを押すと、カメラから自動的に文字列が取得されます。

[Format Info]

[Format Select] ダイアログを表示するには、[+] ボタンを選択します。まず、必要なサイズに応じた [Format] を選択します。
次に、対象が Format 7 CCF か、Non Format 7 CCF かに応じて、モードを選択し、続けて、スピードまたはカラーコーディングを選択します。

このダイアログボックスで [ok] を押すと、[Width]、[Height]、[Video Encoding]、[PixelType]、[BitsPerPixel] などの、必要なフィールドすべてに自動的に値が入力されます。

[Width]

これは取り込まれた画像の幅です。

[Height]

これは取り込まれた画像の高さです。

[Video Encoding]

モノクロタイプのデータに対しては [mono] を選択します。
Bayer 画像データに対しては [Raw] を選択します。
YUV カラー画像データに対しては [YUV] を選択します。

[Pixel Type]

今後取得されるデータのピクセルタイプを選択します。

[Bits Per Pixel]

これは、1 ピクセルあたりに必要な平均ビット数です。

例えば、Mono8 では、1 ピクセルあたり 8 ビットが必要です。

[Other Settings]

[Trigger Mode]

これは、外部的にトリガをかけられたコンフィグギュレーションでカメラを操作するときに、DCAM で使用されるトリガモードです。現在、サポートされているトリガモードは 0 のみです。

[Initial Acquires]

初めてカメラを初期化するときに、ダミー取り込みの実行が必要な場合は、ここに回数を指定する必要があります。

[Shutter Timebase]

これは、絶対露光制御をサポートしていないカメラで必要なパラメータです。

このような場合、露光制御は次の単純な式で表されます。

露光値 = レジスタ値× [Shutter Timebase]

このタイムベースは、ソフトウェアによって内部的に、レジスタ値を計算するために使用されます。ご使用の DCAM で既に絶対露光制御がサポートされている場合、または露光計算が後述の一次方程式に基づいて行われない場合には必要ありません。この場合、ご使用の露光設定には実際のレジスタ値そのものを指定する必要があります。

[Trigger Source]

DCAM 1.31 仕様以降、トリガソースとして使用する GPIO ラインを指定できるようになりました。ここには、そのトリガソースを指定します。何も指定しなかった場合、カメラで指定されたデフォルトのトリガソースが使用されます。

[Strobe IO Line]

DCAM 1.31 仕様以降、DCAM でストロボを使用できるようになりました。ここには、DCAM でストロボがサポートされている場合に使用されるストロボ IO ラインを指定します。ストロボ IO ラインが指定されていない場合、ストロボ機能は使用可能にならないことに注意してください。デフォルトストロボラインの選択の詳細については、使用しているカメラのマニュアルを参照してください。

[Format 7 Params]

これらのパラメータは、Format 7 CCF を作成している場合にのみ適用されます。

[Color Coding]

[Color Coding] は、取り込まれるピクセルデータのタイプです。

[Maximum Bytes Per Packet]

オンラインモードでは、この値はカメラから自動的に読み込まれて、入力されます。オフラインモードでは、手動で入力する必要があります。1394 A カメラでの最大値は 4096 バイトです。

[Region of Interest Offsets]

Bayer データ CCF を作成する場合に必要です。Bayer から RGB への変換アルゴリズムでは、最上位の x および y ピクセルは特定の色である必要があります。多くのセンサは、この条件を満たしていません。このような場合、roi x および roi y の値を指定して、画像へのオフセットを作成することができます。ただし、幅と高さを調整する場合は、roi x と幅の合計が、カメラから取得されたフォーマットの幅の合計を超えないということ、および roi y と高さの合計が、カメラの高さの合計を超えないということを考慮してください。


([Choose Color] ダイアログ)

[Choose Color] ダイアログボックス

<< ここに、アプリケーション固有のヘルプを記入してください。>>


([File Open] ダイアログボックス)

開くファイルを指定するには、次のオプションを使用します。

[File Name]

開くファイルを指定します。このボックスには、[List Files of Type] フィールドで選択した拡張子を持つファイルの一覧が表示されます。

[List Files of Type]

開くファイルのタイプを指定します。

<< ここに、ご使用のアプリケーションのファイルタイプをリストしてください。>>

[Drives]

開こうとするファイルを格納している <<YourApp>> があるドライブを指定します。

[Directories]

開こうとするファイルを格納している <<YourApp>> があるディレクトリを指定します。

[Network]

ネットワーク上の場所に接続するには、このボタンをクリックします。この場所には、新しいドライブ文字が割り当てられます。


([File Save As] ダイアログボックス)

これから保存するファイルの名前と場所を指定するには、次のオプションを使用します。

File Name

別の名前を付けて文書を保存する場合は、ここにファイル名を指定します。<<YourApp>> によって、[Save File As Type] ボックスで指定した拡張子が追加されます。

Drives

文書の保存先ドライブを指定します。

Directories

文書の保存先ディレクトリを指定します。

Network

ネットワーク上の場所に接続するには、このボタンをクリックします。この場所には、新しいドライブ文字が割り当てられます。

<< CFileDialog で使用される OPENFILENAME 構造体の OFN_ フラグを介してご使用のアプリケーションが選択した内容に従って、そのほかの [File Save As] ダイアログボックスオプションを追加してください。>>


([Find] ダイアログ)

[Find] ダイアログボックス

<< ここに、アプリケーション固有のヘルプを記入してください。>>


([Choose Font] ダイアログ)

[Choose Font] ダイアログボックス

<< ここに、アプリケーション固有のヘルプを記入してください。>>


([File New] ダイアログボックス)

<< ご使用のアプリケーションでサポートされる文書のタイプが 1 つのみである場合は、このヘルプトピックを削除してください。>>

作成する文書のタイプを指定します。

<< ここに、ご使用のアプリケーションの文書タイプをリストしてください。>>


([Replace] ダイアログ)

[Replace] ダイアログボックス

<< ここに、アプリケーション固有のヘルプを記入してください。>>


(ヘルプはありません)

このメッセージボックスに対するヘルプはありません。

<< 個々のメッセージボックスプロンプトに対して専用のヘルプを作成する必要がある場合は、ご使用の .hpj ファイルの [ALIAS] セクションから AFX_HIDP_xxx 値を削除し、AFX_HIDP_xxx 値それぞれに対してトピックを作成してください。例えば、AFX_HIDP_INVALID_FILENAME は [Invalid Filename] メッセージボックスのヘルプトピックです。>>


(ドッキングツールバー領域)

この領域は、アプリケーション用に作成されたデフォルトツールバーなどのドッキング可能なツールバーを収納するために提供されています。ドッキングツールバーをドラッグして、このクライアント領域に入れたり、この領域から別の場所に移動したりすることができます。また、使用可能なスペースに応じて配置を変えることもできます。


(ステータスバー)

ステータスバーは <<YourApp>> ウィンドウの最下部に表示されます。ステータスバーの表示、非表示を切り替えるには、[View] メニューの [Status Bar] コマンドを使用します。

矢印キーを使用してメニューを移動していくと、ステータスバーの左側にある領域には、メニュー項目の動作に関する説明が表示されます。同様に、ツールバーのボタンを押したままにすると、このボタンの動作に関する説明もこの領域に示されます。ツールバーボタンコマンドの説明を読んだ後で、このコマンドを実行する必要がないとわかった場合、ツールバーボタンではない部分にポインタを移動させてから、マウスボタンを放してください。

ステータスバーの右側の領域には、次のキーのどれが押されているかが表示されます。

インジケータ 説明

CAP <Caps Lock> キーが押されています。

NUM <Num Lock> キーが押されています。

SCRL <Scroll Lock> キーが押されています。


(ツールバー)

ツールバーは、アプリケーションウィンドウの最上部、メニューバーの下に表示されます。ツールバーとマウスによって、<<YourApp>> で使用されるさまざまなツールにすばやくアクセスすることができます。

ツールバーの表示、非表示を切り替えるには、[View] メニューの [Toolbar] をクリックします。


([About] コマンド ([Help] メニュー))

<<YourApp>> の著作権情報やバージョン番号を表示するにはこのコマンドを使用します。


([File] → [Exit] コマンド)

[Exit] コマンド ([File] メニュー)

<<YourApp>> セッションを終了するには、このコマンドを使用します。また、アプリケーションの [Control] メニューにある [Close] コマンドも使用できます。<<YourApp>> からは、変更内容がまだ保存されていない文書を保存するためのプロンプトが表示されます。


([Help] → [Using Help] コマンド)

[Context Help] コマンド

<<YourApp>> の一部についてのヘルプを表示するには、このコマンドを使用します。ツールバーの [Context Help] ボタンを選択すると、マウスポインタの形が疑問符の付いた矢印に変わります。次に、<<YourApp>> ウィンドウの任意の場所 (別のツールバーボタンなど) をクリックします。クリックした項目に関するヘルプトピックが示されます。


([Edit] → [Clear] コマンド)

[Clear] コマンド ([Edit] メニュー)

<< ここに、アプリケーション固有のヘルプを記入してください。>>


([Edit] → [Clear All])

[Clear All] コマンド ([Edit] メニュー)

<< ここに、アプリケーション固有のヘルプを記入してください。>>


([Copy] コマンド ([Edit] メニュー))

選択したデータをクリップボードにコピーするには、このコマンドを使用します。何もデータが選択されていない場合、このコマンドは使用できません。

クリップボードに格納されていた内容は、コピーしたデータに置き換えられます。


([Cut] コマンド ([Edit] メニュー))

選択されているデータを文書から削除し、クリップボードに格納するには、このコマンドを使用します。何もデータが選択されていない場合、このコマンドは使用できません。

クリップボードに格納されていた内容は、切り取られたデータに置き換えられます。


([Edit] → [Find] コマンド)

[Find] コマンド ([Edit] メニュー)

<< ここに、アプリケーション固有のヘルプを記入してください。>>


([Paste] コマンド ([Edit] メニュー))

挿入ポイントに、クリップボードの内容のコピーを挿入するには、このコマンドを使用します。クリップボードが空の場合、このコマンドは使用できません。


([Redo] コマンド ([Edit] メニュー))

<< ここに、アプリケーション固有のヘルプを記入してください。>>


([Edit] → [Repeat] コマンド)

[Repeat] コマンド ([Edit] メニュー)

直前に実行した編集コマンドを繰り返すには、このコマンドを使用します。最後の操作を繰り返すことができない場合は、[Repeat] メニュー項目は [Can't Repeat] に変わります。


([Edit] → [Replace] コマンド)

[Replace] コマンド ([Edit] メニュー)

<< ここに、アプリケーション固有のヘルプを記入してください。>>


([Undo/Can't Undo] コマンド ([Edit] メニュー))

<< [Undo] に対するご使用のアプリケーションのユーザインタフェースは、後述の説明と異なる場合があります。必要に応じて、このヘルプテキストを変更してください。>>

可能な場合、直前に実行した編集コマンドを取り消すには、このコマンドを使用します。最後に実行した操作に応じて、このコマンドの名前が変更されます。最後の操作を取り消すことができない場合は、メニューの [Undo] コマンドは [Can't Undo] に変わります。


([File] → [Close] コマンド)

[Close] コマンド ([File] メニュー)

アクティブな文書を含むウィンドウをすべて閉じるには、このコマンドを使用します。文書を閉じる前に、<<YourApp>> からは、文書に対する変更を保存するためのプロンプトが表示されます。保存せずに文書を閉じると、最後に保存してから行った変更内容はすべて失われます。名前の付いていない文書を閉じようとすると、<<YourApp>> によって、文書に名前を付けて保存するための [File Save As] ダイアログボックスが表示されます。


([File 1、2、3、4] コマンド)

[1]、[2]、[3]、[4] コマンド ([File] メニュー)

最後に閉じた文書からさかのぼって 4 つまでの文書を開くには、[File] メニューの下に表示されている番号とファイル名を使用します。開く文書に対応する番号を選択してください。


([File] → [New] コマンド)

[New] コマンド ([File] メニュー)

<<YourApp>> で新しい文書を作成するには、このコマンドを使用します。[File New] ダイアログボックスで、新たに作成するファイルのタイプを選択します。<< ご使用のアプリケーションでサポートされる文書のタイプが 1 つのみである場合は、この前の 1 文を削除してください。>>

既存の文書を開くには、[Open] コマンドを使用します。


([File] → [Open] コマンド)

[Open] コマンド ([File] メニュー)

新しいウィンドウに既存の文書を開くには、このコマンドを使用します。一度に複数の文書を開くことができます。複数の文書を開いている場合に、文書を切り替えるには、[Window] メニューを使用します。[Window] → [1]、[2] ... コマンドを参照してください。

新しい文書を作成するには、[New] コマンドを使用します。


([File] → [Save] コマンド)

[Save] コマンド ([File] メニュー)

アクティブな文書を、そのままの名前で、現在保存されているディレクトリに保存するには、このコマンドを使用します。初めて文書を保存すると、<<YourApp>> によって、[File Save As] ダイアログボックスが表示されるので、文書に名前を付けることができます。保存する前に、既存の文書の名前とディレクトリを変更するには、[Save As] コマンドを選択します。


([File] → [Save As] コマンド)

[Save As] コマンド ([File] メニュー)

アクティブな文書に名前を付けて保存するには、このコマンドを使用します。<<YourApp>> によって、[File Save As] ダイアログボックスが表示されるので、文書に名前を付けることができます。

現在の名前で、現在保存されているディレクトリに文書を保存するには、[Save] コマンドを使用します。


([Send] コマンド ([File] メニュー))

電子メールを通じて、アクティブな文書を送信するには、このコマンドを使用します。このコマンドを選択すると、アクティブな文書が添付されたメールウィンドウが表示されます。[To] フィールド、[Subject] フィールドなどに必要事項を入力し、メッセージの本文にテキストを入力します。終了したら、[Send] ボタンをクリックして、メッセージを送信します。


([Index] コマンド ([Help] メニュー))

ヘルプの先頭画面を表示するには、このコマンドを使用します。この先頭画面から、<<YourApp>> を使用するためのステップごとの手順や、さまざまなタイプのリファレンス情報にジャンプできます。

ヘルプを開いた後、[Contents] ボタンをクリックすれば、いつでも先頭画面に戻ることができます。


([Using Help] コマンド ([Help] メニュー))

ヘルプの使用方法を表示するには、このコマンドを使用します。


(タイトルバー)

<< ここに、ご使用のアプリケーションのタイトルバーを示してください。>>

タイトルバーは、ウィンドウの上部に沿って表示されます。このバーには、アプリケーションと文書の名前が表示されます。

ウィンドウを移動するには、タイトルバーをドラッグします。注: タイトルバーをドラッグして、ダイアログボックスを移動することもできます。

タイトルバーに、次の要素が含まれる場合もあります。

[Application Control] メニューボタン

[Document Control] メニューボタン

[Maximize] ボタン

[Minimize] ボタン

アプリケーションの名前

文書の名前

[Restore] ボタン


(ヘルプはありません)

ウィンドウのこの領域に対するヘルプはありません。


([Next Pane] コマンド)

Next Pane

<< ここに、アプリケーション固有のヘルプを記入してください。>>


([Prev Pane] コマンド)

Prev Pane

<< ここに、アプリケーション固有のヘルプを記入してください。>>


([Close] コマンド ([Control] メニュー))

アクティブなウィンドウやダイアログボックスを閉じるには、このコマンドを使用します。

[Control] メニューボックスをダブルクリックすることは、[Close] コマンドを選択することと同じです。

注: 1 つの文書に対して複数のウィンドウを開いている場合でも、文書の [Control] メニューにある [Close] コマンドで一度に閉じられるウィンドウは 1 つのみです。すべてのウィンドウを一度に閉じるには、[File] メニューの [Close] コマンドを使用します。


([Maximize] コマンド ([System] メニュー))

使用可能なスペース全体にアクティブウィンドウを拡大するには、このコマンドを使用します。


([System] → [Minimize] コマンド)

[Minimize] コマンド (アプリケーションの [Control] メニュー)

<<YourApp>> ウィンドウをアイコン化するには、このコマンドを使用します。


([Move] コマンド ([Control] メニュー))

このコマンドを使用すると、先端が 4 つある矢印が表示されます。その後、矢印キーを使用して、アクティブなウィンドウやダイアログボックスを移動できます。

注: ウィンドウが最大化されている場合、このコマンドは使用できません。


([Next Window] コマンド (文書の [Control] メニュー))

開いている文書ウィンドウの次のウィンドウに切り替えるには、このコマンドを使用します。どれが次のウィンドウであるかは、ウィンドウを開いた順序に従って、<<YourApp>> によって決定されます。


([Previous Window] コマンド (文書の [Control] メニュー))

開いている文書ウィンドウの前のウィンドウに切り替えるには、このコマンドを使用します。どれが前のウィンドウであるかは、ウィンドウを開いた順序に従って、<<YourApp>> によって決定されます。


([Restore] コマンド ([Control] メニュー))

アクティブウィンドウを、[Maximize] または [Minimize] コマンドを選択する前のサイズや位置に戻すには、このコマンドを使用します。


([Size] コマンド ([System] メニュー))

このコマンドを使用すると、先端が 4 つある矢印が表示されます。その後、矢印キーを使用して、アクティブなウィンドウのサイズを変更できます。

ポインタが、先端が 4 つある矢印に変わったら、次の操作を行います。

1. 矢印キーの 1 つ (左、右、上、または下矢印キー) を押して、移動する境界線上にポインタを移動します。

2. 矢印キーを押して、境界線を移動します。

3. ウィンドウが希望するサイズになったら、<ENTER> キーを押します。

注: ウィンドウが最大化されている場合、このコマンドは使用できません。


([Switch to] コマンド (アプリケーションの [Control] メニュー))

開いているアプリケーションのリストを表示するには、このコマンドを使用します。このタスクリストを使用して、リスト中のアプリケーションに切り替えたり、アプリケーションを閉じたりすることができます。

ダイアログボックスのオプション

[Switch To] コマンドを選択すると、次のオプションを持つダイアログボックスが表示されます。

[Task List]

切り替え先、または閉じるアプリケーションを指定します。

[Switch To]

選択したアプリケーションをアクティブにします。

[End Task]

選択したアプリケーションを閉じます。

[Cancel]

[Task List] ボックスを閉じます。

[Cascade]

開かれている複数のアプリケーションを重なり合うように並べ替えて、それぞれのタイトルバーが見えるようにします。ただし、アイコン化されているアプリケーションはこのオプションの影響を受けません。

[Tile]

開かれている複数のアプリケーションを、重なり合わないようにウィンドウに配置します。ただし、アイコン化されているアプリケーションはこのオプションの影響を受けません。

[Arrange Icons]

最小化されているアプリケーションのアイコンをすべて、画面の最下部に沿って並べます。


([View] → [Ruler] コマンド)

[Ruler] コマンド ([View] メニュー)

<< ここに、アプリケーション固有のヘルプを記入してください。>>


([View] → [Status Bar] コマンド)

[Status Bar] コマンド ([View] メニュー)

ステータスバーの表示、非表示を切り替えるには、このコマンドを使用します。ステータスバーには、メニュー項目を選択したり、ツールバーボタンを押したりすることによって実行される動作の説明や、キーボードで押されているキーの状態が表示されます。ステータスバーが表示されている場合、このメニュー項目の隣にチェックマークが表示されます。

ステータスバーの使用方法については、「ステータスバー」を参照してください。


([View] → [Toolbar] コマンド)

[Toolbar] コマンド ([View] メニュー)

ツールバーの表示、非表示を切り替えるには、このコマンドを使用します。ツールバーには、[File Open] など、<<YourApp>> で最も一般的なコマンドの一部に対応するボタンが表示されます。ツールバーが表示されている場合、このメニュー項目の隣にチェックマークが表示されます。

ツールバーの使用方法については、「ツールバー」を参照してください。


(1, 2, ... コマンド ([Window] メニュー))

[1]、[2] ... コマンド ([Window] メニュー)

<<YourApp>> は、[Window] メニューの最下部に、現在開かれている文書ウィンドウのリストを表示します。アクティブウィンドウに表示されている文書名の前にはチェックマークが表示されます。このリストから文書を選択すると、対応するウィンドウがアクティブになります。


([Window] → [Arrange Icons] コマンド)

[Window] → [Arrange Icons] コマンド

メインウィンドウの最下部に、最小化したウィンドウのアイコンを並べるには、このコマンドを使用します。メインウィンドウの最下部に、文書ウィンドウが開かれている場合、一部、またはすべてのアイコンがこの文書ウィンドウの下に隠れて見えない可能性があります。


([Cascade] コマンド ([Window] メニュー))

開かれている複数のウィンドウを重ね合わせて並べるには、このコマンドを使用します。


([New] コマンド ([Window] メニュー))

アクティブウィンドウと同じ内容を持つウィンドウを新たに開くには、このコマンドを使用します。複数の文書ウィンドウを開いて、文書の別の部分やビューを同時に複数表示できます。あるウィンドウの内容を変更すると、同じ文書が表示された別のウィンドウすべてにこの変更が反映されます。新しいウィンドウを開くと、そのウィンドウがアクティブウィンドウになり、開かれているほかのすべてのウィンドウの最上部に表示されます。


([Split] コマンド ([Window] メニュー))

アクティブウィンドウをペインに分割するには、このコマンドを使用します。その後、マウスまたはキーボードの矢印キーを使用して、スプリッタバーを移動します。完了したら、マウスボタンか <Enter> キーを押して、移動後の場所にスプリッタバーを固定します。<Escape> キーを押すと、スプリッタバーは元の位置に残ります。<< 単一文書インタフェースアプリケーションでは、このコマンドは [View] メニューに表示されます。>>


([Tile] コマンド ([Window] メニュー))

開かれている複数のウィンドウを重ねずに並べるには、このコマンドを使用します。


([Tile Horizontal] コマンド ([Window] メニュー))

開かれている複数のウィンドウを縦方向に、重ねずに並べるには、このコマンドを使用します。


([Tile Vertical] コマンド ([Window] メニュー))

開かれている複数のウィンドウを隣り合わせに並べるには、このコマンドを使用します。


(文書の変更)

<< ここには、ご使用のアプリケーションを使用して、ドキュメントを変更する方法の概要を説明した、このアプリケーション固有のヘルプを記入します。

ご使用のアプリケーションで複数の文書タイプがサポートされているときに、それぞれのタイプについて個別にヘルプトピックを作成する場合は、アプリケーションウィザードで作成された MAKEHELP.BAT ファイルの実行によって生成されたヘルプコンテキスト ID を使用します。または、MAKEHM を次のように実行します。

makehm IDR_HIDR_,0x2000 resource.h

ご使用の文書タイプのうちの 1 つに対応する IDR_ シンボルが、例えば IDR_CHARTTYPE である場合、MAKEHM によって生成されるヘルプコンテキスト ID は HIDR_CHARTTYPE になります。

注: アプリケーションウィザードは、ご使用のアプリケーションでサポートされる最初の文書タイプに対して、このヘルプトピックによって使用される HIDR_DOC1TYPE ヘルプコンテキスト ID を定義します。このアプリケーションウィザードは、ご使用のアプリケーションの .hpj ファイルにエイリアスを作成し、その文書タイプに対して MAKEHM によって生成された HIDR_ に HIDR_DOC1TYPE をマッピングします。>>


([Edit] メニューのコマンド)

[Edit] メニューには、次のコマンドが用意されています。

[Undo] | 直前の編集操作を元に戻します。
[Cut] | 文書からデータを削除し、クリップボードに移動します。
[Copy] | 文書からデータをコピーし、クリップボードに移動します。
[Paste] | クリップボードから文書にデータを貼り付けます。


([File] メニューのコマンド)

[File] メニューには、次のコマンドが用意されています。

[New] | 新規文書を作成します。
[Open] | 既存の文書を開きます。
[Close] | 開いている文書を閉じます。
[Save] | 同じファイル名を使用して、開いている文書を保存します。
[Save As] | 開いている文書を指定された名前で保存します。
[Exit] | <<YourApp>> を終了します。


([Help] メニューのコマンド)

[Help] メニューには、このアプリケーションの使用をサポートする次のコマンドが用意されています。

[Help Topics] | トピックスのインデックスを表示します。ここからヘルプを表示することができます。
[About] | このアプリケーションのバージョン番号を表示します。


([View] メニューのコマンド)

[View] メニューには、次のコマンドが用意されています。

[Toolbar] | ツールバーの表示、非表示を切り替えます。
[Status Bar] | ステータスバーの表示、非表示を切り替えます。


([Window] メニューのコマンド)

[Window] メニューには、次のコマンドが用意されています。これらのコマンドを使用して、アプリケーションウィンドウ内に複数の文書を、複数のビューに配置することができます。

[New Window] | 新規ウィンドウを作成し、同じ文書を表示します。
[Cascade] | ウィンドウを重ねて配置します。
[Tile] | ウィンドウを重ねずに配置します。
[Arrange Icons] | 最小化されたウィンドウのアイコンを配置します。
[Window] → [1]、[2] ... | 指定されたウィンドウに移動します。


(スクロールバー)

文書ウィンドウの右側と下端に表示されます。スクロールバー内のスクロールボックスは、文書での垂直および水平位置を表しています。マウスを使用して、文書の別の位置にスクロールすることができます。

<< ご使用のアプリケーションでの動作に従って、スクロールバーのさまざまな部分の動作を説明してください。>>