About the In-Sight Software Development Kit

The In-Sight Software Development Kit (SDK) provides a rich set of classes which allow you to develop custom applications that interface with In-Sight sensors from .NET environments. Applications developed with the In-Sight SDK can implement a wide variety of features, including the ability to edit job files and to obtain acquisition results independent of In-Sight Explorer.

The In-Sight SDK provides a unified way to interact with an In-Sight sensor from a PC. Every component is defined in a namespace, which is simply a way of grouping objects in a hierarchy to make them easier to identify. These namespaces form a hierarchy where a particular namespace is identified by a series of words separated by dots. For example, objects that allow you to configure the settings of an In-Sight sensor are located in the Cognex.InSight.Sensor namespace.

NOTE: All In-Sight SDK applications must call a method in order to initialize the In-Sight SDK.

  • C# .NET: CvsInSightSoftwareDevelopmentKit.Initialize()

  • VB .NET: CvsInSightSoftwareDevelopmentKit.Initialize

Anything not explicitly documented in this reference documentation is for internal use only by In-Sight SDK components and should not be used in your application(s). This includes all types contained in any namespace called Internal, as well as some hidden properties and methods that are not for external use. Internal-use-only properties are not guaranteed to function, and these may be removed or altered in a future release without notice.

Class Interaction

The following graphic illustrates the primary classes used in a typical In-Sight SDK application and how they relate to one another. Click on a blue region for details on that particular class:

The CvsNetworkMonitor class detects In-Sight sensors on your network. The CvsNativeModeClient class allows you to communicate with an In-Sight sensor using the Native Mode protocol. The CvsFtpClient class performs file transfers using FTP. The CvsInSight class establishes a connection to an In-Sight sensor and retrieves results (including the image, cell data and graphics.) The CvsResultSet class stores the image, graphics, and cells received from an In-Sight sensor. The CvsInSightDisplay class displays images, graphics, and cell data from an In-Sight sensor.

The In-Sight Display Control

The In-Sight Display Control (CvsInSightDisplay) forms the core of the Job View window in In-Sight Explorer and provides a display of images, graphics and spreadsheet data when connected to an In-Sight sensor. This same level of functionality can be incorporated into your custom application by simply adding a CvsInSightDisplay control and setting a few properties. See the Tutorials section for step-by-step instructions on creating a new In-Sight application containing the CvsInSightDisplay control in C# and VB.NET.

The CvsInSight Object

The CvsInSight object is used to programmatically establish a connection to an In-Sight sensor.

The CvsResultSet Object

A CvsResultSet object is returned from the In-Sight sensor with every image acquisition. This object contains the image, graphics and cells from the latest acquisition. The contents of the CvsResultSet object are depicted graphically in the following image; click on any blue region for details on that particular class:

The CvsGraphicCollection class holds the current set of graphics associated with an image acquisition. The CvsImage class encapsulates the data associated with an acquired image from an In-Sight sensor. The properties of the CvsImage include everything necessary to construct a bitmap that may be rendered on a display. The CvsCellCollection represents a collection of cells in the active job file. Each item is a CvsCell object. The CvsResultSet class holds the image, graphics, and cells received from an In-Sight sensor, including processor constants and information about the job file. The CvsJobInfo object holds information about the job loaded on an In-Sight sensor. The CvsProcessorConstants class holds the processor constants for an In-Sight sensor. Processor constants include image width, image height and flags that determine support for various features (such as Undo, OPC and color support) and more.

Tutorials and Samples

Tutorials are provided to walk you through the process of creating a new In-Sight Application. Fully-featured sample projects are installed by default to %ALL_USERS_PROFILE%\Documents\Cognex\In-Sight\In-Sight Sample Projects <version>. If you originally elected not to install the sample projects, you may install them by launching the Add/Remove Programs Control Panel applet, selecting the Cognex In-Sight Software Development Kit and Change/Modify the installation to include the Sample Projects feature.

Copyright (c) 2004-2014 Cognex Corporation.


System Requirements

Please consult the In-Sight SDK Release Notes for the System Requirements of this release. The Release Notes can be accessed from the Start Menu > Programs > Cognex > In-Sight > In-Sight SDK 6.5.0.

Copyright (c) 2004-2022 Cognex Corporation.


In-Sight Character Mapping

When string data from an In-Sight sensor is retrieved via properties and methods, it is mapped (or translated) to Unicode. This facilitates both its rendering and translation into other languages. Methods like CvsCellString.GetRawBytes allow the retrieval of the un-translated bytes received from the sensor. Most of the bytes that comprise a Unicode string, however, may be translated back to the corresponding In-Sight character using the following table:

In-Sight Character (hexadecimal) | Unicode Value (hexadecimal)
0x02 | 0
0x03 | 0xE001 (In-Sight Button Symbol)
0x04 | 0
0x05 | 0
0x06 | 0
0x07 | 0xE002 (Vision Tool Symbol)
0x08 | 0
0x0E | 0
0x0F | 0xE003 (Up Arrow Button Symbol)
0x10 | 0xE004 (Down Arrow Button Symbol)
0x11 | 0xE005 (Right Arrow Button Symbol)
0x12 | 0xE006 (Left Arrow Button Symbol)
0x13 | 0xE007 (Cross Button Symbol)
0x14 | 0xE008 (Circle Button Symbol)
0x15 | 0xE009 (Triangle Button Symbol)
0x16 | 0xE00A (Square Button Symbol)
0x17 | 0
0x18 | 0
0x19 | 0
0x1A | 0xE00B (Edit Region Symbol)
0x1B | 0xE00C (Unchecked Option Symbol)
0x1C | 0xE00D (Checked Option Symbol)
0x1D | 0x25BA (Right Pointing Black Triangle)
0x9A | 0xE00E (Select Symbol)
0x9B | 0xE00F (Dialog Symbol)
0x9C | 0xE010 (Link Symbol)
0xA0 | 0x2122 (Trademark Symbol)
0xAB | 0xE011 (Wizard Symbol)
0xAC | 0x25CF (Black Circle)
0xAD | 0x25CB (White Circle)
0xB2 | 0x2190 (Left Pointing Arrow)
0xB3 | 0x2192 (Right Pointing Arrow)
0xB7 | 0x00D7 (Multiplication Symbol)
0xB8 | 0x2193 (Down Pointing Arrow)
0xB9 | 0x2191 (Up Pointing Arrow)
0xD7 | 0x00B7 (Middle Dot)


3.1.0 to 3.2.0

In-Sight SDK
API Changes

API Changes - Cognex.InSight.Controls.Display.dll (3.1.1156.0 to 3.2.1328.0)

Added Constructors

Cognex.InSight.Controls.Display.CvsEditEventHandler..ctor(object object, System.IntPtr method)

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder..ctor()

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder..ctor(Cognex.InSight.Controls.Display.CvsInSightDisplay display, string sensorName)

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults..ctor()

Added Methods

Cognex.InSight.Controls.Display.CvsEditEventHandler.BeginInvoke(object sender, Cognex.InSight.Controls.Display.CvsEditEventArgs e, System.AsyncCallback callback, object object)

Cognex.InSight.Controls.Display.CvsEditEventHandler.EndInvoke(System.IAsyncResult result)

Cognex.InSight.Controls.Display.CvsEditEventHandler.Invoke(object sender, Cognex.InSight.Controls.Display.CvsEditEventArgs e)

Cognex.InSight.Controls.Display.CvsInSightDisplay.DisplayApplicationGraphics(Cognex.InSight.Graphic.CvsGraphic[] graphics)

Cognex.InSight.Controls.Display.CvsInSightDisplay.EditGraphics(Cognex.InSight.Graphic.ICvsEditableGraphic[] graphics)

Cognex.InSight.Controls.Display.CvsInSightDisplay.OnMouseEnter(System.EventArgs e)

Cognex.InSight.Controls.Display.CvsInSightDisplay.OnMouseLeave(System.EventArgs e)

Cognex.InSight.Controls.Display.CvsInSightDisplay.Update()

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.Dispose()

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.GetPlaybackFiles()

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlayFirst()

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlayLast()

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlayNext()

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlayPrevious()

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.Refresh()

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.Dispose()

Added Property Setters

Cognex.InSight.Controls.Display.CvsEditEventArgs.Accept { set; }

Cognex.InSight.Controls.Display.CvsEditEventArgs.Value { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.Action { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.FtpPort { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.ImageOrientation { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.Recorder { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowDependencyErrorsOnly { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.AlwaysShowOptions { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlayActive { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackContinuous { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackDelay { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackFilename { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackFolder { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackIndex { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordActive { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordFilenameFormat { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordFolder { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordIndex { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordMax { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordMode { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordResolution { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordWatchCell { set; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordFilenameFormat { set; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordFolder { set; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordMax { set; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordResolution { set; }

Added Property Getters

Cognex.InSight.Controls.Display.CvsEditEventArgs.Accept { get; }

Cognex.InSight.Controls.Display.CvsEditEventArgs.CellLocation { get; }

Cognex.InSight.Controls.Display.CvsEditEventArgs.Value { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.Action { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.ClientToSensorTransform { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.FtpPort { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.ImageOrientation { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.Recorder { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.SensorToClientTransform { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowDependencyErrorsOnly { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditDateTimeSettings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditDiscreteInputSettings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditDiscreteOutputSettings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditFtpSettings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditHostTableSettings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditImageSettings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditNetworkSettings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditSerialPort0Settings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditSerialPort1Settings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditStartupSettings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditUserListSettings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ExportCell { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.GoToFirstError { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ImportCell { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.NextImageOrientation { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.Play { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.PlayFirst { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.PlayLast { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.PlayNext { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.PlayPrevious { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ProfileJob { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.Record { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.RecordPlaybackOptions { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.SetRamDiskSize { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowDependencyErrorsOnly { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowDependencyLevelsDecrease { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowDependencyLevelsIncrease { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowDependencyLevelsReset { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.AlwaysShowOptions { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlayActive { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackContinuous { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackDelay { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackFilename { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackFolder { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackImageCount { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackIndex { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordActive { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordFilename { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordFilenameFormat { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordFolder { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordImageCount { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordIndex { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordMax { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordMode { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordResolution { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordWatchCell { get; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordFilenameFormat { get; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordFolder { get; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordMax { get; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordResolution { get; }

Added Classes

Cognex.InSight.Controls.Display.CvsEditEventArgs

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder

Added Events

Cognex.InSight.Controls.Display.CvsInSightDisplay.EditCellExpressionCompleted

Cognex.InSight.Controls.Display.CvsInSightDisplay.EditGraphicsCompleted

Cognex.InSight.Controls.Display.CvsInSightDisplay.ImageOrientationChanged

Cognex.InSight.Controls.Display.CvsInSightDisplay.PlayActiveChanged

Cognex.InSight.Controls.Display.CvsInSightDisplay.RecordActiveChanged

Added Delegates

Cognex.InSight.Controls.Display.CvsEditEventHandler

Added Enumerations

Cognex.InSight.Controls.Display.CvsRecordMode

Added Enumeration Values

Cognex.InSight.Controls.Display.CvsRecordMode.All

Cognex.InSight.Controls.Display.CvsRecordMode.Good

Cognex.InSight.Controls.Display.CvsRecordMode.Bad

Cognex.InSight.Controls.Display.CvsRecordMode.Sort

Removed Custom Attributes

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowCustomView { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

Added Custom Attributes

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.Action { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.Action { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.FtpPort { get; } - [ComponentModel.Description("The FTP port used to create FTP connections to sensors.")]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.FtpPort { get; } - [ComponentModel.DefaultValue((Int32)21)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.FtpPort { get; } - [ComponentModel.Category("Behavior")]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.ImageOrientation { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.ImageOrientation { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.Recorder { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.Recorder { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowDependencyErrorsOnly { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowDependencyErrorsOnly { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditDateTimeSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditDiscreteInputSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditDiscreteOutputSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditFtpSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditHostTableSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditImageSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditNetworkSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditSerialPort0Settings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditSerialPort1Settings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditStartupSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditUserListSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ExportCell { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.GoToFirstError { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)196730)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ImportCell { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.NextImageOrientation { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)65647)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.Play { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.Play { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131149)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.PlayFirst { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131144)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.PlayLast { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131148)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.PlayNext { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131147)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.PlayPrevious { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131146)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ProfileJob { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.Record { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.Record { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131154)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.RecordPlaybackOptions { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131156)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.SetRamDiskSize { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowDependencyErrorsOnly { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)262266)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowDependencyLevelsDecrease { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)65658)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowDependencyLevelsIncrease { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)122)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowDependencyLevelsReset { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131194)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackFilename { get; } - [Xml.Serialization.XmlIgnore]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackIndex { get; } - [Xml.Serialization.XmlIgnore]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordIndex { get; } - [Xml.Serialization.XmlIgnore]

Enum:Cognex.InSight.Controls.Display.CvsRecordMode - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Display.CvsEditEventArgs - [ComVisible((Boolean)False)]

T:Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder - [Serializable]

T:Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder - [ComSourceInterfaces("")]

T:Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder - [ClassInterface((ClassInterfaceType)2)]

API Changes - Cognex.InSight.dll (3.1.1156.0 to 3.2.1328.0)

Removed Constructors

Cognex.InSight.Graphic.CvsGraphicAnnulus..ctor(Cognex.InSight.CvsCellLocation cell, Cognex.InSight.CvsImageLocation center, System.Single innerRadius, System.Single outerRadius)

Cognex.InSight.Graphic.CvsGraphicCircle..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation center, System.Single radius)

Cognex.InSight.Graphic.CvsGraphicPoint..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation location)

Added Constructors

Cognex.InSight.Graphic.CvsGraphicAnnulus..ctor(Cognex.InSight.CvsCellLocation cell, Cognex.InSight.CvsImageLocation center, System.Single innerRadius, System.Single outerRadius, string label)

Cognex.InSight.Graphic.CvsGraphicArc..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation center, System.Single startAngle, System.Single endAngle, System.Single radius, string label)

Cognex.InSight.Graphic.CvsGraphicArc..ctor()

Cognex.InSight.Graphic.CvsGraphicCircle..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation center, System.Single radius, string label)

Cognex.InSight.Graphic.CvsGraphicPoint..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation location, string label)

Cognex.InSight.Graphic.CvsGraphicPolyline..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation[] points)

Cognex.InSight.Graphic.CvsGraphicPolyline..ctor()

Cognex.InSight.Graphic.CvsGraphicText..ctor(Cognex.InSight.CvsCellLocation cell, Cognex.InSight.CvsImageLocation location, string label)

Cognex.InSight.Graphic.CvsGraphicText..ctor()

Removed Methods

Cognex.InSight.Graphic.CvsGraphicAnnulus.Initialize(int cellRow, int cellCol, System.Single centerRow, System.Single centerCol, System.Single innerRadius, System.Single outerRadius)

Cognex.InSight.Graphic.CvsGraphicCircle.Initialize(int cellRow, int cellCol, System.Single centerRow, System.Single centerCol, System.Single circleRadius)

Cognex.InSight.Graphic.CvsGraphicPoint.Initialize(int cellRow, int cellCol, System.Single pointRow, System.Single pointCol)

Added Methods

Cognex.InSight.Cell.CvsCellCollection.GetCells(int row, int column, int rows, int columns)

Cognex.InSight.Cell.CvsCellCollection.GetCells(Cognex.InSight.CvsCellRange range)

Cognex.InSight.Cell.CvsCellString.GetRawBytes()

Cognex.InSight.CvsFile.CompareTo(object obj)

Cognex.InSight.CvsFileCollection.GetEnumerator()

Cognex.InSight.CvsFileCollection.GetFilteredCollection(string extension)

Cognex.InSight.CvsFileManager.SendImageToInSight(string localFilename)

Cognex.InSight.Ftp.CvsFtpClient.GetFileCollection(string directory)

Cognex.InSight.Graphic.CvsGraphic.Clone()

Cognex.InSight.Graphic.CvsGraphic.OnPropertyChanged(string propertyName)

Cognex.InSight.Graphic.CvsGraphicAnnulus.Initialize(int cellRow, int cellCol, System.Single centerRow, System.Single centerCol, System.Single innerRadius, System.Single outerRadius, string label)

Cognex.InSight.Graphic.CvsGraphicArc.Initialize(int cellRow, int cellCol, System.Single centerRow, System.Single centerCol, System.Single startAngle, System.Single endAngle, System.Single radius, string label)

Cognex.InSight.Graphic.CvsGraphicCircle.Initialize(int cellRow, int cellCol, System.Single centerRow, System.Single centerCol, System.Single circleRadius, string label)

Cognex.InSight.Graphic.CvsGraphicPoint.Initialize(int cellRow, int cellCol, System.Single pointRow, System.Single pointCol, string label)

Cognex.InSight.Graphic.CvsGraphicPolyline.Initialize(int cellRow, int cellCol, Cognex.InSight.CvsImageLocation[] points)

Cognex.InSight.Graphic.CvsGraphicText.Initialize(int cellRow, int cellCol, System.Single textRow, System.Single textCol, string label)

Cognex.InSight.NativeMode.CvsNativeModeClient.ConnectAsynchronous(string hostname, string username, string password)

Cognex.InSight.Sensor.CvsSensor.SerialPortSupported(int port)

Removed Property Setters

Cognex.InSight.Graphic.CvsGraphic4Side.Label { set; }

Cognex.InSight.Graphic.CvsGraphicFixture.Label { set; }

Added Property Setters

Cognex.InSight.Graphic.CvsGraphic.Color { set; }

Cognex.InSight.Graphic.CvsGraphic.Label { set; }

Cognex.InSight.Graphic.CvsGraphic4Side.EditBounds { set; }

Cognex.InSight.Graphic.CvsGraphicAnnulus.Center { set; }

Cognex.InSight.Graphic.CvsGraphicAnnulus.EditBounds { set; }

Cognex.InSight.Graphic.CvsGraphicAnnulus.EditFlags { set; }

Cognex.InSight.Graphic.CvsGraphicAnnulus.InnerRadius { set; }

Cognex.InSight.Graphic.CvsGraphicAnnulus.OuterRadius { set; }

Cognex.InSight.Graphic.CvsGraphicArc.Center { set; }

Cognex.InSight.Graphic.CvsGraphicArc.EndAngle { set; }

Cognex.InSight.Graphic.CvsGraphicArc.Radius { set; }

Cognex.InSight.Graphic.CvsGraphicArc.StartAngle { set; }

Cognex.InSight.Graphic.CvsGraphicCircle.Center { set; }

Cognex.InSight.Graphic.CvsGraphicCircle.EditBounds { set; }

Cognex.InSight.Graphic.CvsGraphicCircle.EditFlags { set; }

Cognex.InSight.Graphic.CvsGraphicCircle.Radius { set; }

Cognex.InSight.Graphic.CvsGraphicCross.Angle { set; }

Cognex.InSight.Graphic.CvsGraphicCross.Center { set; }

Cognex.InSight.Graphic.CvsGraphicCross.DrawArrows { set; }

Cognex.InSight.Graphic.CvsGraphicCross.EditBounds { set; }

Cognex.InSight.Graphic.CvsGraphicCross.EditFlags { set; }

Cognex.InSight.Graphic.CvsGraphicCross.Height { set; }

Cognex.InSight.Graphic.CvsGraphicCross.Width { set; }

Cognex.InSight.Graphic.CvsGraphicFixture.EditBounds { set; }

Cognex.InSight.Graphic.CvsGraphicFixture.EditFlags { set; }

Cognex.InSight.Graphic.CvsGraphicLine.EditBounds { set; }

Cognex.InSight.Graphic.CvsGraphicLine.EditFlags { set; }

Cognex.InSight.Graphic.CvsGraphicLine.EndPoint { set; }

Cognex.InSight.Graphic.CvsGraphicLine.StartPoint { set; }

Cognex.InSight.Graphic.CvsGraphicOffset.Angle { set; }

Cognex.InSight.Graphic.CvsGraphicOffset.EditBounds { set; }

Cognex.InSight.Graphic.CvsGraphicOffset.EditFlags { set; }

Cognex.InSight.Graphic.CvsGraphicOffset.Offset { set; }

Cognex.InSight.Graphic.CvsGraphicOffset.Origin { set; }

Cognex.InSight.Graphic.CvsGraphicPoint.EditBounds { set; }

Cognex.InSight.Graphic.CvsGraphicPoint.EditFlags { set; }

Cognex.InSight.Graphic.CvsGraphicPoint.Location { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.Angle { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.Curve { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.DisplayAxisLabels { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.EditBounds { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.EditFlags { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.Height { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.LabelBackColor { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.LabelBackColorAsRgb { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.LabelForeColor { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.LabelForeColorAsRgb { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.Location { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.MaximumSize { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.MinimumSize { set; }

Cognex.InSight.Graphic.CvsGraphicRegion.Width { set; }

Cognex.InSight.Graphic.CvsGraphicText.BackColor { set; }

Cognex.InSight.Graphic.CvsGraphicText.BackColorAsRgb { set; }

Cognex.InSight.Graphic.CvsGraphicText.Location { set; }

Cognex.InSight.Sensor.CvsSettings.RamDiskSize { set; }

Removed Property Getters

Cognex.InSight.Graphic.CvsGraphic4Side.Label { get; }

Cognex.InSight.Graphic.CvsGraphicAnnulus.Label { get; }

Cognex.InSight.Graphic.CvsGraphicArc.Label { get; }

Cognex.InSight.Graphic.CvsGraphicCircle.Label { get; }

Cognex.InSight.Graphic.CvsGraphicCross.Label { get; }

Cognex.InSight.Graphic.CvsGraphicFixture.Label { get; }

Cognex.InSight.Graphic.CvsGraphicHistogram.Label { get; }

Cognex.InSight.Graphic.CvsGraphicLine.Label { get; }

Cognex.InSight.Graphic.CvsGraphicOffset.Label { get; }

Cognex.InSight.Graphic.CvsGraphicPoint.Label { get; }

Cognex.InSight.Graphic.CvsGraphicRegion.Label { get; }

Cognex.InSight.Graphic.CvsGraphicText.ForeColor { get; }

Cognex.InSight.Graphic.CvsGraphicText.Label { get; }

Added Property Getters

Cognex.InSight.Cell.CvsCellColorLabel.BackColorAsRgb { get; }

Cognex.InSight.Cell.CvsCellColorLabel.ForeColorAsRgb { get; }

Cognex.InSight.Cell.CvsCellMultiStatus.Color0AsRgb { get; }

Cognex.InSight.Cell.CvsCellMultiStatus.Color1AsRgb { get; }

Cognex.InSight.Cell.CvsCellStatusLight.ColorAsRgb { get; }

Cognex.InSight.Cell.CvsCellString.AsciiText { get; }

Cognex.InSight.CvsFile.IsDirectory { get; }

Cognex.InSight.CvsFile.Name { get; }

Cognex.InSight.CvsFile.Size { get; }

Cognex.InSight.CvsFileCollection.Count { get; }

Cognex.InSight.CvsFileCollection.Item { get; }

Cognex.InSight.CvsInSight.LocalIPAddress { get; }

Cognex.InSight.Ftp.CvsFtpClient.WelcomeBanner { get; }

Cognex.InSight.Graphic.CvsGraphic.HighlightColorAsRgb { get; }

Cognex.InSight.Graphic.CvsGraphic.IsLocked { get; }

Cognex.InSight.Graphic.CvsGraphic.Label { get; }

Cognex.InSight.Graphic.CvsGraphic4Side.EditBounds { get; }

Cognex.InSight.Graphic.CvsGraphicAnnulus.EditBounds { get; }

Cognex.InSight.Graphic.CvsGraphicAnnulus.EditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicCircle.EditBounds { get; }

Cognex.InSight.Graphic.CvsGraphicCircle.EditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicCross.DrawArrows { get; }

Cognex.InSight.Graphic.CvsGraphicCross.EditBounds { get; }

Cognex.InSight.Graphic.CvsGraphicCross.EditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicFixture.EditBounds { get; }

Cognex.InSight.Graphic.CvsGraphicFixture.EditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicLine.EditBounds { get; }

Cognex.InSight.Graphic.CvsGraphicLine.EditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicOffset.EditBounds { get; }

Cognex.InSight.Graphic.CvsGraphicOffset.EditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicPoint.EditBounds { get; }

Cognex.InSight.Graphic.CvsGraphicPoint.EditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicRegion.DisplayAxisLabels { get; }

Cognex.InSight.Graphic.CvsGraphicRegion.EditBounds { get; }

Cognex.InSight.Graphic.CvsGraphicRegion.EditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicRegion.LabelBackColorAsRgb { get; }

Cognex.InSight.Graphic.CvsGraphicRegion.LabelForeColorAsRgb { get; }

Cognex.InSight.Graphic.CvsGraphicRegion.MaximumSize { get; }

Cognex.InSight.Graphic.CvsGraphicRegion.MinimumSize { get; }

Cognex.InSight.Graphic.CvsGraphicText.BackColorAsRgb { get; }

Cognex.InSight.Graphic.CvsPatternMatchSegment.ColorAsRgb { get; }

Cognex.InSight.Graphic.CvsPatternMatchSegment.HighlightColorAsRgb { get; }

Cognex.InSight.Graphic.ICvsEditableGraphic.EditBounds { get; }

Cognex.InSight.Graphic.ICvsEditableGraphic.EditFlags { get; }

Cognex.InSight.Sensor.CvsSensor.HostName { get; }

Cognex.InSight.Sensor.CvsSensor.ImportExportSupported { get; }

Cognex.InSight.Sensor.CvsSensor.RamDiskSupported { get; }

Cognex.InSight.Sensor.CvsSensor.SntpSupported { get; }

Cognex.InSight.Sensor.CvsSettings.ImportExportSupported { get; }

Cognex.InSight.Sensor.CvsSettings.RamDiskSize { get; }

Cognex.InSight.Sensor.CvsSettings.RamDiskSupported { get; }

Added Classes

Cognex.InSight.CvsFile

Cognex.InSight.CvsFileCollection

Cognex.InSight.CvsNotLicensedException

Added Events

Cognex.InSight.Graphic.CvsGraphic.PropertyChanged

Cognex.InSight.NativeMode.CvsNativeModeClient.ConnectCompleted

Added Interfaces

Cognex.InSight.Graphic.ICvsEditableGraphic

Added Enumerations

Cognex.InSight.CvsImageOrientation

Added Enumeration Values

Cognex.InSight.CvsImageOrientation.Normal

Cognex.InSight.CvsImageOrientation.RotateCounterclockwise90

Cognex.InSight.CvsImageOrientation.Rotate180

Cognex.InSight.CvsImageOrientation.RotateClockwise90

Cognex.InSight.Graphic.CvsEditFlags.Point0

Cognex.InSight.Graphic.CvsEditFlags.Point1

Cognex.InSight.Sensor.CvsSupportedTools.WaferOCR

Cognex.InSight.Sensor.CvsSupportedTools.WaferBarcode

Cognex.InSight.Sensor.CvsSupportedTools.Wafer2D

Changed Field Values

Cognex.InSight.Sensor.CvsFtpSettings.MinFtpIdleTimeoutInSeconds => Value changed from '1' to '0'.

Cognex.InSight.Sensor.CvsFtpSettings.MinFtpReadTimeoutInSeconds => Value changed from '1' to '0'.

Removed Custom Attributes

P:Cognex.InSight.Graphic.CvsGraphicText.ForeColor { get; } - [ComVisible((Boolean)False)]

Added Custom Attributes

M:Cognex.InSight.Cell.CvsCellCollection.GetCells(int row, int column, int rows, int columns) - [ComVisible((Boolean)True)]

M:Cognex.InSight.Cell.CvsCellCollection.GetCells(Cognex.InSight.CvsCellRange range) - [ComVisible((Boolean)False)]

M:Cognex.InSight.Controls.CvsAction.Bind(object obj, string propertyName, string eventName) - [ComVisible((Boolean)False)]

M:Cognex.InSight.Controls.CvsAction.Bind(params object[] objects) - [ComVisible((Boolean)False)]

P:Cognex.InSight.CvsInSight.LocalIPAddress { get; } - [ComVisible((Boolean)False)]

P:Cognex.InSight.Graphic.CvsGraphicRegion.MaximumSize { get; } - [ComVisible((Boolean)False)]

P:Cognex.InSight.Graphic.CvsGraphicRegion.MinimumSize { get; } - [ComVisible((Boolean)False)]

Enum:Cognex.InSight.CvsImageOrientation - [ComVisible((Boolean)True)]

T:Cognex.InSight.CvsFile - [Serializable]

T:Cognex.InSight.CvsFile - [Guid("5AE8947D-1E72-46e0-825B-B455E0B21AEB")]

T:Cognex.InSight.CvsFileCollection - [Serializable]

T:Cognex.InSight.CvsFileCollection - [Guid("64FB3FA4-83BF-4580-95E9-C6CBBB241908")]

T:Cognex.InSight.CvsFileCollection - [DefaultMember("Item")]

T:Cognex.InSight.CvsNotLicensedException - [Serializable]

Copyright (c) 2004-2014 Cognex Corporation.


3.2.0 to 3.3.0

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (3.2.1328.0 to 3.3.1821.0)

Removed Constructors

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults..ctor()

Added Constructors

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions..ctor()

Removed Methods

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.Dispose()

Added Methods

Cognex.InSight.Controls.Display.CvsInSightDisplay.EditGraphics(Cognex.InSight.Graphic.ICvsEditableGraphic[] graphics, System.Drawing.Color selectedColor, System.Drawing.Color unselectedColor)

Cognex.InSight.Controls.Display.IDisplayOptionsView.FireOptionsChanged()

Cognex.InSight.Controls.Display.IDisplayOptionsView.ShowMessageBox(string message, string caption, Cognex.InSight.Controls.Internal.CvsMessageBoxButtons buttons, Cognex.InSight.Controls.Internal.CvsMessageBoxIcons icon)

Removed Property Setters

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordFilenameFormat { set; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordFolder { set; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordMax { set; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordResolution { set; }

Added Property Setters

Cognex.InSight.Controls.Display.CvsInSightDisplay.Cursor { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowImageSaturation { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.SnippetPath { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.AlwaysShowOptions { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.PlaybackContinuous { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.PlaybackDelay { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.PlaybackFolder { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordFilenameFormat { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordFolder { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordMax { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordMode { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordResolution { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordWatchCell { set; }

Cognex.InSight.Controls.Display.IDisplayOptionsView.HighSaturationLevel { set; }

Cognex.InSight.Controls.Display.IDisplayOptionsView.HighSaturationMin { set; }

Cognex.InSight.Controls.Display.IDisplayOptionsView.LowSaturationLevel { set; }

Cognex.InSight.Controls.Display.IDisplayOptionsView.LowSaturationMax { set; }

Removed Property Getters

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ExportCell { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ImportCell { get; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordFilenameFormat { get; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordFolder { get; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordMax { get; }

Cognex.InSight.Controls.Display.DisplayRecorderSystemDefaults.RecordResolution { get; }

Added Property Getters

Cognex.InSight.Controls.Display.CvsInSightDisplay.Cursor { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowImageSaturation { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.SnippetPath { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ExportCells { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ExportSnippet { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ImportCells { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ImportSnippet { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.MaximizeCellRegion { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowGraphics { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowImageSaturation { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.AlwaysShowOptions { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.PlaybackContinuous { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.PlaybackDelay { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.PlaybackFolder { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordFilenameFormat { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordFolder { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordMax { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordMode { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordResolution { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordWatchCell { get; }

Cognex.InSight.Controls.Display.IDisplayOptionsView.HighSaturationLevel { get; }

Cognex.InSight.Controls.Display.IDisplayOptionsView.HighSaturationMin { get; }

Cognex.InSight.Controls.Display.IDisplayOptionsView.LowSaturationLevel { get; }

Cognex.InSight.Controls.Display.IDisplayOptionsView.LowSaturationMax { get; }

Added Classes

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions

Removed Events

Cognex.InSight.Controls.Display.CvsInSightDisplay.PlayActiveChanged

Cognex.InSight.Controls.Display.CvsInSightDisplay.RecordActiveChanged

Added Events

Cognex.InSight.Controls.Display.InSightDevice.FileListChanged

Added Interfaces

Cognex.InSight.Controls.Display.IDisplayOptionsView

Removed Custom Attributes

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ExportCell { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ImportCell { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

Added Custom Attributes

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.ClientToSensorTransform { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.Cursor { get; } - [ComVisible((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.SensorToClientTransform { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowImageSaturation { get; } - [ComponentModel.DefaultValue((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowImageSaturation { get; } - [ComponentModel.Description("Indicates whether saturated areas of the image will be displayed in color.")]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowImageSaturation { get; } - [ComponentModel.Category("Appearance")]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.SnippetPath { get; } - [ComponentModel.DefaultValue("")]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.SnippetPath { get; } - [ComponentModel.Category("Behavior")]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.SnippetPath { get; } - [ComponentModel.Description("Gets and sets the path for snippets. This path will be the initial directory when cells are imported or exported.")]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ClearAll { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)196676)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.MaximizeCellRegion { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)196685)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowGraphics { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)196679)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowGraphics { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowImageSaturation { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)196691)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowImageSaturation { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

API Changes - Cognex.InSight.dll (3.2.1328.0 to 3.3.1821.0)

Added Methods

Cognex.InSight.Controls.CvsAction.Dispose()

Cognex.InSight.CvsReferenceRange.SetAbsolute(System.Boolean absoluteColumn, System.Boolean absoluteRow, System.Boolean absoluteLastColumn, System.Boolean absoluteLastRow)

Added Property Setters

Cognex.InSight.Graphic.CvsGraphic4Side.Style { set; }

Cognex.InSight.Sensor.CvsNetworkSettings.TelnetPort { set; }

Added Property Getters

Cognex.InSight.Cell.CvsCell.ErrorString { get; }

Cognex.InSight.Cell.CvsCellDialog.DialogRange { get; }

Cognex.InSight.Graphic.CvsGraphic.Flags { get; }

Cognex.InSight.Graphic.CvsGraphic4Side.Style { get; }

Cognex.InSight.Graphic.CvsGraphicText.IsPlotString { get; }

Cognex.InSight.NativeMode.CvsNativeModeClient.WelcomeBanner { get; }

Cognex.InSight.Sensor.CvsNetworkSettings.TelnetPort { get; }

Cognex.InSight.Sensor.CvsSettings.EipWatchdogTimeoutActionSupported { get; }

Cognex.InSight.Sensor.CvsSettings.TelnetPortSupported { get; }

Added Events

Cognex.InSight.CvsReferenceRange.AbsoluteChanged

Added Enumerations

Cognex.InSight.Graphic.CvsDisplayable4SideStyle

Added Enumeration Values

Cognex.InSight.Graphic.CvsDisplayable4SideStyle.DataMatrix

Cognex.InSight.Graphic.CvsDisplayable4SideStyle.SolidLines

Cognex.InSight.Sensor.CvsImageResolution.Quarter

Cognex.InSight.Sensor.CvsMode.Kuka

Copyright (c) 2004-2014 Cognex Corporation.


3.3.0 to 3.4.0

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (3.3.1821.0 to 3.4.2240.0)

Added Property Getters

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ResetSensor { get; }

Added Events

Cognex.InSight.Controls.Display.CvsImageEditor.ImageEditInProgressState

Cognex.InSight.Controls.Display.CvsImageEditor.SaveImageEditClick

API Changes - Cognex.InSight.dll (3.3.1821.0 to 3.4.2240.0)

Added Constructors

Cognex.InSight.Sensor.CvsUser..ctor(string name, string password, Cognex.InSight.CvsInSightSecurityAccess access, System.Boolean ftpReadEnabled, System.Boolean ftpWriteEnabled, System.Boolean customViewDefaultEnabled, System.Boolean onlineOfflineEnabled)

Added Methods

Cognex.InSight.CvsImage.Dispose()

Cognex.InSight.CvsResultSet.Dispose()

Cognex.InSight.CvsUtility.IsValidSensorName(string s, System.Boolean allowZeroLength)

Cognex.InSight.CvsUtility.IsValidSensorNameChar(string s)

Cognex.InSight.Graphic.CvsGraphicImage.Dispose()

Cognex.InSight.Sensor.CvsHost.IsValidSensorName(string s, System.Boolean allowZeroLength)

Cognex.InSight.Sensor.CvsHost.IsValidSensorNameChar(System.Char c)

Added Property Setters

Cognex.InSight.Sensor.CvsNetworkSettings.ProtocolService { set; }

Cognex.InSight.Sensor.CvsSettings.DeEnergizeOutputsWhileOffline { set; }

Cognex.InSight.Sensor.CvsSettings.OnlineAcquisitionMaxImageRate { set; }

Cognex.InSight.Sensor.CvsUser.OnlineOfflineEnabled { set; }

Removed Property Getters

Cognex.InSight.Sensor.CvsProcessorConstants.Is1024x768 { get; }

Added Property Getters

Cognex.InSight.Sensor.CvsNetworkSettings.ProtocolService { get; }

Cognex.InSight.Sensor.CvsSettings.DeEnergizeOutputsWhileOffline { get; }

Cognex.InSight.Sensor.CvsSettings.DeEnergizeOutputsWhileOfflineSupported { get; }

Cognex.InSight.Sensor.CvsSettings.OnlineAcquisitionMaxImageRate { get; }

Cognex.InSight.Sensor.CvsSettings.OnlineAcquisitionMaxImageRateSupported { get; }

Cognex.InSight.Sensor.CvsSettings.OnlineImageResolutionSupported { get; }

Cognex.InSight.Sensor.CvsSettings.ProtectedUserOnlineOfflineSupported { get; }

Cognex.InSight.Sensor.CvsSettings.ProtocolServiceSupported { get; }

Cognex.InSight.Sensor.CvsUser.OnlineOfflineEnabled { get; }

Added Events

Cognex.InSight.Net.CvsNetworkMonitor+NamerInterface.OnNamerPacketReceived

Added Enumerations

Cognex.InSight.Sensor.CvsProtocolServices

Added Enumeration Values

Cognex.InSight.Sensor.CvsProtocolServices.None

Cognex.InSight.Sensor.CvsProtocolServices.EipService

Cognex.InSight.Sensor.CvsProtocolServices.ProfiNetService

Cognex.InSight.Sensor.CvsProtocolServices.Modbus

Added Custom Attributes

Enum:Cognex.InSight.Sensor.CvsProtocolServices - [Flags]

Copyright (c) 2004-2014 Cognex Corporation.


3.4.0 to 4.1.0

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (3.4.2240.0 to 4.1.4222.0)

Removed Methods

Cognex.InSight.Controls.Display.CvsInSightDisplay.EditGraphics(Cognex.InSight.Graphic.ICvsEditableGraphic[] graphics)

Cognex.InSight.Controls.Display.CvsInSightDisplay.EditGraphics(Cognex.InSight.Graphic.ICvsEditableGraphic[] graphics, System.Drawing.Color selectedColor, System.Drawing.Color unselectedColor)

Added Methods

Cognex.InSight.Controls.Display.CvsInSightDisplay.DisplayPreApplicationGraphics(Cognex.InSight.Graphic.CvsGraphic[] graphics)

Cognex.InSight.Controls.Display.CvsInSightDisplay.EditGraphics(Cognex.InSight.Graphic.ICvsEditableGraphic graphic)

Cognex.InSight.Controls.Display.CvsInSightDisplay.EditGraphics(List graphics)

Cognex.InSight.Controls.Display.CvsInSightDisplay.EditGraphics(List graphics, System.Drawing.Color selectedColor, System.Drawing.Color unselectedColor)

Cognex.InSight.Controls.Display.CvsInSightDisplay.OpenPropertySheet(Cognex.InSight.CvsCellLocation location, string expression)

Added Property Getters

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ClearEasyTags { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ConvertToEasyTags { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EasyBuilderPlaybackOptions { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EasyBuilderRecordOptions { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.InsertEasyTag { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.OpenOverallPassFailDialog { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.OpenOverallPassFailDialogWithCurrentCell { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackAllowed { get; }

Added Events

Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowGridChanged

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackFolderChanged

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackFolderSizeChanged

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.PlaybackIndexChanged

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordFolderChanged

Removed Custom Attributes

T:Cognex.InSight.Controls.Display.CvsInSightDisplay - [Cognex.InSight.Internal.ComTypeFlags((TYPEFLAGS)528)]

Added Custom Attributes

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ClearEasyTags { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ConvertToEasyTags { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.InsertEasyTag { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

T:Cognex.InSight.Controls.Display.CvsInSightDisplay - [Cognex.InSight.Internal.ComTypeFlags((ComTypes.TYPEFLAGS)528)]

API Changes - Cognex.InSight.dll (3.4.2240.0 to 4.1.4222.0)

Removed Constructors

Cognex.InSight.Net.CvsNetworkMonitor+NamerPacketNotify..ctor(object object, System.IntPtr method)

Added Constructors

Cognex.InSight.Graphic.CvsCompositeSubregion..ctor(Cognex.InSight.Graphic.CvsGraphicRegion region, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsCompositeSubregion..ctor(Cognex.InSight.Graphic.CvsGraphicPolygon polygon, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsCompositeSubregion..ctor(Cognex.InSight.Graphic.CvsGraphicCircle circle, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsCompositeSubregion..ctor(Cognex.InSight.Graphic.CvsGraphicAnnulus annulus, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsCompositeSubregion..ctor(Cognex.InSight.Graphic.CvsCompositeSubregion src)

Cognex.InSight.Graphic.CvsGraphicComposite..ctor(Cognex.InSight.Graphic.CvsCompositeSubregion[] subRegions)

Cognex.InSight.Graphic.CvsGraphicComposite..ctor(Cognex.InSight.Graphic.CvsGraphicComposite graphic)

Cognex.InSight.Graphic.CvsGraphicComposite..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.Graphic.CvsCompositeSubregion[] subRegions, string label)

Cognex.InSight.Graphic.CvsGraphicComposite..ctor()

Cognex.InSight.Graphic.CvsGraphicPolygon..ctor(Cognex.InSight.CvsImageLocation[] points)

Cognex.InSight.Graphic.CvsGraphicPolygon..ctor(Cognex.InSight.Graphic.CvsGraphicPolygon graphic)

Cognex.InSight.Graphic.CvsGraphicPolygon..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation[] points, string label)

Cognex.InSight.Graphic.CvsGraphicPolygon..ctor()

Cognex.InSight.Net.CvsNetworkListener..ctor()

Cognex.InSight.Net.CvsNetworkListener+NamerPacketNotify..ctor(object object, System.IntPtr method)

Cognex.InSight.Net.CvsNetworkMonitorSubnet..ctor(System.Net.IPAddress ip, System.Net.IPAddress mask, string name)

Removed Methods

Cognex.InSight.Net.CvsNetworkMonitor.Dispose()

Cognex.InSight.Net.CvsNetworkMonitor.PingHost(System.Net.IPAddress address, int timeToWait)

Cognex.InSight.Net.CvsNetworkMonitor+NamerPacketNotify.BeginInvoke(int packetType, Cognex.InSight.Net.CvsHostSensor sensor, System.AsyncCallback callback, object object)

Cognex.InSight.Net.CvsNetworkMonitor+NamerPacketNotify.EndInvoke(System.IAsyncResult result)

Cognex.InSight.Net.CvsNetworkMonitor+NamerPacketNotify.Invoke(int packetType, Cognex.InSight.Net.CvsHostSensor sensor)

Cognex.InSight.Sensor.CvsDiscreteOutputLine.IsIOModuleStandbySupported()

Cognex.InSight.Sensor.CvsDiscreteOutputLine.IsLightControlSupported()

Cognex.InSight.Sensor.CvsDiscreteOutputLine.IsOnlineOfflineSupported()

Cognex.InSight.Sensor.CvsDiscreteOutputLine.IsStrobeSupported()

Cognex.InSight.Sensor.CvsHost.IsValidSubnetIPAddress(string address)

Added Methods

Cognex.InSight.Cell.CvsCellEditComposite.ToString()

Cognex.InSight.Cell.CvsCellEditPolygon.ToString()

Cognex.InSight.Controls.CvsAction.Bind(Cognex.InSight.ICvsActionObject obj)

Cognex.InSight.Controls.CvsAction.Unbind(Cognex.InSight.ICvsActionObject obj)

Cognex.InSight.CvsCellLocation.Parse(string location)

Cognex.InSight.CvsCellLocation.TryNormalizeCell(string location)

Cognex.InSight.CvsCellLocation.TryParse(string location)

Cognex.InSight.CvsCellRange.TryParse(string range)

Cognex.InSight.Graphic.CvsGraphicComposite.DeleteSubregion(Cognex.InSight.Graphic.CvsCompositeSubregion subRegion)

Cognex.InSight.Graphic.CvsGraphicComposite.DeleteSubregionByIndex(int index)

Cognex.InSight.Graphic.CvsGraphicComposite.GetSubregionOperation(int index)

Cognex.InSight.Graphic.CvsGraphicComposite.Initialize(int cellRow, int cellCol, Cognex.InSight.Graphic.CvsCompositeSubregion[] subRegions, string Label)

Cognex.InSight.Graphic.CvsGraphicComposite.InsertAnnulus(int index, Cognex.InSight.Graphic.CvsGraphicAnnulus annulus, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicComposite.InsertCircle(int index, Cognex.InSight.Graphic.CvsGraphicCircle circle, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicComposite.InsertPolygon(int index, Cognex.InSight.Graphic.CvsGraphicPolygon polygon, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicComposite.InsertRegion(int index, Cognex.InSight.Graphic.CvsGraphicRegion region, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicComposite.SetSubregionAnnulus(int index, Cognex.InSight.Graphic.CvsGraphicAnnulus annulus)

Cognex.InSight.Graphic.CvsGraphicComposite.SetSubregionCircle(int index, Cognex.InSight.Graphic.CvsGraphicCircle circle)

Cognex.InSight.Graphic.CvsGraphicComposite.SetSubregionOperation(int index, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicComposite.SetSubregionPolygon(int index, Cognex.InSight.Graphic.CvsGraphicPolygon polygon)

Cognex.InSight.Graphic.CvsGraphicComposite.SetSubregionRegion(int index, Cognex.InSight.Graphic.CvsGraphicRegion region)

Cognex.InSight.Graphic.CvsGraphicPolygon.DeletePoint(int index)

Cognex.InSight.Graphic.CvsGraphicPolygon.GetPoint(int index)

Cognex.InSight.Graphic.CvsGraphicPolygon.Initialize(int cellRow, int cellCol, Cognex.InSight.CvsImageLocation[] points, string label)

Cognex.InSight.Graphic.CvsGraphicPolygon.InsertPoint(int index, Cognex.InSight.CvsImageLocation location)

Cognex.InSight.Graphic.CvsGraphicPolygon.SetPoint(int index, Cognex.InSight.CvsImageLocation location)

Cognex.InSight.Net.CvsNetworkListener.Dispose()

Cognex.InSight.Net.CvsNetworkListener.GetDefaultHostName(Cognex.InSight.Net.CvsHostSensor device)

Cognex.InSight.Net.CvsNetworkListener.PingHost(System.Net.IPAddress address, int timeToWait)

Cognex.InSight.Net.CvsNetworkListener.Refresh()

Cognex.InSight.Net.CvsNetworkListener.Resolve(string name)

Cognex.InSight.Net.CvsNetworkListener.Resolve(System.Net.IPAddress ip)

Cognex.InSight.Net.CvsNetworkListener.SendFlash(Cognex.InSight.Net.CvsHostSensor sensor)

Cognex.InSight.Net.CvsNetworkListener.SendSetNetwork(Cognex.InSight.Net.CvsHostSensor sensor, string username, string password, string hostname, System.Boolean useDhcp, System.Net.IPAddress ip, System.Net.IPAddress subnet, System.Net.IPAddress gateway, System.Net.IPAddress dns, string domainName, System.Boolean reset)

Cognex.InSight.Net.CvsNetworkListener.SupportsCommand(Cognex.InSight.Net.CvsHostSensor sensor, Cognex.InSight.Net.CvsNetworkMonitorCommand cmd)

Cognex.InSight.Net.CvsNetworkListener+NamerPacketNotify.BeginInvoke(Cognex.InSight.Net.CvsNetworkMonitorCommand cmd, Cognex.InSight.Net.CvsHostSensor sensor, System.AsyncCallback callback, object object)

Cognex.InSight.Net.CvsNetworkListener+NamerPacketNotify.EndInvoke(System.IAsyncResult result)

Cognex.InSight.Net.CvsNetworkListener+NamerPacketNotify.Invoke(Cognex.InSight.Net.CvsNetworkMonitorCommand cmd, Cognex.InSight.Net.CvsHostSensor sensor)

Cognex.InSight.Sensor.CvsDiscreteIOLines.IsEqual(Cognex.InSight.Sensor.CvsDiscreteIOLines ioLines)

Cognex.InSight.Sensor.CvsHost.IsValidHostIPAddress(System.Net.IPAddress address, System.Net.IPAddress subnetMask, out System.String& error)

Cognex.InSight.Sensor.CvsHost.IsValidSubnetIPAddress(string subnet)

Cognex.InSight.Sensor.CvsHost.IsValidSubnetIPAddress(System.Net.IPAddress subnet, System.Net.IPAddress ip, out System.String& error)

Cognex.InSight.Sensor.CvsSerialSettings.IsEqual(Cognex.InSight.Sensor.CvsSerialSettings serialSettings)

Cognex.InSight.Sensor.CvsSettings.SetSerialPort1Settings(Cognex.InSight.Sensor.CvsSerialSettings serialPort1Settings)

Cognex.InSight.Sensor.CvsUniversalIOSettings.Clone()

Removed Property Setters

Cognex.InSight.Sensor.CvsExpansionIOSettings.ExpansionAttached { set; }

Added Property Setters

Cognex.InSight.Graphic.CvsCompositeSubregion.Operation { set; }

Cognex.InSight.Graphic.CvsGraphicComposite.EditFlags { set; }

Cognex.InSight.Graphic.CvsGraphicComposite.Subregions { set; }

Cognex.InSight.Graphic.CvsGraphicPolygon.EditBounds { set; }

Cognex.InSight.Graphic.CvsGraphicPolygon.EditFlags { set; }

Cognex.InSight.Graphic.CvsGraphicPolygon.Points { set; }

Cognex.InSight.ICvsActionObject.CheckedStatus { set; }

Cognex.InSight.ICvsActionObject.ContextMenuText { set; }

Cognex.InSight.ICvsActionObject.Enabled { set; }

Cognex.InSight.ICvsActionObject.Image { set; }

Cognex.InSight.ICvsActionObject.ImageIndex { set; }

Cognex.InSight.ICvsActionObject.MenuText { set; }

Cognex.InSight.ICvsActionObject.Tag { set; }

Cognex.InSight.ICvsActionObject.ToolTipText { set; }

Cognex.InSight.ICvsActionObject.Visible { set; }

Cognex.InSight.Net.CvsNetworkListener.Scope { set; }

Cognex.InSight.Sensor.CvsSettings.ActiveIOModule { set; }

Cognex.InSight.Sensor.CvsSettings.EthernetIOAddress { set; }

Cognex.InSight.Sensor.CvsSettings.EthernetIOInactivePollRate { set; }

Cognex.InSight.Sensor.CvsSettings.EthernetIOPollRate { set; }

Removed Property Getters

Cognex.InSight.Net.CvsHostSensor.SensorInformation { get; }

Cognex.InSight.Net.CvsHostSensorInfo.DefaultGateway { get; }

Cognex.InSight.Net.CvsHostSensorInfo.DhcpIP { get; }

Cognex.InSight.Net.CvsHostSensorInfo.DNSServer { get; }

Cognex.InSight.Net.CvsHostSensorInfo.DomainName { get; }

Cognex.InSight.Net.CvsHostSensorInfo.IOModuleSerialNumber { get; }

Cognex.InSight.Net.CvsHostSensorInfo.IOModuleVersion { get; }

Cognex.InSight.Net.CvsHostSensorInfo.JobVersion { get; }

Cognex.InSight.Net.CvsHostSensorInfo.MonitorVersion { get; }

Cognex.InSight.Net.CvsHostSensorInfo.SerialNumber { get; }

Cognex.InSight.Net.CvsHostSensorInfo.SettingsVersion { get; }

Cognex.InSight.Net.CvsHostSensorInfo.SubnetMask { get; }

Cognex.InSight.Net.CvsNetworkMonitor.Hosts { get; }

Cognex.InSight.Sensor.CvsExpansionIOSettings.ExpansionAttached { get; }

Cognex.InSight.Sensor.CvsSensor.MonitorVersion { get; }

Added Property Getters

Cognex.InSight.Cell.CvsCellEditComposite.Subregions { get; }

Cognex.InSight.Cell.CvsCellEditComposite.Text { get; }

Cognex.InSight.Cell.CvsCellEditPolygon.Points { get; }

Cognex.InSight.Cell.CvsCellEditPolygon.Text { get; }

Cognex.InSight.CvsResultSet.StatusLevel { get; }

Cognex.InSight.Graphic.CvsCompositeSubregion.EditableGraphic { get; }

Cognex.InSight.Graphic.CvsCompositeSubregion.InSightGraphic { get; }

Cognex.InSight.Graphic.CvsCompositeSubregion.Operation { get; }

Cognex.InSight.Graphic.CvsCompositeSubregion.ShapeType { get; }

Cognex.InSight.Graphic.CvsGraphicComposite.EditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicComposite.Subregions { get; }

Cognex.InSight.Graphic.CvsGraphicPolygon.Area { get; }

Cognex.InSight.Graphic.CvsGraphicPolygon.BoundingBox { get; }

Cognex.InSight.Graphic.CvsGraphicPolygon.Center { get; }

Cognex.InSight.Graphic.CvsGraphicPolygon.EditBounds { get; }

Cognex.InSight.Graphic.CvsGraphicPolygon.EditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicPolygon.PointCount { get; }

Cognex.InSight.Graphic.CvsGraphicPolygon.Points { get; }

Cognex.InSight.ICvsActionObject.BindToEnabled { get; }

Cognex.InSight.ICvsActionObject.BindToEvent { get; }

Cognex.InSight.ICvsActionObject.CheckedStatus { get; }

Cognex.InSight.ICvsActionObject.ContextMenuText { get; }

Cognex.InSight.ICvsActionObject.Enabled { get; }

Cognex.InSight.ICvsActionObject.IconSize { get; }

Cognex.InSight.ICvsActionObject.Image { get; }

Cognex.InSight.ICvsActionObject.ImageIndex { get; }

Cognex.InSight.ICvsActionObject.MenuText { get; }

Cognex.InSight.ICvsActionObject.NewCheckedStatus { get; }

Cognex.InSight.ICvsActionObject.Tag { get; }

Cognex.InSight.ICvsActionObject.ToolTipText { get; }

Cognex.InSight.ICvsActionObject.Visible { get; }

Cognex.InSight.Net.CvsHostSensor.DefaultGateway { get; }

Cognex.InSight.Net.CvsHostSensor.DnsServer { get; }

Cognex.InSight.Net.CvsHostSensor.DomainName { get; }

Cognex.InSight.Net.CvsHostSensor.IsDhcpEnabled { get; }

Cognex.InSight.Net.CvsHostSensor.Scope { get; }

Cognex.InSight.Net.CvsHostSensor.SerialNumber { get; }

Cognex.InSight.Net.CvsHostSensor.SubnetMask { get; }

Cognex.InSight.Net.CvsHostSensor.VersionString { get; }

Cognex.InSight.Net.CvsNetworkListener.Hosts { get; }

Cognex.InSight.Net.CvsNetworkListener.Scope { get; }

Cognex.InSight.Net.CvsNetworkMonitorSubnet.BroadcastAddress { get; }

Cognex.InSight.Net.CvsNetworkMonitorSubnet.IPAddress { get; }

Cognex.InSight.Net.CvsNetworkMonitorSubnet.Name { get; }

Cognex.InSight.Net.CvsNetworkMonitorSubnet.SubnetMask { get; }

Cognex.InSight.Sensor.CvsHost.Subtype { get; }

Cognex.InSight.Sensor.CvsProcessorConstants.MaxSpreadsheetCells { get; }

Cognex.InSight.Sensor.CvsSensor.DiscreteIOSupported { get; }

Cognex.InSight.Sensor.CvsSensor.SpreadsheetSupported { get; }

Cognex.InSight.Sensor.CvsSensor.SystemSubtype { get; }

Cognex.InSight.Sensor.CvsSettings.ActiveIOModule { get; }

Cognex.InSight.Sensor.CvsSettings.ConnectedIOModule { get; }

Cognex.InSight.Sensor.CvsSettings.DiscreteIOSupported { get; }

Cognex.InSight.Sensor.CvsSettings.EthernetIOAddress { get; }

Cognex.InSight.Sensor.CvsSettings.EthernetIOInactivePollRate { get; }

Cognex.InSight.Sensor.CvsSettings.EthernetIOPollRate { get; }

Cognex.InSight.Sensor.CvsSettings.EthernetIOSettings { get; }

Cognex.InSight.Sensor.CvsSettings.EthernetIOSupported { get; }

Cognex.InSight.Sensor.CvsSettings.ExpansionIOMessagingSupported { get; }

Cognex.InSight.Sensor.CvsSettings.UniversalIOSettings { get; }

Cognex.InSight.Sensor.CvsSettings.UniversalIOSupported { get; }

Removed Classes

Cognex.InSight.Net.CvsHostSensorInfo

Added Classes

Cognex.InSight.Cell.CvsCellEditComposite

Cognex.InSight.Cell.CvsCellEditPolygon

Cognex.InSight.Graphic.CvsCompositeSubregion

Cognex.InSight.Graphic.CvsGraphicComposite

Cognex.InSight.Graphic.CvsGraphicPolygon

Cognex.InSight.Net.CvsNetworkListener

Cognex.InSight.Net.CvsNetworkMonitorSubnet

Cognex.InSight.Sensor.CvsUniversalIOSettings

Removed Events

Cognex.InSight.Net.CvsNetworkMonitor+NamerInterface.OnNamerPacketReceived

Added Events

Cognex.InSight.ICvsActionObject.Activate

Added Interfaces

Cognex.InSight.Graphic.CvsCompositeSubregion+ISubregionShape

Cognex.InSight.ICvsActionObject

Cognex.InSight.Net.Attributes.INetworkDeviceAttributeProvider

Added Namespaces

Cognex.InSight.Net.Attributes

Added Enumerations

Cognex.InSight.CvsStatusLevel

Cognex.InSight.Graphic.CvsCompositeOperation

Cognex.InSight.Graphic.CvsCompositeShapeType

Cognex.InSight.Net.CvsNetworkMonitorCommand

Cognex.InSight.Net.CvsNetworkMonitorScope

Cognex.InSight.Sensor.CvsHostSubtype

Cognex.InSight.Sensor.CvsIOModule

Added Enumeration Values

Cognex.InSight.CvsStatusLevel.None

Cognex.InSight.CvsStatusLevel.Pass

Cognex.InSight.CvsStatusLevel.Fail

Cognex.InSight.CvsStatusLevel.Warn

Cognex.InSight.Graphic.CvsCompositeOperation.Invalid

Cognex.InSight.Graphic.CvsCompositeOperation.Subtract

Cognex.InSight.Graphic.CvsCompositeOperation.Add

Cognex.InSight.Graphic.CvsCompositeShapeType.None

Cognex.InSight.Graphic.CvsCompositeShapeType.RegionType

Cognex.InSight.Graphic.CvsCompositeShapeType.PolygonType

Cognex.InSight.Graphic.CvsCompositeShapeType.CircleType

Cognex.InSight.Graphic.CvsCompositeShapeType.AnnulusType

Cognex.InSight.Graphic.CvsEditFlags.AddItem

Cognex.InSight.Graphic.CvsEditFlags.DeleteItem

Cognex.InSight.Graphic.CvsEditFlags.EditItem

Cognex.InSight.Net.CvsNetworkMonitorCommand.IPRequest

Cognex.InSight.Net.CvsNetworkMonitorCommand.SetNetwork

Cognex.InSight.Net.CvsNetworkMonitorCommand.FactoryReset

Cognex.InSight.Net.CvsNetworkMonitorCommand.Flash

Cognex.InSight.Net.CvsNetworkMonitorCommand.Hello

Cognex.InSight.Net.CvsNetworkMonitorScope.None

Cognex.InSight.Net.CvsNetworkMonitorScope.Version3

Cognex.InSight.Net.CvsNetworkMonitorScope.Version4

Cognex.InSight.Net.CvsNetworkMonitorScope.VersionMask

Cognex.InSight.Net.CvsNetworkMonitorScope.InSubnet

Cognex.InSight.Net.CvsNetworkMonitorScope.OutOfSubnet

Cognex.InSight.Net.CvsNetworkMonitorScope.LocationMask

Cognex.InSight.Net.CvsNetworkMonitorScope.UnsupportedDevices

Cognex.InSight.Net.CvsSupportedFeatures.None

Cognex.InSight.Sensor.CvsHostSubtype.Unknown

Cognex.InSight.Sensor.CvsHostSubtype.InSightGeneric

Cognex.InSight.Sensor.CvsHostSubtype.InSight5000Series

Cognex.InSight.Sensor.CvsHostSubtype.InSight3400

Cognex.InSight.Sensor.CvsHostSubtype.InSight1700SeriesWaferReader

Cognex.InSight.Sensor.CvsHostSubtype.InSightMicroSeries

Cognex.InSight.Sensor.CvsHostSubtype.InSightEmulatorGeneric

Cognex.InSight.Sensor.CvsHostSubtype.InSightEmulatorPcHost

Cognex.InSight.Sensor.CvsHostSubtype.VisionViewGeneric

Cognex.InSight.Sensor.CvsHostSubtype.VisionView700

Cognex.InSight.Sensor.CvsHostType.InSightEmulator

Cognex.InSight.Sensor.CvsHostType.VisionView

Cognex.InSight.Sensor.CvsIOModule.CIO_Expansion

Cognex.InSight.Sensor.CvsIOModule.CIO_None

Cognex.InSight.Sensor.CvsIOModule.CIO_Standard

Cognex.InSight.Sensor.CvsIOModule.CIO_1450

Cognex.InSight.Sensor.CvsIOModule.CIO_1460

Cognex.InSight.Sensor.CvsIOModule.CIO_1400

Cognex.InSight.Sensor.CvsIOModule.WAGO_750_341

Cognex.InSight.Sensor.CvsOutputListType.GroupA

Cognex.InSight.Sensor.CvsOutputListType.GroupBIncludingLightControl

Cognex.InSight.Sensor.CvsOutputListType.GroupC

Cognex.InSight.Sensor.CvsOutputListType.GroupBExceptStrobe

Cognex.InSight.Sensor.CvsOutputListType.GroupB

Cognex.InSight.Sensor.CvsSupportedTools.DefectInspect

Cognex.InSight.Sensor.CvsSupportedTools.Caliper

Cognex.InSight.Sensor.CvsSupportedTools.CalibrateGrid

Cognex.InSight.Sensor.CvsSupportedTools.NotchMax

Cognex.InSight.Sensor.CvsSupportedTools.EasyBuilderOnly

Removed Custom Attributes

T:Cognex.InSight.Net.CvsHostSensor - [Guid("4C9CFC00-F8A3-4597-A44E-B5134633E00C")]

T:Cognex.InSight.Net.CvsHostSensorInfo - [Serializable]

Added Custom Attributes

M:Cognex.InSight.Controls.CvsAction.Bind(Cognex.InSight.ICvsActionObject obj) - [ComVisible((Boolean)False)]

M:Cognex.InSight.CvsCellLocation.Parse(string location) - [ComVisible((Boolean)False)]

M:Cognex.InSight.CvsCellLocation.TryParse(string location) - [ComVisible((Boolean)False)]

Enum:Cognex.InSight.CvsStatusLevel - [Serializable]

Enum:Cognex.InSight.Graphic.CvsCompositeOperation - [ComponentModel.TypeConverter(typeof(Cognex.InSight.Graphic.CvsCompositeOperationConverter))]

Enum:Cognex.InSight.Graphic.CvsCompositeOperation - [Guid("22076CFA-C974-4179-B4A7-B1A700EADEEB")]

Enum:Cognex.InSight.Graphic.CvsCompositeShapeType - [Guid("DC24FF26-B274-4560-912D-9D668311F8C8")]

Enum:Cognex.InSight.Graphic.CvsCompositeShapeType - [ComponentModel.TypeConverter(typeof(Cognex.InSight.Graphic.CvsCompositeShapeTypeConverter))]

Enum:Cognex.InSight.Net.CvsNetworkMonitorScope - [Flags]

Enum:Cognex.InSight.Net.CvsSupportedFeatures - [Flags]

Enum:Cognex.InSight.Sensor.CvsHostSubtype - [Flags]

Enum:Cognex.InSight.Sensor.CvsIOModule - [Serializable]

T:Cognex.InSight.Cell.CvsCellEditComposite - [Serializable]

T:Cognex.InSight.Cell.CvsCellEditComposite - [Guid("97D1DA04-FE50-471f-8EE8-5A91AB62A448")]

T:Cognex.InSight.Cell.CvsCellEditPolygon - [Serializable]

T:Cognex.InSight.Cell.CvsCellEditPolygon - [Guid("54C9D42F-711C-484f-B1F0-CDEF9791D9EE")]

T:Cognex.InSight.Graphic.CvsCompositeSubregion - [Guid("778A5433-3FC4-47a6-B4C6-45F29BB0FCE1")]

T:Cognex.InSight.Graphic.CvsGraphicComposite - [Serializable]

T:Cognex.InSight.Graphic.CvsGraphicComposite - [Guid("BE38FF12-D7D6-494b-8E14-26236219F195")]

T:Cognex.InSight.Graphic.CvsGraphicPolygon - [Serializable]

T:Cognex.InSight.Graphic.CvsGraphicPolygon - [Guid("3FAA0BB3-EECE-4793-839F-FF5CA390D260")]

T:Cognex.InSight.Net.CvsHostSensor - [Guid("81D9712B-4247-4998-81AF-70EB4A05A07B")]

T:Cognex.InSight.Net.CvsNetworkListener - [Guid("6A177146-8B82-4369-B469-D6F028FC5439")]

T:Cognex.InSight.Sensor.CvsUniversalIOSettings - [Serializable]

T:Cognex.InSight.Sensor.CvsUniversalIOSettings - [Guid("24443BD7-74EB-4478-98C8-6271A92776B9")]

Copyright (c) 2004-2014 Cognex Corporation.


4.1.0 to 4.2.0

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (4.1.4222.0 to 4.2.5324.0)

Added Constructors

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl..ctor()

Added Methods

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Dispose(System.Boolean disposing)

Added Property Setters

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Address { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AddressVisible { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModule { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModuleVisible { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.DisplayedText { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.InSight { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Settings { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRate { set; }

Added Property Getters

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditActiveCellsLimit { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditEasyViewSettings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditLicensing { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Address { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AddressVisible { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModule { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModuleVisible { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.InSight { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Settings { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRate { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRateVisible { get; }

Added Classes

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl

Added Events

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.ConfigureModuleClicked

Added Interfaces

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView

Added Custom Attributes

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditActiveCellsLimit { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditEasyViewSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditLicensing { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Address { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Address { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AddressVisible { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AddressVisible { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModule { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModule { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModuleVisible { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModuleVisible { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.InSight { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.InSight { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Settings { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Settings { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRate { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRate { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRateVisible { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRateVisible { get; } - [ComponentModel.Browsable((Boolean)False)]

API Changes - Cognex.InSight.dll (4.1.4222.0 to 4.2.5324.0)

Removed Methods

Cognex.InSight.Sensor.CvsDiscreteOutputLine.IsLifelineSupported()

Added Methods

Cognex.InSight.Cell.CvsCell.GetDataTypeString(Cognex.InSight.Cell.CvsCellDataType dataType)

Cognex.InSight.Cell.CvsCell.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellButton.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellChart.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellCheckBox.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellColorLabel.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellDialog.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditAnnulus.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditCircle.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditComposite.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditFloat.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditGraphic.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditInt.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditLine.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditPoint.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditPolygon.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditRegion.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditString.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEmpty.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellFloat.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellInt.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellLink.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellListBox.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellMultiStatus.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellSelect.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellStatus.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellStatusLight.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellString.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellWizard.Read(Cognex.InSight.Internal.IspReader br)

Added Property Getters

Cognex.InSight.Cell.CvsCell.DataType { get; }

Cognex.InSight.Cell.CvsCell.DataTypeString { get; }

Cognex.InSight.Cell.CvsCell.Hidden { get; }

Cognex.InSight.Cell.CvsCell.IsEditCell { get; }

Cognex.InSight.Cell.CvsCell.ProtectionState { get; }

Cognex.InSight.Cell.CvsCell.SymbolicTag { get; }

Cognex.InSight.Cell.CvsCellButton.DataType { get; }

Cognex.InSight.Cell.CvsCellButton.IsEditCell { get; }

Cognex.InSight.Cell.CvsCellChart.DataType { get; }

Cognex.InSight.Cell.CvsCellCheckBox.DataType { get; }

Cognex.InSight.Cell.CvsCellCheckBox.IsEditCell { get; }

Cognex.InSight.Cell.CvsCellColorLabel.DataType { get; }

Cognex.InSight.Cell.CvsCellDialog.DataType { get; }

Cognex.InSight.Cell.CvsCellDialog.IsEditCell { get; }

Cognex.InSight.Cell.CvsCellEditFloat.DataType { get; }

Cognex.InSight.Cell.CvsCellEditFloat.IsEditCell { get; }

Cognex.InSight.Cell.CvsCellEditGraphic.DataType { get; }

Cognex.InSight.Cell.CvsCellEditGraphic.IsEditCell { get; }

Cognex.InSight.Cell.CvsCellEditInt.DataType { get; }

Cognex.InSight.Cell.CvsCellEditInt.IsEditCell { get; }

Cognex.InSight.Cell.CvsCellEditString.DataType { get; }

Cognex.InSight.Cell.CvsCellEditString.IsEditCell { get; }

Cognex.InSight.Cell.CvsCellFloat.DataType { get; }

Cognex.InSight.Cell.CvsCellInt.DataType { get; }

Cognex.InSight.Cell.CvsCellLink.DataType { get; }

Cognex.InSight.Cell.CvsCellLink.IsEditCell { get; }

Cognex.InSight.Cell.CvsCellListBox.DataType { get; }

Cognex.InSight.Cell.CvsCellListBox.IsEditCell { get; }

Cognex.InSight.Cell.CvsCellMultiStatus.DataType { get; }

Cognex.InSight.Cell.CvsCellSelect.DataType { get; }

Cognex.InSight.Cell.CvsCellSelect.IsEditCell { get; }

Cognex.InSight.Cell.CvsCellStatus.DataType { get; }

Cognex.InSight.Cell.CvsCellStatusLight.DataType { get; }

Cognex.InSight.Cell.CvsCellString.DataType { get; }

Cognex.InSight.Cell.CvsCellWizard.DataType { get; }

Cognex.InSight.Cell.CvsCellWizard.IsEditCell { get; }

Cognex.InSight.CvsCellProtectionException.CellLocation { get; }

Cognex.InSight.Sensor.CvsSensor.LicensingSupported { get; }

Cognex.InSight.Sensor.CvsSettings.EthernetIOAddressSupported { get; }

Cognex.InSight.Sensor.CvsSettings.LicensingSupported { get; }

Added Classes

Cognex.InSight.CvsCellProtectionException

Added Enumerations

Cognex.InSight.Cell.CvsCellDataType

Cognex.InSight.Cell.CvsCellIPProtection

Removed Enumeration Values

Cognex.InSight.Sensor.CvsHostType.VisionView

Cognex.InSight.Sensor.CvsOutputListType.GroupC

Cognex.InSight.Sensor.CvsOutputListType.List2

Cognex.InSight.Sensor.CvsOutputType.Other

Added Enumeration Values

Cognex.InSight.Cell.CvsCellDataType.Integer

Cognex.InSight.Cell.CvsCellDataType.FloatingPoint

Cognex.InSight.Cell.CvsCellDataType.String

Cognex.InSight.Cell.CvsCellDataType.Action

Cognex.InSight.Cell.CvsCellIPProtection.None

Cognex.InSight.Cell.CvsCellIPProtection.Licensed

Cognex.InSight.Cell.CvsCellIPProtection.TemporaryEdit

Cognex.InSight.Cell.CvsCellIPProtection.Unlicensed

Cognex.InSight.CvsInSightError.CellProtectionException

Cognex.InSight.Sensor.CvsHostType.Browser

Cognex.InSight.Sensor.CvsIOModule.CIO_Micro

Cognex.InSight.Sensor.CvsOutputListType.GroupBIncludingLifeline

Cognex.InSight.Sensor.CvsOutputType.Pass

Cognex.InSight.Sensor.CvsOutputType.Fail

Added Custom Attributes

Enum:Cognex.InSight.Cell.CvsCellDataType - [Serializable]

Enum:Cognex.InSight.Cell.CvsCellIPProtection - [Serializable]

T:Cognex.InSight.CvsCellProtectionException - [Serializable]

Copyright (c) 2004-2014 Cognex Corporation.


4.2.0 to 4.3.0

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (4.2.5324.0 to 4.3.6294.0)

Added Property Getters

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditCcLinkSettings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditLineScanSettings { get; }

Added Custom Attributes

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditCcLinkSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditLineScanSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

API Changes - Cognex.InSight.dll (4.2.5324.0 to 4.3.6294.0)

Added Constructors

Cognex.InSight.Graphic.CvsGraphicLine..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation startPoint, Cognex.InSight.CvsImageLocation endPoint, string label, Cognex.InSight.Graphic.CvsGraphicLineAdornment startPointAdornment, Cognex.InSight.Graphic.CvsGraphicLineAdornment endPointAdornment)

Added Methods

Cognex.InSight.CvsCellRange.GetEnumerator()

Cognex.InSight.CvsInSight.ManualAcquire(System.Boolean wait)

Cognex.InSight.CvsInSightSoftwareDevelopmentKit.Initialize()

Cognex.InSight.CvsUtility.CvsInSightSoftwareDevelopmentKitInitialize()

Cognex.InSight.Graphic.CvsGraphicLine.Initialize(int cellRow, int cellCol, System.Single startRow, System.Single startCol, System.Single endRow, System.Single endCol, string label, Cognex.InSight.Graphic.CvsGraphicLineAdornment startPointAdornment, Cognex.InSight.Graphic.CvsGraphicLineAdornment endPointAdornment)

Cognex.InSight.Sensor.CvsSettings.GetSupportedIOModules()

Added Property Getters

Cognex.InSight.CvsCellRange.IsValid { get; }

Cognex.InSight.Graphic.CvsGraphicLine.EndPointAdornment { get; }

Cognex.InSight.Graphic.CvsGraphicLine.StartPointAdornment { get; }

Cognex.InSight.Sensor.CvsProcessorConstants.IsLineScan { get; }

Added Classes

Cognex.InSight.CvsInSightSoftwareDevelopmentKit

Added Enumerations

Cognex.InSight.Graphic.CvsGraphicLineAdornment

Added Enumeration Values

Cognex.InSight.Graphic.CvsGraphicLineAdornment.None

Cognex.InSight.Graphic.CvsGraphicLineAdornment.Arrowhead

Cognex.InSight.Sensor.CvsHostSubtype.InSightEZSeries

Cognex.InSight.Sensor.CvsIOModule.CIO_Micro_CC

Added Custom Attributes

T:Cognex.InSight.CvsInSightSoftwareDevelopmentKit - [ComVisible((Boolean)False)]

Copyright (c) 2004-2014 Cognex Corporation.


4.3.0 to 4.4.0

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (4.3.6294.0 to 4.4.7268.0)

Removed Constructors

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl..ctor()

Added Constructors

Cognex.InSight.Controls.Display.CvsInSightDisplay+TextScaleModeChanged..ctor(object object, System.IntPtr method)

Cognex.InSight.Controls.Display.OmniFontTrainConfusionMatrixData..ctor()

Removed Methods

Cognex.InSight.Controls.Display.CvsInSightDisplay.EditGraphics(List graphics)

Cognex.InSight.Controls.Display.CvsInSightDisplay.EditGraphics(List graphics, System.Drawing.Color selectedColor, System.Drawing.Color unselectedColor)

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Dispose(System.Boolean disposing)

Added Methods

Cognex.InSight.Controls.Display.CvsInSightDisplay.EditGraphics(Cognex.InSight.Graphic.ICvsEditableGraphic[] graphics)

Cognex.InSight.Controls.Display.CvsInSightDisplay.EditGraphics(Cognex.InSight.Graphic.ICvsEditableGraphic[] graphics, System.Drawing.Color selectedColor, System.Drawing.Color unselectedColor)

Cognex.InSight.Controls.Display.CvsInSightDisplay+TextScaleModeChanged.BeginInvoke(int index, System.AsyncCallback callback, object object)

Cognex.InSight.Controls.Display.CvsInSightDisplay+TextScaleModeChanged.EndInvoke(System.IAsyncResult result)

Cognex.InSight.Controls.Display.CvsInSightDisplay+TextScaleModeChanged.Invoke(int index)

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.MnuSensor_BeforePopup()

Removed Property Setters

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Address { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AddressVisible { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModule { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModuleVisible { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.DisplayedText { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.InSight { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Settings { set; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRate { set; }

Added Property Setters

Cognex.InSight.Controls.Display.CvsInSightDisplay.DefaultTextScaleMode { set; }

Cognex.InSight.Controls.Display.CvsKeyboardState.Alt { set; }

Cognex.InSight.Controls.Display.CvsKeyboardState.Control { set; }

Cognex.InSight.Controls.Display.CvsKeyboardState.Shift { set; }

Cognex.InSight.Controls.Display.OmniFontTrainConfusionMatrixData.Highlighted { set; }

Cognex.InSight.Controls.Display.OmniFontTrainConfusionMatrixData.Score { set; }

Removed Property Getters

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Address { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AddressVisible { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModule { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModuleVisible { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.InSight { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Settings { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRate { get; }

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRateVisible { get; }

Added Property Getters

Cognex.InSight.Controls.Display.CvsInSightDisplay.DefaultTextScaleMode { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.DialogUndoOnCancel { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditAuditMessageSettings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.SetTextScaleMode { get; }

Cognex.InSight.Controls.Display.CvsKeyboardState.Alt { get; }

Cognex.InSight.Controls.Display.CvsKeyboardState.Control { get; }

Cognex.InSight.Controls.Display.CvsKeyboardState.Shift { get; }

Cognex.InSight.Controls.Display.OmniFontTrainConfusionMatrixData.Highlighted { get; }

Cognex.InSight.Controls.Display.OmniFontTrainConfusionMatrixData.Score { get; }

Removed Classes

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl

Added Classes

Cognex.InSight.Controls.Display.CvsKeyboardState

Cognex.InSight.Controls.Display.OmniFontTrainConfusionMatrixData

Removed Events

Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.ConfigureModuleClicked

Added Events

Cognex.InSight.Controls.Display.CvsInSightDisplay.OnTextScaleModeChanged

Cognex.InSight.Controls.Display.IoModuleConfigureControl.ConfigValidChanged

Added Enumerations

Cognex.InSight.Controls.Display.CvsInSightDisplay+TextScaleModeType

Added Enumeration Values

Cognex.InSight.Controls.Display.CvsInSightDisplay+TextScaleModeType.Proportional

Cognex.InSight.Controls.Display.CvsInSightDisplay+TextScaleModeType.ShrinkOnly

Cognex.InSight.Controls.Display.CvsInSightDisplay+TextScaleModeType.Fixed

Removed Custom Attributes

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Address { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Address { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AddressVisible { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AddressVisible { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModule { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModule { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModuleVisible { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.AttachedModuleVisible { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.InSight { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.InSight { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Settings { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.Settings { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRate { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRate { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRateVisible { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsIoModuleDisplayControl.UpdateRateVisible { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

Added Custom Attributes

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.DialogUndoOnCancel { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditAuditMessageSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

API Changes - Cognex.InSight.dll (4.3.6294.0 to 4.4.7268.0)

Removed Constructors

Cognex.InSight.Graphic.CvsGraphicComposite..ctor(Cognex.InSight.Graphic.CvsGraphicComposite graphic)

Cognex.InSight.Net.CvsNetworkMonitorSubnet..ctor(System.Net.IPAddress ip, System.Net.IPAddress mask, string name)

Added Constructors

Cognex.InSight.Graphic.CvsGraphicArrows..ctor(Cognex.InSight.Graphic.CvsGraphicArrows graphic)

Cognex.InSight.Graphic.CvsGraphicArrows..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation start, System.Single angle)

Cognex.InSight.Graphic.CvsGraphicArrows..ctor()

Cognex.InSight.Graphic.CvsGraphicComposite..ctor(Cognex.InSight.Graphic.CvsGraphicCompositeBase graphic)

Cognex.InSight.Graphic.CvsGraphicCompositeBase..ctor(Cognex.InSight.Graphic.CvsCompositeSubregion[] subRegions)

Cognex.InSight.Graphic.CvsGraphicCompositeBase..ctor(Cognex.InSight.Graphic.CvsGraphicCompositeBase graphic)

Cognex.InSight.Graphic.CvsGraphicCompositeBase..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.Graphic.CvsCompositeSubregion[] subRegions, string label)

Cognex.InSight.Graphic.CvsGraphicCompositeBase..ctor()

Cognex.InSight.Graphic.CvsGraphicDefectPoints..ctor(Cognex.InSight.Graphic.CvsGraphicDefectPoints graphic)

Cognex.InSight.Graphic.CvsGraphicDefectPoints..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation[] points)

Cognex.InSight.Graphic.CvsGraphicDefectPoints..ctor()

Cognex.InSight.Graphic.CvsGraphicEdgePoints..ctor(Cognex.InSight.Graphic.CvsGraphicEdgePoints graphic)

Cognex.InSight.Graphic.CvsGraphicEdgePoints..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation[] points)

Cognex.InSight.Graphic.CvsGraphicEdgePoints..ctor()

Cognex.InSight.Graphic.CvsGraphicExtremePoints..ctor(Cognex.InSight.Graphic.CvsGraphicExtremePoints graphic)

Cognex.InSight.Graphic.CvsGraphicExtremePoints..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation[] points)

Cognex.InSight.Graphic.CvsGraphicExtremePoints..ctor()

Cognex.InSight.Graphic.CvsGraphicMaskedRegion..ctor(Cognex.InSight.Graphic.CvsCompositeSubregion[] subRegions)

Cognex.InSight.Graphic.CvsGraphicMaskedRegion..ctor(Cognex.InSight.Graphic.CvsGraphicMaskedRegion graphic)

Cognex.InSight.Graphic.CvsGraphicMaskedRegion..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.Graphic.CvsCompositeSubregion[] subRegions, string label)

Cognex.InSight.Graphic.CvsGraphicMaskedRegion..ctor()

Cognex.InSight.Graphic.CvsGraphicPolylinePath..ctor(Cognex.InSight.Graphic.CvsCompositeSubregion[] subRegions)

Cognex.InSight.Graphic.CvsGraphicPolylinePath..ctor(Cognex.InSight.Graphic.CvsGraphicPolylinePath graphic)

Cognex.InSight.Graphic.CvsGraphicPolylinePath..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.Graphic.CvsCompositeSubregion[] subRegions, string label)

Cognex.InSight.Graphic.CvsGraphicPolylinePath..ctor()

Removed Methods

Cognex.InSight.Graphic.CvsGraphicComposite.DeleteSubregion(Cognex.InSight.Graphic.CvsCompositeSubregion subRegion)

Cognex.InSight.Graphic.CvsGraphicComposite.DeleteSubregionByIndex(int index)

Cognex.InSight.Graphic.CvsGraphicComposite.GetSubregionOperation(int index)

Cognex.InSight.Graphic.CvsGraphicComposite.Initialize(int cellRow, int cellCol, Cognex.InSight.Graphic.CvsCompositeSubregion[] subRegions, string Label)

Cognex.InSight.Graphic.CvsGraphicComposite.InsertAnnulus(int index, Cognex.InSight.Graphic.CvsGraphicAnnulus annulus, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicComposite.InsertCircle(int index, Cognex.InSight.Graphic.CvsGraphicCircle circle, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicComposite.InsertPolygon(int index, Cognex.InSight.Graphic.CvsGraphicPolygon polygon, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicComposite.InsertRegion(int index, Cognex.InSight.Graphic.CvsGraphicRegion region, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicComposite.SetSubregionAnnulus(int index, Cognex.InSight.Graphic.CvsGraphicAnnulus annulus)

Cognex.InSight.Graphic.CvsGraphicComposite.SetSubregionCircle(int index, Cognex.InSight.Graphic.CvsGraphicCircle circle)

Cognex.InSight.Graphic.CvsGraphicComposite.SetSubregionOperation(int index, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicComposite.SetSubregionPolygon(int index, Cognex.InSight.Graphic.CvsGraphicPolygon polygon)

Cognex.InSight.Graphic.CvsGraphicComposite.SetSubregionRegion(int index, Cognex.InSight.Graphic.CvsGraphicRegion region)

Added Methods

Cognex.InSight.Cell.CvsCellEditMaskedRegion.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditMaskedRegion.ToString()

Cognex.InSight.Cell.CvsCellEditPolylinePath.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditPolylinePath.ToString()

Cognex.InSight.CvsAuditMessageSettings.Clone()

Cognex.InSight.Graphic.CvsGraphic.GetDrawOrder()

Cognex.InSight.Graphic.CvsGraphicArrows.Initialize(int cellRow, int cellCol, Cognex.InSight.CvsImageLocation start, System.Single angle)

Cognex.InSight.Graphic.CvsGraphicArrows+Arrow.Clone(Cognex.InSight.Graphic.CvsGraphicArrows+Arrow org)

Cognex.InSight.Graphic.CvsGraphicArrows+Arrow.Create(Cognex.InSight.CvsImageLocation loc, System.Single angle)

Cognex.InSight.Graphic.CvsGraphicCompositeBase.ClearSubregions()

Cognex.InSight.Graphic.CvsGraphicCompositeBase.DeleteSubregion(Cognex.InSight.Graphic.CvsCompositeSubregion subRegion)

Cognex.InSight.Graphic.CvsGraphicCompositeBase.DeleteSubregionByIndex(int index)

Cognex.InSight.Graphic.CvsGraphicCompositeBase.GetSubregionOperation(int index)

Cognex.InSight.Graphic.CvsGraphicCompositeBase.Initialize(int cellRow, int cellCol, Cognex.InSight.Graphic.CvsCompositeSubregion[] subRegions, string Label)

Cognex.InSight.Graphic.CvsGraphicCompositeBase.InsertAnnulus(int index, Cognex.InSight.Graphic.CvsGraphicAnnulus annulus, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicCompositeBase.InsertCircle(int index, Cognex.InSight.Graphic.CvsGraphicCircle circle, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicCompositeBase.InsertPolygon(int index, Cognex.InSight.Graphic.CvsGraphicPolygon polygon, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicCompositeBase.InsertRegion(int index, Cognex.InSight.Graphic.CvsGraphicRegion region, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicCompositeBase.SetSubregionAnnulus(int index, Cognex.InSight.Graphic.CvsGraphicAnnulus annulus)

Cognex.InSight.Graphic.CvsGraphicCompositeBase.SetSubregionCircle(int index, Cognex.InSight.Graphic.CvsGraphicCircle circle)

Cognex.InSight.Graphic.CvsGraphicCompositeBase.SetSubregionOperation(int index, Cognex.InSight.Graphic.CvsCompositeOperation operation)

Cognex.InSight.Graphic.CvsGraphicCompositeBase.SetSubregionPolygon(int index, Cognex.InSight.Graphic.CvsGraphicPolygon polygon)

Cognex.InSight.Graphic.CvsGraphicCompositeBase.SetSubregionRegion(int index, Cognex.InSight.Graphic.CvsGraphicRegion region)

Cognex.InSight.Graphic.CvsGraphicDefectPoints.GetPoints()

Cognex.InSight.Graphic.CvsGraphicDefectPoints.Initialize(int cellRow, int cellCol, Cognex.InSight.CvsImageLocation[] points)

Cognex.InSight.Graphic.CvsGraphicEdgePoints.GetPoints()

Cognex.InSight.Graphic.CvsGraphicEdgePoints.Initialize(int cellRow, int cellCol, Cognex.InSight.CvsImageLocation[] points)

Cognex.InSight.Graphic.CvsGraphicExtremePoints.GetPoints()

Cognex.InSight.Graphic.CvsGraphicExtremePoints.Initialize(int cellRow, int cellCol, Cognex.InSight.CvsImageLocation[] points)

Cognex.InSight.Sensor.CvsDiscreteOutputLine.SupportTimeAfterTrigger(Cognex.InSight.Sensor.CvsOutputType type)

Removed Property Setters

Cognex.InSight.Graphic.CvsGraphicComposite.EditFlags { set; }

Cognex.InSight.Graphic.CvsGraphicComposite.Subregions { set; }

Added Property Setters

Cognex.InSight.CvsAuditMessageSettings.Enabled { set; }

Cognex.InSight.CvsAuditMessageSettings.IPAddress { set; }

Cognex.InSight.CvsAuditMessageSettings.LogEventsEnabled { set; }

Cognex.InSight.CvsAuditMessageSettings.LogSystemChangesEnabled { set; }

Cognex.InSight.CvsAuditMessageSettings.LogTagsEnabled { set; }

Cognex.InSight.CvsAuditMessageSettings.Port { set; }

Cognex.InSight.Graphic.CvsGraphicCompositeBase.EditFlags { set; }

Cognex.InSight.Graphic.CvsGraphicCompositeBase.Subregions { set; }

Cognex.InSight.Sensor.CvsDiscreteOutputLine.DelayNumberIsTimeAfterTrigger { set; }

Removed Property Getters

Cognex.InSight.Graphic.CvsGraphicComposite.EditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicComposite.Subregions { get; }

Cognex.InSight.Net.CvsNetworkMonitorSubnet.BroadcastAddress { get; }

Cognex.InSight.Net.CvsNetworkMonitorSubnet.IPAddress { get; }

Cognex.InSight.Net.CvsNetworkMonitorSubnet.Name { get; }

Cognex.InSight.Net.CvsNetworkMonitorSubnet.SubnetMask { get; }

Added Property Getters

Cognex.InSight.Cell.CvsCell.Control { get; }

Cognex.InSight.Cell.CvsCellEditMaskedRegion.Subregions { get; }

Cognex.InSight.Cell.CvsCellEditMaskedRegion.Text { get; }

Cognex.InSight.Cell.CvsCellEditPolylinePath.Subregions { get; }

Cognex.InSight.Cell.CvsCellEditPolylinePath.Text { get; }

Cognex.InSight.Cell.CvsCellString.ControlFunction { get; }

Cognex.InSight.CvsAuditMessageSettings.Enabled { get; }

Cognex.InSight.CvsAuditMessageSettings.IPAddress { get; }

Cognex.InSight.CvsAuditMessageSettings.LogEventsEnabled { get; }

Cognex.InSight.CvsAuditMessageSettings.LogSystemChangesEnabled { get; }

Cognex.InSight.CvsAuditMessageSettings.LogTagsEnabled { get; }

Cognex.InSight.CvsAuditMessageSettings.Port { get; }

Cognex.InSight.Graphic.CvsGraphicArrows.Arrows { get; }

Cognex.InSight.Graphic.CvsGraphicCompositeBase.EditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicCompositeBase.Subregions { get; }

Cognex.InSight.Graphic.CvsGraphicCompositeBase.ValidEditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicDefectPoints.NumPoints { get; }

Cognex.InSight.Graphic.CvsGraphicEdgePoints.NumPoints { get; }

Cognex.InSight.Graphic.CvsGraphicExtremePoints.NumPoints { get; }

Cognex.InSight.Graphic.CvsGraphicMaskedRegion.ValidEditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicPolylinePath.ValidEditFlags { get; }

Cognex.InSight.Sensor.CvsDiscreteOutputLine.DelayNumberIsTimeAfterTrigger { get; }

Cognex.InSight.Sensor.CvsSettings.ActiveIOModuleLines { get; }

Cognex.InSight.Sensor.CvsSettings.AuditMessageSettings { get; }

Cognex.InSight.Sensor.CvsSettings.AuditMessagesSupported { get; }

Cognex.InSight.Sensor.CvsSettings.DiscreteTriggerDelayTimeSupported { get; }

Removed Classes

Cognex.InSight.Net.CvsNetworkMonitorSubnet

Added Classes

Cognex.InSight.Cell.CvsCellEditMaskedRegion

Cognex.InSight.Cell.CvsCellEditPolylinePath

Cognex.InSight.CvsAuditMessageSettings

Cognex.InSight.Graphic.CvsGraphicArrows

Cognex.InSight.Graphic.CvsGraphicCompositeBase

Cognex.InSight.Graphic.CvsGraphicDefectPoints

Cognex.InSight.Graphic.CvsGraphicEdgePoints

Cognex.InSight.Graphic.CvsGraphicExtremePoints

Cognex.InSight.Graphic.CvsGraphicMaskedRegion

Cognex.InSight.Graphic.CvsGraphicPolylinePath

Added Enumerations

Cognex.InSight.Sensor.CvsStrobeStartPositionType

Added Enumeration Values

Cognex.InSight.Cell.CvsCellDataType.Chart

Cognex.InSight.Sensor.CvsStrobeStartPositionType.AcquisitionStart

Cognex.InSight.Sensor.CvsStrobeStartPositionType.CameraTrigger

Added Custom Attributes

T:Cognex.InSight.Cell.CvsCellEditMaskedRegion - [Serializable]

T:Cognex.InSight.Cell.CvsCellEditMaskedRegion - [Guid("1305F631-6785-429d-9C2D-CEAF9C0BB777")]

T:Cognex.InSight.Cell.CvsCellEditPolylinePath - [Serializable]

T:Cognex.InSight.Cell.CvsCellEditPolylinePath - [Guid("801F3466-FDFB-4d85-82E7-47C87D435162")]

T:Cognex.InSight.CvsAuditMessageSettings - [Serializable]

T:Cognex.InSight.CvsAuditMessageSettings - [Guid("DAD1E0D3-7025-4418-9698-8761F9CDFC93")]

T:Cognex.InSight.Graphic.CvsGraphicArrows - [Serializable]

T:Cognex.InSight.Graphic.CvsGraphicArrows - [Guid("1F438B80-16DD-4155-9761-83AEC8FDD7B9")]

T:Cognex.InSight.Graphic.CvsGraphicCompositeBase - [Serializable]

T:Cognex.InSight.Graphic.CvsGraphicDefectPoints - [Serializable]

T:Cognex.InSight.Graphic.CvsGraphicDefectPoints - [Guid("DAF1A1BF-A75E-4829-9A96-952CEAB119CB")]

T:Cognex.InSight.Graphic.CvsGraphicEdgePoints - [Serializable]

T:Cognex.InSight.Graphic.CvsGraphicEdgePoints - [Guid("7787367C-B39C-4d91-8EAD-7ABDFD5F7BDA")]

T:Cognex.InSight.Graphic.CvsGraphicExtremePoints - [Serializable]

T:Cognex.InSight.Graphic.CvsGraphicExtremePoints - [Guid("3E6A4E3B-C833-44db-94CA-B69B8200DD6D")]

T:Cognex.InSight.Graphic.CvsGraphicMaskedRegion - [Serializable]

T:Cognex.InSight.Graphic.CvsGraphicMaskedRegion - [Guid("DB157F28-8133-4ee1-8249-1A3C08BAFCA6")]

T:Cognex.InSight.Graphic.CvsGraphicPolylinePath - [Serializable]

T:Cognex.InSight.Graphic.CvsGraphicPolylinePath - [Guid("02369A0F-E8B4-4979-B919-CB1C9A4C7B28")]

Copyright (c) 2004-2014 Cognex Corporation.


4.4.0 to 4.5.0

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (4.4.7268.0 to 4.5.474.0)

Removed Constructors

Cognex.InSight.Controls.Display.CvsInSightDisplay+TextScaleModeChanged..ctor(object object, System.IntPtr method)

Cognex.InSight.Controls.Display.OmniFontTrainConfusionMatrixData..ctor()

Added Constructors

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController..ctor(Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView view, Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView setupView, Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView poseView, Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView resultsView)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog..ctor()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError..ctor(System.Drawing.Rectangle location, System.Windows.Forms.Control ctrl)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList..ctor()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings..ctor()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings..ctor(Cognex.InSight.CvsInSight InSight)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings..ctor(Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings other)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings..ctor(Cognex.InSight.Internal.CvsTagReader reader)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings..ctor()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings..ctor(Cognex.InSight.CvsInSight InSight)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings..ctor(Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings other)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsFeatureLocation..ctor(int index, double imageX, double imageY)

Cognex.InSight.Controls.Display.CvsFilmstrip..ctor()

Cognex.InSight.Controls.Display.CvsFilmstripPlayback..ctor(Cognex.InSight.Controls.Display.CvsFilmstrip _filmstrip)

Cognex.InSight.Controls.Display.CvsFilmstripPlayback..ctor()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue..ctor(Cognex.InSight.Controls.Display.CvsFilmstrip _filmstrip)

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue..ctor()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions..ctor()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings..ctor()

Cognex.InSight.Controls.Display.CvsInSightDisplay+CvsTextScaleModeEventHandler..ctor(object object, System.IntPtr method)

Cognex.InSight.Controls.Display.Protocols.GridTableCellFormat..ctor()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl..ctor()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController..ctor(Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerDeviceView view)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings..ctor(Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings other)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings..ctor()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl..ctor()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController..ctor(Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView view)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsDialog..ctor()

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock..ctor(Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlockName name)

Cognex.InSight.Controls.Display.Protocols.MelsecDevice..ctor()

Cognex.InSight.Controls.Display.Protocols.MelsecDevice..ctor(Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType type)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettings..ctor()

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl..ctor()

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController..ctor(Cognex.InSight.Controls.Display.Protocols.IProfinetSettingsView view)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog..ctor()

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString..ctor()

Cognex.InSight.Controls.Display.PtpTimeSyncDialog..ctor(Cognex.InSight.Controls.Display.Internal.PtpTimeSyncController controller)

Removed Methods

Cognex.InSight.Controls.Display.CvsInSightDisplay+TextScaleModeChanged.BeginInvoke(int index, System.AsyncCallback callback, object object)

Cognex.InSight.Controls.Display.CvsInSightDisplay+TextScaleModeChanged.EndInvoke(System.IAsyncResult result)

Cognex.InSight.Controls.Display.CvsInSightDisplay+TextScaleModeChanged.Invoke(int index)

Added Methods

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.Calibrate()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.ClearAll()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.Dispose()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.Initialize(Cognex.InSight.CvsCellLocation currentCell, string expr, System.Boolean inDialog, string sensorName)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.OnClosing(System.Windows.Forms.DialogResult dialogResult)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.PoseStepSelected(int poseIndex)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.ResultsStepSelected()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.SetupStepSelected()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.Initialize(Cognex.InSight.CvsCellLocation currentCell, string expr, System.Boolean inDialog, string sensorName, System.Collections.Hashtable options)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.OnClosed(System.EventArgs e)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.OnClosing(System.ComponentModel.CancelEventArgs e)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Dispose()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.SelectFeature(Cognex.InSight.CvsImageLocation location, int touchDistance)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.ShowAxes(int originIndex, int xAxisIndex, int yAxisIndex)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.Clone()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.Equivalent(Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings other)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.AcceptFeatures(int poseIndex, double poseX, double poseY, double poseAngle)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.AnalyzeFeatures(Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings pose, Cognex.InSight.CvsImage image)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.AxisFeaturesValid(int index)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.Calibrate(Cognex.InSight.CvsInSight insight)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.ClearCalibrationResults()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.Clone()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.Dispose()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.Equivalent(Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings other)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.ExtractPoseFeatures(Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings pose, Cognex.InSight.CvsInSight insight, Cognex.InSight.CvsImage image)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.FromTag(Cognex.InSight.Internal.CvsCellTag tag)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.IsPoseOk(int index)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.Pose(int index)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.ReadCalibrationDataFromSensor(Cognex.InSight.CvsInSight insight, Cognex.InSight.CvsCellLocation loc, out Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridUnit& gridUnit, out Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateDistortionModel& distortionModel)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.ReadyToCalibrate()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.SendCalibrationDataToSensor(Cognex.InSight.CvsInSight insight, Cognex.InSight.CvsCellLocation loc)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.ToTag(Cognex.InSight.Internal.CvsCellTag tag, Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings settings)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsFeatureLocation.Clear()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsFeatureLocation.SetIndex(double[] data, double delta)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridCommonView.Dispose()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridCommonView.RaiseClosed()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridControlView.Dispose()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.HideAllControls()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.SetNumberOfPoses(int numberOfPoses)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.SetPoseStatus(int poseIndex, System.Boolean valid)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.SetResultsStatus(System.Boolean valid)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.SetSetupStatus(System.Boolean valid)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.SetTreeViewWidth()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.ShowControl(System.Type t)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.ShowResultsStep()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.ShowSetupStep()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController.AdjustRegion()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController.CheckPoseStatus()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController.FeatureCountChanged()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController.LiveMode()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController.ManualTrigger()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController.OpenImage()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController.PoseAngleChanged()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController.PoseXChanged()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController.PoseYChanged()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController.SetOriginFeature(int index)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController.SetXAxisFeature(int index)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController.SetYAxisFeature(int index)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.HideResults()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.Initialize(Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController controller)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.SetLocationRestrictions(System.Boolean x, System.Boolean y, System.Boolean angle)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.ShowAxes(int originIndex, int xAxisIndex, int yAxisIndex)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.ShowResults(object features, string message, System.Boolean enableRegion, System.Boolean enablePoseCoordinates)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintView.Initialize(Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintViewController controller)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintViewController.Ok()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView.HideResults()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView.ShowResults(double[] features)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupController.GridSpacingChanged()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupController.GridTypeChanged()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupController.GridUnitIndexChanged()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupController.LensDistortionModelChanged()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupController.NotesChanged()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupController.NumberOfPosesChanged()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupController.PoseLocationModeChanged()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupController.PrintGrid()

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.Initialize(Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupController controller)

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.ShowUnits(string[] units)

Cognex.InSight.Controls.Display.CvsFilmstrip.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.CvsFilmstrip.OnResize(System.EventArgs e)

Cognex.InSight.Controls.Display.CvsFilmstrip.PreProcessMessage(ref System.Windows.Forms.Message& msg)

Cognex.InSight.Controls.Display.CvsFilmstrip.UpdateStatus()

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Connect()

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Disconnect()

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Dispose()

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.ProcessShortcutKeys(System.Windows.Forms.KeyEventArgs e)

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.RequestThumbnailImagesUpdate()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Connect()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Disconnect()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Dispose()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.ProcessShortcutKeys(System.Windows.Forms.KeyEventArgs e)

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.RequestThumbnailImagesUpdate()

Cognex.InSight.Controls.Display.CvsInSightDisplay.GetCellAtPoint(int x, int y)

Cognex.InSight.Controls.Display.CvsInSightDisplay+CvsTextScaleModeEventHandler.BeginInvoke(int index, System.AsyncCallback callback, object object)

Cognex.InSight.Controls.Display.CvsInSightDisplay+CvsTextScaleModeEventHandler.EndInvoke(System.IAsyncResult result)

Cognex.InSight.Controls.Display.CvsInSightDisplay+CvsTextScaleModeEventHandler.Invoke(int index)

Cognex.InSight.Controls.Display.ICvsFilmQueue.RequestThumbnailImagesUpdate()

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerDeviceView.UpdateControl()

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerDeviceView.UpdateEnables(System.Boolean offline)

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.SetBusyEnables(System.Boolean enabled)

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.UpdateConnectionStatus(string status)

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.UpdateEnables(System.Boolean offline, System.Boolean validIp)

Cognex.InSight.Controls.Display.Protocols.IProfinetSettingsView.UpdateControl()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.Commit()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.OnLoad(System.EventArgs e)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.Reset()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.UpdateControl()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.UpdateEnables(System.Boolean offline)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController.Commit()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController.OnCommit(System.Boolean writeResults)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController.Reset()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController.UpdateDataBlockFormat()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController.UpdateDataBlocks()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController.UpdateView()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.Equals(object obj)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.GetHashCode()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Commit()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.SetBusyEnables(System.Boolean enabled)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.UpdateConnectionStatus(string p)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.UpdateEnables(System.Boolean offline, System.Boolean validIp)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.Disconnect()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.GetSettings(Cognex.InSight.CvsInSight insight, Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings settings)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.MCProtocolScannerEnabled(Cognex.InSight.CvsInSight inSight)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.OnCommit(System.Boolean writeResult)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.OnIPAddressChanged()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.OnIPAddressLeave()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.OnPortChanged()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.OnPortKeyPress(System.Windows.Forms.KeyPressEventArgs e)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.Reset()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.SetSettings(Cognex.InSight.CvsInSight insight, Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings settings, System.Boolean writeResults)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.TryConnect()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.UpdateConnectToRemoteStation()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsDialog.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsDialog.OnClosing(System.ComponentModel.CancelEventArgs e)

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.ToString()

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl.UpdateControl()

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.GetSettings(Cognex.InSight.CvsInSight inSight)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.SetSettings(Cognex.InSight.CvsInSight inSight, Cognex.InSight.Controls.Display.Protocols.ProfinetSettings settings)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.ValidateStationName(string stationName)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog.OnClosing(System.ComponentModel.CancelEventArgs e)

Cognex.InSight.Controls.Display.PtpTimeSyncDialog.Dispose(System.Boolean disposing)

Removed Property Setters

Cognex.InSight.Controls.Display.OmniFontTrainConfusionMatrixData.Highlighted { set; }

Cognex.InSight.Controls.Display.OmniFontTrainConfusionMatrixData.Score { set; }

Added Property Setters

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.Display { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.InSight { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.Display { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.InSight { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.AverageError { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.BackColor { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.GraphCtrl { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Height { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Width { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.X { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Y { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Angle { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.CalibratedLabel { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Display { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.FeatureRegion { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Features { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.SelectedIndex { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.FeatureRegion { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.Features { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.Image { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.Origin { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.PoseAngle { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.PoseX { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.PoseY { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.XAxis { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.YAxis { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.DistortionModel { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.GridSpacing { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.GridType { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.GridUnit { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.MaxError { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.Notes { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.NumberOfPoses { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.PoseLocationAutomatic { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.PoseLocationMovementFlags { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.RmsError { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.TotalFeatures { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsFeatureLocation.ImageX { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsFeatureLocation.ImageY { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsFeatureLocation.Index { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridControlView.Step { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.CalibrateEnabled { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.CancelEnabled { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.CancelText { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.ClearEnabled { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.ClearText { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.OkEnabled { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.AdjustRegionEnabled { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.AxisSelectionEnabled { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.FeatureCount { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.FeatureRegion { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.ManualAcquireText { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.OriginIndex { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.OriginSelectionEnabled { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.PoseAngle { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.PoseX { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.PoseY { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.XAxisIndex { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.XAxisSelectionEnabled { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.YAxisIndex { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.YAxisSelectionEnabled { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintView.GridSpacing { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintView.GridType { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintView.GridUnit { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView.AvgError { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView.FeaturesFound { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView.MaxError { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView.ShowCalibrating { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView.TotalFeatures { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.GridSpacing { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.GridType { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.GridUnitIndex { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.GridUnitsEnabled { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.LensDistortionModel { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.MovementEnabled { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.Notes { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.NumberOfPoses { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.PoseLocationAutomatic { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.PoseLocationMovementFlags { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.FilmQueue { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.FirstThumbnailIndex { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.HeightScale { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.LedStyle { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.SelectedIndex { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.ShowSummary { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.ShowThumbnailImage { set; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Enabled { set; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Filmstrip { set; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Recorder { set; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectedIndex { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Enabled { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Filmstrip { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.InSight { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Options { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectedIndex { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.DisplayAction { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.LedStyle { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.PauseDelay { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.SavePath { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.ShowFilmstrip { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.UseSystemColors { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.ClearOnline { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.Mode { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.QueueSize { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.Type { set; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.Enabled { set; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.Filmstrip { set; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectedIndex { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DefaultGateway { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DefaultGatewayErrorInfo { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DhcpChecked { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DhcpTimeout { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DnsServer { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DnsServerErrorInfo { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DomainName { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DomainNameErrorInfo { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.HostName { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.HostNameErrorInfo { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.IPAddress { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.IPAddressErrorInfo { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.OKEnabled { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.StaticIpFieldsEnabled { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.SubnetMask { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.SubnetMaskErrorInfo { set; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.ConnectToRemoteStation { set; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.DestinationModule { set; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.IPAddress { set; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.NetworkNumber { set; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.PCNumber { set; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.PollInterval { set; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.Port { set; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.Timeout { set; }

Cognex.InSight.Controls.Display.Protocols.IProfinetSettingsView.StationName { set; }

Cognex.InSight.Controls.Display.Protocols.IProfinetSettingsView.StationNameEnabled { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandLength { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandResultAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandResultLength { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.ControlAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.DestinationModule { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.HostPort { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.InputAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.InputLength { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.IpAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.NetworkNumber { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.OutputAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.OutputLength { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.PCNumber { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.PollInterval { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.StatusAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.Timeout { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.ConnectToRemoteStation { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.DestinationModule { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.IPAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.NetworkNumber { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PCNumber { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PollInterval { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Port { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Timeout { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsDialog.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsDialog.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.FullAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.Length { set; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.Offset { set; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.SelectedDevice { set; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Address { set; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.FullAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Type { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettings.StationName { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettings.StationNameEnabled { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl.StationName { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl.StationNameEnabled { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog.Settings { set; }

Removed Property Getters

Cognex.InSight.Controls.Display.OmniFontTrainConfusionMatrixData.Highlighted { get; }

Cognex.InSight.Controls.Display.OmniFontTrainConfusionMatrixData.Score { get; }

Added Property Getters

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.Display { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.InSight { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.Display { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.InSight { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.AverageError { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.BackColor { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.GraphCtrl { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Height { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Width { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.X { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Y { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Angle { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.CalibratedLabel { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Display { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.FeatureRegion { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Features { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.SelectedIndex { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.FeatureCount { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.FeatureRegion { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.Features { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.Image { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.Origin { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.PoseAngle { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.PoseX { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.PoseY { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.XAxis { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings.YAxis { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.CalibratedFeatures { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.DistortionModel { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.GridSpacing { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.GridType { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.GridUnit { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.GridWithoutFiducial { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.IsCalibrated { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.MaxError { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.MotionCapability { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.Notes { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.NumberOfPoses { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.PoseLocationAutomatic { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.PoseLocationMovementFlags { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.ResultsOk { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.RmsError { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.SetupOk { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.TotalFeatures { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsFeatureLocation.ImageX { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsFeatureLocation.ImageY { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsFeatureLocation.Index { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridControlView.Step { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.CalibrateEnabled { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.CancelEnabled { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.CancelText { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.ClearEnabled { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.ClearText { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView.OkEnabled { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.AdjustRegionEnabled { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.AxisSelectionEnabled { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.FeatureRegion { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.ManualAcquireText { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.OriginIndex { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.OriginSelectionEnabled { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.PoseAngle { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.PoseX { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.PoseY { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.XAxisIndex { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.XAxisSelectionEnabled { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.YAxisIndex { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView.YAxisSelectionEnabled { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintView.GridSpacing { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintView.GridType { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintView.GridUnit { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView.AvgError { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView.FeaturesFound { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView.MaxError { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView.ShowCalibrating { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView.TotalFeatures { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.GridSpacing { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.GridType { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.GridUnitIndex { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.GridUnitsEnabled { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.LensDistortionModel { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.MovementEnabled { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.Notes { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.NumberOfPoses { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.PoseLocationAutomatic { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView.PoseLocationMovementFlags { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.FilmQueue { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.FirstThumbnailIndex { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.HeightScale { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.LedStyle { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.MaxThumbnailsDisplayed { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.SelectedIndex { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.ShowSummary { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.ShowThumbnailImage { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.ThumbnailsDisplayed { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.ClearQueue { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.DeleteSelectedItem { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Enabled { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Filmstrip { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Play { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.QueueSize { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Recorder { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.ResultsStatus { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SaveQueue { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectedIndex { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectFirst { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectLast { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectNext { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectNextPage { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectPrevious { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectPrevPage { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SupportsEdit { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.ThumbnailImages { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.ClearQueue { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.DeleteSelectedItem { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Enabled { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Filmstrip { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.FreezeQueue { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.InSight { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.IsFrozen { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Options { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.QueueSize { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.ResultsStatus { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SaveQueue { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectedIndex { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectFirst { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectLast { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectNext { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectNextPage { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectPrevious { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectPrevPage { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Settings { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SupportsEdit { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.ThumbnailImages { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.DisplayAction { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.LedStyle { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.PauseDelay { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.SavePath { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.ShowFilmstrip { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.UseSystemColors { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.ClearOnline { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.Mode { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.QueueSize { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.Type { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.VisibleRange { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditVisionViewViewSelection { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.ClearQueue { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.DeleteSelectedItem { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.Enabled { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.Filmstrip { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.QueueSize { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.ResultsStatus { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SaveQueue { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectedIndex { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectFirst { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectLast { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectNext { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectNextPage { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectPrevious { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectPrevPage { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SupportsEdit { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.ThumbnailImages { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DefaultGateway { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DefaultGatewayErrorInfo { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DhcpChecked { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DhcpTimeout { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DnsServer { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DnsServerErrorInfo { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DomainName { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DomainNameErrorInfo { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.HostName { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.HostNameErrorInfo { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.IPAddress { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.IPAddressErrorInfo { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.StaticIpFieldsEnabled { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.SubnetMask { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.SubnetMaskErrorInfo { get; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerDeviceView.GridViewDataSource { get; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.ConnectToRemoteStation { get; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.DestinationModule { get; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.IPAddress { get; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.NetworkNumber { get; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.PCNumber { get; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.PollInterval { get; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.Port { get; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.Timeout { get; }

Cognex.InSight.Controls.Display.Protocols.IProfinetSettingsView.StationName { get; }

Cognex.InSight.Controls.Display.Protocols.IProfinetSettingsView.StationNameEnabled { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.Dirty { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.GridViewDataSource { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController.DataBlocksFormat { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController.Dirty { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandLength { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandResultAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandResultLength { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.ControlAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.DestinationModule { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.HostPort { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.InputAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.InputLength { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.IpAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.NetworkNumber { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.OutputAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.OutputLength { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.PCNumber { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.PollInterval { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.StatusAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.Timeout { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.ConnectToRemoteStation { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.DestinationModule { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Dirty { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.IPAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.NetworkNumber { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PCNumber { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PollInterval { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Port { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Timeout { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.ConnectionStatusCode { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.ConnectionStatusString { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.Dirty { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.IPAddressErrorMessage { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.PortErrorMessage { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.ProtocolEnabled { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.Description { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.FullAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.Length { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.Name { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.Offset { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.SelectedDevice { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.SupportedDeviceTypes { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Address { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.AddressError { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.AddressInt { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Code { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Format { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.FullAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.FullName { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Name { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Type { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Units { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.UnitsString { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.ValidAddress { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettings.StationName { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettings.StationNameEnabled { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl.StationName { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl.StationNameEnabled { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog.Settings { get; }

Removed Classes

Cognex.InSight.Controls.Display.OmniFontTrainConfusionMatrixData

Added Classes

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridPoseSettings

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings

Cognex.InSight.Controls.Display.CalibrateGrid.CvsFeatureLocation

Cognex.InSight.Controls.Display.CvsFilmstrip

Cognex.InSight.Controls.Display.CvsFilmstripPlayback

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings

Cognex.InSight.Controls.Display.Protocols.GridTableCellFormat

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsDialog

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock

Cognex.InSight.Controls.Display.Protocols.MelsecDevice

Cognex.InSight.Controls.Display.Protocols.ProfinetSettings

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString

Cognex.InSight.Controls.Display.PtpTimeSyncDialog

Removed Events

Cognex.InSight.Controls.Display.CvsInSightDisplay.OnTextScaleModeChanged

Added Events

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.DistortionModelChanged

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.GridTypeChanged

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.NumberOfPosesChanged

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings.ResultsChanged

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.Changed

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.Changed

Cognex.InSight.Controls.Display.CvsInSightDisplay.FocusGraphicChanged

Cognex.InSight.Controls.Display.CvsInSightDisplay.TextScaleModeChanged

Cognex.InSight.Controls.Display.CvsInSightDisplay.VisibleRangeChanged

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EnablesUpdated

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Committing

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.EnableChanged

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Reset

Added Interfaces

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridCommonView

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridControlView

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseController

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintView

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintViewController

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupController

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView

Cognex.InSight.Controls.Display.ICvsFilmQueue

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerDeviceView

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView

Cognex.InSight.Controls.Display.Protocols.IProfinetSettingsView

Added Namespaces

Cognex.InSight.Controls.Display.CalibrateGrid

Cognex.InSight.Controls.Display.Protocols

Added Enumerations

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationState

Cognex.InSight.Controls.Display.CalibrateGrid.CvsPoseLocationMovementFlags

Cognex.InSight.Controls.Display.CvsFilmstripHeightScale

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueMode

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueType

Cognex.InSight.Controls.Display.CvsResultsQueueDisplayAction

Cognex.InSight.Controls.Display.CvsStatusLevelStyle

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlockName

Cognex.InSight.Controls.Display.Protocols.MelsecAddressUnits

Cognex.InSight.Controls.Display.Protocols.MelsecDataFormat

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode

Added Enumeration Values

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationState.SetupView

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationState.PoseView

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationState.ResultsView

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationState.PrintView

Cognex.InSight.Controls.Display.CalibrateGrid.CvsPoseLocationMovementFlags.SideToSide

Cognex.InSight.Controls.Display.CalibrateGrid.CvsPoseLocationMovementFlags.UpAndDown

Cognex.InSight.Controls.Display.CalibrateGrid.CvsPoseLocationMovementFlags.Rotation

Cognex.InSight.Controls.Display.CalibrateGrid.CvsPoseLocationMovementFlags.All

Cognex.InSight.Controls.Display.CvsFilmstripHeightScale.Quarter

Cognex.InSight.Controls.Display.CvsFilmstripHeightScale.Half

Cognex.InSight.Controls.Display.CvsFilmstripHeightScale.One

Cognex.InSight.Controls.Display.CvsFilmstripHeightScale.Two

Cognex.InSight.Controls.Display.CvsFilmstripHeightScale.Four

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueMode.None

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueMode.OnlyFail

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueMode.All

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueMode.OnlyPass

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueType.Last

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueType.First

Cognex.InSight.Controls.Display.CvsResultsQueueDisplayAction.Freeze

Cognex.InSight.Controls.Display.CvsResultsQueueDisplayAction.Pause

Cognex.InSight.Controls.Display.CvsResultsQueueDisplayAction.Nothing

Cognex.InSight.Controls.Display.CvsStatusLevelStyle.Geometric

Cognex.InSight.Controls.Display.CvsStatusLevelStyle.OKorNG

Cognex.InSight.Controls.Display.CvsStatusLevelStyle.Check

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.LocalStation

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.ControlSystemCPU

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.StandbySystemCPU

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.SystemACPU

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.SystemBCPU

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.CPU1

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.CPU2

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.CPU3

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.CPU4

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlockName.Control

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlockName.Status

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlockName.PLCInput

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlockName.PLCOutput

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlockName.Command

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlockName.CommandResult

Cognex.InSight.Controls.Display.Protocols.MelsecAddressUnits.Hex

Cognex.InSight.Controls.Display.Protocols.MelsecAddressUnits.Decimal

Cognex.InSight.Controls.Display.Protocols.MelsecAddressUnits.None

Cognex.InSight.Controls.Display.Protocols.MelsecAddressUnits.Unknown

Cognex.InSight.Controls.Display.Protocols.MelsecDataFormat.Bit

Cognex.InSight.Controls.Display.Protocols.MelsecDataFormat.Word

Cognex.InSight.Controls.Display.Protocols.MelsecDataFormat.None

Cognex.InSight.Controls.Display.Protocols.MelsecDataFormat.Unknown

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.None

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.InputRelay

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.OutputRelay

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.InternalRelay

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.LatchRelay

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.Annunciator

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.LinkRelay

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.DataRegister

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.LinkRegister

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.FileBlockRegister

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.FileRegister

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.TimerValue

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.CounterValue

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.Unknown

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.IncompatibleInputArgument

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.InvalidUserDataBuffer

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.ConnectionTimeout

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.ProtocolNotStarted

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.UnknownProtocolFault

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.ProtocolConnectionIdle

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.ProtocolConnectionDropped

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.ProtocolConnectionAttemptFailed

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.CIOMicroNotConnected

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.CCLinkNotConfigured

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.CCLinkDown

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerStatusSendingError

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerControlReadingError

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerOutputSendingError

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerInputReadingError

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerCommandReadingError

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerCommandResultSendingError

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerPollRateTooLow

Added Custom Attributes

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Angle { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Angle { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.CalibratedLabel { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.CalibratedLabel { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Display { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Display { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.FeatureRegion { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.FeatureRegion { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Features { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Features { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.FilmQueue { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.FirstThumbnailIndex { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.HeightScale { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.MaxThumbnailsDisplayed { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.SelectedIndex { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.ShowSummary { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.ThumbnailsDisplayed { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectFirst { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)36)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectFirst { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131144)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectLast { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131141)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectLast { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)35)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectNext { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)34)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectNext { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131150)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectNextPage { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)34)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectPrevious { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131152)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectPrevious { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)8)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectPrevPage { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)33)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.ClearQueue { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)12)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.ClearQueue { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131139)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.DeleteSelectedItem { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131140)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.DeleteSelectedItem { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)46)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.FreezeQueue { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131142)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.InSight { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.InSight { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.IsFrozen { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SaveQueue { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131155)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectFirst { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131144)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectFirst { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)36)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectLast { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)35)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectLast { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131141)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectNext { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131150)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectNext { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)34)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectNextPage { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)34)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectPrevious { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)8)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectPrevious { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131138)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectPrevPage { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)33)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.DisplayAction { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.DisplayAction { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.LedStyle { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.LedStyle { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.PauseDelay { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.PauseDelay { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.SavePath { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.SavePath { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.ShowFilmstrip { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.ShowFilmstrip { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.UseSystemColors { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.UseSystemColors { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditVisionViewViewSelection { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceController.Settings { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandLength { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandResultAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandResultLength { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.ControlAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.DestinationModule { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.HostPort { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.InputAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.InputLength { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.IpAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.NetworkNumber { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.OutputAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.OutputLength { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.PCNumber { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.PollInterval { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.StatusAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.Timeout { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.ConnectToRemoteStation { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.ConnectToRemoteStation { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.DestinationModule { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.DestinationModule { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.InSight { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.InSight { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.IPAddress { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.IPAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.NetworkNumber { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.NetworkNumber { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PCNumber { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PCNumber { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PollInterval { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PollInterval { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Port { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Port { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Settings { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Settings { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Timeout { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Timeout { get; } - [ComponentModel.Browsable((Boolean)False)]

Enum:Cognex.InSight.Controls.Display.CalibrateGrid.CvsPoseLocationMovementFlags - [Flags]

Enum:Cognex.InSight.Controls.Display.CvsFilmstripHeightScale - [ComVisible((Boolean)True)]

Enum:Cognex.InSight.Controls.Display.CvsStatusLevelStyle - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList - [ComponentModel.ToolboxItem((Boolean)False)]

T:Cognex.InSight.Controls.Display.CvsFilmstrip - [Cognex.InSight.Internal.ComTypeFlags((ComTypes.TYPEFLAGS)528)]

T:Cognex.InSight.Controls.Display.CvsFilmstrip - [ComSourceInterfaces(typeof(Cognex.InSight.Controls.Display.Internal.ICvsFilmstripEvents))]

T:Cognex.InSight.Controls.Display.CvsFilmstrip - [Guid("019D7437-EF26-4bf8-BEDF-EB5A667B75F7")]

T:Cognex.InSight.Controls.Display.CvsFilmstrip - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Display.CvsFilmstrip - [ClassInterface((ClassInterfaceType)0)]

T:Cognex.InSight.Controls.Display.CvsFilmstripPlayback - [ClassInterface((ClassInterfaceType)2)]

T:Cognex.InSight.Controls.Display.CvsFilmstripPlayback - [ComSourceInterfaces("")]

T:Cognex.InSight.Controls.Display.CvsFilmstripPlayback - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue - [ClassInterface((ClassInterfaceType)2)]

T:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue - [ComSourceInterfaces("")]

T:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl - [ComponentModel.ToolboxItem((Boolean)False)]

T:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl - [ComponentModel.ToolboxItem((Boolean)False)]

T:Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl - [ComponentModel.ToolboxItem((Boolean)False)]

API Changes - Cognex.InSight.dll (4.4.7268.0 to 4.5.474.0)

Added Constructors

Cognex.InSight.Analysis.CvsCellReference..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsCellRange referencedRange, System.Boolean isCellStateReference)

Cognex.InSight.Analysis.CvsCellReferenceTable..ctor()

Cognex.InSight.Analysis.CvsJobAnalyzer..ctor()

Cognex.InSight.CvsEasyViewItem..ctor(string name, string caption, string dataType, System.Boolean editable, Cognex.InSight.CvsEasyViewItemType type, Cognex.InSight.CvsCellLocation location, System.Boolean readOnly)

Cognex.InSight.CvsSymbolicTag..ctor(Cognex.InSight.CvsCellLocation location, string name)

Cognex.InSight.CvsSymbolicTag..ctor(Cognex.InSight.CvsCellLocation location, string name, System.Boolean exposeToOpc)

Cognex.InSight.CvsSymbolicTag..ctor(Cognex.InSight.CvsCellLocation location, string name, System.Boolean exposeToOpc, System.Boolean inEasyView)

Cognex.InSight.CvsSymbolicTag..ctor(Cognex.InSight.CvsSymbolicTag original, System.Boolean inEasyView)

Cognex.InSight.CvsSymbolicTag..ctor(Cognex.InSight.CvsSymbolicTag original)

Cognex.InSight.CvsSymbolicTag..ctor(Cognex.InSight.CvsCellLocation location, string name, System.Boolean exposeToOpc, System.Boolean auditMessage, System.Boolean inEasyView)

Cognex.InSight.CvsSymbolicTagCollection..ctor()

Cognex.InSight.CvsSymbolicTagCollection..ctor(Cognex.InSight.CvsSymbolicTagCollection original)

Cognex.InSight.Graphic.CvsGraphicFilledBox..ctor(Cognex.InSight.Graphic.CvsGraphicFilledBox graphic)

Cognex.InSight.Graphic.CvsGraphicFilledBox..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation location, System.Single height, System.Single width, System.Single angle, System.Single curve, string label)

Cognex.InSight.Graphic.CvsGraphicFilledBox..ctor()

Cognex.InSight.NativeMode.CvsNativeModeClient..ctor(System.Text.Encoding encoding)

Added Methods

Cognex.InSight.Analysis.CvsCellReference.Equals(object obj)

Cognex.InSight.Analysis.CvsCellReference.GetHashCode()

Cognex.InSight.Analysis.CvsCellReferenceInfo.GetHashCode()

Cognex.InSight.Analysis.CvsCellReferenceInfo.ToString()

Cognex.InSight.Analysis.CvsCellReferenceInfo.ToString(System.Boolean expandNames)

Cognex.InSight.Analysis.CvsCellReferenceTable.GetCellSymbolicName(Cognex.InSight.CvsCellLocation location)

Cognex.InSight.Analysis.CvsCellReferenceTable.GetFirstErrorPrecedent(Cognex.InSight.CvsCellLocation location)

Cognex.InSight.Analysis.CvsCellReferenceTable.GetReferencePaths(Cognex.InSight.CvsCellLocation destination, Cognex.InSight.CvsCellLocation source)

Cognex.InSight.Analysis.CvsCellReferenceTable.GetText(System.IO.TextWriter tw, System.Boolean precedents, Cognex.InSight.CvsCellRange cellRange)

Cognex.InSight.Analysis.CvsCellReferenceTable.Update(Cognex.InSight.CvsResultSet resultSet, Cognex.InSight.CvsInSight inSight)

Cognex.InSight.Analysis.CvsJobAnalyzer.Dispose()

Cognex.InSight.Analysis.CvsJobAnalyzer.GetCellName(Cognex.InSight.CvsCellLocation location)

Cognex.InSight.Analysis.CvsJobAnalyzer.GetCellReferenceInfo(Cognex.InSight.CvsCellLocation location)

Cognex.InSight.Analysis.CvsJobAnalyzer.ReferenceConnected(Cognex.InSight.CvsCellLocation destination, Cognex.InSight.CvsCellLocation source)

Cognex.InSight.Analysis.CvsJobAnalyzer.Validate()

Cognex.InSight.Cell.CvsCell.GetCellProperties(Cognex.InSight.Internal.CvsCellFlags cellFlags)

Cognex.InSight.Cell.CvsCellEditMultiGraphics.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellEditMultiGraphics.ToString()

Cognex.InSight.CvsEasyView.Add(Cognex.InSight.CvsSymbolicTag tag)

Cognex.InSight.CvsEasyView.Add(Cognex.InSight.CvsSymbolicTag tag, string caption)

Cognex.InSight.CvsEasyView.AddLabel()

Cognex.InSight.CvsEasyView.AddLabel(string caption)

Cognex.InSight.CvsEasyView.AddRange(Cognex.InSight.CvsSymbolicTagCollection tags)

Cognex.InSight.CvsEasyView.Clear()

Cognex.InSight.CvsEasyView.Contains(Cognex.InSight.CvsEasyViewItem item)

Cognex.InSight.CvsEasyView.Contains(Cognex.InSight.CvsSymbolicTag tag)

Cognex.InSight.CvsEasyView.GetEnumerator()

Cognex.InSight.CvsEasyView.IndexOf(Cognex.InSight.CvsEasyViewItem item)

Cognex.InSight.CvsEasyView.IndexOf(Cognex.InSight.CvsEasyViewItem item, int index)

Cognex.InSight.CvsEasyView.IndexOf(Cognex.InSight.CvsEasyViewItem item, int index, int count)

Cognex.InSight.CvsEasyView.IndexOf(Cognex.InSight.CvsSymbolicTag tag)

Cognex.InSight.CvsEasyView.IndexOf(Cognex.InSight.CvsSymbolicTag tag, int index)

Cognex.InSight.CvsEasyView.IndexOf(Cognex.InSight.CvsSymbolicTag tag, int index, int count)

Cognex.InSight.CvsEasyView.Insert(Cognex.InSight.CvsSymbolicTag tag, int index)

Cognex.InSight.CvsEasyView.Insert(Cognex.InSight.CvsSymbolicTag tag, string caption, int index)

Cognex.InSight.CvsEasyView.InsertLabel(int index)

Cognex.InSight.CvsEasyView.InsertLabel(string caption, int index)

Cognex.InSight.CvsEasyView.InsertRange(int index, Cognex.InSight.CvsSymbolicTagCollection tags)

Cognex.InSight.CvsEasyView.IsTagAllowedInEasyView(Cognex.InSight.CvsSymbolicTag tag)

Cognex.InSight.CvsEasyView.Remove(Cognex.InSight.CvsEasyViewItem item)

Cognex.InSight.CvsEasyView.Remove(Cognex.InSight.CvsSymbolicTag tag)

Cognex.InSight.CvsEasyView.RemoveAt(int index)

Cognex.InSight.CvsEasyView.Retrieve(Cognex.InSight.CvsInSight insight)

Cognex.InSight.CvsEasyView.Update(Cognex.InSight.CvsInSight insight, List items)

Cognex.InSight.CvsEasyViewItem.GetHashCode()

Cognex.InSight.CvsInSight.GetEasyView()

Cognex.InSight.CvsInSight.GetSymbolicTagCollection()

Cognex.InSight.CvsInSight.SetEasyView(Cognex.InSight.CvsEasyView easyView)

Cognex.InSight.CvsInSight.SetSymbolicTag(Cognex.InSight.CvsCellLocation location, string name)

Cognex.InSight.CvsInSight.SetSymbolicTagCollection(Cognex.InSight.CvsSymbolicTagCollection symbolicTags)

Cognex.InSight.CvsModbusSettings.Clone()

Cognex.InSight.CvsSymbolicTag.Equals(object obj)

Cognex.InSight.CvsSymbolicTag.GetHashCode()

Cognex.InSight.CvsSymbolicTagCollection.Add(Cognex.InSight.CvsSymbolicTag item)

Cognex.InSight.CvsSymbolicTagCollection.Clear()

Cognex.InSight.CvsSymbolicTagCollection.IndexOf(Cognex.InSight.CvsSymbolicTag item)

Cognex.InSight.CvsSymbolicTagCollection.Remove(Cognex.InSight.CvsCellLocation location)

Cognex.InSight.CvsSymbolicTagCollection.RemoveAt(int index)

Cognex.InSight.CvsSymbolicTagCollection.SetName(Cognex.InSight.CvsCellLocation location, string name)

Cognex.InSight.CvsSymbolicTagCollection.SetName(Cognex.InSight.CvsCellLocation location, string name, System.Boolean exposeToOpc)

Cognex.InSight.CvsSymbolicTagCollection.SetName(Cognex.InSight.CvsCellLocation location, string name, System.Boolean exposeToOpc, System.Boolean auditMessage)

Cognex.InSight.CvsSymbolicTagCollection.UpdateTag(ref Cognex.InSight.CvsSymbolicTag& oldTag, Cognex.InSight.CvsCellLocation location, string name, System.Boolean exposeToOpc, System.Boolean auditMessage, System.Boolean inEasyView)

Cognex.InSight.CvsSymbolicTagCollection.UpdateTagLocation(ref Cognex.InSight.CvsSymbolicTag& tag, Cognex.InSight.CvsCellLocation location)

Cognex.InSight.CvsSymbolicTagCollection.UpdateTagName(ref Cognex.InSight.CvsSymbolicTag& tag, string name)

Cognex.InSight.Graphic.CvsGraphicFilledBox.Initialize(int cellRow, int cellCol, System.Single regionRow, System.Single regionCol, System.Single regionHeight, System.Single regionWidth, System.Single regionAngle, System.Single regionCurve, string regionLabel)

Cognex.InSight.Sensor.CvsNetworkSettings.SetEnableProtocolService(Cognex.InSight.Sensor.CvsProtocolServices serviceToEnable, Cognex.InSight.Sensor.CvsProtocolServices currentService)

Added Property Setters

Cognex.InSight.Analysis.CvsJobAnalyzer.InSight { set; }

Cognex.InSight.Controls.CvsAction.RethrowExecuteExceptions { set; }

Cognex.InSight.CvsEasyView.Item { set; }

Cognex.InSight.CvsEasyViewItem.Caption { set; }

Cognex.InSight.CvsEasyViewItem.Editable { set; }

Cognex.InSight.CvsEasyViewItem.ItemType { set; }

Cognex.InSight.CvsEasyViewItem.ReadOnly { set; }

Cognex.InSight.CvsModbusSettings.IdleTimeout { set; }

Cognex.InSight.CvsModbusSettings.MaxConnections { set; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.Angle { set; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.Curve { set; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.Height { set; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.LabelBackColor { set; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.LabelBackColorAsRgb { set; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.LabelForeColor { set; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.LabelForeColorAsRgb { set; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.Location { set; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.Width { set; }

Added Property Getters

Cognex.InSight.Analysis.CvsCellReference.CellLocation { get; }

Cognex.InSight.Analysis.CvsCellReference.ExpressionCellReference { get; }

Cognex.InSight.Analysis.CvsCellReference.IsCellStateReference { get; }

Cognex.InSight.Analysis.CvsCellReference.ReferencedRange { get; }

Cognex.InSight.Analysis.CvsCellReferenceInfo.CellTag { get; }

Cognex.InSight.Analysis.CvsCellReferenceInfo.Dependents { get; }

Cognex.InSight.Analysis.CvsCellReferenceInfo.Precedents { get; }

Cognex.InSight.Analysis.CvsCellReferenceInfo.SymbolicExpression { get; }

Cognex.InSight.Analysis.CvsCellReferenceTable.DialogCells { get; }

Cognex.InSight.Analysis.CvsCellReferenceTable.Item { get; }

Cognex.InSight.Analysis.CvsCellReferenceTable.ResultSet { get; }

Cognex.InSight.Analysis.CvsJobAnalyzer.HasChanged { get; }

Cognex.InSight.Analysis.CvsJobAnalyzer.HasNameListChanged { get; }

Cognex.InSight.Analysis.CvsJobAnalyzer.InSight { get; }

Cognex.InSight.Analysis.CvsJobAnalyzer.NameList { get; }

Cognex.InSight.Analysis.CvsJobAnalyzer.Results { get; }

Cognex.InSight.Cell.CvsCell.Properties { get; }

Cognex.InSight.Cell.CvsCellEditMultiGraphics.Locations { get; }

Cognex.InSight.Cell.CvsCellEditMultiGraphics.ShowLabels { get; }

Cognex.InSight.Cell.CvsCellEditMultiGraphics.Text { get; }

Cognex.InSight.Cell.CvsCellEditString.IsPassword { get; }

Cognex.InSight.Cell.CvsCellListBox.Items { get; }

Cognex.InSight.Controls.CvsAction.RethrowExecuteExceptions { get; }

Cognex.InSight.CvsEasyView.Count { get; }

Cognex.InSight.CvsEasyView.Item { get; }

Cognex.InSight.CvsEasyViewItem.Caption { get; }

Cognex.InSight.CvsEasyViewItem.Editable { get; }

Cognex.InSight.CvsEasyViewItem.IsValid { get; }

Cognex.InSight.CvsEasyViewItem.ItemType { get; }

Cognex.InSight.CvsEasyViewItem.ReadOnly { get; }

Cognex.InSight.CvsModbusSettings.IdleTimeout { get; }

Cognex.InSight.CvsModbusSettings.MaxConnections { get; }

Cognex.InSight.CvsSymbolicTag.AuditMessage { get; }

Cognex.InSight.CvsSymbolicTag.ExposeToOpc { get; }

Cognex.InSight.CvsSymbolicTag.InEasyView { get; }

Cognex.InSight.CvsSymbolicTag.Location { get; }

Cognex.InSight.CvsSymbolicTag.Name { get; }

Cognex.InSight.CvsSymbolicTagCollection.Count { get; }

Cognex.InSight.CvsSymbolicTagCollection.Item { get; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.Angle { get; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.Curve { get; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.Height { get; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.LabelBackColor { get; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.LabelBackColorAsRgb { get; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.LabelForeColor { get; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.LabelForeColorAsRgb { get; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.Location { get; }

Cognex.InSight.Graphic.CvsGraphicFilledBox.Width { get; }

Cognex.InSight.Sensor.CvsNetworkSettings.ModbusSettings { get; }

Cognex.InSight.Sensor.CvsSensor.MaxUserListLength { get; }

Cognex.InSight.Sensor.CvsSettings.MaxEthernetIOUpdateRate { get; }

Cognex.InSight.Sensor.CvsSettings.MCProtocolScannerSupported { get; }

Cognex.InSight.Sensor.CvsSettings.ModbusSettingsSupported { get; }

Cognex.InSight.Sensor.CvsSettings.ProfinetSettingsSupported { get; }

Cognex.InSight.Sensor.CvsSettings.PTPTimeSynchSupported { get; }

Added Classes

Cognex.InSight.Analysis.CvsCellReference

Cognex.InSight.Analysis.CvsCellReferenceInfo

Cognex.InSight.Analysis.CvsCellReferenceTable

Cognex.InSight.Analysis.CvsJobAnalyzer

Cognex.InSight.Cell.CvsCellEditMultiGraphics

Cognex.InSight.CvsEasyView

Cognex.InSight.CvsEasyViewItem

Cognex.InSight.CvsModbusSettings

Cognex.InSight.CvsSymbolicTag

Cognex.InSight.CvsSymbolicTagCollection

Cognex.InSight.Graphic.CvsGraphicFilledBox

Added Events

Cognex.InSight.Analysis.CvsJobAnalyzer.Invalidated

Added Namespaces

Cognex.InSight.Analysis

Added Enumerations

Cognex.InSight.Cell.CvsCellProperty

Cognex.InSight.CvsEasyViewItemType

Added Enumeration Values

Cognex.InSight.Cell.CvsCellProperty.None

Cognex.InSight.Cell.CvsCellProperty.EditPassword

Cognex.InSight.Cell.CvsCellProperty.AllPropertiesMask

Cognex.InSight.CvsEasyViewItemType.Standard

Cognex.InSight.CvsEasyViewItemType.Label

Cognex.InSight.Sensor.CvsHostSubtype.InSightAdvantageEngineSeries

Cognex.InSight.Sensor.CvsHostSubtype.InSightMicro1000LR

Cognex.InSight.Sensor.CvsHostSubtype.VisionViewVGA

Cognex.InSight.Sensor.CvsHostSubtype.VisionViewPC

Cognex.InSight.Sensor.CvsHostSubtype.VisionView700A

Cognex.InSight.Sensor.CvsHostSubtype.VisionViewCE

Cognex.InSight.Sensor.CvsOutputType.Waveform

Cognex.InSight.Sensor.CvsProtocolServices.PTP

Cognex.InSight.Sensor.CvsProtocolServices.MCProtocolScanner

Added Custom Attributes

M:Cognex.InSight.Analysis.CvsCellReferenceInfo.ToString(System.Boolean expandNames) - [ComVisible((Boolean)False)]

P:Cognex.InSight.Graphic.CvsGraphicFilledBox.LabelBackColor { get; } - [ComVisible((Boolean)False)]

P:Cognex.InSight.Graphic.CvsGraphicFilledBox.LabelForeColor { get; } - [ComVisible((Boolean)False)]

Enum:Cognex.InSight.Cell.CvsCellProperty - [Serializable]

Enum:Cognex.InSight.Cell.CvsCellProperty - [Flags]

Enum:Cognex.InSight.CvsEasyViewItemType - [Serializable]

F:Cognex.InSight.Sensor.CvsUserCollection.MaxUserListLength - [Obsolete("Use Cognex.InSight.Sensor.CvsSensor.MaxUserListLength instead.")]

T:Cognex.InSight.Analysis.CvsCellReferenceTable - [DefaultMember("Item")]

T:Cognex.InSight.Cell.CvsCellEditMultiGraphics - [Serializable]

T:Cognex.InSight.Cell.CvsCellEditMultiGraphics - [Guid("34BA2B02-CE54-439f-A87E-4061975344FE")]

T:Cognex.InSight.CvsEasyView - [Serializable]

T:Cognex.InSight.CvsEasyView - [Guid("495CB1A3-3E0D-4061-B36B-64DAC5C5E0D6")]

T:Cognex.InSight.CvsEasyView - [DefaultMember("Item")]

T:Cognex.InSight.CvsEasyViewItem - [Serializable]

T:Cognex.InSight.CvsEasyViewItem - [Guid("4353ED7F-86F0-4e4e-A940-93981E8EEF52")]

T:Cognex.InSight.CvsModbusSettings - [Serializable]

T:Cognex.InSight.CvsModbusSettings - [Guid("93452607-1CDA-469a-89AC-3687603D3500")]

T:Cognex.InSight.CvsSymbolicTag - [Serializable]

T:Cognex.InSight.CvsSymbolicTag - [Guid("D6314073-2EE1-408e-8A04-0CDFAD65C6AD")]

T:Cognex.InSight.CvsSymbolicTagCollection - [Serializable]

T:Cognex.InSight.CvsSymbolicTagCollection - [Guid("7CC7C958-89B4-4375-A862-C10418297999")]

T:Cognex.InSight.CvsSymbolicTagCollection - [Diagnostics.DebuggerStepThrough]

T:Cognex.InSight.CvsSymbolicTagCollection - [DefaultMember("Item")]

T:Cognex.InSight.Graphic.CvsGraphicFilledBox - [Serializable]

T:Cognex.InSight.Graphic.CvsGraphicFilledBox - [Guid("3D3D9A24-09D7-4b69-8CDB-645389F7CAF6")]

Copyright (c) 2004-2014 Cognex Corporation.


4.5.0 to 4.6.0

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (4.5.474.0 to 4.6.226.0)

Removed Constructors

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController..ctor(Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView view, Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView setupView, Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView poseView, Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView resultsView)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog..ctor()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError..ctor(System.Drawing.Rectangle location, System.Windows.Forms.Control ctrl)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList..ctor()

Cognex.InSight.Controls.Display.CvsFilmstrip..ctor()

Cognex.InSight.Controls.Display.CvsFilmstripPlayback..ctor(Cognex.InSight.Controls.Display.CvsFilmstrip _filmstrip)

Cognex.InSight.Controls.Display.CvsFilmstripPlayback..ctor()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue..ctor(Cognex.InSight.Controls.Display.CvsFilmstrip _filmstrip)

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue..ctor()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions..ctor()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings..ctor()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings..ctor(Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings other)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings..ctor()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl..ctor()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController..ctor(Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView view)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsDialog..ctor()

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock..ctor(Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlockName name)

Cognex.InSight.Controls.Display.Protocols.MelsecDevice..ctor()

Cognex.InSight.Controls.Display.Protocols.MelsecDevice..ctor(Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType type)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettings..ctor()

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl..ctor()

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController..ctor(Cognex.InSight.Controls.Display.Protocols.IProfinetSettingsView view)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog..ctor()

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString..ctor()

Cognex.InSight.Controls.Display.PtpTimeSyncDialog..ctor(Cognex.InSight.Controls.Display.Internal.PtpTimeSyncController controller)

Added Constructors

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController..ctor(Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridDialogView view, Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView setupView, Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPoseView poseView, Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridResultsView resultsView)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridDialog..ctor()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError..ctor(System.Drawing.Rectangle location, System.Windows.Forms.Control ctrl)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList..ctor()

Cognex.InSight.Controls.Display.Network.CvsIPsecHelper..ctor()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings..ctor(Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings other)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings..ctor()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl..ctor()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController..ctor(Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView view)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsDialog..ctor()

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock..ctor(Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlockName name)

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice..ctor()

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice..ctor(Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType type)

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettings..ctor()

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsControl..ctor()

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsController..ctor(Cognex.InSight.Controls.Display.Protocols.IProfinetSettingsView view)

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsDialog..ctor()

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString..ctor()

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip..ctor()

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback..ctor(Cognex.InSight.Controls.Filmstrip.CvsFilmstrip _filmstrip)

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback..ctor()

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue..ctor(Cognex.InSight.Controls.Filmstrip.CvsFilmstrip _filmstrip)

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue..ctor()

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions..ctor()

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings..ctor()

Removed Methods

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.Calibrate()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.ClearAll()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.Dispose()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.Initialize(Cognex.InSight.CvsCellLocation currentCell, string expr, System.Boolean inDialog, string sensorName)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.OnClosing(System.Windows.Forms.DialogResult dialogResult)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.PoseStepSelected(int poseIndex)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.ResultsStepSelected()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.SetupStepSelected()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.Initialize(Cognex.InSight.CvsCellLocation currentCell, string expr, System.Boolean inDialog, string sensorName, System.Collections.Hashtable options)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.OnClosed(System.EventArgs e)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.OnClosing(System.ComponentModel.CancelEventArgs e)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Dispose()

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.SelectFeature(Cognex.InSight.CvsImageLocation location, int touchDistance)

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.ShowAxes(int originIndex, int xAxisIndex, int yAxisIndex)

Cognex.InSight.Controls.Display.CvsFilmstrip.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.CvsFilmstrip.OnResize(System.EventArgs e)

Cognex.InSight.Controls.Display.CvsFilmstrip.PreProcessMessage(ref System.Windows.Forms.Message& msg)

Cognex.InSight.Controls.Display.CvsFilmstrip.UpdateStatus()

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Connect()

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Disconnect()

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Dispose()

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.ProcessShortcutKeys(System.Windows.Forms.KeyEventArgs e)

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.RequestThumbnailImagesUpdate()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Connect()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Disconnect()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Dispose()

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.ProcessShortcutKeys(System.Windows.Forms.KeyEventArgs e)

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.RequestThumbnailImagesUpdate()

Cognex.InSight.Controls.Display.ICvsFilmQueue.RequestThumbnailImagesUpdate()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.Equals(object obj)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.GetHashCode()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Commit()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.SetBusyEnables(System.Boolean enabled)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.UpdateConnectionStatus(string p)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.UpdateEnables(System.Boolean offline, System.Boolean validIp)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.Disconnect()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.GetSettings(Cognex.InSight.CvsInSight insight, Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings settings)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.MCProtocolScannerEnabled(Cognex.InSight.CvsInSight inSight)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.OnCommit(System.Boolean writeResult)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.OnIPAddressChanged()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.OnIPAddressLeave()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.OnPortChanged()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.OnPortKeyPress(System.Windows.Forms.KeyPressEventArgs e)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.Reset()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.SetSettings(Cognex.InSight.CvsInSight insight, Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings settings, System.Boolean writeResults)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.TryConnect()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.UpdateConnectToRemoteStation()

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsDialog.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsDialog.OnClosing(System.ComponentModel.CancelEventArgs e)

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.ToString()

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl.UpdateControl()

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.GetSettings(Cognex.InSight.CvsInSight inSight)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.SetSettings(Cognex.InSight.CvsInSight inSight, Cognex.InSight.Controls.Display.Protocols.ProfinetSettings settings)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.ValidateStationName(string stationName)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog.OnClosing(System.ComponentModel.CancelEventArgs e)

Cognex.InSight.Controls.Display.PtpTimeSyncDialog.Dispose(System.Boolean disposing)

Added Methods

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController.Calibrate()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController.ClearAll()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController.Dispose()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController.Initialize(Cognex.InSight.CvsCellLocation currentCell, string expr, System.Boolean inDialog, string sensorName)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController.OnClosing(System.Windows.Forms.DialogResult dialogResult)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController.PoseStepSelected(int poseIndex)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController.ResultsStepSelected()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController.SetupStepSelected()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridDialog.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridDialog.Initialize(Cognex.InSight.CvsCellLocation currentCell, string expr, System.Boolean inDialog, string sensorName, System.Collections.Hashtable options)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridDialog.OnClosed(System.EventArgs e)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridDialog.OnClosing(System.ComponentModel.CancelEventArgs e)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.Dispose()

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.SelectFeature(Cognex.InSight.CvsImageLocation location, int touchDistance)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.ShowAxes(int originIndex, int xAxisIndex, int yAxisIndex)

Cognex.InSight.Controls.Display.Network.CvsIPsecHelper.ExportWindowsIPsec(string filename)

Cognex.InSight.Controls.Display.Network.CvsIPsecHelper.ImportWindowsIPsec(string filename)

Cognex.InSight.Controls.Display.Network.CvsIPsecHelper.IsIPsecConnection()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.Equals(object obj)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.GetHashCode()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Commit()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.SetBusyEnables(System.Boolean enabled)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.UpdateConnectionStatus(string p)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.UpdateEnables(System.Boolean offline, System.Boolean validIp)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.Disconnect()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.GetSettings(Cognex.InSight.CvsInSight insight, Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings settings)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.MCProtocolScannerEnabled(Cognex.InSight.CvsInSight inSight)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.OnCommit(System.Boolean writeResult)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.OnIPAddressChanged()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.OnIPAddressLeave()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.OnPortChanged()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.OnPortKeyPress(System.Windows.Forms.KeyPressEventArgs e)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.Reset()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.SetSettings(Cognex.InSight.CvsInSight insight, Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings settings, System.Boolean writeResults)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.TryConnect()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.UpdateConnectToRemoteStation()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsDialog.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsDialog.OnClosing(System.ComponentModel.CancelEventArgs e)

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.ToString()

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsControl.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsControl.UpdateControl()

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsController.GetSettings(Cognex.InSight.CvsInSight inSight)

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsController.SetSettings(Cognex.InSight.CvsInSight inSight, Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettings settings)

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsController.ValidateStationName(string stationName)

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsDialog.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsDialog.OnClosing(System.ComponentModel.CancelEventArgs e)

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.OnResize(System.EventArgs e)

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.PreProcessMessage(ref System.Windows.Forms.Message& msg)

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.UpdateStatus()

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.Connect()

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.Disconnect()

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.Dispose()

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.ProcessShortcutKeys(System.Windows.Forms.KeyEventArgs e)

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.RequestThumbnailImagesUpdate(int index, int count)

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.Connect()

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.Disconnect()

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.Dispose()

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.ProcessShortcutKeys(System.Windows.Forms.KeyEventArgs e)

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.RequestThumbnailImagesUpdate(int index, int count)

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.RequestThumbnailImagesUpdate(int index, int count)

Cognex.InSight.Controls.Filmstrip.ICvsFilmstripImage.ToBitmap()

Removed Property Setters

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.Display { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.InSight { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.Display { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.InSight { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.AverageError { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.BackColor { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.GraphCtrl { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Height { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Width { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.X { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Y { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Angle { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.CalibratedLabel { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Display { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.FeatureRegion { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Features { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.SelectedIndex { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.FilmQueue { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.FirstThumbnailIndex { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.HeightScale { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.LedStyle { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.SelectedIndex { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.ShowSummary { set; }

Cognex.InSight.Controls.Display.CvsFilmstrip.ShowThumbnailImage { set; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Enabled { set; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Filmstrip { set; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Recorder { set; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectedIndex { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Enabled { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Filmstrip { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.InSight { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Options { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectedIndex { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.DisplayAction { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.LedStyle { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.PauseDelay { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.SavePath { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.ShowFilmstrip { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.UseSystemColors { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.ClearOnline { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.Mode { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.QueueSize { set; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.Type { set; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.Enabled { set; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.Filmstrip { set; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectedIndex { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DefaultGateway { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DefaultGatewayErrorInfo { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DhcpChecked { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DhcpTimeout { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DnsServer { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DnsServerErrorInfo { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DomainName { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DomainNameErrorInfo { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.HostName { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.HostNameErrorInfo { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.IPAddress { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.IPAddressErrorInfo { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.OKEnabled { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.StaticIpFieldsEnabled { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.SubnetMask { set; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.SubnetMaskErrorInfo { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandLength { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandResultAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandResultLength { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.ControlAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.DestinationModule { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.HostPort { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.InputAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.InputLength { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.IpAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.NetworkNumber { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.OutputAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.OutputLength { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.PCNumber { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.PollInterval { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.StatusAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.Timeout { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.ConnectToRemoteStation { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.DestinationModule { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.IPAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.NetworkNumber { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PCNumber { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PollInterval { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Port { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Timeout { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsDialog.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsDialog.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.FullAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.Length { set; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.Offset { set; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.SelectedDevice { set; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Address { set; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.FullAddress { set; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Type { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettings.StationName { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettings.StationNameEnabled { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl.StationName { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl.StationNameEnabled { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog.Settings { set; }

Added Property Setters

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController.Display { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController.InSight { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridDialog.Display { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridDialog.InSight { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.AverageError { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.BackColor { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.GraphCtrl { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.Height { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.Width { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.X { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.Y { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.Angle { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.CalibratedLabel { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.Display { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.FeatureRegion { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.Features { set; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.SelectedIndex { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowEntireSheet { set; }

Cognex.InSight.Controls.Display.Network.CvsIPsecHelper.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.CommandAddress { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.CommandLength { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.CommandResultAddress { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.CommandResultLength { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.ControlAddress { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.DestinationModule { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.HostPort { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.InputAddress { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.InputLength { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.IpAddress { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.NetworkNumber { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.OutputAddress { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.OutputLength { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.PCNumber { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.PollInterval { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.StatusAddress { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.Timeout { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ConnectToRemoteStation { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.DestinationModule { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.IPAddress { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.NetworkNumber { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.PCNumber { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.PollInterval { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Port { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Timeout { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsDialog.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsDialog.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.FullAddress { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.Length { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.Offset { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.SelectedDevice { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.Address { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.FullAddress { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.Type { set; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettings.StationName { set; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettings.StationNameEnabled { set; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsControl.StationName { set; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsControl.StationNameEnabled { set; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsController.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsController.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsDialog.InSight { set; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsDialog.Settings { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.FilmQueue { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.FirstThumbnailIndex { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.HeightScale { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.SelectedIndex { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.ShowSummary { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.ShowThumbnailImage { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.StatusLevelStyle { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.Enabled { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.Filmstrip { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.Recorder { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectedIndex { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.Enabled { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.Filmstrip { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.InSight { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.Options { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectedIndex { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.DisplayAction { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.LedStyle { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.PauseDelay { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.SavePath { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.ShowFilmstrip { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.UseSystemColors { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.ClearOnline { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.Mode { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.QueueSize { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.Type { set; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.Enabled { set; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.Filmstrip { set; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.SelectedIndex { set; }

Removed Property Getters

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.Display { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController.InSight { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.Display { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog.InSight { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.AverageError { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.BackColor { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.GraphCtrl { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Height { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Width { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.X { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError.Y { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Angle { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.CalibratedLabel { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Display { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.FeatureRegion { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Features { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.SelectedIndex { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.FilmQueue { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.FirstThumbnailIndex { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.HeightScale { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.LedStyle { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.MaxThumbnailsDisplayed { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.SelectedIndex { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.ShowSummary { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.ShowThumbnailImage { get; }

Cognex.InSight.Controls.Display.CvsFilmstrip.ThumbnailsDisplayed { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.ClearQueue { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.DeleteSelectedItem { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Enabled { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Filmstrip { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Play { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.QueueSize { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.Recorder { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.ResultsStatus { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SaveQueue { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectedIndex { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectFirst { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectLast { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectNext { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectNextPage { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectPrevious { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectPrevPage { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SupportsEdit { get; }

Cognex.InSight.Controls.Display.CvsFilmstripPlayback.ThumbnailImages { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.ClearQueue { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.DeleteSelectedItem { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Enabled { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Filmstrip { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.FreezeQueue { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.InSight { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.IsFrozen { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Options { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.QueueSize { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.ResultsStatus { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SaveQueue { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectedIndex { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectFirst { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectLast { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectNext { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectNextPage { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectPrevious { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectPrevPage { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.Settings { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SupportsEdit { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.ThumbnailImages { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.DisplayAction { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.LedStyle { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.PauseDelay { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.SavePath { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.ShowFilmstrip { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.UseSystemColors { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.ClearOnline { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.Mode { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.QueueSize { get; }

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.Type { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.ClearQueue { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.DeleteSelectedItem { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.Enabled { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.Filmstrip { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.QueueSize { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.ResultsStatus { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SaveQueue { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectedIndex { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectFirst { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectLast { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectNext { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectNextPage { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectPrevious { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SelectPrevPage { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.SupportsEdit { get; }

Cognex.InSight.Controls.Display.ICvsFilmQueue.ThumbnailImages { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DefaultGateway { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DefaultGatewayErrorInfo { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DhcpChecked { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DhcpTimeout { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DnsServer { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DnsServerErrorInfo { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DomainName { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.DomainNameErrorInfo { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.HostName { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.HostNameErrorInfo { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.IPAddress { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.IPAddressErrorInfo { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.StaticIpFieldsEnabled { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.SubnetMask { get; }

Cognex.InSight.Controls.Display.IIoModuleConfigureNetworkView.SubnetMaskErrorInfo { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandLength { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandResultAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandResultLength { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.ControlAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.DestinationModule { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.HostPort { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.InputAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.InputLength { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.IpAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.NetworkNumber { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.OutputAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.OutputLength { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.PCNumber { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.PollInterval { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.StatusAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.Timeout { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.ConnectToRemoteStation { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.DestinationModule { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Dirty { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.IPAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.NetworkNumber { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PCNumber { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PollInterval { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Port { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Timeout { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.ConnectionStatusCode { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.ConnectionStatusString { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.Dirty { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.IPAddressErrorMessage { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.PortErrorMessage { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.ProtocolEnabled { get; }

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.Description { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.FullAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.Length { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.Name { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.Offset { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.SelectedDevice { get; }

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock.SupportedDeviceTypes { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Address { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.AddressError { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.AddressInt { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Code { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Format { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.FullAddress { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.FullName { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Name { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Type { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.Units { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.UnitsString { get; }

Cognex.InSight.Controls.Display.Protocols.MelsecDevice.ValidAddress { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettings.StationName { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettings.StationNameEnabled { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl.StationName { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl.StationNameEnabled { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog.Settings { get; }

Added Property Getters

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController.Display { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController.InSight { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridDialog.Display { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridDialog.InSight { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.AverageError { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.BackColor { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.GraphCtrl { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.Height { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.Width { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.X { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError.Y { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.Angle { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.CalibratedLabel { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.Display { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.FeatureRegion { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.Features { get; }

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.SelectedIndex { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowEntireSheet { get; }

Cognex.InSight.Controls.Display.ICvsInSightDisplayEditForm.AllowShowGrid { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.CommandAddress { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.CommandLength { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.CommandResultAddress { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.CommandResultLength { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.ControlAddress { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.DestinationModule { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.HostPort { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.InputAddress { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.InputLength { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.IpAddress { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.NetworkNumber { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.OutputAddress { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.OutputLength { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.PCNumber { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.PollInterval { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.StatusAddress { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.Timeout { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ConnectToRemoteStation { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.DestinationModule { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Dirty { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.IPAddress { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.NetworkNumber { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.PCNumber { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.PollInterval { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Port { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Timeout { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.ConnectionStatusCode { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.ConnectionStatusString { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.Dirty { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.IPAddressErrorMessage { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.PortErrorMessage { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.ProtocolEnabled { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.Description { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.FullAddress { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.Length { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.Name { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.Offset { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.SelectedDevice { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.SupportedDeviceTypes { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.Address { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.AddressError { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.AddressInt { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.Code { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.Format { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.FullAddress { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.FullName { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.Name { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.Type { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.Units { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.UnitsString { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.ValidAddress { get; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettings.StationName { get; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettings.StationNameEnabled { get; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsControl.StationName { get; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsControl.StationNameEnabled { get; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsController.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsController.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsDialog.InSight { get; }

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsDialog.Settings { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.FilmQueue { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.FirstThumbnailIndex { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.HeightScale { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.MaxThumbnailsDisplayed { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.SelectedIndex { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.ShowSummary { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.ShowThumbnailImage { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.StatusLevelStyle { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.ThumbnailsDisplayed { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.ClearQueue { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.DeleteSelectedItem { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.Enabled { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.Filmstrip { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.Play { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.QueueSize { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.Recorder { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.ResultsStatus { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SaveQueue { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectedIndex { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectFirst { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectLast { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectNext { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectNextPage { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectPrevious { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectPrevPage { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SupportsEdit { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.ThumbnailImages { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.ClearQueue { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.DeleteSelectedItem { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.Enabled { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.Filmstrip { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.FreezeQueue { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.InSight { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.IsFrozen { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.Options { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.QueueSize { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.ResultsStatus { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SaveQueue { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectedIndex { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectFirst { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectLast { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectNext { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectNextPage { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectPrevious { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectPrevPage { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.Settings { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SupportsEdit { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.ThumbnailImages { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.DisplayAction { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.LedStyle { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.PauseDelay { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.SavePath { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.ShowFilmstrip { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.UseSystemColors { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.ClearOnline { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.Mode { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.QueueSize { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.Type { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.ClearQueue { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.DeleteSelectedItem { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.Enabled { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.Filmstrip { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.QueueSize { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.ResultsStatus { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.SaveQueue { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.SelectedIndex { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.SelectFirst { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.SelectLast { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.SelectNext { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.SelectNextPage { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.SelectPrevious { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.SelectPrevPage { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.SupportsEdit { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue.ThumbnailImages { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmstripImage.Bounds { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmstripImage.Height { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmstripImage.PixelFormat { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmstripImage.Size { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmstripImage.Width { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmstripResultStatus.SequenceNumber { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmstripResultStatus.StatusLevel { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmstripResultStatus.StatusMessage { get; }

Cognex.InSight.Controls.Filmstrip.ICvsFilmstripResultStatus.Timestamp { get; }

Removed Classes

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridController

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridDialog

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrateGridError

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList

Cognex.InSight.Controls.Display.CvsFilmstrip

Cognex.InSight.Controls.Display.CvsFilmstripPlayback

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsController

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsDialog

Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlock

Cognex.InSight.Controls.Display.Protocols.MelsecDevice

Cognex.InSight.Controls.Display.Protocols.ProfinetSettings

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsController

Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsDialog

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString

Cognex.InSight.Controls.Display.PtpTimeSyncDialog

Added Classes

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridDialog

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridError

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList

Cognex.InSight.Controls.Display.Network.CvsIPsecHelper

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsDialog

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettings

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsControl

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsController

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsDialog

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings

Removed Events

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.Changed

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueSettings.Changed

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Committing

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.EnableChanged

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Reset

Added Events

Cognex.InSight.Controls.Display.Network.AddEditIPsecRuleControl.DataValidChange

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Committing

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.EnableChanged

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Reset

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.Changed

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.Changed

Removed Interfaces

Cognex.InSight.Controls.Display.ICvsFilmQueue

Added Interfaces

Cognex.InSight.Controls.Display.ICvsInSightDisplayEditForm

Cognex.InSight.Controls.Display.Network.IIPsecRuleControlView

Cognex.InSight.Controls.Display.Network.IIPsecRuleListControlView

Cognex.InSight.Controls.Filmstrip.ICvsFilmQueue

Cognex.InSight.Controls.Filmstrip.ICvsFilmstripImage

Cognex.InSight.Controls.Filmstrip.ICvsFilmstripResultStatus

Added Namespaces

Cognex.InSight.Controls.Display.Network

Cognex.InSight.Controls.Display.UIA

Cognex.InSight.Controls.Filmstrip

Removed Enumerations

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationState

Cognex.InSight.Controls.Display.CvsFilmstripHeightScale

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueMode

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueType

Cognex.InSight.Controls.Display.CvsResultsQueueDisplayAction

Cognex.InSight.Controls.Display.CvsStatusLevelStyle

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType

Cognex.InSight.Controls.Display.Protocols.MelsecAddressUnits

Cognex.InSight.Controls.Display.Protocols.MelsecDataFormat

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode

Added Enumerations

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationState

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerDestinationModuleType

Cognex.InSight.Controls.Display.Protocols.CvsMelsecAddressUnits

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDataFormat

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueMode

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueType

Cognex.InSight.Controls.Filmstrip.CvsFilmstripScale

Cognex.InSight.Controls.Filmstrip.CvsResultsQueueDisplayAction

Cognex.InSight.Controls.Filmstrip.CvsStatusLevelStyle

Removed Enumeration Values

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationState.SetupView

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationState.PoseView

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationState.ResultsView

Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationState.PrintView

Cognex.InSight.Controls.Display.CvsFilmstripHeightScale.Quarter

Cognex.InSight.Controls.Display.CvsFilmstripHeightScale.Half

Cognex.InSight.Controls.Display.CvsFilmstripHeightScale.One

Cognex.InSight.Controls.Display.CvsFilmstripHeightScale.Two

Cognex.InSight.Controls.Display.CvsFilmstripHeightScale.Four

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueMode.None

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueMode.OnlyFail

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueMode.All

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueMode.OnlyPass

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueType.Last

Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueType.First

Cognex.InSight.Controls.Display.CvsResultsQueueDisplayAction.Freeze

Cognex.InSight.Controls.Display.CvsResultsQueueDisplayAction.Pause

Cognex.InSight.Controls.Display.CvsResultsQueueDisplayAction.Nothing

Cognex.InSight.Controls.Display.CvsStatusLevelStyle.Geometric

Cognex.InSight.Controls.Display.CvsStatusLevelStyle.OKorNG

Cognex.InSight.Controls.Display.CvsStatusLevelStyle.Check

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.LocalStation

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.ControlSystemCPU

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.StandbySystemCPU

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.SystemACPU

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.SystemBCPU

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.CPU1

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.CPU2

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.CPU3

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDestinationModuleType.CPU4

Cognex.InSight.Controls.Display.Protocols.MelsecAddressUnits.Hex

Cognex.InSight.Controls.Display.Protocols.MelsecAddressUnits.Decimal

Cognex.InSight.Controls.Display.Protocols.MelsecAddressUnits.None

Cognex.InSight.Controls.Display.Protocols.MelsecAddressUnits.Unknown

Cognex.InSight.Controls.Display.Protocols.MelsecDataFormat.Bit

Cognex.InSight.Controls.Display.Protocols.MelsecDataFormat.Word

Cognex.InSight.Controls.Display.Protocols.MelsecDataFormat.None

Cognex.InSight.Controls.Display.Protocols.MelsecDataFormat.Unknown

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.None

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.InputRelay

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.OutputRelay

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.InternalRelay

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.LatchRelay

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.Annunciator

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.LinkRelay

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.DataRegister

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.LinkRegister

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.FileBlockRegister

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.FileRegister

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.TimerValue

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.CounterValue

Cognex.InSight.Controls.Display.Protocols.MelsecDeviceType.Unknown

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.IncompatibleInputArgument

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.InvalidUserDataBuffer

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.ConnectionTimeout

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.ProtocolNotStarted

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.UnknownProtocolFault

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.ProtocolConnectionIdle

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.ProtocolConnectionDropped

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.ProtocolConnectionAttemptFailed

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.CIOMicroNotConnected

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.CCLinkNotConfigured

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.CCLinkDown

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerStatusSendingError

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerControlReadingError

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerOutputSendingError

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerInputReadingError

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerCommandReadingError

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerCommandResultSendingError

Cognex.InSight.Controls.Display.Protocols.ProtocolErrorCodeString+ProtocolErrorCode.MCScannerPollRateTooLow

Added Enumeration Values

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationState.SetupView

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationState.PoseView

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationState.ResultsView

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationState.PrintView

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerDestinationModuleType.LocalStation

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerDestinationModuleType.ControlSystemCPU

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerDestinationModuleType.StandbySystemCPU

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerDestinationModuleType.SystemACPU

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerDestinationModuleType.SystemBCPU

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerDestinationModuleType.CPU1

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerDestinationModuleType.CPU2

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerDestinationModuleType.CPU3

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerDestinationModuleType.CPU4

Cognex.InSight.Controls.Display.Protocols.CvsMelsecAddressUnits.Hex

Cognex.InSight.Controls.Display.Protocols.CvsMelsecAddressUnits.Decimal

Cognex.InSight.Controls.Display.Protocols.CvsMelsecAddressUnits.None

Cognex.InSight.Controls.Display.Protocols.CvsMelsecAddressUnits.Unknown

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDataFormat.Bit

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDataFormat.Word

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDataFormat.None

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDataFormat.Unknown

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.None

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.InputRelay

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.OutputRelay

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.InternalRelay

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.LatchRelay

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.Annunciator

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.LinkRelay

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.DataRegister

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.LinkRegister

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.FileBlockRegister

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.FileRegister

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.TimerValue

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.CounterValue

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.Unknown

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.IncompatibleInputArgument

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.InvalidUserDataBuffer

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.ConnectionTimeout

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.ProtocolNotStarted

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.UnknownProtocolFault

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.ProtocolConnectionIdle

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.ProtocolConnectionDropped

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.ProtocolConnectionAttemptFailed

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.CIOMicroNotConnected

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.CCLinkNotConfigured

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.CCLinkDown

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.MCScannerStatusSendingError

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.MCScannerControlReadingError

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.MCScannerOutputSendingError

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.MCScannerInputReadingError

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.MCScannerCommandReadingError

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.MCScannerCommandResultSendingError

Cognex.InSight.Controls.Display.Protocols.CvsProtocolErrorCodeString+CvsProtocolErrorCode.MCScannerPollRateTooLow

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueMode.None

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueMode.OnlyFail

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueMode.All

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueMode.OnlyPass

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueType.Last

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueType.First

Cognex.InSight.Controls.Filmstrip.CvsFilmstripScale.Quarter

Cognex.InSight.Controls.Filmstrip.CvsFilmstripScale.Half

Cognex.InSight.Controls.Filmstrip.CvsFilmstripScale.One

Cognex.InSight.Controls.Filmstrip.CvsFilmstripScale.Two

Cognex.InSight.Controls.Filmstrip.CvsFilmstripScale.Four

Cognex.InSight.Controls.Filmstrip.CvsResultsQueueDisplayAction.Freeze

Cognex.InSight.Controls.Filmstrip.CvsResultsQueueDisplayAction.Pause

Cognex.InSight.Controls.Filmstrip.CvsResultsQueueDisplayAction.Nothing

Cognex.InSight.Controls.Filmstrip.CvsStatusLevelStyle.Geometric

Cognex.InSight.Controls.Filmstrip.CvsStatusLevelStyle.OKorNG

Cognex.InSight.Controls.Filmstrip.CvsStatusLevelStyle.Check

Removed Custom Attributes

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Angle { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Angle { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.CalibratedLabel { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.CalibratedLabel { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Display { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Display { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.FeatureRegion { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.FeatureRegion { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Features { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList.Features { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.FilmQueue { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.FirstThumbnailIndex { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.HeightScale { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.MaxThumbnailsDisplayed { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.SelectedIndex { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.ShowSummary { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstrip.ThumbnailsDisplayed { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectFirst { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)36)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectFirst { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131144)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectLast { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131141)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectLast { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)35)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectNext { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)34)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectNext { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131150)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectNextPage { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)34)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectPrevious { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131152)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectPrevious { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)8)]

P:Cognex.InSight.Controls.Display.CvsFilmstripPlayback.SelectPrevPage { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)33)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.ClearQueue { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)12)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.ClearQueue { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131139)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.DeleteSelectedItem { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131140)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.DeleteSelectedItem { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)46)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.FreezeQueue { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131142)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.InSight { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.InSight { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.IsFrozen { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SaveQueue { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131155)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectFirst { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131144)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectFirst { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)36)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectLast { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)35)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectLast { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131141)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectNext { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131150)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectNext { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)34)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectNextPage { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)34)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectPrevious { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)8)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectPrevious { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131138)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue.SelectPrevPage { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)33)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.DisplayAction { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.DisplayAction { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.LedStyle { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.LedStyle { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.PauseDelay { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.PauseDelay { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.SavePath { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.SavePath { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.ShowFilmstrip { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.ShowFilmstrip { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.UseSystemColors { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueueOptions.UseSystemColors { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.Redo { get; } - [Cognex.InSight.Controls.CvsIcon((Int32)25, (Int32)24, "Icons.ISEBase_16x16_high.png", "Icons.ISEBase_32x32_high.png", "Icons.ISEBase_16x16_low.bmp", "Icons.ISEBase_32x32_low.bmp")]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.SoftOnline { get; } - [Cognex.InSight.Controls.CvsIcon((Int32)1, (Int32)0, "Icons.ISESystem_16x16_high.png", "Icons.ISESystem_32x32_high.png", "Icons.ISESystem_16x16_low.bmp", "Icons.ISESystem_32x32_low.bmp")]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.Undo { get; } - [Cognex.InSight.Controls.CvsIcon((Int32)27, (Int32)26, "Icons.ISEBase_16x16_high.png", "Icons.ISEBase_32x32_high.png", "Icons.ISEBase_16x16_low.bmp", "Icons.ISEBase_32x32_low.bmp")]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandLength { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandResultAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.CommandResultLength { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.ControlAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.DestinationModule { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.HostPort { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.InputAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.InputLength { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.IpAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.NetworkNumber { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.OutputAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.OutputLength { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.PCNumber { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.PollInterval { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.StatusAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettings.Timeout { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.ConnectToRemoteStation { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.ConnectToRemoteStation { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.DestinationModule { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.DestinationModule { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.InSight { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.InSight { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.IPAddress { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.IPAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.NetworkNumber { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.NetworkNumber { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PCNumber { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PCNumber { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PollInterval { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.PollInterval { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Port { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Port { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Settings { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Settings { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Timeout { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl.Timeout { get; } - [ComponentModel.Browsable((Boolean)False)]

Enum:Cognex.InSight.Controls.Display.CvsFilmstripHeightScale - [ComVisible((Boolean)True)]

Enum:Cognex.InSight.Controls.Display.CvsStatusLevelStyle - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Display.CalibrateGrid.CalibrationDataList - [ComponentModel.ToolboxItem((Boolean)False)]

T:Cognex.InSight.Controls.Display.CvsFilmstrip - [Cognex.InSight.Internal.ComTypeFlags((ComTypes.TYPEFLAGS)528)]

T:Cognex.InSight.Controls.Display.CvsFilmstrip - [ComSourceInterfaces(typeof(Cognex.InSight.Controls.Display.Internal.ICvsFilmstripEvents))]

T:Cognex.InSight.Controls.Display.CvsFilmstrip - [Guid("019D7437-EF26-4bf8-BEDF-EB5A667B75F7")]

T:Cognex.InSight.Controls.Display.CvsFilmstrip - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Display.CvsFilmstrip - [ClassInterface((ClassInterfaceType)0)]

T:Cognex.InSight.Controls.Display.CvsFilmstripPlayback - [ClassInterface((ClassInterfaceType)2)]

T:Cognex.InSight.Controls.Display.CvsFilmstripPlayback - [ComSourceInterfaces("")]

T:Cognex.InSight.Controls.Display.CvsFilmstripPlayback - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue - [ClassInterface((ClassInterfaceType)2)]

T:Cognex.InSight.Controls.Display.CvsFilmstripResultsQueue - [ComSourceInterfaces("")]

T:Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerSettingsControl - [ComponentModel.ToolboxItem((Boolean)False)]

T:Cognex.InSight.Controls.Display.Protocols.ProfinetSettingsControl - [ComponentModel.ToolboxItem((Boolean)False)]

Added Custom Attributes

P:Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.Angle { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.Angle { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.CalibratedLabel { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.CalibratedLabel { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.Display { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.Display { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.FeatureRegion { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.FeatureRegion { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.Features { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.Features { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowEntireSheet { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.ShowEntireSheet { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.Redo { get; } - [Cognex.InSight.Controls.CvsIcon((Int32)25, (Int32)24, "Framework.Icons.ISEBase_16x16_high.png", "Framework.Icons.ISEBase_32x32_high.png", "Framework.Icons.ISEBase_16x16_low.bmp", "Framework.Icons.ISEBase_32x32_low.bmp")]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.SoftOnline { get; } - [Cognex.InSight.Controls.CvsIcon((Int32)1, (Int32)0, "Framework.Icons.ISESystem_16x16_high.png", "Framework.Icons.ISESystem_32x32_high.png", "Framework.Icons.ISESystem_16x16_low.bmp", "Framework.Icons.ISESystem_32x32_low.bmp")]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.Undo { get; } - [Cognex.InSight.Controls.CvsIcon((Int32)27, (Int32)26, "Framework.Icons.ISEBase_16x16_high.png", "Framework.Icons.ISEBase_32x32_high.png", "Framework.Icons.ISEBase_16x16_low.bmp", "Framework.Icons.ISEBase_32x32_low.bmp")]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.CommandAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.CommandLength { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.CommandResultAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.CommandResultLength { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.ControlAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.DestinationModule { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.HostPort { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.InputAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.InputLength { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.IpAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.NetworkNumber { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.OutputAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.OutputLength { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.PCNumber { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.PollInterval { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.StatusAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.Timeout { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ConnectToRemoteStation { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ConnectToRemoteStation { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.DestinationModule { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.DestinationModule { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.InSight { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.InSight { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.IPAddress { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.IPAddress { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.NetworkNumber { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.NetworkNumber { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.PCNumber { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.PCNumber { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.PollInterval { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.PollInterval { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Port { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Port { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Settings { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Settings { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Timeout { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Timeout { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.FilmQueue { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.FirstThumbnailIndex { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.HeightScale { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.MaxThumbnailsDisplayed { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.SelectedIndex { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.ShowSummary { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.ShowThumbnailImage { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.StatusLevelStyle { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.ThumbnailsDisplayed { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectFirst { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131144)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectFirst { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)36)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectLast { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)35)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectLast { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131141)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectNext { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)34)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectNext { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131150)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectNextPage { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)34)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectPrevious { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)8)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectPrevious { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131152)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.SelectPrevPage { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)33)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.ClearQueue { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)12)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.ClearQueue { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131139)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.DeleteSelectedItem { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)46)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.DeleteSelectedItem { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131140)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.FreezeQueue { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131142)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.InSight { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.InSight { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.IsFrozen { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SaveQueue { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131155)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectFirst { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131144)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectFirst { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)36)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectLast { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)35)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectLast { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131141)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectNext { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131150)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectNext { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)34)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectNextPage { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)34)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectPrevious { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)8)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectPrevious { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)131138)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.SelectPrevPage { get; } - [Cognex.InSight.Controls.CvsShortcut((Windows.Forms.Keys)33)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.DisplayAction { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.DisplayAction { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.LedStyle { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.LedStyle { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.PauseDelay { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.PauseDelay { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.SavePath { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.SavePath { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.ShowFilmstrip { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.ShowFilmstrip { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.UseSystemColors { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions.UseSystemColors { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

Enum:Cognex.InSight.Controls.Filmstrip.CvsFilmstripScale - [ComVisible((Boolean)True)]

Enum:Cognex.InSight.Controls.Filmstrip.CvsStatusLevelStyle - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList - [ComponentModel.ToolboxItem((Boolean)False)]

T:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl - [ComponentModel.ToolboxItem((Boolean)False)]

T:Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsControl - [ComponentModel.ToolboxItem((Boolean)False)]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip - [Cognex.InSight.Internal.ComTypeFlags((ComTypes.TYPEFLAGS)528)]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip - [ClassInterface((ClassInterfaceType)0)]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip - [ComSourceInterfaces(typeof(Cognex.InSight.Controls.Display.Internal.ICvsFilmstripEvents))]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip - [Guid("019D7437-EF26-4bf8-BEDF-EB5A667B75F7")]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstrip - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback - [ComSourceInterfaces("")]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback - [ClassInterface((ClassInterfaceType)2)]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue - [ComSourceInterfaces("")]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue - [ClassInterface((ClassInterfaceType)2)]

API Changes - Cognex.InSight.dll (4.5.474.0 to 4.6.226.0)

Removed Constructors

Cognex.InSight.Analysis.CvsCellReference..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsCellRange referencedRange, System.Boolean isCellStateReference)

Cognex.InSight.Analysis.CvsCellReferenceTable..ctor()

Cognex.InSight.Analysis.CvsJobAnalyzer..ctor()

Added Constructors

Cognex.InSight.Cell.CvsCellAuthorize..ctor(Cognex.InSight.Cell.CvsCellString cell)

Removed Methods

Cognex.InSight.Analysis.CvsCellReference.Equals(object obj)

Cognex.InSight.Analysis.CvsCellReference.GetHashCode()

Cognex.InSight.Analysis.CvsCellReferenceInfo.GetHashCode()

Cognex.InSight.Analysis.CvsCellReferenceInfo.ToString()

Cognex.InSight.Analysis.CvsCellReferenceInfo.ToString(System.Boolean expandNames)

Cognex.InSight.Analysis.CvsCellReferenceTable.GetCellSymbolicName(Cognex.InSight.CvsCellLocation location)

Cognex.InSight.Analysis.CvsCellReferenceTable.GetFirstErrorPrecedent(Cognex.InSight.CvsCellLocation location)

Cognex.InSight.Analysis.CvsCellReferenceTable.GetReferencePaths(Cognex.InSight.CvsCellLocation destination, Cognex.InSight.CvsCellLocation source)

Cognex.InSight.Analysis.CvsCellReferenceTable.GetText(System.IO.TextWriter tw, System.Boolean precedents, Cognex.InSight.CvsCellRange cellRange)

Cognex.InSight.Analysis.CvsCellReferenceTable.Update(Cognex.InSight.CvsResultSet resultSet, Cognex.InSight.CvsInSight inSight)

Cognex.InSight.Analysis.CvsJobAnalyzer.Dispose()

Cognex.InSight.Analysis.CvsJobAnalyzer.GetCellName(Cognex.InSight.CvsCellLocation location)

Cognex.InSight.Analysis.CvsJobAnalyzer.GetCellReferenceInfo(Cognex.InSight.CvsCellLocation location)

Cognex.InSight.Analysis.CvsJobAnalyzer.ReferenceConnected(Cognex.InSight.CvsCellLocation destination, Cognex.InSight.CvsCellLocation source)

Cognex.InSight.Analysis.CvsJobAnalyzer.Validate()

Cognex.InSight.Cell.CvsCellString.GetRawBytes()

Added Methods

Cognex.InSight.Cell.CvsCellEditPolygon.ReadPointList(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.CvsFeatureLicense.IsEmulatorPlaybackLicensed()

Cognex.InSight.CvsFeatureLicense.IssueUnlockChallenge()

Cognex.InSight.CvsFeatureLicense.Unlock(System.Byte[] response)

Cognex.InSight.CvsInSight.ClickSelect(Cognex.InSight.CvsCellLocation location)

Cognex.InSight.CvsInSight.ClickSelect(int row, int col)

Removed Property Setters

Cognex.InSight.Analysis.CvsJobAnalyzer.InSight { set; }

Removed Property Getters

Cognex.InSight.Analysis.CvsCellReference.CellLocation { get; }

Cognex.InSight.Analysis.CvsCellReference.ExpressionCellReference { get; }

Cognex.InSight.Analysis.CvsCellReference.IsCellStateReference { get; }

Cognex.InSight.Analysis.CvsCellReference.ReferencedRange { get; }

Cognex.InSight.Analysis.CvsCellReferenceInfo.CellTag { get; }

Cognex.InSight.Analysis.CvsCellReferenceInfo.Dependents { get; }

Cognex.InSight.Analysis.CvsCellReferenceInfo.Precedents { get; }

Cognex.InSight.Analysis.CvsCellReferenceInfo.SymbolicExpression { get; }

Cognex.InSight.Analysis.CvsCellReferenceTable.DialogCells { get; }

Cognex.InSight.Analysis.CvsCellReferenceTable.Item { get; }

Cognex.InSight.Analysis.CvsCellReferenceTable.ResultSet { get; }

Cognex.InSight.Analysis.CvsJobAnalyzer.HasChanged { get; }

Cognex.InSight.Analysis.CvsJobAnalyzer.HasNameListChanged { get; }

Cognex.InSight.Analysis.CvsJobAnalyzer.InSight { get; }

Cognex.InSight.Analysis.CvsJobAnalyzer.NameList { get; }

Cognex.InSight.Analysis.CvsJobAnalyzer.Results { get; }

Cognex.InSight.Cell.CvsCellString.AsciiText { get; }

Added Property Getters

Cognex.InSight.Cell.CvsCell.SupportsAuthorization { get; }

Cognex.InSight.Cell.CvsCellAuthorize.IsEditCell { get; }

Cognex.InSight.Cell.CvsCellEditFloat.SupportsAuthorization { get; }

Cognex.InSight.Cell.CvsCellEditInt.SupportsAuthorization { get; }

Cognex.InSight.Cell.CvsCellEditString.SupportsAuthorization { get; }

Removed Classes

Cognex.InSight.Analysis.CvsCellReference

Cognex.InSight.Analysis.CvsCellReferenceInfo

Cognex.InSight.Analysis.CvsCellReferenceTable

Cognex.InSight.Analysis.CvsJobAnalyzer

Added Classes

Cognex.InSight.Cell.CvsCellAuthorize

Cognex.InSight.CvsFeatureLicense

Removed Events

Cognex.InSight.Analysis.CvsJobAnalyzer.Invalidated

Removed Namespaces

Cognex.InSight.Analysis

Added Enumerations

Cognex.InSight.Sensor.CvsAuthenticationAlgorithms

Cognex.InSight.Sensor.CvsEncryptionAlgorithms

Cognex.InSight.Sensor.CvsProtocols

Added Enumeration Values

Cognex.InSight.Net.CvsSupportedFeatures.MasterSlave

Cognex.InSight.Sensor.CvsAuthenticationAlgorithms.None

Cognex.InSight.Sensor.CvsAuthenticationAlgorithms.MD5

Cognex.InSight.Sensor.CvsAuthenticationAlgorithms.SHA1

Cognex.InSight.Sensor.CvsEncryptionAlgorithms.None

Cognex.InSight.Sensor.CvsEncryptionAlgorithms.DES

Cognex.InSight.Sensor.CvsEncryptionAlgorithms.TripleDES

Cognex.InSight.Sensor.CvsEncryptionAlgorithms.AES

Cognex.InSight.Sensor.CvsEncryptionAlgorithms.Blowfish

Cognex.InSight.Sensor.CvsHostSubtype.InSightHummingBird

Cognex.InSight.Sensor.CvsProtocols.Any

Cognex.InSight.Sensor.CvsProtocols.TCP

Cognex.InSight.Sensor.CvsProtocols.UDP

Cognex.InSight.Sensor.CvsProtocols.None

Cognex.InSight.Sensor.CvsSupportedTools.SlaveOnly

Removed Custom Attributes

M:Cognex.InSight.Analysis.CvsCellReferenceInfo.ToString(System.Boolean expandNames) - [ComVisible((Boolean)False)]

T:Cognex.InSight.Analysis.CvsCellReferenceTable - [DefaultMember("Item")]

Added Custom Attributes

M:Cognex.InSight.CvsInSight.ClickSelect(Cognex.InSight.CvsCellLocation location) - [ComVisible((Boolean)False)]

M:Cognex.InSight.CvsUtility.CvsInSightSoftwareDevelopmentKitInitialize() - [Obsolete]

T:Cognex.InSight.Cell.CvsCellAuthorize - [Serializable]

T:Cognex.InSight.Cell.CvsCellAuthorize - [Guid("DE22BD88-C4DE-4700-959D-E2E6861EDF3A")]

Copyright (c) 2004-2014 Cognex Corporation.


4.6.0 to 4.7.0

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (4.6.226.0 to 4.7.130.0)

Removed Constructors

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock..ctor(Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlockName name)

Added Constructors

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock..ctor(Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerControllerType controllerType, Cognex.InSight.Controls.Display.Protocols.MCScannerDataBlockName name)

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice..ctor(Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerControllerType controllerType)

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice..ctor(Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerControllerType controllerType, Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType type)

Added Methods

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.Set(Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings other)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.GetControllerTypeString(Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerControllerType controllerType)

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.OnControllerTypeChanged()

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.GetUnitsString(Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerControllerType controllerType)

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.IsSupportedDevice(Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerControllerType controller, Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType device)

Cognex.InSight.Controls.Display.Protocols.IMessageBoxSource.ShowMessageBox(string text, string caption, System.Windows.Forms.MessageBoxButtons buttons, System.Windows.Forms.MessageBoxIcon icon)

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.ShowMessageBox(string text, string caption, System.Windows.Forms.MessageBoxButtons buttons, System.Windows.Forms.MessageBoxIcon icon)

Removed Property Setters

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.SelectedDevice { set; }

Added Property Setters

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.ControllerType { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ControllerType { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ControllerTypesEnabled { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.SelectedDeviceType { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.SelectedDeviceTypeString { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.AddressInt { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.ControllerType { set; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.ControllerType { set; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.ControllerTypesEnabled { set; }

Removed Property Getters

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.SelectedDevice { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.UnitsString { get; }

Added Property Getters

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditExternalLightSettings { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.ControllerType { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ControllerType { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ControllerTypesEnabled { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.DeviceFormat { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.DeviceUnits { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.MaxLength { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.SelectedDeviceType { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCScannerDataBlock.SelectedDeviceTypeString { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDevice.ControllerType { get; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.ControllerType { get; }

Cognex.InSight.Controls.Display.Protocols.IMCProtocolScannerSettingsView.ControllerTypesEnabled { get; }

Added Events

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ControllerTypeChanged

Added Interfaces

Cognex.InSight.Controls.Display.Protocols.IMessageBoxSource

Added Enumerations

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerControllerType

Added Enumeration Values

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerControllerType.Unknown

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerControllerType.QLSeries3EFrame

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerControllerType.FXSeries1EFrame

Cognex.InSight.Controls.Display.Protocols.CvsMelsecAddressUnits.Octal

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.ExtensionRegister

Cognex.InSight.Controls.Display.Protocols.CvsMelsecDeviceType.StateRelay

Added Custom Attributes

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditExternalLightSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettings.ControllerType { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ControllerType { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ControllerType { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ControllerTypesEnabled { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ControllerTypesEnabled { get; } - [ComponentModel.Browsable((Boolean)False)]

API Changes - Cognex.InSight.dll (4.6.226.0 to 4.7.130.0)

Added Constructors

Cognex.InSight.Sensor.CvsUser..ctor(string name, string password, Cognex.InSight.CvsInSightSecurityAccess access, System.Boolean ftpReadEnabled, System.Boolean ftpWriteEnabled, System.Boolean customViewDefaultEnabled, System.Boolean onlineOfflineEnabled, System.Boolean onlineJobSaveEnabled)

Added Methods

Cognex.InSight.Sensor.CvsSettings.GetFeatureFamily()

Added Property Setters

Cognex.InSight.Sensor.CvsUser.OnlineJobSaveEnabled { set; }

Added Property Getters

Cognex.InSight.Sensor.CvsSettings.OnlineJobSaveSupported { get; }

Cognex.InSight.Sensor.CvsUser.OnlineJobSaveEnabled { get; }

Added Enumerations

Cognex.InSight.Sensor.CvsInSightFeatureFamily

Added Enumeration Values

Cognex.InSight.Net.CvsSupportedFeatures.Terminal

Cognex.InSight.Sensor.CvsHostSubtype.InSight500Series

Cognex.InSight.Sensor.CvsHostSubtype.InSight7000Series

Cognex.InSight.Sensor.CvsInSightFeatureFamily.None

Cognex.InSight.Sensor.CvsInSightFeatureFamily.LR

Cognex.InSight.Sensor.CvsInSightFeatureFamily.OcrOnly

Cognex.InSight.Sensor.CvsSupportedTools.FeatureFamily0

Cognex.InSight.Sensor.CvsSupportedTools.FeatureFamily1

Cognex.InSight.Sensor.CvsSupportedTools.FeatureFamily2

Cognex.InSight.Sensor.CvsSupportedTools.FeatureFamily3

Cognex.InSight.Sensor.CvsSupportedTools.FeatureFamily4

Copyright (c) 2004-2014 Cognex Corporation.


4.7.0 to 4.8.0

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (4.7.130.0 to 4.8.6155.0)

Added Constructors

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsControl..ctor()

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsController..ctor(Cognex.InSight.Controls.Display.Protocols.IPowerlinkSettingsView view)

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsDialog..ctor()

Added Methods

Cognex.InSight.Controls.Display.CvsInSightDisplay.Connect(string hostName, string userName, string password, System.Uri primary, System.Uri secondary, System.Boolean forceConnect)

Cognex.InSight.Controls.Display.CvsInSightDisplay.OpenPropertySheet(int row, int column, string expression)

Cognex.InSight.Controls.Display.CvsInSightDisplay.SetStatusInformation(string value, Cognex.InSight.Controls.Display.CvsStatusInformationState state)

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.AddRecentPlaybackFolder(string folder)

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsControl.Commit()

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsControl.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsController.OnCommit()

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsController.OnNodeIDChanged()

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsDialog.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.ProcessKeyPreview(ref System.Windows.Forms.Message& m)

Added Property Setters

Cognex.InSight.Controls.Display.CvsEditEventArgs.DraggingGraphic { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.GetDefaultRecordWatchCell { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordBitDepth { set; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordBitDepth { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.DataSource { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.DisplayMember { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.HexVisible { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.SelectedValue { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ValueMember { set; }

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsControl.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsController.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsDialog.Settings { set; }

Cognex.InSight.Controls.Display.Protocols.IPowerlinkSettingsView.NodeID { set; }

Cognex.InSight.Controls.Display.Protocols.IPowerlinkSettingsView.NodeIDError { set; }

Cognex.InSight.Controls.Display.Protocols.IPowerlinkSettingsView.OKEnabled { set; }

Removed Property Getters

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditUserListSettings { get; }

Added Property Getters

Cognex.InSight.Controls.Display.CvsEditEventArgs.DraggingGraphic { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.CreateNewCustomPrivilege { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditCustomPrivileges { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditImageBuffers { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditUserAccessSettings { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.GetDefaultRecordWatchCell { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecentPlaybackFolders { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordBitDepth { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder.RecordMaxLimit { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions.RecordBitDepth { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.DataSource { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.DisplayMember { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.SelectedValue { get; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ValueMember { get; }

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsControl.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsController.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsDialog.Settings { get; }

Cognex.InSight.Controls.Display.Protocols.IPowerlinkSettingsView.NodeID { get; }

Cognex.InSight.Controls.Display.Protocols.IPowerlinkSettingsView.NodeIDError { get; }

Added Classes

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsControl

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsController

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsDialog

Added Events

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.NetworkTreeRefreshNeeded

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.SelectedValueChanged

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsControl.DataValidChange

Added Interfaces

Cognex.InSight.Controls.Display.Network.IIPSecManager

Cognex.InSight.Controls.Display.Protocols.IPowerlinkSettingsView

Added Namespaces

Cognex.InSight.Controls.Display.Properties

Removed Custom Attributes

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditUserListSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

T:Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder - [Serializable]

Added Custom Attributes

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.CreateNewCustomPrivilege { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditCustomPrivileges { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditImageBuffers { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditUserAccessSettings { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.DataSource { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.DataSource { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.DisplayMember { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.DisplayMember { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.SelectedValue { get; } - [ComponentModel.Browsable((Boolean)False)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.SelectedValue { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ValueMember { get; } - [ComponentModel.DesignerSerializationVisibility((ComponentModel.DesignerSerializationVisibility)0)]

P:Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.ValueMember { get; } - [ComponentModel.Browsable((Boolean)False)]

T:Cognex.InSight.Controls.Display.CvsInSightDisplayRecorderOptions - [Serializable]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions - [ComVisible((Boolean)True)]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings - [ComVisible((Boolean)True)]

API Changes - Cognex.InSight.dll (4.7.130.0 to 4.8.6155.0)

Added Constructors

Cognex.InSight.Graphic.CvsGraphicParallelogram..ctor()

Cognex.InSight.Graphic.CvsGraphicParallelogram..ctor(string label)

Cognex.InSight.Graphic.CvsGraphicParallelogram..ctor(Cognex.InSight.Graphic.CvsGraphicParallelogram graphic)

Cognex.InSight.Graphic.CvsGraphicParallelogram..ctor(Cognex.InSight.CvsCellLocation cellLocation, Cognex.InSight.CvsImageLocation location, System.Single height, System.Single width, System.Single rotation, System.Single interiorAngle, string label)

Cognex.InSight.Net.CvsNetworkMonitorSubnet..ctor(System.Net.IPAddress ip, System.Net.IPAddress mask)

Cognex.InSight.Sensor.CvsRemoteSubnetCollection..ctor()

Cognex.InSight.Sensor.CvsRemoteSubnetCollection..ctor(IEnumerable entries)

Cognex.InSight.Sensor.CvsRemoteSubnetEntry..ctor(string name, System.Net.IPAddress address, System.Net.IPAddress mask, System.Boolean customGatewayEnabled, System.Net.IPAddress customGateway)

Cognex.InSight.Sensor.CvsRemoteSubnetEntry..ctor(Cognex.InSight.Sensor.CvsRemoteSubnetEntry other)

Added Methods

Cognex.InSight.CvsPowerlinkSettings.Clone()

Cognex.InSight.CvsUtility.OpenDialog(Cognex.InSight.CvsInSight inSight, string dlgLocation, string dlgText)

Cognex.InSight.Graphic.CvsGraphicParallelogram.Initialize(int cellRow, int cellCol, System.Single regionRow, System.Single regionCol, System.Single regionHeight, System.Single regionWidth, System.Single regionRotation, System.Single regionInteriorAngle, string regionLabel)

Cognex.InSight.Net.CvsNetworkMonitorSubnet.Equals(object obj)

Cognex.InSight.Net.CvsNetworkMonitorSubnet.GetHashCode()

Cognex.InSight.Sensor.CvsDiscreteOutputLine.SupportEncoderAfterTrigger(Cognex.InSight.Sensor.CvsIOModule module, int line, Cognex.InSight.Sensor.CvsOutputType type)

Cognex.InSight.Sensor.CvsRemoteSubnetCollection.Add(Cognex.InSight.Sensor.CvsRemoteSubnetEntry item)

Cognex.InSight.Sensor.CvsRemoteSubnetCollection.Clear()

Cognex.InSight.Sensor.CvsRemoteSubnetCollection.Clone()

Cognex.InSight.Sensor.CvsRemoteSubnetCollection.Contains(Cognex.InSight.Sensor.CvsRemoteSubnetEntry item)

Cognex.InSight.Sensor.CvsRemoteSubnetCollection.CopyTo(Cognex.InSight.Sensor.CvsRemoteSubnetEntry[] array, int arrayIndex)

Cognex.InSight.Sensor.CvsRemoteSubnetCollection.GetEnumerator()

Cognex.InSight.Sensor.CvsRemoteSubnetCollection.Remove(Cognex.InSight.Sensor.CvsRemoteSubnetEntry item)

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.Clone()

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.Equals(object obj)

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.GetHashCode()

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.Matches(Cognex.InSight.Sensor.CvsRemoteSubnetEntry other)

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.ToString()

Cognex.InSight.Sensor.CvsSettings.GetSupportedLanguages()

Added Property Setters

Cognex.InSight.CvsPowerlinkSettings.NodeID { set; }

Cognex.InSight.Ftp.CvsFtpClient.UsePasswordEncryption { set; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.EditBounds { set; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.EditFlags { set; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.Height { set; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.InteriorAngle { set; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.LabelBackColor { set; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.LabelBackColorAsRgb { set; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.LabelForeColor { set; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.LabelForeColorAsRgb { set; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.Location { set; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.Rotation { set; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.Width { set; }

Cognex.InSight.NativeMode.CvsNativeModeClient.UsePasswordEncryption { set; }

Cognex.InSight.Sensor.CvsDiscreteOutputLine.EncoderDelayNumber { set; }

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.CustomGateway { set; }

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.CustomGatewayEnabled { set; }

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.IPAddress { set; }

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.Mask { set; }

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.Name { set; }

Cognex.InSight.Sensor.CvsSettings.LiveImagesBitDepth { set; }

Cognex.InSight.Sensor.CvsSettings.OnlineImagesBitDepth { set; }

Added Property Getters

Cognex.InSight.CvsInSight.ConnectedUser { get; }

Cognex.InSight.CvsInvalidTimeException.InvalidTime { get; }

Cognex.InSight.CvsPowerlinkSettings.NodeID { get; }

Cognex.InSight.Ftp.CvsFtpClient.LastResponse { get; }

Cognex.InSight.Ftp.CvsFtpClient.UsePasswordEncryption { get; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.Area { get; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.EditBounds { get; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.EditFlags { get; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.Height { get; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.InteriorAngle { get; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.LabelBackColor { get; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.LabelBackColorAsRgb { get; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.LabelForeColor { get; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.LabelForeColorAsRgb { get; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.Location { get; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.Rotation { get; }

Cognex.InSight.Graphic.CvsGraphicParallelogram.Width { get; }

Cognex.InSight.NativeMode.CvsNativeModeClient.UsePasswordEncryption { get; }

Cognex.InSight.Net.CvsHostSensor.HardwarePartNumber { get; }

Cognex.InSight.Net.CvsHostSensor.ProductPartNumber { get; }

Cognex.InSight.Net.CvsNetworkListener.RemoteSubnets { get; }

Cognex.InSight.Net.CvsNetworkMonitorSubnet.BroadcastAddress { get; }

Cognex.InSight.Net.CvsNetworkMonitorSubnet.IPAddress { get; }

Cognex.InSight.Net.CvsNetworkMonitorSubnet.SubnetMask { get; }

Cognex.InSight.Sensor.CvsDiscreteOutputLine.EncoderDelayNumber { get; }

Cognex.InSight.Sensor.CvsNetworkSettings.PowerlinkSettings { get; }

Cognex.InSight.Sensor.CvsRemoteSubnetCollection.Count { get; }

Cognex.InSight.Sensor.CvsRemoteSubnetCollection.Item { get; }

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.CustomGateway { get; }

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.CustomGatewayEnabled { get; }

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.IPAddress { get; }

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.Mask { get; }

Cognex.InSight.Sensor.CvsRemoteSubnetEntry.Name { get; }

Cognex.InSight.Sensor.CvsSensor.BlowfishEncryptionSupported { get; }

Cognex.InSight.Sensor.CvsSensor.ExternalLightSettingsSupported { get; }

Cognex.InSight.Sensor.CvsSensor.IsColor { get; }

Cognex.InSight.Sensor.CvsSensor.PowerlinkSettingsSupported { get; }

Cognex.InSight.Sensor.CvsSensor.RecordModeOnSensorSupported { get; }

Cognex.InSight.Sensor.CvsSettings.BlowfishEncryptionSupported { get; }

Cognex.InSight.Sensor.CvsSettings.EncoderOutputConfigured { get; }

Cognex.InSight.Sensor.CvsSettings.EncoderOutputSupport { get; }

Cognex.InSight.Sensor.CvsSettings.EncoderSupportOnIO_2and3 { get; }

Cognex.InSight.Sensor.CvsSettings.ExternalLightSettingsSupported { get; }

Cognex.InSight.Sensor.CvsSettings.LiveImagesBitDepth { get; }

Cognex.InSight.Sensor.CvsSettings.OnlineImagesBitDepth { get; }

Cognex.InSight.Sensor.CvsSettings.PowerlinkSettingsSupported { get; }

Cognex.InSight.Sensor.CvsSettings.RecordModeOnSensorSupported { get; }

Cognex.InSight.Sensor.CvsSettings.SerialSupportOnIO { get; }

Cognex.InSight.Sensor.CvsSettings.SerialSupportOnIO_1 { get; }

Added Classes

Cognex.InSight.CvsInvalidTimeException

Cognex.InSight.CvsPowerlinkSettings

Cognex.InSight.Graphic.CvsGraphicParallelogram

Cognex.InSight.Net.CvsNetworkMonitorSubnet

Cognex.InSight.Sensor.CvsRemoteSubnetCollection

Cognex.InSight.Sensor.CvsRemoteSubnetEntry

Added Enumerations

Cognex.InSight.Sensor.CvsColorBitDepth

Cognex.InSight.Sensor.CvsOutputDelayTypeFlags

Added Enumeration Values

Cognex.InSight.CvsInSightError.InvalidTimeException

Cognex.InSight.Graphic.CvsEditFlags.Skew

Cognex.InSight.Net.CvsNetworkMonitorScope.RemoteSubnets

Cognex.InSight.Sensor.CvsColorBitDepth.D16

Cognex.InSight.Sensor.CvsColorBitDepth.D24

Cognex.InSight.Sensor.CvsInputType.Encoder

Cognex.InSight.Sensor.CvsInputType.SerialRX

Cognex.InSight.Sensor.CvsOutputDelayTypeFlags.AcquisitionCount

Cognex.InSight.Sensor.CvsOutputDelayTypeFlags.TimeAfterTrigger

Cognex.InSight.Sensor.CvsOutputDelayTypeFlags.EncoderCount

Cognex.InSight.Sensor.CvsOutputListType.EncoderSupport

Cognex.InSight.Sensor.CvsOutputListType.SerialSupport

Cognex.InSight.Sensor.CvsOutputType.Encoder

Cognex.InSight.Sensor.CvsOutputType.SerialTransmit

Cognex.InSight.Sensor.CvsProtocolServices.Powerlink

Cognex.InSight.Sensor.CvsProtocolServices.All

Added Custom Attributes

P:Cognex.InSight.Graphic.CvsGraphicParallelogram.LabelBackColor { get; } - [ComVisible((Boolean)False)]

P:Cognex.InSight.Graphic.CvsGraphicParallelogram.LabelForeColor { get; } - [ComVisible((Boolean)False)]

P:Cognex.InSight.Sensor.CvsRemoteSubnetEntry.CustomGateway { get; } - [ComVisible((Boolean)False)]

P:Cognex.InSight.Sensor.CvsRemoteSubnetEntry.CustomGateway { get; } - [Xml.Serialization.XmlIgnore]

P:Cognex.InSight.Sensor.CvsRemoteSubnetEntry.IPAddress { get; } - [Xml.Serialization.XmlIgnore]

P:Cognex.InSight.Sensor.CvsRemoteSubnetEntry.IPAddress { get; } - [ComVisible((Boolean)False)]

P:Cognex.InSight.Sensor.CvsRemoteSubnetEntry.Mask { get; } - [ComVisible((Boolean)False)]

P:Cognex.InSight.Sensor.CvsRemoteSubnetEntry.Mask { get; } - [Xml.Serialization.XmlIgnore]

Enum:Cognex.InSight.Sensor.CvsColorBitDepth - [Serializable]

T:Cognex.InSight.CvsInvalidTimeException - [Serializable]

T:Cognex.InSight.CvsInvalidTimeException - [ComVisible((Boolean)False)]

T:Cognex.InSight.CvsPowerlinkSettings - [Serializable]

T:Cognex.InSight.CvsPowerlinkSettings - [Guid("232501AD-734B-4d24-A11C-CD96FEF61CA8")]

T:Cognex.InSight.Graphic.CvsGraphicParallelogram - [Serializable]

T:Cognex.InSight.Graphic.CvsGraphicParallelogram - [Guid("F83418CC-6632-4A98-B77A-310D63A37DEB")]

T:Cognex.InSight.Sensor.CvsRemoteSubnetCollection - [Serializable]

T:Cognex.InSight.Sensor.CvsRemoteSubnetCollection - [DefaultMember("Item")]

T:Cognex.InSight.Sensor.CvsRemoteSubnetCollection - [Guid("DB8CBCD9-DCF1-456e-AC29-1EFC604C22C4")]

T:Cognex.InSight.Sensor.CvsRemoteSubnetEntry - [Serializable]

T:Cognex.InSight.Sensor.CvsRemoteSubnetEntry - [Guid("36CE68E7-E048-4e49-9AB9-9734242A1713")]

Copyright (c) 2004-2014 Cognex Corporation.


4.8.0 to 4.9.0

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (4.8.6155.0 to 4.9.2511.0)

Removed Constructors

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsControl..ctor()

Removed Methods

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridDialog.OnClosed(System.EventArgs e)

Cognex.InSight.Controls.Display.CvsInSightDisplay.Connect(string hostName, string userName, string password, System.Uri primary, System.Uri secondary, System.Boolean forceConnect)

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsControl.Commit()

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsControl.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsDialog.OnClosing(System.ComponentModel.CancelEventArgs e)

Added Methods

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridDialog.GetChildrenInTabOrder(System.Windows.Forms.Control parentControl)

Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrationDataList.OnLoad(System.EventArgs e)

Cognex.InSight.Controls.Display.CvsInSightDisplay.ClickSpreadsheetControl(Cognex.InSight.CvsCellLocation location)

Cognex.InSight.Controls.Display.CvsInSightDisplay.ClickSpreadsheetControl(int row, int column)

Cognex.InSight.Controls.Display.CvsInSightDisplay.Connect(string hostName, string userName, string password, Cognex.InSight.CvsAdvancedCapabilities capabilities, System.Boolean forceConnect)

Cognex.InSight.Controls.Display.CvsInSightDisplay.LoadStandardTheme()

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.PromptForInSightRestart()

Cognex.InSight.Controls.Display.IUserListView.RefreshListBox()

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsDialog.GetDialogOptions()

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsDialog.OnClosed(System.EventArgs e)

Cognex.InSight.Controls.Display.Protocols.CvsProfinetSettingsDialog.HandleOkayPressed(System.ComponentModel.CancelEventArgs e)

Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback.Finalize()

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue.Finalize()

Removed Property Setters

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsControl.Settings { set; }

Added Property Setters

Cognex.InSight.Controls.Display.IUserListView.AddEnabled { set; }

Cognex.InSight.Controls.Display.IUserListView.DeleteEnabled { set; }

Cognex.InSight.Controls.Display.IUserListView.EditEnabled { set; }

Cognex.InSight.Controls.Display.IUserListView.SelectedItemIndex { set; }

Cognex.InSight.Controls.Display.IUserListView.SelectedUserName { set; }

Cognex.InSight.Controls.Display.IUserListView.ShowSelectedItem { set; }

Cognex.InSight.Controls.Display.IUserListView.UserList { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.Dirty { set; }

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsController.Dirty { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.Condition { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.FreezeOnRejectAction { set; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.WatchCell { set; }

Removed Property Getters

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsControl.Settings { get; }

Added Property Getters

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ClearPermissions { get; }

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditMaxGuiConnections { get; }

Cognex.InSight.Controls.Display.IUserListView.IsAdminSelected { get; }

Cognex.InSight.Controls.Display.IUserListView.SelectedItemIndex { get; }

Cognex.InSight.Controls.Display.IUserListView.SelectedUserCount { get; }

Cognex.InSight.Controls.Display.IUserListView.SelectedUserName { get; }

Cognex.InSight.Controls.Display.IUserListView.ShowSelectedItem { get; }

Cognex.InSight.Controls.Display.IUserListView.UserList { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.Condition { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.FreezeOnRejectAction { get; }

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings.WatchCell { get; }

Removed Classes

Cognex.InSight.Controls.Display.Protocols.CvsPowerlinkSettingsControl

Added Events

Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.JobSaving

Cognex.InSight.Controls.Display.GridListBox+ContainedComboBox.EnterKeyPressed

Cognex.InSight.Controls.Display.GridListBox+ContainedComboBox.EscapeKeyPressed

Cognex.InSight.Controls.Display.Protocols.CvsMCProtocolScannerSettingsControl.DirtyChanged

Cognex.InSight.Controls.Display.Protocols.MCProtocolScannerDeviceControl.DirtyChanged

Added Interfaces

Cognex.InSight.Controls.Display.IUserListView

Added Namespaces

Cognex.InSight.Controls.Display.PropertySheets

Cognex.InSight.Controls.Display.Resources

Added Enumerations

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueCellCondition

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueCondition

Added Enumeration Values

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueCellCondition.Zero

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueCellCondition.ERR

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueCellCondition.Negative

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueCellCondition.Positive

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueCondition.Pass

Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueCondition.Fail

Removed Custom Attributes

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.MaxUserAccess { get; } - [ComponentModel.Description("The maximum allowed access level of the user.")]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.CreateNewCustomPrivilege { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

Added Custom Attributes

P:Cognex.InSight.Controls.Display.CvsInSightDisplay.MaxUserAccess { get; } - [ComponentModel.Description("The maximum allowed access level of the Classic user.")]

P:Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditMaxGuiConnections { get; } - [Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogMode]

Enum:Cognex.InSight.Controls.Display.CvsDisplayScrollMode - [Guid("A0240520-3320-49DB-8A79-D40F6CE34092")]

Enum:Cognex.InSight.Controls.Display.CvsDisplayState - [Guid("80B84FA1-82B5-4D4B-8C30-17CC5050387C")]

Enum:Cognex.InSight.Controls.Display.CvsDisplayZoom - [Guid("A54D3FBE-6A3B-4CD6-9231-B47A4A072730")]

Enum:Cognex.InSight.Controls.Display.CvsRecordMode - [Guid("69C50522-C6D1-476A-AB48-0109B13FD28A")]

Enum:Cognex.InSight.Controls.Display.CvsStatusInformationState - [Guid("9044EB66-27C8-4A37-BFB5-BDBE40F01CA7")]

Enum:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueCellCondition - [Flags]

Enum:Cognex.InSight.Controls.Filmstrip.CvsFilmstripScale - [Guid("B9BB56F7-63A7-4925-9A12-243802158C54")]

Enum:Cognex.InSight.Controls.Filmstrip.CvsStatusLevelStyle - [Guid("55F3FCB7-DFEB-4B4B-B9A8-7E5DCD38DE5A")]

T:Cognex.InSight.Controls.Display.CvsInSightDisplayRecorder - [Guid("9F691A4C-797B-480D-9EEA-63FC29D83346")]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback - [Guid("FB4BA2C3-0E08-46BD-AD54-68B56D86ACD8")]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue - [Guid("C668348E-83CB-4d94-8E79-EA1180E713BF")]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueOptions - [Guid("63238FAA-800B-43CC-8F66-C7D35B8AD820")]

T:Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueueSettings - [Guid("FE10703A-3DCB-4598-9A53-279DED74A227")]

API Changes - Cognex.InSight.dll (4.8.6155.0 to 4.9.2511.0)

Added Constructors

Cognex.InSight.CvsAdvancedCapabilities..ctor(System.Boolean cdsMode, System.Uri cdsServer, System.Boolean cdsSupported, System.Boolean improvedEncryptionSupported)

Cognex.InSight.CvsAdvancedCapabilities..ctor()

Cognex.InSight.CvsCellLocation..ctor(int row, string column)

Added Methods

Cognex.InSight.Cell.CvsCellOcrMaxAutoTune.Read(Cognex.InSight.Internal.IspReader br)

Cognex.InSight.Cell.CvsCellOcrMaxAutoTune.ToString()

Cognex.InSight.Controls.CvsAction.Dispose(System.Boolean disposing)

Cognex.InSight.Controls.CvsActionToggle.Dispose(System.Boolean disposing)

Cognex.InSight.CvsAdvancedCapabilities.Create(System.Collections.IDictionary attributes)

Cognex.InSight.Sensor.CvsSensor.GetSensorID(Cognex.InSight.Sensor.CvsHostType type, string hostName, string macAddress, string ipAddress)

Cognex.InSight.Sensor.CvsSensor.IsImprovedEncryptionSupported(System.Version v)

Cognex.InSight.Sensor.CvsSensor.IsImprovedEncryptionSupported(Cognex.InSight.Sensor.CvsHostVersion v)

Cognex.InSight.Sensor.CvsSettings.GetSlowBaudRateSupportedFlags(System.Boolean expansionIOAttached, out System.Boolean& allow1200, out System.Boolean& allow2400)

Added Property Setters

Cognex.InSight.CvsInSight.AdvancedCapabilities { set; }

Cognex.InSight.Ftp.CvsFtpClient.Timeout { set; }

Removed Property Getters

Cognex.InSight.Sensor.CvsSensor.BlowfishEncryptionSupported { get; }

Cognex.InSight.Sensor.CvsSettings.BlowfishEncryptionSupported { get; }

Added Property Getters

Cognex.InSight.Cell.CvsCell.HasChecksum { get; }

Cognex.InSight.Cell.CvsCellOcrMaxAutoTune.DataType { get; }

Cognex.InSight.Cell.CvsCellOcrMaxAutoTune.IsEditCell { get; }

Cognex.InSight.Cell.CvsCellOcrMaxAutoTune.Text { get; }

Cognex.InSight.Cell.CvsCellString.Checksum { get; }

Cognex.InSight.CvsAdvancedCapabilities.ImprovedEncryptionSupported { get; }

Cognex.InSight.CvsInSight.AccessDowngraded { get; }

Cognex.InSight.CvsInSight.AdvancedCapabilities { get; }

Cognex.InSight.CvsSensorAlreadyConnectedException.IsMaxGuiConnection { get; }

Cognex.InSight.Ftp.CvsFtpClient.Timeout { get; }

Cognex.InSight.Sensor.CvsProcessorConstants.IsEncryptJobLoadSaveSupported { get; }

Cognex.InSight.Sensor.CvsSettings.ResourceMessagesSupported { get; }

Added Classes

Cognex.InSight.Cell.CvsCellOcrMaxAutoTune

Cognex.InSight.CvsAdvancedCapabilities

Added Enumeration Values

Cognex.InSight.Sensor.CvsHostSubtype.InSightReserved1

Cognex.InSight.Sensor.CvsHostSubtype.InSightReserved2

Cognex.InSight.Sensor.CvsHostSubtype.InSightABBSeries

Cognex.InSight.Sensor.CvsProtocolServices.IQSS

Added Custom Attributes

Enum:Cognex.InSight.Cell.CvsCellDataType - [Guid("A0370C7F-AFF0-4B7E-825A-157907F414C0")]

Enum:Cognex.InSight.Cell.CvsCellIPProtection - [Guid("291A9795-5D6A-4700-8A1E-BF684D8E1010")]

Enum:Cognex.InSight.Cell.CvsCellProperty - [Guid("83567D5C-5E8D-4D67-8C91-75FD0D50BEDA")]

Enum:Cognex.InSight.CvsEasyViewItemType - [Guid("210144E0-53D5-492C-9802-BD2368CADA26")]

Enum:Cognex.InSight.CvsImageOrientation - [Guid("6D49ED57-5D3E-4741-BC16-27116AEC3C80")]

Enum:Cognex.InSight.CvsInSightError - [Guid("E6F40191-C788-4D2B-8A26-B51C6EB366F3")]

Enum:Cognex.InSight.CvsInSightLanguage - [Guid("96D9C754-86EA-420A-9A89-2D65BE112241")]

Enum:Cognex.InSight.CvsInSightMessageId - [Guid("E3129D54-5DF1-41A2-BF18-8E27BA6F4D31")]

Enum:Cognex.InSight.CvsInSightSecurityAccess - [Guid("52B6F26F-87F8-4EFA-B8FE-5339650FE01F")]

Enum:Cognex.InSight.CvsInSightState - [Guid("D2DBA6C6-7BFC-4525-86AE-5AB1EC2E37DA")]

Enum:Cognex.InSight.CvsInSightStateChangedReason - [Guid("A112798A-D45F-4768-9ABD-3CE7F699697C")]

Enum:Cognex.InSight.CvsStatusLevel - [Guid("79A40319-F57A-4A7E-8D15-0DDE8E078A01")]

Enum:Cognex.InSight.Graphic.CvsDisplayable4SideStyle - [Guid("2FEB6378-5821-4363-9456-C3624A385074")]

Enum:Cognex.InSight.Graphic.CvsEditFlags - [Guid("BD46A1E4-9897-4415-BF5D-493DD9C8214C")]

Enum:Cognex.InSight.Graphic.CvsGraphicBlobDirection - [Guid("66AEB2A5-863B-4DD6-A0AE-E3778834AED8")]

Enum:Cognex.InSight.Graphic.CvsGraphicLineAdornment - [Guid("F08658B7-3DB9-4BB0-A059-DC04BB826A1A")]

Enum:Cognex.InSight.Net.CvsNetworkMonitorCommand - [Guid("10F2E714-15C3-4DD2-8A20-0AC98B3447C1")]

Enum:Cognex.InSight.Net.CvsNetworkMonitorScope - [Guid("C3673C6B-A8B0-4CF3-B660-68D813A291EF")]

Enum:Cognex.InSight.Net.CvsSupportedFeatures - [Guid("8C918DF2-991A-40A4-8686-DD091A870329")]

Enum:Cognex.InSight.Sensor.CvsAuthenticationAlgorithms - [Guid("59087055-7CB3-4EC4-AD85-3592E9043566")]

Enum:Cognex.InSight.Sensor.CvsBaudRate - [Guid("5F294117-EF88-4440-9444-E7DA3CB30D8A")]

Enum:Cognex.InSight.Sensor.CvsColorBitDepth - [Guid("C95B2C59-98B4-4E4F-890F-F70F9803064C")]

Enum:Cognex.InSight.Sensor.CvsDataBits - [Guid("632018E7-699B-45D8-B076-05CF4A44DEDA")]

Enum:Cognex.InSight.Sensor.CvsEipWatchdogTimeoutActions - [Guid("2A0C7D74-6519-4DAB-B6DE-67143D36D986")]

Enum:Cognex.InSight.Sensor.CvsEncryptionAlgorithms - [Guid("050489CA-4DC6-4EA2-8E91-BBA45C3324E8")]

Enum:Cognex.InSight.Sensor.CvsHandshake - [Guid("6C25E593-B666-4332-BA77-140F2701F0EB")]

Enum:Cognex.InSight.Sensor.CvsHostSubtype - [Guid("D3969C65-B35A-4F95-B608-C15563CF81FF")]

Enum:Cognex.InSight.Sensor.CvsHostType - [Guid("1B0AA780-CC95-4C9E-8FF7-6D135D16D6C6")]

Enum:Cognex.InSight.Sensor.CvsImageResolution - [Guid("848C0B30-82BF-43C8-AFA2-C8952549F01F")]

Enum:Cognex.InSight.Sensor.CvsInputSignal - [Guid("B1F3B966-CF70-4BFF-BC6C-553D98C7F635")]

Enum:Cognex.InSight.Sensor.CvsInputType - [Guid("7F672554-E7FA-445B-9794-1A002FA6FCF5")]

Enum:Cognex.InSight.Sensor.CvsInSightFeatureFamily - [Guid("D43C8E13-56AA-4C66-8629-BB2E18D0A621")]

Enum:Cognex.InSight.Sensor.CvsIOModule - [Guid("0DBC903B-4534-42C5-9512-8A340FE63959")]

Enum:Cognex.InSight.Sensor.CvsMode - [Guid("33BF2E63-AD46-470F-BBF8-88BA5A65C425")]

Enum:Cognex.InSight.Sensor.CvsOutputDelayTypeFlags - [Guid("535741F2-0D49-4AD2-9C95-0129A8E6E300")]

Enum:Cognex.InSight.Sensor.CvsOutputListType - [Guid("F2D8AB33-C081-4D50-A1D4-5F69EA4C5CF0")]

Enum:Cognex.InSight.Sensor.CvsOutputType - [Guid("B6017DF3-7CEB-420E-AE50-D0F41F8C12E4")]

Enum:Cognex.InSight.Sensor.CvsParity - [Guid("7D63E0BC-DBE7-4494-A1B5-B07749DC6DAE")]

Enum:Cognex.InSight.Sensor.CvsProtocols - [Guid("A9FCC252-B190-42C8-B3D3-63EBC3B06BE8")]

Enum:Cognex.InSight.Sensor.CvsProtocolServices - [Guid("EDE6FC60-795A-4465-9F5A-860946833470")]

Enum:Cognex.InSight.Sensor.CvsStopBits - [Guid("F0A92E04-52CC-469C-AD63-BAE1C68918C8")]

Enum:Cognex.InSight.Sensor.CvsStrobeStartPositionType - [Guid("50FF081D-A50F-4511-95E6-6EBB9FF14ED6")]

Enum:Cognex.InSight.Sensor.CvsSupportedTools - [Guid("1AE26E35-C3C5-477E-90E0-5AA2C4B98B57")]

T:Cognex.InSight.Cell.CvsCell - [Guid("1B176340-214B-4094-9F3D-8CE00079E46F")]

T:Cognex.InSight.Cell.CvsCellOcrMaxAutoTune - [Serializable]

T:Cognex.InSight.Cell.CvsCellOcrMaxAutoTune - [Guid("D2C920E7-72FF-491A-97CA-2F4201F72F2C")]

T:Cognex.InSight.Controls.CvsAction - [Guid("D19193E6-8BF6-4AE9-94AE-4884525A3F84")]

T:Cognex.InSight.Controls.CvsActionToggle - [Guid("F1668C1A-E283-44EA-AA68-511E664DEB76")]

T:Cognex.InSight.CvsAdvancedCapabilities - [Guid("9AA9E5E8-D711-4B4A-8EEA-066B638B3DE0")]

T:Cognex.InSight.CvsAdvancedCapabilities - [ComVisible((Boolean)True)]

T:Cognex.InSight.CvsCellLocation - [Guid("56E0FE07-D1FB-406C-B461-63966C68F2C0")]

T:Cognex.InSight.CvsCellProtectionException - [ComVisible((Boolean)False)]

T:Cognex.InSight.CvsCellRange - [Guid("67CD8580-77E3-4B37-9134-F362BFD8C2A6")]

T:Cognex.InSight.CvsFeatureLicense - [Guid("BDDF669E-5AC1-448A-9B98-150E4261403F")]

T:Cognex.InSight.CvsImageLocation - [Guid("28868491-959F-45EE-AC65-D84A1E2A45B7")]

T:Cognex.InSight.CvsNotLicensedException - [ComVisible((Boolean)False)]

T:Cognex.InSight.Graphic.CvsGraphic - [Guid("128A02A9-8326-4E1F-9F49-18A185A344EA")]

T:Cognex.InSight.Graphic.CvsGraphicBlobPoint - [Guid("B3761533-714F-4A18-9367-0B0EF3B25FC8")]

T:Cognex.InSight.Graphic.CvsGraphicCompositeBase - [Guid("93CEB443-71E1-4C21-A3B1-5DEE34402EFB")]

T:Cognex.InSight.Net.CvsNetworkMonitorSubnet - [Guid("70A3304E-7D40-4271-9B6E-70CDE2C3791F")]

Copyright (c) 2004-2014 Cognex Corporation.


4.9.0 to 4.9.1

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (4.9.2511.0 to 4.9.553.1)

Added Type

Cognex.InSight.Controls.Display.CvsExpressionTreeDisplayBinder

Cognex.InSight.Controls.Display.CvsExpressionTreeItemEventArgs

Cognex.InSight.Controls.Display.CvsExpressionTreeView

Cognex.InSight.Controls.Display.CvsInSightDisplayHistory

Cognex.InSight.Controls.Display.CvsSpreadsheetNavigator

Added Interface

Cognex.InSight.Controls.Display.ISpreadsheetNavigator

Added Event

[Cognex.InSight.Controls.Display.CvsExpressionTreeView] ItemClick (Cognex.InSight.Controls.Display.CvsExpressionTreeItemEventHandler)

[Cognex.InSight.Controls.Display.CvsExpressionTreeView] MouseCellLocationChanged (System.EventHandler)

[Cognex.InSight.Controls.Display.CvsExpressionTreeView] PinnedChanged (System.EventHandler)

[Cognex.InSight.Controls.Display.CvsInSightDisplay] CurrentCellNowChanged (System.EventHandler)

Added Field

[Cognex.InSight.Controls.Display.CvsExpressionTreeItemEventArgs] CellLocation (Cognex.InSight.CvsCellLocation)

[Cognex.InSight.Controls.Display.CvsInSightDisplayHistory] MaxHistoryCount (System.Int32)

Added Constructor

[Cognex.InSight.Controls.Display.CvsExpressionTreeDisplayBinder] Void .ctor(Cognex.InSight.Controls.Display.CvsInSightDisplay, Cognex.InSight.Controls.Display.CvsExpressionTreeView)

[Cognex.InSight.Controls.Display.CvsExpressionTreeItemEventArgs] Void .ctor(Cognex.InSight.CvsCellLocation)

[Cognex.InSight.Controls.Display.CvsExpressionTreeItemEventHandler] Void .ctor(System.Object, IntPtr)

[Cognex.InSight.Controls.Display.CvsExpressionTreeView] Void .ctor()

[Cognex.InSight.Controls.Display.CvsInSightDisplayHistory] Void .ctor(Cognex.InSight.Controls.Display.CvsInSightDisplay)

[Cognex.InSight.Controls.Display.CvsSpreadsheetNavigator] Void .ctor()

Added Delegate

Cognex.InSight.Controls.Display.CvsExpressionTreeItemEventHandler

Added Method

[Cognex.InSight.Controls.Display.CvsExpressionTreeDisplayBinder] Void Dispose()

[Cognex.InSight.Controls.Display.CvsExpressionTreeItemEventHandler] System.IAsyncResult BeginInvoke(System.Object, Cognex.InSight.Controls.Display.CvsExpressionTreeItemEventArgs, System.AsyncCallback, System.Object)

[Cognex.InSight.Controls.Display.CvsExpressionTreeItemEventHandler] Void EndInvoke(System.IAsyncResult)

[Cognex.InSight.Controls.Display.CvsExpressionTreeItemEventHandler] Void Invoke(System.Object, Cognex.InSight.Controls.Display.CvsExpressionTreeItemEventArgs)

[Cognex.InSight.Controls.Display.CvsInSightDisplay] Void GotoCell(Cognex.InSight.CvsCellLocation)

[Cognex.InSight.Controls.Display.CvsInSightDisplayEdit] Boolean OpenImageFromFile(System.String)

[Cognex.InSight.Controls.Display.CvsInSightDisplayEdit] Boolean OpenJobFromFile(System.String)

[Cognex.InSight.Controls.Display.CvsInSightDisplayHistory] Void Dispose()

[Cognex.InSight.Controls.Display.ISpreadsheetNavigator] System.Drawing.Rectangle CellToClientRect(Cognex.InSight.CvsCellLocation)

[Cognex.InSight.Controls.Display.ISpreadsheetNavigator] System.Drawing.Rectangle CellToClientRect(Cognex.InSight.CvsCellRange)

[Cognex.InSight.Controls.Display.ISpreadsheetNavigator] Void Redraw()

Added Property

[Cognex.InSight.Controls.Display.CvsExpressionTreeView] Display (Cognex.InSight.Controls.Display.CvsInSightDisplay)

[Cognex.InSight.Controls.Display.CvsExpressionTreeView] HighlightLocation (Cognex.InSight.CvsCellLocation)

[Cognex.InSight.Controls.Display.CvsExpressionTreeView] InSight (Cognex.InSight.CvsInSight)

[Cognex.InSight.Controls.Display.CvsExpressionTreeView] IsActivated (System.Boolean)

[Cognex.InSight.Controls.Display.CvsExpressionTreeView] MouseCellLocation (Cognex.InSight.CvsCellLocation)

[Cognex.InSight.Controls.Display.CvsExpressionTreeView] Pinned (System.Boolean)

[Cognex.InSight.Controls.Display.CvsExpressionTreeView] SelectedRange (Cognex.InSight.CvsCellRange)

[Cognex.InSight.Controls.Display.CvsInSightDisplay] CurrentCellNow (Cognex.InSight.CvsCellLocation)

[Cognex.InSight.Controls.Display.CvsInSightDisplayEdit] ShowEntireSheet (Cognex.InSight.Controls.CvsActionToggle)

[Cognex.InSight.Controls.Display.CvsInSightDisplayHistory] NavigateBack (Cognex.InSight.Controls.CvsAction)

[Cognex.InSight.Controls.Display.CvsInSightDisplayHistory] NavigateForward (Cognex.InSight.Controls.CvsAction)

[Cognex.InSight.Controls.Display.CvsSpreadsheetNavigator] Display (Cognex.InSight.Controls.Display.CvsInSightDisplay)

[Cognex.InSight.Controls.Display.CvsSpreadsheetNavigator] IsActivated (System.Boolean)

[Cognex.InSight.Controls.Display.CvsSpreadsheetNavigator] ShowToolTips (System.Boolean)

[Cognex.InSight.Controls.Display.ISpreadsheetNavigator] BlahBrush (System.Drawing.Brush)

[Cognex.InSight.Controls.Display.ISpreadsheetNavigator] Display (Cognex.InSight.Controls.Display.CvsInSightDisplay)

Added CustomAttribute

[Event] Cognex.InSight.Controls.Display.CvsInSightDisplay.CurrentCellNowChanged::[System.ComponentModel.BrowsableAttribute((Boolean)False)]

[Method] Cognex.InSight.Controls.Display.CvsInSightDisplay.GotoCell::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Method] Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.OpenImageFromFile::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Method] Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.OpenJobFromFile::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsExpressionTreeView.HighlightLocation::[System.ComponentModel.BrowsableAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsExpressionTreeView.HighlightLocation::[System.ComponentModel.DesignerSerializationVisibilityAttribute((System.ComponentModel.DesignerSerializationVisibility)0)]

[Property] Cognex.InSight.Controls.Display.CvsExpressionTreeView.InSight::[System.ComponentModel.BrowsableAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsExpressionTreeView.InSight::[System.ComponentModel.DesignerSerializationVisibilityAttribute((System.ComponentModel.DesignerSerializationVisibility)0)]

[Property] Cognex.InSight.Controls.Display.CvsExpressionTreeView.MouseCellLocation::[System.ComponentModel.BrowsableAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsExpressionTreeView.MouseCellLocation::[System.ComponentModel.DesignerSerializationVisibilityAttribute((System.ComponentModel.DesignerSerializationVisibility)0)]

[Property] Cognex.InSight.Controls.Display.CvsExpressionTreeView.SelectedRange::[System.ComponentModel.BrowsableAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsExpressionTreeView.SelectedRange::[System.ComponentModel.DesignerSerializationVisibilityAttribute((System.ComponentModel.DesignerSerializationVisibility)0)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplay.CurrentCellNow::[System.ComponentModel.BrowsableAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplay.CurrentCellNow::[System.ComponentModel.DesignerSerializationVisibilityAttribute((System.ComponentModel.DesignerSerializationVisibility)0)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplay.CurrentCellNow::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.OpenImage::[Cognex.InSight.Controls.CvsShortcutAttribute((System.Windows.Forms.Keys)196687)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.SaveImageAs::[Cognex.InSight.Controls.CvsShortcutAttribute((System.Windows.Forms.Keys)196691)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowEntireSheet::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowImageSaturation::[Cognex.InSight.Controls.CvsShortcutAttribute((System.Windows.Forms.Keys)196674)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplayHistory.NavigateBack::[Cognex.InSight.Controls.CvsShortcutAttribute((System.Windows.Forms.Keys)262181)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplayHistory.NavigateForward::[Cognex.InSight.Controls.CvsShortcutAttribute((System.Windows.Forms.Keys)262183)]

[Property] Cognex.InSight.Controls.Display.CvsSpreadsheetNavigator.Display::[System.ComponentModel.DefaultValueAttribute((String)null)]

[Property] Cognex.InSight.Controls.Display.CvsSpreadsheetNavigator.Display::[System.ComponentModel.DescriptionAttribute("The display control with which this control is associated.")]

[Property] Cognex.InSight.Controls.Display.CvsSpreadsheetNavigator.ShowToolTips::[System.ComponentModel.DefaultValueAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsSpreadsheetNavigator.ShowToolTips::[System.ComponentModel.DescriptionAttribute("Whether or not to display the cell contents tooltips.")]

[Type] Cognex.InSight.Controls.Display.CvsExpressionTreeView::[Cognex.Explorer.ToolWindowAttribute("ExpressionTree", Icon = 495, InitialSite = 7)]

[Type] Cognex.InSight.Controls.Display.CvsSpreadsheetNavigator::[Cognex.Explorer.ToolWindowAttribute("SpreadsheetNavigator", Icon = 493, InitialSite = 5)]

Removed Method

[Cognex.InSight.Controls.Display.CvsInSightDisplay] Void Connect(System.String, System.String, System.String, Cognex.InSight.CvsAdvancedCapabilities, Boolean)

Removed CustomAttribute

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.ShowImageSaturation::[Cognex.InSight.Controls.CvsShortcutAttribute((System.Windows.Forms.Keys)196691)]

API Changes - Cognex.InSight.dll (4.9.2511.0 to 4.9.553.1)

Removed Type

Cognex.InSight.CvsAdvancedCapabilities

Removed Constructor

[Cognex.InSight.CvsAdvancedCapabilities] Void .ctor(Boolean, System.Uri, Boolean, Boolean)

[Cognex.InSight.CvsAdvancedCapabilities] Void .ctor()

Removed Method

[Cognex.InSight.CvsAdvancedCapabilities] Cognex.InSight.CvsAdvancedCapabilities Create(System.Collections.IDictionary)

Removed Property

[Cognex.InSight.CvsAdvancedCapabilities] ImprovedEncryptionSupported (System.Boolean)

[Cognex.InSight.CvsInSight] AdvancedCapabilities (Cognex.InSight.CvsAdvancedCapabilities)

Removed CustomAttribute

[Type] Cognex.InSight.CvsAdvancedCapabilities::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)True)]

[Type] Cognex.InSight.CvsAdvancedCapabilities::[System.Runtime.InteropServices.GuidAttribute("9AA9E5E8-D711-4B4A-8EEA-066B638B3DE0")]

Added Type

Cognex.InSight.CvsCellComment

Added Enumeration

Cognex.InSight.Sensor.CvsNetworkLinkModes

Added EnumerationMember

[Cognex.InSight.Sensor.CvsHostSubtype] InSight7000EZSeries

[Cognex.InSight.Sensor.CvsHostSubtype] InSightMotoSightSeries

[Cognex.InSight.Sensor.CvsNetworkLinkModes] AutoNegotiation

[Cognex.InSight.Sensor.CvsNetworkLinkModes] Force1000Full

[Cognex.InSight.Sensor.CvsNetworkLinkModes] Force100Full

[Cognex.InSight.Sensor.CvsNetworkLinkModes] Force100Half

[Cognex.InSight.Sensor.CvsNetworkLinkModes] Force10Full

[Cognex.InSight.Sensor.CvsNetworkLinkModes] Force10Half

[Cognex.InSight.Sensor.CvsNetworkLinkModes] Unknown

Added Field

[Cognex.InSight.CvsCellComment] DefaultFlagColor (System.Drawing.Color)

[Cognex.InSight.CvsCellComment] Empty (Cognex.InSight.CvsCellComment)

Added Constructor

[Cognex.InSight.CvsCellComment] Void .ctor(System.String)

[Cognex.InSight.CvsCellComment] Void .ctor(System.String, System.Drawing.Color)

[Cognex.InSight.CvsCellComment] Void .ctor(Cognex.InSight.CvsCellComment)

Added Method

[Cognex.InSight.CvsCellComment] Boolean Equals(System.Object)

[Cognex.InSight.CvsCellComment] Int32 GetHashCode()

[Cognex.InSight.CvsInSight] Void ClearComment(Cognex.InSight.CvsCellLocation)

[Cognex.InSight.CvsInSight] Void ClearComment(Int32, Int32)

[Cognex.InSight.CvsInSight] Cognex.InSight.CvsCellComment GetComment(Cognex.InSight.CvsCellLocation)

[Cognex.InSight.CvsInSight] Cognex.InSight.CvsCellComment GetComment(Int32, Int32)

[Cognex.InSight.CvsInSight] Void SetComment(Cognex.InSight.CvsCellLocation, Cognex.InSight.CvsCellComment)

[Cognex.InSight.CvsInSight] Void SetComment(Int32, Int32, Cognex.InSight.CvsCellComment)

[Cognex.InSight.CvsInSight] Void SetInteger(Cognex.InSight.CvsCellLocation, Int32, Boolean)

[Cognex.InSight.Sensor.CvsSensor] Void ValidateCellName(System.String)

Added Property

[Cognex.InSight.CvsCellComment] FlagColor (System.Drawing.Color)

[Cognex.InSight.CvsCellComment] Text (System.String)

[Cognex.InSight.CvsFeatureLicense] LicenseFilePath (System.String)

[Cognex.InSight.CvsInSight] IsJobProtected (System.Boolean)

[Cognex.InSight.Sensor.CvsDiscreteOutputLine] IsHighSpeed (System.Boolean)

[Cognex.InSight.Sensor.CvsNetworkSettings] LinkMode (Cognex.InSight.Sensor.CvsNetworkLinkModes)

[Cognex.InSight.Sensor.CvsNetworkSettings] SupportedLinkModes (Cognex.InSight.Sensor.CvsNetworkLinkModes[])

[Cognex.InSight.Sensor.CvsSensor] AuditMessagesSupported (System.Boolean)

[Cognex.InSight.Sensor.CvsSensor] MaxCellNameLength (System.Int32)

[Cognex.InSight.Sensor.CvsSettings] ForceNetworkLinkModeSupported (System.Boolean)

Added CustomAttribute

[Method] Cognex.InSight.CvsInSight.ClearComment::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Method] Cognex.InSight.CvsInSight.ClearComment::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Method] Cognex.InSight.CvsInSight.GetComment::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Method] Cognex.InSight.CvsInSight.GetComment::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Method] Cognex.InSight.CvsInSight.SetComment::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Method] Cognex.InSight.CvsInSight.SetComment::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Type] Cognex.InSight.CvsCellComment::[System.Runtime.InteropServices.GuidAttribute("41D2241E-0F61-4080-B953-19B1881B628D")]

[Type] Cognex.InSight.CvsCellComment::[System.SerializableAttribute()]

[Type] Cognex.InSight.Sensor.CvsNetworkLinkModes::[System.Runtime.InteropServices.GuidAttribute("5C0B4D9A-E05B-4FAB-A492-7477873B1514")]

Changed Method

ReturnType changed:

Old Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.CvsCellLocation, Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
New Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.CvsCellLocation, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

ReturnType changed:

Old Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.CvsEasyViewItem, Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
New Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.CvsEasyViewItem, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

ReturnType changed:

Old Value: Cognex.InSight.CvsEasyView, Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsEasyView, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsSymbolicTagCollection, Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsSymbolicTagCollection, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Graphic.CvsGraphic, Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Graphic.CvsGraphic, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Graphic.CvsGraphicBlobPoint[], Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Graphic.CvsGraphicBlobPoint[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Graphic.CvsPatternMatchSegment[], Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Graphic.CvsPatternMatchSegment[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.Sensor.CvsRemoteSubnetEntry, Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
New Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.Sensor.CvsRemoteSubnetEntry, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsSettings, Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsSettings, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsSntpCurrentData, Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsSntpCurrentData, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsTimeZones, Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsTimeZones, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsInSightFeatureFamily, Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsInSightFeatureFamily, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsIOModule[], Cognex.InSight, Version=4.9.2511.0, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsIOModule[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935

Copyright (c) 2004-2014 Cognex Corporation.


4.9.1 to 4.9.3

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (4.9.553.1 to 4.9.101.3)

Added Method

[Cognex.InSight.Controls.Display.CvsInSightDisplayEdit] Boolean OpenJobFromFile(System.String, Boolean)

Added Property

[Cognex.InSight.Controls.Display.CvsInSightDisplayEdit] EditJobServerSettings (Cognex.InSight.Controls.CvsAction)

Added CustomAttribute

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplayEdit.EditJobServerSettings::[Cognex.InSight.Controls.Display.CvsInSightDisplayEdit+NotInDialogModeAttribute()]

API Changes - Cognex.InSight.dll (4.9.553.1 to 4.9.101.3)

Added Type

Cognex.InSight.Sensor.CvsJobServerSettings

Added Field

[Cognex.InSight.Sensor.CvsJobServerSettings] DefaultFtpPort (System.Int32)

[Cognex.InSight.Sensor.CvsJobServerSettings] MaximumHostnameLength (System.Int32)

[Cognex.InSight.Sensor.CvsJobServerSettings] MaximumPasswordLength (System.Int32)

[Cognex.InSight.Sensor.CvsJobServerSettings] MaximumUsernameLength (System.Int32)

Added Method

[Cognex.InSight.CvsFileManager] Void LoadJobFile(System.String, Boolean)

[Cognex.InSight.CvsFileManager] Void LoadJobFile(System.String, System.String, System.String, Boolean)

[Cognex.InSight.CvsFileManager] Void SaveJobFile(System.String, Boolean)

[Cognex.InSight.Sensor.CvsHost] Boolean IsValidHostNameChar(Char, Boolean)

[Cognex.InSight.Sensor.CvsJobServerSettings] System.Object Clone()

[Cognex.InSight.Sensor.CvsJobServerSettings] Int32 ToFtpPortRangeOrDefault(Int32)

Added Property

[Cognex.InSight.Sensor.CvsJobServerSettings] Enabled (System.Boolean)

[Cognex.InSight.Sensor.CvsJobServerSettings] HostName (System.String)

[Cognex.InSight.Sensor.CvsJobServerSettings] Password (System.String)

[Cognex.InSight.Sensor.CvsJobServerSettings] Port (System.Int32)

[Cognex.InSight.Sensor.CvsJobServerSettings] Username (System.String)

[Cognex.InSight.Sensor.CvsSensor] RemoteJobServerSupported (System.Boolean)

[Cognex.InSight.Sensor.CvsSettings] JobServerSettings (Cognex.InSight.Sensor.CvsJobServerSettings)

[Cognex.InSight.Sensor.CvsSettings] RemoteJobServerSupported (System.Boolean)

Added CustomAttribute

[Type] Cognex.InSight.Sensor.CvsJobServerSettings::[System.Runtime.InteropServices.GuidAttribute("26A5E421-3E9C-4FC1-A403-544EF349BEEB")]

[Type] Cognex.InSight.Sensor.CvsJobServerSettings::[System.SerializableAttribute()]

Changed Method

ReturnType changed:

Old Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.CvsCellLocation, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
New Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.CvsCellLocation, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

ReturnType changed:

Old Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.CvsEasyViewItem, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
New Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.CvsEasyViewItem, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

ReturnType changed:

Old Value: Cognex.InSight.CvsEasyView, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsEasyView, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsSymbolicTagCollection, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsSymbolicTagCollection, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Graphic.CvsGraphic, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Graphic.CvsGraphic, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Graphic.CvsGraphicBlobPoint[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Graphic.CvsGraphicBlobPoint[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Graphic.CvsPatternMatchSegment[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Graphic.CvsPatternMatchSegment[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.Sensor.CvsRemoteSubnetEntry, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
New Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.Sensor.CvsRemoteSubnetEntry, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsSettings, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsSettings, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsSntpCurrentData, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsSntpCurrentData, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsTimeZones, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsTimeZones, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsInSightFeatureFamily, Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsInSightFeatureFamily, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsIOModule[], Cognex.InSight, Version=4.9.553.1, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsIOModule[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935

Copyright (c) 2004-2014 Cognex Corporation.


4.9.3 to 5.1.0

API Changes

API Changes - Cognex.InSight.Controls.Display.dll (4.9.101.3 to 5.1.3154.0)

Added Type

Cognex.InSight.Controls.Display.CvsCellClickEventArgs

Cognex.InSight.Controls.Display.CvsDisplayStateChangedEventArgs

Cognex.InSight.Controls.Display.ImageSettings

Cognex.InSight.Controls.Display.SynchronizedInspectionParametersDialog

Added Event

[Cognex.InSight.Controls.Display.CvsInSightDisplay] StateChanged (Cognex.InSight.Controls.Display.CvsDisplayStateChangedEventHandler)

Added Enumeration

Cognex.InSight.Controls.Display.CvsDisplayStateChange

Added EnumerationMember

[Cognex.InSight.Controls.Display.CvsDisplayState] DialogOpenedByPeer

[Cognex.InSight.Controls.Display.CvsDisplayStateChange] DisplayChanged

[Cognex.InSight.Controls.Display.CvsDisplayStateChange] Popped

[Cognex.InSight.Controls.Display.CvsDisplayStateChange] Pushed

[Cognex.InSight.Controls.Display.CvsDisplayStateChange] Undefined

Added Constructor

[Cognex.InSight.Controls.Display.CvsCellClickEventHandler] Void .ctor(System.Object, IntPtr)

[Cognex.InSight.Controls.Display.CvsDisplayStateChangedEventArgs] Void .ctor(Cognex.InSight.Controls.Display.CvsDisplayState, Cognex.InSight.Controls.Display.CvsDisplayState, Cognex.InSight.Controls.Display.CvsDisplayStateChange)

[Cognex.InSight.Controls.Display.CvsDisplayStateChangedEventHandler] Void .ctor(System.Object, IntPtr)

[Cognex.InSight.Controls.Display.CvsInSightDisplay+ImageSettings] Void .ctor()

[Cognex.InSight.Controls.Display.CvsInSightDisplay+ImageSettings] Void .ctor(Cognex.InSight.Controls.Display.CvsInSightDisplay)

[Cognex.InSight.Controls.Display.SynchronizedInspectionParametersDialog] Void .ctor(Cognex.InSight.Sensor.CvsSensor)

Added Delegate

Cognex.InSight.Controls.Display.CvsCellClickEventHandler

Cognex.InSight.Controls.Display.CvsDisplayStateChangedEventHandler

Added Method

[Cognex.InSight.Controls.Display.CvsCellClickEventHandler] System.IAsyncResult BeginInvoke(System.Object, Cognex.InSight.Controls.Display.CvsCellClickEventArgs, System.AsyncCallback, System.Object)

[Cognex.InSight.Controls.Display.CvsCellClickEventHandler] Void EndInvoke(System.IAsyncResult)

[Cognex.InSight.Controls.Display.CvsCellClickEventHandler] Void Invoke(System.Object, Cognex.InSight.Controls.Display.CvsCellClickEventArgs)

[Cognex.InSight.Controls.Display.CvsDisplayStateChangedEventHandler] System.IAsyncResult BeginInvoke(System.Object, Cognex.InSight.Controls.Display.CvsDisplayStateChangedEventArgs, System.AsyncCallback, System.Object)

[Cognex.InSight.Controls.Display.CvsDisplayStateChangedEventHandler] Void EndInvoke(System.IAsyncResult)

[Cognex.InSight.Controls.Display.CvsDisplayStateChangedEventHandler] Void Invoke(System.Object, Cognex.InSight.Controls.Display.CvsDisplayStateChangedEventArgs)

[Cognex.InSight.Controls.Display.CvsInSightDisplay] Void AcceptUpdate()

[Cognex.InSight.Controls.Display.CvsInSightDisplay+ImageSettings] ImageSettings Clone()

[Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback] Void RequestThumbnailImagesUpdate(Int32, Int32, Int32)

[Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue] Void RequestThumbnailImagesUpdate(Int32, Int32, Int32)

Added Property

[Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridController] IsCalibrated (System.Boolean)

[Cognex.InSight.Controls.Display.CvsCellClickEventArgs] Cell (Cognex.InSight.Cell.CvsCell)

[Cognex.InSight.Controls.Display.CvsCellClickEventArgs] Handled (System.Boolean)

[Cognex.InSight.Controls.Display.CvsCellClickEventArgs] Location (Cognex.InSight.CvsCellLocation)

[Cognex.InSight.Controls.Display.CvsCellClickEventArgs] Mouse (System.Windows.Forms.MouseEventArgs)

[Cognex.InSight.Controls.Display.CvsDisplayStateChangedEventArgs] NewState (Cognex.InSight.Controls.Display.CvsDisplayState)

[Cognex.InSight.Controls.Display.CvsDisplayStateChangedEventArgs] OldState (Cognex.InSight.Controls.Display.CvsDisplayState)

[Cognex.InSight.Controls.Display.CvsDisplayStateChangedEventArgs] Reason (Cognex.InSight.Controls.Display.CvsDisplayStateChange)

[Cognex.InSight.Controls.Display.CvsInSightDisplay] SheetContext (Cognex.InSight.CvsSheetContext)

[Cognex.InSight.Controls.Display.CvsInSightDisplay] SheetIndex (System.Int32)

[Cognex.InSight.Controls.Display.CvsInSightDisplay+ImageSettings] Id (System.Int32)

[Cognex.InSight.Controls.Display.CvsInSightDisplay+ImageSettings] ImageOffset (System.Nullable`1[System.Drawing.PointF])

[Cognex.InSight.Controls.Display.CvsInSightDisplay+ImageSettings] ImageScale (System.Nullable`1[System.Double])

[Cognex.InSight.Controls.Display.CvsInSightDisplay+ImageSettings] ImageZoomMode (System.Nullable`1[Cognex.InSight.Controls.Display.CvsDisplayZoom])

[Cognex.InSight.Controls.Display.CvsInSightDisplayEdit] SynchronizedInspectionParameters (Cognex.InSight.Controls.CvsAction)

[Cognex.InSight.Controls.Display.CvsSpreadsheetNavigator] Displays (System.Collections.Generic.IEnumerable`1[Cognex.InSight.Controls.Display.CvsInSightDisplay])

[Cognex.InSight.Controls.Filmstrip.CvsFilmstrip] ImageIndex (System.Int32)

Added CustomAttribute

[Method] Cognex.InSight.Controls.Display.CvsInSightDisplay.AcceptUpdate::[System.ComponentModel.BrowsableAttribute((Boolean)False)]

[Method] Cognex.InSight.Controls.Display.CvsInSightDisplay.AcceptUpdate::[System.ComponentModel.DesignerSerializationVisibilityAttribute((System.ComponentModel.DesignerSerializationVisibility)0)]

[Method] Cognex.InSight.Controls.Display.CvsInSightDisplay.AcceptUpdate::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplay.SheetContext::[System.ComponentModel.BrowsableAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplay.SheetContext::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplay.SheetIndex::[System.ComponentModel.BrowsableAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplay.SheetIndex::[System.ComponentModel.DesignerSerializationVisibilityAttribute((System.ComponentModel.DesignerSerializationVisibility)0)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplay.SheetIndex::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplay.VisibleRange::[System.ComponentModel.BrowsableAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Display.CvsInSightDisplay+ImageSettings.Id::[System.Xml.Serialization.XmlAttributeAttribute("id")]

[Property] Cognex.InSight.Controls.Display.CvsSpreadsheetNavigator.Displays::[System.ComponentModel.DescriptionAttribute("The display controls this navigator communicates with.")]

[Property] Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.ImageIndex::[System.ComponentModel.BrowsableAttribute((Boolean)False)]

[Property] Cognex.InSight.Controls.Filmstrip.CvsFilmstrip.ImageIndex::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

Removed Interface

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintView

Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView

Cognex.InSight.Controls.Display.ISpreadsheetNavigator

Removed Event

[Cognex.InSight.Controls.Display.CvsInSightDisplay] StateChanged (System.EventHandler)

Removed Method

[Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings] Void ReadCalibrationDataFromSensor(Cognex.InSight.CvsInSight, Cognex.InSight.CvsCellLocation, Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridUnit ByRef, Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateDistortionModel ByRef)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintView] Void Initialize(Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintViewController)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView] Void Initialize(Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupController)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView] Void ShowUnits(System.String[])

[Cognex.InSight.Controls.Display.ISpreadsheetNavigator] System.Drawing.Rectangle CellToClientRect(Cognex.InSight.CvsCellLocation)

[Cognex.InSight.Controls.Display.ISpreadsheetNavigator] System.Drawing.Rectangle CellToClientRect(Cognex.InSight.CvsCellRange)

[Cognex.InSight.Controls.Display.ISpreadsheetNavigator] Void Redraw()

[Cognex.InSight.Controls.Filmstrip.CvsFilmstripPlayback] Void RequestThumbnailImagesUpdate(Int32, Int32)

[Cognex.InSight.Controls.Filmstrip.CvsFilmstripResultsQueue] Void RequestThumbnailImagesUpdate(Int32, Int32)

Removed Property

[Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings] DistortionModel (Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateDistortionModel)

[Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings] GridType (Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridType)

[Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings] GridUnit (Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridUnit)

[Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridSettings] MotionCapability (Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridMotion)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintView] GridSpacing (System.Double)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintView] GridType (Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridType)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridPrintView] GridUnit (Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridUnit)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView] GridSpacing (System.Double)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView] GridType (Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateGridType)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView] GridUnitIndex (System.Int32)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView] GridUnitsEnabled (System.Boolean)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView] LensDistortionModel (Cognex.InSight.Controls.Display.CalibrateGrid.CvsCalibrateDistortionModel)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView] MovementEnabled (System.Boolean)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView] Notes (System.String)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView] NumberOfPoses (System.Int32)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView] PoseLocationAutomatic (System.Boolean)

[Cognex.InSight.Controls.Display.CalibrateGrid.ICalibrateGridSetupView] PoseLocationMovementFlags (Cognex.InSight.Controls.Display.CalibrateGrid.CvsPoseLocationMovementFlags)

[Cognex.InSight.Controls.Display.ISpreadsheetNavigator] BlahBrush (System.Drawing.Brush)

[Cognex.InSight.Controls.Display.ISpreadsheetNavigator] Display (Cognex.InSight.Controls.Display.CvsInSightDisplay)

API Changes - Cognex.InSight.dll (4.9.101.3 to 5.1.3154.0)

Added Type

Cognex.InSight.Sensor.CvsHostSubtypeExtensions

Added Exception

Cognex.InSight.CvsInvalidInsertException

Added EnumerationMember

[Cognex.InSight.Cell.CvsCellDataType] Unknown

[Cognex.InSight.Sensor.CvsHostSubtype] InSight8405

[Cognex.InSight.Sensor.CvsHostSubtype] InSightEZ700Series

[Cognex.InSight.Sensor.CvsHostSubtype] InSightVCSeries

[Cognex.InSight.Sensor.CvsOutputListType] SynchronizerSupport

[Cognex.InSight.Sensor.CvsOutputType] SynchronizerComplete

[Cognex.InSight.Sensor.CvsOutputType] SynchronizerFail

[Cognex.InSight.Sensor.CvsStrobeStartPositionType] AllRowsExposed

Added Field

[Cognex.InSight.CvsCellLocation] MaxSheet (System.Int32)

[Cognex.InSight.CvsCellLocation] PropertySheet (Cognex.InSight.CvsCellLocation)

[Cognex.InSight.Net.CvsHostSensor] VisionControllerModelNumberSubstring (System.String)

[Cognex.InSight.Sensor.CvsDiscreteInputLine] MaxInputLines (System.Int32)

[Cognex.InSight.Sensor.CvsDiscreteOutputLine] MaxOutputLines (System.Int32)

[Cognex.InSight.Sensor.CvsDiscreteOutputLine] SynchronizerOutputTypes (Cognex.InSight.Sensor.CvsOutputType[])

Added Constructor

[Cognex.InSight.CvsCellLocation] Void .ctor(System.String, Cognex.InSight.CvsSheetContext)

[Cognex.InSight.CvsCellLocation] Void .ctor(Int32, Int32, Cognex.InSight.CvsSheetContext)

[Cognex.InSight.CvsCellRange] Void .ctor(System.String, Cognex.InSight.CvsSheetContext)

[Cognex.InSight.CvsReferenceRange] Void .ctor(Cognex.InSight.CvsReferenceRange)

Added Method

[Cognex.InSight.Cell.CvsCellCollection] Cognex.InSight.Cell.CvsCell GetCell(Int32, Int32, Int32)

[Cognex.InSight.Cell.CvsCellString] Byte[] GetRawBytes()

[Cognex.InSight.CvsCellLocation] Int32 CombineSheetColumn(Int32, Int32)

[Cognex.InSight.CvsCellLocation] Int32 GetHashCode(Int32, Int32, Int32)

[Cognex.InSight.CvsCellLocation] Cognex.InSight.CvsCellLocation Parse(System.String, Cognex.InSight.CvsSheetContext)

[Cognex.InSight.CvsCellLocation] Void ResolveStringName(Cognex.InSight.CvsSheetContext)

[Cognex.InSight.CvsCellLocation] Void SplitSheetColumn(Int32, Int32 ByRef, Int32 ByRef)

[Cognex.InSight.CvsCellLocation] System.String ToString(Boolean, Boolean, Cognex.InSight.CvsSheetContext)

[Cognex.InSight.CvsCellLocation] System.String TryNormalizeCell(System.String, Cognex.InSight.CvsSheetContext)

[Cognex.InSight.CvsCellLocation] Cognex.InSight.CvsCellLocation TryParse(System.String, Cognex.InSight.CvsSheetContext)

[Cognex.InSight.CvsCellRange] Boolean Equals(Cognex.InSight.CvsCellRange)

[Cognex.InSight.CvsCellRange] Cognex.InSight.CvsCellRange TryParse(System.String, Cognex.InSight.CvsSheetContext)

[Cognex.InSight.CvsFileManager] Void SendImageToInSight(System.String, Int32)

[Cognex.InSight.CvsInSight] Void AcceptUpdate()

[Cognex.InSight.CvsJobInfo] Boolean IsInCustomView(Cognex.InSight.CvsCellLocation)

[Cognex.InSight.CvsJobInfo] Void SwitchAllCurrentViews(Boolean)

[Cognex.InSight.CvsResultSet] Cognex.InSight.CvsImage GetImage(Int32)

[Cognex.InSight.CvsView] Boolean Shift(Cognex.InSight.CvsCellRange, Boolean)

[Cognex.InSight.Sensor.CvsHostSubtypeExtensions] Boolean Is7000Series(Cognex.InSight.Sensor.CvsHostSubtype)

[Cognex.InSight.Sensor.CvsSettings] System.Collections.Generic.IEnumerable`1[System.String] GetNetworkNames()

[Cognex.InSight.Sensor.CvsSettings] Cognex.InSight.Sensor.CvsNetworkSettings GetNetworkSettings(System.String)

Added Property

[Cognex.InSight.Cell.CvsCellString] AsciiText (System.String)

[Cognex.InSight.CvsCellRange] EntireJob (Cognex.InSight.CvsCellRange)

[Cognex.InSight.CvsImage] ResolutionScale (System.Int32)

[Cognex.InSight.CvsInvalidInsertException] CellLocation (Cognex.InSight.CvsCellLocation)

[Cognex.InSight.CvsJobInfo] AnyCustomViews (System.Boolean)

[Cognex.InSight.CvsJobInfo] HasCustomView (System.Boolean)

[Cognex.InSight.CvsJobInfo] NumberOfSheets (System.Int32)

[Cognex.InSight.CvsJobInfo] SheetContext (Cognex.InSight.CvsSheetContext)

[Cognex.InSight.CvsJobInfo] SupportsSheets (System.Boolean)

[Cognex.InSight.CvsResultSet] Images (Cognex.InSight.CvsImage[])

[Cognex.InSight.CvsView] IsCustomView (System.Boolean)

[Cognex.InSight.CvsView] IsDefined (System.Boolean)

[Cognex.InSight.Net.CvsHostSensor] NumberOfSupportedCameras (System.Int32)

[Cognex.InSight.Sensor.CvsSensor] BufferSize (System.Int32)

[Cognex.InSight.Sensor.CvsSensor] EncoderOutputSupported (System.Boolean)

[Cognex.InSight.Sensor.CvsSensor] MultiSheetSupported (System.Boolean)

[Cognex.InSight.Sensor.CvsSensor] ScriptingSupported (System.Boolean)

[Cognex.InSight.Sensor.CvsSensor] SupportedProtocols (Cognex.InSight.Sensor.CvsProtocolServices)

[Cognex.InSight.Sensor.CvsSensor] TestRunSupported (System.Boolean)

[Cognex.InSight.Sensor.CvsSettings] IOCameraMaskSupported (System.Boolean)

[Cognex.InSight.Sensor.CvsSettings] ScriptingSupported (System.Boolean)

[Cognex.InSight.Sensor.CvsSettings] TestRunSupported (System.Boolean)

Added CustomAttribute

[Method] Cognex.InSight.Sensor.CvsHostSubtypeExtensions.Is7000Series::[System.Runtime.CompilerServices.ExtensionAttribute()]

[Property] Cognex.InSight.CvsImage.Resolution::[System.ObsoleteAttribute()]

[Property] Cognex.InSight.Net.CvsHostSensor.NumberOfSupportedCameras::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Type] Cognex.InSight.CvsInvalidInsertException::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

[Type] Cognex.InSight.Sensor.CvsHostSubtypeExtensions::[System.Runtime.CompilerServices.ExtensionAttribute()]

[Type] Cognex.InSight.Sensor.CvsHostSubtypeExtensions::[System.Runtime.InteropServices.ComVisibleAttribute((Boolean)False)]

Removed Event

[Cognex.InSight.CvsJobInfo] Changed (System.EventHandler)

Removed EnumerationMember

[Cognex.InSight.Sensor.CvsHostSubtype] InSight7000EZSeries

Removed Method

[Cognex.InSight.CvsJobInfo] Void SwitchCurrentView(Boolean)

[Cognex.InSight.Net.CvsNetworkListener] System.String GetDefaultHostName(Cognex.InSight.Net.CvsHostSensor)

Removed Property

[Cognex.InSight.CvsJobInfo] CurrentView (Cognex.InSight.CvsView)

[Cognex.InSight.CvsJobInfo] CustomView (Cognex.InSight.CvsView)

[Cognex.InSight.CvsJobInfo] CustomViewDisplayGraphics (System.Boolean)

[Cognex.InSight.CvsJobInfo] CustomViewDisplayImage (System.Boolean)

[Cognex.InSight.CvsJobInfo] CustomViewDisplayOverlay (System.Boolean)

[Cognex.InSight.CvsJobInfo] IsCustomView (System.Boolean)

[Cognex.InSight.CvsJobInfo] NormalView (Cognex.InSight.CvsView)

[Cognex.InSight.Sensor.CvsSettings] ExternalLightSettingsSupported (System.Boolean)

Changed Method

ReturnType changed:

Old Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.CvsCellLocation, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
New Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.CvsCellLocation, Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

ReturnType changed:

Old Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.CvsEasyViewItem, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
New Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.CvsEasyViewItem, Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

ReturnType changed:

Old Value: Cognex.InSight.CvsEasyView, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsEasyView, Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsSymbolicTagCollection, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsSymbolicTagCollection, Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Graphic.CvsGraphic, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Graphic.CvsGraphic, Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Graphic.CvsGraphicBlobPoint[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Graphic.CvsGraphicBlobPoint[], Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Graphic.CvsPatternMatchSegment[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Graphic.CvsPatternMatchSegment[], Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.CvsImageLocation[], Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.Sensor.CvsRemoteSubnetEntry, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
New Value: System.Collections.Generic.IEnumerator`1[[Cognex.InSight.Sensor.CvsRemoteSubnetEntry, Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935]], mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsSettings, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsSettings, Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsSntpCurrentData, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsSntpCurrentData, Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsTimeZones, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsTimeZones, Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsInSightFeatureFamily, Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsInSightFeatureFamily, Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

ReturnType changed:

Old Value: Cognex.InSight.Sensor.CvsIOModule[], Cognex.InSight, Version=4.9.101.3, Culture=neutral, PublicKeyToken=6b9774afddb09935
New Value: Cognex.InSight.Sensor.CvsIOModule[], Cognex.InSight, Version=5.1.3154.0, Culture=neutral, PublicKeyToken=6b9774afddb09935

Copyright (c) 2004-2014 Cognex Corporation.


How Do I: Create a new In-Sight Application

How Do I
Create a new In-Sight Application

The following tutorials walk you through the process of creating an In-Sight application from scratch and integrating the Cognex In-Sight Display (CvsInSightDisplay) control into a custom C# or VB.NET application:

  • How to create a new In-Sight Application in C# with Visual Studio .NET 2012
  • How to create a new In-Sight Application in VB.NET with Visual Studio .NET 2012


How Do I: Create a new In-Sight Application in C# with Visual Studio .NET 2012

How Do I
Create a new In-Sight Application in C# with Visual Studio .NET 2012

The following tutorial walks you through the process of creating an In-Sight application from scratch and integrating the Cognex In-Sight Display (CvsInSightDisplay) control into a custom C# application to display the image, graphics and spreadsheet from an In-Sight sensor.

  1. Start Microsoft Visual Studio .NET 2012.

  2. Select File > New > Project.

  3. In the left-hand pane, select Visual C#. In the right-hand pane, select Windows Forms Application.

  4. Name the project DisplayTest and click OK.

  5. In the Solution Explorer, right-click your project and select Properties.

  6. Select the Application tab.

  7. Ensure that the Target Framework is set to .NET Framework 4.5.

  8. Select the Build tab.

  9. Under General, change the Platform Target to x86.

  10. In the Solution Explorer, right-click References and select Add Reference.

  11. In the Reference Manager, select Assemblies > Extensions.

    12. Note: In order to easily find the Cognex assemblies, you may need to sort the Component Name column by clicking on the header once or twice to sort the names alphabetically.

  12. Select the following:

    • Cognex.InSight (6.5.6.0)

    • Cognex.InSight.Controls.Display (6.5.6.0)

  13. Click OK.

  14. Open Form1 in the Designer View.

  15. On the View menu, select Toolbox.

  16. If the CvsInSightDisplay control is not shown in your Toolbox window, do the following:

    1. Right-click the Toolbox and select Choose Items...

    2. Select the .NET Framework Components tab.

    3. Sort the rows by Name.

    4. Locate the CvsInSightDisplay component in the list and place a check mark next to it.

      5. If CvsInSightDisplay does not appear in the list:

      • Click Browse and navigate to the following location:

        • [32-bit OS] %ProgramFiles%\Common Files\Cognex\In-Sight\6.5.6.0

        • [64-bit OS] %ProgramFiles(x86)%\Common Files\Cognex\In-Sight\6.5.6.0

      • Select Cognex.InSight.Controls.Display.dll and click Open.

      • The CvsInSightDisplay component should now appear in the list and can be selected.

        • Note: This selection is part of the Visual Studio design environment (not part of your project), so you should only have to do this once.

    5. Click OK to close the Choose Toolbox Items dialog.

  10. Select CvsInSightDisplay in the toolbox.

  11. Click-and-drag on Form1 to create an instance of the CvsInSightDisplay control.

  12. On Form1, right-click the CvsInSightDisplay control and select Properties.

  13. In the Properties window, locate the AutoConnectString property and set it as follows:

    127.0.0.1,admin

    but replace the IP address in this example with the IP address of an In-Sight sensor or emulator on your network.

    If you don't know the IP address, you can find it by opening In-Sight Explorer and selecting Help > About In-Sight Explorer from the main menu.

    Note: The preceding example of AutoConnectString assumes that the In-Sight sensor has a user named admin with no password. If your sensor or emulator has a password, append it with the password argument as follows:

    127.0.0.1,admin,password

  14. When the AutoConnectString property is set correctly, the CvsInSightDisplay control will connect to the In-Sight sensor and show its image and/or spreadsheet within the Visual Studio design environment. At this point, you can press F5 to run your application. While it is running, you can interact with the display just as you would within the Job View of In-Sight Explorer.

    15. Note: If you receive a FileNotFoundException or BadImageFormatException after running your application:

    then it's likely you're running on a 64-bit OS and need to set the Target CPU to x86. Refer to Troubleshooting 64-bit Operating Systems for details on this process.

  15. Stop your application and return to the Visual Studio design mode.

  16. Open your form (if it is not already open).

  17. Select the CvsInSightDisplay control and experiment with its various properties, such as GridOpacity, ShowGrid and ShowCustomView.


How Do I: Create a new In-Sight Application in VB.NET with Visual Studio .NET 2012

How Do I
Create a new In-Sight Application in VB.NET with Visual Studio .NET 2012

The following tutorial walks you through the process of creating an In-Sight application from scratch and integrating the Cognex In-Sight Display (CvsInSightDisplay) control into a custom VB.NET application to display the image, graphics and spreadsheet from an In-Sight sensor.

  1. Start Microsoft Visual Studio .NET 2012.

  2. Select File > New > Project.

  3. In the left-hand pane, select Other Languages > Visual Basic. In the right-hand pane, select Windows Forms Application.

  4. Name the project DisplayTest and click OK.

  5. In the Solution Explorer, right-click your project and select Properties.

  6. Select the Application tab.

  7. Ensure that the Target Framework is set to .NET Framework 4.5.

  8. Select the Compile tab.

  9. Under Compile Options, change the Target CPU to x86.

  10. Select the References tab.

  11. Click Add...

  12. In the Reference Manager, select Assemblies > Extensions.

    13. Note: In order to easily find the Cognex assemblies, you may need to sort the Component Name column by clicking on the header once or twice to sort the names alphabetically.

  13. Select the following:

    • Cognex.InSight (6.5.6.0)

    • Cognex.InSight.Controls.Display (6.5.6.0)

  14. Click OK.

  15. Open Form1 in the Designer View.

  16. On the View menu, select Toolbox.

  17. If the CvsInSightDisplay control is not shown in your Toolbox window, do the following:

    1. Right-click the Toolbox and select Choose Items...

    2. Select the .NET Framework Components tab.

    3. Sort the rows by Name.

    4. Locate the CvsInSightDisplay component in the list and place a check mark next to it.

      5. If CvsInSightDisplay does not appear in the list:

      • Click Browse and navigate to the following location:

        • [32-bit OS] %ProgramFiles%\Common Files\Cognex\In-Sight\6.5.6.0

        • [64-bit OS] %ProgramFiles(x86)%\Common Files\Cognex\In-Sight\6.5.6.0

      • Select Cognex.InSight.Controls.Display.dll and click Open.

      • The CvsInSightDisplay component should now appear in the list and can be selected.

        • Note: This selection is part of the Visual Studio design environment (not part of your project), so you should only have to do this once.

    5. Click OK to close the Choose Toolbox Items dialog.

  10. Select CvsInSightDisplay in the toolbox. Click-and-drag to create one on your form.

  11. On your form, right-click the CvsInSightDisplay control and select Properties.

  12. In the Properties window, locate the AutoConnectString property and set it as follows:

    127.0.0.1,admin

    but replace the IP address in this example with the IP address of an In-Sight sensor or emulator on your network.

    If you don't know the IP address, you can find it by opening In-Sight Explorer and selecting Help > About In-Sight Explorer from the main menu.

    Note: The preceding example of AutoConnectString assumes that the In-Sight sensor has a user named admin with no password. If your sensor or emulator has a password, append it with the password argument as follows:

    127.0.0.1,admin,password

  13. When the AutoConnectString property is set correctly, the CvsInSightDisplay control will connect to the In-Sight sensor and show its image and/or spreadsheet within the Visual Studio design environment. At this point, you can press F5 to run your application. While it is running, you can interact with the display just as you would within the Job View of In-Sight Explorer.

    14. Note: If you receive a FileNotFoundException or BadImageFormatException after running your application:

    then it's likely you're running on a 64-bit OS and need to set the Target CPU to x86. Refer to Troubleshooting 64-bit Operating Systems for details on this process.

  14. Stop your application and return to the Visual Studio design mode.

  15. Open your form (if it is not already open).

  16. Select the CvsInSightDisplay control and experiment with its various properties, such as GridOpacity, ShowGrid and ShowCustomView.


Connect to a Sensor

How Do I
Connect to a Sensor
This sample code demonstrates how to use the CvsInSight object to establish a connection to an In-Sight sensor on the network. Several common exceptions are handled with an appropriate message written to the console.

Code

CopyC#
using System;
using Cognex.InSight;

class ConnectToSensor
{
  [STAThread]
  static void Main(string[] args)
  {
    CvsInSight insight = new CvsInSight();

    // The IP address of the target sensor
    string IP = "10.27.80.23";

    // The user name to use when connecting to the sensor
    string username = "admin";

    // The password to use when connecting to the sensor
    string password = "";

    Console.WriteLine("\nConnecting to In-Sight sensor " + IP + "...");

    // Because the Connect method may throw exceptions, wrap the call in a try/catch block.
    try
    {
      insight.Connect(IP, username, password, false, false);

      // Determine the state of the sensor
      switch (insight.State)
      {
        case CvsInSightState.Offline:
          Console.WriteLine("The sensor is offline.");
          break;
        case CvsInSightState.Online:
          Console.WriteLine("The sensor is online.");
          break;
        case CvsInSightState.NotConnected:
          Console.WriteLine("The sensor is not connected.");
          break;
      }
    }

    catch (CvsInSightLockedException)
    {
      // The sensor has been software-locked, preventing a connection.
      // Display a message and consume the exception.
      Console.WriteLine("The sensor is currently locked.");
    }

    catch (CvsSensorAlreadyConnectedException)
    {
      // Someone is already connected to this sensor.
      // Display a message and consume the exception.
      Console.WriteLine("A user currently has an open connection to the sensor.");
    }

    catch (CvsInvalidLogonException ex)
    {
      // If we receive an invalid logon, then we can look at the IsInvalidUsername property
      // to find out more about the exception.
      if (ex.IsInvalidUsername)
        Console.WriteLine("Invalid Username");
      else
        Console.WriteLine("Invalid Password");
    }

    catch (CvsNetworkException ex)
    {
      // Unable to successfully connect to the sensor.
      // Display a message and consume the exception.
      Console.WriteLine("A network error occurred while connecting to the sensor: " + ex.Message);
    }

    catch (Exception ex)
    {
      // Consume any other exception that may occur
      Console.WriteLine("Error: " + ex.Message);
    }

    finally
    {
      if (insight != null)
      {
        insight.Disconnect();
      }
    }
  }
}
CopyVB.NET
Imports Cognex.InSight

Module ConnectToSensor

    Sub Main()
        Dim oInsight As New CvsInSight
        Dim IP As String
        Dim username As String
        Dim password As String

        ' The IP address of the target sensor
        IP = "10.27.80.23"

        ' The user name to use when connecting to the sensor
        username = "admin"

        ' The password to use when connecting to the sensor
        password = ""

        Console.WriteLine(vbCrLf + "Connecting to In-Sight sensor " + IP + "...")

        ' Because the Connect method may throw exceptions, wrap the call in a try/catch block.
        Try
            oInsight.Connect(IP, username, password, False, False)

            Select Case (oInsight.State)
                Case CvsInSightState.Offline
                    Console.WriteLine("The sensor is offline.")
                Case CvsInSightState.Online
                    Console.WriteLine("The sensor is online.")
                Case CvsInSightState.NotConnected
                    Console.WriteLine("The sensor is not connected.")
            End Select

        Catch ex As CvsInvalidLogonException
            ' If we receive an invalid logon, then we can look at the IsInvalidUsername property
            ' to find out more about the exception.
            If (ex.IsInvalidUsername) Then
                Console.WriteLine("Invalid Username")
            Else
                Console.WriteLine("Invalid Password")
            End If

        Catch ex As CvsNetworkException
            ' Unable to successfully connect to the sensor.
            ' Display a message and consume the exception.
            Console.WriteLine(ex.Message)

        Catch ex As CvsSensorAlreadyConnectedException
            ' Someone is already connected to this sensor.
            ' Display a message and consume the exception.
            Console.WriteLine(ex.Message)

        Catch ex As CvsInSightLockedException
            ' The sensor has been software-locked, preventing a connection.
            ' Display a message and consume the exception.
            Console.WriteLine(ex.Message)

        Catch ex As Exception
            ' Consume any other exception that may occur
            Console.WriteLine(ex.Message)

        Finally
            ' Disconnect from the sensor
            oInsight.Disconnect()

        End Try

    End Sub

End Module


Bind CvsInSightDisplay Actions to Other Controls

How Do I
Bind CvsInSightDisplay Actions to Other Controls
The CvsInSightDisplay control allows many of its editing actions to be bound to other controls. This example demonstrates how to toggle the Live Acquisition mode using a checkbox on a form.

Note: Refer to the Sample Projects installed with the In-Sight Display Control for applications that make full use of the CvsInSightDisplay control's editing actions.

Code

CopyC#
using System;
using System.Drawing;
using System.Collections;
using System.ComponentModel;
using System.Windows.Forms;
using System.Data;

using Cognex.InSight;
using Cognex.InSight.Controls;
using Cognex.InSight.Controls.Display;

namespace ToggleLiveMode
{
  public class Form1 : System.Windows.Forms.Form
  {
    // In-Sight Display Control
    private Cognex.InSight.Controls.Display.CvsInSightDisplay cvsInSightDisplay1;

    // Check box that will toggle the live acquisition mode
    private System.Windows.Forms.CheckBox cbLiveMode;

    /// <summary>
    /// Required designer variable.
    /// </summary>
    private System.ComponentModel.Container components = null;

    public Form1()
    {
      //
      // Required for Windows Form Designer support
      //
      InitializeComponent();

      //
      // TODO: Add any constructor code after InitializeComponent call
      //
    }

    /// <summary>
    /// Clean up any resources being used.
    /// </summary>
    protected override void Dispose(bool disposing)
    {
      if (disposing)
      {
        if (components != null)
        {
          components.Dispose();
        }
      }
      base.Dispose(disposing);
    }

    #region Windows Form Designer generated code
    /// <summary>
    /// Required method for Designer support - do not modify
    /// the contents of this method with the code editor.
    /// </summary>
    private void InitializeComponent()
    {
      System.Resources.ResourceManager resources = new System.Resources.ResourceManager(typeof(Form1));
      this.cvsInSightDisplay1 = new Cognex.InSight.Controls.Display.CvsInSightDisplay();
      this.cbLiveMode = new System.Windows.Forms.CheckBox();
      this.SuspendLayout();
      //
      // cvsInSightDisplay1
      //
      this.cvsInSightDisplay1.BackColor = System.Drawing.SystemColors.Info;
      this.cvsInSightDisplay1.BackgroundImage = ((System.Drawing.Image)(resources.GetObject("cvsInSightDisplay1.BackgroundImage")));
      this.cvsInSightDisplay1.Dock = System.Windows.Forms.DockStyle.Bottom;
      this.cvsInSightDisplay1.Location = new System.Drawing.Point(0, 54);
      this.cvsInSightDisplay1.Name = "cvsInSightDisplay1";
      this.cvsInSightDisplay1.ShowGrid = true;
      this.cvsInSightDisplay1.Size = new System.Drawing.Size(888, 448);
      this.cvsInSightDisplay1.TabIndex = 0;
      //
      // cbLiveMode
      //
      this.cbLiveMode.Location = new System.Drawing.Point(320, 16);
      this.cbLiveMode.Name = "cbLiveMode";
      this.cbLiveMode.TabIndex = 2;
      this.cbLiveMode.Text = "Live Mode";
      //
      // Form1
      //
      this.AutoScaleBaseSize = new System.Drawing.Size(5, 13);
      this.ClientSize = new System.Drawing.Size(888, 502);
      this.Controls.Add(this.cbLiveMode);
      this.Controls.Add(this.cvsInSightDisplay1);
      this.Name = "Form1";
      this.Text = "Form1";
      this.Closing += new System.ComponentModel.CancelEventHandler(this.Form1_Closing);
      this.Load += new System.EventHandler(this.Form1_Load);
      this.ResumeLayout(false);

    }
    #endregion

    /// <summary>
    /// The main entry point for the application.
    /// </summary>
    [STAThread]
    static void Main()
    {
      Application.Run(new Form1());
    }

    private void Form1_Load(object sender, System.EventArgs e)
    {
      // Bind the 'CheckedChanged' event of the cbLiveMode check box to the LiveAcquire editing
      // action of the CvsInSightDisplay control.
      cvsInSightDisplay1.Edit.LiveAcquire.Bind(cbLiveMode, null, "CheckedChanged");
    }
    private void Form1_Closing(object sender, System.ComponentModel.CancelEventArgs e)
    {
      // Verify that the CvsInSightDisplay control is disconnected on exit.
      cvsInSightDisplay1.Disconnect();
    }
  }
}
CopyVB.NET
Public Class Form1
  Inherits System.Windows.Forms.Form

#Region " Windows Form Designer generated code "

  Public Sub New()
    MyBase.New()

    'This call is required by the Windows Form Designer.
    InitializeComponent()

    'Add any initialization after the InitializeComponent() call

  End Sub

  'Form overrides dispose to clean up the component list.
  Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
    If disposing Then
      If Not (components Is Nothing) Then
        components.Dispose()
      End If
    End If
    MyBase.Dispose(disposing)
  End Sub

  'Required by the Windows Form Designer
  Private components As System.ComponentModel.IContainer

  'NOTE: The following procedure is required by the Windows Form Designer
  'It can be modified using the Windows Form Designer.
  'Do not modify it using the code editor.

  Private WithEvents CvsInSightDisplay1 As Cognex.InSight.Controls.Display.CvsInSightDisplay
  ' Check box that will allow Live Acquisition mode to be toggled on/off
  Private WithEvents cbLiveMode As System.Windows.Forms.CheckBox

  <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
    Me.CvsInSightDisplay1 = New Cognex.InSight.Controls.Display.CvsInSightDisplay
    Me.cbLiveMode = New System.Windows.Forms.CheckBox
    Me.SuspendLayout()
    '
    'CvsInSightDisplay1
    '
    Me.CvsInSightDisplay1.Dock = System.Windows.Forms.DockStyle.Bottom
    Me.CvsInSightDisplay1.Location = New System.Drawing.Point(0, 52)
    Me.CvsInSightDisplay1.Name = "CvsInSightDisplay1"
    Me.CvsInSightDisplay1.Size = New System.Drawing.Size(640, 266)
    Me.CvsInSightDisplay1.TabIndex = 0
    '
    'cbLiveMode
    '
    Me.cbLiveMode.Location = New System.Drawing.Point(224, 8)
    Me.cbLiveMode.Name = "cbLiveMode"
    Me.cbLiveMode.TabIndex = 1
    Me.cbLiveMode.Text = "CheckBox1"
    '
    'Form1
    '
    Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
    Me.ClientSize = New System.Drawing.Size(640, 318)
    Me.Controls.Add(Me.cbLiveMode)
    Me.Controls.Add(Me.CvsInSightDisplay1)
    Me.Name = "Form1"
    Me.Text = "Form1"
    Me.ResumeLayout(False)

  End Sub

#End Region

  Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    ' Bind the 'CheckedChanged' event of the cbLiveMode check box to the LiveAcquire editing
    ' action of the CvsInSightDisplay control.
    CvsInSightDisplay1.Edit.LiveAcquire.Bind(cbLiveMode, Nothing, "CheckedChanged")
  End Sub

End Class


Find Sensors On My Network

How Do I
Find Sensors On My Network
This sample code illustrates how to use the CvsNetworkMonitor object to retrieve details of all sensors on your local network. A list view is populated to include each sensor's name, IP address, MAC address, firmware version and type.

Code

CopyC#
using System;
using System.Collections;
using System.ComponentModel;
using System.Windows.Forms;
using System.Data;

using Cognex.InSight.Net;

/// <summary>
/// Defines a form that displays the In-Sight sensors detected on the network.
/// </summary>
/// <remarks>This class shows how the CvsNetworkMonitor may be used in an application.</remarks>
public class FindSensorsOnMyNetwork : System.Windows.Forms.Form
{
  private System.Windows.Forms.CheckBox checkBoxEnabled;
  private System.Windows.Forms.ListView listViewSensors;
  private System.Windows.Forms.ColumnHeader columnHeader1;
  private System.Windows.Forms.ColumnHeader columnHeader2;
  private System.Windows.Forms.ColumnHeader columnHeader3;
  private System.Windows.Forms.Button buttonRefresh;
  private System.Windows.Forms.ColumnHeader columnHeader4;
  private System.Windows.Forms.ColumnHeader columnHeader5;
  private System.Windows.Forms.Label label1;
  private System.Windows.Forms.NumericUpDown numericPingInterval;

  /// <summary>
  /// Required designer variable.
  /// </summary>
  private System.ComponentModel.Container components = null;

  public FindSensorsOnMyNetwork()
  {
    //
    // Required for Windows Form Designer support
    //
    InitializeComponent();
  }

  /// <summary>
  /// Clean up any resources being used.
  /// </summary>
  protected override void Dispose(bool disposing)
  {
    if (disposing)
    {
      if (components != null)
      {
        components.Dispose();
      }
    }
    base.Dispose(disposing);
  }

  #region Windows Form Designer generated code
  /// <summary>
  /// Required method for Designer support - do not modify
  /// the contents of this method with the code editor.
  /// </summary>
  private void InitializeComponent()
  {
    this.checkBoxEnabled = new System.Windows.Forms.CheckBox();
    this.listViewSensors = new System.Windows.Forms.ListView();
    this.columnHeader1 = new System.Windows.Forms.ColumnHeader();
    this.columnHeader2 = new System.Windows.Forms.ColumnHeader();
    this.columnHeader3 = new System.Windows.Forms.ColumnHeader();
    this.columnHeader4 = new System.Windows.Forms.ColumnHeader();
    this.columnHeader5 = new System.Windows.Forms.ColumnHeader();
    this.buttonRefresh = new System.Windows.Forms.Button();
    this.label1 = new System.Windows.Forms.Label();
    this.numericPingInterval = new System.Windows.Forms.NumericUpDown();
    ((System.ComponentModel.ISupportInitialize)(this.numericPingInterval)).BeginInit();
    this.SuspendLayout();
    //
    // checkBoxEnabled
    //
    this.checkBoxEnabled.Checked = true;
    this.checkBoxEnabled.CheckState = System.Windows.Forms.CheckState.Checked;
    this.checkBoxEnabled.Location = new System.Drawing.Point(8, 8);
    this.checkBoxEnabled.Name = "checkBoxEnabled";
    this.checkBoxEnabled.Size = new System.Drawing.Size(72, 24);
    this.checkBoxEnabled.TabIndex = 0;
    this.checkBoxEnabled.Text = "Enabled";
    this.checkBoxEnabled.CheckedChanged += new System.EventHandler(this.checkBoxEnabled_CheckedChanged);
    //
    // listViewSensors
    //
    this.listViewSensors.Anchor = ((System.Windows.Forms.AnchorStyles)((((System.Windows.Forms.AnchorStyles.Top | System.Windows.Forms.AnchorStyles.Bottom)
        | System.Windows.Forms.AnchorStyles.Left)
        | System.Windows.Forms.AnchorStyles.Right)));
    this.listViewSensors.Columns.AddRange(new System.Windows.Forms.ColumnHeader[] {
                                                                                this.columnHeader1,
                                                                                this.columnHeader2,
                                                                                this.columnHeader3,
                                                                                this.columnHeader4,
                                                                                this.columnHeader5});
    this.listViewSensors.Location = new System.Drawing.Point(8, 40);
    this.listViewSensors.Name = "listViewSensors";
    this.listViewSensors.Size = new System.Drawing.Size(512, 216);
    this.listViewSensors.TabIndex = 1;
    this.listViewSensors.View = System.Windows.Forms.View.Details;
    //
    // columnHeader1
    //
    this.columnHeader1.Text = "Name";
    this.columnHeader1.Width = 118;
    //
    // columnHeader2
    //
    this.columnHeader2.Text = "IP Address";
    this.columnHeader2.Width = 91;
    //
    // columnHeader3
    //
    this.columnHeader3.Text = "Version";
    this.columnHeader3.Width = 108;
    //
    // columnHeader4
    //
    this.columnHeader4.Text = "MAC Address";
    this.columnHeader4.Width = 110;
    //
    // columnHeader5
    //
    this.columnHeader5.Text = "Type";
    //
    // buttonRefresh
    //
    this.buttonRefresh.Location = new System.Drawing.Point(328, 8);
    this.buttonRefresh.Name = "buttonRefresh";
    this.buttonRefresh.Size = new System.Drawing.Size(88, 24);
    this.buttonRefresh.TabIndex = 2;
    this.buttonRefresh.Text = "Refresh";
    this.buttonRefresh.Click += new System.EventHandler(this.buttonRefresh_Click);
    //
    // label1
    //
    this.label1.Location = new System.Drawing.Point(88, 8);
    this.label1.Name = "label1";
    this.label1.Size = new System.Drawing.Size(88, 24);
    this.label1.TabIndex = 3;
    this.label1.Text = "Ping Rate (sec):";
    this.label1.TextAlign = System.Drawing.ContentAlignment.MiddleRight;
    //
    // numericPingInterval
    //
    this.numericPingInterval.Location = new System.Drawing.Point(184, 10);
    this.numericPingInterval.Maximum = new System.Decimal(new int[] {
                                                                            30,
                                                                            0,
                                                                            0,
                                                                            0});
    this.numericPingInterval.Name = "numericPingInterval";
    this.numericPingInterval.Size = new System.Drawing.Size(64, 20);
    this.numericPingInterval.TabIndex = 4;
    this.numericPingInterval.ValueChanged += new System.EventHandler(this.numericPingInterval_ValueChanged);
    //
    // FindSensorsOnMyNetwork
    //
    this.AutoScaleBaseSize = new System.Drawing.Size(5, 13);
    this.ClientSize = new System.Drawing.Size(528, 262);
    this.Controls.Add(this.numericPingInterval);
    this.Controls.Add(this.label1);
    this.Controls.Add(this.buttonRefresh);
    this.Controls.Add(this.listViewSensors);
    this.Controls.Add(this.checkBoxEnabled);
    this.Name = "FindSensorsOnMyNetwork";
    this.Text = "Network Monitor Demo";
    this.Load += new System.EventHandler(this.NetworkMonitorForm_Load);
    ((System.ComponentModel.ISupportInitialize)(this.numericPingInterval)).EndInit();
    this.ResumeLayout(false);

  }
  #endregion

  /// <summary>
  /// The main entry point for the application.
  /// </summary>
  [STAThread]
  static void Main()
  {
    Application.Run(new FindSensorsOnMyNetwork());
  }

  private CvsNetworkMonitor monitor;

  private void NetworkMonitorForm_Load(object sender, System.EventArgs e)
  {
    monitor = new CvsNetworkMonitor();

    // Attach an event handler to populate a control when the Hosts change
    monitor.HostsChanged += new EventHandler(monitor_HostsChanged);

    // Make the value of the control consistent with the check box
    monitor.Enabled = checkBoxEnabled.Checked;

    monitor.PingInterval = (int)numericPingInterval.Value;
  }

  private void checkBoxEnabled_CheckedChanged(object sender, System.EventArgs e)
  {
    monitor.Enabled = checkBoxEnabled.Checked; // Enable/disable monitoring
  }

  private void buttonRefresh_Click(object sender, System.EventArgs e)
  {
    monitor.Refresh();
  }

  private void monitor_HostsChanged(object sender, EventArgs e)
  {
    // Remove old items
    listViewSensors.BeginUpdate();
    listViewSensors.Items.Clear();

    // Handle the new selections from the NetworkMonitor...
    foreach (CvsHostSensor host in monitor.Hosts)
    {
      ListViewItem item = new ListViewItem(new string[5] { host.Name,
                                                                    host.IPAddressString,
                                                                    host.Version.ToString(),
                                                                    host.MacAddress, host.Type.ToString() });
      listViewSensors.Items.Add(item);
    }

    listViewSensors.EndUpdate();
  }

  protected override void OnClosed(EventArgs e)
  {
    base.OnClosed(e);

    monitor.Dispose();
  }

  private void numericPingInterval_ValueChanged(object sender, System.EventArgs e)
  {
    monitor.PingInterval = (int)numericPingInterval.Value;
  }
}
CopyVB.NET
Imports Cognex.InSight.Net

Public Class Form1
    Inherits System.Windows.Forms.Form

    Dim WithEvents monitor As CvsNetworkMonitor

#Region " Windows Form Designer generated code "

    Public Sub New()
        MyBase.New()

        'This call is required by the Windows Form Designer.
        InitializeComponent()

        'Add any initialization after the InitializeComponent() call

    End Sub

    'Form overrides dispose to clean up the component list.
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

    'Required by the Windows Form Designer
    Private components As System.ComponentModel.IContainer

    'NOTE: The following procedure is required by the Windows Form Designer
    'It can be modified using the Windows Form Designer.
    'Do not modify it using the code editor.
    Friend WithEvents HostsList As System.Windows.Forms.ListView
    Friend WithEvents HostName As System.Windows.Forms.ColumnHeader
    Friend WithEvents IPAddress As System.Windows.Forms.ColumnHeader
    Friend WithEvents Label1 As System.Windows.Forms.Label
    Friend WithEvents UpDownPing As System.Windows.Forms.NumericUpDown
    Friend WithEvents EnabledCheckBox As System.Windows.Forms.CheckBox
    Friend WithEvents RefreshButton As System.Windows.Forms.Button
    Friend WithEvents Version As System.Windows.Forms.ColumnHeader
    Friend WithEvents MACAddress As System.Windows.Forms.ColumnHeader
    Friend WithEvents Type As System.Windows.Forms.ColumnHeader
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.HostsList = New System.Windows.Forms.ListView
        Me.HostName = New System.Windows.Forms.ColumnHeader
        Me.IPAddress = New System.Windows.Forms.ColumnHeader
        Me.Label1 = New System.Windows.Forms.Label
        Me.UpDownPing = New System.Windows.Forms.NumericUpDown
        Me.EnabledCheckBox = New System.Windows.Forms.CheckBox
        Me.RefreshButton = New System.Windows.Forms.Button
        Me.Version = New System.Windows.Forms.ColumnHeader
        Me.MACAddress = New System.Windows.Forms.ColumnHeader
        Me.Type = New System.Windows.Forms.ColumnHeader
        CType(Me.UpDownPing, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'HostsList
        '
        Me.HostsList.Anchor = CType((((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right), System.Windows.Forms.AnchorStyles)
        Me.HostsList.Columns.AddRange(New System.Windows.Forms.ColumnHeader() {Me.HostName, Me.IPAddress, Me.Version, Me.MACAddress, Me.Type})
        Me.HostsList.Location = New System.Drawing.Point(8, 48)
        Me.HostsList.Name = "HostsList"
        Me.HostsList.Size = New System.Drawing.Size(520, 248)
        Me.HostsList.TabIndex = 0
        Me.HostsList.View = System.Windows.Forms.View.Details
        '
        'HostName
        '
        Me.HostName.Text = "Host"
        Me.HostName.Width = 115
        '
        'IPAddress
        '
        Me.IPAddress.Text = "IP Address"
        Me.IPAddress.Width = 100
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(96, 13)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(88, 16)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Ping Rate (sec):"
        '
        'UpDownPing
        '
        Me.UpDownPing.Location = New System.Drawing.Point(184, 11)
        Me.UpDownPing.Name = "UpDownPing"
        Me.UpDownPing.Size = New System.Drawing.Size(64, 20)
        Me.UpDownPing.TabIndex = 2
        '
        'EnabledCheckBox
        '
        Me.EnabledCheckBox.Checked = True
        Me.EnabledCheckBox.CheckState = System.Windows.Forms.CheckState.Checked
        Me.EnabledCheckBox.Location = New System.Drawing.Point(8, 8)
        Me.EnabledCheckBox.Name = "EnabledCheckBox"
        Me.EnabledCheckBox.Size = New System.Drawing.Size(72, 24)
        Me.EnabledCheckBox.TabIndex = 3
        Me.EnabledCheckBox.Text = "Enabled"
        '
        'RefreshButton
        '
        Me.RefreshButton.Location = New System.Drawing.Point(320, 10)
        Me.RefreshButton.Name = "RefreshButton"
        Me.RefreshButton.Size = New System.Drawing.Size(96, 24)
        Me.RefreshButton.TabIndex = 4
        Me.RefreshButton.Text = "Refresh"
        '
        'Version
        '
        Me.Version.Text = "Version"
        Me.Version.Width = 100
        '
        'MACAddress
        '
        Me.MACAddress.Text = "MAC Address"
        Me.MACAddress.Width = 100
        '
        'Type
        '
        Me.Type.Text = "Type"
        Me.Type.Width = 100
        '
        'Form1
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(536, 302)
        Me.Controls.Add(Me.RefreshButton)
        Me.Controls.Add(Me.EnabledCheckBox)
        Me.Controls.Add(Me.UpDownPing)
        Me.Controls.Add(Me.Label1)
        Me.Controls.Add(Me.HostsList)
        Me.Name = "Form1"
        Me.Text = "Find Sensors on My Network"
        CType(Me.UpDownPing, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

#End Region

    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        ' Create a CvsNetworkMonitor instance to detect sensors on the subnet.
        monitor = New CvsNetworkMonitor
        ' Enable the monitoring operation.
        ' This will allow the HostsChanged event to be generated when new sensors are detected.
        monitor.Enabled = True
    End Sub

    ' Handle the HostsChanged event that occurs when new sensors are detected on the subnet.
    Private Sub monitor_HostsChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles monitor.HostsChanged
        Dim hosts As CvsHostCollection

        ' Prepare the ListView for updating.
        HostsList.BeginUpdate()

        ' Clear any current hosts that where detected.
        HostsList.Items.Clear()

        ' Grab the collection of hosts detected.
        hosts = monitor.Hosts

        Dim n As Integer

        ' Read each host in the collection
        For n = 0 To hosts.Count - 1
            Dim host As CvsHostSensor
            host = hosts(n)
            ' Make a string array that will hold each item to populate a ListViewItem
            Dim entry(5) As String
            entry(0) = host.Name ' The Name of the host sensor detected
            entry(1) = host.IPAddressString ' The IP address of the sensor
            entry(2) = host.Version.ToString() ' The firmware version of the sensor
            entry(3) = host.MacAddress ' The MAC Address of the sensor
            entry(4) = host.Type.ToString() ' The type of device (In-Sight Sensor or PC)

            HostsList.Items.Add(New ListViewItem(entry)) ' Create a new ListViewItem and add it to the ListView.
        Next

        ' Complete the ListView updating.
        HostsList.EndUpdate()

    End Sub

    Private Sub Form1_Closed(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Closed
        ' Dispose assocating CvsNetworkMonitor resources before closing the application.
        monitor.Dispose()
    End Sub

    Private Sub UpDownPing_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles UpDownPing.ValueChanged
        If (Not monitor Is Nothing) Then
            monitor.PingInterval = CInt(UpDownPing.Value) ' Set the PingInterval in seconds
        End If
    End Sub

    Private Sub RefreshButton_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles RefreshButton.Click
        If (Not monitor Is Nothing) Then
            HostsList.Items.Clear() ' Clear the list in preparation for re-populating
            monitor.Refresh()
        End If
    End Sub

    Private Sub EnabledCheckBox_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles EnabledCheckBox.CheckedChanged
        If (Not monitor Is Nothing) Then
            monitor.Enabled = EnabledCheckBox.Checked
            If (Not monitor.Enabled) Then
                HostsList.Items.Clear() ' Clear the list upon disabling
            End If
        End If
    End Sub
End Class


Get the Firmware Version of a Sensor

How Do I
Get the Firmware Version of a Sensor
This sample code demonstrates how to retrieve the firmware version of an In-Sight sensor.

Code

CopyC#
using System;
using Cognex.InSight;

class DisplayFirmwareVersion
{
  [STAThread]
  static void Main(string[] args)
  {
    CvsInSight insight = new CvsInSight();

    // Because the Connect method may throw exceptions, wrap the call in a try/catch block.
    try
    {
      insight.Connect("10.27.80.23", "admin", "", false, false);

      Console.WriteLine("Firmware version of the sensor: " + insight.Sensor.Version);
    }

    // Consume any exception that may occur
    catch (Exception ex)
    {
      Console.WriteLine("Error: " + ex.Message);
    }

    finally
    {
      if (insight != null)
      {
        insight.Disconnect();
      }
    }
  }
}
CopyVB.NET
Imports Cognex.InSight

Module DisplayFirmwareVersion

    Sub Main()
        Dim oInsight As New CvsInSight

        ' Because the Connect method may throw exceptions, wrap the call in a try/catch block.
        Try
            oInsight.Connect("10.27.80.23", "admin", "", False, False)

            Console.Write("Firmware version of the sensor: ")
            Console.WriteLine(oInsight.Sensor.Version)

        Catch ex As Exception
            ' Consume any exception that may occur
            Console.WriteLine(ex.Message)

        Finally
            ' Disconnect from the sensor
            oInsight.Disconnect()

        End Try

    End Sub

End Module


Get the Number of Files on a Sensor

How Do I
Get the Number of Files on a Sensor
This sample code illustrates how to retrieve the number of files contained on an In-Sight sensor's file system.

Code

CopyC#
using System;
using Cognex.InSight;

class GetNumberOfFiles
{
  [STAThread]
  static void Main(string[] args)
  {
    // Create a new CvsInSight object
    CvsInSight insight = new CvsInSight();

    // Because the Connect method may throw exceptions, wrap the call in a try/catch block.
    try
    {
      // Connect to the sensor
      insight.Connect("10.27.80.23", "admin", "", false, false);

      Console.WriteLine("\nThe number of files on In-Sight sensor {0} is {1}.", insight.Sensor.GetSettings().NetworkSettings.HostName, insight.File.GetFileList().Length);
    }

    catch (Exception ex)
    {
      // Consume any exception that may occur
      Console.WriteLine("Error: " + ex.Message);
    }

    finally
    {
      // Clean up
      if (insight != null)
      {
        insight.Disconnect();
      }
    }
  }
}
CopyVB.NET
Imports Cognex.InSight

Module GetNumberOfFiles

    Sub Main()
        Dim oInsight As New CvsInSight

        ' Because the Connect method may throw exceptions, wrap the call in a try/catch block.
        Try
            oInsight.Connect("10.27.80.23", "admin", "", False, False)

            Console.WriteLine(vbCrLf + "The number of files on In-Sight sensor {0} is {1}.", oInsight.Sensor.GetSettings().NetworkSettings.HostName, oInsight.File.GetFileList().Length)

        Catch ex As Exception
            ' Consume any exception that may occur
            Console.WriteLine(ex.Message)

        Finally
            ' Clean up
            If (Not oInsight Is Nothing) Then
                ' Disconnect from the sensor
                oInsight.Disconnect()
            End If

        End Try

    End Sub

End Module


Use Events To Handle Cell Updates

How Do I
Use Events To Handle Cell Updates
This sample code illustrates how to use events to handle cell Results changes.

Note: See Event Troubleshooting for information on common problems encountered when dealing with events and cell results.

Code

CopyC#
using System;
using System.Drawing;
using System.Collections;
using System.ComponentModel;
using System.Windows.Forms;
using System.Data;

using Cognex.InSight;
using Cognex.InSight.Cell;

public class Form1 : System.Windows.Forms.Form
{
  private CvsInSight insight;
  private System.Windows.Forms.Button ManualAcquireButton;
  private System.Windows.Forms.TextBox A2TextBox;

  /// <summary>
  /// Required designer variable.
  /// </summary>
  private readonly System.ComponentModel.Container components = null;

  public Form1()
  {
    //
    // Required for Windows Form Designer support
    //
    InitializeComponent();

    //
    // TODO: Add any constructor code after InitializeComponent call
    //
  }

  /// <summary>
  /// Clean up any resources being used.
  /// </summary>
  protected override void Dispose(bool disposing)
  {
    if (disposing)
    {
      if (components != null)
      {
        components.Dispose();
      }
    }
    base.Dispose(disposing);
  }

  #region Windows Form Designer generated code

  /// <summary>
  /// Required method for Designer support - do not modify
  /// the contents of this method with the code editor.
  /// </summary>
  private void InitializeComponent()
  {
    this.ManualAcquireButton = new System.Windows.Forms.Button();
    this.A2TextBox = new System.Windows.Forms.TextBox();
    this.SuspendLayout();
    //
    // ManualAcquireButton
    //
    this.ManualAcquireButton.Location = new System.Drawing.Point(152, 24);
    this.ManualAcquireButton.Name = "ManualAcquireButton";
    this.ManualAcquireButton.Size = new System.Drawing.Size(128, 72);
    this.ManualAcquireButton.TabIndex = 0;
    this.ManualAcquireButton.Text = "button1";
    this.ManualAcquireButton.Click += new System.EventHandler(this.ManualAcquireButton_Click);
    //
    // A2TextBox
    //
    this.A2TextBox.Location = new System.Drawing.Point(24, 128);
    this.A2TextBox.Name = "A2TextBox";
    this.A2TextBox.Size = new System.Drawing.Size(96, 20);
    this.A2TextBox.TabIndex = 1;
    this.A2TextBox.Text = "textBox1";
    //
    // Form1
    //
    this.AutoScaleBaseSize = new System.Drawing.Size(5, 13);
    this.ClientSize = new System.Drawing.Size(292, 266);
    this.Controls.Add(this.A2TextBox);
    this.Controls.Add(this.ManualAcquireButton);
    this.Name = "Form1";
    this.Text = "Form1";
    this.Closing += new System.ComponentModel.CancelEventHandler(this.Form1_Closing);
    this.Load += new System.EventHandler(this.Form1_Load);
    this.ResumeLayout(false);

    this.insight = new CvsInSight();
    this.insight.ResultsChanged += new System.EventHandler(this.insight_ResultsChanged);
  }

  #endregion

  /// <summary>
  /// The main entry point for the application.
  /// </summary>
  [STAThread]
  private static void Main()
  {
    Application.Run(new Form1());
  }

  private void Form1_Load(object sender, System.EventArgs e)
  {
    insight.Connect("10.27.80.23", "admin", "", true, false);
  }

  private void Form1_Closing(object sender, System.ComponentModel.CancelEventArgs e)
  {
    insight.Disconnect();
  }

  private void ManualAcquireButton_Click(object sender, System.EventArgs e)
  {
    insight.ManualAcquire(); // Request a new acquisition to generate new results
  }

  private void insight_ResultsChanged(object sender, System.EventArgs e)
  {
    CvsCell cell = insight.Results.Cells["A2"];
    if (cell != null)
    {
      A2TextBox.Text = cell.Text;
    }

    insight.AcceptUpdate(); // Tell the sensor that the application is ready for new results.
  }
}
CopyVB.NET
Imports Cognex.InSight
Imports Cognex.InSight.Cell

Public Class MyForm
  Inherits System.Windows.Forms.Form

  Private WithEvents insight As CvsInSight

#Region " Windows Form Designer generated code "

  Public Sub New()
    MyBase.New()

    'This call is required by the Windows Form Designer.
    InitializeComponent()

    'Add any initialization after the InitializeComponent() call

  End Sub

  'Form overrides dispose to clean up the component list.
  Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
    If disposing Then
      If Not (components Is Nothing) Then
        components.Dispose()
      End If
    End If
    MyBase.Dispose(disposing)
  End Sub

  'Required by the Windows Form Designer
  Private components As System.ComponentModel.IContainer

  'NOTE: The following procedure is required by the Windows Form Designer
  'It can be modified using the Windows Form Designer.
  'Do not modify it using the code editor.
  Friend WithEvents A2TextBox As System.Windows.Forms.TextBox
  Friend WithEvents ManualAcquireButton As System.Windows.Forms.Button
  <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
    Me.A2TextBox = New System.Windows.Forms.TextBox
    Me.ManualAcquireButton = New System.Windows.Forms.Button
    Me.SuspendLayout()
    '
    'A2TextBox
    '
    Me.A2TextBox.Location = New System.Drawing.Point(56, 80)
    Me.A2TextBox.Name = "A2TextBox"
    Me.A2TextBox.Size = New System.Drawing.Size(88, 20)
    Me.A2TextBox.TabIndex = 0
    Me.A2TextBox.Text = "TextBox1"
    '
    'ManualAcquireButton
    '
    Me.ManualAcquireButton.Location = New System.Drawing.Point(104, 144)
    Me.ManualAcquireButton.Name = "ManualAcquireButton"
    Me.ManualAcquireButton.Size = New System.Drawing.Size(88, 56)
    Me.ManualAcquireButton.TabIndex = 1
    Me.ManualAcquireButton.Text = "Button1"
    '
    'MyForm
    '
    Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
    Me.ClientSize = New System.Drawing.Size(292, 266)
    Me.Controls.Add(Me.ManualAcquireButton)
    Me.Controls.Add(Me.A2TextBox)
    Me.Name = "MyForm"
    Me.Text = "MyForm"
    Me.ResumeLayout(False)

  End Sub

#End Region

  Private Sub ManualAcquireButton_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ManualAcquireButton.Click
    insight.ManualAcquire() ' Request a new acquisition to generate new results
  End Sub

  ' Notification that the sensor has sent new results
  Private Sub insight_ResultsChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles insight.ResultsChanged
    Dim cell As CvsCell

    cell = insight.Results.Cells("A2") ' Examine cell A2
    If (Not cell Is Nothing) Then
      A2TextBox.Text = cell.Text ' Copy the text for A2 to the visible TextBox
    End If

    insight.AcceptUpdate() ' Tell the sensor that the application is ready for new results.

  End Sub

End Class


Wait For New Results

How Do I
Wait For New Results
This sample code illustrates how to know when a change to a spreadsheet edit control has produced new Results changes.

Note: See Event Troubleshooting for information on common problems encountered when dealing with events and cell results.

Code

CopyC#
using System;
using System.Drawing;
using System.Collections;
using System.ComponentModel;
using System.Windows.Forms;
using System.Data;

using Cognex.InSight;
using Cognex.InSight.Cell;

public class Form1 : System.Windows.Forms.Form
{
  private bool gotResults; // a global flag to indicate new results
  private CvsInSight insight; // CvsInSight object to use

  /// <summary>
  /// Required designer variable.
  /// </summary>
  private readonly System.ComponentModel.Container components = null;

  public Form1()
  {
    //
    // Required for Windows Form Designer support
    //
    InitializeComponent();

    //
    // TODO: Add any constructor code after InitializeComponent call
    //
  }

  /// <summary>
  /// Clean up any resources being used.
  /// </summary>
  protected override void Dispose(bool disposing)
  {
    if (disposing)
    {
      if (components != null)
      {
        components.Dispose();
      }
    }
    base.Dispose(disposing);
  }

  #region Windows Form Designer generated code

  /// <summary>
  /// Required method for Designer support - do not modify
  /// the contents of this method with the code editor.
  /// </summary>
  private void InitializeComponent()
  {
    //
    // Form1
    //
    this.AutoScaleBaseSize = new System.Drawing.Size(5, 13);
    this.ClientSize = new System.Drawing.Size(292, 266);
    this.Name = "Form1";
    this.Text = "Form1";
    this.Load += new System.EventHandler(this.Form1_Load);
  }

  #endregion

  private void Form1_Load(object sender, System.EventArgs e)
  {
    insight = new CvsInSight();
    insight.Connect("10.27.80.23", "admin", "", true, false);
  }

  private void Form1_Closing(object sender, System.ComponentModel.CancelEventArgs e)
  {
    insight.Disconnect();
  }

  /// <summary>
  /// The main entry point for the application.
  /// </summary>
  [STAThread]
  private static void Main()
  {
    Application.Run(new Form1());
  }

  private void insight_ResultsChanged(object sender, System.EventArgs e)
  {
    gotResults = true; // Set the global flag indicating new results

    insight.AcceptUpdate(); // Tell the sensor that the application is ready for new results.
  }

  private bool UpdateEditIntAndWait(string cellLocation, int newValue)
  {
    gotResults = false;

    // Update an edit control
    insight.SetInteger(new CvsCellLocation(cellLocation), newValue);

    // Wait for the sensor to process the command
    int attempts = 30; // Allows approximately 3 seconds to get a response
    while (attempts > 0)
    {
      attempts = attempts - 1;
      System.Threading.Thread.Sleep(100); // Wait 1/10 second

      // Allow the new Results to be processed
      Application.DoEvents();

      if (gotResults)
      {
        CvsCell cell = insight.Results.Cells[cellLocation];
        if ((cell != null) && (cell.Text == newValue.ToString()))
          return true;
        else
          gotResults = false;
      }
    }
    return false; // Failed to get the expected update within 3 seconds
  }
}
CopyVB.NET
Imports Cognex.InSight
Imports Cognex.InSight.Cell

Public Class MyForm

  Private WithEvents insight As CvsInSight

  Private gotResults As Boolean ' A global flag to indicate new results

  ' Notification that the sensor has sent new results
  Private Sub insight_ResultsChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles insight.ResultsChanged
    gotResults = True ' Set the global flag indicating new results
    insight.AcceptUpdate() ' Tell the sensor that the application is ready for new results.
  End Sub

  ' A function that waits for an EditInt cell to be processed with the newValue.
  ' Returns true when the new Results with the updated edit control are received.
  Private Function UpdateEditIntAndWait(ByVal cellLocation As String, ByVal newValue As Integer) As Boolean
    gotResults = False
    ' Update an edit control
    insight.SetInteger(New CvsCellLocation(cellLocation), newValue)
    ' Wait for the sensor to process the command
    Dim attempts As Integer = 30 ' Will allow approximately 3 seconds to get a response
    While (attempts > 0)
      attempts = attempts - 1

      System.Threading.Thread.Sleep(100) ' Wait 1/10 second
      ' Allow the new Results to be processed
      Application.DoEvents()

      If (gotResults) Then
        Dim cell As CvsCell
        cell = insight.Results.Cells(cellLocation)
        If ((Not cell Is Nothing) And cell.Text = newValue.ToString()) Then
          Return True
        End If
        gotResults = False
      End If
    End While

    Return False ' Failed to get the expected update within 3 seconds
  End Function

  Shared Sub Main()
  End Sub

End Class


Deployment Overview

Deployment
Overview

Using the In-Sight Software Development Kit, you can create custom In-Sight applications on your development machine and deploy them to other PCs. Custom In-Sight applications can vary in functionality from a simple In-Sight Display Control docked on a form, to complex and robust applications that manage jobs, images, graphics and I/O.

Deployment Requirements

Required Software

The Microsoft .NET Framework 4.5.2 must be installed on any target PC before custom In-Sight applications will function. Microsoft .NET Framework 4.5.2 may be installed:

  • by installing In-Sight Software

  • from the Microsoft Download Center.

Required Hard Drive Space

After the Microsoft .NET Framework 4.5.2 has been installed, the destination PC requires roughly 50MB of hard drive space for the In-Sight Core Components and any additional space that your custom application files require.

Available Memory

Most In-Sight applications require less than 100MB of free memory to execute; however, if you have multiple CvsInSightDisplay controls or multiple applications running simultaneously, more memory may be required.

Deployment Methods

NOTE: Visual Studio 2012 and later does not include native support for Setup/Deployment project templates. The included tutorials presume the following:

  • Application binaries developed in Visual Studio 2012

  • Installation project developed in Visual Studio 2010

InstallShield Limited Edition has replaced native Visual Studio project templates for setup and deployment projects. See the following link for more details: https://msdn.microsoft.com/en-us/library/2kt85ked%28v=vs.110%29.aspx

Two deployment methods are supported:

  • Custom installer (by integrating the In-Sight Core Components Merge Module)

  • XCOPY Deployment (by installing the In-Sight Core Components package)

Either deployment method will install all of the necessary files to the target system in order to run your custom-developed In-Sight SDK applications.

Custom Installer

If your goal is to install one or more In-Sight SDK applications on multiple target machines, the custom installer method is a good option. Using an installation development environment (such as Microsoft Visual Studio .NET or InstallShield Developer), you create a setup package that incorporates the In-Sight Core Components merge module (which can be located either on the In-Sight SDK CD-ROM or in the "%CommonProgramFiles%\Merge Modules" folder on a PC where the In-Sight SDK has been installed) and the project output from any In-Sight application(s) you have developed. This single installer can be run on any target machine to install all the required In-Sight support files and your custom In-Sight SDK application.

Custom Installer Deployment Tutorial

XCOPY Deployment

If your goal is to install multiple In-Sight SDK applications onto a single target machine, you may want to use the In-Sight Core Components installer (which can be located either on the In-Sight SDK CD-ROM or in the In-Sight SDK installation folder.) After installing the In-Sight Core Components package on the target PC, your custom In-Sight SDK applications can be copied to that PC and executed without the need to develop a custom installer package for each application.

XCOPY Deployment Tutorial


Installer Deployment

Deployment
Installer Deployment Tutorial

This tutorial walks you through the process of creating a custom installer for your In-Sight application and deploying it to another PC. A C# .NET (Visual Studio 2012) project will be created from scratch. The resulting executable will then be packaged in an installer (built in Visual Studio 2010) and installed onto a target PC.

Stage 1: Developing the Application

  1. Follow the steps in How Do I: Create a new In-Sight Application in C# with Visual Studio .NET 2012.

  2. Change the Configuration to Release.

  3. Rebuild the solution.

Stage 2: Developing the Installer

  1. In the Solution Explorer, right-click the solution and select Add > New Project.

  2. Under Installed Templates, expand Other Project Types > Setup and Deployment > Visual Studio Installer.

  3. In the middle pane, select Setup Project.

  4. Name the project DisplayInstaller and click OK.

  5. In the Solution Explorer, right-click the DisplayInstaller project and select Add > Merge Module.

  6. In the Add Modules dialog, select Cognex.InSight.Core.Components 6.5.0.msm and click Open.

  7. In the File System Browser, right-click Application Folder and select Add > Project Output...

  8. Verify that DisplayTest is selected in the Project drop-down list.

  9. Select Primary Output and click OK.

  10. You should now have an item named Primary output from DisplayTest (Active) listed in the Application Folder. Right-click this item and select Create Shortcut to Primary output from DisplayTest (Active). Type In-Sight Display Sample for the name and press ENTER.

  11. Click-and-drag the In-Sight Display Sample shortcut you just created to the User's Desktop folder in the File System Browser.

  12. Click Build > Configuration Manager.

  13. Set the Active Solution Configuration to Release.

  14. For the DisplayInstaller Project, select the checkbox in the Build column.

  15. Click Close.

  16. In the Solution Explorer, right-click the DisplayInstaller project and select Properties.

  17. Click the Prerequisites... button.

  18. Clear any check boxes next to Microsoft .NET Framework 4.5.2 ... options.

  19. Click OK to close the Prerequisites dialog.

  20. Click OK to close the DisplayInstaller Properties dialog.

  21. In the Solution Explorer, right-click the DisplayInstaller project and select View > Launch Conditions.

  22. Under Launch Conditions, right-click .NET Framework and select Properties Window.

  23. Change the Version to .NET Framework 4.5.2.

  24. Click File > Save All.

  25. Click Build > Rebuild Solution.

  26. After the solution has built successfully, exit Visual Studio .NET.

Note: If you are seeing build warnings such as Unable to find module dependency or Two or more objects have the same target location, please consult Deployment Troubleshooting for more details.

Stage 3: Preparing the Target PC

Verify that the Microsoft .NET Framework 4.5.2 is installed on the target PC. This setup package can be downloaded from Microsoft. Alternatively, you can incorporate the .NET Framework 4.5.2 into your installer as a setup prerequisite.

Stage 4: Deploying the Application

  1. Copy all output files from the DisplayInstaller\Release subfolder of your development PC onto the target PC.

  2. On the target PC, run setup.exe.

  3. Follow through the installer steps to the end.

  4. Once the setup has been installed, you should see an icon on your desktop named In-Sight Display Sample. Double-click this icon to launch your sample In-Sight application.


XCOPY Deployment

Deployment
XCOPY Deployment Tutorial

This tutorial walks you through the process of creating a simple In-Sight application containing the CvsInSightDisplay control and deploying it to another PC. A C# .NET (Visual Studio 2012) project will be created from scratch. The resulting executable will then be deployed via XCOPY to a target PC.

Stage 1: Developing the Application

  1. Follow the steps in How Do I: Create a new In-Sight Application in C# with Visual Studio .NET 2012.

  2. Change the Configuration to Release.

  3. Rebuild the solution.

Stage 2: Preparing the Target PC

Install the In-Sight Core Components package (Cognex In-Sight Core Components 6.5.0.exe) on the target PC. This installer is installed with the In-Sight SDK in the following (default) location:

  • [32-bit OS] C:\Program Files\Cognex\In-Sight\In-Sight SDK 6.5.0\bin

  • [64-bit OS] C:\Program Files (x86)\Cognex\In-Sight\In-Sight SDK 6.5.0\bin

Stage 3: Deploying the Application

  1. Copy DisplayTest\bin\Release\DisplayTest.exe into any folder on the target PC.

  2. On the target PC, run DisplayTest.exe.

At this point, you can build new In-Sight applications and copy their executable files (and any dependencies) to the target PC without the need to generate a custom installer package for each application.


64-bit Operating Systems (BadImageFormatException)

Troubleshooting

Why is my application crashing with a BadImageFormatException?

If you are developing an In-Sight SDK application on a 64-bit operating system, you must set your Platform Target to x86. If the Platform Target is set to Any CPU or x64, your application may crash with a FileNotFoundException or BadImageFormatException.

To configure your application for an x86 Target Platform in Visual Studio:

C#
  • In Solution Explorer, right-click your project and select Properties.
  • Select the Build tab.
  • Toggle the Platform target drop-down list to be x86.
  • Save and rebuild your project.
VB .NET
  • In Solution Explorer, right-click your project and select Properties.
  • Select the Compile tab.
  • Near the bottom, click the Advanced Compile Options... button.
  • Under Compilation Constants, change the Target CPU to x86.
  • Click OK.
  • Save and rebuild your project.


CvsNetworkMonitor does not Raise a HostsChanged Event for Emulators

If you shut down In-Sight Explorer or the emulator on a remote computer, the CvsNetworkMonitor never raises a HostsChanged event when using PingInterval since the remote PC still responds to the ping request. (CR 4461)


Deployment Troubleshooting

Troubleshooting

Deployment

During compilation of a Visual Studio Setup/Deployment project, you may observe build warnings similar to the following:

Unable to find module dependency with signature ...

The In-Sight Core Components depends on the following:

Microsoft Visual C++ 8.0 Runtime (8.0.50727.6195)

  • Microsoft_VC80_CRT_x86.msm

  • policy_8_0_Microsoft_VC80_CRT_x86.msm

Microsoft Visual C++ 10.0 Runtime (10.0.30319.460)

  • Microsoft_VC80_CRT_x86.msm

Any development machine that builds custom In-Sight SDK applications for deployment must have the preceding merge modules available. The Cognex In-Sight Core Components merge module references these merge modules as dependencies; if they are present on the development machine, they will be included automatically in your custom installer.

Two or more objects have the same target location ...

The Cognex In-Sight Core Components merge module installs many of its assemblies into the Global Assembly Cache (GAC). Several of these assemblies, being resource assemblies, have the exact same file name. Visual Studio detects that files are being installed to the same location with the same name; however, the GAC allows side-by-side installation of assemblies that have the same file name but different Assembly Names. These warnings can be safely ignored.


EditCellGraphic

Troubleshooting

Why isn't the EditCellGraphic method (editing action) working?

Cells such as ExtractBlobs and EditRegion have graphics associated with them, and the EditCellGraphic method of the CvsInSightDisplay control can be used to allow the user to edit the graphic interactively. This method takes arguments that specify the cell location for which to edit a graphic. The CvsInSightDisplayEdit class also exposes an EditCellGraphic action that will edit the default graphic of the current (active) cell. In most cases applications should call the EditCellGraphic method of the display control rather than calling the Execute method of the EditCellGraphic editing action, because an application can call the EditCellGraphic method without having to set the current cell or wait for the display to receive new results as described below.

The EditCellGraphic editing action edits the graphic of the cell specified by the CurrentCell property. When you change the CurrentCell property, the new cell coordinates are sent to the sensor and there will be a short time delay until the sensor responds with graphic information for the new current cell. Until the graphic information has been received for the current cell the EditCellGraphic editing action will remain disabled, and calling its Execute method will have no effect. Therfore before your application calls this editing action's Execute method, it must first check the Enabled property of the action to ensure that it is true or the action will have no effect. If your application waits for the Enabled property to become true, it must also call DoEvents while waiting in order to allow the display control to process new results received from the sensor.


Event Troubleshooting

Troubleshooting

Why don't I get events from the CvsInSight?

Events are raised on the same thread that called the CvsInSight.Connect method, which is normally the main thread of the application. Thus, the main thread must be allowed to handle the event.

If an operation that takes long to complete is performed, it may be necessary to allow the events to be handled. This can be forced by calling Application.DoEvents (in .NET), allowing the event handler to be executed.

Why are my CvsInSight.Results not updating?

When an application is ready for new results, it should call the CvsInSight.AcceptUpdate method. This may be called at the end of the handler for the ResultsChanged event.

If an application handles the ResultsChanged event, it may be necessary to call Application.DoEvents (in .NET) to allow the event handler to process the new acquisition and spreadsheet data. For methods that do not immediately generate new events, this also allows the CvsInSight.Results property to be updated with the new data from the sensor.

It is best, however, to write an application such that the use of DoEvents is not needed. Consider the following example of an application that displays a value from cell A2 with each acquisition. The ResultsChanged event updates the value of a text box that displays the value of the cell. In this code, there is no need to use DoEvents; the application is completely event driven. A Button is used to trigger an acquisition, and a TextBox is used to display the cell that holds the result.

C#

  private void ManualAcquireButton_Click(object sender, System.EventArgs e)
  {
    insight.ManualAcquire(); // Request a new acquisition to generate new results
  }

  private void insight_ResultsChanged(object sender, System.EventArgs e)
  {
    CvsCell cell = insight.Results.Cells["A2"];
    if(cell != null)
    {
      A2TextBox.Text = cell.Text;
    }

    insight.AcceptUpdate(); // Tell the sensor that the application is ready for new results.
  }

VB .NET

Imports Cognex.InSight
Imports Cognex.InSight.Cell

Public Class MyForm
  Inherits System.Windows.Forms.Form

  Private WithEvents insight As CvsInSight

  Private Sub ManualAcquireButton_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ManualAcquireButton.Click
    insight.ManualAcquire() ' Request a new acquisition to generate new results
  End Sub

  ' Notification that the sensor has sent new results
  Private Sub insight_ResultsChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles insight.ResultsChanged
    Dim cell As CvsCell

    cell = insight.Results.Cells("A2") ' Examine cell A2
    If (Not cell Is Nothing) Then
      A2TextBox.Text = cell.Text ' Copy the text for A2 to the visible TextBox
    End If

    insight.AcceptUpdate() ' Tell the sensor that the application is ready for new results.

  End Sub

End Class

How can I know when a change to a spreadsheet edit control has produced new CvsInSight.Results?

The Results may not update if an application performs an operation that does not wait for new results to be received from the sensor. In this case, calling DoEvents after a period of time has elapsed will allow the results to be updated. The following examples defines a method that will update an EditInt control and wait for the results to be sent back from the sensor:

C#

using Cognex.InSight;
using Cognex.InSight.Cell;

public class Form1 : System.Windows.Forms.Form
{
  private bool gotResults; // a global flag to indicate new results
  private CvsInSight insight; // CvsInSight object to use
  private void insight_ResultsChanged(object sender, System.EventArgs e)
  {
    gotResults = true; // Set the global flag indicating new results

    insight.AcceptUpdate(); // Tell the sensor that the application is ready for new results.
  }

  private bool UpdateEditIntAndWait(string cellLocation, int newValue)
  {
    gotResults = false;

    // Update an edit control
    insight.SetInteger(new CvsCellLocation(cellLocation), newValue);

    // Wait for the sensor to process the command
    int attempts = 30; // Allows approximately 3 seconds to get a response
    while (attempts > 0)
    {
      attempts = attempts - 1;
      System.Threading.Thread.Sleep(100); // Wait 1/10 second

      // Allow the new Results to be processed
      Application.DoEvents();

      if (gotResults)
      {
        CvsCell cell = insight.Results.Cells[cellLocation];
        if ( (cell != null) && (cell.Text == newValue.ToString() ) )
          return true;
        else
          gotResults = false;
      }
    }
  return false; // Failed to get the expected update within 3 seconds
  }
}

VB .NET

Imports Cognex.InSight
Imports Cognex.InSight.Cell

Public Class MyForm

  Private WithEvents insight As CvsInSight

  Private gotResults As Boolean ' A global flag to indicate new results

  ' Notification that the sensor has sent new results
  Private Sub insight_ResultsChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles insight.ResultsChanged
    gotResults = True ' Set the global flag indicating new results
    insight.AcceptUpdate() ' Tell the sensor that the application is ready for new results.
  End Sub

  ' A function that waits for an EditInt cell to be processed with the newValue.
  ' Returns true when the new Results with the updated edit control are received.
  Private Function UpdateEditIntAndWait(ByVal cellLocation As String, ByVal newValue As Integer) As Boolean
    gotResults = False
    ' Update an edit control
    insight.SetInteger(New CvsCellLocation(cellLocation), newValue)
    ' Wait for the sensor to process the command
    Dim attempts As Integer = 30 ' Will allow approximately 3 seconds to get a response
    While (attempts > 0)
      attempts = attempts - 1

      System.Threading.Thread.Sleep(100) ' Wait 1/10 second
      ' Allow the new Results to be processed
      Application.DoEvents()

      If (gotResults) Then
        Dim cell As CvsCell
        cell = insight.Results.Cells(cellLocation)
        If ((Not cell Is Nothing) And cell.Text = newValue.ToString()) Then
          Return True
        End If
        gotResults = False
      End If
    End While

    Return False ' Failed to get the expected update within 3 seconds
  End Function
End Class

Calling UpdateEditIntAndWait("A2", 10) will wait for the results to be sent from the sensor with the value for cell A2 of 10. The call to SetInteger makes a request of the sensor to update the value of an edit control. This command returns immediately and does not wait for any results to be generated. To obtain the updated results after the SetInteger request has been processed: (1) The ResultsChanged event is subscribed to, and (2) the Results are examined in the waiting method looking for the expected value to be returned from the sensor. (Remember, the event handler runs in the same thread that called Connect.)

I make calls to the CvsInSightDisplay and the CvsInSight from different threads. Why does my application behave erratically?

The CvsInSight is not thread-safe; in other words, it is not safe to call methods on CvsInSight objects simultaneously from multiple threads. It is safest, however, to always make requests of these objects from the same thread that called CvsInSight.Connect. See Microsoft Knowledge Base article Q316136 for information on how to synchronize access to a shared resource in a multithreaded environment using Visual Basic .NET.

The CvsInSightDisplay is a Control, so it is absolutely illegal to call any method or property (except Invoke-related members) of it from anything but the main thread.


Exception Handling

In .NET applications the term exception usually refers to an error, although in some cases it may just mean that something unusual has happened. Good handling of exceptions is key to building any robust application, and you should strive to handle exceptions in your applications whenever and wherever possible. When using the In-Sight SDK, there are some special considerations for handling exceptions that may not be immediately apparent.

We have attempted to thoroughly document all exceptions that might be generated by every property or method, but it is best to assume that calling any method or property of any object within the In-Sight SDK might generate an exception; write your code to handle the exception and recover as well as possible. Do not assume that just because a method works 99.9% of the time it will always work. For example, a network problem could cause your application to lose its connection to an In-Sight sensor at any time, and most of the properties and methods of the CvsInSight object will throw exceptions if a sensor is not connected. Code that seems to work flawlessly could suddenly crash due to an unforeseen network problem if you do not have exception handling code throughout your application, because an unhandled exception will shut your application down.

In .NET languages such as C# and VB.NET, exceptions are handled using a Try/Catch block. Please refer to your language documentation for details on the syntax for handling exceptions. It is best to have an exception handler in every method of your application, and you should try to handle and recover from each of the documented error conditions as specifically as possible.

Debugging Exceptions

When your application causes an exception, it is usually helpful to stop the debugger right at the point where the exception is generated. If you have good exception-handling code in your application, the debugger may not stop or you may stop it at a point where the exception is handled, and at that point it may be unclear what line of code caused the exception in the first place. This is particularly important if your code causes an exception in an event handler, because in .NET applications the implementation of events in classes like the CvsInSight may cause the debugger to stop within the In-Sight SDK code that raised the event rather than at the point in your code that caused the exception.

For example, a common mistake is to try to read a property of a cell result that does not exist. Suppose that your application contained code like this:

Caption = InSight.Results.Cells("A3").Text

If the results set received from the sensor did not contain a cell at location A3, a NullReferenceException would be generated because Cells("A3") returns null (Nothing in Visual Basic). If this code is in a handler for the ResultsChanged event and you have insufficient exception handling code in a .NET application, the debugger may not stop until your event handler exits and it may stop inside the CvsInSight code that raises the event instead of in your code. If you do have exception handling code in all your methods (good for you!), by the time the exception is caught it may be impossible to tell exactly which line of code caused the original problem unless you configure your debugger to stop as soon as the exception is generated.

Visual Studio .NET

Visual Studio .NET provides a way to stop the debugger as soon as a particular type of exception is thrown, but by default it does not; therefore, you must specifically turn on this capability when you encounter a problem. For example, you can tell the Visual Studio .NET debugger to break immediately as soon as a NullReferenceException is generated, and the debugger will stop on the line that caused the problem. In order to do this, select Debug > Exceptions and expand the Common Language Runtime Exceptions node in the tree. Under the System node, select the entry for System.NullReferenceException. In the box labeled When the exception is thrown, select Break into the debugger. Now run your application; the debugger will break immediately whenever any NullReferenceException is generated. You can do this for any type of exception in the .NET framework, and you can also break on In-Sight SDK exceptions by selecting the Common Language Runtime Exceptions node and using the Add... button, specifying the full name of the exception (including its namespace) such as Cognex.InSight.CvsInSightLockedException.


IO Module Dialog

Troubleshooting

I/O Module Dialog Not Available

If your In-Sight Display Control application utilizes the Discrete Input Settings dialog or the Discrete Output Settings dialog, the I/O Module button may not function when clicked:

If this occurs, you will need to add a reference to the Cognex.Cnx.CioMicro assembly in your project:

Recompile your application. The I/O Module Selection Dialog should now appear correctly:

If you intend to deploy your application with this functionality, you will need to add a reference to the Cognex.Cnx.CioMicro merge module in your setup/deployment project.


Printing Problems

The Job View window of In-Sight Explorer provides the ability to print the contents of the spreadsheet, and this capability is also available when the CvsInSightDisplay control is used in a custom application. Most printers are able to print the spreadsheet output without problems, but some older printer drivers may not print the spreadsheet correctly. If you experience printing problems, try updating to the latest revision of the printer driver from the manufacturer of your printer. Some printer manufacturers may offer more than one driver for a given printer, such as a PostScript® driver and a non-PostScript driver; if one driver does not print correctly, the other may work. If your printer is still unable to print the spreadsheet correctly after updating to the latest driver, it may not support all of the features that the In-Sight software requires for printing.

As an alternative to printing the spreadsheet directly, you can copy an image of the visible portion of the spreadsheet to the clipboard by pressing Ctrl+Shift+C. This image can then be pasted into any application that supports images (such as Microsoft® Word), and you can then print it. Although this will print exactly what you see on the screen, the quality is not as good as when the spreadsheet content is sent directly to the printer.


Property Sheet Help

When the In-Sight Display Control is used in a custom application, the property sheet help is not available by default. In order for the property sheet help to be available to your custom application, you must copy the In-Sight Explorer help file into a 'Documentation\Help' subfolder relative to where your application's executable exists.

For example--if you installed In-Sight Explorer to the default folder--the help file can be copied from "%ProgramFiles(x86)%\Cognex\In-Sight\In-Sight Explorer 6.5.0\Documentation\Help\Help_ISE_EN.chm" into "Documentation\Help\Help_ISE_EN.chm" relative to the location from which your custom application executes. The In-Sight Explorer help file can also be downloaded from the In-Sight Support web site.


Namespaces
Send Feedback

Namespaces

Namespace | Description
Cognex.Cnx.ComponentModel |
Cognex.InSight | The Cognex.InSight namespace provides classes for accessing an In-Sight sensor. The primary class in this namespace is CvsInSight that allows a direct connection to an In-Sight sensor.
Cognex.InSight.Cell | The Cognex.InSight.Cell namespace provides the classes for accessing cell data associated with a set of results.
Cognex.InSight.Controls | The Cognex.InSight.Controls namespace provides classes for representing actions that can be reset; can be enabled and disabled; can be bound to a Boolean property of another object; and can be invoked by an event.
Cognex.InSight.Controls.Display | The Cognex.InSight.Controls.Display namespace contains the CvsInSightDisplay for displaying images and graphics.
Cognex.InSight.Controls.Display.Extensions |
Cognex.InSight.Controls.Filmstrip | The Cognex.InSight.Controls.Filmstrip namespace contains the CvsFilmstrip control for displaying results.
Cognex.InSight.Extensions |
Cognex.InSight.Ftp | The Cognex.InSight.Ftp namespace provides classes for accessing an In-Sight sensor via FTP.
Cognex.InSight.Graphic | The Cognex.InSight.Graphic namespace provides the classes for accessing the graphics associated with a set of results.
Cognex.InSight.NativeMode | The Cognex.InSight.NativeMode namespace provides classes for accessing an In-Sight sensor via Native Mode.
Cognex.InSight.Net | The Cognex.InSight.Net namespace provides the CvsNetworkMonitor class for detecting In-Sight sensors on a network.
Cognex.InSight.Sensor | The Cognex.InSight.Sensor namespace provides classes for accessing and configuring the settings of an In-Sight sensor.


Cognex.Cnx.ComponentModel Namespace

[image]

In-Sight SDK
Cognex.Cnx.ComponentModel Namespace
Send Feedback

Classes

 | Class | Description
Public class | CnxResourceChangedEvent | An event received from ICnxResource.
Public class | CnxResourceChangedEvent<(Of <(<'T>)>)> | An event received from ICnxResource.
Public class | CnxResourceProperty<(Of <(<'T>)>)> | A read/write property.
Public class | CnxResourceReadOnlyProperty<(Of <(<'T>)>)> | A read-only property.


CnxResourceChangedEvent Class

[image]

In-Sight SDK
CnxResourceChangedEvent Class
Members See Also Send Feedback
An event received from ICnxResource.

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CnxResourceChangedEvent
Visual Basic
Public Class CnxResourceChangedEvent

Inheritance Hierarchy

System..::..Object
Cognex.Cnx.ComponentModel..::..CnxResourceChangedEvent

See Also

CnxResourceChangedEvent..::..CnxResourceChangedEvent Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent Members

[image] [image]

In-Sight SDK
CnxResourceChangedEvent Members
CnxResourceChangedEvent Class Constructors Methods Events See Also Send Feedback

The CnxResourceChangedEvent type exposes the following members.

Constructors

 | Name | Description
Public method | CnxResourceChangedEvent |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged |
Public method | RemoveEventHandler |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Events

 | Name | Description
Public event | Changed |

See Also

CnxResourceChangedEvent Class
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent Constructor

[image]

In-Sight SDK
CnxResourceChangedEvent Constructor
CnxResourceChangedEvent Class See Also Send Feedback

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CnxResourceChangedEvent(
    ICnxResource resource,
    string path
)
Visual Basic
Public Sub New (
    resource As ICnxResource,
    path As String
)

Parameters

resource
Type: ICnxResource

[Missing <param name="resource"/> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceChangedEvent.#ctor(Cognex.Cnx.ComponentModel.ICnxResource,System.String)"]

path
Type: System..::..String

[Missing <param name="path"/> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceChangedEvent.#ctor(Cognex.Cnx.ComponentModel.ICnxResource,System.String)"]

See Also

CnxResourceChangedEvent Class
CnxResourceChangedEvent..::..CnxResourceChangedEvent Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent Methods

[image] [image]

In-Sight SDK
CnxResourceChangedEvent Methods
CnxResourceChangedEvent Class See Also Send Feedback

The CnxResourceChangedEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged |
Public method | RemoveEventHandler |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CnxResourceChangedEvent Class
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent.OnChanged Method

[image]

In-Sight SDK
CnxResourceChangedEvent..::..OnChanged Method
CnxResourceChangedEvent Class See Also Send Feedback

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected virtual void OnChanged(
    Object sender,
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnChanged (
    sender As Object,
    e As EventArgs
)

Parameters

sender
Type: System..::..Object

[Missing <param name="sender"/> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceChangedEvent.OnChanged(System.Object,System.EventArgs)"]

e
Type: System..::..EventArgs

[Missing <param name="e"/> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceChangedEvent.OnChanged(System.Object,System.EventArgs)"]

See Also

CnxResourceChangedEvent Class
CnxResourceChangedEvent..::..CnxResourceChangedEvent Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent.RemoveEventHandler Method

[image]

In-Sight SDK
CnxResourceChangedEvent..::..RemoveEventHandler Method
CnxResourceChangedEvent Class See Also Send Feedback

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool RemoveEventHandler()
Visual Basic
Public Function RemoveEventHandler As Boolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceChangedEvent.RemoveEventHandler"]

See Also

CnxResourceChangedEvent Class
CnxResourceChangedEvent..::..CnxResourceChangedEvent Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent Events

[image] [image]

In-Sight SDK
CnxResourceChangedEvent Events
CnxResourceChangedEvent Class See Also Send Feedback

The CnxResourceChangedEvent type exposes the following members.

Events

 | Name | Description
Public event | Changed |

See Also

CnxResourceChangedEvent Class
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent.Changed Event

[image]

In-Sight SDK
CnxResourceChangedEvent..::..Changed Event
CnxResourceChangedEvent Class See Also Send Feedback

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler Changed
Visual Basic
Public Event Changed As EventHandler

Value

Type: System..::..EventHandler

See Also

CnxResourceChangedEvent Class
CnxResourceChangedEvent..::..CnxResourceChangedEvent Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent(T) Class

[image]

In-Sight SDK
CnxResourceChangedEvent<(Of <(<'T>)>)> Class
Members See Also Send Feedback
An event received from ICnxResource.

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CnxResourceChangedEvent<T>
Visual Basic
Public Class CnxResourceChangedEvent(Of T)

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Cognex.Cnx.ComponentModel.CnxResourceChangedEvent`1"]

Inheritance Hierarchy

System..::..Object
Cognex.Cnx.ComponentModel..::..CnxResourceChangedEvent<(Of <(<'T>)>)>

See Also

CnxResourceChangedEvent<(Of <(<'T>)>)>..::..CnxResourceChangedEvent<(Of <(<'T>)>)> Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent(T) Members

[image] [image]

In-Sight SDK
CnxResourceChangedEvent<(Of <(<'T>)>)> Members
CnxResourceChangedEvent<(Of <(<'T>)>)> Class Constructors Methods Events See Also Send Feedback

The CnxResourceChangedEvent<(Of <(<'T>)>)> generic type exposes the following members.

Constructors

 | Name | Description
Public method | CnxResourceChangedEvent<(Of <(<'T>)>)> |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged |
Public method | RemoveEventHandler |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Events

 | Name | Description
Public event | Changed |

See Also

CnxResourceChangedEvent<(Of <(<'T>)>)> Class
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent(T) Constructor

[image]

In-Sight SDK
CnxResourceChangedEvent<(Of <(<'T>)>)> Constructor
CnxResourceChangedEvent<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CnxResourceChangedEvent(
    ICnxResource resource,
    string path
)
Visual Basic
Public Sub New (
    resource As ICnxResource,
    path As String
)

Parameters

resource
Type: ICnxResource

[Missing <param name="resource"/> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceChangedEvent`1.#ctor(Cognex.Cnx.ComponentModel.ICnxResource,System.String)"]

path
Type: System..::..String

[Missing <param name="path"/> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceChangedEvent`1.#ctor(Cognex.Cnx.ComponentModel.ICnxResource,System.String)"]

See Also

CnxResourceChangedEvent<(Of <(<'T>)>)> Class
CnxResourceChangedEvent<(Of <(<'T>)>)>..::..CnxResourceChangedEvent<(Of <(<'T>)>)> Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent(T) Methods

[image] [image]

In-Sight SDK
CnxResourceChangedEvent<(Of <(<'T>)>)> Methods
CnxResourceChangedEvent<(Of <(<'T>)>)> Class See Also Send Feedback

The CnxResourceChangedEvent<(Of <(<'T>)>)> generic type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged |
Public method | RemoveEventHandler |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CnxResourceChangedEvent<(Of <(<'T>)>)> Class
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent(T).OnChanged Method

[image]

In-Sight SDK
CnxResourceChangedEvent<(Of <(<'T>)>)>..::..OnChanged Method
CnxResourceChangedEvent<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected virtual void OnChanged(
    Object sender,
    ValueEventArgs<T> e
)
Visual Basic
Protected Overridable Sub OnChanged (
    sender As Object,
    e As ValueEventArgs(Of T)
)

Parameters

sender
Type: System..::..Object

[Missing <param name="sender"/> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceChangedEvent`1.OnChanged(System.Object,Cognex.Common.ValueEventArgs{`0})"]

e
Type: ValueEventArgs<(Of <(<' T >)>)>

[Missing <param name="e"/> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceChangedEvent`1.OnChanged(System.Object,Cognex.Common.ValueEventArgs{`0})"]

See Also

CnxResourceChangedEvent<(Of <(<'T>)>)> Class
CnxResourceChangedEvent<(Of <(<'T>)>)>..::..CnxResourceChangedEvent<(Of <(<'T>)>)> Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent(T).RemoveEventHandler Method

[image]

In-Sight SDK
CnxResourceChangedEvent<(Of <(<'T>)>)>..::..RemoveEventHandler Method
CnxResourceChangedEvent<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool RemoveEventHandler()
Visual Basic
Public Function RemoveEventHandler As Boolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceChangedEvent`1.RemoveEventHandler"]

See Also

CnxResourceChangedEvent<(Of <(<'T>)>)> Class
CnxResourceChangedEvent<(Of <(<'T>)>)>..::..CnxResourceChangedEvent<(Of <(<'T>)>)> Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent(T) Events

[image] [image]

In-Sight SDK
CnxResourceChangedEvent<(Of <(<'T>)>)> Events
CnxResourceChangedEvent<(Of <(<'T>)>)> Class See Also Send Feedback

The CnxResourceChangedEvent<(Of <(<'T>)>)> generic type exposes the following members.

Events

 | Name | Description
Public event | Changed |

See Also

CnxResourceChangedEvent<(Of <(<'T>)>)> Class
Cognex.Cnx.ComponentModel Namespace


CnxResourceChangedEvent(T).Changed Event

[image]

In-Sight SDK
CnxResourceChangedEvent<(Of <(<'T>)>)>..::..Changed Event
CnxResourceChangedEvent<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event ValueEventHandler<T> Changed
Visual Basic
Public Event Changed As ValueEventHandler(Of T)

Value

Type: ValueEventHandler<(Of <(<' T >)>)>

See Also

CnxResourceChangedEvent<(Of <(<'T>)>)> Class
CnxResourceChangedEvent<(Of <(<'T>)>)>..::..CnxResourceChangedEvent<(Of <(<'T>)>)> Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceProperty(T) Class

[image]

In-Sight SDK
CnxResourceProperty<(Of <(<'T>)>)> Class
Members See Also Send Feedback
A read/write property.

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CnxResourceProperty<T>
Visual Basic
Public Class CnxResourceProperty(Of T)

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Cognex.Cnx.ComponentModel.CnxResourceProperty`1"]

Inheritance Hierarchy

System..::..Object
Cognex.Cnx.ComponentModel..::..CnxResourceProperty<(Of <(<'T>)>)>

See Also

CnxResourceProperty<(Of <(<'T>)>)>..::..CnxResourceProperty<(Of <(<'T>)>)> Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceProperty(T) Members

[image] [image]

In-Sight SDK
CnxResourceProperty<(Of <(<'T>)>)> Members
CnxResourceProperty<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The CnxResourceProperty<(Of <(<'T>)>)> generic type exposes the following members.

Constructors

 | Name | Description
Public method | CnxResourceProperty<(Of <(<'T>)>)> |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Value | Gets or sets the value.

See Also

CnxResourceProperty<(Of <(<'T>)>)> Class
Cognex.Cnx.ComponentModel Namespace


CnxResourceProperty(T) Constructor

[image]

In-Sight SDK
CnxResourceProperty<(Of <(<'T>)>)> Constructor
CnxResourceProperty<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the CnxResourceProperty<(Of <(<'T>)>)> class

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CnxResourceProperty(
    ICnxResource resource,
    string path
)
Visual Basic
Public Sub New (
    resource As ICnxResource,
    path As String
)

Parameters

resource
Type: ICnxResource

[Missing <param name="resource"/> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceProperty`1.#ctor(Cognex.Cnx.ComponentModel.ICnxResource,System.String)"]

path
Type: System..::..String

[Missing <param name="path"/> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceProperty`1.#ctor(Cognex.Cnx.ComponentModel.ICnxResource,System.String)"]

See Also

CnxResourceProperty<(Of <(<'T>)>)> Class
CnxResourceProperty<(Of <(<'T>)>)>..::..CnxResourceProperty<(Of <(<'T>)>)> Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceProperty(T) Methods

[image] [image]

In-Sight SDK
CnxResourceProperty<(Of <(<'T>)>)> Methods
CnxResourceProperty<(Of <(<'T>)>)> Class See Also Send Feedback

The CnxResourceProperty<(Of <(<'T>)>)> generic type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CnxResourceProperty<(Of <(<'T>)>)> Class
Cognex.Cnx.ComponentModel Namespace


CnxResourceProperty(T) Properties

[image] [image]

In-Sight SDK
CnxResourceProperty<(Of <(<'T>)>)> Properties
CnxResourceProperty<(Of <(<'T>)>)> Class See Also Send Feedback

The CnxResourceProperty<(Of <(<'T>)>)> generic type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets or sets the value.

See Also

CnxResourceProperty<(Of <(<'T>)>)> Class
Cognex.Cnx.ComponentModel Namespace


CnxResourceProperty(T).Value Property

[image]

In-Sight SDK
CnxResourceProperty<(Of <(<'T>)>)>..::..Value Property
CnxResourceProperty<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the value.

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public T Value { get; set; }
Visual Basic
Public Property Value As T
    Get
    Set

Property Value

Type: T

See Also

CnxResourceProperty<(Of <(<'T>)>)> Class
CnxResourceProperty<(Of <(<'T>)>)>..::..CnxResourceProperty<(Of <(<'T>)>)> Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceReadOnlyProperty(T) Class

[image]

In-Sight SDK
CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Class
Members See Also Send Feedback
A read-only property.

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CnxResourceReadOnlyProperty<T>
Visual Basic
Public Class CnxResourceReadOnlyProperty(Of T)

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Cognex.Cnx.ComponentModel.CnxResourceReadOnlyProperty`1"]

Inheritance Hierarchy

System..::..Object
Cognex.Cnx.ComponentModel..::..CnxResourceReadOnlyProperty<(Of <(<'T>)>)>

See Also

CnxResourceReadOnlyProperty<(Of <(<'T>)>)>..::..CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceReadOnlyProperty(T) Members

[image] [image]

In-Sight SDK
CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Members
CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The CnxResourceReadOnlyProperty<(Of <(<'T>)>)> generic type exposes the following members.

Constructors

 | Name | Description
Public method | CnxResourceReadOnlyProperty<(Of <(<'T>)>)> |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Value | Gets the value.

See Also

CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Class
Cognex.Cnx.ComponentModel Namespace


CnxResourceReadOnlyProperty(T) Constructor

[image]

In-Sight SDK
CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Constructor
CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the CnxResourceReadOnlyProperty<(Of <(<'T>)>)> class

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CnxResourceReadOnlyProperty(
    ICnxResource resource,
    string path
)
Visual Basic
Public Sub New (
    resource As ICnxResource,
    path As String
)

Parameters

resource
Type: ICnxResource

[Missing <param name="resource"/> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceReadOnlyProperty`1.#ctor(Cognex.Cnx.ComponentModel.ICnxResource,System.String)"]

path
Type: System..::..String

[Missing <param name="path"/> documentation for "M:Cognex.Cnx.ComponentModel.CnxResourceReadOnlyProperty`1.#ctor(Cognex.Cnx.ComponentModel.ICnxResource,System.String)"]

See Also

CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Class
CnxResourceReadOnlyProperty<(Of <(<'T>)>)>..::..CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Members
Cognex.Cnx.ComponentModel Namespace


CnxResourceReadOnlyProperty(T) Methods

[image] [image]

In-Sight SDK
CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Methods
CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Class See Also Send Feedback

The CnxResourceReadOnlyProperty<(Of <(<'T>)>)> generic type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Class
Cognex.Cnx.ComponentModel Namespace


CnxResourceReadOnlyProperty(T) Properties

[image] [image]

In-Sight SDK
CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Properties
CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Class See Also Send Feedback

The CnxResourceReadOnlyProperty<(Of <(<'T>)>)> generic type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets the value.

See Also

CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Class
Cognex.Cnx.ComponentModel Namespace


CnxResourceReadOnlyProperty(T).Value Property

[image]

In-Sight SDK
CnxResourceReadOnlyProperty<(Of <(<'T>)>)>..::..Value Property
CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the value.

Namespace: Cognex.Cnx.ComponentModel
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public T Value { get; }
Visual Basic
Public ReadOnly Property Value As T
    Get

Property Value

Type: T

See Also

CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Class
CnxResourceReadOnlyProperty<(Of <(<'T>)>)>..::..CnxResourceReadOnlyProperty<(Of <(<'T>)>)> Members
Cognex.Cnx.ComponentModel Namespace


Cognex.InSight Namespace

[image]

In-Sight SDK
Cognex.InSight Namespace
Send Feedback
The Cognex.InSight namespace provides classes for accessing an In-Sight sensor. The primary class in this namespace is CvsInSight that allows a direct connection to an In-Sight sensor.

Classes

 | Class | Description
Public class | CvsAuditMessageSettings | Holds the audit message settings for an In-Sight sensor.
Public class | CvsCellLocationOffsetTag | Holds a CvsCellLocationOffset for block of cells.
Public class | CvsCellProtectionException | The exception that is thrown when the application is not licensed for the In-Sight SDK.
Public class | CvsColorMap | Contains a collection of color map entries.
Public class | CvsColorMapArrayTag | Holds a collection of CvsColorMaps for a block of cells.
Public class | CvsCommunicationException | Provides a base class for exceptions that are thrown when a communication failure occurs.
Public class | CvsConnectCompletedEventArgs | Provides data for the ConnectCompleted event, which is raised after an asynchronous call to the Connect(IPAddress, String, String, Boolean, Boolean) method has completed.
Public class | CvsEasyView | Holds the list of EasyView items that define an EasyView.
Public class | CvsEasyViewItem | Encapsulates the data that defines an EasyView item.
Public class | CvsException | Provides a base class for all exceptions generated by In-Sight SDK components.
Public class | CvsExpressionException | The exception that is thrown when an error occurs setting a spreadsheet expression.
Public class | CvsFeatureLicense | Performs license checking for In-Sight SDK features.
Public class | CvsFile | Holds information related to a file or directory located on an In-Sight sensor.
Public class | CvsFileCollection | Holds a collection of CvsFile objects that represent files and directories that reside on an In-Sight sensor.
Public class | CvsFileManager | Holds the file accessing methods for a connection to an In-Sight sensor.
Public class | CvsFileNotFoundException | The exception that is thrown when a file is not found on the sensor.
Public class | CvsFileOperationFailedException | The exception that is thrown when a file operation fails.
Public class | CvsHmiSettings | Settings for the HTTP HMI server.
Public class | CvsImage | Encapsulates the data associated with an acquired image from an In-Sight sensor.
Public class | CvsIncompleteImageException | Exception that is thrown when an incomplete or invalid CvsImage has been accessed.
Public class | CvsInSight | Provides a direct connection to an In-Sight sensor. Use of this class while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed, the constructor will throw a CvsNotLicensedException.
Public class | CvsInSightLockedException | The exception that is thrown when an In-Sight sensor is locked.
Public class | CvsInSightMessageEventArgs | Provides data for the InSightMessage event.
Public class | CvsInSightPortsExtensions | Extension methods for CvsInSightPorts.
Public class | CvsInSightSoftwareDevelopmentKit | An abstract class to initialize the In-Sight Software Development Kit.
Public class | CvsInvalidInsertException | The exception that is thown when a cell insertion fails.
Public class | CvsInvalidLogonException | The exception that is thrown when an invalid username or password has been specified.
Public class | CvsInvalidTimeException | The exception that is thrown when an invalid username or password has been specified.
Public class | CvsJobInfo | Holds the information about the job loaded on an In-Sight sensor.
Public class | CvsLiveAcquisitionException | The exception that is thrown when the requested operation cannot be performed because the sensor is acquiring live images.
Public class | CvsLoadCompletedEventArgs | Provides data for the LoadCompleted event.
Public class | CvsModbusSettings | Holds the modbus settings for an In-Sight sensor.
Public class | CvsNetworkException | The exception that is thrown when a low-level network error occurs.
Public class | CvsNotConnectedException | The exception that is thrown when there is not an open connection to the sensor or the connection has been lost.
Public class | CvsNotLicensedException | The exception that is thrown when the application is not licensed for the In-Sight SDK.
Public class | CvsNotOfflineException | The exception that is thrown when the requested operation cannot be performed because the sensor is not offline.
Public class | CvsPowerlinkSettings | Holds the POWERLINK settings for an In-Sight sensor.
Public class | CvsReferenceRange | Represents a range of cells that comprise a reference in a formula.
Public class | CvsResultSet | Holds the image, graphics, and cells received from an In-Sight sensor.
Public class | CvsSaveCompletedEventArgs | Provides data for the SaveCompleted event.
Public class | CvsSensorAlreadyConnectedException | The exception that is thrown when an In-Sight sensor is already connected to.
Public class | CvsStateChangedEventArgs | Provides data for the StateChanged event.
Public class | CvsSymbolicTag | Holds the symbolic tag information for a single cell.
Public class | CvsSymbolicTagCollection | Represents a collection of CvsSymbolicTag objects.
Public class | CvsTimeoutException | The exception that is thrown when a timeout has occurred.
Public class | CvsUtility | Holds utility methods for Visual Basic 6 and COM/ActiveX interoperability. These methods are equivalent to various static methods of classes and methods of structures that cannot be called directly from COM/ActiveX applications.
Public class | CvsView | Encapsulates the settings for a single In-Sight view.

Structures

 | Structure | Description
Public structure | CvsCellComment | Represents a comment and comment flag color for a cell.
Public structure | CvsCellLocation | Represents a pair of integer row and column coordinates that identifies a cell in the spreadsheet.
Public structure | CvsCellLocationOffset | Represents an offset to apply to a CvsCellLocation.
Public structure | CvsCellRange | Represents a range of locations specified by row and column coordinates.
Public structure | CvsColorMapEntry | Contains the mapping of a color to another color.
Public structure | CvsImageLocation | Represents a pair of floating point row and column coordinates that defines a point in a two-dimensional plane.

Interfaces

 | Interface | Description
Public interface | ICvsActionObject | An interface for objects that get bound to a CvsAction.

Delegates

 | Delegate | Description
Public delegate | CvsConnectCompletedEventHandler | Represents the method that will handle the ConnectCompleted event.
Public delegate | CvsInSightMessageEventHandler | Represents the method that will handle the InSightMessage event.
Public delegate | CvsLoadCompletedEventHandler | Represents the method that will handle the LoadCompleted event.
Public delegate | CvsSaveCompletedEventHandler | Represents the method that will handle the SaveCompleted event.
Public delegate | CvsStateChangedEventHandler | Represents the method that will handle the StateChanged event.

Enumerations

 | Enumeration | Description
Public enumeration | CvsEasyViewItemType | Defines the types of EasyView entries.
Public enumeration | CvsImageOrientation | Constants that specify how an image is oriented relative to its original form.
Public enumeration | CvsInSightLanguage | Defines the possible languages to designate for a connection to an In-Sight sensor.
Public enumeration | CvsInSightMessageId | Defines the message identifiers that may be returned with the InSightMessage event.
Public enumeration | CvsInSightPorts | An enumeration of ports that may be in use on the In-Sight.
Public enumeration | CvsInSightSecurityAccess | Defines the security access privileges available when connected to an In-Sight sensor.
Public enumeration | CvsInSightState | Defines the possible states of the connection to an In-Sight sensor.
Public enumeration | CvsInSightStateChangedReason | Defines the possible reasons that the state of the connection to the In-Sight sensor changed.
Public enumeration | CvsLocalStorageState | An enumeration of the different states for a sensor's SD Card (or Local Storage).
Public enumeration | CvsPixelFormat | Pixel formats supported by the PixelFormat property.
Public enumeration | CvsStatusLevel | Indicates a pass/warn/fail status.
Public enumeration | CvsStatusLevelStyle | Indicates how a CvsStatusLevel should be displayed graphically.


CvsAuditMessageSettings Class

[image]

In-Sight SDK
CvsAuditMessageSettings Class
Members See Also Send Feedback
Holds the audit message settings for an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsAuditMessageSettings
Visual Basic
<SerializableAttribute>
Public Class CvsAuditMessageSettings

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsAuditMessageSettings

See Also

CvsAuditMessageSettings..::..CvsAuditMessageSettings Members
Cognex.InSight Namespace


CvsAuditMessageSettings Members

[image] [image]

In-Sight SDK
CvsAuditMessageSettings Members
CvsAuditMessageSettings Class Methods Properties See Also Send Feedback

The CvsAuditMessageSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a flag that designates whether or not audit messages are enabled.
Public property | IPAddress | Gets or sets the IP address associated with the device that receives the audit messages from the sensor.
Public property | LogEventsEnabled | Gets or sets a flag that designates whether or not the audit message event logging is enabled.
Public property | LogSystemChangesEnabled | Gets or sets a flag that designates whether or not the audit message system change event logging is enabled.
Public property | LogTagsEnabled | Gets or sets a flag that designates whether or not the audit message tag logging is enabled.
Public property | Port | Gets or sets the port associated with the device that receives the audit messages from the sensor.

See Also

CvsAuditMessageSettings Class
Cognex.InSight Namespace


CvsAuditMessageSettings Methods

[image] [image]

In-Sight SDK
CvsAuditMessageSettings Methods
CvsAuditMessageSettings Class See Also Send Feedback

The CvsAuditMessageSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsAuditMessageSettings Class
Cognex.InSight Namespace


CvsAuditMessageSettings.Clone Method

[image]

In-Sight SDK
CvsAuditMessageSettings..::..Clone Method
CvsAuditMessageSettings Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

See Also

CvsAuditMessageSettings Class
CvsAuditMessageSettings..::..CvsAuditMessageSettings Members
Cognex.InSight Namespace


CvsAuditMessageSettings Properties

[image] [image]

In-Sight SDK
CvsAuditMessageSettings Properties
CvsAuditMessageSettings Class See Also Send Feedback

The CvsAuditMessageSettings type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a flag that designates whether or not audit messages are enabled.
Public property | IPAddress | Gets or sets the IP address associated with the device that receives the audit messages from the sensor.
Public property | LogEventsEnabled | Gets or sets a flag that designates whether or not the audit message event logging is enabled.
Public property | LogSystemChangesEnabled | Gets or sets a flag that designates whether or not the audit message system change event logging is enabled.
Public property | LogTagsEnabled | Gets or sets a flag that designates whether or not the audit message tag logging is enabled.
Public property | Port | Gets or sets the port associated with the device that receives the audit messages from the sensor.

See Also

CvsAuditMessageSettings Class
Cognex.InSight Namespace


CvsAuditMessageSettings.Enabled Property

[image]

In-Sight SDK
CvsAuditMessageSettings..::..Enabled Property
CvsAuditMessageSettings Class See Also Send Feedback
Gets or sets a flag that designates whether or not audit messages are enabled.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsAuditMessageSettings Class
CvsAuditMessageSettings..::..CvsAuditMessageSettings Members
Cognex.InSight Namespace


CvsAuditMessageSettings.IPAddress Property

[image]

In-Sight SDK
CvsAuditMessageSettings..::..IPAddress Property
CvsAuditMessageSettings Class See Also Send Feedback
Gets or sets the IP address associated with the device that receives the audit messages from the sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string IPAddress { get; set; }
Visual Basic
Public Property IPAddress As String
    Get
    Set

Property Value

Type: String

See Also

CvsAuditMessageSettings Class
CvsAuditMessageSettings..::..CvsAuditMessageSettings Members
Cognex.InSight Namespace


CvsAuditMessageSettings.LogEventsEnabled Property

[image]

In-Sight SDK
CvsAuditMessageSettings..::..LogEventsEnabled Property
CvsAuditMessageSettings Class See Also Send Feedback
Gets or sets a flag that designates whether or not the audit message event logging is enabled.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool LogEventsEnabled { get; set; }
Visual Basic
Public Property LogEventsEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsAuditMessageSettings Class
CvsAuditMessageSettings..::..CvsAuditMessageSettings Members
Cognex.InSight Namespace


CvsAuditMessageSettings.LogSystemChangesEnabled Property

[image]

In-Sight SDK
CvsAuditMessageSettings..::..LogSystemChangesEnabled Property
CvsAuditMessageSettings Class See Also Send Feedback
Gets or sets a flag that designates whether or not the audit message system change event logging is enabled.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool LogSystemChangesEnabled { get; set; }
Visual Basic
Public Property LogSystemChangesEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsAuditMessageSettings Class
CvsAuditMessageSettings..::..CvsAuditMessageSettings Members
Cognex.InSight Namespace


CvsAuditMessageSettings.LogTagsEnabled Property

[image]

In-Sight SDK
CvsAuditMessageSettings..::..LogTagsEnabled Property
CvsAuditMessageSettings Class See Also Send Feedback
Gets or sets a flag that designates whether or not the audit message tag logging is enabled.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool LogTagsEnabled { get; set; }
Visual Basic
Public Property LogTagsEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsAuditMessageSettings Class
CvsAuditMessageSettings..::..CvsAuditMessageSettings Members
Cognex.InSight Namespace


CvsAuditMessageSettings.Port Property

[image]

In-Sight SDK
CvsAuditMessageSettings..::..Port Property
CvsAuditMessageSettings Class See Also Send Feedback
Gets or sets the port associated with the device that receives the audit messages from the sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Port { get; set; }
Visual Basic
Public Property Port As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsAuditMessageSettings Class
CvsAuditMessageSettings..::..CvsAuditMessageSettings Members
Cognex.InSight Namespace


CvsCellComment Structure

[image]

In-Sight SDK
CvsCellComment Structure
Members See Also Send Feedback
Represents a comment and comment flag color for a cell.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public struct CvsCellComment
Visual Basic
<SerializableAttribute>
Public Structure CvsCellComment

See Also

CvsCellComment..::..CvsCellComment Members
Cognex.InSight Namespace


CvsCellComment Members

[image] [image]

In-Sight SDK
CvsCellComment Members
CvsCellComment Structure Constructors Methods Fields Properties See Also Send Feedback

The CvsCellComment type exposes the following members.

Constructors

 | Name | Description
Public method | CvsCellComment(String) | Constructs a new instance of the CvsCellComment structure.
Public method | CvsCellComment(CvsCellComment) | Constructs a new instance of the CvsCellComment structure.
Public method | CvsCellComment(String, Color) | Constructs a new instance of the CvsCellComment structure.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
DefaultFlagColor | The default flag color.
Empty | An empty comment.

Properties

 | Name | Description
Public property | FlagColor | Gets or sets the flag color.
Public property | Text | Gets or sets the comment text.

See Also

CvsCellComment Structure
Cognex.InSight Namespace


CvsCellComment Constructor

[image] [image]

In-Sight SDK
CvsCellComment Constructor
CvsCellComment Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsCellComment(String) | Constructs a new instance of the CvsCellComment structure.
Public method | CvsCellComment(CvsCellComment) | Constructs a new instance of the CvsCellComment structure.
Public method | CvsCellComment(String, Color) | Constructs a new instance of the CvsCellComment structure.

See Also

CvsCellComment Structure
CvsCellComment..::..CvsCellComment Members
Cognex.InSight Namespace


CvsCellComment Constructor (String)

[image]

In-Sight SDK
CvsCellComment Constructor (String)
CvsCellComment Structure See Also Send Feedback
Constructs a new instance of the CvsCellComment structure.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellComment(
    string text
)
Visual Basic
Public Sub New (
    text As String
)

Parameters

text
Type: System..::..String
The text of the comment.

See Also

CvsCellComment Structure
CvsCellComment..::..CvsCellComment Members
CvsCellComment Overload
Cognex.InSight Namespace


CvsCellComment Constructor (CvsCellComment)

[image]

In-Sight SDK
CvsCellComment Constructor (CvsCellComment)
CvsCellComment Structure See Also Send Feedback
Constructs a new instance of the CvsCellComment structure.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellComment(
    CvsCellComment comment
)
Visual Basic
Public Sub New (
    comment As CvsCellComment
)

Parameters

comment
Type: Cognex.InSight..::..CvsCellComment
The CvsCellComment to copy.

See Also

CvsCellComment Structure
CvsCellComment..::..CvsCellComment Members
CvsCellComment Overload
Cognex.InSight Namespace


CvsCellComment Constructor (String, Color)

[image]

In-Sight SDK
CvsCellComment Constructor (String, Color)
CvsCellComment Structure See Also Send Feedback
Constructs a new instance of the CvsCellComment structure.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellComment(
    string text,
    Color flagColor
)
Visual Basic
Public Sub New (
    text As String,
    flagColor As Color
)

Parameters

text
Type: System..::..String
The text of the comment.
flagColor
Type: System.Drawing..::..Color
The color of the comment flag.

See Also

CvsCellComment Structure
CvsCellComment..::..CvsCellComment Members
CvsCellComment Overload
Cognex.InSight Namespace


CvsCellComment Fields

[image] [image]

In-Sight SDK
CvsCellComment Fields
CvsCellComment Structure See Also Send Feedback

The CvsCellComment type exposes the following members.

Fields

Name | Description
DefaultFlagColor | The default flag color.
Empty | An empty comment.

See Also

CvsCellComment Structure
Cognex.InSight Namespace


CvsCellComment.DefaultFlagColor Field

[image]

In-Sight SDK
CvsCellComment..::..DefaultFlagColor Field
CvsCellComment Structure See Also Send Feedback
The default flag color.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static readonly Color DefaultFlagColor
Visual Basic
Public Shared ReadOnly DefaultFlagColor As Color

Field Value

Type: Color

See Also

CvsCellComment Structure
CvsCellComment..::..CvsCellComment Members
Cognex.InSight Namespace


CvsCellComment.Empty Field

[image]

In-Sight SDK
CvsCellComment..::..Empty Field
CvsCellComment Structure See Also Send Feedback
An empty comment.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static readonly CvsCellComment Empty
Visual Basic
Public Shared ReadOnly Empty As CvsCellComment

Field Value

Type: CvsCellComment

See Also

CvsCellComment Structure
CvsCellComment..::..CvsCellComment Members
Cognex.InSight Namespace


CvsCellComment Methods

[image] [image]

In-Sight SDK
CvsCellComment Methods
CvsCellComment Structure See Also Send Feedback

The CvsCellComment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CvsCellComment Structure
Cognex.InSight Namespace


CvsCellComment.Equals Method

[image]

In-Sight SDK
CvsCellComment..::..Equals Method
CvsCellComment Structure See Also Send Feedback
Indicates whether this instance and a specified object are equal.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: System..::..Object
Another object to compare to.

Return Value

Type: Boolean
true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

CvsCellComment Structure
CvsCellComment..::..CvsCellComment Members
Cognex.InSight Namespace


CvsCellComment.GetHashCode Method

[image]

In-Sight SDK
CvsCellComment..::..GetHashCode Method
CvsCellComment Structure See Also Send Feedback
Returns the hash code for this instance.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A 32-bit signed integer that is the hash code for this instance.

See Also

CvsCellComment Structure
CvsCellComment..::..CvsCellComment Members
Cognex.InSight Namespace


CvsCellComment Properties

[image] [image]

In-Sight SDK
CvsCellComment Properties
CvsCellComment Structure See Also Send Feedback

The CvsCellComment type exposes the following members.

Properties

 | Name | Description
Public property | FlagColor | Gets or sets the flag color.
Public property | Text | Gets or sets the comment text.

See Also

CvsCellComment Structure
Cognex.InSight Namespace


CvsCellComment.FlagColor Property

[image]

In-Sight SDK
CvsCellComment..::..FlagColor Property
CvsCellComment Structure See Also Send Feedback
Gets or sets the flag color.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color FlagColor { get; set; }
Visual Basic
Public Property FlagColor As Color
    Get
    Set

Property Value

Type: Color

See Also

CvsCellComment Structure
CvsCellComment..::..CvsCellComment Members
Cognex.InSight Namespace


CvsCellComment.Text Property

[image]

In-Sight SDK
CvsCellComment..::..Text Property
CvsCellComment Structure See Also Send Feedback
Gets or sets the comment text.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set

Property Value

Type: String

See Also

CvsCellComment Structure
CvsCellComment..::..CvsCellComment Members
Cognex.InSight Namespace


CvsCellLocation Structure

[image]

In-Sight SDK
CvsCellLocation Structure
Members See Also Send Feedback
Represents a pair of integer row and column coordinates that identifies a cell in the spreadsheet.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public struct CvsCellLocation
Visual Basic
<SerializableAttribute>
Public Structure CvsCellLocation

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, only the row and column fields of this structure are visible because COM does not support methods on structures. The CvsUtility class provides most of the functionality of the methods of this structure for COM/ActiveX applications.

See Also

CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocation Members

[image] [image]

In-Sight SDK
CvsCellLocation Members
CvsCellLocation Structure Methods Operators Fields Properties See Also Send Feedback

The CvsCellLocation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Specifies whether this CvsCellLocation contains the same coordinates as the specified Object. (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode()()()() | Gets a hash code for this CvsCellLocation object. (Overrides ValueType..::..GetHashCode()()()().)
 | GetHashCode(Int32, Int32) | Gets a hash code for a row and column.
 | GetHashCode(Int32, Int32, Int32) | Gets a hash code for a sheet, row and column.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | NormalizeCell | Formats a cell location string to the canonical form. This is an uppercase letter followed by a row number, for example "C17".
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Operators

Name | Description
Equality | Equality operator.
Inequality | Inequality operator.

Fields

Name | Description
DefaultSheetIndex | The default sheet index for a single camera system.
Invalid | Holds a special value that represents an invalid location.
MaxColumn | The maximum supported column number.
MaxRow | The maximum supported row number.
PropertySheet | Static member for a "location" that is on a property sheet

Properties

 | Name | Description
Public property | Column | Gets or sets the column (horizontal) coordinate of this CvsCellLocation.
Public property | IsValid | Returns true if neither coordinate equals int.MinValue or int.MaxValue.
Public property | Row | Gets or sets the row (vertical) coordinate of this CvsCellLocation.

See Also

CvsCellLocation Structure
Cognex.InSight Namespace


CvsCellLocation Fields

[image] [image]

In-Sight SDK
CvsCellLocation Fields
CvsCellLocation Structure See Also Send Feedback

The CvsCellLocation type exposes the following members.

Fields

Name | Description
DefaultSheetIndex | The default sheet index for a single camera system.
Invalid | Holds a special value that represents an invalid location.
MaxColumn | The maximum supported column number.
MaxRow | The maximum supported row number.
PropertySheet | Static member for a "location" that is on a property sheet

See Also

CvsCellLocation Structure
Cognex.InSight Namespace


CvsCellLocation.DefaultSheetIndex Field

[image]

In-Sight SDK
CvsCellLocation..::..DefaultSheetIndex Field
CvsCellLocation Structure See Also Send Feedback
The default sheet index for a single camera system.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static readonly int DefaultSheetIndex
Visual Basic
Public Shared ReadOnly DefaultSheetIndex As Integer

Field Value

Type: Int32

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocation.Invalid Field

[image]

In-Sight SDK
CvsCellLocation..::..Invalid Field
CvsCellLocation Structure See Also Send Feedback
Holds a special value that represents an invalid location.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static readonly CvsCellLocation Invalid
Visual Basic
Public Shared ReadOnly Invalid As CvsCellLocation

Field Value

Type: CvsCellLocation

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocation.MaxColumn Field

[image]

In-Sight SDK
CvsCellLocation..::..MaxColumn Field
CvsCellLocation Structure See Also Send Feedback
The maximum supported column number.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxColumn
Visual Basic
Public Const MaxColumn As Integer

Field Value

Type: Int32

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocation.MaxRow Field

[image]

In-Sight SDK
CvsCellLocation..::..MaxRow Field
CvsCellLocation Structure See Also Send Feedback
The maximum supported row number.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxRow
Visual Basic
Public Const MaxRow As Integer

Field Value

Type: Int32

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocation.PropertySheet Field

[image]

In-Sight SDK
CvsCellLocation..::..PropertySheet Field
CvsCellLocation Structure See Also Send Feedback
Static member for a "location" that is on a property sheet

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static readonly CvsCellLocation PropertySheet
Visual Basic
Public Shared ReadOnly PropertySheet As CvsCellLocation

Field Value

Type: CvsCellLocation

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocation Methods

[image] [image]

In-Sight SDK
CvsCellLocation Methods
CvsCellLocation Structure See Also Send Feedback

The CvsCellLocation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Specifies whether this CvsCellLocation contains the same coordinates as the specified Object. (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode()()()() | Gets a hash code for this CvsCellLocation object. (Overrides ValueType..::..GetHashCode()()()().)
 | GetHashCode(Int32, Int32) | Gets a hash code for a row and column.
 | GetHashCode(Int32, Int32, Int32) | Gets a hash code for a sheet, row and column.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | NormalizeCell | Formats a cell location string to the canonical form. This is an uppercase letter followed by a row number, for example "C17".
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CvsCellLocation Structure
Cognex.InSight Namespace


CvsCellLocation.Equals Method

[image]

In-Sight SDK
CvsCellLocation..::..Equals Method
CvsCellLocation Structure See Also Send Feedback
Specifies whether this CvsCellLocation contains the same coordinates as the specified Object.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: System..::..Object
The object to test.

Return Value

Type: Boolean
true if obj is a CvsCellLocation and its row and column are the same as this instance; otherwise, false.

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocation.GetHashCode Method

[image] [image]

In-Sight SDK
CvsCellLocation..::..GetHashCode Method
CvsCellLocation Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHashCode()()()() | Gets a hash code for this CvsCellLocation object. (Overrides ValueType..::..GetHashCode()()()().)
 | GetHashCode(Int32, Int32) | Gets a hash code for a row and column.
 | GetHashCode(Int32, Int32, Int32) | Gets a hash code for a sheet, row and column.

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocation.GetHashCode Method

[image]

In-Sight SDK
CvsCellLocation..::..GetHashCode Method
CvsCellLocation Structure See Also Send Feedback
Gets a hash code for this CvsCellLocation object.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer where the low-order 16 bits specify the column coordinate and the higher 16 bits specify the row coordinate.

Remarks

If either coordinate exceeds the range of a 16-bit integer, only its lower 16 bits are used.

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
GetHashCode Overload
Cognex.InSight Namespace


CvsCellLocation.GetHashCode Method (Int32, Int32)

[image]

In-Sight SDK
CvsCellLocation..::..GetHashCode Method (Int32, Int32)
CvsCellLocation Structure See Also Send Feedback
Gets a hash code for a row and column.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static int GetHashCode(
    int row,
    int column
)
Visual Basic
Public Shared Function GetHashCode (
    row As Integer,
    column As Integer
) As Integer

Parameters

row
Type: System..::..Int32
The row (vertical) coordinage.
column
Type: System..::..Int32
The column (horizontal) coordinate.

Return Value

Type: Int32
An integer where the low-order 16 bits specify the column coordinate and the higher 16 bits specify the row coordinate.

Remarks

If either coordinate exceeds the range of a 16-bit integer, only its lower 16 bits are used.

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
GetHashCode Overload
Cognex.InSight Namespace


CvsCellLocation.GetHashCode Method (Int32, Int32, Int32)

[image]

In-Sight SDK
CvsCellLocation..::..GetHashCode Method (Int32, Int32, Int32)
CvsCellLocation Structure See Also Send Feedback
Gets a hash code for a sheet, row and column.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static int GetHashCode(
    int sheet,
    int row,
    int column
)
Visual Basic
Public Shared Function GetHashCode (
    sheet As Integer,
    row As Integer,
    column As Integer
) As Integer

Parameters

sheet
Type: System..::..Int32
The sheet (tab) coordinate.
row
Type: System..::..Int32
The row (vertical) coordinage.
column
Type: System..::..Int32
The column (horizontal) coordinate.

Return Value

Type: Int32
An integer where the low-order 16 bits specify the column coordinate and the higher 16 bits specify the row coordinate.

Remarks

If either coordinate exceeds the range of a 16-bit integer, only its lower 16 bits are used.

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
GetHashCode Overload
Cognex.InSight Namespace


CvsCellLocation.NormalizeCell Method

[image]

In-Sight SDK
CvsCellLocation..::..NormalizeCell Method
CvsCellLocation Structure See Also Send Feedback
Formats a cell location string to the canonical form. This is an uppercase letter followed by a row number, for example "C17".

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static string NormalizeCell(
    string location
)
Visual Basic
Public Shared Function NormalizeCell (
    location As String
) As String

Parameters

location
Type: System..::..String
The cell location string to format.

Return Value

Type: String
A string that represents the cell location.

Remarks

'$' characters that precede rows or columns will be stripped.

Exceptions

Exception | Condition
System..::..ArgumentException | The cell location string cannot be parsed.

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocation Operators

[image] [image]

In-Sight SDK
CvsCellLocation Operators
CvsCellLocation Structure See Also Send Feedback

The CvsCellLocation type exposes the following members.

Operators

Name | Description
Equality | Equality operator.
Inequality | Inequality operator.

See Also

CvsCellLocation Structure
Cognex.InSight Namespace


CvsCellLocation.Equality Operator

[image]

In-Sight SDK
CvsCellLocation..::..Equality Operator
CvsCellLocation Structure See Also Send Feedback
Equality operator.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool operator ==(
    CvsCellLocation left,
    CvsCellLocation right
)
Visual Basic
Public Shared Operator = (
    left As CvsCellLocation,
    right As CvsCellLocation
) As Boolean

Parameters

left
Type: Cognex.InSight..::..CvsCellLocation
The first CvsCellLocation to test.
right
Type: Cognex.InSight..::..CvsCellLocation
The second CvsCellLocation to test.

Return Value

Type: Boolean
true if obj if the locations have the same row and column; otherwise, false.

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocation.Inequality Operator

[image]

In-Sight SDK
CvsCellLocation..::..Inequality Operator
CvsCellLocation Structure See Also Send Feedback
Inequality operator.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool operator !=(
    CvsCellLocation left,
    CvsCellLocation right
)
Visual Basic
Public Shared Operator <> (
    left As CvsCellLocation,
    right As CvsCellLocation
) As Boolean

Parameters

left
Type: Cognex.InSight..::..CvsCellLocation
The first CvsCellLocation to test.
right
Type: Cognex.InSight..::..CvsCellLocation
The second CvsCellLocation to test.

Return Value

Type: Boolean
true if obj if the locations do not have the same row or column; otherwise, false.

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocation Properties

[image] [image]

In-Sight SDK
CvsCellLocation Properties
CvsCellLocation Structure See Also Send Feedback

The CvsCellLocation type exposes the following members.

Properties

 | Name | Description
Public property | Column | Gets or sets the column (horizontal) coordinate of this CvsCellLocation.
Public property | IsValid | Returns true if neither coordinate equals int.MinValue or int.MaxValue.
Public property | Row | Gets or sets the row (vertical) coordinate of this CvsCellLocation.

See Also

CvsCellLocation Structure
Cognex.InSight Namespace


CvsCellLocation.Column Property

[image]

In-Sight SDK
CvsCellLocation..::..Column Property
CvsCellLocation Structure See Also Send Feedback
Gets or sets the column (horizontal) coordinate of this CvsCellLocation.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Column { get; set; }
Visual Basic
Public Property Column As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocation.IsValid Property

[image]

In-Sight SDK
CvsCellLocation..::..IsValid Property
CvsCellLocation Structure See Also Send Feedback
Returns true if neither coordinate equals int.MinValue or int.MaxValue.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocation.Row Property

[image]

In-Sight SDK
CvsCellLocation..::..Row Property
CvsCellLocation Structure See Also Send Feedback
Gets or sets the row (vertical) coordinate of this CvsCellLocation.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Row { get; set; }
Visual Basic
Public Property Row As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsCellLocation Structure
CvsCellLocation..::..CvsCellLocation Members
Cognex.InSight Namespace


CvsCellLocationOffset Structure

[image]

In-Sight SDK
CvsCellLocationOffset Structure
Members See Also Send Feedback
Represents an offset to apply to a CvsCellLocation.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public struct CvsCellLocationOffset
Visual Basic
<SerializableAttribute>
Public Structure CvsCellLocationOffset

See Also

CvsCellLocationOffset..::..CvsCellLocationOffset Members
Cognex.InSight Namespace


CvsCellLocationOffset Members

[image] [image]

In-Sight SDK
CvsCellLocationOffset Members
CvsCellLocationOffset Structure Constructors Methods Properties See Also Send Feedback

The CvsCellLocationOffset type exposes the following members.

Constructors

 | Name | Description
Public method | CvsCellLocationOffset(Int32, Int32) | Constructs an offset using the specified values.
Public method | CvsCellLocationOffset(CvsCellLocation, CvsCellLocation) | Constructs an offset using two cell locations.

Methods

 | Name | Description
Public method | Apply | Creates a new CvsCellLocation object from a starting position.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

 | Name | Description
Public property | DeltaColumns | Gets/sets a value representing how many columns to move (+1 is right; -1 is left)
Public property | DeltaRows | Gets/sets a value representing how many rows to move (+1 is down; -1 is up)

See Also

CvsCellLocationOffset Structure
Cognex.InSight Namespace


CvsCellLocationOffset Constructor

[image] [image]

In-Sight SDK
CvsCellLocationOffset Constructor
CvsCellLocationOffset Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsCellLocationOffset(Int32, Int32) | Constructs an offset using the specified values.
Public method | CvsCellLocationOffset(CvsCellLocation, CvsCellLocation) | Constructs an offset using two cell locations.

See Also

CvsCellLocationOffset Structure
CvsCellLocationOffset..::..CvsCellLocationOffset Members
Cognex.InSight Namespace


CvsCellLocationOffset Constructor (Int32, Int32)

[image]

In-Sight SDK
CvsCellLocationOffset Constructor (Int32, Int32)
CvsCellLocationOffset Structure See Also Send Feedback
Constructs an offset using the specified values.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocationOffset(
    int deltaRows,
    int deltaColumns
)
Visual Basic
Public Sub New (
    deltaRows As Integer,
    deltaColumns As Integer
)

Parameters

deltaRows
Type: System..::..Int32

[Missing <param name="deltaRows"/> documentation for "M:Cognex.InSight.CvsCellLocationOffset.#ctor(System.Int32,System.Int32)"]

deltaColumns
Type: System..::..Int32

[Missing <param name="deltaColumns"/> documentation for "M:Cognex.InSight.CvsCellLocationOffset.#ctor(System.Int32,System.Int32)"]

See Also

CvsCellLocationOffset Structure
CvsCellLocationOffset..::..CvsCellLocationOffset Members
CvsCellLocationOffset Overload
Cognex.InSight Namespace


CvsCellLocationOffset Constructor (CvsCellLocation, CvsCellLocation)

[image]

In-Sight SDK
CvsCellLocationOffset Constructor (CvsCellLocation, CvsCellLocation)
CvsCellLocationOffset Structure See Also Send Feedback
Constructs an offset using two cell locations.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocationOffset(
    CvsCellLocation from,
    CvsCellLocation to
)
Visual Basic
Public Sub New (
    from As CvsCellLocation,
    to As CvsCellLocation
)

Parameters

from
Type: Cognex.InSight..::..CvsCellLocation

[Missing <param name="from"/> documentation for "M:Cognex.InSight.CvsCellLocationOffset.#ctor(Cognex.InSight.CvsCellLocation,Cognex.InSight.CvsCellLocation)"]

to
Type: Cognex.InSight..::..CvsCellLocation

[Missing <param name="to"/> documentation for "M:Cognex.InSight.CvsCellLocationOffset.#ctor(Cognex.InSight.CvsCellLocation,Cognex.InSight.CvsCellLocation)"]

See Also

CvsCellLocationOffset Structure
CvsCellLocationOffset..::..CvsCellLocationOffset Members
CvsCellLocationOffset Overload
Cognex.InSight Namespace


CvsCellLocationOffset Methods

[image] [image]

In-Sight SDK
CvsCellLocationOffset Methods
CvsCellLocationOffset Structure See Also Send Feedback

The CvsCellLocationOffset type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Creates a new CvsCellLocation object from a starting position.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CvsCellLocationOffset Structure
Cognex.InSight Namespace


CvsCellLocationOffset.Apply Method

[image]

In-Sight SDK
CvsCellLocationOffset..::..Apply Method
CvsCellLocationOffset Structure See Also Send Feedback
Creates a new CvsCellLocation object from a starting position.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation Apply(
    CvsCellLocation start
)
Visual Basic
Public Function Apply (
    start As CvsCellLocation
) As CvsCellLocation

Parameters

start
Type: Cognex.InSight..::..CvsCellLocation

[Missing <param name="start"/> documentation for "M:Cognex.InSight.CvsCellLocationOffset.Apply(Cognex.InSight.CvsCellLocation)"]

Return Value

Type: CvsCellLocation

[Missing <returns> documentation for "M:Cognex.InSight.CvsCellLocationOffset.Apply(Cognex.InSight.CvsCellLocation)"]

See Also

CvsCellLocationOffset Structure
CvsCellLocationOffset..::..CvsCellLocationOffset Members
Cognex.InSight Namespace


CvsCellLocationOffset Properties

[image] [image]

In-Sight SDK
CvsCellLocationOffset Properties
CvsCellLocationOffset Structure See Also Send Feedback

The CvsCellLocationOffset type exposes the following members.

Properties

 | Name | Description
Public property | DeltaColumns | Gets/sets a value representing how many columns to move (+1 is right; -1 is left)
Public property | DeltaRows | Gets/sets a value representing how many rows to move (+1 is down; -1 is up)

See Also

CvsCellLocationOffset Structure
Cognex.InSight Namespace


CvsCellLocationOffset.DeltaColumns Property

[image]

In-Sight SDK
CvsCellLocationOffset..::..DeltaColumns Property
CvsCellLocationOffset Structure See Also Send Feedback
Gets/sets a value representing how many columns to move (+1 is right; -1 is left)

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int DeltaColumns { get; set; }
Visual Basic
Public Property DeltaColumns As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsCellLocationOffset Structure
CvsCellLocationOffset..::..CvsCellLocationOffset Members
Cognex.InSight Namespace


CvsCellLocationOffset.DeltaRows Property

[image]

In-Sight SDK
CvsCellLocationOffset..::..DeltaRows Property
CvsCellLocationOffset Structure See Also Send Feedback
Gets/sets a value representing how many rows to move (+1 is down; -1 is up)

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int DeltaRows { get; set; }
Visual Basic
Public Property DeltaRows As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsCellLocationOffset Structure
CvsCellLocationOffset..::..CvsCellLocationOffset Members
Cognex.InSight Namespace


CvsCellLocationOffsetTag Class

[image]

In-Sight SDK
CvsCellLocationOffsetTag Class
Members See Also Send Feedback
Holds a CvsCellLocationOffset for block of cells.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellLocationOffsetTag : ICvsTagData,
    ICloneable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellLocationOffsetTag
    Implements ICvsTagData, ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsCellLocationOffsetTag

See Also

CvsCellLocationOffsetTag..::..CvsCellLocationOffsetTag Members
Cognex.InSight Namespace


CvsCellLocationOffsetTag Members

[image] [image]

In-Sight SDK
CvsCellLocationOffsetTag Members
CvsCellLocationOffsetTag Class Methods Properties See Also Send Feedback

The CvsCellLocationOffsetTag type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ID | Gets and sets the ID.
Public property | Offset | Gets and sets the offset.

See Also

CvsCellLocationOffsetTag Class
Cognex.InSight Namespace


CvsCellLocationOffsetTag Methods

[image] [image]

In-Sight SDK
CvsCellLocationOffsetTag Methods
CvsCellLocationOffsetTag Class See Also Send Feedback

The CvsCellLocationOffsetTag type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsCellLocationOffsetTag Class
Cognex.InSight Namespace


CvsCellLocationOffsetTag Properties

[image] [image]

In-Sight SDK
CvsCellLocationOffsetTag Properties
CvsCellLocationOffsetTag Class See Also Send Feedback

The CvsCellLocationOffsetTag type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets and sets the ID.
Public property | Offset | Gets and sets the offset.

See Also

CvsCellLocationOffsetTag Class
Cognex.InSight Namespace


CvsCellLocationOffsetTag.ID Property

[image]

In-Sight SDK
CvsCellLocationOffsetTag..::..ID Property
CvsCellLocationOffsetTag Class See Also Send Feedback
Gets and sets the ID.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string ID { get; set; }
Visual Basic
Public Property ID As String
    Get
    Set

Property Value

Type: String

See Also

CvsCellLocationOffsetTag Class
CvsCellLocationOffsetTag..::..CvsCellLocationOffsetTag Members
Cognex.InSight Namespace


CvsCellLocationOffsetTag.Offset Property

[image]

In-Sight SDK
CvsCellLocationOffsetTag..::..Offset Property
CvsCellLocationOffsetTag Class See Also Send Feedback
Gets and sets the offset.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocationOffset Offset { get; set; }
Visual Basic
Public Property Offset As CvsCellLocationOffset
    Get
    Set

Property Value

Type: CvsCellLocationOffset

See Also

CvsCellLocationOffsetTag Class
CvsCellLocationOffsetTag..::..CvsCellLocationOffsetTag Members
Cognex.InSight Namespace


CvsCellProtectionException Class

[image]

In-Sight SDK
CvsCellProtectionException Class
Members See Also Send Feedback
The exception that is thrown when the application is not licensed for the In-Sight SDK.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellProtectionException : CvsException,
    ISerializable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellProtectionException
    Inherits CvsException
    Implements ISerializable

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsCellProtectionException

See Also

CvsCellProtectionException..::..CvsCellProtectionException Members
Cognex.InSight Namespace


CvsCellProtectionException Members

[image] [image]

In-Sight SDK
CvsCellProtectionException Members
CvsCellProtectionException Class Methods Properties See Also Send Feedback

The CvsCellProtectionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | CellLocation | Gets the location of the protected cell.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsCellProtectionException Class
Cognex.InSight Namespace


CvsCellProtectionException Methods

[image] [image]

In-Sight SDK
CvsCellProtectionException Methods
CvsCellProtectionException Class See Also Send Feedback

The CvsCellProtectionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsCellProtectionException Class
Cognex.InSight Namespace


CvsCellProtectionException Properties

[image] [image]

In-Sight SDK
CvsCellProtectionException Properties
CvsCellProtectionException Class See Also Send Feedback

The CvsCellProtectionException type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the location of the protected cell.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsCellProtectionException Class
Cognex.InSight Namespace


CvsCellProtectionException.CellLocation Property

[image]

In-Sight SDK
CvsCellProtectionException..::..CellLocation Property
CvsCellProtectionException Class See Also Send Feedback
Gets the location of the protected cell.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation CellLocation { get; }
Visual Basic
Public ReadOnly Property CellLocation As CvsCellLocation
    Get

Property Value

Type: CvsCellLocation

See Also

CvsCellProtectionException Class
CvsCellProtectionException..::..CvsCellProtectionException Members
Cognex.InSight Namespace


CvsCellRange Structure

[image]

In-Sight SDK
CvsCellRange Structure
Members See Also Send Feedback
Represents a range of locations specified by row and column coordinates.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public struct CvsCellRange : IEnumerable<CvsCellLocation>,
    IEnumerable, IEquatable<CvsCellRange>
Visual Basic
<SerializableAttribute>
Public Structure CvsCellRange
    Implements IEnumerable(Of CvsCellLocation), IEnumerable,
    IEquatable(Of CvsCellRange)

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, only the location, rows and columns fields of this structure are visible because COM does not support methods on structures. The CvsUtility class provides most of the functionality of the methods of this structure for COM/ActiveX applications.

See Also

CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange Members

[image] [image]

In-Sight SDK
CvsCellRange Members
CvsCellRange Structure Methods Operators Fields Properties See Also Send Feedback

The CvsCellRange type exposes the following members.

Methods

 | Name | Description
Public method | Contains(CvsCellLocation) | Determines if the specified CvsCellLocation is contained within this CvsCellRange structure.
Public method | Contains(CvsCellRange) | Determines if the specified CvsCellRange is contained entirely within this CvsCellRange structure.
Public method | Contains(Int32, Int32) | Determines if the specified location is contained within this CvsCellRange structure.
Public method | ContainsColumn | Determines if the specified column is contained within this CvsCellRange structure
Public method | ContainsRow | Determines if the specified row is contained within this CvsCellRange structure
Public method | Equals(Object) | Object equality test. (Overrides ValueType..::..Equals(Object).)
Public method | Equals(CvsCellRange) | IEQuatable of T Equals test. Specifies whether this CvsCellRange contains the same coordinates as the specified Object.
Public method | GetEnumerator | Gets an enumerator that will enumerate all locations in the range.
Public method | GetHashCode | Gets a hash code for this CvsCellRange object. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetNearest | Given a location, finds the nearest location that is within the range.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Intersect | Returns a third CvsCellRange structure that represents the intersection of two other CvsCellRange structures.
 | Normalize | Returns a CvsCellRange structure that represents the same range of cells specified by value, except that both the Columns and Rows properties are non-negative numbers.
 | Subtract | Computes the portion(s) of range (a) that don't intersect with range (b).
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | Union(CvsCellRange, CvsCellLocation) | Returns a new CvsCellRange structure that represents the union of a CvsCellRange and a CvsCellLocation.
 | Union(CvsCellRange, CvsCellRange) | Returns a new CvsCellRange structure that represents the rectangular union of two other CvsCellRange structures.

Operators

Name | Description
Equality | Equality operator.
Inequality | Inequality operator.

Fields

Name | Description
Empty | Represents an empty CvsCellRange.
Invalid | Represents an invalid range.

Properties

 | Name | Description
Public property | Column | Gets or sets the column coordinate of the start of the range.
Public property | Columns | Gets or sets the number of columns.
 | EntireJob | A range used for wildcarding ISP messages.
Public property | IsEmpty | Determines whether the range is empty.
Public property | IsValid | Determines whether the range is valid.
Public property | LastColumn | Gets the column coordinate of the end of the range.
Public property | LastLocation | Gets the location of the end of the range.
Public property | LastRow | Gets the row coordinate of the end of the range.
Public property | Location | Gets or sets the location of the start of the range.
Public property | Row | Gets or sets the row coordinate of the start of the range.
Public property | Rows | Gets or sets the number of rows.
Public property | Size | Gets or sets the size of the range.

See Also

CvsCellRange Structure
Cognex.InSight Namespace


CvsCellRange Fields

[image] [image]

In-Sight SDK
CvsCellRange Fields
CvsCellRange Structure See Also Send Feedback

The CvsCellRange type exposes the following members.

Fields

Name | Description
Empty | Represents an empty CvsCellRange.
Invalid | Represents an invalid range.

See Also

CvsCellRange Structure
Cognex.InSight Namespace


CvsCellRange.Empty Field

[image]

In-Sight SDK
CvsCellRange..::..Empty Field
CvsCellRange Structure See Also Send Feedback
Represents an empty CvsCellRange.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static readonly CvsCellRange Empty
Visual Basic
Public Shared ReadOnly Empty As CvsCellRange

Field Value

Type: CvsCellRange

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Invalid Field

[image]

In-Sight SDK
CvsCellRange..::..Invalid Field
CvsCellRange Structure See Also Send Feedback
Represents an invalid range.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static readonly CvsCellRange Invalid
Visual Basic
Public Shared ReadOnly Invalid As CvsCellRange

Field Value

Type: CvsCellRange

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange Methods

[image] [image]

In-Sight SDK
CvsCellRange Methods
CvsCellRange Structure See Also Send Feedback

The CvsCellRange type exposes the following members.

Methods

 | Name | Description
Public method | Contains(CvsCellLocation) | Determines if the specified CvsCellLocation is contained within this CvsCellRange structure.
Public method | Contains(CvsCellRange) | Determines if the specified CvsCellRange is contained entirely within this CvsCellRange structure.
Public method | Contains(Int32, Int32) | Determines if the specified location is contained within this CvsCellRange structure.
Public method | ContainsColumn | Determines if the specified column is contained within this CvsCellRange structure
Public method | ContainsRow | Determines if the specified row is contained within this CvsCellRange structure
Public method | Equals(Object) | Object equality test. (Overrides ValueType..::..Equals(Object).)
Public method | Equals(CvsCellRange) | IEQuatable of T Equals test. Specifies whether this CvsCellRange contains the same coordinates as the specified Object.
Public method | GetEnumerator | Gets an enumerator that will enumerate all locations in the range.
Public method | GetHashCode | Gets a hash code for this CvsCellRange object. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetNearest | Given a location, finds the nearest location that is within the range.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Intersect | Returns a third CvsCellRange structure that represents the intersection of two other CvsCellRange structures.
 | Normalize | Returns a CvsCellRange structure that represents the same range of cells specified by value, except that both the Columns and Rows properties are non-negative numbers.
 | Subtract | Computes the portion(s) of range (a) that don't intersect with range (b).
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | Union(CvsCellRange, CvsCellLocation) | Returns a new CvsCellRange structure that represents the union of a CvsCellRange and a CvsCellLocation.
 | Union(CvsCellRange, CvsCellRange) | Returns a new CvsCellRange structure that represents the rectangular union of two other CvsCellRange structures.

See Also

CvsCellRange Structure
Cognex.InSight Namespace


CvsCellRange.Contains Method

[image] [image]

In-Sight SDK
CvsCellRange..::..Contains Method
CvsCellRange Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Contains(CvsCellLocation) | Determines if the specified CvsCellLocation is contained within this CvsCellRange structure.
Public method | Contains(CvsCellRange) | Determines if the specified CvsCellRange is contained entirely within this CvsCellRange structure.
Public method | Contains(Int32, Int32) | Determines if the specified location is contained within this CvsCellRange structure.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Contains Method (CvsCellLocation)

[image]

In-Sight SDK
CvsCellRange..::..Contains Method (CvsCellLocation)
CvsCellRange Structure See Also Send Feedback
Determines if the specified CvsCellLocation is contained within this CvsCellRange structure.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Contains(
    CvsCellLocation location
)
Visual Basic
Public Function Contains (
    location As CvsCellLocation
) As Boolean

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The location.

Return Value

Type: Boolean
true if the point defined by location is contained within this CvsCellRange structure; otherwise >false.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Contains Overload
Cognex.InSight Namespace


CvsCellRange.Contains Method (CvsCellRange)

[image]

In-Sight SDK
CvsCellRange..::..Contains Method (CvsCellRange)
CvsCellRange Structure See Also Send Feedback
Determines if the specified CvsCellRange is contained entirely within this CvsCellRange structure.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Contains(
    CvsCellRange range
)
Visual Basic
Public Function Contains (
    range As CvsCellRange
) As Boolean

Parameters

range
Type: Cognex.InSight..::..CvsCellRange
The range.

Return Value

Type: Boolean
true if range is entirely contained within this CvsCellRange structure; otherwise false.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Contains Overload
Cognex.InSight Namespace


CvsCellRange.Contains Method (Int32, Int32)

[image]

In-Sight SDK
CvsCellRange..::..Contains Method (Int32, Int32)
CvsCellRange Structure See Also Send Feedback
Determines if the specified location is contained within this CvsCellRange structure.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Contains(
    int row,
    int column
)
Visual Basic
Public Function Contains (
    row As Integer,
    column As Integer
) As Boolean

Parameters

row
Type: System..::..Int32
The row of the location.
column
Type: System..::..Int32
The column of the location.

Return Value

Type: Boolean
true if the point defined by row and column is contained within this CvsCellRange structure; otherwise false.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Contains Overload
Cognex.InSight Namespace


CvsCellRange.ContainsColumn Method

[image]

In-Sight SDK
CvsCellRange..::..ContainsColumn Method
CvsCellRange Structure See Also Send Feedback
Determines if the specified column is contained within this CvsCellRange structure

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ContainsColumn(
    int column
)
Visual Basic
Public Function ContainsColumn (
    column As Integer
) As Boolean

Parameters

column
Type: System..::..Int32
The column.

Return Value

Type: Boolean
true if column is contained within this CvsCellRange structure; otherwise false.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.ContainsRow Method

[image]

In-Sight SDK
CvsCellRange..::..ContainsRow Method
CvsCellRange Structure See Also Send Feedback
Determines if the specified row is contained within this CvsCellRange structure

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ContainsRow(
    int row
)
Visual Basic
Public Function ContainsRow (
    row As Integer
) As Boolean

Parameters

row
Type: System..::..Int32
The row.

Return Value

Type: Boolean
true if row is contained within this CvsCellRange structure; otherwise false.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Equals Method

[image] [image]

In-Sight SDK
CvsCellRange..::..Equals Method
CvsCellRange Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Object equality test. (Overrides ValueType..::..Equals(Object).)
Public method | Equals(CvsCellRange) | IEQuatable of T Equals test. Specifies whether this CvsCellRange contains the same coordinates as the specified Object.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Equals Method (Object)

[image]

In-Sight SDK
CvsCellRange..::..Equals Method (Object)
CvsCellRange Structure See Also Send Feedback
Object equality test.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: System..::..Object
The object to test.

Return Value

Type: Boolean
true if obj is a CvsCellRange and its location and size are the same as this instance; otherwise, false.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Equals Overload
Cognex.InSight Namespace


CvsCellRange.Equals Method (CvsCellRange)

[image]

In-Sight SDK
CvsCellRange..::..Equals Method (CvsCellRange)
CvsCellRange Structure See Also Send Feedback
IEQuatable of T Equals test. Specifies whether this CvsCellRange contains the same coordinates as the specified Object.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Equals(
    CvsCellRange range
)
Visual Basic
Public Function Equals (
    range As CvsCellRange
) As Boolean

Parameters

range
Type: Cognex.InSight..::..CvsCellRange

Return Value

Type: Boolean

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Equals Overload
Cognex.InSight Namespace


CvsCellRange.GetEnumerator Method

[image]

In-Sight SDK
CvsCellRange..::..GetEnumerator Method
CvsCellRange Structure See Also Send Feedback
Gets an enumerator that will enumerate all locations in the range.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerator<CvsCellLocation> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of CvsCellLocation)

Return Value

Type: IEnumerator <(Of <(<' CvsCellLocation >)>)>
An enumerator that steps over the range in row-major order.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.GetHashCode Method

[image]

In-Sight SDK
CvsCellRange..::..GetHashCode Method
CvsCellRange Structure See Also Send Feedback
Gets a hash code for this CvsCellRange object.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A value identifying the range, hopefully uniquely.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.GetNearest Method

[image]

In-Sight SDK
CvsCellRange..::..GetNearest Method
CvsCellRange Structure See Also Send Feedback
Given a location, finds the nearest location that is within the range.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation GetNearest(
    CvsCellLocation loc
)
Visual Basic
Public Function GetNearest (
    loc As CvsCellLocation
) As CvsCellLocation

Parameters

loc
Type: Cognex.InSight..::..CvsCellLocation
The location to locate a point that is closest to it.

Return Value

Type: CvsCellLocation
If location is within the range, simply returns it. Otherwise, returns the nearest location that within the range. If the range is empty, returns the location of the empty range.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Intersect Method

[image]

In-Sight SDK
CvsCellRange..::..Intersect Method
CvsCellRange Structure See Also Send Feedback
Returns a third CvsCellRange structure that represents the intersection of two other CvsCellRange structures.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static CvsCellRange Intersect(
    CvsCellRange a,
    CvsCellRange b
)
Visual Basic
Public Shared Function Intersect (
    a As CvsCellRange,
    b As CvsCellRange
) As CvsCellRange

Parameters

a
Type: Cognex.InSight..::..CvsCellRange
The first CvsCellRange.
b
Type: Cognex.InSight..::..CvsCellRange
The second CvsCellRange.

Return Value

Type: CvsCellRange
A new range that represents the intersection of the two ranges, or if there is no intersection, Empty.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Normalize Method

[image]

In-Sight SDK
CvsCellRange..::..Normalize Method
CvsCellRange Structure See Also Send Feedback
Returns a CvsCellRange structure that represents the same range of cells specified by value, except that both the Columns and Rows properties are non-negative numbers.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static CvsCellRange Normalize(
    CvsCellRange value
)
Visual Basic
Public Shared Function Normalize (
    value As CvsCellRange
) As CvsCellRange

Parameters

value
Type: Cognex.InSight..::..CvsCellRange
The CvsCellRange to normalize

Return Value

Type: CvsCellRange
A normalized CvsCellRange

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Subtract Method

[image]

In-Sight SDK
CvsCellRange..::..Subtract Method
CvsCellRange Structure See Also Send Feedback
Computes the portion(s) of range (a) that don't intersect with range (b).

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static CvsCellRange[] Subtract(
    CvsCellRange a,
    CvsCellRange b
)
Visual Basic
Public Shared Function Subtract (
    a As CvsCellRange,
    b As CvsCellRange
) As CvsCellRange()

Parameters

a
Type: Cognex.InSight..::..CvsCellRange
The range from which to subtract.
b
Type: Cognex.InSight..::..CvsCellRange
The range to subtract from (a).

Return Value

Type: array< CvsCellRange >[]()[][]
An array containing 1, 2, 3 or 4 non-empty CvsCellRange structures, or null if range b completely covers range a.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Union Method

[image] [image]

In-Sight SDK
CvsCellRange..::..Union Method
CvsCellRange Structure See Also Send Feedback

Overload List

Name | Description
Union(CvsCellRange, CvsCellLocation) | Returns a new CvsCellRange structure that represents the union of a CvsCellRange and a CvsCellLocation.
Union(CvsCellRange, CvsCellRange) | Returns a new CvsCellRange structure that represents the rectangular union of two other CvsCellRange structures.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Union Method (CvsCellRange, CvsCellLocation)

[image]

In-Sight SDK
CvsCellRange..::..Union Method (CvsCellRange, CvsCellLocation)
CvsCellRange Structure See Also Send Feedback
Returns a new CvsCellRange structure that represents the union of a CvsCellRange and a CvsCellLocation.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static CvsCellRange Union(
    CvsCellRange range,
    CvsCellLocation location
)
Visual Basic
Public Shared Function Union (
    range As CvsCellRange,
    location As CvsCellLocation
) As CvsCellRange

Parameters

range
Type: Cognex.InSight..::..CvsCellRange
The CvsCellRange.
location
Type: Cognex.InSight..::..CvsCellLocation
The CvsCellLocation.

Return Value

Type: CvsCellRange
A new range that represents the union of the given range and location.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Union Overload
Cognex.InSight Namespace


CvsCellRange.Union Method (CvsCellRange, CvsCellRange)

[image]

In-Sight SDK
CvsCellRange..::..Union Method (CvsCellRange, CvsCellRange)
CvsCellRange Structure See Also Send Feedback
Returns a new CvsCellRange structure that represents the rectangular union of two other CvsCellRange structures.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static CvsCellRange Union(
    CvsCellRange a,
    CvsCellRange b
)
Visual Basic
Public Shared Function Union (
    a As CvsCellRange,
    b As CvsCellRange
) As CvsCellRange

Parameters

a
Type: Cognex.InSight..::..CvsCellRange
The first CvsCellRange.
b
Type: Cognex.InSight..::..CvsCellRange
The second CvsCellRange.

Return Value

Type: CvsCellRange
A new range that represents the rectangular union of the two ranges.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Union Overload
Cognex.InSight Namespace


CvsCellRange Operators

[image] [image]

In-Sight SDK
CvsCellRange Operators
CvsCellRange Structure See Also Send Feedback

The CvsCellRange type exposes the following members.

Operators

Name | Description
Equality | Equality operator.
Inequality | Inequality operator.

See Also

CvsCellRange Structure
Cognex.InSight Namespace


CvsCellRange.Equality Operator

[image]

In-Sight SDK
CvsCellRange..::..Equality Operator
CvsCellRange Structure See Also Send Feedback
Equality operator.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool operator ==(
    CvsCellRange left,
    CvsCellRange right
)
Visual Basic
Public Shared Operator = (
    left As CvsCellRange,
    right As CvsCellRange
) As Boolean

Parameters

left
Type: Cognex.InSight..::..CvsCellRange
The first CvsCellRange to test.
right
Type: Cognex.InSight..::..CvsCellRange
The second CvsCellRange to test.

Return Value

Type: Boolean
true if the locations and sizes are equal; otherwise, false.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Inequality Operator

[image]

In-Sight SDK
CvsCellRange..::..Inequality Operator
CvsCellRange Structure See Also Send Feedback
Inequality operator.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool operator !=(
    CvsCellRange left,
    CvsCellRange right
)
Visual Basic
Public Shared Operator <> (
    left As CvsCellRange,
    right As CvsCellRange
) As Boolean

Parameters

left
Type: Cognex.InSight..::..CvsCellRange
The first CvsCellRange to test.
right
Type: Cognex.InSight..::..CvsCellRange
The second CvsCellRange to test.

Return Value

Type: Boolean
true if the locations and sizes are not equal; otherwise, false.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange Properties

[image] [image]

In-Sight SDK
CvsCellRange Properties
CvsCellRange Structure See Also Send Feedback

The CvsCellRange type exposes the following members.

Properties

 | Name | Description
Public property | Column | Gets or sets the column coordinate of the start of the range.
Public property | Columns | Gets or sets the number of columns.
 | EntireJob | A range used for wildcarding ISP messages.
Public property | IsEmpty | Determines whether the range is empty.
Public property | IsValid | Determines whether the range is valid.
Public property | LastColumn | Gets the column coordinate of the end of the range.
Public property | LastLocation | Gets the location of the end of the range.
Public property | LastRow | Gets the row coordinate of the end of the range.
Public property | Location | Gets or sets the location of the start of the range.
Public property | Row | Gets or sets the row coordinate of the start of the range.
Public property | Rows | Gets or sets the number of rows.
Public property | Size | Gets or sets the size of the range.

See Also

CvsCellRange Structure
Cognex.InSight Namespace


CvsCellRange.Column Property

[image]

In-Sight SDK
CvsCellRange..::..Column Property
CvsCellRange Structure See Also Send Feedback
Gets or sets the column coordinate of the start of the range.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Column { get; set; }
Visual Basic
Public Property Column As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Columns Property

[image]

In-Sight SDK
CvsCellRange..::..Columns Property
CvsCellRange Structure See Also Send Feedback
Gets or sets the number of columns.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Columns { get; set; }
Visual Basic
Public Property Columns As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.EntireJob Property

[image]

In-Sight SDK
CvsCellRange..::..EntireJob Property
CvsCellRange Structure See Also Send Feedback
A range used for wildcarding ISP messages.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static CvsCellRange EntireJob { get; }
Visual Basic
Public Shared ReadOnly Property EntireJob As CvsCellRange
    Get

Property Value

Type: CvsCellRange

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.IsEmpty Property

[image]

In-Sight SDK
CvsCellRange..::..IsEmpty Property
CvsCellRange Structure See Also Send Feedback
Determines whether the range is empty.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if the range contains zero rows and/or zero columms; false otherwise.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.IsValid Property

[image]

In-Sight SDK
CvsCellRange..::..IsValid Property
CvsCellRange Structure See Also Send Feedback
Determines whether the range is valid.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Property Value

Type: Boolean
true if the Location is valid and both Rows and Columns are nonnegative; false otherwise.

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.LastColumn Property

[image]

In-Sight SDK
CvsCellRange..::..LastColumn Property
CvsCellRange Structure See Also Send Feedback
Gets the column coordinate of the end of the range.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int LastColumn { get; set; }
Visual Basic
Public Property LastColumn As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.LastLocation Property

[image]

In-Sight SDK
CvsCellRange..::..LastLocation Property
CvsCellRange Structure See Also Send Feedback
Gets the location of the end of the range.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation LastLocation { get; set; }
Visual Basic
Public Property LastLocation As CvsCellLocation
    Get
    Set

Property Value

Type: CvsCellLocation

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.LastRow Property

[image]

In-Sight SDK
CvsCellRange..::..LastRow Property
CvsCellRange Structure See Also Send Feedback
Gets the row coordinate of the end of the range.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int LastRow { get; set; }
Visual Basic
Public Property LastRow As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Location Property

[image]

In-Sight SDK
CvsCellRange..::..Location Property
CvsCellRange Structure See Also Send Feedback
Gets or sets the location of the start of the range.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation Location { get; set; }
Visual Basic
Public Property Location As CvsCellLocation
    Get
    Set

Property Value

Type: CvsCellLocation

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Row Property

[image]

In-Sight SDK
CvsCellRange..::..Row Property
CvsCellRange Structure See Also Send Feedback
Gets or sets the row coordinate of the start of the range.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Row { get; set; }
Visual Basic
Public Property Row As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Rows Property

[image]

In-Sight SDK
CvsCellRange..::..Rows Property
CvsCellRange Structure See Also Send Feedback
Gets or sets the number of rows.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Rows { get; set; }
Visual Basic
Public Property Rows As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsCellRange.Size Property

[image]

In-Sight SDK
CvsCellRange..::..Size Property
CvsCellRange Structure See Also Send Feedback
Gets or sets the size of the range.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Size Size { get; set; }
Visual Basic
Public Property Size As Size
    Get
    Set

Property Value

Type: Size

See Also

CvsCellRange Structure
CvsCellRange..::..CvsCellRange Members
Cognex.InSight Namespace


CvsColorMap Class

[image]

In-Sight SDK
CvsColorMap Class
Members See Also Send Feedback
Contains a collection of color map entries.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsColorMap : ICollection<CvsColorMapEntry>,
    IEnumerable<CvsColorMapEntry>, IEnumerable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsColorMap
    Implements ICollection(Of CvsColorMapEntry), IEnumerable(Of CvsColorMapEntry),
    IEnumerable

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsColorMap

See Also

CvsColorMap..::..CvsColorMap Members
Cognex.InSight Namespace


CvsColorMap Members

[image] [image]

In-Sight SDK
CvsColorMap Members
CvsColorMap Class Constructors Methods Properties See Also Send Feedback

The CvsColorMap type exposes the following members.

Constructors

 | Name | Description
Public method | CvsColorMap | Initializes an empty color map.

Methods

 | Name | Description
Public method | Add(CvsColorMapEntry) | Adds a new entry to the color map.
Public method | Add(Color, Color) | Adds a new entry to the color map.
Public method | Clear | Removes all entries from the color map.
Public method | Contains | Returns true if this map contains the specified entry; otherwise false.
Public method | CopyTo | Copies the entire collection to an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the color map.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Remove | Removes the specified entry from the color map
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the color map.

See Also

CvsColorMap Class
Cognex.InSight Namespace


CvsColorMap Constructor

[image]

In-Sight SDK
CvsColorMap Constructor
CvsColorMap Class See Also Send Feedback
Initializes an empty color map.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsColorMap()
Visual Basic
Public Sub New

See Also

CvsColorMap Class
CvsColorMap..::..CvsColorMap Members
Cognex.InSight Namespace


CvsColorMap Methods

[image] [image]

In-Sight SDK
CvsColorMap Methods
CvsColorMap Class See Also Send Feedback

The CvsColorMap type exposes the following members.

Methods

 | Name | Description
Public method | Add(CvsColorMapEntry) | Adds a new entry to the color map.
Public method | Add(Color, Color) | Adds a new entry to the color map.
Public method | Clear | Removes all entries from the color map.
Public method | Contains | Returns true if this map contains the specified entry; otherwise false.
Public method | CopyTo | Copies the entire collection to an array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the color map.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Remove | Removes the specified entry from the color map
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsColorMap Class
Cognex.InSight Namespace


CvsColorMap.Add Method

[image] [image]

In-Sight SDK
CvsColorMap..::..Add Method
CvsColorMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(CvsColorMapEntry) | Adds a new entry to the color map.
Public method | Add(Color, Color) | Adds a new entry to the color map.

See Also

CvsColorMap Class
CvsColorMap..::..CvsColorMap Members
Cognex.InSight Namespace


CvsColorMap.Add Method (CvsColorMapEntry)

[image]

In-Sight SDK
CvsColorMap..::..Add Method (CvsColorMapEntry)
CvsColorMap Class See Also Send Feedback
Adds a new entry to the color map.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Add(
    CvsColorMapEntry item
)
Visual Basic
Public Sub Add (
    item As CvsColorMapEntry
)

Parameters

item
Type: Cognex.InSight..::..CvsColorMapEntry

[Missing <param name="item"/> documentation for "M:Cognex.InSight.CvsColorMap.Add(Cognex.InSight.CvsColorMapEntry)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

CvsColorMap Class
CvsColorMap..::..CvsColorMap Members
Add Overload
Cognex.InSight Namespace


CvsColorMap.Add Method (Color, Color)

[image]

In-Sight SDK
CvsColorMap..::..Add Method (Color, Color)
CvsColorMap Class See Also Send Feedback
Adds a new entry to the color map.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Add(
    Color from,
    Color to
)
Visual Basic
Public Sub Add (
    from As Color,
    to As Color
)

Parameters

from
Type: System.Drawing..::..Color

[Missing <param name="from"/> documentation for "M:Cognex.InSight.CvsColorMap.Add(System.Drawing.Color,System.Drawing.Color)"]

to
Type: System.Drawing..::..Color

[Missing <param name="to"/> documentation for "M:Cognex.InSight.CvsColorMap.Add(System.Drawing.Color,System.Drawing.Color)"]

See Also

CvsColorMap Class
CvsColorMap..::..CvsColorMap Members
Add Overload
Cognex.InSight Namespace


CvsColorMap.Clear Method

[image]

In-Sight SDK
CvsColorMap..::..Clear Method
CvsColorMap Class See Also Send Feedback
Removes all entries from the color map.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

CvsColorMap Class
CvsColorMap..::..CvsColorMap Members
Cognex.InSight Namespace


CvsColorMap.Contains Method

[image]

In-Sight SDK
CvsColorMap..::..Contains Method
CvsColorMap Class See Also Send Feedback
Returns true if this map contains the specified entry; otherwise false.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Contains(
    CvsColorMapEntry item
)
Visual Basic
Public Function Contains (
    item As CvsColorMapEntry
) As Boolean

Parameters

item
Type: Cognex.InSight..::..CvsColorMapEntry

[Missing <param name="item"/> documentation for "M:Cognex.InSight.CvsColorMap.Contains(Cognex.InSight.CvsColorMapEntry)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.CvsColorMap.Contains(Cognex.InSight.CvsColorMapEntry)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

CvsColorMap Class
CvsColorMap..::..CvsColorMap Members
Cognex.InSight Namespace


CvsColorMap.CopyTo Method

[image]

In-Sight SDK
CvsColorMap..::..CopyTo Method
CvsColorMap Class See Also Send Feedback
Copies the entire collection to an array.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void CopyTo(
    CvsColorMapEntry[] array,
    int arrayIndex
)
Visual Basic
Public Sub CopyTo (
    array As CvsColorMapEntry(),
    arrayIndex As Integer
)

Parameters

array
Type: array< Cognex.InSight..::..CvsColorMapEntry >[]()[][]

[Missing <param name="array"/> documentation for "M:Cognex.InSight.CvsColorMap.CopyTo(Cognex.InSight.CvsColorMapEntry[],System.Int32)"]

arrayIndex
Type: System..::..Int32

[Missing <param name="arrayIndex"/> documentation for "M:Cognex.InSight.CvsColorMap.CopyTo(Cognex.InSight.CvsColorMapEntry[],System.Int32)"]

Implements

ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)

See Also

CvsColorMap Class
CvsColorMap..::..CvsColorMap Members
Cognex.InSight Namespace


CvsColorMap.GetEnumerator Method

[image]

In-Sight SDK
CvsColorMap..::..GetEnumerator Method
CvsColorMap Class See Also Send Feedback
Returns an enumerator that iterates through the color map.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerator<CvsColorMapEntry> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of CvsColorMapEntry)

Return Value

Type: IEnumerator <(Of <(<' CvsColorMapEntry >)>)>

[Missing <returns> documentation for "M:Cognex.InSight.CvsColorMap.GetEnumerator"]

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

CvsColorMap Class
CvsColorMap..::..CvsColorMap Members
Cognex.InSight Namespace


CvsColorMap.Remove Method

[image]

In-Sight SDK
CvsColorMap..::..Remove Method
CvsColorMap Class See Also Send Feedback
Removes the specified entry from the color map

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Remove(
    CvsColorMapEntry item
)
Visual Basic
Public Function Remove (
    item As CvsColorMapEntry
) As Boolean

Parameters

item
Type: Cognex.InSight..::..CvsColorMapEntry

[Missing <param name="item"/> documentation for "M:Cognex.InSight.CvsColorMap.Remove(Cognex.InSight.CvsColorMapEntry)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.CvsColorMap.Remove(Cognex.InSight.CvsColorMapEntry)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

CvsColorMap Class
CvsColorMap..::..CvsColorMap Members
Cognex.InSight Namespace


CvsColorMap Properties

[image] [image]

In-Sight SDK
CvsColorMap Properties
CvsColorMap Class See Also Send Feedback

The CvsColorMap type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the color map.

See Also

CvsColorMap Class
Cognex.InSight Namespace


CvsColorMap.Count Property

[image]

In-Sight SDK
CvsColorMap..::..Count Property
CvsColorMap Class See Also Send Feedback
Gets the number of entries in the color map.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

CvsColorMap Class
CvsColorMap..::..CvsColorMap Members
Cognex.InSight Namespace


CvsColorMapArrayTag Class

[image]

In-Sight SDK
CvsColorMapArrayTag Class
Members See Also Send Feedback
Holds a collection of CvsColorMaps for a block of cells.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsColorMapArrayTag : ICvsTagData,
    ICloneable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsColorMapArrayTag
    Implements ICvsTagData, ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsColorMapArrayTag

See Also

CvsColorMapArrayTag..::..CvsColorMapArrayTag Members
Cognex.InSight Namespace


CvsColorMapArrayTag Members

[image] [image]

In-Sight SDK
CvsColorMapArrayTag Members
CvsColorMapArrayTag Class Methods Properties See Also Send Feedback

The CvsColorMapArrayTag type exposes the following members.

Methods

 | Name | Description
Public method | AddColorMap | Adds an entry to the color map.
Public method | ClearColorMaps | Removes all of the color maps.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetColorMap | Gets the color map stored at the specified index.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SafeGetColorMap | Gets the color map stored at the specified index.
Public method | SetColorMaps | Replaces the existing color map with the specified color map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColorMaps | Gets the color maps
Public property | Index | Gets the index value.

See Also

CvsColorMapArrayTag Class
Cognex.InSight Namespace


CvsColorMapArrayTag Methods

[image] [image]

In-Sight SDK
CvsColorMapArrayTag Methods
CvsColorMapArrayTag Class See Also Send Feedback

The CvsColorMapArrayTag type exposes the following members.

Methods

 | Name | Description
Public method | AddColorMap | Adds an entry to the color map.
Public method | ClearColorMaps | Removes all of the color maps.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetColorMap | Gets the color map stored at the specified index.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SafeGetColorMap | Gets the color map stored at the specified index.
Public method | SetColorMaps | Replaces the existing color map with the specified color map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsColorMapArrayTag Class
Cognex.InSight Namespace


CvsColorMapArrayTag.AddColorMap Method

[image]

In-Sight SDK
CvsColorMapArrayTag..::..AddColorMap Method
CvsColorMapArrayTag Class See Also Send Feedback
Adds an entry to the color map.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void AddColorMap(
    CvsColorMap map
)
Visual Basic
Public Sub AddColorMap (
    map As CvsColorMap
)

Parameters

map
Type: Cognex.InSight..::..CvsColorMap

[Missing <param name="map"/> documentation for "M:Cognex.InSight.CvsColorMapArrayTag.AddColorMap(Cognex.InSight.CvsColorMap)"]

See Also

CvsColorMapArrayTag Class
CvsColorMapArrayTag..::..CvsColorMapArrayTag Members
Cognex.InSight Namespace


CvsColorMapArrayTag.ClearColorMaps Method

[image]

In-Sight SDK
CvsColorMapArrayTag..::..ClearColorMaps Method
CvsColorMapArrayTag Class See Also Send Feedback
Removes all of the color maps.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ClearColorMaps()
Visual Basic
Public Sub ClearColorMaps

See Also

CvsColorMapArrayTag Class
CvsColorMapArrayTag..::..CvsColorMapArrayTag Members
Cognex.InSight Namespace


CvsColorMapArrayTag.GetColorMap Method

[image]

In-Sight SDK
CvsColorMapArrayTag..::..GetColorMap Method
CvsColorMapArrayTag Class See Also Send Feedback
Gets the color map stored at the specified index.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsColorMap GetColorMap(
    int index
)
Visual Basic
Public Function GetColorMap (
    index As Integer
) As CvsColorMap

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Cognex.InSight.CvsColorMapArrayTag.GetColorMap(System.Int32)"]

Return Value

Type: CvsColorMap

[Missing <returns> documentation for "M:Cognex.InSight.CvsColorMapArrayTag.GetColorMap(System.Int32)"]

See Also

CvsColorMapArrayTag Class
CvsColorMapArrayTag..::..CvsColorMapArrayTag Members
Cognex.InSight Namespace


CvsColorMapArrayTag.SafeGetColorMap Method

[image]

In-Sight SDK
CvsColorMapArrayTag..::..SafeGetColorMap Method
CvsColorMapArrayTag Class See Also Send Feedback
Gets the color map stored at the specified index.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsColorMap SafeGetColorMap(
    int index
)
Visual Basic
Public Function SafeGetColorMap (
    index As Integer
) As CvsColorMap

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Cognex.InSight.CvsColorMapArrayTag.SafeGetColorMap(System.Int32)"]

Return Value

Type: CvsColorMap

[Missing <returns> documentation for "M:Cognex.InSight.CvsColorMapArrayTag.SafeGetColorMap(System.Int32)"]

Remarks

* If there are no color maps, this returns null. * If the index is out of range, it is brought in range.

See Also

CvsColorMapArrayTag Class
CvsColorMapArrayTag..::..CvsColorMapArrayTag Members
Cognex.InSight Namespace


CvsColorMapArrayTag.SetColorMaps Method

[image]

In-Sight SDK
CvsColorMapArrayTag..::..SetColorMaps Method
CvsColorMapArrayTag Class See Also Send Feedback
Replaces the existing color map with the specified color map.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetColorMaps(
    IEnumerable<CvsColorMap> maps
)
Visual Basic
Public Sub SetColorMaps (
    maps As IEnumerable(Of CvsColorMap)
)

Parameters

maps
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' CvsColorMap >)>)>

[Missing <param name="maps"/> documentation for "M:Cognex.InSight.CvsColorMapArrayTag.SetColorMaps(System.Collections.Generic.IEnumerable{Cognex.InSight.CvsColorMap})"]

See Also

CvsColorMapArrayTag Class
CvsColorMapArrayTag..::..CvsColorMapArrayTag Members
Cognex.InSight Namespace


CvsColorMapArrayTag Properties

[image] [image]

In-Sight SDK
CvsColorMapArrayTag Properties
CvsColorMapArrayTag Class See Also Send Feedback

The CvsColorMapArrayTag type exposes the following members.

Properties

 | Name | Description
Public property | ColorMaps | Gets the color maps
Public property | Index | Gets the index value.

See Also

CvsColorMapArrayTag Class
Cognex.InSight Namespace


CvsColorMapArrayTag.ColorMaps Property

[image]

In-Sight SDK
CvsColorMapArrayTag..::..ColorMaps Property
CvsColorMapArrayTag Class See Also Send Feedback
Gets the color maps

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerable<CvsColorMap> ColorMaps { get; }
Visual Basic
Public ReadOnly Property ColorMaps As IEnumerable(Of CvsColorMap)
    Get

Property Value

Type: IEnumerable <(Of <(<' CvsColorMap >)>)>

See Also

CvsColorMapArrayTag Class
CvsColorMapArrayTag..::..CvsColorMapArrayTag Members
Cognex.InSight Namespace


CvsColorMapArrayTag.Index Property

[image]

In-Sight SDK
CvsColorMapArrayTag..::..Index Property
CvsColorMapArrayTag Class See Also Send Feedback
Gets the index value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Index { get; set; }
Visual Basic
Public Property Index As Object
    Get
    Set

Property Value

Type: Object

See Also

CvsColorMapArrayTag Class
CvsColorMapArrayTag..::..CvsColorMapArrayTag Members
Cognex.InSight Namespace


CvsColorMapEntry Structure

[image]

In-Sight SDK
CvsColorMapEntry Structure
Members See Also Send Feedback
Contains the mapping of a color to another color.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public struct CvsColorMapEntry : IEquatable<CvsColorMapEntry>
Visual Basic
<SerializableAttribute>
Public Structure CvsColorMapEntry
    Implements IEquatable(Of CvsColorMapEntry)

See Also

CvsColorMapEntry..::..CvsColorMapEntry Members
Cognex.InSight Namespace


CvsColorMapEntry Members

[image] [image]

In-Sight SDK
CvsColorMapEntry Members
CvsColorMapEntry Structure Methods Fields See Also Send Feedback

The CvsColorMapEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns true if the specified value is equivalent to this value. (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | Gets a unique 32-bit value. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | From | The color to change from.
Public field | To | The color to change to.

See Also

CvsColorMapEntry Structure
Cognex.InSight Namespace


CvsColorMapEntry Fields

[image] [image]

In-Sight SDK
CvsColorMapEntry Fields
CvsColorMapEntry Structure See Also Send Feedback

The CvsColorMapEntry type exposes the following members.

Fields

 | Name | Description
Public field | From | The color to change from.
Public field | To | The color to change to.

See Also

CvsColorMapEntry Structure
Cognex.InSight Namespace


CvsColorMapEntry.From Field

[image]

In-Sight SDK
CvsColorMapEntry..::..From Field
CvsColorMapEntry Structure See Also Send Feedback
The color to change from.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color From
Visual Basic
Public From As Color

Field Value

Type: Color

See Also

CvsColorMapEntry Structure
CvsColorMapEntry..::..CvsColorMapEntry Members
Cognex.InSight Namespace


CvsColorMapEntry.To Field

[image]

In-Sight SDK
CvsColorMapEntry..::..To Field
CvsColorMapEntry Structure See Also Send Feedback
The color to change to.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color To
Visual Basic
Public To As Color

Field Value

Type: Color

See Also

CvsColorMapEntry Structure
CvsColorMapEntry..::..CvsColorMapEntry Members
Cognex.InSight Namespace


CvsColorMapEntry Methods

[image] [image]

In-Sight SDK
CvsColorMapEntry Methods
CvsColorMapEntry Structure See Also Send Feedback

The CvsColorMapEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns true if the specified value is equivalent to this value. (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | Gets a unique 32-bit value. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CvsColorMapEntry Structure
Cognex.InSight Namespace


CvsColorMapEntry.Equals Method

[image]

In-Sight SDK
CvsColorMapEntry..::..Equals Method
CvsColorMapEntry Structure See Also Send Feedback
Returns true if the specified value is equivalent to this value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:Cognex.InSight.CvsColorMapEntry.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.CvsColorMapEntry.Equals(System.Object)"]

See Also

CvsColorMapEntry Structure
CvsColorMapEntry..::..CvsColorMapEntry Members
Cognex.InSight Namespace


CvsColorMapEntry.GetHashCode Method

[image]

In-Sight SDK
CvsColorMapEntry..::..GetHashCode Method
CvsColorMapEntry Structure See Also Send Feedback
Gets a unique 32-bit value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32

[Missing <returns> documentation for "M:Cognex.InSight.CvsColorMapEntry.GetHashCode"]

See Also

CvsColorMapEntry Structure
CvsColorMapEntry..::..CvsColorMapEntry Members
Cognex.InSight Namespace


CvsCommunicationException Class

[image]

In-Sight SDK
CvsCommunicationException Class
Members See Also Send Feedback
Provides a base class for exceptions that are thrown when a communication failure occurs.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public abstract class CvsCommunicationException : CvsException
Visual Basic
<SerializableAttribute>
Public MustInherit Class CvsCommunicationException
    Inherits CvsException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsCommunicationException
Cognex.InSight..::..CvsInSightLockedException
Cognex.InSight..::..CvsNetworkException
Cognex.InSight..::..CvsNotConnectedException
Cognex.InSight.NativeMode..::..CvsNativeModeResponseException
Cognex.InSight.NativeMode..::..CvsNativeModeTimeoutException

See Also

CvsCommunicationException..::..CvsCommunicationException Members
Cognex.InSight Namespace
Cognex.InSight..::..CvsNetworkException
Cognex.InSight..::..CvsNotConnectedException
Cognex.InSight..::..CvsInSightLockedException


CvsCommunicationException Members

[image] [image]

In-Sight SDK
CvsCommunicationException Members
CvsCommunicationException Class Methods Properties Events See Also Send Feedback

The CvsCommunicationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

CvsCommunicationException Class
Cognex.InSight Namespace


CvsCommunicationException Methods

[image] [image]

In-Sight SDK
CvsCommunicationException Methods
CvsCommunicationException Class See Also Send Feedback

The CvsCommunicationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsCommunicationException Class
Cognex.InSight Namespace


CvsCommunicationException Properties

[image] [image]

In-Sight SDK
CvsCommunicationException Properties
CvsCommunicationException Class See Also Send Feedback

The CvsCommunicationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsCommunicationException Class
Cognex.InSight Namespace


CvsCommunicationException Events

[image] [image]

In-Sight SDK
CvsCommunicationException Events
CvsCommunicationException Class See Also Send Feedback

The CvsCommunicationException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

CvsCommunicationException Class
Cognex.InSight Namespace


CvsConnectCompletedEventArgs Class

[image]

In-Sight SDK
CvsConnectCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the ConnectCompleted event, which is raised after an asynchronous call to the Connect(IPAddress, String, String, Boolean, Boolean) method has completed.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsConnectCompletedEventArgs : EventArgs
Visual Basic
<SerializableAttribute>
Public Class CvsConnectCompletedEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Cognex.InSight..::..CvsConnectCompletedEventArgs

See Also

CvsConnectCompletedEventArgs..::..CvsConnectCompletedEventArgs Members
Cognex.InSight Namespace


CvsConnectCompletedEventArgs Members

[image] [image]

In-Sight SDK
CvsConnectCompletedEventArgs Members
CvsConnectCompletedEventArgs Class Methods Properties See Also Send Feedback

The CvsConnectCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ErrorMessage | Gets the error message if an error occurred, or an empty string if the connection was successful.
Public property | ErrorNumber | Gets the error number if an error occurred, or zero if the connection was successful.
Public property | Exception | Gets the exception that was thrown during connection, or null if the connection was successful. This property is not available in COM/ActiveX applications.

See Also

CvsConnectCompletedEventArgs Class
Cognex.InSight Namespace


CvsConnectCompletedEventArgs Methods

[image] [image]

In-Sight SDK
CvsConnectCompletedEventArgs Methods
CvsConnectCompletedEventArgs Class See Also Send Feedback

The CvsConnectCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsConnectCompletedEventArgs Class
Cognex.InSight Namespace


CvsConnectCompletedEventArgs Properties

[image] [image]

In-Sight SDK
CvsConnectCompletedEventArgs Properties
CvsConnectCompletedEventArgs Class See Also Send Feedback

The CvsConnectCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ErrorMessage | Gets the error message if an error occurred, or an empty string if the connection was successful.
Public property | ErrorNumber | Gets the error number if an error occurred, or zero if the connection was successful.
Public property | Exception | Gets the exception that was thrown during connection, or null if the connection was successful. This property is not available in COM/ActiveX applications.

See Also

CvsConnectCompletedEventArgs Class
Cognex.InSight Namespace


CvsConnectCompletedEventArgs.ErrorMessage Property

[image]

In-Sight SDK
CvsConnectCompletedEventArgs..::..ErrorMessage Property
CvsConnectCompletedEventArgs Class See Also Send Feedback
Gets the error message if an error occurred, or an empty string if the connection was successful.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string ErrorMessage { get; }
Visual Basic
Public ReadOnly Property ErrorMessage As String
    Get

Property Value

Type: String

See Also

CvsConnectCompletedEventArgs Class
CvsConnectCompletedEventArgs..::..CvsConnectCompletedEventArgs Members
Cognex.InSight Namespace


CvsConnectCompletedEventArgs.ErrorNumber Property

[image]

In-Sight SDK
CvsConnectCompletedEventArgs..::..ErrorNumber Property
CvsConnectCompletedEventArgs Class See Also Send Feedback
Gets the error number if an error occurred, or zero if the connection was successful.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int ErrorNumber { get; }
Visual Basic
Public ReadOnly Property ErrorNumber As Integer
    Get

Property Value

Type: Int32

See Also

CvsConnectCompletedEventArgs Class
CvsConnectCompletedEventArgs..::..CvsConnectCompletedEventArgs Members
Cognex.InSight Namespace


CvsConnectCompletedEventArgs.Exception Property

[image]

In-Sight SDK
CvsConnectCompletedEventArgs..::..Exception Property
CvsConnectCompletedEventArgs Class See Also Send Feedback
Gets the exception that was thrown during connection, or null if the connection was successful. This property is not available in COM/ActiveX applications.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Exception Exception { get; }
Visual Basic
Public ReadOnly Property Exception As Exception
    Get

Property Value

Type: Exception

See Also

CvsConnectCompletedEventArgs Class
CvsConnectCompletedEventArgs..::..CvsConnectCompletedEventArgs Members
Cognex.InSight Namespace


CvsConnectCompletedEventHandler Delegate

[image]

In-Sight SDK
CvsConnectCompletedEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the ConnectCompleted event.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public delegate void CvsConnectCompletedEventHandler(
    Object sender,
    CvsConnectCompletedEventArgs e
)
Visual Basic
Public Delegate Sub CvsConnectCompletedEventHandler (
    sender As Object,
    e As CvsConnectCompletedEventArgs
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Cognex.InSight..::..CvsConnectCompletedEventArgs
A CvsConnectCompletedEventArgs that contains the event data.

See Also

Cognex.InSight Namespace


CvsEasyView Class

[image]

In-Sight SDK
CvsEasyView Class
Members See Also Send Feedback
Holds the list of EasyView items that define an EasyView.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsEasyView : IEnumerable<CvsEasyViewItem>,
    IEnumerable
Visual Basic
<SerializableAttribute>
Public Class CvsEasyView
    Implements IEnumerable(Of CvsEasyViewItem), IEnumerable

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsEasyView

See Also

CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyView Members

[image] [image]

In-Sight SDK
CvsEasyView Members
CvsEasyView Class Methods Properties See Also Send Feedback

The CvsEasyView type exposes the following members.

Methods

 | Name | Description
Public method | Add(CvsSymbolicTag) | Adds a new EasyView item bound to a symbolic tag.
Public method | Add(CvsSymbolicTag, String) | Adds a new EasyView item bound to a symbolic tag with the specified caption.
Public method | AddLabel()()()() | Adds a new EasyView label where the name of the tag is used as the caption.
Public method | AddLabel(String) | Adds a new EasyView label with the specified caption.
Public method | Clear | Removes all of the items from the EasyView.
Public method | Contains(CvsEasyViewItem) | Determines whether this EasyView instance contains an item.
Public method | Contains(CvsSymbolicTag) | Determines whether this EasyView instance contains a symbolic tag.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this EasyView instance.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(CvsEasyViewItem) | Returns the zero-based index of the first occurrence of the specified item.
Public method | IndexOf(CvsSymbolicTag) | Returns the zero-based index of the first occurrence of the item matching the symbolic tag.
Public method | IndexOf(CvsEasyViewItem, Int32) | Returns the zero-based index of the first occurrence of the specified item.
Public method | IndexOf(CvsSymbolicTag, Int32) | Returns the zero-based index of the first occurrence of the item matching the symbolic tag.
Public method | IndexOf(CvsEasyViewItem, Int32, Int32) | Returns the zero-based index of the first occurrence of the specified item.
Public method | IndexOf(CvsSymbolicTag, Int32, Int32) | Returns the zero-based index of the first occurrence of the item matching the symbolic tag.
Public method | Insert(CvsSymbolicTag, Int32) | Inserts a new EasyView item bound to a symbolic tag at the specified index.
Public method | Insert(CvsSymbolicTag, String, Int32) | Inserts a new EasyView item bound to a symbolic tag at the specified index with the specified caption.
Public method | InsertLabel(Int32) | Inserts a new EasyView label at the specified index with the specified caption.
Public method | InsertLabel(String, Int32) | Inserts a new EasyView label at the specified index with the specified caption.
Public method | IsTagAllowedInEasyView | Determines if a symbolic tag is allowed to be in an EasyView.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(CvsEasyViewItem) | Removes the specified item from this EasyView instance.
Public method | Remove(CvsSymbolicTag) | Removes the specified tag from this EasyView instance.
Public method | RemoveAt | Removes the element at the specified index from this EasyView instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of items contained within the EasyView.
Public property | Item | Gets or sets an EasyView item at the specified index.

See Also

CvsEasyView Class
Cognex.InSight Namespace


CvsEasyView Methods

[image] [image]

In-Sight SDK
CvsEasyView Methods
CvsEasyView Class See Also Send Feedback

The CvsEasyView type exposes the following members.

Methods

 | Name | Description
Public method | Add(CvsSymbolicTag) | Adds a new EasyView item bound to a symbolic tag.
Public method | Add(CvsSymbolicTag, String) | Adds a new EasyView item bound to a symbolic tag with the specified caption.
Public method | AddLabel()()()() | Adds a new EasyView label where the name of the tag is used as the caption.
Public method | AddLabel(String) | Adds a new EasyView label with the specified caption.
Public method | Clear | Removes all of the items from the EasyView.
Public method | Contains(CvsEasyViewItem) | Determines whether this EasyView instance contains an item.
Public method | Contains(CvsSymbolicTag) | Determines whether this EasyView instance contains a symbolic tag.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this EasyView instance.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(CvsEasyViewItem) | Returns the zero-based index of the first occurrence of the specified item.
Public method | IndexOf(CvsSymbolicTag) | Returns the zero-based index of the first occurrence of the item matching the symbolic tag.
Public method | IndexOf(CvsEasyViewItem, Int32) | Returns the zero-based index of the first occurrence of the specified item.
Public method | IndexOf(CvsSymbolicTag, Int32) | Returns the zero-based index of the first occurrence of the item matching the symbolic tag.
Public method | IndexOf(CvsEasyViewItem, Int32, Int32) | Returns the zero-based index of the first occurrence of the specified item.
Public method | IndexOf(CvsSymbolicTag, Int32, Int32) | Returns the zero-based index of the first occurrence of the item matching the symbolic tag.
Public method | Insert(CvsSymbolicTag, Int32) | Inserts a new EasyView item bound to a symbolic tag at the specified index.
Public method | Insert(CvsSymbolicTag, String, Int32) | Inserts a new EasyView item bound to a symbolic tag at the specified index with the specified caption.
Public method | InsertLabel(Int32) | Inserts a new EasyView label at the specified index with the specified caption.
Public method | InsertLabel(String, Int32) | Inserts a new EasyView label at the specified index with the specified caption.
Public method | IsTagAllowedInEasyView | Determines if a symbolic tag is allowed to be in an EasyView.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(CvsEasyViewItem) | Removes the specified item from this EasyView instance.
Public method | Remove(CvsSymbolicTag) | Removes the specified tag from this EasyView instance.
Public method | RemoveAt | Removes the element at the specified index from this EasyView instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsEasyView Class
Cognex.InSight Namespace


CvsEasyView.Add Method

[image] [image]

In-Sight SDK
CvsEasyView..::..Add Method
CvsEasyView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(CvsSymbolicTag) | Adds a new EasyView item bound to a symbolic tag.
Public method | Add(CvsSymbolicTag, String) | Adds a new EasyView item bound to a symbolic tag with the specified caption.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyView.Add Method (CvsSymbolicTag)

[image]

In-Sight SDK
CvsEasyView..::..Add Method (CvsSymbolicTag)
CvsEasyView Class See Also Send Feedback
Adds a new EasyView item bound to a symbolic tag.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Add(
    CvsSymbolicTag tag
)
Visual Basic
Public Sub Add (
    tag As CvsSymbolicTag
)

Parameters

tag
Type: Cognex.InSight..::..CvsSymbolicTag
The symbolic tag to use to create the EasyView item.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Add Overload
Cognex.InSight Namespace


CvsEasyView.Add Method (CvsSymbolicTag, String)

[image]

In-Sight SDK
CvsEasyView..::..Add Method (CvsSymbolicTag, String)
CvsEasyView Class See Also Send Feedback
Adds a new EasyView item bound to a symbolic tag with the specified caption.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Add(
    CvsSymbolicTag tag,
    string caption
)
Visual Basic
Public Sub Add (
    tag As CvsSymbolicTag,
    caption As String
)

Parameters

tag
Type: Cognex.InSight..::..CvsSymbolicTag
The symbolic tag to use to create the EasyView item.
caption
Type: System..::..String
The caption to give the item. If this is null or empty, then the name of the tag is used as the caption.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The symbolic tag is not allowed.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Add Overload
Cognex.InSight Namespace


CvsEasyView.AddLabel Method

[image] [image]

In-Sight SDK
CvsEasyView..::..AddLabel Method
CvsEasyView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddLabel()()()() | Adds a new EasyView label where the name of the tag is used as the caption.
Public method | AddLabel(String) | Adds a new EasyView label with the specified caption.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyView.AddLabel Method

[image]

In-Sight SDK
CvsEasyView..::..AddLabel Method
CvsEasyView Class See Also Send Feedback
Adds a new EasyView label where the name of the tag is used as the caption.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void AddLabel()
Visual Basic
Public Sub AddLabel

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
AddLabel Overload
Cognex.InSight Namespace


CvsEasyView.AddLabel Method (String)

[image]

In-Sight SDK
CvsEasyView..::..AddLabel Method (String)
CvsEasyView Class See Also Send Feedback
Adds a new EasyView label with the specified caption.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void AddLabel(
    string caption
)
Visual Basic
Public Sub AddLabel (
    caption As String
)

Parameters

caption
Type: System..::..String
The caption to give the item. If this is null or empty, then the name of the tag is used as the caption.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
AddLabel Overload
Cognex.InSight Namespace


CvsEasyView.Clear Method

[image]

In-Sight SDK
CvsEasyView..::..Clear Method
CvsEasyView Class See Also Send Feedback
Removes all of the items from the EasyView.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyView.Contains Method

[image] [image]

In-Sight SDK
CvsEasyView..::..Contains Method
CvsEasyView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Contains(CvsEasyViewItem) | Determines whether this EasyView instance contains an item.
Public method | Contains(CvsSymbolicTag) | Determines whether this EasyView instance contains a symbolic tag.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyView.Contains Method (CvsEasyViewItem)

[image]

In-Sight SDK
CvsEasyView..::..Contains Method (CvsEasyViewItem)
CvsEasyView Class See Also Send Feedback
Determines whether this EasyView instance contains an item.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Contains(
    CvsEasyViewItem item
)
Visual Basic
Public Function Contains (
    item As CvsEasyViewItem
) As Boolean

Parameters

item
Type: Cognex.InSight..::..CvsEasyViewItem
The item to search for.

Return Value

Type: Boolean
True if the item is contained in this instance; otherwise false.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Contains Overload
Cognex.InSight Namespace


CvsEasyView.Contains Method (CvsSymbolicTag)

[image]

In-Sight SDK
CvsEasyView..::..Contains Method (CvsSymbolicTag)
CvsEasyView Class See Also Send Feedback
Determines whether this EasyView instance contains a symbolic tag.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Contains(
    CvsSymbolicTag tag
)
Visual Basic
Public Function Contains (
    tag As CvsSymbolicTag
) As Boolean

Parameters

tag
Type: Cognex.InSight..::..CvsSymbolicTag
The tag to search for.

Return Value

Type: Boolean
True if an item matches the symbolic tag; otherwise false.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Contains Overload
Cognex.InSight Namespace


CvsEasyView.GetEnumerator Method

[image]

In-Sight SDK
CvsEasyView..::..GetEnumerator Method
CvsEasyView Class See Also Send Feedback
Returns an enumerator that iterates through this EasyView instance.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerator<CvsEasyViewItem> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of CvsEasyViewItem)

Return Value

Type: IEnumerator <(Of <(<' CvsEasyViewItem >)>)>
An enumerator that iterates through this EasyView instance.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyView.IndexOf Method

[image] [image]

In-Sight SDK
CvsEasyView..::..IndexOf Method
CvsEasyView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(CvsEasyViewItem) | Returns the zero-based index of the first occurrence of the specified item.
Public method | IndexOf(CvsSymbolicTag) | Returns the zero-based index of the first occurrence of the item matching the symbolic tag.
Public method | IndexOf(CvsEasyViewItem, Int32) | Returns the zero-based index of the first occurrence of the specified item.
Public method | IndexOf(CvsSymbolicTag, Int32) | Returns the zero-based index of the first occurrence of the item matching the symbolic tag.
Public method | IndexOf(CvsEasyViewItem, Int32, Int32) | Returns the zero-based index of the first occurrence of the specified item.
Public method | IndexOf(CvsSymbolicTag, Int32, Int32) | Returns the zero-based index of the first occurrence of the item matching the symbolic tag.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyView.IndexOf Method (CvsEasyViewItem)

[image]

In-Sight SDK
CvsEasyView..::..IndexOf Method (CvsEasyViewItem)
CvsEasyView Class See Also Send Feedback
Returns the zero-based index of the first occurrence of the specified item.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IndexOf(
    CvsEasyViewItem item
)
Visual Basic
Public Function IndexOf (
    item As CvsEasyViewItem
) As Integer

Parameters

item
Type: Cognex.InSight..::..CvsEasyViewItem
The item to search for.

Return Value

Type: Int32
The zero-based index of the item if found; otherwise a value less than 0.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
IndexOf Overload
Cognex.InSight Namespace


CvsEasyView.IndexOf Method (CvsSymbolicTag)

[image]

In-Sight SDK
CvsEasyView..::..IndexOf Method (CvsSymbolicTag)
CvsEasyView Class See Also Send Feedback
Returns the zero-based index of the first occurrence of the item matching the symbolic tag.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IndexOf(
    CvsSymbolicTag tag
)
Visual Basic
Public Function IndexOf (
    tag As CvsSymbolicTag
) As Integer

Parameters

tag
Type: Cognex.InSight..::..CvsSymbolicTag
The tag to search for.

Return Value

Type: Int32
The zero-based index of the item if found; otherwise a value less than 0.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
IndexOf Overload
Cognex.InSight Namespace


CvsEasyView.IndexOf Method (CvsEasyViewItem, Int32)

[image]

In-Sight SDK
CvsEasyView..::..IndexOf Method (CvsEasyViewItem, Int32)
CvsEasyView Class See Also Send Feedback
Returns the zero-based index of the first occurrence of the specified item.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IndexOf(
    CvsEasyViewItem item,
    int index
)
Visual Basic
Public Function IndexOf (
    item As CvsEasyViewItem,
    index As Integer
) As Integer

Parameters

item
Type: Cognex.InSight..::..CvsEasyViewItem
The item to search for.
index
Type: System..::..Int32
The index to start searching from.

Return Value

Type: Int32
The zero-based index of the item if found; otherwise a value less than 0.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
IndexOf Overload
Cognex.InSight Namespace


CvsEasyView.IndexOf Method (CvsSymbolicTag, Int32)

[image]

In-Sight SDK
CvsEasyView..::..IndexOf Method (CvsSymbolicTag, Int32)
CvsEasyView Class See Also Send Feedback
Returns the zero-based index of the first occurrence of the item matching the symbolic tag.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IndexOf(
    CvsSymbolicTag tag,
    int index
)
Visual Basic
Public Function IndexOf (
    tag As CvsSymbolicTag,
    index As Integer
) As Integer

Parameters

tag
Type: Cognex.InSight..::..CvsSymbolicTag
The tag to search for.
index
Type: System..::..Int32
The index to start searching from.

Return Value

Type: Int32
The zero-based index of the item if found; otherwise a value less than 0.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
IndexOf Overload
Cognex.InSight Namespace


CvsEasyView.IndexOf Method (CvsEasyViewItem, Int32, Int32)

[image]

In-Sight SDK
CvsEasyView..::..IndexOf Method (CvsEasyViewItem, Int32, Int32)
CvsEasyView Class See Also Send Feedback
Returns the zero-based index of the first occurrence of the specified item.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IndexOf(
    CvsEasyViewItem item,
    int index,
    int count
)
Visual Basic
Public Function IndexOf (
    item As CvsEasyViewItem,
    index As Integer,
    count As Integer
) As Integer

Parameters

item
Type: Cognex.InSight..::..CvsEasyViewItem
The item to search for.
index
Type: System..::..Int32
The index to start searching from.
count
Type: System..::..Int32
The number of items to search over before stopping.

Return Value

Type: Int32
The zero-based index of the item if found; otherwise a value less than 0.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
IndexOf Overload
Cognex.InSight Namespace


CvsEasyView.IndexOf Method (CvsSymbolicTag, Int32, Int32)

[image]

In-Sight SDK
CvsEasyView..::..IndexOf Method (CvsSymbolicTag, Int32, Int32)
CvsEasyView Class See Also Send Feedback
Returns the zero-based index of the first occurrence of the item matching the symbolic tag.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IndexOf(
    CvsSymbolicTag tag,
    int index,
    int count
)
Visual Basic
Public Function IndexOf (
    tag As CvsSymbolicTag,
    index As Integer,
    count As Integer
) As Integer

Parameters

tag
Type: Cognex.InSight..::..CvsSymbolicTag
The tag to search for.
index
Type: System..::..Int32
The index to start searching from.
count
Type: System..::..Int32
The number of items to search over before stopping.

Return Value

Type: Int32
The zero-based index of the item if found; otherwise a value less than 0.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
IndexOf Overload
Cognex.InSight Namespace


CvsEasyView.Insert Method

[image] [image]

In-Sight SDK
CvsEasyView..::..Insert Method
CvsEasyView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Insert(CvsSymbolicTag, Int32) | Inserts a new EasyView item bound to a symbolic tag at the specified index.
Public method | Insert(CvsSymbolicTag, String, Int32) | Inserts a new EasyView item bound to a symbolic tag at the specified index with the specified caption.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyView.Insert Method (CvsSymbolicTag, Int32)

[image]

In-Sight SDK
CvsEasyView..::..Insert Method (CvsSymbolicTag, Int32)
CvsEasyView Class See Also Send Feedback
Inserts a new EasyView item bound to a symbolic tag at the specified index.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Insert(
    CvsSymbolicTag tag,
    int index
)
Visual Basic
Public Sub Insert (
    tag As CvsSymbolicTag,
    index As Integer
)

Parameters

tag
Type: Cognex.InSight..::..CvsSymbolicTag
The tag to bind to.
index
Type: System..::..Int32
The index to insert the item.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Insert Overload
Cognex.InSight Namespace


CvsEasyView.Insert Method (CvsSymbolicTag, String, Int32)

[image]

In-Sight SDK
CvsEasyView..::..Insert Method (CvsSymbolicTag, String, Int32)
CvsEasyView Class See Also Send Feedback
Inserts a new EasyView item bound to a symbolic tag at the specified index with the specified caption.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Insert(
    CvsSymbolicTag tag,
    string caption,
    int index
)
Visual Basic
Public Sub Insert (
    tag As CvsSymbolicTag,
    caption As String,
    index As Integer
)

Parameters

tag
Type: Cognex.InSight..::..CvsSymbolicTag
The tag to bind to.
caption
Type: System..::..String
The caption to give the item. If this is null or empty, then the name of the tag is used as the caption.
index
Type: System..::..Int32
The index to insert the item.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The symbolic tag is not allowed.
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Insert Overload
Cognex.InSight Namespace


CvsEasyView.InsertLabel Method

[image] [image]

In-Sight SDK
CvsEasyView..::..InsertLabel Method
CvsEasyView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertLabel(Int32) | Inserts a new EasyView label at the specified index with the specified caption.
Public method | InsertLabel(String, Int32) | Inserts a new EasyView label at the specified index with the specified caption.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyView.InsertLabel Method (Int32)

[image]

In-Sight SDK
CvsEasyView..::..InsertLabel Method (Int32)
CvsEasyView Class See Also Send Feedback
Inserts a new EasyView label at the specified index with the specified caption.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void InsertLabel(
    int index
)
Visual Basic
Public Sub InsertLabel (
    index As Integer
)

Parameters

index
Type: System..::..Int32
The index to insert the item.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
InsertLabel Overload
Cognex.InSight Namespace


CvsEasyView.InsertLabel Method (String, Int32)

[image]

In-Sight SDK
CvsEasyView..::..InsertLabel Method (String, Int32)
CvsEasyView Class See Also Send Feedback
Inserts a new EasyView label at the specified index with the specified caption.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void InsertLabel(
    string caption,
    int index
)
Visual Basic
Public Sub InsertLabel (
    caption As String,
    index As Integer
)

Parameters

caption
Type: System..::..String
The caption to give the item. If this is null or empty, then the name of the tag is used as the caption.
index
Type: System..::..Int32
The index to insert the item.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
InsertLabel Overload
Cognex.InSight Namespace


CvsEasyView.IsTagAllowedInEasyView Method

[image]

In-Sight SDK
CvsEasyView..::..IsTagAllowedInEasyView Method
CvsEasyView Class See Also Send Feedback
Determines if a symbolic tag is allowed to be in an EasyView.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsTagAllowedInEasyView(
    CvsSymbolicTag tag
)
Visual Basic
Public Function IsTagAllowedInEasyView (
    tag As CvsSymbolicTag
) As Boolean

Parameters

tag
Type: Cognex.InSight..::..CvsSymbolicTag
The tag to validate.

Return Value

Type: Boolean
True if the tag is allowed in EasyView; otherwise false.

Remarks

This should be called before attempting to add or insert items to avoid any exceptions.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyView.Remove Method

[image] [image]

In-Sight SDK
CvsEasyView..::..Remove Method
CvsEasyView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(CvsEasyViewItem) | Removes the specified item from this EasyView instance.
Public method | Remove(CvsSymbolicTag) | Removes the specified tag from this EasyView instance.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyView.Remove Method (CvsEasyViewItem)

[image]

In-Sight SDK
CvsEasyView..::..Remove Method (CvsEasyViewItem)
CvsEasyView Class See Also Send Feedback
Removes the specified item from this EasyView instance.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Remove(
    CvsEasyViewItem item
)
Visual Basic
Public Function Remove (
    item As CvsEasyViewItem
) As Boolean

Parameters

item
Type: Cognex.InSight..::..CvsEasyViewItem
The item to remove.

Return Value

Type: Boolean
True if the item was removed, otherwise false.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Remove Overload
Cognex.InSight Namespace


CvsEasyView.Remove Method (CvsSymbolicTag)

[image]

In-Sight SDK
CvsEasyView..::..Remove Method (CvsSymbolicTag)
CvsEasyView Class See Also Send Feedback
Removes the specified tag from this EasyView instance.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Remove(
    CvsSymbolicTag tag
)
Visual Basic
Public Function Remove (
    tag As CvsSymbolicTag
) As Boolean

Parameters

tag
Type: Cognex.InSight..::..CvsSymbolicTag
The symbolic tag to remove.

Return Value

Type: Boolean
True if the item was removed; otherwise false.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Remove Overload
Cognex.InSight Namespace


CvsEasyView.RemoveAt Method

[image]

In-Sight SDK
CvsEasyView..::..RemoveAt Method
CvsEasyView Class See Also Send Feedback
Removes the element at the specified index from this EasyView instance.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: System..::..Int32
The index to remove.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyView Properties

[image] [image]

In-Sight SDK
CvsEasyView Properties
CvsEasyView Class See Also Send Feedback

The CvsEasyView type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of items contained within the EasyView.
Public property | Item | Gets or sets an EasyView item at the specified index.

See Also

CvsEasyView Class
Cognex.InSight Namespace


CvsEasyView.Count Property

[image]

In-Sight SDK
CvsEasyView..::..Count Property
CvsEasyView Class See Also Send Feedback
Gets the number of items contained within the EasyView.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyView.Item Property

[image]

In-Sight SDK
CvsEasyView..::..Item Property
CvsEasyView Class See Also Send Feedback
Gets or sets an EasyView item at the specified index.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEasyViewItem this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item (
    index As Integer
) As CvsEasyViewItem
    Get
    Set

Parameters

index
Type: System..::..Int32
The index to retrieve the item for.

Return Value

Type: CvsEasyViewItem
The EasyView item at the specifed index.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsEasyView Class
CvsEasyView..::..CvsEasyView Members
Cognex.InSight Namespace


CvsEasyViewItem Class

[image]

In-Sight SDK
CvsEasyViewItem Class
Members See Also Send Feedback
Encapsulates the data that defines an EasyView item.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsEasyViewItem
Visual Basic
<SerializableAttribute>
Public Class CvsEasyViewItem

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsEasyViewItem

See Also

CvsEasyViewItem..::..CvsEasyViewItem Members
Cognex.InSight Namespace


CvsEasyViewItem Members

[image] [image]

In-Sight SDK
CvsEasyViewItem Members
CvsEasyViewItem Class Constructors Methods Properties See Also Send Feedback

The CvsEasyViewItem type exposes the following members.

Constructors

 | Name | Description
Public method | CvsEasyViewItem | Constructs a new instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code based on the cell location. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Caption | Gets or sets the caption of the view item.
Public property | DataType | Gets the data type of the view item.
Public property | Editable | Gets or sets a flag that tells whether this item will be editable (false read-only) or not (true read-write).
Public property | IsValid | Gets a flag the designates whether or not the item is valid.
Public property | ItemType | Gets or sets the type of the view item.
Public property | Location | Gets the cell location of the view item.
Public property | Name | Gets the name of the view item.
Public property | ReadOnly | Gets or sets a flag that designates whether or not the cell associated with this item is read-write or read-only.

See Also

CvsEasyViewItem Class
Cognex.InSight Namespace


CvsEasyViewItem Constructor

[image]

In-Sight SDK
CvsEasyViewItem Constructor
CvsEasyViewItem Class See Also Send Feedback
Constructs a new instance.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEasyViewItem(
    string name,
    string caption,
    string dataType,
    bool editable,
    CvsEasyViewItemType type,
    CvsCellLocation location,
    bool readOnly
)
Visual Basic
Public Sub New (
    name As String,
    caption As String,
    dataType As String,
    editable As Boolean,
    type As CvsEasyViewItemType,
    location As CvsCellLocation,
    readOnly As Boolean
)

Parameters

name
Type: System..::..String
The name that identifies view item.
caption
Type: System..::..String
The caption.
dataType
Type: System..::..String
A string that represents the data type of the view item.
editable
Type: System..::..Boolean
A flag that tells whether this item will be editable (false read-only) or not (true read-write).
type
Type: Cognex.InSight..::..CvsEasyViewItemType
The data type of the view item.
location
Type: Cognex.InSight..::..CvsCellLocation
The cell location of the view item.
readOnly
Type: System..::..Boolean
A flag that designates whether or not the cell associated with this item is read-write or read-only.

See Also

CvsEasyViewItem Class
CvsEasyViewItem..::..CvsEasyViewItem Members
Cognex.InSight Namespace


CvsEasyViewItem Methods

[image] [image]

In-Sight SDK
CvsEasyViewItem Methods
CvsEasyViewItem Class See Also Send Feedback

The CvsEasyViewItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code based on the cell location. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

CvsEasyViewItem Class
Cognex.InSight Namespace


CvsEasyViewItem.GetHashCode Method

[image]

In-Sight SDK
CvsEasyViewItem..::..GetHashCode Method
CvsEasyViewItem Class See Also Send Feedback
Gets a hash code based on the cell location.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
The hashcode.

See Also

CvsEasyViewItem Class
CvsEasyViewItem..::..CvsEasyViewItem Members
Cognex.InSight Namespace


CvsEasyViewItem.ToString Method

[image]

In-Sight SDK
CvsEasyViewItem..::..ToString Method
CvsEasyViewItem Class See Also Send Feedback

[Missing <summary> documentation for "M:Cognex.InSight.CvsEasyViewItem.ToString"]

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

[Missing <returns> documentation for "M:Cognex.InSight.CvsEasyViewItem.ToString"]

See Also

CvsEasyViewItem Class
CvsEasyViewItem..::..CvsEasyViewItem Members
Cognex.InSight Namespace


CvsEasyViewItem Properties

[image] [image]

In-Sight SDK
CvsEasyViewItem Properties
CvsEasyViewItem Class See Also Send Feedback

The CvsEasyViewItem type exposes the following members.

Properties

 | Name | Description
Public property | Caption | Gets or sets the caption of the view item.
Public property | DataType | Gets the data type of the view item.
Public property | Editable | Gets or sets a flag that tells whether this item will be editable (false read-only) or not (true read-write).
Public property | IsValid | Gets a flag the designates whether or not the item is valid.
Public property | ItemType | Gets or sets the type of the view item.
Public property | Location | Gets the cell location of the view item.
Public property | Name | Gets the name of the view item.
Public property | ReadOnly | Gets or sets a flag that designates whether or not the cell associated with this item is read-write or read-only.

See Also

CvsEasyViewItem Class
Cognex.InSight Namespace


CvsEasyViewItem.Caption Property

[image]

In-Sight SDK
CvsEasyViewItem..::..Caption Property
CvsEasyViewItem Class See Also Send Feedback
Gets or sets the caption of the view item.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Caption { get; set; }
Visual Basic
Public Property Caption As String
    Get
    Set

Property Value

Type: String

See Also

CvsEasyViewItem Class
CvsEasyViewItem..::..CvsEasyViewItem Members
Cognex.InSight Namespace


CvsEasyViewItem.DataType Property

[image]

In-Sight SDK
CvsEasyViewItem..::..DataType Property
CvsEasyViewItem Class See Also Send Feedback
Gets the data type of the view item.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string DataType { get; }
Visual Basic
Public ReadOnly Property DataType As String
    Get

Property Value

Type: String

See Also

CvsEasyViewItem Class
CvsEasyViewItem..::..CvsEasyViewItem Members
Cognex.InSight Namespace


CvsEasyViewItem.Editable Property

[image]

In-Sight SDK
CvsEasyViewItem..::..Editable Property
CvsEasyViewItem Class See Also Send Feedback
Gets or sets a flag that tells whether this item will be editable (false read-only) or not (true read-write).

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Editable { get; set; }
Visual Basic
Public Property Editable As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsEasyViewItem Class
CvsEasyViewItem..::..CvsEasyViewItem Members
Cognex.InSight Namespace


CvsEasyViewItem.IsValid Property

[image]

In-Sight SDK
CvsEasyViewItem..::..IsValid Property
CvsEasyViewItem Class See Also Send Feedback
Gets a flag the designates whether or not the item is valid.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Property Value

Type: Boolean
True, if the item is a label or the item is not a label and it's cell location is valid. False, otherwise.

See Also

CvsEasyViewItem Class
CvsEasyViewItem..::..CvsEasyViewItem Members
Cognex.InSight Namespace


CvsEasyViewItem.ItemType Property

[image]

In-Sight SDK
CvsEasyViewItem..::..ItemType Property
CvsEasyViewItem Class See Also Send Feedback
Gets or sets the type of the view item.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEasyViewItemType ItemType { get; set; }
Visual Basic
Public Property ItemType As CvsEasyViewItemType
    Get
    Set

Property Value

Type: CvsEasyViewItemType

See Also

CvsEasyViewItem Class
CvsEasyViewItem..::..CvsEasyViewItem Members
Cognex.InSight Namespace


CvsEasyViewItem.Location Property

[image]

In-Sight SDK
CvsEasyViewItem..::..Location Property
CvsEasyViewItem Class See Also Send Feedback
Gets the cell location of the view item.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation Location { get; }
Visual Basic
Public ReadOnly Property Location As CvsCellLocation
    Get

Property Value

Type: CvsCellLocation

See Also

CvsEasyViewItem Class
CvsEasyViewItem..::..CvsEasyViewItem Members
Cognex.InSight Namespace


CvsEasyViewItem.Name Property

[image]

In-Sight SDK
CvsEasyViewItem..::..Name Property
CvsEasyViewItem Class See Also Send Feedback
Gets the name of the view item.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

See Also

CvsEasyViewItem Class
CvsEasyViewItem..::..CvsEasyViewItem Members
Cognex.InSight Namespace


CvsEasyViewItem.ReadOnly Property

[image]

In-Sight SDK
CvsEasyViewItem..::..ReadOnly Property
CvsEasyViewItem Class See Also Send Feedback
Gets or sets a flag that designates whether or not the cell associated with this item is read-write or read-only.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ReadOnly { get; set; }
Visual Basic
Public Property ReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsEasyViewItem Class
CvsEasyViewItem..::..CvsEasyViewItem Members
Cognex.InSight Namespace


CvsEasyViewItemType Enumeration

[image]

In-Sight SDK
CvsEasyViewItemType Enumeration
See Also Send Feedback
Defines the types of EasyView entries.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public enum CvsEasyViewItemType
Visual Basic
<SerializableAttribute>
Public Enumeration CvsEasyViewItemType

Members

Member name | Value | Description
Standard | 0 | The item is rendered as a property display or control.
Label | 1 | The item displays a label.

See Also

Cognex.InSight Namespace


CvsException Class

[image]

In-Sight SDK
CvsException Class
Members See Also Send Feedback
Provides a base class for all exceptions generated by In-Sight SDK components.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public abstract class CvsException : Exception
Visual Basic
<SerializableAttribute>
Public MustInherit Class CvsException
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsCellProtectionException
Cognex.InSight..::..CvsCommunicationException
Cognex.InSight..::..CvsExpressionException
Cognex.InSight..::..CvsFileNotFoundException
Cognex.InSight..::..CvsFileOperationFailedException
Cognex.InSight..::..CvsIncompleteImageException
Cognex.InSight..::..CvsInvalidInsertException
Cognex.InSight..::..CvsInvalidLogonException
Cognex.InSight..::..CvsInvalidTimeException
Cognex.InSight..::..CvsLiveAcquisitionException
Cognex.InSight..::..CvsNotLicensedException
Cognex.InSight..::..CvsNotOfflineException
Cognex.InSight..::..CvsSensorAlreadyConnectedException

See Also

CvsException..::..CvsException Members
Cognex.InSight Namespace


CvsException Members

[image] [image]

In-Sight SDK
CvsException Members
CvsException Class Methods Properties Events See Also Send Feedback

The CvsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

CvsException Class
Cognex.InSight Namespace


CvsException Methods

[image] [image]

In-Sight SDK
CvsException Methods
CvsException Class See Also Send Feedback

The CvsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsException Class
Cognex.InSight Namespace


CvsException Properties

[image] [image]

In-Sight SDK
CvsException Properties
CvsException Class See Also Send Feedback

The CvsException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsException Class
Cognex.InSight Namespace


CvsException.ErrorNumber Property

[image]

In-Sight SDK
CvsException..::..ErrorNumber Property
CvsException Class See Also Send Feedback
Gets the error number (HResult) associated with the exception.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightError ErrorNumber { get; }
Visual Basic
Public ReadOnly Property ErrorNumber As CvsInSightError
    Get

Property Value

Type: CvsInSightError

See Also

CvsException Class
CvsException..::..CvsException Members
Cognex.InSight Namespace


CvsException Events

[image] [image]

In-Sight SDK
CvsException Events
CvsException Class See Also Send Feedback

The CvsException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

CvsException Class
Cognex.InSight Namespace


CvsExpressionException Class

[image]

In-Sight SDK
CvsExpressionException Class
Members See Also Send Feedback
The exception that is thrown when an error occurs setting a spreadsheet expression.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsExpressionException : CvsException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsExpressionException
    Inherits CvsException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsExpressionException

See Also

CvsExpressionException..::..CvsExpressionException Members
Cognex.InSight Namespace
CvsInSightErrorExpressionException


CvsExpressionException Members

[image] [image]

In-Sight SDK
CvsExpressionException Members
CvsExpressionException Class Methods Properties See Also Send Feedback

The CvsExpressionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsExpressionException Class
Cognex.InSight Namespace


CvsExpressionException Methods

[image] [image]

In-Sight SDK
CvsExpressionException Methods
CvsExpressionException Class See Also Send Feedback

The CvsExpressionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsExpressionException Class
Cognex.InSight Namespace


CvsExpressionException Properties

[image] [image]

In-Sight SDK
CvsExpressionException Properties
CvsExpressionException Class See Also Send Feedback

The CvsExpressionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsExpressionException Class
Cognex.InSight Namespace


CvsFeatureLicense Class

[image]

In-Sight SDK
CvsFeatureLicense Class
Members See Also Send Feedback
Performs license checking for In-Sight SDK features.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public sealed class CvsFeatureLicense
Visual Basic
Public NotInheritable Class CvsFeatureLicense

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsFeatureLicense

See Also

CvsFeatureLicense..::..CvsFeatureLicense Members
Cognex.InSight Namespace


CvsFeatureLicense Members

[image] [image]

In-Sight SDK
CvsFeatureLicense Members
CvsFeatureLicense Class Methods Properties See Also Send Feedback

The CvsFeatureLicense type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmulatorPlaybackLicensed | Returns true if emulator image playback is licensed.
 | IssueUnlockChallenge | Initiates the challenge-response mechanism for unlocking SDK features.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unlock | Completes the challenge-response sequences. If the expected response is provided, then the SDK features specified in the license file will be unlocked.

Properties

Name | Description
LicenseFile | Get the location of the license file.
LicenseFilePath | Gets or sets the directory in which to look for the Feature License file.

See Also

CvsFeatureLicense Class
Cognex.InSight Namespace


CvsFeatureLicense Methods

[image] [image]

In-Sight SDK
CvsFeatureLicense Methods
CvsFeatureLicense Class See Also Send Feedback

The CvsFeatureLicense type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmulatorPlaybackLicensed | Returns true if emulator image playback is licensed.
 | IssueUnlockChallenge | Initiates the challenge-response mechanism for unlocking SDK features.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unlock | Completes the challenge-response sequences. If the expected response is provided, then the SDK features specified in the license file will be unlocked.

See Also

CvsFeatureLicense Class
Cognex.InSight Namespace


CvsFeatureLicense.IsEmulatorPlaybackLicensed Method

[image]

In-Sight SDK
CvsFeatureLicense..::..IsEmulatorPlaybackLicensed Method
CvsFeatureLicense Class See Also Send Feedback
Returns true if emulator image playback is licensed.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsEmulatorPlaybackLicensed()
Visual Basic
Public Shared Function IsEmulatorPlaybackLicensed As Boolean

Return Value

Type: Boolean
True if emulator image playback is licensed.

See Also

CvsFeatureLicense Class
CvsFeatureLicense..::..CvsFeatureLicense Members
Cognex.InSight Namespace


CvsFeatureLicense.IssueUnlockChallenge Method

[image]

In-Sight SDK
CvsFeatureLicense..::..IssueUnlockChallenge Method
CvsFeatureLicense Class See Also Send Feedback
Initiates the challenge-response mechanism for unlocking SDK features.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static byte[] IssueUnlockChallenge()
Visual Basic
Public Shared Function IssueUnlockChallenge As Byte()

Return Value

Type: array< Byte >[]()[][]
A collection of random bytes which must be used to generate the challenge response.

See Also

CvsFeatureLicense Class
CvsFeatureLicense..::..CvsFeatureLicense Members
Cognex.InSight Namespace


CvsFeatureLicense.Unlock Method

[image]

In-Sight SDK
CvsFeatureLicense..::..Unlock Method
CvsFeatureLicense Class See Also Send Feedback
Completes the challenge-response sequences. If the expected response is provided, then the SDK features specified in the license file will be unlocked.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool Unlock(
    byte[] response
)
Visual Basic
Public Shared Function Unlock (
    response As Byte()
) As Boolean

Parameters

response
Type: array< System..::..Byte >[]()[][]
The response generated from the challenged issued by IssueUnlockChallenge()()()().

Return Value

Type: Boolean
True if the expected response is given and the application ID is present in the license file. Otherwise, false is returned.

See Also

CvsFeatureLicense Class
CvsFeatureLicense..::..CvsFeatureLicense Members
Cognex.InSight Namespace


CvsFeatureLicense Properties

[image] [image]

In-Sight SDK
CvsFeatureLicense Properties
CvsFeatureLicense Class See Also Send Feedback

The CvsFeatureLicense type exposes the following members.

Properties

Name | Description
LicenseFile | Get the location of the license file.
LicenseFilePath | Gets or sets the directory in which to look for the Feature License file.

See Also

CvsFeatureLicense Class
Cognex.InSight Namespace


CvsFeatureLicense.LicenseFile Property

[image]

In-Sight SDK
CvsFeatureLicense..::..LicenseFile Property
CvsFeatureLicense Class See Also Send Feedback
Get the location of the license file.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static string LicenseFile { get; }
Visual Basic
Public Shared ReadOnly Property LicenseFile As String
    Get

Property Value

Type: String

See Also

CvsFeatureLicense Class
CvsFeatureLicense..::..CvsFeatureLicense Members
Cognex.InSight Namespace


CvsFeatureLicense.LicenseFilePath Property

[image]

In-Sight SDK
CvsFeatureLicense..::..LicenseFilePath Property
CvsFeatureLicense Class See Also Send Feedback
Gets or sets the directory in which to look for the Feature License file.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static string LicenseFilePath { get; set; }
Visual Basic
Public Shared Property LicenseFilePath As String
    Get
    Set

Property Value

Type: String

See Also

CvsFeatureLicense Class
CvsFeatureLicense..::..CvsFeatureLicense Members
Cognex.InSight Namespace


CvsFile Class

[image]

In-Sight SDK
CvsFile Class
Members See Also Send Feedback
Holds information related to a file or directory located on an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsFile : IComparable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsFile
    Implements IComparable

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsFile

See Also

CvsFile..::..CvsFile Members
Cognex.InSight Namespace


CvsFile Members

[image] [image]

In-Sight SDK
CvsFile Members
CvsFile Class Methods Properties See Also Send Feedback

The CvsFile type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the Name property of the current instance with another object of the same type.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsDirectory | Gets the flag that designates whether this object represents a file or directory.
Public property | Name | Gets the name of the file or directory.
Public property | Size | Gets the size of the file in bytes.

See Also

CvsFile Class
Cognex.InSight Namespace


CvsFile Methods

[image] [image]

In-Sight SDK
CvsFile Methods
CvsFile Class See Also Send Feedback

The CvsFile type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the Name property of the current instance with another object of the same type.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsFile Class
Cognex.InSight Namespace


CvsFile.CompareTo Method

[image]

In-Sight SDK
CvsFile..::..CompareTo Method
CvsFile Class See Also Send Feedback
Compares the Name property of the current instance with another object of the same type.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo (
    obj As Object
) As Integer

Parameters

obj
Type: System..::..Object
An object to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands. See CompareTo(Object).

Implements

IComparable..::..CompareTo(Object)

See Also

CvsFile Class
CvsFile..::..CvsFile Members
Cognex.InSight Namespace


CvsFile Properties

[image] [image]

In-Sight SDK
CvsFile Properties
CvsFile Class See Also Send Feedback

The CvsFile type exposes the following members.

Properties

 | Name | Description
Public property | IsDirectory | Gets the flag that designates whether this object represents a file or directory.
Public property | Name | Gets the name of the file or directory.
Public property | Size | Gets the size of the file in bytes.

See Also

CvsFile Class
Cognex.InSight Namespace


CvsFile.IsDirectory Property

[image]

In-Sight SDK
CvsFile..::..IsDirectory Property
CvsFile Class See Also Send Feedback
Gets the flag that designates whether this object represents a file or directory.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsDirectory { get; }
Visual Basic
Public ReadOnly Property IsDirectory As Boolean
    Get

Property Value

Type: Boolean
true if the object represents a directory and false if it represents a file.

See Also

CvsFile Class
CvsFile..::..CvsFile Members
Cognex.InSight Namespace


CvsFile.Name Property

[image]

In-Sight SDK
CvsFile..::..Name Property
CvsFile Class See Also Send Feedback
Gets the name of the file or directory.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

See Also

CvsFile Class
CvsFile..::..CvsFile Members
Cognex.InSight Namespace


CvsFile.Size Property

[image]

In-Sight SDK
CvsFile..::..Size Property
CvsFile Class See Also Send Feedback
Gets the size of the file in bytes.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Size { get; }
Visual Basic
Public ReadOnly Property Size As Integer
    Get

Property Value

Type: Int32
The size of the file in bytes or zero if the object represents a directory.

See Also

CvsFile Class
CvsFile..::..CvsFile Members
Cognex.InSight Namespace


CvsFileCollection Class

[image]

In-Sight SDK
CvsFileCollection Class
Members See Also Send Feedback
Holds a collection of CvsFile objects that represent files and directories that reside on an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsFileCollection : IEnumerable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsFileCollection
    Implements IEnumerable

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsFileCollection

See Also

CvsFileCollection..::..CvsFileCollection Members
Cognex.InSight Namespace


CvsFileCollection Members

[image] [image]

In-Sight SDK
CvsFileCollection Members
CvsFileCollection Class Methods Properties See Also Send Feedback

The CvsFileCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsFileCollection.
Public method | GetFilteredCollection | Gets a collection of files that have the same extension.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of files in the collection.
Public property | Item | Gets the CvsFile object at the specified zero-based index.

See Also

CvsFileCollection Class
Cognex.InSight Namespace


CvsFileCollection Methods

[image] [image]

In-Sight SDK
CvsFileCollection Methods
CvsFileCollection Class See Also Send Feedback

The CvsFileCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsFileCollection.
Public method | GetFilteredCollection | Gets a collection of files that have the same extension.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsFileCollection Class
Cognex.InSight Namespace


CvsFileCollection.GetEnumerator Method

[image]

In-Sight SDK
CvsFileCollection..::..GetEnumerator Method
CvsFileCollection Class See Also Send Feedback
Returns an IEnumerator that can iterate through the CvsFileCollection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CvsFileCollection Class
CvsFileCollection..::..CvsFileCollection Members
Cognex.InSight Namespace


CvsFileCollection.GetFilteredCollection Method

[image]

In-Sight SDK
CvsFileCollection..::..GetFilteredCollection Method
CvsFileCollection Class See Also Send Feedback
Gets a collection of files that have the same extension.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsFileCollection GetFilteredCollection(
    string extension
)
Visual Basic
Public Function GetFilteredCollection (
    extension As String
) As CvsFileCollection

Parameters

extension
Type: System..::..String
The extension for files in the new collection. (e.g. "job", "bmp", etc.)

Return Value

Type: CvsFileCollection
A new collection of files that share the same extension.

Remarks

The comparison is not case sensitive.

The resulting collection is sorted by name.

See Also

CvsFileCollection Class
CvsFileCollection..::..CvsFileCollection Members
Cognex.InSight Namespace


CvsFileCollection Properties

[image] [image]

In-Sight SDK
CvsFileCollection Properties
CvsFileCollection Class See Also Send Feedback

The CvsFileCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of files in the collection.
Public property | Item | Gets the CvsFile object at the specified zero-based index.

See Also

CvsFileCollection Class
Cognex.InSight Namespace


CvsFileCollection.Count Property

[image]

In-Sight SDK
CvsFileCollection..::..Count Property
CvsFileCollection Class See Also Send Feedback
Gets the number of files in the collection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

CvsFileCollection Class
CvsFileCollection..::..CvsFileCollection Members
Cognex.InSight Namespace


CvsFileCollection.Item Property

[image]

In-Sight SDK
CvsFileCollection..::..Item Property
CvsFileCollection Class See Also Send Feedback
Gets the CvsFile object at the specified zero-based index.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsFile this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As CvsFile
    Get

Parameters

index
Type: System..::..Int32
The zero-based index into the collection.

Property Value

Type: CvsFile

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsFileCollection Class
CvsFileCollection..::..CvsFileCollection Members
Cognex.InSight Namespace


CvsFileManager Class

[image]

In-Sight SDK
CvsFileManager Class
Members See Also Send Feedback
Holds the file accessing methods for a connection to an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsFileManager : MarshalByRefObject
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsFileManager
    Inherits MarshalByRefObject

Remarks

This object is returned by the File property of the CvsInSight object.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
Cognex.InSight..::..CvsFileManager

See Also

CvsFileManager..::..CvsFileManager Members
Cognex.InSight Namespace


CvsFileManager Members

[image] [image]

In-Sight SDK
CvsFileManager Members
CvsFileManager Class Methods See Also Send Feedback

The CvsFileManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateNewJob | Creates a new job on the In-Sight sensor as its current job.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetFileFromInSight | Gets a file from the In-Sight sensor.
Public method | GetFileList | Returns the list of files held on the In-Sight sensor.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadJobFile(String) | Loads a job file from the In-Sight file system or remote FTP server as its current job.
Public method | LoadJobFile(String, Boolean) | Loads a job file from the In-Sight file system or remote FTP server as its current job.
Public method | LoadJobFile(String, String, String) | Loads a job file from the remote In-Sight file system or from an FTP server as its current job.
Public method | LoadJobFile(String, String, String, Boolean) | Loads a job file from the remote In-Sight file system or from an FTP server as its current job.
Public method | LoadJobFileLocally | Loads the current job on the In-Sight sensor from the local (PC) file system.
Public method | RemoveFile | Deletes a file from the In-Sight file system.
Public method | RenameFile | Renames a file on the In-Sight file system.
Public method | SaveJobFile(String) | Saves the current job on the In-Sight file system.
Public method | SaveJobFile(String, Boolean) | Saves the current job on the In-Sight file system or an FTP server.
Public method | SaveJobFileLocally | Save the current job on the In-Sight sensor to the local (PC) file system.
Public method | SendFileToInSight | Sends a file to the In-Sight sensor.
Public method | SendImageToInSight(String) | Sends an image file to the In-Sight sensor.
Public method | SendImageToInSight(String, Int32) | Sends an image file to the In-Sight sensor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsFileManager Class
Cognex.InSight Namespace


CvsFileManager Methods

[image] [image]

In-Sight SDK
CvsFileManager Methods
CvsFileManager Class See Also Send Feedback

The CvsFileManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateNewJob | Creates a new job on the In-Sight sensor as its current job.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetFileFromInSight | Gets a file from the In-Sight sensor.
Public method | GetFileList | Returns the list of files held on the In-Sight sensor.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadJobFile(String) | Loads a job file from the In-Sight file system or remote FTP server as its current job.
Public method | LoadJobFile(String, Boolean) | Loads a job file from the In-Sight file system or remote FTP server as its current job.
Public method | LoadJobFile(String, String, String) | Loads a job file from the remote In-Sight file system or from an FTP server as its current job.
Public method | LoadJobFile(String, String, String, Boolean) | Loads a job file from the remote In-Sight file system or from an FTP server as its current job.
Public method | LoadJobFileLocally | Loads the current job on the In-Sight sensor from the local (PC) file system.
Public method | RemoveFile | Deletes a file from the In-Sight file system.
Public method | RenameFile | Renames a file on the In-Sight file system.
Public method | SaveJobFile(String) | Saves the current job on the In-Sight file system.
Public method | SaveJobFile(String, Boolean) | Saves the current job on the In-Sight file system or an FTP server.
Public method | SaveJobFileLocally | Save the current job on the In-Sight sensor to the local (PC) file system.
Public method | SendFileToInSight | Sends a file to the In-Sight sensor.
Public method | SendImageToInSight(String) | Sends an image file to the In-Sight sensor.
Public method | SendImageToInSight(String, Int32) | Sends an image file to the In-Sight sensor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsFileManager Class
Cognex.InSight Namespace


CvsFileManager.CreateNewJob Method

[image]

In-Sight SDK
CvsFileManager..::..CreateNewJob Method
CvsFileManager Class See Also Send Feedback
Creates a new job on the In-Sight sensor as its current job.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void CreateNewJob()
Visual Basic
Public Sub CreateNewJob

Events

Event Type | Reason
CvsInSight..::..InSightMessage | Raised when a warning or error occurs attempting to create the new job. If a CvsInSightDisplay is not used, then a message from the sensor will cause the load operation to fail. Otherwise, the CvsInSightDisplay will display the warning or error in a message box.
CvsInSight..::..LoadCompleted | Raised to signal that a new, empty job has been loaded. The CvsLoadCompletedEventArgs designates the success or failure of the operation.
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNotOfflineException | State is Online.
Cognex.InSight..::..CvsNetworkException | A network error occurred during the creation of the new job.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been explicitly locked, temporarily preventing communication.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
Cognex.InSight Namespace


CvsFileManager.GetFileFromInSight Method

[image]

In-Sight SDK
CvsFileManager..::..GetFileFromInSight Method
CvsFileManager Class See Also Send Feedback
Gets a file from the In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void GetFileFromInSight(
    string localFilename,
    string remoteFilename
)
Visual Basic
Public Sub GetFileFromInSight (
    localFilename As String,
    remoteFilename As String
)

Parameters

localFilename
Type: System..::..String
The file on the local (PC) file system to be created/overwritten.
remoteFilename
Type: System..::..String
The file to be retrieved from the In-Sight sensor.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..UnauthorizedAccessException | Attempting to overwrite a read-only file.
Cognex.InSight..::..CvsFileOperationFailedException | The file cannot be read from the In-Sight.
Cognex.InSight..::..CvsNetworkException | A network error prevents the file from being read. Either an FTP connection could not be established or an error occurred performing the transfer.
Cognex.InSight..::..CvsInvalidLogonException | Unable to log on to the FTP server on the sensor using the username and password specified for the CvsInSight connection. This typically means that the sensor is not configured to give this user FTP access.
Cognex.InSight..::..CvsFileNotFoundException | The remote file is not found.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
Cognex.InSight Namespace


CvsFileManager.GetFileList Method

[image]

In-Sight SDK
CvsFileManager..::..GetFileList Method
CvsFileManager Class See Also Send Feedback
Returns the list of files held on the In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string[] GetFileList()
Visual Basic
Public Function GetFileList As String()

Return Value

Type: array< String >[]()[][]
Returns an array of file names, or a null reference (Nothing in Visual Basic) if the State is CvsInSightState.NotConnected.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | A network error prevents the file list from being read. Either an FTP connection could not be established or an error occurred performing the transfer.
Cognex.InSight..::..CvsInvalidLogonException | Unable to log on to the FTP server on the sensor using the username and password specified for the CvsInSight connection. This typically means that the sensor is not configured to give this user FTP access.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
Cognex.InSight Namespace


CvsFileManager.LoadJobFile Method

[image] [image]

In-Sight SDK
CvsFileManager..::..LoadJobFile Method
CvsFileManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadJobFile(String) | Loads a job file from the In-Sight file system or remote FTP server as its current job.
Public method | LoadJobFile(String, Boolean) | Loads a job file from the In-Sight file system or remote FTP server as its current job.
Public method | LoadJobFile(String, String, String) | Loads a job file from the remote In-Sight file system or from an FTP server as its current job.
Public method | LoadJobFile(String, String, String, Boolean) | Loads a job file from the remote In-Sight file system or from an FTP server as its current job.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
Cognex.InSight Namespace


CvsFileManager.LoadJobFile Method (String)

[image]

In-Sight SDK
CvsFileManager..::..LoadJobFile Method (String)
CvsFileManager Class See Also Send Feedback
Loads a job file from the In-Sight file system or remote FTP server as its current job.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void LoadJobFile(
    string remoteFilename
)
Visual Basic
Public Sub LoadJobFile (
    remoteFilename As String
)

Parameters

remoteFilename
Type: System..::..String
The file to be loaded on the In-Sight sensor. In order to load a file from an FTP server or from another In-Sight sensor, specify a string in this format: ftp://ServerName[:port]/FileName. Port may be omitted if loading from an In-Sight sensor or if using port 21.

Remarks

If an FTP file path is given, this method will attempt to log on to the FTP server using the username and password with which the CvsInSight is connected to the In-Sight sensor. The operation is not complete until the LoadCompleted event is raised.

Events

Event Type | Reason
CvsInSight..::..InSightMessage | Raised when a warning or error occurs attempting to load the file. This will most often occur if the job was created with a different version of firmware, or if the job contains cells that are not valid for the firmware. If a CvsInSightDisplay is not used, then a message from the sensor will cause the load operation to fail. Otherwise, the CvsInSightDisplay will display the warning or error in a message box.
CvsInSight..::..LoadCompleted | Raised when the file load operation is complete. The CvsLoadCompletedEventArgs designates the success or failure of the operation.
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
System..::..ArgumentException | The specified file is not a job file.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNotOfflineException | State is Online.
Cognex.InSight..::..CvsFileNotFoundException | remoteFilename was not found on the remote sensor.
Cognex.InSight..::..CvsNetworkException | The file could not be loaded due to a network error.
Cognex.InSight..::..CvsInSightLockedException | There is already a file operation in progress, or a messagebox open, or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
LoadJobFile Overload
Cognex.InSight Namespace


CvsFileManager.LoadJobFile Method (String, Boolean)

[image]

In-Sight SDK
CvsFileManager..::..LoadJobFile Method (String, Boolean)
CvsFileManager Class See Also Send Feedback
Loads a job file from the In-Sight file system or remote FTP server as its current job.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void LoadJobFile(
    string remoteFilename,
    bool ftpServer
)
Visual Basic
Public Sub LoadJobFile (
    remoteFilename As String,
    ftpServer As Boolean
)

Parameters

remoteFilename
Type: System..::..String
The file to be loaded on the In-Sight sensor. In order to load a file from an FTP server or from another In-Sight sensor, specify a string in this format: ftp://ServerName[:port]/FileName. Port may be omitted if loading from an In-Sight sensor or if using port 21.
ftpServer
Type: System..::..Boolean
true if the file is on an ftp server; false if it on is a sensor.

Remarks

If an FTP file path is given, this method will attempt to log on to the FTP server using the username and password with which the CvsInSight is connected to the In-Sight sensor. The operation is not complete until the LoadCompleted event is raised.

Events

Event Type | Reason
CvsInSight..::..InSightMessage | Raised when a warning or error occurs attempting to load the file. This will most often occur if the job was created with a different version of firmware, or if the job contains cells that are not valid for the firmware. If a CvsInSightDisplay is not used, then a message from the sensor will cause the load operation to fail. Otherwise, the CvsInSightDisplay will display the warning or error in a message box.
CvsInSight..::..LoadCompleted | Raised when the file load operation is complete. The CvsLoadCompletedEventArgs designates the success or failure of the operation.
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
System..::..ArgumentException | The specified file is not a job file.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNotOfflineException | State is Online.
Cognex.InSight..::..CvsFileNotFoundException | remoteFilename was not found on the remote sensor.
Cognex.InSight..::..CvsNetworkException | The file could not be loaded due to a network error.
Cognex.InSight..::..CvsInSightLockedException | There is already a file operation in progress, or a messagebox open, or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
LoadJobFile Overload
Cognex.InSight Namespace


CvsFileManager.LoadJobFile Method (String, String, String)

[image]

In-Sight SDK
CvsFileManager..::..LoadJobFile Method (String, String, String)
CvsFileManager Class See Also Send Feedback
Loads a job file from the remote In-Sight file system or from an FTP server as its current job.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void LoadJobFile(
    string remoteFilename,
    string username,
    string password
)
Visual Basic
Public Sub LoadJobFile (
    remoteFilename As String,
    username As String,
    password As String
)

Parameters

remoteFilename
Type: System..::..String
The file to be loaded on the In-Sight sensor. In order to load a file from an FTP server or from another In-Sight sensor, specify a string in this format: ftp://ServerName[:port]/FileName. Port may be omitted if loading from an In-Sight sensor or if using port 21.
username
Type: System..::..String
The username to log on to the FTP server.
password
Type: System..::..String
The password to log on to the FTP server.

Remarks

The operation is not complete until the LoadCompleted event is raised.

Events

Event Type | Reason
CvsInSight..::..InSightMessage | Raised when a warning or error occurs attempting to load the file. This will most often occur if the job was created with a different version of firmware, or if the job contains cells that are not valid for the firmware. If a CvsInSightDisplay is not used, then a message from the sensor will cause the load operation to fail. Otherwise, the CvsInSightDisplay will display the warning or error in a message box.
CvsInSight..::..LoadCompleted | Raised when the file load operation is complete. The CvsLoadCompletedEventArgs designates the success or failure of the operation.
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
System..::..ArgumentException | The specified file is not a job file.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNotOfflineException | State is Online.
Cognex.InSight..::..CvsNetworkException | The file could not be loaded due to a network error.
Cognex.InSight..::..CvsInSightLockedException | There is already a file operation in progress, or a messagebox open, or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
LoadJobFile Overload
Cognex.InSight Namespace


CvsFileManager.LoadJobFile Method (String, String, String, Boolean)

[image]

In-Sight SDK
CvsFileManager..::..LoadJobFile Method (String, String, String, Boolean)
CvsFileManager Class See Also Send Feedback
Loads a job file from the remote In-Sight file system or from an FTP server as its current job.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void LoadJobFile(
    string remoteFilename,
    string username,
    string password,
    bool ftpServer
)
Visual Basic
Public Sub LoadJobFile (
    remoteFilename As String,
    username As String,
    password As String,
    ftpServer As Boolean
)

Parameters

remoteFilename
Type: System..::..String
The file to be loaded on the In-Sight sensor. In order to load a file from an FTP server or from another In-Sight sensor, specify a string in this format: ftp://ServerName[:port]/FileName. Port may be omitted if loading from an In-Sight sensor or if using port 21.
username
Type: System..::..String
The username to log on to the FTP server.
password
Type: System..::..String
The password to log on to the FTP server.
ftpServer
Type: System..::..Boolean
true if the file is on an ftp server; false if it is on a sensor.

Remarks

The operation is not complete until the LoadCompleted event is raised.

Events

Event Type | Reason
CvsInSight..::..InSightMessage | Raised when a warning or error occurs attempting to load the file. This will most often occur if the job was created with a different version of firmware, or if the job contains cells that are not valid for the firmware. If a CvsInSightDisplay is not used, then a message from the sensor will cause the load operation to fail. Otherwise, the CvsInSightDisplay will display the warning or error in a message box.
CvsInSight..::..LoadCompleted | Raised when the file load operation is complete. The CvsLoadCompletedEventArgs designates the success or failure of the operation.
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
System..::..ArgumentException | The specified file is not a job file.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNotOfflineException | State is Online.
Cognex.InSight..::..CvsNetworkException | The file could not be loaded due to a network error.
Cognex.InSight..::..CvsInSightLockedException | There is already a file operation in progress, or a messagebox open, or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
LoadJobFile Overload
Cognex.InSight Namespace


CvsFileManager.LoadJobFileLocally Method

[image]

In-Sight SDK
CvsFileManager..::..LoadJobFileLocally Method
CvsFileManager Class See Also Send Feedback
Loads the current job on the In-Sight sensor from the local (PC) file system.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void LoadJobFileLocally(
    string localFilename
)
Visual Basic
Public Sub LoadJobFileLocally (
    localFilename As String
)

Parameters

localFilename
Type: System..::..String
The file to read on the local machine.

Remarks

The operation will generate the LoadCompleted event.

The ActiveJobFile property will be empty after this operation.

Events

Event Type | Reason
CvsInSight..::..InSightMessage | Raised when a warning or error occurs attempting to load the job on the sensor. This will most often occur if the job was created with a different version of firmware, or if the job contains cells that are not valid for the firmware. If a CvsInSightDisplay is not used, then a message from the sensor will cause the load operation to fail. Otherwise, the CvsInSightDisplay will display the warning or error in a message box.
CvsInSight..::..LoadCompleted | Raised when the job load operation is complete.
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNotOfflineException | State is Online.
System..::..ArgumentException | The specified file is not a job file.
System.IO..::..FileNotFoundException | The local (PC) file is not found.
Cognex.InSight..::..CvsNetworkException | A network error prevents the file from being sent.
Cognex.InSight..::..CvsInSightLockedException | There is already a file operation in progress, or a messagebox open, or the sensor has been locked while performing another operation, temporarily preventing communication.
Cognex.InSight..::..CvsFileOperationFailedException | The file cannot be saved on the In-Sight sensor.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
Cognex.InSight Namespace


CvsFileManager.RemoveFile Method

[image]

In-Sight SDK
CvsFileManager..::..RemoveFile Method
CvsFileManager Class See Also Send Feedback
Deletes a file from the In-Sight file system.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void RemoveFile(
    string remoteFilename
)
Visual Basic
Public Sub RemoveFile (
    remoteFilename As String
)

Parameters

remoteFilename
Type: System..::..String
The file to be deleted on the In-Sight sensor.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNetworkException | A network error prevents the file from being removed. Either an FTP connection could not be established or an error occurred performing the transfer.
Cognex.InSight..::..CvsFileNotFoundException | The remote file was not found.
Cognex.InSight..::..CvsFileOperationFailedException | The remote file cannot be deleted.
Cognex.InSight..::..CvsInvalidLogonException | Unable to log on to the FTP server on the sensor using the username and password specified for the CvsInSight connection. This typically means that the sensor is not configured to give this user FTP access.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
Cognex.InSight Namespace


CvsFileManager.RenameFile Method

[image]

In-Sight SDK
CvsFileManager..::..RenameFile Method
CvsFileManager Class See Also Send Feedback
Renames a file on the In-Sight file system.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void RenameFile(
    string remoteFilename,
    string newRemoteFilename
)
Visual Basic
Public Sub RenameFile (
    remoteFilename As String,
    newRemoteFilename As String
)

Parameters

remoteFilename
Type: System..::..String
The file to rename on the In-Sight sensor.
newRemoteFilename
Type: System..::..String
The new name of the file on the In-Sight sensor.

Exceptions

Exception | Condition
System..::..ArgumentException | The remote file name is too long or not valid.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNetworkException | A network error prevents the file from being renamed. Either an FTP connection could not be established or an error occurred performing the transfer.
Cognex.InSight..::..CvsFileNotFoundException | The remote file was not found.
Cognex.InSight..::..CvsFileOperationFailedException | The remote file cannot be renamed due insufficient permissions, or the file already exists.
Cognex.InSight..::..CvsInvalidLogonException | Unable to log on to the FTP server on the sensor using the username and password specified for the CvsInSight connection. This typically means that the sensor is not configured to give this user FTP access.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
Cognex.InSight Namespace


CvsFileManager.SaveJobFile Method

[image] [image]

In-Sight SDK
CvsFileManager..::..SaveJobFile Method
CvsFileManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SaveJobFile(String) | Saves the current job on the In-Sight file system.
Public method | SaveJobFile(String, Boolean) | Saves the current job on the In-Sight file system or an FTP server.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
Cognex.InSight Namespace


CvsFileManager.SaveJobFile Method (String)

[image]

In-Sight SDK
CvsFileManager..::..SaveJobFile Method (String)
CvsFileManager Class See Also Send Feedback
Saves the current job on the In-Sight file system.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SaveJobFile(
    string remoteFilename
)
Visual Basic
Public Sub SaveJobFile (
    remoteFilename As String
)

Parameters

remoteFilename
Type: System..::..String
The file to be saved on the In-Sight sensor.

Remarks

The operation is not complete until the SaveCompleted event is raised.

Events

Event Type | Reason
CvsInSight..::..InSightMessage | Raised when a warning or error occurs attempting to save the file. If a CvsInSightDisplay is not used, then a message from the sensor will cause the save operation to fail. Otherwise, the CvsInSightDisplay will display the warning or error in a message box.
CvsInSight..::..SaveCompleted | Raised when the file save operation is complete. The CvsSaveCompletedEventArgs designates the success or failure of the operation.

Exceptions

Exception | Condition
System..::..ArgumentException | The remote file name is too long or not valid.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNotOfflineException | State is Online and the OnlineJobSaveEnabled is not set to true for the current user.
Cognex.InSight..::..CvsNetworkException | The file could not be saved due to a network error.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been explicitly locked, temporarily preventing communication.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
SaveJobFile Overload
Cognex.InSight Namespace


CvsFileManager.SaveJobFile Method (String, Boolean)

[image]

In-Sight SDK
CvsFileManager..::..SaveJobFile Method (String, Boolean)
CvsFileManager Class See Also Send Feedback
Saves the current job on the In-Sight file system or an FTP server.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SaveJobFile(
    string remoteFilename,
    bool ftpServer
)
Visual Basic
Public Sub SaveJobFile (
    remoteFilename As String,
    ftpServer As Boolean
)

Parameters

remoteFilename
Type: System..::..String
The file to be saved.
ftpServer
Type: System..::..Boolean
true if the file is on an ftp server; false if it is on a sensor.

Remarks

The operation is not complete until the SaveCompleted event is raised.

Events

Event Type | Reason
CvsInSight..::..InSightMessage | Raised when a warning or error occurs attempting to save the file. If a CvsInSightDisplay is not used, then a message from the sensor will cause the save operation to fail. Otherwise, the CvsInSightDisplay will display the warning or error in a message box.
CvsInSight..::..SaveCompleted | Raised when the file save operation is complete. The CvsSaveCompletedEventArgs designates the success or failure of the operation.

Exceptions

Exception | Condition
System..::..ArgumentException | The remote file name is too long or not valid.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNotOfflineException | State is Online and the OnlineJobSaveEnabled is not set to true for the current user.
Cognex.InSight..::..CvsNetworkException | The file could not be saved due to a network error.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been explicitly locked, temporarily preventing communication.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
SaveJobFile Overload
Cognex.InSight Namespace


CvsFileManager.SaveJobFileLocally Method

[image]

In-Sight SDK
CvsFileManager..::..SaveJobFileLocally Method
CvsFileManager Class See Also Send Feedback
Save the current job on the In-Sight sensor to the local (PC) file system.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SaveJobFileLocally(
    string localFilename
)
Visual Basic
Public Sub SaveJobFileLocally (
    localFilename As String
)

Parameters

localFilename
Type: System..::..String
The file to write on the local machine.

Remarks

This operation will generate the SaveCompleted event. For sensors with firmware prior to 4.9.1, a temporary file is created to perform this operation. This file is sent to the local (PC) file system, and then it is deleted from the remote (sensor) file system.

The ActiveJobFile property will be empty after this operation.

Events

Event Type | Reason
CvsInSight..::..InSightMessage | Raised when a warning or error occurs attempting to save the file on the sensor file system. If a CvsInSightDisplay is not used, then a message from the sensor will cause the save operation to fail. Otherwise, the CvsInSightDisplay will display the warning or error in a message box.
CvsInSight..::..SaveCompleted | Raised when the temporary file is saved.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNotOfflineException | State is Online and the OnlineJobSaveEnabled is not set to true for the current user.
Cognex.InSight..::..CvsInvalidLogonException | Unable to log on to the FTP server on the sensor using the username and password specified for the CvsInSight connection. This typically means that the sensor is not configured to give this user FTP access.
System..::..UnauthorizedAccessException | Attempting to overwrite a read-only file.
Cognex.InSight..::..CvsFileOperationFailedException | The file cannot be read from the In-Sight.
Cognex.InSight..::..CvsNetworkException | A network error prevents the file from being read. Either an FTP connection could not be established or an error occurred performing the transfer.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been explicitly locked, temporarily preventing communication.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
Cognex.InSight Namespace


CvsFileManager.SendFileToInSight Method

[image]

In-Sight SDK
CvsFileManager..::..SendFileToInSight Method
CvsFileManager Class See Also Send Feedback
Sends a file to the In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SendFileToInSight(
    string localFilename,
    string remoteFilename
)
Visual Basic
Public Sub SendFileToInSight (
    localFilename As String,
    remoteFilename As String
)

Parameters

localFilename
Type: System..::..String
The file on the local (PC) file system to be sent to the In-Sight sensor.
remoteFilename
Type: System..::..String
The file to be created/overwritten on the In-Sight sensor.

Remarks

remoteFilename must be valid to be saved on the In-Sight sensor. IsValidFilename(String) may be used to validate the characters that comprise the filename. Some file extensions, however, are not valid to be saved to an In-Sight sensor.

An In-Sight image file (*.BMP or *.JPG) may be loaded by any In-Sight system for use in Offline spreadsheet job testing and configuration. However, because In-Sight sensors can store only one image, images from any In-Sight system can only be saved to disk on In-Sight PC Host systems or other, non-In-Sight FTP servers on the network.

When an image is loaded to an In-Sight sensor, it becomes the current image (image.bmp), irrespective of the chosen filename; In-Sight sensors do not support image files with arbitrary names.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNetworkException | Unable to complete the FTP connection.
Cognex.InSight..::..CvsInvalidLogonException | Unable to log on to the FTP server on the sensor using the username and password specified for the CvsInSight connection. This typically means that the sensor is not configured to give this user FTP access.
System..::..ArgumentException | The remote file name is too long or not valid.
System.IO..::..FileNotFoundException | The local file is not found.
Cognex.InSight..::..CvsNetworkException | A network error prevents the file from being sent. Either an FTP connection could not be established or an error occurred performing the transfer.
Cognex.InSight..::..CvsFileOperationFailedException | The file cannot be saved on the In-Sight.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
Cognex.InSight Namespace


CvsFileManager.SendImageToInSight Method

[image] [image]

In-Sight SDK
CvsFileManager..::..SendImageToInSight Method
CvsFileManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SendImageToInSight(String) | Sends an image file to the In-Sight sensor.
Public method | SendImageToInSight(String, Int32) | Sends an image file to the In-Sight sensor.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
Cognex.InSight Namespace


CvsFileManager.SendImageToInSight Method (String)

[image]

In-Sight SDK
CvsFileManager..::..SendImageToInSight Method (String)
CvsFileManager Class See Also Send Feedback
Sends an image file to the In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SendImageToInSight(
    string localFilename
)
Visual Basic
Public Sub SendImageToInSight (
    localFilename As String
)

Parameters

localFilename
Type: System..::..String
The image file on the local (PC) file system to be sent to the In-Sight sensor.

Remarks

An In-Sight image file (*.BMP or *.JPG) may be loaded by any In-Sight system for use in Offline spreadsheet job testing and configuration. However, because In-Sight sensors can store only one image, images from any In-Sight system can only be saved to disk on In-Sight PC Host systems or other, non-In-Sight FTP servers on the network.

When an image is loaded to an In-Sight sensor, it becomes the current image (image.bmp), irrespective of the local filename; In-Sight sensors do not support image files with arbitrary names.

Events

Event Type | Reason
CvsInSight..::..LoadCompleted | Raised when the image load operation is complete.

Exceptions

Exception | Condition
System..::..ArgumentException | The file is empty or too large.
System.IO..::..IOException | An I/O exception occurred reading the file on the PC.
System.IO..::..FileNotFoundException | File not found.
System..::..InvalidOperationException | Cannot send an image file to an emulator.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNotOfflineException | State is Online.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
SendImageToInSight Overload
Cognex.InSight Namespace


CvsFileManager.SendImageToInSight Method (String, Int32)

[image]

In-Sight SDK
CvsFileManager..::..SendImageToInSight Method (String, Int32)
CvsFileManager Class See Also Send Feedback
Sends an image file to the In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SendImageToInSight(
    string localFilename,
    int target
)
Visual Basic
Public Sub SendImageToInSight (
    localFilename As String,
    target As Integer
)

Parameters

localFilename
Type: System..::..String
The image file on the local (PC) file system to be sent to the In-Sight sensor.
target
Type: System..::..Int32
Identifies the target within the sensor.

Remarks

An In-Sight image file (*.BMP or *.JPG) may be loaded by any In-Sight system for use in Offline spreadsheet job testing and configuration. However, because In-Sight sensors can store only one image, images from any In-Sight system can only be saved to disk on In-Sight PC Host systems or other, non-In-Sight FTP servers on the network.

When an image is loaded to an In-Sight sensor, it becomes the current image (image.bmp), irrespective of the local filename; In-Sight sensors do not support image files with arbitrary names.

Events

Event Type | Reason
CvsInSight..::..LoadCompleted | Raised when the image load operation is complete.

Exceptions

Exception | Condition
System..::..ArgumentException | The file is empty or too large.
System.IO..::..IOException | An I/O exception occurred reading the file on the PC.
System.IO..::..FileNotFoundException | File not found.
System..::..InvalidOperationException | Cannot send an image file to an emulator.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNotOfflineException | State is Online.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsFileManager Class
CvsFileManager..::..CvsFileManager Members
SendImageToInSight Overload
Cognex.InSight Namespace


CvsFileNotFoundException Class

[image]

In-Sight SDK
CvsFileNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when a file is not found on the sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsFileNotFoundException : CvsException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsFileNotFoundException
    Inherits CvsException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsFileNotFoundException

See Also

CvsFileNotFoundException..::..CvsFileNotFoundException Members
Cognex.InSight Namespace
CvsInSightErrorFileNotFoundException


CvsFileNotFoundException Members

[image] [image]

In-Sight SDK
CvsFileNotFoundException Members
CvsFileNotFoundException Class Methods Properties See Also Send Feedback

The CvsFileNotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsFileNotFoundException Class
Cognex.InSight Namespace


CvsFileNotFoundException Methods

[image] [image]

In-Sight SDK
CvsFileNotFoundException Methods
CvsFileNotFoundException Class See Also Send Feedback

The CvsFileNotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsFileNotFoundException Class
Cognex.InSight Namespace


CvsFileNotFoundException Properties

[image] [image]

In-Sight SDK
CvsFileNotFoundException Properties
CvsFileNotFoundException Class See Also Send Feedback

The CvsFileNotFoundException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsFileNotFoundException Class
Cognex.InSight Namespace


CvsFileOperationFailedException Class

[image]

In-Sight SDK
CvsFileOperationFailedException Class
Members See Also Send Feedback
The exception that is thrown when a file operation fails.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsFileOperationFailedException : CvsException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsFileOperationFailedException
    Inherits CvsException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsFileOperationFailedException

See Also

CvsFileOperationFailedException..::..CvsFileOperationFailedException Members
Cognex.InSight Namespace
CvsInSightErrorFileOperationFailedException


CvsFileOperationFailedException Members

[image] [image]

In-Sight SDK
CvsFileOperationFailedException Members
CvsFileOperationFailedException Class Methods Properties See Also Send Feedback

The CvsFileOperationFailedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsFileOperationFailedException Class
Cognex.InSight Namespace


CvsFileOperationFailedException Methods

[image] [image]

In-Sight SDK
CvsFileOperationFailedException Methods
CvsFileOperationFailedException Class See Also Send Feedback

The CvsFileOperationFailedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsFileOperationFailedException Class
Cognex.InSight Namespace


CvsFileOperationFailedException Properties

[image] [image]

In-Sight SDK
CvsFileOperationFailedException Properties
CvsFileOperationFailedException Class See Also Send Feedback

The CvsFileOperationFailedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsFileOperationFailedException Class
Cognex.InSight Namespace


CvsHmiSettings Class

[image]

In-Sight SDK
CvsHmiSettings Class
Members See Also Send Feedback
Settings for the HTTP HMI server.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public class CvsHmiSettings : IEquatable<CvsHmiSettings>
Visual Basic
Public Class CvsHmiSettings
    Implements IEquatable(Of CvsHmiSettings)

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsHmiSettings

See Also

CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings Members

[image] [image]

In-Sight SDK
CvsHmiSettings Members
CvsHmiSettings Class Constructors Methods Properties See Also Send Feedback

The CvsHmiSettings type exposes the following members.

Constructors

 | Name | Description
Public method | CvsHmiSettings | Initializes properties to their desired defaults.

Methods

 | Name | Description
Public method | Clone | Creates a copy of this object.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(CvsHmiSettings) | Returns true if the value of this object equals the other object.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowAdjustImage | Indicates if the HMI provides rotation and pan and zoom controls.
Public property | AllowFilmstrip | Indicates if the Filmstrip is visible on the HMI.
Public property | AllowFilmstripSaveImage | Indicates if the Filmstrip save button is visible on the HMI.
Public property | AllowFocus | Indicates if the HMI provides focus controls.
Public property | AllowJobLoad | Indicates if the HMI provides job load controls.
Public property | AllowJobSave | Indicates if the HMI provides job save controls.
Public property | AllowLocalStorage | Indicates if local storage is enabled.
Public property | AllowSoftOnline | Indicates if the HMI provides a soft online option.
Public property | AllowSwitchView | Indicates if the HMI provides a option for switching views.
Public property | AllowTrigger | Indicates if the HMI provides a trigger command.
Public property | DefaultColorScheme | Gets and sets the default color scheme.
Public property | EnableHttpImages | Indicates if images are allowed to use HTTP when the HMI is in Secure Mode.
Public property | ImageResolution | The desired image resolution (for all images).
Public property | InactivityTimeout | The inactivity timeout, in minutes.
Public property | LedStyle | Indicates the style of the icons displayed in the filmstrip.
Public property | MaximumInactivityTimeout | The maximum value for the InactivityTimeout setting, in minutes.
Public property | MaximumPortNumber | The maximum value for the PortNumber setting.
Public property | MinimumInactivityTimeout | The minimum value for the InactivityTimeout setting, in minutes.
Public property | MinimumPortNumber | The minimum value for the PortNumber setting.
Public property | PortNumber | Gets and sets the http port number.
Public property | SecurePortNumber | Gets and sets the https port number
Public property | ServerEnabled | Enables and disables the http server.

See Also

CvsHmiSettings Class
Cognex.InSight Namespace


CvsHmiSettings Constructor

[image]

In-Sight SDK
CvsHmiSettings Constructor
CvsHmiSettings Class See Also Send Feedback
Initializes properties to their desired defaults.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHmiSettings()
Visual Basic
Public Sub New

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings Methods

[image] [image]

In-Sight SDK
CvsHmiSettings Methods
CvsHmiSettings Class See Also Send Feedback

The CvsHmiSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of this object.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(CvsHmiSettings) | Returns true if the value of this object equals the other object.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsHmiSettings Class
Cognex.InSight Namespace


CvsHmiSettings.Clone Method

[image]

In-Sight SDK
CvsHmiSettings..::..Clone Method
CvsHmiSettings Class See Also Send Feedback
Creates a copy of this object.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHmiSettings Clone()
Visual Basic
Public Function Clone As CvsHmiSettings

Return Value

Type: CvsHmiSettings

[Missing <returns> documentation for "M:Cognex.InSight.CvsHmiSettings.Clone"]

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.Equals Method

[image] [image]

In-Sight SDK
CvsHmiSettings..::..Equals Method
CvsHmiSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(CvsHmiSettings) | Returns true if the value of this object equals the other object.

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.Equals Method (CvsHmiSettings)

[image]

In-Sight SDK
CvsHmiSettings..::..Equals Method (CvsHmiSettings)
CvsHmiSettings Class See Also Send Feedback
Returns true if the value of this object equals the other object.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Equals(
    CvsHmiSettings other
)
Visual Basic
Public Function Equals (
    other As CvsHmiSettings
) As Boolean

Parameters

other
Type: Cognex.InSight..::..CvsHmiSettings

[Missing <param name="other"/> documentation for "M:Cognex.InSight.CvsHmiSettings.Equals(Cognex.InSight.CvsHmiSettings)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.CvsHmiSettings.Equals(Cognex.InSight.CvsHmiSettings)"]

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Equals Overload
Cognex.InSight Namespace


CvsHmiSettings Properties

[image] [image]

In-Sight SDK
CvsHmiSettings Properties
CvsHmiSettings Class See Also Send Feedback

The CvsHmiSettings type exposes the following members.

Properties

 | Name | Description
Public property | AllowAdjustImage | Indicates if the HMI provides rotation and pan and zoom controls.
Public property | AllowFilmstrip | Indicates if the Filmstrip is visible on the HMI.
Public property | AllowFilmstripSaveImage | Indicates if the Filmstrip save button is visible on the HMI.
Public property | AllowFocus | Indicates if the HMI provides focus controls.
Public property | AllowJobLoad | Indicates if the HMI provides job load controls.
Public property | AllowJobSave | Indicates if the HMI provides job save controls.
Public property | AllowLocalStorage | Indicates if local storage is enabled.
Public property | AllowSoftOnline | Indicates if the HMI provides a soft online option.
Public property | AllowSwitchView | Indicates if the HMI provides a option for switching views.
Public property | AllowTrigger | Indicates if the HMI provides a trigger command.
Public property | DefaultColorScheme | Gets and sets the default color scheme.
Public property | EnableHttpImages | Indicates if images are allowed to use HTTP when the HMI is in Secure Mode.
Public property | ImageResolution | The desired image resolution (for all images).
Public property | InactivityTimeout | The inactivity timeout, in minutes.
Public property | LedStyle | Indicates the style of the icons displayed in the filmstrip.
Public property | MaximumInactivityTimeout | The maximum value for the InactivityTimeout setting, in minutes.
Public property | MaximumPortNumber | The maximum value for the PortNumber setting.
Public property | MinimumInactivityTimeout | The minimum value for the InactivityTimeout setting, in minutes.
Public property | MinimumPortNumber | The minimum value for the PortNumber setting.
Public property | PortNumber | Gets and sets the http port number.
Public property | SecurePortNumber | Gets and sets the https port number
Public property | ServerEnabled | Enables and disables the http server.

See Also

CvsHmiSettings Class
Cognex.InSight Namespace


CvsHmiSettings.AllowAdjustImage Property

[image]

In-Sight SDK
CvsHmiSettings..::..AllowAdjustImage Property
CvsHmiSettings Class See Also Send Feedback
Indicates if the HMI provides rotation and pan and zoom controls.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AllowAdjustImage { get; set; }
Visual Basic
Public Property AllowAdjustImage As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.AllowFilmstrip Property

[image]

In-Sight SDK
CvsHmiSettings..::..AllowFilmstrip Property
CvsHmiSettings Class See Also Send Feedback
Indicates if the Filmstrip is visible on the HMI.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AllowFilmstrip { get; set; }
Visual Basic
Public Property AllowFilmstrip As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.AllowFilmstripSaveImage Property

[image]

In-Sight SDK
CvsHmiSettings..::..AllowFilmstripSaveImage Property
CvsHmiSettings Class See Also Send Feedback
Indicates if the Filmstrip save button is visible on the HMI.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AllowFilmstripSaveImage { get; set; }
Visual Basic
Public Property AllowFilmstripSaveImage As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.AllowFocus Property

[image]

In-Sight SDK
CvsHmiSettings..::..AllowFocus Property
CvsHmiSettings Class See Also Send Feedback
Indicates if the HMI provides focus controls.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AllowFocus { get; set; }
Visual Basic
Public Property AllowFocus As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.AllowJobLoad Property

[image]

In-Sight SDK
CvsHmiSettings..::..AllowJobLoad Property
CvsHmiSettings Class See Also Send Feedback
Indicates if the HMI provides job load controls.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AllowJobLoad { get; set; }
Visual Basic
Public Property AllowJobLoad As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.AllowJobSave Property

[image]

In-Sight SDK
CvsHmiSettings..::..AllowJobSave Property
CvsHmiSettings Class See Also Send Feedback
Indicates if the HMI provides job save controls.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AllowJobSave { get; set; }
Visual Basic
Public Property AllowJobSave As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.AllowLocalStorage Property

[image]

In-Sight SDK
CvsHmiSettings..::..AllowLocalStorage Property
CvsHmiSettings Class See Also Send Feedback
Indicates if local storage is enabled.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AllowLocalStorage { get; set; }
Visual Basic
Public Property AllowLocalStorage As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.AllowSoftOnline Property

[image]

In-Sight SDK
CvsHmiSettings..::..AllowSoftOnline Property
CvsHmiSettings Class See Also Send Feedback
Indicates if the HMI provides a soft online option.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AllowSoftOnline { get; set; }
Visual Basic
Public Property AllowSoftOnline As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.AllowSwitchView Property

[image]

In-Sight SDK
CvsHmiSettings..::..AllowSwitchView Property
CvsHmiSettings Class See Also Send Feedback
Indicates if the HMI provides a option for switching views.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AllowSwitchView { get; set; }
Visual Basic
Public Property AllowSwitchView As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.AllowTrigger Property

[image]

In-Sight SDK
CvsHmiSettings..::..AllowTrigger Property
CvsHmiSettings Class See Also Send Feedback
Indicates if the HMI provides a trigger command.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AllowTrigger { get; set; }
Visual Basic
Public Property AllowTrigger As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.DefaultColorScheme Property

[image]

In-Sight SDK
CvsHmiSettings..::..DefaultColorScheme Property
CvsHmiSettings Class See Also Send Feedback
Gets and sets the default color scheme.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string DefaultColorScheme { get; set; }
Visual Basic
Public Property DefaultColorScheme As String
    Get
    Set

Property Value

Type: String

Remarks

The default color scheme is 'Default'.

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.EnableHttpImages Property

[image]

In-Sight SDK
CvsHmiSettings..::..EnableHttpImages Property
CvsHmiSettings Class See Also Send Feedback
Indicates if images are allowed to use HTTP when the HMI is in Secure Mode.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool EnableHttpImages { get; set; }
Visual Basic
Public Property EnableHttpImages As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.ImageResolution Property

[image]

In-Sight SDK
CvsHmiSettings..::..ImageResolution Property
CvsHmiSettings Class See Also Send Feedback
The desired image resolution (for all images).

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageResolution ImageResolution { get; set; }
Visual Basic
Public Property ImageResolution As CvsImageResolution
    Get
    Set

Property Value

Type: CvsImageResolution

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.InactivityTimeout Property

[image]

In-Sight SDK
CvsHmiSettings..::..InactivityTimeout Property
CvsHmiSettings Class See Also Send Feedback
The inactivity timeout, in minutes.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int InactivityTimeout { get; set; }
Visual Basic
Public Property InactivityTimeout As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

A timeout of zero indicates that the inactivity timeout is disabled.

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.LedStyle Property

[image]

In-Sight SDK
CvsHmiSettings..::..LedStyle Property
CvsHmiSettings Class See Also Send Feedback
Indicates the style of the icons displayed in the filmstrip.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsStatusLevelStyle LedStyle { get; set; }
Visual Basic
Public Property LedStyle As CvsStatusLevelStyle
    Get
    Set

Property Value

Type: CvsStatusLevelStyle

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.MaximumInactivityTimeout Property

[image]

In-Sight SDK
CvsHmiSettings..::..MaximumInactivityTimeout Property
CvsHmiSettings Class See Also Send Feedback
The maximum value for the InactivityTimeout setting, in minutes.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaximumInactivityTimeout { get; }
Visual Basic
Public ReadOnly Property MaximumInactivityTimeout As Integer
    Get

Property Value

Type: Int32

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.MaximumPortNumber Property

[image]

In-Sight SDK
CvsHmiSettings..::..MaximumPortNumber Property
CvsHmiSettings Class See Also Send Feedback
The maximum value for the PortNumber setting.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaximumPortNumber { get; }
Visual Basic
Public ReadOnly Property MaximumPortNumber As Integer
    Get

Property Value

Type: Int32

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.MinimumInactivityTimeout Property

[image]

In-Sight SDK
CvsHmiSettings..::..MinimumInactivityTimeout Property
CvsHmiSettings Class See Also Send Feedback
The minimum value for the InactivityTimeout setting, in minutes.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MinimumInactivityTimeout { get; }
Visual Basic
Public ReadOnly Property MinimumInactivityTimeout As Integer
    Get

Property Value

Type: Int32

Remarks

A timeout of zero indicates that the inactivity timeout is disabled.

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.MinimumPortNumber Property

[image]

In-Sight SDK
CvsHmiSettings..::..MinimumPortNumber Property
CvsHmiSettings Class See Also Send Feedback
The minimum value for the PortNumber setting.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MinimumPortNumber { get; }
Visual Basic
Public ReadOnly Property MinimumPortNumber As Integer
    Get

Property Value

Type: Int32

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.PortNumber Property

[image]

In-Sight SDK
CvsHmiSettings..::..PortNumber Property
CvsHmiSettings Class See Also Send Feedback
Gets and sets the http port number.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int PortNumber { get; set; }
Visual Basic
Public Property PortNumber As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.SecurePortNumber Property

[image]

In-Sight SDK
CvsHmiSettings..::..SecurePortNumber Property
CvsHmiSettings Class See Also Send Feedback
Gets and sets the https port number

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int SecurePortNumber { get; set; }
Visual Basic
Public Property SecurePortNumber As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsHmiSettings.ServerEnabled Property

[image]

In-Sight SDK
CvsHmiSettings..::..ServerEnabled Property
CvsHmiSettings Class See Also Send Feedback
Enables and disables the http server.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ServerEnabled { get; set; }
Visual Basic
Public Property ServerEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsHmiSettings Class
CvsHmiSettings..::..CvsHmiSettings Members
Cognex.InSight Namespace


CvsImage Class

[image]

In-Sight SDK
CvsImage Class
Members See Also Send Feedback
Encapsulates the data associated with an acquired image from an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsImage : ISerializable,
    IDisposable, IServiceProvider
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsImage
    Implements ISerializable, IDisposable, IServiceProvider

Remarks

The properties of the CvsImage include everything necessary to construct a bitmap that may be rendered on a display.

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsImage

See Also

CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage Members

[image] [image]

In-Sight SDK
CvsImage Members
CvsImage Class Methods Properties See Also Send Feedback

The CvsImage type exposes the following members.

Methods

 | Name | Description
Public method | ChangePixelFormat | Changes the buffer's pixel format.
Public method | ChangePixelFormatAndBackup | Change the pixel format and backup the original image.
Public method | Dispose | Releases a reference to the object, freeing internal resources when all references have been released.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPixel | Gets the pixel value at the given coordinates.
Public method | GetPixelGrayscale | Gets the pixel grayscale value at the given coordinates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Save(String) | Saves the image to a file.
Public method | Save(String, ImageFormat) | Saves the image to a file.
Public method | ToBitmap | Creates a Bitmap containing the pixels of the CvsImage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | SaveAsBitmap(CvsPixelFormat) | Overloaded. Returns the image in a bitmap file format, using the specified pixel format. (Defined by CvsImageExtensions.)
Public Extension Method | SaveAsBitmap(Stream, CvsPixelFormat) | Overloaded. Writes the image to the stream in a bitmap file format, using the specified pixel format. (Defined by CvsImageExtensions.)

Properties

Name Description
Public property Height
Gets the height (in pixels) of the image.
Public property Location
Gets the location of the cell that generated the image.
Public property PixelFormat
Gets the pixel format of the image.
Public property Resolution Obsolete.
Gets a value that designates the resolution at which the image was transmitted from the In-Sight sensor.
Public property ResolutionScale
Gets the scale factor used by the sensor when transmitting the image.

Field Value

Type:
The scale factor is the ratio of acquired pixels to transmitted pixels, e.g. a 640x480 image transmitted as a 320x240 would have a scale factor of 2.
Public property StartColumn
Gets the start column (in pixels) at which the image was acquired.
Public property StartRow
Gets the start row (in pixels) at which the image was acquired.
Public property Width
Gets the width (in pixels) of the image.

See Also

CvsImage Class
Cognex.InSight Namespace


CvsImage Methods

[image] [image]

In-Sight SDK
CvsImage Methods
CvsImage Class See Also Send Feedback

The CvsImage type exposes the following members.

Methods

 | Name | Description
Public method | ChangePixelFormat | Changes the buffer's pixel format.
Public method | ChangePixelFormatAndBackup | Change the pixel format and backup the original image.
Public method | Dispose | Releases a reference to the object, freeing internal resources when all references have been released.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPixel | Gets the pixel value at the given coordinates.
Public method | GetPixelGrayscale | Gets the pixel grayscale value at the given coordinates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Save(String) | Saves the image to a file.
Public method | Save(String, ImageFormat) | Saves the image to a file.
Public method | ToBitmap | Creates a Bitmap containing the pixels of the CvsImage.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | SaveAsBitmap(CvsPixelFormat) | Overloaded. Returns the image in a bitmap file format, using the specified pixel format. (Defined by CvsImageExtensions.)
Public Extension Method | SaveAsBitmap(Stream, CvsPixelFormat) | Overloaded. Writes the image to the stream in a bitmap file format, using the specified pixel format. (Defined by CvsImageExtensions.)

See Also

CvsImage Class
Cognex.InSight Namespace


CvsImage.ChangePixelFormat Method

[image]

In-Sight SDK
CvsImage..::..ChangePixelFormat Method
CvsImage Class See Also Send Feedback
Changes the buffer's pixel format.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ChangePixelFormat(
    CvsPixelFormat format
)
Visual Basic
Public Sub ChangePixelFormat (
    format As CvsPixelFormat
)

Parameters

format
Type: Cognex.InSight..::..CvsPixelFormat

[Missing <param name="format"/> documentation for "M:Cognex.InSight.CvsImage.ChangePixelFormat(Cognex.InSight.CvsPixelFormat)"]

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage.ChangePixelFormatAndBackup Method

[image]

In-Sight SDK
CvsImage..::..ChangePixelFormatAndBackup Method
CvsImage Class See Also Send Feedback
Change the pixel format and backup the original image.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ChangePixelFormatAndBackup(
    CvsPixelFormat format
)
Visual Basic
Public Sub ChangePixelFormatAndBackup (
    format As CvsPixelFormat
)

Parameters

format
Type: Cognex.InSight..::..CvsPixelFormat
New pixel format.

Remarks

Always copies for now. Might be able to short circuit in a few cases.

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage.Dispose Method

[image]

In-Sight SDK
CvsImage..::..Dispose Method
CvsImage Class See Also Send Feedback
Releases a reference to the object, freeing internal resources when all references have been released.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage.GetPixel Method

[image]

In-Sight SDK
CvsImage..::..GetPixel Method
CvsImage Class See Also Send Feedback
Gets the pixel value at the given coordinates.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color GetPixel(
    int row,
    int column
)
Visual Basic
Public Function GetPixel (
    row As Integer,
    column As Integer
) As Color

Parameters

row
Type: System..::..Int32
The row (vertical) coordinate relative to the top of the image.
column
Type: System..::..Int32
The column (horizontal) coordinate relative the left side of the image.

Return Value

Type: Color
The Color of the pixel.

Remarks

This method is only available in .NET applications. To obtain a pixel value for use in COM/ActiveX applications, use the GetPixelGrayscale(Int32, Int32) method instead.

Throws a CvsIncompleteImageException if the image is not valid.

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage.GetPixelGrayscale Method

[image]

In-Sight SDK
CvsImage..::..GetPixelGrayscale Method
CvsImage Class See Also Send Feedback
Gets the pixel grayscale value at the given coordinates.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public byte GetPixelGrayscale(
    int row,
    int column
)
Visual Basic
Public Function GetPixelGrayscale (
    row As Integer,
    column As Integer
) As Byte

Parameters

row
Type: System..::..Int32
The row (vertical) coordinate relative to the top of the image.
column
Type: System..::..Int32
The column (horizontal) coordinate relative the left side of the image.

Return Value

Type: Byte
The greyscale value of the pixel.

Remarks

Throws a CvsIncompleteImageException if the image is not valid.

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage.Save Method

[image] [image]

In-Sight SDK
CvsImage..::..Save Method
CvsImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Save(String) | Saves the image to a file.
Public method | Save(String, ImageFormat) | Saves the image to a file.

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage.Save Method (String)

[image]

In-Sight SDK
CvsImage..::..Save Method (String)
CvsImage Class See Also Send Feedback
Saves the image to a file.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Save(
    string fileName
)
Visual Basic
Public Sub Save (
    fileName As String
)

Parameters

fileName
Type: System..::..String
The file name to which to save the image.

Remarks

The format of the file is determined by the extension of the given file name, which can be .JPG, .JPEG, .GIF, .TIF, .TIFF or .BMP (not case-sensitive). If the file extension is not recognized, the BMP format is used. Throws a CvsIncompleteImageException if the image is not valid.

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Save Overload
Cognex.InSight Namespace


CvsImage.Save Method (String, ImageFormat)

[image]

In-Sight SDK
CvsImage..::..Save Method (String, ImageFormat)
CvsImage Class See Also Send Feedback
Saves the image to a file.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Save(
    string filename,
    ImageFormat format
)
Visual Basic
Public Sub Save (
    filename As String,
    format As ImageFormat
)

Parameters

filename
Type: System..::..String
The destination file name.
format
Type: System.Drawing.Imaging..::..ImageFormat
The format of the destination file.

Remarks

This overload of this method is not available in COM/ActiveX applications.

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Save Overload
Cognex.InSight Namespace


CvsImage.ToBitmap Method

[image]

In-Sight SDK
CvsImage..::..ToBitmap Method
CvsImage Class See Also Send Feedback
Creates a Bitmap containing the pixels of the CvsImage.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Bitmap ToBitmap()
Visual Basic
Public Function ToBitmap As Bitmap

Return Value

Type: Bitmap
A Bitmap. Modifying pixels in this Bitmap will not change the actual pixel data of the CvsImage.

Remarks

This method is only available in .NET applications. To obtain an OLE Picture object for use in COM/ActiveX applications, use the ToPicture method instead.

Throws a CvsIncompleteImageException if the image is not valid.

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage Properties

[image] [image]

In-Sight SDK
CvsImage Properties
CvsImage Class See Also Send Feedback

The CvsImage type exposes the following members.

Properties

Name Description
Public property Height
Gets the height (in pixels) of the image.
Public property Location
Gets the location of the cell that generated the image.
Public property PixelFormat
Gets the pixel format of the image.
Public property Resolution Obsolete.
Gets a value that designates the resolution at which the image was transmitted from the In-Sight sensor.
Public property ResolutionScale
Gets the scale factor used by the sensor when transmitting the image.

Field Value

Type:
The scale factor is the ratio of acquired pixels to transmitted pixels, e.g. a 640x480 image transmitted as a 320x240 would have a scale factor of 2.
Public property StartColumn
Gets the start column (in pixels) at which the image was acquired.
Public property StartRow
Gets the start row (in pixels) at which the image was acquired.
Public property Width
Gets the width (in pixels) of the image.

See Also

CvsImage Class
Cognex.InSight Namespace


CvsImage.Height Property

[image]

In-Sight SDK
CvsImage..::..Height Property
CvsImage Class See Also Send Feedback
Gets the height (in pixels) of the image.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Height { get; }
Visual Basic
Public ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32

Remarks

The In-Sight sensor may be configured to send cropped and/or scaled images to improve performance.

The Resolution property indicates the resolution of this image. If the Resolution is less than Full, the Height and Width will be less than the size of the acquired image.

The image may also be cropped to the visible portion of the display control to improve performance. Cropping is enabled by default when connected to 5.0 or newer firmware. Cropping can be disabled from the CvsInSightDisplay control.

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage.Location Property

[image]

In-Sight SDK
CvsImage..::..Location Property
CvsImage Class See Also Send Feedback
Gets the location of the cell that generated the image.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation Location { get; }
Visual Basic
Public ReadOnly Property Location As CvsCellLocation
    Get

Property Value

Type: CvsCellLocation

Remarks

This is normally cell A0, unless this image is contained in a CvsGraphicImage object that represents a processed image.

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage.PixelFormat Property

[image]

In-Sight SDK
CvsImage..::..PixelFormat Property
CvsImage Class See Also Send Feedback
Gets the pixel format of the image.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsPixelFormat PixelFormat { get; }
Visual Basic
Public ReadOnly Property PixelFormat As CvsPixelFormat
    Get

Property Value

Type: CvsPixelFormat

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage.Resolution Property

[image]

In-Sight SDK
CvsImage..::..Resolution Property
CvsImage Class See Also Send Feedback
Gets a value that designates the resolution at which the image was transmitted from the In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[ObsoleteAttribute]
public CvsImageResolution Resolution { get; }
Visual Basic
<ObsoleteAttribute>
Public ReadOnly Property Resolution As CvsImageResolution
    Get

Property Value

Type: CvsImageResolution
This property will reflect the actual transmitted resolution of the image, e.g. Full or Half, and will never be equal to Default.

Remarks

The In-Sight sensor may be configured to send images with reduced resolution in order to improve performance, and the Resolution property indicates the resolution of this image. If the Resolution is less than Full, the Height and Width will be less than the size of the acquired image.

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage.ResolutionScale Property

[image]

In-Sight SDK
CvsImage..::..ResolutionScale Property
CvsImage Class See Also Send Feedback
Gets the scale factor used by the sensor when transmitting the image.

Property Value

Type: Int32
The scale factor is the ratio of acquired pixels to transmitted pixels, e.g. a 640x480 image transmitted as a 320x240 would have a scale factor of 2.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int ResolutionScale { get; }
Visual Basic
Public ReadOnly Property ResolutionScale As Integer
    Get

Property Value

Type: Int32

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage.StartColumn Property

[image]

In-Sight SDK
CvsImage..::..StartColumn Property
CvsImage Class See Also Send Feedback
Gets the start column (in pixels) at which the image was acquired.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int StartColumn { get; }
Visual Basic
Public ReadOnly Property StartColumn As Integer
    Get

Property Value

Type: Int32

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage.StartRow Property

[image]

In-Sight SDK
CvsImage..::..StartRow Property
CvsImage Class See Also Send Feedback
Gets the start row (in pixels) at which the image was acquired.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int StartRow { get; }
Visual Basic
Public ReadOnly Property StartRow As Integer
    Get

Property Value

Type: Int32

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImage.Width Property

[image]

In-Sight SDK
CvsImage..::..Width Property
CvsImage Class See Also Send Feedback
Gets the width (in pixels) of the image.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Width { get; }
Visual Basic
Public ReadOnly Property Width As Integer
    Get

Property Value

Type: Int32

Remarks

The In-Sight sensor may be configured to send cropped and/or scaled images to improve performance.

The Resolution property indicates the resolution of this image. If the Resolution is less than Full, the Height and Width will be less than the size of the acquired image.

The image may also be cropped to the visible portion of the display control to improve performance. Cropping is enabled by default when connected to 5.0 or newer firmware. Cropping can be disabled from the CvsInSightDisplay control.

See Also

CvsImage Class
CvsImage..::..CvsImage Members
Cognex.InSight Namespace


CvsImageLocation Structure

[image]

In-Sight SDK
CvsImageLocation Structure
Members See Also Send Feedback
Represents a pair of floating point row and column coordinates that defines a point in a two-dimensional plane.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public struct CvsImageLocation
Visual Basic
<SerializableAttribute>
Public Structure CvsImageLocation

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, only the row and column fields of this structure are visible because COM does not support methods on structures. The CvsUtility class provides most of the functionality of the methods of this structure for COM/ActiveX applications.

See Also

CvsImageLocation..::..CvsImageLocation Members
Cognex.InSight Namespace


CvsImageLocation Members

[image] [image]

In-Sight SDK
CvsImageLocation Members
CvsImageLocation Structure Constructors Methods Operators Properties See Also Send Feedback

The CvsImageLocation type exposes the following members.

Constructors

 | Name | Description
Public method | CvsImageLocation(CvsImageLocation) | Constructs a new instance of the CvsImageLocation structure.
Public method | CvsImageLocation(Double, Double) | Constructs a new instance of the CvsImageLocation structure.
Public method | CvsImageLocation(Single, Single) | Constructs a new instance of the CvsImageLocation structure.

Methods

 | Name | Description
Public method | Equals | Specifies whether this CvsImageLocation contains the same coordinates as the specified Object. (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | Gets a hash code for this CvsImageLocation object. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Set(Double, Double) | Set the instance to the specified row and column.
Public method | Set(Single, Single) | Set the instance to the specified row and column.
Public method | ToString | Converts this CvsImageLocation to a human readable string. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Equality | Equality operator.
ImplicitWideningImplicitImplicitImplicit(PointF to CvsImageLocation) | Converts a PointF structure into a CvsImageLocation
ImplicitWideningImplicitImplicitImplicit(CvsImageLocation to PointF) | Converts a CvsImageLocation into a PointF.
Inequality | Inequality operator.

Properties

 | Name | Description
Public property | Column | Gets or sets the column (horizontal) coordinate of this CvsImageLocation.
Public property | Row | Gets or sets the row (vertical) coordinate of this CvsImageLocation.

See Also

CvsImageLocation Structure
Cognex.InSight Namespace


CvsImageLocation Constructor

[image] [image]

In-Sight SDK
CvsImageLocation Constructor
CvsImageLocation Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsImageLocation(CvsImageLocation) | Constructs a new instance of the CvsImageLocation structure.
Public method | CvsImageLocation(Double, Double) | Constructs a new instance of the CvsImageLocation structure.
Public method | CvsImageLocation(Single, Single) | Constructs a new instance of the CvsImageLocation structure.

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
Cognex.InSight Namespace


CvsImageLocation Constructor (CvsImageLocation)

[image]

In-Sight SDK
CvsImageLocation Constructor (CvsImageLocation)
CvsImageLocation Structure See Also Send Feedback
Constructs a new instance of the CvsImageLocation structure.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation(
    CvsImageLocation location
)
Visual Basic
Public Sub New (
    location As CvsImageLocation
)

Parameters

location
Type: Cognex.InSight..::..CvsImageLocation
The location to copy.

Remarks

Com/ActiveX applications should use the helper method CvsImageLocationFromLocation(Single, Single).

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
CvsImageLocation Overload
Cognex.InSight Namespace


CvsImageLocation Constructor (Double, Double)

[image]

In-Sight SDK
CvsImageLocation Constructor (Double, Double)
CvsImageLocation Structure See Also Send Feedback
Constructs a new instance of the CvsImageLocation structure.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation(
    double row,
    double column
)
Visual Basic
Public Sub New (
    row As Double,
    column As Double
)

Parameters

row
Type: System..::..Double
The row (vertical) coordinate.
column
Type: System..::..Double
The column (horizontal) coordinate.

Remarks

Com/ActiveX applications should use the helper method CvsImageLocationFromLocation(Single, Single).

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
CvsImageLocation Overload
Cognex.InSight Namespace


CvsImageLocation Constructor (Single, Single)

[image]

In-Sight SDK
CvsImageLocation Constructor (Single, Single)
CvsImageLocation Structure See Also Send Feedback
Constructs a new instance of the CvsImageLocation structure.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation(
    float row,
    float column
)
Visual Basic
Public Sub New (
    row As Single,
    column As Single
)

Parameters

row
Type: System..::..Single
The row (vertical) coordinate.
column
Type: System..::..Single
The column (horizontal) coordinate.

Remarks

Com/ActiveX applications should use the helper method CvsImageLocationFromLocation(Single, Single).

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
CvsImageLocation Overload
Cognex.InSight Namespace


CvsImageLocation Methods

[image] [image]

In-Sight SDK
CvsImageLocation Methods
CvsImageLocation Structure See Also Send Feedback

The CvsImageLocation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Specifies whether this CvsImageLocation contains the same coordinates as the specified Object. (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | Gets a hash code for this CvsImageLocation object. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Set(Double, Double) | Set the instance to the specified row and column.
Public method | Set(Single, Single) | Set the instance to the specified row and column.
Public method | ToString | Converts this CvsImageLocation to a human readable string. (Overrides ValueType..::..ToString()()()().)

See Also

CvsImageLocation Structure
Cognex.InSight Namespace


CvsImageLocation.Equals Method

[image]

In-Sight SDK
CvsImageLocation..::..Equals Method
CvsImageLocation Structure See Also Send Feedback
Specifies whether this CvsImageLocation contains the same coordinates as the specified Object.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: System..::..Object
The object to test.

Return Value

Type: Boolean
true if obj is a CvsImageLocation and its row and column are the same as this instance; otherwise, false.

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
Cognex.InSight Namespace


CvsImageLocation.GetHashCode Method

[image]

In-Sight SDK
CvsImageLocation..::..GetHashCode Method
CvsImageLocation Structure See Also Send Feedback
Gets a hash code for this CvsImageLocation object.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A 32-bit signed integer hash code.

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
Cognex.InSight Namespace


CvsImageLocation.Set Method

[image] [image]

In-Sight SDK
CvsImageLocation..::..Set Method
CvsImageLocation Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Double, Double) | Set the instance to the specified row and column.
Public method | Set(Single, Single) | Set the instance to the specified row and column.

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
Cognex.InSight Namespace


CvsImageLocation.Set Method (Double, Double)

[image]

In-Sight SDK
CvsImageLocation..::..Set Method (Double, Double)
CvsImageLocation Structure See Also Send Feedback
Set the instance to the specified row and column.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Set(
    double row,
    double column
)
Visual Basic
Public Sub Set (
    row As Double,
    column As Double
)

Parameters

row
Type: System..::..Double
The row (vertical) coordinate.
column
Type: System..::..Double
The column (horizontal) coordinate.

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
Set Overload
Cognex.InSight Namespace


CvsImageLocation.Set Method (Single, Single)

[image]

In-Sight SDK
CvsImageLocation..::..Set Method (Single, Single)
CvsImageLocation Structure See Also Send Feedback
Set the instance to the specified row and column.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Set(
    float row,
    float column
)
Visual Basic
Public Sub Set (
    row As Single,
    column As Single
)

Parameters

row
Type: System..::..Single
The row (vertical) coordinate.
column
Type: System..::..Single
The column (horizontal) coordinate.

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
Set Overload
Cognex.InSight Namespace


CvsImageLocation.ToString Method

[image]

In-Sight SDK
CvsImageLocation..::..ToString Method
CvsImageLocation Structure See Also Send Feedback
Converts this CvsImageLocation to a human readable string.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
A string that represents the image location.

Remarks

Com/ActiveX applications should use the helper method CvsImageLocationToString(Single, Single).

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
Cognex.InSight Namespace


CvsImageLocation Operators and Type Conversions

[image] [image]

In-Sight SDK
CvsImageLocation Operators and Type Conversions
CvsImageLocation Structure See Also Send Feedback

The CvsImageLocation type exposes the following members.

Operators

Name | Description
Equality | Equality operator.
ImplicitWideningImplicitImplicitImplicit(PointF to CvsImageLocation) | Converts a PointF structure into a CvsImageLocation
ImplicitWideningImplicitImplicitImplicit(CvsImageLocation to PointF) | Converts a CvsImageLocation into a PointF.
Inequality | Inequality operator.

See Also

CvsImageLocation Structure
Cognex.InSight Namespace


CvsImageLocation.Equality Operator

[image]

In-Sight SDK
CvsImageLocation..::..Equality Operator
CvsImageLocation Structure See Also Send Feedback
Equality operator.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool operator ==(
    CvsImageLocation left,
    CvsImageLocation right
)
Visual Basic
Public Shared Operator = (
    left As CvsImageLocation,
    right As CvsImageLocation
) As Boolean

Parameters

left
Type: Cognex.InSight..::..CvsImageLocation
The first CvsImageLocation to test.
right
Type: Cognex.InSight..::..CvsImageLocation
The second CvsImageLocation to test.

Return Value

Type: Boolean
true if obj if the locations have the same row and column; otherwise, false.

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
Cognex.InSight Namespace


CvsImageLocation Implicit Conversion Operators

[image] [image]

In-Sight SDK
CvsImageLocation ImplicitWideningImplicitImplicitImplicit Conversion Operators
CvsImageLocation Structure See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(PointF to CvsImageLocation) | Converts a PointF structure into a CvsImageLocation
ImplicitWideningImplicitImplicitImplicit(CvsImageLocation to PointF) | Converts a CvsImageLocation into a PointF.

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
Cognex.InSight Namespace


CvsImageLocation Implicit Conversion (PointF to CvsImageLocation)

[image]

In-Sight SDK
CvsImageLocation ImplicitWideningImplicitImplicitImplicit Conversion (PointF to CvsImageLocation)
CvsImageLocation Structure See Also Send Feedback
Converts a PointF structure into a CvsImageLocation

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static implicit operator CvsImageLocation (
    PointF rhs
)
Visual Basic
Public Shared Widening Operator CType (
    rhs As PointF
) As CvsImageLocation

Parameters

rhs
Type: System.Drawing..::..PointF
The source PointF structure

Return Value

Type: CvsImageLocation
An equivalent CvsImageLocation structure

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
ImplicitWideningImplicitImplicitImplicit Overload
Cognex.InSight Namespace


CvsImageLocation Implicit Conversion (CvsImageLocation to PointF)

[image]

In-Sight SDK
CvsImageLocation ImplicitWideningImplicitImplicitImplicit Conversion (CvsImageLocation to PointF)
CvsImageLocation Structure See Also Send Feedback
Converts a CvsImageLocation into a PointF.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static implicit operator PointF (
    CvsImageLocation rhs
)
Visual Basic
Public Shared Widening Operator CType (
    rhs As CvsImageLocation
) As PointF

Parameters

rhs
Type: Cognex.InSight..::..CvsImageLocation
The source CvsImageLocation

Return Value

Type: PointF
An equivalent PointF structure

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
ImplicitWideningImplicitImplicitImplicit Overload
Cognex.InSight Namespace


CvsImageLocation.Inequality Operator

[image]

In-Sight SDK
CvsImageLocation..::..Inequality Operator
CvsImageLocation Structure See Also Send Feedback
Inequality operator.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool operator !=(
    CvsImageLocation left,
    CvsImageLocation right
)
Visual Basic
Public Shared Operator <> (
    left As CvsImageLocation,
    right As CvsImageLocation
) As Boolean

Parameters

left
Type: Cognex.InSight..::..CvsImageLocation
The first CvsImageLocation to test.
right
Type: Cognex.InSight..::..CvsImageLocation
The second CvsImageLocation to test.

Return Value

Type: Boolean
true if obj if the locations do not have the same row and column; otherwise, false.

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
Cognex.InSight Namespace


CvsImageLocation Properties

[image] [image]

In-Sight SDK
CvsImageLocation Properties
CvsImageLocation Structure See Also Send Feedback

The CvsImageLocation type exposes the following members.

Properties

 | Name | Description
Public property | Column | Gets or sets the column (horizontal) coordinate of this CvsImageLocation.
Public property | Row | Gets or sets the row (vertical) coordinate of this CvsImageLocation.

See Also

CvsImageLocation Structure
Cognex.InSight Namespace


CvsImageLocation.Column Property

[image]

In-Sight SDK
CvsImageLocation..::..Column Property
CvsImageLocation Structure See Also Send Feedback
Gets or sets the column (horizontal) coordinate of this CvsImageLocation.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Column { get; set; }
Visual Basic
Public Property Column As Single
    Get
    Set

Property Value

Type: Single

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
Cognex.InSight Namespace


CvsImageLocation.Row Property

[image]

In-Sight SDK
CvsImageLocation..::..Row Property
CvsImageLocation Structure See Also Send Feedback
Gets or sets the row (vertical) coordinate of this CvsImageLocation.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Row { get; set; }
Visual Basic
Public Property Row As Single
    Get
    Set

Property Value

Type: Single

See Also

CvsImageLocation Structure
CvsImageLocation..::..CvsImageLocation Members
Cognex.InSight Namespace


CvsImageOrientation Enumeration

[image]

In-Sight SDK
CvsImageOrientation Enumeration
See Also Send Feedback
Constants that specify how an image is oriented relative to its original form.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsImageOrientation
Visual Basic
Public Enumeration CvsImageOrientation

Members

Member name | Value | Description
Normal | 0 | Normal orientation.
RotateCounterclockwise90 | 90 | Rotated 90 degrees counterclockwise.
Rotate180 | 180 | Rotated 180 degrees.
RotateClockwise90 | 270 | Rotated 90 degrees clockwise.

See Also

Cognex.InSight Namespace


CvsIncompleteImageException Class

[image]

In-Sight SDK
CvsIncompleteImageException Class
Members See Also Send Feedback
Exception that is thrown when an incomplete or invalid CvsImage has been accessed.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsIncompleteImageException : CvsException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsIncompleteImageException
    Inherits CvsException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsIncompleteImageException

See Also

CvsIncompleteImageException..::..CvsIncompleteImageException Members
Cognex.InSight Namespace


CvsIncompleteImageException Members

[image] [image]

In-Sight SDK
CvsIncompleteImageException Members
CvsIncompleteImageException Class Methods Properties See Also Send Feedback

The CvsIncompleteImageException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsIncompleteImageException Class
Cognex.InSight Namespace


CvsIncompleteImageException Methods

[image] [image]

In-Sight SDK
CvsIncompleteImageException Methods
CvsIncompleteImageException Class See Also Send Feedback

The CvsIncompleteImageException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsIncompleteImageException Class
Cognex.InSight Namespace


CvsIncompleteImageException Properties

[image] [image]

In-Sight SDK
CvsIncompleteImageException Properties
CvsIncompleteImageException Class See Also Send Feedback

The CvsIncompleteImageException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsIncompleteImageException Class
Cognex.InSight Namespace


CvsInSight Class

[image]

In-Sight SDK
CvsInSight Class
Members See Also Send Feedback
Provides a direct connection to an In-Sight sensor. Use of this class while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed, the constructor will throw a CvsNotLicensedException.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public class CvsInSight : MarshalByRefObject, IDisposable,
    ICvsHostVersionProvider
Visual Basic
Public Class CvsInSight
    Inherits MarshalByRefObject
    Implements IDisposable, ICvsHostVersionProvider

Remarks

Call the Connect(IPAddress, String, String, Boolean, Boolean) method to connect to an In-Sight sensor. When the connection is no longer needed, call Disconnect()()()() to disconnect from the In-Sight sensor and free the associated resources.

Results from the most recent acquisition can be obtained using the Results property.

Call the AcceptUpdate()()()() method after the application has received and processed results from an In-Sight sensor and is ready for new results.

There can only be a single connection to an In-Sight sensor. In other words, a single CvsInSight will own the connection to an In-Sight.

IMPORTANT NOTE: All events generated by an instance of this class will be raised on the same thread that called the Connect(IPAddress, String, String, Boolean, Boolean) method. If this method is called on another thread, then the instance MUST NOT be connected to a CvsInSightDisplay.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
Cognex.InSight..::..CvsInSight

See Also

CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight Members

[image] [image]

In-Sight SDK
CvsInSight Members
CvsInSight Class Constructors Methods Properties Events See Also Send Feedback

The CvsInSight type exposes the following members.

Constructors

 | Name | Description
Public method | CvsInSight | Initializes a new instance of the CvsInSight class.

Methods

 | Name | Description
Public method | AcceptUpdate | Accepts the next update from the sensor.
Public method | ClearComment(CvsCellLocation) | Removes the comment at the location.
Public method | ClearComment(Int32, Int32) | Removes the comment at the location.
Public method | ClickButton(CvsCellLocation) | Performs a button click for a Button control cell.
Public method | ClickButton(Int32, Int32) | Performs a button click for a Button control cell.
Public method | ClickSelect(CvsCellLocation) | Performs a send select event for a Select control cell.
Public method | ClickSelect(Int32, Int32) | Performs a send select event for a Select control cell.
Public method | Connect(IPAddress, String, String, Boolean, Boolean) | Connects to the In-Sight sensor at the specified IP address.
Public method | Connect(String, String, String, Boolean, Boolean) | Connects to the specified In-Sight sensor.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects from the In-Sight sensor.
Public method | Dispose | Closes any connection that is open and releases all resources used by CvsInSight object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetComment(CvsCellLocation) | Gets the comment at the specified location.
Public method | GetComment(Int32, Int32) | Gets the comment at the specified location.
Public method | GetEasyView | Gets the EasyView that is stored in the job.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetSymbolicTagCollection | Gets a collection of symbolic tags that are associated with cells in the job.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ManualAcquire()()()() | Manually triggers an image acquisition.
Public method | ManualAcquire(Boolean) | Manually triggers an image acquisition and optionally waits for the results to be received.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ResetSystem | Resets the In-Sight system and optionally tries to reconnect to it. This command is similar to physically cycling power on the system.
Public method | SetCellState(CvsCellLocation, Boolean) | Sets the cell's state to either enabled or disabled.
Public method | SetCellState(Int32, Int32, Boolean) | Sets the cell's state to either enabled or disabled.
Public method | SetCellState(CvsCellLocation, CvsCellLocation, Boolean, Boolean) | Sets the cell's state to a reference.
Public method | SetCellState(Int32, Int32, Int32, Boolean, Int32, Boolean) | Sets the cell's state to a reference.
Public method | SetCheckBox(CvsCellLocation, Boolean) | Sets a CheckBox control to the specified value.
Public method | SetCheckBox(Int32, Int32, Boolean) | Sets a CheckBox control to the specified value.
Public method | SetComment(CvsCellLocation, CvsCellComment) | Sets the comment at the location to the specified value.
Public method | SetComment(Int32, Int32, CvsCellComment) | Sets the comment at the location to the specified value.
Public method | SetEasyView | Sets the EasyView that is stored in the job.
Public method | SetEditGraphic | Sets the coordinates of the graphical shape for the specified edit cell.
Public method | SetFloat(CvsCellLocation, Single) | Sets an EditFloat control to the specified value.
Public method | SetFloat(Int32, Int32, Single) | Sets an EditFloat control to the specified value.
Public method | SetInteger(CvsCellLocation, Int32) | Sets an EditInt control to the specified value.
Public method | SetInteger(Int32, Int32, Int32) | Sets an EditInt control to the specified value.
Public method | SetInteger(CvsCellLocation, Int32, Boolean) | Sets an EditInt control to the specified value.
Public method | SetListBoxIndex(CvsCellLocation, Int32) | Sets a ListBox control to the specified value.
Public method | SetListBoxIndex(Int32, Int32, Int32) | Sets a ListBox control to the specified value.
Public method | SetString(CvsCellLocation, String) | Sets an EditString control to the specified value.
Public method | SetString(Int32, Int32, String) | Sets an EditString control to the specified value.
Public method | SetSymbolicTag | Sets the symbolic tag that is associated with a cell in the job.
Public method | SetSymbolicTagCollection | Sets the collection of symbolic tags that are associated with cells in the job.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | GetCell(CvsCellLocation) | Overloaded. Returns the CvsCell from the current result set. (Defined by CvsInSightExtensions.)
Public Extension Method | GetCell<(Of <<'(TResult>)>>)(CvsCellLocation) | Overloaded. Returns the CvsCell from the current result set cast to the specified type. (Defined by CvsInSightExtensions.)
Public Extension Method | GetCellGraphics | Returns an enumeration of all of the graphics associated with a cell. (Defined by CvsInSightExtensions.)
Public Extension Method | GetFirmwareVersion | Gets the firmware version of the connected CvsInSight object. (Defined by CvsInSightExtensions.)
Public Extension Method | GetFormatDecimalPlaces | Returns the number of decimal places that should be used when displaying a floating point value. The value is extracted from the cell format tag. If no tag is present, then the default value is returned. (Defined by CvsInSightExtensions.)
Public Extension Method | GetPropertySheetExpression | Gets the current property sheet expression. (Defined by CvsInSightExtensions.)

Properties

 | Name | Description
Public property | Access | Gets the security access setting for the current connection to an In-Sight sensor.
Public property | AccessDowngraded | Returns true if the security access for the current connection was downgraded due to restrictions on multiple connections.
Public property | DiscreteOnline | Returns true (the usual case) if the discrete inputs of the In-Sight sensor will permit the sensor to go online, or false if a discrete input will prevent it from going online. This property also returns false when the In-Sight sensor is disconnected.
Public property | ExclusiveConnection | Gets or sets a flag that designates the locking of the connection to an In-Sight sensor.
Public property | File | Gets the object that holds the file management methods for a connection to an In-Sight sensor.
Public property | IsJobProtected | Gets a flag that designates whether or not the current job is protected.
Public property | JobInfo | Gets the object that holds the job information and view settings for a connection to an In-Sight sensor.
Public property | Language | Gets the language used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | LiveAcquisition | Gets or sets the live acquisition mode for the In-Sight sensor.
Public property | LocalIPAddress | Gets the local IP Address used for the current connection to an In-Sight sensor.
Public property | NativeOnline | Returns true (the usual case) when no native mode command has forced the In-Sight sensor into the offline state, or false if the Native Mode "Set Online false" (SO0) will prevent it from going online. This property also returns false when the In-Sight sensor is disconnected.
Public property | Password | Gets the password used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | RemoteIPAddress | Gets the IP Address used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | RemoteIPAddressString | Gets the IP Address used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | Results | Gets the most recent set of results from an acquisition.
Public property | Sensor | Gets the object that holds the sensor settings for a connection to an In-Sight sensor.
Public property | SoftOnline | Gets or sets the software online enabling flag. If true, and if the DiscreteOnline and NativeOnline flags are also true, then the In-Sight sensor will be in the online state.
Public property | State | Gets the state (NotConnected, Offline, Online) of the In-Sight sensor.
Public property | Username | Gets the user name used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.

Events

 | Name | Description
Public event | ConnectCompleted | The ConnectCompleted event is raised when an asynchronous Connect(IPAddress, String, String, Boolean, Boolean) call has completed. The event arguments indicate whether an exception was generated while attempting the connection.
Public event | InSightMessage | The InSightMessage event is raised when the connected In-Sight sensor sends an informational message.
Public event | LiveAcquisitionChanged | The LiveAcquisitionChanged event is raised when the LiveAcquisition property has changed.
Public event | LoadCompleted | The LoadCompleted event is raised when a file load operation is complete.
Public event | ResultsChanged | The ResultsChanged event is raised when the Results property has changed.
Public event | SaveCompleted | The SaveCompleted event is raised when a file save operation is complete.
Public event | SensorChanged | The SensorChanged event is raised when one or more properties or sub-objects in the Sensor changed.
Public event | StateChanged | The StateChanged event is raised when the State, SoftOnline, NativeOnline, or DiscreteOnline properties changed.

See Also

CvsInSight Class
Cognex.InSight Namespace


CvsInSight Constructor

[image]

In-Sight SDK
CvsInSight Constructor
CvsInSight Class See Also Send Feedback
Initializes a new instance of the CvsInSight class.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSight()
Visual Basic
Public Sub New

Remarks

Call Connect(IPAddress, String, String, Boolean, Boolean) to establish a connection to an In-Sight sensor.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotLicensedException | The CvsInSight class may not be constructed in a debug environment without an In-Sight SDK license.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight Methods

[image] [image]

In-Sight SDK
CvsInSight Methods
CvsInSight Class See Also Send Feedback

The CvsInSight type exposes the following members.

Methods

 | Name | Description
Public method | AcceptUpdate | Accepts the next update from the sensor.
Public method | ClearComment(CvsCellLocation) | Removes the comment at the location.
Public method | ClearComment(Int32, Int32) | Removes the comment at the location.
Public method | ClickButton(CvsCellLocation) | Performs a button click for a Button control cell.
Public method | ClickButton(Int32, Int32) | Performs a button click for a Button control cell.
Public method | ClickSelect(CvsCellLocation) | Performs a send select event for a Select control cell.
Public method | ClickSelect(Int32, Int32) | Performs a send select event for a Select control cell.
Public method | Connect(IPAddress, String, String, Boolean, Boolean) | Connects to the In-Sight sensor at the specified IP address.
Public method | Connect(String, String, String, Boolean, Boolean) | Connects to the specified In-Sight sensor.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects from the In-Sight sensor.
Public method | Dispose | Closes any connection that is open and releases all resources used by CvsInSight object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetComment(CvsCellLocation) | Gets the comment at the specified location.
Public method | GetComment(Int32, Int32) | Gets the comment at the specified location.
Public method | GetEasyView | Gets the EasyView that is stored in the job.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetSymbolicTagCollection | Gets a collection of symbolic tags that are associated with cells in the job.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ManualAcquire()()()() | Manually triggers an image acquisition.
Public method | ManualAcquire(Boolean) | Manually triggers an image acquisition and optionally waits for the results to be received.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ResetSystem | Resets the In-Sight system and optionally tries to reconnect to it. This command is similar to physically cycling power on the system.
Public method | SetCellState(CvsCellLocation, Boolean) | Sets the cell's state to either enabled or disabled.
Public method | SetCellState(Int32, Int32, Boolean) | Sets the cell's state to either enabled or disabled.
Public method | SetCellState(CvsCellLocation, CvsCellLocation, Boolean, Boolean) | Sets the cell's state to a reference.
Public method | SetCellState(Int32, Int32, Int32, Boolean, Int32, Boolean) | Sets the cell's state to a reference.
Public method | SetCheckBox(CvsCellLocation, Boolean) | Sets a CheckBox control to the specified value.
Public method | SetCheckBox(Int32, Int32, Boolean) | Sets a CheckBox control to the specified value.
Public method | SetComment(CvsCellLocation, CvsCellComment) | Sets the comment at the location to the specified value.
Public method | SetComment(Int32, Int32, CvsCellComment) | Sets the comment at the location to the specified value.
Public method | SetEasyView | Sets the EasyView that is stored in the job.
Public method | SetEditGraphic | Sets the coordinates of the graphical shape for the specified edit cell.
Public method | SetFloat(CvsCellLocation, Single) | Sets an EditFloat control to the specified value.
Public method | SetFloat(Int32, Int32, Single) | Sets an EditFloat control to the specified value.
Public method | SetInteger(CvsCellLocation, Int32) | Sets an EditInt control to the specified value.
Public method | SetInteger(Int32, Int32, Int32) | Sets an EditInt control to the specified value.
Public method | SetInteger(CvsCellLocation, Int32, Boolean) | Sets an EditInt control to the specified value.
Public method | SetListBoxIndex(CvsCellLocation, Int32) | Sets a ListBox control to the specified value.
Public method | SetListBoxIndex(Int32, Int32, Int32) | Sets a ListBox control to the specified value.
Public method | SetString(CvsCellLocation, String) | Sets an EditString control to the specified value.
Public method | SetString(Int32, Int32, String) | Sets an EditString control to the specified value.
Public method | SetSymbolicTag | Sets the symbolic tag that is associated with a cell in the job.
Public method | SetSymbolicTagCollection | Sets the collection of symbolic tags that are associated with cells in the job.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | GetCell(CvsCellLocation) | Overloaded. Returns the CvsCell from the current result set. (Defined by CvsInSightExtensions.)
Public Extension Method | GetCell<(Of <<'(TResult>)>>)(CvsCellLocation) | Overloaded. Returns the CvsCell from the current result set cast to the specified type. (Defined by CvsInSightExtensions.)
Public Extension Method | GetCellGraphics | Returns an enumeration of all of the graphics associated with a cell. (Defined by CvsInSightExtensions.)
Public Extension Method | GetFirmwareVersion | Gets the firmware version of the connected CvsInSight object. (Defined by CvsInSightExtensions.)
Public Extension Method | GetFormatDecimalPlaces | Returns the number of decimal places that should be used when displaying a floating point value. The value is extracted from the cell format tag. If no tag is present, then the default value is returned. (Defined by CvsInSightExtensions.)
Public Extension Method | GetPropertySheetExpression | Gets the current property sheet expression. (Defined by CvsInSightExtensions.)

See Also

CvsInSight Class
Cognex.InSight Namespace


CvsInSight.AcceptUpdate Method

[image]

In-Sight SDK
CvsInSight..::..AcceptUpdate Method
CvsInSight Class See Also Send Feedback
Accepts the next update from the sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void AcceptUpdate()
Visual Basic
Public Sub AcceptUpdate

Remarks

AcceptUpdate should be called after the application has received and processed results from an In-Sight sensor and is ready for new results.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.ClearComment Method

[image] [image]

In-Sight SDK
CvsInSight..::..ClearComment Method
CvsInSight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearComment(CvsCellLocation) | Removes the comment at the location.
Public method | ClearComment(Int32, Int32) | Removes the comment at the location.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.ClearComment Method (CvsCellLocation)

[image]

In-Sight SDK
CvsInSight..::..ClearComment Method (CvsCellLocation)
CvsInSight Class See Also Send Feedback
Removes the comment at the location.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ClearComment(
    CvsCellLocation location
)
Visual Basic
Public Sub ClearComment (
    location As CvsCellLocation
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
ClearComment Overload
Cognex.InSight Namespace


CvsInSight.ClearComment Method (Int32, Int32)

[image]

In-Sight SDK
CvsInSight..::..ClearComment Method (Int32, Int32)
CvsInSight Class See Also Send Feedback
Removes the comment at the location.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ClearComment(
    int row,
    int col
)
Visual Basic
Public Sub ClearComment (
    row As Integer,
    col As Integer
)

Parameters

row
Type: System..::..Int32
The cell's row location.
col
Type: System..::..Int32
The cell's column location.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
ClearComment Overload
Cognex.InSight Namespace


CvsInSight.ClickButton Method

[image] [image]

In-Sight SDK
CvsInSight..::..ClickButton Method
CvsInSight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClickButton(CvsCellLocation) | Performs a button click for a Button control cell.
Public method | ClickButton(Int32, Int32) | Performs a button click for a Button control cell.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.ClickButton Method (CvsCellLocation)

[image]

In-Sight SDK
CvsInSight..::..ClickButton Method (CvsCellLocation)
CvsInSight Class See Also Send Feedback
Performs a button click for a Button control cell.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ClickButton(
    CvsCellLocation location
)
Visual Basic
Public Sub ClickButton (
    location As CvsCellLocation
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the effect of clicking is reflected in the results.

This method remains operational even when the control's cell is disabled.

This overload of this method is not available in COM/ActiveX applications.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
ClickButton Overload
Cognex.InSight Namespace


CvsInSight.ClickButton Method (Int32, Int32)

[image]

In-Sight SDK
CvsInSight..::..ClickButton Method (Int32, Int32)
CvsInSight Class See Also Send Feedback
Performs a button click for a Button control cell.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ClickButton(
    int row,
    int col
)
Visual Basic
Public Sub ClickButton (
    row As Integer,
    col As Integer
)

Parameters

row
Type: System..::..Int32
The cell's row location.
col
Type: System..::..Int32
The cell's column location.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the effect of clicking is reflected in the results.

This method remains operational even when the control's cell is disabled.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
ClickButton Overload
Cognex.InSight Namespace


CvsInSight.ClickSelect Method

[image] [image]

In-Sight SDK
CvsInSight..::..ClickSelect Method
CvsInSight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClickSelect(CvsCellLocation) | Performs a send select event for a Select control cell.
Public method | ClickSelect(Int32, Int32) | Performs a send select event for a Select control cell.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.ClickSelect Method (CvsCellLocation)

[image]

In-Sight SDK
CvsInSight..::..ClickSelect Method (CvsCellLocation)
CvsInSight Class See Also Send Feedback
Performs a send select event for a Select control cell.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ClickSelect(
    CvsCellLocation location
)
Visual Basic
Public Sub ClickSelect (
    location As CvsCellLocation
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the effect of clicking is reflected in the results.

This method remains operational even when the control's cell is disabled.

This overload of this method is not available in COM/ActiveX applications.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
ClickSelect Overload
Cognex.InSight Namespace


CvsInSight.ClickSelect Method (Int32, Int32)

[image]

In-Sight SDK
CvsInSight..::..ClickSelect Method (Int32, Int32)
CvsInSight Class See Also Send Feedback
Performs a send select event for a Select control cell.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ClickSelect(
    int row,
    int col
)
Visual Basic
Public Sub ClickSelect (
    row As Integer,
    col As Integer
)

Parameters

row
Type: System..::..Int32
The cell's row location.
col
Type: System..::..Int32
The cell's column location.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the effect of clicking is reflected in the results.

This method remains operational even when the control's cell is disabled.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
ClickSelect Overload
Cognex.InSight Namespace


CvsInSight.Connect Method

[image] [image]

In-Sight SDK
CvsInSight..::..Connect Method
CvsInSight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Connect(IPAddress, String, String, Boolean, Boolean) | Connects to the In-Sight sensor at the specified IP address.
Public method | Connect(String, String, String, Boolean, Boolean) | Connects to the specified In-Sight sensor.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.Connect Method (IPAddress, String, String, Boolean, Boolean)

[image]

In-Sight SDK
CvsInSight..::..Connect Method (IPAddress, String, String, Boolean, Boolean)
CvsInSight Class See Also Send Feedback
Connects to the In-Sight sensor at the specified IP address.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Connect(
    IPAddress address,
    string username,
    string password,
    bool forceConnect,
    bool asynchronous
)
Visual Basic
Public Sub Connect (
    address As IPAddress,
    username As String,
    password As String,
    forceConnect As Boolean,
    asynchronous As Boolean
)

Parameters

address
Type: System.Net..::..IPAddress
The IP address of the In-Sight sensor to connect to.
username
Type: System..::..String
The user name to connect with.
password
Type: System..::..String
The password associated with the user name to connect with.
forceConnect
Type: System..::..Boolean
true will break an existing connection; false will prohibit a connection if one already exists.
asynchronous
Type: System..::..Boolean
true will return without waiting for the connection to be complete; false will wait for the connection to complete.

NOTE: If true, no properties or methods (other than Disconnect()()()()) on the CvsInSight instance may be called until the ConnectCompleted event is raised. Doing so will result in the CvsInSightLockedException.

Remarks

It may take up to 30 seconds to establish a connection to an In-Sight sensor.

If asynchronous is false, This method will not return until the connection is completely established with In-Sight sensor or an exception is thrown that prevented the connection.

If asynchronous is true, the ConnectCompleted event must be handled. If it is not, InvalidOperationException will be thrown. No properties or methods (other than Disconnect()()()()) on the CvsInSight instance may be called until the ConnectCompleted event is raised. Doing so will result in the CvsInSightLockedException. If an asynchronous connection is already in progress or an established connection has an open messagebox, the CvsInSightLockedException will be thrown. Other exceptions will not be thrown from this Connect method, but rather they will be reported in the Exception property that is reported with the ConnectCompleted event.

The method Disconnect()()()() should always be called before exiting an application that has made a connection to a sensor. If asynchronous is false, this method will disconnect a connection before establishing a new one.

If the forceConnect is true, any existing connection to the In-Sight sensor from the same or another PC will be broken, unless that connection was etablished with the ExclusiveConnection property set to true.

This overload of this method is not available in COM/ActiveX applications.

IMPORTANT NOTE: All events generated by an instance of this class will be raised on the same thread that called the this method. If this method is called on another thread, then the instance MUST NOT be connected to a CvsInSightDisplay. The thread that calls this method is expected to have a message pump.

Events

Event Type | Reason
CvsInSight..::..ConnectCompleted | Raised when the asynchronous connection is complete. NOTE: This event must be handled for asynchronous connections.
CvsInSight..::..StateChanged | Raised when the connection is complete and the State property is updated.
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.
CvsInSight..::..SensorChanged | Raised when the Sensor property is updated with new sensor information.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The ConnectCompleted event must be subscribed to in order to connect asynchronously.
Cognex.InSight..::..CvsInSightLockedException | The In-Sight sensor is locked and unable to accept a connection or an asynchronous connection is already in progress. See ExclusiveConnection for more information on explicitly locking the In-Sight connection.
Cognex.InSight..::..CvsNetworkException | The connection to the specified In-Sight sensor could not be completed. This may be because the wrong address was specified or some other low-level or network condition is preventing the connection.
Cognex.InSight..::..CvsInvalidLogonException | An Invalid user name or password was specified.
CvsCdsLoginException | There was a problem authenticating the user on the In-Sight with the current CDS.
Cognex.InSight..::..CvsSensorAlreadyConnectedException | There is already a local or remote connection to the In-Sight sensor. There was an error authenticating with the CDS server. This could be an incorrect username/password, a problem connecting to the server, or an error with the user account. Details on the specific failure are provided in the exception. If the sensor is in Classic authentication mode, this exception will not be thrown. See ExclusiveConnection for more information on explicitly locking the In-Sight connection.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Connect Overload
Cognex.InSight Namespace


CvsInSight.Connect Method (String, String, String, Boolean, Boolean)

[image]

In-Sight SDK
CvsInSight..::..Connect Method (String, String, String, Boolean, Boolean)
CvsInSight Class See Also Send Feedback
Connects to the specified In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Connect(
    string hostName,
    string username,
    string password,
    bool forceConnect,
    bool asynchronous
)
Visual Basic
Public Sub Connect (
    hostName As String,
    username As String,
    password As String,
    forceConnect As Boolean,
    asynchronous As Boolean
)

Parameters

hostName
Type: System..::..String
The DNS name or IP address of the In-Sight sensor to which you intend to connect.
username
Type: System..::..String
The user name to connect with.
password
Type: System..::..String
The password associated with the user name to connect with.
forceConnect
Type: System..::..Boolean
true will break an existing connection; false will prohibit a connection if one already exists.
asynchronous
Type: System..::..Boolean
true will return without waiting for the connection to be complete; false will wait for the connection to complete.

NOTE: If true, no properties or methods (other than Disconnect()()()()) on the CvsInSight instance may be called until the ConnectCompleted event is raised. Doing so will result in the CvsInSightLockedException.

Remarks

It may take up to 30 seconds to establish a connection to an In-Sight sensor.

If asynchronous is false, This method will not return until the connection is completely established with In-Sight sensor or an exception is thrown that prevented the connection.

If asynchronous is true, the ConnectCompleted event must be handled. If it is not, InvalidOperationException will be thrown. No properties or methods (other than Disconnect()()()()) on the CvsInSight instance may be called until the ConnectCompleted event is raised. Doing so will result in the CvsInSightLockedException. If an asynchronous connection is already in progress or an established connection has an open messagebox, the CvsInSightLockedException will be thrown. Other exceptions will not be thrown from this Connect method, but rather they will be reported in the Exception property that is reported with the ConnectCompleted event.

The method Disconnect()()()() should always be called before exiting an application that has made a connection to a sensor. If asynchronous is false, this method will disconnect a connection before establishing a new one.

If the forceConnect is true, any existing connection to the In-Sight sensor from the same or another PC will be broken, unless that connection was etablished with the ExclusiveConnection property set to true.

IMPORTANT NOTE: All events generated by an instance of this class will be raised on the same thread that called the this method. If this method is called on another thread, then the instance MUST NOT be connected to a CvsInSightDisplay. The thread that calls this method is expected to have a message pump.

Events

Event Type | Reason
CvsInSight..::..ConnectCompleted | Raised when the asynchronous connection is complete. NOTE: This event must be handled for asynchronous connections.
CvsInSight..::..StateChanged | Raised when the connection is complete and the State property is updated.
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.
CvsInSight..::..SensorChanged | Raised when the Sensor property is updated with new sensor information.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The ConnectCompleted event must be subscribed to in order to connect asynchronously.
Cognex.InSight..::..CvsInSightLockedException | The In-Sight sensor is locked and unable to accept a connection or an asynchronous connection is already in progress. See ExclusiveConnection for more information on explicitly locking the In-Sight connection.
Cognex.InSight..::..CvsNetworkException | The connection to the specified In-Sight sensor could not be completed. This may be because the wrong address was specified, the hostName could not be resolved, or some other low-level or network condition is preventing the connection.
Cognex.InSight..::..CvsInvalidLogonException | An Invalid user name or password was specified.
Cognex.InSight..::..CvsSensorAlreadyConnectedException | There is already a local or remote connection to the In-Sight sensor.
CvsCdsLoginException | There was an error authenticating with the CDS server. This could be an incorrect username/password, a problem connecting to the server, or an error with the user account. Details on the specific failure are provided in the exception. If the sensor is in Classic authentication mode, this exception will not be thrown.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Connect Overload
Cognex.InSight Namespace


CvsInSight.Disconnect Method

[image]

In-Sight SDK
CvsInSight..::..Disconnect Method
CvsInSight Class See Also Send Feedback
Disconnects from the In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Disconnect()
Visual Basic
Public Sub Disconnect

Remarks

This method blocks until the connection is closed for synchronous connects or after a connection has been established. If an asynchronous connection is in progress, then this method will not block, but must allow the asynchronous thread to perform the close operation. This method should be called in order to close the connection when the CvsInSight object is to be used again. If the CvsInSight object is not to be used again, call the Dispose()()()() method instead.

Events

Event Type | Reason
CvsInSight..::..StateChanged | Raised when the State property is updated.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace
CvsInSight..::..Connect(IPAddress, String, String, Boolean, Boolean)


CvsInSight.Dispose Method

[image]

In-Sight SDK
CvsInSight..::..Dispose Method
CvsInSight Class See Also Send Feedback
Closes any connection that is open and releases all resources used by CvsInSight object.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual void Dispose()
Visual Basic
Public Overridable Sub Dispose

Implements

IDisposable..::..Dispose()()()()

Remarks

If a connection is still open to an In-Sight sensor, this method will block until the connection is closed.

The CvsInSight object must not be used after calling this method. Doing so may result in unpredictable operation. If the CvsInSight object is to be used again, call the Disconnect()()()() method instead.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.GetComment Method

[image] [image]

In-Sight SDK
CvsInSight..::..GetComment Method
CvsInSight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetComment(CvsCellLocation) | Gets the comment at the specified location.
Public method | GetComment(Int32, Int32) | Gets the comment at the specified location.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.GetComment Method (CvsCellLocation)

[image]

In-Sight SDK
CvsInSight..::..GetComment Method (CvsCellLocation)
CvsInSight Class See Also Send Feedback
Gets the comment at the specified location.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellComment GetComment(
    CvsCellLocation location
)
Visual Basic
Public Function GetComment (
    location As CvsCellLocation
) As CvsCellComment

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.

Return Value

Type: CvsCellComment
The CvsCellComment at the cell location, or Empty if no comment exists.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
GetComment Overload
Cognex.InSight Namespace


CvsInSight.GetComment Method (Int32, Int32)

[image]

In-Sight SDK
CvsInSight..::..GetComment Method (Int32, Int32)
CvsInSight Class See Also Send Feedback
Gets the comment at the specified location.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellComment GetComment(
    int row,
    int col
)
Visual Basic
Public Function GetComment (
    row As Integer,
    col As Integer
) As CvsCellComment

Parameters

row
Type: System..::..Int32
The cell's row location.
col
Type: System..::..Int32
The cell's column location.

Return Value

Type: CvsCellComment
The CvsCellComment at the cell location, or Empty if no comment exists.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
GetComment Overload
Cognex.InSight Namespace


CvsInSight.GetEasyView Method

[image]

In-Sight SDK
CvsInSight..::..GetEasyView Method
CvsInSight Class See Also Send Feedback
Gets the EasyView that is stored in the job.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEasyView GetEasyView()
Visual Basic
Public Function GetEasyView As CvsEasyView

Return Value

Type: CvsEasyView
A class that holds a list of CvsEasyViewItem objects.

Remarks

A new instance is constructed every time this method is called.

Whenever a new job is loaded, this method should be called to retrieve the current EasyView.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.GetSymbolicTagCollection Method

[image]

In-Sight SDK
CvsInSight..::..GetSymbolicTagCollection Method
CvsInSight Class See Also Send Feedback
Gets a collection of symbolic tags that are associated with cells in the job.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSymbolicTagCollection GetSymbolicTagCollection()
Visual Basic
Public Function GetSymbolicTagCollection As CvsSymbolicTagCollection

Return Value

Type: CvsSymbolicTagCollection
A collection of CvsSymbolicTag items.

Remarks

A new collection of symbolic tag items is constructed every time this method is called.

Whenever a new job is loaded, this method should be called to retrieve the current set of symbolic tags.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.ManualAcquire Method

[image] [image]

In-Sight SDK
CvsInSight..::..ManualAcquire Method
CvsInSight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ManualAcquire()()()() | Manually triggers an image acquisition.
Public method | ManualAcquire(Boolean) | Manually triggers an image acquisition and optionally waits for the results to be received.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.ManualAcquire Method

[image]

In-Sight SDK
CvsInSight..::..ManualAcquire Method
CvsInSight Class See Also Send Feedback
Manually triggers an image acquisition.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ManualAcquire()
Visual Basic
Public Sub ManualAcquire

Remarks

An acquisition will only be triggered by this command when online if the AcquireImage function has the trigger set to "Manual". When offline, the "Manual" checkbox must be checked.

This method will block the current thread until the results for an acquisition have been received. When the acquisition is complete and after this method has returned, the ResultsChanged event will be raised.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the acquisition is complete and the image, graphics and cell data from the acquisition have been collected into the Results.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsLiveAcquisitionException | LiveAcquisition is true
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
ManualAcquire Overload
Cognex.InSight Namespace


CvsInSight.ManualAcquire Method (Boolean)

[image]

In-Sight SDK
CvsInSight..::..ManualAcquire Method (Boolean)
CvsInSight Class See Also Send Feedback
Manually triggers an image acquisition and optionally waits for the results to be received.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ManualAcquire(
    bool wait
)
Visual Basic
Public Sub ManualAcquire (
    wait As Boolean
)

Parameters

wait
Type: System..::..Boolean
true designates that the calling thread should block until the In-Sight sensor processes the request. false designates an immediate return after making the request.

Remarks

An acquisition will only be triggered by this command when online if the AcquireImage function has the trigger set to "Manual". When offline, the "Manual" checkbox must be checked.

This method will optionally block the current thread until the results for an acquisition have been received. When the acquisition is complete and after this method has returned, the ResultsChanged event will be raised.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the acquisition is complete and the image, graphics and cell data from the acquisition have been collected into the Results.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsLiveAcquisitionException | LiveAcquisition is true
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
ManualAcquire Overload
Cognex.InSight Namespace


CvsInSight.ResetSystem Method

[image]

In-Sight SDK
CvsInSight..::..ResetSystem Method
CvsInSight Class See Also Send Feedback
Resets the In-Sight system and optionally tries to reconnect to it. This command is similar to physically cycling power on the system.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ResetSystem(
    bool waitForReconnect
)
Visual Basic
Public Sub ResetSystem (
    waitForReconnect As Boolean
)

Parameters

waitForReconnect
Type: System..::..Boolean
true designates that a reconnect will be attempted after the reboot.

Remarks

This method may take up to 15 seconds to break the connection to the In-Sight sensor. If it is necessary to reconnect, it may take 30 seconds or more to break and re-establish a connection.

Events

Event Type | Reason
CvsInSight..::..StateChanged | The State will be changed to NotConnected and will not reconnect, if waitForReconnect is false. If reconnecting, the operation will occur synchronously and another event will generated on connect.

Exceptions

Exception | Condition
Cognex.InSight.NativeMode..::..CvsNativeModeResponseException | User did not have full access or there was an error reading the response.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNetworkException | When reconnecting, the connection to the specified In-Sight sensor could not be completed. This may be because the sensor address changed or some other low-level or network condition is preventing the connection.
Cognex.InSight..::..CvsSensorAlreadyConnectedException | When reconnecting, there was already a local or remote connection to the In-Sight sensor. This may happen if another application on the same or another PC connects as the sensor is rebooting.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SetCellState Method

[image] [image]

In-Sight SDK
CvsInSight..::..SetCellState Method
CvsInSight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellState(CvsCellLocation, Boolean) | Sets the cell's state to either enabled or disabled.
Public method | SetCellState(Int32, Int32, Boolean) | Sets the cell's state to either enabled or disabled.
Public method | SetCellState(CvsCellLocation, CvsCellLocation, Boolean, Boolean) | Sets the cell's state to a reference.
Public method | SetCellState(Int32, Int32, Int32, Boolean, Int32, Boolean) | Sets the cell's state to a reference.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SetCellState Method (CvsCellLocation, Boolean)

[image]

In-Sight SDK
CvsInSight..::..SetCellState Method (CvsCellLocation, Boolean)
CvsInSight Class See Also Send Feedback
Sets the cell's state to either enabled or disabled.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetCellState(
    CvsCellLocation location,
    bool enabled
)
Visual Basic
Public Sub SetCellState (
    location As CvsCellLocation,
    enabled As Boolean
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.
enabled
Type: System..::..Boolean
true enables the cell and false disables it.

Remarks

This method will not return until the cell state change operation is complete.

This overload of this method is not available in COM/ActiveX applications.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the cell state has been accepted and the image, graphics and cell data from the most recent acquisition have been collected into the Results.
CvsInSight..::..InSightMessage | Raised if the sensor cannot perform the requested operation (e.g. it would created a circular cell reference).

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The location of the range of cells is not valid.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetCellState Overload
Cognex.InSight Namespace


CvsInSight.SetCellState Method (Int32, Int32, Boolean)

[image]

In-Sight SDK
CvsInSight..::..SetCellState Method (Int32, Int32, Boolean)
CvsInSight Class See Also Send Feedback
Sets the cell's state to either enabled or disabled.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetCellState(
    int row,
    int col,
    bool enabled
)
Visual Basic
Public Sub SetCellState (
    row As Integer,
    col As Integer,
    enabled As Boolean
)

Parameters

row
Type: System..::..Int32
The cell's row location.
col
Type: System..::..Int32
The cell's column location.
enabled
Type: System..::..Boolean
true enables the cell and false disables it.

Remarks

This method will not return until the cell state change operation is complete.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the cell state has been accepted and the image, graphics and cell data from the most recent acquisition have been collected into the Results.
CvsInSight..::..InSightMessage | Raised if the sensor cannot perform the requested operation (e.g. it would created a circular cell reference).

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The location of the range of cells is not valid.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetCellState Overload
Cognex.InSight Namespace


CvsInSight.SetCellState Method (CvsCellLocation, CvsCellLocation, Boolean, Boolean)

[image]

In-Sight SDK
CvsInSight..::..SetCellState Method (CvsCellLocation, CvsCellLocation, Boolean, Boolean)
CvsInSight Class See Also Send Feedback
Sets the cell's state to a reference.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetCellState(
    CvsCellLocation location,
    CvsCellLocation referenceLocation,
    bool absoluteRow,
    bool absoluteColumn
)
Visual Basic
Public Sub SetCellState (
    location As CvsCellLocation,
    referenceLocation As CvsCellLocation,
    absoluteRow As Boolean,
    absoluteColumn As Boolean
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.
referenceLocation
Type: Cognex.InSight..::..CvsCellLocation
The location of the referenced cell.
absoluteRow
Type: System..::..Boolean
true makes the row reference absolute; false makes the reference relative.
absoluteColumn
Type: System..::..Boolean
true makes the column reference absolute; false makes the reference relative.

Remarks

Each row and column may either be an absolute or relative reference.

This method will not return until the cell state change operation is complete.

This overload of this method is not available in COM/ActiveX applications.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the cell state has been accepted and the image, graphics and cell data from the most recent acquisition have been collected into the Results.
CvsInSight..::..InSightMessage | Raised if the sensor cannot perform the requested operation (e.g. it would created a circular cell reference).

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The location of the range of cells or referenced location is not valid.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetCellState Overload
Cognex.InSight Namespace


CvsInSight.SetCellState Method (Int32, Int32, Int32, Boolean, Int32, Boolean)

[image]

In-Sight SDK
CvsInSight..::..SetCellState Method (Int32, Int32, Int32, Boolean, Int32, Boolean)
CvsInSight Class See Also Send Feedback
Sets the cell's state to a reference.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetCellState(
    int row,
    int col,
    int referenceRow,
    bool absoluteRow,
    int referenceColumn,
    bool absoluteColumn
)
Visual Basic
Public Sub SetCellState (
    row As Integer,
    col As Integer,
    referenceRow As Integer,
    absoluteRow As Boolean,
    referenceColumn As Integer,
    absoluteColumn As Boolean
)

Parameters

row
Type: System..::..Int32
The cell's row location.
col
Type: System..::..Int32
The cell's column location.
referenceRow
Type: System..::..Int32
The row of the referenced cell.
absoluteRow
Type: System..::..Boolean
true makes the row reference absolute; false makes the reference relative.
referenceColumn
Type: System..::..Int32
The column of the referenced cell.
absoluteColumn
Type: System..::..Boolean
true makes the column reference absolute; false makes the reference relative.

Remarks

Each row and column may either be an absolute or relative reference.

This method will not return until the cell state change operation is complete.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the cell state has been accepted and the image, graphics and cell data from the most recent acquisition have been collected into the Results.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The location of the range of cells or referenced location is not valid.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetCellState Overload
Cognex.InSight Namespace


CvsInSight.SetCheckBox Method

[image] [image]

In-Sight SDK
CvsInSight..::..SetCheckBox Method
CvsInSight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCheckBox(CvsCellLocation, Boolean) | Sets a CheckBox control to the specified value.
Public method | SetCheckBox(Int32, Int32, Boolean) | Sets a CheckBox control to the specified value.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SetCheckBox Method (CvsCellLocation, Boolean)

[image]

In-Sight SDK
CvsInSight..::..SetCheckBox Method (CvsCellLocation, Boolean)
CvsInSight Class See Also Send Feedback
Sets a CheckBox control to the specified value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetCheckBox(
    CvsCellLocation location,
    bool cellValue
)
Visual Basic
Public Sub SetCheckBox (
    location As CvsCellLocation,
    cellValue As Boolean
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.
cellValue
Type: System..::..Boolean
The checked state for the cell.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the new value is reflected in the results.

This method remains operational even when the control's cell is disabled.

This overload of this method is not available in COM/ActiveX applications.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetCheckBox Overload
Cognex.InSight Namespace


CvsInSight.SetCheckBox Method (Int32, Int32, Boolean)

[image]

In-Sight SDK
CvsInSight..::..SetCheckBox Method (Int32, Int32, Boolean)
CvsInSight Class See Also Send Feedback
Sets a CheckBox control to the specified value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetCheckBox(
    int row,
    int col,
    bool cellValue
)
Visual Basic
Public Sub SetCheckBox (
    row As Integer,
    col As Integer,
    cellValue As Boolean
)

Parameters

row
Type: System..::..Int32
The cell's row location.
col
Type: System..::..Int32
The cell's column location.
cellValue
Type: System..::..Boolean
The checked state for the cell.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the new value is reflected in the results.

This method remains operational even when the control's cell is disabled.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetCheckBox Overload
Cognex.InSight Namespace


CvsInSight.SetComment Method

[image] [image]

In-Sight SDK
CvsInSight..::..SetComment Method
CvsInSight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetComment(CvsCellLocation, CvsCellComment) | Sets the comment at the location to the specified value.
Public method | SetComment(Int32, Int32, CvsCellComment) | Sets the comment at the location to the specified value.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SetComment Method (CvsCellLocation, CvsCellComment)

[image]

In-Sight SDK
CvsInSight..::..SetComment Method (CvsCellLocation, CvsCellComment)
CvsInSight Class See Also Send Feedback
Sets the comment at the location to the specified value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetComment(
    CvsCellLocation location,
    CvsCellComment comment
)
Visual Basic
Public Sub SetComment (
    location As CvsCellLocation,
    comment As CvsCellComment
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.
comment
Type: Cognex.InSight..::..CvsCellComment
The comment.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetComment Overload
Cognex.InSight Namespace


CvsInSight.SetComment Method (Int32, Int32, CvsCellComment)

[image]

In-Sight SDK
CvsInSight..::..SetComment Method (Int32, Int32, CvsCellComment)
CvsInSight Class See Also Send Feedback
Sets the comment at the location to the specified value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetComment(
    int row,
    int col,
    CvsCellComment comment
)
Visual Basic
Public Sub SetComment (
    row As Integer,
    col As Integer,
    comment As CvsCellComment
)

Parameters

row
Type: System..::..Int32
The cell's row location.
col
Type: System..::..Int32
The cell's column location.
comment
Type: Cognex.InSight..::..CvsCellComment
The comment.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetComment Overload
Cognex.InSight Namespace


CvsInSight.SetEasyView Method

[image]

In-Sight SDK
CvsInSight..::..SetEasyView Method
CvsInSight Class See Also Send Feedback
Sets the EasyView that is stored in the job.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetEasyView(
    CvsEasyView easyView
)
Visual Basic
Public Sub SetEasyView (
    easyView As CvsEasyView
)

Parameters

easyView
Type: Cognex.InSight..::..CvsEasyView
The instance that holds the EasyView items.

Remarks

Each item in the EasyView MUST already has a symbolic tag defined for the designated cell. Calling this method WILL NOT create or modify the symbolic tag associated with a cell.

Exceptions

Exception | Condition
System..::..ArgumentException | The EasyView has invalid entries.
Cognex.InSight..::..CvsNotOfflineException | The sensor must be offline to perform this operation.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SetEditGraphic Method

[image]

In-Sight SDK
CvsInSight..::..SetEditGraphic Method
CvsInSight Class See Also Send Feedback
Sets the coordinates of the graphical shape for the specified edit cell.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetEditGraphic(
    CvsGraphic graphic
)
Visual Basic
Public Sub SetEditGraphic (
    graphic As CvsGraphic
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphic
The graphic from which to extract the new coordinates.

Remarks

The cell at the row and column specified by the CellLocation property of the given graphic must contain an edit function. The following edit cell functions are supported: EditRegion, EditCircle, EditPoint, EditLine, and EditAnnulus. The corresponding graphic type must also be specified. (e.g. An EditRegion function requires a CvsGraphicRegion.)

This method will not return until the new coordinates have been set.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The graphic cell location did not reference a valid edit control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SetFloat Method

[image] [image]

In-Sight SDK
CvsInSight..::..SetFloat Method
CvsInSight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetFloat(CvsCellLocation, Single) | Sets an EditFloat control to the specified value.
Public method | SetFloat(Int32, Int32, Single) | Sets an EditFloat control to the specified value.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SetFloat Method (CvsCellLocation, Single)

[image]

In-Sight SDK
CvsInSight..::..SetFloat Method (CvsCellLocation, Single)
CvsInSight Class See Also Send Feedback
Sets an EditFloat control to the specified value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetFloat(
    CvsCellLocation location,
    float cellValue
)
Visual Basic
Public Sub SetFloat (
    location As CvsCellLocation,
    cellValue As Single
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.
cellValue
Type: System..::..Single
The floating point value for the cell.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the new value is reflected in the results.

This method remains operational even when the control's cell is disabled.

This overload of this method is not available in COM/ActiveX applications.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control or the value is out of range for the control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetFloat Overload
Cognex.InSight Namespace


CvsInSight.SetFloat Method (Int32, Int32, Single)

[image]

In-Sight SDK
CvsInSight..::..SetFloat Method (Int32, Int32, Single)
CvsInSight Class See Also Send Feedback
Sets an EditFloat control to the specified value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetFloat(
    int row,
    int col,
    float cellValue
)
Visual Basic
Public Sub SetFloat (
    row As Integer,
    col As Integer,
    cellValue As Single
)

Parameters

row
Type: System..::..Int32
The cell's row location.
col
Type: System..::..Int32
The cell's column location.
cellValue
Type: System..::..Single
The floating point value for the cell.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the new value is reflected in the results.

This method remains operational even when the control's cell is disabled.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control or the value is out of range for the control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetFloat Overload
Cognex.InSight Namespace


CvsInSight.SetInteger Method

[image] [image]

In-Sight SDK
CvsInSight..::..SetInteger Method
CvsInSight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetInteger(CvsCellLocation, Int32) | Sets an EditInt control to the specified value.
Public method | SetInteger(Int32, Int32, Int32) | Sets an EditInt control to the specified value.
Public method | SetInteger(CvsCellLocation, Int32, Boolean) | Sets an EditInt control to the specified value.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SetInteger Method (CvsCellLocation, Int32)

[image]

In-Sight SDK
CvsInSight..::..SetInteger Method (CvsCellLocation, Int32)
CvsInSight Class See Also Send Feedback
Sets an EditInt control to the specified value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetInteger(
    CvsCellLocation location,
    int cellValue
)
Visual Basic
Public Sub SetInteger (
    location As CvsCellLocation,
    cellValue As Integer
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.
cellValue
Type: System..::..Int32
The integer value for the cell.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the new value is reflected in the results.

This method remains operational even when the control's cell is disabled.

This overload of this method is not available in COM/ActiveX applications.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control or the value is out of range for the control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetInteger Overload
Cognex.InSight Namespace


CvsInSight.SetInteger Method (Int32, Int32, Int32)

[image]

In-Sight SDK
CvsInSight..::..SetInteger Method (Int32, Int32, Int32)
CvsInSight Class See Also Send Feedback
Sets an EditInt control to the specified value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetInteger(
    int row,
    int col,
    int cellValue
)
Visual Basic
Public Sub SetInteger (
    row As Integer,
    col As Integer,
    cellValue As Integer
)

Parameters

row
Type: System..::..Int32
The cell's row location.
col
Type: System..::..Int32
The cell's column location.
cellValue
Type: System..::..Int32
The integer value for the cell.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the new value is reflected in the results.

This method remains operational even when the control's cell is disabled.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control or the value is out of range for the control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetInteger Overload
Cognex.InSight Namespace


CvsInSight.SetInteger Method (CvsCellLocation, Int32, Boolean)

[image]

In-Sight SDK
CvsInSight..::..SetInteger Method (CvsCellLocation, Int32, Boolean)
CvsInSight Class See Also Send Feedback
Sets an EditInt control to the specified value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetInteger(
    CvsCellLocation location,
    int cellValue,
    bool wait
)
Visual Basic
Public Sub SetInteger (
    location As CvsCellLocation,
    cellValue As Integer,
    wait As Boolean
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.
cellValue
Type: System..::..Int32
The integer value for the cell.
wait
Type: System..::..Boolean
If true, do not return until new results are received; otherwise, return immediately.

Remarks

This method will block the current thread until the job has run if the wait parameter is set to true. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the new value is reflected in the results.

This method remains operational even when the control's cell is disabled.

This overload of this method is not available in COM/ActiveX applications.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control or the value is out of range for the control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetInteger Overload
Cognex.InSight Namespace


CvsInSight.SetListBoxIndex Method

[image] [image]

In-Sight SDK
CvsInSight..::..SetListBoxIndex Method
CvsInSight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetListBoxIndex(CvsCellLocation, Int32) | Sets a ListBox control to the specified value.
Public method | SetListBoxIndex(Int32, Int32, Int32) | Sets a ListBox control to the specified value.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SetListBoxIndex Method (CvsCellLocation, Int32)

[image]

In-Sight SDK
CvsInSight..::..SetListBoxIndex Method (CvsCellLocation, Int32)
CvsInSight Class See Also Send Feedback
Sets a ListBox control to the specified value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetListBoxIndex(
    CvsCellLocation location,
    int index
)
Visual Basic
Public Sub SetListBoxIndex (
    location As CvsCellLocation,
    index As Integer
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.
index
Type: System..::..Int32
The integer index for the cell.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the new value is reflected in the results.

This method remains operational even when the control's cell is disabled.

This overload of this method is not available in COM/ActiveX applications.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control or the index is out of range for the control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetListBoxIndex Overload
Cognex.InSight Namespace


CvsInSight.SetListBoxIndex Method (Int32, Int32, Int32)

[image]

In-Sight SDK
CvsInSight..::..SetListBoxIndex Method (Int32, Int32, Int32)
CvsInSight Class See Also Send Feedback
Sets a ListBox control to the specified value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetListBoxIndex(
    int row,
    int col,
    int index
)
Visual Basic
Public Sub SetListBoxIndex (
    row As Integer,
    col As Integer,
    index As Integer
)

Parameters

row
Type: System..::..Int32
The cell's row location.
col
Type: System..::..Int32
The cell's column location.
index
Type: System..::..Int32
The integer index for the cell.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the new value is reflected in the results.

This method remains operational even when the control's cell is disabled.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control or the index is out of range for the control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetListBoxIndex Overload
Cognex.InSight Namespace


CvsInSight.SetString Method

[image] [image]

In-Sight SDK
CvsInSight..::..SetString Method
CvsInSight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetString(CvsCellLocation, String) | Sets an EditString control to the specified value.
Public method | SetString(Int32, Int32, String) | Sets an EditString control to the specified value.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SetString Method (CvsCellLocation, String)

[image]

In-Sight SDK
CvsInSight..::..SetString Method (CvsCellLocation, String)
CvsInSight Class See Also Send Feedback
Sets an EditString control to the specified value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetString(
    CvsCellLocation location,
    string cellValue
)
Visual Basic
Public Sub SetString (
    location As CvsCellLocation,
    cellValue As String
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.
cellValue
Type: System..::..String
The string value for the cell.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the new value is reflected in the results.

This method remains operational even when the control's cell is disabled.

This overload of this method is not available in COM/ActiveX applications.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control or the length of cellValue is too long for the control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetString Overload
Cognex.InSight Namespace


CvsInSight.SetString Method (Int32, Int32, String)

[image]

In-Sight SDK
CvsInSight..::..SetString Method (Int32, Int32, String)
CvsInSight Class See Also Send Feedback
Sets an EditString control to the specified value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetString(
    int row,
    int col,
    string cellValue
)
Visual Basic
Public Sub SetString (
    row As Integer,
    col As Integer,
    cellValue As String
)

Parameters

row
Type: System..::..Int32
The cell's row location.
col
Type: System..::..Int32
The cell's column location.
cellValue
Type: System..::..String
The string value for the cell.

Remarks

This method will block the current thread until the job has run. When new results are generated, the ResultsChanged event will be raised. Because the In-Sight sensor may be generating results from other requests or job processing, there may be several ResultsChanged events generated before the new value is reflected in the results.

This method remains operational even when the control's cell is disabled.

Events

Event Type | Reason
CvsInSight..::..ResultsChanged | Raised when the Results property is updated with a new result set.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
System..::..ArgumentException | The cell location does not contain the correct control or the length of cellValue is too long for the control.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsCellProtectionException | The cell is protected and requires a license to run.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
SetString Overload
Cognex.InSight Namespace


CvsInSight.SetSymbolicTag Method

[image]

In-Sight SDK
CvsInSight..::..SetSymbolicTag Method
CvsInSight Class See Also Send Feedback
Sets the symbolic tag that is associated with a cell in the job.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetSymbolicTag(
    CvsCellLocation location,
    string name
)
Visual Basic
Public Sub SetSymbolicTag (
    location As CvsCellLocation,
    name As String
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.
name
Type: System..::..String
The name to associate with the cell.

Exceptions

Exception | Condition
System..::..ArgumentException | The tag name is not valid.
Cognex.InSight..::..CvsNotOfflineException | The sensor must be offline to perform this operation.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SetSymbolicTagCollection Method

[image]

In-Sight SDK
CvsInSight..::..SetSymbolicTagCollection Method
CvsInSight Class See Also Send Feedback
Sets the collection of symbolic tags that are associated with cells in the job.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetSymbolicTagCollection(
    CvsSymbolicTagCollection symbolicTags
)
Visual Basic
Public Sub SetSymbolicTagCollection (
    symbolicTags As CvsSymbolicTagCollection
)

Parameters

symbolicTags
Type: Cognex.InSight..::..CvsSymbolicTagCollection
A collection of CvsSymbolicTag items.

Exceptions

Exception | Condition
System..::..ArgumentException | A tag name of an item in the collection is not valid.
Cognex.InSight..::..CvsNotOfflineException | The sensor must be offline to perform this operation.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight Properties

[image] [image]

In-Sight SDK
CvsInSight Properties
CvsInSight Class See Also Send Feedback

The CvsInSight type exposes the following members.

Properties

 | Name | Description
Public property | Access | Gets the security access setting for the current connection to an In-Sight sensor.
Public property | AccessDowngraded | Returns true if the security access for the current connection was downgraded due to restrictions on multiple connections.
Public property | DiscreteOnline | Returns true (the usual case) if the discrete inputs of the In-Sight sensor will permit the sensor to go online, or false if a discrete input will prevent it from going online. This property also returns false when the In-Sight sensor is disconnected.
Public property | ExclusiveConnection | Gets or sets a flag that designates the locking of the connection to an In-Sight sensor.
Public property | File | Gets the object that holds the file management methods for a connection to an In-Sight sensor.
Public property | IsJobProtected | Gets a flag that designates whether or not the current job is protected.
Public property | JobInfo | Gets the object that holds the job information and view settings for a connection to an In-Sight sensor.
Public property | Language | Gets the language used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | LiveAcquisition | Gets or sets the live acquisition mode for the In-Sight sensor.
Public property | LocalIPAddress | Gets the local IP Address used for the current connection to an In-Sight sensor.
Public property | NativeOnline | Returns true (the usual case) when no native mode command has forced the In-Sight sensor into the offline state, or false if the Native Mode "Set Online false" (SO0) will prevent it from going online. This property also returns false when the In-Sight sensor is disconnected.
Public property | Password | Gets the password used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | RemoteIPAddress | Gets the IP Address used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | RemoteIPAddressString | Gets the IP Address used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | Results | Gets the most recent set of results from an acquisition.
Public property | Sensor | Gets the object that holds the sensor settings for a connection to an In-Sight sensor.
Public property | SoftOnline | Gets or sets the software online enabling flag. If true, and if the DiscreteOnline and NativeOnline flags are also true, then the In-Sight sensor will be in the online state.
Public property | State | Gets the state (NotConnected, Offline, Online) of the In-Sight sensor.
Public property | Username | Gets the user name used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.

See Also

CvsInSight Class
Cognex.InSight Namespace


CvsInSight.Access Property

[image]

In-Sight SDK
CvsInSight..::..Access Property
CvsInSight Class See Also Send Feedback
Gets the security access setting for the current connection to an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightSecurityAccess Access { get; }
Visual Basic
Public ReadOnly Property Access As CvsInSightSecurityAccess
    Get

Property Value

Type: CvsInSightSecurityAccess

Remarks

Returns None if the In-Sight sensor is disconnected.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.AccessDowngraded Property

[image]

In-Sight SDK
CvsInSight..::..AccessDowngraded Property
CvsInSight Class See Also Send Feedback
Returns true if the security access for the current connection was downgraded due to restrictions on multiple connections.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AccessDowngraded { get; }
Visual Basic
Public ReadOnly Property AccessDowngraded As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.DiscreteOnline Property

[image]

In-Sight SDK
CvsInSight..::..DiscreteOnline Property
CvsInSight Class See Also Send Feedback
Returns true (the usual case) if the discrete inputs of the In-Sight sensor will permit the sensor to go online, or false if a discrete input will prevent it from going online. This property also returns false when the In-Sight sensor is disconnected.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool DiscreteOnline { get; }
Visual Basic
Public ReadOnly Property DiscreteOnline As Boolean
    Get

Property Value

Type: Boolean

Remarks

The In-Sight sensor will go to the online state only if the DiscreteOnline, NativeOnline and SoftOnline properties are all true.

Events

Event Type | Reason
CvsInSight..::..StateChanged | Raised when the sensor reports that the value has changed.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.ExclusiveConnection Property

[image]

In-Sight SDK
CvsInSight..::..ExclusiveConnection Property
CvsInSight Class See Also Send Feedback
Gets or sets a flag that designates the locking of the connection to an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ExclusiveConnection { get; set; }
Visual Basic
Public Property ExclusiveConnection As Boolean
    Get
    Set

Property Value

Type: Boolean
true designates that the connection cannot be broken by another call to Connect(IPAddress, String, String, Boolean, Boolean) from the same or a different PC. The default value is false which designates that the connection may be broken by a call to Connect(IPAddress, String, String, Boolean, Boolean) with the forceConnect parameter set to true.

Remarks

Calling Connect(IPAddress, String, String, Boolean, Boolean) when another connection already exists with ExclusiveConnection set to true will cause the CvsInSightLockedException to be thrown.

Setting this property has no effect unless the sensor has firmware version 3.1 or later. Getting this property will always return false for sensors with firmware prior to version 3.1.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNetworkException | A network error occurred while getting or setting the property.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.File Property

[image]

In-Sight SDK
CvsInSight..::..File Property
CvsInSight Class See Also Send Feedback
Gets the object that holds the file management methods for a connection to an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsFileManager File { get; }
Visual Basic
Public ReadOnly Property File As CvsFileManager
    Get

Property Value

Type: CvsFileManager

Remarks

This object is always available, even when State is NotConnected. Accessing data from this object when not connected, however, will generate the CvsNotConnectedException.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.IsJobProtected Property

[image]

In-Sight SDK
CvsInSight..::..IsJobProtected Property
CvsInSight Class See Also Send Feedback
Gets a flag that designates whether or not the current job is protected.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsJobProtected { get; }
Visual Basic
Public ReadOnly Property IsJobProtected As Boolean
    Get

Property Value

Type: Boolean
Returns true if the job is protected, or false if it is not protected or there is no connection to a sensor.

Remarks

A protected job prevents users from changing, moving or deleting data within that job.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.JobInfo Property

[image]

In-Sight SDK
CvsInSight..::..JobInfo Property
CvsInSight Class See Also Send Feedback
Gets the object that holds the job information and view settings for a connection to an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsJobInfo JobInfo { get; }
Visual Basic
Public ReadOnly Property JobInfo As CvsJobInfo
    Get

Property Value

Type: CvsJobInfo

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.Language Property

[image]

In-Sight SDK
CvsInSight..::..Language Property
CvsInSight Class See Also Send Feedback
Gets the language used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightLanguage Language { get; }
Visual Basic
Public ReadOnly Property Language As CvsInSightLanguage
    Get

Property Value

Type: CvsInSightLanguage

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace
Connect


CvsInSight.LiveAcquisition Property

[image]

In-Sight SDK
CvsInSight..::..LiveAcquisition Property
CvsInSight Class See Also Send Feedback
Gets or sets the live acquisition mode for the In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool LiveAcquisition { get; set; }
Visual Basic
Public Property LiveAcquisition As Boolean
    Get
    Set

Property Value

Type: Boolean
The default value is false.

Remarks

If true, the In-Sight sensor will acquire images at full speed but not run the job. Not accessible if not connected. Not settable if the State is not offline.

Remarks

Returns false if the In-Sight sensor is disconnected.

Events

Event Type | Reason
CvsInSight..::..LiveAcquisitionChanged | Raised when the value has changed.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | Property is set to true when the State is NotConnected.
Cognex.InSight..::..CvsNotOfflineException | Property is set to true when the State is Online.
Cognex.InSight..::..CvsNetworkException | A network error occurred while sending the request the change the mode.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.LocalIPAddress Property

[image]

In-Sight SDK
CvsInSight..::..LocalIPAddress Property
CvsInSight Class See Also Send Feedback
Gets the local IP Address used for the current connection to an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress LocalIPAddress { get; }
Visual Basic
Public ReadOnly Property LocalIPAddress As IPAddress
    Get

Property Value

Type: IPAddress
The IP address of the local host or null if not connected.

Remarks

This property is only available in .NET applications.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace
Connect


CvsInSight.NativeOnline Property

[image]

In-Sight SDK
CvsInSight..::..NativeOnline Property
CvsInSight Class See Also Send Feedback
Returns true (the usual case) when no native mode command has forced the In-Sight sensor into the offline state, or false if the Native Mode "Set Online false" (SO0) will prevent it from going online. This property also returns false when the In-Sight sensor is disconnected.
Gets false if the will block the In-Sight sensor from going online. This is typically true.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool NativeOnline { get; }
Visual Basic
Public ReadOnly Property NativeOnline As Boolean
    Get

Property Value

Type: Boolean

Remarks

The In-Sight sensor will go to the online state only if the DiscreteOnline, NativeOnline and SoftOnline properties are all true.

Events

Event Type | Reason
CvsInSight..::..StateChanged | Raised when the sensor reports that the value has changed.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.Password Property

[image]

In-Sight SDK
CvsInSight..::..Password Property
CvsInSight Class See Also Send Feedback
Gets the password used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Password { get; }
Visual Basic
Public ReadOnly Property Password As String
    Get

Property Value

Type: String

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace
Connect


CvsInSight.RemoteIPAddress Property

[image]

In-Sight SDK
CvsInSight..::..RemoteIPAddress Property
CvsInSight Class See Also Send Feedback
Gets the IP Address used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress RemoteIPAddress { get; }
Visual Basic
Public ReadOnly Property RemoteIPAddress As IPAddress
    Get

Property Value

Type: IPAddress

Remarks

This property is only available in .NET applications. To obtain an an IP address for use in COM/ActiveX applications, use the RemoteIPAddressString property instead.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace
Connect


CvsInSight.RemoteIPAddressString Property

[image]

In-Sight SDK
CvsInSight..::..RemoteIPAddressString Property
CvsInSight Class See Also Send Feedback
Gets the IP Address used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string RemoteIPAddressString { get; }
Visual Basic
Public ReadOnly Property RemoteIPAddressString As String
    Get

Property Value

Type: String

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace
Connect


CvsInSight.Results Property

[image]

In-Sight SDK
CvsInSight..::..Results Property
CvsInSight Class See Also Send Feedback
Gets the most recent set of results from an acquisition.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsResultSet Results { get; }
Visual Basic
Public ReadOnly Property Results As CvsResultSet
    Get

Property Value

Type: CvsResultSet

Remarks

This includes the image, graphics, and cell data associated with an acquisition. Returns an empty result set if the In-Sight sensor is disconnected.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.Sensor Property

[image]

In-Sight SDK
CvsInSight..::..Sensor Property
CvsInSight Class See Also Send Feedback
Gets the object that holds the sensor settings for a connection to an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSensor Sensor { get; }
Visual Basic
Public ReadOnly Property Sensor As CvsSensor
    Get

Property Value

Type: CvsSensor

Remarks

This object is always available, even when State is NotConnected. Accessing data from this object when not connected, however, will generate the CvsNotConnectedException.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SoftOnline Property

[image]

In-Sight SDK
CvsInSight..::..SoftOnline Property
CvsInSight Class See Also Send Feedback
Gets or sets the software online enabling flag. If true, and if the DiscreteOnline and NativeOnline flags are also true, then the In-Sight sensor will be in the online state.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SoftOnline { get; set; }
Visual Basic
Public Property SoftOnline As Boolean
    Get
    Set

Property Value

Type: Boolean
The default value varies according to the job. A job may either specify to start in the online or offline state.

Remarks

When the CvsInSight is not connected to a sensor, this property returns false and setting it to true will generate an exception.

Setting this property will not return until the new state is returned from the In-Sight sensor.

Events

Event Type | Reason
CvsInSight..::..StateChanged | Raised after the sensor echoes back the state.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | Property is set to true when the State is NotConnected.
Cognex.InSight..::..CvsNetworkException | A network error occurred while sending the request to change the state.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace
Connect


CvsInSight.State Property

[image]

In-Sight SDK
CvsInSight..::..State Property
CvsInSight Class See Also Send Feedback
Gets the state (NotConnected, Offline, Online) of the In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightState State { get; }
Visual Basic
Public ReadOnly Property State As CvsInSightState
    Get

Property Value

Type: CvsInSightState

Remarks

The In-Sight sensor will be in the online state when the SoftOnline, NativeOnline, and DiscreteOnline properties are all true.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.Username Property

[image]

In-Sight SDK
CvsInSight..::..Username Property
CvsInSight Class See Also Send Feedback
Gets the user name used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Username { get; }
Visual Basic
Public ReadOnly Property Username As String
    Get

Property Value

Type: String

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace
Connect


CvsInSight Events

[image] [image]

In-Sight SDK
CvsInSight Events
CvsInSight Class See Also Send Feedback

The CvsInSight type exposes the following members.

Events

 | Name | Description
Public event | ConnectCompleted | The ConnectCompleted event is raised when an asynchronous Connect(IPAddress, String, String, Boolean, Boolean) call has completed. The event arguments indicate whether an exception was generated while attempting the connection.
Public event | InSightMessage | The InSightMessage event is raised when the connected In-Sight sensor sends an informational message.
Public event | LiveAcquisitionChanged | The LiveAcquisitionChanged event is raised when the LiveAcquisition property has changed.
Public event | LoadCompleted | The LoadCompleted event is raised when a file load operation is complete.
Public event | ResultsChanged | The ResultsChanged event is raised when the Results property has changed.
Public event | SaveCompleted | The SaveCompleted event is raised when a file save operation is complete.
Public event | SensorChanged | The SensorChanged event is raised when one or more properties or sub-objects in the Sensor changed.
Public event | StateChanged | The StateChanged event is raised when the State, SoftOnline, NativeOnline, or DiscreteOnline properties changed.

See Also

CvsInSight Class
Cognex.InSight Namespace


CvsInSight.ConnectCompleted Event

[image]

In-Sight SDK
CvsInSight..::..ConnectCompleted Event
CvsInSight Class See Also Send Feedback
The ConnectCompleted event is raised when an asynchronous Connect(IPAddress, String, String, Boolean, Boolean) call has completed. The event arguments indicate whether an exception was generated while attempting the connection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public event CvsConnectCompletedEventHandler ConnectCompleted
Visual Basic
Public Event ConnectCompleted As CvsConnectCompletedEventHandler

Value

Type: Cognex.InSight..::..CvsConnectCompletedEventHandler

Remarks

This event is raised on the same thread that called the Connect(IPAddress, String, String, Boolean, Boolean) method.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.InSightMessage Event

[image]

In-Sight SDK
CvsInSight..::..InSightMessage Event
CvsInSight Class See Also Send Feedback
The InSightMessage event is raised when the connected In-Sight sensor sends an informational message.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public event CvsInSightMessageEventHandler InSightMessage
Visual Basic
Public Event InSightMessage As CvsInSightMessageEventHandler

Value

Type: Cognex.InSight..::..CvsInSightMessageEventHandler

Remarks

Typically a messagebox may be opened in response to this event.

This event is raised on the same thread that called the Connect(IPAddress, String, String, Boolean, Boolean) method.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.LiveAcquisitionChanged Event

[image]

In-Sight SDK
CvsInSight..::..LiveAcquisitionChanged Event
CvsInSight Class See Also Send Feedback
The LiveAcquisitionChanged event is raised when the LiveAcquisition property has changed.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler LiveAcquisitionChanged
Visual Basic
Public Event LiveAcquisitionChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

This event is raised on the same thread that called the Connect(IPAddress, String, String, Boolean, Boolean) method.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.LoadCompleted Event

[image]

In-Sight SDK
CvsInSight..::..LoadCompleted Event
CvsInSight Class See Also Send Feedback
The LoadCompleted event is raised when a file load operation is complete.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public event CvsLoadCompletedEventHandler LoadCompleted
Visual Basic
Public Event LoadCompleted As CvsLoadCompletedEventHandler

Value

Type: Cognex.InSight..::..CvsLoadCompletedEventHandler

Remarks

This event is generated when a new job is loaded as the current job on the sensor, or an image is loaded into the sensor. The CvsLoadCompletedEventArgs designates the success or failure of the load operation.

This event is raised on the same thread that called the Connect(IPAddress, String, String, Boolean, Boolean) method.

This event will not be raised if a job is loaded via the native mode 'LF' command.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.ResultsChanged Event

[image]

In-Sight SDK
CvsInSight..::..ResultsChanged Event
CvsInSight Class See Also Send Feedback
The ResultsChanged event is raised when the Results property has changed.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler ResultsChanged
Visual Basic
Public Event ResultsChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

This event is raised on the same thread that called the Connect(IPAddress, String, String, Boolean, Boolean) method.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SaveCompleted Event

[image]

In-Sight SDK
CvsInSight..::..SaveCompleted Event
CvsInSight Class See Also Send Feedback
The SaveCompleted event is raised when a file save operation is complete.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public event CvsSaveCompletedEventHandler SaveCompleted
Visual Basic
Public Event SaveCompleted As CvsSaveCompletedEventHandler

Value

Type: Cognex.InSight..::..CvsSaveCompletedEventHandler

Remarks

This event is generated when the current job is saved on the sensor's file system. The CvsSaveCompletedEventArgs designates the success or failure of the save operation.

This event is raised on the same thread that called the Connect(IPAddress, String, String, Boolean, Boolean) method.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.SensorChanged Event

[image]

In-Sight SDK
CvsInSight..::..SensorChanged Event
CvsInSight Class See Also Send Feedback
The SensorChanged event is raised when one or more properties or sub-objects in the Sensor changed.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler SensorChanged
Visual Basic
Public Event SensorChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

This event is raised on the same thread that called the Connect(IPAddress, String, String, Boolean, Boolean) method.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSight.StateChanged Event

[image]

In-Sight SDK
CvsInSight..::..StateChanged Event
CvsInSight Class See Also Send Feedback
The StateChanged event is raised when the State, SoftOnline, NativeOnline, or DiscreteOnline properties changed.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public event CvsStateChangedEventHandler StateChanged
Visual Basic
Public Event StateChanged As CvsStateChangedEventHandler

Value

Type: Cognex.InSight..::..CvsStateChangedEventHandler

Remarks

This event is raised on the same thread that called the Connect(IPAddress, String, String, Boolean, Boolean) method.

See Also

CvsInSight Class
CvsInSight..::..CvsInSight Members
Cognex.InSight Namespace


CvsInSightLanguage Enumeration

[image]

In-Sight SDK
CvsInSightLanguage Enumeration
See Also Send Feedback
Defines the possible languages to designate for a connection to an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public enum CvsInSightLanguage
Visual Basic
<SerializableAttribute>
Public Enumeration CvsInSightLanguage

Members

Member name | Value | Description
English | 0 | Designates English language messages.
French | 1 | Designates French language messages.
Japanese | 2 | Designates Japanese language messages.
German | 3 | Designates German language messages.
Spanish | 4 | Designates Spanish language messages.
Italian | 5 | Designates Italian language messages.
JapaneseSJIS2 | 6 | Designates Japanese language messages. (Full SJIS, both level 1 and 2)
SimplifiedChinese | 7 | Designates Simplified Chinese language messages. (GB2312)
TraditionalChinese | 8 | Designates Traditional Chinese language messages.
Korean | 9 | Designates Korean language messages. (EUC-KR)

See Also

Cognex.InSight Namespace
CvsInSight..::..Connect(IPAddress, String, String, Boolean, Boolean)


CvsInSightLockedException Class

[image]

In-Sight SDK
CvsInSightLockedException Class
Members See Also Send Feedback
The exception that is thrown when an In-Sight sensor is locked.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsInSightLockedException : CvsCommunicationException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsInSightLockedException
    Inherits CvsCommunicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsCommunicationException
Cognex.InSight..::..CvsInSightLockedException

See Also

CvsInSightLockedException..::..CvsInSightLockedException Members
Cognex.InSight Namespace
CvsInSightErrorInSightLockedException


CvsInSightLockedException Members

[image] [image]

In-Sight SDK
CvsInSightLockedException Members
CvsInSightLockedException Class Methods Properties See Also Send Feedback

The CvsInSightLockedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsInSightLockedException Class
Cognex.InSight Namespace


CvsInSightLockedException Methods

[image] [image]

In-Sight SDK
CvsInSightLockedException Methods
CvsInSightLockedException Class See Also Send Feedback

The CvsInSightLockedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsInSightLockedException Class
Cognex.InSight Namespace


CvsInSightLockedException Properties

[image] [image]

In-Sight SDK
CvsInSightLockedException Properties
CvsInSightLockedException Class See Also Send Feedback

The CvsInSightLockedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsInSightLockedException Class
Cognex.InSight Namespace


CvsInSightMessageEventArgs Class

[image]

In-Sight SDK
CvsInSightMessageEventArgs Class
Members See Also Send Feedback
Provides data for the InSightMessage event.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsInSightMessageEventArgs : EventArgs
Visual Basic
<SerializableAttribute>
Public Class CvsInSightMessageEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Cognex.InSight..::..CvsInSightMessageEventArgs

See Also

CvsInSightMessageEventArgs..::..CvsInSightMessageEventArgs Members
Cognex.InSight Namespace


CvsInSightMessageEventArgs Members

[image] [image]

In-Sight SDK
CvsInSightMessageEventArgs Members
CvsInSightMessageEventArgs Class Methods Properties See Also Send Feedback

The CvsInSightMessageEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Message | Gets the message.
Public property | MessageId | Gets the ID of the message.

See Also

CvsInSightMessageEventArgs Class
Cognex.InSight Namespace


CvsInSightMessageEventArgs Methods

[image] [image]

In-Sight SDK
CvsInSightMessageEventArgs Methods
CvsInSightMessageEventArgs Class See Also Send Feedback

The CvsInSightMessageEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsInSightMessageEventArgs Class
Cognex.InSight Namespace


CvsInSightMessageEventArgs Properties

[image] [image]

In-Sight SDK
CvsInSightMessageEventArgs Properties
CvsInSightMessageEventArgs Class See Also Send Feedback

The CvsInSightMessageEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Message | Gets the message.
Public property | MessageId | Gets the ID of the message.

See Also

CvsInSightMessageEventArgs Class
Cognex.InSight Namespace


CvsInSightMessageEventArgs.Message Property

[image]

In-Sight SDK
CvsInSightMessageEventArgs..::..Message Property
CvsInSightMessageEventArgs Class See Also Send Feedback
Gets the message.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get

Property Value

Type: String

See Also

CvsInSightMessageEventArgs Class
CvsInSightMessageEventArgs..::..CvsInSightMessageEventArgs Members
Cognex.InSight Namespace


CvsInSightMessageEventArgs.MessageId Property

[image]

In-Sight SDK
CvsInSightMessageEventArgs..::..MessageId Property
CvsInSightMessageEventArgs Class See Also Send Feedback
Gets the ID of the message.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightMessageId MessageId { get; }
Visual Basic
Public ReadOnly Property MessageId As CvsInSightMessageId
    Get

Property Value

Type: CvsInSightMessageId

Remarks

This property is only valid for 3.1 and newer firmware.

See Also

CvsInSightMessageEventArgs Class
CvsInSightMessageEventArgs..::..CvsInSightMessageEventArgs Members
Cognex.InSight Namespace


CvsInSightMessageEventHandler Delegate

[image]

In-Sight SDK
CvsInSightMessageEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the InSightMessage event.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public delegate void CvsInSightMessageEventHandler(
    Object sender,
    CvsInSightMessageEventArgs e
)
Visual Basic
Public Delegate Sub CvsInSightMessageEventHandler (
    sender As Object,
    e As CvsInSightMessageEventArgs
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Cognex.InSight..::..CvsInSightMessageEventArgs
A CvsInSightMessageEventArgs that contains the event data.

See Also

Cognex.InSight Namespace


CvsInSightMessageId Enumeration

[image]

In-Sight SDK
CvsInSightMessageId Enumeration
See Also Send Feedback
Defines the message identifiers that may be returned with the InSightMessage event.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public enum CvsInSightMessageId
Visual Basic
<SerializableAttribute>
Public Enumeration CvsInSightMessageId

Members

Member name | Value | Description
None | 0 | No message ID was specified.
TooManyDialogsError | 1963 | This version only supports a maximum of 20 dialogs per job.
LockedJobError | 1966 | The job is locked.
FileLoadError | 1967 | The load operation failed.
ExpressionSyntaxError | 1969 | The expression contained a syntax error.
ExpressionSizeError | 1970 | The expression string specified was too long.
ExpressionComplexityError | 1971 | The expression was too long or too complex.
MemoryAllocationError | 1972 | The memory allocation failed.
NotAllowedInDialogError | 1974 | The specified function is not allowed in a dialog.
MaxCellsError | 1975 | The operation would have exceeded the maximum spreadsheet size (cell count).
MaxReferenceDepthError | 1976 | The operation would have exceeded the maximum cell reference depth.
CircularReferenceError | 1977 | The operation would have caused a circular cell reference.
FileDeleteError | 1978 | The file delete operation failed.
FileSaveError | 1979 | The file save operation failed.
SaveMemoryError | 1980 | The flash memory is full. Could not save the job.
VersionLoadError | 1981 | The firmware version stored in the job does not match the sensor.
JobLanguageMismatch | 1982 | The language stored in the job does not match the current connection setting.
JobContentsError | 1983 | An error was encountered at the designated location while loading a job.
JobLoadError | 1984 | Failed to load the job file. The spreadsheet was initialized.
LockedJobLoadError | 1985 | The job is locked and could not be run on this system.
ReadPermissionsError | 1986 | The user does not have read permissions for the specified file.
LockedJobSaveWarning | 1987 | The MAC address specified in NodeLock() differs from the MAC address for this system. This job will not run on the system when loaded. It is recommended to add a second NodeLock() function that has no MAC address specified then save a backup job.
LockedJobSaveWarning2 | 1988 | This job cannot be edited the next time it is loaded. It is recommended to add a second NodeLock() function that has no MAC address specified then save a backup job.
PermissionDeniedError | 1989 | The user does not have permissions to perform the requested operation.
MiscError | 1993 | An error occurred during the operation.
LowMemoryError | 1994 | An invalid name was specified.
BlankRowsError | 1995 | Insufficient nonblank rows.

Remarks

This enumeration is only valid for 3.1 and newer firmware.

See Also

Cognex.InSight Namespace


CvsInSightPorts Enumeration

[image]

In-Sight SDK
CvsInSightPorts Enumeration
See Also Send Feedback
An enumeration of ports that may be in use on the In-Sight.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsInSightPorts
Visual Basic
Public Enumeration CvsInSightPorts

Members

Member name | Value | Description
ChromeInvalidPort | 1 | The port disallowed by Chrome.
Ftp | 21 | The port used by an FTP server.
SFtp | 22 | The port used by an SFTP server.
Telnet | 23 | The port used by a telnet server.
Http | 80 | The port used by an HTTP server.
Modbus | 502 | The port used by the modbus protocol.
Isp | 1069 | The port used by the In-Sight protocol.
MachineStatue | 1070 | The port used by the In-Sight machine status server.
FirmwareUpdateServer | 1212 | The port used by the firmware update server.
EthernetIpIo | 2222 | The port used by ethernet-ip protocol for I/O.
HmiServer | 8087 | The port used by the HMI server when in HTTP mode.
Https | 8443 | The port used by the HMI server when in HTTPS mode.
EthernetIpMessaging | 44818 | The port used by ethernet-ip protocol for messaging.
DataChannel | 50000 | The port used by the data channel server.

Remarks

The enumeration value is the default port number. However, some port numbers are configurable. Refer to the appropriate setting or use GetPortNumber(CvsInSightPorts, CvsSettings) or GetPortsInUse()()()()

See Also

Cognex.InSight Namespace


CvsInSightPortsExtensions Class

[image]

In-Sight SDK
CvsInSightPortsExtensions Class
Members See Also Send Feedback
Extension methods for CvsInSightPorts.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static class CvsInSightPortsExtensions
Visual Basic
<ExtensionAttribute>
Public NotInheritable Class CvsInSightPortsExtensions

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsInSightPortsExtensions

See Also

CvsInSightPortsExtensions..::..CvsInSightPortsExtensions Members
Cognex.InSight Namespace


CvsInSightPortsExtensions Members

[image] [image]

In-Sight SDK
CvsInSightPortsExtensions Members
CvsInSightPortsExtensions Class Methods See Also Send Feedback

The CvsInSightPortsExtensions type exposes the following members.

Methods

Name | Description
GetPortNumber | Returns the port number for the specified CvsInSightPorts.

See Also

CvsInSightPortsExtensions Class
Cognex.InSight Namespace


CvsInSightPortsExtensions Methods

[image] [image]

In-Sight SDK
CvsInSightPortsExtensions Methods
CvsInSightPortsExtensions Class See Also Send Feedback

The CvsInSightPortsExtensions type exposes the following members.

Methods

Name | Description
GetPortNumber | Returns the port number for the specified CvsInSightPorts.

See Also

CvsInSightPortsExtensions Class
Cognex.InSight Namespace


CvsInSightPortsExtensions.GetPortNumber Method

[image]

In-Sight SDK
CvsInSightPortsExtensions..::..GetPortNumber Method
CvsInSightPortsExtensions Class See Also Send Feedback
Returns the port number for the specified CvsInSightPorts.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static int GetPortNumber(
    this CvsInSightPorts port,
    CvsSettings settings
)
Visual Basic
<ExtensionAttribute>
Public Shared Function GetPortNumber (
    port As CvsInSightPorts,
    settings As CvsSettings
) As Integer

Parameters

port
Type: Cognex.InSight..::..CvsInSightPorts

[Missing <param name="port"/> documentation for "M:Cognex.InSight.CvsInSightPortsExtensions.GetPortNumber(Cognex.InSight.CvsInSightPorts,Cognex.InSight.Sensor.CvsSettings)"]

settings
Type: Cognex.InSight.Sensor..::..CvsSettings

[Missing <param name="settings"/> documentation for "M:Cognex.InSight.CvsInSightPortsExtensions.GetPortNumber(Cognex.InSight.CvsInSightPorts,Cognex.InSight.Sensor.CvsSettings)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Cognex.InSight.CvsInSightPortsExtensions.GetPortNumber(Cognex.InSight.CvsInSightPorts,Cognex.InSight.Sensor.CvsSettings)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CvsInSightPorts. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

CvsInSightPortsExtensions Class
CvsInSightPortsExtensions..::..CvsInSightPortsExtensions Members
Cognex.InSight Namespace


CvsInSightSecurityAccess Enumeration

[image]

In-Sight SDK
CvsInSightSecurityAccess Enumeration
See Also Send Feedback
Defines the security access privileges available when connected to an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsInSightSecurityAccess
Visual Basic
Public Enumeration CvsInSightSecurityAccess

Members

Member name | Value | Description
None | -1 | Specifies no access.
Full | 0 | Specifies full, administrative privileges.
Protected | 1 | Specifies protected, operator privileges.
Locked | 2 | Specifies locked, monitor-only privileges.

See Also

Cognex.InSight Namespace
CvsInSight..::..Access


CvsInSightSoftwareDevelopmentKit Class

[image]

In-Sight SDK
CvsInSightSoftwareDevelopmentKit Class
Members See Also Send Feedback
An abstract class to initialize the In-Sight Software Development Kit.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public abstract class CvsInSightSoftwareDevelopmentKit
Visual Basic
Public MustInherit Class CvsInSightSoftwareDevelopmentKit

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsInSightSoftwareDevelopmentKit

See Also

CvsInSightSoftwareDevelopmentKit..::..CvsInSightSoftwareDevelopmentKit Members
Cognex.InSight Namespace


CvsInSightSoftwareDevelopmentKit Members

[image] [image]

In-Sight SDK
CvsInSightSoftwareDevelopmentKit Members
CvsInSightSoftwareDevelopmentKit Class Constructors Methods See Also Send Feedback

The CvsInSightSoftwareDevelopmentKit type exposes the following members.

Constructors

 | Name | Description
Protected method | CvsInSightSoftwareDevelopmentKit | Initializes a new instance of the CvsInSightSoftwareDevelopmentKit class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Initializes the In-Sight Software Development Kit.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsInSightSoftwareDevelopmentKit Class
Cognex.InSight Namespace


CvsInSightSoftwareDevelopmentKit Constructor

[image]

In-Sight SDK
CvsInSightSoftwareDevelopmentKit Constructor
CvsInSightSoftwareDevelopmentKit Class See Also Send Feedback
Initializes a new instance of the CvsInSightSoftwareDevelopmentKit class

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
protected CvsInSightSoftwareDevelopmentKit()
Visual Basic
Protected Sub New

See Also

CvsInSightSoftwareDevelopmentKit Class
CvsInSightSoftwareDevelopmentKit..::..CvsInSightSoftwareDevelopmentKit Members
Cognex.InSight Namespace


CvsInSightSoftwareDevelopmentKit Methods

[image] [image]

In-Sight SDK
CvsInSightSoftwareDevelopmentKit Methods
CvsInSightSoftwareDevelopmentKit Class See Also Send Feedback

The CvsInSightSoftwareDevelopmentKit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Initializes the In-Sight Software Development Kit.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsInSightSoftwareDevelopmentKit Class
Cognex.InSight Namespace


CvsInSightSoftwareDevelopmentKit.Initialize Method

[image]

In-Sight SDK
CvsInSightSoftwareDevelopmentKit..::..Initialize Method
CvsInSightSoftwareDevelopmentKit Class See Also Send Feedback
Initializes the In-Sight Software Development Kit.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static void Initialize()
Visual Basic
Public Shared Sub Initialize

Remarks

Com/ActiveX applications should use the helper method CvsInSightSoftwareDevelopmentKitInitialize()()()().

See Also

CvsInSightSoftwareDevelopmentKit Class
CvsInSightSoftwareDevelopmentKit..::..CvsInSightSoftwareDevelopmentKit Members
Cognex.InSight Namespace


CvsInSightState Enumeration

[image]

In-Sight SDK
CvsInSightState Enumeration
See Also Send Feedback
Defines the possible states of the connection to an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public enum CvsInSightState
Visual Basic
<SerializableAttribute>
Public Enumeration CvsInSightState

Members

Member name | Value | Description
NotConnected | 0 | There is no current connection to an In-Sight sensor.
Offline | 1 | There is a connection to an offline In-Sight sensor.
Online | 2 | There is a connection to an online In-Sight sensor.

See Also

Cognex.InSight Namespace
CvsInSight..::..StateChanged
CvsInSight..::..State


CvsInSightStateChangedReason Enumeration

[image]

In-Sight SDK
CvsInSightStateChangedReason Enumeration
See Also Send Feedback
Defines the possible reasons that the state of the connection to the In-Sight sensor changed.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public enum CvsInSightStateChangedReason
Visual Basic
<SerializableAttribute>
Public Enumeration CvsInSightStateChangedReason

Members

Member name | Value | Description
Normal | 0 | The State changed by normal user intervention or programmatic means.
Timeout | 1 | The State changed to NotConnected because there was a network timeout error condition.
Restart | 2 | The State changed to NotConnected because the ResetSystem(Boolean) method was called.

See Also

Cognex.InSight Namespace
CvsInSight..::..StateChanged
CvsInSight..::..State


CvsInvalidInsertException Class

[image]

In-Sight SDK
CvsInvalidInsertException Class
Members See Also Send Feedback
The exception that is thown when a cell insertion fails.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public sealed class CvsInvalidInsertException : CvsException
Visual Basic
Public NotInheritable Class CvsInvalidInsertException
    Inherits CvsException

Remarks

If an insert would cause filled cells to move outside the range of the sheet, this exception may be thrown.

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsInvalidInsertException

See Also

CvsInvalidInsertException..::..CvsInvalidInsertException Members
Cognex.InSight Namespace


CvsInvalidInsertException Members

[image] [image]

In-Sight SDK
CvsInvalidInsertException Members
CvsInvalidInsertException Class Methods Properties See Also Send Feedback

The CvsInvalidInsertException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | CellLocation | Gets the location of the cell that is preventing the insertion.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsInvalidInsertException Class
Cognex.InSight Namespace


CvsInvalidInsertException Methods

[image] [image]

In-Sight SDK
CvsInvalidInsertException Methods
CvsInvalidInsertException Class See Also Send Feedback

The CvsInvalidInsertException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsInvalidInsertException Class
Cognex.InSight Namespace


CvsInvalidInsertException Properties

[image] [image]

In-Sight SDK
CvsInvalidInsertException Properties
CvsInvalidInsertException Class See Also Send Feedback

The CvsInvalidInsertException type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the location of the cell that is preventing the insertion.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsInvalidInsertException Class
Cognex.InSight Namespace


CvsInvalidInsertException.CellLocation Property

[image]

In-Sight SDK
CvsInvalidInsertException..::..CellLocation Property
CvsInvalidInsertException Class See Also Send Feedback
Gets the location of the cell that is preventing the insertion.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation CellLocation { get; }
Visual Basic
Public ReadOnly Property CellLocation As CvsCellLocation
    Get

Property Value

Type: CvsCellLocation

See Also

CvsInvalidInsertException Class
CvsInvalidInsertException..::..CvsInvalidInsertException Members
Cognex.InSight Namespace


CvsInvalidLogonException Class

[image]

In-Sight SDK
CvsInvalidLogonException Class
Members See Also Send Feedback
The exception that is thrown when an invalid username or password has been specified.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsInvalidLogonException : CvsException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsInvalidLogonException
    Inherits CvsException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsInvalidLogonException

See Also

CvsInvalidLogonException..::..CvsInvalidLogonException Members
Cognex.InSight Namespace
CvsInSightErrorInvalidLogonException


CvsInvalidLogonException Members

[image] [image]

In-Sight SDK
CvsInvalidLogonException Members
CvsInvalidLogonException Class Methods Properties See Also Send Feedback

The CvsInvalidLogonException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | IsInvalidUsername | Gets the flag that determines if the exception was due to an invalid user name.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsInvalidLogonException Class
Cognex.InSight Namespace


CvsInvalidLogonException Methods

[image] [image]

In-Sight SDK
CvsInvalidLogonException Methods
CvsInvalidLogonException Class See Also Send Feedback

The CvsInvalidLogonException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsInvalidLogonException Class
Cognex.InSight Namespace


CvsInvalidLogonException Properties

[image] [image]

In-Sight SDK
CvsInvalidLogonException Properties
CvsInvalidLogonException Class See Also Send Feedback

The CvsInvalidLogonException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | IsInvalidUsername | Gets the flag that determines if the exception was due to an invalid user name.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsInvalidLogonException Class
Cognex.InSight Namespace


CvsInvalidLogonException.IsInvalidUsername Property

[image]

In-Sight SDK
CvsInvalidLogonException..::..IsInvalidUsername Property
CvsInvalidLogonException Class See Also Send Feedback
Gets the flag that determines if the exception was due to an invalid user name.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsInvalidUsername { get; }
Visual Basic
Public ReadOnly Property IsInvalidUsername As Boolean
    Get

Property Value

Type: Boolean
true if the exception was due to an invalid username; false if the exception was due to an invalid password.

See Also

CvsInvalidLogonException Class
CvsInvalidLogonException..::..CvsInvalidLogonException Members
Cognex.InSight Namespace


CvsInvalidTimeException Class

[image]

In-Sight SDK
CvsInvalidTimeException Class
Members See Also Send Feedback
The exception that is thrown when an invalid username or password has been specified.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsInvalidTimeException : CvsException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsInvalidTimeException
    Inherits CvsException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsInvalidTimeException

See Also

CvsInvalidTimeException..::..CvsInvalidTimeException Members
Cognex.InSight Namespace
CvsInSightErrorInvalidLogonException


CvsInvalidTimeException Members

[image] [image]

In-Sight SDK
CvsInvalidTimeException Members
CvsInvalidTimeException Class Methods Properties See Also Send Feedback

The CvsInvalidTimeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InvalidTime | Gets the time that was invalid.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsInvalidTimeException Class
Cognex.InSight Namespace


CvsInvalidTimeException Methods

[image] [image]

In-Sight SDK
CvsInvalidTimeException Methods
CvsInvalidTimeException Class See Also Send Feedback

The CvsInvalidTimeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsInvalidTimeException Class
Cognex.InSight Namespace


CvsInvalidTimeException Properties

[image] [image]

In-Sight SDK
CvsInvalidTimeException Properties
CvsInvalidTimeException Class See Also Send Feedback

The CvsInvalidTimeException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InvalidTime | Gets the time that was invalid.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsInvalidTimeException Class
Cognex.InSight Namespace


CvsInvalidTimeException.InvalidTime Property

[image]

In-Sight SDK
CvsInvalidTimeException..::..InvalidTime Property
CvsInvalidTimeException Class See Also Send Feedback
Gets the time that was invalid.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public DateTime InvalidTime { get; }
Visual Basic
Public ReadOnly Property InvalidTime As DateTime
    Get

Property Value

Type: DateTime

See Also

CvsInvalidTimeException Class
CvsInvalidTimeException..::..CvsInvalidTimeException Members
Cognex.InSight Namespace


CvsJobInfo Class

[image]

In-Sight SDK
CvsJobInfo Class
Members See Also Send Feedback
Holds the information about the job loaded on an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsJobInfo : MarshalByRefObject,
    ICvsSheet
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsJobInfo
    Inherits MarshalByRefObject
    Implements ICvsSheet

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
Cognex.InSight..::..CvsJobInfo

See Also

CvsJobInfo..::..CvsJobInfo Members
Cognex.InSight Namespace


CvsJobInfo Members

[image] [image]

In-Sight SDK
CvsJobInfo Members
CvsJobInfo Class Methods Properties See Also Send Feedback

The CvsJobInfo type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsInCustomView | Returns true if the location is contained in any of the custom view.
Public method | SetCustomViewConditionalRefreshLocation | Sets the CustomViewConditionalRefreshLocation property, which is the location of the cell to use for conditionally refreshing the custom view.
Public method | SwitchAllCurrentViews | Switches all sheets to either the normal view or the custom view.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveJobFile | Gets the name of the active job.
Public property | AnyCustomViews | Returns true if any one of the sheets is showing a custom view.
Public property | CustomViewConditionalRefresh | Gets or sets a value designating the Conditional Refresh flag for the custom view.
Public property | CustomViewConditionalRefreshLocation | Gets or sets the location of the cell to use for conditionally refreshing the custom view.
Public property | HasCustomView | Returns true if any of the sheets has a custom view defined.
Public property | NumColumns | Gets the number of columns in the spreadsheet.
Public property | NumRows | Gets the number of rows in the spreadsheet.

See Also

CvsJobInfo Class
Cognex.InSight Namespace


CvsJobInfo Methods

[image] [image]

In-Sight SDK
CvsJobInfo Methods
CvsJobInfo Class See Also Send Feedback

The CvsJobInfo type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsInCustomView | Returns true if the location is contained in any of the custom view.
Public method | SetCustomViewConditionalRefreshLocation | Sets the CustomViewConditionalRefreshLocation property, which is the location of the cell to use for conditionally refreshing the custom view.
Public method | SwitchAllCurrentViews | Switches all sheets to either the normal view or the custom view.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsJobInfo Class
Cognex.InSight Namespace


CvsJobInfo.IsInCustomView Method

[image]

In-Sight SDK
CvsJobInfo..::..IsInCustomView Method
CvsJobInfo Class See Also Send Feedback
Returns true if the location is contained in any of the custom view.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsInCustomView(
    CvsCellLocation loc
)
Visual Basic
Public Function IsInCustomView (
    loc As CvsCellLocation
) As Boolean

Parameters

loc
Type: Cognex.InSight..::..CvsCellLocation
A CvsCellLocation.

Return Value

Type: Boolean
True if the location is contained by a custom view.

See Also

CvsJobInfo Class
CvsJobInfo..::..CvsJobInfo Members
Cognex.InSight Namespace


CvsJobInfo.SetCustomViewConditionalRefreshLocation Method

[image]

In-Sight SDK
CvsJobInfo..::..SetCustomViewConditionalRefreshLocation Method
CvsJobInfo Class See Also Send Feedback
Sets the CustomViewConditionalRefreshLocation property, which is the location of the cell to use for conditionally refreshing the custom view.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetCustomViewConditionalRefreshLocation(
    int row,
    int col
)
Visual Basic
Public Sub SetCustomViewConditionalRefreshLocation (
    row As Integer,
    col As Integer
)

Parameters

row
Type: System..::..Int32
The cell's row (vertical) coordinate.
col
Type: System..::..Int32
The cell's column (horizontal) coordinate.

Remarks

This method is provided for use in COM/ActiveX applications.

See Also

CvsJobInfo Class
CvsJobInfo..::..CvsJobInfo Members
Cognex.InSight Namespace


CvsJobInfo.SwitchAllCurrentViews Method

[image]

In-Sight SDK
CvsJobInfo..::..SwitchAllCurrentViews Method
CvsJobInfo Class See Also Send Feedback
Switches all sheets to either the normal view or the custom view.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SwitchAllCurrentViews(
    bool customView
)
Visual Basic
Public Sub SwitchAllCurrentViews (
    customView As Boolean
)

Parameters

customView
Type: System..::..Boolean
True is the sheets should switch to their custom view.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | The view change could not be sent to the sensor.

See Also

CvsJobInfo Class
CvsJobInfo..::..CvsJobInfo Members
Cognex.InSight Namespace


CvsJobInfo Properties

[image] [image]

In-Sight SDK
CvsJobInfo Properties
CvsJobInfo Class See Also Send Feedback

The CvsJobInfo type exposes the following members.

Properties

 | Name | Description
Public property | ActiveJobFile | Gets the name of the active job.
Public property | AnyCustomViews | Returns true if any one of the sheets is showing a custom view.
Public property | CustomViewConditionalRefresh | Gets or sets a value designating the Conditional Refresh flag for the custom view.
Public property | CustomViewConditionalRefreshLocation | Gets or sets the location of the cell to use for conditionally refreshing the custom view.
Public property | HasCustomView | Returns true if any of the sheets has a custom view defined.
Public property | NumColumns | Gets the number of columns in the spreadsheet.
Public property | NumRows | Gets the number of rows in the spreadsheet.

See Also

CvsJobInfo Class
Cognex.InSight Namespace


CvsJobInfo.ActiveJobFile Property

[image]

In-Sight SDK
CvsJobInfo..::..ActiveJobFile Property
CvsJobInfo Class See Also Send Feedback
Gets the name of the active job.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string ActiveJobFile { get; }
Visual Basic
Public ReadOnly Property ActiveJobFile As String
    Get

Property Value

Type: String

See Also

CvsJobInfo Class
CvsJobInfo..::..CvsJobInfo Members
Cognex.InSight Namespace


CvsJobInfo.AnyCustomViews Property

[image]

In-Sight SDK
CvsJobInfo..::..AnyCustomViews Property
CvsJobInfo Class See Also Send Feedback
Returns true if any one of the sheets is showing a custom view.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AnyCustomViews { get; }
Visual Basic
Public ReadOnly Property AnyCustomViews As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsJobInfo Class
CvsJobInfo..::..CvsJobInfo Members
Cognex.InSight Namespace


CvsJobInfo.CustomViewConditionalRefresh Property

[image]

In-Sight SDK
CvsJobInfo..::..CustomViewConditionalRefresh Property
CvsJobInfo Class See Also Send Feedback
Gets or sets a value designating the Conditional Refresh flag for the custom view.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CustomViewConditionalRefresh { get; set; }
Visual Basic
Public Property CustomViewConditionalRefresh As Boolean
    Get
    Set

Property Value

Type: Boolean

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | A network error occurred while setting the value.

See Also

CvsJobInfo Class
CvsJobInfo..::..CvsJobInfo Members
Cognex.InSight Namespace


CvsJobInfo.CustomViewConditionalRefreshLocation Property

[image]

In-Sight SDK
CvsJobInfo..::..CustomViewConditionalRefreshLocation Property
CvsJobInfo Class See Also Send Feedback
Gets or sets the location of the cell to use for conditionally refreshing the custom view.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation CustomViewConditionalRefreshLocation { get; set; }
Visual Basic
Public Property CustomViewConditionalRefreshLocation As CvsCellLocation
    Get
    Set

Property Value

Type: CvsCellLocation

Remarks

This property can also be set using the SetCustomViewConditionalRefreshLocation(Int32, Int32) method, which is the preferred method for COM/ActiveX applications.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value designates a row or column less than zero or greater than or equal to the total spreadsheet size.
Cognex.InSight..::..CvsNetworkException | A network error occurred while setting the value.

See Also

CvsJobInfo Class
CvsJobInfo..::..CvsJobInfo Members
Cognex.InSight Namespace


CvsJobInfo.HasCustomView Property

[image]

In-Sight SDK
CvsJobInfo..::..HasCustomView Property
CvsJobInfo Class See Also Send Feedback
Returns true if any of the sheets has a custom view defined.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool HasCustomView { get; }
Visual Basic
Public ReadOnly Property HasCustomView As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsJobInfo Class
CvsJobInfo..::..CvsJobInfo Members
Cognex.InSight Namespace


CvsJobInfo.NumColumns Property

[image]

In-Sight SDK
CvsJobInfo..::..NumColumns Property
CvsJobInfo Class See Also Send Feedback
Gets the number of columns in the spreadsheet.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NumColumns { get; }
Visual Basic
Public ReadOnly Property NumColumns As Integer
    Get

Property Value

Type: Int32

See Also

CvsJobInfo Class
CvsJobInfo..::..CvsJobInfo Members
Cognex.InSight Namespace


CvsJobInfo.NumRows Property

[image]

In-Sight SDK
CvsJobInfo..::..NumRows Property
CvsJobInfo Class See Also Send Feedback
Gets the number of rows in the spreadsheet.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NumRows { get; }
Visual Basic
Public ReadOnly Property NumRows As Integer
    Get

Property Value

Type: Int32

See Also

CvsJobInfo Class
CvsJobInfo..::..CvsJobInfo Members
Cognex.InSight Namespace


CvsLiveAcquisitionException Class

[image]

In-Sight SDK
CvsLiveAcquisitionException Class
Members See Also Send Feedback
The exception that is thrown when the requested operation cannot be performed because the sensor is acquiring live images.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsLiveAcquisitionException : CvsException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsLiveAcquisitionException
    Inherits CvsException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsLiveAcquisitionException

See Also

CvsLiveAcquisitionException..::..CvsLiveAcquisitionException Members
Cognex.InSight Namespace
CvsInSightErrorLiveAcquisitionException


CvsLiveAcquisitionException Members

[image] [image]

In-Sight SDK
CvsLiveAcquisitionException Members
CvsLiveAcquisitionException Class Methods Properties See Also Send Feedback

The CvsLiveAcquisitionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsLiveAcquisitionException Class
Cognex.InSight Namespace


CvsLiveAcquisitionException Methods

[image] [image]

In-Sight SDK
CvsLiveAcquisitionException Methods
CvsLiveAcquisitionException Class See Also Send Feedback

The CvsLiveAcquisitionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsLiveAcquisitionException Class
Cognex.InSight Namespace


CvsLiveAcquisitionException Properties

[image] [image]

In-Sight SDK
CvsLiveAcquisitionException Properties
CvsLiveAcquisitionException Class See Also Send Feedback

The CvsLiveAcquisitionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsLiveAcquisitionException Class
Cognex.InSight Namespace


CvsLoadCompletedEventArgs Class

[image]

In-Sight SDK
CvsLoadCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the LoadCompleted event.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsLoadCompletedEventArgs : EventArgs
Visual Basic
<SerializableAttribute>
Public Class CvsLoadCompletedEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Cognex.InSight..::..CvsLoadCompletedEventArgs

See Also

CvsLoadCompletedEventArgs..::..CvsLoadCompletedEventArgs Members
Cognex.InSight Namespace


CvsLoadCompletedEventArgs Members

[image] [image]

In-Sight SDK
CvsLoadCompletedEventArgs Members
CvsLoadCompletedEventArgs Class Methods Properties See Also Send Feedback

The CvsLoadCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | JobCreated | Gets the flag that designates whether or not a new, empty job was created.
Public property | JobLoaded | Gets the flag that designates whether or not the file loaded was a job file.
Public property | Succeeded | Gets the flag that designates the success or failure of the load operation.

See Also

CvsLoadCompletedEventArgs Class
Cognex.InSight Namespace


CvsLoadCompletedEventArgs Methods

[image] [image]

In-Sight SDK
CvsLoadCompletedEventArgs Methods
CvsLoadCompletedEventArgs Class See Also Send Feedback

The CvsLoadCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsLoadCompletedEventArgs Class
Cognex.InSight Namespace


CvsLoadCompletedEventArgs Properties

[image] [image]

In-Sight SDK
CvsLoadCompletedEventArgs Properties
CvsLoadCompletedEventArgs Class See Also Send Feedback

The CvsLoadCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | JobCreated | Gets the flag that designates whether or not a new, empty job was created.
Public property | JobLoaded | Gets the flag that designates whether or not the file loaded was a job file.
Public property | Succeeded | Gets the flag that designates the success or failure of the load operation.

See Also

CvsLoadCompletedEventArgs Class
Cognex.InSight Namespace


CvsLoadCompletedEventArgs.JobCreated Property

[image]

In-Sight SDK
CvsLoadCompletedEventArgs..::..JobCreated Property
CvsLoadCompletedEventArgs Class See Also Send Feedback
Gets the flag that designates whether or not a new, empty job was created.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool JobCreated { get; }
Visual Basic
Public ReadOnly Property JobCreated As Boolean
    Get

Property Value

Type: Boolean
true if the new, empty job file was created and false otherwise.

See Also

CvsLoadCompletedEventArgs Class
CvsLoadCompletedEventArgs..::..CvsLoadCompletedEventArgs Members
Cognex.InSight Namespace


CvsLoadCompletedEventArgs.JobLoaded Property

[image]

In-Sight SDK
CvsLoadCompletedEventArgs..::..JobLoaded Property
CvsLoadCompletedEventArgs Class See Also Send Feedback
Gets the flag that designates whether or not the file loaded was a job file.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool JobLoaded { get; }
Visual Basic
Public ReadOnly Property JobLoaded As Boolean
    Get

Property Value

Type: Boolean
true if the loaded file was a job file and false otherwise.

See Also

CvsLoadCompletedEventArgs Class
CvsLoadCompletedEventArgs..::..CvsLoadCompletedEventArgs Members
Cognex.InSight Namespace


CvsLoadCompletedEventArgs.Succeeded Property

[image]

In-Sight SDK
CvsLoadCompletedEventArgs..::..Succeeded Property
CvsLoadCompletedEventArgs Class See Also Send Feedback
Gets the flag that designates the success or failure of the load operation.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Succeeded { get; }
Visual Basic
Public ReadOnly Property Succeeded As Boolean
    Get

Property Value

Type: Boolean
true if the load operation was successful and false otherwise.

See Also

CvsLoadCompletedEventArgs Class
CvsLoadCompletedEventArgs..::..CvsLoadCompletedEventArgs Members
Cognex.InSight Namespace


CvsLoadCompletedEventHandler Delegate

[image]

In-Sight SDK
CvsLoadCompletedEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the LoadCompleted event.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public delegate void CvsLoadCompletedEventHandler(
    Object sender,
    CvsLoadCompletedEventArgs e
)
Visual Basic
Public Delegate Sub CvsLoadCompletedEventHandler (
    sender As Object,
    e As CvsLoadCompletedEventArgs
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Cognex.InSight..::..CvsLoadCompletedEventArgs
A CvsLoadCompletedEventArgs that contains the event data.

See Also

Cognex.InSight Namespace


CvsLocalStorageState Enumeration

[image]

In-Sight SDK
CvsLocalStorageState Enumeration
See Also Send Feedback
An enumeration of the different states for a sensor's SD Card (or Local Storage).

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsLocalStorageState
Visual Basic
Public Enumeration CvsLocalStorageState

Members

Member name | Value | Description
Unknown | 0 | The state of the SD Card is unknown.
Disabled | 1 | The SD Card is disabled.
Enabled | 2 | The SD Card is enabled.

See Also

Cognex.InSight Namespace


CvsModbusSettings Class

[image]

In-Sight SDK
CvsModbusSettings Class
Members See Also Send Feedback
Holds the modbus settings for an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsModbusSettings
Visual Basic
<SerializableAttribute>
Public Class CvsModbusSettings

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsModbusSettings

See Also

CvsModbusSettings..::..CvsModbusSettings Members
Cognex.InSight Namespace


CvsModbusSettings Members

[image] [image]

In-Sight SDK
CvsModbusSettings Members
CvsModbusSettings Class Methods Properties See Also Send Feedback

The CvsModbusSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IdleTimeout | Gets or sets the idle timeout value.
Public property | IdleTimeoutMax | Gets the idle timeout maximum value.
Public property | IdleTimeoutMin | Gets the idle timeout minimum value.
Public property | MaxConnections | Gets or sets the maximum connections value.
Public property | MaxConnectionsMax | Gets the maximum connections maximum value.
Public property | MaxConnectionsMin | Gets the maximum connections minimum value.

See Also

CvsModbusSettings Class
Cognex.InSight Namespace


CvsModbusSettings Methods

[image] [image]

In-Sight SDK
CvsModbusSettings Methods
CvsModbusSettings Class See Also Send Feedback

The CvsModbusSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsModbusSettings Class
Cognex.InSight Namespace


CvsModbusSettings.Clone Method

[image]

In-Sight SDK
CvsModbusSettings..::..Clone Method
CvsModbusSettings Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

See Also

CvsModbusSettings Class
CvsModbusSettings..::..CvsModbusSettings Members
Cognex.InSight Namespace


CvsModbusSettings Properties

[image] [image]

In-Sight SDK
CvsModbusSettings Properties
CvsModbusSettings Class See Also Send Feedback

The CvsModbusSettings type exposes the following members.

Properties

 | Name | Description
Public property | IdleTimeout | Gets or sets the idle timeout value.
Public property | IdleTimeoutMax | Gets the idle timeout maximum value.
Public property | IdleTimeoutMin | Gets the idle timeout minimum value.
Public property | MaxConnections | Gets or sets the maximum connections value.
Public property | MaxConnectionsMax | Gets the maximum connections maximum value.
Public property | MaxConnectionsMin | Gets the maximum connections minimum value.

See Also

CvsModbusSettings Class
Cognex.InSight Namespace


CvsModbusSettings.IdleTimeout Property

[image]

In-Sight SDK
CvsModbusSettings..::..IdleTimeout Property
CvsModbusSettings Class See Also Send Feedback
Gets or sets the idle timeout value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IdleTimeout { get; set; }
Visual Basic
Public Property IdleTimeout As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsModbusSettings Class
CvsModbusSettings..::..CvsModbusSettings Members
Cognex.InSight Namespace


CvsModbusSettings.IdleTimeoutMax Property

[image]

In-Sight SDK
CvsModbusSettings..::..IdleTimeoutMax Property
CvsModbusSettings Class See Also Send Feedback
Gets the idle timeout maximum value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IdleTimeoutMax { get; }
Visual Basic
Public ReadOnly Property IdleTimeoutMax As Integer
    Get

Property Value

Type: Int32

See Also

CvsModbusSettings Class
CvsModbusSettings..::..CvsModbusSettings Members
Cognex.InSight Namespace


CvsModbusSettings.IdleTimeoutMin Property

[image]

In-Sight SDK
CvsModbusSettings..::..IdleTimeoutMin Property
CvsModbusSettings Class See Also Send Feedback
Gets the idle timeout minimum value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IdleTimeoutMin { get; }
Visual Basic
Public ReadOnly Property IdleTimeoutMin As Integer
    Get

Property Value

Type: Int32

See Also

CvsModbusSettings Class
CvsModbusSettings..::..CvsModbusSettings Members
Cognex.InSight Namespace


CvsModbusSettings.MaxConnections Property

[image]

In-Sight SDK
CvsModbusSettings..::..MaxConnections Property
CvsModbusSettings Class See Also Send Feedback
Gets or sets the maximum connections value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxConnections { get; set; }
Visual Basic
Public Property MaxConnections As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsModbusSettings Class
CvsModbusSettings..::..CvsModbusSettings Members
Cognex.InSight Namespace


CvsModbusSettings.MaxConnectionsMax Property

[image]

In-Sight SDK
CvsModbusSettings..::..MaxConnectionsMax Property
CvsModbusSettings Class See Also Send Feedback
Gets the maximum connections maximum value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxConnectionsMax { get; }
Visual Basic
Public ReadOnly Property MaxConnectionsMax As Integer
    Get

Property Value

Type: Int32

See Also

CvsModbusSettings Class
CvsModbusSettings..::..CvsModbusSettings Members
Cognex.InSight Namespace


CvsModbusSettings.MaxConnectionsMin Property

[image]

In-Sight SDK
CvsModbusSettings..::..MaxConnectionsMin Property
CvsModbusSettings Class See Also Send Feedback
Gets the maximum connections minimum value.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxConnectionsMin { get; }
Visual Basic
Public ReadOnly Property MaxConnectionsMin As Integer
    Get

Property Value

Type: Int32

See Also

CvsModbusSettings Class
CvsModbusSettings..::..CvsModbusSettings Members
Cognex.InSight Namespace


CvsNetworkException Class

[image]

In-Sight SDK
CvsNetworkException Class
Members See Also Send Feedback
The exception that is thrown when a low-level network error occurs.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsNetworkException : CvsCommunicationException
Visual Basic
<SerializableAttribute>
Public Class CvsNetworkException
    Inherits CvsCommunicationException

Remarks

If a sensor cannot be located on the network or there is a problem communicating with a sensor, this exception may be thrown.

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsCommunicationException
Cognex.InSight..::..CvsNetworkException
Cognex.InSight..::..CvsTimeoutException

See Also

CvsNetworkException..::..CvsNetworkException Members
Cognex.InSight Namespace
CvsInSightErrorNetworkException


CvsNetworkException Members

[image] [image]

In-Sight SDK
CvsNetworkException Members
CvsNetworkException Class Methods Properties Events See Also Send Feedback

The CvsNetworkException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

CvsNetworkException Class
Cognex.InSight Namespace


CvsNetworkException Methods

[image] [image]

In-Sight SDK
CvsNetworkException Methods
CvsNetworkException Class See Also Send Feedback

The CvsNetworkException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsNetworkException Class
Cognex.InSight Namespace


CvsNetworkException Properties

[image] [image]

In-Sight SDK
CvsNetworkException Properties
CvsNetworkException Class See Also Send Feedback

The CvsNetworkException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsNetworkException Class
Cognex.InSight Namespace


CvsNetworkException Events

[image] [image]

In-Sight SDK
CvsNetworkException Events
CvsNetworkException Class See Also Send Feedback

The CvsNetworkException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

CvsNetworkException Class
Cognex.InSight Namespace


CvsNotConnectedException Class

[image]

In-Sight SDK
CvsNotConnectedException Class
Members See Also Send Feedback
The exception that is thrown when there is not an open connection to the sensor or the connection has been lost.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsNotConnectedException : CvsCommunicationException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsNotConnectedException
    Inherits CvsCommunicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsCommunicationException
Cognex.InSight..::..CvsNotConnectedException

See Also

CvsNotConnectedException..::..CvsNotConnectedException Members
Cognex.InSight Namespace
CvsInSightErrorNotConnectedException


CvsNotConnectedException Members

[image] [image]

In-Sight SDK
CvsNotConnectedException Members
CvsNotConnectedException Class Methods Properties See Also Send Feedback

The CvsNotConnectedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsNotConnectedException Class
Cognex.InSight Namespace


CvsNotConnectedException Methods

[image] [image]

In-Sight SDK
CvsNotConnectedException Methods
CvsNotConnectedException Class See Also Send Feedback

The CvsNotConnectedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsNotConnectedException Class
Cognex.InSight Namespace


CvsNotConnectedException Properties

[image] [image]

In-Sight SDK
CvsNotConnectedException Properties
CvsNotConnectedException Class See Also Send Feedback

The CvsNotConnectedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsNotConnectedException Class
Cognex.InSight Namespace


CvsNotLicensedException Class

[image]

In-Sight SDK
CvsNotLicensedException Class
Members See Also Send Feedback
The exception that is thrown when the application is not licensed for the In-Sight SDK.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsNotLicensedException : CvsException,
    ISerializable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsNotLicensedException
    Inherits CvsException
    Implements ISerializable

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsNotLicensedException

See Also

CvsNotLicensedException..::..CvsNotLicensedException Members
Cognex.InSight Namespace


CvsNotLicensedException Members

[image] [image]

In-Sight SDK
CvsNotLicensedException Members
CvsNotLicensedException Class Methods Properties See Also Send Feedback

The CvsNotLicensedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsNotLicensedException Class
Cognex.InSight Namespace


CvsNotLicensedException Methods

[image] [image]

In-Sight SDK
CvsNotLicensedException Methods
CvsNotLicensedException Class See Also Send Feedback

The CvsNotLicensedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsNotLicensedException Class
Cognex.InSight Namespace


CvsNotLicensedException Properties

[image] [image]

In-Sight SDK
CvsNotLicensedException Properties
CvsNotLicensedException Class See Also Send Feedback

The CvsNotLicensedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsNotLicensedException Class
Cognex.InSight Namespace


CvsNotOfflineException Class

[image]

In-Sight SDK
CvsNotOfflineException Class
Members See Also Send Feedback
The exception that is thrown when the requested operation cannot be performed because the sensor is not offline.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsNotOfflineException : CvsException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsNotOfflineException
    Inherits CvsException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsNotOfflineException

See Also

CvsNotOfflineException..::..CvsNotOfflineException Members
Cognex.InSight Namespace
CvsInSightErrorNotOfflineException


CvsNotOfflineException Members

[image] [image]

In-Sight SDK
CvsNotOfflineException Members
CvsNotOfflineException Class Methods Properties See Also Send Feedback

The CvsNotOfflineException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsNotOfflineException Class
Cognex.InSight Namespace


CvsNotOfflineException Methods

[image] [image]

In-Sight SDK
CvsNotOfflineException Methods
CvsNotOfflineException Class See Also Send Feedback

The CvsNotOfflineException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsNotOfflineException Class
Cognex.InSight Namespace


CvsNotOfflineException Properties

[image] [image]

In-Sight SDK
CvsNotOfflineException Properties
CvsNotOfflineException Class See Also Send Feedback

The CvsNotOfflineException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsNotOfflineException Class
Cognex.InSight Namespace


CvsPixelFormat Enumeration

[image]

In-Sight SDK
CvsPixelFormat Enumeration
See Also Send Feedback
Pixel formats supported by the PixelFormat property.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsPixelFormat
Visual Basic
Public Enumeration CvsPixelFormat

Members

Member name | Value | Description
Format8bppGrayscale | 1 | 8 bits per pixel, grayscale
Format16bppRgb565 | 3 | 16 bits per pixel, RGB packed 565 format
Format24bppRgb | 4 | 24 bits per pixel, RGB format
Format32bppRgb | 5 | 32 bits per pixel, 0RGB format

See Also

Cognex.InSight Namespace


CvsPowerlinkSettings Class

[image]

In-Sight SDK
CvsPowerlinkSettings Class
Members See Also Send Feedback
Holds the POWERLINK settings for an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsPowerlinkSettings
Visual Basic
<SerializableAttribute>
Public Class CvsPowerlinkSettings

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsPowerlinkSettings

See Also

CvsPowerlinkSettings..::..CvsPowerlinkSettings Members
Cognex.InSight Namespace


CvsPowerlinkSettings Members

[image] [image]

In-Sight SDK
CvsPowerlinkSettings Members
CvsPowerlinkSettings Class Methods Properties See Also Send Feedback

The CvsPowerlinkSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NodeID | Gets or sets the node.

See Also

CvsPowerlinkSettings Class
Cognex.InSight Namespace


CvsPowerlinkSettings Methods

[image] [image]

In-Sight SDK
CvsPowerlinkSettings Methods
CvsPowerlinkSettings Class See Also Send Feedback

The CvsPowerlinkSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsPowerlinkSettings Class
Cognex.InSight Namespace


CvsPowerlinkSettings.Clone Method

[image]

In-Sight SDK
CvsPowerlinkSettings..::..Clone Method
CvsPowerlinkSettings Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

See Also

CvsPowerlinkSettings Class
CvsPowerlinkSettings..::..CvsPowerlinkSettings Members
Cognex.InSight Namespace


CvsPowerlinkSettings Properties

[image] [image]

In-Sight SDK
CvsPowerlinkSettings Properties
CvsPowerlinkSettings Class See Also Send Feedback

The CvsPowerlinkSettings type exposes the following members.

Properties

 | Name | Description
Public property | NodeID | Gets or sets the node.

See Also

CvsPowerlinkSettings Class
Cognex.InSight Namespace


CvsPowerlinkSettings.NodeID Property

[image]

In-Sight SDK
CvsPowerlinkSettings..::..NodeID Property
CvsPowerlinkSettings Class See Also Send Feedback
Gets or sets the node.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NodeID { get; set; }
Visual Basic
Public Property NodeID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsPowerlinkSettings Class
CvsPowerlinkSettings..::..CvsPowerlinkSettings Members
Cognex.InSight Namespace


CvsReferenceRange Class

[image]

In-Sight SDK
CvsReferenceRange Class
Members See Also Send Feedback
Represents a range of cells that comprise a reference in a formula.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public class CvsReferenceRange
Visual Basic
Public Class CvsReferenceRange

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsReferenceRange

See Also

CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange Members

[image] [image]

In-Sight SDK
CvsReferenceRange Members
CvsReferenceRange Class Constructors Methods Fields Properties Events See Also Send Feedback

The CvsReferenceRange type exposes the following members.

Constructors

 | Name | Description
Public method | CvsReferenceRange()()()() | Initializes a new instance of the CvsReferenceRange class.
Public method | CvsReferenceRange(CvsReferenceRange) | Create a new instance of the CvsReferenceRange, copying the values from another CvsReferenceRange.
Public method | CvsReferenceRange(CvsCellRange, Color, Boolean, Boolean, Boolean, Boolean, Boolean) | Initializes a new instance of the CvsReferenceRange class.

Methods

 | Name | Description
Public method | Equals | Returns true if the given object is a CvsReferenceRange whose properties equal those of this CvsReferenceRange. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code based on the Range property. (Overrides Object..::..GetHashCode()()()().)
 | GetRangeColor | Gets a display color for a range based on a numerical index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAbsolute | Sets all of the absolute reference options.
Public method | ToString | Returns the canonical representation of the cell range. (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | mRange | The range of selected cells.

Properties

 | Name | Description
Public property | AbsoluteColumn | Gets or sets a value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute column reference (e.g. $B5:C6).
Public property | AbsoluteLastColumn | Gets or sets a value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute last column reference (e.g. B5:$C6).
Public property | AbsoluteLastRow | Gets or sets a value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute last row reference (e.g. B5:C$6).
Public property | AbsoluteRow | Gets or sets a value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute row reference (e.g. B$5:C6).
Public property | AllowResize | Gets or sets a value that designates if the range can be resized by the user.
Public property | Color | Gets the color in which the range is displayed.
Public property | Highlight | Gets or sets a value that indicates that the range should be displayed highlighted.
Public property | Range | Gets or sets the range of cells represented by this CvsReferenceRange object.

Events

 | Name | Description
Public event | AbsoluteChanged | Raised whenever AbsoluteColumn or AbsoluteRow or AbsoluteLastColumn or AbsoluteLastRow has changed.
Public event | HighlightChanged | Raised whenever Highlight has changed.
Public event | RangeChanged | Raised whenever Range has changed.

See Also

CvsReferenceRange Class
Cognex.InSight Namespace


CvsReferenceRange Constructor

[image] [image]

In-Sight SDK
CvsReferenceRange Constructor
CvsReferenceRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsReferenceRange()()()() | Initializes a new instance of the CvsReferenceRange class.
Public method | CvsReferenceRange(CvsReferenceRange) | Create a new instance of the CvsReferenceRange, copying the values from another CvsReferenceRange.
Public method | CvsReferenceRange(CvsCellRange, Color, Boolean, Boolean, Boolean, Boolean, Boolean) | Initializes a new instance of the CvsReferenceRange class.

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange Constructor

[image]

In-Sight SDK
CvsReferenceRange Constructor
CvsReferenceRange Class See Also Send Feedback
Initializes a new instance of the CvsReferenceRange class.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsReferenceRange()
Visual Basic
Public Sub New

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
CvsReferenceRange Overload
Cognex.InSight Namespace


CvsReferenceRange Constructor (CvsReferenceRange)

[image]

In-Sight SDK
CvsReferenceRange Constructor (CvsReferenceRange)
CvsReferenceRange Class See Also Send Feedback
Create a new instance of the CvsReferenceRange, copying the values from another CvsReferenceRange.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsReferenceRange(
    CvsReferenceRange other
)
Visual Basic
Public Sub New (
    other As CvsReferenceRange
)

Parameters

other
Type: Cognex.InSight..::..CvsReferenceRange
The CvsReferenceRange whose values should be copied.

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
CvsReferenceRange Overload
Cognex.InSight Namespace


CvsReferenceRange Constructor (CvsCellRange, Color, Boolean, Boolean, Boolean, Boolean, Boolean)

[image]

In-Sight SDK
CvsReferenceRange Constructor (CvsCellRange, Color, Boolean, Boolean, Boolean, Boolean, Boolean)
CvsReferenceRange Class See Also Send Feedback
Initializes a new instance of the CvsReferenceRange class.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsReferenceRange(
    CvsCellRange range,
    Color color,
    bool allowResize,
    bool absoluteRow,
    bool absoluteColumn,
    bool absoluteLastRow,
    bool absoluteLastColumn
)
Visual Basic
Public Sub New (
    range As CvsCellRange,
    color As Color,
    allowResize As Boolean,
    absoluteRow As Boolean,
    absoluteColumn As Boolean,
    absoluteLastRow As Boolean,
    absoluteLastColumn As Boolean
)

Parameters

range
Type: Cognex.InSight..::..CvsCellRange
The initial range of cells.
color
Type: System.Drawing..::..Color
The display color.
allowResize
Type: System..::..Boolean
true allows the range to be resized.
absoluteRow
Type: System..::..Boolean
If true, the string returned by ToString()()()() will include the $ symbol to represent an absolute row reference (e.g. B$5:C6).
absoluteColumn
Type: System..::..Boolean
If true, the string returned by ToString()()()() will include the $ symbol to represent an absolute column reference (e.g. $B5:C6).
absoluteLastRow
Type: System..::..Boolean
If true, the string returned by ToString()()()() will include the $ symbol to represent an absolute last row reference (e.g. B5:C$6).
absoluteLastColumn
Type: System..::..Boolean
If true, the string returned by ToString()()()() will include the $ symbol to represent an absolute last column reference (e.g. B5:$C6).

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
CvsReferenceRange Overload
Cognex.InSight Namespace


CvsReferenceRange Fields

[image] [image]

In-Sight SDK
CvsReferenceRange Fields
CvsReferenceRange Class See Also Send Feedback

The CvsReferenceRange type exposes the following members.

Fields

 | Name | Description
Protected field | mRange | The range of selected cells.

See Also

CvsReferenceRange Class
Cognex.InSight Namespace


CvsReferenceRange.mRange Field

[image]

In-Sight SDK
CvsReferenceRange..::..mRange Field
CvsReferenceRange Class See Also Send Feedback
The range of selected cells.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
protected CvsCellRange mRange
Visual Basic
Protected mRange As CvsCellRange

Field Value

Type: CvsCellRange

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange Methods

[image] [image]

In-Sight SDK
CvsReferenceRange Methods
CvsReferenceRange Class See Also Send Feedback

The CvsReferenceRange type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns true if the given object is a CvsReferenceRange whose properties equal those of this CvsReferenceRange. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code based on the Range property. (Overrides Object..::..GetHashCode()()()().)
 | GetRangeColor | Gets a display color for a range based on a numerical index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAbsolute | Sets all of the absolute reference options.
Public method | ToString | Returns the canonical representation of the cell range. (Overrides Object..::..ToString()()()().)

See Also

CvsReferenceRange Class
Cognex.InSight Namespace


CvsReferenceRange.Equals Method

[image]

In-Sight SDK
CvsReferenceRange..::..Equals Method
CvsReferenceRange Class See Also Send Feedback
Returns true if the given object is a CvsReferenceRange whose properties equal those of this CvsReferenceRange.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: System..::..Object
An object to compare with this instance.

Return Value

Type: Boolean
true if the ranges are equal.

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange.GetHashCode Method

[image]

In-Sight SDK
CvsReferenceRange..::..GetHashCode Method
CvsReferenceRange Class See Also Send Feedback
Gets a hash code based on the Range property.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash value for the current object.

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange.GetRangeColor Method

[image]

In-Sight SDK
CvsReferenceRange..::..GetRangeColor Method
CvsReferenceRange Class See Also Send Feedback
Gets a display color for a range based on a numerical index.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static Color GetRangeColor(
    int index
)
Visual Basic
Public Shared Function GetRangeColor (
    index As Integer
) As Color

Parameters

index
Type: System..::..Int32
The index into the array of colors.

Return Value

Type: Color
The color for the range.

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange.SetAbsolute Method

[image]

In-Sight SDK
CvsReferenceRange..::..SetAbsolute Method
CvsReferenceRange Class See Also Send Feedback
Sets all of the absolute reference options.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetAbsolute(
    bool absoluteColumn,
    bool absoluteRow,
    bool absoluteLastColumn,
    bool absoluteLastRow
)
Visual Basic
Public Sub SetAbsolute (
    absoluteColumn As Boolean,
    absoluteRow As Boolean,
    absoluteLastColumn As Boolean,
    absoluteLastRow As Boolean
)

Parameters

absoluteColumn
Type: System..::..Boolean
A value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute column reference (e.g. $B5:C6).
absoluteRow
Type: System..::..Boolean
A value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute row reference (e.g. B$5:C6).
absoluteLastColumn
Type: System..::..Boolean
A value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute last column reference (e.g. B5:$C6).
absoluteLastRow
Type: System..::..Boolean
A value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute last row reference (e.g. B5:C$6).

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange.ToString Method

[image]

In-Sight SDK
CvsReferenceRange..::..ToString Method
CvsReferenceRange Class See Also Send Feedback
Returns the canonical representation of the cell range.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of the cell range (e.g. A5:B6 for an relative cell range or $A$5:$B$6 for a cell range that has an absolute range).

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange Properties

[image] [image]

In-Sight SDK
CvsReferenceRange Properties
CvsReferenceRange Class See Also Send Feedback

The CvsReferenceRange type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteColumn | Gets or sets a value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute column reference (e.g. $B5:C6).
Public property | AbsoluteLastColumn | Gets or sets a value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute last column reference (e.g. B5:$C6).
Public property | AbsoluteLastRow | Gets or sets a value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute last row reference (e.g. B5:C$6).
Public property | AbsoluteRow | Gets or sets a value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute row reference (e.g. B$5:C6).
Public property | AllowResize | Gets or sets a value that designates if the range can be resized by the user.
Public property | Color | Gets the color in which the range is displayed.
Public property | Highlight | Gets or sets a value that indicates that the range should be displayed highlighted.
Public property | Range | Gets or sets the range of cells represented by this CvsReferenceRange object.

See Also

CvsReferenceRange Class
Cognex.InSight Namespace


CvsReferenceRange.AbsoluteColumn Property

[image]

In-Sight SDK
CvsReferenceRange..::..AbsoluteColumn Property
CvsReferenceRange Class See Also Send Feedback
Gets or sets a value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute column reference (e.g. $B5:C6).

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual bool AbsoluteColumn { get; set; }
Visual Basic
Public Overridable Property AbsoluteColumn As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange.AbsoluteLastColumn Property

[image]

In-Sight SDK
CvsReferenceRange..::..AbsoluteLastColumn Property
CvsReferenceRange Class See Also Send Feedback
Gets or sets a value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute last column reference (e.g. B5:$C6).

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual bool AbsoluteLastColumn { get; set; }
Visual Basic
Public Overridable Property AbsoluteLastColumn As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange.AbsoluteLastRow Property

[image]

In-Sight SDK
CvsReferenceRange..::..AbsoluteLastRow Property
CvsReferenceRange Class See Also Send Feedback
Gets or sets a value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute last row reference (e.g. B5:C$6).

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual bool AbsoluteLastRow { get; set; }
Visual Basic
Public Overridable Property AbsoluteLastRow As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange.AbsoluteRow Property

[image]

In-Sight SDK
CvsReferenceRange..::..AbsoluteRow Property
CvsReferenceRange Class See Also Send Feedback
Gets or sets a value that indicates the string returned by ToString()()()() will include the $ symbol to represent an absolute row reference (e.g. B$5:C6).

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual bool AbsoluteRow { get; set; }
Visual Basic
Public Overridable Property AbsoluteRow As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange.AllowResize Property

[image]

In-Sight SDK
CvsReferenceRange..::..AllowResize Property
CvsReferenceRange Class See Also Send Feedback
Gets or sets a value that designates if the range can be resized by the user.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual bool AllowResize { get; set; }
Visual Basic
Public Overridable Property AllowResize As Boolean
    Get
    Set

Property Value

Type: Boolean
true designates the range can be resized by the user; false designates its size must remain unchanged.

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange.Color Property

[image]

In-Sight SDK
CvsReferenceRange..::..Color Property
CvsReferenceRange Class See Also Send Feedback
Gets the color in which the range is displayed.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual Color Color { get; }
Visual Basic
Public Overridable ReadOnly Property Color As Color
    Get

Property Value

Type: Color

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange.Highlight Property

[image]

In-Sight SDK
CvsReferenceRange..::..Highlight Property
CvsReferenceRange Class See Also Send Feedback
Gets or sets a value that indicates that the range should be displayed highlighted.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual bool Highlight { get; set; }
Visual Basic
Public Overridable Property Highlight As Boolean
    Get
    Set

Property Value

Type: Boolean
true designates that the range should be displayed highlighted.

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange.Range Property

[image]

In-Sight SDK
CvsReferenceRange..::..Range Property
CvsReferenceRange Class See Also Send Feedback
Gets or sets the range of cells represented by this CvsReferenceRange object.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual CvsCellRange Range { get; set; }
Visual Basic
Public Overridable Property Range As CvsCellRange
    Get
    Set

Property Value

Type: CvsCellRange

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange Events

[image] [image]

In-Sight SDK
CvsReferenceRange Events
CvsReferenceRange Class See Also Send Feedback

The CvsReferenceRange type exposes the following members.

Events

 | Name | Description
Public event | AbsoluteChanged | Raised whenever AbsoluteColumn or AbsoluteRow or AbsoluteLastColumn or AbsoluteLastRow has changed.
Public event | HighlightChanged | Raised whenever Highlight has changed.
Public event | RangeChanged | Raised whenever Range has changed.

See Also

CvsReferenceRange Class
Cognex.InSight Namespace


CvsReferenceRange.AbsoluteChanged Event

[image]

In-Sight SDK
CvsReferenceRange..::..AbsoluteChanged Event
CvsReferenceRange Class See Also Send Feedback
Raised whenever AbsoluteColumn or AbsoluteRow or AbsoluteLastColumn or AbsoluteLastRow has changed.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual event EventHandler AbsoluteChanged
Visual Basic
Public Overridable Event AbsoluteChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange.HighlightChanged Event

[image]

In-Sight SDK
CvsReferenceRange..::..HighlightChanged Event
CvsReferenceRange Class See Also Send Feedback
Raised whenever Highlight has changed.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual event EventHandler HighlightChanged
Visual Basic
Public Overridable Event HighlightChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsReferenceRange.RangeChanged Event

[image]

In-Sight SDK
CvsReferenceRange..::..RangeChanged Event
CvsReferenceRange Class See Also Send Feedback
Raised whenever Range has changed.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual event EventHandler RangeChanged
Visual Basic
Public Overridable Event RangeChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsReferenceRange Class
CvsReferenceRange..::..CvsReferenceRange Members
Cognex.InSight Namespace


CvsResultSet Class

[image]

In-Sight SDK
CvsResultSet Class
Members See Also Send Feedback
Holds the image, graphics, and cells received from an In-Sight sensor.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsResultSet : IDisposable,
    IServiceProvider
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsResultSet
    Implements IDisposable, IServiceProvider

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsResultSet

See Also

CvsResultSet..::..CvsResultSet Members
Cognex.InSight Namespace


CvsResultSet Members

[image] [image]

In-Sight SDK
CvsResultSet Members
CvsResultSet Class Methods Properties See Also Send Feedback

The CvsResultSet type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases a reference to the object, freeing internal resources when all references have been released.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Gets the image associated with the specified sheet.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cells | Gets the collection of all cells in the spreadsheet.
Public property | Graphics | Gets the collection of graphics associated with the image.
Public property | HasNewlyAcquiredImage | Gets a flag that indicates if this rset of results contains a newly acquired image.
Public property | Id | Gets the ID number of the result set.
Public property | Image | Gets the acquired image.
Public property | Images | Gets the acquired image.
Public property | JobInfo | Gets the job information associated with the set of results.
Public property | ProcessorConstants | Gets the processor constants associated with the set of results.
Public property | StatusLevel | Gets the pass/warn/fail status.

See Also

CvsResultSet Class
Cognex.InSight Namespace


CvsResultSet Methods

[image] [image]

In-Sight SDK
CvsResultSet Methods
CvsResultSet Class See Also Send Feedback

The CvsResultSet type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases a reference to the object, freeing internal resources when all references have been released.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Gets the image associated with the specified sheet.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsResultSet Class
Cognex.InSight Namespace


CvsResultSet.Dispose Method

[image]

In-Sight SDK
CvsResultSet..::..Dispose Method
CvsResultSet Class See Also Send Feedback
Releases a reference to the object, freeing internal resources when all references have been released.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

CvsResultSet Class
CvsResultSet..::..CvsResultSet Members
Cognex.InSight Namespace


CvsResultSet.GetImage Method

[image]

In-Sight SDK
CvsResultSet..::..GetImage Method
CvsResultSet Class See Also Send Feedback
Gets the image associated with the specified sheet.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImage GetImage(
    int sheetIndex
)
Visual Basic
Public Function GetImage (
    sheetIndex As Integer
) As CvsImage

Parameters

sheetIndex
Type: System..::..Int32
The sheet index of the desired image.

Return Value

Type: CvsImage
If the sheet index is in range, the corresponding image will be returned. If the sheet index is out of range, a null will be returned.

See Also

CvsResultSet Class
CvsResultSet..::..CvsResultSet Members
Cognex.InSight Namespace


CvsResultSet Properties

[image] [image]

In-Sight SDK
CvsResultSet Properties
CvsResultSet Class See Also Send Feedback

The CvsResultSet type exposes the following members.

Properties

 | Name | Description
Public property | Cells | Gets the collection of all cells in the spreadsheet.
Public property | Graphics | Gets the collection of graphics associated with the image.
Public property | HasNewlyAcquiredImage | Gets a flag that indicates if this rset of results contains a newly acquired image.
Public property | Id | Gets the ID number of the result set.
Public property | Image | Gets the acquired image.
Public property | Images | Gets the acquired image.
Public property | JobInfo | Gets the job information associated with the set of results.
Public property | ProcessorConstants | Gets the processor constants associated with the set of results.
Public property | StatusLevel | Gets the pass/warn/fail status.

See Also

CvsResultSet Class
Cognex.InSight Namespace


CvsResultSet.Cells Property

[image]

In-Sight SDK
CvsResultSet..::..Cells Property
CvsResultSet Class See Also Send Feedback
Gets the collection of all cells in the spreadsheet.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellCollection Cells { get; }
Visual Basic
Public ReadOnly Property Cells As CvsCellCollection
    Get

Property Value

Type: CvsCellCollection
The CvsCellCollection associated with the set of results.

See Also

CvsResultSet Class
CvsResultSet..::..CvsResultSet Members
Cognex.InSight Namespace


CvsResultSet.Graphics Property

[image]

In-Sight SDK
CvsResultSet..::..Graphics Property
CvsResultSet Class See Also Send Feedback
Gets the collection of graphics associated with the image.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicCollection Graphics { get; }
Visual Basic
Public ReadOnly Property Graphics As CvsGraphicCollection
    Get

Property Value

Type: CvsGraphicCollection
The CvsGraphicCollection associated with the set of results.

See Also

CvsResultSet Class
CvsResultSet..::..CvsResultSet Members
Cognex.InSight Namespace


CvsResultSet.HasNewlyAcquiredImage Property

[image]

In-Sight SDK
CvsResultSet..::..HasNewlyAcquiredImage Property
CvsResultSet Class See Also Send Feedback
Gets a flag that indicates if this rset of results contains a newly acquired image.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool HasNewlyAcquiredImage { get; }
Visual Basic
Public ReadOnly Property HasNewlyAcquiredImage As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsResultSet Class
CvsResultSet..::..CvsResultSet Members
Cognex.InSight Namespace


CvsResultSet.Id Property

[image]

In-Sight SDK
CvsResultSet..::..Id Property
CvsResultSet Class See Also Send Feedback
Gets the ID number of the result set.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32

Remarks

Each new result set generated will have a new identifier. Identifiers are incremented as results are produced.

See Also

CvsResultSet Class
CvsResultSet..::..CvsResultSet Members
Cognex.InSight Namespace


CvsResultSet.Image Property

[image]

In-Sight SDK
CvsResultSet..::..Image Property
CvsResultSet Class See Also Send Feedback
Gets the acquired image.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImage Image { get; }
Visual Basic
Public ReadOnly Property Image As CvsImage
    Get

Property Value

Type: CvsImage
The CvsImage associated with the set of results.

See Also

CvsResultSet Class
CvsResultSet..::..CvsResultSet Members
Cognex.InSight Namespace


CvsResultSet.Images Property

[image]

In-Sight SDK
CvsResultSet..::..Images Property
CvsResultSet Class See Also Send Feedback
Gets the acquired image.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImage[] Images { get; }
Visual Basic
Public ReadOnly Property Images As CvsImage()
    Get

Property Value

Type: array< CvsImage >[]()[][]
The CvsImage associated with the set of results.

See Also

CvsResultSet Class
CvsResultSet..::..CvsResultSet Members
Cognex.InSight Namespace


CvsResultSet.JobInfo Property

[image]

In-Sight SDK
CvsResultSet..::..JobInfo Property
CvsResultSet Class See Also Send Feedback
Gets the job information associated with the set of results.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsJobInfo JobInfo { get; }
Visual Basic
Public ReadOnly Property JobInfo As CvsJobInfo
    Get

Property Value

Type: CvsJobInfo
The CvsJobInfo associated with the set of results.

Remarks

The CvsJobInfo object is not connected to the In-Sight sensor, and cannot be modified. To modify the job information, see JobInfo.

See Also

CvsResultSet Class
CvsResultSet..::..CvsResultSet Members
Cognex.InSight Namespace


CvsResultSet.ProcessorConstants Property

[image]

In-Sight SDK
CvsResultSet..::..ProcessorConstants Property
CvsResultSet Class See Also Send Feedback
Gets the processor constants associated with the set of results.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsProcessorConstants ProcessorConstants { get; }
Visual Basic
Public ReadOnly Property ProcessorConstants As CvsProcessorConstants
    Get

Property Value

Type: CvsProcessorConstants
The CvsProcessorConstants associated with the set of results.

See Also

CvsResultSet Class
CvsResultSet..::..CvsResultSet Members
Cognex.InSight Namespace


CvsResultSet.StatusLevel Property

[image]

In-Sight SDK
CvsResultSet..::..StatusLevel Property
CvsResultSet Class See Also Send Feedback
Gets the pass/warn/fail status.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsStatusLevel StatusLevel { get; }
Visual Basic
Public ReadOnly Property StatusLevel As CvsStatusLevel
    Get

Property Value

Type: CvsStatusLevel

See Also

CvsResultSet Class
CvsResultSet..::..CvsResultSet Members
Cognex.InSight Namespace


CvsSaveCompletedEventArgs Class

[image]

In-Sight SDK
CvsSaveCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the SaveCompleted event.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsSaveCompletedEventArgs : EventArgs
Visual Basic
<SerializableAttribute>
Public Class CvsSaveCompletedEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Cognex.InSight..::..CvsSaveCompletedEventArgs

See Also

CvsSaveCompletedEventArgs..::..CvsSaveCompletedEventArgs Members
Cognex.InSight Namespace


CvsSaveCompletedEventArgs Members

[image] [image]

In-Sight SDK
CvsSaveCompletedEventArgs Members
CvsSaveCompletedEventArgs Class Methods Properties See Also Send Feedback

The CvsSaveCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Succeeded | Gets the flag that designates the success or failure of the save operation.

See Also

CvsSaveCompletedEventArgs Class
Cognex.InSight Namespace


CvsSaveCompletedEventArgs Methods

[image] [image]

In-Sight SDK
CvsSaveCompletedEventArgs Methods
CvsSaveCompletedEventArgs Class See Also Send Feedback

The CvsSaveCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsSaveCompletedEventArgs Class
Cognex.InSight Namespace


CvsSaveCompletedEventArgs Properties

[image] [image]

In-Sight SDK
CvsSaveCompletedEventArgs Properties
CvsSaveCompletedEventArgs Class See Also Send Feedback

The CvsSaveCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Succeeded | Gets the flag that designates the success or failure of the save operation.

See Also

CvsSaveCompletedEventArgs Class
Cognex.InSight Namespace


CvsSaveCompletedEventArgs.Succeeded Property

[image]

In-Sight SDK
CvsSaveCompletedEventArgs..::..Succeeded Property
CvsSaveCompletedEventArgs Class See Also Send Feedback
Gets the flag that designates the success or failure of the save operation.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Succeeded { get; }
Visual Basic
Public ReadOnly Property Succeeded As Boolean
    Get

Property Value

Type: Boolean
trueis the save operation was successful and false otherwise.

See Also

CvsSaveCompletedEventArgs Class
CvsSaveCompletedEventArgs..::..CvsSaveCompletedEventArgs Members
Cognex.InSight Namespace


CvsSaveCompletedEventHandler Delegate

[image]

In-Sight SDK
CvsSaveCompletedEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the SaveCompleted event.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public delegate void CvsSaveCompletedEventHandler(
    Object sender,
    CvsSaveCompletedEventArgs e
)
Visual Basic
Public Delegate Sub CvsSaveCompletedEventHandler (
    sender As Object,
    e As CvsSaveCompletedEventArgs
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Cognex.InSight..::..CvsSaveCompletedEventArgs
A CvsSaveCompletedEventArgs that contains the event data.

See Also

Cognex.InSight Namespace


CvsSensorAlreadyConnectedException Class

[image]

In-Sight SDK
CvsSensorAlreadyConnectedException Class
Members See Also Send Feedback
The exception that is thrown when an In-Sight sensor is already connected to.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsSensorAlreadyConnectedException : CvsException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsSensorAlreadyConnectedException
    Inherits CvsException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsSensorAlreadyConnectedException

See Also

CvsSensorAlreadyConnectedException..::..CvsSensorAlreadyConnectedException Members
Cognex.InSight Namespace
CvsInSightErrorSensorAlreadyConnectedException


CvsSensorAlreadyConnectedException Members

[image] [image]

In-Sight SDK
CvsSensorAlreadyConnectedException Members
CvsSensorAlreadyConnectedException Class Methods Properties See Also Send Feedback

The CvsSensorAlreadyConnectedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | IsMaxGuiConnection | Gets the flag that determines if the exception was due to the maximum number of GUI connections.
Public property | IsRemoteConnection | Gets the flag that determines if the exception was due to a remote connection.
Public property | Machine | Gets the name of the machine that holds the connection.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | Username | Gets the user name.

See Also

CvsSensorAlreadyConnectedException Class
Cognex.InSight Namespace


CvsSensorAlreadyConnectedException Methods

[image] [image]

In-Sight SDK
CvsSensorAlreadyConnectedException Methods
CvsSensorAlreadyConnectedException Class See Also Send Feedback

The CvsSensorAlreadyConnectedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsSensorAlreadyConnectedException Class
Cognex.InSight Namespace


CvsSensorAlreadyConnectedException Properties

[image] [image]

In-Sight SDK
CvsSensorAlreadyConnectedException Properties
CvsSensorAlreadyConnectedException Class See Also Send Feedback

The CvsSensorAlreadyConnectedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | IsMaxGuiConnection | Gets the flag that determines if the exception was due to the maximum number of GUI connections.
Public property | IsRemoteConnection | Gets the flag that determines if the exception was due to a remote connection.
Public property | Machine | Gets the name of the machine that holds the connection.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | Username | Gets the user name.

See Also

CvsSensorAlreadyConnectedException Class
Cognex.InSight Namespace


CvsSensorAlreadyConnectedException.IsMaxGuiConnection Property

[image]

In-Sight SDK
CvsSensorAlreadyConnectedException..::..IsMaxGuiConnection Property
CvsSensorAlreadyConnectedException Class See Also Send Feedback
Gets the flag that determines if the exception was due to the maximum number of GUI connections.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsMaxGuiConnection { get; }
Visual Basic
Public ReadOnly Property IsMaxGuiConnection As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSensorAlreadyConnectedException Class
CvsSensorAlreadyConnectedException..::..CvsSensorAlreadyConnectedException Members
Cognex.InSight Namespace


CvsSensorAlreadyConnectedException.IsRemoteConnection Property

[image]

In-Sight SDK
CvsSensorAlreadyConnectedException..::..IsRemoteConnection Property
CvsSensorAlreadyConnectedException Class See Also Send Feedback
Gets the flag that determines if the exception was due to a remote connection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsRemoteConnection { get; }
Visual Basic
Public ReadOnly Property IsRemoteConnection As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSensorAlreadyConnectedException Class
CvsSensorAlreadyConnectedException..::..CvsSensorAlreadyConnectedException Members
Cognex.InSight Namespace


CvsSensorAlreadyConnectedException.Machine Property

[image]

In-Sight SDK
CvsSensorAlreadyConnectedException..::..Machine Property
CvsSensorAlreadyConnectedException Class See Also Send Feedback
Gets the name of the machine that holds the connection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Machine { get; }
Visual Basic
Public ReadOnly Property Machine As String
    Get

Property Value

Type: String

See Also

CvsSensorAlreadyConnectedException Class
CvsSensorAlreadyConnectedException..::..CvsSensorAlreadyConnectedException Members
Cognex.InSight Namespace


CvsSensorAlreadyConnectedException.Username Property

[image]

In-Sight SDK
CvsSensorAlreadyConnectedException..::..Username Property
CvsSensorAlreadyConnectedException Class See Also Send Feedback
Gets the user name.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Username { get; }
Visual Basic
Public ReadOnly Property Username As String
    Get

Property Value

Type: String

See Also

CvsSensorAlreadyConnectedException Class
CvsSensorAlreadyConnectedException..::..CvsSensorAlreadyConnectedException Members
Cognex.InSight Namespace


CvsStateChangedEventArgs Class

[image]

In-Sight SDK
CvsStateChangedEventArgs Class
Members See Also Send Feedback
Provides data for the StateChanged event.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsStateChangedEventArgs : EventArgs
Visual Basic
<SerializableAttribute>
Public Class CvsStateChangedEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Cognex.InSight..::..CvsStateChangedEventArgs

See Also

CvsStateChangedEventArgs..::..CvsStateChangedEventArgs Members
Cognex.InSight Namespace


CvsStateChangedEventArgs Members

[image] [image]

In-Sight SDK
CvsStateChangedEventArgs Members
CvsStateChangedEventArgs Class Methods Properties See Also Send Feedback

The CvsStateChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Reason | Gets the reason that the state of the State changed.
Public property | State | Gets the new state of the In-Sight sensor or its connection (NotConnected, Offline, Online).

See Also

CvsStateChangedEventArgs Class
Cognex.InSight Namespace


CvsStateChangedEventArgs Methods

[image] [image]

In-Sight SDK
CvsStateChangedEventArgs Methods
CvsStateChangedEventArgs Class See Also Send Feedback

The CvsStateChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsStateChangedEventArgs Class
Cognex.InSight Namespace


CvsStateChangedEventArgs Properties

[image] [image]

In-Sight SDK
CvsStateChangedEventArgs Properties
CvsStateChangedEventArgs Class See Also Send Feedback

The CvsStateChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Reason | Gets the reason that the state of the State changed.
Public property | State | Gets the new state of the In-Sight sensor or its connection (NotConnected, Offline, Online).

See Also

CvsStateChangedEventArgs Class
Cognex.InSight Namespace


CvsStateChangedEventArgs.Reason Property

[image]

In-Sight SDK
CvsStateChangedEventArgs..::..Reason Property
CvsStateChangedEventArgs Class See Also Send Feedback
Gets the reason that the state of the State changed.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightStateChangedReason Reason { get; }
Visual Basic
Public ReadOnly Property Reason As CvsInSightStateChangedReason
    Get

Property Value

Type: CvsInSightStateChangedReason

See Also

CvsStateChangedEventArgs Class
CvsStateChangedEventArgs..::..CvsStateChangedEventArgs Members
Cognex.InSight Namespace


CvsStateChangedEventArgs.State Property

[image]

In-Sight SDK
CvsStateChangedEventArgs..::..State Property
CvsStateChangedEventArgs Class See Also Send Feedback
Gets the new state of the In-Sight sensor or its connection (NotConnected, Offline, Online).

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightState State { get; }
Visual Basic
Public ReadOnly Property State As CvsInSightState
    Get

Property Value

Type: CvsInSightState

See Also

CvsStateChangedEventArgs Class
CvsStateChangedEventArgs..::..CvsStateChangedEventArgs Members
Cognex.InSight Namespace


CvsStateChangedEventHandler Delegate

[image]

In-Sight SDK
CvsStateChangedEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the StateChanged event.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public delegate void CvsStateChangedEventHandler(
    Object sender,
    CvsStateChangedEventArgs e
)
Visual Basic
Public Delegate Sub CvsStateChangedEventHandler (
    sender As Object,
    e As CvsStateChangedEventArgs
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Cognex.InSight..::..CvsStateChangedEventArgs
A CvsStateChangedEventArgs that contains the event data.

See Also

Cognex.InSight Namespace


CvsStatusLevel Enumeration

[image]

In-Sight SDK
CvsStatusLevel Enumeration
See Also Send Feedback
Indicates a pass/warn/fail status.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public enum CvsStatusLevel
Visual Basic
<SerializableAttribute>
Public Enumeration CvsStatusLevel

Members

Member name | Value | Description
None | 0 | Indicates that no status level is specified.
Pass | 1 | Indicates unconditional success.
Fail | 2 | Indicates a failure condition.
Warn | 3 | Indicates success but with a warning condition.

See Also

Cognex.InSight Namespace


CvsStatusLevelStyle Enumeration

[image]

In-Sight SDK
CvsStatusLevelStyle Enumeration
See Also Send Feedback
Indicates how a CvsStatusLevel should be displayed graphically.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsStatusLevelStyle
Visual Basic
Public Enumeration CvsStatusLevelStyle

Members

Member name | Value | Description
Geometric | 0 | Display a green square for Pass, a yellow triangle for Warn, and a red circle for Fail.
OKorNG | 1 | Display a green OK for Pass, a yellow ? for Warn, and a red NG for Fail.
Check | 2 | Display a green check for Pass, a yellow ? for Warn, and a red X for Fail.

See Also

Cognex.InSight Namespace


CvsSymbolicTag Class

[image]

In-Sight SDK
CvsSymbolicTag Class
Members See Also Send Feedback
Holds the symbolic tag information for a single cell.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsSymbolicTag
Visual Basic
<SerializableAttribute>
Public Class CvsSymbolicTag

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsSymbolicTag

See Also

CvsSymbolicTag..::..CvsSymbolicTag Members
Cognex.InSight Namespace


CvsSymbolicTag Members

[image] [image]

In-Sight SDK
CvsSymbolicTag Members
CvsSymbolicTag Class Constructors Methods Properties See Also Send Feedback

The CvsSymbolicTag type exposes the following members.

Constructors

 | Name | Description
Public method | CvsSymbolicTag(CvsSymbolicTag) | Constructs a new instance that is a copy of the original.
Public method | CvsSymbolicTag(CvsCellLocation, String) | Constructs a new instance with ExposeToOpc and AuditMessage set to false.
Public method | CvsSymbolicTag(CvsCellLocation, String, Boolean) | Constructs a new instance with AuditMessage set to false.

Methods

 | Name | Description
Public method | Equals | Determines if two instances are equal. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code based on the cell location. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AuditMessage | Gets a flag that designates whether or not audit messages for the associated cell will be generated.
Public property | ExposeToOpc | Gets a flag that designates whether or not the data for the associated cell should be sent on the OPC channel.
Public property | InEasyView | Gets a flag that designates whether or not the associated cell will appear in an EasyView.
Public property | Location | Gets the cell location associated with the symbolic tag.
Public property | Name | Gets the symbolic tag name.

See Also

CvsSymbolicTag Class
Cognex.InSight Namespace


CvsSymbolicTag Constructor

[image] [image]

In-Sight SDK
CvsSymbolicTag Constructor
CvsSymbolicTag Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsSymbolicTag(CvsSymbolicTag) | Constructs a new instance that is a copy of the original.
Public method | CvsSymbolicTag(CvsCellLocation, String) | Constructs a new instance with ExposeToOpc and AuditMessage set to false.
Public method | CvsSymbolicTag(CvsCellLocation, String, Boolean) | Constructs a new instance with AuditMessage set to false.

See Also

CvsSymbolicTag Class
CvsSymbolicTag..::..CvsSymbolicTag Members
Cognex.InSight Namespace


CvsSymbolicTag Constructor (CvsSymbolicTag)

[image]

In-Sight SDK
CvsSymbolicTag Constructor (CvsSymbolicTag)
CvsSymbolicTag Class See Also Send Feedback
Constructs a new instance that is a copy of the original.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSymbolicTag(
    CvsSymbolicTag original
)
Visual Basic
Public Sub New (
    original As CvsSymbolicTag
)

Parameters

original
Type: Cognex.InSight..::..CvsSymbolicTag
The instance to copy.

See Also

CvsSymbolicTag Class
CvsSymbolicTag..::..CvsSymbolicTag Members
CvsSymbolicTag Overload
Cognex.InSight Namespace


CvsSymbolicTag Constructor (CvsCellLocation, String)

[image]

In-Sight SDK
CvsSymbolicTag Constructor (CvsCellLocation, String)
CvsSymbolicTag Class See Also Send Feedback
Constructs a new instance with ExposeToOpc and AuditMessage set to false.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSymbolicTag(
    CvsCellLocation location,
    string name
)
Visual Basic
Public Sub New (
    location As CvsCellLocation,
    name As String
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell assoicated with the symbolic tag.
name
Type: System..::..String
The symbolic tag name for the cell.

See Also

CvsSymbolicTag Class
CvsSymbolicTag..::..CvsSymbolicTag Members
CvsSymbolicTag Overload
Cognex.InSight Namespace


CvsSymbolicTag Constructor (CvsCellLocation, String, Boolean)

[image]

In-Sight SDK
CvsSymbolicTag Constructor (CvsCellLocation, String, Boolean)
CvsSymbolicTag Class See Also Send Feedback
Constructs a new instance with AuditMessage set to false.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSymbolicTag(
    CvsCellLocation location,
    string name,
    bool exposeToOpc
)
Visual Basic
Public Sub New (
    location As CvsCellLocation,
    name As String,
    exposeToOpc As Boolean
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell assoicated with the symbolic tag.
name
Type: System..::..String
The symbolic tag name for the cell.
exposeToOpc
Type: System..::..Boolean
A flag that designates whether or not the data for the associated cell should be sent on the OPC channel.

See Also

CvsSymbolicTag Class
CvsSymbolicTag..::..CvsSymbolicTag Members
CvsSymbolicTag Overload
Cognex.InSight Namespace


CvsSymbolicTag Methods

[image] [image]

In-Sight SDK
CvsSymbolicTag Methods
CvsSymbolicTag Class See Also Send Feedback

The CvsSymbolicTag type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines if two instances are equal. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code based on the cell location. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsSymbolicTag Class
Cognex.InSight Namespace


CvsSymbolicTag.Equals Method

[image]

In-Sight SDK
CvsSymbolicTag..::..Equals Method
CvsSymbolicTag Class See Also Send Feedback
Determines if two instances are equal.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: System..::..Object
Another object.

Return Value

Type: Boolean
Return true if the objects are the same and false otherwise.

See Also

CvsSymbolicTag Class
CvsSymbolicTag..::..CvsSymbolicTag Members
Cognex.InSight Namespace


CvsSymbolicTag.GetHashCode Method

[image]

In-Sight SDK
CvsSymbolicTag..::..GetHashCode Method
CvsSymbolicTag Class See Also Send Feedback
Gets a hash code based on the cell location.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
The hashcode.

See Also

CvsSymbolicTag Class
CvsSymbolicTag..::..CvsSymbolicTag Members
Cognex.InSight Namespace


CvsSymbolicTag Properties

[image] [image]

In-Sight SDK
CvsSymbolicTag Properties
CvsSymbolicTag Class See Also Send Feedback

The CvsSymbolicTag type exposes the following members.

Properties

 | Name | Description
Public property | AuditMessage | Gets a flag that designates whether or not audit messages for the associated cell will be generated.
Public property | ExposeToOpc | Gets a flag that designates whether or not the data for the associated cell should be sent on the OPC channel.
Public property | InEasyView | Gets a flag that designates whether or not the associated cell will appear in an EasyView.
Public property | Location | Gets the cell location associated with the symbolic tag.
Public property | Name | Gets the symbolic tag name.

See Also

CvsSymbolicTag Class
Cognex.InSight Namespace


CvsSymbolicTag.AuditMessage Property

[image]

In-Sight SDK
CvsSymbolicTag..::..AuditMessage Property
CvsSymbolicTag Class See Also Send Feedback
Gets a flag that designates whether or not audit messages for the associated cell will be generated.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AuditMessage { get; }
Visual Basic
Public ReadOnly Property AuditMessage As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSymbolicTag Class
CvsSymbolicTag..::..CvsSymbolicTag Members
Cognex.InSight Namespace


CvsSymbolicTag.ExposeToOpc Property

[image]

In-Sight SDK
CvsSymbolicTag..::..ExposeToOpc Property
CvsSymbolicTag Class See Also Send Feedback
Gets a flag that designates whether or not the data for the associated cell should be sent on the OPC channel.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ExposeToOpc { get; }
Visual Basic
Public ReadOnly Property ExposeToOpc As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSymbolicTag Class
CvsSymbolicTag..::..CvsSymbolicTag Members
Cognex.InSight Namespace


CvsSymbolicTag.InEasyView Property

[image]

In-Sight SDK
CvsSymbolicTag..::..InEasyView Property
CvsSymbolicTag Class See Also Send Feedback
Gets a flag that designates whether or not the associated cell will appear in an EasyView.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool InEasyView { get; }
Visual Basic
Public ReadOnly Property InEasyView As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSymbolicTag Class
CvsSymbolicTag..::..CvsSymbolicTag Members
Cognex.InSight Namespace


CvsSymbolicTag.Location Property

[image]

In-Sight SDK
CvsSymbolicTag..::..Location Property
CvsSymbolicTag Class See Also Send Feedback
Gets the cell location associated with the symbolic tag.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation Location { get; }
Visual Basic
Public ReadOnly Property Location As CvsCellLocation
    Get

Property Value

Type: CvsCellLocation

See Also

CvsSymbolicTag Class
CvsSymbolicTag..::..CvsSymbolicTag Members
Cognex.InSight Namespace


CvsSymbolicTag.Name Property

[image]

In-Sight SDK
CvsSymbolicTag..::..Name Property
CvsSymbolicTag Class See Also Send Feedback
Gets the symbolic tag name.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

See Also

CvsSymbolicTag Class
CvsSymbolicTag..::..CvsSymbolicTag Members
Cognex.InSight Namespace


CvsSymbolicTagCollection Class

[image]

In-Sight SDK
CvsSymbolicTagCollection Class
Members See Also Send Feedback
Represents a collection of CvsSymbolicTag objects.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsSymbolicTagCollection : IEnumerable
Visual Basic
<SerializableAttribute>
Public Class CvsSymbolicTagCollection
    Implements IEnumerable

Remarks

The CvsSymbolicTagCollection holds the symbolic tag to spreadsheet cell mappings for a job.

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsSymbolicTagCollection

See Also

CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Cognex.InSight Namespace


CvsSymbolicTagCollection Members

[image] [image]

In-Sight SDK
CvsSymbolicTagCollection Members
CvsSymbolicTagCollection Class Constructors Methods Properties See Also Send Feedback

The CvsSymbolicTagCollection type exposes the following members.

Constructors

 | Name | Description
Public method | CvsSymbolicTagCollection()()()() | Constructs a new instance.
Public method | CvsSymbolicTagCollection(CvsSymbolicTagCollection) | Constructs a new instance that is a deep copy of the original.

Methods

 | Name | Description
Public method | Add | Adds an element to the collection.
Public method | Clear | Removes all elements from the collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Finds the index of a CvsSymbolicTag in the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an element from the collection.
Public method | RemoveAt | Removes the item at the given index.
Public method | SetName(CvsCellLocation, String) | Sets the symbolic tag name for the specified cell.
Public method | SetName(CvsCellLocation, String, Boolean) | Sets the symbolic tag name for the specified cell.
Public method | SetName(CvsCellLocation, String, Boolean, Boolean) | Sets the symbolic tag name for the specified cell.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateTag | Completely updates a symbolic tag stored in the collection.
Public method | UpdateTagLocation | Updates the cell location of a symbolic tag stored in the collection.
Public method | UpdateTagName | Updates the name of a symbolic tag stored in the collection.

Properties

 | Name | Description
Public property | Count | Gets the number of items in the collection.
Public property | Item[([( Int32])]) | Gets the CvsSymbolicTag for the designated index into the collection.
Public property | Item[([( String])]) | Gets the CvsSymbolicTag item that has the designated name.
Public property | Item[([( CvsCellLocation])]) | Gets the CvsSymbolicTag for the designated cell.

See Also

CvsSymbolicTagCollection Class
Cognex.InSight Namespace


CvsSymbolicTagCollection Constructor

[image] [image]

In-Sight SDK
CvsSymbolicTagCollection Constructor
CvsSymbolicTagCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsSymbolicTagCollection()()()() | Constructs a new instance.
Public method | CvsSymbolicTagCollection(CvsSymbolicTagCollection) | Constructs a new instance that is a deep copy of the original.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Cognex.InSight Namespace


CvsSymbolicTagCollection Constructor

[image]

In-Sight SDK
CvsSymbolicTagCollection Constructor
CvsSymbolicTagCollection Class See Also Send Feedback
Constructs a new instance.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSymbolicTagCollection()
Visual Basic
Public Sub New

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
CvsSymbolicTagCollection Overload
Cognex.InSight Namespace


CvsSymbolicTagCollection Constructor (CvsSymbolicTagCollection)

[image]

In-Sight SDK
CvsSymbolicTagCollection Constructor (CvsSymbolicTagCollection)
CvsSymbolicTagCollection Class See Also Send Feedback
Constructs a new instance that is a deep copy of the original.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSymbolicTagCollection(
    CvsSymbolicTagCollection original
)
Visual Basic
Public Sub New (
    original As CvsSymbolicTagCollection
)

Parameters

original
Type: Cognex.InSight..::..CvsSymbolicTagCollection
The collection to copy.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
CvsSymbolicTagCollection Overload
Cognex.InSight Namespace


CvsSymbolicTagCollection Methods

[image] [image]

In-Sight SDK
CvsSymbolicTagCollection Methods
CvsSymbolicTagCollection Class See Also Send Feedback

The CvsSymbolicTagCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an element to the collection.
Public method | Clear | Removes all elements from the collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Finds the index of a CvsSymbolicTag in the collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an element from the collection.
Public method | RemoveAt | Removes the item at the given index.
Public method | SetName(CvsCellLocation, String) | Sets the symbolic tag name for the specified cell.
Public method | SetName(CvsCellLocation, String, Boolean) | Sets the symbolic tag name for the specified cell.
Public method | SetName(CvsCellLocation, String, Boolean, Boolean) | Sets the symbolic tag name for the specified cell.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateTag | Completely updates a symbolic tag stored in the collection.
Public method | UpdateTagLocation | Updates the cell location of a symbolic tag stored in the collection.
Public method | UpdateTagName | Updates the name of a symbolic tag stored in the collection.

See Also

CvsSymbolicTagCollection Class
Cognex.InSight Namespace


CvsSymbolicTagCollection.Add Method

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..Add Method
CvsSymbolicTagCollection Class See Also Send Feedback
Adds an element to the collection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Add(
    CvsSymbolicTag item
)
Visual Basic
Public Sub Add (
    item As CvsSymbolicTag
)

Parameters

item
Type: Cognex.InSight..::..CvsSymbolicTag
The element to add.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Cognex.InSight Namespace


CvsSymbolicTagCollection.Clear Method

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..Clear Method
CvsSymbolicTagCollection Class See Also Send Feedback
Removes all elements from the collection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Cognex.InSight Namespace


CvsSymbolicTagCollection.IndexOf Method

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..IndexOf Method
CvsSymbolicTagCollection Class See Also Send Feedback
Finds the index of a CvsSymbolicTag in the collection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IndexOf(
    CvsSymbolicTag item
)
Visual Basic
Public Function IndexOf (
    item As CvsSymbolicTag
) As Integer

Parameters

item
Type: Cognex.InSight..::..CvsSymbolicTag
An item for which to search.

Return Value

Type: Int32
The index of the given item in the array, or -1 if the object is not found.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Cognex.InSight Namespace


CvsSymbolicTagCollection.Remove Method

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..Remove Method
CvsSymbolicTagCollection Class See Also Send Feedback
Removes an element from the collection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Remove(
    CvsCellLocation location
)
Visual Basic
Public Sub Remove (
    location As CvsCellLocation
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location of the item to remove.

Remarks

This method does nothing if the item cannot be found in the collection.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Cognex.InSight Namespace


CvsSymbolicTagCollection.RemoveAt Method

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..RemoveAt Method
CvsSymbolicTagCollection Class See Also Send Feedback
Removes the item at the given index.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: System..::..Int32
The zero-based index into the collection.

Remarks

This method does nothing if the item cannot be found in the collection.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Cognex.InSight Namespace


CvsSymbolicTagCollection.SetName Method

[image] [image]

In-Sight SDK
CvsSymbolicTagCollection..::..SetName Method
CvsSymbolicTagCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetName(CvsCellLocation, String) | Sets the symbolic tag name for the specified cell.
Public method | SetName(CvsCellLocation, String, Boolean) | Sets the symbolic tag name for the specified cell.
Public method | SetName(CvsCellLocation, String, Boolean, Boolean) | Sets the symbolic tag name for the specified cell.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Cognex.InSight Namespace


CvsSymbolicTagCollection.SetName Method (CvsCellLocation, String)

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..SetName Method (CvsCellLocation, String)
CvsSymbolicTagCollection Class See Also Send Feedback
Sets the symbolic tag name for the specified cell.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetName(
    CvsCellLocation location,
    string name
)
Visual Basic
Public Sub SetName (
    location As CvsCellLocation,
    name As String
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.
name
Type: System..::..String
The Symbolic tag name.

Remarks

The symbolic tag will not be exposed to OPC or EasyViews and will not have audit messsaging enabled.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
SetName Overload
Cognex.InSight Namespace


CvsSymbolicTagCollection.SetName Method (CvsCellLocation, String, Boolean)

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..SetName Method (CvsCellLocation, String, Boolean)
CvsSymbolicTagCollection Class See Also Send Feedback
Sets the symbolic tag name for the specified cell.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetName(
    CvsCellLocation location,
    string name,
    bool exposeToOpc
)
Visual Basic
Public Sub SetName (
    location As CvsCellLocation,
    name As String,
    exposeToOpc As Boolean
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.
name
Type: System..::..String
The Symbolic tag name.
exposeToOpc
Type: System..::..Boolean
Whether to expose to OPC or not.

Remarks

The symbolic tag will not be exposed to EasyViews and will not have audit messsaging enabled.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
SetName Overload
Cognex.InSight Namespace


CvsSymbolicTagCollection.SetName Method (CvsCellLocation, String, Boolean, Boolean)

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..SetName Method (CvsCellLocation, String, Boolean, Boolean)
CvsSymbolicTagCollection Class See Also Send Feedback
Sets the symbolic tag name for the specified cell.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetName(
    CvsCellLocation location,
    string name,
    bool exposeToOpc,
    bool auditMessage
)
Visual Basic
Public Sub SetName (
    location As CvsCellLocation,
    name As String,
    exposeToOpc As Boolean,
    auditMessage As Boolean
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.
name
Type: System..::..String
The symbolic tag name.
exposeToOpc
Type: System..::..Boolean
Whether to expose to OPC or not.
auditMessage
Type: System..::..Boolean
Whether to audit the tag or not.

Remarks

The symbolic tag will not be exposed to EasyViews.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
SetName Overload
Cognex.InSight Namespace


CvsSymbolicTagCollection.UpdateTag Method

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..UpdateTag Method
CvsSymbolicTagCollection Class See Also Send Feedback
Completely updates a symbolic tag stored in the collection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool UpdateTag(
    ref CvsSymbolicTag oldTag,
    CvsCellLocation location,
    string name,
    bool exposeToOpc,
    bool auditMessage,
    bool inEasyView
)
Visual Basic
Public Function UpdateTag (
    ByRef oldTag As CvsSymbolicTag,
    location As CvsCellLocation,
    name As String,
    exposeToOpc As Boolean,
    auditMessage As Boolean,
    inEasyView As Boolean
) As Boolean

Parameters

oldTag
Type: Cognex.InSight..::..CvsSymbolicTag %
The old tag to update.
location
Type: Cognex.InSight..::..CvsCellLocation
The new CvsCellLocation.
name
Type: System..::..String
The new name.
exposeToOpc
Type: System..::..Boolean
The new ExposeToOpc flag.
auditMessage
Type: System..::..Boolean
The new AuditMessage flag.
inEasyView
Type: System..::..Boolean
The new InEasyView flag.

Return Value

Type: Boolean
Returns true is the update was successful and false otherwise.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Cognex.InSight Namespace


CvsSymbolicTagCollection.UpdateTagLocation Method

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..UpdateTagLocation Method
CvsSymbolicTagCollection Class See Also Send Feedback
Updates the cell location of a symbolic tag stored in the collection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool UpdateTagLocation(
    ref CvsSymbolicTag tag,
    CvsCellLocation location
)
Visual Basic
Public Function UpdateTagLocation (
    ByRef tag As CvsSymbolicTag,
    location As CvsCellLocation
) As Boolean

Parameters

tag
Type: Cognex.InSight..::..CvsSymbolicTag %
The CvsSymbolicTag to update.
location
Type: Cognex.InSight..::..CvsCellLocation
The CvsCellLocation to give to the tag.

Return Value

Type: Boolean
Returns true is the update was successful and false otherwise.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Cognex.InSight Namespace


CvsSymbolicTagCollection.UpdateTagName Method

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..UpdateTagName Method
CvsSymbolicTagCollection Class See Also Send Feedback
Updates the name of a symbolic tag stored in the collection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool UpdateTagName(
    ref CvsSymbolicTag tag,
    string name
)
Visual Basic
Public Function UpdateTagName (
    ByRef tag As CvsSymbolicTag,
    name As String
) As Boolean

Parameters

tag
Type: Cognex.InSight..::..CvsSymbolicTag %
The CvsSymbolicTag to update.
name
Type: System..::..String
The name to give the tag.

Return Value

Type: Boolean
Returns true is the update was successful and false otherwise.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Cognex.InSight Namespace


CvsSymbolicTagCollection Properties

[image] [image]

In-Sight SDK
CvsSymbolicTagCollection Properties
CvsSymbolicTagCollection Class See Also Send Feedback

The CvsSymbolicTagCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of items in the collection.
Public property | Item[([( Int32])]) | Gets the CvsSymbolicTag for the designated index into the collection.
Public property | Item[([( String])]) | Gets the CvsSymbolicTag item that has the designated name.
Public property | Item[([( CvsCellLocation])]) | Gets the CvsSymbolicTag for the designated cell.

See Also

CvsSymbolicTagCollection Class
Cognex.InSight Namespace


CvsSymbolicTagCollection.Count Property

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..Count Property
CvsSymbolicTagCollection Class See Also Send Feedback
Gets the number of items in the collection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Cognex.InSight Namespace


CvsSymbolicTagCollection.Item Property

[image] [image]

In-Sight SDK
CvsSymbolicTagCollection..::..Item Property
CvsSymbolicTagCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets the CvsSymbolicTag for the designated index into the collection.
Public property | Item[([( String])]) | Gets the CvsSymbolicTag item that has the designated name.
Public property | Item[([( CvsCellLocation])]) | Gets the CvsSymbolicTag for the designated cell.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Cognex.InSight Namespace


CvsSymbolicTagCollection.Item Property (Int32)

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..Item Property (Int32)
CvsSymbolicTagCollection Class See Also Send Feedback
Gets the CvsSymbolicTag for the designated index into the collection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSymbolicTag this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As CvsSymbolicTag
    Get

Parameters

index
Type: System..::..Int32
The zero-based index into the collection.

Property Value

Type: CvsSymbolicTag

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Item Overload
Cognex.InSight Namespace


CvsSymbolicTagCollection.Item Property (String)

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..Item Property (String)
CvsSymbolicTagCollection Class See Also Send Feedback
Gets the CvsSymbolicTag item that has the designated name.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSymbolicTag this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    name As String
) As CvsSymbolicTag
    Get

Parameters

name
Type: System..::..String
The Name of the item in the collection.

Property Value

Type: CvsSymbolicTag
The item or null if name is not found.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Item Overload
Cognex.InSight Namespace


CvsSymbolicTagCollection.Item Property (CvsCellLocation)

[image]

In-Sight SDK
CvsSymbolicTagCollection..::..Item Property (CvsCellLocation)
CvsSymbolicTagCollection Class See Also Send Feedback
Gets the CvsSymbolicTag for the designated cell.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSymbolicTag this[
    CvsCellLocation location
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    location As CvsCellLocation
) As CvsSymbolicTag
    Get

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location of the item to retrieve.

Property Value

Type: CvsSymbolicTag
The item or null if location is not found.

See Also

CvsSymbolicTagCollection Class
CvsSymbolicTagCollection..::..CvsSymbolicTagCollection Members
Item Overload
Cognex.InSight Namespace


CvsTimeoutException Class

[image]

In-Sight SDK
CvsTimeoutException Class
Members See Also Send Feedback
The exception that is thrown when a timeout has occurred.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsTimeoutException : CvsNetworkException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsTimeoutException
    Inherits CvsNetworkException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsCommunicationException
Cognex.InSight..::..CvsNetworkException
Cognex.InSight..::..CvsTimeoutException

See Also

CvsTimeoutException..::..CvsTimeoutException Members
Cognex.InSight Namespace


CvsTimeoutException Members

[image] [image]

In-Sight SDK
CvsTimeoutException Members
CvsTimeoutException Class Methods Properties See Also Send Feedback

The CvsTimeoutException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsTimeoutException Class
Cognex.InSight Namespace


CvsTimeoutException Methods

[image] [image]

In-Sight SDK
CvsTimeoutException Methods
CvsTimeoutException Class See Also Send Feedback

The CvsTimeoutException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsTimeoutException Class
Cognex.InSight Namespace


CvsTimeoutException Properties

[image] [image]

In-Sight SDK
CvsTimeoutException Properties
CvsTimeoutException Class See Also Send Feedback

The CvsTimeoutException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsTimeoutException Class
Cognex.InSight Namespace


CvsUtility Class

[image]

In-Sight SDK
CvsUtility Class
Members See Also Send Feedback
Holds utility methods for Visual Basic 6 and COM/ActiveX interoperability. These methods are equivalent to various static methods of classes and methods of structures that cannot be called directly from COM/ActiveX applications.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public sealed class CvsUtility
Visual Basic
Public NotInheritable Class CvsUtility

Remarks

COM/ActiveX environments like Visual Basic 6.0 can call the methods of this class as global functions. This class is not needed in .NET applications.

Inheritance Hierarchy

System..::..Object
Cognex.InSight..::..CvsUtility

See Also

CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility Members

[image] [image]

In-Sight SDK
CvsUtility Members
CvsUtility Class Methods See Also Send Feedback

The CvsUtility type exposes the following members.

Methods

 | Name | Description
Public method | CvsCellLocationFromLocation | Constructs a new instance of the CvsCellLocation structure.
Public method | CvsCellLocationFromString | Constructs a new instance of the CvsCellLocation structure from the string location.
Public method | CvsCellLocationToString | Converts the row and column to a string representation of a cell location (e.g. "B5").
Public method | CvsCellRangeFromRange | Constructs a new instance of the CvsCellRange structure.
Public method | CvsCellRangeFromString | Constructs a new instance of the CvsCellRange structure.
Public method | CvsCellRangeToString | Converts the range to a string representation for a cell range (e.g. "B5:D10").
Public method | CvsDiscreteInputLineSupportsSignalSetting | Determines if the input type supports a signal setting.
Public method | CvsDiscreteOutputLineSupportsPulseAndAcquisitionDelay | Determines if the output type supports pulse enable selection and acquisition delay settings. This type also supports a PulseLength setting when the PulseEnabledOrStrobedEdge flag is set to true.
Public method | CvsDiscreteOutputLineSupportsPulseLengthSetting | Determines if the output type supports a pulse length setting without regard to the Pulse Enable flag.
Public method | CvsDiscreteOutputLineSupportsStrobeTriggerSelection | Determines if the output type supports a strobe trigger selection.
Public method | CvsImageLocationFromLocation | Constructs a new instance of the CvsImageLocation structure.
Public method | CvsImageLocationToString | Converts Row and Column to a human readable string.
Public method | CvsInSightSoftwareDevelopmentKitInitialize | Obsolete. Calls the initialization method of the CvsInSightSoftwareDevelopmentKit class.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidHostIPAddress | Determines if the string is a valid IP address.
Public method | IsValidHostName | Determines if the string is a valid host name. Checks the length and the content.
Public method | IsValidHostNameChar | Determines if the first character in a string is valid for a host name.
Public method | IsValidIPAddressChar | Determines if the first character in a string is valid for an IP address.
Public method | IsValidPassword | Determines if the string is a valid password. Checks the length and the content.
Public method | IsValidSensorName | Determines if the string is a valid sensor name. Checks the length and the content.
Public method | IsValidSensorNameChar | Determines if the first character in a string is valid for a sensor name.
Public method | IsValidSubnetIPAddress | Determines if the string is a valid Subnet IP address.
Public method | IsValidUserName | Determines if the string is a valid username. Checks the length and the content.
Public method | IsValidUserNameOrPasswordChar | Determines if the first character in a string is valid for a user name or password.
Public method | OpenDialog | Opens a dialog within a job.
Public method | PingHost | This method performs a network ping to determine if a sensor is available on the network.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsUtility Class
Cognex.InSight Namespace


CvsUtility Methods

[image] [image]

In-Sight SDK
CvsUtility Methods
CvsUtility Class See Also Send Feedback

The CvsUtility type exposes the following members.

Methods

 | Name | Description
Public method | CvsCellLocationFromLocation | Constructs a new instance of the CvsCellLocation structure.
Public method | CvsCellLocationFromString | Constructs a new instance of the CvsCellLocation structure from the string location.
Public method | CvsCellLocationToString | Converts the row and column to a string representation of a cell location (e.g. "B5").
Public method | CvsCellRangeFromRange | Constructs a new instance of the CvsCellRange structure.
Public method | CvsCellRangeFromString | Constructs a new instance of the CvsCellRange structure.
Public method | CvsCellRangeToString | Converts the range to a string representation for a cell range (e.g. "B5:D10").
Public method | CvsDiscreteInputLineSupportsSignalSetting | Determines if the input type supports a signal setting.
Public method | CvsDiscreteOutputLineSupportsPulseAndAcquisitionDelay | Determines if the output type supports pulse enable selection and acquisition delay settings. This type also supports a PulseLength setting when the PulseEnabledOrStrobedEdge flag is set to true.
Public method | CvsDiscreteOutputLineSupportsPulseLengthSetting | Determines if the output type supports a pulse length setting without regard to the Pulse Enable flag.
Public method | CvsDiscreteOutputLineSupportsStrobeTriggerSelection | Determines if the output type supports a strobe trigger selection.
Public method | CvsImageLocationFromLocation | Constructs a new instance of the CvsImageLocation structure.
Public method | CvsImageLocationToString | Converts Row and Column to a human readable string.
Public method | CvsInSightSoftwareDevelopmentKitInitialize | Obsolete. Calls the initialization method of the CvsInSightSoftwareDevelopmentKit class.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidHostIPAddress | Determines if the string is a valid IP address.
Public method | IsValidHostName | Determines if the string is a valid host name. Checks the length and the content.
Public method | IsValidHostNameChar | Determines if the first character in a string is valid for a host name.
Public method | IsValidIPAddressChar | Determines if the first character in a string is valid for an IP address.
Public method | IsValidPassword | Determines if the string is a valid password. Checks the length and the content.
Public method | IsValidSensorName | Determines if the string is a valid sensor name. Checks the length and the content.
Public method | IsValidSensorNameChar | Determines if the first character in a string is valid for a sensor name.
Public method | IsValidSubnetIPAddress | Determines if the string is a valid Subnet IP address.
Public method | IsValidUserName | Determines if the string is a valid username. Checks the length and the content.
Public method | IsValidUserNameOrPasswordChar | Determines if the first character in a string is valid for a user name or password.
Public method | OpenDialog | Opens a dialog within a job.
Public method | PingHost | This method performs a network ping to determine if a sensor is available on the network.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsUtility Class
Cognex.InSight Namespace


CvsUtility.CvsCellLocationFromLocation Method

[image]

In-Sight SDK
CvsUtility..::..CvsCellLocationFromLocation Method
CvsUtility Class See Also Send Feedback
Constructs a new instance of the CvsCellLocation structure.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation CvsCellLocationFromLocation(
    int row,
    int column
)
Visual Basic
Public Function CvsCellLocationFromLocation (
    row As Integer,
    column As Integer
) As CvsCellLocation

Parameters

row
Type: System..::..Int32
The row (vertical) coordinate.
column
Type: System..::..Int32
The column (horizontal) coordinate.

Return Value

Type: CvsCellLocation
A CvsCellLocation.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.CvsCellLocationFromString Method

[image]

In-Sight SDK
CvsUtility..::..CvsCellLocationFromString Method
CvsUtility Class See Also Send Feedback
Constructs a new instance of the CvsCellLocation structure from the string location.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation CvsCellLocationFromString(
    string location
)
Visual Basic
Public Function CvsCellLocationFromString (
    location As String
) As CvsCellLocation

Parameters

location
Type: System..::..String
The location of a cell, e.g. "B5".

Return Value

Type: CvsCellLocation
The new CvsCellLocation structure.

Remarks

'$' characters that precede rows or columns will be stripped when the location is parsed.

Exceptions

Exception | Condition
System..::..ArgumentException | The cell location string cannot be parsed.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.CvsCellLocationToString Method

[image]

In-Sight SDK
CvsUtility..::..CvsCellLocationToString Method
CvsUtility Class See Also Send Feedback
Converts the row and column to a string representation of a cell location (e.g. "B5").

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string CvsCellLocationToString(
    int row,
    int column,
    bool absoluteRow,
    bool absoluteColumn
)
Visual Basic
Public Function CvsCellLocationToString (
    row As Integer,
    column As Integer,
    absoluteRow As Boolean,
    absoluteColumn As Boolean
) As String

Parameters

row
Type: System..::..Int32
The row (vertical) coordinate.
column
Type: System..::..Int32
The column (horizontal) coordinate.
absoluteRow
Type: System..::..Boolean
If true, the returned string will include the $ symbol to represent an absolute row reference (e.g. B$5).
absoluteColumn
Type: System..::..Boolean
If true, the returned string will include the $ symbol to represent an absolute column reference (e.g. $B5).

Return Value

Type: String
A string that represents the row and column as a spreadsheet location (e.g. "B5").

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.CvsCellRangeFromRange Method

[image]

In-Sight SDK
CvsUtility..::..CvsCellRangeFromRange Method
CvsUtility Class See Also Send Feedback
Constructs a new instance of the CvsCellRange structure.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellRange CvsCellRangeFromRange(
    int row,
    int column,
    int rows,
    int columns
)
Visual Basic
Public Function CvsCellRangeFromRange (
    row As Integer,
    column As Integer,
    rows As Integer,
    columns As Integer
) As CvsCellRange

Parameters

row
Type: System..::..Int32
The starting row (vertical) coordinate.
column
Type: System..::..Int32
The starting column (horizontal) coordinate.
rows
Type: System..::..Int32
The number of rows.
columns
Type: System..::..Int32
The number of columns.

Return Value

Type: CvsCellRange
The new CvsCellRange structure.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.CvsCellRangeFromString Method

[image]

In-Sight SDK
CvsUtility..::..CvsCellRangeFromString Method
CvsUtility Class See Also Send Feedback
Constructs a new instance of the CvsCellRange structure.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellRange CvsCellRangeFromString(
    string range
)
Visual Basic
Public Function CvsCellRangeFromString (
    range As String
) As CvsCellRange

Parameters

range
Type: System..::..String
The range of cell locations expressed as string, e.g. "A3:B5".

Return Value

Type: CvsCellRange
The new CvsCellRange structure.

Remarks

The range may either be a single cell (like "B5") to designate a range with a single row and column, or it may be pair of cell strings separated by a colon (like "A3:B5") designating the range of cells.

'$' characters that precede rows or columns will be stripped when the location is parsed.

Exceptions

Exception | Condition
System..::..ArgumentException | The cell range string cannot be parsed.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.CvsCellRangeToString Method

[image]

In-Sight SDK
CvsUtility..::..CvsCellRangeToString Method
CvsUtility Class See Also Send Feedback
Converts the range to a string representation for a cell range (e.g. "B5:D10").

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string CvsCellRangeToString(
    int row,
    int column,
    int rows,
    int columns,
    bool absoluteRow,
    bool absoluteColumn,
    bool absoluteLastRow,
    bool absoluteLastColumn
)
Visual Basic
Public Function CvsCellRangeToString (
    row As Integer,
    column As Integer,
    rows As Integer,
    columns As Integer,
    absoluteRow As Boolean,
    absoluteColumn As Boolean,
    absoluteLastRow As Boolean,
    absoluteLastColumn As Boolean
) As String

Parameters

row
Type: System..::..Int32
The starting row (vertical) coordinate.
column
Type: System..::..Int32
The starting column (horizontal) coordinate.
rows
Type: System..::..Int32
The number of rows.
columns
Type: System..::..Int32
The number of columns.
absoluteRow
Type: System..::..Boolean
If true, the returned string will include the $ symbol to represent an absolute row reference (e.g. B$5:C6).
absoluteColumn
Type: System..::..Boolean
If true, the returned string will include the $ symbol to represent an absolute column reference (e.g. $B5:C6).
absoluteLastRow
Type: System..::..Boolean
If true, the returned string will include the $ symbol to represent an absolute last row reference (e.g. B5:C$6).
absoluteLastColumn
Type: System..::..Boolean
If true, the returned string will include the $ symbol to represent an absolute last column reference (e.g. B5:$C6).

Return Value

Type: String
A string that represents the range of cells (e.g. "B5:C6").

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.CvsDiscreteInputLineSupportsSignalSetting Method

[image]

In-Sight SDK
CvsUtility..::..CvsDiscreteInputLineSupportsSignalSetting Method
CvsUtility Class See Also Send Feedback
Determines if the input type supports a signal setting.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CvsDiscreteInputLineSupportsSignalSetting(
    CvsInputType type
)
Visual Basic
Public Function CvsDiscreteInputLineSupportsSignalSetting (
    type As CvsInputType
) As Boolean

Parameters

type
Type: Cognex.InSight.Sensor..::..CvsInputType
The input type to validate.

Return Value

Type: Boolean
true if input type supports the signal setting; otherwise, false.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.CvsDiscreteOutputLineSupportsPulseAndAcquisitionDelay Method

[image]

In-Sight SDK
CvsUtility..::..CvsDiscreteOutputLineSupportsPulseAndAcquisitionDelay Method
CvsUtility Class See Also Send Feedback
Determines if the output type supports pulse enable selection and acquisition delay settings. This type also supports a PulseLength setting when the PulseEnabledOrStrobedEdge flag is set to true.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CvsDiscreteOutputLineSupportsPulseAndAcquisitionDelay(
    CvsOutputType type
)
Visual Basic
Public Function CvsDiscreteOutputLineSupportsPulseAndAcquisitionDelay (
    type As CvsOutputType
) As Boolean

Parameters

type
Type: Cognex.InSight.Sensor..::..CvsOutputType
The output type to validate.

Return Value

Type: Boolean
true if pulse enabling and acquisition delay setting are valid; otherwise, false.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.CvsDiscreteOutputLineSupportsPulseLengthSetting Method

[image]

In-Sight SDK
CvsUtility..::..CvsDiscreteOutputLineSupportsPulseLengthSetting Method
CvsUtility Class See Also Send Feedback
Determines if the output type supports a pulse length setting without regard to the Pulse Enable flag.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CvsDiscreteOutputLineSupportsPulseLengthSetting(
    CvsOutputType type
)
Visual Basic
Public Function CvsDiscreteOutputLineSupportsPulseLengthSetting (
    type As CvsOutputType
) As Boolean

Parameters

type
Type: Cognex.InSight.Sensor..::..CvsOutputType
The output type to validate.

Return Value

Type: Boolean
true if pulse length setting is valid; otherwise, false.

Remarks

Note that Programmed lines must have the PulseEnabledOrStrobedEdge flag set to true to set the PulseLength.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.CvsDiscreteOutputLineSupportsStrobeTriggerSelection Method

[image]

In-Sight SDK
CvsUtility..::..CvsDiscreteOutputLineSupportsStrobeTriggerSelection Method
CvsUtility Class See Also Send Feedback
Determines if the output type supports a strobe trigger selection.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CvsDiscreteOutputLineSupportsStrobeTriggerSelection(
    CvsOutputType type
)
Visual Basic
Public Function CvsDiscreteOutputLineSupportsStrobeTriggerSelection (
    type As CvsOutputType
) As Boolean

Parameters

type
Type: Cognex.InSight.Sensor..::..CvsOutputType
The output type to validate.

Return Value

Type: Boolean
true if strobe trigger setting is valid to set; otherwise, false.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.CvsImageLocationFromLocation Method

[image]

In-Sight SDK
CvsUtility..::..CvsImageLocationFromLocation Method
CvsUtility Class See Also Send Feedback
Constructs a new instance of the CvsImageLocation structure.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation CvsImageLocationFromLocation(
    float row,
    float column
)
Visual Basic
Public Function CvsImageLocationFromLocation (
    row As Single,
    column As Single
) As CvsImageLocation

Parameters

row
Type: System..::..Single
The row (vertical) coordinate.
column
Type: System..::..Single
The column (horizontal) coordinate.

Return Value

Type: CvsImageLocation
A CvsImageLocation.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.CvsImageLocationToString Method

[image]

In-Sight SDK
CvsUtility..::..CvsImageLocationToString Method
CvsUtility Class See Also Send Feedback
Converts Row and Column to a human readable string.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string CvsImageLocationToString(
    float row,
    float column
)
Visual Basic
Public Function CvsImageLocationToString (
    row As Single,
    column As Single
) As String

Parameters

row
Type: System..::..Single
The row (vertical) coordinate.
column
Type: System..::..Single
The column (horizontal) coordinate.

Return Value

Type: String
A readable string with the row and column.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.CvsInSightSoftwareDevelopmentKitInitialize Method

[image]

In-Sight SDK
CvsUtility..::..CvsInSightSoftwareDevelopmentKitInitialize Method
CvsUtility Class See Also Send Feedback
Calls the initialization method of the CvsInSightSoftwareDevelopmentKit class.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[ObsoleteAttribute]
public void CvsInSightSoftwareDevelopmentKitInitialize()
Visual Basic
<ObsoleteAttribute>
Public Sub CvsInSightSoftwareDevelopmentKitInitialize

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.IsValidHostIPAddress Method

[image]

In-Sight SDK
CvsUtility..::..IsValidHostIPAddress Method
CvsUtility Class See Also Send Feedback
Determines if the string is a valid IP address.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValidHostIPAddress(
    string address
)
Visual Basic
Public Function IsValidHostIPAddress (
    address As String
) As Boolean

Parameters

address
Type: System..::..String
The IP address string.

Return Value

Type: Boolean
true if ipAddr is a valid IP address; otherwise, false.

Remarks

Valid range is {1, 223}.{0, 255}.{0, 255}.{1, 254}. An empty string is also considered a valid address. When empty string is used, the sensor is accessed via its name.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.IsValidHostName Method

[image]

In-Sight SDK
CvsUtility..::..IsValidHostName Method
CvsUtility Class See Also Send Feedback
Determines if the string is a valid host name. Checks the length and the content.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValidHostName(
    string s,
    bool allowZeroLength
)
Visual Basic
Public Function IsValidHostName (
    s As String,
    allowZeroLength As Boolean
) As Boolean

Parameters

s
Type: System..::..String
The host name string.
allowZeroLength
Type: System..::..Boolean
If true, means that zero length string is valid.

Return Value

Type: Boolean
true if s is a valid host name; otherwise, false.

Remarks

Valid characters include those returned from IsValidHostNameChar(String).

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.IsValidHostNameChar Method

[image]

In-Sight SDK
CvsUtility..::..IsValidHostNameChar Method
CvsUtility Class See Also Send Feedback
Determines if the first character in a string is valid for a host name.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValidHostNameChar(
    string s
)
Visual Basic
Public Function IsValidHostNameChar (
    s As String
) As Boolean

Parameters

s
Type: System..::..String
The character to validate. If the string is empty, false is returned.

Return Value

Type: Boolean
true if the character is valid; otherwise, false.

Remarks

Valid characters include letters, numeric digits, '_', '-', '.', or ':'.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.IsValidIPAddressChar Method

[image]

In-Sight SDK
CvsUtility..::..IsValidIPAddressChar Method
CvsUtility Class See Also Send Feedback
Determines if the first character in a string is valid for an IP address.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValidIPAddressChar(
    string s
)
Visual Basic
Public Function IsValidIPAddressChar (
    s As String
) As Boolean

Parameters

s
Type: System..::..String
The character to validate. If the string contains no characters, a false is returned.

Return Value

Type: Boolean
true if the character is valid; otherwise, false.

Remarks

Valid characters include numeric digits or '.'.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.IsValidPassword Method

[image]

In-Sight SDK
CvsUtility..::..IsValidPassword Method
CvsUtility Class See Also Send Feedback
Determines if the string is a valid password. Checks the length and the content.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValidPassword(
    string s
)
Visual Basic
Public Function IsValidPassword (
    s As String
) As Boolean

Parameters

s
Type: System..::..String
The password to validate.

Return Value

Type: Boolean
true if the string is a valid password; otherwise, false.

Remarks

Valid characters include those returned from IsValidUserNameOrPasswordChar(String).

Passwords use the same naming rules as usernames, except zero-length passwords are allowed.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.IsValidSensorName Method

[image]

In-Sight SDK
CvsUtility..::..IsValidSensorName Method
CvsUtility Class See Also Send Feedback
Determines if the string is a valid sensor name. Checks the length and the content.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValidSensorName(
    string s,
    bool allowZeroLength
)
Visual Basic
Public Function IsValidSensorName (
    s As String,
    allowZeroLength As Boolean
) As Boolean

Parameters

s
Type: System..::..String
The sensor name string.
allowZeroLength
Type: System..::..Boolean
If true, means that zero length string is valid.

Return Value

Type: Boolean
true if s is a valid sensor name; otherwise, false.

Remarks

Valid characters include those returned from IsValidSensorNameChar(String).

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.IsValidSensorNameChar Method

[image]

In-Sight SDK
CvsUtility..::..IsValidSensorNameChar Method
CvsUtility Class See Also Send Feedback
Determines if the first character in a string is valid for a sensor name.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValidSensorNameChar(
    string s
)
Visual Basic
Public Function IsValidSensorNameChar (
    s As String
) As Boolean

Parameters

s
Type: System..::..String
The character to validate. If the string is empty, false is returned.

Return Value

Type: Boolean
true if the character is valid; otherwise, false.

Remarks

Valid characters include English letters, numeric digits, '_', '-', '.', and ':'.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.IsValidSubnetIPAddress Method

[image]

In-Sight SDK
CvsUtility..::..IsValidSubnetIPAddress Method
CvsUtility Class See Also Send Feedback
Determines if the string is a valid Subnet IP address.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValidSubnetIPAddress(
    string address
)
Visual Basic
Public Function IsValidSubnetIPAddress (
    address As String
) As Boolean

Parameters

address
Type: System..::..String
The IP address string.

Return Value

Type: Boolean
true if ipAddr is a valid Subnet IP address; otherwise, false.

Remarks

Valid range is {0, 255}.{0, 255}.{0, 255}.{0, 255}.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.IsValidUserName Method

[image]

In-Sight SDK
CvsUtility..::..IsValidUserName Method
CvsUtility Class See Also Send Feedback
Determines if the string is a valid username. Checks the length and the content.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValidUserName(
    string s
)
Visual Basic
Public Function IsValidUserName (
    s As String
) As Boolean

Parameters

s
Type: System..::..String
The user name to validate.

Return Value

Type: Boolean
true if the string is a valid username; otherwise, false.

Remarks

Valid characters include those returned from IsValidUserNameOrPasswordChar(String).

Passwords use the same naming rules as usernames, except zero-length passwords are allowed.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.IsValidUserNameOrPasswordChar Method

[image]

In-Sight SDK
CvsUtility..::..IsValidUserNameOrPasswordChar Method
CvsUtility Class See Also Send Feedback
Determines if the first character in a string is valid for a user name or password.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValidUserNameOrPasswordChar(
    string s
)
Visual Basic
Public Function IsValidUserNameOrPasswordChar (
    s As String
) As Boolean

Parameters

s
Type: System..::..String
The character to validate. If the string contains no characters, a false is returned.

Return Value

Type: Boolean
true if the character is valid; otherwise, false.

Remarks

Valid characters include letters, numberic digits, '_', or '-'.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.OpenDialog Method

[image]

In-Sight SDK
CvsUtility..::..OpenDialog Method
CvsUtility Class See Also Send Feedback
Opens a dialog within a job.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void OpenDialog(
    CvsInSight inSight,
    string dlgLocation,
    string dlgText
)
Visual Basic
Public Sub OpenDialog (
    inSight As CvsInSight,
    dlgLocation As String,
    dlgText As String
)

Parameters

inSight
Type: Cognex.InSight..::..CvsInSight
The connection to the sensor.
dlgLocation
Type: System..::..String
The location of the dialog cell (e.g. "B5").
dlgText
Type: System..::..String
The text to display at the top of the dialog.

Remarks

This method should only be called when there is a display available to show the dialog.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsUtility.PingHost Method

[image]

In-Sight SDK
CvsUtility..::..PingHost Method
CvsUtility Class See Also Send Feedback
This method performs a network ping to determine if a sensor is available on the network.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool PingHost(
    string hostName,
    int timeToWait
)
Visual Basic
Public Function PingHost (
    hostName As String,
    timeToWait As Integer
) As Boolean

Parameters

hostName
Type: System..::..String
The host or IP address in string form.
timeToWait
Type: System..::..Int32
Amount to time (ms) to wait for a response.

Return Value

Type: Boolean
true if the sensor is available on the network; otherwise, false.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | When hostName cannot be resolved to a sensor on the network.

See Also

CvsUtility Class
CvsUtility..::..CvsUtility Members
Cognex.InSight Namespace


CvsView Class

[image]

In-Sight SDK
CvsView Class
Members See Also Send Feedback
Encapsulates the settings for a single In-Sight view.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsView : MarshalByRefObject
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsView
    Inherits MarshalByRefObject

Remarks

An In-Sight job has two views: normal and custom.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
Cognex.InSight..::..CvsView

See Also

CvsView..::..CvsView Members
Cognex.InSight Namespace


CvsView Members

[image] [image]

In-Sight SDK
CvsView Members
CvsView Class Methods Properties See Also Send Feedback

The CvsView type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | SetCurrentAndVisibleCells(CvsCellLocation, CvsCellRange) | Sets the CurrentLocation and VisibleCells properties.
Public method | SetCurrentAndVisibleCells(Int32, Int32, Int32, Int32, Int32, Int32) | Sets the CurrentLocation and VisibleCells properties.
Public method | Shift | Adjusts the view based on cells being inserted or deleted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveRange | Gets or sets the range of active (i.e. possibly visible) cells in cell coordinates.
Public property | Bounds | Gets or sets the location and size of the view in pixels.
Public property | CurrentLocation | Gets or sets the location of the current (active) cell.
Public property | IsCustomView | Returns true if the sheet is currently configured for the custom view.
Public property | IsDefined | Returns true if the view has been defined. The normal view is always considered to be defined while the custom view is considered to be defined if the active range is not equal to the entire sheet.
Public property | VisibleCells | Gets the visible range of cells

See Also

CvsView Class
Cognex.InSight Namespace


CvsView Methods

[image] [image]

In-Sight SDK
CvsView Methods
CvsView Class See Also Send Feedback

The CvsView type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | SetCurrentAndVisibleCells(CvsCellLocation, CvsCellRange) | Sets the CurrentLocation and VisibleCells properties.
Public method | SetCurrentAndVisibleCells(Int32, Int32, Int32, Int32, Int32, Int32) | Sets the CurrentLocation and VisibleCells properties.
Public method | Shift | Adjusts the view based on cells being inserted or deleted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsView Class
Cognex.InSight Namespace


CvsView.SetCurrentAndVisibleCells Method

[image] [image]

In-Sight SDK
CvsView..::..SetCurrentAndVisibleCells Method
CvsView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCurrentAndVisibleCells(CvsCellLocation, CvsCellRange) | Sets the CurrentLocation and VisibleCells properties.
Public method | SetCurrentAndVisibleCells(Int32, Int32, Int32, Int32, Int32, Int32) | Sets the CurrentLocation and VisibleCells properties.

See Also

CvsView Class
CvsView..::..CvsView Members
Cognex.InSight Namespace


CvsView.SetCurrentAndVisibleCells Method (CvsCellLocation, CvsCellRange)

[image]

In-Sight SDK
CvsView..::..SetCurrentAndVisibleCells Method (CvsCellLocation, CvsCellRange)
CvsView Class See Also Send Feedback
Sets the CurrentLocation and VisibleCells properties.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetCurrentAndVisibleCells(
    CvsCellLocation location,
    CvsCellRange visibleCells
)
Visual Basic
Public Sub SetCurrentAndVisibleCells (
    location As CvsCellLocation,
    visibleCells As CvsCellRange
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The location of the current (active) cell.
visibleCells
Type: Cognex.InSight..::..CvsCellRange
The visible range of cells.

Remarks

This overload is only available in .NET applications.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown when connected and this view is not the current view. Be sure the view is CurrentView, or call SwitchCurrentView(Boolean) to change the view.
System..::..ArgumentOutOfRangeException | location is not valid for the processor.
Cognex.InSight..::..CvsNetworkException | A network error occurred while setting the view.

See Also

CvsView Class
CvsView..::..CvsView Members
SetCurrentAndVisibleCells Overload
Cognex.InSight Namespace


CvsView.SetCurrentAndVisibleCells Method (Int32, Int32, Int32, Int32, Int32, Int32)

[image]

In-Sight SDK
CvsView..::..SetCurrentAndVisibleCells Method (Int32, Int32, Int32, Int32, Int32, Int32)
CvsView Class See Also Send Feedback
Sets the CurrentLocation and VisibleCells properties.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetCurrentAndVisibleCells(
    int row,
    int col,
    int visibleRow,
    int visibleColumn,
    int visibleRows,
    int visibleColumns
)
Visual Basic
Public Sub SetCurrentAndVisibleCells (
    row As Integer,
    col As Integer,
    visibleRow As Integer,
    visibleColumn As Integer,
    visibleRows As Integer,
    visibleColumns As Integer
)

Parameters

row
Type: System..::..Int32
The current (active) cell's row location.
col
Type: System..::..Int32
The current (active) cell's column location.
visibleRow
Type: System..::..Int32
The first row of the visible range.
visibleColumn
Type: System..::..Int32
The first column of the visible range.
visibleRows
Type: System..::..Int32
The number of rows in the visible range.
visibleColumns
Type: System..::..Int32
The number of columns in the visible range.

Remarks

This method is provided for COM/ActiveX interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | State is NotConnected. - or - This view is not the current view. Be sure the view is CurrentView, or call SwitchCurrentView(Boolean) to change the view.
System..::..ArgumentOutOfRangeException | location is not valid for the processor.
Cognex.InSight..::..CvsNetworkException | A network error occurred while setting the view.

See Also

CvsView Class
CvsView..::..CvsView Members
SetCurrentAndVisibleCells Overload
Cognex.InSight Namespace


CvsView.Shift Method

[image]

In-Sight SDK
CvsView..::..Shift Method
CvsView Class See Also Send Feedback
Adjusts the view based on cells being inserted or deleted.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Shift(
    CvsCellRange range,
    bool insert
)
Visual Basic
Public Function Shift (
    range As CvsCellRange,
    insert As Boolean
) As Boolean

Parameters

range
Type: Cognex.InSight..::..CvsCellRange
The range of cells inserted or deleted.
insert
Type: System..::..Boolean
True if the range was inserted, false if deleted.

Return Value

Type: Boolean
True if the view was modified, false if the view was not modified.

See Also

CvsView Class
CvsView..::..CvsView Members
Cognex.InSight Namespace


CvsView Properties

[image] [image]

In-Sight SDK
CvsView Properties
CvsView Class See Also Send Feedback

The CvsView type exposes the following members.

Properties

 | Name | Description
Public property | ActiveRange | Gets or sets the range of active (i.e. possibly visible) cells in cell coordinates.
Public property | Bounds | Gets or sets the location and size of the view in pixels.
Public property | CurrentLocation | Gets or sets the location of the current (active) cell.
Public property | IsCustomView | Returns true if the sheet is currently configured for the custom view.
Public property | IsDefined | Returns true if the view has been defined. The normal view is always considered to be defined while the custom view is considered to be defined if the active range is not equal to the entire sheet.
Public property | VisibleCells | Gets the visible range of cells

See Also

CvsView Class
Cognex.InSight Namespace


CvsView.ActiveRange Property

[image]

In-Sight SDK
CvsView..::..ActiveRange Property
CvsView Class See Also Send Feedback
Gets or sets the range of active (i.e. possibly visible) cells in cell coordinates.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellRange ActiveRange { get; set; }
Visual Basic
Public Property ActiveRange As CvsCellRange
    Get
    Set

Property Value

Type: CvsCellRange

Remarks

Normally this would include all cells from A0 to Z399 for example. However it will be a subset of this range when the custom view is shown. When the display is used to show a dialog, the ActiveRange will be a range of cells outside the range of "normal" cells, corresponding to the particular dialog being shown.

See Also

CvsView Class
CvsView..::..CvsView Members
Cognex.InSight Namespace


CvsView.Bounds Property

[image]

In-Sight SDK
CvsView..::..Bounds Property
CvsView Class See Also Send Feedback
Gets or sets the location and size of the view in pixels.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle Bounds { get; set; }
Visual Basic
Public Property Bounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown when connected and this view is not the current view. Be sure the view is CurrentView, or call SwitchCurrentView(Boolean) to change the view.
Cognex.InSight..::..CvsNetworkException | A network error occurred while setting the view.

See Also

CvsView Class
CvsView..::..CvsView Members
Cognex.InSight Namespace


CvsView.CurrentLocation Property

[image]

In-Sight SDK
CvsView..::..CurrentLocation Property
CvsView Class See Also Send Feedback
Gets or sets the location of the current (active) cell.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation CurrentLocation { get; set; }
Visual Basic
Public Property CurrentLocation As CvsCellLocation
    Get
    Set

Property Value

Type: CvsCellLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown when connected and this view is not the current view. Be sure the view is CurrentView, or call SwitchCurrentView(Boolean) to change the view.
System..::..ArgumentOutOfRangeException | Attempted to set the row or column to a value that is not valid for the processor.
Cognex.InSight..::..CvsNetworkException | A network error occurred while setting the view.

See Also

CvsView Class
CvsView..::..CvsView Members
Cognex.InSight Namespace


CvsView.IsCustomView Property

[image]

In-Sight SDK
CvsView..::..IsCustomView Property
CvsView Class See Also Send Feedback
Returns true if the sheet is currently configured for the custom view.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsCustomView { get; }
Visual Basic
Public ReadOnly Property IsCustomView As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsView Class
CvsView..::..CvsView Members
Cognex.InSight Namespace


CvsView.IsDefined Property

[image]

In-Sight SDK
CvsView..::..IsDefined Property
CvsView Class See Also Send Feedback
Returns true if the view has been defined. The normal view is always considered to be defined while the custom view is considered to be defined if the active range is not equal to the entire sheet.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsDefined { get; }
Visual Basic
Public ReadOnly Property IsDefined As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsView Class
CvsView..::..CvsView Members
Cognex.InSight Namespace


CvsView.VisibleCells Property

[image]

In-Sight SDK
CvsView..::..VisibleCells Property
CvsView Class See Also Send Feedback
Gets the visible range of cells

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellRange VisibleCells { get; }
Visual Basic
Public ReadOnly Property VisibleCells As CvsCellRange
    Get

Property Value

Type: CvsCellRange

See Also

CvsView Class
CvsView..::..CvsView Members
Cognex.InSight Namespace


ICvsActionObject Interface

[image]

In-Sight SDK
ICvsActionObject Interface
Members See Also Send Feedback
An interface for objects that get bound to a CvsAction.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public interface ICvsActionObject : IDisposable
Visual Basic
Public Interface ICvsActionObject
    Inherits IDisposable

See Also

ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject Members

[image] [image]

In-Sight SDK
ICvsActionObject Members
ICvsActionObject Interface Methods Properties Events See Also Send Feedback

The ICvsActionObject type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)

Properties

 | Name | Description
Public property | BindToEnabled | Returns true if the CvsAction should bind to the Enabled property.
Public property | BindToEvent | Returns true if the CvsAction should bind to the Activate event.
Public property | CheckedStatus | The status of a checkbox.
Public property | ContextMenuText | Gets and sets context menu text.
Public property | Enabled | Gets and sets the Enabled state of the object.
Public property | IconSize | Gets and sets the size of the object's icon.
Public property | Image | Gets and sets the image for the control.
Public property | ImageIndex | Gets and sets the image index for the control.
Public property | MenuText | Gets and sets menu text.
Public property | NewCheckedStatus | Returns the new checked status at the time of the event.
Public property | Tag | Returns an object
Public property | ToolTipText | Gets and sets tool tip text.
Public property | Visible | Gets and sets the objects visible status.

Events

 | Name | Description
Public event | Activate | An event to signal when the object has been activated/clicked/checked.

See Also

ICvsActionObject Interface
Cognex.InSight Namespace


ICvsActionObject Methods

[image] [image]

In-Sight SDK
ICvsActionObject Methods
ICvsActionObject Interface See Also Send Feedback

The ICvsActionObject type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)

See Also

ICvsActionObject Interface
Cognex.InSight Namespace


ICvsActionObject Properties

[image] [image]

In-Sight SDK
ICvsActionObject Properties
ICvsActionObject Interface See Also Send Feedback

The ICvsActionObject type exposes the following members.

Properties

 | Name | Description
Public property | BindToEnabled | Returns true if the CvsAction should bind to the Enabled property.
Public property | BindToEvent | Returns true if the CvsAction should bind to the Activate event.
Public property | CheckedStatus | The status of a checkbox.
Public property | ContextMenuText | Gets and sets context menu text.
Public property | Enabled | Gets and sets the Enabled state of the object.
Public property | IconSize | Gets and sets the size of the object's icon.
Public property | Image | Gets and sets the image for the control.
Public property | ImageIndex | Gets and sets the image index for the control.
Public property | MenuText | Gets and sets menu text.
Public property | NewCheckedStatus | Returns the new checked status at the time of the event.
Public property | Tag | Returns an object
Public property | ToolTipText | Gets and sets tool tip text.
Public property | Visible | Gets and sets the objects visible status.

See Also

ICvsActionObject Interface
Cognex.InSight Namespace


ICvsActionObject.BindToEnabled Property

[image]

In-Sight SDK
ICvsActionObject..::..BindToEnabled Property
ICvsActionObject Interface See Also Send Feedback
Returns true if the CvsAction should bind to the Enabled property.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
bool BindToEnabled { get; }
Visual Basic
ReadOnly Property BindToEnabled As Boolean
    Get

Property Value

Type: Boolean

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject.BindToEvent Property

[image]

In-Sight SDK
ICvsActionObject..::..BindToEvent Property
ICvsActionObject Interface See Also Send Feedback
Returns true if the CvsAction should bind to the Activate event.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
bool BindToEvent { get; }
Visual Basic
ReadOnly Property BindToEvent As Boolean
    Get

Property Value

Type: Boolean

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject.CheckedStatus Property

[image]

In-Sight SDK
ICvsActionObject..::..CheckedStatus Property
ICvsActionObject Interface See Also Send Feedback
The status of a checkbox.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
bool CheckedStatus { get; set; }
Visual Basic
Property CheckedStatus As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject.ContextMenuText Property

[image]

In-Sight SDK
ICvsActionObject..::..ContextMenuText Property
ICvsActionObject Interface See Also Send Feedback
Gets and sets context menu text.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
string ContextMenuText { get; set; }
Visual Basic
Property ContextMenuText As String
    Get
    Set

Property Value

Type: String

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject.Enabled Property

[image]

In-Sight SDK
ICvsActionObject..::..Enabled Property
ICvsActionObject Interface See Also Send Feedback
Gets and sets the Enabled state of the object.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
bool Enabled { get; set; }
Visual Basic
Property Enabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject.IconSize Property

[image]

In-Sight SDK
ICvsActionObject..::..IconSize Property
ICvsActionObject Interface See Also Send Feedback
Gets and sets the size of the object's icon.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
Size IconSize { get; }
Visual Basic
ReadOnly Property IconSize As Size
    Get

Property Value

Type: Size

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject.Image Property

[image]

In-Sight SDK
ICvsActionObject..::..Image Property
ICvsActionObject Interface See Also Send Feedback
Gets and sets the image for the control.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
Image Image { get; set; }
Visual Basic
Property Image As Image
    Get
    Set

Property Value

Type: Image

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject.ImageIndex Property

[image]

In-Sight SDK
ICvsActionObject..::..ImageIndex Property
ICvsActionObject Interface See Also Send Feedback
Gets and sets the image index for the control.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
int ImageIndex { get; set; }
Visual Basic
Property ImageIndex As Integer
    Get
    Set

Property Value

Type: Int32

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject.MenuText Property

[image]

In-Sight SDK
ICvsActionObject..::..MenuText Property
ICvsActionObject Interface See Also Send Feedback
Gets and sets menu text.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
string MenuText { get; set; }
Visual Basic
Property MenuText As String
    Get
    Set

Property Value

Type: String

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject.NewCheckedStatus Property

[image]

In-Sight SDK
ICvsActionObject..::..NewCheckedStatus Property
ICvsActionObject Interface See Also Send Feedback
Returns the new checked status at the time of the event.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
bool NewCheckedStatus { get; }
Visual Basic
ReadOnly Property NewCheckedStatus As Boolean
    Get

Property Value

Type: Boolean

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject.Tag Property

[image]

In-Sight SDK
ICvsActionObject..::..Tag Property
ICvsActionObject Interface See Also Send Feedback
Returns an object

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
Object Tag { get; set; }
Visual Basic
Property Tag As Object
    Get
    Set

Property Value

Type: Object

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject.ToolTipText Property

[image]

In-Sight SDK
ICvsActionObject..::..ToolTipText Property
ICvsActionObject Interface See Also Send Feedback
Gets and sets tool tip text.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
string ToolTipText { get; set; }
Visual Basic
Property ToolTipText As String
    Get
    Set

Property Value

Type: String

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject.Visible Property

[image]

In-Sight SDK
ICvsActionObject..::..Visible Property
ICvsActionObject Interface See Also Send Feedback
Gets and sets the objects visible status.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
bool Visible { get; set; }
Visual Basic
Property Visible As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


ICvsActionObject Events

[image] [image]

In-Sight SDK
ICvsActionObject Events
ICvsActionObject Interface See Also Send Feedback

The ICvsActionObject type exposes the following members.

Events

 | Name | Description
Public event | Activate | An event to signal when the object has been activated/clicked/checked.

See Also

ICvsActionObject Interface
Cognex.InSight Namespace


ICvsActionObject.Activate Event

[image]

In-Sight SDK
ICvsActionObject..::..Activate Event
ICvsActionObject Interface See Also Send Feedback
An event to signal when the object has been activated/clicked/checked.

Namespace: Cognex.InSight
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
event EventHandler Activate
Visual Basic
Event Activate As EventHandler

Value

Type: System..::..EventHandler

See Also

ICvsActionObject Interface
ICvsActionObject..::..ICvsActionObject Members
Cognex.InSight Namespace


Cognex.InSight.Cell Namespace

[image]

In-Sight SDK
Cognex.InSight.Cell Namespace
Send Feedback
The Cognex.InSight.Cell namespace provides the classes for accessing cell data associated with a set of results.

Classes

 | Class | Description
Public class | CvsCell | Provides a base class used to define CvsCell object classes.
Public class | CvsCellAuthorize | Represents a new cell type when the Control bit of a cell is set, and the ControlFunction is "Authorize". This allows a new grid control to be created instead of re-using the a string grid control.
Public class | CvsCellButton | Encapsulates the data associated with an In-Sight Button function.
Public class | CvsCellChart | Encapsulates the data associated with an In-Sight Chart function.
Public class | CvsCellCheckBox | Encapsulates the data associated with an In-Sight CheckBox function.
Public class | CvsCellCollection | Represents a collection of cells.
Public class | CvsCellColorLabel | Encapsulates the data associated with an In-Sight ColorLabel function.
Public class | CvsCellDialog | Encapsulates the data associated with an In-Sight Dialog function.
Public class | CvsCellEditAnnulus | Encapsulates the data associated with an In-Sight EditAnnulus function.
Public class | CvsCellEditCircle | Encapsulates the data associated with an In-Sight EditCircle function.
Public class | CvsCellEditComposite | Encapsulates the data associated with an In-Sight EditCompositeRegion function.
Public class | CvsCellEditFloat | Encapsulates the data associated with an In-Sight EditFloat function.
Public class | CvsCellEditGraphic | Defines a base class for editable graphics.
Public class | CvsCellEditInt | Encapsulates the data associated with an In-Sight EditInt function.
Public class | CvsCellEditLine | Encapsulates the data associated with an In-Sight EditLine function.
Public class | CvsCellEditMaskedRegion | Encapsulates the data associated with an In-Sight EditCompositeRegion function.
Public class | CvsCellEditMultiGraphics | Encapsulates the data associated with an In-Sight EditRegion function.
Public class | CvsCellEditPoint | Encapsulates the data associated with an In-Sight EditPoint function.
Public class | CvsCellEditPolygon | Encapsulates the data associated with an In-Sight EditPolygon function.
Public class | CvsCellEditPolylinePath | Encapsulates the data associated with an In-Sight EditCompositeRegion function.
Public class | CvsCellEditRegion | Encapsulates the data associated with an In-Sight EditRegion function.
Public class | CvsCellEditString | Encapsulates the data associated with an In-Sight EditString function.
Public class | CvsCellEmpty | Holds an empty cell's state.
Public class | CvsCellFloat | Encapsulates the data associated with an In-Sight cell that has a floating point number.
Public class | CvsCellInt | Encapsulates the data associated with an In-Sight cell that has an integer number.
Public class | CvsCellLink | Encapsulates the data associated with an In-Sight Link function.
Public class | CvsCellListBox | Encapsulates the data associated with an In-Sight ListBox function.
Public class | CvsCellMultiStatus | Encapsulates the data associated with an In-Sight MultiStatus function.
Public class | CvsCellOcrMaxAutoTune | Encapsulates the data associated with an In-Sight OcrMaxAutoTune function.
Public class | CvsCellSelect | Encapsulates the data associated with an In-Sight Select function.
Public class | CvsCellStatus | Encapsulates the data associated with an In-Sight Status function.
Public class | CvsCellStatusLight | Encapsulates the data associated with an In-Sight StatusLight function.
Public class | CvsCellString | Encapsulates the data associated with an In-Sight cell that has a text string displayed.
Public class | CvsCellWizard | Encapsulates the data associated with an In-Sight Wizard function.

Enumerations

 | Enumeration | Description
Public enumeration | CvsCellDataType | A enumeration of potential cell data types.
Public enumeration | CvsCellIPProtection | Defines the cell states for intellectual property protection.
Public enumeration | CvsCellProperty | An enumeration of cell properties.


CvsCell Class

[image]

In-Sight SDK
CvsCell Class
Members See Also Send Feedback
Provides a base class used to define CvsCell object classes.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public abstract class CvsCell : ICloneable
Visual Basic
<SerializableAttribute>
Public MustInherit Class CvsCell
    Implements ICloneable

Remarks

The CvsCell class is the abstract (MustInherit in Visual Basic) base class from which cells must derive.

CvsCell objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellButton
Cognex.InSight.Cell..::..CvsCellChart
Cognex.InSight.Cell..::..CvsCellCheckBox
Cognex.InSight.Cell..::..CvsCellColorLabel
Cognex.InSight.Cell..::..CvsCellDialog
Cognex.InSight.Cell..::..CvsCellEditFloat
Cognex.InSight.Cell..::..CvsCellEditGraphic
Cognex.InSight.Cell..::..CvsCellEditInt
Cognex.InSight.Cell..::..CvsCellEditString
Cognex.InSight.Cell..::..CvsCellEmpty
Cognex.InSight.Cell..::..CvsCellFloat
Cognex.InSight.Cell..::..CvsCellInt
Cognex.InSight.Cell..::..CvsCellLink
Cognex.InSight.Cell..::..CvsCellListBox
Cognex.InSight.Cell..::..CvsCellMultiStatus
Cognex.InSight.Cell..::..CvsCellOcrMaxAutoTune
Cognex.InSight.Cell..::..CvsCellSelect
Cognex.InSight.Cell..::..CvsCellStatus
Cognex.InSight.Cell..::..CvsCellStatusLight
Cognex.InSight.Cell..::..CvsCellString
Cognex.InSight.Cell..::..CvsCellWizard

See Also

CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell Members

[image] [image]

In-Sight SDK
CvsCell Members
CvsCell Class Methods Properties See Also Send Feedback

The CvsCell type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataTypeString | Given a data type, return the corresponding string.
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state.
Public property | Control | Gets a value indicating whether the cell represents a control.
Public property | DataType | Gets the data type of the cell.
Public property | DataTypeString | Gets the string name of the cell's data type.
Public property | Enabled | Gets a value indicating whether the cell is enabled.
Public property | Error | Gets a value indicating whether the cell is in error.
Public property | ErrorString | Gets a string describing the error.
Public property | Expression | Gets the expression associated with the cell.
Protected property | Flags | Returns the flags for this cell.
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data.
Public property | Hidden | Gets a value indicating whether the cell is hidden.
Public property | IsEditCell | Returns true if the cell is an 'edit' cell.
Public property | Location | Gets the cell's location.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set.
Public property | Properties | Gets the cell properties for this cell
Public property | ProtectionState | Gets the state of the cell protection.
Public property | SupportsAuthorization | Returns true if the cell supports authorization.
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set.
Public property | Text | Gets the text associated with the cell.

See Also

CvsCell Class
Cognex.InSight.Cell Namespace


CvsCell Methods

[image] [image]

In-Sight SDK
CvsCell Methods
CvsCell Class See Also Send Feedback

The CvsCell type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataTypeString | Given a data type, return the corresponding string.
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsCell Class
Cognex.InSight.Cell Namespace


CvsCell.GetDataTypeString Method

[image]

In-Sight SDK
CvsCell..::..GetDataTypeString Method
CvsCell Class See Also Send Feedback
Given a data type, return the corresponding string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static string GetDataTypeString(
    CvsCellDataType dataType
)
Visual Basic
Public Shared Function GetDataTypeString (
    dataType As CvsCellDataType
) As String

Parameters

dataType
Type: Cognex.InSight.Cell..::..CvsCellDataType
The data type.

Return Value

Type: String
A string that represents the data type.

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.GetHashCode Method

[image]

In-Sight SDK
CvsCell..::..GetHashCode Method
CvsCell Class See Also Send Feedback
Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash value for the current object.

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell Properties

[image] [image]

In-Sight SDK
CvsCell Properties
CvsCell Class See Also Send Feedback

The CvsCell type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state.
Public property | Control | Gets a value indicating whether the cell represents a control.
Public property | DataType | Gets the data type of the cell.
Public property | DataTypeString | Gets the string name of the cell's data type.
Public property | Enabled | Gets a value indicating whether the cell is enabled.
Public property | Error | Gets a value indicating whether the cell is in error.
Public property | ErrorString | Gets a string describing the error.
Public property | Expression | Gets the expression associated with the cell.
Protected property | Flags | Returns the flags for this cell.
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data.
Public property | Hidden | Gets a value indicating whether the cell is hidden.
Public property | IsEditCell | Returns true if the cell is an 'edit' cell.
Public property | Location | Gets the cell's location.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set.
Public property | Properties | Gets the cell properties for this cell
Public property | ProtectionState | Gets the state of the cell protection.
Public property | SupportsAuthorization | Returns true if the cell supports authorization.
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set.
Public property | Text | Gets the text associated with the cell.

See Also

CvsCell Class
Cognex.InSight.Cell Namespace


CvsCell.CellStateReference Property

[image]

In-Sight SDK
CvsCell..::..CellStateReference Property
CvsCell Class See Also Send Feedback
Gets the cell reference associated with a cell's state.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string CellStateReference { get; }
Visual Basic
Public ReadOnly Property CellStateReference As String
    Get

Property Value

Type: String

Remarks

If a cell is disabled or does not reference another cell, a null reference is returned (Nothing in Visual Basic).

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.Control Property

[image]

In-Sight SDK
CvsCell..::..Control Property
CvsCell Class See Also Send Feedback
Gets a value indicating whether the cell represents a control.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Control { get; }
Visual Basic
Public ReadOnly Property Control As Boolean
    Get

Property Value

Type: Boolean
true if the cell represents a control; otherwise, false.

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.DataType Property

[image]

In-Sight SDK
CvsCell..::..DataType Property
CvsCell Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual CvsCellDataType DataType { get; }
Visual Basic
Public Overridable ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType
The data type of the cell.

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.DataTypeString Property

[image]

In-Sight SDK
CvsCell..::..DataTypeString Property
CvsCell Class See Also Send Feedback
Gets the string name of the cell's data type.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string DataTypeString { get; }
Visual Basic
Public ReadOnly Property DataTypeString As String
    Get

Property Value

Type: String

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.Enabled Property

[image]

In-Sight SDK
CvsCell..::..Enabled Property
CvsCell Class See Also Send Feedback
Gets a value indicating whether the cell is enabled.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Enabled { get; }
Visual Basic
Public ReadOnly Property Enabled As Boolean
    Get

Property Value

Type: Boolean
true if the cell is enabled; otherwise, false.

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.Error Property

[image]

In-Sight SDK
CvsCell..::..Error Property
CvsCell Class See Also Send Feedback
Gets a value indicating whether the cell is in error.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Error { get; }
Visual Basic
Public ReadOnly Property Error As Boolean
    Get

Property Value

Type: Boolean
true if the cell has an error; otherwise, false.

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.ErrorString Property

[image]

In-Sight SDK
CvsCell..::..ErrorString Property
CvsCell Class See Also Send Feedback
Gets a string describing the error.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string ErrorString { get; }
Visual Basic
Public ReadOnly Property ErrorString As String
    Get

Property Value

Type: String

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.Expression Property

[image]

In-Sight SDK
CvsCell..::..Expression Property
CvsCell Class See Also Send Feedback
Gets the expression associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Expression { get; }
Visual Basic
Public ReadOnly Property Expression As String
    Get

Property Value

Type: String

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.Flags Property

[image]

In-Sight SDK
CvsCell..::..Flags Property
CvsCell Class See Also Send Feedback
Returns the flags for this cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
protected CvsCellFlags Flags { get; }
Visual Basic
Protected ReadOnly Property Flags As CvsCellFlags
    Get

Property Value

Type: CvsCellFlags

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.HasChecksum Property

[image]

In-Sight SDK
CvsCell..::..HasChecksum Property
CvsCell Class See Also Send Feedback
Gets a value indicating whether the cell has a checksum associated with its data.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool HasChecksum { get; }
Visual Basic
Public ReadOnly Property HasChecksum As Boolean
    Get

Property Value

Type: Boolean
true for cells that have additional data associated with them for which a checksum is calculated; otherwise, false.

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.Hidden Property

[image]

In-Sight SDK
CvsCell..::..Hidden Property
CvsCell Class See Also Send Feedback
Gets a value indicating whether the cell is hidden.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Hidden { get; }
Visual Basic
Public ReadOnly Property Hidden As Boolean
    Get

Property Value

Type: Boolean
true if the cell is hidden; otherwise, false.

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.IsEditCell Property

[image]

In-Sight SDK
CvsCell..::..IsEditCell Property
CvsCell Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual bool IsEditCell { get; }
Visual Basic
Public Overridable ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.Location Property

[image]

In-Sight SDK
CvsCell..::..Location Property
CvsCell Class See Also Send Feedback
Gets the cell's location.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation Location { get; }
Visual Basic
Public ReadOnly Property Location As CvsCellLocation
    Get

Property Value

Type: CvsCellLocation

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.OpcTag Property

[image]

In-Sight SDK
CvsCell..::..OpcTag Property
CvsCell Class See Also Send Feedback
Gets the OPC tag associated with the cell or null if it has not been set.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string OpcTag { get; }
Visual Basic
Public ReadOnly Property OpcTag As String
    Get

Property Value

Type: String

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.Properties Property

[image]

In-Sight SDK
CvsCell..::..Properties Property
CvsCell Class See Also Send Feedback
Gets the cell properties for this cell

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellProperty Properties { get; }
Visual Basic
Public ReadOnly Property Properties As CvsCellProperty
    Get

Property Value

Type: CvsCellProperty

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.ProtectionState Property

[image]

In-Sight SDK
CvsCell..::..ProtectionState Property
CvsCell Class See Also Send Feedback
Gets the state of the cell protection.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellIPProtection ProtectionState { get; }
Visual Basic
Public ReadOnly Property ProtectionState As CvsCellIPProtection
    Get

Property Value

Type: CvsCellIPProtection

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.SupportsAuthorization Property

[image]

In-Sight SDK
CvsCell..::..SupportsAuthorization Property
CvsCell Class See Also Send Feedback
Returns true if the cell supports authorization.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual bool SupportsAuthorization { get; }
Visual Basic
Public Overridable ReadOnly Property SupportsAuthorization As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.SymbolicTag Property

[image]

In-Sight SDK
CvsCell..::..SymbolicTag Property
CvsCell Class See Also Send Feedback
Gets the symbolic tag associated with the cell or null if it has not been set.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string SymbolicTag { get; }
Visual Basic
Public ReadOnly Property SymbolicTag As String
    Get

Property Value

Type: String

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCell.Text Property

[image]

In-Sight SDK
CvsCell..::..Text Property
CvsCell Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual string Text { get; }
Visual Basic
Public Overridable ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCell Class
CvsCell..::..CvsCell Members
Cognex.InSight.Cell Namespace


CvsCellAuthorize Class

[image]

In-Sight SDK
CvsCellAuthorize Class
Members See Also Send Feedback
Represents a new cell type when the Control bit of a cell is set, and the ControlFunction is "Authorize". This allows a new grid control to be created instead of re-using the a string grid control.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsCellAuthorize : CvsCellString
Visual Basic
<SerializableAttribute>
Public Class CvsCellAuthorize
    Inherits CvsCellString

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellString
Cognex.InSight.Cell..::..CvsCellAuthorize

See Also

CvsCellAuthorize..::..CvsCellAuthorize Members
Cognex.InSight.Cell Namespace


CvsCellAuthorize Members

[image] [image]

In-Sight SDK
CvsCellAuthorize Members
CvsCellAuthorize Class Constructors Methods Properties See Also Send Feedback

The CvsCellAuthorize type exposes the following members.

Constructors

 | Name | Description
Public method | CvsCellAuthorize | Initializes a new instance that is a copy of the specified instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetRawBytes | Gets the un-encoded bytes that represent the text associated with the cell. (Inherited from CvsCellString.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the Text for the cell. (Inherited from CvsCellString.)

Properties

 | Name | Description
Public property | AsciiText | Gets the text string associated with the cell assuming that it represents an ASCII string. (Inherited from CvsCellString.)
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Checksum | Gets the checksum of the data associated with the cell's function. (Inherited from CvsCellString.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | ControlFunction | Gets a string (in ASCII) that describes the control or the empty string if this cell does not represent a control. (Inherited from CvsCellString.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellString.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Protected property | Flags | Returns the flags for this cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text string associated with the cell. (Inherited from CvsCellString.)

See Also

CvsCellAuthorize Class
Cognex.InSight.Cell Namespace


CvsCellAuthorize Constructor

[image]

In-Sight SDK
CvsCellAuthorize Constructor
CvsCellAuthorize Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellAuthorize(
    CvsCellString cell
)
Visual Basic
Public Sub New (
    cell As CvsCellString
)

Parameters

cell
Type: Cognex.InSight.Cell..::..CvsCellString
The instance to copy.

See Also

CvsCellAuthorize Class
CvsCellAuthorize..::..CvsCellAuthorize Members
Cognex.InSight.Cell Namespace


CvsCellAuthorize Methods

[image] [image]

In-Sight SDK
CvsCellAuthorize Methods
CvsCellAuthorize Class See Also Send Feedback

The CvsCellAuthorize type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetRawBytes | Gets the un-encoded bytes that represent the text associated with the cell. (Inherited from CvsCellString.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the Text for the cell. (Inherited from CvsCellString.)

See Also

CvsCellAuthorize Class
Cognex.InSight.Cell Namespace


CvsCellAuthorize Properties

[image] [image]

In-Sight SDK
CvsCellAuthorize Properties
CvsCellAuthorize Class See Also Send Feedback

The CvsCellAuthorize type exposes the following members.

Properties

 | Name | Description
Public property | AsciiText | Gets the text string associated with the cell assuming that it represents an ASCII string. (Inherited from CvsCellString.)
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Checksum | Gets the checksum of the data associated with the cell's function. (Inherited from CvsCellString.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | ControlFunction | Gets a string (in ASCII) that describes the control or the empty string if this cell does not represent a control. (Inherited from CvsCellString.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellString.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Protected property | Flags | Returns the flags for this cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text string associated with the cell. (Inherited from CvsCellString.)

See Also

CvsCellAuthorize Class
Cognex.InSight.Cell Namespace


CvsCellAuthorize.IsEditCell Property

[image]

In-Sight SDK
CvsCellAuthorize..::..IsEditCell Property
CvsCellAuthorize Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool IsEditCell { get; }
Visual Basic
Public Overrides ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellAuthorize Class
CvsCellAuthorize..::..CvsCellAuthorize Members
Cognex.InSight.Cell Namespace


CvsCellButton Class

[image]

In-Sight SDK
CvsCellButton Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight Button function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellButton : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellButton
    Inherits CvsCell

Remarks

CvsCellButton objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellButton

See Also

CvsCellButton..::..CvsCellButton Members
Cognex.InSight.Cell Namespace


CvsCellButton Members

[image] [image]

In-Sight SDK
CvsCellButton Members
CvsCellButton Class Methods Properties See Also Send Feedback

The CvsCellButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the Text for the button. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the button. (Overrides CvsCell..::..Text.)

See Also

CvsCellButton Class
Cognex.InSight.Cell Namespace


CvsCellButton Methods

[image] [image]

In-Sight SDK
CvsCellButton Methods
CvsCellButton Class See Also Send Feedback

The CvsCellButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the Text for the button. (Overrides Object..::..ToString()()()().)

See Also

CvsCellButton Class
Cognex.InSight.Cell Namespace


CvsCellButton.ToString Method

[image]

In-Sight SDK
CvsCellButton..::..ToString Method
CvsCellButton Class See Also Send Feedback
Returns the Text for the button.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellButton Class
CvsCellButton..::..CvsCellButton Members
Cognex.InSight.Cell Namespace


CvsCellButton Properties

[image] [image]

In-Sight SDK
CvsCellButton Properties
CvsCellButton Class See Also Send Feedback

The CvsCellButton type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the button. (Overrides CvsCell..::..Text.)

See Also

CvsCellButton Class
Cognex.InSight.Cell Namespace


CvsCellButton.DataType Property

[image]

In-Sight SDK
CvsCellButton..::..DataType Property
CvsCellButton Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellButton Class
CvsCellButton..::..CvsCellButton Members
Cognex.InSight.Cell Namespace


CvsCellButton.IsEditCell Property

[image]

In-Sight SDK
CvsCellButton..::..IsEditCell Property
CvsCellButton Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool IsEditCell { get; }
Visual Basic
Public Overrides ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellButton Class
CvsCellButton..::..CvsCellButton Members
Cognex.InSight.Cell Namespace


CvsCellButton.Text Property

[image]

In-Sight SDK
CvsCellButton..::..Text Property
CvsCellButton Class See Also Send Feedback
Gets the text for the button.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellButton Class
CvsCellButton..::..CvsCellButton Members
Cognex.InSight.Cell Namespace


CvsCellChart Class

[image]

In-Sight SDK
CvsCellChart Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight Chart function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellChart : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellChart
    Inherits CvsCell

Remarks

CvsCellChart objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellChart

See Also

CvsCellChart..::..CvsCellChart Members
Cognex.InSight.Cell Namespace


CvsCellChart Members

[image] [image]

In-Sight SDK
CvsCellChart Members
CvsCellChart Class Methods Properties See Also Send Feedback

The CvsCellChart type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetData | Returns the chart's data.
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the text that describes the chart. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | MaxPoints | Gets the maximum possible number of data points in the chart. This is greater than or equal to NumPoints.
Public property | MaxValue | Gets the maximum value to be displayed in the chart.
Public property | MinValue | Gets the minimum value to be displayed in the chart.
Public property | NumPoints | Gets the actual number of data points in the chart.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text that describes the chart. (Overrides CvsCell..::..Text.)

See Also

CvsCellChart Class
Cognex.InSight.Cell Namespace


CvsCellChart Methods

[image] [image]

In-Sight SDK
CvsCellChart Methods
CvsCellChart Class See Also Send Feedback

The CvsCellChart type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetData | Returns the chart's data.
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the text that describes the chart. (Overrides Object..::..ToString()()()().)

See Also

CvsCellChart Class
Cognex.InSight.Cell Namespace


CvsCellChart.GetData Method

[image]

In-Sight SDK
CvsCellChart..::..GetData Method
CvsCellChart Class See Also Send Feedback
Returns the chart's data.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public double[] GetData()
Visual Basic
Public Function GetData As Double()

Return Value

Type: array< Double >[]()[][]
An array of length NumPoints.

Remarks

Each data point that is inclusively between the MinValue and MaxValue should be rendered.

See Also

CvsCellChart Class
CvsCellChart..::..CvsCellChart Members
Cognex.InSight.Cell Namespace


CvsCellChart.ToString Method

[image]

In-Sight SDK
CvsCellChart..::..ToString Method
CvsCellChart Class See Also Send Feedback
Returns the text that describes the chart.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellChart Class
CvsCellChart..::..CvsCellChart Members
Cognex.InSight.Cell Namespace


CvsCellChart Properties

[image] [image]

In-Sight SDK
CvsCellChart Properties
CvsCellChart Class See Also Send Feedback

The CvsCellChart type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | MaxPoints | Gets the maximum possible number of data points in the chart. This is greater than or equal to NumPoints.
Public property | MaxValue | Gets the maximum value to be displayed in the chart.
Public property | MinValue | Gets the minimum value to be displayed in the chart.
Public property | NumPoints | Gets the actual number of data points in the chart.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text that describes the chart. (Overrides CvsCell..::..Text.)

See Also

CvsCellChart Class
Cognex.InSight.Cell Namespace


CvsCellChart.DataType Property

[image]

In-Sight SDK
CvsCellChart..::..DataType Property
CvsCellChart Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellChart Class
CvsCellChart..::..CvsCellChart Members
Cognex.InSight.Cell Namespace


CvsCellChart.MaxPoints Property

[image]

In-Sight SDK
CvsCellChart..::..MaxPoints Property
CvsCellChart Class See Also Send Feedback
Gets the maximum possible number of data points in the chart. This is greater than or equal to NumPoints.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxPoints { get; }
Visual Basic
Public ReadOnly Property MaxPoints As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellChart Class
CvsCellChart..::..CvsCellChart Members
Cognex.InSight.Cell Namespace


CvsCellChart.MaxValue Property

[image]

In-Sight SDK
CvsCellChart..::..MaxValue Property
CvsCellChart Class See Also Send Feedback
Gets the maximum value to be displayed in the chart.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public double MaxValue { get; }
Visual Basic
Public ReadOnly Property MaxValue As Double
    Get

Property Value

Type: Double

See Also

CvsCellChart Class
CvsCellChart..::..CvsCellChart Members
Cognex.InSight.Cell Namespace


CvsCellChart.MinValue Property

[image]

In-Sight SDK
CvsCellChart..::..MinValue Property
CvsCellChart Class See Also Send Feedback
Gets the minimum value to be displayed in the chart.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public double MinValue { get; }
Visual Basic
Public ReadOnly Property MinValue As Double
    Get

Property Value

Type: Double

See Also

CvsCellChart Class
CvsCellChart..::..CvsCellChart Members
Cognex.InSight.Cell Namespace


CvsCellChart.NumPoints Property

[image]

In-Sight SDK
CvsCellChart..::..NumPoints Property
CvsCellChart Class See Also Send Feedback
Gets the actual number of data points in the chart.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NumPoints { get; }
Visual Basic
Public ReadOnly Property NumPoints As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellChart Class
CvsCellChart..::..CvsCellChart Members
Cognex.InSight.Cell Namespace


CvsCellChart.Text Property

[image]

In-Sight SDK
CvsCellChart..::..Text Property
CvsCellChart Class See Also Send Feedback
Gets the text that describes the chart.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellChart Class
CvsCellChart..::..CvsCellChart Members
Cognex.InSight.Cell Namespace


CvsCellCheckBox Class

[image]

In-Sight SDK
CvsCellCheckBox Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight CheckBox function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellCheckBox : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellCheckBox
    Inherits CvsCell

Remarks

CvsCellCheckBox objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellCheckBox

See Also

CvsCellCheckBox..::..CvsCellCheckBox Members
Cognex.InSight.Cell Namespace


CvsCellCheckBox Members

[image] [image]

In-Sight SDK
CvsCellCheckBox Members
CvsCellCheckBox Class Methods Properties See Also Send Feedback

The CvsCellCheckBox type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the checked state of the cell to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Checked | Gets the checked state of the CheckBox cell.
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the CheckBox cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellCheckBox Class
Cognex.InSight.Cell Namespace


CvsCellCheckBox Methods

[image] [image]

In-Sight SDK
CvsCellCheckBox Methods
CvsCellCheckBox Class See Also Send Feedback

The CvsCellCheckBox type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the checked state of the cell to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellCheckBox Class
Cognex.InSight.Cell Namespace


CvsCellCheckBox.ToString Method

[image]

In-Sight SDK
CvsCellCheckBox..::..ToString Method
CvsCellCheckBox Class See Also Send Feedback
Converts the checked state of the cell to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellCheckBox Class
CvsCellCheckBox..::..CvsCellCheckBox Members
Cognex.InSight.Cell Namespace


CvsCellCheckBox Properties

[image] [image]

In-Sight SDK
CvsCellCheckBox Properties
CvsCellCheckBox Class See Also Send Feedback

The CvsCellCheckBox type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Checked | Gets the checked state of the CheckBox cell.
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the CheckBox cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellCheckBox Class
Cognex.InSight.Cell Namespace


CvsCellCheckBox.Checked Property

[image]

In-Sight SDK
CvsCellCheckBox..::..Checked Property
CvsCellCheckBox Class See Also Send Feedback
Gets the checked state of the CheckBox cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Checked { get; }
Visual Basic
Public ReadOnly Property Checked As Boolean
    Get

Property Value

Type: Boolean
true if check box is checked; otherwise, false.

See Also

CvsCellCheckBox Class
CvsCellCheckBox..::..CvsCellCheckBox Members
Cognex.InSight.Cell Namespace


CvsCellCheckBox.DataType Property

[image]

In-Sight SDK
CvsCellCheckBox..::..DataType Property
CvsCellCheckBox Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellCheckBox Class
CvsCellCheckBox..::..CvsCellCheckBox Members
Cognex.InSight.Cell Namespace


CvsCellCheckBox.IsEditCell Property

[image]

In-Sight SDK
CvsCellCheckBox..::..IsEditCell Property
CvsCellCheckBox Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool IsEditCell { get; }
Visual Basic
Public Overrides ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellCheckBox Class
CvsCellCheckBox..::..CvsCellCheckBox Members
Cognex.InSight.Cell Namespace


CvsCellCheckBox.Text Property

[image]

In-Sight SDK
CvsCellCheckBox..::..Text Property
CvsCellCheckBox Class See Also Send Feedback
Gets the text associated with the CheckBox cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellCheckBox Class
CvsCellCheckBox..::..CvsCellCheckBox Members
Cognex.InSight.Cell Namespace


CvsCellCollection Class

[image]

In-Sight SDK
CvsCellCollection Class
Members See Also Send Feedback
Represents a collection of cells.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellCollection : IEnumerable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellCollection
    Implements IEnumerable

Remarks

Each item is a CvsCell object.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCellCollection

See Also

CvsCellCollection..::..CvsCellCollection Members
Cognex.InSight.Cell Namespace


CvsCellCollection Members

[image] [image]

In-Sight SDK
CvsCellCollection Members
CvsCellCollection Class Methods Properties See Also Send Feedback

The CvsCellCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCell(Int32, Int32) | Gets the CvsCell object at the specified row and column. Returns null if the cell is empty.
Public method | GetCell(Int32, Int32, Int32) | Gets the CvsCell object at the specified sheet, row and column. Returns null if the cell is empty.
Public method | GetCells(CvsCellRange) | Get a collection containing all cells within a given cell range.
Public method | GetCells(Int32, Int32, Int32, Int32) | Get a collection containing all cells within a given cell range.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Gets the index of the cell at the given location.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of items in the collection.
Public property | Item[([( Int32])]) | Gets the CvsCell object at the specified zero-based index. The index must be nonnegative and less than Count.
Public property | Item[([( String])]) | Gets the CvsCell object at the specified row and column. Returns null if the cell is empty.
Public property | Item[([( CvsCellLocation])]) | Gets the CvsCell object at the specified location. Returns null if the cell is empty.

See Also

CvsCellCollection Class
Cognex.InSight.Cell Namespace


CvsCellCollection Methods

[image] [image]

In-Sight SDK
CvsCellCollection Methods
CvsCellCollection Class See Also Send Feedback

The CvsCellCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCell(Int32, Int32) | Gets the CvsCell object at the specified row and column. Returns null if the cell is empty.
Public method | GetCell(Int32, Int32, Int32) | Gets the CvsCell object at the specified sheet, row and column. Returns null if the cell is empty.
Public method | GetCells(CvsCellRange) | Get a collection containing all cells within a given cell range.
Public method | GetCells(Int32, Int32, Int32, Int32) | Get a collection containing all cells within a given cell range.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Gets the index of the cell at the given location.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsCellCollection Class
Cognex.InSight.Cell Namespace


CvsCellCollection.GetCell Method

[image] [image]

In-Sight SDK
CvsCellCollection..::..GetCell Method
CvsCellCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCell(Int32, Int32) | Gets the CvsCell object at the specified row and column. Returns null if the cell is empty.
Public method | GetCell(Int32, Int32, Int32) | Gets the CvsCell object at the specified sheet, row and column. Returns null if the cell is empty.

See Also

CvsCellCollection Class
CvsCellCollection..::..CvsCellCollection Members
Cognex.InSight.Cell Namespace


CvsCellCollection.GetCell Method (Int32, Int32)

[image]

In-Sight SDK
CvsCellCollection..::..GetCell Method (Int32, Int32)
CvsCellCollection Class See Also Send Feedback
Gets the CvsCell object at the specified row and column. Returns null if the cell is empty.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCell GetCell(
    int row,
    int column
)
Visual Basic
Public Function GetCell (
    row As Integer,
    column As Integer
) As CvsCell

Parameters

row
Type: System..::..Int32
The cell's row (vertical) coordinate.
column
Type: System..::..Int32
The cell's column (horizontal) coordinate.

Return Value

Type: CvsCell
A CvsCell object for the location.

See Also

CvsCellCollection Class
CvsCellCollection..::..CvsCellCollection Members
GetCell Overload
Cognex.InSight.Cell Namespace


CvsCellCollection.GetCell Method (Int32, Int32, Int32)

[image]

In-Sight SDK
CvsCellCollection..::..GetCell Method (Int32, Int32, Int32)
CvsCellCollection Class See Also Send Feedback
Gets the CvsCell object at the specified sheet, row and column. Returns null if the cell is empty.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCell GetCell(
    int sheetIndex,
    int row,
    int column
)
Visual Basic
Public Function GetCell (
    sheetIndex As Integer,
    row As Integer,
    column As Integer
) As CvsCell

Parameters

sheetIndex
Type: System..::..Int32
The cell's sheet index.
row
Type: System..::..Int32
The cell's row (vertical) coordinate.
column
Type: System..::..Int32
The cell's column (horizontal) coordinate.

Return Value

Type: CvsCell
A CvsCell object for the location.

See Also

CvsCellCollection Class
CvsCellCollection..::..CvsCellCollection Members
GetCell Overload
Cognex.InSight.Cell Namespace


CvsCellCollection.GetCells Method

[image] [image]

In-Sight SDK
CvsCellCollection..::..GetCells Method
CvsCellCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCells(CvsCellRange) | Get a collection containing all cells within a given cell range.
Public method | GetCells(Int32, Int32, Int32, Int32) | Get a collection containing all cells within a given cell range.

See Also

CvsCellCollection Class
CvsCellCollection..::..CvsCellCollection Members
Cognex.InSight.Cell Namespace


CvsCellCollection.GetCells Method (CvsCellRange)

[image]

In-Sight SDK
CvsCellCollection..::..GetCells Method (CvsCellRange)
CvsCellCollection Class See Also Send Feedback
Get a collection containing all cells within a given cell range.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellCollection GetCells(
    CvsCellRange range
)
Visual Basic
Public Function GetCells (
    range As CvsCellRange
) As CvsCellCollection

Parameters

range
Type: Cognex.InSight..::..CvsCellRange
The cell range for which to get all cells.

Return Value

Type: CvsCellCollection
A collection of all cells inside the given range.

Remarks

This overload of this method is not available in COM/ActiveX applications.

See Also

CvsCellCollection Class
CvsCellCollection..::..CvsCellCollection Members
GetCells Overload
Cognex.InSight.Cell Namespace


CvsCellCollection.GetCells Method (Int32, Int32, Int32, Int32)

[image]

In-Sight SDK
CvsCellCollection..::..GetCells Method (Int32, Int32, Int32, Int32)
CvsCellCollection Class See Also Send Feedback
Get a collection containing all cells within a given cell range.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellCollection GetCells(
    int row,
    int column,
    int rows,
    int columns
)
Visual Basic
Public Function GetCells (
    row As Integer,
    column As Integer,
    rows As Integer,
    columns As Integer
) As CvsCellCollection

Parameters

row
Type: System..::..Int32
The starting cell's row (vertical) coordinate.
column
Type: System..::..Int32
The starting cell's column (horizontal) coordinate.
rows
Type: System..::..Int32
The number of rows.
columns
Type: System..::..Int32
The number of columns.

Return Value

Type: CvsCellCollection
A collection of all cells inside the given range.

See Also

CvsCellCollection Class
CvsCellCollection..::..CvsCellCollection Members
GetCells Overload
Cognex.InSight.Cell Namespace


CvsCellCollection.IndexOf Method

[image]

In-Sight SDK
CvsCellCollection..::..IndexOf Method
CvsCellCollection Class See Also Send Feedback
Gets the index of the cell at the given location.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IndexOf(
    CvsCellLocation location
)
Visual Basic
Public Function IndexOf (
    location As CvsCellLocation
) As Integer

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location for which to search.

Return Value

Type: Int32
The index of the cell with the given location, of one is found. -or- A negative number, which is the bitwise complement of the index at which a cell with the given location would be inserted to maintain the sort order.

See Also

CvsCellCollection Class
CvsCellCollection..::..CvsCellCollection Members
Cognex.InSight.Cell Namespace


CvsCellCollection Properties

[image] [image]

In-Sight SDK
CvsCellCollection Properties
CvsCellCollection Class See Also Send Feedback

The CvsCellCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of items in the collection.
Public property | Item[([( Int32])]) | Gets the CvsCell object at the specified zero-based index. The index must be nonnegative and less than Count.
Public property | Item[([( String])]) | Gets the CvsCell object at the specified row and column. Returns null if the cell is empty.
Public property | Item[([( CvsCellLocation])]) | Gets the CvsCell object at the specified location. Returns null if the cell is empty.

See Also

CvsCellCollection Class
Cognex.InSight.Cell Namespace


CvsCellCollection.Count Property

[image]

In-Sight SDK
CvsCellCollection..::..Count Property
CvsCellCollection Class See Also Send Feedback
Gets the number of items in the collection.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellCollection Class
CvsCellCollection..::..CvsCellCollection Members
Cognex.InSight.Cell Namespace


CvsCellCollection.Item Property

[image] [image]

In-Sight SDK
CvsCellCollection..::..Item Property
CvsCellCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets the CvsCell object at the specified zero-based index. The index must be nonnegative and less than Count.
Public property | Item[([( String])]) | Gets the CvsCell object at the specified row and column. Returns null if the cell is empty.
Public property | Item[([( CvsCellLocation])]) | Gets the CvsCell object at the specified location. Returns null if the cell is empty.

See Also

CvsCellCollection Class
CvsCellCollection..::..CvsCellCollection Members
Cognex.InSight.Cell Namespace


CvsCellCollection.Item Property (Int32)

[image]

In-Sight SDK
CvsCellCollection..::..Item Property (Int32)
CvsCellCollection Class See Also Send Feedback
Gets the CvsCell object at the specified zero-based index. The index must be nonnegative and less than Count.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCell this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As CvsCell
    Get

Parameters

index
Type: System..::..Int32
The zero-based index into the collection.

Property Value

Type: CvsCell

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsCellCollection Class
CvsCellCollection..::..CvsCellCollection Members
Item Overload
Cognex.InSight.Cell Namespace


CvsCellCollection.Item Property (String)

[image]

In-Sight SDK
CvsCellCollection..::..Item Property (String)
CvsCellCollection Class See Also Send Feedback
Gets the CvsCell object at the specified row and column. Returns null if the cell is empty.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCell this[
    string cell
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    cell As String
) As CvsCell
    Get

Parameters

cell
Type: System..::..String
The cell location reference (e.g. "A0").

Property Value

Type: CvsCell

Exceptions

Exception | Condition
System..::..ArgumentException | The cell location string cannot be parsed.

See Also

CvsCellCollection Class
CvsCellCollection..::..CvsCellCollection Members
Item Overload
Cognex.InSight.Cell Namespace


CvsCellCollection.Item Property (CvsCellLocation)

[image]

In-Sight SDK
CvsCellCollection..::..Item Property (CvsCellLocation)
CvsCellCollection Class See Also Send Feedback
Gets the CvsCell object at the specified location. Returns null if the cell is empty.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCell this[
    CvsCellLocation cell
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    cell As CvsCellLocation
) As CvsCell
    Get

Parameters

cell
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.

Property Value

Type: CvsCell

Remarks

This indexer is only available in .NET applications.

See Also

CvsCellCollection Class
CvsCellCollection..::..CvsCellCollection Members
Item Overload
Cognex.InSight.Cell Namespace


CvsCellColorLabel Class

[image]

In-Sight SDK
CvsCellColorLabel Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight ColorLabel function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellColorLabel : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellColorLabel
    Inherits CvsCell

Remarks

CvsCellColorLabel objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellColorLabel

See Also

CvsCellColorLabel..::..CvsCellColorLabel Members
Cognex.InSight.Cell Namespace


CvsCellColorLabel Members

[image] [image]

In-Sight SDK
CvsCellColorLabel Members
CvsCellColorLabel Class Methods Properties See Also Send Feedback

The CvsCellColorLabel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the text for the color label. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | BackColor | Gets the background color of the color label.
Public property | BackColorAsRgb | Gets the BackColor as an RGB value.
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | ForeColor | Gets the foreground color of the color label.
Public property | ForeColorAsRgb | Gets the ForeColor as an RGB value.
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the color label. (Overrides CvsCell..::..Text.)

See Also

CvsCellColorLabel Class
Cognex.InSight.Cell Namespace


CvsCellColorLabel Methods

[image] [image]

In-Sight SDK
CvsCellColorLabel Methods
CvsCellColorLabel Class See Also Send Feedback

The CvsCellColorLabel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the text for the color label. (Overrides Object..::..ToString()()()().)

See Also

CvsCellColorLabel Class
Cognex.InSight.Cell Namespace


CvsCellColorLabel.ToString Method

[image]

In-Sight SDK
CvsCellColorLabel..::..ToString Method
CvsCellColorLabel Class See Also Send Feedback
Returns the text for the color label.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellColorLabel Class
CvsCellColorLabel..::..CvsCellColorLabel Members
Cognex.InSight.Cell Namespace


CvsCellColorLabel Properties

[image] [image]

In-Sight SDK
CvsCellColorLabel Properties
CvsCellColorLabel Class See Also Send Feedback

The CvsCellColorLabel type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | Gets the background color of the color label.
Public property | BackColorAsRgb | Gets the BackColor as an RGB value.
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | ForeColor | Gets the foreground color of the color label.
Public property | ForeColorAsRgb | Gets the ForeColor as an RGB value.
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the color label. (Overrides CvsCell..::..Text.)

See Also

CvsCellColorLabel Class
Cognex.InSight.Cell Namespace


CvsCellColorLabel.BackColor Property

[image]

In-Sight SDK
CvsCellColorLabel..::..BackColor Property
CvsCellColorLabel Class See Also Send Feedback
Gets the background color of the color label.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color BackColor { get; }
Visual Basic
Public ReadOnly Property BackColor As Color
    Get

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

See Also

CvsCellColorLabel Class
CvsCellColorLabel..::..CvsCellColorLabel Members
Cognex.InSight.Cell Namespace


CvsCellColorLabel.BackColorAsRgb Property

[image]

In-Sight SDK
CvsCellColorLabel..::..BackColorAsRgb Property
CvsCellColorLabel Class See Also Send Feedback
Gets the BackColor as an RGB value.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int BackColorAsRgb { get; }
Visual Basic
Public ReadOnly Property BackColorAsRgb As Integer
    Get

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

See Also

CvsCellColorLabel Class
CvsCellColorLabel..::..CvsCellColorLabel Members
Cognex.InSight.Cell Namespace


CvsCellColorLabel.DataType Property

[image]

In-Sight SDK
CvsCellColorLabel..::..DataType Property
CvsCellColorLabel Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellColorLabel Class
CvsCellColorLabel..::..CvsCellColorLabel Members
Cognex.InSight.Cell Namespace


CvsCellColorLabel.ForeColor Property

[image]

In-Sight SDK
CvsCellColorLabel..::..ForeColor Property
CvsCellColorLabel Class See Also Send Feedback
Gets the foreground color of the color label.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color ForeColor { get; }
Visual Basic
Public ReadOnly Property ForeColor As Color
    Get

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

See Also

CvsCellColorLabel Class
CvsCellColorLabel..::..CvsCellColorLabel Members
Cognex.InSight.Cell Namespace


CvsCellColorLabel.ForeColorAsRgb Property

[image]

In-Sight SDK
CvsCellColorLabel..::..ForeColorAsRgb Property
CvsCellColorLabel Class See Also Send Feedback
Gets the ForeColor as an RGB value.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int ForeColorAsRgb { get; }
Visual Basic
Public ReadOnly Property ForeColorAsRgb As Integer
    Get

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

See Also

CvsCellColorLabel Class
CvsCellColorLabel..::..CvsCellColorLabel Members
Cognex.InSight.Cell Namespace


CvsCellColorLabel.Text Property

[image]

In-Sight SDK
CvsCellColorLabel..::..Text Property
CvsCellColorLabel Class See Also Send Feedback
Gets the text for the color label.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellColorLabel Class
CvsCellColorLabel..::..CvsCellColorLabel Members
Cognex.InSight.Cell Namespace


CvsCellDataType Enumeration

[image]

In-Sight SDK
CvsCellDataType Enumeration
See Also Send Feedback
A enumeration of potential cell data types.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public enum CvsCellDataType
Visual Basic
<SerializableAttribute>
Public Enumeration CvsCellDataType

Members

Member name | Value | Description
Unknown | -1 | An unknown data type.
Integer | 0 | An integer data type.
FloatingPoint | 1 | A floating point data type.
String | 2 | A string data type.
Action | 3 | An action data type.
Chart | 4 | A chart data type.

See Also

Cognex.InSight.Cell Namespace


CvsCellDialog Class

[image]

In-Sight SDK
CvsCellDialog Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight Dialog function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellDialog : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellDialog
    Inherits CvsCell

Remarks

CvsCellDialog objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellDialog

See Also

CvsCellDialog..::..CvsCellDialog Members
Cognex.InSight.Cell Namespace


CvsCellDialog Members

[image] [image]

In-Sight SDK
CvsCellDialog Members
CvsCellDialog Class Methods Properties See Also Send Feedback

The CvsCellDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the text for the Dialog cell. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | DialogRange | Gets the range of cells belonging to this Dialog cell. Its Location will be CvsCellLocation.Invalid if the dialog range is unknown.
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the Dialog cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellDialog Class
Cognex.InSight.Cell Namespace


CvsCellDialog Methods

[image] [image]

In-Sight SDK
CvsCellDialog Methods
CvsCellDialog Class See Also Send Feedback

The CvsCellDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the text for the Dialog cell. (Overrides Object..::..ToString()()()().)

See Also

CvsCellDialog Class
Cognex.InSight.Cell Namespace


CvsCellDialog.ToString Method

[image]

In-Sight SDK
CvsCellDialog..::..ToString Method
CvsCellDialog Class See Also Send Feedback
Returns the text for the Dialog cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellDialog Class
CvsCellDialog..::..CvsCellDialog Members
Cognex.InSight.Cell Namespace


CvsCellDialog Properties

[image] [image]

In-Sight SDK
CvsCellDialog Properties
CvsCellDialog Class See Also Send Feedback

The CvsCellDialog type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | DialogRange | Gets the range of cells belonging to this Dialog cell. Its Location will be CvsCellLocation.Invalid if the dialog range is unknown.
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the Dialog cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellDialog Class
Cognex.InSight.Cell Namespace


CvsCellDialog.DataType Property

[image]

In-Sight SDK
CvsCellDialog..::..DataType Property
CvsCellDialog Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellDialog Class
CvsCellDialog..::..CvsCellDialog Members
Cognex.InSight.Cell Namespace


CvsCellDialog.DialogRange Property

[image]

In-Sight SDK
CvsCellDialog..::..DialogRange Property
CvsCellDialog Class See Also Send Feedback
Gets the range of cells belonging to this Dialog cell. Its Location will be CvsCellLocation.Invalid if the dialog range is unknown.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellRange DialogRange { get; }
Visual Basic
Public ReadOnly Property DialogRange As CvsCellRange
    Get

Property Value

Type: CvsCellRange

See Also

CvsCellDialog Class
CvsCellDialog..::..CvsCellDialog Members
Cognex.InSight.Cell Namespace


CvsCellDialog.IsEditCell Property

[image]

In-Sight SDK
CvsCellDialog..::..IsEditCell Property
CvsCellDialog Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool IsEditCell { get; }
Visual Basic
Public Overrides ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellDialog Class
CvsCellDialog..::..CvsCellDialog Members
Cognex.InSight.Cell Namespace


CvsCellDialog.Text Property

[image]

In-Sight SDK
CvsCellDialog..::..Text Property
CvsCellDialog Class See Also Send Feedback
Gets the text for the Dialog cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellDialog Class
CvsCellDialog..::..CvsCellDialog Members
Cognex.InSight.Cell Namespace


CvsCellEditAnnulus Class

[image]

In-Sight SDK
CvsCellEditAnnulus Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight EditAnnulus function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEditAnnulus : CvsCellEditGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEditAnnulus
    Inherits CvsCellEditGraphic

Remarks

CvsCellEditAnnulus objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditGraphic
Cognex.InSight.Cell..::..CvsCellEditAnnulus

See Also

CvsCellEditAnnulus..::..CvsCellEditAnnulus Members
Cognex.InSight.Cell Namespace


CvsCellEditAnnulus Members

[image] [image]

In-Sight SDK
CvsCellEditAnnulus Members
CvsCellEditAnnulus Class Methods Properties See Also Send Feedback

The CvsCellEditAnnulus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Center | Gets the location of the center of the graphic. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | InnerRadius | Gets the inner radius of the annulus in pixels.
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | OuterRadius | Gets the outer radius of the annulus in pixels.
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditAnnulus Class
Cognex.InSight.Cell Namespace


CvsCellEditAnnulus Methods

[image] [image]

In-Sight SDK
CvsCellEditAnnulus Methods
CvsCellEditAnnulus Class See Also Send Feedback

The CvsCellEditAnnulus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEditAnnulus Class
Cognex.InSight.Cell Namespace


CvsCellEditAnnulus.ToString Method

[image]

In-Sight SDK
CvsCellEditAnnulus..::..ToString Method
CvsCellEditAnnulus Class See Also Send Feedback
Converts the properties of the cell to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEditAnnulus Class
CvsCellEditAnnulus..::..CvsCellEditAnnulus Members
Cognex.InSight.Cell Namespace


CvsCellEditAnnulus Properties

[image] [image]

In-Sight SDK
CvsCellEditAnnulus Properties
CvsCellEditAnnulus Class See Also Send Feedback

The CvsCellEditAnnulus type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Center | Gets the location of the center of the graphic. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | InnerRadius | Gets the inner radius of the annulus in pixels.
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | OuterRadius | Gets the outer radius of the annulus in pixels.
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditAnnulus Class
Cognex.InSight.Cell Namespace


CvsCellEditAnnulus.Center Property

[image]

In-Sight SDK
CvsCellEditAnnulus..::..Center Property
CvsCellEditAnnulus Class See Also Send Feedback
Gets the location of the center of the graphic. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Center { get; }
Visual Basic
Public ReadOnly Property Center As CvsImageLocation
    Get

Property Value

Type: CvsImageLocation

See Also

CvsCellEditAnnulus Class
CvsCellEditAnnulus..::..CvsCellEditAnnulus Members
Cognex.InSight.Cell Namespace


CvsCellEditAnnulus.InnerRadius Property

[image]

In-Sight SDK
CvsCellEditAnnulus..::..InnerRadius Property
CvsCellEditAnnulus Class See Also Send Feedback
Gets the inner radius of the annulus in pixels.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float InnerRadius { get; }
Visual Basic
Public ReadOnly Property InnerRadius As Single
    Get

Property Value

Type: Single

See Also

CvsCellEditAnnulus Class
CvsCellEditAnnulus..::..CvsCellEditAnnulus Members
Cognex.InSight.Cell Namespace


CvsCellEditAnnulus.OuterRadius Property

[image]

In-Sight SDK
CvsCellEditAnnulus..::..OuterRadius Property
CvsCellEditAnnulus Class See Also Send Feedback
Gets the outer radius of the annulus in pixels.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float OuterRadius { get; }
Visual Basic
Public ReadOnly Property OuterRadius As Single
    Get

Property Value

Type: Single

See Also

CvsCellEditAnnulus Class
CvsCellEditAnnulus..::..CvsCellEditAnnulus Members
Cognex.InSight.Cell Namespace


CvsCellEditAnnulus.Text Property

[image]

In-Sight SDK
CvsCellEditAnnulus..::..Text Property
CvsCellEditAnnulus Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellEditAnnulus Class
CvsCellEditAnnulus..::..CvsCellEditAnnulus Members
Cognex.InSight.Cell Namespace


CvsCellEditCircle Class

[image]

In-Sight SDK
CvsCellEditCircle Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight EditCircle function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEditCircle : CvsCellEditGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEditCircle
    Inherits CvsCellEditGraphic

Remarks

CvsCellEditCircle objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditGraphic
Cognex.InSight.Cell..::..CvsCellEditCircle

See Also

CvsCellEditCircle..::..CvsCellEditCircle Members
Cognex.InSight.Cell Namespace


CvsCellEditCircle Members

[image] [image]

In-Sight SDK
CvsCellEditCircle Members
CvsCellEditCircle Class Methods Properties See Also Send Feedback

The CvsCellEditCircle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Center | Gets the center of the circle graphic. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | Radius | Gets the radius of the circle in pixels.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditCircle Class
Cognex.InSight.Cell Namespace


CvsCellEditCircle Methods

[image] [image]

In-Sight SDK
CvsCellEditCircle Methods
CvsCellEditCircle Class See Also Send Feedback

The CvsCellEditCircle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEditCircle Class
Cognex.InSight.Cell Namespace


CvsCellEditCircle.ToString Method

[image]

In-Sight SDK
CvsCellEditCircle..::..ToString Method
CvsCellEditCircle Class See Also Send Feedback
Converts the properties of the cell to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEditCircle Class
CvsCellEditCircle..::..CvsCellEditCircle Members
Cognex.InSight.Cell Namespace


CvsCellEditCircle Properties

[image] [image]

In-Sight SDK
CvsCellEditCircle Properties
CvsCellEditCircle Class See Also Send Feedback

The CvsCellEditCircle type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Center | Gets the center of the circle graphic. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | Radius | Gets the radius of the circle in pixels.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditCircle Class
Cognex.InSight.Cell Namespace


CvsCellEditCircle.Center Property

[image]

In-Sight SDK
CvsCellEditCircle..::..Center Property
CvsCellEditCircle Class See Also Send Feedback
Gets the center of the circle graphic. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Center { get; }
Visual Basic
Public ReadOnly Property Center As CvsImageLocation
    Get

Property Value

Type: CvsImageLocation

See Also

CvsCellEditCircle Class
CvsCellEditCircle..::..CvsCellEditCircle Members
Cognex.InSight.Cell Namespace


CvsCellEditCircle.Radius Property

[image]

In-Sight SDK
CvsCellEditCircle..::..Radius Property
CvsCellEditCircle Class See Also Send Feedback
Gets the radius of the circle in pixels.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Radius { get; }
Visual Basic
Public ReadOnly Property Radius As Single
    Get

Property Value

Type: Single

See Also

CvsCellEditCircle Class
CvsCellEditCircle..::..CvsCellEditCircle Members
Cognex.InSight.Cell Namespace


CvsCellEditCircle.Text Property

[image]

In-Sight SDK
CvsCellEditCircle..::..Text Property
CvsCellEditCircle Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellEditCircle Class
CvsCellEditCircle..::..CvsCellEditCircle Members
Cognex.InSight.Cell Namespace


CvsCellEditComposite Class

[image]

In-Sight SDK
CvsCellEditComposite Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight EditCompositeRegion function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEditComposite : CvsCellEditGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEditComposite
    Inherits CvsCellEditGraphic

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditGraphic
Cognex.InSight.Cell..::..CvsCellEditComposite

See Also

CvsCellEditComposite..::..CvsCellEditComposite Members
Cognex.InSight.Cell Namespace


CvsCellEditComposite Members

[image] [image]

In-Sight SDK
CvsCellEditComposite Members
CvsCellEditComposite Class Methods Properties See Also Send Feedback

The CvsCellEditComposite type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | Subregions | Provides read-only access to the subregions that define the composite region.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditComposite Class
Cognex.InSight.Cell Namespace


CvsCellEditComposite Methods

[image] [image]

In-Sight SDK
CvsCellEditComposite Methods
CvsCellEditComposite Class See Also Send Feedback

The CvsCellEditComposite type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEditComposite Class
Cognex.InSight.Cell Namespace


CvsCellEditComposite.ToString Method

[image]

In-Sight SDK
CvsCellEditComposite..::..ToString Method
CvsCellEditComposite Class See Also Send Feedback
Converts the properties of the cell to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEditComposite Class
CvsCellEditComposite..::..CvsCellEditComposite Members
Cognex.InSight.Cell Namespace


CvsCellEditComposite Properties

[image] [image]

In-Sight SDK
CvsCellEditComposite Properties
CvsCellEditComposite Class See Also Send Feedback

The CvsCellEditComposite type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | Subregions | Provides read-only access to the subregions that define the composite region.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditComposite Class
Cognex.InSight.Cell Namespace


CvsCellEditComposite.Subregions Property

[image]

In-Sight SDK
CvsCellEditComposite..::..Subregions Property
CvsCellEditComposite Class See Also Send Feedback
Provides read-only access to the subregions that define the composite region.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeSubregion[] Subregions { get; }
Visual Basic
Public ReadOnly Property Subregions As CvsCompositeSubregion()
    Get

Property Value

Type: array< CvsCompositeSubregion >[]()[][]

See Also

CvsCellEditComposite Class
CvsCellEditComposite..::..CvsCellEditComposite Members
Cognex.InSight.Cell Namespace


CvsCellEditComposite.Text Property

[image]

In-Sight SDK
CvsCellEditComposite..::..Text Property
CvsCellEditComposite Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellEditComposite Class
CvsCellEditComposite..::..CvsCellEditComposite Members
Cognex.InSight.Cell Namespace


CvsCellEditFloat Class

[image]

In-Sight SDK
CvsCellEditFloat Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight EditFloat function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEditFloat : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEditFloat
    Inherits CvsCell

Remarks

CvsCellEditFloat objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditFloat

See Also

CvsCellEditFloat..::..CvsCellEditFloat Members
Cognex.InSight.Cell Namespace


CvsCellEditFloat Members

[image] [image]

In-Sight SDK
CvsCellEditFloat Members
CvsCellEditFloat Class Methods Properties See Also Send Feedback

The CvsCellEditFloat type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the Value to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | MaxValue | Gets the maximum numeric value of the edit control cell.
Public property | MinValue | Gets the minimum numeric value of the edit control cell.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Overrides CvsCell..::..SupportsAuthorization.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the numeric value of the edit control cell.

See Also

CvsCellEditFloat Class
Cognex.InSight.Cell Namespace


CvsCellEditFloat Methods

[image] [image]

In-Sight SDK
CvsCellEditFloat Methods
CvsCellEditFloat Class See Also Send Feedback

The CvsCellEditFloat type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the Value to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEditFloat Class
Cognex.InSight.Cell Namespace


CvsCellEditFloat.ToString Method

[image]

In-Sight SDK
CvsCellEditFloat..::..ToString Method
CvsCellEditFloat Class See Also Send Feedback
Converts the Value to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEditFloat Class
CvsCellEditFloat..::..CvsCellEditFloat Members
Cognex.InSight.Cell Namespace


CvsCellEditFloat Properties

[image] [image]

In-Sight SDK
CvsCellEditFloat Properties
CvsCellEditFloat Class See Also Send Feedback

The CvsCellEditFloat type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | MaxValue | Gets the maximum numeric value of the edit control cell.
Public property | MinValue | Gets the minimum numeric value of the edit control cell.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Overrides CvsCell..::..SupportsAuthorization.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the numeric value of the edit control cell.

See Also

CvsCellEditFloat Class
Cognex.InSight.Cell Namespace


CvsCellEditFloat.DataType Property

[image]

In-Sight SDK
CvsCellEditFloat..::..DataType Property
CvsCellEditFloat Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellEditFloat Class
CvsCellEditFloat..::..CvsCellEditFloat Members
Cognex.InSight.Cell Namespace


CvsCellEditFloat.IsEditCell Property

[image]

In-Sight SDK
CvsCellEditFloat..::..IsEditCell Property
CvsCellEditFloat Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool IsEditCell { get; }
Visual Basic
Public Overrides ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellEditFloat Class
CvsCellEditFloat..::..CvsCellEditFloat Members
Cognex.InSight.Cell Namespace


CvsCellEditFloat.MaxValue Property

[image]

In-Sight SDK
CvsCellEditFloat..::..MaxValue Property
CvsCellEditFloat Class See Also Send Feedback
Gets the maximum numeric value of the edit control cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float MaxValue { get; }
Visual Basic
Public ReadOnly Property MaxValue As Single
    Get

Property Value

Type: Single

See Also

CvsCellEditFloat Class
CvsCellEditFloat..::..CvsCellEditFloat Members
Cognex.InSight.Cell Namespace


CvsCellEditFloat.MinValue Property

[image]

In-Sight SDK
CvsCellEditFloat..::..MinValue Property
CvsCellEditFloat Class See Also Send Feedback
Gets the minimum numeric value of the edit control cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float MinValue { get; }
Visual Basic
Public ReadOnly Property MinValue As Single
    Get

Property Value

Type: Single

See Also

CvsCellEditFloat Class
CvsCellEditFloat..::..CvsCellEditFloat Members
Cognex.InSight.Cell Namespace


CvsCellEditFloat.SupportsAuthorization Property

[image]

In-Sight SDK
CvsCellEditFloat..::..SupportsAuthorization Property
CvsCellEditFloat Class See Also Send Feedback
Returns true if the cell supports authorization.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool SupportsAuthorization { get; }
Visual Basic
Public Overrides ReadOnly Property SupportsAuthorization As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellEditFloat Class
CvsCellEditFloat..::..CvsCellEditFloat Members
Cognex.InSight.Cell Namespace


CvsCellEditFloat.Text Property

[image]

In-Sight SDK
CvsCellEditFloat..::..Text Property
CvsCellEditFloat Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellEditFloat Class
CvsCellEditFloat..::..CvsCellEditFloat Members
Cognex.InSight.Cell Namespace


CvsCellEditFloat.Value Property

[image]

In-Sight SDK
CvsCellEditFloat..::..Value Property
CvsCellEditFloat Class See Also Send Feedback
Gets the numeric value of the edit control cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Value { get; }
Visual Basic
Public ReadOnly Property Value As Single
    Get

Property Value

Type: Single

See Also

CvsCellEditFloat Class
CvsCellEditFloat..::..CvsCellEditFloat Members
Cognex.InSight.Cell Namespace


CvsCellEditGraphic Class

[image]

In-Sight SDK
CvsCellEditGraphic Class
Members See Also Send Feedback
Defines a base class for editable graphics.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public abstract class CvsCellEditGraphic : CvsCell
Visual Basic
<SerializableAttribute>
Public MustInherit Class CvsCellEditGraphic
    Inherits CvsCell

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditGraphic
Cognex.InSight.Cell..::..CvsCellEditAnnulus
Cognex.InSight.Cell..::..CvsCellEditCircle
Cognex.InSight.Cell..::..CvsCellEditComposite
Cognex.InSight.Cell..::..CvsCellEditLine
Cognex.InSight.Cell..::..CvsCellEditMaskedRegion
Cognex.InSight.Cell..::..CvsCellEditMultiGraphics
Cognex.InSight.Cell..::..CvsCellEditPoint
Cognex.InSight.Cell..::..CvsCellEditPolygon
Cognex.InSight.Cell..::..CvsCellEditPolylinePath
Cognex.InSight.Cell..::..CvsCellEditRegion

See Also

CvsCellEditGraphic..::..CvsCellEditGraphic Members
Cognex.InSight.Cell Namespace


CvsCellEditGraphic Members

[image] [image]

In-Sight SDK
CvsCellEditGraphic Members
CvsCellEditGraphic Class Methods Properties See Also Send Feedback

The CvsCellEditGraphic type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell.
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Protected property | Flags | Returns the flags for this cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Inherited from CvsCell.)

See Also

CvsCellEditGraphic Class
Cognex.InSight.Cell Namespace


CvsCellEditGraphic Methods

[image] [image]

In-Sight SDK
CvsCellEditGraphic Methods
CvsCellEditGraphic Class See Also Send Feedback

The CvsCellEditGraphic type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsCellEditGraphic Class
Cognex.InSight.Cell Namespace


CvsCellEditGraphic Properties

[image] [image]

In-Sight SDK
CvsCellEditGraphic Properties
CvsCellEditGraphic Class See Also Send Feedback

The CvsCellEditGraphic type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell.
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Protected property | Flags | Returns the flags for this cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Inherited from CvsCell.)

See Also

CvsCellEditGraphic Class
Cognex.InSight.Cell Namespace


CvsCellEditGraphic.DataType Property

[image]

In-Sight SDK
CvsCellEditGraphic..::..DataType Property
CvsCellEditGraphic Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellEditGraphic Class
CvsCellEditGraphic..::..CvsCellEditGraphic Members
Cognex.InSight.Cell Namespace


CvsCellEditGraphic.EditFlags Property

[image]

In-Sight SDK
CvsCellEditGraphic..::..EditFlags Property
CvsCellEditGraphic Class See Also Send Feedback
Gets the value that describes the editing capabilities of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEditFlags EditFlags { get; }
Visual Basic
Public ReadOnly Property EditFlags As CvsEditFlags
    Get

Property Value

Type: CvsEditFlags

See Also

CvsCellEditGraphic Class
CvsCellEditGraphic..::..CvsCellEditGraphic Members
Cognex.InSight.Cell Namespace


CvsCellEditGraphic.IsEditCell Property

[image]

In-Sight SDK
CvsCellEditGraphic..::..IsEditCell Property
CvsCellEditGraphic Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool IsEditCell { get; }
Visual Basic
Public Overrides ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellEditGraphic Class
CvsCellEditGraphic..::..CvsCellEditGraphic Members
Cognex.InSight.Cell Namespace


CvsCellEditInt Class

[image]

In-Sight SDK
CvsCellEditInt Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight EditInt function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEditInt : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEditInt
    Inherits CvsCell

Remarks

CvsCellEditInt objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditInt

See Also

CvsCellEditInt..::..CvsCellEditInt Members
Cognex.InSight.Cell Namespace


CvsCellEditInt Members

[image] [image]

In-Sight SDK
CvsCellEditInt Members
CvsCellEditInt Class Methods Properties See Also Send Feedback

The CvsCellEditInt type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the Value to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | MaxValue | Gets the maximum numeric value of the edit control cell.
Public property | MinValue | Gets the minimum numeric value of the edit control cell.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Overrides CvsCell..::..SupportsAuthorization.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the numeric value of the edit control cell.

See Also

CvsCellEditInt Class
Cognex.InSight.Cell Namespace


CvsCellEditInt Methods

[image] [image]

In-Sight SDK
CvsCellEditInt Methods
CvsCellEditInt Class See Also Send Feedback

The CvsCellEditInt type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the Value to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEditInt Class
Cognex.InSight.Cell Namespace


CvsCellEditInt.ToString Method

[image]

In-Sight SDK
CvsCellEditInt..::..ToString Method
CvsCellEditInt Class See Also Send Feedback
Converts the Value to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEditInt Class
CvsCellEditInt..::..CvsCellEditInt Members
Cognex.InSight.Cell Namespace


CvsCellEditInt Properties

[image] [image]

In-Sight SDK
CvsCellEditInt Properties
CvsCellEditInt Class See Also Send Feedback

The CvsCellEditInt type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | MaxValue | Gets the maximum numeric value of the edit control cell.
Public property | MinValue | Gets the minimum numeric value of the edit control cell.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Overrides CvsCell..::..SupportsAuthorization.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the numeric value of the edit control cell.

See Also

CvsCellEditInt Class
Cognex.InSight.Cell Namespace


CvsCellEditInt.DataType Property

[image]

In-Sight SDK
CvsCellEditInt..::..DataType Property
CvsCellEditInt Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellEditInt Class
CvsCellEditInt..::..CvsCellEditInt Members
Cognex.InSight.Cell Namespace


CvsCellEditInt.IsEditCell Property

[image]

In-Sight SDK
CvsCellEditInt..::..IsEditCell Property
CvsCellEditInt Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool IsEditCell { get; }
Visual Basic
Public Overrides ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellEditInt Class
CvsCellEditInt..::..CvsCellEditInt Members
Cognex.InSight.Cell Namespace


CvsCellEditInt.MaxValue Property

[image]

In-Sight SDK
CvsCellEditInt..::..MaxValue Property
CvsCellEditInt Class See Also Send Feedback
Gets the maximum numeric value of the edit control cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxValue { get; }
Visual Basic
Public ReadOnly Property MaxValue As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellEditInt Class
CvsCellEditInt..::..CvsCellEditInt Members
Cognex.InSight.Cell Namespace


CvsCellEditInt.MinValue Property

[image]

In-Sight SDK
CvsCellEditInt..::..MinValue Property
CvsCellEditInt Class See Also Send Feedback
Gets the minimum numeric value of the edit control cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MinValue { get; }
Visual Basic
Public ReadOnly Property MinValue As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellEditInt Class
CvsCellEditInt..::..CvsCellEditInt Members
Cognex.InSight.Cell Namespace


CvsCellEditInt.SupportsAuthorization Property

[image]

In-Sight SDK
CvsCellEditInt..::..SupportsAuthorization Property
CvsCellEditInt Class See Also Send Feedback
Returns true if the cell supports authorization.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool SupportsAuthorization { get; }
Visual Basic
Public Overrides ReadOnly Property SupportsAuthorization As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellEditInt Class
CvsCellEditInt..::..CvsCellEditInt Members
Cognex.InSight.Cell Namespace


CvsCellEditInt.Text Property

[image]

In-Sight SDK
CvsCellEditInt..::..Text Property
CvsCellEditInt Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellEditInt Class
CvsCellEditInt..::..CvsCellEditInt Members
Cognex.InSight.Cell Namespace


CvsCellEditInt.Value Property

[image]

In-Sight SDK
CvsCellEditInt..::..Value Property
CvsCellEditInt Class See Also Send Feedback
Gets the numeric value of the edit control cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Value { get; }
Visual Basic
Public ReadOnly Property Value As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellEditInt Class
CvsCellEditInt..::..CvsCellEditInt Members
Cognex.InSight.Cell Namespace


CvsCellEditLine Class

[image]

In-Sight SDK
CvsCellEditLine Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight EditLine function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEditLine : CvsCellEditGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEditLine
    Inherits CvsCellEditGraphic

Remarks

CvsCellEditLine objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditGraphic
Cognex.InSight.Cell..::..CvsCellEditLine

See Also

CvsCellEditLine..::..CvsCellEditLine Members
Cognex.InSight.Cell Namespace


CvsCellEditLine Members

[image] [image]

In-Sight SDK
CvsCellEditLine Members
CvsCellEditLine Class Methods Properties See Also Send Feedback

The CvsCellEditLine type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | EndPoint | Gets the second point of the line. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | StartPoint | Gets the first point of the line. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditLine Class
Cognex.InSight.Cell Namespace


CvsCellEditLine Methods

[image] [image]

In-Sight SDK
CvsCellEditLine Methods
CvsCellEditLine Class See Also Send Feedback

The CvsCellEditLine type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEditLine Class
Cognex.InSight.Cell Namespace


CvsCellEditLine.ToString Method

[image]

In-Sight SDK
CvsCellEditLine..::..ToString Method
CvsCellEditLine Class See Also Send Feedback
Converts the properties of the cell to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEditLine Class
CvsCellEditLine..::..CvsCellEditLine Members
Cognex.InSight.Cell Namespace


CvsCellEditLine Properties

[image] [image]

In-Sight SDK
CvsCellEditLine Properties
CvsCellEditLine Class See Also Send Feedback

The CvsCellEditLine type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | EndPoint | Gets the second point of the line. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | StartPoint | Gets the first point of the line. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditLine Class
Cognex.InSight.Cell Namespace


CvsCellEditLine.EndPoint Property

[image]

In-Sight SDK
CvsCellEditLine..::..EndPoint Property
CvsCellEditLine Class See Also Send Feedback
Gets the second point of the line. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation EndPoint { get; }
Visual Basic
Public ReadOnly Property EndPoint As CvsImageLocation
    Get

Property Value

Type: CvsImageLocation

See Also

CvsCellEditLine Class
CvsCellEditLine..::..CvsCellEditLine Members
Cognex.InSight.Cell Namespace


CvsCellEditLine.StartPoint Property

[image]

In-Sight SDK
CvsCellEditLine..::..StartPoint Property
CvsCellEditLine Class See Also Send Feedback
Gets the first point of the line. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation StartPoint { get; }
Visual Basic
Public ReadOnly Property StartPoint As CvsImageLocation
    Get

Property Value

Type: CvsImageLocation

See Also

CvsCellEditLine Class
CvsCellEditLine..::..CvsCellEditLine Members
Cognex.InSight.Cell Namespace


CvsCellEditLine.Text Property

[image]

In-Sight SDK
CvsCellEditLine..::..Text Property
CvsCellEditLine Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellEditLine Class
CvsCellEditLine..::..CvsCellEditLine Members
Cognex.InSight.Cell Namespace


CvsCellEditMaskedRegion Class

[image]

In-Sight SDK
CvsCellEditMaskedRegion Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight EditCompositeRegion function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEditMaskedRegion : CvsCellEditGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEditMaskedRegion
    Inherits CvsCellEditGraphic

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditGraphic
Cognex.InSight.Cell..::..CvsCellEditMaskedRegion

See Also

CvsCellEditMaskedRegion..::..CvsCellEditMaskedRegion Members
Cognex.InSight.Cell Namespace


CvsCellEditMaskedRegion Members

[image] [image]

In-Sight SDK
CvsCellEditMaskedRegion Members
CvsCellEditMaskedRegion Class Methods Properties See Also Send Feedback

The CvsCellEditMaskedRegion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | Subregions | Provides read-only access to the subregions that define the composite region.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditMaskedRegion Class
Cognex.InSight.Cell Namespace


CvsCellEditMaskedRegion Methods

[image] [image]

In-Sight SDK
CvsCellEditMaskedRegion Methods
CvsCellEditMaskedRegion Class See Also Send Feedback

The CvsCellEditMaskedRegion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEditMaskedRegion Class
Cognex.InSight.Cell Namespace


CvsCellEditMaskedRegion.ToString Method

[image]

In-Sight SDK
CvsCellEditMaskedRegion..::..ToString Method
CvsCellEditMaskedRegion Class See Also Send Feedback
Converts the properties of the cell to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEditMaskedRegion Class
CvsCellEditMaskedRegion..::..CvsCellEditMaskedRegion Members
Cognex.InSight.Cell Namespace


CvsCellEditMaskedRegion Properties

[image] [image]

In-Sight SDK
CvsCellEditMaskedRegion Properties
CvsCellEditMaskedRegion Class See Also Send Feedback

The CvsCellEditMaskedRegion type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | Subregions | Provides read-only access to the subregions that define the composite region.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditMaskedRegion Class
Cognex.InSight.Cell Namespace


CvsCellEditMaskedRegion.Subregions Property

[image]

In-Sight SDK
CvsCellEditMaskedRegion..::..Subregions Property
CvsCellEditMaskedRegion Class See Also Send Feedback
Provides read-only access to the subregions that define the composite region.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeSubregion[] Subregions { get; }
Visual Basic
Public ReadOnly Property Subregions As CvsCompositeSubregion()
    Get

Property Value

Type: array< CvsCompositeSubregion >[]()[][]

See Also

CvsCellEditMaskedRegion Class
CvsCellEditMaskedRegion..::..CvsCellEditMaskedRegion Members
Cognex.InSight.Cell Namespace


CvsCellEditMaskedRegion.Text Property

[image]

In-Sight SDK
CvsCellEditMaskedRegion..::..Text Property
CvsCellEditMaskedRegion Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellEditMaskedRegion Class
CvsCellEditMaskedRegion..::..CvsCellEditMaskedRegion Members
Cognex.InSight.Cell Namespace


CvsCellEditMultiGraphics Class

[image]

In-Sight SDK
CvsCellEditMultiGraphics Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight EditRegion function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEditMultiGraphics : CvsCellEditGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEditMultiGraphics
    Inherits CvsCellEditGraphic

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditGraphic
Cognex.InSight.Cell..::..CvsCellEditMultiGraphics

See Also

CvsCellEditMultiGraphics..::..CvsCellEditMultiGraphics Members
Cognex.InSight.Cell Namespace


CvsCellEditMultiGraphics Members

[image] [image]

In-Sight SDK
CvsCellEditMultiGraphics Members
CvsCellEditMultiGraphics Class Methods Properties See Also Send Feedback

The CvsCellEditMultiGraphics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | Locations | Gets the cell locations of the edit graphics.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | ShowLabels | Get the show labels option.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the cell text. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditMultiGraphics Class
Cognex.InSight.Cell Namespace


CvsCellEditMultiGraphics Methods

[image] [image]

In-Sight SDK
CvsCellEditMultiGraphics Methods
CvsCellEditMultiGraphics Class See Also Send Feedback

The CvsCellEditMultiGraphics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEditMultiGraphics Class
Cognex.InSight.Cell Namespace


CvsCellEditMultiGraphics.ToString Method

[image]

In-Sight SDK
CvsCellEditMultiGraphics..::..ToString Method
CvsCellEditMultiGraphics Class See Also Send Feedback
Converts the properties of the cell to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEditMultiGraphics Class
CvsCellEditMultiGraphics..::..CvsCellEditMultiGraphics Members
Cognex.InSight.Cell Namespace


CvsCellEditMultiGraphics Properties

[image] [image]

In-Sight SDK
CvsCellEditMultiGraphics Properties
CvsCellEditMultiGraphics Class See Also Send Feedback

The CvsCellEditMultiGraphics type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | Locations | Gets the cell locations of the edit graphics.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | ShowLabels | Get the show labels option.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the cell text. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditMultiGraphics Class
Cognex.InSight.Cell Namespace


CvsCellEditMultiGraphics.Locations Property

[image]

In-Sight SDK
CvsCellEditMultiGraphics..::..Locations Property
CvsCellEditMultiGraphics Class See Also Send Feedback
Gets the cell locations of the edit graphics.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public List<CvsCellLocation> Locations { get; }
Visual Basic
Public ReadOnly Property Locations As List(Of CvsCellLocation)
    Get

Return Value

Type: List <(Of <(<' CvsCellLocation >)>)>

See Also

CvsCellEditMultiGraphics Class
CvsCellEditMultiGraphics..::..CvsCellEditMultiGraphics Members
Cognex.InSight.Cell Namespace


CvsCellEditMultiGraphics.ShowLabels Property

[image]

In-Sight SDK
CvsCellEditMultiGraphics..::..ShowLabels Property
CvsCellEditMultiGraphics Class See Also Send Feedback
Get the show labels option.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowLabels { get; }
Visual Basic
Public ReadOnly Property ShowLabels As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellEditMultiGraphics Class
CvsCellEditMultiGraphics..::..CvsCellEditMultiGraphics Members
Cognex.InSight.Cell Namespace


CvsCellEditMultiGraphics.Text Property

[image]

In-Sight SDK
CvsCellEditMultiGraphics..::..Text Property
CvsCellEditMultiGraphics Class See Also Send Feedback
Gets the cell text.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellEditMultiGraphics Class
CvsCellEditMultiGraphics..::..CvsCellEditMultiGraphics Members
Cognex.InSight.Cell Namespace


CvsCellEditPoint Class

[image]

In-Sight SDK
CvsCellEditPoint Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight EditPoint function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEditPoint : CvsCellEditGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEditPoint
    Inherits CvsCellEditGraphic

Remarks

CvsCellEditPoint objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditGraphic
Cognex.InSight.Cell..::..CvsCellEditPoint

See Also

CvsCellEditPoint..::..CvsCellEditPoint Members
Cognex.InSight.Cell Namespace


CvsCellEditPoint Members

[image] [image]

In-Sight SDK
CvsCellEditPoint Members
CvsCellEditPoint Class Methods Properties See Also Send Feedback

The CvsCellEditPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | GraphicLocation | Gets the location of the graphic. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditPoint Class
Cognex.InSight.Cell Namespace


CvsCellEditPoint Methods

[image] [image]

In-Sight SDK
CvsCellEditPoint Methods
CvsCellEditPoint Class See Also Send Feedback

The CvsCellEditPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEditPoint Class
Cognex.InSight.Cell Namespace


CvsCellEditPoint.ToString Method

[image]

In-Sight SDK
CvsCellEditPoint..::..ToString Method
CvsCellEditPoint Class See Also Send Feedback
Converts the properties of the cell to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEditPoint Class
CvsCellEditPoint..::..CvsCellEditPoint Members
Cognex.InSight.Cell Namespace


CvsCellEditPoint Properties

[image] [image]

In-Sight SDK
CvsCellEditPoint Properties
CvsCellEditPoint Class See Also Send Feedback

The CvsCellEditPoint type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | GraphicLocation | Gets the location of the graphic. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditPoint Class
Cognex.InSight.Cell Namespace


CvsCellEditPoint.GraphicLocation Property

[image]

In-Sight SDK
CvsCellEditPoint..::..GraphicLocation Property
CvsCellEditPoint Class See Also Send Feedback
Gets the location of the graphic. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation GraphicLocation { get; }
Visual Basic
Public ReadOnly Property GraphicLocation As CvsImageLocation
    Get

Property Value

Type: CvsImageLocation

See Also

CvsCellEditPoint Class
CvsCellEditPoint..::..CvsCellEditPoint Members
Cognex.InSight.Cell Namespace


CvsCellEditPoint.Text Property

[image]

In-Sight SDK
CvsCellEditPoint..::..Text Property
CvsCellEditPoint Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellEditPoint Class
CvsCellEditPoint..::..CvsCellEditPoint Members
Cognex.InSight.Cell Namespace


CvsCellEditPolygon Class

[image]

In-Sight SDK
CvsCellEditPolygon Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight EditPolygon function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEditPolygon : CvsCellEditGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEditPolygon
    Inherits CvsCellEditGraphic

Remarks

CvsCellEditPolygon objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditGraphic
Cognex.InSight.Cell..::..CvsCellEditPolygon

See Also

CvsCellEditPolygon..::..CvsCellEditPolygon Members
Cognex.InSight.Cell Namespace


CvsCellEditPolygon Members

[image] [image]

In-Sight SDK
CvsCellEditPolygon Members
CvsCellEditPolygon Class Methods Properties See Also Send Feedback

The CvsCellEditPolygon type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Points | Provides read-only access to the points that define the polygon.
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditPolygon Class
Cognex.InSight.Cell Namespace


CvsCellEditPolygon Methods

[image] [image]

In-Sight SDK
CvsCellEditPolygon Methods
CvsCellEditPolygon Class See Also Send Feedback

The CvsCellEditPolygon type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEditPolygon Class
Cognex.InSight.Cell Namespace


CvsCellEditPolygon.ToString Method

[image]

In-Sight SDK
CvsCellEditPolygon..::..ToString Method
CvsCellEditPolygon Class See Also Send Feedback
Converts the properties of the cell to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEditPolygon Class
CvsCellEditPolygon..::..CvsCellEditPolygon Members
Cognex.InSight.Cell Namespace


CvsCellEditPolygon Properties

[image] [image]

In-Sight SDK
CvsCellEditPolygon Properties
CvsCellEditPolygon Class See Also Send Feedback

The CvsCellEditPolygon type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Points | Provides read-only access to the points that define the polygon.
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditPolygon Class
Cognex.InSight.Cell Namespace


CvsCellEditPolygon.Points Property

[image]

In-Sight SDK
CvsCellEditPolygon..::..Points Property
CvsCellEditPolygon Class See Also Send Feedback
Provides read-only access to the points that define the polygon.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation[] Points { get; }
Visual Basic
Public ReadOnly Property Points As CvsImageLocation()
    Get

Property Value

Type: array< CvsImageLocation >[]()[][]

See Also

CvsCellEditPolygon Class
CvsCellEditPolygon..::..CvsCellEditPolygon Members
Cognex.InSight.Cell Namespace


CvsCellEditPolygon.Text Property

[image]

In-Sight SDK
CvsCellEditPolygon..::..Text Property
CvsCellEditPolygon Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellEditPolygon Class
CvsCellEditPolygon..::..CvsCellEditPolygon Members
Cognex.InSight.Cell Namespace


CvsCellEditPolylinePath Class

[image]

In-Sight SDK
CvsCellEditPolylinePath Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight EditCompositeRegion function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEditPolylinePath : CvsCellEditGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEditPolylinePath
    Inherits CvsCellEditGraphic

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditGraphic
Cognex.InSight.Cell..::..CvsCellEditPolylinePath

See Also

CvsCellEditPolylinePath..::..CvsCellEditPolylinePath Members
Cognex.InSight.Cell Namespace


CvsCellEditPolylinePath Members

[image] [image]

In-Sight SDK
CvsCellEditPolylinePath Members
CvsCellEditPolylinePath Class Methods Properties See Also Send Feedback

The CvsCellEditPolylinePath type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | Subregions | Provides read-only access to the subregions that define the composite region.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditPolylinePath Class
Cognex.InSight.Cell Namespace


CvsCellEditPolylinePath Methods

[image] [image]

In-Sight SDK
CvsCellEditPolylinePath Methods
CvsCellEditPolylinePath Class See Also Send Feedback

The CvsCellEditPolylinePath type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEditPolylinePath Class
Cognex.InSight.Cell Namespace


CvsCellEditPolylinePath.ToString Method

[image]

In-Sight SDK
CvsCellEditPolylinePath..::..ToString Method
CvsCellEditPolylinePath Class See Also Send Feedback
Converts the properties of the cell to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEditPolylinePath Class
CvsCellEditPolylinePath..::..CvsCellEditPolylinePath Members
Cognex.InSight.Cell Namespace


CvsCellEditPolylinePath Properties

[image] [image]

In-Sight SDK
CvsCellEditPolylinePath Properties
CvsCellEditPolylinePath Class See Also Send Feedback

The CvsCellEditPolylinePath type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | Subregions | Provides read-only access to the subregions that define the composite region.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditPolylinePath Class
Cognex.InSight.Cell Namespace


CvsCellEditPolylinePath.Subregions Property

[image]

In-Sight SDK
CvsCellEditPolylinePath..::..Subregions Property
CvsCellEditPolylinePath Class See Also Send Feedback
Provides read-only access to the subregions that define the composite region.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeSubregion[] Subregions { get; }
Visual Basic
Public ReadOnly Property Subregions As CvsCompositeSubregion()
    Get

Property Value

Type: array< CvsCompositeSubregion >[]()[][]

See Also

CvsCellEditPolylinePath Class
CvsCellEditPolylinePath..::..CvsCellEditPolylinePath Members
Cognex.InSight.Cell Namespace


CvsCellEditPolylinePath.Text Property

[image]

In-Sight SDK
CvsCellEditPolylinePath..::..Text Property
CvsCellEditPolylinePath Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellEditPolylinePath Class
CvsCellEditPolylinePath..::..CvsCellEditPolylinePath Members
Cognex.InSight.Cell Namespace


CvsCellEditRegion Class

[image]

In-Sight SDK
CvsCellEditRegion Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight EditRegion function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEditRegion : CvsCellEditGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEditRegion
    Inherits CvsCellEditGraphic

Remarks

CvsCellEditRegion objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditGraphic
Cognex.InSight.Cell..::..CvsCellEditRegion

See Also

CvsCellEditRegion..::..CvsCellEditRegion Members
Cognex.InSight.Cell Namespace


CvsCellEditRegion Members

[image] [image]

In-Sight SDK
CvsCellEditRegion Members
CvsCellEditRegion Class Methods Properties See Also Send Feedback

The CvsCellEditRegion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Angle | Gets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | Curve | Gets the curve of the graphic. The curve is the angular deviation between the region's vertical axis and the opposing boundary line.
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | GraphicLocation | Gets location of the graphic. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Height | Gets the height (in pixels) of the graphic.
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)
Public property | Width | Gets the width (in pixels) of the graphic.

See Also

CvsCellEditRegion Class
Cognex.InSight.Cell Namespace


CvsCellEditRegion Methods

[image] [image]

In-Sight SDK
CvsCellEditRegion Methods
CvsCellEditRegion Class See Also Send Feedback

The CvsCellEditRegion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the properties of the cell to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEditRegion Class
Cognex.InSight.Cell Namespace


CvsCellEditRegion.ToString Method

[image]

In-Sight SDK
CvsCellEditRegion..::..ToString Method
CvsCellEditRegion Class See Also Send Feedback
Converts the properties of the cell to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEditRegion Class
CvsCellEditRegion..::..CvsCellEditRegion Members
Cognex.InSight.Cell Namespace


CvsCellEditRegion Properties

[image] [image]

In-Sight SDK
CvsCellEditRegion Properties
CvsCellEditRegion Class See Also Send Feedback

The CvsCellEditRegion type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | Curve | Gets the curve of the graphic. The curve is the angular deviation between the region's vertical axis and the opposing boundary line.
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCellEditGraphic.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | EditFlags | Gets the value that describes the editing capabilities of the cell. (Inherited from CvsCellEditGraphic.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | GraphicLocation | Gets location of the graphic. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Height | Gets the height (in pixels) of the graphic.
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCellEditGraphic.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)
Public property | Width | Gets the width (in pixels) of the graphic.

See Also

CvsCellEditRegion Class
Cognex.InSight.Cell Namespace


CvsCellEditRegion.Angle Property

[image]

In-Sight SDK
CvsCellEditRegion..::..Angle Property
CvsCellEditRegion Class See Also Send Feedback
Gets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Angle { get; }
Visual Basic
Public ReadOnly Property Angle As Single
    Get

Property Value

Type: Single

See Also

CvsCellEditRegion Class
CvsCellEditRegion..::..CvsCellEditRegion Members
Cognex.InSight.Cell Namespace


CvsCellEditRegion.Curve Property

[image]

In-Sight SDK
CvsCellEditRegion..::..Curve Property
CvsCellEditRegion Class See Also Send Feedback
Gets the curve of the graphic. The curve is the angular deviation between the region's vertical axis and the opposing boundary line.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Curve { get; }
Visual Basic
Public ReadOnly Property Curve As Single
    Get

Property Value

Type: Single

See Also

CvsCellEditRegion Class
CvsCellEditRegion..::..CvsCellEditRegion Members
Cognex.InSight.Cell Namespace


CvsCellEditRegion.GraphicLocation Property

[image]

In-Sight SDK
CvsCellEditRegion..::..GraphicLocation Property
CvsCellEditRegion Class See Also Send Feedback
Gets location of the graphic. The Row designates the pixels from the top of the image. The Column designates the pixels from the left side of the image.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation GraphicLocation { get; }
Visual Basic
Public ReadOnly Property GraphicLocation As CvsImageLocation
    Get

Property Value

Type: CvsImageLocation

See Also

CvsCellEditRegion Class
CvsCellEditRegion..::..CvsCellEditRegion Members
Cognex.InSight.Cell Namespace


CvsCellEditRegion.Height Property

[image]

In-Sight SDK
CvsCellEditRegion..::..Height Property
CvsCellEditRegion Class See Also Send Feedback
Gets the height (in pixels) of the graphic.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Height { get; }
Visual Basic
Public ReadOnly Property Height As Single
    Get

Property Value

Type: Single

See Also

CvsCellEditRegion Class
CvsCellEditRegion..::..CvsCellEditRegion Members
Cognex.InSight.Cell Namespace


CvsCellEditRegion.Text Property

[image]

In-Sight SDK
CvsCellEditRegion..::..Text Property
CvsCellEditRegion Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellEditRegion Class
CvsCellEditRegion..::..CvsCellEditRegion Members
Cognex.InSight.Cell Namespace


CvsCellEditRegion.Width Property

[image]

In-Sight SDK
CvsCellEditRegion..::..Width Property
CvsCellEditRegion Class See Also Send Feedback
Gets the width (in pixels) of the graphic.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Width { get; }
Visual Basic
Public ReadOnly Property Width As Single
    Get

Property Value

Type: Single

See Also

CvsCellEditRegion Class
CvsCellEditRegion..::..CvsCellEditRegion Members
Cognex.InSight.Cell Namespace


CvsCellEditString Class

[image]

In-Sight SDK
CvsCellEditString Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight EditString function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEditString : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEditString
    Inherits CvsCell

Remarks

CvsCellEditString objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEditString

See Also

CvsCellEditString..::..CvsCellEditString Members
Cognex.InSight.Cell Namespace


CvsCellEditString Members

[image] [image]

In-Sight SDK
CvsCellEditString Members
CvsCellEditString Class Methods Properties See Also Send Feedback

The CvsCellEditString type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the Text for the cell. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | IsPassword | Returns true is the string should be treated like a password.
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | MaxChars | Gets the maximum number of characters allowed in the string.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Overrides CvsCell..::..SupportsAuthorization.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text string associated with the edit control cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditString Class
Cognex.InSight.Cell Namespace


CvsCellEditString Methods

[image] [image]

In-Sight SDK
CvsCellEditString Methods
CvsCellEditString Class See Also Send Feedback

The CvsCellEditString type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the Text for the cell. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEditString Class
Cognex.InSight.Cell Namespace


CvsCellEditString.ToString Method

[image]

In-Sight SDK
CvsCellEditString..::..ToString Method
CvsCellEditString Class See Also Send Feedback
Returns the Text for the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEditString Class
CvsCellEditString..::..CvsCellEditString Members
Cognex.InSight.Cell Namespace


CvsCellEditString Properties

[image] [image]

In-Sight SDK
CvsCellEditString Properties
CvsCellEditString Class See Also Send Feedback

The CvsCellEditString type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | IsPassword | Returns true is the string should be treated like a password.
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | MaxChars | Gets the maximum number of characters allowed in the string.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Overrides CvsCell..::..SupportsAuthorization.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text string associated with the edit control cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellEditString Class
Cognex.InSight.Cell Namespace


CvsCellEditString.DataType Property

[image]

In-Sight SDK
CvsCellEditString..::..DataType Property
CvsCellEditString Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellEditString Class
CvsCellEditString..::..CvsCellEditString Members
Cognex.InSight.Cell Namespace


CvsCellEditString.IsEditCell Property

[image]

In-Sight SDK
CvsCellEditString..::..IsEditCell Property
CvsCellEditString Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool IsEditCell { get; }
Visual Basic
Public Overrides ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellEditString Class
CvsCellEditString..::..CvsCellEditString Members
Cognex.InSight.Cell Namespace


CvsCellEditString.IsPassword Property

[image]

In-Sight SDK
CvsCellEditString..::..IsPassword Property
CvsCellEditString Class See Also Send Feedback
Returns true is the string should be treated like a password.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsPassword { get; }
Visual Basic
Public ReadOnly Property IsPassword As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellEditString Class
CvsCellEditString..::..CvsCellEditString Members
Cognex.InSight.Cell Namespace


CvsCellEditString.MaxChars Property

[image]

In-Sight SDK
CvsCellEditString..::..MaxChars Property
CvsCellEditString Class See Also Send Feedback
Gets the maximum number of characters allowed in the string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxChars { get; }
Visual Basic
Public ReadOnly Property MaxChars As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellEditString Class
CvsCellEditString..::..CvsCellEditString Members
Cognex.InSight.Cell Namespace


CvsCellEditString.SupportsAuthorization Property

[image]

In-Sight SDK
CvsCellEditString..::..SupportsAuthorization Property
CvsCellEditString Class See Also Send Feedback
Returns true if the cell supports authorization.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool SupportsAuthorization { get; }
Visual Basic
Public Overrides ReadOnly Property SupportsAuthorization As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellEditString Class
CvsCellEditString..::..CvsCellEditString Members
Cognex.InSight.Cell Namespace


CvsCellEditString.Text Property

[image]

In-Sight SDK
CvsCellEditString..::..Text Property
CvsCellEditString Class See Also Send Feedback
Gets the text string associated with the edit control cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellEditString Class
CvsCellEditString..::..CvsCellEditString Members
Cognex.InSight.Cell Namespace


CvsCellEmpty Class

[image]

In-Sight SDK
CvsCellEmpty Class
Members See Also Send Feedback
Holds an empty cell's state.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellEmpty : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellEmpty
    Inherits CvsCell

Remarks

Empty cells do not have an expression associated with them.

CvsCellEmpty objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellEmpty

See Also

CvsCellEmpty..::..CvsCellEmpty Members
Cognex.InSight.Cell Namespace


CvsCellEmpty Members

[image] [image]

In-Sight SDK
CvsCellEmpty Members
CvsCellEmpty Class Methods Properties See Also Send Feedback

The CvsCellEmpty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns an empty string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCell.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Inherited from CvsCell.)

See Also

CvsCellEmpty Class
Cognex.InSight.Cell Namespace


CvsCellEmpty Methods

[image] [image]

In-Sight SDK
CvsCellEmpty Methods
CvsCellEmpty Class See Also Send Feedback

The CvsCellEmpty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns an empty string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellEmpty Class
Cognex.InSight.Cell Namespace


CvsCellEmpty.ToString Method

[image]

In-Sight SDK
CvsCellEmpty..::..ToString Method
CvsCellEmpty Class See Also Send Feedback
Returns an empty string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellEmpty Class
CvsCellEmpty..::..CvsCellEmpty Members
Cognex.InSight.Cell Namespace


CvsCellEmpty Properties

[image] [image]

In-Sight SDK
CvsCellEmpty Properties
CvsCellEmpty Class See Also Send Feedback

The CvsCellEmpty type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Inherited from CvsCell.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Inherited from CvsCell.)

See Also

CvsCellEmpty Class
Cognex.InSight.Cell Namespace


CvsCellFloat Class

[image]

In-Sight SDK
CvsCellFloat Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight cell that has a floating point number.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellFloat : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellFloat
    Inherits CvsCell

Remarks

CvsCellFloat objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellFloat

See Also

CvsCellFloat..::..CvsCellFloat Members
Cognex.InSight.Cell Namespace


CvsCellFloat Members

[image] [image]

In-Sight SDK
CvsCellFloat Members
CvsCellFloat Class Methods Properties See Also Send Feedback

The CvsCellFloat type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the Value to its equivalent string representation. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the numeric value of the cell.

See Also

CvsCellFloat Class
Cognex.InSight.Cell Namespace


CvsCellFloat Methods

[image] [image]

In-Sight SDK
CvsCellFloat Methods
CvsCellFloat Class See Also Send Feedback

The CvsCellFloat type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the Value to its equivalent string representation. (Overrides Object..::..ToString()()()().)

See Also

CvsCellFloat Class
Cognex.InSight.Cell Namespace


CvsCellFloat.ToString Method

[image]

In-Sight SDK
CvsCellFloat..::..ToString Method
CvsCellFloat Class See Also Send Feedback
Converts the Value to its equivalent string representation.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellFloat Class
CvsCellFloat..::..CvsCellFloat Members
Cognex.InSight.Cell Namespace


CvsCellFloat Properties

[image] [image]

In-Sight SDK
CvsCellFloat Properties
CvsCellFloat Class See Also Send Feedback

The CvsCellFloat type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the numeric value of the cell.

See Also

CvsCellFloat Class
Cognex.InSight.Cell Namespace


CvsCellFloat.DataType Property

[image]

In-Sight SDK
CvsCellFloat..::..DataType Property
CvsCellFloat Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellFloat Class
CvsCellFloat..::..CvsCellFloat Members
Cognex.InSight.Cell Namespace


CvsCellFloat.Text Property

[image]

In-Sight SDK
CvsCellFloat..::..Text Property
CvsCellFloat Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellFloat Class
CvsCellFloat..::..CvsCellFloat Members
Cognex.InSight.Cell Namespace


CvsCellFloat.Value Property

[image]

In-Sight SDK
CvsCellFloat..::..Value Property
CvsCellFloat Class See Also Send Feedback
Gets the numeric value of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Value { get; }
Visual Basic
Public ReadOnly Property Value As Single
    Get

Property Value

Type: Single

See Also

CvsCellFloat Class
CvsCellFloat..::..CvsCellFloat Members
Cognex.InSight.Cell Namespace


CvsCellInt Class

[image]

In-Sight SDK
CvsCellInt Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight cell that has an integer number.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellInt : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellInt
    Inherits CvsCell

Remarks

CvsCellInt objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellInt

See Also

CvsCellInt..::..CvsCellInt Members
Cognex.InSight.Cell Namespace


CvsCellInt Members

[image] [image]

In-Sight SDK
CvsCellInt Members
CvsCellInt Class Methods Properties See Also Send Feedback

The CvsCellInt type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the Value to its equivalent string representation. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the numeric value of the cell.

See Also

CvsCellInt Class
Cognex.InSight.Cell Namespace


CvsCellInt Methods

[image] [image]

In-Sight SDK
CvsCellInt Methods
CvsCellInt Class See Also Send Feedback

The CvsCellInt type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the Value to its equivalent string representation. (Overrides Object..::..ToString()()()().)

See Also

CvsCellInt Class
Cognex.InSight.Cell Namespace


CvsCellInt.ToString Method

[image]

In-Sight SDK
CvsCellInt..::..ToString Method
CvsCellInt Class See Also Send Feedback
Converts the Value to its equivalent string representation.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellInt Class
CvsCellInt..::..CvsCellInt Members
Cognex.InSight.Cell Namespace


CvsCellInt Properties

[image] [image]

In-Sight SDK
CvsCellInt Properties
CvsCellInt Class See Also Send Feedback

The CvsCellInt type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the numeric value of the cell.

See Also

CvsCellInt Class
Cognex.InSight.Cell Namespace


CvsCellInt.DataType Property

[image]

In-Sight SDK
CvsCellInt..::..DataType Property
CvsCellInt Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellInt Class
CvsCellInt..::..CvsCellInt Members
Cognex.InSight.Cell Namespace


CvsCellInt.Text Property

[image]

In-Sight SDK
CvsCellInt..::..Text Property
CvsCellInt Class See Also Send Feedback
Gets the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellInt Class
CvsCellInt..::..CvsCellInt Members
Cognex.InSight.Cell Namespace


CvsCellInt.Value Property

[image]

In-Sight SDK
CvsCellInt..::..Value Property
CvsCellInt Class See Also Send Feedback
Gets the numeric value of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Value { get; }
Visual Basic
Public ReadOnly Property Value As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellInt Class
CvsCellInt..::..CvsCellInt Members
Cognex.InSight.Cell Namespace


CvsCellIPProtection Enumeration

[image]

In-Sight SDK
CvsCellIPProtection Enumeration
See Also Send Feedback
Defines the cell states for intellectual property protection.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public enum CvsCellIPProtection
Visual Basic
<SerializableAttribute>
Public Enumeration CvsCellIPProtection

Members

Member name | Value | Description
None | 0 | The cell has no password protection.
Licensed | 1 | The cell is password protected with a corresponding license.
TemporaryEdit | 2 | The cell is password protected and has been enabled for temporary editing.
Unlicensed | 3 | The cell is password protected, but without a corresponding license.

See Also

Cognex.InSight.Cell Namespace


CvsCellLink Class

[image]

In-Sight SDK
CvsCellLink Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight Link function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellLink : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellLink
    Inherits CvsCell

Remarks

CvsCellLink objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellLink

See Also

CvsCellLink..::..CvsCellLink Members
Cognex.InSight.Cell Namespace


CvsCellLink Members

[image] [image]

In-Sight SDK
CvsCellLink Members
CvsCellLink Class Methods Properties See Also Send Feedback

The CvsCellLink type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the text for the Link cell. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | CursorPosition | Gets the cursor position for the Link cell.
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | DialogLabel | Gets the dialog label for the Link cell.
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | HostName | Gets the host name for the Link cell.
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the Link cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellLink Class
Cognex.InSight.Cell Namespace


CvsCellLink Methods

[image] [image]

In-Sight SDK
CvsCellLink Methods
CvsCellLink Class See Also Send Feedback

The CvsCellLink type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the text for the Link cell. (Overrides Object..::..ToString()()()().)

See Also

CvsCellLink Class
Cognex.InSight.Cell Namespace


CvsCellLink.ToString Method

[image]

In-Sight SDK
CvsCellLink..::..ToString Method
CvsCellLink Class See Also Send Feedback
Returns the text for the Link cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellLink Class
CvsCellLink..::..CvsCellLink Members
Cognex.InSight.Cell Namespace


CvsCellLink Properties

[image] [image]

In-Sight SDK
CvsCellLink Properties
CvsCellLink Class See Also Send Feedback

The CvsCellLink type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | CursorPosition | Gets the cursor position for the Link cell.
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | DialogLabel | Gets the dialog label for the Link cell.
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | HostName | Gets the host name for the Link cell.
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the Link cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellLink Class
Cognex.InSight.Cell Namespace


CvsCellLink.CursorPosition Property

[image]

In-Sight SDK
CvsCellLink..::..CursorPosition Property
CvsCellLink Class See Also Send Feedback
Gets the cursor position for the Link cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string CursorPosition { get; }
Visual Basic
Public ReadOnly Property CursorPosition As String
    Get

Property Value

Type: String

See Also

CvsCellLink Class
CvsCellLink..::..CvsCellLink Members
Cognex.InSight.Cell Namespace


CvsCellLink.DataType Property

[image]

In-Sight SDK
CvsCellLink..::..DataType Property
CvsCellLink Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellLink Class
CvsCellLink..::..CvsCellLink Members
Cognex.InSight.Cell Namespace


CvsCellLink.DialogLabel Property

[image]

In-Sight SDK
CvsCellLink..::..DialogLabel Property
CvsCellLink Class See Also Send Feedback
Gets the dialog label for the Link cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string DialogLabel { get; }
Visual Basic
Public ReadOnly Property DialogLabel As String
    Get

Property Value

Type: String

See Also

CvsCellLink Class
CvsCellLink..::..CvsCellLink Members
Cognex.InSight.Cell Namespace


CvsCellLink.HostName Property

[image]

In-Sight SDK
CvsCellLink..::..HostName Property
CvsCellLink Class See Also Send Feedback
Gets the host name for the Link cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string HostName { get; }
Visual Basic
Public ReadOnly Property HostName As String
    Get

Property Value

Type: String

See Also

CvsCellLink Class
CvsCellLink..::..CvsCellLink Members
Cognex.InSight.Cell Namespace


CvsCellLink.IsEditCell Property

[image]

In-Sight SDK
CvsCellLink..::..IsEditCell Property
CvsCellLink Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool IsEditCell { get; }
Visual Basic
Public Overrides ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellLink Class
CvsCellLink..::..CvsCellLink Members
Cognex.InSight.Cell Namespace


CvsCellLink.Text Property

[image]

In-Sight SDK
CvsCellLink..::..Text Property
CvsCellLink Class See Also Send Feedback
Gets the text for the Link cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellLink Class
CvsCellLink..::..CvsCellLink Members
Cognex.InSight.Cell Namespace


CvsCellListBox Class

[image]

In-Sight SDK
CvsCellListBox Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight ListBox function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellListBox : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellListBox
    Inherits CvsCell

Remarks

CvsCellListBox objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellListBox

See Also

CvsCellListBox..::..CvsCellListBox Members
Cognex.InSight.Cell Namespace


CvsCellListBox Members

[image] [image]

In-Sight SDK
CvsCellListBox Members
CvsCellListBox Class Methods Properties See Also Send Feedback

The CvsCellListBox type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetSelection | Returns the ListBox selection text. The Value property indexes into this array.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the selected value of the cell as a string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Items | Gets the list items.
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | NumSelections | Gets the number of selections in the ListBox.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the selected value of the cell as a string. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the numeric value of the selection of the edit control cell. The first selection's index is zero.

See Also

CvsCellListBox Class
Cognex.InSight.Cell Namespace


CvsCellListBox Methods

[image] [image]

In-Sight SDK
CvsCellListBox Methods
CvsCellListBox Class See Also Send Feedback

The CvsCellListBox type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetSelection | Returns the ListBox selection text. The Value property indexes into this array.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the selected value of the cell as a string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellListBox Class
Cognex.InSight.Cell Namespace


CvsCellListBox.GetSelection Method

[image]

In-Sight SDK
CvsCellListBox..::..GetSelection Method
CvsCellListBox Class See Also Send Feedback
Returns the ListBox selection text. The Value property indexes into this array.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string GetSelection(
    int index
)
Visual Basic
Public Function GetSelection (
    index As Integer
) As String

Parameters

index
Type: System..::..Int32
The index of the selection which is in the range 0 to NumSelections-1.

Return Value

Type: String
A string that represents the selection.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or greater than or equal to NumSelections.

See Also

CvsCellListBox Class
CvsCellListBox..::..CvsCellListBox Members
Cognex.InSight.Cell Namespace


CvsCellListBox.ToString Method

[image]

In-Sight SDK
CvsCellListBox..::..ToString Method
CvsCellListBox Class See Also Send Feedback
Returns the selected value of the cell as a string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellListBox Class
CvsCellListBox..::..CvsCellListBox Members
Cognex.InSight.Cell Namespace


CvsCellListBox Properties

[image] [image]

In-Sight SDK
CvsCellListBox Properties
CvsCellListBox Class See Also Send Feedback

The CvsCellListBox type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Items | Gets the list items.
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | NumSelections | Gets the number of selections in the ListBox.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the selected value of the cell as a string. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the numeric value of the selection of the edit control cell. The first selection's index is zero.

See Also

CvsCellListBox Class
Cognex.InSight.Cell Namespace


CvsCellListBox.DataType Property

[image]

In-Sight SDK
CvsCellListBox..::..DataType Property
CvsCellListBox Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellListBox Class
CvsCellListBox..::..CvsCellListBox Members
Cognex.InSight.Cell Namespace


CvsCellListBox.IsEditCell Property

[image]

In-Sight SDK
CvsCellListBox..::..IsEditCell Property
CvsCellListBox Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool IsEditCell { get; }
Visual Basic
Public Overrides ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellListBox Class
CvsCellListBox..::..CvsCellListBox Members
Cognex.InSight.Cell Namespace


CvsCellListBox.Items Property

[image]

In-Sight SDK
CvsCellListBox..::..Items Property
CvsCellListBox Class See Also Send Feedback
Gets the list items.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string[] Items { get; }
Visual Basic
Public ReadOnly Property Items As String()
    Get

Property Value

Type: array< String >[]()[][]

See Also

CvsCellListBox Class
CvsCellListBox..::..CvsCellListBox Members
Cognex.InSight.Cell Namespace


CvsCellListBox.NumSelections Property

[image]

In-Sight SDK
CvsCellListBox..::..NumSelections Property
CvsCellListBox Class See Also Send Feedback
Gets the number of selections in the ListBox.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NumSelections { get; }
Visual Basic
Public ReadOnly Property NumSelections As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellListBox Class
CvsCellListBox..::..CvsCellListBox Members
Cognex.InSight.Cell Namespace


CvsCellListBox.Text Property

[image]

In-Sight SDK
CvsCellListBox..::..Text Property
CvsCellListBox Class See Also Send Feedback
Gets the selected value of the cell as a string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellListBox Class
CvsCellListBox..::..CvsCellListBox Members
Cognex.InSight.Cell Namespace


CvsCellListBox.Value Property

[image]

In-Sight SDK
CvsCellListBox..::..Value Property
CvsCellListBox Class See Also Send Feedback
Gets the numeric value of the selection of the edit control cell. The first selection's index is zero.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Value { get; }
Visual Basic
Public ReadOnly Property Value As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellListBox Class
CvsCellListBox..::..CvsCellListBox Members
Cognex.InSight.Cell Namespace


CvsCellMultiStatus Class

[image]

In-Sight SDK
CvsCellMultiStatus Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight MultiStatus function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellMultiStatus : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellMultiStatus
    Inherits CvsCell

Remarks

CvsCellMultiStatus objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellMultiStatus

See Also

CvsCellMultiStatus..::..CvsCellMultiStatus Members
Cognex.InSight.Cell Namespace


CvsCellMultiStatus Members

[image] [image]

In-Sight SDK
CvsCellMultiStatus Members
CvsCellMultiStatus Class Methods Properties See Also Send Feedback

The CvsCellMultiStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the status bits to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Color0 | Gets the color of the "zero" value for the MultiStatus cell. Each bit with the value of 0 should be indicated with this color.
Public property | Color0AsRgb | Gets the Color0 as an RGB value.
Public property | Color1 | Gets the color of the "one" value for the MultiStatus cell. Each bit with the value of 1 should be indicated with this color.
Public property | Color1AsRgb | Gets the Color1 as an RGB value.
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | NumBits | Gets the number of bits displayed in the MultiStatus cell.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | ReverseOrder | Gets a value that determines if the order of the bits in the MultiStatus cell is reversed. A value of False designates the high-order bits are displayed to the left and the low order bits are displayed to the right.
Public property | StartBit | Gets the start bit of the MultiStatus cell.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Inherited from CvsCell.)
Public property | Value | Gets the value of the MultiStatus cell. The Value is a bitfield with NumBits bits from the StartBit displayed as a set of on/off indicators.

See Also

CvsCellMultiStatus Class
Cognex.InSight.Cell Namespace


CvsCellMultiStatus Methods

[image] [image]

In-Sight SDK
CvsCellMultiStatus Methods
CvsCellMultiStatus Class See Also Send Feedback

The CvsCellMultiStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the status bits to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellMultiStatus Class
Cognex.InSight.Cell Namespace


CvsCellMultiStatus.ToString Method

[image]

In-Sight SDK
CvsCellMultiStatus..::..ToString Method
CvsCellMultiStatus Class See Also Send Feedback
Converts the status bits to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellMultiStatus Class
CvsCellMultiStatus..::..CvsCellMultiStatus Members
Cognex.InSight.Cell Namespace


CvsCellMultiStatus Properties

[image] [image]

In-Sight SDK
CvsCellMultiStatus Properties
CvsCellMultiStatus Class See Also Send Feedback

The CvsCellMultiStatus type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Color0 | Gets the color of the "zero" value for the MultiStatus cell. Each bit with the value of 0 should be indicated with this color.
Public property | Color0AsRgb | Gets the Color0 as an RGB value.
Public property | Color1 | Gets the color of the "one" value for the MultiStatus cell. Each bit with the value of 1 should be indicated with this color.
Public property | Color1AsRgb | Gets the Color1 as an RGB value.
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | NumBits | Gets the number of bits displayed in the MultiStatus cell.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | ReverseOrder | Gets a value that determines if the order of the bits in the MultiStatus cell is reversed. A value of False designates the high-order bits are displayed to the left and the low order bits are displayed to the right.
Public property | StartBit | Gets the start bit of the MultiStatus cell.
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text associated with the cell. (Inherited from CvsCell.)
Public property | Value | Gets the value of the MultiStatus cell. The Value is a bitfield with NumBits bits from the StartBit displayed as a set of on/off indicators.

See Also

CvsCellMultiStatus Class
Cognex.InSight.Cell Namespace


CvsCellMultiStatus.Color0 Property

[image]

In-Sight SDK
CvsCellMultiStatus..::..Color0 Property
CvsCellMultiStatus Class See Also Send Feedback
Gets the color of the "zero" value for the MultiStatus cell. Each bit with the value of 0 should be indicated with this color.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color Color0 { get; }
Visual Basic
Public ReadOnly Property Color0 As Color
    Get

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

See Also

CvsCellMultiStatus Class
CvsCellMultiStatus..::..CvsCellMultiStatus Members
Cognex.InSight.Cell Namespace


CvsCellMultiStatus.Color0AsRgb Property

[image]

In-Sight SDK
CvsCellMultiStatus..::..Color0AsRgb Property
CvsCellMultiStatus Class See Also Send Feedback
Gets the Color0 as an RGB value.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Color0AsRgb { get; }
Visual Basic
Public ReadOnly Property Color0AsRgb As Integer
    Get

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

See Also

CvsCellMultiStatus Class
CvsCellMultiStatus..::..CvsCellMultiStatus Members
Cognex.InSight.Cell Namespace


CvsCellMultiStatus.Color1 Property

[image]

In-Sight SDK
CvsCellMultiStatus..::..Color1 Property
CvsCellMultiStatus Class See Also Send Feedback
Gets the color of the "one" value for the MultiStatus cell. Each bit with the value of 1 should be indicated with this color.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color Color1 { get; }
Visual Basic
Public ReadOnly Property Color1 As Color
    Get

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

See Also

CvsCellMultiStatus Class
CvsCellMultiStatus..::..CvsCellMultiStatus Members
Cognex.InSight.Cell Namespace


CvsCellMultiStatus.Color1AsRgb Property

[image]

In-Sight SDK
CvsCellMultiStatus..::..Color1AsRgb Property
CvsCellMultiStatus Class See Also Send Feedback
Gets the Color1 as an RGB value.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Color1AsRgb { get; }
Visual Basic
Public ReadOnly Property Color1AsRgb As Integer
    Get

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

See Also

CvsCellMultiStatus Class
CvsCellMultiStatus..::..CvsCellMultiStatus Members
Cognex.InSight.Cell Namespace


CvsCellMultiStatus.DataType Property

[image]

In-Sight SDK
CvsCellMultiStatus..::..DataType Property
CvsCellMultiStatus Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellMultiStatus Class
CvsCellMultiStatus..::..CvsCellMultiStatus Members
Cognex.InSight.Cell Namespace


CvsCellMultiStatus.NumBits Property

[image]

In-Sight SDK
CvsCellMultiStatus..::..NumBits Property
CvsCellMultiStatus Class See Also Send Feedback
Gets the number of bits displayed in the MultiStatus cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NumBits { get; }
Visual Basic
Public ReadOnly Property NumBits As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellMultiStatus Class
CvsCellMultiStatus..::..CvsCellMultiStatus Members
Cognex.InSight.Cell Namespace


CvsCellMultiStatus.ReverseOrder Property

[image]

In-Sight SDK
CvsCellMultiStatus..::..ReverseOrder Property
CvsCellMultiStatus Class See Also Send Feedback
Gets a value that determines if the order of the bits in the MultiStatus cell is reversed. A value of False designates the high-order bits are displayed to the left and the low order bits are displayed to the right.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ReverseOrder { get; }
Visual Basic
Public ReadOnly Property ReverseOrder As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellMultiStatus Class
CvsCellMultiStatus..::..CvsCellMultiStatus Members
Cognex.InSight.Cell Namespace


CvsCellMultiStatus.StartBit Property

[image]

In-Sight SDK
CvsCellMultiStatus..::..StartBit Property
CvsCellMultiStatus Class See Also Send Feedback
Gets the start bit of the MultiStatus cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int StartBit { get; }
Visual Basic
Public ReadOnly Property StartBit As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellMultiStatus Class
CvsCellMultiStatus..::..CvsCellMultiStatus Members
Cognex.InSight.Cell Namespace


CvsCellMultiStatus.Value Property

[image]

In-Sight SDK
CvsCellMultiStatus..::..Value Property
CvsCellMultiStatus Class See Also Send Feedback
Gets the value of the MultiStatus cell. The Value is a bitfield with NumBits bits from the StartBit displayed as a set of on/off indicators.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Value { get; }
Visual Basic
Public ReadOnly Property Value As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellMultiStatus Class
CvsCellMultiStatus..::..CvsCellMultiStatus Members
Cognex.InSight.Cell Namespace


CvsCellOcrMaxAutoTune Class

[image]

In-Sight SDK
CvsCellOcrMaxAutoTune Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight OcrMaxAutoTune function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellOcrMaxAutoTune : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellOcrMaxAutoTune
    Inherits CvsCell

Remarks

CvsCellOcrMaxAutoTune objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellOcrMaxAutoTune

See Also

CvsCellOcrMaxAutoTune..::..CvsCellOcrMaxAutoTune Members
Cognex.InSight.Cell Namespace


CvsCellOcrMaxAutoTune Members

[image] [image]

In-Sight SDK
CvsCellOcrMaxAutoTune Members
CvsCellOcrMaxAutoTune Class Methods Properties See Also Send Feedback

The CvsCellOcrMaxAutoTune type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the Text for the cell. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the Select cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellOcrMaxAutoTune Class
Cognex.InSight.Cell Namespace


CvsCellOcrMaxAutoTune Methods

[image] [image]

In-Sight SDK
CvsCellOcrMaxAutoTune Methods
CvsCellOcrMaxAutoTune Class See Also Send Feedback

The CvsCellOcrMaxAutoTune type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the Text for the cell. (Overrides Object..::..ToString()()()().)

See Also

CvsCellOcrMaxAutoTune Class
Cognex.InSight.Cell Namespace


CvsCellOcrMaxAutoTune.ToString Method

[image]

In-Sight SDK
CvsCellOcrMaxAutoTune..::..ToString Method
CvsCellOcrMaxAutoTune Class See Also Send Feedback
Returns the Text for the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellOcrMaxAutoTune Class
CvsCellOcrMaxAutoTune..::..CvsCellOcrMaxAutoTune Members
Cognex.InSight.Cell Namespace


CvsCellOcrMaxAutoTune Properties

[image] [image]

In-Sight SDK
CvsCellOcrMaxAutoTune Properties
CvsCellOcrMaxAutoTune Class See Also Send Feedback

The CvsCellOcrMaxAutoTune type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the Select cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellOcrMaxAutoTune Class
Cognex.InSight.Cell Namespace


CvsCellOcrMaxAutoTune.DataType Property

[image]

In-Sight SDK
CvsCellOcrMaxAutoTune..::..DataType Property
CvsCellOcrMaxAutoTune Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellOcrMaxAutoTune Class
CvsCellOcrMaxAutoTune..::..CvsCellOcrMaxAutoTune Members
Cognex.InSight.Cell Namespace


CvsCellOcrMaxAutoTune.IsEditCell Property

[image]

In-Sight SDK
CvsCellOcrMaxAutoTune..::..IsEditCell Property
CvsCellOcrMaxAutoTune Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool IsEditCell { get; }
Visual Basic
Public Overrides ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellOcrMaxAutoTune Class
CvsCellOcrMaxAutoTune..::..CvsCellOcrMaxAutoTune Members
Cognex.InSight.Cell Namespace


CvsCellOcrMaxAutoTune.Text Property

[image]

In-Sight SDK
CvsCellOcrMaxAutoTune..::..Text Property
CvsCellOcrMaxAutoTune Class See Also Send Feedback
Gets the text for the Select cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellOcrMaxAutoTune Class
CvsCellOcrMaxAutoTune..::..CvsCellOcrMaxAutoTune Members
Cognex.InSight.Cell Namespace


CvsCellProperty Enumeration

[image]

In-Sight SDK
CvsCellProperty Enumeration
See Also Send Feedback
An enumeration of cell properties.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
[FlagsAttribute]
public enum CvsCellProperty
Visual Basic
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration CvsCellProperty

Members

Member name | Value | Description
None | 0 | No properties are defined.
EditPassword | 1 | This cell is an Edit Password cell
AllPropertiesMask | 1 | All defined properties.

See Also

Cognex.InSight.Cell Namespace


CvsCellSelect Class

[image]

In-Sight SDK
CvsCellSelect Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight Select function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellSelect : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellSelect
    Inherits CvsCell

Remarks

CvsCellSelect objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellSelect

See Also

CvsCellSelect..::..CvsCellSelect Members
Cognex.InSight.Cell Namespace


CvsCellSelect Members

[image] [image]

In-Sight SDK
CvsCellSelect Members
CvsCellSelect Class Methods Properties See Also Send Feedback

The CvsCellSelect type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the Text for the cell. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | Index | Gets the index selected for the cell.
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the Select cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellSelect Class
Cognex.InSight.Cell Namespace


CvsCellSelect Methods

[image] [image]

In-Sight SDK
CvsCellSelect Methods
CvsCellSelect Class See Also Send Feedback

The CvsCellSelect type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the Text for the cell. (Overrides Object..::..ToString()()()().)

See Also

CvsCellSelect Class
Cognex.InSight.Cell Namespace


CvsCellSelect.ToString Method

[image]

In-Sight SDK
CvsCellSelect..::..ToString Method
CvsCellSelect Class See Also Send Feedback
Returns the Text for the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellSelect Class
CvsCellSelect..::..CvsCellSelect Members
Cognex.InSight.Cell Namespace


CvsCellSelect Properties

[image] [image]

In-Sight SDK
CvsCellSelect Properties
CvsCellSelect Class See Also Send Feedback

The CvsCellSelect type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | Index | Gets the index selected for the cell.
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the Select cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellSelect Class
Cognex.InSight.Cell Namespace


CvsCellSelect.DataType Property

[image]

In-Sight SDK
CvsCellSelect..::..DataType Property
CvsCellSelect Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellSelect Class
CvsCellSelect..::..CvsCellSelect Members
Cognex.InSight.Cell Namespace


CvsCellSelect.Index Property

[image]

In-Sight SDK
CvsCellSelect..::..Index Property
CvsCellSelect Class See Also Send Feedback
Gets the index selected for the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellSelect Class
CvsCellSelect..::..CvsCellSelect Members
Cognex.InSight.Cell Namespace


CvsCellSelect.IsEditCell Property

[image]

In-Sight SDK
CvsCellSelect..::..IsEditCell Property
CvsCellSelect Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool IsEditCell { get; }
Visual Basic
Public Overrides ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellSelect Class
CvsCellSelect..::..CvsCellSelect Members
Cognex.InSight.Cell Namespace


CvsCellSelect.Text Property

[image]

In-Sight SDK
CvsCellSelect..::..Text Property
CvsCellSelect Class See Also Send Feedback
Gets the text for the Select cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellSelect Class
CvsCellSelect..::..CvsCellSelect Members
Cognex.InSight.Cell Namespace


CvsCellStatus Class

[image]

In-Sight SDK
CvsCellStatus Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight Status function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellStatus : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellStatus
    Inherits CvsCell

Remarks

CvsCellStatus objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellStatus

See Also

CvsCellStatus..::..CvsCellStatus Members
Cognex.InSight.Cell Namespace


CvsCellStatus Members

[image] [image]

In-Sight SDK
CvsCellStatus Members
CvsCellStatus Class Methods Properties See Also Send Feedback

The CvsCellStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the Value to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the Status cell. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the value of the Status cell. Less than zero implies red. Zero implies yellow. Greater than zero implies green.

See Also

CvsCellStatus Class
Cognex.InSight.Cell Namespace


CvsCellStatus Methods

[image] [image]

In-Sight SDK
CvsCellStatus Methods
CvsCellStatus Class See Also Send Feedback

The CvsCellStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the Value to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellStatus Class
Cognex.InSight.Cell Namespace


CvsCellStatus.ToString Method

[image]

In-Sight SDK
CvsCellStatus..::..ToString Method
CvsCellStatus Class See Also Send Feedback
Converts the Value to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellStatus Class
CvsCellStatus..::..CvsCellStatus Members
Cognex.InSight.Cell Namespace


CvsCellStatus Properties

[image] [image]

In-Sight SDK
CvsCellStatus Properties
CvsCellStatus Class See Also Send Feedback

The CvsCellStatus type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the Status cell. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the value of the Status cell. Less than zero implies red. Zero implies yellow. Greater than zero implies green.

See Also

CvsCellStatus Class
Cognex.InSight.Cell Namespace


CvsCellStatus.DataType Property

[image]

In-Sight SDK
CvsCellStatus..::..DataType Property
CvsCellStatus Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellStatus Class
CvsCellStatus..::..CvsCellStatus Members
Cognex.InSight.Cell Namespace


CvsCellStatus.Text Property

[image]

In-Sight SDK
CvsCellStatus..::..Text Property
CvsCellStatus Class See Also Send Feedback
Gets the text for the Status cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellStatus Class
CvsCellStatus..::..CvsCellStatus Members
Cognex.InSight.Cell Namespace


CvsCellStatus.Value Property

[image]

In-Sight SDK
CvsCellStatus..::..Value Property
CvsCellStatus Class See Also Send Feedback
Gets the value of the Status cell. Less than zero implies red. Zero implies yellow. Greater than zero implies green.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Value { get; }
Visual Basic
Public ReadOnly Property Value As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellStatus Class
CvsCellStatus..::..CvsCellStatus Members
Cognex.InSight.Cell Namespace


CvsCellStatusLight Class

[image]

In-Sight SDK
CvsCellStatusLight Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight StatusLight function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellStatusLight : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellStatusLight
    Inherits CvsCell

Remarks

CvsCellStatusLight objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellStatusLight

See Also

CvsCellStatusLight..::..CvsCellStatusLight Members
Cognex.InSight.Cell Namespace


CvsCellStatusLight Members

[image] [image]

In-Sight SDK
CvsCellStatusLight Members
CvsCellStatusLight Class Methods Properties See Also Send Feedback

The CvsCellStatusLight type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the Value to a readable string. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Color | Gets the color to render the indicator.
Public property | ColorAsRgb | Gets the Color as an RGB value.
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the StatusLight cell. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the value of the StatusLight cell.

See Also

CvsCellStatusLight Class
Cognex.InSight.Cell Namespace


CvsCellStatusLight Methods

[image] [image]

In-Sight SDK
CvsCellStatusLight Methods
CvsCellStatusLight Class See Also Send Feedback

The CvsCellStatusLight type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts the Value to a readable string. (Overrides Object..::..ToString()()()().)

See Also

CvsCellStatusLight Class
Cognex.InSight.Cell Namespace


CvsCellStatusLight.ToString Method

[image]

In-Sight SDK
CvsCellStatusLight..::..ToString Method
CvsCellStatusLight Class See Also Send Feedback
Converts the Value to a readable string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellStatusLight Class
CvsCellStatusLight..::..CvsCellStatusLight Members
Cognex.InSight.Cell Namespace


CvsCellStatusLight Properties

[image] [image]

In-Sight SDK
CvsCellStatusLight Properties
CvsCellStatusLight Class See Also Send Feedback

The CvsCellStatusLight type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Color | Gets the color to render the indicator.
Public property | ColorAsRgb | Gets the Color as an RGB value.
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the StatusLight cell. (Overrides CvsCell..::..Text.)
Public property | Value | Gets the value of the StatusLight cell.

See Also

CvsCellStatusLight Class
Cognex.InSight.Cell Namespace


CvsCellStatusLight.Color Property

[image]

In-Sight SDK
CvsCellStatusLight..::..Color Property
CvsCellStatusLight Class See Also Send Feedback
Gets the color to render the indicator.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color Color { get; }
Visual Basic
Public ReadOnly Property Color As Color
    Get

Property Value

Type: Color

Remarks

The value of the cell determines the rendering color.

This property is only available in .NET applications.

See Also

CvsCellStatusLight Class
CvsCellStatusLight..::..CvsCellStatusLight Members
Cognex.InSight.Cell Namespace


CvsCellStatusLight.ColorAsRgb Property

[image]

In-Sight SDK
CvsCellStatusLight..::..ColorAsRgb Property
CvsCellStatusLight Class See Also Send Feedback
Gets the Color as an RGB value.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int ColorAsRgb { get; }
Visual Basic
Public ReadOnly Property ColorAsRgb As Integer
    Get

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

See Also

CvsCellStatusLight Class
CvsCellStatusLight..::..CvsCellStatusLight Members
Cognex.InSight.Cell Namespace


CvsCellStatusLight.DataType Property

[image]

In-Sight SDK
CvsCellStatusLight..::..DataType Property
CvsCellStatusLight Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellStatusLight Class
CvsCellStatusLight..::..CvsCellStatusLight Members
Cognex.InSight.Cell Namespace


CvsCellStatusLight.Text Property

[image]

In-Sight SDK
CvsCellStatusLight..::..Text Property
CvsCellStatusLight Class See Also Send Feedback
Gets the text for the StatusLight cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellStatusLight Class
CvsCellStatusLight..::..CvsCellStatusLight Members
Cognex.InSight.Cell Namespace


CvsCellStatusLight.Value Property

[image]

In-Sight SDK
CvsCellStatusLight..::..Value Property
CvsCellStatusLight Class See Also Send Feedback
Gets the value of the StatusLight cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Value { get; }
Visual Basic
Public ReadOnly Property Value As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellStatusLight Class
CvsCellStatusLight..::..CvsCellStatusLight Members
Cognex.InSight.Cell Namespace


CvsCellString Class

[image]

In-Sight SDK
CvsCellString Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight cell that has a text string displayed.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsCellString : CvsCell
Visual Basic
<SerializableAttribute>
Public Class CvsCellString
    Inherits CvsCell

Remarks

CvsCellString objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellString
Cognex.InSight.Cell..::..CvsCellAuthorize

See Also

CvsCellString..::..CvsCellString Members
Cognex.InSight.Cell Namespace


CvsCellString Members

[image] [image]

In-Sight SDK
CvsCellString Members
CvsCellString Class Methods Properties See Also Send Feedback

The CvsCellString type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetRawBytes | Gets the un-encoded bytes that represent the text associated with the cell.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the Text for the cell. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AsciiText | Gets the text string associated with the cell assuming that it represents an ASCII string.
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Checksum | Gets the checksum of the data associated with the cell's function.
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | ControlFunction | Gets a string (in ASCII) that describes the control or the empty string if this cell does not represent a control.
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Protected property | Flags | Returns the flags for this cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text string associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellString Class
Cognex.InSight.Cell Namespace


CvsCellString Methods

[image] [image]

In-Sight SDK
CvsCellString Methods
CvsCellString Class See Also Send Feedback

The CvsCellString type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetRawBytes | Gets the un-encoded bytes that represent the text associated with the cell.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the Text for the cell. (Overrides Object..::..ToString()()()().)

See Also

CvsCellString Class
Cognex.InSight.Cell Namespace


CvsCellString.GetRawBytes Method

[image]

In-Sight SDK
CvsCellString..::..GetRawBytes Method
CvsCellString Class See Also Send Feedback
Gets the un-encoded bytes that represent the text associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public byte[] GetRawBytes()
Visual Basic
Public Function GetRawBytes As Byte()

Return Value

Type: array< Byte >[]()[][]
An array of un-encoded data bytes including a trailing zero terminator byte.

Remarks

This method is particularly useful for obtaining values read from barcodes and symbols, where the actual values are more important than a displayable representation.

Because the Text property encodes the cell text as unicode, use this property to obtain the un-encoded bytes that represent the text. These raw data bytes will be the same as those character values from the In-Sight character set that are used within the job.

See Also

CvsCellString Class
CvsCellString..::..CvsCellString Members
Cognex.InSight.Cell Namespace


CvsCellString.ToString Method

[image]

In-Sight SDK
CvsCellString..::..ToString Method
CvsCellString Class See Also Send Feedback
Returns the Text for the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellString Class
CvsCellString..::..CvsCellString Members
Cognex.InSight.Cell Namespace


CvsCellString Properties

[image] [image]

In-Sight SDK
CvsCellString Properties
CvsCellString Class See Also Send Feedback

The CvsCellString type exposes the following members.

Properties

 | Name | Description
Public property | AsciiText | Gets the text string associated with the cell assuming that it represents an ASCII string.
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Checksum | Gets the checksum of the data associated with the cell's function.
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | ControlFunction | Gets a string (in ASCII) that describes the control or the empty string if this cell does not represent a control.
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Protected property | Flags | Returns the flags for this cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Inherited from CvsCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text string associated with the cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellString Class
Cognex.InSight.Cell Namespace


CvsCellString.AsciiText Property

[image]

In-Sight SDK
CvsCellString..::..AsciiText Property
CvsCellString Class See Also Send Feedback
Gets the text string associated with the cell assuming that it represents an ASCII string.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string AsciiText { get; }
Visual Basic
Public ReadOnly Property AsciiText As String
    Get

Property Value

Type: String

Remarks

This function can be used if a function returns an ASCII character string.

Any characters that lie outside of the ASCII character set will be replaced with question marks (?).

This method is particularly useful for obtaining values read from barcodes and symbols that contain only ASCII characters.

See Also

CvsCellString Class
CvsCellString..::..CvsCellString Members
Cognex.InSight.Cell Namespace


CvsCellString.Checksum Property

[image]

In-Sight SDK
CvsCellString..::..Checksum Property
CvsCellString Class See Also Send Feedback
Gets the checksum of the data associated with the cell's function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Checksum { get; }
Visual Basic
Public ReadOnly Property Checksum As Integer
    Get

Property Value

Type: Int32
The value will be the checksum for any data associated with the cell's function. Otherwise, the default value of 0 is returned.

Remarks

The checksum is calculated for additional information that the sensor keeps for various functions. This value may be used to determine when this data changes. For instance, OCRMax font changes or PatMax pattern retraining will cause the checksum to be recalculated.

The value will be set for cells for which HasChecksum is true.

See Also

CvsCellString Class
CvsCellString..::..CvsCellString Members
Cognex.InSight.Cell Namespace


CvsCellString.ControlFunction Property

[image]

In-Sight SDK
CvsCellString..::..ControlFunction Property
CvsCellString Class See Also Send Feedback
Gets a string (in ASCII) that describes the control or the empty string if this cell does not represent a control.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string ControlFunction { get; }
Visual Basic
Public ReadOnly Property ControlFunction As String
    Get

Property Value

Type: String

See Also

CvsCellString Class
CvsCellString..::..CvsCellString Members
Cognex.InSight.Cell Namespace


CvsCellString.DataType Property

[image]

In-Sight SDK
CvsCellString..::..DataType Property
CvsCellString Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellString Class
CvsCellString..::..CvsCellString Members
Cognex.InSight.Cell Namespace


CvsCellString.Text Property

[image]

In-Sight SDK
CvsCellString..::..Text Property
CvsCellString Class See Also Send Feedback
Gets the text string associated with the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

Remarks

If the cell is a tool, then the first character of the string will be the unicode character E006.

See Also

CvsCellString Class
CvsCellString..::..CvsCellString Members
Cognex.InSight.Cell Namespace


CvsCellWizard Class

[image]

In-Sight SDK
CvsCellWizard Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight Wizard function.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsCellWizard : CvsCell
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsCellWizard
    Inherits CvsCell

Remarks

CvsCellWizard objects are returned as items in a CvsCellCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Cell..::..CvsCell
Cognex.InSight.Cell..::..CvsCellWizard

See Also

CvsCellWizard..::..CvsCellWizard Members
Cognex.InSight.Cell Namespace


CvsCellWizard Members

[image] [image]

In-Sight SDK
CvsCellWizard Members
CvsCellWizard Class Methods Properties See Also Send Feedback

The CvsCellWizard type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the Text for the cell. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | NumDialogs | Gets the number of dialogs associated with the Wizard cell.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the Wizard cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellWizard Class
Cognex.InSight.Cell Namespace


CvsCellWizard Methods

[image] [image]

In-Sight SDK
CvsCellWizard Methods
CvsCellWizard Class See Also Send Feedback

The CvsCellWizard type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Computes an integer that represents the cell's coordinates. The X (column) coordinate is stored in the lower 16 bits and the Y (row) coordinate is stored in the upper 16 bits. (Inherited from CvsCell.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the Text for the cell. (Overrides Object..::..ToString()()()().)

See Also

CvsCellWizard Class
Cognex.InSight.Cell Namespace


CvsCellWizard.ToString Method

[image]

In-Sight SDK
CvsCellWizard..::..ToString Method
CvsCellWizard Class See Also Send Feedback
Returns the Text for the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsCellWizard Class
CvsCellWizard..::..CvsCellWizard Members
Cognex.InSight.Cell Namespace


CvsCellWizard Properties

[image] [image]

In-Sight SDK
CvsCellWizard Properties
CvsCellWizard Class See Also Send Feedback

The CvsCellWizard type exposes the following members.

Properties

 | Name | Description
Public property | CellStateReference | Gets the cell reference associated with a cell's state. (Inherited from CvsCell.)
Public property | Control | Gets a value indicating whether the cell represents a control. (Inherited from CvsCell.)
Public property | DataType | Gets the data type of the cell. (Overrides CvsCell..::..DataType.)
Public property | DataTypeString | Gets the string name of the cell's data type. (Inherited from CvsCell.)
Public property | Enabled | Gets a value indicating whether the cell is enabled. (Inherited from CvsCell.)
Public property | Error | Gets a value indicating whether the cell is in error. (Inherited from CvsCell.)
Public property | ErrorString | Gets a string describing the error. (Inherited from CvsCell.)
Public property | Expression | Gets the expression associated with the cell. (Inherited from CvsCell.)
Public property | HasChecksum | Gets a value indicating whether the cell has a checksum associated with its data. (Inherited from CvsCell.)
Public property | Hidden | Gets a value indicating whether the cell is hidden. (Inherited from CvsCell.)
Public property | IsEditCell | Returns true if the cell is an 'edit' cell. (Overrides CvsCell..::..IsEditCell.)
Public property | Location | Gets the cell's location. (Inherited from CvsCell.)
Public property | NumDialogs | Gets the number of dialogs associated with the Wizard cell.
Public property | OpcTag | Gets the OPC tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Properties | Gets the cell properties for this cell (Inherited from CvsCell.)
Public property | ProtectionState | Gets the state of the cell protection. (Inherited from CvsCell.)
Public property | SupportsAuthorization | Returns true if the cell supports authorization. (Inherited from CvsCell.)
Public property | SymbolicTag | Gets the symbolic tag associated with the cell or null if it has not been set. (Inherited from CvsCell.)
Public property | Text | Gets the text for the Wizard cell. (Overrides CvsCell..::..Text.)

See Also

CvsCellWizard Class
Cognex.InSight.Cell Namespace


CvsCellWizard.DataType Property

[image]

In-Sight SDK
CvsCellWizard..::..DataType Property
CvsCellWizard Class See Also Send Feedback
Gets the data type of the cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override CvsCellDataType DataType { get; }
Visual Basic
Public Overrides ReadOnly Property DataType As CvsCellDataType
    Get

Return Value

Type: CvsCellDataType

See Also

CvsCellWizard Class
CvsCellWizard..::..CvsCellWizard Members
Cognex.InSight.Cell Namespace


CvsCellWizard.IsEditCell Property

[image]

In-Sight SDK
CvsCellWizard..::..IsEditCell Property
CvsCellWizard Class See Also Send Feedback
Returns true if the cell is an 'edit' cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool IsEditCell { get; }
Visual Basic
Public Overrides ReadOnly Property IsEditCell As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsCellWizard Class
CvsCellWizard..::..CvsCellWizard Members
Cognex.InSight.Cell Namespace


CvsCellWizard.NumDialogs Property

[image]

In-Sight SDK
CvsCellWizard..::..NumDialogs Property
CvsCellWizard Class See Also Send Feedback
Gets the number of dialogs associated with the Wizard cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NumDialogs { get; }
Visual Basic
Public ReadOnly Property NumDialogs As Integer
    Get

Property Value

Type: Int32

See Also

CvsCellWizard Class
CvsCellWizard..::..CvsCellWizard Members
Cognex.InSight.Cell Namespace


CvsCellWizard.Text Property

[image]

In-Sight SDK
CvsCellWizard..::..Text Property
CvsCellWizard Class See Also Send Feedback
Gets the text for the Wizard cell.

Namespace: Cognex.InSight.Cell
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get

Property Value

Type: String

See Also

CvsCellWizard Class
CvsCellWizard..::..CvsCellWizard Members
Cognex.InSight.Cell Namespace


Cognex.InSight.Controls Namespace

[image]

In-Sight SDK
Cognex.InSight.Controls Namespace
Send Feedback
The Cognex.InSight.Controls namespace provides classes for representing actions that can be reset; can be enabled and disabled; can be bound to a Boolean property of another object; and can be invoked by an event.

Classes

 | Class | Description
Public class | CvsAction | This object represents an action that can be enabled and disabled, can be bound to a Boolean property of another object, and can be invoked by an event.
Public class | CvsActionToggle | This object represents an action that can be reset, can be enabled and disabled, can be bound to a Boolean property of another object, and can be invoked by an event. It is typically bound to toggle-style controls like menu items and toolbar buttons.


CvsAction Class

[image]

In-Sight SDK
CvsAction Class
Members See Also Send Feedback
This object represents an action that can be enabled and disabled, can be bound to a Boolean property of another object, and can be invoked by an event.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public class CvsAction : ICvsAction, IDisposable
Visual Basic
Public Class CvsAction
    Implements ICvsAction, IDisposable

Remarks

Actions will only be enabled when they are expected to execute successfully, so normally they will not generate exceptions. Nevertheless, while executing an action it is possible for an exception to be generated due to unforeseen circumstances such as a network error. If an exception occurs while executing an action in response to an event from a control to which the action is bound via the Bind(Object, String, String) method, a message box will be displayed indicating that the action could not be completed and showing the message provided by the exception. If an exception occurs while executing an action by directly calling its Execute()()()() method, the exception must be handled by the application. Any application code that calls the Execute method should have appropriate exception handling for CvsCommunicationException and exceptions derived from it.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Controls..::..CvsAction
Cognex.InSight.Controls..::..CvsActionToggle

See Also

CvsAction..::..CvsAction Members
Cognex.InSight.Controls Namespace


CvsAction Members

[image] [image]

In-Sight SDK
CvsAction Members
CvsAction Class Methods Properties Events See Also Send Feedback

The CvsAction type exposes the following members.

Methods

 | Name | Description
Public method | Bind(array<Object>[]()[][]) | Binds the action to the Enabled property and Click or CheckedChanged event of one or more objects.
Public method | Bind(ICvsActionObject) | Binds the action to a property and event of an object.
Public method | Bind(Object, String, String) | Binds the action to a property and event of an object.
Public method | Dispose()()()() | Base Dispose
Public method | Dispose(Boolean) | Disposes of the action, disconnecting all event sinks etc.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Performs the action if it is enabled, or does nothing if it is not enabled.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unbind(array<Object>[]()[][]) | Unbinds the action from the Enabled property and Click event of one or more objects.
Public method | Unbind(ICvsActionObject) | Unbinds the action from a property and event of an object.
Public method | Unbind(Object, String, String) | Unbinds the action from a property and event of an object.
Protected method | UpdateControlIcons | Updates the icon index of all bound controls.

Properties

 | Name | Description
Public property | Enabled | Gets the enabled state of the action.
Public property | HintText | A string that if set, contains the hint text for the selected actions shortcut EXAMPLE: "Shift+Plus"
 | RethrowExecuteExceptions | If set to false, exceptions caught during the execution of an action will result in a message box but the exception will not be rethrown. If set the true, the exception will be rethrown after the message box has been shown.
Public property | Suppressed | Allows the action to be suppressed, which hides any controls bound to its Enabled state and permanently disables the action.

Events

 | Name | Description
Public event | EnabledChanged | Raised when the Enabled property has changed.

See Also

CvsAction Class
Cognex.InSight.Controls Namespace


CvsAction Methods

[image] [image]

In-Sight SDK
CvsAction Methods
CvsAction Class See Also Send Feedback

The CvsAction type exposes the following members.

Methods

 | Name | Description
Public method | Bind(array<Object>[]()[][]) | Binds the action to the Enabled property and Click or CheckedChanged event of one or more objects.
Public method | Bind(ICvsActionObject) | Binds the action to a property and event of an object.
Public method | Bind(Object, String, String) | Binds the action to a property and event of an object.
Public method | Dispose()()()() | Base Dispose
Public method | Dispose(Boolean) | Disposes of the action, disconnecting all event sinks etc.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Performs the action if it is enabled, or does nothing if it is not enabled.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unbind(array<Object>[]()[][]) | Unbinds the action from the Enabled property and Click event of one or more objects.
Public method | Unbind(ICvsActionObject) | Unbinds the action from a property and event of an object.
Public method | Unbind(Object, String, String) | Unbinds the action from a property and event of an object.
Protected method | UpdateControlIcons | Updates the icon index of all bound controls.

See Also

CvsAction Class
Cognex.InSight.Controls Namespace


CvsAction.Bind Method

[image] [image]

In-Sight SDK
CvsAction..::..Bind Method
CvsAction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Bind(array<Object>[]()[][]) | Binds the action to the Enabled property and Click or CheckedChanged event of one or more objects.
Public method | Bind(ICvsActionObject) | Binds the action to a property and event of an object.
Public method | Bind(Object, String, String) | Binds the action to a property and event of an object.

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Cognex.InSight.Controls Namespace


CvsAction.Bind Method (Object[])

[image]

In-Sight SDK
CvsAction..::..Bind Method (array<Object>[]()[][])
CvsAction Class Example See Also Send Feedback
Binds the action to the Enabled property and Click or CheckedChanged event of one or more objects.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Bind(
    params Object[] objects
)
Visual Basic
Public Sub Bind (
    ParamArray objects As Object()
)

Parameters

objects
Type: array< System..::..Object >[]()[][]
One or more objects with an Enabled property and an event to which the action can be bound.

Remarks

If a ToolBarButton is given, the action will be bound to it through the ButtonClick event of its parent ToolBar. If a CheckBox is given, the action will be bound to its CheckedChanged event. Otherwise the action will be bound to the Click event.

This method is not available in ActiveX applications.

Examples

The following example binds the Copy action of the CvsInSightDisplay control to a MenuItem named mnuCopy and a ToolBarButton named tbbCopy. The Enabled properties of these controls will be changed automatically to match the Enabled state of the action, and the Click event of either control will automatically perform the action.
Copy image Copy
cvsInSightDisplay1.Edit.Copy.Bind(mnuCopy, tbbCopy);

Exceptions

Exception | Condition
System..::..ArgumentNullException | One of the parameters is null.
System..::..MissingMemberException | One of the given objects does not have a public writable Boolean property named Enabled.
System..::..MissingMemberException | One of the given objects does not have a public event of type EventHandler of the expected name.

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Bind Overload
Cognex.InSight.Controls Namespace


CvsAction.Bind Method (ICvsActionObject)

[image]

In-Sight SDK
CvsAction..::..Bind Method (ICvsActionObject)
CvsAction Class See Also Send Feedback
Binds the action to a property and event of an object.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Bind(
    ICvsActionObject obj
)
Visual Basic
Public Sub Bind (
    obj As ICvsActionObject
)

Parameters

obj
Type: Cognex.InSight..::..ICvsActionObject
The object to bind.

Remarks

This method is not available in ActiveX applications.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The obj parameter is null.
System..::..MissingMemberException | The propertyName parameter is non-null and the given object does not have a public writable Boolean property by that name.
System..::..MissingMemberException | The eventName parameter is non-null and the given object does not have a public event of type EventHandler by that name.

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Bind Overload
Cognex.InSight.Controls Namespace


CvsAction.Bind Method (Object, String, String)

[image]

In-Sight SDK
CvsAction..::..Bind Method (Object, String, String)
CvsAction Class Example See Also Send Feedback
Binds the action to a property and event of an object.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Bind(
    Object obj,
    string propertyName,
    string eventName
)
Visual Basic
Public Sub Bind (
    obj As Object,
    propertyName As String,
    eventName As String
)

Parameters

obj
Type: System..::..Object
The object to bind.
propertyName
Type: System..::..String
The name of a property to which to assign the enabled state of this action, or null if no property binding is desired.
eventName
Type: System..::..String
The name of an event that should initiate this action, or null if no event binding is desired.

Remarks

If a ToolBarButton is given, the action will be bound to it through the ButtonClick event of its parent ToolBar.

This method is not available in ActiveX applications.

Examples

The following example binds the Copy action of the CvsInSightDisplay control to the Click event of a Button named btnCopy but it does not bind to the Enabled property of the button, so the Enabled state of the button will be controlled by the application instead of by the editing action.
Copy image Copy
cvsInSightDisplay1.Edit.Copy.Bind(btnCopy, null, "Click");

Exceptions

Exception | Condition
System..::..ArgumentNullException | The obj parameter is null.
System..::..MissingMemberException | The propertyName parameter is non-null and the given object does not have a public writable Boolean property by that name.
System..::..MissingMemberException | The eventName parameter is non-null and the given object does not have a public event of type EventHandler by that name.

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Bind Overload
Cognex.InSight.Controls Namespace


CvsAction.Dispose Method

[image] [image]

In-Sight SDK
CvsAction..::..Dispose Method
CvsAction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Base Dispose
Public method | Dispose(Boolean) | Disposes of the action, disconnecting all event sinks etc.

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Cognex.InSight.Controls Namespace


CvsAction.Dispose Method

[image]

In-Sight SDK
CvsAction..::..Dispose Method
CvsAction Class See Also Send Feedback
Base Dispose

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Dispose Overload
Cognex.InSight.Controls Namespace


CvsAction.Dispose Method (Boolean)

[image]

In-Sight SDK
CvsAction..::..Dispose Method (Boolean)
CvsAction Class See Also Send Feedback
Disposes of the action, disconnecting all event sinks etc.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual void Dispose(
    bool disposing
)
Visual Basic
Public Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: System..::..Boolean
True to dispose managed and unmanaged resources. False to release only unmanaged resources.

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Dispose Overload
Cognex.InSight.Controls Namespace


CvsAction.Execute Method

[image]

In-Sight SDK
CvsAction..::..Execute Method
CvsAction Class See Also Send Feedback
Performs the action if it is enabled, or does nothing if it is not enabled.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual void Execute()
Visual Basic
Public Overridable Sub Execute

Remarks

Actions will only be enabled when they are expected to execute successfully, so normally they will not generate exceptions. Nevertheless, while executing an action it is possible for an exception to be generated due to unforeseen circumstances such as a network error. If an exception occurs while executing an action in response to an event from a control to which the action is bound via the Bind(Object, String, String) method, a message box will be displayed indicating that the action could not be completed and showing the message provided by the exception. If an exception occurs while executing an action by directly calling its Execute()()()() method, the exception must be handled by the application. Any application code that calls the Execute method should have appropriate exception handling for CvsCommunicationException and exceptions derived from it.

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Cognex.InSight.Controls Namespace


CvsAction.Unbind Method

[image] [image]

In-Sight SDK
CvsAction..::..Unbind Method
CvsAction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Unbind(array<Object>[]()[][]) | Unbinds the action from the Enabled property and Click event of one or more objects.
Public method | Unbind(ICvsActionObject) | Unbinds the action from a property and event of an object.
Public method | Unbind(Object, String, String) | Unbinds the action from a property and event of an object.

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Cognex.InSight.Controls Namespace


CvsAction.Unbind Method (Object[])

[image]

In-Sight SDK
CvsAction..::..Unbind Method (array<Object>[]()[][])
CvsAction Class See Also Send Feedback
Unbinds the action from the Enabled property and Click event of one or more objects.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Unbind(
    params Object[] objects
)
Visual Basic
Public Sub Unbind (
    ParamArray objects As Object()
)

Parameters

objects
Type: array< System..::..Object >[]()[][]
One or more objects with an Enabled property and a Click event.

Remarks

If a ToolBarButton is given, the action will be unbound from it through the ButtonClick event of its parent ToolBar.

This method is not available in ActiveX applications.

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Unbind Overload
Cognex.InSight.Controls Namespace


CvsAction.Unbind Method (ICvsActionObject)

[image]

In-Sight SDK
CvsAction..::..Unbind Method (ICvsActionObject)
CvsAction Class See Also Send Feedback
Unbinds the action from a property and event of an object.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Unbind(
    ICvsActionObject obj
)
Visual Basic
Public Sub Unbind (
    obj As ICvsActionObject
)

Parameters

obj
Type: Cognex.InSight..::..ICvsActionObject
The object to unbind.

Remarks

This method is not available in ActiveX applications.

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Unbind Overload
Cognex.InSight.Controls Namespace


CvsAction.Unbind Method (Object, String, String)

[image]

In-Sight SDK
CvsAction..::..Unbind Method (Object, String, String)
CvsAction Class See Also Send Feedback
Unbinds the action from a property and event of an object.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Unbind(
    Object obj,
    string propertyName,
    string eventName
)
Visual Basic
Public Sub Unbind (
    obj As Object,
    propertyName As String,
    eventName As String
)

Parameters

obj
Type: System..::..Object
The object to unbind.
propertyName
Type: System..::..String
The name of a property to which to assign the enabled state of this action, or null if no property binding is desired.
eventName
Type: System..::..String
The name of an event that should initiate this action, or null if no event binding is desired.

Remarks

If a ToolBarButton is given, the action will be unbound from it through the ButtonClick event of its parent ToolBar.

This method is not available in ActiveX applications.

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Unbind Overload
Cognex.InSight.Controls Namespace


CvsAction.UpdateControlIcons Method

[image]

In-Sight SDK
CvsAction..::..UpdateControlIcons Method
CvsAction Class See Also Send Feedback
Updates the icon index of all bound controls.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
protected void UpdateControlIcons()
Visual Basic
Protected Sub UpdateControlIcons

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Cognex.InSight.Controls Namespace


CvsAction Properties

[image] [image]

In-Sight SDK
CvsAction Properties
CvsAction Class See Also Send Feedback

The CvsAction type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets the enabled state of the action.
Public property | HintText | A string that if set, contains the hint text for the selected actions shortcut EXAMPLE: "Shift+Plus"
 | RethrowExecuteExceptions | If set to false, exceptions caught during the execution of an action will result in a message box but the exception will not be rethrown. If set the true, the exception will be rethrown after the message box has been shown.
Public property | Suppressed | Allows the action to be suppressed, which hides any controls bound to its Enabled state and permanently disables the action.

See Also

CvsAction Class
Cognex.InSight.Controls Namespace


CvsAction.Enabled Property

[image]

In-Sight SDK
CvsAction..::..Enabled Property
CvsAction Class See Also Send Feedback
Gets the enabled state of the action.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Enabled { get; }
Visual Basic
Public ReadOnly Property Enabled As Boolean
    Get

Property Value

Type: Boolean

Remarks

When this property changes, the EnabledChanged event is raised.

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Cognex.InSight.Controls Namespace


CvsAction.HintText Property

[image]

In-Sight SDK
CvsAction..::..HintText Property
CvsAction Class See Also Send Feedback
A string that if set, contains the hint text for the selected actions shortcut EXAMPLE: "Shift+Plus"

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string HintText { get; set; }
Visual Basic
Public Property HintText As String
    Get
    Set

Property Value

Type: String

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Cognex.InSight.Controls Namespace


CvsAction.RethrowExecuteExceptions Property

[image]

In-Sight SDK
CvsAction..::..RethrowExecuteExceptions Property
CvsAction Class See Also Send Feedback
If set to false, exceptions caught during the execution of an action will result in a message box but the exception will not be rethrown. If set the true, the exception will be rethrown after the message box has been shown.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool RethrowExecuteExceptions { get; set; }
Visual Basic
Public Shared Property RethrowExecuteExceptions As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Cognex.InSight.Controls Namespace


CvsAction.Suppressed Property

[image]

In-Sight SDK
CvsAction..::..Suppressed Property
CvsAction Class See Also Send Feedback
Allows the action to be suppressed, which hides any controls bound to its Enabled state and permanently disables the action.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Suppressed { get; set; }
Visual Basic
Public Property Suppressed As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Cognex.InSight.Controls Namespace


CvsAction Events

[image] [image]

In-Sight SDK
CvsAction Events
CvsAction Class See Also Send Feedback

The CvsAction type exposes the following members.

Events

 | Name | Description
Public event | EnabledChanged | Raised when the Enabled property has changed.

See Also

CvsAction Class
Cognex.InSight.Controls Namespace


CvsAction.EnabledChanged Event

[image]

In-Sight SDK
CvsAction..::..EnabledChanged Event
CvsAction Class See Also Send Feedback
Raised when the Enabled property has changed.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler EnabledChanged
Visual Basic
Public Event EnabledChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsAction Class
CvsAction..::..CvsAction Members
Cognex.InSight.Controls Namespace


CvsActionToggle Class

[image]

In-Sight SDK
CvsActionToggle Class
Members See Also Send Feedback
This object represents an action that can be reset, can be enabled and disabled, can be bound to a Boolean property of another object, and can be invoked by an event. It is typically bound to toggle-style controls like menu items and toolbar buttons.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public class CvsActionToggle : CvsAction,
    ICvsActionToggle
Visual Basic
Public Class CvsActionToggle
    Inherits CvsAction
    Implements ICvsActionToggle

Remarks

Actions will only be enabled when they are expected to execute successfully, so normally they will not generate exceptions. Nevertheless, while executing an action it is possible for an exception to be generated due to unforeseen circumstances such as a network error. If an exception occurs while executing an action in response to an event from a control to which the action is bound via the Bind(Object, String, String) method, a message box will be displayed indicating that the action could not be completed and showing the message provided by the exception. If an exception occurs while executing an action by directly calling its Execute()()()() method, the exception must be handled by the application. Any application code that calls the Execute method should have appropriate exception handling for CvsCommunicationException and exceptions derived from it.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Controls..::..CvsAction
Cognex.InSight.Controls..::..CvsActionToggle

See Also

CvsActionToggle..::..CvsActionToggle Members
Cognex.InSight.Controls Namespace


CvsActionToggle Members

[image] [image]

In-Sight SDK
CvsActionToggle Members
CvsActionToggle Class Methods Properties Events See Also Send Feedback

The CvsActionToggle type exposes the following members.

Methods

 | Name | Description
Public method | Bind(array<Object>[]()[][]) | Binds the action to the Enabled property and Click or CheckedChanged event of one or more objects. (Inherited from CvsAction.)
Public method | Bind(ICvsActionObject) | Binds the action to a property and event of an object. (Inherited from CvsAction.)
Public method | Bind(Object, String, String) | Binds the action to a property and event of an object. (Inherited from CvsAction.)
Public method | Dispose()()()() | Base Dispose (Inherited from CvsAction.)
Public method | Dispose(Boolean) | Dispose of resources. (Overrides CvsAction..::..Dispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Toggles the Activated state of the action if it is enabled, or does nothing if it is not enabled. (Overrides CvsAction..::..Execute()()()().)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unbind(array<Object>[]()[][]) | Unbinds the action from the Enabled property and Click event of one or more objects. (Inherited from CvsAction.)
Public method | Unbind(ICvsActionObject) | Unbinds the action from a property and event of an object. (Inherited from CvsAction.)
Public method | Unbind(Object, String, String) | Unbinds the action from a property and event of an object. (Inherited from CvsAction.)
Protected method | UpdateControlIcons | Updates the icon index of all bound controls. (Inherited from CvsAction.)

Properties

 | Name | Description
Public property | Activated | Gets or sets a value that indicates whether the action is currently activated.
Public property | Enabled | Gets the enabled state of the action. (Inherited from CvsAction.)
Public property | HintText | A string that if set, contains the hint text for the selected actions shortcut EXAMPLE: "Shift+Plus" (Inherited from CvsAction.)
Public property | Suppressed | Allows the action to be suppressed, which hides any controls bound to its Enabled state and permanently disables the action. (Inherited from CvsAction.)

Events

 | Name | Description
Public event | EnabledChanged | Raised when the Enabled property has changed. (Inherited from CvsAction.)

See Also

CvsActionToggle Class
Cognex.InSight.Controls Namespace


CvsActionToggle Methods

[image] [image]

In-Sight SDK
CvsActionToggle Methods
CvsActionToggle Class See Also Send Feedback

The CvsActionToggle type exposes the following members.

Methods

 | Name | Description
Public method | Bind(array<Object>[]()[][]) | Binds the action to the Enabled property and Click or CheckedChanged event of one or more objects. (Inherited from CvsAction.)
Public method | Bind(ICvsActionObject) | Binds the action to a property and event of an object. (Inherited from CvsAction.)
Public method | Bind(Object, String, String) | Binds the action to a property and event of an object. (Inherited from CvsAction.)
Public method | Dispose()()()() | Base Dispose (Inherited from CvsAction.)
Public method | Dispose(Boolean) | Dispose of resources. (Overrides CvsAction..::..Dispose(Boolean).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Toggles the Activated state of the action if it is enabled, or does nothing if it is not enabled. (Overrides CvsAction..::..Execute()()()().)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unbind(array<Object>[]()[][]) | Unbinds the action from the Enabled property and Click event of one or more objects. (Inherited from CvsAction.)
Public method | Unbind(ICvsActionObject) | Unbinds the action from a property and event of an object. (Inherited from CvsAction.)
Public method | Unbind(Object, String, String) | Unbinds the action from a property and event of an object. (Inherited from CvsAction.)
Protected method | UpdateControlIcons | Updates the icon index of all bound controls. (Inherited from CvsAction.)

See Also

CvsActionToggle Class
Cognex.InSight.Controls Namespace


CvsActionToggle.Dispose Method

[image] [image]

In-Sight SDK
CvsActionToggle..::..Dispose Method
CvsActionToggle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Base Dispose (Inherited from CvsAction.)
Public method | Dispose(Boolean) | Dispose of resources. (Overrides CvsAction..::..Dispose(Boolean).)

See Also

CvsActionToggle Class
CvsActionToggle..::..CvsActionToggle Members
Cognex.InSight.Controls Namespace


CvsActionToggle.Dispose Method (Boolean)

[image]

In-Sight SDK
CvsActionToggle..::..Dispose Method (Boolean)
CvsActionToggle Class See Also Send Feedback
Dispose of resources.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override void Dispose(
    bool disposing
)
Visual Basic
Public Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: System..::..Boolean
True to dispose managed and unmanaged resources. False to release only unmanaged resources.

See Also

CvsActionToggle Class
CvsActionToggle..::..CvsActionToggle Members
Dispose Overload
Cognex.InSight.Controls Namespace


CvsActionToggle.Execute Method

[image]

In-Sight SDK
CvsActionToggle..::..Execute Method
CvsActionToggle Class See Also Send Feedback
Toggles the Activated state of the action if it is enabled, or does nothing if it is not enabled.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override void Execute()
Visual Basic
Public Overrides Sub Execute

Remarks

Actions will only be enabled when they are expected to execute successfully, so normally they will not generate exceptions. Nevertheless, while executing an action it is possible for an exception to be generated due to unforeseen circumstances such as a network error. If an exception occurs while executing an action in response to an event from a control to which the action is bound via the Bind(Object, String, String) method, a message box will be displayed indicating that the action could not be completed and showing the message provided by the exception. If an exception occurs while executing an action by directly calling its Execute()()()() method, the exception must be handled by the application. Any application code that calls the Execute method should have appropriate exception handling for CvsCommunicationException and exceptions derived from it.

See Also

CvsActionToggle Class
CvsActionToggle..::..CvsActionToggle Members
Cognex.InSight.Controls Namespace


CvsActionToggle Properties

[image] [image]

In-Sight SDK
CvsActionToggle Properties
CvsActionToggle Class See Also Send Feedback

The CvsActionToggle type exposes the following members.

Properties

 | Name | Description
Public property | Activated | Gets or sets a value that indicates whether the action is currently activated.
Public property | Enabled | Gets the enabled state of the action. (Inherited from CvsAction.)
Public property | HintText | A string that if set, contains the hint text for the selected actions shortcut EXAMPLE: "Shift+Plus" (Inherited from CvsAction.)
Public property | Suppressed | Allows the action to be suppressed, which hides any controls bound to its Enabled state and permanently disables the action. (Inherited from CvsAction.)

See Also

CvsActionToggle Class
Cognex.InSight.Controls Namespace


CvsActionToggle.Activated Property

[image]

In-Sight SDK
CvsActionToggle..::..Activated Property
CvsActionToggle Class See Also Send Feedback
Gets or sets a value that indicates whether the action is currently activated.

Namespace: Cognex.InSight.Controls
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Activated { get; set; }
Visual Basic
Public Property Activated As Boolean
    Get
    Set

Property Value

Type: Boolean

Exceptions

Exception | Condition
System..::..Exception | This property may throw a variety of exceptions that are specific to the implementation of the action. The caller must have an exception trap so it can handle exceptions as gracefully as possible.

See Also

CvsActionToggle Class
CvsActionToggle..::..CvsActionToggle Members
Cognex.InSight.Controls Namespace


CvsActionToggle Events

[image] [image]

In-Sight SDK
CvsActionToggle Events
CvsActionToggle Class See Also Send Feedback

The CvsActionToggle type exposes the following members.

Events

 | Name | Description
Public event | EnabledChanged | Raised when the Enabled property has changed. (Inherited from CvsAction.)

See Also

CvsActionToggle Class
Cognex.InSight.Controls Namespace


Cognex.InSight.Controls.Display Namespace

[image]

In-Sight SDK
Cognex.InSight.Controls.Display Namespace
Send Feedback
The Cognex.InSight.Controls.Display namespace contains the CvsInSightDisplay for displaying images and graphics.

Classes

 | Class | Description
Public class | CvsCellClickEventArgs | The event arguments class for events raised when a cell is clicked in the display.
Public class | CvsDisplayStateChangedEventArgs | This class holds information about the state transition of the display. It is used when the display StateChanged event occurs.
Public class | CvsEditEventArgs | The event arguments class for events raised while editing items in the display.
Public class | CvsExpressionTreeDisplayBinder | This class binds a CvsExpressionTree control to a CvsInSightDisplay, keeping their selected cell etc. in sync.
Public class | CvsExpressionTreeItemEventArgs | Event arguments for the ItemClick event.
Public class | CvsExpressionTreeView | Displays a tree-style view of a cell expression and its dependents/precedents.
Public class | CvsInSightDisplay | The CvsInSightDisplay displays images, graphics, and cell data from an In-Sight sensor.
Public class | CvsInSightDisplayEdit | Provides the editing actions for the CvsInSightDisplay control.
Public class | CvsInSightDisplayHistory | Maintains a browsing history within a display, so one can navigate forward and back to cell locations.
Public class | CvsInSightDisplayRecorder | This class manages Record and Playback operations for the CvsInSightDisplay.
Public class | CvsInSightDisplayRecorderOptions | A class to hold all of the recorder options that get stored in the job view options.
Public class | CvsSpreadsheetNavigator | Provides a thumbnail view of the spreadsheet with a box indicating the current view within the display.
Public class | CvsSpreadsheetNavigatorPanel | Contains the CvsSpreadsheetNavigator control for use in Docking windows
Public class | SpreadsheetNavigatorOptions | class for storing spreadsheet navigator preferences uses SystemOptions to store data in Options.xml
Public class | SynchronizedInspectionParametersDialog | The dialog that allows the user to edit parameters controlling the inspection synchronizer.

Structures

 | Structure | Description
Public structure | CvsKeyboardState | Holds the current keyboard state during a KeyDown or KeyUp event.

Interfaces

 | Interface | Description
Public interface | ICvsInSightDisplayEditForm | An interface that provides forms with some control over the display's actions.
Public interface | IDisplayOptionsView | The interface between the options Emulation controller and the options Emulation control.
Public interface | IProvideDialogActivationLocation | Used by a dialog to indicate a safe location where the dialog can be activated without causing an event. Added since clicking at 5,5 on the OCRMax's AutoTuneDialog activates the reset button.
Public interface | IUserListView | The IUserListView interface is used to separate the controller and control functionality to aid in unit testing.

Delegates

 | Delegate | Description
Public delegate | CvsCellClickEventHandler | The delegate for the CellClick event.
Public delegate | CvsDisplayStateChangedEventHandler | Represents the method that will handle the StateChanged event.
Public delegate | CvsEditEventHandler | The delegate for receiving editing events from the display.
Public delegate | CvsExpressionTreeItemEventHandler | Delegate for the ItemClick event.
Public delegate | CvsInSightDisplay..::..CvsTextScaleModeEventHandler | Delegate for TextScaleModeChanged event

Enumerations

 | Enumeration | Description
Public enumeration | CvsDisplayScrollMode | Used by the ScrollMode property of the CvsInSightDisplay control to specify whether the scroll bars scroll the image or the grid.
Public enumeration | CvsDisplayState | The CvsDisplayState enumeration is used by the State property to indicate the current state of the display.
Public enumeration | CvsDisplayStateChange | Enum for the CvsDisplayStateChangedEventArgs to describe how the event changed.
Public enumeration | CvsDisplayZoom | Constants for specifying the zooming mode of the display, via the ImageZoomMode property.
Public enumeration | CvsInSightDisplay..::..TextScaleModeType | Enumerator for text scaling mode
Public enumeration | CvsInSightDisplayCropScaleMode | Indicates the appropriate Crop/Scale mode for the InSight Display.
Public enumeration | CvsRecordMode | Values used by the RecordMode property to specify what images are recorded and whether they are sorted.
Public enumeration | CvsStatusInformationState | The CvsStatusInformationState enumeration is used by the StatusInformationState property to indicate the current type of information contained in the StatusInformation property.


CvsCellClickEventArgs Class

[image]

In-Sight SDK
CvsCellClickEventArgs Class
Members See Also Send Feedback
The event arguments class for events raised when a cell is clicked in the display.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsCellClickEventArgs : EventArgs
Visual Basic
Public Class CvsCellClickEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Cognex.InSight.Controls.Display..::..CvsCellClickEventArgs

See Also

CvsCellClickEventArgs..::..CvsCellClickEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsCellClickEventArgs Members

[image] [image]

In-Sight SDK
CvsCellClickEventArgs Members
CvsCellClickEventArgs Class Methods Properties See Also Send Feedback

The CvsCellClickEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cell | Gets the cell that was clicked, or null if the clicked cell is empty.
Public property | Handled | Set to true if the event is handled by an event sink and should be ignored by the display.
Public property | Location | Gets the cell location that was clicked.
Public property | Mouse | Gets the mouse event arguments.

See Also

CvsCellClickEventArgs Class
Cognex.InSight.Controls.Display Namespace


CvsCellClickEventArgs Methods

[image] [image]

In-Sight SDK
CvsCellClickEventArgs Methods
CvsCellClickEventArgs Class See Also Send Feedback

The CvsCellClickEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsCellClickEventArgs Class
Cognex.InSight.Controls.Display Namespace


CvsCellClickEventArgs Properties

[image] [image]

In-Sight SDK
CvsCellClickEventArgs Properties
CvsCellClickEventArgs Class See Also Send Feedback

The CvsCellClickEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cell | Gets the cell that was clicked, or null if the clicked cell is empty.
Public property | Handled | Set to true if the event is handled by an event sink and should be ignored by the display.
Public property | Location | Gets the cell location that was clicked.
Public property | Mouse | Gets the mouse event arguments.

See Also

CvsCellClickEventArgs Class
Cognex.InSight.Controls.Display Namespace


CvsCellClickEventArgs.Cell Property

[image]

In-Sight SDK
CvsCellClickEventArgs..::..Cell Property
CvsCellClickEventArgs Class See Also Send Feedback
Gets the cell that was clicked, or null if the clicked cell is empty.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsCell Cell { get; }
Visual Basic
Public ReadOnly Property Cell As CvsCell
    Get

Property Value

Type: CvsCell

See Also

CvsCellClickEventArgs Class
CvsCellClickEventArgs..::..CvsCellClickEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsCellClickEventArgs.Handled Property

[image]

In-Sight SDK
CvsCellClickEventArgs..::..Handled Property
CvsCellClickEventArgs Class See Also Send Feedback
Set to true if the event is handled by an event sink and should be ignored by the display.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsCellClickEventArgs Class
CvsCellClickEventArgs..::..CvsCellClickEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsCellClickEventArgs.Location Property

[image]

In-Sight SDK
CvsCellClickEventArgs..::..Location Property
CvsCellClickEventArgs Class See Also Send Feedback
Gets the cell location that was clicked.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation Location { get; }
Visual Basic
Public ReadOnly Property Location As CvsCellLocation
    Get

Property Value

Type: CvsCellLocation

See Also

CvsCellClickEventArgs Class
CvsCellClickEventArgs..::..CvsCellClickEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsCellClickEventArgs.Mouse Property

[image]

In-Sight SDK
CvsCellClickEventArgs..::..Mouse Property
CvsCellClickEventArgs Class See Also Send Feedback
Gets the mouse event arguments.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public MouseEventArgs Mouse { get; }
Visual Basic
Public ReadOnly Property Mouse As MouseEventArgs
    Get

Property Value

Type: MouseEventArgs

See Also

CvsCellClickEventArgs Class
CvsCellClickEventArgs..::..CvsCellClickEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsCellClickEventHandler Delegate

[image]

In-Sight SDK
CvsCellClickEventHandler Delegate
See Also Send Feedback
The delegate for the CellClick event.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public delegate void CvsCellClickEventHandler(
    Object sender,
    CvsCellClickEventArgs e
)
Visual Basic
Public Delegate Sub CvsCellClickEventHandler (
    sender As Object,
    e As CvsCellClickEventArgs
)

Parameters

sender
Type: System..::..Object
e
Type: Cognex.InSight.Controls.Display..::..CvsCellClickEventArgs

See Also

Cognex.InSight.Controls.Display Namespace


CvsDisplayScrollMode Enumeration

[image]

In-Sight SDK
CvsDisplayScrollMode Enumeration
See Also Send Feedback
Used by the ScrollMode property of the CvsInSightDisplay control to specify whether the scroll bars scroll the image or the grid.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsDisplayScrollMode
Visual Basic
Public Enumeration CvsDisplayScrollMode

Members

Member name | Value | Description
None | -1 | The scroll bars are disabled.
Image | 0 | The scroll bars scroll the image.
Grid | 1 | The scroll bars scroll the grid.

See Also

Cognex.InSight.Controls.Display Namespace


CvsDisplayState Enumeration

[image]

In-Sight SDK
CvsDisplayState Enumeration
See Also Send Feedback
The CvsDisplayState enumeration is used by the State property to indicate the current state of the display.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsDisplayState
Visual Basic
Public Enumeration CvsDisplayState

Members

Member name | Value | Description
Normal | 0 | The normal display of image and graphics.
Connecting | 1 | Trying to connect to an In-Sight sensor.
EditingCellExpression | 2 | The expression of a cell is currently being edited in place.
EditingCellValue | 3 | The value of a cell is currently being edited. This only applies to cells such as EditInt, EditFloat and EditString.
EditingGraphics | 4 | Graphics are currently being edited.
EditingReferenceRanges | 5 | Cell reference ranges are currently being edited.
Waiting | 6 | Waiting for a response from the In-Sight sensor.
Dialog | 7 | A dialog is open and active.
DialogEditingReferenceRanges | 8 | A user dialog is open for editing reference ranges.
DialogOpenedByPeer | 9 | A peer has opened a dialog.
Wizard | 10 | A sequential-mode wizard has been started.

See Also

Cognex.InSight.Controls.Display Namespace


CvsDisplayStateChange Enumeration

[image]

In-Sight SDK
CvsDisplayStateChange Enumeration
See Also Send Feedback
Enum for the CvsDisplayStateChangedEventArgs to describe how the event changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsDisplayStateChange
Visual Basic
Public Enumeration CvsDisplayStateChange

Members

Member name | Value | Description
Undefined | 0 | Undefined change.
Pushed | 1 | Display pushed a change on its stack.
Popped | 2 | Display popped a change off its stack.
DisplayChanged | 3 | Display was changed.

See Also

Cognex.InSight.Controls.Display Namespace


CvsDisplayStateChangedEventArgs Class

[image]

In-Sight SDK
CvsDisplayStateChangedEventArgs Class
Members See Also Send Feedback
This class holds information about the state transition of the display. It is used when the display StateChanged event occurs.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsDisplayStateChangedEventArgs : EventArgs
Visual Basic
Public Class CvsDisplayStateChangedEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Cognex.InSight.Controls.Display..::..CvsDisplayStateChangedEventArgs

See Also

CvsDisplayStateChangedEventArgs..::..CvsDisplayStateChangedEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsDisplayStateChangedEventArgs Members

[image] [image]

In-Sight SDK
CvsDisplayStateChangedEventArgs Members
CvsDisplayStateChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The CvsDisplayStateChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CvsDisplayStateChangedEventArgs | Initializes a new instance of the CvsDisplayStateChangedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NewState | The state the stack is transitioning to.
Public property | OldState | The state the stack is transitioning from.
Public property | Reason | The reason for the state change.

See Also

CvsDisplayStateChangedEventArgs Class
Cognex.InSight.Controls.Display Namespace


CvsDisplayStateChangedEventArgs Constructor

[image]

In-Sight SDK
CvsDisplayStateChangedEventArgs Constructor
CvsDisplayStateChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the CvsDisplayStateChangedEventArgs class.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsDisplayStateChangedEventArgs(
    CvsDisplayState newState,
    CvsDisplayState oldState,
    CvsDisplayStateChange reason
)
Visual Basic
Public Sub New (
    newState As CvsDisplayState,
    oldState As CvsDisplayState,
    reason As CvsDisplayStateChange
)

Parameters

newState
Type: Cognex.InSight.Controls.Display..::..CvsDisplayState
The state the stack is transitioning to.
oldState
Type: Cognex.InSight.Controls.Display..::..CvsDisplayState
The state the stack is transitioning from.
reason
Type: Cognex.InSight.Controls.Display..::..CvsDisplayStateChange
The reason for the state change.

See Also

CvsDisplayStateChangedEventArgs Class
CvsDisplayStateChangedEventArgs..::..CvsDisplayStateChangedEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsDisplayStateChangedEventArgs Methods

[image] [image]

In-Sight SDK
CvsDisplayStateChangedEventArgs Methods
CvsDisplayStateChangedEventArgs Class See Also Send Feedback

The CvsDisplayStateChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsDisplayStateChangedEventArgs Class
Cognex.InSight.Controls.Display Namespace


CvsDisplayStateChangedEventArgs Properties

[image] [image]

In-Sight SDK
CvsDisplayStateChangedEventArgs Properties
CvsDisplayStateChangedEventArgs Class See Also Send Feedback

The CvsDisplayStateChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | NewState | The state the stack is transitioning to.
Public property | OldState | The state the stack is transitioning from.
Public property | Reason | The reason for the state change.

See Also

CvsDisplayStateChangedEventArgs Class
Cognex.InSight.Controls.Display Namespace


CvsDisplayStateChangedEventArgs.NewState Property

[image]

In-Sight SDK
CvsDisplayStateChangedEventArgs..::..NewState Property
CvsDisplayStateChangedEventArgs Class See Also Send Feedback
The state the stack is transitioning to.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsDisplayState NewState { get; }
Visual Basic
Public ReadOnly Property NewState As CvsDisplayState
    Get

Property Value

Type: CvsDisplayState

See Also

CvsDisplayStateChangedEventArgs Class
CvsDisplayStateChangedEventArgs..::..CvsDisplayStateChangedEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsDisplayStateChangedEventArgs.OldState Property

[image]

In-Sight SDK
CvsDisplayStateChangedEventArgs..::..OldState Property
CvsDisplayStateChangedEventArgs Class See Also Send Feedback
The state the stack is transitioning from.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsDisplayState OldState { get; }
Visual Basic
Public ReadOnly Property OldState As CvsDisplayState
    Get

Property Value

Type: CvsDisplayState

See Also

CvsDisplayStateChangedEventArgs Class
CvsDisplayStateChangedEventArgs..::..CvsDisplayStateChangedEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsDisplayStateChangedEventArgs.Reason Property

[image]

In-Sight SDK
CvsDisplayStateChangedEventArgs..::..Reason Property
CvsDisplayStateChangedEventArgs Class See Also Send Feedback
The reason for the state change.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsDisplayStateChange Reason { get; }
Visual Basic
Public ReadOnly Property Reason As CvsDisplayStateChange
    Get

Property Value

Type: CvsDisplayStateChange

See Also

CvsDisplayStateChangedEventArgs Class
CvsDisplayStateChangedEventArgs..::..CvsDisplayStateChangedEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsDisplayStateChangedEventHandler Delegate

[image]

In-Sight SDK
CvsDisplayStateChangedEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the StateChanged event.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public delegate void CvsDisplayStateChangedEventHandler(
    Object sender,
    CvsDisplayStateChangedEventArgs e
)
Visual Basic
Public Delegate Sub CvsDisplayStateChangedEventHandler (
    sender As Object,
    e As CvsDisplayStateChangedEventArgs
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Cognex.InSight.Controls.Display..::..CvsDisplayStateChangedEventArgs
A CvsDisplayStateChangedEventArgs that contains the event data.

See Also

Cognex.InSight.Controls.Display Namespace


CvsDisplayZoom Enumeration

[image]

In-Sight SDK
CvsDisplayZoom Enumeration
See Also Send Feedback
Constants for specifying the zooming mode of the display, via the ImageZoomMode property.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsDisplayZoom
Visual Basic
Public Enumeration CvsDisplayZoom

Members

Member name | Value | Description
None | 0 | No automatic zooming is performed.
Fit | 1 | The display automatically adjusts the scale factor so that the entire region just fits within the display. If the aspect ratios differ, empty space may appear outside the displayed region.
Fill | 2 | The display automatically adjusts the scale factor so that the region fills the entire display. If the aspect ratios differ, the display portions of the region may not be visible.

See Also

Cognex.InSight.Controls.Display Namespace


CvsEditEventArgs Class

[image]

In-Sight SDK
CvsEditEventArgs Class
Members See Also Send Feedback
The event arguments class for events raised while editing items in the display.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsEditEventArgs : EventArgs
Visual Basic
Public Class CvsEditEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Cognex.InSight.Controls.Display..::..CvsEditEventArgs

See Also

CvsEditEventArgs..::..CvsEditEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsEditEventArgs Members

[image] [image]

In-Sight SDK
CvsEditEventArgs Members
CvsEditEventArgs Class Methods Properties See Also Send Feedback

The CvsEditEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Accept | Gets or sets a value that indicates whether the changes are accepted. If set to false, changes will be discarded and the edited item will revert to its previous state.
Public property | CellLocation | Gets the cell location that was edited. This will equal Invalid if the item(s) being edited do not correspond to a particular cell location.
Public property | DraggingGraphic | Gets or sets a value to indicate that a graphic is being dragged.
Public property | Value | Gets or sets the new value of the item being edited. This value is ignored if Accept is false.

See Also

CvsEditEventArgs Class
Cognex.InSight.Controls.Display Namespace


CvsEditEventArgs Methods

[image] [image]

In-Sight SDK
CvsEditEventArgs Methods
CvsEditEventArgs Class See Also Send Feedback

The CvsEditEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsEditEventArgs Class
Cognex.InSight.Controls.Display Namespace


CvsEditEventArgs Properties

[image] [image]

In-Sight SDK
CvsEditEventArgs Properties
CvsEditEventArgs Class See Also Send Feedback

The CvsEditEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Accept | Gets or sets a value that indicates whether the changes are accepted. If set to false, changes will be discarded and the edited item will revert to its previous state.
Public property | CellLocation | Gets the cell location that was edited. This will equal Invalid if the item(s) being edited do not correspond to a particular cell location.
Public property | DraggingGraphic | Gets or sets a value to indicate that a graphic is being dragged.
Public property | Value | Gets or sets the new value of the item being edited. This value is ignored if Accept is false.

See Also

CvsEditEventArgs Class
Cognex.InSight.Controls.Display Namespace


CvsEditEventArgs.Accept Property

[image]

In-Sight SDK
CvsEditEventArgs..::..Accept Property
CvsEditEventArgs Class See Also Send Feedback
Gets or sets a value that indicates whether the changes are accepted. If set to false, changes will be discarded and the edited item will revert to its previous state.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool Accept { get; set; }
Visual Basic
Public Property Accept As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsEditEventArgs Class
CvsEditEventArgs..::..CvsEditEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsEditEventArgs.CellLocation Property

[image]

In-Sight SDK
CvsEditEventArgs..::..CellLocation Property
CvsEditEventArgs Class See Also Send Feedback
Gets the cell location that was edited. This will equal Invalid if the item(s) being edited do not correspond to a particular cell location.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation CellLocation { get; }
Visual Basic
Public ReadOnly Property CellLocation As CvsCellLocation
    Get

Property Value

Type: CvsCellLocation

See Also

CvsEditEventArgs Class
CvsEditEventArgs..::..CvsEditEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsEditEventArgs.DraggingGraphic Property

[image]

In-Sight SDK
CvsEditEventArgs..::..DraggingGraphic Property
CvsEditEventArgs Class See Also Send Feedback
Gets or sets a value to indicate that a graphic is being dragged.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool DraggingGraphic { get; set; }
Visual Basic
Public Property DraggingGraphic As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsEditEventArgs Class
CvsEditEventArgs..::..CvsEditEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsEditEventArgs.Value Property

[image]

In-Sight SDK
CvsEditEventArgs..::..Value Property
CvsEditEventArgs Class See Also Send Feedback
Gets or sets the new value of the item being edited. This value is ignored if Accept is false.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public Object Value { get; set; }
Visual Basic
Public Property Value As Object
    Get
    Set

Property Value

Type: Object

See Also

CvsEditEventArgs Class
CvsEditEventArgs..::..CvsEditEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsEditEventHandler Delegate

[image]

In-Sight SDK
CvsEditEventHandler Delegate
See Also Send Feedback
The delegate for receiving editing events from the display.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public delegate void CvsEditEventHandler(
    Object sender,
    CvsEditEventArgs e
)
Visual Basic
Public Delegate Sub CvsEditEventHandler (
    sender As Object,
    e As CvsEditEventArgs
)

Parameters

sender
Type: System..::..Object
The object that raised the event.
e
Type: Cognex.InSight.Controls.Display..::..CvsEditEventArgs
The event arguments.

See Also

Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeDisplayBinder Class

[image]

In-Sight SDK
CvsExpressionTreeDisplayBinder Class
Members See Also Send Feedback
This class binds a CvsExpressionTree control to a CvsInSightDisplay, keeping their selected cell etc. in sync.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsExpressionTreeDisplayBinder : IDisposable
Visual Basic
Public Class CvsExpressionTreeDisplayBinder
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Controls.Display..::..CvsExpressionTreeDisplayBinder

See Also

CvsExpressionTreeDisplayBinder..::..CvsExpressionTreeDisplayBinder Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeDisplayBinder Members

[image] [image]

In-Sight SDK
CvsExpressionTreeDisplayBinder Members
CvsExpressionTreeDisplayBinder Class Constructors Methods See Also Send Feedback

The CvsExpressionTreeDisplayBinder type exposes the following members.

Constructors

 | Name | Description
Public method | CvsExpressionTreeDisplayBinder | Create an expression tree binder

Methods

 | Name | Description
Public method | Dispose | Removes all binding behavior.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsExpressionTreeDisplayBinder Class
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeDisplayBinder Constructor

[image]

In-Sight SDK
CvsExpressionTreeDisplayBinder Constructor
CvsExpressionTreeDisplayBinder Class See Also Send Feedback
Create an expression tree binder

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsExpressionTreeDisplayBinder(
    CvsInSightDisplay display,
    CvsExpressionTreeView tree
)
Visual Basic
Public Sub New (
    display As CvsInSightDisplay,
    tree As CvsExpressionTreeView
)

Parameters

display
Type: Cognex.InSight.Controls.Display..::..CvsInSightDisplay
The InSightDisplay source.
tree
Type: Cognex.InSight.Controls.Display..::..CvsExpressionTreeView
The expression tree target.

See Also

CvsExpressionTreeDisplayBinder Class
CvsExpressionTreeDisplayBinder..::..CvsExpressionTreeDisplayBinder Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeDisplayBinder Methods

[image] [image]

In-Sight SDK
CvsExpressionTreeDisplayBinder Methods
CvsExpressionTreeDisplayBinder Class See Also Send Feedback

The CvsExpressionTreeDisplayBinder type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Removes all binding behavior.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsExpressionTreeDisplayBinder Class
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeDisplayBinder.Dispose Method

[image]

In-Sight SDK
CvsExpressionTreeDisplayBinder..::..Dispose Method
CvsExpressionTreeDisplayBinder Class See Also Send Feedback
Removes all binding behavior.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

CvsExpressionTreeDisplayBinder Class
CvsExpressionTreeDisplayBinder..::..CvsExpressionTreeDisplayBinder Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeItemEventArgs Class

[image]

In-Sight SDK
CvsExpressionTreeItemEventArgs Class
Members See Also Send Feedback
Event arguments for the ItemClick event.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsExpressionTreeItemEventArgs : EventArgs
Visual Basic
Public Class CvsExpressionTreeItemEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Cognex.InSight.Controls.Display..::..CvsExpressionTreeItemEventArgs

See Also

CvsExpressionTreeItemEventArgs..::..CvsExpressionTreeItemEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeItemEventArgs Members

[image] [image]

In-Sight SDK
CvsExpressionTreeItemEventArgs Members
CvsExpressionTreeItemEventArgs Class Constructors Methods Fields See Also Send Feedback

The CvsExpressionTreeItemEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CvsExpressionTreeItemEventArgs | Constructs a new instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | CellLocation | Gets the cell location that was clicked.

See Also

CvsExpressionTreeItemEventArgs Class
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeItemEventArgs Constructor

[image]

In-Sight SDK
CvsExpressionTreeItemEventArgs Constructor
CvsExpressionTreeItemEventArgs Class See Also Send Feedback
Constructs a new instance.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsExpressionTreeItemEventArgs(
    CvsCellLocation cellLocation
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell location that was clicked.

See Also

CvsExpressionTreeItemEventArgs Class
CvsExpressionTreeItemEventArgs..::..CvsExpressionTreeItemEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeItemEventArgs Fields

[image] [image]

In-Sight SDK
CvsExpressionTreeItemEventArgs Fields
CvsExpressionTreeItemEventArgs Class See Also Send Feedback

The CvsExpressionTreeItemEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | CellLocation | Gets the cell location that was clicked.

See Also

CvsExpressionTreeItemEventArgs Class
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeItemEventArgs.CellLocation Field

[image]

In-Sight SDK
CvsExpressionTreeItemEventArgs..::..CellLocation Field
CvsExpressionTreeItemEventArgs Class See Also Send Feedback
Gets the cell location that was clicked.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public readonly CvsCellLocation CellLocation
Visual Basic
Public ReadOnly CellLocation As CvsCellLocation

Field Value

Type: CvsCellLocation

See Also

CvsExpressionTreeItemEventArgs Class
CvsExpressionTreeItemEventArgs..::..CvsExpressionTreeItemEventArgs Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeItemEventArgs Methods

[image] [image]

In-Sight SDK
CvsExpressionTreeItemEventArgs Methods
CvsExpressionTreeItemEventArgs Class See Also Send Feedback

The CvsExpressionTreeItemEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsExpressionTreeItemEventArgs Class
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeItemEventHandler Delegate

[image]

In-Sight SDK
CvsExpressionTreeItemEventHandler Delegate
See Also Send Feedback
Delegate for the ItemClick event.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public delegate void CvsExpressionTreeItemEventHandler(
    Object sender,
    CvsExpressionTreeItemEventArgs e
)
Visual Basic
Public Delegate Sub CvsExpressionTreeItemEventHandler (
    sender As Object,
    e As CvsExpressionTreeItemEventArgs
)

Parameters

sender
Type: System..::..Object
e
Type: Cognex.InSight.Controls.Display..::..CvsExpressionTreeItemEventArgs

See Also

Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView Class

[image]

In-Sight SDK
CvsExpressionTreeView Class
Members See Also Send Feedback
Displays a tree-style view of a cell expression and its dependents/precedents.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsExpressionTreeView : ToolWindowPanel
Visual Basic
Public Class CvsExpressionTreeView
    Inherits ToolWindowPanel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
ToolWindowPanel
Cognex.InSight.Controls.Display..::..CvsExpressionTreeView

See Also

CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView Members

[image] [image]

In-Sight SDK
CvsExpressionTreeView Members
CvsExpressionTreeView Class Constructors Methods Properties Events See Also Send Feedback

The CvsExpressionTreeView type exposes the following members.

Constructors

 | Name | Description
Public method | CvsExpressionTreeView | Constructs a new instance.

Methods

 | Name | Description
Public method | Accept | (Inherited from ToolWindowPanel.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides ToolWindowPanelDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowedDockState | (Inherited from ToolWindowPanel.)
Public property | AllowToggle | (Inherited from ToolWindowPanel.)
Public property | AlwaysForceVisible | (Inherited from ToolWindowPanel.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CaptionTextID | (Overrides ToolWindowPanelCaptionTextID.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | Closeable | (Inherited from ToolWindowPanel.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Display | Gets or sets a display control to which this tree view is bound.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightLocation | Gets or sets a cell location to be highlighted when it is shown in the tree.
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | (Overrides ToolWindowPanelIcon.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InitiallyVisible | (Inherited from ToolWindowPanel.)
Public property | InitialSite | (Overrides ToolWindowPanelInitialSite.)
Public property | InitialSize | (Inherited from ToolWindowPanel.)
Public property | InSight | Gets or sets the system to which this control is connected.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseCellLocation | Gets the cell location of the node under the mouse cursor, or CvsCellLocation.Invalid if the mouse is not over a node.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | Pinned | Gets or sets a value that indicates whether clicking a node should keep the current cell location (pinned) or change to the clicked cell location (unpinned).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedRange | Gets or sets the range of cells for which dependencies are displayed.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemClick | Raised when the user clicks on an item in the tree.
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseCellLocationChanged | Raised when an item is highlighted using the mouse cursor.
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PinnedChanged | Raised when the Pinned property has changed.
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CvsExpressionTreeView Class
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView Constructor

[image]

In-Sight SDK
CvsExpressionTreeView Constructor
CvsExpressionTreeView Class See Also Send Feedback
Constructs a new instance.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsExpressionTreeView(
    IContainer container
)
Visual Basic
Public Sub New (
    container As IContainer
)

Parameters

container
Type: System.ComponentModel..::..IContainer

[Missing <param name="container"/> documentation for "M:Cognex.InSight.Controls.Display.CvsExpressionTreeView.#ctor(System.ComponentModel.IContainer)"]

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView Methods

[image] [image]

In-Sight SDK
CvsExpressionTreeView Methods
CvsExpressionTreeView Class See Also Send Feedback

The CvsExpressionTreeView type exposes the following members.

Methods

 | Name | Description
Public method | Accept | (Inherited from ToolWindowPanel.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides ToolWindowPanelDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)

See Also

CvsExpressionTreeView Class
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.Dispose Method

[image] [image]

In-Sight SDK
CvsExpressionTreeView..::..Dispose Method
CvsExpressionTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides ToolWindowPanelDispose(Boolean).)

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.Dispose Method (Boolean)

[image]

In-Sight SDK
CvsExpressionTreeView..::..Dispose Method (Boolean)
CvsExpressionTreeView Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: System..::..Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Dispose Overload
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView Properties

[image] [image]

In-Sight SDK
CvsExpressionTreeView Properties
CvsExpressionTreeView Class See Also Send Feedback

The CvsExpressionTreeView type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowedDockState | (Inherited from ToolWindowPanel.)
Public property | AllowToggle | (Inherited from ToolWindowPanel.)
Public property | AlwaysForceVisible | (Inherited from ToolWindowPanel.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CaptionTextID | (Overrides ToolWindowPanelCaptionTextID.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | Closeable | (Inherited from ToolWindowPanel.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Display | Gets or sets a display control to which this tree view is bound.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HighlightLocation | Gets or sets a cell location to be highlighted when it is shown in the tree.
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | (Overrides ToolWindowPanelIcon.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InitiallyVisible | (Inherited from ToolWindowPanel.)
Public property | InitialSite | (Overrides ToolWindowPanelInitialSite.)
Public property | InitialSize | (Inherited from ToolWindowPanel.)
Public property | InSight | Gets or sets the system to which this control is connected.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MouseCellLocation | Gets the cell location of the node under the mouse cursor, or CvsCellLocation.Invalid if the mouse is not over a node.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | Pinned | Gets or sets a value that indicates whether clicking a node should keep the current cell location (pinned) or change to the clicked cell location (unpinned).
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedRange | Gets or sets the range of cells for which dependencies are displayed.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

CvsExpressionTreeView Class
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.CaptionTextID Property

[image]

In-Sight SDK
CvsExpressionTreeView..::..CaptionTextID Property
CvsExpressionTreeView Class See Also Send Feedback

[Missing <summary> documentation for "P:Cognex.InSight.Controls.Display.CvsExpressionTreeView.CaptionTextID"]

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public override string CaptionTextID { get; }
Visual Basic
Public Overrides ReadOnly Property CaptionTextID As String
    Get

Property Value

Type: String

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.Display Property

[image]

In-Sight SDK
CvsExpressionTreeView..::..Display Property
CvsExpressionTreeView Class See Also Send Feedback
Gets or sets a display control to which this tree view is bound.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplay Display { get; set; }
Visual Basic
Public Property Display As CvsInSightDisplay
    Get
    Set

Property Value

Type: CvsInSightDisplay

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.HighlightLocation Property

[image]

In-Sight SDK
CvsExpressionTreeView..::..HighlightLocation Property
CvsExpressionTreeView Class See Also Send Feedback
Gets or sets a cell location to be highlighted when it is shown in the tree.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation HighlightLocation { get; set; }
Visual Basic
Public Property HighlightLocation As CvsCellLocation
    Get
    Set

Property Value

Type: CvsCellLocation

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.Icon Property

[image]

In-Sight SDK
CvsExpressionTreeView..::..Icon Property
CvsExpressionTreeView Class See Also Send Feedback

[Missing <summary> documentation for "P:Cognex.InSight.Controls.Display.CvsExpressionTreeView.Icon"]

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public override int Icon { get; }
Visual Basic
Public Overrides ReadOnly Property Icon As Integer
    Get

Property Value

Type: Int32

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.InitialSite Property

[image]

In-Sight SDK
CvsExpressionTreeView..::..InitialSite Property
CvsExpressionTreeView Class See Also Send Feedback

[Missing <summary> documentation for "P:Cognex.InSight.Controls.Display.CvsExpressionTreeView.InitialSite"]

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public override DockingSite InitialSite { get; }
Visual Basic
Public Overrides ReadOnly Property InitialSite As DockingSite
    Get

Property Value

Type: DockingSite

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.InSight Property

[image]

In-Sight SDK
CvsExpressionTreeView..::..InSight Property
CvsExpressionTreeView Class See Also Send Feedback
Gets or sets the system to which this control is connected.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSight InSight { get; set; }
Visual Basic
Public Property InSight As CvsInSight
    Get
    Set

Property Value

Type: CvsInSight

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.MouseCellLocation Property

[image]

In-Sight SDK
CvsExpressionTreeView..::..MouseCellLocation Property
CvsExpressionTreeView Class See Also Send Feedback
Gets the cell location of the node under the mouse cursor, or CvsCellLocation.Invalid if the mouse is not over a node.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation MouseCellLocation { get; }
Visual Basic
Public ReadOnly Property MouseCellLocation As CvsCellLocation
    Get

Property Value

Type: CvsCellLocation

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.Pinned Property

[image]

In-Sight SDK
CvsExpressionTreeView..::..Pinned Property
CvsExpressionTreeView Class See Also Send Feedback
Gets or sets a value that indicates whether clicking a node should keep the current cell location (pinned) or change to the clicked cell location (unpinned).

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool Pinned { get; set; }
Visual Basic
Public Property Pinned As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.SelectedRange Property

[image]

In-Sight SDK
CvsExpressionTreeView..::..SelectedRange Property
CvsExpressionTreeView Class See Also Send Feedback
Gets or sets the range of cells for which dependencies are displayed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellRange SelectedRange { get; set; }
Visual Basic
Public Property SelectedRange As CvsCellRange
    Get
    Set

Property Value

Type: CvsCellRange

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView Events

[image] [image]

In-Sight SDK
CvsExpressionTreeView Events
CvsExpressionTreeView Class See Also Send Feedback

The CvsExpressionTreeView type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemClick | Raised when the user clicks on an item in the tree.
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseCellLocationChanged | Raised when an item is highlighted using the mouse cursor.
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PinnedChanged | Raised when the Pinned property has changed.
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CvsExpressionTreeView Class
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.ItemClick Event

[image]

In-Sight SDK
CvsExpressionTreeView..::..ItemClick Event
CvsExpressionTreeView Class See Also Send Feedback
Raised when the user clicks on an item in the tree.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event CvsExpressionTreeItemEventHandler ItemClick
Visual Basic
Public Event ItemClick As CvsExpressionTreeItemEventHandler

Value

Type: Cognex.InSight.Controls.Display..::..CvsExpressionTreeItemEventHandler

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.MouseCellLocationChanged Event

[image]

In-Sight SDK
CvsExpressionTreeView..::..MouseCellLocationChanged Event
CvsExpressionTreeView Class See Also Send Feedback
Raised when an item is highlighted using the mouse cursor.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler MouseCellLocationChanged
Visual Basic
Public Event MouseCellLocationChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsExpressionTreeView.PinnedChanged Event

[image]

In-Sight SDK
CvsExpressionTreeView..::..PinnedChanged Event
CvsExpressionTreeView Class See Also Send Feedback
Raised when the Pinned property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler PinnedChanged
Visual Basic
Public Event PinnedChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsExpressionTreeView Class
CvsExpressionTreeView..::..CvsExpressionTreeView Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay Class

[image]

In-Sight SDK
CvsInSightDisplay Class
Members See Also Send Feedback
The CvsInSightDisplay displays images, graphics, and cell data from an In-Sight sensor.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public sealed class CvsInSightDisplay : UserControl,
    ICvsInSightDisplayInternal, IJobViewDisplay, IFindDisplay
Visual Basic
Public NotInheritable Class CvsInSightDisplay
    Inherits UserControl
    Implements ICvsInSightDisplayInternal, IJobViewDisplay, IFindDisplay

Remarks

Call the AcceptUpdate()()()() method after the application has received and processed results from an In-Sight sensor and is ready for new results. If the CvsInSightDisplay is visible and not minimized, this is handled automatically.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
Cognex.InSight.Controls.Display..::..CvsInSightDisplay

See Also

CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay Members

[image] [image]

In-Sight SDK
CvsInSightDisplay Members
CvsInSightDisplay Class Constructors Methods Fields Properties Events See Also Send Feedback

The CvsInSightDisplay type exposes the following members.

Constructors

 | Name | Description
Public method | CvsInSightDisplay | Constructs a new instance of the class.

Methods

 | Name | Description
Public method | AcceptUpdate | Accepts the next update from the sensor.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClickSpreadsheetControl(CvsCellLocation) | Clicks a user control in the spreadsheet. If the control is enabled, the operation associated with the control will occur. For example, for Dialog cells, the user dialog will open.
Public method | ClickSpreadsheetControl(Int32, Int32) | Clicks a user control in the spreadsheet. If the control is enabled, the operation associated with the control will occur. For example, for Dialog cells, the user dialog will open.
Public method | Connect | Attempts to connect to a new In-Sight sensor. If there is an existing connection to the sensor and forceConnect is false, prompts the user whether to forcibly break the other connection.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Ends the connection, if the display is currently connected to an In-Sight sensor.
Public method | DisplayApplicationGraphics | Displays application-defined graphics.
Public method | DisplayPreApplicationGraphics | Displays application-defined graphics prior to the other graphics.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EditCellGraphic(CvsCellLocation) | Begins editing the default graphic associated with the given cell.
Public method | EditCellGraphic(Int32, Int32) | Begins editing the default graphic associated with the given cell.
Public method | EditGraphics(ICvsEditableGraphic) | Switches the display into graphics editing mode and puts the specified graphics on the display for editing.
Public method | EditGraphics(array<ICvsEditableGraphic>[]()[][]) | Switches the display into graphics editing mode and puts the specified graphics on the display for editing.
Public method | EditGraphics(array<ICvsEditableGraphic>[]()[][], Color, Color) | Switches the display into graphics editing mode and puts the specified graphics on the display for editing.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureCellIsVisible(CvsCellLocation) | Ensures that the given cell is visible, scrolling the display if necessary.
Public method | EnsureCellIsVisible(Int32, Int32) | Ensures that the given cell is visible, scrolling the display if necessary.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetBitmap | Gets a Bitmap that represents the contents of the display, excluding the scroll bars.
Public method | GetCellAtPoint | Gets the cell location corresponding to the given point in display pixels.
Public method | GetCellBounds(CvsCellRange) | Gets the bounds of a range of cells.
Public method | GetCellBounds(Int32, Int32, Int32, Int32) | Gets the bounds of a range of cells.
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPicture | Gets an OLE Picture object that represents the contents of the display, excluding the scroll bars.
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GotoCell | Go to a cell safely. This won't change the cell if the user is editing. If a dialog is open the cell will be changed on the dialog however a dialog won't be closed and a new one opened if the cell to go to was on a different dialog. If the cell is on a dialog (e.g. on a row greater than 399) and if the user has permission the entire spread sheet will be displayed and the display will go to that cell.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LoadStandardTheme | Loads the standard theme used by the application. This is different from the default Blue theme.
Public method | OpenPropertySheet(CvsCellLocation, String) | Opens a property sheet to edit a cell.
Public method | OpenPropertySheet(Int32, Int32, String) | Opens a property sheet to edit a cell.
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself. This method also updates the displayed result set from the Results property, and recomputes all internal information used by the control.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | SafeSetFocus | Set focus to the display, if it can receive focus.
Public method | SaveBitmap | Saves an image that represents the contents of the display, excluding the scroll bars. The bitmap will include the image, graphics and grid overlay if enabled by the various properties of the display control.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetCurrentCell | Sets the CurrentCell property.
Public method | SetGridOffset | Sets the GridOffset property.
Public method | SetImageScaleAndOffset | Sets the ImageScale and ImageOffset properties.
Public method | SetSelectedRange | Sets the SelectedRange property.
Public method | SetStatusInformation | Sets the StatusInformation property. Sets a string that represents some extra information that could be displayed about the current state of the display. This is information that could be displayed in the status bar of an application for example.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. This method also updates the displayed result set from the Results property, and updates all internal information used by the control.
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

Fields

Name | Description
ScrollBarWidth | The width of the horizontal and vertical scroll bars, in pixels.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | Action | When set, executes an editing action in the Edit object of the display.
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActualCropScaleMode | Gets the crop/scale mode currently in use. This may differ from PreferredCropScaleMode if the firmware does not support the mode specified by PreferredCropScaleMode or if the display state requires None.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoConnectString | Gets or sets an auto-connection string in the format: HostName, UserName[, Password[, ForceConnect]].
Public property | AutoReconnect | If true, causes the display to automatically attempt to reconnect to the In-Sight sensor when connection is lost due to a network problem or because the display's connection was forcibly broken by another connection. The default value is false.
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CellsClientRectangle | Gets the rectangle in client coordinates in which the cells of the grid may be drawn. Includes the entire drawable cell region even if it's not entirely filled with cells. Excludes the row and column headers and scroll bars.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ClientToSensorTransform | Gets a Matrix that transforms client coordinates into sensor coordinates.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | ConfirmOnlineTransitions | If true, a confirmation of transitions to and from online mode will be requested via a message box. If false, no confirmation will be necessary. The default value is true.
Public property | Connected | Returns true if the display is connected to an In-Sight sensor.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | CurrentCell | Gets or sets the location of the current (active) cell.
Public property | CurrentCellExpression | Gets or sets the expression of the current cell. Can only be set when the State is EditingCellExpression.
Public property | CurrentCellNow | Gets the location of the current cell of the display, or the current cell of the user dialog's display if a user dialog is open.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse is over the control.
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DefaultTextScaleMode | Get and set the global text scaling mode
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Edit | Gets an object that provides the editing actions of the display.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FtpPort | Gets or sets the FTP port used to create FTP connections to sensors.
Public property | GridOffset | Gets or sets the cell location that is displayed in the upper-left corner of the grid. This property is represented by the scroll position of the grid scroll bars.
Public property | GridOpacity | Gets or sets the opacity of the grid background. The valid range is 0.0 (transparent) to 1.0 (opaque).
Public property | GridScale | Gets or sets the scale factor of the grid display. This value is stored in the job, and separate values are maintained for the normal and custom views.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImageOffset | Gets or sets the image pixel location that is displayed in the upper-left corner of the control.
Public property | ImageOrientation | Gets or sets the displayed image orientation.
Public property | ImageScale | Gets or sets the scale factor of the displayed image.
Public property | ImageZoomMode | Gets or sets the automatic zooming mode of the display, which determines whether the image scale factor is automatically adjusted when the display size changes.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InSight | Gets or sets a CvsInSight object to which the display is connected. Use of this property while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed this property will return null and cannot be set.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxUserAccess | Gets or sets the maximum allowed access level of the Classic user. This will not affect any permissions if the connected In-Sight is in Advanced user access mode.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredCropScaleMode | Get and sets the desired crop/scale mode.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Recorder | Gets or sets the object that handles record and playback for the display.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Results | Gets or sets the result set that is currently displayed. Use of this property while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed this property will return null and cannot be set.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | ScrollMode | Determines whether the scroll bars will scroll the image or the grid.
Public property | SelectedRange | Gets or sets the range of cells that are selected. A value of Empty indicates that no cells are selected.
Public property | SensorToClientTransform | Gets a Matrix that transforms sensor coordinates into client coordinates.
Public property | SheetIndex | Gets or sets the sheet index which is associated with this display
Public property | ShiftPartialImage | When set to true, and the sensor is configured to acquire less than the maximum image size, the displayed image will be shifted relative to the portion of the sensor's image that is acquired.
Public property | ShowCustomView | Gets or sets a value that determines whether the custom view is displayed.
Public property | ShowDependencyErrorsOnly | True to display errors only; false to display all dependencies.
Public property | ShowEntireSheet | Gets or sets a value that determines whether the entire sheet (including dialog rows) will be displayed.
Public property | ShowGraphics | Gets or sets a value that determines whether the In-Sight graphics will be displayed.
Public property | ShowGrid | Gets or sets a value that determines whether the grid overlay (cells) will be displayed.
Public property | ShowImage | Gets or sets a value that determines whether the image will be displayed.
Public property | ShowImageSaturation | Gets or sets a value that determines whether saturated areas of the image will be displayed in color.
Public property | ShowScrollBars | Gets or sets a value indicating whether the scroll bars will be displayed.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SnippetPath | Gets and sets the path for snippets. This path will be the initial directory when cells are imported or exported.
Public property | SoftOnline | Gets or sets the soft-online state of the In-Sight sensor.
Public property | State | Gets the current state of the display.
Public property | StatusInformation | Gets a string that represents some extra information that could be displayed about the current state of the display. This is information that could be displayed in the status bar of an application for example.
Public property | StatusInformationState | Gets the type of information contained in the StatusInformation property.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisibleRange | Gets the range of cells that are visible in the display.
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name Description
Public event AutoSizeChanged
Occurs when the AutoSize property changes.
(Inherited from UserControl.)
Public event AutoValidateChanged
Occurs when the AutoValidate property changes.
(Inherited from UserControl.)
Public event BackColorChanged
Occurs when the value of the BackColor property changes.
(Inherited from Control.)
Public event BackgroundImageChanged
Occurs when the value of the BackgroundImage property changes.
(Inherited from Control.)
Public event BackgroundImageLayoutChanged
Occurs when the BackgroundImageLayout property changes.
(Inherited from Control.)
Public event BindingContextChanged
Occurs when the value of the BindingContext property changes.
(Inherited from Control.)
Public event CausesValidationChanged
Occurs when the value of the CausesValidation property changes.
(Inherited from Control.)
Public event ChangeUICues
Occurs when the focus or keyboard user interface (UI) cues change.
(Inherited from Control.)
Public event Click
Occurs when the control is clicked.
(Inherited from Control.)
Public event ClientSizeChanged
Occurs when the value of the ClientSize property changes.
(Inherited from Control.)
Public event ConnectCompleted
The ConnectCompleted event is raised when an asynchronous Connect call has completed. The event arguments indicate whether an exception was generated while attempting the connection.
Public event ConnectedChanged
Raised whenever the Connected property has changed.
Public event ContextMenuChanged
Occurs when the value of the ContextMenu property changes.
(Inherited from Control.)
Public event ContextMenuStripChanged
Occurs when the value of the ContextMenuStrip property changes.
(Inherited from Control.)
Public event ControlAdded
Occurs when a new control is added to the Control..::..ControlCollection.
(Inherited from Control.)
Public event ControlRemoved
Occurs when a control is removed from the Control..::..ControlCollection.
(Inherited from Control.)
Public event CurrentCellChanged
Raised whenever the CurrentCell property has changed.
Public event CurrentCellExpressionChanged
Raised whenever the CurrentCellExpression property has changed.
Public event CurrentCellNowChanged
Raised whenever the CurrentCellNow property has changed.
Public event CursorChanged
Occurs when the value of the Cursor property changes.
(Inherited from Control.)
Public event Disposed
Occurs when the component is disposed by a call to the Dispose()()()() method.
(Inherited from Component.)
Public event DockChanged
Occurs when the value of the Dock property changes.
(Inherited from Control.)
Public event DoubleClick
Occurs when the control is double-clicked.
(Inherited from Control.)
Public event DragDrop
Occurs when a drag-and-drop operation is completed.
(Inherited from Control.)
Public event DragEnter
Occurs when an object is dragged into the control's bounds.
(Inherited from Control.)
Public event DragLeave
Occurs when an object is dragged out of the control's bounds.
(Inherited from Control.)
Public event DragOver
Occurs when an object is dragged over the control's bounds.
(Inherited from Control.)
Public event EditCellExpressionCompleted
This event is raised when the user has finished editing a cell expression.
Public event EditGraphicsCompleted
This event is raised when the user has finished editing the default graphic of a cell, or graphics passed into the EditGraphics(array<ICvsEditableGraphic>[]()[][]) method.
Public event EnabledChanged
Occurs when the Enabled property value has changed.
(Inherited from Control.)
Public event Enter
Occurs when the control is entered.
(Inherited from Control.)
Public event FocusGraphicChanged
Notifies the subscriber that the focused graphic has changed while in graphics editing mode.

Remarks

This event will be raised only when the State property equals EditingGraphics.

The Accept event argument is ignored.

The Value event argument will be the ICvsEditableDisplayGraphic object which currently has focus.

The CellLocation event argument will equal the cell location if the default graphic of a cell was edited, and it will equal Invalid if the EditGraphics(array<ICvsEditableGraphic>[]()[][]) method was called.

This event is not available in COM/ActiveX applications.

Public event FontChanged
Occurs when the Font property value changes.
(Inherited from Control.)
Public event ForeColorChanged
Occurs when the ForeColor property value changes.
(Inherited from Control.)
Public event GiveFeedback
Occurs during a drag operation.
(Inherited from Control.)
Public event GotFocus
Occurs when the control receives focus.
(Inherited from Control.)
Public event GridOffsetChanged
Raised whenever the GridOffset property has changed.
Public event GridOpacityChanged
Raised whenever the GridOpacity property has changed.
Public event GridScaleChanged
Raised whenever the GridScale property has changed.
Public event HandleCreated
Occurs when a handle is created for the control.
(Inherited from Control.)
Public event HandleDestroyed
Occurs when the control's handle is in the process of being destroyed.
(Inherited from Control.)
Public event HelpRequested
Occurs when the user requests help for a control.
(Inherited from Control.)
Public event ImageOffsetChanged
Raised whenever the ImageOffset property has changed.
Public event ImageOrientationChanged
Raised whenever the ImageOrientation property has changed.
Public event ImageScaleChanged
Raised whenever the ImageScale property has changed.
Public event ImeModeChanged
Occurs when the ImeMode property has changed.
(Inherited from Control.)
Public event InSightChanged
Raised whenever the InSight property has changed.
Public event Invalidated
Occurs when a control's display requires redrawing.
(Inherited from Control.)
Public event KeyDown
Occurs when a key is pressed while the control has focus.
(Inherited from Control.)
Public event KeyPress
Occurs when a character. space or backspace key is pressed while the control has focus.
(Inherited from Control.)
Public event KeyUp
Occurs when a key is released while the control has focus.
(Inherited from Control.)
Public event Layout
Occurs when a control should reposition its child controls.
(Inherited from Control.)
Public event Leave
Occurs when the input focus leaves the control.
(Inherited from Control.)
Public event Load
Occurs before the control becomes visible for the first time.
(Inherited from UserControl.)
Public event LocationChanged
Occurs when the Location property value has changed.
(Inherited from Control.)
Public event LostFocus
Occurs when the control loses focus.
(Inherited from Control.)
Public event MarginChanged
Occurs when the control's margin changes.
(Inherited from Control.)
Public event MouseCaptureChanged
Occurs when the control loses mouse capture.
(Inherited from Control.)
Public event MouseClick
Occurs when the control is clicked by the mouse.
(Inherited from Control.)
Public event MouseDoubleClick
Occurs when the control is double clicked by the mouse.
(Inherited from Control.)
Public event MouseDown
Occurs when the mouse pointer is over the control and a mouse button is pressed.
(Inherited from Control.)
Public event MouseEnter
Occurs when the mouse pointer enters the control.
(Inherited from Control.)
Public event MouseHover
Occurs when the mouse pointer rests on the control.
(Inherited from Control.)
Public event MouseLeave
Occurs when the mouse pointer leaves the control.
(Inherited from Control.)
Public event MouseMove
Occurs when the mouse pointer is moved over the control.
(Inherited from Control.)
Public event MouseUp
Occurs when the mouse pointer is over the control and a mouse button is released.
(Inherited from Control.)
Public event MouseWheel
Occurs when the mouse wheel moves while the control has focus.
(Inherited from Control.)
Public event Move
Occurs when the control is moved.
(Inherited from Control.)
Public event PaddingChanged
Occurs when the control's padding changes.
(Inherited from Control.)
Public event Paint
Occurs when the control is redrawn.
(Inherited from Control.)
Public event PaintGraphics
Allows an application to paint custom graphics over the image.
Public event ParentChanged
Occurs when the Parent property value changes.
(Inherited from Control.)
Public event PreviewKeyDown
Occurs before the KeyDown event when a key is pressed while focus is on this control.
(Inherited from Control.)
Public event QueryAccessibilityHelp
Occurs when AccessibleObject is providing help to accessibility applications.
(Inherited from Control.)
Public event QueryContinueDrag
Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
(Inherited from Control.)
Public event RegionChanged
Occurs when the value of the Region property changes.
(Inherited from Control.)
Public event Resize
Occurs when the control is resized.
(Inherited from Control.)
Public event ResultsChanged
Raised whenever the Results property has changed.
Public event RightToLeftChanged
Occurs when the RightToLeft property value changes.
(Inherited from Control.)
Public event Scroll
Occurs when the user or code scrolls through the client area.
(Inherited from ScrollableControl.)
Public event ScrollModeChanged
Raised whenever the ScrollMode property has changed.
Public event SelectedRangeChanged
Raised whenever the SelectedRange property has changed.
Public event ShowGridChanged
Raised whenever the ShowGrid property has changed.
Public event SizeChanged
Occurs when the Size property value changes.
(Inherited from Control.)
Public event StateChanged
Raised whenever the State property has changed.
Public event StatusInformationChanged
Raised whenever the StatusInformation or StatusInformationState property has changed.
Public event StyleChanged
Occurs when the control style changes.
(Inherited from Control.)
Public event SystemColorsChanged
Occurs when the system colors change.
(Inherited from Control.)
Public event TabIndexChanged
Occurs when the TabIndex property value changes.
(Inherited from Control.)
Public event TabStopChanged
Occurs when the TabStop property value changes.
(Inherited from Control.)
Public event TextChanged
Raises the TextChanged event.
(Inherited from UserControl.)
Public event TextScaleModeChanged
Pass the TextScaleModeChanged event handler to the control
Public event Validated
Occurs when the control is finished validating.
(Inherited from Control.)
Public event Validating
Occurs when the control is validating.
(Inherited from Control.)
Public event VisibleChanged
Occurs when the Visible property value changes.
(Inherited from Control.)
Public event VisibleRangeChanged
Raised when the VisibleRange property has changed.

See Also

CvsInSightDisplay Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay Constructor

[image]

In-Sight SDK
CvsInSightDisplay Constructor
CvsInSightDisplay Class See Also Send Feedback
Constructs a new instance of the class.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplay()
Visual Basic
Public Sub New

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay Fields

[image] [image]

In-Sight SDK
CvsInSightDisplay Fields
CvsInSightDisplay Class See Also Send Feedback

The CvsInSightDisplay type exposes the following members.

Fields

Name | Description
ScrollBarWidth | The width of the horizontal and vertical scroll bars, in pixels.

See Also

CvsInSightDisplay Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ScrollBarWidth Field

[image]

In-Sight SDK
CvsInSightDisplay..::..ScrollBarWidth Field
CvsInSightDisplay Class See Also Send Feedback
The width of the horizontal and vertical scroll bars, in pixels.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public const int ScrollBarWidth
Visual Basic
Public Const ScrollBarWidth As Integer

Field Value

Type: Int32

Remarks

This field is not available in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay Methods

[image] [image]

In-Sight SDK
CvsInSightDisplay Methods
CvsInSightDisplay Class See Also Send Feedback

The CvsInSightDisplay type exposes the following members.

Methods

 | Name | Description
Public method | AcceptUpdate | Accepts the next update from the sensor.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClickSpreadsheetControl(CvsCellLocation) | Clicks a user control in the spreadsheet. If the control is enabled, the operation associated with the control will occur. For example, for Dialog cells, the user dialog will open.
Public method | ClickSpreadsheetControl(Int32, Int32) | Clicks a user control in the spreadsheet. If the control is enabled, the operation associated with the control will occur. For example, for Dialog cells, the user dialog will open.
Public method | Connect | Attempts to connect to a new In-Sight sensor. If there is an existing connection to the sensor and forceConnect is false, prompts the user whether to forcibly break the other connection.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Ends the connection, if the display is currently connected to an In-Sight sensor.
Public method | DisplayApplicationGraphics | Displays application-defined graphics.
Public method | DisplayPreApplicationGraphics | Displays application-defined graphics prior to the other graphics.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EditCellGraphic(CvsCellLocation) | Begins editing the default graphic associated with the given cell.
Public method | EditCellGraphic(Int32, Int32) | Begins editing the default graphic associated with the given cell.
Public method | EditGraphics(ICvsEditableGraphic) | Switches the display into graphics editing mode and puts the specified graphics on the display for editing.
Public method | EditGraphics(array<ICvsEditableGraphic>[]()[][]) | Switches the display into graphics editing mode and puts the specified graphics on the display for editing.
Public method | EditGraphics(array<ICvsEditableGraphic>[]()[][], Color, Color) | Switches the display into graphics editing mode and puts the specified graphics on the display for editing.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureCellIsVisible(CvsCellLocation) | Ensures that the given cell is visible, scrolling the display if necessary.
Public method | EnsureCellIsVisible(Int32, Int32) | Ensures that the given cell is visible, scrolling the display if necessary.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetBitmap | Gets a Bitmap that represents the contents of the display, excluding the scroll bars.
Public method | GetCellAtPoint | Gets the cell location corresponding to the given point in display pixels.
Public method | GetCellBounds(CvsCellRange) | Gets the bounds of a range of cells.
Public method | GetCellBounds(Int32, Int32, Int32, Int32) | Gets the bounds of a range of cells.
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPicture | Gets an OLE Picture object that represents the contents of the display, excluding the scroll bars.
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GotoCell | Go to a cell safely. This won't change the cell if the user is editing. If a dialog is open the cell will be changed on the dialog however a dialog won't be closed and a new one opened if the cell to go to was on a different dialog. If the cell is on a dialog (e.g. on a row greater than 399) and if the user has permission the entire spread sheet will be displayed and the display will go to that cell.
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LoadStandardTheme | Loads the standard theme used by the application. This is different from the default Blue theme.
Public method | OpenPropertySheet(CvsCellLocation, String) | Opens a property sheet to edit a cell.
Public method | OpenPropertySheet(Int32, Int32, String) | Opens a property sheet to edit a cell.
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself. This method also updates the displayed result set from the Results property, and recomputes all internal information used by the control.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | SafeSetFocus | Set focus to the display, if it can receive focus.
Public method | SaveBitmap | Saves an image that represents the contents of the display, excluding the scroll bars. The bitmap will include the image, graphics and grid overlay if enabled by the various properties of the display control.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetCurrentCell | Sets the CurrentCell property.
Public method | SetGridOffset | Sets the GridOffset property.
Public method | SetImageScaleAndOffset | Sets the ImageScale and ImageOffset properties.
Public method | SetSelectedRange | Sets the SelectedRange property.
Public method | SetStatusInformation | Sets the StatusInformation property. Sets a string that represents some extra information that could be displayed about the current state of the display. This is information that could be displayed in the status bar of an application for example.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. This method also updates the displayed result set from the Results property, and updates all internal information used by the control.
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

CvsInSightDisplay Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.AcceptUpdate Method

[image]

In-Sight SDK
CvsInSightDisplay..::..AcceptUpdate Method
CvsInSightDisplay Class See Also Send Feedback
Accepts the next update from the sensor.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void AcceptUpdate()
Visual Basic
Public Sub AcceptUpdate

Remarks

AcceptUpdate should be called after the application has received and processed results from an In-Sight sensor and is ready for new results. If the CvsInSightDisplay is visible and is not minimized, this is handled automatically.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ClickSpreadsheetControl Method

[image] [image]

In-Sight SDK
CvsInSightDisplay..::..ClickSpreadsheetControl Method
CvsInSightDisplay Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClickSpreadsheetControl(CvsCellLocation) | Clicks a user control in the spreadsheet. If the control is enabled, the operation associated with the control will occur. For example, for Dialog cells, the user dialog will open.
Public method | ClickSpreadsheetControl(Int32, Int32) | Clicks a user control in the spreadsheet. If the control is enabled, the operation associated with the control will occur. For example, for Dialog cells, the user dialog will open.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ClickSpreadsheetControl Method (CvsCellLocation)

[image]

In-Sight SDK
CvsInSightDisplay..::..ClickSpreadsheetControl Method (CvsCellLocation)
CvsInSightDisplay Class See Also Send Feedback
Clicks a user control in the spreadsheet. If the control is enabled, the operation associated with the control will occur. For example, for Dialog cells, the user dialog will open.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void ClickSpreadsheetControl(
    CvsCellLocation location
)
Visual Basic
Public Sub ClickSpreadsheetControl (
    location As CvsCellLocation
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
ClickSpreadsheetControl Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ClickSpreadsheetControl Method (Int32, Int32)

[image]

In-Sight SDK
CvsInSightDisplay..::..ClickSpreadsheetControl Method (Int32, Int32)
CvsInSightDisplay Class See Also Send Feedback
Clicks a user control in the spreadsheet. If the control is enabled, the operation associated with the control will occur. For example, for Dialog cells, the user dialog will open.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void ClickSpreadsheetControl(
    int row,
    int column
)
Visual Basic
Public Sub ClickSpreadsheetControl (
    row As Integer,
    column As Integer
)

Parameters

row
Type: System..::..Int32
The cell row.
column
Type: System..::..Int32
The cell column.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
ClickSpreadsheetControl Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.Connect Method

[image]

In-Sight SDK
CvsInSightDisplay..::..Connect Method
CvsInSightDisplay Class See Also Send Feedback
Attempts to connect to a new In-Sight sensor. If there is an existing connection to the sensor and forceConnect is false, prompts the user whether to forcibly break the other connection.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Connect(
    string hostName,
    string userName,
    string password,
    bool forceConnect
)
Visual Basic
Public Sub Connect (
    hostName As String,
    userName As String,
    password As String,
    forceConnect As Boolean
)

Parameters

hostName
Type: System..::..String
The DNS name or IP address of the In-Sight sensor.
userName
Type: System..::..String
The user name.
password
Type: System..::..String
The password.
forceConnect
Type: System..::..Boolean
true will forcibly break an existing connection; false will prompt the user whether to break the connection if one already exists. If the existing connection is from the local host, this argument will be ignored and the connection will be forced.

Remarks

This method changes the display's State property to Connecting, raises the StateChanged event, and then returns almost immediately before the connection has been established. The display will then attempt to connect to the In-Sight sensor for up to 30 seconds, after which it will return to the Normal state and the StateChanged event will be raised again. If the connection was successful, the display's Connected property will be true. If the connection fails, the StatusInformation property will indicate the reason that the connection could not be established.

After the State property has returned to Normal and the StateChanged event has been raised, the ConnectCompleted event will be raised. The arguments of this event indicate whether the connection was successful and if was not, what error occurred.

The Disconnect()()()() method can be called to disconnect from the In-Sight sensor. When the display control's Dispose(Boolean) method is called, as happens when a form containing the display is closed, the display control will automatically disconnect from an In-Sight sensor (if currently connected) by calling the Disconnect()()()() method.

This method is similar in functionality to the Connect(IPAddress, String, String, Boolean, Boolean) method of the CvsInSight object. However, the display always connects asynchronously and it handles errors automatically whereas the Connect method of the CvsInSight provides an option to wait until the connection is completed before returning and it requires the caller to handle all error conditions. For applications developed with an In-Sight SDK license, the Connect method of the CvsInSight is an alternative way to connect to a sensor that provides more control to the application at the cost of requiring more error handling.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If the display is already in the Connecting state when this method is called.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace
CvsInSightDisplay..::..AutoConnectString


CvsInSightDisplay.Disconnect Method

[image]

In-Sight SDK
CvsInSightDisplay..::..Disconnect Method
CvsInSightDisplay Class See Also Send Feedback
Ends the connection, if the display is currently connected to an In-Sight sensor.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Disconnect()
Visual Basic
Public Sub Disconnect

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.DisplayApplicationGraphics Method

[image]

In-Sight SDK
CvsInSightDisplay..::..DisplayApplicationGraphics Method
CvsInSightDisplay Class See Also Send Feedback
Displays application-defined graphics.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void DisplayApplicationGraphics(
    CvsGraphic[] graphics
)
Visual Basic
Public Sub DisplayApplicationGraphics (
    graphics As CvsGraphic()
)

Parameters

graphics
Type: array< Cognex.InSight.Graphic..::..CvsGraphic >[]()[][]
An array of one or more application-defined graphics to display, or null to remove all application-defined graphics from the display.

Remarks

This method can be used to display an arbitrary set of graphics together with the graphic objects in the result set. If your application modifies any of the CvsGraphic objects in the array, it should call this method again in order to refresh the contents of the display. Note that this method does not depend on the value of the ShowGraphics property, which only affects the display of graphics received from the In-Sight sensor.

This method is not available in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.DisplayPreApplicationGraphics Method

[image]

In-Sight SDK
CvsInSightDisplay..::..DisplayPreApplicationGraphics Method
CvsInSightDisplay Class See Also Send Feedback
Displays application-defined graphics prior to the other graphics.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void DisplayPreApplicationGraphics(
    CvsGraphic[] graphics
)
Visual Basic
Public Sub DisplayPreApplicationGraphics (
    graphics As CvsGraphic()
)

Parameters

graphics
Type: array< Cognex.InSight.Graphic..::..CvsGraphic >[]()[][]
An array of one or more application-defined graphics to display, or null to remove all application-defined graphics from the display.

Remarks

This method can be used to display an arbitrary set of graphics together with the graphic objects in the result set. If your application modifies any of the CvsGraphic objects in the array, it should call this method again in order to refresh the contents of the display. Note that this method does not depend on the value of the ShowGraphics property, which only affects the display of graphics received from the In-Sight sensor.

This method is not available in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.EditCellGraphic Method

[image] [image]

In-Sight SDK
CvsInSightDisplay..::..EditCellGraphic Method
CvsInSightDisplay Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditCellGraphic(CvsCellLocation) | Begins editing the default graphic associated with the given cell.
Public method | EditCellGraphic(Int32, Int32) | Begins editing the default graphic associated with the given cell.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.EditCellGraphic Method (CvsCellLocation)

[image]

In-Sight SDK
CvsInSightDisplay..::..EditCellGraphic Method (CvsCellLocation)
CvsInSightDisplay Class See Also Send Feedback
Begins editing the default graphic associated with the given cell.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void EditCellGraphic(
    CvsCellLocation location
)
Visual Basic
Public Sub EditCellGraphic (
    location As CvsCellLocation
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.

Remarks

The graphic of a cell that contains an EditAnnulus, EditCircle, EditLine, EditPoint or EditRegion expression may be edited while the sensor is on-line and regardless of the user's access level. The default graphic of other types of cells such as ExtractBlobs may only be edited when the sensor is off-line and when the user has Full (administrator) access.

If the given cell has a graphic that can be edited, this method will change the State property to EditingGraphics while the graphic is being edited, and it will change back to Normal when the user is finished editing the graphic.

This overload of this method is not available in COM/ActiveX applications.

Exceptions

Exception | Condition
System..::..ArgumentException | There is no editable graphic associated with the given location.
System..::..UnauthorizedAccessException | The current user does not have permission to edit graphics.
System..::..ApplicationException | Graphics are already being edited.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
EditCellGraphic Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.EditCellGraphic Method (Int32, Int32)

[image]

In-Sight SDK
CvsInSightDisplay..::..EditCellGraphic Method (Int32, Int32)
CvsInSightDisplay Class See Also Send Feedback
Begins editing the default graphic associated with the given cell.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void EditCellGraphic(
    int row,
    int column
)
Visual Basic
Public Sub EditCellGraphic (
    row As Integer,
    column As Integer
)

Parameters

row
Type: System..::..Int32
The cell row.
column
Type: System..::..Int32
The cell column.

Remarks

A cell may not have an editable graphic until it has been selected as the CurrentCell and a new set of results has been received from the sensor, unless the cell has been configured using the property sheet to display its input graphics all the time.

The graphic of a cell that contains an EditAnnulus, EditCircle, EditLine, EditPoint or EditRegion expression may be edited while the sensor is on-line and regardless of the user's access level. The default graphic of other types of cells such as ExtractBlobs may only be edited when the sensor is off-line and when the user has Full (administrator) access.

If the given cell has a graphic that can be edited, this method will change the State property to EditingGraphics while the graphic is being edited. When editing is completed, the EditGraphicsCompleted event will be raised, and then the State property will change back to Normal.

Exceptions

Exception | Condition
System..::..ArgumentException | The specified cell location does not contain an editable graphic.
System..::..ApplicationException | Graphics are already being edited.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
EditCellGraphic Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.EditGraphics Method

[image] [image]

In-Sight SDK
CvsInSightDisplay..::..EditGraphics Method
CvsInSightDisplay Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditGraphics(ICvsEditableGraphic) | Switches the display into graphics editing mode and puts the specified graphics on the display for editing.
Public method | EditGraphics(array<ICvsEditableGraphic>[]()[][]) | Switches the display into graphics editing mode and puts the specified graphics on the display for editing.
Public method | EditGraphics(array<ICvsEditableGraphic>[]()[][], Color, Color) | Switches the display into graphics editing mode and puts the specified graphics on the display for editing.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.EditGraphics Method (ICvsEditableGraphic)

[image]

In-Sight SDK
CvsInSightDisplay..::..EditGraphics Method (ICvsEditableGraphic)
CvsInSightDisplay Class See Also Send Feedback
Switches the display into graphics editing mode and puts the specified graphics on the display for editing.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void EditGraphics(
    ICvsEditableGraphic graphic
)
Visual Basic
Public Sub EditGraphics (
    graphic As ICvsEditableGraphic
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..ICvsEditableGraphic
The graphic to edit

Remarks

This method will change the State property to EditingGraphics while the graphics are being edited. When editing is completed, the EditGraphicsCompleted event will be raised, and then the State property will change back to Normal.

This method is not available in COM/ActiveX applications.

Exceptions

Exception | Condition
System..::..ApplicationException | Graphics are already being edited.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
EditGraphics Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.EditGraphics Method (ICvsEditableGraphic[])

[image]

In-Sight SDK
CvsInSightDisplay..::..EditGraphics Method (array<ICvsEditableGraphic>[]()[][])
CvsInSightDisplay Class See Also Send Feedback
Switches the display into graphics editing mode and puts the specified graphics on the display for editing.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void EditGraphics(
    ICvsEditableGraphic[] graphics
)
Visual Basic
Public Sub EditGraphics (
    graphics As ICvsEditableGraphic()
)

Parameters

graphics
Type: array< Cognex.InSight.Graphic..::..ICvsEditableGraphic >[]()[][]
The graphics to edit

Remarks

This method will change the State property to EditingGraphics while the graphics are being edited. When editing is completed, the EditGraphicsCompleted event will be raised, and then the State property will change back to Normal.

This method is not available in COM/ActiveX applications.

Exceptions

Exception | Condition
System..::..ApplicationException | Graphics are already being edited.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
EditGraphics Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.EditGraphics Method (ICvsEditableGraphic[], Color, Color)

[image]

In-Sight SDK
CvsInSightDisplay..::..EditGraphics Method (array<ICvsEditableGraphic>[]()[][], Color, Color)
CvsInSightDisplay Class See Also Send Feedback
Switches the display into graphics editing mode and puts the specified graphics on the display for editing.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void EditGraphics(
    ICvsEditableGraphic[] graphics,
    Color selectedColor,
    Color unselectedColor
)
Visual Basic
Public Sub EditGraphics (
    graphics As ICvsEditableGraphic(),
    selectedColor As Color,
    unselectedColor As Color
)

Parameters

graphics
Type: array< Cognex.InSight.Graphic..::..ICvsEditableGraphic >[]()[][]
The graphics to edit
selectedColor
Type: System.Drawing..::..Color
The color to draw selected graphics, or Color.Empty to use the default.
unselectedColor
Type: System.Drawing..::..Color
The color to draw unselected graphics, or Color.Empty to use the default.

Remarks

This method will change the State property to EditingGraphics while the graphics are being edited. When editing is completed, the EditGraphicsCompleted event will be raised, and then the State property will change back to Normal.

This method is not available in COM/ActiveX applications.

Exceptions

Exception | Condition
System..::..ApplicationException | Graphics are already being edited.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
EditGraphics Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.EnsureCellIsVisible Method

[image] [image]

In-Sight SDK
CvsInSightDisplay..::..EnsureCellIsVisible Method
CvsInSightDisplay Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EnsureCellIsVisible(CvsCellLocation) | Ensures that the given cell is visible, scrolling the display if necessary.
Public method | EnsureCellIsVisible(Int32, Int32) | Ensures that the given cell is visible, scrolling the display if necessary.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.EnsureCellIsVisible Method (CvsCellLocation)

[image]

In-Sight SDK
CvsInSightDisplay..::..EnsureCellIsVisible Method (CvsCellLocation)
CvsInSightDisplay Class See Also Send Feedback
Ensures that the given cell is visible, scrolling the display if necessary.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void EnsureCellIsVisible(
    CvsCellLocation location
)
Visual Basic
Public Sub EnsureCellIsVisible (
    location As CvsCellLocation
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.

Remarks

This method will ensure that the given cell location is within the visible range of cells, but it will not un-hide rows or columns so the given location may not be visible if its row or column has been hidden.

This overload of this method is not available in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
EnsureCellIsVisible Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.EnsureCellIsVisible Method (Int32, Int32)

[image]

In-Sight SDK
CvsInSightDisplay..::..EnsureCellIsVisible Method (Int32, Int32)
CvsInSightDisplay Class See Also Send Feedback
Ensures that the given cell is visible, scrolling the display if necessary.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void EnsureCellIsVisible(
    int row,
    int column
)
Visual Basic
Public Sub EnsureCellIsVisible (
    row As Integer,
    column As Integer
)

Parameters

row
Type: System..::..Int32
The cell row.
column
Type: System..::..Int32
The cell column.

Remarks

This method will ensure that the given cell location is within the visible range of cells, but it will not un-hide rows or columns so the given location may not be visible if its row or column has been hidden.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
EnsureCellIsVisible Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.GetBitmap Method

[image]

In-Sight SDK
CvsInSightDisplay..::..GetBitmap Method
CvsInSightDisplay Class See Also Send Feedback
Gets a Bitmap that represents the contents of the display, excluding the scroll bars.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public Bitmap GetBitmap()
Visual Basic
Public Function GetBitmap As Bitmap

Return Value

Type: Bitmap
A newly-created bitmap representing the contents of the display. The bitmap will include the image, graphics and grid overlay if enabled by the various properties of the display control.

Remarks

It is not necessary for the display control to be visible when this method is called. The bitmap that is returned will be equal in size to the pixel size of the display, determined by its Size property, minus the size of the scroll bars if they are visible. The image will be generated from the set of results most recently received from the In-Sight sensor or set using the Results property.

This method is only available in .NET applications. To obtain an OLE Picture object for use in COM/ActiveX applications, use the GetPicture()()()() method instead.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.GetCellAtPoint Method

[image]

In-Sight SDK
CvsInSightDisplay..::..GetCellAtPoint Method
CvsInSightDisplay Class See Also Send Feedback
Gets the cell location corresponding to the given point in display pixels.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation GetCellAtPoint(
    int x,
    int y
)
Visual Basic
Public Function GetCellAtPoint (
    x As Integer,
    y As Integer
) As CvsCellLocation

Parameters

x
Type: System..::..Int32
The X location in display pixels.
y
Type: System..::..Int32
The Y location in display pixels.

Return Value

Type: CvsCellLocation
The cell location corresponding to the given point. If the given point does not correspond to any cell, the IsValid property of the returned location will be false.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.GetCellBounds Method

[image] [image]

In-Sight SDK
CvsInSightDisplay..::..GetCellBounds Method
CvsInSightDisplay Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCellBounds(CvsCellRange) | Gets the bounds of a range of cells.
Public method | GetCellBounds(Int32, Int32, Int32, Int32) | Gets the bounds of a range of cells.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.GetCellBounds Method (CvsCellRange)

[image]

In-Sight SDK
CvsInSightDisplay..::..GetCellBounds Method (CvsCellRange)
CvsInSightDisplay Class See Also Send Feedback
Gets the bounds of a range of cells.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle GetCellBounds(
    CvsCellRange cellRange
)
Visual Basic
Public Function GetCellBounds (
    cellRange As CvsCellRange
) As Rectangle

Parameters

cellRange
Type: Cognex.InSight..::..CvsCellRange
A range of one or more cells.

Return Value

Type: Rectangle
Returns the bounds of the cells in display pixels based on the current display settings, with a position relative to the upper-left corner of the control.

Remarks

The returned rectangle is not clipped to the bounds of the control so it may extend beyond the control's bounds if all or part of the range is outside the visible range of cells. It is up to the caller to clip the rectangle within the bounds of the control if necessary.

This overload of this method is not available in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
GetCellBounds Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.GetCellBounds Method (Int32, Int32, Int32, Int32)

[image]

In-Sight SDK
CvsInSightDisplay..::..GetCellBounds Method (Int32, Int32, Int32, Int32)
CvsInSightDisplay Class See Also Send Feedback
Gets the bounds of a range of cells.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle GetCellBounds(
    int row,
    int column,
    int rows,
    int columns
)
Visual Basic
Public Function GetCellBounds (
    row As Integer,
    column As Integer,
    rows As Integer,
    columns As Integer
) As Rectangle

Parameters

row
Type: System..::..Int32
The starting row.
column
Type: System..::..Int32
The starting column.
rows
Type: System..::..Int32
The number of rows.
columns
Type: System..::..Int32
The number of columns.

Return Value

Type: Rectangle
Returns the bounds of the cells in display pixels based on the current display settings, with a position relative to the upper-left corner of the control.

Remarks

The returned rectangle is not clipped to the bounds of the control so it may extend beyond the control's bounds if all or part of the range is outside the visible range of cells. It is up to the caller to clip the rectangle within the bounds of the control if necessary.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
GetCellBounds Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.GetPicture Method

[image]

In-Sight SDK
CvsInSightDisplay..::..GetPicture Method
CvsInSightDisplay Class See Also Send Feedback
Gets an OLE Picture object that represents the contents of the display, excluding the scroll bars.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public Object GetPicture()
Visual Basic
Public Function GetPicture As Object

Return Value

Type: Object
A newly-created Picture object representing the contents of the display. The bitmap will include the image, graphics and grid overlay if enabled by the various properties of the display control.

Remarks

It is not necessary for the display control to be visible when this method is called. The bitmap that is returned will be equal in size to the pixel size of the display, determined by its Size property, minus the size of the scroll bars if they are visible. The image will be generated from the set of results most recently received from the In-Sight sensor or set using the Results property.

This method is only useful in COM/ActiveX applications. To obtain a Bitmap object for use in .NET applications, use the GetBitmap()()()() method instead.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.GotoCell Method

[image]

In-Sight SDK
CvsInSightDisplay..::..GotoCell Method
CvsInSightDisplay Class See Also Send Feedback
Go to a cell safely. This won't change the cell if the user is editing. If a dialog is open the cell will be changed on the dialog however a dialog won't be closed and a new one opened if the cell to go to was on a different dialog. If the cell is on a dialog (e.g. on a row greater than 399) and if the user has permission the entire spread sheet will be displayed and the display will go to that cell.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void GotoCell(
    CvsCellLocation location
)
Visual Basic
Public Sub GotoCell (
    location As CvsCellLocation
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The requested location. If the location is not accessible the current cell will be changed to the closest location.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.LoadStandardTheme Method

[image]

In-Sight SDK
CvsInSightDisplay..::..LoadStandardTheme Method
CvsInSightDisplay Class See Also Send Feedback
Loads the standard theme used by the application. This is different from the default Blue theme.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void LoadStandardTheme()
Visual Basic
Public Sub LoadStandardTheme

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.OpenPropertySheet Method

[image] [image]

In-Sight SDK
CvsInSightDisplay..::..OpenPropertySheet Method
CvsInSightDisplay Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenPropertySheet(CvsCellLocation, String) | Opens a property sheet to edit a cell.
Public method | OpenPropertySheet(Int32, Int32, String) | Opens a property sheet to edit a cell.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.OpenPropertySheet Method (CvsCellLocation, String)

[image]

In-Sight SDK
CvsInSightDisplay..::..OpenPropertySheet Method (CvsCellLocation, String)
CvsInSightDisplay Class See Also Send Feedback
Opens a property sheet to edit a cell.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void OpenPropertySheet(
    CvsCellLocation location,
    string expression
)
Visual Basic
Public Sub OpenPropertySheet (
    location As CvsCellLocation,
    expression As String
)

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell location for which to open the property sheet.
expression
Type: System..::..String
The new expression to be edited in the property sheet, or null to use the current expression in the cell.

Remarks

This overload of this method is not available in COM/ActiveX applications.

When specifying an expression, pass in the function name. If there is already an expression with the same function in that cell, then that cell's values will be edited. Otherwise, the initial values will be the default values for that function. To specify a cell to edit that does not have the default values for the expression, use InSight.SetExpression to set the expression before calling this method.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
OpenPropertySheet Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.OpenPropertySheet Method (Int32, Int32, String)

[image]

In-Sight SDK
CvsInSightDisplay..::..OpenPropertySheet Method (Int32, Int32, String)
CvsInSightDisplay Class See Also Send Feedback
Opens a property sheet to edit a cell.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void OpenPropertySheet(
    int row,
    int column,
    string expression
)
Visual Basic
Public Sub OpenPropertySheet (
    row As Integer,
    column As Integer,
    expression As String
)

Parameters

row
Type: System..::..Int32
The cell row.
column
Type: System..::..Int32
The cell column.
expression
Type: System..::..String
The new expression to be edited in the property sheet, or null to use the current expression in the cell.

Remarks

COM/ActiveX applications should pass in the empty string to edit the current expression.

When specifying an expression, pass in the function name. If there is already an expression with the same function in that cell, then that cell's values will be edited. Otherwise, the initial values will be the default values for that function. To specify a cell to edit that does not have the default values for the expression, use InSight.SetExpression to set the expression before calling this method.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
OpenPropertySheet Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.Refresh Method

[image]

In-Sight SDK
CvsInSightDisplay..::..Refresh Method
CvsInSightDisplay Class See Also Send Feedback
Forces the control to invalidate its client area and immediately redraw itself. This method also updates the displayed result set from the Results property, and recomputes all internal information used by the control.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Refresh()
Visual Basic
Public Sub Refresh

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.SafeSetFocus Method

[image]

In-Sight SDK
CvsInSightDisplay..::..SafeSetFocus Method
CvsInSightDisplay Class See Also Send Feedback
Set focus to the display, if it can receive focus.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void SafeSetFocus()
Visual Basic
Public Sub SafeSetFocus

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.SaveBitmap Method

[image]

In-Sight SDK
CvsInSightDisplay..::..SaveBitmap Method
CvsInSightDisplay Class See Also Send Feedback
Saves an image that represents the contents of the display, excluding the scroll bars. The bitmap will include the image, graphics and grid overlay if enabled by the various properties of the display control.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void SaveBitmap(
    string fileName
)
Visual Basic
Public Sub SaveBitmap (
    fileName As String
)

Parameters

fileName
Type: System..::..String
The file name to which to save the image.

Remarks

The image that is saved is the same as the image returned by the GetBitmap()()()() and GetPicture()()()() methods. The format of the file is determined by the extension of the given file name, which can be .JPG, .JPEG, .GIF, .TIF, .TIFF or .BMP (not case-sensitive). If the file extension is not recognized, the BMP format is used. To save only the image, see .

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.SetCurrentCell Method

[image]

In-Sight SDK
CvsInSightDisplay..::..SetCurrentCell Method
CvsInSightDisplay Class See Also Send Feedback
Sets the CurrentCell property.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void SetCurrentCell(
    int row,
    int column
)
Visual Basic
Public Sub SetCurrentCell (
    row As Integer,
    column As Integer
)

Parameters

row
Type: System..::..Int32
The row number.
column
Type: System..::..Int32
The column number.

Remarks

This is the preferred way to set the CurrentCell property in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.SetGridOffset Method

[image]

In-Sight SDK
CvsInSightDisplay..::..SetGridOffset Method
CvsInSightDisplay Class See Also Send Feedback
Sets the GridOffset property.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void SetGridOffset(
    int row,
    int column
)
Visual Basic
Public Sub SetGridOffset (
    row As Integer,
    column As Integer
)

Parameters

row
Type: System..::..Int32
The row number.
column
Type: System..::..Int32
The column number.

Remarks

This is the preferred way to set the GridOffset property in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.SetImageScaleAndOffset Method

[image]

In-Sight SDK
CvsInSightDisplay..::..SetImageScaleAndOffset Method
CvsInSightDisplay Class See Also Send Feedback
Sets the ImageScale and ImageOffset properties.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void SetImageScaleAndOffset(
    double scale,
    float x,
    float y
)
Visual Basic
Public Sub SetImageScaleAndOffset (
    scale As Double,
    x As Single,
    y As Single
)

Parameters

scale
Type: System..::..Double
The image scale.
x
Type: System..::..Single
The horizontal offset.
y
Type: System..::..Single
The vertical offset.

Remarks

Calling this method will also set the ImageZoomMode property to None.

This is the preferred way to set the ImageOffset property in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.SetSelectedRange Method

[image]

In-Sight SDK
CvsInSightDisplay..::..SetSelectedRange Method
CvsInSightDisplay Class See Also Send Feedback
Sets the SelectedRange property.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void SetSelectedRange(
    int row,
    int column,
    int rows,
    int columns
)
Visual Basic
Public Sub SetSelectedRange (
    row As Integer,
    column As Integer,
    rows As Integer,
    columns As Integer
)

Parameters

row
Type: System..::..Int32
The starting row number.
column
Type: System..::..Int32
The starting column number.
rows
Type: System..::..Int32
The number of rows selected.
columns
Type: System..::..Int32
The number of columns selected.

Remarks

This is the preferred method for setting the SelectedRange property in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.SetStatusInformation Method

[image]

In-Sight SDK
CvsInSightDisplay..::..SetStatusInformation Method
CvsInSightDisplay Class See Also Send Feedback
Sets the StatusInformation property.

Sets a string that represents some extra information that could be displayed about the current state of the display. This is information that could be displayed in the status bar of an application for example.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void SetStatusInformation(
    string value,
    CvsStatusInformationState state
)
Visual Basic
Public Sub SetStatusInformation (
    value As String,
    state As CvsStatusInformationState
)

Parameters

value
Type: System..::..String
The text to display.
state
Type: Cognex.InSight.Controls.Display..::..CvsStatusInformationState
Classifies the text as a warning or error, for example.

Remarks

When this property is changed, the StatusInformationChanged event is raised.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace
CvsInSightDisplay..::..StatusInformation
CvsInSightDisplay..::..StatusInformationState


CvsInSightDisplay.Update Method

[image]

In-Sight SDK
CvsInSightDisplay..::..Update Method
CvsInSightDisplay Class See Also Send Feedback
Causes the control to redraw the invalidated regions within its client area. This method also updates the displayed result set from the Results property, and updates all internal information used by the control.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Update()
Visual Basic
Public Sub Update

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay Properties

[image] [image]

In-Sight SDK
CvsInSightDisplay Properties
CvsInSightDisplay Class See Also Send Feedback

The CvsInSightDisplay type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | Action | When set, executes an editing action in the Edit object of the display.
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActualCropScaleMode | Gets the crop/scale mode currently in use. This may differ from PreferredCropScaleMode if the firmware does not support the mode specified by PreferredCropScaleMode or if the display state requires None.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoConnectString | Gets or sets an auto-connection string in the format: HostName, UserName[, Password[, ForceConnect]].
Public property | AutoReconnect | If true, causes the display to automatically attempt to reconnect to the In-Sight sensor when connection is lost due to a network problem or because the display's connection was forcibly broken by another connection. The default value is false.
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CellsClientRectangle | Gets the rectangle in client coordinates in which the cells of the grid may be drawn. Includes the entire drawable cell region even if it's not entirely filled with cells. Excludes the row and column headers and scroll bars.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ClientToSensorTransform | Gets a Matrix that transforms client coordinates into sensor coordinates.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | ConfirmOnlineTransitions | If true, a confirmation of transitions to and from online mode will be requested via a message box. If false, no confirmation will be necessary. The default value is true.
Public property | Connected | Returns true if the display is connected to an In-Sight sensor.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | CurrentCell | Gets or sets the location of the current (active) cell.
Public property | CurrentCellExpression | Gets or sets the expression of the current cell. Can only be set when the State is EditingCellExpression.
Public property | CurrentCellNow | Gets the location of the current cell of the display, or the current cell of the user dialog's display if a user dialog is open.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse is over the control.
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DefaultTextScaleMode | Get and set the global text scaling mode
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Edit | Gets an object that provides the editing actions of the display.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FtpPort | Gets or sets the FTP port used to create FTP connections to sensors.
Public property | GridOffset | Gets or sets the cell location that is displayed in the upper-left corner of the grid. This property is represented by the scroll position of the grid scroll bars.
Public property | GridOpacity | Gets or sets the opacity of the grid background. The valid range is 0.0 (transparent) to 1.0 (opaque).
Public property | GridScale | Gets or sets the scale factor of the grid display. This value is stored in the job, and separate values are maintained for the normal and custom views.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImageOffset | Gets or sets the image pixel location that is displayed in the upper-left corner of the control.
Public property | ImageOrientation | Gets or sets the displayed image orientation.
Public property | ImageScale | Gets or sets the scale factor of the displayed image.
Public property | ImageZoomMode | Gets or sets the automatic zooming mode of the display, which determines whether the image scale factor is automatically adjusted when the display size changes.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InSight | Gets or sets a CvsInSight object to which the display is connected. Use of this property while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed this property will return null and cannot be set.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxUserAccess | Gets or sets the maximum allowed access level of the Classic user. This will not affect any permissions if the connected In-Sight is in Advanced user access mode.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredCropScaleMode | Get and sets the desired crop/scale mode.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Recorder | Gets or sets the object that handles record and playback for the display.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Results | Gets or sets the result set that is currently displayed. Use of this property while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed this property will return null and cannot be set.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | ScrollMode | Determines whether the scroll bars will scroll the image or the grid.
Public property | SelectedRange | Gets or sets the range of cells that are selected. A value of Empty indicates that no cells are selected.
Public property | SensorToClientTransform | Gets a Matrix that transforms sensor coordinates into client coordinates.
Public property | SheetIndex | Gets or sets the sheet index which is associated with this display
Public property | ShiftPartialImage | When set to true, and the sensor is configured to acquire less than the maximum image size, the displayed image will be shifted relative to the portion of the sensor's image that is acquired.
Public property | ShowCustomView | Gets or sets a value that determines whether the custom view is displayed.
Public property | ShowDependencyErrorsOnly | True to display errors only; false to display all dependencies.
Public property | ShowEntireSheet | Gets or sets a value that determines whether the entire sheet (including dialog rows) will be displayed.
Public property | ShowGraphics | Gets or sets a value that determines whether the In-Sight graphics will be displayed.
Public property | ShowGrid | Gets or sets a value that determines whether the grid overlay (cells) will be displayed.
Public property | ShowImage | Gets or sets a value that determines whether the image will be displayed.
Public property | ShowImageSaturation | Gets or sets a value that determines whether saturated areas of the image will be displayed in color.
Public property | ShowScrollBars | Gets or sets a value indicating whether the scroll bars will be displayed.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SnippetPath | Gets and sets the path for snippets. This path will be the initial directory when cells are imported or exported.
Public property | SoftOnline | Gets or sets the soft-online state of the In-Sight sensor.
Public property | State | Gets the current state of the display.
Public property | StatusInformation | Gets a string that represents some extra information that could be displayed about the current state of the display. This is information that could be displayed in the status bar of an application for example.
Public property | StatusInformationState | Gets the type of information contained in the StatusInformation property.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisibleRange | Gets the range of cells that are visible in the display.
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

CvsInSightDisplay Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.Action Property

[image]

In-Sight SDK
CvsInSightDisplay..::..Action Property
CvsInSightDisplay Class Example See Also Send Feedback
When set, executes an editing action in the Edit object of the display.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string Action { get; set; }
Visual Basic
Public Property Action As String
    Get
    Set

Property Value

Type: String

Remarks

This property is intended for use in HMI design environments where it is not possible or practical to call methods of the Edit object directly. When this property is set to the name of a property of the Edit object that returns a CvsAction or CvsActionToggle object, it will call the action's Execute method if it is enabled. Refer to the properties of the CvsInSightDisplayEdit class for the complete list of actions that are available. This property is not case-sensitive.

After setting this property to the name of an editing action, reading the property will return the name of the action if it was enabled and executed. If the action was disabled, reading the property will return null (or an empty string in COM/ActiveX environments). This makes it possible for the application to determine whether the action executed successfully or not. The property can be set to null or an empty string in order to clear it out.

For editing actions that are of type CvsActionToggle this property can be set simply to the name of the action in order to toggle the action's Activated state, or it can be set to the name of the action followed by an equals sign (=) and a value to explicitly set the Activated state. A value of false or 0 will set the Activated state to false, and a value of true, 1 or -1 will set the Activated state to true. Any other value will result in an ArgumentException. Spaces are ignored and upper/lower case does not matter.

Examples

The following example illustrates how to open the Save Job As dialog by setting this property in Visual Basic:

Copy image Copy
CvsInSightDisplay1.Action = "SaveJobAs"
If CvsInSightDisplay1.Action = "SaveJobAs" Then
  ' The action was enabled and the Save As dialog is open
Else
  ' The action was disabled and nothing happened
End If

Examples

The following example illustrates how to turn live acquisition on and off by setting this property in Visual Basic:

Copy image Copy
CvsInSightDisplay1.Action = "LiveAcquire=1"
CvsInSightDisplay1.Action = "LiveAcquire=0"

Exceptions

Exception | Condition
System..::..MissingMemberException | If the property is set to a value (other than null or an empty string) that is not the name of a public property of the CvsInSightDisplayEdit class that returns a CvsAction or CvsActionToggle object.
System..::..ArgumentException | If the property is set to a value that contains an equals sign, and the given action name is not a CvsActionToggle or the remainder of the string is not a valid value as specified above.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ActualCropScaleMode Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ActualCropScaleMode Property
CvsInSightDisplay Class See Also Send Feedback
Gets the crop/scale mode currently in use. This may differ from PreferredCropScaleMode if the firmware does not support the mode specified by PreferredCropScaleMode or if the display state requires None.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplayCropScaleMode ActualCropScaleMode { get; }
Visual Basic
Public ReadOnly Property ActualCropScaleMode As CvsInSightDisplayCropScaleMode
    Get

Property Value

Type: CvsInSightDisplayCropScaleMode

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace
CvsInSightDisplay..::..PreferredCropScaleMode


CvsInSightDisplay.AutoConnectString Property

[image]

In-Sight SDK
CvsInSightDisplay..::..AutoConnectString Property
CvsInSightDisplay Class Example See Also Send Feedback
Gets or sets an auto-connection string in the format: HostName, UserName[, Password[, ForceConnect]].

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string AutoConnectString { get; set; }
Visual Basic
Public Property AutoConnectString As String
    Get
    Set

Property Value

Type: String

Remarks

This property provides a simple way to connect to an In-Sight sensor while using the control in a design environment without writing any code. Application code developers may find it easier to call the Connect method directly instead of setting this property, but either approach is acceptable. The parts of this string are the same as the parameters to the Connect method and when this string is set to a valid host name, user name and password, the display will automatically connect to the specified In-Sight sensor using its Connect method.

The HostName part of the string can be either the DNS name or the IP address of an In-Sight sensor.

The ForceConnect option specifies whether to break any existing connection to the sensor from another application. If not specified, it defaults to true. If false, and there is an existing connection, the user will be prompted whether to break the existing connection or not. This part of the string can be 0, 1, false or true.

If the string appears to be valid but the connection cannot be established, the display remains disconnected and no exception is thrown.

Examples

In order to connect to a sensor when the control is used in a design environment, open the property page for the control and set the AutoConnectString to a string containing the IP address of the sensor and the username and (optionally) a password. The following example connects to the IP address of the emulator, which is normally available while In-Sight Explorer is running.
Copy image Copy
127.0.0.1,admin

Exceptions

Exception | Condition
System..::..ArgumentException | If the format of the string is invalid.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace
CvsInSightDisplay..::..Connect(String, String, String, Boolean)


CvsInSightDisplay.AutoReconnect Property

[image]

In-Sight SDK
CvsInSightDisplay..::..AutoReconnect Property
CvsInSightDisplay Class See Also Send Feedback
If true, causes the display to automatically attempt to reconnect to the In-Sight sensor when connection is lost due to a network problem or because the display's connection was forcibly broken by another connection. The default value is false.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool AutoReconnect { get; set; }
Visual Basic
Public Property AutoReconnect As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

If this property is false when the connection to an In-Sight sensor is lost, the display control will not attempt to reconnect. However if this property is later changed to true, the display will attempt to reconnect at that time.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.CellsClientRectangle Property

[image]

In-Sight SDK
CvsInSightDisplay..::..CellsClientRectangle Property
CvsInSightDisplay Class See Also Send Feedback
Gets the rectangle in client coordinates in which the cells of the grid may be drawn. Includes the entire drawable cell region even if it's not entirely filled with cells. Excludes the row and column headers and scroll bars.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle CellsClientRectangle { get; }
Visual Basic
Public ReadOnly Property CellsClientRectangle As Rectangle
    Get

Property Value

Type: Rectangle

Remarks

This property is not available in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ClientToSensorTransform Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ClientToSensorTransform Property
CvsInSightDisplay Class See Also Send Feedback
Gets a Matrix that transforms client coordinates into sensor coordinates.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public Matrix ClientToSensorTransform { get; }
Visual Basic
Public ReadOnly Property ClientToSensorTransform As Matrix
    Get

Property Value

Type: Matrix

Remarks

This property is not available in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ConfirmOnlineTransitions Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ConfirmOnlineTransitions Property
CvsInSightDisplay Class See Also Send Feedback
If true, a confirmation of transitions to and from online mode will be requested via a message box. If false, no confirmation will be necessary. The default value is true.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ConfirmOnlineTransitions { get; set; }
Visual Basic
Public Property ConfirmOnlineTransitions As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.Connected Property

[image]

In-Sight SDK
CvsInSightDisplay..::..Connected Property
CvsInSightDisplay Class See Also Send Feedback
Returns true if the display is connected to an In-Sight sensor.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool Connected { get; }
Visual Basic
Public ReadOnly Property Connected As Boolean
    Get

Property Value

Type: Boolean

Remarks

When this property is changed, the ConnectedChanged event is raised.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.CurrentCell Property

[image]

In-Sight SDK
CvsInSightDisplay..::..CurrentCell Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the location of the current (active) cell.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation CurrentCell { get; set; }
Visual Basic
Public Property CurrentCell As CvsCellLocation
    Get
    Set

Property Value

Type: CvsCellLocation

Remarks

If this property is set to a value outside the active range of cells, it will be limited to within the active range and no exception will be thrown. If this property is set to a value outside the SelectedRange property, the SelectedRange will also be changed to include only the new CurrentCell.

When this property is changed, either programmatically or via user interaction, the CurrentCellChanged event is raised.

This property can also be set using the SetCurrentCell(Int32, Int32) method, which is the preferred method for COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.CurrentCellExpression Property

[image]

In-Sight SDK
CvsInSightDisplay..::..CurrentCellExpression Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the expression of the current cell. Can only be set when the State is EditingCellExpression.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string CurrentCellExpression { get; set; }
Visual Basic
Public Property CurrentCellExpression As String
    Get
    Set

Property Value

Type: String

Remarks

The CurrentCellExpressionChanged event will be raised whenever this property changes. When the user is editing the expression in the current cell, for example when the State of the display is EditingCellExpression, this property will reflect the user's changes immediately but the edited expression is not sent to the In-Sight sensor until the user accepts the changes. The expression will revert to its previous value if the user cancels the changes.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If the property is set when the State is not EditingCellExpression.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.CurrentCellNow Property

[image]

In-Sight SDK
CvsInSightDisplay..::..CurrentCellNow Property
CvsInSightDisplay Class See Also Send Feedback
Gets the location of the current cell of the display, or the current cell of the user dialog's display if a user dialog is open.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation CurrentCellNow { get; }
Visual Basic
Public ReadOnly Property CurrentCellNow As CvsCellLocation
    Get

Property Value

Type: CvsCellLocation

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.Cursor Property

[image]

In-Sight SDK
CvsInSightDisplay..::..Cursor Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the cursor that is displayed when the mouse is over the control.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public Cursor Cursor { get; set; }
Visual Basic
Public Property Cursor As Cursor
    Get
    Set

Property Value

Type: Cursor

Remarks

This property always returns the actual cursor that is shown. Normally an application does not need to set this property, and the control will manage the cursor automatically based on the position of the mouse and the current state of the display.

An application can explicitly set this property in order to override the automatically-selected cursor. In this case the Cursor set by the application will remain in effect regardless of the state of the display. Setting this property to null will revert to the automatically-selected cursor.

This property is not available in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.DefaultTextScaleMode Property

[image]

In-Sight SDK
CvsInSightDisplay..::..DefaultTextScaleMode Property
CvsInSightDisplay Class See Also Send Feedback
Get and set the global text scaling mode

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplay..::..TextScaleModeType DefaultTextScaleMode { get; set; }
Visual Basic
Public Property DefaultTextScaleMode As CvsInSightDisplay..::..TextScaleModeType
    Get
    Set

Property Value

Type: CvsInSightDisplay..::..TextScaleModeType

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.Edit Property

[image]

In-Sight SDK
CvsInSightDisplay..::..Edit Property
CvsInSightDisplay Class See Also Send Feedback
Gets an object that provides the editing actions of the display.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplayEdit Edit { get; }
Visual Basic
Public ReadOnly Property Edit As CvsInSightDisplayEdit
    Get

Property Value

Type: CvsInSightDisplayEdit

Remarks

Refer to the CvsInSightDisplayEdit class documentation for examples of using this property.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.FtpPort Property

[image]

In-Sight SDK
CvsInSightDisplay..::..FtpPort Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the FTP port used to create FTP connections to sensors.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int FtpPort { get; set; }
Visual Basic
Public Property FtpPort As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.GridOffset Property

[image]

In-Sight SDK
CvsInSightDisplay..::..GridOffset Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the cell location that is displayed in the upper-left corner of the grid. This property is represented by the scroll position of the grid scroll bars.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation GridOffset { get; set; }
Visual Basic
Public Property GridOffset As CvsCellLocation
    Get
    Set

Property Value

Type: CvsCellLocation

Remarks

If this property is set to a location that is outside the valid range of rows and columns for the current view, it will be limited to within the valid range and no exception will be thrown. If it is set to a location that is within a hidden row or column, it will be set to the next-visible row and/or column and no exception will be thrown.

This property can also be set using the SetGridOffset(Int32, Int32) method, which is the preferred method for COM/ActiveX applications.

When this property is changed, the GridOffsetChanged event is raised.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace
CvsInSightDisplay..::..ImageOffset
CvsInSightDisplay..::..ImageScale


CvsInSightDisplay.GridOpacity Property

[image]

In-Sight SDK
CvsInSightDisplay..::..GridOpacity Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the opacity of the grid background. The valid range is 0.0 (transparent) to 1.0 (opaque).

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public double GridOpacity { get; set; }
Visual Basic
Public Property GridOpacity As Double
    Get
    Set

Property Value

Type: Double

Remarks

This property is similar to the Opacity property of the Form class, and determines whether the grid background is opaque or allows the image and graphics to show through. If this property is set to a value outside the valid range of 0.0 to 1.0, it will be limited to within the valid range and no exception will be thrown.

When this property is changed, the GridOpacityChanged event will be raised.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.GridScale Property

[image]

In-Sight SDK
CvsInSightDisplay..::..GridScale Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the scale factor of the grid display. This value is stored in the job, and separate values are maintained for the normal and custom views.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public double GridScale { get; set; }
Visual Basic
Public Property GridScale As Double
    Get
    Set

Property Value

Type: Double

Remarks

A value of 1.0 designates the normal 1:1 grid display. Larger value will proportionally zoom in on the grid. Smaller values will zoom out. The valid range of this property is 0.1 to 4.0. If it is set to a value outside the valid range, the value will be limited to within the valid range and no exception will be thrown.

Whenever this property changes, the GridScaleChanged event is raised. If this property is set while the custom view is on display, the custom view will be automatically resized to fit based on the new grid scale.

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace
CvsInSightDisplay..::..ImageOffset
CvsInSightDisplay..::..ImageScale


CvsInSightDisplay.ImageOffset Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ImageOffset Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the image pixel location that is displayed in the upper-left corner of the control.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public PointF ImageOffset { get; set; }
Visual Basic
Public Property ImageOffset As PointF
    Get
    Set

Property Value

Type: PointF

Remarks

The ImageOffset is automatically adjusted whenever it is set and whenever the control is resized or scrolled, so that the maximum portion of the image remains visible. If the display is larger horizontally and/or vertically than the displayed image size, the ImageOffset will be fixed horizontally and/or vertically so that the image remains centered in the visible area.

Setting this property will also set the ImageZoomMode property to None.

This property can also be set using the SetImageScaleAndOffset(Double, Single, Single) method, which is the preferred method for COM/ActiveX applications.

When this property is changed, the ImageOffsetChanged event is raised.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace
CvsInSightDisplay..::..GridOffset
CvsInSightDisplay..::..GridScale


CvsInSightDisplay.ImageOrientation Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ImageOrientation Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the displayed image orientation.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageOrientation ImageOrientation { get; set; }
Visual Basic
Public Property ImageOrientation As CvsImageOrientation
    Get
    Set

Property Value

Type: CvsImageOrientation

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ImageScale Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ImageScale Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the scale factor of the displayed image.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public double ImageScale { get; set; }
Visual Basic
Public Property ImageScale As Double
    Get
    Set

Property Value

Type: Double

Remarks

1.0 designates the normal 1:1 display of the image. Larger value will proportionally zoom in on the image. Smaller values will zoom out.

Setting this property will also set the ImageZoomMode property to None.

This property can also be set using the SetImageScaleAndOffset(Double, Single, Single) method.

When this property is changed, the ImageScaleChanged event is raised.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | If the property is set to a non-positive number.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace
CvsInSightDisplay..::..GridOffset
CvsInSightDisplay..::..GridScale


CvsInSightDisplay.ImageZoomMode Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ImageZoomMode Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the automatic zooming mode of the display, which determines whether the image scale factor is automatically adjusted when the display size changes.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsDisplayZoom ImageZoomMode { get; set; }
Visual Basic
Public Property ImageZoomMode As CvsDisplayZoom
    Get
    Set

Property Value

Type: CvsDisplayZoom

Remarks

If this property is set to Fit, the display will automatically set the ImageOffset and ImageScale properties so that the entire image just fits within the display, possibly showing blank areas along the top and bottom or right and left edges of the display.

If this property is set to Fill, the display will automatically set the ImageScale property so that the entire image just fills the display, possibly hiding some image pixels along the top and bottom or right and left edges of the display.

If this property is set to None the application can control the zooming of the image using the ImageScale and ImageOffset properties, and the image can be zoomed in and out using the ZoomImageIn, ZoomImageOut, ZoomImage1To1 and ZoomImageToMax editing actions if they are enabled. The ZoomImageToFit editing action will toggle this property between None and Fit. The ZoomImageToFill editing action will toggle this property between None and Fill.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace
CvsInSightDisplay..::..SetImageScaleAndOffset(Double, Single, Single)
CvsInSightDisplay..::..GridOffset
CvsInSightDisplay..::..GridScale


CvsInSightDisplay.InSight Property

[image]

In-Sight SDK
CvsInSightDisplay..::..InSight Property
CvsInSightDisplay Class Example See Also Send Feedback
Gets or sets a CvsInSight object to which the display is connected. Use of this property while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed this property will return null and cannot be set.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSight InSight { get; set; }
Visual Basic
Public Property InSight As CvsInSight
    Get
    Set

Property Value

Type: CvsInSight

Remarks

By default this property is set to a new CvsInSight object, which can be connected to an In-Sight sensor using its Connect(IPAddress, String, String, Boolean, Boolean) method.

When the display control's Dispose(Boolean) method is called, as happens when a form containing the display is closed, the display control will automatically disconnect from an In-Sight sensor (if currently connected) by calling its Dispose()()()() method. If this behavior is not desired, set this property to null before the display is disposed.

When this property has changed to a new CvsInSight object, the InSightChanged event is raised. This will happen while the display is connecting to a sensor using its Connect method or when the AutoConnectString property is set.

Examples

This VB.NET example shows how to connect the display control to a CvsInSight object that has been previously created by the application.
Copy image Copy
Set cvsInSightDisplay1.InSight = myInSight

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.MaxUserAccess Property

[image]

In-Sight SDK
CvsInSightDisplay..::..MaxUserAccess Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the maximum allowed access level of the Classic user. This will not affect any permissions if the connected In-Sight is in Advanced user access mode.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightSecurityAccess MaxUserAccess { get; set; }
Visual Basic
Public Property MaxUserAccess As CvsInSightSecurityAccess
    Get
    Set

Property Value

Type: CvsInSightSecurityAccess

Remarks

This property exists for compatibility when in Classic user access mode. This allows an application to connect to a sensor with full administrative access in order to use the methods of the CvsInSight object but restrict the operations that the user can perform interactively using the display control. The default value of this property is Full, meaning that the user's access is determined solely by the sensor's access setting for the current user name.

Changing this property while the user editing a cell's expression or value will accept any changes that were made and return the display to the normal state.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.PreferredCropScaleMode Property

[image]

In-Sight SDK
CvsInSightDisplay..::..PreferredCropScaleMode Property
CvsInSightDisplay Class See Also Send Feedback
Get and sets the desired crop/scale mode.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplayCropScaleMode PreferredCropScaleMode { get; set; }
Visual Basic
Public Property PreferredCropScaleMode As CvsInSightDisplayCropScaleMode
    Get
    Set

Property Value

Type: CvsInSightDisplayCropScaleMode

Remarks

In certain cases, such as when recording, the requested value will be ignored and None will be used.

If the firmware does not support the requested value, then this value will be ignored and None will be used.

Other image quality options may also affect the image.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace
CvsSettings..::..LiveAcquisitionResolution
CvsSettings..::..OnlineImageResolution
CvsInSightDisplay..::..ActualCropScaleMode


CvsInSightDisplay.Recorder Property

[image]

In-Sight SDK
CvsInSightDisplay..::..Recorder Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the object that handles record and playback for the display.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplayRecorder Recorder { get; set; }
Visual Basic
Public Property Recorder As CvsInSightDisplayRecorder
    Get
    Set

Property Value

Type: CvsInSightDisplayRecorder

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.Results Property

[image]

In-Sight SDK
CvsInSightDisplay..::..Results Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the result set that is currently displayed. Use of this property while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed this property will return null and cannot be set.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsResultSet Results { get; set; }
Visual Basic
Public Property Results As CvsResultSet
    Get
    Set

Property Value

Type: CvsResultSet

Remarks

The CvsResultSet object contains the image, graphics, cell data and job information that is needed in order to render the display. An application can store CvsResultSet objects obtained from this property while the display is connected to a sensor in order to record inspection results for future reference. When the display is not connected to a sensor, an application can assign a stored CvsResultSet object to this property in order to display results of previous inspections.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If this property is set while the display is connected to a sensor.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ScrollMode Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ScrollMode Property
CvsInSightDisplay Class See Also Send Feedback
Determines whether the scroll bars will scroll the image or the grid.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsDisplayScrollMode ScrollMode { get; set; }
Visual Basic
Public Property ScrollMode As CvsDisplayScrollMode
    Get
    Set

Property Value

Type: CvsDisplayScrollMode

Remarks

When this property is changed, the ScrollModeChanged event is raised.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.SelectedRange Property

[image]

In-Sight SDK
CvsInSightDisplay..::..SelectedRange Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the range of cells that are selected. A value of Empty indicates that no cells are selected.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellRange SelectedRange { get; set; }
Visual Basic
Public Property SelectedRange As CvsCellRange
    Get
    Set

Property Value

Type: CvsCellRange

Remarks

If this property is set to a value outside the active range of cells, it will be limited to within the active range and no exception will be thrown. Whenever this property is changed, either programmatically or via user interaction, the SelectedRangeChanged event will be raised. Often when this property is changed, the CurrentCell property is changed also.

This property can also be set using the SetSelectedRange(Int32, Int32, Int32, Int32) method, which is the preferred method for COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.SensorToClientTransform Property

[image]

In-Sight SDK
CvsInSightDisplay..::..SensorToClientTransform Property
CvsInSightDisplay Class See Also Send Feedback
Gets a Matrix that transforms sensor coordinates into client coordinates.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public Matrix SensorToClientTransform { get; }
Visual Basic
Public ReadOnly Property SensorToClientTransform As Matrix
    Get

Property Value

Type: Matrix

Remarks

This property is not available in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.SheetIndex Property

[image]

In-Sight SDK
CvsInSightDisplay..::..SheetIndex Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the sheet index which is associated with this display

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int SheetIndex { get; set; }
Visual Basic
Public Property SheetIndex As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ShiftPartialImage Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ShiftPartialImage Property
CvsInSightDisplay Class See Also Send Feedback
When set to true, and the sensor is configured to acquire less than the maximum image size, the displayed image will be shifted relative to the portion of the sensor's image that is acquired.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ShiftPartialImage { get; set; }
Visual Basic
Public Property ShiftPartialImage As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

By default this property is false, and the display will center the Acquired image based on the actual number of lines acquired. This is the behavior seen in In-Sight Explorer 3.1 and later. If this property is set to true the display calculates the center position of the image based on the maximum acquired image size of the sensor, and if the job is configured to acquire only a portion of the maximum size then the displayed pixels will be shifted accordingly.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ShowCustomView Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ShowCustomView Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets a value that determines whether the custom view is displayed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowCustomView { get; set; }
Visual Basic
Public Property ShowCustomView As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

If this property is set to false and the user has administrative access, the display will show the non-custom (job editing) view; otherwise it will show the custom (run time) view. If the user does not have administrative access, the custom view will be shown regardless of the value of this property.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ShowDependencyErrorsOnly Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ShowDependencyErrorsOnly Property
CvsInSightDisplay Class See Also Send Feedback
True to display errors only; false to display all dependencies.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowDependencyErrorsOnly { get; set; }
Visual Basic
Public Property ShowDependencyErrorsOnly As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ShowEntireSheet Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ShowEntireSheet Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets a value that determines whether the entire sheet (including dialog rows) will be displayed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowEntireSheet { get; set; }
Visual Basic
Public Property ShowEntireSheet As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

This property is only effective when the job editing (non-custom) view is displayed and when the display is not within a dialog.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ShowGraphics Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ShowGraphics Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets a value that determines whether the In-Sight graphics will be displayed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowGraphics { get; set; }
Visual Basic
Public Property ShowGraphics As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ShowGrid Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ShowGrid Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets a value that determines whether the grid overlay (cells) will be displayed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowGrid { get; set; }
Visual Basic
Public Property ShowGrid As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Even when this property is set to true, the grid may be hidden at certain times such as when editing graphics. The value of this property does not change in such cases.

Changing this property while editing a cell's expression or value will accept any changes that were made and return the display to the normal state.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ShowImage Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ShowImage Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets a value that determines whether the image will be displayed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowImage { get; set; }
Visual Basic
Public Property ShowImage As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ShowImageSaturation Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ShowImageSaturation Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets a value that determines whether saturated areas of the image will be displayed in color.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowImageSaturation { get; set; }
Visual Basic
Public Property ShowImageSaturation As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

When a grayscale image is displayed, setting this property to true causes areas of gray level 0 to be drawn in blue, and areas of gray level 255 to be drawn in green. This property has no effect when a color image is displayed.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ShowScrollBars Property

[image]

In-Sight SDK
CvsInSightDisplay..::..ShowScrollBars Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets a value indicating whether the scroll bars will be displayed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowScrollBars { get; set; }
Visual Basic
Public Property ShowScrollBars As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Even if this property is set to true scroll bars will not appear when there is nothing to scroll, for example if the ImageZoomMode is set to Fit and the active portion of the grid fills the entire display.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.SnippetPath Property

[image]

In-Sight SDK
CvsInSightDisplay..::..SnippetPath Property
CvsInSightDisplay Class See Also Send Feedback
Gets and sets the path for snippets. This path will be the initial directory when cells are imported or exported.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string SnippetPath { get; set; }
Visual Basic
Public Property SnippetPath As String
    Get
    Set

Property Value

Type: String

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.SoftOnline Property

[image]

In-Sight SDK
CvsInSightDisplay..::..SoftOnline Property
CvsInSightDisplay Class See Also Send Feedback
Gets or sets the soft-online state of the In-Sight sensor.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool SoftOnline { get; set; }
Visual Basic
Public Property SoftOnline As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

This property is the same as the SoftOnline property of the CvsInSight object, and is exposed by the display control for convenience and for applications that cannot use the CvsInSight object directly. Setting this property will have no effect when the display is not connected to an In-Sight sensor.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | A network error occurred while sending the request to change the state.
Cognex.InSight..::..CvsInSightLockedException | There is a messagebox open or the sensor has been locked while performing another operation, temporarily preventing communication.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.State Property

[image]

In-Sight SDK
CvsInSightDisplay..::..State Property
CvsInSightDisplay Class See Also Send Feedback
Gets the current state of the display.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsDisplayState State { get; }
Visual Basic
Public ReadOnly Property State As CvsDisplayState
    Get

Property Value

Type: CvsDisplayState

Remarks

When this property is changed, the StateChanged event is raised.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.StatusInformation Property

[image]

In-Sight SDK
CvsInSightDisplay..::..StatusInformation Property
CvsInSightDisplay Class See Also Send Feedback
Gets a string that represents some extra information that could be displayed about the current state of the display. This is information that could be displayed in the status bar of an application for example.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string StatusInformation { get; }
Visual Basic
Public ReadOnly Property StatusInformation As String
    Get

Property Value

Type: String

Remarks

Returns null when no applicable information is available.

When this property is changed, the StatusInformationChanged event is raised.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace
CvsInSightDisplay..::..StatusInformationState


CvsInSightDisplay.StatusInformationState Property

[image]

In-Sight SDK
CvsInSightDisplay..::..StatusInformationState Property
CvsInSightDisplay Class See Also Send Feedback
Gets the type of information contained in the StatusInformation property.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsStatusInformationState StatusInformationState { get; }
Visual Basic
Public ReadOnly Property StatusInformationState As CvsStatusInformationState
    Get

Property Value

Type: CvsStatusInformationState

Remarks

When this property is changed, the StatusInformationChanged event is raised.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.VisibleRange Property

[image]

In-Sight SDK
CvsInSightDisplay..::..VisibleRange Property
CvsInSightDisplay Class See Also Send Feedback
Gets the range of cells that are visible in the display.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellRange VisibleRange { get; }
Visual Basic
Public ReadOnly Property VisibleRange As CvsCellRange
    Get

Property Value

Type: CvsCellRange

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay Events

[image] [image]

In-Sight SDK
CvsInSightDisplay Events
CvsInSightDisplay Class See Also Send Feedback

The CvsInSightDisplay type exposes the following members.

Events

Name Description
Public event AutoSizeChanged
Occurs when the AutoSize property changes.
(Inherited from UserControl.)
Public event AutoValidateChanged
Occurs when the AutoValidate property changes.
(Inherited from UserControl.)
Public event BackColorChanged
Occurs when the value of the BackColor property changes.
(Inherited from Control.)
Public event BackgroundImageChanged
Occurs when the value of the BackgroundImage property changes.
(Inherited from Control.)
Public event BackgroundImageLayoutChanged
Occurs when the BackgroundImageLayout property changes.
(Inherited from Control.)
Public event BindingContextChanged
Occurs when the value of the BindingContext property changes.
(Inherited from Control.)
Public event CausesValidationChanged
Occurs when the value of the CausesValidation property changes.
(Inherited from Control.)
Public event ChangeUICues
Occurs when the focus or keyboard user interface (UI) cues change.
(Inherited from Control.)
Public event Click
Occurs when the control is clicked.
(Inherited from Control.)
Public event ClientSizeChanged
Occurs when the value of the ClientSize property changes.
(Inherited from Control.)
Public event ConnectCompleted
The ConnectCompleted event is raised when an asynchronous Connect call has completed. The event arguments indicate whether an exception was generated while attempting the connection.
Public event ConnectedChanged
Raised whenever the Connected property has changed.
Public event ContextMenuChanged
Occurs when the value of the ContextMenu property changes.
(Inherited from Control.)
Public event ContextMenuStripChanged
Occurs when the value of the ContextMenuStrip property changes.
(Inherited from Control.)
Public event ControlAdded
Occurs when a new control is added to the Control..::..ControlCollection.
(Inherited from Control.)
Public event ControlRemoved
Occurs when a control is removed from the Control..::..ControlCollection.
(Inherited from Control.)
Public event CurrentCellChanged
Raised whenever the CurrentCell property has changed.
Public event CurrentCellExpressionChanged
Raised whenever the CurrentCellExpression property has changed.
Public event CurrentCellNowChanged
Raised whenever the CurrentCellNow property has changed.
Public event CursorChanged
Occurs when the value of the Cursor property changes.
(Inherited from Control.)
Public event Disposed
Occurs when the component is disposed by a call to the Dispose()()()() method.
(Inherited from Component.)
Public event DockChanged
Occurs when the value of the Dock property changes.
(Inherited from Control.)
Public event DoubleClick
Occurs when the control is double-clicked.
(Inherited from Control.)
Public event DragDrop
Occurs when a drag-and-drop operation is completed.
(Inherited from Control.)
Public event DragEnter
Occurs when an object is dragged into the control's bounds.
(Inherited from Control.)
Public event DragLeave
Occurs when an object is dragged out of the control's bounds.
(Inherited from Control.)
Public event DragOver
Occurs when an object is dragged over the control's bounds.
(Inherited from Control.)
Public event EditCellExpressionCompleted
This event is raised when the user has finished editing a cell expression.
Public event EditGraphicsCompleted
This event is raised when the user has finished editing the default graphic of a cell, or graphics passed into the EditGraphics(array<ICvsEditableGraphic>[]()[][]) method.
Public event EnabledChanged
Occurs when the Enabled property value has changed.
(Inherited from Control.)
Public event Enter
Occurs when the control is entered.
(Inherited from Control.)
Public event FocusGraphicChanged
Notifies the subscriber that the focused graphic has changed while in graphics editing mode.

Remarks

This event will be raised only when the State property equals EditingGraphics.

The Accept event argument is ignored.

The Value event argument will be the ICvsEditableDisplayGraphic object which currently has focus.

The CellLocation event argument will equal the cell location if the default graphic of a cell was edited, and it will equal Invalid if the EditGraphics(array<ICvsEditableGraphic>[]()[][]) method was called.

This event is not available in COM/ActiveX applications.

Public event FontChanged
Occurs when the Font property value changes.
(Inherited from Control.)
Public event ForeColorChanged
Occurs when the ForeColor property value changes.
(Inherited from Control.)
Public event GiveFeedback
Occurs during a drag operation.
(Inherited from Control.)
Public event GotFocus
Occurs when the control receives focus.
(Inherited from Control.)
Public event GridOffsetChanged
Raised whenever the GridOffset property has changed.
Public event GridOpacityChanged
Raised whenever the GridOpacity property has changed.
Public event GridScaleChanged
Raised whenever the GridScale property has changed.
Public event HandleCreated
Occurs when a handle is created for the control.
(Inherited from Control.)
Public event HandleDestroyed
Occurs when the control's handle is in the process of being destroyed.
(Inherited from Control.)
Public event HelpRequested
Occurs when the user requests help for a control.
(Inherited from Control.)
Public event ImageOffsetChanged
Raised whenever the ImageOffset property has changed.
Public event ImageOrientationChanged
Raised whenever the ImageOrientation property has changed.
Public event ImageScaleChanged
Raised whenever the ImageScale property has changed.
Public event ImeModeChanged
Occurs when the ImeMode property has changed.
(Inherited from Control.)
Public event InSightChanged
Raised whenever the InSight property has changed.
Public event Invalidated
Occurs when a control's display requires redrawing.
(Inherited from Control.)
Public event KeyDown
Occurs when a key is pressed while the control has focus.
(Inherited from Control.)
Public event KeyPress
Occurs when a character. space or backspace key is pressed while the control has focus.
(Inherited from Control.)
Public event KeyUp
Occurs when a key is released while the control has focus.
(Inherited from Control.)
Public event Layout
Occurs when a control should reposition its child controls.
(Inherited from Control.)
Public event Leave
Occurs when the input focus leaves the control.
(Inherited from Control.)
Public event Load
Occurs before the control becomes visible for the first time.
(Inherited from UserControl.)
Public event LocationChanged
Occurs when the Location property value has changed.
(Inherited from Control.)
Public event LostFocus
Occurs when the control loses focus.
(Inherited from Control.)
Public event MarginChanged
Occurs when the control's margin changes.
(Inherited from Control.)
Public event MouseCaptureChanged
Occurs when the control loses mouse capture.
(Inherited from Control.)
Public event MouseClick
Occurs when the control is clicked by the mouse.
(Inherited from Control.)
Public event MouseDoubleClick
Occurs when the control is double clicked by the mouse.
(Inherited from Control.)
Public event MouseDown
Occurs when the mouse pointer is over the control and a mouse button is pressed.
(Inherited from Control.)
Public event MouseEnter
Occurs when the mouse pointer enters the control.
(Inherited from Control.)
Public event MouseHover
Occurs when the mouse pointer rests on the control.
(Inherited from Control.)
Public event MouseLeave
Occurs when the mouse pointer leaves the control.
(Inherited from Control.)
Public event MouseMove
Occurs when the mouse pointer is moved over the control.
(Inherited from Control.)
Public event MouseUp
Occurs when the mouse pointer is over the control and a mouse button is released.
(Inherited from Control.)
Public event MouseWheel
Occurs when the mouse wheel moves while the control has focus.
(Inherited from Control.)
Public event Move
Occurs when the control is moved.
(Inherited from Control.)
Public event PaddingChanged
Occurs when the control's padding changes.
(Inherited from Control.)
Public event Paint
Occurs when the control is redrawn.
(Inherited from Control.)
Public event PaintGraphics
Allows an application to paint custom graphics over the image.
Public event ParentChanged
Occurs when the Parent property value changes.
(Inherited from Control.)
Public event PreviewKeyDown
Occurs before the KeyDown event when a key is pressed while focus is on this control.
(Inherited from Control.)
Public event QueryAccessibilityHelp
Occurs when AccessibleObject is providing help to accessibility applications.
(Inherited from Control.)
Public event QueryContinueDrag
Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
(Inherited from Control.)
Public event RegionChanged
Occurs when the value of the Region property changes.
(Inherited from Control.)
Public event Resize
Occurs when the control is resized.
(Inherited from Control.)
Public event ResultsChanged
Raised whenever the Results property has changed.
Public event RightToLeftChanged
Occurs when the RightToLeft property value changes.
(Inherited from Control.)
Public event Scroll
Occurs when the user or code scrolls through the client area.
(Inherited from ScrollableControl.)
Public event ScrollModeChanged
Raised whenever the ScrollMode property has changed.
Public event SelectedRangeChanged
Raised whenever the SelectedRange property has changed.
Public event ShowGridChanged
Raised whenever the ShowGrid property has changed.
Public event SizeChanged
Occurs when the Size property value changes.
(Inherited from Control.)
Public event StateChanged
Raised whenever the State property has changed.
Public event StatusInformationChanged
Raised whenever the StatusInformation or StatusInformationState property has changed.
Public event StyleChanged
Occurs when the control style changes.
(Inherited from Control.)
Public event SystemColorsChanged
Occurs when the system colors change.
(Inherited from Control.)
Public event TabIndexChanged
Occurs when the TabIndex property value changes.
(Inherited from Control.)
Public event TabStopChanged
Occurs when the TabStop property value changes.
(Inherited from Control.)
Public event TextChanged
Raises the TextChanged event.
(Inherited from UserControl.)
Public event TextScaleModeChanged
Pass the TextScaleModeChanged event handler to the control
Public event Validated
Occurs when the control is finished validating.
(Inherited from Control.)
Public event Validating
Occurs when the control is validating.
(Inherited from Control.)
Public event VisibleChanged
Occurs when the Visible property value changes.
(Inherited from Control.)
Public event VisibleRangeChanged
Raised when the VisibleRange property has changed.

See Also

CvsInSightDisplay Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ConnectCompleted Event

[image]

In-Sight SDK
CvsInSightDisplay..::..ConnectCompleted Event
CvsInSightDisplay Class See Also Send Feedback
The ConnectCompleted event is raised when an asynchronous Connect call has completed. The event arguments indicate whether an exception was generated while attempting the connection.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event CvsConnectCompletedEventHandler ConnectCompleted
Visual Basic
Public Event ConnectCompleted As CvsConnectCompletedEventHandler

Value

Type: Cognex.InSight..::..CvsConnectCompletedEventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides only the ErrorNumber and ErrorMessage arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ConnectedChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..ConnectedChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the Connected property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler ConnectedChanged
Visual Basic
Public Event ConnectedChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.CurrentCellChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..CurrentCellChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the CurrentCell property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler CurrentCellChanged
Visual Basic
Public Event CurrentCellChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.CurrentCellExpressionChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..CurrentCellExpressionChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the CurrentCellExpression property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler CurrentCellExpressionChanged
Visual Basic
Public Event CurrentCellExpressionChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.CurrentCellNowChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..CurrentCellNowChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the CurrentCellNow property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler CurrentCellNowChanged
Visual Basic
Public Event CurrentCellNowChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.EditCellExpressionCompleted Event

[image]

In-Sight SDK
CvsInSightDisplay..::..EditCellExpressionCompleted Event
CvsInSightDisplay Class See Also Send Feedback
This event is raised when the user has finished editing a cell expression.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event CvsEditEventHandler EditCellExpressionCompleted
Visual Basic
Public Event EditCellExpressionCompleted As CvsEditEventHandler

Value

Type: Cognex.InSight.Controls.Display..::..CvsEditEventHandler

Remarks

This event will be raised when the State property equals EditingCellExpression if a cell expression is edited in-place, or Dialog if a cell expression is edited using the property sheet. After this event is raised, the StateChanged event is raised indicating that the State property has returned to Normal.

The Accept event argument indicates whether the user accepted the changes that were made.

If the Accept argument is true, the Value event argument will be a string containing the new cell expression. If the Accept argument is false, the Value event argument is ignored.

This event is not available in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.EditGraphicsCompleted Event

[image]

In-Sight SDK
CvsInSightDisplay..::..EditGraphicsCompleted Event
CvsInSightDisplay Class See Also Send Feedback
This event is raised when the user has finished editing the default graphic of a cell, or graphics passed into the EditGraphics(array<ICvsEditableGraphic>[]()[][]) method.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event CvsEditEventHandler EditGraphicsCompleted
Visual Basic
Public Event EditGraphicsCompleted As CvsEditEventHandler

Value

Type: Cognex.InSight.Controls.Display..::..CvsEditEventHandler

Remarks

This event will be raised when the State property equals EditingGraphics. After this event is raised, the StateChanged event is raised indicating that the State property has returned to Normal.

The Accept event argument indicates whether the user accepted the changes that were made.

If the Accept argument is true, the Value event argument will be an array containing the CvsGraphic objects that were edited. If the Accept argument is false, the Value event argument is ignored.

The CellLocation event argument will equal the cell location if the default graphic of a cell was edited, and it will equal Invalid if the EditGraphics(array<ICvsEditableGraphic>[]()[][]) method was called.

This event is not available in COM/ActiveX applications.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.FocusGraphicChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..FocusGraphicChanged Event
CvsInSightDisplay Class See Also Send Feedback
Notifies the subscriber that the focused graphic has changed while in graphics editing mode.

Remarks

This event will be raised only when the State property equals EditingGraphics.

The Accept event argument is ignored.

The Value event argument will be the ICvsEditableDisplayGraphic object which currently has focus.

The CellLocation event argument will equal the cell location if the default graphic of a cell was edited, and it will equal Invalid if the EditGraphics(array<ICvsEditableGraphic>[]()[][]) method was called.

This event is not available in COM/ActiveX applications.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event CvsEditEventHandler FocusGraphicChanged
Visual Basic
Public Event FocusGraphicChanged As CvsEditEventHandler

Value

Type: Cognex.InSight.Controls.Display..::..CvsEditEventHandler

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.GridOffsetChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..GridOffsetChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the GridOffset property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler GridOffsetChanged
Visual Basic
Public Event GridOffsetChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.GridOpacityChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..GridOpacityChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the GridOpacity property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler GridOpacityChanged
Visual Basic
Public Event GridOpacityChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.GridScaleChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..GridScaleChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the GridScale property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler GridScaleChanged
Visual Basic
Public Event GridScaleChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ImageOffsetChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..ImageOffsetChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the ImageOffset property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler ImageOffsetChanged
Visual Basic
Public Event ImageOffsetChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ImageOrientationChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..ImageOrientationChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the ImageOrientation property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler ImageOrientationChanged
Visual Basic
Public Event ImageOrientationChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ImageScaleChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..ImageScaleChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the ImageScale property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler ImageScaleChanged
Visual Basic
Public Event ImageScaleChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.InSightChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..InSightChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the InSight property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler InSightChanged
Visual Basic
Public Event InSightChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.PaintGraphics Event

[image]

In-Sight SDK
CvsInSightDisplay..::..PaintGraphics Event
CvsInSightDisplay Class Example See Also Send Feedback
Allows an application to paint custom graphics over the image.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event PaintEventHandler PaintGraphics
Visual Basic
Public Event PaintGraphics As PaintEventHandler

Value

Type: System.Windows.Forms..::..PaintEventHandler

Remarks

This event is raised after the image and the In-Sight graphics have been painted, and before the grid has been painted. The Graphics object provided by the event arguments will be initially configured to use coordinates in image pixels relative to the upper-left corner of the image. Therefore the screen location and size of graphics will change according to the ImageScale and ImageOffset properties. The ResetTransform()()()() method of the Graphics object can be called in order to draw graphics in client coordinates of the display.

Any graphics painted using this event will appear behind the grid if the grid is visible. The Paint event can be used to paint custom graphics in front of the grid.

This event is not available in COM/ActiveX applications.

Examples

The following C# example illustrates how to draw custom graphics in the display by sinking the PaintGraphics event. It requires an In-Sight SDK license because it uses the Results property in order to obtain the dimensions of the acquired image.
Copy image Copy
// This method handles the PaintGraphics event of the display in order
// to draw custom graphics in front of the image and behind the grid.
private void cvsInSightDisplay1_PaintGraphics(object sender, System.Windows.Forms.PaintEventArgs e)
{
  if (cvsInSightDisplay1.Results != null)
  {
    CvsImage img = cvsInSightDisplay1.Results.Image;
    if (img != null)
    {
      // Draw a blue box in the center of the image. This is drawn in image coordinates
      // so the size and line width of this graphic will scale with the image,
      // getting smaller as the image is zoomed out and getting larger as the image
      // is zoomed in.
      e.Graphics.DrawRectangle(Pens.Blue, img.Width/2-5, img.Height/2-5, 10, 10);

      // Compute the location of the center of the image in client coordinates
      // so we can draw a cross there after resetting the transform.
      Point[] pts = new Point[1] {new Point(img.Width/2, img.Height/2)};
      e.Graphics.Transform.TransformPoints(pts);
      Point cp = pts[0]; // just for readability

      // Reset the transform in order to draw in client coordinates.
      e.Graphics.ResetTransform();

      // Display the image size at a fixed location behind the grid
      e.Graphics.DrawString("Image size: " + img.Width.ToString() + " x " +
        img.Height.ToString(), this.Font, Brushes.Orange, 50, 50);

      // Draw a yellow cross in the center of the image. This is drawn in client coordinates
      // so the size and line width of this cross will NOT scale as the ImageScale changes.
      // We must use the image center point transformed into client coordinates (above)
      // in order to draw the cross in the proper location.
      e.Graphics.DrawLine(Pens.Yellow, cp.X, cp.Y-5, cp.X, cp.Y+5);
      e.Graphics.DrawLine(Pens.Yellow, cp.X-5, cp.Y, cp.X+5, cp.Y);
    }
  }
}

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ResultsChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..ResultsChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the Results property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler ResultsChanged
Visual Basic
Public Event ResultsChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ScrollModeChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..ScrollModeChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the ScrollMode property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler ScrollModeChanged
Visual Basic
Public Event ScrollModeChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.SelectedRangeChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..SelectedRangeChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the SelectedRange property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler SelectedRangeChanged
Visual Basic
Public Event SelectedRangeChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.ShowGridChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..ShowGridChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the ShowGrid property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler ShowGridChanged
Visual Basic
Public Event ShowGridChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.StateChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..StateChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the State property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event CvsDisplayStateChangedEventHandler StateChanged
Visual Basic
Public Event StateChanged As CvsDisplayStateChangedEventHandler

Value

Type: Cognex.InSight.Controls.Display..::..CvsDisplayStateChangedEventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.StatusInformationChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..StatusInformationChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised whenever the StatusInformation or StatusInformationState property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler StatusInformationChanged
Visual Basic
Public Event StatusInformationChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

In COM/ActiveX environments such as Microsoft Visual Basic 6.0, this event provides no arguments.

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.TextScaleModeChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..TextScaleModeChanged Event
CvsInSightDisplay Class See Also Send Feedback
Pass the TextScaleModeChanged event handler to the control

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event CvsInSightDisplay..::..CvsTextScaleModeEventHandler TextScaleModeChanged
Visual Basic
Public Event TextScaleModeChanged As CvsInSightDisplay..::..CvsTextScaleModeEventHandler

Value

Type: Cognex.InSight.Controls.Display..::..CvsInSightDisplay..::..CvsTextScaleModeEventHandler

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.VisibleRangeChanged Event

[image]

In-Sight SDK
CvsInSightDisplay..::..VisibleRangeChanged Event
CvsInSightDisplay Class See Also Send Feedback
Raised when the VisibleRange property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler VisibleRangeChanged
Visual Basic
Public Event VisibleRangeChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsInSightDisplay Class
CvsInSightDisplay..::..CvsInSightDisplay Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.CvsTextScaleModeEventHandler Delegate

[image]

In-Sight SDK
CvsInSightDisplay..::..CvsTextScaleModeEventHandler Delegate
CvsInSightDisplay Class See Also Send Feedback
Delegate for TextScaleModeChanged event

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public delegate void CvsTextScaleModeEventHandler(
    int index
)
Visual Basic
Public Delegate Sub CvsTextScaleModeEventHandler (
    index As Integer
)

Parameters

index
Type: System..::..Int32

See Also

Cognex.InSight.Controls.Display Namespace


CvsInSightDisplay.TextScaleModeType Enumeration

[image]

In-Sight SDK
CvsInSightDisplay..::..TextScaleModeType Enumeration
CvsInSightDisplay Class See Also Send Feedback
Enumerator for text scaling mode

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public enum TextScaleModeType
Visual Basic
Public Enumeration TextScaleModeType

Members

Member name | Value | Description
Proportional | 0 | Scale with image
ShrinkOnly | 1 | Shrink only or zoom out only
Fixed | 2 | Fixed size

See Also

Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayCropScaleMode Enumeration

[image]

In-Sight SDK
CvsInSightDisplayCropScaleMode Enumeration
See Also Send Feedback
Indicates the appropriate Crop/Scale mode for the InSight Display.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsInSightDisplayCropScaleMode
Visual Basic
Public Enumeration CvsInSightDisplayCropScaleMode

Members

Member name | Value | Description
Default | 0 | The display will choose the best crop scale mode.
None | 1 | The image should be a full-size 1:1 representation of the camera image.
CropOnly | 2 | The image should be a 1:1 scale of the portion that will be shown in the display.
CropScale | 3 | The image should be cropped and scaled to fit the drawing area in the display.

See Also

Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit Class

[image]

In-Sight SDK
CvsInSightDisplayEdit Class
Members Example See Also Send Feedback
Provides the editing actions for the CvsInSightDisplay control.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public sealed class CvsInSightDisplayEdit : DynamicValueComputed,
    ICvsInSightDisplayEdit
Visual Basic
Public NotInheritable Class CvsInSightDisplayEdit
    Inherits DynamicValueComputed
    Implements ICvsInSightDisplayEdit

Remarks

Most of the members of this class are properties that return a CvsAction object, which provides methods and properties that allow a user interface to interact with the various editing actions of the display.

The display control will automatically enable and disable its editing actions depending on conditions such as the user's access level, what is selected in the display, the display's State, whether the In-Sight sensor is online etc. Your code can determine whether a given action is currently enabled by reading its Enabled property, and you can permanently disable an action and hide any associated menu items by setting its Suppressed property.

Examples

The following example illustrates how to use the Copy action to copy the currently selected cells (determined by the SelectedRange property) onto the clipboard. This code will have no effect when the Copy action is disabled, i.e. when its Enabled property is false.
Copy image Copy
cvsInSightDisplay1.Edit.Copy.Execute();

Examples

The following example illustrates how to suppress the EditCellExpression action. When the action is suppressed, it will remain disabled regardless of the state of the display and if the display's context menu has an item associated with the action it will be hidden.
Copy image Copy
cvsInSightDisplay1.Edit.EditCellExpression.Suppressed = true;

Inheritance Hierarchy

System..::..Object
DynamicValue
DynamicValueComputed
Cognex.InSight.Controls.Display..::..CvsInSightDisplayEdit

See Also

CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit Members

[image] [image]

In-Sight SDK
CvsInSightDisplayEdit Members
CvsInSightDisplayEdit Class Methods Fields Properties Events See Also Send Feedback

The CvsInSightDisplayEdit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MnuSensor_BeforePopup | Update DialogUndoOnCancelEnabled state
Public method | OpenImageFromFile | Open an image from a file.
Public method | OpenJobFromFile(String) | Open a job from a file.
Public method | OpenJobFromFile(String, Boolean) | Open a job from a file.
Public method | ProcessShortcutKey | Processes a keystroke, executing any enabled editing action that has a corresponding shortcut key.
Public method | PromptForInSightRestart | Prompts user to restart the InSight. This will also prompt the user to save the job first.
Public method | SetBackColor | Sets the background color for the current selection range.
Public method | SetForeColor | Sets the foreground color for the current selection range.
Public method | SuppressChanges | Suppress/allow accept and cancel changes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ClassicUserRefreshNeeded | Raised when in Classic User Access mode and the user list has been changed.

Properties

 | Name | Description
Public property | AcceptChanges | Accepts changes made in the current editing mode.
Public property | AutoFitColumns | Gets a CvsAction object with an Execute()()()() method that resizes the column(s) of the selected range so that they are just wide enough to show the contents of the cells in the selected range.
Public property | AutoFitRows | Gets a CvsAction object with an Execute()()()() method that resizes the rows(s) of the selected range so that they are just high enough to show the contents of the cells in the selected range.
Public property | CancelChanges | Cancels changes made in the current editing mode.
Public property | ClearAll | Clears the contents, comments, formats, and OPC tags of cells in the selected range.
Public property | ClearComments | Gets a CvsAction object with an Execute()()()() method that clears the comments of cells in the selected range.
Public property | ClearContents | Clears the contents of cells in the selected range.
Public property | ClearEasyTags | Gets a CvsAction object with an Execute()()()() method that clears the EasyTags of cells in the selected range.
Public property | ClearFormats | Gets a CvsAction object with an Execute()()()() method that clears the formats of cells in the selected range.
Public property | ClearOpcTags | Gets a CvsAction object with an Execute()()()() method that clears the OPC tags of cells in the selected range.
Public property | ClearPermissions | Gets a CvsAction object with an Execute()()()() method that clears the permissions of cells in the selected range.
Public property | ConvertToEasyTags | Gets a CvsAction object with an Execute()()()() method that converts all appropriate comments to EasyTags. This also strips off the "EE" (if present).
Public property | Copy | Copies all cells in the selected range to the clipboard.
Public property | CopyBitmap | Copies a bitmap of the display contents to the clipboard.
Public property | CreateNewCustomPrivilege | Gets a CvsAction object with an Execute()()()() method that opens the User List Settings dialog.
Public property | Cut | Cuts all cells in the selected range to the clipboard.
Public property | CycleGraphicColor | Cycles the displayed color of all input graphics
Public property | DecreaseGridOpacity | Gets a CvsAction object with an Execute()()()() method that decreases the opacity of the grid.
Public property | DeleteCellsOrRowsOrColumns | Gets a CvsAction object with an Execute()()()() method that deletes cells, rows or columns depending on what is selected.
Public property | DialogUndoOnCancel | Get and set Dialog Undo on Cancel True if the "Undo On Dialog Cancel" is enabled, which means when a dialog is cancelled it will perform an "undo" to all dialog cells, which is the current behavior. False if the "Undo On Dialog Cancel" is disabled, which means it won't perform "Undo" to the dialog cells anymore, which is a new behavior.
Public property | EasyBuilderPlaybackOptions | Opens the Record / Playback Options dialog. This version forces the Playback tab to start visible.
Public property | EasyBuilderRecordOptions | Opens the Record / Playback Options dialog. This version forces the Record tab to start visible.
Public property | EditActiveCellsLimit | Gets a CvsAction object with an Execute()()()() method that opens the EditActiveCellsLimit dialog.
Public property | EditAuditMessageSettings | Gets a CvsAction object with an Execute()()()() method that opens the AuditTrailSettings dialog.
Public property | EditCcLinkSettings | Gets a CvsAction object with an Execute()()()() method that opens the CC-Link Settings dialog.
Public property | EditCellExpression | Begins editing the expression of the current cell, using the property sheet if applicable or the in-place formula text box otherwise.
Public property | EditCellExpressionInPlace | Begins editing the expression of the current cell using the in-place formula text box.
Public property | EditCellGraphic | Begins editing the graphic of the current cell.
Public property | EditCellState | Gets a CvsAction object with an Execute()()()() method that opens the Cell State dialog.
Public property | EditCustomPrivileges | Gets a CvsAction object with an Execute()()()() method that opens the list of custom privileges dialog.
Public property | EditCustomViewSettings | Gets a CvsAction object with an Execute()()()() method that opens the Custom View Settings dialog, using the selected range of cells as the custom view range.
Public property | EditDateTimeSettings | Gets a CvsAction object with an Execute()()()() method that opens the Date Time Settings dialog.
Public property | EditDiscreteInputSettings | Gets a CvsAction object with an Execute()()()() method that opens the Discrete Input Settings dialog.
Public property | EditDiscreteOutputSettings | Gets a CvsAction object with an Execute()()()() method that opens the Discrete Output Settings dialog.
Public property | EditDiscreteSettings | Gets a CvsAction object with an Execute()()()() method that opens the Discrete Settings dialog.
Public property | EditEasyViewSettings | Gets a CvsAction object with an Execute()()()() method that opens the Custom View Settings dialog, using the selected range of cells as the custom view range.
Public property | EditFtpSettings | Gets a CvsAction object with an Execute()()()() method that opens the FTP Settings dialog.
Public property | EditHmiSettings | Gets a CvsAction object with an Execute()()()() method that opens the Hmi Settings dialog.
Public property | EditHostTableSettings | Gets a CvsAction object with an Execute()()()() method that opens the Host Table Settings dialog.
Public property | EditImageBuffers | Gets a CvsAction object with an Execute()()()() method that opens the Image Buffers dialog.
Public property | EditImageSettings | Gets a CvsAction object with an Execute()()()() method that opens the Image Settings dialog.
Public property | EditJobServerSettings | Gets a CvsAction object with an Execute()()()() method that opens the Job Server Settings dialog.
Public property | EditLicensing | Gets a CvsAction object with an Execute()()()() method that opens the Licensing dialog.
Public property | EditLightSettings | Gets a CvsAction object with an Execute()()()() method that opens the Light Settings dialog.
Public property | EditLineScanSettings | Gets a CvsAction object with an Execute()()()() method that opens the Line Scan Settings dialog.
Public property | EditNetworkSettings | Gets a CvsAction object with an Execute()()()() method that opens the Network Settings dialog.
Public property | EditSalesModelSettings |
Public property | EditSerialPort0Settings | Gets a CvsAction object with an Execute()()()() method that opens the Serial Port 0 Settings dialog.
Public property | EditSerialPort1Settings | Gets a CvsAction object with an Execute()()()() method that opens the Serial Port 0 Settings dialog.
Public property | EditStartupSettings | Gets a CvsAction object with an Execute()()()() method that opens the Startup Settings dialog.
Public property | EditUserAccessSettings | Gets a CvsAction object with an Execute()()()() method that opens the User List Settings dialog.
Public property | EditVisionViewViewSelection | Gets a CvsAction object with an Execute()()()() method that opens the VisionView Settings dialog.
Public property | ExportCells | Gets a CvsAction object with an Execute()()()() method that exports the current cell to a cell data file.
Public property | ExportSnippet | Gets a CvsAction object with an Execute()()()() method that exports the current cell to a cell data file.
Public property | Find | Opens the Find dialog.
Public property | FormatBold | Toggles the formatting of all cells in the selected range between Bold and non-Bold.
Public property | FormatCenter | Gets a CvsActionToggle object with an Execute()()()() method that toggles the formatting of all cells in the selected range between Center-aligned and non-Center-aligned (default).
Public property | FormatDecreaseDecimal | Gets a CvsAction object with an Execute()()()() method that decreases the number of decimal places in the formatting of all cells in the selected range.
Public property | FormatDecreaseFont | Gets a CvsAction object with an Execute()()()() method that decreases the font size in the formatting of all cells in the selected range.
Public property | FormatIncreaseDecimal | Gets a CvsAction object with an Execute()()()() method that increases the number of decimal places in the formatting of all cells in the selected range.
Public property | FormatIncreaseFont | Gets a CvsAction object with an Execute()()()() method that increases the font size in the formatting of all cells in the selected range.
Public property | FormatItalic | Toggles the formatting of all cells in the selected range between Italic and non-Italic.
Public property | FormatLeft | Gets a CvsActionToggle object with an Execute()()()() method that toggles the formatting of all cells in the selected range between Left-aligned and non-Left-aligned (default).
Public property | FormatRight | Gets a CvsActionToggle object with an Execute()()()() method that toggles the formatting of all cells in the selected range between Right-aligned and non-Right-aligned (default).
Public property | GoTo | Opens a dialog to prompt the user for a location and jumps to that cell
Public property | GoToFirstError | Changes the current (active) cell to the first precedent of the current cell that is in error. This action will have no effect if the current cell has no precedents in error.
Public property | HideColumns | Gets a CvsAction object with an Execute()()()() method that hides the columns of the selected range.
Public property | HideRows | Gets a CvsAction object with an Execute()()()() method that hides the rows of the selected range.
Public property | HideRowsOrColumns | Gets a CvsAction object with an Execute()()()() method that hides the rows or columns of the selected range depending on what is selected.
Public property | ImportCells | Gets a CvsAction object with an Execute()()()() method that imports a cell data file to the current cell.
Public property | ImportSnippet | Gets a CvsAction object with an Execute()()()() method that imports a snippet.
Public property | IncreaseGridOpacity | Gets a CvsAction object with an Execute()()()() method that increases the opacity of the grid.
Public property | InsertAbsoluteReference | Inserts a new absolute cell reference.
Public property | InsertCells | Gets a CvsAction object with an Execute()()()() method that inserts cells in the selected range, prompting the user for how to shift the remaining cells.
Public property | InsertCellsOrRowsOrColumns | Gets a CvsAction object with an Execute()()()() method that inserts new cells, rows or columns depending on what is selected.
Public property | InsertColumns | Gets a CvsAction object with an Execute()()()() method that inserts columns in the selected range, shifting the contents of existing columns to the right.
Public property | InsertComment | Gets a CvsAction object with an Execute()()()() method that inserts a comment for the selected cell, or edits an existing comment.
Public property | InsertEasyTag | Gets a CvsAction object with an Execute()()()() method that inserts an EasyTag for the selected cell, or edits an existing EasyTag.
Public property | InsertFunction | Inserts a function for the selected cell using the Insert Function dialog.
Public property | InsertOpcTag | Gets a CvsAction object with an Execute()()()() method that inserts an OPC tag for the selected cell, or edits an existing tag.
Public property | InsertRelativeReference | Inserts a new relative cell reference.
Public property | InsertRows | Gets a CvsAction object with an Execute()()()() method that inserts rows in the selected range, shifting the contents of existing rows downward.
Public property | IsRepeatingTriggerActive | Gets a value indicating if repeating trigger is active.
Public property | LiveAcquire | Gets a CvsActionToggle object with an Execute()()()() method that toggles the live acquisition mode of the In-Sight sensor.
Public property | ManualAcquire | Manually triggers an image acquisition.
Public property | MaximizeCellRegion | Maximizes the region to the size of the image. Rotation and curve will be reset to zero.
Public property | MoveDown | Moves the active cell down.
Public property | MoveLeft | Moves the active cell left.
Public property | MovePageDown | Moves the active cell one page downward.
Public property | MovePageUp | Moves the active cell one page upward.
Public property | MoveRight | Moves the active cell right.
Public property | MoveToFirstCell | Moves the active cell to the first cell in the spreadsheet.
Public property | MoveToLastCell | Moves the active cell to the last cell in the spreadsheet.
Public property | MoveToRowEnd | Moves the active cell to the end of the current row.
Public property | MoveToRowStart | Moves the active cell to the start of the current row.
Public property | MoveUp | Moves the active cell up.
Public property | NewJob | Prompts the user for confirmation and then creates a new 'empty' job.
Public property | NextImageOrientation | Advances the ImageOrientation property to the next setting.
Public property | OpenCellFormatDialog | Opens the cell format dialog.
Public property | OpenImage | Gets a CvsAction object with an Execute()()()() method that shows the open file dialog to open an existing image file.
Public property | OpenJob | Shows the open file dialog to open an existing job file.
Public property | OpenOverallPassFailDialog | Opens the Overall Pass Fail Cell Setup dialog.
Public property | OpenOverallPassFailDialogWithCurrentCell | Opens the Overall Pass Fail Cell Setup dialog using the display's current cell as the newly selected Job Pass Fail Cell.
Public property | OpenPageSetupDialog | Opens the print page setup dialog.
Public property | OpenPrintDialog | Opens the print dialog.
Public property | OpenPrintPreviewDialog | Opens the print preview dialog.
Public property | Paste | Pastes the contents of the clipboard into the selected range.
Public property | Play | Toggles the Playback mode of the Display control.
Public property | PlayFirst | Loads the first image from the playback buffer.
Public property | PlayLast | Loads the last image from the playback buffer.
Public property | PlayNext | Loads the next image from the playback buffer.
Public property | PlayPrevious | Loads the previous image from the playback buffer.
Public property | PrintNow | Gets a CvsAction object with an Execute()()()() method that prints the display using the current print settings, without prompting the user in any way.
Public property | ProfileJob | Gets a CvsAction object with an Execute()()()() method that opens the Profiler dialog.
Public property | ProtectJob | Gets a CvsAction object with an Execute()()()() method that opens the Protect Job dialog in order to protect or unprotect the job.
Public property | Record | Toggles the Record mode of the Display control.
Public property | RecordPlaybackOptions | Opens the Record / Playback Options dialog.
Public property | Redo | Redoes the last action that was undone.
Public property | RepeatingTrigger | Gets a CvsActionToggle object with an Execute()()()() method that toggles the repeating trigger mode of the In-Sight sensor.
Public property | ResetSensor | Resets the sensor.
Public property | SaveImageAs | Gets a CvsAction object with an Execute()()()() method that opens the Save As dialog to save the current image to a file.
Public property | SaveJob | Saves the job, opening the Save As dialog if the job has not previously been saved to or loaded from a sensor.
Public property | SaveJobAs | Opens the Save As dialog in order to save the job to a specific location.
Public property | SelectColumn | Selects an entire column.
Public property | SelectDown | Expands the selected range one row down.
Public property | SelectedFontName | Gets the font family name for the current cell. Sets the font family name for the selected range of cells.
Public property | SelectedFontSize | Gets the font size for the current cell. Sets the font size for the selected range of cells.
Public property | SelectLeft | Expands the selected range one column left.
Public property | SelectPageDown | Expands the selected range one page downward.
Public property | SelectPageUp | Expands the selected range one page upward.
Public property | SelectRight | Expands the selected range one column right.
Public property | SelectRow | Selects an entire row.
Public property | SelectToRowEnd | Expands the selection to the end of the row.
Public property | SelectToRowStart | Expands the selection to the start of the row.
Public property | SelectUp | Expands the selected range one row up.
Public property | SetColumnWidth | Gets a CvsAction object with an Execute()()()() method that prompts the user and sets the width of all columns in the selected range.
Public property | SetGridOpacity | Gets a CvsAction object with an Execute()()()() method that prompts the user and sets grid opacity to a specific value.
Public property | SetGridScale | Gets a CvsAction object with an Execute()()()() method that prompts the user and sets grid scale (sheet zoom) to a specific value.
Public property | SetRamDiskSize | Gets a CvsAction object with an Execute()()()() method that prompts the user and sets the RAM disk size to a specific value.
Public property | SetRowHeight | Gets a CvsAction object with an Execute()()()() method that pPrompts the user and sets the height of all rows in the selected range.
Public property | SetTextScaleMode | Callback for the Text Scale Mode button
Public property | ShowCustomView | Toggles the ShowCustomView property in order to switch between the custom view and the normal (job editing) view.
Public property | ShowDependencyErrorsOnly | Toggles the ShowDependencyErrorsOnly property in order to switch between showing all dependencies and errors only.
Public property | ShowDependencyLevelsDecrease | Decreases the displayed dependency levels.
Public property | ShowDependencyLevelsIncrease | Increases the displayed dependency levels.
Public property | ShowDependencyLevelsReset | Sets the displayed dependency levels to zero.
Public property | ShowEntireSheet | Shows or hides the dialog cells in the main spreadsheet area.
Public property | ShowGraphics | Toggles the ShowGraphics property in order to show or hide the spreadsheet graphics.
Public property | ShowGrid | Toggles the ShowGrid property in order to show or hide the spreadsheet grid.
Public property | ShowImageSaturation | Toggles the ShowImageSaturation property in order to show the saturated areas of the image in color.
Public property | SoftOnline | Toggles the soft-online state of the In-Sight sensor, first prompting the user if the ConfirmOnlineTransitions property is true.
Public property | SynchronizedInspectionParameters | Displays the inspection synchronizer parameters dialog.
Public property | Undo | Undoes the last action that was done.
Public property | UnhideColumns | Gets a CvsAction object with an Execute()()()() method that unhides all columns within the selected range.
Public property | UnhideRows | Gets a CvsAction object with an Execute()()()() method that unhides all rows within the selected range.
Public property | UnhideRowsOrColumns | Gets a CvsAction object with an Execute()()()() method that unhides the rows or columns of the selected range depending on what is selected.
Public property | ZoomGrid1To1 | Sets the GridScale to 1.0 if a single cell is selected, or otherwise zooms the grid to fit the selected range.
Public property | ZoomGridIn | Increases the GridScale (sheet zoom).
Public property | ZoomGridOut | Decreases the GridScale (sheet zoom).
Public property | ZoomImage1To1 | Sets the display's ImageZoomMode to None to disable automatic zooming of the image, and then sets the ImageScale to 1.0.
Public property | ZoomImageIn | Sets the display's ImageZoomMode to None to disable automatic zooming of the image, and then increases the ImageScale.
Public property | ZoomImageOut | Sets the display's ImageZoomMode to None to disable automatic zooming of the image, and and then decreases the ImageScale.
Public property | ZoomImageToFill | Gets a CvsActionToggle object with an Execute()()()() method that toggles the display's ImageZoomMode between None and Fill.
Public property | ZoomImageToFit | Gets a CvsActionToggle object with an Execute()()()() method that toggles the display's ImageZoomMode between None and Fit.
Public property | ZoomImageToMax | Gets a CvsAction object with an Execute()()()() method that sets the display's ImageZoomMode to None to disable automatic zooming of the image, and then sets the ImageScale to 20.

Events

 | Name | Description
Public event | EnablesUpdated | Raised when the action enables have been updated.
Public event | JobSaveCompleted | Raised after a job save completes, either successfully or with errors.
Public event | JobSaving | Raised prior to saving a job.
Public event | NetworkTreeRefreshNeeded | Raised when a refresh to the network tree is needed.
Public event | RepeatingTriggerChanged | Repeating trigger state has changed.
Public event | SelectedFontChanged | Occurs when either the SelectedFontName or the SelectedFontSize property has changed.

See Also

CvsInSightDisplayEdit Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit Fields

[image] [image]

In-Sight SDK
CvsInSightDisplayEdit Fields
CvsInSightDisplayEdit Class See Also Send Feedback

The CvsInSightDisplayEdit type exposes the following members.

Fields

 | Name | Description
Public field | ClassicUserRefreshNeeded | Raised when in Classic User Access mode and the user list has been changed.

See Also

CvsInSightDisplayEdit Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ClassicUserRefreshNeeded Field

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ClassicUserRefreshNeeded Field
CvsInSightDisplayEdit Class See Also Send Feedback
Raised when in Classic User Access mode and the user list has been changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public EventHandler ClassicUserRefreshNeeded
Visual Basic
Public ClassicUserRefreshNeeded As EventHandler

Field Value

Type: EventHandler

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit Methods

[image] [image]

In-Sight SDK
CvsInSightDisplayEdit Methods
CvsInSightDisplayEdit Class See Also Send Feedback

The CvsInSightDisplayEdit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MnuSensor_BeforePopup | Update DialogUndoOnCancelEnabled state
Public method | OpenImageFromFile | Open an image from a file.
Public method | OpenJobFromFile(String) | Open a job from a file.
Public method | OpenJobFromFile(String, Boolean) | Open a job from a file.
Public method | ProcessShortcutKey | Processes a keystroke, executing any enabled editing action that has a corresponding shortcut key.
Public method | PromptForInSightRestart | Prompts user to restart the InSight. This will also prompt the user to save the job first.
Public method | SetBackColor | Sets the background color for the current selection range.
Public method | SetForeColor | Sets the foreground color for the current selection range.
Public method | SuppressChanges | Suppress/allow accept and cancel changes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsInSightDisplayEdit Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.MnuSensor_BeforePopup Method

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..MnuSensor_BeforePopup Method
CvsInSightDisplayEdit Class See Also Send Feedback
Update DialogUndoOnCancelEnabled state

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void MnuSensor_BeforePopup()
Visual Basic
Public Sub MnuSensor_BeforePopup

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.OpenImageFromFile Method

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..OpenImageFromFile Method
CvsInSightDisplayEdit Class See Also Send Feedback
Open an image from a file.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool OpenImageFromFile(
    string filename
)
Visual Basic
Public Function OpenImageFromFile (
    filename As String
) As Boolean

Parameters

filename
Type: System..::..String
The name of the image file.

Return Value

Type: Boolean
true if successful; otherwise, false.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.OpenJobFromFile Method

[image] [image]

In-Sight SDK
CvsInSightDisplayEdit..::..OpenJobFromFile Method
CvsInSightDisplayEdit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenJobFromFile(String) | Open a job from a file.
Public method | OpenJobFromFile(String, Boolean) | Open a job from a file.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.OpenJobFromFile Method (String)

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..OpenJobFromFile Method (String)
CvsInSightDisplayEdit Class See Also Send Feedback
Open a job from a file.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool OpenJobFromFile(
    string filename
)
Visual Basic
Public Function OpenJobFromFile (
    filename As String
) As Boolean

Parameters

filename
Type: System..::..String
The name of the file to open.

Return Value

Type: Boolean
true if successful; otherwise, false.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
OpenJobFromFile Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.OpenJobFromFile Method (String, Boolean)

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..OpenJobFromFile Method (String, Boolean)
CvsInSightDisplayEdit Class See Also Send Feedback
Open a job from a file.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool OpenJobFromFile(
    string filename,
    bool ftpServer
)
Visual Basic
Public Function OpenJobFromFile (
    filename As String,
    ftpServer As Boolean
) As Boolean

Parameters

filename
Type: System..::..String
The name of the file to open.
ftpServer
Type: System..::..Boolean
true if the file is on an ftp server; false if it is on a sensor.

Return Value

Type: Boolean
true if successful; otherwise, false.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
OpenJobFromFile Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ProcessShortcutKey Method

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ProcessShortcutKey Method
CvsInSightDisplayEdit Class See Also Send Feedback
Processes a keystroke, executing any enabled editing action that has a corresponding shortcut key.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ProcessShortcutKey(
    Keys keyData
)
Visual Basic
Public Function ProcessShortcutKey (
    keyData As Keys
) As Boolean

Parameters

keyData
Type: System.Windows.Forms..::..Keys
The key that was pressed.

Return Value

Type: Boolean
True if an action was processed; false if not.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.PromptForInSightRestart Method

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..PromptForInSightRestart Method
CvsInSightDisplayEdit Class See Also Send Feedback
Prompts user to restart the InSight. This will also prompt the user to save the job first.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void PromptForInSightRestart()
Visual Basic
Public Sub PromptForInSightRestart

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SetBackColor Method

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SetBackColor Method
CvsInSightDisplayEdit Class See Also Send Feedback
Sets the background color for the current selection range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void SetBackColor(
    Color color
)
Visual Basic
Public Sub SetBackColor (
    color As Color
)

Parameters

color
Type: System.Drawing..::..Color
The new background color.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SetForeColor Method

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SetForeColor Method
CvsInSightDisplayEdit Class See Also Send Feedback
Sets the foreground color for the current selection range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void SetForeColor(
    Color color
)
Visual Basic
Public Sub SetForeColor (
    color As Color
)

Parameters

color
Type: System.Drawing..::..Color
The new foreground color.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SuppressChanges Method

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SuppressChanges Method
CvsInSightDisplayEdit Class See Also Send Feedback
Suppress/allow accept and cancel changes.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void SuppressChanges(
    bool suppress
)
Visual Basic
Public Sub SuppressChanges (
    suppress As Boolean
)

Parameters

suppress
Type: System..::..Boolean
True for suppress accept and cancel changes, false for allow them.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit Properties

[image] [image]

In-Sight SDK
CvsInSightDisplayEdit Properties
CvsInSightDisplayEdit Class See Also Send Feedback

The CvsInSightDisplayEdit type exposes the following members.

Properties

 | Name | Description
Public property | AcceptChanges | Accepts changes made in the current editing mode.
Public property | AutoFitColumns | Gets a CvsAction object with an Execute()()()() method that resizes the column(s) of the selected range so that they are just wide enough to show the contents of the cells in the selected range.
Public property | AutoFitRows | Gets a CvsAction object with an Execute()()()() method that resizes the rows(s) of the selected range so that they are just high enough to show the contents of the cells in the selected range.
Public property | CancelChanges | Cancels changes made in the current editing mode.
Public property | ClearAll | Clears the contents, comments, formats, and OPC tags of cells in the selected range.
Public property | ClearComments | Gets a CvsAction object with an Execute()()()() method that clears the comments of cells in the selected range.
Public property | ClearContents | Clears the contents of cells in the selected range.
Public property | ClearEasyTags | Gets a CvsAction object with an Execute()()()() method that clears the EasyTags of cells in the selected range.
Public property | ClearFormats | Gets a CvsAction object with an Execute()()()() method that clears the formats of cells in the selected range.
Public property | ClearOpcTags | Gets a CvsAction object with an Execute()()()() method that clears the OPC tags of cells in the selected range.
Public property | ClearPermissions | Gets a CvsAction object with an Execute()()()() method that clears the permissions of cells in the selected range.
Public property | ConvertToEasyTags | Gets a CvsAction object with an Execute()()()() method that converts all appropriate comments to EasyTags. This also strips off the "EE" (if present).
Public property | Copy | Copies all cells in the selected range to the clipboard.
Public property | CopyBitmap | Copies a bitmap of the display contents to the clipboard.
Public property | CreateNewCustomPrivilege | Gets a CvsAction object with an Execute()()()() method that opens the User List Settings dialog.
Public property | Cut | Cuts all cells in the selected range to the clipboard.
Public property | CycleGraphicColor | Cycles the displayed color of all input graphics
Public property | DecreaseGridOpacity | Gets a CvsAction object with an Execute()()()() method that decreases the opacity of the grid.
Public property | DeleteCellsOrRowsOrColumns | Gets a CvsAction object with an Execute()()()() method that deletes cells, rows or columns depending on what is selected.
Public property | DialogUndoOnCancel | Get and set Dialog Undo on Cancel True if the "Undo On Dialog Cancel" is enabled, which means when a dialog is cancelled it will perform an "undo" to all dialog cells, which is the current behavior. False if the "Undo On Dialog Cancel" is disabled, which means it won't perform "Undo" to the dialog cells anymore, which is a new behavior.
Public property | EasyBuilderPlaybackOptions | Opens the Record / Playback Options dialog. This version forces the Playback tab to start visible.
Public property | EasyBuilderRecordOptions | Opens the Record / Playback Options dialog. This version forces the Record tab to start visible.
Public property | EditActiveCellsLimit | Gets a CvsAction object with an Execute()()()() method that opens the EditActiveCellsLimit dialog.
Public property | EditAuditMessageSettings | Gets a CvsAction object with an Execute()()()() method that opens the AuditTrailSettings dialog.
Public property | EditCcLinkSettings | Gets a CvsAction object with an Execute()()()() method that opens the CC-Link Settings dialog.
Public property | EditCellExpression | Begins editing the expression of the current cell, using the property sheet if applicable or the in-place formula text box otherwise.
Public property | EditCellExpressionInPlace | Begins editing the expression of the current cell using the in-place formula text box.
Public property | EditCellGraphic | Begins editing the graphic of the current cell.
Public property | EditCellState | Gets a CvsAction object with an Execute()()()() method that opens the Cell State dialog.
Public property | EditCustomPrivileges | Gets a CvsAction object with an Execute()()()() method that opens the list of custom privileges dialog.
Public property | EditCustomViewSettings | Gets a CvsAction object with an Execute()()()() method that opens the Custom View Settings dialog, using the selected range of cells as the custom view range.
Public property | EditDateTimeSettings | Gets a CvsAction object with an Execute()()()() method that opens the Date Time Settings dialog.
Public property | EditDiscreteInputSettings | Gets a CvsAction object with an Execute()()()() method that opens the Discrete Input Settings dialog.
Public property | EditDiscreteOutputSettings | Gets a CvsAction object with an Execute()()()() method that opens the Discrete Output Settings dialog.
Public property | EditDiscreteSettings | Gets a CvsAction object with an Execute()()()() method that opens the Discrete Settings dialog.
Public property | EditEasyViewSettings | Gets a CvsAction object with an Execute()()()() method that opens the Custom View Settings dialog, using the selected range of cells as the custom view range.
Public property | EditFtpSettings | Gets a CvsAction object with an Execute()()()() method that opens the FTP Settings dialog.
Public property | EditHmiSettings | Gets a CvsAction object with an Execute()()()() method that opens the Hmi Settings dialog.
Public property | EditHostTableSettings | Gets a CvsAction object with an Execute()()()() method that opens the Host Table Settings dialog.
Public property | EditImageBuffers | Gets a CvsAction object with an Execute()()()() method that opens the Image Buffers dialog.
Public property | EditImageSettings | Gets a CvsAction object with an Execute()()()() method that opens the Image Settings dialog.
Public property | EditJobServerSettings | Gets a CvsAction object with an Execute()()()() method that opens the Job Server Settings dialog.
Public property | EditLicensing | Gets a CvsAction object with an Execute()()()() method that opens the Licensing dialog.
Public property | EditLightSettings | Gets a CvsAction object with an Execute()()()() method that opens the Light Settings dialog.
Public property | EditLineScanSettings | Gets a CvsAction object with an Execute()()()() method that opens the Line Scan Settings dialog.
Public property | EditNetworkSettings | Gets a CvsAction object with an Execute()()()() method that opens the Network Settings dialog.
Public property | EditSalesModelSettings |
Public property | EditSerialPort0Settings | Gets a CvsAction object with an Execute()()()() method that opens the Serial Port 0 Settings dialog.
Public property | EditSerialPort1Settings | Gets a CvsAction object with an Execute()()()() method that opens the Serial Port 0 Settings dialog.
Public property | EditStartupSettings | Gets a CvsAction object with an Execute()()()() method that opens the Startup Settings dialog.
Public property | EditUserAccessSettings | Gets a CvsAction object with an Execute()()()() method that opens the User List Settings dialog.
Public property | EditVisionViewViewSelection | Gets a CvsAction object with an Execute()()()() method that opens the VisionView Settings dialog.
Public property | ExportCells | Gets a CvsAction object with an Execute()()()() method that exports the current cell to a cell data file.
Public property | ExportSnippet | Gets a CvsAction object with an Execute()()()() method that exports the current cell to a cell data file.
Public property | Find | Opens the Find dialog.
Public property | FormatBold | Toggles the formatting of all cells in the selected range between Bold and non-Bold.
Public property | FormatCenter | Gets a CvsActionToggle object with an Execute()()()() method that toggles the formatting of all cells in the selected range between Center-aligned and non-Center-aligned (default).
Public property | FormatDecreaseDecimal | Gets a CvsAction object with an Execute()()()() method that decreases the number of decimal places in the formatting of all cells in the selected range.
Public property | FormatDecreaseFont | Gets a CvsAction object with an Execute()()()() method that decreases the font size in the formatting of all cells in the selected range.
Public property | FormatIncreaseDecimal | Gets a CvsAction object with an Execute()()()() method that increases the number of decimal places in the formatting of all cells in the selected range.
Public property | FormatIncreaseFont | Gets a CvsAction object with an Execute()()()() method that increases the font size in the formatting of all cells in the selected range.
Public property | FormatItalic | Toggles the formatting of all cells in the selected range between Italic and non-Italic.
Public property | FormatLeft | Gets a CvsActionToggle object with an Execute()()()() method that toggles the formatting of all cells in the selected range between Left-aligned and non-Left-aligned (default).
Public property | FormatRight | Gets a CvsActionToggle object with an Execute()()()() method that toggles the formatting of all cells in the selected range between Right-aligned and non-Right-aligned (default).
Public property | GoTo | Opens a dialog to prompt the user for a location and jumps to that cell
Public property | GoToFirstError | Changes the current (active) cell to the first precedent of the current cell that is in error. This action will have no effect if the current cell has no precedents in error.
Public property | HideColumns | Gets a CvsAction object with an Execute()()()() method that hides the columns of the selected range.
Public property | HideRows | Gets a CvsAction object with an Execute()()()() method that hides the rows of the selected range.
Public property | HideRowsOrColumns | Gets a CvsAction object with an Execute()()()() method that hides the rows or columns of the selected range depending on what is selected.
Public property | ImportCells | Gets a CvsAction object with an Execute()()()() method that imports a cell data file to the current cell.
Public property | ImportSnippet | Gets a CvsAction object with an Execute()()()() method that imports a snippet.
Public property | IncreaseGridOpacity | Gets a CvsAction object with an Execute()()()() method that increases the opacity of the grid.
Public property | InsertAbsoluteReference | Inserts a new absolute cell reference.
Public property | InsertCells | Gets a CvsAction object with an Execute()()()() method that inserts cells in the selected range, prompting the user for how to shift the remaining cells.
Public property | InsertCellsOrRowsOrColumns | Gets a CvsAction object with an Execute()()()() method that inserts new cells, rows or columns depending on what is selected.
Public property | InsertColumns | Gets a CvsAction object with an Execute()()()() method that inserts columns in the selected range, shifting the contents of existing columns to the right.
Public property | InsertComment | Gets a CvsAction object with an Execute()()()() method that inserts a comment for the selected cell, or edits an existing comment.
Public property | InsertEasyTag | Gets a CvsAction object with an Execute()()()() method that inserts an EasyTag for the selected cell, or edits an existing EasyTag.
Public property | InsertFunction | Inserts a function for the selected cell using the Insert Function dialog.
Public property | InsertOpcTag | Gets a CvsAction object with an Execute()()()() method that inserts an OPC tag for the selected cell, or edits an existing tag.
Public property | InsertRelativeReference | Inserts a new relative cell reference.
Public property | InsertRows | Gets a CvsAction object with an Execute()()()() method that inserts rows in the selected range, shifting the contents of existing rows downward.
Public property | IsRepeatingTriggerActive | Gets a value indicating if repeating trigger is active.
Public property | LiveAcquire | Gets a CvsActionToggle object with an Execute()()()() method that toggles the live acquisition mode of the In-Sight sensor.
Public property | ManualAcquire | Manually triggers an image acquisition.
Public property | MaximizeCellRegion | Maximizes the region to the size of the image. Rotation and curve will be reset to zero.
Public property | MoveDown | Moves the active cell down.
Public property | MoveLeft | Moves the active cell left.
Public property | MovePageDown | Moves the active cell one page downward.
Public property | MovePageUp | Moves the active cell one page upward.
Public property | MoveRight | Moves the active cell right.
Public property | MoveToFirstCell | Moves the active cell to the first cell in the spreadsheet.
Public property | MoveToLastCell | Moves the active cell to the last cell in the spreadsheet.
Public property | MoveToRowEnd | Moves the active cell to the end of the current row.
Public property | MoveToRowStart | Moves the active cell to the start of the current row.
Public property | MoveUp | Moves the active cell up.
Public property | NewJob | Prompts the user for confirmation and then creates a new 'empty' job.
Public property | NextImageOrientation | Advances the ImageOrientation property to the next setting.
Public property | OpenCellFormatDialog | Opens the cell format dialog.
Public property | OpenImage | Gets a CvsAction object with an Execute()()()() method that shows the open file dialog to open an existing image file.
Public property | OpenJob | Shows the open file dialog to open an existing job file.
Public property | OpenOverallPassFailDialog | Opens the Overall Pass Fail Cell Setup dialog.
Public property | OpenOverallPassFailDialogWithCurrentCell | Opens the Overall Pass Fail Cell Setup dialog using the display's current cell as the newly selected Job Pass Fail Cell.
Public property | OpenPageSetupDialog | Opens the print page setup dialog.
Public property | OpenPrintDialog | Opens the print dialog.
Public property | OpenPrintPreviewDialog | Opens the print preview dialog.
Public property | Paste | Pastes the contents of the clipboard into the selected range.
Public property | Play | Toggles the Playback mode of the Display control.
Public property | PlayFirst | Loads the first image from the playback buffer.
Public property | PlayLast | Loads the last image from the playback buffer.
Public property | PlayNext | Loads the next image from the playback buffer.
Public property | PlayPrevious | Loads the previous image from the playback buffer.
Public property | PrintNow | Gets a CvsAction object with an Execute()()()() method that prints the display using the current print settings, without prompting the user in any way.
Public property | ProfileJob | Gets a CvsAction object with an Execute()()()() method that opens the Profiler dialog.
Public property | ProtectJob | Gets a CvsAction object with an Execute()()()() method that opens the Protect Job dialog in order to protect or unprotect the job.
Public property | Record | Toggles the Record mode of the Display control.
Public property | RecordPlaybackOptions | Opens the Record / Playback Options dialog.
Public property | Redo | Redoes the last action that was undone.
Public property | RepeatingTrigger | Gets a CvsActionToggle object with an Execute()()()() method that toggles the repeating trigger mode of the In-Sight sensor.
Public property | ResetSensor | Resets the sensor.
Public property | SaveImageAs | Gets a CvsAction object with an Execute()()()() method that opens the Save As dialog to save the current image to a file.
Public property | SaveJob | Saves the job, opening the Save As dialog if the job has not previously been saved to or loaded from a sensor.
Public property | SaveJobAs | Opens the Save As dialog in order to save the job to a specific location.
Public property | SelectColumn | Selects an entire column.
Public property | SelectDown | Expands the selected range one row down.
Public property | SelectedFontName | Gets the font family name for the current cell. Sets the font family name for the selected range of cells.
Public property | SelectedFontSize | Gets the font size for the current cell. Sets the font size for the selected range of cells.
Public property | SelectLeft | Expands the selected range one column left.
Public property | SelectPageDown | Expands the selected range one page downward.
Public property | SelectPageUp | Expands the selected range one page upward.
Public property | SelectRight | Expands the selected range one column right.
Public property | SelectRow | Selects an entire row.
Public property | SelectToRowEnd | Expands the selection to the end of the row.
Public property | SelectToRowStart | Expands the selection to the start of the row.
Public property | SelectUp | Expands the selected range one row up.
Public property | SetColumnWidth | Gets a CvsAction object with an Execute()()()() method that prompts the user and sets the width of all columns in the selected range.
Public property | SetGridOpacity | Gets a CvsAction object with an Execute()()()() method that prompts the user and sets grid opacity to a specific value.
Public property | SetGridScale | Gets a CvsAction object with an Execute()()()() method that prompts the user and sets grid scale (sheet zoom) to a specific value.
Public property | SetRamDiskSize | Gets a CvsAction object with an Execute()()()() method that prompts the user and sets the RAM disk size to a specific value.
Public property | SetRowHeight | Gets a CvsAction object with an Execute()()()() method that pPrompts the user and sets the height of all rows in the selected range.
Public property | SetTextScaleMode | Callback for the Text Scale Mode button
Public property | ShowCustomView | Toggles the ShowCustomView property in order to switch between the custom view and the normal (job editing) view.
Public property | ShowDependencyErrorsOnly | Toggles the ShowDependencyErrorsOnly property in order to switch between showing all dependencies and errors only.
Public property | ShowDependencyLevelsDecrease | Decreases the displayed dependency levels.
Public property | ShowDependencyLevelsIncrease | Increases the displayed dependency levels.
Public property | ShowDependencyLevelsReset | Sets the displayed dependency levels to zero.
Public property | ShowEntireSheet | Shows or hides the dialog cells in the main spreadsheet area.
Public property | ShowGraphics | Toggles the ShowGraphics property in order to show or hide the spreadsheet graphics.
Public property | ShowGrid | Toggles the ShowGrid property in order to show or hide the spreadsheet grid.
Public property | ShowImageSaturation | Toggles the ShowImageSaturation property in order to show the saturated areas of the image in color.
Public property | SoftOnline | Toggles the soft-online state of the In-Sight sensor, first prompting the user if the ConfirmOnlineTransitions property is true.
Public property | SynchronizedInspectionParameters | Displays the inspection synchronizer parameters dialog.
Public property | Undo | Undoes the last action that was done.
Public property | UnhideColumns | Gets a CvsAction object with an Execute()()()() method that unhides all columns within the selected range.
Public property | UnhideRows | Gets a CvsAction object with an Execute()()()() method that unhides all rows within the selected range.
Public property | UnhideRowsOrColumns | Gets a CvsAction object with an Execute()()()() method that unhides the rows or columns of the selected range depending on what is selected.
Public property | ZoomGrid1To1 | Sets the GridScale to 1.0 if a single cell is selected, or otherwise zooms the grid to fit the selected range.
Public property | ZoomGridIn | Increases the GridScale (sheet zoom).
Public property | ZoomGridOut | Decreases the GridScale (sheet zoom).
Public property | ZoomImage1To1 | Sets the display's ImageZoomMode to None to disable automatic zooming of the image, and then sets the ImageScale to 1.0.
Public property | ZoomImageIn | Sets the display's ImageZoomMode to None to disable automatic zooming of the image, and then increases the ImageScale.
Public property | ZoomImageOut | Sets the display's ImageZoomMode to None to disable automatic zooming of the image, and and then decreases the ImageScale.
Public property | ZoomImageToFill | Gets a CvsActionToggle object with an Execute()()()() method that toggles the display's ImageZoomMode between None and Fill.
Public property | ZoomImageToFit | Gets a CvsActionToggle object with an Execute()()()() method that toggles the display's ImageZoomMode between None and Fit.
Public property | ZoomImageToMax | Gets a CvsAction object with an Execute()()()() method that sets the display's ImageZoomMode to None to disable automatic zooming of the image, and then sets the ImageScale to 20.

See Also

CvsInSightDisplayEdit Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.AcceptChanges Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..AcceptChanges Property
CvsInSightDisplayEdit Class See Also Send Feedback
Accepts changes made in the current editing mode.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction AcceptChanges { get; }
Visual Basic
Public ReadOnly Property AcceptChanges As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • the display is in an editing state (State = EditingCellExpression, EditingReferenceRanges, DialogEditingReferenceRanges, EditingGraphics or EditingCellValue).
  • The edited expression, reference ranges, graphic or value can be accepted.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.AutoFitColumns Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..AutoFitColumns Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that resizes the column(s) of the selected range so that they are just wide enough to show the contents of the cells in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction AutoFitColumns { get; }
Visual Basic
Public ReadOnly Property AutoFitColumns As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog, OR the sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.AutoFitRows Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..AutoFitRows Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that resizes the rows(s) of the selected range so that they are just high enough to show the contents of the cells in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction AutoFitRows { get; }
Visual Basic
Public ReadOnly Property AutoFitRows As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions ).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog, OR the sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.CancelChanges Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..CancelChanges Property
CvsInSightDisplayEdit Class See Also Send Feedback
Cancels changes made in the current editing mode.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction CancelChanges { get; }
Visual Basic
Public ReadOnly Property CancelChanges As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and the display is in an editing state (State = EditingCellExpression, EditingReferenceRanges, DialogEditingReferenceRanges, EditingGraphics or EditingCellValue).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ClearAll Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ClearAll Property
CvsInSightDisplayEdit Class See Also Send Feedback
Clears the contents, comments, formats, and OPC tags of cells in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ClearAll { get; }
Visual Basic
Public ReadOnly Property ClearAll As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions ).
  • The grid is shown (ShowGrid = true).
  • The selected range does not contain an AcquireImage cell.
  • The job is not protected, OR the selected range does not contain locked cells.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ClearComments Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ClearComments Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that clears the comments of cells in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ClearComments { get; }
Visual Basic
Public ReadOnly Property ClearComments As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions ).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ClearContents Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ClearContents Property
CvsInSightDisplayEdit Class See Also Send Feedback
Clears the contents of cells in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ClearContents { get; }
Visual Basic
Public ReadOnly Property ClearContents As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions ).
  • The grid is shown (ShowGrid = true).
  • The selected range does not contain an AcquireImage cell.
  • The job is not protected, OR the selected range does not contain locked cells.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ClearEasyTags Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ClearEasyTags Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that clears the EasyTags of cells in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ClearEasyTags { get; }
Visual Basic
Public ReadOnly Property ClearEasyTags As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).
  • The emulator is running in DEBUG.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ClearFormats Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ClearFormats Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that clears the formats of cells in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ClearFormats { get; }
Visual Basic
Public ReadOnly Property ClearFormats As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ClearOpcTags Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ClearOpcTags Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that clears the OPC tags of cells in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ClearOpcTags { get; }
Visual Basic
Public ReadOnly Property ClearOpcTags As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The job is not protected, OR the selected range does not contain locked cells.
  • The sensor's firmware supports OPC tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ClearPermissions Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ClearPermissions Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that clears the permissions of cells in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ClearPermissions { get; }
Visual Basic
Public ReadOnly Property ClearPermissions As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The job is not protected, OR the selected range does not contain locked cells.
  • The sensor's firmware supports OPC tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ConvertToEasyTags Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ConvertToEasyTags Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that converts all appropriate comments to EasyTags. This also strips off the "EE" (if present).

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ConvertToEasyTags { get; }
Visual Basic
Public ReadOnly Property ConvertToEasyTags As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when the following condition is true:

  • The program is running in DEBUG mode.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.Copy Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..Copy Property
CvsInSightDisplayEdit Class See Also Send Feedback
Copies all cells in the selected range to the clipboard.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction Copy { get; }
Visual Basic
Public ReadOnly Property Copy As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The selected range does not contain an AcquireImage cell.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.CopyBitmap Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..CopyBitmap Property
CvsInSightDisplayEdit Class See Also Send Feedback
Copies a bitmap of the display contents to the clipboard.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction CopyBitmap { get; }
Visual Basic
Public ReadOnly Property CopyBitmap As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.CreateNewCustomPrivilege Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..CreateNewCustomPrivilege Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the User List Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction CreateNewCustomPrivilege { get; }
Visual Basic
Public ReadOnly Property CreateNewCustomPrivilege As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.Cut Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..Cut Property
CvsInSightDisplayEdit Class See Also Send Feedback
Cuts all cells in the selected range to the clipboard.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction Cut { get; }
Visual Basic
Public ReadOnly Property Cut As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The selected range does not contain an AcquireImage cell.
  • The job is not protected, OR the selected range does not contain locked cells.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.CycleGraphicColor Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..CycleGraphicColor Property
CvsInSightDisplayEdit Class See Also Send Feedback
Cycles the displayed color of all input graphics

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction CycleGraphicColor { get; }
Visual Basic
Public ReadOnly Property CycleGraphicColor As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.DecreaseGridOpacity Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..DecreaseGridOpacity Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that decreases the opacity of the grid.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction DecreaseGridOpacity { get; }
Visual Basic
Public ReadOnly Property DecreaseGridOpacity As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The grid opacity is greater than 0.0 (GridOpacity > 0.0).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.DeleteCellsOrRowsOrColumns Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..DeleteCellsOrRowsOrColumns Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that deletes cells, rows or columns depending on what is selected.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction DeleteCellsOrRowsOrColumns { get; }
Visual Basic
Public ReadOnly Property DeleteCellsOrRowsOrColumns As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The selected range does not contain an AcquireImage cell.
  • The job is not protected.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.DialogUndoOnCancel Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..DialogUndoOnCancel Property
CvsInSightDisplayEdit Class See Also Send Feedback
Get and set Dialog Undo on Cancel True if the "Undo On Dialog Cancel" is enabled, which means when a dialog is cancelled it will perform an "undo" to all dialog cells, which is the current behavior. False if the "Undo On Dialog Cancel" is disabled, which means it won't perform "Undo" to the dialog cells anymore, which is a new behavior.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle DialogUndoOnCancel { get; }
Visual Basic
Public ReadOnly Property DialogUndoOnCancel As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EasyBuilderPlaybackOptions Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EasyBuilderPlaybackOptions Property
CvsInSightDisplayEdit Class See Also Send Feedback
Opens the Record / Playback Options dialog. This version forces the Playback tab to start visible.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EasyBuilderPlaybackOptions { get; }
Visual Basic
Public ReadOnly Property EasyBuilderPlaybackOptions As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The job is not protected, OR the selected range does not contain locked cells.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EasyBuilderRecordOptions Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EasyBuilderRecordOptions Property
CvsInSightDisplayEdit Class See Also Send Feedback
Opens the Record / Playback Options dialog. This version forces the Record tab to start visible.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EasyBuilderRecordOptions { get; }
Visual Basic
Public ReadOnly Property EasyBuilderRecordOptions As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The job is not protected, OR the selected range does not contain locked cells.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditActiveCellsLimit Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditActiveCellsLimit Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the EditActiveCellsLimit dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditActiveCellsLimit { get; }
Visual Basic
Public ReadOnly Property EditActiveCellsLimit As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The sensor version is 4.2 or higher.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditAuditMessageSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditAuditMessageSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the AuditTrailSettings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditAuditMessageSettings { get; }
Visual Basic
Public ReadOnly Property EditAuditMessageSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The sensor version is 4.2 or higher.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditCcLinkSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditCcLinkSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the CC-Link Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditCcLinkSettings { get; }
Visual Basic
Public ReadOnly Property EditCcLinkSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • Serial Port 1 is supported.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditCellExpression Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditCellExpression Property
CvsInSightDisplayEdit Class See Also Send Feedback
Begins editing the expression of the current cell, using the property sheet if applicable or the in-place formula text box otherwise.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditCellExpression { get; }
Visual Basic
Public ReadOnly Property EditCellExpression As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The job is not protected, OR the selected range does not contain locked cells.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditCellExpressionInPlace Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditCellExpressionInPlace Property
CvsInSightDisplayEdit Class See Also Send Feedback
Begins editing the expression of the current cell using the in-place formula text box.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditCellExpressionInPlace { get; }
Visual Basic
Public ReadOnly Property EditCellExpressionInPlace As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The job is not protected, OR the selected range does not contain locked cells.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditCellGraphic Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditCellGraphic Property
CvsInSightDisplayEdit Class See Also Send Feedback
Begins editing the graphic of the current cell.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditCellGraphic { get; }
Visual Basic
Public ReadOnly Property EditCellGraphic As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The current cell has a default graphic.
  • The job is not protected, OR the selected range does not contain locked cells.

This action will be disabled until a default graphic has been received from the sensor for the current cell. It may not be enabled immediately after changing the CurrentCell property because it takes time for the sensor to receive the new current cell location and transmit the graphic back to the PC. An application that uses this editing action directly should check its Enabled property to make sure that updated results have been received from the sensor, and if necessary call DoEvents()()()() in order to process new results from the sensor until the editable graphic has been received.

This action will change the State property to EditingGraphics while the graphic is being edited, and it will change back to Normal when the user is finished editing the graphic.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditCellState Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditCellState Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Cell State dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditCellState { get; }
Visual Basic
Public ReadOnly Property EditCellState As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The job is not protected, OR the selected range does not contain locked cells.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditCustomPrivileges Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditCustomPrivileges Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the list of custom privileges dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditCustomPrivileges { get; }
Visual Basic
Public ReadOnly Property EditCustomPrivileges As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditCustomViewSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditCustomViewSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Custom View Settings dialog, using the selected range of cells as the custom view range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditCustomViewSettings { get; }
Visual Basic
Public ReadOnly Property EditCustomViewSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditDateTimeSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditDateTimeSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Date Time Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditDateTimeSettings { get; }
Visual Basic
Public ReadOnly Property EditDateTimeSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • SNTP is supported by the sensor.
  • The sensor is not a PC.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditDiscreteInputSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditDiscreteInputSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Discrete Input Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditDiscreteInputSettings { get; }
Visual Basic
Public ReadOnly Property EditDiscreteInputSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The sensor is not a PC.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditDiscreteOutputSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditDiscreteOutputSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Discrete Output Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditDiscreteOutputSettings { get; }
Visual Basic
Public ReadOnly Property EditDiscreteOutputSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The sensor is not a PC.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditDiscreteSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditDiscreteSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Discrete Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditDiscreteSettings { get; }
Visual Basic
Public ReadOnly Property EditDiscreteSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The sensor is not a PC.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditEasyViewSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditEasyViewSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Custom View Settings dialog, using the selected range of cells as the custom view range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditEasyViewSettings { get; }
Visual Basic
Public ReadOnly Property EditEasyViewSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditFtpSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditFtpSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the FTP Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditFtpSettings { get; }
Visual Basic
Public ReadOnly Property EditFtpSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditHmiSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditHmiSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Hmi Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditHmiSettings { get; }
Visual Basic
Public ReadOnly Property EditHmiSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The sensor version is 4.9 or higher.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditHostTableSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditHostTableSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Host Table Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditHostTableSettings { get; }
Visual Basic
Public ReadOnly Property EditHostTableSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditImageBuffers Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditImageBuffers Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Image Buffers dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditImageBuffers { get; }
Visual Basic
Public ReadOnly Property EditImageBuffers As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The sensor version is 4.6 or higher.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditImageSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditImageSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Image Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditImageSettings { get; }
Visual Basic
Public ReadOnly Property EditImageSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The sensor version is 2.90 or higher.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditJobServerSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditJobServerSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Job Server Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditJobServerSettings { get; }
Visual Basic
Public ReadOnly Property EditJobServerSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The sensor version is 4.9.3 or higher.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditLicensing Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditLicensing Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Licensing dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditLicensing { get; }
Visual Basic
Public ReadOnly Property EditLicensing As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The spreadsheet is visible.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditLightSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditLightSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Light Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditLightSettings { get; }
Visual Basic
Public ReadOnly Property EditLightSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The sensor version is 2.90 or higher.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditLineScanSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditLineScanSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Line Scan Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditLineScanSettings { get; }
Visual Basic
Public ReadOnly Property EditLineScanSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditNetworkSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditNetworkSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Network Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditNetworkSettings { get; }
Visual Basic
Public ReadOnly Property EditNetworkSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditSalesModelSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditSalesModelSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditSalesModelSettings { get; }
Visual Basic
Public ReadOnly Property EditSalesModelSettings As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditSerialPort0Settings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditSerialPort0Settings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Serial Port 0 Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditSerialPort0Settings { get; }
Visual Basic
Public ReadOnly Property EditSerialPort0Settings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • Serial Port 0 is supported.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditSerialPort1Settings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditSerialPort1Settings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Serial Port 0 Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditSerialPort1Settings { get; }
Visual Basic
Public ReadOnly Property EditSerialPort1Settings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • Serial Port 1 is supported.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditStartupSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditStartupSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Startup Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditStartupSettings { get; }
Visual Basic
Public ReadOnly Property EditStartupSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditUserAccessSettings Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditUserAccessSettings Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the User List Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditUserAccessSettings { get; }
Visual Basic
Public ReadOnly Property EditUserAccessSettings As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EditVisionViewViewSelection Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EditVisionViewViewSelection Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the VisionView Settings dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction EditVisionViewViewSelection { get; }
Visual Basic
Public ReadOnly Property EditVisionViewViewSelection As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ExportCells Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ExportCells Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that exports the current cell to a cell data file.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ExportCells { get; }
Visual Basic
Public ReadOnly Property ExportCells As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ExportSnippet Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ExportSnippet Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that exports the current cell to a cell data file.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ExportSnippet { get; }
Visual Basic
Public ReadOnly Property ExportSnippet As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.Find Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..Find Property
CvsInSightDisplayEdit Class See Also Send Feedback
Opens the Find dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction Find { get; }
Visual Basic
Public ReadOnly Property Find As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.FormatBold Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..FormatBold Property
CvsInSightDisplayEdit Class See Also Send Feedback
Toggles the formatting of all cells in the selected range between Bold and non-Bold.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle FormatBold { get; }
Visual Basic
Public ReadOnly Property FormatBold As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.FormatCenter Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..FormatCenter Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsActionToggle object with an Execute()()()() method that toggles the formatting of all cells in the selected range between Center-aligned and non-Center-aligned (default).

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle FormatCenter { get; }
Visual Basic
Public ReadOnly Property FormatCenter As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.FormatDecreaseDecimal Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..FormatDecreaseDecimal Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that decreases the number of decimal places in the formatting of all cells in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction FormatDecreaseDecimal { get; }
Visual Basic
Public ReadOnly Property FormatDecreaseDecimal As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.FormatDecreaseFont Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..FormatDecreaseFont Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that decreases the font size in the formatting of all cells in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction FormatDecreaseFont { get; }
Visual Basic
Public ReadOnly Property FormatDecreaseFont As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.FormatIncreaseDecimal Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..FormatIncreaseDecimal Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that increases the number of decimal places in the formatting of all cells in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction FormatIncreaseDecimal { get; }
Visual Basic
Public ReadOnly Property FormatIncreaseDecimal As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.FormatIncreaseFont Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..FormatIncreaseFont Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that increases the font size in the formatting of all cells in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction FormatIncreaseFont { get; }
Visual Basic
Public ReadOnly Property FormatIncreaseFont As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.FormatItalic Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..FormatItalic Property
CvsInSightDisplayEdit Class See Also Send Feedback
Toggles the formatting of all cells in the selected range between Italic and non-Italic.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle FormatItalic { get; }
Visual Basic
Public ReadOnly Property FormatItalic As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.FormatLeft Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..FormatLeft Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsActionToggle object with an Execute()()()() method that toggles the formatting of all cells in the selected range between Left-aligned and non-Left-aligned (default).

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle FormatLeft { get; }
Visual Basic
Public ReadOnly Property FormatLeft As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.FormatRight Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..FormatRight Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsActionToggle object with an Execute()()()() method that toggles the formatting of all cells in the selected range between Right-aligned and non-Right-aligned (default).

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle FormatRight { get; }
Visual Basic
Public ReadOnly Property FormatRight As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.GoTo Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..GoTo Property
CvsInSightDisplayEdit Class See Also Send Feedback
Opens a dialog to prompt the user for a location and jumps to that cell

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction GoTo { get; }
Visual Basic
Public ReadOnly Property GoTo As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.GoToFirstError Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..GoToFirstError Property
CvsInSightDisplayEdit Class See Also Send Feedback
Changes the current (active) cell to the first precedent of the current cell that is in error. This action will have no effect if the current cell has no precedents in error.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction GoToFirstError { get; }
Visual Basic
Public ReadOnly Property GoToFirstError As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The display is in the normal state (State = Normal) or showing a user dialog (State = Dialog).
  • The grid is shown (ShowGrid = true).
  • The normal (non-custom) view is shown (ShowCustomView = false).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.HideColumns Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..HideColumns Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that hides the columns of the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction HideColumns { get; }
Visual Basic
Public ReadOnly Property HideColumns As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog, OR the sensor's firmware supports formatting tags (revision 2.8 or later).
  • One or more columns are selected.
  • Hiding the selected columns would not result in all columns being hidden.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.HideRows Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..HideRows Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that hides the rows of the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction HideRows { get; }
Visual Basic
Public ReadOnly Property HideRows As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog, OR the sensor's firmware supports formatting tags (revision 2.8 or later).
  • One or more rows are selected.
  • Hiding the selected rows would not result in all rows being hidden.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.HideRowsOrColumns Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..HideRowsOrColumns Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that hides the rows or columns of the selected range depending on what is selected.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction HideRowsOrColumns { get; }
Visual Basic
Public ReadOnly Property HideRowsOrColumns As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and when the HideRows action or the HideColumns action is enabled.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ImportCells Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ImportCells Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that imports a cell data file to the current cell.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ImportCells { get; }
Visual Basic
Public ReadOnly Property ImportCells As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ImportSnippet Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ImportSnippet Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that imports a snippet.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ImportSnippet { get; }
Visual Basic
Public ReadOnly Property ImportSnippet As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.IncreaseGridOpacity Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..IncreaseGridOpacity Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that increases the opacity of the grid.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction IncreaseGridOpacity { get; }
Visual Basic
Public ReadOnly Property IncreaseGridOpacity As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The grid opacity is less than 1.0 (GridOpacity < 1.0).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.InsertAbsoluteReference Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..InsertAbsoluteReference Property
CvsInSightDisplayEdit Class See Also Send Feedback
Inserts a new absolute cell reference.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction InsertAbsoluteReference { get; }
Visual Basic
Public ReadOnly Property InsertAbsoluteReference As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The user is editing an expression and a cell reference is valid at the current location, OR the display is in the normal state and the current cell is empty or contains a simple cell reference.
  • The job is not protected, OR the selected range does not contain locked cells.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.InsertCells Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..InsertCells Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that inserts cells in the selected range, prompting the user for how to shift the remaining cells.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction InsertCells { get; }
Visual Basic
Public ReadOnly Property InsertCells As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The selected range does not contain an AcquireImage cell.
  • The job is not protected.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.InsertCellsOrRowsOrColumns Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..InsertCellsOrRowsOrColumns Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that inserts new cells, rows or columns depending on what is selected.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction InsertCellsOrRowsOrColumns { get; }
Visual Basic
Public ReadOnly Property InsertCellsOrRowsOrColumns As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The selected range does not contain an AcquireImage cell.
  • The job is not protected.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.InsertColumns Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..InsertColumns Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that inserts columns in the selected range, shifting the contents of existing columns to the right.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction InsertColumns { get; }
Visual Basic
Public ReadOnly Property InsertColumns As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The first column of the selected range is greater than zero (column A).
  • The selected range does not contain an entire row.
  • The selected range does not contain an AcquireImage cell.
  • The job is not protected.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.InsertComment Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..InsertComment Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that inserts a comment for the selected cell, or edits an existing comment.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction InsertComment { get; }
Visual Basic
Public ReadOnly Property InsertComment As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.InsertEasyTag Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..InsertEasyTag Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that inserts an EasyTag for the selected cell, or edits an existing EasyTag.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction InsertEasyTag { get; }
Visual Basic
Public ReadOnly Property InsertEasyTag As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).
  • The program is running in DEBUG mode.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.InsertFunction Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..InsertFunction Property
CvsInSightDisplayEdit Class See Also Send Feedback
Inserts a function for the selected cell using the Insert Function dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction InsertFunction { get; }
Visual Basic
Public ReadOnly Property InsertFunction As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state or editing a cell expression (State = Normal or EditingCellExpression).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The job is not protected, OR the selected range does not contain locked cells.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.InsertOpcTag Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..InsertOpcTag Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that inserts an OPC tag for the selected cell, or edits an existing tag.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction InsertOpcTag { get; }
Visual Basic
Public ReadOnly Property InsertOpcTag As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The current cell is not empty.
  • The job is not protected, OR the selected range does not contain locked cells.
  • The sensor's firmware supports OPC tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.InsertRelativeReference Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..InsertRelativeReference Property
CvsInSightDisplayEdit Class See Also Send Feedback
Inserts a new relative cell reference.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction InsertRelativeReference { get; }
Visual Basic
Public ReadOnly Property InsertRelativeReference As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The user is editing an expression and a cell reference is valid at the current location, OR the display is in the normal state and the current cell is empty or contains a simple cell reference.
  • The job is not protected, OR the selected range does not contain locked cells.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.InsertRows Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..InsertRows Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that inserts rows in the selected range, shifting the contents of existing rows downward.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction InsertRows { get; }
Visual Basic
Public ReadOnly Property InsertRows As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The first row of the selected range is greater than zero.
  • The selected range does not contain an entire column.
  • The display is not part of a user dialog.
  • The job is not protected.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.IsRepeatingTriggerActive Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..IsRepeatingTriggerActive Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a value indicating if repeating trigger is active.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool IsRepeatingTriggerActive { get; }
Visual Basic
Public ReadOnly Property IsRepeatingTriggerActive As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.LiveAcquire Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..LiveAcquire Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsActionToggle object with an Execute()()()() method that toggles the live acquisition mode of the In-Sight sensor.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle LiveAcquire { get; }
Visual Basic
Public ReadOnly Property LiveAcquire As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ManualAcquire Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ManualAcquire Property
CvsInSightDisplayEdit Class See Also Send Feedback
Manually triggers an image acquisition.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ManualAcquire { get; }
Visual Basic
Public ReadOnly Property ManualAcquire As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line, OR the job is configured to allow manual trigger while on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.MaximizeCellRegion Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..MaximizeCellRegion Property
CvsInSightDisplayEdit Class See Also Send Feedback
Maximizes the region to the size of the image. Rotation and curve will be reset to zero.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction MaximizeCellRegion { get; }
Visual Basic
Public ReadOnly Property MaximizeCellRegion As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The current cell has a default graphic.
  • The job is not protected, OR the selected range does not contain locked cells.

This action will be disabled until a default graphic has been received from the sensor for the current cell. It may not be enabled immediately after changing the CurrentCell property because it takes time for the sensor to receive the new current cell location and transmit the graphic back to the PC. An application that uses this editing action directly should check its Enabled property to make sure that updated results have been received from the sensor, and if necessary call DoEvents()()()() in order to process new results from the sensor until the editable graphic has been received.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.MoveDown Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..MoveDown Property
CvsInSightDisplayEdit Class See Also Send Feedback
Moves the active cell down.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction MoveDown { get; }
Visual Basic
Public ReadOnly Property MoveDown As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.MoveLeft Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..MoveLeft Property
CvsInSightDisplayEdit Class See Also Send Feedback
Moves the active cell left.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction MoveLeft { get; }
Visual Basic
Public ReadOnly Property MoveLeft As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.MovePageDown Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..MovePageDown Property
CvsInSightDisplayEdit Class See Also Send Feedback
Moves the active cell one page downward.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction MovePageDown { get; }
Visual Basic
Public ReadOnly Property MovePageDown As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.MovePageUp Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..MovePageUp Property
CvsInSightDisplayEdit Class See Also Send Feedback
Moves the active cell one page upward.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction MovePageUp { get; }
Visual Basic
Public ReadOnly Property MovePageUp As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.MoveRight Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..MoveRight Property
CvsInSightDisplayEdit Class See Also Send Feedback
Moves the active cell right.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction MoveRight { get; }
Visual Basic
Public ReadOnly Property MoveRight As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.MoveToFirstCell Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..MoveToFirstCell Property
CvsInSightDisplayEdit Class See Also Send Feedback
Moves the active cell to the first cell in the spreadsheet.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction MoveToFirstCell { get; }
Visual Basic
Public ReadOnly Property MoveToFirstCell As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.MoveToLastCell Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..MoveToLastCell Property
CvsInSightDisplayEdit Class See Also Send Feedback
Moves the active cell to the last cell in the spreadsheet.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction MoveToLastCell { get; }
Visual Basic
Public ReadOnly Property MoveToLastCell As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.MoveToRowEnd Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..MoveToRowEnd Property
CvsInSightDisplayEdit Class See Also Send Feedback
Moves the active cell to the end of the current row.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction MoveToRowEnd { get; }
Visual Basic
Public ReadOnly Property MoveToRowEnd As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.MoveToRowStart Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..MoveToRowStart Property
CvsInSightDisplayEdit Class See Also Send Feedback
Moves the active cell to the start of the current row.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction MoveToRowStart { get; }
Visual Basic
Public ReadOnly Property MoveToRowStart As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.MoveUp Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..MoveUp Property
CvsInSightDisplayEdit Class See Also Send Feedback
Moves the active cell up.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction MoveUp { get; }
Visual Basic
Public ReadOnly Property MoveUp As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.NewJob Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..NewJob Property
CvsInSightDisplayEdit Class See Also Send Feedback
Prompts the user for confirmation and then creates a new 'empty' job.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction NewJob { get; }
Visual Basic
Public ReadOnly Property NewJob As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.NextImageOrientation Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..NextImageOrientation Property
CvsInSightDisplayEdit Class See Also Send Feedback
Advances the ImageOrientation property to the next setting.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction NextImageOrientation { get; }
Visual Basic
Public ReadOnly Property NextImageOrientation As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and the following condition is true:

  • The user has appropriate access permissions defined in CvsPermissionDefinitions.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.OpenCellFormatDialog Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..OpenCellFormatDialog Property
CvsInSightDisplayEdit Class See Also Send Feedback
Opens the cell format dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction OpenCellFormatDialog { get; }
Visual Basic
Public ReadOnly Property OpenCellFormatDialog As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.OpenImage Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..OpenImage Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that shows the open file dialog to open an existing image file.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction OpenImage { get; }
Visual Basic
Public ReadOnly Property OpenImage As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The user has FTP read access to the sensor.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.OpenJob Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..OpenJob Property
CvsInSightDisplayEdit Class See Also Send Feedback
Shows the open file dialog to open an existing job file.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction OpenJob { get; }
Visual Basic
Public ReadOnly Property OpenJob As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The user has FTP read access to the sensor.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.OpenOverallPassFailDialog Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..OpenOverallPassFailDialog Property
CvsInSightDisplayEdit Class See Also Send Feedback
Opens the Overall Pass Fail Cell Setup dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction OpenOverallPassFailDialog { get; }
Visual Basic
Public ReadOnly Property OpenOverallPassFailDialog As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports the overall pass fail cell (revision 4.1 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.OpenOverallPassFailDialogWithCurrentCell Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..OpenOverallPassFailDialogWithCurrentCell Property
CvsInSightDisplayEdit Class See Also Send Feedback
Opens the Overall Pass Fail Cell Setup dialog using the display's current cell as the newly selected Job Pass Fail Cell.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction OpenOverallPassFailDialogWithCurrentCell { get; }
Visual Basic
Public ReadOnly Property OpenOverallPassFailDialogWithCurrentCell As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The sensor's firmware supports the overall pass fail cell (revision 4.1 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.OpenPageSetupDialog Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..OpenPageSetupDialog Property
CvsInSightDisplayEdit Class See Also Send Feedback
Opens the print page setup dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction OpenPageSetupDialog { get; }
Visual Basic
Public ReadOnly Property OpenPageSetupDialog As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and the display is in the normal state (State = Normal).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.OpenPrintDialog Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..OpenPrintDialog Property
CvsInSightDisplayEdit Class See Also Send Feedback
Opens the print dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction OpenPrintDialog { get; }
Visual Basic
Public ReadOnly Property OpenPrintDialog As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and the display is in the normal state (State = Normal).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.OpenPrintPreviewDialog Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..OpenPrintPreviewDialog Property
CvsInSightDisplayEdit Class See Also Send Feedback
Opens the print preview dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction OpenPrintPreviewDialog { get; }
Visual Basic
Public ReadOnly Property OpenPrintPreviewDialog As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is not available in COM/ActiveX applications.

This action is enabled when its Suppressed property is false and the display is in the normal state (State = Normal).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.Paste Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..Paste Property
CvsInSightDisplayEdit Class See Also Send Feedback
Pastes the contents of the clipboard into the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction Paste { get; }
Visual Basic
Public ReadOnly Property Paste As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The range to be pasted does not contain an AcquireImage cell.
  • The job is not protected, OR the selected range does not contain locked cells and the size of the selected range is equal to or greater than the size of the cell range on the clipboard.
  • The clipboard contains content that can be pasted into cells.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.Play Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..Play Property
CvsInSightDisplayEdit Class See Also Send Feedback
Toggles the Playback mode of the Display control.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle Play { get; }
Visual Basic
Public ReadOnly Property Play As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.PlayFirst Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..PlayFirst Property
CvsInSightDisplayEdit Class See Also Send Feedback
Loads the first image from the playback buffer.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction PlayFirst { get; }
Visual Basic
Public ReadOnly Property PlayFirst As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.PlayLast Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..PlayLast Property
CvsInSightDisplayEdit Class See Also Send Feedback
Loads the last image from the playback buffer.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction PlayLast { get; }
Visual Basic
Public ReadOnly Property PlayLast As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.PlayNext Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..PlayNext Property
CvsInSightDisplayEdit Class See Also Send Feedback
Loads the next image from the playback buffer.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction PlayNext { get; }
Visual Basic
Public ReadOnly Property PlayNext As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.PlayPrevious Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..PlayPrevious Property
CvsInSightDisplayEdit Class See Also Send Feedback
Loads the previous image from the playback buffer.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction PlayPrevious { get; }
Visual Basic
Public ReadOnly Property PlayPrevious As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.PrintNow Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..PrintNow Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that prints the display using the current print settings, without prompting the user in any way.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction PrintNow { get; }
Visual Basic
Public ReadOnly Property PrintNow As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ProfileJob Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ProfileJob Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Profiler dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ProfileJob { get; }
Visual Basic
Public ReadOnly Property ProfileJob As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ProtectJob Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ProtectJob Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Protect Job dialog in order to protect or unprotect the job.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ProtectJob { get; }
Visual Basic
Public ReadOnly Property ProtectJob As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.Record Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..Record Property
CvsInSightDisplayEdit Class See Also Send Feedback
Toggles the Record mode of the Display control.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle Record { get; }
Visual Basic
Public ReadOnly Property Record As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.RecordPlaybackOptions Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..RecordPlaybackOptions Property
CvsInSightDisplayEdit Class See Also Send Feedback
Opens the Record / Playback Options dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction RecordPlaybackOptions { get; }
Visual Basic
Public ReadOnly Property RecordPlaybackOptions As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The job is not protected, OR the selected range does not contain locked cells.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.Redo Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..Redo Property
CvsInSightDisplayEdit Class See Also Send Feedback
Redoes the last action that was undone.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction Redo { get; }
Visual Basic
Public ReadOnly Property Redo As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The display is in the normal state (State = Normal).
  • The sensor's firmware supports undo and redo operations (revision 2.8 or later).
  • An action has been undone that can be redone.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.RepeatingTrigger Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..RepeatingTrigger Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsActionToggle object with an Execute()()()() method that toggles the repeating trigger mode of the In-Sight sensor.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle RepeatingTrigger { get; }
Visual Basic
Public ReadOnly Property RepeatingTrigger As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not live or on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ResetSensor Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ResetSensor Property
CvsInSightDisplayEdit Class See Also Send Feedback
Resets the sensor.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ResetSensor { get; }
Visual Basic
Public ReadOnly Property ResetSensor As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SaveImageAs Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SaveImageAs Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that opens the Save As dialog to save the current image to a file.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SaveImageAs { get; }
Visual Basic
Public ReadOnly Property SaveImageAs As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • Live acquisition is not active.
  • The user has FTP write access to the sensor.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SaveJob Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SaveJob Property
CvsInSightDisplayEdit Class See Also Send Feedback
Saves the job, opening the Save As dialog if the job has not previously been saved to or loaded from a sensor.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SaveJob { get; }
Visual Basic
Public ReadOnly Property SaveJob As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • Live acquisition is not active.
  • The user has FTP write access to the sensor.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SaveJobAs Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SaveJobAs Property
CvsInSightDisplayEdit Class See Also Send Feedback
Opens the Save As dialog in order to save the job to a specific location.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SaveJobAs { get; }
Visual Basic
Public ReadOnly Property SaveJobAs As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • Live acquisition is not active.
  • The user has FTP write access to the sensor.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SelectColumn Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SelectColumn Property
CvsInSightDisplayEdit Class See Also Send Feedback
Selects an entire column.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectColumn { get; }
Visual Basic
Public ReadOnly Property SelectColumn As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SelectDown Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SelectDown Property
CvsInSightDisplayEdit Class See Also Send Feedback
Expands the selected range one row down.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectDown { get; }
Visual Basic
Public ReadOnly Property SelectDown As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SelectedFontName Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SelectedFontName Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets the font family name for the current cell. Sets the font family name for the selected range of cells.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string SelectedFontName { get; set; }
Visual Basic
Public Property SelectedFontName As String
    Get
    Set

Property Value

Type: String

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SelectedFontSize Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SelectedFontSize Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets the font size for the current cell. Sets the font size for the selected range of cells.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public float SelectedFontSize { get; set; }
Visual Basic
Public Property SelectedFontSize As Single
    Get
    Set

Property Value

Type: Single

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SelectLeft Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SelectLeft Property
CvsInSightDisplayEdit Class See Also Send Feedback
Expands the selected range one column left.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectLeft { get; }
Visual Basic
Public ReadOnly Property SelectLeft As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SelectPageDown Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SelectPageDown Property
CvsInSightDisplayEdit Class See Also Send Feedback
Expands the selected range one page downward.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectPageDown { get; }
Visual Basic
Public ReadOnly Property SelectPageDown As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SelectPageUp Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SelectPageUp Property
CvsInSightDisplayEdit Class See Also Send Feedback
Expands the selected range one page upward.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectPageUp { get; }
Visual Basic
Public ReadOnly Property SelectPageUp As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SelectRight Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SelectRight Property
CvsInSightDisplayEdit Class See Also Send Feedback
Expands the selected range one column right.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectRight { get; }
Visual Basic
Public ReadOnly Property SelectRight As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SelectRow Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SelectRow Property
CvsInSightDisplayEdit Class See Also Send Feedback
Selects an entire row.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectRow { get; }
Visual Basic
Public ReadOnly Property SelectRow As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SelectToRowEnd Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SelectToRowEnd Property
CvsInSightDisplayEdit Class See Also Send Feedback
Expands the selection to the end of the row.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectToRowEnd { get; }
Visual Basic
Public ReadOnly Property SelectToRowEnd As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SelectToRowStart Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SelectToRowStart Property
CvsInSightDisplayEdit Class See Also Send Feedback
Expands the selection to the start of the row.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectToRowStart { get; }
Visual Basic
Public ReadOnly Property SelectToRowStart As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SelectUp Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SelectUp Property
CvsInSightDisplayEdit Class See Also Send Feedback
Expands the selected range one row up.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectUp { get; }
Visual Basic
Public ReadOnly Property SelectUp As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • The display is in the normal state or editing reference ranges (State = Normal or EditingReferenceRanges).
  • The grid is shown (ShowGrid = true).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SetColumnWidth Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SetColumnWidth Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that prompts the user and sets the width of all columns in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SetColumnWidth { get; }
Visual Basic
Public ReadOnly Property SetColumnWidth As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog, OR the sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SetGridOpacity Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SetGridOpacity Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that prompts the user and sets grid opacity to a specific value.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SetGridOpacity { get; }
Visual Basic
Public ReadOnly Property SetGridOpacity As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state (State = Normal).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SetGridScale Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SetGridScale Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that prompts the user and sets grid scale (sheet zoom) to a specific value.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SetGridScale { get; }
Visual Basic
Public ReadOnly Property SetGridScale As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state (State = Normal).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SetRamDiskSize Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SetRamDiskSize Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that prompts the user and sets the RAM disk size to a specific value.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SetRamDiskSize { get; }
Visual Basic
Public ReadOnly Property SetRamDiskSize As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state (State = Normal).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SetRowHeight Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SetRowHeight Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that pPrompts the user and sets the height of all rows in the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SetRowHeight { get; }
Visual Basic
Public ReadOnly Property SetRowHeight As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog, OR the sensor's firmware supports formatting tags (revision 2.8 or later).

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SetTextScaleMode Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SetTextScaleMode Property
CvsInSightDisplayEdit Class See Also Send Feedback
Callback for the Text Scale Mode button

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SetTextScaleMode { get; }
Visual Basic
Public ReadOnly Property SetTextScaleMode As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ShowCustomView Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ShowCustomView Property
CvsInSightDisplayEdit Class See Also Send Feedback
Toggles the ShowCustomView property in order to switch between the custom view and the normal (job editing) view.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle ShowCustomView { get; }
Visual Basic
Public ReadOnly Property ShowCustomView As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The display is in the normal state (State = Normal) or showing a user dialog ((State = Dialog).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ShowDependencyErrorsOnly Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ShowDependencyErrorsOnly Property
CvsInSightDisplayEdit Class See Also Send Feedback
Toggles the ShowDependencyErrorsOnly property in order to switch between showing all dependencies and errors only.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle ShowDependencyErrorsOnly { get; }
Visual Basic
Public ReadOnly Property ShowDependencyErrorsOnly As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is currently visible.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ShowDependencyLevelsDecrease Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ShowDependencyLevelsDecrease Property
CvsInSightDisplayEdit Class See Also Send Feedback
Decreases the displayed dependency levels.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ShowDependencyLevelsDecrease { get; }
Visual Basic
Public ReadOnly Property ShowDependencyLevelsDecrease As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is currently visible.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ShowDependencyLevelsIncrease Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ShowDependencyLevelsIncrease Property
CvsInSightDisplayEdit Class See Also Send Feedback
Increases the displayed dependency levels.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ShowDependencyLevelsIncrease { get; }
Visual Basic
Public ReadOnly Property ShowDependencyLevelsIncrease As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is currently visible.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ShowDependencyLevelsReset Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ShowDependencyLevelsReset Property
CvsInSightDisplayEdit Class See Also Send Feedback
Sets the displayed dependency levels to zero.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ShowDependencyLevelsReset { get; }
Visual Basic
Public ReadOnly Property ShowDependencyLevelsReset As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is currently visible.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ShowEntireSheet Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ShowEntireSheet Property
CvsInSightDisplayEdit Class See Also Send Feedback
Shows or hides the dialog cells in the main spreadsheet area.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle ShowEntireSheet { get; }
Visual Basic
Public ReadOnly Property ShowEntireSheet As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ShowGraphics Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ShowGraphics Property
CvsInSightDisplayEdit Class See Also Send Feedback
Toggles the ShowGraphics property in order to show or hide the spreadsheet graphics.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle ShowGraphics { get; }
Visual Basic
Public ReadOnly Property ShowGraphics As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state or the property sheet is open (State = Normal or Dialog).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The normal view is shown, OR the custom view is shown and the job is configured to display the graphics in the custom view.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ShowGrid Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ShowGrid Property
CvsInSightDisplayEdit Class See Also Send Feedback
Toggles the ShowGrid property in order to show or hide the spreadsheet grid.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle ShowGrid { get; }
Visual Basic
Public ReadOnly Property ShowGrid As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is in the normal state or the property sheet is open (State = Normal or Dialog).
  • Live acquisition is not active.
  • The display is not part of a user dialog.
  • The normal view is shown, OR the custom view is shown and the job is configured to display the grid overlay in the custom view.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ShowImageSaturation Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ShowImageSaturation Property
CvsInSightDisplayEdit Class See Also Send Feedback
Toggles the ShowImageSaturation property in order to show the saturated areas of the image in color.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle ShowImageSaturation { get; }
Visual Basic
Public ReadOnly Property ShowImageSaturation As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SoftOnline Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SoftOnline Property
CvsInSightDisplayEdit Class See Also Send Feedback
Toggles the soft-online state of the In-Sight sensor, first prompting the user if the ConfirmOnlineTransitions property is true.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle SoftOnline { get; }
Visual Basic
Public ReadOnly Property SoftOnline As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The display is in the normal state or editing a cell value (State = Normal or EditingCellValue).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions.
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SynchronizedInspectionParameters Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SynchronizedInspectionParameters Property
CvsInSightDisplayEdit Class See Also Send Feedback
Displays the inspection synchronizer parameters dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SynchronizedInspectionParameters { get; }
Visual Basic
Public ReadOnly Property SynchronizedInspectionParameters As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • Live acquisition is not active.
  • The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.Undo Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..Undo Property
CvsInSightDisplayEdit Class See Also Send Feedback
Undoes the last action that was done.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction Undo { get; }
Visual Basic
Public ReadOnly Property Undo As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The display is in the normal state (State = Normal).
  • The sensor's firmware supports undo and redo operations (revision 2.8 or later).
  • An action has been done that can be undone.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.UnhideColumns Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..UnhideColumns Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that unhides all columns within the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction UnhideColumns { get; }
Visual Basic
Public ReadOnly Property UnhideColumns As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog, OR the sensor's firmware supports formatting tags (revision 2.8 or later).
  • One or more columns are selected.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.UnhideRows Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..UnhideRows Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that unhides all rows within the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction UnhideRows { get; }
Visual Basic
Public ReadOnly Property UnhideRows As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog, OR the sensor's firmware supports formatting tags (revision 2.8 or later).
  • One or more rows are selected.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.UnhideRowsOrColumns Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..UnhideRowsOrColumns Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that unhides the rows or columns of the selected range depending on what is selected.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction UnhideRowsOrColumns { get; }
Visual Basic
Public ReadOnly Property UnhideRowsOrColumns As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The sensor is not on-line.
  • The display is in the normal state (State = Normal).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The display is not part of a user dialog, OR the sensor's firmware supports formatting tags (revision 2.8 or later).
  • One or more rows or columns are selected.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ZoomGrid1To1 Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ZoomGrid1To1 Property
CvsInSightDisplayEdit Class See Also Send Feedback
Sets the GridScale to 1.0 if a single cell is selected, or otherwise zooms the grid to fit the selected range.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ZoomGrid1To1 { get; }
Visual Basic
Public ReadOnly Property ZoomGrid1To1 As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).

If this action changes the GridScale while the custom view is on display, the custom view will be automatically resized to fit based on the new grid scale.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ZoomGridIn Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ZoomGridIn Property
CvsInSightDisplayEdit Class See Also Send Feedback
Increases the GridScale (sheet zoom).

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ZoomGridIn { get; }
Visual Basic
Public ReadOnly Property ZoomGridIn As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The grid scale is less than 4.0 (GridScale < 4.0).

If this action changes the GridScale while the custom view is on display, the custom view will be automatically resized to fit based on the new grid scale.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ZoomGridOut Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ZoomGridOut Property
CvsInSightDisplayEdit Class See Also Send Feedback
Decreases the GridScale (sheet zoom).

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ZoomGridOut { get; }
Visual Basic
Public ReadOnly Property ZoomGridOut As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is connected to a sensor (Connected = true).
  • The user has appropriate access permissions defined in CvsPermissionDefinitions).
  • The grid is shown (ShowGrid = true).
  • The grid scale is greater than 0.1 (GridScale > 0.1).

If this action changes the GridScale while the custom view is on display, the custom view will be automatically resized to fit based on the new grid scale.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ZoomImage1To1 Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ZoomImage1To1 Property
CvsInSightDisplayEdit Class See Also Send Feedback
Sets the display's ImageZoomMode to None to disable automatic zooming of the image, and then sets the ImageScale to 1.0.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ZoomImage1To1 { get; }
Visual Basic
Public ReadOnly Property ZoomImage1To1 As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and The display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ZoomImageIn Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ZoomImageIn Property
CvsInSightDisplayEdit Class See Also Send Feedback
Sets the display's ImageZoomMode to None to disable automatic zooming of the image, and then increases the ImageScale.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ZoomImageIn { get; }
Visual Basic
Public ReadOnly Property ZoomImageIn As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is not part of a user dialog.
  • The image scale is less than 20.0 (ImageScale < 20.0)

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ZoomImageOut Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ZoomImageOut Property
CvsInSightDisplayEdit Class See Also Send Feedback
Sets the display's ImageZoomMode to None to disable automatic zooming of the image, and and then decreases the ImageScale.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ZoomImageOut { get; }
Visual Basic
Public ReadOnly Property ZoomImageOut As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and all of the following conditions are true:

  • The display is not part of a user dialog.
  • The image scale is greater than 0.1 (ImageScale > 0.1)

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ZoomImageToFill Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ZoomImageToFill Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsActionToggle object with an Execute()()()() method that toggles the display's ImageZoomMode between None and Fill.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle ZoomImageToFill { get; }
Visual Basic
Public ReadOnly Property ZoomImageToFill As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and the display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ZoomImageToFit Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ZoomImageToFit Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsActionToggle object with an Execute()()()() method that toggles the display's ImageZoomMode between None and Fit.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle ZoomImageToFit { get; }
Visual Basic
Public ReadOnly Property ZoomImageToFit As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

Remarks

This action is enabled when its Suppressed property is false and the display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.ZoomImageToMax Property

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..ZoomImageToMax Property
CvsInSightDisplayEdit Class See Also Send Feedback
Gets a CvsAction object with an Execute()()()() method that sets the display's ImageZoomMode to None to disable automatic zooming of the image, and then sets the ImageScale to 20.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ZoomImageToMax { get; }
Visual Basic
Public ReadOnly Property ZoomImageToMax As CvsAction
    Get

Property Value

Type: CvsAction

Remarks

This action is enabled when its Suppressed property is false and the display is not part of a user dialog.

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit Events

[image] [image]

In-Sight SDK
CvsInSightDisplayEdit Events
CvsInSightDisplayEdit Class See Also Send Feedback

The CvsInSightDisplayEdit type exposes the following members.

Events

 | Name | Description
Public event | EnablesUpdated | Raised when the action enables have been updated.
Public event | JobSaveCompleted | Raised after a job save completes, either successfully or with errors.
Public event | JobSaving | Raised prior to saving a job.
Public event | NetworkTreeRefreshNeeded | Raised when a refresh to the network tree is needed.
Public event | RepeatingTriggerChanged | Repeating trigger state has changed.
Public event | SelectedFontChanged | Occurs when either the SelectedFontName or the SelectedFontSize property has changed.

See Also

CvsInSightDisplayEdit Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.EnablesUpdated Event

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..EnablesUpdated Event
CvsInSightDisplayEdit Class See Also Send Feedback
Raised when the action enables have been updated.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler EnablesUpdated
Visual Basic
Public Event EnablesUpdated As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.JobSaveCompleted Event

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..JobSaveCompleted Event
CvsInSightDisplayEdit Class See Also Send Feedback
Raised after a job save completes, either successfully or with errors.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler<CvsSaveCompletedEventArgs> JobSaveCompleted
Visual Basic
Public Event JobSaveCompleted As EventHandler(Of CvsSaveCompletedEventArgs)

Value

Type: System..::..EventHandler <(Of <(<' CvsSaveCompletedEventArgs >)>)>

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.JobSaving Event

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..JobSaving Event
CvsInSightDisplayEdit Class See Also Send Feedback
Raised prior to saving a job.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler JobSaving
Visual Basic
Public Event JobSaving As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.NetworkTreeRefreshNeeded Event

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..NetworkTreeRefreshNeeded Event
CvsInSightDisplayEdit Class See Also Send Feedback
Raised when a refresh to the network tree is needed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler NetworkTreeRefreshNeeded
Visual Basic
Public Event NetworkTreeRefreshNeeded As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.RepeatingTriggerChanged Event

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..RepeatingTriggerChanged Event
CvsInSightDisplayEdit Class See Also Send Feedback
Repeating trigger state has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler RepeatingTriggerChanged
Visual Basic
Public Event RepeatingTriggerChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayEdit.SelectedFontChanged Event

[image]

In-Sight SDK
CvsInSightDisplayEdit..::..SelectedFontChanged Event
CvsInSightDisplayEdit Class See Also Send Feedback
Occurs when either the SelectedFontName or the SelectedFontSize property has changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler SelectedFontChanged
Visual Basic
Public Event SelectedFontChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsInSightDisplayEdit Class
CvsInSightDisplayEdit..::..CvsInSightDisplayEdit Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayHistory Class

[image]

In-Sight SDK
CvsInSightDisplayHistory Class
Members See Also Send Feedback
Maintains a browsing history within a display, so one can navigate forward and back to cell locations.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsInSightDisplayHistory
Visual Basic
Public Class CvsInSightDisplayHistory

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Controls.Display..::..CvsInSightDisplayHistory

See Also

CvsInSightDisplayHistory..::..CvsInSightDisplayHistory Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayHistory Members

[image] [image]

In-Sight SDK
CvsInSightDisplayHistory Members
CvsInSightDisplayHistory Class Constructors Methods Fields Properties See Also Send Feedback

The CvsInSightDisplayHistory type exposes the following members.

Constructors

 | Name | Description
Public method | CvsInSightDisplayHistory | Constructs a new instance.

Methods

 | Name | Description
Public method | Dispose | Frees all resources in use.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
MaxHistoryCount | The maximum number of entries in the history.

Properties

 | Name | Description
Public property | NavigateBack | Navigates back one step in the history.
Public property | NavigateForward | Navigates forward one step in the history.

See Also

CvsInSightDisplayHistory Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayHistory Constructor

[image]

In-Sight SDK
CvsInSightDisplayHistory Constructor
CvsInSightDisplayHistory Class See Also Send Feedback
Constructs a new instance.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplayHistory(
    CvsInSightDisplay display
)
Visual Basic
Public Sub New (
    display As CvsInSightDisplay
)

Parameters

display
Type: Cognex.InSight.Controls.Display..::..CvsInSightDisplay
The display control for which to maintain the history.

See Also

CvsInSightDisplayHistory Class
CvsInSightDisplayHistory..::..CvsInSightDisplayHistory Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayHistory Fields

[image] [image]

In-Sight SDK
CvsInSightDisplayHistory Fields
CvsInSightDisplayHistory Class See Also Send Feedback

The CvsInSightDisplayHistory type exposes the following members.

Fields

Name | Description
MaxHistoryCount | The maximum number of entries in the history.

See Also

CvsInSightDisplayHistory Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayHistory.MaxHistoryCount Field

[image]

In-Sight SDK
CvsInSightDisplayHistory..::..MaxHistoryCount Field
CvsInSightDisplayHistory Class See Also Send Feedback
The maximum number of entries in the history.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxHistoryCount
Visual Basic
Public Const MaxHistoryCount As Integer

Field Value

Type: Int32

See Also

CvsInSightDisplayHistory Class
CvsInSightDisplayHistory..::..CvsInSightDisplayHistory Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayHistory Methods

[image] [image]

In-Sight SDK
CvsInSightDisplayHistory Methods
CvsInSightDisplayHistory Class See Also Send Feedback

The CvsInSightDisplayHistory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Frees all resources in use.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsInSightDisplayHistory Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayHistory.Dispose Method

[image]

In-Sight SDK
CvsInSightDisplayHistory..::..Dispose Method
CvsInSightDisplayHistory Class See Also Send Feedback
Frees all resources in use.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

See Also

CvsInSightDisplayHistory Class
CvsInSightDisplayHistory..::..CvsInSightDisplayHistory Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayHistory Properties

[image] [image]

In-Sight SDK
CvsInSightDisplayHistory Properties
CvsInSightDisplayHistory Class See Also Send Feedback

The CvsInSightDisplayHistory type exposes the following members.

Properties

 | Name | Description
Public property | NavigateBack | Navigates back one step in the history.
Public property | NavigateForward | Navigates forward one step in the history.

See Also

CvsInSightDisplayHistory Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayHistory.NavigateBack Property

[image]

In-Sight SDK
CvsInSightDisplayHistory..::..NavigateBack Property
CvsInSightDisplayHistory Class See Also Send Feedback
Navigates back one step in the history.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction NavigateBack { get; }
Visual Basic
Public ReadOnly Property NavigateBack As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsInSightDisplayHistory Class
CvsInSightDisplayHistory..::..CvsInSightDisplayHistory Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayHistory.NavigateForward Property

[image]

In-Sight SDK
CvsInSightDisplayHistory..::..NavigateForward Property
CvsInSightDisplayHistory Class See Also Send Feedback
Navigates forward one step in the history.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction NavigateForward { get; }
Visual Basic
Public ReadOnly Property NavigateForward As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsInSightDisplayHistory Class
CvsInSightDisplayHistory..::..CvsInSightDisplayHistory Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder Class

[image]

In-Sight SDK
CvsInSightDisplayRecorder Class
Members See Also Send Feedback
This class manages Record and Playback operations for the CvsInSightDisplay.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsInSightDisplayRecorder : IDisposable,
    IRecordOptionsModel
Visual Basic
Public Class CvsInSightDisplayRecorder
    Implements IDisposable, IRecordOptionsModel

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Controls.Display..::..CvsInSightDisplayRecorder

See Also

CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder Members

[image] [image]

In-Sight SDK
CvsInSightDisplayRecorder Members
CvsInSightDisplayRecorder Class Constructors Methods Fields Properties Events See Also Send Feedback

The CvsInSightDisplayRecorder type exposes the following members.

Constructors

 | Name | Description
Public method | CvsInSightDisplayRecorder()()()() | Constructs a new instance of the CvsInSightDisplayRecorder class.
Public method | CvsInSightDisplayRecorder(CvsInSightDisplay, String) | Constructs a new instance of the CvsInSightDisplayRecorder class.

Methods

 | Name | Description
Public method | AddRecentPlaybackFolder | Add a folder to the recent playback list.
Public method | Dispose | Disposes of all resources used by the recorder.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPlaybackFiles | Returns an array of playback file names in playback order.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PlayFirst | Loads the first image in the playback buffer.
Public method | PlayLast | Loads the last image in the playback buffer.
Public method | PlayNext | Loads the next image in the playback buffer.
Public method | PlayPrevious | Loads the previous image in the playback buffer.
Public method | Refresh | Refreshes the Recorder by checking the Playback folder and enabling navigational buttons.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
CvsRecorderImageTypes | Array of supported image formats
CvsRecorderReserveWords | Array of valid reserve words

Properties

 | Name | Description
Public property | AlwaysShowOptions | Flag to indicate if the options dialog should be displayed every time record or playback is started.
Public property | DeferImageLoading | Allows PlaybackIndex to be set without sending the image to the In-Sight. Used during initialization.
Public property | GetDefaultRecordWatchCell | A callback used when restoring the playback and record options to their default value. This allows the environment (easybuilder, spreadsheet) to determine what the default watch cell should be. For spreadsheet, an empty string or A0 may be appropriate. For easybuilder, this is typically in a job snippet, usually at S1.
Public property | PlayActive | Gets or sets a value that indicates whether the display is playing back previously recorded images.
Public property | PlaybackAllowed | Flag to indicate if Playback functionality is allowed for this sensor.
Public property | PlaybackContinuous | Continuous or single pass playback indicator.
Public property | PlaybackDelay | The time delay in seconds between images during playback.
Public property | PlaybackFilename | Filename of the last image played back.
Public property | PlaybackFolder | Folder location to play images from.
Public property | PlaybackImageCount | The number of images in the playback buffer.
Public property | PlaybackIndex | The index of the last image played back.
Public property | RecentPlaybackFolders | Returns a list of recent playback folders.
Public property | RecordActive | Gets or sets a value that indicates whether to record images.
Public property | RecordBitDepth | The bit depth of color images sent while recording.
Public property | RecordFilename | Filename of the last image recorded
Public property | RecordFilenameFormat | Format expression for the recorded image's file naming convention and file type
Public property | RecordFolder | Folder location to record images to.
Public property | RecordImageCount | Total number of images currently in the Record Folder, if recording on a cell expression this is the total number of images stored in the Record Folders Good and Bad subfolders
Public property | RecordIndex | Index for the next recorded image
Public property | RecordMax | Maximum number of images that can be recorded into one folder.
Public property | RecordMaxLimit | Gets the maximum allowed number of playback/record images in a folder. This is the maximum value that can be entered by the user.
Public property | RecordMode | The Record mode.
Public property | RecordResolution | The resolution setting of the sensor while recording.
Public property | RecordWatchCell | The cell to evaluate for record on conditional state.

Events

 | Name | Description
Public event | PlaybackFolderChanged | Raised when the PlaybackFolder changed.
Public event | PlaybackFolderSizeChanged | Raised when the number of images in the PlaybackFolder changed.
Public event | PlaybackIndexChanged | Raised when the PlaybackIndex changed.
Public event | RecordFolderChanged | Raised when the RecordFolder changed.

See Also

CvsInSightDisplayRecorder Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder Constructor

[image] [image]

In-Sight SDK
CvsInSightDisplayRecorder Constructor
CvsInSightDisplayRecorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsInSightDisplayRecorder()()()() | Constructs a new instance of the CvsInSightDisplayRecorder class.
Public method | CvsInSightDisplayRecorder(CvsInSightDisplay, String) | Constructs a new instance of the CvsInSightDisplayRecorder class.

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder Constructor

[image]

In-Sight SDK
CvsInSightDisplayRecorder Constructor
CvsInSightDisplayRecorder Class See Also Send Feedback
Constructs a new instance of the CvsInSightDisplayRecorder class.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplayRecorder()
Visual Basic
Public Sub New

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
CvsInSightDisplayRecorder Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder Constructor (CvsInSightDisplay, String)

[image]

In-Sight SDK
CvsInSightDisplayRecorder Constructor (CvsInSightDisplay, String)
CvsInSightDisplayRecorder Class See Also Send Feedback
Constructs a new instance of the CvsInSightDisplayRecorder class.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplayRecorder(
    CvsInSightDisplay display,
    string sensorName
)
Visual Basic
Public Sub New (
    display As CvsInSightDisplay,
    sensorName As String
)

Parameters

display
Type: Cognex.InSight.Controls.Display..::..CvsInSightDisplay
The display control.
sensorName
Type: System..::..String
The InSight sensor's host name used in the record folder path.

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
CvsInSightDisplayRecorder Overload
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder Fields

[image] [image]

In-Sight SDK
CvsInSightDisplayRecorder Fields
CvsInSightDisplayRecorder Class See Also Send Feedback

The CvsInSightDisplayRecorder type exposes the following members.

Fields

Name | Description
CvsRecorderImageTypes | Array of supported image formats
CvsRecorderReserveWords | Array of valid reserve words

See Also

CvsInSightDisplayRecorder Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.CvsRecorderImageTypes Field

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..CvsRecorderImageTypes Field
CvsInSightDisplayRecorder Class See Also Send Feedback
Array of supported image formats

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public static readonly string[] CvsRecorderImageTypes
Visual Basic
Public Shared ReadOnly CvsRecorderImageTypes As String()

Field Value

Type: array< String >[]()[][]

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.CvsRecorderReserveWords Field

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..CvsRecorderReserveWords Field
CvsInSightDisplayRecorder Class See Also Send Feedback
Array of valid reserve words

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public static readonly string[] CvsRecorderReserveWords
Visual Basic
Public Shared ReadOnly CvsRecorderReserveWords As String()

Field Value

Type: array< String >[]()[][]

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder Methods

[image] [image]

In-Sight SDK
CvsInSightDisplayRecorder Methods
CvsInSightDisplayRecorder Class See Also Send Feedback

The CvsInSightDisplayRecorder type exposes the following members.

Methods

 | Name | Description
Public method | AddRecentPlaybackFolder | Add a folder to the recent playback list.
Public method | Dispose | Disposes of all resources used by the recorder.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPlaybackFiles | Returns an array of playback file names in playback order.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PlayFirst | Loads the first image in the playback buffer.
Public method | PlayLast | Loads the last image in the playback buffer.
Public method | PlayNext | Loads the next image in the playback buffer.
Public method | PlayPrevious | Loads the previous image in the playback buffer.
Public method | Refresh | Refreshes the Recorder by checking the Playback folder and enabling navigational buttons.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsInSightDisplayRecorder Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.AddRecentPlaybackFolder Method

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..AddRecentPlaybackFolder Method
CvsInSightDisplayRecorder Class See Also Send Feedback
Add a folder to the recent playback list.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void AddRecentPlaybackFolder(
    string folder
)
Visual Basic
Public Sub AddRecentPlaybackFolder (
    folder As String
)

Parameters

folder
Type: System..::..String
The path to add to the most recently used list.

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.Dispose Method

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..Dispose Method
CvsInSightDisplayRecorder Class See Also Send Feedback
Disposes of all resources used by the recorder.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.GetPlaybackFiles Method

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..GetPlaybackFiles Method
CvsInSightDisplayRecorder Class See Also Send Feedback
Returns an array of playback file names in playback order.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string[] GetPlaybackFiles()
Visual Basic
Public Function GetPlaybackFiles As String()

Return Value

Type: array< String >[]()[][]
An array of strings that represent the file names.

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlayFirst Method

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlayFirst Method
CvsInSightDisplayRecorder Class See Also Send Feedback
Loads the first image in the playback buffer.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void PlayFirst()
Visual Basic
Public Sub PlayFirst

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlayLast Method

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlayLast Method
CvsInSightDisplayRecorder Class See Also Send Feedback
Loads the last image in the playback buffer.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void PlayLast()
Visual Basic
Public Sub PlayLast

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlayNext Method

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlayNext Method
CvsInSightDisplayRecorder Class See Also Send Feedback
Loads the next image in the playback buffer.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void PlayNext()
Visual Basic
Public Sub PlayNext

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlayPrevious Method

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlayPrevious Method
CvsInSightDisplayRecorder Class See Also Send Feedback
Loads the previous image in the playback buffer.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void PlayPrevious()
Visual Basic
Public Sub PlayPrevious

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.Refresh Method

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..Refresh Method
CvsInSightDisplayRecorder Class See Also Send Feedback
Refreshes the Recorder by checking the Playback folder and enabling navigational buttons.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Refresh()
Visual Basic
Public Sub Refresh

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder Properties

[image] [image]

In-Sight SDK
CvsInSightDisplayRecorder Properties
CvsInSightDisplayRecorder Class See Also Send Feedback

The CvsInSightDisplayRecorder type exposes the following members.

Properties

 | Name | Description
Public property | AlwaysShowOptions | Flag to indicate if the options dialog should be displayed every time record or playback is started.
Public property | DeferImageLoading | Allows PlaybackIndex to be set without sending the image to the In-Sight. Used during initialization.
Public property | GetDefaultRecordWatchCell | A callback used when restoring the playback and record options to their default value. This allows the environment (easybuilder, spreadsheet) to determine what the default watch cell should be. For spreadsheet, an empty string or A0 may be appropriate. For easybuilder, this is typically in a job snippet, usually at S1.
Public property | PlayActive | Gets or sets a value that indicates whether the display is playing back previously recorded images.
Public property | PlaybackAllowed | Flag to indicate if Playback functionality is allowed for this sensor.
Public property | PlaybackContinuous | Continuous or single pass playback indicator.
Public property | PlaybackDelay | The time delay in seconds between images during playback.
Public property | PlaybackFilename | Filename of the last image played back.
Public property | PlaybackFolder | Folder location to play images from.
Public property | PlaybackImageCount | The number of images in the playback buffer.
Public property | PlaybackIndex | The index of the last image played back.
Public property | RecentPlaybackFolders | Returns a list of recent playback folders.
Public property | RecordActive | Gets or sets a value that indicates whether to record images.
Public property | RecordBitDepth | The bit depth of color images sent while recording.
Public property | RecordFilename | Filename of the last image recorded
Public property | RecordFilenameFormat | Format expression for the recorded image's file naming convention and file type
Public property | RecordFolder | Folder location to record images to.
Public property | RecordImageCount | Total number of images currently in the Record Folder, if recording on a cell expression this is the total number of images stored in the Record Folders Good and Bad subfolders
Public property | RecordIndex | Index for the next recorded image
Public property | RecordMax | Maximum number of images that can be recorded into one folder.
Public property | RecordMaxLimit | Gets the maximum allowed number of playback/record images in a folder. This is the maximum value that can be entered by the user.
Public property | RecordMode | The Record mode.
Public property | RecordResolution | The resolution setting of the sensor while recording.
Public property | RecordWatchCell | The cell to evaluate for record on conditional state.

See Also

CvsInSightDisplayRecorder Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.AlwaysShowOptions Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..AlwaysShowOptions Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Flag to indicate if the options dialog should be displayed every time record or playback is started.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool AlwaysShowOptions { get; set; }
Visual Basic
Public Property AlwaysShowOptions As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.DeferImageLoading Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..DeferImageLoading Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Allows PlaybackIndex to be set without sending the image to the In-Sight. Used during initialization.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public IDisposable DeferImageLoading { get; }
Visual Basic
Public ReadOnly Property DeferImageLoading As IDisposable
    Get

Property Value

Type: IDisposable

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.GetDefaultRecordWatchCell Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..GetDefaultRecordWatchCell Property
CvsInSightDisplayRecorder Class See Also Send Feedback
A callback used when restoring the playback and record options to their default value. This allows the environment (easybuilder, spreadsheet) to determine what the default watch cell should be. For spreadsheet, an empty string or A0 may be appropriate. For easybuilder, this is typically in a job snippet, usually at S1.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public Func<string> GetDefaultRecordWatchCell { get; set; }
Visual Basic
Public Property GetDefaultRecordWatchCell As Func(Of String)
    Get
    Set

Property Value

Type: Func <(Of <(<' String >)>)>

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlayActive Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlayActive Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Gets or sets a value that indicates whether the display is playing back previously recorded images.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool PlayActive { get; set; }
Visual Basic
Public Property PlayActive As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlaybackAllowed Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlaybackAllowed Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Flag to indicate if Playback functionality is allowed for this sensor.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool PlaybackAllowed { get; }
Visual Basic
Public ReadOnly Property PlaybackAllowed As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlaybackContinuous Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlaybackContinuous Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Continuous or single pass playback indicator.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool PlaybackContinuous { get; set; }
Visual Basic
Public Property PlaybackContinuous As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlaybackDelay Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlaybackDelay Property
CvsInSightDisplayRecorder Class See Also Send Feedback
The time delay in seconds between images during playback.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public double PlaybackDelay { get; set; }
Visual Basic
Public Property PlaybackDelay As Double
    Get
    Set

Property Value

Type: Double

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlaybackFilename Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlaybackFilename Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Filename of the last image played back.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string PlaybackFilename { get; set; }
Visual Basic
Public Property PlaybackFilename As String
    Get
    Set

Property Value

Type: String

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlaybackFolder Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlaybackFolder Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Folder location to play images from.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string PlaybackFolder { get; set; }
Visual Basic
Public Property PlaybackFolder As String
    Get
    Set

Property Value

Type: String

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlaybackImageCount Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlaybackImageCount Property
CvsInSightDisplayRecorder Class See Also Send Feedback
The number of images in the playback buffer.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int PlaybackImageCount { get; }
Visual Basic
Public ReadOnly Property PlaybackImageCount As Integer
    Get

Property Value

Type: Int32

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlaybackIndex Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlaybackIndex Property
CvsInSightDisplayRecorder Class See Also Send Feedback
The index of the last image played back.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int PlaybackIndex { get; set; }
Visual Basic
Public Property PlaybackIndex As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecentPlaybackFolders Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecentPlaybackFolders Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Returns a list of recent playback folders.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string[] RecentPlaybackFolders { get; }
Visual Basic
Public ReadOnly Property RecentPlaybackFolders As String()
    Get

Property Value

Type: array< String >[]()[][]

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecordActive Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecordActive Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Gets or sets a value that indicates whether to record images.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool RecordActive { get; set; }
Visual Basic
Public Property RecordActive As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecordBitDepth Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecordBitDepth Property
CvsInSightDisplayRecorder Class See Also Send Feedback
The bit depth of color images sent while recording.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsColorBitDepth RecordBitDepth { get; set; }
Visual Basic
Public Property RecordBitDepth As CvsColorBitDepth
    Get
    Set

Property Value

Type: CvsColorBitDepth

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecordFilename Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecordFilename Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Filename of the last image recorded

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string RecordFilename { get; }
Visual Basic
Public ReadOnly Property RecordFilename As String
    Get

Property Value

Type: String

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecordFilenameFormat Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecordFilenameFormat Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Format expression for the recorded image's file naming convention and file type

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string RecordFilenameFormat { get; set; }
Visual Basic
Public Property RecordFilenameFormat As String
    Get
    Set

Property Value

Type: String

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecordFolder Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecordFolder Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Folder location to record images to.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string RecordFolder { get; set; }
Visual Basic
Public Property RecordFolder As String
    Get
    Set

Property Value

Type: String

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecordImageCount Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecordImageCount Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Total number of images currently in the Record Folder, if recording on a cell expression this is the total number of images stored in the Record Folders Good and Bad subfolders

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int RecordImageCount { get; }
Visual Basic
Public ReadOnly Property RecordImageCount As Integer
    Get

Property Value

Type: Int32

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecordIndex Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecordIndex Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Index for the next recorded image

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int RecordIndex { get; set; }
Visual Basic
Public Property RecordIndex As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecordMax Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecordMax Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Maximum number of images that can be recorded into one folder.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int RecordMax { get; set; }
Visual Basic
Public Property RecordMax As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecordMaxLimit Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecordMaxLimit Property
CvsInSightDisplayRecorder Class See Also Send Feedback
Gets the maximum allowed number of playback/record images in a folder. This is the maximum value that can be entered by the user.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int RecordMaxLimit { get; }
Visual Basic
Public ReadOnly Property RecordMaxLimit As Integer
    Get

Property Value

Type: Int32

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecordMode Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecordMode Property
CvsInSightDisplayRecorder Class See Also Send Feedback
The Record mode.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsRecordMode RecordMode { get; set; }
Visual Basic
Public Property RecordMode As CvsRecordMode
    Get
    Set

Property Value

Type: CvsRecordMode

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecordResolution Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecordResolution Property
CvsInSightDisplayRecorder Class See Also Send Feedback
The resolution setting of the sensor while recording.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageResolution RecordResolution { get; set; }
Visual Basic
Public Property RecordResolution As CvsImageResolution
    Get
    Set

Property Value

Type: CvsImageResolution

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecordWatchCell Property

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecordWatchCell Property
CvsInSightDisplayRecorder Class See Also Send Feedback
The cell to evaluate for record on conditional state.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string RecordWatchCell { get; set; }
Visual Basic
Public Property RecordWatchCell As String
    Get
    Set

Property Value

Type: String

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder Events

[image] [image]

In-Sight SDK
CvsInSightDisplayRecorder Events
CvsInSightDisplayRecorder Class See Also Send Feedback

The CvsInSightDisplayRecorder type exposes the following members.

Events

 | Name | Description
Public event | PlaybackFolderChanged | Raised when the PlaybackFolder changed.
Public event | PlaybackFolderSizeChanged | Raised when the number of images in the PlaybackFolder changed.
Public event | PlaybackIndexChanged | Raised when the PlaybackIndex changed.
Public event | RecordFolderChanged | Raised when the RecordFolder changed.

See Also

CvsInSightDisplayRecorder Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlaybackFolderChanged Event

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlaybackFolderChanged Event
CvsInSightDisplayRecorder Class See Also Send Feedback
Raised when the PlaybackFolder changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler PlaybackFolderChanged
Visual Basic
Public Event PlaybackFolderChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlaybackFolderSizeChanged Event

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlaybackFolderSizeChanged Event
CvsInSightDisplayRecorder Class See Also Send Feedback
Raised when the number of images in the PlaybackFolder changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler PlaybackFolderSizeChanged
Visual Basic
Public Event PlaybackFolderSizeChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.PlaybackIndexChanged Event

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..PlaybackIndexChanged Event
CvsInSightDisplayRecorder Class See Also Send Feedback
Raised when the PlaybackIndex changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler PlaybackIndexChanged
Visual Basic
Public Event PlaybackIndexChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorder.RecordFolderChanged Event

[image]

In-Sight SDK
CvsInSightDisplayRecorder..::..RecordFolderChanged Event
CvsInSightDisplayRecorder Class See Also Send Feedback
Raised when the RecordFolder changed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler RecordFolderChanged
Visual Basic
Public Event RecordFolderChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsInSightDisplayRecorder Class
CvsInSightDisplayRecorder..::..CvsInSightDisplayRecorder Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions Class

[image]

In-Sight SDK
CvsInSightDisplayRecorderOptions Class
Members See Also Send Feedback
A class to hold all of the recorder options that get stored in the job view options.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsInSightDisplayRecorderOptions
Visual Basic
<SerializableAttribute>
Public Class CvsInSightDisplayRecorderOptions

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Controls.Display..::..CvsInSightDisplayRecorderOptions

See Also

CvsInSightDisplayRecorderOptions..::..CvsInSightDisplayRecorderOptions Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions Members

[image] [image]

In-Sight SDK
CvsInSightDisplayRecorderOptions Members
CvsInSightDisplayRecorderOptions Class Constructors Methods Properties See Also Send Feedback

The CvsInSightDisplayRecorderOptions type exposes the following members.

Constructors

 | Name | Description
Public method | CvsInSightDisplayRecorderOptions | Initializes a new instance of the CvsInSightDisplayRecorderOptions class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlwaysShowOptions | Flag to indicate if the options dialog should be displayed everytime record or playback is started.
Public property | PlaybackContinuous | Continuous or single pass playback indicator.
Public property | PlaybackDelay | The time delay in seconds between images during playback.
Public property | PlaybackFolder | Folder location to play images from.
Public property | RecordBitDepth | The bit depth of color images sent while recording.
Public property | RecordFilenameFormat | Format expresson for the recorded image's file naming convention and file type
Public property | RecordFolder | Folder location to record images to.
Public property | RecordMax | Maximum number of images that can be recorded into one folder.
Public property | RecordMode | The Record mode.
Public property | RecordResolution | The resolution setting of the sensor while recording online.
Public property | RecordWatchCell | The cell to evaluate for record on conditional state.

See Also

CvsInSightDisplayRecorderOptions Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions Constructor

[image]

In-Sight SDK
CvsInSightDisplayRecorderOptions Constructor
CvsInSightDisplayRecorderOptions Class See Also Send Feedback
Initializes a new instance of the CvsInSightDisplayRecorderOptions class

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplayRecorderOptions()
Visual Basic
Public Sub New

See Also

CvsInSightDisplayRecorderOptions Class
CvsInSightDisplayRecorderOptions..::..CvsInSightDisplayRecorderOptions Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions Methods

[image] [image]

In-Sight SDK
CvsInSightDisplayRecorderOptions Methods
CvsInSightDisplayRecorderOptions Class See Also Send Feedback

The CvsInSightDisplayRecorderOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsInSightDisplayRecorderOptions Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions Properties

[image] [image]

In-Sight SDK
CvsInSightDisplayRecorderOptions Properties
CvsInSightDisplayRecorderOptions Class See Also Send Feedback

The CvsInSightDisplayRecorderOptions type exposes the following members.

Properties

 | Name | Description
Public property | AlwaysShowOptions | Flag to indicate if the options dialog should be displayed everytime record or playback is started.
Public property | PlaybackContinuous | Continuous or single pass playback indicator.
Public property | PlaybackDelay | The time delay in seconds between images during playback.
Public property | PlaybackFolder | Folder location to play images from.
Public property | RecordBitDepth | The bit depth of color images sent while recording.
Public property | RecordFilenameFormat | Format expresson for the recorded image's file naming convention and file type
Public property | RecordFolder | Folder location to record images to.
Public property | RecordMax | Maximum number of images that can be recorded into one folder.
Public property | RecordMode | The Record mode.
Public property | RecordResolution | The resolution setting of the sensor while recording online.
Public property | RecordWatchCell | The cell to evaluate for record on conditional state.

See Also

CvsInSightDisplayRecorderOptions Class
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions.AlwaysShowOptions Property

[image]

In-Sight SDK
CvsInSightDisplayRecorderOptions..::..AlwaysShowOptions Property
CvsInSightDisplayRecorderOptions Class See Also Send Feedback
Flag to indicate if the options dialog should be displayed everytime record or playback is started.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool AlwaysShowOptions { get; set; }
Visual Basic
Public Property AlwaysShowOptions As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsInSightDisplayRecorderOptions Class
CvsInSightDisplayRecorderOptions..::..CvsInSightDisplayRecorderOptions Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions.PlaybackContinuous Property

[image]

In-Sight SDK
CvsInSightDisplayRecorderOptions..::..PlaybackContinuous Property
CvsInSightDisplayRecorderOptions Class See Also Send Feedback
Continuous or single pass playback indicator.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool PlaybackContinuous { get; set; }
Visual Basic
Public Property PlaybackContinuous As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsInSightDisplayRecorderOptions Class
CvsInSightDisplayRecorderOptions..::..CvsInSightDisplayRecorderOptions Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions.PlaybackDelay Property

[image]

In-Sight SDK
CvsInSightDisplayRecorderOptions..::..PlaybackDelay Property
CvsInSightDisplayRecorderOptions Class See Also Send Feedback
The time delay in seconds between images during playback.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public double PlaybackDelay { get; set; }
Visual Basic
Public Property PlaybackDelay As Double
    Get
    Set

Property Value

Type: Double

See Also

CvsInSightDisplayRecorderOptions Class
CvsInSightDisplayRecorderOptions..::..CvsInSightDisplayRecorderOptions Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions.PlaybackFolder Property

[image]

In-Sight SDK
CvsInSightDisplayRecorderOptions..::..PlaybackFolder Property
CvsInSightDisplayRecorderOptions Class See Also Send Feedback
Folder location to play images from.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string PlaybackFolder { get; set; }
Visual Basic
Public Property PlaybackFolder As String
    Get
    Set

Property Value

Type: String

See Also

CvsInSightDisplayRecorderOptions Class
CvsInSightDisplayRecorderOptions..::..CvsInSightDisplayRecorderOptions Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions.RecordBitDepth Property

[image]

In-Sight SDK
CvsInSightDisplayRecorderOptions..::..RecordBitDepth Property
CvsInSightDisplayRecorderOptions Class See Also Send Feedback
The bit depth of color images sent while recording.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsColorBitDepth RecordBitDepth { get; set; }
Visual Basic
Public Property RecordBitDepth As CvsColorBitDepth
    Get
    Set

Property Value

Type: CvsColorBitDepth

See Also

CvsInSightDisplayRecorderOptions Class
CvsInSightDisplayRecorderOptions..::..CvsInSightDisplayRecorderOptions Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions.RecordFilenameFormat Property

[image]

In-Sight SDK
CvsInSightDisplayRecorderOptions..::..RecordFilenameFormat Property
CvsInSightDisplayRecorderOptions Class See Also Send Feedback
Format expresson for the recorded image's file naming convention and file type

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string RecordFilenameFormat { get; set; }
Visual Basic
Public Property RecordFilenameFormat As String
    Get
    Set

Property Value

Type: String

See Also

CvsInSightDisplayRecorderOptions Class
CvsInSightDisplayRecorderOptions..::..CvsInSightDisplayRecorderOptions Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions.RecordFolder Property

[image]

In-Sight SDK
CvsInSightDisplayRecorderOptions..::..RecordFolder Property
CvsInSightDisplayRecorderOptions Class See Also Send Feedback
Folder location to record images to.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string RecordFolder { get; set; }
Visual Basic
Public Property RecordFolder As String
    Get
    Set

Property Value

Type: String

See Also

CvsInSightDisplayRecorderOptions Class
CvsInSightDisplayRecorderOptions..::..CvsInSightDisplayRecorderOptions Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions.RecordMax Property

[image]

In-Sight SDK
CvsInSightDisplayRecorderOptions..::..RecordMax Property
CvsInSightDisplayRecorderOptions Class See Also Send Feedback
Maximum number of images that can be recorded into one folder.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int RecordMax { get; set; }
Visual Basic
Public Property RecordMax As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsInSightDisplayRecorderOptions Class
CvsInSightDisplayRecorderOptions..::..CvsInSightDisplayRecorderOptions Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions.RecordMode Property

[image]

In-Sight SDK
CvsInSightDisplayRecorderOptions..::..RecordMode Property
CvsInSightDisplayRecorderOptions Class See Also Send Feedback
The Record mode.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsRecordMode RecordMode { get; set; }
Visual Basic
Public Property RecordMode As CvsRecordMode
    Get
    Set

Property Value

Type: CvsRecordMode

See Also

CvsInSightDisplayRecorderOptions Class
CvsInSightDisplayRecorderOptions..::..CvsInSightDisplayRecorderOptions Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions.RecordResolution Property

[image]

In-Sight SDK
CvsInSightDisplayRecorderOptions..::..RecordResolution Property
CvsInSightDisplayRecorderOptions Class See Also Send Feedback
The resolution setting of the sensor while recording online.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageResolution RecordResolution { get; set; }
Visual Basic
Public Property RecordResolution As CvsImageResolution
    Get
    Set

Property Value

Type: CvsImageResolution

Remarks

This resolution should NOT be used while recording images offline. Those images should be recorded at full resolution.

See Also

CvsInSightDisplayRecorderOptions Class
CvsInSightDisplayRecorderOptions..::..CvsInSightDisplayRecorderOptions Members
Cognex.InSight.Controls.Display Namespace


CvsInSightDisplayRecorderOptions.RecordWatchCell Property

[image]

In-Sight SDK
CvsInSightDisplayRecorderOptions..::..RecordWatchCell Property
CvsInSightDisplayRecorderOptions Class See Also Send Feedback
The cell to evaluate for record on conditional state.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string RecordWatchCell { get; set; }
Visual Basic
Public Property RecordWatchCell As String
    Get
    Set

Property Value

Type: String

See Also

CvsInSightDisplayRecorderOptions Class
CvsInSightDisplayRecorderOptions..::..CvsInSightDisplayRecorderOptions Members
Cognex.InSight.Controls.Display Namespace


CvsKeyboardState Structure

[image]

In-Sight SDK
CvsKeyboardState Structure
Members See Also Send Feedback
Holds the current keyboard state during a KeyDown or KeyUp event.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public struct CvsKeyboardState
Visual Basic
Public Structure CvsKeyboardState

See Also

CvsKeyboardState..::..CvsKeyboardState Members
Cognex.InSight.Controls.Display Namespace


CvsKeyboardState Members

[image] [image]

In-Sight SDK
CvsKeyboardState Members
CvsKeyboardState Structure Methods Properties See Also Send Feedback

The CvsKeyboardState type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

 | Name | Description
Public property | Alt | Gets or sets a value indicating if the alt key is being pressed.
Public property | Control | Gets or sets a value indicating if the control key is being pressed.
Public property | Shift | Gets or sets a value indicating if the shift key is being pressed.

See Also

CvsKeyboardState Structure
Cognex.InSight.Controls.Display Namespace


CvsKeyboardState Methods

[image] [image]

In-Sight SDK
CvsKeyboardState Methods
CvsKeyboardState Structure See Also Send Feedback

The CvsKeyboardState type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CvsKeyboardState Structure
Cognex.InSight.Controls.Display Namespace


CvsKeyboardState Properties

[image] [image]

In-Sight SDK
CvsKeyboardState Properties
CvsKeyboardState Structure See Also Send Feedback

The CvsKeyboardState type exposes the following members.

Properties

 | Name | Description
Public property | Alt | Gets or sets a value indicating if the alt key is being pressed.
Public property | Control | Gets or sets a value indicating if the control key is being pressed.
Public property | Shift | Gets or sets a value indicating if the shift key is being pressed.

See Also

CvsKeyboardState Structure
Cognex.InSight.Controls.Display Namespace


CvsKeyboardState.Alt Property

[image]

In-Sight SDK
CvsKeyboardState..::..Alt Property
CvsKeyboardState Structure See Also Send Feedback
Gets or sets a value indicating if the alt key is being pressed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool Alt { get; set; }
Visual Basic
Public Property Alt As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsKeyboardState Structure
CvsKeyboardState..::..CvsKeyboardState Members
Cognex.InSight.Controls.Display Namespace


CvsKeyboardState.Control Property

[image]

In-Sight SDK
CvsKeyboardState..::..Control Property
CvsKeyboardState Structure See Also Send Feedback
Gets or sets a value indicating if the control key is being pressed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool Control { get; set; }
Visual Basic
Public Property Control As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsKeyboardState Structure
CvsKeyboardState..::..CvsKeyboardState Members
Cognex.InSight.Controls.Display Namespace


CvsKeyboardState.Shift Property

[image]

In-Sight SDK
CvsKeyboardState..::..Shift Property
CvsKeyboardState Structure See Also Send Feedback
Gets or sets a value indicating if the shift key is being pressed.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool Shift { get; set; }
Visual Basic
Public Property Shift As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsKeyboardState Structure
CvsKeyboardState..::..CvsKeyboardState Members
Cognex.InSight.Controls.Display Namespace


CvsRecordMode Enumeration

[image]

In-Sight SDK
CvsRecordMode Enumeration
See Also Send Feedback
Values used by the RecordMode property to specify what images are recorded and whether they are sorted.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsRecordMode
Visual Basic
Public Enumeration CvsRecordMode

Members

Member name | Value | Description
All | 0 | Record all images the display receives into the RecordFolder.
Good | 1 | Record only the good images into the Good sub-folder Good = Cells with a non-zero value
Bad | 2 | Record only the bad images into the Bad sub-folder Bad = Cells with a zero or !ERR value
Sort | 3 | Sort images into the Good and Bad sub-folders

See Also

Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator Class

[image]

In-Sight SDK
CvsSpreadsheetNavigator Class
Members See Also Send Feedback
Provides a thumbnail view of the spreadsheet with a box indicating the current view within the display.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsSpreadsheetNavigator : Control,
    ICvsNavigatorViewMenuHandler
Visual Basic
Public Class CvsSpreadsheetNavigator
    Inherits Control
    Implements ICvsNavigatorViewMenuHandler

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
Cognex.InSight.Controls.Display..::..CvsSpreadsheetNavigator

See Also

CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator Members

[image] [image]

In-Sight SDK
CvsSpreadsheetNavigator Members
CvsSpreadsheetNavigator Class Constructors Methods Properties Events See Also Send Feedback

The CvsSpreadsheetNavigator type exposes the following members.

Constructors

 | Name | Description
Public method | CvsSpreadsheetNavigator | Constructs a new instance

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | ShowContextMenu | Display the context menu to allow users to switch view modes.
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Display | Gets or sets a reference to the display control with which this control is associated.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Displays | Gets or sets references to a collection of displays representing each of the sheets to be displayed in the navigator.
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowToolTips | Get or set whether or not to show the cell contents ToolTips.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CvsSpreadsheetNavigator Class
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator Constructor

[image]

In-Sight SDK
CvsSpreadsheetNavigator Constructor
CvsSpreadsheetNavigator Class See Also Send Feedback
Constructs a new instance

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsSpreadsheetNavigator(
    CvsInSightDisplay display
)
Visual Basic
Public Sub New (
    display As CvsInSightDisplay
)

Parameters

display
Type: Cognex.InSight.Controls.Display..::..CvsInSightDisplay
display we are connected to

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator Methods

[image] [image]

In-Sight SDK
CvsSpreadsheetNavigator Methods
CvsSpreadsheetNavigator Class See Also Send Feedback

The CvsSpreadsheetNavigator type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Control..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl()()()() method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Overrides Control..::..OnMouseLeave(EventArgs).)
Protected method | OnMouseMove | Raises the MouseMove event. (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Raises the MouseUp event. (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Paints the background of the control. (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::..OnSizeChanged(EventArgs).)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | ShowContextMenu | Display the context menu to allow users to switch view modes.
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Processes Windows messages. (Inherited from Control.)

See Also

CvsSpreadsheetNavigator Class
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator.Dispose Method

[image] [image]

In-Sight SDK
CvsSpreadsheetNavigator..::..Dispose Method
CvsSpreadsheetNavigator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Overrides Control..::..Dispose(Boolean).)

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator.Dispose Method (Boolean)

[image]

In-Sight SDK
CvsSpreadsheetNavigator..::..Dispose Method (Boolean)
CvsSpreadsheetNavigator Class See Also Send Feedback
Releases the unmanaged resources used by the Component and optionally releases the managed resources.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: System..::..Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Dispose Overload
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator.OnMouseDown Method

[image]

In-Sight SDK
CvsSpreadsheetNavigator..::..OnMouseDown Method
CvsSpreadsheetNavigator Class See Also Send Feedback
Raises the MouseDown event.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator.OnMouseLeave Method

[image]

In-Sight SDK
CvsSpreadsheetNavigator..::..OnMouseLeave Method
CvsSpreadsheetNavigator Class See Also Send Feedback
Raises the MouseLeave event.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave (
    e As EventArgs
)

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator.OnMouseMove Method

[image]

In-Sight SDK
CvsSpreadsheetNavigator..::..OnMouseMove Method
CvsSpreadsheetNavigator Class See Also Send Feedback
Raises the MouseMove event.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator.OnMouseUp Method

[image]

In-Sight SDK
CvsSpreadsheetNavigator..::..OnMouseUp Method
CvsSpreadsheetNavigator Class See Also Send Feedback
Raises the MouseUp event.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp (
    e As MouseEventArgs
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator.OnPaint Method

[image]

In-Sight SDK
CvsSpreadsheetNavigator..::..OnPaint Method
CvsSpreadsheetNavigator Class See Also Send Feedback
Raises the Paint event.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint (
    e As PaintEventArgs
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs
A PaintEventArgs that contains the event data.

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator.OnPaintBackground Method

[image]

In-Sight SDK
CvsSpreadsheetNavigator..::..OnPaintBackground Method
CvsSpreadsheetNavigator Class See Also Send Feedback
Paints the background of the control.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground (
    e As PaintEventArgs
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:Cognex.InSight.Controls.Display.CvsSpreadsheetNavigator.OnPaintBackground(System.Windows.Forms.PaintEventArgs)"]

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator.OnSizeChanged Method

[image]

In-Sight SDK
CvsSpreadsheetNavigator..::..OnSizeChanged Method
CvsSpreadsheetNavigator Class See Also Send Feedback
Raises the SizeChanged event.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSizeChanged (
    e As EventArgs
)

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator.ShowContextMenu Method

[image]

In-Sight SDK
CvsSpreadsheetNavigator..::..ShowContextMenu Method
CvsSpreadsheetNavigator Class See Also Send Feedback
Display the context menu to allow users to switch view modes.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected void ShowContextMenu(
    Point position
)
Visual Basic
Protected Sub ShowContextMenu (
    position As Point
)

Parameters

position
Type: System.Drawing..::..Point
The location to display the context menu.

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator Properties

[image] [image]

In-Sight SDK
CvsSpreadsheetNavigator Properties
CvsSpreadsheetNavigator Class See Also Send Feedback

The CvsSpreadsheetNavigator type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Control.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Display | Gets or sets a reference to the display control with which this control is associated.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Displays | Gets or sets references to a collection of displays representing each of the sheets to be displayed in the navigator.
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowToolTips | Get or set whether or not to show the cell contents ToolTips.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

CvsSpreadsheetNavigator Class
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator.Display Property

[image]

In-Sight SDK
CvsSpreadsheetNavigator..::..Display Property
CvsSpreadsheetNavigator Class See Also Send Feedback
Gets or sets a reference to the display control with which this control is associated.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplay Display { get; set; }
Visual Basic
Public Property Display As CvsInSightDisplay
    Get
    Set

Property Value

Type: CvsInSightDisplay

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator.Displays Property

[image]

In-Sight SDK
CvsSpreadsheetNavigator..::..Displays Property
CvsSpreadsheetNavigator Class See Also Send Feedback
Gets or sets references to a collection of displays representing each of the sheets to be displayed in the navigator.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerable<CvsInSightDisplay> Displays { get; set; }
Visual Basic
Public Property Displays As IEnumerable(Of CvsInSightDisplay)
    Get
    Set

Property Value

Type: IEnumerable <(Of <(<' CvsInSightDisplay >)>)>

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator.ShowToolTips Property

[image]

In-Sight SDK
CvsSpreadsheetNavigator..::..ShowToolTips Property
CvsSpreadsheetNavigator Class See Also Send Feedback
Get or set whether or not to show the cell contents ToolTips.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowToolTips { get; set; }
Visual Basic
Public Property ShowToolTips As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsSpreadsheetNavigator Class
CvsSpreadsheetNavigator..::..CvsSpreadsheetNavigator Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigator Events

[image] [image]

In-Sight SDK
CvsSpreadsheetNavigator Events
CvsSpreadsheetNavigator Class See Also Send Feedback

The CvsSpreadsheetNavigator type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CvsSpreadsheetNavigator Class
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigatorPanel Class

[image]

In-Sight SDK
CvsSpreadsheetNavigatorPanel Class
Members See Also Send Feedback
Contains the CvsSpreadsheetNavigator control for use in Docking windows

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsSpreadsheetNavigatorPanel : ToolWindowPanel
Visual Basic
Public Class CvsSpreadsheetNavigatorPanel
    Inherits ToolWindowPanel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
ToolWindowPanel
Cognex.InSight.Controls.Display..::..CvsSpreadsheetNavigatorPanel

See Also

CvsSpreadsheetNavigatorPanel..::..CvsSpreadsheetNavigatorPanel Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigatorPanel Members

[image] [image]

In-Sight SDK
CvsSpreadsheetNavigatorPanel Members
CvsSpreadsheetNavigatorPanel Class Constructors Methods Properties Events See Also Send Feedback

The CvsSpreadsheetNavigatorPanel type exposes the following members.

Constructors

 | Name | Description
Public method | CvsSpreadsheetNavigatorPanel | constructs a new instance

Methods

 | Name | Description
Public method | Accept | (Inherited from ToolWindowPanel.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from ToolWindowPanel.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowedDockState | (Inherited from ToolWindowPanel.)
Public property | AllowToggle | (Inherited from ToolWindowPanel.)
Public property | AlwaysForceVisible | (Inherited from ToolWindowPanel.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CaptionTextID | (Overrides ToolWindowPanelCaptionTextID.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | Closeable | (Inherited from ToolWindowPanel.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Display | Gets or sets the CvsInSightDisplay used by the navigator
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | (Overrides ToolWindowPanelIcon.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InitiallyVisible | (Overrides ToolWindowPanelInitiallyVisible.)
Public property | InitialSite | (Overrides ToolWindowPanelInitialSite.)
Public property | InitialSize | (Inherited from ToolWindowPanel.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CvsSpreadsheetNavigatorPanel Class
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigatorPanel Constructor

[image]

In-Sight SDK
CvsSpreadsheetNavigatorPanel Constructor
CvsSpreadsheetNavigatorPanel Class See Also Send Feedback
constructs a new instance

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsSpreadsheetNavigatorPanel(
    IContainer container,
    CvsInSightDisplay display
)
Visual Basic
Public Sub New (
    container As IContainer,
    display As CvsInSightDisplay
)

Parameters

container
Type: System.ComponentModel..::..IContainer

[Missing <param name="container"/> documentation for "M:Cognex.InSight.Controls.Display.CvsSpreadsheetNavigatorPanel.#ctor(System.ComponentModel.IContainer,Cognex.InSight.Controls.Display.CvsInSightDisplay)"]

display
Type: Cognex.InSight.Controls.Display..::..CvsInSightDisplay
CvsInsightDisplay we are connected to

See Also

CvsSpreadsheetNavigatorPanel Class
CvsSpreadsheetNavigatorPanel..::..CvsSpreadsheetNavigatorPanel Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigatorPanel Methods

[image] [image]

In-Sight SDK
CvsSpreadsheetNavigatorPanel Methods
CvsSpreadsheetNavigatorPanel Class See Also Send Feedback

The CvsSpreadsheetNavigatorPanel type exposes the following members.

Methods

 | Name | Description
Public method | Accept | (Inherited from ToolWindowPanel.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from ToolWindowPanel.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)

See Also

CvsSpreadsheetNavigatorPanel Class
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigatorPanel Properties

[image] [image]

In-Sight SDK
CvsSpreadsheetNavigatorPanel Properties
CvsSpreadsheetNavigatorPanel Class See Also Send Feedback

The CvsSpreadsheetNavigatorPanel type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowedDockState | (Inherited from ToolWindowPanel.)
Public property | AllowToggle | (Inherited from ToolWindowPanel.)
Public property | AlwaysForceVisible | (Inherited from ToolWindowPanel.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CaptionTextID | (Overrides ToolWindowPanelCaptionTextID.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | Closeable | (Inherited from ToolWindowPanel.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Display | Gets or sets the CvsInSightDisplay used by the navigator
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | (Overrides ToolWindowPanelIcon.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InitiallyVisible | (Overrides ToolWindowPanelInitiallyVisible.)
Public property | InitialSite | (Overrides ToolWindowPanelInitialSite.)
Public property | InitialSize | (Inherited from ToolWindowPanel.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

CvsSpreadsheetNavigatorPanel Class
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigatorPanel.CaptionTextID Property

[image]

In-Sight SDK
CvsSpreadsheetNavigatorPanel..::..CaptionTextID Property
CvsSpreadsheetNavigatorPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:Cognex.InSight.Controls.Display.CvsSpreadsheetNavigatorPanel.CaptionTextID"]

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public override string CaptionTextID { get; }
Visual Basic
Public Overrides ReadOnly Property CaptionTextID As String
    Get

Property Value

Type: String

See Also

CvsSpreadsheetNavigatorPanel Class
CvsSpreadsheetNavigatorPanel..::..CvsSpreadsheetNavigatorPanel Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigatorPanel.Display Property

[image]

In-Sight SDK
CvsSpreadsheetNavigatorPanel..::..Display Property
CvsSpreadsheetNavigatorPanel Class See Also Send Feedback
Gets or sets the CvsInSightDisplay used by the navigator

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplay Display { get; set; }
Visual Basic
Public Property Display As CvsInSightDisplay
    Get
    Set

Property Value

Type: CvsInSightDisplay

See Also

CvsSpreadsheetNavigatorPanel Class
CvsSpreadsheetNavigatorPanel..::..CvsSpreadsheetNavigatorPanel Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigatorPanel.Icon Property

[image]

In-Sight SDK
CvsSpreadsheetNavigatorPanel..::..Icon Property
CvsSpreadsheetNavigatorPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:Cognex.InSight.Controls.Display.CvsSpreadsheetNavigatorPanel.Icon"]

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public override int Icon { get; }
Visual Basic
Public Overrides ReadOnly Property Icon As Integer
    Get

Property Value

Type: Int32

See Also

CvsSpreadsheetNavigatorPanel Class
CvsSpreadsheetNavigatorPanel..::..CvsSpreadsheetNavigatorPanel Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigatorPanel.InitiallyVisible Property

[image]

In-Sight SDK
CvsSpreadsheetNavigatorPanel..::..InitiallyVisible Property
CvsSpreadsheetNavigatorPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:Cognex.InSight.Controls.Display.CvsSpreadsheetNavigatorPanel.InitiallyVisible"]

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public override bool InitiallyVisible { get; }
Visual Basic
Public Overrides ReadOnly Property InitiallyVisible As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSpreadsheetNavigatorPanel Class
CvsSpreadsheetNavigatorPanel..::..CvsSpreadsheetNavigatorPanel Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigatorPanel.InitialSite Property

[image]

In-Sight SDK
CvsSpreadsheetNavigatorPanel..::..InitialSite Property
CvsSpreadsheetNavigatorPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:Cognex.InSight.Controls.Display.CvsSpreadsheetNavigatorPanel.InitialSite"]

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public override DockingSite InitialSite { get; }
Visual Basic
Public Overrides ReadOnly Property InitialSite As DockingSite
    Get

Property Value

Type: DockingSite

See Also

CvsSpreadsheetNavigatorPanel Class
CvsSpreadsheetNavigatorPanel..::..CvsSpreadsheetNavigatorPanel Members
Cognex.InSight.Controls.Display Namespace


CvsSpreadsheetNavigatorPanel Events

[image] [image]

In-Sight SDK
CvsSpreadsheetNavigatorPanel Events
CvsSpreadsheetNavigatorPanel Class See Also Send Feedback

The CvsSpreadsheetNavigatorPanel type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CvsSpreadsheetNavigatorPanel Class
Cognex.InSight.Controls.Display Namespace


CvsStatusInformationState Enumeration

[image]

In-Sight SDK
CvsStatusInformationState Enumeration
See Also Send Feedback
The CvsStatusInformationState enumeration is used by the StatusInformationState property to indicate the current type of information contained in the StatusInformation property.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsStatusInformationState
Visual Basic
Public Enumeration CvsStatusInformationState

Members

Member name | Value | Description
None | 0 | No information is contained in the StatusInformation property.
Info | 1 | The StatusInformation property represents neutral information.
Warning | 2 | The StatusInformation property contains a warning message.
Error | 3 | The StatusInformation property contains an error message.

See Also

Cognex.InSight.Controls.Display Namespace


ICvsInSightDisplayEditForm Interface

[image]

In-Sight SDK
ICvsInSightDisplayEditForm Interface
Members See Also Send Feedback
An interface that provides forms with some control over the display's actions.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public interface ICvsInSightDisplayEditForm
Visual Basic
Public Interface ICvsInSightDisplayEditForm

See Also

ICvsInSightDisplayEditForm..::..ICvsInSightDisplayEditForm Members
Cognex.InSight.Controls.Display Namespace


ICvsInSightDisplayEditForm Members

[image] [image]

In-Sight SDK
ICvsInSightDisplayEditForm Members
ICvsInSightDisplayEditForm Interface Properties See Also Send Feedback

The ICvsInSightDisplayEditForm type exposes the following members.

Properties

 | Name | Description
Public property | AllowShowGrid | Returns true if ShowGrid should be allowed while the form is open.

See Also

ICvsInSightDisplayEditForm Interface
Cognex.InSight.Controls.Display Namespace


ICvsInSightDisplayEditForm Properties

[image] [image]

In-Sight SDK
ICvsInSightDisplayEditForm Properties
ICvsInSightDisplayEditForm Interface See Also Send Feedback

The ICvsInSightDisplayEditForm type exposes the following members.

Properties

 | Name | Description
Public property | AllowShowGrid | Returns true if ShowGrid should be allowed while the form is open.

See Also

ICvsInSightDisplayEditForm Interface
Cognex.InSight.Controls.Display Namespace


ICvsInSightDisplayEditForm.AllowShowGrid Property

[image]

In-Sight SDK
ICvsInSightDisplayEditForm..::..AllowShowGrid Property
ICvsInSightDisplayEditForm Interface See Also Send Feedback
Returns true if ShowGrid should be allowed while the form is open.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
bool AllowShowGrid { get; }
Visual Basic
ReadOnly Property AllowShowGrid As Boolean
    Get

Property Value

Type: Boolean

See Also

ICvsInSightDisplayEditForm Interface
ICvsInSightDisplayEditForm..::..ICvsInSightDisplayEditForm Members
Cognex.InSight.Controls.Display Namespace


IDisplayOptionsView Interface

[image]

In-Sight SDK
IDisplayOptionsView Interface
Members See Also Send Feedback
The interface between the options Emulation controller and the options Emulation control.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public interface IDisplayOptionsView
Visual Basic
Public Interface IDisplayOptionsView

See Also

IDisplayOptionsView..::..IDisplayOptionsView Members
Cognex.InSight.Controls.Display Namespace


IDisplayOptionsView Members

[image] [image]

In-Sight SDK
IDisplayOptionsView Members
IDisplayOptionsView Interface Methods Properties See Also Send Feedback

The IDisplayOptionsView type exposes the following members.

Methods

 | Name | Description
Public method | FireOptionsChanged | Raises the OptionsChanged event.

Properties

 | Name | Description
Public property | HighSaturationLevel | Gets or sets the level at or above which pixels will be shown in red when saturation display is enabled.
Public property | HighSaturationMin | The minimum value for the high saturation level.
Public property | LowSaturationLevel | Gets or sets the level at or below which pixels will be shown in blue when saturation display is enabled.
Public property | LowSaturationMax | The maximum value for the low saturation level.

See Also

IDisplayOptionsView Interface
Cognex.InSight.Controls.Display Namespace


IDisplayOptionsView Methods

[image] [image]

In-Sight SDK
IDisplayOptionsView Methods
IDisplayOptionsView Interface See Also Send Feedback

The IDisplayOptionsView type exposes the following members.

Methods

 | Name | Description
Public method | FireOptionsChanged | Raises the OptionsChanged event.

See Also

IDisplayOptionsView Interface
Cognex.InSight.Controls.Display Namespace


IDisplayOptionsView.FireOptionsChanged Method

[image]

In-Sight SDK
IDisplayOptionsView..::..FireOptionsChanged Method
IDisplayOptionsView Interface See Also Send Feedback
Raises the OptionsChanged event.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
void FireOptionsChanged()
Visual Basic
Sub FireOptionsChanged

See Also

IDisplayOptionsView Interface
IDisplayOptionsView..::..IDisplayOptionsView Members
Cognex.InSight.Controls.Display Namespace


IDisplayOptionsView Properties

[image] [image]

In-Sight SDK
IDisplayOptionsView Properties
IDisplayOptionsView Interface See Also Send Feedback

The IDisplayOptionsView type exposes the following members.

Properties

 | Name | Description
Public property | HighSaturationLevel | Gets or sets the level at or above which pixels will be shown in red when saturation display is enabled.
Public property | HighSaturationMin | The minimum value for the high saturation level.
Public property | LowSaturationLevel | Gets or sets the level at or below which pixels will be shown in blue when saturation display is enabled.
Public property | LowSaturationMax | The maximum value for the low saturation level.

See Also

IDisplayOptionsView Interface
Cognex.InSight.Controls.Display Namespace


IDisplayOptionsView.HighSaturationLevel Property

[image]

In-Sight SDK
IDisplayOptionsView..::..HighSaturationLevel Property
IDisplayOptionsView Interface See Also Send Feedback
Gets or sets the level at or above which pixels will be shown in red when saturation display is enabled.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
byte HighSaturationLevel { get; set; }
Visual Basic
Property HighSaturationLevel As Byte
    Get
    Set

Property Value

Type: Byte

See Also

IDisplayOptionsView Interface
IDisplayOptionsView..::..IDisplayOptionsView Members
Cognex.InSight.Controls.Display Namespace


IDisplayOptionsView.HighSaturationMin Property

[image]

In-Sight SDK
IDisplayOptionsView..::..HighSaturationMin Property
IDisplayOptionsView Interface See Also Send Feedback
The minimum value for the high saturation level.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
byte HighSaturationMin { get; set; }
Visual Basic
Property HighSaturationMin As Byte
    Get
    Set

Property Value

Type: Byte

See Also

IDisplayOptionsView Interface
IDisplayOptionsView..::..IDisplayOptionsView Members
Cognex.InSight.Controls.Display Namespace


IDisplayOptionsView.LowSaturationLevel Property

[image]

In-Sight SDK
IDisplayOptionsView..::..LowSaturationLevel Property
IDisplayOptionsView Interface See Also Send Feedback
Gets or sets the level at or below which pixels will be shown in blue when saturation display is enabled.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
byte LowSaturationLevel { get; set; }
Visual Basic
Property LowSaturationLevel As Byte
    Get
    Set

Property Value

Type: Byte

See Also

IDisplayOptionsView Interface
IDisplayOptionsView..::..IDisplayOptionsView Members
Cognex.InSight.Controls.Display Namespace


IDisplayOptionsView.LowSaturationMax Property

[image]

In-Sight SDK
IDisplayOptionsView..::..LowSaturationMax Property
IDisplayOptionsView Interface See Also Send Feedback
The maximum value for the low saturation level.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
byte LowSaturationMax { get; set; }
Visual Basic
Property LowSaturationMax As Byte
    Get
    Set

Property Value

Type: Byte

See Also

IDisplayOptionsView Interface
IDisplayOptionsView..::..IDisplayOptionsView Members
Cognex.InSight.Controls.Display Namespace


IProvideDialogActivationLocation Interface

[image]

In-Sight SDK
IProvideDialogActivationLocation Interface
Members See Also Send Feedback
Used by a dialog to indicate a safe location where the dialog can be activated without causing an event. Added since clicking at 5,5 on the OCRMax's AutoTuneDialog activates the reset button.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public interface IProvideDialogActivationLocation
Visual Basic
Public Interface IProvideDialogActivationLocation

See Also

IProvideDialogActivationLocation..::..IProvideDialogActivationLocation Members
Cognex.InSight.Controls.Display Namespace


IProvideDialogActivationLocation Members

[image] [image]

In-Sight SDK
IProvideDialogActivationLocation Members
IProvideDialogActivationLocation Interface Methods See Also Send Feedback

The IProvideDialogActivationLocation type exposes the following members.

Methods

 | Name | Description
Public method | GetClickableLocation | Returns a safe location where the dialog can be activated without causing an event.

See Also

IProvideDialogActivationLocation Interface
Cognex.InSight.Controls.Display Namespace


IProvideDialogActivationLocation Methods

[image] [image]

In-Sight SDK
IProvideDialogActivationLocation Methods
IProvideDialogActivationLocation Interface See Also Send Feedback

The IProvideDialogActivationLocation type exposes the following members.

Methods

 | Name | Description
Public method | GetClickableLocation | Returns a safe location where the dialog can be activated without causing an event.

See Also

IProvideDialogActivationLocation Interface
Cognex.InSight.Controls.Display Namespace


IProvideDialogActivationLocation.GetClickableLocation Method

[image]

In-Sight SDK
IProvideDialogActivationLocation..::..GetClickableLocation Method
IProvideDialogActivationLocation Interface See Also Send Feedback
Returns a safe location where the dialog can be activated without causing an event.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
Point GetClickableLocation()
Visual Basic
Function GetClickableLocation As Point

Return Value

Type: Point

[Missing <returns> documentation for "M:Cognex.InSight.Controls.Display.IProvideDialogActivationLocation.GetClickableLocation"]

See Also

IProvideDialogActivationLocation Interface
IProvideDialogActivationLocation..::..IProvideDialogActivationLocation Members
Cognex.InSight.Controls.Display Namespace


IUserListView Interface

[image]

In-Sight SDK
IUserListView Interface
Members See Also Send Feedback
The IUserListView interface is used to separate the controller and control functionality to aid in unit testing.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public interface IUserListView
Visual Basic
Public Interface IUserListView

See Also

IUserListView..::..IUserListView Members
Cognex.InSight.Controls.Display Namespace


IUserListView Members

[image] [image]

In-Sight SDK
IUserListView Members
IUserListView Interface Methods Properties See Also Send Feedback

The IUserListView type exposes the following members.

Methods

 | Name | Description
Public method | RefreshListBox | Refreshes the list view's display, sets the selected item and ensures that the selected item is visible in the list view.

Properties

 | Name | Description
Public property | AddEnabled | Sets the Add button enabled property (true means enabled)
Public property | DeleteEnabled | Sets the Delete button enabled property (true means enabled)
Public property | EditEnabled | Sets the Edit button enabled property (true means enabled)
Public property | IsAdminSelected | Gets the flag that states if the admin user is selected.
Public property | SelectedItemIndex | Gets or Sets the index into the list view control's collection identifying the selected item.
Public property | SelectedUserCount | Gets the current number of users selected.
Public property | SelectedUserName | Gets or Sets the user name string identifying the selected item in the list view control's collection. This is needed to keep track of the selected index after a sort/edit operation.
Public property | ShowSelectedItem | Gets or Sets the flag that tells the list view control whether or not an item should be selected.
Public property | UserList | Gets or sets the User Collection being edited.

See Also

IUserListView Interface
Cognex.InSight.Controls.Display Namespace


IUserListView Methods

[image] [image]

In-Sight SDK
IUserListView Methods
IUserListView Interface See Also Send Feedback

The IUserListView type exposes the following members.

Methods

 | Name | Description
Public method | RefreshListBox | Refreshes the list view's display, sets the selected item and ensures that the selected item is visible in the list view.

See Also

IUserListView Interface
Cognex.InSight.Controls.Display Namespace


IUserListView.RefreshListBox Method

[image]

In-Sight SDK
IUserListView..::..RefreshListBox Method
IUserListView Interface See Also Send Feedback
Refreshes the list view's display, sets the selected item and ensures that the selected item is visible in the list view.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
void RefreshListBox()
Visual Basic
Sub RefreshListBox

See Also

IUserListView Interface
IUserListView..::..IUserListView Members
Cognex.InSight.Controls.Display Namespace


IUserListView Properties

[image] [image]

In-Sight SDK
IUserListView Properties
IUserListView Interface See Also Send Feedback

The IUserListView type exposes the following members.

Properties

 | Name | Description
Public property | AddEnabled | Sets the Add button enabled property (true means enabled)
Public property | DeleteEnabled | Sets the Delete button enabled property (true means enabled)
Public property | EditEnabled | Sets the Edit button enabled property (true means enabled)
Public property | IsAdminSelected | Gets the flag that states if the admin user is selected.
Public property | SelectedItemIndex | Gets or Sets the index into the list view control's collection identifying the selected item.
Public property | SelectedUserCount | Gets the current number of users selected.
Public property | SelectedUserName | Gets or Sets the user name string identifying the selected item in the list view control's collection. This is needed to keep track of the selected index after a sort/edit operation.
Public property | ShowSelectedItem | Gets or Sets the flag that tells the list view control whether or not an item should be selected.
Public property | UserList | Gets or sets the User Collection being edited.

See Also

IUserListView Interface
Cognex.InSight.Controls.Display Namespace


IUserListView.AddEnabled Property

[image]

In-Sight SDK
IUserListView..::..AddEnabled Property
IUserListView Interface See Also Send Feedback
Sets the Add button enabled property (true means enabled)

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
bool AddEnabled { set; }
Visual Basic
WriteOnly Property AddEnabled As Boolean
    Set

Property Value

Type: Boolean

See Also

IUserListView Interface
IUserListView..::..IUserListView Members
Cognex.InSight.Controls.Display Namespace


IUserListView.DeleteEnabled Property

[image]

In-Sight SDK
IUserListView..::..DeleteEnabled Property
IUserListView Interface See Also Send Feedback
Sets the Delete button enabled property (true means enabled)

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
bool DeleteEnabled { set; }
Visual Basic
WriteOnly Property DeleteEnabled As Boolean
    Set

Property Value

Type: Boolean

See Also

IUserListView Interface
IUserListView..::..IUserListView Members
Cognex.InSight.Controls.Display Namespace


IUserListView.EditEnabled Property

[image]

In-Sight SDK
IUserListView..::..EditEnabled Property
IUserListView Interface See Also Send Feedback
Sets the Edit button enabled property (true means enabled)

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
bool EditEnabled { set; }
Visual Basic
WriteOnly Property EditEnabled As Boolean
    Set

Property Value

Type: Boolean

See Also

IUserListView Interface
IUserListView..::..IUserListView Members
Cognex.InSight.Controls.Display Namespace


IUserListView.IsAdminSelected Property

[image]

In-Sight SDK
IUserListView..::..IsAdminSelected Property
IUserListView Interface See Also Send Feedback
Gets the flag that states if the admin user is selected.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
bool IsAdminSelected { get; }
Visual Basic
ReadOnly Property IsAdminSelected As Boolean
    Get

Property Value

Type: Boolean

See Also

IUserListView Interface
IUserListView..::..IUserListView Members
Cognex.InSight.Controls.Display Namespace


IUserListView.SelectedItemIndex Property

[image]

In-Sight SDK
IUserListView..::..SelectedItemIndex Property
IUserListView Interface See Also Send Feedback
Gets or Sets the index into the list view control's collection identifying the selected item.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
int SelectedItemIndex { get; set; }
Visual Basic
Property SelectedItemIndex As Integer
    Get
    Set

Property Value

Type: Int32

See Also

IUserListView Interface
IUserListView..::..IUserListView Members
Cognex.InSight.Controls.Display Namespace


IUserListView.SelectedUserCount Property

[image]

In-Sight SDK
IUserListView..::..SelectedUserCount Property
IUserListView Interface See Also Send Feedback
Gets the current number of users selected.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
int SelectedUserCount { get; }
Visual Basic
ReadOnly Property SelectedUserCount As Integer
    Get

Property Value

Type: Int32

See Also

IUserListView Interface
IUserListView..::..IUserListView Members
Cognex.InSight.Controls.Display Namespace


IUserListView.SelectedUserName Property

[image]

In-Sight SDK
IUserListView..::..SelectedUserName Property
IUserListView Interface See Also Send Feedback
Gets or Sets the user name string identifying the selected item in the list view control's collection. This is needed to keep track of the selected index after a sort/edit operation.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
string SelectedUserName { get; set; }
Visual Basic
Property SelectedUserName As String
    Get
    Set

Property Value

Type: String

See Also

IUserListView Interface
IUserListView..::..IUserListView Members
Cognex.InSight.Controls.Display Namespace


IUserListView.ShowSelectedItem Property

[image]

In-Sight SDK
IUserListView..::..ShowSelectedItem Property
IUserListView Interface See Also Send Feedback
Gets or Sets the flag that tells the list view control whether or not an item should be selected.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
bool ShowSelectedItem { get; set; }
Visual Basic
Property ShowSelectedItem As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

IUserListView Interface
IUserListView..::..IUserListView Members
Cognex.InSight.Controls.Display Namespace


IUserListView.UserList Property

[image]

In-Sight SDK
IUserListView..::..UserList Property
IUserListView Interface See Also Send Feedback
Gets or sets the User Collection being edited.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
CvsUserCollection UserList { get; set; }
Visual Basic
Property UserList As CvsUserCollection
    Get
    Set

Property Value

Type: CvsUserCollection

See Also

IUserListView Interface
IUserListView..::..IUserListView Members
Cognex.InSight.Controls.Display Namespace


SpreadsheetNavigatorOptions Class

[image]

In-Sight SDK
SpreadsheetNavigatorOptions Class
Members See Also Send Feedback
class for storing spreadsheet navigator preferences uses SystemOptions to store data in Options.xml

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class SpreadsheetNavigatorOptions : Options
Visual Basic
Public Class SpreadsheetNavigatorOptions
    Inherits Options

Inheritance Hierarchy

System..::..Object
Options
Cognex.InSight.Controls.Display..::..SpreadsheetNavigatorOptions

See Also

SpreadsheetNavigatorOptions..::..SpreadsheetNavigatorOptions Members
Cognex.InSight.Controls.Display Namespace


SpreadsheetNavigatorOptions Members

[image] [image]

In-Sight SDK
SpreadsheetNavigatorOptions Members
SpreadsheetNavigatorOptions Class Constructors Methods Properties See Also Send Feedback

The SpreadsheetNavigatorOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SpreadsheetNavigatorOptions | constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LoadUnknownElement | (Inherited from Options.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentViewDisplayNameID | current view mode spreadsheet navigator is in
 | Options | gets the spreadsheet nav options
Public property | ToolTipsEnabled | if spreadsheetnav has tooltips enabled or nah

See Also

SpreadsheetNavigatorOptions Class
Cognex.InSight.Controls.Display Namespace


SpreadsheetNavigatorOptions Constructor

[image]

In-Sight SDK
SpreadsheetNavigatorOptions Constructor
SpreadsheetNavigatorOptions Class See Also Send Feedback
constructor

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public SpreadsheetNavigatorOptions()
Visual Basic
Public Sub New

See Also

SpreadsheetNavigatorOptions Class
SpreadsheetNavigatorOptions..::..SpreadsheetNavigatorOptions Members
Cognex.InSight.Controls.Display Namespace


SpreadsheetNavigatorOptions Methods

[image] [image]

In-Sight SDK
SpreadsheetNavigatorOptions Methods
SpreadsheetNavigatorOptions Class See Also Send Feedback

The SpreadsheetNavigatorOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | LoadUnknownElement | (Inherited from Options.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpreadsheetNavigatorOptions Class
Cognex.InSight.Controls.Display Namespace


SpreadsheetNavigatorOptions Properties

[image] [image]

In-Sight SDK
SpreadsheetNavigatorOptions Properties
SpreadsheetNavigatorOptions Class See Also Send Feedback

The SpreadsheetNavigatorOptions type exposes the following members.

Properties

 | Name | Description
Public property | CurrentViewDisplayNameID | current view mode spreadsheet navigator is in
 | Options | gets the spreadsheet nav options
Public property | ToolTipsEnabled | if spreadsheetnav has tooltips enabled or nah

See Also

SpreadsheetNavigatorOptions Class
Cognex.InSight.Controls.Display Namespace


SpreadsheetNavigatorOptions.CurrentViewDisplayNameID Property

[image]

In-Sight SDK
SpreadsheetNavigatorOptions..::..CurrentViewDisplayNameID Property
SpreadsheetNavigatorOptions Class See Also Send Feedback
current view mode spreadsheet navigator is in

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string CurrentViewDisplayNameID { get; set; }
Visual Basic
Public Property CurrentViewDisplayNameID As String
    Get
    Set

Property Value

Type: String

See Also

SpreadsheetNavigatorOptions Class
SpreadsheetNavigatorOptions..::..SpreadsheetNavigatorOptions Members
Cognex.InSight.Controls.Display Namespace


SpreadsheetNavigatorOptions.Options Property

[image]

In-Sight SDK
SpreadsheetNavigatorOptions..::..Options Property
SpreadsheetNavigatorOptions Class See Also Send Feedback
gets the spreadsheet nav options

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public static SpreadsheetNavigatorOptions Options { get; }
Visual Basic
Public Shared ReadOnly Property Options As SpreadsheetNavigatorOptions
    Get

Property Value

Type: SpreadsheetNavigatorOptions

See Also

SpreadsheetNavigatorOptions Class
SpreadsheetNavigatorOptions..::..SpreadsheetNavigatorOptions Members
Cognex.InSight.Controls.Display Namespace


SpreadsheetNavigatorOptions.ToolTipsEnabled Property

[image]

In-Sight SDK
SpreadsheetNavigatorOptions..::..ToolTipsEnabled Property
SpreadsheetNavigatorOptions Class See Also Send Feedback
if spreadsheetnav has tooltips enabled or nah

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ToolTipsEnabled { get; set; }
Visual Basic
Public Property ToolTipsEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

SpreadsheetNavigatorOptions Class
SpreadsheetNavigatorOptions..::..SpreadsheetNavigatorOptions Members
Cognex.InSight.Controls.Display Namespace


SynchronizedInspectionParametersDialog Class

[image]

In-Sight SDK
SynchronizedInspectionParametersDialog Class
Members See Also Send Feedback
The dialog that allows the user to edit parameters controlling the inspection synchronizer.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class SynchronizedInspectionParametersDialog : Dialog
Visual Basic
Public Class SynchronizedInspectionParametersDialog
    Inherits Dialog

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
RadFormControlBase
RadForm
BaseMenuShortcutForm
Dialog
Cognex.InSight.Controls.Display..::..SynchronizedInspectionParametersDialog

See Also

SynchronizedInspectionParametersDialog..::..SynchronizedInspectionParametersDialog Members
Cognex.InSight.Controls.Display Namespace


SynchronizedInspectionParametersDialog Members

[image] [image]

In-Sight SDK
SynchronizedInspectionParametersDialog Members
SynchronizedInspectionParametersDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The SynchronizedInspectionParametersDialog type exposes the following members.

Constructors

 | Name | Description
Public method | SynchronizedInspectionParametersDialog | Create an Inspection Synchronizer Parameters Dialog.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Protected method | AddInvalidatedRect | (Inherited from RadFormControlBase.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | AdjustToSize | (Inherited from Dialog.)
Protected method | AllowSizeChanges | (Inherited from BaseMenuShortcutForm.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | AutosizeToControl | (Inherited from Dialog.)
Public method | BeginInit | (Inherited from RadFormControlBase.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CallBaseWndProc | (Inherited from RadFormControlBase.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | CheckChildResizeRequests | (Inherited from Dialog.)
Protected method | Cleanup | (Inherited from Dialog.)
Public method | Close | Closes the form. (Inherited from Form.)
Protected method | Construct | (Inherited from RadFormControlBase.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ControlDefinesThemeForElement | (Inherited from RadFormControlBase.)
Public method | ControlThemeChangedCallback | (Inherited from RadFormControlBase.)
Protected method | CreateAccessibilityInstance | (Inherited from BaseMenuShortcutForm.)
Protected method | CreateChildItems | (Inherited from RadFormControlBase.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateRootElement | (Inherited from RadFormControlBase.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides DialogDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInit | (Inherited from Dialog.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Protected method | FindChildControlsRequestingResize | (Inherited from Dialog.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetDialogHelpTopic | (Inherited from Dialog.)
Protected method | GetDialogOptions | (Inherited from Dialog.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | (Inherited from RadFormControlBase.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUseNewLayout | (Inherited from RadFormControlBase.)
Protected method | HandleCancelPressed | (Inherited from Dialog.)
Protected method | HandleOkayPressed | (Inherited from Dialog.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Protected method | InitializeFormBehavior | (Inherited from BaseMenuShortcutForm.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | InvalidateElement(RadElement) | (Inherited from RadFormControlBase.)
Public method | InvalidateElement(RadElement, Rectangle) | (Inherited from RadFormControlBase.)
Public method | InvalidateIfNotSuspended | (Inherited from RadFormControlBase.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Public method | InvokeLayoutCallback | (Inherited from RadFormControlBase.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LoadElementTree()()()() | (Inherited from RadFormControlBase.)
Public method | LoadElementTree(Size) | (Inherited from RadFormControlBase.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | MergeShortcuts | (Inherited from BaseMenuShortcutForm.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | (Inherited from RadFormControlBase.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | (Inherited from RadFormControlBase.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnChildRequestedResize | (Inherited from Dialog.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | (Inherited from Dialog.)
Protected method | OnClosing | When dialog is closing, if the user press OK set the synchronized inspection parameters in the sensor to the values present in the dialog. (Overrides Form..::..OnClosing(CancelEventArgs).)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from RadFormControlBase.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDisplayPropertyChanged | (Inherited from RadFormControlBase.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from RadFormControlBase.)
Protected method | OnForeColorChanged | (Inherited from RadFormControlBase.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | (Inherited from Dialog.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | (Inherited from Dialog.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from RadFormControlBase.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad(EventArgs) | (Inherited from Dialog.)
Protected method | OnLoad(Size) | (Inherited from RadFormControlBase.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnNotifyPropertyChanged(String) | (Inherited from RadFormControlBase.)
Protected method | OnNotifyPropertyChanged(PropertyChangedEventArgs) | (Inherited from RadFormControlBase.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from RadFormControlBase.)
Protected method | OnPaintBackground | (Inherited from RadFormControlBase.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from RadFormControlBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScreenTipNeeded | (Inherited from RadFormControlBase.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnThemeChanged | (Inherited from RadFormControlBase.)
Protected method | OnThemeNameChanged | (Inherited from RadFormControlBase.)
Protected method | OnToolTipTextNeeded | (Inherited from RadFormControlBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Protected method | PerformDesignModeLocationCorrection | (Inherited from RadFormControlBase.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCaptureChangeRequested | (Inherited from RadForm.)
Protected method | ProcessCmdKey | (Inherited from Dialog.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessFocusRequested | (Inherited from RadFormControlBase.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | ReadWriteState | (Inherited from Dialog.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RegisterHostedControl | (Inherited from RadFormControlBase.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetFormBehavior | (Inherited from RadFormControlBase.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Protected method | ResizeIfChildRequestsIt | (Inherited from Dialog.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from RadFormControlBase.)
Public method | ResumeUpdate()()()() | (Inherited from RadFormControlBase.)
Public method | ResumeUpdate(Boolean) | (Inherited from RadFormControlBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from RadFormControlBase.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from RadFormControlBase.)
Protected method | SetClientSizeCore | (Inherited from RadFormControlBase.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | ShouldSerializeBackColor | (Inherited from RadFormControlBase.)
Public method | ShouldSerializeFont | (Inherited from RadFormControlBase.)
Public method | ShouldSerializeForeColor | (Inherited from RadFormControlBase.)
Protected method | ShouldSerializeProperty | (Inherited from RadFormControlBase.)
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | (Inherited from RadFormControlBase.)
Public method | SuspendUpdate | (Inherited from RadFormControlBase.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Protected method | UnmergeShortcuts | (Inherited from BaseMenuShortcutForm.)
Public method | UnregisterHostedControl | (Inherited from RadFormControlBase.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from BaseMenuShortcutForm.)

Fields

 | Name | Description
Public field | controlIsInitializingRootComponent | (Inherited from RadFormControlBase.)
Protected field | isBehaviorPrepared | (Inherited from RadFormControlBase.)
Protected field | isPainting | (Inherited from RadFormControlBase.)
Protected field | menuShortcutManager1 | (Inherited from BaseMenuShortcutForm.)

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowShowFocusCues | (Inherited from RadFormControlBase.)
Public property | AllowTheming | (Inherited from RadForm.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | AnalyticsName | (Inherited from RadFormControlBase.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoResizeIfChildRequests | (Inherited from Dialog.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from RadFormControlBase.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from RadFormControlBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from RadFormControlBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | Behavior | (Inherited from RadFormControlBase.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CancelOnEsc | (Inherited from Dialog.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CommandBindings | (Inherited from RadFormControlBase.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from RadFormControlBase.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | ElementTree | (Inherited from RadFormControlBase.)
Public property | EnableAnalytics | (Inherited from RadFormControlBase.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableKeyMap | (Inherited from RadFormControlBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusedElement | (Inherited from RadFormControlBase.)
Public property | Font | (Inherited from RadFormControlBase.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | (Inherited from RadFormControlBase.)
Public property | FormBehavior | (Inherited from RadFormControlBase.)
Public property | FormBorderStyle | (Inherited from RadFormControlBase.)
Public property | FormElement | (Inherited from RadForm.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from BaseMenuShortcutForm.)
Public property | IconScaling | (Inherited from RadForm.)
Public property | ImageList | (Inherited from RadFormControlBase.)
Public property | ImageScalingSize | (Inherited from RadFormControlBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDesignMode | (Inherited from RadFormControlBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInitialized | (Inherited from RadFormControlBase.)
Public property | IsLoaded | (Inherited from RadFormControlBase.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Protected property | IsUpdateSuspended | (Inherited from RadFormControlBase.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | LayoutManager | (Inherited from RadFormControlBase.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | (Inherited from RadFormControlBase.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | (Inherited from RadFormControlBase.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | RootElement | (Inherited from RadFormControlBase.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | (Inherited from RadForm.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | ShowItemToolTips | (Inherited from RadFormControlBase.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | (Inherited from RadFormControlBase.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | SmallImageList | (Inherited from RadFormControlBase.)
Public property | SmallImageScalingSize | (Inherited from RadFormControlBase.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | StateBehavior | (Inherited from Dialog.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | ThemeClassName | (Inherited from RadForm.)
Public property | ThemeName | (Inherited from RadFormControlBase.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Initialized | (Inherited from RadFormControlBase.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | (Inherited from RadFormControlBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | ScreenTipNeeded | (Inherited from RadFormControlBase.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | ThemeNameChanged | (Inherited from RadFormControlBase.)
Public event | ToolTipTextNeeded | (Inherited from RadFormControlBase.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SynchronizedInspectionParametersDialog Class
Cognex.InSight.Controls.Display Namespace


SynchronizedInspectionParametersDialog Constructor

[image]

In-Sight SDK
SynchronizedInspectionParametersDialog Constructor
SynchronizedInspectionParametersDialog Class See Also Send Feedback
Create an Inspection Synchronizer Parameters Dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public SynchronizedInspectionParametersDialog(
    CvsSensor sensor
)
Visual Basic
Public Sub New (
    sensor As CvsSensor
)

Parameters

sensor
Type: Cognex.InSight.Sensor..::..CvsSensor
The sensor to create the dialog for.

See Also

SynchronizedInspectionParametersDialog Class
SynchronizedInspectionParametersDialog..::..SynchronizedInspectionParametersDialog Members
Cognex.InSight.Controls.Display Namespace


SynchronizedInspectionParametersDialog Fields

[image] [image]

In-Sight SDK
SynchronizedInspectionParametersDialog Fields
SynchronizedInspectionParametersDialog Class See Also Send Feedback

The SynchronizedInspectionParametersDialog type exposes the following members.

Fields

 | Name | Description
Public field | controlIsInitializingRootComponent | (Inherited from RadFormControlBase.)
Protected field | isBehaviorPrepared | (Inherited from RadFormControlBase.)
Protected field | isPainting | (Inherited from RadFormControlBase.)
Protected field | menuShortcutManager1 | (Inherited from BaseMenuShortcutForm.)

See Also

SynchronizedInspectionParametersDialog Class
Cognex.InSight.Controls.Display Namespace


SynchronizedInspectionParametersDialog Methods

[image] [image]

In-Sight SDK
SynchronizedInspectionParametersDialog Methods
SynchronizedInspectionParametersDialog Class See Also Send Feedback

The SynchronizedInspectionParametersDialog type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Protected method | AddInvalidatedRect | (Inherited from RadFormControlBase.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | AdjustToSize | (Inherited from Dialog.)
Protected method | AllowSizeChanges | (Inherited from BaseMenuShortcutForm.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | AutosizeToControl | (Inherited from Dialog.)
Public method | BeginInit | (Inherited from RadFormControlBase.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CallBaseWndProc | (Inherited from RadFormControlBase.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | CheckChildResizeRequests | (Inherited from Dialog.)
Protected method | Cleanup | (Inherited from Dialog.)
Public method | Close | Closes the form. (Inherited from Form.)
Protected method | Construct | (Inherited from RadFormControlBase.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ControlDefinesThemeForElement | (Inherited from RadFormControlBase.)
Public method | ControlThemeChangedCallback | (Inherited from RadFormControlBase.)
Protected method | CreateAccessibilityInstance | (Inherited from BaseMenuShortcutForm.)
Protected method | CreateChildItems | (Inherited from RadFormControlBase.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateRootElement | (Inherited from RadFormControlBase.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides DialogDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInit | (Inherited from Dialog.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Protected method | FindChildControlsRequestingResize | (Inherited from Dialog.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Protected method | GetDialogHelpTopic | (Inherited from Dialog.)
Protected method | GetDialogOptions | (Inherited from Dialog.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | (Inherited from RadFormControlBase.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUseNewLayout | (Inherited from RadFormControlBase.)
Protected method | HandleCancelPressed | (Inherited from Dialog.)
Protected method | HandleOkayPressed | (Inherited from Dialog.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Protected method | InitializeFormBehavior | (Inherited from BaseMenuShortcutForm.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | InvalidateElement(RadElement) | (Inherited from RadFormControlBase.)
Public method | InvalidateElement(RadElement, Rectangle) | (Inherited from RadFormControlBase.)
Public method | InvalidateIfNotSuspended | (Inherited from RadFormControlBase.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Public method | InvokeLayoutCallback | (Inherited from RadFormControlBase.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LoadElementTree()()()() | (Inherited from RadFormControlBase.)
Public method | LoadElementTree(Size) | (Inherited from RadFormControlBase.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | MergeShortcuts | (Inherited from BaseMenuShortcutForm.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | (Inherited from RadFormControlBase.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | (Inherited from RadFormControlBase.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnChildRequestedResize | (Inherited from Dialog.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | (Inherited from Dialog.)
Protected method | OnClosing | When dialog is closing, if the user press OK set the synchronized inspection parameters in the sensor to the values present in the dialog. (Overrides Form..::..OnClosing(CancelEventArgs).)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from RadFormControlBase.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDisplayPropertyChanged | (Inherited from RadFormControlBase.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from RadFormControlBase.)
Protected method | OnForeColorChanged | (Inherited from RadFormControlBase.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | (Inherited from Dialog.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | (Inherited from Dialog.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from RadFormControlBase.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad(EventArgs) | (Inherited from Dialog.)
Protected method | OnLoad(Size) | (Inherited from RadFormControlBase.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnNotifyPropertyChanged(String) | (Inherited from RadFormControlBase.)
Protected method | OnNotifyPropertyChanged(PropertyChangedEventArgs) | (Inherited from RadFormControlBase.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from RadFormControlBase.)
Protected method | OnPaintBackground | (Inherited from RadFormControlBase.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from RadFormControlBase.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScreenTipNeeded | (Inherited from RadFormControlBase.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnThemeChanged | (Inherited from RadFormControlBase.)
Protected method | OnThemeNameChanged | (Inherited from RadFormControlBase.)
Protected method | OnToolTipTextNeeded | (Inherited from RadFormControlBase.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Protected method | PerformDesignModeLocationCorrection | (Inherited from RadFormControlBase.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCaptureChangeRequested | (Inherited from RadForm.)
Protected method | ProcessCmdKey | (Inherited from Dialog.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessFocusRequested | (Inherited from RadFormControlBase.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | ReadWriteState | (Inherited from Dialog.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RegisterHostedControl | (Inherited from RadFormControlBase.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetFormBehavior | (Inherited from RadFormControlBase.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Protected method | ResizeIfChildRequestsIt | (Inherited from Dialog.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from RadFormControlBase.)
Public method | ResumeUpdate()()()() | (Inherited from RadFormControlBase.)
Public method | ResumeUpdate(Boolean) | (Inherited from RadFormControlBase.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from RadFormControlBase.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from RadFormControlBase.)
Protected method | SetClientSizeCore | (Inherited from RadFormControlBase.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | ShouldSerializeBackColor | (Inherited from RadFormControlBase.)
Public method | ShouldSerializeFont | (Inherited from RadFormControlBase.)
Public method | ShouldSerializeForeColor | (Inherited from RadFormControlBase.)
Protected method | ShouldSerializeProperty | (Inherited from RadFormControlBase.)
Public method | Show()()()() | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | (Inherited from RadFormControlBase.)
Public method | SuspendUpdate | (Inherited from RadFormControlBase.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Protected method | UnmergeShortcuts | (Inherited from BaseMenuShortcutForm.)
Public method | UnregisterHostedControl | (Inherited from RadFormControlBase.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from BaseMenuShortcutForm.)

See Also

SynchronizedInspectionParametersDialog Class
Cognex.InSight.Controls.Display Namespace


SynchronizedInspectionParametersDialog.Dispose Method

[image] [image]

In-Sight SDK
SynchronizedInspectionParametersDialog..::..Dispose Method
SynchronizedInspectionParametersDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides DialogDispose(Boolean).)

See Also

SynchronizedInspectionParametersDialog Class
SynchronizedInspectionParametersDialog..::..SynchronizedInspectionParametersDialog Members
Cognex.InSight.Controls.Display Namespace


SynchronizedInspectionParametersDialog.Dispose Method (Boolean)

[image]

In-Sight SDK
SynchronizedInspectionParametersDialog..::..Dispose Method (Boolean)
SynchronizedInspectionParametersDialog Class See Also Send Feedback
Clean up any resources being used.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

SynchronizedInspectionParametersDialog Class
SynchronizedInspectionParametersDialog..::..SynchronizedInspectionParametersDialog Members
Dispose Overload
Cognex.InSight.Controls.Display Namespace


SynchronizedInspectionParametersDialog.OnClosing Method

[image]

In-Sight SDK
SynchronizedInspectionParametersDialog..::..OnClosing Method
SynchronizedInspectionParametersDialog Class See Also Send Feedback
When dialog is closing, if the user press OK set the synchronized inspection parameters in the sensor to the values present in the dialog.

Namespace: Cognex.InSight.Controls.Display
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void OnClosing(
    CancelEventArgs e
)
Visual Basic
Protected Overrides Sub OnClosing (
    e As CancelEventArgs
)

Parameters

e
Type: System.ComponentModel..::..CancelEventArgs
The event arguments.

See Also

SynchronizedInspectionParametersDialog Class
SynchronizedInspectionParametersDialog..::..SynchronizedInspectionParametersDialog Members
Cognex.InSight.Controls.Display Namespace


SynchronizedInspectionParametersDialog Properties

[image] [image]

In-Sight SDK
SynchronizedInspectionParametersDialog Properties
SynchronizedInspectionParametersDialog Class See Also Send Feedback

The SynchronizedInspectionParametersDialog type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowShowFocusCues | (Inherited from RadFormControlBase.)
Public property | AllowTheming | (Inherited from RadForm.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | AnalyticsName | (Inherited from RadFormControlBase.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoResizeIfChildRequests | (Inherited from Dialog.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from RadFormControlBase.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from RadFormControlBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from RadFormControlBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | Behavior | (Inherited from RadFormControlBase.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CancelOnEsc | (Inherited from Dialog.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CommandBindings | (Inherited from RadFormControlBase.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from RadFormControlBase.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | ElementTree | (Inherited from RadFormControlBase.)
Public property | EnableAnalytics | (Inherited from RadFormControlBase.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EnableKeyMap | (Inherited from RadFormControlBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusedElement | (Inherited from RadFormControlBase.)
Public property | Font | (Inherited from RadFormControlBase.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | (Inherited from RadFormControlBase.)
Public property | FormBehavior | (Inherited from RadFormControlBase.)
Public property | FormBorderStyle | (Inherited from RadFormControlBase.)
Public property | FormElement | (Inherited from RadForm.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from BaseMenuShortcutForm.)
Public property | IconScaling | (Inherited from RadForm.)
Public property | ImageList | (Inherited from RadFormControlBase.)
Public property | ImageScalingSize | (Inherited from RadFormControlBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDesignMode | (Inherited from RadFormControlBase.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInitialized | (Inherited from RadFormControlBase.)
Public property | IsLoaded | (Inherited from RadFormControlBase.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Protected property | IsUpdateSuspended | (Inherited from RadFormControlBase.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | LayoutManager | (Inherited from RadFormControlBase.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | (Inherited from RadFormControlBase.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | (Inherited from RadFormControlBase.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | RootElement | (Inherited from RadFormControlBase.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | (Inherited from RadForm.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | ShowItemToolTips | (Inherited from RadFormControlBase.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | (Inherited from RadFormControlBase.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | SmallImageList | (Inherited from RadFormControlBase.)
Public property | SmallImageScalingSize | (Inherited from RadFormControlBase.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | StateBehavior | (Inherited from Dialog.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | ThemeClassName | (Inherited from RadForm.)
Public property | ThemeName | (Inherited from RadFormControlBase.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

SynchronizedInspectionParametersDialog Class
Cognex.InSight.Controls.Display Namespace


SynchronizedInspectionParametersDialog Events

[image] [image]

In-Sight SDK
SynchronizedInspectionParametersDialog Events
SynchronizedInspectionParametersDialog Class See Also Send Feedback

The SynchronizedInspectionParametersDialog type exposes the following members.

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Initialized | (Inherited from RadFormControlBase.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PropertyChanged | (Inherited from RadFormControlBase.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | ScreenTipNeeded | (Inherited from RadFormControlBase.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | ThemeNameChanged | (Inherited from RadFormControlBase.)
Public event | ToolTipTextNeeded | (Inherited from RadFormControlBase.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SynchronizedInspectionParametersDialog Class
Cognex.InSight.Controls.Display Namespace


Cognex.InSight.Controls.Display.Extensions Namespace

[image]

In-Sight SDK
Cognex.InSight.Controls.Display.Extensions Namespace
Send Feedback

[Missing <summary> documentation for "N:Cognex.InSight.Controls.Display.Extensions"]

Classes

 | Class | Description
Public class | CnxUIDocumentExtensions | Extension methods for ICnxUIDocument objects.


CnxUIDocumentExtensions Class

[image]

In-Sight SDK
CnxUIDocumentExtensions Class
Members See Also Send Feedback
Extension methods for ICnxUIDocument objects.

Namespace: Cognex.InSight.Controls.Display.Extensions
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public static class CnxUIDocumentExtensions
Visual Basic
<ExtensionAttribute>
Public NotInheritable Class CnxUIDocumentExtensions

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Controls.Display.Extensions..::..CnxUIDocumentExtensions

See Also

CnxUIDocumentExtensions..::..CnxUIDocumentExtensions Members
Cognex.InSight.Controls.Display.Extensions Namespace


CnxUIDocumentExtensions Members

[image] [image]

In-Sight SDK
CnxUIDocumentExtensions Members
CnxUIDocumentExtensions Class Methods See Also Send Feedback

Methods

Name | Description
GetLocalizedName(ICnxUIDocument) | Gets the localized name based on the document name.
GetLocalizedName(String) | Gets the localized name based on the document name.

See Also

CnxUIDocumentExtensions Class
Cognex.InSight.Controls.Display.Extensions Namespace


CnxUIDocumentExtensions Methods

[image] [image]

In-Sight SDK
CnxUIDocumentExtensions Methods
CnxUIDocumentExtensions Class See Also Send Feedback

Methods

Name | Description
GetLocalizedName(ICnxUIDocument) | Gets the localized name based on the document name.
GetLocalizedName(String) | Gets the localized name based on the document name.

See Also

CnxUIDocumentExtensions Class
Cognex.InSight.Controls.Display.Extensions Namespace


CnxUIDocumentExtensions.GetLocalizedName Method

[image] [image]

In-Sight SDK
CnxUIDocumentExtensions..::..GetLocalizedName Method
CnxUIDocumentExtensions Class See Also Send Feedback

Overload List

Name | Description
GetLocalizedName(ICnxUIDocument) | Gets the localized name based on the document name.
GetLocalizedName(String) | Gets the localized name based on the document name.

See Also

CnxUIDocumentExtensions Class
CnxUIDocumentExtensions..::..CnxUIDocumentExtensions Members
Cognex.InSight.Controls.Display.Extensions Namespace


CnxUIDocumentExtensions.GetLocalizedName Method (ICnxUIDocument)

[image]

In-Sight SDK
CnxUIDocumentExtensions..::..GetLocalizedName Method (ICnxUIDocument)
CnxUIDocumentExtensions Class See Also Send Feedback
Gets the localized name based on the document name.

Namespace: Cognex.InSight.Controls.Display.Extensions
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public static string GetLocalizedName(
    this ICnxUIDocument document
)
Visual Basic
<ExtensionAttribute>
Public Shared Function GetLocalizedName (
    document As ICnxUIDocument
) As String

Parameters

document
Type: ICnxUIDocument

[Missing <param name="document"/> documentation for "M:Cognex.InSight.Controls.Display.Extensions.CnxUIDocumentExtensions.GetLocalizedName(Cognex.Cnx.UserInterface.ICnxUIDocument)"]

Return Value

Type: String
The localized text, or the non-localized name if localized text is not available.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICnxUIDocument. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

CnxUIDocumentExtensions Class
CnxUIDocumentExtensions..::..CnxUIDocumentExtensions Members
GetLocalizedName Overload
Cognex.InSight.Controls.Display.Extensions Namespace


CnxUIDocumentExtensions.GetLocalizedName Method (String)

[image]

In-Sight SDK
CnxUIDocumentExtensions..::..GetLocalizedName Method (String)
CnxUIDocumentExtensions Class See Also Send Feedback
Gets the localized name based on the document name.

Namespace: Cognex.InSight.Controls.Display.Extensions
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public static string GetLocalizedName(
    string documentName
)
Visual Basic
Public Shared Function GetLocalizedName (
    documentName As String
) As String

Parameters

documentName
Type: System..::..String

[Missing <param name="documentName"/> documentation for "M:Cognex.InSight.Controls.Display.Extensions.CnxUIDocumentExtensions.GetLocalizedName(System.String)"]

Return Value

Type: String
The localized text, or the non-localized name if localized text is not available.

See Also

CnxUIDocumentExtensions Class
CnxUIDocumentExtensions..::..CnxUIDocumentExtensions Members
GetLocalizedName Overload
Cognex.InSight.Controls.Display.Extensions Namespace


Cognex.InSight.Controls.Filmstrip Namespace

[image]

In-Sight SDK
Cognex.InSight.Controls.Filmstrip Namespace
Send Feedback
The Cognex.InSight.Controls.Filmstrip namespace contains the CvsFilmstrip control for displaying results.

Classes

 | Class | Description
Public class | CvsFilmstrip | The Filmstrip control can be used to play back images recorded to the PC or review images and results stored to the sensor.
Public class | CvsFilmstripPlayback | PlaybackRecorder operator for CvsFilmstrip, which handles the images playback.
Public class | CvsFilmstripResultsQueue | ResultsQueue operator for CvsFilmstrip
Public class | CvsFilmstripResultsQueueOptions | A class to hold all of the ResultsQueue options for CvsFilmstrip
Public class | CvsFilmstripResultsQueueSettings | Defines the sensor settings for the results queue.

Interfaces

 | Interface | Description
Public interface | ICvsFilmstripImage | Defines an image interface corresponding to a thumbnail of the CvsFilmstrip.
Public interface | ICvsFilmstripResultStatus | Defines a result status interface corresponding to a thumbnail of the CvsFilmstrip.

Enumerations

 | Enumeration | Description
Public enumeration | CvsFilmstripResultsQueueCellCondition | Specifies the bit fields for what inspections get added to the queue.
Public enumeration | CvsFilmstripResultsQueueCondition | Designates the values for CvsResultsQueueCellCondition fields.
Public enumeration | CvsFilmstripResultsQueueMode | Specifies what inspections get added to the queue.
Public enumeration | CvsFilmstripResultsQueueType | Specifies the type of result queue.
Public enumeration | CvsFilmstripScale | Indicates scales the filmstrip's size based on its initial height.
Public enumeration | CvsResultsQueueDisplayAction | Specifies what the Display should do when a new result is added to the queue.


CvsFilmstrip Class

[image]

In-Sight SDK
CvsFilmstrip Class
Members See Also Send Feedback
The Filmstrip control can be used to play back images recorded to the PC or review images and results stored to the sensor.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsFilmstrip : UserControl,
    ICvsFilmstripInternal
Visual Basic
Public Class CvsFilmstrip
    Inherits UserControl
    Implements ICvsFilmstripInternal

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
Cognex.InSight.Controls.Filmstrip..::..CvsFilmstrip

See Also

CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip Members

[image] [image]

In-Sight SDK
CvsFilmstrip Members
CvsFilmstrip Class Constructors Methods Properties Events See Also Send Feedback

The CvsFilmstrip type exposes the following members.

Constructors

 | Name | Description
Public method | CvsFilmstrip | Constructs a new instance of the class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFilmQueueChanged | Invokes the FilmQueueChanged event.
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Called when the controls is resized. (Overrides UserControl..::..OnResize(EventArgs).)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocess input message within the message loop before they are dispatched. (Overrides Control..::..PreProcessMessage(Message%).)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Preview a keyboard message. (Overrides Control..::..ProcessKeyPreview(Message%).)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Public method | UpdateStatus | Updates the filmstrip status.
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FilmQueue | Gets and sets the FilmQueue operator implementing the ICvsFilmQueue interface.
Public property | FirstThumbnailIndex | Gets and sets the zero-based index for the first thumbnail slot displayed.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HeightScale | Gets and sets the CvsFilmstripScale of the filmstrip control.
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageIndex | Gets and sets a value indicating the selected image index.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxThumbnailsDisplayed | Gets the number of total thumbnail slots that are displayed.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets and sets a value indicating the selected thumbnail index.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowSummary | Gets and sets whether the summary bar is visible.
Public property | ShowThumbnailImage | Gets and sets whether to show thumbnail images.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StatusLevelStyle | Gets and sets the style used to render the status of each item in the queue.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | ThumbnailsDisplayed | Gets the number of filled thumbnail slots that are displayed.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FilmQueueChanged | An event fired when the film queue is changed.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CvsFilmstrip Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip Constructor

[image]

In-Sight SDK
CvsFilmstrip Constructor
CvsFilmstrip Class See Also Send Feedback
Constructs a new instance of the class.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstrip()
Visual Basic
Public Sub New

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip Methods

[image] [image]

In-Sight SDK
CvsFilmstrip Methods
CvsFilmstrip Class See Also Send Feedback

The CvsFilmstrip type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFilmQueueChanged | Invokes the FilmQueueChanged event.
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Called when the controls is resized. (Overrides UserControl..::..OnResize(EventArgs).)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocess input message within the message loop before they are dispatched. (Overrides Control..::..PreProcessMessage(Message%).)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Preview a keyboard message. (Overrides Control..::..ProcessKeyPreview(Message%).)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Public method | UpdateStatus | Updates the filmstrip status.
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)

See Also

CvsFilmstrip Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.Dispose Method

[image] [image]

In-Sight SDK
CvsFilmstrip..::..Dispose Method
CvsFilmstrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.Dispose Method (Boolean)

[image]

In-Sight SDK
CvsFilmstrip..::..Dispose Method (Boolean)
CvsFilmstrip Class See Also Send Feedback
Clean up any resources being used.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Dispose Overload
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.OnFilmQueueChanged Method

[image]

In-Sight SDK
CvsFilmstrip..::..OnFilmQueueChanged Method
CvsFilmstrip Class See Also Send Feedback
Invokes the FilmQueueChanged event.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected virtual void OnFilmQueueChanged()
Visual Basic
Protected Overridable Sub OnFilmQueueChanged

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.OnResize Method

[image]

In-Sight SDK
CvsFilmstrip..::..OnResize Method
CvsFilmstrip Class See Also Send Feedback
Called when the controls is resized.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void OnResize(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnResize (
    e As EventArgs
)

Parameters

e
Type: System..::..EventArgs
The event args.

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.PreProcessMessage Method

[image]

In-Sight SDK
CvsFilmstrip..::..PreProcessMessage Method
CvsFilmstrip Class See Also Send Feedback
Preprocess input message within the message loop before they are dispatched.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public override bool PreProcessMessage(
    ref Message msg
)
Visual Basic
Public Overrides Function PreProcessMessage (
    ByRef msg As Message
) As Boolean

Parameters

msg
Type: System.Windows.Forms..::..Message %
A message, passed by reference, that represents the message to process.

Return Value

Type: Boolean
True if the message was processed by the control; otherwise, false.

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.ProcessKeyPreview Method

[image]

In-Sight SDK
CvsFilmstrip..::..ProcessKeyPreview Method
CvsFilmstrip Class See Also Send Feedback
Preview a keyboard message.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override bool ProcessKeyPreview(
    ref Message m
)
Visual Basic
Protected Overrides Function ProcessKeyPreview (
    ByRef m As Message
) As Boolean

Parameters

m
Type: System.Windows.Forms..::..Message %
A Message, passed by reference, that represents the window message to process.

Return Value

Type: Boolean
true if the message was processed by the control; otherwise, false.

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.UpdateStatus Method

[image]

In-Sight SDK
CvsFilmstrip..::..UpdateStatus Method
CvsFilmstrip Class See Also Send Feedback
Updates the filmstrip status.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void UpdateStatus()
Visual Basic
Public Sub UpdateStatus

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip Properties

[image] [image]

In-Sight SDK
CvsFilmstrip Properties
CvsFilmstrip Class See Also Send Feedback

The CvsFilmstrip type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FilmQueue | Gets and sets the FilmQueue operator implementing the ICvsFilmQueue interface.
Public property | FirstThumbnailIndex | Gets and sets the zero-based index for the first thumbnail slot displayed.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HeightScale | Gets and sets the CvsFilmstripScale of the filmstrip control.
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImageIndex | Gets and sets a value indicating the selected image index.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxThumbnailsDisplayed | Gets the number of total thumbnail slots that are displayed.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedIndex | Gets and sets a value indicating the selected thumbnail index.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowSummary | Gets and sets whether the summary bar is visible.
Public property | ShowThumbnailImage | Gets and sets whether to show thumbnail images.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StatusLevelStyle | Gets and sets the style used to render the status of each item in the queue.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | ThumbnailsDisplayed | Gets the number of filled thumbnail slots that are displayed.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

CvsFilmstrip Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.FilmQueue Property

[image]

In-Sight SDK
CvsFilmstrip..::..FilmQueue Property
CvsFilmstrip Class See Also Send Feedback
Gets and sets the FilmQueue operator implementing the ICvsFilmQueue interface.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public ICvsFilmQueue FilmQueue { get; set; }
Visual Basic
Public Property FilmQueue As ICvsFilmQueue
    Get
    Set

Property Value

Type: ICvsFilmQueue

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.FirstThumbnailIndex Property

[image]

In-Sight SDK
CvsFilmstrip..::..FirstThumbnailIndex Property
CvsFilmstrip Class See Also Send Feedback
Gets and sets the zero-based index for the first thumbnail slot displayed.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int FirstThumbnailIndex { get; set; }
Visual Basic
Public Property FirstThumbnailIndex As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.HeightScale Property

[image]

In-Sight SDK
CvsFilmstrip..::..HeightScale Property
CvsFilmstrip Class See Also Send Feedback
Gets and sets the CvsFilmstripScale of the filmstrip control.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstripScale HeightScale { get; set; }
Visual Basic
Public Property HeightScale As CvsFilmstripScale
    Get
    Set

Property Value

Type: CvsFilmstripScale

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.ImageIndex Property

[image]

In-Sight SDK
CvsFilmstrip..::..ImageIndex Property
CvsFilmstrip Class See Also Send Feedback
Gets and sets a value indicating the selected image index.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int ImageIndex { get; set; }
Visual Basic
Public Property ImageIndex As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.MaxThumbnailsDisplayed Property

[image]

In-Sight SDK
CvsFilmstrip..::..MaxThumbnailsDisplayed Property
CvsFilmstrip Class See Also Send Feedback
Gets the number of total thumbnail slots that are displayed.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int MaxThumbnailsDisplayed { get; }
Visual Basic
Public ReadOnly Property MaxThumbnailsDisplayed As Integer
    Get

Property Value

Type: Int32

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.SelectedIndex Property

[image]

In-Sight SDK
CvsFilmstrip..::..SelectedIndex Property
CvsFilmstrip Class See Also Send Feedback
Gets and sets a value indicating the selected thumbnail index.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic
Public Property SelectedIndex As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.ShowSummary Property

[image]

In-Sight SDK
CvsFilmstrip..::..ShowSummary Property
CvsFilmstrip Class See Also Send Feedback
Gets and sets whether the summary bar is visible.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowSummary { get; set; }
Visual Basic
Public Property ShowSummary As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.ShowThumbnailImage Property

[image]

In-Sight SDK
CvsFilmstrip..::..ShowThumbnailImage Property
CvsFilmstrip Class See Also Send Feedback
Gets and sets whether to show thumbnail images.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowThumbnailImage { get; set; }
Visual Basic
Public Property ShowThumbnailImage As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.StatusLevelStyle Property

[image]

In-Sight SDK
CvsFilmstrip..::..StatusLevelStyle Property
CvsFilmstrip Class See Also Send Feedback
Gets and sets the style used to render the status of each item in the queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsStatusLevelStyle StatusLevelStyle { get; set; }
Visual Basic
Public Property StatusLevelStyle As CvsStatusLevelStyle
    Get
    Set

Property Value

Type: CvsStatusLevelStyle

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.ThumbnailsDisplayed Property

[image]

In-Sight SDK
CvsFilmstrip..::..ThumbnailsDisplayed Property
CvsFilmstrip Class See Also Send Feedback
Gets the number of filled thumbnail slots that are displayed.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int ThumbnailsDisplayed { get; }
Visual Basic
Public ReadOnly Property ThumbnailsDisplayed As Integer
    Get

Property Value

Type: Int32

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip Events

[image] [image]

In-Sight SDK
CvsFilmstrip Events
CvsFilmstrip Class See Also Send Feedback

The CvsFilmstrip type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FilmQueueChanged | An event fired when the film queue is changed.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CvsFilmstrip Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstrip.FilmQueueChanged Event

[image]

In-Sight SDK
CvsFilmstrip..::..FilmQueueChanged Event
CvsFilmstrip Class See Also Send Feedback
An event fired when the film queue is changed.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler FilmQueueChanged
Visual Basic
Public Event FilmQueueChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsFilmstrip Class
CvsFilmstrip..::..CvsFilmstrip Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback Class

[image]

In-Sight SDK
CvsFilmstripPlayback Class
Members See Also Send Feedback
PlaybackRecorder operator for CvsFilmstrip, which handles the images playback.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsFilmstripPlayback : ICvsFilmQueue,
    IDisposable
Visual Basic
Public Class CvsFilmstripPlayback
    Implements ICvsFilmQueue, IDisposable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Controls.Filmstrip..::..CvsFilmstripPlayback

See Also

CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback Members

[image] [image]

In-Sight SDK
CvsFilmstripPlayback Members
CvsFilmstripPlayback Class Constructors Methods Properties See Also Send Feedback

The CvsFilmstripPlayback type exposes the following members.

Constructors

 | Name | Description
Public method | CvsFilmstripPlayback()()()() | Constructs a instance of the CvsFilmstripPlayback class.
Public method | CvsFilmstripPlayback(CvsFilmstrip) | Constructs a instance of the CvsFilmstripPlayback class.

Methods

 | Name | Description
Public method | Connect | Connects to the CvsInSightDisplayRecorder, then update the controls and images.
Public method | Disconnect | Disconnects from the CvsInSightDisplayRecorder.
Public method | Dispose | Dispose
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalize (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessShortcutKeys | Process Shortcut keys.
Public method | RequestThumbnailImagesUpdate | Requests thumbnail images to be updated.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name Description
Public property ClearQueue
Handles clearing the queue action.
Public property DeleteSelectedItem
Handles deleting the selected result in the queue.

Remarks

Not supported.
Public property Enabled
Gets and sets a boolean indicating whether the subject should be enabled.
Public property Filmstrip
Gets and sets the CvsFilmstrip control.
Public property Play
Handles continously playing back the images action.
Public property QueueSize
Gets the number of elements in the Results Queue.
Public property Recorder
Gets and sets CvsInSightDisplayRecorder, which provides playback images and navigation operations.
Public property ResultsStatus
Gets results status.
Public property SaveQueue
Handles saving the queue action.

Remarks

Not supported.
Public property SelectedIndex
Gets and sets the index of the result to display.
Public property SelectFirst
Handles selecting the first result in the queue action.
Public property SelectLast
Handles selecting the last result in the queue action.
Public property SelectNext
Handles selecting the next result in the queue action.
Public property SelectNextPage
Handles selecting the next results page in the queue action..
Public property SelectPrevious
Handles selecting the previous result in the queue action.
Public property SelectPrevPage
Handles selecting the previous results page in the queue action.
Public property SupportsEdit
Gets whether the FilmQueue is editable.

Remarks

CvsFilmstripPlayback's results queue is not editable.
Public property ThumbnailImages
Gets thumbnail images.

See Also

CvsFilmstripPlayback Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback Constructor

[image] [image]

In-Sight SDK
CvsFilmstripPlayback Constructor
CvsFilmstripPlayback Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsFilmstripPlayback()()()() | Constructs a instance of the CvsFilmstripPlayback class.
Public method | CvsFilmstripPlayback(CvsFilmstrip) | Constructs a instance of the CvsFilmstripPlayback class.

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback Constructor

[image]

In-Sight SDK
CvsFilmstripPlayback Constructor
CvsFilmstripPlayback Class See Also Send Feedback
Constructs a instance of the CvsFilmstripPlayback class.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstripPlayback()
Visual Basic
Public Sub New

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
CvsFilmstripPlayback Overload
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback Constructor (CvsFilmstrip)

[image]

In-Sight SDK
CvsFilmstripPlayback Constructor (CvsFilmstrip)
CvsFilmstripPlayback Class See Also Send Feedback
Constructs a instance of the CvsFilmstripPlayback class.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstripPlayback(
    CvsFilmstrip _filmstrip
)
Visual Basic
Public Sub New (
    _filmstrip As CvsFilmstrip
)

Parameters

_filmstrip
Type: Cognex.InSight.Controls.Filmstrip..::..CvsFilmstrip
CvsFilmstrip connected.

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
CvsFilmstripPlayback Overload
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback Methods

[image] [image]

In-Sight SDK
CvsFilmstripPlayback Methods
CvsFilmstripPlayback Class See Also Send Feedback

The CvsFilmstripPlayback type exposes the following members.

Methods

 | Name | Description
Public method | Connect | Connects to the CvsInSightDisplayRecorder, then update the controls and images.
Public method | Disconnect | Disconnects from the CvsInSightDisplayRecorder.
Public method | Dispose | Dispose
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalize (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessShortcutKeys | Process Shortcut keys.
Public method | RequestThumbnailImagesUpdate | Requests thumbnail images to be updated.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsFilmstripPlayback Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.Connect Method

[image]

In-Sight SDK
CvsFilmstripPlayback..::..Connect Method
CvsFilmstripPlayback Class See Also Send Feedback
Connects to the CvsInSightDisplayRecorder, then update the controls and images.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Connect()
Visual Basic
Public Sub Connect

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.Disconnect Method

[image]

In-Sight SDK
CvsFilmstripPlayback..::..Disconnect Method
CvsFilmstripPlayback Class See Also Send Feedback
Disconnects from the CvsInSightDisplayRecorder.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Disconnect()
Visual Basic
Public Sub Disconnect

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.Dispose Method

[image]

In-Sight SDK
CvsFilmstripPlayback..::..Dispose Method
CvsFilmstripPlayback Class See Also Send Feedback
Dispose

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.Finalize Method

[image]

In-Sight SDK
CvsFilmstripPlayback..::..Finalize Method
CvsFilmstripPlayback Class See Also Send Feedback
Finalize

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize

Implements

Object..::..Finalize()()()()

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.ProcessShortcutKeys Method

[image]

In-Sight SDK
CvsFilmstripPlayback..::..ProcessShortcutKeys Method
CvsFilmstripPlayback Class See Also Send Feedback
Process Shortcut keys.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void ProcessShortcutKeys(
    KeyEventArgs e
)
Visual Basic
Public Sub ProcessShortcutKeys (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
A KeyEventArgs object.

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.RequestThumbnailImagesUpdate Method

[image]

In-Sight SDK
CvsFilmstripPlayback..::..RequestThumbnailImagesUpdate Method
CvsFilmstripPlayback Class See Also Send Feedback
Requests thumbnail images to be updated.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void RequestThumbnailImagesUpdate(
    int index,
    int count,
    int imageIndex
)
Visual Basic
Public Sub RequestThumbnailImagesUpdate (
    index As Integer,
    count As Integer,
    imageIndex As Integer
)

Parameters

index
Type: System..::..Int32
Index of the first image.
count
Type: System..::..Int32
Number of images
imageIndex
Type: System..::..Int32
Image index

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback Properties

[image] [image]

In-Sight SDK
CvsFilmstripPlayback Properties
CvsFilmstripPlayback Class See Also Send Feedback

The CvsFilmstripPlayback type exposes the following members.

Properties

Name Description
Public property ClearQueue
Handles clearing the queue action.
Public property DeleteSelectedItem
Handles deleting the selected result in the queue.

Remarks

Not supported.
Public property Enabled
Gets and sets a boolean indicating whether the subject should be enabled.
Public property Filmstrip
Gets and sets the CvsFilmstrip control.
Public property Play
Handles continously playing back the images action.
Public property QueueSize
Gets the number of elements in the Results Queue.
Public property Recorder
Gets and sets CvsInSightDisplayRecorder, which provides playback images and navigation operations.
Public property ResultsStatus
Gets results status.
Public property SaveQueue
Handles saving the queue action.

Remarks

Not supported.
Public property SelectedIndex
Gets and sets the index of the result to display.
Public property SelectFirst
Handles selecting the first result in the queue action.
Public property SelectLast
Handles selecting the last result in the queue action.
Public property SelectNext
Handles selecting the next result in the queue action.
Public property SelectNextPage
Handles selecting the next results page in the queue action..
Public property SelectPrevious
Handles selecting the previous result in the queue action.
Public property SelectPrevPage
Handles selecting the previous results page in the queue action.
Public property SupportsEdit
Gets whether the FilmQueue is editable.

Remarks

CvsFilmstripPlayback's results queue is not editable.
Public property ThumbnailImages
Gets thumbnail images.

See Also

CvsFilmstripPlayback Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.ClearQueue Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..ClearQueue Property
CvsFilmstripPlayback Class See Also Send Feedback
Handles clearing the queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ClearQueue { get; }
Visual Basic
Public ReadOnly Property ClearQueue As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.DeleteSelectedItem Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..DeleteSelectedItem Property
CvsFilmstripPlayback Class See Also Send Feedback
Handles deleting the selected result in the queue.

Remarks

Not supported.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction DeleteSelectedItem { get; }
Visual Basic
Public ReadOnly Property DeleteSelectedItem As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.Enabled Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..Enabled Property
CvsFilmstripPlayback Class See Also Send Feedback
Gets and sets a boolean indicating whether the subject should be enabled.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.Filmstrip Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..Filmstrip Property
CvsFilmstripPlayback Class See Also Send Feedback
Gets and sets the CvsFilmstrip control.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstrip Filmstrip { get; set; }
Visual Basic
Public Property Filmstrip As CvsFilmstrip
    Get
    Set

Property Value

Type: CvsFilmstrip

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.Play Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..Play Property
CvsFilmstripPlayback Class See Also Send Feedback
Handles continously playing back the images action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle Play { get; }
Visual Basic
Public ReadOnly Property Play As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.QueueSize Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..QueueSize Property
CvsFilmstripPlayback Class See Also Send Feedback
Gets the number of elements in the Results Queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int QueueSize { get; }
Visual Basic
Public ReadOnly Property QueueSize As Integer
    Get

Property Value

Type: Int32

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.Recorder Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..Recorder Property
CvsFilmstripPlayback Class See Also Send Feedback
Gets and sets CvsInSightDisplayRecorder, which provides playback images and navigation operations.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightDisplayRecorder Recorder { get; set; }
Visual Basic
Public Property Recorder As CvsInSightDisplayRecorder
    Get
    Set

Property Value

Type: CvsInSightDisplayRecorder

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.ResultsStatus Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..ResultsStatus Property
CvsFilmstripPlayback Class See Also Send Feedback
Gets results status.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public ICvsFilmstripResultStatus[] ResultsStatus { get; }
Visual Basic
Public ReadOnly Property ResultsStatus As ICvsFilmstripResultStatus()
    Get

Property Value

Type: array< ICvsFilmstripResultStatus >[]()[][]

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.SaveQueue Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..SaveQueue Property
CvsFilmstripPlayback Class See Also Send Feedback
Handles saving the queue action.

Remarks

Not supported.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SaveQueue { get; }
Visual Basic
Public ReadOnly Property SaveQueue As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.SelectedIndex Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..SelectedIndex Property
CvsFilmstripPlayback Class See Also Send Feedback
Gets and sets the index of the result to display.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic
Public Property SelectedIndex As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.SelectFirst Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..SelectFirst Property
CvsFilmstripPlayback Class See Also Send Feedback
Handles selecting the first result in the queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectFirst { get; }
Visual Basic
Public ReadOnly Property SelectFirst As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.SelectLast Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..SelectLast Property
CvsFilmstripPlayback Class See Also Send Feedback
Handles selecting the last result in the queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectLast { get; }
Visual Basic
Public ReadOnly Property SelectLast As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.SelectNext Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..SelectNext Property
CvsFilmstripPlayback Class See Also Send Feedback
Handles selecting the next result in the queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectNext { get; }
Visual Basic
Public ReadOnly Property SelectNext As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.SelectNextPage Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..SelectNextPage Property
CvsFilmstripPlayback Class See Also Send Feedback
Handles selecting the next results page in the queue action..

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectNextPage { get; }
Visual Basic
Public ReadOnly Property SelectNextPage As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.SelectPrevious Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..SelectPrevious Property
CvsFilmstripPlayback Class See Also Send Feedback
Handles selecting the previous result in the queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectPrevious { get; }
Visual Basic
Public ReadOnly Property SelectPrevious As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.SelectPrevPage Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..SelectPrevPage Property
CvsFilmstripPlayback Class See Also Send Feedback
Handles selecting the previous results page in the queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectPrevPage { get; }
Visual Basic
Public ReadOnly Property SelectPrevPage As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.SupportsEdit Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..SupportsEdit Property
CvsFilmstripPlayback Class See Also Send Feedback
Gets whether the FilmQueue is editable.

Remarks

CvsFilmstripPlayback's results queue is not editable.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool SupportsEdit { get; }
Visual Basic
Public ReadOnly Property SupportsEdit As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripPlayback.ThumbnailImages Property

[image]

In-Sight SDK
CvsFilmstripPlayback..::..ThumbnailImages Property
CvsFilmstripPlayback Class See Also Send Feedback
Gets thumbnail images.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public ICvsFilmstripImage[] ThumbnailImages { get; }
Visual Basic
Public ReadOnly Property ThumbnailImages As ICvsFilmstripImage()
    Get

Property Value

Type: array< ICvsFilmstripImage >[]()[][]

See Also

CvsFilmstripPlayback Class
CvsFilmstripPlayback..::..CvsFilmstripPlayback Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue Class

[image]

In-Sight SDK
CvsFilmstripResultsQueue Class
Members See Also Send Feedback
ResultsQueue operator for CvsFilmstrip

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsFilmstripResultsQueue : ICvsFilmQueue,
    IDisposable
Visual Basic
Public Class CvsFilmstripResultsQueue
    Implements ICvsFilmQueue, IDisposable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Controls.Filmstrip..::..CvsFilmstripResultsQueue

See Also

CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue Members

[image] [image]

In-Sight SDK
CvsFilmstripResultsQueue Members
CvsFilmstripResultsQueue Class Constructors Methods Properties See Also Send Feedback

The CvsFilmstripResultsQueue type exposes the following members.

Constructors

 | Name | Description
Public method | CvsFilmstripResultsQueue()()()() | Create an instance of the CvsFilmstripResultsQueue class
Public method | CvsFilmstripResultsQueue(CvsFilmstrip) | Create an instance of the CvsFilmstripResultsQueue class with a filmstrip parameter

Methods

 | Name | Description
Public method | Connect | Connect to the ResultsQueue.
Public method | Disconnect | Disconnect from the ResultsQueue
Public method | Dispose | Dispose
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalize (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessShortcutKeys | Process shortcut Keys.
Public method | RequestThumbnailImagesUpdate | Requests thumbnail images to be updated.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ClearQueue | Handles clearing the queue action.
Public property | DeleteSelectedItem | Handles deleting the selected result in the queue.
Public property | Enabled | Gets and sets a boolean indicating whether the subject should be enabled.
Public property | Filmstrip | Gets and sets the CvsFilmstrip control.
Public property | FreezeQueue | Handles freezing queue action.
Public property | InSight | Gets or sets a CvsInSight object to which is connected. Use of this property while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed this property will return null and cannot be set.
Public property | IsFrozen | Gets whether the ResultsQueue is frozen.
Public property | Options | Gets and sets ResultsQueue options for CvsFilmstrip.
Public property | QueueSize | Gets the number of elements in the Results Queue.
Public property | ResultsStatus | Gets results status.
Public property | SaveQueue | Handles saving the queue action.
Public property | SelectedIndex | Gets and sets the index of the result to display.
Public property | SelectFirst | Handles selecting the first result in the queue action.
Public property | SelectLast | Handles selecting the last result in the queue action.
Public property | SelectNext | Handles selecting the next result in the queue action.
Public property | SelectNextPage | Handles selecting the next results page in the queue action..
Public property | SelectPrevious | Handles selecting the previous result in the queue action.
Public property | SelectPrevPage | Handles selecting the previous results page in the queue action.
Public property | Settings | Gets a CvsFilmstripResultsQueueSettings object determines the ResultsQueue settings.
Public property | ShowFail | Toggles the ShowFail value.
Public property | ShowPass | Toggles the ShowPass value.
Public property | SupportsEdit | Gets whether saving and deleting results are supported.
Public property | ThumbnailImages | Gets thumbnail images.

See Also

CvsFilmstripResultsQueue Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue Constructor

[image] [image]

In-Sight SDK
CvsFilmstripResultsQueue Constructor
CvsFilmstripResultsQueue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsFilmstripResultsQueue()()()() | Create an instance of the CvsFilmstripResultsQueue class
Public method | CvsFilmstripResultsQueue(CvsFilmstrip) | Create an instance of the CvsFilmstripResultsQueue class with a filmstrip parameter

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue Constructor

[image]

In-Sight SDK
CvsFilmstripResultsQueue Constructor
CvsFilmstripResultsQueue Class See Also Send Feedback
Create an instance of the CvsFilmstripResultsQueue class

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstripResultsQueue()
Visual Basic
Public Sub New

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
CvsFilmstripResultsQueue Overload
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue Constructor (CvsFilmstrip)

[image]

In-Sight SDK
CvsFilmstripResultsQueue Constructor (CvsFilmstrip)
CvsFilmstripResultsQueue Class See Also Send Feedback
Create an instance of the CvsFilmstripResultsQueue class with a filmstrip parameter

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstripResultsQueue(
    CvsFilmstrip _filmstrip
)
Visual Basic
Public Sub New (
    _filmstrip As CvsFilmstrip
)

Parameters

_filmstrip
Type: Cognex.InSight.Controls.Filmstrip..::..CvsFilmstrip
A CvsFilmstrip object.

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
CvsFilmstripResultsQueue Overload
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue Methods

[image] [image]

In-Sight SDK
CvsFilmstripResultsQueue Methods
CvsFilmstripResultsQueue Class See Also Send Feedback

The CvsFilmstripResultsQueue type exposes the following members.

Methods

 | Name | Description
Public method | Connect | Connect to the ResultsQueue.
Public method | Disconnect | Disconnect from the ResultsQueue
Public method | Dispose | Dispose
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalize (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessShortcutKeys | Process shortcut Keys.
Public method | RequestThumbnailImagesUpdate | Requests thumbnail images to be updated.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsFilmstripResultsQueue Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.Connect Method

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..Connect Method
CvsFilmstripResultsQueue Class See Also Send Feedback
Connect to the ResultsQueue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Connect()
Visual Basic
Public Sub Connect

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.Disconnect Method

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..Disconnect Method
CvsFilmstripResultsQueue Class See Also Send Feedback
Disconnect from the ResultsQueue

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Disconnect()
Visual Basic
Public Sub Disconnect

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.Dispose Method

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..Dispose Method
CvsFilmstripResultsQueue Class See Also Send Feedback
Dispose

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.Finalize Method

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..Finalize Method
CvsFilmstripResultsQueue Class See Also Send Feedback
Finalize

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize

Implements

Object..::..Finalize()()()()

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.ProcessShortcutKeys Method

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..ProcessShortcutKeys Method
CvsFilmstripResultsQueue Class See Also Send Feedback
Process shortcut Keys.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void ProcessShortcutKeys(
    KeyEventArgs e
)
Visual Basic
Public Sub ProcessShortcutKeys (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
A KeyEventArgs object.

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.RequestThumbnailImagesUpdate Method

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..RequestThumbnailImagesUpdate Method
CvsFilmstripResultsQueue Class See Also Send Feedback
Requests thumbnail images to be updated.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public void RequestThumbnailImagesUpdate(
    int index,
    int count,
    int imageIndex
)
Visual Basic
Public Sub RequestThumbnailImagesUpdate (
    index As Integer,
    count As Integer,
    imageIndex As Integer
)

Parameters

index
Type: System..::..Int32
Index of the first image.
count
Type: System..::..Int32
Number of images
imageIndex
Type: System..::..Int32
The image index for which to get thumbnails

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue Properties

[image] [image]

In-Sight SDK
CvsFilmstripResultsQueue Properties
CvsFilmstripResultsQueue Class See Also Send Feedback

The CvsFilmstripResultsQueue type exposes the following members.

Properties

 | Name | Description
Public property | ClearQueue | Handles clearing the queue action.
Public property | DeleteSelectedItem | Handles deleting the selected result in the queue.
Public property | Enabled | Gets and sets a boolean indicating whether the subject should be enabled.
Public property | Filmstrip | Gets and sets the CvsFilmstrip control.
Public property | FreezeQueue | Handles freezing queue action.
Public property | InSight | Gets or sets a CvsInSight object to which is connected. Use of this property while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed this property will return null and cannot be set.
Public property | IsFrozen | Gets whether the ResultsQueue is frozen.
Public property | Options | Gets and sets ResultsQueue options for CvsFilmstrip.
Public property | QueueSize | Gets the number of elements in the Results Queue.
Public property | ResultsStatus | Gets results status.
Public property | SaveQueue | Handles saving the queue action.
Public property | SelectedIndex | Gets and sets the index of the result to display.
Public property | SelectFirst | Handles selecting the first result in the queue action.
Public property | SelectLast | Handles selecting the last result in the queue action.
Public property | SelectNext | Handles selecting the next result in the queue action.
Public property | SelectNextPage | Handles selecting the next results page in the queue action..
Public property | SelectPrevious | Handles selecting the previous result in the queue action.
Public property | SelectPrevPage | Handles selecting the previous results page in the queue action.
Public property | Settings | Gets a CvsFilmstripResultsQueueSettings object determines the ResultsQueue settings.
Public property | ShowFail | Toggles the ShowFail value.
Public property | ShowPass | Toggles the ShowPass value.
Public property | SupportsEdit | Gets whether saving and deleting results are supported.
Public property | ThumbnailImages | Gets thumbnail images.

See Also

CvsFilmstripResultsQueue Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.ClearQueue Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..ClearQueue Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Handles clearing the queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction ClearQueue { get; }
Visual Basic
Public ReadOnly Property ClearQueue As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.DeleteSelectedItem Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..DeleteSelectedItem Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Handles deleting the selected result in the queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction DeleteSelectedItem { get; }
Visual Basic
Public ReadOnly Property DeleteSelectedItem As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.Enabled Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..Enabled Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Gets and sets a boolean indicating whether the subject should be enabled.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.Filmstrip Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..Filmstrip Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Gets and sets the CvsFilmstrip control.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstrip Filmstrip { get; set; }
Visual Basic
Public Property Filmstrip As CvsFilmstrip
    Get
    Set

Property Value

Type: CvsFilmstrip

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.FreezeQueue Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..FreezeQueue Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Handles freezing queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle FreezeQueue { get; }
Visual Basic
Public ReadOnly Property FreezeQueue As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.InSight Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..InSight Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Gets or sets a CvsInSight object to which is connected. Use of this property while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed this property will return null and cannot be set.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSight InSight { get; set; }
Visual Basic
Public Property InSight As CvsInSight
    Get
    Set

Property Value

Type: CvsInSight

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.IsFrozen Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..IsFrozen Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Gets whether the ResultsQueue is frozen.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool IsFrozen { get; }
Visual Basic
Public ReadOnly Property IsFrozen As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.Options Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..Options Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Gets and sets ResultsQueue options for CvsFilmstrip.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstripResultsQueueOptions Options { get; set; }
Visual Basic
Public Property Options As CvsFilmstripResultsQueueOptions
    Get
    Set

Property Value

Type: CvsFilmstripResultsQueueOptions

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.QueueSize Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..QueueSize Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Gets the number of elements in the Results Queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int QueueSize { get; }
Visual Basic
Public ReadOnly Property QueueSize As Integer
    Get

Property Value

Type: Int32

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.ResultsStatus Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..ResultsStatus Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Gets results status.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public ICvsFilmstripResultStatus[] ResultsStatus { get; }
Visual Basic
Public ReadOnly Property ResultsStatus As ICvsFilmstripResultStatus()
    Get

Return Value

Type: array< ICvsFilmstripResultStatus >[]()[][]

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.SaveQueue Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..SaveQueue Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Handles saving the queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SaveQueue { get; }
Visual Basic
Public ReadOnly Property SaveQueue As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.SelectedIndex Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..SelectedIndex Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Gets and sets the index of the result to display.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic
Public Property SelectedIndex As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.SelectFirst Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..SelectFirst Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Handles selecting the first result in the queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectFirst { get; }
Visual Basic
Public ReadOnly Property SelectFirst As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.SelectLast Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..SelectLast Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Handles selecting the last result in the queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectLast { get; }
Visual Basic
Public ReadOnly Property SelectLast As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.SelectNext Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..SelectNext Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Handles selecting the next result in the queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectNext { get; }
Visual Basic
Public ReadOnly Property SelectNext As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.SelectNextPage Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..SelectNextPage Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Handles selecting the next results page in the queue action..

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectNextPage { get; }
Visual Basic
Public ReadOnly Property SelectNextPage As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.SelectPrevious Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..SelectPrevious Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Handles selecting the previous result in the queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectPrevious { get; }
Visual Basic
Public ReadOnly Property SelectPrevious As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.SelectPrevPage Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..SelectPrevPage Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Handles selecting the previous results page in the queue action.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsAction SelectPrevPage { get; }
Visual Basic
Public ReadOnly Property SelectPrevPage As CvsAction
    Get

Property Value

Type: CvsAction

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.Settings Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..Settings Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Gets a CvsFilmstripResultsQueueSettings object determines the ResultsQueue settings.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstripResultsQueueSettings Settings { get; }
Visual Basic
Public ReadOnly Property Settings As CvsFilmstripResultsQueueSettings
    Get

Property Value

Type: CvsFilmstripResultsQueueSettings

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.ShowFail Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..ShowFail Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Toggles the ShowFail value.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle ShowFail { get; }
Visual Basic
Public ReadOnly Property ShowFail As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.ShowPass Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..ShowPass Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Toggles the ShowPass value.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsActionToggle ShowPass { get; }
Visual Basic
Public ReadOnly Property ShowPass As CvsActionToggle
    Get

Property Value

Type: CvsActionToggle

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.SupportsEdit Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..SupportsEdit Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Gets whether saving and deleting results are supported.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool SupportsEdit { get; }
Visual Basic
Public ReadOnly Property SupportsEdit As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueue.ThumbnailImages Property

[image]

In-Sight SDK
CvsFilmstripResultsQueue..::..ThumbnailImages Property
CvsFilmstripResultsQueue Class See Also Send Feedback
Gets thumbnail images.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public ICvsFilmstripImage[] ThumbnailImages { get; }
Visual Basic
Public ReadOnly Property ThumbnailImages As ICvsFilmstripImage()
    Get

Return Value

Type: array< ICvsFilmstripImage >[]()[][]

See Also

CvsFilmstripResultsQueue Class
CvsFilmstripResultsQueue..::..CvsFilmstripResultsQueue Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueCellCondition Enumeration

[image]

In-Sight SDK
CvsFilmstripResultsQueueCellCondition Enumeration
See Also Send Feedback
Specifies the bit fields for what inspections get added to the queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
[FlagsAttribute]
public enum CvsFilmstripResultsQueueCellCondition
Visual Basic
<FlagsAttribute>
Public Enumeration CvsFilmstripResultsQueueCellCondition

Members

Member name | Value | Description
Zero | 1 | Cell value is equal to 0.
ERR | 2 | Cell is in the #ERR state.
Negative | 4 | Cell value is less than 0.
Positive | 8 | Cell value is greater than 0.

See Also

Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueCondition Enumeration

[image]

In-Sight SDK
CvsFilmstripResultsQueueCondition Enumeration
See Also Send Feedback
Designates the values for CvsResultsQueueCellCondition fields.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsFilmstripResultsQueueCondition
Visual Basic
Public Enumeration CvsFilmstripResultsQueueCondition

Members

Member name | Value | Description
Pass | 0 | Cells in the designated state will be designated as the Pass condition.
Fail | 1 | Cells in the designated state will be designated as the Fail condition.

See Also

Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueMode Enumeration

[image]

In-Sight SDK
CvsFilmstripResultsQueueMode Enumeration
See Also Send Feedback
Specifies what inspections get added to the queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsFilmstripResultsQueueMode
Visual Basic
Public Enumeration CvsFilmstripResultsQueueMode

Members

Member name | Value | Description
None | 0 | The queue is turned off.
OnlyFail | 1 | Based on the evaluation of the Watch Cells value, all failed inspections will be added to the queue
All | 2 | All inspections are added to the queue.
OnlyPass | 3 | Based on the evaluation of the Watch Cells value, all passed inspections will be added to the queue
Separate | 4 | There are two separate queues. One for pass and the other for fail.

See Also

Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions Class

[image]

In-Sight SDK
CvsFilmstripResultsQueueOptions Class
Members See Also Send Feedback
A class to hold all of the ResultsQueue options for CvsFilmstrip

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsFilmstripResultsQueueOptions
Visual Basic
Public Class CvsFilmstripResultsQueueOptions

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Controls.Filmstrip..::..CvsFilmstripResultsQueueOptions

See Also

CvsFilmstripResultsQueueOptions..::..CvsFilmstripResultsQueueOptions Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions Members

[image] [image]

In-Sight SDK
CvsFilmstripResultsQueueOptions Members
CvsFilmstripResultsQueueOptions Class Constructors Methods Fields Properties Events See Also Send Feedback

The CvsFilmstripResultsQueueOptions type exposes the following members.

Constructors

 | Name | Description
Public method | CvsFilmstripResultsQueueOptions | Initializes a new instance of the CvsFilmstripResultsQueueOptions class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
MaxPauseDelay | Maximum Pause Delay
MinPauseDelay | Minimum Pause Delay

Properties

 | Name | Description
Public property | DisplayAction | Gets or Sets what the Display should do when a new result is added to the queue.
Public property | LedStyle | Indicates the style of LED to display
Public property | PauseDelay | Gets or sets the the duration (in seconds) that the display should hold the results before returning to the normal update mode.
Public property | SavePath | Save result image path
Public property | ShowFilmstrip | Indicates if the filmstrip is visible
Public property | UseSystemColors | Indicates if the filmstrip color should match the system's color theme

Events

 | Name | Description
Public event | Changed | Raised when any field in the options has been changed.

See Also

CvsFilmstripResultsQueueOptions Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions Constructor

[image]

In-Sight SDK
CvsFilmstripResultsQueueOptions Constructor
CvsFilmstripResultsQueueOptions Class See Also Send Feedback
Initializes a new instance of the CvsFilmstripResultsQueueOptions class

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstripResultsQueueOptions()
Visual Basic
Public Sub New

See Also

CvsFilmstripResultsQueueOptions Class
CvsFilmstripResultsQueueOptions..::..CvsFilmstripResultsQueueOptions Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions Fields

[image] [image]

In-Sight SDK
CvsFilmstripResultsQueueOptions Fields
CvsFilmstripResultsQueueOptions Class See Also Send Feedback

The CvsFilmstripResultsQueueOptions type exposes the following members.

Fields

Name | Description
MaxPauseDelay | Maximum Pause Delay
MinPauseDelay | Minimum Pause Delay

See Also

CvsFilmstripResultsQueueOptions Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions.MaxPauseDelay Field

[image]

In-Sight SDK
CvsFilmstripResultsQueueOptions..::..MaxPauseDelay Field
CvsFilmstripResultsQueueOptions Class See Also Send Feedback
Maximum Pause Delay

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxPauseDelay
Visual Basic
Public Const MaxPauseDelay As Integer

Field Value

Type: Int32

See Also

CvsFilmstripResultsQueueOptions Class
CvsFilmstripResultsQueueOptions..::..CvsFilmstripResultsQueueOptions Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions.MinPauseDelay Field

[image]

In-Sight SDK
CvsFilmstripResultsQueueOptions..::..MinPauseDelay Field
CvsFilmstripResultsQueueOptions Class See Also Send Feedback
Minimum Pause Delay

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public const int MinPauseDelay
Visual Basic
Public Const MinPauseDelay As Integer

Field Value

Type: Int32

See Also

CvsFilmstripResultsQueueOptions Class
CvsFilmstripResultsQueueOptions..::..CvsFilmstripResultsQueueOptions Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions Methods

[image] [image]

In-Sight SDK
CvsFilmstripResultsQueueOptions Methods
CvsFilmstripResultsQueueOptions Class See Also Send Feedback

The CvsFilmstripResultsQueueOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsFilmstripResultsQueueOptions Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions Properties

[image] [image]

In-Sight SDK
CvsFilmstripResultsQueueOptions Properties
CvsFilmstripResultsQueueOptions Class See Also Send Feedback

The CvsFilmstripResultsQueueOptions type exposes the following members.

Properties

 | Name | Description
Public property | DisplayAction | Gets or Sets what the Display should do when a new result is added to the queue.
Public property | LedStyle | Indicates the style of LED to display
Public property | PauseDelay | Gets or sets the the duration (in seconds) that the display should hold the results before returning to the normal update mode.
Public property | SavePath | Save result image path
Public property | ShowFilmstrip | Indicates if the filmstrip is visible
Public property | UseSystemColors | Indicates if the filmstrip color should match the system's color theme

See Also

CvsFilmstripResultsQueueOptions Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions.DisplayAction Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueOptions..::..DisplayAction Property
CvsFilmstripResultsQueueOptions Class See Also Send Feedback
Gets or Sets what the Display should do when a new result is added to the queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsResultsQueueDisplayAction DisplayAction { get; set; }
Visual Basic
Public Property DisplayAction As CvsResultsQueueDisplayAction
    Get
    Set

Property Value

Type: CvsResultsQueueDisplayAction

See Also

CvsFilmstripResultsQueueOptions Class
CvsFilmstripResultsQueueOptions..::..CvsFilmstripResultsQueueOptions Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions.LedStyle Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueOptions..::..LedStyle Property
CvsFilmstripResultsQueueOptions Class See Also Send Feedback
Indicates the style of LED to display

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsStatusLevelStyle LedStyle { get; set; }
Visual Basic
Public Property LedStyle As CvsStatusLevelStyle
    Get
    Set

Property Value

Type: CvsStatusLevelStyle

See Also

CvsFilmstripResultsQueueOptions Class
CvsFilmstripResultsQueueOptions..::..CvsFilmstripResultsQueueOptions Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions.PauseDelay Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueOptions..::..PauseDelay Property
CvsFilmstripResultsQueueOptions Class See Also Send Feedback
Gets or sets the the duration (in seconds) that the display should hold the results before returning to the normal update mode.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int PauseDelay { get; set; }
Visual Basic
Public Property PauseDelay As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsFilmstripResultsQueueOptions Class
CvsFilmstripResultsQueueOptions..::..CvsFilmstripResultsQueueOptions Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions.SavePath Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueOptions..::..SavePath Property
CvsFilmstripResultsQueueOptions Class See Also Send Feedback
Save result image path

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string SavePath { get; set; }
Visual Basic
Public Property SavePath As String
    Get
    Set

Property Value

Type: String

See Also

CvsFilmstripResultsQueueOptions Class
CvsFilmstripResultsQueueOptions..::..CvsFilmstripResultsQueueOptions Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions.ShowFilmstrip Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueOptions..::..ShowFilmstrip Property
CvsFilmstripResultsQueueOptions Class See Also Send Feedback
Indicates if the filmstrip is visible

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowFilmstrip { get; set; }
Visual Basic
Public Property ShowFilmstrip As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsFilmstripResultsQueueOptions Class
CvsFilmstripResultsQueueOptions..::..CvsFilmstripResultsQueueOptions Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions.UseSystemColors Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueOptions..::..UseSystemColors Property
CvsFilmstripResultsQueueOptions Class See Also Send Feedback
Indicates if the filmstrip color should match the system's color theme

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool UseSystemColors { get; set; }
Visual Basic
Public Property UseSystemColors As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsFilmstripResultsQueueOptions Class
CvsFilmstripResultsQueueOptions..::..CvsFilmstripResultsQueueOptions Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions Events

[image] [image]

In-Sight SDK
CvsFilmstripResultsQueueOptions Events
CvsFilmstripResultsQueueOptions Class See Also Send Feedback

The CvsFilmstripResultsQueueOptions type exposes the following members.

Events

 | Name | Description
Public event | Changed | Raised when any field in the options has been changed.

See Also

CvsFilmstripResultsQueueOptions Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueOptions.Changed Event

[image]

In-Sight SDK
CvsFilmstripResultsQueueOptions..::..Changed Event
CvsFilmstripResultsQueueOptions Class See Also Send Feedback
Raised when any field in the options has been changed.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler Changed
Visual Basic
Public Event Changed As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsFilmstripResultsQueueOptions Class
CvsFilmstripResultsQueueOptions..::..CvsFilmstripResultsQueueOptions Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings Class

[image]

In-Sight SDK
CvsFilmstripResultsQueueSettings Class
Members See Also Send Feedback
Defines the sensor settings for the results queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public class CvsFilmstripResultsQueueSettings
Visual Basic
Public Class CvsFilmstripResultsQueueSettings

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Controls.Filmstrip..::..CvsFilmstripResultsQueueSettings

See Also

CvsFilmstripResultsQueueSettings..::..CvsFilmstripResultsQueueSettings Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings Members

[image] [image]

In-Sight SDK
CvsFilmstripResultsQueueSettings Members
CvsFilmstripResultsQueueSettings Class Constructors Methods Properties Events See Also Send Feedback

The CvsFilmstripResultsQueueSettings type exposes the following members.

Constructors

 | Name | Description
Public method | CvsFilmstripResultsQueueSettings | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ClearOnline | Gets or sets a flag that indicates whether or not the results queue should be cleared each time the sensor goes online.
Public property | Condition | Gets or sets the condition that determines which results are designated as Pass or Fails for the watch cell's value.
Public property | FailQueueSize | Gets or sets a value that designates the maximum number of fail images that may be held in the results queue.
Public property | FreezeOnRejectAction | Gets or sets a flag that designates whether or not the queue should freeze on reject.
Public property | Mode | Gets or Sets the operational mode of the queue. This specifies what inspections get added to the queue.
Public property | PassQueueSize | Gets or sets a value that designates the maximum number of pass images that may be held in the results queue.
Public property | QueueSize | Gets or sets a value that designates the maximum number of images that may be held in the results queue.
Public property | Type | Gets or sets a CvsFilmstripResultsQueueType object indicating the ResultsQueue Type.
Public property | WatchCell | Gets or sets the string representation of the watch cell.

Events

 | Name | Description
Public event | Changed | Raised when any property has been changed.

See Also

CvsFilmstripResultsQueueSettings Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings Constructor

[image]

In-Sight SDK
CvsFilmstripResultsQueueSettings Constructor
CvsFilmstripResultsQueueSettings Class See Also Send Feedback
Constructor

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstripResultsQueueSettings()
Visual Basic
Public Sub New

See Also

CvsFilmstripResultsQueueSettings Class
CvsFilmstripResultsQueueSettings..::..CvsFilmstripResultsQueueSettings Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings Methods

[image] [image]

In-Sight SDK
CvsFilmstripResultsQueueSettings Methods
CvsFilmstripResultsQueueSettings Class See Also Send Feedback

The CvsFilmstripResultsQueueSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsFilmstripResultsQueueSettings Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings Properties

[image] [image]

In-Sight SDK
CvsFilmstripResultsQueueSettings Properties
CvsFilmstripResultsQueueSettings Class See Also Send Feedback

The CvsFilmstripResultsQueueSettings type exposes the following members.

Properties

 | Name | Description
Public property | ClearOnline | Gets or sets a flag that indicates whether or not the results queue should be cleared each time the sensor goes online.
Public property | Condition | Gets or sets the condition that determines which results are designated as Pass or Fails for the watch cell's value.
Public property | FailQueueSize | Gets or sets a value that designates the maximum number of fail images that may be held in the results queue.
Public property | FreezeOnRejectAction | Gets or sets a flag that designates whether or not the queue should freeze on reject.
Public property | Mode | Gets or Sets the operational mode of the queue. This specifies what inspections get added to the queue.
Public property | PassQueueSize | Gets or sets a value that designates the maximum number of pass images that may be held in the results queue.
Public property | QueueSize | Gets or sets a value that designates the maximum number of images that may be held in the results queue.
Public property | Type | Gets or sets a CvsFilmstripResultsQueueType object indicating the ResultsQueue Type.
Public property | WatchCell | Gets or sets the string representation of the watch cell.

See Also

CvsFilmstripResultsQueueSettings Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings.ClearOnline Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueSettings..::..ClearOnline Property
CvsFilmstripResultsQueueSettings Class See Also Send Feedback
Gets or sets a flag that indicates whether or not the results queue should be cleared each time the sensor goes online.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool ClearOnline { get; set; }
Visual Basic
Public Property ClearOnline As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsFilmstripResultsQueueSettings Class
CvsFilmstripResultsQueueSettings..::..CvsFilmstripResultsQueueSettings Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings.Condition Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueSettings..::..Condition Property
CvsFilmstripResultsQueueSettings Class See Also Send Feedback
Gets or sets the condition that determines which results are designated as Pass or Fails for the watch cell's value.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int Condition { get; set; }
Visual Basic
Public Property Condition As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

Depending upon the Mode selection, this value (along with the value of the watch cell) will determine whether or not a result should be placed in the queue.

The value of this property is bit fields that are defined in CvsFilmstripResultsQueueCellCondition. The value of each field is defined in CvsFilmstripResultsQueueCondition.

See Also

CvsFilmstripResultsQueueSettings Class
CvsFilmstripResultsQueueSettings..::..CvsFilmstripResultsQueueSettings Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings.FailQueueSize Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueSettings..::..FailQueueSize Property
CvsFilmstripResultsQueueSettings Class See Also Send Feedback
Gets or sets a value that designates the maximum number of fail images that may be held in the results queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int FailQueueSize { get; set; }
Visual Basic
Public Property FailQueueSize As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsFilmstripResultsQueueSettings Class
CvsFilmstripResultsQueueSettings..::..CvsFilmstripResultsQueueSettings Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings.FreezeOnRejectAction Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueSettings..::..FreezeOnRejectAction Property
CvsFilmstripResultsQueueSettings Class See Also Send Feedback
Gets or sets a flag that designates whether or not the queue should freeze on reject.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public bool FreezeOnRejectAction { get; set; }
Visual Basic
Public Property FreezeOnRejectAction As Boolean
    Get
    Set

Property Value

Type: Boolean
The the default value is false.

See Also

CvsFilmstripResultsQueueSettings Class
CvsFilmstripResultsQueueSettings..::..CvsFilmstripResultsQueueSettings Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings.Mode Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueSettings..::..Mode Property
CvsFilmstripResultsQueueSettings Class See Also Send Feedback
Gets or Sets the operational mode of the queue. This specifies what inspections get added to the queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstripResultsQueueMode Mode { get; set; }
Visual Basic
Public Property Mode As CvsFilmstripResultsQueueMode
    Get
    Set

Property Value

Type: CvsFilmstripResultsQueueMode

Remarks

If this property is set to OnlyPass, based on the evaluation of the In-Sight job, pass inspections will be added to the queue.

If this property is set to OnlyFail, based on the evaluation of the In-Sight job, failed inspections will be added to the queue.

If this property is set to All, All inspections are added to the queue.

If this property is set to None, the The queue will be turned off.

See Also

CvsFilmstripResultsQueueSettings Class
CvsFilmstripResultsQueueSettings..::..CvsFilmstripResultsQueueSettings Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings.PassQueueSize Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueSettings..::..PassQueueSize Property
CvsFilmstripResultsQueueSettings Class See Also Send Feedback
Gets or sets a value that designates the maximum number of pass images that may be held in the results queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int PassQueueSize { get; set; }
Visual Basic
Public Property PassQueueSize As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsFilmstripResultsQueueSettings Class
CvsFilmstripResultsQueueSettings..::..CvsFilmstripResultsQueueSettings Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings.QueueSize Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueSettings..::..QueueSize Property
CvsFilmstripResultsQueueSettings Class See Also Send Feedback
Gets or sets a value that designates the maximum number of images that may be held in the results queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public int QueueSize { get; set; }
Visual Basic
Public Property QueueSize As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsFilmstripResultsQueueSettings Class
CvsFilmstripResultsQueueSettings..::..CvsFilmstripResultsQueueSettings Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings.Type Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueSettings..::..Type Property
CvsFilmstripResultsQueueSettings Class See Also Send Feedback
Gets or sets a CvsFilmstripResultsQueueType object indicating the ResultsQueue Type.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public CvsFilmstripResultsQueueType Type { get; set; }
Visual Basic
Public Property Type As CvsFilmstripResultsQueueType
    Get
    Set

Property Value

Type: CvsFilmstripResultsQueueType

See Also

CvsFilmstripResultsQueueSettings Class
CvsFilmstripResultsQueueSettings..::..CvsFilmstripResultsQueueSettings Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings.WatchCell Property

[image]

In-Sight SDK
CvsFilmstripResultsQueueSettings..::..WatchCell Property
CvsFilmstripResultsQueueSettings Class See Also Send Feedback
Gets or sets the string representation of the watch cell.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public string WatchCell { get; set; }
Visual Basic
Public Property WatchCell As String
    Get
    Set

Property Value

Type: String

See Also

CvsFilmstripResultsQueueSettings Class
CvsFilmstripResultsQueueSettings..::..CvsFilmstripResultsQueueSettings Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings Events

[image] [image]

In-Sight SDK
CvsFilmstripResultsQueueSettings Events
CvsFilmstripResultsQueueSettings Class See Also Send Feedback

The CvsFilmstripResultsQueueSettings type exposes the following members.

Events

 | Name | Description
Public event | Changed | Raised when any property has been changed.

See Also

CvsFilmstripResultsQueueSettings Class
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueSettings.Changed Event

[image]

In-Sight SDK
CvsFilmstripResultsQueueSettings..::..Changed Event
CvsFilmstripResultsQueueSettings Class See Also Send Feedback
Raised when any property has been changed.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler Changed
Visual Basic
Public Event Changed As EventHandler

Value

Type: System..::..EventHandler

See Also

CvsFilmstripResultsQueueSettings Class
CvsFilmstripResultsQueueSettings..::..CvsFilmstripResultsQueueSettings Members
Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripResultsQueueType Enumeration

[image]

In-Sight SDK
CvsFilmstripResultsQueueType Enumeration
See Also Send Feedback
Specifies the type of result queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsFilmstripResultsQueueType
Visual Basic
Public Enumeration CvsFilmstripResultsQueueType

Members

Member name | Value | Description
Last | 0 | The queue will always have the Last X inspections.
First | 1 | Store only the First X inspections encountered.

See Also

Cognex.InSight.Controls.Filmstrip Namespace


CvsFilmstripScale Enumeration

[image]

In-Sight SDK
CvsFilmstripScale Enumeration
See Also Send Feedback
Indicates scales the filmstrip's size based on its initial height.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsFilmstripScale
Visual Basic
Public Enumeration CvsFilmstripScale

Members

Member name | Value | Description
Quarter | 25 | Scale 0.25
Half | 50 | Scale 0.5
One | 100 | Scale 1.0
Two | 200 | Scale 2.0
Four | 400 | Scale 4.0

See Also

Cognex.InSight.Controls.Filmstrip Namespace


CvsResultsQueueDisplayAction Enumeration

[image]

In-Sight SDK
CvsResultsQueueDisplayAction Enumeration
See Also Send Feedback
Specifies what the Display should do when a new result is added to the queue.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsResultsQueueDisplayAction
Visual Basic
Public Enumeration CvsResultsQueueDisplayAction

Members

Member name | Value | Description
Freeze | 0 | The Display will show the new result and freeze.
Pause | 1 | The Display will show the new result and pause for the duration specified in Pause Delay.
Nothing | 2 | The Display will do nothing differenct.

See Also

Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripImage Interface

[image]

In-Sight SDK
ICvsFilmstripImage Interface
Members See Also Send Feedback
Defines an image interface corresponding to a thumbnail of the CvsFilmstrip.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public interface ICvsFilmstripImage
Visual Basic
Public Interface ICvsFilmstripImage

See Also

ICvsFilmstripImage..::..ICvsFilmstripImage Members
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripImage Members

[image] [image]

In-Sight SDK
ICvsFilmstripImage Members
ICvsFilmstripImage Interface Methods Properties See Also Send Feedback

The ICvsFilmstripImage type exposes the following members.

Methods

 | Name | Description
Public method | ToBitmap | Converts this image into a Bitmap object.

Properties

 | Name | Description
Public property | Bounds | Gets the bounds of the image in its own pixel coordinates.
Public property | Height | Gets the height in pixels of this image.
Public property | PixelFormat | Gets the pixel format for this image.
Public property | Size | Gets the width and height, in pixels, of this image.
Public property | Width | Gets the width in pixels of this image.

See Also

ICvsFilmstripImage Interface
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripImage Methods

[image] [image]

In-Sight SDK
ICvsFilmstripImage Methods
ICvsFilmstripImage Interface See Also Send Feedback

The ICvsFilmstripImage type exposes the following members.

Methods

 | Name | Description
Public method | ToBitmap | Converts this image into a Bitmap object.

See Also

ICvsFilmstripImage Interface
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripImage.ToBitmap Method

[image]

In-Sight SDK
ICvsFilmstripImage..::..ToBitmap Method
ICvsFilmstripImage Interface See Also Send Feedback
Converts this image into a Bitmap object.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
Bitmap ToBitmap()
Visual Basic
Function ToBitmap As Bitmap

Return Value

Type: Bitmap
The converted Bitmap object.

Exceptions

Exception | Condition
System..::..NotSupportedException | The image is not a supported type.

See Also

ICvsFilmstripImage Interface
ICvsFilmstripImage..::..ICvsFilmstripImage Members
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripImage Properties

[image] [image]

In-Sight SDK
ICvsFilmstripImage Properties
ICvsFilmstripImage Interface See Also Send Feedback

The ICvsFilmstripImage type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | Gets the bounds of the image in its own pixel coordinates.
Public property | Height | Gets the height in pixels of this image.
Public property | PixelFormat | Gets the pixel format for this image.
Public property | Size | Gets the width and height, in pixels, of this image.
Public property | Width | Gets the width in pixels of this image.

See Also

ICvsFilmstripImage Interface
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripImage.Bounds Property

[image]

In-Sight SDK
ICvsFilmstripImage..::..Bounds Property
ICvsFilmstripImage Interface See Also Send Feedback
Gets the bounds of the image in its own pixel coordinates.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
RectangleF Bounds { get; }
Visual Basic
ReadOnly Property Bounds As RectangleF
    Get

Property Value

Type: RectangleF

See Also

ICvsFilmstripImage Interface
ICvsFilmstripImage..::..ICvsFilmstripImage Members
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripImage.Height Property

[image]

In-Sight SDK
ICvsFilmstripImage..::..Height Property
ICvsFilmstripImage Interface See Also Send Feedback
Gets the height in pixels of this image.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
int Height { get; }
Visual Basic
ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32

See Also

ICvsFilmstripImage Interface
ICvsFilmstripImage..::..ICvsFilmstripImage Members
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripImage.PixelFormat Property

[image]

In-Sight SDK
ICvsFilmstripImage..::..PixelFormat Property
ICvsFilmstripImage Interface See Also Send Feedback
Gets the pixel format for this image.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
PixelFormat PixelFormat { get; }
Visual Basic
ReadOnly Property PixelFormat As PixelFormat
    Get

Property Value

Type: PixelFormat

See Also

ICvsFilmstripImage Interface
ICvsFilmstripImage..::..ICvsFilmstripImage Members
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripImage.Size Property

[image]

In-Sight SDK
ICvsFilmstripImage..::..Size Property
ICvsFilmstripImage Interface See Also Send Feedback
Gets the width and height, in pixels, of this image.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
Size Size { get; }
Visual Basic
ReadOnly Property Size As Size
    Get

Property Value

Type: Size

See Also

ICvsFilmstripImage Interface
ICvsFilmstripImage..::..ICvsFilmstripImage Members
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripImage.Width Property

[image]

In-Sight SDK
ICvsFilmstripImage..::..Width Property
ICvsFilmstripImage Interface See Also Send Feedback
Gets the width in pixels of this image.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
int Width { get; }
Visual Basic
ReadOnly Property Width As Integer
    Get

Property Value

Type: Int32

See Also

ICvsFilmstripImage Interface
ICvsFilmstripImage..::..ICvsFilmstripImage Members
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripResultStatus Interface

[image]

In-Sight SDK
ICvsFilmstripResultStatus Interface
Members See Also Send Feedback
Defines a result status interface corresponding to a thumbnail of the CvsFilmstrip.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
public interface ICvsFilmstripResultStatus
Visual Basic
Public Interface ICvsFilmstripResultStatus

See Also

ICvsFilmstripResultStatus..::..ICvsFilmstripResultStatus Members
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripResultStatus Members

[image] [image]

In-Sight SDK
ICvsFilmstripResultStatus Members
ICvsFilmstripResultStatus Interface Properties See Also Send Feedback

The ICvsFilmstripResultStatus type exposes the following members.

Properties

 | Name | Description
Public property | SequenceNumber | Gets a sequence number for this result.
Public property | StatusLevel | Gets a CvsStatusLevel object indicating the pass/fail/warn result status.
Public property | StatusMessage | Gets a status message indicating the reasons for any warning or failure conditions. Will return null (not an empty string) if there is no status message.
Public property | Timestamp | Gets the date and time that this result was generated.

See Also

ICvsFilmstripResultStatus Interface
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripResultStatus Properties

[image] [image]

In-Sight SDK
ICvsFilmstripResultStatus Properties
ICvsFilmstripResultStatus Interface See Also Send Feedback

The ICvsFilmstripResultStatus type exposes the following members.

Properties

 | Name | Description
Public property | SequenceNumber | Gets a sequence number for this result.
Public property | StatusLevel | Gets a CvsStatusLevel object indicating the pass/fail/warn result status.
Public property | StatusMessage | Gets a status message indicating the reasons for any warning or failure conditions. Will return null (not an empty string) if there is no status message.
Public property | Timestamp | Gets the date and time that this result was generated.

See Also

ICvsFilmstripResultStatus Interface
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripResultStatus.SequenceNumber Property

[image]

In-Sight SDK
ICvsFilmstripResultStatus..::..SequenceNumber Property
ICvsFilmstripResultStatus Interface See Also Send Feedback
Gets a sequence number for this result.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
long SequenceNumber { get; }
Visual Basic
ReadOnly Property SequenceNumber As Long
    Get

Property Value

Type: Int64

See Also

ICvsFilmstripResultStatus Interface
ICvsFilmstripResultStatus..::..ICvsFilmstripResultStatus Members
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripResultStatus.StatusLevel Property

[image]

In-Sight SDK
ICvsFilmstripResultStatus..::..StatusLevel Property
ICvsFilmstripResultStatus Interface See Also Send Feedback
Gets a CvsStatusLevel object indicating the pass/fail/warn result status.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
CvsStatusLevel StatusLevel { get; }
Visual Basic
ReadOnly Property StatusLevel As CvsStatusLevel
    Get

Property Value

Type: CvsStatusLevel

See Also

ICvsFilmstripResultStatus Interface
ICvsFilmstripResultStatus..::..ICvsFilmstripResultStatus Members
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripResultStatus.StatusMessage Property

[image]

In-Sight SDK
ICvsFilmstripResultStatus..::..StatusMessage Property
ICvsFilmstripResultStatus Interface See Also Send Feedback
Gets a status message indicating the reasons for any warning or failure conditions. Will return null (not an empty string) if there is no status message.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
string StatusMessage { get; }
Visual Basic
ReadOnly Property StatusMessage As String
    Get

Property Value

Type: String

See Also

ICvsFilmstripResultStatus Interface
ICvsFilmstripResultStatus..::..ICvsFilmstripResultStatus Members
Cognex.InSight.Controls.Filmstrip Namespace


ICvsFilmstripResultStatus.Timestamp Property

[image]

In-Sight SDK
ICvsFilmstripResultStatus..::..Timestamp Property
ICvsFilmstripResultStatus Interface See Also Send Feedback
Gets the date and time that this result was generated.

Namespace: Cognex.InSight.Controls.Filmstrip
Assembly: Cognex.InSight.Controls.Display (in Cognex.InSight.Controls.Display.dll) Version: 6.5.6.0

Syntax

C#
DateTime Timestamp { get; }
Visual Basic
ReadOnly Property Timestamp As DateTime
    Get

Property Value

Type: DateTime

See Also

ICvsFilmstripResultStatus Interface
ICvsFilmstripResultStatus..::..ICvsFilmstripResultStatus Members
Cognex.InSight.Controls.Filmstrip Namespace


Cognex.InSight.Extensions Namespace

[image]

In-Sight SDK
Cognex.InSight.Extensions Namespace
Send Feedback

Classes

 | Class | Description
Public class | BitmapExtensions | Extension methods for Image.
Public class | CnxResourceExtensions | Contains extension methods for ICnxResource.
Public class | CvsImageExtensions | Extension methods for CvsImage.
Public class | CvsInSightExtensions | Extension methods for CvsInSight.
Public class | CvsNativeModeClientExtensions | Provides extensions for CvsNativeModeClient.
Public class | DoubleExtensions | Provides extension methods for double.
Public class | ExceptionExtensions | Extension methods for Exception objects.
Public class | PropertyInfoExtensions | Extension methods for System.Reflection.PropertyInfo.
Public class | StringExtensions | Provides extension methods for String.


BitmapExtensions Class

[image]

In-Sight SDK
BitmapExtensions Class
Members See Also Send Feedback
Extension methods for Image.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static class BitmapExtensions
Visual Basic
<ExtensionAttribute>
Public NotInheritable Class BitmapExtensions

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Extensions..::..BitmapExtensions

See Also

BitmapExtensions..::..BitmapExtensions Members
Cognex.InSight.Extensions Namespace


BitmapExtensions Members

[image] [image]

In-Sight SDK
BitmapExtensions Members
BitmapExtensions Class Methods See Also Send Feedback

Methods

Name | Description
SaveAsBitmap(Bitmap, CvsPixelFormat) | Returns the image in a bitmap file format, using the specified pixel format.
SaveAsBitmap(Bitmap, Stream, CvsPixelFormat) | Writes the image to the stream in a bitmap file format, using the specified pixel format.

See Also

BitmapExtensions Class
Cognex.InSight.Extensions Namespace


BitmapExtensions Methods

[image] [image]

In-Sight SDK
BitmapExtensions Methods
BitmapExtensions Class See Also Send Feedback

Methods

Name | Description
SaveAsBitmap(Bitmap, CvsPixelFormat) | Returns the image in a bitmap file format, using the specified pixel format.
SaveAsBitmap(Bitmap, Stream, CvsPixelFormat) | Writes the image to the stream in a bitmap file format, using the specified pixel format.

See Also

BitmapExtensions Class
Cognex.InSight.Extensions Namespace


BitmapExtensions.SaveAsBitmap Method

[image] [image]

In-Sight SDK
BitmapExtensions..::..SaveAsBitmap Method
BitmapExtensions Class See Also Send Feedback

Overload List

Name | Description
SaveAsBitmap(Bitmap, CvsPixelFormat) | Returns the image in a bitmap file format, using the specified pixel format.
SaveAsBitmap(Bitmap, Stream, CvsPixelFormat) | Writes the image to the stream in a bitmap file format, using the specified pixel format.

See Also

BitmapExtensions Class
BitmapExtensions..::..BitmapExtensions Members
Cognex.InSight.Extensions Namespace


BitmapExtensions.SaveAsBitmap Method (Bitmap, CvsPixelFormat)

[image]

In-Sight SDK
BitmapExtensions..::..SaveAsBitmap Method (Bitmap, CvsPixelFormat)
BitmapExtensions Class See Also Send Feedback
Returns the image in a bitmap file format, using the specified pixel format.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static byte[] SaveAsBitmap(
    this Bitmap image,
    CvsPixelFormat format
)
Visual Basic
<ExtensionAttribute>
Public Shared Function SaveAsBitmap (
    image As Bitmap,
    format As CvsPixelFormat
) As Byte()

Parameters

image
Type: System.Drawing..::..Bitmap

[Missing <param name="image"/> documentation for "M:Cognex.InSight.Extensions.BitmapExtensions.SaveAsBitmap(System.Drawing.Bitmap,Cognex.InSight.CvsPixelFormat)"]

format
Type: Cognex.InSight..::..CvsPixelFormat

[Missing <param name="format"/> documentation for "M:Cognex.InSight.Extensions.BitmapExtensions.SaveAsBitmap(System.Drawing.Bitmap,Cognex.InSight.CvsPixelFormat)"]

Return Value

Type: array< Byte >[]()[][]

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.BitmapExtensions.SaveAsBitmap(System.Drawing.Bitmap,Cognex.InSight.CvsPixelFormat)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Bitmap. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

BitmapExtensions Class
BitmapExtensions..::..BitmapExtensions Members
SaveAsBitmap Overload
Cognex.InSight.Extensions Namespace


BitmapExtensions.SaveAsBitmap Method (Bitmap, Stream, CvsPixelFormat)

[image]

In-Sight SDK
BitmapExtensions..::..SaveAsBitmap Method (Bitmap, Stream, CvsPixelFormat)
BitmapExtensions Class See Also Send Feedback
Writes the image to the stream in a bitmap file format, using the specified pixel format.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static void SaveAsBitmap(
    this Bitmap image,
    Stream stream,
    CvsPixelFormat format
)
Visual Basic
<ExtensionAttribute>
Public Shared Sub SaveAsBitmap (
    image As Bitmap,
    stream As Stream,
    format As CvsPixelFormat
)

Parameters

image
Type: System.Drawing..::..Bitmap

[Missing <param name="image"/> documentation for "M:Cognex.InSight.Extensions.BitmapExtensions.SaveAsBitmap(System.Drawing.Bitmap,System.IO.Stream,Cognex.InSight.CvsPixelFormat)"]

stream
Type: System.IO..::..Stream

[Missing <param name="stream"/> documentation for "M:Cognex.InSight.Extensions.BitmapExtensions.SaveAsBitmap(System.Drawing.Bitmap,System.IO.Stream,Cognex.InSight.CvsPixelFormat)"]

format
Type: Cognex.InSight..::..CvsPixelFormat

[Missing <param name="format"/> documentation for "M:Cognex.InSight.Extensions.BitmapExtensions.SaveAsBitmap(System.Drawing.Bitmap,System.IO.Stream,Cognex.InSight.CvsPixelFormat)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Bitmap. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

BitmapExtensions Class
BitmapExtensions..::..BitmapExtensions Members
SaveAsBitmap Overload
Cognex.InSight.Extensions Namespace


CnxResourceExtensions Class

[image]

In-Sight SDK
CnxResourceExtensions Class
Members See Also Send Feedback
Contains extension methods for ICnxResource.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static class CnxResourceExtensions
Visual Basic
<ExtensionAttribute>
Public NotInheritable Class CnxResourceExtensions

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Extensions..::..CnxResourceExtensions

See Also

CnxResourceExtensions..::..CnxResourceExtensions Members
Cognex.InSight.Extensions Namespace


CnxResourceExtensions Members

[image] [image]

In-Sight SDK
CnxResourceExtensions Members
CnxResourceExtensions Class Methods See Also Send Feedback

The CnxResourceExtensions type exposes the following members.

Methods

Name | Description
Parse<(Of <<'(T>)>>) |
ReadResource<(Of <<'(T>)>>) |
TryReadResource<(Of <<'(T>)>>) | Attempt to read a value from the resource at the specified path. If any error occurs, the fallback delegate is invoked.
WriteResource<(Of <<'(T>)>>) |

See Also

CnxResourceExtensions Class
Cognex.InSight.Extensions Namespace


CnxResourceExtensions Methods

[image] [image]

In-Sight SDK
CnxResourceExtensions Methods
CnxResourceExtensions Class See Also Send Feedback

The CnxResourceExtensions type exposes the following members.

Methods

Name | Description
Parse<(Of <<'(T>)>>) |
ReadResource<(Of <<'(T>)>>) |
TryReadResource<(Of <<'(T>)>>) | Attempt to read a value from the resource at the specified path. If any error occurs, the fallback delegate is invoked.
WriteResource<(Of <<'(T>)>>) |

See Also

CnxResourceExtensions Class
Cognex.InSight.Extensions Namespace


CnxResourceExtensions.Parse(T) Method

[image]

In-Sight SDK
CnxResourceExtensions..::..Parse<(Of <(<'T>)>)> Method
CnxResourceExtensions Class See Also Send Feedback

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static T Parse<T>(
    string value
)
Visual Basic
Public Shared Function Parse(Of T) (
    value As String
) As T

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.Parse``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.Parse``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.Parse``1(System.String)"]

See Also

CnxResourceExtensions Class
CnxResourceExtensions..::..CnxResourceExtensions Members
Cognex.InSight.Extensions Namespace


CnxResourceExtensions.ReadResource(T) Method

[image]

In-Sight SDK
CnxResourceExtensions..::..ReadResource<(Of <(<'T>)>)> Method
CnxResourceExtensions Class See Also Send Feedback

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static T ReadResource<T>(
    this ICnxResource resource,
    string path
)
Visual Basic
<ExtensionAttribute>
Public Shared Function ReadResource(Of T) (
    resource As ICnxResource,
    path As String
) As T

Parameters

resource
Type: ICnxResource

[Missing <param name="resource"/> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.ReadResource``1(Cognex.Cnx.ComponentModel.ICnxResource,System.String)"]

path
Type: System..::..String

[Missing <param name="path"/> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.ReadResource``1(Cognex.Cnx.ComponentModel.ICnxResource,System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.ReadResource``1(Cognex.Cnx.ComponentModel.ICnxResource,System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.ReadResource``1(Cognex.Cnx.ComponentModel.ICnxResource,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICnxResource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

CnxResourceExtensions Class
CnxResourceExtensions..::..CnxResourceExtensions Members
Cognex.InSight.Extensions Namespace


CnxResourceExtensions.TryReadResource(T) Method

[image]

In-Sight SDK
CnxResourceExtensions..::..TryReadResource<(Of <(<'T>)>)> Method
CnxResourceExtensions Class See Also Send Feedback
Attempt to read a value from the resource at the specified path. If any error occurs, the fallback delegate is invoked.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static T TryReadResource<T>(
    this ICnxResource resource,
    string path,
    Func<T> fallback
)
Visual Basic
<ExtensionAttribute>
Public Shared Function TryReadResource(Of T) (
    resource As ICnxResource,
    path As String,
    fallback As Func(Of T)
) As T

Parameters

resource
Type: ICnxResource

[Missing <param name="resource"/> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.TryReadResource``1(Cognex.Cnx.ComponentModel.ICnxResource,System.String,System.Func{``0})"]

path
Type: System..::..String

[Missing <param name="path"/> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.TryReadResource``1(Cognex.Cnx.ComponentModel.ICnxResource,System.String,System.Func{``0})"]

fallback
Type: System..::..Func <(Of <(<'T>)>)>

[Missing <param name="fallback"/> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.TryReadResource``1(Cognex.Cnx.ComponentModel.ICnxResource,System.String,System.Func{``0})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.TryReadResource``1(Cognex.Cnx.ComponentModel.ICnxResource,System.String,System.Func{``0})"]

Return Value

Type: T

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.TryReadResource``1(Cognex.Cnx.ComponentModel.ICnxResource,System.String,System.Func{``0})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICnxResource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

CnxResourceExtensions Class
CnxResourceExtensions..::..CnxResourceExtensions Members
Cognex.InSight.Extensions Namespace


CnxResourceExtensions.WriteResource(T) Method

[image]

In-Sight SDK
CnxResourceExtensions..::..WriteResource<(Of <(<'T>)>)> Method
CnxResourceExtensions Class See Also Send Feedback

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static void WriteResource<T>(
    this ICnxResource resource,
    string path,
    T value
)
Visual Basic
<ExtensionAttribute>
Public Shared Sub WriteResource(Of T) (
    resource As ICnxResource,
    path As String,
    value As T
)

Parameters

resource
Type: ICnxResource

[Missing <param name="resource"/> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.WriteResource``1(Cognex.Cnx.ComponentModel.ICnxResource,System.String,``0)"]

path
Type: System..::..String

[Missing <param name="path"/> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.WriteResource``1(Cognex.Cnx.ComponentModel.ICnxResource,System.String,``0)"]

value
Type: T

[Missing <param name="value"/> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.WriteResource``1(Cognex.Cnx.ComponentModel.ICnxResource,System.String,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Cognex.InSight.Extensions.CnxResourceExtensions.WriteResource``1(Cognex.Cnx.ComponentModel.ICnxResource,System.String,``0)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICnxResource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

CnxResourceExtensions Class
CnxResourceExtensions..::..CnxResourceExtensions Members
Cognex.InSight.Extensions Namespace


CvsImageExtensions Class

[image]

In-Sight SDK
CvsImageExtensions Class
Members See Also Send Feedback
Extension methods for CvsImage.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static class CvsImageExtensions
Visual Basic
<ExtensionAttribute>
Public NotInheritable Class CvsImageExtensions

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Extensions..::..CvsImageExtensions

See Also

CvsImageExtensions..::..CvsImageExtensions Members
Cognex.InSight.Extensions Namespace


CvsImageExtensions Members

[image] [image]

In-Sight SDK
CvsImageExtensions Members
CvsImageExtensions Class Methods See Also Send Feedback

Methods

Name | Description
SaveAsBitmap(CvsImage, CvsPixelFormat) | Returns the image in a bitmap file format, using the specified pixel format.
SaveAsBitmap(CvsImage, Stream, CvsPixelFormat) | Writes the image to the stream in a bitmap file format, using the specified pixel format.

See Also

CvsImageExtensions Class
Cognex.InSight.Extensions Namespace


CvsImageExtensions Methods

[image] [image]

In-Sight SDK
CvsImageExtensions Methods
CvsImageExtensions Class See Also Send Feedback

Methods

Name | Description
SaveAsBitmap(CvsImage, CvsPixelFormat) | Returns the image in a bitmap file format, using the specified pixel format.
SaveAsBitmap(CvsImage, Stream, CvsPixelFormat) | Writes the image to the stream in a bitmap file format, using the specified pixel format.

See Also

CvsImageExtensions Class
Cognex.InSight.Extensions Namespace


CvsImageExtensions.SaveAsBitmap Method

[image] [image]

In-Sight SDK
CvsImageExtensions..::..SaveAsBitmap Method
CvsImageExtensions Class See Also Send Feedback

Overload List

Name | Description
SaveAsBitmap(CvsImage, CvsPixelFormat) | Returns the image in a bitmap file format, using the specified pixel format.
SaveAsBitmap(CvsImage, Stream, CvsPixelFormat) | Writes the image to the stream in a bitmap file format, using the specified pixel format.

See Also

CvsImageExtensions Class
CvsImageExtensions..::..CvsImageExtensions Members
Cognex.InSight.Extensions Namespace


CvsImageExtensions.SaveAsBitmap Method (CvsImage, CvsPixelFormat)

[image]

In-Sight SDK
CvsImageExtensions..::..SaveAsBitmap Method (CvsImage, CvsPixelFormat)
CvsImageExtensions Class See Also Send Feedback
Returns the image in a bitmap file format, using the specified pixel format.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static byte[] SaveAsBitmap(
    this CvsImage image,
    CvsPixelFormat format
)
Visual Basic
<ExtensionAttribute>
Public Shared Function SaveAsBitmap (
    image As CvsImage,
    format As CvsPixelFormat
) As Byte()

Parameters

image
Type: Cognex.InSight..::..CvsImage

[Missing <param name="image"/> documentation for "M:Cognex.InSight.Extensions.CvsImageExtensions.SaveAsBitmap(Cognex.InSight.CvsImage,Cognex.InSight.CvsPixelFormat)"]

format
Type: Cognex.InSight..::..CvsPixelFormat

[Missing <param name="format"/> documentation for "M:Cognex.InSight.Extensions.CvsImageExtensions.SaveAsBitmap(Cognex.InSight.CvsImage,Cognex.InSight.CvsPixelFormat)"]

Return Value

Type: array< Byte >[]()[][]

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.CvsImageExtensions.SaveAsBitmap(Cognex.InSight.CvsImage,Cognex.InSight.CvsPixelFormat)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CvsImage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

CvsImageExtensions Class
CvsImageExtensions..::..CvsImageExtensions Members
SaveAsBitmap Overload
Cognex.InSight.Extensions Namespace


CvsImageExtensions.SaveAsBitmap Method (CvsImage, Stream, CvsPixelFormat)

[image]

In-Sight SDK
CvsImageExtensions..::..SaveAsBitmap Method (CvsImage, Stream, CvsPixelFormat)
CvsImageExtensions Class See Also Send Feedback
Writes the image to the stream in a bitmap file format, using the specified pixel format.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static void SaveAsBitmap(
    this CvsImage image,
    Stream stream,
    CvsPixelFormat format
)
Visual Basic
<ExtensionAttribute>
Public Shared Sub SaveAsBitmap (
    image As CvsImage,
    stream As Stream,
    format As CvsPixelFormat
)

Parameters

image
Type: Cognex.InSight..::..CvsImage

[Missing <param name="image"/> documentation for "M:Cognex.InSight.Extensions.CvsImageExtensions.SaveAsBitmap(Cognex.InSight.CvsImage,System.IO.Stream,Cognex.InSight.CvsPixelFormat)"]

stream
Type: System.IO..::..Stream

[Missing <param name="stream"/> documentation for "M:Cognex.InSight.Extensions.CvsImageExtensions.SaveAsBitmap(Cognex.InSight.CvsImage,System.IO.Stream,Cognex.InSight.CvsPixelFormat)"]

format
Type: Cognex.InSight..::..CvsPixelFormat

[Missing <param name="format"/> documentation for "M:Cognex.InSight.Extensions.CvsImageExtensions.SaveAsBitmap(Cognex.InSight.CvsImage,System.IO.Stream,Cognex.InSight.CvsPixelFormat)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CvsImage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

CvsImageExtensions Class
CvsImageExtensions..::..CvsImageExtensions Members
SaveAsBitmap Overload
Cognex.InSight.Extensions Namespace


CvsInSightExtensions Class

[image]

In-Sight SDK
CvsInSightExtensions Class
Members See Also Send Feedback
Extension methods for CvsInSight.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static class CvsInSightExtensions
Visual Basic
<ExtensionAttribute>
Public NotInheritable Class CvsInSightExtensions

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Extensions..::..CvsInSightExtensions

See Also

CvsInSightExtensions..::..CvsInSightExtensions Members
Cognex.InSight.Extensions Namespace


CvsInSightExtensions Members

[image] [image]

In-Sight SDK
CvsInSightExtensions Members
CvsInSightExtensions Class Methods See Also Send Feedback

The CvsInSightExtensions type exposes the following members.

Methods

Name | Description
GetCell(CvsInSight, CvsCellLocation) | Returns the CvsCell from the current result set.
GetCell<(Of <<'(TResult>)>>)(CvsInSight, CvsCellLocation) | Returns the CvsCell from the current result set cast to the specified type.
GetCellGraphics | Returns an enumeration of all of the graphics associated with a cell.
GetFirmwareVersion | Gets the firmware version of the connected CvsInSight object.
GetFormatDecimalPlaces | Returns the number of decimal places that should be used when displaying a floating point value. The value is extracted from the cell format tag. If no tag is present, then the default value is returned.
GetPropertySheetExpression | Gets the current property sheet expression.

See Also

CvsInSightExtensions Class
Cognex.InSight.Extensions Namespace


CvsInSightExtensions Methods

[image] [image]

In-Sight SDK
CvsInSightExtensions Methods
CvsInSightExtensions Class See Also Send Feedback

The CvsInSightExtensions type exposes the following members.

Methods

Name | Description
GetCell(CvsInSight, CvsCellLocation) | Returns the CvsCell from the current result set.
GetCell<(Of <<'(TResult>)>>)(CvsInSight, CvsCellLocation) | Returns the CvsCell from the current result set cast to the specified type.
GetCellGraphics | Returns an enumeration of all of the graphics associated with a cell.
GetFirmwareVersion | Gets the firmware version of the connected CvsInSight object.
GetFormatDecimalPlaces | Returns the number of decimal places that should be used when displaying a floating point value. The value is extracted from the cell format tag. If no tag is present, then the default value is returned.
GetPropertySheetExpression | Gets the current property sheet expression.

See Also

CvsInSightExtensions Class
Cognex.InSight.Extensions Namespace


CvsInSightExtensions.GetCell Method

[image] [image]

In-Sight SDK
CvsInSightExtensions..::..GetCell Method
CvsInSightExtensions Class See Also Send Feedback

Overload List

Name | Description
GetCell(CvsInSight, CvsCellLocation) | Returns the CvsCell from the current result set.
GetCell<(Of <<'(TResult>)>>)(CvsInSight, CvsCellLocation) | Returns the CvsCell from the current result set cast to the specified type.

See Also

CvsInSightExtensions Class
CvsInSightExtensions..::..CvsInSightExtensions Members
Cognex.InSight.Extensions Namespace


CvsInSightExtensions.GetCell Method (CvsInSight, CvsCellLocation)

[image]

In-Sight SDK
CvsInSightExtensions..::..GetCell Method (CvsInSight, CvsCellLocation)
CvsInSightExtensions Class See Also Send Feedback
Returns the CvsCell from the current result set.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static CvsCell GetCell(
    this CvsInSight inSight,
    CvsCellLocation location
)
Visual Basic
<ExtensionAttribute>
Public Shared Function GetCell (
    inSight As CvsInSight,
    location As CvsCellLocation
) As CvsCell

Parameters

inSight
Type: Cognex.InSight..::..CvsInSight
The CvsInSight object.
location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.

Return Value

Type: CvsCell
The CvsCell from the current result set. Returns null if there is no CvsCell available or if the location is invalid.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CvsInSight. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

Remarks

This method will not throw if the State is NotConnected. Rather, null will be returned.

See Also

CvsInSightExtensions Class
CvsInSightExtensions..::..CvsInSightExtensions Members
GetCell Overload
Cognex.InSight.Extensions Namespace


CvsInSightExtensions.GetCell(TResult) Method (CvsInSight, CvsCellLocation)

[image]

In-Sight SDK
CvsInSightExtensions..::..GetCell<(Of <(<'TResult>)>)> Method (CvsInSight, CvsCellLocation)
CvsInSightExtensions Class See Also Send Feedback
Returns the CvsCell from the current result set cast to the specified type.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static TResult GetCell<TResult>(
    this CvsInSight inSight,
    CvsCellLocation location
)
where TResult : CvsCell
Visual Basic
<ExtensionAttribute>
Public Shared Function GetCell(Of TResult As CvsCell) (
    inSight As CvsInSight,
    location As CvsCellLocation
) As TResult

Parameters

inSight
Type: Cognex.InSight..::..CvsInSight
The CvsInSight object.
location
Type: Cognex.InSight..::..CvsCellLocation
The cell location.

Type Parameters

TResult
The type to cast the CvsCell result to.

Return Value

Type: TResult
The CvsCell from the current result set cast to the specified type. Returns null if there is no CvsCell available, if the location is invalid, or if the cast fails.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CvsInSight. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

Remarks

This method will not throw if the State is NotConnected. Rather, null will be returned.

See Also

CvsInSightExtensions Class
CvsInSightExtensions..::..CvsInSightExtensions Members
GetCell Overload
Cognex.InSight.Extensions Namespace


CvsInSightExtensions.GetCellGraphics Method

[image]

In-Sight SDK
CvsInSightExtensions..::..GetCellGraphics Method
CvsInSightExtensions Class See Also Send Feedback
Returns an enumeration of all of the graphics associated with a cell.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static IEnumerable<CvsGraphic> GetCellGraphics(
    this CvsInSight inSight,
    CvsCellLocation location
)
Visual Basic
<ExtensionAttribute>
Public Shared Function GetCellGraphics (
    inSight As CvsInSight,
    location As CvsCellLocation
) As IEnumerable(Of CvsGraphic)

Parameters

inSight
Type: Cognex.InSight..::..CvsInSight
The CvsInSight object.
location
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.

Return Value

Type: IEnumerable <(Of <(<' CvsGraphic >)>)>
An enumeration of all of the graphics associated with the cell. If no graphics are available, then an empty enumeration is returned.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CvsInSight. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

Remarks

This method will not throw if the State is NotConnected. Rather, an empty enumeration will be returned.

See Also

CvsInSightExtensions Class
CvsInSightExtensions..::..CvsInSightExtensions Members
Cognex.InSight.Extensions Namespace


CvsInSightExtensions.GetFirmwareVersion Method

[image]

In-Sight SDK
CvsInSightExtensions..::..GetFirmwareVersion Method
CvsInSightExtensions Class See Also Send Feedback
Gets the firmware version of the connected CvsInSight object.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static CvsHostVersion GetFirmwareVersion(
    this CvsInSight inSight
)
Visual Basic
<ExtensionAttribute>
Public Shared Function GetFirmwareVersion (
    inSight As CvsInSight
) As CvsHostVersion

Parameters

inSight
Type: Cognex.InSight..::..CvsInSight

[Missing <param name="inSight"/> documentation for "M:Cognex.InSight.Extensions.CvsInSightExtensions.GetFirmwareVersion(Cognex.InSight.CvsInSight)"]

Return Value

Type: CvsHostVersion

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.CvsInSightExtensions.GetFirmwareVersion(Cognex.InSight.CvsInSight)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CvsInSight. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

CvsInSightExtensions Class
CvsInSightExtensions..::..CvsInSightExtensions Members
Cognex.InSight.Extensions Namespace


CvsInSightExtensions.GetFormatDecimalPlaces Method

[image]

In-Sight SDK
CvsInSightExtensions..::..GetFormatDecimalPlaces Method
CvsInSightExtensions Class See Also Send Feedback
Returns the number of decimal places that should be used when displaying a floating point value. The value is extracted from the cell format tag. If no tag is present, then the default value is returned.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static int GetFormatDecimalPlaces(
    this CvsInSight inSight,
    CvsCellLocation location,
    int defaultValue
)
Visual Basic
<ExtensionAttribute>
Public Shared Function GetFormatDecimalPlaces (
    inSight As CvsInSight,
    location As CvsCellLocation,
    defaultValue As Integer
) As Integer

Parameters

inSight
Type: Cognex.InSight..::..CvsInSight
The CvsInSight object.
location
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
defaultValue
Type: System..::..Int32
The value to return if no cell format information is available.

Return Value

Type: Int32

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.CvsInSightExtensions.GetFormatDecimalPlaces(Cognex.InSight.CvsInSight,Cognex.InSight.CvsCellLocation,System.Int32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CvsInSight. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

Remarks

This method will not throw if the State is NotConnected. Rather, the default value will be returned.

See Also

CvsInSightExtensions Class
CvsInSightExtensions..::..CvsInSightExtensions Members
Cognex.InSight.Extensions Namespace


CvsInSightExtensions.GetPropertySheetExpression Method

[image]

In-Sight SDK
CvsInSightExtensions..::..GetPropertySheetExpression Method
CvsInSightExtensions Class See Also Send Feedback
Gets the current property sheet expression.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static string GetPropertySheetExpression(
    this CvsInSight insight
)
Visual Basic
<ExtensionAttribute>
Public Shared Function GetPropertySheetExpression (
    insight As CvsInSight
) As String

Parameters

insight
Type: Cognex.InSight..::..CvsInSight

[Missing <param name="insight"/> documentation for "M:Cognex.InSight.Extensions.CvsInSightExtensions.GetPropertySheetExpression(Cognex.InSight.CvsInSight)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.CvsInSightExtensions.GetPropertySheetExpression(Cognex.InSight.CvsInSight)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CvsInSight. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

CvsInSightExtensions Class
CvsInSightExtensions..::..CvsInSightExtensions Members
Cognex.InSight.Extensions Namespace


CvsNativeModeClientExtensions Class

[image]

In-Sight SDK
CvsNativeModeClientExtensions Class
Members See Also Send Feedback
Provides extensions for CvsNativeModeClient.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static class CvsNativeModeClientExtensions
Visual Basic
<ExtensionAttribute>
Public NotInheritable Class CvsNativeModeClientExtensions

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Extensions..::..CvsNativeModeClientExtensions

See Also

CvsNativeModeClientExtensions..::..CvsNativeModeClientExtensions Members
Cognex.InSight.Extensions Namespace


CvsNativeModeClientExtensions Members

[image] [image]

In-Sight SDK
CvsNativeModeClientExtensions Members
CvsNativeModeClientExtensions Class Methods See Also Send Feedback

The CvsNativeModeClientExtensions type exposes the following members.

Methods

Name | Description
GetResource<(Of <<'(T>)>>) | Sends a GET request to the client and deserializes result.

See Also

CvsNativeModeClientExtensions Class
Cognex.InSight.Extensions Namespace


CvsNativeModeClientExtensions Methods

[image] [image]

In-Sight SDK
CvsNativeModeClientExtensions Methods
CvsNativeModeClientExtensions Class See Also Send Feedback

The CvsNativeModeClientExtensions type exposes the following members.

Methods

Name | Description
GetResource<(Of <<'(T>)>>) | Sends a GET request to the client and deserializes result.

See Also

CvsNativeModeClientExtensions Class
Cognex.InSight.Extensions Namespace


CvsNativeModeClientExtensions.GetResource(T) Method

[image]

In-Sight SDK
CvsNativeModeClientExtensions..::..GetResource<(Of <(<'T>)>)> Method
CvsNativeModeClientExtensions Class See Also Send Feedback
Sends a GET request to the client and deserializes result.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static T GetResource<T>(
    this CvsNativeModeClient client,
    string resourcePath
)
Visual Basic
<ExtensionAttribute>
Public Shared Function GetResource(Of T) (
    client As CvsNativeModeClient,
    resourcePath As String
) As T

Parameters

client
Type: Cognex.InSight.NativeMode..::..CvsNativeModeClient

[Missing <param name="client"/> documentation for "M:Cognex.InSight.Extensions.CvsNativeModeClientExtensions.GetResource``1(Cognex.InSight.NativeMode.CvsNativeModeClient,System.String)"]

resourcePath
Type: System..::..String

[Missing <param name="resourcePath"/> documentation for "M:Cognex.InSight.Extensions.CvsNativeModeClientExtensions.GetResource``1(Cognex.InSight.NativeMode.CvsNativeModeClient,System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Cognex.InSight.Extensions.CvsNativeModeClientExtensions.GetResource``1(Cognex.InSight.NativeMode.CvsNativeModeClient,System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.CvsNativeModeClientExtensions.GetResource``1(Cognex.InSight.NativeMode.CvsNativeModeClient,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CvsNativeModeClient. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

Remarks

The result is assumed to be valid JSON.

See Also

CvsNativeModeClientExtensions Class
CvsNativeModeClientExtensions..::..CvsNativeModeClientExtensions Members
Cognex.InSight.Extensions Namespace


DoubleExtensions Class

[image]

In-Sight SDK
DoubleExtensions Class
Members See Also Send Feedback
Provides extension methods for double.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static class DoubleExtensions
Visual Basic
<ExtensionAttribute>
Public NotInheritable Class DoubleExtensions

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Extensions..::..DoubleExtensions

See Also

DoubleExtensions..::..DoubleExtensions Members
Cognex.InSight.Extensions Namespace


DoubleExtensions Members

[image] [image]

In-Sight SDK
DoubleExtensions Members
DoubleExtensions Class Methods See Also Send Feedback

Methods

Name | Description
IsFinite(Double) | Returns true if the value is not NaN, PositiveInfinity, or NegativeInfinity.
IsFinite(Nullable<(Of <<'(Double>)>>)) | Returns true if the value is not null, NaN, PositiveInfinity, or NegativeInfinity.

See Also

DoubleExtensions Class
Cognex.InSight.Extensions Namespace


DoubleExtensions Methods

[image] [image]

In-Sight SDK
DoubleExtensions Methods
DoubleExtensions Class See Also Send Feedback

Methods

Name | Description
IsFinite(Double) | Returns true if the value is not NaN, PositiveInfinity, or NegativeInfinity.
IsFinite(Nullable<(Of <<'(Double>)>>)) | Returns true if the value is not null, NaN, PositiveInfinity, or NegativeInfinity.

See Also

DoubleExtensions Class
Cognex.InSight.Extensions Namespace


DoubleExtensions.IsFinite Method

[image] [image]

In-Sight SDK
DoubleExtensions..::..IsFinite Method
DoubleExtensions Class See Also Send Feedback

Overload List

Name | Description
IsFinite(Double) | Returns true if the value is not NaN, PositiveInfinity, or NegativeInfinity.
IsFinite(Nullable<(Of <<'(Double>)>>)) | Returns true if the value is not null, NaN, PositiveInfinity, or NegativeInfinity.

See Also

DoubleExtensions Class
DoubleExtensions..::..DoubleExtensions Members
Cognex.InSight.Extensions Namespace


DoubleExtensions.IsFinite Method (Double)

[image]

In-Sight SDK
DoubleExtensions..::..IsFinite Method (Double)
DoubleExtensions Class See Also Send Feedback
Returns true if the value is not NaN, PositiveInfinity, or NegativeInfinity.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsFinite(
    this double value
)
Visual Basic
<ExtensionAttribute>
Public Shared Function IsFinite (
    value As Double
) As Boolean

Parameters

value
Type: System..::..Double

[Missing <param name="value"/> documentation for "M:Cognex.InSight.Extensions.DoubleExtensions.IsFinite(System.Double)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.DoubleExtensions.IsFinite(System.Double)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Double. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

DoubleExtensions Class
DoubleExtensions..::..DoubleExtensions Members
IsFinite Overload
Cognex.InSight.Extensions Namespace


DoubleExtensions.IsFinite Method (Nullable(Double))

[image]

In-Sight SDK
DoubleExtensions..::..IsFinite Method (Nullable<(Of <(<'Double>)>)>)
DoubleExtensions Class See Also Send Feedback
Returns true if the value is not null, NaN, PositiveInfinity, or NegativeInfinity.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsFinite(
    this Nullable<double> value
)
Visual Basic
<ExtensionAttribute>
Public Shared Function IsFinite (
    value As Nullable(Of Double)
) As Boolean

Parameters

value
Type: System..::..Nullable <(Of <(<' Double >)>)>

[Missing <param name="value"/> documentation for "M:Cognex.InSight.Extensions.DoubleExtensions.IsFinite(System.Nullable{System.Double})"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.DoubleExtensions.IsFinite(System.Nullable{System.Double})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Nullable <(Of <(<' Double >)>)>. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

DoubleExtensions Class
DoubleExtensions..::..DoubleExtensions Members
IsFinite Overload
Cognex.InSight.Extensions Namespace


ExceptionExtensions Class

[image]

In-Sight SDK
ExceptionExtensions Class
Members See Also Send Feedback
Extension methods for Exception objects.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static class ExceptionExtensions
Visual Basic
<ExtensionAttribute>
Public NotInheritable Class ExceptionExtensions

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Extensions..::..ExceptionExtensions

See Also

ExceptionExtensions..::..ExceptionExtensions Members
Cognex.InSight.Extensions Namespace


ExceptionExtensions Members

[image] [image]

In-Sight SDK
ExceptionExtensions Members
ExceptionExtensions Class Methods See Also Send Feedback

The ExceptionExtensions type exposes the following members.

Methods

Name | Description
FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException.

See Also

ExceptionExtensions Class
Cognex.InSight.Extensions Namespace


ExceptionExtensions Methods

[image] [image]

In-Sight SDK
ExceptionExtensions Methods
ExceptionExtensions Class See Also Send Feedback

The ExceptionExtensions type exposes the following members.

Methods

Name | Description
FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException.

See Also

ExceptionExtensions Class
Cognex.InSight.Extensions Namespace


ExceptionExtensions.FindInnerException(TInnerException) Method

[image]

In-Sight SDK
ExceptionExtensions..::..FindInnerException<(Of <(<'TInnerException>)>)> Method
ExceptionExtensions Class See Also Send Feedback
Recursively searches for an inner exception of type TInnerException.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static TInnerException FindInnerException<TInnerException>(
    this Exception ex
)
where TInnerException : Exception
Visual Basic
<ExtensionAttribute>
Public Shared Function FindInnerException(Of TInnerException As Exception) (
    ex As Exception
) As TInnerException

Parameters

ex
Type: System..::..Exception

[Missing <param name="ex"/> documentation for "M:Cognex.InSight.Extensions.ExceptionExtensions.FindInnerException``1(System.Exception)"]

Type Parameters

TInnerException
The exception type to return.

Return Value

Type: TInnerException
An exception of type TInnerException, or null if no such inner exception exits.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Exception. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

ExceptionExtensions Class
ExceptionExtensions..::..ExceptionExtensions Members
Cognex.InSight.Extensions Namespace


PropertyInfoExtensions Class

[image]

In-Sight SDK
PropertyInfoExtensions Class
Members See Also Send Feedback
Extension methods for System.Reflection.PropertyInfo.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static class PropertyInfoExtensions
Visual Basic
<ExtensionAttribute>
Public NotInheritable Class PropertyInfoExtensions

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Extensions..::..PropertyInfoExtensions

See Also

PropertyInfoExtensions..::..PropertyInfoExtensions Members
Cognex.InSight.Extensions Namespace


PropertyInfoExtensions Members

[image] [image]

In-Sight SDK
PropertyInfoExtensions Members
PropertyInfoExtensions Class Methods See Also Send Feedback

The PropertyInfoExtensions type exposes the following members.

Methods

Name | Description
GetJsonPropertyName | Gets the JSON property name.
HasAttribute<(Of <<'(TAttribute>)>>) | Indicates if the property has an attribute of the specified type.

See Also

PropertyInfoExtensions Class
Cognex.InSight.Extensions Namespace


PropertyInfoExtensions Methods

[image] [image]

In-Sight SDK
PropertyInfoExtensions Methods
PropertyInfoExtensions Class See Also Send Feedback

The PropertyInfoExtensions type exposes the following members.

Methods

Name | Description
GetJsonPropertyName | Gets the JSON property name.
HasAttribute<(Of <<'(TAttribute>)>>) | Indicates if the property has an attribute of the specified type.

See Also

PropertyInfoExtensions Class
Cognex.InSight.Extensions Namespace


PropertyInfoExtensions.GetJsonPropertyName Method

[image]

In-Sight SDK
PropertyInfoExtensions..::..GetJsonPropertyName Method
PropertyInfoExtensions Class See Also Send Feedback
Gets the JSON property name.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static string GetJsonPropertyName(
    this PropertyInfo propertyInfo
)
Visual Basic
<ExtensionAttribute>
Public Shared Function GetJsonPropertyName (
    propertyInfo As PropertyInfo
) As String

Parameters

propertyInfo
Type: System.Reflection..::..PropertyInfo

[Missing <param name="propertyInfo"/> documentation for "M:Cognex.InSight.Extensions.PropertyInfoExtensions.GetJsonPropertyName(System.Reflection.PropertyInfo)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.PropertyInfoExtensions.GetJsonPropertyName(System.Reflection.PropertyInfo)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PropertyInfo. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

Remarks

Prefers the name specified in the Newtonsoft.Json.JsonPropertyAttribute, if that attribute exists. Otherwise, PropertyInfo.Name will be used.

See Also

PropertyInfoExtensions Class
PropertyInfoExtensions..::..PropertyInfoExtensions Members
Cognex.InSight.Extensions Namespace


PropertyInfoExtensions.HasAttribute(TAttribute) Method

[image]

In-Sight SDK
PropertyInfoExtensions..::..HasAttribute<(Of <(<'TAttribute>)>)> Method
PropertyInfoExtensions Class See Also Send Feedback
Indicates if the property has an attribute of the specified type.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool HasAttribute<TAttribute>(
    this PropertyInfo propertyInfo
)
Visual Basic
<ExtensionAttribute>
Public Shared Function HasAttribute(Of TAttribute) (
    propertyInfo As PropertyInfo
) As Boolean

Parameters

propertyInfo
Type: System.Reflection..::..PropertyInfo

[Missing <param name="propertyInfo"/> documentation for "M:Cognex.InSight.Extensions.PropertyInfoExtensions.HasAttribute``1(System.Reflection.PropertyInfo)"]

Type Parameters

TAttribute

[Missing <typeparam name="TAttribute"/> documentation for "M:Cognex.InSight.Extensions.PropertyInfoExtensions.HasAttribute``1(System.Reflection.PropertyInfo)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.PropertyInfoExtensions.HasAttribute``1(System.Reflection.PropertyInfo)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PropertyInfo. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

PropertyInfoExtensions Class
PropertyInfoExtensions..::..PropertyInfoExtensions Members
Cognex.InSight.Extensions Namespace


StringExtensions Class

[image]

In-Sight SDK
StringExtensions Class
Members See Also Send Feedback
Provides extension methods for String.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static class StringExtensions
Visual Basic
<ExtensionAttribute>
Public NotInheritable Class StringExtensions

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Extensions..::..StringExtensions

See Also

StringExtensions..::..StringExtensions Members
Cognex.InSight.Extensions Namespace


StringExtensions Members

[image] [image]

In-Sight SDK
StringExtensions Members
StringExtensions Class Methods See Also Send Feedback

The StringExtensions type exposes the following members.

Methods

Name | Description
Contains | Returns a value indicating whether a specified substring occurs within this string.
ReplaceNewLineWithSpace | Replace new line characters, \r and \n, with a space.
TryParseInvariant(String, Int32%) | Converts the string representation of a int to its 32-bit number equivalent.
TryParseInvariant(String, Single%) | Converts the string representation of a float to its single-precision floating-point number equivalent.

See Also

StringExtensions Class
Cognex.InSight.Extensions Namespace


StringExtensions Methods

[image] [image]

In-Sight SDK
StringExtensions Methods
StringExtensions Class See Also Send Feedback

The StringExtensions type exposes the following members.

Methods

Name | Description
Contains | Returns a value indicating whether a specified substring occurs within this string.
ReplaceNewLineWithSpace | Replace new line characters, \r and \n, with a space.
TryParseInvariant(String, Int32%) | Converts the string representation of a int to its 32-bit number equivalent.
TryParseInvariant(String, Single%) | Converts the string representation of a float to its single-precision floating-point number equivalent.

See Also

StringExtensions Class
Cognex.InSight.Extensions Namespace


StringExtensions.Contains Method

[image]

In-Sight SDK
StringExtensions..::..Contains Method
StringExtensions Class See Also Send Feedback
Returns a value indicating whether a specified substring occurs within this string.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool Contains(
    this string text,
    string value,
    StringComparison type
)
Visual Basic
<ExtensionAttribute>
Public Shared Function Contains (
    text As String,
    value As String,
    type As StringComparison
) As Boolean

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Cognex.InSight.Extensions.StringExtensions.Contains(System.String,System.String,System.StringComparison)"]

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:Cognex.InSight.Extensions.StringExtensions.Contains(System.String,System.String,System.StringComparison)"]

type
Type: System..::..StringComparison

[Missing <param name="type"/> documentation for "M:Cognex.InSight.Extensions.StringExtensions.Contains(System.String,System.String,System.StringComparison)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.StringExtensions.Contains(System.String,System.String,System.StringComparison)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

StringExtensions Class
StringExtensions..::..StringExtensions Members
Cognex.InSight.Extensions Namespace


StringExtensions.ReplaceNewLineWithSpace Method

[image]

In-Sight SDK
StringExtensions..::..ReplaceNewLineWithSpace Method
StringExtensions Class See Also Send Feedback
Replace new line characters, \r and \n, with a space.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static string ReplaceNewLineWithSpace(
    this string other
)
Visual Basic
<ExtensionAttribute>
Public Shared Function ReplaceNewLineWithSpace (
    other As String
) As String

Parameters

other
Type: System..::..String

[Missing <param name="other"/> documentation for "M:Cognex.InSight.Extensions.StringExtensions.ReplaceNewLineWithSpace(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Cognex.InSight.Extensions.StringExtensions.ReplaceNewLineWithSpace(System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

StringExtensions Class
StringExtensions..::..StringExtensions Members
Cognex.InSight.Extensions Namespace


StringExtensions.TryParseInvariant Method

[image] [image]

In-Sight SDK
StringExtensions..::..TryParseInvariant Method
StringExtensions Class See Also Send Feedback

Overload List

Name | Description
TryParseInvariant(String, Int32%) | Converts the string representation of a int to its 32-bit number equivalent.
TryParseInvariant(String, Single%) | Converts the string representation of a float to its single-precision floating-point number equivalent.

See Also

StringExtensions Class
StringExtensions..::..StringExtensions Members
Cognex.InSight.Extensions Namespace


StringExtensions.TryParseInvariant Method (String, Int32)

[image]

In-Sight SDK
StringExtensions..::..TryParseInvariant Method (String, Int32%)
StringExtensions Class See Also Send Feedback
Converts the string representation of a int to its 32-bit number equivalent.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool TryParseInvariant(
    this string s,
    out int result
)
Visual Basic
<ExtensionAttribute>
Public Shared Function TryParseInvariant (
    s As String,
    <OutAttribute> ByRef result As Integer
) As Boolean

Parameters

s
Type: System..::..String
A string representing a number to convert.
result
Type: System..::..Int32 %
The result if successful; otherwise 0.

Return Value

Type: Boolean
true if successful; otherwise, false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

StringExtensions Class
StringExtensions..::..StringExtensions Members
TryParseInvariant Overload
Cognex.InSight.Extensions Namespace


StringExtensions.TryParseInvariant Method (String, Single)

[image]

In-Sight SDK
StringExtensions..::..TryParseInvariant Method (String, Single%)
StringExtensions Class See Also Send Feedback
Converts the string representation of a float to its single-precision floating-point number equivalent.

Namespace: Cognex.InSight.Extensions
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool TryParseInvariant(
    this string s,
    out float result
)
Visual Basic
<ExtensionAttribute>
Public Shared Function TryParseInvariant (
    s As String,
    <OutAttribute> ByRef result As Single
) As Boolean

Parameters

s
Type: System..::..String
A string representing a number to convert.
result
Type: System..::..Single %
The result if successful; otherwise 0.

Return Value

Type: Boolean
true if successful; otherwise, false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).

See Also

StringExtensions Class
StringExtensions..::..StringExtensions Members
TryParseInvariant Overload
Cognex.InSight.Extensions Namespace


Cognex.InSight.Ftp Namespace

[image]

In-Sight SDK
Cognex.InSight.Ftp Namespace
Send Feedback
The Cognex.InSight.Ftp namespace provides classes for accessing an In-Sight sensor via FTP.

Classes

 | Class | Description
Public class | CvsFtpClient | Performs file transfer operations using FTP (File Transfer Protocol) with an In-Sight sensor. Use of this class while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed, the constructor will throw a CvsNotLicensedException.


CvsFtpClient Class

[image]

In-Sight SDK
CvsFtpClient Class
Members See Also Send Feedback
Performs file transfer operations using FTP (File Transfer Protocol) with an In-Sight sensor. Use of this class while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed, the constructor will throw a CvsNotLicensedException.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public sealed class CvsFtpClient : IDisposable
Visual Basic
Public NotInheritable Class CvsFtpClient
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Ftp..::..CvsFtpClient

See Also

CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient Members

[image] [image]

In-Sight SDK
CvsFtpClient Members
CvsFtpClient Class Constructors Methods Properties See Also Send Feedback

The CvsFtpClient type exposes the following members.

Constructors

 | Name | Description
Public method | CvsFtpClient()()()() | Initializes a new instance of the CvsFtpClient class for connecting to an In-Sight sensor for FTP file transfers.
Public method | CvsFtpClient(Encoding) | Initializes a new instance of the CvsFtpClient class for connecting to an In-Sight sensor for FTP file transfers.

Methods

 | Name | Description
Public method | Connect(IPAddress, String, String) | Opens an FTP connection to the In-Sight sensor on the default port of 21.
Public method | Connect(IPEndPoint, String, String) | Opens an FTP connection to the In-Sight sensor.
Public method | Connect(IPAddress, String, String, Int32) | Opens an FTP connection to the In-Sight sensor.
Public method | Connect(String, String, String, Int32) | Opens an FTP connection to the In-Sight sensor.
Public method | Disconnect | Disconnects from the In-Sight sensor.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetFileArrayFromInSight | Gets one or more files from the In-Sight sensor. If a remote file name contains a mask only the first file matching the mask is received.
Public method | GetFileCollection | Returns a collection of files and directories held on the In-Sight sensor.
Public method | GetFileFromInSight | Gets a file from the In-Sight sensor. If remoteFilename contains a mask only the first file matching the mask is received.
Public method | GetFileList | Returns the list of files held on the In-Sight sensor in its root directory.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetReadPermissionEnabled | Gets a flag that determines if read permissions are enabled for the current connection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWritePermissionEnabled | Gets a flag that determines if write permissions are enabled for the current connection.
Public method | IsValidFilename | Determines if the filename is valid for the In-Sight Sensor.
Public method | ReadFileFromInSight | Reads a file from the In-Sight sensor into memory. If remoteFilename contains a mask only the first file matching the mask is received.
Public method | RemoveFile | Deletes a file on the In-Sight sensor.
Public method | RenameFile | Renames a file on the In-Sight file system.
Public method | SendFileToInSight(Stream, String) | Sends a file to the In-Sight sensor.
Public method | SendFileToInSight(String, String) | Sends a file to the In-Sight sensor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Connected | Gets a value indicating whether a client is connected to a remote host.
Public property | Encoding | Gets the encoding used to read and write from the FTP socket.
Public property | LastResponse | Gets the last response returned from the server.
Public property | Password | Gets the password associated with the user name for the connection.
Public property | Port | Gets the port used for the connection to an In-Sight sensor.
Public property | RemoteIPAddress | Gets the IP Address of the In-Sight sensor used for the connection.
Public property | RemoteIPAddressString | Gets the IP Address of the In-Sight sensor used for the connection.
Public property | Timeout | Gets or sets the timeout (ms) used for sending or receiving data.
Public property | UsePasswordEncryption | Gets or sets the value indicating whether to use advanced encryption when sending the password to the host.
Public property | Username | Gets the user name for the connection.
Public property | WelcomeBanner | Gets the first line of the Welcome Banner returned from the server.

See Also

CvsFtpClient Class
Cognex.InSight.Ftp Namespace


CvsFtpClient Constructor

[image] [image]

In-Sight SDK
CvsFtpClient Constructor
CvsFtpClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsFtpClient()()()() | Initializes a new instance of the CvsFtpClient class for connecting to an In-Sight sensor for FTP file transfers.
Public method | CvsFtpClient(Encoding) | Initializes a new instance of the CvsFtpClient class for connecting to an In-Sight sensor for FTP file transfers.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient Constructor

[image]

In-Sight SDK
CvsFtpClient Constructor
CvsFtpClient Class See Also Send Feedback
Initializes a new instance of the CvsFtpClient class for connecting to an In-Sight sensor for FTP file transfers.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsFtpClient()
Visual Basic
Public Sub New

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotLicensedException | The CvsFtpClient class may not be debugged without an In-Sight SDK license.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
CvsFtpClient Overload
Cognex.InSight.Ftp Namespace


CvsFtpClient Constructor (Encoding)

[image]

In-Sight SDK
CvsFtpClient Constructor (Encoding)
CvsFtpClient Class See Also Send Feedback
Initializes a new instance of the CvsFtpClient class for connecting to an In-Sight sensor for FTP file transfers.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsFtpClient(
    Encoding encoding
)
Visual Basic
Public Sub New (
    encoding As Encoding
)

Parameters

encoding
Type: System.Text..::..Encoding
The encoding to use to read and write to the FTP socket, and perform file listing operations

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotLicensedException | The CvsFtpClient class may not be constructed in a debug environment without an In-Sight SDK license.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
CvsFtpClient Overload
Cognex.InSight.Ftp Namespace


CvsFtpClient Methods

[image] [image]

In-Sight SDK
CvsFtpClient Methods
CvsFtpClient Class See Also Send Feedback

The CvsFtpClient type exposes the following members.

Methods

 | Name | Description
Public method | Connect(IPAddress, String, String) | Opens an FTP connection to the In-Sight sensor on the default port of 21.
Public method | Connect(IPEndPoint, String, String) | Opens an FTP connection to the In-Sight sensor.
Public method | Connect(IPAddress, String, String, Int32) | Opens an FTP connection to the In-Sight sensor.
Public method | Connect(String, String, String, Int32) | Opens an FTP connection to the In-Sight sensor.
Public method | Disconnect | Disconnects from the In-Sight sensor.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetFileArrayFromInSight | Gets one or more files from the In-Sight sensor. If a remote file name contains a mask only the first file matching the mask is received.
Public method | GetFileCollection | Returns a collection of files and directories held on the In-Sight sensor.
Public method | GetFileFromInSight | Gets a file from the In-Sight sensor. If remoteFilename contains a mask only the first file matching the mask is received.
Public method | GetFileList | Returns the list of files held on the In-Sight sensor in its root directory.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetReadPermissionEnabled | Gets a flag that determines if read permissions are enabled for the current connection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWritePermissionEnabled | Gets a flag that determines if write permissions are enabled for the current connection.
Public method | IsValidFilename | Determines if the filename is valid for the In-Sight Sensor.
Public method | ReadFileFromInSight | Reads a file from the In-Sight sensor into memory. If remoteFilename contains a mask only the first file matching the mask is received.
Public method | RemoveFile | Deletes a file on the In-Sight sensor.
Public method | RenameFile | Renames a file on the In-Sight file system.
Public method | SendFileToInSight(Stream, String) | Sends a file to the In-Sight sensor.
Public method | SendFileToInSight(String, String) | Sends a file to the In-Sight sensor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsFtpClient Class
Cognex.InSight.Ftp Namespace


CvsFtpClient.Connect Method

[image] [image]

In-Sight SDK
CvsFtpClient..::..Connect Method
CvsFtpClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Connect(IPAddress, String, String) | Opens an FTP connection to the In-Sight sensor on the default port of 21.
Public method | Connect(IPEndPoint, String, String) | Opens an FTP connection to the In-Sight sensor.
Public method | Connect(IPAddress, String, String, Int32) | Opens an FTP connection to the In-Sight sensor.
Public method | Connect(String, String, String, Int32) | Opens an FTP connection to the In-Sight sensor.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.Connect Method (IPAddress, String, String)

[image]

In-Sight SDK
CvsFtpClient..::..Connect Method (IPAddress, String, String)
CvsFtpClient Class See Also Send Feedback
Opens an FTP connection to the In-Sight sensor on the default port of 21.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Connect(
    IPAddress address,
    string username,
    string password
)
Visual Basic
Public Sub Connect (
    address As IPAddress,
    username As String,
    password As String
)

Parameters

address
Type: System.Net..::..IPAddress
The TCP/IP address of the In-Sight sensor to connect to.
username
Type: System..::..String
The user name to connect with.
password
Type: System..::..String
The password associated with the user name to connect with.

Remarks

This method disconnects a connection before establishing a new one.

This overload is only available in .NET applications.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | Unable to complete the Ftp connection.
Cognex.InSight..::..CvsInvalidLogonException | Unable to log on to the sensor using the specified username and password.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Connect Overload
Cognex.InSight.Ftp Namespace


CvsFtpClient.Connect Method (IPEndPoint, String, String)

[image]

In-Sight SDK
CvsFtpClient..::..Connect Method (IPEndPoint, String, String)
CvsFtpClient Class See Also Send Feedback
Opens an FTP connection to the In-Sight sensor.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Connect(
    IPEndPoint remoteEP,
    string username,
    string password
)
Visual Basic
Public Sub Connect (
    remoteEP As IPEndPoint,
    username As String,
    password As String
)

Parameters

remoteEP
Type: System.Net..::..IPEndPoint
The TCP/IP address and port for the In-Sight sensor to connect to.
username
Type: System..::..String
The user name to connect with.
password
Type: System..::..String
The password associated with the user name to connect with.

Remarks

This method disconnects a connection before establishing a new one.

This overload is only available in .NET applications.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | Unable to complete the Ftp connection.
Cognex.InSight..::..CvsInvalidLogonException | Unable to log on to the sensor using the specified username and password.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Connect Overload
Cognex.InSight.Ftp Namespace


CvsFtpClient.Connect Method (IPAddress, String, String, Int32)

[image]

In-Sight SDK
CvsFtpClient..::..Connect Method (IPAddress, String, String, Int32)
CvsFtpClient Class See Also Send Feedback
Opens an FTP connection to the In-Sight sensor.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Connect(
    IPAddress address,
    string username,
    string password,
    int port
)
Visual Basic
Public Sub Connect (
    address As IPAddress,
    username As String,
    password As String,
    port As Integer
)

Parameters

address
Type: System.Net..::..IPAddress
The TCP/IP address of the In-Sight sensor to connect to.
username
Type: System..::..String
The user name to connect with.
password
Type: System..::..String
The password associated with the user name to connect with.
port
Type: System..::..Int32
The port number to connect with.

Remarks

This method disconnects a connection before establishing a new one.

This overload is only available in .NET applications.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | Unable to complete the Ftp connection.
Cognex.InSight..::..CvsInvalidLogonException | Unable to log on to the sensor using the specified username and password.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Connect Overload
Cognex.InSight.Ftp Namespace


CvsFtpClient.Connect Method (String, String, String, Int32)

[image]

In-Sight SDK
CvsFtpClient..::..Connect Method (String, String, String, Int32)
CvsFtpClient Class See Also Send Feedback
Opens an FTP connection to the In-Sight sensor.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Connect(
    string hostname,
    string username,
    string password,
    int port
)
Visual Basic
Public Sub Connect (
    hostname As String,
    username As String,
    password As String,
    port As Integer
)

Parameters

hostname
Type: System..::..String
The TCP/IP address of the In-Sight sensor to connect to.
username
Type: System..::..String
The user name to connect with.
password
Type: System..::..String
The password associated with the user name to connect with.
port
Type: System..::..Int32
The port number to connect with.

Remarks

This method disconnects a connection before establishing a new one.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | Unable to complete the Ftp connection, or resolve the hostname.
Cognex.InSight..::..CvsInvalidLogonException | Unable to log on to the sensor using the specified username and password.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Connect Overload
Cognex.InSight.Ftp Namespace


CvsFtpClient.Disconnect Method

[image]

In-Sight SDK
CvsFtpClient..::..Disconnect Method
CvsFtpClient Class See Also Send Feedback
Disconnects from the In-Sight sensor.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Disconnect()
Visual Basic
Public Sub Disconnect

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace
CvsInSight..::..Connect(IPAddress, String, String, Boolean, Boolean)


CvsFtpClient.GetFileArrayFromInSight Method

[image]

In-Sight SDK
CvsFtpClient..::..GetFileArrayFromInSight Method
CvsFtpClient Class See Also Send Feedback
Gets one or more files from the In-Sight sensor. If a remote file name contains a mask only the first file matching the mask is received.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void GetFileArrayFromInSight(
    List<string> localFilenames,
    List<string> remoteFilenames
)
Visual Basic
Public Sub GetFileArrayFromInSight (
    localFilenames As List(Of String),
    remoteFilenames As List(Of String)
)

Parameters

localFilenames
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
A list of one or more full filenames of the local files.
remoteFilenames
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
A list of one or more files on the In-Sight sensor.

Remarks

This method is only available in .NET applications.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is null.
System..::..IndexOutOfRangeException | The remoteFilenames list has fewer elements than the localFilenames list.
Cognex.InSight..::..CvsNotConnectedException | Connected is false.
Cognex.InSight..::..CvsFileNotFoundException | A remote file is not found.
Cognex.InSight..::..CvsFileOperationFailedException | A remote file cannot be read due to insufficient read permissions.
Cognex.InSight..::..CvsNetworkException | Could not find an acceptable IP address to perform the file transfer or some other network error occurred.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.GetFileCollection Method

[image]

In-Sight SDK
CvsFtpClient..::..GetFileCollection Method
CvsFtpClient Class See Also Send Feedback
Returns a collection of files and directories held on the In-Sight sensor.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsFileCollection GetFileCollection(
    string directory
)
Visual Basic
Public Function GetFileCollection (
    directory As String
) As CvsFileCollection

Parameters

directory
Type: System..::..String
The directory to request the file listing from. An empty string requests the root directory.

Return Value

Type: CvsFileCollection
Returns an array of file names.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | Connected is false.
Cognex.InSight..::..CvsFileOperationFailedException | The file operation reading the files failed.
Cognex.InSight..::..CvsNetworkException | Could not find an acceptable IP address to perform the file transfer or some other network error occurred.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.GetFileFromInSight Method

[image]

In-Sight SDK
CvsFtpClient..::..GetFileFromInSight Method
CvsFtpClient Class See Also Send Feedback
Gets a file from the In-Sight sensor. If remoteFilename contains a mask only the first file matching the mask is received.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void GetFileFromInSight(
    string localFilename,
    string remoteFilename
)
Visual Basic
Public Sub GetFileFromInSight (
    localFilename As String,
    remoteFilename As String
)

Parameters

localFilename
Type: System..::..String
The full filename of the local file.
remoteFilename
Type: System..::..String
The file on the In-Sight sensor.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | Connected is false.
System..::..UnauthorizedAccessException | The local file cannot be written.
Cognex.InSight..::..CvsFileNotFoundException | The remote file is not found.
Cognex.InSight..::..CvsFileOperationFailedException | The remote file cannot be read due to insufficient read permissions.
Cognex.InSight..::..CvsNetworkException | Could not find an acceptable IP address to perform the file transfer or some other network error occurred.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.GetFileList Method

[image]

In-Sight SDK
CvsFtpClient..::..GetFileList Method
CvsFtpClient Class See Also Send Feedback
Returns the list of files held on the In-Sight sensor in its root directory.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string[] GetFileList()
Visual Basic
Public Function GetFileList As String()

Return Value

Type: array< String >[]()[][]
Returns an array of file names.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | Connected is false.
Cognex.InSight..::..CvsFileOperationFailedException | The file operation reading the files failed.
Cognex.InSight..::..CvsNetworkException | Could not find an acceptable IP address to perform the file transfer or some other network error occurred.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.GetReadPermissionEnabled Method

[image]

In-Sight SDK
CvsFtpClient..::..GetReadPermissionEnabled Method
CvsFtpClient Class See Also Send Feedback
Gets a flag that determines if read permissions are enabled for the current connection.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool GetReadPermissionEnabled()
Visual Basic
Public Function GetReadPermissionEnabled As Boolean

Return Value

Type: Boolean
true if read permissions are enabled and false otherwise.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | Connected is false.
Cognex.InSight..::..CvsNetworkException | A network error occurred.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.GetWritePermissionEnabled Method

[image]

In-Sight SDK
CvsFtpClient..::..GetWritePermissionEnabled Method
CvsFtpClient Class See Also Send Feedback
Gets a flag that determines if write permissions are enabled for the current connection.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool GetWritePermissionEnabled()
Visual Basic
Public Function GetWritePermissionEnabled As Boolean

Return Value

Type: Boolean
true if write permissions are enabled and false otherwise.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | Connected is false.
Cognex.InSight..::..CvsNetworkException | A network error occurred.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.IsValidFilename Method

[image]

In-Sight SDK
CvsFtpClient..::..IsValidFilename Method
CvsFtpClient Class See Also Send Feedback
Determines if the filename is valid for the In-Sight Sensor.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValidFilename(
    string remoteFilename
)
Visual Basic
Public Function IsValidFilename (
    remoteFilename As String
) As Boolean

Parameters

remoteFilename
Type: System..::..String
The file on the In-Sight sensor.

Return Value

Type: Boolean
true if the file is a valid In-Sight sensor file name, and false otherwise.

Remarks

This method determines if valid characters are used for the filename and also that it is structured properly, such as having only one extension. Any path specified will be ignored and not validated.

Invalid characters include '*', '|', ':', '"', '?', '<', '>', ',', ';', '\', '/', '%' as well as extended ASCII characters.

It does not verify that the length of the file name is acceptable for the processor. The length of the filename should be verified with the MaxFileNameLength. Although, a limit of at most 255 characters is always imposed.

It also does not validate if the file extension designates a valid file type that may be saved on an In-sight sensor.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.ReadFileFromInSight Method

[image]

In-Sight SDK
CvsFtpClient..::..ReadFileFromInSight Method
CvsFtpClient Class See Also Send Feedback
Reads a file from the In-Sight sensor into memory. If remoteFilename contains a mask only the first file matching the mask is received.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ReadFileFromInSight(
    Stream stream,
    string remoteFilename
)
Visual Basic
Public Sub ReadFileFromInSight (
    stream As Stream,
    remoteFilename As String
)

Parameters

stream
Type: System.IO..::..Stream
The Stream for the file.
remoteFilename
Type: System..::..String
The file on the In-Sight sensor.

Remarks

This method is only available in .NET applications.

Exceptions

Exception | Condition
System..::..ArgumentNullException | stream is null.
Cognex.InSight..::..CvsNotConnectedException | Connected is false.
Cognex.InSight..::..CvsFileNotFoundException | The remote file is not found.
Cognex.InSight..::..CvsFileOperationFailedException | The remote file cannot be read due to insufficient read permissions.
Cognex.InSight..::..CvsNetworkException | Could not find an acceptable IP address to perform the file transfer or some other network error occurred.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.RemoveFile Method

[image]

In-Sight SDK
CvsFtpClient..::..RemoveFile Method
CvsFtpClient Class See Also Send Feedback
Deletes a file on the In-Sight sensor.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void RemoveFile(
    string remoteFilename
)
Visual Basic
Public Sub RemoveFile (
    remoteFilename As String
)

Parameters

remoteFilename
Type: System..::..String
The file name on the In-Sight sensor.

Exceptions

Exception | Condition
System..::..ArgumentException | remoteFilename is not valid.
Cognex.InSight..::..CvsNotConnectedException | Connected is false.
Cognex.InSight..::..CvsFileNotFoundException | The remote file was not found.
Cognex.InSight..::..CvsFileOperationFailedException | The remote file cannot be deleted due to insufficient permissions.
Cognex.InSight..::..CvsNetworkException | A network error occurred.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.RenameFile Method

[image]

In-Sight SDK
CvsFtpClient..::..RenameFile Method
CvsFtpClient Class See Also Send Feedback
Renames a file on the In-Sight file system.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void RenameFile(
    string remoteFilename,
    string newRemoteFilename
)
Visual Basic
Public Sub RenameFile (
    remoteFilename As String,
    newRemoteFilename As String
)

Parameters

remoteFilename
Type: System..::..String
The file to rename on the In-Sight sensor.
newRemoteFilename
Type: System..::..String
The new name of the file on the In-Sight sensor.

Exceptions

Exception | Condition
System..::..ArgumentException | The remote file name is too long or not valid.
Cognex.InSight..::..CvsNotConnectedException | State is NotConnected.
Cognex.InSight..::..CvsNetworkException | A network error prevents the file from being renamed. Either an FTP connection could not be established or an error occurred performing the transfer.
Cognex.InSight..::..CvsFileNotFoundException | The remote file was not found.
Cognex.InSight..::..CvsFileOperationFailedException | The remote file cannot be renamed due to insufficient permissions, or the file already exists.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.SendFileToInSight Method

[image] [image]

In-Sight SDK
CvsFtpClient..::..SendFileToInSight Method
CvsFtpClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SendFileToInSight(Stream, String) | Sends a file to the In-Sight sensor.
Public method | SendFileToInSight(String, String) | Sends a file to the In-Sight sensor.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.SendFileToInSight Method (Stream, String)

[image]

In-Sight SDK
CvsFtpClient..::..SendFileToInSight Method (Stream, String)
CvsFtpClient Class See Also Send Feedback
Sends a file to the In-Sight sensor.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SendFileToInSight(
    Stream data,
    string remoteFilename
)
Visual Basic
Public Sub SendFileToInSight (
    data As Stream,
    remoteFilename As String
)

Parameters

data
Type: System.IO..::..Stream
The file data stream to send to the In-Sight sensor.
remoteFilename
Type: System..::..String
The file name to create on the In-Sight sensor.

Remarks

remoteFilename must be valid to be saved on the In-Sight sensor. IsValidFilename(String) may be used to validate the characters that comprise the filename. Some file extensions, however, are not valid to be saved to an In-Sight sensor.

An In-Sight image file (*.BMP or *.JPG) may be loaded by any In-Sight system for use in Offline spreadsheet job testing and configuration. However, because In-Sight sensors can store only one image, images from any In-Sight system can only be saved to disk on In-Sight PC Host systems or other, non-In-Sight FTP servers on the network.

When an image is loaded to an In-Sight sensor, it becomes the current image (image.bmp), irrespective of the chosen filename; In-Sight sensors do not support image files with arbitrary names.

This overload is only available in .NET applications.

Exceptions

Exception | Condition
System..::..ArgumentNullException | data is null.
System..::..ArgumentException | remoteFilename is not valid.
Cognex.InSight..::..CvsNotConnectedException | Connected is false.
Cognex.InSight..::..CvsFileOperationFailedException | The file cannot be saved on the In-Sight.
Cognex.InSight..::..CvsNetworkException | Could not find an acceptable IP address to perform the file transfer or some other network error occurred.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
SendFileToInSight Overload
Cognex.InSight.Ftp Namespace


CvsFtpClient.SendFileToInSight Method (String, String)

[image]

In-Sight SDK
CvsFtpClient..::..SendFileToInSight Method (String, String)
CvsFtpClient Class See Also Send Feedback
Sends a file to the In-Sight sensor.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SendFileToInSight(
    string localFilename,
    string remoteFilename
)
Visual Basic
Public Sub SendFileToInSight (
    localFilename As String,
    remoteFilename As String
)

Parameters

localFilename
Type: System..::..String
The fully qualified filename of the local file.
remoteFilename
Type: System..::..String
The file name on the In-Sight sensor.

Remarks

remoteFilename must be valid to be saved on the In-Sight sensor. IsValidFilename(String) may be used to validate the characters that comprise the filename. Some file extensions, however, are not valid to be saved to an In-Sight sensor.

An In-Sight image file (*.BMP or *.JPG) may be loaded by any In-Sight system for use in Offline spreadsheet job testing and configuration. However, because In-Sight sensors can store only one image, images from any In-Sight system can only be saved to disk on In-Sight PC Host systems or other, non-In-Sight FTP servers on the network.

When an image is loaded to an In-Sight sensor, it becomes the current image (image.bmp), irrespective of the chosen filename; In-Sight sensors do not support image files with arbitrary names.

Exceptions

Exception | Condition
System..::..ArgumentException | remoteFilename is not valid.
Cognex.InSight..::..CvsNotConnectedException | Connected is false.
System.IO..::..FileNotFoundException | The local file was not found.
Cognex.InSight..::..CvsFileOperationFailedException | The file cannot be saved on the In-Sight.
Cognex.InSight..::..CvsNetworkException | Could not find an acceptable IP address to perform the file transfer or some other network error occurred.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
SendFileToInSight Overload
Cognex.InSight.Ftp Namespace


CvsFtpClient Properties

[image] [image]

In-Sight SDK
CvsFtpClient Properties
CvsFtpClient Class See Also Send Feedback

The CvsFtpClient type exposes the following members.

Properties

 | Name | Description
Public property | Connected | Gets a value indicating whether a client is connected to a remote host.
Public property | Encoding | Gets the encoding used to read and write from the FTP socket.
Public property | LastResponse | Gets the last response returned from the server.
Public property | Password | Gets the password associated with the user name for the connection.
Public property | Port | Gets the port used for the connection to an In-Sight sensor.
Public property | RemoteIPAddress | Gets the IP Address of the In-Sight sensor used for the connection.
Public property | RemoteIPAddressString | Gets the IP Address of the In-Sight sensor used for the connection.
Public property | Timeout | Gets or sets the timeout (ms) used for sending or receiving data.
Public property | UsePasswordEncryption | Gets or sets the value indicating whether to use advanced encryption when sending the password to the host.
Public property | Username | Gets the user name for the connection.
Public property | WelcomeBanner | Gets the first line of the Welcome Banner returned from the server.

See Also

CvsFtpClient Class
Cognex.InSight.Ftp Namespace


CvsFtpClient.Connected Property

[image]

In-Sight SDK
CvsFtpClient..::..Connected Property
CvsFtpClient Class See Also Send Feedback
Gets a value indicating whether a client is connected to a remote host.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Connected { get; }
Visual Basic
Public ReadOnly Property Connected As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.Encoding Property

[image]

In-Sight SDK
CvsFtpClient..::..Encoding Property
CvsFtpClient Class See Also Send Feedback
Gets the encoding used to read and write from the FTP socket.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Encoding Encoding { get; }
Visual Basic
Public ReadOnly Property Encoding As Encoding
    Get

Property Value

Type: Encoding

Remarks

This property is only available in .NET applications.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.LastResponse Property

[image]

In-Sight SDK
CvsFtpClient..::..LastResponse Property
CvsFtpClient Class See Also Send Feedback
Gets the last response returned from the server.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string LastResponse { get; }
Visual Basic
Public ReadOnly Property LastResponse As String
    Get

Property Value

Type: String

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.Password Property

[image]

In-Sight SDK
CvsFtpClient..::..Password Property
CvsFtpClient Class See Also Send Feedback
Gets the password associated with the user name for the connection.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Password { get; }
Visual Basic
Public ReadOnly Property Password As String
    Get

Property Value

Type: String

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.Port Property

[image]

In-Sight SDK
CvsFtpClient..::..Port Property
CvsFtpClient Class See Also Send Feedback
Gets the port used for the connection to an In-Sight sensor.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Port { get; }
Visual Basic
Public ReadOnly Property Port As Integer
    Get

Property Value

Type: Int32

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.RemoteIPAddress Property

[image]

In-Sight SDK
CvsFtpClient..::..RemoteIPAddress Property
CvsFtpClient Class See Also Send Feedback
Gets the IP Address of the In-Sight sensor used for the connection.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress RemoteIPAddress { get; }
Visual Basic
Public ReadOnly Property RemoteIPAddress As IPAddress
    Get

Property Value

Type: IPAddress

Remarks

This property is only available in .NET applications. To obtain an an IP address for use in COM/ActiveX applications, use the RemoteIPAddressString property instead.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.RemoteIPAddressString Property

[image]

In-Sight SDK
CvsFtpClient..::..RemoteIPAddressString Property
CvsFtpClient Class See Also Send Feedback
Gets the IP Address of the In-Sight sensor used for the connection.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string RemoteIPAddressString { get; }
Visual Basic
Public ReadOnly Property RemoteIPAddressString As String
    Get

Property Value

Type: String

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.Timeout Property

[image]

In-Sight SDK
CvsFtpClient..::..Timeout Property
CvsFtpClient Class See Also Send Feedback
Gets or sets the timeout (ms) used for sending or receiving data.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Timeout { get; set; }
Visual Basic
Public Property Timeout As Integer
    Get
    Set

Property Value

Type: Int32
The default value is 10000.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is less than or equal to zero.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.UsePasswordEncryption Property

[image]

In-Sight SDK
CvsFtpClient..::..UsePasswordEncryption Property
CvsFtpClient Class See Also Send Feedback
Gets or sets the value indicating whether to use advanced encryption when sending the password to the host.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool UsePasswordEncryption { get; set; }
Visual Basic
Public Property UsePasswordEncryption As Boolean
    Get
    Set

Property Value

Type: Boolean
The default value is false.

Remarks

To use this feature, advanced password encryption must be supported on the host. Attempting to use advanced encryption with a host that does not support advanced password encryption will result in a bad password notification. In-Sight firmware versions 4.8.0 and above support advanced password encryption.

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.Username Property

[image]

In-Sight SDK
CvsFtpClient..::..Username Property
CvsFtpClient Class See Also Send Feedback
Gets the user name for the connection.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Username { get; }
Visual Basic
Public ReadOnly Property Username As String
    Get

Property Value

Type: String

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


CvsFtpClient.WelcomeBanner Property

[image]

In-Sight SDK
CvsFtpClient..::..WelcomeBanner Property
CvsFtpClient Class See Also Send Feedback
Gets the first line of the Welcome Banner returned from the server.

Namespace: Cognex.InSight.Ftp
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string WelcomeBanner { get; }
Visual Basic
Public ReadOnly Property WelcomeBanner As String
    Get

Property Value

Type: String

See Also

CvsFtpClient Class
CvsFtpClient..::..CvsFtpClient Members
Cognex.InSight.Ftp Namespace


Cognex.InSight.Graphic Namespace

[image]

In-Sight SDK
Cognex.InSight.Graphic Namespace
Send Feedback
The Cognex.InSight.Graphic namespace provides the classes for accessing the graphics associated with a set of results.

Classes

 | Class | Description
Public class | CvsCompositeSubregion | A CompositeRegion structure is defined as an ordered collection of CvsCompositeSubregion objects. Each subregion contains shape information plus the operation used to generate the overall inspection area for the CompositeRegion.
Public class | CvsGraphic | An abstract base class used to define CvsGraphic objects.
Public class | CvsGraphic4Side | Encapsulates the data associated with an In-Sight four-sided graphic.
Public class | CvsGraphicAnnulus | Encapsulates the data associated with an In-Sight Annulus graphic.
Public class | CvsGraphicArc | Encapsulates the data associated with an In-Sight arc graphic.
Public class | CvsGraphicArrows | Encapsulates the data associated with an In-Sight arrow graphic.
Public class | CvsGraphicBeadPath | Encapsulates the data associated with an In-Sight Bead graphic.
Public class | CvsGraphicBeadPath..::..Vertex | A point along the bead path.
Public class | CvsGraphicBlob | Encapsulates the data associated with an In-Sight blob graphic, a chain of points that represent a single blob.
Public class | CvsGraphicBlobProperties | Encapsulates the data associated with an In-Sight blob properties graphic.
Public class | CvsGraphicCircle | Encapsulates the data associated with an In-Sight circle graphic.
Public class | CvsGraphicCollection | Represents a collection of CvsGraphic objects.
Public class | CvsGraphicColorSampleList | Encapsulates the data associated with list of In-Sight color sample points.
Public class | CvsGraphicComposite | Encapsulates the data associated with an In-Sight CompositeRegion graphic.
Public class | CvsGraphicCompositeBase | Encapsulates the data associated with an In-Sight CompositeRegion graphic.
Public class | CvsGraphicCross | Encapsulates the data associated with an In-Sight cross graphic.
Public class | CvsGraphicDefectPoints | Encapsulates the data associated with an In-Sight polyline graphic.
Public class | CvsGraphicEdgePoints | Encapsulates the data associated with an In-Sight edge points graphic.
Public class | CvsGraphicEdgeProfile | Encapsulates the data associated with an In-Sight edge profile graphic.
Public class | CvsGraphicExtremePoints | Encapsulates the data associated with an In-Sight polyline graphic.
Public class | CvsGraphicFilledBox | Encapsulates the data associated with an In-Sight filled box graphic.
Public class | CvsGraphicFixture | Encapsulates the data associated with an In-Sight fixture graphic.
Public class | CvsGraphicHistogram | Encapsulates the data associated with an In-Sight graphical histogram.
Public class | CvsGraphicImage | Encapsulates the data associated with an In-Sight Image graphic
Public class | CvsGraphicLine | Encapsulates the data associated with an In-Sight line graphic.
Public class | CvsGraphicMaskedRegion | Encapsulates the data associated with an In-Sight CompositeRegion graphic.
Public class | CvsGraphicOffset | Encapsulates the data associated with an In-Sight offset graphic.
Public class | CvsGraphicParallelogram | Encapsulates the data associated with an In-Sight parallelogram graphic.
Public class | CvsGraphicPatternMatch | Encapsulates the data associated with an In-Sight pattern match graphic.
Public class | CvsGraphicPoint | Encapsulates the data associated with an In-Sight point graphic.
Public class | CvsGraphicPolygon | Encapsulates the data associated with an In-Sight Polygon graphic.
Public class | CvsGraphicPolyline | Encapsulates the data associated with an In-Sight polyline graphic.
Public class | CvsGraphicPolylinePath | Encapsulates the data associated with an In-Sight CompositeRegion graphic.
Public class | CvsGraphicRegion | Encapsulates the data associated with an In-Sight region graphic.
Public class | CvsGraphicText | Encapsulates the data associated with an In-Sight text graphic.
Public class | CvsPatternMatchSegment | Defines a single colored segment for a CvsGraphicPatternMatch graphic.

Structures

 | Structure | Description
Public structure | CvsGraphicArrows..::..Arrow | Arrow structure containing the location and angle.
Public structure | CvsGraphicBlobPoint | Represents a single point in the chain graphic
Public structure | CvsGraphicColorSampleList..::..ColorSample | Color sample point data.

Interfaces

 | Interface | Description
Public interface | ICvsEditableGraphic | CvsGraphic classes that implement the ICvsEditableGraphic interface may be edited by the In-Sight display control.

Enumerations

 | Enumeration | Description
Public enumeration | CvsCompositeOperation | The operation determines if a subregion will be included or excluded from the overall inspection area.
Public enumeration | CvsCompositeShapeType | Describes the shape used to define the subregion.
Public enumeration | CvsDisplayable4SideStyle | An enumeration of drawing styles for the matrix.
Public enumeration | CvsEditFlags | Defines the edit flags for a graphic.
Public enumeration | CvsGraphicBeadPath..::..CaliperInspectionFlags | The CaliperInspectionFlags defines inspection options for an edge on a trained BeadPath polyline.
Public enumeration | CvsGraphicBlobDirection | The direction values for the CvsGraphicBlobPoint structure.
Public enumeration | CvsGraphicLineAdornment | Adornments that may be rendered for the endpoints of the line.


CvsCompositeOperation Enumeration

[image]

In-Sight SDK
CvsCompositeOperation Enumeration
See Also Send Feedback
The operation determines if a subregion will be included or excluded from the overall inspection area.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsCompositeOperation
Visual Basic
Public Enumeration CvsCompositeOperation

Members

Member name | Value | Description
Invalid | -1 | Operation not set
Subtract | 0 | The subregion will be subtracted from the inspection area.
Add | 1 | The subregion will be added to the inspection area.

See Also

Cognex.InSight.Graphic Namespace


CvsCompositeShapeType Enumeration

[image]

In-Sight SDK
CvsCompositeShapeType Enumeration
See Also Send Feedback
Describes the shape used to define the subregion.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsCompositeShapeType
Visual Basic
Public Enumeration CvsCompositeShapeType

Members

Member name | Value | Description
None | 0 | No shape defined. This subregion will have no effect on the overall inspection area.
RegionType | 1 | A subregion based on the Region structure.
PolygonType | 2 | A subregion based on the Polygon structure.
CircleType | 3 | A subregion based on the Circle structure.
AnnulusType | 4 | A subregion based on the Annulus structure.

See Also

Cognex.InSight.Graphic Namespace


CvsCompositeSubregion Class

[image]

In-Sight SDK
CvsCompositeSubregion Class
Members See Also Send Feedback
A CompositeRegion structure is defined as an ordered collection of CvsCompositeSubregion objects. Each subregion contains shape information plus the operation used to generate the overall inspection area for the CompositeRegion.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public class CvsCompositeSubregion
Visual Basic
Public Class CvsCompositeSubregion

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsCompositeSubregion

See Also

CvsCompositeSubregion..::..CvsCompositeSubregion Members
Cognex.InSight.Graphic Namespace


CvsCompositeSubregion Members

[image] [image]

In-Sight SDK
CvsCompositeSubregion Members
CvsCompositeSubregion Class Constructors Methods Properties See Also Send Feedback

The CvsCompositeSubregion type exposes the following members.

Constructors

 | Name | Description
Public method | CvsCompositeSubregion(CvsCompositeSubregion) | Create a copy of the given CvsCompositeSubregion object.
Public method | CvsCompositeSubregion(CvsGraphicAnnulus, CvsCompositeOperation) | Creates a subregion based on a CvsGraphicAnnulus object.
Public method | CvsCompositeSubregion(CvsGraphicCircle, CvsCompositeOperation) | Creates a subregion based on a CvsGraphicCircle object.
Public method | CvsCompositeSubregion(CvsGraphicPolygon, CvsCompositeOperation) | Creates a subregion based on a CvsGraphicPolygon object.
Public method | CvsCompositeSubregion(CvsGraphicRegion, CvsCompositeOperation) | Creates a subregion based on a CvsGraphicRegion object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EditableGraphic | Gets a reference to a ICvsEditableGraphic object that defines the subregion's shape.
Public property | InSightGraphic | Gets a reference to the CvsGraphic object that defines the subregion's shape.
Public property | Operation | Gets or sets the CompositeOperation for the subregion.
Public property | ShapeType | Gets the ShapeType of the subregion's shape.

See Also

CvsCompositeSubregion Class
Cognex.InSight.Graphic Namespace


CvsCompositeSubregion Constructor

[image] [image]

In-Sight SDK
CvsCompositeSubregion Constructor
CvsCompositeSubregion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsCompositeSubregion(CvsCompositeSubregion) | Create a copy of the given CvsCompositeSubregion object.
Public method | CvsCompositeSubregion(CvsGraphicAnnulus, CvsCompositeOperation) | Creates a subregion based on a CvsGraphicAnnulus object.
Public method | CvsCompositeSubregion(CvsGraphicCircle, CvsCompositeOperation) | Creates a subregion based on a CvsGraphicCircle object.
Public method | CvsCompositeSubregion(CvsGraphicPolygon, CvsCompositeOperation) | Creates a subregion based on a CvsGraphicPolygon object.
Public method | CvsCompositeSubregion(CvsGraphicRegion, CvsCompositeOperation) | Creates a subregion based on a CvsGraphicRegion object.

See Also

CvsCompositeSubregion Class
CvsCompositeSubregion..::..CvsCompositeSubregion Members
Cognex.InSight.Graphic Namespace


CvsCompositeSubregion Constructor (CvsCompositeSubregion)

[image]

In-Sight SDK
CvsCompositeSubregion Constructor (CvsCompositeSubregion)
CvsCompositeSubregion Class See Also Send Feedback
Create a copy of the given CvsCompositeSubregion object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeSubregion(
    CvsCompositeSubregion src
)
Visual Basic
Public Sub New (
    src As CvsCompositeSubregion
)

Parameters

src
Type: Cognex.InSight.Graphic..::..CvsCompositeSubregion
The instance to copy.

See Also

CvsCompositeSubregion Class
CvsCompositeSubregion..::..CvsCompositeSubregion Members
CvsCompositeSubregion Overload
Cognex.InSight.Graphic Namespace


CvsCompositeSubregion Constructor (CvsGraphicAnnulus, CvsCompositeOperation)

[image]

In-Sight SDK
CvsCompositeSubregion Constructor (CvsGraphicAnnulus, CvsCompositeOperation)
CvsCompositeSubregion Class See Also Send Feedback
Creates a subregion based on a CvsGraphicAnnulus object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeSubregion(
    CvsGraphicAnnulus annulus,
    CvsCompositeOperation operation
)
Visual Basic
Public Sub New (
    annulus As CvsGraphicAnnulus,
    operation As CvsCompositeOperation
)

Parameters

annulus
Type: Cognex.InSight.Graphic..::..CvsGraphicAnnulus
The subregion.
operation
Type: Cognex.InSight.Graphic..::..CvsCompositeOperation
The operation that defines how to use the subregion.

See Also

CvsCompositeSubregion Class
CvsCompositeSubregion..::..CvsCompositeSubregion Members
CvsCompositeSubregion Overload
Cognex.InSight.Graphic Namespace


CvsCompositeSubregion Constructor (CvsGraphicCircle, CvsCompositeOperation)

[image]

In-Sight SDK
CvsCompositeSubregion Constructor (CvsGraphicCircle, CvsCompositeOperation)
CvsCompositeSubregion Class See Also Send Feedback
Creates a subregion based on a CvsGraphicCircle object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeSubregion(
    CvsGraphicCircle circle,
    CvsCompositeOperation operation
)
Visual Basic
Public Sub New (
    circle As CvsGraphicCircle,
    operation As CvsCompositeOperation
)

Parameters

circle
Type: Cognex.InSight.Graphic..::..CvsGraphicCircle
The subregion.
operation
Type: Cognex.InSight.Graphic..::..CvsCompositeOperation
The operation that defines how to use the subregion.

See Also

CvsCompositeSubregion Class
CvsCompositeSubregion..::..CvsCompositeSubregion Members
CvsCompositeSubregion Overload
Cognex.InSight.Graphic Namespace


CvsCompositeSubregion Constructor (CvsGraphicPolygon, CvsCompositeOperation)

[image]

In-Sight SDK
CvsCompositeSubregion Constructor (CvsGraphicPolygon, CvsCompositeOperation)
CvsCompositeSubregion Class See Also Send Feedback
Creates a subregion based on a CvsGraphicPolygon object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeSubregion(
    CvsGraphicPolygon polygon,
    CvsCompositeOperation operation
)
Visual Basic
Public Sub New (
    polygon As CvsGraphicPolygon,
    operation As CvsCompositeOperation
)

Parameters

polygon
Type: Cognex.InSight.Graphic..::..CvsGraphicPolygon
The subregion.
operation
Type: Cognex.InSight.Graphic..::..CvsCompositeOperation
The operation that defines how to use the subregion.

See Also

CvsCompositeSubregion Class
CvsCompositeSubregion..::..CvsCompositeSubregion Members
CvsCompositeSubregion Overload
Cognex.InSight.Graphic Namespace


CvsCompositeSubregion Constructor (CvsGraphicRegion, CvsCompositeOperation)

[image]

In-Sight SDK
CvsCompositeSubregion Constructor (CvsGraphicRegion, CvsCompositeOperation)
CvsCompositeSubregion Class See Also Send Feedback
Creates a subregion based on a CvsGraphicRegion object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeSubregion(
    CvsGraphicRegion region,
    CvsCompositeOperation operation
)
Visual Basic
Public Sub New (
    region As CvsGraphicRegion,
    operation As CvsCompositeOperation
)

Parameters

region
Type: Cognex.InSight.Graphic..::..CvsGraphicRegion
The subregion.
operation
Type: Cognex.InSight.Graphic..::..CvsCompositeOperation
The operation that defines how to use the subregion.

See Also

CvsCompositeSubregion Class
CvsCompositeSubregion..::..CvsCompositeSubregion Members
CvsCompositeSubregion Overload
Cognex.InSight.Graphic Namespace


CvsCompositeSubregion Methods

[image] [image]

In-Sight SDK
CvsCompositeSubregion Methods
CvsCompositeSubregion Class See Also Send Feedback

The CvsCompositeSubregion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsCompositeSubregion Class
Cognex.InSight.Graphic Namespace


CvsCompositeSubregion Properties

[image] [image]

In-Sight SDK
CvsCompositeSubregion Properties
CvsCompositeSubregion Class See Also Send Feedback

The CvsCompositeSubregion type exposes the following members.

Properties

 | Name | Description
Public property | EditableGraphic | Gets a reference to a ICvsEditableGraphic object that defines the subregion's shape.
Public property | InSightGraphic | Gets a reference to the CvsGraphic object that defines the subregion's shape.
Public property | Operation | Gets or sets the CompositeOperation for the subregion.
Public property | ShapeType | Gets the ShapeType of the subregion's shape.

See Also

CvsCompositeSubregion Class
Cognex.InSight.Graphic Namespace


CvsCompositeSubregion.EditableGraphic Property

[image]

In-Sight SDK
CvsCompositeSubregion..::..EditableGraphic Property
CvsCompositeSubregion Class See Also Send Feedback
Gets a reference to a ICvsEditableGraphic object that defines the subregion's shape.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public ICvsEditableGraphic EditableGraphic { get; }
Visual Basic
Public ReadOnly Property EditableGraphic As ICvsEditableGraphic
    Get

Property Value

Type: ICvsEditableGraphic

See Also

CvsCompositeSubregion Class
CvsCompositeSubregion..::..CvsCompositeSubregion Members
Cognex.InSight.Graphic Namespace


CvsCompositeSubregion.InSightGraphic Property

[image]

In-Sight SDK
CvsCompositeSubregion..::..InSightGraphic Property
CvsCompositeSubregion Class See Also Send Feedback
Gets a reference to the CvsGraphic object that defines the subregion's shape.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphic InSightGraphic { get; }
Visual Basic
Public ReadOnly Property InSightGraphic As CvsGraphic
    Get

Property Value

Type: CvsGraphic

See Also

CvsCompositeSubregion Class
CvsCompositeSubregion..::..CvsCompositeSubregion Members
Cognex.InSight.Graphic Namespace


CvsCompositeSubregion.Operation Property

[image]

In-Sight SDK
CvsCompositeSubregion..::..Operation Property
CvsCompositeSubregion Class See Also Send Feedback
Gets or sets the CompositeOperation for the subregion.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeOperation Operation { get; set; }
Visual Basic
Public Property Operation As CvsCompositeOperation
    Get
    Set

Property Value

Type: CvsCompositeOperation

See Also

CvsCompositeSubregion Class
CvsCompositeSubregion..::..CvsCompositeSubregion Members
Cognex.InSight.Graphic Namespace


CvsCompositeSubregion.ShapeType Property

[image]

In-Sight SDK
CvsCompositeSubregion..::..ShapeType Property
CvsCompositeSubregion Class See Also Send Feedback
Gets the ShapeType of the subregion's shape.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeShapeType ShapeType { get; }
Visual Basic
Public ReadOnly Property ShapeType As CvsCompositeShapeType
    Get

Property Value

Type: CvsCompositeShapeType

See Also

CvsCompositeSubregion Class
CvsCompositeSubregion..::..CvsCompositeSubregion Members
Cognex.InSight.Graphic Namespace


CvsDisplayable4SideStyle Enumeration

[image]

In-Sight SDK
CvsDisplayable4SideStyle Enumeration
See Also Send Feedback
An enumeration of drawing styles for the matrix.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsDisplayable4SideStyle
Visual Basic
Public Enumeration CvsDisplayable4SideStyle

Members

Member name | Value | Description
DataMatrix | 0 | Draws the matrix with 2 solid lines and 2 dashed lines.
SolidLines | 1 | Draws the matrix with 4 solid lines.

See Also

Cognex.InSight.Graphic Namespace


CvsEditFlags Enumeration

[image]

In-Sight SDK
CvsEditFlags Enumeration
See Also Send Feedback
Defines the edit flags for a graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
[FlagsAttribute]
public enum CvsEditFlags
Visual Basic
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration CvsEditFlags

Members

Member name | Value | Description
None | 0 | Specifies a non-editable graphic.
Location | 1 | Specifies a graphic with an adjustable location.
Size | 2 | Specifies a graphic with an adjustable size.
Point0 | 1 | Specifies a graphic with an adjustable 1st point.
Point1 | 2 | Specifies a graphic with an adjustable 2nd point.
Rotation | 4 | Specifies a graphic with an adjustable angle of rotation.
Bend | 8 | Specifies a graphic with an adjustable curve.
AddItem | 64 | Specifies a graphic supports the addition of new items.
DeleteItem | 32 | Specifies a graphic supports the removal of items.
EditItem | 256 | Specifies a graphic supports the moving or sizing of items.
Corner0 | 8 | Specifies a graphic with an adjustable first corner.
Corner1 | 16 | Specifies a graphic with an adjustable second corner.
Corner2 | 32 | Specifies a graphic with an adjustable third corner.
Corner3 | 64 | Specifies a graphic with an adjustable fourth corner.
Skew | 8 | Specifies a graphic with adjustable skew.
MaskArea | 512 | Specifies a graphic with adjustable mask areas.
FillEdgeArea | 1024 | Specifies a graphic with adjustable fill missing edge areas.
All | 2047 | The bitwise OR of all edit flags

Remarks

The edit flags determine what aspects of a graphic may be edited.

See Also

Cognex.InSight.Graphic Namespace


CvsGraphic Class

[image]

In-Sight SDK
CvsGraphic Class
Members See Also Send Feedback
An abstract base class used to define CvsGraphic objects.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public abstract class CvsGraphic : ICloneable
Visual Basic
<SerializableAttribute>
Public MustInherit Class CvsGraphic
    Implements ICloneable

Remarks

CvsGraphic objects are returned as items in a CvsGraphicCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphic4Side
Cognex.InSight.Graphic..::..CvsGraphicAnnulus
Cognex.InSight.Graphic..::..CvsGraphicArc
Cognex.InSight.Graphic..::..CvsGraphicArrows
Cognex.InSight.Graphic..::..CvsGraphicBeadPath
Cognex.InSight.Graphic..::..CvsGraphicBlob
Cognex.InSight.Graphic..::..CvsGraphicCircle
Cognex.InSight.Graphic..::..CvsGraphicColorSampleList
Cognex.InSight.Graphic..::..CvsGraphicCompositeBase
Cognex.InSight.Graphic..::..CvsGraphicCross
Cognex.InSight.Graphic..::..CvsGraphicDefectPoints
Cognex.InSight.Graphic..::..CvsGraphicEdgePoints
Cognex.InSight.Graphic..::..CvsGraphicEdgeProfile
Cognex.InSight.Graphic..::..CvsGraphicExtremePoints
Cognex.InSight.Graphic..::..CvsGraphicFilledBox
Cognex.InSight.Graphic..::..CvsGraphicFixture
Cognex.InSight.Graphic..::..CvsGraphicHistogram
Cognex.InSight.Graphic..::..CvsGraphicImage
Cognex.InSight.Graphic..::..CvsGraphicLine
Cognex.InSight.Graphic..::..CvsGraphicOffset
Cognex.InSight.Graphic..::..CvsGraphicParallelogram
Cognex.InSight.Graphic..::..CvsGraphicPatternMatch
Cognex.InSight.Graphic..::..CvsGraphicPoint
Cognex.InSight.Graphic..::..CvsGraphicPolygon
Cognex.InSight.Graphic..::..CvsGraphicPolyline
Cognex.InSight.Graphic..::..CvsGraphicRegion
Cognex.InSight.Graphic..::..CvsGraphicText

See Also

CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic Members

[image] [image]

In-Sight SDK
CvsGraphic Members
CvsGraphic Class Methods Properties Events See Also Send Feedback

The CvsGraphic type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); }
Protected method | CheckCopy<(Of <<'(TDerived>)>>) | Throws an InvalidOperationException if the graphic is locked
Public method | Clone | Clone this CvsGraphic object.
Protected method | CopyFrom(CvsGraphic) | Copies member from the source graphic to this graphic.
Protected method | CopyFrom(ICvsEditableGraphic) | Copies member from the source graphic to this graphic.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Fires the PropertyChanged event.
Public method | ToString | Returns a string that identifies this graphic. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated.
Public property | Color | Gets or sets the foreground color of the graphic.
Protected property | Flags | Gets the flags for the graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted.
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value.
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected.
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it.
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed.
Public property | Label | Gets the text label associated with the graphic.
Public property | TransparentColor | Gets or sets the transparent color of the graphic.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set.

See Also

CvsGraphic Class
Cognex.InSight.Graphic Namespace


CvsGraphic Methods

[image] [image]

In-Sight SDK
CvsGraphic Methods
CvsGraphic Class See Also Send Feedback

The CvsGraphic type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); }
Protected method | CheckCopy<(Of <<'(TDerived>)>>) | Throws an InvalidOperationException if the graphic is locked
Public method | Clone | Clone this CvsGraphic object.
Protected method | CopyFrom(CvsGraphic) | Copies member from the source graphic to this graphic.
Protected method | CopyFrom(ICvsEditableGraphic) | Copies member from the source graphic to this graphic.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Fires the PropertyChanged event.
Public method | ToString | Returns a string that identifies this graphic. (Overrides Object..::..ToString()()()().)

See Also

CvsGraphic Class
Cognex.InSight.Graphic Namespace


CvsGraphic.AddPropertyChangedHandler Method

[image]

In-Sight SDK
CvsGraphic..::..AddPropertyChangedHandler Method
CvsGraphic Class See Also Send Feedback
Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller.

Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged  with:

private readonly PropertyChangedEventHandler mGraphicChangedHandler;
CvsDisplayableFoo(CvsGraphicFoo graphic)
{
  mGraphic = graphic;
  mGraphicChangedHandler = CvsGraphic_PropertyChanged;
  mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler);
}

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void AddPropertyChangedHandler(
    PropertyChangedEventHandler handler
)
Visual Basic
Public Sub AddPropertyChangedHandler (
    handler As PropertyChangedEventHandler
)

Parameters

handler
Type: System.ComponentModel..::..PropertyChangedEventHandler

[Missing <param name="handler"/> documentation for "M:Cognex.InSight.Graphic.CvsGraphic.AddPropertyChangedHandler(System.ComponentModel.PropertyChangedEventHandler)"]

Remarks

Use this rather than the PropertyChanged event when it is not possible to deterministically unsubscribe from the event.

The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller.

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.CheckCopy(TDerived) Method

[image]

In-Sight SDK
CvsGraphic..::..CheckCopy<(Of <(<'TDerived>)>)> Method
CvsGraphic Class See Also Send Feedback
Throws an InvalidOperationException if the graphic is locked

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
protected TDerived CheckCopy<TDerived>(
    ICvsEditableGraphic source
)
where TDerived : CvsGraphic
Visual Basic
Protected Function CheckCopy(Of TDerived As CvsGraphic) (
    source As ICvsEditableGraphic
) As TDerived

Parameters

source
Type: Cognex.InSight.Graphic..::..ICvsEditableGraphic

[Missing <param name="source"/> documentation for "M:Cognex.InSight.Graphic.CvsGraphic.CheckCopy``1(Cognex.InSight.Graphic.ICvsEditableGraphic)"]

Type Parameters

TDerived

[Missing <typeparam name="TDerived"/> documentation for "M:Cognex.InSight.Graphic.CvsGraphic.CheckCopy``1(Cognex.InSight.Graphic.ICvsEditableGraphic)"]

Return Value

Type: TDerived

[Missing <returns> documentation for "M:Cognex.InSight.Graphic.CvsGraphic.CheckCopy``1(Cognex.InSight.Graphic.ICvsEditableGraphic)"]

Exceptions

Exception | Condition
System..::..InvalidOperationException | The source graphic is not of the same type as this graphic.
System..::..InvalidOperationException | If the IsLocked property is true for this graphic.

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.Clone Method

[image]

In-Sight SDK
CvsGraphic..::..Clone Method
CvsGraphic Class See Also Send Feedback
Clone this CvsGraphic object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphic Clone()
Visual Basic
Public Function Clone As CvsGraphic

Return Value

Type: CvsGraphic
A new object that is a copy of this instance.

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.CopyFrom Method

[image] [image]

In-Sight SDK
CvsGraphic..::..CopyFrom Method
CvsGraphic Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | CopyFrom(CvsGraphic) | Copies member from the source graphic to this graphic.
Protected method | CopyFrom(ICvsEditableGraphic) | Copies member from the source graphic to this graphic.

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.CopyFrom Method (CvsGraphic)

[image]

In-Sight SDK
CvsGraphic..::..CopyFrom Method (CvsGraphic)
CvsGraphic Class See Also Send Feedback
Copies member from the source graphic to this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
protected void CopyFrom(
    CvsGraphic source
)
Visual Basic
Protected Sub CopyFrom (
    source As CvsGraphic
)

Parameters

source
Type: Cognex.InSight.Graphic..::..CvsGraphic

[Missing <param name="source"/> documentation for "M:Cognex.InSight.Graphic.CvsGraphic.CopyFrom(Cognex.InSight.Graphic.CvsGraphic)"]

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
CopyFrom Overload
Cognex.InSight.Graphic Namespace


CvsGraphic.CopyFrom Method (ICvsEditableGraphic)

[image]

In-Sight SDK
CvsGraphic..::..CopyFrom Method (ICvsEditableGraphic)
CvsGraphic Class See Also Send Feedback
Copies member from the source graphic to this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
protected void CopyFrom(
    ICvsEditableGraphic source
)
Visual Basic
Protected Sub CopyFrom (
    source As ICvsEditableGraphic
)

Parameters

source
Type: Cognex.InSight.Graphic..::..ICvsEditableGraphic
A CvsGraphic object that implements ICvsEditableGraphic.

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
CopyFrom Overload
Cognex.InSight.Graphic Namespace


CvsGraphic.GetHashCode Method

[image]

In-Sight SDK
CvsGraphic..::..GetHashCode Method
CvsGraphic Class See Also Send Feedback
Returns the hash code for this instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A 32-bit signed integer that is the hash code for this instance.

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.OnPropertyChanged Method

[image]

In-Sight SDK
CvsGraphic..::..OnPropertyChanged Method
CvsGraphic Class See Also Send Feedback
Fires the PropertyChanged event.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: System..::..String
The name of the changed property, or null if multiple properties have changed.

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.ToString Method

[image]

In-Sight SDK
CvsGraphic..::..ToString Method
CvsGraphic Class See Also Send Feedback
Returns a string that identifies this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic Properties

[image] [image]

In-Sight SDK
CvsGraphic Properties
CvsGraphic Class See Also Send Feedback

The CvsGraphic type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated.
Public property | Color | Gets or sets the foreground color of the graphic.
Protected property | Flags | Gets the flags for the graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted.
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value.
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected.
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it.
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed.
Public property | Label | Gets the text label associated with the graphic.
Public property | TransparentColor | Gets or sets the transparent color of the graphic.

See Also

CvsGraphic Class
Cognex.InSight.Graphic Namespace


CvsGraphic.CellLocation Property

[image]

In-Sight SDK
CvsGraphic..::..CellLocation Property
CvsGraphic Class See Also Send Feedback
Gets the cell location with which the graphic is associated.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellLocation CellLocation { get; }
Visual Basic
Public ReadOnly Property CellLocation As CvsCellLocation
    Get

Property Value

Type: CvsCellLocation

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.Color Property

[image]

In-Sight SDK
CvsGraphic..::..Color Property
CvsGraphic Class See Also Send Feedback
Gets or sets the foreground color of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.Flags Property

[image]

In-Sight SDK
CvsGraphic..::..Flags Property
CvsGraphic Class See Also Send Feedback
Gets the flags for the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
protected int Flags { get; }
Visual Basic
Protected ReadOnly Property Flags As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.HighlightColor Property

[image]

In-Sight SDK
CvsGraphic..::..HighlightColor Property
CvsGraphic Class See Also Send Feedback
Gets the foreground color of the graphic to be used when the graphic in highlighted.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color HighlightColor { get; }
Visual Basic
Public ReadOnly Property HighlightColor As Color
    Get

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.HighlightColorAsRgb Property

[image]

In-Sight SDK
CvsGraphic..::..HighlightColorAsRgb Property
CvsGraphic Class See Also Send Feedback
Gets the HighlightColor as an RGB value.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int HighlightColorAsRgb { get; }
Visual Basic
Public ReadOnly Property HighlightColorAsRgb As Integer
    Get

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.IsAlwaysShown Property

[image]

In-Sight SDK
CvsGraphic..::..IsAlwaysShown Property
CvsGraphic Class See Also Send Feedback
Gets a value that indicates whether or not the current graphic should always be shown.

If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsAlwaysShown { get; }
Visual Basic
Public ReadOnly Property IsAlwaysShown As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.IsDefaultEdit Property

[image]

In-Sight SDK
CvsGraphic..::..IsDefaultEdit Property
CvsGraphic Class See Also Send Feedback
Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsDefaultEdit { get; }
Visual Basic
Public ReadOnly Property IsDefaultEdit As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.IsLocked Property

[image]

In-Sight SDK
CvsGraphic..::..IsLocked Property
CvsGraphic Class See Also Send Feedback
Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsLocked { get; }
Visual Basic
Public ReadOnly Property IsLocked As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.Label Property

[image]

In-Sight SDK
CvsGraphic..::..Label Property
CvsGraphic Class See Also Send Feedback
Gets the text label associated with the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Label { get; set; }
Visual Basic
Public Property Label As String
    Get
    Set

Property Value

Type: String

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic.TransparentColor Property

[image]

In-Sight SDK
CvsGraphic..::..TransparentColor Property
CvsGraphic Class See Also Send Feedback
Gets or sets the transparent color of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color TransparentColor { get; set; }
Visual Basic
Public Property TransparentColor As Color
    Get
    Set

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic Events

[image] [image]

In-Sight SDK
CvsGraphic Events
CvsGraphic Class See Also Send Feedback

The CvsGraphic type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set.

See Also

CvsGraphic Class
Cognex.InSight.Graphic Namespace


CvsGraphic.PropertyChanged Event

[image]

In-Sight SDK
CvsGraphic..::..PropertyChanged Event
CvsGraphic Class See Also Send Feedback
This event is raised every time a settable property of the graphic is set.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModel..::..PropertyChangedEventHandler

See Also

CvsGraphic Class
CvsGraphic..::..CvsGraphic Members
Cognex.InSight.Graphic Namespace


CvsGraphic4Side Class

[image]

In-Sight SDK
CvsGraphic4Side Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight four-sided graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphic4Side : CvsGraphic,
    ICvsEditableGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphic4Side
    Inherits CvsGraphic
    Implements ICvsEditableGraphic

Remarks

This graphic is a 4-sided quadrilateral. Its sides (r0, c0) - (r1, c1) and (r1,c1) - (r2,c2) are the clock track sides and the other two sides are the Finder Pattern sides.

CvsGraphic4Side objects are returned as items in a CvsGraphicCollection. They are generated by the ReadIDCode function.

A 4side is an editable graphic and may be edited by a control and returned to the In-Sight sensor.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphic4Side

See Also

CvsGraphic4Side..::..CvsGraphic4Side Members
Cognex.InSight.Graphic Namespace


CvsGraphic4Side Members

[image] [image]

In-Sight SDK
CvsGraphic4Side Members
CvsGraphic4Side Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphic4Side type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphic4Side()()()() | Initializes a new instance of the CvsGraphic4Side class.
Public method | CvsGraphic4Side(CvsGraphic4Side) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphic4Side(CvsCellLocation, array<CvsImageLocation>[]()[][], String) | Initializes a new instance that is a copy of the specified instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Point0 | Gets or sets the location of the first point of the 4-side graphic. The coordinates are measured in pixels from the sides of the CvsImage.
Public property | Point1 | Gets or sets the location of the second point of the 4-side graphic. The coordinates are measured in pixels from the sides of the CvsImage.
Public property | Point2 | Gets or sets the location of the third point of the 4-side graphic. The coordinates are measured in pixels from the sides of the CvsImage.
Public property | Point3 | Gets or sets the location of the fourth point of the 4-side graphic. The coordinates are measured in pixels from the sides of the CvsImage.
Public property | Style | Gets and sets the drawing style of matrix.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphic4Side Class
Cognex.InSight.Graphic Namespace


CvsGraphic4Side Constructor

[image] [image]

In-Sight SDK
CvsGraphic4Side Constructor
CvsGraphic4Side Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphic4Side()()()() | Initializes a new instance of the CvsGraphic4Side class.
Public method | CvsGraphic4Side(CvsGraphic4Side) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphic4Side(CvsCellLocation, array<CvsImageLocation>[]()[][], String) | Initializes a new instance that is a copy of the specified instance.

See Also

CvsGraphic4Side Class
CvsGraphic4Side..::..CvsGraphic4Side Members
Cognex.InSight.Graphic Namespace


CvsGraphic4Side Constructor

[image]

In-Sight SDK
CvsGraphic4Side Constructor
CvsGraphic4Side Class See Also Send Feedback
Initializes a new instance of the CvsGraphic4Side class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphic4Side()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphic4Side Class
CvsGraphic4Side..::..CvsGraphic4Side Members
CvsGraphic4Side Overload
Cognex.InSight.Graphic Namespace


CvsGraphic4Side Constructor (CvsGraphic4Side)

[image]

In-Sight SDK
CvsGraphic4Side Constructor (CvsGraphic4Side)
CvsGraphic4Side Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphic4Side(
    CvsGraphic4Side graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphic4Side
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphic4Side
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphic4Side Class
CvsGraphic4Side..::..CvsGraphic4Side Members
CvsGraphic4Side Overload
Cognex.InSight.Graphic Namespace


CvsGraphic4Side Constructor (CvsCellLocation, CvsImageLocation[], String)

[image]

In-Sight SDK
CvsGraphic4Side Constructor (CvsCellLocation, array<CvsImageLocation>[]()[][], String)
CvsGraphic4Side Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphic4Side(
    CvsCellLocation cellLocation,
    CvsImageLocation[] points,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    points As CvsImageLocation(),
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell location of this graphic.
points
Type: array< Cognex.InSight..::..CvsImageLocation >[]()[][]
An array of four points to initialize the matrix with.
label
Type: System..::..String
The label associated with this graphic.

Exceptions

Exception | Condition
System..::..IndexOutOfRangeException | Thrown if the points array length is less than 4.

See Also

CvsGraphic4Side Class
CvsGraphic4Side..::..CvsGraphic4Side Members
CvsGraphic4Side Overload
Cognex.InSight.Graphic Namespace


CvsGraphic4Side Methods

[image] [image]

In-Sight SDK
CvsGraphic4Side Methods
CvsGraphic4Side Class See Also Send Feedback

The CvsGraphic4Side type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphic4Side Class
Cognex.InSight.Graphic Namespace


CvsGraphic4Side.Initialize Method

[image]

In-Sight SDK
CvsGraphic4Side..::..Initialize Method
CvsGraphic4Side Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float pt0Row,
    float pt0Col,
    float pt1Row,
    float pt1Col,
    float pt2Row,
    float pt2Col,
    float pt3Row,
    float pt3Col,
    string graphicLabel
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    pt0Row As Single,
    pt0Col As Single,
    pt1Row As Single,
    pt1Col As Single,
    pt2Row As Single,
    pt2Col As Single,
    pt3Row As Single,
    pt3Col As Single,
    graphicLabel As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
pt0Row
Type: System..::..Single
The point 0 row location.
pt0Col
Type: System..::..Single
The point 0 column location.
pt1Row
Type: System..::..Single
The point 1 row location.
pt1Col
Type: System..::..Single
The point 1 column location.
pt2Row
Type: System..::..Single
The point 2 row location.
pt2Col
Type: System..::..Single
The point 2 column location.
pt3Row
Type: System..::..Single
The point 3 row location.
pt3Col
Type: System..::..Single
The point 3 column location.
graphicLabel
Type: System..::..String
The label to draw for this graphic

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphic4Side Class
CvsGraphic4Side..::..CvsGraphic4Side Members
Cognex.InSight.Graphic Namespace


CvsGraphic4Side Properties

[image] [image]

In-Sight SDK
CvsGraphic4Side Properties
CvsGraphic4Side Class See Also Send Feedback

The CvsGraphic4Side type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Point0 | Gets or sets the location of the first point of the 4-side graphic. The coordinates are measured in pixels from the sides of the CvsImage.
Public property | Point1 | Gets or sets the location of the second point of the 4-side graphic. The coordinates are measured in pixels from the sides of the CvsImage.
Public property | Point2 | Gets or sets the location of the third point of the 4-side graphic. The coordinates are measured in pixels from the sides of the CvsImage.
Public property | Point3 | Gets or sets the location of the fourth point of the 4-side graphic. The coordinates are measured in pixels from the sides of the CvsImage.
Public property | Style | Gets and sets the drawing style of matrix.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphic4Side Class
Cognex.InSight.Graphic Namespace


CvsGraphic4Side.EditBounds Property

[image]

In-Sight SDK
CvsGraphic4Side..::..EditBounds Property
CvsGraphic4Side Class See Also Send Feedback
Gets or Sets the edit boundary for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle EditBounds { get; set; }
Visual Basic
Public Property EditBounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphic4Side Class
CvsGraphic4Side..::..CvsGraphic4Side Members
Cognex.InSight.Graphic Namespace


CvsGraphic4Side.Point0 Property

[image]

In-Sight SDK
CvsGraphic4Side..::..Point0 Property
CvsGraphic4Side Class See Also Send Feedback
Gets or sets the location of the first point of the 4-side graphic. The coordinates are measured in pixels from the sides of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Point0 { get; set; }
Visual Basic
Public Property Point0 As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphic4Side Class
CvsGraphic4Side..::..CvsGraphic4Side Members
Cognex.InSight.Graphic Namespace


CvsGraphic4Side.Point1 Property

[image]

In-Sight SDK
CvsGraphic4Side..::..Point1 Property
CvsGraphic4Side Class See Also Send Feedback
Gets or sets the location of the second point of the 4-side graphic. The coordinates are measured in pixels from the sides of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Point1 { get; set; }
Visual Basic
Public Property Point1 As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphic4Side Class
CvsGraphic4Side..::..CvsGraphic4Side Members
Cognex.InSight.Graphic Namespace


CvsGraphic4Side.Point2 Property

[image]

In-Sight SDK
CvsGraphic4Side..::..Point2 Property
CvsGraphic4Side Class See Also Send Feedback
Gets or sets the location of the third point of the 4-side graphic. The coordinates are measured in pixels from the sides of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Point2 { get; set; }
Visual Basic
Public Property Point2 As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphic4Side Class
CvsGraphic4Side..::..CvsGraphic4Side Members
Cognex.InSight.Graphic Namespace


CvsGraphic4Side.Point3 Property

[image]

In-Sight SDK
CvsGraphic4Side..::..Point3 Property
CvsGraphic4Side Class See Also Send Feedback
Gets or sets the location of the fourth point of the 4-side graphic. The coordinates are measured in pixels from the sides of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Point3 { get; set; }
Visual Basic
Public Property Point3 As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphic4Side Class
CvsGraphic4Side..::..CvsGraphic4Side Members
Cognex.InSight.Graphic Namespace


CvsGraphic4Side.Style Property

[image]

In-Sight SDK
CvsGraphic4Side..::..Style Property
CvsGraphic4Side Class See Also Send Feedback
Gets and sets the drawing style of matrix.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsDisplayable4SideStyle Style { get; set; }
Visual Basic
Public Property Style As CvsDisplayable4SideStyle
    Get
    Set

Property Value

Type: CvsDisplayable4SideStyle

See Also

CvsGraphic4Side Class
CvsGraphic4Side..::..CvsGraphic4Side Members
Cognex.InSight.Graphic Namespace


CvsGraphic4Side Events

[image] [image]

In-Sight SDK
CvsGraphic4Side Events
CvsGraphic4Side Class See Also Send Feedback

The CvsGraphic4Side type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphic4Side Class
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus Class

[image]

In-Sight SDK
CvsGraphicAnnulus Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight Annulus graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicAnnulus : CvsGraphic,
    ICvsEditableGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicAnnulus
    Inherits CvsGraphic
    Implements ICvsEditableGraphic

Remarks

CvsGraphicAnnulus objects are returned as items in a CvsGraphicCollection. They are generated by the FindCircleDefects, FindCircle, and FindCircleMinMax functions.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicAnnulus

See Also

CvsGraphicAnnulus..::..CvsGraphicAnnulus Members
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus Members

[image] [image]

In-Sight SDK
CvsGraphicAnnulus Members
CvsGraphicAnnulus Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicAnnulus type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicAnnulus()()()() | Initializes a new instance of the CvsGraphicAnnulus class.
Public method | CvsGraphicAnnulus(CvsGraphicAnnulus) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicAnnulus(CvsCellLocation, CvsImageLocation, Single, Single, String) | Initializes a new instance of the CvsGraphicAnnulus class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Center | Gets the location of the center of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | InnerRadius | Gets the inner radius of the Annulus in pixels.
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | OuterRadius | Gets the outer radius of the Annulus in pixels.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicAnnulus Class
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus Constructor

[image] [image]

In-Sight SDK
CvsGraphicAnnulus Constructor
CvsGraphicAnnulus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicAnnulus()()()() | Initializes a new instance of the CvsGraphicAnnulus class.
Public method | CvsGraphicAnnulus(CvsGraphicAnnulus) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicAnnulus(CvsCellLocation, CvsImageLocation, Single, Single, String) | Initializes a new instance of the CvsGraphicAnnulus class.

See Also

CvsGraphicAnnulus Class
CvsGraphicAnnulus..::..CvsGraphicAnnulus Members
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus Constructor

[image]

In-Sight SDK
CvsGraphicAnnulus Constructor
CvsGraphicAnnulus Class See Also Send Feedback
Initializes a new instance of the CvsGraphicAnnulus class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicAnnulus()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicAnnulus Class
CvsGraphicAnnulus..::..CvsGraphicAnnulus Members
CvsGraphicAnnulus Overload
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus Constructor (CvsGraphicAnnulus)

[image]

In-Sight SDK
CvsGraphicAnnulus Constructor (CvsGraphicAnnulus)
CvsGraphicAnnulus Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicAnnulus(
    CvsGraphicAnnulus graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicAnnulus
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicAnnulus
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicAnnulus Class
CvsGraphicAnnulus..::..CvsGraphicAnnulus Members
CvsGraphicAnnulus Overload
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus Constructor (CvsCellLocation, CvsImageLocation, Single, Single, String)

[image]

In-Sight SDK
CvsGraphicAnnulus Constructor (CvsCellLocation, CvsImageLocation, Single, Single, String)
CvsGraphicAnnulus Class See Also Send Feedback
Initializes a new instance of the CvsGraphicAnnulus class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicAnnulus(
    CvsCellLocation cell,
    CvsImageLocation center,
    float innerRadius,
    float outerRadius,
    string label
)
Visual Basic
Public Sub New (
    cell As CvsCellLocation,
    center As CvsImageLocation,
    innerRadius As Single,
    outerRadius As Single,
    label As String
)

Parameters

cell
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
center
Type: Cognex.InSight..::..CvsImageLocation
The offset of the center of the Annulus in pixels.
innerRadius
Type: System..::..Single
The inner radius of the Annulus in pixels.
outerRadius
Type: System..::..Single
The outer radius of the Annulus in pixels.
label
Type: System..::..String
The annulus graphic's label.

Remarks

The graphic constructed may be passed to the SetEditGraphic(CvsGraphic) method to set the graphic associated with an edit cell function.

See Also

CvsGraphicAnnulus Class
CvsGraphicAnnulus..::..CvsGraphicAnnulus Members
CvsGraphicAnnulus Overload
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus Methods

[image] [image]

In-Sight SDK
CvsGraphicAnnulus Methods
CvsGraphicAnnulus Class See Also Send Feedback

The CvsGraphicAnnulus type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicAnnulus Class
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus.Initialize Method

[image]

In-Sight SDK
CvsGraphicAnnulus..::..Initialize Method
CvsGraphicAnnulus Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float centerRow,
    float centerCol,
    float innerRadius,
    float outerRadius,
    string label
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    centerRow As Single,
    centerCol As Single,
    innerRadius As Single,
    outerRadius As Single,
    label As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
centerRow
Type: System..::..Single
The Annulus' center row location.
centerCol
Type: System..::..Single
The Annulus' center column location.
innerRadius
Type: System..::..Single
The inner radius of the Annulus in pixels.
outerRadius
Type: System..::..Single
The outer radius of the Annulus in pixels.
label
Type: System..::..String
The annulus graphic's label.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicAnnulus Class
CvsGraphicAnnulus..::..CvsGraphicAnnulus Members
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus Properties

[image] [image]

In-Sight SDK
CvsGraphicAnnulus Properties
CvsGraphicAnnulus Class See Also Send Feedback

The CvsGraphicAnnulus type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Center | Gets the location of the center of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | InnerRadius | Gets the inner radius of the Annulus in pixels.
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | OuterRadius | Gets the outer radius of the Annulus in pixels.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicAnnulus Class
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus.Center Property

[image]

In-Sight SDK
CvsGraphicAnnulus..::..Center Property
CvsGraphicAnnulus Class See Also Send Feedback
Gets the location of the center of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Center { get; set; }
Visual Basic
Public Property Center As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicAnnulus Class
CvsGraphicAnnulus..::..CvsGraphicAnnulus Members
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus.EditBounds Property

[image]

In-Sight SDK
CvsGraphicAnnulus..::..EditBounds Property
CvsGraphicAnnulus Class See Also Send Feedback
Gets or Sets the edit boundary for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle EditBounds { get; set; }
Visual Basic
Public Property EditBounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicAnnulus Class
CvsGraphicAnnulus..::..CvsGraphicAnnulus Members
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus.EditFlags Property

[image]

In-Sight SDK
CvsGraphicAnnulus..::..EditFlags Property
CvsGraphicAnnulus Class See Also Send Feedback
Gets or Sets the allowed edit modes for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEditFlags EditFlags { get; set; }
Visual Basic
Public Property EditFlags As CvsEditFlags
    Get
    Set

Property Value

Type: CvsEditFlags

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicAnnulus Class
CvsGraphicAnnulus..::..CvsGraphicAnnulus Members
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus.InnerRadius Property

[image]

In-Sight SDK
CvsGraphicAnnulus..::..InnerRadius Property
CvsGraphicAnnulus Class See Also Send Feedback
Gets the inner radius of the Annulus in pixels.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float InnerRadius { get; set; }
Visual Basic
Public Property InnerRadius As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicAnnulus Class
CvsGraphicAnnulus..::..CvsGraphicAnnulus Members
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus.OuterRadius Property

[image]

In-Sight SDK
CvsGraphicAnnulus..::..OuterRadius Property
CvsGraphicAnnulus Class See Also Send Feedback
Gets the outer radius of the Annulus in pixels.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float OuterRadius { get; set; }
Visual Basic
Public Property OuterRadius As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicAnnulus Class
CvsGraphicAnnulus..::..CvsGraphicAnnulus Members
Cognex.InSight.Graphic Namespace


CvsGraphicAnnulus Events

[image] [image]

In-Sight SDK
CvsGraphicAnnulus Events
CvsGraphicAnnulus Class See Also Send Feedback

The CvsGraphicAnnulus type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicAnnulus Class
Cognex.InSight.Graphic Namespace


CvsGraphicArc Class

[image]

In-Sight SDK
CvsGraphicArc Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight arc graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicArc : CvsGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicArc
    Inherits CvsGraphic

Remarks

CvsGraphicArc objects are returned as items in a CvsGraphicCollection. They are generated by the PlotArc function.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicArc

See Also

CvsGraphicArc..::..CvsGraphicArc Members
Cognex.InSight.Graphic Namespace


CvsGraphicArc Members

[image] [image]

In-Sight SDK
CvsGraphicArc Members
CvsGraphicArc Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicArc type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicArc()()()() | Initializes a new instance of the CvsGraphicArc class.
Public method | CvsGraphicArc(CvsGraphicArc) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicArc(CvsCellLocation, CvsImageLocation, Single, Single, Single, String) | Initializes a new instance of the CvsGraphicArc class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Center | Gets the location of the center of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | CounterClockwise | Gets a value indicating the direction of the arc.
Public property | EndAngle | Gets the end angle of the arc in degrees. The angle is relative to the horizontal axis.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Radius | Gets the radius of the arc in pixels.
Public property | StartAngle | Gets the start angle of the arc in degrees. The angle is relative to the horizontal axis.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicArc Class
Cognex.InSight.Graphic Namespace


CvsGraphicArc Constructor

[image] [image]

In-Sight SDK
CvsGraphicArc Constructor
CvsGraphicArc Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicArc()()()() | Initializes a new instance of the CvsGraphicArc class.
Public method | CvsGraphicArc(CvsGraphicArc) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicArc(CvsCellLocation, CvsImageLocation, Single, Single, Single, String) | Initializes a new instance of the CvsGraphicArc class.

See Also

CvsGraphicArc Class
CvsGraphicArc..::..CvsGraphicArc Members
Cognex.InSight.Graphic Namespace


CvsGraphicArc Constructor

[image]

In-Sight SDK
CvsGraphicArc Constructor
CvsGraphicArc Class See Also Send Feedback
Initializes a new instance of the CvsGraphicArc class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicArc()
Visual Basic
Public Sub New

See Also

CvsGraphicArc Class
CvsGraphicArc..::..CvsGraphicArc Members
CvsGraphicArc Overload
Cognex.InSight.Graphic Namespace


CvsGraphicArc Constructor (CvsGraphicArc)

[image]

In-Sight SDK
CvsGraphicArc Constructor (CvsGraphicArc)
CvsGraphicArc Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicArc(
    CvsGraphicArc graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicArc
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicArc
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicArc Class
CvsGraphicArc..::..CvsGraphicArc Members
CvsGraphicArc Overload
Cognex.InSight.Graphic Namespace


CvsGraphicArc Constructor (CvsCellLocation, CvsImageLocation, Single, Single, Single, String)

[image]

In-Sight SDK
CvsGraphicArc Constructor (CvsCellLocation, CvsImageLocation, Single, Single, Single, String)
CvsGraphicArc Class See Also Send Feedback
Initializes a new instance of the CvsGraphicArc class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicArc(
    CvsCellLocation cellLocation,
    CvsImageLocation center,
    float startAngle,
    float endAngle,
    float radius,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    center As CvsImageLocation,
    startAngle As Single,
    endAngle As Single,
    radius As Single,
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
center
Type: Cognex.InSight..::..CvsImageLocation
The center point of the arc.
startAngle
Type: System..::..Single
The start angle of the arc in degrees.
endAngle
Type: System..::..Single
The end angle of the arc in degrees.
radius
Type: System..::..Single
The radius of the arc.
label
Type: System..::..String
The label associated with this arc.

See Also

CvsGraphicArc Class
CvsGraphicArc..::..CvsGraphicArc Members
CvsGraphicArc Overload
Cognex.InSight.Graphic Namespace


CvsGraphicArc Methods

[image] [image]

In-Sight SDK
CvsGraphicArc Methods
CvsGraphicArc Class See Also Send Feedback

The CvsGraphicArc type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicArc Class
Cognex.InSight.Graphic Namespace


CvsGraphicArc.Initialize Method

[image]

In-Sight SDK
CvsGraphicArc..::..Initialize Method
CvsGraphicArc Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float centerRow,
    float centerCol,
    float startAngle,
    float endAngle,
    float radius,
    string label
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    centerRow As Single,
    centerCol As Single,
    startAngle As Single,
    endAngle As Single,
    radius As Single,
    label As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
centerRow
Type: System..::..Single
The region's row location.
centerCol
Type: System..::..Single
The region's column location.
startAngle
Type: System..::..Single
The height of the region in pixels.
endAngle
Type: System..::..Single
The width of the region in pixels.
radius
Type: System..::..Single
The radius of the arc
label
Type: System..::..String
The label associated with this region.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicArc Class
CvsGraphicArc..::..CvsGraphicArc Members
Cognex.InSight.Graphic Namespace


CvsGraphicArc Properties

[image] [image]

In-Sight SDK
CvsGraphicArc Properties
CvsGraphicArc Class See Also Send Feedback

The CvsGraphicArc type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Center | Gets the location of the center of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | CounterClockwise | Gets a value indicating the direction of the arc.
Public property | EndAngle | Gets the end angle of the arc in degrees. The angle is relative to the horizontal axis.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Radius | Gets the radius of the arc in pixels.
Public property | StartAngle | Gets the start angle of the arc in degrees. The angle is relative to the horizontal axis.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicArc Class
Cognex.InSight.Graphic Namespace


CvsGraphicArc.Center Property

[image]

In-Sight SDK
CvsGraphicArc..::..Center Property
CvsGraphicArc Class See Also Send Feedback
Gets the location of the center of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Center { get; set; }
Visual Basic
Public Property Center As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicArc Class
CvsGraphicArc..::..CvsGraphicArc Members
Cognex.InSight.Graphic Namespace


CvsGraphicArc.CounterClockwise Property

[image]

In-Sight SDK
CvsGraphicArc..::..CounterClockwise Property
CvsGraphicArc Class See Also Send Feedback
Gets a value indicating the direction of the arc.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CounterClockwise { get; }
Visual Basic
Public ReadOnly Property CounterClockwise As Boolean
    Get

Property Value

Type: Boolean
true if the direction is counterclockwise; otherwise, false indicates clockwise.

See Also

CvsGraphicArc Class
CvsGraphicArc..::..CvsGraphicArc Members
Cognex.InSight.Graphic Namespace


CvsGraphicArc.EndAngle Property

[image]

In-Sight SDK
CvsGraphicArc..::..EndAngle Property
CvsGraphicArc Class See Also Send Feedback
Gets the end angle of the arc in degrees. The angle is relative to the horizontal axis.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float EndAngle { get; set; }
Visual Basic
Public Property EndAngle As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicArc Class
CvsGraphicArc..::..CvsGraphicArc Members
Cognex.InSight.Graphic Namespace


CvsGraphicArc.Radius Property

[image]

In-Sight SDK
CvsGraphicArc..::..Radius Property
CvsGraphicArc Class See Also Send Feedback
Gets the radius of the arc in pixels.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Radius { get; set; }
Visual Basic
Public Property Radius As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicArc Class
CvsGraphicArc..::..CvsGraphicArc Members
Cognex.InSight.Graphic Namespace


CvsGraphicArc.StartAngle Property

[image]

In-Sight SDK
CvsGraphicArc..::..StartAngle Property
CvsGraphicArc Class See Also Send Feedback
Gets the start angle of the arc in degrees. The angle is relative to the horizontal axis.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float StartAngle { get; set; }
Visual Basic
Public Property StartAngle As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicArc Class
CvsGraphicArc..::..CvsGraphicArc Members
Cognex.InSight.Graphic Namespace


CvsGraphicArc Events

[image] [image]

In-Sight SDK
CvsGraphicArc Events
CvsGraphicArc Class See Also Send Feedback

The CvsGraphicArc type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicArc Class
Cognex.InSight.Graphic Namespace


CvsGraphicArrows Class

[image]

In-Sight SDK
CvsGraphicArrows Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight arrow graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicArrows : CvsGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicArrows
    Inherits CvsGraphic

Remarks

CvsGraphicArrow objects are returned as items in a CvsGraphicCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicArrows

See Also

CvsGraphicArrows..::..CvsGraphicArrows Members
Cognex.InSight.Graphic Namespace


CvsGraphicArrows Members

[image] [image]

In-Sight SDK
CvsGraphicArrows Members
CvsGraphicArrows Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicArrows type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicArrows()()()() | Initializes a new instance of the CvsGraphicArrow class.
Public method | CvsGraphicArrows(CvsGraphicArrows) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicArrows(CvsCellLocation, CvsImageLocation, Single) | Initializes a new instance with a single arrow.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | Arrows | The list of arrows.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicArrows Class
Cognex.InSight.Graphic Namespace


CvsGraphicArrows Constructor

[image] [image]

In-Sight SDK
CvsGraphicArrows Constructor
CvsGraphicArrows Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicArrows()()()() | Initializes a new instance of the CvsGraphicArrow class.
Public method | CvsGraphicArrows(CvsGraphicArrows) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicArrows(CvsCellLocation, CvsImageLocation, Single) | Initializes a new instance with a single arrow.

See Also

CvsGraphicArrows Class
CvsGraphicArrows..::..CvsGraphicArrows Members
Cognex.InSight.Graphic Namespace


CvsGraphicArrows Constructor

[image]

In-Sight SDK
CvsGraphicArrows Constructor
CvsGraphicArrows Class See Also Send Feedback
Initializes a new instance of the CvsGraphicArrow class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicArrows()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicArrows Class
CvsGraphicArrows..::..CvsGraphicArrows Members
CvsGraphicArrows Overload
Cognex.InSight.Graphic Namespace


CvsGraphicArrows Constructor (CvsGraphicArrows)

[image]

In-Sight SDK
CvsGraphicArrows Constructor (CvsGraphicArrows)
CvsGraphicArrows Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicArrows(
    CvsGraphicArrows graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicArrows
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicArrows
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicArrows Class
CvsGraphicArrows..::..CvsGraphicArrows Members
CvsGraphicArrows Overload
Cognex.InSight.Graphic Namespace


CvsGraphicArrows Constructor (CvsCellLocation, CvsImageLocation, Single)

[image]

In-Sight SDK
CvsGraphicArrows Constructor (CvsCellLocation, CvsImageLocation, Single)
CvsGraphicArrows Class See Also Send Feedback
Initializes a new instance with a single arrow.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicArrows(
    CvsCellLocation cellLocation,
    CvsImageLocation start,
    float angle
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    start As CvsImageLocation,
    angle As Single
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell location of this graphic.
start
Type: Cognex.InSight..::..CvsImageLocation
The start of the arrowhead
angle
Type: System..::..Single
The angle from the start.

See Also

CvsGraphicArrows Class
CvsGraphicArrows..::..CvsGraphicArrows Members
CvsGraphicArrows Overload
Cognex.InSight.Graphic Namespace


CvsGraphicArrows Methods

[image] [image]

In-Sight SDK
CvsGraphicArrows Methods
CvsGraphicArrows Class See Also Send Feedback

The CvsGraphicArrows type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicArrows Class
Cognex.InSight.Graphic Namespace


CvsGraphicArrows.Initialize Method

[image]

In-Sight SDK
CvsGraphicArrows..::..Initialize Method
CvsGraphicArrows Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    CvsImageLocation start,
    float angle
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    start As CvsImageLocation,
    angle As Single
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
start
Type: Cognex.InSight..::..CvsImageLocation
The start of the arrowhead
angle
Type: System..::..Single
The angle from the start.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicArrows Class
CvsGraphicArrows..::..CvsGraphicArrows Members
Cognex.InSight.Graphic Namespace


CvsGraphicArrows Properties

[image] [image]

In-Sight SDK
CvsGraphicArrows Properties
CvsGraphicArrows Class See Also Send Feedback

The CvsGraphicArrows type exposes the following members.

Properties

 | Name | Description
Public property | Arrows | The list of arrows.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicArrows Class
Cognex.InSight.Graphic Namespace


CvsGraphicArrows.Arrows Property

[image]

In-Sight SDK
CvsGraphicArrows..::..Arrows Property
CvsGraphicArrows Class See Also Send Feedback
The list of arrows.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public List<CvsGraphicArrows..::..Arrow> Arrows { get; }
Visual Basic
Public ReadOnly Property Arrows As List(Of CvsGraphicArrows..::..Arrow)
    Get

Property Value

Type: List <(Of <(<' CvsGraphicArrows..::..Arrow >)>)>

See Also

CvsGraphicArrows Class
CvsGraphicArrows..::..CvsGraphicArrows Members
Cognex.InSight.Graphic Namespace


CvsGraphicArrows Events

[image] [image]

In-Sight SDK
CvsGraphicArrows Events
CvsGraphicArrows Class See Also Send Feedback

The CvsGraphicArrows type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicArrows Class
Cognex.InSight.Graphic Namespace


CvsGraphicArrows.Arrow Structure

[image]

In-Sight SDK
CvsGraphicArrows..::..Arrow Structure
CvsGraphicArrows Class Members See Also Send Feedback
Arrow structure containing the location and angle.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public struct Arrow
Visual Basic
Public Structure Arrow

See Also

CvsGraphicArrows..::..Arrow..::..Arrow Members
Cognex.InSight.Graphic Namespace


Arrow Members

[image] [image]

In-Sight SDK
Arrow Members
CvsGraphicArrows..::..Arrow Structure Methods Fields See Also Send Feedback

The CvsGraphicArrows..::..Arrow type exposes the following members.

Methods

 | Name | Description
 | Clone | Clone an arrow.
 | Create | Create a new arrow from a location and angle.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | Angle | The direction the arrow is pointing.
Public field | Location | The start location of the arrow.

See Also

CvsGraphicArrows..::..Arrow Structure
Cognex.InSight.Graphic Namespace


Arrow Fields

[image] [image]

In-Sight SDK
Arrow Fields
CvsGraphicArrows..::..Arrow Structure See Also Send Feedback

The CvsGraphicArrows..::..Arrow type exposes the following members.

Fields

 | Name | Description
Public field | Angle | The direction the arrow is pointing.
Public field | Location | The start location of the arrow.

See Also

CvsGraphicArrows..::..Arrow Structure
Cognex.InSight.Graphic Namespace


CvsGraphicArrows.Arrow.Angle Field

[image]

In-Sight SDK
CvsGraphicArrows..::..Arrow..::..Angle Field
CvsGraphicArrows..::..Arrow Structure See Also Send Feedback
The direction the arrow is pointing.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Angle
Visual Basic
Public Angle As Single

Field Value

Type: Single

See Also

CvsGraphicArrows..::..Arrow Structure
CvsGraphicArrows..::..Arrow..::..Arrow Members
Cognex.InSight.Graphic Namespace


CvsGraphicArrows.Arrow.Location Field

[image]

In-Sight SDK
CvsGraphicArrows..::..Arrow..::..Location Field
CvsGraphicArrows..::..Arrow Structure See Also Send Feedback
The start location of the arrow.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Location
Visual Basic
Public Location As CvsImageLocation

Field Value

Type: CvsImageLocation

See Also

CvsGraphicArrows..::..Arrow Structure
CvsGraphicArrows..::..Arrow..::..Arrow Members
Cognex.InSight.Graphic Namespace


Arrow Methods

[image] [image]

In-Sight SDK
Arrow Methods
CvsGraphicArrows..::..Arrow Structure See Also Send Feedback

The CvsGraphicArrows..::..Arrow type exposes the following members.

Methods

 | Name | Description
 | Clone | Clone an arrow.
 | Create | Create a new arrow from a location and angle.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CvsGraphicArrows..::..Arrow Structure
Cognex.InSight.Graphic Namespace


CvsGraphicArrows.Arrow.Clone Method

[image]

In-Sight SDK
CvsGraphicArrows..::..Arrow..::..Clone Method
CvsGraphicArrows..::..Arrow Structure See Also Send Feedback
Clone an arrow.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static CvsGraphicArrows..::..Arrow Clone(
    CvsGraphicArrows..::..Arrow org
)
Visual Basic
Public Shared Function Clone (
    org As CvsGraphicArrows..::..Arrow
) As CvsGraphicArrows..::..Arrow

Parameters

org
Type: Cognex.InSight.Graphic..::..CvsGraphicArrows..::..Arrow
The arrow to clone.

Return Value

Type: CvsGraphicArrows..::..Arrow
The cloned arrow.

See Also

CvsGraphicArrows..::..Arrow Structure
CvsGraphicArrows..::..Arrow..::..Arrow Members
Cognex.InSight.Graphic Namespace


CvsGraphicArrows.Arrow.Create Method

[image]

In-Sight SDK
CvsGraphicArrows..::..Arrow..::..Create Method
CvsGraphicArrows..::..Arrow Structure See Also Send Feedback
Create a new arrow from a location and angle.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static CvsGraphicArrows..::..Arrow Create(
    CvsImageLocation loc,
    float angle
)
Visual Basic
Public Shared Function Create (
    loc As CvsImageLocation,
    angle As Single
) As CvsGraphicArrows..::..Arrow

Parameters

loc
Type: Cognex.InSight..::..CvsImageLocation
The location of the center of the arrow.
angle
Type: System..::..Single
The angle of the arrow.

Return Value

Type: CvsGraphicArrows..::..Arrow
A new arrow.

See Also

CvsGraphicArrows..::..Arrow Structure
CvsGraphicArrows..::..Arrow..::..Arrow Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath Class

[image]

In-Sight SDK
CvsGraphicBeadPath Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight Bead graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsGraphicBeadPath : CvsGraphic,
    ICvsEditableGraphic
Visual Basic
<SerializableAttribute>
Public Class CvsGraphicBeadPath
    Inherits CvsGraphic
    Implements ICvsEditableGraphic

Remarks

CvsGraphicBeadPath objects are returned as items in a CvsGraphicCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicBeadPath

See Also

CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath Members

[image] [image]

In-Sight SDK
CvsGraphicBeadPath Members
CvsGraphicBeadPath Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicBeadPath type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicBeadPath | Initializes a new instance that is a copy of the specified instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | CanClosePolyline | Returns true if Closed is false.
Public method | CanDeleteVertex | Indicates if the delete operation can be performed.
Public method | CanDeleteVerticesAfter | Indicates if the delete operation can be performed.
Public method | CanDeleteVerticesBefore | Indicates if the delete operation can be performed.
Public method | CanInsertVertex | Indicates if the insert operation can be performed.
Public method | CanOpenPolygon | Returns true if Closed is true and the point index is valid.
Protected method | CheckCopy<(Of <<'(TDerived>)>>) | Throws an InvalidOperationException if the graphic is locked (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | ClosePolyline | If the shape is not Closed, coverts the open polyline to an closed polygon by connecting the last point to the first point.
Protected method | CopyFrom(CvsGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Protected method | CopyFrom(ICvsEditableGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Public method | DeleteVertex | Delete the point at the specified index.
Public method | DeleteVerticesAfter | Delete the vertices after to the specified index.
Public method | DeleteVerticesBefore | Delete the vertices prior to the specified index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertVertex | Add a new CvsImageLocation value at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Fires the PropertyChanged event. (Inherited from CvsGraphic.)
Public method | OpenPolygon | If the shape is Closed, coverts the closed polygon to an open polyline, with the specified point being the last point in the resulting polyline.
Public method | SetVertexLocation | Sets the CvsImageLocation value at the specified index
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Closed | Gets and sets a flag that indicates if the shape is closed or open.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditData | Additional data to be persisted for undo/redo support.
Public property | EditFlags | Gets the possible edit modes for this graphic.
Protected property | Flags | Gets the flags for the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | MinVertexCount | Gets the minimum number of vertices. If Closed is true, then the bead path requires at least three vertices. If Closed is false, then the bead path requires at least two vertices.
Public property | ScanWidth | Gets and sets the scan width of the bead path.
Public property | ShowFillEdgeAreas | Gets and sets a flag that indicates if the fill edge areas should always be drawn.
Public property | ShowIgnoreAreas | Gets and sets a flag that indicates if the ignore areas should always be drawn.
Public property | ShowSearchBoundary | Gets and sets a flag that indicates if the search boundaries should always be drawn.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)
Public property | VertexCount | Gets the number of vertices that define the bead path.
Public property | Vertices | Enumerates the vertices that define the bead path.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicBeadPath Class
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath Constructor

[image]

In-Sight SDK
CvsGraphicBeadPath Constructor
CvsGraphicBeadPath Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicBeadPath(
    CvsGraphicBeadPath graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicBeadPath
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicBeadPath
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath Methods

[image] [image]

In-Sight SDK
CvsGraphicBeadPath Methods
CvsGraphicBeadPath Class See Also Send Feedback

The CvsGraphicBeadPath type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | CanClosePolyline | Returns true if Closed is false.
Public method | CanDeleteVertex | Indicates if the delete operation can be performed.
Public method | CanDeleteVerticesAfter | Indicates if the delete operation can be performed.
Public method | CanDeleteVerticesBefore | Indicates if the delete operation can be performed.
Public method | CanInsertVertex | Indicates if the insert operation can be performed.
Public method | CanOpenPolygon | Returns true if Closed is true and the point index is valid.
Protected method | CheckCopy<(Of <<'(TDerived>)>>) | Throws an InvalidOperationException if the graphic is locked (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | ClosePolyline | If the shape is not Closed, coverts the open polyline to an closed polygon by connecting the last point to the first point.
Protected method | CopyFrom(CvsGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Protected method | CopyFrom(ICvsEditableGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Public method | DeleteVertex | Delete the point at the specified index.
Public method | DeleteVerticesAfter | Delete the vertices after to the specified index.
Public method | DeleteVerticesBefore | Delete the vertices prior to the specified index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertVertex | Add a new CvsImageLocation value at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Fires the PropertyChanged event. (Inherited from CvsGraphic.)
Public method | OpenPolygon | If the shape is Closed, coverts the closed polygon to an open polyline, with the specified point being the last point in the resulting polyline.
Public method | SetVertexLocation | Sets the CvsImageLocation value at the specified index
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicBeadPath Class
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.CanClosePolyline Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..CanClosePolyline Method
CvsGraphicBeadPath Class See Also Send Feedback
Returns true if Closed is false.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CanClosePolyline()
Visual Basic
Public Function CanClosePolyline As Boolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.CanClosePolyline"]

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.CanDeleteVertex Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..CanDeleteVertex Method
CvsGraphicBeadPath Class See Also Send Feedback
Indicates if the delete operation can be performed.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CanDeleteVertex(
    int index
)
Visual Basic
Public Function CanDeleteVertex (
    index As Integer
) As Boolean

Parameters

index
Type: System..::..Int32
The zero-based index.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.CanDeleteVertex(System.Int32)"]

Remarks

The delete can be performed if the index is in range, if the graphic is not Locked, and if the delete operation would not result in too few vertices. If Closed is true, then the polygon shape requires at least three vertices. If Closed is false, then the polygon shape requires at least two vertices.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.CanDeleteVerticesAfter Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..CanDeleteVerticesAfter Method
CvsGraphicBeadPath Class See Also Send Feedback
Indicates if the delete operation can be performed.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CanDeleteVerticesAfter(
    int index
)
Visual Basic
Public Function CanDeleteVerticesAfter (
    index As Integer
) As Boolean

Parameters

index
Type: System..::..Int32
The zero-based index. All vertices after this vertex will be deleted.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.CanDeleteVerticesAfter(System.Int32)"]

Remarks

The delete can be performed if the index is in range, if the graphic is not Locked, and if the delete operation would not result in too few vertices. If Closed is true, then the polygon shape requires at least three vertices. If Closed is false, then the polygon shape requires at least two vertices.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.CanDeleteVerticesBefore Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..CanDeleteVerticesBefore Method
CvsGraphicBeadPath Class See Also Send Feedback
Indicates if the delete operation can be performed.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CanDeleteVerticesBefore(
    int index
)
Visual Basic
Public Function CanDeleteVerticesBefore (
    index As Integer
) As Boolean

Parameters

index
Type: System..::..Int32
The zero-based index. All vertices before this vertex will be deleted.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.CanDeleteVerticesBefore(System.Int32)"]

Remarks

The delete can be performed if the index is in range, if the graphic is not Locked, and if the delete operation would not result in too few vertices. If Closed is true, then the polygon shape requires at least three vertices. If Closed is false, then the polygon shape requires at least two vertices.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.CanInsertVertex Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..CanInsertVertex Method
CvsGraphicBeadPath Class See Also Send Feedback
Indicates if the insert operation can be performed.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CanInsertVertex(
    int index
)
Visual Basic
Public Function CanInsertVertex (
    index As Integer
) As Boolean

Parameters

index
Type: System..::..Int32
The zero-based index.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.CanInsertVertex(System.Int32)"]

Remarks

The insert can be performed the graphic is not Locked and if the index is in range.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.CanOpenPolygon Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..CanOpenPolygon Method
CvsGraphicBeadPath Class See Also Send Feedback
Returns true if Closed is true and the point index is valid.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CanOpenPolygon(
    int pointIndex
)
Visual Basic
Public Function CanOpenPolygon (
    pointIndex As Integer
) As Boolean

Parameters

pointIndex
Type: System..::..Int32
The point that will be the last point in the open polyline.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.CanOpenPolygon(System.Int32)"]

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.ClosePolyline Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..ClosePolyline Method
CvsGraphicBeadPath Class See Also Send Feedback
If the shape is not Closed, coverts the open polyline to an closed polygon by connecting the last point to the first point.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ClosePolyline()
Visual Basic
Public Sub ClosePolyline

Remarks

If the path is already closed, this method will do nothing.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.DeleteVertex Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..DeleteVertex Method
CvsGraphicBeadPath Class See Also Send Feedback
Delete the point at the specified index.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void DeleteVertex(
    int index
)
Visual Basic
Public Sub DeleteVertex (
    index As Integer
)

Parameters

index
Type: System..::..Int32
The zero-based index.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true or if the delete operation would result in too few points.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.DeleteVerticesAfter Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..DeleteVerticesAfter Method
CvsGraphicBeadPath Class See Also Send Feedback
Delete the vertices after to the specified index.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void DeleteVerticesAfter(
    int index
)
Visual Basic
Public Sub DeleteVerticesAfter (
    index As Integer
)

Parameters

index
Type: System..::..Int32
The zero-based index.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true or if the delete operation would result in too few points.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.DeleteVerticesBefore Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..DeleteVerticesBefore Method
CvsGraphicBeadPath Class See Also Send Feedback
Delete the vertices prior to the specified index.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void DeleteVerticesBefore(
    int index
)
Visual Basic
Public Sub DeleteVerticesBefore (
    index As Integer
)

Parameters

index
Type: System..::..Int32
The zero-based index.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true or if the delete operation would result in too few points.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.InsertVertex Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..InsertVertex Method
CvsGraphicBeadPath Class See Also Send Feedback
Add a new CvsImageLocation value at the specified index.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void InsertVertex(
    int index,
    CvsImageLocation location
)
Visual Basic
Public Sub InsertVertex (
    index As Integer,
    location As CvsImageLocation
)

Parameters

index
Type: System..::..Int32
The zero-based index.
location
Type: Cognex.InSight..::..CvsImageLocation
The image location.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.OpenPolygon Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..OpenPolygon Method
CvsGraphicBeadPath Class See Also Send Feedback
If the shape is Closed, coverts the closed polygon to an open polyline, with the specified point being the last point in the resulting polyline.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void OpenPolygon(
    int pointIndex
)
Visual Basic
Public Sub OpenPolygon (
    pointIndex As Integer
)

Parameters

pointIndex
Type: System..::..Int32
The point that will be the last point in the open polyline.

Remarks

If the path is already open, this method will do nothing.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.SetVertexLocation Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..SetVertexLocation Method
CvsGraphicBeadPath Class See Also Send Feedback
Sets the CvsImageLocation value at the specified index

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetVertexLocation(
    int index,
    CvsImageLocation location
)
Visual Basic
Public Sub SetVertexLocation (
    index As Integer,
    location As CvsImageLocation
)

Parameters

index
Type: System..::..Int32
The zero-based index.
location
Type: Cognex.InSight..::..CvsImageLocation
The image location.

Exceptions

Exception | Condition
System..::..IndexOutOfRangeException | An invalid index was specified.
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath Properties

[image] [image]

In-Sight SDK
CvsGraphicBeadPath Properties
CvsGraphicBeadPath Class See Also Send Feedback

The CvsGraphicBeadPath type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Closed | Gets and sets a flag that indicates if the shape is closed or open.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditData | Additional data to be persisted for undo/redo support.
Public property | EditFlags | Gets the possible edit modes for this graphic.
Protected property | Flags | Gets the flags for the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | MinVertexCount | Gets the minimum number of vertices. If Closed is true, then the bead path requires at least three vertices. If Closed is false, then the bead path requires at least two vertices.
Public property | ScanWidth | Gets and sets the scan width of the bead path.
Public property | ShowFillEdgeAreas | Gets and sets a flag that indicates if the fill edge areas should always be drawn.
Public property | ShowIgnoreAreas | Gets and sets a flag that indicates if the ignore areas should always be drawn.
Public property | ShowSearchBoundary | Gets and sets a flag that indicates if the search boundaries should always be drawn.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)
Public property | VertexCount | Gets the number of vertices that define the bead path.
Public property | Vertices | Enumerates the vertices that define the bead path.

See Also

CvsGraphicBeadPath Class
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.Closed Property

[image]

In-Sight SDK
CvsGraphicBeadPath..::..Closed Property
CvsGraphicBeadPath Class See Also Send Feedback
Gets and sets a flag that indicates if the shape is closed or open.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Closed { get; set; }
Visual Basic
Public Property Closed As Boolean
    Get
    Set

Property Value

Type: Boolean

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.EditBounds Property

[image]

In-Sight SDK
CvsGraphicBeadPath..::..EditBounds Property
CvsGraphicBeadPath Class See Also Send Feedback
Gets or Sets the edit boundary for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle EditBounds { get; set; }
Visual Basic
Public Property EditBounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle

Implements

ICvsEditableGraphic..::..EditBounds

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.EditData Property

[image]

In-Sight SDK
CvsGraphicBeadPath..::..EditData Property
CvsGraphicBeadPath Class See Also Send Feedback
Additional data to be persisted for undo/redo support.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public ICloneable EditData { get; set; }
Visual Basic
Public Property EditData As ICloneable
    Get
    Set

Property Value

Type: ICloneable

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.EditFlags Property

[image]

In-Sight SDK
CvsGraphicBeadPath..::..EditFlags Property
CvsGraphicBeadPath Class See Also Send Feedback
Gets the possible edit modes for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEditFlags EditFlags { get; }
Visual Basic
Public ReadOnly Property EditFlags As CvsEditFlags
    Get

Property Value

Type: CvsEditFlags

Implements

ICvsEditableGraphic..::..EditFlags

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.MinVertexCount Property

[image]

In-Sight SDK
CvsGraphicBeadPath..::..MinVertexCount Property
CvsGraphicBeadPath Class See Also Send Feedback
Gets the minimum number of vertices. If Closed is true, then the bead path requires at least three vertices. If Closed is false, then the bead path requires at least two vertices.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MinVertexCount { get; }
Visual Basic
Public ReadOnly Property MinVertexCount As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.ScanWidth Property

[image]

In-Sight SDK
CvsGraphicBeadPath..::..ScanWidth Property
CvsGraphicBeadPath Class See Also Send Feedback
Gets and sets the scan width of the bead path.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float ScanWidth { get; set; }
Visual Basic
Public Property ScanWidth As Single
    Get
    Set

Property Value

Type: Single

Remarks

The scan area is centered over the polyline path segment.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.ShowFillEdgeAreas Property

[image]

In-Sight SDK
CvsGraphicBeadPath..::..ShowFillEdgeAreas Property
CvsGraphicBeadPath Class See Also Send Feedback
Gets and sets a flag that indicates if the fill edge areas should always be drawn.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowFillEdgeAreas { get; set; }
Visual Basic
Public Property ShowFillEdgeAreas As Boolean
    Get
    Set

Property Value

Type: Boolean

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.ShowIgnoreAreas Property

[image]

In-Sight SDK
CvsGraphicBeadPath..::..ShowIgnoreAreas Property
CvsGraphicBeadPath Class See Also Send Feedback
Gets and sets a flag that indicates if the ignore areas should always be drawn.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowIgnoreAreas { get; set; }
Visual Basic
Public Property ShowIgnoreAreas As Boolean
    Get
    Set

Property Value

Type: Boolean

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.ShowSearchBoundary Property

[image]

In-Sight SDK
CvsGraphicBeadPath..::..ShowSearchBoundary Property
CvsGraphicBeadPath Class See Also Send Feedback
Gets and sets a flag that indicates if the search boundaries should always be drawn.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ShowSearchBoundary { get; set; }
Visual Basic
Public Property ShowSearchBoundary As Boolean
    Get
    Set

Property Value

Type: Boolean

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.VertexCount Property

[image]

In-Sight SDK
CvsGraphicBeadPath..::..VertexCount Property
CvsGraphicBeadPath Class See Also Send Feedback
Gets the number of vertices that define the bead path.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int VertexCount { get; }
Visual Basic
Public ReadOnly Property VertexCount As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.Vertices Property

[image]

In-Sight SDK
CvsGraphicBeadPath..::..Vertices Property
CvsGraphicBeadPath Class See Also Send Feedback
Enumerates the vertices that define the bead path.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerable<CvsGraphicBeadPath..::..Vertex> Vertices { get; set; }
Visual Basic
Public Property Vertices As IEnumerable(Of CvsGraphicBeadPath..::..Vertex)
    Get
    Set

Property Value

Type: IEnumerable <(Of <(<' CvsGraphicBeadPath..::..Vertex >)>)>

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicBeadPath Class
CvsGraphicBeadPath..::..CvsGraphicBeadPath Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath Events

[image] [image]

In-Sight SDK
CvsGraphicBeadPath Events
CvsGraphicBeadPath Class See Also Send Feedback

The CvsGraphicBeadPath type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicBeadPath Class
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.CaliperInspectionFlags Enumeration

[image]

In-Sight SDK
CvsGraphicBeadPath..::..CaliperInspectionFlags Enumeration
CvsGraphicBeadPath Class See Also Send Feedback
The CaliperInspectionFlags defines inspection options for an edge on a trained BeadPath polyline.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[FlagsAttribute]
public enum CaliperInspectionFlags
Visual Basic
<FlagsAttribute>
Public Enumeration CaliperInspectionFlags

Members

Member name | Value | Description
None | 0 | Both sides of the bead must be found at runtime, and the caliper result will be used.
FillEdge1 | 1 | Specifies that the inspection algorithm may interpolate where the edge of the bead is, as long as the opposite side is found.
FillEdge2 | 2 | Specifies that the inspection algorithm may interpolate where the edge of the bead is, as long as the opposite side is found.
FillEither | 3 | Specifies that the inspection algorithm may interpolate where the either side of the bead is, as long as the opposite side is found.
Ignore | 4 | Specifies that the inspection algorithm will ignore this area of the bead path.

See Also

Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.Vertex Class

[image]

In-Sight SDK
CvsGraphicBeadPath..::..Vertex Class
CvsGraphicBeadPath Class Members See Also Send Feedback
A point along the bead path.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public class Vertex
Visual Basic
Public Class Vertex

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphicBeadPath..::..Vertex

See Also

CvsGraphicBeadPath..::..Vertex..::..Vertex Members
Cognex.InSight.Graphic Namespace


Vertex Members

[image] [image]

In-Sight SDK
Vertex Members
CvsGraphicBeadPath..::..Vertex Class Constructors Methods Operators Properties See Also Send Feedback

The CvsGraphicBeadPath..::..Vertex type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicBeadPath..::..Vertex(CvsGraphicBeadPath..::..Vertex) |
Public method | CvsGraphicBeadPath..::..Vertex(CvsImageLocation, CvsGraphicBeadPath..::..CaliperInspectionFlags) |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(CvsGraphicBeadPath..::..Vertex to CvsImageLocation) |

Properties

 | Name | Description
Public property | Flags |
Public property | Location |

See Also

CvsGraphicBeadPath..::..Vertex Class
Cognex.InSight.Graphic Namespace


Vertex Constructor

[image] [image]

In-Sight SDK
Vertex Constructor
CvsGraphicBeadPath..::..Vertex Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicBeadPath..::..Vertex(CvsGraphicBeadPath..::..Vertex) | Initializes a new instance of the CvsGraphicBeadPath..::..Vertex class
Public method | CvsGraphicBeadPath..::..Vertex(CvsImageLocation, CvsGraphicBeadPath..::..CaliperInspectionFlags) | Initializes a new instance of the CvsGraphicBeadPath..::..Vertex class

See Also

CvsGraphicBeadPath..::..Vertex Class
CvsGraphicBeadPath..::..Vertex..::..Vertex Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.Vertex Constructor (CvsGraphicBeadPath.Vertex)

[image]

In-Sight SDK
CvsGraphicBeadPath..::..Vertex Constructor (CvsGraphicBeadPath..::..Vertex)
CvsGraphicBeadPath..::..Vertex Class See Also Send Feedback
Initializes a new instance of the CvsGraphicBeadPath..::..Vertex class

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Vertex(
    CvsGraphicBeadPath..::..Vertex source
)
Visual Basic
Public Sub New (
    source As CvsGraphicBeadPath..::..Vertex
)

Parameters

source
Type: Cognex.InSight.Graphic..::..CvsGraphicBeadPath..::..Vertex

[Missing <param name="source"/> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex.#ctor(Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex)"]

See Also

CvsGraphicBeadPath..::..Vertex Class
CvsGraphicBeadPath..::..Vertex..::..Vertex Members
CvsGraphicBeadPath..::..Vertex Overload
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.Vertex Constructor (CvsImageLocation, CvsGraphicBeadPath.CaliperInspectionFlags)

[image]

In-Sight SDK
CvsGraphicBeadPath..::..Vertex Constructor (CvsImageLocation, CvsGraphicBeadPath..::..CaliperInspectionFlags)
CvsGraphicBeadPath..::..Vertex Class See Also Send Feedback
Initializes a new instance of the CvsGraphicBeadPath..::..Vertex class

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Vertex(
    CvsImageLocation location,
    CvsGraphicBeadPath..::..CaliperInspectionFlags flags
)
Visual Basic
Public Sub New (
    location As CvsImageLocation,
    flags As CvsGraphicBeadPath..::..CaliperInspectionFlags
)

Parameters

location
Type: Cognex.InSight..::..CvsImageLocation

[Missing <param name="location"/> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex.#ctor(Cognex.InSight.CvsImageLocation,Cognex.InSight.Graphic.CvsGraphicBeadPath.CaliperInspectionFlags)"]

flags
Type: Cognex.InSight.Graphic..::..CvsGraphicBeadPath..::..CaliperInspectionFlags

[Missing <param name="flags"/> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex.#ctor(Cognex.InSight.CvsImageLocation,Cognex.InSight.Graphic.CvsGraphicBeadPath.CaliperInspectionFlags)"]

See Also

CvsGraphicBeadPath..::..Vertex Class
CvsGraphicBeadPath..::..Vertex..::..Vertex Members
CvsGraphicBeadPath..::..Vertex Overload
Cognex.InSight.Graphic Namespace


Vertex Methods

[image] [image]

In-Sight SDK
Vertex Methods
CvsGraphicBeadPath..::..Vertex Class See Also Send Feedback

The CvsGraphicBeadPath..::..Vertex type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

CvsGraphicBeadPath..::..Vertex Class
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.Vertex.ToString Method

[image]

In-Sight SDK
CvsGraphicBeadPath..::..Vertex..::..ToString Method
CvsGraphicBeadPath..::..Vertex Class See Also Send Feedback

[Missing <summary> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex.ToString"]

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String

[Missing <returns> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex.ToString"]

See Also

CvsGraphicBeadPath..::..Vertex Class
CvsGraphicBeadPath..::..Vertex..::..Vertex Members
Cognex.InSight.Graphic Namespace


Vertex Type Conversions

[image] [image]

In-Sight SDK
Vertex Type Conversions
CvsGraphicBeadPath..::..Vertex Class See Also Send Feedback

The CvsGraphicBeadPath..::..Vertex type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(CvsGraphicBeadPath..::..Vertex to CvsImageLocation) |

See Also

CvsGraphicBeadPath..::..Vertex Class
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.Vertex Implicit Conversion (CvsGraphicBeadPath.Vertex to CvsImageLocation)

[image]

In-Sight SDK
CvsGraphicBeadPath..::..Vertex ImplicitWideningImplicitImplicitImplicit Conversion (CvsGraphicBeadPath..::..Vertex to CvsImageLocation)
CvsGraphicBeadPath..::..Vertex Class See Also Send Feedback

[Missing <summary> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex.op_Implicit(Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex)~Cognex.InSight.CvsImageLocation"]

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static implicit operator CvsImageLocation (
    CvsGraphicBeadPath..::..Vertex v
)
Visual Basic
Public Shared Widening Operator CType (
    v As CvsGraphicBeadPath..::..Vertex
) As CvsImageLocation

Parameters

v
Type: Cognex.InSight.Graphic..::..CvsGraphicBeadPath..::..Vertex

[Missing <param name="v"/> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex.op_Implicit(Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex)~Cognex.InSight.CvsImageLocation"]

Return Value

Type: CvsImageLocation

[Missing <returns> documentation for "M:Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex.op_Implicit(Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex)~Cognex.InSight.CvsImageLocation"]

See Also

CvsGraphicBeadPath..::..Vertex Class
CvsGraphicBeadPath..::..Vertex..::..Vertex Members
Cognex.InSight.Graphic Namespace


Vertex Properties

[image] [image]

In-Sight SDK
Vertex Properties
CvsGraphicBeadPath..::..Vertex Class See Also Send Feedback

The CvsGraphicBeadPath..::..Vertex type exposes the following members.

Properties

 | Name | Description
Public property | Flags |
Public property | Location |

See Also

CvsGraphicBeadPath..::..Vertex Class
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.Vertex.Flags Property

[image]

In-Sight SDK
CvsGraphicBeadPath..::..Vertex..::..Flags Property
CvsGraphicBeadPath..::..Vertex Class See Also Send Feedback

[Missing <summary> documentation for "P:Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex.Flags"]

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicBeadPath..::..CaliperInspectionFlags Flags { get; }
Visual Basic
Public ReadOnly Property Flags As CvsGraphicBeadPath..::..CaliperInspectionFlags
    Get

Property Value

Type: CvsGraphicBeadPath..::..CaliperInspectionFlags

See Also

CvsGraphicBeadPath..::..Vertex Class
CvsGraphicBeadPath..::..Vertex..::..Vertex Members
Cognex.InSight.Graphic Namespace


CvsGraphicBeadPath.Vertex.Location Property

[image]

In-Sight SDK
CvsGraphicBeadPath..::..Vertex..::..Location Property
CvsGraphicBeadPath..::..Vertex Class See Also Send Feedback

[Missing <summary> documentation for "P:Cognex.InSight.Graphic.CvsGraphicBeadPath.Vertex.Location"]

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Location { get; }
Visual Basic
Public ReadOnly Property Location As CvsImageLocation
    Get

Property Value

Type: CvsImageLocation

See Also

CvsGraphicBeadPath..::..Vertex Class
CvsGraphicBeadPath..::..Vertex..::..Vertex Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlob Class

[image]

In-Sight SDK
CvsGraphicBlob Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight blob graphic, a chain of points that represent a single blob.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsGraphicBlob : CvsGraphic
Visual Basic
<SerializableAttribute>
Public Class CvsGraphicBlob
    Inherits CvsGraphic

Remarks

CvsGraphicBlob objects are returned as items in a CvsGraphicCollection. They are generated by the ExtractBlobs function.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicBlob
Cognex.InSight.Graphic..::..CvsGraphicBlobProperties

See Also

CvsGraphicBlob..::..CvsGraphicBlob Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlob Members

[image] [image]

In-Sight SDK
CvsGraphicBlob Members
CvsGraphicBlob Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicBlob type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicBlob | Initializes a new instance that is a copy of the specified instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Protected method | CheckCopy<(Of <<'(TDerived>)>>) | Throws an InvalidOperationException if the graphic is locked (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Protected method | CopyFrom(CvsGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Protected method | CopyFrom(ICvsEditableGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPath | Creates a GraphicsPath object that represents this chain.
Public method | GetPoints | Returns the encoded array of points that comprise the chain.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Fires the PropertyChanged event. (Inherited from CvsGraphic.)
Public method | ToString | Returns a string that identifies this graphic. (Overrides CvsGraphic..::..ToString()()()().)

Properties

 | Name | Description
Public property | BlobNumber | Gets the blob number that identifies the chain.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Protected property | Flags | Gets the flags for the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Location | Gets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | NumPoints | Gets the number of points within the chain.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicBlob Class
Cognex.InSight.Graphic Namespace


CvsGraphicBlob Constructor

[image]

In-Sight SDK
CvsGraphicBlob Constructor
CvsGraphicBlob Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicBlob(
    CvsGraphicBlob graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicBlob
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicBlob
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicBlob Class
CvsGraphicBlob..::..CvsGraphicBlob Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlob Methods

[image] [image]

In-Sight SDK
CvsGraphicBlob Methods
CvsGraphicBlob Class See Also Send Feedback

The CvsGraphicBlob type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Protected method | CheckCopy<(Of <<'(TDerived>)>>) | Throws an InvalidOperationException if the graphic is locked (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Protected method | CopyFrom(CvsGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Protected method | CopyFrom(ICvsEditableGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPath | Creates a GraphicsPath object that represents this chain.
Public method | GetPoints | Returns the encoded array of points that comprise the chain.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Fires the PropertyChanged event. (Inherited from CvsGraphic.)
Public method | ToString | Returns a string that identifies this graphic. (Overrides CvsGraphic..::..ToString()()()().)

See Also

CvsGraphicBlob Class
Cognex.InSight.Graphic Namespace


CvsGraphicBlob.GetPath Method

[image]

In-Sight SDK
CvsGraphicBlob..::..GetPath Method
CvsGraphicBlob Class See Also Send Feedback
Creates a GraphicsPath object that represents this chain.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public GraphicsPath GetPath()
Visual Basic
Public Function GetPath As GraphicsPath

Return Value

Type: GraphicsPath
A new GraphicsPath object.

Remarks

This method is only available in .NET applications.

See Also

CvsGraphicBlob Class
CvsGraphicBlob..::..CvsGraphicBlob Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlob.GetPoints Method

[image]

In-Sight SDK
CvsGraphicBlob..::..GetPoints Method
CvsGraphicBlob Class See Also Send Feedback
Returns the encoded array of points that comprise the chain.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicBlobPoint[] GetPoints()
Visual Basic
Public Function GetPoints As CvsGraphicBlobPoint()

Return Value

Type: array< CvsGraphicBlobPoint >[]()[][]
An array of CvsGraphicBlobPoint that represent the chain.

See Also

CvsGraphicBlob Class
CvsGraphicBlob..::..CvsGraphicBlob Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlob.ToString Method

[image]

In-Sight SDK
CvsGraphicBlob..::..ToString Method
CvsGraphicBlob Class See Also Send Feedback
Returns a string that identifies this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of this instance.

See Also

CvsGraphicBlob Class
CvsGraphicBlob..::..CvsGraphicBlob Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlob Properties

[image] [image]

In-Sight SDK
CvsGraphicBlob Properties
CvsGraphicBlob Class See Also Send Feedback

The CvsGraphicBlob type exposes the following members.

Properties

 | Name | Description
Public property | BlobNumber | Gets the blob number that identifies the chain.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Protected property | Flags | Gets the flags for the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Location | Gets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | NumPoints | Gets the number of points within the chain.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicBlob Class
Cognex.InSight.Graphic Namespace


CvsGraphicBlob.BlobNumber Property

[image]

In-Sight SDK
CvsGraphicBlob..::..BlobNumber Property
CvsGraphicBlob Class See Also Send Feedback
Gets the blob number that identifies the chain.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int BlobNumber { get; }
Visual Basic
Public ReadOnly Property BlobNumber As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicBlob Class
CvsGraphicBlob..::..CvsGraphicBlob Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlob.Location Property

[image]

In-Sight SDK
CvsGraphicBlob..::..Location Property
CvsGraphicBlob Class See Also Send Feedback
Gets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Location { get; }
Visual Basic
Public ReadOnly Property Location As CvsImageLocation
    Get

Property Value

Type: CvsImageLocation

See Also

CvsGraphicBlob Class
CvsGraphicBlob..::..CvsGraphicBlob Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlob.NumPoints Property

[image]

In-Sight SDK
CvsGraphicBlob..::..NumPoints Property
CvsGraphicBlob Class See Also Send Feedback
Gets the number of points within the chain.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NumPoints { get; }
Visual Basic
Public ReadOnly Property NumPoints As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicBlob Class
CvsGraphicBlob..::..CvsGraphicBlob Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlob Events

[image] [image]

In-Sight SDK
CvsGraphicBlob Events
CvsGraphicBlob Class See Also Send Feedback

The CvsGraphicBlob type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicBlob Class
Cognex.InSight.Graphic Namespace


CvsGraphicBlobDirection Enumeration

[image]

In-Sight SDK
CvsGraphicBlobDirection Enumeration
See Also Send Feedback
The direction values for the CvsGraphicBlobPoint structure.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public enum CvsGraphicBlobDirection
Visual Basic
<SerializableAttribute>
Public Enumeration CvsGraphicBlobDirection

Members

Member name | Value | Description
ChainNW | 0 | Northwest.
ChainN | 1 | North.
ChainNE | 2 | Northeast.
ChainE | 3 | East.
ChainSE | 4 | Southeast.
ChainS | 5 | South
ChainSW | 6 | Southwest
ChainW | 7 | West

See Also

Cognex.InSight.Graphic Namespace


CvsGraphicBlobPoint Structure

[image]

In-Sight SDK
CvsGraphicBlobPoint Structure
Members See Also Send Feedback
Represents a single point in the chain graphic

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public struct CvsGraphicBlobPoint
Visual Basic
<SerializableAttribute>
Public Structure CvsGraphicBlobPoint

Remarks

Use the GetLocation(CvsImageLocation) method to determine the location of each point.

See Also

CvsGraphicBlobPoint..::..CvsGraphicBlobPoint Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlobPoint Members

[image] [image]

In-Sight SDK
CvsGraphicBlobPoint Members
CvsGraphicBlobPoint Structure Methods Properties See Also Send Feedback

The CvsGraphicBlobPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetLocation | Gets the location of this point given the previous point's location.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

 | Name | Description
Public property | Direction | The direction that this point is relative to the previous point.
Public property | Distance | The number of pixels to add to the previous point's row and column values to determine where this point is.

See Also

CvsGraphicBlobPoint Structure
Cognex.InSight.Graphic Namespace


CvsGraphicBlobPoint Methods

[image] [image]

In-Sight SDK
CvsGraphicBlobPoint Methods
CvsGraphicBlobPoint Structure See Also Send Feedback

The CvsGraphicBlobPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetLocation | Gets the location of this point given the previous point's location.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CvsGraphicBlobPoint Structure
Cognex.InSight.Graphic Namespace


CvsGraphicBlobPoint.GetLocation Method

[image]

In-Sight SDK
CvsGraphicBlobPoint..::..GetLocation Method
CvsGraphicBlobPoint Structure See Also Send Feedback
Gets the location of this point given the previous point's location.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation GetLocation(
    CvsImageLocation previousPoint
)
Visual Basic
Public Function GetLocation (
    previousPoint As CvsImageLocation
) As CvsImageLocation

Parameters

previousPoint
Type: Cognex.InSight..::..CvsImageLocation
The previous point's location.

Return Value

Type: CvsImageLocation
The location of this point.

Remarks

This method is only available in .NET applications.

See Also

CvsGraphicBlobPoint Structure
CvsGraphicBlobPoint..::..CvsGraphicBlobPoint Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlobPoint Properties

[image] [image]

In-Sight SDK
CvsGraphicBlobPoint Properties
CvsGraphicBlobPoint Structure See Also Send Feedback

The CvsGraphicBlobPoint type exposes the following members.

Properties

 | Name | Description
Public property | Direction | The direction that this point is relative to the previous point.
Public property | Distance | The number of pixels to add to the previous point's row and column values to determine where this point is.

See Also

CvsGraphicBlobPoint Structure
Cognex.InSight.Graphic Namespace


CvsGraphicBlobPoint.Direction Property

[image]

In-Sight SDK
CvsGraphicBlobPoint..::..Direction Property
CvsGraphicBlobPoint Structure See Also Send Feedback
The direction that this point is relative to the previous point.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicBlobDirection Direction { get; }
Visual Basic
Public ReadOnly Property Direction As CvsGraphicBlobDirection
    Get

Property Value

Type: CvsGraphicBlobDirection

See Also

CvsGraphicBlobPoint Structure
CvsGraphicBlobPoint..::..CvsGraphicBlobPoint Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlobPoint.Distance Property

[image]

In-Sight SDK
CvsGraphicBlobPoint..::..Distance Property
CvsGraphicBlobPoint Structure See Also Send Feedback
The number of pixels to add to the previous point's row and column values to determine where this point is.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Distance { get; }
Visual Basic
Public ReadOnly Property Distance As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicBlobPoint Structure
CvsGraphicBlobPoint..::..CvsGraphicBlobPoint Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlobProperties Class

[image]

In-Sight SDK
CvsGraphicBlobProperties Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight blob properties graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicBlobProperties : CvsGraphicBlob
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicBlobProperties
    Inherits CvsGraphicBlob

Remarks

CvsGraphicBlobProperties objects are returned as items in a CvsGraphicCollection. They are generated by the FindBlobs function and are only returned when the property sheet for the FindBlobs cell is open.

An input chain is an editable graphic and may be edited by a control and returned to the In-Sight sensor.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicBlob
Cognex.InSight.Graphic..::..CvsGraphicBlobProperties

See Also

CvsGraphicBlobProperties..::..CvsGraphicBlobProperties Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlobProperties Members

[image] [image]

In-Sight SDK
CvsGraphicBlobProperties Members
CvsGraphicBlobProperties Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicBlobProperties type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicBlobProperties | Initializes a new instance that is a copy of the specified instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPath | Creates a GraphicsPath object that represents this chain. (Inherited from CvsGraphicBlob.)
Public method | GetPoints | Returns the encoded array of points that comprise the chain. (Inherited from CvsGraphicBlob.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphicBlob.)

Properties

 | Name | Description
Public property | Angle | Gets the angle (in degress) that represents the counter-clockwise rotation of the graphic from the horizontal axis.
Public property | Area | Gets the area of the connected region in pixels.
Public property | BlobNumber | Gets the blob number that identifies the chain. (Inherited from CvsGraphicBlob.)
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Centroid | Gets the centroid of the graphic.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | Elongation | Gets a dimensionless value proportional to the ratio of the extreme moments of inertia about the centroid.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | Hole | Gets the hole count.
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Location | Gets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage. (Inherited from CvsGraphicBlob.)
Public property | NumPoints | Gets the number of points within the chain. (Inherited from CvsGraphicBlob.)
Public property | Perimeter | Gets the boundary length of the connected region in pixels.
Public property | Spread | Gets a dimensionless value proportional to ratio of the dimensional variance to the area.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicBlobProperties Class
Cognex.InSight.Graphic Namespace


CvsGraphicBlobProperties Constructor

[image]

In-Sight SDK
CvsGraphicBlobProperties Constructor
CvsGraphicBlobProperties Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicBlobProperties(
    CvsGraphicBlobProperties graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicBlobProperties
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicBlobProperties
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicBlobProperties Class
CvsGraphicBlobProperties..::..CvsGraphicBlobProperties Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlobProperties Methods

[image] [image]

In-Sight SDK
CvsGraphicBlobProperties Methods
CvsGraphicBlobProperties Class See Also Send Feedback

The CvsGraphicBlobProperties type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPath | Creates a GraphicsPath object that represents this chain. (Inherited from CvsGraphicBlob.)
Public method | GetPoints | Returns the encoded array of points that comprise the chain. (Inherited from CvsGraphicBlob.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphicBlob.)

See Also

CvsGraphicBlobProperties Class
Cognex.InSight.Graphic Namespace


CvsGraphicBlobProperties Properties

[image] [image]

In-Sight SDK
CvsGraphicBlobProperties Properties
CvsGraphicBlobProperties Class See Also Send Feedback

The CvsGraphicBlobProperties type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets the angle (in degress) that represents the counter-clockwise rotation of the graphic from the horizontal axis.
Public property | Area | Gets the area of the connected region in pixels.
Public property | BlobNumber | Gets the blob number that identifies the chain. (Inherited from CvsGraphicBlob.)
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Centroid | Gets the centroid of the graphic.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | Elongation | Gets a dimensionless value proportional to the ratio of the extreme moments of inertia about the centroid.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | Hole | Gets the hole count.
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Location | Gets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage. (Inherited from CvsGraphicBlob.)
Public property | NumPoints | Gets the number of points within the chain. (Inherited from CvsGraphicBlob.)
Public property | Perimeter | Gets the boundary length of the connected region in pixels.
Public property | Spread | Gets a dimensionless value proportional to ratio of the dimensional variance to the area.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicBlobProperties Class
Cognex.InSight.Graphic Namespace


CvsGraphicBlobProperties.Angle Property

[image]

In-Sight SDK
CvsGraphicBlobProperties..::..Angle Property
CvsGraphicBlobProperties Class See Also Send Feedback
Gets the angle (in degress) that represents the counter-clockwise rotation of the graphic from the horizontal axis.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Angle { get; }
Visual Basic
Public ReadOnly Property Angle As Single
    Get

Property Value

Type: Single

See Also

CvsGraphicBlobProperties Class
CvsGraphicBlobProperties..::..CvsGraphicBlobProperties Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlobProperties.Area Property

[image]

In-Sight SDK
CvsGraphicBlobProperties..::..Area Property
CvsGraphicBlobProperties Class See Also Send Feedback
Gets the area of the connected region in pixels.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Area { get; }
Visual Basic
Public ReadOnly Property Area As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicBlobProperties Class
CvsGraphicBlobProperties..::..CvsGraphicBlobProperties Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlobProperties.Centroid Property

[image]

In-Sight SDK
CvsGraphicBlobProperties..::..Centroid Property
CvsGraphicBlobProperties Class See Also Send Feedback
Gets the centroid of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Centroid { get; }
Visual Basic
Public ReadOnly Property Centroid As CvsImageLocation
    Get

Property Value

Type: CvsImageLocation
The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.

See Also

CvsGraphicBlobProperties Class
CvsGraphicBlobProperties..::..CvsGraphicBlobProperties Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlobProperties.Elongation Property

[image]

In-Sight SDK
CvsGraphicBlobProperties..::..Elongation Property
CvsGraphicBlobProperties Class See Also Send Feedback
Gets a dimensionless value proportional to the ratio of the extreme moments of inertia about the centroid.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Elongation { get; }
Visual Basic
Public ReadOnly Property Elongation As Single
    Get

Property Value

Type: Single

See Also

CvsGraphicBlobProperties Class
CvsGraphicBlobProperties..::..CvsGraphicBlobProperties Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlobProperties.Hole Property

[image]

In-Sight SDK
CvsGraphicBlobProperties..::..Hole Property
CvsGraphicBlobProperties Class See Also Send Feedback
Gets the hole count.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Hole { get; }
Visual Basic
Public ReadOnly Property Hole As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicBlobProperties Class
CvsGraphicBlobProperties..::..CvsGraphicBlobProperties Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlobProperties.Perimeter Property

[image]

In-Sight SDK
CvsGraphicBlobProperties..::..Perimeter Property
CvsGraphicBlobProperties Class See Also Send Feedback
Gets the boundary length of the connected region in pixels.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Perimeter { get; }
Visual Basic
Public ReadOnly Property Perimeter As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicBlobProperties Class
CvsGraphicBlobProperties..::..CvsGraphicBlobProperties Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlobProperties.Spread Property

[image]

In-Sight SDK
CvsGraphicBlobProperties..::..Spread Property
CvsGraphicBlobProperties Class See Also Send Feedback
Gets a dimensionless value proportional to ratio of the dimensional variance to the area.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Spread { get; }
Visual Basic
Public ReadOnly Property Spread As Single
    Get

Property Value

Type: Single

See Also

CvsGraphicBlobProperties Class
CvsGraphicBlobProperties..::..CvsGraphicBlobProperties Members
Cognex.InSight.Graphic Namespace


CvsGraphicBlobProperties Events

[image] [image]

In-Sight SDK
CvsGraphicBlobProperties Events
CvsGraphicBlobProperties Class See Also Send Feedback

The CvsGraphicBlobProperties type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicBlobProperties Class
Cognex.InSight.Graphic Namespace


CvsGraphicCircle Class

[image]

In-Sight SDK
CvsGraphicCircle Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight circle graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicCircle : CvsGraphic,
    ICvsEditableGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicCircle
    Inherits CvsGraphic
    Implements ICvsEditableGraphic

Remarks

CvsGraphicCircle objects are returned as items in a CvsGraphicCollection. They are generated by the PointToCircle, LineToCircle, CircleToCircle, and Circle functions.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicCircle

See Also

CvsGraphicCircle..::..CvsGraphicCircle Members
Cognex.InSight.Graphic Namespace


CvsGraphicCircle Members

[image] [image]

In-Sight SDK
CvsGraphicCircle Members
CvsGraphicCircle Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicCircle type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicCircle()()()() | Initializes a new instance of the CvsGraphicCircle class.
Public method | CvsGraphicCircle(CvsGraphicCircle) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicCircle(CvsCellLocation, CvsImageLocation, Single, String) | Initializes a new instance of the CvsGraphicCircle class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Center | Gets the location of the center of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Radius | Gets the radius of the circle in pixels.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicCircle Class
Cognex.InSight.Graphic Namespace


CvsGraphicCircle Constructor

[image] [image]

In-Sight SDK
CvsGraphicCircle Constructor
CvsGraphicCircle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicCircle()()()() | Initializes a new instance of the CvsGraphicCircle class.
Public method | CvsGraphicCircle(CvsGraphicCircle) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicCircle(CvsCellLocation, CvsImageLocation, Single, String) | Initializes a new instance of the CvsGraphicCircle class.

See Also

CvsGraphicCircle Class
CvsGraphicCircle..::..CvsGraphicCircle Members
Cognex.InSight.Graphic Namespace


CvsGraphicCircle Constructor

[image]

In-Sight SDK
CvsGraphicCircle Constructor
CvsGraphicCircle Class See Also Send Feedback
Initializes a new instance of the CvsGraphicCircle class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicCircle()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicCircle Class
CvsGraphicCircle..::..CvsGraphicCircle Members
CvsGraphicCircle Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCircle Constructor (CvsGraphicCircle)

[image]

In-Sight SDK
CvsGraphicCircle Constructor (CvsGraphicCircle)
CvsGraphicCircle Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicCircle(
    CvsGraphicCircle graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicCircle
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicCircle
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicCircle Class
CvsGraphicCircle..::..CvsGraphicCircle Members
CvsGraphicCircle Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCircle Constructor (CvsCellLocation, CvsImageLocation, Single, String)

[image]

In-Sight SDK
CvsGraphicCircle Constructor (CvsCellLocation, CvsImageLocation, Single, String)
CvsGraphicCircle Class See Also Send Feedback
Initializes a new instance of the CvsGraphicCircle class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicCircle(
    CvsCellLocation cellLocation,
    CvsImageLocation center,
    float radius,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    center As CvsImageLocation,
    radius As Single,
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
center
Type: Cognex.InSight..::..CvsImageLocation
The offset of the center of the circle in pixels.
radius
Type: System..::..Single
The radius of the circle in pixels.
label
Type: System..::..String
The circle's label

Remarks

The graphic constructed may be passed to the SetEditGraphic(CvsGraphic) method to set the graphic associated with an edit cell function.

See Also

CvsGraphicCircle Class
CvsGraphicCircle..::..CvsGraphicCircle Members
CvsGraphicCircle Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCircle Methods

[image] [image]

In-Sight SDK
CvsGraphicCircle Methods
CvsGraphicCircle Class See Also Send Feedback

The CvsGraphicCircle type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicCircle Class
Cognex.InSight.Graphic Namespace


CvsGraphicCircle.Initialize Method

[image]

In-Sight SDK
CvsGraphicCircle..::..Initialize Method
CvsGraphicCircle Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float centerRow,
    float centerCol,
    float circleRadius,
    string label
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    centerRow As Single,
    centerCol As Single,
    circleRadius As Single,
    label As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
centerRow
Type: System..::..Single
The circle's center row location.
centerCol
Type: System..::..Single
The circle's center column location.
circleRadius
Type: System..::..Single
The radius of the circle in pixels.
label
Type: System..::..String
The circle graphic's label.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCircle Class
CvsGraphicCircle..::..CvsGraphicCircle Members
Cognex.InSight.Graphic Namespace


CvsGraphicCircle Properties

[image] [image]

In-Sight SDK
CvsGraphicCircle Properties
CvsGraphicCircle Class See Also Send Feedback

The CvsGraphicCircle type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Center | Gets the location of the center of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Radius | Gets the radius of the circle in pixels.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicCircle Class
Cognex.InSight.Graphic Namespace


CvsGraphicCircle.Center Property

[image]

In-Sight SDK
CvsGraphicCircle..::..Center Property
CvsGraphicCircle Class See Also Send Feedback
Gets the location of the center of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Center { get; set; }
Visual Basic
Public Property Center As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCircle Class
CvsGraphicCircle..::..CvsGraphicCircle Members
Cognex.InSight.Graphic Namespace


CvsGraphicCircle.EditBounds Property

[image]

In-Sight SDK
CvsGraphicCircle..::..EditBounds Property
CvsGraphicCircle Class See Also Send Feedback
Gets or Sets the edit boundary for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle EditBounds { get; set; }
Visual Basic
Public Property EditBounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCircle Class
CvsGraphicCircle..::..CvsGraphicCircle Members
Cognex.InSight.Graphic Namespace


CvsGraphicCircle.EditFlags Property

[image]

In-Sight SDK
CvsGraphicCircle..::..EditFlags Property
CvsGraphicCircle Class See Also Send Feedback
Gets or Sets the allowed edit modes for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEditFlags EditFlags { get; set; }
Visual Basic
Public Property EditFlags As CvsEditFlags
    Get
    Set

Property Value

Type: CvsEditFlags

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCircle Class
CvsGraphicCircle..::..CvsGraphicCircle Members
Cognex.InSight.Graphic Namespace


CvsGraphicCircle.Radius Property

[image]

In-Sight SDK
CvsGraphicCircle..::..Radius Property
CvsGraphicCircle Class See Also Send Feedback
Gets the radius of the circle in pixels.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Radius { get; set; }
Visual Basic
Public Property Radius As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCircle Class
CvsGraphicCircle..::..CvsGraphicCircle Members
Cognex.InSight.Graphic Namespace


CvsGraphicCircle Events

[image] [image]

In-Sight SDK
CvsGraphicCircle Events
CvsGraphicCircle Class See Also Send Feedback

The CvsGraphicCircle type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicCircle Class
Cognex.InSight.Graphic Namespace


CvsGraphicCollection Class

[image]

In-Sight SDK
CvsGraphicCollection Class
Members See Also Send Feedback
Represents a collection of CvsGraphic objects.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicCollection : IEnumerable<CvsGraphic>,
    IEnumerable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicCollection
    Implements IEnumerable(Of CvsGraphic), IEnumerable

Remarks

The CvsGraphicCollection holds the current set of graphics associated with an acquisition.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphicCollection

See Also

CvsGraphicCollection..::..CvsGraphicCollection Members
Cognex.InSight.Graphic Namespace


CvsGraphicCollection Members

[image] [image]

In-Sight SDK
CvsGraphicCollection Members
CvsGraphicCollection Class Methods Properties See Also Send Feedback

The CvsGraphicCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCellGraphics(String) | Returns a collection of all of the graphics associated with a cell.
Public method | GetCellGraphics(CvsCellLocation) | Returns a collection of all of the graphics associated with a cell.
Public method | GetDefaultGraphic(String) | Returns the default graphic associated with a cell.
Public method | GetDefaultGraphic(CvsCellLocation) | Returns the default graphic associated with a cell.
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsGraphicCollection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of items in the collection.
Public property | Item | Gets the CvsGraphic object at the specified zero-based index. The index must be nonnegative and less than Count.

See Also

CvsGraphicCollection Class
Cognex.InSight.Graphic Namespace


CvsGraphicCollection Methods

[image] [image]

In-Sight SDK
CvsGraphicCollection Methods
CvsGraphicCollection Class See Also Send Feedback

The CvsGraphicCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCellGraphics(String) | Returns a collection of all of the graphics associated with a cell.
Public method | GetCellGraphics(CvsCellLocation) | Returns a collection of all of the graphics associated with a cell.
Public method | GetDefaultGraphic(String) | Returns the default graphic associated with a cell.
Public method | GetDefaultGraphic(CvsCellLocation) | Returns the default graphic associated with a cell.
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsGraphicCollection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsGraphicCollection Class
Cognex.InSight.Graphic Namespace


CvsGraphicCollection.GetCellGraphics Method

[image] [image]

In-Sight SDK
CvsGraphicCollection..::..GetCellGraphics Method
CvsGraphicCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCellGraphics(String) | Returns a collection of all of the graphics associated with a cell.
Public method | GetCellGraphics(CvsCellLocation) | Returns a collection of all of the graphics associated with a cell.

See Also

CvsGraphicCollection Class
CvsGraphicCollection..::..CvsGraphicCollection Members
Cognex.InSight.Graphic Namespace


CvsGraphicCollection.GetCellGraphics Method (String)

[image]

In-Sight SDK
CvsGraphicCollection..::..GetCellGraphics Method (String)
CvsGraphicCollection Class See Also Send Feedback
Returns a collection of all of the graphics associated with a cell.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicCollection GetCellGraphics(
    string location
)
Visual Basic
Public Function GetCellGraphics (
    location As String
) As CvsGraphicCollection

Parameters

location
Type: System..::..String
The cell's location.

Return Value

Type: CvsGraphicCollection
The collection of graphics.

See Also

CvsGraphicCollection Class
CvsGraphicCollection..::..CvsGraphicCollection Members
GetCellGraphics Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCollection.GetCellGraphics Method (CvsCellLocation)

[image]

In-Sight SDK
CvsGraphicCollection..::..GetCellGraphics Method (CvsCellLocation)
CvsGraphicCollection Class See Also Send Feedback
Returns a collection of all of the graphics associated with a cell.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicCollection GetCellGraphics(
    CvsCellLocation location
)
Visual Basic
Public Function GetCellGraphics (
    location As CvsCellLocation
) As CvsGraphicCollection

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.

Return Value

Type: CvsGraphicCollection
The collection of graphics.

Remarks

This overload of this method is not available in COM/ActiveX applications.

See Also

CvsGraphicCollection Class
CvsGraphicCollection..::..CvsGraphicCollection Members
GetCellGraphics Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCollection.GetDefaultGraphic Method

[image] [image]

In-Sight SDK
CvsGraphicCollection..::..GetDefaultGraphic Method
CvsGraphicCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDefaultGraphic(String) | Returns the default graphic associated with a cell.
Public method | GetDefaultGraphic(CvsCellLocation) | Returns the default graphic associated with a cell.

See Also

CvsGraphicCollection Class
CvsGraphicCollection..::..CvsGraphicCollection Members
Cognex.InSight.Graphic Namespace


CvsGraphicCollection.GetDefaultGraphic Method (String)

[image]

In-Sight SDK
CvsGraphicCollection..::..GetDefaultGraphic Method (String)
CvsGraphicCollection Class See Also Send Feedback
Returns the default graphic associated with a cell.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphic GetDefaultGraphic(
    string location
)
Visual Basic
Public Function GetDefaultGraphic (
    location As String
) As CvsGraphic

Parameters

location
Type: System..::..String
The cell's location.

Return Value

Type: CvsGraphic
A graphic object or null if a default graphic is not found.

See Also

CvsGraphicCollection Class
CvsGraphicCollection..::..CvsGraphicCollection Members
GetDefaultGraphic Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCollection.GetDefaultGraphic Method (CvsCellLocation)

[image]

In-Sight SDK
CvsGraphicCollection..::..GetDefaultGraphic Method (CvsCellLocation)
CvsGraphicCollection Class See Also Send Feedback
Returns the default graphic associated with a cell.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphic GetDefaultGraphic(
    CvsCellLocation location
)
Visual Basic
Public Function GetDefaultGraphic (
    location As CvsCellLocation
) As CvsGraphic

Parameters

location
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.

Return Value

Type: CvsGraphic
A graphic object or null if a default graphic is not found.

Remarks

This overload of this method is not available in COM/ActiveX applications.

See Also

CvsGraphicCollection Class
CvsGraphicCollection..::..CvsGraphicCollection Members
GetDefaultGraphic Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCollection.GetEnumerator Method

[image]

In-Sight SDK
CvsGraphicCollection..::..GetEnumerator Method
CvsGraphicCollection Class See Also Send Feedback
Returns an IEnumerator that can iterate through the CvsGraphicCollection.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerator<CvsGraphic> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of CvsGraphic)

Return Value

Type: IEnumerator <(Of <(<' CvsGraphic >)>)>

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

CvsGraphicCollection Class
CvsGraphicCollection..::..CvsGraphicCollection Members
Cognex.InSight.Graphic Namespace


CvsGraphicCollection Properties

[image] [image]

In-Sight SDK
CvsGraphicCollection Properties
CvsGraphicCollection Class See Also Send Feedback

The CvsGraphicCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of items in the collection.
Public property | Item | Gets the CvsGraphic object at the specified zero-based index. The index must be nonnegative and less than Count.

See Also

CvsGraphicCollection Class
Cognex.InSight.Graphic Namespace


CvsGraphicCollection.Count Property

[image]

In-Sight SDK
CvsGraphicCollection..::..Count Property
CvsGraphicCollection Class See Also Send Feedback
Gets the number of items in the collection.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicCollection Class
CvsGraphicCollection..::..CvsGraphicCollection Members
Cognex.InSight.Graphic Namespace


CvsGraphicCollection.Item Property

[image]

In-Sight SDK
CvsGraphicCollection..::..Item Property
CvsGraphicCollection Class See Also Send Feedback
Gets the CvsGraphic object at the specified zero-based index. The index must be nonnegative and less than Count.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphic this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As CvsGraphic
    Get

Parameters

index
Type: System..::..Int32
The zero-based index into the collection.

Property Value

Type: CvsGraphic

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsGraphicCollection Class
CvsGraphicCollection..::..CvsGraphicCollection Members
Cognex.InSight.Graphic Namespace


CvsGraphicColorSampleList Class

[image]

In-Sight SDK
CvsGraphicColorSampleList Class
Members See Also Send Feedback
Encapsulates the data associated with list of In-Sight color sample points.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsGraphicColorSampleList : CvsGraphic
Visual Basic
<SerializableAttribute>
Public Class CvsGraphicColorSampleList
    Inherits CvsGraphic

Remarks

CvsGraphicColorSampleList objects are returned as items in a CvsGraphicCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicColorSampleList

See Also

CvsGraphicColorSampleList..::..CvsGraphicColorSampleList Members
Cognex.InSight.Graphic Namespace


CvsGraphicColorSampleList Members

[image] [image]

In-Sight SDK
CvsGraphicColorSampleList Members
CvsGraphicColorSampleList Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicColorSampleList type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicColorSampleList | Initializes a new instance that is a copy of the specified instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Protected method | CheckCopy<(Of <<'(TDerived>)>>) | Throws an InvalidOperationException if the graphic is locked (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Protected method | CopyFrom(CvsGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Protected method | CopyFrom(ICvsEditableGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Fires the PropertyChanged event. (Inherited from CvsGraphic.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | ColorSamples | Returns an enumeration of CvsGraphicColorSampleList..::..ColorSample objects.
Protected property | Flags | Gets the flags for the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicColorSampleList Class
Cognex.InSight.Graphic Namespace


CvsGraphicColorSampleList Constructor

[image]

In-Sight SDK
CvsGraphicColorSampleList Constructor
CvsGraphicColorSampleList Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicColorSampleList(
    CvsGraphicColorSampleList graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicColorSampleList
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicColorSampleList
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicColorSampleList Class
CvsGraphicColorSampleList..::..CvsGraphicColorSampleList Members
Cognex.InSight.Graphic Namespace


CvsGraphicColorSampleList Methods

[image] [image]

In-Sight SDK
CvsGraphicColorSampleList Methods
CvsGraphicColorSampleList Class See Also Send Feedback

The CvsGraphicColorSampleList type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Protected method | CheckCopy<(Of <<'(TDerived>)>>) | Throws an InvalidOperationException if the graphic is locked (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Protected method | CopyFrom(CvsGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Protected method | CopyFrom(ICvsEditableGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Fires the PropertyChanged event. (Inherited from CvsGraphic.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicColorSampleList Class
Cognex.InSight.Graphic Namespace


CvsGraphicColorSampleList Properties

[image] [image]

In-Sight SDK
CvsGraphicColorSampleList Properties
CvsGraphicColorSampleList Class See Also Send Feedback

The CvsGraphicColorSampleList type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | ColorSamples | Returns an enumeration of CvsGraphicColorSampleList..::..ColorSample objects.
Protected property | Flags | Gets the flags for the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicColorSampleList Class
Cognex.InSight.Graphic Namespace


CvsGraphicColorSampleList.ColorSamples Property

[image]

In-Sight SDK
CvsGraphicColorSampleList..::..ColorSamples Property
CvsGraphicColorSampleList Class See Also Send Feedback
Returns an enumeration of CvsGraphicColorSampleList..::..ColorSample objects.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerable<CvsGraphicColorSampleList..::..ColorSample> ColorSamples { get; }
Visual Basic
Public ReadOnly Property ColorSamples As IEnumerable(Of CvsGraphicColorSampleList..::..ColorSample)
    Get

Property Value

Type: IEnumerable <(Of <(<' CvsGraphicColorSampleList..::..ColorSample >)>)>

See Also

CvsGraphicColorSampleList Class
CvsGraphicColorSampleList..::..CvsGraphicColorSampleList Members
Cognex.InSight.Graphic Namespace


CvsGraphicColorSampleList Events

[image] [image]

In-Sight SDK
CvsGraphicColorSampleList Events
CvsGraphicColorSampleList Class See Also Send Feedback

The CvsGraphicColorSampleList type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicColorSampleList Class
Cognex.InSight.Graphic Namespace


CvsGraphicColorSampleList.ColorSample Structure

[image]

In-Sight SDK
CvsGraphicColorSampleList..::..ColorSample Structure
CvsGraphicColorSampleList Class Members See Also Send Feedback
Color sample point data.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public struct ColorSample
Visual Basic
Public Structure ColorSample

See Also

CvsGraphicColorSampleList..::..ColorSample..::..ColorSample Members
Cognex.InSight.Graphic Namespace


ColorSample Members

[image] [image]

In-Sight SDK
ColorSample Members
CvsGraphicColorSampleList..::..ColorSample Structure Methods Properties See Also Send Feedback

The CvsGraphicColorSampleList..::..ColorSample type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

 | Name | Description
Public property | Color | The sample color.
Public property | Location | The location of the sample point in the image.
Public property | Radius | The suggested radius for presenting the sample color.

See Also

CvsGraphicColorSampleList..::..ColorSample Structure
Cognex.InSight.Graphic Namespace


ColorSample Methods

[image] [image]

In-Sight SDK
ColorSample Methods
CvsGraphicColorSampleList..::..ColorSample Structure See Also Send Feedback

The CvsGraphicColorSampleList..::..ColorSample type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CvsGraphicColorSampleList..::..ColorSample Structure
Cognex.InSight.Graphic Namespace


ColorSample Properties

[image] [image]

In-Sight SDK
ColorSample Properties
CvsGraphicColorSampleList..::..ColorSample Structure See Also Send Feedback

The CvsGraphicColorSampleList..::..ColorSample type exposes the following members.

Properties

 | Name | Description
Public property | Color | The sample color.
Public property | Location | The location of the sample point in the image.
Public property | Radius | The suggested radius for presenting the sample color.

See Also

CvsGraphicColorSampleList..::..ColorSample Structure
Cognex.InSight.Graphic Namespace


CvsGraphicColorSampleList.ColorSample.Color Property

[image]

In-Sight SDK
CvsGraphicColorSampleList..::..ColorSample..::..Color Property
CvsGraphicColorSampleList..::..ColorSample Structure See Also Send Feedback
The sample color.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color Color { get; }
Visual Basic
Public ReadOnly Property Color As Color
    Get

Property Value

Type: Color

See Also

CvsGraphicColorSampleList..::..ColorSample Structure
CvsGraphicColorSampleList..::..ColorSample..::..ColorSample Members
Cognex.InSight.Graphic Namespace


CvsGraphicColorSampleList.ColorSample.Location Property

[image]

In-Sight SDK
CvsGraphicColorSampleList..::..ColorSample..::..Location Property
CvsGraphicColorSampleList..::..ColorSample Structure See Also Send Feedback
The location of the sample point in the image.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Location { get; }
Visual Basic
Public ReadOnly Property Location As CvsImageLocation
    Get

Property Value

Type: CvsImageLocation

See Also

CvsGraphicColorSampleList..::..ColorSample Structure
CvsGraphicColorSampleList..::..ColorSample..::..ColorSample Members
Cognex.InSight.Graphic Namespace


CvsGraphicColorSampleList.ColorSample.Radius Property

[image]

In-Sight SDK
CvsGraphicColorSampleList..::..ColorSample..::..Radius Property
CvsGraphicColorSampleList..::..ColorSample Structure See Also Send Feedback
The suggested radius for presenting the sample color.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Radius { get; }
Visual Basic
Public ReadOnly Property Radius As Single
    Get

Property Value

Type: Single

See Also

CvsGraphicColorSampleList..::..ColorSample Structure
CvsGraphicColorSampleList..::..ColorSample..::..ColorSample Members
Cognex.InSight.Graphic Namespace


CvsGraphicComposite Class

[image]

In-Sight SDK
CvsGraphicComposite Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight CompositeRegion graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicComposite : CvsGraphicCompositeBase
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicComposite
    Inherits CvsGraphicCompositeBase

Remarks

CvsGraphicComposite objects are returned as items in a CvsGraphicCollection.

A CvsGraphicComposite is an editable graphic and may be edited by a control and returned to the In-Sight sensor.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicCompositeBase
Cognex.InSight.Graphic..::..CvsGraphicComposite

See Also

CvsGraphicComposite..::..CvsGraphicComposite Members
Cognex.InSight.Graphic Namespace


CvsGraphicComposite Members

[image] [image]

In-Sight SDK
CvsGraphicComposite Members
CvsGraphicComposite Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicComposite type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicComposite()()()() | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicComposite(array<CvsCompositeSubregion>[]()[][]) | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicComposite(CvsGraphicCompositeBase) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicComposite(CvsCellLocation, array<CvsCompositeSubregion>[]()[][], String) | Initializes a new instance of the CvsGraphicComposite class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | ClearSubregions | Remove all the subregions (Inherited from CvsGraphicCompositeBase.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | DeleteSubregion | Remove the subregion from the composite. (Inherited from CvsGraphicCompositeBase.)
Public method | DeleteSubregionByIndex | Remove the subregion at the specified index. (Inherited from CvsGraphicCompositeBase.)
Public method | DeleteSubregions | Deletes subregions in the specified range. (Inherited from CvsGraphicCompositeBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetSubregionOperation | Returns the operation of the specified subregion. (Inherited from CvsGraphicCompositeBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertAnnulus | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertCircle | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertPolygon | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertRegion | Insert a subregion based on the provided CvsGraphicRegion object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionAnnulus | Update the subregion using the provided CvsGraphicAnnulus object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionCircle | Update the subregion using the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionOperation | Modifies the operation of the specified subregion. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionPolygon | Insert a subregion based on the provided CvsGraphicPolygon object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionRegion | Update the subregion using the provided CvsGraphicRegion object. (Inherited from CvsGraphicCompositeBase.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditFlags | Gets or sets the allowed edit modes for this graphic. (Inherited from CvsGraphicCompositeBase.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Subregions | Gets or sets the array of CvsCompositeSubregion objects which define this composite region. (Inherited from CvsGraphicCompositeBase.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicComposite Class
Cognex.InSight.Graphic Namespace


CvsGraphicComposite Constructor

[image] [image]

In-Sight SDK
CvsGraphicComposite Constructor
CvsGraphicComposite Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicComposite()()()() | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicComposite(array<CvsCompositeSubregion>[]()[][]) | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicComposite(CvsGraphicCompositeBase) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicComposite(CvsCellLocation, array<CvsCompositeSubregion>[]()[][], String) | Initializes a new instance of the CvsGraphicComposite class.

See Also

CvsGraphicComposite Class
CvsGraphicComposite..::..CvsGraphicComposite Members
Cognex.InSight.Graphic Namespace


CvsGraphicComposite Constructor

[image]

In-Sight SDK
CvsGraphicComposite Constructor
CvsGraphicComposite Class See Also Send Feedback
Initializes a new instance of the CvsGraphicComposite class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicComposite()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicComposite Class
CvsGraphicComposite..::..CvsGraphicComposite Members
CvsGraphicComposite Overload
Cognex.InSight.Graphic Namespace


CvsGraphicComposite Constructor (CvsCompositeSubregion[])

[image]

In-Sight SDK
CvsGraphicComposite Constructor (array<CvsCompositeSubregion>[]()[][])
CvsGraphicComposite Class See Also Send Feedback
Initializes a new instance of the CvsGraphicComposite class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicComposite(
    CvsCompositeSubregion[] subRegions
)
Visual Basic
Public Sub New (
    subRegions As CvsCompositeSubregion()
)

Parameters

subRegions
Type: array< Cognex.InSight.Graphic..::..CvsCompositeSubregion >[]()[][]
Subregions which define the CompositeRegion.

See Also

CvsGraphicComposite Class
CvsGraphicComposite..::..CvsGraphicComposite Members
CvsGraphicComposite Overload
Cognex.InSight.Graphic Namespace


CvsGraphicComposite Constructor (CvsGraphicCompositeBase)

[image]

In-Sight SDK
CvsGraphicComposite Constructor (CvsGraphicCompositeBase)
CvsGraphicComposite Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicComposite(
    CvsGraphicCompositeBase graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicCompositeBase
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicCompositeBase
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicComposite Class
CvsGraphicComposite..::..CvsGraphicComposite Members
CvsGraphicComposite Overload
Cognex.InSight.Graphic Namespace


CvsGraphicComposite Constructor (CvsCellLocation, CvsCompositeSubregion[], String)

[image]

In-Sight SDK
CvsGraphicComposite Constructor (CvsCellLocation, array<CvsCompositeSubregion>[]()[][], String)
CvsGraphicComposite Class See Also Send Feedback
Initializes a new instance of the CvsGraphicComposite class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicComposite(
    CvsCellLocation cellLocation,
    CvsCompositeSubregion[] subRegions,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    subRegions As CvsCompositeSubregion(),
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
subRegions
Type: array< Cognex.InSight.Graphic..::..CvsCompositeSubregion >[]()[][]
Subregions which define the CompositeRegion.
label
Type: System..::..String
The label to draw for this graphic

Remarks

The graphic constructed may be passed to the SetEditGraphic(CvsGraphic) method to set the graphic associated with an edit cell function.

See Also

CvsGraphicComposite Class
CvsGraphicComposite..::..CvsGraphicComposite Members
CvsGraphicComposite Overload
Cognex.InSight.Graphic Namespace


CvsGraphicComposite Methods

[image] [image]

In-Sight SDK
CvsGraphicComposite Methods
CvsGraphicComposite Class See Also Send Feedback

The CvsGraphicComposite type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | ClearSubregions | Remove all the subregions (Inherited from CvsGraphicCompositeBase.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | DeleteSubregion | Remove the subregion from the composite. (Inherited from CvsGraphicCompositeBase.)
Public method | DeleteSubregionByIndex | Remove the subregion at the specified index. (Inherited from CvsGraphicCompositeBase.)
Public method | DeleteSubregions | Deletes subregions in the specified range. (Inherited from CvsGraphicCompositeBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetSubregionOperation | Returns the operation of the specified subregion. (Inherited from CvsGraphicCompositeBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertAnnulus | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertCircle | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertPolygon | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertRegion | Insert a subregion based on the provided CvsGraphicRegion object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionAnnulus | Update the subregion using the provided CvsGraphicAnnulus object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionCircle | Update the subregion using the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionOperation | Modifies the operation of the specified subregion. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionPolygon | Insert a subregion based on the provided CvsGraphicPolygon object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionRegion | Update the subregion using the provided CvsGraphicRegion object. (Inherited from CvsGraphicCompositeBase.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicComposite Class
Cognex.InSight.Graphic Namespace


CvsGraphicComposite Properties

[image] [image]

In-Sight SDK
CvsGraphicComposite Properties
CvsGraphicComposite Class See Also Send Feedback

The CvsGraphicComposite type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditFlags | Gets or sets the allowed edit modes for this graphic. (Inherited from CvsGraphicCompositeBase.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Subregions | Gets or sets the array of CvsCompositeSubregion objects which define this composite region. (Inherited from CvsGraphicCompositeBase.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicComposite Class
Cognex.InSight.Graphic Namespace


CvsGraphicComposite Events

[image] [image]

In-Sight SDK
CvsGraphicComposite Events
CvsGraphicComposite Class See Also Send Feedback

The CvsGraphicComposite type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicComposite Class
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase Class

[image]

In-Sight SDK
CvsGraphicCompositeBase Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight CompositeRegion graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public abstract class CvsGraphicCompositeBase : CvsGraphic,
    ICvsEditableGraphic
Visual Basic
<SerializableAttribute>
Public MustInherit Class CvsGraphicCompositeBase
    Inherits CvsGraphic
    Implements ICvsEditableGraphic

Remarks

CvsGraphicComposite objects are returned as items in a CvsGraphicCollection.

A CvsGraphicComposite is an editable graphic and may be edited by a control and returned to the In-Sight sensor.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicCompositeBase
Cognex.InSight.Graphic..::..CvsGraphicComposite
Cognex.InSight.Graphic..::..CvsGraphicMaskedRegion
Cognex.InSight.Graphic..::..CvsGraphicPolylinePath

See Also

CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase Members

[image] [image]

In-Sight SDK
CvsGraphicCompositeBase Members
CvsGraphicCompositeBase Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicCompositeBase type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicCompositeBase()()()() | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicCompositeBase(array<CvsCompositeSubregion>[]()[][]) | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicCompositeBase(CvsGraphicCompositeBase) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicCompositeBase(CvsCellLocation, array<CvsCompositeSubregion>[]()[][], String) | Initializes a new instance of the CvsGraphicComposite class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Protected method | CheckCopy<(Of <<'(TDerived>)>>) | Throws an InvalidOperationException if the graphic is locked (Inherited from CvsGraphic.)
Public method | ClearSubregions | Remove all the subregions
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Protected method | CopyFrom(CvsGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Protected method | CopyFrom(ICvsEditableGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Public method | DeleteSubregion | Remove the subregion from the composite.
Public method | DeleteSubregionByIndex | Remove the subregion at the specified index.
Public method | DeleteSubregions | Deletes subregions in the specified range.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetSubregionOperation | Returns the operation of the specified subregion.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | InsertAnnulus | Insert a subregion based on the provided CvsGraphicCircle object.
Public method | InsertCircle | Insert a subregion based on the provided CvsGraphicCircle object.
Public method | InsertPolygon | Insert a subregion based on the provided CvsGraphicCircle object.
Public method | InsertRegion | Insert a subregion based on the provided CvsGraphicRegion object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Fires the PropertyChanged event. (Inherited from CvsGraphic.)
Public method | SetSubregionAnnulus | Update the subregion using the provided CvsGraphicAnnulus object.
Public method | SetSubregionCircle | Update the subregion using the provided CvsGraphicCircle object.
Public method | SetSubregionOperation | Modifies the operation of the specified subregion.
Public method | SetSubregionPolygon | Insert a subregion based on the provided CvsGraphicPolygon object.
Public method | SetSubregionRegion | Update the subregion using the provided CvsGraphicRegion object.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditFlags | Gets or sets the allowed edit modes for this graphic.
Protected property | Flags | Gets the flags for the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Subregions | Gets or sets the array of CvsCompositeSubregion objects which define this composite region.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)
Protected property | ValidEditFlags | Return the valid edit flags, PolylinePath and MaskedRegion have different valid flags.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicCompositeBase Class
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase Constructor

[image] [image]

In-Sight SDK
CvsGraphicCompositeBase Constructor
CvsGraphicCompositeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicCompositeBase()()()() | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicCompositeBase(array<CvsCompositeSubregion>[]()[][]) | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicCompositeBase(CvsGraphicCompositeBase) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicCompositeBase(CvsCellLocation, array<CvsCompositeSubregion>[]()[][], String) | Initializes a new instance of the CvsGraphicComposite class.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase Constructor

[image]

In-Sight SDK
CvsGraphicCompositeBase Constructor
CvsGraphicCompositeBase Class See Also Send Feedback
Initializes a new instance of the CvsGraphicComposite class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicCompositeBase()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
CvsGraphicCompositeBase Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase Constructor (CvsCompositeSubregion[])

[image]

In-Sight SDK
CvsGraphicCompositeBase Constructor (array<CvsCompositeSubregion>[]()[][])
CvsGraphicCompositeBase Class See Also Send Feedback
Initializes a new instance of the CvsGraphicComposite class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicCompositeBase(
    CvsCompositeSubregion[] subRegions
)
Visual Basic
Public Sub New (
    subRegions As CvsCompositeSubregion()
)

Parameters

subRegions
Type: array< Cognex.InSight.Graphic..::..CvsCompositeSubregion >[]()[][]
Subregions which define the CompositeRegion.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
CvsGraphicCompositeBase Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase Constructor (CvsGraphicCompositeBase)

[image]

In-Sight SDK
CvsGraphicCompositeBase Constructor (CvsGraphicCompositeBase)
CvsGraphicCompositeBase Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicCompositeBase(
    CvsGraphicCompositeBase graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicCompositeBase
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicCompositeBase
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
CvsGraphicCompositeBase Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase Constructor (CvsCellLocation, CvsCompositeSubregion[], String)

[image]

In-Sight SDK
CvsGraphicCompositeBase Constructor (CvsCellLocation, array<CvsCompositeSubregion>[]()[][], String)
CvsGraphicCompositeBase Class See Also Send Feedback
Initializes a new instance of the CvsGraphicComposite class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicCompositeBase(
    CvsCellLocation cellLocation,
    CvsCompositeSubregion[] subRegions,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    subRegions As CvsCompositeSubregion(),
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
subRegions
Type: array< Cognex.InSight.Graphic..::..CvsCompositeSubregion >[]()[][]
Subregions which define the CompositeRegion.
label
Type: System..::..String
The label to draw for this graphic

Remarks

The graphic constructed may be passed to the SetEditGraphic(CvsGraphic) method to set the graphic associated with an edit cell function.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
CvsGraphicCompositeBase Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase Methods

[image] [image]

In-Sight SDK
CvsGraphicCompositeBase Methods
CvsGraphicCompositeBase Class See Also Send Feedback

The CvsGraphicCompositeBase type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Protected method | CheckCopy<(Of <<'(TDerived>)>>) | Throws an InvalidOperationException if the graphic is locked (Inherited from CvsGraphic.)
Public method | ClearSubregions | Remove all the subregions
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Protected method | CopyFrom(CvsGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Protected method | CopyFrom(ICvsEditableGraphic) | Copies member from the source graphic to this graphic. (Inherited from CvsGraphic.)
Public method | DeleteSubregion | Remove the subregion from the composite.
Public method | DeleteSubregionByIndex | Remove the subregion at the specified index.
Public method | DeleteSubregions | Deletes subregions in the specified range.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetSubregionOperation | Returns the operation of the specified subregion.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | InsertAnnulus | Insert a subregion based on the provided CvsGraphicCircle object.
Public method | InsertCircle | Insert a subregion based on the provided CvsGraphicCircle object.
Public method | InsertPolygon | Insert a subregion based on the provided CvsGraphicCircle object.
Public method | InsertRegion | Insert a subregion based on the provided CvsGraphicRegion object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Fires the PropertyChanged event. (Inherited from CvsGraphic.)
Public method | SetSubregionAnnulus | Update the subregion using the provided CvsGraphicAnnulus object.
Public method | SetSubregionCircle | Update the subregion using the provided CvsGraphicCircle object.
Public method | SetSubregionOperation | Modifies the operation of the specified subregion.
Public method | SetSubregionPolygon | Insert a subregion based on the provided CvsGraphicPolygon object.
Public method | SetSubregionRegion | Update the subregion using the provided CvsGraphicRegion object.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicCompositeBase Class
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.ClearSubregions Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..ClearSubregions Method
CvsGraphicCompositeBase Class See Also Send Feedback
Remove all the subregions

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ClearSubregions()
Visual Basic
Public Sub ClearSubregions

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.DeleteSubregion Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..DeleteSubregion Method
CvsGraphicCompositeBase Class See Also Send Feedback
Remove the subregion from the composite.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void DeleteSubregion(
    CvsCompositeSubregion subRegion
)
Visual Basic
Public Sub DeleteSubregion (
    subRegion As CvsCompositeSubregion
)

Parameters

subRegion
Type: Cognex.InSight.Graphic..::..CvsCompositeSubregion
Reference to the subregion to remove.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.DeleteSubregionByIndex Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..DeleteSubregionByIndex Method
CvsGraphicCompositeBase Class See Also Send Feedback
Remove the subregion at the specified index.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void DeleteSubregionByIndex(
    int index
)
Visual Basic
Public Sub DeleteSubregionByIndex (
    index As Integer
)

Parameters

index
Type: System..::..Int32
The zero-based index of the subregion to remove.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.DeleteSubregions Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..DeleteSubregions Method
CvsGraphicCompositeBase Class See Also Send Feedback
Deletes subregions in the specified range.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void DeleteSubregions(
    int index,
    int count
)
Visual Basic
Public Sub DeleteSubregions (
    index As Integer,
    count As Integer
)

Parameters

index
Type: System..::..Int32
The first subregion to delete.
count
Type: System..::..Int32
The number of subregions to delete.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsInSightLockedException | A CvsInSightLockedException is thrown if this graphic is locked.
System..::..InvalidOperationException | An InvalidOperationException is thrown if count is less than 0, or if the number of remaining subregions will be less than one.
System..::..IndexOutOfRangeException | An IndexOutOfRangeException is thrown if the index is out of range or if index plus count is out of range.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace
CvsGraphic..::..IsLocked


CvsGraphicCompositeBase.GetSubregionOperation Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..GetSubregionOperation Method
CvsGraphicCompositeBase Class See Also Send Feedback
Returns the operation of the specified subregion.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeOperation GetSubregionOperation(
    int index
)
Visual Basic
Public Function GetSubregionOperation (
    index As Integer
) As CvsCompositeOperation

Parameters

index
Type: System..::..Int32
The zero-based index of the subregion.

Return Value

Type: CvsCompositeOperation
The operation of the subregion.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.Initialize Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..Initialize Method
CvsGraphicCompositeBase Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    CvsCompositeSubregion[] subRegions,
    string Label
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    subRegions As CvsCompositeSubregion(),
    Label As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
subRegions
Type: array< Cognex.InSight.Graphic..::..CvsCompositeSubregion >[]()[][]
Subregions which define the CompositeRegion.
Label
Type: System..::..String
The label to draw for this graphic

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.InsertAnnulus Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..InsertAnnulus Method
CvsGraphicCompositeBase Class See Also Send Feedback
Insert a subregion based on the provided CvsGraphicCircle object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeSubregion InsertAnnulus(
    int index,
    CvsGraphicAnnulus annulus,
    CvsCompositeOperation operation
)
Visual Basic
Public Function InsertAnnulus (
    index As Integer,
    annulus As CvsGraphicAnnulus,
    operation As CvsCompositeOperation
) As CvsCompositeSubregion

Parameters

index
Type: System..::..Int32
The index of the new region
annulus
Type: Cognex.InSight.Graphic..::..CvsGraphicAnnulus
The CvsGraphic object which defines the subregion shape
operation
Type: Cognex.InSight.Graphic..::..CvsCompositeOperation
The operation of the new subregion.

Return Value

Type: CvsCompositeSubregion
The new region.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.InsertCircle Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..InsertCircle Method
CvsGraphicCompositeBase Class See Also Send Feedback
Insert a subregion based on the provided CvsGraphicCircle object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeSubregion InsertCircle(
    int index,
    CvsGraphicCircle circle,
    CvsCompositeOperation operation
)
Visual Basic
Public Function InsertCircle (
    index As Integer,
    circle As CvsGraphicCircle,
    operation As CvsCompositeOperation
) As CvsCompositeSubregion

Parameters

index
Type: System..::..Int32
The index of the new region
circle
Type: Cognex.InSight.Graphic..::..CvsGraphicCircle
The CvsGraphic object which defines the subregion shape
operation
Type: Cognex.InSight.Graphic..::..CvsCompositeOperation
The operation of the new subregion.

Return Value

Type: CvsCompositeSubregion
The new region.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.InsertPolygon Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..InsertPolygon Method
CvsGraphicCompositeBase Class See Also Send Feedback
Insert a subregion based on the provided CvsGraphicCircle object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeSubregion InsertPolygon(
    int index,
    CvsGraphicPolygon polygon,
    CvsCompositeOperation operation
)
Visual Basic
Public Function InsertPolygon (
    index As Integer,
    polygon As CvsGraphicPolygon,
    operation As CvsCompositeOperation
) As CvsCompositeSubregion

Parameters

index
Type: System..::..Int32
The index of the new region
polygon
Type: Cognex.InSight.Graphic..::..CvsGraphicPolygon
The CvsGraphic object which defines the subregion shape
operation
Type: Cognex.InSight.Graphic..::..CvsCompositeOperation
The operation of the new subregion.

Return Value

Type: CvsCompositeSubregion
The new region.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.InsertRegion Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..InsertRegion Method
CvsGraphicCompositeBase Class See Also Send Feedback
Insert a subregion based on the provided CvsGraphicRegion object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeSubregion InsertRegion(
    int index,
    CvsGraphicRegion region,
    CvsCompositeOperation operation
)
Visual Basic
Public Function InsertRegion (
    index As Integer,
    region As CvsGraphicRegion,
    operation As CvsCompositeOperation
) As CvsCompositeSubregion

Parameters

index
Type: System..::..Int32
The index of the new region
region
Type: Cognex.InSight.Graphic..::..CvsGraphicRegion
The CvsGraphic object which defines the subregion shape
operation
Type: Cognex.InSight.Graphic..::..CvsCompositeOperation
The operation of the new subregion.

Return Value

Type: CvsCompositeSubregion
The new region.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.SetSubregionAnnulus Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..SetSubregionAnnulus Method
CvsGraphicCompositeBase Class See Also Send Feedback
Update the subregion using the provided CvsGraphicAnnulus object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetSubregionAnnulus(
    int index,
    CvsGraphicAnnulus annulus
)
Visual Basic
Public Sub SetSubregionAnnulus (
    index As Integer,
    annulus As CvsGraphicAnnulus
)

Parameters

index
Type: System..::..Int32
The index of the new region.
annulus
Type: Cognex.InSight.Graphic..::..CvsGraphicAnnulus
The CvsGraphic object which defines the subregion shape.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.SetSubregionCircle Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..SetSubregionCircle Method
CvsGraphicCompositeBase Class See Also Send Feedback
Update the subregion using the provided CvsGraphicCircle object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetSubregionCircle(
    int index,
    CvsGraphicCircle circle
)
Visual Basic
Public Sub SetSubregionCircle (
    index As Integer,
    circle As CvsGraphicCircle
)

Parameters

index
Type: System..::..Int32
The index of the new region.
circle
Type: Cognex.InSight.Graphic..::..CvsGraphicCircle
The CvsGraphic object which defines the subregion shape.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.SetSubregionOperation Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..SetSubregionOperation Method
CvsGraphicCompositeBase Class See Also Send Feedback
Modifies the operation of the specified subregion.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetSubregionOperation(
    int index,
    CvsCompositeOperation operation
)
Visual Basic
Public Sub SetSubregionOperation (
    index As Integer,
    operation As CvsCompositeOperation
)

Parameters

index
Type: System..::..Int32
The zero-based index of the subregion to modify.
operation
Type: Cognex.InSight.Graphic..::..CvsCompositeOperation
The operation of the modified subregion.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.SetSubregionPolygon Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..SetSubregionPolygon Method
CvsGraphicCompositeBase Class See Also Send Feedback
Insert a subregion based on the provided CvsGraphicPolygon object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetSubregionPolygon(
    int index,
    CvsGraphicPolygon polygon
)
Visual Basic
Public Sub SetSubregionPolygon (
    index As Integer,
    polygon As CvsGraphicPolygon
)

Parameters

index
Type: System..::..Int32
The index of the new region.
polygon
Type: Cognex.InSight.Graphic..::..CvsGraphicPolygon
The CvsGraphic object which defines the subregion shape.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.SetSubregionRegion Method

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..SetSubregionRegion Method
CvsGraphicCompositeBase Class See Also Send Feedback
Update the subregion using the provided CvsGraphicRegion object.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetSubregionRegion(
    int index,
    CvsGraphicRegion region
)
Visual Basic
Public Sub SetSubregionRegion (
    index As Integer,
    region As CvsGraphicRegion
)

Parameters

index
Type: System..::..Int32
The index of the new region.
region
Type: Cognex.InSight.Graphic..::..CvsGraphicRegion
The CvsGraphic object which defines the subregion shape.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase Properties

[image] [image]

In-Sight SDK
CvsGraphicCompositeBase Properties
CvsGraphicCompositeBase Class See Also Send Feedback

The CvsGraphicCompositeBase type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditFlags | Gets or sets the allowed edit modes for this graphic.
Protected property | Flags | Gets the flags for the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Subregions | Gets or sets the array of CvsCompositeSubregion objects which define this composite region.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)
Protected property | ValidEditFlags | Return the valid edit flags, PolylinePath and MaskedRegion have different valid flags.

See Also

CvsGraphicCompositeBase Class
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.EditFlags Property

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..EditFlags Property
CvsGraphicCompositeBase Class See Also Send Feedback
Gets or sets the allowed edit modes for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEditFlags EditFlags { get; set; }
Visual Basic
Public Property EditFlags As CvsEditFlags
    Get
    Set

Property Value

Type: CvsEditFlags

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.Subregions Property

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..Subregions Property
CvsGraphicCompositeBase Class See Also Send Feedback
Gets or sets the array of CvsCompositeSubregion objects which define this composite region.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCompositeSubregion[] Subregions { get; set; }
Visual Basic
Public Property Subregions As CvsCompositeSubregion()
    Get
    Set

Property Value

Type: array< CvsCompositeSubregion >[]()[][]

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase.ValidEditFlags Property

[image]

In-Sight SDK
CvsGraphicCompositeBase..::..ValidEditFlags Property
CvsGraphicCompositeBase Class See Also Send Feedback
Return the valid edit flags, PolylinePath and MaskedRegion have different valid flags.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
protected virtual CvsEditFlags ValidEditFlags { get; }
Visual Basic
Protected Overridable ReadOnly Property ValidEditFlags As CvsEditFlags
    Get

Property Value

Type: CvsEditFlags

See Also

CvsGraphicCompositeBase Class
CvsGraphicCompositeBase..::..CvsGraphicCompositeBase Members
Cognex.InSight.Graphic Namespace


CvsGraphicCompositeBase Events

[image] [image]

In-Sight SDK
CvsGraphicCompositeBase Events
CvsGraphicCompositeBase Class See Also Send Feedback

The CvsGraphicCompositeBase type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicCompositeBase Class
Cognex.InSight.Graphic Namespace


CvsGraphicCross Class

[image]

In-Sight SDK
CvsGraphicCross Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight cross graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicCross : CvsGraphic,
    ICvsEditableGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicCross
    Inherits CvsGraphic
    Implements ICvsEditableGraphic

Remarks

CvsGraphicCross objects are returned as items in a CvsGraphicCollection. They are generated by the Cross function.

A cross is an editable graphic and may be edited by a control and returned to the In-Sight sensor.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicCross

See Also

CvsGraphicCross..::..CvsGraphicCross Members
Cognex.InSight.Graphic Namespace


CvsGraphicCross Members

[image] [image]

In-Sight SDK
CvsGraphicCross Members
CvsGraphicCross Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicCross type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicCross()()()() | Initializes a new instance of the CvsGraphicCross class.
Public method | CvsGraphicCross(CvsGraphicCross) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicCross(CvsCellLocation, CvsImageLocation, Single, Single, Single, String) | Initializes a new instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | Angle | Gets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Center | Gets the location of the center of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | DrawArrows | Gets a value that determines if the graphic should be rendered with or without arrows.
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | Height | Gets the height (in pixels) of the graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)
Public property | Width | Gets the width (in pixels) of the graphic.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicCross Class
Cognex.InSight.Graphic Namespace


CvsGraphicCross Constructor

[image] [image]

In-Sight SDK
CvsGraphicCross Constructor
CvsGraphicCross Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicCross()()()() | Initializes a new instance of the CvsGraphicCross class.
Public method | CvsGraphicCross(CvsGraphicCross) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicCross(CvsCellLocation, CvsImageLocation, Single, Single, Single, String) | Initializes a new instance.

See Also

CvsGraphicCross Class
CvsGraphicCross..::..CvsGraphicCross Members
Cognex.InSight.Graphic Namespace


CvsGraphicCross Constructor

[image]

In-Sight SDK
CvsGraphicCross Constructor
CvsGraphicCross Class See Also Send Feedback
Initializes a new instance of the CvsGraphicCross class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicCross()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicCross Class
CvsGraphicCross..::..CvsGraphicCross Members
CvsGraphicCross Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCross Constructor (CvsGraphicCross)

[image]

In-Sight SDK
CvsGraphicCross Constructor (CvsGraphicCross)
CvsGraphicCross Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicCross(
    CvsGraphicCross graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicCross
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicCross
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicCross Class
CvsGraphicCross..::..CvsGraphicCross Members
CvsGraphicCross Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCross Constructor (CvsCellLocation, CvsImageLocation, Single, Single, Single, String)

[image]

In-Sight SDK
CvsGraphicCross Constructor (CvsCellLocation, CvsImageLocation, Single, Single, Single, String)
CvsGraphicCross Class See Also Send Feedback
Initializes a new instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicCross(
    CvsCellLocation cellLocation,
    CvsImageLocation center,
    float angle,
    float height,
    float width,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    center As CvsImageLocation,
    angle As Single,
    height As Single,
    width As Single,
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell location of the cross graphic.
center
Type: Cognex.InSight..::..CvsImageLocation
The center point of the cross graphic.
angle
Type: System..::..Single
The rotation angle of the cross graphic.
height
Type: System..::..Single
The height of the cross graphic.
width
Type: System..::..Single
The width of the cross graphic.
label
Type: System..::..String
The label of the cross graphic.

See Also

CvsGraphicCross Class
CvsGraphicCross..::..CvsGraphicCross Members
CvsGraphicCross Overload
Cognex.InSight.Graphic Namespace


CvsGraphicCross Methods

[image] [image]

In-Sight SDK
CvsGraphicCross Methods
CvsGraphicCross Class See Also Send Feedback

The CvsGraphicCross type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicCross Class
Cognex.InSight.Graphic Namespace


CvsGraphicCross.Initialize Method

[image]

In-Sight SDK
CvsGraphicCross..::..Initialize Method
CvsGraphicCross Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float centerRow,
    float centerCol,
    float crossAngle,
    float crossHeight,
    float crossWidth,
    string crossLabel
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    centerRow As Single,
    centerCol As Single,
    crossAngle As Single,
    crossHeight As Single,
    crossWidth As Single,
    crossLabel As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
centerRow
Type: System..::..Single
The cross' center row location.
centerCol
Type: System..::..Single
The cross' center column location.
crossAngle
Type: System..::..Single
The rotation angle of the cross graphic.
crossHeight
Type: System..::..Single
The height of the cross graphic.
crossWidth
Type: System..::..Single
The width of the cross graphic.
crossLabel
Type: System..::..String
The label of the cross graphic.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCross Class
CvsGraphicCross..::..CvsGraphicCross Members
Cognex.InSight.Graphic Namespace


CvsGraphicCross Properties

[image] [image]

In-Sight SDK
CvsGraphicCross Properties
CvsGraphicCross Class See Also Send Feedback

The CvsGraphicCross type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Center | Gets the location of the center of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | DrawArrows | Gets a value that determines if the graphic should be rendered with or without arrows.
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | Height | Gets the height (in pixels) of the graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)
Public property | Width | Gets the width (in pixels) of the graphic.

See Also

CvsGraphicCross Class
Cognex.InSight.Graphic Namespace


CvsGraphicCross.Angle Property

[image]

In-Sight SDK
CvsGraphicCross..::..Angle Property
CvsGraphicCross Class See Also Send Feedback
Gets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Angle { get; set; }
Visual Basic
Public Property Angle As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCross Class
CvsGraphicCross..::..CvsGraphicCross Members
Cognex.InSight.Graphic Namespace


CvsGraphicCross.Center Property

[image]

In-Sight SDK
CvsGraphicCross..::..Center Property
CvsGraphicCross Class See Also Send Feedback
Gets the location of the center of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Center { get; set; }
Visual Basic
Public Property Center As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCross Class
CvsGraphicCross..::..CvsGraphicCross Members
Cognex.InSight.Graphic Namespace


CvsGraphicCross.DrawArrows Property

[image]

In-Sight SDK
CvsGraphicCross..::..DrawArrows Property
CvsGraphicCross Class See Also Send Feedback
Gets a value that determines if the graphic should be rendered with or without arrows.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool DrawArrows { get; set; }
Visual Basic
Public Property DrawArrows As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Typically the Cross Graphic is rendered with arrows. If the Cross Graphic is not an editable graphic, then it is rendered with just lines.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCross Class
CvsGraphicCross..::..CvsGraphicCross Members
Cognex.InSight.Graphic Namespace


CvsGraphicCross.EditBounds Property

[image]

In-Sight SDK
CvsGraphicCross..::..EditBounds Property
CvsGraphicCross Class See Also Send Feedback
Gets or Sets the edit boundary for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle EditBounds { get; set; }
Visual Basic
Public Property EditBounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCross Class
CvsGraphicCross..::..CvsGraphicCross Members
Cognex.InSight.Graphic Namespace


CvsGraphicCross.EditFlags Property

[image]

In-Sight SDK
CvsGraphicCross..::..EditFlags Property
CvsGraphicCross Class See Also Send Feedback
Gets or Sets the allowed edit modes for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEditFlags EditFlags { get; set; }
Visual Basic
Public Property EditFlags As CvsEditFlags
    Get
    Set

Property Value

Type: CvsEditFlags

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCross Class
CvsGraphicCross..::..CvsGraphicCross Members
Cognex.InSight.Graphic Namespace


CvsGraphicCross.Height Property

[image]

In-Sight SDK
CvsGraphicCross..::..Height Property
CvsGraphicCross Class See Also Send Feedback
Gets the height (in pixels) of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Height { get; set; }
Visual Basic
Public Property Height As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCross Class
CvsGraphicCross..::..CvsGraphicCross Members
Cognex.InSight.Graphic Namespace


CvsGraphicCross.Width Property

[image]

In-Sight SDK
CvsGraphicCross..::..Width Property
CvsGraphicCross Class See Also Send Feedback
Gets the width (in pixels) of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Width { get; set; }
Visual Basic
Public Property Width As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicCross Class
CvsGraphicCross..::..CvsGraphicCross Members
Cognex.InSight.Graphic Namespace


CvsGraphicCross Events

[image] [image]

In-Sight SDK
CvsGraphicCross Events
CvsGraphicCross Class See Also Send Feedback

The CvsGraphicCross type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicCross Class
Cognex.InSight.Graphic Namespace


CvsGraphicDefectPoints Class

[image]

In-Sight SDK
CvsGraphicDefectPoints Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight polyline graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicDefectPoints : CvsGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicDefectPoints
    Inherits CvsGraphic

Remarks

CvsGraphicDefectPoints objects are returned as items in a CvsGraphicCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicDefectPoints

See Also

CvsGraphicDefectPoints..::..CvsGraphicDefectPoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicDefectPoints Members

[image] [image]

In-Sight SDK
CvsGraphicDefectPoints Members
CvsGraphicDefectPoints Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicDefectPoints type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicDefectPoints()()()() | Initializes a new instance of the CvsGraphicDefectPoints class.
Public method | CvsGraphicDefectPoints(CvsGraphicDefectPoints) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicDefectPoints(CvsCellLocation, array<CvsImageLocation>[]()[][]) | Initializes a new instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPoints | Returns the array of the points of the graphic.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | NumPoints | Gets the number of points within the polyline graphic.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicDefectPoints Class
Cognex.InSight.Graphic Namespace


CvsGraphicDefectPoints Constructor

[image] [image]

In-Sight SDK
CvsGraphicDefectPoints Constructor
CvsGraphicDefectPoints Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicDefectPoints()()()() | Initializes a new instance of the CvsGraphicDefectPoints class.
Public method | CvsGraphicDefectPoints(CvsGraphicDefectPoints) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicDefectPoints(CvsCellLocation, array<CvsImageLocation>[]()[][]) | Initializes a new instance.

See Also

CvsGraphicDefectPoints Class
CvsGraphicDefectPoints..::..CvsGraphicDefectPoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicDefectPoints Constructor

[image]

In-Sight SDK
CvsGraphicDefectPoints Constructor
CvsGraphicDefectPoints Class See Also Send Feedback
Initializes a new instance of the CvsGraphicDefectPoints class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicDefectPoints()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicDefectPoints Class
CvsGraphicDefectPoints..::..CvsGraphicDefectPoints Members
CvsGraphicDefectPoints Overload
Cognex.InSight.Graphic Namespace


CvsGraphicDefectPoints Constructor (CvsGraphicDefectPoints)

[image]

In-Sight SDK
CvsGraphicDefectPoints Constructor (CvsGraphicDefectPoints)
CvsGraphicDefectPoints Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicDefectPoints(
    CvsGraphicDefectPoints graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicDefectPoints
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicDefectPoints
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicDefectPoints Class
CvsGraphicDefectPoints..::..CvsGraphicDefectPoints Members
CvsGraphicDefectPoints Overload
Cognex.InSight.Graphic Namespace


CvsGraphicDefectPoints Constructor (CvsCellLocation, CvsImageLocation[])

[image]

In-Sight SDK
CvsGraphicDefectPoints Constructor (CvsCellLocation, array<CvsImageLocation>[]()[][])
CvsGraphicDefectPoints Class See Also Send Feedback
Initializes a new instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicDefectPoints(
    CvsCellLocation cellLocation,
    CvsImageLocation[] points
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    points As CvsImageLocation()
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell location of this graphic.
points
Type: array< Cognex.InSight..::..CvsImageLocation >[]()[][]
An array of points with which to initialize the graphic.

See Also

CvsGraphicDefectPoints Class
CvsGraphicDefectPoints..::..CvsGraphicDefectPoints Members
CvsGraphicDefectPoints Overload
Cognex.InSight.Graphic Namespace


CvsGraphicDefectPoints Methods

[image] [image]

In-Sight SDK
CvsGraphicDefectPoints Methods
CvsGraphicDefectPoints Class See Also Send Feedback

The CvsGraphicDefectPoints type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPoints | Returns the array of the points of the graphic.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicDefectPoints Class
Cognex.InSight.Graphic Namespace


CvsGraphicDefectPoints.GetPoints Method

[image]

In-Sight SDK
CvsGraphicDefectPoints..::..GetPoints Method
CvsGraphicDefectPoints Class See Also Send Feedback
Returns the array of the points of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation[] GetPoints()
Visual Basic
Public Function GetPoints As CvsImageLocation()

Return Value

Type: array< CvsImageLocation >[]()[][]
An array of point in which each point is a vertex of the polyline.

Remarks

Each Row designates the pixels from the top of the CvsImage. Each Column designates the pixels from the left side of the CvsImage.

See Also

CvsGraphicDefectPoints Class
CvsGraphicDefectPoints..::..CvsGraphicDefectPoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicDefectPoints.Initialize Method

[image]

In-Sight SDK
CvsGraphicDefectPoints..::..Initialize Method
CvsGraphicDefectPoints Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    CvsImageLocation[] points
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    points As CvsImageLocation()
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
points
Type: array< Cognex.InSight..::..CvsImageLocation >[]()[][]
The list of points.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicDefectPoints Class
CvsGraphicDefectPoints..::..CvsGraphicDefectPoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicDefectPoints Properties

[image] [image]

In-Sight SDK
CvsGraphicDefectPoints Properties
CvsGraphicDefectPoints Class See Also Send Feedback

The CvsGraphicDefectPoints type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | NumPoints | Gets the number of points within the polyline graphic.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicDefectPoints Class
Cognex.InSight.Graphic Namespace


CvsGraphicDefectPoints.NumPoints Property

[image]

In-Sight SDK
CvsGraphicDefectPoints..::..NumPoints Property
CvsGraphicDefectPoints Class See Also Send Feedback
Gets the number of points within the polyline graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NumPoints { get; }
Visual Basic
Public ReadOnly Property NumPoints As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicDefectPoints Class
CvsGraphicDefectPoints..::..CvsGraphicDefectPoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicDefectPoints Events

[image] [image]

In-Sight SDK
CvsGraphicDefectPoints Events
CvsGraphicDefectPoints Class See Also Send Feedback

The CvsGraphicDefectPoints type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicDefectPoints Class
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints Class

[image]

In-Sight SDK
CvsGraphicEdgePoints Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight edge points graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicEdgePoints : CvsGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicEdgePoints
    Inherits CvsGraphic

Remarks

CvsGraphicEdgePoints objects are returned as items in a CvsGraphicCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicEdgePoints

See Also

CvsGraphicEdgePoints..::..CvsGraphicEdgePoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints Members

[image] [image]

In-Sight SDK
CvsGraphicEdgePoints Members
CvsGraphicEdgePoints Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicEdgePoints type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicEdgePoints()()()() | Initializes a new instance of the CvsGraphicEdgePoints class.
Public method | CvsGraphicEdgePoints(CvsGraphicEdgePoints) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicEdgePoints(CvsCellLocation, array<CvsImageLocation>[]()[][]) | Initializes a new instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPoints | Returns the array of the points of the graphic.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | Filled | Indicates if the points should be filled when drawn.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | LineThickness | Indicates the preferred line thickness to use when drawn. If negative, then there is no preference.
Public property | NumPoints | Gets the number of points within the polyline graphic.
Public property | Radius | Indicates the preferred radius when drawn. If negative, then there is no preference.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicEdgePoints Class
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints Constructor

[image] [image]

In-Sight SDK
CvsGraphicEdgePoints Constructor
CvsGraphicEdgePoints Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicEdgePoints()()()() | Initializes a new instance of the CvsGraphicEdgePoints class.
Public method | CvsGraphicEdgePoints(CvsGraphicEdgePoints) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicEdgePoints(CvsCellLocation, array<CvsImageLocation>[]()[][]) | Initializes a new instance.

See Also

CvsGraphicEdgePoints Class
CvsGraphicEdgePoints..::..CvsGraphicEdgePoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints Constructor

[image]

In-Sight SDK
CvsGraphicEdgePoints Constructor
CvsGraphicEdgePoints Class See Also Send Feedback
Initializes a new instance of the CvsGraphicEdgePoints class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicEdgePoints()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicEdgePoints Class
CvsGraphicEdgePoints..::..CvsGraphicEdgePoints Members
CvsGraphicEdgePoints Overload
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints Constructor (CvsGraphicEdgePoints)

[image]

In-Sight SDK
CvsGraphicEdgePoints Constructor (CvsGraphicEdgePoints)
CvsGraphicEdgePoints Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicEdgePoints(
    CvsGraphicEdgePoints graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicEdgePoints
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicEdgePoints
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicEdgePoints Class
CvsGraphicEdgePoints..::..CvsGraphicEdgePoints Members
CvsGraphicEdgePoints Overload
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints Constructor (CvsCellLocation, CvsImageLocation[])

[image]

In-Sight SDK
CvsGraphicEdgePoints Constructor (CvsCellLocation, array<CvsImageLocation>[]()[][])
CvsGraphicEdgePoints Class See Also Send Feedback
Initializes a new instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicEdgePoints(
    CvsCellLocation cellLocation,
    CvsImageLocation[] points
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    points As CvsImageLocation()
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell location of this graphic.
points
Type: array< Cognex.InSight..::..CvsImageLocation >[]()[][]
An array of points with which to initialize the graphic.

See Also

CvsGraphicEdgePoints Class
CvsGraphicEdgePoints..::..CvsGraphicEdgePoints Members
CvsGraphicEdgePoints Overload
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints Methods

[image] [image]

In-Sight SDK
CvsGraphicEdgePoints Methods
CvsGraphicEdgePoints Class See Also Send Feedback

The CvsGraphicEdgePoints type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPoints | Returns the array of the points of the graphic.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicEdgePoints Class
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints.GetPoints Method

[image]

In-Sight SDK
CvsGraphicEdgePoints..::..GetPoints Method
CvsGraphicEdgePoints Class See Also Send Feedback
Returns the array of the points of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation[] GetPoints()
Visual Basic
Public Function GetPoints As CvsImageLocation()

Return Value

Type: array< CvsImageLocation >[]()[][]
An array of point in which each point is a vertex of the polyline.

Remarks

Each Row designates the pixels from the top of the CvsImage. Each Column designates the pixels from the left side of the CvsImage.

See Also

CvsGraphicEdgePoints Class
CvsGraphicEdgePoints..::..CvsGraphicEdgePoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints.Initialize Method

[image]

In-Sight SDK
CvsGraphicEdgePoints..::..Initialize Method
CvsGraphicEdgePoints Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    CvsImageLocation[] points
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    points As CvsImageLocation()
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
points
Type: array< Cognex.InSight..::..CvsImageLocation >[]()[][]
The list of points.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicEdgePoints Class
CvsGraphicEdgePoints..::..CvsGraphicEdgePoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints Properties

[image] [image]

In-Sight SDK
CvsGraphicEdgePoints Properties
CvsGraphicEdgePoints Class See Also Send Feedback

The CvsGraphicEdgePoints type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | Filled | Indicates if the points should be filled when drawn.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | LineThickness | Indicates the preferred line thickness to use when drawn. If negative, then there is no preference.
Public property | NumPoints | Gets the number of points within the polyline graphic.
Public property | Radius | Indicates the preferred radius when drawn. If negative, then there is no preference.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicEdgePoints Class
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints.Filled Property

[image]

In-Sight SDK
CvsGraphicEdgePoints..::..Filled Property
CvsGraphicEdgePoints Class See Also Send Feedback
Indicates if the points should be filled when drawn.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Filled { get; }
Visual Basic
Public ReadOnly Property Filled As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsGraphicEdgePoints Class
CvsGraphicEdgePoints..::..CvsGraphicEdgePoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints.LineThickness Property

[image]

In-Sight SDK
CvsGraphicEdgePoints..::..LineThickness Property
CvsGraphicEdgePoints Class See Also Send Feedback
Indicates the preferred line thickness to use when drawn. If negative, then there is no preference.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int LineThickness { get; }
Visual Basic
Public ReadOnly Property LineThickness As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicEdgePoints Class
CvsGraphicEdgePoints..::..CvsGraphicEdgePoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints.NumPoints Property

[image]

In-Sight SDK
CvsGraphicEdgePoints..::..NumPoints Property
CvsGraphicEdgePoints Class See Also Send Feedback
Gets the number of points within the polyline graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NumPoints { get; }
Visual Basic
Public ReadOnly Property NumPoints As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicEdgePoints Class
CvsGraphicEdgePoints..::..CvsGraphicEdgePoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints.Radius Property

[image]

In-Sight SDK
CvsGraphicEdgePoints..::..Radius Property
CvsGraphicEdgePoints Class See Also Send Feedback
Indicates the preferred radius when drawn. If negative, then there is no preference.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Radius { get; }
Visual Basic
Public ReadOnly Property Radius As Single
    Get

Property Value

Type: Single

See Also

CvsGraphicEdgePoints Class
CvsGraphicEdgePoints..::..CvsGraphicEdgePoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgePoints Events

[image] [image]

In-Sight SDK
CvsGraphicEdgePoints Events
CvsGraphicEdgePoints Class See Also Send Feedback

The CvsGraphicEdgePoints type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicEdgePoints Class
Cognex.InSight.Graphic Namespace


CvsGraphicEdgeProfile Class

[image]

In-Sight SDK
CvsGraphicEdgeProfile Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight edge profile graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicEdgeProfile : CvsGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicEdgeProfile
    Inherits CvsGraphic

Remarks

CvsGraphicEdgeProfile objects are returned as items in a CvsGraphicCollection. They are generated by the FindLine and FindMultiLine functions.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicEdgeProfile

See Also

CvsGraphicEdgeProfile..::..CvsGraphicEdgeProfile Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgeProfile Members

[image] [image]

In-Sight SDK
CvsGraphicEdgeProfile Members
CvsGraphicEdgeProfile Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicEdgeProfile type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicEdgeProfile | Initializes a new instance that is a copy of the specified instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEdgeValues | Gets the array of edge values.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | NegativeThreshold | Gets the negative threshold value.
Public property | NumEdgeValues | Gets the number of edge values returned by GetEdgeValues()()()().
Public property | PositiveThreshold | Gets the positive threshold value.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicEdgeProfile Class
Cognex.InSight.Graphic Namespace


CvsGraphicEdgeProfile Constructor

[image]

In-Sight SDK
CvsGraphicEdgeProfile Constructor
CvsGraphicEdgeProfile Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicEdgeProfile(
    CvsGraphicEdgeProfile graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicEdgeProfile
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicEdgeProfile
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicEdgeProfile Class
CvsGraphicEdgeProfile..::..CvsGraphicEdgeProfile Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgeProfile Methods

[image] [image]

In-Sight SDK
CvsGraphicEdgeProfile Methods
CvsGraphicEdgeProfile Class See Also Send Feedback

The CvsGraphicEdgeProfile type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEdgeValues | Gets the array of edge values.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicEdgeProfile Class
Cognex.InSight.Graphic Namespace


CvsGraphicEdgeProfile.GetEdgeValues Method

[image]

In-Sight SDK
CvsGraphicEdgeProfile..::..GetEdgeValues Method
CvsGraphicEdgeProfile Class See Also Send Feedback
Gets the array of edge values.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int[] GetEdgeValues()
Visual Basic
Public Function GetEdgeValues As Integer()

Return Value

Type: array< Int32 >[]()[][]
An array of integers that represent the edge values.

Remarks

The length of the array will correspond to the width of the associated region.

Each entry in the array is measured from the bottom of the edge chart.

See Also

CvsGraphicEdgeProfile Class
CvsGraphicEdgeProfile..::..CvsGraphicEdgeProfile Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgeProfile Properties

[image] [image]

In-Sight SDK
CvsGraphicEdgeProfile Properties
CvsGraphicEdgeProfile Class See Also Send Feedback

The CvsGraphicEdgeProfile type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | NegativeThreshold | Gets the negative threshold value.
Public property | NumEdgeValues | Gets the number of edge values returned by GetEdgeValues()()()().
Public property | PositiveThreshold | Gets the positive threshold value.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicEdgeProfile Class
Cognex.InSight.Graphic Namespace


CvsGraphicEdgeProfile.NegativeThreshold Property

[image]

In-Sight SDK
CvsGraphicEdgeProfile..::..NegativeThreshold Property
CvsGraphicEdgeProfile Class See Also Send Feedback
Gets the negative threshold value.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NegativeThreshold { get; }
Visual Basic
Public ReadOnly Property NegativeThreshold As Integer
    Get

Property Value

Type: Int32
The range is 0 to 100. The default is 40.

Remarks

For the FindLine function, this represents the negative Accept Threshold.

For the FindMultiLine function, this represents the negative W2B Threshold.

See Also

CvsGraphicEdgeProfile Class
CvsGraphicEdgeProfile..::..CvsGraphicEdgeProfile Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgeProfile.NumEdgeValues Property

[image]

In-Sight SDK
CvsGraphicEdgeProfile..::..NumEdgeValues Property
CvsGraphicEdgeProfile Class See Also Send Feedback
Gets the number of edge values returned by GetEdgeValues()()()().

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NumEdgeValues { get; }
Visual Basic
Public ReadOnly Property NumEdgeValues As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicEdgeProfile Class
CvsGraphicEdgeProfile..::..CvsGraphicEdgeProfile Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgeProfile.PositiveThreshold Property

[image]

In-Sight SDK
CvsGraphicEdgeProfile..::..PositiveThreshold Property
CvsGraphicEdgeProfile Class See Also Send Feedback
Gets the positive threshold value.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int PositiveThreshold { get; }
Visual Basic
Public ReadOnly Property PositiveThreshold As Integer
    Get

Property Value

Type: Int32
The range is 0 to 100. The default is 40.

Remarks

For the FindLine function, this represents the Accept Threshold.

For the FindMultiLine function, this represents the B2W Threshold.

See Also

CvsGraphicEdgeProfile Class
CvsGraphicEdgeProfile..::..CvsGraphicEdgeProfile Members
Cognex.InSight.Graphic Namespace


CvsGraphicEdgeProfile Events

[image] [image]

In-Sight SDK
CvsGraphicEdgeProfile Events
CvsGraphicEdgeProfile Class See Also Send Feedback

The CvsGraphicEdgeProfile type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicEdgeProfile Class
Cognex.InSight.Graphic Namespace


CvsGraphicExtremePoints Class

[image]

In-Sight SDK
CvsGraphicExtremePoints Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight polyline graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicExtremePoints : CvsGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicExtremePoints
    Inherits CvsGraphic

Remarks

CvsGraphicDefectPoints objects are returned as items in a CvsGraphicCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicExtremePoints

See Also

CvsGraphicExtremePoints..::..CvsGraphicExtremePoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicExtremePoints Members

[image] [image]

In-Sight SDK
CvsGraphicExtremePoints Members
CvsGraphicExtremePoints Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicExtremePoints type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicExtremePoints()()()() | Initializes a new instance of the CvsGraphicExtremePoints class.
Public method | CvsGraphicExtremePoints(CvsGraphicExtremePoints) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicExtremePoints(CvsCellLocation, array<CvsImageLocation>[]()[][]) | Initializes a new instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPoints | Returns the array of the points of the graphic.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | NumPoints | Gets the number of points within the polyline graphic.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicExtremePoints Class
Cognex.InSight.Graphic Namespace


CvsGraphicExtremePoints Constructor

[image] [image]

In-Sight SDK
CvsGraphicExtremePoints Constructor
CvsGraphicExtremePoints Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicExtremePoints()()()() | Initializes a new instance of the CvsGraphicExtremePoints class.
Public method | CvsGraphicExtremePoints(CvsGraphicExtremePoints) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicExtremePoints(CvsCellLocation, array<CvsImageLocation>[]()[][]) | Initializes a new instance.

See Also

CvsGraphicExtremePoints Class
CvsGraphicExtremePoints..::..CvsGraphicExtremePoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicExtremePoints Constructor

[image]

In-Sight SDK
CvsGraphicExtremePoints Constructor
CvsGraphicExtremePoints Class See Also Send Feedback
Initializes a new instance of the CvsGraphicExtremePoints class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicExtremePoints()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicExtremePoints Class
CvsGraphicExtremePoints..::..CvsGraphicExtremePoints Members
CvsGraphicExtremePoints Overload
Cognex.InSight.Graphic Namespace


CvsGraphicExtremePoints Constructor (CvsGraphicExtremePoints)

[image]

In-Sight SDK
CvsGraphicExtremePoints Constructor (CvsGraphicExtremePoints)
CvsGraphicExtremePoints Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicExtremePoints(
    CvsGraphicExtremePoints graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicExtremePoints
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicExtremePoints
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicExtremePoints Class
CvsGraphicExtremePoints..::..CvsGraphicExtremePoints Members
CvsGraphicExtremePoints Overload
Cognex.InSight.Graphic Namespace


CvsGraphicExtremePoints Constructor (CvsCellLocation, CvsImageLocation[])

[image]

In-Sight SDK
CvsGraphicExtremePoints Constructor (CvsCellLocation, array<CvsImageLocation>[]()[][])
CvsGraphicExtremePoints Class See Also Send Feedback
Initializes a new instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicExtremePoints(
    CvsCellLocation cellLocation,
    CvsImageLocation[] points
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    points As CvsImageLocation()
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell location of this graphic.
points
Type: array< Cognex.InSight..::..CvsImageLocation >[]()[][]
An array of points with which to initialize the graphic.

See Also

CvsGraphicExtremePoints Class
CvsGraphicExtremePoints..::..CvsGraphicExtremePoints Members
CvsGraphicExtremePoints Overload
Cognex.InSight.Graphic Namespace


CvsGraphicExtremePoints Methods

[image] [image]

In-Sight SDK
CvsGraphicExtremePoints Methods
CvsGraphicExtremePoints Class See Also Send Feedback

The CvsGraphicExtremePoints type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPoints | Returns the array of the points of the graphic.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicExtremePoints Class
Cognex.InSight.Graphic Namespace


CvsGraphicExtremePoints.GetPoints Method

[image]

In-Sight SDK
CvsGraphicExtremePoints..::..GetPoints Method
CvsGraphicExtremePoints Class See Also Send Feedback
Returns the array of the points of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation[] GetPoints()
Visual Basic
Public Function GetPoints As CvsImageLocation()

Return Value

Type: array< CvsImageLocation >[]()[][]
An array of point in which each point is a vertex of the polyline.

Remarks

Each Row designates the pixels from the top of the CvsImage. Each Column designates the pixels from the left side of the CvsImage.

See Also

CvsGraphicExtremePoints Class
CvsGraphicExtremePoints..::..CvsGraphicExtremePoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicExtremePoints.Initialize Method

[image]

In-Sight SDK
CvsGraphicExtremePoints..::..Initialize Method
CvsGraphicExtremePoints Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    CvsImageLocation[] points
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    points As CvsImageLocation()
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
points
Type: array< Cognex.InSight..::..CvsImageLocation >[]()[][]
The list of points.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicExtremePoints Class
CvsGraphicExtremePoints..::..CvsGraphicExtremePoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicExtremePoints Properties

[image] [image]

In-Sight SDK
CvsGraphicExtremePoints Properties
CvsGraphicExtremePoints Class See Also Send Feedback

The CvsGraphicExtremePoints type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | NumPoints | Gets the number of points within the polyline graphic.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicExtremePoints Class
Cognex.InSight.Graphic Namespace


CvsGraphicExtremePoints.NumPoints Property

[image]

In-Sight SDK
CvsGraphicExtremePoints..::..NumPoints Property
CvsGraphicExtremePoints Class See Also Send Feedback
Gets the number of points within the polyline graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NumPoints { get; }
Visual Basic
Public ReadOnly Property NumPoints As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicExtremePoints Class
CvsGraphicExtremePoints..::..CvsGraphicExtremePoints Members
Cognex.InSight.Graphic Namespace


CvsGraphicExtremePoints Events

[image] [image]

In-Sight SDK
CvsGraphicExtremePoints Events
CvsGraphicExtremePoints Class See Also Send Feedback

The CvsGraphicExtremePoints type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicExtremePoints Class
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox Class

[image]

In-Sight SDK
CvsGraphicFilledBox Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight filled box graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicFilledBox : CvsGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicFilledBox
    Inherits CvsGraphic

Remarks

CvsGraphicFilledBox objects are returned as items in a CvsGraphicCollection. They are generated by the FlawDetect function.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicFilledBox

See Also

CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox Members

[image] [image]

In-Sight SDK
CvsGraphicFilledBox Members
CvsGraphicFilledBox Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicFilledBox type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicFilledBox()()()() | Initializes a new instance of the CvsGraphicFilledBox class.
Public method | CvsGraphicFilledBox(CvsGraphicFilledBox) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicFilledBox(CvsCellLocation, CvsImageLocation, Single, Single, Single, Single, String) | Initializes a new instance of the CvsGraphicFilledBox class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | Angle | Gets or sets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | Curve | Gets or sets the curve of the graphic. The curve is the angular deviation between the region's vertical axis and the opposing boundary line.
Public property | Height | Gets or sets the height (in pixels) of the graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | LabelBackColor | Gets or sets the text label background color associated with the graphic, or Color.Empty if no color was specified.
Public property | LabelBackColorAsRgb | Gets or sets the LabelBackColor as an RGB value.
Public property | LabelForeColor | Gets or sets the text label foreground color associated with the graphic, or Color.Empty if no color was specified.
Public property | LabelForeColorAsRgb | Gets or sets the LabelForeColor as an RGB value.
Public property | Location | Gets or sets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)
Public property | Width | Gets or sets the width (in pixels) of the graphic.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicFilledBox Class
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox Constructor

[image] [image]

In-Sight SDK
CvsGraphicFilledBox Constructor
CvsGraphicFilledBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicFilledBox()()()() | Initializes a new instance of the CvsGraphicFilledBox class.
Public method | CvsGraphicFilledBox(CvsGraphicFilledBox) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicFilledBox(CvsCellLocation, CvsImageLocation, Single, Single, Single, Single, String) | Initializes a new instance of the CvsGraphicFilledBox class.

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox Constructor

[image]

In-Sight SDK
CvsGraphicFilledBox Constructor
CvsGraphicFilledBox Class See Also Send Feedback
Initializes a new instance of the CvsGraphicFilledBox class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicFilledBox()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
CvsGraphicFilledBox Overload
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox Constructor (CvsGraphicFilledBox)

[image]

In-Sight SDK
CvsGraphicFilledBox Constructor (CvsGraphicFilledBox)
CvsGraphicFilledBox Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicFilledBox(
    CvsGraphicFilledBox graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicFilledBox
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicFilledBox
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
CvsGraphicFilledBox Overload
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox Constructor (CvsCellLocation, CvsImageLocation, Single, Single, Single, Single, String)

[image]

In-Sight SDK
CvsGraphicFilledBox Constructor (CvsCellLocation, CvsImageLocation, Single, Single, Single, Single, String)
CvsGraphicFilledBox Class See Also Send Feedback
Initializes a new instance of the CvsGraphicFilledBox class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicFilledBox(
    CvsCellLocation cellLocation,
    CvsImageLocation location,
    float height,
    float width,
    float angle,
    float curve,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    location As CvsImageLocation,
    height As Single,
    width As Single,
    angle As Single,
    curve As Single,
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
location
Type: Cognex.InSight..::..CvsImageLocation
The offset of the region in pixels.
height
Type: System..::..Single
The height of the region in pixels.
width
Type: System..::..Single
The width of the region in pixels.
angle
Type: System..::..Single
The orientation (angle) of the region.
curve
Type: System..::..Single
The curve of the region.
label
Type: System..::..String
The label associated with this region.

Remarks

The graphic constructed may be passed to the SetEditGraphic(CvsGraphic) method to set the graphic associated with an edit cell function.

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
CvsGraphicFilledBox Overload
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox Methods

[image] [image]

In-Sight SDK
CvsGraphicFilledBox Methods
CvsGraphicFilledBox Class See Also Send Feedback

The CvsGraphicFilledBox type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicFilledBox Class
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox.Initialize Method

[image]

In-Sight SDK
CvsGraphicFilledBox..::..Initialize Method
CvsGraphicFilledBox Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float regionRow,
    float regionCol,
    float regionHeight,
    float regionWidth,
    float regionAngle,
    float regionCurve,
    string regionLabel
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    regionRow As Single,
    regionCol As Single,
    regionHeight As Single,
    regionWidth As Single,
    regionAngle As Single,
    regionCurve As Single,
    regionLabel As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
regionRow
Type: System..::..Single
The region's row location.
regionCol
Type: System..::..Single
The region's column location.
regionHeight
Type: System..::..Single
The height of the region in pixels.
regionWidth
Type: System..::..Single
The width of the region in pixels.
regionAngle
Type: System..::..Single
The orientation (angle) of the region.
regionCurve
Type: System..::..Single
The curve of the region.
regionLabel
Type: System..::..String
The label associated with this region.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox Properties

[image] [image]

In-Sight SDK
CvsGraphicFilledBox Properties
CvsGraphicFilledBox Class See Also Send Feedback

The CvsGraphicFilledBox type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets or sets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | Curve | Gets or sets the curve of the graphic. The curve is the angular deviation between the region's vertical axis and the opposing boundary line.
Public property | Height | Gets or sets the height (in pixels) of the graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | LabelBackColor | Gets or sets the text label background color associated with the graphic, or Color.Empty if no color was specified.
Public property | LabelBackColorAsRgb | Gets or sets the LabelBackColor as an RGB value.
Public property | LabelForeColor | Gets or sets the text label foreground color associated with the graphic, or Color.Empty if no color was specified.
Public property | LabelForeColorAsRgb | Gets or sets the LabelForeColor as an RGB value.
Public property | Location | Gets or sets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)
Public property | Width | Gets or sets the width (in pixels) of the graphic.

See Also

CvsGraphicFilledBox Class
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox.Angle Property

[image]

In-Sight SDK
CvsGraphicFilledBox..::..Angle Property
CvsGraphicFilledBox Class See Also Send Feedback
Gets or sets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Angle { get; set; }
Visual Basic
Public Property Angle As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox.Curve Property

[image]

In-Sight SDK
CvsGraphicFilledBox..::..Curve Property
CvsGraphicFilledBox Class See Also Send Feedback
Gets or sets the curve of the graphic. The curve is the angular deviation between the region's vertical axis and the opposing boundary line.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Curve { get; set; }
Visual Basic
Public Property Curve As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox.Height Property

[image]

In-Sight SDK
CvsGraphicFilledBox..::..Height Property
CvsGraphicFilledBox Class See Also Send Feedback
Gets or sets the height (in pixels) of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Height { get; set; }
Visual Basic
Public Property Height As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox.LabelBackColor Property

[image]

In-Sight SDK
CvsGraphicFilledBox..::..LabelBackColor Property
CvsGraphicFilledBox Class See Also Send Feedback
Gets or sets the text label background color associated with the graphic, or Color.Empty if no color was specified.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color LabelBackColor { get; set; }
Visual Basic
Public Property LabelBackColor As Color
    Get
    Set

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox.LabelBackColorAsRgb Property

[image]

In-Sight SDK
CvsGraphicFilledBox..::..LabelBackColorAsRgb Property
CvsGraphicFilledBox Class See Also Send Feedback
Gets or sets the LabelBackColor as an RGB value.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int LabelBackColorAsRgb { get; set; }
Visual Basic
Public Property LabelBackColorAsRgb As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox.LabelForeColor Property

[image]

In-Sight SDK
CvsGraphicFilledBox..::..LabelForeColor Property
CvsGraphicFilledBox Class See Also Send Feedback
Gets or sets the text label foreground color associated with the graphic, or Color.Empty if no color was specified.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color LabelForeColor { get; set; }
Visual Basic
Public Property LabelForeColor As Color
    Get
    Set

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox.LabelForeColorAsRgb Property

[image]

In-Sight SDK
CvsGraphicFilledBox..::..LabelForeColorAsRgb Property
CvsGraphicFilledBox Class See Also Send Feedback
Gets or sets the LabelForeColor as an RGB value.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int LabelForeColorAsRgb { get; set; }
Visual Basic
Public Property LabelForeColorAsRgb As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox.Location Property

[image]

In-Sight SDK
CvsGraphicFilledBox..::..Location Property
CvsGraphicFilledBox Class See Also Send Feedback
Gets or sets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Location { get; set; }
Visual Basic
Public Property Location As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox.Width Property

[image]

In-Sight SDK
CvsGraphicFilledBox..::..Width Property
CvsGraphicFilledBox Class See Also Send Feedback
Gets or sets the width (in pixels) of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Width { get; set; }
Visual Basic
Public Property Width As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFilledBox Class
CvsGraphicFilledBox..::..CvsGraphicFilledBox Members
Cognex.InSight.Graphic Namespace


CvsGraphicFilledBox Events

[image] [image]

In-Sight SDK
CvsGraphicFilledBox Events
CvsGraphicFilledBox Class See Also Send Feedback

The CvsGraphicFilledBox type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicFilledBox Class
Cognex.InSight.Graphic Namespace


CvsGraphicFixture Class

[image]

In-Sight SDK
CvsGraphicFixture Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight fixture graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicFixture : CvsGraphic,
    ICvsEditableGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicFixture
    Inherits CvsGraphic
    Implements ICvsEditableGraphic

Remarks

CvsGraphicFixture objects are returned as items in a CvsGraphicCollection. They are generated by the Fixture function.

A fixture is an editable graphic and may be edited by a control and returned to the In-Sight sensor.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicFixture

See Also

CvsGraphicFixture..::..CvsGraphicFixture Members
Cognex.InSight.Graphic Namespace


CvsGraphicFixture Members

[image] [image]

In-Sight SDK
CvsGraphicFixture Members
CvsGraphicFixture Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicFixture type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicFixture()()()() | Initializes a new instance of the CvsGraphicFixture class.
Public method | CvsGraphicFixture(CvsGraphicFixture) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicFixture(CvsCellLocation, CvsImageLocation, Single, String) | Initializes a new instance that is a copy of the specified instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Center | Gets or sets the center of the fixture. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Theta | Gets or sets the orientation (angle) of the fixture. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicFixture Class
Cognex.InSight.Graphic Namespace


CvsGraphicFixture Constructor

[image] [image]

In-Sight SDK
CvsGraphicFixture Constructor
CvsGraphicFixture Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicFixture()()()() | Initializes a new instance of the CvsGraphicFixture class.
Public method | CvsGraphicFixture(CvsGraphicFixture) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicFixture(CvsCellLocation, CvsImageLocation, Single, String) | Initializes a new instance that is a copy of the specified instance.

See Also

CvsGraphicFixture Class
CvsGraphicFixture..::..CvsGraphicFixture Members
Cognex.InSight.Graphic Namespace


CvsGraphicFixture Constructor

[image]

In-Sight SDK
CvsGraphicFixture Constructor
CvsGraphicFixture Class See Also Send Feedback
Initializes a new instance of the CvsGraphicFixture class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicFixture()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicFixture Class
CvsGraphicFixture..::..CvsGraphicFixture Members
CvsGraphicFixture Overload
Cognex.InSight.Graphic Namespace


CvsGraphicFixture Constructor (CvsGraphicFixture)

[image]

In-Sight SDK
CvsGraphicFixture Constructor (CvsGraphicFixture)
CvsGraphicFixture Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicFixture(
    CvsGraphicFixture graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicFixture
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicFixture
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicFixture Class
CvsGraphicFixture..::..CvsGraphicFixture Members
CvsGraphicFixture Overload
Cognex.InSight.Graphic Namespace


CvsGraphicFixture Constructor (CvsCellLocation, CvsImageLocation, Single, String)

[image]

In-Sight SDK
CvsGraphicFixture Constructor (CvsCellLocation, CvsImageLocation, Single, String)
CvsGraphicFixture Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicFixture(
    CvsCellLocation cellLocation,
    CvsImageLocation point,
    float angle,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    point As CvsImageLocation,
    angle As Single,
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The In-Sight cell location of this graphic.
point
Type: Cognex.InSight..::..CvsImageLocation
The point of this fixture graphic.
angle
Type: System..::..Single
The angle of this fixture.
label
Type: System..::..String
The label to display with this fixture.

See Also

CvsGraphicFixture Class
CvsGraphicFixture..::..CvsGraphicFixture Members
CvsGraphicFixture Overload
Cognex.InSight.Graphic Namespace


CvsGraphicFixture Methods

[image] [image]

In-Sight SDK
CvsGraphicFixture Methods
CvsGraphicFixture Class See Also Send Feedback

The CvsGraphicFixture type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicFixture Class
Cognex.InSight.Graphic Namespace


CvsGraphicFixture.Initialize Method

[image]

In-Sight SDK
CvsGraphicFixture..::..Initialize Method
CvsGraphicFixture Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float pointRow,
    float pointCol,
    float angle,
    string label
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    pointRow As Single,
    pointCol As Single,
    angle As Single,
    label As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
pointRow
Type: System..::..Single
The fixture's point row location.
pointCol
Type: System..::..Single
The fixture's point column location.
angle
Type: System..::..Single
The angle of this fixture.
label
Type: System..::..String
The label to display with this fixture.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFixture Class
CvsGraphicFixture..::..CvsGraphicFixture Members
Cognex.InSight.Graphic Namespace


CvsGraphicFixture Properties

[image] [image]

In-Sight SDK
CvsGraphicFixture Properties
CvsGraphicFixture Class See Also Send Feedback

The CvsGraphicFixture type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Center | Gets or sets the center of the fixture. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Theta | Gets or sets the orientation (angle) of the fixture. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicFixture Class
Cognex.InSight.Graphic Namespace


CvsGraphicFixture.Center Property

[image]

In-Sight SDK
CvsGraphicFixture..::..Center Property
CvsGraphicFixture Class See Also Send Feedback
Gets or sets the center of the fixture. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Center { get; set; }
Visual Basic
Public Property Center As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFixture Class
CvsGraphicFixture..::..CvsGraphicFixture Members
Cognex.InSight.Graphic Namespace


CvsGraphicFixture.EditBounds Property

[image]

In-Sight SDK
CvsGraphicFixture..::..EditBounds Property
CvsGraphicFixture Class See Also Send Feedback
Gets or Sets the edit boundary for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle EditBounds { get; set; }
Visual Basic
Public Property EditBounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFixture Class
CvsGraphicFixture..::..CvsGraphicFixture Members
Cognex.InSight.Graphic Namespace


CvsGraphicFixture.EditFlags Property

[image]

In-Sight SDK
CvsGraphicFixture..::..EditFlags Property
CvsGraphicFixture Class See Also Send Feedback
Gets or Sets the allowed edit modes for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEditFlags EditFlags { get; set; }
Visual Basic
Public Property EditFlags As CvsEditFlags
    Get
    Set

Property Value

Type: CvsEditFlags

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFixture Class
CvsGraphicFixture..::..CvsGraphicFixture Members
Cognex.InSight.Graphic Namespace


CvsGraphicFixture.Theta Property

[image]

In-Sight SDK
CvsGraphicFixture..::..Theta Property
CvsGraphicFixture Class See Also Send Feedback
Gets or sets the orientation (angle) of the fixture. The angle is measured counter-clockwise relative to the horizontal axis.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Theta { get; set; }
Visual Basic
Public Property Theta As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicFixture Class
CvsGraphicFixture..::..CvsGraphicFixture Members
Cognex.InSight.Graphic Namespace


CvsGraphicFixture Events

[image] [image]

In-Sight SDK
CvsGraphicFixture Events
CvsGraphicFixture Class See Also Send Feedback

The CvsGraphicFixture type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicFixture Class
Cognex.InSight.Graphic Namespace


CvsGraphicHistogram Class

[image]

In-Sight SDK
CvsGraphicHistogram Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight graphical histogram.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicHistogram : CvsGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicHistogram
    Inherits CvsGraphic

Remarks

CvsGraphicHistogram objects are returned as items in a CvsGraphicCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicHistogram

See Also

CvsGraphicHistogram..::..CvsGraphicHistogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicHistogram Members

[image] [image]

In-Sight SDK
CvsGraphicHistogram Members
CvsGraphicHistogram Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicHistogram type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicHistogram | Initializes a new instance that is a copy of the specified instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetHistogram | Returns the histogram with each index representing a count of pixels.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Threshold | Gets the binary threshold of the histogram.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicHistogram Class
Cognex.InSight.Graphic Namespace


CvsGraphicHistogram Constructor

[image]

In-Sight SDK
CvsGraphicHistogram Constructor
CvsGraphicHistogram Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicHistogram(
    CvsGraphicHistogram graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicHistogram
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicHistogram
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicHistogram Class
CvsGraphicHistogram..::..CvsGraphicHistogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicHistogram Methods

[image] [image]

In-Sight SDK
CvsGraphicHistogram Methods
CvsGraphicHistogram Class See Also Send Feedback

The CvsGraphicHistogram type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetHistogram | Returns the histogram with each index representing a count of pixels.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicHistogram Class
Cognex.InSight.Graphic Namespace


CvsGraphicHistogram.GetHistogram Method

[image]

In-Sight SDK
CvsGraphicHistogram..::..GetHistogram Method
CvsGraphicHistogram Class See Also Send Feedback
Returns the histogram with each index representing a count of pixels.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int[] GetHistogram()
Visual Basic
Public Function GetHistogram As Integer()

Return Value

Type: array< Int32 >[]()[][]
An array of integers that represent the histogram.

See Also

CvsGraphicHistogram Class
CvsGraphicHistogram..::..CvsGraphicHistogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicHistogram Properties

[image] [image]

In-Sight SDK
CvsGraphicHistogram Properties
CvsGraphicHistogram Class See Also Send Feedback

The CvsGraphicHistogram type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Threshold | Gets the binary threshold of the histogram.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicHistogram Class
Cognex.InSight.Graphic Namespace


CvsGraphicHistogram.Threshold Property

[image]

In-Sight SDK
CvsGraphicHistogram..::..Threshold Property
CvsGraphicHistogram Class See Also Send Feedback
Gets the binary threshold of the histogram.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Threshold { get; }
Visual Basic
Public ReadOnly Property Threshold As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicHistogram Class
CvsGraphicHistogram..::..CvsGraphicHistogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicHistogram Events

[image] [image]

In-Sight SDK
CvsGraphicHistogram Events
CvsGraphicHistogram Class See Also Send Feedback

The CvsGraphicHistogram type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicHistogram Class
Cognex.InSight.Graphic Namespace


CvsGraphicImage Class

[image]

In-Sight SDK
CvsGraphicImage Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight Image graphic

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicImage : CvsGraphic,
    IDisposable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicImage
    Inherits CvsGraphic
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicImage

See Also

CvsGraphicImage..::..CvsGraphicImage Members
Cognex.InSight.Graphic Namespace


CvsGraphicImage Members

[image] [image]

In-Sight SDK
CvsGraphicImage Members
CvsGraphicImage Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicImage type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicImage(CvsGraphicImage) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicImage(CvsImage) | Initializes a new instance using the provided image.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Dispose | Disposes the associated Image.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | Image | Gets the image data associated with this image graphic
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | IsResultImage | True if this image represents the result of an image processing operation
Public property | IsSourceImage | True if this image represents a source image of the current function
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicImage Class
Cognex.InSight.Graphic Namespace


CvsGraphicImage Constructor

[image] [image]

In-Sight SDK
CvsGraphicImage Constructor
CvsGraphicImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicImage(CvsGraphicImage) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicImage(CvsImage) | Initializes a new instance using the provided image.

See Also

CvsGraphicImage Class
CvsGraphicImage..::..CvsGraphicImage Members
Cognex.InSight.Graphic Namespace


CvsGraphicImage Constructor (CvsGraphicImage)

[image]

In-Sight SDK
CvsGraphicImage Constructor (CvsGraphicImage)
CvsGraphicImage Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicImage(
    CvsGraphicImage graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicImage
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicImage
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicImage Class
CvsGraphicImage..::..CvsGraphicImage Members
CvsGraphicImage Overload
Cognex.InSight.Graphic Namespace


CvsGraphicImage Constructor (CvsImage)

[image]

In-Sight SDK
CvsGraphicImage Constructor (CvsImage)
CvsGraphicImage Class See Also Send Feedback
Initializes a new instance using the provided image.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicImage(
    CvsImage image
)
Visual Basic
Public Sub New (
    image As CvsImage
)

Parameters

image
Type: Cognex.InSight..::..CvsImage
The source image.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicImage Class
CvsGraphicImage..::..CvsGraphicImage Members
CvsGraphicImage Overload
Cognex.InSight.Graphic Namespace


CvsGraphicImage Methods

[image] [image]

In-Sight SDK
CvsGraphicImage Methods
CvsGraphicImage Class See Also Send Feedback

The CvsGraphicImage type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Dispose | Disposes the associated Image.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicImage Class
Cognex.InSight.Graphic Namespace


CvsGraphicImage.Dispose Method

[image]

In-Sight SDK
CvsGraphicImage..::..Dispose Method
CvsGraphicImage Class See Also Send Feedback
Disposes the associated Image.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

CvsGraphicImage Class
CvsGraphicImage..::..CvsGraphicImage Members
Cognex.InSight.Graphic Namespace


CvsGraphicImage Properties

[image] [image]

In-Sight SDK
CvsGraphicImage Properties
CvsGraphicImage Class See Also Send Feedback

The CvsGraphicImage type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | Image | Gets the image data associated with this image graphic
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | IsResultImage | True if this image represents the result of an image processing operation
Public property | IsSourceImage | True if this image represents a source image of the current function
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicImage Class
Cognex.InSight.Graphic Namespace


CvsGraphicImage.Image Property

[image]

In-Sight SDK
CvsGraphicImage..::..Image Property
CvsGraphicImage Class See Also Send Feedback
Gets the image data associated with this image graphic

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImage Image { get; }
Visual Basic
Public ReadOnly Property Image As CvsImage
    Get

Property Value

Type: CvsImage

See Also

CvsGraphicImage Class
CvsGraphicImage..::..CvsGraphicImage Members
Cognex.InSight.Graphic Namespace


CvsGraphicImage.IsResultImage Property

[image]

In-Sight SDK
CvsGraphicImage..::..IsResultImage Property
CvsGraphicImage Class See Also Send Feedback
True if this image represents the result of an image processing operation

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsResultImage { get; }
Visual Basic
Public ReadOnly Property IsResultImage As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsGraphicImage Class
CvsGraphicImage..::..CvsGraphicImage Members
Cognex.InSight.Graphic Namespace


CvsGraphicImage.IsSourceImage Property

[image]

In-Sight SDK
CvsGraphicImage..::..IsSourceImage Property
CvsGraphicImage Class See Also Send Feedback
True if this image represents a source image of the current function

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsSourceImage { get; }
Visual Basic
Public ReadOnly Property IsSourceImage As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsGraphicImage Class
CvsGraphicImage..::..CvsGraphicImage Members
Cognex.InSight.Graphic Namespace


CvsGraphicImage Events

[image] [image]

In-Sight SDK
CvsGraphicImage Events
CvsGraphicImage Class See Also Send Feedback

The CvsGraphicImage type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicImage Class
Cognex.InSight.Graphic Namespace


CvsGraphicLine Class

[image]

In-Sight SDK
CvsGraphicLine Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight line graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicLine : CvsGraphic,
    ICvsEditableGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicLine
    Inherits CvsGraphic
    Implements ICvsEditableGraphic

Remarks

CvsGraphicLine objects are returned as items in a CvsGraphicCollection. They are generated by the PointToLine, LineToLine, LineToCircle, and Line functions.

A line is an editable graphic and may be edited by a control and returned to the In-Sight sensor.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicLine

See Also

CvsGraphicLine..::..CvsGraphicLine Members
Cognex.InSight.Graphic Namespace


CvsGraphicLine Members

[image] [image]

In-Sight SDK
CvsGraphicLine Members
CvsGraphicLine Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicLine type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicLine()()()() | Initializes a new instance of the CvsGraphicLine class.
Public method | CvsGraphicLine(CvsGraphicLine) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicLine(CvsCellLocation, CvsImageLocation, CvsImageLocation, String) | Initializes a new instance of the CvsGraphicLine class.
Public method | CvsGraphicLine(CvsCellLocation, CvsImageLocation, CvsImageLocation, String, CvsGraphicLineAdornment, CvsGraphicLineAdornment) | Initializes a new instance of the CvsGraphicLine class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize(Int32, Int32, Single, Single, Single, Single, String) | Initializes the instance.
Public method | Initialize(Int32, Int32, Single, Single, Single, Single, String, CvsGraphicLineAdornment, CvsGraphicLineAdornment) | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | EndPoint | Gets the second point of the line. The Row is measured in pixels from the sides of the CvsImage. The Column is measured in pixels from the sides of the CvsImage.
Public property | EndPointAdornment | Gets the adornment for the second point of the line.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | StartPoint | Gets the first point of the line. The Row is measured in pixels from the sides of the CvsImage. The Column is measured in pixels from the sides of the CvsImage.
Public property | StartPointAdornment | Gets the adornment for the first point of the line.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicLine Class
Cognex.InSight.Graphic Namespace


CvsGraphicLine Constructor

[image] [image]

In-Sight SDK
CvsGraphicLine Constructor
CvsGraphicLine Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicLine()()()() | Initializes a new instance of the CvsGraphicLine class.
Public method | CvsGraphicLine(CvsGraphicLine) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicLine(CvsCellLocation, CvsImageLocation, CvsImageLocation, String) | Initializes a new instance of the CvsGraphicLine class.
Public method | CvsGraphicLine(CvsCellLocation, CvsImageLocation, CvsImageLocation, String, CvsGraphicLineAdornment, CvsGraphicLineAdornment) | Initializes a new instance of the CvsGraphicLine class.

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
Cognex.InSight.Graphic Namespace


CvsGraphicLine Constructor

[image]

In-Sight SDK
CvsGraphicLine Constructor
CvsGraphicLine Class See Also Send Feedback
Initializes a new instance of the CvsGraphicLine class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicLine()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
CvsGraphicLine Overload
Cognex.InSight.Graphic Namespace


CvsGraphicLine Constructor (CvsGraphicLine)

[image]

In-Sight SDK
CvsGraphicLine Constructor (CvsGraphicLine)
CvsGraphicLine Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicLine(
    CvsGraphicLine graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicLine
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicLine
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
CvsGraphicLine Overload
Cognex.InSight.Graphic Namespace


CvsGraphicLine Constructor (CvsCellLocation, CvsImageLocation, CvsImageLocation, String)

[image]

In-Sight SDK
CvsGraphicLine Constructor (CvsCellLocation, CvsImageLocation, CvsImageLocation, String)
CvsGraphicLine Class See Also Send Feedback
Initializes a new instance of the CvsGraphicLine class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicLine(
    CvsCellLocation cellLocation,
    CvsImageLocation startPoint,
    CvsImageLocation endPoint,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    startPoint As CvsImageLocation,
    endPoint As CvsImageLocation,
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
startPoint
Type: Cognex.InSight..::..CvsImageLocation
The offset of the first point of the line in pixels.
endPoint
Type: Cognex.InSight..::..CvsImageLocation
The offset of the second point of the line in pixels.
label
Type: System..::..String
The label to draw for this graphic

Remarks

The graphic constructed may be passed to the SetEditGraphic(CvsGraphic) method to set the graphic associated with an edit cell function.

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
CvsGraphicLine Overload
Cognex.InSight.Graphic Namespace


CvsGraphicLine Constructor (CvsCellLocation, CvsImageLocation, CvsImageLocation, String, CvsGraphicLineAdornment, CvsGraphicLineAdornment)

[image]

In-Sight SDK
CvsGraphicLine Constructor (CvsCellLocation, CvsImageLocation, CvsImageLocation, String, CvsGraphicLineAdornment, CvsGraphicLineAdornment)
CvsGraphicLine Class See Also Send Feedback
Initializes a new instance of the CvsGraphicLine class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicLine(
    CvsCellLocation cellLocation,
    CvsImageLocation startPoint,
    CvsImageLocation endPoint,
    string label,
    CvsGraphicLineAdornment startPointAdornment,
    CvsGraphicLineAdornment endPointAdornment
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    startPoint As CvsImageLocation,
    endPoint As CvsImageLocation,
    label As String,
    startPointAdornment As CvsGraphicLineAdornment,
    endPointAdornment As CvsGraphicLineAdornment
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
startPoint
Type: Cognex.InSight..::..CvsImageLocation
The offset of the first point of the line in pixels.
endPoint
Type: Cognex.InSight..::..CvsImageLocation
The offset of the second point of the line in pixels.
label
Type: System..::..String
The label to draw for this graphic
startPointAdornment
Type: Cognex.InSight.Graphic..::..CvsGraphicLineAdornment
Adornments that may be rendered at the first point of the line.
endPointAdornment
Type: Cognex.InSight.Graphic..::..CvsGraphicLineAdornment
Adornments that may be rendered at the second point of the line.

Remarks

The graphic constructed may be passed to the SetEditGraphic(CvsGraphic) method to set the graphic associated with an edit cell function.

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
CvsGraphicLine Overload
Cognex.InSight.Graphic Namespace


CvsGraphicLine Methods

[image] [image]

In-Sight SDK
CvsGraphicLine Methods
CvsGraphicLine Class See Also Send Feedback

The CvsGraphicLine type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize(Int32, Int32, Single, Single, Single, Single, String) | Initializes the instance.
Public method | Initialize(Int32, Int32, Single, Single, Single, Single, String, CvsGraphicLineAdornment, CvsGraphicLineAdornment) | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicLine Class
Cognex.InSight.Graphic Namespace


CvsGraphicLine.Initialize Method

[image] [image]

In-Sight SDK
CvsGraphicLine..::..Initialize Method
CvsGraphicLine Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Initialize(Int32, Int32, Single, Single, Single, Single, String) | Initializes the instance.
Public method | Initialize(Int32, Int32, Single, Single, Single, Single, String, CvsGraphicLineAdornment, CvsGraphicLineAdornment) | Initializes the instance.

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
Cognex.InSight.Graphic Namespace


CvsGraphicLine.Initialize Method (Int32, Int32, Single, Single, Single, Single, String)

[image]

In-Sight SDK
CvsGraphicLine..::..Initialize Method (Int32, Int32, Single, Single, Single, Single, String)
CvsGraphicLine Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float startRow,
    float startCol,
    float endRow,
    float endCol,
    string label
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    startRow As Single,
    startCol As Single,
    endRow As Single,
    endCol As Single,
    label As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
startRow
Type: System..::..Single
The line's start row location.
startCol
Type: System..::..Single
The line's start column location.
endRow
Type: System..::..Single
The line's end row location.
endCol
Type: System..::..Single
The line's end column location.
label
Type: System..::..String
The label to draw for this graphic

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
Initialize Overload
Cognex.InSight.Graphic Namespace


CvsGraphicLine.Initialize Method (Int32, Int32, Single, Single, Single, Single, String, CvsGraphicLineAdornment, CvsGraphicLineAdornment)

[image]

In-Sight SDK
CvsGraphicLine..::..Initialize Method (Int32, Int32, Single, Single, Single, Single, String, CvsGraphicLineAdornment, CvsGraphicLineAdornment)
CvsGraphicLine Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float startRow,
    float startCol,
    float endRow,
    float endCol,
    string label,
    CvsGraphicLineAdornment startPointAdornment,
    CvsGraphicLineAdornment endPointAdornment
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    startRow As Single,
    startCol As Single,
    endRow As Single,
    endCol As Single,
    label As String,
    startPointAdornment As CvsGraphicLineAdornment,
    endPointAdornment As CvsGraphicLineAdornment
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
startRow
Type: System..::..Single
The line's start row location.
startCol
Type: System..::..Single
The line's start column location.
endRow
Type: System..::..Single
The line's end row location.
endCol
Type: System..::..Single
The line's end column location.
label
Type: System..::..String
The label to draw for this graphic
startPointAdornment
Type: Cognex.InSight.Graphic..::..CvsGraphicLineAdornment
Adornments that may be rendered at the first point of the line.
endPointAdornment
Type: Cognex.InSight.Graphic..::..CvsGraphicLineAdornment
Adornments that may be rendered at the second point of the line.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
Initialize Overload
Cognex.InSight.Graphic Namespace


CvsGraphicLine Properties

[image] [image]

In-Sight SDK
CvsGraphicLine Properties
CvsGraphicLine Class See Also Send Feedback

The CvsGraphicLine type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | EndPoint | Gets the second point of the line. The Row is measured in pixels from the sides of the CvsImage. The Column is measured in pixels from the sides of the CvsImage.
Public property | EndPointAdornment | Gets the adornment for the second point of the line.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | StartPoint | Gets the first point of the line. The Row is measured in pixels from the sides of the CvsImage. The Column is measured in pixels from the sides of the CvsImage.
Public property | StartPointAdornment | Gets the adornment for the first point of the line.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicLine Class
Cognex.InSight.Graphic Namespace


CvsGraphicLine.EditBounds Property

[image]

In-Sight SDK
CvsGraphicLine..::..EditBounds Property
CvsGraphicLine Class See Also Send Feedback
Gets or Sets the edit boundary for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle EditBounds { get; set; }
Visual Basic
Public Property EditBounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
Cognex.InSight.Graphic Namespace


CvsGraphicLine.EditFlags Property

[image]

In-Sight SDK
CvsGraphicLine..::..EditFlags Property
CvsGraphicLine Class See Also Send Feedback
Gets or Sets the allowed edit modes for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEditFlags EditFlags { get; set; }
Visual Basic
Public Property EditFlags As CvsEditFlags
    Get
    Set

Property Value

Type: CvsEditFlags

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
Cognex.InSight.Graphic Namespace


CvsGraphicLine.EndPoint Property

[image]

In-Sight SDK
CvsGraphicLine..::..EndPoint Property
CvsGraphicLine Class See Also Send Feedback
Gets the second point of the line. The Row is measured in pixels from the sides of the CvsImage. The Column is measured in pixels from the sides of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation EndPoint { get; set; }
Visual Basic
Public Property EndPoint As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
Cognex.InSight.Graphic Namespace


CvsGraphicLine.EndPointAdornment Property

[image]

In-Sight SDK
CvsGraphicLine..::..EndPointAdornment Property
CvsGraphicLine Class See Also Send Feedback
Gets the adornment for the second point of the line.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicLineAdornment EndPointAdornment { get; }
Visual Basic
Public ReadOnly Property EndPointAdornment As CvsGraphicLineAdornment
    Get

Property Value

Type: CvsGraphicLineAdornment

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
Cognex.InSight.Graphic Namespace


CvsGraphicLine.StartPoint Property

[image]

In-Sight SDK
CvsGraphicLine..::..StartPoint Property
CvsGraphicLine Class See Also Send Feedback
Gets the first point of the line. The Row is measured in pixels from the sides of the CvsImage. The Column is measured in pixels from the sides of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation StartPoint { get; set; }
Visual Basic
Public Property StartPoint As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
Cognex.InSight.Graphic Namespace


CvsGraphicLine.StartPointAdornment Property

[image]

In-Sight SDK
CvsGraphicLine..::..StartPointAdornment Property
CvsGraphicLine Class See Also Send Feedback
Gets the adornment for the first point of the line.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicLineAdornment StartPointAdornment { get; }
Visual Basic
Public ReadOnly Property StartPointAdornment As CvsGraphicLineAdornment
    Get

Property Value

Type: CvsGraphicLineAdornment

See Also

CvsGraphicLine Class
CvsGraphicLine..::..CvsGraphicLine Members
Cognex.InSight.Graphic Namespace


CvsGraphicLine Events

[image] [image]

In-Sight SDK
CvsGraphicLine Events
CvsGraphicLine Class See Also Send Feedback

The CvsGraphicLine type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicLine Class
Cognex.InSight.Graphic Namespace


CvsGraphicLineAdornment Enumeration

[image]

In-Sight SDK
CvsGraphicLineAdornment Enumeration
See Also Send Feedback
Adornments that may be rendered for the endpoints of the line.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsGraphicLineAdornment
Visual Basic
Public Enumeration CvsGraphicLineAdornment

Members

Member name | Value | Description
None | 0 | No special rendering at the endpoint.
Arrowhead | 1 | Render an arrowhead at the endpoint.

See Also

Cognex.InSight.Graphic Namespace


CvsGraphicMaskedRegion Class

[image]

In-Sight SDK
CvsGraphicMaskedRegion Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight CompositeRegion graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicMaskedRegion : CvsGraphicCompositeBase
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicMaskedRegion
    Inherits CvsGraphicCompositeBase

Remarks

CvsGraphicComposite objects are returned as items in a CvsGraphicCollection.

A CvsGraphicComposite is an editable graphic and may be edited by a control and returned to the In-Sight sensor.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicCompositeBase
Cognex.InSight.Graphic..::..CvsGraphicMaskedRegion

See Also

CvsGraphicMaskedRegion..::..CvsGraphicMaskedRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicMaskedRegion Members

[image] [image]

In-Sight SDK
CvsGraphicMaskedRegion Members
CvsGraphicMaskedRegion Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicMaskedRegion type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicMaskedRegion()()()() | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicMaskedRegion(array<CvsCompositeSubregion>[]()[][]) | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicMaskedRegion(CvsGraphicMaskedRegion) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicMaskedRegion(CvsCellLocation, array<CvsCompositeSubregion>[]()[][], String) | Initializes a new instance of the CvsGraphicComposite class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | ClearSubregions | Remove all the subregions (Inherited from CvsGraphicCompositeBase.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | DeleteSubregion | Remove the subregion from the composite. (Inherited from CvsGraphicCompositeBase.)
Public method | DeleteSubregionByIndex | Remove the subregion at the specified index. (Inherited from CvsGraphicCompositeBase.)
Public method | DeleteSubregions | Deletes subregions in the specified range. (Inherited from CvsGraphicCompositeBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetSubregionOperation | Returns the operation of the specified subregion. (Inherited from CvsGraphicCompositeBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertAnnulus | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertCircle | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertPolygon | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertRegion | Insert a subregion based on the provided CvsGraphicRegion object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionAnnulus | Update the subregion using the provided CvsGraphicAnnulus object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionCircle | Update the subregion using the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionOperation | Modifies the operation of the specified subregion. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionPolygon | Insert a subregion based on the provided CvsGraphicPolygon object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionRegion | Update the subregion using the provided CvsGraphicRegion object. (Inherited from CvsGraphicCompositeBase.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditFlags | Gets or sets the allowed edit modes for this graphic. (Inherited from CvsGraphicCompositeBase.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Subregions | Gets or sets the array of CvsCompositeSubregion objects which define this composite region. (Inherited from CvsGraphicCompositeBase.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicMaskedRegion Class
Cognex.InSight.Graphic Namespace


CvsGraphicMaskedRegion Constructor

[image] [image]

In-Sight SDK
CvsGraphicMaskedRegion Constructor
CvsGraphicMaskedRegion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicMaskedRegion()()()() | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicMaskedRegion(array<CvsCompositeSubregion>[]()[][]) | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicMaskedRegion(CvsGraphicMaskedRegion) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicMaskedRegion(CvsCellLocation, array<CvsCompositeSubregion>[]()[][], String) | Initializes a new instance of the CvsGraphicComposite class.

See Also

CvsGraphicMaskedRegion Class
CvsGraphicMaskedRegion..::..CvsGraphicMaskedRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicMaskedRegion Constructor

[image]

In-Sight SDK
CvsGraphicMaskedRegion Constructor
CvsGraphicMaskedRegion Class See Also Send Feedback
Initializes a new instance of the CvsGraphicComposite class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicMaskedRegion()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicMaskedRegion Class
CvsGraphicMaskedRegion..::..CvsGraphicMaskedRegion Members
CvsGraphicMaskedRegion Overload
Cognex.InSight.Graphic Namespace


CvsGraphicMaskedRegion Constructor (CvsCompositeSubregion[])

[image]

In-Sight SDK
CvsGraphicMaskedRegion Constructor (array<CvsCompositeSubregion>[]()[][])
CvsGraphicMaskedRegion Class See Also Send Feedback
Initializes a new instance of the CvsGraphicComposite class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicMaskedRegion(
    CvsCompositeSubregion[] subRegions
)
Visual Basic
Public Sub New (
    subRegions As CvsCompositeSubregion()
)

Parameters

subRegions
Type: array< Cognex.InSight.Graphic..::..CvsCompositeSubregion >[]()[][]
Subregions which define the CompositeRegion.

See Also

CvsGraphicMaskedRegion Class
CvsGraphicMaskedRegion..::..CvsGraphicMaskedRegion Members
CvsGraphicMaskedRegion Overload
Cognex.InSight.Graphic Namespace


CvsGraphicMaskedRegion Constructor (CvsGraphicMaskedRegion)

[image]

In-Sight SDK
CvsGraphicMaskedRegion Constructor (CvsGraphicMaskedRegion)
CvsGraphicMaskedRegion Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicMaskedRegion(
    CvsGraphicMaskedRegion graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicMaskedRegion
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicMaskedRegion
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicMaskedRegion Class
CvsGraphicMaskedRegion..::..CvsGraphicMaskedRegion Members
CvsGraphicMaskedRegion Overload
Cognex.InSight.Graphic Namespace


CvsGraphicMaskedRegion Constructor (CvsCellLocation, CvsCompositeSubregion[], String)

[image]

In-Sight SDK
CvsGraphicMaskedRegion Constructor (CvsCellLocation, array<CvsCompositeSubregion>[]()[][], String)
CvsGraphicMaskedRegion Class See Also Send Feedback
Initializes a new instance of the CvsGraphicComposite class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicMaskedRegion(
    CvsCellLocation cellLocation,
    CvsCompositeSubregion[] subRegions,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    subRegions As CvsCompositeSubregion(),
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
subRegions
Type: array< Cognex.InSight.Graphic..::..CvsCompositeSubregion >[]()[][]
Subregions which define the CompositeRegion.
label
Type: System..::..String
The label to draw for this graphic

Remarks

The graphic constructed may be passed to the SetEditGraphic(CvsGraphic) method to set the graphic associated with an edit cell function.

See Also

CvsGraphicMaskedRegion Class
CvsGraphicMaskedRegion..::..CvsGraphicMaskedRegion Members
CvsGraphicMaskedRegion Overload
Cognex.InSight.Graphic Namespace


CvsGraphicMaskedRegion Methods

[image] [image]

In-Sight SDK
CvsGraphicMaskedRegion Methods
CvsGraphicMaskedRegion Class See Also Send Feedback

The CvsGraphicMaskedRegion type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | ClearSubregions | Remove all the subregions (Inherited from CvsGraphicCompositeBase.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | DeleteSubregion | Remove the subregion from the composite. (Inherited from CvsGraphicCompositeBase.)
Public method | DeleteSubregionByIndex | Remove the subregion at the specified index. (Inherited from CvsGraphicCompositeBase.)
Public method | DeleteSubregions | Deletes subregions in the specified range. (Inherited from CvsGraphicCompositeBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetSubregionOperation | Returns the operation of the specified subregion. (Inherited from CvsGraphicCompositeBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertAnnulus | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertCircle | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertPolygon | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertRegion | Insert a subregion based on the provided CvsGraphicRegion object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionAnnulus | Update the subregion using the provided CvsGraphicAnnulus object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionCircle | Update the subregion using the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionOperation | Modifies the operation of the specified subregion. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionPolygon | Insert a subregion based on the provided CvsGraphicPolygon object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionRegion | Update the subregion using the provided CvsGraphicRegion object. (Inherited from CvsGraphicCompositeBase.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicMaskedRegion Class
Cognex.InSight.Graphic Namespace


CvsGraphicMaskedRegion Properties

[image] [image]

In-Sight SDK
CvsGraphicMaskedRegion Properties
CvsGraphicMaskedRegion Class See Also Send Feedback

The CvsGraphicMaskedRegion type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditFlags | Gets or sets the allowed edit modes for this graphic. (Inherited from CvsGraphicCompositeBase.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Subregions | Gets or sets the array of CvsCompositeSubregion objects which define this composite region. (Inherited from CvsGraphicCompositeBase.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicMaskedRegion Class
Cognex.InSight.Graphic Namespace


CvsGraphicMaskedRegion Events

[image] [image]

In-Sight SDK
CvsGraphicMaskedRegion Events
CvsGraphicMaskedRegion Class See Also Send Feedback

The CvsGraphicMaskedRegion type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicMaskedRegion Class
Cognex.InSight.Graphic Namespace


CvsGraphicOffset Class

[image]

In-Sight SDK
CvsGraphicOffset Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight offset graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicOffset : CvsGraphic,
    ICvsEditableGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicOffset
    Inherits CvsGraphic
    Implements ICvsEditableGraphic

Remarks

CvsGraphicOffset objects are returned as items in a CvsGraphicCollection. They are generated by the PatFind function.

An offset is an editable graphic and may be edited by a control and returned to the In-Sight sensor.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicOffset

See Also

CvsGraphicOffset..::..CvsGraphicOffset Members
Cognex.InSight.Graphic Namespace


CvsGraphicOffset Members

[image] [image]

In-Sight SDK
CvsGraphicOffset Members
CvsGraphicOffset Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicOffset type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicOffset()()()() | Initializes a new instance of the CvsGraphicOffset class.
Public method | CvsGraphicOffset(CvsGraphicOffset) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicOffset(CvsCellLocation, CvsImageLocation, CvsImageLocation, Single, String) | Initializes a new instance with the specified parameters.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | Angle | Gets the orientation of the offset graphic. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Offset | Gets the offset point. The Row is measured in pixels from the sides of the CvsImage. The Column is measured in pixels from the sides of the CvsImage.
Public property | Origin | Gets the origin point. The Row is measured in pixels from the sides of the CvsImage. The Column is measured in pixels from the sides of the CvsImage.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicOffset Class
Cognex.InSight.Graphic Namespace


CvsGraphicOffset Constructor

[image] [image]

In-Sight SDK
CvsGraphicOffset Constructor
CvsGraphicOffset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicOffset()()()() | Initializes a new instance of the CvsGraphicOffset class.
Public method | CvsGraphicOffset(CvsGraphicOffset) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicOffset(CvsCellLocation, CvsImageLocation, CvsImageLocation, Single, String) | Initializes a new instance with the specified parameters.

See Also

CvsGraphicOffset Class
CvsGraphicOffset..::..CvsGraphicOffset Members
Cognex.InSight.Graphic Namespace


CvsGraphicOffset Constructor

[image]

In-Sight SDK
CvsGraphicOffset Constructor
CvsGraphicOffset Class See Also Send Feedback
Initializes a new instance of the CvsGraphicOffset class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicOffset()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicOffset Class
CvsGraphicOffset..::..CvsGraphicOffset Members
CvsGraphicOffset Overload
Cognex.InSight.Graphic Namespace


CvsGraphicOffset Constructor (CvsGraphicOffset)

[image]

In-Sight SDK
CvsGraphicOffset Constructor (CvsGraphicOffset)
CvsGraphicOffset Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicOffset(
    CvsGraphicOffset graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicOffset
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicOffset
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicOffset Class
CvsGraphicOffset..::..CvsGraphicOffset Members
CvsGraphicOffset Overload
Cognex.InSight.Graphic Namespace


CvsGraphicOffset Constructor (CvsCellLocation, CvsImageLocation, CvsImageLocation, Single, String)

[image]

In-Sight SDK
CvsGraphicOffset Constructor (CvsCellLocation, CvsImageLocation, CvsImageLocation, Single, String)
CvsGraphicOffset Class See Also Send Feedback
Initializes a new instance with the specified parameters.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicOffset(
    CvsCellLocation cellLocation,
    CvsImageLocation offset,
    CvsImageLocation origin,
    float angle,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    offset As CvsImageLocation,
    origin As CvsImageLocation,
    angle As Single,
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell location of this graphic, or CvsCellLocation.Empty
offset
Type: Cognex.InSight..::..CvsImageLocation
The offset this graphic represents.
origin
Type: Cognex.InSight..::..CvsImageLocation
The origin point of the offset.
angle
Type: System..::..Single
The angle of the offset.
label
Type: System..::..String
The label of the offset.

See Also

CvsGraphicOffset Class
CvsGraphicOffset..::..CvsGraphicOffset Members
CvsGraphicOffset Overload
Cognex.InSight.Graphic Namespace


CvsGraphicOffset Methods

[image] [image]

In-Sight SDK
CvsGraphicOffset Methods
CvsGraphicOffset Class See Also Send Feedback

The CvsGraphicOffset type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicOffset Class
Cognex.InSight.Graphic Namespace


CvsGraphicOffset.Initialize Method

[image]

In-Sight SDK
CvsGraphicOffset..::..Initialize Method
CvsGraphicOffset Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float offsetRow,
    float offsetCol,
    float originRow,
    float originCol,
    float angle,
    string label
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    offsetRow As Single,
    offsetCol As Single,
    originRow As Single,
    originCol As Single,
    angle As Single,
    label As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
offsetRow
Type: System..::..Single
The offset's row location.
offsetCol
Type: System..::..Single
The offset's column location.
originRow
Type: System..::..Single
The offset's origin row location.
originCol
Type: System..::..Single
The offset's origin column location.
angle
Type: System..::..Single
The angle of the offset.
label
Type: System..::..String
The label of the offset.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicOffset Class
CvsGraphicOffset..::..CvsGraphicOffset Members
Cognex.InSight.Graphic Namespace


CvsGraphicOffset Properties

[image] [image]

In-Sight SDK
CvsGraphicOffset Properties
CvsGraphicOffset Class See Also Send Feedback

The CvsGraphicOffset type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets the orientation of the offset graphic. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Offset | Gets the offset point. The Row is measured in pixels from the sides of the CvsImage. The Column is measured in pixels from the sides of the CvsImage.
Public property | Origin | Gets the origin point. The Row is measured in pixels from the sides of the CvsImage. The Column is measured in pixels from the sides of the CvsImage.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicOffset Class
Cognex.InSight.Graphic Namespace


CvsGraphicOffset.Angle Property

[image]

In-Sight SDK
CvsGraphicOffset..::..Angle Property
CvsGraphicOffset Class See Also Send Feedback
Gets the orientation of the offset graphic. The angle is measured counter-clockwise relative to the horizontal axis.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Angle { get; set; }
Visual Basic
Public Property Angle As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicOffset Class
CvsGraphicOffset..::..CvsGraphicOffset Members
Cognex.InSight.Graphic Namespace


CvsGraphicOffset.EditBounds Property

[image]

In-Sight SDK
CvsGraphicOffset..::..EditBounds Property
CvsGraphicOffset Class See Also Send Feedback
Gets or Sets the edit boundary for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle EditBounds { get; set; }
Visual Basic
Public Property EditBounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicOffset Class
CvsGraphicOffset..::..CvsGraphicOffset Members
Cognex.InSight.Graphic Namespace


CvsGraphicOffset.EditFlags Property

[image]

In-Sight SDK
CvsGraphicOffset..::..EditFlags Property
CvsGraphicOffset Class See Also Send Feedback
Gets or Sets the allowed edit modes for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEditFlags EditFlags { get; set; }
Visual Basic
Public Property EditFlags As CvsEditFlags
    Get
    Set

Property Value

Type: CvsEditFlags

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicOffset Class
CvsGraphicOffset..::..CvsGraphicOffset Members
Cognex.InSight.Graphic Namespace


CvsGraphicOffset.Offset Property

[image]

In-Sight SDK
CvsGraphicOffset..::..Offset Property
CvsGraphicOffset Class See Also Send Feedback
Gets the offset point. The Row is measured in pixels from the sides of the CvsImage. The Column is measured in pixels from the sides of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Offset { get; set; }
Visual Basic
Public Property Offset As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicOffset Class
CvsGraphicOffset..::..CvsGraphicOffset Members
Cognex.InSight.Graphic Namespace


CvsGraphicOffset.Origin Property

[image]

In-Sight SDK
CvsGraphicOffset..::..Origin Property
CvsGraphicOffset Class See Also Send Feedback
Gets the origin point. The Row is measured in pixels from the sides of the CvsImage. The Column is measured in pixels from the sides of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Origin { get; set; }
Visual Basic
Public Property Origin As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicOffset Class
CvsGraphicOffset..::..CvsGraphicOffset Members
Cognex.InSight.Graphic Namespace


CvsGraphicOffset Events

[image] [image]

In-Sight SDK
CvsGraphicOffset Events
CvsGraphicOffset Class See Also Send Feedback

The CvsGraphicOffset type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicOffset Class
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram Class

[image]

In-Sight SDK
CvsGraphicParallelogram Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight parallelogram graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicParallelogram : CvsGraphic,
    ICvsEditableGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicParallelogram
    Inherits CvsGraphic
    Implements ICvsEditableGraphic

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicParallelogram

See Also

CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram Members

[image] [image]

In-Sight SDK
CvsGraphicParallelogram Members
CvsGraphicParallelogram Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicParallelogram type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicParallelogram()()()() | Initializes a new instance of the CvsGraphicParallelogram class.
Public method | CvsGraphicParallelogram(String) | Initializes a new instance of the CvsGraphicParallelogram class.
Public method | CvsGraphicParallelogram(CvsGraphicParallelogram) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicParallelogram(CvsCellLocation, CvsImageLocation, Single, Single, Single, Single, String) | Initializes a new instance of the CvsGraphicRegion class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | Area | Gets the area of the parallelogram.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | Height | Gets or sets the height (in pixels) of the graphic. The height is the distance between the top left corner of the parallelogram and the bottom left corner.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | InteriorAngle | Gets or sets the interior angle of the parallegram. The is the angle between the left and bottom sides of the parallelogram.
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | LabelBackColor | Gets or sets the text label background color associated with the graphic, or Color.Empty if no color was specified.
Public property | LabelBackColorAsRgb | Gets or sets the LabelBackColor as an RGB value.
Public property | LabelForeColor | Gets or sets the text label foreground color associated with the graphic, or Color.Empty if no color was specified.
Public property | LabelForeColorAsRgb | Gets or sets the LabelForeColor as an RGB value.
Public property | Location | Gets or sets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | Rotation | Gets or sets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)
Public property | Width | Gets or sets the width (in pixels) of the graphic.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicParallelogram Class
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram Constructor

[image] [image]

In-Sight SDK
CvsGraphicParallelogram Constructor
CvsGraphicParallelogram Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicParallelogram()()()() | Initializes a new instance of the CvsGraphicParallelogram class.
Public method | CvsGraphicParallelogram(String) | Initializes a new instance of the CvsGraphicParallelogram class.
Public method | CvsGraphicParallelogram(CvsGraphicParallelogram) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicParallelogram(CvsCellLocation, CvsImageLocation, Single, Single, Single, Single, String) | Initializes a new instance of the CvsGraphicRegion class.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram Constructor

[image]

In-Sight SDK
CvsGraphicParallelogram Constructor
CvsGraphicParallelogram Class See Also Send Feedback
Initializes a new instance of the CvsGraphicParallelogram class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicParallelogram()
Visual Basic
Public Sub New

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
CvsGraphicParallelogram Overload
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram Constructor (String)

[image]

In-Sight SDK
CvsGraphicParallelogram Constructor (String)
CvsGraphicParallelogram Class See Also Send Feedback
Initializes a new instance of the CvsGraphicParallelogram class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicParallelogram(
    string label
)
Visual Basic
Public Sub New (
    label As String
)

Parameters

label
Type: System..::..String
The label associated with this region.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
CvsGraphicParallelogram Overload
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram Constructor (CvsGraphicParallelogram)

[image]

In-Sight SDK
CvsGraphicParallelogram Constructor (CvsGraphicParallelogram)
CvsGraphicParallelogram Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicParallelogram(
    CvsGraphicParallelogram graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicParallelogram
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicParallelogram
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
CvsGraphicParallelogram Overload
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram Constructor (CvsCellLocation, CvsImageLocation, Single, Single, Single, Single, String)

[image]

In-Sight SDK
CvsGraphicParallelogram Constructor (CvsCellLocation, CvsImageLocation, Single, Single, Single, Single, String)
CvsGraphicParallelogram Class See Also Send Feedback
Initializes a new instance of the CvsGraphicRegion class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicParallelogram(
    CvsCellLocation cellLocation,
    CvsImageLocation location,
    float height,
    float width,
    float rotation,
    float interiorAngle,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    location As CvsImageLocation,
    height As Single,
    width As Single,
    rotation As Single,
    interiorAngle As Single,
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
location
Type: Cognex.InSight..::..CvsImageLocation
The offset of the region in pixels.
height
Type: System..::..Single
The height of the region in pixels.
width
Type: System..::..Single
The width of the region in pixels.
rotation
Type: System..::..Single
The orientation/rotation (angle) of the region.
interiorAngle
Type: System..::..Single
The interior angle of the region.
label
Type: System..::..String
The label associated with this region.

Remarks

The graphic constructed may be passed to the SetEditGraphic(CvsGraphic) method to set the graphic associated with an edit cell function.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
CvsGraphicParallelogram Overload
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram Methods

[image] [image]

In-Sight SDK
CvsGraphicParallelogram Methods
CvsGraphicParallelogram Class See Also Send Feedback

The CvsGraphicParallelogram type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicParallelogram Class
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram.Initialize Method

[image]

In-Sight SDK
CvsGraphicParallelogram..::..Initialize Method
CvsGraphicParallelogram Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float regionRow,
    float regionCol,
    float regionHeight,
    float regionWidth,
    float regionRotation,
    float regionInteriorAngle,
    string regionLabel
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    regionRow As Single,
    regionCol As Single,
    regionHeight As Single,
    regionWidth As Single,
    regionRotation As Single,
    regionInteriorAngle As Single,
    regionLabel As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
regionRow
Type: System..::..Single
The region's row location.
regionCol
Type: System..::..Single
The region's column location.
regionHeight
Type: System..::..Single
The height of the region in pixels.
regionWidth
Type: System..::..Single
The width of the region in pixels.
regionRotation
Type: System..::..Single
The orientation/rotation (angle) of the region.
regionInteriorAngle
Type: System..::..Single
The interior angle of the region.
regionLabel
Type: System..::..String
The label associated with this region.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram Properties

[image] [image]

In-Sight SDK
CvsGraphicParallelogram Properties
CvsGraphicParallelogram Class See Also Send Feedback

The CvsGraphicParallelogram type exposes the following members.

Properties

 | Name | Description
Public property | Area | Gets the area of the parallelogram.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | Height | Gets or sets the height (in pixels) of the graphic. The height is the distance between the top left corner of the parallelogram and the bottom left corner.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | InteriorAngle | Gets or sets the interior angle of the parallegram. The is the angle between the left and bottom sides of the parallelogram.
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | LabelBackColor | Gets or sets the text label background color associated with the graphic, or Color.Empty if no color was specified.
Public property | LabelBackColorAsRgb | Gets or sets the LabelBackColor as an RGB value.
Public property | LabelForeColor | Gets or sets the text label foreground color associated with the graphic, or Color.Empty if no color was specified.
Public property | LabelForeColorAsRgb | Gets or sets the LabelForeColor as an RGB value.
Public property | Location | Gets or sets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | Rotation | Gets or sets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)
Public property | Width | Gets or sets the width (in pixels) of the graphic.

See Also

CvsGraphicParallelogram Class
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram.Area Property

[image]

In-Sight SDK
CvsGraphicParallelogram..::..Area Property
CvsGraphicParallelogram Class See Also Send Feedback
Gets the area of the parallelogram.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Area { get; }
Visual Basic
Public ReadOnly Property Area As Single
    Get

Property Value

Type: Single

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram.EditBounds Property

[image]

In-Sight SDK
CvsGraphicParallelogram..::..EditBounds Property
CvsGraphicParallelogram Class See Also Send Feedback
Gets or Sets the edit boundary for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle EditBounds { get; set; }
Visual Basic
Public Property EditBounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle

Implements

ICvsEditableGraphic..::..EditBounds

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram.EditFlags Property

[image]

In-Sight SDK
CvsGraphicParallelogram..::..EditFlags Property
CvsGraphicParallelogram Class See Also Send Feedback
Gets or Sets the allowed edit modes for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEditFlags EditFlags { get; set; }
Visual Basic
Public Property EditFlags As CvsEditFlags
    Get
    Set

Property Value

Type: CvsEditFlags

Implements

ICvsEditableGraphic..::..EditFlags

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram.Height Property

[image]

In-Sight SDK
CvsGraphicParallelogram..::..Height Property
CvsGraphicParallelogram Class See Also Send Feedback
Gets or sets the height (in pixels) of the graphic. The height is the distance between the top left corner of the parallelogram and the bottom left corner.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Height { get; set; }
Visual Basic
Public Property Height As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram.InteriorAngle Property

[image]

In-Sight SDK
CvsGraphicParallelogram..::..InteriorAngle Property
CvsGraphicParallelogram Class See Also Send Feedback
Gets or sets the interior angle of the parallegram. The is the angle between the left and bottom sides of the parallelogram.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float InteriorAngle { get; set; }
Visual Basic
Public Property InteriorAngle As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram.LabelBackColor Property

[image]

In-Sight SDK
CvsGraphicParallelogram..::..LabelBackColor Property
CvsGraphicParallelogram Class See Also Send Feedback
Gets or sets the text label background color associated with the graphic, or Color.Empty if no color was specified.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color LabelBackColor { get; set; }
Visual Basic
Public Property LabelBackColor As Color
    Get
    Set

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram.LabelBackColorAsRgb Property

[image]

In-Sight SDK
CvsGraphicParallelogram..::..LabelBackColorAsRgb Property
CvsGraphicParallelogram Class See Also Send Feedback
Gets or sets the LabelBackColor as an RGB value.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int LabelBackColorAsRgb { get; set; }
Visual Basic
Public Property LabelBackColorAsRgb As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram.LabelForeColor Property

[image]

In-Sight SDK
CvsGraphicParallelogram..::..LabelForeColor Property
CvsGraphicParallelogram Class See Also Send Feedback
Gets or sets the text label foreground color associated with the graphic, or Color.Empty if no color was specified.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color LabelForeColor { get; set; }
Visual Basic
Public Property LabelForeColor As Color
    Get
    Set

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram.LabelForeColorAsRgb Property

[image]

In-Sight SDK
CvsGraphicParallelogram..::..LabelForeColorAsRgb Property
CvsGraphicParallelogram Class See Also Send Feedback
Gets or sets the LabelForeColor as an RGB value.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int LabelForeColorAsRgb { get; set; }
Visual Basic
Public Property LabelForeColorAsRgb As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram.Location Property

[image]

In-Sight SDK
CvsGraphicParallelogram..::..Location Property
CvsGraphicParallelogram Class See Also Send Feedback
Gets or sets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Location { get; set; }
Visual Basic
Public Property Location As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram.Rotation Property

[image]

In-Sight SDK
CvsGraphicParallelogram..::..Rotation Property
CvsGraphicParallelogram Class See Also Send Feedback
Gets or sets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Rotation { get; set; }
Visual Basic
Public Property Rotation As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram.Width Property

[image]

In-Sight SDK
CvsGraphicParallelogram..::..Width Property
CvsGraphicParallelogram Class See Also Send Feedback
Gets or sets the width (in pixels) of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Width { get; set; }
Visual Basic
Public Property Width As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicParallelogram Class
CvsGraphicParallelogram..::..CvsGraphicParallelogram Members
Cognex.InSight.Graphic Namespace


CvsGraphicParallelogram Events

[image] [image]

In-Sight SDK
CvsGraphicParallelogram Events
CvsGraphicParallelogram Class See Also Send Feedback

The CvsGraphicParallelogram type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicParallelogram Class
Cognex.InSight.Graphic Namespace


CvsGraphicPatternMatch Class

[image]

In-Sight SDK
CvsGraphicPatternMatch Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight pattern match graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicPatternMatch : CvsGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicPatternMatch
    Inherits CvsGraphic

Remarks

CvsGraphicPatternMatch objects are returned as items in a CvsGraphicCollection. They are generated by the TrainPatMaxPattern and FindPatMaxPattern functions.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicPatternMatch

See Also

CvsGraphicPatternMatch..::..CvsGraphicPatternMatch Members
Cognex.InSight.Graphic Namespace


CvsGraphicPatternMatch Members

[image] [image]

In-Sight SDK
CvsGraphicPatternMatch Members
CvsGraphicPatternMatch Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicPatternMatch type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicPatternMatch | Initializes a new instance that is a copy of the specified instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetSegments | Returns the array of pattern match segments that comprise the graphic.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | NumSegments | Gets the segments in this graphic.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicPatternMatch Class
Cognex.InSight.Graphic Namespace


CvsGraphicPatternMatch Constructor

[image]

In-Sight SDK
CvsGraphicPatternMatch Constructor
CvsGraphicPatternMatch Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPatternMatch(
    CvsGraphicPatternMatch graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicPatternMatch
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicPatternMatch
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicPatternMatch Class
CvsGraphicPatternMatch..::..CvsGraphicPatternMatch Members
Cognex.InSight.Graphic Namespace


CvsGraphicPatternMatch Methods

[image] [image]

In-Sight SDK
CvsGraphicPatternMatch Methods
CvsGraphicPatternMatch Class See Also Send Feedback

The CvsGraphicPatternMatch type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetSegments | Returns the array of pattern match segments that comprise the graphic.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicPatternMatch Class
Cognex.InSight.Graphic Namespace


CvsGraphicPatternMatch.GetSegments Method

[image]

In-Sight SDK
CvsGraphicPatternMatch..::..GetSegments Method
CvsGraphicPatternMatch Class See Also Send Feedback
Returns the array of pattern match segments that comprise the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsPatternMatchSegment[] GetSegments()
Visual Basic
Public Function GetSegments As CvsPatternMatchSegment()

Return Value

Type: array< CvsPatternMatchSegment >[]()[][]
An array of color match segments.

See Also

CvsGraphicPatternMatch Class
CvsGraphicPatternMatch..::..CvsGraphicPatternMatch Members
Cognex.InSight.Graphic Namespace


CvsGraphicPatternMatch Properties

[image] [image]

In-Sight SDK
CvsGraphicPatternMatch Properties
CvsGraphicPatternMatch Class See Also Send Feedback

The CvsGraphicPatternMatch type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | NumSegments | Gets the segments in this graphic.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicPatternMatch Class
Cognex.InSight.Graphic Namespace


CvsGraphicPatternMatch.NumSegments Property

[image]

In-Sight SDK
CvsGraphicPatternMatch..::..NumSegments Property
CvsGraphicPatternMatch Class See Also Send Feedback
Gets the segments in this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NumSegments { get; }
Visual Basic
Public ReadOnly Property NumSegments As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicPatternMatch Class
CvsGraphicPatternMatch..::..CvsGraphicPatternMatch Members
Cognex.InSight.Graphic Namespace


CvsGraphicPatternMatch Events

[image] [image]

In-Sight SDK
CvsGraphicPatternMatch Events
CvsGraphicPatternMatch Class See Also Send Feedback

The CvsGraphicPatternMatch type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicPatternMatch Class
Cognex.InSight.Graphic Namespace


CvsGraphicPoint Class

[image]

In-Sight SDK
CvsGraphicPoint Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight point graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicPoint : CvsGraphic,
    ICvsEditableGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicPoint
    Inherits CvsGraphic
    Implements ICvsEditableGraphic

Remarks

CvsGraphicPoint objects are returned as items in a CvsGraphicCollection. They are generated by many functions including: Point, PointToPoint, PointToLine, et al.

A point is an editable graphic and may be edited by a control and returned to the In-Sight sensor.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicPoint

See Also

CvsGraphicPoint..::..CvsGraphicPoint Members
Cognex.InSight.Graphic Namespace


CvsGraphicPoint Members

[image] [image]

In-Sight SDK
CvsGraphicPoint Members
CvsGraphicPoint Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicPoint type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicPoint()()()() | Initializes a new instance of the CvsGraphicPoint class.
Public method | CvsGraphicPoint(CvsGraphicPoint) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicPoint(CvsCellLocation, CvsImageLocation, String) | Initializes a new instance of the CvsGraphicPoint class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Location | Gets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicPoint Class
Cognex.InSight.Graphic Namespace


CvsGraphicPoint Constructor

[image] [image]

In-Sight SDK
CvsGraphicPoint Constructor
CvsGraphicPoint Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicPoint()()()() | Initializes a new instance of the CvsGraphicPoint class.
Public method | CvsGraphicPoint(CvsGraphicPoint) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicPoint(CvsCellLocation, CvsImageLocation, String) | Initializes a new instance of the CvsGraphicPoint class.

See Also

CvsGraphicPoint Class
CvsGraphicPoint..::..CvsGraphicPoint Members
Cognex.InSight.Graphic Namespace


CvsGraphicPoint Constructor

[image]

In-Sight SDK
CvsGraphicPoint Constructor
CvsGraphicPoint Class See Also Send Feedback
Initializes a new instance of the CvsGraphicPoint class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPoint()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicPoint Class
CvsGraphicPoint..::..CvsGraphicPoint Members
CvsGraphicPoint Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPoint Constructor (CvsGraphicPoint)

[image]

In-Sight SDK
CvsGraphicPoint Constructor (CvsGraphicPoint)
CvsGraphicPoint Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPoint(
    CvsGraphicPoint graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicPoint
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicPoint
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicPoint Class
CvsGraphicPoint..::..CvsGraphicPoint Members
CvsGraphicPoint Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPoint Constructor (CvsCellLocation, CvsImageLocation, String)

[image]

In-Sight SDK
CvsGraphicPoint Constructor (CvsCellLocation, CvsImageLocation, String)
CvsGraphicPoint Class See Also Send Feedback
Initializes a new instance of the CvsGraphicPoint class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPoint(
    CvsCellLocation cellLocation,
    CvsImageLocation location,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    location As CvsImageLocation,
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
location
Type: Cognex.InSight..::..CvsImageLocation
The location of the point in pixels.
label
Type: System..::..String
The point's label

Remarks

The graphic constructed may be passed to the SetEditGraphic(CvsGraphic) method to set the graphic associated with an edit cell function.

See Also

CvsGraphicPoint Class
CvsGraphicPoint..::..CvsGraphicPoint Members
CvsGraphicPoint Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPoint Methods

[image] [image]

In-Sight SDK
CvsGraphicPoint Methods
CvsGraphicPoint Class See Also Send Feedback

The CvsGraphicPoint type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicPoint Class
Cognex.InSight.Graphic Namespace


CvsGraphicPoint.Initialize Method

[image]

In-Sight SDK
CvsGraphicPoint..::..Initialize Method
CvsGraphicPoint Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float pointRow,
    float pointCol,
    string label
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    pointRow As Single,
    pointCol As Single,
    label As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
pointRow
Type: System..::..Single
The point's row location.
pointCol
Type: System..::..Single
The point's column location.
label
Type: System..::..String
The point graphic's label.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicPoint Class
CvsGraphicPoint..::..CvsGraphicPoint Members
Cognex.InSight.Graphic Namespace


CvsGraphicPoint Properties

[image] [image]

In-Sight SDK
CvsGraphicPoint Properties
CvsGraphicPoint Class See Also Send Feedback

The CvsGraphicPoint type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Location | Gets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicPoint Class
Cognex.InSight.Graphic Namespace


CvsGraphicPoint.EditBounds Property

[image]

In-Sight SDK
CvsGraphicPoint..::..EditBounds Property
CvsGraphicPoint Class See Also Send Feedback
Gets or sets the edit boundary for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle EditBounds { get; set; }
Visual Basic
Public Property EditBounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicPoint Class
CvsGraphicPoint..::..CvsGraphicPoint Members
Cognex.InSight.Graphic Namespace


CvsGraphicPoint.EditFlags Property

[image]

In-Sight SDK
CvsGraphicPoint..::..EditFlags Property
CvsGraphicPoint Class See Also Send Feedback
Gets or Sets the allowed edit modes for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEditFlags EditFlags { get; set; }
Visual Basic
Public Property EditFlags As CvsEditFlags
    Get
    Set

Property Value

Type: CvsEditFlags

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicPoint Class
CvsGraphicPoint..::..CvsGraphicPoint Members
Cognex.InSight.Graphic Namespace


CvsGraphicPoint.Location Property

[image]

In-Sight SDK
CvsGraphicPoint..::..Location Property
CvsGraphicPoint Class See Also Send Feedback
Gets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Location { get; set; }
Visual Basic
Public Property Location As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicPoint Class
CvsGraphicPoint..::..CvsGraphicPoint Members
Cognex.InSight.Graphic Namespace


CvsGraphicPoint Events

[image] [image]

In-Sight SDK
CvsGraphicPoint Events
CvsGraphicPoint Class See Also Send Feedback

The CvsGraphicPoint type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicPoint Class
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon Class

[image]

In-Sight SDK
CvsGraphicPolygon Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight Polygon graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicPolygon : CvsGraphic,
    ICvsEditableGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicPolygon
    Inherits CvsGraphic
    Implements ICvsEditableGraphic

Remarks

CvsGraphicPolygon objects are returned as items in a CvsGraphicCollection.

A polygon is an editable graphic and may be edited by a control and returned to the In-Sight sensor.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicPolygon

See Also

CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon Members

[image] [image]

In-Sight SDK
CvsGraphicPolygon Members
CvsGraphicPolygon Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicPolygon type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicPolygon()()()() | Initializes a new instance of the CvsGraphicPolygon class.
Public method | CvsGraphicPolygon(CvsGraphicPolygon) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicPolygon(array<CvsImageLocation>[]()[][]) | Initializes a new instance of the CvsGraphicPolygon class.
Public method | CvsGraphicPolygon(CvsCellLocation, array<CvsImageLocation>[]()[][], String) | Initializes a new instance of the CvsGraphicPolygon class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | DeletePoint | Delete the point at the specified index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPoint | Gets the CvsImageLocation value at the specified index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | InsertPoint | Add a new CvsImageLocation value at the specified index.
Public method | SetPoint | Sets the CvsImageLocation value at the specified index
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | Area | Returns the area of the polygon.
Public property | BoundingBox | Returns the bounding rectangle of the graphic, in sensor coordinates.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Center | Returns the center of the polygon's bounding box.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or sets the edit boundary for this graphic.
Public property | EditFlags | Gets or sets the allowed edit modes for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | PointCount | Gets the number of points in the polygon.
Public property | Points | Gets or sets the array of points which define this polygon. The points are copied from the source array.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicPolygon Class
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon Constructor

[image] [image]

In-Sight SDK
CvsGraphicPolygon Constructor
CvsGraphicPolygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicPolygon()()()() | Initializes a new instance of the CvsGraphicPolygon class.
Public method | CvsGraphicPolygon(CvsGraphicPolygon) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicPolygon(array<CvsImageLocation>[]()[][]) | Initializes a new instance of the CvsGraphicPolygon class.
Public method | CvsGraphicPolygon(CvsCellLocation, array<CvsImageLocation>[]()[][], String) | Initializes a new instance of the CvsGraphicPolygon class.

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon Constructor

[image]

In-Sight SDK
CvsGraphicPolygon Constructor
CvsGraphicPolygon Class See Also Send Feedback
Initializes a new instance of the CvsGraphicPolygon class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPolygon()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
CvsGraphicPolygon Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon Constructor (CvsGraphicPolygon)

[image]

In-Sight SDK
CvsGraphicPolygon Constructor (CvsGraphicPolygon)
CvsGraphicPolygon Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPolygon(
    CvsGraphicPolygon graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicPolygon
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicPolygon
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
CvsGraphicPolygon Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon Constructor (CvsImageLocation[])

[image]

In-Sight SDK
CvsGraphicPolygon Constructor (array<CvsImageLocation>[]()[][])
CvsGraphicPolygon Class See Also Send Feedback
Initializes a new instance of the CvsGraphicPolygon class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPolygon(
    CvsImageLocation[] points
)
Visual Basic
Public Sub New (
    points As CvsImageLocation()
)

Parameters

points
Type: array< Cognex.InSight..::..CvsImageLocation >[]()[][]
Points, in Sensor coordinates, which define the polygon.

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
CvsGraphicPolygon Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon Constructor (CvsCellLocation, CvsImageLocation[], String)

[image]

In-Sight SDK
CvsGraphicPolygon Constructor (CvsCellLocation, array<CvsImageLocation>[]()[][], String)
CvsGraphicPolygon Class See Also Send Feedback
Initializes a new instance of the CvsGraphicPolygon class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPolygon(
    CvsCellLocation cellLocation,
    CvsImageLocation[] points,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    points As CvsImageLocation(),
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
points
Type: array< Cognex.InSight..::..CvsImageLocation >[]()[][]
The list of points that define the polygon.
label
Type: System..::..String
The label to draw for this graphic

Remarks

The graphic constructed may be passed to the SetEditGraphic(CvsGraphic) method to set the graphic associated with an edit cell function.

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
CvsGraphicPolygon Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon Methods

[image] [image]

In-Sight SDK
CvsGraphicPolygon Methods
CvsGraphicPolygon Class See Also Send Feedback

The CvsGraphicPolygon type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | DeletePoint | Delete the point at the specified index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPoint | Gets the CvsImageLocation value at the specified index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | InsertPoint | Add a new CvsImageLocation value at the specified index.
Public method | SetPoint | Sets the CvsImageLocation value at the specified index
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicPolygon Class
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon.DeletePoint Method

[image]

In-Sight SDK
CvsGraphicPolygon..::..DeletePoint Method
CvsGraphicPolygon Class See Also Send Feedback
Delete the point at the specified index.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void DeletePoint(
    int index
)
Visual Basic
Public Sub DeletePoint (
    index As Integer
)

Parameters

index
Type: System..::..Int32
The zero-based index.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true or if the delete operation would result in less than 3 points.

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon.GetPoint Method

[image]

In-Sight SDK
CvsGraphicPolygon..::..GetPoint Method
CvsGraphicPolygon Class See Also Send Feedback
Gets the CvsImageLocation value at the specified index.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation GetPoint(
    int index
)
Visual Basic
Public Function GetPoint (
    index As Integer
) As CvsImageLocation

Parameters

index
Type: System..::..Int32
The zero-based index.

Return Value

Type: CvsImageLocation
The image location.

Exceptions

Exception | Condition
System..::..IndexOutOfRangeException | An invalid index was specified.

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon.Initialize Method

[image]

In-Sight SDK
CvsGraphicPolygon..::..Initialize Method
CvsGraphicPolygon Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    CvsImageLocation[] points,
    string label
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    points As CvsImageLocation(),
    label As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
points
Type: array< Cognex.InSight..::..CvsImageLocation >[]()[][]
The list of points that define the polygon.
label
Type: System..::..String
The label to draw for this graphic

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon.InsertPoint Method

[image]

In-Sight SDK
CvsGraphicPolygon..::..InsertPoint Method
CvsGraphicPolygon Class See Also Send Feedback
Add a new CvsImageLocation value at the specified index.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void InsertPoint(
    int index,
    CvsImageLocation location
)
Visual Basic
Public Sub InsertPoint (
    index As Integer,
    location As CvsImageLocation
)

Parameters

index
Type: System..::..Int32
The zero-based index.
location
Type: Cognex.InSight..::..CvsImageLocation
The image location.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon.SetPoint Method

[image]

In-Sight SDK
CvsGraphicPolygon..::..SetPoint Method
CvsGraphicPolygon Class See Also Send Feedback
Sets the CvsImageLocation value at the specified index

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetPoint(
    int index,
    CvsImageLocation location
)
Visual Basic
Public Sub SetPoint (
    index As Integer,
    location As CvsImageLocation
)

Parameters

index
Type: System..::..Int32
The zero-based index.
location
Type: Cognex.InSight..::..CvsImageLocation
The image location.

Exceptions

Exception | Condition
System..::..IndexOutOfRangeException | An invalid index was specified.
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon Properties

[image] [image]

In-Sight SDK
CvsGraphicPolygon Properties
CvsGraphicPolygon Class See Also Send Feedback

The CvsGraphicPolygon type exposes the following members.

Properties

 | Name | Description
Public property | Area | Returns the area of the polygon.
Public property | BoundingBox | Returns the bounding rectangle of the graphic, in sensor coordinates.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Center | Returns the center of the polygon's bounding box.
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditBounds | Gets or sets the edit boundary for this graphic.
Public property | EditFlags | Gets or sets the allowed edit modes for this graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | PointCount | Gets the number of points in the polygon.
Public property | Points | Gets or sets the array of points which define this polygon. The points are copied from the source array.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicPolygon Class
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon.Area Property

[image]

In-Sight SDK
CvsGraphicPolygon..::..Area Property
CvsGraphicPolygon Class See Also Send Feedback
Returns the area of the polygon.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public double Area { get; }
Visual Basic
Public ReadOnly Property Area As Double
    Get

Property Value

Type: Double

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon.BoundingBox Property

[image]

In-Sight SDK
CvsGraphicPolygon..::..BoundingBox Property
CvsGraphicPolygon Class See Also Send Feedback
Returns the bounding rectangle of the graphic, in sensor coordinates.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public RectangleF BoundingBox { get; }
Visual Basic
Public ReadOnly Property BoundingBox As RectangleF
    Get

Property Value

Type: RectangleF

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon.Center Property

[image]

In-Sight SDK
CvsGraphicPolygon..::..Center Property
CvsGraphicPolygon Class See Also Send Feedback
Returns the center of the polygon's bounding box.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Center { get; }
Visual Basic
Public ReadOnly Property Center As CvsImageLocation
    Get

Property Value

Type: CvsImageLocation

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon.EditBounds Property

[image]

In-Sight SDK
CvsGraphicPolygon..::..EditBounds Property
CvsGraphicPolygon Class See Also Send Feedback
Gets or sets the edit boundary for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle EditBounds { get; set; }
Visual Basic
Public Property EditBounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon.EditFlags Property

[image]

In-Sight SDK
CvsGraphicPolygon..::..EditFlags Property
CvsGraphicPolygon Class See Also Send Feedback
Gets or sets the allowed edit modes for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEditFlags EditFlags { get; set; }
Visual Basic
Public Property EditFlags As CvsEditFlags
    Get
    Set

Property Value

Type: CvsEditFlags

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon.PointCount Property

[image]

In-Sight SDK
CvsGraphicPolygon..::..PointCount Property
CvsGraphicPolygon Class See Also Send Feedback
Gets the number of points in the polygon.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int PointCount { get; }
Visual Basic
Public ReadOnly Property PointCount As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon.Points Property

[image]

In-Sight SDK
CvsGraphicPolygon..::..Points Property
CvsGraphicPolygon Class See Also Send Feedback
Gets or sets the array of points which define this polygon. The points are copied from the source array.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation[] Points { get; set; }
Visual Basic
Public Property Points As CvsImageLocation()
    Get
    Set

Property Value

Type: array< CvsImageLocation >[]()[][]

Remarks

The points are defined in Sensor coordinates.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicPolygon Class
CvsGraphicPolygon..::..CvsGraphicPolygon Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolygon Events

[image] [image]

In-Sight SDK
CvsGraphicPolygon Events
CvsGraphicPolygon Class See Also Send Feedback

The CvsGraphicPolygon type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicPolygon Class
Cognex.InSight.Graphic Namespace


CvsGraphicPolyline Class

[image]

In-Sight SDK
CvsGraphicPolyline Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight polyline graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicPolyline : CvsGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicPolyline
    Inherits CvsGraphic

Remarks

CvsGraphicPolyline objects are returned as items in a CvsGraphicCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicPolyline

See Also

CvsGraphicPolyline..::..CvsGraphicPolyline Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolyline Members

[image] [image]

In-Sight SDK
CvsGraphicPolyline Members
CvsGraphicPolyline Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicPolyline type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicPolyline()()()() | Initializes a new instance of the CvsGraphicPolyline class.
Public method | CvsGraphicPolyline(CvsGraphicPolyline) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicPolyline(CvsCellLocation, array<CvsImageLocation>[]()[][]) | Initializes a new instance.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPoints | Returns the array of the points of the graphic.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | NumPoints | Gets the number of points within the polyline graphic.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicPolyline Class
Cognex.InSight.Graphic Namespace


CvsGraphicPolyline Constructor

[image] [image]

In-Sight SDK
CvsGraphicPolyline Constructor
CvsGraphicPolyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicPolyline()()()() | Initializes a new instance of the CvsGraphicPolyline class.
Public method | CvsGraphicPolyline(CvsGraphicPolyline) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicPolyline(CvsCellLocation, array<CvsImageLocation>[]()[][]) | Initializes a new instance.

See Also

CvsGraphicPolyline Class
CvsGraphicPolyline..::..CvsGraphicPolyline Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolyline Constructor

[image]

In-Sight SDK
CvsGraphicPolyline Constructor
CvsGraphicPolyline Class See Also Send Feedback
Initializes a new instance of the CvsGraphicPolyline class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPolyline()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicPolyline Class
CvsGraphicPolyline..::..CvsGraphicPolyline Members
CvsGraphicPolyline Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPolyline Constructor (CvsGraphicPolyline)

[image]

In-Sight SDK
CvsGraphicPolyline Constructor (CvsGraphicPolyline)
CvsGraphicPolyline Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPolyline(
    CvsGraphicPolyline graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicPolyline
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicPolyline
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicPolyline Class
CvsGraphicPolyline..::..CvsGraphicPolyline Members
CvsGraphicPolyline Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPolyline Constructor (CvsCellLocation, CvsImageLocation[])

[image]

In-Sight SDK
CvsGraphicPolyline Constructor (CvsCellLocation, array<CvsImageLocation>[]()[][])
CvsGraphicPolyline Class See Also Send Feedback
Initializes a new instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPolyline(
    CvsCellLocation cellLocation,
    CvsImageLocation[] points
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    points As CvsImageLocation()
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell location of this graphic.
points
Type: array< Cognex.InSight..::..CvsImageLocation >[]()[][]
An array of points with which to initialize the graphic.

See Also

CvsGraphicPolyline Class
CvsGraphicPolyline..::..CvsGraphicPolyline Members
CvsGraphicPolyline Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPolyline Methods

[image] [image]

In-Sight SDK
CvsGraphicPolyline Methods
CvsGraphicPolyline Class See Also Send Feedback

The CvsGraphicPolyline type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetPoints | Returns the array of the points of the graphic.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicPolyline Class
Cognex.InSight.Graphic Namespace


CvsGraphicPolyline.GetPoints Method

[image]

In-Sight SDK
CvsGraphicPolyline..::..GetPoints Method
CvsGraphicPolyline Class See Also Send Feedback
Returns the array of the points of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation[] GetPoints()
Visual Basic
Public Function GetPoints As CvsImageLocation()

Return Value

Type: array< CvsImageLocation >[]()[][]
An array of point in which each point is a vertex of the polyline.

Remarks

Each Row designates the pixels from the top of the CvsImage. Each Column designates the pixels from the left side of the CvsImage.

See Also

CvsGraphicPolyline Class
CvsGraphicPolyline..::..CvsGraphicPolyline Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolyline.Initialize Method

[image]

In-Sight SDK
CvsGraphicPolyline..::..Initialize Method
CvsGraphicPolyline Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    CvsImageLocation[] points
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    points As CvsImageLocation()
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
points
Type: array< Cognex.InSight..::..CvsImageLocation >[]()[][]
The list of points.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicPolyline Class
CvsGraphicPolyline..::..CvsGraphicPolyline Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolyline Properties

[image] [image]

In-Sight SDK
CvsGraphicPolyline Properties
CvsGraphicPolyline Class See Also Send Feedback

The CvsGraphicPolyline type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | NumPoints | Gets the number of points within the polyline graphic.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicPolyline Class
Cognex.InSight.Graphic Namespace


CvsGraphicPolyline.NumPoints Property

[image]

In-Sight SDK
CvsGraphicPolyline..::..NumPoints Property
CvsGraphicPolyline Class See Also Send Feedback
Gets the number of points within the polyline graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int NumPoints { get; }
Visual Basic
Public ReadOnly Property NumPoints As Integer
    Get

Property Value

Type: Int32

See Also

CvsGraphicPolyline Class
CvsGraphicPolyline..::..CvsGraphicPolyline Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolyline Events

[image] [image]

In-Sight SDK
CvsGraphicPolyline Events
CvsGraphicPolyline Class See Also Send Feedback

The CvsGraphicPolyline type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicPolyline Class
Cognex.InSight.Graphic Namespace


CvsGraphicPolylinePath Class

[image]

In-Sight SDK
CvsGraphicPolylinePath Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight CompositeRegion graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicPolylinePath : CvsGraphicCompositeBase
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicPolylinePath
    Inherits CvsGraphicCompositeBase

Remarks

CvsGraphicComposite objects are returned as items in a CvsGraphicCollection.

A CvsGraphicComposite is an editable graphic and may be edited by a control and returned to the In-Sight sensor.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicCompositeBase
Cognex.InSight.Graphic..::..CvsGraphicPolylinePath

See Also

CvsGraphicPolylinePath..::..CvsGraphicPolylinePath Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolylinePath Members

[image] [image]

In-Sight SDK
CvsGraphicPolylinePath Members
CvsGraphicPolylinePath Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicPolylinePath type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicPolylinePath()()()() | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicPolylinePath(array<CvsCompositeSubregion>[]()[][]) | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicPolylinePath(CvsGraphicPolylinePath) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicPolylinePath(CvsCellLocation, array<CvsCompositeSubregion>[]()[][], String) | Initializes a new instance of the CvsGraphicComposite class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | ClearSubregions | Remove all the subregions (Inherited from CvsGraphicCompositeBase.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | DeleteSubregion | Remove the subregion from the composite. (Inherited from CvsGraphicCompositeBase.)
Public method | DeleteSubregionByIndex | Remove the subregion at the specified index. (Inherited from CvsGraphicCompositeBase.)
Public method | DeleteSubregions | Deletes subregions in the specified range. (Inherited from CvsGraphicCompositeBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetSubregionOperation | Returns the operation of the specified subregion. (Inherited from CvsGraphicCompositeBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertAnnulus | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertCircle | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertPolygon | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertRegion | Insert a subregion based on the provided CvsGraphicRegion object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionAnnulus | Update the subregion using the provided CvsGraphicAnnulus object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionCircle | Update the subregion using the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionOperation | Modifies the operation of the specified subregion. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionPolygon | Insert a subregion based on the provided CvsGraphicPolygon object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionRegion | Update the subregion using the provided CvsGraphicRegion object. (Inherited from CvsGraphicCompositeBase.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditFlags | Gets or sets the allowed edit modes for this graphic. (Inherited from CvsGraphicCompositeBase.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Subregions | Gets or sets the array of CvsCompositeSubregion objects which define this composite region. (Inherited from CvsGraphicCompositeBase.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicPolylinePath Class
Cognex.InSight.Graphic Namespace


CvsGraphicPolylinePath Constructor

[image] [image]

In-Sight SDK
CvsGraphicPolylinePath Constructor
CvsGraphicPolylinePath Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicPolylinePath()()()() | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicPolylinePath(array<CvsCompositeSubregion>[]()[][]) | Initializes a new instance of the CvsGraphicComposite class.
Public method | CvsGraphicPolylinePath(CvsGraphicPolylinePath) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicPolylinePath(CvsCellLocation, array<CvsCompositeSubregion>[]()[][], String) | Initializes a new instance of the CvsGraphicComposite class.

See Also

CvsGraphicPolylinePath Class
CvsGraphicPolylinePath..::..CvsGraphicPolylinePath Members
Cognex.InSight.Graphic Namespace


CvsGraphicPolylinePath Constructor

[image]

In-Sight SDK
CvsGraphicPolylinePath Constructor
CvsGraphicPolylinePath Class See Also Send Feedback
Initializes a new instance of the CvsGraphicComposite class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPolylinePath()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicPolylinePath Class
CvsGraphicPolylinePath..::..CvsGraphicPolylinePath Members
CvsGraphicPolylinePath Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPolylinePath Constructor (CvsCompositeSubregion[])

[image]

In-Sight SDK
CvsGraphicPolylinePath Constructor (array<CvsCompositeSubregion>[]()[][])
CvsGraphicPolylinePath Class See Also Send Feedback
Initializes a new instance of the CvsGraphicComposite class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPolylinePath(
    CvsCompositeSubregion[] subRegions
)
Visual Basic
Public Sub New (
    subRegions As CvsCompositeSubregion()
)

Parameters

subRegions
Type: array< Cognex.InSight.Graphic..::..CvsCompositeSubregion >[]()[][]
Subregions which define the CompositeRegion.

See Also

CvsGraphicPolylinePath Class
CvsGraphicPolylinePath..::..CvsGraphicPolylinePath Members
CvsGraphicPolylinePath Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPolylinePath Constructor (CvsGraphicPolylinePath)

[image]

In-Sight SDK
CvsGraphicPolylinePath Constructor (CvsGraphicPolylinePath)
CvsGraphicPolylinePath Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPolylinePath(
    CvsGraphicPolylinePath graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicPolylinePath
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicPolylinePath
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicPolylinePath Class
CvsGraphicPolylinePath..::..CvsGraphicPolylinePath Members
CvsGraphicPolylinePath Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPolylinePath Constructor (CvsCellLocation, CvsCompositeSubregion[], String)

[image]

In-Sight SDK
CvsGraphicPolylinePath Constructor (CvsCellLocation, array<CvsCompositeSubregion>[]()[][], String)
CvsGraphicPolylinePath Class See Also Send Feedback
Initializes a new instance of the CvsGraphicComposite class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicPolylinePath(
    CvsCellLocation cellLocation,
    CvsCompositeSubregion[] subRegions,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    subRegions As CvsCompositeSubregion(),
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
subRegions
Type: array< Cognex.InSight.Graphic..::..CvsCompositeSubregion >[]()[][]
Subregions which define the CompositeRegion.
label
Type: System..::..String
The label to draw for this graphic

Remarks

The graphic constructed may be passed to the SetEditGraphic(CvsGraphic) method to set the graphic associated with an edit cell function.

See Also

CvsGraphicPolylinePath Class
CvsGraphicPolylinePath..::..CvsGraphicPolylinePath Members
CvsGraphicPolylinePath Overload
Cognex.InSight.Graphic Namespace


CvsGraphicPolylinePath Methods

[image] [image]

In-Sight SDK
CvsGraphicPolylinePath Methods
CvsGraphicPolylinePath Class See Also Send Feedback

The CvsGraphicPolylinePath type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | ClearSubregions | Remove all the subregions (Inherited from CvsGraphicCompositeBase.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | DeleteSubregion | Remove the subregion from the composite. (Inherited from CvsGraphicCompositeBase.)
Public method | DeleteSubregionByIndex | Remove the subregion at the specified index. (Inherited from CvsGraphicCompositeBase.)
Public method | DeleteSubregions | Deletes subregions in the specified range. (Inherited from CvsGraphicCompositeBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetSubregionOperation | Returns the operation of the specified subregion. (Inherited from CvsGraphicCompositeBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertAnnulus | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertCircle | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertPolygon | Insert a subregion based on the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | InsertRegion | Insert a subregion based on the provided CvsGraphicRegion object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionAnnulus | Update the subregion using the provided CvsGraphicAnnulus object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionCircle | Update the subregion using the provided CvsGraphicCircle object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionOperation | Modifies the operation of the specified subregion. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionPolygon | Insert a subregion based on the provided CvsGraphicPolygon object. (Inherited from CvsGraphicCompositeBase.)
Public method | SetSubregionRegion | Update the subregion using the provided CvsGraphicRegion object. (Inherited from CvsGraphicCompositeBase.)
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicPolylinePath Class
Cognex.InSight.Graphic Namespace


CvsGraphicPolylinePath Properties

[image] [image]

In-Sight SDK
CvsGraphicPolylinePath Properties
CvsGraphicPolylinePath Class See Also Send Feedback

The CvsGraphicPolylinePath type exposes the following members.

Properties

 | Name | Description
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | EditFlags | Gets or sets the allowed edit modes for this graphic. (Inherited from CvsGraphicCompositeBase.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Subregions | Gets or sets the array of CvsCompositeSubregion objects which define this composite region. (Inherited from CvsGraphicCompositeBase.)
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicPolylinePath Class
Cognex.InSight.Graphic Namespace


CvsGraphicPolylinePath Events

[image] [image]

In-Sight SDK
CvsGraphicPolylinePath Events
CvsGraphicPolylinePath Class See Also Send Feedback

The CvsGraphicPolylinePath type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicPolylinePath Class
Cognex.InSight.Graphic Namespace


CvsGraphicRegion Class

[image]

In-Sight SDK
CvsGraphicRegion Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight region graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicRegion : CvsGraphic,
    ICvsEditableGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicRegion
    Inherits CvsGraphic
    Implements ICvsEditableGraphic

Remarks

CvsGraphicRegion objects are returned as items in a CvsGraphicCollection. They are generated by many functions including: EditRegion, ExtractBlobs, Region, et al.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicRegion

See Also

CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion Members

[image] [image]

In-Sight SDK
CvsGraphicRegion Members
CvsGraphicRegion Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicRegion type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicRegion()()()() | Initializes a new instance of the CvsGraphicRegion class.
Public method | CvsGraphicRegion(CvsGraphicRegion) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicRegion(CvsCellLocation, CvsImageLocation, Single, Single, Single, Single, String) | Initializes a new instance of the CvsGraphicRegion class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | Angle | Gets or sets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | Curve | Gets or sets the curve of the graphic. The curve is the angular deviation between the region's vertical axis and the opposing boundary line.
Public property | DisplayAxisLabels | True to display the x and y axis labels on the image
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | Height | Gets or sets the height (in pixels) of the graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | LabelBackColor | Gets or sets the text label background color associated with the graphic, or Color.Empty if no color was specified.
Public property | LabelBackColorAsRgb | Gets or sets the LabelBackColor as an RGB value.
Public property | LabelForeColor | Gets or sets the text label foreground color associated with the graphic, or Color.Empty if no color was specified.
Public property | LabelForeColorAsRgb | Gets or sets the LabelForeColor as an RGB value.
Public property | Location | Gets or sets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | MaximumSize | Gets or sets the maximum size this region can be edited to
Public property | MinimumSize | Gets or sets the minimum size this region can be edited to
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)
Public property | Width | Gets or sets the width (in pixels) of the graphic.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicRegion Class
Cognex.InSight.Graphic Namespace


CvsGraphicRegion Constructor

[image] [image]

In-Sight SDK
CvsGraphicRegion Constructor
CvsGraphicRegion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicRegion()()()() | Initializes a new instance of the CvsGraphicRegion class.
Public method | CvsGraphicRegion(CvsGraphicRegion) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicRegion(CvsCellLocation, CvsImageLocation, Single, Single, Single, Single, String) | Initializes a new instance of the CvsGraphicRegion class.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion Constructor

[image]

In-Sight SDK
CvsGraphicRegion Constructor
CvsGraphicRegion Class See Also Send Feedback
Initializes a new instance of the CvsGraphicRegion class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicRegion()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
CvsGraphicRegion Overload
Cognex.InSight.Graphic Namespace


CvsGraphicRegion Constructor (CvsGraphicRegion)

[image]

In-Sight SDK
CvsGraphicRegion Constructor (CvsGraphicRegion)
CvsGraphicRegion Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicRegion(
    CvsGraphicRegion graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicRegion
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicRegion
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
CvsGraphicRegion Overload
Cognex.InSight.Graphic Namespace


CvsGraphicRegion Constructor (CvsCellLocation, CvsImageLocation, Single, Single, Single, Single, String)

[image]

In-Sight SDK
CvsGraphicRegion Constructor (CvsCellLocation, CvsImageLocation, Single, Single, Single, Single, String)
CvsGraphicRegion Class See Also Send Feedback
Initializes a new instance of the CvsGraphicRegion class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicRegion(
    CvsCellLocation cellLocation,
    CvsImageLocation location,
    float height,
    float width,
    float angle,
    float curve,
    string label
)
Visual Basic
Public Sub New (
    cellLocation As CvsCellLocation,
    location As CvsImageLocation,
    height As Single,
    width As Single,
    angle As Single,
    curve As Single,
    label As String
)

Parameters

cellLocation
Type: Cognex.InSight..::..CvsCellLocation
The cell's location.
location
Type: Cognex.InSight..::..CvsImageLocation
The offset of the region in pixels.
height
Type: System..::..Single
The height of the region in pixels.
width
Type: System..::..Single
The width of the region in pixels.
angle
Type: System..::..Single
The orientation (angle) of the region.
curve
Type: System..::..Single
The curve of the region.
label
Type: System..::..String
The label associated with this region.

Remarks

The graphic constructed may be passed to the SetEditGraphic(CvsGraphic) method to set the graphic associated with an edit cell function.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
CvsGraphicRegion Overload
Cognex.InSight.Graphic Namespace


CvsGraphicRegion Methods

[image] [image]

In-Sight SDK
CvsGraphicRegion Methods
CvsGraphicRegion Class See Also Send Feedback

The CvsGraphicRegion type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicRegion Class
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.Initialize Method

[image]

In-Sight SDK
CvsGraphicRegion..::..Initialize Method
CvsGraphicRegion Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float regionRow,
    float regionCol,
    float regionHeight,
    float regionWidth,
    float regionAngle,
    float regionCurve,
    string regionLabel
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    regionRow As Single,
    regionCol As Single,
    regionHeight As Single,
    regionWidth As Single,
    regionAngle As Single,
    regionCurve As Single,
    regionLabel As String
)

Parameters

cellRow
Type: System..::..Int32
The cell's row location.
cellCol
Type: System..::..Int32
The cell's column location.
regionRow
Type: System..::..Single
The region's row location.
regionCol
Type: System..::..Single
The region's column location.
regionHeight
Type: System..::..Single
The height of the region in pixels.
regionWidth
Type: System..::..Single
The width of the region in pixels.
regionAngle
Type: System..::..Single
The orientation (angle) of the region.
regionCurve
Type: System..::..Single
The curve of the region.
regionLabel
Type: System..::..String
The label associated with this region.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion Properties

[image] [image]

In-Sight SDK
CvsGraphicRegion Properties
CvsGraphicRegion Class See Also Send Feedback

The CvsGraphicRegion type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets or sets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | Curve | Gets or sets the curve of the graphic. The curve is the angular deviation between the region's vertical axis and the opposing boundary line.
Public property | DisplayAxisLabels | True to display the x and y axis labels on the image
Public property | EditBounds | Gets or Sets the edit boundary for this graphic.
Public property | EditFlags | Gets or Sets the allowed edit modes for this graphic.
Public property | Height | Gets or sets the height (in pixels) of the graphic.
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | LabelBackColor | Gets or sets the text label background color associated with the graphic, or Color.Empty if no color was specified.
Public property | LabelBackColorAsRgb | Gets or sets the LabelBackColor as an RGB value.
Public property | LabelForeColor | Gets or sets the text label foreground color associated with the graphic, or Color.Empty if no color was specified.
Public property | LabelForeColorAsRgb | Gets or sets the LabelForeColor as an RGB value.
Public property | Location | Gets or sets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | MaximumSize | Gets or sets the maximum size this region can be edited to
Public property | MinimumSize | Gets or sets the minimum size this region can be edited to
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)
Public property | Width | Gets or sets the width (in pixels) of the graphic.

See Also

CvsGraphicRegion Class
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.Angle Property

[image]

In-Sight SDK
CvsGraphicRegion..::..Angle Property
CvsGraphicRegion Class See Also Send Feedback
Gets or sets the orientation (angle) of the graphic. The angle is measured counter-clockwise relative to the horizontal axis.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Angle { get; set; }
Visual Basic
Public Property Angle As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.Curve Property

[image]

In-Sight SDK
CvsGraphicRegion..::..Curve Property
CvsGraphicRegion Class See Also Send Feedback
Gets or sets the curve of the graphic. The curve is the angular deviation between the region's vertical axis and the opposing boundary line.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Curve { get; set; }
Visual Basic
Public Property Curve As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.DisplayAxisLabels Property

[image]

In-Sight SDK
CvsGraphicRegion..::..DisplayAxisLabels Property
CvsGraphicRegion Class See Also Send Feedback
True to display the x and y axis labels on the image

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool DisplayAxisLabels { get; set; }
Visual Basic
Public Property DisplayAxisLabels As Boolean
    Get
    Set

Property Value

Type: Boolean

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.EditBounds Property

[image]

In-Sight SDK
CvsGraphicRegion..::..EditBounds Property
CvsGraphicRegion Class See Also Send Feedback
Gets or Sets the edit boundary for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Rectangle EditBounds { get; set; }
Visual Basic
Public Property EditBounds As Rectangle
    Get
    Set

Property Value

Type: Rectangle

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.EditFlags Property

[image]

In-Sight SDK
CvsGraphicRegion..::..EditFlags Property
CvsGraphicRegion Class See Also Send Feedback
Gets or Sets the allowed edit modes for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEditFlags EditFlags { get; set; }
Visual Basic
Public Property EditFlags As CvsEditFlags
    Get
    Set

Property Value

Type: CvsEditFlags

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.Height Property

[image]

In-Sight SDK
CvsGraphicRegion..::..Height Property
CvsGraphicRegion Class See Also Send Feedback
Gets or sets the height (in pixels) of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Height { get; set; }
Visual Basic
Public Property Height As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.LabelBackColor Property

[image]

In-Sight SDK
CvsGraphicRegion..::..LabelBackColor Property
CvsGraphicRegion Class See Also Send Feedback
Gets or sets the text label background color associated with the graphic, or Color.Empty if no color was specified.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color LabelBackColor { get; set; }
Visual Basic
Public Property LabelBackColor As Color
    Get
    Set

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.LabelBackColorAsRgb Property

[image]

In-Sight SDK
CvsGraphicRegion..::..LabelBackColorAsRgb Property
CvsGraphicRegion Class See Also Send Feedback
Gets or sets the LabelBackColor as an RGB value.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int LabelBackColorAsRgb { get; set; }
Visual Basic
Public Property LabelBackColorAsRgb As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.LabelForeColor Property

[image]

In-Sight SDK
CvsGraphicRegion..::..LabelForeColor Property
CvsGraphicRegion Class See Also Send Feedback
Gets or sets the text label foreground color associated with the graphic, or Color.Empty if no color was specified.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color LabelForeColor { get; set; }
Visual Basic
Public Property LabelForeColor As Color
    Get
    Set

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.LabelForeColorAsRgb Property

[image]

In-Sight SDK
CvsGraphicRegion..::..LabelForeColorAsRgb Property
CvsGraphicRegion Class See Also Send Feedback
Gets or sets the LabelForeColor as an RGB value.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int LabelForeColorAsRgb { get; set; }
Visual Basic
Public Property LabelForeColorAsRgb As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.Location Property

[image]

In-Sight SDK
CvsGraphicRegion..::..Location Property
CvsGraphicRegion Class See Also Send Feedback
Gets or sets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Location { get; set; }
Visual Basic
Public Property Location As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.MaximumSize Property

[image]

In-Sight SDK
CvsGraphicRegion..::..MaximumSize Property
CvsGraphicRegion Class See Also Send Feedback
Gets or sets the maximum size this region can be edited to

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Size MaximumSize { get; set; }
Visual Basic
Public Property MaximumSize As Size
    Get
    Set

Property Value

Type: Size

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.MinimumSize Property

[image]

In-Sight SDK
CvsGraphicRegion..::..MinimumSize Property
CvsGraphicRegion Class See Also Send Feedback
Gets or sets the minimum size this region can be edited to

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Size MinimumSize { get; set; }
Visual Basic
Public Property MinimumSize As Size
    Get
    Set

Property Value

Type: Size

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion.Width Property

[image]

In-Sight SDK
CvsGraphicRegion..::..Width Property
CvsGraphicRegion Class See Also Send Feedback
Gets or sets the width (in pixels) of the graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float Width { get; set; }
Visual Basic
Public Property Width As Single
    Get
    Set

Property Value

Type: Single

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicRegion Class
CvsGraphicRegion..::..CvsGraphicRegion Members
Cognex.InSight.Graphic Namespace


CvsGraphicRegion Events

[image] [image]

In-Sight SDK
CvsGraphicRegion Events
CvsGraphicRegion Class See Also Send Feedback

The CvsGraphicRegion type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicRegion Class
Cognex.InSight.Graphic Namespace


CvsGraphicText Class

[image]

In-Sight SDK
CvsGraphicText Class
Members See Also Send Feedback
Encapsulates the data associated with an In-Sight text graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsGraphicText : CvsGraphic
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsGraphicText
    Inherits CvsGraphic

Remarks

CvsGraphicText objects are returned as items in a CvsGraphicCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsGraphic
Cognex.InSight.Graphic..::..CvsGraphicText

See Also

CvsGraphicText..::..CvsGraphicText Members
Cognex.InSight.Graphic Namespace


CvsGraphicText Members

[image] [image]

In-Sight SDK
CvsGraphicText Members
CvsGraphicText Class Constructors Methods Properties Events See Also Send Feedback

The CvsGraphicText type exposes the following members.

Constructors

 | Name | Description
Public method | CvsGraphicText()()()() | Initializes a new instance of the CvsGraphicText class.
Public method | CvsGraphicText(CvsGraphicText) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicText(CvsCellLocation, CvsImageLocation, String) | Initializes a new instance of the CvsGraphicText class.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes a new instance of the CvsGraphicText class.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

Properties

 | Name | Description
Public property | BackColor | Gets the text label background color associated with the graphic, or Color.Empty if no color was specified.
Public property | BackColorAsRgb | Gets the BackColor as an RGB value.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | IsPlotString | Returns true if this is a PlotString graphic.
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Location | Gets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicText Class
Cognex.InSight.Graphic Namespace


CvsGraphicText Constructor

[image] [image]

In-Sight SDK
CvsGraphicText Constructor
CvsGraphicText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsGraphicText()()()() | Initializes a new instance of the CvsGraphicText class.
Public method | CvsGraphicText(CvsGraphicText) | Initializes a new instance that is a copy of the specified instance.
Public method | CvsGraphicText(CvsCellLocation, CvsImageLocation, String) | Initializes a new instance of the CvsGraphicText class.

See Also

CvsGraphicText Class
CvsGraphicText..::..CvsGraphicText Members
Cognex.InSight.Graphic Namespace


CvsGraphicText Constructor

[image]

In-Sight SDK
CvsGraphicText Constructor
CvsGraphicText Class See Also Send Feedback
Initializes a new instance of the CvsGraphicText class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicText()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsGraphicText Class
CvsGraphicText..::..CvsGraphicText Members
CvsGraphicText Overload
Cognex.InSight.Graphic Namespace


CvsGraphicText Constructor (CvsGraphicText)

[image]

In-Sight SDK
CvsGraphicText Constructor (CvsGraphicText)
CvsGraphicText Class See Also Send Feedback
Initializes a new instance that is a copy of the specified instance.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicText(
    CvsGraphicText graphic
)
Visual Basic
Public Sub New (
    graphic As CvsGraphicText
)

Parameters

graphic
Type: Cognex.InSight.Graphic..::..CvsGraphicText
The instance to copy.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The graphic is a null reference (Nothing in Visual Basic).

See Also

CvsGraphicText Class
CvsGraphicText..::..CvsGraphicText Members
CvsGraphicText Overload
Cognex.InSight.Graphic Namespace


CvsGraphicText Constructor (CvsCellLocation, CvsImageLocation, String)

[image]

In-Sight SDK
CvsGraphicText Constructor (CvsCellLocation, CvsImageLocation, String)
CvsGraphicText Class See Also Send Feedback
Initializes a new instance of the CvsGraphicText class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsGraphicText(
    CvsCellLocation cell,
    CvsImageLocation location,
    string label
)
Visual Basic
Public Sub New (
    cell As CvsCellLocation,
    location As CvsImageLocation,
    label As String
)

Parameters

cell
Type: Cognex.InSight..::..CvsCellLocation
The spreadsheet cell associated with this graphic.
location
Type: Cognex.InSight..::..CvsImageLocation
The image location of this graphic.
label
Type: System..::..String
The text to draw on the image.

See Also

CvsGraphicText Class
CvsGraphicText..::..CvsGraphicText Members
CvsGraphicText Overload
Cognex.InSight.Graphic Namespace


CvsGraphicText Methods

[image] [image]

In-Sight SDK
CvsGraphicText Methods
CvsGraphicText Class See Also Send Feedback

The CvsGraphicText type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyChangedHandler | Stores a weak reference to the handler. The caller must hold a reference to the handler to prevent the handler from getting garbage collected before the caller. Usage: replace mGraphic.PropertyChanged += CvsGraphic_PropertyChanged with: private readonly PropertyChangedEventHandler mGraphicChangedHandler; CvsDisplayableFoo(CvsGraphicFoo graphic) { mGraphic = graphic; mGraphicChangedHandler = CvsGraphic_PropertyChanged; mGraphic.AddPropertyChangedHandler(mGraphicChangedHandler); } (Inherited from CvsGraphic.)
Public method | Clone | Clone this CvsGraphic object. (Inherited from CvsGraphic.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from CvsGraphic.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes a new instance of the CvsGraphicText class.
Public method | ToString | Returns a string that identifies this graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicText Class
Cognex.InSight.Graphic Namespace


CvsGraphicText.Initialize Method

[image]

In-Sight SDK
CvsGraphicText..::..Initialize Method
CvsGraphicText Class See Also Send Feedback
Initializes a new instance of the CvsGraphicText class.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    int cellRow,
    int cellCol,
    float textRow,
    float textCol,
    string label
)
Visual Basic
Public Sub Initialize (
    cellRow As Integer,
    cellCol As Integer,
    textRow As Single,
    textCol As Single,
    label As String
)

Parameters

cellRow
Type: System..::..Int32
The spreadsheet cell row associated with this graphic.
cellCol
Type: System..::..Int32
The spreadsheet cell column associated with this graphic.
textRow
Type: System..::..Single
The image row of this graphic.
textCol
Type: System..::..Single
The image column of this graphic.
label
Type: System..::..String
The text to draw on the image.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicText Class
CvsGraphicText..::..CvsGraphicText Members
Cognex.InSight.Graphic Namespace


CvsGraphicText Properties

[image] [image]

In-Sight SDK
CvsGraphicText Properties
CvsGraphicText Class See Also Send Feedback

The CvsGraphicText type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | Gets the text label background color associated with the graphic, or Color.Empty if no color was specified.
Public property | BackColorAsRgb | Gets the BackColor as an RGB value.
Public property | CellLocation | Gets the cell location with which the graphic is associated. (Inherited from CvsGraphic.)
Public property | Color | Gets or sets the foreground color of the graphic. (Inherited from CvsGraphic.)
Public property | HighlightColor | Gets the foreground color of the graphic to be used when the graphic in highlighted. (Inherited from CvsGraphic.)
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value. (Inherited from CvsGraphic.)
Public property | IsAlwaysShown | Gets a value that indicates whether or not the current graphic should always be shown. If IsAlwaysShown is true, then the graphic should always be displayed, regardless of what the current cell is. Otherwise, the graphic should only be displayed when the reference cell is selected. (Inherited from CvsGraphic.)
Public property | IsDefaultEdit | Gets a value that indicates whether or not the graphic is the default graphic for the cell which contains it. (Inherited from CvsGraphic.)
Public property | IsLocked | Returns true if this graphic is contained in a result set and originated from an In-Sight connection. A locked CvsGraphic object cannot be changed. (Inherited from CvsGraphic.)
Public property | IsPlotString | Returns true if this is a PlotString graphic.
Public property | Label | Gets the text label associated with the graphic. (Inherited from CvsGraphic.)
Public property | Location | Gets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.
Public property | TransparentColor | Gets or sets the transparent color of the graphic. (Inherited from CvsGraphic.)

See Also

CvsGraphicText Class
Cognex.InSight.Graphic Namespace


CvsGraphicText.BackColor Property

[image]

In-Sight SDK
CvsGraphicText..::..BackColor Property
CvsGraphicText Class See Also Send Feedback
Gets the text label background color associated with the graphic, or Color.Empty if no color was specified.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color BackColor { get; set; }
Visual Basic
Public Property BackColor As Color
    Get
    Set

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicText Class
CvsGraphicText..::..CvsGraphicText Members
Cognex.InSight.Graphic Namespace


CvsGraphicText.BackColorAsRgb Property

[image]

In-Sight SDK
CvsGraphicText..::..BackColorAsRgb Property
CvsGraphicText Class See Also Send Feedback
Gets the BackColor as an RGB value.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int BackColorAsRgb { get; set; }
Visual Basic
Public Property BackColorAsRgb As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicText Class
CvsGraphicText..::..CvsGraphicText Members
Cognex.InSight.Graphic Namespace


CvsGraphicText.IsPlotString Property

[image]

In-Sight SDK
CvsGraphicText..::..IsPlotString Property
CvsGraphicText Class See Also Send Feedback
Returns true if this is a PlotString graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsPlotString { get; }
Visual Basic
Public ReadOnly Property IsPlotString As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsGraphicText Class
CvsGraphicText..::..CvsGraphicText Members
Cognex.InSight.Graphic Namespace


CvsGraphicText.Location Property

[image]

In-Sight SDK
CvsGraphicText..::..Location Property
CvsGraphicText Class See Also Send Feedback
Gets the location of the graphic. The Row designates the pixels from the top of the CvsImage. The Column designates the pixels from the left side of the CvsImage.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation Location { get; set; }
Visual Basic
Public Property Location As CvsImageLocation
    Get
    Set

Property Value

Type: CvsImageLocation

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a set operation was attempted when the IsLocked property is true.

See Also

CvsGraphicText Class
CvsGraphicText..::..CvsGraphicText Members
Cognex.InSight.Graphic Namespace


CvsGraphicText Events

[image] [image]

In-Sight SDK
CvsGraphicText Events
CvsGraphicText Class See Also Send Feedback

The CvsGraphicText type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | This event is raised every time a settable property of the graphic is set. (Inherited from CvsGraphic.)

See Also

CvsGraphicText Class
Cognex.InSight.Graphic Namespace


CvsPatternMatchSegment Class

[image]

In-Sight SDK
CvsPatternMatchSegment Class
Members See Also Send Feedback
Defines a single colored segment for a CvsGraphicPatternMatch graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsPatternMatchSegment
Visual Basic
<SerializableAttribute>
Public Class CvsPatternMatchSegment

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Graphic..::..CvsPatternMatchSegment

See Also

CvsPatternMatchSegment..::..CvsPatternMatchSegment Members
Cognex.InSight.Graphic Namespace


CvsPatternMatchSegment Members

[image] [image]

In-Sight SDK
CvsPatternMatchSegment Members
CvsPatternMatchSegment Class Methods Properties See Also Send Feedback

The CvsPatternMatchSegment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | Gets the unhighlighted color of the line segment.
Public property | ColorAsRgb | Gets the Color as an RGB value.
Public property | EndLocation | Gets the location of the second point of the line segment.
Public property | HighlightColor | Gets the highlighted color of the line segment.
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value.
Public property | StartLocation | Gets the location of the first point of the line segment.

See Also

CvsPatternMatchSegment Class
Cognex.InSight.Graphic Namespace


CvsPatternMatchSegment Methods

[image] [image]

In-Sight SDK
CvsPatternMatchSegment Methods
CvsPatternMatchSegment Class See Also Send Feedback

The CvsPatternMatchSegment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsPatternMatchSegment Class
Cognex.InSight.Graphic Namespace


CvsPatternMatchSegment Properties

[image] [image]

In-Sight SDK
CvsPatternMatchSegment Properties
CvsPatternMatchSegment Class See Also Send Feedback

The CvsPatternMatchSegment type exposes the following members.

Properties

 | Name | Description
Public property | Color | Gets the unhighlighted color of the line segment.
Public property | ColorAsRgb | Gets the Color as an RGB value.
Public property | EndLocation | Gets the location of the second point of the line segment.
Public property | HighlightColor | Gets the highlighted color of the line segment.
Public property | HighlightColorAsRgb | Gets the HighlightColor as an RGB value.
Public property | StartLocation | Gets the location of the first point of the line segment.

See Also

CvsPatternMatchSegment Class
Cognex.InSight.Graphic Namespace


CvsPatternMatchSegment.Color Property

[image]

In-Sight SDK
CvsPatternMatchSegment..::..Color Property
CvsPatternMatchSegment Class See Also Send Feedback
Gets the unhighlighted color of the line segment.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color Color { get; }
Visual Basic
Public ReadOnly Property Color As Color
    Get

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

See Also

CvsPatternMatchSegment Class
CvsPatternMatchSegment..::..CvsPatternMatchSegment Members
Cognex.InSight.Graphic Namespace


CvsPatternMatchSegment.ColorAsRgb Property

[image]

In-Sight SDK
CvsPatternMatchSegment..::..ColorAsRgb Property
CvsPatternMatchSegment Class See Also Send Feedback
Gets the Color as an RGB value.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int ColorAsRgb { get; }
Visual Basic
Public ReadOnly Property ColorAsRgb As Integer
    Get

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

See Also

CvsPatternMatchSegment Class
CvsPatternMatchSegment..::..CvsPatternMatchSegment Members
Cognex.InSight.Graphic Namespace


CvsPatternMatchSegment.EndLocation Property

[image]

In-Sight SDK
CvsPatternMatchSegment..::..EndLocation Property
CvsPatternMatchSegment Class See Also Send Feedback
Gets the location of the second point of the line segment.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation EndLocation { get; }
Visual Basic
Public ReadOnly Property EndLocation As CvsImageLocation
    Get

Property Value

Type: CvsImageLocation

See Also

CvsPatternMatchSegment Class
CvsPatternMatchSegment..::..CvsPatternMatchSegment Members
Cognex.InSight.Graphic Namespace


CvsPatternMatchSegment.HighlightColor Property

[image]

In-Sight SDK
CvsPatternMatchSegment..::..HighlightColor Property
CvsPatternMatchSegment Class See Also Send Feedback
Gets the highlighted color of the line segment.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Color HighlightColor { get; }
Visual Basic
Public ReadOnly Property HighlightColor As Color
    Get

Property Value

Type: Color

Remarks

This property is only available in .NET applications.

See Also

CvsPatternMatchSegment Class
CvsPatternMatchSegment..::..CvsPatternMatchSegment Members
Cognex.InSight.Graphic Namespace


CvsPatternMatchSegment.HighlightColorAsRgb Property

[image]

In-Sight SDK
CvsPatternMatchSegment..::..HighlightColorAsRgb Property
CvsPatternMatchSegment Class See Also Send Feedback
Gets the HighlightColor as an RGB value.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int HighlightColorAsRgb { get; }
Visual Basic
Public ReadOnly Property HighlightColorAsRgb As Integer
    Get

Property Value

Type: Int32

Remarks

The color value is formatted with the red component in bits 0-7, green in bits 8-15, and blue in bits 16-23.

See Also

CvsPatternMatchSegment Class
CvsPatternMatchSegment..::..CvsPatternMatchSegment Members
Cognex.InSight.Graphic Namespace


CvsPatternMatchSegment.StartLocation Property

[image]

In-Sight SDK
CvsPatternMatchSegment..::..StartLocation Property
CvsPatternMatchSegment Class See Also Send Feedback
Gets the location of the first point of the line segment.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageLocation StartLocation { get; }
Visual Basic
Public ReadOnly Property StartLocation As CvsImageLocation
    Get

Property Value

Type: CvsImageLocation

See Also

CvsPatternMatchSegment Class
CvsPatternMatchSegment..::..CvsPatternMatchSegment Members
Cognex.InSight.Graphic Namespace


ICvsEditableGraphic Interface

[image]

In-Sight SDK
ICvsEditableGraphic Interface
Members See Also Send Feedback
CvsGraphic classes that implement the ICvsEditableGraphic interface may be edited by the In-Sight display control.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public interface ICvsEditableGraphic
Visual Basic
Public Interface ICvsEditableGraphic

See Also

ICvsEditableGraphic..::..ICvsEditableGraphic Members
Cognex.InSight.Graphic Namespace


ICvsEditableGraphic Members

[image] [image]

In-Sight SDK
ICvsEditableGraphic Members
ICvsEditableGraphic Interface Methods Properties See Also Send Feedback

The ICvsEditableGraphic type exposes the following members.

Methods

 | Name | Description
Public method | CopyFrom | Copies the source graphic to this graphic.

Properties

 | Name | Description
Public property | EditBounds | Gets and sets the maximum edit boundary for this graphic.
Public property | EditFlags | Gets the degrees of freedom that are allowed for this graphic.

See Also

ICvsEditableGraphic Interface
Cognex.InSight.Graphic Namespace


ICvsEditableGraphic Methods

[image] [image]

In-Sight SDK
ICvsEditableGraphic Methods
ICvsEditableGraphic Interface See Also Send Feedback

The ICvsEditableGraphic type exposes the following members.

Methods

 | Name | Description
Public method | CopyFrom | Copies the source graphic to this graphic.

See Also

ICvsEditableGraphic Interface
Cognex.InSight.Graphic Namespace


ICvsEditableGraphic.CopyFrom Method

[image]

In-Sight SDK
ICvsEditableGraphic..::..CopyFrom Method
ICvsEditableGraphic Interface See Also Send Feedback
Copies the source graphic to this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
void CopyFrom(
    ICvsEditableGraphic source
)
Visual Basic
Sub CopyFrom (
    source As ICvsEditableGraphic
)

Parameters

source
Type: Cognex.InSight.Graphic..::..ICvsEditableGraphic

[Missing <param name="source"/> documentation for "M:Cognex.InSight.Graphic.ICvsEditableGraphic.CopyFrom(Cognex.InSight.Graphic.ICvsEditableGraphic)"]

Exceptions

Exception | Condition
System..::..InvalidOperationException | The source graphic is not of the same type as this graphic.
System..::..InvalidOperationException | If the IsLocked property is true for this graphic.

See Also

ICvsEditableGraphic Interface
ICvsEditableGraphic..::..ICvsEditableGraphic Members
Cognex.InSight.Graphic Namespace


ICvsEditableGraphic Properties

[image] [image]

In-Sight SDK
ICvsEditableGraphic Properties
ICvsEditableGraphic Interface See Also Send Feedback

The ICvsEditableGraphic type exposes the following members.

Properties

 | Name | Description
Public property | EditBounds | Gets and sets the maximum edit boundary for this graphic.
Public property | EditFlags | Gets the degrees of freedom that are allowed for this graphic.

See Also

ICvsEditableGraphic Interface
Cognex.InSight.Graphic Namespace


ICvsEditableGraphic.EditBounds Property

[image]

In-Sight SDK
ICvsEditableGraphic..::..EditBounds Property
ICvsEditableGraphic Interface See Also Send Feedback
Gets and sets the maximum edit boundary for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
Rectangle EditBounds { get; }
Visual Basic
ReadOnly Property EditBounds As Rectangle
    Get

Property Value

Type: Rectangle

See Also

ICvsEditableGraphic Interface
ICvsEditableGraphic..::..ICvsEditableGraphic Members
Cognex.InSight.Graphic Namespace


ICvsEditableGraphic.EditFlags Property

[image]

In-Sight SDK
ICvsEditableGraphic..::..EditFlags Property
ICvsEditableGraphic Interface See Also Send Feedback
Gets the degrees of freedom that are allowed for this graphic.

Namespace: Cognex.InSight.Graphic
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
CvsEditFlags EditFlags { get; }
Visual Basic
ReadOnly Property EditFlags As CvsEditFlags
    Get

Property Value

Type: CvsEditFlags

See Also

ICvsEditableGraphic Interface
ICvsEditableGraphic..::..ICvsEditableGraphic Members
Cognex.InSight.Graphic Namespace


Cognex.InSight.NativeMode Namespace

[image]

In-Sight SDK
Cognex.InSight.NativeMode Namespace
Send Feedback
The Cognex.InSight.NativeMode namespace provides classes for accessing an In-Sight sensor via Native Mode.

Classes

 | Class | Description
Public class | CvsNativeModeClient | Provides a direct connection to an In-Sight using the Native Mode Command Protocol. Use of this class while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed, the constructor will throw a CvsNotLicensedException.
Public class | CvsNativeModeResponseException | The exception that is thrown when a Native Mode status is received that indicates the command returned an error response.
Public class | CvsNativeModeTimeoutException | The exception that is thrown when a Native Mode timeout occurs.


CvsNativeModeClient Class

[image]

In-Sight SDK
CvsNativeModeClient Class
Members See Also Send Feedback
Provides a direct connection to an In-Sight using the Native Mode Command Protocol. Use of this class while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed, the constructor will throw a CvsNotLicensedException.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public sealed class CvsNativeModeClient : IDisposable
Visual Basic
Public NotInheritable Class CvsNativeModeClient
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.NativeMode..::..CvsNativeModeClient

See Also

CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient Members

[image] [image]

In-Sight SDK
CvsNativeModeClient Members
CvsNativeModeClient Class Constructors Methods Properties Events See Also Send Feedback

The CvsNativeModeClient type exposes the following members.

Constructors

 | Name | Description
Public method | CvsNativeModeClient()()()() | Initializes a new instance for connecting to an In-Sight sensor using Native Mode communications.
Public method | CvsNativeModeClient(Encoding) | Initializes a new instance for connecting to an In-Sight sensor using Native Mode communications.

Methods

 | Name | Description
Public method | Connect(IPAddress, String, String) | Opens a Native Mode connection on the In-Sight sensor at the specified IP address.
Public method | Connect(String, String, String) | Opens a Native Mode connection on the specified In-Sight sensor.
Public method | ConnectAsynchronous | Opens a Native Mode connection on the specified In-Sight sensor, but returns before the connection is complete.
Public method | Disconnect | Disconnects from the In-Sight sensor.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadStatusValue | Interprets an XML response, returning the embedded Status Value.
Public method | ResetSystem | Resets the In-Sight system. This command is similar to physically cycling power on the system.
Public method | SendCommand | Send the specified string to the In-Sight sensor as a native mode command and waits for a response.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | GetResource<(Of <<'(T>)>>) | Sends a GET request to the client and deserializes result. (Defined by CvsNativeModeClientExtensions.)

Properties

 | Name | Description
Public property | Connected | Gets a value that determines if there is a connection established with an In-Sight sensor.
Public property | LastResponseReader | Gets the last message response received on the In-Sight Native Mode Channel as a XmlNodeReader.
Public property | LastResponseString | Gets the last message response received on the In-Sight Native Mode Channel as a string.
Public property | NativeOnline | Gets or sets the native mode online.
Public property | Password | Gets the password used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | RemoteIPAddress | Gets the IP address used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | RemoteIPAddressString | Gets the IP address used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | Timeout | Gets or sets the time (in milliseconds) to wait for a response when calling SendCommand(String).
Public property | UsePasswordEncryption | Gets or sets the value indicating whether to use advanced encryption when sending the password to the host.
Public property | Username | Gets the user name used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | WelcomeBanner | Gets the Welcome message returned from the sensor after connecting. It will be null prior to connecting.

Events

 | Name | Description
Public event | ConnectCompleted | The ConnectCompleted event is raised when an ConnectAsynchronous(String, String, String) call has completed. The event arguments indicate whether an exception was generated while attempting the connection.

See Also

CvsNativeModeClient Class
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient Constructor

[image] [image]

In-Sight SDK
CvsNativeModeClient Constructor
CvsNativeModeClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsNativeModeClient()()()() | Initializes a new instance for connecting to an In-Sight sensor using Native Mode communications.
Public method | CvsNativeModeClient(Encoding) | Initializes a new instance for connecting to an In-Sight sensor using Native Mode communications.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient Constructor

[image]

In-Sight SDK
CvsNativeModeClient Constructor
CvsNativeModeClient Class See Also Send Feedback
Initializes a new instance for connecting to an In-Sight sensor using Native Mode communications.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsNativeModeClient()
Visual Basic
Public Sub New

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotLicensedException | The CvsNativeModeClient class may not be constructed in a debug environment without an In-Sight SDK license.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
CvsNativeModeClient Overload
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient Constructor (Encoding)

[image]

In-Sight SDK
CvsNativeModeClient Constructor (Encoding)
CvsNativeModeClient Class See Also Send Feedback
Initializes a new instance for connecting to an In-Sight sensor using Native Mode communications.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsNativeModeClient(
    Encoding encoding
)
Visual Basic
Public Sub New (
    encoding As Encoding
)

Parameters

encoding
Type: System.Text..::..Encoding
The text encoding used to send localized data over the native mode connection.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotLicensedException | The CvsNativeModeClient class may not be constructed in a debug environment without an In-Sight SDK license.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
CvsNativeModeClient Overload
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient Methods

[image] [image]

In-Sight SDK
CvsNativeModeClient Methods
CvsNativeModeClient Class See Also Send Feedback

The CvsNativeModeClient type exposes the following members.

Methods

 | Name | Description
Public method | Connect(IPAddress, String, String) | Opens a Native Mode connection on the In-Sight sensor at the specified IP address.
Public method | Connect(String, String, String) | Opens a Native Mode connection on the specified In-Sight sensor.
Public method | ConnectAsynchronous | Opens a Native Mode connection on the specified In-Sight sensor, but returns before the connection is complete.
Public method | Disconnect | Disconnects from the In-Sight sensor.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadStatusValue | Interprets an XML response, returning the embedded Status Value.
Public method | ResetSystem | Resets the In-Sight system. This command is similar to physically cycling power on the system.
Public method | SendCommand | Send the specified string to the In-Sight sensor as a native mode command and waits for a response.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | GetResource<(Of <<'(T>)>>) | Sends a GET request to the client and deserializes result. (Defined by CvsNativeModeClientExtensions.)

See Also

CvsNativeModeClient Class
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.Connect Method

[image] [image]

In-Sight SDK
CvsNativeModeClient..::..Connect Method
CvsNativeModeClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Connect(IPAddress, String, String) | Opens a Native Mode connection on the In-Sight sensor at the specified IP address.
Public method | Connect(String, String, String) | Opens a Native Mode connection on the specified In-Sight sensor.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.Connect Method (IPAddress, String, String)

[image]

In-Sight SDK
CvsNativeModeClient..::..Connect Method (IPAddress, String, String)
CvsNativeModeClient Class See Also Send Feedback
Opens a Native Mode connection on the In-Sight sensor at the specified IP address.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Connect(
    IPAddress address,
    string username,
    string password
)
Visual Basic
Public Sub Connect (
    address As IPAddress,
    username As String,
    password As String
)

Parameters

address
Type: System.Net..::..IPAddress
The IP address of the In-Sight sensor to connect to.
username
Type: System..::..String
The user name to connect with.
password
Type: System..::..String
The password associated with the user name to connect with.

Remarks

This method disconnects before establishing a new connection.

This overload is only available in .NET applications.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | A connection cannot be established because the Native Mode Channel is not accessible, or a connection could not be established to the address specified.
Cognex.InSight..::..CvsInvalidLogonException | An invalid username/password combination is used, or there is no response to a username or password entry.
Cognex.InSight.NativeMode..::..CvsNativeModeResponseException | The sensor failed to return an XML response. There may be insufficient permissions to allow the connection.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Connect Overload
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.Connect Method (String, String, String)

[image]

In-Sight SDK
CvsNativeModeClient..::..Connect Method (String, String, String)
CvsNativeModeClient Class See Also Send Feedback
Opens a Native Mode connection on the specified In-Sight sensor.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Connect(
    string hostname,
    string username,
    string password
)
Visual Basic
Public Sub Connect (
    hostname As String,
    username As String,
    password As String
)

Parameters

hostname
Type: System..::..String
The DNS name or address of the In-Sight sensor to which you intend to connect.
username
Type: System..::..String
The user name to connect with.
password
Type: System..::..String
The password associated with the user name to connect with.

Remarks

This method disconnects before establishing a new connection.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | A connection cannot be established because the Native Mode Channel is not accessible, a connection could not be established to the address specified, or the hostname could not be resolved.
Cognex.InSight..::..CvsInvalidLogonException | An invalid username/password combination is used, or there is no response to a username or password entry.
Cognex.InSight.NativeMode..::..CvsNativeModeResponseException | The sensor failed to return an XML response. There may be insufficient permissions to allow the connection.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Connect Overload
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.ConnectAsynchronous Method

[image]

In-Sight SDK
CvsNativeModeClient..::..ConnectAsynchronous Method
CvsNativeModeClient Class See Also Send Feedback
Opens a Native Mode connection on the specified In-Sight sensor, but returns before the connection is complete.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ConnectAsynchronous(
    string hostname,
    string username,
    string password
)
Visual Basic
Public Sub ConnectAsynchronous (
    hostname As String,
    username As String,
    password As String
)

Parameters

hostname
Type: System..::..String
The DNS name or address of the In-Sight sensor to which you intend to connect.
username
Type: System..::..String
The user name to connect with.
password
Type: System..::..String
The password associated with the user name to connect with.

Remarks

This method waits for the connection to complete.

NOTE: No properties or methods on the CvsNativeModeClient instance should be called until the ConnectCompleted event is raised.

This method disconnects before establishing a new connection.

Events

Event Type | Reason
CvsNativeModeClient..::..ConnectCompleted | Raised when the asynchronous connection is complete. NOTE: This event must be handled for this method, and it is raised on the same thread that called ConnectAsynchronous(String, String, String).

Exceptions

Exception | Condition
System..::..InvalidOperationException | The ConnectCompleted event must be subscribed to in order to connect asynchronously.
Cognex.InSight..::..CvsNetworkException | A connection cannot be established because the Native Mode Channel is not accessible, a connection could not be established to the address specified, or the hostname could not be resolved.
Cognex.InSight..::..CvsInvalidLogonException | An invalid username/password combination is used, or there is no response to a username or password entry.
Cognex.InSight.NativeMode..::..CvsNativeModeResponseException | The sensor failed to return an XML response. There may be insufficient permissions to allow the connection.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.Disconnect Method

[image]

In-Sight SDK
CvsNativeModeClient..::..Disconnect Method
CvsNativeModeClient Class See Also Send Feedback
Disconnects from the In-Sight sensor.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Disconnect()
Visual Basic
Public Sub Disconnect

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace
CvsNativeModeClient..::..Connect(IPAddress, String, String)


CvsNativeModeClient.ReadStatusValue Method

[image]

In-Sight SDK
CvsNativeModeClient..::..ReadStatusValue Method
CvsNativeModeClient Class See Also Send Feedback
Interprets an XML response, returning the embedded Status Value.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public short ReadStatusValue()
Visual Basic
Public Function ReadStatusValue As Short

Return Value

Type: Int16
The status value in the XML response from the last native mode command sent, or -255 if LastResponseReader is null.

Remarks

The LastResponseReader must be positioned at the start of the response. It reads up to and including the Status Value, but not the Status close tag.

Exceptions

Exception | Condition
Cognex.InSight.NativeMode..::..CvsNativeModeResponseException | LastResponseReader contains unexpected response XML.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.ResetSystem Method

[image]

In-Sight SDK
CvsNativeModeClient..::..ResetSystem Method
CvsNativeModeClient Class See Also Send Feedback
Resets the In-Sight system. This command is similar to physically cycling power on the system.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ResetSystem()
Visual Basic
Public Sub ResetSystem

Remarks

This method is equivalent to sending the "RT" command and waiting for 15 seconds for the In-Sight sensor to reboot.

Exceptions

Exception | Condition
Cognex.InSight.NativeMode..::..CvsNativeModeResponseException | User did not have full access or there was an error reading the response.
Cognex.InSight..::..CvsNotConnectedException | Connected is false.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.SendCommand Method

[image]

In-Sight SDK
CvsNativeModeClient..::..SendCommand Method
CvsNativeModeClient Class See Also Send Feedback
Send the specified string to the In-Sight sensor as a native mode command and waits for a response.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string SendCommand(
    string command
)
Visual Basic
Public Function SendCommand (
    command As String
) As String

Parameters

command
Type: System..::..String
The Native Mode Command to send to the In-Sight sensor.

Return Value

Type: String
The string that holds the response. This is the same as the LastResponseString.

Remarks

The command will wait up to the Timeout time to receive a response. If a response is not received, CvsNativeModeTimeoutException is thrown.

If a response is successfully received, the LastResponseString may be used to examine the response. Typically, the LastResponseReader will also be populated to facilitate easy reading of the response. However, if the XML was not parsable, LastResponseReader will be null.

The Native Mode Command "RT" that resets the system, does not produce a response, so null is returned.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | Connected is false.
Cognex.InSight.NativeMode..::..CvsNativeModeResponseException | The sensor failed to return an XML response.
Cognex.InSight.NativeMode..::..CvsNativeModeTimeoutException | A response is not received on the Native Mode Channel within the Timeout time.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient Properties

[image] [image]

In-Sight SDK
CvsNativeModeClient Properties
CvsNativeModeClient Class See Also Send Feedback

The CvsNativeModeClient type exposes the following members.

Properties

 | Name | Description
Public property | Connected | Gets a value that determines if there is a connection established with an In-Sight sensor.
Public property | LastResponseReader | Gets the last message response received on the In-Sight Native Mode Channel as a XmlNodeReader.
Public property | LastResponseString | Gets the last message response received on the In-Sight Native Mode Channel as a string.
Public property | NativeOnline | Gets or sets the native mode online.
Public property | Password | Gets the password used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | RemoteIPAddress | Gets the IP address used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | RemoteIPAddressString | Gets the IP address used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | Timeout | Gets or sets the time (in milliseconds) to wait for a response when calling SendCommand(String).
Public property | UsePasswordEncryption | Gets or sets the value indicating whether to use advanced encryption when sending the password to the host.
Public property | Username | Gets the user name used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.
Public property | WelcomeBanner | Gets the Welcome message returned from the sensor after connecting. It will be null prior to connecting.

See Also

CvsNativeModeClient Class
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.Connected Property

[image]

In-Sight SDK
CvsNativeModeClient..::..Connected Property
CvsNativeModeClient Class See Also Send Feedback
Gets a value that determines if there is a connection established with an In-Sight sensor.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Connected { get; }
Visual Basic
Public ReadOnly Property Connected As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace
CvsNativeModeClient.Connect


CvsNativeModeClient.LastResponseReader Property

[image]

In-Sight SDK
CvsNativeModeClient..::..LastResponseReader Property
CvsNativeModeClient Class See Also Send Feedback
Gets the last message response received on the In-Sight Native Mode Channel as a XmlNodeReader.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public XmlNodeReader LastResponseReader { get; }
Visual Basic
Public ReadOnly Property LastResponseReader As XmlNodeReader
    Get

Property Value

Type: XmlNodeReader
A XmlNodeReader object, or a null reference (Nothing in Visual Basic) if the Connected is false.

Remarks

The message response is used to populate an XmlNodeReader that can be used to easily parse the XML.

This property is only available in .NET applications. COM/ActiveX applications should use the LastResponseString property instead.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.LastResponseString Property

[image]

In-Sight SDK
CvsNativeModeClient..::..LastResponseString Property
CvsNativeModeClient Class See Also Send Feedback
Gets the last message response received on the In-Sight Native Mode Channel as a string.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string LastResponseString { get; }
Visual Basic
Public ReadOnly Property LastResponseString As String
    Get

Property Value

Type: String

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.NativeOnline Property

[image]

In-Sight SDK
CvsNativeModeClient..::..NativeOnline Property
CvsNativeModeClient Class See Also Send Feedback
Gets or sets the native mode online.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool NativeOnline { get; set; }
Visual Basic
Public Property NativeOnline As Boolean
    Get
    Set

Return Value

Type: Boolean
The native mode online status.

Remarks

Getting is equivalent to sending the "GO" command. Setting is equivalent to sending the "SO" command.

The LastResponseReader is null after getting or setting.

Exceptions

Exception | Condition
Cognex.InSight.NativeMode..::..CvsNativeModeResponseException | User did not have full access or there was an error reading the response.
Cognex.InSight..::..CvsNotConnectedException | Connected is false.
Cognex.InSight.NativeMode..::..CvsNativeModeTimeoutException | A response is not received on the Native Mode Channel within the Timeout time.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.Password Property

[image]

In-Sight SDK
CvsNativeModeClient..::..Password Property
CvsNativeModeClient Class See Also Send Feedback
Gets the password used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Password { get; }
Visual Basic
Public ReadOnly Property Password As String
    Get

Property Value

Type: String

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace
CvsNativeModeClient.Connect


CvsNativeModeClient.RemoteIPAddress Property

[image]

In-Sight SDK
CvsNativeModeClient..::..RemoteIPAddress Property
CvsNativeModeClient Class See Also Send Feedback
Gets the IP address used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress RemoteIPAddress { get; }
Visual Basic
Public ReadOnly Property RemoteIPAddress As IPAddress
    Get

Property Value

Type: IPAddress

Remarks

This property is only available in .NET applications. To obtain an an IP address for use in COM/ActiveX applications, use the RemoteIPAddressString property instead.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace
CvsNativeModeClient.Connect


CvsNativeModeClient.RemoteIPAddressString Property

[image]

In-Sight SDK
CvsNativeModeClient..::..RemoteIPAddressString Property
CvsNativeModeClient Class See Also Send Feedback
Gets the IP address used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string RemoteIPAddressString { get; }
Visual Basic
Public ReadOnly Property RemoteIPAddressString As String
    Get

Property Value

Type: String

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace
CvsNativeModeClient.Connect


CvsNativeModeClient.Timeout Property

[image]

In-Sight SDK
CvsNativeModeClient..::..Timeout Property
CvsNativeModeClient Class See Also Send Feedback
Gets or sets the time (in milliseconds) to wait for a response when calling SendCommand(String).

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Timeout { get; set; }
Visual Basic
Public Property Timeout As Integer
    Get
    Set

Property Value

Type: Int32
The default value is 30000.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The value is less than or equal to zero.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.UsePasswordEncryption Property

[image]

In-Sight SDK
CvsNativeModeClient..::..UsePasswordEncryption Property
CvsNativeModeClient Class See Also Send Feedback
Gets or sets the value indicating whether to use advanced encryption when sending the password to the host.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool UsePasswordEncryption { get; set; }
Visual Basic
Public Property UsePasswordEncryption As Boolean
    Get
    Set

Property Value

Type: Boolean
The default value is false.

Remarks

To use this feature, advanced password encryption must be supported on the host. Attempting to use advanced encryption with a host that does not support advanced password encryption will result in a bad password notification. In-Sight firmware versions 4.8.0 and above support advanced password encryption.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.Username Property

[image]

In-Sight SDK
CvsNativeModeClient..::..Username Property
CvsNativeModeClient Class See Also Send Feedback
Gets the user name used for the most recent connection to an In-Sight sensor, even if the sensor has been disconnected.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Username { get; }
Visual Basic
Public ReadOnly Property Username As String
    Get

Property Value

Type: String

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace
CvsNativeModeClient.Connect


CvsNativeModeClient.WelcomeBanner Property

[image]

In-Sight SDK
CvsNativeModeClient..::..WelcomeBanner Property
CvsNativeModeClient Class See Also Send Feedback
Gets the Welcome message returned from the sensor after connecting. It will be null prior to connecting.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string WelcomeBanner { get; }
Visual Basic
Public ReadOnly Property WelcomeBanner As String
    Get

Property Value

Type: String

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient Events

[image] [image]

In-Sight SDK
CvsNativeModeClient Events
CvsNativeModeClient Class See Also Send Feedback

The CvsNativeModeClient type exposes the following members.

Events

 | Name | Description
Public event | ConnectCompleted | The ConnectCompleted event is raised when an ConnectAsynchronous(String, String, String) call has completed. The event arguments indicate whether an exception was generated while attempting the connection.

See Also

CvsNativeModeClient Class
Cognex.InSight.NativeMode Namespace


CvsNativeModeClient.ConnectCompleted Event

[image]

In-Sight SDK
CvsNativeModeClient..::..ConnectCompleted Event
CvsNativeModeClient Class See Also Send Feedback
The ConnectCompleted event is raised when an ConnectAsynchronous(String, String, String) call has completed. The event arguments indicate whether an exception was generated while attempting the connection.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public event CvsConnectCompletedEventHandler ConnectCompleted
Visual Basic
Public Event ConnectCompleted As CvsConnectCompletedEventHandler

Value

Type: Cognex.InSight..::..CvsConnectCompletedEventHandler

Remarks

This event is raised on the same thread that called the ConnectAsynchronous(String, String, String) method.

See Also

CvsNativeModeClient Class
CvsNativeModeClient..::..CvsNativeModeClient Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeResponseException Class

[image]

In-Sight SDK
CvsNativeModeResponseException Class
Members See Also Send Feedback
The exception that is thrown when a Native Mode status is received that indicates the command returned an error response.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsNativeModeResponseException : CvsCommunicationException,
    ISerializable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsNativeModeResponseException
    Inherits CvsCommunicationException
    Implements ISerializable

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsCommunicationException
Cognex.InSight.NativeMode..::..CvsNativeModeResponseException

See Also

CvsNativeModeResponseException..::..CvsNativeModeResponseException Members
Cognex.InSight.NativeMode Namespace
CvsInSightErrorNativeModeResponseException


CvsNativeModeResponseException Members

[image] [image]

In-Sight SDK
CvsNativeModeResponseException Members
CvsNativeModeResponseException Class Methods Properties See Also Send Feedback

The CvsNativeModeResponseException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | Status | Gets the status value associated with the exception.
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsNativeModeResponseException Class
Cognex.InSight.NativeMode Namespace


CvsNativeModeResponseException Methods

[image] [image]

In-Sight SDK
CvsNativeModeResponseException Methods
CvsNativeModeResponseException Class See Also Send Feedback

The CvsNativeModeResponseException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsNativeModeResponseException Class
Cognex.InSight.NativeMode Namespace


CvsNativeModeResponseException Properties

[image] [image]

In-Sight SDK
CvsNativeModeResponseException Properties
CvsNativeModeResponseException Class See Also Send Feedback

The CvsNativeModeResponseException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | Status | Gets the status value associated with the exception.
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsNativeModeResponseException Class
Cognex.InSight.NativeMode Namespace


CvsNativeModeResponseException.Status Property

[image]

In-Sight SDK
CvsNativeModeResponseException..::..Status Property
CvsNativeModeResponseException Class See Also Send Feedback
Gets the status value associated with the exception.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Status { get; }
Visual Basic
Public ReadOnly Property Status As Integer
    Get

Property Value

Type: Int32

Remarks

The possible values are documented for each command. The value -255 is returned when an unexpected response is received.

See Also

CvsNativeModeResponseException Class
CvsNativeModeResponseException..::..CvsNativeModeResponseException Members
Cognex.InSight.NativeMode Namespace


CvsNativeModeTimeoutException Class

[image]

In-Sight SDK
CvsNativeModeTimeoutException Class
Members See Also Send Feedback
The exception that is thrown when a Native Mode timeout occurs.

Namespace: Cognex.InSight.NativeMode
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsNativeModeTimeoutException : CvsCommunicationException,
    ISerializable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsNativeModeTimeoutException
    Inherits CvsCommunicationException
    Implements ISerializable

Inheritance Hierarchy

System..::..Object
System..::..Exception
Cognex.InSight..::..CvsException
Cognex.InSight..::..CvsCommunicationException
Cognex.InSight.NativeMode..::..CvsNativeModeTimeoutException

See Also

CvsNativeModeTimeoutException..::..CvsNativeModeTimeoutException Members
Cognex.InSight.NativeMode Namespace
CvsInSightErrorNativeModeTimeoutException


CvsNativeModeTimeoutException Members

[image] [image]

In-Sight SDK
CvsNativeModeTimeoutException Members
CvsNativeModeTimeoutException Class Methods Properties See Also Send Feedback

The CvsNativeModeTimeoutException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsNativeModeTimeoutException Class
Cognex.InSight.NativeMode Namespace


CvsNativeModeTimeoutException Methods

[image] [image]

In-Sight SDK
CvsNativeModeTimeoutException Methods
CvsNativeModeTimeoutException Class See Also Send Feedback

The CvsNativeModeTimeoutException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Extension Methods

 | Name | Description
Public Extension Method | FindInnerException<(Of <<'(TInnerException>)>>) | Recursively searches for an inner exception of type TInnerException. (Defined by ExceptionExtensions.)

See Also

CvsNativeModeTimeoutException Class
Cognex.InSight.NativeMode Namespace


CvsNativeModeTimeoutException Properties

[image] [image]

In-Sight SDK
CvsNativeModeTimeoutException Properties
CvsNativeModeTimeoutException Class See Also Send Feedback

The CvsNativeModeTimeoutException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorNumber | Gets the error number (HResult) associated with the exception. (Inherited from CvsException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CvsNativeModeTimeoutException Class
Cognex.InSight.NativeMode Namespace


Cognex.InSight.Net Namespace

[image]

In-Sight SDK
Cognex.InSight.Net Namespace
Send Feedback
The Cognex.InSight.Net namespace provides the CvsNetworkMonitor class for detecting In-Sight sensors on a network.

Classes

 | Class | Description
Public class | CvsHostCollection | Holds the collection of In-Sight sensors detected on the network.
Public class | CvsHostSensor | Holds the information about a device detected on the network.
Public class | CvsNetworkListener | Listens for In-Sight sensors on the network. Use of this class while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed, the constructor will throw a CvsNotLicensedException.
Public class | CvsNetworkMonitor | Monitors In-Sight sensors on the network. Use of this class while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed, the constructor will throw a CvsNotLicensedException.
Public class | CvsNetworkMonitorSubnet | Represents a subnet on the network.

Enumerations

 | Enumeration | Description
Public enumeration | CvsLightControlType | Enumeration used to determine the light currently attached to the sensor.
Public enumeration | CvsNetworkMonitorCommand | Commands that can be checked for support using the
Public enumeration | CvsNetworkMonitorScope | Enumeration used to specify the search domain for the network monitor
Public enumeration | CvsSupportedFeatures | Enumeration used to determine what features an In-Sight sensor supports.


CvsHostCollection Class

[image]

In-Sight SDK
CvsHostCollection Class
Members See Also Send Feedback
Holds the collection of In-Sight sensors detected on the network.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsHostCollection : IEnumerable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsHostCollection
    Implements IEnumerable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Net..::..CvsHostCollection

See Also

CvsHostCollection..::..CvsHostCollection Members
Cognex.InSight.Net Namespace
Cognex.InSight.Sensor..::..CvsHost
Cognex.InSight.Net..::..CvsHostSensor
Cognex.InSight.Net..::..CvsNetworkMonitor


CvsHostCollection Members

[image] [image]

In-Sight SDK
CvsHostCollection Members
CvsHostCollection Class Methods Properties See Also Send Feedback

The CvsHostCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of host items in the collection.
Public property | Item[([( Int32])]) | Gets the CvsHostSensor object at the specified zero-based index.
Public property | Item[([( String])]) | Gets the CvsHostSensor object for the specified name.

See Also

CvsHostCollection Class
Cognex.InSight.Net Namespace


CvsHostCollection Methods

[image] [image]

In-Sight SDK
CvsHostCollection Methods
CvsHostCollection Class See Also Send Feedback

The CvsHostCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsHostCollection Class
Cognex.InSight.Net Namespace


CvsHostCollection Properties

[image] [image]

In-Sight SDK
CvsHostCollection Properties
CvsHostCollection Class See Also Send Feedback

The CvsHostCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of host items in the collection.
Public property | Item[([( Int32])]) | Gets the CvsHostSensor object at the specified zero-based index.
Public property | Item[([( String])]) | Gets the CvsHostSensor object for the specified name.

See Also

CvsHostCollection Class
Cognex.InSight.Net Namespace


CvsHostCollection.Count Property

[image]

In-Sight SDK
CvsHostCollection..::..Count Property
CvsHostCollection Class See Also Send Feedback
Gets the number of host items in the collection.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

CvsHostCollection Class
CvsHostCollection..::..CvsHostCollection Members
Cognex.InSight.Net Namespace


CvsHostCollection.Item Property

[image] [image]

In-Sight SDK
CvsHostCollection..::..Item Property
CvsHostCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets the CvsHostSensor object at the specified zero-based index.
Public property | Item[([( String])]) | Gets the CvsHostSensor object for the specified name.

See Also

CvsHostCollection Class
CvsHostCollection..::..CvsHostCollection Members
Cognex.InSight.Net Namespace


CvsHostCollection.Item Property (Int32)

[image]

In-Sight SDK
CvsHostCollection..::..Item Property (Int32)
CvsHostCollection Class See Also Send Feedback
Gets the CvsHostSensor object at the specified zero-based index.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostSensor this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As CvsHostSensor
    Get

Parameters

index
Type: System..::..Int32
The zero-based index into the collection.

Property Value

Type: CvsHostSensor

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsHostCollection Class
CvsHostCollection..::..CvsHostCollection Members
Item Overload
Cognex.InSight.Net Namespace
Cognex.InSight.Sensor..::..CvsHost
Cognex.InSight.Net..::..CvsHostSensor
Cognex.InSight.Net..::..CvsNetworkMonitor


CvsHostCollection.Item Property (String)

[image]

In-Sight SDK
CvsHostCollection..::..Item Property (String)
CvsHostCollection Class See Also Send Feedback
Gets the CvsHostSensor object for the specified name.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostSensor this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    name As String
) As CvsHostSensor
    Get

Parameters

name
Type: System..::..String
The name of the host.

Property Value

Type: CvsHostSensor
Returns a CvsHostSensor if its name is found in the collection, returns null otherwise.

See Also

CvsHostCollection Class
CvsHostCollection..::..CvsHostCollection Members
Item Overload
Cognex.InSight.Net Namespace


CvsHostSensor Class

[image]

In-Sight SDK
CvsHostSensor Class
Members See Also Send Feedback
Holds the information about a device detected on the network.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsHostSensor : CvsHost,
    ICloneable, ICvsHostVersionProvider
Visual Basic
<SerializableAttribute>
Public Class CvsHostSensor
    Inherits CvsHost
    Implements ICloneable, ICvsHostVersionProvider

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsHost
Cognex.InSight.Net..::..CvsHostSensor

See Also

CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor Members

[image] [image]

In-Sight SDK
CvsHostSensor Members
CvsHostSensor Class Methods Properties See Also Send Feedback

The CvsHostSensor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Gets the version of the device or null if the version is not available.
Public method | Matches | Compares the MAC address to the specified host to determine if the host is a match. (Overrides CvsHost..::..Matches(CvsHost).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SupportsFeature | Determines whether this In-Sight sensor supports a particular feature.
Public method | SupportsTool | Determines whether this In-Sight sensor supports a particular tool.
Public method | ToString | Returns the name of the host. (Inherited from CvsHost.)

Properties

 | Name | Description
Public property | DefaultGateway | Gets the default gateway setting on this device
Public property | DnsServer | Gets the dns server setting on this device
Public property | DomainName | Gets the domain name setting on this device
Public property | HardwarePartNumber | The In-Sight hardware part number of the sensor, or an empty string if this is not supported.
Public property | IPAddress | Gets the IP address for the host. (Inherited from CvsHost.)
Public property | IPAddressString | Gets the IP address string for the host. (Inherited from CvsHost.)
Public property | IsDhcpEnabled | Gets the Dhcp setting on this device
Public property | LocalInterface | Gets the IP Address of the local network adapter that this sensor was detected on.
Public property | LocalInterfaceString | Gets the IP Address of the local network adapter that this sensor was detected on.
Public property | MacAddress | Gets the MAC address of the In-Sight sensor.
Public property | MacAddressLong | Gets the Mac address as a long value.
Public property | ModelNumber | The In-Sight model number if the sensor is an In-Sight Sensor, or "PC" if the sensor is an emulator
Public property | Name | Gets the name of the host. (Inherited from CvsHost.)
Public property | ProductPartNumber | The In-Sight part number of the sensor, or an empty string if this is not supported.
Public property | Scope | Gets the domain that this device was detected on.
Public property | SerialNumber | Gets the serial number of the In-Sight sensor
Public property | Services | Get the services of the device.
Public property | SubnetMask | Gets the subnet mask setting on this device
Public property | Subtype | Gets the sensor subtype of the host. (Inherited from CvsHost.)
Public property | Type | Gets the sensor type of the host. (Inherited from CvsHost.)
Public property | Version | Gets the software version running on the device. Returns null if the version is unknown.
Public property | VersionString | Gets the firmware version of the In-Sight sensor.

See Also

CvsHostSensor Class
Cognex.InSight.Net Namespace


CvsHostSensor Methods

[image] [image]

In-Sight SDK
CvsHostSensor Methods
CvsHostSensor Class See Also Send Feedback

The CvsHostSensor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Gets the version of the device or null if the version is not available.
Public method | Matches | Compares the MAC address to the specified host to determine if the host is a match. (Overrides CvsHost..::..Matches(CvsHost).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SupportsFeature | Determines whether this In-Sight sensor supports a particular feature.
Public method | SupportsTool | Determines whether this In-Sight sensor supports a particular tool.
Public method | ToString | Returns the name of the host. (Inherited from CvsHost.)

See Also

CvsHostSensor Class
Cognex.InSight.Net Namespace


CvsHostSensor.GetVersion Method

[image]

In-Sight SDK
CvsHostSensor..::..GetVersion Method
CvsHostSensor Class See Also Send Feedback
Gets the version of the device or null if the version is not available.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostVersion GetVersion()
Visual Basic
Public Function GetVersion As CvsHostVersion

Return Value

Type: CvsHostVersion

[Missing <returns> documentation for "M:Cognex.InSight.Net.CvsHostSensor.GetVersion"]

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.Matches Method

[image]

In-Sight SDK
CvsHostSensor..::..Matches Method
CvsHostSensor Class See Also Send Feedback
Compares the MAC address to the specified host to determine if the host is a match.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool Matches(
    CvsHost hostBase
)
Visual Basic
Public Overrides Function Matches (
    hostBase As CvsHost
) As Boolean

Parameters

hostBase
Type: Cognex.InSight.Sensor..::..CvsHost
The host.

Return Value

Type: Boolean
true if the given host has the same MAC address; otherwise, false.

Remarks

The name and type of sensor must also match.

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.SupportsFeature Method

[image]

In-Sight SDK
CvsHostSensor..::..SupportsFeature Method
CvsHostSensor Class See Also Send Feedback
Determines whether this In-Sight sensor supports a particular feature.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SupportsFeature(
    CvsSupportedFeatures feature
)
Visual Basic
Public Function SupportsFeature (
    feature As CvsSupportedFeatures
) As Boolean

Parameters

feature
Type: Cognex.InSight.Net..::..CvsSupportedFeatures
The feature to check

Return Value

Type: Boolean
True if the sensor supports the feature.

Exceptions

Exception | Condition
System..::..NotSupportedException | The firmware does not support checking this function.

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.SupportsTool Method

[image]

In-Sight SDK
CvsHostSensor..::..SupportsTool Method
CvsHostSensor Class See Also Send Feedback
Determines whether this In-Sight sensor supports a particular tool.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SupportsTool(
    CvsSupportedTools tool
)
Visual Basic
Public Function SupportsTool (
    tool As CvsSupportedTools
) As Boolean

Parameters

tool
Type: Cognex.InSight.Sensor..::..CvsSupportedTools
The tool to check.

Return Value

Type: Boolean
true if the sensor supports the tool, and false otherwise.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | If tool is not a member of the CvsSupportedTools enumeration.

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor Properties

[image] [image]

In-Sight SDK
CvsHostSensor Properties
CvsHostSensor Class See Also Send Feedback

The CvsHostSensor type exposes the following members.

Properties

 | Name | Description
Public property | DefaultGateway | Gets the default gateway setting on this device
Public property | DnsServer | Gets the dns server setting on this device
Public property | DomainName | Gets the domain name setting on this device
Public property | HardwarePartNumber | The In-Sight hardware part number of the sensor, or an empty string if this is not supported.
Public property | IPAddress | Gets the IP address for the host. (Inherited from CvsHost.)
Public property | IPAddressString | Gets the IP address string for the host. (Inherited from CvsHost.)
Public property | IsDhcpEnabled | Gets the Dhcp setting on this device
Public property | LocalInterface | Gets the IP Address of the local network adapter that this sensor was detected on.
Public property | LocalInterfaceString | Gets the IP Address of the local network adapter that this sensor was detected on.
Public property | MacAddress | Gets the MAC address of the In-Sight sensor.
Public property | MacAddressLong | Gets the Mac address as a long value.
Public property | ModelNumber | The In-Sight model number if the sensor is an In-Sight Sensor, or "PC" if the sensor is an emulator
Public property | Name | Gets the name of the host. (Inherited from CvsHost.)
Public property | ProductPartNumber | The In-Sight part number of the sensor, or an empty string if this is not supported.
Public property | Scope | Gets the domain that this device was detected on.
Public property | SerialNumber | Gets the serial number of the In-Sight sensor
Public property | Services | Get the services of the device.
Public property | SubnetMask | Gets the subnet mask setting on this device
Public property | Subtype | Gets the sensor subtype of the host. (Inherited from CvsHost.)
Public property | Type | Gets the sensor type of the host. (Inherited from CvsHost.)
Public property | Version | Gets the software version running on the device. Returns null if the version is unknown.
Public property | VersionString | Gets the firmware version of the In-Sight sensor.

See Also

CvsHostSensor Class
Cognex.InSight.Net Namespace


CvsHostSensor.DefaultGateway Property

[image]

In-Sight SDK
CvsHostSensor..::..DefaultGateway Property
CvsHostSensor Class See Also Send Feedback
Gets the default gateway setting on this device

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress DefaultGateway { get; }
Visual Basic
Public ReadOnly Property DefaultGateway As IPAddress
    Get

Property Value

Type: IPAddress
Null when the default gateway is not available

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.DnsServer Property

[image]

In-Sight SDK
CvsHostSensor..::..DnsServer Property
CvsHostSensor Class See Also Send Feedback
Gets the dns server setting on this device

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress DnsServer { get; }
Visual Basic
Public ReadOnly Property DnsServer As IPAddress
    Get

Property Value

Type: IPAddress
Null when the dns server is not available

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.DomainName Property

[image]

In-Sight SDK
CvsHostSensor..::..DomainName Property
CvsHostSensor Class See Also Send Feedback
Gets the domain name setting on this device

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string DomainName { get; }
Visual Basic
Public ReadOnly Property DomainName As String
    Get

Property Value

Type: String
Null when the domain name is not available

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.HardwarePartNumber Property

[image]

In-Sight SDK
CvsHostSensor..::..HardwarePartNumber Property
CvsHostSensor Class See Also Send Feedback
The In-Sight hardware part number of the sensor, or an empty string if this is not supported.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string HardwarePartNumber { get; }
Visual Basic
Public ReadOnly Property HardwarePartNumber As String
    Get

Property Value

Type: String

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.IsDhcpEnabled Property

[image]

In-Sight SDK
CvsHostSensor..::..IsDhcpEnabled Property
CvsHostSensor Class See Also Send Feedback
Gets the Dhcp setting on this device

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsDhcpEnabled { get; }
Visual Basic
Public ReadOnly Property IsDhcpEnabled As Boolean
    Get

Property Value

Type: Boolean
True if dhcp is enabled, false if not or if the value is unknown.

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.LocalInterface Property

[image]

In-Sight SDK
CvsHostSensor..::..LocalInterface Property
CvsHostSensor Class See Also Send Feedback
Gets the IP Address of the local network adapter that this sensor was detected on.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress LocalInterface { get; }
Visual Basic
Public ReadOnly Property LocalInterface As IPAddress
    Get

Property Value

Type: IPAddress

Remarks

This property is only available in .NET applications. To obtain an an IP address for use in COM/ActiveX applications, use the LocalInterfaceString property instead.

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.LocalInterfaceString Property

[image]

In-Sight SDK
CvsHostSensor..::..LocalInterfaceString Property
CvsHostSensor Class See Also Send Feedback
Gets the IP Address of the local network adapter that this sensor was detected on.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string LocalInterfaceString { get; }
Visual Basic
Public ReadOnly Property LocalInterfaceString As String
    Get

Property Value

Type: String

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.MacAddress Property

[image]

In-Sight SDK
CvsHostSensor..::..MacAddress Property
CvsHostSensor Class See Also Send Feedback
Gets the MAC address of the In-Sight sensor.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string MacAddress { get; }
Visual Basic
Public ReadOnly Property MacAddress As String
    Get

Property Value

Type: String
String.Empty if MAC address is unknown

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.MacAddressLong Property

[image]

In-Sight SDK
CvsHostSensor..::..MacAddressLong Property
CvsHostSensor Class See Also Send Feedback
Gets the Mac address as a long value.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public long MacAddressLong { get; }
Visual Basic
Public ReadOnly Property MacAddressLong As Long
    Get

Property Value

Type: Int64
0 if MAC address is unknown

Remarks

This property is only available in .NET applications.

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.ModelNumber Property

[image]

In-Sight SDK
CvsHostSensor..::..ModelNumber Property
CvsHostSensor Class See Also Send Feedback
The In-Sight model number if the sensor is an In-Sight Sensor, or "PC" if the sensor is an emulator

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string ModelNumber { get; }
Visual Basic
Public ReadOnly Property ModelNumber As String
    Get

Property Value

Type: String

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.ProductPartNumber Property

[image]

In-Sight SDK
CvsHostSensor..::..ProductPartNumber Property
CvsHostSensor Class See Also Send Feedback
The In-Sight part number of the sensor, or an empty string if this is not supported.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string ProductPartNumber { get; }
Visual Basic
Public ReadOnly Property ProductPartNumber As String
    Get

Property Value

Type: String

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.Scope Property

[image]

In-Sight SDK
CvsHostSensor..::..Scope Property
CvsHostSensor Class See Also Send Feedback
Gets the domain that this device was detected on.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsNetworkMonitorScope Scope { get; }
Visual Basic
Public ReadOnly Property Scope As CvsNetworkMonitorScope
    Get

Property Value

Type: CvsNetworkMonitorScope

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.SerialNumber Property

[image]

In-Sight SDK
CvsHostSensor..::..SerialNumber Property
CvsHostSensor Class See Also Send Feedback
Gets the serial number of the In-Sight sensor

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string SerialNumber { get; }
Visual Basic
Public ReadOnly Property SerialNumber As String
    Get

Property Value

Type: String

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.Services Property

[image]

In-Sight SDK
CvsHostSensor..::..Services Property
CvsHostSensor Class See Also Send Feedback
Get the services of the device.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string[] Services { get; }
Visual Basic
Public ReadOnly Property Services As String()
    Get

Property Value

Type: array< String >[]()[][]
Null when there are no services available

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.SubnetMask Property

[image]

In-Sight SDK
CvsHostSensor..::..SubnetMask Property
CvsHostSensor Class See Also Send Feedback
Gets the subnet mask setting on this device

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress SubnetMask { get; }
Visual Basic
Public ReadOnly Property SubnetMask As IPAddress
    Get

Property Value

Type: IPAddress
Null when the subnet mask is not available

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.Version Property

[image]

In-Sight SDK
CvsHostSensor..::..Version Property
CvsHostSensor Class See Also Send Feedback
Gets the software version running on the device. Returns null if the version is unknown.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Version Version { get; }
Visual Basic
Public ReadOnly Property Version As Version
    Get

Property Value

Type: Version

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsHostSensor.VersionString Property

[image]

In-Sight SDK
CvsHostSensor..::..VersionString Property
CvsHostSensor Class See Also Send Feedback
Gets the firmware version of the In-Sight sensor.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string VersionString { get; }
Visual Basic
Public ReadOnly Property VersionString As String
    Get

Property Value

Type: String

Remarks

The ToString()()()() formats the string as: major.minor.revision type (build)

See Also

CvsHostSensor Class
CvsHostSensor..::..CvsHostSensor Members
Cognex.InSight.Net Namespace


CvsLightControlType Enumeration

[image]

In-Sight SDK
CvsLightControlType Enumeration
See Also Send Feedback
Enumeration used to determine the light currently attached to the sensor.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsLightControlType
Visual Basic
Public Enumeration CvsLightControlType

Members

Member name | Value | Description
None | 0 | No light control - must be == 0.
i4CH | 1 | 3000 style, independent 4-ch light control.
Wafer | 2 | 1700 style wafer light control.
Ring | 3 | 1510 style integrated 2-ch ring LED light.
i5000 | 4 | 5400 style integrated 2-ch ring LED light + external strobe support.
IDEngine | 5 | ID Engine illumination - bright field and dark field control with 0-255 brightness.
WaferExt | 6 | 1700 style wafer light control, with external and expansion lights.
HummingBird | 7 | Obsolete. Hummingbird illumination
IS7000 | 8 | Rogue illumination, LED light ring,external
AT70 | 9 | AT70 illumination - Single source with brightness control. Supports external with brightness
ISAE62 | 10 | Gripper illumination
IS2000 | 11 | Merlin illumination - Internal:- Addon:no brigthness control, Premium illumination (Torch) support
IS2000Mini | 12 | Merlin Mini illumination - Internal:- Addon:no brigthness control

Remarks

Copied from sysopt.h in firmware.

See Also

Cognex.InSight.Net Namespace


CvsNetworkListener Class

[image]

In-Sight SDK
CvsNetworkListener Class
Members See Also Send Feedback
Listens for In-Sight sensors on the network. Use of this class while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed, the constructor will throw a CvsNotLicensedException.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public class CvsNetworkListener : IDisposable,
    INetworkMonitor
Visual Basic
Public Class CvsNetworkListener
    Implements IDisposable, INetworkMonitor

Remarks

This class listens for In-Sight sensors on the network and provides the list of detected sensors through its Hosts property. The value of this property will change whenever new sensors are detected on the network, but this class does not raise any event to notify applications when the Hosts property has changed and it does not detect when sensors have been removed from the network. If these additional features are required, use the CvsNetworkMonitor class instead.

Only In-Sight sensors on the local subnet for each network adaptor will be detected.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Net..::..CvsNetworkListener
Cognex.InSight.Net..::..CvsNetworkMonitor

See Also

CvsNetworkListener..::..CvsNetworkListener Members
Cognex.InSight.Net Namespace
Cognex.InSight.Net..::..CvsNetworkMonitor
Cognex.InSight.Net..::..CvsHostSensor
Cognex.InSight.Net..::..CvsHostCollection


CvsNetworkListener Members

[image] [image]

In-Sight SDK
CvsNetworkListener Members
CvsNetworkListener Class Constructors Methods Properties See Also Send Feedback

The CvsNetworkListener type exposes the following members.

Constructors

 | Name | Description
Public method | CvsNetworkListener | Initializes a new instance of the CvsNetworkListener class.

Methods

 | Name | Description
Public method | Dispose | Forces the associated network resources to be freed. This should only be called if the associated object will no longer be used.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PingHost | This method takes the IP Address of the sensor and pings it for a response.
Public method | Refresh | Clears the current Hosts collection and requests identification from all In-Sight sensors on the same subnet.
Public method | Resolve(IPAddress) | Resolves the specified IP address to a CvsHostSensor describing the device at the specified IP address.
Public method | Resolve(String) | Resolves the specified name to a CvsHostSensor describing the device with the specified name.
Public method | SendFlash | Sends a message to the specified sensor which will cause it to flash its display for 3 seconds. This can be used to find the physical device associated with this object.
Public method | SendSetNetwork | Sends a message to the specified sensor to reconfigure its TCP/IP settings to those specified in the parameters.
Public method | SupportsCommand | Determines if the specified device supports sending a particular command without being connected to the device via a TCP channel.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Hosts | Gets the collection that holds the current set of identified In-Sight sensors on the network.
Public property | RemoteSubnets | Gets the list of remote subnets to scan for devices. After this list is changed, Refresh must be called on the CvsNetworkMonitor for the change to take effect.
Public property | Scope | Sets the scope of this network listener. This defines whether it will browse for version 2&3 devices and/or version 4 devices.

See Also

CvsNetworkListener Class
Cognex.InSight.Net Namespace


CvsNetworkListener Constructor

[image]

In-Sight SDK
CvsNetworkListener Constructor
CvsNetworkListener Class See Also Send Feedback
Initializes a new instance of the CvsNetworkListener class.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsNetworkListener()
Visual Basic
Public Sub New

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotLicensedException | The CvsNetworkListener class may not be constructed in a debug environment without an In-Sight SDK license.
Cognex.InSight..::..CvsNetworkException | The CvsNetworkListener class could not bind to the network

See Also

CvsNetworkListener Class
CvsNetworkListener..::..CvsNetworkListener Members
Cognex.InSight.Net Namespace


CvsNetworkListener Methods

[image] [image]

In-Sight SDK
CvsNetworkListener Methods
CvsNetworkListener Class See Also Send Feedback

The CvsNetworkListener type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Forces the associated network resources to be freed. This should only be called if the associated object will no longer be used.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PingHost | This method takes the IP Address of the sensor and pings it for a response.
Public method | Refresh | Clears the current Hosts collection and requests identification from all In-Sight sensors on the same subnet.
Public method | Resolve(IPAddress) | Resolves the specified IP address to a CvsHostSensor describing the device at the specified IP address.
Public method | Resolve(String) | Resolves the specified name to a CvsHostSensor describing the device with the specified name.
Public method | SendFlash | Sends a message to the specified sensor which will cause it to flash its display for 3 seconds. This can be used to find the physical device associated with this object.
Public method | SendSetNetwork | Sends a message to the specified sensor to reconfigure its TCP/IP settings to those specified in the parameters.
Public method | SupportsCommand | Determines if the specified device supports sending a particular command without being connected to the device via a TCP channel.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsNetworkListener Class
Cognex.InSight.Net Namespace


CvsNetworkListener.Dispose Method

[image]

In-Sight SDK
CvsNetworkListener..::..Dispose Method
CvsNetworkListener Class See Also Send Feedback
Forces the associated network resources to be freed. This should only be called if the associated object will no longer be used.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

CvsNetworkListener Class
CvsNetworkListener..::..CvsNetworkListener Members
Cognex.InSight.Net Namespace


CvsNetworkListener.PingHost Method

[image]

In-Sight SDK
CvsNetworkListener..::..PingHost Method
CvsNetworkListener Class See Also Send Feedback
This method takes the IP Address of the sensor and pings it for a response.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool PingHost(
    IPAddress address,
    int timeToWait
)
Visual Basic
Public Shared Function PingHost (
    address As IPAddress,
    timeToWait As Integer
) As Boolean

Parameters

address
Type: System.Net..::..IPAddress
The IP address of the sensor.
timeToWait
Type: System..::..Int32
Amount to time (ms) to wait for a response.

Return Value

Type: Boolean
true if the sensor is available on the network.

Remarks

COM/ActiveX applications should use the helper method PingHost(String, Int32).

See Also

CvsNetworkListener Class
CvsNetworkListener..::..CvsNetworkListener Members
Cognex.InSight.Net Namespace


CvsNetworkListener.Refresh Method

[image]

In-Sight SDK
CvsNetworkListener..::..Refresh Method
CvsNetworkListener Class See Also Send Feedback
Clears the current Hosts collection and requests identification from all In-Sight sensors on the same subnet.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual void Refresh()
Visual Basic
Public Overridable Sub Refresh

Remarks

It may take several seconds, for all sensors to identify themselves. When sensors are identified, the Hosts collection will be updated.

If a new network adaptor is enabled, calling this method will request sensors accessible via this new adaptor to identify themselves.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | The object was disposed.

See Also

CvsNetworkListener Class
CvsNetworkListener..::..CvsNetworkListener Members
Cognex.InSight.Net Namespace


CvsNetworkListener.Resolve Method

[image] [image]

In-Sight SDK
CvsNetworkListener..::..Resolve Method
CvsNetworkListener Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Resolve(IPAddress) | Resolves the specified IP address to a CvsHostSensor describing the device at the specified IP address.
Public method | Resolve(String) | Resolves the specified name to a CvsHostSensor describing the device with the specified name.

See Also

CvsNetworkListener Class
CvsNetworkListener..::..CvsNetworkListener Members
Cognex.InSight.Net Namespace


CvsNetworkListener.Resolve Method (IPAddress)

[image]

In-Sight SDK
CvsNetworkListener..::..Resolve Method (IPAddress)
CvsNetworkListener Class See Also Send Feedback
Resolves the specified IP address to a CvsHostSensor describing the device at the specified IP address.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostSensor Resolve(
    IPAddress ip
)
Visual Basic
Public Function Resolve (
    ip As IPAddress
) As CvsHostSensor

Parameters

ip
Type: System.Net..::..IPAddress
The IP Address to resolve to a CvsHostSensor.

Return Value

Type: CvsHostSensor
The CvsHostSensor with the specified IP address, or null if one could not be found

See Also

CvsNetworkListener Class
CvsNetworkListener..::..CvsNetworkListener Members
Resolve Overload
Cognex.InSight.Net Namespace


CvsNetworkListener.Resolve Method (String)

[image]

In-Sight SDK
CvsNetworkListener..::..Resolve Method (String)
CvsNetworkListener Class See Also Send Feedback
Resolves the specified name to a CvsHostSensor describing the device with the specified name.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostSensor Resolve(
    string name
)
Visual Basic
Public Function Resolve (
    name As String
) As CvsHostSensor

Parameters

name
Type: System..::..String
The name to resolve to a CvsHostSensor.

Return Value

Type: CvsHostSensor
The CvsHostSensor with the specified name, or null if one could not be found

See Also

CvsNetworkListener Class
CvsNetworkListener..::..CvsNetworkListener Members
Resolve Overload
Cognex.InSight.Net Namespace


CvsNetworkListener.SendFlash Method

[image]

In-Sight SDK
CvsNetworkListener..::..SendFlash Method
CvsNetworkListener Class See Also Send Feedback
Sends a message to the specified sensor which will cause it to flash its display for 3 seconds. This can be used to find the physical device associated with this object.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SendFlash(
    CvsHostSensor sensor
)
Visual Basic
Public Function SendFlash (
    sensor As CvsHostSensor
) As Boolean

Parameters

sensor
Type: Cognex.InSight.Net..::..CvsHostSensor
The sensor to display flashing lights

Return Value

Type: Boolean
True if the operation succeeded

See Also

CvsNetworkListener Class
CvsNetworkListener..::..CvsNetworkListener Members
Cognex.InSight.Net Namespace


CvsNetworkListener.SendSetNetwork Method

[image]

In-Sight SDK
CvsNetworkListener..::..SendSetNetwork Method
CvsNetworkListener Class Example See Also Send Feedback
Sends a message to the specified sensor to reconfigure its TCP/IP settings to those specified in the parameters.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SendSetNetwork(
    CvsHostSensor sensor,
    string username,
    string password,
    string hostname,
    bool useDhcp,
    IPAddress ip,
    IPAddress subnet,
    IPAddress gateway,
    IPAddress dns,
    string domainName,
    bool reset
)
Visual Basic
Public Function SendSetNetwork (
    sensor As CvsHostSensor,
    username As String,
    password As String,
    hostname As String,
    useDhcp As Boolean,
    ip As IPAddress,
    subnet As IPAddress,
    gateway As IPAddress,
    dns As IPAddress,
    domainName As String,
    reset As Boolean
) As Boolean

Parameters

sensor
Type: Cognex.InSight.Net..::..CvsHostSensor
The sensor to configure.
username
Type: System..::..String
An admin username.
password
Type: System..::..String
The password for the specified username.
hostname
Type: System..::..String
The new host name for the device.
useDhcp
Type: System..::..Boolean
True to tell the device to use DHCP.
ip
Type: System.Net..::..IPAddress
The new IP address for the device if not using DHCP.
subnet
Type: System.Net..::..IPAddress
The new subnet mask for the device if not using DHCP.
gateway
Type: System.Net..::..IPAddress
The new default gateway to use if not using DHCP.
dns
Type: System.Net..::..IPAddress
The new DNS server to use if not using DHCP.
domainName
Type: System..::..String
The new domain name for the device if not using DHCP.
reset
Type: System..::..Boolean
Unused parameter.

Return Value

Type: Boolean
True if the operation succeeded

Examples

Copy image Copy
// Create In-Sight Network Listener
CvsNetworkListener nl = new CvsNetworkListener();
nl.Scope = CvsNetworkMonitorScope.OutOfSubnet;

// Wait for In-Sight Network Listener to populate
System.Threading.Sleep(3000);

// Choose an In-Sight to reconfigure
CvsHostSensor device = nl.Hosts["MyInSight"];

if (device != null)
{
  // Send new network settings
  bool ret = nl.SendSetNetwork(device, "admin", "", "NewInSightName",
    IPAddress.Parse("192.168.0.2"), IPAddress.Parse("255.255.255.0"),
    IPAddress.Any, IPAddress.Any, String.Empty);
}

See Also

CvsNetworkListener Class
CvsNetworkListener..::..CvsNetworkListener Members
Cognex.InSight.Net Namespace


CvsNetworkListener.SupportsCommand Method

[image]

In-Sight SDK
CvsNetworkListener..::..SupportsCommand Method
CvsNetworkListener Class See Also Send Feedback
Determines if the specified device supports sending a particular command without being connected to the device via a TCP channel.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SupportsCommand(
    CvsHostSensor sensor,
    CvsNetworkMonitorCommand cmd
)
Visual Basic
Public Function SupportsCommand (
    sensor As CvsHostSensor,
    cmd As CvsNetworkMonitorCommand
) As Boolean

Parameters

sensor
Type: Cognex.InSight.Net..::..CvsHostSensor
The sensor to inspect
cmd
Type: Cognex.InSight.Net..::..CvsNetworkMonitorCommand
The command to inspect

Return Value

Type: Boolean
True if the specified device supports the specified command

See Also

CvsNetworkListener Class
CvsNetworkListener..::..CvsNetworkListener Members
Cognex.InSight.Net Namespace


CvsNetworkListener Properties

[image] [image]

In-Sight SDK
CvsNetworkListener Properties
CvsNetworkListener Class See Also Send Feedback

The CvsNetworkListener type exposes the following members.

Properties

 | Name | Description
Public property | Hosts | Gets the collection that holds the current set of identified In-Sight sensors on the network.
Public property | RemoteSubnets | Gets the list of remote subnets to scan for devices. After this list is changed, Refresh must be called on the CvsNetworkMonitor for the change to take effect.
Public property | Scope | Sets the scope of this network listener. This defines whether it will browse for version 2&3 devices and/or version 4 devices.

See Also

CvsNetworkListener Class
Cognex.InSight.Net Namespace


CvsNetworkListener.Hosts Property

[image]

In-Sight SDK
CvsNetworkListener..::..Hosts Property
CvsNetworkListener Class See Also Send Feedback
Gets the collection that holds the current set of identified In-Sight sensors on the network.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostCollection Hosts { get; }
Visual Basic
Public ReadOnly Property Hosts As CvsHostCollection
    Get

Property Value

Type: CvsHostCollection
The collection of CvsHostSensor objects.

Remarks

The contents of the collection returned by this property will not change. When the list of detected hosts changes, a new collection will be created and this property will return the new collection.

See Also

CvsNetworkListener Class
CvsNetworkListener..::..CvsNetworkListener Members
Cognex.InSight.Net Namespace


CvsNetworkListener.RemoteSubnets Property

[image]

In-Sight SDK
CvsNetworkListener..::..RemoteSubnets Property
CvsNetworkListener Class See Also Send Feedback
Gets the list of remote subnets to scan for devices. After this list is changed, Refresh must be called on the CvsNetworkMonitor for the change to take effect.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IList<CvsNetworkMonitorSubnet> RemoteSubnets { get; }
Visual Basic
Public ReadOnly Property RemoteSubnets As IList(Of CvsNetworkMonitorSubnet)
    Get

Property Value

Type: IList <(Of <(<' CvsNetworkMonitorSubnet >)>)>

See Also

CvsNetworkListener Class
CvsNetworkListener..::..CvsNetworkListener Members
Cognex.InSight.Net Namespace


CvsNetworkListener.Scope Property

[image]

In-Sight SDK
CvsNetworkListener..::..Scope Property
CvsNetworkListener Class See Also Send Feedback
Sets the scope of this network listener. This defines whether it will browse for version 2&3 devices and/or version 4 devices.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsNetworkMonitorScope Scope { get; set; }
Visual Basic
Public Property Scope As CvsNetworkMonitorScope
    Get
    Set

Property Value

Type: CvsNetworkMonitorScope

See Also

CvsNetworkListener Class
CvsNetworkListener..::..CvsNetworkListener Members
Cognex.InSight.Net Namespace


CvsNetworkMonitor Class

[image]

In-Sight SDK
CvsNetworkMonitor Class
Members Example See Also Send Feedback
Monitors In-Sight sensors on the network. Use of this class while debugging requires an In-Sight SDK license. If you are debugging an application without an In-Sight SDK license installed, the constructor will throw a CvsNotLicensedException.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public class CvsNetworkMonitor : CvsNetworkListener
Visual Basic
Public Class CvsNetworkMonitor
    Inherits CvsNetworkListener

Remarks

This class extends the capability of its base class CvsNetworkListener to provide a HostsChanged event that is raised when the Hosts property has changed. This event will be raised at most once per second. It also provides a PingInterval property that enables it to periodically ping sensors that were detected on the network in order to determine whether they are still present. Both of these features are controlled by the Enabled property. If these features are not needed, use the simpler CvsNetworkListener class instead.

Only In-Sight sensors on the local subnet for each network adaptor will be detected.

Examples

This example shows how to create a CvsNetworkMonitor and use it to receive a collection of In-Sight sensors.
Copy image Copy
private CvsNetworkMonitor monitor;

private void NetworkMonitorForm_Load(object sender, System.EventArgs e)
{
  monitor = new CvsNetworkMonitor();

  // Attach an event handler to populate a control when the Hosts change
  monitor.HostsChanged += new EventHandler(monitor_HostsChanged);
  monitor.Enabled = checkBoxEnabled.Checked; // Make the value of the control consistent with the check box
}

private void checkBoxEnabled_CheckedChanged(object sender, System.EventArgs e)
{
  monitor.Enabled = checkBoxEnabled.Checked; // Enable/disable monitoring
}

private void buttonRefresh_Click(object sender, System.EventArgs e)
{
  monitor.Refresh();
}

private void monitor_HostsChanged(object sender, EventArgs e)
{
  // Remove old items
  listViewSensors.BeginUpdate();
  listViewSensors.Items.Clear();

  // Handle the new selections from the NetworkMonitor...
  for ( int i = 0; i < monitor.Hosts.Count; i++ )
  {
    ListViewItem item = new ListViewItem(new string[2] { monitor.Hosts[i].Name, monitor.Hosts[i].IPAddress });
    listViewSensors.Items.Add(item);
  }

  listViewSensors.EndUpdate();
}

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Net..::..CvsNetworkListener
Cognex.InSight.Net..::..CvsNetworkMonitor

See Also

CvsNetworkMonitor..::..CvsNetworkMonitor Members
Cognex.InSight.Net Namespace
Cognex.InSight.Net..::..CvsHostSensor
Cognex.InSight.Net..::..CvsHostCollection


CvsNetworkMonitor Members

[image] [image]

In-Sight SDK
CvsNetworkMonitor Members
CvsNetworkMonitor Class Constructors Methods Properties Events See Also Send Feedback

The CvsNetworkMonitor type exposes the following members.

Constructors

 | Name | Description
Public method | CvsNetworkMonitor | Initializes a new instance of the CvsNetworkMonitor class.

Methods

 | Name | Description
Public method | Dispose | Forces the associated network resources to be freed. This should only be called if the associated object will no longer be used. (Inherited from CvsNetworkListener.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Clears the current Hosts collection and requests identification from all In-Sight sensors on the same subnet. (Overrides CvsNetworkListener..::..Refresh()()()().)
Public method | Resolve(IPAddress) | Resolves the specified IP address to a CvsHostSensor describing the device at the specified IP address. (Inherited from CvsNetworkListener.)
Public method | Resolve(String) | Resolves the specified name to a CvsHostSensor describing the device with the specified name. (Inherited from CvsNetworkListener.)
Public method | SendFlash | Sends a message to the specified sensor which will cause it to flash its display for 3 seconds. This can be used to find the physical device associated with this object. (Inherited from CvsNetworkListener.)
Public method | SendSetNetwork | Sends a message to the specified sensor to reconfigure its TCP/IP settings to those specified in the parameters. (Inherited from CvsNetworkListener.)
Public method | SupportsCommand | Determines if the specified device supports sending a particular command without being connected to the device via a TCP channel. (Inherited from CvsNetworkListener.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value that enables or disables monitoring for In-Sight sensors on the network.
Public property | Hosts | Gets the collection that holds the current set of identified In-Sight sensors on the network. (Inherited from CvsNetworkListener.)
Public property | PingInterval | Gets or sets the rate (in seconds) to ping In-Sight sensors that have been detected on the network to see if they are still available. A value of 0 implies that no pinging will be performed.
Public property | RemoteSubnets | Gets the list of remote subnets to scan for devices. After this list is changed, Refresh must be called on the CvsNetworkMonitor for the change to take effect. (Inherited from CvsNetworkListener.)
Public property | Scope | Sets the scope of this network listener. This defines whether it will browse for version 2&3 devices and/or version 4 devices. (Inherited from CvsNetworkListener.)

Events

 | Name | Description
Public event | HostsChanged | The HostsChanged event is raised whenever the Hosts collection changes.

See Also

CvsNetworkMonitor Class
Cognex.InSight.Net Namespace


CvsNetworkMonitor Constructor

[image]

In-Sight SDK
CvsNetworkMonitor Constructor
CvsNetworkMonitor Class See Also Send Feedback
Initializes a new instance of the CvsNetworkMonitor class.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsNetworkMonitor()
Visual Basic
Public Sub New

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotLicensedException | The CvsNetworkMonitor class may not be constructed in a debug environment without an In-Sight SDK license.
Cognex.InSight..::..CvsNetworkException | The CvsNetworkMonitor class could not bind to the network

See Also

CvsNetworkMonitor Class
CvsNetworkMonitor..::..CvsNetworkMonitor Members
Cognex.InSight.Net Namespace


CvsNetworkMonitor Methods

[image] [image]

In-Sight SDK
CvsNetworkMonitor Methods
CvsNetworkMonitor Class See Also Send Feedback

The CvsNetworkMonitor type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Forces the associated network resources to be freed. This should only be called if the associated object will no longer be used. (Inherited from CvsNetworkListener.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Clears the current Hosts collection and requests identification from all In-Sight sensors on the same subnet. (Overrides CvsNetworkListener..::..Refresh()()()().)
Public method | Resolve(IPAddress) | Resolves the specified IP address to a CvsHostSensor describing the device at the specified IP address. (Inherited from CvsNetworkListener.)
Public method | Resolve(String) | Resolves the specified name to a CvsHostSensor describing the device with the specified name. (Inherited from CvsNetworkListener.)
Public method | SendFlash | Sends a message to the specified sensor which will cause it to flash its display for 3 seconds. This can be used to find the physical device associated with this object. (Inherited from CvsNetworkListener.)
Public method | SendSetNetwork | Sends a message to the specified sensor to reconfigure its TCP/IP settings to those specified in the parameters. (Inherited from CvsNetworkListener.)
Public method | SupportsCommand | Determines if the specified device supports sending a particular command without being connected to the device via a TCP channel. (Inherited from CvsNetworkListener.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsNetworkMonitor Class
Cognex.InSight.Net Namespace


CvsNetworkMonitor.Refresh Method

[image]

In-Sight SDK
CvsNetworkMonitor..::..Refresh Method
CvsNetworkMonitor Class See Also Send Feedback
Clears the current Hosts collection and requests identification from all In-Sight sensors on the same subnet.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override void Refresh()
Visual Basic
Public Overrides Sub Refresh

Remarks

It may take several seconds, for all sensors to identify themselves. When sensors are identified, the Hosts collection will be updated.

If a new network adaptor is enabled, calling this method will request sensors accessible via this new adaptor to identify themselves.

If the Enabled property was false, calling this method will set it to true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | The object was disposed.

See Also

CvsNetworkMonitor Class
CvsNetworkMonitor..::..CvsNetworkMonitor Members
Cognex.InSight.Net Namespace


CvsNetworkMonitor Properties

[image] [image]

In-Sight SDK
CvsNetworkMonitor Properties
CvsNetworkMonitor Class See Also Send Feedback

The CvsNetworkMonitor type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value that enables or disables monitoring for In-Sight sensors on the network.
Public property | Hosts | Gets the collection that holds the current set of identified In-Sight sensors on the network. (Inherited from CvsNetworkListener.)
Public property | PingInterval | Gets or sets the rate (in seconds) to ping In-Sight sensors that have been detected on the network to see if they are still available. A value of 0 implies that no pinging will be performed.
Public property | RemoteSubnets | Gets the list of remote subnets to scan for devices. After this list is changed, Refresh must be called on the CvsNetworkMonitor for the change to take effect. (Inherited from CvsNetworkListener.)
Public property | Scope | Sets the scope of this network listener. This defines whether it will browse for version 2&3 devices and/or version 4 devices. (Inherited from CvsNetworkListener.)

See Also

CvsNetworkMonitor Class
Cognex.InSight.Net Namespace


CvsNetworkMonitor.Enabled Property

[image]

In-Sight SDK
CvsNetworkMonitor..::..Enabled Property
CvsNetworkMonitor Class See Also Send Feedback
Gets or sets a value that enables or disables monitoring for In-Sight sensors on the network.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true, when monitoring for In-Sight sensors on the network; false otherwise.

Remarks

When set to true, a request is sent to all In-Sight sensors on the subnet of each network adaptor to identify themselves and monitoring for their responses is started. When the Hosts collection has changed, the HostsChanged event will be raised.

When set to false, the HostsChanged event will not be raised. Also, sensors identified will not be pinged to assure their continued accessibility.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | The object was disposed.

See Also

CvsNetworkMonitor Class
CvsNetworkMonitor..::..CvsNetworkMonitor Members
Cognex.InSight.Net Namespace


CvsNetworkMonitor.PingInterval Property

[image]

In-Sight SDK
CvsNetworkMonitor..::..PingInterval Property
CvsNetworkMonitor Class See Also Send Feedback
Gets or sets the rate (in seconds) to ping In-Sight sensors that have been detected on the network to see if they are still available. A value of 0 implies that no pinging will be performed.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int PingInterval { get; set; }
Visual Basic
Public Property PingInterval As Integer
    Get
    Set

Property Value

Type: Int32
Default is 3.

Remarks

If a sensor is no longer available, the Hosts collection will be updated. Note: Emulators will not be removed from the collection when they are shutdown.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is less than zero.
System..::..ObjectDisposedException | The object was disposed.

See Also

CvsNetworkMonitor Class
CvsNetworkMonitor..::..CvsNetworkMonitor Members
Cognex.InSight.Net Namespace


CvsNetworkMonitor Events

[image] [image]

In-Sight SDK
CvsNetworkMonitor Events
CvsNetworkMonitor Class See Also Send Feedback

The CvsNetworkMonitor type exposes the following members.

Events

 | Name | Description
Public event | HostsChanged | The HostsChanged event is raised whenever the Hosts collection changes.

See Also

CvsNetworkMonitor Class
Cognex.InSight.Net Namespace


CvsNetworkMonitor.HostsChanged Event

[image]

In-Sight SDK
CvsNetworkMonitor..::..HostsChanged Event
CvsNetworkMonitor Class See Also Send Feedback
The HostsChanged event is raised whenever the Hosts collection changes.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public event EventHandler HostsChanged
Visual Basic
Public Event HostsChanged As EventHandler

Value

Type: System..::..EventHandler

Remarks

This event will be raised at most once per second, on the thread that created the CvsNetworkMonitor.

See Also

CvsNetworkMonitor Class
CvsNetworkMonitor..::..CvsNetworkMonitor Members
Cognex.InSight.Net Namespace


CvsNetworkMonitorCommand Enumeration

[image]

In-Sight SDK
CvsNetworkMonitorCommand Enumeration
See Also Send Feedback
Commands that can be checked for support using the

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsNetworkMonitorCommand
Visual Basic
Public Enumeration CvsNetworkMonitorCommand

Members

Member name | Value | Description
IPRequest | 1 | Determines if the device sends IP Request commands on startup
SetNetwork | 2 | Determines if the device supports the SendSetNetwork command.
FactoryReset | 3 | Determines if the device supports the SendSetNetwork command with the reset parameter set to true.
Flash | 4 | Determines if the device supports displaying flashing lights
Hello | 5 | Command sent by the sensor upon request

See Also

Cognex.InSight.Net Namespace


CvsNetworkMonitorScope Enumeration

[image]

In-Sight SDK
CvsNetworkMonitorScope Enumeration
See Also Send Feedback
Enumeration used to specify the search domain for the network monitor

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[FlagsAttribute]
public enum CvsNetworkMonitorScope
Visual Basic
<FlagsAttribute>
Public Enumeration CvsNetworkMonitorScope

Members

Member name | Value | Description
None | 0 | No Scope
Version3 | 1 | Search for Version 2.x and 3.x In-Sight devices
Version4 | 2 | Search for Version 4 In-Sight devices
VersionMask | 3 | Used to mask off only the version field
InSubnet | 256 | Search for devices that are on a locally connected subnet
OutOfSubnet | 512 | Search for devices that are locally connected, but not in a local subnet
RemoteSubnets | 1024 | Search for devices in a remote subnet either via a gateway, or via subnet-directed broadcast
LocationMask | 1792 | Used to mask off only the Location fields
UnsupportedDevices | 65536 | Enables searching for devices which cannot be connected to by this version of the In-Sight SDK.

See Also

Cognex.InSight.Net Namespace


CvsNetworkMonitorSubnet Class

[image]

In-Sight SDK
CvsNetworkMonitorSubnet Class
Members See Also Send Feedback
Represents a subnet on the network.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public class CvsNetworkMonitorSubnet
Visual Basic
Public Class CvsNetworkMonitorSubnet

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Net..::..CvsNetworkMonitorSubnet

See Also

CvsNetworkMonitorSubnet..::..CvsNetworkMonitorSubnet Members
Cognex.InSight.Net Namespace


CvsNetworkMonitorSubnet Members

[image] [image]

In-Sight SDK
CvsNetworkMonitorSubnet Members
CvsNetworkMonitorSubnet Class Constructors Methods Properties See Also Send Feedback

The CvsNetworkMonitorSubnet type exposes the following members.

Constructors

 | Name | Description
Public method | CvsNetworkMonitorSubnet | Constructs a new subnet structure.

Methods

 | Name | Description
Public method | Equals | Override of Equals function (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Override of GetHashCode function (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BroadcastAddress | Gets the broadcast address for this subnet
Public property | IPAddress | The IP Address of the subnet, or the IP Address of the gateway device on the subnet
Public property | SubnetMask | The Subnet Mask of the target subnet

See Also

CvsNetworkMonitorSubnet Class
Cognex.InSight.Net Namespace


CvsNetworkMonitorSubnet Constructor

[image]

In-Sight SDK
CvsNetworkMonitorSubnet Constructor
CvsNetworkMonitorSubnet Class See Also Send Feedback
Constructs a new subnet structure.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsNetworkMonitorSubnet(
    IPAddress ip,
    IPAddress mask
)
Visual Basic
Public Sub New (
    ip As IPAddress,
    mask As IPAddress
)

Parameters

ip
Type: System.Net..::..IPAddress
The IP address of the subnet.
mask
Type: System.Net..::..IPAddress
The subnet mask of the target subnet.

See Also

CvsNetworkMonitorSubnet Class
CvsNetworkMonitorSubnet..::..CvsNetworkMonitorSubnet Members
Cognex.InSight.Net Namespace


CvsNetworkMonitorSubnet Methods

[image] [image]

In-Sight SDK
CvsNetworkMonitorSubnet Methods
CvsNetworkMonitorSubnet Class See Also Send Feedback

The CvsNetworkMonitorSubnet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Override of Equals function (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Override of GetHashCode function (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsNetworkMonitorSubnet Class
Cognex.InSight.Net Namespace


CvsNetworkMonitorSubnet.Equals Method

[image]

In-Sight SDK
CvsNetworkMonitorSubnet..::..Equals Method
CvsNetworkMonitorSubnet Class See Also Send Feedback
Override of Equals function

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: System..::..Object
The object to check.

Return Value

Type: Boolean
Returns true if the object is the same type and IP and mask match; otherwise false.

See Also

CvsNetworkMonitorSubnet Class
CvsNetworkMonitorSubnet..::..CvsNetworkMonitorSubnet Members
Cognex.InSight.Net Namespace


CvsNetworkMonitorSubnet.GetHashCode Method

[image]

In-Sight SDK
CvsNetworkMonitorSubnet..::..GetHashCode Method
CvsNetworkMonitorSubnet Class See Also Send Feedback
Override of GetHashCode function

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash of the IP address and the mask.

See Also

CvsNetworkMonitorSubnet Class
CvsNetworkMonitorSubnet..::..CvsNetworkMonitorSubnet Members
Cognex.InSight.Net Namespace


CvsNetworkMonitorSubnet Properties

[image] [image]

In-Sight SDK
CvsNetworkMonitorSubnet Properties
CvsNetworkMonitorSubnet Class See Also Send Feedback

The CvsNetworkMonitorSubnet type exposes the following members.

Properties

 | Name | Description
Public property | BroadcastAddress | Gets the broadcast address for this subnet
Public property | IPAddress | The IP Address of the subnet, or the IP Address of the gateway device on the subnet
Public property | SubnetMask | The Subnet Mask of the target subnet

See Also

CvsNetworkMonitorSubnet Class
Cognex.InSight.Net Namespace


CvsNetworkMonitorSubnet.BroadcastAddress Property

[image]

In-Sight SDK
CvsNetworkMonitorSubnet..::..BroadcastAddress Property
CvsNetworkMonitorSubnet Class See Also Send Feedback
Gets the broadcast address for this subnet

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress BroadcastAddress { get; }
Visual Basic
Public ReadOnly Property BroadcastAddress As IPAddress
    Get

Property Value

Type: IPAddress

See Also

CvsNetworkMonitorSubnet Class
CvsNetworkMonitorSubnet..::..CvsNetworkMonitorSubnet Members
Cognex.InSight.Net Namespace


CvsNetworkMonitorSubnet.IPAddress Property

[image]

In-Sight SDK
CvsNetworkMonitorSubnet..::..IPAddress Property
CvsNetworkMonitorSubnet Class See Also Send Feedback
The IP Address of the subnet, or the IP Address of the gateway device on the subnet

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress IPAddress { get; }
Visual Basic
Public ReadOnly Property IPAddress As IPAddress
    Get

Property Value

Type: IPAddress

See Also

CvsNetworkMonitorSubnet Class
CvsNetworkMonitorSubnet..::..CvsNetworkMonitorSubnet Members
Cognex.InSight.Net Namespace


CvsNetworkMonitorSubnet.SubnetMask Property

[image]

In-Sight SDK
CvsNetworkMonitorSubnet..::..SubnetMask Property
CvsNetworkMonitorSubnet Class See Also Send Feedback
The Subnet Mask of the target subnet

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress SubnetMask { get; }
Visual Basic
Public ReadOnly Property SubnetMask As IPAddress
    Get

Property Value

Type: IPAddress

See Also

CvsNetworkMonitorSubnet Class
CvsNetworkMonitorSubnet..::..CvsNetworkMonitorSubnet Members
Cognex.InSight.Net Namespace


CvsSupportedFeatures Enumeration

[image]

In-Sight SDK
CvsSupportedFeatures Enumeration
See Also Send Feedback
Enumeration used to determine what features an In-Sight sensor supports.

Namespace: Cognex.InSight.Net
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[FlagsAttribute]
public enum CvsSupportedFeatures
Visual Basic
<FlagsAttribute>
Public Enumeration CvsSupportedFeatures

Members

Member name | Value | Description
None | 0 | The sensor doesn't support any of these features
OPC | 1 | The sensor supports the In-Sight OPC Server.
AutoExposure | 2 | The sensor supports the AutoExposure feature.
MasterSlave | 4 | The sensor supports being in a master-slave configuration.
Terminal | 8 | The sensor supports a terminal window.
LocalStorage | 16 | Indicates SD Card support.

See Also

Cognex.InSight.Net Namespace


Cognex.InSight.Sensor Namespace

[image]

In-Sight SDK
Cognex.InSight.Sensor Namespace
Send Feedback
The Cognex.InSight.Sensor namespace provides classes for accessing and configuring the settings of an In-Sight sensor.

Classes

 | Class | Description
Public class | CvsDefaultRegion | Holds the default region data for an In-Sight sensor. This region can be the base region for example the exposure and the focus region.
Public class | CvsDiscreteInputLineHelper |
Public class | CvsDiscreteIOLine | Contains the data associated with a discrete I/O line.
Public class | CvsDiscreteIOLines | A base class used with the CvsLocalIOSettings and CvsExpansionIOSettings classes.
Public class | CvsDiscreteLineCollection<(Of <(<'T>)>)> |
Public class | CvsDiscreteOutputLineHelper |
Public class | CvsExpansionIOSettings | Holds the expansion IO settings.
Public class | CvsFtpSettings | Holds the FTP settings for an In-Sight sensor.
Public class | CvsHost | The base class for sensors, servers, or host table entries that can be connected to.
Public class | CvsHostTableCollection | Holds the collection of In-Sight sensors that may be available on the network.
Public class | CvsHostTableEntry | Holds the network address and name of an In-Sight sensor.
Public class | CvsHostVersion | Holds information about the version of firmware loaded on an In-Sight sensor.
Public class | CvsInputCollection | Represents a collection of ICvsDiscreteInputLine objects.
Public class | CvsJobServerSettings | Holds the job server settings for an In-Sight sensor.
Public class | CvsLocalIOSettings | Holds the local IO settings.
Public class | CvsNetworkSettings | Holds the network settings for an In-Sight sensor.
Public class | CvsOutputCollection | Represents a collection of ICvsDiscreteOutputLine objects.
Public class | CvsProcessorConstants | Holds the processor constants for an In-Sight sensor.
Public class | CvsProtocolServicesInfo | Holds which CvsProtocolServices are mutually exclusive and which are not.
Public class | CvsRemoteSubnetCollection | Represents a collection of subnet entries.
Public class | CvsRemoteSubnetEntry | Represents a remote subnet entry.
Public class | CvsSensor | Provides access to the sensor settings and processor constants for an In-Sight sensor.
Public class | CvsSerialSettings | Holds the serial port settings for a single serial port.
Public class | CvsSettings | Holds the processor settings for an In-Sight sensor.
Public class | CvsSntpCurrentData | Holds the current SNTP settings for an In-Sight sensor.
Public class | CvsSntpSettings | Holds the SNTP settings for an In-Sight sensor.
Public class | CvsTimeDateData | Holds time and date settings for an In-Sight sensor.
Public class | CvsTimeZones | Holds the valid time zone settings for an In-Sight sensor.
Public class | CvsUniversalIOSettings | Holds the Universal IO settings.
Public class | CvsUser | Holds information for a single entry in the user list.
Public class | CvsUserCollection | Holds the user list for an In-Sight sensor.

Interfaces

 | Interface | Description
Public interface | ICvsDiscreteInputLine | A contract for the common properties of a Discrete Input line.
Public interface | ICvsDiscreteLine | A contract for the common properties of a Discrete I/O line.
Public interface | ICvsDiscreteOutputLine | A contract for the common properties of a Discrete Output line.

Enumerations

 | Enumeration | Description
Public enumeration | CvsAuthenticationAlgorithms | Authentication Algorithm Enumeration
Public enumeration | CvsBaudRate | Defines the serial port's baud rate selections.
Public enumeration | CvsColorBitDepth | Defines the bit depths for color images.
Public enumeration | CvsDataBits | Defines the serial port's number of data bits selections.
Public enumeration | CvsDioLineDirection | Enum of the direction for a specific line
Public enumeration | CvsDioTriColorType | Enum of the type of Tri-color type for a specific line
Public enumeration | CvsEipWatchdogTimeoutActions | An enumeration of EtherNet/IP watchdog timeout actions.
Public enumeration | CvsEncryptionAlgorithms | Encryption Algorithm Enumeration
Public enumeration | CvsHandshake | Defines the serial port's handshake selections.
Public enumeration | CvsHostSubtype | Defines the available subtypes of sensors that can be connected to.
Public enumeration | CvsHostType | Defines the available types of sensors that can be connected to.
Public enumeration | CvsImageResolution | Defines the resolution options for images sent from an In-Sight sensor.
Public enumeration | CvsInputSignal | Defines the trigger signal associated with the input line.
Public enumeration | CvsInputType | Defines the type of operation performed by the input line.
Public enumeration | CvsInSightFeatureFamily | An enumeration of feature families that describes a sensor's capabilities.
Public enumeration | CvsIOModule | Defines the IO module types.
Public enumeration | CvsMode | Defines the serial port's protocol mode selections.
Public enumeration | CvsNetworkLinkModes | An enumeration of Ethernet link modes that may be supported by an In-Sight.
Public enumeration | CvsOutputDelayTypeFlags | Enum of the output delay capabilities of a specific output line
Public enumeration | CvsOutputType | Defines the type of operation designated by the output line.
Public enumeration | CvsParity | Defines the serial port's parity selections.
Public enumeration | CvsProtocols | Protocols that may be secured by an CvsIPsecRule.
Public enumeration | CvsProtocolServices | An enumeration of protocol services that may be enabled or disabled.
Public enumeration | CvsSensorIconType | Defines the known sensor icon types.
Public enumeration | CvsStopBits | Defines the serial port's number of stop bits selections.
Public enumeration | CvsStrobeStartPositionType | Strobe Start Position
Public enumeration | CvsSupportedTools | Enumeration used to determine what tools are enabled on a particular In-Sight sensor.


CvsAuthenticationAlgorithms Enumeration

[image]

In-Sight SDK
CvsAuthenticationAlgorithms Enumeration
See Also Send Feedback
Authentication Algorithm Enumeration

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsAuthenticationAlgorithms
Visual Basic
Public Enumeration CvsAuthenticationAlgorithms

Members

Member name | Value | Description
None | 0 | None
MD5 | 1 | MD5
SHA1 | 2 | SHA1

See Also

Cognex.InSight.Sensor Namespace


CvsBaudRate Enumeration

[image]

In-Sight SDK
CvsBaudRate Enumeration
See Also Send Feedback
Defines the serial port's baud rate selections.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsBaudRate
Visual Basic
Public Enumeration CvsBaudRate

Members

Member name | Value | Description
Baud1200 | 1200 | Designates 1200 Baud.
Baud2400 | 2400 | Designates 2400 Baud.
Baud4800 | 4800 | Designates 4800 Baud.
Baud9600 | 9600 | Designates 9600 Baud.
Baud19200 | 19200 | Designates 19200 Baud.
Baud38400 | 38400 | Designates 38400 Baud.
Baud57600 | 57600 | Designates 57600 Baud.
Baud115200 | 115200 | Designates 115200 Baud.

See Also

Cognex.InSight.Sensor Namespace


CvsColorBitDepth Enumeration

[image]

In-Sight SDK
CvsColorBitDepth Enumeration
See Also Send Feedback
Defines the bit depths for color images.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public enum CvsColorBitDepth
Visual Basic
<SerializableAttribute>
Public Enumeration CvsColorBitDepth

Members

Member name | Value | Description
D16 | 0 | 16 bit color. This is the default.
D24 | 1 | 24 bit color.

See Also

Cognex.InSight.Sensor Namespace


CvsDataBits Enumeration

[image]

In-Sight SDK
CvsDataBits Enumeration
See Also Send Feedback
Defines the serial port's number of data bits selections.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsDataBits
Visual Basic
Public Enumeration CvsDataBits

Members

Member name | Value | Description
Bits7 | 4 | 7 data bits are used.
Bits8 | 8 | 8 data bits are used.

See Also

Cognex.InSight.Sensor Namespace


CvsDefaultRegion Class

[image]

In-Sight SDK
CvsDefaultRegion Class
Members See Also Send Feedback
Holds the default region data for an In-Sight sensor. This region can be the base region for example the exposure and the focus region.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsDefaultRegion
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsDefaultRegion

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsDefaultRegion

See Also

CvsDefaultRegion..::..CvsDefaultRegion Members
Cognex.InSight.Sensor Namespace


CvsDefaultRegion Members

[image] [image]

In-Sight SDK
CvsDefaultRegion Members
CvsDefaultRegion Class Methods Properties See Also Send Feedback

The CvsDefaultRegion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Height | Gets the height of the region.
Public property | Width | Gets the width of the region.
Public property | X | Gets the x position of the region upper-left corner.
Public property | Y | Gets the y position of the region upper-left corner.

See Also

CvsDefaultRegion Class
Cognex.InSight.Sensor Namespace


CvsDefaultRegion Methods

[image] [image]

In-Sight SDK
CvsDefaultRegion Methods
CvsDefaultRegion Class See Also Send Feedback

The CvsDefaultRegion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsDefaultRegion Class
Cognex.InSight.Sensor Namespace


CvsDefaultRegion Properties

[image] [image]

In-Sight SDK
CvsDefaultRegion Properties
CvsDefaultRegion Class See Also Send Feedback

The CvsDefaultRegion type exposes the following members.

Properties

 | Name | Description
Public property | Height | Gets the height of the region.
Public property | Width | Gets the width of the region.
Public property | X | Gets the x position of the region upper-left corner.
Public property | Y | Gets the y position of the region upper-left corner.

See Also

CvsDefaultRegion Class
Cognex.InSight.Sensor Namespace


CvsDefaultRegion.Height Property

[image]

In-Sight SDK
CvsDefaultRegion..::..Height Property
CvsDefaultRegion Class See Also Send Feedback
Gets the height of the region.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Height { get; }
Visual Basic
Public ReadOnly Property Height As Integer
    Get

Property Value

Type: Int32

See Also

CvsDefaultRegion Class
CvsDefaultRegion..::..CvsDefaultRegion Members
Cognex.InSight.Sensor Namespace


CvsDefaultRegion.Width Property

[image]

In-Sight SDK
CvsDefaultRegion..::..Width Property
CvsDefaultRegion Class See Also Send Feedback
Gets the width of the region.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Width { get; }
Visual Basic
Public ReadOnly Property Width As Integer
    Get

Property Value

Type: Int32

See Also

CvsDefaultRegion Class
CvsDefaultRegion..::..CvsDefaultRegion Members
Cognex.InSight.Sensor Namespace


CvsDefaultRegion.X Property

[image]

In-Sight SDK
CvsDefaultRegion..::..X Property
CvsDefaultRegion Class See Also Send Feedback
Gets the x position of the region upper-left corner.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int X { get; }
Visual Basic
Public ReadOnly Property X As Integer
    Get

Property Value

Type: Int32

See Also

CvsDefaultRegion Class
CvsDefaultRegion..::..CvsDefaultRegion Members
Cognex.InSight.Sensor Namespace


CvsDefaultRegion.Y Property

[image]

In-Sight SDK
CvsDefaultRegion..::..Y Property
CvsDefaultRegion Class See Also Send Feedback
Gets the y position of the region upper-left corner.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Y { get; }
Visual Basic
Public ReadOnly Property Y As Integer
    Get

Property Value

Type: Int32

See Also

CvsDefaultRegion Class
CvsDefaultRegion..::..CvsDefaultRegion Members
Cognex.InSight.Sensor Namespace


CvsDioLineDirection Enumeration

[image]

In-Sight SDK
CvsDioLineDirection Enumeration
See Also Send Feedback
Enum of the direction for a specific line

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsDioLineDirection
Visual Basic
Public Enumeration CvsDioLineDirection

Members

Member name | Value | Description
Input | 0 | This is an input line
Output | 1 | This is an output line

See Also

Cognex.InSight.Sensor Namespace


CvsDioTriColorType Enumeration

[image]

In-Sight SDK
CvsDioTriColorType Enumeration
See Also Send Feedback
Enum of the type of Tri-color type for a specific line

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsDioTriColorType
Visual Basic
Public Enumeration CvsDioTriColorType

Members

Member name | Value | Description
OffGreen | 0 | The possible states for the line are Off (0) or Green (1)
OffRed | 1 | The possible states for the line are Off (0) or Red (1)
RedGreen | 2 | The possible states for the line are Red (0) or Green (1)

See Also

Cognex.InSight.Sensor Namespace


CvsDiscreteInputLineHelper Class

[image]

In-Sight SDK
CvsDiscreteInputLineHelper Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Cognex.InSight.Sensor.CvsDiscreteInputLineHelper"]

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static class CvsDiscreteInputLineHelper
Visual Basic
Public NotInheritable Class CvsDiscreteInputLineHelper

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsDiscreteInputLineHelper

See Also

CvsDiscreteInputLineHelper..::..CvsDiscreteInputLineHelper Members
Cognex.InSight.Sensor Namespace


CvsDiscreteInputLineHelper Members

[image] [image]

In-Sight SDK
CvsDiscreteInputLineHelper Members
CvsDiscreteInputLineHelper Class Methods See Also Send Feedback

The CvsDiscreteInputLineHelper type exposes the following members.

Methods

Name | Description
SupportsSignalSetting | Determines whether the given input type supports a Signal setting.

See Also

CvsDiscreteInputLineHelper Class
Cognex.InSight.Sensor Namespace


CvsDiscreteInputLineHelper Methods

[image] [image]

In-Sight SDK
CvsDiscreteInputLineHelper Methods
CvsDiscreteInputLineHelper Class See Also Send Feedback

The CvsDiscreteInputLineHelper type exposes the following members.

Methods

Name | Description
SupportsSignalSetting | Determines whether the given input type supports a Signal setting.

See Also

CvsDiscreteInputLineHelper Class
Cognex.InSight.Sensor Namespace


CvsDiscreteInputLineHelper.SupportsSignalSetting Method

[image]

In-Sight SDK
CvsDiscreteInputLineHelper..::..SupportsSignalSetting Method
CvsDiscreteInputLineHelper Class See Also Send Feedback
Determines whether the given input type supports a Signal setting.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool SupportsSignalSetting(
    CvsInputType type
)
Visual Basic
Public Shared Function SupportsSignalSetting (
    type As CvsInputType
) As Boolean

Parameters

type
Type: Cognex.InSight.Sensor..::..CvsInputType
The input type to validate.

Return Value

Type: Boolean
true if input type supports the Signal setting; otherwise, false.

Remarks

Visual Basic 6 users should use the helper method CvsDiscreteInputLineSupportsSignalSetting(CvsInputType).

See Also

CvsDiscreteInputLineHelper Class
CvsDiscreteInputLineHelper..::..CvsDiscreteInputLineHelper Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine Class

[image]

In-Sight SDK
CvsDiscreteIOLine Class
Members See Also Send Feedback
Contains the data associated with a discrete I/O line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsDiscreteIOLine : ICvsDiscreteInputLine,
    ICvsDiscreteLine, ICloneable, ICvsDiscreteOutputLine
Visual Basic
<SerializableAttribute>
Public Class CvsDiscreteIOLine
    Implements ICvsDiscreteInputLine, ICvsDiscreteLine, ICloneable, ICvsDiscreteOutputLine

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsDiscreteIOLine

See Also

CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine Members

[image] [image]

In-Sight SDK
CvsDiscreteIOLine Members
CvsDiscreteIOLine Class Methods Fields Properties See Also Send Feedback

The CvsDiscreteIOLine type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidOutputType | Determines whether the given output type is valid for the output line.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
MaximumAcquisitionDelay | Maximum allowed number of acquisition or tracking pulses to delay the output.
MaximumAcquisitionDelayTime | Maximum allowed number of ms to delay the output.
MaximumEncoderDelay | Maximum allowed number of encoder counts to delay the output. Max 24 bit number
MaximumPulseLengthInMs | Maximum duration of an output pulse in milliseconds.
MaxInputLines | Constant defining the maximum number of input lines.
MaxIOLineNameLength | Maximum Input/Output line string name length.
MaxOutputLines | Constant defining the maximum number of output lines.
MinimumAcquisitionDelay | Minimum allowed number of acquisition or tracking pulses to delay the output.
MinimumAcquisitionDelayTime | Minimum allowed number of ms to delay the output.
MinimumEncoderDelay | Minimum allowed number of encoder counts to delay the output.
MinimumPulseLengthInMs | Minimum duration of an output pulse in milliseconds.

Properties

 | Name | Description
Public property | Direction | Gets or sets (if supported) the direction of the line.
Public property | IsBiDirectional | Returns true if the output is bi-directional
Public property | Line | Gets the index associated with this line.
Public property | SupportsTriColorLED | Returns true if the output supports Tri-color LED
Public property | TriColorType | Gets or sets (if supported) the tri-color type of the line.

See Also

CvsDiscreteIOLine Class
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine Fields

[image] [image]

In-Sight SDK
CvsDiscreteIOLine Fields
CvsDiscreteIOLine Class See Also Send Feedback

The CvsDiscreteIOLine type exposes the following members.

Fields

Name | Description
MaximumAcquisitionDelay | Maximum allowed number of acquisition or tracking pulses to delay the output.
MaximumAcquisitionDelayTime | Maximum allowed number of ms to delay the output.
MaximumEncoderDelay | Maximum allowed number of encoder counts to delay the output. Max 24 bit number
MaximumPulseLengthInMs | Maximum duration of an output pulse in milliseconds.
MaxInputLines | Constant defining the maximum number of input lines.
MaxIOLineNameLength | Maximum Input/Output line string name length.
MaxOutputLines | Constant defining the maximum number of output lines.
MinimumAcquisitionDelay | Minimum allowed number of acquisition or tracking pulses to delay the output.
MinimumAcquisitionDelayTime | Minimum allowed number of ms to delay the output.
MinimumEncoderDelay | Minimum allowed number of encoder counts to delay the output.
MinimumPulseLengthInMs | Minimum duration of an output pulse in milliseconds.

See Also

CvsDiscreteIOLine Class
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.MaximumAcquisitionDelay Field

[image]

In-Sight SDK
CvsDiscreteIOLine..::..MaximumAcquisitionDelay Field
CvsDiscreteIOLine Class See Also Send Feedback
Maximum allowed number of acquisition or tracking pulses to delay the output.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaximumAcquisitionDelay
Visual Basic
Public Const MaximumAcquisitionDelay As Integer

Field Value

Type: Int32

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.MaximumAcquisitionDelayTime Field

[image]

In-Sight SDK
CvsDiscreteIOLine..::..MaximumAcquisitionDelayTime Field
CvsDiscreteIOLine Class See Also Send Feedback
Maximum allowed number of ms to delay the output.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaximumAcquisitionDelayTime
Visual Basic
Public Const MaximumAcquisitionDelayTime As Integer

Field Value

Type: Int32

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.MaximumEncoderDelay Field

[image]

In-Sight SDK
CvsDiscreteIOLine..::..MaximumEncoderDelay Field
CvsDiscreteIOLine Class See Also Send Feedback
Maximum allowed number of encoder counts to delay the output. Max 24 bit number

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaximumEncoderDelay
Visual Basic
Public Const MaximumEncoderDelay As Integer

Field Value

Type: Int32

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.MaximumPulseLengthInMs Field

[image]

In-Sight SDK
CvsDiscreteIOLine..::..MaximumPulseLengthInMs Field
CvsDiscreteIOLine Class See Also Send Feedback
Maximum duration of an output pulse in milliseconds.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaximumPulseLengthInMs
Visual Basic
Public Const MaximumPulseLengthInMs As Integer

Field Value

Type: Int32

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.MaxInputLines Field

[image]

In-Sight SDK
CvsDiscreteIOLine..::..MaxInputLines Field
CvsDiscreteIOLine Class See Also Send Feedback
Constant defining the maximum number of input lines.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxInputLines
Visual Basic
Public Const MaxInputLines As Integer

Field Value

Type: Int32

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.MaxIOLineNameLength Field

[image]

In-Sight SDK
CvsDiscreteIOLine..::..MaxIOLineNameLength Field
CvsDiscreteIOLine Class See Also Send Feedback
Maximum Input/Output line string name length.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxIOLineNameLength
Visual Basic
Public Const MaxIOLineNameLength As Integer

Field Value

Type: Int32

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.MaxOutputLines Field

[image]

In-Sight SDK
CvsDiscreteIOLine..::..MaxOutputLines Field
CvsDiscreteIOLine Class See Also Send Feedback
Constant defining the maximum number of output lines.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxOutputLines
Visual Basic
Public Const MaxOutputLines As Integer

Field Value

Type: Int32

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.MinimumAcquisitionDelay Field

[image]

In-Sight SDK
CvsDiscreteIOLine..::..MinimumAcquisitionDelay Field
CvsDiscreteIOLine Class See Also Send Feedback
Minimum allowed number of acquisition or tracking pulses to delay the output.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MinimumAcquisitionDelay
Visual Basic
Public Const MinimumAcquisitionDelay As Integer

Field Value

Type: Int32

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.MinimumAcquisitionDelayTime Field

[image]

In-Sight SDK
CvsDiscreteIOLine..::..MinimumAcquisitionDelayTime Field
CvsDiscreteIOLine Class See Also Send Feedback
Minimum allowed number of ms to delay the output.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MinimumAcquisitionDelayTime
Visual Basic
Public Const MinimumAcquisitionDelayTime As Integer

Field Value

Type: Int32

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.MinimumEncoderDelay Field

[image]

In-Sight SDK
CvsDiscreteIOLine..::..MinimumEncoderDelay Field
CvsDiscreteIOLine Class See Also Send Feedback
Minimum allowed number of encoder counts to delay the output.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MinimumEncoderDelay
Visual Basic
Public Const MinimumEncoderDelay As Integer

Field Value

Type: Int32

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.MinimumPulseLengthInMs Field

[image]

In-Sight SDK
CvsDiscreteIOLine..::..MinimumPulseLengthInMs Field
CvsDiscreteIOLine Class See Also Send Feedback
Minimum duration of an output pulse in milliseconds.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MinimumPulseLengthInMs
Visual Basic
Public Const MinimumPulseLengthInMs As Integer

Field Value

Type: Int32

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine Methods

[image] [image]

In-Sight SDK
CvsDiscreteIOLine Methods
CvsDiscreteIOLine Class See Also Send Feedback

The CvsDiscreteIOLine type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidOutputType | Determines whether the given output type is valid for the output line.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsDiscreteIOLine Class
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.IsValidOutputType Method

[image]

In-Sight SDK
CvsDiscreteIOLine..::..IsValidOutputType Method
CvsDiscreteIOLine Class See Also Send Feedback
Determines whether the given output type is valid for the output line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValidOutputType(
    CvsOutputType type
)
Visual Basic
Public Function IsValidOutputType (
    type As CvsOutputType
) As Boolean

Parameters

type
Type: Cognex.InSight.Sensor..::..CvsOutputType
The output type to validate.

Return Value

Type: Boolean
true if output type is valid; otherwise, false.

Implements

ICvsDiscreteOutputLine..::..IsValidOutputType(CvsOutputType)

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine Properties

[image] [image]

In-Sight SDK
CvsDiscreteIOLine Properties
CvsDiscreteIOLine Class See Also Send Feedback

The CvsDiscreteIOLine type exposes the following members.

Properties

 | Name | Description
Public property | Direction | Gets or sets (if supported) the direction of the line.
Public property | IsBiDirectional | Returns true if the output is bi-directional
Public property | Line | Gets the index associated with this line.
Public property | SupportsTriColorLED | Returns true if the output supports Tri-color LED
Public property | TriColorType | Gets or sets (if supported) the tri-color type of the line.

See Also

CvsDiscreteIOLine Class
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.Direction Property

[image]

In-Sight SDK
CvsDiscreteIOLine..::..Direction Property
CvsDiscreteIOLine Class See Also Send Feedback
Gets or sets (if supported) the direction of the line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsDioLineDirection Direction { get; set; }
Visual Basic
Public Property Direction As CvsDioLineDirection
    Get
    Set

Property Value

Type: CvsDioLineDirection

Implements

ICvsDiscreteLine..::..Direction

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.IsBiDirectional Property

[image]

In-Sight SDK
CvsDiscreteIOLine..::..IsBiDirectional Property
CvsDiscreteIOLine Class See Also Send Feedback
Returns true if the output is bi-directional

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsBiDirectional { get; }
Visual Basic
Public ReadOnly Property IsBiDirectional As Boolean
    Get

Property Value

Type: Boolean

Implements

ICvsDiscreteLine..::..IsBiDirectional

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.Line Property

[image]

In-Sight SDK
CvsDiscreteIOLine..::..Line Property
CvsDiscreteIOLine Class See Also Send Feedback
Gets the index associated with this line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Line { get; }
Visual Basic
Public ReadOnly Property Line As Integer
    Get

Property Value

Type: Int32

Implements

ICvsDiscreteLine..::..Line

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.SupportsTriColorLED Property

[image]

In-Sight SDK
CvsDiscreteIOLine..::..SupportsTriColorLED Property
CvsDiscreteIOLine Class See Also Send Feedback
Returns true if the output supports Tri-color LED

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SupportsTriColorLED { get; }
Visual Basic
Public ReadOnly Property SupportsTriColorLED As Boolean
    Get

Property Value

Type: Boolean

Implements

ICvsDiscreteLine..::..SupportsTriColorLED

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLine.TriColorType Property

[image]

In-Sight SDK
CvsDiscreteIOLine..::..TriColorType Property
CvsDiscreteIOLine Class See Also Send Feedback
Gets or sets (if supported) the tri-color type of the line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsDioTriColorType TriColorType { get; set; }
Visual Basic
Public Property TriColorType As CvsDioTriColorType
    Get
    Set

Property Value

Type: CvsDioTriColorType

Implements

ICvsDiscreteLine..::..TriColorType

See Also

CvsDiscreteIOLine Class
CvsDiscreteIOLine..::..CvsDiscreteIOLine Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLines Class

[image]

In-Sight SDK
CvsDiscreteIOLines Class
Members See Also Send Feedback
A base class used with the CvsLocalIOSettings and CvsExpansionIOSettings classes.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public abstract class CvsDiscreteIOLines : ICloneable
Visual Basic
<SerializableAttribute>
Public MustInherit Class CvsDiscreteIOLines
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsDiscreteIOLines
Cognex.InSight.Sensor..::..CvsExpansionIOSettings
Cognex.InSight.Sensor..::..CvsLocalIOSettings
Cognex.InSight.Sensor..::..CvsUniversalIOSettings

See Also

CvsDiscreteIOLines..::..CvsDiscreteIOLines Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLines Members

[image] [image]

In-Sight SDK
CvsDiscreteIOLines Members
CvsDiscreteIOLines Class Methods Properties See Also Send Feedback

The CvsDiscreteIOLines type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines if the CvsDiscreteIOLines objects contain the same values.
Public method | IsValidInputType | Determines if the input type for the current input line is valid for the current In-Sight sensor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetInputType | Sets the type for the designated input line.
Public method | SetOutputType | Sets the type for the designated output line.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inputs | Gets the collection of input lines.
Public property | Outputs | Gets the collection of output lines.

See Also

CvsDiscreteIOLines Class
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLines Methods

[image] [image]

In-Sight SDK
CvsDiscreteIOLines Methods
CvsDiscreteIOLines Class See Also Send Feedback

The CvsDiscreteIOLines type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines if the CvsDiscreteIOLines objects contain the same values.
Public method | IsValidInputType | Determines if the input type for the current input line is valid for the current In-Sight sensor.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetInputType | Sets the type for the designated input line.
Public method | SetOutputType | Sets the type for the designated output line.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsDiscreteIOLines Class
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLines.Clone Method

[image]

In-Sight SDK
CvsDiscreteIOLines..::..Clone Method
CvsDiscreteIOLines Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public abstract Object Clone()
Visual Basic
Public MustOverride Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsDiscreteIOLines Class
CvsDiscreteIOLines..::..CvsDiscreteIOLines Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLines.IsEqual Method

[image]

In-Sight SDK
CvsDiscreteIOLines..::..IsEqual Method
CvsDiscreteIOLines Class See Also Send Feedback
Determines if the CvsDiscreteIOLines objects contain the same values.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsEqual(
    CvsDiscreteIOLines ioLines
)
Visual Basic
Public Function IsEqual (
    ioLines As CvsDiscreteIOLines
) As Boolean

Parameters

ioLines
Type: Cognex.InSight.Sensor..::..CvsDiscreteIOLines
The object to compare with this instance.

Return Value

Type: Boolean
true if objects have the same values; otherwise, false.

See Also

CvsDiscreteIOLines Class
CvsDiscreteIOLines..::..CvsDiscreteIOLines Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLines.IsValidInputType Method

[image]

In-Sight SDK
CvsDiscreteIOLines..::..IsValidInputType Method
CvsDiscreteIOLines Class See Also Send Feedback
Determines if the input type for the current input line is valid for the current In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsValidInputType(
    int line,
    CvsInputType type
)
Visual Basic
Public Function IsValidInputType (
    line As Integer,
    type As CvsInputType
) As Boolean

Parameters

line
Type: System..::..Int32
The line to validate.
type
Type: Cognex.InSight.Sensor..::..CvsInputType
The input type to validate.

Return Value

Type: Boolean
true if input type is valid for the specified line; otherwise, false.

See Also

CvsDiscreteIOLines Class
CvsDiscreteIOLines..::..CvsDiscreteIOLines Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLines.SetInputType Method

[image]

In-Sight SDK
CvsDiscreteIOLines..::..SetInputType Method
CvsDiscreteIOLines Class See Also Send Feedback
Sets the type for the designated input line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetInputType(
    int line,
    CvsInputType value
)
Visual Basic
Public Sub SetInputType (
    line As Integer,
    value As CvsInputType
)

Parameters

line
Type: System..::..Int32
The line to set.
value
Type: Cognex.InSight.Sensor..::..CvsInputType
The type of input line.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | line does not specify a valid input line.
System..::..ArgumentException | value designates an invalid input line type for the sensor.

See Also

CvsDiscreteIOLines Class
CvsDiscreteIOLines..::..CvsDiscreteIOLines Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLines.SetOutputType Method

[image]

In-Sight SDK
CvsDiscreteIOLines..::..SetOutputType Method
CvsDiscreteIOLines Class See Also Send Feedback
Sets the type for the designated output line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetOutputType(
    int line,
    CvsOutputType value
)
Visual Basic
Public Sub SetOutputType (
    line As Integer,
    value As CvsOutputType
)

Parameters

line
Type: System..::..Int32
The line to set.
value
Type: Cognex.InSight.Sensor..::..CvsOutputType
The type of output line.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | line does not specify a valid output line.
System..::..ArgumentException | value designates an invalid output line type for the sensor.

See Also

CvsDiscreteIOLines Class
CvsDiscreteIOLines..::..CvsDiscreteIOLines Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLines Properties

[image] [image]

In-Sight SDK
CvsDiscreteIOLines Properties
CvsDiscreteIOLines Class See Also Send Feedback

The CvsDiscreteIOLines type exposes the following members.

Properties

 | Name | Description
Public property | Inputs | Gets the collection of input lines.
Public property | Outputs | Gets the collection of output lines.

See Also

CvsDiscreteIOLines Class
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLines.Inputs Property

[image]

In-Sight SDK
CvsDiscreteIOLines..::..Inputs Property
CvsDiscreteIOLines Class See Also Send Feedback
Gets the collection of input lines.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsInputCollection Inputs { get; }
Visual Basic
Public ReadOnly Property Inputs As CvsInputCollection
    Get

Property Value

Type: CvsInputCollection

See Also

CvsDiscreteIOLines Class
CvsDiscreteIOLines..::..CvsDiscreteIOLines Members
Cognex.InSight.Sensor Namespace


CvsDiscreteIOLines.Outputs Property

[image]

In-Sight SDK
CvsDiscreteIOLines..::..Outputs Property
CvsDiscreteIOLines Class See Also Send Feedback
Gets the collection of output lines.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsOutputCollection Outputs { get; }
Visual Basic
Public ReadOnly Property Outputs As CvsOutputCollection
    Get

Property Value

Type: CvsOutputCollection

See Also

CvsDiscreteIOLines Class
CvsDiscreteIOLines..::..CvsDiscreteIOLines Members
Cognex.InSight.Sensor Namespace


CvsDiscreteLineCollection(T) Class

[image]

In-Sight SDK
CvsDiscreteLineCollection<(Of <(<'T>)>)> Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Cognex.InSight.Sensor.CvsDiscreteLineCollection`1"]

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public abstract class CvsDiscreteLineCollection<T> : IEnumerable
where T : ICvsDiscreteLine
Visual Basic
<SerializableAttribute>
Public MustInherit Class CvsDiscreteLineCollection(Of T As ICvsDiscreteLine)
    Implements IEnumerable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Cognex.InSight.Sensor.CvsDiscreteLineCollection`1"]

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsDiscreteLineCollection<(Of <(<'T>)>)>
Cognex.InSight.Sensor..::..CvsInputCollection
Cognex.InSight.Sensor..::..CvsOutputCollection

See Also

CvsDiscreteLineCollection<(Of <(<'T>)>)>..::..CvsDiscreteLineCollection<(Of <(<'T>)>)> Members
Cognex.InSight.Sensor Namespace


CvsDiscreteLineCollection(T) Members

[image] [image]

In-Sight SDK
CvsDiscreteLineCollection<(Of <(<'T>)>)> Members
CvsDiscreteLineCollection<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The CvsDiscreteLineCollection<(Of <(<'T>)>)> generic type exposes the following members.

Constructors

 | Name | Description
Protected method | CvsDiscreteLineCollection<(Of <(<'T>)>)> | Initializes a new instance of the CvsDiscreteLineCollection<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | At | Gets the ICvsDiscreteLine object at the specified zero-based index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsInputCollection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSettings | Returns the settings for the specified line.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of lines in the collection.
Public property | Item | Gets the ICvsDiscreteLine object at the specified zero-based index.

See Also

CvsDiscreteLineCollection<(Of <(<'T>)>)> Class
Cognex.InSight.Sensor Namespace


CvsDiscreteLineCollection(T) Constructor

[image]

In-Sight SDK
CvsDiscreteLineCollection<(Of <(<'T>)>)> Constructor
CvsDiscreteLineCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the CvsDiscreteLineCollection<(Of <(<'T>)>)> class

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
protected CvsDiscreteLineCollection()
Visual Basic
Protected Sub New

See Also

CvsDiscreteLineCollection<(Of <(<'T>)>)> Class
CvsDiscreteLineCollection<(Of <(<'T>)>)>..::..CvsDiscreteLineCollection<(Of <(<'T>)>)> Members
Cognex.InSight.Sensor Namespace


CvsDiscreteLineCollection(T) Methods

[image] [image]

In-Sight SDK
CvsDiscreteLineCollection<(Of <(<'T>)>)> Methods
CvsDiscreteLineCollection<(Of <(<'T>)>)> Class See Also Send Feedback

The CvsDiscreteLineCollection<(Of <(<'T>)>)> generic type exposes the following members.

Methods

 | Name | Description
Public method | At | Gets the ICvsDiscreteLine object at the specified zero-based index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsInputCollection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSettings | Returns the settings for the specified line.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsDiscreteLineCollection<(Of <(<'T>)>)> Class
Cognex.InSight.Sensor Namespace


CvsDiscreteLineCollection(T).At Method

[image]

In-Sight SDK
CvsDiscreteLineCollection<(Of <(<'T>)>)>..::..At Method
CvsDiscreteLineCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the ICvsDiscreteLine object at the specified zero-based index.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public T At(
    int index
)
Visual Basic
Public Function At (
    index As Integer
) As T

Parameters

index
Type: System..::..Int32
The zero-based index into the collection.

Return Value

Type: T
The ICvsDiscreteLine at the specified index, or null.

See Also

CvsDiscreteLineCollection<(Of <(<'T>)>)> Class
CvsDiscreteLineCollection<(Of <(<'T>)>)>..::..CvsDiscreteLineCollection<(Of <(<'T>)>)> Members
Cognex.InSight.Sensor Namespace


CvsDiscreteLineCollection(T).GetEnumerator Method

[image]

In-Sight SDK
CvsDiscreteLineCollection<(Of <(<'T>)>)>..::..GetEnumerator Method
CvsDiscreteLineCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Returns an IEnumerator that can iterate through the CvsInputCollection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CvsDiscreteLineCollection<(Of <(<'T>)>)> Class
CvsDiscreteLineCollection<(Of <(<'T>)>)>..::..CvsDiscreteLineCollection<(Of <(<'T>)>)> Members
Cognex.InSight.Sensor Namespace


CvsDiscreteLineCollection(T).GetSettings Method

[image]

In-Sight SDK
CvsDiscreteLineCollection<(Of <(<'T>)>)>..::..GetSettings Method
CvsDiscreteLineCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Returns the settings for the specified line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public T GetSettings(
    int line
)
Visual Basic
Public Function GetSettings (
    line As Integer
) As T

Parameters

line
Type: System..::..Int32
The hardware line number for which to retrieve settings. This corresponds to the Line property of the ICvsDiscreteLine to be retrieved.

Return Value

Type: T
The line settings or null if not found.

See Also

CvsDiscreteLineCollection<(Of <(<'T>)>)> Class
CvsDiscreteLineCollection<(Of <(<'T>)>)>..::..CvsDiscreteLineCollection<(Of <(<'T>)>)> Members
Cognex.InSight.Sensor Namespace


CvsDiscreteLineCollection(T) Properties

[image] [image]

In-Sight SDK
CvsDiscreteLineCollection<(Of <(<'T>)>)> Properties
CvsDiscreteLineCollection<(Of <(<'T>)>)> Class See Also Send Feedback

The CvsDiscreteLineCollection<(Of <(<'T>)>)> generic type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of lines in the collection.
Public property | Item | Gets the ICvsDiscreteLine object at the specified zero-based index.

See Also

CvsDiscreteLineCollection<(Of <(<'T>)>)> Class
Cognex.InSight.Sensor Namespace


CvsDiscreteLineCollection(T).Count Property

[image]

In-Sight SDK
CvsDiscreteLineCollection<(Of <(<'T>)>)>..::..Count Property
CvsDiscreteLineCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the number of lines in the collection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

CvsDiscreteLineCollection<(Of <(<'T>)>)> Class
CvsDiscreteLineCollection<(Of <(<'T>)>)>..::..CvsDiscreteLineCollection<(Of <(<'T>)>)> Members
Cognex.InSight.Sensor Namespace


CvsDiscreteLineCollection(T).Item Property

[image]

In-Sight SDK
CvsDiscreteLineCollection<(Of <(<'T>)>)>..::..Item Property
CvsDiscreteLineCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the ICvsDiscreteLine object at the specified zero-based index.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public T this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As T
    Get

Parameters

index
Type: System..::..Int32
The zero-based index into the collection.

Property Value

Type: T

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsDiscreteLineCollection<(Of <(<'T>)>)> Class
CvsDiscreteLineCollection<(Of <(<'T>)>)>..::..CvsDiscreteLineCollection<(Of <(<'T>)>)> Members
Cognex.InSight.Sensor Namespace


CvsDiscreteOutputLineHelper Class

[image]

In-Sight SDK
CvsDiscreteOutputLineHelper Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Cognex.InSight.Sensor.CvsDiscreteOutputLineHelper"]

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static class CvsDiscreteOutputLineHelper
Visual Basic
Public NotInheritable Class CvsDiscreteOutputLineHelper

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsDiscreteOutputLineHelper

See Also

CvsDiscreteOutputLineHelper..::..CvsDiscreteOutputLineHelper Members
Cognex.InSight.Sensor Namespace


CvsDiscreteOutputLineHelper Members

[image] [image]

In-Sight SDK
CvsDiscreteOutputLineHelper Members
CvsDiscreteOutputLineHelper Class Methods See Also Send Feedback

The CvsDiscreteOutputLineHelper type exposes the following members.

Methods

Name | Description
SupportEncoderAfterTrigger(CvsOutputType, Boolean) | Determines if the output type supports Encoder After Trigger settings.
SupportEncoderAfterTrigger(CvsIOModule, Int32, CvsOutputType, Int32) | Determines if the output type supports Encoder After Trigger settings.
SupportsPulseAndAcquisitionDelay | Determines if the output type supports pulse enable selection and acquisition delay settings. This type also supports a PulseLength setting when the PulseEnabledOrStrobedEdge flag is set to true.
SupportsPulseLengthSetting | Determines if the output type supports a pulse length setting without regard to the Pulse Enable flag.
SupportsStrobeTriggerSelection | Determines if the output type supports a strobe trigger selection.
SupportTimeAfterTrigger | Determines if the output type supports Time After Trigger settings. Note that if Programmed lines have the DelayNumberIsTimeAfterTrigger flag set to true, the DelayNumber is the desired number of milliseconds after the (possibly delayed) image trigger.

See Also

CvsDiscreteOutputLineHelper Class
Cognex.InSight.Sensor Namespace


CvsDiscreteOutputLineHelper Methods

[image] [image]

In-Sight SDK
CvsDiscreteOutputLineHelper Methods
CvsDiscreteOutputLineHelper Class See Also Send Feedback

The CvsDiscreteOutputLineHelper type exposes the following members.

Methods

Name | Description
SupportEncoderAfterTrigger(CvsOutputType, Boolean) | Determines if the output type supports Encoder After Trigger settings.
SupportEncoderAfterTrigger(CvsIOModule, Int32, CvsOutputType, Int32) | Determines if the output type supports Encoder After Trigger settings.
SupportsPulseAndAcquisitionDelay | Determines if the output type supports pulse enable selection and acquisition delay settings. This type also supports a PulseLength setting when the PulseEnabledOrStrobedEdge flag is set to true.
SupportsPulseLengthSetting | Determines if the output type supports a pulse length setting without regard to the Pulse Enable flag.
SupportsStrobeTriggerSelection | Determines if the output type supports a strobe trigger selection.
SupportTimeAfterTrigger | Determines if the output type supports Time After Trigger settings. Note that if Programmed lines have the DelayNumberIsTimeAfterTrigger flag set to true, the DelayNumber is the desired number of milliseconds after the (possibly delayed) image trigger.

See Also

CvsDiscreteOutputLineHelper Class
Cognex.InSight.Sensor Namespace


CvsDiscreteOutputLineHelper.SupportEncoderAfterTrigger Method

[image] [image]

In-Sight SDK
CvsDiscreteOutputLineHelper..::..SupportEncoderAfterTrigger Method
CvsDiscreteOutputLineHelper Class See Also Send Feedback

Overload List

Name | Description
SupportEncoderAfterTrigger(CvsOutputType, Boolean) | Determines if the output type supports Encoder After Trigger settings.
SupportEncoderAfterTrigger(CvsIOModule, Int32, CvsOutputType, Int32) | Determines if the output type supports Encoder After Trigger settings.

See Also

CvsDiscreteOutputLineHelper Class
CvsDiscreteOutputLineHelper..::..CvsDiscreteOutputLineHelper Members
Cognex.InSight.Sensor Namespace


CvsDiscreteOutputLineHelper.SupportEncoderAfterTrigger Method (CvsOutputType, Boolean)

[image]

In-Sight SDK
CvsDiscreteOutputLineHelper..::..SupportEncoderAfterTrigger Method (CvsOutputType, Boolean)
CvsDiscreteOutputLineHelper Class See Also Send Feedback
Determines if the output type supports Encoder After Trigger settings.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool SupportEncoderAfterTrigger(
    CvsOutputType type,
    bool highSpeed
)
Visual Basic
Public Shared Function SupportEncoderAfterTrigger (
    type As CvsOutputType,
    highSpeed As Boolean
) As Boolean

Parameters

type
Type: Cognex.InSight.Sensor..::..CvsOutputType
The output type to validate.
highSpeed
Type: System..::..Boolean
Whether the line is high speed.

Return Value

Type: Boolean
true if Encoder After Trigger is supported; otherwise, false.

See Also

CvsDiscreteOutputLineHelper Class
CvsDiscreteOutputLineHelper..::..CvsDiscreteOutputLineHelper Members
SupportEncoderAfterTrigger Overload
Cognex.InSight.Sensor Namespace


CvsDiscreteOutputLineHelper.SupportEncoderAfterTrigger Method (CvsIOModule, Int32, CvsOutputType, Int32)

[image]

In-Sight SDK
CvsDiscreteOutputLineHelper..::..SupportEncoderAfterTrigger Method (CvsIOModule, Int32, CvsOutputType, Int32)
CvsDiscreteOutputLineHelper Class See Also Send Feedback
Determines if the output type supports Encoder After Trigger settings.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool SupportEncoderAfterTrigger(
    CvsIOModule module,
    int line,
    CvsOutputType type,
    int ledCount
)
Visual Basic
Public Shared Function SupportEncoderAfterTrigger (
    module As CvsIOModule,
    line As Integer,
    type As CvsOutputType,
    ledCount As Integer
) As Boolean

Parameters

module
Type: Cognex.InSight.Sensor..::..CvsIOModule
Active module
line
Type: System..::..Int32
line number
type
Type: Cognex.InSight.Sensor..::..CvsOutputType
The output type to validate.
ledCount
Type: System..::..Int32
The LED count in the current I/O module.

Return Value

Type: Boolean
true if Encoder After Trigger is supported; otherwise, false.

See Also

CvsDiscreteOutputLineHelper Class
CvsDiscreteOutputLineHelper..::..CvsDiscreteOutputLineHelper Members
SupportEncoderAfterTrigger Overload
Cognex.InSight.Sensor Namespace


CvsDiscreteOutputLineHelper.SupportsPulseAndAcquisitionDelay Method

[image]

In-Sight SDK
CvsDiscreteOutputLineHelper..::..SupportsPulseAndAcquisitionDelay Method
CvsDiscreteOutputLineHelper Class See Also Send Feedback
Determines if the output type supports pulse enable selection and acquisition delay settings. This type also supports a PulseLength setting when the PulseEnabledOrStrobedEdge flag is set to true.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool SupportsPulseAndAcquisitionDelay(
    CvsOutputType type
)
Visual Basic
Public Shared Function SupportsPulseAndAcquisitionDelay (
    type As CvsOutputType
) As Boolean

Parameters

type
Type: Cognex.InSight.Sensor..::..CvsOutputType
The output type to validate.

Return Value

Type: Boolean
true if pulse enabling and acquisition delay setting are valid; otherwise, false.

Remarks

Visual Basic 6 users should use the helper method CvsDiscreteOutputLineSupportsPulseAndAcquisitionDelay(CvsOutputType).

See Also

CvsDiscreteOutputLineHelper Class
CvsDiscreteOutputLineHelper..::..CvsDiscreteOutputLineHelper Members
Cognex.InSight.Sensor Namespace


CvsDiscreteOutputLineHelper.SupportsPulseLengthSetting Method

[image]

In-Sight SDK
CvsDiscreteOutputLineHelper..::..SupportsPulseLengthSetting Method
CvsDiscreteOutputLineHelper Class See Also Send Feedback
Determines if the output type supports a pulse length setting without regard to the Pulse Enable flag.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool SupportsPulseLengthSetting(
    CvsOutputType type
)
Visual Basic
Public Shared Function SupportsPulseLengthSetting (
    type As CvsOutputType
) As Boolean

Parameters

type
Type: Cognex.InSight.Sensor..::..CvsOutputType
The output type to validate.

Return Value

Type: Boolean
true if pulse length setting is valid; otherwise, false.

Remarks

Note that Programmed lines must have the PulseEnabledOrStrobedEdge flag set to true to set the PulseLength.

Visual Basic 6 users should use the helper method CvsDiscreteOutputLineSupportsPulseLengthSetting(CvsOutputType).

See Also

CvsDiscreteOutputLineHelper Class
CvsDiscreteOutputLineHelper..::..CvsDiscreteOutputLineHelper Members
Cognex.InSight.Sensor Namespace


CvsDiscreteOutputLineHelper.SupportsStrobeTriggerSelection Method

[image]

In-Sight SDK
CvsDiscreteOutputLineHelper..::..SupportsStrobeTriggerSelection Method
CvsDiscreteOutputLineHelper Class See Also Send Feedback
Determines if the output type supports a strobe trigger selection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool SupportsStrobeTriggerSelection(
    CvsOutputType type
)
Visual Basic
Public Shared Function SupportsStrobeTriggerSelection (
    type As CvsOutputType
) As Boolean

Parameters

type
Type: Cognex.InSight.Sensor..::..CvsOutputType
The output type to validate.

Return Value

Type: Boolean
true if strobe trigger setting or light control edge setting is valid to set; otherwise, false.

Remarks

Visual Basic 6 users should use the helper method CvsDiscreteOutputLineSupportsStrobeTriggerSelection(CvsOutputType).

See Also

CvsDiscreteOutputLineHelper Class
CvsDiscreteOutputLineHelper..::..CvsDiscreteOutputLineHelper Members
Cognex.InSight.Sensor Namespace


CvsDiscreteOutputLineHelper.SupportTimeAfterTrigger Method

[image]

In-Sight SDK
CvsDiscreteOutputLineHelper..::..SupportTimeAfterTrigger Method
CvsDiscreteOutputLineHelper Class See Also Send Feedback
Determines if the output type supports Time After Trigger settings. Note that if Programmed lines have the DelayNumberIsTimeAfterTrigger flag set to true, the DelayNumber is the desired number of milliseconds after the (possibly delayed) image trigger.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool SupportTimeAfterTrigger(
    CvsOutputType type
)
Visual Basic
Public Shared Function SupportTimeAfterTrigger (
    type As CvsOutputType
) As Boolean

Parameters

type
Type: Cognex.InSight.Sensor..::..CvsOutputType
The output type to validate.

Return Value

Type: Boolean
true if Time After Trigger is supported; otherwise, false.

See Also

CvsDiscreteOutputLineHelper Class
CvsDiscreteOutputLineHelper..::..CvsDiscreteOutputLineHelper Members
Cognex.InSight.Sensor Namespace


CvsEipWatchdogTimeoutActions Enumeration

[image]

In-Sight SDK
CvsEipWatchdogTimeoutActions Enumeration
See Also Send Feedback
An enumeration of EtherNet/IP watchdog timeout actions.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsEipWatchdogTimeoutActions
Visual Basic
Public Enumeration CvsEipWatchdogTimeoutActions

Members

Member name | Value | Description
TransitionToTimedOut | 0 | The connection enters a timed out state.
AutoDelete | 1 | Instead of timing out, the connection is deleted, allowing the PLC to establish a new connection.

See Also

Cognex.InSight.Sensor Namespace


CvsEncryptionAlgorithms Enumeration

[image]

In-Sight SDK
CvsEncryptionAlgorithms Enumeration
See Also Send Feedback
Encryption Algorithm Enumeration

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsEncryptionAlgorithms
Visual Basic
Public Enumeration CvsEncryptionAlgorithms

Members

Member name | Value | Description
None | 0 | None
DES | 1 | DES
TripleDES | 2 | 3DES
AES | 3 | AES
Blowfish | 4 | Blowfish

See Also

Cognex.InSight.Sensor Namespace


CvsExpansionIOSettings Class

[image]

In-Sight SDK
CvsExpansionIOSettings Class
Members See Also Send Feedback
Holds the expansion IO settings.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsExpansionIOSettings : CvsDiscreteIOLines
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsExpansionIOSettings
    Inherits CvsDiscreteIOLines

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsDiscreteIOLines
Cognex.InSight.Sensor..::..CvsExpansionIOSettings

See Also

CvsExpansionIOSettings..::..CvsExpansionIOSettings Members
Cognex.InSight.Sensor Namespace


CvsExpansionIOSettings Members

[image] [image]

In-Sight SDK
CvsExpansionIOSettings Members
CvsExpansionIOSettings Class Methods Properties See Also Send Feedback

The CvsExpansionIOSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance. (Overrides CvsDiscreteIOLines..::..Clone()()()().)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines if the CvsDiscreteIOLines objects contain the same values. (Inherited from CvsDiscreteIOLines.)
Public method | IsValidInputType | Determines if the input type for the current input line is valid for the current In-Sight sensor. (Inherited from CvsDiscreteIOLines.)
Public method | SetInputType | Sets the type for the designated input line. (Inherited from CvsDiscreteIOLines.)
Public method | SetOutputType | Sets the type for the designated output line. (Inherited from CvsDiscreteIOLines.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inputs | Gets the collection of input lines. (Inherited from CvsDiscreteIOLines.)
Public property | Outputs | Gets the collection of output lines. (Inherited from CvsDiscreteIOLines.)

See Also

CvsExpansionIOSettings Class
Cognex.InSight.Sensor Namespace


CvsExpansionIOSettings Methods

[image] [image]

In-Sight SDK
CvsExpansionIOSettings Methods
CvsExpansionIOSettings Class See Also Send Feedback

The CvsExpansionIOSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance. (Overrides CvsDiscreteIOLines..::..Clone()()()().)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines if the CvsDiscreteIOLines objects contain the same values. (Inherited from CvsDiscreteIOLines.)
Public method | IsValidInputType | Determines if the input type for the current input line is valid for the current In-Sight sensor. (Inherited from CvsDiscreteIOLines.)
Public method | SetInputType | Sets the type for the designated input line. (Inherited from CvsDiscreteIOLines.)
Public method | SetOutputType | Sets the type for the designated output line. (Inherited from CvsDiscreteIOLines.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsExpansionIOSettings Class
Cognex.InSight.Sensor Namespace


CvsExpansionIOSettings.Clone Method

[image]

In-Sight SDK
CvsExpansionIOSettings..::..Clone Method
CvsExpansionIOSettings Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsExpansionIOSettings Class
CvsExpansionIOSettings..::..CvsExpansionIOSettings Members
Cognex.InSight.Sensor Namespace


CvsExpansionIOSettings Properties

[image] [image]

In-Sight SDK
CvsExpansionIOSettings Properties
CvsExpansionIOSettings Class See Also Send Feedback

The CvsExpansionIOSettings type exposes the following members.

Properties

 | Name | Description
Public property | Inputs | Gets the collection of input lines. (Inherited from CvsDiscreteIOLines.)
Public property | Outputs | Gets the collection of output lines. (Inherited from CvsDiscreteIOLines.)

See Also

CvsExpansionIOSettings Class
Cognex.InSight.Sensor Namespace


CvsFtpSettings Class

[image]

In-Sight SDK
CvsFtpSettings Class
Members See Also Send Feedback
Holds the FTP settings for an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsFtpSettings : ICloneable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsFtpSettings
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsFtpSettings

See Also

CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings Members

[image] [image]

In-Sight SDK
CvsFtpSettings Members
CvsFtpSettings Class Methods Fields Properties See Also Send Feedback

The CvsFtpSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
MaxFtpConnectionRetries | The maximum number of connection retries.
MaxFtpIdleTimeoutInSeconds | The maximum idle timeout in seconds.
MaxFtpPortNumber | The maximum port number setting (remote or local).
MaxFtpReadTimeoutInSeconds | The maximum read timeout in seconds.
MinFtpConnectionRetries | The minimum number of connection retries.
MinFtpIdleTimeoutInSeconds | The minimum idle timeout in seconds.
MinFtpPortNumber | The minimum port number setting (remote or local).
MinFtpReadTimeoutInSeconds | The minimum read timeout in seconds.

Properties

 | Name | Description
Public property | ConnectionRetries | Gets or sets the number of connection retries.
Public property | IdleTimeout | Gets or sets the idle timeout value in seconds.
Public property | LocalPort | Gets or sets the local FTP port.
Public property | PassiveTransfersEnabled | Gets or sets a value designating whether passive transferring is enabled.
Public property | ReadTimeout | Gets or sets the read timeout value in seconds.
Public property | RemotePort | Gets or sets the remote FTP port.

See Also

CvsFtpSettings Class
Cognex.InSight.Sensor Namespace


CvsFtpSettings Fields

[image] [image]

In-Sight SDK
CvsFtpSettings Fields
CvsFtpSettings Class See Also Send Feedback

The CvsFtpSettings type exposes the following members.

Fields

Name | Description
MaxFtpConnectionRetries | The maximum number of connection retries.
MaxFtpIdleTimeoutInSeconds | The maximum idle timeout in seconds.
MaxFtpPortNumber | The maximum port number setting (remote or local).
MaxFtpReadTimeoutInSeconds | The maximum read timeout in seconds.
MinFtpConnectionRetries | The minimum number of connection retries.
MinFtpIdleTimeoutInSeconds | The minimum idle timeout in seconds.
MinFtpPortNumber | The minimum port number setting (remote or local).
MinFtpReadTimeoutInSeconds | The minimum read timeout in seconds.

See Also

CvsFtpSettings Class
Cognex.InSight.Sensor Namespace


CvsFtpSettings.MaxFtpConnectionRetries Field

[image]

In-Sight SDK
CvsFtpSettings..::..MaxFtpConnectionRetries Field
CvsFtpSettings Class See Also Send Feedback
The maximum number of connection retries.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxFtpConnectionRetries
Visual Basic
Public Const MaxFtpConnectionRetries As Integer

Field Value

Type: Int32

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings.MaxFtpIdleTimeoutInSeconds Field

[image]

In-Sight SDK
CvsFtpSettings..::..MaxFtpIdleTimeoutInSeconds Field
CvsFtpSettings Class See Also Send Feedback
The maximum idle timeout in seconds.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxFtpIdleTimeoutInSeconds
Visual Basic
Public Const MaxFtpIdleTimeoutInSeconds As Integer

Field Value

Type: Int32

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings.MaxFtpPortNumber Field

[image]

In-Sight SDK
CvsFtpSettings..::..MaxFtpPortNumber Field
CvsFtpSettings Class See Also Send Feedback
The maximum port number setting (remote or local).

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxFtpPortNumber
Visual Basic
Public Const MaxFtpPortNumber As Integer

Field Value

Type: Int32

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings.MaxFtpReadTimeoutInSeconds Field

[image]

In-Sight SDK
CvsFtpSettings..::..MaxFtpReadTimeoutInSeconds Field
CvsFtpSettings Class See Also Send Feedback
The maximum read timeout in seconds.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxFtpReadTimeoutInSeconds
Visual Basic
Public Const MaxFtpReadTimeoutInSeconds As Integer

Field Value

Type: Int32

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings.MinFtpConnectionRetries Field

[image]

In-Sight SDK
CvsFtpSettings..::..MinFtpConnectionRetries Field
CvsFtpSettings Class See Also Send Feedback
The minimum number of connection retries.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MinFtpConnectionRetries
Visual Basic
Public Const MinFtpConnectionRetries As Integer

Field Value

Type: Int32

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings.MinFtpIdleTimeoutInSeconds Field

[image]

In-Sight SDK
CvsFtpSettings..::..MinFtpIdleTimeoutInSeconds Field
CvsFtpSettings Class See Also Send Feedback
The minimum idle timeout in seconds.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MinFtpIdleTimeoutInSeconds
Visual Basic
Public Const MinFtpIdleTimeoutInSeconds As Integer

Field Value

Type: Int32

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings.MinFtpPortNumber Field

[image]

In-Sight SDK
CvsFtpSettings..::..MinFtpPortNumber Field
CvsFtpSettings Class See Also Send Feedback
The minimum port number setting (remote or local).

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MinFtpPortNumber
Visual Basic
Public Const MinFtpPortNumber As Integer

Field Value

Type: Int32

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings.MinFtpReadTimeoutInSeconds Field

[image]

In-Sight SDK
CvsFtpSettings..::..MinFtpReadTimeoutInSeconds Field
CvsFtpSettings Class See Also Send Feedback
The minimum read timeout in seconds.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MinFtpReadTimeoutInSeconds
Visual Basic
Public Const MinFtpReadTimeoutInSeconds As Integer

Field Value

Type: Int32

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings Methods

[image] [image]

In-Sight SDK
CvsFtpSettings Methods
CvsFtpSettings Class See Also Send Feedback

The CvsFtpSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsFtpSettings Class
Cognex.InSight.Sensor Namespace


CvsFtpSettings.Clone Method

[image]

In-Sight SDK
CvsFtpSettings..::..Clone Method
CvsFtpSettings Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings Properties

[image] [image]

In-Sight SDK
CvsFtpSettings Properties
CvsFtpSettings Class See Also Send Feedback

The CvsFtpSettings type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionRetries | Gets or sets the number of connection retries.
Public property | IdleTimeout | Gets or sets the idle timeout value in seconds.
Public property | LocalPort | Gets or sets the local FTP port.
Public property | PassiveTransfersEnabled | Gets or sets a value designating whether passive transferring is enabled.
Public property | ReadTimeout | Gets or sets the read timeout value in seconds.
Public property | RemotePort | Gets or sets the remote FTP port.

See Also

CvsFtpSettings Class
Cognex.InSight.Sensor Namespace


CvsFtpSettings.ConnectionRetries Property

[image]

In-Sight SDK
CvsFtpSettings..::..ConnectionRetries Property
CvsFtpSettings Class See Also Send Feedback
Gets or sets the number of connection retries.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int ConnectionRetries { get; set; }
Visual Basic
Public Property ConnectionRetries As Integer
    Get
    Set

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value does not fall between MinFtpConnectionRetries and MaxFtpConnectionRetries.

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings.IdleTimeout Property

[image]

In-Sight SDK
CvsFtpSettings..::..IdleTimeout Property
CvsFtpSettings Class See Also Send Feedback
Gets or sets the idle timeout value in seconds.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IdleTimeout { get; set; }
Visual Basic
Public Property IdleTimeout As Integer
    Get
    Set

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value does not fall between MinFtpIdleTimeoutInSeconds and MaxFtpIdleTimeoutInSeconds.

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings.LocalPort Property

[image]

In-Sight SDK
CvsFtpSettings..::..LocalPort Property
CvsFtpSettings Class See Also Send Feedback
Gets or sets the local FTP port.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int LocalPort { get; set; }
Visual Basic
Public Property LocalPort As Integer
    Get
    Set

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value does not fall between MinFtpPortNumber and MaxFtpPortNumber.

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings.PassiveTransfersEnabled Property

[image]

In-Sight SDK
CvsFtpSettings..::..PassiveTransfersEnabled Property
CvsFtpSettings Class See Also Send Feedback
Gets or sets a value designating whether passive transferring is enabled.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool PassiveTransfersEnabled { get; set; }
Visual Basic
Public Property PassiveTransfersEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings.ReadTimeout Property

[image]

In-Sight SDK
CvsFtpSettings..::..ReadTimeout Property
CvsFtpSettings Class See Also Send Feedback
Gets or sets the read timeout value in seconds.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int ReadTimeout { get; set; }
Visual Basic
Public Property ReadTimeout As Integer
    Get
    Set

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value does not fall between MinFtpReadTimeoutInSeconds and MaxFtpReadTimeoutInSeconds.

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsFtpSettings.RemotePort Property

[image]

In-Sight SDK
CvsFtpSettings..::..RemotePort Property
CvsFtpSettings Class See Also Send Feedback
Gets or sets the remote FTP port.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int RemotePort { get; set; }
Visual Basic
Public Property RemotePort As Integer
    Get
    Set

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value does not fall between MinFtpPortNumber and MaxFtpPortNumber.

See Also

CvsFtpSettings Class
CvsFtpSettings..::..CvsFtpSettings Members
Cognex.InSight.Sensor Namespace


CvsHandshake Enumeration

[image]

In-Sight SDK
CvsHandshake Enumeration
See Also Send Feedback
Defines the serial port's handshake selections.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsHandshake
Visual Basic
Public Enumeration CvsHandshake

Members

Member name | Value | Description
None | 0 | No handshaking is used.
XonXoff | 2 | Xon/Xoff handshaking is used.
Hardware | 1 | Hardware handshaking is used.

See Also

Cognex.InSight.Sensor Namespace


CvsHost Class

[image]

In-Sight SDK
CvsHost Class
Members See Also Send Feedback
The base class for sensors, servers, or host table entries that can be connected to.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsHost : ICloneable
Visual Basic
<SerializableAttribute>
Public Class CvsHost
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsHost
Cognex.InSight.Net..::..CvsHostSensor
Cognex.InSight.Sensor..::..CvsHostTableEntry

See Also

CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost Members

[image] [image]

In-Sight SDK
CvsHost Members
CvsHost Class Methods Fields Properties See Also Send Feedback

The CvsHost type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidHostIPAddress(String) | Determines if the string is a valid IP address.
 | IsValidHostIPAddress(IPAddress, IPAddress, String%) | Determines if the host IP Address is valid.
 | IsValidHostName | Determines if the string is a valid host name. Checks the length and content.
 | IsValidHostNameChar(Char) | Determines if the character is valid for a host name.
 | IsValidHostNameChar(Char, Boolean) | Determines if the character is valid for a host name.
 | IsValidIPAddressChar | Determines if the character is valid for an IP address.
 | IsValidSensorName | Determines if the string is a valid sensor name. Checks the length and content.
 | IsValidSensorNameChar | Determines if the character is valid for a sensor name.
 | IsValidSubnetIPAddress(String) | Determines if the string is a valid Subnet IP address.
 | IsValidSubnetIPAddress(IPAddress, IPAddress, String%) | Determines if the string is a valid Subnet IP address.
Public method | Matches | Tests whether obj is a CvsHost with the same contents of this instance by comparing the names.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the name of the host. (Overrides Object..::..ToString()()()().)

Fields

Name | Description
MaxNameLength | The maximum length for a host name.

Properties

 | Name | Description
Public property | IPAddress | Gets the IP address for the host.
Public property | IPAddressString | Gets the IP address string for the host.
Public property | Name | Gets the name of the host.
Public property | Subtype | Gets the sensor subtype of the host.
Public property | Type | Gets the sensor type of the host.

See Also

CvsHost Class
Cognex.InSight.Sensor Namespace


CvsHost Fields

[image] [image]

In-Sight SDK
CvsHost Fields
CvsHost Class See Also Send Feedback

The CvsHost type exposes the following members.

Fields

Name | Description
MaxNameLength | The maximum length for a host name.

See Also

CvsHost Class
Cognex.InSight.Sensor Namespace


CvsHost.MaxNameLength Field

[image]

In-Sight SDK
CvsHost..::..MaxNameLength Field
CvsHost Class See Also Send Feedback
The maximum length for a host name.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxNameLength
Visual Basic
Public Const MaxNameLength As Integer

Field Value

Type: Int32

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost Methods

[image] [image]

In-Sight SDK
CvsHost Methods
CvsHost Class See Also Send Feedback

The CvsHost type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidHostIPAddress(String) | Determines if the string is a valid IP address.
 | IsValidHostIPAddress(IPAddress, IPAddress, String%) | Determines if the host IP Address is valid.
 | IsValidHostName | Determines if the string is a valid host name. Checks the length and content.
 | IsValidHostNameChar(Char) | Determines if the character is valid for a host name.
 | IsValidHostNameChar(Char, Boolean) | Determines if the character is valid for a host name.
 | IsValidIPAddressChar | Determines if the character is valid for an IP address.
 | IsValidSensorName | Determines if the string is a valid sensor name. Checks the length and content.
 | IsValidSensorNameChar | Determines if the character is valid for a sensor name.
 | IsValidSubnetIPAddress(String) | Determines if the string is a valid Subnet IP address.
 | IsValidSubnetIPAddress(IPAddress, IPAddress, String%) | Determines if the string is a valid Subnet IP address.
Public method | Matches | Tests whether obj is a CvsHost with the same contents of this instance by comparing the names.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the name of the host. (Overrides Object..::..ToString()()()().)

See Also

CvsHost Class
Cognex.InSight.Sensor Namespace


CvsHost.IsValidHostIPAddress Method

[image] [image]

In-Sight SDK
CvsHost..::..IsValidHostIPAddress Method
CvsHost Class See Also Send Feedback

Overload List

Name | Description
IsValidHostIPAddress(String) | Determines if the string is a valid IP address.
IsValidHostIPAddress(IPAddress, IPAddress, String%) | Determines if the host IP Address is valid.

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost.IsValidHostIPAddress Method (String)

[image]

In-Sight SDK
CvsHost..::..IsValidHostIPAddress Method (String)
CvsHost Class See Also Send Feedback
Determines if the string is a valid IP address.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsValidHostIPAddress(
    string address
)
Visual Basic
Public Shared Function IsValidHostIPAddress (
    address As String
) As Boolean

Parameters

address
Type: System..::..String
The IP address string.

Return Value

Type: Boolean
true if ipAddr is a valid IP address; otherwise, false.

Remarks

Valid range is {1, 223}.{0, 255}.{0, 255}.{1, 255}. An empty string is also considered a valid address. When empty string is used, the sensor is accessed via its name.

Visual Basic 6 users should use the helper method IsValidHostIPAddress(String).

See Also

CvsHost Class
CvsHost..::..CvsHost Members
IsValidHostIPAddress Overload
Cognex.InSight.Sensor Namespace


CvsHost.IsValidHostIPAddress Method (IPAddress, IPAddress, String)

[image]

In-Sight SDK
CvsHost..::..IsValidHostIPAddress Method (IPAddress, IPAddress, String%)
CvsHost Class See Also Send Feedback
Determines if the host IP Address is valid.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsValidHostIPAddress(
    IPAddress address,
    IPAddress subnetMask,
    out string error
)
Visual Basic
Public Shared Function IsValidHostIPAddress (
    address As IPAddress,
    subnetMask As IPAddress,
    <OutAttribute> ByRef error As String
) As Boolean

Parameters

address
Type: System.Net..::..IPAddress
The IP address.
subnetMask
Type: System.Net..::..IPAddress
The current subnet mask setting, or null if unknown.
error
Type: System..::..String %
The error string explaining what is wrong with the IP Address.

Return Value

Type: Boolean
true if ipAddr is a valid IP address; otherwise, false.

Remarks

Valid range is {1, 223}.{0, 255}.{0, 255}.{0, 255}.

Visual Basic 6 users should use the helper method IsValidHostIPAddress(String).

See Also

CvsHost Class
CvsHost..::..CvsHost Members
IsValidHostIPAddress Overload
Cognex.InSight.Sensor Namespace


CvsHost.IsValidHostName Method

[image]

In-Sight SDK
CvsHost..::..IsValidHostName Method
CvsHost Class See Also Send Feedback
Determines if the string is a valid host name. Checks the length and content.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsValidHostName(
    string s,
    bool allowZeroLength
)
Visual Basic
Public Shared Function IsValidHostName (
    s As String,
    allowZeroLength As Boolean
) As Boolean

Parameters

s
Type: System..::..String
The host name string.
allowZeroLength
Type: System..::..Boolean
If true, a zero length string is valid.

Return Value

Type: Boolean
true if s is a valid host name; otherwise, false.

Remarks

Valid characters are those returned from IsValidHostNameChar(Char).

Visual Basic 6 users should use the helper method IsValidHostName(String, Boolean).

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost.IsValidHostNameChar Method

[image] [image]

In-Sight SDK
CvsHost..::..IsValidHostNameChar Method
CvsHost Class See Also Send Feedback

Overload List

Name | Description
IsValidHostNameChar(Char) | Determines if the character is valid for a host name.
IsValidHostNameChar(Char, Boolean) | Determines if the character is valid for a host name.

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost.IsValidHostNameChar Method (Char)

[image]

In-Sight SDK
CvsHost..::..IsValidHostNameChar Method (Char)
CvsHost Class See Also Send Feedback
Determines if the character is valid for a host name.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsValidHostNameChar(
    char c
)
Visual Basic
Public Shared Function IsValidHostNameChar (
    c As Char
) As Boolean

Parameters

c
Type: System..::..Char
The character to validate.

Return Value

Type: Boolean
true if the character is valid; otherwise, false.

Remarks

Valid characters include letters, numeric digits, '_', '-', '.', or ':'.

Visual Basic 6 users should use the helper method IsValidHostNameChar(String).

See Also

CvsHost Class
CvsHost..::..CvsHost Members
IsValidHostNameChar Overload
Cognex.InSight.Sensor Namespace


CvsHost.IsValidHostNameChar Method (Char, Boolean)

[image]

In-Sight SDK
CvsHost..::..IsValidHostNameChar Method (Char, Boolean)
CvsHost Class See Also Send Feedback
Determines if the character is valid for a host name.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsValidHostNameChar(
    char c,
    bool allowColon
)
Visual Basic
Public Shared Function IsValidHostNameChar (
    c As Char,
    allowColon As Boolean
) As Boolean

Parameters

c
Type: System..::..Char
The character to validate.
allowColon
Type: System..::..Boolean
If true, allow a colon in the host name.

Return Value

Type: Boolean
true if the character is valid; otherwise, false.

Remarks

Valid characters include letters, numeric digits, '_', '-', '.', or ':'.

Visual Basic 6 users should use the helper method IsValidHostNameChar(String).

See Also

CvsHost Class
CvsHost..::..CvsHost Members
IsValidHostNameChar Overload
Cognex.InSight.Sensor Namespace


CvsHost.IsValidIPAddressChar Method

[image]

In-Sight SDK
CvsHost..::..IsValidIPAddressChar Method
CvsHost Class See Also Send Feedback
Determines if the character is valid for an IP address.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsValidIPAddressChar(
    char c
)
Visual Basic
Public Shared Function IsValidIPAddressChar (
    c As Char
) As Boolean

Parameters

c
Type: System..::..Char
The character to validate.

Return Value

Type: Boolean
true if the character is valid; otherwise, false.

Remarks

Valid characters include numeric digits or '.'.

Visual Basic 6 users should use the helper method IsValidIPAddressChar(String).

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost.IsValidSensorName Method

[image]

In-Sight SDK
CvsHost..::..IsValidSensorName Method
CvsHost Class See Also Send Feedback
Determines if the string is a valid sensor name. Checks the length and content.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsValidSensorName(
    string s,
    bool allowZeroLength
)
Visual Basic
Public Shared Function IsValidSensorName (
    s As String,
    allowZeroLength As Boolean
) As Boolean

Parameters

s
Type: System..::..String
The sensor name string.
allowZeroLength
Type: System..::..Boolean
If true, a zero length string is valid.

Return Value

Type: Boolean
true if s is a valid sensor name; otherwise, false.

Remarks

Valid characters are those returned from IsValidSensorNameChar(Char).

Visual Basic 6 users should use the helper method IsValidSensorName(String, Boolean).

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost.IsValidSensorNameChar Method

[image]

In-Sight SDK
CvsHost..::..IsValidSensorNameChar Method
CvsHost Class See Also Send Feedback
Determines if the character is valid for a sensor name.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsValidSensorNameChar(
    char c
)
Visual Basic
Public Shared Function IsValidSensorNameChar (
    c As Char
) As Boolean

Parameters

c
Type: System..::..Char
The character to validate.

Return Value

Type: Boolean
true if the character is valid; otherwise, false.

Remarks

Valid characters include English letters, numeric digits, '_', '-', '.', or ':'.

Visual Basic 6 users should use the helper method IsValidSensorNameChar(String).

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost.IsValidSubnetIPAddress Method

[image] [image]

In-Sight SDK
CvsHost..::..IsValidSubnetIPAddress Method
CvsHost Class See Also Send Feedback

Overload List

Name | Description
IsValidSubnetIPAddress(String) | Determines if the string is a valid Subnet IP address.
IsValidSubnetIPAddress(IPAddress, IPAddress, String%) | Determines if the string is a valid Subnet IP address.

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost.IsValidSubnetIPAddress Method (String)

[image]

In-Sight SDK
CvsHost..::..IsValidSubnetIPAddress Method (String)
CvsHost Class See Also Send Feedback
Determines if the string is a valid Subnet IP address.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsValidSubnetIPAddress(
    string subnet
)
Visual Basic
Public Shared Function IsValidSubnetIPAddress (
    subnet As String
) As Boolean

Parameters

subnet
Type: System..::..String
The IP address string.

Return Value

Type: Boolean
true if ipAddr is a valid Subnet IP address; otherwise, false.

Remarks

Valid range is {0, 255}.{0, 255}.{0, 255}.{0, 255}. An empty string is also considered a valid address.

Visual Basic 6 users should use the helper method IsValidSubnetIPAddress(String).

See Also

CvsHost Class
CvsHost..::..CvsHost Members
IsValidSubnetIPAddress Overload
Cognex.InSight.Sensor Namespace


CvsHost.IsValidSubnetIPAddress Method (IPAddress, IPAddress, String)

[image]

In-Sight SDK
CvsHost..::..IsValidSubnetIPAddress Method (IPAddress, IPAddress, String%)
CvsHost Class See Also Send Feedback
Determines if the string is a valid Subnet IP address.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsValidSubnetIPAddress(
    IPAddress subnet,
    IPAddress ip,
    out string error
)
Visual Basic
Public Shared Function IsValidSubnetIPAddress (
    subnet As IPAddress,
    ip As IPAddress,
    <OutAttribute> ByRef error As String
) As Boolean

Parameters

subnet
Type: System.Net..::..IPAddress
The subnet string.
ip
Type: System.Net..::..IPAddress
The current IP Address value if known.
error
Type: System..::..String %
The error string explaining what is wrong with the subnet mask.

Return Value

Type: Boolean
true if ipAddr is a valid Subnet IP address; otherwise, false.

Remarks

Valid range is {0, 255}.{0, 255}.{0, 255}.{0, 255}.

Visual Basic 6 users should use the helper method IsValidSubnetIPAddress(String).

See Also

CvsHost Class
CvsHost..::..CvsHost Members
IsValidSubnetIPAddress Overload
Cognex.InSight.Sensor Namespace


CvsHost.Matches Method

[image]

In-Sight SDK
CvsHost..::..Matches Method
CvsHost Class See Also Send Feedback
Tests whether obj is a CvsHost with the same contents of this instance by comparing the names.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public virtual bool Matches(
    CvsHost host
)
Visual Basic
Public Overridable Function Matches (
    host As CvsHost
) As Boolean

Parameters

host
Type: Cognex.InSight.Sensor..::..CvsHost
The CvsHost to test.

Return Value

Type: Boolean
This method returns true if obj has the same contents as this instance.

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost.ToString Method

[image]

In-Sight SDK
CvsHost..::..ToString Method
CvsHost Class See Also Send Feedback
Returns the name of the host.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
A string that represents the host.

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost Properties

[image] [image]

In-Sight SDK
CvsHost Properties
CvsHost Class See Also Send Feedback

The CvsHost type exposes the following members.

Properties

 | Name | Description
Public property | IPAddress | Gets the IP address for the host.
Public property | IPAddressString | Gets the IP address string for the host.
Public property | Name | Gets the name of the host.
Public property | Subtype | Gets the sensor subtype of the host.
Public property | Type | Gets the sensor type of the host.

See Also

CvsHost Class
Cognex.InSight.Sensor Namespace


CvsHost.IPAddress Property

[image]

In-Sight SDK
CvsHost..::..IPAddress Property
CvsHost Class See Also Send Feedback
Gets the IP address for the host.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress IPAddress { get; }
Visual Basic
Public ReadOnly Property IPAddress As IPAddress
    Get

Property Value

Type: IPAddress

Remarks

This property is only available in .NET applications. To obtain an an IP address for use in COM/ActiveX applications, use the IPAddressString property instead.

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost.IPAddressString Property

[image]

In-Sight SDK
CvsHost..::..IPAddressString Property
CvsHost Class See Also Send Feedback
Gets the IP address string for the host.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string IPAddressString { get; }
Visual Basic
Public ReadOnly Property IPAddressString As String
    Get

Property Value

Type: String
The IP address string or the empty string if IPAddress is null.

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost.Name Property

[image]

In-Sight SDK
CvsHost..::..Name Property
CvsHost Class See Also Send Feedback
Gets the name of the host.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost.Subtype Property

[image]

In-Sight SDK
CvsHost..::..Subtype Property
CvsHost Class See Also Send Feedback
Gets the sensor subtype of the host.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostSubtype Subtype { get; }
Visual Basic
Public ReadOnly Property Subtype As CvsHostSubtype
    Get

Property Value

Type: CvsHostSubtype

Remarks

The sensor subtype is a specific family (IS3400, IS5600, ISMicro, etc.)

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHost.Type Property

[image]

In-Sight SDK
CvsHost..::..Type Property
CvsHost Class See Also Send Feedback
Gets the sensor type of the host.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostType Type { get; }
Visual Basic
Public ReadOnly Property Type As CvsHostType
    Get

Property Value

Type: CvsHostType

Remarks

The sensor type may either be an In-Sight sensor or a CvsInSightServer.

See Also

CvsHost Class
CvsHost..::..CvsHost Members
Cognex.InSight.Sensor Namespace


CvsHostSubtype Enumeration

[image]

In-Sight SDK
CvsHostSubtype Enumeration
See Also Send Feedback
Defines the available subtypes of sensors that can be connected to.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[FlagsAttribute]
public enum CvsHostSubtype
Visual Basic
<FlagsAttribute>
Public Enumeration CvsHostSubtype

Members

Member name | Value | Description
Unknown | 0 | Any Device
InSightGeneric | 256 | Any In-Sight
InSight5000Series | 257 | In-Sight 5000 series
InSight3400 | 258 | In-Sight 3400
InSight1700SeriesWaferReader | 259 | In-Sight Wafer Reader
InSightMicroSeries | 260 | In-Sight Micro
InSightEZSeries | 261 | In-Sight EZ series
InSightAdvantageEngineSeries | 262 | In-Sight Advantage Engine series
InSightMicro1000LR | 263 | In-Sight Micro 1000LR
InSight500Series | 264 | In-Sight 500 series
InSightHummingBird | 264 | (Legacy name for InSight500)
InSight7000Series | 265 | In-Sight7000 series
InSightReserved1 | 266 | Reserved.
InSightReserved2 | 267 | Reserved.
InSightABBSeries | 268 | In-Sight ABB series
InSightEZ700Series | 269 | In-Sight EZ 700 Series
InSightMotoSightSeries | 271 | MotoSight series
InSight8000Series | 274 | In-Sight 8000 series.
InSight2000Series | 275 | In-Sight 2000 series
InSight7000G2Series | 276 | In-Sight 7000 G2 series
InSight9000Series | 277 | In-Sight 9000 series (includes 9602L and 9902L)
InSightVS20Series | 278 | In-Sight VS20 series
InSightVS70Series | 279 | In-Sight VS70 series
InSightVS80Series | 280 | In-Sight VS80 series
InSightGss2000 | 281 | In-Sight GSS Align2000 series
InSightGss8000 | 282 | In-Sight GSS Align8000 series
InSight8500Series | 283 | In-Sight MicroZ series (8000 GS)
InSightEmulatorGeneric | 512 | Any In-Sight Emulator
InSightEmulatorPcHost | 513 | The In-Sight Emulator
VisionViewGeneric | 768 | Any VisionView
VisionView700 | 769 | VisionView 700
VisionViewVGA | 770 | VisionView VGA Adapter
VisionViewPC | 771 | VisionView PC
VisionView700A | 772 | VisionView 700A
VisionViewCE | 784 | VisionView Windows CE

See Also

Cognex.InSight.Sensor Namespace


CvsHostTableCollection Class

[image]

In-Sight SDK
CvsHostTableCollection Class
Members See Also Send Feedback
Holds the collection of In-Sight sensors that may be available on the network.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsHostTableCollection : IEnumerable,
    ICloneable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsHostTableCollection
    Implements IEnumerable, ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsHostTableCollection

See Also

CvsHostTableCollection..::..CvsHostTableCollection Members
Cognex.InSight.Sensor Namespace
Cognex.InSight.Sensor..::..CvsHost
Cognex.InSight.Sensor..::..CvsHostTableEntry


CvsHostTableCollection Members

[image] [image]

In-Sight SDK
CvsHostTableCollection Members
CvsHostTableCollection Class Constructors Methods Fields Properties See Also Send Feedback

The CvsHostTableCollection type exposes the following members.

Constructors

 | Name | Description
Public method | CvsHostTableCollection | Initializes a new instance of the CvsHostTableCollection class.

Methods

 | Name | Description
Public method | Clear | Removes all of the hosts from the collection.
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsHostTableCollection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Remove | Removes a host from the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
MaxHostTableEntries | The maximum number of entries in the HostTableCollection that may be sent to the In-sight.
MaxNameLength | The maximum length for the Name of a host in the HostTableCollection that may be sent to the In-sight.

Properties

 | Name | Description
Public property | Count | Gets the number of host items in the collection.
Public property | Item[([( Int32])]) | Gets the CvsHost object at the specified zero-based index.
Public property | Item[([( String])]) | Gets the CvsHostTableEntry object for the specified name.

See Also

CvsHostTableCollection Class
Cognex.InSight.Sensor Namespace


CvsHostTableCollection Constructor

[image]

In-Sight SDK
CvsHostTableCollection Constructor
CvsHostTableCollection Class See Also Send Feedback
Initializes a new instance of the CvsHostTableCollection class.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostTableCollection()
Visual Basic
Public Sub New

See Also

CvsHostTableCollection Class
CvsHostTableCollection..::..CvsHostTableCollection Members
Cognex.InSight.Sensor Namespace
Cognex.InSight.Sensor..::..CvsHost
Cognex.InSight.Sensor..::..CvsHostTableEntry


CvsHostTableCollection Fields

[image] [image]

In-Sight SDK
CvsHostTableCollection Fields
CvsHostTableCollection Class See Also Send Feedback

The CvsHostTableCollection type exposes the following members.

Fields

Name | Description
MaxHostTableEntries | The maximum number of entries in the HostTableCollection that may be sent to the In-sight.
MaxNameLength | The maximum length for the Name of a host in the HostTableCollection that may be sent to the In-sight.

See Also

CvsHostTableCollection Class
Cognex.InSight.Sensor Namespace


CvsHostTableCollection.MaxHostTableEntries Field

[image]

In-Sight SDK
CvsHostTableCollection..::..MaxHostTableEntries Field
CvsHostTableCollection Class See Also Send Feedback
The maximum number of entries in the HostTableCollection that may be sent to the In-sight.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxHostTableEntries
Visual Basic
Public Const MaxHostTableEntries As Integer

Field Value

Type: Int32

See Also

CvsHostTableCollection Class
CvsHostTableCollection..::..CvsHostTableCollection Members
Cognex.InSight.Sensor Namespace


CvsHostTableCollection.MaxNameLength Field

[image]

In-Sight SDK
CvsHostTableCollection..::..MaxNameLength Field
CvsHostTableCollection Class See Also Send Feedback
The maximum length for the Name of a host in the HostTableCollection that may be sent to the In-sight.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxNameLength
Visual Basic
Public Const MaxNameLength As Integer

Field Value

Type: Int32

See Also

CvsHostTableCollection Class
CvsHostTableCollection..::..CvsHostTableCollection Members
Cognex.InSight.Sensor Namespace


CvsHostTableCollection Methods

[image] [image]

In-Sight SDK
CvsHostTableCollection Methods
CvsHostTableCollection Class See Also Send Feedback

The CvsHostTableCollection type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes all of the hosts from the collection.
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsHostTableCollection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Remove | Removes a host from the collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsHostTableCollection Class
Cognex.InSight.Sensor Namespace


CvsHostTableCollection.Clear Method

[image]

In-Sight SDK
CvsHostTableCollection..::..Clear Method
CvsHostTableCollection Class See Also Send Feedback
Removes all of the hosts from the collection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

CvsHostTableCollection Class
CvsHostTableCollection..::..CvsHostTableCollection Members
Cognex.InSight.Sensor Namespace


CvsHostTableCollection.Clone Method

[image]

In-Sight SDK
CvsHostTableCollection..::..Clone Method
CvsHostTableCollection Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsHostTableCollection Class
CvsHostTableCollection..::..CvsHostTableCollection Members
Cognex.InSight.Sensor Namespace


CvsHostTableCollection.GetEnumerator Method

[image]

In-Sight SDK
CvsHostTableCollection..::..GetEnumerator Method
CvsHostTableCollection Class See Also Send Feedback
Returns an IEnumerator that can iterate through the CvsHostTableCollection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CvsHostTableCollection Class
CvsHostTableCollection..::..CvsHostTableCollection Members
Cognex.InSight.Sensor Namespace


CvsHostTableCollection.Remove Method

[image]

In-Sight SDK
CvsHostTableCollection..::..Remove Method
CvsHostTableCollection Class See Also Send Feedback
Removes a host from the collection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Remove(
    CvsHost host
)
Visual Basic
Public Sub Remove (
    host As CvsHost
)

Parameters

host
Type: Cognex.InSight.Sensor..::..CvsHost
The host to be removed.

See Also

CvsHostTableCollection Class
CvsHostTableCollection..::..CvsHostTableCollection Members
Cognex.InSight.Sensor Namespace


CvsHostTableCollection Properties

[image] [image]

In-Sight SDK
CvsHostTableCollection Properties
CvsHostTableCollection Class See Also Send Feedback

The CvsHostTableCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of host items in the collection.
Public property | Item[([( Int32])]) | Gets the CvsHost object at the specified zero-based index.
Public property | Item[([( String])]) | Gets the CvsHostTableEntry object for the specified name.

See Also

CvsHostTableCollection Class
Cognex.InSight.Sensor Namespace


CvsHostTableCollection.Count Property

[image]

In-Sight SDK
CvsHostTableCollection..::..Count Property
CvsHostTableCollection Class See Also Send Feedback
Gets the number of host items in the collection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

CvsHostTableCollection Class
CvsHostTableCollection..::..CvsHostTableCollection Members
Cognex.InSight.Sensor Namespace


CvsHostTableCollection.Item Property

[image] [image]

In-Sight SDK
CvsHostTableCollection..::..Item Property
CvsHostTableCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets the CvsHost object at the specified zero-based index.
Public property | Item[([( String])]) | Gets the CvsHostTableEntry object for the specified name.

See Also

CvsHostTableCollection Class
CvsHostTableCollection..::..CvsHostTableCollection Members
Cognex.InSight.Sensor Namespace


CvsHostTableCollection.Item Property (Int32)

[image]

In-Sight SDK
CvsHostTableCollection..::..Item Property (Int32)
CvsHostTableCollection Class See Also Send Feedback
Gets the CvsHost object at the specified zero-based index.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHost this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As CvsHost
    Get

Parameters

index
Type: System..::..Int32
The zero-based index into the collection.

Property Value

Type: CvsHost

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsHostTableCollection Class
CvsHostTableCollection..::..CvsHostTableCollection Members
Item Overload
Cognex.InSight.Sensor Namespace
Cognex.InSight.Sensor..::..CvsHost
Cognex.InSight.Sensor..::..CvsHostTableEntry


CvsHostTableCollection.Item Property (String)

[image]

In-Sight SDK
CvsHostTableCollection..::..Item Property (String)
CvsHostTableCollection Class See Also Send Feedback
Gets the CvsHostTableEntry object for the specified name.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostTableEntry this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    name As String
) As CvsHostTableEntry
    Get

Parameters

name
Type: System..::..String
The name of the entry (not case-sensitive).

Property Value

Type: CvsHostTableEntry
Returns a CvsHostTableEntry if its name is found in the collection, returns null otherwise.

See Also

CvsHostTableCollection Class
CvsHostTableCollection..::..CvsHostTableCollection Members
Item Overload
Cognex.InSight.Sensor Namespace


CvsHostTableEntry Class

[image]

In-Sight SDK
CvsHostTableEntry Class
Members See Also Send Feedback
Holds the network address and name of an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsHostTableEntry : CvsHost,
    ICloneable
Visual Basic
<SerializableAttribute>
Public Class CvsHostTableEntry
    Inherits CvsHost
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsHost
Cognex.InSight.Sensor..::..CvsHostTableEntry

See Also

CvsHostTableEntry..::..CvsHostTableEntry Members
Cognex.InSight.Sensor Namespace


CvsHostTableEntry Members

[image] [image]

In-Sight SDK
CvsHostTableEntry Members
CvsHostTableEntry Class Constructors Methods Properties See Also Send Feedback

The CvsHostTableEntry type exposes the following members.

Constructors

 | Name | Description
Public method | CvsHostTableEntry()()()() | Initializes a new instance of the CvsHostTableEntry class.
Public method | CvsHostTableEntry(String, IPAddress) | Initializes a new instance of the CvsHostTableEntry class.
Public method | CvsHostTableEntry(String, IPAddress, CvsHostType) | Initializes a new instance of the CvsHostTableEntry class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Tests whether obj is a CvsHost with the same contents of this instance by comparing the names. (Inherited from CvsHost.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetIPAddress | Sets the IPAddress and IPAddressString for the host given a new IPAddress object.
Public method | SetIPAddressString | Sets the IPAddress and IPAddressString for the host given a new IP address as a string.
Public method | SetName | Sets the Name of the host.
Public method | ToString | Returns the name of the host. (Inherited from CvsHost.)

Properties

 | Name | Description
Public property | IPAddress | Gets the IP address for the host. (Inherited from CvsHost.)
Public property | IPAddressString | Gets the IP address string for the host. (Inherited from CvsHost.)
Public property | Name | Gets the name of the host. (Inherited from CvsHost.)
Public property | Subtype | Gets the sensor subtype of the host. (Inherited from CvsHost.)
Public property | Type | Gets the sensor type of the host. (Inherited from CvsHost.)

See Also

CvsHostTableEntry Class
Cognex.InSight.Sensor Namespace


CvsHostTableEntry Constructor

[image] [image]

In-Sight SDK
CvsHostTableEntry Constructor
CvsHostTableEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsHostTableEntry()()()() | Initializes a new instance of the CvsHostTableEntry class.
Public method | CvsHostTableEntry(String, IPAddress) | Initializes a new instance of the CvsHostTableEntry class.
Public method | CvsHostTableEntry(String, IPAddress, CvsHostType) | Initializes a new instance of the CvsHostTableEntry class.

See Also

CvsHostTableEntry Class
CvsHostTableEntry..::..CvsHostTableEntry Members
Cognex.InSight.Sensor Namespace


CvsHostTableEntry Constructor

[image]

In-Sight SDK
CvsHostTableEntry Constructor
CvsHostTableEntry Class See Also Send Feedback
Initializes a new instance of the CvsHostTableEntry class.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostTableEntry()
Visual Basic
Public Sub New

See Also

CvsHostTableEntry Class
CvsHostTableEntry..::..CvsHostTableEntry Members
CvsHostTableEntry Overload
Cognex.InSight.Sensor Namespace


CvsHostTableEntry Constructor (String, IPAddress)

[image]

In-Sight SDK
CvsHostTableEntry Constructor (String, IPAddress)
CvsHostTableEntry Class See Also Send Feedback
Initializes a new instance of the CvsHostTableEntry class.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostTableEntry(
    string name,
    IPAddress address
)
Visual Basic
Public Sub New (
    name As String,
    address As IPAddress
)

Parameters

name
Type: System..::..String
The name of the host.
address
Type: System.Net..::..IPAddress
The IP address of the host.

See Also

CvsHostTableEntry Class
CvsHostTableEntry..::..CvsHostTableEntry Members
CvsHostTableEntry Overload
Cognex.InSight.Sensor Namespace


CvsHostTableEntry Constructor (String, IPAddress, CvsHostType)

[image]

In-Sight SDK
CvsHostTableEntry Constructor (String, IPAddress, CvsHostType)
CvsHostTableEntry Class See Also Send Feedback
Initializes a new instance of the CvsHostTableEntry class.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostTableEntry(
    string name,
    IPAddress address,
    CvsHostType type
)
Visual Basic
Public Sub New (
    name As String,
    address As IPAddress,
    type As CvsHostType
)

Parameters

name
Type: System..::..String
The name of the host.
address
Type: System.Net..::..IPAddress
The IP address of the host.
type
Type: Cognex.InSight.Sensor..::..CvsHostType
The type of sensor.

Remarks

This constructor allows a specific type of host to be added to the table.

See Also

CvsHostTableEntry Class
CvsHostTableEntry..::..CvsHostTableEntry Members
CvsHostTableEntry Overload
Cognex.InSight.Sensor Namespace


CvsHostTableEntry Methods

[image] [image]

In-Sight SDK
CvsHostTableEntry Methods
CvsHostTableEntry Class See Also Send Feedback

The CvsHostTableEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Tests whether obj is a CvsHost with the same contents of this instance by comparing the names. (Inherited from CvsHost.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetIPAddress | Sets the IPAddress and IPAddressString for the host given a new IPAddress object.
Public method | SetIPAddressString | Sets the IPAddress and IPAddressString for the host given a new IP address as a string.
Public method | SetName | Sets the Name of the host.
Public method | ToString | Returns the name of the host. (Inherited from CvsHost.)

See Also

CvsHostTableEntry Class
Cognex.InSight.Sensor Namespace


CvsHostTableEntry.SetIPAddress Method

[image]

In-Sight SDK
CvsHostTableEntry..::..SetIPAddress Method
CvsHostTableEntry Class See Also Send Feedback
Sets the IPAddress and IPAddressString for the host given a new IPAddress object.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetIPAddress(
    IPAddress ipAddress
)
Visual Basic
Public Sub SetIPAddress (
    ipAddress As IPAddress
)

Parameters

ipAddress
Type: System.Net..::..IPAddress
The IP address for the host.

Remarks

The ipAddress specified must be a valid IP address. This may be verified with IsValidHostIPAddress(String). The empty address, "", is permitted.

This method is only available in .NET applications. To set an an IP address for use in COM/ActiveX applications, use the SetIPAddressString(String) property instead.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | ipAddress is not valid for a host table entry.

See Also

CvsHostTableEntry Class
CvsHostTableEntry..::..CvsHostTableEntry Members
Cognex.InSight.Sensor Namespace


CvsHostTableEntry.SetIPAddressString Method

[image]

In-Sight SDK
CvsHostTableEntry..::..SetIPAddressString Method
CvsHostTableEntry Class See Also Send Feedback
Sets the IPAddress and IPAddressString for the host given a new IP address as a string.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetIPAddressString(
    string ipAddress
)
Visual Basic
Public Sub SetIPAddressString (
    ipAddress As String
)

Parameters

ipAddress
Type: System..::..String
The IP address for the host.

Remarks

The ipAddress specified must be a valid IP address. This may be verified with IsValidHostIPAddress(String). The empty address, "", is permitted.

Exceptions

Exception | Condition
System..::..FormatException | ipAddress is not a valid IP address.
System..::..ArgumentOutOfRangeException | ipAddress is not valid for a host table entry.

See Also

CvsHostTableEntry Class
CvsHostTableEntry..::..CvsHostTableEntry Members
Cognex.InSight.Sensor Namespace


CvsHostTableEntry.SetName Method

[image]

In-Sight SDK
CvsHostTableEntry..::..SetName Method
CvsHostTableEntry Class See Also Send Feedback
Sets the Name of the host.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetName(
    string name
)
Visual Basic
Public Sub SetName (
    name As String
)

Parameters

name
Type: System..::..String
The name of the host.

Remarks

The name specified must be a valid host name. This may be verified with IsValidHostName(String, Boolean). A zero-length name is permitted.

Exceptions

Exception | Condition
System..::..ArgumentNullException | name is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | name is an invalid host name.

See Also

CvsHostTableEntry Class
CvsHostTableEntry..::..CvsHostTableEntry Members
Cognex.InSight.Sensor Namespace


CvsHostTableEntry Properties

[image] [image]

In-Sight SDK
CvsHostTableEntry Properties
CvsHostTableEntry Class See Also Send Feedback

The CvsHostTableEntry type exposes the following members.

Properties

 | Name | Description
Public property | IPAddress | Gets the IP address for the host. (Inherited from CvsHost.)
Public property | IPAddressString | Gets the IP address string for the host. (Inherited from CvsHost.)
Public property | Name | Gets the name of the host. (Inherited from CvsHost.)
Public property | Subtype | Gets the sensor subtype of the host. (Inherited from CvsHost.)
Public property | Type | Gets the sensor type of the host. (Inherited from CvsHost.)

See Also

CvsHostTableEntry Class
Cognex.InSight.Sensor Namespace


CvsHostType Enumeration

[image]

In-Sight SDK
CvsHostType Enumeration
See Also Send Feedback
Defines the available types of sensors that can be connected to.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsHostType
Visual Basic
Public Enumeration CvsHostType

Members

Member name | Value | Description
Server | 0 | Specifies a server and not a direct connection to an In-Sight sensor.
Unknown | 1 | The type of the In-Sight sensor is unknown.
HostTableEntry | 2 | Specifies a Host Table entry.
InSightEmulator | 3 | Specifies the emulator.
InSightSensor | 4 | Specifies a hardware In-Sight sensor.
Browser | 5 | Specifies a network browser (like a VisionView Terminal)
PC | 3 | Obsolete. Deprecated. InSightEmulator should be used instead

See Also

Cognex.InSight.Sensor Namespace


CvsHostVersion Class

[image]

In-Sight SDK
CvsHostVersion Class
Members See Also Send Feedback
Holds information about the version of firmware loaded on an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsHostVersion : IComparable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsHostVersion
    Implements IComparable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsHostVersion

See Also

CvsHostVersion..::..CvsHostVersion Members
Cognex.InSight.Sensor Namespace


CvsHostVersion Members

[image] [image]

In-Sight SDK
CvsHostVersion Members
CvsHostVersion Class Methods Operators Properties See Also Send Feedback

The CvsHostVersion type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type.
Public method | CompareTo(Int32, Int32, Int32) | Compares the current instance to the specified version number
Public method | CompareTo(Int32, Int32, Int32, Int32, Int32) | Compares the current instance to the specified version number
Public method | Equals | Determines whether this instance of CvsHostVersion and a specified object, which must be a CvsHostVersion, have the same value. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Parse | Parses a string into a CvsHostVersion object.
Public method | ToString | Gets the firmware version of the In-Sight sensor. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether two specified instances of CvsHostVersion are equal.
Inequality | Determines whether two specified instances of CvsHostVersion are not equal.

Properties

 | Name | Description
Public property | BuildNumber | Gets the build number of the host firmware.
Public property | Major | Gets the major firmware version number of the host.
Public property | Minor | Gets the minor firmware version number of the host.
Public property | ReleaseType | Gets the beta/release status of the host firmware.
Public property | Revision | Gets the revision firmware version number of the host.

See Also

CvsHostVersion Class
Cognex.InSight.Sensor Namespace


CvsHostVersion Methods

[image] [image]

In-Sight SDK
CvsHostVersion Methods
CvsHostVersion Class See Also Send Feedback

The CvsHostVersion type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type.
Public method | CompareTo(Int32, Int32, Int32) | Compares the current instance to the specified version number
Public method | CompareTo(Int32, Int32, Int32, Int32, Int32) | Compares the current instance to the specified version number
Public method | Equals | Determines whether this instance of CvsHostVersion and a specified object, which must be a CvsHostVersion, have the same value. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Parse | Parses a string into a CvsHostVersion object.
Public method | ToString | Gets the firmware version of the In-Sight sensor. (Overrides Object..::..ToString()()()().)

See Also

CvsHostVersion Class
Cognex.InSight.Sensor Namespace


CvsHostVersion.CompareTo Method

[image] [image]

In-Sight SDK
CvsHostVersion..::..CompareTo Method
CvsHostVersion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type.
Public method | CompareTo(Int32, Int32, Int32) | Compares the current instance to the specified version number
Public method | CompareTo(Int32, Int32, Int32, Int32, Int32) | Compares the current instance to the specified version number

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
Cognex.InSight.Sensor Namespace


CvsHostVersion.CompareTo Method (Object)

[image]

In-Sight SDK
CvsHostVersion..::..CompareTo Method (Object)
CvsHostVersion Class See Also Send Feedback
Compares the current instance with another object of the same type.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo (
    obj As Object
) As Integer

Parameters

obj
Type: System..::..Object
An object to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer indicating the lexical relationship between the two comparands.
ValueConditionLess than zeroThis instance is less than value.ZeroThis instance is equal to value.Greater than zeroThis instance is greater than value. -or-value is a null reference (Nothing in Visual Basic).

Implements

IComparable..::..CompareTo(Object)

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
CompareTo Overload
Cognex.InSight.Sensor Namespace


CvsHostVersion.CompareTo Method (Int32, Int32, Int32)

[image]

In-Sight SDK
CvsHostVersion..::..CompareTo Method (Int32, Int32, Int32)
CvsHostVersion Class See Also Send Feedback
Compares the current instance to the specified version number

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int CompareTo(
    int major,
    int minor,
    int revision
)
Visual Basic
Public Function CompareTo (
    major As Integer,
    minor As Integer,
    revision As Integer
) As Integer

Parameters

major
Type: System..::..Int32
The major version number
minor
Type: System..::..Int32
The minor version number
revision
Type: System..::..Int32
The revision number

Return Value

Type: Int32
A 32-bit signed integer indicating the lexical relationship between the two comparands.
ValueConditionLess than zeroThis instance is less than value.ZeroThis instance is equal to value.Greater than zeroThis instance is greater than value.

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
CompareTo Overload
Cognex.InSight.Sensor Namespace


CvsHostVersion.CompareTo Method (Int32, Int32, Int32, Int32, Int32)

[image]

In-Sight SDK
CvsHostVersion..::..CompareTo Method (Int32, Int32, Int32, Int32, Int32)
CvsHostVersion Class See Also Send Feedback
Compares the current instance to the specified version number

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int CompareTo(
    int major,
    int minor,
    int revision,
    int releaseType,
    int buildNumber
)
Visual Basic
Public Function CompareTo (
    major As Integer,
    minor As Integer,
    revision As Integer,
    releaseType As Integer,
    buildNumber As Integer
) As Integer

Parameters

major
Type: System..::..Int32
The major version number
minor
Type: System..::..Int32
The minor version number
revision
Type: System..::..Int32
The revision number
releaseType
Type: System..::..Int32
The beta/release type
buildNumber
Type: System..::..Int32
The build number

Return Value

Type: Int32
A 32-bit signed integer indicating the lexical relationship between the two comparands.
ValueConditionLess than zeroThis instance is less than value.ZeroThis instance is equal to value.Greater than zeroThis instance is greater than value.

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
CompareTo Overload
Cognex.InSight.Sensor Namespace


CvsHostVersion.Equals Method

[image]

In-Sight SDK
CvsHostVersion..::..Equals Method
CvsHostVersion Class See Also Send Feedback
Determines whether this instance of CvsHostVersion and a specified object, which must be a CvsHostVersion, have the same value.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: System..::..Object
A Object.

Return Value

Type: Boolean
true if obj is a CvsHostVersion and its value is the same as this instance; otherwise, false.

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
Cognex.InSight.Sensor Namespace


CvsHostVersion.GetHashCode Method

[image]

In-Sight SDK
CvsHostVersion..::..GetHashCode Method
CvsHostVersion Class See Also Send Feedback
Returns the hash code for this instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A 32-bit signed integer that is the hash code for this instance.

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
Cognex.InSight.Sensor Namespace


CvsHostVersion.Parse Method

[image]

In-Sight SDK
CvsHostVersion..::..Parse Method
CvsHostVersion Class See Also Send Feedback
Parses a string into a CvsHostVersion object.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static CvsHostVersion Parse(
    string text
)
Visual Basic
Public Shared Function Parse (
    text As String
) As CvsHostVersion

Parameters

text
Type: System..::..String
A version string formatted as: Major.Minor.Revision ReleaseType (BuildNumber)

Return Value

Type: CvsHostVersion
A new CvsHostVersion object.

Exceptions

Exception | Condition
System..::..ArgumentException | The string does not represent a valid version number.

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
Cognex.InSight.Sensor Namespace


CvsHostVersion.ToString Method

[image]

In-Sight SDK
CvsHostVersion..::..ToString Method
CvsHostVersion Class See Also Send Feedback
Gets the firmware version of the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
A string that represents the firmware version.

Remarks

The version is formatted: Major.Minor.Revision ReleaseType (BuildNumber)

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
Cognex.InSight.Sensor Namespace


CvsHostVersion Operators

[image] [image]

In-Sight SDK
CvsHostVersion Operators
CvsHostVersion Class See Also Send Feedback

The CvsHostVersion type exposes the following members.

Operators

Name | Description
Equality | Determines whether two specified instances of CvsHostVersion are equal.
Inequality | Determines whether two specified instances of CvsHostVersion are not equal.

See Also

CvsHostVersion Class
Cognex.InSight.Sensor Namespace


CvsHostVersion.Equality Operator

[image]

In-Sight SDK
CvsHostVersion..::..Equality Operator
CvsHostVersion Class See Also Send Feedback
Determines whether two specified instances of CvsHostVersion are equal.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool operator ==(
    CvsHostVersion v1,
    CvsHostVersion v2
)
Visual Basic
Public Shared Operator = (
    v1 As CvsHostVersion,
    v2 As CvsHostVersion
) As Boolean

Parameters

v1
Type: Cognex.InSight.Sensor..::..CvsHostVersion
The first instance of CvsHostVersion.
v2
Type: Cognex.InSight.Sensor..::..CvsHostVersion
The second instance of CvsHostVersion.

Return Value

Type: Boolean
true if v1 does equal v2; otherwise, false.

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
Cognex.InSight.Sensor Namespace


CvsHostVersion.Inequality Operator

[image]

In-Sight SDK
CvsHostVersion..::..Inequality Operator
CvsHostVersion Class See Also Send Feedback
Determines whether two specified instances of CvsHostVersion are not equal.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool operator !=(
    CvsHostVersion v1,
    CvsHostVersion v2
)
Visual Basic
Public Shared Operator <> (
    v1 As CvsHostVersion,
    v2 As CvsHostVersion
) As Boolean

Parameters

v1
Type: Cognex.InSight.Sensor..::..CvsHostVersion
The first instance of CvsHostVersion.
v2
Type: Cognex.InSight.Sensor..::..CvsHostVersion
The second instance of CvsHostVersion.

Return Value

Type: Boolean
true if v1 does not equal v2; otherwise, false.

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
Cognex.InSight.Sensor Namespace


CvsHostVersion Properties

[image] [image]

In-Sight SDK
CvsHostVersion Properties
CvsHostVersion Class See Also Send Feedback

The CvsHostVersion type exposes the following members.

Properties

 | Name | Description
Public property | BuildNumber | Gets the build number of the host firmware.
Public property | Major | Gets the major firmware version number of the host.
Public property | Minor | Gets the minor firmware version number of the host.
Public property | ReleaseType | Gets the beta/release status of the host firmware.
Public property | Revision | Gets the revision firmware version number of the host.

See Also

CvsHostVersion Class
Cognex.InSight.Sensor Namespace


CvsHostVersion.BuildNumber Property

[image]

In-Sight SDK
CvsHostVersion..::..BuildNumber Property
CvsHostVersion Class See Also Send Feedback
Gets the build number of the host firmware.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int BuildNumber { get; }
Visual Basic
Public ReadOnly Property BuildNumber As Integer
    Get

Property Value

Type: Int32

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
Cognex.InSight.Sensor Namespace


CvsHostVersion.Major Property

[image]

In-Sight SDK
CvsHostVersion..::..Major Property
CvsHostVersion Class See Also Send Feedback
Gets the major firmware version number of the host.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Major { get; }
Visual Basic
Public ReadOnly Property Major As Integer
    Get

Property Value

Type: Int32

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
Cognex.InSight.Sensor Namespace


CvsHostVersion.Minor Property

[image]

In-Sight SDK
CvsHostVersion..::..Minor Property
CvsHostVersion Class See Also Send Feedback
Gets the minor firmware version number of the host.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Minor { get; }
Visual Basic
Public ReadOnly Property Minor As Integer
    Get

Property Value

Type: Int32

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
Cognex.InSight.Sensor Namespace


CvsHostVersion.ReleaseType Property

[image]

In-Sight SDK
CvsHostVersion..::..ReleaseType Property
CvsHostVersion Class See Also Send Feedback
Gets the beta/release status of the host firmware.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string ReleaseType { get; }
Visual Basic
Public ReadOnly Property ReleaseType As String
    Get

Property Value

Type: String

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
Cognex.InSight.Sensor Namespace


CvsHostVersion.Revision Property

[image]

In-Sight SDK
CvsHostVersion..::..Revision Property
CvsHostVersion Class See Also Send Feedback
Gets the revision firmware version number of the host.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Revision { get; }
Visual Basic
Public ReadOnly Property Revision As Integer
    Get

Property Value

Type: Int32

See Also

CvsHostVersion Class
CvsHostVersion..::..CvsHostVersion Members
Cognex.InSight.Sensor Namespace


CvsImageResolution Enumeration

[image]

In-Sight SDK
CvsImageResolution Enumeration
See Also Send Feedback
Defines the resolution options for images sent from an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public enum CvsImageResolution
Visual Basic
<SerializableAttribute>
Public Enumeration CvsImageResolution

Members

Member name | Value | Description
Default | 0 | The default image resolution is used.
Full | 1 | Designates full resolution images.
Half | 2 | Designates half resolution images.
Quarter | 4 | Designates quarter resolution images.
Eighth | 8 | Designates eighth resolution images.

Remarks

The integer value of each member of this enumeration, except for Default, equals the factor by which the image is sub-sampled.

See Also

Cognex.InSight.Sensor Namespace
CvsSettings..::..LiveAcquisitionResolution
CvsSettings..::..OnlineImageResolution


CvsInputCollection Class

[image]

In-Sight SDK
CvsInputCollection Class
Members See Also Send Feedback
Represents a collection of ICvsDiscreteInputLine objects.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsInputCollection : CvsDiscreteLineCollection<ICvsDiscreteInputLine>
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsInputCollection
    Inherits CvsDiscreteLineCollection(Of ICvsDiscreteInputLine)

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsDiscreteLineCollection <(Of <(<' ICvsDiscreteInputLine >)>)>
Cognex.InSight.Sensor..::..CvsInputCollection

See Also

CvsInputCollection..::..CvsInputCollection Members
Cognex.InSight.Sensor Namespace


CvsInputCollection Members

[image] [image]

In-Sight SDK
CvsInputCollection Members
CvsInputCollection Class Constructors Methods Properties See Also Send Feedback

The CvsInputCollection type exposes the following members.

Constructors

 | Name | Description
Public method | CvsInputCollection | Initializes a new instance of the CvsInputCollection class

Methods

 | Name | Description
Public method | At | Gets the ICvsDiscreteLine object at the specified zero-based index. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsInputCollection. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSettings | Returns the settings for the specified line. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of lines in the collection. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public property | Item | Gets the ICvsDiscreteLine object at the specified zero-based index. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)

See Also

CvsInputCollection Class
Cognex.InSight.Sensor Namespace


CvsInputCollection Constructor

[image]

In-Sight SDK
CvsInputCollection Constructor
CvsInputCollection Class See Also Send Feedback
Initializes a new instance of the CvsInputCollection class

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsInputCollection()
Visual Basic
Public Sub New

See Also

CvsInputCollection Class
CvsInputCollection..::..CvsInputCollection Members
Cognex.InSight.Sensor Namespace


CvsInputCollection Methods

[image] [image]

In-Sight SDK
CvsInputCollection Methods
CvsInputCollection Class See Also Send Feedback

The CvsInputCollection type exposes the following members.

Methods

 | Name | Description
Public method | At | Gets the ICvsDiscreteLine object at the specified zero-based index. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsInputCollection. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSettings | Returns the settings for the specified line. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsInputCollection Class
Cognex.InSight.Sensor Namespace


CvsInputCollection Properties

[image] [image]

In-Sight SDK
CvsInputCollection Properties
CvsInputCollection Class See Also Send Feedback

The CvsInputCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of lines in the collection. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public property | Item | Gets the ICvsDiscreteLine object at the specified zero-based index. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)

See Also

CvsInputCollection Class
Cognex.InSight.Sensor Namespace


CvsInputSignal Enumeration

[image]

In-Sight SDK
CvsInputSignal Enumeration
See Also Send Feedback
Defines the trigger signal associated with the input line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsInputSignal
Visual Basic
Public Enumeration CvsInputSignal

Members

Member name | Value | Description
RisingEdge | 0 | Specifies a rising edge trigger.
FallingEdge | 1 | Specifies a falling edge trigger.
BothEdges | 2 | Specifies a trigger for both rising and falling edges (valid for Event Trigger only).

See Also

Cognex.InSight.Sensor Namespace


CvsInputType Enumeration

[image]

In-Sight SDK
CvsInputType Enumeration
See Also Send Feedback
Defines the type of operation performed by the input line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsInputType
Visual Basic
Public Enumeration CvsInputType

Members

Member name | Value | Description
UserData | 0 | Specifies a User Data input line.
EventTrigger | 1 | Specifies an Event Trigger input line.
JobIdNumber | 2 | Specifies a Job ID Number input line.
OnlineOffline | 3 | Specifies an Online/Offline input line.
AcquisitionTrigger | 4 | Specifies an Acqusition Trigger input line.
JobLoadSwitch | 5 | Specifies a Job Load Switch input line.
TrackingPulse | 6 | Specifies a Tracking Pulse input line.
Encoder | 7 | Specifies a encoder input line.
SerialRX | 8 | Specifies a serial input line.
PulseCountBasedJobChange | 9 | Specifies a pulse count based job change line.

See Also

Cognex.InSight.Sensor Namespace


CvsInSightFeatureFamily Enumeration

[image]

In-Sight SDK
CvsInSightFeatureFamily Enumeration
See Also Send Feedback
An enumeration of feature families that describes a sensor's capabilities.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsInSightFeatureFamily
Visual Basic
Public Enumeration CvsInSightFeatureFamily

Members

Member name | Value | Description
None | 0 | General purpose sensor.
LR | 1 | Limit functionality (e.g. 1000LR).
OcrOnly | 2 | An OCR-Only sensor.
Abb | 3 | An ABB sensor.
Is2000_110 | 4 | Limit functionality (e.g. IS2000-110).
Is2000_120 | 5 | Limit functionality (e.g. IS2000-120).
Is2000_130 | 6 | Limit functionality (e.g. IS2000-130).
Is2000_130PlusBlob | 7 | Limit functionality to (e.g. IS2000-130) and all Blob/Color blob functions (except the 1-10 functions). IS2000-139.
Gss | 8 | A GSS sensor.

See Also

Cognex.InSight.Sensor Namespace


CvsIOModule Enumeration

[image]

In-Sight SDK
CvsIOModule Enumeration
See Also Send Feedback
Defines the IO module types.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public enum CvsIOModule
Visual Basic
<SerializableAttribute>
Public Enumeration CvsIOModule

Members

Member name | Value | Description
CIO_Expansion | -2 | The expansion I/O. This setting is used with older firmware that does distinguish between the 1450 and the 1460.
CIO_None | -1 | No I/O module
CIO_Standard | 0 | The standard I/O
CIO_1450 | 1 | The 1450 I/O module
CIO_1460 | 2 | The 1460 I/O module
CIO_1400 | 3 | The 1400 I/O module
WAGO_750_341 | 4 | The WAGO 750-341 module
CIO_Micro | 5 | The CIO-Micro I/O module
CIO_Micro_CC | 6 | The CIO-Micro-CC I/O module

See Also

Cognex.InSight.Sensor Namespace


CvsJobServerSettings Class

[image]

In-Sight SDK
CvsJobServerSettings Class
Members See Also Send Feedback
Holds the job server settings for an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsJobServerSettings : ICloneable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsJobServerSettings
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsJobServerSettings

See Also

CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsJobServerSettings Members

[image] [image]

In-Sight SDK
CvsJobServerSettings Members
CvsJobServerSettings Class Methods Fields Properties See Also Send Feedback

The CvsJobServerSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | This method performs a shallow copy of the object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ToFtpPortRangeOrDefault | Restricts the integer to the allowed port range. Returns the default value (21) if it isn't.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
DefaultFtpPort | The default ftp port.
MaximumDirectoryLength | Maximum directory length.
MaximumHostnameLength | Maximum hostname length per RFC 1035.
MaximumPasswordLength | Maximum password length.
MaximumUsernameLength | Maximum username length.

Properties

 | Name | Description
Public property | Directory | Gets or sets the server directory.
Public property | Enabled | Gets or sets a value that determines if the job server is enabled for the InSight.
Public property | HostName | Gets or sets the host name or IP address of the server.
Public property | Password | Gets or sets the server login password.
Public property | Port | Gets or sets the FTP Port of the server.
Public property | Username | Gets or sets the server login username.

See Also

CvsJobServerSettings Class
Cognex.InSight.Sensor Namespace


CvsJobServerSettings Fields

[image] [image]

In-Sight SDK
CvsJobServerSettings Fields
CvsJobServerSettings Class See Also Send Feedback

The CvsJobServerSettings type exposes the following members.

Fields

Name | Description
DefaultFtpPort | The default ftp port.
MaximumDirectoryLength | Maximum directory length.
MaximumHostnameLength | Maximum hostname length per RFC 1035.
MaximumPasswordLength | Maximum password length.
MaximumUsernameLength | Maximum username length.

See Also

CvsJobServerSettings Class
Cognex.InSight.Sensor Namespace


CvsJobServerSettings.DefaultFtpPort Field

[image]

In-Sight SDK
CvsJobServerSettings..::..DefaultFtpPort Field
CvsJobServerSettings Class See Also Send Feedback
The default ftp port.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int DefaultFtpPort
Visual Basic
Public Const DefaultFtpPort As Integer

Field Value

Type: Int32

See Also

CvsJobServerSettings Class
CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsJobServerSettings.MaximumDirectoryLength Field

[image]

In-Sight SDK
CvsJobServerSettings..::..MaximumDirectoryLength Field
CvsJobServerSettings Class See Also Send Feedback
Maximum directory length.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaximumDirectoryLength
Visual Basic
Public Const MaximumDirectoryLength As Integer

Field Value

Type: Int32

See Also

CvsJobServerSettings Class
CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsJobServerSettings.MaximumHostnameLength Field

[image]

In-Sight SDK
CvsJobServerSettings..::..MaximumHostnameLength Field
CvsJobServerSettings Class See Also Send Feedback
Maximum hostname length per RFC 1035.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaximumHostnameLength
Visual Basic
Public Const MaximumHostnameLength As Integer

Field Value

Type: Int32

See Also

CvsJobServerSettings Class
CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsJobServerSettings.MaximumPasswordLength Field

[image]

In-Sight SDK
CvsJobServerSettings..::..MaximumPasswordLength Field
CvsJobServerSettings Class See Also Send Feedback
Maximum password length.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaximumPasswordLength
Visual Basic
Public Const MaximumPasswordLength As Integer

Field Value

Type: Int32

See Also

CvsJobServerSettings Class
CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsJobServerSettings.MaximumUsernameLength Field

[image]

In-Sight SDK
CvsJobServerSettings..::..MaximumUsernameLength Field
CvsJobServerSettings Class See Also Send Feedback
Maximum username length.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaximumUsernameLength
Visual Basic
Public Const MaximumUsernameLength As Integer

Field Value

Type: Int32

See Also

CvsJobServerSettings Class
CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsJobServerSettings Methods

[image] [image]

In-Sight SDK
CvsJobServerSettings Methods
CvsJobServerSettings Class See Also Send Feedback

The CvsJobServerSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | This method performs a shallow copy of the object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ToFtpPortRangeOrDefault | Restricts the integer to the allowed port range. Returns the default value (21) if it isn't.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsJobServerSettings Class
Cognex.InSight.Sensor Namespace


CvsJobServerSettings.Clone Method

[image]

In-Sight SDK
CvsJobServerSettings..::..Clone Method
CvsJobServerSettings Class See Also Send Feedback
This method performs a shallow copy of the object.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsJobServerSettings Class
CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsJobServerSettings.ToFtpPortRangeOrDefault Method

[image]

In-Sight SDK
CvsJobServerSettings..::..ToFtpPortRangeOrDefault Method
CvsJobServerSettings Class See Also Send Feedback
Restricts the integer to the allowed port range. Returns the default value (21) if it isn't.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static int ToFtpPortRangeOrDefault(
    int value
)
Visual Basic
Public Shared Function ToFtpPortRangeOrDefault (
    value As Integer
) As Integer

Parameters

value
Type: System..::..Int32
The port value.

Return Value

Type: Int32
The value if it is within the range; otherwise the default ftp port.

See Also

CvsJobServerSettings Class
CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsJobServerSettings Properties

[image] [image]

In-Sight SDK
CvsJobServerSettings Properties
CvsJobServerSettings Class See Also Send Feedback

The CvsJobServerSettings type exposes the following members.

Properties

 | Name | Description
Public property | Directory | Gets or sets the server directory.
Public property | Enabled | Gets or sets a value that determines if the job server is enabled for the InSight.
Public property | HostName | Gets or sets the host name or IP address of the server.
Public property | Password | Gets or sets the server login password.
Public property | Port | Gets or sets the FTP Port of the server.
Public property | Username | Gets or sets the server login username.

See Also

CvsJobServerSettings Class
Cognex.InSight.Sensor Namespace


CvsJobServerSettings.Directory Property

[image]

In-Sight SDK
CvsJobServerSettings..::..Directory Property
CvsJobServerSettings Class See Also Send Feedback
Gets or sets the server directory.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Directory { get; set; }
Visual Basic
Public Property Directory As String
    Get
    Set

Property Value

Type: String

Remarks

The maximum directory length is 255. Any longer string is truncated.

See Also

CvsJobServerSettings Class
CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsJobServerSettings.Enabled Property

[image]

In-Sight SDK
CvsJobServerSettings..::..Enabled Property
CvsJobServerSettings Class See Also Send Feedback
Gets or sets a value that determines if the job server is enabled for the InSight.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsJobServerSettings Class
CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsJobServerSettings.HostName Property

[image]

In-Sight SDK
CvsJobServerSettings..::..HostName Property
CvsJobServerSettings Class See Also Send Feedback
Gets or sets the host name or IP address of the server.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string HostName { get; set; }
Visual Basic
Public Property HostName As String
    Get
    Set

Property Value

Type: String

Remarks

The maximum host name length is 255. Any longer string is truncated.

See Also

CvsJobServerSettings Class
CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsJobServerSettings.Password Property

[image]

In-Sight SDK
CvsJobServerSettings..::..Password Property
CvsJobServerSettings Class See Also Send Feedback
Gets or sets the server login password.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set

Property Value

Type: String

Remarks

The maximum password length is 127. Any longer string is truncated.

See Also

CvsJobServerSettings Class
CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsJobServerSettings.Port Property

[image]

In-Sight SDK
CvsJobServerSettings..::..Port Property
CvsJobServerSettings Class See Also Send Feedback
Gets or sets the FTP Port of the server.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Port { get; set; }
Visual Basic
Public Property Port As Integer
    Get
    Set

Property Value

Type: Int32
The default value is port 21.

See Also

CvsJobServerSettings Class
CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsJobServerSettings.Username Property

[image]

In-Sight SDK
CvsJobServerSettings..::..Username Property
CvsJobServerSettings Class See Also Send Feedback
Gets or sets the server login username.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Username { get; set; }
Visual Basic
Public Property Username As String
    Get
    Set

Property Value

Type: String

Remarks

The maximum username length is 63. Any longer string is truncated.

See Also

CvsJobServerSettings Class
CvsJobServerSettings..::..CvsJobServerSettings Members
Cognex.InSight.Sensor Namespace


CvsLocalIOSettings Class

[image]

In-Sight SDK
CvsLocalIOSettings Class
Members See Also Send Feedback
Holds the local IO settings.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsLocalIOSettings : CvsDiscreteIOLines
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsLocalIOSettings
    Inherits CvsDiscreteIOLines

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsDiscreteIOLines
Cognex.InSight.Sensor..::..CvsLocalIOSettings

See Also

CvsLocalIOSettings..::..CvsLocalIOSettings Members
Cognex.InSight.Sensor Namespace


CvsLocalIOSettings Members

[image] [image]

In-Sight SDK
CvsLocalIOSettings Members
CvsLocalIOSettings Class Methods Properties See Also Send Feedback

The CvsLocalIOSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance. (Overrides CvsDiscreteIOLines..::..Clone()()()().)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines if the CvsDiscreteIOLines objects contain the same values. (Inherited from CvsDiscreteIOLines.)
Public method | IsValidInputType | Determines if the input type for the current input line is valid for the current In-Sight sensor. (Inherited from CvsDiscreteIOLines.)
Public method | SetInputType | Sets the type for the designated input line. (Inherited from CvsDiscreteIOLines.)
Public method | SetOutputType | Sets the type for the designated output line. (Inherited from CvsDiscreteIOLines.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inputs | Gets the collection of input lines. (Inherited from CvsDiscreteIOLines.)
Public property | Outputs | Gets the collection of output lines. (Inherited from CvsDiscreteIOLines.)

See Also

CvsLocalIOSettings Class
Cognex.InSight.Sensor Namespace


CvsLocalIOSettings Methods

[image] [image]

In-Sight SDK
CvsLocalIOSettings Methods
CvsLocalIOSettings Class See Also Send Feedback

The CvsLocalIOSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance. (Overrides CvsDiscreteIOLines..::..Clone()()()().)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines if the CvsDiscreteIOLines objects contain the same values. (Inherited from CvsDiscreteIOLines.)
Public method | IsValidInputType | Determines if the input type for the current input line is valid for the current In-Sight sensor. (Inherited from CvsDiscreteIOLines.)
Public method | SetInputType | Sets the type for the designated input line. (Inherited from CvsDiscreteIOLines.)
Public method | SetOutputType | Sets the type for the designated output line. (Inherited from CvsDiscreteIOLines.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsLocalIOSettings Class
Cognex.InSight.Sensor Namespace


CvsLocalIOSettings.Clone Method

[image]

In-Sight SDK
CvsLocalIOSettings..::..Clone Method
CvsLocalIOSettings Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsLocalIOSettings Class
CvsLocalIOSettings..::..CvsLocalIOSettings Members
Cognex.InSight.Sensor Namespace


CvsLocalIOSettings Properties

[image] [image]

In-Sight SDK
CvsLocalIOSettings Properties
CvsLocalIOSettings Class See Also Send Feedback

The CvsLocalIOSettings type exposes the following members.

Properties

 | Name | Description
Public property | Inputs | Gets the collection of input lines. (Inherited from CvsDiscreteIOLines.)
Public property | Outputs | Gets the collection of output lines. (Inherited from CvsDiscreteIOLines.)

See Also

CvsLocalIOSettings Class
Cognex.InSight.Sensor Namespace


CvsMode Enumeration

[image]

In-Sight SDK
CvsMode Enumeration
See Also Send Feedback
Defines the serial port's protocol mode selections.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsMode
Visual Basic
Public Enumeration CvsMode

Members

Member name | Value | Description
Unused | -1 | The mode is unused.
None | 0 | The mode is not set.
Text | 6 | The Text mode is used.
Native | 7 | The Native mode is used.
DeviceNet | 8 | The DeviceNet mode is used.
Motoman | 9 | The Motoman mode is used.
Kuka | 10 | The Kuka mode is used.

See Also

Cognex.InSight.Sensor Namespace


CvsNetworkLinkModes Enumeration

[image]

In-Sight SDK
CvsNetworkLinkModes Enumeration
See Also Send Feedback
An enumeration of Ethernet link modes that may be supported by an In-Sight.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsNetworkLinkModes
Visual Basic
Public Enumeration CvsNetworkLinkModes

Members

Member name | Value | Description
AutoNegotiation | 0 | The In-Sight's link speed and duplex mode is determined automatically.
Force10Half | 100 | The In-Sight will be forced to connect at 10 Mbit/s, half-duplex.
Force10Full | 101 | The In-Sight will be forced to connect at 10 Mbit/s, full-duplex.
Force100Half | 102 | The In-Sight will be forced to connect at 100 Mbit/s, half-duplex.
Force100Full | 103 | The In-Sight will be forced to connect at 100 Mbit/s, full-duplex.
Force1000Full | 104 | The In-Sight will be forced to connect at 1,000 Mbit/s, full-duplex.
Unknown | -1 | The In-Sight response was unexpected.

See Also

Cognex.InSight.Sensor Namespace


CvsNetworkSettings Class

[image]

In-Sight SDK
CvsNetworkSettings Class
Members See Also Send Feedback
Holds the network settings for an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsNetworkSettings : ICloneable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsNetworkSettings
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsNetworkSettings

See Also

CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings Members

[image] [image]

In-Sight SDK
CvsNetworkSettings Members
CvsNetworkSettings Class Methods Properties See Also Send Feedback

The CvsNetworkSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | SetEnableProtocolService | Enables the specified CvsProtocolServices for the current protocol service.
Public method | SetProtocolService | Sanitizes the value based on the specified CvsProtocolServicesInfo object and sets the ProtocolService property.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryEnableProtocolService | Enables the protocol if it isn't enabled.

Properties

 | Name | Description
Public property | CurrentLinkMode | Gets the current, actual CvsNetworkLinkModes speed.
Public property | DhcpDefaultGateway | Gets the DHCP default gateway.
Public property | DhcpDefaultGatewayString | Gets the DHCP default gateway.
Public property | DhcpDnsServer | Gets the DHCP DNS server.
Public property | DhcpDnsServerString | Gets the DHCP DNS server.
Public property | DhcpDomainName | Gets the DHCP domain name.
Public property | DhcpEnabled | Gets or sets the value that designates if DHCP locating is enabled.
Public property | DhcpIPAddress | Gets the DHCP IP address of the In-Sight sensor.
Public property | DhcpIPAddressString | Gets the DHCP IP address of the In-Sight sensor.
Public property | DhcpSubnetMask | Gets the DHCP subnet mask.
Public property | DhcpSubnetMaskString | Gets the DHCP subnet mask.
Public property | DhcpTimeout | Gets or sets the DHCP timeout in seconds.
Public property | EipWatchdogTimeoutAction | Gets and sets the EtherNet/IP watchdog timeout action.
Public property | FtpSettings | Gets the FTP settings.
Public property | HostName | Gets or sets the host name associated with the In-Sight sensor.
Public property | HostTable | Gets the host table collection.
Public property | HostTableFavored | Gets or sets the flag that designates if the Host Table should be favored.
Public property | LinkMode | Gets and sets the current CvsNetworkLinkModes setting.
Public property | ModbusSettings | Gets or sets the maximum number of modbus connections.
Public property | PowerlinkSettings | Gets the POWERLINK settings for the sensor.
Public property | ProtocolService | Gets the enable for a particular protocol service.
Public property | StaticDefaultGateway | Gets or sets the static default gateway.
Public property | StaticDefaultGatewayString | Gets or sets the static default gateway.
Public property | StaticDnsServer | Gets or sets the static DNS server.
Public property | StaticDnsServerString | Gets or sets the static DNS server.
Public property | StaticDomainName | Gets or sets the static (fixed) domain name.
Public property | StaticIPAddress | Gets or sets the static IP address of the In-Sight sensor.
Public property | StaticIPAddressString | Gets or sets the static IP address of the In-Sight sensor.
Public property | StaticSubnetMask | Gets or sets the static subnet mask.
Public property | StaticSubnetMaskString | Gets or sets the static subnet mask.
Public property | SupportedLinkModes | Gets the list of CvsNetworkLinkModes supported by the In-Sight.
Public property | TelnetPort | Gets or sets the Telnet port.
Public property | UserList | Gets the user list collection.

See Also

CvsNetworkSettings Class
Cognex.InSight.Sensor Namespace


CvsNetworkSettings Methods

[image] [image]

In-Sight SDK
CvsNetworkSettings Methods
CvsNetworkSettings Class See Also Send Feedback

The CvsNetworkSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | SetEnableProtocolService | Enables the specified CvsProtocolServices for the current protocol service.
Public method | SetProtocolService | Sanitizes the value based on the specified CvsProtocolServicesInfo object and sets the ProtocolService property.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryEnableProtocolService | Enables the protocol if it isn't enabled.

See Also

CvsNetworkSettings Class
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.Clone Method

[image]

In-Sight SDK
CvsNetworkSettings..::..Clone Method
CvsNetworkSettings Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.SetEnableProtocolService Method

[image]

In-Sight SDK
CvsNetworkSettings..::..SetEnableProtocolService Method
CvsNetworkSettings Class See Also Send Feedback
Enables the specified CvsProtocolServices for the current protocol service.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static CvsProtocolServices SetEnableProtocolService(
    CvsProtocolServices value,
    CvsProtocolServices current,
    CvsProtocolServicesInfo info
)
Visual Basic
Public Shared Function SetEnableProtocolService (
    value As CvsProtocolServices,
    current As CvsProtocolServices,
    info As CvsProtocolServicesInfo
) As CvsProtocolServices

Parameters

value
Type: Cognex.InSight.Sensor..::..CvsProtocolServices
Protocol service to enable.
current
Type: Cognex.InSight.Sensor..::..CvsProtocolServices
Current protocol service.
info
Type: Cognex.InSight.Sensor..::..CvsProtocolServicesInfo
The info to use for determining if a protocol is exclusive/inclusive.

Return Value

Type: CvsProtocolServices
Enabled protocol service.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The CvsProtocolServicesInfo parameter is null.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.SetProtocolService Method

[image]

In-Sight SDK
CvsNetworkSettings..::..SetProtocolService Method
CvsNetworkSettings Class See Also Send Feedback
Sanitizes the value based on the specified CvsProtocolServicesInfo object and sets the ProtocolService property.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetProtocolService(
    CvsProtocolServices value,
    CvsProtocolServicesInfo info
)
Visual Basic
Public Sub SetProtocolService (
    value As CvsProtocolServices,
    info As CvsProtocolServicesInfo
)

Parameters

value
Type: Cognex.InSight.Sensor..::..CvsProtocolServices

[Missing <param name="value"/> documentation for "M:Cognex.InSight.Sensor.CvsNetworkSettings.SetProtocolService(Cognex.InSight.Sensor.CvsProtocolServices,Cognex.InSight.Sensor.CvsProtocolServicesInfo)"]

info
Type: Cognex.InSight.Sensor..::..CvsProtocolServicesInfo

[Missing <param name="info"/> documentation for "M:Cognex.InSight.Sensor.CvsNetworkSettings.SetProtocolService(Cognex.InSight.Sensor.CvsProtocolServices,Cognex.InSight.Sensor.CvsProtocolServicesInfo)"]

Exceptions

Exception | Condition
System..::..ArgumentNullException | The CvsProtocolServicesInfo parameter is null.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.TryEnableProtocolService Method

[image]

In-Sight SDK
CvsNetworkSettings..::..TryEnableProtocolService Method
CvsNetworkSettings Class See Also Send Feedback
Enables the protocol if it isn't enabled.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool TryEnableProtocolService(
    CvsProtocolServices desired,
    ICvsSupportedSettings supported
)
Visual Basic
Public Function TryEnableProtocolService (
    desired As CvsProtocolServices,
    supported As ICvsSupportedSettings
) As Boolean

Parameters

desired
Type: Cognex.InSight.Sensor..::..CvsProtocolServices
The desired protocol to enable.
supported
Type: ICvsSupportedSettings
Used to retrieve the CvsProtocolServicesInfo object.

Return Value

Type: Boolean
True if the protocol was enabled; otherwise false.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The ICvsSupportedSettings parameter is null.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings Properties

[image] [image]

In-Sight SDK
CvsNetworkSettings Properties
CvsNetworkSettings Class See Also Send Feedback

The CvsNetworkSettings type exposes the following members.

Properties

 | Name | Description
Public property | CurrentLinkMode | Gets the current, actual CvsNetworkLinkModes speed.
Public property | DhcpDefaultGateway | Gets the DHCP default gateway.
Public property | DhcpDefaultGatewayString | Gets the DHCP default gateway.
Public property | DhcpDnsServer | Gets the DHCP DNS server.
Public property | DhcpDnsServerString | Gets the DHCP DNS server.
Public property | DhcpDomainName | Gets the DHCP domain name.
Public property | DhcpEnabled | Gets or sets the value that designates if DHCP locating is enabled.
Public property | DhcpIPAddress | Gets the DHCP IP address of the In-Sight sensor.
Public property | DhcpIPAddressString | Gets the DHCP IP address of the In-Sight sensor.
Public property | DhcpSubnetMask | Gets the DHCP subnet mask.
Public property | DhcpSubnetMaskString | Gets the DHCP subnet mask.
Public property | DhcpTimeout | Gets or sets the DHCP timeout in seconds.
Public property | EipWatchdogTimeoutAction | Gets and sets the EtherNet/IP watchdog timeout action.
Public property | FtpSettings | Gets the FTP settings.
Public property | HostName | Gets or sets the host name associated with the In-Sight sensor.
Public property | HostTable | Gets the host table collection.
Public property | HostTableFavored | Gets or sets the flag that designates if the Host Table should be favored.
Public property | LinkMode | Gets and sets the current CvsNetworkLinkModes setting.
Public property | ModbusSettings | Gets or sets the maximum number of modbus connections.
Public property | PowerlinkSettings | Gets the POWERLINK settings for the sensor.
Public property | ProtocolService | Gets the enable for a particular protocol service.
Public property | StaticDefaultGateway | Gets or sets the static default gateway.
Public property | StaticDefaultGatewayString | Gets or sets the static default gateway.
Public property | StaticDnsServer | Gets or sets the static DNS server.
Public property | StaticDnsServerString | Gets or sets the static DNS server.
Public property | StaticDomainName | Gets or sets the static (fixed) domain name.
Public property | StaticIPAddress | Gets or sets the static IP address of the In-Sight sensor.
Public property | StaticIPAddressString | Gets or sets the static IP address of the In-Sight sensor.
Public property | StaticSubnetMask | Gets or sets the static subnet mask.
Public property | StaticSubnetMaskString | Gets or sets the static subnet mask.
Public property | SupportedLinkModes | Gets the list of CvsNetworkLinkModes supported by the In-Sight.
Public property | TelnetPort | Gets or sets the Telnet port.
Public property | UserList | Gets the user list collection.

See Also

CvsNetworkSettings Class
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.CurrentLinkMode Property

[image]

In-Sight SDK
CvsNetworkSettings..::..CurrentLinkMode Property
CvsNetworkSettings Class See Also Send Feedback
Gets the current, actual CvsNetworkLinkModes speed.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsNetworkLinkModes CurrentLinkMode { get; }
Visual Basic
Public ReadOnly Property CurrentLinkMode As CvsNetworkLinkModes
    Get

Property Value

Type: CvsNetworkLinkModes

Remarks

The current setting may differ if the In-Sight has not been restarted.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.DhcpDefaultGateway Property

[image]

In-Sight SDK
CvsNetworkSettings..::..DhcpDefaultGateway Property
CvsNetworkSettings Class See Also Send Feedback
Gets the DHCP default gateway.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress DhcpDefaultGateway { get; }
Visual Basic
Public ReadOnly Property DhcpDefaultGateway As IPAddress
    Get

Property Value

Type: IPAddress

Remarks

This property is only available in .NET applications. To obtain an an IP address for use in COM/ActiveX applications, use the DhcpDefaultGatewayString property instead.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.DhcpDefaultGatewayString Property

[image]

In-Sight SDK
CvsNetworkSettings..::..DhcpDefaultGatewayString Property
CvsNetworkSettings Class See Also Send Feedback
Gets the DHCP default gateway.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string DhcpDefaultGatewayString { get; }
Visual Basic
Public ReadOnly Property DhcpDefaultGatewayString As String
    Get

Property Value

Type: String

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.DhcpDnsServer Property

[image]

In-Sight SDK
CvsNetworkSettings..::..DhcpDnsServer Property
CvsNetworkSettings Class See Also Send Feedback
Gets the DHCP DNS server.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress DhcpDnsServer { get; }
Visual Basic
Public ReadOnly Property DhcpDnsServer As IPAddress
    Get

Property Value

Type: IPAddress

Remarks

This property is only available in .NET applications. To obtain an an IP address for use in COM/ActiveX applications, use the DhcpDnsServerString property instead.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.DhcpDnsServerString Property

[image]

In-Sight SDK
CvsNetworkSettings..::..DhcpDnsServerString Property
CvsNetworkSettings Class See Also Send Feedback
Gets the DHCP DNS server.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string DhcpDnsServerString { get; }
Visual Basic
Public ReadOnly Property DhcpDnsServerString As String
    Get

Property Value

Type: String

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.DhcpDomainName Property

[image]

In-Sight SDK
CvsNetworkSettings..::..DhcpDomainName Property
CvsNetworkSettings Class See Also Send Feedback
Gets the DHCP domain name.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string DhcpDomainName { get; }
Visual Basic
Public ReadOnly Property DhcpDomainName As String
    Get

Property Value

Type: String

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.DhcpEnabled Property

[image]

In-Sight SDK
CvsNetworkSettings..::..DhcpEnabled Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the value that designates if DHCP locating is enabled.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool DhcpEnabled { get; set; }
Visual Basic
Public Property DhcpEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.DhcpIPAddress Property

[image]

In-Sight SDK
CvsNetworkSettings..::..DhcpIPAddress Property
CvsNetworkSettings Class See Also Send Feedback
Gets the DHCP IP address of the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress DhcpIPAddress { get; }
Visual Basic
Public ReadOnly Property DhcpIPAddress As IPAddress
    Get

Property Value

Type: IPAddress

Remarks

This property is only available in .NET applications. To obtain an an IP address for use in COM/ActiveX applications, use the DhcpIPAddressString property instead.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.DhcpIPAddressString Property

[image]

In-Sight SDK
CvsNetworkSettings..::..DhcpIPAddressString Property
CvsNetworkSettings Class See Also Send Feedback
Gets the DHCP IP address of the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string DhcpIPAddressString { get; }
Visual Basic
Public ReadOnly Property DhcpIPAddressString As String
    Get

Property Value

Type: String

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.DhcpSubnetMask Property

[image]

In-Sight SDK
CvsNetworkSettings..::..DhcpSubnetMask Property
CvsNetworkSettings Class See Also Send Feedback
Gets the DHCP subnet mask.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress DhcpSubnetMask { get; }
Visual Basic
Public ReadOnly Property DhcpSubnetMask As IPAddress
    Get

Property Value

Type: IPAddress

Remarks

This property is only available in .NET applications. To obtain an an IP address for use in COM/ActiveX applications, use the DhcpSubnetMaskString property instead.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.DhcpSubnetMaskString Property

[image]

In-Sight SDK
CvsNetworkSettings..::..DhcpSubnetMaskString Property
CvsNetworkSettings Class See Also Send Feedback
Gets the DHCP subnet mask.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string DhcpSubnetMaskString { get; }
Visual Basic
Public ReadOnly Property DhcpSubnetMaskString As String
    Get

Property Value

Type: String

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.DhcpTimeout Property

[image]

In-Sight SDK
CvsNetworkSettings..::..DhcpTimeout Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the DHCP timeout in seconds.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int DhcpTimeout { get; set; }
Visual Basic
Public Property DhcpTimeout As Integer
    Get
    Set

Property Value

Type: Int32
The valid range is 5 to 180 seconds.

Remarks

Setting this property has no effect unless the sensor has firmware version 3.1 or later.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is in the range 5-180.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.EipWatchdogTimeoutAction Property

[image]

In-Sight SDK
CvsNetworkSettings..::..EipWatchdogTimeoutAction Property
CvsNetworkSettings Class See Also Send Feedback
Gets and sets the EtherNet/IP watchdog timeout action.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEipWatchdogTimeoutActions EipWatchdogTimeoutAction { get; set; }
Visual Basic
Public Property EipWatchdogTimeoutAction As CvsEipWatchdogTimeoutActions
    Get
    Set

Property Value

Type: CvsEipWatchdogTimeoutActions

Remarks

Setting this property has no effect unless the sensor has firmware version 3.1 or later.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.FtpSettings Property

[image]

In-Sight SDK
CvsNetworkSettings..::..FtpSettings Property
CvsNetworkSettings Class See Also Send Feedback
Gets the FTP settings.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsFtpSettings FtpSettings { get; }
Visual Basic
Public ReadOnly Property FtpSettings As CvsFtpSettings
    Get

Property Value

Type: CvsFtpSettings

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.HostName Property

[image]

In-Sight SDK
CvsNetworkSettings..::..HostName Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the host name associated with the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string HostName { get; set; }
Visual Basic
Public Property HostName As String
    Get
    Set

Property Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentException | value is longer than MaxNameLength or contains invalid characters.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.HostTable Property

[image]

In-Sight SDK
CvsNetworkSettings..::..HostTable Property
CvsNetworkSettings Class See Also Send Feedback
Gets the host table collection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostTableCollection HostTable { get; }
Visual Basic
Public ReadOnly Property HostTable As CvsHostTableCollection
    Get

Property Value

Type: CvsHostTableCollection

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.HostTableFavored Property

[image]

In-Sight SDK
CvsNetworkSettings..::..HostTableFavored Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the flag that designates if the Host Table should be favored.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool HostTableFavored { get; set; }
Visual Basic
Public Property HostTableFavored As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.LinkMode Property

[image]

In-Sight SDK
CvsNetworkSettings..::..LinkMode Property
CvsNetworkSettings Class See Also Send Feedback
Gets and sets the current CvsNetworkLinkModes setting.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsNetworkLinkModes LinkMode { get; set; }
Visual Basic
Public Property LinkMode As CvsNetworkLinkModes
    Get
    Set

Property Value

Type: CvsNetworkLinkModes

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.ModbusSettings Property

[image]

In-Sight SDK
CvsNetworkSettings..::..ModbusSettings Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the maximum number of modbus connections.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsModbusSettings ModbusSettings { get; }
Visual Basic
Public ReadOnly Property ModbusSettings As CvsModbusSettings
    Get

Property Value

Type: CvsModbusSettings

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.PowerlinkSettings Property

[image]

In-Sight SDK
CvsNetworkSettings..::..PowerlinkSettings Property
CvsNetworkSettings Class See Also Send Feedback
Gets the POWERLINK settings for the sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsPowerlinkSettings PowerlinkSettings { get; }
Visual Basic
Public ReadOnly Property PowerlinkSettings As CvsPowerlinkSettings
    Get

Property Value

Type: CvsPowerlinkSettings

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.ProtocolService Property

[image]

In-Sight SDK
CvsNetworkSettings..::..ProtocolService Property
CvsNetworkSettings Class See Also Send Feedback
Gets the enable for a particular protocol service.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsProtocolServices ProtocolService { get; }
Visual Basic
Public ReadOnly Property ProtocolService As CvsProtocolServices
    Get

Property Value

Type: CvsProtocolServices

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.StaticDefaultGateway Property

[image]

In-Sight SDK
CvsNetworkSettings..::..StaticDefaultGateway Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the static default gateway.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress StaticDefaultGateway { get; set; }
Visual Basic
Public Property StaticDefaultGateway As IPAddress
    Get
    Set

Property Value

Type: IPAddress

Remarks

This property is only available in .NET applications. To obtain an an IP address for use in COM/ActiveX applications, use the StaticDefaultGatewayString property instead.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a valid IP address.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.StaticDefaultGatewayString Property

[image]

In-Sight SDK
CvsNetworkSettings..::..StaticDefaultGatewayString Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the static default gateway.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string StaticDefaultGatewayString { get; set; }
Visual Basic
Public Property StaticDefaultGatewayString As String
    Get
    Set

Property Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a valid IP address.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.StaticDnsServer Property

[image]

In-Sight SDK
CvsNetworkSettings..::..StaticDnsServer Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the static DNS server.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress StaticDnsServer { get; set; }
Visual Basic
Public Property StaticDnsServer As IPAddress
    Get
    Set

Property Value

Type: IPAddress

Remarks

This property is only available in .NET applications. To obtain an an IP address for use in COM/ActiveX applications, use the StaticDnsServerString property instead.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a valid IP address.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.StaticDnsServerString Property

[image]

In-Sight SDK
CvsNetworkSettings..::..StaticDnsServerString Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the static DNS server.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string StaticDnsServerString { get; set; }
Visual Basic
Public Property StaticDnsServerString As String
    Get
    Set

Property Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a valid IP address.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.StaticDomainName Property

[image]

In-Sight SDK
CvsNetworkSettings..::..StaticDomainName Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the static (fixed) domain name.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string StaticDomainName { get; set; }
Visual Basic
Public Property StaticDomainName As String
    Get
    Set

Property Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentException | value is too long.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.StaticIPAddress Property

[image]

In-Sight SDK
CvsNetworkSettings..::..StaticIPAddress Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the static IP address of the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress StaticIPAddress { get; set; }
Visual Basic
Public Property StaticIPAddress As IPAddress
    Get
    Set

Property Value

Type: IPAddress

Remarks

This property is only available in .NET applications. To obtain an an IP address for use in COM/ActiveX applications, use the StaticIPAddressString property instead.

Exceptions

Exception | Condition
System..::..ArgumentNullException | value is null.
System..::..ArgumentOutOfRangeException | value is not a valid IP address.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.StaticIPAddressString Property

[image]

In-Sight SDK
CvsNetworkSettings..::..StaticIPAddressString Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the static IP address of the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string StaticIPAddressString { get; set; }
Visual Basic
Public Property StaticIPAddressString As String
    Get
    Set

Property Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a valid IP address.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.StaticSubnetMask Property

[image]

In-Sight SDK
CvsNetworkSettings..::..StaticSubnetMask Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the static subnet mask.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress StaticSubnetMask { get; set; }
Visual Basic
Public Property StaticSubnetMask As IPAddress
    Get
    Set

Property Value

Type: IPAddress

Remarks

This property is only available in .NET applications. To obtain an an IP address for use in COM/ActiveX applications, use the StaticSubnetMaskString property instead.

Exceptions

Exception | Condition
System..::..ArgumentNullException | value is null.
System..::..ArgumentOutOfRangeException | value is not a valid IP address.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.StaticSubnetMaskString Property

[image]

In-Sight SDK
CvsNetworkSettings..::..StaticSubnetMaskString Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the static subnet mask.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string StaticSubnetMaskString { get; set; }
Visual Basic
Public Property StaticSubnetMaskString As String
    Get
    Set

Property Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a valid IP address.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.SupportedLinkModes Property

[image]

In-Sight SDK
CvsNetworkSettings..::..SupportedLinkModes Property
CvsNetworkSettings Class See Also Send Feedback
Gets the list of CvsNetworkLinkModes supported by the In-Sight.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsNetworkLinkModes[] SupportedLinkModes { get; }
Visual Basic
Public ReadOnly Property SupportedLinkModes As CvsNetworkLinkModes()
    Get

Property Value

Type: array< CvsNetworkLinkModes >[]()[][]

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.TelnetPort Property

[image]

In-Sight SDK
CvsNetworkSettings..::..TelnetPort Property
CvsNetworkSettings Class See Also Send Feedback
Gets or sets the Telnet port.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int TelnetPort { get; set; }
Visual Basic
Public Property TelnetPort As Integer
    Get
    Set

Property Value

Type: Int32
The valid range is 1 to 65535, but not the FTP port, 68, 80, 502, 1069, 1070, or 1212.

Remarks

Setting this property has no effect unless the sensor has firmware version 3.3 or later.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not in the range 1-65535 or is a reserved port.

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsNetworkSettings.UserList Property

[image]

In-Sight SDK
CvsNetworkSettings..::..UserList Property
CvsNetworkSettings Class See Also Send Feedback
Gets the user list collection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsUserCollection UserList { get; }
Visual Basic
Public ReadOnly Property UserList As CvsUserCollection
    Get

Property Value

Type: CvsUserCollection

Remarks

Any changes to this list will be ignored when sent back to the sensor via SetSettings(CvsSettings).

See Also

CvsNetworkSettings Class
CvsNetworkSettings..::..CvsNetworkSettings Members
Cognex.InSight.Sensor Namespace


CvsOutputCollection Class

[image]

In-Sight SDK
CvsOutputCollection Class
Members See Also Send Feedback
Represents a collection of ICvsDiscreteOutputLine objects.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsOutputCollection : CvsDiscreteLineCollection<ICvsDiscreteOutputLine>
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsOutputCollection
    Inherits CvsDiscreteLineCollection(Of ICvsDiscreteOutputLine)

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsDiscreteLineCollection <(Of <(<' ICvsDiscreteOutputLine >)>)>
Cognex.InSight.Sensor..::..CvsOutputCollection

See Also

CvsOutputCollection..::..CvsOutputCollection Members
Cognex.InSight.Sensor Namespace


CvsOutputCollection Members

[image] [image]

In-Sight SDK
CvsOutputCollection Members
CvsOutputCollection Class Constructors Methods Properties See Also Send Feedback

The CvsOutputCollection type exposes the following members.

Constructors

 | Name | Description
Public method | CvsOutputCollection | Initializes a new instance of the CvsOutputCollection class

Methods

 | Name | Description
Public method | At | Gets the ICvsDiscreteLine object at the specified zero-based index. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsInputCollection. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSettings | Returns the settings for the specified line. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of lines in the collection. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public property | Item | Gets the ICvsDiscreteLine object at the specified zero-based index. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)

See Also

CvsOutputCollection Class
Cognex.InSight.Sensor Namespace


CvsOutputCollection Constructor

[image]

In-Sight SDK
CvsOutputCollection Constructor
CvsOutputCollection Class See Also Send Feedback
Initializes a new instance of the CvsOutputCollection class

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsOutputCollection()
Visual Basic
Public Sub New

See Also

CvsOutputCollection Class
CvsOutputCollection..::..CvsOutputCollection Members
Cognex.InSight.Sensor Namespace


CvsOutputCollection Methods

[image] [image]

In-Sight SDK
CvsOutputCollection Methods
CvsOutputCollection Class See Also Send Feedback

The CvsOutputCollection type exposes the following members.

Methods

 | Name | Description
Public method | At | Gets the ICvsDiscreteLine object at the specified zero-based index. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsInputCollection. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSettings | Returns the settings for the specified line. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsOutputCollection Class
Cognex.InSight.Sensor Namespace


CvsOutputCollection Properties

[image] [image]

In-Sight SDK
CvsOutputCollection Properties
CvsOutputCollection Class See Also Send Feedback

The CvsOutputCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of lines in the collection. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)
Public property | Item | Gets the ICvsDiscreteLine object at the specified zero-based index. (Inherited from CvsDiscreteLineCollection<(Of <(<'T>)>)>.)

See Also

CvsOutputCollection Class
Cognex.InSight.Sensor Namespace


CvsOutputDelayTypeFlags Enumeration

[image]

In-Sight SDK
CvsOutputDelayTypeFlags Enumeration
See Also Send Feedback
Enum of the output delay capabilities of a specific output line

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsOutputDelayTypeFlags
Visual Basic
Public Enumeration CvsOutputDelayTypeFlags

Members

Member name | Value | Description
AcquisitionCount | 0 | The delay is for the acqusition count
TimeAfterTrigger | 268435456 | The delay is for the time after trigger
EncoderCount | 536870912 | The delay is for the encoder count

See Also

Cognex.InSight.Sensor Namespace


CvsOutputType Enumeration

[image]

In-Sight SDK
CvsOutputType Enumeration
See Also Send Feedback
Defines the type of operation designated by the output line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsOutputType
Visual Basic
Public Enumeration CvsOutputType

Members

Member name | Value | Description
Programmed | 0 | Specifies a Programmed output line.
High | 1 | Specifies a High output line.
Low | 2 | Specifies a Low output line.
AcquisitionStart | 3 | Specifies an Acquisition Start output line.
AcquisitionEnd | 4 | Specifies an Acquisition End output line.
JobCompleted | 5 | Specifies a Job Completed output line.
SystemBusy | 6 | Specifies a System Busy output line.
JobLoadOK | 7 | Specifies a Job Load OK output line.
JobLoadFail | 8 | Specifies a Job Load Failed output line.
MissedAcquisition | 9 | Specifies a Missed Acquisition output line.
TrackingOverrun | 10 | Specifies a Tracking Overrun output line.
TrackingQueueFull | 11 | Specifies a Tracking Queue Full output line.
OnlineOffline | 12 | Specifies an Online/Offline output line.
Strobe | 13 | Specifies a Strobe output line.
IOModuleStandby | 1073741837 | Specifies an I/O module standby output line.
LightControl | 14 | Specifies a Light Control output line.
Pass | 15 | Specifies a Pass output line which is set when the inspection passes
Fail | 16 | Specifies a Fail output line which is set when the inspection fails
Lifeline | 17 | Specifies a Lifeline output line which is set when the I/O module and In-Sight are communicating properly
Waveform | 18 | Specifies a Waveform output line.
Encoder | 19 | Specifies a Encoder.
SerialTransmit | 20 | Specifies a serial transmit line.
SynchronizerComplete | 21 | Specifies a Synchronizer output line which is set when the synchronizer succeeds in getting a full set of acquired images.
SynchronizerFail | 22 | Specifies a Synchronizer output line which is set when the synchronizer fails to get a full set of images.
PassFail | 24 | Specifies that the Tri-State LED line should mimic the pass/fail cell in the spreadsheet.

Remarks

The Strobe, IOModuleStandby and Other members have the same numerical value.

See Also

Cognex.InSight.Sensor Namespace


CvsParity Enumeration

[image]

In-Sight SDK
CvsParity Enumeration
See Also Send Feedback
Defines the serial port's parity selections.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsParity
Visual Basic
Public Enumeration CvsParity

Members

Member name | Value | Description
None | 256 | No parity bits are used.
Odd | 512 | Odd parity is used.
Even | 1024 | Even parity is used.

See Also

Cognex.InSight.Sensor Namespace


CvsProcessorConstants Class

[image]

In-Sight SDK
CvsProcessorConstants Class
Members See Also Send Feedback
Holds the processor constants for an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsProcessorConstants
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsProcessorConstants

Remarks

Each In-Sight sensor may have a different set of constants based on sensor type or firmware version.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsProcessorConstants

See Also

CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants Members

[image] [image]

In-Sight SDK
CvsProcessorConstants Members
CvsProcessorConstants Class Methods Properties See Also Send Feedback

The CvsProcessorConstants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FirmwareDrivenTestRunSupported | Gets the flag whether the camera supports running TestRun directly.
Public property | ImageHeight | Gets the height (in pixels) of the full-resolution images captured by the In-Sight sensor.
Public property | ImageWidth | Gets the width (in pixels) of the full-resolution images captured by the In-Sight sensor.
Public property | IsColor | Gets the flag that determines if the processor acquires color or grayscale images.
Public property | IsEncryptJobLoadSaveSupported | Gets the flag whether the camera supports password encryption of load and save jobs commands over ISP.
Public property | IsJobTagSupported | Gets the flag that determines if the processor supports job tags. This includes tags applied to the job, columns, rows and cells.
Public property | IsLineScan | Gets the flag that determines if the processor acquires line scan images.
Public property | IsOpcSupported | Gets the flag that determines if the processor supports OPC tags.
Public property | IsUndoSupported | Gets the flag that determines if the processor supports undo, allowing the user to undo and redo changes made with the display control.
Public property | MaxExpressionLength | Gets the maximum expression length.
Public property | MaxExpressionStack | Gets the maximum number of items that can comprise an expression.
Public property | MaxFileNameLength | Gets the maximum file name length, including the extension.
Public property | MaxSpreadsheetCells | Gets the maximum number of cells allowed in the spreadsheet.
Public property | MaxStringLength | Gets the maximum string length.
Public property | SpreadsheetColumns | Gets the number of columns in the main spreadsheet.
Public property | SpreadsheetRange | Gets a cell range representing the overall range of cells in the main spreadsheet, not including dialogs.
Public property | SpreadsheetRows | Gets the number of rows in the main spreadsheet, not including the dialog rows.
Public property | SpreadsheetTotalRows | Gets the total number of rows in the spreadsheet, including the dialog rows.

See Also

CvsProcessorConstants Class
Cognex.InSight.Sensor Namespace


CvsProcessorConstants Methods

[image] [image]

In-Sight SDK
CvsProcessorConstants Methods
CvsProcessorConstants Class See Also Send Feedback

The CvsProcessorConstants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsProcessorConstants Class
Cognex.InSight.Sensor Namespace


CvsProcessorConstants Properties

[image] [image]

In-Sight SDK
CvsProcessorConstants Properties
CvsProcessorConstants Class See Also Send Feedback

The CvsProcessorConstants type exposes the following members.

Properties

 | Name | Description
Public property | FirmwareDrivenTestRunSupported | Gets the flag whether the camera supports running TestRun directly.
Public property | ImageHeight | Gets the height (in pixels) of the full-resolution images captured by the In-Sight sensor.
Public property | ImageWidth | Gets the width (in pixels) of the full-resolution images captured by the In-Sight sensor.
Public property | IsColor | Gets the flag that determines if the processor acquires color or grayscale images.
Public property | IsEncryptJobLoadSaveSupported | Gets the flag whether the camera supports password encryption of load and save jobs commands over ISP.
Public property | IsJobTagSupported | Gets the flag that determines if the processor supports job tags. This includes tags applied to the job, columns, rows and cells.
Public property | IsLineScan | Gets the flag that determines if the processor acquires line scan images.
Public property | IsOpcSupported | Gets the flag that determines if the processor supports OPC tags.
Public property | IsUndoSupported | Gets the flag that determines if the processor supports undo, allowing the user to undo and redo changes made with the display control.
Public property | MaxExpressionLength | Gets the maximum expression length.
Public property | MaxExpressionStack | Gets the maximum number of items that can comprise an expression.
Public property | MaxFileNameLength | Gets the maximum file name length, including the extension.
Public property | MaxSpreadsheetCells | Gets the maximum number of cells allowed in the spreadsheet.
Public property | MaxStringLength | Gets the maximum string length.
Public property | SpreadsheetColumns | Gets the number of columns in the main spreadsheet.
Public property | SpreadsheetRange | Gets a cell range representing the overall range of cells in the main spreadsheet, not including dialogs.
Public property | SpreadsheetRows | Gets the number of rows in the main spreadsheet, not including the dialog rows.
Public property | SpreadsheetTotalRows | Gets the total number of rows in the spreadsheet, including the dialog rows.

See Also

CvsProcessorConstants Class
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.FirmwareDrivenTestRunSupported Property

[image]

In-Sight SDK
CvsProcessorConstants..::..FirmwareDrivenTestRunSupported Property
CvsProcessorConstants Class See Also Send Feedback
Gets the flag whether the camera supports running TestRun directly.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool FirmwareDrivenTestRunSupported { get; }
Visual Basic
Public ReadOnly Property FirmwareDrivenTestRunSupported As Boolean
    Get

Property Value

Type: Boolean
true if the sensor supports running TestRun directly; otherwise, false.

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.ImageHeight Property

[image]

In-Sight SDK
CvsProcessorConstants..::..ImageHeight Property
CvsProcessorConstants Class See Also Send Feedback
Gets the height (in pixels) of the full-resolution images captured by the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int ImageHeight { get; }
Visual Basic
Public ReadOnly Property ImageHeight As Integer
    Get

Property Value

Type: Int32

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.ImageWidth Property

[image]

In-Sight SDK
CvsProcessorConstants..::..ImageWidth Property
CvsProcessorConstants Class See Also Send Feedback
Gets the width (in pixels) of the full-resolution images captured by the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int ImageWidth { get; }
Visual Basic
Public ReadOnly Property ImageWidth As Integer
    Get

Property Value

Type: Int32

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.IsColor Property

[image]

In-Sight SDK
CvsProcessorConstants..::..IsColor Property
CvsProcessorConstants Class See Also Send Feedback
Gets the flag that determines if the processor acquires color or grayscale images.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsColor { get; }
Visual Basic
Public ReadOnly Property IsColor As Boolean
    Get

Property Value

Type: Boolean
true if the processor acquires color images; otherwise, false if the processor acquires grayscale images.

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.IsEncryptJobLoadSaveSupported Property

[image]

In-Sight SDK
CvsProcessorConstants..::..IsEncryptJobLoadSaveSupported Property
CvsProcessorConstants Class See Also Send Feedback
Gets the flag whether the camera supports password encryption of load and save jobs commands over ISP.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsEncryptJobLoadSaveSupported { get; }
Visual Basic
Public ReadOnly Property IsEncryptJobLoadSaveSupported As Boolean
    Get

Property Value

Type: Boolean
true if the processor supports encryption in these ISP commands otherwise, false.

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.IsJobTagSupported Property

[image]

In-Sight SDK
CvsProcessorConstants..::..IsJobTagSupported Property
CvsProcessorConstants Class See Also Send Feedback
Gets the flag that determines if the processor supports job tags. This includes tags applied to the job, columns, rows and cells.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsJobTagSupported { get; }
Visual Basic
Public ReadOnly Property IsJobTagSupported As Boolean
    Get

Property Value

Type: Boolean
true if the processor supports the setting of job tags; otherwise, false.

Remarks

Job tags are used for various features including cell formatting, job protection, and setting exact row/column sizes.

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.IsLineScan Property

[image]

In-Sight SDK
CvsProcessorConstants..::..IsLineScan Property
CvsProcessorConstants Class See Also Send Feedback
Gets the flag that determines if the processor acquires line scan images.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsLineScan { get; }
Visual Basic
Public ReadOnly Property IsLineScan As Boolean
    Get

Property Value

Type: Boolean
true if the processor acquires line scan images; otherwise, false.

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.IsOpcSupported Property

[image]

In-Sight SDK
CvsProcessorConstants..::..IsOpcSupported Property
CvsProcessorConstants Class See Also Send Feedback
Gets the flag that determines if the processor supports OPC tags.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsOpcSupported { get; }
Visual Basic
Public ReadOnly Property IsOpcSupported As Boolean
    Get

Property Value

Type: Boolean
true if the processor supports the setting of OPC tags; otherwise, false.

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.IsUndoSupported Property

[image]

In-Sight SDK
CvsProcessorConstants..::..IsUndoSupported Property
CvsProcessorConstants Class See Also Send Feedback
Gets the flag that determines if the processor supports undo, allowing the user to undo and redo changes made with the display control.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsUndoSupported { get; }
Visual Basic
Public ReadOnly Property IsUndoSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.MaxExpressionLength Property

[image]

In-Sight SDK
CvsProcessorConstants..::..MaxExpressionLength Property
CvsProcessorConstants Class See Also Send Feedback
Gets the maximum expression length.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxExpressionLength { get; }
Visual Basic
Public ReadOnly Property MaxExpressionLength As Integer
    Get

Property Value

Type: Int32

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.MaxExpressionStack Property

[image]

In-Sight SDK
CvsProcessorConstants..::..MaxExpressionStack Property
CvsProcessorConstants Class See Also Send Feedback
Gets the maximum number of items that can comprise an expression.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxExpressionStack { get; }
Visual Basic
Public ReadOnly Property MaxExpressionStack As Integer
    Get

Property Value

Type: Int32

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.MaxFileNameLength Property

[image]

In-Sight SDK
CvsProcessorConstants..::..MaxFileNameLength Property
CvsProcessorConstants Class See Also Send Feedback
Gets the maximum file name length, including the extension.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxFileNameLength { get; }
Visual Basic
Public ReadOnly Property MaxFileNameLength As Integer
    Get

Property Value

Type: Int32

Remarks

The length is the actual number of editable characters and does not include a null terminator.

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.MaxSpreadsheetCells Property

[image]

In-Sight SDK
CvsProcessorConstants..::..MaxSpreadsheetCells Property
CvsProcessorConstants Class See Also Send Feedback
Gets the maximum number of cells allowed in the spreadsheet.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxSpreadsheetCells { get; }
Visual Basic
Public ReadOnly Property MaxSpreadsheetCells As Integer
    Get

Property Value

Type: Int32

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.MaxStringLength Property

[image]

In-Sight SDK
CvsProcessorConstants..::..MaxStringLength Property
CvsProcessorConstants Class See Also Send Feedback
Gets the maximum string length.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxStringLength { get; }
Visual Basic
Public ReadOnly Property MaxStringLength As Integer
    Get

Property Value

Type: Int32

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.SpreadsheetColumns Property

[image]

In-Sight SDK
CvsProcessorConstants..::..SpreadsheetColumns Property
CvsProcessorConstants Class See Also Send Feedback
Gets the number of columns in the main spreadsheet.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int SpreadsheetColumns { get; }
Visual Basic
Public ReadOnly Property SpreadsheetColumns As Integer
    Get

Property Value

Type: Int32

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.SpreadsheetRange Property

[image]

In-Sight SDK
CvsProcessorConstants..::..SpreadsheetRange Property
CvsProcessorConstants Class See Also Send Feedback
Gets a cell range representing the overall range of cells in the main spreadsheet, not including dialogs.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsCellRange SpreadsheetRange { get; }
Visual Basic
Public ReadOnly Property SpreadsheetRange As CvsCellRange
    Get

Property Value

Type: CvsCellRange

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.SpreadsheetRows Property

[image]

In-Sight SDK
CvsProcessorConstants..::..SpreadsheetRows Property
CvsProcessorConstants Class See Also Send Feedback
Gets the number of rows in the main spreadsheet, not including the dialog rows.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int SpreadsheetRows { get; }
Visual Basic
Public ReadOnly Property SpreadsheetRows As Integer
    Get

Property Value

Type: Int32

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProcessorConstants.SpreadsheetTotalRows Property

[image]

In-Sight SDK
CvsProcessorConstants..::..SpreadsheetTotalRows Property
CvsProcessorConstants Class See Also Send Feedback
Gets the total number of rows in the spreadsheet, including the dialog rows.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int SpreadsheetTotalRows { get; }
Visual Basic
Public ReadOnly Property SpreadsheetTotalRows As Integer
    Get

Property Value

Type: Int32

See Also

CvsProcessorConstants Class
CvsProcessorConstants..::..CvsProcessorConstants Members
Cognex.InSight.Sensor Namespace


CvsProtocols Enumeration

[image]

In-Sight SDK
CvsProtocols Enumeration
See Also Send Feedback
Protocols that may be secured by an CvsIPsecRule.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsProtocols
Visual Basic
Public Enumeration CvsProtocols

Members

Member name | Value | Description
Any | 0 | Any
TCP | 1 | TCP
UDP | 2 | UDP
None | -1 | None

See Also

Cognex.InSight.Sensor Namespace
CvsIPsecRule


CvsProtocolServices Enumeration

[image]

In-Sight SDK
CvsProtocolServices Enumeration
See Also Send Feedback
An enumeration of protocol services that may be enabled or disabled.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[FlagsAttribute]
public enum CvsProtocolServices
Visual Basic
<FlagsAttribute>
Public Enumeration CvsProtocolServices

Members

Member name | Value | Description
None | 0 |
Melsec | 0 | The Melsec protocol service.
Modbus | 1 | The Modbus service.
EipService | 2 | The EtherNet/IP service.
ProfiNetService | 4 | The ProfiNet service.
PTP | 8 | PTP Synchronization.
MCProtocolScanner | 16 | MC Protocol Scanner.
Powerlink | 32 | Powerlink.
IQSS | 64 | iQ Sensor Solution.
CcLinkIEFB | 128 | CC-Link IE Field Basic.
OpcUA | 256 | The OPC UA protocol service.
All | 511 | All of the protocol services OR'ed together.

See Also

Cognex.InSight.Sensor Namespace


CvsProtocolServicesInfo Class

[image]

In-Sight SDK
CvsProtocolServicesInfo Class
Members See Also Send Feedback
Holds which CvsProtocolServices are mutually exclusive and which are not.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public sealed class CvsProtocolServicesInfo
Visual Basic
Public NotInheritable Class CvsProtocolServicesInfo

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsProtocolServicesInfo

See Also

CvsProtocolServicesInfo..::..CvsProtocolServicesInfo Members
Cognex.InSight.Sensor Namespace


CvsProtocolServicesInfo Members

[image] [image]

In-Sight SDK
CvsProtocolServicesInfo Members
CvsProtocolServicesInfo Class Constructors Methods Fields See Also Send Feedback

The CvsProtocolServicesInfo type exposes the following members.

Constructors

 | Name | Description
Public method | CvsProtocolServicesInfo | Initializes a new instance of the CvsProtocolServicesInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Exclusive | Protocol services which can't be enabled at the same time.
Public field | Inclusive | Protocol services which can be enabled at the same time.

See Also

CvsProtocolServicesInfo Class
Cognex.InSight.Sensor Namespace


CvsProtocolServicesInfo Constructor

[image]

In-Sight SDK
CvsProtocolServicesInfo Constructor
CvsProtocolServicesInfo Class See Also Send Feedback
Initializes a new instance of the CvsProtocolServicesInfo class

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsProtocolServicesInfo()
Visual Basic
Public Sub New

See Also

CvsProtocolServicesInfo Class
CvsProtocolServicesInfo..::..CvsProtocolServicesInfo Members
Cognex.InSight.Sensor Namespace


CvsProtocolServicesInfo Fields

[image] [image]

In-Sight SDK
CvsProtocolServicesInfo Fields
CvsProtocolServicesInfo Class See Also Send Feedback

The CvsProtocolServicesInfo type exposes the following members.

Fields

 | Name | Description
Public field | Exclusive | Protocol services which can't be enabled at the same time.
Public field | Inclusive | Protocol services which can be enabled at the same time.

See Also

CvsProtocolServicesInfo Class
Cognex.InSight.Sensor Namespace


CvsProtocolServicesInfo.Exclusive Field

[image]

In-Sight SDK
CvsProtocolServicesInfo..::..Exclusive Field
CvsProtocolServicesInfo Class See Also Send Feedback
Protocol services which can't be enabled at the same time.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsProtocolServices[] Exclusive
Visual Basic
Public Exclusive As CvsProtocolServices()

Field Value

Type: array< CvsProtocolServices >[]()[][]

See Also

CvsProtocolServicesInfo Class
CvsProtocolServicesInfo..::..CvsProtocolServicesInfo Members
Cognex.InSight.Sensor Namespace


CvsProtocolServicesInfo.Inclusive Field

[image]

In-Sight SDK
CvsProtocolServicesInfo..::..Inclusive Field
CvsProtocolServicesInfo Class See Also Send Feedback
Protocol services which can be enabled at the same time.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsProtocolServices[] Inclusive
Visual Basic
Public Inclusive As CvsProtocolServices()

Field Value

Type: array< CvsProtocolServices >[]()[][]

See Also

CvsProtocolServicesInfo Class
CvsProtocolServicesInfo..::..CvsProtocolServicesInfo Members
Cognex.InSight.Sensor Namespace


CvsProtocolServicesInfo Methods

[image] [image]

In-Sight SDK
CvsProtocolServicesInfo Methods
CvsProtocolServicesInfo Class See Also Send Feedback

The CvsProtocolServicesInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsProtocolServicesInfo Class
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection Class

[image]

In-Sight SDK
CvsRemoteSubnetCollection Class
Members See Also Send Feedback
Represents a collection of subnet entries.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsRemoteSubnetCollection : ICollection<CvsRemoteSubnetEntry>,
    IEnumerable<CvsRemoteSubnetEntry>, IEnumerable, ICloneable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsRemoteSubnetCollection
    Implements ICollection(Of CvsRemoteSubnetEntry), IEnumerable(Of CvsRemoteSubnetEntry),
    IEnumerable, ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsRemoteSubnetCollection

See Also

CvsRemoteSubnetCollection..::..CvsRemoteSubnetCollection Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection Members

[image] [image]

In-Sight SDK
CvsRemoteSubnetCollection Members
CvsRemoteSubnetCollection Class Constructors Methods Properties See Also Send Feedback

The CvsRemoteSubnetCollection type exposes the following members.

Constructors

 | Name | Description
Public method | CvsRemoteSubnetCollection()()()() | Creates an empty collection of subnet entries.
Public method | CvsRemoteSubnetCollection(IEnumerable<(Of <<'(CvsRemoteSubnetEntry>)>>)) | Creates a collection of subnet entries filled with the specified entries.

Methods

 | Name | Description
Public method | Add | Adds a new subnet entry.
Public method | Clear | Immediately clears all entries from the collection.
Public method | Clone | Creates a deep copy of the collection and the entries.
Public method | Contains | Determines whether an entry exists in the collection.
Public method | CopyTo | Copies the collection to the specified array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Retrieves an enumerator that iterates over the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of the entry.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of entries.
Public property | Item | Retrieves the entry at the specifed index.

See Also

CvsRemoteSubnetCollection Class
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection Constructor

[image] [image]

In-Sight SDK
CvsRemoteSubnetCollection Constructor
CvsRemoteSubnetCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsRemoteSubnetCollection()()()() | Creates an empty collection of subnet entries.
Public method | CvsRemoteSubnetCollection(IEnumerable<(Of <<'(CvsRemoteSubnetEntry>)>>)) | Creates a collection of subnet entries filled with the specified entries.

See Also

CvsRemoteSubnetCollection Class
CvsRemoteSubnetCollection..::..CvsRemoteSubnetCollection Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection Constructor

[image]

In-Sight SDK
CvsRemoteSubnetCollection Constructor
CvsRemoteSubnetCollection Class See Also Send Feedback
Creates an empty collection of subnet entries.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsRemoteSubnetCollection()
Visual Basic
Public Sub New

See Also

CvsRemoteSubnetCollection Class
CvsRemoteSubnetCollection..::..CvsRemoteSubnetCollection Members
CvsRemoteSubnetCollection Overload
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection Constructor (IEnumerable(CvsRemoteSubnetEntry))

[image]

In-Sight SDK
CvsRemoteSubnetCollection Constructor (IEnumerable<(Of <(<'CvsRemoteSubnetEntry>)>)>)
CvsRemoteSubnetCollection Class See Also Send Feedback
Creates a collection of subnet entries filled with the specified entries.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsRemoteSubnetCollection(
    IEnumerable<CvsRemoteSubnetEntry> entries
)
Visual Basic
Public Sub New (
    entries As IEnumerable(Of CvsRemoteSubnetEntry)
)

Parameters

entries
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' CvsRemoteSubnetEntry >)>)>
The entries to initialize this collection with.

See Also

CvsRemoteSubnetCollection Class
CvsRemoteSubnetCollection..::..CvsRemoteSubnetCollection Members
CvsRemoteSubnetCollection Overload
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection Methods

[image] [image]

In-Sight SDK
CvsRemoteSubnetCollection Methods
CvsRemoteSubnetCollection Class See Also Send Feedback

The CvsRemoteSubnetCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a new subnet entry.
Public method | Clear | Immediately clears all entries from the collection.
Public method | Clone | Creates a deep copy of the collection and the entries.
Public method | Contains | Determines whether an entry exists in the collection.
Public method | CopyTo | Copies the collection to the specified array.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Retrieves an enumerator that iterates over the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of the entry.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsRemoteSubnetCollection Class
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection.Add Method

[image]

In-Sight SDK
CvsRemoteSubnetCollection..::..Add Method
CvsRemoteSubnetCollection Class See Also Send Feedback
Adds a new subnet entry.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Add(
    CvsRemoteSubnetEntry item
)
Visual Basic
Public Sub Add (
    item As CvsRemoteSubnetEntry
)

Parameters

item
Type: Cognex.InSight.Sensor..::..CvsRemoteSubnetEntry
The entry to add.

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

CvsRemoteSubnetCollection Class
CvsRemoteSubnetCollection..::..CvsRemoteSubnetCollection Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection.Clear Method

[image]

In-Sight SDK
CvsRemoteSubnetCollection..::..Clear Method
CvsRemoteSubnetCollection Class See Also Send Feedback
Immediately clears all entries from the collection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

CvsRemoteSubnetCollection Class
CvsRemoteSubnetCollection..::..CvsRemoteSubnetCollection Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection.Clone Method

[image]

In-Sight SDK
CvsRemoteSubnetCollection..::..Clone Method
CvsRemoteSubnetCollection Class See Also Send Feedback
Creates a deep copy of the collection and the entries.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A deep copy of the collection.

Implements

ICloneable..::..Clone()()()()

See Also

CvsRemoteSubnetCollection Class
CvsRemoteSubnetCollection..::..CvsRemoteSubnetCollection Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection.Contains Method

[image]

In-Sight SDK
CvsRemoteSubnetCollection..::..Contains Method
CvsRemoteSubnetCollection Class See Also Send Feedback
Determines whether an entry exists in the collection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Contains(
    CvsRemoteSubnetEntry item
)
Visual Basic
Public Function Contains (
    item As CvsRemoteSubnetEntry
) As Boolean

Parameters

item
Type: Cognex.InSight.Sensor..::..CvsRemoteSubnetEntry
The entry to check for.

Return Value

Type: Boolean
Returns true if the entry is found; otherwise false.

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

CvsRemoteSubnetCollection Class
CvsRemoteSubnetCollection..::..CvsRemoteSubnetCollection Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection.CopyTo Method

[image]

In-Sight SDK
CvsRemoteSubnetCollection..::..CopyTo Method
CvsRemoteSubnetCollection Class See Also Send Feedback
Copies the collection to the specified array.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void CopyTo(
    CvsRemoteSubnetEntry[] array,
    int arrayIndex
)
Visual Basic
Public Sub CopyTo (
    array As CvsRemoteSubnetEntry(),
    arrayIndex As Integer
)

Parameters

array
Type: array< Cognex.InSight.Sensor..::..CvsRemoteSubnetEntry >[]()[][]
The array to copy to.
arrayIndex
Type: System..::..Int32
The index within the array to start copying to.

Implements

ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)

See Also

CvsRemoteSubnetCollection Class
CvsRemoteSubnetCollection..::..CvsRemoteSubnetCollection Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection.GetEnumerator Method

[image]

In-Sight SDK
CvsRemoteSubnetCollection..::..GetEnumerator Method
CvsRemoteSubnetCollection Class See Also Send Feedback
Retrieves an enumerator that iterates over the collection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerator<CvsRemoteSubnetEntry> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of CvsRemoteSubnetEntry)

Return Value

Type: IEnumerator <(Of <(<' CvsRemoteSubnetEntry >)>)>
The enumerator used for iteration.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

CvsRemoteSubnetCollection Class
CvsRemoteSubnetCollection..::..CvsRemoteSubnetCollection Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection.Remove Method

[image]

In-Sight SDK
CvsRemoteSubnetCollection..::..Remove Method
CvsRemoteSubnetCollection Class See Also Send Feedback
Removes the first occurrence of the entry.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Remove(
    CvsRemoteSubnetEntry item
)
Visual Basic
Public Function Remove (
    item As CvsRemoteSubnetEntry
) As Boolean

Parameters

item
Type: Cognex.InSight.Sensor..::..CvsRemoteSubnetEntry
The entry to remove.

Return Value

Type: Boolean
Returns true if the entry was found and removed; otherwise false.

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

CvsRemoteSubnetCollection Class
CvsRemoteSubnetCollection..::..CvsRemoteSubnetCollection Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection Properties

[image] [image]

In-Sight SDK
CvsRemoteSubnetCollection Properties
CvsRemoteSubnetCollection Class See Also Send Feedback

The CvsRemoteSubnetCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of entries.
Public property | Item | Retrieves the entry at the specifed index.

See Also

CvsRemoteSubnetCollection Class
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection.Count Property

[image]

In-Sight SDK
CvsRemoteSubnetCollection..::..Count Property
CvsRemoteSubnetCollection Class See Also Send Feedback
Gets the number of entries.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

CvsRemoteSubnetCollection Class
CvsRemoteSubnetCollection..::..CvsRemoteSubnetCollection Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetCollection.Item Property

[image]

In-Sight SDK
CvsRemoteSubnetCollection..::..Item Property
CvsRemoteSubnetCollection Class See Also Send Feedback
Retrieves the entry at the specifed index.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsRemoteSubnetEntry this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As CvsRemoteSubnetEntry
    Get

Parameters

index
Type: System..::..Int32
The index of the entry to retrieve.

Return Value

Type: CvsRemoteSubnetEntry
The entry at the specified index.

See Also

CvsRemoteSubnetCollection Class
CvsRemoteSubnetCollection..::..CvsRemoteSubnetCollection Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry Class

[image]

In-Sight SDK
CvsRemoteSubnetEntry Class
Members See Also Send Feedback
Represents a remote subnet entry.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public class CvsRemoteSubnetEntry : ICloneable
Visual Basic
<SerializableAttribute>
Public Class CvsRemoteSubnetEntry
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsRemoteSubnetEntry

See Also

CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry Members

[image] [image]

In-Sight SDK
CvsRemoteSubnetEntry Members
CvsRemoteSubnetEntry Class Constructors Methods Properties See Also Send Feedback

The CvsRemoteSubnetEntry type exposes the following members.

Constructors

 | Name | Description
Public method | CvsRemoteSubnetEntry(CvsRemoteSubnetEntry) | Creates a new subnet entry filling it with the data of another entry.
Public method | CvsRemoteSubnetEntry(String, IPAddress, IPAddress, Boolean, IPAddress) | Creates a new subnet entry.

Methods

 | Name | Description
Public method | Clone | Creates a deep copy of the entry.
Public method | Equals | Determines whether or not the entry is equivalent to another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Creates a hash of the entry. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Determines whether or not the entry matches another entry.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a representation of this entry. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CustomGateway | Gets or sets the address of the custom gateway.
Public property | CustomGatewayEnabled | Gets or sets if the custom gateway is enabled.
Public property | IPAddress | Gets or sets the IP address of the entry.
Public property | Mask | Gets or sets the subnet mask of the entry.
Public property | Name | Gets or sets the name of the entry.

See Also

CvsRemoteSubnetEntry Class
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry Constructor

[image] [image]

In-Sight SDK
CvsRemoteSubnetEntry Constructor
CvsRemoteSubnetEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsRemoteSubnetEntry(CvsRemoteSubnetEntry) | Creates a new subnet entry filling it with the data of another entry.
Public method | CvsRemoteSubnetEntry(String, IPAddress, IPAddress, Boolean, IPAddress) | Creates a new subnet entry.

See Also

CvsRemoteSubnetEntry Class
CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry Constructor (CvsRemoteSubnetEntry)

[image]

In-Sight SDK
CvsRemoteSubnetEntry Constructor (CvsRemoteSubnetEntry)
CvsRemoteSubnetEntry Class See Also Send Feedback
Creates a new subnet entry filling it with the data of another entry.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsRemoteSubnetEntry(
    CvsRemoteSubnetEntry other
)
Visual Basic
Public Sub New (
    other As CvsRemoteSubnetEntry
)

Parameters

other
Type: Cognex.InSight.Sensor..::..CvsRemoteSubnetEntry
The entry to pull data from.

See Also

CvsRemoteSubnetEntry Class
CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
CvsRemoteSubnetEntry Overload
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry Constructor (String, IPAddress, IPAddress, Boolean, IPAddress)

[image]

In-Sight SDK
CvsRemoteSubnetEntry Constructor (String, IPAddress, IPAddress, Boolean, IPAddress)
CvsRemoteSubnetEntry Class See Also Send Feedback
Creates a new subnet entry.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsRemoteSubnetEntry(
    string name,
    IPAddress address,
    IPAddress mask,
    bool customGatewayEnabled,
    IPAddress customGateway
)
Visual Basic
Public Sub New (
    name As String,
    address As IPAddress,
    mask As IPAddress,
    customGatewayEnabled As Boolean,
    customGateway As IPAddress
)

Parameters

name
Type: System..::..String
The name of the entry.
address
Type: System.Net..::..IPAddress
The IP address of the entry.
mask
Type: System.Net..::..IPAddress
The subnet mask of the entry.
customGatewayEnabled
Type: System..::..Boolean
Whether or not the custom gateway is enabled.
customGateway
Type: System.Net..::..IPAddress
The custom gateway address of the entry.

See Also

CvsRemoteSubnetEntry Class
CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
CvsRemoteSubnetEntry Overload
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry Methods

[image] [image]

In-Sight SDK
CvsRemoteSubnetEntry Methods
CvsRemoteSubnetEntry Class See Also Send Feedback

The CvsRemoteSubnetEntry type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a deep copy of the entry.
Public method | Equals | Determines whether or not the entry is equivalent to another object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Creates a hash of the entry. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Determines whether or not the entry matches another entry.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a representation of this entry. (Overrides Object..::..ToString()()()().)

See Also

CvsRemoteSubnetEntry Class
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry.Clone Method

[image]

In-Sight SDK
CvsRemoteSubnetEntry..::..Clone Method
CvsRemoteSubnetEntry Class See Also Send Feedback
Creates a deep copy of the entry.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A deep copy of the entry.

Implements

ICloneable..::..Clone()()()()

See Also

CvsRemoteSubnetEntry Class
CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry.Equals Method

[image]

In-Sight SDK
CvsRemoteSubnetEntry..::..Equals Method
CvsRemoteSubnetEntry Class See Also Send Feedback
Determines whether or not the entry is equivalent to another object.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: System..::..Object
The object to check.

Return Value

Type: Boolean
Returns true if the entries are equivalent; otherwise false.

See Also

CvsRemoteSubnetEntry Class
CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry.GetHashCode Method

[image]

In-Sight SDK
CvsRemoteSubnetEntry..::..GetHashCode Method
CvsRemoteSubnetEntry Class See Also Send Feedback
Creates a hash of the entry.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value containing the hash for the entry.

See Also

CvsRemoteSubnetEntry Class
CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry.Matches Method

[image]

In-Sight SDK
CvsRemoteSubnetEntry..::..Matches Method
CvsRemoteSubnetEntry Class See Also Send Feedback
Determines whether or not the entry matches another entry.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Matches(
    CvsRemoteSubnetEntry other
)
Visual Basic
Public Function Matches (
    other As CvsRemoteSubnetEntry
) As Boolean

Parameters

other
Type: Cognex.InSight.Sensor..::..CvsRemoteSubnetEntry
The entry to compare to.

Return Value

Type: Boolean
Returns true if the entries match; otherwise false.

See Also

CvsRemoteSubnetEntry Class
CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry.ToString Method

[image]

In-Sight SDK
CvsRemoteSubnetEntry..::..ToString Method
CvsRemoteSubnetEntry Class See Also Send Feedback
Creates a representation of this entry.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
Returns the name.

See Also

CvsRemoteSubnetEntry Class
CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry Properties

[image] [image]

In-Sight SDK
CvsRemoteSubnetEntry Properties
CvsRemoteSubnetEntry Class See Also Send Feedback

The CvsRemoteSubnetEntry type exposes the following members.

Properties

 | Name | Description
Public property | CustomGateway | Gets or sets the address of the custom gateway.
Public property | CustomGatewayEnabled | Gets or sets if the custom gateway is enabled.
Public property | IPAddress | Gets or sets the IP address of the entry.
Public property | Mask | Gets or sets the subnet mask of the entry.
Public property | Name | Gets or sets the name of the entry.

See Also

CvsRemoteSubnetEntry Class
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry.CustomGateway Property

[image]

In-Sight SDK
CvsRemoteSubnetEntry..::..CustomGateway Property
CvsRemoteSubnetEntry Class See Also Send Feedback
Gets or sets the address of the custom gateway.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress CustomGateway { get; set; }
Visual Basic
Public Property CustomGateway As IPAddress
    Get
    Set

Property Value

Type: IPAddress

See Also

CvsRemoteSubnetEntry Class
CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry.CustomGatewayEnabled Property

[image]

In-Sight SDK
CvsRemoteSubnetEntry..::..CustomGatewayEnabled Property
CvsRemoteSubnetEntry Class See Also Send Feedback
Gets or sets if the custom gateway is enabled.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CustomGatewayEnabled { get; set; }
Visual Basic
Public Property CustomGatewayEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsRemoteSubnetEntry Class
CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry.IPAddress Property

[image]

In-Sight SDK
CvsRemoteSubnetEntry..::..IPAddress Property
CvsRemoteSubnetEntry Class See Also Send Feedback
Gets or sets the IP address of the entry.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress IPAddress { get; set; }
Visual Basic
Public Property IPAddress As IPAddress
    Get
    Set

Property Value

Type: IPAddress

See Also

CvsRemoteSubnetEntry Class
CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry.Mask Property

[image]

In-Sight SDK
CvsRemoteSubnetEntry..::..Mask Property
CvsRemoteSubnetEntry Class See Also Send Feedback
Gets or sets the subnet mask of the entry.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IPAddress Mask { get; set; }
Visual Basic
Public Property Mask As IPAddress
    Get
    Set

Property Value

Type: IPAddress

See Also

CvsRemoteSubnetEntry Class
CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
Cognex.InSight.Sensor Namespace


CvsRemoteSubnetEntry.Name Property

[image]

In-Sight SDK
CvsRemoteSubnetEntry..::..Name Property
CvsRemoteSubnetEntry Class See Also Send Feedback
Gets or sets the name of the entry.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

CvsRemoteSubnetEntry Class
CvsRemoteSubnetEntry..::..CvsRemoteSubnetEntry Members
Cognex.InSight.Sensor Namespace


CvsSensor Class

[image]

In-Sight SDK
CvsSensor Class
Members See Also Send Feedback
Provides access to the sensor settings and processor constants for an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsSensor : MarshalByRefObject,
    ICvsSupportedSettings
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsSensor
    Inherits MarshalByRefObject
    Implements ICvsSupportedSettings

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
Cognex.InSight.Sensor..::..CvsSensor

See Also

CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor Members

[image] [image]

In-Sight SDK
CvsSensor Members
CvsSensor Class Methods Properties See Also Send Feedback

The CvsSensor type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDefaultRegion | Returns the CvsDefaultRegion object from the In-Sight sensor.
Public method | GetEzToolSettings | Get the settings for the tool based on the tool's guid.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHmiSettings | Gets the current HMI settings from the In-Sight.
Public method | GetHttpsEnabled | Gets whether the In-Sight has HTTPS mode configured and successfully running.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLocalStorageState | Gets a value indicating if the state of the SD Card.
Public method | GetPortsInUse | Returns a dictionary containing the ports used by the In-Sight.
 | GetSensorID(CvsHost, String) | Creates a device specific identifier based on the information provided. The identifier can be used to identify a device.
 | GetSensorID(CvsHostType, String, String, String) | Creates a device specific identifier based on the information provided. The identifier can be used to identify a device.
Public method | GetSettings | Returns a copy of the processor settings received from the In-Sight sensor.
Public method | GetSntpCurrentData | Returns the CvsSntpCurrentData object from the In-Sight sensor.
Public method | GetTimeZones | Returns the CvsTimeZones object from the In-Sight sensor.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsEzToolEnabled | Gets a value indicating whether the tool is enabled based on the tool's Guid. Tool may still be disabled based on function security bits.
 | IsImprovedEncryptionSupported(Version) | Determines whether or not the version of the sensor's firmware supports Improved Encryption.
 | IsImprovedEncryptionSupported(CvsHostVersion) | Determines whether or not the version of the sensor's firmware supports Improved Encryption.
Public method | SerialPortSupported | Gets a value that determines if the specified serial port is supported.
Public method | SetHmiSettings | Sends new HMI settings to the In-Sight.
Public method | SetSettings | Sends the CvsSettings object to the In-Sight sensor.
Public method | SetTimeDateData | Sends the CvsTimeDateData object to the In-Sight sensor.
Public method | SupportsTool | Determines if the sensor supports a particular tool.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCellName | Validates the length and characters of a cell name.

Properties

 | Name | Description
Public property | AllEzToolsEnabled | Gets a value indicating that all Ez Tools are enabled. Tools may still be disabled based on function security bits.
Public property | AuditMessagesSupported | Gets a value that determines if audit messages are supported.
Public property | BufferSize | The buffer size on the sensor. 4000 for newer firmware, 256 for older firmware.
Public property | BuildDateTime | Gets the date and time of the firmware build on the In-Sight sensor.
Public property | DiscreteIOSupported | Gets a value that determines if Discrete Input or Output is supported, either local or expansion.
Public property | EncoderOutputSupported | Gets a value indicating whether encoder output is supported.
Public property | ExternalLightSettingsSupported | Gets a value that determines if the External Light Settings are supported.
Public property | FirmwareDrivenTestRunSupported | Gets a value that determines if TestRun is supported directly on this device.
Public property | FirmwareUpgradeFilename | Gets the firmware upgrade filename used to update this In-Sight sensor type.
Public property | FirmwareUpgradeReconnectDelay | Gets the delay between reconnect attempts.
Public property | GuiActionRequestEventSupported | Gets a value that indicates if the GuiActionRequest event is supported.
Public property | HmiServerSupported | Gets a value that determines if a the HMI Server is supported.
Public property | HostName | Gets the host name associated with the In-Sight sensor.
Public property | ImageResolutionSupported | Gets a value that determines if modifying the image resolution is supported.
Public property | ImportExportSupported | Gets a value that determines if cell import/export is supported.
Public property | Is2000Series | Returns true if the sensor is an InSight 2000 model.
Public property | Is8000Series | Returns true if the sensor is an InSight 8000 model.
Public property | IsColor | Gets a value that determines if the sensor is a color sensor.
Public property | LicensingSupported | Gets a value that determines if licensing is supported.
Public property | MacAddress | Gets the MAC address of the In-Sight sensor.
Public property | MacAddressLong | Gets the Mac address as a long value.
Public property | MaxCellNameLength | Gets the maximum cell name length in bytes.
Public property | MaxGuiConnections | Gets the maximum number of GUI connections (ISE, VisionView, and WebHMI) that the In-Sight supports.
Public property | MaxUserListLength | Gets the maximum number of entries allowed in the list of users.
Public property | ModelNumber | Gets the model number as a string. (i.e. 5100, 5400C, 1700, etc.)
Public property | PowerlinkSettingsSupported | Gets a value that determines if the POWERLINK settings are supported.
Public property | ProcessorConstants | Gets the processor constants associated with the In-Sight sensor.
Public property | RamDiskSupported | Gets a value that determines if a RAM disk is supported.
Public property | RecordModeOnSensorSupported | Gets a value that determines if the record mode is supported on the sensor. That is, if the bit depth, image resolution and max image acquisition rate for recording are supported in firmware.
Public property | RemoteJobServerSupported | Gets a value that determines if a Remote Job Server is supported.
Public property | RepresentedSystemSubtype | Gets the represented system subtype. For instance, if the SystemSubtype is emulator emulating a 7000, this will return 7000Series. If this is not an emulator, this will return the same value as SystemSubtype.
Public property | ScriptingSupported | Gets a value that determines if Scripting is supported on this device.
Public property | SerialNumber | Gets the serial number.
Public property | SntpSupported | Gets a value that determines if SNTP is supported.
Public property | SpreadsheetSupported | Gets a value that determines if the spreadsheet is allowed for this sensor.
Public property | SupportedProtocols | Gets the supported protocols for the Sensor. Returns 'None' if the command is not supported, or the Sensor is not connected.
Public property | SystemSubtype | Gets the system subtype.
Public property | SystemType | Gets the system type.
Public property | Version | Gets the firmware version.

See Also

CvsSensor Class
Cognex.InSight.Sensor Namespace


CvsSensor Methods

[image] [image]

In-Sight SDK
CvsSensor Methods
CvsSensor Class See Also Send Feedback

The CvsSensor type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDefaultRegion | Returns the CvsDefaultRegion object from the In-Sight sensor.
Public method | GetEzToolSettings | Get the settings for the tool based on the tool's guid.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHmiSettings | Gets the current HMI settings from the In-Sight.
Public method | GetHttpsEnabled | Gets whether the In-Sight has HTTPS mode configured and successfully running.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLocalStorageState | Gets a value indicating if the state of the SD Card.
Public method | GetPortsInUse | Returns a dictionary containing the ports used by the In-Sight.
 | GetSensorID(CvsHost, String) | Creates a device specific identifier based on the information provided. The identifier can be used to identify a device.
 | GetSensorID(CvsHostType, String, String, String) | Creates a device specific identifier based on the information provided. The identifier can be used to identify a device.
Public method | GetSettings | Returns a copy of the processor settings received from the In-Sight sensor.
Public method | GetSntpCurrentData | Returns the CvsSntpCurrentData object from the In-Sight sensor.
Public method | GetTimeZones | Returns the CvsTimeZones object from the In-Sight sensor.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsEzToolEnabled | Gets a value indicating whether the tool is enabled based on the tool's Guid. Tool may still be disabled based on function security bits.
 | IsImprovedEncryptionSupported(Version) | Determines whether or not the version of the sensor's firmware supports Improved Encryption.
 | IsImprovedEncryptionSupported(CvsHostVersion) | Determines whether or not the version of the sensor's firmware supports Improved Encryption.
Public method | SerialPortSupported | Gets a value that determines if the specified serial port is supported.
Public method | SetHmiSettings | Sends new HMI settings to the In-Sight.
Public method | SetSettings | Sends the CvsSettings object to the In-Sight sensor.
Public method | SetTimeDateData | Sends the CvsTimeDateData object to the In-Sight sensor.
Public method | SupportsTool | Determines if the sensor supports a particular tool.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCellName | Validates the length and characters of a cell name.

See Also

CvsSensor Class
Cognex.InSight.Sensor Namespace


CvsSensor.GetDefaultRegion Method

[image]

In-Sight SDK
CvsSensor..::..GetDefaultRegion Method
CvsSensor Class See Also Send Feedback
Returns the CvsDefaultRegion object from the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsDefaultRegion GetDefaultRegion()
Visual Basic
Public Function GetDefaultRegion As CvsDefaultRegion

Return Value

Type: CvsDefaultRegion
A CvsDefaultRegion object that describes the default region for the current In-Sight connection, or a null reference (Nothing in Visual Basic) if the State is CvsInSightState.NotConnected.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.GetEzToolSettings Method

[image]

In-Sight SDK
CvsSensor..::..GetEzToolSettings Method
CvsSensor Class See Also Send Feedback
Get the settings for the tool based on the tool's guid.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsEzToolSettings GetEzToolSettings(
    Guid guid
)
Visual Basic
Public Function GetEzToolSettings (
    guid As Guid
) As CvsEzToolSettings

Parameters

guid
Type: System..::..Guid
The tool's guid.

Return Value

Type: CvsEzToolSettings
The settings for the tool if they exist; otherwise, null.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.GetHmiSettings Method

[image]

In-Sight SDK
CvsSensor..::..GetHmiSettings Method
CvsSensor Class See Also Send Feedback
Gets the current HMI settings from the In-Sight.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHmiSettings GetHmiSettings(
    bool forceUpdate
)
Visual Basic
Public Function GetHmiSettings (
    forceUpdate As Boolean
) As CvsHmiSettings

Parameters

forceUpdate
Type: System..::..Boolean

[Missing <param name="forceUpdate"/> documentation for "M:Cognex.InSight.Sensor.CvsSensor.GetHmiSettings(System.Boolean)"]

Return Value

Type: CvsHmiSettings
Returns the settings or null if HmiServerSupported is false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace
CvsSensor..::..HmiServerSupported
CvsSensor..::..SetHmiSettings(CvsHmiSettings)


CvsSensor.GetHttpsEnabled Method

[image]

In-Sight SDK
CvsSensor..::..GetHttpsEnabled Method
CvsSensor Class See Also Send Feedback
Gets whether the In-Sight has HTTPS mode configured and successfully running.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool GetHttpsEnabled()
Visual Basic
Public Function GetHttpsEnabled As Boolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Sensor.CvsSensor.GetHttpsEnabled"]

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.GetLocalStorageState Method

[image]

In-Sight SDK
CvsSensor..::..GetLocalStorageState Method
CvsSensor Class See Also Send Feedback
Gets a value indicating if the state of the SD Card.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsLocalStorageState GetLocalStorageState()
Visual Basic
Public Function GetLocalStorageState As CvsLocalStorageState

Return Value

Type: CvsLocalStorageState

[Missing <returns> documentation for "M:Cognex.InSight.Sensor.CvsSensor.GetLocalStorageState"]

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.GetPortsInUse Method

[image]

In-Sight SDK
CvsSensor..::..GetPortsInUse Method
CvsSensor Class See Also Send Feedback
Returns a dictionary containing the ports used by the In-Sight.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IDictionary<CvsInSightPorts, int> GetPortsInUse()
Visual Basic
Public Function GetPortsInUse As IDictionary(Of CvsInSightPorts, Integer)

Return Value

Type: IDictionary <(Of <(<' CvsInSightPorts, Int32 >)>)>

[Missing <returns> documentation for "M:Cognex.InSight.Sensor.CvsSensor.GetPortsInUse"]

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.GetSensorID Method

[image] [image]

In-Sight SDK
CvsSensor..::..GetSensorID Method
CvsSensor Class See Also Send Feedback

Overload List

Name | Description
GetSensorID(CvsHost, String) | Creates a device specific identifier based on the information provided. The identifier can be used to identify a device.
GetSensorID(CvsHostType, String, String, String) | Creates a device specific identifier based on the information provided. The identifier can be used to identify a device.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.GetSensorID Method (CvsHost, String)

[image]

In-Sight SDK
CvsSensor..::..GetSensorID Method (CvsHost, String)
CvsSensor Class See Also Send Feedback
Creates a device specific identifier based on the information provided. The identifier can be used to identify a device.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static string GetSensorID(
    CvsHost host,
    string macAddress
)
Visual Basic
Public Shared Function GetSensorID (
    host As CvsHost,
    macAddress As String
) As String

Parameters

host
Type: Cognex.InSight.Sensor..::..CvsHost
The sensor.
macAddress
Type: System..::..String
The MAC address of the device.

Return Value

Type: String
A descriptor that can be used to identify the device.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
GetSensorID Overload
Cognex.InSight.Sensor Namespace


CvsSensor.GetSensorID Method (CvsHostType, String, String, String)

[image]

In-Sight SDK
CvsSensor..::..GetSensorID Method (CvsHostType, String, String, String)
CvsSensor Class See Also Send Feedback
Creates a device specific identifier based on the information provided. The identifier can be used to identify a device.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static string GetSensorID(
    CvsHostType type,
    string hostName,
    string macAddress,
    string ipAddress
)
Visual Basic
Public Shared Function GetSensorID (
    type As CvsHostType,
    hostName As String,
    macAddress As String,
    ipAddress As String
) As String

Parameters

type
Type: Cognex.InSight.Sensor..::..CvsHostType
The sensor type.
hostName
Type: System..::..String
The host name associated with the device.
macAddress
Type: System..::..String
The MAC address of the device.
ipAddress
Type: System..::..String
The IP Address of the device.

Return Value

Type: String
A descriptor that can be used to identify the device.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
GetSensorID Overload
Cognex.InSight.Sensor Namespace


CvsSensor.GetSettings Method

[image]

In-Sight SDK
CvsSensor..::..GetSettings Method
CvsSensor Class See Also Send Feedback
Returns a copy of the processor settings received from the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSettings GetSettings()
Visual Basic
Public Function GetSettings As CvsSettings

Return Value

Type: CvsSettings
A CvsSettings object that describes the current In-Sight settings, or a null reference (Nothing in Visual Basic) if the State is CvsInSightState.NotConnected.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.GetSntpCurrentData Method

[image]

In-Sight SDK
CvsSensor..::..GetSntpCurrentData Method
CvsSensor Class See Also Send Feedback
Returns the CvsSntpCurrentData object from the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSntpCurrentData GetSntpCurrentData()
Visual Basic
Public Function GetSntpCurrentData As CvsSntpCurrentData

Return Value

Type: CvsSntpCurrentData
A CvsSntpCurrentData object that describes the current SNTP settings, or a null reference (Nothing in Visual Basic) if the State is CvsInSightState.NotConnected.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.GetTimeZones Method

[image]

In-Sight SDK
CvsSensor..::..GetTimeZones Method
CvsSensor Class See Also Send Feedback
Returns the CvsTimeZones object from the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsTimeZones GetTimeZones()
Visual Basic
Public Function GetTimeZones As CvsTimeZones

Return Value

Type: CvsTimeZones
A CvsTimesZones object that describes the time zones for the current In-Sight connection, or a null reference (Nothing in Visual Basic) if the State is CvsInSightState.NotConnected.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.IsEzToolEnabled Method

[image]

In-Sight SDK
CvsSensor..::..IsEzToolEnabled Method
CvsSensor Class See Also Send Feedback
Gets a value indicating whether the tool is enabled based on the tool's Guid. Tool may still be disabled based on function security bits.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsEzToolEnabled(
    Guid guid
)
Visual Basic
Public Function IsEzToolEnabled (
    guid As Guid
) As Boolean

Parameters

guid
Type: System..::..Guid
The tool's guid.

Return Value

Type: Boolean
true if the tool is enabled; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.IsImprovedEncryptionSupported Method

[image] [image]

In-Sight SDK
CvsSensor..::..IsImprovedEncryptionSupported Method
CvsSensor Class See Also Send Feedback

Overload List

Name | Description
IsImprovedEncryptionSupported(Version) | Determines whether or not the version of the sensor's firmware supports Improved Encryption.
IsImprovedEncryptionSupported(CvsHostVersion) | Determines whether or not the version of the sensor's firmware supports Improved Encryption.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.IsImprovedEncryptionSupported Method (Version)

[image]

In-Sight SDK
CvsSensor..::..IsImprovedEncryptionSupported Method (Version)
CvsSensor Class See Also Send Feedback
Determines whether or not the version of the sensor's firmware supports Improved Encryption.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsImprovedEncryptionSupported(
    Version v
)
Visual Basic
Public Shared Function IsImprovedEncryptionSupported (
    v As Version
) As Boolean

Parameters

v
Type: System..::..Version
The firmware version.

Return Value

Type: Boolean
true if improved encryption is supported; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
IsImprovedEncryptionSupported Overload
Cognex.InSight.Sensor Namespace


CvsSensor.IsImprovedEncryptionSupported Method (CvsHostVersion)

[image]

In-Sight SDK
CvsSensor..::..IsImprovedEncryptionSupported Method (CvsHostVersion)
CvsSensor Class See Also Send Feedback
Determines whether or not the version of the sensor's firmware supports Improved Encryption.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsImprovedEncryptionSupported(
    CvsHostVersion v
)
Visual Basic
Public Shared Function IsImprovedEncryptionSupported (
    v As CvsHostVersion
) As Boolean

Parameters

v
Type: Cognex.InSight.Sensor..::..CvsHostVersion
The firmware version.

Return Value

Type: Boolean
true if improved encryption is supported; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
IsImprovedEncryptionSupported Overload
Cognex.InSight.Sensor Namespace


CvsSensor.SerialPortSupported Method

[image]

In-Sight SDK
CvsSensor..::..SerialPortSupported Method
CvsSensor Class See Also Send Feedback
Gets a value that determines if the specified serial port is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SerialPortSupported(
    int port
)
Visual Basic
Public Function SerialPortSupported (
    port As Integer
) As Boolean

Parameters

port
Type: System..::..Int32
The serial port number (0 or 1).

Return Value

Type: Boolean
true if the serial port is supported, otherwise false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.SetHmiSettings Method

[image]

In-Sight SDK
CvsSensor..::..SetHmiSettings Method
CvsSensor Class See Also Send Feedback
Sends new HMI settings to the In-Sight.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetHmiSettings(
    CvsHmiSettings settings
)
Visual Basic
Public Sub SetHmiSettings (
    settings As CvsHmiSettings
)

Parameters

settings
Type: Cognex.InSight..::..CvsHmiSettings

[Missing <param name="settings"/> documentation for "M:Cognex.InSight.Sensor.CvsSensor.SetHmiSettings(Cognex.InSight.CvsHmiSettings)"]

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace
CvsSensor..::..HmiServerSupported
CvsSensor..::..GetHmiSettings(Boolean)


CvsSensor.SetSettings Method

[image]

In-Sight SDK
CvsSensor..::..SetSettings Method
CvsSensor Class See Also Send Feedback
Sends the CvsSettings object to the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SetSettings(
    CvsSettings settings
)
Visual Basic
Public Function SetSettings (
    settings As CvsSettings
) As Boolean

Parameters

settings
Type: Cognex.InSight.Sensor..::..CvsSettings
The settings to send to the In-Sight sensor.

Return Value

Type: Boolean
A boolean indicating whether a change in the settings was detected and sent to the sensor.

Exceptions

Exception | Condition
System..::..ArgumentNullException | null is passed as a parameter.
Cognex.InSight..::..CvsNotConnectedException | State is CvsInSightState.NotConnected.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.SetTimeDateData Method

[image]

In-Sight SDK
CvsSensor..::..SetTimeDateData Method
CvsSensor Class See Also Send Feedback
Sends the CvsTimeDateData object to the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetTimeDateData(
    CvsTimeDateData data
)
Visual Basic
Public Sub SetTimeDateData (
    data As CvsTimeDateData
)

Parameters

data
Type: Cognex.InSight.Sensor..::..CvsTimeDateData
The time and date information to send to the In-Sight sensor.

Exceptions

Exception | Condition
System..::..ArgumentNullException | null is passed as a parameter.
Cognex.InSight..::..CvsNotConnectedException | State is CvsInSightState.NotConnected.
Cognex.InSight..::..CvsNetworkException | A network error occurred while performing the requested operation.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.SupportsTool Method

[image]

In-Sight SDK
CvsSensor..::..SupportsTool Method
CvsSensor Class See Also Send Feedback
Determines if the sensor supports a particular tool.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SupportsTool(
    CvsSupportedTools tool
)
Visual Basic
Public Function SupportsTool (
    tool As CvsSupportedTools
) As Boolean

Parameters

tool
Type: Cognex.InSight.Sensor..::..CvsSupportedTools
The CvsSupportedTools tool to check.

Return Value

Type: Boolean
true if the sensor supports the tool, and false if the sensor does not support the tool or there is no connection to a sensor.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | If tool is not a member of the CvsSupportedTools enumeration.
System..::..NotSupportedException | The firmware does not support checking this function.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.ValidateCellName Method

[image]

In-Sight SDK
CvsSensor..::..ValidateCellName Method
CvsSensor Class See Also Send Feedback
Validates the length and characters of a cell name.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void ValidateCellName(
    string name
)
Visual Basic
Public Sub ValidateCellName (
    name As String
)

Parameters

name
Type: System..::..String
The cell name.

Exceptions

Exception | Condition
System..::..ArgumentException | The name is not valid.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor Properties

[image] [image]

In-Sight SDK
CvsSensor Properties
CvsSensor Class See Also Send Feedback

The CvsSensor type exposes the following members.

Properties

 | Name | Description
Public property | AllEzToolsEnabled | Gets a value indicating that all Ez Tools are enabled. Tools may still be disabled based on function security bits.
Public property | AuditMessagesSupported | Gets a value that determines if audit messages are supported.
Public property | BufferSize | The buffer size on the sensor. 4000 for newer firmware, 256 for older firmware.
Public property | BuildDateTime | Gets the date and time of the firmware build on the In-Sight sensor.
Public property | DiscreteIOSupported | Gets a value that determines if Discrete Input or Output is supported, either local or expansion.
Public property | EncoderOutputSupported | Gets a value indicating whether encoder output is supported.
Public property | ExternalLightSettingsSupported | Gets a value that determines if the External Light Settings are supported.
Public property | FirmwareDrivenTestRunSupported | Gets a value that determines if TestRun is supported directly on this device.
Public property | FirmwareUpgradeFilename | Gets the firmware upgrade filename used to update this In-Sight sensor type.
Public property | FirmwareUpgradeReconnectDelay | Gets the delay between reconnect attempts.
Public property | GuiActionRequestEventSupported | Gets a value that indicates if the GuiActionRequest event is supported.
Public property | HmiServerSupported | Gets a value that determines if a the HMI Server is supported.
Public property | HostName | Gets the host name associated with the In-Sight sensor.
Public property | ImageResolutionSupported | Gets a value that determines if modifying the image resolution is supported.
Public property | ImportExportSupported | Gets a value that determines if cell import/export is supported.
Public property | Is2000Series | Returns true if the sensor is an InSight 2000 model.
Public property | Is8000Series | Returns true if the sensor is an InSight 8000 model.
Public property | IsColor | Gets a value that determines if the sensor is a color sensor.
Public property | LicensingSupported | Gets a value that determines if licensing is supported.
Public property | MacAddress | Gets the MAC address of the In-Sight sensor.
Public property | MacAddressLong | Gets the Mac address as a long value.
Public property | MaxCellNameLength | Gets the maximum cell name length in bytes.
Public property | MaxGuiConnections | Gets the maximum number of GUI connections (ISE, VisionView, and WebHMI) that the In-Sight supports.
Public property | MaxUserListLength | Gets the maximum number of entries allowed in the list of users.
Public property | ModelNumber | Gets the model number as a string. (i.e. 5100, 5400C, 1700, etc.)
Public property | PowerlinkSettingsSupported | Gets a value that determines if the POWERLINK settings are supported.
Public property | ProcessorConstants | Gets the processor constants associated with the In-Sight sensor.
Public property | RamDiskSupported | Gets a value that determines if a RAM disk is supported.
Public property | RecordModeOnSensorSupported | Gets a value that determines if the record mode is supported on the sensor. That is, if the bit depth, image resolution and max image acquisition rate for recording are supported in firmware.
Public property | RemoteJobServerSupported | Gets a value that determines if a Remote Job Server is supported.
Public property | RepresentedSystemSubtype | Gets the represented system subtype. For instance, if the SystemSubtype is emulator emulating a 7000, this will return 7000Series. If this is not an emulator, this will return the same value as SystemSubtype.
Public property | ScriptingSupported | Gets a value that determines if Scripting is supported on this device.
Public property | SerialNumber | Gets the serial number.
Public property | SntpSupported | Gets a value that determines if SNTP is supported.
Public property | SpreadsheetSupported | Gets a value that determines if the spreadsheet is allowed for this sensor.
Public property | SupportedProtocols | Gets the supported protocols for the Sensor. Returns 'None' if the command is not supported, or the Sensor is not connected.
Public property | SystemSubtype | Gets the system subtype.
Public property | SystemType | Gets the system type.
Public property | Version | Gets the firmware version.

See Also

CvsSensor Class
Cognex.InSight.Sensor Namespace


CvsSensor.AllEzToolsEnabled Property

[image]

In-Sight SDK
CvsSensor..::..AllEzToolsEnabled Property
CvsSensor Class See Also Send Feedback
Gets a value indicating that all Ez Tools are enabled. Tools may still be disabled based on function security bits.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AllEzToolsEnabled { get; }
Visual Basic
Public ReadOnly Property AllEzToolsEnabled As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.AuditMessagesSupported Property

[image]

In-Sight SDK
CvsSensor..::..AuditMessagesSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if audit messages are supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AuditMessagesSupported { get; }
Visual Basic
Public ReadOnly Property AuditMessagesSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.BufferSize Property

[image]

In-Sight SDK
CvsSensor..::..BufferSize Property
CvsSensor Class See Also Send Feedback
The buffer size on the sensor. 4000 for newer firmware, 256 for older firmware.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int BufferSize { get; }
Visual Basic
Public ReadOnly Property BufferSize As Integer
    Get

Property Value

Type: Int32

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.BuildDateTime Property

[image]

In-Sight SDK
CvsSensor..::..BuildDateTime Property
CvsSensor Class See Also Send Feedback
Gets the date and time of the firmware build on the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public DateTime BuildDateTime { get; }
Visual Basic
Public ReadOnly Property BuildDateTime As DateTime
    Get

Property Value

Type: DateTime

Remarks

This property is not available in COM/ActiveX applications.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.DiscreteIOSupported Property

[image]

In-Sight SDK
CvsSensor..::..DiscreteIOSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if Discrete Input or Output is supported, either local or expansion.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool DiscreteIOSupported { get; }
Visual Basic
Public ReadOnly Property DiscreteIOSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.EncoderOutputSupported Property

[image]

In-Sight SDK
CvsSensor..::..EncoderOutputSupported Property
CvsSensor Class See Also Send Feedback
Gets a value indicating whether encoder output is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool EncoderOutputSupported { get; }
Visual Basic
Public ReadOnly Property EncoderOutputSupported As Boolean
    Get

Property Value

Type: Boolean
true if encoder output is supported; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.ExternalLightSettingsSupported Property

[image]

In-Sight SDK
CvsSensor..::..ExternalLightSettingsSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if the External Light Settings are supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ExternalLightSettingsSupported { get; }
Visual Basic
Public ReadOnly Property ExternalLightSettingsSupported As Boolean
    Get

Property Value

Type: Boolean
true if the External Light Settings are supported; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.FirmwareDrivenTestRunSupported Property

[image]

In-Sight SDK
CvsSensor..::..FirmwareDrivenTestRunSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if TestRun is supported directly on this device.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool FirmwareDrivenTestRunSupported { get; }
Visual Basic
Public ReadOnly Property FirmwareDrivenTestRunSupported As Boolean
    Get

Property Value

Type: Boolean
true if TestRun is supported directly on this device; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.FirmwareUpgradeFilename Property

[image]

In-Sight SDK
CvsSensor..::..FirmwareUpgradeFilename Property
CvsSensor Class See Also Send Feedback
Gets the firmware upgrade filename used to update this In-Sight sensor type.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string FirmwareUpgradeFilename { get; }
Visual Basic
Public ReadOnly Property FirmwareUpgradeFilename As String
    Get

Property Value

Type: String
The filename.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.FirmwareUpgradeReconnectDelay Property

[image]

In-Sight SDK
CvsSensor..::..FirmwareUpgradeReconnectDelay Property
CvsSensor Class See Also Send Feedback
Gets the delay between reconnect attempts.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int FirmwareUpgradeReconnectDelay { get; }
Visual Basic
Public ReadOnly Property FirmwareUpgradeReconnectDelay As Integer
    Get

Property Value

Type: Int32
The delay in ms.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.GuiActionRequestEventSupported Property

[image]

In-Sight SDK
CvsSensor..::..GuiActionRequestEventSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that indicates if the GuiActionRequest event is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool GuiActionRequestEventSupported { get; }
Visual Basic
Public ReadOnly Property GuiActionRequestEventSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.HmiServerSupported Property

[image]

In-Sight SDK
CvsSensor..::..HmiServerSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if a the HMI Server is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool HmiServerSupported { get; }
Visual Basic
Public ReadOnly Property HmiServerSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.HostName Property

[image]

In-Sight SDK
CvsSensor..::..HostName Property
CvsSensor Class See Also Send Feedback
Gets the host name associated with the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string HostName { get; }
Visual Basic
Public ReadOnly Property HostName As String
    Get

Property Value

Type: String

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.ImageResolutionSupported Property

[image]

In-Sight SDK
CvsSensor..::..ImageResolutionSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if modifying the image resolution is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ImageResolutionSupported { get; }
Visual Basic
Public ReadOnly Property ImageResolutionSupported As Boolean
    Get

Property Value

Type: Boolean
true if modifying the image resolution is supported; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.ImportExportSupported Property

[image]

In-Sight SDK
CvsSensor..::..ImportExportSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if cell import/export is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ImportExportSupported { get; }
Visual Basic
Public ReadOnly Property ImportExportSupported As Boolean
    Get

Property Value

Type: Boolean
true if cell import/export is supported; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.Is2000Series Property

[image]

In-Sight SDK
CvsSensor..::..Is2000Series Property
CvsSensor Class See Also Send Feedback
Returns true if the sensor is an InSight 2000 model.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Is2000Series { get; }
Visual Basic
Public ReadOnly Property Is2000Series As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.Is8000Series Property

[image]

In-Sight SDK
CvsSensor..::..Is8000Series Property
CvsSensor Class See Also Send Feedback
Returns true if the sensor is an InSight 8000 model.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool Is8000Series { get; }
Visual Basic
Public ReadOnly Property Is8000Series As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.IsColor Property

[image]

In-Sight SDK
CvsSensor..::..IsColor Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if the sensor is a color sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsColor { get; }
Visual Basic
Public ReadOnly Property IsColor As Boolean
    Get

Property Value

Type: Boolean
true if the sensor is a color sensor; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.LicensingSupported Property

[image]

In-Sight SDK
CvsSensor..::..LicensingSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if licensing is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool LicensingSupported { get; }
Visual Basic
Public ReadOnly Property LicensingSupported As Boolean
    Get

Property Value

Type: Boolean
true if licensing is supported, otherwise false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.MacAddress Property

[image]

In-Sight SDK
CvsSensor..::..MacAddress Property
CvsSensor Class See Also Send Feedback
Gets the MAC address of the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string MacAddress { get; }
Visual Basic
Public ReadOnly Property MacAddress As String
    Get

Property Value

Type: String
The mac address as a formatted string.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.MacAddressLong Property

[image]

In-Sight SDK
CvsSensor..::..MacAddressLong Property
CvsSensor Class See Also Send Feedback
Gets the Mac address as a long value.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public long MacAddressLong { get; }
Visual Basic
Public ReadOnly Property MacAddressLong As Long
    Get

Property Value

Type: Int64
The mac address value as a formatted string.

Remarks

This property is not available in COM/ActiveX applications.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.MaxCellNameLength Property

[image]

In-Sight SDK
CvsSensor..::..MaxCellNameLength Property
CvsSensor Class See Also Send Feedback
Gets the maximum cell name length in bytes.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxCellNameLength { get; }
Visual Basic
Public ReadOnly Property MaxCellNameLength As Integer
    Get

Property Value

Type: Int32

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.MaxGuiConnections Property

[image]

In-Sight SDK
CvsSensor..::..MaxGuiConnections Property
CvsSensor Class See Also Send Feedback
Gets the maximum number of GUI connections (ISE, VisionView, and WebHMI) that the In-Sight supports.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxGuiConnections { get; }
Visual Basic
Public ReadOnly Property MaxGuiConnections As Integer
    Get

Property Value

Type: Int32

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.MaxUserListLength Property

[image]

In-Sight SDK
CvsSensor..::..MaxUserListLength Property
CvsSensor Class See Also Send Feedback
Gets the maximum number of entries allowed in the list of users.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxUserListLength { get; }
Visual Basic
Public ReadOnly Property MaxUserListLength As Integer
    Get

Property Value

Type: Int32
A value that indicates the maximum number of entries allowed in the list of users.

Exceptions

Exception | Condition
Cognex.InSight..::..CvsNotConnectedException | State is CvsInSightState.NotConnected.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.ModelNumber Property

[image]

In-Sight SDK
CvsSensor..::..ModelNumber Property
CvsSensor Class See Also Send Feedback
Gets the model number as a string. (i.e. 5100, 5400C, 1700, etc.)

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string ModelNumber { get; }
Visual Basic
Public ReadOnly Property ModelNumber As String
    Get

Property Value

Type: String
A string that reflects the model of the In-Sight sensor or "PC" for the emulator for the most recent connection.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.PowerlinkSettingsSupported Property

[image]

In-Sight SDK
CvsSensor..::..PowerlinkSettingsSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if the POWERLINK settings are supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool PowerlinkSettingsSupported { get; }
Visual Basic
Public ReadOnly Property PowerlinkSettingsSupported As Boolean
    Get

Property Value

Type: Boolean
true if the POWERLINK settings are supported; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.ProcessorConstants Property

[image]

In-Sight SDK
CvsSensor..::..ProcessorConstants Property
CvsSensor Class See Also Send Feedback
Gets the processor constants associated with the In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsProcessorConstants ProcessorConstants { get; }
Visual Basic
Public ReadOnly Property ProcessorConstants As CvsProcessorConstants
    Get

Property Value

Type: CvsProcessorConstants
A CvsProcessorConstants object that contains the processor constants.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.RamDiskSupported Property

[image]

In-Sight SDK
CvsSensor..::..RamDiskSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if a RAM disk is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool RamDiskSupported { get; }
Visual Basic
Public ReadOnly Property RamDiskSupported As Boolean
    Get

Property Value

Type: Boolean
true if a RAM disk is supported; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.RecordModeOnSensorSupported Property

[image]

In-Sight SDK
CvsSensor..::..RecordModeOnSensorSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if the record mode is supported on the sensor. That is, if the bit depth, image resolution and max image acquisition rate for recording are supported in firmware.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool RecordModeOnSensorSupported { get; }
Visual Basic
Public ReadOnly Property RecordModeOnSensorSupported As Boolean
    Get

Property Value

Type: Boolean
true if the record mode is supported on the sensor; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.RemoteJobServerSupported Property

[image]

In-Sight SDK
CvsSensor..::..RemoteJobServerSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if a Remote Job Server is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool RemoteJobServerSupported { get; }
Visual Basic
Public ReadOnly Property RemoteJobServerSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.RepresentedSystemSubtype Property

[image]

In-Sight SDK
CvsSensor..::..RepresentedSystemSubtype Property
CvsSensor Class See Also Send Feedback
Gets the represented system subtype. For instance, if the SystemSubtype is emulator emulating a 7000, this will return 7000Series. If this is not an emulator, this will return the same value as SystemSubtype.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostSubtype RepresentedSystemSubtype { get; }
Visual Basic
Public ReadOnly Property RepresentedSystemSubtype As CvsHostSubtype
    Get

Property Value

Type: CvsHostSubtype

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.ScriptingSupported Property

[image]

In-Sight SDK
CvsSensor..::..ScriptingSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if Scripting is supported on this device.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ScriptingSupported { get; }
Visual Basic
Public ReadOnly Property ScriptingSupported As Boolean
    Get

Property Value

Type: Boolean
true if Scripting is supported on this device; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.SerialNumber Property

[image]

In-Sight SDK
CvsSensor..::..SerialNumber Property
CvsSensor Class See Also Send Feedback
Gets the serial number.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string SerialNumber { get; }
Visual Basic
Public ReadOnly Property SerialNumber As String
    Get

Property Value

Type: String
The serial number string.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.SntpSupported Property

[image]

In-Sight SDK
CvsSensor..::..SntpSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if SNTP is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SntpSupported { get; }
Visual Basic
Public ReadOnly Property SntpSupported As Boolean
    Get

Property Value

Type: Boolean
true if SNTP is supported, otherwise false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.SpreadsheetSupported Property

[image]

In-Sight SDK
CvsSensor..::..SpreadsheetSupported Property
CvsSensor Class See Also Send Feedback
Gets a value that determines if the spreadsheet is allowed for this sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SpreadsheetSupported { get; }
Visual Basic
Public ReadOnly Property SpreadsheetSupported As Boolean
    Get

Property Value

Type: Boolean
true if the spreadsheet is allowed for this sensor; otherwise, false.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.SupportedProtocols Property

[image]

In-Sight SDK
CvsSensor..::..SupportedProtocols Property
CvsSensor Class See Also Send Feedback
Gets the supported protocols for the Sensor. Returns 'None' if the command is not supported, or the Sensor is not connected.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsProtocolServices SupportedProtocols { get; }
Visual Basic
Public ReadOnly Property SupportedProtocols As CvsProtocolServices
    Get

Property Value

Type: CvsProtocolServices

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.SystemSubtype Property

[image]

In-Sight SDK
CvsSensor..::..SystemSubtype Property
CvsSensor Class See Also Send Feedback
Gets the system subtype.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostSubtype SystemSubtype { get; }
Visual Basic
Public ReadOnly Property SystemSubtype As CvsHostSubtype
    Get

Property Value

Type: CvsHostSubtype
The CvsHostSubtype object for the most recent connection.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.SystemType Property

[image]

In-Sight SDK
CvsSensor..::..SystemType Property
CvsSensor Class See Also Send Feedback
Gets the system type.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostType SystemType { get; }
Visual Basic
Public ReadOnly Property SystemType As CvsHostType
    Get

Property Value

Type: CvsHostType
The CvsHostType object for the most recent connection.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensor.Version Property

[image]

In-Sight SDK
CvsSensor..::..Version Property
CvsSensor Class See Also Send Feedback
Gets the firmware version.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHostVersion Version { get; }
Visual Basic
Public ReadOnly Property Version As CvsHostVersion
    Get

Property Value

Type: CvsHostVersion
The CvsHostVersion object for the most recent connection.

See Also

CvsSensor Class
CvsSensor..::..CvsSensor Members
Cognex.InSight.Sensor Namespace


CvsSensorIconType Enumeration

[image]

In-Sight SDK
CvsSensorIconType Enumeration
See Also Send Feedback
Defines the known sensor icon types.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsSensorIconType
Visual Basic
Public Enumeration CvsSensorIconType

Members

Member name | Value | Description
Generic | 0 |
InSight5000 | 1 |
InSight5400R | 2 |
InSightEmulator | 3 |
InSight3400 | 4 |
InSight1000 | 5 |
InSight3000 | 6 |
InSight4000 | 7 |
InSight1700 | 8 |
InSightAE | 9 |
InSightMicro | 10 |
InSightMicro1000LR | 11 |
InSightDM60 | 12 |
InSight500 | 13 |
InSightRogue | 14 | 7000s
InSightEZ100 | 15 |
InSightAdvantageEngine | 16 |
InSightMotoSight | 17 |
InSightEZ700 | 18 |
InSight8000 | 19 |
InSight2000mini | 20 |
InSight2000_xxx | 21 |
InSightZebra | 22 | 7900, 7902, 7800, 7801, 7802, 7600, 7500, 7502
InSight9000Series | 23 | 9602L, 9902L, 9912
InSightVS20Series | 24 |
InSightVS70Series | 25 |
InSightVS80Series | 26 |

Remarks

Since this enum is internal, these names can be changed. Order does not matter.

See Also

Cognex.InSight.Sensor Namespace


CvsSerialSettings Class

[image]

In-Sight SDK
CvsSerialSettings Class
Members See Also Send Feedback
Holds the serial port settings for a single serial port.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsSerialSettings : ICloneable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsSerialSettings
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsSerialSettings

See Also

CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings Members

[image] [image]

In-Sight SDK
CvsSerialSettings Members
CvsSerialSettings Class Methods Properties See Also Send Feedback

The CvsSerialSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines if the CvsSerialSettings objects contain the same values.
Public method | SupportsSlowBaudRates | Determines if the sensor supports slow (1200/2400) baud rate settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BaudRate | Gets or sets the baud rate (from 1200 to 115200).
Public property | DataBits | Gets or sets the number of data bits (7 or 8).
Public property | DeviceNetReceiveLength | Gets or sets the expected packet size to be received through the DeviceNet Interface Module, in bytes.
Public property | DeviceNetSendLength | Gets or sets the packet size to send out through DeviceNet Interface Module, in bytes.
Public property | FixedInputLength | Gets or sets the fixed number of characters that should be read before triggering an event if FixedInputLengthEnabled is true.
Public property | FixedInputLengthEnabled | Gets or sets whether a fixed number of characters should be read before triggering an event.
Public property | Handshake | Gets or sets the handshake protocol (none, Xon/Xoff or hardware).
Public property | InputTerminator | Gets or sets the ASCII value interpreted by In-Sight as the end of an incoming string.
Public property | Mode | Gets or sets the serial port's protocol mode selections.
Public property | OutputTerminator | Gets or sets the ASCII value that In-Sight adds to each output string to mark the end of the transmitted string.
Public property | Parity | Gets or sets the parity (none, odd, or even).
Public property | Port | Gets the serial port number that identifies this instance.
Public property | StopBits | Gets or sets the number of stop bits (1 or 2).
Public property | TriggerOnFirstByteEnabled | Gets or sets triggering of an acquisition when the first byte is received.

See Also

CvsSerialSettings Class
Cognex.InSight.Sensor Namespace


CvsSerialSettings Methods

[image] [image]

In-Sight SDK
CvsSerialSettings Methods
CvsSerialSettings Class See Also Send Feedback

The CvsSerialSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines if the CvsSerialSettings objects contain the same values.
Public method | SupportsSlowBaudRates | Determines if the sensor supports slow (1200/2400) baud rate settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsSerialSettings Class
Cognex.InSight.Sensor Namespace


CvsSerialSettings.Clone Method

[image]

In-Sight SDK
CvsSerialSettings..::..Clone Method
CvsSerialSettings Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.IsEqual Method

[image]

In-Sight SDK
CvsSerialSettings..::..IsEqual Method
CvsSerialSettings Class See Also Send Feedback
Determines if the CvsSerialSettings objects contain the same values.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsEqual(
    CvsSerialSettings serialSettings
)
Visual Basic
Public Function IsEqual (
    serialSettings As CvsSerialSettings
) As Boolean

Parameters

serialSettings
Type: Cognex.InSight.Sensor..::..CvsSerialSettings
The object to compare with this instance.

Return Value

Type: Boolean
true if objects have the same values; otherwise, false.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.SupportsSlowBaudRates Method

[image]

In-Sight SDK
CvsSerialSettings..::..SupportsSlowBaudRates Method
CvsSerialSettings Class See Also Send Feedback
Determines if the sensor supports slow (1200/2400) baud rate settings.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SupportsSlowBaudRates()
Visual Basic
Public Function SupportsSlowBaudRates As Boolean

Return Value

Type: Boolean
true the sensor supports rates under 4800 and false otherwise.

Remarks

The model 3400 and 5xxx series sensors do not support baud rates less than 4800 unless an expansion I/O module is attached.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings Properties

[image] [image]

In-Sight SDK
CvsSerialSettings Properties
CvsSerialSettings Class See Also Send Feedback

The CvsSerialSettings type exposes the following members.

Properties

 | Name | Description
Public property | BaudRate | Gets or sets the baud rate (from 1200 to 115200).
Public property | DataBits | Gets or sets the number of data bits (7 or 8).
Public property | DeviceNetReceiveLength | Gets or sets the expected packet size to be received through the DeviceNet Interface Module, in bytes.
Public property | DeviceNetSendLength | Gets or sets the packet size to send out through DeviceNet Interface Module, in bytes.
Public property | FixedInputLength | Gets or sets the fixed number of characters that should be read before triggering an event if FixedInputLengthEnabled is true.
Public property | FixedInputLengthEnabled | Gets or sets whether a fixed number of characters should be read before triggering an event.
Public property | Handshake | Gets or sets the handshake protocol (none, Xon/Xoff or hardware).
Public property | InputTerminator | Gets or sets the ASCII value interpreted by In-Sight as the end of an incoming string.
Public property | Mode | Gets or sets the serial port's protocol mode selections.
Public property | OutputTerminator | Gets or sets the ASCII value that In-Sight adds to each output string to mark the end of the transmitted string.
Public property | Parity | Gets or sets the parity (none, odd, or even).
Public property | Port | Gets the serial port number that identifies this instance.
Public property | StopBits | Gets or sets the number of stop bits (1 or 2).
Public property | TriggerOnFirstByteEnabled | Gets or sets triggering of an acquisition when the first byte is received.

See Also

CvsSerialSettings Class
Cognex.InSight.Sensor Namespace


CvsSerialSettings.BaudRate Property

[image]

In-Sight SDK
CvsSerialSettings..::..BaudRate Property
CvsSerialSettings Class See Also Send Feedback
Gets or sets the baud rate (from 1200 to 115200).

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsBaudRate BaudRate { get; set; }
Visual Basic
Public Property BaudRate As CvsBaudRate
    Get
    Set

Property Value

Type: CvsBaudRate

Remarks

The model 3400 and 5xxx series sensors do not support baud rates less than 4800 unless an expansion I/O module is attached.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a CvsBaudRate, or the baud rate is not supported by the sensor.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.DataBits Property

[image]

In-Sight SDK
CvsSerialSettings..::..DataBits Property
CvsSerialSettings Class See Also Send Feedback
Gets or sets the number of data bits (7 or 8).

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsDataBits DataBits { get; set; }
Visual Basic
Public Property DataBits As CvsDataBits
    Get
    Set

Property Value

Type: CvsDataBits

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a CvsDataBits.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.DeviceNetReceiveLength Property

[image]

In-Sight SDK
CvsSerialSettings..::..DeviceNetReceiveLength Property
CvsSerialSettings Class See Also Send Feedback
Gets or sets the expected packet size to be received through the DeviceNet Interface Module, in bytes.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int DeviceNetReceiveLength { get; set; }
Visual Basic
Public Property DeviceNetReceiveLength As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

The setting must agree with the MaxWidth value in the RS232-to-DeviceNet configuration.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not int the range 1-255.
System..::..ArgumentException | value is not valid for the current Mode setting.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.DeviceNetSendLength Property

[image]

In-Sight SDK
CvsSerialSettings..::..DeviceNetSendLength Property
CvsSerialSettings Class See Also Send Feedback
Gets or sets the packet size to send out through DeviceNet Interface Module, in bytes.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int DeviceNetSendLength { get; set; }
Visual Basic
Public Property DeviceNetSendLength As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

The setting must agree with the Transmit Width value in the RS232-to-DeviceNet configuration.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not int the range 1-255.
System..::..ArgumentException | value is not valid for the current Mode setting.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.FixedInputLength Property

[image]

In-Sight SDK
CvsSerialSettings..::..FixedInputLength Property
CvsSerialSettings Class See Also Send Feedback
Gets or sets the fixed number of characters that should be read before triggering an event if FixedInputLengthEnabled is true.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int FixedInputLength { get; set; }
Visual Basic
Public Property FixedInputLength As Integer
    Get
    Set

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not int the range 1 to 255.
System..::..ArgumentException | value is not valid for the current Mode setting.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.FixedInputLengthEnabled Property

[image]

In-Sight SDK
CvsSerialSettings..::..FixedInputLengthEnabled Property
CvsSerialSettings Class See Also Send Feedback
Gets or sets whether a fixed number of characters should be read before triggering an event.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool FixedInputLengthEnabled { get; set; }
Visual Basic
Public Property FixedInputLengthEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

Exceptions

Exception | Condition
System..::..ArgumentException | value is not valid for the current Mode setting.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.Handshake Property

[image]

In-Sight SDK
CvsSerialSettings..::..Handshake Property
CvsSerialSettings Class See Also Send Feedback
Gets or sets the handshake protocol (none, Xon/Xoff or hardware).

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHandshake Handshake { get; set; }
Visual Basic
Public Property Handshake As CvsHandshake
    Get
    Set

Property Value

Type: CvsHandshake

Remarks

Most In-Sight sensors only support hardware handshaking if the sensor is connected to an In-Sight 1450 or 1460 I/O Expansion Module, but this property can be set to any value regardless of whether an expansion module is connected. Please refer to your sensor's hardware manual to determine the physical connection requirements needed to enable hardware handshaking.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a CvsHandshake.
System..::..ArgumentException | value is not valid for the current Mode setting.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.InputTerminator Property

[image]

In-Sight SDK
CvsSerialSettings..::..InputTerminator Property
CvsSerialSettings Class See Also Send Feedback
Gets or sets the ASCII value interpreted by In-Sight as the end of an incoming string.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int InputTerminator { get; set; }
Visual Basic
Public Property InputTerminator As Integer
    Get
    Set

Property Value

Type: Int32
The default is 13 (carriage return).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not int the range 1 to 255.
System..::..ArgumentException | value is not valid for the current Mode setting.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.Mode Property

[image]

In-Sight SDK
CvsSerialSettings..::..Mode Property
CvsSerialSettings Class See Also Send Feedback
Gets or sets the serial port's protocol mode selections.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsMode Mode { get; set; }
Visual Basic
Public Property Mode As CvsMode
    Get
    Set

Property Value

Type: CvsMode

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a CvsMode.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.OutputTerminator Property

[image]

In-Sight SDK
CvsSerialSettings..::..OutputTerminator Property
CvsSerialSettings Class See Also Send Feedback
Gets or sets the ASCII value that In-Sight adds to each output string to mark the end of the transmitted string.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int OutputTerminator { get; set; }
Visual Basic
Public Property OutputTerminator As Integer
    Get
    Set

Property Value

Type: Int32
The default is 13 (carriage return), -1 specifies "CRLF" (carriage return/line feed), and 0 specifies "no terminator".

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not int tthe range -1 to 255.
System..::..ArgumentException | value is not valid for the current Mode setting.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.Parity Property

[image]

In-Sight SDK
CvsSerialSettings..::..Parity Property
CvsSerialSettings Class See Also Send Feedback
Gets or sets the parity (none, odd, or even).

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsParity Parity { get; set; }
Visual Basic
Public Property Parity As CvsParity
    Get
    Set

Property Value

Type: CvsParity

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a CvsParity.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.Port Property

[image]

In-Sight SDK
CvsSerialSettings..::..Port Property
CvsSerialSettings Class See Also Send Feedback
Gets the serial port number that identifies this instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Port { get; }
Visual Basic
Public ReadOnly Property Port As Integer
    Get

Property Value

Type: Int32

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.StopBits Property

[image]

In-Sight SDK
CvsSerialSettings..::..StopBits Property
CvsSerialSettings Class See Also Send Feedback
Gets or sets the number of stop bits (1 or 2).

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsStopBits StopBits { get; set; }
Visual Basic
Public Property StopBits As CvsStopBits
    Get
    Set

Property Value

Type: CvsStopBits

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a member of CvsStopBits.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSerialSettings.TriggerOnFirstByteEnabled Property

[image]

In-Sight SDK
CvsSerialSettings..::..TriggerOnFirstByteEnabled Property
CvsSerialSettings Class See Also Send Feedback
Gets or sets triggering of an acquisition when the first byte is received.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool TriggerOnFirstByteEnabled { get; set; }
Visual Basic
Public Property TriggerOnFirstByteEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

The Trigger parameter must be set to External in the AcquireImage property sheet.

Exceptions

Exception | Condition
System..::..ArgumentException | value is not valid for the current Mode setting.

See Also

CvsSerialSettings Class
CvsSerialSettings..::..CvsSerialSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings Class

[image]

In-Sight SDK
CvsSettings Class
Members See Also Send Feedback
Holds the processor settings for an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsSettings : ICvsSupportedSettings,
    ICloneable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsSettings
    Implements ICvsSupportedSettings, ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsSettings

See Also

CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings Members

[image] [image]

In-Sight SDK
CvsSettings Members
CvsSettings Class Methods Properties See Also Send Feedback

The CvsSettings type exposes the following members.

Methods

Name Description
Public method Clone
Creates a new object that is a deep copy of the current instance.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method GetFeatureFamily
Gets the feature family that describes the sensor's capabilities.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetNetworkNames
Gets all the names of the network settings.
Public method GetNetworkSettings
Gets the network settings for the name.
Public method GetSlowBaudRateSupportedFlags
Determines whether or not the 1200 and 2400 serial port baud rates are supported.
Public method GetSupportedIOModules
Returns a list of expansion I/O module types that this In-Sight Vision System supports.
GetSupportedLanguages
Gets the list of languages supported.

Remarks

Each language is represented by its culture name, as described in the National Language Support (NLS) API Reference (http://msdn.microsoft.com/en-us/goglobal/bb896001.aspx).
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method SerialPortSupported
Gets a value that determines if the specified serial port is supported.
Public method SetSerialPort1Settings
Sets the serial port 1 settings.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveIOModule | Gets and sets the I/O module that should be used by the sensor.
Public property | ActiveIOModuleLines | Gets the CvsDiscreteIOLines for the currently active I/O Module specified by the ActiveIOModule property.
Public property | AuditMessageSettings | Gets the audit message settings.
Public property | AuditMessagesSupported | Gets a value that determines if audit messages are supported.
Public property | ConnectedIOModule | Gets the type of the connected I/O module.
Public property | DeEnergizeOutputsWhileOffline | Gets or sets whether the In-Sight sensor will de-energize outputs while offline.
Public property | DeEnergizeOutputsWhileOfflineSupported | Returns true if the de-energizing of outputs while offline is supported.
Public property | DiscreteIOSupported | Gets a value that determines if the device supports discrete IO, whether expansion or local.
Public property | DiscreteTriggerDelayTimeSupported | Gets a value that determines if discrete output's trigger delay time is supported.
Public property | EipWatchdogTimeoutActionSupported | Gets a value that determines if the EtherNet/IP Watchdog Timeout Action is supported.
Public property | EncoderOutputConfigured | Is the encoder configured
Public property | EncoderOutputSupport | Return true for 7000 series version >= 4.7.1 as this supports encode Phase B and A on input and output lines 2 and 3 respectfully NOTE: Not supported in 4.7.1 due to hardware issue
Public property | EncoderSupportOnIO_2and3 | Return true for 7000 series version >= 4.7.1 as this supports encode Phase B and A on input and output lines 2 and 3 respectfully NOTE: Not supported in 4.7.1 due to hardware issue
Public property | EthernetIOAddress | Gets or sets the IP Address or name of the Ethernet IO device to connect to
Public property | EthernetIOAddressSupported | Gets a value that determines if an extended ethernet IO address is supported.
Public property | EthernetIOInactivePollRate | Gets or sets maximum poll rate in milliseconds for the Ethernet IO connection during periods of inactivity.
Public property | EthernetIOPollRate | Gets or sets minimum poll rate in milliseconds for the Ethernet IO connection
Public property | EthernetIOSettings | Gets the Ethernet input and output line settings, if available.
Public property | EthernetIOSupported | Returns true if the Wago IO module is supported on this device
Public property | ExpansionIOMessagingSupported | Gets a value that determines if expansion IO is supported.
Public property | ExpansionIOSettings | Gets the serial expansion module input and output line settings, if available.
Public property | ExpansionIOSupported | Returns true if the 1450/1460 or 1400 are supported
Public property | ForceNetworkLinkModeSupported | Returns true if the In-Sight supports the network link mode option.
Public property | GuiActionRequestEventSupported | Gets a value that indicates if the GuiActionRequest event is supported.
Public property | HardwareStrobeSupported | Gets a value that determines if a hardware strobe is supported.
Public property | HmiServerSupported | Gets a value that determines if a the HMI Server is supported.
Public property | HmiSettings | Gets the Hmi settings, if available.
Public property | ImportExportSupported | Gets a value that determines if cell import/export is supported.
Public property | IOCameraMaskSupported | Determines whether the sensor supports camera masks on IO.
Public property | JobServerSettings | Gets the Remote Job Server Settings, if supported.
Public property | LicensingSupported | Gets a value that determines if licensing is supported.
Public property | LiveAcquisitionMaxImageRate | Gets or sets the maximum rate of images that are received when LiveAcquisition is true.
Public property | LiveAcquisitionResolution | Gets or sets the resolution of the images that are received when LiveAcquisition is true.
Public property | LiveImagesBitDepth | Gets or sets the bit depth for color images sent while in live mode.
Public property | LocalIOSettings | Gets the local input and output line settings.
Public property | MaxEthernetIOUpdateRate | Gets the maximum ethernet IO update rate. Maximum ethernet IO poll rate is the time the IO module gets data from the sensor frequently. This used to be 1000ms, but since ISE 4.1.1 (CR 67676), this value has been changed to 500ms for Micro, Micro-CC and WAGO.
Public property | MaxGuiConnections | Gets the maximum number of GUI connections (ISE, VisionView, and WebHMI) that the In-Sight supports.
Public property | MCProtocolScannerSupported | Gets a value that determines if MC Protocol Scanner is supported.
Public property | ModbusSettingsSupported | Gets a value that determines if modbus settings are supported.
Public property | NetworkSettings | Gets the network settings.
Public property | OnlineAcquisitionMaxImageRate | Gets or sets the maximum rate of images that are received when the sensor is online and acquiring images.
Public property | OnlineAcquisitionMaxImageRateSupported | Gets a value that determines if an online maximum image rate is supported.
Public property | OnlineImageResolution | Gets or sets the resolution of the images that are received when the sensor is online and acquiring images.
Public property | OnlineImageResolutionSupported | Gets a value that determines if changes to resolution while online are supported.
Public property | OnlineImagesBitDepth | Gets or sets the bit depth for color images sent while online.
Public property | OnlineJobSaveSupported | Gets a value that determines if saving a job while online is supported.
Public property | PowerlinkSettingsSupported | Gets a value that determines if the POWERLINK settings are supported.
Public property | ProfinetSettingsSupported | Gets a boolean that determines if the ProfiNet Settings is supported.
Public property | ProtectedUserOnlineOfflineSupported | Returns true if the online/offline option for Protected access users is supported.
Public property | ProtocolServiceSupported | Gets a value that determines if the Protocol Service is supported.
Public property | PTPTimeSynchSupported | Gets a value that determines if PTP Time Synchronization is supported.
Public property | RamDiskSize | Gets and sets the RAM disk size in bytes.
Public property | RamDiskSupported | Gets a value that determines if a RAM disk is supported.
Public property | RecordModeOnSensorSupported | Gets a value that determines if the record mode is supported on the sensor. That is, if the bit depth, image resolution and max image acquisition rate for recording are supported in firmware.
Public property | RemoteJobServerDirectorySupported | Gets a value that determines if a Remote Job Server Directory is supported.
Public property | RemoteJobServerSupported | Gets a value that determines if a Remote Job Server is supported.
Public property | ResourceMessagesSupported | Gets a value that determines if the resource message system is supported.
Public property | ScriptingSupported | Gets a value that determines if Scripting is supported on this device.
Public property | SerialPort0Settings | Gets the serial port settings for port 0.
Public property | SerialPort1Settings | Gets the serial port settings for port 1.
Public property | SerialSupportOnIO | Return true for 7000 series version >= 4.7.1 as this supports Serial RX and TX on input and output line 1 respectfully
Public property | SerialSupportOnIO_1 | Return true for 7000 series version >= 4.7.1 as this supports Serial RX and TX on input and output line 1 respectfully
Public property | SntpSettings | Gets the SNTP settings, if available.
Public property | SntpSupported | Gets a value that determines if SNTP is supported.
Public property | StartupJob | Gets or sets the name of the startup job.
Public property | StartupOnline | Gets or sets whether the In-Sight sensor will start (after power-up) in the online state.
Public property | TelnetPortSupported | Gets a value that determines if changing the Telnet port is supported.
Public property | TuneButtonSupported | Returns true if the camera has a tune button
Public property | UniversalIOSettings | Gets the universal input and output line settings, if available.
Public property | UniversalIOSupported | Returns true if the Universal I/O, or 1400 module, is supported.
Public property | UseLegacyResourceMessages | If true, resources start with "/sys/"; otherwise, resources start with "/".

See Also

CvsSettings Class
Cognex.InSight.Sensor Namespace


CvsSettings Methods

[image] [image]

In-Sight SDK
CvsSettings Methods
CvsSettings Class See Also Send Feedback

The CvsSettings type exposes the following members.

Methods

Name Description
Public method Clone
Creates a new object that is a deep copy of the current instance.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method GetFeatureFamily
Gets the feature family that describes the sensor's capabilities.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetNetworkNames
Gets all the names of the network settings.
Public method GetNetworkSettings
Gets the network settings for the name.
Public method GetSlowBaudRateSupportedFlags
Determines whether or not the 1200 and 2400 serial port baud rates are supported.
Public method GetSupportedIOModules
Returns a list of expansion I/O module types that this In-Sight Vision System supports.
GetSupportedLanguages
Gets the list of languages supported.

Remarks

Each language is represented by its culture name, as described in the National Language Support (NLS) API Reference (http://msdn.microsoft.com/en-us/goglobal/bb896001.aspx).
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method SerialPortSupported
Gets a value that determines if the specified serial port is supported.
Public method SetSerialPort1Settings
Sets the serial port 1 settings.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)

See Also

CvsSettings Class
Cognex.InSight.Sensor Namespace


CvsSettings.Clone Method

[image]

In-Sight SDK
CvsSettings..::..Clone Method
CvsSettings Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.GetFeatureFamily Method

[image]

In-Sight SDK
CvsSettings..::..GetFeatureFamily Method
CvsSettings Class See Also Send Feedback
Gets the feature family that describes the sensor's capabilities.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightFeatureFamily GetFeatureFamily()
Visual Basic
Public Function GetFeatureFamily As CvsInSightFeatureFamily

Return Value

Type: CvsInSightFeatureFamily
The feature families that describes this sensor's capabilities.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.GetNetworkNames Method

[image]

In-Sight SDK
CvsSettings..::..GetNetworkNames Method
CvsSettings Class See Also Send Feedback
Gets all the names of the network settings.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerable<string> GetNetworkNames()
Visual Basic
Public Function GetNetworkNames As IEnumerable(Of String)

Return Value

Type: IEnumerable <(Of <(<' String >)>)>
An IEnumerable<(Of <(<'T>)>)> of the network names.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.GetNetworkSettings Method

[image]

In-Sight SDK
CvsSettings..::..GetNetworkSettings Method
CvsSettings Class See Also Send Feedback
Gets the network settings for the name.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsNetworkSettings GetNetworkSettings(
    string name
)
Visual Basic
Public Function GetNetworkSettings (
    name As String
) As CvsNetworkSettings

Parameters

name
Type: System..::..String
The network name.

Return Value

Type: CvsNetworkSettings
The network settings from the map, or null if not found.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.GetSlowBaudRateSupportedFlags Method

[image]

In-Sight SDK
CvsSettings..::..GetSlowBaudRateSupportedFlags Method
CvsSettings Class See Also Send Feedback
Determines whether or not the 1200 and 2400 serial port baud rates are supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void GetSlowBaudRateSupportedFlags(
    bool expansionIOAttached,
    out bool allow1200,
    out bool allow2400
)
Visual Basic
Public Sub GetSlowBaudRateSupportedFlags (
    expansionIOAttached As Boolean,
    <OutAttribute> ByRef allow1200 As Boolean,
    <OutAttribute> ByRef allow2400 As Boolean
)

Parameters

expansionIOAttached
Type: System..::..Boolean
A flag that designates whether or not an IO module is attached to the sensor.
allow1200
Type: System..::..Boolean %
The value is true if the 1200 baud rate is supported.
allow2400
Type: System..::..Boolean %
The value is true if the 2400 baud rate is supported.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.GetSupportedIOModules Method

[image]

In-Sight SDK
CvsSettings..::..GetSupportedIOModules Method
CvsSettings Class See Also Send Feedback
Returns a list of expansion I/O module types that this In-Sight Vision System supports.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsIOModule[] GetSupportedIOModules()
Visual Basic
Public Function GetSupportedIOModules As CvsIOModule()

Return Value

Type: array< CvsIOModule >[]()[][]
An array of CvsIOModule types.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.GetSupportedLanguages Method

[image]

In-Sight SDK
CvsSettings..::..GetSupportedLanguages Method
CvsSettings Class See Also Send Feedback
Gets the list of languages supported.

Remarks

Each language is represented by its culture name, as described in the National Language Support (NLS) API Reference (http://msdn.microsoft.com/en-us/goglobal/bb896001.aspx).

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static IEnumerable<string> GetSupportedLanguages()
Visual Basic
Public Shared Function GetSupportedLanguages As IEnumerable(Of String)

Return Value

Type: IEnumerable <(Of <(<' String >)>)>
A collection of supported culture names.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.SerialPortSupported Method

[image]

In-Sight SDK
CvsSettings..::..SerialPortSupported Method
CvsSettings Class See Also Send Feedback
Gets a value that determines if the specified serial port is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SerialPortSupported(
    int port
)
Visual Basic
Public Function SerialPortSupported (
    port As Integer
) As Boolean

Parameters

port
Type: System..::..Int32
The serial port number (0 or 1).

Return Value

Type: Boolean
true if the serial port is supported, otherwise false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.SetSerialPort1Settings Method

[image]

In-Sight SDK
CvsSettings..::..SetSerialPort1Settings Method
CvsSettings Class See Also Send Feedback
Sets the serial port 1 settings.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetSerialPort1Settings(
    CvsSerialSettings serialPort1Settings
)
Visual Basic
Public Sub SetSerialPort1Settings (
    serialPort1Settings As CvsSerialSettings
)

Parameters

serialPort1Settings
Type: Cognex.InSight.Sensor..::..CvsSerialSettings
The settings to set.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings Properties

[image] [image]

In-Sight SDK
CvsSettings Properties
CvsSettings Class See Also Send Feedback

The CvsSettings type exposes the following members.

Properties

 | Name | Description
Public property | ActiveIOModule | Gets and sets the I/O module that should be used by the sensor.
Public property | ActiveIOModuleLines | Gets the CvsDiscreteIOLines for the currently active I/O Module specified by the ActiveIOModule property.
Public property | AuditMessageSettings | Gets the audit message settings.
Public property | AuditMessagesSupported | Gets a value that determines if audit messages are supported.
Public property | ConnectedIOModule | Gets the type of the connected I/O module.
Public property | DeEnergizeOutputsWhileOffline | Gets or sets whether the In-Sight sensor will de-energize outputs while offline.
Public property | DeEnergizeOutputsWhileOfflineSupported | Returns true if the de-energizing of outputs while offline is supported.
Public property | DiscreteIOSupported | Gets a value that determines if the device supports discrete IO, whether expansion or local.
Public property | DiscreteTriggerDelayTimeSupported | Gets a value that determines if discrete output's trigger delay time is supported.
Public property | EipWatchdogTimeoutActionSupported | Gets a value that determines if the EtherNet/IP Watchdog Timeout Action is supported.
Public property | EncoderOutputConfigured | Is the encoder configured
Public property | EncoderOutputSupport | Return true for 7000 series version >= 4.7.1 as this supports encode Phase B and A on input and output lines 2 and 3 respectfully NOTE: Not supported in 4.7.1 due to hardware issue
Public property | EncoderSupportOnIO_2and3 | Return true for 7000 series version >= 4.7.1 as this supports encode Phase B and A on input and output lines 2 and 3 respectfully NOTE: Not supported in 4.7.1 due to hardware issue
Public property | EthernetIOAddress | Gets or sets the IP Address or name of the Ethernet IO device to connect to
Public property | EthernetIOAddressSupported | Gets a value that determines if an extended ethernet IO address is supported.
Public property | EthernetIOInactivePollRate | Gets or sets maximum poll rate in milliseconds for the Ethernet IO connection during periods of inactivity.
Public property | EthernetIOPollRate | Gets or sets minimum poll rate in milliseconds for the Ethernet IO connection
Public property | EthernetIOSettings | Gets the Ethernet input and output line settings, if available.
Public property | EthernetIOSupported | Returns true if the Wago IO module is supported on this device
Public property | ExpansionIOMessagingSupported | Gets a value that determines if expansion IO is supported.
Public property | ExpansionIOSettings | Gets the serial expansion module input and output line settings, if available.
Public property | ExpansionIOSupported | Returns true if the 1450/1460 or 1400 are supported
Public property | ForceNetworkLinkModeSupported | Returns true if the In-Sight supports the network link mode option.
Public property | GuiActionRequestEventSupported | Gets a value that indicates if the GuiActionRequest event is supported.
Public property | HardwareStrobeSupported | Gets a value that determines if a hardware strobe is supported.
Public property | HmiServerSupported | Gets a value that determines if a the HMI Server is supported.
Public property | HmiSettings | Gets the Hmi settings, if available.
Public property | ImportExportSupported | Gets a value that determines if cell import/export is supported.
Public property | IOCameraMaskSupported | Determines whether the sensor supports camera masks on IO.
Public property | JobServerSettings | Gets the Remote Job Server Settings, if supported.
Public property | LicensingSupported | Gets a value that determines if licensing is supported.
Public property | LiveAcquisitionMaxImageRate | Gets or sets the maximum rate of images that are received when LiveAcquisition is true.
Public property | LiveAcquisitionResolution | Gets or sets the resolution of the images that are received when LiveAcquisition is true.
Public property | LiveImagesBitDepth | Gets or sets the bit depth for color images sent while in live mode.
Public property | LocalIOSettings | Gets the local input and output line settings.
Public property | MaxEthernetIOUpdateRate | Gets the maximum ethernet IO update rate. Maximum ethernet IO poll rate is the time the IO module gets data from the sensor frequently. This used to be 1000ms, but since ISE 4.1.1 (CR 67676), this value has been changed to 500ms for Micro, Micro-CC and WAGO.
Public property | MaxGuiConnections | Gets the maximum number of GUI connections (ISE, VisionView, and WebHMI) that the In-Sight supports.
Public property | MCProtocolScannerSupported | Gets a value that determines if MC Protocol Scanner is supported.
Public property | ModbusSettingsSupported | Gets a value that determines if modbus settings are supported.
Public property | NetworkSettings | Gets the network settings.
Public property | OnlineAcquisitionMaxImageRate | Gets or sets the maximum rate of images that are received when the sensor is online and acquiring images.
Public property | OnlineAcquisitionMaxImageRateSupported | Gets a value that determines if an online maximum image rate is supported.
Public property | OnlineImageResolution | Gets or sets the resolution of the images that are received when the sensor is online and acquiring images.
Public property | OnlineImageResolutionSupported | Gets a value that determines if changes to resolution while online are supported.
Public property | OnlineImagesBitDepth | Gets or sets the bit depth for color images sent while online.
Public property | OnlineJobSaveSupported | Gets a value that determines if saving a job while online is supported.
Public property | PowerlinkSettingsSupported | Gets a value that determines if the POWERLINK settings are supported.
Public property | ProfinetSettingsSupported | Gets a boolean that determines if the ProfiNet Settings is supported.
Public property | ProtectedUserOnlineOfflineSupported | Returns true if the online/offline option for Protected access users is supported.
Public property | ProtocolServiceSupported | Gets a value that determines if the Protocol Service is supported.
Public property | PTPTimeSynchSupported | Gets a value that determines if PTP Time Synchronization is supported.
Public property | RamDiskSize | Gets and sets the RAM disk size in bytes.
Public property | RamDiskSupported | Gets a value that determines if a RAM disk is supported.
Public property | RecordModeOnSensorSupported | Gets a value that determines if the record mode is supported on the sensor. That is, if the bit depth, image resolution and max image acquisition rate for recording are supported in firmware.
Public property | RemoteJobServerDirectorySupported | Gets a value that determines if a Remote Job Server Directory is supported.
Public property | RemoteJobServerSupported | Gets a value that determines if a Remote Job Server is supported.
Public property | ResourceMessagesSupported | Gets a value that determines if the resource message system is supported.
Public property | ScriptingSupported | Gets a value that determines if Scripting is supported on this device.
Public property | SerialPort0Settings | Gets the serial port settings for port 0.
Public property | SerialPort1Settings | Gets the serial port settings for port 1.
Public property | SerialSupportOnIO | Return true for 7000 series version >= 4.7.1 as this supports Serial RX and TX on input and output line 1 respectfully
Public property | SerialSupportOnIO_1 | Return true for 7000 series version >= 4.7.1 as this supports Serial RX and TX on input and output line 1 respectfully
Public property | SntpSettings | Gets the SNTP settings, if available.
Public property | SntpSupported | Gets a value that determines if SNTP is supported.
Public property | StartupJob | Gets or sets the name of the startup job.
Public property | StartupOnline | Gets or sets whether the In-Sight sensor will start (after power-up) in the online state.
Public property | TelnetPortSupported | Gets a value that determines if changing the Telnet port is supported.
Public property | TuneButtonSupported | Returns true if the camera has a tune button
Public property | UniversalIOSettings | Gets the universal input and output line settings, if available.
Public property | UniversalIOSupported | Returns true if the Universal I/O, or 1400 module, is supported.
Public property | UseLegacyResourceMessages | If true, resources start with "/sys/"; otherwise, resources start with "/".

See Also

CvsSettings Class
Cognex.InSight.Sensor Namespace


CvsSettings.ActiveIOModule Property

[image]

In-Sight SDK
CvsSettings..::..ActiveIOModule Property
CvsSettings Class See Also Send Feedback
Gets and sets the I/O module that should be used by the sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsIOModule ActiveIOModule { get; set; }
Visual Basic
Public Property ActiveIOModule As CvsIOModule
    Get
    Set

Property Value

Type: CvsIOModule

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.ActiveIOModuleLines Property

[image]

In-Sight SDK
CvsSettings..::..ActiveIOModuleLines Property
CvsSettings Class See Also Send Feedback
Gets the CvsDiscreteIOLines for the currently active I/O Module specified by the ActiveIOModule property.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsDiscreteIOLines ActiveIOModuleLines { get; }
Visual Basic
Public ReadOnly Property ActiveIOModuleLines As CvsDiscreteIOLines
    Get

Property Value

Type: CvsDiscreteIOLines

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.AuditMessageSettings Property

[image]

In-Sight SDK
CvsSettings..::..AuditMessageSettings Property
CvsSettings Class See Also Send Feedback
Gets the audit message settings.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsAuditMessageSettings AuditMessageSettings { get; }
Visual Basic
Public ReadOnly Property AuditMessageSettings As CvsAuditMessageSettings
    Get

Property Value

Type: CvsAuditMessageSettings

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.AuditMessagesSupported Property

[image]

In-Sight SDK
CvsSettings..::..AuditMessagesSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if audit messages are supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AuditMessagesSupported { get; }
Visual Basic
Public ReadOnly Property AuditMessagesSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.ConnectedIOModule Property

[image]

In-Sight SDK
CvsSettings..::..ConnectedIOModule Property
CvsSettings Class See Also Send Feedback
Gets the type of the connected I/O module.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsIOModule ConnectedIOModule { get; }
Visual Basic
Public ReadOnly Property ConnectedIOModule As CvsIOModule
    Get

Property Value

Type: CvsIOModule

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.DeEnergizeOutputsWhileOffline Property

[image]

In-Sight SDK
CvsSettings..::..DeEnergizeOutputsWhileOffline Property
CvsSettings Class See Also Send Feedback
Gets or sets whether the In-Sight sensor will de-energize outputs while offline.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool DeEnergizeOutputsWhileOffline { get; set; }
Visual Basic
Public Property DeEnergizeOutputsWhileOffline As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.DeEnergizeOutputsWhileOfflineSupported Property

[image]

In-Sight SDK
CvsSettings..::..DeEnergizeOutputsWhileOfflineSupported Property
CvsSettings Class See Also Send Feedback
Returns true if the de-energizing of outputs while offline is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool DeEnergizeOutputsWhileOfflineSupported { get; }
Visual Basic
Public ReadOnly Property DeEnergizeOutputsWhileOfflineSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.DiscreteIOSupported Property

[image]

In-Sight SDK
CvsSettings..::..DiscreteIOSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if the device supports discrete IO, whether expansion or local.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool DiscreteIOSupported { get; }
Visual Basic
Public ReadOnly Property DiscreteIOSupported As Boolean
    Get

Property Value

Type: Boolean
true if the device supports discrete IO, whether expansion or local; otherwise, false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.DiscreteTriggerDelayTimeSupported Property

[image]

In-Sight SDK
CvsSettings..::..DiscreteTriggerDelayTimeSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if discrete output's trigger delay time is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool DiscreteTriggerDelayTimeSupported { get; }
Visual Basic
Public ReadOnly Property DiscreteTriggerDelayTimeSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.EipWatchdogTimeoutActionSupported Property

[image]

In-Sight SDK
CvsSettings..::..EipWatchdogTimeoutActionSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if the EtherNet/IP Watchdog Timeout Action is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool EipWatchdogTimeoutActionSupported { get; }
Visual Basic
Public ReadOnly Property EipWatchdogTimeoutActionSupported As Boolean
    Get

Property Value

Type: Boolean
true if the EtherNet/IP Watchdog Timeout Action is supported; otherwise, false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.EncoderOutputConfigured Property

[image]

In-Sight SDK
CvsSettings..::..EncoderOutputConfigured Property
CvsSettings Class See Also Send Feedback
Is the encoder configured

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool EncoderOutputConfigured { get; }
Visual Basic
Public ReadOnly Property EncoderOutputConfigured As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.EncoderOutputSupport Property

[image]

In-Sight SDK
CvsSettings..::..EncoderOutputSupport Property
CvsSettings Class See Also Send Feedback
Return true for 7000 series version >= 4.7.1 as this supports encode Phase B and A on input and output lines 2 and 3 respectfully NOTE: Not supported in 4.7.1 due to hardware issue

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool EncoderOutputSupport { get; }
Visual Basic
Public ReadOnly Property EncoderOutputSupport As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.EncoderSupportOnIO_2and3 Property

[image]

In-Sight SDK
CvsSettings..::..EncoderSupportOnIO_2and3 Property
CvsSettings Class See Also Send Feedback
Return true for 7000 series version >= 4.7.1 as this supports encode Phase B and A on input and output lines 2 and 3 respectfully NOTE: Not supported in 4.7.1 due to hardware issue

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool EncoderSupportOnIO_2and3 { get; }
Visual Basic
Public ReadOnly Property EncoderSupportOnIO_2and3 As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.EthernetIOAddress Property

[image]

In-Sight SDK
CvsSettings..::..EthernetIOAddress Property
CvsSettings Class See Also Send Feedback
Gets or sets the IP Address or name of the Ethernet IO device to connect to

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string EthernetIOAddress { get; set; }
Visual Basic
Public Property EthernetIOAddress As String
    Get
    Set

Property Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentException | Thrown if the specified address is not a valid IP Address

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.EthernetIOAddressSupported Property

[image]

In-Sight SDK
CvsSettings..::..EthernetIOAddressSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if an extended ethernet IO address is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool EthernetIOAddressSupported { get; }
Visual Basic
Public ReadOnly Property EthernetIOAddressSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.EthernetIOInactivePollRate Property

[image]

In-Sight SDK
CvsSettings..::..EthernetIOInactivePollRate Property
CvsSettings Class See Also Send Feedback
Gets or sets maximum poll rate in milliseconds for the Ethernet IO connection during periods of inactivity.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int EthernetIOInactivePollRate { get; set; }
Visual Basic
Public Property EthernetIOInactivePollRate As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.EthernetIOPollRate Property

[image]

In-Sight SDK
CvsSettings..::..EthernetIOPollRate Property
CvsSettings Class See Also Send Feedback
Gets or sets minimum poll rate in milliseconds for the Ethernet IO connection

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int EthernetIOPollRate { get; set; }
Visual Basic
Public Property EthernetIOPollRate As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.EthernetIOSettings Property

[image]

In-Sight SDK
CvsSettings..::..EthernetIOSettings Property
CvsSettings Class See Also Send Feedback
Gets the Ethernet input and output line settings, if available.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsExpansionIOSettings EthernetIOSettings { get; }
Visual Basic
Public ReadOnly Property EthernetIOSettings As CvsExpansionIOSettings
    Get

Property Value

Type: CvsExpansionIOSettings
The line settings or null if they are not available.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.EthernetIOSupported Property

[image]

In-Sight SDK
CvsSettings..::..EthernetIOSupported Property
CvsSettings Class See Also Send Feedback
Returns true if the Wago IO module is supported on this device

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool EthernetIOSupported { get; }
Visual Basic
Public ReadOnly Property EthernetIOSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.ExpansionIOMessagingSupported Property

[image]

In-Sight SDK
CvsSettings..::..ExpansionIOMessagingSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if expansion IO is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ExpansionIOMessagingSupported { get; }
Visual Basic
Public ReadOnly Property ExpansionIOMessagingSupported As Boolean
    Get

Property Value

Type: Boolean
true if expansion input/output lines are supported, otherwise false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.ExpansionIOSettings Property

[image]

In-Sight SDK
CvsSettings..::..ExpansionIOSettings Property
CvsSettings Class See Also Send Feedback
Gets the serial expansion module input and output line settings, if available.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsExpansionIOSettings ExpansionIOSettings { get; }
Visual Basic
Public ReadOnly Property ExpansionIOSettings As CvsExpansionIOSettings
    Get

Property Value

Type: CvsExpansionIOSettings
The line settings or null if they are not available.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.ExpansionIOSupported Property

[image]

In-Sight SDK
CvsSettings..::..ExpansionIOSupported Property
CvsSettings Class See Also Send Feedback
Returns true if the 1450/1460 or 1400 are supported

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ExpansionIOSupported { get; }
Visual Basic
Public ReadOnly Property ExpansionIOSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.ForceNetworkLinkModeSupported Property

[image]

In-Sight SDK
CvsSettings..::..ForceNetworkLinkModeSupported Property
CvsSettings Class See Also Send Feedback
Returns true if the In-Sight supports the network link mode option.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ForceNetworkLinkModeSupported { get; }
Visual Basic
Public ReadOnly Property ForceNetworkLinkModeSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.GuiActionRequestEventSupported Property

[image]

In-Sight SDK
CvsSettings..::..GuiActionRequestEventSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that indicates if the GuiActionRequest event is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool GuiActionRequestEventSupported { get; }
Visual Basic
Public ReadOnly Property GuiActionRequestEventSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.HardwareStrobeSupported Property

[image]

In-Sight SDK
CvsSettings..::..HardwareStrobeSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if a hardware strobe is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool HardwareStrobeSupported { get; }
Visual Basic
Public ReadOnly Property HardwareStrobeSupported As Boolean
    Get

Property Value

Type: Boolean
true if a hardware strobe is supported, otherwise false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.HmiServerSupported Property

[image]

In-Sight SDK
CvsSettings..::..HmiServerSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if a the HMI Server is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool HmiServerSupported { get; }
Visual Basic
Public ReadOnly Property HmiServerSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.HmiSettings Property

[image]

In-Sight SDK
CvsSettings..::..HmiSettings Property
CvsSettings Class See Also Send Feedback
Gets the Hmi settings, if available.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsHmiSettings HmiSettings { get; }
Visual Basic
Public ReadOnly Property HmiSettings As CvsHmiSettings
    Get

Property Value

Type: CvsHmiSettings
The HMI settings or null if they are not available.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.ImportExportSupported Property

[image]

In-Sight SDK
CvsSettings..::..ImportExportSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if cell import/export is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ImportExportSupported { get; }
Visual Basic
Public ReadOnly Property ImportExportSupported As Boolean
    Get

Property Value

Type: Boolean
true if cell import/export is supported; otherwise, false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.IOCameraMaskSupported Property

[image]

In-Sight SDK
CvsSettings..::..IOCameraMaskSupported Property
CvsSettings Class See Also Send Feedback
Determines whether the sensor supports camera masks on IO.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IOCameraMaskSupported { get; }
Visual Basic
Public ReadOnly Property IOCameraMaskSupported As Boolean
    Get

Property Value

Type: Boolean

Remarks

Currently only supported with 5.1 software and vision core.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.JobServerSettings Property

[image]

In-Sight SDK
CvsSettings..::..JobServerSettings Property
CvsSettings Class See Also Send Feedback
Gets the Remote Job Server Settings, if supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsJobServerSettings JobServerSettings { get; }
Visual Basic
Public ReadOnly Property JobServerSettings As CvsJobServerSettings
    Get

Property Value

Type: CvsJobServerSettings
The Job Server Settings or null if not supported.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.LicensingSupported Property

[image]

In-Sight SDK
CvsSettings..::..LicensingSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if licensing is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool LicensingSupported { get; }
Visual Basic
Public ReadOnly Property LicensingSupported As Boolean
    Get

Property Value

Type: Boolean
true if licensing is supported, otherwise false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.LiveAcquisitionMaxImageRate Property

[image]

In-Sight SDK
CvsSettings..::..LiveAcquisitionMaxImageRate Property
CvsSettings Class See Also Send Feedback
Gets or sets the maximum rate of images that are received when LiveAcquisition is true.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float LiveAcquisitionMaxImageRate { get; set; }
Visual Basic
Public Property LiveAcquisitionMaxImageRate As Single
    Get
    Set

Property Value

Type: Single

Remarks

Zero is the default and designates that as many images will be received as possible. Positive numbers designate the maximum number of images per second that will be received. Setting this property has no effect unless the sensor has firmware version 3.1 or later. Previous versions of firmware always send as many images as possible during live acquisition.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is negative.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.LiveAcquisitionResolution Property

[image]

In-Sight SDK
CvsSettings..::..LiveAcquisitionResolution Property
CvsSettings Class See Also Send Feedback
Gets or sets the resolution of the images that are received when LiveAcquisition is true.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageResolution LiveAcquisitionResolution { get; set; }
Visual Basic
Public Property LiveAcquisitionResolution As CvsImageResolution
    Get
    Set

Property Value

Type: CvsImageResolution

Remarks

Setting this property has no effect unless the sensor has firmware version 3.1 or later. Previous versions of firmware always send half-resolution images during live acquisition.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a CvsImageResolution.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.LiveImagesBitDepth Property

[image]

In-Sight SDK
CvsSettings..::..LiveImagesBitDepth Property
CvsSettings Class See Also Send Feedback
Gets or sets the bit depth for color images sent while in live mode.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsColorBitDepth LiveImagesBitDepth { get; set; }
Visual Basic
Public Property LiveImagesBitDepth As CvsColorBitDepth
    Get
    Set

Property Value

Type: CvsColorBitDepth

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.LocalIOSettings Property

[image]

In-Sight SDK
CvsSettings..::..LocalIOSettings Property
CvsSettings Class See Also Send Feedback
Gets the local input and output line settings.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsLocalIOSettings LocalIOSettings { get; }
Visual Basic
Public ReadOnly Property LocalIOSettings As CvsLocalIOSettings
    Get

Property Value

Type: CvsLocalIOSettings

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.MaxEthernetIOUpdateRate Property

[image]

In-Sight SDK
CvsSettings..::..MaxEthernetIOUpdateRate Property
CvsSettings Class See Also Send Feedback
Gets the maximum ethernet IO update rate. Maximum ethernet IO poll rate is the time the IO module gets data from the sensor frequently. This used to be 1000ms, but since ISE 4.1.1 (CR 67676), this value has been changed to 500ms for Micro, Micro-CC and WAGO.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxEthernetIOUpdateRate { get; }
Visual Basic
Public ReadOnly Property MaxEthernetIOUpdateRate As Integer
    Get

Property Value

Type: Int32

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.MaxGuiConnections Property

[image]

In-Sight SDK
CvsSettings..::..MaxGuiConnections Property
CvsSettings Class See Also Send Feedback
Gets the maximum number of GUI connections (ISE, VisionView, and WebHMI) that the In-Sight supports.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int MaxGuiConnections { get; }
Visual Basic
Public ReadOnly Property MaxGuiConnections As Integer
    Get

Property Value

Type: Int32

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.MCProtocolScannerSupported Property

[image]

In-Sight SDK
CvsSettings..::..MCProtocolScannerSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if MC Protocol Scanner is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool MCProtocolScannerSupported { get; }
Visual Basic
Public ReadOnly Property MCProtocolScannerSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.ModbusSettingsSupported Property

[image]

In-Sight SDK
CvsSettings..::..ModbusSettingsSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if modbus settings are supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ModbusSettingsSupported { get; }
Visual Basic
Public ReadOnly Property ModbusSettingsSupported As Boolean
    Get

Property Value

Type: Boolean
true if modbus settings are supported; otherwise, false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.NetworkSettings Property

[image]

In-Sight SDK
CvsSettings..::..NetworkSettings Property
CvsSettings Class See Also Send Feedback
Gets the network settings.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsNetworkSettings NetworkSettings { get; }
Visual Basic
Public ReadOnly Property NetworkSettings As CvsNetworkSettings
    Get

Property Value

Type: CvsNetworkSettings

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.OnlineAcquisitionMaxImageRate Property

[image]

In-Sight SDK
CvsSettings..::..OnlineAcquisitionMaxImageRate Property
CvsSettings Class See Also Send Feedback
Gets or sets the maximum rate of images that are received when the sensor is online and acquiring images.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public float OnlineAcquisitionMaxImageRate { get; set; }
Visual Basic
Public Property OnlineAcquisitionMaxImageRate As Single
    Get
    Set

Property Value

Type: Single

Remarks

Zero is the default and designates that as many images will be received as possible. Positive numbers designate the maximum number of images per second that will be received. Setting this property has no effect unless the sensor has firmware version 3.1 or later.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is negative.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.OnlineAcquisitionMaxImageRateSupported Property

[image]

In-Sight SDK
CvsSettings..::..OnlineAcquisitionMaxImageRateSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if an online maximum image rate is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool OnlineAcquisitionMaxImageRateSupported { get; }
Visual Basic
Public ReadOnly Property OnlineAcquisitionMaxImageRateSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.OnlineImageResolution Property

[image]

In-Sight SDK
CvsSettings..::..OnlineImageResolution Property
CvsSettings Class See Also Send Feedback
Gets or sets the resolution of the images that are received when the sensor is online and acquiring images.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsImageResolution OnlineImageResolution { get; set; }
Visual Basic
Public Property OnlineImageResolution As CvsImageResolution
    Get
    Set

Property Value

Type: CvsImageResolution

Remarks

Setting this property has no effect unless the sensor has firmware version 3.1 or later. Previous versions of firmware always send half-resolution images when the sensor is online.

Default designates a half resolution image.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not a CvsImageResolution.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.OnlineImageResolutionSupported Property

[image]

In-Sight SDK
CvsSettings..::..OnlineImageResolutionSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if changes to resolution while online are supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool OnlineImageResolutionSupported { get; }
Visual Basic
Public ReadOnly Property OnlineImageResolutionSupported As Boolean
    Get

Property Value

Type: Boolean
true if changes to resolution while online are supported; otherwise, false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.OnlineImagesBitDepth Property

[image]

In-Sight SDK
CvsSettings..::..OnlineImagesBitDepth Property
CvsSettings Class See Also Send Feedback
Gets or sets the bit depth for color images sent while online.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsColorBitDepth OnlineImagesBitDepth { get; set; }
Visual Basic
Public Property OnlineImagesBitDepth As CvsColorBitDepth
    Get
    Set

Property Value

Type: CvsColorBitDepth

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.OnlineJobSaveSupported Property

[image]

In-Sight SDK
CvsSettings..::..OnlineJobSaveSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if saving a job while online is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool OnlineJobSaveSupported { get; }
Visual Basic
Public ReadOnly Property OnlineJobSaveSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.PowerlinkSettingsSupported Property

[image]

In-Sight SDK
CvsSettings..::..PowerlinkSettingsSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if the POWERLINK settings are supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool PowerlinkSettingsSupported { get; }
Visual Basic
Public ReadOnly Property PowerlinkSettingsSupported As Boolean
    Get

Property Value

Type: Boolean
true if the POWERLINK settings are supported; otherwise, false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.ProfinetSettingsSupported Property

[image]

In-Sight SDK
CvsSettings..::..ProfinetSettingsSupported Property
CvsSettings Class See Also Send Feedback
Gets a boolean that determines if the ProfiNet Settings is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ProfinetSettingsSupported { get; }
Visual Basic
Public ReadOnly Property ProfinetSettingsSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.ProtectedUserOnlineOfflineSupported Property

[image]

In-Sight SDK
CvsSettings..::..ProtectedUserOnlineOfflineSupported Property
CvsSettings Class See Also Send Feedback
Returns true if the online/offline option for Protected access users is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ProtectedUserOnlineOfflineSupported { get; }
Visual Basic
Public ReadOnly Property ProtectedUserOnlineOfflineSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.ProtocolServiceSupported Property

[image]

In-Sight SDK
CvsSettings..::..ProtocolServiceSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if the Protocol Service is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ProtocolServiceSupported { get; }
Visual Basic
Public ReadOnly Property ProtocolServiceSupported As Boolean
    Get

Property Value

Type: Boolean
true if the Protocol Service is supported; otherwise, false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.PTPTimeSynchSupported Property

[image]

In-Sight SDK
CvsSettings..::..PTPTimeSynchSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if PTP Time Synchronization is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool PTPTimeSynchSupported { get; }
Visual Basic
Public ReadOnly Property PTPTimeSynchSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.RamDiskSize Property

[image]

In-Sight SDK
CvsSettings..::..RamDiskSize Property
CvsSettings Class See Also Send Feedback
Gets and sets the RAM disk size in bytes.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int RamDiskSize { get; set; }
Visual Basic
Public Property RamDiskSize As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.RamDiskSupported Property

[image]

In-Sight SDK
CvsSettings..::..RamDiskSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if a RAM disk is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool RamDiskSupported { get; }
Visual Basic
Public ReadOnly Property RamDiskSupported As Boolean
    Get

Property Value

Type: Boolean
true if a RAM disk is supported, otherwise false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.RecordModeOnSensorSupported Property

[image]

In-Sight SDK
CvsSettings..::..RecordModeOnSensorSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if the record mode is supported on the sensor. That is, if the bit depth, image resolution and max image acquisition rate for recording are supported in firmware.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool RecordModeOnSensorSupported { get; }
Visual Basic
Public ReadOnly Property RecordModeOnSensorSupported As Boolean
    Get

Property Value

Type: Boolean
true if the record mode is supported on the sensor; otherwise, false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.RemoteJobServerDirectorySupported Property

[image]

In-Sight SDK
CvsSettings..::..RemoteJobServerDirectorySupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if a Remote Job Server Directory is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool RemoteJobServerDirectorySupported { get; }
Visual Basic
Public ReadOnly Property RemoteJobServerDirectorySupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.RemoteJobServerSupported Property

[image]

In-Sight SDK
CvsSettings..::..RemoteJobServerSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if a Remote Job Server is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool RemoteJobServerSupported { get; }
Visual Basic
Public ReadOnly Property RemoteJobServerSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.ResourceMessagesSupported Property

[image]

In-Sight SDK
CvsSettings..::..ResourceMessagesSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if the resource message system is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ResourceMessagesSupported { get; }
Visual Basic
Public ReadOnly Property ResourceMessagesSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.ScriptingSupported Property

[image]

In-Sight SDK
CvsSettings..::..ScriptingSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if Scripting is supported on this device.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool ScriptingSupported { get; }
Visual Basic
Public ReadOnly Property ScriptingSupported As Boolean
    Get

Property Value

Type: Boolean
true if Scripting is supported on this device; otherwise, false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.SerialPort0Settings Property

[image]

In-Sight SDK
CvsSettings..::..SerialPort0Settings Property
CvsSettings Class See Also Send Feedback
Gets the serial port settings for port 0.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSerialSettings SerialPort0Settings { get; }
Visual Basic
Public ReadOnly Property SerialPort0Settings As CvsSerialSettings
    Get

Property Value

Type: CvsSerialSettings

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.SerialPort1Settings Property

[image]

In-Sight SDK
CvsSettings..::..SerialPort1Settings Property
CvsSettings Class See Also Send Feedback
Gets the serial port settings for port 1.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSerialSettings SerialPort1Settings { get; }
Visual Basic
Public ReadOnly Property SerialPort1Settings As CvsSerialSettings
    Get

Property Value

Type: CvsSerialSettings

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.SerialSupportOnIO Property

[image]

In-Sight SDK
CvsSettings..::..SerialSupportOnIO Property
CvsSettings Class See Also Send Feedback
Return true for 7000 series version >= 4.7.1 as this supports Serial RX and TX on input and output line 1 respectfully

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SerialSupportOnIO { get; }
Visual Basic
Public ReadOnly Property SerialSupportOnIO As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.SerialSupportOnIO_1 Property

[image]

In-Sight SDK
CvsSettings..::..SerialSupportOnIO_1 Property
CvsSettings Class See Also Send Feedback
Return true for 7000 series version >= 4.7.1 as this supports Serial RX and TX on input and output line 1 respectfully

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SerialSupportOnIO_1 { get; }
Visual Basic
Public ReadOnly Property SerialSupportOnIO_1 As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.SntpSettings Property

[image]

In-Sight SDK
CvsSettings..::..SntpSettings Property
CvsSettings Class See Also Send Feedback
Gets the SNTP settings, if available.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsSntpSettings SntpSettings { get; }
Visual Basic
Public ReadOnly Property SntpSettings As CvsSntpSettings
    Get

Property Value

Type: CvsSntpSettings
The SNTP settings or null if they are not available.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.SntpSupported Property

[image]

In-Sight SDK
CvsSettings..::..SntpSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if SNTP is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SntpSupported { get; }
Visual Basic
Public ReadOnly Property SntpSupported As Boolean
    Get

Property Value

Type: Boolean
true if SNTP is supported, otherwise false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.StartupJob Property

[image]

In-Sight SDK
CvsSettings..::..StartupJob Property
CvsSettings Class See Also Send Feedback
Gets or sets the name of the startup job.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string StartupJob { get; set; }
Visual Basic
Public Property StartupJob As String
    Get
    Set

Property Value

Type: String

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.StartupOnline Property

[image]

In-Sight SDK
CvsSettings..::..StartupOnline Property
CvsSettings Class See Also Send Feedback
Gets or sets whether the In-Sight sensor will start (after power-up) in the online state.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool StartupOnline { get; set; }
Visual Basic
Public Property StartupOnline As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.TelnetPortSupported Property

[image]

In-Sight SDK
CvsSettings..::..TelnetPortSupported Property
CvsSettings Class See Also Send Feedback
Gets a value that determines if changing the Telnet port is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool TelnetPortSupported { get; }
Visual Basic
Public ReadOnly Property TelnetPortSupported As Boolean
    Get

Property Value

Type: Boolean
true if changing the Telnet port is supported; otherwise, false.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.TuneButtonSupported Property

[image]

In-Sight SDK
CvsSettings..::..TuneButtonSupported Property
CvsSettings Class See Also Send Feedback
Returns true if the camera has a tune button

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool TuneButtonSupported { get; }
Visual Basic
Public ReadOnly Property TuneButtonSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.UniversalIOSettings Property

[image]

In-Sight SDK
CvsSettings..::..UniversalIOSettings Property
CvsSettings Class See Also Send Feedback
Gets the universal input and output line settings, if available.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsUniversalIOSettings UniversalIOSettings { get; }
Visual Basic
Public ReadOnly Property UniversalIOSettings As CvsUniversalIOSettings
    Get

Property Value

Type: CvsUniversalIOSettings
The line settings or null if they are not available.

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.UniversalIOSupported Property

[image]

In-Sight SDK
CvsSettings..::..UniversalIOSupported Property
CvsSettings Class See Also Send Feedback
Returns true if the Universal I/O, or 1400 module, is supported.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool UniversalIOSupported { get; }
Visual Basic
Public ReadOnly Property UniversalIOSupported As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSettings.UseLegacyResourceMessages Property

[image]

In-Sight SDK
CvsSettings..::..UseLegacyResourceMessages Property
CvsSettings Class See Also Send Feedback
If true, resources start with "/sys/"; otherwise, resources start with "/".

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool UseLegacyResourceMessages { get; }
Visual Basic
Public ReadOnly Property UseLegacyResourceMessages As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSettings Class
CvsSettings..::..CvsSettings Members
Cognex.InSight.Sensor Namespace


CvsSntpCurrentData Class

[image]

In-Sight SDK
CvsSntpCurrentData Class
Members See Also Send Feedback
Holds the current SNTP settings for an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsSntpCurrentData : ICloneable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsSntpCurrentData
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsSntpCurrentData

See Also

CvsSntpCurrentData..::..CvsSntpCurrentData Members
Cognex.InSight.Sensor Namespace


CvsSntpCurrentData Members

[image] [image]

In-Sight SDK
CvsSntpCurrentData Members
CvsSntpCurrentData Class Methods Properties See Also Send Feedback

The CvsSntpCurrentData type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SntpServer | Gets a string that represents the SNTP server in dotted notation.
Public property | TimeDateData | Gets the associated time and date information.

See Also

CvsSntpCurrentData Class
Cognex.InSight.Sensor Namespace


CvsSntpCurrentData Methods

[image] [image]

In-Sight SDK
CvsSntpCurrentData Methods
CvsSntpCurrentData Class See Also Send Feedback

The CvsSntpCurrentData type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsSntpCurrentData Class
Cognex.InSight.Sensor Namespace


CvsSntpCurrentData.Clone Method

[image]

In-Sight SDK
CvsSntpCurrentData..::..Clone Method
CvsSntpCurrentData Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsSntpCurrentData Class
CvsSntpCurrentData..::..CvsSntpCurrentData Members
Cognex.InSight.Sensor Namespace


CvsSntpCurrentData Properties

[image] [image]

In-Sight SDK
CvsSntpCurrentData Properties
CvsSntpCurrentData Class See Also Send Feedback

The CvsSntpCurrentData type exposes the following members.

Properties

 | Name | Description
Public property | SntpServer | Gets a string that represents the SNTP server in dotted notation.
Public property | TimeDateData | Gets the associated time and date information.

See Also

CvsSntpCurrentData Class
Cognex.InSight.Sensor Namespace


CvsSntpCurrentData.SntpServer Property

[image]

In-Sight SDK
CvsSntpCurrentData..::..SntpServer Property
CvsSntpCurrentData Class See Also Send Feedback
Gets a string that represents the SNTP server in dotted notation.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string SntpServer { get; }
Visual Basic
Public ReadOnly Property SntpServer As String
    Get

Property Value

Type: String

See Also

CvsSntpCurrentData Class
CvsSntpCurrentData..::..CvsSntpCurrentData Members
Cognex.InSight.Sensor Namespace


CvsSntpCurrentData.TimeDateData Property

[image]

In-Sight SDK
CvsSntpCurrentData..::..TimeDateData Property
CvsSntpCurrentData Class See Also Send Feedback
Gets the associated time and date information.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsTimeDateData TimeDateData { get; }
Visual Basic
Public ReadOnly Property TimeDateData As CvsTimeDateData
    Get

Property Value

Type: CvsTimeDateData

See Also

CvsSntpCurrentData Class
CvsSntpCurrentData..::..CvsSntpCurrentData Members
Cognex.InSight.Sensor Namespace


CvsSntpSettings Class

[image]

In-Sight SDK
CvsSntpSettings Class
Members See Also Send Feedback
Holds the SNTP settings for an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsSntpSettings : ICloneable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsSntpSettings
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsSntpSettings

See Also

CvsSntpSettings..::..CvsSntpSettings Members
Cognex.InSight.Sensor Namespace


CvsSntpSettings Members

[image] [image]

In-Sight SDK
CvsSntpSettings Members
CvsSntpSettings Class Methods Fields Properties See Also Send Feedback

The CvsSntpSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetSntpAndDhcpUsage | Enables/Disables SNTP and DHCP usage.
Public method | SetTimeZoneId | Sets the time zone identifier.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
MaxSntpUpdateInterval | The maximum update interval in minutes.
MinSntpUpdateInterval | The minimum update interval in minutes.

Properties

 | Name | Description
Public property | AdjustForDaylightSavingsTimeEnabled | Gets or sets whether adjusting for daylight savings time is enabled.
Public property | AlternateServer | Gets or sets the alternate server.
Public property | LocateUsingDhcpEnabled | Gets a value that determines if DHCP locating is enabled.
Public property | PreferredServer | Gets or sets the preferred server.
Public property | SntpEnabled | Get a value the determines if the SNTP is in use.
Public property | TimeZoneId | Gets the time zone identifier.
Public property | UpdateInterval | Gets or sets the update interval in minutes. Valid values are between 15 and 1440.

See Also

CvsSntpSettings Class
Cognex.InSight.Sensor Namespace


CvsSntpSettings Fields

[image] [image]

In-Sight SDK
CvsSntpSettings Fields
CvsSntpSettings Class See Also Send Feedback

The CvsSntpSettings type exposes the following members.

Fields

Name | Description
MaxSntpUpdateInterval | The maximum update interval in minutes.
MinSntpUpdateInterval | The minimum update interval in minutes.

See Also

CvsSntpSettings Class
Cognex.InSight.Sensor Namespace


CvsSntpSettings.MaxSntpUpdateInterval Field

[image]

In-Sight SDK
CvsSntpSettings..::..MaxSntpUpdateInterval Field
CvsSntpSettings Class See Also Send Feedback
The maximum update interval in minutes.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxSntpUpdateInterval
Visual Basic
Public Const MaxSntpUpdateInterval As Integer

Field Value

Type: Int32

See Also

CvsSntpSettings Class
CvsSntpSettings..::..CvsSntpSettings Members
Cognex.InSight.Sensor Namespace


CvsSntpSettings.MinSntpUpdateInterval Field

[image]

In-Sight SDK
CvsSntpSettings..::..MinSntpUpdateInterval Field
CvsSntpSettings Class See Also Send Feedback
The minimum update interval in minutes.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MinSntpUpdateInterval
Visual Basic
Public Const MinSntpUpdateInterval As Integer

Field Value

Type: Int32

See Also

CvsSntpSettings Class
CvsSntpSettings..::..CvsSntpSettings Members
Cognex.InSight.Sensor Namespace


CvsSntpSettings Methods

[image] [image]

In-Sight SDK
CvsSntpSettings Methods
CvsSntpSettings Class See Also Send Feedback

The CvsSntpSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetSntpAndDhcpUsage | Enables/Disables SNTP and DHCP usage.
Public method | SetTimeZoneId | Sets the time zone identifier.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsSntpSettings Class
Cognex.InSight.Sensor Namespace


CvsSntpSettings.Clone Method

[image]

In-Sight SDK
CvsSntpSettings..::..Clone Method
CvsSntpSettings Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsSntpSettings Class
CvsSntpSettings..::..CvsSntpSettings Members
Cognex.InSight.Sensor Namespace


CvsSntpSettings.SetSntpAndDhcpUsage Method

[image]

In-Sight SDK
CvsSntpSettings..::..SetSntpAndDhcpUsage Method
CvsSntpSettings Class See Also Send Feedback
Enables/Disables SNTP and DHCP usage.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetSntpAndDhcpUsage(
    bool enableSntp,
    bool useDhcp
)
Visual Basic
Public Sub SetSntpAndDhcpUsage (
    enableSntp As Boolean,
    useDhcp As Boolean
)

Parameters

enableSntp
Type: System..::..Boolean
The flag that enables/disables SNTP.
useDhcp
Type: System..::..Boolean
The flag that enables/disables DHCP.

Remarks

If SNTP is disabled, the DHCP setting is ignored.

See Also

CvsSntpSettings Class
CvsSntpSettings..::..CvsSntpSettings Members
Cognex.InSight.Sensor Namespace


CvsSntpSettings.SetTimeZoneId Method

[image]

In-Sight SDK
CvsSntpSettings..::..SetTimeZoneId Method
CvsSntpSettings Class See Also Send Feedback
Sets the time zone identifier.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void SetTimeZoneId(
    CvsTimeZones timeZoneObject,
    int timeZoneId
)
Visual Basic
Public Sub SetTimeZoneId (
    timeZoneObject As CvsTimeZones,
    timeZoneId As Integer
)

Parameters

timeZoneObject
Type: Cognex.InSight.Sensor..::..CvsTimeZones
The time zone object.
timeZoneId
Type: System..::..Int32
The time zone ID.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | timeZoneId is not valid.

See Also

CvsSntpSettings Class
CvsSntpSettings..::..CvsSntpSettings Members
Cognex.InSight.Sensor Namespace


CvsSntpSettings Properties

[image] [image]

In-Sight SDK
CvsSntpSettings Properties
CvsSntpSettings Class See Also Send Feedback

The CvsSntpSettings type exposes the following members.

Properties

 | Name | Description
Public property | AdjustForDaylightSavingsTimeEnabled | Gets or sets whether adjusting for daylight savings time is enabled.
Public property | AlternateServer | Gets or sets the alternate server.
Public property | LocateUsingDhcpEnabled | Gets a value that determines if DHCP locating is enabled.
Public property | PreferredServer | Gets or sets the preferred server.
Public property | SntpEnabled | Get a value the determines if the SNTP is in use.
Public property | TimeZoneId | Gets the time zone identifier.
Public property | UpdateInterval | Gets or sets the update interval in minutes. Valid values are between 15 and 1440.

See Also

CvsSntpSettings Class
Cognex.InSight.Sensor Namespace


CvsSntpSettings.AdjustForDaylightSavingsTimeEnabled Property

[image]

In-Sight SDK
CvsSntpSettings..::..AdjustForDaylightSavingsTimeEnabled Property
CvsSntpSettings Class See Also Send Feedback
Gets or sets whether adjusting for daylight savings time is enabled.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool AdjustForDaylightSavingsTimeEnabled { get; set; }
Visual Basic
Public Property AdjustForDaylightSavingsTimeEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsSntpSettings Class
CvsSntpSettings..::..CvsSntpSettings Members
Cognex.InSight.Sensor Namespace


CvsSntpSettings.AlternateServer Property

[image]

In-Sight SDK
CvsSntpSettings..::..AlternateServer Property
CvsSntpSettings Class See Also Send Feedback
Gets or sets the alternate server.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string AlternateServer { get; set; }
Visual Basic
Public Property AlternateServer As String
    Get
    Set

Property Value

Type: String

Remarks

The value must be a valid host name. This may be verified with IsValidHostName(String, Boolean).

Exceptions

Exception | Condition
System..::..ArgumentException | value is not a valid host name.

See Also

CvsSntpSettings Class
CvsSntpSettings..::..CvsSntpSettings Members
Cognex.InSight.Sensor Namespace


CvsSntpSettings.LocateUsingDhcpEnabled Property

[image]

In-Sight SDK
CvsSntpSettings..::..LocateUsingDhcpEnabled Property
CvsSntpSettings Class See Also Send Feedback
Gets a value that determines if DHCP locating is enabled.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool LocateUsingDhcpEnabled { get; }
Visual Basic
Public ReadOnly Property LocateUsingDhcpEnabled As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSntpSettings Class
CvsSntpSettings..::..CvsSntpSettings Members
Cognex.InSight.Sensor Namespace


CvsSntpSettings.PreferredServer Property

[image]

In-Sight SDK
CvsSntpSettings..::..PreferredServer Property
CvsSntpSettings Class See Also Send Feedback
Gets or sets the preferred server.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string PreferredServer { get; set; }
Visual Basic
Public Property PreferredServer As String
    Get
    Set

Property Value

Type: String

Remarks

The value must be a valid host name. This may be verified with IsValidHostName(String, Boolean).

Exceptions

Exception | Condition
System..::..ArgumentException | value is not a valid host name.

See Also

CvsSntpSettings Class
CvsSntpSettings..::..CvsSntpSettings Members
Cognex.InSight.Sensor Namespace


CvsSntpSettings.SntpEnabled Property

[image]

In-Sight SDK
CvsSntpSettings..::..SntpEnabled Property
CvsSntpSettings Class See Also Send Feedback
Get a value the determines if the SNTP is in use.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool SntpEnabled { get; }
Visual Basic
Public ReadOnly Property SntpEnabled As Boolean
    Get

Property Value

Type: Boolean

See Also

CvsSntpSettings Class
CvsSntpSettings..::..CvsSntpSettings Members
Cognex.InSight.Sensor Namespace


CvsSntpSettings.TimeZoneId Property

[image]

In-Sight SDK
CvsSntpSettings..::..TimeZoneId Property
CvsSntpSettings Class See Also Send Feedback
Gets the time zone identifier.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int TimeZoneId { get; }
Visual Basic
Public ReadOnly Property TimeZoneId As Integer
    Get

Property Value

Type: Int32

See Also

CvsSntpSettings Class
CvsSntpSettings..::..CvsSntpSettings Members
Cognex.InSight.Sensor Namespace


CvsSntpSettings.UpdateInterval Property

[image]

In-Sight SDK
CvsSntpSettings..::..UpdateInterval Property
CvsSntpSettings Class See Also Send Feedback
Gets or sets the update interval in minutes. Valid values are between 15 and 1440.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int UpdateInterval { get; set; }
Visual Basic
Public Property UpdateInterval As Integer
    Get
    Set

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value is not between 15 and 1440.

See Also

CvsSntpSettings Class
CvsSntpSettings..::..CvsSntpSettings Members
Cognex.InSight.Sensor Namespace


CvsStopBits Enumeration

[image]

In-Sight SDK
CvsStopBits Enumeration
See Also Send Feedback
Defines the serial port's number of stop bits selections.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsStopBits
Visual Basic
Public Enumeration CvsStopBits

Members

Member name | Value | Description
Bits1 | 1 | 1 stop bit is used.
Bits2 | 4 | 2 stop bits are used.

See Also

Cognex.InSight.Sensor Namespace


CvsStrobeStartPositionType Enumeration

[image]

In-Sight SDK
CvsStrobeStartPositionType Enumeration
See Also Send Feedback
Strobe Start Position

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsStrobeStartPositionType
Visual Basic
Public Enumeration CvsStrobeStartPositionType

Members

Member name | Value | Description
AcquisitionStart | 0 | Strobe signal will be active while the CCD is being exposed.
CameraTrigger | 1 | Strobe signal will be active when the camera trigger occurs.
AllRowsExposed | 2 | Strobe signal will be active when all rows are exposed.

See Also

Cognex.InSight.Sensor Namespace


CvsSupportedTools Enumeration

[image]

In-Sight SDK
CvsSupportedTools Enumeration
See Also Send Feedback
Enumeration used to determine what tools are enabled on a particular In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public enum CvsSupportedTools
Visual Basic
Public Enumeration CvsSupportedTools

Members

Member name | Value | Description
Blob | 1 | The blob tools.
Edge | 2 | The edge finding tools.
Histogram | 3 | The histogram tool.
Symbol | 4 | The 2D symbol tool.
Wafer | 5 | The Wafer ID tool.
Barcode | 6 | The Barcode reader.
CompareImage | 7 | The CompareImage tool.
Image | 8 | The image manipulation tools.
PatFind | 9 | The PatFind tool.
Transforms | 10 | The world transformation tools.
Geometry | 11 | The geometry tools.
OCV | 12 | The OCV/OCR tools
Color | 13 | The color tools.
CvtIdCode | 14 | The Cognex ID Code tool.
DefectInspect | 17 | The FFD tool.
Caliper | 18 | The caliper tool.
CalibrateGrid | 19 | The grid calibration tool.
HmiWebView | 22 | The HMI Web View.
CvtPatmax | 33 | The Cognex PatMax tool.
CvtIdVerify | 34 | The Cognex ID Verify tool.
WaferOCR | 36 | The Wafer OCR tools.
WaferBarcode | 37 | The Wafer Barcode tools.
Wafer2D | 38 | The Wafer 2D code tools.
PatFindPlus | 43 | The PatFindPlus tool.
Reserved1 | 49 | Reserved.
NotchMax | 50 | A NotchMax sensor.
EasyBuilderOnly | 51 | Disables Spreadsheet.
SlaveOnly | 52 | Slave only sensor.
FeatureFamily0 | 62 | Feature family bit 0.
FeatureFamily1 | 63 | Feature family bit 1.
FeatureFamily2 | 64 | Feature family bit 2.
FeatureFamily3 | 65 | Feature family bit 3.
FeatureFamily4 | 66 | Feature family bit 4.
ReadIDMaxDotCode | 67 | ReadIDMax DotCode option
FfpPassFailOnly | 68 | FFP Pass/Fail only tool tag limitation
LiteUI | 69 | Displaying Lite UI in EasyBuilder view.
SalesModel | 91 | Whether this sensor is a sales model.

See Also

Cognex.InSight.Sensor Namespace


CvsTimeDateData Class

[image]

In-Sight SDK
CvsTimeDateData Class
Members See Also Send Feedback
Holds time and date settings for an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsTimeDateData : ICloneable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsTimeDateData
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsTimeDateData

See Also

CvsTimeDateData..::..CvsTimeDateData Members
Cognex.InSight.Sensor Namespace


CvsTimeDateData Members

[image] [image]

In-Sight SDK
CvsTimeDateData Members
CvsTimeDateData Class Constructors Methods Properties See Also Send Feedback

The CvsTimeDateData type exposes the following members.

Constructors

 | Name | Description
Public method | CvsTimeDateData()()()() | Initializes a new instance of the CvsTimeDateData class.
Public method | CvsTimeDateData(Int32, Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the CvsTimeDateData class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a shallow copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Day | Gets or sets the day of the month, in the range 1 to the number of days in the current Month.
Public property | Hours | Gets or sets the hours, in the range 0 to 23.
Public property | Minutes | Gets or sets the minutes, in the range 0 to 59.
Public property | Month | Gets or sets the month, in the range 0 to 11. Note that this is one less than the Month property of the DateTime structure.
Public property | Seconds | Gets or sets the seconds, in the range 0 to 59.
Public property | Year | Gets or sets the year, in the range 1970 to 2036.

See Also

CvsTimeDateData Class
Cognex.InSight.Sensor Namespace


CvsTimeDateData Constructor

[image] [image]

In-Sight SDK
CvsTimeDateData Constructor
CvsTimeDateData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsTimeDateData()()()() | Initializes a new instance of the CvsTimeDateData class.
Public method | CvsTimeDateData(Int32, Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the CvsTimeDateData class.

See Also

CvsTimeDateData Class
CvsTimeDateData..::..CvsTimeDateData Members
Cognex.InSight.Sensor Namespace


CvsTimeDateData Constructor

[image]

In-Sight SDK
CvsTimeDateData Constructor
CvsTimeDateData Class See Also Send Feedback
Initializes a new instance of the CvsTimeDateData class.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsTimeDateData()
Visual Basic
Public Sub New

Remarks

The properties of the new object will be set to the current local date and time on this computer.

See Also

CvsTimeDateData Class
CvsTimeDateData..::..CvsTimeDateData Members
CvsTimeDateData Overload
Cognex.InSight.Sensor Namespace


CvsTimeDateData Constructor (Int32, Int32, Int32, Int32, Int32, Int32)

[image]

In-Sight SDK
CvsTimeDateData Constructor (Int32, Int32, Int32, Int32, Int32, Int32)
CvsTimeDateData Class See Also Send Feedback
Initializes a new instance of the CvsTimeDateData class.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsTimeDateData(
    int year,
    int month,
    int day,
    int hours,
    int minutes,
    int seconds
)
Visual Basic
Public Sub New (
    year As Integer,
    month As Integer,
    day As Integer,
    hours As Integer,
    minutes As Integer,
    seconds As Integer
)

Parameters

year
Type: System..::..Int32
The year, which must be in the range 1970 to 2036.
month
Type: System..::..Int32
The month, which must be in the range 0 to 11. Note that this is one less than the Month property of the DateTime structure.
day
Type: System..::..Int32
The day, which must be in the range 1 to the number of days in the given month.
hours
Type: System..::..Int32
The hours, which must be in the range 0 to 23.
minutes
Type: System..::..Int32
The minutes, which must be in the range 0 to 59.
seconds
Type: System..::..Int32
The seconds, which must be in the range 0 to 59.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | An argument was outside the valid range.

See Also

CvsTimeDateData Class
CvsTimeDateData..::..CvsTimeDateData Members
CvsTimeDateData Overload
Cognex.InSight.Sensor Namespace


CvsTimeDateData Methods

[image] [image]

In-Sight SDK
CvsTimeDateData Methods
CvsTimeDateData Class See Also Send Feedback

The CvsTimeDateData type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a shallow copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsTimeDateData Class
Cognex.InSight.Sensor Namespace


CvsTimeDateData.Clone Method

[image]

In-Sight SDK
CvsTimeDateData..::..Clone Method
CvsTimeDateData Class See Also Send Feedback
Creates a new object that is a shallow copy of the current instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A new object that is a shallow copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsTimeDateData Class
CvsTimeDateData..::..CvsTimeDateData Members
Cognex.InSight.Sensor Namespace


CvsTimeDateData Properties

[image] [image]

In-Sight SDK
CvsTimeDateData Properties
CvsTimeDateData Class See Also Send Feedback

The CvsTimeDateData type exposes the following members.

Properties

 | Name | Description
Public property | Day | Gets or sets the day of the month, in the range 1 to the number of days in the current Month.
Public property | Hours | Gets or sets the hours, in the range 0 to 23.
Public property | Minutes | Gets or sets the minutes, in the range 0 to 59.
Public property | Month | Gets or sets the month, in the range 0 to 11. Note that this is one less than the Month property of the DateTime structure.
Public property | Seconds | Gets or sets the seconds, in the range 0 to 59.
Public property | Year | Gets or sets the year, in the range 1970 to 2036.

See Also

CvsTimeDateData Class
Cognex.InSight.Sensor Namespace


CvsTimeDateData.Day Property

[image]

In-Sight SDK
CvsTimeDateData..::..Day Property
CvsTimeDateData Class See Also Send Feedback
Gets or sets the day of the month, in the range 1 to the number of days in the current Month.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Day { get; set; }
Visual Basic
Public Property Day As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

In a leap year, February has 29 days.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value was not a valid day for the current Month.

See Also

CvsTimeDateData Class
CvsTimeDateData..::..CvsTimeDateData Members
Cognex.InSight.Sensor Namespace


CvsTimeDateData.Hours Property

[image]

In-Sight SDK
CvsTimeDateData..::..Hours Property
CvsTimeDateData Class See Also Send Feedback
Gets or sets the hours, in the range 0 to 23.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Hours { get; set; }
Visual Basic
Public Property Hours As Integer
    Get
    Set

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value was not in the range 0 to 23.

See Also

CvsTimeDateData Class
CvsTimeDateData..::..CvsTimeDateData Members
Cognex.InSight.Sensor Namespace


CvsTimeDateData.Minutes Property

[image]

In-Sight SDK
CvsTimeDateData..::..Minutes Property
CvsTimeDateData Class See Also Send Feedback
Gets or sets the minutes, in the range 0 to 59.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Minutes { get; set; }
Visual Basic
Public Property Minutes As Integer
    Get
    Set

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value was not in the range 0 to 59.

See Also

CvsTimeDateData Class
CvsTimeDateData..::..CvsTimeDateData Members
Cognex.InSight.Sensor Namespace


CvsTimeDateData.Month Property

[image]

In-Sight SDK
CvsTimeDateData..::..Month Property
CvsTimeDateData Class See Also Send Feedback
Gets or sets the month, in the range 0 to 11. Note that this is one less than the Month property of the DateTime structure.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Month { get; set; }
Visual Basic
Public Property Month As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

Setting the month may result in a change to Day setting such that the day of month falls within the valid range.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value was not in the range 0 to 11.

See Also

CvsTimeDateData Class
CvsTimeDateData..::..CvsTimeDateData Members
Cognex.InSight.Sensor Namespace


CvsTimeDateData.Seconds Property

[image]

In-Sight SDK
CvsTimeDateData..::..Seconds Property
CvsTimeDateData Class See Also Send Feedback
Gets or sets the seconds, in the range 0 to 59.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Seconds { get; set; }
Visual Basic
Public Property Seconds As Integer
    Get
    Set

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value was not in the range 0 to 59.

See Also

CvsTimeDateData Class
CvsTimeDateData..::..CvsTimeDateData Members
Cognex.InSight.Sensor Namespace


CvsTimeDateData.Year Property

[image]

In-Sight SDK
CvsTimeDateData..::..Year Property
CvsTimeDateData Class See Also Send Feedback
Gets or sets the year, in the range 1970 to 2036.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Year { get; set; }
Visual Basic
Public Property Year As Integer
    Get
    Set

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value was not in the range 1970 to 2036.

See Also

CvsTimeDateData Class
CvsTimeDateData..::..CvsTimeDateData Members
Cognex.InSight.Sensor Namespace


CvsTimeZones Class

[image]

In-Sight SDK
CvsTimeZones Class
Members See Also Send Feedback
Holds the valid time zone settings for an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsTimeZones
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsTimeZones

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsTimeZones

See Also

CvsTimeZones..::..CvsTimeZones Members
Cognex.InSight.Sensor Namespace


CvsTimeZones Members

[image] [image]

In-Sight SDK
CvsTimeZones Members
CvsTimeZones Class Methods See Also Send Feedback

The CvsTimeZones type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTimeZoneId | Returns a time zone identifier for the specified index into the array of time zones returned by GetTimeZones()()()().
Public method | GetTimeZoneIndex | Finds the corresponding time zone index for the specified time zone identifier.
Public method | GetTimeZones | Gets the array of time zone strings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAdjustedForDST | Returns true if the specified time zone is adjusted for daylight savings time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsTimeZones Class
Cognex.InSight.Sensor Namespace


CvsTimeZones Methods

[image] [image]

In-Sight SDK
CvsTimeZones Methods
CvsTimeZones Class See Also Send Feedback

The CvsTimeZones type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTimeZoneId | Returns a time zone identifier for the specified index into the array of time zones returned by GetTimeZones()()()().
Public method | GetTimeZoneIndex | Finds the corresponding time zone index for the specified time zone identifier.
Public method | GetTimeZones | Gets the array of time zone strings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAdjustedForDST | Returns true if the specified time zone is adjusted for daylight savings time.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsTimeZones Class
Cognex.InSight.Sensor Namespace


CvsTimeZones.GetTimeZoneId Method

[image]

In-Sight SDK
CvsTimeZones..::..GetTimeZoneId Method
CvsTimeZones Class See Also Send Feedback
Returns a time zone identifier for the specified index into the array of time zones returned by GetTimeZones()()()().

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int GetTimeZoneId(
    int index
)
Visual Basic
Public Function GetTimeZoneId (
    index As Integer
) As Integer

Parameters

index
Type: System..::..Int32
The index into the time zones collection.

Return Value

Type: Int32
Returns the time zone identifier, or -1 if index out of range.

Remarks

The time zone identifier is used by the In-Sight sensor to identify a particular time zone. There is a single time zone identifier for each item in array of time zones.

See Also

CvsTimeZones Class
CvsTimeZones..::..CvsTimeZones Members
Cognex.InSight.Sensor Namespace


CvsTimeZones.GetTimeZoneIndex Method

[image]

In-Sight SDK
CvsTimeZones..::..GetTimeZoneIndex Method
CvsTimeZones Class See Also Send Feedback
Finds the corresponding time zone index for the specified time zone identifier.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int GetTimeZoneIndex(
    int timeZoneId
)
Visual Basic
Public Function GetTimeZoneIndex (
    timeZoneId As Integer
) As Integer

Parameters

timeZoneId
Type: System..::..Int32
The time zone identifier.

Return Value

Type: Int32
Index into the array of time zones returned by GetTimeZones()()()(), or -1 if not found.

See Also

CvsTimeZones Class
CvsTimeZones..::..CvsTimeZones Members
Cognex.InSight.Sensor Namespace


CvsTimeZones.GetTimeZones Method

[image]

In-Sight SDK
CvsTimeZones..::..GetTimeZones Method
CvsTimeZones Class See Also Send Feedback
Gets the array of time zone strings.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string[] GetTimeZones()
Visual Basic
Public Function GetTimeZones As String()

Return Value

Type: array< String >[]()[][]
Returns an array of strings that contain the time zones.

See Also

CvsTimeZones Class
CvsTimeZones..::..CvsTimeZones Members
Cognex.InSight.Sensor Namespace


CvsTimeZones.IsAdjustedForDST Method

[image]

In-Sight SDK
CvsTimeZones..::..IsAdjustedForDST Method
CvsTimeZones Class See Also Send Feedback
Returns true if the specified time zone is adjusted for daylight savings time.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool IsAdjustedForDST(
    int timeZoneId
)
Visual Basic
Public Function IsAdjustedForDST (
    timeZoneId As Integer
) As Boolean

Parameters

timeZoneId
Type: System..::..Int32
The time zone identifier that references an item in the array of time zones returned by GetTimeZones()()()().

Return Value

Type: Boolean
true if the time zone is adjusted for daylight savings time, or false, otherwise.

See Also

CvsTimeZones Class
CvsTimeZones..::..CvsTimeZones Members
Cognex.InSight.Sensor Namespace


CvsUniversalIOSettings Class

[image]

In-Sight SDK
CvsUniversalIOSettings Class
Members See Also Send Feedback
Holds the Universal IO settings.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsUniversalIOSettings : CvsDiscreteIOLines
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsUniversalIOSettings
    Inherits CvsDiscreteIOLines

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsDiscreteIOLines
Cognex.InSight.Sensor..::..CvsUniversalIOSettings

See Also

CvsUniversalIOSettings..::..CvsUniversalIOSettings Members
Cognex.InSight.Sensor Namespace


CvsUniversalIOSettings Members

[image] [image]

In-Sight SDK
CvsUniversalIOSettings Members
CvsUniversalIOSettings Class Methods Properties See Also Send Feedback

The CvsUniversalIOSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance. (Overrides CvsDiscreteIOLines..::..Clone()()()().)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines if the CvsDiscreteIOLines objects contain the same values. (Inherited from CvsDiscreteIOLines.)
Public method | IsValidInputType | Determines if the input type for the current input line is valid for the current In-Sight sensor. (Inherited from CvsDiscreteIOLines.)
Public method | SetInputType | Sets the type for the designated input line. (Inherited from CvsDiscreteIOLines.)
Public method | SetOutputType | Sets the type for the designated output line. (Inherited from CvsDiscreteIOLines.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inputs | Gets the collection of input lines. (Inherited from CvsDiscreteIOLines.)
Public property | Outputs | Gets the collection of output lines. (Inherited from CvsDiscreteIOLines.)

See Also

CvsUniversalIOSettings Class
Cognex.InSight.Sensor Namespace


CvsUniversalIOSettings Methods

[image] [image]

In-Sight SDK
CvsUniversalIOSettings Methods
CvsUniversalIOSettings Class See Also Send Feedback

The CvsUniversalIOSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance. (Overrides CvsDiscreteIOLines..::..Clone()()()().)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines if the CvsDiscreteIOLines objects contain the same values. (Inherited from CvsDiscreteIOLines.)
Public method | IsValidInputType | Determines if the input type for the current input line is valid for the current In-Sight sensor. (Inherited from CvsDiscreteIOLines.)
Public method | SetInputType | Sets the type for the designated input line. (Inherited from CvsDiscreteIOLines.)
Public method | SetOutputType | Sets the type for the designated output line. (Inherited from CvsDiscreteIOLines.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsUniversalIOSettings Class
Cognex.InSight.Sensor Namespace


CvsUniversalIOSettings.Clone Method

[image]

In-Sight SDK
CvsUniversalIOSettings..::..Clone Method
CvsUniversalIOSettings Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsUniversalIOSettings Class
CvsUniversalIOSettings..::..CvsUniversalIOSettings Members
Cognex.InSight.Sensor Namespace


CvsUniversalIOSettings Properties

[image] [image]

In-Sight SDK
CvsUniversalIOSettings Properties
CvsUniversalIOSettings Class See Also Send Feedback

The CvsUniversalIOSettings type exposes the following members.

Properties

 | Name | Description
Public property | Inputs | Gets the collection of input lines. (Inherited from CvsDiscreteIOLines.)
Public property | Outputs | Gets the collection of output lines. (Inherited from CvsDiscreteIOLines.)

See Also

CvsUniversalIOSettings Class
Cognex.InSight.Sensor Namespace


CvsUser Class

[image]

In-Sight SDK
CvsUser Class
Members See Also Send Feedback
Holds information for a single entry in the user list.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsUser : ICloneable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsUser
    Implements ICloneable

Remarks

CvsUser objects are returned as items in a CvsUserCollection.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsUser

See Also

CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser Members

[image] [image]

In-Sight SDK
CvsUser Members
CvsUser Class Constructors Methods Fields Properties See Also Send Feedback

The CvsUser type exposes the following members.

Constructors

 | Name | Description
Public method | CvsUser()()()() | Initializes a new instance of the CvsUser class.
Public method | CvsUser(String, String, CvsInSightSecurityAccess, Boolean, Boolean, Boolean) | Initializes a new instance of the CvsUser class.
Public method | CvsUser(String, String, CvsInSightSecurityAccess, Boolean, Boolean, Boolean, Boolean) | Initializes a new instance of the CvsUser class.
Public method | CvsUser(String, String, CvsInSightSecurityAccess, Boolean, Boolean, Boolean, Boolean, Boolean) | Initializes a new instance of the CvsUser class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
 | IsValidPassword | Determines if the string is a valid password. Checks the length and the content.
 | IsValidUserName | Determines if the string is a valid username. Checks the length and the content.
 | IsValidUserNameOrPasswordChar | Determines if the character is valid for a user name or password.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
MaxPasswordLength | The maximum length for a user password.
MaxUserNameLength | The maximum length for a user name.

Properties

 | Name | Description
Public property | Access | Gets or sets the security access associated with the user.
Public property | CustomViewDefaultEnabled | Gets or sets a value that determines if the custom view is the default view for the user.
Public property | FtpReadEnabled | Gets or sets a value that determines if FTP reading is enabled for the user.
Public property | FtpWriteEnabled | Gets or sets a value that determines if FTP writing is enabled for the user.
Public property | Name | Gets or sets the name of the user.
Public property | OnlineJobSaveEnabled | Gets or sets a value that determines if the user can save while online.
Public property | OnlineOfflineEnabled | Gets or sets a value that determines if the user can go on and offline.
Public property | Password | Gets or sets the password associated with the user.

See Also

CvsUser Class
Cognex.InSight.Sensor Namespace


CvsUser Constructor

[image] [image]

In-Sight SDK
CvsUser Constructor
CvsUser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CvsUser()()()() | Initializes a new instance of the CvsUser class.
Public method | CvsUser(String, String, CvsInSightSecurityAccess, Boolean, Boolean, Boolean) | Initializes a new instance of the CvsUser class.
Public method | CvsUser(String, String, CvsInSightSecurityAccess, Boolean, Boolean, Boolean, Boolean) | Initializes a new instance of the CvsUser class.
Public method | CvsUser(String, String, CvsInSightSecurityAccess, Boolean, Boolean, Boolean, Boolean, Boolean) | Initializes a new instance of the CvsUser class.

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser Constructor

[image]

In-Sight SDK
CvsUser Constructor
CvsUser Class See Also Send Feedback
Initializes a new instance of the CvsUser class.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsUser()
Visual Basic
Public Sub New

Remarks

Provided for Visual Basic 6 interoperability.

See Also

CvsUser Class
CvsUser..::..CvsUser Members
CvsUser Overload
Cognex.InSight.Sensor Namespace


CvsUser Constructor (String, String, CvsInSightSecurityAccess, Boolean, Boolean, Boolean)

[image]

In-Sight SDK
CvsUser Constructor (String, String, CvsInSightSecurityAccess, Boolean, Boolean, Boolean)
CvsUser Class See Also Send Feedback
Initializes a new instance of the CvsUser class.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsUser(
    string name,
    string password,
    CvsInSightSecurityAccess access,
    bool ftpReadEnabled,
    bool ftpWriteEnabled,
    bool customViewDefaultEnabled
)
Visual Basic
Public Sub New (
    name As String,
    password As String,
    access As CvsInSightSecurityAccess,
    ftpReadEnabled As Boolean,
    ftpWriteEnabled As Boolean,
    customViewDefaultEnabled As Boolean
)

Parameters

name
Type: System..::..String
The name of the user.
password
Type: System..::..String
The password associated with the user.
access
Type: Cognex.InSight..::..CvsInSightSecurityAccess
The security access associated with the user.
ftpReadEnabled
Type: System..::..Boolean
Enables FTP reading priveleges for the user.
ftpWriteEnabled
Type: System..::..Boolean
Enables FTP writing priveleges for the user.
customViewDefaultEnabled
Type: System..::..Boolean
Enables the Custom View as the default view for the user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | name or password is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | name exceeds MaxUserNameLength, or password exceeds MaxPasswordLength.

See Also

CvsUser Class
CvsUser..::..CvsUser Members
CvsUser Overload
Cognex.InSight.Sensor Namespace


CvsUser Constructor (String, String, CvsInSightSecurityAccess, Boolean, Boolean, Boolean, Boolean)

[image]

In-Sight SDK
CvsUser Constructor (String, String, CvsInSightSecurityAccess, Boolean, Boolean, Boolean, Boolean)
CvsUser Class See Also Send Feedback
Initializes a new instance of the CvsUser class.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsUser(
    string name,
    string password,
    CvsInSightSecurityAccess access,
    bool ftpReadEnabled,
    bool ftpWriteEnabled,
    bool customViewDefaultEnabled,
    bool onlineOfflineEnabled
)
Visual Basic
Public Sub New (
    name As String,
    password As String,
    access As CvsInSightSecurityAccess,
    ftpReadEnabled As Boolean,
    ftpWriteEnabled As Boolean,
    customViewDefaultEnabled As Boolean,
    onlineOfflineEnabled As Boolean
)

Parameters

name
Type: System..::..String
The name of the user.
password
Type: System..::..String
The password associated with the user.
access
Type: Cognex.InSight..::..CvsInSightSecurityAccess
The security access associated with the user.
ftpReadEnabled
Type: System..::..Boolean
Enables FTP reading priveleges for the user.
ftpWriteEnabled
Type: System..::..Boolean
Enables FTP writing priveleges for the user.
customViewDefaultEnabled
Type: System..::..Boolean
Enables the Custom View as the default view for the user.
onlineOfflineEnabled
Type: System..::..Boolean
Enables the user to go on and offline.

Exceptions

Exception | Condition
System..::..ArgumentNullException | name or password is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | name exceeds MaxUserNameLength, or password exceeds MaxPasswordLength.

See Also

CvsUser Class
CvsUser..::..CvsUser Members
CvsUser Overload
Cognex.InSight.Sensor Namespace


CvsUser Constructor (String, String, CvsInSightSecurityAccess, Boolean, Boolean, Boolean, Boolean, Boolean)

[image]

In-Sight SDK
CvsUser Constructor (String, String, CvsInSightSecurityAccess, Boolean, Boolean, Boolean, Boolean, Boolean)
CvsUser Class See Also Send Feedback
Initializes a new instance of the CvsUser class.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsUser(
    string name,
    string password,
    CvsInSightSecurityAccess access,
    bool ftpReadEnabled,
    bool ftpWriteEnabled,
    bool customViewDefaultEnabled,
    bool onlineOfflineEnabled,
    bool onlineJobSaveEnabled
)
Visual Basic
Public Sub New (
    name As String,
    password As String,
    access As CvsInSightSecurityAccess,
    ftpReadEnabled As Boolean,
    ftpWriteEnabled As Boolean,
    customViewDefaultEnabled As Boolean,
    onlineOfflineEnabled As Boolean,
    onlineJobSaveEnabled As Boolean
)

Parameters

name
Type: System..::..String
The name of the user.
password
Type: System..::..String
The password associated with the user.
access
Type: Cognex.InSight..::..CvsInSightSecurityAccess
The security access associated with the user.
ftpReadEnabled
Type: System..::..Boolean
Enables FTP reading priveleges for the user.
ftpWriteEnabled
Type: System..::..Boolean
Enables FTP writing priveleges for the user.
customViewDefaultEnabled
Type: System..::..Boolean
Enables the Custom View as the default view for the user.
onlineOfflineEnabled
Type: System..::..Boolean
Enables the user to go on and offline.
onlineJobSaveEnabled
Type: System..::..Boolean
Enables the user to save the job while offline.

Exceptions

Exception | Condition
System..::..ArgumentNullException | name or password is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | name exceeds MaxUserNameLength, or password exceeds MaxPasswordLength.

See Also

CvsUser Class
CvsUser..::..CvsUser Members
CvsUser Overload
Cognex.InSight.Sensor Namespace


CvsUser Fields

[image] [image]

In-Sight SDK
CvsUser Fields
CvsUser Class See Also Send Feedback

The CvsUser type exposes the following members.

Fields

Name | Description
MaxPasswordLength | The maximum length for a user password.
MaxUserNameLength | The maximum length for a user name.

See Also

CvsUser Class
Cognex.InSight.Sensor Namespace


CvsUser.MaxPasswordLength Field

[image]

In-Sight SDK
CvsUser..::..MaxPasswordLength Field
CvsUser Class See Also Send Feedback
The maximum length for a user password.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxPasswordLength
Visual Basic
Public Const MaxPasswordLength As Integer

Field Value

Type: Int32

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser.MaxUserNameLength Field

[image]

In-Sight SDK
CvsUser..::..MaxUserNameLength Field
CvsUser Class See Also Send Feedback
The maximum length for a user name.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public const int MaxUserNameLength
Visual Basic
Public Const MaxUserNameLength As Integer

Field Value

Type: Int32

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser Methods

[image] [image]

In-Sight SDK
CvsUser Methods
CvsUser Class See Also Send Feedback

The CvsUser type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
 | IsValidPassword | Determines if the string is a valid password. Checks the length and the content.
 | IsValidUserName | Determines if the string is a valid username. Checks the length and the content.
 | IsValidUserNameOrPasswordChar | Determines if the character is valid for a user name or password.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsUser Class
Cognex.InSight.Sensor Namespace


CvsUser.Clone Method

[image]

In-Sight SDK
CvsUser..::..Clone Method
CvsUser Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

Type: Object
A new object that is a deep copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser.Initialize Method

[image]

In-Sight SDK
CvsUser..::..Initialize Method
CvsUser Class See Also Send Feedback
Initializes the instance.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Initialize(
    string name,
    string password,
    CvsInSightSecurityAccess access,
    bool ftpReadEnabled,
    bool ftpWriteEnabled,
    bool customViewDefaultEnabled
)
Visual Basic
Public Sub Initialize (
    name As String,
    password As String,
    access As CvsInSightSecurityAccess,
    ftpReadEnabled As Boolean,
    ftpWriteEnabled As Boolean,
    customViewDefaultEnabled As Boolean
)

Parameters

name
Type: System..::..String
The name of the user.
password
Type: System..::..String
The password associated with the user.
access
Type: Cognex.InSight..::..CvsInSightSecurityAccess
The security access associated with the user.
ftpReadEnabled
Type: System..::..Boolean
Enables FTP reading priveleges for the user.
ftpWriteEnabled
Type: System..::..Boolean
Enables FTP writing priveleges for the user.
customViewDefaultEnabled
Type: System..::..Boolean
Enables the Custom View as the default view for the user.

Remarks

Provided for Visual Basic 6 interoperability.

Exceptions

Exception | Condition
System..::..ArgumentNullException | name or password is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | name exceeds MaxUserNameLength, or password exceeds MaxPasswordLength.

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser.IsValidPassword Method

[image]

In-Sight SDK
CvsUser..::..IsValidPassword Method
CvsUser Class See Also Send Feedback
Determines if the string is a valid password. Checks the length and the content.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsValidPassword(
    string s
)
Visual Basic
Public Shared Function IsValidPassword (
    s As String
) As Boolean

Parameters

s
Type: System..::..String
The password to validate.

Return Value

Type: Boolean
true if the string is a valid password; false, otherwise.

Remarks

Valid characters include those returned from IsValidUserNameOrPasswordChar(Char).

Passwords use the same naming rules as usernames, except zero-length passwords are allowed.

Visual Basic 6 users should use the helper method IsValidPassword(String).

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser.IsValidUserName Method

[image]

In-Sight SDK
CvsUser..::..IsValidUserName Method
CvsUser Class See Also Send Feedback
Determines if the string is a valid username. Checks the length and the content.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsValidUserName(
    string s
)
Visual Basic
Public Shared Function IsValidUserName (
    s As String
) As Boolean

Parameters

s
Type: System..::..String
The user name to validate.

Return Value

Type: Boolean
true if the string is a valid username; false, otherwise.

Remarks

Valid characters include those returned from IsValidUserNameOrPasswordChar(Char).

Passwords use the same naming rules as usernames, except zero-length passwords are allowed.

Visual Basic 6 users should use the helper method IsValidUserName(String).

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser.IsValidUserNameOrPasswordChar Method

[image]

In-Sight SDK
CvsUser..::..IsValidUserNameOrPasswordChar Method
CvsUser Class See Also Send Feedback
Determines if the character is valid for a user name or password.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public static bool IsValidUserNameOrPasswordChar(
    char c
)
Visual Basic
Public Shared Function IsValidUserNameOrPasswordChar (
    c As Char
) As Boolean

Parameters

c
Type: System..::..Char
The character to validate.

Return Value

Type: Boolean
true if the character is valid; false, otherwise.

Remarks

Valid characters include letters, numeric digits, '_', or '-'.

Visual Basic 6 users should use the helper method IsValidUserNameOrPasswordChar(String).

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser Properties

[image] [image]

In-Sight SDK
CvsUser Properties
CvsUser Class See Also Send Feedback

The CvsUser type exposes the following members.

Properties

 | Name | Description
Public property | Access | Gets or sets the security access associated with the user.
Public property | CustomViewDefaultEnabled | Gets or sets a value that determines if the custom view is the default view for the user.
Public property | FtpReadEnabled | Gets or sets a value that determines if FTP reading is enabled for the user.
Public property | FtpWriteEnabled | Gets or sets a value that determines if FTP writing is enabled for the user.
Public property | Name | Gets or sets the name of the user.
Public property | OnlineJobSaveEnabled | Gets or sets a value that determines if the user can save while online.
Public property | OnlineOfflineEnabled | Gets or sets a value that determines if the user can go on and offline.
Public property | Password | Gets or sets the password associated with the user.

See Also

CvsUser Class
Cognex.InSight.Sensor Namespace


CvsUser.Access Property

[image]

In-Sight SDK
CvsUser..::..Access Property
CvsUser Class See Also Send Feedback
Gets or sets the security access associated with the user.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsInSightSecurityAccess Access { get; set; }
Visual Basic
Public Property Access As CvsInSightSecurityAccess
    Get
    Set

Property Value

Type: CvsInSightSecurityAccess

Exceptions

Exception | Condition
System..::..ArgumentException | value does not specify a CvsInSightSecurityAccess.

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser.CustomViewDefaultEnabled Property

[image]

In-Sight SDK
CvsUser..::..CustomViewDefaultEnabled Property
CvsUser Class See Also Send Feedback
Gets or sets a value that determines if the custom view is the default view for the user.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool CustomViewDefaultEnabled { get; set; }
Visual Basic
Public Property CustomViewDefaultEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser.FtpReadEnabled Property

[image]

In-Sight SDK
CvsUser..::..FtpReadEnabled Property
CvsUser Class See Also Send Feedback
Gets or sets a value that determines if FTP reading is enabled for the user.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool FtpReadEnabled { get; set; }
Visual Basic
Public Property FtpReadEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser.FtpWriteEnabled Property

[image]

In-Sight SDK
CvsUser..::..FtpWriteEnabled Property
CvsUser Class See Also Send Feedback
Gets or sets a value that determines if FTP writing is enabled for the user.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool FtpWriteEnabled { get; set; }
Visual Basic
Public Property FtpWriteEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser.Name Property

[image]

In-Sight SDK
CvsUser..::..Name Property
CvsUser Class See Also Send Feedback
Gets or sets the name of the user.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentNullException | value is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | value exceeds MaxUserNameLength. The length is checked in bytes not characters. The classic mode In-Sight camera only supports username and passwords of 15 bytes. Characters can take more than one byte.

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser.OnlineJobSaveEnabled Property

[image]

In-Sight SDK
CvsUser..::..OnlineJobSaveEnabled Property
CvsUser Class See Also Send Feedback
Gets or sets a value that determines if the user can save while online.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool OnlineJobSaveEnabled { get; set; }
Visual Basic
Public Property OnlineJobSaveEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser.OnlineOfflineEnabled Property

[image]

In-Sight SDK
CvsUser..::..OnlineOfflineEnabled Property
CvsUser Class See Also Send Feedback
Gets or sets a value that determines if the user can go on and offline.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public bool OnlineOfflineEnabled { get; set; }
Visual Basic
Public Property OnlineOfflineEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUser.Password Property

[image]

In-Sight SDK
CvsUser..::..Password Property
CvsUser Class See Also Send Feedback
Gets or sets the password associated with the user.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set

Property Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentNullException | value is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | value exceeds MaxPasswordLength. The length is checked in bytes not characters. The classic mode In-Sight camera only supports username and passwords of 15 bytes. Characters can take more than one byte.

See Also

CvsUser Class
CvsUser..::..CvsUser Members
Cognex.InSight.Sensor Namespace


CvsUserCollection Class

[image]

In-Sight SDK
CvsUserCollection Class
Members See Also Send Feedback
Holds the user list for an In-Sight sensor.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[SerializableAttribute]
public sealed class CvsUserCollection : IEnumerable
Visual Basic
<SerializableAttribute>
Public NotInheritable Class CvsUserCollection
    Implements IEnumerable

Remarks

The user list contains the user names and their associated permissions for logging onto an In-sight sensor. It can be obtained using the UserList property.

Inheritance Hierarchy

System..::..Object
Cognex.InSight.Sensor..::..CvsUserCollection

See Also

CvsUserCollection..::..CvsUserCollection Members
Cognex.InSight.Sensor Namespace


CvsUserCollection Members

[image] [image]

In-Sight SDK
CvsUserCollection Members
CvsUserCollection Class Constructors Methods Fields Properties See Also Send Feedback

The CvsUserCollection type exposes the following members.

Constructors

 | Name | Description
Public method | CvsUserCollection | Initializes a new instance of the CvsUserCollection class.

Methods

 | Name | Description
Public method | Add | Adds a user to the collection.
Public method | Clear | Clears the collection of users.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsUserCollection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(String) | Searches for the user with the specified name and returns the zero-based index of the first occurrence within the CvsUserCollection.
Public method | IndexOf(CvsUser) | Searches for the specified user and returns the zero-based index of the first occurrence within the CvsUserCollection.
Public method | RemoveAt | Removes the user at the specified index of the CvsUserCollection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
MaxUserListLength | Obsolete. The maximum number of entries allowed in the list of users.

Properties

 | Name | Description
Public property | Count | Gets the number of users in the collection.
Public property | Item[([( Int32])]) | Gets the CvsUser object at the specified zero-based index.
Public property | Item[([( String])]) | Gets the CvsUser object with the designated name, or null if the name does not reference a user in the collection.

See Also

CvsUserCollection Class
Cognex.InSight.Sensor Namespace


CvsUserCollection Constructor

[image]

In-Sight SDK
CvsUserCollection Constructor
CvsUserCollection Class See Also Send Feedback
Initializes a new instance of the CvsUserCollection class.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsUserCollection()
Visual Basic
Public Sub New

See Also

CvsUserCollection Class
CvsUserCollection..::..CvsUserCollection Members
Cognex.InSight.Sensor Namespace


CvsUserCollection Fields

[image] [image]

In-Sight SDK
CvsUserCollection Fields
CvsUserCollection Class See Also Send Feedback

The CvsUserCollection type exposes the following members.

Fields

Name | Description
MaxUserListLength | Obsolete. The maximum number of entries allowed in the list of users.

See Also

CvsUserCollection Class
Cognex.InSight.Sensor Namespace


CvsUserCollection.MaxUserListLength Field

[image]

In-Sight SDK
CvsUserCollection..::..MaxUserListLength Field
CvsUserCollection Class See Also Send Feedback
The maximum number of entries allowed in the list of users.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
[ObsoleteAttribute("Use Cognex.InSight.Sensor.CvsSensor.MaxUserListLength instead.")]
public const int MaxUserListLength
Visual Basic
<ObsoleteAttribute("Use Cognex.InSight.Sensor.CvsSensor.MaxUserListLength instead.")>
Public Const MaxUserListLength As Integer

Field Value

Type: Int32

See Also

CvsUserCollection Class
CvsUserCollection..::..CvsUserCollection Members
Cognex.InSight.Sensor Namespace


CvsUserCollection Methods

[image] [image]

In-Sight SDK
CvsUserCollection Methods
CvsUserCollection Class See Also Send Feedback

The CvsUserCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a user to the collection.
Public method | Clear | Clears the collection of users.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator that can iterate through the CvsUserCollection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(String) | Searches for the user with the specified name and returns the zero-based index of the first occurrence within the CvsUserCollection.
Public method | IndexOf(CvsUser) | Searches for the specified user and returns the zero-based index of the first occurrence within the CvsUserCollection.
Public method | RemoveAt | Removes the user at the specified index of the CvsUserCollection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CvsUserCollection Class
Cognex.InSight.Sensor Namespace


CvsUserCollection.Add Method

[image]

In-Sight SDK
CvsUserCollection..::..Add Method
CvsUserCollection Class See Also Send Feedback
Adds a user to the collection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Add(
    CvsUser user
)
Visual Basic
Public Sub Add (
    user As CvsUser
)

Parameters

user
Type: Cognex.InSight.Sensor..::..CvsUser
The user to be added.

Remarks

Users with the name "admin" will be placed at the top of the list.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The user is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | The user name is empty.

See Also

CvsUserCollection Class
CvsUserCollection..::..CvsUserCollection Members
Cognex.InSight.Sensor Namespace


CvsUserCollection.Clear Method

[image]

In-Sight SDK
CvsUserCollection..::..Clear Method
CvsUserCollection Class See Also Send Feedback
Clears the collection of users.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

CvsUserCollection Class
CvsUserCollection..::..CvsUserCollection Members
Cognex.InSight.Sensor Namespace


CvsUserCollection.GetEnumerator Method

[image]

In-Sight SDK
CvsUserCollection..::..GetEnumerator Method
CvsUserCollection Class See Also Send Feedback
Returns an IEnumerator that can iterate through the CvsUserCollection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CvsUserCollection Class
CvsUserCollection..::..CvsUserCollection Members
Cognex.InSight.Sensor Namespace


CvsUserCollection.IndexOf Method

[image] [image]

In-Sight SDK
CvsUserCollection..::..IndexOf Method
CvsUserCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(String) | Searches for the user with the specified name and returns the zero-based index of the first occurrence within the CvsUserCollection.
Public method | IndexOf(CvsUser) | Searches for the specified user and returns the zero-based index of the first occurrence within the CvsUserCollection.

See Also

CvsUserCollection Class
CvsUserCollection..::..CvsUserCollection Members
Cognex.InSight.Sensor Namespace


CvsUserCollection.IndexOf Method (String)

[image]

In-Sight SDK
CvsUserCollection..::..IndexOf Method (String)
CvsUserCollection Class See Also Send Feedback
Searches for the user with the specified name and returns the zero-based index of the first occurrence within the CvsUserCollection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IndexOf(
    string name
)
Visual Basic
Public Function IndexOf (
    name As String
) As Integer

Parameters

name
Type: System..::..String
The name of the user to locate.

Return Value

Type: Int32
The zero-based index of the first occurrence of the user with the name within the collection, if found; otherwise, -1.

See Also

CvsUserCollection Class
CvsUserCollection..::..CvsUserCollection Members
IndexOf Overload
Cognex.InSight.Sensor Namespace


CvsUserCollection.IndexOf Method (CvsUser)

[image]

In-Sight SDK
CvsUserCollection..::..IndexOf Method (CvsUser)
CvsUserCollection Class See Also Send Feedback
Searches for the specified user and returns the zero-based index of the first occurrence within the CvsUserCollection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int IndexOf(
    CvsUser user
)
Visual Basic
Public Function IndexOf (
    user As CvsUser
) As Integer

Parameters

user
Type: Cognex.InSight.Sensor..::..CvsUser
The user to locate. The value can be a null reference (Nothing in Visual Basic).

Return Value

Type: Int32
The zero-based index of the first occurrence of user within the entire collection, if found; otherwise, -1.

See Also

CvsUserCollection Class
CvsUserCollection..::..CvsUserCollection Members
IndexOf Overload
Cognex.InSight.Sensor Namespace


CvsUserCollection.RemoveAt Method

[image]

In-Sight SDK
CvsUserCollection..::..RemoveAt Method
CvsUserCollection Class See Also Send Feedback
Removes the user at the specified index of the CvsUserCollection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

See Also

CvsUserCollection Class
CvsUserCollection..::..CvsUserCollection Members
Cognex.InSight.Sensor Namespace


CvsUserCollection Properties

[image] [image]

In-Sight SDK
CvsUserCollection Properties
CvsUserCollection Class See Also Send Feedback

The CvsUserCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of users in the collection.
Public property | Item[([( Int32])]) | Gets the CvsUser object at the specified zero-based index.
Public property | Item[([( String])]) | Gets the CvsUser object with the designated name, or null if the name does not reference a user in the collection.

See Also

CvsUserCollection Class
Cognex.InSight.Sensor Namespace


CvsUserCollection.Count Property

[image]

In-Sight SDK
CvsUserCollection..::..Count Property
CvsUserCollection Class See Also Send Feedback
Gets the number of users in the collection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

CvsUserCollection Class
CvsUserCollection..::..CvsUserCollection Members
Cognex.InSight.Sensor Namespace


CvsUserCollection.Item Property

[image] [image]

In-Sight SDK
CvsUserCollection..::..Item Property
CvsUserCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets the CvsUser object at the specified zero-based index.
Public property | Item[([( String])]) | Gets the CvsUser object with the designated name, or null if the name does not reference a user in the collection.

See Also

CvsUserCollection Class
CvsUserCollection..::..CvsUserCollection Members
Cognex.InSight.Sensor Namespace


CvsUserCollection.Item Property (Int32)

[image]

In-Sight SDK
CvsUserCollection..::..Item Property (Int32)
CvsUserCollection Class See Also Send Feedback
Gets the CvsUser object at the specified zero-based index.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsUser this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As CvsUser
    Get

Parameters

index
Type: System..::..Int32
The zero-based index into the collection.

Property Value

Type: CvsUser

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is less than zero or index is equal to or greater than Count.

See Also

CvsUserCollection Class
CvsUserCollection..::..CvsUserCollection Members
Item Overload
Cognex.InSight.Sensor Namespace


CvsUserCollection.Item Property (String)

[image]

In-Sight SDK
CvsUserCollection..::..Item Property (String)
CvsUserCollection Class See Also Send Feedback
Gets the CvsUser object with the designated name, or null if the name does not reference a user in the collection.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public CvsUser this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    name As String
) As CvsUser
    Get

Parameters

name
Type: System..::..String
The name of the user.

Property Value

Type: CvsUser

See Also

CvsUserCollection Class
CvsUserCollection..::..CvsUserCollection Members
Item Overload
Cognex.InSight.Sensor Namespace


ICvsDiscreteInputLine Interface

[image]

In-Sight SDK
ICvsDiscreteInputLine Interface
Members See Also Send Feedback
A contract for the common properties of a Discrete Input line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public interface ICvsDiscreteInputLine : ICvsDiscreteLine,
    ICloneable
Visual Basic
Public Interface ICvsDiscreteInputLine
    Inherits ICvsDiscreteLine, ICloneable

See Also

ICvsDiscreteInputLine..::..ICvsDiscreteInputLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteInputLine Members

[image] [image]

In-Sight SDK
ICvsDiscreteInputLine Members
ICvsDiscreteInputLine Interface Methods Properties See Also Send Feedback

The ICvsDiscreteInputLine type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)

Properties

 | Name | Description
Public property | Direction | Gets or sets (if supported) the direction of the line. (Inherited from ICvsDiscreteLine.)
Public property | IsBiDirectional | Returns true if the output is bi-directional (Inherited from ICvsDiscreteLine.)
Public property | Line | Gets the line index. (Inherited from ICvsDiscreteLine.)
Public property | Name | Gets or sets the input line name.
Public property | Signal | Gets or sets the signal associated with the input line.
Public property | SupportsTriColorLED | Returns true if the output supports Tri-color LED (Inherited from ICvsDiscreteLine.)
Public property | TriColorType | Gets or sets (if supported) the tri-color type of the line. (Inherited from ICvsDiscreteLine.)
Public property | Type | Gets or sets the type of the input line.

See Also

ICvsDiscreteInputLine Interface
Cognex.InSight.Sensor Namespace


ICvsDiscreteInputLine Methods

[image] [image]

In-Sight SDK
ICvsDiscreteInputLine Methods
ICvsDiscreteInputLine Interface See Also Send Feedback

The ICvsDiscreteInputLine type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)

See Also

ICvsDiscreteInputLine Interface
Cognex.InSight.Sensor Namespace


ICvsDiscreteInputLine Properties

[image] [image]

In-Sight SDK
ICvsDiscreteInputLine Properties
ICvsDiscreteInputLine Interface See Also Send Feedback

The ICvsDiscreteInputLine type exposes the following members.

Properties

 | Name | Description
Public property | Direction | Gets or sets (if supported) the direction of the line. (Inherited from ICvsDiscreteLine.)
Public property | IsBiDirectional | Returns true if the output is bi-directional (Inherited from ICvsDiscreteLine.)
Public property | Line | Gets the line index. (Inherited from ICvsDiscreteLine.)
Public property | Name | Gets or sets the input line name.
Public property | Signal | Gets or sets the signal associated with the input line.
Public property | SupportsTriColorLED | Returns true if the output supports Tri-color LED (Inherited from ICvsDiscreteLine.)
Public property | TriColorType | Gets or sets (if supported) the tri-color type of the line. (Inherited from ICvsDiscreteLine.)
Public property | Type | Gets or sets the type of the input line.

See Also

ICvsDiscreteInputLine Interface
Cognex.InSight.Sensor Namespace


ICvsDiscreteInputLine.Name Property

[image]

In-Sight SDK
ICvsDiscreteInputLine..::..Name Property
ICvsDiscreteInputLine Interface See Also Send Feedback
Gets or sets the input line name.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
string Name { get; set; }
Visual Basic
Property Name As String
    Get
    Set

Property Value

Type: String

See Also

ICvsDiscreteInputLine Interface
ICvsDiscreteInputLine..::..ICvsDiscreteInputLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteInputLine.Signal Property

[image]

In-Sight SDK
ICvsDiscreteInputLine..::..Signal Property
ICvsDiscreteInputLine Interface See Also Send Feedback
Gets or sets the signal associated with the input line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
CvsInputSignal Signal { get; set; }
Visual Basic
Property Signal As CvsInputSignal
    Get
    Set

Property Value

Type: CvsInputSignal

See Also

ICvsDiscreteInputLine Interface
ICvsDiscreteInputLine..::..ICvsDiscreteInputLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteInputLine.Type Property

[image]

In-Sight SDK
ICvsDiscreteInputLine..::..Type Property
ICvsDiscreteInputLine Interface See Also Send Feedback
Gets or sets the type of the input line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
CvsInputType Type { get; set; }
Visual Basic
Property Type As CvsInputType
    Get
    Set

Property Value

Type: CvsInputType

See Also

ICvsDiscreteInputLine Interface
ICvsDiscreteInputLine..::..ICvsDiscreteInputLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteLine Interface

[image]

In-Sight SDK
ICvsDiscreteLine Interface
Members See Also Send Feedback
A contract for the common properties of a Discrete I/O line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public interface ICvsDiscreteLine : ICloneable
Visual Basic
Public Interface ICvsDiscreteLine
    Inherits ICloneable

See Also

ICvsDiscreteLine..::..ICvsDiscreteLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteLine Members

[image] [image]

In-Sight SDK
ICvsDiscreteLine Members
ICvsDiscreteLine Interface Methods Properties See Also Send Feedback

The ICvsDiscreteLine type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)

Properties

 | Name | Description
Public property | Direction | Gets or sets (if supported) the direction of the line.
Public property | IsBiDirectional | Returns true if the output is bi-directional
Public property | Line | Gets the line index.
Public property | SupportsTriColorLED | Returns true if the output supports Tri-color LED
Public property | TriColorType | Gets or sets (if supported) the tri-color type of the line.

See Also

ICvsDiscreteLine Interface
Cognex.InSight.Sensor Namespace


ICvsDiscreteLine Methods

[image] [image]

In-Sight SDK
ICvsDiscreteLine Methods
ICvsDiscreteLine Interface See Also Send Feedback

The ICvsDiscreteLine type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)

See Also

ICvsDiscreteLine Interface
Cognex.InSight.Sensor Namespace


ICvsDiscreteLine Properties

[image] [image]

In-Sight SDK
ICvsDiscreteLine Properties
ICvsDiscreteLine Interface See Also Send Feedback

The ICvsDiscreteLine type exposes the following members.

Properties

 | Name | Description
Public property | Direction | Gets or sets (if supported) the direction of the line.
Public property | IsBiDirectional | Returns true if the output is bi-directional
Public property | Line | Gets the line index.
Public property | SupportsTriColorLED | Returns true if the output supports Tri-color LED
Public property | TriColorType | Gets or sets (if supported) the tri-color type of the line.

See Also

ICvsDiscreteLine Interface
Cognex.InSight.Sensor Namespace


ICvsDiscreteLine.Direction Property

[image]

In-Sight SDK
ICvsDiscreteLine..::..Direction Property
ICvsDiscreteLine Interface See Also Send Feedback
Gets or sets (if supported) the direction of the line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
CvsDioLineDirection Direction { get; set; }
Visual Basic
Property Direction As CvsDioLineDirection
    Get
    Set

Property Value

Type: CvsDioLineDirection

See Also

ICvsDiscreteLine Interface
ICvsDiscreteLine..::..ICvsDiscreteLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteLine.IsBiDirectional Property

[image]

In-Sight SDK
ICvsDiscreteLine..::..IsBiDirectional Property
ICvsDiscreteLine Interface See Also Send Feedback
Returns true if the output is bi-directional

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
bool IsBiDirectional { get; }
Visual Basic
ReadOnly Property IsBiDirectional As Boolean
    Get

Property Value

Type: Boolean

See Also

ICvsDiscreteLine Interface
ICvsDiscreteLine..::..ICvsDiscreteLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteLine.Line Property

[image]

In-Sight SDK
ICvsDiscreteLine..::..Line Property
ICvsDiscreteLine Interface See Also Send Feedback
Gets the line index.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
int Line { get; }
Visual Basic
ReadOnly Property Line As Integer
    Get

Property Value

Type: Int32

See Also

ICvsDiscreteLine Interface
ICvsDiscreteLine..::..ICvsDiscreteLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteLine.SupportsTriColorLED Property

[image]

In-Sight SDK
ICvsDiscreteLine..::..SupportsTriColorLED Property
ICvsDiscreteLine Interface See Also Send Feedback
Returns true if the output supports Tri-color LED

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
bool SupportsTriColorLED { get; }
Visual Basic
ReadOnly Property SupportsTriColorLED As Boolean
    Get

Property Value

Type: Boolean

See Also

ICvsDiscreteLine Interface
ICvsDiscreteLine..::..ICvsDiscreteLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteLine.TriColorType Property

[image]

In-Sight SDK
ICvsDiscreteLine..::..TriColorType Property
ICvsDiscreteLine Interface See Also Send Feedback
Gets or sets (if supported) the tri-color type of the line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
CvsDioTriColorType TriColorType { get; set; }
Visual Basic
Property TriColorType As CvsDioTriColorType
    Get
    Set

Property Value

Type: CvsDioTriColorType

See Also

ICvsDiscreteLine Interface
ICvsDiscreteLine..::..ICvsDiscreteLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteOutputLine Interface

[image]

In-Sight SDK
ICvsDiscreteOutputLine Interface
Members See Also Send Feedback
A contract for the common properties of a Discrete Output line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
public interface ICvsDiscreteOutputLine : ICvsDiscreteLine,
    ICloneable
Visual Basic
Public Interface ICvsDiscreteOutputLine
    Inherits ICvsDiscreteLine, ICloneable

See Also

ICvsDiscreteOutputLine..::..ICvsDiscreteOutputLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteOutputLine Members

[image] [image]

In-Sight SDK
ICvsDiscreteOutputLine Members
ICvsDiscreteOutputLine Interface Methods Properties See Also Send Feedback

The ICvsDiscreteOutputLine type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | IsValidOutputType | Determines whether the given output type is valid for the output line.

Properties

 | Name | Description
Public property | DelayNumber | Gets or sets the number of acquisition (tracking) pulses or time (ms) to delay the output.
Public property | DelayNumberIsTimeAfterTrigger | Gets or sets a flag that determines how to interpret the DelayNumber field.
Public property | Direction | Gets or sets (if supported) the direction of the line. (Inherited from ICvsDiscreteLine.)
Public property | IsBiDirectional | Returns true if the output is bi-directional (Inherited from ICvsDiscreteLine.)
Public property | IsHighSpeed | Returns true if the output is a high speed line.
Public property | Line | Gets the line index. (Inherited from ICvsDiscreteLine.)
Public property | Name | Gets or sets the output line name.
Public property | PulseEnabledOrStrobedEdge | Gets or sets pulse enabling flag state for Programmed output lines. -or- Gets or sets the strobed output line's edge.
Public property | PulseLength | Gets the pulse length (in milliseconds) associated with the output line.
Public property | SupportsTriColorLED | Returns true if the output supports Tri-color LED (Inherited from ICvsDiscreteLine.)
Public property | TriColorType | Gets or sets (if supported) the tri-color type of the line. (Inherited from ICvsDiscreteLine.)
Public property | Type | Gets or sets the type associated with the output line.

See Also

ICvsDiscreteOutputLine Interface
Cognex.InSight.Sensor Namespace


ICvsDiscreteOutputLine Methods

[image] [image]

In-Sight SDK
ICvsDiscreteOutputLine Methods
ICvsDiscreteOutputLine Interface See Also Send Feedback

The ICvsDiscreteOutputLine type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | IsValidOutputType | Determines whether the given output type is valid for the output line.

See Also

ICvsDiscreteOutputLine Interface
Cognex.InSight.Sensor Namespace


ICvsDiscreteOutputLine.IsValidOutputType Method

[image]

In-Sight SDK
ICvsDiscreteOutputLine..::..IsValidOutputType Method
ICvsDiscreteOutputLine Interface See Also Send Feedback
Determines whether the given output type is valid for the output line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
bool IsValidOutputType(
    CvsOutputType type
)
Visual Basic
Function IsValidOutputType (
    type As CvsOutputType
) As Boolean

Parameters

type
Type: Cognex.InSight.Sensor..::..CvsOutputType
The output type to validate.

Return Value

Type: Boolean
true if output type is valid; otherwise, false.

See Also

ICvsDiscreteOutputLine Interface
ICvsDiscreteOutputLine..::..ICvsDiscreteOutputLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteOutputLine Properties

[image] [image]

In-Sight SDK
ICvsDiscreteOutputLine Properties
ICvsDiscreteOutputLine Interface See Also Send Feedback

The ICvsDiscreteOutputLine type exposes the following members.

Properties

 | Name | Description
Public property | DelayNumber | Gets or sets the number of acquisition (tracking) pulses or time (ms) to delay the output.
Public property | DelayNumberIsTimeAfterTrigger | Gets or sets a flag that determines how to interpret the DelayNumber field.
Public property | Direction | Gets or sets (if supported) the direction of the line. (Inherited from ICvsDiscreteLine.)
Public property | IsBiDirectional | Returns true if the output is bi-directional (Inherited from ICvsDiscreteLine.)
Public property | IsHighSpeed | Returns true if the output is a high speed line.
Public property | Line | Gets the line index. (Inherited from ICvsDiscreteLine.)
Public property | Name | Gets or sets the output line name.
Public property | PulseEnabledOrStrobedEdge | Gets or sets pulse enabling flag state for Programmed output lines. -or- Gets or sets the strobed output line's edge.
Public property | PulseLength | Gets the pulse length (in milliseconds) associated with the output line.
Public property | SupportsTriColorLED | Returns true if the output supports Tri-color LED (Inherited from ICvsDiscreteLine.)
Public property | TriColorType | Gets or sets (if supported) the tri-color type of the line. (Inherited from ICvsDiscreteLine.)
Public property | Type | Gets or sets the type associated with the output line.

See Also

ICvsDiscreteOutputLine Interface
Cognex.InSight.Sensor Namespace


ICvsDiscreteOutputLine.DelayNumber Property

[image]

In-Sight SDK
ICvsDiscreteOutputLine..::..DelayNumber Property
ICvsDiscreteOutputLine Interface See Also Send Feedback
Gets or sets the number of acquisition (tracking) pulses or time (ms) to delay the output.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
int DelayNumber { get; set; }
Visual Basic
Property DelayNumber As Integer
    Get
    Set

Property Value

Type: Int32

See Also

ICvsDiscreteOutputLine Interface
ICvsDiscreteOutputLine..::..ICvsDiscreteOutputLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteOutputLine.DelayNumberIsTimeAfterTrigger Property

[image]

In-Sight SDK
ICvsDiscreteOutputLine..::..DelayNumberIsTimeAfterTrigger Property
ICvsDiscreteOutputLine Interface See Also Send Feedback
Gets or sets a flag that determines how to interpret the DelayNumber field.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
CvsOutputDelayTypeFlags DelayNumberIsTimeAfterTrigger { get; set; }
Visual Basic
Property DelayNumberIsTimeAfterTrigger As CvsOutputDelayTypeFlags
    Get
    Set

Property Value

Type: CvsOutputDelayTypeFlags

See Also

ICvsDiscreteOutputLine Interface
ICvsDiscreteOutputLine..::..ICvsDiscreteOutputLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteOutputLine.IsHighSpeed Property

[image]

In-Sight SDK
ICvsDiscreteOutputLine..::..IsHighSpeed Property
ICvsDiscreteOutputLine Interface See Also Send Feedback
Returns true if the output is a high speed line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
bool IsHighSpeed { get; }
Visual Basic
ReadOnly Property IsHighSpeed As Boolean
    Get

Property Value

Type: Boolean

See Also

ICvsDiscreteOutputLine Interface
ICvsDiscreteOutputLine..::..ICvsDiscreteOutputLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteOutputLine.Name Property

[image]

In-Sight SDK
ICvsDiscreteOutputLine..::..Name Property
ICvsDiscreteOutputLine Interface See Also Send Feedback
Gets or sets the output line name.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
string Name { get; set; }
Visual Basic
Property Name As String
    Get
    Set

Property Value

Type: String

See Also

ICvsDiscreteOutputLine Interface
ICvsDiscreteOutputLine..::..ICvsDiscreteOutputLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteOutputLine.PulseEnabledOrStrobedEdge Property

[image]

In-Sight SDK
ICvsDiscreteOutputLine..::..PulseEnabledOrStrobedEdge Property
ICvsDiscreteOutputLine Interface See Also Send Feedback
Gets or sets pulse enabling flag state for Programmed output lines.

-or-

Gets or sets the strobed output line's edge.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
bool PulseEnabledOrStrobedEdge { get; set; }
Visual Basic
Property PulseEnabledOrStrobedEdge As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

ICvsDiscreteOutputLine Interface
ICvsDiscreteOutputLine..::..ICvsDiscreteOutputLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteOutputLine.PulseLength Property

[image]

In-Sight SDK
ICvsDiscreteOutputLine..::..PulseLength Property
ICvsDiscreteOutputLine Interface See Also Send Feedback
Gets the pulse length (in milliseconds) associated with the output line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
int PulseLength { get; set; }
Visual Basic
Property PulseLength As Integer
    Get
    Set

Property Value

Type: Int32

See Also

ICvsDiscreteOutputLine Interface
ICvsDiscreteOutputLine..::..ICvsDiscreteOutputLine Members
Cognex.InSight.Sensor Namespace


ICvsDiscreteOutputLine.Type Property

[image]

In-Sight SDK
ICvsDiscreteOutputLine..::..Type Property
ICvsDiscreteOutputLine Interface See Also Send Feedback
Gets or sets the type associated with the output line.

Namespace: Cognex.InSight.Sensor
Assembly: Cognex.InSight (in Cognex.InSight.dll) Version: 6.5.6.0

Syntax

C#
CvsOutputType Type { get; set; }
Visual Basic
Property Type As CvsOutputType
    Get
    Set

Property Value

Type: CvsOutputType

See Also

ICvsDiscreteOutputLine Interface
ICvsDiscreteOutputLine..::..ICvsDiscreteOutputLine Members
Cognex.InSight.Sensor Namespace