接続

EasyBuilder® ビューへようこそ。EasyBuilder はステップバイステップのアプローチで、マシンビジョンのアプリケーションを構築します。[接続] ステップでは、In-Sight ビジョンシステム、ビジョンセンサやエミュレータに接続したり、設定をしたり、ジョブのビルドを始めたりすることができます。

注 :
  • ジョブの作成中は、定期的にジョブを保存 (「ファイル」メニュー>「ジョブの保存」または Ctrl+S) してください。[ユーザ] ダイアログの [オンラインでもジョブを保存] チェックボックスを ON にすると、フルアクセスまたはプロテクトのアクセス権を持つユーザは、オンライン中のジョブ保存が許可されます。[オンラインでもジョブを保存] チェックボックスが OFF の場合、ジョブを保存するにはビジョンシステムをオフラインにする必要があります。
  • アクセスレベル、現在使用中のジョブの状態、あるいは接続先 (ビジョンセンサまたはエミュレータなど) の条件によっては、EasyBuilder のアプリケーションステップが薄く表示されたり、グレーアウトしていることがあります。

EasyBuilder ヘルプ

EasyBuilder ヘルプには、パレットヘルプとオンラインヘルプの 2 種類のフォーマットがあります。EasyBuilder パレットヘルプは、パレットの [ヘルプ] タブに表示されます。EasyBuilder オンラインヘルプは、CHM フォーマットのヘルプシステムで、検索機能を持ちます。F1 キーボードを押すか、パレットの [ヘルプ] タブのヘルプ [image] ボタンを押すか、あるいは [ヘルプ] メニューから [EasyBuilder ヘルプ] を選択して、EasyBuilder オンラインヘルプを開きます。

In-Sight センサまたはエミュレータに接続するには

EasyBuilder ジョブを新規作成する、またはジョブを開くには

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder ヘルプ | 08/29/2022 | Revision: 5.9.0.2


In-Sight センサまたはエミュレータに接続するには

[In-Sight センサまたはエミュレータの選択] グループボックスに、使用可能な In-Sight センサおよびローカルエミュレータが表示されます。EasyBuilder に一度に接続できるのは、1 台のセンサまたは 1 つのエミュレータのみです。接続後、センサまたはエミュレータの名前が [センサの情報] グループボックスの [接続先] および[モデル番号] フィールドに表示されます。

使用するセンサまたはエミュレータに接続されていない場合は、次のいずれかの操作を行います。

  • 使用するセンサまたはエミュレータをダブルクリックします。
  • 使用するセンサまたはエミュレータを選択してから、[接続] ボタンをクリックします。

現在接続中のセンサまたはエミュレータとの通信を切断する場合は、[切断] ボタンをクリックしてください。

注 :
  • 使用するセンサまたはエミュレータに他のユーザがすでにログオンしている場合、警告メッセージが表示されます。他のユーザの接続を切断し、ログオンする場合は [はい] を、ログオンをキャンセルして EasyBuilder に戻る場合は [いいえ] をクリックしてください。
  • 使用するセンサまたはエミュレータに接続する権限がない場合、[ログオン/ログオフ] ダイアログが表示されます。
  • センサおよびネットワークに接続できない場合、ネットワークカードに問題がある場合があります。
  • [連続] トリガを In-Sight 2000 シリーズビジョンセンサで使用すると、センサの CPU 負荷が高くなる影響で、In-Sight Explorer からの接続に失敗することがあります。 その場合はトリガの [種類] を変更するか、またはトリガの [間隔] を調整して対応してください。
  • In-Sight ビジョンシステムに接続している場合、モデルタイプによって、使用可能な位置決めおよび検査ツールは異なります。

リストにないセンサに接続するには

ローカルエミュレータのモードを変更するには


リストにないセンサに接続するには

接続する必要のあるセンサが物理的にローカルサブネット上に接続されているが、リストに表示されていない場合は、[更新] または [追加] ボタンをクリックしてください (センサのネットワーク設定により異なります)。

  • [更新] ボタンはリストを更新して、ローカルサブネットワークに接続されているすべての In-Sight センサを表示します。
  • [追加] ボタンはセンサ/デバイスをネットワークに追加] ダイアログを開き、フルアクセスの権限を持つユーザに、ローカルサブネットと互換性のないローカルネットワーク上のセンサのネットワーク再設定を許可します。正しく設定されると、センサは自動的にローカルサブネットに追加され、通信を行うことができます。

接続する必要のあるセンサが異なるサブネット上にある場合、[システム] メニューから [Explorer のホストテーブル] を選択して、 [Explorer のホストテーブルの設定] ダイアログを開きます。


ローカルエミュレータのモードを変更するには

  1. [In-Sight センサまたはエミュレータの選択] グループボックスから使用するエミュレータを選択してクリックします。
  2. [エミュレータ] ボタンを押して、[エミュレータのオプション] ダイアログを開きます。ダイアログには、サポートされているすべての In-Sight ビジョンシステムおよびセンサが使用できるツールが含まれています。
  3. [モデル] ドロップダウンリストから、エミュレートする In-Sight センサモデルを選択します。デフォルトでは、[標準] が選択されています。[標準] は、In-Sight ビジョンセンサが備えている主要な機能を提供します。画像解像度は、640×480 です。
  4. 選択後、[OK] を押してエミュレータの設定を変更します。
注 : [OK] ボタンをクリックした後、いったん接続を終了して再接続するために、遅延が生じます。


EasyBuilder ジョブを新規作成する、またはジョブを開くには

閉じた ジョブの新規作成:
  1. センサがオンラインでないことを確認します。
  2. [ジョブのロード] グループボックスの [ジョブの新規作成] ボタンをクリックするか、または CTRL+N を押して、[ジョブの新規作成] ダイアログを開きます。
  3. ダイアログの [現在のジョブデータはすべて失われます。続けますか？] に対し、[はい] をクリックします。　(現在のジョブを保存する場合、ダイアログの [いいえ] をクリックしてから CTRL+S を押し、ジョブを新規作成する前に「保存」操作を完了します)。

新規作成のジョブ名は、名前を付けて保存されるまで、[センサの情報] グループボックスの [現在のジョブ] フィールドには表示されません。

閉じた ジョブを開く:
  1. センサがオンラインでないことを確認します。
  2. [ジョブのロード] グループボックスの [ジョブを開く] ボタンをクリックするか、または CTRL+O を押して、[開く] ダイアログを開きます。
  3. ジョブを選択します。
  4. ジョブをダブルクリックするか、またはジョブを選択してから [開く] をクリックします。
  5. [ジョブを開く] ダイアログが開きます。ダイアログの [現在のジョブデータはすべて失われます。ジョブを開きますか？] に対し [はい] をクリックします。 (現在のジョブを保存する場合、ダイアログの [いいえ] をクリックしてから CTRL+S を押し、ジョブを新規作成する前に「保存」操作を完了しておいてください)。

開いたジョブの名前が [現在のジョブ] フィールドに表示されます。

注 :
  • In-Sight 2000 シリーズビジョンセンサで作成されたジョブは、他の In-Sight モデルで作成されたジョブとは互換性がありません。
  • EasyBuilder のみ使用できるビジョンシステムは、スプレッドシートで編集された EasyBuilder ジョブを開くことはできません。
  • In-Sight Explorer のスプレッドシートビューで作成されたジョブは EasyBuilder で開くことはできません。 開こうとすると、アプリケーションステップが薄く表示されたり、グレーアウトされてしまいます。 In-Sight Explorer 環境でジョブを使用するには、EasyBuilder の [表示] メニューから [スプレッドシート] をクリックしてください。
  • In-Sight 4.7.3 以前を使用して作成した EasyBuilder ジョブを、 In-Sight 5.x.x ファームウェアを搭載したビジョンシステムにロードした場合、シンボリックタグ (EasyBuilder タグ) がジョブから削除されてしまうことがあります。


画像の設定

[画像の設定] ステップでは、画像の取り込みやロードを行ったり、In-Sight センサの画像取り込み設定を調整したり、アプリケーションをミリメートルやインチといった実単位に変換する必要がある場合に、キャリブレーションを実行したりすることができます。

画像を取り込み、またはロードするには

画像取り込みの設定を調整するには

キャリブレーション (画像単位を実単位に変換) を行うには


画像を取り込み、またはロードするには

[画像取り込み/ロード] グループボックスを使用して、ビジョンシステムから画像を取り込んだり、アクティブなライブビデオ画像を表示したり、以前に取り込んだ画像を PC からロードしたりすることができます。

In-Sight 2000 シリーズビジョンセンサ

  • 画像を取り込み、またはロードするには

In-Sight ビジョンシステム

  • 画像を取り込み、またはロードするには

In-Sight 2000 シリーズビジョンセンサ

In-Sight ビジョンシステム

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder ヘルプ | 08/29/2022 | Revision: 5.9.0.2


画像を取り込み、またはロードするには

注 : このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。 In-Sight ビジョンシステムに接続している場合、画像を取り込み、またはロードするにはを参照してください。
閉じた トリガ

[トリガ] ボタンを押して、 単一の画像を取り込みます。 またはキーボードの F5 キーを押すか、EasyBuilder ツールバーの [image] ボタンを押してください。 ([トリガ] コントロールを [手動] に設定する必要があります。)

閉じた ライブビデオ

[ライブビデオ] ボタンは、ビジョンセンサをライブ表示にします。ライブ表示にして、ビジョンセンサに装着されたレンズのフォーカスを調整したり、レンズの絞りを調整して露光や輝度を最適にしたりすることができます。 画像にフォーカスが合い、輝度が調整されてコントラストが最大になっている時に、アプリケーションが最適に機能します。

注 :
  • [画像] メニューから [ライブビデオ] を選択するか、または EasyBuilder ツールバーの [image] ボタンをクリックして、ライブビデオモードに入ることもできます。 これらのライブビデオのオプションは、すべてのアプリケーションステップで使用することができます。
  • ライブビデオモード中でも、自動/手動露光、露光時間、最適露光、照明制御モードおよび画像拡大モードの設定の変更を行うことができます。

画像の下に表示されるフォーカスメトリクスは、画像フォーカス得点を決定するのに使用することができます。フォーカスメトリクスは、「シーン」内で認識可能な最小の特徴が画像または画像領域に含まれる度合いを示します。

注 :
  • In-Sight 2000 シリーズビジョンセンサに接続している場合、フォーカスメトリクスの [最小]、[最大]、[フォーカス] 値は表示されません。
  • ライブビデオモード中に、EasyBuilder ツールバーの [フォーカスメトリクス] アイコン [image] を押して、フォーカスメトリクスを非表示にすることができます。 または、[表示] メニューの [フォーカスメトリクス] を選択して、非表示にすることもできます。
閉じた フォーカス調整

  1. [ライブビデオ] ボタンを押すか、 EasyBuilder ツールバーの [image] ボタンを押してください。

    注 : ビジョンセンサはオフラインにてください。
  2. In-Sight 2000 Mini シリーズビジョンセンサを使用している場合、[オートフォーカス] ボタンを使用して自動的にレンズをフォーカスすることができます。 または、検査する特徴がはっきりとした高コントラストとなるように、[フォーカス距離 (%)] スライダーコントロールを使用して、手動でフォーカスを調整することもできます。
  3. 他の In-Sight 2000 シリーズビジョンセンサを使用している場合、検査する特徴がはっきりとた高コントラストとなるように、ビジョンセンサに装着された照明モジュールを手動で調整してください。
  4. 満足のいく画質が得られたら、[ライブビデオ] ボタンを再び押します。
閉じた 輝度調整
  1. [ライブビデオ] ボタンを押すか、 EasyBuilder ツールバーの [image] ボタンを押してください。

  2. EasyBuilder ツールバーから、[露光過多・過少を表示] アイコンを押します。 暗すぎる画像エリアは青で表示され、明るすぎる画像エリアは赤で表示されます。

    注 : [表示] メニューから、[露光過多・過少を表示] を選択することもできます。

  3. 次のいずれかの方法で、画像の輝度を調整することができます。

    • ビジョンセンサに装着されたレンズの絞りを手動で調整し、赤および青で表示されている画像エリアを最小にします。
    • [露光時間] コントロールを調整して、赤および青で表示されている画像エリアを最小にします。 詳細については、露光時間をご参照ください。
    • [自動露光] を選択します。 詳細については、自動露光をご参照ください。

  4. 満足のいく画質が得られたら、露光過多・過小を表示 [image] アイコンを再び押し、表示を OFF にします。

    注 : [表示] メニューから、[露光過多・過少を表示] を選択して、表示を OFF にすることもできます。
閉じた PC から画像をロード

[PC から画像をロード] ボタンを押すと、[記録再生のオプション] ダイアログが開き、ビジョンセンサまたはエミュレータの記録および再生を設定することができます。 ダイアログの設定が済むと、指定の [記録フォルダ] および [再生フォルダ] に保存された画像を記録および再生することができます。

注 :
  • ジョブ実行時のモニタリングおよびデバッグ用に、PC ではなく、ビジョンセンサに画像を保存することができます。[フィルムストリップ] アプリケーションステップで [センサの設定] を使用して設定してください。

  • PC にカラー画像を記録する場合、24 ビット画像でなく、16 ビット画像で保存されます。カラー画像を使用して、カラーツールをテストする必要がある場合、FTP 経由で画像をエクスポートし ([通信] アプリケーションステップで FTP デバイスを追加します) 、画像を保存することによってフルカラーを保持することができます。

閉じた [再生] タブ

[再生] タブを設定してから、PC のフィルムストリップの [再生] ボタンを押すと、PC 上の指定の [再生] フォルダに保存された画像はビジョンシステムに送信され、再生中の画像に対してジョブが実行されます。デフォルトでは、再生フォルダは EasyBuilder Sample Jobs フォルダを参照します。

閉じた [記録] タブ

[記録] タブを設定してから、EasyBuilder ツールバーの [記録] ボタンを押すと、画像が取り込まれ、PASS および FAIL 画像が記録され、PC 上の指定の [再生] フォルダに保存されます。オンラインまたはオフラインのビジョンシステムから、書き込み権限を持つ PC 上の任意のフォルダに結果を保存することができます。 PC に保存できる画像の数は最大 10,000 です。


画像を取り込み、またはロードするには

[画像取り込み/ロード] グループボックスを使用して、ビジョンシステムから画像を取り込んだり、アクティブなライブビデオ画像を表示したり、以前に取り込んだ画像を PC からロードしたりすることができます。

閉じた トリガ

[トリガ] ボタンは、ビジョンシステムから単一の画像を取り込むのに使用されます。 [トリガ] ボタンを押して、単一の画像を取り込みます。 またはキーボードの F5 キーを押すか、EasyBuilder ツールバーの [image] を押してください。 ([画像取り込みの設定] グループボックスの [トリガ] コントロールを [手動] に設定する必要があります。)

閉じた ライブビデオ

[ライブビデオ] ボタンはビジョンシステムをライブ表示にします。ライブ表示にして、ビジョンシステムに装着されたレンズのフォーカスを調整したり、露光や輝度を調整したりすることができます。 画像にフォーカスが合い、輝度が調整されてコントラストが最大になっている時に、アプリケーションが最適に機能します。

画像の下に表示されるフォーカスメトリクスは、画像フォーカス得点を決定するのに使用することができます。フォーカスメトリクスは、「シーン」 (その画像でキャプチャされた対象物とその背景) 内で認識可能な最小の特徴が画像または画像領域に含まれる度合いを示し、[フォーカス領域] ボタンを使用して定義します。

注 :
  • 関連するデータを提供するには、まったく同一のシーンから取得した別の画像のフォーカスメトリックス得点と比較する必要があります。
  • ライブビデオモード中に、EasyBuilder ツールバーの [フォーカスメトリクス] [image] アイコンを押して、フォーカスメトリクスを非表示にすることができます。
閉じた フォーカス調整
閉じた In-Sight 5000 シリーズ、In-Sight Microシリーズおよび C マウントレンズ装着の In-Sight 7000 シリーズビジョンシステムおよび 8000 シリーズビジョンシステム

  1. [ライブビデオ] ボタンを押すか、 EasyBuilder ツールバーの [image] ボタンを押してください。

    注 : ビジョンシステムはオフラインにてください。
  2. 検査する特徴がはっきりとた高コントラストで、許容可能なフォーカスメトリクス得点となるように、ビジョンセンサに装着されたレンズのフォーカスリングを手動で調整します。
  3. 満足のいく画質が得られたら、[ライブビデオ] ボタンを再び押します。
  4. 最後に取り込まれた画像が表示されます。
閉じた オートフォーカス M12 レンズを装着した In-Sight 7000 シリーズビジョンシステム
注 : [フォーカス制御] は、In-Sight Explorer 4.7.3 以降、In-Sight ファームウェア4.7.3 以降を使用している In-Sight 70xx - 74xx シリーズビジョンシステムで使用可能です。

  1. [ライブビデオ] ボタンを押すか、 EasyBuilder ツールバーの [image] ボタンを押してください。

    注 : ビジョンシステムはオフラインにてください。

  2. [オートフォーカス] ボタンを押すか、あるいは検査する特徴がはっきりとた高コントラストで、許容可能なフォーカスメトリクス得点となるように、フォーカス位置スライダを手動で調整します。

    注 : [オートフォーカス] ボタンを押すと、フォーカス位置スライダおよび [フォーカスの保存] ボタンは無効となります。
  3. [オートフォーカス] ボタンを押すと、フォーカス位置の値は更新され、新しい画像が表示されます。
  4. 満足のいく画質および得点が得られたら、[フォーカスの保存] ボタンを押します。 現在のフォーカス位置がデフォルトのフォーカス位置として保存され、ビジョンシステムを再起動すると現在の位置に自動的にレンズが移動します。
閉じた 輝度調整
  1. [ライブビデオ] ボタンを押すか、 EasyBuilder ツールバーの [image] ボタンを押してください。
  2. EasyBuilder ツールバーから、[露光過多・過少を表示] アイコンを押します。 暗すぎる画像エリアは青で表示され、明るすぎる画像エリアは赤で表示されます。
  3. 次のいずれかの方法で、画像の輝度を調整することができます。
    • ビジョンシステムに装着されたレンズの絞りを手動で調整し、赤および青で表示されている画像エリアを最小にします。
    • [画像取り込みの設定] グループボックスの [露光時間] コントロールの数字を大きくし、赤および青で表示されている画像エリアを最小にします。
    • [画像取り込みの設定] グループボックスの [自動露光] ドロップダウンメニューから　[連続] または [シングルショット] を選択します。 [連続] は、画像が取り込まれるたびにビジョンシステムをアクティブにし、照明の状態に基づいて自動的に露光を調整します。 [シングルショット] は、最初に取り込まれた画像を基に露光を調整します。この露光時間の値は、その後、画像が取り込まれても変更されません。
  4. 満足のいく画質が得られたら、露光過多・過小を表示 [image] アイコンを再び押し、表示を OFF にします。
閉じた PC から画像をロード

[PC から画像をロード] ボタンを押すと、[記録再生のオプション] ダイアログが開き、ビジョンセンサまたはエミュレータの記録および再生を設定することができます。 ダイアログの設定が済むと、指定の [記録フォルダ] および [再生フォルダ] に保存された画像を記録および再生することができます。

注 :
  • ジョブ実行時のモニタリングおよびデバッグ用に、PC ではなく、ビジョンシステムに画像を保存することができます。[フィルムストリップ] アプリケーションステップで [センサの設定] を使用して設定してください。

  • PC にカラー画像を記録する場合、24 ビット画像でなく、16 ビット画像で保存されます。カラー画像を使用して、カラーツールをテストする必要がある場合、FTP 経由で画像をエクスポートし ([通信] アプリケーションステップで FTP デバイスを追加します) 、画像を保存することによってフルカラーを保持することができます。

閉じた [再生] タブ

[再生] タブを設定してから、PC のフィルムストリップの [再生] ボタンを押すと、PC 上の指定の [再生] フォルダに保存された画像はビジョンシステムに送信され、再生中の画像に対してジョブが実行されます。 デフォルトでは、再生フォルダは EasyBuilder Sample Jobs フォルダを参照します。

注 : [再生] フォルダは、デフォルトでEasyBuilder サンプルジョブフォルダを参照しています。これらのサンプルジョブを使用して、[記録再生のオプション] の便利な使い方についてデモンストレーションを行うことができます。記録再生のオプションは、以前に取り込んだ画像を繰り返し再生し、ツール結果を即時に表示することから、しきい値や制限の設定を短時間で行うことができます。
閉じた [記録] タブ

[記録] タブを設定してから、EasyBuilder ツールバーの [記録] ボタンを押すと、画像が取り込まれ、PASS および FAIL 画像が記録され、PC 上の指定の [再生] フォルダに保存されます。 オンラインまたはオフラインのビジョンシステムから、書き込み権限を持つ PC 上の任意のフォルダに結果を保存することができます。 PC に保存できる画像の数は最大 10,000 です。


画像取り込みの設定を調整するには

[画像取り込みの設定] グループボックスのコントロールを使用して、画像取り込みトリガのコントロールを調整したり、露光および輝度の補正を行ったり、In-Sight センサの照明をコントロールすることができます。

In-Sight 2000 シリーズビジョンセンサ

  • 画像の設定

In-Sight ビジョンシステム

  • トリガ制御
  • 露光制御
  • 画像センサ転送制御
  • 照明制御
  • ハイダイナミックレンジ (HDR)
  • ホワイトバランス
  • フォーカス領域
  • フォーカス制御
  • 照明の設定
  • ラインスキャンの設定

In-Sight 2000 シリーズビジョンセンサ

In-Sight ビジョンシステム

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder ヘルプ | 08/29/2022 | Revision: 5.9.0.2


画像の設定

注 : このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。 In-Sight ビジョンシステムに接続している場合、画像取り込みの設定を調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。

トリガ

[トリガ] コントロール ([種類]、[遅延] および [間隔]) を使用して、画像を取得したり、検査を実行したりする方法やタイミングをカスタマイズすることができます。

注 : [連続] トリガを In-Sight 2000 シリーズビジョンセンサで使用すると、センサの CPU 負荷が高くなる影響で、In-Sight Explorer からの接続に失敗することがあります。 その場合はトリガの [種類] を変更するか、またはトリガの [間隔] を調整して対応してください。
閉じた 種類

ドロップダウンメニューから、In-Sight センサのオンライン時に、画像を取り込むソースを指定することができます。

カメラ | ビジョンシステムの専用取り込みトリガ入力において検出される、立ち上がりエッジで画像取り込みを有効にします。
連続 (デフォルト) | 「フリーランニング」による画像取り込み (可能な限り高速) を有効にします。
手動 | F5 キーが押されたときに、画像取り込みを有効にします。 注 : ビジョンセンサの TRG ボタンを押して、センサにトリガをかけることができます。
産業用イーサネット | EtherNet/IP、PROFINET、SLMP スキャナまたは CC-Link IE フィールド Basic などの産業用イーサネットプロトコルからのトリガを有効にします。 詳細については、『In-Sight® Explorer ヘルプ』ファイルをご参照ください。
閉じた 遅延 (msec)

トリガを受信してから In-Sight ビジョンセンサが画像取り込みを始めるまでの、遅延時間をミリ秒単位で指定することができます (0～10,000) 。 [トリガ] タイプは、[カメラ] に設定する必要があります。

注 :
  • 遅延は、1 ミリ秒から最大ライン露光時間 (64 マイクロ秒) を引いた値から、要求されたミリ秒数に最大ライン露光時間を足した値までの範囲です。
  • [入力/出力] ステップの [信号のタイプ] で、[画像取り込み開始] が選択された場合、指定時間分、出力が遅延します。
閉じた 間隔 (msec)

[トリガ] を [連続] に設定した場合、画像取り込み間隔をミリ秒単位で指定することができます (0～10,000、デフォルトは 0) 。

注 : この遅延は、画像処理を完了するのに必要な時間によって異なります。 例えば、[トリガ間隔] を 500 ミリ秒に設定した場合、ジョブが 500 ミリ秒以内に画像処理を完了する条件で、In-Sight ビジョンセンサは画像を 500 ミリ秒ごとに取り込みます。 そうでなければ、In-Sight ビジョンセンサは画像処理が完了した時点で画像を取り込みます。

フォーカス (オートフォーカス機能付き In-Sight 2000 ビジョンセンサのみ)

[フォーカス] タブを使用して、自動的にレンズのフォーカスを合わせたり、特定のフォーカス位置にレンズを移動したりして、サポートされているオートフォーカス機能付き In-Sight 2000 ビジョンセンサのレンズのフォーカス位置を制御します。

閉じた オートフォーカス領域

レンズを自動的にフォーカスするときに使用する、画像領域を指定します。 [オートフォーカス領域] ボタンを押して、領域を設定してください。

閉じた [オートフォーカス] ボタン

自動的にレンズの焦点を合わせ、領域内の画像シャープネスを最大にします。

閉じた ジョブロード時にオートフォーカスを実行
  • OFF (デフォルト): 現在の [フォーカス距離 (%)] をジョブに保存します。
  • ON: ジョブがロードされたときに、ビジョンセンサはレンズを自動的にフォーカスします。
閉じた フォーカス距離 (%)

手動でフォーカス位置を調整します (0～100%。 デフォルト: 6.2mm レンズ = 66%、16mm レンズ = 69.2%)。 ビジョンセンサの近くに置かれた対象物にフォーカスするには、ハンドルを左に (0% のほうに) 動かします。 ビジョンセンサの遠くに置かれた対象物にフォーカスするには、ハンドルを右に (100% のほうに) 動かします。 ライブビデオモードのステータスに関わらず、ハンドルを動かすことができます。

注 : 0% は、最も近いフォーカス面を表します。 例えば、対象物がビジョンセンサに非常に近い時、0% となります。 100% は、最も遠いフォーカス面を表します。これは、本質的に「無限遠焦点」です。

照明

注 : 条件によっては、オートフォーカス機能付き In-Sight 2000 Mini シリーズビジョンセンサの照度が、他の In-Sight 2000 シリーズビジョンセンサの照度よりも暗くなることがあります。
閉じた 自動露光

画像取り込みごとに、露光を自動的に計算します。 光を乱反射する金属物など、影が動き背景の照明が変化するといった照明のばらつきを調整することができます。 [自動露光] はデフォルトで OFF になっています。

閉じた 手動露光

画像取得の際に使用する、固定された露光値を設定します。 手動露光はデフォルトで ON になっています。 OFF にするには、[自動露光] を ON にしてください。

閉じた 画像の目標輝度

輝度レベル (0～100、デフォルト = 50) を指定することができます。値は、ハンドルを調整したり、対応する編集ボックスに値を入力したりして調整できます。 値は、露光領域内で許容される飽和状態 (＝白) のピクセルのパーセンテージです。

ヒント : 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。
閉じた 露光時間 (msec)

画像取得時の露光時間を設定します (0.000 ～ 1000.000; デフォルト = 0.250)。 露光時間が長いほど、取り込まれた画像の輝度が高くなります。 このコントロールは、[自動露光] が選択されている場合、無効となります。

閉じた 照明輝度
注 : [照明輝度] スライダーバーは、In-Sight 2000 Mini シリーズビジョンセンサではサポートされていません。

LED の輝度レベルをパーセンテージで指定することができます (0～100、デフォルト = 70、OFF = 0)。値は、ハンドルを調整したり、対応する編集ボックスに値を入力したりして調整できます。 輝度はジョブに保存されます。

ヒント : 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

青い背景は、現在の設定で使用可能な最大輝度値を示します。 最大照明輝度値は、[画像の目標輝度]、[露光時間]、[画像エリアの高さ]、[画像拡大モード] などの、他の画像の設定によって異なります。

注 : スライダコントロール上にマウスポインタを重ねると、最大値が表示されます。
閉じた [露光領域] ボタン (領域の設定)

露光時間の自動計算に使用される領域を指定します。

注 : [デフォルト領域にリセット] ボタンをクリックして、デフォルト設定に戻すことができます。
閉じた 最適露光

自動的に露光時間を最適化します。 最適化後、画像取り込み時に、常に同じ露光時間が使用されます。

閉じた 照明制御モード

[ON (露光)] は、露光時間中のみリング照明を点灯します (デフォルト)。 [OFF] に設定した場合、照明は OFF となり、センサは周囲 (室内) の照明に依存することになります。

ホワイトバランス (In-Sight 2000 カラーセンサのみ)

閉じた [ホワイトバランス領域] および [ホワイトバランスの設定]

画像の赤、緑および青 (RGB) 値を計算し補正を行うことによって、カラー画像からカラーキャスト (色かぶり) を削除します。 その結果、白いアイテムが画像でも白く表示されます。

新規ジョブを作成すると、最後に実行されたホワイトバランス設定が使用されます。 ホワイトバランス設定はジョブに保存され、ジョブがロードされるとホワイトバランス設定がリストアされます。

注 :
  • ホワイトバランスの設定は、手動露光中に行ってください。

  • [照明輝度] パラメータを大幅に変更した場合、最も正確なカラーを画像に再現するため、ホワイトバランスを再度実行してください。

  1. マット仕上げの白い紙など、平らなテストオブジェクトに対し、In-Sight ビジョンセンサのフォーカスを合わせ、照明制御を設定してください。この際、露光過多にならないようにしてください。

  2. [ホワイトバランス領域] ボタンをクリックし、明るいピクセルのみを含む領域を囲んでください。この時、『ホットスポット』が領域に入らないようにしてください。

    注 : [デフォルト領域にリセット] ボタンをクリックして、画像全体を含むようにすることができます。
  3. [ホワイトバランスの設定] ボタンをクリックします。 その後、この設定を使用して、画像が取り込まれます。
ホワイトバランス前 | ホワイトバランス | ホワイトバランス後

画像

閉じた 画像エリアの高さ

画像を取り込む際の、取り込み行数を指定します。対象エリアが画像内の同じ帯に常に制限されている場合に使用できます。 左ハンドル (開始行) や右ハンドル (終了行) を調整したり、対応する編集ボックスに値を入力したりして、値を設定することができます。

ヒント : 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。
In-Sight モデル | 解像度 | 開始行の値 | 終了行の値
2000-110 | 640 ✕ 480 | 0～479 (デフォルト = 0) | 0～479 (デフォルト = 479)
2000-120/120C | 640 ✕ 480 | 0～479 (デフォルト = 0) | 0～479 (デフォルト = 479)
2000-130/130C1 2000-230/230C1 | 640 ✕ 480 (デフォルト) | 0～479 (デフォルト = 0) | 0～479 (デフォルト = 479)
 | 800 ✕ 600 | 0～599 (デフォルト = 0) | 0～599 (デフォルト = 599)
2000-23M1 | 640 ✕ 480 | 0～479 (デフォルト = 0) | 0～479 (デフォルト = 479)
 | 800 ✕ 600 (デフォルト) | 0～599 (デフォルト = 0) | 0～599 (デフォルト = 599)
2001-230/230C1 | 640 ✕ 480 | 0～479 (デフォルト = 0) | 0～479 (デフォルト = 479)
 | 800 ✕ 600 | 0～599 (デフォルト = 0) | 0～599 (デフォルト = 599)
 | 1280 x 960 (デフォルト) | 0 - 959 (デフォルト = 0) | 0 - 959 (デフォルト = 959)
1解像度は、[画像の設定] ダイアログで設定できます。 詳細については、[画像の設定] ダイアログをご参照ください。 詳細については、[画像の設定] ダイアログをご参照ください。
閉じた 画像拡大モード

[画像拡大モード] を ON にします。 ON にすると FOV は 50% 減少し、光解像度は 200% に増加します。

In-Sight モデル | 解像度 | 画像拡大モード
2000-110 | 640 ✕ 480 | サポートされていません
2000-120/120C | 640 ✕ 480 | ON/OFF に設定可
2000-130/130C1 2000-230/230C1 | 640 ✕ 480 (デフォルト) | ON/OFF に設定可
 | 800 ✕ 600 | 常に ON
2000-23M1 | 640 ✕ 480 | ON/OFF に設定可
 | 800 ✕ 600 (デフォルト) | 常に ON
2001-230/230C1 | 640 ✕ 480 | ON/OFF に設定可
 | 800 ✕ 600 | 常に ON
 | 1280 ✕ 960 (デフォルト) | 常に ON
1解像度は、[画像の設定] ダイアログで設定できます。 詳細については、[画像の設定] ダイアログをご参照ください。 詳細については、[画像の設定] ダイアログをご参照ください。
画像拡大モード 無効 | 画像拡大モード 有効
閉じた キャリブレーションタイプ

検査ツールをピクセルから実単位に変換またはキャリブレートします。 2 つのオプション ([FOV (幅)] または [インポート] ) があります。

注 :
  • [FOV (幅)] は、2000-110 および 2000-120/120C ビジョンセンサではサポートされていません。
  • [インポート] オプションは、In-Sight 2000-23M ビジョンセンサでのみ使用できます。
閉じた FOV (幅)

寸法測定ツールの結果を、ピクセルから実単位 (ミリメートル、センチメートルまたはインチ) に変換します。

FOV (幅) = 640 ピクセル/ 125 ミリメートル
  1. [キャリブレーションタイプ] ドロップダウンメニューから、[FOV (幅)] を選択します。
  2. ドロップダウンメニューから使用する実単位 (ミリメートル、センチメートルまたはインチ) を選択します。 デフォルトでは [ピクセル] が選択されており、値を変更することはできません。
  3. FOV (視野) の値を選択した単位で可能な限り正確に計測し、その値を入力します。

  4. 入力後、すぐに単位が変換されます。 例えば、FOV (幅) を 125 ミリメートルに設定し、2 つのエッジの幅が 490 ピクセルである場合、結果は 95.703mm を返します。

    注 :
    • 以下に、数式および例で実際に使用された計算方法を示します。
      • FOV (実単位) / FOV (ピクセル) * 測定値 (ピクセル) = 結果 (実単位)
      • 125/640*490 = 95.703mm
閉じた インポート

[インポート] キャリブレーションタイプを使用して、N 点キャリブレーションツールで作成したキャリブレーションファイルをロードしたり、In-Sight ビジョンセンサのローカルファイルシステムにエクスポートしたりすることができます。 インポートされたキャリブレーションファイルは、ロード次第、自動的にジョブをキャリブレーションします。

注 : [キャリブレーションタイプ] から [インポート] を選択する前に、まず N 点キャリブレーションツールをジョブに追加、設定してください。その後、キャリブレーションファイルを In-Sight ビジョンセンサのローカルファイルシステムにエクスポートしてください。

N 点キャリブレーションツールは、ピクセル座標系とワールド座標系間で変換を行うための 2D 変換を作成します。 このツールは、以下の変換を行います。

  • 2 次元での変換 (5 つ以上の点を使用) 。
  • 3 つの軸についての回転 (4 つ以上の点を使用) 。
  • 2 次元でのスケール (2 つ以上の点を使用) 。
  • 平行四辺形化またはスキュー (4 つ以上の点を使用) 。
  • 平行四辺形化またはスキュー (4 つ以上の点を使用) 。

使用法

  1. [キャリブレーションタイプ] ドロップダウンメニューから、[インポート] を選択します。
  2. EasyBuilder は、N 点キャリブレーションツールで生成されたキャリブレーションファイルがジョブに含まれているかどうかを調査し、キャリブレーションファイルをロードします。 1 個以上のキャリブレーションファイルを作成した場合、[ファイル名] ドロップダウンメニューから使用するファイルを選択してください。
  3. [単位] ドロップダウンメニューからキャリブレーションを定義する実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  4. このオプションが選択されるとすぐにキャリブレーションが実行され、値が設定されます。


トリガ制御

[トリガ]、[トリガ遅延] および [トリガ間隔] を使用して、いつ、どのように画像が取り込まれるかをカスタマイズすることができます。

  • [トリガ]: In-Sight ビジョンシステムのオンライン時に、画像を取り込むソースを指定することができます。

    • カメラ (デフォルト): ビジョンシステムの専用取り込みトリガ入力において検出される、立ち上がりエッジで画像取り込みを有効にします。
    • 連続: 「フリーランニング」による画像取り込み (可能な限り高速) を有効にします。

    • 外部: シリアルコマンド、または画像取り込みトリガとして設定されているディスクリート入力ビットが立ち上がりエッジになったときの、いずれかで画像取り込みを有効にします。

      注 :
      • ビジョンシステムの内蔵画像取り込みトリガ入力 (AcquireImage 関数の [トリガ] パラメータを [カメラ] に設定) に対し、汎用入力ラインを画像取り込みトリガ ([トリガ] パラメータを [外部] に設定) として設定することにより、より高速にトリガを実行することができます。
      • AcquireImage 関数の [トリガ] パラメータを [外部] に設定したときに画像取り込みに失敗した場合、[エラー: 画像取り込みミス] ディスクリート出力は、ビジョンシステムから送信されません。 [エラー: 画像取り込みミス] 信号は、AcquireImage 関数の [トリガ] パラメータが [カメラ] に設定されている場合のみサポートされています。
    • 手動: F5 キーが押されたときに、画像取り込みを有効にします。
    • 産業用イーサネット: 産業用イーサネットプロトコルによるトリガを有効にします (EtherNet/IP、POWERLINK、Profinet、SLMP スキャナまたは CC-Link IE フィールド Basic)。
    • タイムスタンプ: PLC から EtherNet/IP を介し、ビジョンシステムにタイムスタンプトリガが送信されたときに、画像取り込みを有効にします。 [タイムスタンプ] オプションは次のビジョンシステムのみでサポートされています。

      • 128MB 以上の不揮発性フラッシュメモリを持ち、ファームウェアバージョン 4.5.0 以降を搭載した In-Sight 5000 シリーズビジョンシステム

        注 : In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-1R)、In-Sight 5705 ビジョンシステムおよび In-Sight 5705C ビジョンシステムではサポートされていません。
      • In-Sight 7000 Gen2 シリーズビジョンシステム
      • In-Sight 9000シリーズビジョンシステム

  • [トリガ遅延]: トリガを受信してからビジョンシステムが画像取り込みを始めるまでの、遅延時間をミリ秒単位で指定することができます (0～10,000)。

    注 :
    • この機能を有効にするには、[トリガ] を [カメラ] または [ネットワーク] に設定する必要があります。
    • 遅延は、要求されたミリ秒数から最大ライン露光時間 (64 マイクロ秒) を引いた値から、要求されたミリ秒数に最大ライン露光時間を足した値までの範囲です。
    • [入力/出力] ステップの [信号のタイプ] で、[画像取り込み開始] または [ストロボ] が選択された場合、指定時間分、出力が遅延します。

  • [トリガ間隔]: [トリガ] を [連続] に設定した場合、画像取り込み間隔をミリ秒単位で指定することができます (0～10,000、デフォルトは 500)。

    注 : この遅延は、画像処理を完了するのに必要な時間によって異なります。 例えば、[トリガ間隔] を 5,000 ミリ秒に設定した場合、ジョブが 5,000 ミリ秒以内に画像処理を完了する条件で、In-Sight ビジョンシステムは画像を 5,000 ミリ秒ごとに取り込みます。 そうでなければ、In-Sight ビジョンセンサは画像処理が完了した時点で画像を取り込みます。


露光制御

露光制御を使用して、照明のばらつきと輝度のバランスを調整し、検査に使用する特徴を最大限に際立たせるように、アプリケーションをカスタマイズすることができます。

閉じた 露光時間

[露光時間] を使用して、露光時間を指定することができます。In-Sight ビジョンシステムがトリガ信号を受信すると、指定された露光時間の間、イメージャーに光が蓄積されます。

注 :
  • 以下のビジョンシステム/センサの解像度は、[画像の設定] ダイアログで設定できます:In-Sight Micro 1500、In-Sight 2000-130、2000-130C、2000-230、2000-230C、2000-23M、2001-230、2001-230C、In-Sight 7500、7500C、7600、7600C、7800、7800C、7900、7900C、7802、7802C、7902、7902C。
  • 5604 および 5614 ラインスキャンビジョンシステムでは、[ラインスキャンの設定] ダイアログで画像の高さを設定することができます。
  • 9902L ラインスキャンビジョンシステムでは、[ラインスキャンの設定] ダイアログで 1K 解像度 (低照明モード) および最大画像高を設定することができます。
  • In-Sight 5604 または 9902L ラインスキャンビジョンシステムに接続されている場合、露光時間はマイクロ秒 (µsec) 単位で設定されます。
  • In-Sight 8405 ビジョンシステムでストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。 詳細については、ローリングシャッターの操作をご参照ください。

  • このパラメータが技術的に 0 に設定されている場合、露光時間は In-Sight ビジョンシステムに依存します。露光時間の値が 0 の場合は、デフォルトで、選択したビジョンシステムの最小露光時間 (ミリ秒またはマイクロ秒単位) となります。

In-Sight モデル | 解像度 | センサの種類 | 露光時間 (ms)
Micro 1020、1050、1100、1110、1100C、1400、1410、1400C | 640 ✕ 480 | CCD、グローバルシャッター | 0.016～1000
Micro 1402、1412 | 1280 ✕ 1024 | CMOS、グローバルシャッター | 0.016 ～ 950
Micro 1403、1413、1403C | 1600 ✕ 1200 | CCD、グローバルシャッター | 0.052 ～1000
Micro 1500 | 640 ✕ 480 | CMOS、グローバルシャッター | 0.004 ～ 500
 | 800 ✕ 600 | CMOS、グローバルシャッター | 0.005 ～ 500
2000-110、2000-120、2000-120C、2000-130、2000-130C、2000-230、2000-230C、2000-23M、2001-230、2001-230C | 640 ✕ 480 | CMOS、グローバルシャッター | 0.001 ～ 1000
2000-130、2000-130C、2000-230、2000-230C、2000-23M、2001-230、2001-230C | 800 ✕ 600 | CMOS、グローバルシャッター | 0.001 ～ 1000
2001-230、2001-230C | 1280 ✕ 960 | CMOS、グローバルシャッター | 0.001 ～ 1000
5100、5110、5100C、5400、5410、5400C、5600、5610 | 640 ✕ 480 | CCD、グローバルシャッター | 0.016～1000
5403、5413、5603、5613 | 1600 ✕ 1200 | CCD、グローバルシャッター | 0.027 ～ 1000
5604 & 5614 ラインスキャン | 1024 ✕ 8192 | CCD、グローバルシャッター | 1.33 ～ 1000 µs
5605、5615、5705、5715 | 2448 ✕ 2048 | CCD、グローバルシャッター | 0.014 ～ 1000
5705C | 2448 ✕ 2048 | CCD、グローバルシャッター | 0.016～1000
7010、7010C、7020、7050、7200、7210、7230、7200C、7400、7410、7430、7400C | 800 ✕ 600 | CMOS、グローバルシャッター | 0.016 ～ 950
7402、7412、7432、7402C | 1280 ✕ 1024 | CMOS、グローバルシャッター | 0.016 ～ 950
7500、7500C、7600、7600C、7800、7800C、7900、7900C | 800 ✕ 600 | CMOS、グローバルシャッター | 0.014 ～ 550
 | 640 ✕ 480 | CMOS、グローバルシャッター | 0.014 ～ 520
7501、7501C、7801、7801C、7901、7901C | 1280 ✕ 1024 | CMOS、グローバルシャッター | 0.017 ～ 750
7802、7802C、7902、7902C | 1600 ✕ 1200 | CMOS、グローバルシャッター | 0.020 ～ 940
 | 800 ✕ 600 (低照明モード) | CMOS、グローバルシャッター | 0.020 ～ 940
7802P、7902P | 1920 ✕ 1200 | CMOS、グローバルシャッター | 0.021 ～ 1000
7905、7905C | 2448 ✕ 2048 | CMOS、グローバルシャッター | 0.021 ～ 1000
8100、8100C、8200、8200C、8400、8400C | 640 ✕ 480 | CMOS、グローバルシャッター | 0.014 ～ 520
8101、8101C、8401、8401C | 1280 ✕ 1024 | CMOS、グローバルシャッター | 0.0174 ～ 750
8402、8402C | 1600 ✕ 1200 | CMOS、グローバルシャッター | 0.020 ～ 940
8405 | 2592 ✕ 1944 | CMOS, ローリングシャッター | 0.032～1000
8505P | 2448 ✕ 2048 | CMOS、グローバルシャッター | 0.021 ～ 1000
9902L ラインスキャン | 2048 ✕ 16384 | CMOS、グローバルシャッター | 2.00 µsec ～ 1000 µsec
 | 1024 ✕ 16384
9912、9912C | 4096 ✕ 3000 | CMOS、グローバルシャッター | 0.021 ～ 1000
閉じた 自動露光

[自動露光] を使用して、In-Sight ビジョンシステムが自動的に露光を設定できるようにします。光を乱反射する金属物などのように、画像のコントラストが大きく変化するアプリケーションや、影が動き背景の照明が変化するといった照明のばらつきに対して、露光時間を自動で調整することができます。

  • [連続]: 照明の状態を基にして、画像取り込みごとに自動的に露光を調整します。

    注 : [連続] モードでは、画像取り込みの間隔を別途設定できます。
  • [シングルショット]: 最初に取り込まれた画像を基に露光を調整します。この露光時間の値は、その後、画像が取り込まれても変更されません。
    • [最初の画像取り込み]: ビジョンシステムがオフラインの場合、最初の取り込みは露光時間の決定のために使用されます。この露光時間の値は、シングルショットが無効にされるまで保存されます。ビジョンシステムがオフラインの間に取り込みが行われなかった場合、ビジョンシステムをオンラインにしたときの最初の取り込みが露光時間の決定に使用されます。
    • [2 回目以降の画像取り込み]: ビジョンシステムは、最初の取り込みで計算された露光時間の値を使用して、画像を取り込みます。
    注 :
    • ビジョンシステムまたはビジョンセンサがこの機能をサポートしていない場合、表示されません。
    • 異なる [自動露光] モードを選択すると、露光時間の値がリセットされます。露光時間のリセット後に行われた最初の取り込みは、新しい露光時間の値を決定するために使用されます。
閉じた [露光領域] ボタン

露光時間の自動計算に使用される領域を指定します。

注 : この機能を有効にするには、[自動露光] ドロップダウンリストから、[連続] または [シングルショット] を選択してください。
閉じた 露光時間

適切な露光時間の決定の際に使用される最大露光時間を指定することができます。

閉じた 画像の目標輝度

輝度レベル (0～100) を指定することができます。

注 : この機能を有効にするには、[自動露光] ドロップダウンリストから、[連続] または [シングルショット] を選択してください。


画像センサ転送制御

画像センサ転送制御を使用して、画像転送を開始する画像センサ (CCD または CMOS) の行や、画像を生成するのに使用される画像センサの行数を定義することができます。

In-Sight ビジョンシステムは、非同期リセットとプログレッシブスキャンを使用してすべての画像を取り込みます。グレースケールの In-Sight ビジョンシステムは 8 ビットの画像を生成し、カラーの In-Sight ビジョンシステムは 24 ビットの画像を生成します。すべてのビジョンシステムで約 250µs 以内に画像取り込みが開始され、次のように進行します。

  1. 画像センサは、[露光時間] 制御で設定された時間の間、光を蓄積します。
  2. 画像センサに蓄積された画像は行単位でシリアルシフトレジスタに転送されます。
  3. すべての行転送に対し、センサはピクセルごとに画像センサ外部でシフトレジスタをクロッキングして、ピクセル値を転送します。
  4. 転送は取り込み開始行から開始され、指定された行数が処理されます。
閉じた 取り込み開始行

画像センサから In-Sight ビジョンシステムのメモリに転送される最初の行を定義します。

解像度 | 有効な取り込み開始行の値
640 ✕ 480 | 0～479
800 ✕ 600 | 0 ～ 599
1024 ✕ 768 | 0～767
1280 × 1024 | 0 ～ 1023
1600 ✕ 1200 | 0～1199
2448 ✕ 2048 | 0～2047
2592 ✕ 1944 | 0～1943
閉じた 取り込み行数

In-Sight ビジョンシステムのメモリに転送される行数を定義します。

解像度 | 許容される行数
640 ✕ 480 | 1 ～ 480
800 ✕ 600 | 1 ～ 600
1024 ✕ 768 | 1 ～ 768
1280 ✕ 1024 | 1 ～ 1024
1600 ✕ 1200 | 1～1200
2448 ✕ 2048 | 1～2048
2592 ✕ 1944 | 1～1944
注 : エミュレータ に接続し、部分画像取り込みパラメータを有効にして In-Sight ビジョンシステムが取り込んだ画像を表示する場合、エミュレータの[取り込み開始行] および [行数] パラメータは、In-Sight ビジョンシステムのパラメータと同じに設定してください。


照明制御

照明制御を使用して、In-Sight ビジョンシステムの LED 照明バンクおよびリングを設定することができます。

注 : この機能を有効にするには、[自動露光] ドロップダウンリストから、[連続] または [シングルショット] を選択してください。
閉じた 照明制御モード (In-Sight 5000 シリーズおよび In-Sight 70xx～74xx シリーズのみ)

[照明制御モード] は、In-Sight 5000 シリーズまたは 70xx～74xx シリーズビジョンシステムのリング照明を、指定された露光時間のみ点灯するか、常に点灯しておくかを指定します。[ON (露光)] は、露光時間中のみリング照明を点灯します。[常に ON] は、リング照明を常に点灯し、画像を露光していないときに 50% の輝度で LED を点灯し続けることにより、ストロボの効果を低減させます。

閉じた 照明制御 (In-Sight 5000 シリーズのみ)

In-Sight ビジョンシステムの LED 照明バンクを最大 4 つまで制御します。

閉じた 例 - In-Sight 5000 センサシリーズのリング照明

  • [水平] は、水平 LED バンク × 2 を有効にします。
  • [垂直] は、垂直 LED バンク × 2 を有効にします。
  • [すべて] は、水平および垂直 LED バンク (各 2) を有効にします。
閉じた 照明輝度 (In-Sight 70xx～74xx シリーズのみ)

LED の輝度を制御します。輝度はジョブに保存されます。

  • In-Sight 70xx～74xx シリーズビジョンシステム:0 ～ 100、デフォルト = 1、OFF = 0
閉じた ゲイン (In-Sight 7000 シリーズおよび 9912 のみ)

A/D コンバータの前段の増幅器のゲインを制御します。

In-Sight モデル | ゲインの設定
70xx ～ 74xx シリーズ | 0 ～ 7; デフォルト = 0
7500、7501、7600、7600C、7800、7800C、7801、7801C、7802、7802C、7900、7900C、7901、7901C、7902、7902C | 0 ～ 6; デフォルト = 0
7802P、7902P、7905、7905C | 0 ～ 240; デフォルト = 60
9912、9912C | 0 ～ 255; デフォルト = 60


ハイダイナミックレンジ (HDR)

HDR (ハイダイナミックレンジ) は、画像の暗い領域に対し、より優れたコントラストおよび輝度を提供します。 HDR を有効にするには、設定後、画像を 1 度取り込こんでください。

注 : HDR は、In-Sight 7802P、7902P、7905、8505P、9912モノクロビジョンシステムでのみサポートされています。

  • HDR モード: 使用する HDR のモードを定義します。
    • 無効 (デフォルト): HDR は使用されません。
    • HDR+: 周囲のピクセルを考慮して、各ピクセルのグレースケール値を調整します (カーネルサイズの設定によります)。 HDR と比較し、暗い (露出不足の) 領域と明るい (露出過剰の) 領域で、より高いコントラストを提供します。
    • HDR: 各ピクセルのグレースケール値を個別に調整します 。 入力画像上の暗い (露出不足の) 領域により高いコントラストを提供します。
  • HDR カーネルサイズ: HDR+ で同時に処理するピクセルの数を定義します。
    • 小: 121 ピクセル (11☓11 グリッド)
    • 大: 484 ピクセル (22☓22 グリッド)


ホワイトバランス (In-Sight カラービジョンシステムのみ)

注 : このトピックでは、In-Sight カラービジョンシステム接続時のホワイトバランス機能について説明します。 In-Sight 2000 シリーズカラービジョンセンサに接続している場合、画像の設定のホワイトバランスセクションをご参照ください。

カラーの In-Sight センサおよびカラーを有効にしたエミュレータを使用している場合のみ、[ホワイトバランス] ボタンを使用することができます。[ホワイトバランス] は、画像の赤、緑および青 (RGB) 値を計算し、In-Sight ジョブに保存されたカラーテーブルに従って補正を行うことによって、画像のカラーキャスト (色かぶり) を削除します。 その結果、白いアイテムが画像でも白く表示されます。

ホワイトバランス前 | ホワイトバランス | ホワイトバランス後

基準となるニュートラル (灰色) 画像を取り込んで、カラーテーブルを作成します。画像全体に 18-18-18 のような均一の RGB 値を持つ灰色の画像をニュートラル画像と呼びます。このとき、画像を飽和状態 (255-255-255) にしないでください。 続いて [ホワイトバランス] ボタンを押すと、EasyBuilder は各カラーチャネル (赤、緑、青) のヒストグラムを作成します。そして、最も大きな値を各チャネルの値で割ることでスケールファクタ (倍率) を求め、これを RGB 値の均等化に使用します。例えば、200-100-50 の RGB 値によって、1-2-4 倍のスケールファクターが求められます。

使用中のセンサのカラーテーブル設定は、ジョブファイルに保存されています。 適切なホワイトバランス情報を画像に適用するには、画像のロードや取り込みの前にジョブをロードする必要があります。

ホワイトバランス機能を使用するには、次の手順に従います。

  1. 黒い印字のある白紙の断片など、平らなテストオブジェクトに対し、In-Sight センサのフォーカスを合わせ、[画像の目標輝度] を設定します。

    注 : [ホワイトバランス領域] ボタンを使用して、画像のホワイトバランスを計算する領域を指定します。 [ホワイトバランス領域] ボタンを押して、領域を指定してください。
  2. テストオブジェクトの上に、白紙の紙などほかのオブジェクトを差し込みます。 2 番目のオブジェクトも、最初のオブジェクトと同様、視野に入るようにします。

  3. [ホワイトバランス] ボタンを押します。

  4. EasyBuilder は、これらの設定をジョブファイルに保存します。その後、カラーバランス設定を使用して、画像が取り込まれます。

    注 : ホワイトバランス設定は、ジョブファイルに保存され、In-Sight ビジョンシステム上には保存されません。 ジョブを新規作成する場合、上記のステップを繰り返して、ホワイトバランス設定をジョブファイルに適用する必要があります。 EasyBuilder では、ホワイトバランス設定をビジョンシステム上に保持することはできません。


フォーカス領域

[フォーカス領域] ボタンは、画像の領域を指定するのに使用されます。この領域は、ライブモード時に表示されるフォーカスメトリクスの画像フォーカスを計算するのに使用されます。[フォーカス領域] ボタンを押して、領域を設定してください。


フォーカス制御

[フォーカス制御] を使用して、自動的にレンズの焦点を合わせたり、特定の焦点位置にレンズを移動したりして、サポートされている In-Sight 7000 シリーズビジョンシステムのレンズの焦点位置を制御します。

注 :
  • [フォーカス制御] は、In-Sight Explorer 4.7.3 以降、In-Sight ファームウェア4.7.3 以降を使用している In-Sight 70xx - 74xx シリーズビジョンシステムで使用可能です。
  • [フォーカス制御] は、ビジョンシステムのオフライン時にのみ使用できます。
  • [オートフォーカス] および [フォーカスの保存] ボタンは、スプレッドシートビューおよび EasyBuilder ビューの両方に表示されるライブビデオモードからもアクセスすることができます。
閉じた フォーカス制御

[フォーカス制御] を有効にするかどうかを指定します。 デフォルトでは、有効なデフォルトのフォーカス位置がセンサに設定されている場合、[フォーカス制御] は有効となります。フォーカス位置が設定されていない場合、[フォーカス制御] は無効となります。

閉じた [オートフォーカス] ボタン

自動的にレンズの焦点を合わせ、領域内の画像シャープネスを最大にします。

閉じた オートフォーカスオフセット (In-Sight 70xx - 74xx シリーズのみ)

オートフォーカス完了後に、レンズ位置に適用するオフセット値 (-100～100。デフォルト = 0) を指定します。

注 : この設定は、In-Sight 7000 Gen2 シリーズビジョンシステムではサポートされていません。
閉じた フォーカス位置

特定の焦点位置にレンズを移動し、新しい画像を取り込みます。

  • In-Sight 70xx~74xx シリーズ: 0 - 100; デフォルト = 0
  • In-Sight 7000 Gen2 シリーズ: 0 - 250; デフォルト = 0
閉じた 焦点位置とジョブの保存

フォーカス位置をジョブに保存し、ジョブをリロードした際にレンズに適用するかどうかを指定します。 デフォルトでは、[フォーカス位置をジョブに保存] チェックボックスは ON になっています。


ラインスキャン制御

ラインスキャン制御を使用して、In-Sight 5604 または 9902L ラインスキャンビジョンシステムを設定することができます。ラインスキャンは、ターゲットオブジェクトが真下を通り過ぎるたびに、行ごとに画像を生成することから、円筒形状の対象物全体の曲がりのない画像や、表面を薄切りした連続画像を生成することが可能です。ご用意いただいたエンコーダ使用して、ターゲットスピードのばらつきに関わらず、高精度の画像を提供することができます。

注 :
  • これらの制御を有効にするには、In-Sight 5604 または 9902L ラインスキャンビジョンシステムまたはエミュレータに接続する必要があります。
  • フルアクセス権限を持つユーザのみが、ラインスキャンの設定をすることができます。
  • ラインスキャンビジョンシステムはオフラインにしてください。

トリガ: ラインスキャンビジョンシステムのオンライン時における、画像取り込みトリガソースを定義することができます。

  • カメラ (デフォルト): ビジョンシステムの専用取り込みトリガ入力において検出される、立ち上がりエッジで画像取り込みを有効にします。
  • 連続: 「フリーランニング」による画像取り込み (可能な限り高速) を有効にします。

  • 外部: シリアルコマンド、または画像取り込みトリガとして設定されているディスクリート入力ビットが立ち上がりエッジになったときの、いずれかで画像取り込みを有効にします。

    注 :
    • ビジョンシステムの内蔵画像取り込みトリガ入力 (AcquireImage 関数の [トリガ] パラメータを [カメラ] に設定) に対し、汎用入力ラインを画像取り込みトリガ ([トリガ] パラメータを [外部] に設定) として設定することにより、より高速にトリガを実行することができます。
    • AcquireImage 関数の [トリガ] パラメータを [外部] に設定したときに画像取り込みに失敗した場合、[エラー: 画像取り込みミス] ディスクリート出力は、ビジョンシステムから送信されません。 [エラー: 画像取り込みミス] 信号は、AcquireImage 関数の [トリガ] パラメータが [カメラ] に設定されている場合のみサポートされています。
  • 手動: F5 キーが押されたときに、画像取り込みを有効にします。
  • 産業用イーサネット: 産業用イーサネットプロトコルによるトリガを有効にします (EtherNet/IP、POWERLINK、Profinet、SLMP スキャナまたは CC-Link IE フィールド Basic)。
  • タイムスタンプ: PLC から EtherNet/IP を介し、ビジョンシステムにタイムスタンプトリガが送信されたときに、画像取り込みを有効にします。 [タイムスタンプ] オプションは次のビジョンシステムのみでサポートされています。

    • 128MB 以上の不揮発性フラッシュメモリを持ち、ファームウェアバージョン 4.5.0 以降を搭載した In-Sight 5000 シリーズビジョンシステム

      注 : In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-1R)、In-Sight 5705 ビジョンシステムおよび In-Sight 5705C ビジョンシステムではサポートされていません。
    • In-Sight 7000 Gen2 シリーズビジョンシステム
    • In-Sight 9000シリーズビジョンシステム

ラインディレイ (ライン): 画像取り込み開始前に、カメラがトリガを受信してからの遅延ライン数を定義します。

注 : このコントロールを有効にするには、[トリガ] パラメータを [カメラ] に設定してください。

トリガ間隔: [トリガ] コントロールが [連続] に設定されている場合の、画像取り込み間隔をミリ秒単位で定義します (0～10,000、デフォルトは 500)。

注 : この遅延は、画像処理を完了するのに必要な時間によって異なります。例えば、[トリガ間隔] を 5,000 ミリ秒に設定した場合、ジョブが 5,000 ミリ秒以内に画像処理を完了する条件で、In-Sight ビジョンシステムは画像を 5,000 ミリ秒ごとに取り込みます。そうでない場合、In-Sight は、画像処理を終了次第、画像を取り込みます。

露光時間 (µsec): 露光時間をマイクロ秒単位で定義します (0～1,000 µsec、デフォルトは 8 µsec)。In-Sight 5604 がトリガ信号を受信すると、指定された露光時間の間、CCD アレイに光が蓄積されます。

注 :

  • 5604 では、このパラメータは 0 に設定可能ですが、1.33 µsec 以下の値に設定した場合、[露光時間] で定義した時間に関わらず 1.33 µsec の間露光します。

  • 9902L では、このパラメータは 0 に設定可能ですが、2.00 µsec 以下の値に設定した場合、[露光時間] で定義した時間に関わらず 2.00 µsec の間露光します。

ライントリガタイプ: エンコーダタイプを指定します。選択肢は、[ソフトウェアエンコーダ] または [ハードウェアエンコーダ] です。このコントロールを ON にするには、In-Sight 5604 または 9902L に接続する必要があります。このコントロールは、ラインスキャンエミュレータでは OFF になっています。

  • ハードウェアエンコーダ: ライントリガの駆動に [ステップ/ライン] 設定値と外部ハードウェアエンコーダが使用されます。ハードウェアエンコーダは、ターゲットオブジェクトが指定の方向または距離を動くたびに遷移信号を提供し、その位置をデジタル化するデバイスです。In-Sight 5604 および 9902L では、[単位相] および [4 位相] の 2 種類のハードウェアエンコーダをサポートします。この設定は、[ラインスキャンの設定] ダイアログで指定することができます。
  • ソフトウェアエンコーダ (デフォルト): [ライン間隔] 設定で指定した間隔で周期的にライントリガが駆動されます。ソフトウェアエンコーダは、ハードウェアエンコーダのソフトウェアエミュレーションで、指定された周期でラインを取り込みます。この方法はターゲットスピードの変化に対して脆弱で (低周波加速および高周波振動) 、垂直方向の画像に悪影響を及ぼすことがあるため、主に設定およびトラブルシューティングに使用されます。

ライン数: ラインスキャンビジョンシステムからの画像を生成するために取り込む行数を定義します。

  • In-Sight 5604 は、デフォルトで、解像度 1024 × 2048 の標準画像を生成します。幅は、変更できません。高さは、[ラインスキャンの設定] ダイアログの [画像最大高] ドロップダウンを使用して変更することができます。ライン数の値は、1～ [画像最大高] の範囲を使用することができます。

  • In-Sight 9902L は、デフォルトで、解像度 2048 × 4096 の標準画像を生成します。幅および画像最高高は、エンコーダの設定ボタンから開くことができる [ラインスキャンの設定] ダイアログで設定することができます。1K 解像度 (低照明モード) チェックボックスを ON にすると、幅は 1024 に減少し、照明感度が向上します。ライン数の値は、1～ [画像最大高] の範囲を使用することができます。

In-Sight モデル | 最大解像度 | 最小 | 最大 | デフォルト
In-Sight 5604 | 1024 x 8192 | 1 | 8192 | 2048
In-Sight 9902L | 2048 x 16384 | 1 | 16384 | 4096
 | 1024 x 16384
注 :
  • 回転するターゲット画像を取り込む場合、画像トリガミスを防ぐため、[ライン数] は 2 フレーム間のトリガより少ない値としてください。
  • このパラメータは 1 に設定可能ですが、8 以下に設定すると、画像取り込みに失敗します。

ステップ/ライン: [ライントリガタイプ] を [ハードウェアエンコーダ] に設定した場合に、画像ラインごとのエンコーダステップの数を定義します。4 位相ハードウェアエンコーダが使用されている場合、エンコーダ信号が 1 サイクルを完了することを「ステップ」と呼びます。シングルラインハードウェアエンコーダの場合は、1 ステップは 2 回の信号変化に等しく、4 位相ハードウェアエンコーダの場合は 4 回の信号変化に等しくなります。

In-Sight モデル | ステップ/ライン
In-Sight 5604 | 0.250～256.000; デフォルト = 40.000
In-Sight 9902L | 0.250～8191.000; デフォルト = 40.000
注 :
  • [ステップ/ライン] の値は、単位相ラインハードウェアエンコーダでは 0.5 ずつ、4 位相ハードウェアエンコーダでは 0.25 ずつ増分してください。
  • 5604 では、ライントリガの欠落を避けるため、[ステップ/ライン] の値を、任意の 2 つのライン間の最短時間が [露光時間] 設定値 (最短 1.33 µs) より 21.47 µs 長くなるように設定する必要があります。
  • 9902L では、ライントリガの欠落を避けるため、[ステップ/ライン] の値を、任意の 2 つのライン間の最短時間が [露光時間] 設定値 より 3 µs 長くなる値か、もしくは 15µsec か、大きい値のほうに設定する必要があります。
閉じた ステップ/ラインハードウェアエンコーダのタイミング図

ライン間隔 (µsec): [ライントリガタイプ] を [ソフトウェアエンコーダ] に設定した場合に、画像ラインごとの間隔をマイクロ秒単位で定義します。

In-Sight モデル | ライン間隔
In-Sight 5604 | 21.000～1000000.000; デフォルト = 40.000
In-Sight 9902L | 21.000～1000000.000; デフォルト = 40.000
In-Sight エミュレータ | 10.000～1000000.000; デフォルト = 40.000
注 :
  • 5604 では、ライントリガの欠落を避けるため、[ライン間隔] の値を、任意の 2 つのライン間の最短時間が [露光時間] 設定値 (最短 1.33 µs) より 21.47 µs 長くなるように設定する必要があります。

  • 9902L では、ライントリガの欠落を避けるため、[ライン間隔] の値を、任意の 2 つのライン間の最短時間が [露光時間] 設定値 より 3 µs 長くなる値か、もしくは 15µsec か、大きい値のほうに設定する必要があります。

クリップモード: 画像取り込みトリガを受信したときに指定された数のラインの取り込みが完了していない場合の動作を指定します。

  • クリップングなし (デフォルト): 画像トリガを無視し、「画像取り込みエラー」イベントを生成するように指定します。
  • 黒く塗りつぶし: 残りのラインを黒いピクセルで埋め、新しい画像を即座に開始するように指定します。「画像取り込みエラー」イベントは生成されません
  • ラインスキャンラインの間引き: 現在の画像を現在取り込んだ行数のサイズに縮小し、即座に新しい画像を開始するように指定します。
注 :
  • [黒く塗りつぶし] または [ラインスキャンラインの間引き] が有効な場合:
    • 画像を正しくクリッピングするには、[トリガ] タイプを [カメラ] に設定する必要があります。その他のトリガタイプが設定されている場合、画像取り込み中にトリガを受信すると、現在の画像はクリッピングされず、新たに受信したトリガは無視されます。
    • Set Event ネイティブモードコマンドを送信して画像取り込みをトリガを試みた場合に、画像取り込み中にそのトリガを受信すると、現在の画像はクリッピングされず、新たに受信したトリガは無視されます。
  • 時間に厳密なアプリケーションの場合は [ラインスキャンラインの間引き] オプションを選択します。[黒く塗りつぶし] オプションを使用する場合は、埋める行数は数百行程度までに抑えます。
    • 5604 では、[黒く塗りつぶし] オプションでは、1 行埋めるのに約 2 µs かかります (100 行あたり 0.2 ミリ秒)。
    • 9902L では、[黒く塗りつぶし] オプションでは、1 行埋めるのに約 3 µs かかります (100 行あたり 0.3 ミリ秒)。

画像取り込み期間: [クリップ] モードを [黒く塗りつぶし] または [ラインスキャン] の間引きに設定した場合に、いつ画像取り込みを終了するかを定義します。このオプションは、In-Sight 9902L ビジョンシステムで [トリガ] タイプが [カメラ] に設定されている場合のみサポートされています。

  • 0 = 次のトリガ (デフォルト): トリガパルスの立ち上がりエッジで画像取り込みを開始し、次のトリガ信号開始時に、画像取り込みを終了します。
  • 1 = トリガ終了: トリガパルスの立ち上がりエッジで画像取り込みを開始し、現在のトリガ信号終了時に、画像取り込みを終了します。次の状態のときに、画像取り込み完了となります。
    • 指定の [ライン数] が取り込まれたとき。トリガパルスの後端が到着していない場合でも、完了となります。

    • 指定の [ライン数] を取り込む前に、パルスの後端が到着し画像取り込みが終了したとき。

      注 : [トリガ終了] を選択すると、[遅延] パラメータは無効となり、画像取得の際に遅延は適用されません。

[ラインスキャンの設定] ダイアログ


[ラインスキャンの設定] ダイアログ

[ラインスキャンの設定] ダイアログの概要

[ラインスキャンの設定] ダイアログでは、In-Sight 5604 ラインスキャンビジョンシステムのハードウェアエンコーダを設定します。また、このビジョンシステムの特定の診断値を表示します。

注 : In-Sight 5604 ラインスキャンビジョンシステムに接続して、4 位相ハードウェアエンコーダを利用しているときに、ビジョンシステムが画像の取り込みを開始し、4 位相ハードウェアエンコーダが、反対方向に移動してフレームトリガの開始点を通過したという信号を出力した場合、取り込まれた画像は正常には生成されておらず、使用することはできません。このような状況が発生した場合は、4 位相ハードウェアエンコーダが方向を反転したという信号を出力したときに、ビジョンシステムをオフラインにします。次に、4 位相ハードウェアエンコーダが以前の方向に戻ったという信号を出力したときに、ビジョンシステムをオンラインに戻します。

[ラインスキャンの設定] ダイアログの表示

  • [センサ] メニューから [ラインスキャンの設定] をクリックします。

[ラインスキャンの設定] ダイアログの設定項目

  • [画像最大高]: ラインスキャンビジョンシステムでの画像の生成に使用する最大行数 (2048、4096、または 8192、デフォルト = 2048) を指定します。

    注 :
    • ラインスキャンビジョンシステムの [画像最大高] の設定を変更するには、ビジョンシステムを再起動する必要があります。その結果、ビジョンシステムでそのときに行われているジョブは消去されます。続行する前に、ジョブを保存するかバックアップしてください。
    • 起動時にビジョンシステムに割り当てられる画像バッファのデフォルト数は、ビジョンシステムの解像度と RAM サイズによって異なります。[画像最大高] の設定を調整すると、ビジョンシステムで利用可能な画像バッファの最大数が増加または減少します。必要に応じて、[画像バッファ] ダイアログを使用し、起動時にビジョンシステムに割り当てる画像バッファの数を変更してください。
    • 使用しているラインスキャンビジョンシステムの [画像最大高] が 8192 に設定されているときに、ビジョンツールの対象領域の幅を 3072 よりも大きい値に設定する必要がある場合は、数式バーから手動で領域値を入力するか、あるいはコントロール関数または構造体関数を別途作成して、ツールの内部 [領域] パラメータの代わりに参照する必要があります。

  • [ハードウェアエンコーダ]

    注 :
    • AcquireImage プロパティシートの [ライントリガタイプ] パラメータを、[ハードウェアエンコーダ] に設定しておく必要があります。
    • In-Sight 5604 はオフラインになっている必要があります。
    • ユーザがフルアクセスのアクセス権を持っている必要があります。
    • [エンコーダタイプ]: ラインをトリガするために使用されるエンコーダのタイプとして、[単位相] (デフォルト) または [4 位相] を指定します。

    • [方向): エンコーダの方向として、[プラス] (デフォルト) または [マイナス] を指定します。このコントロールは、[エンコーダタイプ] に [4 位相] が設定されている場合に有効になります。

      注 : このコントロールは、[エンコーダタイプ] に [単位相] が設定されている場合には無効化されます。

  • [診断]

    注 : [リセット] ボタンをクリックしたとき、またはビジョンシステムをオンラインまたはオフラインに切り替えたときには、すべての診断統計情報がリセットされます。
    • [エンコーダ数]: エンコーダのステップ数 (ソフトウェアエンコーダの場合はミリ秒) を表示します。
    • [ライン数]: カウンタが前回リセットされてから現在までに実行された画像取り込みライン数の合計を表示します。
    • [ラインオーバラップ数]: エンコーダレートが大きすぎたために失われたラインの数を表示します。
    • [バッファオーバラン数]: ビジョンシステムで画像バッファが不足した回数を表示します。
    • [フレーム/秒]: 1 秒あたりに取り込まれたフレームの数を表示します。
    • [ステップ/秒]: AcquireImage 関数の [ライントリガタイプ] パラメータを [ハードウェアエンコーダ] に設定した場合は、1 秒間に外部エンコーダから受信するステップの数を表示します。AcquireImage 関数の [ライントリガタイプ] パラメータを [ソフトウェアエンコーダ] に設定した場合は、1 秒間のマイクロ秒数を表示します。

    • [リセット]: このボタンは、すべての診断統計情報を 0 にリセットします。

      注 : ビジョンシステムがオンラインまたはオフラインに切り替わったときにはいつでも、統計情報がリセットされます。


キャリブレーション (画像単位を実単位に変換) を行うには

注 : このトピックでは、In-Sight ビジョンシステムのキャリブレーション機能について説明します。 In-Sight 2000-130/130C または 2000 シリーズ 23X ビジョンセンサに接続している場合、[画像の設定] の [FOV (幅)] セクションをご参照ください。

[キャリブレーション (画像座標系をワールド座標系に変換) グループボックスを使用して、位置決めおよび検査ツールの結果をキャリブレーションし、ピクセル単位ではなく、実単位 (ミクロン、ミリメートル、センチメートル、インチ) で表示することができます。

In-Sight ビジョンシステムにおいて、キャリブレーションとは、画像領域を「マッピング」して、画像内の特徴と、既知の実世界の測定単位との関係を確立することです。 このプロセスでは、2 次元 (2D) 変換によって、画像のピクセル座標の点をワールド座標へ数学的にマッピングします。 画像のキャリブレーションが完了すると、位置決めおよび検査ツールは、結果をキャリブレーションされた単位 (実世界値) で報告できるようになります。

In-Sight ビジョンシステムのキャリブレーションには、[X/Y スケール]、[エッジ]、[X/Y エッジ]、[円]、[グリッド]、[インポート] および [9 点] の 7 つがあり、それぞれ精度が異なります。

ジョブでキャリブレーションを実行するには、[キャリブレーションタイプ] ドロップダウンメニューから、キャリブレーションのオプションを選択してください。

  • なし (デフォルト)
  • X/Y スケール
  • エッジ
  • X/Y エッジ
  • 9 点
  • 円
  • グリッド
  • インポート
注 :
  • [X/Y スケール]、[エッジ]、[X/Y エッジ]、[円]、[グリッド]、[インポート] および [9 点] キャリブレーションオプションは、画像内でユーザが指定した、1～16 点を使用し、検査対象物の実世界の計測値に関連付けます。 これらのキャリブレーションオプションは、線形および非線形の歪みのみを補正します。 正確を期すためには、グリッドキャリブレーションオプションを使用してください。
  • これらのキャリブレーションオプションは、線形および非線形の歪みのみを補正します。
  • [X と Y を入れ替える] チェックボックスを ON にすると、スプレッドシートビューの座標 (Y/X) 配置でキャリブレーションの結果を表示することができます。
  • キャリブレーション実行時の、物理的・光学的な設定 (レンズ、ビジョンシステム、およびビジョンシステムと画像を取り込むシーン間の物理的関係) を同一にしてください。 このうちのいずれかが変更された場合、システムを再キャリブレーションする必要があります。 よって、キャリブレーション時とジョブ実行時に、同一のビジョンシステムおよびレンズを使用することに留意してください。 ビジョンシステムおよびレンズも、既存構成の設定およびキャリブレーション設定を保持するようにしてください。 例えば、 (解像度を変更することによって) 画像取り込みフォーマットを変更したり、ビジョンシステムを動かしたりすると、ピクセルをワールド座標にマッピングした 2D 変換計算が無効となってしまいます。

[X/Y スケール]、[エッジ]、[X/Y エッジ] および [円] キャリブレーションタイプ

[9 点] キャリブレーションタイプ

グリッドを使用したキャリブレーション

[インポート] キャリブレーションタイプ


[X/Y スケール]、[エッジ]、[X/Y エッジ] および [円] キャリブレーションタイプ

[X/Y スケール]、[エッジ]、[X/Y エッジ] および [円] キャリブレーションオプションは、検査対象物またはオブジェクトの実際の寸法が分かっている場合に有用なアプリケーションです。

注 : スケールを使用したキャリブレーションは、レンズの歪みを考慮に入れていません。正確を期すためには、検査する表面に対して直角にIn-Sight ビジョンシステムを取り付けるようにする必要があります。そうでない場合は、歪みを取り除き、より正確に画像のキャリブレーションを行うことができるように、グリッドを使用したキャリブレーションを使用してください。
閉じた X/Y スケール

X および Y 値がわかっている場合の、シンプルなキャリブレーション計算に使用します。

注 : このオプションは、歪みを考慮しません。
  1. [キャリブレーションタイプ] ドロップダウンメニューから、[X/Y スケール] を選択します。
  2. [単位] ドロップダウンメニューから実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  3. [水平スケール] パラメータに水平スケール値 (0～9,999,999) を入力します。
  4. [垂直スケール] パラメータに水平スケール値 (0～9,999,999) を入力します。
  5. このオプションが選択されるとすぐにキャリブレーションが実行され、値が設定されます。
閉じた エッジ

2 つのエッジ特徴間の距離が分かっている場合に使用します。

  1. [キャリブレーションタイプ] ドロップダウンメニューから、[エッジ] を選択します。
  2. [エッジの選択] ボタンを押すと、EasyBuilder は画像を検査し、特徴をスマートフィーチャーとして自動的に検出して水色で提示します。
  3. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。

  4. 次に、2 番目のスマートフィーチャーを選択します。

    注 : 目的の特徴が EasyBuilder によって自動的に検出されない場合は、[スマートフィーチャー] チェックボックスを OFF にして、特徴の上に領域を配置してください。
  5. [OK] ボタンを押して、特徴を定義します。
  6. [単位] ドロップダウンメニューから実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  7. [寸法] フィールドに、選択した単位の寸法を入力します。
  8. [キャリブレーション] ボタンを押して、キャリブレーションのプロセスを終了します。位置決めおよび検査ツールの結果が、実単位で表示されるようになります。
閉じた X/Y エッジ

2 つのエッジ特徴間 (1 つは水平方向、もう 1 つは垂直方向) の距離が分かっている場合に使用します。水平方向の測定寸法と垂直方向の測定寸法を結合することにより、2 つの異なるスケールを作成します。

  1. [キャリブレーションタイプ] ドロップダウンメニューから、[X/Y エッジ] を選択します。
  2. [水平距離の定義] ボタンを押すと、EasyBuilder は画像を検査し、特徴をスマートフィーチャーとして自動的に検出して水色で提示します。
  3. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。

  4. 次に、2 番目のスマートフィーチャーを選択します。

    注 : 目的の特徴が EasyBuilder によって自動的に検出されない場合は、[スマートフィーチャー] チェックボックスを OFF にして、特徴の上に領域を配置してください。
  5. [OK] ボタンを押して、特徴を定義します。
  6. [垂直距離の定義] ボタンを押すと、EasyBuilder は画像を検査し、特徴をスマートフィーチャーとして自動的に検出して水色で提示します。
  7. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  8. 次に、2 番目のスマートフィーチャーを選択します。
  9. [OK] ボタンを押して、特徴を定義します。
  10. [単位] ドロップダウンメニューから実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  11. [水平寸法] フィールドに、選択した単位の寸法を入力します。
  12. [垂直寸法] フィールドに、選択した単位の寸法を入力します。
  13. [キャリブレーション] ボタンを押して、キャリブレーションのプロセスを終了します。位置決めおよび検査ツールの結果が、実単位で表示されるようになります。
閉じた 円

特徴の直径が分かっている場合に使用します。

  1. [キャリブレーションタイプ] ドロップダウンメニューから、[円] を選択します。
  2. [円の選択] ボタンを押すと、EasyBuilder は画像を検査し、特徴をスマートフィーチャーとして自動的に検出して水色で提示します。

  3. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。

    注 : 目的の特徴が EasyBuilder によって自動的に検出されない場合は、[スマートフィーチャー] チェックボックスを OFF にして、特徴の上に領域を配置してください。
  4. [OK] ボタンを押して、特徴を定義します。
  5. [単位] ドロップダウンメニューから実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  6. [寸法] フィールドに、選択した単位の寸法を入力します。
  7. [キャリブレーション] ボタンを押して、キャリブレーションのプロセスを終了します。位置決めおよび検査ツールの結果が、実単位で表示されるようになります。


[9 点] キャリブレーションタイプ

[9 点] キャリブレーションオプションは、ロボットアプリケーションにおいて正確な座標空間を作成する場合に有用です。このキャリブレーションオプションは、下のイラストに示されるように円ターゲットを基にしています。グリッドパターンでは、等間隔に並べられた 9 個のターゲットからなるキャリブレーションプレートが理想です。キャリブレーションを実行する前にターゲット間の水平および垂直距離を把握しておく必要があります。

注 :
  • ロボット座標システムでは、9 個のターゲットの中心ターゲットが原点 (0,0) とみなされます。
  • 水平ターゲットの間隔は、一定である必要があります。垂直ターゲットも同様です。しかし、水平および垂直ターゲットの間隔は同一である必要はありません。
  • 各ターゲットの円の直径は、25 ピクセル以上必要です。
閉じた 例 - 単一のターゲット

閉じた 例 - 9 個のターゲット

注 : 座標は実際の画像には表示されていません。イラスト用に挿入されているだけです。
注 : [9 点] キャリブレーションオプションでは、レンズの歪みは考慮されません。正確を期すためには、検査する表面に対して直角に In-Sight ビジョンシステムを取り付けるようにする必要があります。

キャリブレーションを実行する前に、等間隔に並べられた 9 個のターゲットを含むキャリブレーションプレート画像を取り込んでください。

  1. [キャリブレーションタイプ] ドロップダウンメニューから、[9 点] を選択します。

  2. [モデル編集] ボタンを押し、中央のターゲットを囲むように領域を設定してから、[OK] ボタンを押します。ターゲットを囲む領域を設定する際には、円の外側のエッジと領域の間に 3～4 ピクセル以上のスペースを空けるようにしてください。また、領域の中心をターゲットの中心にできるだけ合わせてください。

    閉じた 例

  3. モデル設定後、画像内のすべてのターゲットが検出され、緑の十字マークがターゲット上に表示されます。

    注 : ターゲットのフィデューシャル (十字部分) は検出されたものの、フィデューシャルを囲む円が検出されない場合、赤の十字マークが表示されます。この場合、モデルを再登録するか、新たに画像を取り込んで、問題を解決してください。
  4. [単位] ドロップダウンメニューから実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  5. [X 寸法] フィールドに、同じ行にある 2 つのターゲット間の水平距離 (ターゲットの中心から別ターゲットの中心までの距離) の実寸を入力します。(ターゲットの中心から別ターゲットの中心の距離)
  6. [Y 寸法] フィールドに、同じ列にある 2 つのターゲット間の垂直距離 (ターゲットの中心から別ターゲットの中心までの距離) の実寸を入力します。(ターゲットの中心から別ターゲットの中心の距離)
  7. [キャリブレーション] ボタンを押して、キャリブレーションのプロセスを終了します。位置決めおよび検査ツールの結果が、実単位で表示されるようになります。


グリッドを使用したキャリブレーション

In-Sight ビジョンシステムは、設置環境によって、レンズなど特定の設定条件によって引き起こされた歪みや遠近歪みを含む画像を取り込むことがあります。レンズによっては、樽型歪みまたは糸巻型歪みのパターンが生成される場合があり、これによって、実世界の直線が画像内では曲線に見えてしまうことがあります。遠近歪みは、In-Sight ビジョンシステムを検査領域に対して垂直に取り付けることができない場合に生じます。このような状況では、画像内の特徴が、視野内の位置に応じて引き延ばされたように表示され、不正確な結果となることがあります。

[グリッド] キャリブレーションオプションは、ドットまたは正方形のチェッカボードによるグリッドパターン画像を取り込むことで、画像領域の「マップ」を生成します。この関数は、グリッド内で検出された特徴 (ドットまたは正方形の交点) を、ユーザが指定したグリッドパターンのグリッド間隔に関連付けます。このプロセスによって、非常に正確な計算が可能になり、それを使用して歪んだ特徴を正しい形状に変換することができます。

In-Sight ビジョンシステムをキャリブレーションすることによって、画像の周辺部にある対象物をより正確に検出できます。また、In-Sight ビジョンシステムを検査面に対して最大 45 度の角度で取り付けることができるなど、柔軟な設置が可能になります。

ヒント : [グリッド] キャリブレーションをアプリケーションに使用する必要がある場合、変換画像フィルタツールを使用して、歪みのない結果を表示することができます。また、その出力画像を、他の検査ツールのツール画像として参照することができます。
  1. [キャリブレーションタイプ] ドロップダウンメニューから、[グリッド] を選択します。
  2. [キャリブレーション] ボタンを押して、[CalibrateGrid] ダイアログを開きます。詳細については、『In-Sight® Explorer ヘルプ』ファイルをご参照ください。


[インポート] キャリブレーションタイプ

[インポート] キャリブレーションタイプを使用して、N 点またはシーケンス N 点キャリブレーションツールで作成したキャリブレーションファイルをロードしたり、In-Sight ビジョンシステムのローカルファイルシステムにエクスポートしたりすることができます。インポートされたキャリブレーションファイルは、ロード次第、自動的にジョブをキャリブレーションします。

注 : [キャリブレーションタイプ] から [インポート] を選択する前に、まず N 点またはシーケンス N 点キャリブレーションツールをジョブに追加、設定してください。その後、キャリブレーションファイルを In-Sight ビジョンシステムのローカルファイルシステムにエクスポートしてください。

N 点およびシーケンス N 点キャリブレーションツールは、ピクセル座標系とワールド座標系間で変換を行うための 2D 変換を作成します。このプロセスで、線形および非線形歪みを補正します。また、5 個以上の点を使用した場合、[X/Y スケール]、[エッジ]、[X/Y エッジ] および [円] キャリブレーションメソッドよりも高精度です。このツールは、以下の変換を行います。

  • 2 次元での変換 (5 つ以上の点を使用)。
  • 3 つの軸についての回転 (4 つ以上の点を使用)。
  • 2 次元でのスケール (2 つ以上の点を使用)。
  • 遠近歪み (4 つ以上の点を使用)。
  • 平行四辺形化またはスキュー (4 つ以上の点を使用)。
閉じた インポート
  1. [キャリブレーションタイプ] ドロップダウンメニューから、[インポート] を選択します。
  2. EasyBuilder は、N 点またはシーケンス N 点キャリブレーションツールで生成されたキャリブレーションファイルがジョブに含まれているかどうかを調査し、キャリブレーションファイルをロードします。1 個以上のキャリブレーションファイルを作成した場合、[ファイル名] ドロップダウンメニューから使用するファイルを選択してください。
  3. [単位] ドロップダウンメニューからキャリブレーションを定義する実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  4. このオプションを選択し、値を設定次第、キャリブレーションが実行されます。


位置決め

位置決めツールは、画像中の特徴の定義に使われ、その位置データを提供します。 そして、回転や移動を伴う検査対象物に素早く確実に追従するフィクスチャを作成します。 詳細については、フィクスチャをご参照ください。

注 :
  • 位置データが不要な場合、または常に同じ場所に検査対象物が存在する場合、検査をご参照ください。
  • In-Sight 2000-110 および 120/120C ビジョンセンサでは、ジョブに追加できるフィクスチャは 1 つのみです。
  • [リンク] タブは In-Sight 2000 シリーズビジョンセンサではサポートされていません。

位置決めツールは、次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000-110 および 2000-120/120C ビジョンセンサ | PASS/FAIL ステータスのみ
In-Sight 2000-130/130C ビジョンセンサ | パターン位置決めツール: PASS/FAIL ステータスおよびパターンの得点 その他の位置決めツール: PASS/FAIL ステータスのみ
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 標準の結果 (位置データ、PASS/FAIL ステータス) ツールの結果はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

位置決めツールを追加、削除、編集するには

位置決めツールを選択するには

位置決めツールと検査ツールの間にリンクを作成するには


位置決めツールを追加、削除、編集するには

閉じた ツールを追加する

ジョブにツールを追加するには、[ツールの追加] リストからツールを選択して [追加] ボタンを押すか、またはそのツールをダブルクリックしてください。続いて、EasyBuilder のスマートフィーチャーまたは領域グラフィックスを使用して、位置決め用の特徴を定義します。

特徴の定義後、ツールの機能をチューニングすることができます。ツールの各種パラメータを操作してください。

注 : [ツール] サーチボックスを使用して、ツールを動的にサーチすることができます。
閉じた ツールを削除する

ジョブからツールを削除するには、次のいずれかの方法で行います。

  • パレットの [結果] テーブルでツールを選択し、キーボードの Delete キーを押します。
  • パレットの [結果] テーブルでツールを選択し、標準ツールバーの [削除] アイコンをクリックします。
  • パレットの [結果] テーブルでツールを右クリックし、[削除] を選びます。
閉じた ツールを編集する

EasyBuilder のどのステップからでも、次のいずれかの方法でツールを編集することができます。

  • パレットの [結果] テーブルでツールをダブルクリックします。
  • パレットの [結果] テーブルでツールを右クリックし、[このツールへジャンプして編集] を選択します。

[ジョブの実行] ステップの [結果] テーブルでツールをダブルクリックします。

  • 画像内の領域グラフィックスを選択します。
  • パレットの [結果] テーブルでツールをダブルクリックします。
  • パレットの [結果] テーブルでツールを右クリックし、[このツールへジャンプして編集] を選択します。
  • [ジョブの実行] ステップの [結果] テーブルでツールをダブルクリックします。
注 :
  • In-Sight ビジョンシステムが In-Sight Explorer スプレッドシートプログラミング環境へのアクセスをサポートしている場合、右クリックすると [このツールにジャンプして編集] オプションが表示されます。スプレッドシートプログラミング環境に精通し、その操作方法を熟知している場合のみ、この環境にアクセスすることを推奨します。In-Sight Explorer オンラインヘルプファイルのスプレッドシートの EasyBuilder ジョブの編集トピックをご参照ください。
  • [結果] テーブル内のツールをドラッグ & ドロップすることによって、ツールの順番を変更することができます。この操作は、ジョブの実行 [結果] テーブルおよびパレットの [結果] タブの両方で実行でき、その結果は両方のテーブルに反映されます。ドラッグ & ドロップソーティングは、テーブルの [ツールの順番および依存関係グラフィックス] 行を選択しているときのみ、有効となります。行を再度選択すると、順番は逆になります。リストの順番を変更する機能は、ジョブがジョブサイズ制限に近づくと、無効になります。
注 : ツールを追加するのに十分なスペースがジョブにない場合、[位置決め] または [検査] アプリケーションステップを終了し、[センサ] メニューから [ジョブサイズ制限] を選択します。このダイアログで、ツールが追加できるよう、ジョブサイズを調整することができます。In-Sight ビジョンシステムのジョブサイズを調整するには、ビジョンシステムを再起動する必要があります。その際、すべてのジョブおよび設定ファイルが不揮発性メモリから消去されます。継続する前に、ジョブを保存、バックアップしてください。

特徴とは

領域

フィクスチャ


特徴とは

マシンビジョンでは、特徴は「画像の中の検査対象物」と呼ばれます。ビジョンによる検査は画像中に検出された特徴に対して行われます。

[位置決め] ステップで検出される特徴には次の種類があります。

閉じた エッジ

白ピクセルと黒ピクセルとの遷移が直線状に並んでいる部分を指します。検査対象物の端、電子基板上のピン、ネジの山などがエッジにあたります。エッジ検出は、さまざまなビジョンツールの中でも高速な部類に入ります。フィクスチャとして使用する場合は、一方向 (水平または垂直) のみに移動する、高コントラストな特徴を選択してください。

閉じた エッジフィクスチャの例

この例では、エアフレッシュナーのスプレー容器が画像ごとに違う場所に表示されます。スプレー容器は垂直方向に表示されますが、水平方向に移動します。2 つのエッジ位置決めツールがフィクスチャとして使用されており、左側のフィクスチャは、スプレー容器下部の外側エッジを位置決めし、左側にある検査ツールの領域を追従させます。一方、右側のフィクスチャは、右側のツールを追従させます。

閉じた 円

本質的にはエッジですが、特に白ピクセルと黒ピクセルとの遷移が円形状に並んでいる部分を指します。 高コントラストな円であれば比較的速く検出されます。フィクスチャとして使用する場合は、円の角度データが提供されないことにご注意ください。

閉じた 円フィクスチャの例

この例では、2 つのフィクスチャが使用されています。1 番目のフィクスチャであるブロブ位置決めツールは、パイプ外側を位置決めし、2 番目のフィクスチャである円位置決めツールは、パイプの基本的な形状である円を、検出されたブロブ内で位置決めします。アプリケーションの設定に従い、検出された形状の基準点から距離を計算してネジの長さを決定しますが、その長さは均一である必要があります。

閉じた パターン

パターンには、反復模様のようなシンプルなものからロゴやラベルといった複雑なものまでさまざまな形状が含まれます。フィクスチャとして使用する場合、パターンは非常に高い信頼性を発揮します。回転、移動、スケール変化にも対応することができますが、一般的に検査時間は長めです。

閉じた パターンフィクスチャの例

この例では、2D コードが画像内のさまざまな位置および向きに表示されます。PatMax パターン位置決めツールがフィクスチャを作成するのに使用され、ID コードの読み取り識別ツールのサーチを追従させます。このように PatMax パターン位置決めツールは、さまざまな位置、向きおよびスケールに対応しながら、複雑なパターンを位置決めすることができます。

閉じた ブロブ

黒い背景上の白いしみや、白いベルトコンベヤ上の黒いネジなど、黒色または白色のピクセルの塊をブロブと呼びます。ブロブの検査時間はエッジツールとパターンツールの中間に位置し、パターンツールと比較した場合、特徴の形状やサイズの変化が大きくても検出することができる特徴があります。フィクスチャとして使用する場合は、一般に角度の値を制限して使用します。

閉じた ブロブフィクスチャの例

この例では、検査特徴 (ネジ) が対象物 (パイプ) 内にあり、その方向や垂直および水平位置が画像によって異なるため、2 つのフィクスチャが使用されています。パイプのフランジが不規則な形を作るため、視野内のパイプを位置決めするフィクスチャとして、ブロブ位置決めツールが使用されています。


領域

領域は、位置決めおよび検査ツールが検査を行う画像領域を定義します。領域は、検査対象領域 (ROI) とも呼ばれます。

EasyBuilder では、使用するツールによって、異なるタイプの領域が使用されます。領域の種類は、次の通りです。

  • 矩形
  • 円
  • 円環
  • ポリゴン

円環領域

円領域

ポリゴン領域

矩形領域


円環領域

円環領域は円形エッジ特徴の定義に使用されます。円環領域には、内半径および外半径があるため、円の中心を無視して、円形エッジ特徴を定義することが可能です。

閉じた 円環領域マウス動作

 | コントロール | 説明
1 | 移動 | 内半径および外半径の間にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、画像の内部の任意の場所にこの領域をドラッグできるようになります。
2 | サイズ変更 | 円環領域の内半径または外半径の上にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、この領域をドラッグして、サイズを変更できるようになります (内半径および外半径は、それぞれ別にサイズ変更する必要があります)。
閉じた 円環領域スキャン方向

円環領域のスキャン方向 - 円特徴の内側から外側へ

閉じた 円環領域カラーコード

 | 説明
1 | 新しく追加された、未選択の領域
2 | 選択されているが、設定されていない領域
3 | 選択、設定されている PASS 領域
4 | 選択されていないが、設定は行われている PASS 領域
5 | 選択、設定されている FAIL 領域
6 | 選択されていないが、設定は行われている FAIL 領域


円領域

円領域は円特徴の定義に使用されます。円領域は、円内のすべてのものをキャプチャします。円の中心を無視して円特徴を定義するには、円環領域を使用します。

閉じた 円領域マウス動作

 | コントロール | 説明
1 | 移動 | 領域内にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、画像の内部の任意の場所にこの領域をドラッグできるようになります。
2 | サイズ変更 | 円領域の境界にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、この領域をドラッグして、サイズを変更できるようになります。
閉じた 円領域スキャン方向

円領域のスキャン方向： 円特徴の内側から外側へ

閉じた 円領域カラーコード

 | 説明
1 | 新しく追加された、未選択の領域
2 | 選択されているが、設定されていない領域
3 | 選択、設定されている PASS 領域
4 | 選択されていないが、設定は行われている PASS 領域
5 | 選択、設定されている FAIL 領域
6 | 選択されていないが、設定は行われている FAIL 領域


ポリゴン領域

ポリゴン領域を使用して、ラインセグメントから作成された不規則な特徴を定義します。使用用途にあわせて、必要な形状に設定してください。

閉じた ポリゴン領域の凡例

 | コントロール | 説明
1 | サイズ変更可能な端点マーク | ポリゴン領域の三隅を定義します (1 つのポリゴン領域では、最大 100 までの点を作成することができます)。端点をクリックして、三隅の 1 つから領域のサイズを変更することができます。
2 | 回転ハンドル | 領域を 360°回転させることができます。
閉じた ポリゴン領域マウス動作

領域内のさまざまな場所にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、以下の動作を行うことができます。

マウスアイコン | 説明
 | 画像の内部の任意の場所にポリゴン領域全体をドラッグできます。
 | 領域全体を水平または垂直に拡大縮小することができます。
 | 領域を現在の向きから 360 度回転させることができます。
 | ポリゴン領域のサイズ変更可能な端点マークの 1 つを移動させることができます。
 | ポリゴン領域にサイズ変更可能な端点マークを追加することができます。
閉じた ポリゴン領域スキャン方向

 | コントロール | 説明
1 | トップ | 水平方向にスキャンされることを示します。
2 | サイド | 垂直方向にスキャンされることを示します。
閉じた ポリゴン領域カラーコード

 | 説明
1 | 新しく追加された、未選択の領域
2 | 選択されているが、設定されていない領域
3 | 選択、設定されている PASS 領域
4 | 選択されていないが、設定は行われている PASS 領域
5 | 選択、設定されている FAIL 領域
6 | 選択されていないが、設定は行われている FAIL 領域


矩形領域

矩形領域は、検査の定義に最もよく使用される領域です。使用するアプリケーションのニーズに合わせて、矩形領域のサイズを変更し、円弧または円環領域にすることができます。

閉じた 矩形領域の凡例

 | コントロール | 説明
1 | サイズ変更用端点マーク (× 4) | 矩形領域の四隅を定義します。端点の 1 つをクリックして、四隅の 1 つから領域のサイズを変更することができます。
2 | スキャン方向インジケータ (× 2) | 矩形領域で特徴がスキャンされる方向を定義します。
3 | カーブ用ハンドル | 矩形領域を円弧または円形に曲げることができます。
4 | 回転用ハンドル | 領域を 360 度回転させることができます。
閉じた 矩形領域のマウス動作

 | コントロール | 説明
1 | 移動 | 領域の内側にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、画像の内部の任意の場所にこの領域をドラッグできるようになります。
2 | 曲げ | 曲げハンドル上にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、矩形領域を扇形に変形できるようになります。 例えば、その後で、形状の四辺を円形に変更できます。
3 | サイズ変更 | 4 つの端点マークのいずれか、または四辺のいずれか沿いにマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、この領域をドラッグしてサイズを変更できるようになります。
4 | 回転 | 回転ハンドル上にマウスカーソルを置くことにより、マウスカーソルアイコンが自動的に変わり、領域を現在の向きから 360 度回転させることができます。
閉じた 矩形領域のスキャン方向

 | コントロール | 説明
1 | トップ | 水平方向にスキャンされることを示します。
2 | サイド | 垂直方向にスキャンされることを示します。
閉じた 矩形領域カラーコード

 | 説明
1 | 新しく追加された、未選択の領域
2 | 選択されているが、設定されていない領域
3 | 選択、設定されている PASS 領域
4 | 選択されていないが、設定は行われている PASS 領域
5 | 選択、設定されている FAIL 領域
6 | 選択されていないが、設定は行われている FAIL 領域


フィクスチャ

[位置決め] ステップの位置決めツールはフィクスチャを作成します。フィクスチャは、他のビジョンツールの基準点として機能します。

フィクスチャを作成する際には、検査対象物をよく観察して、どの特徴タイプを使用するかを検討します。パターン、エッジ、サークル、ブロブのどれを使うのが効果的か、また、その特徴がすべての画像に存在するかを考慮してください。そして、その特徴に適した位置決めツールを選択します。

特徴をフィクスチャとして使用するため、In-Sight センサは特徴検出を行います。検出に成功すると、その検出位置が他のビジョンツールの基準点として使われ、ツールの検査領域が決まります。

閉じた 例 - パターンフィクスチャを使用したジョブ

閉じた 例 - パターンフィクスチャを使用しないジョブ

注 :
  • すべての画像で常に同じ場所に検査対象物が存在している場合、位置決めをする必要はありません。
  • 1 つのジョブに複数のフィクスチャを作成することができます。また、それらのフィクスチャを連結することも可能です。
  • 他のツールによって使用することができる、フィクスチャを生成するのは、次の検査ツールです。エッジ有無判定ツール、PatMax パターン有無判定ツール、パターン有無判定ツール 、ID の読み取り識別ツール、PatMax パターン (1-10) 識別ツール 、パターン (1-10) 識別ツール、角度結果寸法測定ツール、距離寸法測定ツール、円の同心度寸法測定ツール、円の直径寸法測定ツール、2 点間の中点幾何・計測ツール、N 点を通る近似円幾何・計測ツール。


位置決めツールを選択するには

検査目的や仕様に対してどのタイプの特徴が向いているか、検査対象物をよく観察して検討します。

位置決めツール | In-Sight ビジョンシステム (5.x.x ファームウェア) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
PatMax RedLine パターン 1 | X |  |  |  |  |
PatMax® パターン | X |  |  |  |  |
パターン | X | X | X | X | X | X
PatMax RedLine™ パターン (1-10) 1 | X |  |  |  |  |
PatMax® パターン (1-10) | X |  |  |  |  |
パターン (1-10) | X |  |  |  | X |
エッジ | X |  |  | X | X | X
エッジ交点 | X |  |  | X | X | X
ブロブ 2 | X |  |  |  | X |
ブロブ (1-10) 2 | X |  |  |  | X |
カラーブロブ 3 | X |  |  |  | X |
カラーブロブ (1-10) 3 | X |  |  |  | X |
円 | X |  |  | X | X | X
フィクスチャ計算 | X |  |  |  |  | X
1 In-Sight 5.x.x ファームウェアのみ。 2モノクロモデルのみ。 3カラーモデルのみ。

PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10)

パターンおよびパターン (1-10)

エッジ

エッジ交点

ブロブおよびブロブ (1-10)

カラーブロブおよびカラーブロブ (1-10)

円

フィクスチャ計算


PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツール

注 :
  • In-Sight ファームウェア 5.5.0 以降、ツールのアルゴリズムが変更され、条件によっては、より正確な結果を返すようになり、実行時間が短縮されました。
  • この変更により、In-Sight ファームウェア 5.5.0 以降で作成されたこのツールを含むジョブを、ファームウェアバージョン 5.4.x 以前を搭載した In-Sight ビジョンシステムにロードしようとすると、エラーメッセージが表示されます。
  • PatMax RedLine パターンおよび PatMax RedLine パターン (1-10) 位置決めツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) は、登録済みのパターン表現 (モデルと呼ばれます) を基に、PatMax RedLine または PatMax アルゴリズムを使用して、パターンを位置決めします。 PatMax RedLine パターンおよび PatMax パターンツールは単一のパターンの位置決めに使用され、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) ツールは、最大 10 パターンまでの位置決めに使用されます。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

これらのツールは、正確な位置決めが必要とされるロボットガイダンスなどのアプリケーションに有用です。 また、このツールは他のビジョンツールに対してサーチベースのフィクスチャを提供するのに特に有用です。

ツールを設定するには

ツールのパラメータを調整するには


PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

  1. [モデル] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [サーチ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。

  3. [OK] ボタンを押し、2 つの領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。

  4. ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。

パターンを選択するには

PatMax RedLine パターン、PatMax パターンおよびパターン


パターン特徴を選択するには

パターンを選択する際には、次のガイドラインを参考にしてください。

  • そのパターンがすべての画像に存在していること。
  • ユニーク性の高い特徴や一貫性の高い特徴をできるだけ多くそのパターンに含めること。また、検査対象物全体の形状に対してそのパターンが常に一定の位置に、かつ明確に存在すること。
  • できるだけ大きなパターンを選択すること。大きなパターンはユニークな特徴を多く含むため、それだけ一貫した正確な検査を行うことができます。


PatMax RedLine パターン、PatMax パターンおよびパターン

注 : PatMax RedLine パターンおよび PatMax RedLine パターン (1-10) 位置決めツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターン、PatMax パターンおよびパターンツールは、どちらも登録済みのモデルパターンを検出する、最も高精度な検査ツールです。中でも PatMax RedLine パターンおよび PatMax パターンツールは、照明の条件やパターンのポジションが大幅に変わっても特徴を検出できるため、より強力な検査ツールと言えます。PatMax RedLine パターンおよび PatMax パターンツールは、スケール変化、回転、部分的な遮蔽、照明のばらつきによる外観変化に対しても、より優れた認識能力を発揮します。

PatMax RedLine パターンと PatMax パターンの主な違いはそのスピードにあります。PatMax RedLine パターンは最新のパターンマッチアルゴリズムを使用し、5 メガピクセルの画像内の登録した特徴を PatMax パターンの最大 7 倍の速さで検出します。よって、PatMax RedLine パターンは高解像度のビジョンシステムに最適と言えます。

通常、パターンツールは PatMax パターンツールより高速に動作します。しかし、次のような状況では PatMax RedLine または PatMax パターンツールの正確性および信頼性が必要とされる場合があります。

  • 照明のばらつきや反射の抑制が困難な場合 (例: 光を乱反射しやすい金属物を検査する場合)。
  • 検査対象物に似た形状やシェーディングが背景上にある場合、またはパターンが重なっていたり、他の物体によって部分的に隠蔽されていたりする場合。
  • 他の類似したパターンを除外し、目的の検査パターンを正確に検出したい場合。
  • 設置環境の状態によって、パターンツールでは一貫した信頼性のある検査を実行できない場合。


PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツールの設定ペインには次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [モデル] および [サーチ] タブ
  • [登録画像] タブ
  • テーブル
注 : [テーブル] タブは、PatMax パターン (1-10) 位置決めツールにのみ表示されます。
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[モデル] および [サーチ] タブ

[登録画像] タブ

テーブル


[全般] タブ (PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツール)

閉じた 検出する数

検出するモデルパターンのインスタンスの数 (1～10) を定義します。デフォルトは 1 です。ほとんどのアプリケーションは 1 つのフィクスチャで十分ですが、複数のインスタンス (実体) を位置決めすることもできます。識別する登録インスタンスの数が多いほど、実行時間は増大します。

閉じた アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

閉じた コントラストしきい値

検出パターンに存在する必要のある、最小コントラスト値を指定します。有効なインスタンスとみなすには、検出パターンのコントラストが [コントラストしきい値] より高い必要があります。PatMax RedLine パターンではデフォルト = 0、有効なパラメータ範囲は 0～100 です。PatMax パターンではデフォルト = 10、有効なパラメータ範囲は 0～255 です。低コントラストの画像には、低いコントラストしきい値が使用され、高コントラストの画像には、高いコントラストしきい値が使用されます。

注 : PatMax RedLine パターンでは、登録パターン内の特徴とサーチ画像内のマッチする特徴との間のコントラスト差をパーセンテージで表した、「相対」コントラストが報告されます。よって、特徴のコントラストがパターンコントラストと同じまたはより高い場合、報告されるコントラストは ~100 となります。特徴のコントラストがパターンコントラストより低い場合、報告されるコントラストは <100 となります。PatMax RedLine パターンのコントラストは PatMax パターンのコントラストは異なります。PatMax パターンでは、サーチ ROI 内の「絶対」画像コントラストがグレースケール値で報告されます。
閉じた 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。大きな値を設定すると、ツールの実行時間が増大します。

閉じた スケール許容

モデルパターンの大きさを基準とした、検出パターンで許容されるスケール変化量を指定します (0～50、デフォルトは 0% です)。この値を 5 に設定すると、モデルの大きさに対して 95～105% のサイズのパターンが検出対象となります。大きな値を設定すると、ツールの実行時間が増大します。

閉じた 検出モード

パターンの登録および認識に使用されるサーチモードを指定します。選択肢は、[PatMax] (デフォルト) または [PatQuick] です。デフォルトでは、[PatMax] が選択されています。PatMax は、PatQuick より高精度ですが、実行時間が長くなります。一方、PatQuick は、PatMax より精度が低いですが、実行時間は短くなります。

閉じた クラッタ

モデルパターンと比較して、検出パターンの欠落または遮蔽された特徴を得点に考慮するかどうかを定義します。デフォルトは OFF、すなわち欠落があっても得点は減点されません。クラッタを ON にすると、検出パターン中の特徴欠落によって得点が減点されます。

閉じた 極性を無視

モデルパターンに対し、カラー変換したマッチ特徴を検出パターンに含むかどうか指定します (デフォルト = OFF)。[極性を無視] を ON にすると、例えば、モデルパターン内の黒/白 vs. 白/黒など、カラー変換した特徴を含む検出パターンが、モデルパターンにマッチしていると分類されます。

閉じた ソート

検出パターンのソート方法を定義します。選択肢は、[得点] (デフォルト) 、[X]、[Y] です。[得点] を選択した場合、検出パターンは得点を基に、最高得点のパターンから降順でソートされます。[X] を選択した場合、検出パターンは X 軸からの距離を基に、近いものから遠いパターンの降順でソートされます。[Y] を選択した場合、検出パターンは Y 軸からの距離を基に、近いものから遠いパターンの降順でソートされます。

閉じた 水平オフセット

検出パターンの中心座標を基準にした水平方向のオフセットをピクセル単位で指定します。検出パターンの中心から離れた場所を割り当てることができるため、ロボットガイダンスのピックポイントを定義するのに有効です。

閉じた 垂直オフセット

検出パターンの中心座標を基準にした垂直方向のオフセットをピクセル単位で指定します。検出パターンの中心から離れた場所を割り当てることができるため、ロボットガイダンスのピックポイントを定義するのに有効です。

閉じた タイムアウト
ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。デフォルトで、このパラメータは 5,000 に設定されています。
閉じた 結果

検出パターンの中心座標、角度、得点 (モデルパターンとの類似度) が表示されます。[水平オフセット]/[垂直オフセット] の値が指定されている場合、その分だけ座標が調整されます。

注 : [検出する数] パラメータを 2 以上に設定していても、[ソート] パラメータを [X] または [Y] に設定した場合以外は、[結果] フィールドには、最高得点の結果だけが表示されます。
注 :
  • PatMax RedLine パターンおよび PatMax RedLine パターン (1-10) 位置決めツールには、[検出モード] パラメータは含まれていません。
  • 検出する数およびソートパラメータは、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) でのみサポートされています。


[モデル] および [サーチ] タブ (PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツール)

[モデル] および [サーチ] タブを使用して、ツールのモデルおよびサーチ領域の合成領域を設定します。 合成領域は、サブ領域 (矩形、円環、円またはポリゴン) の集合体で、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • [モデル] タブでは、[モデル領域] ボタンを押した後にのみ、合成領域を有効にすることができます。
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


[登録画像] タブ (PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツール)

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


テーブル (PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツール)

検出されたパターンの結果を表示します。

閉じた インデックス

検出されたパターンの順番を表示します。EasyBuilder では 0 から数えます。

閉じた X

検出パターンの中心の X 座標を表示します。[水平オフセット] の値を指定した場合、その分だけ座標が調整されます。

閉じた Y

検出パターンの中心の Y 座標を表示します。[垂直オフセット] の値を指定した場合、その分だけ座標が調整されます。

閉じた 角度

モデルパターンを基準にした、検出パターンの角度を表示します。

閉じた 得点

検出パターンとモデルパターンとの類似度を表示します。

閉じた スケール

検出パターンのスケールを表示します。


パターン/パターン (1-10) 位置決めツール

パターン位置決めツールおよびパターン (1-10) 位置決めツールは、登録済みのパターン表現 (モデルと呼ばれます) を基に、パターンを位置決めします。 パターンツールは単一のパターンの位置決めに使用され、パターン (1-10) ツールは、最大 10 パターンまでの位置決めに使用されます。

パターン位置決めツールおよびパターン (1-10) 位置決めツールは、正確な位置決めが必要とされるロボットガイダンスなどのアプリケーションに有用です。 また、このツールは他のビジョンツールに対してサーチベースのフィクスチャを提供するのに特に有用です。

ヒント :
  • 位置決めパターンの特徴を選択する際の詳細については、パターン特徴を選択するにはをご参照ください。
  • 位置決めパターンツールについての詳細は、PatMax RedLine パターン、PatMax パターンおよびパターン

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000-110 および 2000-120/120C ビジョンセンサ | PASS/FAIL ステータスのみ
In-Sight 2000-130/130C ビジョンセンサ | PASS/FAIL ステータスおよびパターンの得点
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | XY 座標*、角度、得点、PASS/FAIL ステータス
*結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


パターン/パターン (1-10) 位置決めツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

  1. 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。

  2. パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。

    注 : モデルおよびサーチ領域は、円弧またはドーナツ状に曲げることはできません。

  3. [OK] ボタンを押し、2 つの領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。

  4. 領域の設定を確定すると、モデル領域の代わりに検出パターンの位置および角度方向を示すアイコン [image] が表示されます。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


パターン位置決め/パターン位置決め (1-10) ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

In-Sight 2000 シリーズビジョンセンサ

パターンツール

  • [ツールの編集] グループボックス

パターン (1-10) ツール

  • [全般] タブ
  • [設定] タブ
  • [登録画像] タブ
  • テーブル

In-Sight ビジョンシステム

パターンおよびパターン (1-10) 位置決めツール設定ペインには、次のタブが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [登録画像] タブ
  • テーブル
注 : テーブルは、パターン (1-10) 位置決めツールにのみ表示されます。
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

In-Sight 2000 シリーズビジョンセンサ

In-Sight ビジョンシステム

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder ヘルプ | 08/29/2022 | Revision: 5.9.0.2


パターン位置決めツールのパラメータを調整するには

注 :
  • このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。 In-Sight ビジョンシステムに接続している場合、パターン位置決め/パターン位置決め (1-10) ツールのパラメータを調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。
  • このツールを In-Sight ファームウェア 5.7.0 以降で設定した場合、ファームウェアバージョン 5.6.x 以前を搭載した In-Sight ビジョンシステムにジョブをロードしようとすると、エラーメッセージが表示され、ジョブロードに失敗します。

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

閉じた PASS/FAIL インジケータ

緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。

閉じた 回転許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 45 度です。大きな値を設定すると、ツールの実行時間が増大します。左ハンドルはマイナスの回転許容値を、右ハンドルはプラスの回転許容値を設定します。ハンドルを調整したり、対応する編集ボックスに値を入力したりして、回転許容値を調整することができます。

ヒント : 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。
閉じた パーツ検出メータ

パーツ検出メータは、ツールがいかによく特徴を検出したかを表示し、最小アクセプトしきい値を設定します。最小アクセプトしきい値は、手動で設定することができます。ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を調整してください。

ヒント : 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

メータの示す値がしきい値より高い場合、パーツは検出されたとみなされ、メータは緑で表示されます。しきい値より低い場合、パーツは検出されなかったとみなされ、メータは表示されなくなります。パーツ以外の物を検出したり、間違った特徴を検出したりしている場合、ハンドルを右に動かしてください。パーツ検出に失敗している場合、ハンドルを左に動かしてください (または、モデル領域を新規作成してください)。設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

PASS
FAIL
注 : スライダコントロール上にマウスポインタを重ねると、[結果] および [しきい値] が表示されます。
閉じた ±10% スケール許容

検出パターンとモデルパターン間の ±10% のスケール変化を許容するかどうかを指定します。

登録パターン | 検出パターン: +10% | 検出パターン: -10%
OFF (デフォルト) | (FAIL) | (FAIL)
ON | (PASS) | (PASS)
閉じた 手動タイムアウトを使用する

タイムアウト設定を使用するかどうかを指定します。

  • OFF (デフォルト): タイムアウト設定は無効です (タイムアウトしません)。

  • ON: タイムアウト設定を有効にします。 編集ボックスを使用して、手動でタイムアウト値をミリ秒単位で指定します。(0 ～ 30000)

    注 : 値を 0 に設定すると設定が無効になり、タイムアウトは適用されません。
閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 名前

検査ツールの名前を定義します。 デフォルト名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
閉じた フィクスチャ

ツールに使用するフィクスチャを選択します。フィクスチャコントロールが有効な場合、[フィクスチャ] ボタンはオレンジ色になります。

注 : このコントロールは、フィクスチャを定義するツールがすでに追加されている場合のみ、有効になります。
閉じた 登録の入力

モデルパターンを入力ラインを介して登録するかどうかを定義します。デフォルトは OFF で、無効です。

  • 入力: モデルパターンを入力ラインを介して登録します。 選択した入力ラインは、登録シグナルとして使用されます。

    注 :
    • このオプションは、In-Sight ビジョンシステムにディスクリート入力がない場合 (例えば、直接接続 I/O を使用している In-Sight 8000 シリーズビジョンシステムなど) 、表示されません。
    • 入力/出力ステップで、 選択した入力ラインの [信号タイプ] を [イベントトリガ] に設定してください。
    • モデルパターンの登録には、ビジョンシステム/センサが取り込んだ最新の画像が使用されます。 登録するために、ビジョンシステム/センサを再度トリガする必要はありません。
    • 詳細については、 入力: 入力ラインを介してモデルパターンを登録するにはをご参照ください。
閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

閉じた モデル領域

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


[全般] タブ (パターン/パターン (1-10) 位置決めツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([画像の設定]、[入力/出力] および [通信]) で参照されます。デフォルトのツール名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (パターン/パターン (1-10) 位置決めツール)

閉じた 登録の入力

モデルパターンを入力ラインを介して登録するかどうかを定義します。デフォルトは OFF で、無効です。

  • 入力: モデルパターンを入力ラインを介して登録します。 選択した入力ラインは、登録シグナルとして使用されます。

    注 :
    • このオプションは、In-Sight ビジョンシステムにディスクリート入力がない場合 (例えば、直接接続 I/O を使用している In-Sight 8000 シリーズビジョンシステムなど) 、表示されません。
    • 入力/出力ステップで、 選択した入力ラインの [信号タイプ] を [イベントトリガ] に設定してください。
    • モデルパターンの登録には、ビジョンシステム/センサが取り込んだ最新の画像が使用されます。 登録するために、ビジョンシステム/センサを再度トリガする必要はありません。
    • 詳細については、 入力: 入力ラインを介してモデルパターンを登録するにはをご参照ください。
閉じた 検出する数

検出するモデルパターンのインスタンスの数 (1～10) を定義します。デフォルトは 1 です。 ほとんどのアプリケーションは 1 つのフィクスチャで十分ですが、複数のインスタンス (実体) を位置決めすることもできます。 識別する登録インスタンスの数が多いほど、実行時間は増大します。

閉じた アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。 この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。 この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。 設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

閉じた 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。 大きな値を設定すると、ツールの実行時間が増大します。

閉じた スケール許容

モデルパターンの大きさを基準とした、検出パターンのスケール変化 (±10% 以内) を許容するかどうかを指定します。 デフォルトは OFF です。大きな値を設定すると、ツールの実行時間が増大します。 スケール許容を ON にすると、±10% の範囲でパターンを検出しますが、スケール変化量が大きくなるほど、特徴の得点は低くなります。

閉じた ソート

検出パターンのソート方法を定義します。選択肢は、[得点] (デフォルト)、[X]、[Y] です。 [得点] を選択した場合、検出パターンは得点を基に、最高得点のパターンから降順でソートされます。 [X] を選択した場合、検出パターンは X 軸からの距離を基に、近いものから遠いパターンの降順でソートされます。 [Y] を選択した場合、検出パターンは Y 軸からの距離を基に、近いものから遠いパターンの降順でソートされます。

閉じた 水平オフセット

検出パターンの中心座標を基準にした水平方向のオフセットをピクセル単位で指定します。 検出パターンの中心から離れた場所を割り当てることができるため、ロボットガイダンスのピックポイントを定義するのに有効です。

閉じた 垂直オフセット

検出パターンの中心座標を基準にした垂直方向のオフセットをピクセル単位で指定します。 検出パターンの中心から離れた場所を割り当てることができるため、ロボットガイダンスのピックポイントを定義するのに有効です。

閉じた モデルタイプ

ツールが、どのようにモデルパターンを作成するかを定義します。選択肢は、[エリアモデル] または [エッジモデル] です。[エリアモデル] は、モデル領域からのグレースケース値の均一サンプリングに基づいてパターンを作成します。[エッジモデル] は、モデル領域内のパターンの検出エッジ (白/黒の遷移) に基づいて、モデルパターンを作成します。

閉じた 高精度モード

ツールがどのように精度/信頼性と実行速度のトレードオフを評価するか定義します。選択肢は、[高精度]、[中程度] (デフォルト) および [高速] です。[高精度] は、精度/信頼性が高くなる反面、実行速度が遅くなります。[高速] は、実行速度が速くなる反面、精度/信頼性が低くなります。[中程度] は、その中間を取るように指定します。

閉じた タイムアウト

ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

閉じた 結果

検出パターンの中心座標、角度、得点 (モデルパターンとの類似度) が表示されます。 [水平オフセット]/[垂直オフセット] の値が指定されている場合、その分だけ座標が調整されます。

注 : [検出する数] パラメータを 2 以上に設定していても、[ソート] パラメータを [X] または [Y] に設定した場合以外は、[結果] フィールドには、最高得点の結果だけが表示されます。
注 : パターン位置決めツールには、[検出する数] および [ソート] パラメータは含まれていません。


[テーブル] タブ (パターン位置決めツール)

検出されたパターンの結果を表示します。

閉じた インデックス

検出されたパターンの順番を表示します。EasyBuilder では 0 から数えます。

閉じた X

検出パターンの中心の X 座標を表示します。[水平オフセット] の値を指定した場合、その分だけ座標が調整されます。

閉じた Y

検出パターンの中心の Y 座標を表示します。[垂直オフセット] の値を指定した場合、その分だけ座標が調整されます。

閉じた 角度

モデルパターンを基準にした、検出パターンの角度を表示します。

閉じた 得点

検出パターンとモデルパターンとの類似度を表示します。

閉じた スケール

検出パターンのスケールを表示します。


[登録画像] タブ (パターン/パターン (1-10) 位置決めツール)

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


エッジ位置決めツール

エッジ位置決めツールは、指定したパラメータに合致する直線エッジ特徴を位置決めします。

エッジ位置決めツールは、高速なツールの 1 つです。パターン位置決めツールよりも短時間で特徴を検出することができます。 高コントラストのエッジがあり、対象物が一方向のみ移動し、かつ、回転が 10 度以内である場合は、他のビジョンツールのフィクスチャとして有効に機能します。

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズ 1XX ビジョンセンサ (110、120、130) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 検出エッジの中点の XY 座標*、角度、PASS/FAIL ステータス
*結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


エッジ位置決めツールを設定するには

ツールを追加したら、フィクスチャとして使用する特徴を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. 特徴の 1 つをクリックすると、紫色に変わります。

  3. [OK] ボタンを押して、エッジを確定してください。(ツールをジョブに追加しない場合は [キャンセル] ボタンを押します)。選択したエッジを囲むエッジ領域が作成され、検出されたエッジの位置とその向きを示す [image] アイコンが表示されます。

    注 : 必要に応じて、検出エッジ周囲の領域を回転したり、サイズ変更したりしてください。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジ位置決めツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジ位置決めツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • グラフ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

グラフ


[全般] タブ (エッジ位置決めツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はエッジ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (エッジ位置決めツール)

閉じた エッジのコントラスト

エッジが検出されたとみなすための最小コントラスト得点 (1～100) を指定します。初期値はスマートセッティングによって自動的に決定されます。 このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注 : パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
閉じた スコアの正規化

エッジスコアを領域のグレースケールヒストグラムで正規化するかどうかを指定します。このパラメータは、低コントラスト領域でエッジを見つける場合に有用です。検出対象のエッジが高コントラストだけの場合は、このパラメータを無効にします。

  • ON (デフォルト): スコアを正規化します。
  • OFF: スコアを正規化しません。
閉じた エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 検出する基準

複数のエッジが存在する場合に、目的とする 1 つのエッジに絞り込む方法を定義します。デフォルトは [得点の高い順] です。

  • 得点の高い順: 最も明確なエッジ (コントラストが最も高いもの) が選択されます。
  • 最初のエッジ: 領域のスキャン開始点に最も近いエッジが選択されます。
  • 最後のエッジ: 領域のスキャン開始点から最も遠いエッジが選択されます。
閉じた 角度範囲

検出されたエッジが取り得る、角度の最大値 (0～10 度) を定義します。デフォルトは 10 度です。 角度の許容範囲を広げると、ツールの実行時間が増大します。

閉じた 結果

検出されたエッジの中心座標および角度方向を返します。


グラフ (エッジ位置決めツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


エッジ交点位置決めツール

エッジ交点位置決めツールは、2 つのエッジ特徴の交点を指定します。

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズ 1XX ビジョンセンサ (110、120、130) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 交点の XY 座標*、2 つのエッジ間の 2 等分角度、PASS/FAIL ステータス
*結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


エッジ交点位置決めツールを使用するには

ツールを追加したら、交差するエッジ特徴を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 次に、交差するエッジ特徴を選択してください。
  4. EasyBuilder は自動的に直線の交点を決定し、検出された交点の位置および方向を示す [image] アイコンを挿入します。同時に、エッジ有無判定ツールを挿入し、未設定のエッジ特徴を設定します。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジ交点位置決めツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

エッジ交点位置決めツールの設定ペインには、次のコントロールが表示されます。

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]および[通信]) で参照されます。デフォルトのツール名は交点_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


ブロブ/ブロブ (1-10) 位置決めツール

ブロブ位置決めツールおよびブロブ (1-10) 位置決めツールは、指定したパラメータに合致しているブロブを位置決めします。 ツールは、検出したブロブの重心座標や角度を返します。 ブロブツールが 1 個のブロブの位置決めに使用されるのに対し、ブロブ (1-10) 位置決めツールは最大 10 個までのブロブの位置決めに使用されます。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ブロブ/ブロブ (1-10) 位置決めツールの性能は、エッジ位置決めツールとパターン位置決めツールの中間に位置します。一般に、ブロブ位置決めツールはパターン位置決めツールより高速ですが、エッジ位置決めツールより時間がかかります。 このツールは、一定の形状を持たない対象物 (例: 白い背景上の黒いしみ、パターンツールの許容範囲を超えて形状変化するもの、など) を他のビジョンツールのフィクスチャとして利用するのに有効です。

ツールを設定するには

ツールのパラメータを調整するには


ブロブ/ブロブ (1-10) 位置決めツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 ブロブをフィクスチャとして使用する場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. 領域の設定を確定すると、検出されたブロブの重心点とその向きを示す [image] アイコンが表示されます。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ブロブ/ブロブ (1-10) 位置決めツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ブロブ/ブロブ (1-10) 位置決めツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • テーブル
  • [ヒストグラム] タブ
  • [合成領域] タブ
注 : [テーブル] タブは、ブロブ (1-10) 位置決めツールにのみ表示されます。
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

テーブル

[合成領域] タブ

ヒストグラム


[全般] タブ (ブロブ/ブロブ (1-10) 位置決めツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (ブロブ/ブロブ (1-10) 位置決めツール)

閉じた しきい値モード

ブロブと背景を切り分けるためのグレー値を決める方法を指定します。[自動] を選択した場合、画像取り込みのたびに自動的にしきい値が計算されます。[手動] を選択した場合、値を手動で入力、調整してください。

閉じた ブロブしきい値

ブロブと背景を切り分けるグレー値 (0～255) を定義します。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。ヒストグラムを参考にして、最適な値を設定してください。

閉じた ブロブの色

ブロブの色を定義します。選択肢は [黒]、[白]、[任意] (デフォルト) です。

  • 任意: 黒白両方のブロブを返します。
  • 黒: ブロブしきい値より低いグレー値で構成されたブロブを返します。
  • 白: ブロブしきい値より高いグレー値で構成されたブロブを返します。
閉じた 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。つまり、その他の条件を満たしていれば、領域の境界に接しているブロブを検出します。
閉じた 最小面積

ブロブ検出時の、最小面積をピクセルで定義します (0～16777216。デフォルト = 100)。認識されるのは、[最小面積] の値より面積が大きいブロブのみです。

閉じた 最大面積

ブロブ検出時の、最大面積をピクセルで定義します (0～16777216。デフォルト = 100000)。認識されるのは、[最大面積] の値より面積が小さいブロブのみです。

閉じた 角度を無視

ブロブ重心の角度方向を考慮するかどうかを指定します。デフォルトは ON (無視する) です。

注 : ブロブの角度は変動しやすくフィクスチャへの影響が大きいため、このパラメータのデフォルトは ON となっています。
閉じた 検出する数

検出するモデルパターンのインスタンスの数 (1～10) を定義します。デフォルトは 1 です。ほとんどのアプリケーションは 1 つのフィクスチャで十分ですが、複数のインスタンス (実体) を位置決めすることもできます。識別するブロブの数が多いほど、実行時間は増大します。

閉じた ソート

ツールが検出したブロブをどのように計測し、ソートするかを定義します。選択肢は、[面積]、[行]、[列]、[グリッド: フィクスチャから X、次に Y]、[グリッド: フィクスチャから Y、次に X]、[フィクスチャ原点からの距離]、[フィクスチャ行軸からの角度 (CCW)]、および [角度絶対値]。デフォルトは、[面積] です。

  • [面積]: 検出ブロブの面積を最大から最小の順番にソートします。
  • [行]: 行画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [列]: 列画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから X、次に Y]: まず、フィクスチャの行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから Y、次に X]: まず、フィクスチャの列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [フィクスチャ原点からの距離]: フィクスチャの原点からブロブの重心までの距離を、短いものから長いものの順 (降順) にソートします。
  • [フィクスチャ行軸からの角度 (CCW)]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
  • [角度絶対値]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
閉じた 結果

検出されたブロブの重心座標と角度を表示します。[角度を無視] チェックボックスが ON の場合は、90度 ([画像の設定] ステップの [X と Y を入れ替える] が ON の場合は 0度) に固定されます。

注 : [検出する数] パラメータを 2 以上に設定していても、[ソート] パラメータを [X] または [Y] に設定した場合以外は、[結果] フィールドには、最高得点の結果だけが表示されます。
注 : ブロブ位置決めツールには、[検出する数] パラメータは含まれていません。


[テーブル] タブ (ブロブ (1-10) 位置決めツール)

注 :
  • ブロブ位置決めツールは、[テーブル] タブをサポートしていません。ブロブ (1-10) 位置決めツールのみに表示されます。

  • [ソート] パラメータが [面積] 以外のオプションに設定されている場合、[ピクセル列] および [ピクセル行] がテーブルに追加されます。ピクセル [列] および [ピクセル行] は、In-Sight ビジョンシステムの画像センサ (アレイの列および行) の 2D グリッドに基づく画像座標を参照し、実座標 (X/Y) と逆 (Y/X) になります。

  • [画像の設定] ステップのキャリブレーション (画像座標系をワールド座標系に変換) グループボックスで、[X と Y を入れ替える] オプションを ON にした場合、XY 座標は画像座標 (Y/X) と同じになります。

[テーブル] タブには、検出したブロブの結果が報告されます。その数は、[設定] タブの [検出する数] パラメータによります。

閉じた インデックス

[設定] タブの [ソート] パラメータに基づいて、検出したブロブの順番を表示します。EasyBuilder では 0 から数えます。

閉じた X

検出したブロブ重心の X 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

閉じた Y

検出したブロブ重心の Y 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

閉じた 角度結果

領域の中心を基準に、検出したブロブ重心の角度を返します。

閉じた 面積

検出したブロブの面積を返します (ピクセル単位)。

閉じた ピクセル行

検出したブロブの重心画像行 (X) 座標を返します。

閉じた ピクセル列

検出したブロブの重心画像行 (Y) 座標を返します。


[合成領域] タブ (ブロブ/ブロブ (1-10) 位置決めツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


ヒストグラム (ブロブ (1-10) 位置決めツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の垂直線は、画像の黒い部分と白い部分を切り分けるしきい値を表します。垂直線より左側が黒、右側が白とみなすことができます。
注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


カラーブロブ/カラーブロブ (1-10) 位置決めツール

カラーブロブおよびカラーブロブ (1-10) 位置決めツールは、指定したパラメータに合致しているブロブを位置決めし、 検出したブロブの重心座標や角度を返します。 カラーブロブツールが 1 個のブロブの位置決めに使用されるのに対し、カラーブロブ (1-10) 位置決めツールは最大 10 個までのブロブの位置決めに使用されます。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

カラーブロブ/カラーブロブ (1-10) ツールは、登録済みカラーモデルライブラリを参照し、選択した登録済みカラーモデルにマッチする、領域内のピクセル数を決定します。 ツールは、その後、有効なカラーモデルにマッチするピクセルを白 (255) に、それ以外のピクセルを黒 (0) に設定した、2 値化グレースケール出力画像を作成します。 この 2 値化出力画像を使用して、有効なカラーモデルによって生成されたブロブ特徴を画像からサーチします。

ツールを設定するには

ツールのパラメータを調整するには


カラーブロブ/カラーブロブ (1-10) 位置決めツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 ブロブをフィクスチャとして使用する場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。

    • カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。

    • カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブに戻り使用する [カラーライブラリ] を選択してから、[ライブラリ] タブで [カラーモデル] のチェックボックスを ON にします。

    • [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  4. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。

  5. 領域の設定を確定すると、検出されたブロブの重心点とその向きを示す [image] アイコンが表示されます。

  6. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  7. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーブロブ/カラーブロブ (1-10) 位置決めツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーブロブ/カラーブロブ (1-10) 位置決めツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [ライブラリ] タブ
  • [テーブル] タブ
  • [合成領域] タブ
注 : [テーブル] タブは、カラーブロブ (1-10) 位置決めツールでのみ有効になります。
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[合成領域] タブ

テーブル

ライブラリ


[全般] タブ (カラーブロブ/カラーブロブ (1-10) 位置決めツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラーブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 アプリケーションに合わせて、名前を変更することができます。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーブロブ/カラーブロブ (1-10) 位置決めツール)

閉じた [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

閉じた カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール
閉じた 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。つまり、その他の条件を満たしていれば、領域の境界に接しているブロブを検出します。
閉じた 最小面積

ブロブ検出時の、最小面積をピクセルで定義します (0～16777216。デフォルト = 100)。認識されるのは、[最小面積] の値より面積が大きいブロブのみです。

閉じた 最大面積

ブロブ検出時の、最大面積をピクセルで定義します (0～16777216。デフォルト = 100000)。認識されるのは、[最大面積] の値より面積が小さいブロブのみです。

閉じた 角度を無視

ブロブ重心の角度方向を考慮するかどうかを指定します。デフォルトは ON (無視する) です。

注 : ブロブの角度は変動しやすくフィクスチャへの影響が大きいため、このパラメータのデフォルトは ON となっています。
閉じた 検出する数

検出するカラーブロブの数 (1～10) を定義します。デフォルトは 1 です。ほとんどのアプリケーションは 1 つのフィクスチャで十分ですが、複数のインスタンス (実体) を位置決めすることもできます。識別するブロブの数が多いほど、実行時間は増大します。

注 : このコントロールは、カラーブロブ (1-10) 位置決めツールでのみ使用できます。
閉じた ソート

ツールが検出したブロブをどのように計測し、ソートするかを定義します。選択肢は、[面積]、[行]、[列]、[グリッド: フィクスチャから X、次に Y]、[グリッド: フィクスチャから Y、次に X]、[フィクスチャ原点からの距離]、[フィクスチャ行軸からの角度 (CCW)]、および [角度絶対値]。デフォルトは、[面積] です。

  • [面積]: 検出ブロブの面積を最大から最小の順番にソートします。
  • [行]: 行画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [列]: 列画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから X、次に Y]: まず、フィクスチャの行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから Y、次に X]: まず、フィクスチャの列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [フィクスチャ原点からの距離]: フィクスチャの原点からブロブの重心までの距離を、短いものから長いものの順 (降順) にソートします。
  • [フィクスチャ行軸からの角度 (CCW)]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
  • [角度絶対値]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
閉じた 平滑化係数

画像を平滑化する係数を定義します (0～25; デフォルト = 1)。平滑化を行わない場合は、0 に設定してください。

閉じた オリジナル画像の表示
  • OFF (デフォルト):選択した領域にバイナリのグレースケール出力画像を表示します。
  • ON:選択した領域にオリジナルの入力画像を表示します。
閉じた 結果

検出されたブロブの重心座標と角度を表示します。[角度を無視] チェックボックスが ON の場合は、90度 ([画像の設定] ステップの [X と Y を入れ替える] が ON の場合は 0度) に固定されます。


[合成領域] タブ (カラーブロブ/カラーブロブ (1-10) 位置決めツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


[テーブル] タブ (カラーブロブ (1-10) 位置決めツール)

注 :
  • カラーブロブ位置決めツールは、[テーブル] タブをサポートしていません。カラーブロブ (1-10) 位置決めツールのみに表示されます。

  • [ソート] パラメータが [面積] 以外のオプションに設定されている場合、[ピクセル列] および [ピクセル行] がテーブルに追加されます。ピクセル [列] および [ピクセル行] は、In-Sight ビジョンシステムの画像センサ (アレイの列および行) の 2D グリッドに基づく画像座標を参照し、実座標 (X/Y) と逆 (Y/X) になります。

  • [画像の設定] ステップのキャリブレーション (画像座標系をワールド座標系に変換) グループボックスで、[X と Y を入れ替える] オプションを ON にした場合、XY 座標は画像座標 (Y/X) と同じになります。

[テーブル] タブには、検出したブロブの結果が報告されます。その数は、[設定] タブの [検出する数] パラメータによります。

閉じた インデックス

[設定] タブの [ソート] パラメータに基づいて、検出したブロブの順番を表示します。EasyBuilder では 0 から数えます。

閉じた X

検出したブロブ重心の X 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

閉じた Y

検出したブロブ重心の Y 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

閉じた 角度結果

領域の中心を基準に、検出したブロブ重心の角度を返します。

閉じた 面積

検出したブロブの面積を返します (ピクセル単位)。

閉じた ピクセル行

検出したブロブの重心画像行 (X) 座標を返します。

閉じた ピクセル列

検出したブロブの重心画像行 (Y) 座標を返します。


[ライブラリ] タブ (カラーブロブ/カラーブロブ (1-10) 位置決めツール)

閉じた [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

閉じた カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

閉じた カラー名

選択したカラーモデルに含まれるカラー名を表示します。

閉じた RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

閉じた 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


円位置決めツール

円位置決めツールは、指定したパラメータに合致する円形状の特徴を位置決めします。

円位置決めツールは、高速なツールの 1 つです。パターン位置決めツールよりも短時間で特徴を検出することができます。 回転を伴わない円形の対象物を検査する場合、他のビジョンツールのフィクスチャとして有効に機能します。

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズ 1XX ビジョンセンサ (110、120、130) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 検出された円の XY 座標 (中心)、直径*、PASS/FAIL ステータス
* 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


円位置決めツールを設定するには

ツールを追加したら、円検査領域を定義します。

  1. 円形状の特徴の上に円領域を配置します。特徴とちょうど同じぐらいの大きさになるように調整してください。円をフィクスチャとして選択する場合、すべての画像のほぼ同じ位置に存在し、ピクセルの白黒の差がはっきりした、高コントラストの円を選択してください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. 円形状の特徴の周囲にドーナツ領域が表示され、検出された円の中心位置とその向きを示す [image] アイコン が表示されます。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円位置決めツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

円位置決めツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • グラフ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

グラフ


[全般] タブ (円位置決めツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は円_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (円位置決めツール)

閉じた エッジのコントラスト

円が検出されたとみなすための最小コントラスト得点 (1～100) を指定します。初期値はスマートセッティングによって自動的に決定されます。 このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注 : パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
閉じた スコアの正規化

エッジスコアを領域のグレースケールヒストグラムで正規化するかどうかを指定します。このパラメータは、低コントラスト領域でエッジを見つける場合に有用です。検出対象のエッジが高コントラストだけの場合は、このパラメータを無効にします。

  • ON (デフォルト): スコアを正規化します。
  • OFF: スコアを正規化しません。
閉じた エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。 検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 検出する基準

複数の円が存在する場合に、目的とする 1 つの円に絞り込む方法を定義します。デフォルトは [得点の高い順] です。

  • 得点の高い順: 最も明確な円 (コントラストが最も高いもの) が選択されます。
  • 最小円: 最も小さい円が選択されます。
  • 最大円: 最も大きい円が選択されます。
閉じた 結果

検出された円の中心座標および直径を表示します。


グラフ (円位置決めツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


フィクスチャ計算位置決めツール

フィクスチャ計算位置決めツールは、他の位置決め/検査ツールが出力した数式に基いて、フィクスチャの位置を計算するのに使用します。 このツールは、計算したフィクスチャの XY 座標および角度を返します。

注 :
    結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。
  • このツールを [グリッド] キャリブレーションと連動して使用すると、キャリブレーションした角度値が変化した場合に、不正確な結果を生成することがあります。 この場合、[エッジ] や [円]、[インポート] キャリブレーションを使用してください。

フィクスチャ計算位置決めツールは、位置決め/検査ツールで生成された特定の点や、ライン、角度データを使用して、フィクスチャを計算したい場合に有用です。例えば、2 個のエッジとその交点および2 等分角度結果を基にして、フィクスチャを作成したい場合などです。 このシナリオでは、エッジ有無判定ツールを使用してエッジを定義し、角度 2 等分幾何・計測ツールを使用して X、Y および角度の値を定義します。 フィクスチャ計算位置決めツールは、その後、角度 2 等分幾何・計測ツールの出力データを使用して、X (2等分_1.点.X) 、Y (2等分_1.点.Y) および角度結果 (2等分_1.角度) 式を入力します。

ツールを設定するには

ツールのパラメータを調整するには


フィクスチャ計算位置決めツールを設定するには

ツールを追加したら、[式] に [X]、[Y] および [角度結果] 値を入力します。

注 : 他の位置決め/検査ツールを入力として使用します。入力として使用する他の位置決め/検査ツールを設定してから、このツールを追加してください。そうしないと、[式] を設定することができず、他のツールを設定してから、このツールに戻って設定し直すことになります。
  1. 設定ペインの左側から演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してからダブルクリックするか、または [挿入] ボタンを押します。
  2. すべての [式] を作成したら、計算されたフィクスチャの位置とその向きを示す アイコン [image] が表示されます。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


フィクスチャ計算位置決めツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

フィクスチャ計算位置決めツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [X]、[ Y] および [角度] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[X]、[ Y] および [角度] タブ


[全般] タブ (フィクスチャ計算位置決めツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はフィクスチャ_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (フィクスチャ計算位置決めツール)

閉じた 結果

計算された X、Y および 角度の値を表示します。

閉じた カラー

計算されたフィクスチャ位置のカラーを定義します。デフォルト (=緑)、暗い赤、暗い緑、暗い黄色、暗い青、暗い赤紫、暗い水色、赤、緑、黄色、青、赤紫、水色、暗い灰色、灰色、黒または白。


[X]、[Y]、[角度結果] タブ (フィクスチャ計算位置決めツール)

[X]、[Y]および [角度結果] タブを使用して、フィクスチャの X、Y および 角度座標を定義する数式を作成します。

注 : これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。
閉じた 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 :
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
閉じた ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

閉じた ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 :
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。
注 : 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注 : このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。
閉じた 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注 : これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


位置決めおよび検査ツール間にリンクを作成するには

位置決め/検査ツールをジョブに追加すると、[パレット] の [リンク] タブを使用し、プロパティ (入力パラメータおよび出力結果) を結びつけることができます。[リンク] タブでは、ツールの出力結果を他のツールの入力パラメータとして使用することができます。

閉じた [リンク] タブを使用するには

[パレット] の [リンク] タブには、現在ジョブにロードされている位置決め/検査ツールのツリービューが表示されます。ツールのプロパティ (入力パラメータおよび出力結果) は、シンボリックタグに参照されています。シンボリックタグとは、ツールプロパティに含まれる値を参照しているシンボルのことです。また、値は、データタイプ (動作、浮動小数点、整数値、または文字列) に関連付けられています。

ツールプロパティは入力および出力プロパティに分けられ、出力プロパティから入力プロパティのみリンクすることができます。出力プロパティは複数かつ個別の入力プロパティとリンクすることができますが、入力プロパティがリンクできるのは、1 つの出力プロパティのみです。

表示するツールプロパティを選択して [リンク] タグで設定するには、ツールプロパティを右クリックし、[プロパティの選択] ダイアログを開きます。[プロパティの選択] ダイアログには、ジョブに含まれるすべてのツールのツリービューリストおよび関連するツールプロパティ (入力・出力とも) が含まれています。表示するプロパティを選択することによって、[リンク] タグのツールプロパティをカスタマイズすることができます。複数のツールプロパティを選択し、[追加]/[削除] ボタンを使用して、一度に複数のツールプロパティを追加または削除することができます。

閉じた [リンク] タブのコントロール
[リンク] タブのコントロール

ジョブに含まれるすべてのツールプロパティを開きます。

ジョブに含まれるすべてのツールプロパティを閉じます。

ツールプロパティの表示オプションを切り替えます。

  • デフォルト: [プロパティの選択] メニューで選択したツールプロパティのみを表示します。
  • 標準プロパティを表示: ツールプロパティをサブセットで表示します。説明、総合判定に含める、エラー_数、実行_時間、FAIL_数、PASS_数、ツール有効ステータス および反転は、非表示となります。
  • すべてのプロパティを表示: すべてのツールプロパティを表示します。

ツールプロパティの順番をソートします。

  • デフォルト: ジョブに追加した順番でツールを表示します。最初に追加したツールがリストの 1 番上となります。
  • アルファベット順: ツール名に基づき、アルファベット→カタカナ→漢字の順番でソートします。
  • 依存関係順: 依存関係の順番でツールを表示します。入力プロパティは出力プロパティの上に表示されます。
注 :
  • 他のツールにリンクされたツールを削除すると、そのリンクは自動的に削除されます。
  • 入力・出力両方のプロパティがリンクされているツールをジョブにコピー＆ペーストすると、入力プロパティのみが保持されます。
閉じた ツール間にリンクを作成するには

ツール出力プロパティと入力プロパティの間のリンクは、出力プロパティノードを適切な入力プロパティノードにドラッグするか、または入力プロパティを右クリックし、[リンク先] コンテクストメニューから適切な出力プロパティを選択することによって作成することができます。

注 : リンクプロパティにドラッグ＆ドロップする方法を使用する場合、ショートカットアイコンが表示され、暗い青の矢印がカーソルに表示されます。プロパティをリンクすることができない場合、カーソルに黒いアイコンが表示されます。

ツールプロパティをリンクすると、入力プロパティパラメータはグレーアウトされ、使用不可能になり、ツール名の右側にリンクアイコンが表示されます。リンクアイコンの上にマウスカーソルを動かすと、リンクのソースを示すツールのヒントが表示され、リンクアイコンを右クリックすると、リンクを解除するコンテクストメニューが開きます。

注 : 作成したリンクを取り消すには、EasyBuilder ツールバーの取り消しボタンを押すか、またはCTRL+Z を使用します。
閉じた ツール間のリンクを削除するには

入力プロパティと出力プロパティの間のリンクを削除するには、入力リンクのプロパティを選択し、Delete キーを押すか、または右クリックしてコンテクストメニューを表示し、[リンク削除] を選択します。

注 : リンクの削除を取り消すには、EasyBuilder ツールバーの取り消しボタンを押すか、またはCTRL+Z を使用します。
閉じた 例
閉じた ID コードの読み取り識別ツールと文字認識識別ーツールをリンクするには

文字認識識別ツールを使用して、ID コードの読み取り識別ツールが返した文字列が正しいかどうかを検証することができます。まず、文字認識ツールの [モード] を [照合] に設定し、[マッチ文字列] に予想される文字列を入力します。次に ID コードの読み取りツールの [文字列] 出力結果を文字認識ツールの [マッチ文字列] 入力パラメータにリンクします。すると、文字列認識ツールは ID コードの読み取りツールによって検査されたコードが正しい文字列かどうかを検証します。


検査

検査ステップは、ジョブを作成する検査ツールを組み立てたり、設定したりするのに使用されます。 製品を調べ、どのタイプの特徴がアプリケーションの条件を最も満たしているか、さらにどの検査ツールが問題解決に最も適しているかを判断します。 詳細については、特徴とはをご参照ください。

注 : [リンク] タブは In-Sight 2000 シリーズビジョンセンサではサポートされていません。

位置決めツールは、次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000-110 および 2000-120/120C ビジョンセンサ | PASS/FAIL ステータスのみ
In-Sight 2000-130/130C ビジョンセンサ | 寸法測定および計数ツール: 標準の結果 (数値データ) 有無判定ツール: PASS/FAIL ステータスおよびパターンの得点 その他のツール:PASS/FAIL ステータスのみ
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 標準の結果 (制限無し)

検査ツールを追加、削除、編集するには

検査ツールを選択するには

位置決めツールと検査ツールの間にリンクを作成するには


検査ツールを追加、削除、編集するには

閉じた ツールを追加する

ジョブにツールを追加するには、[ツールの追加] リストからツールを選択して [追加] ボタンを押すか、またはそのツールをダブルクリックしてください。続いて、EasyBuilder のスマートフィーチャーまたは領域グラフィックスを使用して、位置決め用の特徴を定義します。

特徴の定義後、ツールの機能をチューニングすることができます。ツールの各種パラメータを操作してください。

注 : [ツール] サーチボックスを使用して、ツールを動的にサーチすることができます。
閉じた ツールを削除する

ジョブからツールを削除するには、次のいずれかの方法で行います。

  • パレットの [結果] テーブルでツールを選択し、キーボードの Delete キーを押します。
  • パレットの [結果] テーブルでツールを選択し、標準ツールバーの [削除] アイコンをクリックします。
  • パレットの [結果] テーブルでツールを右クリックし、[削除] を選びます。
閉じた ツールを編集する

EasyBuilder のどのステップからでも、次のいずれかの方法でツールを編集することができます。

  • パレットの [結果] テーブルでツールをダブルクリックします。
  • パレットの [結果] テーブルでツールを右クリックし、[このツールへジャンプして編集] を選択します。

[ジョブの実行] ステップの [結果] テーブルでツールをダブルクリックします。

  • 画像内の領域グラフィックスを選択します。
  • パレットの [結果] テーブルでツールをダブルクリックします。
  • パレットの [結果] テーブルでツールを右クリックし、[このツールへジャンプして編集] を選択します。
  • [ジョブの実行] ステップの [結果] テーブルでツールをダブルクリックします。
注 :
  • In-Sight ビジョンシステムが In-Sight Explorer スプレッドシートプログラミング環境へのアクセスをサポートしている場合、右クリックすると [このツールにジャンプして編集] オプションが表示されます。スプレッドシートプログラミング環境に精通し、その操作方法を熟知している場合のみ、この環境にアクセスすることを推奨します。In-Sight Explorer オンラインヘルプファイルのスプレッドシートの EasyBuilder ジョブの編集トピックをご参照ください。
  • [結果] テーブル内のツールをドラッグ & ドロップすることによって、ツールの順番を変更することができます。この操作は、ジョブの実行 [結果] テーブルおよびパレットの [結果] タブの両方で実行でき、その結果は両方のテーブルに反映されます。ドラッグ & ドロップソーティングは、テーブルの [ツールの順番および依存関係グラフィックス] 行を選択しているときのみ、有効となります。行を再度選択すると、順番は逆になります。リストの順番を変更する機能は、ジョブがジョブサイズ制限に近づくと、無効になります。
注 : ツールを追加するのに十分なスペースがジョブにない場合、[位置決め] または [検査] アプリケーションステップを終了し、[センサ] メニューから [ジョブサイズ制限] を選択します。このダイアログで、ツールが追加できるよう、ジョブサイズを調整することができます。In-Sight ビジョンシステムのジョブサイズを調整するには、ビジョンシステムを再起動する必要があります。その際、すべてのジョブおよび設定ファイルが不揮発性メモリから消去されます。継続する前に、ジョブを保存、バックアップしてください。

特徴とは

領域

EasyBuilder スマートセレクションとは


特徴とは

マシンビジョンでは、特徴は「画像の中の検査対象物」と呼ばれます。ビジョンによる検査は画像中に検出された特徴に対して行われます。

[検査] ステップで検出される特徴には次の種類があります。

閉じた エッジ

白ピクセルと黒ピクセルとの遷移が、水平または垂直方向、円またはカーブ状に並んでいる部分を指します。検査対象物の端、電子基板上のピン、ネジの山、ボトルの底、バネのコイルなどがエッジにあたります。これらのタイプの特徴は、一般的に最も速く簡単に検出されます。

閉じた エッジの例

閉じた 円、線および点

寸法計算に使用される、標準的な幾何学参照図形。

閉じた 円、線および点の例

閉じた パターン

パターンには、反復模様のようなシンプルなものからロゴやラベルといった複雑なものまでさまざまな形状が含まれます。パターンは非常に高い信頼性を発揮します。回転、移動、スケール変化にも対応することができますが、一般的に検査時間は長めです。

閉じた パターンの例

閉じた ブロブ

黒い背景上の白いしみや、白いベルトコンベヤ上の黒いネジなど、黒色または白色のピクセルの塊をブロブと呼びます。比較的早く検出され、ブロブの形状およびサイズのばらつきに対応することができますが、ブロブの角度データが制限されていることにご注意ください。

閉じた ブロブの例

閉じた 文字

英数字の文字列を指します。

閉じた 文字列の例

閉じた コード

英数字のデータ文字列を含むバーコード、2D マトリックスコード、およびシンボルを指します。

閉じた コードの例

閉じた ビード

ビードとは、指定した幅値を使用して、ピクセル値の異なる 2 つの領域間の境界を定義する、連続したエッジペアのことです (必ずしも閉じている必要はありません)。例えば、溶接メタル、接着剤、またはシーラントのパスは、「ビード」パスと呼ばれます。

閉じた ビードの例


領域

領域は、位置決めおよび検査ツールが検査を行う画像領域を定義します。領域は、検査対象領域 (ROI) とも呼ばれます。

EasyBuilder では、使用するツールによって、異なるタイプの領域が使用されます。領域の種類は、次の通りです。

  • 矩形
  • 円
  • 円環
  • ポリゴン
  • マスク領域
  • ポリラインパス

円環領域

円領域

マスク領域

ポリゴン領域

ポリラインパス領域

矩形領域


マスク領域

マスク領域は、エッジ解析を実行する画像エリアを定義するのに使用されます。領域は、エッジの正確な位置を特定するキャリパアレイと連動して使用されます。

閉じた マスク領域の凡例

 | コントロール | 説明
1 | サイズ変更用端点マーク (× 4) | 矩形領域の四隅を定義します。端点の 1 つをクリックして、四隅の 1 つから領域のサイズを変更することができます。
2 | マスク | 画像解析を実行しない画像エリアを定義します。領域内からマスクを削除したり、サイズ変更したりすることができます。領域には、最大 99 までのマスクを追加することができます。マスクを始めて追加した場合、領域の始めに追加され、その後に追加されたマスクは、以前に追加されたマスクの次に追加されます。 注 : マスクは重ねることができません。マスクが重なるように設定されている場合、自動的に 1 ピクセルバッファが挿入され、マスクの重なりを防ぎます。
3 | スキャン方向インジケータ (× 2) | マスク領域で特徴がスキャンされる方向を定義します。
4 | エッジ検出インジケータ | エッジ遷移が検出される領域内のエリアを定義します。また、領域に新しいマスクを追加することを可能にします。
5 | 回転用ハンドル | 領域を 360 度回転させることができます。
6 | カーブ用ハンドル | 矩形領域を円弧または円形に曲げることができます。
閉じた マスク領域のマウス動作

領域内のさまざまな場所にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、以下の動作を行うことができます。

マウスアイコン | 説明
 | 画像内の任意の場所にマスク領域全体をドラッグできます。
 | 領域全体を水平または垂直に拡大縮小することができます。また、マスクのサイズ変更にも使用されます。
 | マウスカーソルの位置により、以下の 2 つの動作を行うことができます。回転用ハンドルの上にある場合、領域を現在の向きから 360 度回転させることができます。カーブ用ハンドルの上にある場合、領域を円弧または円環に再形成して、円状のエッジ特徴を検出できるようにします。
 | 領域内にマスクをドラッグできます。
 | 領域内にマスクを追加したり、削除したりできます。このアイコンを表示し、マウスを右クリックすると、[マスクの追加] または [マスクの削除] オプションメニューが開きます。


ポリラインパス領域

ポリラインパス領域は、エッジ解析を実行する画像エリアを定義するのに使用されます。領域は、エッジの正確な位置を特定するキャリパアレイと連動して使用されます。

注 :

  • グラフィックスの編集中は、右クリックメニューを使用して、線分を追加または削除することができます。

  • ポリラインパス領域では、領域の最大化ボタンは OFF となっています。
閉じた ポリラインパス領域の凡例

 | コントロール | 説明
1 | ポリラインパスの頂点 (x3) | ポリライン線分のパスを定義します。頂点をクリックして、ポリラインの位置を決めます。
2 | スキャン方向インジケータ (× 2) | ポリラインパス領域で特徴がスキャンされる方向を定義します。
3 | ポリラインパス | ポリラインのプロットをグラフィカルに表示します。
4 | 回転用ハンドル | 領域を 360 度回転させることができます。
閉じた ポリライン領域のマウス動作

領域内のさまざまな場所にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、以下の動作を行うことができます。

コントロール | 説明
 | 画像内の任意の場所にポリライン領域全体をドラッグできます。
 | 領域全体を水平または垂直に拡大縮小することができます。また、マスクのサイズ変更にも使用されます。
 | 領域を現在の向きから 360 度回転できます。
 | 領域内でポリラインを移動できます。
 | ポリラインパスに頂点を追加できます。1 つのポリラインに最大 99 個の頂点を追加できます。99 個の頂点をポリラインに追加すると、このオプションは無効になります。


EasyBuilder スマートセレクションとは

EasyBuilder スマートセレクション – スマートフィーチャー、スマートリミットおよびスマートセッティング – を使用すると、ツールおよびアプリケーションの条件に基づいて、インテリジェントなデフォルトしきい値を自動的に決定することにより、アプリケーションの設置をスピードアップすることができます。

注 : EasyBuilder でアプリケーションを設定する場合は、アプリケーションに適したデフォルトのしきい値を設定できるように、検査対象製品または対象物の『PASS』画像を使用してください。
  • スマートフィーチャー
  • スマートリミット
  • スマートセッティング

スマートフィーチャーとは

スマートリミットとは

スマートセッティングとは


スマートフィーチャーとは

特定の位置決めおよび検査ツールでは、選択したツールに基づいて画像から特徴を抽出し、検査に使用する特徴をポイント＆クリックして選択することができます。

これらのツールがジョブに追加された場合、ツールは画像を自動的に検査し、どの特徴がツールの条件にマッチするかを決定します。例えば、エッジ位置決めツールでは、水平または垂直方向のエッジのみを返し、円の直径および円の同心度寸法測定ツールでは、円形状の特徴のみを返します。

閉じた 例
閉じた スマートフィーチャー - エッジ

閉じた スマートフィーチャー - 円

特徴が事前に定義されていない場合、水色で提示されます。既存の特徴 (他の位置決めまたは検査ツールで定義された、パターン、ブロブ重心、距離、エッジまたは円など) は緑色で提示されます。

閉じた 例

スマートフィーチャー – 新たに検出されたものと、定義済みのもの

検査に使用する特徴をクリックしてください。領域が未定義の場合、EasyBuilder はその特徴に適した領域を自動的に作成します。

注 :

目的の特徴がスマートフィーチャーとして表示されない場合は、次のいずれかの方法を行ってください。

  • ほかのスマートフィーチャーを選択し、自動的に作成された領域を目的の特徴の上に移動します。そして、目的の特徴が検出されるようにツールのパラメータを調整します。
  • 有無判定または幾何・計測ツールを使用して、検査に使用する特徴を定義します。次に、ツールを再度追加して、目的の特徴を選択します。


スマートリミットとは

[制限範囲] タブの表示される検査ツールでは、自動的に [最大] および [最小] 範囲が設定されます。

ヒント : よりよい結果を得るため、スマートセッティングを使用の際には『PASS』画像の登録から始めてください。

[制限範囲] タブの表示されるツールがジョブに追加されると、ツールは画像を自動的に検査し、ツールの条件に基づいて適切な最大および最小範囲を決定します。例えば、距離および角度結果寸法測定ツールの最大および最小制限範囲は、距離および角度値の ±5% 内であるのに対し、計数ツールの制限範囲は、最初の画像で検出された特徴の数によって決定されます。


スマートセッティングとは

円およびエッジを定義する位置決めおよび検査ツールでは、[コントラスト] パラメータ値をエッジ特徴が検出されるまで自動的に増加させることにより、アプリケーションに基づいたしきい値をすばやく設定できることができます。

注 : よりよい結果を得るため、スマートセッティングを使用の際には『PASS』画像の登録から始めてください。

円またはエッジ位置決め/検査ツールがジョブに追加されると、ツールは画像を自動的に検査します。同時に、適切なコントラスト設定を決定して、設定値を2 レベル分下げたしきい値を設定します。デフォルトのコントラスト設定は 25 で、最小は 5 です。


検査ツールを選択するには

検査ツールは、検査タイプによってグループ分けされます。

閉じた 有無判定ツール

画像内の特徴の有無を判定します。

有無判定ツール | In-Sight ビジョンシステム (5.x.x ファームウェア) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
輝度 | X |  | X | X | X | X
コントラスト | X |  | X | X | X | X
PatMax RedLine パターン 1 | X |  |  |  |  |
PatMax パターン | X |  |  |  |  |
パターン | X | X | X | X | X | X
ピクセル計数 2 | X |  | X | X | X | X
カラーピクセル計数 3 | X |  | X | X | X |
ブロブ 1 | X |  |  |  | X |
カラーブロブ 2 | X |  |  |  | X |
エッジ | X |  |  | X | X | X
円 | X |  |  | X | X | X
シャープネス | X |  |  |  | X |
1In-Sight 5.x.x ファームウェアのみ。 2モノクロモデルのみ。 3カラーモデルのみ。
閉じた 寸法測定ツール

画像中の特徴の距離、直径、角度および面積を測定するのに使用します。

寸法測定ツール | In-Sight ビジョンシステム | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
距離 | X |  |  | X | X | X
角度 | X |  |  | X | X | X
ブロブ面積 1 | X |  |  |  | X |
ブロブ面積 (1-10) 1 | X |  |  |  | X |
カラーブロブ面積 2 | X |  |  |  | X |
カラーブロブ面積 (1-10) 2 | X |  |  |  | X |
円の直径 | X |  |  | X | X | X
円の同心度 | X |  |  |  |  | X
半径測定 | X |  |  |  | X | X
最小/最大点 | X |  |  |  |  |
1モノクロモデルのみ。 2カラーモデルのみ。
閉じた 計数ツール

画像中の特徴の距離、直径、角度および面積を測定するのに使用します。

計数ツール | In-Sight ビジョンシステム | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
ブロブ 1 | X |  |  |  | X |
カラーブロブ 2 | X |  |  |  | X |
エッジ | X |  |  | X | X | X
エッジペア | X |  |  |  |  |
PatMax RedLine パターンs 3 | X |  |  |  |  |
PatMax パターン | X |  |  |  |  |
パターン | X |  |  | X | X | X
1モノクロモデルのみ。 2カラーモデルのみ。 3In-Sight 5.x.x ファームウェアのみ。
閉じた 識別ツール

画像内のバーコード、2D コード、シンボル、英数字文字列、パターン特徴およびカラーを識別、検証するのに使用します。

識別ツール | In-Sight ビジョンシステム (5.x.x ファームウェア) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
1D コードの読み取り | X |  |  |  |  |
1D コードの読み取り (1-20) | X |  |  |  |  |
2D コードの読み取り | X |  |  |  |  |
2D コードの読み取り (1-20) | X |  |  |  |  |
郵便コードの読み取り | X |  |  |  |  |
ID コードの読み取り 1 |  |  |  |  |  |
文字認識 1 |  |  |  |  |  |
文字認識 (OCRMax) | X |  |  |  | X |
PatMax RedLine パターン (1-10) 2 | X |  |  |  |  |
PatMax パターン (1-10) | X |  |  |  |  |
パターン (1-10) | X |  |  |  | X |
カラー 3 | X |  |  |  |  |
カラーモデル 2 | X |  |  |  |  |
1ID コードの読み取りおよび文字認識ツールはレガシーツールで、In-Sight Explorer 4.7.0 以降のシステムではサポートされていません。 2In-Sight 5.x.x ファームウェアのみ。 3カラーモデルのみ。
閉じた 幾何・計測ツール

画像内に幾何学参照図形を作成します。演算＆ロジックツールや寸法測定ツールなどの他の検査ツールによって参照することができます。

幾何・計測ツール | In-Sight ビジョンシステム | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
2 点間の直線 | X |  |  |  | X | X
2 点間の中点 | X |  |  |  | X | X
2 点間の距離 | X |  |  |  | X | X
垂直線 | X |  |  |  |  | X
直線交点 | X |  |  |  | X | X
角度 2 等分 | X |  |  |  |  | X
N 点を通る直線 | X |  |  |  |  | X
N 点を通る近似円 | X |  |  |  |  | X
円-直線交点 | X |  |  |  |  | X
ユーザ定義点 | X |  |  |  |  | X
ユーザ定義直線 | X |  |  |  |  | X
最適円 | X |  |  |  |  |
最適ライン | X |  |  |  |  |
閉じた 演算＆ロジックツール

ツールデータおよびジョブデータに結果に基づき、条件付きでツールをリンクさせたり、出力されたツールに数学演算を実行したり、ツールの統計処理を行ったり、ツールをグループ化したり、演算順序のステップを作成したりするのに使用します。

演算＆ロジックツール | In-Sight ビジョンシステム | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
演算 | X |  |  |  | X | X
ロジック | X | X | X | X | X | X
トレンド | X |  |  |  |  | X
統計 | X |  |  |  |  | X
グループ | X |  |  | X | X | X
シーケンス | X |  |  |  |  |
点計算 | X |  |  |  |  | X
変数 | X |  |  |  | X | X
ロボットガイダンス | X |  |  |  |  |
閉じた プロットツール

数式に基づき、画像にグラフィックスを計算するのに使用します。

プロットツール | In-Sight ビジョンシステム | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
円弧 | X |  |  |  | X | X
円 | X |  |  |  | X | X
十字 | X |  |  |  | X | X
プロットライン | X |  |  |  | X | X
点 | X |  |  |  | X | X
領域 | X |  |  |  | X | X
プロット文字列 | X |  |  |  | X | X
閉じた 画像フィルタツール

画像解析用に、画像または画像領域を強調するのに使用します。

画像フィルタツール | In-Sight ビジョンシステム (5.x.x ファームウェア) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
フィルタ | X |  |  |  | X |
近傍 1 |  |  |  |  |  |
シーン補正 1 |  |  |  |  |  |
輝度 1 |  |  |  |  |  |
カラーからグレースケール変換 2 | X |  |  |  |  |
カラーから二値化変換 2 | X |  |  |  |  |
変換 | X |  |  |  |  |
比較 | X |  |  |  |  |
1ファームウェアバージョン 4.x.x を搭載した In-Sight ビジョンシステムのみでサポートされています。 2カラーモデルのみ。
閉じた 欠陥検出ツール

検査対象物に、亀裂、ひだ、くぼみ、ギャップ、切り目、または傷などの欠陥があるかどうかを決定するのに使用します。

注 : 欠陥検出ツールは、In-Sight ビジョンシステムのみでサポートされています。
  • 傷検査
  • エッジ
  • エッジペア
  • エッジ幅
  • ビードファインダー
  • ビードトラッカー
閉じた キャリブレーションツール

ジョブ間で共有可能なキャリブレーションファイルを作成します。

キャリブレーションツール | In-Sight ビジョンシステム | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
ロボット | X |  |  |  |  |
N 点 | X |  |  |  |  | X
シーケンス N 点 | X |  |  |  |  |

有無判定ツール

寸法測定ツール

計数ツール

識別ツール

幾何・計測ツール

演算＆ロジックツール

プロットツール

画像フィルタツール

キャリブレーションツール


輝度有無判定ツール

輝度有無判定ツールは、領域内ピクセルの平均グレー値 (＝輝度) を基に特徴の有無を判定し、 その値を表示します。

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズ 1XX ビジョンセンサ (110、120、130) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 標準の結果 (制限無し)

輝度有無判定ツールは、良品の特徴が不良品の特徴と比較して非常に黒い、または白い場合に有用です。 特徴の輝度の上昇または低下は、検査対象物の有無を示します。 例えば、領域内の輝度を計測することによって、黒または白の瓶キャップの有無をすばやく判定することができます。

ヒント : 特徴を選択する際の詳細については、特徴を選択するにはをご参照ください。

ツールを設定するには

ツールのパラメータを調整するには


輝度有無判定ツールを設定するには

ツールを追加したら、特徴検査領域を定義します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 特徴の全体を囲むように領域を配置します (領域は、特徴のみ含めるようにしてください。領域が特徴より大きいと、背景の輝度も測定されてしまうため、不正確な結果が返されることがあります)。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにするか、または特徴が移動しても十分にカバーできる大きさに領域を設定してください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。

特徴を選択するには


特徴を選択するには

特徴を選択する際には、次のガイドラインを参考にしてください。

  • フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにしてください。または、特徴が移動しても十分にカバーできる大きさに領域を設定するようにするにしてください。
  • 輝度ツールは、検査対象に単一のグレー値 (黒または白など) のみ存在するといったアプリケーションに有用です。
閉じた 例

この例では、ボトルキャップ対し、2 つのエッジ位置決めツールが、2 つの検査ツールをフィクスチャするために使用されています。1 つは輝度ツールで、液体の有無を検知するための領域が設定されています。もう 1 つは、コントラストツールで、ボトルキャップが締められているかどうかを検知するための領域が設定されています。輝度ツールは液体部分に領域が設定されています。これは、液体がボトルに入っている場合、単一のグレー値 (約10～20) となり、入っていない場合はグレー値が 255 となるためです。シールが破けた場合にグレー値が複数となるため、コントラストツールの領域は、ボトルキャップ部分に設定されています。


輝度有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

In-Sight 2000 シリーズビジョンセンサ

  • [ツールの編集] グループボックス

In-Sight ビジョンシステム

輝度有無判定ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ
  • [ヒストグラム] タブ
  • [合成領域] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

In-Sight 2000 シリーズビジョンセンサ

In-Sight ビジョンシステム

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder ヘルプ | 08/29/2022 | Revision: 5.9.0.2


輝度有無判定ツールのパラメータを調整するには

注 : このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。In-Sight ビジョンシステムに接続している場合、輝度有無判定ツールのパラメータを調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

閉じた PASS/FAIL インジケータ

緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。

閉じた [輝度メータおよび PASS 範囲] スライダーコントロール

最小および最大輝度レベルを設定します。 ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を設定することができます。

ヒント : 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。
  • 左ハンドル: 平均グレースケール値の最小許容範囲を設定します。(0 - 255)
  • 右ハンドル: 平均グレースケール値の最大許容範囲を設定します。(0 - 255)
  • 結果インジケータ: 領域内のピクセルの平均グレースケール値を表示します。インジケータが左右ハンドルの間にある場合、ツールは PASS となり、結果インジケータは緑で表示されます。そうでない場合、ツールは FAIL となり、結果インジケータは赤で表示されます。
PASS
FAIL
注 : スライダコントロール上にマウスポインタを重ねると、最大値が表示されます。
閉じた [自動] ボタン

最大結果値の +/-10% を最新のツール結果に加算し、制限範囲を自動的に設定します。例えば、最大結果値が 255 で、最新のツール結果が 150 の場合、[自動] ボタンをクリックすると、最小制限範囲は 125 (=150-25)、最大制限範囲は 175 (=150+25) に自動的に設定されます。

閉じた 結果を反転

ON にした場合、結果が制限範囲内にあると、ツール結果は FAIL となります。(デフォルト = OFF)

PASS/FAIL | (反転) | PASS/FAIL
PASS/FAIL | (反転) | PASS/FAIL
閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 名前

輝度ツールの名前を定義します。 デフォルト名は輝度_1 で、末尾の番号はツールの追加に応じて増加します。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
閉じた フィクスチャ

ツールに使用するフィクスチャを選択します。フィクスチャコントロールが有効な場合、[フィクスチャ] ボタンはオレンジ色になります。

注 : このコントロールは、フィクスチャを定義するツールがすでに追加されている場合のみ、有効になります。
閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[全般] タブ (輝度有無判定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は輝度_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (輝度有無判定ツール)

閉じた 最大

最大グレー値 (0～255) を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 輝度

領域内に検出されたピクセルの平均グレー値 (0～255) を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

閉じた 最小

最小グレー値 (0～255) を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[ヒストグラム] タブ (輝度有無判定ツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の 3 本の垂直線は、[最小]、[輝度] および [最高] パラメータのグレー値 (ピクセル) を順番に表します。
注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


[合成領域] タブ (輝度有無判定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


コントラスト有無判定ツール

コントラスト有無判定ツールは、領域内のピクセル特徴間のコントラスト値を基に、特徴の有無を判定し、その値を表示します。 (コントラスト値とは、しきい値以上の平均グレー値としきい値以下の平均グレー値の差分を示す値です) 。

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズ 1XX ビジョンセンサ (110、120、130) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 標準の結果 (制限無し)

コントラスト有無判定ツールは、良品の特徴に、不良品の特徴と比較して非常に白い、または黒いエリアがある場合に有用です。 例えば、白ラベル上の黒い印字の有無を検証する場合などです。

ヒント : 特徴を選択する際の詳細については、特徴を選択するにはをご参照ください。

ツールを設定するには


コントラスト有無判定ツールを設定するには

ツールを追加したら、特徴検査領域を定義します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 特徴の全体を囲むように領域を配置します (領域は、特徴のみ含めるようにしてください。領域が特徴より大きいと、背景の輝度も測定されてしまうため、不正確な結果が返されることがあります)。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにするか、または特徴が移動しても十分にカバーできる大きさに領域を設定してください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。

特徴を選択するには

ツールのパラメータを調整するには


特徴を選択するには

特徴を選択する際には、次のガイドラインを参考にしてください。

  • フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにしてください。または、特徴が移動しても十分にカバーできる大きさに領域を設定するようにするようにしてください。
  • コントラストツールは、検査対象に特徴が存在する場合に複数のグレー値が含まれ、存在しない場合にグレー値が均一となるといったアプリケーションに有用です。
  • 輝度やコントラストより微妙な差別化がアプリケーションに必要な場合、ピクセル計数ツールを使用してください。ピクセル計数ツールは、コントラストツールより差異を正確に計測することができます。
閉じた 例

この例では、ボトルキャップ対し、2 つのエッジ位置決めツールが、2 つの検査ツールをフィクスチャするために使用されています。1 つは輝度ツールで、液体の有無を検知するための領域が設定されています。もう 1 つは、コントラストツールで、ボトルキャップが締められているかどうかを検知するための領域が設定されています。輝度ツールは液体部分に領域が設定されています。これは、液体がボトルに入っている場合、単一のグレー値 (約10～20) 、入っていない場合はグレー値が 255 となるためです。シールが破けた場合に、複数のグレー値となるため、コントラストツールの領域は、ボトルキャップ部分に設定されています。


コントラスト有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

In-Sight 2000 シリーズビジョンセンサ

  • [ツールの編集] グループボックス

In-Sight ビジョンシステム

コントラスト有無判定ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ
  • [ヒストグラム] タブ
  • [合成領域] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

In-Sight 2000 シリーズビジョンセンサ

In-Sight ビジョンシステム

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder ヘルプ | 08/29/2022 | Revision: 5.9.0.2


コントラスト有無判定ツールのパラメータを調整するには

注 : このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。In-Sight ビジョンシステムに接続している場合、コントラスト有無判定ツールのパラメータを調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

閉じた PASS/FAIL インジケータ

緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。

閉じた コントラストメータおよび PASS 範囲

最小および最大コントラストレベルを設定します。 ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を設定することができます。

ヒント : 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。
  • 左ハンドル: 平均グレースケール値の最小許容範囲を設定します。(0 - 255)
  • 右ハンドル: 平均グレースケール値の最大許容範囲を設定します。(0 - 255)
  • 結果インジケータ: 領域内のピクセルの平均グレースケール値を表示します。インジケータが左右ハンドルの間にある場合、ツールは PASS となり、結果インジケータは緑で表示されます。そうでない場合、ツールは FAIL となり、結果インジケータは赤で表示されます。
PASS
FAIL
注 : スライダコントロール上にマウスポインタを重ねると、[結果] が表示されます。
閉じた [自動] ボタン

最大結果値の +/-10% を最新のツール結果に加算し、制限範囲を自動的に設定します。例えば、最大結果値が 255 で、最新のツール結果が 150 の場合、[自動] ボタンをクリックすると、最小制限範囲は 125 (=150-25)、最大制限範囲は 175 (=150+25) に自動的に設定されます。

閉じた 結果を反転

ON にした場合、結果が制限範囲内にあると、ツール結果は FAIL となります。(デフォルト = OFF)

PASS/FAIL | (反転) | PASS/FAIL
PASS/FAIL | (反転) | PASS/FAIL
閉じた 名前

検査ツールの名前を定義します。 デフォルト名はコントラスト_1 で、末尾の番号はツールの追加に応じて増加します。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
閉じた フィクスチャ

ツールに使用するフィクスチャを選択します。フィクスチャコントロールが有効な場合、[フィクスチャ] ボタンはオレンジ色になります。

注 : このコントロールは、フィクスチャを定義するツールがすでに追加されている場合のみ、有効になります。
閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[全般] タブ (コントラスト有無判定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はコントラスト_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (コントラスト有無判定ツール)

閉じた 最大

最大コントラスト値 (0～255) を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた コントラスト

「スマート」しきい値上下の平均グレー値間の差を表示します。値が [最小]～[最大] の範囲内にある場合、 PASS を返します。

閉じた 最小

最小コントラスト値 (0～255) を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[ヒストグラム] タブ (コントラスト有無判定ツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の 3 本の垂直線は、しきい値下の平均グレー値、しきい値、およびしきい値上の平均グレー値を順番に表します。
注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


[合成領域] タブ (コントラスト有無判定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


PatMax RedLine パターン および PatMax パターン有無判定ツール

注 :
  • In-Sight ファームウェア 5.5.0 以降、ツールのアルゴリズムが変更され、条件によっては、より正確な結果を返すようになり、実行時間が短縮されました。
  • この変更により、In-Sight ファームウェア 5.5.0 以降で作成されたこのツールを含むジョブを、ファームウェアバージョン 5.4.x 以前を搭載した In-Sight ビジョンシステムにロードしようとすると、エラーメッセージが表示されます。
  • PatMax RedLine パターンおよび PatMax RedLine パターン (1-10) 位置決めツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターン および PatMax パターン有無判定ツールは、登録済みのパターン (モデルと呼ばれます) を基に、PatMax RedLine または PatMax アルゴリズムを使用して、パターンの有無を決定します。

これらのツールは、不良品にはなく良品に認識できる特徴がある場合に、あるいはその逆の場合に有用です。 例えば、機械の組み立てにおいてネジ山の有無を検証する場合などです。

ツールを設定するには

ツールのパラメータを調整するには


PatMax RedLine パターンおよび PatMax パターン有無判定ツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

  1. [モデル] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [サーチ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。
  3. [OK] ボタンを押し、2 つの領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。

PatMax RedLine パターン、PatMax パターンおよびパターン

パターンを選択するには


PatMax RedLine パターン、PatMax パターンおよびパターン

注 : PatMax RedLine パターン有無判定ツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターン、PatMax パターンおよびパターンツールは、どちらも登録済みのモデルパターンを検出する、最も高精度な検査ツールです。中でも PatMax RedLine パターンおよび PatMax パターンツールは、照明の条件やパターンのポジションが大幅に変わっても特徴を検出できるため、より強力な検査ツールと言えます。PatMax RedLine パターンおよび PatMax パターンツールは、スケール変化、回転、部分的な遮蔽、照明のばらつきによる外観変化に対しても、より優れた認識能力を発揮します。

PatMax RedLine パターンと PatMax パターンの主な違いはそのスピードにあります。PatMax RedLine パターンは最新のパターンマッチアルゴリズムを使用し、5 メガピクセルの画像内の登録した特徴を PatMax パターンの最大 7 倍の速さで検出します。よって、PatMax RedLine パターンは高解像度のビジョンシステムに最適と言えます。

通常、パターンツールは PatMax パターンツールより高速に動作します。しかし、次のような状況では PatMax RedLine または PatMax パターンツールの正確性および信頼性が必要とされる場合があります。

  • 照明のばらつきや反射の抑制が困難な場合 (例: 光を乱反射しやすい金属物を検査する場合)。
  • 検査対象物に似た形状やシェーディングが背景上にある場合、またはパターンが重なっていたり、他の物体によって部分的に隠蔽されていたりする場合。
  • 他の類似したパターンを除外し、目的の検査パターンを正確に検出したい場合。
  • 設置環境の状態によって、パターンツールでは一貫した信頼性のある検査を実行できない場合。


パターンを選択するには

パターンを選択する際には、次のガイドラインを参考にしてください。

  • そのパターンがすべての画像に存在していること。
  • ユニーク性の高い特徴や一貫性の高い特徴をできるだけ多くそのパターンに含めること。また、検査対象物全体の形状に対してそのパターンが常に一定の位置に、かつ明確に存在すること。
  • できるだけ大きなパターンを選択すること。大きなパターンはユニークな特徴を多く含むため、それだけ一貫した正確な検査を行うことができます。


PatMax RedLine パターンおよび PatMax パターン有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

PatMax RedLine パターンおよび PatMax パターン有無判定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [モデル] および [サーチ] タブ
  • [登録画像] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[モデル] および [サーチ] タブ

[登録画像] タブ


[全般] タブ (PatMax RedLine パターンおよび PatMax パターン有無判定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (PatMax RedLine パターンおよび PatMax パターン有無判定ツール)

閉じた アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。 この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。 この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。 設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

閉じた コントラストしきい値

検出パターンに存在する必要のある、最小コントラスト値を指定します。有効なインスタンスとみなすには、検出パターンのコントラストが [コントラストしきい値] より高い必要があります。PatMax RedLine パターンではデフォルト = 0、有効なパラメータ範囲は 0～100 です。PatMax パターンではデフォルト = 10、有効なパラメータ範囲は 0～255 です。低コントラストの画像には、低いコントラストしきい値が使用され、高コントラストの画像には、高いコントラストしきい値が使用されます。

注 : PatMax RedLine パターンでは、登録パターン内の特徴とサーチ画像内のマッチする特徴との間のコントラスト差をパーセンテージで表した、「相対」コントラストが報告されます。よって、特徴のコントラストがパターンコントラストと同じまたはより高い場合、報告されるコントラストは ~100 となります。特徴のコントラストがパターンコントラストより低い場合、報告されるコントラストは <100 となります。PatMax RedLine パターンのコントラストは PatMax パターンのコントラストは異なります。PatMax パターンでは、サーチ ROI 内の「絶対」画像コントラストがグレースケール値で報告されます。
閉じた 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。 大きな値を設定すると、ツールの実行時間が増大します。

閉じた スケール許容

モデルパターンの大きさを基準とした、検出パターンで許容されるスケール変化量を指定します (0～50、デフォルトは 0% です)。この値を 5 に設定すると、モデルの大きさに対して 95～105% のサイズのパターンが検出対象となります。大きな値を設定すると、ツールの実行時間が増大します。

閉じた 検出モード

パターンの登録および認識に使用されるサーチモードを指定します。選択肢は、[PatMax] (デフォルト) または [PatQuick] です。 デフォルトでは、[PatMax] が選択されています。 PatMax は、PatQuick より高精度ですが、実行時間が長くなります。一方、PatQuick は、PatMax より精度が低いですが、実行時間は短くなります。

閉じた クラッタ

モデルパターンと比較して、検出パターンの欠落または遮蔽された特徴を得点に考慮するかどうかを定義します。デフォルトは OFF、すなわち欠落があっても得点は減点されません。 クラッタを ON にすると、検出パターン中の特徴欠落によって得点が減点されます。

閉じた クラッタ

モデルパターンと比較して、検出パターンの欠落または遮蔽された特徴を得点に考慮するかどうかを定義します。デフォルトは OFF、すなわち欠落があっても得点は減点されません。 クラッタを ON にすると、検出パターン中の特徴欠落によって得点が減点されます。

閉じた 極性を無視

モデルパターンに対し、カラー変換したマッチ特徴を検出パターンに含むかどうか指定します (デフォルト = OFF)。[極性を無視] を ON にすると、例えば、モデルパターン内の黒/白 vs. 白/黒など、カラー変換した特徴を含む検出パターンが、モデルパターンにマッチしていると分類されます。

閉じた 反転
ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。 ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた タイムアウト
ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。デフォルトで、このパラメータは 5,000 に設定されています。
閉じた 結果

ツールの結果が表示されます。パターン特徴が検出された場合は、[あり] が表示され、モデルパターンとの類似度が表示されます。パターン特徴が検出されなかった場合、または複数のインスタンスのパターンが検出された場合、[なし] が表示されます。[あり] はブール値 1（PASS） 、[なし] はブール値 0（FAIL）となります。

注 : PatMax RedLine パターンには、[検出モード] パラメータは含まれていません。


[モデル] および [サーチ] タブ (PatMax RedLine パターンおよび PatMax パターン有無判定ツール)

[モデル] および [サーチ] タブを使用して、ツールのモデルおよびサーチ領域の合成領域を設定します。 合成領域は、サブ領域 (矩形、円環、円またはポリゴン) の集合体で、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • [モデル] タブでは、[モデル領域] ボタンを押した後にのみ、合成領域を有効にすることができます。
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


[登録画像] タブ (PatMax RedLine パターンおよび PatMax パターン有無判定ツール)

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


パターン有無判定ツール

パターン有無判定ツールは、登録済みのパターン (モデルと呼ばれます) を基に、パターンの有無を決定します。

パターン有無判定ツールは、不良品にはなく良品に認識できる特徴がある場合に、あるいはその逆の場合に有用です。 例えば、機械の組み立てにおいてネジ山の有無を検証する場合などです。

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000-110 および 2000-120/120C ビジョンセンサ | PASS/FAIL ステータスのみ
In-Sight 2000-130/130C ビジョンセンサ | PASS/FAIL ステータスおよびパターンの得点
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 標準の結果 (制限無し)

ツールを設定するには

ツールのパラメータを調整するには


パターン有無判定ツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

  1. 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。

  2. パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。

    注 : モデルおよびサーチ領域は、円弧またはドーナツ状に曲げることはできません。
  3. [OK] ボタンを押し、2 つの領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


パターン有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

In-Sight 2000 シリーズビジョンセンサ

  • [ツールの編集] グループボックス

In-Sight ビジョンシステム

パターン有無判定ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [登録画像] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

In-Sight 2000 シリーズビジョンセンサ

In-Sight ビジョンシステム

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder ヘルプ | 08/29/2022 | Revision: 5.9.0.2


パターン有無判定ツールのパラメータを調整するには

注 :
  • このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。In-Sight ビジョンシステムに接続している場合、パターン位置決め/パターン位置決め (1-10) ツールのパラメータを調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。
  • このツールを In-Sight ファームウェア 5.7.0 以降で設定した場合、ファームウェアバージョン 5.6.x 以前を搭載した In-Sight ビジョンシステムにジョブをロードしようとすると、エラーメッセージが表示され、ジョブロードに失敗します。

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

閉じた PASS/FAIL インジケータ

緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。

閉じた 回転許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 45 度です。大きな値を設定すると、ツールの実行時間が増大します。左ハンドルはマイナスの回転許容値を、右ハンドルはプラスの回転許容値を設定します。ハンドルを調整したり、対応する編集ボックスに値を入力したりして、回転許容値を調整することができます。

ヒント : 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。
閉じた パーツ検出メータ

パーツ検出メータは、ツールがいかによく特徴を検出したかを表示し、最小アクセプトしきい値を設定します。最小アクセプトしきい値は、手動で設定することができます。ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を調整してください。

ヒント : 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

メータの示す値がしきい値より高い場合、パーツは検出されたとみなされ、メータは緑で表示されます。しきい値より低い場合、パーツは検出されなかったとみなされ、メータは表示されなくなります。パーツ以外の物を検出したり、間違った特徴を検出したりしている場合、ハンドルを右に動かしてください。パーツ検出に失敗している場合、ハンドルを左に動かしてください (または、モデル領域を新規作成してください)。設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

PASS
FAIL
注 : スライダコントロール上にマウスポインタを重ねると、[結果] および [しきい値] が表示されます。
閉じた 結果を反転

ON にした場合、結果が制限範囲内にあると、ツール結果は FAIL となります。(デフォルト = OFF)

PASS/FAIL | (反転) | PASS/FAIL
PASS/FAIL | (反転) | PASS/FAIL
閉じた ±10% スケール許容

検出パターンとモデルパターン間の ±10% のスケール変化を許容するかどうかを指定します。

登録パターン | 検出パターン: +10% | 検出パターン: -10%
OFF (デフォルト) | (FAIL) | (FAIL)
ON | (PASS) | (PASS)
閉じた 手動タイムアウトを使用する

タイムアウト設定を使用するかどうかを指定します。

  • OFF (デフォルト): タイムアウト設定は無効です (タイムアウトしません)。

  • ON: タイムアウト設定を有効にします。 編集ボックスを使用して、手動でタイムアウト値をミリ秒単位で指定します。(0 ～ 30000)

    注 : 値を 0 に設定すると設定が無効になり、タイムアウトは適用されません。
閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 名前

検査ツールの名前を定義します。 デフォルト名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
閉じた フィクスチャ

ツールに使用するフィクスチャを選択します。フィクスチャコントロールが有効な場合、[フィクスチャ] ボタンはオレンジ色になります。

注 : このコントロールは、フィクスチャを定義するツールがすでに追加されている場合のみ、有効になります。
閉じた 登録の入力

モデルパターンを入力ラインを介して登録するかどうかを定義します。デフォルトは OFF で、無効です。

  • 入力: モデルパターンを入力ラインを介して登録します。 選択した入力ラインは、登録シグナルとして使用されます。

    注 :
    • このオプションは、In-Sight ビジョンシステムにディスクリート入力がない場合 (例えば、直接接続 I/O を使用している In-Sight 8000 シリーズビジョンシステムなど) 、表示されません。
    • 入力/出力ステップで、 選択した入力ラインの [信号タイプ] を [イベントトリガ] に設定してください。
    • モデルパターンの登録には、ビジョンシステム/センサが取り込んだ最新の画像が使用されます。 登録するために、ビジョンシステム/センサを再度トリガする必要はありません。
    • 詳細については、 入力: 入力ラインを介してモデルパターンを登録するにはをご参照ください。
閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

閉じた モデル領域

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


[全般] タブ (パターン有無判定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([画像の設定]、[入力/出力] および [通信]) で参照されます。デフォルトのツール名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (パターン有無判定めツール)

閉じた 登録の入力

モデルパターンを入力ラインを介して登録するかどうかを定義します。デフォルトは OFF で、無効です。

  • 入力: モデルパターンを入力ラインを介して登録します。 選択した入力ラインは、登録シグナルとして使用されます。

    注 :
    • このオプションは、In-Sight ビジョンシステムにディスクリート入力がない場合 (例えば、直接接続 I/O を使用している In-Sight 8000 シリーズビジョンシステムなど) 、表示されません。
    • 入力/出力ステップで、 選択した入力ラインの [信号タイプ] を [イベントトリガ] に設定してください。
    • モデルパターンの登録には、ビジョンシステム/センサが取り込んだ最新の画像が使用されます。 登録するために、ビジョンシステム/センサを再度トリガする必要はありません。
    • 詳細については、 入力: 入力ラインを介してモデルパターンを登録するにはをご参照ください。
閉じた アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。 この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。 この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。 設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

閉じた 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。 大きな値を設定すると、ツールの実行時間が増大します。

閉じた スケール許容

検出パターンのスケール変化 (±10% 以内) を許容するかどうかを指定します。 デフォルトは OFF です。大きな値を設定すると、ツールの実行時間が増大します。 スケール許容を ON にすると、±10% の範囲でパターンを検出しますが、スケール変化量が大きくなるほど、特徴の得点は低くなります。

閉じた 反転
ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。 ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた モデルタイプ

ツールが、どのようにモデルパターンを作成するかを定義します。選択肢は、[エリアモデル] または [エッジモデル] です。[エリアモデル] は、モデル領域からのグレースケース値の均一サンプリングに基づいてパターンを作成します。[エッジモデル] は、モデル領域内のパターンの検出エッジ (白/黒の遷移) に基づいて、モデルパターンを作成します。

閉じた 高精度モード

ツールがどのように精度/信頼性と実行速度のトレードオフを評価するか定義します。選択肢は、[高精度]、[中程度] (デフォルト) および [高速] です。[高精度] は、精度/信頼性が高くなる反面、実行速度が遅くなります。[高速] は、実行速度が速くなる反面、精度/信頼性が低くなります。[中程度] は、その中間を取るように指定します。

閉じた タイムアウト

ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

閉じた 結果

ツールの結果が表示されます。パターン特徴が検出された場合は、[あり] が表示され、モデルパターンとの類似度が表示されます。パターン特徴が検出されなかった場合、または複数のインスタンスのパターンが検出された場合、[なし] が表示されます。 [あり] はブール値 1 (PASS) 、[なし] はブール値 0 (FAIL) となります。


登録画像タブ (パターン有無判定ツール)

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


ピクセル計数有無判定ツール

ピクセル計数有無判定ツールは、領域内の白または黒のピクセル数を基に、特徴の有無を判定し、その値を表示します。

このツールは、白黒ピクセル間の画像を切り分けるグレーしきい値 (0～255) の最適な値を計算し、しきい値以上または以下 (設定によって異なります) のピクセル数をカウントします。

ピクセル計数有無判定ツールは、領域内の白または黒ピクセル数を基に、特徴の有無を判定する場合に有用です。 例えば、回路基板リードの周囲に適切な量のはんだが施されたかどうか、またはラベル上にインクジェットの文字列があるかどうかを検証する場合などです。

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズ 1XX ビジョンセンサ (110、120、130) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 標準の結果 (制限無し)

ツールを設定するには

ツールのパラメータを調整するには


ピクセル計数有無判定ツールを設定するには

ツールを追加したら、特徴検査領域を定義します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 特徴の全体を囲むように領域を配置します (領域は、特徴のみ含めるようにしてください。領域が特徴より大きいと、背景の輝度も測定されてしまうため、不正確な結果が返されることがあります)。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにするか、または特徴が移動しても十分にカバーできる大きさに領域を設定してください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。

特徴を選択するには


特徴を選択するには

特徴を選択する際には、次のガイドラインを参考にしてください。

  • フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在すること。または、特徴が移動しても十分にカバーできる大きさに領域を設定するようにすること。
  • ピクセル計数は、検査対象に特徴が存在する場合に複数のグレー値が含まれ、存在しない場合にグレー値が均一となるといったアプリケーションに有用です。
  • ピクセル計数ツールは、輝度とコントラストの間の微妙な違いを差別化することができます。したがって、輝度有無判定ツールやコントラスト有無判定ツールより正確に差異を計測することができます。
閉じた 例

この例では、はんだパッドが適切に基板とリードにはんだ付けされていることを確認するため 3 つのピクセル計数ツールが使用され、さらにこの 3 つのピクセル計数をフィクスチャするために、2 つのエッジ位置決めツールが回路基板のコントラストの高いエッジで使用されています。


ピクセル計数有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

In-Sight 2000 シリーズビジョンセンサ

  • [ツールの編集] グループボックス

In-Sight ビジョンシステム

ピクセル計数有無判定ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • [ヒストグラム] タブ
  • [合成領域] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

In-Sight 2000 シリーズビジョンセンサ

In-Sight ビジョンシステム

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder ヘルプ | 08/29/2022 | Revision: 5.9.0.2


ピクセル計数有無判定ツールのパラメータを調整するには

注 : このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。In-Sight ビジョンシステムに接続している場合、ピクセル計数有無判定ツールのパラメータを調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

閉じた PASS/FAIL インジケータ

緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。

閉じた ピクセルセレクタ

白黒ピクセルのエリアを、どのように切り分けるかを定義します。 デフォルトでは、黒ピクセルの数がカウントされ、領域内の黒ピクセルが黄色にハイライトされて表示されます。

オリジナル画像
選択されたピクセルの色 = 黒

左ハンドルはしきい値 (低) を、右ハンドルはしきい値 (高) を設定します (0～255)。 ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を設定することができます。

ヒント : 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

白ピクセルの数をカウントするには、 [image] を押してください。 領域内の白ピクセルが黄色にハイライトされて表示されます。

選択されたピクセルの色 = 白
閉じた [自動] ボタン

最大結果値の +/-10% を最新のツール結果に加算し、制限範囲を自動的に設定します。例えば、最大結果値が 255 で、最新のツール結果が 150 の場合、[自動] ボタンをクリックすると、最小制限範囲は 125 (=150-25)、最大制限範囲は 175 (=150+25) に自動的に設定されます。

閉じた ピクセル計数メータおよび PASS 範囲

領域内で許容されるピクセル数を指定します。 ハンドルを使用して、黒または白ピクセルの最小および最大数を設定します。カウントされたピクセル数が設定範囲内であれば、ツールは PASS となります。

PASS
FAIL

結果が左右ハンドルの間にある場合、ツールは PASS となり、メータが緑色の線で囲われます。 そうでない場合、ツールは FAIL となり、赤い線で囲われます。

ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を設定することができます。

ヒント : 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。
注 : スライダコントロール上にマウスポインタを重ねると、[結果] (領域内で検出されたピクセルの数) および [PASS 範囲] が表示されます。
閉じた 結果を反転

ON にした場合、結果が制限範囲内にあると、ツール結果は FAIL となります。(デフォルト = OFF)

PASS/FAIL | (反転) | PASS/FAIL
PASS/FAIL | (反転) | PASS/FAIL
閉じた 詳細の表示

カウントされたピクセルを EasyBuilder の画像エリアに常に表示するかどうかを定義します (黄色でハイライトされます)。

ヒント: カウントされたピクセルを VisionView で表示するには、[通信] アプリケーションステップの EasyView 内で [詳細の表示] シンボリック名を選択し、VisionView アプリケーション上の Show_Details チェックボックスを ON にします。 VisionView 上でのデータの表示方法についての詳細は、EasyView を設定するにはをご参照ください。

  • ON ( [image] = デフォルト): カウントされたピクセルは常に画像エリアに表示されます。ただし、他の位置決めまたは検査ツールが編集されている場合は除きます。

  • OFF ( [image]): このツールが編集されているときのみ、カウントされたピクセルは画像エリアに表示されます。

閉じた 選択したピクセルを反転させる

カウントするピクセルの色を変更します (黒 [image] または白 [image] 、デフォルト = 黒)

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 名前

検査ツールの名前を定義します。 デフォルト名はピクセル_1 で、末尾の番号はツールの追加に応じて増加します。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
閉じた フィクスチャ

ツールに使用するフィクスチャを選択します。フィクスチャコントロールが有効な場合、[フィクスチャ] ボタンはオレンジ色になります。

注 : このコントロールは、フィクスチャを定義するツールがすでに追加されている場合のみ、有効になります。
閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[全般] タブ (ピクセル計数有無判定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はピクセル_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (ピクセル計数有無判定ツール)

閉じた しきい値モード

画像領域を白黒のピクセルに切り分けるグレー値を決める方法を指定します。[自動] (デフォルトは [自動]) を選択した場合、画像取り込みのたびにツールは画像に基づいてスマートセッティングを作成し、画像間の輝度の変化を調整します。[手動] を選択した場合、2 つのしきい値の値を手動で入力、調整してください。

閉じた しきい値 (低)

白ピクセルを黒ピクセルから切り分けるグレー値を定義します (0～255、有効時)。[しきい値 (高)] で設定した値 ≤ [しきい値 (低)] で設定した値の場合、白ピクセルは [しきい値 (低)] ≤ 値 ≤ [しきい値 (高)] として指定されます。また、[しきい値 (高)] < [しきい値 (低)] の場合、白ピクセルは、値 ≤ [しきい値 (高)] または [しきい値 (低)] ≤ 値として指定されます。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。[ヒストグラム] タブのグラフを参考にして、最適な値を設定してください。

  • しきい値 (低) ≤ しきい値 (高): 実際のグレースケール値に関わらず、2 つのしきい値の範囲内のすべての値は「白」とみなされ、 範囲外の値は「黒」とみなされます。
  • しきい値 (高) ≤ しきい値 (低): 実際のグレースケール値に関わらず、2 つのしきい値の範囲内のすべての値は「黒」とみなされ、 範囲外の値は「白」とみなされます。
閉じた しきい値 (高)

白ピクセルを黒ピクセルから切り分けるグレー値を定義します (0～255、有効時)。[しきい値 (高)] で設定した値 ≥ [しきい値 (低)] で設定した値の場合、白ピクセルは [しきい値 (低)] ≤ 値 ≤ [しきい値 (高)] として指定されます。また、[しきい値 (高)] < [しきい値 (低)] の場合、白ピクセルは、値 ≤ [しきい値 (高)] または [しきい値 (低)] ≤ 値として指定されます。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。[ヒストグラム] タブのグラフを参考にして、最適な値を設定してください。

  • しきい値 (低) ≤ しきい値 (高): 実際のグレースケール値に関わらず、2 つのしきい値の範囲内のすべての値は「白」とみなされ、 範囲外の値は「黒」とみなされます。
  • しきい値 (高) ≤ しきい値 (低): 実際のグレースケール値に関わらず、2 つのしきい値の範囲内のすべての値は「黒」とみなされ、 範囲外の値は「白」とみなされます。
閉じた 極性

ピクセルの色を定義します。選択肢は、黒または白 (デフォルト) です。


[制限範囲] タブ (ピクセル計数有無判定ツール)

閉じた 最大

領域内の最大ピクセル数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた ピクセル

領域内に検出されたピクセル数を表示します。値は 0～ [最大] で設定された値となります。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

閉じた 最小

領域内の最小ピクセル数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[ヒストグラム] タブ (ピクセル計数有無判定ツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の垂直線は、画像の黒い部分と白い部分を切り分けるしきい値を表します。垂直線より左側が黒、右側が白とみなすことができます。
注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


[合成領域] タブ (ピクセル計数有無判定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


カラーピクセル計数有無判定ツール

カラーピクセル計数有無判定ツールは、カラーテーブル内の登録カラーにマッチするピクセル数 (In-Sight 2000 シリーズカラービジョンセンサ) または登録ライブラリの選択したカラーモデル領域にマッチする領域内のピクセル数 (In-Sight カラービジョンシステム) を基に特徴の有無を判定し、値を返します。

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズ 1XX ビジョンセンサ (110、120、130) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 標準の結果 (制限無し)

ツールを設定するには

ツールのパラメータを調整するには


カラーピクセル計数有無判定ツールを設定するには

ツールを追加したら、特徴検査領域を定義します。

In-Sight 2000 シリーズカラービジョンセンサ

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 特徴の全体を囲むように領域を配置します (領域は、特徴のみ含めるようにしてください。領域が特徴より大きいと、背景の輝度も測定されてしまうため、不正確な結果が返されることがあります)。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにするか、または特徴が移動しても十分にカバーできる大きさに領域を設定してください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、ツールのカラー設定を登録します。

    注 : カラーを選択するまで、ツールの結果はデフォルトで自動的に FAIL となります。
  4. [カラーの登録] ボタンを押します。 カラー登録コンテキストペインが開きます。
  5. をクリックして、カラーを追加します。
  6. カーソルを画像エリアに動かします。 コンテキストペインに、カラーを選択しやすいよう、拡大画像が表示されます。

  7. クリックして、カラーを選択します。 選択後、カラーは下のカラーテーブルに追加され、選択したカラーにマッチする領域内のピクセルが黄色で表示されます。

    カラー追加前 カラーの選択 カラー追加後
  8. ステップ 6～7 を繰り返して、カラーテーブルに必要なカラーを追加します。
  9. カラーを減算するには、 [image] をクリックしてステップ 6～8 を繰り返します。
  10. [カラー選択の終了] ボタンをクリックして、全般コンテキストペインに戻ります。
  11. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  12. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他の外部デバイスへ出力します。

In-Sight カラービジョンシステム

カラーピクセル計数有無判定ツールは、登録済みカラーモデルライブラリを参照し、選択した登録済みカラーモデルにマッチする領域内のピクセル数を決定します。 ツールは、その後、有効なカラーモデルにマッチする各ピクセルを白 (255) に、それ以外のピクセルを黒 (0) に設定する、2 値化グレースケール出力画像を作成します。 この 2 値化出力画像を使用して、画像をサーチし、有効なカラーモデルにマッチするピクセル数を記録します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 特徴の全体を囲むように領域を配置します (領域は、特徴のみ含めるようにしてください。領域が特徴より大きいと、背景の輝度も測定されてしまうため、不正確な結果が返されることがあります)。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにするか、または特徴が移動しても十分にカバーできる大きさに領域を設定してください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。

    • カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。

    • カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブで使用する [カラーライブラリ] を選択してから、[ライブラリ] タブで使用する [カラーモデル] のチェックボックスを ON にします。

    • [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  4. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


カラーピクセル計数有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

In-Sight 2000 シリーズビジョンセンサ

  • [ツールの編集] グループボックス

In-Sight ビジョンシステム

ピクセル計数有無判定ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • [ライブラリ] タブ
  • [合成領域] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

In-Sight 2000 シリーズビジョンセンサ

In-Sight ビジョンシステム

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder ヘルプ | 08/29/2022 | Revision: 5.9.0.2


カラーピクセル計数有無判定ツールのパラメータを調整するには

注 : このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。In-Sight ビジョンシステムに接続している場合、ピクセル計数有無判定ツールのパラメータを調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

全般コンテキストペイン

閉じた PASS/FAIL インジケータ

緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。

閉じた カラーの登録

カラー登録コンテキストペインを開きます。

閉じた カラータイル

カラー登録コンテキストペインで [追加カラーの選択] [image] ボタンを使用して追加した、最初の 5 色の登録カラーを表示します。 カラータイルをクリックすると、カラー登録コンテキストペインが開きます。

閉じた ピクセル計数メータおよび PASS 範囲

領域内で許容されるピクセル数を指定します。 ハンドルを使用して、ピクセルの最小および最大数を設定します。カウントされたピクセル数が設定範囲内であれば、ツールは PASS となります。

PASS
FAIL

結果が左右ハンドルの間にある場合、ツールは PASS となり、メータが緑色の線で囲われます。 そうでない場合、ツールは FAIL となり、赤い線で囲われます。

ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を設定することができます。

ヒント : 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。
注 : スライダコントロール上にマウスポインタを重ねると、[結果] (領域内で検出されたピクセルの数) および [PASS 範囲] が表示されます。
閉じた [自動] ボタン

最大結果値の +/-10% を最新のツール結果に加算し、制限範囲を自動的に設定します。例えば、最大結果値が 255 で、最新のツール結果が 150 の場合、[自動] ボタンをクリックすると、最小制限範囲は 125 (=150-25)、最大制限範囲は 175 (=150+25) に自動的に設定されます。

閉じた 結果を反転

ON にした場合、結果が制限範囲内にあると、ツール結果は FAIL となります。(デフォルト = OFF)

PASS/FAIL | (反転) | PASS/FAIL
PASS/FAIL | (反転) | PASS/FAIL
閉じた 詳細の表示

カウントされたピクセルを EasyBuilder の画像エリアに常に表示するかどうかを定義します (黄色でハイライトされます)。

ヒント: カウントされたピクセルを VisionView で表示するには、[通信] アプリケーションステップの EasyView 内で [詳細の表示] シンボリック名を選択し、VisionView アプリケーション上の Show_Details チェックボックスを ON にします。 VisionView 上でのデータの表示方法についての詳細は、EasyView を設定するにはをご参照ください。

  • ON ( [image] = デフォルト): カウントされたピクセルは常に画像エリアに表示されます。ただし、他の位置決めまたは検査ツールが編集されている場合は除きます。

  • OFF ( [image]): このツールが編集されているときのみ、カウントされたピクセルは画像エリアに表示されます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 名前

検査ツールの名前を定義します。 デフォルト名はカラーピクセル_1 で、末尾の番号はツールの追加に応じて増加します。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
閉じた フィクスチャ

ツールに使用するフィクスチャを選択します。フィクスチャコントロールが有効な場合、[フィクスチャ] ボタンはオレンジ色になります。

注 : このコントロールは、フィクスチャを定義するツールがすでに追加されている場合のみ、有効になります。
閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

カラー登録コンテキストペイン

閉じた [追加カラーの選択] および [減算カラーの選択] ボタン

  • 追加カラーの選択: 追加カラーをカラーテーブルに追加します。 領域内に存在するピクセルの数を決定する際に、このボタンで選択したカラーが計算に含まれます。 選択後、追加カラーにマッチする領域内のピクセルが黄色で表示されます。

    注 : このボタンを使用して追加した最初の 5 色のカラーは、「カラータイル」として全般コンテキストペインに表示されます。
    カラー追加前 カラー追加後
  • 減算カラーの選択: 減算カラーをカラーテーブルに追加します。 領域内に存在するピクセルの数を決定する際に、このボタンで選択したカラーは除外されます。

[追加カラーの選択] または [減算カラーの選択] ボタンのクリック後、カーソルを画像エリアに移動すると、カラーを選択しやすいように、コンテキストペインに拡大画像が表示されます。

拡大画像
閉じた カラーテーブル

  • カラー: [追加カラーの選択] および [減算カラーの選択] ボタンを使用して追加したカラーを表示します。

    注 : スライダコントロール上にマウスポインタを重ねると、RBG 値が表示されます。

  • 許容値: カラーの許容値を定義します (0 - 10; デフォルト = 2)。 許容値を上げる/下げると、登録カラーの色相がより多く/少なく含まれるようになります。

    注 : スライダコントロール上にマウスポインタを重ねると、許容値が表示されます。
    オリジナル画像

    許容値 = 0.5

             許容値 = 2 (デフォルト) 許容値 = 7
  • 操作:
    • カラー減算に変更: 領域内でカラーは黄色に表示され、領域内に存在するピクセルの数を決定する際に計算に含まれます。 このボタンはトグルです。カラー減算に変更するには、このボタンをクリックしてください。
    • カラー追加に変更: 領域内に存在するピクセルの数を決定する際に除外されます。 このボタンはトグルです。カラー追加に変更するには、このボタンをクリックしてください。

    • 上へ/下へ: テーブル内のカラーの操作順を変更します。 カラー操作は上から下の順番で実行されます。

    • カラーの削除: カラーをテーブルから削除します。
閉じた 輝度を無視

[輝度を無視] チェックボックスが ON の場合 (デフォルト)、登録カラーより暗い/明るいピクセルが多数、計算に含まれます。 このオプションを使用すると、画像の輝度が視野内を通して均一でない場合、ツールのパフォーマンスを上げることができます。 ただし、登録カラー以外の黒/白ピクセルを計算に含むべきでない場合、チェックボックスを OFF にしてください。

閉じた カラー選択の終了

[全般] コンテキストペインに戻ります。

カラー操作の例

閉じた 例

この例では、画像中の「青」と「緑」のチョークを選択します。

例 1

  1. 画像中の「青」と「緑」のチョークを [追加カラーの選択] [image] ボタンを使用して選択します。

    オリジナル画像 「青 (追加)」および「緑 (追加)」を選択

  2. その結果、紫のチョークも部分的にハイライトされてしまいます。これは、これらの色 (青、緑および紫) がよく似ているからです。 「紫」は「青」から派生しており (次の画像をご参照ください) 、青 (もしくはダークシアン) を選択すると、似た色が紫から選択されてしまいます。

  3. 次に、画像から「紫」を減算します。 紫のチョークのハイライトされた部分から、[減算カラーの選択] [image] ボタンを使用して、「紫」を選択します。

    「紫 (減算)」を選択
  4. 青と緑のチョークの選択に成功しました。

例 2

この例では、画像中の「青」と「緑」のチョークを選択します。ただし、カラー操作の順番が例 1 とは異なるため、望む結果が得られない可能性があります。

  1. 画像中の「青」のチョークを [追加カラーの選択] [image] ボタンを使用して選択します。

  2. [減算カラーの選択] [image] ボタンを使用して、「紫」を選択します。

    「青 (追加)」および「紫 (減算)」を選択

  3. 画像中の「緑」を [追加カラーの選択] [image] ボタンを使用して選択します。

    「緑 (追加)」を選択
  4. その結果、紫のチョークも部分的にハイライトされてしまいます。 これは、緑が紫によく似ているからです。 緑を選択すると、似た色が紫から選択されてしまいます。
  5. 画像から紫を取り除くには、[下へ] [image] ボタンを使用して紫のカラー操作を下に動かすか、 あるいは、[減算カラーの選択] [image] ボタンを使用して、「緑」の後に 2 番めの「紫」カラー操作を追加します。


[全般] タブ (カラーピクセル計数有無判定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラーブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーピクセル計数有無判定ツール)

閉じた [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

閉じた カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール


[制限範囲] タブ (カラーピクセル計数有無判定ツール)

閉じた 最大

領域内の最大ピクセル数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた ピクセル

領域内に検出されたピクセル数を表示します。値は 0～ [最大] で設定された値となります。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

閉じた 最小

領域内の最小ピクセル数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


カラーライブラリ (カラーピクセル計数有無判定ツール)

閉じた [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

閉じた カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

閉じた カラー名

選択したカラーモデルに含まれるカラー名を表示します。

閉じた RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

閉じた 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


[合成領域] タブ (カラーピクセル計数有無判定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


ブロブ有無判定ツール

ブロブ有無判定ツールは、ブロブの有無を判定します。 ブロブが検出された場合、[あり] を表示し、PASS となります。 ブロブが検出されなかったり、指定された範囲に合致しなかったりした場合、[なし] を表示し、結果は FAIL となります。

ブロブ有無判定ツールは、高速のツールの 1 つで、パターン有無判定ツールより短時間で特徴を検出することができます。 このツールは、ピクセルの塊の有無を判定するのに有用です。 例えば、型打ちした金属製品に穴があるかどうかを検証する場合などです。

ツールを設定するには

ツールのパラメータを調整するには


ブロブ有無判定ツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、ブロブが移動しても十分にカバーできる大きさに領域を設定してください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ブロブ有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ブロブ有無判定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [ヒストグラム] タブ
  • [合成領域] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

ヒストグラム

[合成領域] タブ


[全般] タブ (ブロブ有無判定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (ブロブ有無判定ツール)

閉じた しきい値モード

ブロブと背景を切り分けるためのグレー値を決める方法を指定します。[自動] を選択した場合、画像取り込みのたびに自動的にしきい値が計算されます。[手動] を選択した場合、常に [ブロブしきい値] の値が使用されます。デフォルトは [自動] です。

閉じた ブロブしきい値

ブロブと背景を切り分けるグレー値 (0～255) を定義します。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。グラフを参考にして、最適な値を設定してください。

閉じた ブロブの色

ブロブの色を定義します。選択肢は [黒]、[白]、[任意] (デフォルト) です。

  • 黒: ブロブしきい値より低いグレー値で構成されたブロブを返します。
  • 白: ブロブしきい値より高いグレー値で構成されたブロブを返します。
  • 任意: 黒白両方のブロブを返します。
閉じた 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。
閉じた 最小面積

ブロブ面積の最小値をピクセル単位 (0～900000) で指定します。デフォルトは 100 です。指定された値より小さなブロブは検出されません。

閉じた 最大面積

ブロブ面積の最大値をピクセル単位 (0～900000) で指定します。デフォルトは 100000です。指定された値より大きなブロブは検出されません。

閉じた 結果

ツールの結果が表示されます。ブロブが検出された場合は、[あり] が表示されます。ブロブが検出されなかった場合、または指定の範囲に合致しなかった場合、[なし] が表示されます。[あり] はブール値 1 (PASS) 、[なし] はブール値 0 (FAIL) となります。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。


[ヒストグラム] タブ (ブロブ有無判定ツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の垂直線は、画像の黒い部分と白い部分を切り分けるしきい値を表します。垂直線より左側が黒、右側が白とみなすことができます。
注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


[合成領域] タブ (ブロブ有無判定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


カラーブロブ有無判定ツール

カラーブロブ有無判定ツールは、カラーブロブの有無を判定します。

カラーモデルツールは、登録済みのカラーモデルライブラリを参照し、ライブラリ内の選択した登録済みカラーモデルにマッチする、領域内のピクセル数を決定します。 ツールは、有効なカラーモデルにマッチするピクセルを白 (255) に、それ以外のピクセルを黒 (0) に設定する、二値化グレースケール出力画像を生成します。 この 2 値化出力画像を使用して、有効なカラーモデルによって生成されたブロブ特徴を画像からサーチします。

ツールを設定するには

ツールのパラメータを調整するには


カラーブロブ有無判定ツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、ブロブが移動しても十分にカバーできる大きさに領域を設定してください。ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。
    • カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。
    • カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブで使用する [カラーライブラリ] を選択してから、[ライブラリ] タブで使用する [カラーモデル] のチェックボックスを ON にします。

    • [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  4. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーブロブ有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーブロブ有無判定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [ライブラリ] タブ
  • [合成領域] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[合成領域] タブ

カラーライブラリ


[全般] タブ (カラーブロブ有無判定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラーブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーブロブ有無判定ツール)

閉じた [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

閉じた カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール
閉じた 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。つまり、その他の条件を満たしていれば、領域の境界に接しているブロブを検出します。
閉じた 最小面積

ブロブ検出時の、最小面積をピクセルで定義します (0～16777216。デフォルト = 100)。認識されるのは、[最小面積] の値より面積が大きいブロブのみです。

閉じた 最大面積

ブロブ検出時の、最大面積をピクセルで定義します (0～16777216。デフォルト = 100000)。認識されるのは、[最大面積] の値より面積が小さいブロブのみです。

閉じた 平滑化係数

画像を平滑化する係数を定義します (0～25; デフォルト = 1)。平滑化を行わない場合は、0 に設定してください。

閉じた オリジナル画像の表示
  • OFF (デフォルト):選択した領域にバイナリのグレースケール出力画像を表示します。
  • ON:選択した領域にオリジナルの入力画像を表示します。
閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた 結果

ツールの結果が表示されます。ブロブが検出された場合は、[あり] が表示されます。ブロブが検出されなかった場合、または指定の範囲に合致しなかった場合、[なし] が表示されます。[あり] はブール値 1 (PASS)、[なし] はブール値 0 (FAIL) となります。


[合成領域] タブ (カラーブロブ有無判定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


カラーライブラリ (カラーブロブ有無判定ツール)

閉じた [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

閉じた カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

閉じた カラー名

選択したカラーモデルに含まれるカラー名を表示します。

閉じた RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

閉じた 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


エッジ有無判定ツール

エッジ有無判定ツールは、指定したパラメータに合致するエッジ特徴の有無を判定します。

エッジ有無判定ツールは、高速なツールの 1 つで、パターン有無判定ツールより短時間で特徴を検出することができます。

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズ 1XX ビジョンセンサ (110、120、130) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 標準の結果 (制限無し)

ツールを設定するには

ツールのパラメータを調整するには


エッジ有無判定ツールを使用するには

ツールを追加したら、特徴検査領域を定義します。

  1. エッジ特徴を直線領域の上に配置してください。

    閉じた 例

    エッジ特徴を直線領域の上に配置

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. EasyBuilder が、選択したエッジを囲むエッジ領域を自動的に作成します。

    閉じた 例

    自動的に作成された領域

  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジ有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジ有無判定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • グラフ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

グラフ


[全般] タブ (エッジ有無判定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はエッジ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (エッジ有無判定ツール)

閉じた エッジのコントラスト

円が検出されたとみなすための最小コントラスト得点 (1～100) を指定します。初期値はスマートセッティングによって自動的に決定されます。このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注 : パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
閉じた スコアの正規化

エッジスコアを領域のグレースケールヒストグラムで正規化するかどうかを指定します。このパラメータは、低コントラスト領域でエッジを見つける場合に有用です。検出対象のエッジが高コントラストだけの場合は、このパラメータを無効にします。

  • ON (デフォルト): スコアを正規化します。
  • OFF: スコアを正規化しません。
閉じた エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 検出する基準

複数のエッジが存在する場合に、目的とする 1 つのエッジに絞り込む方法を定義します。デフォルトは [得点の高い順] です。

  • 得点の高い順: 最も明確なエッジ (コントラストが最も高いもの) が選択されます。
  • 最初のエッジ: 領域のスキャン開始点に最も近いエッジが選択されます。
  • 最後のエッジ: 領域のスキャン開始点から最も遠いエッジが選択されます。
閉じた 角度範囲

検出されたエッジが取り得る、角度の最大値 (0～10 度) を定義します。デフォルトは 10 度です。 角度の許容範囲を広げると、ツールの実行時間が増大します。

閉じた 結果

ツールの結果が表示されます。エッジが検出された場合は、[あり] が表示されます。エッジが検出されなかった場合、または指定の範囲に合致しなかった場合、[なし] が表示されます。[あり] はブール値 1 (PASS) 、[なし] はブール値 0 (FAIL) となります。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。


グラフ (エッジ有無判定ツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


円有無判定ツール

円有無判定ツールは、指定したパラメータに合致する円特徴の有無を判定します。

円有無判定ツールは、高速のツールの 1 つで、パターン有無判定ツールより短時間で特徴を検出することができます。

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズ 1XX ビジョンセンサ (110、120、130) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 標準の結果 (制限無し)

ツールを設定するには

ツールのパラメータを調整するには


円有無判定ツールを設定するには

ツールを追加したら、特徴検査領域を定義します。

  1. 円形状の特徴の上に円領域を配置、設定します。特徴とちょうど同じぐらいの大きさになるように調整してください。

    閉じた 例

    特徴の上に円領域を配置

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. EasyBuilder が、選択した円を囲む円領域を自動的に作成します。

    閉じた 例

    円形エッジ特徴を囲む円環領域

  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

円有無判定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • グラフ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

グラフ


[全般] タブ (円有無判定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は円_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (円有無判定ツール)

閉じた エッジのコントラスト

エッジが検出されたとみなすための最小コントラスト得点 (1～100) を指定します (初期値はスマートセッティングによって自動的に決定されます) 。 このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注 : パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
閉じた スコアの正規化

エッジスコアを領域のグレースケールヒストグラムで正規化するかどうかを指定します。このパラメータは、低コントラスト領域でエッジを見つける場合に有用です。検出対象のエッジが高コントラストだけの場合は、このパラメータを無効にします。

  • ON (デフォルト): スコアを正規化します。
  • OFF: スコアを正規化しません。
閉じた エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 検出する基準

複数の円が存在する場合に、目的とする 1 つの円に絞り込む方法を定義します。デフォルトは [得点の高い順] です。

  • 得点の高い順: 最も明確な円 (コントラストが最も高いもの) が選択されます。
  • 最小円: 最も小さい円が選択されます。
  • 最大円: 最も大きい円が選択されます。
閉じた 結果

ツールの結果が表示されます。円が検出された場合は、[あり] が表示されます。円が検出されなかった場合、または指定の範囲に合致しなかった場合、[なし] が表示されます。[あり] はブール値 1 (PASS) 、[なし] はブール値 0 (FAIL) となります。

閉じた 反転
ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。 ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。


グラフ (円有無判定ツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


シャープネス有無判定ツール

シャープネス有無判定ツールは、領域内の画像シャープネス得点に基づき、画像が正しくフォーカスされているかどうかを定義します。 このツールは、In-Sight ビジョンシステムのレンズを再フォーカスする反復プロセスの一部として、入力画像の相対的な焦点を計測します。

画像シャープネス得点は、「シーン」 (その画像でキャプチャされた対象物とその背景) 内で認識可能な最小の特徴が画像領域内に含まれる度合いを示します。

ツールを設定するには

ツールのパラメータを調整するには


シャープネス有無判定ツールを設定するには

ツールを追加したら、領域を設定します。

  1. 「シーン」 (その画像でキャプチャされた対象物とその背景) の重要な部分を囲むように領域を配置します。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの確定後、まったく同一のシーンから取得した他の画像シャープネス得点 (対象物とその背景が同じ、In-Sight ビジョンシステムの方向および位置が同じ、照明が同じなど) と比較する必要があります。単一の画像シャープネス得点だけでは、画像領域内の絶対シャープネスについての情報は十分ではありません。
  4. [画像の設定] ステップに戻り、[ライブビデオ] モードに入ります。In-Sight ビジョンシステムのレンズを再フォーカスして、シーンに変更がないことを確認します。
  5. [ライブビデオ] モードを終了します。画像シャープネス得点が再計算されます。
  6. 再計算後の得点と、以前の得点を比較します。得点が高いほど、焦点がシャープになっています。
  7. 4 ～ 6 までのステップを繰り返し、許容範囲になるまで焦点をあわせます。
注 : フォーカスに問題が残る場合、レンズの交換や、レンズと対象物間の距離の調整、[画像の設定] アプリケーションステップでの他の画像の取り込みパラメータの調整などを試してください。


シャープネス有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

シャープネス有無判定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[制限範囲] タブ


[全般] タブ (シャープネス有無判定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はシャープネス_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (シャープネス有無判定ツール)

閉じた 最大

画像シャープネスの最大得点値を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた シャープネス

領域内の画像シャープネス得点を返します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

閉じた 最小

画像シャープネスの最小平均得点値を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


距離寸法測定ツール

距離寸法測定ツールは、任意に選択した 2 つの入力特徴の距離を測定します。

注 : . 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

距離寸法測定ツールは、検査対象物を正確に測定するのに有用です。 例えば、検査対象物の両端の間の距離や、2 つの穴の中心から中心までの距離を測定する場合などです。

ツールを設定するには

ツールのパラメータを調整するには


距離寸法測定ツールを使用するには

ツールを追加したら、検査する特徴を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 2 番目の特徴を選択します。
  4. EasyBuilder は自動的に特徴間の距離を測定します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


距離寸法測定ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

距離寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[制限範囲] タブ


[全般] タブ (距離寸法測定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は距離_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (距離寸法測定ツール)

閉じた 測定タイプ

エッジ間の距離の測定方法を指定します。選択肢は、[中点から線へ] (デフォルト設定。エッジ間の垂直距離を測定します) 、または [中点から中点へ] です。

注 :

このコントロールは 2 つの特徴のうち、1 つ以上がエッジである場合のみに有効になります。それ以外の場合、次の方法で自動的に距離を測定します。

  • 円から線へ: 円の中心からエッジまたは参照線の水平交点までの距離を計測します。
  • 点から線へ: 点からエッジまたは参照線の垂直交点までの距離を計測します。
  • 円から点へ: 円の中心から点までの距離を計測します。
  • 円から円へ: 円の中心からもう 1 つの円の中心までの距離を計測します。
  • 点から点へ: 2 点間の距離を計測します。

点とは定義済みの特徴、つまりブロブ、円、エッジ、パターン、または点のことで、次のように認識されます。

  • ブロブ: ブロブ重心の XY 座標から計測します。
  • 円: 円の中心の　XY 座標から計測します。
  • エッジ: 中点の XY 座標から計測されます。
  • パターン: モデルパターンの　XY 原点座標から計測します。
  • 点: 点の XY 座標から計測します。


[制限範囲] タブ (距離寸法測定ツール)

閉じた 最大

最大距離を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 距離結果

2 特徴間に測定された距離を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
閉じた 最小

最小距離を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


角度結果寸法測定ツール

角度結果寸法測定ツールは、2 つの特徴間の角度を測定します。

角度結果寸法測定ツールは、検査対象物を正確に測定する必要がある場合などに有用です。

ツールを設定するには

ツールのパラメータを調整するには


角度結果寸法測定ツールを設定するには

ツールを追加したら、検査する特徴を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 2 番目の特徴を選択します。
  4. EasyBuilder は自動的に 2 つの特徴間の角度を計算し、2 つのエッジの交点および測定角度を画像中にグラフィックスとして描画します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


角度結果寸法測定ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

角度結果寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[制限範囲] タブ


[全般] タブ (角度結果寸法測定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は角度_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (角度結果寸法測定ツール)

閉じた 最大

最大角度を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 角度結果

2 特徴間に測定された角度を表示します。値が [最小]～[最大] の範囲内にある場合、 PASS を返します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
閉じた 最小

最小角度を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


ブロブ面積/ブロブ面積 (1-10) 寸法測定ツール

ブロブ面積/ブロブ面積 (1-10) 寸法測定ツールは、検出された最大ブロブ特徴の面積を測定します。 ブロブ面積ツールが 1 個のブロブ面積の測定に使用されるに対し、ブロブ面積 (1-10) ツールは最大 10 個までのブロブ面積の測定に使用されます。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ブロブ面積およびブロブ面積 (1-10) 寸法測定ツールは、特徴の予想面積を測定したり、スルーホールの遮蔽物を検出する場合などに有用です。

ツールを設定するには

ツールのパラメータを調整するには


ブロブ面積/ブロブ面積 (1-10) 寸法測定ツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、ブロブが移動しても十分にカバーできる大きさに領域を設定してください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ブロブ面積/ブロブ面積 (1-10) 寸法測定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ブロブ面積およびブロブ面積 (1-10) 寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • [テーブル] タブ
  • [ヒストグラム] タブ
  • [合成領域] タブ
注 :
  • [ヒストグラム] タブは、ツール FAIL 時には表示されません。
  • [テーブル] タブは、ブロブ面積 (1-10) 寸法測定ツールでのみ有効になります。
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[制限範囲] タブ

テーブル

ヒストグラム

[合成領域] タブ


[全般] タブ (ブロブ面積/ブロブ面積 (1-10) 寸法測定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (ブロブ面積/ブロブ面積 (1-10) 寸法測定ツール)

閉じた しきい値モード

ブロブと背景を切り分けるためのグレー値を決める方法を指定します。[自動] を選択した場合、画像取り込みのたびに自動的にしきい値が計算されます (デフォルト)。[手動] を選択した場合、値を手動で入力、調整してください。

閉じた ブロブしきい値

ブロブと背景を切り分けるグレー値 (0～255) を定義します。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。ヒストグラムを参考にして、最適な値を設定してください。

閉じた ブロブの色

ブロブの色を定義します。選択肢は [黒]、[白]、[任意] (デフォルト) です。

  • 任意: 黒白両方のブロブを返します。
  • 黒: ブロブしきい値より低いグレー値で構成されたブロブを返します。
  • 白: ブロブしきい値より高いグレー値で構成されたブロブを返します。
閉じた 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。つまり、その他の条件を満たしていれば、領域の境界に接しているブロブを検出します。
閉じた 最小面積制限

ブロブ検出時の、最小面積をピクセルで定義します (0～16777216。デフォルト = 50)。報告されるのは、[最小面積制限] の値より面積が大きいブロブのみです。

注 : [制限範囲] タブの [最小] パラメータがツールの PASS/FAIL を決定するのに対し、[最小面積制限] パラメータはブロブを報告するかどうかを決定します。
閉じた 最大面積制限

ブロブ検出時の、最大面積をピクセルで定義します (0～16777216。デフォルト = 307,200)。報告されるのは、[最大面積制限] の値より面積が小さいブロブのみです。

注 : [制限範囲] タブの [最大] パラメータがツールの PASS/FAIL を決定するのに対し、[最大面積制限] パラメータはブロブを報告するかどうかを決定します。
閉じた 検出する数

検出するモデルパターンのインスタンスの数 (1～10) を定義します。デフォルトは 1 です。ほとんどのアプリケーションは 1 つのフィクスチャで十分ですが、複数のインスタンス (実体) を位置決めすることもできます。識別するブロブの数が多いほど、実行時間は増大します。

閉じた ソート

ツールが検出したブロブをどのように計測し、ソートするかを定義します。選択肢は、[面積]、[行]、[列]、[グリッド: フィクスチャから X、次に Y]、[グリッド: フィクスチャから Y、次に X]、[フィクスチャ原点からの距離]、[フィクスチャ行軸からの角度 (CCW)]、および [角度絶対値]。デフォルトは、[面積] です。

  • [面積]: 検出ブロブの面積を最大から最小の順番にソートします。
  • [行]: 行画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [列]: 列画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから X、次に Y]: まず、フィクスチャの行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから Y、次に X]: まず、フィクスチャの列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [フィクスチャ原点からの距離]: フィクスチャの原点からブロブの重心までの距離を、短いものから長いものの順 (降順) にソートします。
  • [フィクスチャ行軸からの角度 (CCW)]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
  • [角度絶対値]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
注 : ブロブ面積寸法測定ツールには、[検出する数] パラメータは含まれていません。


[制限範囲] タブ (ブロブ面積/ブロブ面積 (1-10) 寸法測定ツール)

閉じた 最大

最大ブロブ面積を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた ブロブ面積結果

測定されたブロブ面積を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
閉じた 最小

最小ブロブ面積を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[テーブル] タブ (ブロブ面積 (1-10) 寸法測定ツール)

注 :
  • ブロブ面積寸法測定ツールは、[テーブル] タブをサポートしていません。ブロブ面積 (1-10) 寸法測定ツールのみに表示されます。

  • [ソート] パラメータが [面積] 以外のオプションに設定されている場合、[ピクセル列] および [ピクセル行] がテーブルに追加されます。ピクセル [列] および [ピクセル行] は、In-Sight ビジョンシステムの画像センサ (アレイの列および行) の 2D グリッドに基づく画像座標を参照し、実座標 (X/Y) と逆 (Y/X) になります。

  • [画像の設定] ステップのキャリブレーション (画像座標系をワールド座標系に変換) グループボックスで、[X と Y を入れ替える] オプションを ON にした場合、XY 座標は画像座標 (Y/X) と同じになります。

[テーブル] タブには、検出したブロブの結果が報告されます。その数は、[設定] タブの [検出する数] パラメータによります。

閉じた インデックス

[設定] タブの [ソート] パラメータに基づいて、検出したブロブの順番を表示します。EasyBuilder では 0 から数えます。

閉じた 面積

検出したブロブの面積を返します (ピクセル単位)。

閉じた X

検出したブロブ重心の X 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

閉じた Y

検出したブロブ重心の Y 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

閉じた 角度結果

領域の中心を基準に、検出したブロブ重心の角度を返します。

閉じた エラー

検出したブロブにエラーが発生した場合、エラーを返します。

閉じた ピクセル行

検出したブロブの重心画像行 (X) 座標を返します。

閉じた ピクセル列

検出したブロブの重心画像行 (Y) 座標を返します。


グラフ (ブロブ面積/ブロブ面積 (1-10) 寸法測定ツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の垂直線は、画像の黒い部分と白い部分を切り分けるしきい値を表します。垂直線より左側が黒、右側が白とみなすことができます。
注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


[合成領域] タブ (ブロブ面積/ブロブ面積 (1-10) 寸法測定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール

カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツールは、検出された最大ブロブ特徴の面積を測定します。 カラーブロブ面積ツールが 1 個のブロブ面積の測定に使用されるのに対し、カラーブロブ面積 (1-10) ツールは最大 10 個までのブロブ面積の測定に使用されます。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

カラーブロブ面積/カラーブロブ面積 (1-10) ツールは、登録済みカラーモデルライブラリを参照し、選択した登録済みカラーモデルにマッチする領域内のピクセル数を決定します。 ツールは、有効なカラーモデルにマッチするピクセルを白 (255) に、それ以外のピクセルを黒 (0) に設定する、二値化グレースケール出力画像を生成します。 この 2 値化出力画像を使用して、有効なカラーモデルによって生成されたブロブ特徴を画像からサーチします。

ツールを設定するには

ツールのパラメータを調整するには


カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、ブロブが移動しても十分にカバーできる大きさに領域を設定してください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。

    • カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。

    • カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブで使用する [カラーライブラリ] を選択してから、[カラーライブラリ] タブで使用する [カラーモデル] のチェックボックスを ON にします。

    • [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  4. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーブロブ面積およびカラーブロブ面積 (1-10) 寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [範囲設定] タブ
  • [ライブラリ] タブ
  • [ライブラリ] タブ
  • [合成領域] タブ
注 : [テーブル] タブは、カラーブロブ面積 (1-10) 寸法測定ツールでのみ有効になります。
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[制限範囲] タブ

[ライブラリ] タブ

テーブル

[合成領域] タブ


[全般] タブ (カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラーブロブ面積_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール)

閉じた [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

閉じた カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール
閉じた 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。つまり、その他の条件を満たしていれば、領域の境界に接しているブロブを検出します。
閉じた ソート

ツールが検出したブロブをどのように計測し、ソートするかを定義します。選択肢は、[面積]、[行]、[列]、[グリッド: フィクスチャから X、次に Y]、[グリッド: フィクスチャから Y、次に X]、[フィクスチャ原点からの距離]、[フィクスチャ行軸からの角度 (CCW)]、および [角度絶対値]。デフォルトは、[面積] です。

  • [面積]: 検出ブロブの面積を最大から最小の順番にソートします。
  • [行]: 行画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [列]: 列画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから X、次に Y]: まず、フィクスチャの行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから Y、次に X]: まず、フィクスチャの列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [フィクスチャ原点からの距離]: フィクスチャの原点からブロブの重心までの距離を、短いものから長いものの順 (降順) にソートします。
  • [フィクスチャ行軸からの角度 (CCW)]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
  • [角度絶対値]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
閉じた 検出する数

検出するブロブの数 (1～10) を定義します。デフォルトは 1 です。識別するブロブの数が多いほど、実行時間は増大します。

注 : このコントロールは、カラーブロブ面積 (1-10) 寸法測定ツールでのみ使用できます。
閉じた 最小面積制限

ブロブ検出時の、最小面積をピクセルで定義します (0～16777216。デフォルト = 100)。報告されるのは、[最小面積制限] の値より面積が大きいブロブのみです。

注 : [制限範囲] タブの [最小] パラメータがツールの PASS/FAIL を決定するのに対し、[最小面積制限] パラメータはブロブを報告するかどうかを決定します。
閉じた 最大面積制限

ブロブ検出時の、最大面積をピクセルで定義します (0～16777216。デフォルト = 100000)。報告されるのは、[最大面積制限] の値より面積が小さいブロブのみです。

注 : [制限範囲] タブの [最大] パラメータがツールの PASS/FAIL を決定するのに対し、[最大面積制限] パラメータはブロブを報告するかどうかを決定します。
閉じた 平滑化係数

画像を平滑化する係数を定義します (0～25; デフォルト = 1)。平滑化を行わない場合は、0 に設定してください。

閉じた オリジナル画像の表示
  • OFF (デフォルト):選択した領域にバイナリのグレースケール出力画像を表示します。
  • ON:選択した領域にオリジナルの入力画像を表示します。


[制限範囲] タブ (カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール)

閉じた 最大

最大ブロブ面積を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた ブロブ面積

測定されたブロブ面積を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
閉じた 最小

最小ブロブ面積を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[ライブラリ] タブ (カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール)

閉じた [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

閉じた カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

閉じた カラー名

選択したカラーモデルに含まれるカラー名を表示します。

閉じた RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

閉じた 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


[テーブル] タブ (カラーブロブ面積 (1-10) 寸法測定ツール)

注 :
  • カラーブロブ面積寸法測定ツールは、[テーブル] タブをサポートしていません。カラーブロブ面積 (1-10) 寸法測定ツールのみに表示されます。

  • [ソート] パラメータが [面積] 以外のオプションに設定されている場合、[ピクセル列] および [ピクセル行] がテーブルに追加されます。ピクセル [列] および [ピクセル行] は、In-Sight ビジョンシステムの画像センサ (アレイの列および行) の 2D グリッドに基づく画像座標を参照し、実座標 (X/Y) と逆 (Y/X) になります。

  • [画像の設定] ステップのキャリブレーション (画像座標系をワールド座標系に変換) グループボックスで、[X と Y を入れ替える] オプションを ON にした場合、XY 座標は画像座標 (Y/X) と同じになります。

[テーブル] タブには、検出したブロブの結果が報告されます。その数は、[設定] タブの [検出する数] パラメータによります。

閉じた インデックス

[設定] タブの [ソート] パラメータに基づいて、検出したブロブの順番を表示します。EasyBuilder では 0 から数えます。

閉じた 面積

検出したブロブの面積を返します (ピクセル単位)。

閉じた X

検出したブロブ重心の X 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

閉じた Y

検出したブロブ重心の Y 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

閉じた 角度結果

領域の中心を基準に、検出したブロブ重心の角度を返します。

閉じた エラー

検出したブロブにエラーが発生した場合、エラーを返します。

閉じた ピクセル行

検出したブロブの重心画像行 (X) 座標を返します。

閉じた ピクセル列

検出したブロブの重心画像行 (Y) 座標を返します。


[合成領域] タブ (カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


円の直径寸法測定ツール

円の直径寸法測定ツールは、円形エッジ特徴の直径を測定します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


円の直径寸法測定ツールを使用するには

ツールを追加したら、検査する特徴を選択します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つをクリックすると、紫色に変わります。
  3. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  4. EasyBuilder は自動的に特徴の直径を測定します。 同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円の直径寸法測定ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

円の直径寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • グラフ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[制限範囲] タブ

グラフ


[全般] タブ (円の直径寸法測定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は直径_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (円の直径寸法測定ツール)

閉じた エッジのコントラスト

エッジが検出されたとみなすための最小コントラスト得点 (1～100) を指定します (初期値はスマートセッティングによって自動的に決定されます) 。 このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注 : パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
閉じた スコアの正規化

エッジスコアを領域のグレースケールヒストグラムで正規化するかどうかを指定します。このパラメータは、低コントラスト領域でエッジを見つける場合に有用です。検出対象のエッジが高コントラストだけの場合は、このパラメータを無効にします。

  • ON (デフォルト): スコアを正規化します。
  • OFF: スコアを正規化しません。
閉じた エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 検出する基準

複数の円が存在する場合に、目的とする 1 つの円に絞り込む方法を定義します。デフォルトは [得点の高い順] です。

  • 得点の高い順: 最も明確な円 (コントラストが最も高いもの) が選択されます。
  • 最小円: 最も小さい円が選択されます。
  • 最大円: 最も大きい円が選択されます。


[制限範囲] タブ (円の直径寸法測定ツール)

閉じた 最大

最大直径を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 直径結果

描画された円の直径を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
閉じた 最小

最小直径を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


グラフ (円の直径寸法測定ツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


円の同心度寸法測定ツール

円の同心度寸法測定ツールは、2 つの円特徴の中心距離を測定するのに使用されます。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

このツールは、円形ラベルが円形キャップの中心にあるかどうか検証したり、機械加工の皿穴の同心度を測定する場合などに有用です。

ツールを設定するには

ツールのパラメータを調整するには


円の同心度寸法測定ツールを設定するには

ツールを追加したら、円の同心度の測定に使用される、入力特徴 (円特徴または参照円) を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 2 番目の特徴を選択します。
  4. EasyBuilder は自動的に特徴間の距離を測定します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円の同心度寸法測定ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

円の同心度寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[制限範囲] タブ


[全般] タブ (円の同心度寸法測定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は同心度_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (円の同心度寸法測定ツール)

閉じた 最大

2 つの円の間の最大直径を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 距離結果

2 つの円の間に測定された距離を表示します。値が、0～[最大] の範囲内にある場合、PASS を返します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


半径計測寸法測定ツール

半径計測寸法測定ツールは、カーブエッジ特徴を定義し、カーブの軸を示す参照線と参照点を作成します。 このツールは、カーブの半径を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


半径計測寸法測定ツールを設定するには

ツールを追加したら、カーブエッジ特徴の検査領域を定義します。

  1. 領域をカーブエッジ特徴の上に配置してください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. EasyBuilder が、カーブ半径を自動的に計算し、カーブ軸を示す参照線および参照点を作成します。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じて パラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


半径計測寸法測定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

半径計測寸法測定ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[制限範囲] タブ


[全般] タブ (半径計測寸法測定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名はカーブ_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (半径計測寸法測定ツール)

閉じた エッジのコントラスト

円が検出されたとみなすための最小コントラスト得点 (1～100) を指定します。初期値はスマートセッティングによって自動的に決定されます。このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注 : パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
閉じた スコアの正規化

エッジスコアを領域のグレースケールヒストグラムで正規化するかどうかを指定します。このパラメータは、低コントラスト領域でエッジを見つける場合に有用です。検出対象のエッジが高コントラストだけの場合は、このパラメータを無効にします。

  • ON (デフォルト): スコアを正規化します。
  • OFF: スコアを正規化しません。
閉じた エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 検出する基準

複数のエッジが存在する場合に、目的とする 1 つのエッジに絞り込む方法を定義します。デフォルトは [得点の高い順] です。

  • 得点の高い順: 最も明確なエッジ (コントラストが最も高いもの) が選択されます。
  • 最初のエッジ: 領域のスキャン開始点に最も近いエッジが選択されます。
  • 最後のエッジ: 領域のスキャン開始点から最も遠いエッジが選択されます。


[範囲制限] タブ (半径計測寸法測定ツール)

閉じた 最大

最大半径を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 半径 (単位)

検出されたカーブエッジ特徴を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
閉じた 最小

最小半径を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


最小/最大点寸法測定ツール

最小/最大点寸法測定ツールは、エッジの位置を測定し、検出エッジまたはエッジを定義する領域から一番近いエッジ点と遠いエッジ点を指定します。このツールはエッジ解析キャリパアレイを使用して、エッジ特徴の正確な位置を特定します。エッジの識別後、最適ラインまたは最適円 (エッジ特徴にカーブがあるかどうかによります) をエッジ特徴の上に作成し、最適ラインまたは最適円に一番近いエッジ点と遠いエッジ点を返します。

注 :
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

最小/最大点寸法測定ツールは、検査対象物またはオブジェクトが予想される範囲内の位置から外れていないことを確認する場合などに有用です。例えば、刃に切れ目やくぼみ、突起がないこととを確認するのに使用します。

ツールを設定するには

ツールのパラメータを調整するには


最小/最大点寸法測定ツールを設定するには

ツールを追加したら、エッジ特徴上のマスク領域を設定します。

  1. エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

    注 : マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[エッジ]、[エッジ得点]、[最適ライン] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際、エッジ候補を正しく検出し、最適ラインや最適円を正しく作成していることを確認してください。最初にツールを設定する際には、理想的なエッジ特徴を含む画像を使用します。その後、エッジ候補を含む画像を取り込み、欠陥やギャップなどの偏差があるかどうかを決定します。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


最小/最大点寸法測定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

最小/最大点寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [最適ライン] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[エッジ] タブ

[エッジ得点] タブ

[最適ライン] タブ


[全般] タブ (最小/最大点寸法測定ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は最小最大点_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[エッジ] タブ (最小/最大点寸法測定ツール)

[エッジ] タブを選択すると、領域内で検出されたすべてのエッジが暗い緑色で表示されます。[キャリパサイズ]、[キャリパ間隔]、[エッジ幅] および [最小コントラスト] パラメータを必要に応じて調整し、使用するエッジを検出することができます。

[すべてのキャリパを表示] チェックボックスを ON にすると、すべてのキャリパが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

閉じた キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

閉じた キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

閉じた エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

閉じた キャリパ数

領域内のキャリパ総数を表示します。

閉じた キャリパインデックス

検出および表示する、キャリパを指定します。

閉じた すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (最小/最大点寸法測定ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補が、カラーコード化された小さな円で表示されます (領域は選択し、調整することができます)。エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。パラメータを調整して、使用するエッジ候補を検出してください。

検出された欠陥およびギャップも表示されます。

閉じた エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]) を指定します。デフォルトは、[左→右] です。

閉じた エッジの遷移

エッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには、遷移タイプを明示してください。

閉じた 規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


[最適ライン] タブ (最小/最大点寸法測定ツール)

[最適ライン] タブを選択すると、領域内で検出されたすべてのエッジ候補および最適円または最適ラインの結果が表示されます。エッジ候補は、最適ラインまたは最適円作成時に使用可能なエッジを表し、小さな円で表示されます。

閉じた 最適ライン

検出されたエッジから作成される、最適ラインのタイプを指定します ([なし]、[最適直線]、[最適円]、[自動調節] (デフォルト) または [領域])。

  • [なし] を選択すると、最適ラインは作成されません。検出エッジの位置は領域の中心を基準に計測されます。
  • [最適直線] を選択すると、検出エッジから最適直線が作成されます。検出エッジの位置は、最適ラインを基準に計測されます。
  • [最適円] を選択すると、検出エッジから最適円が作成されます。検出エッジの位置は、最適ラインを基準に計測されます。
  • [自動調節] を選択すると、検出エッジから最適直線または最適円が作成されます。検出エッジの位置は、最適ラインを基準に計測されます。
  • [領域] を選択すると、検出エッジから最適直線または最適円が自動的に作成されます。検出エッジの位置は、領域の側面を基準に計測されます。
閉じた 外れ値の除外

[最適距離フィルタ] パラメータで指定されている距離より遠い点を、最適ラインから削除するかどうかを指定します。デフォルトは、OFF です。

閉じた 最適距離フィルタ

エッジが元の最適ラインから離れている必要がある距離をピクセルで指定します (1～1920、デフォルト = 2)。この値は、最適合計算で使用します。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。

注 : このパラメータを使用するには、[外れ値の除外] パラメータを ON (有効) にする必要があります。
閉じた 最端フィルタ距離

除外距離を指定します (1～1920、デフォルト = 1000)。この値の外にあるエッジは、最小距離および最大距離を決定するのに使用されません。この値より大きなエッジは無視されます。

閉じた 再得点

最初に破棄した検出エッジが削除されているかどうかを確認するのに、検出エッジを再得点するかどうかを指定します。デフォルトは、OFF です。

閉じた 再計算

エッジ得点の再計算後に、最適ラインの再計算を行うように指定します。デフォルトは、OFF です。

注 : この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。
閉じた 結果

画像中の最適ラインを表示し、最適ラインに一番近い点と一番遠い点を返します。


ブロブ計数ツール

ブロブ計数ツールは、画像の領域内に存在するブロブ特徴のインスタンスの個数を返します。

ブロブ計数ツールは、高速なツールの 1 つです。パターン有無判定ツールよりも短時間でブロブ特徴を検出することができます。このツールは、コネクタ上に正しい数のピンがあるかを検証したり、クッキーのチョコレートチップを計数する場合などに有用です。

ツールを設定するには

ツールのパラメータを調整するには


ブロブ計数ツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

注 : ピクセルの白黒の差がはっきりした、高コントラストのブロブを選択してください。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、ブロブが移動しても十分にカバーできる大きさに領域を設定してください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


ブロブ計数ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ブロブ計数ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • [ヒストグラム] タブ
  • [合成領域] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[制限範囲] タブ

ヒストグラム

[合成領域] タブ


[全般] タブ (ブロブ計数ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (ブロブ計数ツール)

閉じた しきい値モード

ブロブと背景を切り分けるためのグレー値を決める方法を指定します。[自動] を選択した場合、画像取り込みのたびに自動的にしきい値が計算されます。[手動] を選択した場合、常に [ブロブしきい値] の値が使用されます。デフォルトは [自動] です。

閉じた ブロブしきい値

ブロブと背景を切り分けるグレー値 (0～255) を定義します。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。 グラフを参考にして、最適な値を設定してください。

閉じた ブロブの色

ブロブの色を定義します。選択肢は [黒]、[白]、[任意] (デフォルト) です。

  • 黒: ブロブしきい値より低いグレー値で構成されたブロブを返します。
  • 白: ブロブしきい値より高いグレー値で構成されたブロブを返します。
  • 任意: 黒白両方のブロブを返します。
閉じた 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。
閉じた 最小面積

ブロブ面積の最小値をピクセル単位で指定します。デフォルトは 100 です。指定された値より小さなブロブは検出されません。

閉じた 最大面積

ブロブ面積の最大値をピクセル単位で指定します。指定された値より大きなブロブは検出されません。


[制限範囲] タブ (ブロブ計数ツール)

閉じた 最大

検出する最大ブロブ数を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた ブロブ数

検出されたブロブ数を表示します。(ブロブは 0 から数えます。) 値が [最小]～[最大] の範囲内にある場合、PASS を返します。

閉じた 最小

検出する最小ブロブ数を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[ヒストグラム] タブ (ブロブ計数ツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の垂直線は、画像の黒い部分と白い部分を切り分けるしきい値を表します。垂直線より左側が黒、右側が白とみなすことができます。
注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


[合成領域] タブ (ブロブ計数ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


カラーブロブ計数ツール

カラーブロブ計数ツールは、画像の領域内に存在するブロブ特徴のインスタンスの個数を返します。

カラーブロブ計数ツールは、高速なツールの 1 つです。パターン有無判定ツールよりも短時間でブロブ特徴を検出することができます。このツールは、コネクタ上に正しい数のピンがあるかを検証したり、クッキーのチョコレートチップを計数する場合などに有用です。

ツールを設定するには

ツールのパラメータを調整するには


カラーブロブ計数ツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、ブロブが移動しても十分にカバーできる大きさに領域を設定してください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

    • サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。

    • カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。

    • カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブで使用する [カラーライブラリ] を選択してから、[カラーライブラリ] タブで使用する [カラーモデル] のチェックボックスを ON にします。

    • [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  3. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 最後に、必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーブロブ計数ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーブロブ計数ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • カラーライブラリタブ
  • [合成領域] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[制限範囲] タブ

[ライブラリ] タブ

[合成領域] タブ


[全般] タブ (カラーブロブ計数ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーブロブ計数ツール)

閉じた [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

閉じた カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール
閉じた 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。つまり、その他の条件を満たしていれば、領域の境界に接しているブロブを検出します。
閉じた 最小面積

ブロブ検出時の、最小面積をピクセルで定義します (0～16777216。デフォルト = 100)。認識されるのは、[最小面積] の値より面積が大きいブロブのみです。

閉じた 最大面積

ブロブ検出時の、最大面積をピクセルで定義します (0～16777216。デフォルト = 100000)。認識されるのは、[最大面積] の値より面積が小さいブロブのみです。

閉じた 平滑化係数

画像を平滑化する係数を定義します (0～25; デフォルト = 1)。平滑化を行わない場合は、0 に設定してください。

閉じた オリジナル画像の表示
  • OFF (デフォルト):選択した領域にバイナリのグレースケール出力画像を表示します。
  • ON:選択した領域にオリジナルの入力画像を表示します。


[制限範囲] タブ (カラーブロブ計数ツール)

閉じた 最大

検出する最大ブロブ数を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた ブロブ数

検出されたブロブ数を表示します。(ブロブは 0 から数えます。) 値が [最小]～[最大] の範囲内にある場合、PASS を返します。

閉じた 最小

検出する最小ブロブ数を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


カラーライブラリタブ (カラーブロブ計数ツール)

閉じた [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

閉じた カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

閉じた カラー名

選択したカラーモデルに含まれるカラー名を表示します。

閉じた RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

閉じた 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


[合成領域] タブ (カラーブロブ計数ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


エッジ計数ツール

エッジ計数ツールは、画像の領域内に存在するエッジ特徴の個数を返します。

このツールは、ネジのねじ山を計数したり、トレイのクラッカーを計数する場合などに有用です。

ツールを設定するには

ツールのパラメータを調整するには


エッジ計数ツールを使用するには

ツールを追加したら、エッジ検査領域を設定します。

  1. 特徴全体を囲むように領域を配置します。スキャン方向を示す矢印に特に注意して、エッジ検出を最適化するように領域を配置してください。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけツールの実行時間が増大します。

    処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、そのエッジがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、特徴が移動しても十分にカバーできる大きさに領域を設定してください。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジ計数ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジ計数ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • グラフ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[制限範囲] タブ

グラフ


[全般] タブ (エッジ計数ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]]、[通信]) で参照されます。ツールのデフォルト名はエッジ_1 で、末尾の番号はツールに応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (エッジ計数ツール)

閉じた エッジのコントラスト

エッジが検出されたとみなすための最小コントラスト得点 (1～100) を指定します (初期値はスマートセッティングによって自動的に決定されます) 。 このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注 : パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
閉じた スコアの正規化

エッジスコアを領域のグレースケールヒストグラムで正規化するかどうかを指定します。このパラメータは、低コントラスト領域でエッジを見つける場合に有用です。検出対象のエッジが高コントラストだけの場合は、このパラメータを無効にします。

  • ON (デフォルト): スコアを正規化します。
  • OFF: スコアを正規化しません。
閉じた エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 角度範囲

検出されたエッジが取り得る、角度の最大値 (0～10 度) を定義します。デフォルトは 10 度です。 角度の許容範囲を広げると、ツールの実行時間が増大します。


[制限範囲] タブ (エッジ計数ツール)

閉じた 最大

検出する最大エッジ数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた エッジ

検出されたエッジ数を表示します。エッジは 0 から数えます。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

閉じた 最小

検出する最小エッジ数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


グラフ (エッジ計数ツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


エッジペア計数ツール

エッジペア計数ツールは、画像の領域内に存在する直線エッジペアのインスタンスの個数を返します。

エッジペア計数ツールは、エッジ計数ツールと違い、エッジペア間の予想幅を設定できます。このツールは、歯車の歯数やコンピュータチップのリードを計数するといったアプリケーションに有用です。

ツールを設定するには

ツールのパラメータを調整するには


エッジペア計数ツールを使用するには

ツールを追加したら、エッジ検査領域を設定します。

  1. 特徴全体を囲むように領域を配置します。領域のスキャン方向、[設定] タブのパラメータおよび [制限範囲] の設定により、検出されるエッジペアの数が変わります。特徴全体を囲むように領域を配置します。

    領域のスキャン方向、[設定] タブのパラメータおよび [制限範囲] の設定により、検出されるエッジペアの数が変わります。

    閉じた 例 1

    閉じた 例 2

    閉じた 例 3

    処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、そのエッジがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、特徴が移動しても十分にカバーできる大きさに領域を設定してください。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジペア計数ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジペア計数ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • グラフ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[制限範囲] タブ

グラフ


[全般] タブ (エッジペア計数ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]]、[通信]) で参照されます。ツールのデフォルト名はエッジ_1 で、末尾の番号はツールに応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (エッジペア計数ツール)

閉じた エッジのコントラスト

エッジが検出されたとみなすための最小コントラスト得点 (1～100) を指定します (初期値はスマートセッティングによって自動的に決定されます) 。 このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。

注 : パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
閉じた スコアの正規化

エッジスコアを領域のグレースケールヒストグラムで正規化するかどうかを指定します。このパラメータは、低コントラスト領域でエッジを見つける場合に有用です。検出対象のエッジが高コントラストだけの場合は、このパラメータを無効にします。

  • ON (デフォルト): スコアを正規化します。
  • OFF: スコアを正規化しません。
閉じた エッジ 1 の遷移

1 番目のエッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。 検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた エッジ 2 の遷移

2 番目のエッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。 検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 角度範囲

検出されたエッジが取り得る、角度の最大値 (0～10 度) を定義します。デフォルトは 10 度です。 角度の許容範囲を広げると、ツールの実行時間が増大します。

閉じた 最小距離

検出されたすべてのエッジペアのエッジ間の最小距離をピクセルで定義します (0～900000、デフォルトは 10)。定義された値以上の距離のエッジペアのみ認識されます。

閉じた 最大距離

検出されたすべてのエッジペアのエッジ間の最大距離をピクセルで定義します (0～900000、デフォルトは 50)。定義された値以下の距離のエッジペアのみ認識されます。


[制限範囲] タブ (エッジペア計数ツール)

閉じた エッジペア

検出されたエッジペア数を表示します。エッジペアは 0 から数えます。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

閉じた 最大

検出する最大エッジペア数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 最小

検出する最小エッジペア数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


グラフ (エッジペア計数ツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注 : グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


PatMax RedLine パターンおよび PatMax パターン計数ツール

注 :
  • In-Sight ファームウェア 5.5.0 以降、ツールのアルゴリズムが変更され、条件によっては、より正確な結果を返すようになり、実行時間が短縮されました。
  • この変更により、In-Sight ファームウェア 5.5.0 以降で作成されたこのツールを含むジョブを、ファームウェアバージョン 5.4.x 以前を搭載した In-Sight ビジョンシステムにロードしようとすると、エラーメッセージが表示されます。
  • PatMax RedLine パターン計数ツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターンおよび PatMax パターン計数ツールは、登録済みのパターン表現 (モデルと呼ばれます) を基に、PatMax RedLine または PatMax アルゴリズムを使用して、パターンのインスタンスの個数を返します。

これらのツールは、機械の組み立てにおいてボルトを計数したり、トレイのバイラルを計数したりするアプリケーションなどに有用です。

ツールを設定するには

ツールのパラメータを調整するには


PatMax RedLine パターンおよび PatMax パターン計数ツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

  1. [モデル] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [サーチ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。
  3. [OK] ボタンを押し、2 つの領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。

パターンを選択するには

PatMax RedLine パターン、PatMax パターンおよびパターン


PatMax RedLine パターン、PatMax パターンおよびパターン

注 : PatMax RedLine パターン計数ツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターン、PatMax パターンおよびパターンツールは、どちらも登録済みのモデルパターンを検出する、最も高精度な検査ツールです。中でも PatMax RedLine パターンおよび PatMax パターンツールは、照明の条件やパターンのポジションが大幅に変わっても特徴を検出できるため、より強力な検査ツールと言えます。PatMax RedLine パターンおよび PatMax パターンツールは、スケール変化、回転、部分的な遮蔽、照明のばらつきによる外観変化に対しても、より優れた認識能力を発揮します。

PatMax RedLine パターンと PatMax パターンの主な違いはそのスピードにあります。PatMax RedLine パターンは最新のパターンマッチアルゴリズムを使用し、5 メガピクセルの画像内の登録した特徴を PatMax パターンの最大 7 倍の速さで検出します。よって、PatMax RedLine パターンは高解像度のビジョンシステムに最適と言えます。

通常、パターンツールは PatMax パターンツールより高速に動作します。しかし、次のような状況では PatMax RedLine または PatMax パターンツールの正確性および信頼性が必要とされる場合があります。

  • 照明のばらつきや反射の抑制が困難な場合 (例: 光を乱反射しやすい金属物を検査する場合)。
  • 検査対象物に似た形状やシェーディングが背景上にある場合、またはパターンが重なっていたり、他の物体によって部分的に隠蔽されていたりする場合。
  • 他の類似したパターンを除外し、目的の検査パターンを正確に検出したい場合。
  • 設置環境の状態によって、パターンツールでは一貫した信頼性のある検査を実行できない場合。


PatMax RedLine パターンおよび PatMax パターン計数ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

PatMax パターン計数ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • [モデル] および [サーチ] タブ
  • [登録画像] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[制限範囲] タブ

[モデル] および [サーチ] タブ

[登録画像] タブ


[全般] タブ (PatMax RedLine パターンおよび PatMax パターン計数ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([画像の設定]、[入力/出力] および [通信]) で参照されます。デフォルトのツール名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (PatMax RedLine パターン/PatMax パターン計数ツール)

閉じた アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。 この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。 この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。 設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

閉じた コントラストしきい値

検出パターンに存在する必要のある、最小コントラスト値を指定します。有効なインスタンスとみなすには、検出パターンのコントラストが [コントラストしきい値] より高い必要があります。PatMax RedLine パターンではデフォルト = 0、有効なパラメータ範囲は 0～100 です。PatMax パターンではデフォルト = 10、有効なパラメータ範囲は 0～255 です。低コントラストの画像には、低いコントラストしきい値が使用され、高コントラストの画像には、高いコントラストしきい値が使用されます。

注 : PatMax RedLine パターンでは、登録パターン内の特徴とサーチ画像内のマッチする特徴との間のコントラスト差をパーセンテージで表した、「相対」コントラストが報告されます。よって、特徴のコントラストがパターンコントラストと同じまたはより高い場合、報告されるコントラストは ~100 となります。特徴のコントラストがパターンコントラストより低い場合、報告されるコントラストは <100 となります。PatMax RedLine パターンのコントラストは PatMax パターンのコントラストは異なります。PatMax パターンでは、サーチ ROI 内の「絶対」画像コントラストがグレースケール値で報告されます。
閉じた 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。 大きな値を設定すると、ツールの実行時間が増大します。

閉じた スケール許容

モデルパターンの大きさを基準とした、検出パターンで許容されるスケール変化量を指定します (0～50、デフォルトは 0% です)。この値を 5 に設定すると、モデルの大きさに対して 95～105% のサイズのパターンが検出対象となります。大きな値を設定すると、ツールの実行時間が増大します。

閉じた 検出モード

パターンの登録および認識に使用されるサーチモードを指定します。選択肢は、[PatMax] (デフォルト) または [PatQuick] です。 デフォルトでは、[PatMax] が選択されています。 PatMax は、PatQuick より高精度ですが、実行時間が長くなります。一方、PatQuick は、PatMax より精度が低いですが、実行時間は短くなります。

閉じた クラッタ

モデルパターンと比較して、検出パターンの欠落または遮蔽された特徴を得点に考慮するかどうかを定義します。デフォルトは OFF、すなわち欠落があっても得点は減点されません。 クラッタを ON にすると、検出パターン中の特徴欠落によって得点が減点されます。

閉じた 極性を無視

モデルパターンに対し、カラー変換したマッチ特徴を検出パターンに含むかどうか指定します (デフォルト = OFF)。[極性を無視] を ON にすると、例えば、モデルパターン内の黒/白 vs. 白/黒など、カラー変換した特徴を含む検出パターンが、モデルパターンにマッチしていると分類されます。

閉じた タイムアウト
ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。デフォルトで、このパラメータは 5,000 に設定されています。
注 : PatMax RedLine パターンには、[検出モード] パラメータは含まれていません。


[制限範囲] タブ (PatMax RedLine パターンおよび PatMax パターン計数ツール)

閉じた 最大

検出する最大パターン数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた パターン

検出されたパターン数を表示します。パターンは 0 から数えます。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

閉じた 最小

検出する最小パターン数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[モデル] および [サーチ] タブ (PatMax RedLine パターンおよび PatMax パターン計数ツール)

[モデル] および [サーチ] タブを使用して、ツールのモデルおよびサーチ領域の合成領域を設定します。 合成領域は、サブ領域 (矩形、円環、円またはポリゴン) の集合体で、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • [モデル] タブでは、[モデル領域] ボタンを押した後にのみ、合成領域を有効にすることができます。
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


登録画像タブ (PatMax RedLine パターンおよび PatMax パターン計数ツール)

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


パターン計数ツール

パターン計数ツールは、登録済みのパターン表現 (モデルと呼ばれます) を基に、パターンのインスタンスの個数を返します。

パターン計数ツールは、機械の組み立てにおいてボルトを計数したり、トレイのバイラルを計数したりするアプリケーションなどに有用です。

ツールを設定するには

ツールのパラメータを調整するには


パターン計数ツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

  1. 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。

  2. パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。

    注 : モデルおよびサーチ領域は、円弧またはドーナツ状に曲げることはできません。
  3. [OK] ボタンを押し、2 つの領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。

パターンを選択するには


パターンを選択するには

パターンを選択する際には、次のガイドラインを参考にしてください。

  • そのパターンがすべての画像に存在していること。
  • ユニーク性の高い特徴や一貫性の高い特徴をできるだけ多くそのパターンに含めること。また、検査対象物全体の形状に対してそのパターンが常に一定の位置に、かつ明確に存在すること。
  • できるだけ大きなパターンを選択すること。大きなパターンはユニークな特徴を多く含むため、それだけ一貫した正確な検査を行うことができるます。


パターン計数ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

パターン計数ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • 登録画像タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[制限範囲] タブ

[登録画像] タブ


[全般] タブ (パターン計数ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (パターン計数ツール)

閉じた 登録の入力

モデルパターンを入力ラインを介して登録するかどうかを定義します。デフォルトは OFF で、無効です。

  • 入力: モデルパターンを入力ラインを介して登録します。 選択した入力ラインは、登録シグナルとして使用されます。

    注 :
    • このオプションは、In-Sight ビジョンシステムにディスクリート入力がない場合 (例えば、直接接続 I/O を使用している In-Sight 8000 シリーズビジョンシステムなど) 、表示されません。
    • 入力/出力ステップで、 選択した入力ラインの [信号タイプ] を [イベントトリガ] に設定してください。
    • モデルパターンの登録には、ビジョンシステム/センサが取り込んだ最新の画像が使用されます。 登録するために、ビジョンシステム/センサを再度トリガする必要はありません。
    • 詳細については、 入力: 入力ラインを介してモデルパターンを登録するにはをご参照ください。
閉じた アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。 この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。 この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。 設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

閉じた 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。 大きな値を設定すると、ツールの実行時間が増大します。

閉じた スケール許容

検出パターンのスケール変化 (±10% 以内) を許容するかどうかを指定します。 デフォルトは OFF です。大きな値を設定すると、ツールの実行時間が増大します。 スケール許容を ON にすると、±10% の範囲でパターンを検出しますが、スケール変化量が大きくなるほど、特徴の得点は低くなります。

閉じた モデルタイプ

ツールが、どのようにモデルパターンを作成するかを定義します。選択肢は、[エリアモデル] または [エッジモデル] です。[エリアモデル] は、モデル領域からのグレースケース値の均一サンプリングに基づいてパターンを作成します。[エッジモデル] は、モデル領域内のパターンの検出エッジ (白/黒の遷移) に基づいて、モデルパターンを作成します。

閉じた 高精度モード

ツールがどのように精度/信頼性と実行速度のトレードオフを評価するか定義します。選択肢は、[高精度]、[中程度] (デフォルト) および [高速] です。[高精度] は、精度/信頼性が高くなる反面、実行速度が遅くなります。[高速] は、実行速度が速くなる反面、精度/信頼性が低くなります。[中程度] は、その中間を取るように指定します。

閉じた タイムアウト

ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。


[制限範囲] タブ (パターン計数ツール)

閉じた 最大

検出する最大パターン数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた パターン

検出されたパターン数を表示します。パターンは 0 から数えます。値が [最小]～[最大] の範囲内にある場合、 PASS を返します。

閉じた 最小

検出する最小パターン数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


登録画像タブ (パターン計数ツール)

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


/ 1D コードの読み取り/1D コードの読み取り (1-20) 識別ツール

1D コードの読み取り/1D コードの読み取り (1-20) 識別ツールは、バーコードやスタックドバーコードを ReadIDMax® を使用してデコードしたり照合したりします。ツールは、デコード情報を返します。また、正しくデコードされ、コードが指定のしきい値内にある場合、PASS となります。

1D コードの読み取り識別ツールは、領域内の 1 個のコードを読み取り/照合するのに使用します。一方、1D コードの読み取り (1-20) 識別ツールは、領域内にある最大 20 個のコードを読み取り/照合するのに使用します。

ツールを設定するには

ツールのパラメータを調整するには


/ 1D コードの読み取り/1D コードの読み取り (1-20) 識別ツールを設定するには

ツールを追加したら、領域を設定します。

  1. コードやシンボル全体を囲むように領域を配置します。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[設定] タブでパラメータを指定します。

    1. [モード] パラメータで、ツールの操作方法を指定します。選択肢は、[読み取り] (デフォルト) または [マッチ文字列] です。
    2. 1D コードの読み取り (1-20) 識別ツールを使用する場合、[最大結果] パラメータを設定して、デコードするコードやシンボルの数を指定する必要があります。デフォルトは、1 です。
  4. ツールは、デコードされたコードやシンボルの周りを囲む四角形のボックスを描画します (このボックスは編集できません)。また、デコードされたコードやシンボルからフィクスチャが作成されたことを示す [image] アイコンが挿入されます。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


/ 1D コードの読み取り/1D コードの読み取り (1-20) 識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

1D コードの読み取り/1D コードの読み取り (1-20) 識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [1D] タブ
  • [スタックド] タブ
  • [結果] タブ
  • テーブル
注 :
  • [結果] タブは、1D コードの読み取り識別ツールのみに表示されます。
  • テーブルは、1D コードの読み取り (1-20) 識別ツールのみに表示されます。
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[1D] タブ

[スタックド] タブ

[結果] タブ

テーブル


/ [全般] タブ (1D コードの読み取り/1D コードの読み取り (1-20) 識別ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は ID コード_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (1D コードの読み取り/1D コードの読み取り (1-20) 識別ツール)

閉じた 最大結果

読み取りを実行するコードやシンボルの最大数を指定します (1～20、デフォルト = 1)。

注 : [最大結果] で指定した値が視野に含まれるコードやシンボルの数を超えている場合、ツールは指定した数のコードやシンボルを検出し続けます。視野に含まれるコードやシンボルの数にばらつきがある場合、[タイムアウト] パラメータの値を調整することによって、ツールの実行時間を短くすることができます。
閉じた 登録

特定のコードやシンボルが登録済みかどうかを表示します。登録済みの場合 1 を、未登録の場合 0 を表示します。

閉じた 登録

コードやシンボルの読み取りモデルを登録します。登録された情報は、[登録解除] ボタンを押すまで保持されます。コードやシンボルを再登録するには、 [登録解除] ボタンを押してから、新しいコードやシンボルに対して [登録] ボタンを押します。登録は、デコードするコードやシンボルのタイプをツールに学習させるため、使用すると、ツールのスピードおよびパフォーマンスが向上します。1D コードの読み取り (1-20) 識別ツールまたは 2D コードの読み取り (1-20) 識別ツールで登録を使用する場合、1 つのコードやシンボルの周りを囲むように領域を設定してから、[登録] ボタンを押してください。コードやシンボルが登録されたら、領域を調整し、視野 (FOV) を広げて、複数のコードやシンボルをサーチすることができるようになります。登録することができるのは、領域内の 1 つのコードやシンボルのみです。領域内の複数のコードやシンボルに対して [登録] ボタンを押すと、どのコード、シンボルが登録されるのか分からなくなります。登録前に、[1D] および [スタックド] タブで正しいコードタイプが選択されていることを確認してください。

閉じた 登録解除

コードやシンボルの登録済みモデルの登録を解除します。シンボルを再登録するには、[登録解除] ボタンを押してから、新しいコードに対して [登録] ボタンを押します。

閉じた モード

ツールのモードを指定します。選択肢は、[読み取り] (デフォルト) と [マッチ文字列] です。

  • 読み取り: 目的のコードやシンボルの情報がない場合に使用されます。ツールが情報を自動的にデコードして、デコードされた情報を [文字列] パラメータに表示します。
  • マッチ文字列: 既知のコードやシンボルが存在し、読み取り可能かどうかを検証するのに使用されます。ツールは情報をデコードし、その情報と [マッチ文字列] に入力された情報を比較します。
閉じた マッチ文字列

読み取りされる文字列を定義します ([モード] パラメータが [マッチ文字列] に設定されているときのみ有効となります)。デコードする情報を入力してください。

注 : マッチ文字列は他のデバイスから入力されることがあります。ジョブの実行時に、識別ツールを使用して入力デバイスからの文字列を読み取って、認識済みの ID コードやシンボルと比較することができます。マッチ文字列が外部デバイスから入力されるまで、ツールの結果は FAIL となり、[マッチ文字列] には TRIG が表示されます。
閉じた マッチモード

領域内のデコードされたすべてのコードやシンボルを、[マッチ文字列] パラメータで指定した文字列にマッチさせるかどうかを指定します。このオプションを有効にするには、[マッチ文字列] パラメータに文字列を入力する必要があります。

  • 全てマッチ: デコードされたコードやシンボルは、[マッチ文字列] パラメータで指定された文字列とすべてマッチする必要があります。
  • 任意のマッチ: デコードされたコードやシンボルが、[マッチ文字列] パラメータで指定された文字列と最低 1 つマッチする必要があります。
閉じた チェックサム

エラー検出アルゴリズムを使用して、信頼性を保証するために、コードやシンボルを検証するかどうかを指定します。デフォルトで、この設定は OFF となっています。チェックサムアルゴリズムが含まれるコードやサンプルのみに、チェックサムは適用されます。コードやサンプルには、それぞれ固有のチェックサムアルゴリズムが存在します。選択されたコードやシンボルにより、使用されるチェックサムの種類は異なります。

注 : Code 128、Code 93、RSS、UPC および EAN バーコードは、このパラメータに関わらず、チェックサムを使用して検証されます。その他のバーコードで [チェックサム] を ON にし、チェックサムがエンコードされていない場合、読み取りに失敗します。
閉じた ソートモード

結果を表示する順番を指定します。選択肢は、[なし] (デフォルト)、[上→下]、[左→右]、[アルファベット順]、[文字数] です。

  • なし: デコードされた順番に結果をソートします。その次に、デコードできなかった結果が表示されます。
  • 上→下: X フィクスチャ座標値の順番に、昇順でソートします。
  • 左→右: Y フィクスチャ座標値の順番に、昇順でソートします。
  • アルファベット順: 結果をアルファベット順にソートします。
  • 文字数: 結果を文字列の長さ順にソートします (短→長)。
  • 行: シンボルを行で分類し、各行内で左→右の順番にソートします。
  • 列: シンボルを列で分類し、各列内で上→下の順番にソートします。
閉じた 同一 1D シンボルの許容

領域内のすべてのシンボルを、同一でもデコードするかどうかを指定します。長さおよびシンボルタイプが同一で、文字列がデコードされている場合、2 つのシンボルは、同一であるとみなされます (デフォルトでは、この設定は OFF となっています)。

閉じた 照合

印刷精度テストを実行するかどうかを指定します。デフォルトは、OFF です。

閉じた 拡張 UPC-E

デコードされたシンボルが 6 桁の UPC-E 文字列を返すか、あるいは 11 桁の UPC-A 同等文字列を返すかを定義します (デフォルトで、この設定は有効となっています)。

注 : 拡張 UPC-E パラメータは、バージョン 4.10.1 以降のファームウェアを搭載した In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズおよび In-Sight 70xx - 74xx シリーズビジョンシステムのみでサポートされています。
閉じた タイムアウト

ツールがコードやシンボルをサーチする時間をミリ秒単位で指定します (0～30000、デフォルト = 0)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

閉じた デコード数

デコードしたコードやシンボルの数を表示します。

注 : [最大結果]、[マッチモード]、[ソートモード]、[同一 1D シンボルの許容] および [デコード数] パラメータは、1D コードの読み取り (1-20) 識別ツールのみに表示されます。


[1D] タブ (1D コードの読み取り/1D コードの読み取り (1-20) 識別ツール)

このタブを使用して、デコードを試みるコードやシンボルを指定します。デフォルトで、すべてのコードやシンボルタイプが有効となっており、複数のシンボルを選択して、読み取ることができます。

閉じた Code 128

Code 128 の読み取りを試みるかどうかを指定します。

閉じた Code 39

Code 39 の読み取りを試みるかどうかを指定します (Code 39 は、Code 3 of 9 または BC39 ともよばれます)。

閉じた インターリーブド 2 of 5

ITF-14 の読み取りを試みるかどうかを指定します。

閉じた Pharmacode

PharmaCode の読み取りを試みるかどうかを指定します。

閉じた UPC/EAN

UPC (Universal Product Code) および EAN (European Article Numbering) の読み取りを試みるかどうかを指定します。UPC は、バージョン A (標準バージョン) およびバージョン E (ゼロ抑制バージョン) の UPC バーコードと、2 文字および 5 文字の補足コードをサポートします。EAN は、EAN-8 および EAN-13 バーコードと同時に、2 文字および 5 文字の補足コードをサポートします。

閉じた Code 93

Code 93 の読み取りを試みるかどうかを指定します。

閉じた Codabar

Codabar の読み取りを試みるかどうかを指定します (Codabar は、USD-4 または Code 2 of 7 ともよばれます)。


/ [スタックド] タブ (1D コードの読み取り/1D コードの読み取り (1-20) 識別ツール)

このタブを使用して、デコードを試みるコードやシンボルを指定します。デフォルトで、すべてのコードやシンボルタイプが有効となっており、複数のシンボルを選択して、読み取ることができます。

閉じた PDF 417

PDF 417 の読み取りを試みるかどうかを指定します。

閉じた DataBar

DataBar の読み取りを試みるかどうかを指定します。

閉じた DataBar リミテッド

DataBar リミテッドの読み取りを試みるかどうかを指定します。

閉じた DataBar Expanded

DataBar Expanded の読み取りを試みるかどうかを指定します。

閉じた EAN.UCC コンポジット

EAN.UCC コンポジットの読み取りを試みるかどうかを指定します。


[結果] タブ (1D コードの読み取り識別ツール)

[結果] タブには、デコードされたコードやシンボルの情報が表示されます。

閉じた 文字列

デコードされたコードやシンボルに含まれる文字列を返します。

閉じた シンボル

デコードされたシンボルのタイプを返します。

閉じた グレード

デコードされたコードやシンボルのグレードを返します。


テーブル (1D コードの読み取り (1-20) 識別ツール)

デコードされたコードやシンボルの情報がテーブルに表示されます。

閉じた インデックス

[ソートモード] パラメータに基づいて、デコードされたコードやシンボルの順番を表示します (1～20)。EasyBuilder では 0 から数えます。

閉じた 文字列

デコードされたコードやシンボルに含まれる文字列を返します。

閉じた シンボル

デコードされたシンボルのタイプを返します。

閉じた X

デコードされたコードやシンボルのフィクスチャ出力の X 座標を返します。

閉じた Y

デコードされたコードやシンボルのフィクスチャ出力の Y 座標を返します。

閉じた 角度結果

デコードされたコードやシンボルのフィクスチャ出力の角度値を返します。

閉じた グレード

デコードされたコードやシンボルのグレードを返します。


/ 2D コードの読み取り/2D コードの読み取り (1-20) 識別ツール

2D コードの読み取り/2D コードの読み取り (1-20) 識別ツールは、QR コードやデータマトリックスシンボルを ReadIDMax® を使用してデコードしたり照合したりします。ツールは、デコード情報を返します。また、正しくデコードされ、コードが指定のしきい値内にある場合、PASS となります。

2D コードの読み取り識別ツールは、領域内の 1 個のシンボルを読み取り/照合するのに使用します。一方、2D コードの読み取り (1-20) 識別ツールは、領域内にある最大 20 個のシンボルを読み取り/照合するのに使用します。

ツールを設定するには

ツールのパラメータを調整するには


/ 2D コードの読み取り/2D コードの読み取り (1-20) 識別ツールを設定するには

ツールを追加したら、領域を設定します。

  1. コードやシンボル全体を囲むように領域を配置します。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。

    注 : 2D コード読み取りの際には、コードと領域の間に「クワイエットゾーン」が必要です。クワイエットゾーンとは、コードの端とコード定義領域の間の最小 3 ピクセルのスペースのことです。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[設定] タブでパラメータを指定します。
    1. [シンボルグループ] パラメータでシンボルのタイプを指定します。選択肢は、[データマトリックス] (デフォルト) または [QR コード] です。
    2. [モード] パラメータで、ツールの操作方法を指定します。選択肢は、[読み取り] (デフォルト) または [マッチ文字列] です。
    3. 2D コードの読み取り (1-20) 識別ツールを使用する場合、[最大結果] パラメータを設定して、デコードするコードやシンボルの数を指定する必要があります。デフォルトは、1 です。
  4. ツールは、デコードされたコードやシンボルの周りを囲む四角形のボックスを描画します (このボックスは編集できません)。また、デコードされたコードやシンボルからフィクスチャが作成されたことを示す [image] アイコンが挿入されます。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


/ 2D コードの読み取り/2D コードの読み取り (1-20) 識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

2D コードの読み取り/2D コードの読み取り (1-20) 識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [結果] タブ
  • テーブル
注 :
  • [結果] タブは、2D コードの読み取り識別ツールのみに表示されます。
  • テーブルは、2D コードの読み取り (1-20) 識別ツールのみに表示されます。
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[結果] タブ

テーブル


/ [全般] タブ (2D コードの読み取り/2D コードの読み取り (1-20) 識別ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は ID コード_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


/ [設定] タブ (2D コードの読み取り/2D コードの読み取り (1-20) 識別ツール)

閉じた シンボルグループ

デコードを試みるシンボルのタイプを指定します。選択肢は、[データマトリックス] (デフォルト) または [QR コード] です。

注 : QR コードを選択すると、ツールはすべての QR コードタイプ (QR モデル 1/2、マイクロ QR および QR モデル 1/2) のデコードを試みます。
閉じた 最大結果

読み取りを実行するコードやシンボルの最大数を指定します (1～20、デフォルト = 1)。

注 : [最大結果] で指定した値が視野に含まれるコードやシンボルの数を超えている場合、ツールは指定した数のコードやシンボルを検出し続けます。視野に含まれるコードやシンボルの数にばらつきがある場合、[タイムアウト] パラメータの値を調整することによって、ツールの実行時間を短くすることができます。
閉じた 登録済み

特定のコードやシンボルが登録済みかどうかを表示します。登録済みの場合 1 を、未登録の場合 0 を表示します。

閉じた 登録

コードやシンボルの読み取りモデルを登録します。登録された情報は、[登録解除] ボタンを押すまで保持されます。コードやシンボルを再登録するには、 [登録解除] ボタンを押してから、新しいコードやシンボルに対して [登録] ボタンを押します。登録は、デコードするコードやシンボルのタイプをツールに学習させるため、使用すると、ツールのスピードおよびパフォーマンスが向上します。1D コードの読み取り (1-20) 識別ツールまたは 2D コードの読み取り (1-20) 識別ツールで登録を使用する場合、1 つのコードやシンボルの周りを囲むように領域を設定してから、[登録] ボタンを押してください。コードやシンボルが登録されたら、領域を調整し、視野 (FOV) を広げて、複数のコードやシンボルをサーチすることができるようになります。登録することができるのは、領域内の 1 つのコードやシンボルのみです。領域内の複数のコードやシンボルに対して [登録] ボタンを押すと、どのコード、シンボルが登録されるのか分からなくなります。登録する前に、[シンボルグループ] パラメータで、シンボルグループ (データマトリックスまたは QR) が正しく選択されていることを確認して下さい。

閉じた 登録解除

コードやシンボルの登録済みモデルの登録を解除します。シンボルを再登録するには、[登録解除] ボタンを押してから、新しいコードに対して [登録] ボタンを押します。

閉じた 遠近補正

データマトリックスシンボルのデコード設定 ([遠近補正なし] = デフォルト、[遠近補正]、[遠近補正データを登録]) を指定します。 このパラメータを有効にするには、[シンボルグループ] パラメータを [データマトリックス] に設定する必要があります。

  • 遠近補正なし: 遠近歪みのないデータマトリックスシンボルをデコードします。
  • 遠近補正: 遠近歪みを持つデータマトリックスシンボルをデコードします。遠近歪みは、モデルの登録中およびランタイムに、個別に予測されます。

  • 遠近補正データを登録: 既知の遠近歪みを持つデータマトリックスシンボルをデコードします。 シンボルの登録モデルを使用している場合、遠近補正は、そのほかの属性とともに登録されます。 ランタイムに、登録済み属性を使用して入力画像の遠近歪みが補正されている空間から、このシンボルがサーチされます。 このオプションでは、ランタイムシンボルを、登録シンボルと同じ平面に配置する必要があります。 このオプションを指定すると、既知の遠近歪みを持つひどく損傷したシンボルでもデコードを行うことができます。

    ヒント : In-Sight ビジョンシステムは入射角 (センサの光軸と、シンボルが存在する平面の法線ベクトルの角度含む) が 40 度を超えないように、またシンボルの解像度が 1 セルあたり最低 5 ピクセルになるように取り付けることを推奨します。
閉じた モード

ツールのモードを指定します。選択肢は、[読み取り] (デフォルト) と [マッチ文字列] です。

  • 読み取り: 目的のコードやシンボルの情報がない場合に使用されます。ツールが情報を自動的にデコードして、デコードされた情報を [文字列] パラメータに表示します。
  • マッチ文字列: 既知のコードやシンボルが存在し、読み取り可能かどうかを検証するのに使用されます。ツールは情報をデコードし、その情報と [マッチ文字列] に入力された情報を比較します。
閉じた マッチ文字列

読み取りされる文字列を定義します ([モード] パラメータが [マッチ文字列] に設定されているときのみ有効となります)。デコードする情報を入力してください。

注 : マッチ文字列は他のデバイスから入力されることがあります。ジョブの実行時に、識別ツールを使用して入力デバイスからの文字列を読み取って、認識済みの ID コードやシンボルと比較することができます。マッチ文字列が外部デバイスから入力されるまで、ツールの結果は FAIL となり、[マッチ文字列] には TRIG が表示されます。
閉じた マッチモード

領域内のデコードされたすべてのコードやシンボルを、[マッチ文字列] パラメータで指定した文字列にマッチさせるかどうかを指定します。このオプションを有効にするには、[マッチ文字列] パラメータに文字列を入力する必要があります。

  • 全てマッチ: デコードされたコードやシンボルは、[マッチ文字列] パラメータで指定された文字列とすべてマッチする必要があります。
  • 任意のマッチ: デコードされたコードやシンボルが、[マッチ文字列] パラメータで指定された文字列と最低 1 つマッチする必要があります。
閉じた ソートモード

結果を表示する順番を指定します。選択肢は、[なし] (デフォルト)、[上→下]、[左→右]、[アルファベット順]、[文字数] です。

  • なし: デコードされた順番に結果をソートします。その次に、デコードできなかった結果が表示されます。
  • 上→下: X フィクスチャ座標値の順番に、昇順でソートします。
  • 左→右: Y フィクスチャ座標値の順番に、昇順でソートします。
  • アルファベット順: 結果をアルファベット順にソートします。
  • 文字数: 結果を文字列の長さ順にソートします (短→長)。
  • 行: シンボルを行で分類し、各行内で左→右の順番にソートします。
  • 列: シンボルを列で分類し、各列内で上→下の順番にソートします。
閉じた 照合

印刷精度テストを実行するかどうかを指定します。デフォルトは、OFF です。

閉じた バイナリ結果の許容

16 進数 ASCII データマトリックスシンボルを base-256 バイナリデータとしてデコードするかどうかを指定します (デフォルトでは、この設定は OFF となっています)。

閉じた タイムアウト

ツールがコードやシンボルをサーチする時間をミリ秒単位で指定します (0～30000、デフォルト = 0)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

閉じた デコード数

デコードしたコードやシンボルの数を表示します。

注 : [最大結果]、[マッチモード]、[ソートモード] および [デコード数] パラメータは、2D コードの読み取り (1-20) 識別ツールのみに表示されます。


[結果] タブ (2D コードの読み取り識別ツール)

[結果] タブには、デコードされたコードやシンボルの情報が表示されます。

閉じた 文字列

デコードされたコードやシンボルに含まれる文字列を返します。

閉じた シンボル

デコードされたシンボルのタイプを返します。

閉じた グレード

デコードされたコードやシンボルのグレードを返します。


テーブル (2D コードの読み取り (1-20) 識別ツール)

デコードされたコードやシンボルの情報がテーブルに表示されます。

閉じた インデックス

[ソートモード] パラメータに基づいて、デコードされたコードやシンボルの順番を表示します (1～20)。EasyBuilder では 0 から数えます。

閉じた 文字列

デコードされたコードやシンボルに含まれる文字列を返します。

閉じた シンボル

デコードされたシンボルのタイプを返します。

閉じた X

デコードされたコードやシンボルのフィクスチャ出力の X 座標を返します。

閉じた Y

デコードされたコードやシンボルのフィクスチャ出力の Y 座標を返します。

閉じた 角度

デコードされたコードやシンボルのフィクスチャ出力の角度値を返します。

閉じた グレード

デコードされたコードやシンボルのグレードを返します。


ID コードの読み取り識別ツール

ID コードの読み取り識別ツールは、バーコードおよび　2D マトリックスシンボルに含まれる情報を自動的にデコードしたり検証したりします。

注 : ID コードの読み取り識別ツールは、In-Sight Explorer 4.5.0 以降では、ReadIDMax® をサポートしない In-Sight ビジョンシステムでのみご使用いただけます。

ツールを設定するには

ツールのパラメータを調整するには


ID コードの読み取り識別ツールを使用するには

ツールを追加したら、領域のタイプを選択し、画像を設定します。

  1. コードまたはシンボル全体を囲むように領域を配置します。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。

    注 : 2D コード読み取りの際には、コードと領域の間に「クワイエットゾーン」が必要です。クワイエットゾーンとは、コードの端とコード定義領域の間の最小 3 ピクセルのスペースのことです。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. 領域の確定後、[設定] タブの [モード] を定義してください。選択肢は、[読み取り] (デフォルト) または [マッチ文字列]です。
  4. ツールはコードタイプを記憶し、ジョブ実行時に指定のコードタイプをサーチするようになります。コードタイプが変更された場合、[設定] タブの[学習] ボタンを押してください。ツールは新しいコードタイプを認識するようになり、そのコードタイプをサーチします。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。

サポートする ID コードの種類


サポートする ID コードの種類

ID コードの読み取り識別ツールは、次のタイプのコードおよびシンボルをサポートします。

Code 39* | Code 128
Code I2of5* | UPC
EAN | PharmaCode
POSTNET | PLANET
RSS-14 & スタックド | RSS-リミテッド
Codabar (NW-7)* | Code 93
UPU 4-State | Australia Post 4-State
Japan Post 4-State | USPS OneCode 4-State
データマトリックス | QR
RSS CC-A | RSS CC-B
PDF 417 |
* チェックサムアルゴリズムが含まれるコードおよびシンボル (オプション)。


ID コードの読み取り識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ID コードの読み取り識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ


[全般] タブ (ID コードの読み取り識別ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は ID コード_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (ID コードの読み取り識別ツール)

閉じた [学習] ボタン

新規のコードタイプまたはシンボルを定義します。[学習] ボタンは、ツールに新しいコードやシンボルを追加する時に使用されます。 ツールに新しいコードやシンボルを提示してから[学習] ボタンを押すと、ツールは自動的にデコードを試みます。 デコード後、ツールはそのタイプのコードまたはシンボルのみ、読み取りまたは照合を行うようになります。

閉じた コード

デコードされたコードまたはシンボルを表示します。

閉じた モード

ツールのモードを定義します。選択肢は、[読み取り] と [マッチ文字列] です。

[読み取り] (デフォルト) は、目的のコードやシンボルの情報がない場合に使用されます。 ツールが情報を自動的にデコードして、デコードされた情報を [文字列] パラメータに表示します。

[マッチ文字列] は、既知のバーコードやシンボルが存在し、読み取り可能かどうかを検証するのに使用されます。 ツールは情報をデコードし、その情報と [マッチ文字列] に入力された情報を比較します。

注 :

このツールには、PASS と FAIL の 2 つのステータスしかありません。したがって、ツールの [モード] コントロールを [マッチ文字列] に設定している際に FAIL が返される場合、2 つのシナリオが考えられます。1 つは、読み取りに失敗した場合、もう 1 つは、読み取りには成功したものの、デコードした情報が [マッチ文字列] パラメータに入力した文字列と一致しない場合です。

後者の場合、ツールはミスマッチデータ ([ミスマッチ] および [ミスマッチ数]) を出力します。このデータは、EasyView および [通信] アプリケーションステップの他のコミュニケーションデバイスで使用することができます。ミスマッチデータは、[EasyView アイテムの選択]、[OPC タグの選択] または [入力/出力データ] ダイアログから選択することができます。

ミスマッチデータは、ツールがコードの読み取りに失敗したのか、それとも、コードの読み取りに成功したものの、デコード情報が [マッチ文字列] で定義した情報と一致しないのかを決定する必要がある場合に有用です。例えば、ツールがコードの読み取りに失敗した場合、ラベル印刷のプロセスやビジョンシステムのセットアップに問題がある可能性があります。コードの読み取りに成功したもののデコード情報が [マッチ文字列] で定義した情報に一致しない場合、異なるラベルが印刷されている可能性があります。

閉じた マッチ文字列

読み取りされる文字列を定義します ([モード] パラメータが [マッチ文字列] に設定されているときのみ有効となります)。デコードする情報を入力してください。

注 : マッチ文字列は他のデバイスから入力されることがあります。ジョブの実行時に、識別ツールを使用して入力デバイスからの文字列を読み取って、認識済みの ID コードと比較することができます。マッチ文字列が外部デバイスから入力されるまで、ID コードの読み取りツールの結果は FAIL となり、[マッチ文字列] には TRIG　が表示されます。
閉じた タイムアウト

ツールがコードをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

閉じた 文字列

デコードされた情報を表示します。


カラー識別ツール

カラー識別ツールは、登録済みカラーライブラリのどの色が、画像中の色に一番マッチするかを決定するのに使用されます。

このツールは、検査対象物の色を基に、製造ライン上に正しい製品が流れていることを確認したり、他の生産現場のデバイスに、認識した製品の情報を通信したりするアプリケーションにおいて有用です。

ツールを設定するには

ツールのパラメータを調整するには


カラー識別ツールを設定するには

ツールを追加したら、領域のタイプを選択し、画像を設定します。

  1. [モデル] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 カラー全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのカラーがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、カラーが移動しても十分にカバーできる大きさに領域を設定してください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. 領域を設定したら、ツールのカラーライブラリを設定し、使用するカラーを有効にしてください。
  4. カラー識別ツールを始めて追加した場合、まずカラーライブラリおよびカラーを定義する必要があります。
  5. カラー識別ツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーを使用したい場合は、[設定] タブに戻って [カラーライブラリ] を選択してから、[ライブラリ] タブで使用する [カラー] のチェックボックスを ON にします。
  6. カラーライブラリが定義されるまで、ツールは自動的に FAIL を返します (デフォルト)。カラーライブラリが定義されると、ツールは自動的にそのライブラリを使用し、ライブラリに含まれるカラーを有効にします。
  7. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  8. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。

ピクセルの色成分


Inspect_ID_Color_ColorPixels

ピクセルの色成分

各カラーピクセルは、3 つの個別の色成分によって構成されています。これらの成分は、赤、緑、および青の組み合わせ (RGB) または色相、彩度、および明度の組み合わせ (HSI) として表されます。RGB も HSI も、ピクセルの各成分は 0～255 の値に変換されます。

閉じた RGB

RGB の場合、異なる割合の赤、緑、および青の色調の組み合わせによって作成されます。この組み合わせによって、各ピクセルに特定の色が生成されます。

閉じた HSI

HSI の場合、色の色相は、放射線の電磁スペクトルの可視部でのその色の位置に対応しています。

色の彩度は、その色に灰色または白色が混ざっている度合いです。彩度が飽和状態の場合は、純色になります。白色 (または灰色) が混ざっている度合いが高くなるほど、彩度が低下します。

色の明度は、明るさの尺度です。色の明度は、色を構成する赤、緑、および青成分の平均値として定義されます。色相、彩度、および明度の組み合わせによって、各ピクセルの正確な色が生成されます。

閉じた RGB 値および HSI 値の比較

RGB 値 = 255, 0, 0

HSI 値 = 0, 255, 85

RGB 値 = 0, 255, 0

HSI 値 = 85, 255, 85

RGB 値 = 0, 0, 255

HSI 値 = 170, 255, 85


カラー識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラー識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [テーブル] タブ
  • [ライブラリ] タブ
  • [合成領域] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

テーブル

[ライブラリ] タブ

[合成領域] タブ


[全般] タブ (カラー識別ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラー識別_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラー識別ツール)

閉じた カラーの登録

[MatchColor 登録] ダイアログを開き、選択したカラーライブラリのカラーを定義します。

閉じた カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[MatchColor 登録] ダイアログが開きます。EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。各カラーライブラリには、検査対象物の RGB/HSI 値から構成される、最大 100 個のカラーを含めることができます。

閉じた カラー空間

ツールに使用される値を定義します。選択肢は、[RGB] (デフォルト) または [HSI] です。各カラーピクセルは、3 つの色成分によって構成されています。これらの成分は、赤、緑、青の組み合わせ (RGB)、または色相、彩度、および明度の組み合わせ (HSI) として表されます。RGB も HSI もピクセルの各成分は 0～255 の値に変換されます。

閉じた モード

ツールのモードを定義します。選択肢は、[識別] または [マッチ] です。

  • [識別]: 画像内のカラーが不明な場合に使用します。このツールは、どのカラーモデルが画像中の色に一番マッチするかを決定します。選択したカラーライブラリに有効なカラーモデルが複数ある場合、そのピクセル数に基づき結果を順番付けし、ランクを決定します。
  • [マッチ]: 指定したカラーモデルが画像に存在するかを検証します。このツールは画像を処理し、画像内のカラーが [マッチカラー] パラメータで指定したカラーモデルと一致するかどうかを決定します。
閉じた マッチカラー

検出されるカラーモデルを指定します。このフィールドは、[モード] パラメータを [マッチ] に設定した場合にのみ有効となります。検出するカラーモデルの名前をフィールドに入力してください。

閉じた アクセプトしきい値

検出された色がサンプルカラーに類似していなければならない度合いを 0～100 で定義します。デフォルトは 90 です。

閉じた カラー

検出された色の名前を表示します。


テーブル (カラー識別ツール)

最もマッチした検出カラーを、ランクおよび得点順にソートして 10 位まで表示します (読み取り専用)。

閉じた ランク

検査基準に最もマッチしているカラーをランク順に 1～10 まで表示します。

閉じた カラー名

検出されたカラーの名前を表示します。

閉じた 得点

検出されたカラーの得点を表示します。


ライブラリ (カラー識別ツール)

閉じた カラー名

選択したマッチカラーライブラリに含まれる、カラーのリストを表示します (読み取り専用)。カラー名の横にあるチェックボックスを ON または OFF にすることによって、カラーを有効にしたり、無効にすることができます。

注 : マッチカラーライブラリに含まれる既存のカラーは、ツール追加時に自動的に有効となります (デフォルト)。カラーを無効にする場合は、選択したカラーライブラリを参照するツールを手動で無効にする (OFF にする) 必要があります。選択したカラーライブラリに登録済みのカラーがない場合、リストは空欄となります。
閉じた RGB

選択したマッチカラーライブラリに含まれるカラーの RGB 平均値のリストを表示します (読み取り専用)。

閉じた HSI

選択したマッチカラーライブラリに含まれるカラーの HSI 平均値のリストを表示します (読み取り専用)。


[合成領域] タブ (カラー識別ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


郵便コードの読み取り識別ツール

郵便コードの読み取り識別ツールは、領域内の 1 つのポスタルスタックドシンボルを ReadIDMax® を使用してデコードしたり照合したりします。ツールは、デコード情報を返します。また、正しくデコードされ、コードやシンボルが指定のしきい値内にある場合、PASS となります。

ツールを設定するには

ツールのパラメータを調整するには


郵便コードの読み取り識別ツールを設定するには

ツールを追加したら、領域を設定します。

  1. コードやシンボル全体を囲むように領域を配置します。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[設定] タブでパラメータを指定します。 [モード] パラメータで、ツールの操作方法を指定します。選択肢は、[読み取り] (デフォルト) または [マッチ文字列] です。
  4. ツールは、デコードされたコードやシンボルの周りを囲む四角形のボックスを描画します (このボックスは編集できません)。また、デコードされたコードやシンボルからフィクスチャが作成されたことを示す [image] アイコンが挿入されます。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


郵便コードの読み取り識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

郵便コードの読み取り識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [ポスタル] タブ
  • [結果] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[ポスタル] タブ

[結果] タブ


[全般] タブ (郵便コードの読み取り識別ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は ID コード_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (郵便コードの読み取り識別ツール)

閉じた 登録済み

特定のコードやシンボルが登録済みかどうかを表示します。登録済みの場合 1 を、未登録の場合 0 を表示します。

閉じた 登録

コードやシンボルの読み取りモデルを登録します。登録された情報は、[登録解除] ボタンを押すまで保持されます。コードやシンボルを再登録するには、 [登録解除] ボタンを押してから、新しいコードやシンボルに対して [登録] ボタンを押します。登録は、デコードするコードやシンボルのタイプをツールに学習させるため、使用すると、ツールのスピードおよびパフォーマンスが向上します。1D コードの読み取り (1-20) 識別ツールまたは 2D コードの読み取り (1-20) 識別ツールで登録を使用する場合、1 つのコードやシンボルの周りを囲むように領域を設定してから、[登録] ボタンを押してください。コードやシンボルが登録されたら、領域を調整し、視野 (FOV) を広げて、複数のコードやシンボルをサーチすることができるようになります。登録することができるのは、領域内の 1 つのコードやシンボルのみです。領域内の複数のコードやシンボルに対して [登録] ボタンを押すと、どのコード、シンボルが登録されるのか分からなくなります。登録する前に、[ポスタル] タブでコードタイプが正しく選択されていることを確認して下さい。

閉じた 登録解除

コードやシンボルの登録済みモデルの登録を解除します。シンボルを再登録するには、[登録解除] ボタンを押してから、新しいコードに対して [登録] ボタンを押します。

閉じた モード

ツールのモードを指定します。選択肢は、[読み取り] (デフォルト) と [マッチ文字列] です。

  • 読み取り: 目的のコードやシンボルの情報がない場合に使用されます。ツールが情報を自動的にデコードして、デコードされた情報を [文字列] パラメータに表示します。
  • マッチ文字列: 既知のコードやシンボルが存在し、読み取り可能かどうかを検証するのに使用されます。ツールは情報をデコードし、その情報と [マッチ文字列] に入力された情報を比較します。
閉じた マッチ文字列

読み取りされる文字列を定義します ([モード] パラメータが [マッチ文字列] に設定されているときのみ有効となります)。デコードする情報を入力してください。

注 : マッチ文字列は他のデバイスから入力されることがあります。ジョブの実行時に、識別ツールを使用して入力デバイスからの文字列を読み取って、認識済みの ID コードやシンボルと比較することができます。マッチ文字列が外部デバイスから入力されるまで、ツールの結果は FAIL となり、[マッチ文字列] には TRIG が表示されます。
閉じた モード

領域内のデコードされたすべてのコードやシンボルを、[マッチ文字列] パラメータで指定した文字列にマッチさせるかどうかを指定します。このオプションを有効にするには、[マッチ文字列] パラメータに文字列を入力する必要があります。

  • 全てマッチ: デコードされたコードやシンボルは、[マッチ文字列] パラメータで指定された文字列とすべてマッチする必要があります。
  • 任意のマッチ: デコードされたコードやシンボルが、[マッチ文字列] パラメータで指定された文字列と最低 1 つマッチする必要があります。
閉じた 照合

印刷精度テストを実行するかどうかを指定します。デフォルトは、OFF です。

閉じた タイムアウト

ツールがコードやシンボルをサーチする時間をミリ秒単位で指定します (0～30000、デフォルト = 0)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

閉じた 全方向読み取り

全方向読み取りモードを使用して、バーコードの読み取りを試みるかどうかを決定します (デフォルトは、OFF)。バーコードのエレメントをすべて検出するために、領域内に抽出されるスキャンラインの方向を指定します。1D シンボルの場合、バーコードはバーに対して垂直な最大 10 本の等間隔ライン (スキャンライン) に分割されます。デコードを成功させるには、バーコードのすべてのエレメント間で、少なくとも 1 つのスキャンラインを抽出する必要があります。OFF の場合、スキャンラインは領域に平行なバーコードを検出するような 1 方向のみにプロジェクションされます。ON の場合、スキャンラインは領域に対して回転したバーコードを検出するように、複数の角度でプロジェクションされます。


[ポスタル] タブ (郵便コードの読み取り識別ツール)

このタブを使用して、デコードを試みるコードやシンボルを指定します。デフォルトで、すべてのコードやシンボルタイプが有効となっており、複数のシンボルを選択して、読み取ることができます。

閉じた POSTNET

POSTNET の読み取りを試みるかどうかを指定します。

閉じた PLANET

PLANET の読み取りを試みるかどうかを指定します。

閉じた 日本郵便

日本郵便の読み取りを試みるかどうかを指定します。

閉じた オーストラリア郵便

オーストラリア郵便の読み取りを試みるかどうかを指定します。

閉じた UPU

UPU の読み取りを試みるかどうかを指定します。

閉じた インテリジェントメールバーコード

インテリジェントメールバーコードの読み取りを試みるかどうかを指定します。


[結果] タブ (郵便コードの読み取り識別ツール)

[結果] タブには、デコードされたコードやシンボルの情報が表示されます。

閉じた 文字列

デコードされたコードやシンボルに含まれる文字列を返します。

閉じた シンボル

デコードされたシンボルのタイプを返します。

閉じた グレード

デコードされたコードやシンボルのグレードを返します。


文字認識 (OCRMax) 識別ツール

文字認識 (OCRMax) 識別ツールを使用して、ユーザ定義の文字フォントの登録・作成後、領域内の文字列の認識/照合に使用します。

文字認識 (OCRMax) 識別ツールは、セグメント化および分類化プロセスを実行することにより、光学文字認識 (OCR) を行います。しきい値技術を使用して、文字列を含む画像エリアを識別し、セグメント化します。その後、文字を登録し、フォントデータベースに保存します。ランタイム中に分類化が行われ、セグメント化が実行された後、検出された文字に対して読み取りが行われます。これは、セグメント化された文字を、フォント中の登録文字に比較することによって実行されます。

ツールを設定するには

ツールのパラメータを調整するには


文字認識 (OCRMax) 識別ツールを設定するには

文字認識 (OCRMax) 識別ツールの操作は、2 つのステップ (登録および実行) からなります。

  • 登録ステップでは、読み取りを行う文字の複数の画像をロードし、画像から文字を抽出およびセグメント化し、文字の登録フォントデータベースを作成します。
  • 実行ステップでは、In-Sight ビジョンシステムをオンラインにし、画像を取り込み、登録フォントデータベースを基に文字の抽出および分類を行います。
注 : ツールを設定する前に、登録画像をロードしてください。フォントデータベースの登録の際には、文字の外観を最もよく表す画像 (最良の画像) を使用してプロセスを開始し、最後に最も状態の悪い画像を使用することを推奨します。
閉じた 文字認識 (OCRMax) 識別ツールを登録するには
  1. 最初の画像をロードします。
  2. 文字認識 (OCRMax) 識別ツールを追加します。

  3. 画像内の領域を設定します。読み取りを行う文字列を囲むように領域を配置します。

    • 領域の X 軸は文字列のベースラインに対して平行になるように、Y 軸は文字の垂直のストロークと平行になるように領域を設定します。文字に歪み (スキュー) がない場合、Y 時期は X 軸に対して直角になります。

    • X 軸の正の方向は、読み取りの方向となります。

    • 領域には、1 つの文字列およびその背景のみ含むようにしてください。背景には、ノイズが多かったり、多数の勾配/影があることがあります。
    • 明瞭に印刷され、ノイズがほとんどない画像では、領域を文字列より大幅に大きく設定することが可能です。
    • ノイズの多い画像では、文字列を囲む領域を狭く設定する必要があります。

    • 経験則として、可能な場合、領域はすべての側でテキスト行より文字幅の半分以上大きくします (領域の境界に、他の特徴が含まれてしまう場合を除きます)。

    注 :
    • 文字列のベースラインが傾いている (0～360 度) 場合、領域もほぼ同じ程度の角度で傾くように設定してください。
    • 領域には、文字列以外の顕著な特徴を含むことはできません。例えば、異なる文字列やラベルのエッジなどの一部が領域に含まれないようにしてください。
    • 領域に角度がある場合、ツールは画像から自動的に角度を取り除き、歪み補正した「カーブ領域位置」ラベル付きの領域を出力します。この領域は、表示用に画像内で再配置されている可能性があります。

  4. [セグメント] タブの設定に基づいて、文字の周囲に矩形が自動的に作成されます。

  5. 関数がテキスト周囲の文字領域を正しく描画しなかった場合は、2 つのオプションがあります。
    • [オートチューン] ダイアログを使用して、文字認識 (OCRMax) 識別ツールのセグメントの最適設定を自動的に計算します。[オートチューン] ダイアログは、セグメントおよび登録の 2 段階を 1 つにまとめます。[オートチューン] ダイアログトピックの指示にしたがって、フォントデータベースをセグメントし、登録してください。

    • [セグメント] タブでテキストが個々の文字領域で正しく囲まれるまでパラメータを調整します。セグメントプロセスにしたがって、登録前に画像データベース内のすべての文字をセグメントしてください。

    注 :
    • ノイズが多かったり、読み取りにくい文字の場合、[詳細設定] タブを使用して、これらの条件を補正することが可能です。
    • 文字間にスペースがある場合、[スペース] タブを開き、パラメータを調整してスペースの設定を調整してください。
閉じた セグメント後に、文字認識 (OCRMax) 識別ツールを手動で登録するには

文字をセグメントすると、文字を登録しフォントに追加することができます。まず、[設定] タブを開き、フォントライブラリパラメータからフォントを選択します。

  • 新規にカスタムフォントを作成する場合、[登録] タブを開き、登録する文字列を入力してから、[すべてを登録] ボタンを押します。選択中のカスタムフォントに文字が追加・保存されます。

    既存のカスタムフォントに文字を追加するには、登録する文字が含まれる別の画像を取得またはロードします。必要な場合、領域やセグメント化関連のパラメータを再設定し、文字を正しくセグメント化します。次に、[登録] タブの [新規文字を登録] または [選択中の文字を登録] ボタンを押します。

    注 : カスタムフォントは、[登録] タブから OCRMax データファイル (*.ocm) としてエクスポートしたり、インポートしたりすることができます。

  • 定義済みの OCRA または OCRBフォントを使用している場合、読み取りを行う文字の上にツールの領域を配置すると、[セグメント] および [詳細設定] タブで定義したパラメータ設定に基づいて、領域内の文字は自動的にセグメント化されます。

    注 : 定義済みの OCRA/OCRB フォントは編集できません。
閉じた 実行ステップ

フォントデータベース登録後、実行ステップに進むことができます。

  1. [検査モード] を設定します。ランタイム中に、領域内の文字を読み取るだけなのか、または読み取られた文字が正しいかどうかを認識/照合するかを決定します。
  2. 実行時に、In-Sight ビジョンシステムはオンラインになり、ジョブによって定義されているとおりに画像を取り込みます。画像が取り込まれると、画像内のテキスト文字列は [セグメント] パラメータに基づいて自動的にセグメンテーションされ、登録済みインスタンスと比較されます。


文字認識 (OCRMax) 識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

文字認識 (OCRMax) 識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [セグメント] タブ
  • [詳細設定] タブ
  • [スペース] タブ
  • [可変長] タブ
  • [登録] タブ
  • [フィールド化] タブ
  • [診断] タブ
  • [結果] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[セグメント] タブ

[詳細設定] タブ

[スペース] タブ

[可変長] タブ

[登録] タブ

[フィールド化] タブ

[診断] タブ

[結果] タブ


[全般] タブ (文字認識 (OCRMax) 識別ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は文字_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (文字認識 (OCRMax) 識別ツール)

閉じた フォントライブラリ

ツールが参照するフォントデータベースを指定します。定義済みのフォントタイプ (OCR-A/OCR-B、白地に黒/黒地に白) から選択するか、あるいは文字モデルを登録してカスタムフォントを作成してください (ジョブには 8 個までのカスタムフォントデータベースを作成することができます)。

注 : 4 種類の OCRA/OCRB フォントは読み取り専用で、再登録や、削除、名前の変更をすることはできません。
  • 定義済みのフォントを選択した場合、読み取りを行う文字の上にツールの領域を配置すると、領域内の文字は自動的にセグメント化されます。
  • カスタムフォントを選択した場合、文字認識 (OCRMax) 識別ツールを設定するにはトピックで説明されたステップに従って、カスタムフォントデータベース新規作成してください。既存のカスタムフォントを変更する場合、同一のカスタムフォントを使用している他の文字認識 (OCRMax) ツールも変更されます。
閉じた 検査モード

ツールのモードを指定します。選択肢は、[読み取り] または [認識と照合] です。

  • [読み取り]: 登録済み文字インスタンスに基づき、領域内の文字の読み取りを試みます。
  • [認識と照合]: 登録済み文字インスタンスに基づき、領域内の文字の読み取りを試みた後、[マッチ文字列] で指定した文字列に対応しているかどうかを検証します。
閉じた マッチ文字列

[認識と照合] 検査モード時に、マッチさせる文字列を指定します。

閉じた アクセプトしきい値

各文字の許容できる最低一致得点 (0～100、デフォルト = 80) を指定します。マッチ得点がアクセプトしきい値以下の場合、FAIL となります。

閉じた コンフュージョンしきい値

最高得点の文字と 2 番目の得点の文字のマッチ得点の間に必要な最小の値 (0～40、デフォルト = 0) を指定します。

閉じた サブサンプリングを使用

画像のサブサンプリングを有効にするかどうかを指定します。ON にすると、文字の解像度は低くなりますが、読み取り速度は早くなります。

閉じた タイムアウト

文字のサーチ時間 (0 ～ 30000、デフォルト = 5000) をミリ秒単位で指定します。指定された時間が経過すると、実行は停止し、#ERR が返されます。値を 0 に設定すると、OFF になり、タイムアウトは適応されません。

閉じた 文字の表示

文字および文字の領域をすべてのアプリケーションステップで表示するか、あるいは位置決めおよび検査アプリケーションステップでのみ表示するかどうかを指定します。(デフォルト = ON)

閉じた 文字ラベル位置

文字を囲む領域に対し、文字ラベルを表示する場所を指定します。選択肢は、文字の上 (デフォルト)、文字の右、文字の下、または文字の左です。


[セグメント] タブ (文字認識 (OCRMax) 識別ツール)

[セグメント] タブでは、領域内のセグメント化文字の設定を調整したり、修正したりします。デフォルト値を使用して、ほとんどの文字を読み取ることができますが、比較的難しいケースの場合、パラメータ値を調整する必要が生じることもあります。これらのケースでは、文字幅の最小値や、最大値、最小ピッチ値 (文字の左エッジから、次の文字の左エッジまでといった、文字間の距離) を指定して、補正を行なってください。困難なケースの場合、フォントデータベースの作成時間を短縮するために、[オートチューン] ボタンを使用して、[オートチューン] ダイアログを開き、セグメントの最適設定を自動的に計算することができます。

閉じた セグメント化のガイドライン
  • 強いテクスチャや多くのノイスが背景に含まれている場合、文字が背景に溶けこんでしまい、セグメント化は困難です。
  • 領域には、読み取る文字のみ含まれるようにし、別の文字やラベルエッジなど、無関係な強い特徴は含まれないようにしてください。
  • 2 つの文字が接触している場合、ほとんどのケースでパラメータを調整する必要があります。接触している文字の幅が固定幅の場合、文字幅を指定することにより、補正が可能です。ただし、接触している文字がプロポーショナルフォントの場合、補正は簡単ではありません。正しくプロセスできる場合もありますが、そうでない場合もあります。
  • 文字列が短い場合 (3 文字以下の場合など) や、多くのラインジッタが含まれる比較的短い文字列の場合、[角度範囲] を指定することにより、短い文字列の方向を決定する際に生じる不確実性を補正することができます。
  • 文字列に含まれる文字は、すべて同じ方向およびスキューである必要があります。
  • ドットマトリクス印刷で、ドットとドットが離れている場合、文字を正しくセグメント化するには、[最小文字フラグメントサイズ] などのパラメータ調整が必要です。
  • 文字のストローク幅は、2 ピクセル以上である必要があります。
  • 大きな文字 (アルファベットなど) の最小文字サイズは 8 x 8 ピクセルです。小さな文字 (ピリオドなど) の最小文字サイズは、2 x 2 ピクセルです。
閉じた オートチューン

文字認識 (OCRMax) 識別ツールとともに使用される [オートチューン] ダイアログを開き、オートチューンモデルを作成し、オートチューン記録を構成することによって、ツールのセグメントパラメータを設定し、フォントデータベースを登録します。オートチューン記録は、画像、登録文字列および画像内でユーザが検証した文字の位置から構成されています。オートチューンモデルとは、1 つまたは複数のオートチューン記録、さらにオートチューン記録内のすべての画像においての最適なセグメント設定から構成されています。

注 :
  • オートチューンを使用する場合、In-Sight ビジョンシステム上でなく、In-Sight エミュレータ上で実施することを推奨します。文字認識 (OCRMax) 識別ツールのオートチューンアルゴリズムには、非常に多くの計算リソースが必要であるため、ビジョンシステムよりエミュレータで計算を行ったほうが、より良く機能します。
  • フォントデータベースを登録するのに [オートチューン] ダイアログを使用する場合、文字の外観を最もよく表す画像 (最良の画像) を使用してプロセスを開始し、最後に最も状態の悪い画像を使用することを推奨します。このプロセスにより、文字認識 (OCRMax) 識別ツールのオートチューンアルゴリズムを最善の状態で使用することができます。
閉じた 文字の極性

入力画像の文字極性を指定します。選択肢は、[黒 (白い背景)]、[白 (黒い背景)] または [自動] (デフォルト) です。

注 : 文字の極性を指定することによって、ツールのパフォーマンスを向上することができます。
  • [黒 (白い背景)]: 白い背景上に黒い文字。
  • [白 (黒い背景)]: 黒い背景上に白い文字。
  • [自動]: 自動的に文字の色および背景の極性を決定します。
閉じた 文字幅のタイプ

フォント内の文字幅がどのように異なるかを指定します。選択肢は、[自動] (デフォルト)、[固定] または [変数] です。

注 : 文字幅とは、文字を囲む矩形の幅のことです。領域ではありません。
  • [自動]: 文字幅は不明です。フォントの幅は、固定またはプロポーショナルである可能性があります。
  • [固定]: フォント内の文字を囲む矩形は、すべて等幅です。
  • [変数]: フォント内の文字を囲む矩形の幅は異なっています。
閉じた 文字幅の最小値

文字を囲む矩形の最小幅 (1～1000、デフォルトは 3) をピクセル単位で指定します。

閉じた 文字の高さの最小値

文字を囲む矩形の最小の高さ (1～1000、デフォルトは 3) をピクセル単位で指定します。

閉じた 文字幅の最大値を使用

文字を囲む矩形の幅の最大許容可能値を考慮に入れるかどうかを指定します (デフォルトは、OFF)。

注 : ON にすると、指定値より幅が広い文字は、2 つのセグメントに分割されます。
閉じた 文字幅の最大値

文字を囲む矩形の最大幅 (1～5000、デフォルトは 100) をピクセル単位で指定します。

閉じた 文字の高さの最大値を使用

文字を囲む矩形の高さの最大許容可能値を考慮に入れるかどうかを指定します (デフォルトは、OFF)。

注 : この値の使用方法は 2 種類あります。1 つは、全体的なラインの検出に使用します。垂直線に隣接したノイズや、垂直線に隣接した文字の他のラインを除外したりします。もう 1 つの使用方法は、この値を超える高さの各文字をトリミングして、この高さに合うようにします。
閉じた 文字の高さの最大値

文字を囲む矩形の最大の高さ (1～5000、デフォルトは 100) をピクセル単位で指定します。

閉じた 最小文字アスペクト比を使用

文字のアスペクト比の最小許容可能値を考慮に入れるかどうかを指定します。アスペクト比とは、文字列全体の高さを文字列を囲む矩形の幅で割ったものです。(デフォルトは ON)。

注 : ON の場合、アスペクト比が指定値より小さい文字 (幅が広すぎるなど) は、複数のセグメントに分割されます。
閉じた 最小文字アスペクト比

許容可能な最小アスペクト比 (0～500、デフォルトは 80) を指定します。

閉じた 角度範囲

角度のサーチ範囲 (0～45、デフォルトは 0) を指定します。

注 : 0 以上の値に設定すると、セグメント化実行時間が長くなります。
閉じた スキュー範囲

スキューのサーチ範囲 (0～45、デフォルトは 0) を指定します。

注 : 0 以上の値に設定すると、セグメント化実行時間が長くなります。
閉じた 診断の表示

画像のグラフィックス診断データを表示するかどうかを指定します。有効にした場合、保存された文字 (緑)、除外した文字 (赤)、保存されたフラグメント (水色)、不合格フラグメント (黄)、文字のメインライン (青) および文字の延長メインライン (紫) の周囲に領域が描画されます。


[詳細設定] タブ (文字認識 (OCRMax) 識別ツール)

閉じた 文字フラグメントマージモード

セグメント化中に文字を形成しているときの、文字のマージ方法を指定します。選択肢は、[要オーバラップ] (デフォルト)、[最小文字間ギャップ値に設定] または [最小文字間ギャップ値/最大文字内ギャップ値に設定] です。

  • [要オーバラップ]: マージするには、文字フラグメントが最低 1 ピクセル分、水平に重なっている必要があります。
  • [最小文字間ギャップ値に設定]: 水平ギャップのある文字フラグメントが、[最小文字間ギャップ値] で指定した値より小さい場合、マージし文字を形成します。
  • [最小文字間ギャップ値/最大文字内ギャップ値に設定]: [最小文字間ギャップ値] および [最大文字内ギャップ値] パラメータに基づき、水平ギャップのある文字フラグメントをマージし、文字を形成します。
閉じた 文字フラグメントの最小オーバーラップ値

2 つの文字フラグメントが X 方向に重なりあい、同じ文字の一部としてみなすのに必要な、最小フラグメント値 (0～100、デフォルトは 0) を指定します。

閉じた 最大文字内ギャップ値

1 つの文字内 (損傷した文字を含む) で起こり得る最大ギャップサイズ (0～1000、デフォルトは 5) をピクセル単位で指定します。

閉じた 最小文字間ギャップ値

1 つの文字内で起こり得る最小ギャップサイズをピクセル単位で指定します　(0～1000、デフォルトは 0)。ギャップとは、文字の矩形の右エッジから次の文字の矩形の左エッジまでの距離のことです。2 つのフラグメント間のギャップがこの値より小さい場合、2 つの文字を合わせた幅が広すぎない限り ([文字幅の最大値] や [最小文字アスペクト比] で指定します)、これらのフラグメントを同じ文字の一部とみなします。

閉じた 最小文字フラグメントサイズ

フラグメントを文字としてみなすために必要な、前景色 (文字など) の最小ピクセル値 (0～1000、デフォルトは、15) を指定します。文字フラグメントとは、2 値化画像内のブロブのことです。

閉じた 文字サイズの最小値

文字として報告するために必要な、前景色 (文字など) の最小ピクセル値 (0～5000、デフォルトは、15) を指定します。

閉じた 正規化モード

画像の正規化に使用するモードを指定します。選択肢は、[なし]、[グローバル]、[ローカル] または [ローカル詳細設定](デフォルト) です。

注 : この設定は、登録時もランタイム時も同じである必要があります。登録後に設定を変更すると、分類化に問題が生じます。
  • [なし]: 正規化は実行されません。
  • [グローバル]: 領域全体を使用して、グローバル正規化を実行します。ローカルバリエーションは使用されません。
  • [ローカル]: 領域内の各ローカル文字の矩形についての情報を使用して、正規化を実行します。
  • [ローカル詳細設定]: 領域内の各ローカル文字の矩形についての情報を使用して、正規化を実行します。正規化の際には、背景だけでなく、前景色のコントラストの調整も実行されます。
閉じた ストローク幅フィルタを使用

正規化画像から、ストローク幅が異なるものをすべて削除するかどうかを指定します (デフォルトは、ON)。この設定は、細いノイズストリークのせいで、文字がつながって見える場合などに有用です。ただし、この設定を使用すると、ストローク幅が均一でない場合、文字を誤って削除してしまう可能性があります。

注 : この設定は、登録時もランタイム時も同じである必要があります。登録後に設定を変更すると、分類化に問題が生じます。
閉じた 境界フラグメントを無視

領域の境界上にあるフラグメントを完全に無視するかどうかを指定します (デフォルトでは、この設定は OFF です)。この設定は、ラベルのエッジなどの文字以外の特徴が領域に含まれている場合に有用です。

注 : 文字矩形の境界から文字のメインラインに至るフラグメントは文字とみなされます。このパラメータを ON に設定した場合、フラグメントを無視するには、文字のメインラインに至らないようにしてください。
閉じた 2 値化しきい値

2 値化しきい値の計算に使用される範囲内のパーセンテージ修飾子 (0～100、デフォルトは、50) を指定します。2 値化しきい値は、正規化画像内で画像を前景色と背景に 2 値化します。

閉じた 文字フラグメントのコントラストしきい値

[2 値化しきい値] を基準にして、フラグメントを文字とみなすのに必要な最小コントラスト値 (正規化画像内のグレーレベル、0～255、デフォルトは 30) を指定します。

閉じた メインラインまでの最大フラグメント距離

文字列の水平線「メインライン」から削除されるフラグメントの距離を、ピクセル単位で (0～1000、デフォルトは 0) 指定します。

閉じた セグメント解析モード

文字セグメント化を実行する、文字解析モードタイプを指定します。選択肢は、[最小] または [標準](デフォルト) です。

  • [最小]: セグメント化パラメータに基づき、簡単なセグメント化を実行します。
  • [標準]: 文字の間隔を含む、文字列ライン全体の解析を行い、最適なセグメント方法を決定します。
閉じた 最小ピッチ値

2 つの文字間で起こり得る、最小ピッチ値 (0～1000、デフォルトは 0) をピクセル単位で指定します。ピッチは、[文字ピッチ位置] パラメータに基づいて計算されます。2 つのフラグメント間のピッチがこの値より小さい場合、2 つの文字を合わせた幅が広すぎない限り ([文字幅の最大値] や [最小文字アスペクト比] で指定します)、これらのフラグメントを同じ文字の一部とみなします。ピッチは、隣り合う文字の対応点間の距離によって定義します。文字の終わりから、次の文字の始めの間の距離は、文字間のギャップと呼ばれます。

閉じた 文字ピッチ位置

文字間のピッチの測定方法を指定します。選択肢は、[自動](デフォルト)、[左-左]、[中央-中央] または [右-右] です。

注 :
  • [セグメント解析モード] パラメータを [最小] に設定した場合、このパラメータは無効になります。
  • 「左」および「右」とは、領域が定義する座標を基準にしています。例えば、「右」は、X の正方向と同意です。
  • [自動]: 未知のメトリックスが使用されている場合に指定します。他のピッチ位置が適切なピッチ位置である場合もあれば、一定したピッチ位置 (プロポーショナルピッチフォントの場合など) がない場合もあります。
  • [左-左]: 文字を囲む矩形の左端から、次の文字の矩形の左端までの距離を使用して測定したピッチを指定します。
  • [中央-中央]: 文字を囲む矩形の中央から、次の文字の矩形の中央までの距離を使用して測定したピッチを指定します。
  • [右-右]: 文字を囲む矩形の右端から、次の文字の矩形の右端までの距離を使用して測定したピッチを指定します。
閉じた 文字のピッチタイプ

文字間隔の定義に使用するメトリックスを指定します。選択肢は、[自動](デフォルト)、[固定]、[比例] または [変数] です。

注 : [セグメント解析モード] パラメータを [最小] に設定した場合、このパラメータは無効になります。
  • [自動]: ピッチタイプが [固定] または[比例] タイプであるが、どちらか不明の場合に指定します。[変数] タイプには使用できません。
  • [固定]:　文字の矩形の幅にかかわらず、2 つの文字間のピッチが一定の、固定ピッチである場合に指定します。ピッチは、[文字ピッチ位置] を基に計測します。

  • [比例]: 2 つの文字間のピッチが、文字によって異なる、プロポーショナルピッチである場合に指定します。

    注 :
    • どのピッチ計測法も文字列内で一定ではありません。一般的に、文字の矩形の右端から次の文字の矩形の左端までの距離である文字間ギャップは、おおよそ一定です。
    • 「左」および「右」とは、領域が定義する座標を基準にしています。例えば、「右」は、X の正方向と同意です。
  • [変数]: 文字間距離のメトリックスが文字列内で一定でない場合に指定します。例えば、文字位置が一定しておらず、ピッチが [固定] または [比例] のいずれでもない場合などです。
注 : [変数] ピッチは、[自動] とは異なります。[自動] は、未知のピッチが [固定] または [比例] である場合を想定しています。
閉じた 追加の文字検証をスキップ

分類化中に追加の文字検証を実行するかどうかを指定します (デフォルトは、OFF)。OFF の場合、分類化中に追加の文字検証を実行し、誤読が発生する機会を減少させます。

閉じた 出力画像グラフィックス

表示する出力画像のタイプを指定します。選択肢は、[入力画像](デフォルト)、[正規化画像] または [バイナリ画像] です。

  • [入力画像]： アクティブな入力画像が表示されます。
  • [正規化画像]: 正規化された画像が表示されます。
  • [バイナリ画像]: 2 値化画像が表示されます。


[スペース] タブ (文字認識 (OCRMax) 識別ツール)

[スペース] タブを使用して、必要な場合に、文字間のスペースをどのように取り扱うかを指定します。文字認識 (OCRMax) 識別ツールは、文字間ギャップをユーザ定義のスペース文字として分類、処理します。

閉じた スペースの検出

文字間のギャップにどのようにスペース文字を挿入するかを指定します。選択肢は、[なし](デフォルト)、[シングルスペースの挿入] または [複数スペースの挿入] です。

  • [なし]: 文字間のギャップの大きさにかかわらず、スペース文字は挿入されません。
  • [シングルスペースの挿入]: 文字間のギャップの大きさにかかわらず、文字間に 1 つのスペース文字を挿入します。
  • [複数スペースの挿入]: 文字間ギャップに x 個 (0 または 1 以上) のスペース文字を挿入します。
閉じた スペース得点モード

スペースの得点方法を指定します。選択肢は、[常に 100 を得点] または [クラッタを基に得点] です。

  • [常に 100 を得点]: スペース文字は常に 100 点となります。
  • [クラッタを基に得点]: 背景にあるピクセルフラグメントに基づいて、スペース文字を得点します。背景ピクセルのみからなるスペース文字は 100 点を得点します。
閉じた スペース最小幅

スペース文字の最小幅値をピクセル単位で指定します。(0～1000、デフォルトは、10)

閉じた スペース最大幅

スペース文字の最大幅値をピクセル単位で指定します。(0～1000、デフォルトは、100)


[可変長] タブ (文字認識 (OCRMax) 識別ツール)

[可変長] タブを使用して、 どの文字が文字中の異なる位置に表示されるかという情報を提供します。

注 : これらのパラメータは、[フィールド化] タブのパラメータを有効にし、設定したときのみ、使用します。
閉じた 文字数

フィールド化を実行する文字列の長さを指定します。選択肢は、[固定](デフォルト) または [変数] です。

  • [変数]: 可変長モードで操作されます。
  • [固定]: 固定の文字列数モードで操作されます。
閉じた 最大文字列長

文字列の最大許容文字数を指定します。(0～100、デフォルトは、15)。

注 : このパラメータは、[文字数] パラメータが [固定] の場合、OFF となります。
閉じた 最小文字列長

文字列の最小許容文字数を指定します。(0～100、デフォルトは、5)。

注 : このパラメータは、[文字数] パラメータが [固定] の場合、OFF となります。
閉じた 最後にフィールド化した最大インデックス値

フィールド化サブシーケンスを指定します。フィールド化サブシーケンス開始位置は、このインデックス値より小さい値である必要があります。(0～100、デフォルトは、100)

注 : このパラメータは、[文字数] パラメータが [固定] の場合、OFF となります。
閉じた 最初にフィールド化した最小インデックス値

フィールド化サブシーケンスを指定します。フィールド化サブシーケンス終了位置は、このインデックス値より大きい値である必要があります。(0～100、デフォルトは、0)

注 : このパラメータは、[文字数] パラメータが [固定] の場合、OFF となります。


[登録] タブ (文字認識 (OCRMax) 識別ツール)

[登録] タブを使用して、登録、表示、名前の変更および文字の削除などを行うことができます。このタブは、文字登録パラメータを指定するタブと、登録済みフォントを管理するタブの 2 つのグループに分かれています。

注 :
  • [登録] タブでは、領域を調整することができます (編集グラフィックスボタンが ON になります)。領域が修正されると、セグメント化グラフィックス (文字の矩形) が更新されます。
  • 複数バイトの文字名 (漢字など) はサポートされていません。複数バイトの文字を登録することは可能ですが、文字名はシングルバイト名である必要があります。
閉じた 登録グループボックスの設定項目
注 : 文字を登録する前に、正しくセグメント化が行われている必要があります。
  • [文字列の登録]: 登録する文字列を指定します。[文字列の登録] テキスト入力ボックス内の文字数は、セグメント化された文字の数と一致する必要があります。最大 50 までの文字を登録できます。
  • [すべてを登録]: 領域内のすべての文字を登録します。登録する文字を [文字列の登録] テキスト入力ボックスに入力してから、[すべてを登録] ボタンを押します。テキスト入力ボックス内の文字数は、セグメント化された文字の数と一致する必要があります。
  • [新規文字を登録]: 領域内の新規文字のみを登録します。登録する文字を [文字列の登録] テキスト入力ボックスに入力してから、[新規文字を登録] ボタンを押します。テキスト入力ボックス内の文字数は、セグメント化された文字の数と一致する必要があります。
  • [選択中の文字を登録]: 領域内の指定の文字を登録します。このオプションを選択すると、[文字列の登録] テキスト入力ボックスは無効となり、[個々の文字をフォントに追加] ダイアログが開きます。ダイアログには、領域内の矩形で囲まれた画像と、その下にラベルとテキスト入力ボックスが表示されます。ラベルには、その画像に現在関連付けられているシンボルが表示されます (未登録の文字では、「?」が表示されます)。ラベルの下にはテキスト入力ボックスが表示されます。セグメント化された文字のラベル名をテキスト入力ボックスに入力してください。その文字を保持しない場合は、テキスト入力ボックスには何も入力しないでください。[登録] ボタンを押して、ダイアログを閉じます。
閉じた 文字グループボックスの設定項目

登録後、登録済みの文字は、ツリーに表示されます。各文字にはフォルダおよびラベルが割り当てられ、グループ化 (同じラベルの文字がある場合) されます。

  • ルートフォルダを選択して、右側のパネルにフォント内のすべての文字を表示します。文字はアイコンとして表示され、その下にはラベルが表示されます。
  • 文字フォルダを選択して、右側のパネルにその文字の登録インスタンスを表示します。文字はアイコンとして表示され、その下にはラベルが表示されます。

  • 文字の登録インスタンスを選択して、右側のパネルに拡大された文字を表示します。

    ヒント : 各文字に対して複数のインスタンスを登録することにより、ランタイム中に、類似の文字タイプをより正確に識別することができるようになります。しかし、複数の文字インスタントの登録には、長所と短所が存在します。長所は、誤って分類してしまう可能性がある文字 (8 と B など) を読み取る際などに、より正確に分類化を行うことができる点です。短所としては、次の点があげられます: ツールの実行時間が長くなったり、信頼性得点が低くなったりすることがある。複数の登録インスタンスは得点を上げるが、2 番目に高い得点も上げてしまう。悪い文字を登録してしまうことがある。
  • インポート: [開く] ダイアログを開き、OCRMax データファイル (*.ocm) として保存されたフォントをインポートします。
  • エクスポート: [名前をつけて保存] ダイアログを開き、OCRMax データファイル (*.ocm) として保存されたフォントをエクスポートします。

  • 名前の変更: アイテムを選択し、名前を変更します。ツリー中または右側のリストパネル中のいかなるアイテムの名前も変更することができます。

    注 : 文字グループの名前を変更すると、グループ内のすべての文字に対して新しいラベルが割り当てられます。単一の文字の名前を変更すると、選択中の 1 つの文字に対して新しいラベルが割り当てられ、その文字はツリー内の新しいグループまたは別のグループに移動します。

  • 削除: フォントから削除するアイテムを選択してから、ボタンを押します。ツリー中または右側のリストパネル中のいかなるアイテムも削除することができます。

    注 : フォントフォルダを削除すると、フォントが消去され、すべての文字が削除されます。文字グループを削除すると、同じラベル名のすべての文字が削除されます。


[フィールド化] タブ (文字認識 (OCRMax) 識別ツール)

[フィールド化] タブは、文字認識 (OCRMax) 識別ツールのフィールド文字列およびフィールド定義のグラフィックスを作成、編集します。結果値は、リテラル文字列としてツールに挿入されます。

フィールド化することにより、文字列が正しいかどうか検証・訂正し、最もマッチする有効な文字列セットを返すことができます。フィールド化には主に 2 つの使用方法があります。

  • OCR 結果の検証。フィールド文字列およびフィールド定義パラメータに基づき、返された文字列が正しいかどうかを決定します。
  • OCR 結果の訂正。返された文字列が許容可能な結果リストにない場合、フィールド化によって許容された、返された文字列に一番近い文字列の検出を試みます。

フィールド化の一般的なユーザケースは、文字列に接頭辞/接尾辞が含まれる場合です。フィールドを使用して、これらの接頭辞/接尾辞を無視します。この場合、フィールド文字列およびフィールド定義は領域内の文字列ポジションオフセットを決定します。

閉じた フィールド文字列

文字列に含まれる文字数を指定します。フィールド文字列エントリには、(A～Z)、(a～z)、(0～9)、ハイフン (-) 、ドット (.) 、スペース ( ) など、[テキスト入力] ダイアログのすべての文字を使用できます。

フィールド文字列の各文字は、0～31 のインデックス付きポジションに対応します。フィールド文字列には、最低でも、文字列中の文字のポジション数と同じ数の文字が含まれていないと、PASS 結果は得られません。例えば、文字列に 10 個の文字があり、フィールド文字列が 9 文字のみ指定している場合、1 番マッチする 9 個の文字が返されます。反対に、文字列に 8 個の文字があり、フィールド文字列が 9 文字を指定している場合、#ERR が返されます。デフォルトでは、フィールド文字列の各ポジションは、アスタリスク (*) 、つまり英数字の「ワイルドカード」で示されます。これは、文字列のそのポジションではすべての文字が有効であることを意味します。

ただし、フィールド文字列の個別の位置は、その位置に一部の文字しか想定されないように制限することができます。すると、対象外の文字は読み取り時に考慮されないため、全体的な性能と信頼性が向上します。

定義済みのフィールド文字列エントリは、次のとおりです。

フィールド文字列 エントリ | 説明 | 有効な文字
* | ワイルドカード | フォント内の任意の登録済み文字
N | 数字 | 0123456789
A | 大文字の英字 | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | 小文字の英字 | abcdefghijklmnopqrstuvwxyz
H | 16 進値 (大文字の英字と数字) | 0123456789ABCDEF
h | 16 進値 (小文字の英字と数字) | 0123456789abcdef
O | 8 進値 | 01234567
注 :
  • フィールド文字列のある位置を特定の文字に制限する場合は、その文字を入力してください。文字はフォントに登録されている必要があります。また、「フィールド定義」パラメータを使用して再割り当てしない限り、上記の定義済みフィールド文字列エントリの文字を使用することはできません。
  • スペースを含む文字列を読み取るには、フィールド文字列にスペースを含めます。その位置の対応するフィールド文字列エントリがアスタリスク (*) の場合、ReadText 関数はスペースを読み取りません。
閉じた フィールド文字列の例 1

フィールド文字列が「**********AN」の場合、1～10 番目のフィールド文字列位置ではフォントに含まれるすべての文字が有効です。ただし、11 番目の位置は、読み取り時に大文字の英字だけが想定されます。また、12 番目の位置は、数字だけが想定されます。

閉じた フィールド文字列の例 2

フォントには、0～9 の数字と / だけが含まれます。フィールド文字列が「NN/NN/NN」の場合、1、2、4、5、7、および 8 番目の位置では数字だけが想定されています。また、3 および 6 番目の位置ではスラッシュ (/) だけが想定されています。

ただし、フィールド文字列が「NN/NN/AA」の場合は、フォントに英字が含まれていないため、#ERR が返されます。

閉じた フィールド化していない文字を無視

各文字ポジションにおいて、文字のフィールド化で指定した文字のみ含むよう、結果を制限するかどうかを指定します。ON にすると、分類化得点にかかわらず、フォント内のすべてのほかの文字を無視します。

閉じた フィールド定義

必要に応じて、フィールド文字列のユーザ定義エントリを作成するためにフィールド定義設定を使用できます。このエントリをフィールド文字列に入力すると、その位置の読み取り対象文字が、定義リストに含まれる文字のみに限定されます。システム定義のフィールド定義の他に、ユーザ定義のフィールド定義も追加することができます。システム定義のフィールド定義は、グレーのテキストで表示され、削除したり、編集したりすることはできません。有効にしたり、無効にしたりすることのみ可能です。ユーザ定義のフィールド定義は、黒のテキストで表示され、追加したり、削除したり、または編集したりすることができます。フィールド定義を追加するには、[新規追加] ボタンを押して、その文字のアイコンを割り当ててから、定義を割りててください。

フィールド定義エントリのために示す文字は、フォントに含まれている必要があります。例えば、#=123 は、ユーザ登録フォントに 1、2、3 が含まれる場合に有効です。ただし、#=123 は、フォントに 1、2、3 が含まれない場合は無効です。

注 : 定義済みのエントリ (*, A, a, N, H, h, O) をフィールド定義パラメータで使用すると、新しい定義で有効な文字のリストが再割り当てされます。
閉じた フィールド定義の例 1

フィールド定義の値が「#=123;$=3456;%=789」でフィールド文字列が「#$%*******」の場合、1 番目の位置では 1、2、または 3 だけが、2 番目の位置では 3、4、5、または 6 だけが、3 番目の位置では 7、8、または 9 だけが有効です。また、4～10 番目の位置ではフォントに含まれるすべての文字が有効です。

閉じた フィールド定義の例 2

フィールド定義の値が「#=123;$=3456;%=789, A=A」でフィールド文字列が「#$%******A」の場合、1 番目の位置では 1、2、または 3 だけが、2 番目の位置では 3、4、5、または 6 だけが、3 番目の位置では 7、8、または 9 だけが有効です。また、4～9 番目の位置ではフォントに含まれるすべての文字が有効です。フィールド定義「A=A」は定義済みのフィールド文字列エントリを再割り当てするため、10 番目の位置では A だけが想定されています。


Read Text (OCRMax) Identification Tool - Diagnostics Tab

[診断] タブ (文字認識 (OCRMax) 識別ツール)

文字認識 (OCRMax) ツールが、領域内でどのようにセグメント化されているかについての情報を表示します。このデータは、どのパラメータをどの程度調整するか、文字や文字フラグメントが正しくセグメントされているかどうかを判断するのに有用です。診断データのグラフィックス表示方法を設定する [診断の表示] パラメータとともに、このタブを使用してください。

閉じた メインライン角度

領域を基準にして、文字領域の角度値を度数で表示します。

閉じた 文字スキュー

領域を基準にして、文字領域のスキュー角度値を度数で表示します。

閉じた 文字間ギャップ

文字間ギャップの最小および最大値をピクセル単位で表示します。

閉じた 文字内ギャップ

文字内ギャップの最小および最大値をピクセル単位で表示します。

閉じた 文字ピッチ

文字の最小および最大ピッチ値をピクセル単位で表示します。

閉じた 合格フラグメントのサイズ

合格フラグメントの最小および最大サイズをピクセル単位で表示します。

閉じた 合格フラグメントのコントラスト

合格フラグメントの最小および最大コントラスト値をピクセル単位で表示します。

閉じた 合格フラグメントのメインラインまでの距離 (%)

すべての合格フラグメントの最大 Y 距離を、メインラインの高さのパーセンテージとして表示します。

閉じた 除外したフラグメントのサイズ

除外したフラグメントの最小および最大サイズをピクセル単位で表示します。

閉じた 除外したフラグメントのコントラスト

除外したフラグメントの最小および最大コントラスト値をピクセル単位で表示します。

閉じた 除外したフラグメントのメインラインまでの距離 (%)

すべての除外したフラグメントの最大 Y 距離を、メインラインの高さのパーセンテージとして表示します。

閉じた 合格した文字の幅

合格した文字の最小および最大幅をピクセル単位で表示します。

閉じた 合格した文字の高さ

合格した文字の最小および最大の高さをピクセル単位で表示します。

閉じた 合格した文字のサイズ

合格した文字の最小および最大サイズをピクセル単位で表示します。

閉じた 除外した文字の幅

除外した文字の最小および最大幅をピクセル単位で表示します。

注 : 除外した文字がない場合、#ERR が表示されます。
閉じた 除外した文字の高さ

除外した文字の最小および最大の高さをピクセル単位で表示します。

注 : 除外した文字がない場合、#ERR が表示されます。
閉じた 除外した文字のサイズ

除外した文字の最小および最大サイズをピクセル単位で表示します。

注 : 除外した文字がない場合、#ERR が表示されます。


[結果] タブ (文字認識 (OCRMax) 識別ツール)

閉じた 文字

そのポジションで読み取った文字を表示します。

閉じた ステータス

読み取った文字のステータス ([読み取り (Bad)]、[読み取り (Good)]、[無視]、[コンフュージョン]、[ミスマッチ]、[コンフュージョンミスマッチ] または [検証失敗]) を返します。

  • [読み取り (Bad)]: 読み取り成功とみなす、[アクセプトしきい値] を上回る得点を獲得した文字がない場合に返されます。
  • [読み取り (Good)]: このポジションの文字の読み取りに成功した場合に返されます。
  • [無視]: フィールドを有効にしたときに、読み取った文字列がフィールド文字列で指定した文字数より短い場合、文字列の最初または最後の文字は (黄色で) セグメント化されますが、全体の結果には含まれません。例えば、フィールド定義が ABC で、読み取った文字列が「12ABC34」の場合、「1234」は無視されます。
  • [コンフュージョン]: 読み取り成功 (得点が [アクセプトしきい値] パラメータを上回る) に十分な高得点の文字を識別しましたが、他の文字もほぼ同じスコア ([コンフュージョンしきい値] 内) を得点したため、正しい文字を選択したかどうか、確信が持てない場合に返されます。[コンフュージョン = (最高得点 - 2 番目に高い得点)/信頼性しきい値]
  • [ミスマッチ]: フィールド化に一致しない文字を検出しましたが、その文字がフィールド化に一致しない文字より高い得点を獲得している場合に返されます。フィールド化に一致しない文字がこのポジションに印刷されている可能性が高いです。[フィールド化] タブを有効にしたときのみ、このステータスが返されます。
  • [コンフュージョンミスマッチ]: [コンフュージョン] および [ミスマッチ] の両方の条件を満たす文字を検出したときに返されます。
  • [検証失敗]: [追加の文字検証をスキップ] パラメータを無効にした場合に、追加の検証ステップを使用して文字を解析しますが、その検証に失敗した場合に返されます。
閉じた 得点

読み取った文字が、フォントデータベース内の登録文字にどれだけマッチしているか、その得点を返します。

閉じた コンフュージョン

2 番目にマッチする文字を返します。

閉じた コンフュージョン得点

2 番目にマッチする文字と比較して、選択したマッチがどれだけ信頼性があるかを返します。


文字認識識別ツール

文字認識識別ツールは、登録済みの文字モデルを基に、英数文字列の照合/認識に使用されます。

注 : In-Sight Explorer 4.7.0 以降では、文字認識識別ツールは OCRMax をサポートしない In-Sight ビジョンシステムでのみ使用できます。また、In-Sight ファームウェア 5.1.0 以降ではサポートされていません。

ツールを設定するには

ツールのパラメータを調整するには


文字認識識別ツールを設定するには

ツールを追加したら、領域のタイプを選択し、画像を設定します。

  1. 文字全体を囲むように領域を配置します (認識させる文字を選択するにはトピックを参考にしてください)。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけツールの実行時間が増大します。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. [設定] タブの [モード] (選択肢は、[読み取り]、[照合] または [認識と照合]) 、[フォント] (選択肢は、[OCR-A 白地に黒]、[OCR-A 黒地に白]、[OCR-B 白地に黒]、[OCR-B 黒地に白] または [カスタム]) 、および [フィールド文字列] または [マッチ文字列] の文字数を定義してください ([モード] によってどちらの文字数を指定するかが決まります)。

    • [モード] で [読み取り] を選択し、OCR-A または OCR-B フォントを選択した場合、[フィールド文字列] の文字数を指定してから [チューニング] を押してスケールを設定します。

    • [モード] で [照合] または [認識と照合] を選択し、OCR-A または OCR-B フォントを選択した場合、[マッチ文字列] の文字を指定してから[チューニング] を押してスケールを設定します。

    注 : OCR-A または OCR-B フォントを使用している場合、画像中の文字は 15～60 ピクセルである必要があります。[チューニング] ボタンを押して、文字スケールを正しく設定してください。 文字が 15 ピクセル以下の場合、または 60 ピクセル以上の場合、カスタムフォントを作成する必要があります。
  4. [フォント] で [カスタム] を選択した場合、[フォントの登録] ボタンを押して、フォントライブラリを作成してください。 その後、[モード] [読み取り] を選択した場合、[フィールド文字列] の文字数を指定し、[照合] または [認識と照合] を選択した場合には [マッチ文字列] の文字を指定します。
  5. 1 つのジョブ内で、4 つまでのカスタムフォント (例: Custom_1～4) を使用することができます。また、ジョブに登録されたカスタムフォントは、他の文字認識識別ツールと共有することができます。
  6. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  7. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。

カスタムフォントを作成するには

認識させる文字を選択するには


カスタムフォントを作成するには

  1. カスタムフォントを設定するには、[設定] タブをクリックし、[フォントの登録] ボタンを押します。[OCV/OCR フォントの登録] ダイアログが開き、アプリケーションに合わせて文字を設定することができます。

    注 : 1 つのジョブ内で、4 つまでのカスタムフォント (例: Custom_1～4) を使用することができます。
  2. [登録] タブで、フォントに名前を付けることができます。複数のフォントライブラリがある場合、この機能は有用です。

  3. 文字の [極性] を設定します。登録する文字が周囲の背景よりも明るい場合は、[極性] として [白 (黒い背景) ] を選択します。登録する文字が周囲の背景よりも暗い場合は、[黒 (白い背景) ] を選択します。

    注 : [フォントの追加] をクリックする前に、登録する文字の極性が正しく設定されていることを確認してください。文字モデルをフォントに追加した後に極性を変更することはできません。
  4. 識別されるべき文字列を定義します。 識別される文字列はモデル文字と大文字または小文字までマッチするようにしてください。モデル文字にスペースがある場合、識別される文字列にもスペースを入れてください。
  5. 文字列を入力したら、[セグメント] ボタンをクリックします。 各文字には個別の領域と識別子が含まれるようにしてください。含まれない場合は、[セグメントの調整] を使用して次の作業を行ってください。
    • [修正] ボタンを押して、個々のインスタンスを囲む領域を変更します。
    • [ラベルの変更] ボタンを押して、文字インスタンスに新しい名前を割り当てます。
    • [削除] ボタンを押して、文字インスタンスを削除します。
  6. 画像内の文字の識別に問題がなければ、[フォントの追加] ボタンをクリックします。 識別された各文字のインスタンスがユーザフォントとして登録されます。
  7. ユーザフォントにはいくつかの文字モデルが含まれています。いくつかのモデルは、複数のインスタンスにより構成されています。スペースや句読点を含むすべての文字が切り出され、文字モデルとして登録されます。

  8. ここで、すべての文字モデルを参照して、特定のモデルまたはインスタンスの追加、削除、編集、名前変更、または有効化/無効化を行うことが可能です。

    注 : ジョブに登録されたカスタムフォントは、他の文字認識識別ツールと共有することができます。
  9. 登録されたフォントに問題がなければ、[OK] ボタンを押してください。


認識させる文字を選択するには

一貫した結果を得るために、次のガイドラインを参考にしてください。

閉じた フォント
  • OCR/OCV アプリケーション専用にデザインされた特殊フォントを使用してください。
  • 文字のストローク幅が 5 ピクセル以上あるようにしてください。文字ができるだけ画像を満たすようにしてください。文字のピクセル数が多いほどツールの正確性が高まるが、実行時間は増大します。
  • 画像中に複数のフォントタイプが存在する場合、各フォントタイプごとに異なる文字認識識別ツールを使用してください。
  • 画像中に複数のフォントサイズが存在する場合、各フォントサイズごとに異なる文字認識識別ツールを使用してください。
閉じた OCR/OCV 専用特殊フォント

閉じた 文字モデルとインスタンス
  • 明瞭かつ特徴ある文字モデルを作成するために、高解析度の文字を使用するしてください。
  • 各文字認識識別ツールは最大 255 種類の文字モデルをサポートし、各文字モデルは最大 8 種類までの登録済みインスタンスから作られています。文字モデルのインスタンスを追加登録すると、文字モデルの変化の許容値は増大します。アプリケーションの変化の許容値が低い場合、高品質の文字モデル 1 つのみを登録してください。アプリケーションの変化の許容値が高い場合、できるだけ多くのインスタンスを文字モデルとして登録してください。
  • 文字モデルの登録の際には、印字にできるだけ一貫性があるようにしてください。文字の形やサイズが大幅に変化すると、悪い文字モデルとなりジョブの実行時に FAIL となります。
閉じた 登録インスタンス例

良い登録インスタンス

悪い登録インスタンス


文字認識識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

文字認識識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • 文字モデルテーブル
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

文字モデルテーブル


[全般] タブ (文字認識識別ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は文字_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (文字認識識別ツール)

閉じた フォントの登録

[OCV/OCR フォントの登録] ダイアログが開き、フォント (文字モデルおよびそのインスタンス) の定義や編集を行うことができます。

閉じた モード

ツールのモードを指定します。選択肢は、[読み取り]、[照合]、または [認識と照合] です。

  • [読み取り]: 登録済みの文字モデルを基に、文字列をデコードします。デコードされた文字列は、[フィールド文字列] で定義された文字数にマッチする必要があります。
  • [照合]: [マッチ文字列] で定義された文字列を基に、文字列をデコードします。
  • [認識と照合]: 文字列をデコードし、[マッチ文字列] で定義された文字列とデコードされた文字列を比較します。PASS の結果を得るためには、デコードされた文字列は、[マッチ文字列] で定義された文字列と合致している必要があります。
注 : このツールには、PASS と FAIL の 2 つのステータスしかありません。したがって、ツールの [モード] コントロールを [照合] または [認識と照合] に設定している際に FAIL が返される場合、2 つのシナリオが考えられます。1 つは、読み取りに失敗した場合、もう 1 つは、読み取りには成功したものの、[マッチ文字列] パラメータに入力した文字列と一致しない場合です。

後者の場合、[認識と照合] が選択されている時に、ツールはミスマッチデータ ([ミスマッチ] および [ミスマッチ数]) を出力します。このデータは、EasyView および [通信] アプリケーションステップの他のコミュニケーションデバイスで使用することができます。ミスマッチデータは、[EasyView アイテムの選択]、[OPC タグの選択] または [入力/出力データ] ダイアログから選択することができます。

ミスマッチデータは、ツールがコードの読み取りに失敗したのか、それとも、コードの読み取りに成功したものの、文字列が [マッチ文字列] で定義した情報と一致しないのかを決定する必要がある場合に有用です。例えば、ツールが文字列の読み取りに失敗した場合、文字列印刷のプロセスやビジョンシステムのセットアップに問題がある可能性があります。文字列の読み取りに成功したものの、[マッチ文字列] で定義した情報に一致しない場合、異なる文字列が印刷されている可能性があります。
閉じた フォント

フォントのタイプを定義します。 定義済みのフォントタイプ (OCR-A/OCR-B、白地に黒/黒地に白) から選択するか、あるいは文字モデルを登録することによってカスタムフォントを作成することができます。

注 : 1 つのジョブ内で、4 つまでのカスタムフォント (例: Custom_1～4) を使用することができます。
閉じた フィールド文字列

[読み取り] モードを選択した際に、文字列に含まれる文字数を定義します。フィールド文字列の各文字は、0～31 のインデックス付きポジションに対応します。フィールド文字列には、文字列の文字と同じ数のポジションが含まれている必要があります。

フィールド文字列エントリには、(A～Z)、(a～z)、(0～9)、ハイフン (-) 、ドット (.) 、スペース ( ) を使用することができます。デフォルトでは、フィールド文字列の各ポジションは、アスタリスク (*) 、つまり英数字の「ワイルドカード」で示されます。これは、文字列のそのポジションではすべての文字が有効であることを意味します。

フィールド文字列の個別のポジションは、そのポジションに一部の文字しか想定されないように制限することができます。これにより、全体的な性能と信頼性が向上します。

フィールド文字列 エントリ | 説明 | 有効な文字
* | ワイルドカード | フォントに含まれる任意の登録文字です。
N | 数字 | 0123456789
A | 大文字の英字 | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | 小文字の英字 | abcdefghijklmnopqrstuvwxyz
H | 16 進値 (大文字の英字と数字) | 0123456789ABCDEF
h | 16 進値 (小文字の英字と数字) | 0123456789abcdef
O | 8 進値 | 01234567
閉じた マッチ文字列

読み取りされる文字列を定義します。[モード] で、[照合] または [認識と照合] が選択された場合のみに有効となります。デコードする情報を入力してください。

注 : マッチ文字列は他のデバイスから入力されることがあります。ジョブの実行時に、識別ツールを使用して入力デバイスからの文字列を読み取って、認識済みの ID コードと比較することができます。マッチ文字列が外部デバイスから入力されるまで、文字認識ツールの結果は FAIL となり、[マッチ文字列] には TRIG　が表示されます。
閉じた [チューニング] ボタン

フォントライブラリ登録済み文字モデルと画像中の文字間のスケール差 (50～200%) を計算します。[チューニング] ボタンは、文字モデルと文字列の文字間のサイズ差が ±5% 以上の場合のみ使用してください。

閉じた アクセプトしきい値

文字列中の各文字のスコアを 0～100 で定義します。デフォルトは 70 です。この設定以下の文字が 1 つでも文字列に含まれると、文字列全体の結果は FAIL となります。

閉じた モードの読み取り

文字列を読み取る際のアルゴリズムモードを定義します。選択肢は、[高速モード] (デフォルト) および [高精度モード] です。[高速モード] は、鮮明で高コントラストの画像を使用して、ツールを高速処理する必要がある場合に有用です。[高精度モード] は、不鮮明で低コントラストの画像を使用して、ツールの処理時間が問題とならない場合に有用です。

閉じた 得点差しきい値

1 番得点の高い文字と 2 番目の得点の文字間の得点差を 0～20 で定義します。デフォルトは 0 です。 得点差が指定の値と同じ、またはそれ以下の場合、文字列全体の結果は FAIL となります。

閉じた 擬似背景

画像内のそのほかの特徴が、文字列と判別しにくい場合に補正を行います。デフォルトは OFF です。 [擬似背景] を ON にした場合、ツールの処理速度は遅くなります。領域内のほかの特徴が文字列の先頭と誤って認識されてしまう場合に有用です。

閉じた スケール許容

文字スケールのばらつきを許容します。デフォルトは OFF です。

領域内のほかの特徴が文字列の先頭と誤って認識されてしまう場合に有用です。

閉じた タイムアウト

ツールがテキストをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

閉じた 結果

デコード、または検証された文字列情報を表示します。


文字モデルテーブル (文字認識識別ツール)

閉じた インデックス

文字列の文字ポジションを表示します。

閉じた 文字

最高得点の文字モデルを表示します。つまり、文字列の文字に一番マッチする文字モデルが表示されます。

閉じた 得点

最高得点の文字モデルにおける信頼性得点を表示します。[設定] タブの [アクセプトしきい値] より低い値が返された場合、文字列全体の結果は FAIL となります。

閉じた 合格

結果の PASS/FAIL を表示します。[得点] および [得点差] の値が、[設定] タブの [アクセプトしきい値] および [得点差しきい値] と同等または下の場合は FAIL を、上の場合は PASS を返します。

閉じた 第 2 候補文字

2 番目に高い得点の文字モデルを表示します。つまり、文字列の文字に二番目にマッチする文字モデルが表示されます。

閉じた 第 2 候補得点

2 番目に高い得点の文字モデルにおける信頼性得点を表示します。

閉じた 得点差

最高得点と 2 番目に高い得点の間の差を表示します。この値が [得点差しきい値] と同等または下の場合は、文字列全体の結果は　FAIL となります。


PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツール

注 :
  • In-Sight ファームウェア 5.5.0 以降、ツールのアルゴリズムが変更され、条件によっては、より正確な結果を返すようになり、実行時間が短縮されました。
  • この変更により、In-Sight ファームウェア 5.5.0 以降で作成されたこのツールを含むジョブを、ファームウェアバージョン 5.4.x 以前を搭載した In-Sight ビジョンシステムにロードしようとすると、エラーメッセージが表示されます。
  • PatMax RedLine パターン識別ツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターンおよび PatMax パターン識別ツールは、PatMax RedLine または PatMax アルゴリズムを使用して、パターンの特徴を登録し、画像中に抽出した特定のパターンの特徴を検証または識別するのに使用されます。

これらのツールは、ロゴやラベル、部品を基に、製造ライン上に正しい製品が流れていることを確認したり、他の生産現場のデバイスに、認識した製品の情報を通信したりするアプリケーションにおいて有用です。

ツールを設定するには

ツールのパラメータを調整するには


PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツールは、最大 10 までのモデルパターンのライブラリを作成することができます。各モデルパターンは、それぞれ別のパターンを使用して登録する必要があります。ツールは、登録済みパターンから個々のインスタンスをサーチします。1 つの画像から複数のインスタンスを認識することはできません。

  1. [モデル] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [サーチ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。

  3. [OK] ボタンを押し、領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。モデル領域の色が変わり、定義済みを表す緑色に提示されます。

  4. 2 番目のモデルパターンを定義するには、新しいパターンが存在する新しい画像をロードするか取り込んでください。テーブルから未登録のパターンを選択し ([登録済み] 列に [未登録] と表示されています)、[モデル領域] ボタンをクリックし、1～3 までのステップを繰り返してください。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。

パターンを選択するには

PatMax RedLine パターン、PatMax パターンおよびパターン


PatMax RedLine パターン、PatMax パターンおよびパターン

注 : PatMax RedLine パターン識別ツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターン、PatMax パターンおよびパターンツールは、どちらも登録済みのモデルパターンを検出する、最も高精度な検査ツールです。中でも PatMax RedLine パターンおよび PatMax パターンツールは、照明の条件やパターンのポジションが大幅に変わっても特徴を検出できるため、より強力な検査ツールと言えます。PatMax RedLine パターンおよび PatMax パターンツールは、スケール変化、回転、部分的な遮蔽、照明のばらつきによる外観変化に対しても、より優れた認識能力を発揮します。

PatMax RedLine パターンと PatMax パターンの主な違いはそのスピードにあります。PatMax RedLine パターンは最新のパターンマッチアルゴリズムを使用し、5 メガピクセルの画像内の登録した特徴を PatMax パターンの最大 7 倍の速さで検出します。よって、PatMax RedLine パターンは高解像度のビジョンシステムに最適と言えます。

通常、パターンツールは PatMax パターンツールより高速に動作します。しかし、次のような状況では PatMax RedLine または PatMax パターンツールの正確性および信頼性が必要とされる場合があります。

  • 照明のばらつきや反射の抑制が困難な場合 (例: 光を乱反射しやすい金属物を検査する場合)。
  • 検査対象物に似た形状やシェーディングが背景上にある場合、またはパターンが重なっていたり、他の物体によって部分的に隠蔽されていたりする場合。
  • 他の類似したパターンを除外し、目的の検査パターンを正確に検出したい場合。
  • 設置環境の状態によって、パターンツールでは一貫した信頼性のある検査を実行できない場合。


PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [モデル] および [サーチ] タブ
  • テーブル
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[モデル] および [サーチ] タブ

テーブル


[全般] タブ (PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 計数ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は品種 ID_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツール)

閉じた モード

ツールのモードを定義します。選択肢は、[識別] または [照合] です。

[識別] (デフォルト) は、検査するパターンが未知の場合に使用されます。 ツールは領域に基づいて画像を自動的に検査し、登録済みパターンライブラリからどのパターンが表示されているかを判断し、その情報を [結果] パラメータに返します。

[照合] は、正しいパターンが存在する場合に使用されます。 ツールは指定のパターンをサーチして、検出されたパターンと [パターン] パラメータで指定されたパターンを比較します。

閉じた パターン

照合する登録パターンを定義します。この設定を有効にするには、[モード] から [照合] を選択する必要があります。 登録済みのパターンから選択してください。

閉じた アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 65 です。 この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。 この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

閉じた コントラストしきい値

検出パターンに存在する必要のある、最小コントラスト値を指定します。有効なインスタンスとみなすには、検出パターンのコントラストが [コントラストしきい値] より高い必要があります。PatMax RedLine パターンではデフォルト = 0、有効なパラメータ範囲は 0～100 です。PatMax パターンではデフォルト = 10、有効なパラメータ範囲は 0～255 です。低コントラストの画像には、低いコントラストしきい値が使用され、高コントラストの画像には、高いコントラストしきい値が使用されます。

注 : PatMax RedLine パターンでは、登録パターン内の特徴とサーチ画像内のマッチする特徴との間のコントラスト差をパーセンテージで表した、「相対」コントラストが報告されます。よって、特徴のコントラストがパターンコントラストと同じまたはより高い場合、報告されるコントラストは ~100 となります。特徴のコントラストがパターンコントラストより低い場合、報告されるコントラストは <100 となります。PatMax RedLine パターンのコントラストは PatMax パターンのコントラストは異なります。PatMax パターンでは、サーチ ROI 内の「絶対」画像コントラストがグレースケール値で報告されます。
閉じた 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。 大きな値を設定すると、ツールの実行時間が増大します。

閉じた スケール許容

モデルパターンの大きさを基準とした、検出パターンで許容されるスケール変化量を指定します (0～50、デフォルトは 0% です)。この値を 5 に設定すると、モデルの大きさに対して 95～105% のサイズのパターンが検出対象となります。大きな値を設定すると、ツールの実行時間が増大します。

閉じた 得点差しきい値

検出されたパターンと任意の登録済みモデルパターンの得点差を 0～20 で定義します。デフォルトは 0 です。 この値は、任意の 2 つの登録モデルパターンの間の得点差です。つまり、得点差しきい値が 5 の場合、他のモデルパターンより 5 得点以上のパターンを検出します。

閉じた 検出モード

パターンの登録および認識に使用されるサーチモードを指定します。選択肢は、[PatMax] (デフォルト) または [PatQuick] です。 デフォルトでは、[PatMax] が選択されています。 PatMax は、PatQuick より高精度ですが、実行時間が長くなります。一方、PatQuick は、PatMax より精度が低いですが、実行時間は短くなります。

閉じた クラッタ

モデルパターンと比較して、検出パターンの欠落または遮蔽された特徴を得点に考慮するかどうかを定義します。デフォルトは OFF、すなわち欠落があっても得点は減点されません。 クラッタを ON にすると、検出パターン中の特徴欠落によって得点が減点されます。

閉じた タイムアウト
ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。デフォルトで、このパラメータは 1,000 に設定されています。
閉じた 結果

識別されたパターンの名前を表示します。

注 : PatMax RedLine パターンには、[検出モード] パラメータは含まれていません。


[モデル] および [サーチ] タブ (PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツール)

[モデル] および [サーチ] タブを使用して、ツールのモデルおよびサーチ領域の合成領域を設定します。 合成領域は、サブ領域 (矩形、円環、円またはポリゴン) の集合体で、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • [モデル] タブでは、[モデル領域] ボタンを押した後にのみ、合成領域を有効にすることができます。
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


テーブル (PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツール)

テーブルには、登録済みパターンテーブルおよび登録済みパターンのサムネイル画像が表示されます。

閉じた テーブル

名前: 登録済みパターンの名前が表示されます。アプリケーションに合わせて、名前を変更することができます。

登録済み: パターンが登録済みかどうかを表示します。登録済みパターンの場合、[登録済み] が表示され、未登録の場合は [未登録] が表示されます。

得点: 検出された登録済みパターンの得点を表示します。

注 :
  • パターンをツールから削除するには、テーブルタブ内のパターンを右クリックし、メニューから [削除] を選びます。
  • テーブルタブ表示には、[サムネイル表示]、[詳細表示] および [並べて表示]の 3 つのオプションがあります。設定ペインの異なる表示オプションを選択するには、テーブル内の任意の場所で右クリックし、[表示] サブメニューから使用するオプションを選択してください。
閉じた [モデル領域] ボタン

パターンを登録します。

閉じた [名前の変更] ボタン

テーブルの登録パターンを選択してからこのボタンを押すと、アプリケーションに合わせた名前に変更することができます。

閉じた 登録画像のサムネイル

[モデル領域] ボタンの下に、モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


パターン (1-10) 識別ツール

パターン (1-10) 識別ツールは、パターン特徴のオカレンスを登録し、画像中のオカレンスを検証または識別するのに使用されます。

このツールは、ロゴやラベル、部品を基に、製造ライン上に正しい製品が流れていることを確認したり、他の生産現場のデバイスに、認識した製品の情報を通信したりするアプリケーションにおいて有用です。

ツールを設定するには

ツールのパラメータを調整するには


パターン (1-10) 識別ツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

パターン (1-10) 識別ツールは、最大 10 までのモデルパターンのライブラリを作成することができます。各モデルパターンは、それぞれ別のパターンを使用して登録する必要があります。ツールは、登録済みパターンから個々のインスタンスをサーチします。1 つの画像から複数のインスタンスを認識することはできません。

  1. 1 番目の登録モデルとして使用されるパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。

  2. パターンの出現する可能性がある場所をサーチ領域で囲みます。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。

    注 : モデルおよびサーチ領域は、円弧またはドーナツ状に曲げることはできません。
  3. [OK] ボタンを押し、領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。モデル領域の色が変わり、定義済みを表す緑色に提示されます。
  4. 2 番目のモデルパターンを定義するには、新しいパターンが存在する新しい画像をロードするか取り込んでください。テーブルから未登録のパターンを選択し ([登録済み] 列に [未登録] と表示されています) 、[モデル領域]　ボタンをクリックし、1～3　までのステップを繰り返してください。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


パターン (1-10) 識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

パターン (1-10) 識別ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [テーブル] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

テーブル


[全般] タブ (パターン (1-10) 識別ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([画像の設定]、[入力/出力] および [通信]) で参照されます。デフォルトのツール名は品種 ID_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (パターン (1-10) 識別ツール)

閉じた モード

ツールのモードを定義します。選択肢は、[識別] または [照合] です。

[識別] (デフォルト) は、検査するパターンが未知の場合に使用されます。ツールは領域に基づいて画像を自動的に検査し、登録済みパターンライブラリからどのパターンが表示されているかを判断し、その情報を [結果] パラメータに返します。

[照合] は、正しいパターンが存在する場合に使用されます。ツールは指定のパターンをサーチして、検出されたパターンと [パターン] パラメータで指定されたパターンを比較します。

閉じた パターン

照合する登録パターンを定義します。この設定を有効にするには、[モード] から [照合] を選択する必要があります。登録済みのパターンから選択してください。

閉じた アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

閉じた 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。大きな値を設定すると、ツールの実行時間が増大します。

閉じた スケール許容

検出パターンのスケール変化 (±10% 以内) を許容するかどうかを指定します。デフォルトは OFF です。大きな値を設定すると、ツールの実行時間が増大します。スケール許容を ON にすると、±10% の範囲でパターンを検出しますが、スケール変化量が大きくなるほど、特徴の得点は低くなります。

閉じた 得点差しきい値

検出されたパターンと任意の登録済みモデルパターンの得点差を 0～20 で定義します。デフォルトは 0 です。この値は、任意の 2 つの登録モデルパターンの間の得点差です。つまり、得点差しきい値が 5 の場合、他のモデルパターンより 5 得点以上のパターンを検出します。

閉じた モデルタイプ

ツールが、どのようにモデルパターンを作成するかを定義します。選択肢は、[エリアモデル] または [エッジモデル] です。[エリアモデル] は、モデル領域からのグレースケース値の均一サンプリングに基づいてパターンを作成します。[エッジモデル] は、モデル領域内のパターンの検出エッジ (白/黒の遷移) に基づいて、モデルパターンを作成します。

閉じた 高精度モード

ツールがどのように精度/信頼性と実行速度のトレードオフを評価するか定義します。選択肢は、[高精度]、[中程度] (デフォルト) および [高速] です。[高精度] は、精度/信頼性が高くなる反面、実行速度が遅くなります。[高速] は、実行速度が速くなる反面、精度/信頼性が低くなります。[中程度] は、その中間を取るように指定します。

閉じた タイムアウト

ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

閉じた 結果

識別されたパターンの名前を表示します。


テーブル (パターン (1-10) 識別ツール)

テーブルには、登録済みパターンテーブルおよび登録済みパターンのサムネイル画像が表示されます。

閉じた テーブル

名前: 登録済みパターンの名前が表示されます。アプリケーションに合わせて、名前を変更することができます。

登録済み: パターンが登録済みかどうかを表示します。登録済みパターンの場合、[登録済み] が表示され、未登録の場合は [未登録] が表示されます。

得点: 検出された登録済みパターンの得点を表示します。

注 :
  • パターンをツールから削除するには、テーブルタブ内のパターンを右クリックし、メニューから [削除] を選びます。
  • テーブルタブ表示には、[サムネイル表示]、[詳細表示] および [並べて表示]の 3 つのオプションがあります。設定ペインの異なる表示オプションを選択するには、テーブル内の任意の場所で右クリックし、[表示] サブメニューから使用するオプションを選択してください。
閉じた [モデル領域] ボタン

パターンを登録します。

閉じた [名前の変更] ボタン

テーブルの登録パターンを選択してからこのボタンを押すと、アプリケーションに合わせた名前に変更することができます。

閉じた 登録画像のサムネイル

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


カラーモデル識別ツール

カラーモデル識別ツールは、カラーモデルライブラリ中のどのカラーモデルが、画像中の色に一番マッチするかを決定し、そのカラーモデルの名前を返します。

カラーモデルツールは、登録済みのカラーモデルライブラリを参照し、ライブラリ内の選択した登録済みカラーモデルにマッチする、領域内のピクセル数を決定します。ツールのモード (デフォルト設定の[識別] または [マッチ]) に基づき、検査基準に最もマッチするカラーモデルの名前を返します。また、ツールは、有効なカラーモデルにマッチするピクセルを白 (255) に、それ以外のピクセルを黒 (0) に設定する、二値化グレースケール出力画像を生成します。

  1. カラーモデル識別ツールを設定するには
  2. カラーモデル識別ツールのパラメータを調整するには
  3. カラーモデル識別ツールの入出力プロパティを使用するには

ツールを設定するには

ツールのパラメータを調整するには


カラーモデル識別ツールを設定するには

ツールを追加したら、領域のタイプを選択し、画像を設定します。

  1. [モデル] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 カラー全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのカラーがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、カラーが移動しても十分にカバーできる大きさに領域を設定してください。

    注 : ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。

  4. カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。

  5. カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブに戻り [カラーライブラリ] を選択してから、[ライブラリ] タブで使用する [カラーモデル] のチェックボックスを ON にします。

  6. [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  7. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。
  8. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  9. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーモデル識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーモデル識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [テーブル] タブ
  • ライブラリ
  • [合成領域] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

カラーライブラリ

テーブル

[合成領域] タブ


[全般] タブ (カラーモデル識別ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名はカラーモデル識別_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーモデル識別ツール)

閉じた [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

閉じた カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール
閉じた モード

ツールのモードを定義します。選択肢は、[識別] または [マッチ] です。

  • [識別]: 画像内のカラーが不明な場合に使用します。このツールは、どのカラーモデルが画像中の色に一番マッチするかを決定します。選択したカラーライブラリに有効なカラーモデルが複数ある場合、そのピクセル数に基づき結果を順番付けし、ランクを決定します。
  • [マッチ]: 指定したカラーモデルが画像に存在するかを検証します。このツールは画像を処理し、画像内のカラーが [マッチカラー] パラメータで指定したカラーモデルと一致するかどうかを決定します。
閉じた マッチカラー

検出されるカラーモデルを指定します。このフィールドは、[モード] パラメータを [マッチ] に設定した場合にのみ有効となります。検出するカラーモデルの名前をフィールドに入力してください。

閉じた 最小ピクセル数

カラーモデルがマッチするとみなされる、最小ピクセル数しきい値を定義します (0～9,999,999、デフォルトは 1,000)。例えば、[識別] モードで、このしきい値を 1,000 に設定すると、ピクセル数が 1,000 以下のカラーモデルはすべて除外されます。[マッチ] モードでは、指定のカラーモデルにマッチするカラーモデルが 1,000 ピクセル以下だと、ツールは FAIL を返します。

閉じた 結果

検出されたカラーモデルの名前を表示します。


ライブラリ (カラーモデル識別ツール)

閉じた [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

閉じた カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

閉じた カラー名

選択したカラーモデルに含まれるカラー名を表示します。

閉じた RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

閉じた 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


テーブル (カラーモデル識別ツール)

最もマッチした検出カラーモデルを、ランクおよび得点順にソートして 10 位まで表示します (読み取り専用)。

閉じた ランク

検査基準に最もマッチしているカラーモデルをランク順に 1～10 まで表示します。

閉じた 名前

検出されたカラーモデルの名前を表示します。

閉じた ピクセル数

検出されたカラーモデルのピクセル数を表示します。


[合成領域] タブ (カラーモデル識別ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


2 点間の直線幾何・計測ツール

2 点間の直線幾何・計測ツールは、2 つの入力特徴 (点、フィクスチャ原点または円特徴の中心) の間に参照線を作成し、その線の両端の座標を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


2 点間の直線幾何・計測ツールを設定するには

ツールを追加したら、ラインを作成するのに使用される、入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 2 番目の特徴を選択します。
  4. EasyBuilder は 2 つの特徴の間に自動的に直線を作成します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


2 点間の直線幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

2 点間の直線幾何・計測ツール設定ペインには、次のコントロールが表示されます。

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名はライン_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


2 点間の中点幾何・計測ツール

2 点間の中点幾何・計測ツールは、2 つの入力特徴 (点、フィクスチャ原点または円特徴の中心) の中点を計算し、特徴間に参照線を作成します。同時に、フィクスチャを基準とした中点の角度と、中点の座標を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


2 点間の中点幾何・計測ツールを設定するには

ツールを追加したら、ラインを作成するのに使用される、入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。

  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。

  3. 2 番目の特徴を選択します。

  4. EasyBuilder は 2 つの特徴の間に自動的に直線を作成し、中点の場所に [image] を配置します。 同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


2 点間の中点幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

2 点間の中点幾何・計測ツール設定ペインには、次のコントロールが表示されます。

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [検査の結果] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は中点_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

閉じた [設定] タブ
閉じた 結果

2 つの入力特徴間の中点座標、およびフィクスチャを基準にした中点の角度方向を返します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


2 点間の距離幾何・計測ツール

2 点間の距離幾何・計測ツールは、2 つの入力特徴 (点、フィクスチャ原点または円特徴の中心) の中点間の距離をエッジまたは直線を基準に計算します。同時に、距離を示す参照線を作成し、その寸法を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

2 点間の距離幾何・計測ツールは、組み立て時の配置を正確に測定する場合に有用です。

ツールを設定するには

ツールのパラメータを調整するには


2 点間の距離幾何・計測ツールを設定するには

ツールを追加したら、ラインを作成するのに使用される、入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 2 番目の特徴を選択します。
  4. EasyBuilder は自動的にジョブを検査し、計測用の参照線として使用するエッジまたは直線スマートフィーチャーを提示します。参照するエッジまたは直線を選択してください。
  5. その後、EasyBuilder は特徴の中点から、参照エッジまたは直線に対して垂直の参照線を引き、その参照線と参照エッジ/直線の間の距離を計算します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  6. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  7. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


2 点間の距離幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

2 点間の距離幾何・計測ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[制限範囲] タブ


[全般] タブ (2 点間の距離幾何・計測ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [検査の結果] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は寸法_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (2 点間の距離幾何・計測ツール)

閉じた 最大

最大距離を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 距離

参照エッジまたは参照線を基準にして、2 つの特徴の中点から垂直に引いた 2 本の参照線の間の距離を表示します。値が [最小] ～ [最大] の範囲内にある場合、PASS を返します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
閉じた 最小

最小距離を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


垂直線幾何・計測ツール

垂直線幾何・計測ツールは、直線またはエッジ特徴に対して垂直の参照線を作成し、その両端の座標を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


垂直線幾何・計測ツールを設定するには

ツールを追加したら、直線またはエッジ特徴に対する垂直線を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. 直線またはエッジ特徴を選択すると、EasyBuilder は、特徴に対して垂直の直線の交点を自動的に決定します。同時に、垂直線を定義する参照線およびエッジ有無判定ツールを挿入し、未設定の特徴を設定します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


垂直線幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

垂直線幾何・計測ツール設定ペインには、次のコントロールが表示されます。

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名はライン_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


直線交点幾何・計測ツール

直線交点幾何・計測ツールは、2 つのエッジ特徴/参照線の交点を特定し、その座標を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


直線交点幾何・計測ツールを使用するには

ツールを追加したら、交差するエッジ特徴または直線を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 次に、交差するエッジ特徴または直線を選択してください。
  4. EasyBuilder は自動的に直線の交点を決定し、交点を定義する点を挿入します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


直線交点幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

直線交点幾何・計測ツール設定ペインには、次のコントロールが表示されます。

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [検査の結果] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は交点_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


角度 2 等分幾何・計測ツール

角度 2 等分幾何・計測ツールは、2 つのエッジ特徴または 2 本の直線間の角度を 2 等分する参照線を作成し、その両端の座標を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

角度 2 等分幾何・計測ツールは、検査対象物の特徴を 2 等分する角度を特定したり、他の計測用参照点として 2 等分した角度を使用したりする場合などに有用です。

ツールを設定するには

ツールのパラメータを調整するには


角度 2 等分幾何・計測ツールを設定するには

ツールを追加したら、角度 2 等分参照線の作成に使用される、エッジ特徴または直線を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. 水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。
  3. 次に、2 番目のエッジまたは直線をクリックして、2 等分するエリアを定義してください。
  4. EasyBuilder が、選択したエッジまたは直線から、自動的に参照線を作成します。 同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


角度 2 等分幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

角度 2 等分幾何・計測ツール設定ペインには、次のコントロールが表示されます。

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は 2 等分_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


N 点を通る直線幾何・計測ツール

N 点を通る直線幾何・計測ツールは、2～10 の入力特徴 (点、フィクスチャ原点または円特徴の中心) から参照線を作成し、その両端の座標を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

N 点を通る直線幾何・計測ツールは、画像に存在する複数の特徴から参照線を作成する場合に有用です。

ツールを設定するには

ツールのパラメータを調整するには


N 点を通る直線幾何・計測ツールを設定するには

ツールを追加したら、ラインを作成するのに使用される、入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. 水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。
  3. 次に、直線を定義する特徴をすべて選択してください。 最小 2 から最大 10 までの入力特徴を選択することができます。
  4. 目的の特徴をすべて選択した後、[OK] ボタンを押してください。(ツールの追加を取りやめるには、[キャンセル] ボタンを押してください。)
  5. EasyBuilder が、選択した入力特徴から、自動的に参照線を作成します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  6. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  7. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


N 点を通る直線幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

N 点を通る直線幾何・計測ツール設定ペインには、次のコントロールが表示されます。

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名はライン_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


N 点を通る近似円幾何・計測ツール

N 点を通る近似円幾何・計測ツールは、3～10 の入力特徴 (点、フィクスチャ原点または円特徴の中心) から参照円を作成し、その直径を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

N 点を通る近似円幾何・計測ツールは、画像に存在する特徴から参照円を作成する場合に有用です。

ツールを設定するには

ツールのパラメータを調整するには


N 点を通る近似円幾何・計測ツールを設定するには

ツールを追加したら、参照円を作成するのに使用される、入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. 水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。
  3. 次に、円の定義に使用する特徴をすべて選択してください。 最小 3 から最大 10 までの入力特徴を選択することができます。
  4. 目的の特徴をすべて選択した後、[OK] ボタンを押してください。(ツールの追加を取りやめるには、[キャンセル] ボタンを押してください。)
  5. EasyBuilder が、選択した入力特徴から、自動的に参照円を作成します。 同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  6. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  7. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


N 点を通る近似円幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

N 点を通る近似円幾何・計測ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[制限範囲] タブ


[全般] タブ (N 点を通る近似円幾何・計測ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は円_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (N 点を通る近似円幾何・計測ツール)

閉じた 最大

最大直径を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 直径

作成された円の直径を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
閉じた 最小

最小直径を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


円-直線交点幾何・計測ツール

円-直線交点幾何・計測ツールは、直線と円の交点を特定し、その座標を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

円-直線交点幾何・計測ツールは、円特徴とエッジ特徴が正確に配置されているかを検証する場合などに有用です。

ツールを設定するには

ツールのパラメータを調整するには


円-直線幾何・計測ツールを設定するには

ツールを追加したら、円と交差するエッジ特徴または直線を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 次に、円と交差するエッジまたは直線を選択してください。
  4. EasyBuilder は自動的に円と直線の交点を決定し、交点を定義する 2 点を挿入します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円-直線幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

円-直線幾何・計測ツール設定ペインには、次のコントロールが表示されます。

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [検査の結果] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は交点_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

閉じた [設定] タブ
閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


ユーザ定義点幾何・計測ツール

ユーザ定義点幾何・計測ツールは、参照点を画像中の任意の場所に作成し、その座標を返します。

ユーザ定義点幾何・計測ツールは、検査対象物またはオブジェクトの特徴以外の参照点に基づいて計測を行う場合に有用です。

注 :
  • 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。
  • このツールの点は、角度情報を持ちませんが、他のツールのフィクスチャとしても使用可能です。

ツールを設定するには

ツールのパラメータを調整するには


ユーザ定義点幾何・計測ツールを設定するには

  1. ツールを追加したら、紫色のクロスヘアが画像に表示されます。
  2. クロスヘアを任意の場所に配置して、[OK] ボタンを押してください。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。

  4. 最後に、必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。

    注 : このツールの点は、角度情報を持ちませんが、他のツールのフィクスチャとしても使用可能です。


ユーザ定義点幾何・計測ツールのパラメータを調整するには

検査領域の確定後、用途に合わせてツールをカスタマイズしたり、チューニングしたりすることができます。

ユーザ定義点幾何・計測ツール設定ペインには、次のコントロールが表示されます。

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は点_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


ユーザ定義直線幾何・計測ツール

ユーザ定義直線幾何・計測ツールは、参照線を画像内の任意の場所に作成し、その両端の座標を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ユーザ定義直線幾何・計測ツールは、検査対象物またはオブジェクトの特徴以外の参照線に基づいて計測を行う場合に有用です。

ツールを設定するには

ツールのパラメータを調整するには


ユーザ定義直線幾何・計測ツールを設定するには

  1. ツールを追加すると、紫色の直線が画像に表示されます。
  2. 直線を任意の場所に配置して、[OK] ボタンを押してください。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ユーザ定義直線幾何・計測ツールのパラメータを調整するには

検査領域の確定後、用途に合わせてツールをカスタマイズしたり、チューニングしたりすることができます。

ユーザ定義直線幾何・計測ツール設定ペインには、次のコントロールが表示されます。

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名はライン_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

閉じた [設定] タブ
閉じた ライン

作成した線分の両端の座標を返します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


最適円幾何・計測ツール

最適円幾何・計測ツールは、検出されたエッジに基づき、最適円を作成します。このツールはエッジ解析キャリパアレイを使用して、エッジ特徴の正確な位置を特定します。エッジを識別すると、エッジ特徴の上に最適円を作成し、その半径と中心を返します。

注 :
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

最適円幾何・計測ツールは、検査対象物またはオブジェクトが同一の形状であることを確認したい場合などに有用です。このツールは、例えば、N 点を通る近似円幾何・計測ツールより正確な最適円を作成することができますが、速度は遅くなります。

ツールを設定するには

ツールのパラメータを調整するには


最適円幾何・計測ツールを設定するには

ツールを追加したら、エッジ特徴上のマスク領域を設定します。

  1. 円環状のマスク領域をエッジ特徴上に配置、設定します。円環の外半径および内半径を調整して、エッジが正しく検出されるようにしてください。領域を配置、設定する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジ特徴を囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

    注 : マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[エッジ]、[エッジ得点]、[最適ライン] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際、エッジ候補を正しく検出し、最適ラインや最適円が正しく作成されていることを確認してください。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


最適円幾何・計測ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

最適円幾何・計測ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [最適ライン] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[最適ライン] タブ

[エッジ] タブ

[エッジ得点] タブ


[全般] タブ (最適円幾何・計測ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は最適円_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[最適ライン] タブ (最適円幾何・計測ツール)

[最適ライン] タブを選択すると、領域内に検出されたすべてのエッジ候補および最適円の結果が表示されます。エッジ候補は、最適円作成時に使用可能なエッジを表し、小さなカラーコード化された円で表示されます。

閉じた 外れ値の除外

[最適距離フィルタ] パラメータで指定されている距離より遠い点を、最適ラインから削除するかどうかを指定します。デフォルトは、OFF です。

閉じた 最適距離フィルタ

エッジが元の最適ラインから離れている必要がある距離をピクセルで指定します (1～1920、デフォルト = 2)。この値は、最適合計算で使用します。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。

注 : このパラメータを使用するには、[外れ値の除外] パラメータを ON (有効) にする必要があります。
閉じた 最端フィルタ距離

除外距離を指定します (1～1920、デフォルト = 1000)。この値の外にあるエッジは、最小距離および最大距離を決定するのに使用されません。この値より大きなエッジは無視されます。

閉じた 再得点

最初に破棄した検出エッジが削除されているかどうかを確認するのに、検出エッジを再得点するかどうかを指定します。デフォルトは、OFF です。

閉じた 再計算

エッジ得点の再計算後に、最適ラインの再計算を行うように指定します。デフォルトは、OFF です。

注 : この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。
閉じた 結果

画像中の最適ラインを表示し、最適円の半径および中心を返します。


[エッジ] タブ (最適円幾何・計測ツール)

[エッジ] タブを選択すると、領域内で検出されたすべてのエッジが暗い緑色で表示されます。[キャリパサイズ]、[キャリパ間隔]、[エッジ幅] および [最小コントラスト] パラメータを必要に応じて調整し、使用するエッジを検出することができます。

[すべてのキャリパを表示] チェックボックスを ON にすると、すべてのキャリパが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

閉じた キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

閉じた キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

閉じた エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

閉じた キャリパ数

領域内のキャリパ総数を表示します。

閉じた キャリパインデックス

検出および表示する、キャリパを指定します。

閉じた すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (最適円幾何・計測ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補が、カラーコード化された小さな円で表示されます (領域は選択し、調整することができます)。エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。パラメータを調整して、使用するエッジ候補を検出してください。

検出された欠陥およびギャップも表示されます。

閉じた エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]) を指定します。デフォルトは、[左→右] です。

閉じた エッジの遷移

エッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには、遷移タイプを明示してください。

閉じた 規則: 最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 規則: エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


最適ライン幾何・計測ツール

最適ライン幾何・計測ツールは、検出されたエッジに基づき、最適ラインを作成します。このツールはエッジ解析キャリパアレイを使用して、エッジ特徴の正確な位置を特定します。エッジを識別すると、エッジ特徴の上に最適ラインを作成し、ラインセグメントの始点と終点の座標を返します。

注 :
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

最適ライン幾何・計測ツールは、検査対象物またはオブジェクトが同一の形状をしていることを確認したい場合などに有用です。このツールは、例えば、N 点を通る直線幾何・計測ツールより正確な最適ラインを作成することができますが、速度は遅くなります。

ツールを設定するには

ツールのパラメータを調整するには


最適円幾何・計測ツールを設定するには

ツールを追加したら、エッジ特徴上のマスク領域を設定します。

  1. エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

    注 : マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[エッジ]、[エッジ得点]、[最適ライン] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際、エッジ候補を正しく検出し、最適ラインや最適円が正しく作成されていることを確認してください。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


最適ライン幾何・計測ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

最適ライン幾何・計測ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [最適ライン] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[最適ライン] タブ

[エッジ] タブ

[エッジ得点] タブ


[全般] タブ (最適円幾何・計測ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は最適ライン_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[最適ライン] タブ (最適ライン幾何・計測ツール)

[最適ライン] タブを選択すると、領域内に検出されたすべてのエッジ候補および最適ラインの結果が表示されます。エッジ候補は、最適ライン作成時に使用可能なエッジを表し、小さなカラーコード化された円で表示されます。

閉じた 外れ値の除外

[最適距離フィルタ] パラメータで指定されている距離より遠い点を、最適ラインから削除するかどうかを指定します。デフォルトは、OFF です。

閉じた 最適距離フィルタ

エッジが元の最適ラインから離れている必要がある距離をピクセルで指定します (1～1920、デフォルト = 2)。この値は、最適合計算で使用します。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。

注 : このパラメータを使用するには、[外れ値の除外] パラメータを ON (有効) にする必要があります。
閉じた 最端フィルタ距離

除外距離を指定します (1～1920、デフォルト = 1000)。この値の外にあるエッジは、最小距離および最大距離を決定するのに使用されません。この値より大きなエッジは無視されます。

閉じた 再得点

最初に破棄した検出エッジが削除されているかどうかを確認するのに、検出エッジを再得点するかどうかを指定します。デフォルトは、OFF です。

閉じた 再計算

エッジ得点の再計算後に、最適ラインの再計算を行うように指定します。デフォルトは、OFF です。

注 : この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。
閉じた 結果

画像中の最適ラインを表示し、ラインセグメントの始点と終点の座標を返します。


[エッジ] タブ (最適ライン幾何・計測ツール)

[エッジ] タブを選択すると、領域内で検出されたすべてのエッジが暗い緑色で表示されます。[キャリパサイズ]、[キャリパ間隔]、[エッジ幅] および [最小コントラスト] パラメータを必要に応じて調整し、使用するエッジを検出することができます。

[すべてのキャリパを表示] チェックボックスを ON にすると、すべてのキャリパが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

閉じた キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

閉じた キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

閉じた エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

閉じた キャリパ数

領域内のキャリパ総数を表示します。

閉じた キャリパインデックス

検出および表示する、キャリパを指定します。

閉じた すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (最適ライン幾何・計測ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補が、カラーコード化された小さな円で表示されます (領域は選択し、調整することができます)。エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。パラメータを調整して、使用するエッジ候補を検出してください。

検出された欠陥およびギャップも表示されます。

閉じた エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]) を指定します。デフォルトは、[左→右] です。

閉じた エッジの遷移

エッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには、遷移タイプを明示してください。

閉じた 規則: 最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 規則: エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


演算演算＆ロジックツール

演算演算＆ロジックツールでは、標準の数学関数、演算子、論理演算、統計、三角関数を使用して、ツールおよびジョブデータを処理する数式を作成することができます。

演算演算＆ロジックツールは、2 つのツールが検出した欠陥数を追加したり、寸法測定ツールの平均値を返したりするのに有用です。

ツールを設定するには

ツールのパラメータを調整するには


演算演算＆ロジックツールを設定するには

注 : 他の位置決め/検査ツールを入力として使用します。入力として使用する他の位置決め/検査ツールを設定してから、このツールを追加してください。そうしないと、[式] を設定することができず、他のツールを設定してから、このツールに戻って設定し直すことになります。

ツールを追加したら、式を作成します。

  1. 設定ペインの左側から演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してからダブルクリックするか、または[挿入] ボタンを押します。

  2. [式] を作成したら、[制限範囲] タブをクリックして、ツールの制限範囲を定義します。デフォルトでは、[最大] は 9,999,999 に、[最小] は -9,999,999 に設定されています。アプリケーションに合わせて制限範囲をカスタマイズしてください。

    注 : 式の結果が文字列を返す場合、[最大] および [最小] 制限は無効となります。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


演算演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

演算演算＆ロジックツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ
  • 式
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

式

[制限範囲] タブ


[全般] タブ (演算演算＆ロジックツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は演算_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


式 (演算演算＆ロジックツール)

注 : これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。
閉じた 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 :
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
ヒント :

文字列が他の文字列と一致しているかどうかを見るには、Exact 関数を使用してください。If 関数は、値を比較するときに使用するため、If 関数を使用して文字列を比較しようとした場合、EasyBuilder はエラーを返します。

例:

  • ID コードの読み取り識別ツールで使用されている文字列が、文字認識識別ツールで読み取った文字列と一致しているかどうかを比較する必要ある場合、次の数式を [式] に作成することができます:　Exact(IDコード_1.文字列,Text_1.結果)。
閉じた ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

閉じた ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 :
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。
注 : 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注 : このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。
閉じた 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注 : これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


[制限範囲] タブ (演算演算＆ロジックツール)

閉じた 最大

数式の最大許容値を設定します。デフォルトで、最大値 9,999,999 がツールに割り当てられています。アプリケーションに合わせて、値をカスタマイズする必要があります。

閉じた 結果

[式] の結果を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

閉じた 最小

数式の最小許容値を設定します。デフォルトで、最小値 -9,999,999 がツールに割り当てられてます。アプリケーションに合わせて、値をカスタマイズする必要があります。

閉じた 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
閉じた [オートリミット] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。 このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。

注 : 式の結果が文字列を返す場合、[最大] および [最小] 制限は無効となります。


ロジック演算＆ロジックツール

ロジック演算＆ロジックツールでは、標準ブール値ロジック演算子を使用して、PASS/FAIL データを処理する数式を作成することができます。

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズ 1XX ビジョンセンサ (110、120、130) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 標準の結果 (制限無し)

ツールを設定するには

ツールのパラメータを調整するには


ロジック演算＆ロジックツールを設定するには

注 : 他の位置決め/検査ツールを入力として使用します。入力として使用する他の位置決め/検査ツールを設定してから、このツールを追加してください。そうしないと、[式] を設定することができず、他のツールを設定してから、このツールに戻って設定し直すことになります。

ツールを追加したら、式を作成します。[式] テキストボックスを使用して、ツールの PASS/FAIL 結果を処理する数式を作成します。

In-Sight 2000 シリーズビジョンセンサ

  1. ツールの PASS/FAIL 結果を追加して、式を作成します。[式] エディタに PASS/FAIL 結果を入力するには、結果を選択してからダブルクリックするか、または [挿入] ボタンを押します。
  2. 式の作成後、ツールの PASS/FAIL ロジックを反転させることができます (オプション)。
  3. ツールの初期設定を済ませたら、結果を考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。

In-Sight ビジョンシステム

  1. ツールの PASS/FAIL 結果を追加して、式を作成します。[式] エディタに PASS/FAIL 結果を入力するには、結果を選択してからダブルクリックするか、または [挿入] ボタンを押します。
  2. 式の作成後、ツールの PASS/FAIL ロジックを [設定] タブを使用して反転させることができます (オプション)。
  3. ツールの初期設定を済ませたら、結果を考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


ロジック演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

In-Sight 2000 シリーズビジョンセンサ

  • [ツールの編集] グループボックス

In-Sight ビジョンシステム

ロジック演算＆ロジックツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • 式
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

In-Sight 2000 シリーズビジョンセンサ

In-Sight ビジョンシステム

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder ヘルプ | 08/29/2022 | Revision: 5.9.0.2


ロジック演算＆ロジックツールのパラメータを調整するには

注 : このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。In-Sight ビジョンシステムに接続している場合、ロジック演算＆ロジックツールのパラメータを調整するにはをご参照ください。
閉じた 式

[式] テキストボックスを使用して、ツールの PASS/FAIL 結果を処理する数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 : [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決め/検査ツールが出力する PASS/FAIL 結果が含まれています。ジョブ/ツールデータは、データに含まれる値のシンボル参照です。次の 2 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、シンボルを [式] に入力することができます。使用するシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

閉じた 左括弧、コンマ (,)、右括弧、 AND、OR および NOT ボタン

[(] (左括弧)、[,] (コンマ)、[)] (右括弧)、AND、OR または NOT ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

閉じた [削除] ボタン

[削除] ボタンを使用して、ハイライトしたワードやシンボルを [式] から削除することができます。削除するワードまたはシンボルをハイライトして、[削除] をクリックしてください。

閉じた 結果を反転

ON にした場合、結果が制限範囲内にあると、ツール結果は FAIL となります。(デフォルト = OFF)

PASS/FAIL | (反転) | PASS/FAIL
PASS/FAIL | (反転) | PASS/FAIL
閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 名前

検査ツールの名前を定義します。デフォルト名はロジック_1 で、末尾の番号はツールの追加に応じて増加します。

閉じた 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[全般] タブ (ロジック演算＆ロジックツール)

閉じた ツール名

検査ツールの名前を定義します。デフォルト名はロジック_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


式 (ロジック演算＆ロジックツール)

注 : これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。
閉じた 式

[式] テキストボックスを使用して、ツールの PASS/FAIL 結果を処理する数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 :
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決め/検査ツールが出力する PASS/FAIL 結果が含まれています。ジョブ/ツールデータは、データに含まれる値のシンボル参照です。次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、シンボルを [式] に入力することができます。使用するシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

閉じた 左括弧、コンマ (,)、右括弧、 AND、OR および NOT ボタン

[(] (左括弧)、[,] (コンマ)、[)] (右括弧)、AND、OR または NOT ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

閉じた [削除] ボタン

[削除] ボタンを使用して、ハイライトしたワードやシンボルを [式] から削除することができます。削除するワードまたはシンボルをハイライトして、[削除] をクリックしてください。


[設定] タブ (ロジック演算＆ロジックツール)

閉じた 結果

式の結果を報告します。

閉じた 反転

ツールの PASS/FAIL 結果を反転させるかどうかを定義します。

  • OFF (デフォルト): PASS/FAIL 結果を反転しません。
  • ON: PASS/FAIL 結果を反転します。


トレンド演算＆ロジックツール

トレンド演算＆ロジックツールは、位置決め/検査ツール値または入力ラインの、リセット前の指定サンプル数に対する、最大値、最小値、平均、サンプル数および標準偏差統計を返します。

トレンド演算＆ロジックツールは、製造過程の解析用に、特定ツールの結果について、ジョブ実行中にわたって統計情報を蓄積したい場合などに有用です。

ツールを設定するには

ツールのパラメータを調整するには


トレンド演算＆ロジックツールを使用するには

ツールを追加したら、処理する値を指定し、ツールのパラメータを設定します。

  1. アプリケーションに合わせて、[全般] タブを設定します。
  2. [設定] タブをクリックし、統計データを蓄積する値を指定します。ツールをジョブに追加すると、EasyBuilderはその時点でのアプリケーションを精査し、[最後の値] パラメータが参照可能な値を表示します。値を選択したら、タブの他のパラメータを設定してください。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


トレンド演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

トレンド演算＆ロジックツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [テーブル] タブ
  • [値] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[値] タブ

テーブル


[全般] タブ (トレンド演算＆ロジックツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はトレンド_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (トレンド演算＆ロジックツール)

閉じた 最後の数値

ツールが計算する値を指定します。デフォルトでは、[未定義] が選択されており、統計は蓄積されません。 ツールまたは入力値の統計データを蓄積するには、ツールが返す値、またはジョブに入力する値を選択してください。

閉じた 最大サンプル

ツールの統計蓄積に使用する、最大サンプル数を指定します。デフォルトでは、100 サンプルが使用されます。 サンプル数は、最小 2～最大 5,000 の範囲となります。 ツールが最大サンプル数に達したら、一番古い値が捨てられ、新しい値が加わります。

閉じた 表示

計算値をどこに表示するかを指定します。選択肢は、[最後の数値]、[最小]、[最大]、[平均] または [標準偏差] です。 デフォルトでは、[最後の数値] が選択されています。

閉じた 結果

[表示] パラメータで指定した、現在の計算値を表示します。

閉じた [リセット] ボタン

データ蓄積を 0 にリセットします。

閉じた オンラインリセット

In-Sight ビジョンシステムをオンラインに切り替えるたびに、ツールがデータ蓄積を自動的にリセットするかどうかを指定します。デフォルトは OFF で、手動でのリセットが必要です。

閉じた ジョブロードのリセット

In-Sight ビジョンシステムがツールを含むジョブをロードするたびに、ツールがデータ蓄積を自動的にリセットするかどうかを指定します。デフォルトは OFF で、手動でのリセットが必要です。


[値] タブ (トレンド演算＆ロジックツール)

グラフを使用して、値をグラフィックスで表示します。


[テーブル] タブ (トレンド演算＆ロジックツール)

トレンド演算＆ロジックツールのテーブルには、[設定] タブの [最大サンプル] で指定したサンプル数に対して、[最後の数値] パラメータで指定した値を蓄積した結果が表示されます。


統計演算＆ロジックツール

統計演算＆ロジックツールは、位置決め/検査ツール値または入力ラインの、最大値、最小値、平均、サンプル数および標準偏差統計を返します。

統計演算＆ロジックツールは、製造過程の解析用に、特定ツールの結果について、統計情報を蓄積したい場合などに有用です。

ツールを設定するには

ツールのパラメータを調整するには


統計演算＆ロジックツールを使用するには

ツールを追加したら、処理する値を指定し、ツールのパラメータを設定します。

  1. アプリケーションに合わせて、[全般] タブを設定します。
  2. [設定] タブをクリックし、統計データを蓄積する値を指定します。ツールをジョブに追加すると、EasyBuilder はその時点でのアプリケーションを精査し、[最後の値] パラメータが参照可能な値を表示します。値を選択したら、タブの他のパラメータを設定してください。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


統計演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

統計演算＆ロジックツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • テーブル
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

テーブル


[全般] タブ (統計演算＆ロジックツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は統計_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (統計演算＆ロジックツール)

閉じた 最後の数値

ツールが計算する値を指定します。デフォルトでは、[未定義] が選択されており、統計データは蓄積されません。ツールまたは入力値の統計データを蓄積するには、ツールが返す値、またはジョブに入力する値を選択してください。

閉じた 表示

どの計算値を表示するかを指定します。選択肢は、[最後の数値]、[最小]、[最大]、[平均] または [標準偏差] です。デフォルトでは、[最後の数値] が選択されています。

閉じた 結果

[表示] パラメータで指定した、現在の計算値を表示します。

閉じた オフライン時にカウント

In-Sight ビジョンシステムがオフライン時に、取り込んだ画像を結果に含めるかどうかを指定します。デフォルトは ON で、ビジョンシステムがオフラインでも統計データは蓄積されます。チェックボックスを OFF にすると、In-Sight ビジョンシステムがオンライン時のみ、統計データを蓄積します。

閉じた [リセット] ボタン

データ蓄積を 0 にリセットします。

閉じた 外部リセット

外部デバイスによって、データ蓄積をリセット可能にするかどうか指定します。デフォルトは OFF で、外部デバイスからは制御できません。PLC または VisionView® オペレータインタフェースパネルなどの外部デバイスからこのツールをリセットするには、チェックボックスを ON にして、通信ステップでデータを設定してください。

閉じた オンラインリセット

In-Sight ビジョンシステムをオンラインに切り替えるたびに、ツールがデータ蓄積を自動的にリセットするかどうかを指定します。デフォルトは OFF で、手動でのリセットが必要です。

閉じた ジョブロードのリセット

ビジョンシステムがツールを含むジョブをロードするたびに、ツールがデータ蓄積を自動的にリセットするかどうかを指定します。デフォルトは OFF で、手動でのリセットが必要です。


テーブル (統計演算＆ロジックツール)

統計演算＆ロジックツールのテーブルには、[設定] タブの [最後の数値] パラメータで指定した値を蓄積したデータ結果が表示されます。


グループ演算＆ロジックツール

グループ演算＆ロジックツールは、位置決めおよび検査ツールをグループ化します。その結果、ツール実行は連結され、グループ内のツールは有効ステータスを共有します。

グループ演算＆ロジックツールは、対象物の 1 つの特徴が PASS かどうかを判定するのに複数のツールが必要な場合や、複数の画像取り込みが必要なジョブ、またはたくさんのツールが必要なジョブなどに有用です。

ツールを設定するには

ツールのパラメータを調整するには


グループ演算＆ロジックツールを設定するには

注 : 他の位置決め/検査ツールを入力として使用します。入力として使用する他の位置決め/検査ツールを設定してから、このツールを追加してください。そうしないと、[式] を設定することができず、他のツールを設定してから、このツールに戻って設定し直すことになります。

ツールを追加したら、どのツールをグループに含めるかを指定します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点のジョブを調査し、ジョブに含まれるツールを [ツールグループ] タブにすべて表示します。
  2. グループに追加するツールを選択し (CTRL キーを押したまま複数のツールを個々に選択するか、または SHIFT キーを押したまま順番に並んだ複数のツールをまとめて選択します) 、[追加] ボタンを押します。
  3. グループの設定が済んだら、[グループ有効条件] タブを選択し、グループ実行制御ロジックを提供する [式] をカスタマイズすることができます。デフォルトでは、[式] は　1 に設定されており、グループは常に有効となります。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


グループ演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

グループ演算＆ロジックツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [ツールグループ] タブ
  • [グループ有効条件] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[ツールグループ] タブ

[グループ有効条件] タブ


[全般] タブ (グループ演算＆ロジックツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はグループ_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

注 : [グループ有効条件] タブを設定して [式] を使用する場合、正常に作動させるためには、[ツール有効] パラメータを [式] に設定する必要があります。
閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (グループ演算＆ロジックツール)

閉じた グループ ID

[グループ ID] 数は、グループ演算＆ロジックツールに含まれるツールが FAIL となった場合に、ツール失敗を表示するのに使用されます。グループ演算＆ロジックツールでは、ツールが PASS と等しい場合に 0 を返し、FAIL の場合にグループ ID 番号を返します。グループ ID 番号は、1～9,999,999 から選択することができます。グループ ID はデフォルトで 10 に設定されており、新たなグループ演算＆ロジックツールが追加されても増分されることはありません。


[ツールグループ] タブ (グループ演算＆ロジックツール)

[ツールグループ] タブを使用して、選択中のグループ演算＆ロジックツールにツールを追加したり、削除することができます。

左側のリストにはグループに含まれていないツール、右側のリストにはグループに含まれているツールが表示されています。デフォルトでは、右側のリストは空欄となっています。

閉じた [追加] ボタン

左側のツールを選択すると、[追加] ボタンが有効になります。

  • ツールを 1 つずつ追加するには、ツールを選択してから、[追加] ボタンを押します。
  • 順番に並んでいない、複数のツールをまとめて追加するには、CTRL キーを押したまま各ツールを順番にハイライトし、[追加] ボタンを押します。
  • 順番に並んでいる、複数のツールをまとめて追加するには、SHIFT キーを押したまま最初のツールをハイライトし、次に最後のツールをハイライトしてから[追加] ボタンを押します。
閉じた [削除] ボタン

右側のツールを選択すると、[削除] ボタンが有効になります。

  • ツールを 1 つずつ削除するには、ツールを選択してから、[削除] ボタンを押します。
  • 順番に並んでいない、複数のツールをまとめて削除するには、CTRL キーを押したまま各ツールを順番にハイライトし、[削除] ボタンを押します。
  • 順番に並んでいる、複数のツールを削除するには、SHIFT キーを押したまま最初のツールをハイライトし、次に最後のツールをハイライトしてから、[削除] ボタンを押します。
注 :
  • ツールは、1 つのグループ演算＆ツールのみに含めることができます。既にグループ演算＆ロジックツールに含まれているツールを他のグループ演算＆ロジックツールに追加するには、まずグループ演算＆ロジックツールから削除し、その後、別の演算＆ロジックツールに追加します。
  • グループ演算＆ロジックツールには、他のグループ演算＆ロジックツールに含まれるツールを追加することはできません。
  • グループ演算＆ロジックツールをコピー＆ペーストする場合、グループ演算＆ロジックツールに含まれるすべてのツールがコピー＆ペーストされます。
  • グループ演算＆ロジックツールを削除する場合、グループ演算＆ロジックツールに含まれるツールをすべて削除してもよいかを確認するダイアログが表示されます。グループに含まれるツールを削除したくない場合、ツールをグループから削除してから、グループ演算＆ロジックツールを削除してください。


[グループ有効条件] タブ (グループ演算＆ロジックツール)

注 : これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

[グループ有効条件] タブを使用して、ツール実行を決定する数式を作成します。デフォルトで [式] は 1 に設定され、画像取り込みトリガ時にツールは実行されます。 このコントロールを有効にするには、[全般] タブの[ツール有効] コントロールを [式] に設定する必要があります。

In-Sight 2000-130/130C ビジョンセンサ

閉じた 式

[式] テキストボックスを使用して、ツールの PASS/FAIL 結果を処理する数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 : [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決め/検査ツールが出力する PASS/FAIL 結果が含まれています。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 2 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、シンボルを [式] に入力することができます。使用するシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

閉じた 左括弧、コンマ (,)、右括弧、 AND、OR および NOT ボタン

[(] (左括弧)、[,] (コンマ)、[)] (右括弧)、AND、OR または NOT ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

閉じた [削除] ボタン

[削除] ボタンを使用して、ハイライトしたワードやシンボルを [式] から削除することができます。削除するワードまたはシンボルをハイライトして、[削除] をクリックしてください。

In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230)

注 : グループ演算＆ロジックツールとシーケンス演算＆ロジックツール実行を連結するには、グループ演算＆ロジックツールの式をシーケンス演算＆ロジックツールに設定し (例: Sequence_1.Current_Step=1) 、さらに [全般] タブの [ツール有効] コントロールを [式] に設定する必要があります。
閉じた 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 :
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
閉じた ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

閉じた ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 :
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。
注 : 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注 : このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。
閉じた 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注 : これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


シーケンス演算＆ロジックツール

シーケンス演算＆ロジックツールは、複数の画像取り込みが必要なジョブのステップ数や、組み立て工程におけるステージを定義します。このツールは、グループ演算＆ロジックツールと連動して使用され、グループ内のツールの実行順序を制御します。

シーケンス演算＆ロジックツールは、組み立て/製造工程の順序に基づいて、画像取り込みや検査ツールの実行を同期させる場合などに有用です。例えば、特定シーケンスの結果を基にして組み立てを継続するかどうかを決定するのに、部品をさまざまな製造工程で検査したい場合などです。

ツールを設定するには

ツールのパラメータを調整するには


シーケンス演算＆ロジックツールを設定するには

ツールを追加したら、ツールのパラメータを設定します。

  1. アプリケーションに合わせて [全般] タブを設定します。

  2. [設定] タブをクリックし、パラメータをアプリケーションに合わせて設定します。

    注 : グループ演算＆ロジックツールとシーケンス演算＆ロジックツールを連結するには、シーケンス演算＆ロジックツールの [現在のステップ] シンボルを使用して、グループ演算＆ロジックツールの [式] を作成する必要があります。(例: グループ_1.有効=シーケンス_1.現在のステップ=1)
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


シーケンス演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

シーケンス演算＆ロジックツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ


[全般] タブ (シーケンス演算＆ロジックツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はステップ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 アプリケーションに合わせて、名前を変更することができます。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (シーケンス演算＆ロジックツール)

閉じた ステップ

ツールが制御するステップの数を指定します。デフォルトは、4 ステップです。

閉じた [ステップをリセット] ボタン

次の画像を取り込む際に、最初のステップで、0 に戻し、シーケンスを再スタートします。

閉じた 次のステップを有効に

[次のステップ] パラメータが、外部デバイスによって制御可能かどうかを指定します。デフォルトは OFF で、外部デバイスからは制御できません。このパラメータを ON にすると、ツールから外部デバイスに送信されるステップ番号は、次の画像取り込みから [現在のステップ] となります。この構成では、ステップを順番に実行する必要はなく、入力されたステップ番号によっては、ステップをスキップすることも可能です (例えば、ステップの数が 6 で、ツールの現在のステップが 2 のときに、[次のステップ] から 5 が入力された場合、ステップ 3 および 4 はスキップされます)。

閉じた 次のステップ

シーケンスにおいて、次のステップを開始するステップを指定します。デフォルトでは、1 が選択されています。このコントロールは、[次のステップを有効に] パラメータが ON の場合のみ、有効となります。PLC または VisionView® オペレータインタフェースパネルなどの外部デバイスからこのツールをリセットするには、[次のステップを有効に] チェックボックスを ON にして、通信ステップの [次のステップ] パラメータにて次のステップの値を設定してください。

閉じた 現在のステップ

アクティブなステップを表示します。デフォルトは 1.000 です。現在のステップを定義します。


点計算演算＆ロジックツール

点計算演算＆ロジックツールは、他の位置決め/検査ツールが出力した数式に基いて、画像中の点を計算するのに使用します。この点は、他のツールによって参照可能です。 ツールは、計算した点の XY 座標を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

点計算演算＆ロジックツールは、他のツールによって参照可能な画像中の点を、プログラミングによって識別したい場合などに有用です。これに対し、ユーザ定義点幾何・計測ツールは、グラフィックスによって画像中に固定点を定義します。 例えば、演算関数の結果やエッジ有無判定ツールで検出された中点やエッジといった、特定ツールの結果に基づいて画像中に点を配置したい場合に、点計算演算＆ロジックツールは、ツール結果を入力として使用して点を計算することができます。また、画像中の点の位置は、参照するツールの出力を反映して変化します。 演算演算＆ロジックツールで、その他のロジックを決定するのに、計算された点を使用することができます。

ツールを設定するには

ツールのパラメータを調整するには


点計算演算＆ロジックツールを設定するには

注 : 他の位置決め/検査ツールを入力として使用します。入力として使用する他の位置決め/検査ツールを設定してから、このツールを追加してください。そうしないと、[式] を設定することができず、他のツールを設定してから、このツールに戻って設定し直すことになります。

ツールを追加したら、[式] を作成して、X および Y 値を定義します。

  1. 設定ペインの左側から演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してからダブルクリックするか、または [挿入] ボタンを押します。
  2. [式] を作成すると、画像に点アイコンが挿入され、計算された点の場所を示します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


点計算演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

点計算演算＆ロジックツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [X]、[Y] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[X]、[Y] タブ


[全般] タブ (点計算演算＆ロジックツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は点_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。.

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (点計算演算＆ロジックツール)

閉じた 結果

計算された X および Y 式の結果を表示します。


[X]、[Y] タブ (点計算演算＆ロジックツール)

注 : これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

[X] および [Y] タブを使用して、点の X および Y 座標を定義する数式を作成します。

閉じた 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 :
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
閉じた ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

閉じた ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 :
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。
注 : 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注 : このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。
閉じた 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注 : これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


変数演算＆ロジックツール

変数演算＆ロジックツールは、外部デバイスからジョブに入力する整数、浮動小数点または文字列を定義します。これらの値は、定義後、位置決め、検査ツール、あるいは PLC や VisionView® オペレータインタフェースパネルなどの外部デバイスによって、参照することができるようになります。

変数演算＆ロジックツールは、PLC などの外部デバイスから位置決めまたは検査ツールに値を入力したり、演算演算＆ロジックツールやグループ演算＆ロジックツールの [式] から値を入力したりする場合などに有用です。例えば、文字認識識別ツールに文字列を入力したり、ブロブ計数ツールがサーチするブロブ数を制御する整数を入力したり、グループ演算＆ロジックツールの数式の一部として浮動小数点を入力したりするアプリケーションがある場合に、変数演算＆ロジックツールでそれらの値を作成してから、他のツールや通信ステップによってシンボル参照することができます。

ツールを設定するには

ツールのパラメータを調整するには


変数演算＆ロジックツールを設定するには

ツールを追加したら、入力変数に使用する値を定義します。

  1. アプリケーションに合わせて [全般] タブを設定します。
  2. [全般] タブ横の設定ペインは、入力変数テーブルです。値がブール値の場合は [ブール値の追加] ボタンを、値が整数の場合は [整数の追加] ボタンを、値が浮動小数点の場合は [浮動小数点の追加] ボタンを、値が文字列の場合は [文字列の追加] ボタンを押します。
  3. 入力変数を追加したら、アプリケーションに合わせて変数をカスタマイズしてください。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。

  5. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。

    注 : リストから変数を削除するには、変数の隣のチェックボックスを ON にしてから [削除] ボタンを押します。([削除] ボタンを有効にするには、チェックボックスを ON にする必要があります。)


変数演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

変数演算＆ロジックツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • 入力変数テーブル
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

入力変数テーブル


[全般] タブ (変数演算＆ロジックツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は変数_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


入力変数テーブル (変数演算＆ロジックツール)

変数演算＆ロジックツールの入力変数テーブルを使用して、入力変数を追加、編集および削除します。変数演算＆ロジックツールでは、32 個までの入力変数を作成することができます。

閉じた [ブール値の追加] ボタン

値がブールロジック値の場合、[ブール値の追加] ボタンを押します。デフォルトでは、0 が追加されます (右にあるチェックボックスを ON にすると、ブール値は 1 に設定されます)。デフォルトのツール名は ブーリアン0 で、末尾の番号はツールの追加に応じて増加します。アプリケーションに合わせて、名前を変更することができます。

閉じた [整数の追加] ボタン

値が整数の場合、[整数の追加] ボタンを押します。デフォルトでは、0 が追加されます。デフォルトのツール名は Integer0 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。整数の範囲は、-9,999,999～9,999,999 です。

閉じた [浮動小数点の追加] ボタン

値が浮動小数点の場合、[浮動小数点の追加] ボタンを押します。デフォルトでは、0 が追加されます。デフォルトのツール名は Float0 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。浮動小数点の範囲は、-9,999,999～9,999,999 です。

閉じた [文字列の追加] ボタン

値が文字列の場合、[文字列を追加] ボタンを押します。デフォルトで、文字列は空欄になっています。デフォルトの文字列名は String0 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。文字列は 32 文字まで入力可能です。

閉じた [削除] ボタン

[削除] ボタンを押して、値をテーブルから削除します。変数をリストから削除するには、変数の隣のチェックボックスを ON にしてから [削除] ボタンを押します。([削除] ボタンを有効にするには、チェックボックスを ON にする必要があります。)


ロボットガイダンス演算＆ロジックツール

ロボットガイダンス演算＆ロジックツールは、ビジョンシステムから、ロボットにパーツの位置を通信します。

ツールを設定するには

ツールのパラメータを調整するには


ロボットガイダンスツールを設定するには

ヒント : キャリブレーション作成後、ジョブファイルを保存することを推奨します。その後、キャリブレーションを実行するには、キャリブレーションジョブをロードし、画像を取り込んでから、更新したキャリブレーションファイルを参照するジョブに自動エクスポートします。

ツールを追加したら、キャリブレーションの作成に使用される入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールにジョブを追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴 (点、フィクスチャ原点、円特徴の中心) を水色のスマートフィーチャーとして提示します。同時に他のツールで定義済みの特徴を緑色で提示します。同時に、円有無判定ツールを挿入し、未設定の円特徴を定義します。

  2. 水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。

  3. 目的の特徴を選択した後、[OK] ボタンを押してください。 (ツールの追加を取りやめるには、[キャンセル] ボタンを押してください。)

  4. ジョブファイルに保存します。
  5. ツールの初期設定を済ませたら、必要に応じてパラメータを調整してください。
  6. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


ロボットガイダンスツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

ロボットガイダンスツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ

[全般] タブ


[全般] タブ (ロボットガイダンスツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([画像の設定]、[入力/出力]、および [通信]) で参照されます。デフォルトのツール名はガイダンス_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。ジョブには、1 つのロボットガイダンスツールのみ追加することができます。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


円弧プロットツール

円弧プロットツールは、円弧の中心X、中心Y、半径、開始角度および範囲値を定義する数式に基づき画像上に円弧グラフィックスをプロットし、 円弧を定義する値を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


円弧プロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円弧プロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

円弧プロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [中心X」、[中心Y]、[半径]、[開始角度] および [範囲] 数式タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] および [設定] タブ

[中心X」、[中心Y]、[半径]、[開始角度] および [範囲] 数式タブ


[全般] および [設定] タブ (円弧プロットツール)

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は円弧_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

閉じた [設定] タブ
閉じた カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

閉じた 結果

ツール数式タブの結果を返します。円弧の X、Y、半径、開始角度および範囲値を表示します。


[中心 X]、[中心 Y]、[半径]、[開始角度] および [範囲] 数式タブ (円弧プロットツール)

円弧プロットツールには、[中心X]、[中心Y]、[半径]、[開始角度] および [範囲] 数式タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注 : これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。
閉じた 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 :
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
閉じた ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

閉じた ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 :
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。
注 : 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注 : このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。
閉じた 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注 : これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


円プロットツール

円プロットツールは、円の X、Y および半径の値を定義する数式に基づき画像上に円グラフィックスをプロットし、 円を定義する値を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


円プロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円プロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

円プロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [X]、[Y] および [半径] 数式タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] および [設定] タブ

[X]、[Y] および [半径] 数式タブ


[全般] および [設定] タブ (円プロットツール)

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は円_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

閉じた [設定] タブ
閉じた カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

閉じた 結果

ツール数式タブの結果を返します。円の X、Y、および半径の値を表示します。


[X]、[Y] および [半径] 数式タブ (円プロットツール)

円プロットツールには、[X]、[Y] および [半径] 数式タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注 : これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。
閉じた 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 :
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
閉じた ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

閉じた ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 :
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。
注 : 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注 : このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。
閉じた 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注 : これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


十字プロットツール

十字プロットツールは、十字の X、Y および角度結果の値を定義する数式に基づき画像上に十字グラフィックスをプロットし、 十字を定義する値を返します。

注 :
  • 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。
  • 十字プロットツールの出力は、他ツールのフィクスチャとして使用することができます。

ツールを設定するには

ツールのパラメータを調整するには


十字プロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


十字プロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

十字プロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [X]、[Y] および [角度結果] 数式タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] および [設定] タブ

[X]、[Y] および [角度結果] タブ


[全般] および [設定] タブ (十字プロットツール)

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は十字_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

閉じた [設定] タブ
閉じた カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

閉じた 結果

ツール数式タブの結果を返します。円の X、Y、および角度結果の値を表示します。


[X]、[Y] および [角度結果] 数式タブ (十字プロットツール)

十字プロットツールには、[X]、[Y] および [角度結果] タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注 : これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。
閉じた 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 :
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
閉じた ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

閉じた ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 :
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。
注 : 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注 : このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。
閉じた 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注 : これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


ラインプロットツール

ラインプロットツールは、ラインの始点 X、始点 Y、終点 X および終点 Y 値を定義する数式に基づき画像上にライングラフィックスをプロットし、 ラインを定義する値を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


ラインプロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ラインプロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ラインプロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [始点X]、[始点Y]、[終点X] および [終点Y] 数式タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] および [設定] タブ

[始点X]、[始点Y]、[終点X] および [終点Y] 数式タブ


[全般] および [設定] タブ (ラインプロットツール)

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はライン_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

閉じた [設定] タブ
閉じた カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

閉じた 結果

ツール数式タブの結果を返します。ラインの始点/終点の X、Y 値を表示します。


[始点X]、[始点Y]、[終点X] および [終点Y] 数式タブ (ラインプロットツール)

ラインプロットツールには、[始点X]、[始点Y]、[終点X] および [終点Y] 数式タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注 : これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。
閉じた 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 :
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
閉じた ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

閉じた ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 :
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。
注 : 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注 : このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。
閉じた 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注 : これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


点プロットツール

点プロットツールは、点の X および Y 値を定義する数式に基づき画像上に点グラフィックスをプロットし、 点を定義する値を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


点プロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


点プロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

点プロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [X] および [Y] 数式タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] および [設定] タブ

[X] および [Y] 数式タブ


[全般] および [設定] タブ (点プロットツール)

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は点_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

閉じた [設定] タブ
閉じた カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

閉じた 結果

ツール数式タブの結果を返します。点の X および Y 値を表示します。


[X] および [Y] 数式タブ (点プロットツール)

点プロットツールには、[X] および [Y] 数式タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注 : これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。
閉じた 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 :
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
閉じた ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

閉じた ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 :
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。
注 : 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注 : このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。
閉じた 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注 : これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


領域プロットツール

領域プロットツールは、領域の X、Y、高さ、幅、角度結果およびカーブ値を定義する数式に基づき画像上に領域グラフィックスをプロットし、 領域を定義する値を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


領域プロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


領域プロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

領域プロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [X]、[Y]、[高さ]、[幅]、[角度] および [カーブ] 数式タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] および [設定] タブ

[X]、[Y]、[高さ]、[幅]、[角度] および [カーブ] 数式タブ


[全般] および [設定] タブ (領域プロットツール)

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は領域_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

閉じた [設定] タブ
閉じた カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

閉じた 結果

ツール数式タブの結果を返します。領域の X、Y、高さ、幅、角度およびカーブ値を表示します。


[X]、[Y]、[高さ]、[幅]、[角度] および [カーブ] 数式タブ (領域プロットツール)

領域プロットツールには、[X]、[Y]、[高さ]、[幅]、[角度] および [カーブ] 数式タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。[X] 数式タブは領域の第 1 頂点の位置を定義し、[Y] 数式タブは、その他の頂点を定義します。[高さ] 数式タブは X 軸 (+)、[幅] 数式タブは Y 軸 (+) の領域の距離を定義します。[角度] 数式タブは X 軸 (+) から領域の最初の境界までの領域の角度を定義します。[カーブ] 数式タブは領域の両端の境界の間の角度を定義します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注 : これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。
閉じた 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 :
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
閉じた ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

閉じた ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 :
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。
注 : 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注 : このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。
閉じた 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注 : これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


文字列プロットツール

文字列プロットツールは、文字列の X および Y 値を定義する数式に基づき画像上に文字列グラフィックスをプロットし、 文字列の X/Y 位置を定義する値を返します。

注 : 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000 シリーズビジョンセンサに接続している場合)、その単位で表示されます。

ツールを設定するには

ツールのパラメータを調整するには


文字列プロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


文字列プロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

領域プロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [X]、[Y] および [文字列] 数式タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] および [設定] タブ

[X]、[Y] および [文字列] 数式タブ


[全般] および [設定] タブ (文字列プロットツール)

閉じた [全般] タブ
閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は文字列_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

閉じた [設定] タブ
閉じた 結果

ツール数式タブの結果を返します。文字列およびその X および Y 値を表示します。

閉じた カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

閉じた フォント名

文字列グラフィックスに使用するフォントタイプを定義します。デフォルトは、Arial です。

閉じた フォントスタイル

文字列グラフィックスに使用するフォントスタイル (標準、斜体、太字、太字 斜体) を定義します。デフォルトは、標準です。

閉じた フォントサイズ

文字列グラフィックスに使用するフォントサイズを定義します。デフォルトは、9 ポイントです。


[X]、[Y] および [文字列] 数式タブ (文字列プロットツール)

文字列プロットツールには、[X]、[Y] および [文字列] 数式タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注 : これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。
閉じた 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注 :
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
閉じた ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 : 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
閉じた 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

閉じた ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注 :
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
閉じた ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。
注 : 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。
閉じた [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注 : このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。
閉じた 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注 : これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


フィルタ画像フィルタツール

注 : このツールは、In-Sight 5.1.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。 モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアのバージョンをご参照ください。 モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

フィルタ 画像フィルタツールは、画像の一部または画像の全体領域にフィルタをかけ、ツール画像を出力します。ツール画像は、 位置決めツールまたは検査ツールによって参照することができます。

フィルタ画像フィルタツールは多目的フィルタで、低コントラスト画像や画像内の特徴を強調するのに使用する、カラーまたはグレースケール出力画像を生成します。 このツールは、検出したい特徴を強調したり、不要な特徴を最小にしたりするのに有効です。 効果的に使用することによって、検査アプリケーションの信頼性・再現性を高めることができます。

フィルタ画像フィルタツールでは、さまざまな種類の局所およびグローバル画像強調技術を使用することができます。[フィルタタイプ] から、使用する画像フィルタを選択してください。

ツールを設定するには

ツールのパラメータを調整するには


フィルタ画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


フィルタ画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

フィルタ画像フィルタツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ


[全般] タブ (フィルタ画像フィルタツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (フィルタ画像フィルタツール)

閉じた フィルタタイプ

領域に適用する画像フィルタを定義します。選択後、領域内の画像は自動的に更新されます。

フィルタタイプ | 説明
2 値化 (デフォルト)

グレースケールしきい値を元に画像にフィルタをかけ、白 (255) または黒 (0) のどちらになるかを判定します。しきい値以上の入力ピクセル値は白に、しきい値を下回る値は黒になります。

注 : カラー入力画像が使用される場合、出力画像はグレースケール画像となります。
ボトムハット

フィルタサイズより小さい暗い特徴以外のすべてにフィルタをかけます。暗い特徴が明るいピクセルで表示され、背景が暗く表示された画像を出力します。

注 : [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
クリップ

入力ピクセルのグレースケール値と最小値および最大値を比較し、画像にフィルタをかけます。グレースケールスペクトルの両端を除去し、特徴がより均一な画像を出力します。
クローズ

フィルタサイズより小さい黒い特徴にフィルタをかけます。全体的な明度がわずかに高くなった画像を出力します。

注 : [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
膨張

明るい特徴を拡大し、暗い特徴を縮小します。明るいピクセルがより大きな領域を占める画像を出力します。このフィルタは、暗い斑点の除去に有用です。

注 : [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
エッジ強調

明るい特徴と暗い特徴にフィルタをかけます。明るいピクセルでエッジを表示した画像を出力します。この操作は、対角線方向のエッジを表現できますが、「勾配 全方向」より実行時間が長くなります。

注 : [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
等化 | ヒストグラム平坦化 (最も多いグレースケール値を平坦化して、分布をより均一にする) に基づいて画像にフィルタをかけます。コントラストが強められた画像を出力します。
収縮

明るい特徴を縮小し、暗い特徴を拡大します。暗いピクセルがより大きな領域を占める画像を出力します。このフィルタは、明るい斑点の除去に有用です。

注 : [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
黒穴塗りつぶし | 明るいピクセルで囲まれた暗いピクセルを明るいピクセルに変換します。暗い穴が埋められた画像を出力します。
白穴塗りつぶし | 暗いピクセルで囲まれた明るいピクセルを暗いピクセルに変換します。明るい穴が埋められた画像を出力します。
勾配 全方向 | 垂直方向および垂直方向のエッジ特徴にフィルタをかけます。垂直方向および垂直方向のエッジが明るいピクセルで表示された画像を出力します。この操作は対角線方向のエッジは表現しませんが、「エッジ強調」操作より実行時間が短くなります。
勾配 水平方向 | 水平方向のエッジ特徴にフィルタをかけます。水平方向のエッジが明るいピクセルで表示された画像を出力します。
勾配 垂直方向 | 垂直方向のエッジ特徴にフィルタをかけます。垂直方向のエッジが明るいピクセルで表示された画像を出力します。
グレースケール距離

各出力ピクセルのグレースケール値を、各入力ピクセルのグレースケール値としきい値レベルの差としてフィルタをかけます。例えば、入力ピクセル値が 100 で、しきい値が 25 の場合、出力ピクセルは 75 となります。
ハイパス

エッジ特徴にフィルタをかけ、そのほかの特徴を抑制します。むらのないグレースケール勾配を持つ領域に対し、相対的にエッジが強調された画像を出力します。

注 : [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
反転 | ピクセル値のグレースケール反転を基にフィルタをかけます。入力画像の「ネガティブ」状態の画像を出力します。
ローカル中央値

近傍カーネル内のピクセル値の中央ピクセル値を計算し、その結果を出力画像のピクセル値に使用します。

注 : [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
正規化したローカル中央値

画像から背景を減算します。この操作は、入力画像から入力画像のローカル中央値を減算し、結果を右に 1 つシフトし、128 を加算して出力ピクセル値を生成します。

注 : [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
ローパス

エッジ特徴を除去し、ほかの特徴を使用してエッジをぼやかします。エッジが「平滑化」された、またはぼやけた画像を出力します。

注 : [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
最大 (トップハット/ボトムハット)

トップハットおよびボトムハット操作の最大値を使用します。

注 : [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
オープン

フィルタサイズより小さい明るい特徴にフィルタをかけます。全体的な輝度がわずかに低くなった画像を出力します。

注 : [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
光密度

対数目盛に基づく、ピクセル値の反転を指定します。対象物と特徴を通り抜ける光の量を測定し、その密度を明らかにする画像を出力します。対象物と特徴の密度が高いほど、出力画像ではより明るいピクセルで表示されます。
シャープ

エッジ強調に使用する「シャープネス」操作を行います。隣接ピクセル間のコントラストを評価し、高コントラストの場合、コントラストを上げます。隣接ピクセル間の大きなコントラスト差は、通常エッジを表します。しかし、この操作はローカルエッジの検出ために使用されるべきではありません。この操作の効果は、画像コンテンツおよび解像度によって異なります。

  • [ゲイン] パラメータは、シャープネスの強度を決定します。ピクセル間の一定の差を無視することによって、軽い陰影のあるエリアを過度にシャープしてしまうことを防ぎます。
引き伸ばし | グレースケール値を線状に拡大縮小したり、または「引き伸ばし」することにより、フィルタをかけます。コントラストが強められた画像を出力します。
しきい値範囲

各入力ピクセルを、2 つのしきい値 (最小値と最大値) で比較し、出力ピクセルが白または黒のどちらになるかを判定する、2 値化 (白黒) しきい値に基づいてフィルタをかけます。入力ピクセル値が最小値または最大値と等しいか、またはそれを超える場合、出力ピクセルは白となります。入力ピクセル値が最小値と最大値の間にある場合、出力ピクセルは黒となります。
トップハット

フィルタサイズより小さい明るい特徴以外のすべてにフィルタをかけます。暗い背景に、明るい特徴が明るいピクセルで表示された画像を出力します。

注 : [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
閉じた カーネル行

カーネル行数を指定します。(1–25: デフォルト = 3) カーネルとは長方形の数配列のことで、画像の各ピクセル位置に対して近傍処理操作を行います。ピクセルの近傍グレースケール値は、出力画像上のピクセル位置のグレースケール値を定義します。

注 :

  • カーネルは非加重です。

  • カーネルは、奇数の整数である必要があります。通常、カーネルは 3 ✕ 3 ですが、そのサイズは任意です。

このパラメータは、フィルタが次のタイプに設定されている場合に、ON になります。

  • ボトムハット
  • クローズ
  • 膨張
  • エッジ強調
  • 収縮
  • ハイパス
  • ローカル中央値
  • 正規化したローカル中央値
  • ローパス
  • 最大 (トップハット/ボトムハット)
  • オープン
  • トップハット
閉じた カーネル列

カーネル列数を指定します。(1–25: デフォルト = 3) カーネルとは長方形の数配列のことで、画像の各ピクセル位置に対して近傍処理操作を行います。ピクセルの近傍グレースケール値は、出力画像上のピクセル位置のグレースケール値を定義します。

注 :

  • カーネルは非加重です。

  • カーネルは、奇数の整数である必要があります。通常、カーネルは 3 ✕ 3 ですが、そのサイズは任意です。

このパラメータは、フィルタが次のタイプに設定されている場合に、ON になります。

  • ボトムハット
  • クローズ
  • 膨張
  • エッジ強調
  • 収縮
  • ハイパス
  • ローカル中央値
  • 正規化したローカル中央値
  • ローパス
  • 最大 (トップハット/ボトムハット)
  • オープン
  • トップハット
閉じた しきい値モード

[フィルタタイプ] を [2 値化]、[グレースケール距離] または [しきい値範囲] に設定した場合に、しきい値レベルを自動的に設定するかどうかを指定します。

  • 手動: [しきい値] パラメータを ON にし、しきい値を手動で設定します。
  • 自動 (デフォルト):
    • [フィルタタイプ] を [2 値化] に設定した場合に、指定領域内のグレースケール値に基いて、しきい値レベルを自動的に設定します。
    • [フィルタタイプ] を [グレースケール距離] に設定した場合に、指定領域内の平均グレースケール値に基いて、しきい値レベルを自動的に計算します。
    • [フィルタタイプ] を [しきい値範囲] に設定した場合に、次の操作が自動的に行われrます。
      • ピクセル値が [最小] パラメータ設定より小さい場合、あるいはピクセル値が [最大] パラメータ設定より大きい場合、ピクセル値は背景に設定されます。
      • ピクセル値が [最小] および [最大] パラメータ設定の範囲内にある場合、 ピクセル値は前景に設定されます。
閉じた しきい値

[フィルタタイプ] を [2 値化]、[グレースケール距離] または [しきい値範囲] に設定した場合に、しきい値レベルを自動的に設定します (0～255; デフォルト = 128) 。

閉じた 最小

[フィルタタイプ] を [クリップ]、[引き伸ばし] または [しきい値範囲] に設定した場合に、最小グレースケール値を指定します (0～255; デフォルト = 128) 。

閉じた 最大

[フィルタタイプ] を [クリップ]、[引き伸ばし] または [しきい値範囲] に設定した場合に、最大グレースケール値を指定します (0～255; デフォルト = 128) 。

閉じた ゲイン

[フィルタタイプ] を [シャープ] に設定した場合に、ゲイン値を指定します (0～10; デフォルト = 1) 。 このパラメータは、エッジコントラストの強度を制御することによって、シャープネス強度を決定します。エッジ周囲のピクセルはその最小値または最大値により、エッジをよりシャープにします。

閉じた スムーズネス

[フィルタタイプ] を [シャープ] に設定した場合に、ガウス (ガウシアン) カーネルのスムーズネス値を指定します (1～4; デフォルト = 1) 。スムーズネスは、ガウス (ガウシアン) カーネルの標準偏差を制御します。高スムーズネス値は、スムーズ操作では広い「絞り」となり、特徴をシャープにするのに役立ちます。

注 : ガウス (ガウシアン) とは釣鐘型の曲線のことを指し、ROI 内のピクセルに加重平均を適用します。


輝度画像フィルタツール

注 : このツールは、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

輝度画像フィルタツールは、各ピクセルに「グローバルな」画像強調技術 (2 値化、反転、ヒストグラム平坦化、クリッピングまたはグレースケール伸長など) を使用して、画像領域にフィルタをかけ、ツール画像を出力します。ツール画像は、位置決めまたは検査ツールによって参照することができます。

「グローバルな」画像強調操作では、ツール領域にある個々のグレースケール値に基づいて、出力ピクセルにグレースケール値を割り当てます。

輝度画像フィルタツールは、OCR 文字をより正確に読み取るために表面からホットスポットをクリッピングしたり、コントラストを強調するために検査対象物の特徴を引き伸ばしたりするなど、特徴をより正確に検査するために画像領域を強調する場合に有用です。

ツールを設定するには

ツールのパラメータを調整するには


輝度フィルタ画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。

ツール画像 (画像フィルタツールおよびカラーツール)


ツール画像 (画像フィルタツールおよびカラーツール)

画像フィルタツール (フィルタ、近傍、輝度、シーン補正、カラーからグレースケール変換、カラーから二値化変換、変換、および比較) およびカラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) の出力画像を、位置決めおよび検査ツールのツール画像として使用することができます。

[ツール画像] パラメータは、[ツール画像] を出力するジョブがツールに追加された後に、ツールの [全般] タブに表示されます。すべてのツールは、取り込み画像以外にも、ツール画像を入力画像として使用することができます。ツール画像は、[使用法] 設定ペインでドロップダウンメニューからも選択することができます。

位置決めまたは検査ツールの [ツール画像] パラメータを、ツール画像を出力するツールに設定した場合 (画像フィルタツールは、他の画像フィルタを入力画像として使用することができます) 、これらのツールはフィルタ画像を使用して検査を実行します。このとき、ツール領域は、ツール画像領域を出力するツール内に含まれる必要があります。

[ツール画像] パラメータを画像フィルタツールに設定するには、画像フィルタツールを追加してから、追加済みツールの [全般] タブに戻り、[ツール画像] ドロップダウンリストから、画像フィルタツール (例: フィルタ_1.画像) を選択します。

注 : [ツール画像] を出力する画像フィルタツールまたはカラーツールをジョブに追加した後、取り込み画像以外の画像を入力画像としてサポートするツールをジョブに追加するたびに、設定ペインの [使用法] グループボックスで、ツールの入力画像を設定する必要があります。デフォルトは、現在取り込んでいる、フィルタなし画像 ([カメラ画像]) となります。


輝度フィルタ画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

輝度フィルタ画像フィルタツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [フィルタ前]/[フィルタ後] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[フィルタ前]/[フィルタ後] タブ


[全般] タブ (輝度フィルタ画像フィルタツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (輝度フィルタ画像フィルタツール)

閉じた 操作

領域に適用する画像強調技術を定義します。選択後、領域は自動的に更新されます。

操作 | 説明
2 値化 (デフォルト) | グレースケールしきい値を元に画像にフィルタをかけ、白 (255) または黒 (0) のどちらになるかを判定します。しきい値以上の入力ピクセル値は白に、しきい値を下回る値は黒になります。
クリップ | 入力ピクセルのグレースケール値と最小値および最大値を比較し、画像にフィルタをかけます。グレースケールスペクトルの両端を除去し、特徴がより均一な画像を出力します。
等化 | ヒストグラム平坦化 (最も多いグレースケール値を平坦化して、分布をより均一にする) に基づいて画像にフィルタをかけます。コントラストが強められた画像を出力します。
グレースケール距離 | 各出力ピクセルのグレースケール値を、各入力ピクセルのグレースケール値としきい値レベルの差としてフィルタをかけます。例えば、入力ピクセル値が 100 で、しきい値が 25 の場合、出力ピクセルは 75 となります。
反転 | ピクセル値のグレースケール反転を基にフィルタをかけます。入力画像の「ネガティブ」状態の画像を出力します。
しきい値範囲 | 各入力ピクセルを、2 つのしきい値 (最小値と最大値) で比較し、出力ピクセルが白または黒のどちらになるかを判定する、2 値化 (白黒) しきい値に基づいてフィルタをかけます。入力ピクセル値が最小値または最大値と等しいか、またはそれを超える場合、出力ピクセルは白となります。入力ピクセル値が最小値と最大値の間にある場合、出力ピクセルは黒となります。
光密度 | 対数メモリ上のピクセル値の反転に基づきフィルタをかけます。対象物と特徴を通り抜ける光の量を測定し、その密度を明らかにする画像を出力します。対象物と特徴の密度が高いほど、出力画像ではより明るいピクセルで表示されます。
引き伸ばし | グレースケール値を線状に拡大縮小したり、または「引き伸ばし」することにより、フィルタをかけます。コントラストが強められた画像を出力します。
閉じた 最小

[クリップ] または [しきい値範囲] 操作の最小グレースケール値 (0～255) を指定します。このコントロールは、この 2 つの操作のどちらかが選択されている場合のみ、有効になります。

閉じた 最大

[クリップ] または [しきい値範囲] 操作の最大グレースケール値 (0～255) を指定します。このコントロールは、この 2 つの操作のどちらかが選択されている場合のみ、有効になります。

閉じた しきい値モード

[2 値化]、[グレースケール距離] または [しきい値範囲] を選択した場合に、画像領域を白黒のピクセルに切り分けるグレースケール値を決める方法を指定します。[自動] (デフォルトは [自動]) を選択した場合、画像取り込みのたびにツールは画像に基づいてスマートセッティングを作成し、画像間の輝度の変化を調整します。[手動] を選択した場合、値を手動で入力、調整してください。

閉じた [しきい値]

[2 値化] または [グレースケール] 演算を選択した場合に、白ピクセルを黒ピクセルから切り分けるグレースケール値 (0～255) を定義します。しきい値以下のピクセル値は黒となり、しきい値以上のピクセルは白となります。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。グラフを参考にして、最適な値を設定してください。


[フィルタ前]/[フィルタ後] タブ (輝度フィルタ画像フィルタツール)

[フィルタ前]/[フィルタ後] タブは、領域内にあるピクセルのグレー値をヒストグラムで表したものです。[フィルタ前] タブには、画像処理前の画像領域のヒストグラムが表示されます。一方、[フィルタ後] タブには、画像処理を実行した後の画像領域のヒストグラムが表示されます。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 緑の垂直線は、画像の黒い部分と白い部分を切り分けるしきい値を表します。垂直線より左側が黒、右側が白とみなすことができます。


近傍画像フィルタツール

注 : このツールは、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

近傍画像フィルタツールは、各画像に「局所的」な画像強調技術 (縮小、拡大、塗りつぶし、平滑化またはエッジ強調など) を使用して、画像領域にフィルタをかけ、ツール画像を出力します。ツール画像は、位置決めまたは検査ツールによって参照することができます。

「局所的」な画像強調操作では、ツール領域の「近傍」ピクセルのグレースケール値に基づいて、出力ピクセルにグレースケール値を割り当てます。「近傍」サイズを指定するには、[フィルタ行] および [フィルタ列] パラメータを使用します。

近傍画像フィルタツールは、ドットピーンコードをより正確に読み取るために、金属表面の反射を低減させたり、OCR 文字の読み取り時に、グレースケールスペクトルの白側の端を膨張して黒い点を取り除いたりするなど、特徴をより正確に検出するために、画像領域を強調する場合に有用です。

ツールを設定するには

ツールのパラメータを調整するには


近傍フィルタ画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


近傍フィルタ画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

近傍フィルタ画像フィルタツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ


[全般] タブ (近傍フィルタ画像フィルタツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (近傍フィルタ画像フィルタツール)

閉じた 操作

領域に適用する画像強調技術を定義します。選択後、領域は自動的に更新されます。

操作 | 説明
ボトムハット | フィルタサイズより小さい暗い特徴以外のすべてにフィルタをかけます。暗い特徴が明るいピクセルで表示され、背景が暗く表示された画像を出力します。
クローズ | フィルタサイズより小さい特徴にフィルタをかけます。全体的な明度がわずかに高くなった画像を出力します。
膨張 | 明るい特徴を拡大し、暗い特徴を縮小します。明るいピクセルがより大きな領域を占める画像を出力します。このフィルタは、暗い斑点の除去に有用です。
エッジ強調 | 明るい特徴と暗い特徴にフィルタをかけます。明るいピクセルでエッジを表示した画像を出力します。この操作は、対角線方向のエッジを表現できますが、「勾配 全方向」より実行時間が長くなります。
収縮 | 明るい特徴を縮小し、暗い特徴を拡大します。暗いピクセルがより大きな領域を占める画像を出力します。このフィルタは明るい斑点の除去に有効です。
黒穴塗りつぶし | 明るいピクセルで囲まれた暗いピクセルを明るいピクセルに変換します。暗い穴が埋められた画像を出力します。
白穴塗りつぶし | 暗いピクセルで囲まれた明るいピクセルを暗いピクセルに変換します。明るい穴が埋められた画像を出力します。
勾配 垂直方向 | 垂直方向のエッジ特徴にフィルタをかけます。垂直方向のエッジが明るいピクセルで表示された画像を出力します。
勾配 水平方向 | 水平方向のエッジ特徴にフィルタをかけます。水平方向のエッジが明るいピクセルで表示された画像を出力します。
勾配 全方向 | 垂直方向および垂直方向のエッジ特徴にフィルタをかけます。垂直方向および垂直方向のエッジが明るいピクセルで表示された画像を出力します。この操作は対角線方向のエッジは表現しませんが、「エッジ強調」操作より実行時間が短くなります。
ハイパス | エッジ特徴にフィルタをかけ、そのほかの特徴を抑制します。むらのないグレースケール勾配を持つ領域に対し、相対的にエッジが強調された画像を出力します。
ローパス (デフォルト) | エッジ特徴を除去し、ほかの特徴を使用してエッジをぼやかします。エッジが「平滑化」された、またはぼやけた画像を出力します。
オープン | フィルタサイズより小さい明るい特徴にフィルタをかけます。全体的な輝度がわずかに低くなった画像を出力します。
トップハット | フィルタサイズより小さい明るい特徴以外のすべてにフィルタをかけます。暗い背景に、明るい特徴が明るいピクセルで表示された画像を出力します。
閉じた フィルタ行

近傍処理を行う画像の水平方向のサイズを指定します (1～25; デフォルト = 3)。

閉じた フィルタ列

近傍処理を行う画像の垂直方向のサイズを指定します (1～25; デフォルト = 3)。


シーン補正画像フィルタツール

注 : このツールは、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

シーン補正画像フィルタツールは、ピクセルごとの「局所的」な画像強調技術 (「平均明度」と呼ばれます) を使用して画像の領域にフィルタをかけ、位置決めまたは検査ツールによって参照するツール画像を出力します。

「平均明度」画像強調技術は、取り込み行数および列数パラメータで定義される、近傍処理に使用するピクセル明度を基に画像にフィルタをかけます。このフィルタは、各ピクセルの明度を近傍処理に使用するピクセルの平均明度と比較して、むらのある照明または影を画像から除外するシミュレーションを実行します。ばらつきがない、あるいは少ない画像エリアは、元の明度に関わらず、ニュートラル (灰色) で表示されます。周囲のピクセルより黒いピクセルは、周囲よりもどれぐらい黒いかによって、ニュートラル (灰色) より黒い色で表示されます。同様に、周囲のピクセルより白いピクセルは、ニュートラル (灰色) より白い色で表示されます。エッジおよびシャープな遷移は、「ハイパス」操作同様、保持されます。

シーン補正画像フィルタツールは、画像内にむらのある照明や影がある場合に有用です。

ツールを設定するには

ツールのパラメータを調整するには


シーン補正画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


シーン補正画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

シーン補正画像フィルタツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ


[全般] タブ (シーン補正画像フィルタツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (シーン補正画像フィルタツール)

閉じた 取り込み行数

近傍処理を行う画像の水平方向のサイズを指定します (1～画像の最大の高さ; デフォルト = 11)。

注 :
  • 最大値は、In-Sight ビジョンシステムの画像エリア (640 × 480, 1024 × 768 または 1600 × 1200 など) の最大サイズによって定義されます。
  • 近傍処理の画像サイズには、奇数のみが使用できます。偶数が入力されると、自動的に切り上げられます。
閉じた 列数

近傍処理を行う画像の垂直方向のサイズを指定します (1–～画像の最大幅; デフォルト = 11)。

注 :
  • 最大値は、In-Sight ビジョンシステムの画像エリア (640 × 480, 1024 × 768 または 1600 × 1200 など) の最大サイズによって定義されます。
  • 近傍処理の画像サイズには、奇数のみが使用できます。偶数が入力されると、自動的に切り上げられます。
閉じた タイムアウト

ツールが画像の明度を計算する時間をミリ秒単位で定義します (0～30,000; デフォルト = 0)。この時間を過ぎると、計算は終了し、ツールは FAIL を返します。値を 0 に設定すると、パラメータは無効となります。


カラーからグレースケール変換画像フィルタツール

カラーからグレースケール画像フィルタツールは、指定の操作に基づき、領域内のカラーピクセルをグレースケール値に変換し、画像の領域にフィルタをかけ、ツール画像を出力します。ツール画像は、位置決めまたは検査ツールによって参照することができます。

カラーからグレースケール変換ツールは、「純色の」赤、緑、青 (RGB)、色相、彩度、明度 (HSI)、輝度、もしくは RGB 成分の加重平均の補間の、いずれか 1 つのカラーパラメータからなる単純なフィルタに基づいて、領域内の各カラーピクセルをグレースケール値に変換します。

ツールを設定するには

ツールのパラメータを調整するには


カラーからグレースケール変換画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーからグレースケール変換画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーからグレースケール変換画像フィルタツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ


[全般] タブ (カラーからグレースケール変換画像フィルタツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラーフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーからグレースケール変換画像フィルタツール)

閉じた 操作
操作 | 説明
輝度 (デフォルト) | 輝度の出力画像です。概念上、輝度は明度に密接に関係しており、特定の領域から放射または反射される光の量の尺度です。入力画像でピクセルから放射される光が多いほど、出力画像での表示が明るくなります。
赤 | ピクセルの赤 (255,0,0) 以外の成分がフィルタで除去されます。入力画像のピクセルの赤の値が大きいほど、出力画像での表示が明るくなります。
緑 | ピクセルの緑 (0,255,0) 以外の成分がフィルタで除去されます。入力画像のピクセルの緑の値が大きいほど、出力画像での表示が明るくなります。
青 | ピクセルの青 (0,0,255) 以外の成分がフィルタで除去されます。入力画像のピクセルの青の値が大きいほど、出力画像での表示が明るくなります。
色相 | ピクセルの色相以外の成分がフィルタで除去されます。入力画像のピクセルの色相値が大きいほど、出力画像での表示が明るくなります。
彩度 | ピクセルの彩度以外の成分がフィルタで除去されます。入力画像のピクセルの彩度値が大きいほど、出力画像での表示が明るくなります。
明度 | ピクセルの明度以外の成分がフィルタで除去され、ピクセルの RGB 成分の平均輝度が判定されます。入力画像のピクセルの輝度値が大きいほど、出力画像での表示が明るくなります。
補間方法 | ピクセルの RGB (赤、緑、および青) 成分の加重平均である、補完を使用します。輝度フィルタと同様に、結果は、ピクセルの輝度以外の成分がフィルタで除去されます。入力画像のピクセルの輝度値が大きいほど、出力画像での表示が明るくなります。ただし、補間フィルタは RGB 成分の「加重」平均輝度を判定する、非標準の変換フィルタです。


カラーから二値化変換画像フィルタツール

カラーから二値化変換画像フィルタツールは、有効なカラーモデルにマッチするピクセルを白に、それ以外のピクセルを黒に変換することにより、画像領域にフィルタをかけ、ツール画像を出力します。ツール画像は、位置決めまたは検査ツールによって参照することができます。

カラーから二値化変換ツールは、登録済みのカラーモデルライブラリを参照し、選択した登録済みのカラーモデルにマッチする領域内のピクセル数を決定します。ツールは、有効なカラーモデルにマッチするピクセルを白 (255) に、それ以外のピクセルを黒 (0) に設定する、二値化グレースケール出力画像を作成します。

ツールを設定するには

ツールのパラメータを調整するには


カラーから二値化変換画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。

    • カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。

    • カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブでに戻って [カラーライブラリ] を選択してから、[ライブラリ] タブで使用する [カラーモデル] のチェックボックスを ON にします。

    • [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  4. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。

  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーから二値化変換画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーから二値化変換画像フィルタツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • カラーライブラリ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

カラーライブラリ


[全般] タブ (カラーから二値化変換画像フィルタツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラーフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーから二値化変換画像フィルタツール)

閉じた [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

閉じた カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール


カラーライブラリ (カラーから二値化変換画像フィルタツール)

閉じた [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

閉じた カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

閉じた カラー名

選択したカラーモデルに含まれるカラー名を表示します。

閉じた RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

閉じた 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


変換画像フィルタツール

変換画像フィルタツールは、画像領域の線形や非線形、レンズの歪みにフィルタをかけ、[画像の設定] ステップの[グリッド] キャリブレーションを使用して、実単位とピクセル間の変換を適用し、ツール画像を出力します。ツール画像は、位置決めまたは検査ツールによって参照することができます。

変換画像フィルタツールは、[画像の設定] ステップの [グリッド] キャリブレーションと連動して使用します。このツールは、光学歪みを補正 (画像を「変換」) して、非常に正確な計測値を返し、ピクセル単位を、ミリメートルやインチなどの実世界の測定単位に変換します。このツールと [グリッド] キャリブレーションを使用して、画像の周辺部にある対象物をより正確に検出することができます。また、In-Sight ビジョンシステムを検査面に対して最大 45 度の角度で取り付けることができるなど、柔軟な設置が可能になります。

ツールを設定するには

ツールのパラメータを調整するには


変換画像フィルタツールを設定するには

注 : このツールを追加する前に、[画像の設定] ステップで [グリッド] キャリブレーションを実行してください。

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


変換画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

変換画像フィルタツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ


[全般] タブ (変換画像フィルタツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は変換_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (変換画像フィルタツール)

閉じた 画像スケール

変換後の画像の表示スケールを定義します (0.01～10、デフォルトは 1.0)。

閉じた 基準点

変換に使用される基準点を指定します。[画像の中心] (デフォルト) では、基準点は画像の中心になります。[領域の中心] では、基準点は領域の中心になります。

閉じた 画像の表示

取り込み画像の代わりに、変換された画像を表示するかどうかを定義します。デフォルトでは、パラメータは ON (有効) で、変換された画像が常に表示されます。

注 : 他の位置決めまたは検査ツールが、変換フィルタを適用した画像ではなく、取り込み画像を使用して検査を実行している可能性があると、グラフィックスオーバーレイが、変換された画像とは関係なく表示されることがあります。その場合、[ジョブの実行] ステップで [グラフィックスの表示] オプションを OFF にして、これらのツールのグラフィックスオーバーレイを非表示にすることができます。


比較画像フィルタツール

比較画像フィルタツールは、入力画像とテンプレート画像を比較し、各ピクセルが正規化された差を表すグレースケール出力画像を生成します。ツール画像は、位置決めまたは検査ツールによって参照することができます。

『比較』画像強調プロセスでは、テンプレートのピクセルを入力画像にマッピングして入力画像とテンプレートを比較し、グレースケール出力画像を生成します。テンプレート画像と一致しないピクセルは、白ピクセルとして表示されます。

比較画像フィルタツールは、製造工程中に検査対象またはその一部の傷を検出したい場合などに有用です。例えば、比較画像フィルタツールに、傷のない検査対象またはその一部を登録してから、登録画像と取得した画像を比較します。ブロブ計数ツールなど、その他のツールが、比較画像フィルタツールが出力したツール画像に対して検査を実行します。ブロブ計数ツールのロジックを反転させておくと、ブロブが検出されない場合はツールは PASS を返し、ブロブを検出した場合は FAIL を返します。

ツールを設定するには

ツールのパラメータを調整するには


比較画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

注 : このツールは、画像中に背景ノイズが存在しない場合に、最も性能を発揮します。また、各画像は、検査対象またはその一部がほぼ同じ場所に存在するなど、ほぼ同一にするようにしてください。また、傷がある場合は、顕著で大きい必要があります。画像にノイズがある場合、輝度フィルタ画像フィルタツールを使用し、2 値化操作を実行して、画像中のグレースケール差を取り除いてください。
  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


比較画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

比較画像フィルタツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • 登録画像タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

[登録画像] タブ


[全般] タブ (比較画像フィルタツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (比較画像フィルタツール)

閉じた ピクセル比較

テンプレートを入力画像にマッピングするときに使用する、ピクセル比較のタイプを定義します。選択肢は、[最近傍間] または [バイリニア] です。

[最近傍間] (デフォルト設定) では、テンプレートの各ピクセルを入力画像内の最近傍ピクセルと比較し、正規化されたグレースケールの差分をピクセルごとに計算します。これは高速ですが、精度の低い方法です。

[バイリニア] では、テンプレートの各ピクセルを加重平均 (入力画像の 4 つの最近傍ピクセルのグレースケール値を表す) と比較し、正規化されたグレースケールの差をピクセルごとに計算します。これは、比較的正確な方法ですが、速度は遅くなります。

閉じた エッジ範囲

画像の比較時に許容されるエッジ周辺のピクセル数を定義します (0～24、デフォルト = 3)。数値が大きいほど、一致が不完全なエッジが、出力画像に差分として示される可能性が低くなります。


登録画像タブ (比較画像フィルタツール)

モデルテンプレート画像のサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


傷検査欠陥検出ツール

傷検査欠陥検出ツールは、ピクセル明度のばらつきに基づき、小さな傷を検出するのに使用します。このツールは、グレースケールまたはカラー画像で、細い傷や切れ目、破れ、欠けといった傷を検出するように設計されています。

傷検査欠陥検出ツールは、輝度や色に局部的な変化のあるエリアを検出するように設計されています。ツールは内部でフィルタ操作を実行して、色やグレースケールに急激な変化があるエッジやエリアをハイライトしてから、ブロブで解析して傷があるかどうかを決定します。このツールは、急激な輝度の変化が欠陥であると分類されるような、均一のエリアがあるパーツの検査に有用です。

傷検査欠陥検出ツールでは、必要に応じて、画像の検査エリアをハイライトする一方で検査の必要のないエリアを除外する、内蔵画像マスクを使用することができます。

ツールを設定するには

ツールのパラメータを調整するには


傷検査欠陥検出ツールを設定するには

ツール設定には、傷が存在するかどうかを決定するのに使用する、しきい値設定が含まれます。 検査するパーツの画像データベース (PASS および FAIL の両方の画像を含む) を PC からロードして、設定を始めてください。

  1. エラーのない状態のパーツ画像をロードします。次に、傷検査欠陥検出ツールを追加します。

  2. 画像領域を設定します。 [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 領域がすべての傷および傷が発生する可能性のある場所を囲んでいることを確認して下さい。

    注 :
    • パフォーマンスを上げるため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、その傷がすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、傷が移動しても十分にカバーできる大きさに領域を設定してください。
    • ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  3. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  4. エラーのない画像を使用して、ツールが傷を検出しないようパラメータを調整します。 [傷検出] タブの [表示画像] パラメータを使用すると、パラメータ調整がツール結果にどのような影響を与えるか、視覚的なフィードバックを表示することができます。 四角形の赤ボックス内に検出される傷がすべて含まれるように、[画像表示] パラメータを [傷候補] に設定します。

    注 : 必要に応じて、マスクを生成して画像の検査エリアをハイライトし、その他のエリアを検査から排除することができます。 テキスト、ラベルまたは他の特徴を無視する検査を設定する場合などに、マスクは非常に有用です。
  5. パラメータ調整の際に、ツールの領域が検査エリアを正しく囲むように ROI 設定されていることを確認して下さい。また、領域から不必要な特徴 (ラベルや文字のエッジまたはロゴなど) が排除されるようにしてください。 検査にパーツのエッジが含まれる場合、領域はエッジと平行に配置してください。(円状の領域にも同じことが適用されます。円領域の円弧はパーツのエッジと並行に配置してください。)
  6. 次に、[サンプリング係数] および [平滑化係数] パラメータを調整してください。 勾配の少ない傷を検出したり、低コントラストの大きな傷を検出したりするには、[サンプル化係数] を大きくします。 [平滑化係数] を大きくすると、小さな偽の傷を排除することができます。
  7. [検出タイプ]、[検出サイズ] および [検出軸] パラメータを調整します。 ほとんどのアプリケーションにおいて、[検出タイプ] を [高速] に、[検出サイズ] を 1 に設定することが可能です。 [検出タイプ] を [白]、[黒]、[白および黒] に設定する必要があるアプリケーションでは、[検出サイズ] パラメータを検出する傷の半径より大きく設定する必要があります。 領域がエッジに並行するように設定されている場合、検出軸は領域に並行するように設定する必要があります。
  8. [最小傷面積]、[最大傷面積] および [最小コントラスト] パラメータを調整します。
  9. エラーのない状態のパーツを正しく検査するようになったら、傷のあるパーツ画像をロードします。 上記のパラメータ調整プロセスを再度行い、傷を正しく認識するようにツールを調整します。 傷のあるパーツ画像を更にロードし、必要に応じて、別の傷を認識するようにパラメータを調整します。
  10. 傷を認識するようになったら、傷のない状態のパーツ画像を再度ロードし、検査の結果傷が検出されないことを確認します。 正しく設定されていることが確認できたら、ランタイム検査にツールを使用する準備が整ったことになります。
  11. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。

[マスク] タブを設定するには


傷検査欠陥検出ツールマスクを設定するには

傷検査欠陥検出ツールでは、内部マスクを生成して、検査エリアをハイライトし、他のエリアを検査から除外することができます。

  1. [マスク] タブを開き、[マスク有効] チェックボックスを ON にします。
  2. マスクをどのように生成するかを決定します (最大セグメントまたはエッジ)。デフォルトでは、エッジが使用され ([マスク方法] パラメータが [エッジマスク] に設定されます)、エッジ強度に応じて画像マスクを生成します。この画像マスクでは、エッジピクセルのみがマスクされ、その他のピクセルは表示されます。最大セグメントを選択した場合、検査特徴エリアは最大セグメントとなり、背景を検査から排除します。
  3. マスク表示画像パラメータを設定します。選択したマスクは、カラーコード化されインデックス番号が与えられたセグメントを表示することによって、マスク特徴をハイライトするのに有用なマスクを生成します。
  4. マスク平滑化パラメータを調整します。画像のエッジが正しくハイライトされていることを確認して下さい。
  5. [穴塗りつぶし最大サイズ]、[カーネルサイズ中央値] および [収縮マスク数] パラメータを調整します。これらのパラメータは順番に、画像マスクの穴の塗りつぶし、境界線の平滑化、および細い切れの除外に使用されます。[マスク方法] パラメータが [エッジマスク] に設定されが選択されている場合、[穴塗りつぶし最大サイズ] パラメータは 0 に設定してください。
  6. マスクが特徴を正しくハイライトし、その他のエリアを除外するよう調整したら、[登録] ボタンを押しマスクを設定します。
注 : 領域以外のパラメータが変更された場合、マスクを更新し強制的に再登録されます。領域が移動したりサイズ変更された場合、[登録] ボタン再度押してマスクを更新してください。


傷検査欠陥検出ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

傷検査欠陥検出ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [マスク] タブ
  • [傷検出] タブ
  • [統計]、[傷] および [合成領域] タブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[マスク] タブ

[傷検出] タブ

[統計]、[傷]、および [合成領域] タブ


[全般] タブ (傷検査欠陥検出ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名は傷検査_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[マスク] タブ (傷検出欠陥検出ツール)

閉じた マスク有効

マスクを使用するかどうかを定義します (デフォルト = OFF)。

閉じた マスク登録

現在設定されているパラメータでマスクを登録するかどうかを定義します。

閉じた マスク方法

マスクの生成方法を定義します。選択肢は、[最大セグメント] または [エッジマスク] (デフォルト) です。

  • 最大セグメント: 最大のセグメントを使用してマスクを生成します。
  • エッジマスク: エッジを使用してマスクを生成します ([最小エッジコントラスト] パラメータがどのエッジを使用するか定義します)。
閉じた マスク表示画像

表示する出力画像を定義します。選択肢は、[入力画像]、[エッジ画像]、[セグメント化した画像] または [マスク画像] (デフォルト) です。

  • 入力画像: 現在取得されている画像を表示します。
  • エッジ画像: エッジ強度画像を表示します。
  • セグメント化した画像: 色分けされた、セグメント画像を表示します。
  • マスク画像: セグメント化およびマスク生成処理後に作成されたバイナリマスク画像を表示します (フィクスチャ入力適用後)。ピクセル値 255 = ピクセルを考慮します。ピクセル値 0 = ピクセル値を考慮しません。
注 : この画像は表示のみに使用されます。他の機能の入力としては使用できません。
閉じた マスク平滑化係数

画像の平滑化に使用するシグマ係数を定義します (0～100; デフォルト = 1)。

閉じた 最小エッジコントラスト

エッジ検出に使用する最小コントラストを定義します (1～100; デフォルト = 1)。

注 : このパラメータは、[マスク方法] パラメータが [エッジマスク] に設定されている場合に有効となります。
閉じた 最小セグメントサイズ

セグメントを抽出するのに必要な最小面積をピクセル単位で定義します (1～50000; デフォルト = 1000)。

閉じた 穴塗りつぶし最大サイズ

「穴」として考慮されないよう、小さな穴を塗りつぶすために必要な最大サイズを定義します (0～1000; デフォルト = 100)。

閉じた カーネルサイズ中央値

マスク画像のエッジを平滑化するのに使用するカーネルサイズ中央値を定義します(0～50000; デフォルト = 0)。

閉じた 収縮マスク数

生成画像が収縮される回数を定義します (-100～100; デフォルト = 0)。値には正の値および負の値の両方が使用できます。負の値は画像を膨張させます。

閉じた 反転

白を黒に、または黒を白になど、マスクを反転させるかどうかを定義します。white for black, black for white.


[傷検出] タブ (傷検出欠陥検出ツール)

閉じた 検出タイプ

欠陥が存在するかを決定するために画像に適用する画像処理の方法を定義します。選択肢は、[高速] (デフォルト)、[白]、[黒]、[白および黒] です。

  • 高速: 細い線や傷といった、「エッジ」タイプの傷の明度遷移を検出するのに有用です。傷のエッジをハイライトする、収縮誇張処理を適用します。実行時間は一番短いですが、報告されるのは傷の面積ではなく、周囲長のみとなります。
  • 白: 黒い背景上にある白い「ブロブ」タイプの傷の検出に有用です。傷面積のピクセルサイズに基づいて、傷を検出します。「トップハット」フィルタ処理を行い、[検出サイズ] パラメータで指定した値より小さい白い特徴以外をすべて取り除き、潜在的な傷を検出します。
  • 黒: 白い背景上にある黒い「ブロブ」タイプの傷の検出に有用です。傷面積のピクセルサイズに基づいて、傷を検出します。「ボトムハット」フィルタ処理を行い、[検出サイズ] パラメータで指定した値より小さい黒い特徴以外をすべて取り除き、潜在的な傷を検出します。
  • 白および黒: 黒または白背景上にある「ブロブ」タイプの傷の検出に有用です。傷面積のピクセルサイズに基づいて、傷を検出します。「ボトムハット」および「トップハット」両方の処理を行い、両方の処理の最大結果を使用します。
注 : 白、黒または白および黒傷タイプタイプが選択されている場合、[検出サイズ] パラメータは検出される傷の最大サイズに設定する必要があります。
閉じた 表示画像

出力画像を定義します。選択肢は、[入力画像]、[サンプリング画像]、[傷候補]、[傷マスク画像] (デフォルト) です。

  • 入力画像: 現在取得されている画像を表示します。
  • サンプリング画像: 平滑化したサンプル画像が表示されます。角度やカーブのある領域が入力に使用されている場合、平滑化・サンプル効果に加え、歪み補正を実行し変換した画像が表示されます。
  • 傷候補: 傷候補が表示されます。傷候補は背景と対象をなす色でハイライトされます。
  • 傷マスク画像: 傷が表示されます。傷は白で、その他のエリアは黒で描画されされます。この表示オプションでは、傷定義指定範囲外 ([最小傷面積] および [最大傷面積])の傷も表示します。
注 : この画像は表示のみに使用されます。他の機能の入力としては使用できません。
閉じた サンプリング係数

解像度を下げることにより、どの入力画像をサンプリングするか定義します (1～ 99999; デフォルト = 1)。サンプリングによりツールの実行時間は短くなりますが、その精度さは下がります。サンプル係数値 1 は、サンプリングを実行しない、 フル解像度の画像となります。サンプル係数値が増えると解像度および精度は下がり、実行時間は短くなります。

閉じた 自動平滑化

画像を平滑化する、最適平滑化係数を決定するかどうかを定義します (デフォルト = OFF)。通常、最適平滑化係数を選択することにより、パフォーマンスを上げることができます。

注 : [自動平滑化] パラメータはデフォルトで OFF となっています。ON にするには、 [サンプリング係数] パラメータを 1 以上の値に設定してください。[サンプリング係数] パラメータを 1 以上の値に設定した場合に、[自動平滑化] パラメータを ON にしたくない場合は、[自動平滑化] パラメータを OFF にし、[平滑化係数] パラメータを適切な数値に設定してください。
閉じた 平滑化係数

画像を平滑化する係数を定義します (0～99999; デフォルト = 0)。最適値を決定する場合、サンプリング係数で指定した値と近い値から始めてください。平滑化を行わない場合は、0 に設定してください。

注 : [自動平滑化] パラメータを ON にした場合、このパラメータは無効となります。[自動平滑化] パラメータが ON の場合、[サンプリング係数] パラメータを 1 以上に設定して、[自動平滑化] パラメータを OFF にした後で、 [平滑化係数] パラメータの数値を増分することができます。
閉じた 検出軸

傷候補を検出する軸を定義します。選択肢は、[X]、[Y]、[X および Y] (デフォルト) です。

閉じた 検出サイズ

検出近傍サイズをピクセル単位で定義します (1～99999; デフォルト = 1)。このパラメータは、[操作] パラメータともに使用して、近傍処理の作成やカーネルに使用されます。[操作] パラメータを [高速] 以外に設定した場合、サイズ値は検出する傷の長さまたは幅と最低同じ値にする必要があります。

閉じた 最小コントラスト

傷検出に使用する明度しきい値を定義します (1～255;デフォルト = 20)。傷を検出するには、明度は背景の値と異なる必要があります。

閉じた 最小傷面積

検出する傷の最小サイズをピクセル単位で定義します (1～99999; デフォルト = 30)。

注 : この値は、常にピクセル単位で表示されます。ジョブが、[画像の設定] ステップで実世界の計測値にキャリブレートされている場合もピクセル表示となります。
閉じた 最大傷面積

検出する傷の最大サイズをピクセル単位で定義します (1～99999; デフォルト = 99999)。

注 : この値は、常にピクセル単位で表示されます。ジョブが、[画像の設定] ステップで実世界の計測値にキャリブレートされている場合もピクセル表示となります。
閉じた タイムアウト

ツールが傷をサーチする時間をミリ秒単位で定義します (0～30,000; デフォルト = 5000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

閉じた すべての傷

検出された傷の総数を表示します。


[統計]、[傷]、および [合成領域] タブ (傷検出欠陥検出ツール)

閉じた [統計] タブ

傷総数および累積サイズについてのデータを表示します。

閉じた [傷] タブ

最初に検出された 10 個の傷を面積でソートし、最大から最小の順番で表示します。 テーブルには、画像内の傷の位置 (X/Y 座標)、面積、周囲長、新エンドおよび明度が表示されます。

閉じた [合成領域] タブ

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注 :
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
閉じた [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注 :

合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。

閉じた 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

閉じた 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

閉じた 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

閉じた ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


エッジ欠陥検出ツール

エッジ欠陥検出ツールは、エッジ特徴の正確な位置を特定するエッジ解析キャリパアレイを使用して、エッジ特徴に最も適合するラインまたは円を作成します。エッジの識別後、最適ラインまたは最適円 (エッジ特徴にカーブがあるかどうかによります) をエッジ特徴の上に作成し、欠陥またはギャップなどの偏差があるかどうかを決定して、検出した欠陥/ギャップの数を返します。

注 :
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

エッジ欠陥検出ツールは、、検査対象物またはオブジェクトのエッジ特徴に、欠陥またはギャップなどの偏差が無いことを確認する場合などに有用です。例えば、検査対象物/オブジェクトの外側が同じ形状を維持しているかどうか、小さなくぼみや切れ目がないかどうかを確認するのに使用します。

ツールを設定するには

ツールのパラメータを調整するには


エッジ欠陥検出ツールを設定するには

ツールを追加したら、エッジ特徴上のマスク領域を設定します。

  1. エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

    注 : マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[エッジ]、[エッジ得点]、[最適ライン]、[欠陥] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際、エッジ候補を正しく検出し、最適ラインや最適円を正しく作成していることを確認してください。最初にツールを設定する際には、理想的なエッジ特徴を含む画像を使用します。その後、エッジ候補を含む画像を取り込み、欠陥やギャップなどの偏差があるかどうかを決定します。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジ欠陥検出ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジ欠陥検出ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [最適ライン] タブ
  • [欠陥] タブ
  • [ギャップ] タブ
  • [欠陥] および [ギャップ] テーブルタブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[エッジ] タブ

[エッジ得点] タブ

[最適ライン] タブ

[欠陥] タブ

[ギャップ] タブ

[欠陥] および [ギャップ] テーブルタブ


[全般] タブ (エッジ欠陥検出ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名はエッジ欠陥_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[エッジ] タブ (エッジ欠陥検出ツール)

[エッジ] タブを選択すると、領域内で検出されたすべてのエッジが暗い緑色で表示されます。[キャリパサイズ]、[キャリパ間隔]、[エッジ幅] および [最小コントラスト] パラメータを必要に応じて調整し、使用するエッジを検出することができます。

[すべてのキャリパを表示] チェックボックスを ON にすると、すべてのキャリパが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

閉じた キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

閉じた キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

閉じた エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

閉じた キャリパ数

領域内のキャリパ総数を表示します。

閉じた キャリパインデックス

検出および表示する、キャリパを指定します。

閉じた すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (エッジ欠陥検出ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補が、カラーコード化された小さな円で表示されます (領域は選択し、調整することができます)。エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。パラメータを調整して、使用するエッジ候補を検出してください。

検出された欠陥およびギャップも表示されます。

閉じた エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]) を指定します。デフォルトは、[左→右] です。

閉じた エッジの遷移

エッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには、遷移タイプを明示してください。

閉じた 規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


[最適ライン] タブ (エッジ欠陥検出ツール)

[最適ライン] タブを選択すると、領域内で検出されたすべてのエッジ候補や、最適円または最適ラインの結果が表示されます。

エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。エッジ候補はカラーコード化された小さな円で表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

閉じた 外れ値の除外

[最適距離フィルタ] パラメータで指定されている距離より遠い点を、最適ラインから削除するかどうかを指定します。デフォルトは、OFF です。

閉じた 最適距離フィルタ

エッジが元の最適ラインから離れている必要がある距離をピクセルで指定します (1～1920、デフォルト = 2)。この値は、最適合計算で使用します。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。

注 : このパラメータを使用するには、[外れ値の除外] パラメータを ON (有効) にする必要があります。
閉じた 最端フィルタ距離

除外距離を指定します (1～1920、デフォルト = 1000)。この値の外にあるエッジは、最小距離および最大距離を決定するのに使用されません。この値より大きなエッジは無視されます。

閉じた 再得点

最初に破棄した検出エッジが削除されているかどうかを確認するのに、検出エッジを再得点するかどうかを指定します。デフォルトは、OFF です。

閉じた 再計算

エッジ得点の再計算後に、最適ラインの再計算を行うように指定します。デフォルトは、OFF です。

注 : この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。


[欠陥] タブ (エッジ欠陥検出ツール)

[欠陥] タブを選択すると、最適円または最適ラインの結果と、検出された欠陥またはギャップが表示されます。「欠陥」は、最適ラインまたは最適円からのエッジ偏差として指定されます。

このタブの選択中に、領域を選択し、調整することもできます。

>

閉じた 最小距離

エッジおよび最適ライン/最適円からの最小距離をピクセルで指定します (0.001～1920、デフォルト = 4)。この値より距離が短い場合、欠陥とみなされません。

閉じた 最大距離

エッジおよび最適ライン/最適円からの最大距離をピクセルで指定します (0.001～1920、デフォルト = 1000)。この値より距離が長い場合、欠陥とみなされません。

閉じた サイズ有効

サイズ欠陥 (エッジ沿いの長さ) を考慮するかどうかを指定します。デフォルトは、ON です。

注 : [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。
閉じた 最小サイズ

最小欠陥サイズをピクセルで指定します (0.001～1920、デフォルト = 10)。最適ラインまたは最適円からの連続偏差がこの値より小さい場合、欠陥とみなされません。

閉じた 最大サイズ

最大欠陥サイズをピクセルで定義します (0.001～1920、デフォルト = 1000)。最適ラインまたは最適円からの連続偏差がこの値より大きい場合、欠陥とみなされません。

閉じた 面積有効

面積欠陥を考慮するかどうかを指定します。デフォルトは、ON です。面積欠陥は、最適ラインまたは最適円沿いの長さ、および欠陥エッジの最適ラインまたは最適円からの欠陥エッジの長さを考慮します。

注 : [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。
閉じた 最小面積

最小面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 10)。この値より面積が小さい場合、欠陥とみなされません。

閉じた 最大面積

最大面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 1000000)。この値より面積が大きい場合、欠陥とみなされません。

閉じた 欠陥フィルタ

最適ラインを基準に、欠陥をフィルタするかどうかを定義します。選択肢は、フィルタなし (デフォルト)、最適ライン左の欠陥を無視、最適ライン右の欠陥を無視。


[ギャップ] タブ (エッジ欠陥検出ツール)

[ギャップ] タブを選択すると、最適円または最適ラインの結果と、検出された欠陥またはギャップが表示されます。「ギャップ」は、最適ラインまたは最適円からのエッジ偏差として指定されます。

このタブの選択中に、領域を選択し、調整することもできます。

閉じた ギャップの検出

検出エッジ中のギャップを考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 最小ギャップ

最小ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より小さい場合、ギャップとみなされません。

閉じた 最大ギャップ

最大ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より大きい場合、ギャップとみなされません。

閉じた 終端ギャップを無視

領域の始まりと終わりで検出されたギャップを考慮するかどうかを指定します。デフォルトは、OFF です。

閉じた 結果

検出された欠陥/ギャップの総数を表示します。


[欠陥] および [ギャップ] テーブルタブ (エッジ欠陥検出ツール)

[欠陥] および [ギャップ] テーブルタブは、最初に検出された 10 個の欠陥/ギャップをエッジ上の位置でソートして表示します。

閉じた インデックス

検出された欠陥/ギャップの順番。エッジ上の位置によりソートされます (1～10)。EasyBuilder では 0 から数えます。

閉じた X

欠陥/ギャップの周りを囲む四角形の X 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

閉じた Y

欠陥/ギャップの周りを囲む四角形の Y 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

閉じた 面積

欠陥/ギャップの周りを囲む四角形の面積を返します。

閉じた サイズ

エッジ上の欠陥/ギャップのサイズ (長さ) を返します。

閉じた キャリパ

欠陥/ギャップが及ぶキャリパの範囲を返します。

閉じた キャリブレーション単位/ピクセル

テーブルに表示する結果の単位 (ワールド座標 = キャリブレーション単位、またはピクセル) を指定します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


エッジペア欠陥検出ツール

エッジペア欠陥検出ツールは、エッジ特徴の正確な位置を特定するエッジ解析キャリパアレイを使用して、エッジ特徴に最も適合するラインまたは円のペアを作成します。エッジの識別後、最適ラインまたは最適円 (エッジ特徴にカーブがあるかどうかによります) のペアをエッジ特徴の上に作成し、欠陥またはギャップなどの偏差があるかどうかを決定して、検出した欠陥/ギャップの数を返します。

注 :
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

エッジペア欠陥検出ツールは、欠陥またはギャップなどの偏差が、検査対象物またはオブジェクトのエッジ特徴に無いことを確認する場合などに有用です。例えば、検査対象物/オブジェクトの外側が同じ形状を維持し、小さなくぼみや切れ目がないことを確認するのに使用します。

ツールを設定するには

ツールのパラメータを調整するには


エッジペア欠陥検出ツールを設定するには

ツールを追加したら、エッジ特徴上のマスク領域を設定します。

  1. エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

    注 : マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[エッジ]、[エッジ得点]、[最適ライン]、[欠陥] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際、エッジ候補を正しく検出し、最適ラインや最適円を正しく作成していることを確認してください。最初にツールを設定する際には、理想的なエッジ特徴を含む画像を使用します。その後、エッジ候補を含む画像を取り込み、欠陥やギャップなどの偏差があるかどうかを決定します。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジペア欠陥検出ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジペア欠陥検出ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [最適ライン] タブ
  • [欠陥] タブ
  • [ギャップ] タブ
  • [エッジ 0 欠陥]、[エッジ 1 欠陥] および [ギャップ] テーブルタブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[エッジ] タブ

[エッジ得点] タブ

[最適ライン] タブ

[欠陥] タブ

[ギャップ] タブ

[エッジ 0 欠陥]、[エッジ 1 欠陥] および [ギャップ] テーブルタブ


[全般] タブ (エッジペア欠陥検出ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名はエッジペア欠陥_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[エッジ] タブ (エッジペア欠陥検出ツール)

[エッジ] タブを選択すると、領域内で検出されたすべてのエッジが暗い緑色で表示されます。[キャリパサイズ]、[キャリパ間隔]、[エッジ幅] および [最小コントラスト] パラメータを必要に応じて調整し、使用するエッジを検出することができます。

[すべてのキャリパを表示] チェックボックスを ON にすると、すべてのキャリパが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

閉じた キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

閉じた キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

閉じた エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

閉じた キャリパ数

領域内のキャリパ総数を表示します。

閉じた キャリパインデックス

検出および表示する、キャリパを指定します。

閉じた すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (エッジペア欠陥検出ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補が、カラーコード化された小さな円で表示されます (領域は選択し、調整することができます)。エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。パラメータを調整して、使用するエッジ候補を検出してください。

検出された欠陥およびギャップも表示されます。

閉じた エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]、[内→外] [外→内]) を指定します。デフォルトは、[左→右] です。

閉じた エッジ0 の遷移

最初に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた エッジ1 の遷移

2 番目に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた 規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 規則:ペアサイズ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、[ペアサイズ] パラメータで指定した値に最も近いサイズのエッジペアを第一に考慮するかどうかを指定します。デフォルトは、OFF です。

閉じた ペアサイズ

最高得点を与えるエッジペアサイズを指定します (1～1920、デフォルト = 5)。このパラメータを有効にすると、この値より大きいまたは小さいサイズのエッジペアが検出されたとき、この値に近いエッジペアが選択されます。例えば、[ペアサイズ] を10に設定しているとき、8 と 14 のエッジペアが検出されると、14 より 8 のほうが 10 に近いので、8 が選択されます。このパラメータを使用するには、[規則: ペアサイズ] チェックボックスを ON にする必要があります。

閉じた 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


[最適ライン] タブ (エッジペア欠陥検出ツール)

[最適ライン] タブを選択すると、領域内で検出されたすべてのエッジ候補や、最適円または最適ラインの結果が表示されます。

エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。エッジ候補はカラーコード化された小さな円で表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

閉じた 外れ値の除外

[最適距離フィルタ] パラメータで指定されている距離より遠い点を、最適ラインから削除するかどうかを指定します。デフォルトは、OFF です。

閉じた 最適距離フィルタ

エッジが元の最適ラインから離れている必要がある距離をピクセルで指定します (1～1920、デフォルト = 2)。この値は、最適合計算で使用します。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。

注 : このパラメータを使用するには、[外れ値の除外] パラメータを ON (有効) にする必要があります。
閉じた 最端フィルタ距離

除外距離を指定します (1～1920、デフォルト = 1000)。この値の外にあるエッジは、最小距離および最大距離を決定するのに使用されません。この値より大きなエッジは無視されます。

閉じた 再得点

最初に破棄した検出エッジが削除されているかどうかを確認するのに、検出エッジを再得点するかどうかを指定します。デフォルトは、OFF です。

閉じた 再計算

エッジ得点の再計算後に、最適ラインの再計算を行うように指定します。デフォルトは、OFF です。

注 : この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。


[欠陥] タブ (エッジペア欠陥検出ツール)

[欠陥] タブを選択すると、最適円または最適ラインの結果と、検出された欠陥またはギャップが表示されます。「欠陥」は、最適ラインまたは最適円からのエッジ偏差として指定されます。

このタブの選択中に、領域を選択し、調整することもできます。

閉じた 最小距離

エッジおよび最適ライン/最適円からの最小距離をピクセルで指定します (0.001～1920、デフォルト = 4)。この値より距離が短い場合、欠陥とみなされません。

閉じた 最大距離

エッジおよび最適ライン/最適円からの最大距離をピクセルで指定します (0.001～1920、デフォルト = 1000)。この値より距離が長い場合、欠陥とみなされません。

閉じた サイズ有効

サイズ欠陥 (エッジ沿いの長さ) を考慮するかどうかを指定します。デフォルトは、ON です。

注 : [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。
閉じた 最小サイズ

最小欠陥サイズをピクセルで指定します (0.001～1920、デフォルト = 10)。最適ラインまたは最適円からの連続偏差がこの値より小さい場合、欠陥とみなされません。

閉じた 最大サイズ

最大欠陥サイズをピクセルで定義します (0.001～1920、デフォルト = 1000)。最適ラインまたは最適円からの連続偏差がこの値より大きい場合、欠陥とみなされません。

閉じた 面積有効

面積欠陥を考慮するかどうかを指定します。デフォルトは、ON です。面積欠陥は、最適ラインまたは最適円沿いの長さ、および欠陥エッジの最適ラインまたは最適円からの欠陥エッジの長さを考慮します。

注 : [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。
閉じた 最小面積

最小面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 10)。この値より面積が小さい場合、欠陥とみなされません。

閉じた 最大面積

最大面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 1000000)。この値より面積が大きい場合、欠陥とみなされません。

閉じた 欠陥フィルタ

最適ラインを基準に、欠陥をフィルタするかどうかを定義します。選択肢は、フィルタなし (デフォルト)、最適ライン左の欠陥を無視、最適ライン右の欠陥を無視。


[ギャップ] タブ (エッジペア欠陥検出ツール)

[ギャップ] タブを選択すると、最適円または最適ラインの結果と、検出された欠陥またはギャップが表示されます。「ギャップ」は、最適ラインまたは最適円からのエッジ偏差として指定されます。

このタブの選択中に、領域を選択し、調整することもできます。

閉じた ギャップの検出

検出エッジ中のギャップを考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 最小ギャップ

最小ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より小さい場合、ギャップとみなされません。

閉じた 最大ギャップ

最大ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より大きい場合、ギャップとみなされません。

閉じた 終端ギャップを無視

領域の始まりと終わりで検出されたギャップを考慮するかどうかを指定します。デフォルトは、OFF です。

閉じた 結果

検出された欠陥/ギャップの総数を表示します。


[エッジ 0 欠陥]、[エッジ 1 欠陥] および [ギャップ] テーブルタブ (エッジペア欠陥検出ツール)

[エッジ 0 欠陥]、[エッジ 1 欠陥] および [ギャップ] テーブルタブは、最初に検出された 10 個の欠陥/ギャップをエッジ上の位置でソートして表示します。「エッジ0」は最初のエッジを、「エッジ1」は 2 番目のエッジを指します。

閉じた インデックス

検出された欠陥/ギャップの順番。エッジ上の位置によりソートされます (1～10)。EasyBuilder では 0 から数えます。

閉じた X

欠陥/ギャップの周りを囲む四角形の X 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

閉じた Y

欠陥/ギャップの周りを囲む四角形の Y 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

閉じた 面積

欠陥/ギャップの周りを囲む四角形の面積を返します。

閉じた サイズ

エッジ上の欠陥/ギャップのサイズ (長さ) を返します。

閉じた キャリパ

欠陥/ギャップが及ぶキャリパの範囲を返します。

閉じた キャリブレーション単位/ピクセル

テーブルに表示する結果の単位 (ワールド座標 = キャリブレーション単位、またはピクセル) を指定します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


エッジ幅欠陥検出ツール

エッジ幅欠陥検出ツールは、エッジペアの幅が許容範囲内にあるかどうかを計測、検証します。特徴の正確な位置を特定するエッジ解析キャリパアレイを使用し、欠陥またはギャップなどの偏差があるかどうかを決定して、検出した欠陥/ギャップの数を返します。

注 :
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

エッジ幅欠陥検出ツールは、欠陥またはギャップなどの偏差が、検査対象物またはオブジェクトのエッジ特徴に無いことを確認する場合などに有用です。例えば、溶接の継ぎ目が適切な幅を維持しているかどうかを確認するのに使用します。

ツールを設定するには

ツールのパラメータを調整するには


エッジ幅欠陥検出ツールを設定するには

ツールを追加したら、領域タイプを選択し、エッジ特徴上で領域を設定します。

  1. [領域タイプ] ドロップダウンメニューから、領域のタイプ ([マスク領域] または [ポリラインパス])を選択してください。エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

    注 : マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[エッジ]、[エッジ得点]、[外れ値]、[欠陥]、[ギャップ] などのタブを選択し、パラメータおよび領域を必要に応じて調整して、エッジ候補が正しく検出されていることを確認して下さい。最初にツールを設定する際には、理想的なエッジ特徴を含む画像を使用します。その後、エッジ候補を含む画像を取り込み、欠陥やギャップなどの偏差があるかどうかを決定します。

    注 : [外れ値] タブの [再得点] チェックボックスをON にすると、最適ラインまたは最適円が作成されます (オプション)。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジ幅欠陥検出ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジ幅欠陥検出ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [外れ値] タブ
  • [欠陥] タブ
  • [ギャップ] タブ
  • [幅欠陥] および [ギャップ] テーブルタブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[エッジ] タブ

[エッジ得点] タブ

[外れ値] タブ

[欠陥] タブ

[ギャップ] タブ

[幅欠陥] および [ギャップ] テーブルタブ


[全般] タブ (エッジ幅欠陥検出ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名はエッジ幅_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 領域タイプ

エッジ特徴を検出する際に使用する、領域のタイプを指定します。選択肢は、[マスク領域] (デフォルト) または [ポリラインパス] です。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[エッジ] タブ (エッジ幅欠陥検出ツール)

[エッジ] タブを選択すると、領域内で検出されたすべてのエッジが暗い緑色で表示されます。[キャリパサイズ]、[キャリパ間隔]、[エッジ幅] および [最小コントラスト] パラメータを必要に応じて調整し、使用するエッジを検出することができます。

[すべてのキャリパを表示] チェックボックスを ON にすると、すべてのキャリパが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

閉じた キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

閉じた キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

閉じた エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

閉じた キャリパ数

領域内のキャリパ総数を表示します。

閉じた キャリパインデックス

検出および表示する、キャリパを指定します。

閉じた すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (エッジ幅欠陥検出ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補が、カラーコード化された小さな円で表示されます　(領域は選択し、調整することができます)。パラメータを調整して、使用するエッジ候補を検出してください。

注 : [外れ値] タブの [再得点] チェックボックスをON にすると、最適ラインまたは最適円が作成されます (オプション)。

検出された欠陥およびギャップが表示されるほか、エッジの最小および最大幅も黄色の線で表示されます。

閉じた エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]、[内→外] [外→内]) を指定します。デフォルトは、[左→右] です。

閉じた エッジ0 の遷移

最初に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた エッジ 1 の遷移

2 番目に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた 規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた コントラスト上限

エッジとみなされる、エッジコントラスト遷移の上限を定義します (2～255、デフォルト = 255)。この値よりエッジコントラスト遷移が高いエッジは、同じ最高得点を返します。

閉じた 規則:ペアサイズ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、[ペアサイズ] パラメータで指定した値に最も近いサイズのエッジペアを第一に考慮するかどうかを指定します。デフォルトは、OFF です。

閉じた ペアサイズ

最高得点を与えるエッジペアサイズを指定します (1～1920、デフォルト = 5)。このパラメータを有効にすると、この値より大きいまたは小さいサイズのエッジペアが検出されたとき、この値に近いエッジペアが選択されます。例えば、[ペアサイズ] を10に設定しているとき、8 と 14 のエッジペアが検出されると、14 より 8 のほうが 10 に近いので、8 が選択されます。このパラメータを使用するには、[規則: ペアサイズ] チェックボックスを ON にする必要があります。

閉じた 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


[外れ値] タブ (エッジ幅欠陥検出ツール)

[外れ値] タブを選択すると、領域内で検出されたすべてのエッジ候補、および最適円または最適ラインの結果が表示されます。エッジ候補は、最適ラインまたは最適円作成時に使用可能なエッジを表します。エッジ候補はカラーコード化された小さな円で表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

検出された欠陥およびギャップが表示されるほか、エッジの最小および最大幅も黄色の線で表示されます。

閉じた 再得点

エッジの得点再計算後に、最適ラインの再計算を行うように指定します。デフォルトは、OFF です。

注 : この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。
閉じた 最適ライン

検出されたエッジから作成する、最適ラインのタイプを指定します ([自動調節] (デフォルト)、[最適直線]、[最適円])。

注 : このパラメータを使用するには、[再得点] パラメータを有効にする必要があります。
閉じた 外れ値の除外

[最適距離フィルタ] パラメータで指定されている距離より遠い点を最適ラインから削除するかどうかを指定します。デフォルトは、OFF です。

閉じた 最適距離フィルタ

エッジが元の最適ラインから離れている必要がある距離をピクセルで指定します (1～1920、デフォルト = 2)。この値は、最適合計算で使用します。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。

注 : このパラメータを使用するには、[外れ値の除外] パラメータを ON (有効) にする必要があります。


[欠陥] タブ (エッジ幅欠陥検出ツール)

[欠陥] タブを選択すると、検出したエッジペアの最小幅および最大幅 (黄色の線) と、検出した欠陥またはギャップが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

閉じた 最小幅

検出されたエッジペア間の幅距離をピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より幅距離が短い場合、欠陥とみなされません。

閉じた 最大幅

検出されたエッジペア間の幅距離をピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より幅距離が長い場合、欠陥とみなされません。

閉じた サイズ有効

サイズ欠陥 (エッジ沿いの長さ) を考慮するかどうかを指定します。デフォルトは、ON です。

注 : [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。
閉じた 最小サイズ

最小欠陥サイズをピクセルで指定します (0.001～1920、デフォルト = 10)。最適ラインまたは最適円からの連続偏差がこの値より小さい場合、欠陥とみなされません。

閉じた 最大サイズ

最大欠陥サイズをピクセルで定義します (0.001～1920、デフォルト = 1000)。最適ラインまたは最適円からの連続偏差がこの値より大きい場合、欠陥とみなされません。

閉じた 面積有効

面積欠陥を考慮するかどうかを指定します。デフォルトは、ON です。面積欠陥は、最適ラインまたは最適円沿いの長さ、および欠陥エッジの最適ラインまたは最適円からの欠陥エッジの長さを考慮します。

注 : [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。
閉じた 最小面積

最小面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 10)。この値より面積が小さい場合、欠陥とみなされません。

閉じた 最大面積

最大面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 1000000)。この値より面積が大きい場合、欠陥とみなされません。


[ギャップ] タブ (エッジ幅欠陥検出ツール)

[ギャップ] タブを選択すると、最適円または最適ラインの結果 (ON の場合) と、検出された欠陥またはギャップが表示されます。「ギャップ」は、最適ラインまたは最適円からのエッジ偏差として指定されます。

このタブの選択中に、領域を選択し、調整することもできます。

閉じた ギャップの検出

検出エッジ中のギャップを考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 最小ギャップ

最小ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より小さい場合、ギャップとみなされません。

閉じた 最大ギャップ

最大ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より大きい場合、ギャップとみなされません。

閉じた 終端ギャップを無視

領域の始まりと終わりで検出されたギャップを考慮するかどうかを指定します。デフォルトは、OFF です。

閉じた 結果

検出された欠陥/ギャップの総数を表示します。


[幅欠陥] および [ギャップ] テーブルタブ (エッジ幅欠陥検出ツール)

[幅欠陥] および [ギャップ] テーブルタブは、最初に検出された 10 個の欠陥/ギャップをエッジ上の位置でソートして表示します。

閉じた インデックス

検出された欠陥/ギャップの順番。エッジ上の位置によりソートされます (1～10)。EasyBuilder では 0 から数えます。

閉じた X

欠陥/ギャップの周りを囲む四角形の X 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

閉じた Y

欠陥/ギャップの周りを囲む四角形の Y 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

閉じた 面積

欠陥/ギャップの周りを囲む四角形の面積を返します。

閉じた サイズ

エッジ上の欠陥/ギャップのサイズ (長さ) を返します。

閉じた キャリパ

欠陥/ギャップが及ぶキャリパの範囲を返します。

閉じた キャリブレーション単位/ピクセル

テーブルに表示する結果の単位 (ワールド座標 = キャリブレーション単位、またはピクセル) を指定します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


ビードファインダー欠陥検出ツール

ビードファインダー欠陥検出ツールは、ビードの中心を検出し、ビード幅の検査に使用される領域を作成して、形状に関わらずビード特徴 (エッジペアにより定義されます) を識別します。このツールはエッジ解析キャリパアレイを使用して、エッジ特徴の正確な位置を特定します。ビード特徴を識別したら、ビードをプロットし、ビード幅が許容範囲外にある場合、欠陥またはギャップとして返します。

注 :
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

ビードファインダー欠陥検出ツールは、視野内に不規則に表示される接着ビードなどのビード特徴の幅を識別、検証する場合などに有用です。

ツールを設定するには

ツールのパラメータを調整するには


ビードファインダー欠陥検出ツールを設定するには

ツールを追加したら、領域タイプを選択し、エッジ特徴上で領域を設定します。

  1. [領域タイプ] ドロップダウンメニューから、領域のタイプ ([マスク領域] または [ポリラインパス])を選択してください。エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

    注 : マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[検出ビード]、[エッジ]、[エッジ得点]、[欠陥]、[ギャップ] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際に、エッジ候補が正しく検出され、ポリラインが正しく作成されていることを確認して下さい。最初にツールを設定する際には、理想的なエッジ特徴を含む画像を使用してください。その後、エッジ候補を含む画像を取り込み、欠陥やギャップなどの偏差があるかどうかを決定します。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ビードファインダー欠陥検出ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ビードファインダー欠陥検出ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [検出ビード] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [欠陥] タブ
  • [ギャップ] タブ
  • [統計]、[幅欠陥] および [ギャップ] テーブルタブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[検出ビード] タブ

[エッジ] タブ

[エッジ得点] タブ

[欠陥] タブ

[ギャップ] タブ

[統計]、[幅欠陥] および [ギャップ] テーブルタブ


[全般] タブ (ビードファインダー欠陥検出ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名はビードファインダー_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 領域タイプ

解析中の画像エリア定義に使用される領域のタイプを指定します。選択肢は、[マスク領域] (デフォルト) および [ポリラインパス] です。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[検出ビード] タブ (ビードファインダー欠陥検出ツール)

[検出ビード] タブを選択すると、ビード特徴の位置に関連するグラフィックスが表示されます。表示されるのは、検出されたエッジ (暗い緑色) や、領域内 (選択し、調整することができます) で検出されたエッジ候補 (カラーコード化された小さな円で表示されます)、およびビード位置 (青のポリライン) です。

パラメータを調整して、使用するエッジおよびエッジ候補を検出することができます。エッジ候補は、ビード特徴の輪郭となるポリラインパスを作成するのに使用されます。

閉じた 検出ビードのキャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 8)。キャリパは、検査方向に沿って解析します。

閉じた 検出ビードのキャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

閉じた 検出ビードのエッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 検出ビードの最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

閉じた 検出ビードのエッジ方向

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]、[内→外] [外→内]) を指定します。デフォルトは、[左→右] です。

閉じた 検出ビードエッジ0 の遷移

最初に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた 検出ビードエッジ1 の遷移

2 番目に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた 検出ビード規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 検出ビード規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 検出ビードのコントラスト上限

エッジとみなされる、エッジコントラスト遷移の上限を定義します (2～255、デフォルト = 255)。この値よりエッジコントラスト遷移が高いエッジは、同じ最高得点を返します。

閉じた 検出ビード規則:ペアサイズ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、[ペアサイズ] パラメータで指定した値に最も近いサイズのエッジペアを第一に考慮するかどうかを指定します。デフォルトは、OFF です。

閉じた 検出ビードの得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。

閉じた 検出ビードのキャリパ

領域内のキャリパ総数を表示します。

閉じた 検出ビードのキャリパインデックス

検出および表示する、キャリパを指定します。

閉じた 検出ビードの全キャリパ表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ] タブ (ビードファインダー欠陥検出ツール)

[エッジ] タブを選択すると、ビードパスの位置 (青) 、検出されたすべてのエッジ (緑)、ビードパスの位置から生成されたポリラインパスを定義するキャリパ (水色) が表示されます。水色のキャリパは、[ポリライン幅] パラメータを使用してのみ、調整することができます。[ポリライン幅]、[キャリパサイズ]、[キャリパ間隔]、および [最小コントラスト] パラメータを必要に応じて調整して、使用するエッジを検出することができます。

閉じた ポリライン幅

ポリラインを定義するのに使用する、キャリパの幅を指定します (1～1920、デフォルト = 25)。

閉じた キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

閉じた キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

閉じた エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

閉じた キャリパ数

領域内のキャリパ総数を表示します。

閉じた キャリパインデックス

検出および表示する、キャリパを指定します。

閉じた すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (ビードファインダー欠陥検出ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補 (カラーコード化された小さな円で表示されます) や、検出されたエッジ (暗い緑色)、ビード位置 (青のポリライン) 、ビードの最大幅および最小幅 (黄色の線)が表示されます。同時に、検出された欠陥またはギャップも表示されます。

閉じた エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]、[内→外] [外→内]) を指定します。デフォルトは、[外→内] です。

閉じた エッジ0 の遷移

最初に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた エッジ 1 の遷移

2 番目に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた 規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた コントラスト上限

エッジとみなされる、エッジコントラスト遷移の上限を定義します (2～255、デフォルト = 255)。この値よりエッジコントラスト遷移が高いエッジは、同じ最高得点を返します。

閉じた 規則:ペアサイズ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、[ペアサイズ] パラメータで指定した値に最も近いサイズのエッジペアを第一に考慮するかどうかを指定します。デフォルトは、OFF です。

閉じた ペアサイズ

最高得点を与えるエッジペアサイズを指定します (1～1920、デフォルト = 5)。このパラメータを有効にすると、この値より大きいまたは小さいサイズのエッジペアが検出されたとき、この値に近いエッジペアが選択されます。例えば、[ペアサイズ] を10に設定しているとき、8 と 14 のエッジペアが検出されると、14 より 8 のほうが 10 に近いので、8 が選択されます。このパラメータを使用するには、[規則: ペアサイズ] チェックボックスを ON にする必要があります。

閉じた 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


[欠陥] タブ (ビードファインダー欠陥検出ツール)

[欠陥] タブを選択すると、検査対象物またはオブジェクトに発生しているエラーの識別/分類に関連したグラフィックスが表示されます。ビードの位置は青のポリラインで、ビードの最大幅および最小幅は黄色の線で表示されるほか、検出された欠陥/ギャップも表示されます。

閉じた 最小幅

検出されたエッジペア間の幅距離をピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より幅距離が短い場合、欠陥とみなされません。

閉じた 最大幅

検出されたエッジペア間の幅距離をピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より幅距離が長い場合、欠陥とみなされません。

閉じた サイズ有効

サイズ欠陥 (エッジ沿いの長さ) を考慮するかどうかを指定します。デフォルトは、ON です。

注 : [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。
閉じた 最小サイズ

最小欠陥サイズをピクセルで定義します (0.001～1920、デフォルト = 3)。ポリラインからの連続偏差がこの値より小さい場合、欠陥とみなされません。

閉じた 最大サイズ

最大欠陥サイズをピクセルで定義します (0.001～1920、デフォルト = 1000)。ポリラインからの連続偏差がこの値より大きい場合、欠陥とみなされません。

閉じた 面積有効

面積欠陥を考慮するかどうかを指定します。デフォルトは、ON です。面積欠陥は、ポリライン上の長さ、ポリラインからの欠陥エッジの長さを考慮します。

注 : [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。
閉じた 最小面積

最小面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 10)。この値より面積が小さい場合、欠陥とみなされません。

閉じた 最大面積

最大面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 1000000)。この値より面積が大きい場合、欠陥とみなされません。


[ギャップ] タブ (ビードファインダー欠陥検出ツール)

[ギャップ] タブを選択すると、検査対象物またはオブジェクトに発生しているエラーの識別/分類に関連したグラフィックスが表示されます。ビードの位置は青のポリラインで、ビードの最大幅および最小幅は黄色の線で表示されるほか、検出された欠陥/ギャップも表示されます。

閉じた ギャップの検出

検出エッジ中のギャップを考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 最小ギャップ

最小ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より小さい場合、ギャップとみなされません。

閉じた 最大ギャップ

最大ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より大きい場合、ギャップとみなされません。

閉じた 終端ギャップを無視

領域の始まりと終わりで検出されたギャップを考慮するかどうかを指定します。デフォルトは、OFF です。

閉じた 結果

検出された欠陥/ギャップの総数を表示します。


[統計]、[幅欠陥] および [ギャップ] テーブルタブ (ビードファインダー欠陥検出ツール)

[統計] テーブルタブは、一定時間内のツールのデータを記録します。[幅欠陥] および [ギャップ] テーブルタブは、最初に検出された 10 個の欠陥/ギャップを表示します。

閉じた インデックス

検出された欠陥/ギャップの順番。エッジ上の位置によりソートされます (1～10)。EasyBuilder では 0 から数えます。

閉じた X

欠陥/ギャップの周りを囲む四角形の X 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

閉じた Y

欠陥/ギャップの周りを囲む四角形の Y 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

閉じた 面積

欠陥/ギャップの周りを囲む四角形の面積を返します。

閉じた サイズ

エッジ上の欠陥/ギャップのサイズ (長さ) を返します。

閉じた キャリパ

欠陥/ギャップが及ぶキャリパの範囲を返します。

閉じた キャリブレーション単位/ピクセル

テーブルに表示する結果の単位 (ワールド座標 = キャリブレーション単位、またはピクセル) を指定します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


ビードトラッカー欠陥検出ツール

ビードトラッカー欠陥検出ツールは、ビード特徴 (エッジペアにより定義) の位置、形状および幅を検査します。ユーザが作成したビード特徴のモデルに基づき、エッジ解析キャリパアレイを使用して、エッジ特徴の正確な位置を特定します。ビード特徴モデルを作成すると、ジョブ実行時に、取り込んだ画像中のビード特徴とビードモデルを比較して、ビードが正しい位置あるかどうか、欠陥またはギャップなどの偏差がビードにあるかどうかを決定し、検出された欠陥/ギャップの数を返します。

注 :
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

ビードトラッカー欠陥検出ツールは、溶接ビードなどのビード特徴が同じ位置に存在し、ビードの形状や幅に偏差がないかを確認する場合などに有用です。

ツールを設定するには

ツールのパラメータを調整するには


ビードトラッカー欠陥検出ツールを設定するには

ツールを追加したら、領域タイプを選択し、エッジ特徴上で領域を設定します。

  1. [領域タイプ] ドロップダウンメニューから、領域のタイプ ([マスク領域] または [ポリラインパス])を選択してください。エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。最初にツールを設定する際には、理想的なエッジ特徴を含む画像を使用してください。その後、エッジ候補を含む画像を取り込み、欠陥やギャップなどの偏差があるかどうかを決定します。

    注 : マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[登録ビード]、[エッジ]、[エッジ得点]、[欠陥]、[ギャップ]、[ポジション] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際に、エッジ候補が正しく検出され、ポリラインが正しく作成されいることを確認して下さい。
  4. 領域およびパラメータを調整したら、[登録ビード] タブを開き、[登録] ボタンを押して、ビードエッジモデルを作成します。その後、画像を取り込み、登録ビードエッジモデルと比較します。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ビードトラッカー欠陥検出ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ビードトラッカー欠陥検出ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [登録ビード] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [欠陥] タブ
  • [ギャップ] タブ
  • [ポジション] タブ
  • [統計]、[幅欠陥]、[ギャップ] および [位置欠陥] テーブルタブ
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[登録ビード] タブ

[エッジ] タブ

[エッジ得点] タブ

[欠陥] タブ

[ポジション] タブ

[統計]、[幅欠陥]、[ギャップ] および [位置欠陥] テーブルタブ

[ギャップ] タブ


[全般] タブ (ビードトラッカー欠陥検出ツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名はビードトラッカー_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

閉じた ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 領域タイプ

解析中の画像エリア定義に使用される領域のタイプを指定します。選択肢は、[マスク領域] (デフォルト) および [ポリラインパス] です。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[登録ビード] タブ (ビードファインダー欠陥検出ツール)

[登録ビード] タブを選択すると、ビード特徴の位置に関連するグラフィックスが表示されます。表示されるのは、領域内で検出されたすべてのエッジ候補 (カラーコード化された小さな円で表示されます)および、ビード位置 (青のポリライン)です。領域は、調整することができます。

閉じた [登録] ボタン

ビードエッジモデルを定義します。[登録] ボタンは、ビードエッジモデルの設定に使用します。ツールのパラメータおよび領域を設定したら、[登録] ボタンを押して、ビードエッジモデルの関連特徴を強調させます。ビードエッジモデルを登録すると、取り込んだ画像中のビード特徴と登録したビードエッジモデルを比較して、欠陥またはギャップなどの偏差があるかどうかを決定します。

注 : ビードエッジモデルを登録するまで、ツール結果は FAIL となります。
閉じた 登録ビードのキャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 8)。キャリパは、検査方向に沿って解析します。

閉じた 登録ビードのキャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

閉じた 登録ビードのエッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 登録ビードの最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

閉じた 登録ビードのエッジ方向

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]、[内→外] [外→内]) を指定します。デフォルトは、[左→右] です。

閉じた 登録ビードのエッジ0 遷移

最初に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた 登録ビードのエッジ1 遷移

2 番目に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた 登録ビード規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 登録ビード規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 登録ビードのコントラスト上限

エッジとみなされる、エッジコントラスト遷移の上限を定義します (2～255、デフォルト = 255)。この値よりエッジコントラスト遷移が高いエッジは、同じ最高得点を返します。

閉じた 登録ビード規則: ペアサイズ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、[ペアサイズ] パラメータで指定した値に最も近いサイズのエッジペアを第一に考慮するかどうかを指定します。デフォルトは、OFF です。

閉じた 登録ビードの得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。

閉じた 登録ビードのキャリパ

領域内のキャリパ総数を表示します。

閉じた 登録ビードのキャリパインデックス

検出および表示する、キャリパを指定します。

閉じた 登録ビードの全キャリパ表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ] タブ (ビードトラッカー欠陥検出ツール)

[エッジ] タブを選択すると、ビードパスの位置 (青) 、検出されたすべてのエッジ (緑)、ビードパスの位置から生成されたポリラインパスを定義するキャリパ (水色) が表示されます。水色のキャリパは、[ポリライン幅] パラメータを使用してのみ、調整することができます。[ポリライン幅]、[キャリパサイズ]、[キャリパ間隔]、および [最小コントラスト] パラメータを必要に応じて調整して、使用するエッジを検出することができます。

閉じた ポリライン幅

ポリライン定義に使用するキャリパの幅を指定します (1～1920、デフォルト = 25)。

閉じた キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

閉じた キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

閉じた エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

閉じた 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

閉じた キャリパ数

領域内のキャリパ総数を表示します。

閉じた キャリパインデックス

検出および表示する、キャリパを指定します。

閉じた すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (ビードトラッカー欠陥検出ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補 (カラーコード化された小さな円で表示されます) や、検出されたエッジ (暗い緑色)、ビード位置 (青のポリライン) 、ビードの最大幅および最小幅 (黄色の線)が表示されます。同時に、検出された欠陥またはギャップも表示されます。

閉じた エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]、[内→外] [外→内]) を指定します。デフォルトは、[外→内] です。

閉じた エッジ0 の遷移

最初に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた エッジ 1 の遷移

2 番目に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

閉じた 規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

閉じた コントラスト上限

エッジとみなされる、エッジコントラスト遷移の上限を定義します (2～255、デフォルト = 255)。この値よりエッジコントラスト遷移が高いエッジは、同じ最高得点を返します。

閉じた 規則:ペアサイズ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、[ペアサイズ] パラメータで指定した値に最も近いサイズのエッジペアを第一に考慮するかどうかを指定します。デフォルトは、OFF です。

閉じた ペアサイズ

最高得点を与えるエッジペアサイズを指定します (1～1920、デフォルト = 5)。このパラメータを有効にすると、この値より大きいまたは小さいサイズのエッジペアが検出されたとき、この値に近いエッジペアが選択されます。例えば、[ペアサイズ] を10に設定しているとき、8 と 14 のエッジペアが検出されると、14 より 8 のほうが 10 に近いので、8 が選択されます。このパラメータを使用するには、[規則: ペアサイズ] チェックボックスを ON にする必要があります。

閉じた 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


[欠陥] タブ (ビードトラッカー欠陥検出ツール)

[欠陥] タブを選択すると、検査対象物またはオブジェクトに発生しているエラーの識別/分類に関連したグラフィックスが表示されます。ビードの位置は青のポリラインで、ビードの最大幅および最小幅は黄色の線で表示されるほか、検出された欠陥/ギャップも表示されます。

閉じた 最小幅

検出されたエッジペア間の幅距離をピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より幅距離が短い場合、欠陥とみなされません。

閉じた 最大幅

検出されたエッジペア間の幅距離をピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より幅距離が長い場合、欠陥とみなされません。

閉じた サイズ有効

サイズ欠陥 (エッジ沿いの長さ) を考慮するかどうかを指定します。デフォルトは、ON です。

注 : [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。
閉じた 最小サイズ

最小欠陥サイズをピクセルで指定します (0.001～1920、デフォルト = 10)。ポリラインからの連続偏差がこの値より小さい場合、欠陥とみなされません。

閉じた 最大サイズ

最大欠陥サイズをピクセルで定義します (0.001～1920、デフォルト = 1000)。ポリラインからの連続偏差がこの値より大きい場合、欠陥とみなされません。

閉じた 面積有効

面積欠陥を考慮するかどうかを指定します。デフォルトは、ON です。面積欠陥は、ポリライン上の長さ、ポリラインからの欠陥エッジの長さを考慮します。

注 : [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。
閉じた 最小面積

最小面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 10)。この値より面積が小さい場合、欠陥とみなされません。

閉じた 最大面積

最大面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 1000000)。この値より面積が大きい場合、欠陥とみなされません。


[ポジション] タブ (ビードトラッカー欠陥検出ツール)

[ポジション] タブを選択すると、検査対象物またはオブジェクトに発生しているエラーの識別/分類に関連したグラフィックスが表示されます。最後に登録したビードの位置は青のポリラインで、ビードの最大幅および最小幅は黄色の線で表示されるほか、検出された欠陥/ギャップも表示されます。

閉じた 位置欠陥有効

位置欠陥を考慮するかどうかを指定します。デフォルトは ON です。

閉じた 位置欠陥の最小距離

エラーとみなされない、ビードエッジモデル中心からのエッジ候補の最小距離をピクセルで指定します (0.001～1920、デフォルト = 3)。

閉じた 位置欠陥サイズ有効

位置エラー定義に、サイズ測定基準も使用するかどうかを指定します。デフォルトは、ON です。サイズエラーは、エッジの長さ上に検出されます。

注 : [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。
閉じた 位置欠陥の最小サイズ

最小欠陥サイズをピクセルで指定します (0.001～1920、デフォルト = 3)。ポリラインからの連続偏差がこの値より小さい場合、欠陥とみなされません。

閉じた 位置欠陥の最大サイズ

最大欠陥サイズをピクセルで指定します (0.001～1920、デフォルト = 1000)。ポリラインからの連続偏差がこの値より大きい場合、欠陥とみなされません。

閉じた 位置欠陥面積有効

面積欠陥を考慮するかどうかを指定します。デフォルトは、ON です。面積欠陥は、ポリライン上の長さ、ポリラインからの欠陥エッジの長さを考慮します。

注 : [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。
閉じた 位置欠陥の最小面積

最小面積欠陥をピクセルで指定します (0.001～1000000、デフォルト = 10)。この値より面積が小さい場合、欠陥とみなされません。

閉じた 位置欠陥の最大面積

最大面積欠陥をピクセルで指定します (0.001～1000000、デフォルト = 1000000)。この値より面積が大きい場合、欠陥とみなされません。

閉じた 結果

検出された欠陥、ギャップ、位置エラーの総数を表示します。


[統計]、[幅欠陥] [ギャップ] および [位置欠陥] テーブルタブ (ビードトラッカー欠陥検出ツール)

[統計] テーブルタブは、一定時間内のツールのデータを記録します。 [幅欠陥] および [ギャップ] および [位置欠陥] テーブルタブは、最初に検出された 10 個の欠陥/ギャップを表示します。

閉じた インデックス

検出された欠陥/ギャップの順番。エッジ上の位置によりソートされます (1～10)。EasyBuilder では 0 から数えます。

閉じた X

欠陥/ギャップの周りを囲む四角形の X 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

閉じた Y

欠陥/ギャップの周りを囲む四角形の Y 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

閉じた 面積

欠陥/ギャップの周りを囲む四角形の面積を返します。

閉じた サイズ

エッジ上の欠陥/ギャップのサイズ (長さ) を返します。

閉じた キャリパ

欠陥/ギャップが及ぶキャリパの範囲を返します。

閉じた キャリブレーション単位/ピクセル

テーブルに表示する結果の単位 (ワールド座標 = キャリブレーション単位、またはピクセル) を指定します。

注 : 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


[ギャップ] タブ (ビードトラッカー欠陥検出ツール)

[ギャップ] タブを選択すると、検査対象物またはオブジェクトに発生しているエラーの識別/分類に関連したグラフィックスが表示されます。ビードの位置は青のポリラインで、ビードの最大幅および最小幅は黄色の線で表示されるほか、検出された欠陥/ギャップも表示されます。

閉じた ギャップの検出

検出エッジ中のギャップを考慮するかどうかを指定します。デフォルトは、ON です。

閉じた 最小ギャップ

最小ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より小さい場合、ギャップとみなされません。

閉じた 最大ギャップ

最大ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より大きい場合、ギャップとみなされません。

閉じた 終端ギャップを無視

領域の始まりと終わりで検出されたギャップを考慮するかどうかを指定します。デフォルトは、OFF です。

閉じた 結果

検出された欠陥/ギャップの総数を表示します。


ロボットキャリブレーションツール

このツールは、ビジョンツールをロボットキャリブレーション関数にリンクし、ピクセル座標をロボットポーズに変換して、EasyBuilder にキャリブレーションファイルを自動的に作成します。

ツールを設定するには

ツールのパラメータを調整するには


ロボットキャリブレーションツールを設定するには

ヒント : キャリブレーション作成後、ジョブファイルを保存することを推奨します。その後、キャリブレーションを実行するには、キャリブレーションジョブをロードし、画像を取り込んでから、更新したキャリブレーションファイルを参照するジョブに自動エクスポートします。

ツールを追加したら、キャリブレーションの作成に使用される入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールにジョブを追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴 (点、フィクスチャ原点、円特徴の中心) を水色のスマートフィーチャーとして提示します。同時に他のツールで定義済みの特徴を緑色で提示します。同時に、円有無判定ツールを挿入し、未設定の円特徴を定義します。

  2. 水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。

  3. 目的の特徴を選択した後、[OK] ボタンを押してください。 (ツールの追加を取りやめるには、[キャンセル] ボタンを押してください。)

  4. ジョブファイルに保存します。
  5. ツールの初期設定を済ませたら、必要に応じてパラメータを調整してください。
  6. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


ロボットキャリブレーションツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

ロボットキャリブレーションツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ

[全般] タブ

[設定] タブ


[全般] タブ (ロボットキャリブレーションツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([画像の設定]、[入力/出力]、および [通信]) で参照されます。デフォルトのツール名はキャリブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。ジョブには、1 つのロボットツールのみ追加することができます。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (ロボットキャリブレーションツール)

閉じた ファイル名

ロボットキャリブレーションのファイル名を定義します。デフォルトは、Default です。

閉じた フルネーム

ロボットキャリブレーションファイルのフルネームを、.CXD 拡張子付きで表示します。

閉じた 日付/時間の追記

現在の日付及び時間をファイル名に含めるには、[日付/時間の追記] チェックボックスを ON にします。


N 点キャリブレーションツール

N 点キャリブレーションツールは、2～16 の入力特徴と、そのワールド座標を使用して、キャリブレーションファイルを作成します。キャリブレーションファイルをエクスポートして、[画像の設定] ステップでキャリブレーションタイプとして選択し、他のジョブに使用することができます。

ヒント : キャリブレーション作成後、ジョブファイルを保存することを推奨します。その後、キャリブレーションを実行するには、キャリブレーションジョブをロードし、画像を取り込んでから、更新したキャリブレーションファイルを参照するジョブに自動エクスポートします。

このツールは、検査対象物またはオブジェクトの実際の寸法がCAD 図面などから分かっており、その値をキャリブレーションとして適用したい場合に有用です。このタイプのアプリケーションでは、In-Sight ビジョンシステムが検査対象物またはオブジェクトの画像を取り込み、実単位を画像のピクセル座標に関連付けます。ビジョンシステムのローカルファイルシステムに保存することにより、他のジョブにキャリブレーション結果を適用することができます。

注 :
  • キャリブレーション点を定義するのに、他の位置決め/検査ツールを入力として使用します。必要な位置決め/検査ツールを設定してから、このツールを追加してください。
  • N 点またはシーケンス N 点キャリブレーションツールを使用している場合、キャリブレーション時およびジョブ実行時の、物理的・光学的な設定 (レンズ、ビジョンシステム、およびビジョンシステムと画像を取り込むシーン間の物理的関係) を同一にしてください。設定が変更されてしまうと、システムをキャリブレーションし直す必要があります。よって、キャリブレーション時とジョブ実行時に、同一のビジョンシステムおよびレンズを使用することを推奨します。ビジョンシステムおよびレンズも、オリジナル設定およびキャリブレーション設定を保持するようにしてください。例えば、 (解像度を変更することによって) 画像取り込みフォーマットを変更したり、ビジョンシステムを動かしたりすると、ピクセルをワールド座標にマッピングした 2D 変換計算が無効となってしまいます。

ツールを設定するには

ツールのパラメータを調整するには


N 点キャリブレーションツールを設定するには

ヒント : キャリブレーション作成後、ジョブファイルを保存することを推奨します。その後、キャリブレーションを実行するには、キャリブレーションジョブをロードし、画像を取り込んでから、更新したキャリブレーションファイルを参照するジョブに自動エクスポートします。

ツールを追加したら、キャリブレーションの作成に使用される入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールにジョブを追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴 (点、フィクスチャ原点、円特徴の中心) を水色のスマートフィーチャーとして提示します。同時に他のツールで定義済みの特徴を緑色で提示します。同時に、円有無判定ツールを挿入し、未設定の円特徴を定義します。

  2. 水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。

  3. 次に、キャリブレーションの定義に使用する特徴をすべて選択してください。最小 2 から最大 16 までの入力特徴を選択することができます。

  4. 目的の特徴をすべて選択した後、[OK] ボタンを押してください。(ツールの追加を取りやめるには、[キャンセル] ボタンを押してください。)

  5. ツールを追加し、入力変数に使用する値を定義したら、各入力特徴の実単位値を定義します。点テーブルから点を選択し、その実単位値を [ワールド X] および [ワールド Y] フィールドに手動または増減コントロールを使用して入力します。
  6. ジョブファイルを保存します。
  7. [設定] タブの [エクスポート] ボタンを押すと、In-Sight ビジョンシステムのローカルファイルシステムのキャリブレーションファイルがセットされます。同時に、[画像の設定] ステップ、キャリブレーションタイプの [インポート] オプションが選択され、キャリブレーションが有効になります。
  8. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  9. 最後に、必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


N 点キャリブレーションツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

N 点キャリブレーションツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • 点テーブル
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

点テーブル


[全般] タブ (N 点キャリブレーションツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([画像の設定]、[入力/出力] および [通信]) で参照されます。デフォルトのツール名はキャリブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (N 点キャリブレーションツール)

閉じた ファイル名

キャリブレーションファイル名を定義します。デフォルトのファイル名は、[デフォルト] です。

閉じた フルネーム

[画像の設定] ステップで、[キャリブレーションタイプ] を [インポート] に設定した場合に、キャリブレーションファイルのフルネームが表示されます。[画像の設定] ステップで表示される前に、ファイルをエクスポートしておく必要があります。

閉じた エクスポート

キャリブレーションファイルを In-Sight ビジョンシステムのローカルファイルシステムにエクスポートします。

閉じた 自動エクスポート

ジョブファイルがロードされたとき、または画像が取り込まれたときに、自動的にキャリブレーションファイルをエクスポートするかどうかを定義します。 有効 (ON) にした場合、ツールは自動的にキャリブレーションファイルをエクスポートします (デフォルトは、無効/OFF)。

注 : [自動エクスポート] チェックボックスを ON にした場合、キャリブレーションデータを含むジョブファイルを保存してから、エクスポートする必要があります。 ジョブファイルの保存後、キャリブレーションファイルが In-Sight ファイルペインに表示されない場合、ほかの In-Sight ビジョンシステムまたはエミュレータをクリックします。 その後、使用しているビジョンシステムを選択し直すと、ジョブファイルは表示されます。


テーブル (N 点キャリブレーションツール)

ピクセルおよびワールド座標点テーブルを使用して、キャリブレーション用の実単位を表示、定義します。

閉じた 点

検出した点の読み取り専用インデックスリスト (1～16) を表示します (EasyBuilder では 0 から数えます)。

閉じた ピクセル行

点のピクセル行 (X) ロケーションを表示します。

閉じた ピクセル列

点の画像列 (X) 座標を表示します。

閉じた ワールド X

点の X 座標値 (実単位) を表示します。

閉じた ワールド Y

点の Y 座標値 (実単位) を表示します。

閉じた ワールド X

選択した点の X 座標値 (実単位) を定義します。

閉じた ワールド Y

選択した点の Y 座標値 (実単位) を定義します。

閉じた [点の選択]

点として使用する入力特徴の選択を可能にします。このボタンを押すと、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴 (点、フィクスチャ原点、円特徴の中心) を水色のスマートフィーチャーとして提示します。同時に他のツールで定義済みの特徴を緑色で提示します。水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。


シーケンス N 点キャリブレーションツール

シーケンス N 点キャリブレーションツールは、1 個の入力特徴とそのワールド座標を使用し、連続する画像取り込みに対して、キャリブレーションファイルを作成します。キャリブレーションファイルをエクスポートして、[画像の設定] ステップでキャリブレーションタイプとして選択し、他のジョブに使用することができます。

ヒント : キャリブレーション作成後、ジョブファイルを保存することを推奨します。その後、キャリブレーションを実行するには、キャリブレーションジョブをロードし、画像を取り込んでから、更新したキャリブレーションファイルを参照するジョブに自動エクスポートします。

このツールは、In-Sight ビジョンシステムとロボットの座標システムをキャリブレーションする場合に有用です。このタイプのアプリケーションでは、ロボットコントローラが、画像取り込みごとに 1 つづつ、異なる複数のロケーションの検査対象物をビジョンシステムに提示します。画像取り込むごとに、点がキャリブレーションテーブルに追加されていきます。ロボットがロケーションすべてを提示し、点がすべて保存されると、キャリブレーションファイルをエクスポートし、ジョブファイルを保存することができます。

注 :
  • キャリブレーション点を定義するのに、他の位置決め/検査ツールを入力として使用します。必要な位置決め/検査ツールを設定してから、このツールを追加してください。
  • N 点またはシーケンス N 点キャリブレーションツールを使用している場合、キャリブレーション時およびジョブ実行時の、物理的・光学的な設定 (レンズ、ビジョンシステム、およびビジョンシステムと画像を取り込むシーン間の物理的関係) を同一にしてください。設定が変更されてしまうと、システムをキャリブレーションし直す必要があります。よって、キャリブレーション時とジョブ実行時に、同一のビジョンシステムおよびレンズを使用することを推奨します。ビジョンシステムおよびレンズも、オリジナル設定およびキャリブレーション設定を保持するようにしてください。例えば、 (解像度を変更することによって) 画像取り込みフォーマットを変更したり、ビジョンシステムを動かしたりすると、ピクセルをワールド座標にマッピングした 2D 変換計算が無効となってしまいます。

ツールを設定するには

ツールのパラメータを調整するには


シーケンス N 点キャリブレーションツールを設定するには

ヒント : キャリブレーション作成後、ジョブファイルを保存することを推奨します。その後、キャリブレーションを実行するには、キャリブレーションジョブをロードし、画像を取り込んでから、更新したキャリブレーションファイルを参照するジョブに自動エクスポートします。

ツールを追加したら、キャリブレーションの作成に使用される入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールにジョブを追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴 (点、フィクスチャ原点、円特徴の中心) を水色のスマートフィーチャーとして提示します。同時に他のツールで定義済みの特徴を緑色で提示します。同時に、円有無判定ツールを挿入し、未設定の円特徴を定義します。
  2. 水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。
  3. 目的の特徴を選択した後、[OK] ボタンを押してください。(ツールの追加を取りやめるには、[キャンセル] ボタンを押してください。)
  4. [設定] タブの [点の数] パラメータを定義して、キャリブレーションを定義する点/画像取り込みの数を指定します
  5. ロボットコントローラを移動して、次のロケーションで点の画像を取得します。このプロセスを繰り返して、すべての点を取り込みます。
  6. すべての点を追加したら、点の実単位値を定義します。点テーブルから点を選択し、その実単位値を [ワールド X] および [ワールド Y] フィールドに手動または増減コントロールを使用して入力します。
  7. [設定] タブの [エクスポート] ボタンを押すと、in-Sight ビジョンシステムのローカルファイルシステムのキャリブレーションファイルがセットされます。 同時に、[画像の設定] ステップ、キャリブレーションタイプの [インポート] オプションが選択され、キャリブレーションが有効になります。
  8. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  9. 最後に、必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


シーケンス N 点キャリブレーションツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

シーケンス N 点キャリブレーションツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • 点テーブル
ヒント : ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。

[全般] タブ

[設定] タブ

点テーブル


[全般] タブ (シーケンス N 点キャリブレーションツール)

閉じた ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はキャリブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

閉じた ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

閉じた 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

閉じた 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

閉じた 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (シーケンス N 点キャリブレーションツール)

閉じた 点の数

取り込む点の数を定義します (2～16、デフォルトは 12)。

閉じた リセット

取り込みカウントを 0 にリセットします。

閉じた オンラインリセット

In-Sight ビジョンシステムをオンラインに切り替えたときに、取り込みカウントをリセットするかどうかを定義します。デフォルトは、無効 (OFF) です。

閉じた ジョブロードのリセット

ジョブファイルがロードされたときに、取り込みカウントをリセットするかどうかを定義します。デフォルトは有効 (ON) です。

閉じた ファイル名

キャリブレーションファイル名を定義します。デフォルトのファイル名は、[デフォルト] です。

閉じた フルネーム

[画像の設定] ステップで、[キャリブレーションタイプ] を [インポート] に設定した場合に、キャリブレーションファイルのフルネームが表示されます。[画像の設定] ステップで表示される前に、ファイルをエクスポートしておく必要があります。

閉じた エクスポート

キャリブレーションファイルを In-Sight ビジョンシステムのローカルファイルシステムにエクスポートします。

閉じた 自動エクスポート

ジョブファイルがロードされたとき、または画像が取り込まれたときに、自動的にキャリブレーションファイルをエクスポートするかどうかを定義します。 有効 (ON) にした場合、ツールは自動的にキャリブレーションファイルをエクスポートします (デフォルトは、無効/OFF)。

注 : [自動エクスポート] チェックボックスを ON にした場合、キャリブレーションデータを含むジョブファイルを保存してから、エクスポートする必要があります。 ジョブファイルの保存後、キャリブレーションファイルが In-Sight ファイルペインに表示されない場合、ほかの In-Sight ビジョンシステムまたはエミュレータをクリックします。 その後、使用しているビジョンシステムを選択し直すと、ジョブファイルは表示されます。
閉じた 結果

ツールの PASS/FAIL ステータスを表示します。


テーブル (シーケンス N 点キャリブレーションツール)

ピクセルおよびワールド座標点テーブルを使用して、キャリブレーション用の実単位を表示、定義します。

閉じた 点

検出した点の読み取り専用インデックスリスト (1～16) を表示します (EasyBuilder では 0 から数えます)。

閉じた ピクセル行

点のピクセル行 (X) ロケーションを表示します。

閉じた ピクセル列

点の画像列 (X) 座標を表示します。

閉じた ワールド X

点の X 座標値 (実単位) を表示します。

閉じた ワールド Y

点の Y 座標値 (実単位) を表示します。

閉じた ワールド X

選択した点の X 座標値 (実単位) を定義します。

閉じた ワールド Y

選択した点の Y 座標値 (実単位) を定義します。

閉じた [点の選択]

点として使用する入力特徴の選択を可能にします。このボタンを押すと、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴 (点、フィクスチャ原点、円特徴の中心) を水色のスマートフィーチャーとして提示します。同時に他のツールで定義済みの特徴を緑色で提示します。水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。


入力/出力

[入力/出力] ステップは、サポートされている In-Sight ビジョンシステムおよび I/O モジュールのディスクリート入出力ライン設定を定義します。 ラインの名前をカスタマイズしたり、信号タイプを設定したり、信号のエッジ遷移や強制入出力の設定をして、アプリケーションのテストを行うことができます。

注 :
  • このアプリケーションステップは、エミュレータ使用時に無効となります。
  • ディスクリート入出力ラインの設定前に、使用する出力デバイスが PNP (ソース) または NPN (シンク) かに留意し、In-Sight センサまたはモジュールに正しく接続されていることを確認してください。 詳細については、In-Sight センサまたは I/O モジュールの取扱説明書をご参照ください。

入出力ラインを設定するには

入力: ジョブファイルをロードするには

位置決めツールおよび検査ツールの ON/OFF を切り替えるには

画像取り込みをトリガするには

入力: 入力ラインを介してモデルパターンを登録するには

画像取り込みミスを送信するには

出力: 画像取り込み時に照明を同期させるには

位置決めツールまたは検査ツールの結果を出力ラインに設定するには


入出力ラインを設定するには

  1. [I/O の種類] ボタンをクリックして、[I/O モジュールの設定] ダイアログを開きます (オプション)。 I/O モジュールを設定したら [OK] ボタンを押し、[I/O モジュールの設定] ダイアログを閉じます。ビジョンシステムと I/O モジュールが接続されると、リストの I/O モジュール名の隣に「 (接続済み) 」のメッセージが表示されます。I/O モジュールに接続後、ラインをカスタマイズすることができます。
  2. 設定する入力または出力ラインを選択してください。 利用できる入力または出力ラインの数は、In-Sight のモデルと I/O モジュールの接続状況によって異なります。 詳細については、このトピックをご参照ください。
  3. In-Sight 7000 Gen2 シリーズおよび 9912 のみ: ラインが双方向 I/O をサポートする場合、[方向] ドロップダウンから [入力] または [出力] を選択してください。
  4. [名前] フィールドに新しい名前を入力して、入力ライン名をカスタマイズすることができます。 名前は 15 バイトまで入力可能です。ライン名は表示のためだけに用意されており、出力ラインの機能を変更したり、参照したりすることはできません。

  5. 次に、選択した入力ラインの [信号タイプ] を定義します。 次のいずれかの方法で、各ラインを設定することができます。

    入力信号タイプ 説明
    ユーザ用

    汎用入力ラインです。位置決めツールおよび検査ツールを ON/OFF にします。
    リセットカウンタ

    EasyBuilder カウンタ (Job.Fail_Count、Job.Inspection_Count、Job.Pass_Count、<Tool>.Error_Count、<Tool>.Fail_Count および <Tool>.Pass_Count) を 0 にリセットします。

    注 :
    • この信号タイプは、ビジョンシステムがオンライン時のみに使用できます。
    • リセットカウンタに設定できるのは、1 つの入力のみです。
    • 入力ラインを [リセットカウンタ] に設定した後にジョブを新規作成すると、新しいジョブは自動的に入力ラインを [イベントトリガ] に戻してしまいます (In-Sight 2000 シリーズセンサでは空白)。

    イベントトリガ

    スプレッドシートビューで作成されたロジックを使用して、イベントをトリガします。 スプレッドシートを更新するには、このディスクリート入力ライン番号にトリガパラメータを設定したイベント構造体がスプレッドシートに含まれる必要があります。

    注 :
    • この信号タイプは、ビジョンシステムがオンライン時のみに使用できます。
    • 入力ラインを介してモデルパターンを登録する場合以外、このオプションを使用するには、スプレッドシートビューへのアクセスが必要です。

    ジョブ ID 番号

    ジョブ ID 番号を構成する 1 ビットです。別のラインに割り当てた [ジョブを開く] の入力ラインが ON になったときにジョブ ID 番号が読み込まれます。

    注 :
    • ジョブ ID 番号の機能を使用する場合は、ジョブファイル名の先頭に 0 ～ 127 の接頭辞を付けておく必要があります。
    • ジョブ ID 番号の最小値は、I/O モジュール上のディスクリート入力ラインの最小値に対応しています。

    オンライン/オフライン

    In-Sight ビジョンシステムをオンラインまたはオフラインにします。(0 = オフライン、1 = オンライン)この入力タイプを、同時に複数の入力ラインに割り当てることはできません。

    注 : In-Sight Explorer の手動操作で In-Sight ビジョンシステムをオフラインにしているとき、あるいはネイティブモードコマンド SO0 で In-Sight ビジョンシステムをオフラインにしているときは、この信号タイプに設定したラインを ON にしてもオンラインモードになりません。

    画像取り込みトリガ
    (In-Sight 2000 シリーズセンサおよび CIO-1400 ではサポートされていません)

    In-Sight ビジョンシステムの画像取り込みをトリガします。 この入力タイプを、同時に複数の入力ラインに割り当てることはできません。

    注 :
    • [画像取り込みの設定] グループボックスの [トリガ] パラメータを [外部] にして、[画像取り込みトリガ] 入力を使用します。画像取り込みトリガを使用するには、信号ラインは In-Sight ビジョンシステムの入力に物理的に接続する必要があります。
    • ビジョンシステムの内蔵画像取り込みトリガ入力 ([トリガ] を [カメラ] に設定) に対し、汎用入力ラインを画像取り込みトリガ ([トリガ] を [外部] に設定) として設定することにより、より高速にトリガを実行することができます。
    • [トリガ] パラメータを [外部] に設定したときに画像取り込みに失敗した場合、[エラー: 画像取り込みミス] 出力は、ビジョンシステムから送信されません。[エラー: 画像取り込みミス] 信号は、[トリガ] パラメータが [カメラ] に設定されている場合のみサポートされています。

    ジョブを開く

    入力ラインの状態が ON になると、すべてのジョブ ID 番号を読み取り、指定されたジョブをロードします。この入力タイプを、同時に複数の入力ラインに割り当てることはできません。

    注 : ビジョンシステムはオフラインにてください。

    ジョブ変更 (パルス)

    (I/O 直接接続の In-Sight 2000 シリーズセンサでのみサポート)

    異なるパルス幅の入力パルスを検出することにより、ジョブ変更を開始します。 このパルスは外部デバイス (PLC など) によって生成され、In-Sight 2000 センサに送信されます。 まず、外部デバイスから開始パルスを生成します。 次に、外部デバイスから、パルス間にギャップのあるカウントパルスを発行します。 最後に、外部デバイスから停止パルスを発行します。

    パルスの種類 | パルス幅
    開始パルス | 20ms (±2ms)
    カウントパルス | 10ms (±1ms)
    パルスギャップ | 10ms (± 1ms)
    停止パルス | 20ms (±2ms)

    すべてのパルスおよびパルスギャップが指定のパルス長にマッチすると、ジョブ変更リクエストに成功し、ジョブがセンサにロードされます。 これらの条件に 1 つでも満たない場合 (パルスまたはパルスギャップのタイミングが正しくない場合)、ジョブ変更リクエストに失敗し、ジョブ変更は起こりません。

    注 :
    • この信号タイプは、ビジョンシステムがオンライン時のみに使用できます。
    • [ジョブ変更 (パルス)] 信号タイプ機能を使用するには、ジョブ名が 0～31 の数字で始まるジョブが (例: 1PinInspection.job) 1 つ以上、センサに保存されている必要があります。 カウントパルスの数は、ロードするジョブの接頭辞と一致する必要があります。
    • SetSystemConfig("PulseJobChangeTiming") ネイティブモードコマンドを使用して、開始パルス、カウントパルス、パルスギャップおよび停止パルスの幅を設定することができます。
    • オプションとして、ディスクリート出力ラインを [ジョブを開く - 完了] または [エラー: ジョブを開く] タイプに設定し、出力をパルスすることによって、ジョブ変更リクエストの成功または失敗を報告することができます。

    シリアル受信
    (直接接続)

    シリアル受信ラインとして設定します。

    注 :
    • この信号タイプは、[直接接続 I/O] 選択時に、入力ライン 1 でのみ使用可能です。
    • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。
    • In-Sight 70xx - 74xx シリーズのビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように構成されている場合、ブレークアウトケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効です。 I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。

  6. 選択された入力ラインの [エッジタイプ] を設定します。これは、エッジの遷移に対する入力ラインの状態を制御します。

    • [立ち上がりエッジ]: パルスの立ち上がりエッジで入力ラインの状態が変わります。
    • [立ち下がりエッジ]: パルスの立ち下がりエッジで入力ラインの状態が変わります。
    • [両方のエッジ]: パルスの立ち上がりエッジおよび立ち下がりエッジの両方で入力ラインの状態が変わります。 このオプションは [イベントトリガ] タイプでのみ利用できます。

  7. 次に、選択した出力ラインの [信号タイプ] を定義します。 次のいずれかの方法で、各ラインを設定することができます。

    出力信号タイプ | 説明
    ジョブの結果 (デフォルト) | 位置決めツールまたは検査ツールの結果によって、この出力ラインの状態を制御するようにします。 パルスまたはレベル信号です。
    ハイ (High) | 出力を HIGH (1) にします。
    ロー (Low) | 出力を LOW (0) にします。
    画像取り込み開始

    ビジョンシステムが画像取り込みを開始したことを示す信号です。 常にパルスとなります。

    注 : In-Sight Micro 8405 ビジョンシステムでは、最初のピクセル行が露光したときに、画像取り込み開始信号がパルスされます。詳細については、ローリングシャッターの操作をご参照ください。
    画像取り込み終了

    ビジョンシステムの画像取り込み終了を示す信号です。 常にパルスとなります。

    注 : In-Sight Micro 8405 ビジョンシステムでは、画像読み出しがすべて完了したときに、画像取り込み終了信号がパルスされます。詳細については、ローリングシャッターの操作をご参照ください。
    ジョブ完了 | EasyBuilder の更新を完了するたびに示す信号です。 常にパルスとなります。
    システムビジー | ビジョンシステムがジョブを実行しているとき、またはユーザ入力に応答しているときは HIGH になります。ビジョンシステムがアイドルの場合は LOW です。.
    ジョブを開く - 完了 | ジョブロードに成功したことを示す信号です。 常にパルスとなります。
    エラー: ジョブを開く | ジョブのロードが失敗したことを示す信号です。 常にパルスとなります。
    エラー: 画像取り込みミス

    画像取り込み終了信号が送信される前に画像取り込みトリガを受信したか、または画像取り込みトリガを受信したときに画像バッファが利用できないことを示す信号です。常にパルスとなります。詳細については、[画像バッファ] ダイアログをご参照ください。 詳細については、[画像バッファ] ダイアログをご参照ください。

    注 : [画像の設定] ステップ、[画像取り込みの設定] グループボックスの [トリガ] パラメータを [カメラ] に設定して、エラー: 画像取り込みミス出力を使用します。
    エラー: トラックオーバラン

    予想時間よりやや遅れて EasyBuilder が遅延ディスクリート出力信号を出力したことを示す信号です。 常にパルスとなります。

    注 : この信号は、CIO-1400 および CIO-MICRO ではサポートされていません。
    エラー: トラックキューフル | 同時に別の出力が発生するように予定されたラインに、EasyBuilder が遅延ディスクリート出力信号を出力したことを示す信号です。 常にパルスとなります。
    オンライン/オフライン | In-Sight がオンラインのときは HIGH (1) になります。In-Sight がオフラインのときは LOW (0) です。
    ストロボ | 信号の立ち上がりエッジまたは立ち下がりエッジでストロボにトリガをかけることができます。
    照明制御
    (CIO-1460 のみ)     		信号の立ち上がりエッジまたは立ち下がりエッジで照明にトリガをかけることができます。
    I/O モジュールスタンバイ
    (CIO-1450 および CIO-1460 のみ)

    [ON] は、I/O モジュールがビジョンシステムと I/O モジュールの間の通信エラーを検知し、再接続を試みていることを示します。 [OFF] は、I/O モジュールの検出したエラーが修正されたことを示します。は、I/O モジュールの検出したエラーが修正されたことを示します。

    注 : この出力タイプは、CIO-1450 または CIO-1460 の設定時に、ライン 0～7 のみで有効です。
    ライフライン
    (CIO-MICRO および CIO-MICRO-CC のみ)     		ビジョンシステムが CIO-MICRO または CIO-MICRO-CC にアクティブに接続されているときは HIGH になります。 ビジョンシステムが接続に失敗すると、LOW です。
    波形

    スプレッドシート中の Waveform、WriteWaveformPulseTrain または WriteWaveformClocked 関数を有効にし、出力ラインの状態を制御します。

    注 : このオプションを使用するには、スプレッドシートビューへのアクセスが必要です。
    シリアル送信

    シリアル送信ラインとして設定します。

    注 :
    • シリアル送信は、In-Sight Explorer 4.7.1 以降を使用し、In-Sight 4.7.1 以降のファームウェアを実装した In-Sight 70xx - 74xx シリーズビジョンシステムに接続時のみサポートされています。
    • この出力タイプは、[直接接続 I/O] 選択時に、ライン 1 でのみ使用可能です。
    • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。
    ジョブの PASS/FAIL (In-Sight 7000 Gen2 シリーズおよび In-Sight 9000 シリーズのみ) | 現在のジョブ全体の PASS/FAIL ステータスに基づき、ビジョンシステムの PASS/FAIL LED およびインジケータリングが、緑 (PASS) または赤 (FAIL) に点灯します。
  8. [信号タイプ] で詳細設定が可能な場合、[詳細] ボタンを押して、選択した出力ラインのラインの出力詳細ダイアログを開きます。

  9. [オフライン中は出力を OFF にする] チェックボックスを ON にして、ビジョンシステムオフライン時に出力を OFF にすることができます (オプション)。

    注 : [オフライン中は出力を OFF にする] チェックボックスが ON で、CIO-MICRO または CIO-MICRO-CC I/O の出力ラインが [ライフライン] 信号タイプに設定されている場合、接続中のビジョンシステムがオフラインでもラインは HIGH となります。
  10. [強制] オプションを使用して、設置前または設置後に、アプリケーションのテストやデバッグを行うことができます。 [強制] オプションはライン設定をオーバライドして、In-Sight センサのオンライン時に入力または出力ラインを強制的に ON にし、結果をテストします。
    1. テストするラインを選択します。
    2. [強制] 設定を ON にします。 設定した動作を強制的に実行するようになります。
    3. ビジョンシステムをオンラインにし、トリガします。

    4. ラインのテストを終了したら、ビジョンシステムをオフラインにし、[強制] を [OFF] または [なし] に設定し直してください。

    注 :
    • 出力ラインにおいて、[強制] 機能では、実際に出力はされません。 出力の値を変更するのみです。
    • 電気的接続を出力ライン上でテストする場合、[強制] を使用するのではなく、[HIGH] または [LOW] を使用し、ビジョンシステムをオンラインに設定することを推奨します。 こうすることにより、ビジョンシステムはオンラインモードであるため、出力信号はハイまたはローのままとなります。 その後、マルチメーターを使用して、電気路が期待通りに動いているかどうかを確認することができます。
  11. 設定を変更した場合、このステップを終了する際に自動的に In-Sight ビジョンシステムに保存されます (ジョブファイルには保存されません) 。

I/O モジュールの設定

入出力の数

デフォルトの入出力ライン

出力 [詳細] ダイアログのコントロール


I/O モジュールの設定

閉じた CIO-1400、CIO-1450、または CIO-1460 を設定する
  1. In-Sight Explorer から、サポートしているビジョンシステムに接続します。
  2. [I/O モジュールの設定] ダイアログを開きます。
  3. [I/O モジュールの選択] ドロップダウンリストから、CIO-1400、CIO-1450 またはCIO-1460 を選択します。
  4. [OK] をクリックして、ダイアログを閉じます。
閉じた CIO-MICRO または CIO-MICRO-CC を設定する
  1. In-Sight Explorer から、サポートしているビジョンシステムに接続します。
  2. [I/O モジュールの設定] ダイアログを開きます。
  3. [I/O モジュールの選択] ドロップダウンリストから、CIO-MICRO または CIO-MICRO-CC を選択します。

  4. [接続先] ドロップダウンリストから、適切な I/O モジュールを選択します。

    注 : I/O モジュールのホスト名がリストに表示されない場合は、<IP アドレスによって接続> を選択し、I/O モジュールの IP アドレスを手動で入力してください。

  5. [更新間隔] フィールドに、In-Sight Micro ビジョンシステムと CIO-MICRO または CIO-MICRO-CC I/O モジュール間の入出力を同期させるのに必要な時間間隔を入力してください。(1ms～500ms。デフォルトは、20ms)

    注 : 出力信号の大幅な遅延が問題になる場合は、アプリケーションに必要なだけ更新時間を短くします。ただし、更新時間は必要以上に短くしないでください。更新時間が短くなると、ジョブの実行にかかる時間が長くなることがあります。
  6. 必要に応じて、[設定の変更] ボタンをクリックして、I/O モジュールのネットワーク設定を行います。

    • デフォルトで、In-Sight CIO-MICRO および CIO-MICRO-CC I/O モジュールは、起動時に DHCP サーバによって動的に設定されます。 新しいホスト名を割り当てることもできますが、ダイアログ内のそのほかのフィールドはすべて無効です。

      注 : DHCP サーバが使用できない場合は、I/O モジュールはタイムアウトし、リンクローカル IP アドレスを取得します。
    • CIO-MICRO および CIO-MICRO-CC には、固定 IP アドレスも使用することができます。[DHCP サーバの使用] チェックボックスを OFF にして、[IP アドレス]、[サブネットマスク]、[デフォルトゲートウェイ]、[DNS サーバ] および [ドメイン名] フィールドを設定してください。
  7. [OK] をクリックして、ダイアログを閉じます。
閉じた CIO-WENET を設定する

CIO-WENET I/O モジュールに IP アドレスを割り当ててから、 In-Sight Explorer で設定します。

  1. In-Sight Explorer から、サポートしているビジョンシステムに接続します。
  2. [I/O モジュールの設定] ダイアログを開きます。
  3. [I/O モジュールの選択] ドロップダウンリストから [CIO-WENET] を選択します。
  4. [IP アドレス] フィールドに、CIO-WENET に割り当てた IP アドレスを入力します。

  5. [更新間隔] フィールドに、In-Sight Micro ビジョンシステムと CIO-WENET I/O モジュール間の入出力を同期させるのに必要な時間間隔を入力してください。(1ms～500ms。デフォルトは、20ms)

    注 :
    • 出力信号の大幅な遅延が問題になる場合は、アプリケーションに必要なだけ更新時間を短くします。 ただし、更新時間は必要以上に短くしないでください。更新時間が短くなると、ジョブの実行にかかる時間が長くなることがあります。
    • CIO-WENET では、同期させるのに必要な時間は、[更新時間] より 3ms 長くなります。
  6. [OK] をクリックして、ダイアログを閉じます。


入出力の数

直接接続 (内蔵) 出力の数は、次のように、In-Sight ビジョンシステムによって異なります。

In-Sight ビジョンシステム | 直接接続 (内蔵) 入力 | 直接接続 (内蔵) 出力
In-Sight Micro 1000 シリーズ | なし | 高速出力✕ 2 ユーザ設定可能 LED ✕ 2 (緑✕ 1、赤✕ 1)
In-Sight 2000 シリーズ | 汎用入力✕ 1 | 高速出力✕ 4 ユーザ設定可能 LED ✕ 2 (緑または赤✕ 1、黄✕ 1)
In-Sight 5000 シリーズ | なし | 高速出力✕ 2 ユーザ設定可能 LED ✕ 2 (緑✕ 1、赤✕ 1)
In-Sight 70xx～74xx シリーズ | 汎用入力✕ 3 | 高速出力✕ 4 ユーザ設定可能 LED ✕ 2 (緑✕ 1、赤✕ 1)
In-Sight 76xx～79xx シリーズ | 汎用入力✕ 3 (最大) | 高速出力✕ 4 (最大) ユーザ設定可能 LED ✕ 2 (緑または赤✕ 1、赤✕ 1)
In-Sight Micro 8000 シリーズ | なし | 高速出力✕ 2 ユーザ設定可能 LED ✕ 2 (緑✕ 1、赤✕ 1)
In-Sight 9902L | 汎用入力✕ 1 | 高速出力✕ 2 ユーザ設定可能 LED ✕ 2 (緑または赤✕ 1、赤✕ 1)
In-Sight 9912 | 汎用入力✕ 3 (最大) | 高速出力✕ 4 (最大) ユーザ設定可能 LED ✕ 2 (緑または赤✕ 1、赤✕ 1)
注 :
  • In-Sight 5000 シリーズ、7000 シリーズ、および Micro シリーズのビジョンシステムには、画像取り込みトリガ専用入力 (×1) があります。詳細については、AcquireImage 関数のトピックのトリガパラメータを参照してください。また、In-Sight Explorer ソフトウェアに収録されているビジョンシステムのインストールガイドも参照してください。
  • ブレークアウトケーブル接続時、In-Sight 76xx - 79xx シリーズビジョンシステムおよび 9912 ビジョンシステムは双方向高速出力および汎用入力を、HS OUT 2 /汎用入力 2 および HS OUT 3 / 汎用入力 3 で使用することができます。 これらのラインはデフォルトで出力に設定されています。

I/O モジュールを使用して、ディスクリート入出力数を追加することができます。 I/O モジュールのディスクリート入出力数は次の通りです。

I/O モジュール | サポートされている In-Sight ビジョンシステム | ディスクリート入力 | ディスクリート出力
CIO-1400 | In-Sight 2000 シリーズ、In-Sight 5000 シリーズ (5604 のみ), In-Sight 76xx - 79xx シリーズ、In-Sight 9000 シリーズ | 汎用✕ 7 | 汎用出力✕ 6
CIO-MICRO | In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight 70xx～79xx シリーズ、In-Sight Micro 8000 シリーズ、In-Sight 9000 シリーズ | 汎用✕ 8 | 汎用✕ 8
CIO-MICRO-CC | In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ (5705、5705C および 5715 を除く)、In-Sight 70xx～74xx0 シリーズ | 汎用✕ 8 | 汎用✕ 8
CIO-1450 | In-Sight 5000 シリーズ (5604、5705、5705C および 5715 を除く) | 汎用✕ 8 | 汎用✕ 8
CIO-1460 | In-Sight 5000 シリーズ (5604、5605、5705、5705C および 5715) | 汎用✕ 8 | 汎用✕ 8
CIO-WENET | In-Sight Micro 1000 シリーズ | 汎用✕ 8 | 汎用✕ 8
注 :
  • CIO-1400 I/O モジュールは、ファームウェア 5.3.0 以降を搭載した In-Sight 2000 シリーズビジョンセンサをサポートします。
  • CIO-1400 I/O モジュールは、In-Sight Explorer 5.4.0 以降を使用している In-Sight 76xx～79xx シリーズビジョンシステムをサポートしています。 このバージョン以前の In-Sight Explorer を使用してビジョンシステムにログオンし、CIO-1400 I/O に接続して I/O ラインを設定した場合、その変更は保持されません。
  • CIO-MICRO I/O モジュールは、ファームウェア 5.3.0 以降を搭載した In-Sight 5705、5705C、5715 および In-Sight Micro 8000 シリーズビジョンシステムをサポートします。
  • CIO-MICRO および CIO-MICRO-CC I/O モジュールがサポートしているのは、128MB 以上の不揮発性フラッシュメモリを持つ In-Sight 5100 シリーズ、および 5400 シリーズのビジョンシステムのみです。モデルはタイプ番号 (821-xxxx-xx) で特定できます。 このタイプ番号は、ビジョンシステムに添付されているラベルに記載されています。 モデル一覧、タイプ番号および不揮発性フラッシュメモリの詳細については、ここをクリックしてください。
  • CIO-1450、CIO-1460 および CIO-WENET I/O モジュールのサポートは終了しました。これらの I/O モジュールはご購入いただくことはできませんが、下位互換性のみを目的として In-Sight Explorer ではサポートされています。


デフォルトの入出力ライン

閉じた In-Sight Micro 1000 シリーズ
注 :
  • HS OUT 0 および HS OUT 1 は内蔵高速出力で、ビジョンシステムと直接接続しています。
  • ビジョンセンサは、HSOUT 1 ラインで [ストロボ] 信号タイプをサポートします。

直接接続 I/O

出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
4 | 緑 LED
5 | 赤 LED

CIO-MICRO または CIO-MICRO-CC

入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | 緑 LED
11 | 赤 LED

CIO-WENET

入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | 緑 LED
11 | 赤 LED
閉じた In-Sight 2000 シリーズ
注 :
  • IN 0 は内蔵入力で、ビジョンシステムと直接接続しています。

  • HS OUT 0、HS OUT 1、HS OUT 2 および HS OUT 3 は内蔵高速出力で、ビジョンシステムと直接接続しています。

  • ビジョンセンサは、HSOUT 1 ラインで [ストロボ] 信号タイプをサポートします。
  • 緑 LED/赤 LED は単一の LED 出力で、緑・赤ともユーザ定義可能です。

直接接続 I/O

入力 | 名前
0 | 汎用入力 0
出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
2 | HSOUT 2
3 | HSOUT 3
4 | 緑 LED
 | 赤 LED
5 | 黄 LED

CIO-1400

入力 | 名前
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
 | ライン 5
5 | ライン 6
7 | ライン 7
8 | 緑 LED
9 | 赤 LED
10 | 黄 LED
11 | 無効
12 | 無効
閉じた In-Sight 5000 シリーズ

直接接続/CIO-1350

出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
4 | 緑 LED
5 | 赤 LED

CIO-1400

入力 | 名前
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | 緑 LED
9 | 赤 LED

CIO-1450

注 : パルスディスクリート出力が CIO-1450 I/O モジュールから送信されるときには、パルス幅が指定より 10 ミリ秒長くなることがあります。
入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | 緑 LED
11 | 赤 LED

CIO-1460

注 : CIO-1460 I/O モジュールの電源を入れ直すと、ディスクリート出力は初期設定時に約 250 ミリ秒後に出力されます。
入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | 緑 LED
11 | 赤 LED
12 | 無効
13 | 無効

CIO-MICRO/CIO-MICRO-CC

注 :
  • CIO-MICRO I/O モジュールは、ファームウェアバージョン 5.3.0 以降を搭載した In-Sight 5705、5705C、5715 をサポートします。
  • CIO-MICRO および CIO-MICRO-CC I/O モジュールは、128MB 以上の不揮発性フラッシュメモリを持つ In-Sight 5100 シリーズおよび 5400 シリーズビジョンシステムをサポートします。 モデルはタイプ番号 (821-xxxx-xx) で特定できます。 このタイプ番号は、ビジョンシステムに添付されているラベルに記載されています。 モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアのバージョンをご参照ください。 モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。
入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | 緑 LED
11 | 赤 LED
閉じた In-Sight 70xx～74xx シリーズ
注 :
  • In-Sight 70xx - 74xx シリーズビジョンシステムは、ブレークアウトケーブルと CIO-MICRO または CIO-MICRO-CC I/O モジュールへの同時接続をサポートしています。
  • 汎用入力 1、汎用入力 2 および 汎用入力 3 は内蔵入力で、ビジョンシステムと直接接続しています。直接接続 (内蔵) は、ビジョンシステムがブレークアウトケーブルに接続されているときのみサポートされています。
  • HS OUT 0、HS OUT 1、HS OUT 2 および HS OUT 3 は内蔵高速出力で、ビジョンシステムと直接接続しています。In-Sight 70xx - 74xx シリーズビジョンシステムの高速出力は、ビジョンシステムがブレークアウトケーブルに接続されている場合のみサポートされます。
  • ビジョンシステムは、HSOUT 0 ラインの [ストロボ] 信号タイプをサポートします。
  • 外部ストロボデバイスを In-Sight 70xx - 74xx シリーズビジョンシステムの外部照明ケーブルに接続している場合、[照明の設定] ダイアログを使用して、外部照明を設定してください。
  • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。

直接接続 I/O

入力 | 名前
1 | 汎用入力 1/シリアル受信
2 | 汎用入力 2
3 | 汎用入力 3
出力 | 名前
0 | 高速出力0
1 | HS OUT 1/シリアル送信
2 | 高速出力2
3 | 高速出力3
4 | 緑 LED
5 | 赤 LED

CIO-MICRO/CIO-MICRO-CC

注 :
  • ビジョンシステムがブレークアウトケーブルに接続されており、CIO-MICRO I/O モジュールへのイーサネット接続が確立している場合:
    • I/O モジュールの I/O ポート (DB15) および TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1 および HS COMMON 端子はサポートされていません。 リモートデバイスからこれらの端子にリード線を接続しないでください。
    • I/O モジュールの I/O ポート (DB15) はサポートされていません。 このポートには何も接続しないでください。
    • ブレークアウトケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効になっています。 この場合、I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
9 | 汎用入力 1
10 | 汎用入力 2
11 | 汎用入力 3
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | 高速出力0
9 | 高速出力1
10 | 高速出力2
11 | 高速出力3
12 | 緑 LED
13 | 赤 LED
閉じた In-Sight 7000 Gen2 シリーズ
注 :
  • ビジョンシステムは、ブレークアウトケーブルと CIO-MICRO I/O モジュールとの同時接続をサポートします。
  • 汎用入力 1、汎用入力 2 および 汎用入力 3 は内蔵入力で、ビジョンシステムと直接接続しています。直接接続 (内蔵) は、ビジョンシステムがブレークアウトケーブルに接続されているときのみサポートされています。
  • HS OUT 0、HS OUT 1、HS OUT 2 および HS OUT 3 は内蔵高速出力で、ビジョンシステムと直接接続しています。
  • ビジョンセンサは、HSOUT 1 ラインで [ストロボ] 信号タイプをサポートします。
  • 外部ストロボデバイスを In-Sight 7000 Gen2 シリーズビジョンシステムの外部照明ケーブルに接続している場合、または照明アクセサリをビジョンシステムのフェースプレートに接続している場合、[照明の設定] ダイアログを使用して照明を設定してください。

直接接続 I/O

注 : ビジョンシステムは双方向高速出力および汎用入力を、IN 2 / HS OUT 2 および IN 3 / HS OUT 3 で使用することができます。 これらのラインはデフォルトで出力に設定されています。
入力 | 方向 | 名前
1 | 固定入力 | 汎用入力 1
2 | 入力 | 汎用入力 2
3 | 入力 | 汎用入力 3
出力 | 方向 | 名前
0 | 固定出力 | HSOUT 0
1 | 固定出力 | HSOUT 1
2 | 出力 | HSOUT 2
3 | 出力 | HSOUT 3
4 | 固定出力 | PASS/FAIL LED
5 | 固定出力 | エラー LED

CIO-MICRO

注 :
  • ビジョンシステムがブレークアウトケーブルに接続されており、CIO-MICRO I/O モジュールへのイーサネット接続が確立している場合:
    • ビジョンシステムは双方向高速出力および汎用入力を、IN 2 / HS OUT 2 および IN 3 / HS OUT 3 で使用することができます。 これらのラインはデフォルトで出力に設定されています。
    • CIO-MICRO I/O モジュールの TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1 および HS COMMON 端子はサポートされていません。 リモートデバイスからこれらの端子にリード線を接続しないでください。
    • ブレークアウトケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効になっています。 この場合、I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
  • ビジョンシステムが I/O モジュールケーブルを介して CIO-MICRO I/O モジュールに接続されている場合:
    • ビジョンシステムの IN 1、IN 2、IN 3、HS OUT 2 および HS OUT 3 ラインは、[ディスクリート I/O の設定] ダイアログに表示されますが、サポートされていません。 これらのラインは、ビジョンシステムがブレークアウトケーブルに接続されている場合のみ、サポートされます。
    • TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1 および HS COMMON は、CIO-MICRO I/O モジュール端子を介して接続されます。
    • ビジョンシステムのフェースプレートに装着されている照明アクセサリ、または LIGHT コネクタはサポートされていません。 こららの照明アクセサリが装着されている場合、ブレークアウトケーブルを使用してビジョンシステムに電源を供給し、I/O モジュールへの接続はイーサネットを介してのみ確立するようにしてください。
入力 | 方向 | 名前
0 | 固定入力 | ライン 0
1 | 固定入力 | ライン 1
2 | 固定入力 | ライン 2
3 | 固定入力 | ライン 3
4 | 固定入力 | ライン 4
5 | 固定入力 | ライン 5
6 | 固定入力 | ライン 6
7 | 固定入力 | ライン 7
9 | 固定入力 | 汎用入力 1
10 | 入力 | 汎用入力 2
11 | 入力 | 汎用入力 3
出力 | 方向 | 名前
0 | 固定出力 | ライン 0
1 | 固定出力 | ライン 1
2 | 固定出力 | ライン 2
3 | 固定出力 | ライン 3
4 | 固定出力 | ライン 4
5 | 固定出力 | ライン 5
6 | 固定出力 | ライン 6
7 | 固定出力 | ライン 7
8 | 固定出力 | HSOUT 0
9 | 固定出力 | HSOUT 1
10 | 出力 | HSOUT 2
11 | 出力 | HSOUT 3
12 | 固定出力 | PASS/FAIL LED
13 | 固定出力 | エラー LED

CIO-1400

注 :
  • CIO-1400 I/O モジュール接続時、ビジョンシステムの 汎用入力 1、汎用入力 2、汎用入力 3、HS OUT 2 および HS OUT 3 ラインはサポートされていません。
  • CIO-1400 I/O モジュールは、In-Sight Explorer 5.4.0 以降を使用している In-Sight Gen2 シリーズビジョンシステムをサポートしています。 このバージョン以前の In-Sight Explorer を使用してビジョンシステムにログオンし、CIO-1400 I/O に接続して I/O ラインを設定した場合、その変更は保持されません。
入力 | 名前
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | PASS/FAIL LED
9 | エラー LED
閉じた In-Sight Micro 8000 シリーズ
注 :
  • HS OUT 0 および HS OUT 1 は内蔵高速出力で、ビジョンシステムと直接接続しています。
  • ビジョンセンサは、HSOUT 1 ラインで [ストロボ] 信号タイプをサポートします。
  • In-Sight 8405 ビジョンシステムでストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。 詳細については、ローリングシャッターの操作をご参照ください。

直接接続 I/O

出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
4 | 緑 LED
5 | 赤 LED

CIO-MICRO

注 :
  • CIO-MICRO I/O モジュールは、5.3.0 以降のファームウェアを搭載した In-Sight 8000 シリーズビジョンシステムをサポートします。
  • In-Sight 8505P ビジョンシステムは、定格 12.95 ワット以上のクラス 0、3、または 4 PoE 電源に接続する必要があります。CIO-MICRO I/O モジュールはクラス 2 PoE デバイスであるため、I/O モジュールの PoE ポートを介して In-Sight 8505P ビジョンシステムに電源を供給することはできません。ビジョンシステムのイーサネットケーブルをクラス 0、3、または 4 PoE 電源に接続し、In-Sight Explorer を使用してローカルネットワークを介し、/O モジュールへの接続を確立してください。
入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | 緑 LED
11 | 赤 LED
閉じた In-Sight 9902L ラインスキャンビジョンシステム
注 :
  • ビジョンシステムは、ブレークアウトケーブルと CIO-MICRO I/O モジュールとの同時接続をサポートします。
  • 汎用入力 1、汎用入力 2 および 汎用入力 3 は内蔵入力で、ビジョンシステムと直接接続しています。直接接続 (内蔵) は、ビジョンシステムがブレークアウトケーブルに接続されているときのみサポートされています。
  • HS OUT 0 および HS OUT 1 は内蔵高速出力で、ビジョンシステムと直接接続しています。
  • ビジョンセンサは、HSOUT 1 ラインで [ストロボ] 信号タイプをサポートします。
  • In-Sight 9902L ラインスキャンビジョンシステムで、ストロボを使用する場合、
    • ストロボは PNP 配線を使用し、[ストロボ]/[照明制御] トリガを [立ち上がりエッジ] に設定してください。
    • ビジョンシステムが画像取り込みトリガを受信すると、出力ラインはパルスを発信し、ストロボが露光時間中、点灯します。 露光完了後、次の画像トリガを受信する前に、最低 100µs が必要です。それ以下の場合、ストロボ正しく機能しません。

直接接続 I/O

入力 | 名前
1 | 汎用入力 1
出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
4 | PASS/FAIL LED
5 | エラー LED

CIO-MICRO

注 :
  • ビジョンシステムがブレークアウトケーブルに接続されており、CIO-MICRO I/O モジュールへのイーサネット接続が確立している場合:
    • CIO-MICRO I/O モジュールの TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1 および HS COMMON 端子はサポートされていません。 リモートデバイスからこれらの端子にリード線を接続しないでください。
    • ブレークアウトケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効になっています。 この場合、I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
  • ビジョンシステムが I/O モジュールケーブルを介して CIO-MICRO I/O モジュールに接続されている場合:
    • ビジョンシステムのエンコーダ A 入力およびエンコーダ B 入力はサポートされていません。

    • ビジョンシステムの IN 1 ラインは、[ディスクリート I/O の設定] ダイアログに表示されますが、サポートされていません。 IN 1 は、ビジョンシステムがブレークアウトケーブルに接続されている場合のみ、サポートされます。

    • TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1 および HS COMMON は、CIO-MICRO I/O モジュール端子を介して接続されます。
入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
9 | 汎用入力 1
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | PASS/FAIL LED
11 | エラー LED

CIO-1400

注 : CIO-1400 I/O モジュール接続時、ビジョンシステムのエンコーダ A 入力、エンコーダ B 入力および汎用入力 1 ラインはサポートされていません。
入力 | 名前
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | PASS/FAIL LED
9 | エラー LED
閉じた In-Sight 9912
注 :
  • ビジョンシステムは、ブレークアウトケーブルと CIO-MICRO I/O モジュールとの同時接続をサポートします。
  • 汎用入力 1、汎用入力 2 および 汎用入力 3 は内蔵入力で、ビジョンシステムと直接接続しています。直接接続 (内蔵) は、ビジョンシステムがブレークアウトケーブルに接続されているときのみサポートされています。
  • HS OUT 0、HS OUT 1、HS OUT 2 および HS OUT 3 は内蔵高速出力で、ビジョンシステムと直接接続しています。
  • ビジョンセンサは、HSOUT 1 ラインで [ストロボ] 信号タイプをサポートします。
  • 外部ストロボデバイスを In-Sight 9912 ビジョンシステムの外部照明ケーブルに接続している場合、[照明の設定] ダイアログを使用して、外部照明を設定してください。

直接接続 I/O

注 : ビジョンシステムは双方向高速出力および汎用入力を、IN 2 / HS OUT 2 および IN 3 / HS OUT 3 で使用することができます。 これらのラインはデフォルトで出力に設定されています。
入力 | 方向 | 名前
1 | 固定入力 | 汎用入力 1
2 | 入力 | 汎用入力 2
3 | 入力 | 汎用入力 3
出力 | 方向 | 名前
0 | 固定出力 | HSOUT 0
1 | 固定出力 | HSOUT 1
2 | 出力 | HSOUT 2
3 | 出力 | HSOUT 3
4 | 固定出力 | PASS/FAIL LED
5 | 固定出力 | エラー LED

CIO-MICRO

注 :
  • ビジョンシステムがブレークアウトケーブルに接続されており、CIO-MICRO I/O モジュールへのイーサネット接続が確立している場合:
    • ビジョンシステムは双方向高速出力および汎用入力を、IN 2 / HS OUT 2 および IN 3 / HS OUT 3 で使用することができます。 これらのラインはデフォルトで出力に設定されています。
    • CIO-MICRO I/O モジュールの TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1 および HS COMMON 端子はサポートされていません。 リモートデバイスからこれらの端子にリード線を接続しないでください。
    • ブレークアウトケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効になっています。 この場合、I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
  • ビジョンシステムが I/O モジュールケーブルを介して CIO-MICRO I/O モジュールに接続されている場合:
    • ビジョンシステムの IN 1、IN 2、IN 3、HS OUT 2 および HS OUT 3 ラインは、[ディスクリート I/O の設定] ダイアログに表示されますが、サポートされていません。 これらのラインは、ビジョンシステムがブレークアウトケーブルに接続されている場合のみ、サポートされます。
    • TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1 および HS COMMON は、CIO-MICRO I/O モジュール端子を介して接続されます。
    • ビジョンシステムの LIGHT コネクタに装着された照明アクセサリはサポートされていません。 こららの照明アクセサリが装着されている場合、ブレークアウトケーブルを使用してビジョンシステムに電源を供給し、I/O モジュールへの接続はイーサネットを介してのみ確立するようにしてください。
入力 | 方向 | 名前
0 | 固定入力 | ライン 0
1 | 固定入力 | ライン 1
2 | 固定入力 | ライン 2
3 | 固定入力 | ライン 3
4 | 固定入力 | ライン 4
5 | 固定入力 | ライン 5
6 | 固定入力 | ライン 6
7 | 固定入力 | ライン 7
9 | 固定入力 | 汎用入力 1
10 | 入力 | 汎用入力 2
11 | 入力 | 汎用入力 3
出力 | 方向 | 名前
0 | 固定出力 | ライン 0
1 | 固定出力 | ライン 1
2 | 固定出力 | ライン 2
3 | 固定出力 | ライン 3
4 | 固定出力 | ライン 4
5 | 固定出力 | ライン 5
6 | 固定出力 | ライン 6
7 | 固定出力 | ライン 7
8 | 固定出力 | HSOUT 0
9 | 固定出力 | HSOUT 1
10 | 出力 | HSOUT 2
11 | 出力 | HSOUT 3
12 | 固定出力 | PASS/FAIL LED
13 | 固定出力 | エラー LED

CIO-1400

注 : CIO-1400 I/O モジュール接続時、ビジョンシステムの 汎用入力 1、汎用入力 2、汎用入力 3、HS OUT 2 および HS OUT 3 ラインはサポートされていません。
入力 | 名前
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | PASS/FAIL LED
9 | エラー LED


出力 [詳細] ダイアログのコントロール

  • [パルス]: このチェックボックスが ON のときは、出力はパルスになります。 OFF にするとレベルに設定されます。 [取り込み遅延] が 0 以外の場合、パルス出力になります。

  • [パルス幅 (ミリ秒)]: 出力パルスの持続時間を指定します。

    ビジョンシステム/ビジョンセンサ | 最小パルス幅 | 最大パルス幅 | デフォルトのパルス幅
    汎用出力 | 高速出力
    In-Sight Micro 1000 シリーズ (1402、1412 および 1500 を除く) | 10ms | 10ms | 1000ms | 10ms
    In-Sight Micro 1402、1412 および 1500 | 10ms | 1ms | 1000ms | 10ms
    In-Sight 2000 シリーズ | 10ms | 1ms | 1000ms | 10ms
    In-Sight 5000 シリーズ | 10ms | 10ms | 1000ms | 10ms
    In-Sight 70xx～74xx シリーズ | 10ms | 1ms | 1000ms | 10ms
    In-Sight 76xx～79xx シリーズ | 10ms | 1ms | 1000ms | 10ms
    In-Sight Micro 8000 シリーズ | 10ms | 1ms | 1000ms | 10ms
    In-Sight 9902L | 1ms | 1ms | 1000ms | 10ms
    In-Sight 9912 | 1ms | 1ms | 1000ms | 10ms
    注 :
    • CIO-MICRO または CIO-MICRO-CC I/O モジュールをサポートしているビジョンシステムと共に使用しているときに、汎用出力の最小パルス幅は [I/O モジュールの設定] ダイアログの [更新間隔] 設定によって制限されます。 例えば、[更新間隔] が 20ms の場合、最小パルス幅は 30ms 以下に設定できません。 詳細については、 [I/O モジュールの設定] ダイアログをご参照ください。
    • In-Sight 76xx - 79xx シリーズおよび 8000 シリーズでは、最小パルス幅 1ms は、In-Sight ファームウェアバージョン 5.5.0 以降でのみサポートされています。 それ以前のファームウェアバージョンでは、最小パルス幅は 10ms です。

  • [取り込み遅延 (N)]: 信号のパルスを出力線が受信した後、出力を遅延させるための画像取り込みパルスまたはトラッキングパルスの数 (0～1000) を指定します。 取り込み遅延が 0 の場合、In-Sight ビジョンシステムは、EasyBuilder ジョブを評価するとすぐに出力ラインを更新します。 [取り込み遅延] が 0 よりも大きい場合、出力ラインは常にパルスとなります。

    注 : [取り込み遅延] と [トリガ後の時間] を同時に使用することはできません。これらは個別に使用する必要があります。例えば、[取り込み遅延] が有効になると、[トリガ後の時間] は無効になります。逆に、[トリガ後の時間] が有効になると、[取り込み遅延] は無効になります。

  • トリガ後の時間 (ms): このチェックボックスを ON にすると、指定された時間 (0 ～ 10000 ミリ秒) の経過後に、出力が行われます。

    注 : [取り込み遅延] と [トリガ後の時間] を同時に使用することはできません。これらは個別に使用する必要があります。例えば、[取り込み遅延] が有効になると、[トリガ後の時間] は無効になります。逆に、[トリガ後の時間] が有効になると、[取り込み遅延] は無効になります。
  • [ストロボ/照明制御のトリガ]: 立ち上がりまたは立ち下がりエッジ信号を使用して、ストロボまたは照明制御にトリガをかけます。
    • NPN の設定: トリガを [立ち上がりエッジ] に設定すると、画像センサの露光時に信号が HIGH となり、それ以外は LOW になります。[立ち下がりエッジ] に設定すると、画像センサの露光時に信号が LOW になり、それ以外は HIGH となります。露光時は常にパルスとなります。 露光時間は外部ストロボデバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。

    • PNP の設定: トリガを [立ち上がりエッジ] に設定すると、画像センサの露光時に信号が LOW となり、それ以外は HIGH になります。[立ち下がりエッジ] に設定すると、画像センサの露光時に信号が HIGH になり、それ以外は LOW となります。露光時は常にパルスとなります。 露光時間は外部ストロボデバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。

      注 :
      • In-Sight 5600 シリーズ、5705、5705C、5715 および 9902L ビジョンシステムでは、ストロボ動作が反転しています。例えば、NPN 配線では、立ち上がりエッジおよび立ち下がりエッジが PNP 配線のように動作します。
      • In-Sight 9902L ラインスキャンビジョンシステムで、ストロボを使用する場合、
        • ストロボは PNP 配線を使用し、[ストロボ]/[照明制御] トリガを [立ち上がりエッジ] に設定してください。
        • ビジョンシステムが画像取り込みトリガを受信すると、出力ラインはパルスを発信し、ストロボが露光時間中、点灯します。 露光完了後、次の画像トリガを受信する前に、最低 100µs が必要です。それ以下の場合、ストロボ正しく機能しません。
  • ストロボ開始位置: ストロボ出力を開始する位置を指定します。 このオプションは、In-Sight 9902L ビジョンシステムではサポートされていません。
    • 画像取り込み開始: In-Sight ビジョンシステムが画像取り込みを開始するときにストロボ出力を開始するよう指定します。In-Sight Micro 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。
    • カメラトリガ: カメラトリガイベントを受信したときにストロボ出力を開始するよう指定します。In-Sight Micro 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。

    • すべての行を露光: すべてのピクセル行を露光するときのみストロボ出力を開始します。In-Sight Micro 8405 ビジョンシステムでのみサポートされています。

      注 : In-Sight Micro 8405 でストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。詳細については、ローリングシャッターの操作をご参照ください。

  • 三色 LED: 三色 LED ラインの動作を設定します。 (OFF/緑、OFF/赤、赤/緑。デフォルト = OFF/緑) このオプションは、ラインが三色 LED をサポートする場合のみ使用できます。

    注 : このオプションは、In-Sight 76xx～78xx シリーズおよび In-Sight 9000 シリーズビジョンシステムの PASS/FAIL LED でサポートされていますが、PASS/FAIL ジョブセルを信号タイプで選択している場合、使用することはできません。


入力: ジョブファイルをロードするには

In-Sight 2000 シリーズビジョンセンサ

この機能を使用するには、ジョブファイル名の先頭に 0~31 の数値が付いたジョブを 1 つ以上保存しておく必要があります (例: 2PinInspection.job)。

  1. [入力ライン 0] を選択し、[信号タイプ] を [ジョブ変更 (パルス)] に設定します。

  2. 2PinInspection.job をセンサにロードするには、外部デバイス (PLC など) から一連のパルスを In-Sight 2000 センサに対して発行します。

    パルスの種類 | パルス幅
    開始パルス | 20ms (±2ms)
    カウントパルス | 10ms (±1ms)
    パルスギャップ | 10ms (± 1ms)
    停止パルス | 20ms (±2ms)
    1. 外部デバイスが、パルスギャップに続き、開始パルスを生成します。
    2. 次に、外部デバイスがカウントパルスを生成します。 各カウントパルス間、および最後のカウントパルスの後にパルスギャップが発生します。 カウントパルスの数は、ロードするジョブの接頭辞と一致する必要があります。例えば、2PinInspection.job には、カウントパルスが 2 つ必要です。
    3. 外部デバイスから、停止パルスを発行します。 すべてのパルスおよびパルスギャップが指定のパルス長にマッチすると、ジョブ変更リクエストに成功し、2PinInspection.job がセンサにロードされます。 これらの条件に 1 つでも満たない場合 (パルスまたはパルスギャップのタイミングが正しくない場合)、ジョブ変更リクエストに失敗し、ジョブ変更は起こりません。
    注 :
    • SetSystemConfig("PulseJobChangeTiming") ネイティブモードコマンドを使用して、開始パルス、カウントパルス、パルスギャップおよび停止パルスの幅を設定することができます。
    • オプションとして、ディスクリート出力ラインを [ジョブを開く - 完了] または [エラー: ジョブを開く] タイプに設定し、出力をパルスすることによって、ジョブ変更リクエストの成功または失敗を報告することができます。 指定の入力パルス長が使用されない場合、ジョブロードに失敗し、出力はパルスされません。

In-Sight ビジョンシステム

この機能を使用するには、ジョブファイル名の先頭に 0~127 の数値が付いたジョブを 1 つ以上保存しておく必要があります (例: 1PinInspection.job)。

  1. 入力ラインを選択し、[信号タイプ] を [ジョブを開く] に設定します。どのジョブファイルがロードされるかは、[ジョブ ID 番号] に設定した入力ラインの状態 (0 または 1) によって決まります。
  2. 信号タイプの設定で [ジョブ ID 番号] の入力ラインを 1 本以上用意しておきます。
  3. [ジョブ ID 番号] に設定した入力ラインは、2 進数の 1 ビットとして扱われます。 続いて同様に [ジョブ ID 番号] に設定した他の入力ラインも 2 進数の追加ビットとして扱われます。 これらのビットで構成された 2 進数の値が、ロードするジョブの番号となります。ジョブファイルは、あらかじめファイル名の先頭に 10 進数のジョブ番号を付けて保存 (例: 6test.job) しておく必要があります。

例 1

4 本のディスクリート入力ラインを [ジョブ ID 番号] に割り当てます。 そのときジョブ番号は 4 ビットの 2 進数値で表されます。これらの 4 本の入力状態が 1-1-1-0 であったとすると、2 進数の 1110、すなわち 10 進数の 14 が指定され、"14" で始まるジョブファイル (例: 14inspect.job) がロードされます。

例 2

3inspection.job、6inspection.job および 9inspection.job という名前の付いた3 つのジョブファイルがあります。 センサが PLC から HIGH 信号を受信する時に、ジョブファイル 6inspection.job がロードされるように指定するとします。 ディスクリート入力 1 は、現在画像取り込みトリガとして使用されています。

  1. 入力ライン 1 を PLC に接続します。
  2. 入力ライン 1 の [信号タイプ] を [ジョブを開く] に設定します。
  3. ジョブファイルの先頭の数値が 3～9 なので、[ジョブ ID 番号] に 4 点の入力が必要となります (9 は2 進数では 1001)。

  4. ジョブ ID 番号ラインの状態が順番に 1-1-0-0 (6 は2 進数で 1100) で、入力ライン 2 の状態が HIGH (1) のとき、ジョブ名 6inspeciton.job がロードされます。

    注 : 同じ先頭の数値を持つファイルが　In-Sight センサに保存されている場合、ファイルは英数字順にロードされます。


位置決めツールおよび検査ツールの ON/OFF を切り替えるには

位置決めツールおよび検査ツールの実行可否が、入力ラインと関連付けられていることがあります。そうすることにより、どのツールを実行すべきかを PLC などの制御システムから選択することができます。

  1. 入力ラインを選択し、[信号タイプ] を [ユーザ用] に設定します。
  2. 目的の位置決めツールまたは検査ツールに戻り、ツールの [ツール有効] ドロップダウンメニューから、ステップ　1 で定義した入力ラインを選択します。
  3. 制御システムがツールの ON/OFF を切り替えるようになります (HIGH = 1 は ON 、LOW = 0 はOFF)。


画像取り込みをトリガするには

PLC、光電ビジョンシステムまたはその他のデバイスから入力ラインを介して画像取り込みトリガを受信するように In-Sight ビジョンシステムを設定するには、次の手順に従ってください。

  1. [画像の設定] ステップをクリックします。

  2. [画像の取り込みの設定] グループボックスの [トリガ] ドロップダウンメニューから [外部] を選択します。

    注 :
    • [外部] トリガは、In-Sight 2000 シリーズビジョンシステムではサポートされていません。
    • ビジョンシステムの内蔵画像取り込みトリガ入力 (AcquireImage 関数の [トリガ] パラメータを [カメラ] に設定) に対し、汎用入力ラインを画像取り込みトリガ ([トリガ] パラメータを [外部] に設定) として設定することにより、より高速にトリガを実行することができます。
    • AcquireImage 関数の [トリガ] パラメータを [外部] に設定したときに画像取り込みに失敗した場合、[エラー: 画像取り込みミス] ディスクリート出力は、ビジョンシステムから送信されません。 [エラー: 画像取り込みミス] 信号は、AcquireImage 関数の [トリガ] パラメータが [カメラ] に設定されている場合のみサポートされています。
  3. [入力] ステップに戻ります。
  4. 入力ラインを選択して、[信号タイプ] を [画像取り込みトリガ] に設定します。
  5. [エッジタイプ] を [立ち上がりエッジ] または [立ち下がりエッジ] に設定します。
  6. 入力デバイスのワイヤを In-Sight ビジョンシステムのブレークアウトケーブルまたは I/O モジュールのトリガ入力に接続します。詳細については、In-Sight ビジョンシステムまたは I/O モジュール取扱説明書を参照してください。


入力: 入力ラインを介してモデルパターンを登録するには

入力ラインを介してモデルパターンを登録するように In-Sight ビジョンシステムを設定するには、次の手順に従ってください。

  1. パターン/パターン (1 - 10) 位置決めツール、パターン有無判明ツールまたはパターン計数ツールにおいて、登録信号として使用する入力ラインを [登録の入力] ドロップダウンリストから選択します。

    注 : In-Sight ビジョンシステムまたは In-Sight 2000-23M ビジョンセンサ接続時、[登録の入力] ドロップダウンリストは [設定] タブに含まれています。
  2. [入力/出力] アプリケーションステップに戻ります。
  3. 選択した入力ラインの [信号タイプ] を [イベントトリガ] に設定します。
  4. [エッジタイプ] を [立ち上がりエッジ]、[立ち下がりエッジ] または [両方のエッジ] に設定します。

  5. In-Sight ビジョンシステム/センサをオンラインにします。

    注 : モデルパターンの登録には、ビジョンシステム/センサが取り込んだ最新の画像が使用されます。 登録するために、ビジョンシステム/センサを再度トリガする必要はありません。

  6. 選択した [エッジタイプ] のエッジで、モデルパターンが登録されます。


画像取り込みミスを送信するには

画像取り込み終了信号が送信される前に画像取り込みトリガを受信したか、または画像取り込みトリガを受信したときに画像バッファが利用できないことを示す信号です。常にパルスとなります。
注 : [画像の設定] ステップ、[画像取り込みの設定] グループボックスの [トリガ] パラメータを [カメラ] に設定して、エラー: 画像取り込みミス出力を使用します。

画像取り込みミスを送信するには、次の手順に従ってください。

  1. 出力ラインを選択し、[信号タイプ] を [画像取り込み終了] に設定します。[詳細] ボタンを押し、パルス幅を指定します。
  2. 他の出力ラインを選択し、[信号タイプ] を [エラー: 画像取り込みミス]　に設定します。[詳細] ボタンを押し、パルス幅を指定します。


出力: 画像取り込み時に照明を同期させるには

閉じた ストロボのトリガ

信号の立ち上がりエッジまたは立ち下がりエッジでストロボにトリガをかけることができます。

ストロボをトリガする信号を送信するには、次の手順に従ってください。

  1. [画像の設定] ステップで画像取り込みトリガを定義します。 露光時間は外部照明デバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。
  2. 出力ラインの [信号タイプ] を [ストロボ] に設定します。
  3. [詳細] ボタンを押して、信号の [立ち上がりエッジ] または [立ち下りエッジ] でストロボにトリガをかけるように設定します。
    • NPN の設定: トリガを [立ち上がりエッジ] に設定すると、画像センサの露光時に信号が HIGH となり、それ以外は LOW になります。[立ち下がりエッジ] に設定すると、画像センサの露光時に信号が LOW になり、それ以外は HIGH となります。露光時は常にパルスとなります。 露光時間は外部ストロボデバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。

    • PNP の設定: トリガを [立ち上がりエッジ] に設定すると、画像センサの露光時に信号が LOW となり、それ以外は HIGH になります。[立ち下がりエッジ] に設定すると、画像センサの露光時に信号が HIGH になり、それ以外は LOW となります。露光時は常にパルスとなります。 露光時間は外部ストロボデバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。

      注 :
      • In-Sight 5600 シリーズ、5705、5705C、5715 および 9902L ビジョンシステムでは、ストロボ動作が反転しています。例えば、NPN 配線では、立ち上がりエッジおよび立ち下がりエッジが PNP 配線のように動作します。
      • In-Sight 9902L ラインスキャンビジョンシステムで、ストロボを使用する場合、
        • ストロボは PNP 配線を使用し、[ストロボ]/[照明制御] トリガを [立ち上がりエッジ] に設定してください。
        • ビジョンシステムが画像取り込みトリガを受信すると、出力ラインはパルスを発信し、ストロボが露光時間中、点灯します。 露光完了後、次の画像トリガを受信する前に、最低 100µs が必要です。それ以下の場合、ストロボ正しく機能しません。
  4. [ストロボ開始位置] を指定します。 このオプションは、In-Sight 9902L ビジョンシステムではサポートされていません。
    • 画像取り込み開始: In-Sight ビジョンシステムが画像取り込みを開始するときにストロボ出力を開始するよう指定します。In-Sight Micro 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。
    • カメラトリガ: カメラトリガイベントを受信したときにストロボ出力を開始するよう指定します。In-Sight Micro 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。
    • すべての行を露光: すべてのピクセル行を露光するときのみストロボ出力を開始します。In-Sight Micro 8405 ビジョンシステムでのみサポートされています。
注 :
  • 照明デバイスを正常に作動させるには、In-Sight ビジョンシステムと照明デバイスが共通のグラウンドに接続されている必要があります。
  • In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ (5604 を除く), In-Sight 76xx - 79xx シリーズ、In-Sight Micro 8000 シリーズおよび In-Sight 9000 シリーズビジョンシステムは、HSOUT 1 ラインで [ストロボ] 信号タイプをサポートします。
  • In-Sight 70xx - 74xx シリーズビジョンシステムは、HSOUT 0 ラインで [ストロボ] 信号タイプをサポートします。
  • In-Sight Micro 8405 ビジョンシステムでは、ストロボ開始位置は [すべての行を露光] に固定されています。すべてのピクセル行が露光されたときのみ、パルス信号が出力されます。 In-Sight Micro 8405 でストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。詳細については、ローリングシャッターの操作をご参照ください。
閉じた 外部照明のトリガ (CIO-1460 のみ)

信号の立ち上がりまたは立ち下がりエッジで外部照明にトリガをかけることができます。

外部照明をトリガする信号を送信するには、次の手順に従ってください。

  1. In-Sight 5000 シリーズビジョンシステムにログオンし、CIO-1460 I/O モジュールに接続します。
  2. [画像の設定] ステップで画像取り込みトリガを定義します。 露光時間は外部照明デバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。
  3. 出力ライン HSOUT1 の [信号タイプ] を [照明制御] に設定します。
  4. [詳細] ボタンを押して、信号の [立ち上がりエッジ] または [立ち下りエッジ] でストロボにトリガをかけるように設定します。
注 :
  • 照明デバイスを正常に作動させるには、In-Sight ビジョンシステムと照明デバイスが共通のグラウンドに接続されている必要があります。
  • この出力タイプは、In-Sight 5000 ビジョンシステムシリーズを使用し、CIO-1460 I/O モジュールを設定した場合、高速出力ライン 1 (HSOUT1) でのみ有効です。


位置決めツールまたは検査ツールの結果を出力ラインに設定するには

位置決めツールまたは検査ツールの結果に基づいて信号を送信するには、次の手順に従ってください。

  1. 出力ラインを選択し、[信号タイプ] を [ジョブの結果] に設定します。
  2. [ジョブの結果] ドロップダウンメニューから、出力するツールの結果を選択します。リスト中のツールの結果は、個々のツール (Text_1 など) の　PASS/FAIL の総数を表します。ジョブの結果は、すべてのツールの PASS/FAIL を総合した結果です。ツールの結果が PASS のときは HIGH (1) になります。FAIL のときは LOW (0) です。
  3. [詳細] ボタンを押して、パルス幅および取り込み遅延を指定してください。これらの設定が指定されないときは、信号はパルスとなります。


通信

[通信] ステップは、オープンデータアクセスおよびエクスチェンジ (OPC 用) に検査の結果を定義したり、VisionView オペレータインタフェース用に EasyView を設定したり、FTP を介したり SD カードに画像を転送したり、In-Sight ビジョンシステムのネットワーク通信およびシリアル通信を設定したりすることによって、ロボットまたは PLC/モーションコントローラ (MC) などの他のデバイスとの通信を可能にします。

注 :
  • 通信ステップでのプログラミングを可能にするには、In-Sight センサをオフラインにしてください。
  • ジョブの通信プロトコルをエミュレータを使用して設定、保存した後に、In-Sight ビジョンシステムにロードして、ジョブを実行することができます。 ただし、ProfiNet および CC-Link プロトコルはエミュレータでも選択可能ですが、シミュレートできません。 これらのプロトコルは、ProfiNet または CC-Link ネットワークに接続された In-Sight ビジョンシステムで、ジョブの通信プロトコルを開発、保存する必要があります。

サポートしているプロトコル

最大 2 つまでのプロトコルをジョブに追加することができます。 プロトコルを 2 つ追加する場合、「プライマリ」プロトコル✕ 1 と、「セカンダリ」プロトコル✕ 1 を追加することができます。 例えば、[SLMP スキャナ] プロトコル (プライマリ) の追加後、[デバイスの追加] ボタンをクリックして [TCP/IP] プロトコル (セカンダリ) を追加することができます。

注 : 「プライマリ」プロトコル✕ 2 または、「セカンダリ」プロトコル✕ 2 を追加することはできません。

In-Sight ファームウェア 4.x.x

 | プライマリまたは セカンダリ | Micro 1000 シリーズ | 5000 シリーズ (5705 & 5705C を除く) | 70xx - 74xx シリーズ
CC-Link | プライマリ | X | X | X
イーサネットネイティブ | プライマリ | X | X | X
イーサネットネイティブロボット | プライマリ | X | X | X
イーサネットネイティブ文字列 | プライマリ | X | X | X
EtherNet/IP | プライマリ | X | X | X
Modbus TCP サーバ | プライマリ | X | X | X
POWERLINK | プライマリ |  |  | X
PROFINET | プライマリ | X | X | X
シリアル Kuka | プライマリ | X | X | X
シリアル Motoman | プライマリ | X | X | X
シリアルネイティブ | プライマリ | X | X | X
シリアルネイティブロボット | プライマリ | X | X | X
シリアルネイティブ文字列 | プライマリ | X | X | X
シリアルテキスト | プライマリ | X | X | X
SLMP | プライマリ | X | X | X
SLMP スキャナ | プライマリ | X | X | X
TCP/IP | セカンダリ | X | X | X
UDP | セカンダリ | X | X | X

In-Sight ファームウェア 5.x.x

 | プライマリまたは セカンダリ | 2000 シリーズ | 5705 & 5705C | 7000 Gen2 シリーズ | Micro 8000 シリーズ | 9000 シリーズ
CC-Link IE フィールド Basic | プライマリ | X | X | X | X | X
イーサネットネイティブ | プライマリ |  | X | X | X | X
イーサネットネイティブロボット | プライマリ |  | X | X | X | X
イーサネットネイティブ文字列 | プライマリ |  | X | X | X | X
EtherNet/IP | プライマリ | X | X | X | X | X
Modbus TCP サーバ | プライマリ | X | X | X | X | X
PROFINET | プライマリ | X | X | X | X | X
シリアル Kuka | プライマリ |  | X | X | X | X
シリアル Motoman | プライマリ |  | X | X | X | X
シリアルネイティブ | プライマリ | X (ベーシック) | X | X | X | X
シリアルネイティブロボット | プライマリ |  | X | X | X | X
シリアルネイティブ文字列 | プライマリ |  | X | X | X | X
シリアルテキスト | プライマリ | X | X | X | X | X
SLMP | プライマリ | X | X | X | X | X
SLMP スキャナ | プライマリ | X | X | X | X | X
TCP/IP | セカンダリ | X | X | X | X | X
UDP | セカンダリ | X | X | X | X | X

OPC サーバを介してデータを共有するには

EasyView を設定するには

FTP を介して画像を転送するには

FTP を介してデータファイルを転送したり、またはデータ文字列の追記を行うには

SD カードに画像を転送するには

SD カードにデータファイルを転送したり、またはデータ文字列の追記を行うには

デバイスの設定

Rockwell ControlLogix PLC と通信するには

Universal Robots との統合 - TCP/IP


OPC サーバを介してデータを共有するには

ジョブアプリケーションに OPC サーバを使用するほかのデバイスとの通信が含まれる場合、検査結果 (または入力データ) を有効にし、In-Sight OPC UA サーバまたは In-Sight OPC クラシックサーバにポストすることができます。

In-Sight OPC UA サーバおよび In-Sight OPC クラシックサーバは次のモデルでサポートされています。

ビジョンシステム/センサ | In-Sight OPC UA サーバサポート | In-Sight OPC クラシックサーバサポート
In-Sight Micro 1000 シリーズ | サポートしていません | 4.x.x ファームウェア
In-Sight 2000 シリーズ | 5.8.0 ファームウェア以降 | サポートしていません
In-Sight 5400 および 5600 シリーズ | サポートしていません | 4.x.x ファームウェア
In-Sight 5705 および 5705C | サポートしていません | 5.x.x ファームウェア
In-Sight 7000 シリーズ | サポートしていません | 4.x.x ファームウェア
In-Sight 7000 Gen2 シリーズ | 5.8.0 ファームウェア以降 | 5.x.x ファームウェア
In-Sight Micro 8000 シリーズ | 5.8.0 ファームウェア以降 | 5.x.x ファームウェア
In-Sight 9000 シリーズ | 5.8.0 ファームウェア以降 | 5.x.x ファームウェア
エミュレータ | サポートしていません | サポートしています

OPC タグ

OPC タグをジョブファイルに追加するには

OPC UA


OPC タグ

OPC タグはシンボリック名で、サポートされている In-Sight ビジョンシステム/センサの EasyBuilder 検査結果に追加できます。このタグは OPC UA クライアントから公開可能なため、In-Sight のジョブデータにアクセスすることができます。In-Sight OPC UA を実装するにあたり、ジョブタグとシステムタグの 2 種類の OPC タグが存在します。

OPC タグは、次のデータタイプを表すことができます。

  • ブール値:ブール値のみを保持するタグを表すために使用されます。
  • 浮動小数点:浮動小数点値のみを保持するタグを表すために使用されます。
  • 整数:整数値のみを保持するタグを表すために使用されます。

  • テキスト文字列:テキスト文字列値のみを保持するタグを表すために使用されます。

    注 :
    • 文字列は最大 256 文字までサポートします。
    • 文字列は、Unicode 表現で OPC クライアントに送信されます。

OPC タグは、読み取りまたは読み取り/書き込みのアクセスレベルを持つことができます。In-Sight ジョブファイルからデータを読み書きするOPC UAクライアントの機能は、OPC タグのアクセスレベルによって異なります。

  • 読み取り:タグの値は、OPC UA クライアントから取得のみできます。
  • 読み取り/書き込み:タグの値は、OPC UA クライアントによって取得または設定できます。


OPC タグをジョブファイルに追加するには

OPC UA をサポートするすべての In-Sight ビジョンシステム/センサには、OPC UA クライアントが使用するシステムタグが事前に定義されています。しかし、これらのタグは OPC UA クライアントからアクセスしたい値すべてを公開することはほとんどありません。このため、EasyBuilder の検査およびジョブ結果にジョブタグを追加することによって、クライアントが値を利用できるようになります。

  1. [通信] グループボックスの [OPC] を選択します。
  2. [選択中の OPC タグ] の [追加] ボタンをクリックし、[OPC タグの選択] ダイアログを開きます。
  3. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータおよびジョブ全体の結果が含まれています。ダイアログから、有効にするデータを選択します。
  4. [OK] をクリックし、変更を受け入れます。OPC タグが、[選択中の OPC タグ] に表示されます。
  5. OPC サーバを設定します。
    • OPC UA サーバを使用している場合、OPC UAをご参照ください。
    • OPC クラシックサーバを使用している場合、『In-Sight® OPC クラシックサーバヘルプ』ファイルをご参照ください。


OPC UA

OPC UA (オープンプラットフォームコミュニケーション - 統合アーキテクチャ) とは、OPC Foundation によって開発された最新の通信プロトコルで、産業用デバイスおよびシステムにプラットフォームに依存しない、安全なオープンアーキテクチャソリューションを提供します。In‑Sight の場合、ビジョンシステムまたはビジョンセンサは OPC UA サーバーとして機能し、OPC UA クライアントと直接通信できるため、追加のハードウェアは不要です。

In-Sight OPC UA サーバおよび In-Sight OPC クラシックサーバは次のモデルでサポートされています。In-Sight OPC クラシックサーバーの詳細については、『In-Sight® OPC クラシックサーバーヘルプ』ファイルをご参照ください。

ビジョンシステム/センサ | In-Sight OPC UA サーバサポート | In-Sight OPC クラシックサーバサポート
In-Sight Micro 1000 シリーズ | サポートしていません | 4.x.x ファームウェア
In-Sight 2000 シリーズ | 5.8.0 ファームウェア以降 | サポートしていません
In-Sight 5400 および 5600 シリーズ | サポートしていません | 4.x.x ファームウェア
In-Sight 5705 および 5705C | サポートしていません | 5.x.x ファームウェア
In-Sight 7000 シリーズ | サポートしていません | 4.x.x ファームウェア
In-Sight 7000 Gen2 シリーズ | 5.8.0 ファームウェア以降 | 5.x.x ファームウェア
In-Sight Micro 8000 シリーズ | 5.8.0 ファームウェア以降 | 5.x.x ファームウェア
In-Sight 9000 シリーズ | 5.8.0 ファームウェア以降 | 5.x.x ファームウェア
エミュレータ | サポートしていません | サポートしています

OPC UA クライアントは、In-Sight ビジョンシステム/センサから次のデータにアクセスできます。

  • 画像取り込み数
  • 使用中のジョブファイル名
  • オンラインステータス (ネイティブオンライン、ディスクリートオンラインおよび GUI オンラインを含む)
  • ライブビデオモードステータス

データの取得に加えて、In-Sight OPC UA サーバーは OPC UA クライアントに以下を許可します。

  • 使用中のジョブの保存
  • ジョブのロード
  • トリガ画像取り込みイベント
  • オンラインモードの切り替え
  • ライブビデオモードの切り替え
注 : 新しいジョブファイルの書き込み、セルの値の書き込み、ビジョンシステム/センサのオンライン/オフライン状態の切り替えなど、サーバーの公開タグへのアクセスを制限するのは、カスタムアプリケーション設計者の責任です。

さらに、OPC クライアントは、AddressSpace ノード (または「監視対象アイテム」) の値の変更を監視するように構成できます。これらの値の変更を常にポーリングする代わりに、ノードのサブスクリプションを作成して、これらのアイテムを監視できます。変更が検出されると、通知が生成され、サブスクリプションによって OPC UA クライアントに転送されます。監視対象アイテムでサポートされるセッション、クライアント、ノードの数は、ビジョンシステム/センサによって異なります。

ビジョンシステム/センサ | セッション/クライアント数 | AddressSpace ノード
In-Sight 2000 シリーズ | 1 つの OPC UA クライアントで 1 つのセッション。 | セッション/クライアントにつき、50 ノード/20 サブスクリプション。
In-Sight 7000 Gen2 シリーズ | 2 セッション/ 2 OPC UA クライアント | セッション/クライアントにつき、250 ノード/20 サブスクリプション。
In-Sight 8000 シリーズ | 2 セッション/ 2 OPC UA クライアント | セッション/クライアントにつき、250 ノード/20 サブスクリプション。
In-Sight 9000 シリーズ | 2 セッション/ 2 OPC UA クライアント | セッション/クライアントにつき、250 ノード/20 サブスクリプション。

OPC UA サーバの有効化

OPC UA ジョブタグとシステムタグ

OPC UA メソッド

SetSystemConfig: OPC UA 時刻同期

トラブルシューティング


OPC UA サーバの有効化

OPC UA を使用している場合、ビジョンシステム/センサの In-Sight OPC UA サーバを ON にしてから、OPC UA クライアントに接続してください。

ヒント : OPC UA タグ用に時刻同期を設定する必要がある場合、OPC UA サーバを有効にする前に SetSystemConfig OPCUA.TimeSync 拡張ネイティブモードコマンドを使用してください。詳細については、SetSystemConfig: OPC UA 時刻同期をご参照ください。
  1. [通信] グループボックスの [OPC] を選択します。

  2. [OPC UA サーバ有効] チェックボックスを ON にします。

  3. [OK] をクリックします。
  4. ダイアログが表示されたら [はい] をクリックして、ビジョンシステム/センサを再起動します。再起動後、OPC UA サーバは初期化され稼働し、検出エンドポイントが OPC UA クライアントの要求をリスンします。
  5. OPC UA クライアントを開きます。

  6. OPC UA クライアントから、エンドポイント URL を入力し、OPC UA サーバに接続します。エンドポイント URL は次のフォーマットで入力してください。<IP アドレス> はビジョンシステム/センサの IP アドレスになります。

    opc.tcp://<IP アドレス>:4840

    例: opc.tcp://192.168.0.8:4840


OPC UA ジョブタグとシステムタグ

ジョブタグはユーザ設定可能なタグで、In-Sight ジョブファイルに保存した値を表し、OPC UA クライアントに公開することができます。ジョブタグはジョブファイル内に保存されます。

システムタグはデフォルトのタグで、OPC UA をサポートするビジョンシステム/センサにおいて常に利用可能で、設定に追加することができます。システムタグはジョブファイルに保存されません。

システムタグ

アクセシビリティ

データタイプ

説明

AcquisitionCount

読み取り専用

整数

ビジョンシステム/センサの電源を ON にしたときからの、画像取り込みの数を返します。

DiscreteOnline

読み取り専用

ブール値

ディスクリート入力ライン (オンライン/オフラインタイプとして設定) が LOW (0) に設定されている場合、 FALSE を返します。そうでない場合、TRUE を返します。

GuiOnline

読み取り専用

ブール値

In-Sight Explorer GUI がオンラインモードに設定されている場合 ([センサ] メニュー > [オンライン])、TRUE を返します。

JobName

読み取り専用

文字列

ビジョンシステム/センサにロードされている使用中のジョブの名前を返します。この場合、使用中のジョブはすでに保存されている必要があります。

注 : JobName タグは読み取り専用です。ジョブファイルの名前を変更するには、SaveJobAs メソッドを使用します。詳細については、OPC UA メソッドをご参照ください。

LiveMode

読み取り/書き込み

ブール値
  • 読み取り:ビジョンシステム/センサがライブビデオモードの場合、TRUE を返します。そうでない場合、FALSE を返します。
  • 書き込み:ゼロ以外の値を LiveMode タグに書き込むことにより、ビジョンシステム/センサをライブビデオモードにします。ゼロを LiveMode タグに書き込むと、ライブモードを終了します。
注 : LiveMode タグに TRUE 値を書き込んだ後に、ビジョンシステム/センサのジョブビューが In‑Sight Explorer で開いたままの場合、In‑Sight Explorer はライブ画像を表示せず、ジョブビューステータスバーはライブビデオモードを表示しません。

NativeOnline

読み取り/書き込み

ブール値
  • 読み取り:ネイティブモードのセットオンラインコマンド "SO0" をビジョンシステム/センサに発行した場合、FALSE を返します。そうでない場合、TRUE を返します。
  • 書き込み:ゼロ以外の値を NativeOnline タグに書き込むことにより、ネイティブモードを介し、In-Sight ビジョンシステム/センサをオフラインにします (ネイティブモードのセットオンラインコマンド "SO0" を発行するのと同等)。ゼロを NativeOnline タグに書き込むと、ビジョンシステム/センサはオンラインになります (ネイティブモードのセットオンラインコマンド "SO1" を発行するのと同等)。

オンライン

読み取り専用

ブール値

次の論理「AND」を返します:(DiscreteOnline AND NativeOnline AND GuiOnline)。


OPC UA メソッド

次のデフォルトのメソッドは、OPC UA をサポートするビジョンシステム/センサにおいて常に利用可能で、設定に追加することができます。メソッドはジョブファイルに保存されません。

メソッド

アクセシビリティ

データタイプ

説明
LoadJob(filename) 読み取り/書き込み 文字列

指定したジョブをビジョンシステムにロードします。

注 :

  • 指定したジョブファイルは、ビジョンシステム/センサ上に存在する必要があります。そうでない場合、エラーを返します。

  • 大きなジョブファイルをロードするときに次のいずれかのエラーが発生した場合、ジョブロードに必要な時間が反映するように、デフォルトのタイムアウト値を変更することをご検討ください。
    • LoadJob メソッドのデフォルトのタイムアウトは 10 秒です。デフォルトの時間を超過した場合、メソッドタイムエラーが OPC UA クライアントに表示されます。ジョブは引き続きロードされ、通信も引き続き機能します。
    • 接続ウォッチドッグタイムアウトのデフォルトのタイムアウトは 5 秒です。ジョブをロードしているとき、ビジョンシステム/センサは OPC UA クライアントを更新しません。この状態が維持されデフォルトのタイムアウトを超過した場合、接続警告ウォッチドッグタイムアウトエラーが OPC UA クライアントに表示されます。ジョブがロードされると、接続は自動的に再確立され、通信は自動的に再開します。
SaveJobAs(filename) 読み取り/書き込み 文字列

使用中のジョブファイルを指定した文字列として保存します。

注 : SaveJobAs メソッドをコールするには、ビジョンシステム/センサはオフラインである必要があります。そうでない場合、エラーを返します。
TriggerManualAcquisition 読み取り/書き込み N/A

ビジョンシステム/センサ上で、手動で画像取得を開始します。
TriggerSoftEvent(index) 読み取り/書き込み 整数

ビジョンシステム/センサ上で、ソフトトリガを開始します。整数 0 ～ 7 を TriggerSoftEvent メソッドに書き込むことにより、スプレッドシート上の対応する「ソフト n」トリガイベントを開始します。n は書き込まれた整数値です。


SetSystemConfig: OPC UA 時刻同期

OPC UA タグのタイムスタンプ用時刻同期を設定します。

注 : このネイティブモードコマンドは、In-Sight 2000 ビジョンセンサでサポートされています。

入力

Syntax: EV SetSystemConfig("OPCUA.TimeSync",[TimeSyncFrequency],[InitialTimeoutSec],[TimeSyncFrequencySec],[WriteProcSet])

パラメータ

 説明

"OPCUA.TimeSync"

OPC UA のタイムスタンプ設定を参照します。
TimeSyncFrequency
  • 0 = 日付/時刻は、システムのスタートアップ時に 1 度のみ同期します。(デフォルト)
  • 1 = 日付/時刻は、TimeSyncFrequencySec パラメータ値に基づき、連続的に同期します。この設定は、高精度の時刻同期に推奨されます。
InitialTimeoutSec

日付/時刻の変更が有効になるまで OPC UA サーバーが待機する時間 (秒単位) を指定します。(デフォルト = 15 秒)

注 :
  • OPC UA サーバーは、InitialTimeoutSec で指定した時間が経過するまで起動しません。
  • ビジョンシステム/センサの設定を手動で設定し、ビジョンシステム/センサの電源を再投入したときに、SNTP サーバまたは PTP (Precision Time Protocol) 用に設定した外部デバイスを検出できない場合、初期日付/時刻設定は 1970 年 1 月 1 日 12:00:00 AM にリセットされます。この場合、InitialTimeoutSec の値を増やし、ビジョンシステム/センサの再起動後、手動で日付/時刻を設定してください。
TimeSyncFrequencySec

TimeSyncFrequency パラメータ値が 1 に設定されているときに、時刻同期の頻度を指定します。(デフォルト = 1 秒)

WriteProcSet
  • 0 = 設定は proc.set ファイルに保存されません。ビジョンシステム/センサの電源を入れ直すと、設定は失われます。 (デフォルト)
  • 1 = 設定は proc.set ファイルに保存されます。ビジョンシステム/センサの電源を入れ直しても、設定は失われません。

出力

ステータスコードの後に、結果の文字数 (バイト単位) と、結果 (XML フォーマット) が続きます。ステータスコードは次のとおりです。

ステータスコード | 説明
1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。


トラブルシューティング

問題 解決方法

UaExpert をクライアントとして使用する場合、30 秒のセッションタイムアウトが 14〜16回発生した後に、ビジョンシステムは OPC UA 要求への応答を停止し、UaExpert クライアントはビジョンシステムに接続できなくなります。

この場合、新しいクライアントおよび以前にタイムアウトしたクライアントが接続を試みると、次のエラーを受け取ります。

"Error 'BadTimeout' was returned during OpenSecureChannel" (エラー: OpenSecureChannel 中に 'BadTimeout' が返されました)

注 : この状態では、他はすべて予想通りに機能します。セッションタイムアウトが何回発生したかについては、In-Sight Explorer のセンサステータスビュー (ウィンドウ > 表示センサのステータスビュー) で確認することができます。

UaExpert サイド:

  • SecureChannelLifetime:チャネルをアクティブにする時間を決定します。(デフォルト = 1 時間。最小 = 5 分。)
  • SessionTimeout:無反応のセッションを切断するまでの、待機時間を決定します。セキュリティで保護されたチャネルは、タイムアウト後もアクティブのままであることにご注意ください。(デフォルト = 20 分。最小 = 30 秒。)
  1. 1 時間待ってから、SecureChannelLifetime をリセットしてください。
  2. SecureChannelLifetime が非常に長く、その間に多くのセッションタイムアウトがある場合、ビジョンシステム/センサを再起動します。


EasyView を設定するには

HMI アプリケーションを使用している場合、 データ表示方法をカスタマイズしたり、オペレータにデータ編集を許可するかどうかを決定したりすることができる EasyView を作成することができます。 まず、EasyBuilder で EasyView を作成し、センサのジョブに保存します。 次に、PC にインストールした VisionView PC デモまたは Web HMI アプリケーションを使用して、正しく設定されているかどうかを確認します。

EasyView を設定するには、次の手順に従ってください。

  1. [通信] グループボックスの [EasyView] を選択します。
  2. [選択中の EasyView アイテム] の [追加] ボタンを押し、[EasyView アイテムの選択] ダイアログを開きます。

  3. ダイアログには、ジョブに追加された位置決め/検査ツール、画像取り込み、およびジョブ設定のデータが含まれています。 使用するアイテムをハイライトしてから [追加] ボタンを押すか、または使用するアイテムの EasyView チェックボックスを ON にして、EasyView に追加するデータを選択してください。

    注 :
    • 順番に並んでいない複数のアイテムをまとめて選択するには、CTRL キーを押したまま各アイテムを順番にハイライトしてください。
    • 順番に並んでいる複数のアイテムをまとめて選択するには、SHIFT キーを押したままリストの最初のアイテムをハイライトし、次に最後のアイテムをハイライトしてください。

  4. [OK] をクリックし、変更を受け入れます。 ツールデータが [選択中の EasyView アイテム] に表示されます。

    注 :
    • 順番に並んでいない複数のアイテムをまとめて選択するには、CTRL キーを押したまま各アイテムを順番にハイライトしてください。
    • 順番に並んでいる複数のアイテムをまとめて選択するには、SHIFT キーを押したままリストの最初のアイテムをハイライトし、次に最後のアイテムをハイライトしてください。

  5. [編集の可否] チェックボックスを ON にすると、オペレータが VisionView オペレータインタフェースパネル上で、ツールデータを変更することができます (オプション)。

    注 : VisionView からツールデータを編集するには、読み取り/書き込み許可が必要です。
  6. [ラベルの挿入] ボタンを押して、ヘッダラベルを作成します (オプション)。 ラベルは、ツールデータをグループ化するのに有用です。
  7. [キャプション] は、HMI アプリケーションで表示される名前です。 デフォルトの [キャプション] を変更するには、ツールバーまたはラベルの [キャプション] フィールドをクリックして、新しい名前を入力します。 <ENTER> キーを押すか、キャプションフィールドの外をクリックして、変更を受け入れます。キャンセルするには、<ESCAPE> キーを押します。
  8. [上へ] または [下へ] ボタンを押して、ツールデータまたはラベルの順番を変更することができます。

  9. ジョブファイルに保存します。

    注 : [通信] ステップから他のステップに移るときにも、EasyView 設定は自動的に In-Sight センサに保存されます。

  10. EasyView がどのように表示されるかをプレビューするには、VisionView PC デモアプリケーションまたは Web HMI を起動してください。

    注 : ご使用の PC に VisionView PC デモがインストールされている場合、デフォルトのインストールディレクトリは、C:\Program Files\Cognex\VisionView\PC Demo x.x.x となります。 VisionView PC デモがインストールされていない場合、VisionView サポートサイトからアプリケーションをダウンロードできます。
  11. VisionView PC デモアプリケーションまたは Web HMI を起動したら、[接続] ステップでセンサを [切断] してください。

  12. Web HMI を使用している場合、EasyView ペインで EasyView をプレビューすることができます。

    VisionView PC デモを使用している場合、[選択中のセンサ] リストに使用中のセンサを追加してから、実行モードに入ります。[表示切り替え] ボタンを押して、EasyView をプレビューします。

    注 :
    • EasyView をプレビューするには、まず [HMI ビューの設定] ダイアログの [EasyView] オプションを ON にします。
    • VisionView PC Demo は、45 分で自動的にタイムアウトします。 すべての機能を使用することが可能で、タイムアウトすることのないライセンスバージョンを購入するには、VisionView PC ソフトウェアをインストールして下さい。VisionView PC ソフトウェアは、VisionView サポートサイトからダウンロードすることができます。
    • VisionView PC デモアプリケーションのルック&フィールは、VisionView オペレータインタフェースパネルとは多少異なります。
    • エミュレータにログオン中に EasyView をプレビューするには、まず、VisionView アプリケーションの [選択中のセンサ] リストに手動でエミュレータを追加する必要があります。


FTP を介して画像を転送するには

ネットワーク上の FTP サーバに画像を転送するように、In-Sight ビジョンシステムを設定することができます。 このように設定すると、アーカイブ用に取り込んだ画像を (ツールまたはジョブの PASS/FAIL 状態に基づいて) 転送して、他のデバイスに保存することができます。 また、保存した画像を確認することによって、生産過程で発生した問題の原因究明に役立てることもできます。

FTP 接続を設定するには、次の手順に従ってください。

  1. [通信] グループボックスの [FTP] を選択します。
  2. [画像] タブを選択します。

  3. [追加] ボタンを押してエントリを追加し、画像転送のパラメータを設定します。

    注 : 1 つのジョブで、複数の画像を転送させることもできます。
  4. [設定] タブを選択して FTP サーバを設定します。
  5. In-Sight ビジョンシステムをオンラインにします。 画像転送を実行するには、ビジョンシステムをオンラインにする必要があります。オフライン時には画像は転送できません。
  6. ビジョンシステムの画像取り込みをトリガします。 画像を取り込むたびに、画像ファイルを転送し、パラメータで指定したホストに保存します。画像ファイルは、[ファイルフォーマット] パラメータで BMP または JPG を指定することができます。
注 :
  • [転送条件] を [なし] (デフォルト) に設定している場合、画像を取り込むたびに、画像ファイルを転送します。 [転送条件] を [なし] 以外に設定している場合、指定のイベントが発生するたびに、画像ファイルを転送します。 例えば、[転送条件] を [ジョブ.FAIL] に設定している場合、ジョブが FAIL するたびに、画像ファイルを転送し、FTP サーバに保存します。
  • In-Sight エミュレータを FTP サーバとして使用している場合、デフォルトで、ファイルは次のエミュレータフォルダに書き込まれます([ProgramData]\Cognex\In-Sight\Emulators\x.x.x)。 このディレクトリ以外のユーザ指定のロケーションにもファイルを書き込むことができます(FTP ルートディレクトリ)。 FTP ルートディレクトリの詳細については、[オプション] ダイアログトピック (エミュレーションパネル) をご参照ください。

[画像] タブ

転送する画像、画像フォーマット、画像をいつ、どこに転送するかを定義するパラメータを設定します。

閉じた [有効] チェックボックス

画像転送操作の実行可否 (デフォルトは ON) を定義したり、VisionView オペレータインタフェースパネルに表示し、オペレータによって編集可能な EasyView アイテム (WriteImageFTP_1.ツール_有効など) として公開するかどうかを定義します。

注 : 有効にするには、[有効] チェックボックスを ON にしてください。 テーブル内で設定できるのは、このパラメータのみです。
閉じた 名前

転送する画像の名前を定義します。この名前は、[結果の設定] の各ステップ ([入力/出力]、[出力]、[通信]) で参照されます。デフォルト名は、WriteImageFtp_1 で、末尾の番号は操作の増加に応じて増加します。 転送条件などに合わせて適切な名前に変更してください。

閉じた 転送条件

ツールの PASS または FAIL 時、または入力を受信したときなど、いつデータを FTP サーバに送信するかを定義します。 デフォルトは、[なし] です。[有効] チェックボックスが ON の場合、画像を取り込むたびにデータを転送します。 [有効] チェックボックスが OFF になっている場合、または参照されたツールが無効になっている場合は、転送は実行されません。

閉じた デバイス

FTP サーバを定義します。FTP サーバは [設定] タブで定義され、転送されるデータを受信します。 デフォルトでは、[デバイス 1] が選択されています。

閉じた ファイルフォーマット

転送画像のファイルフォーマットを定義します。選択肢は、[BMP] (Windows ビットマップフォーマット) または [JPG] (標準エンコード JPEG フォーマット) です。 デフォルトでは、[BMP] が選択されています。

閉じた 画像サイズ

転送画像の解像度を定義します。選択肢は、[フル (1/1)]、[ハーフ(1/2)]、[クォーター (1/4)] です。 デフォルトでは、[フル (1/1)] が選択されています。

閉じた グラフィックを含む

[位置決め] および [検査] ツール用に、オーバレイグラフィックスのデータを含む SVG ファイルを作成するかどうかを定義します。 SVG ファイルおよび画像ファイルを表示するには、SVG ファイルタイプをサポートする (Microsoft Internet Explorer 9.0 など) ウェブブラウザを使用して、SVG ファイルおよび画像ファイルを開きます。 SVG ファイルには、このファイルに関連する取得画像へのリンクが含まれており、ブラウザで SVG ファイルを開くと、このリンクを使用して、取得画像と共にオーバレイグラフィックスを表示します。

注 :
  • 「グラフィックを含む」を有効にするには、右側のグループボックス内、[グラフィックを含む] チェックボックスを ON にしてください。 テーブル内の [グラフィックを含む] チェックボックスは、読み取り専用です。
  • ON にした場合、SVG ファイルは [ファイル名] パラメータで指定した名前を使用します。
  • [設定] タブの [ホスト名] パラメータを In-Sight エミュレータに設定した場合、svg ファイルはエミュレータディレクトリ ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x) に保存され、[In-Sight のファイル]ペインに表示されます。
  • [結果表示のオプション] ダイアログの [ツールのオプション] を使用して、[位置決め] および [検査] ツールのオーバレイグラフィックスを非表示に設定している場合、SVG 画像は出力されません。 デフォルトでは、すべてのツールはオーバレイグラフィックスを表示します。
  • ウェブブラウザといったサードパーティーのアプリケーションを使用してグラフィックスを表示するため、オーバレイグラフィックスのデータは、ピクセル単位で正確に一致しません。
  • In-Sight ファームウェアは、すべての SVG および画像ファイルぺアの送信を保証しません。 In-Sight ビジョンシステムがオーバーロードしている場合、検査や画像取得をミスしないよう、SVG/画像ファイルの片方、または両方の送信をスキップします。
閉じた ファイル名プレビュー

転送する画像ファイルの名前のプレビューを表示します。デフォルトでは、Image999 が表示されます。 ファイル名は、[デフォルトファイル名]、[リンクの追加]、[タイムスタンプの追加]、[カウンターの追加] パラメータを使用してカスタマイズすることができます。

注 :
  • 最低 1 つ以上のパラメータを定義する必要があります。 [デフォルトファイル名] が空白で、[リンクの追加]、[タイムスタンプの追加]、[カウンターの追加] パラメータが OFF の場合、ファイルの転送に失敗します。
  • パラメータの順番は変更することはできません。
  • [カウンターの追加] パラメータを ON にすると、カウンターの最大値が [ファイル名プレビュー] に常に表示されます。
閉じた デフォルトファイル名

転送する画像ファイルの名前を定義します。デフォルトは「Image」です。ロングファイル名がサポートされています。

閉じた リンクの追加

選択したツールをリンクして、その結果を転送するファイルの名前に追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。

注 :
  • リンクされているツールの文字列に、<、>,、:、"、/、\、|、? または *が含まれている場合、ファイルの転送に失敗します。
  • リンク可能なツールを EasyBuilder が検出できない場合、[リンクの追加] チェックボックスはグレーアウトされます。
  • ジョブからリンクが削除されると、[リンクの追加] チェックボックスは自動的に OFF となります。
  • [リンクの追加] チェックボックスを ON にし、ドロップダウンリストから [未定義] を選択すると、予期しない結果が起こることがあります。
閉じた タイムスタンプの追加

転送するファイルの名前に、タイムスタンプを追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。 ON にすると、ドロップダウンリストから次の定義済タイムスタンプフォーマットを選択することができます: MMDDYY、YYYYMMDD_HHMMSS、DDMMYY_HHMMSS、MM-DD-YYYY_HH.MM.SS、HHMMSS, YYMMDD_HHMMSS または YYDDMM_HHMMSS

注 : In-Sight ビジョンシステムの日付/時刻は、[日付/時刻の設定] ダイアログを使用して設定することができます。
閉じた カウンターの追加

転送するファイルの名前に、カウンターを追加するかどうかを定義します。デフォルトは、ON です。 ON にすると、カウンターの最大値を指定することができます (0～9999999; デフォルト = 999)。 各画像ファイルが転送されるごとにカウンタが 1 つ増加します。 カウンタが最大値に達するとリセットされ、出力先のシステムにある画像ファイルは同じ名前の新しいファイルで上書きされます。

閉じた [追加] ボタン

転送操作をリストに追加します。

閉じた [削除] ボタン

転送操作をリストから削除します。 1 度に削除できるのは、転送操作 1 つのみです。

閉じた [すべてのカウンターをリセット] ボタン

リストにある画像転送の [ファイル名] に追加した数値を 000 にリセットします。

[設定] タブ

[設定] タブでは、パラメータを使用して 2 台の出力デバイスを定義することができます。 出力先デバイスには、In-Sight エミュレータや、ネットワーク上で FTP サーバとして動作するホストがあります。

閉じた ホスト名

出力先デバイスの FTP サーバのホスト名 (または IP アドレス) を定義します。

注 :
  • 無効な [ホスト名] を指定した場合、最大 30 秒後に接続はタイムアウトします。

  • [ホスト名] または [ユーザ名] を指定している場合、名前の前後にスペースを使用しないようにしてください。 [ホスト名] または [ユーザ名] 設定の前後にスペースがある場合、画像エクスポートに失敗し、指定したサーバに画像を書き込むことができません。

  • FTP サーバがインストールされている PC が他にある場合、保存場所を選択することができます。 In-Sight Explorer ソフトウェアは FTP サーバとして機能するため、 サードパーティーの FTP サーバを使用している場合、In-Sight Explorer を閉じる必要があります。 FTP サーバが動作していないのであれば、In-Sight Explorer を動作させる必要があります。 サードパーティーの FTP サーバを使用している場合、ホスト名のパラメータに PC の IP アドレスを使用してください。
  • FTP サーバ接続のポート番号を変更するには、ホスト名 (または IP アドレス)、コロン (:)、新しいポート番号の順に追記します。 例えば、現在のホスト名が PRODUCTION1 である場合、ポート番号をデフォルト (ポート 21) からポート 34 に変更するには、ホスト名パラメータに PRODUCTION1:34 と指定します。
閉じた ユーザ名

出力先デバイスの FTP サーバ用に有効なユーザ名を定義します。ユーザ名には、最大 255 文字まで使用できます。 ユーザ名は、画像ファイルを転送する In-Sight ビジョンシステム上に存在する必要はありません。

閉じた パスワード

出力デバイスの FTP サーバ用に有効なパスワードを定義します。 パスワードは最大 20 文字で、大文字と小文字の区別があります。

注 :
  • セキュリティの目的から、入力されたパスワードは、フィールド内では "*" の表示でマスクされます。
  • パスワードは、暗号化されたフォーマットでジョブファイルに保存されます。
閉じた 接続タイプ

画像転送の接続タイプを定義します。選択肢は、[標準 FTP]、[SFTP]、[三菱 GOT] です。 [SFTP] は、ファイル転送を保護し、SFTP アプリケーションとともに使用されます。[三菱 GOT] は、三菱 GOT 表示器での画像表示をサポートします。

注 : [設定] タブの [接続タイプ] パラメータを [三菱 GOT] に設定した場合、最良の画質で表示するために [ファイルフォーマット] パラメータは [JPG] に設定してください。
閉じた [FTP の設定] ボタン

[FTP の設定] ダイアログを開きます。

注 : In-Sight センサ間ですべての FTP 接続が行われる In-Sight 専用のローカルネットワークでは、通常、デフォルト設定を変える必要はありません。 ただし、In-Sight ビジョンシステムとほかのネットワークデバイスの間や、別のネットワークの In-Sight センサとの間で FTP 接続が必要になる場合は、デフォルトの FTP 設定を変更しなければならないことがあります。
閉じた 最終ネットワークエラー

転送中にエラーが発生した場合、エラーの原因を示すテキストを表示します。 画像のトリガなど、転送条件発生のイベントはファイルタブで指定されます。フィールドを更新するには、In-Sight ビジョンシステムをオンラインにする必要があります。


FTP を介してデータファイルを転送したり、またはデータ文字列の追記を行うには

ネットワーク上の FTP サーバにデータファイルを転送するように、In-Sight ビジョンシステムを設定することができます。 この機能は、データ結果のログ作成に使用されます。 このログはファイルで参照できます。

FTP 接続を設定するには、次の手順に従ってください。

  1. [通信] グループボックスの [FTP] を選択します。
  2. [ファイル] タブを選択します。

  3. [追加] ボタンを押してエントリを追加し、転送のパラメータを設定します。

    注 : 1 つのジョブで、複数のファイルを転送させることもできます。
  4. [設定] タブを選択して FTP サーバを設定します。
  5. In-Sight ビジョンシステムをオンラインにします。 データ転送を実行するには、ビジョンシステムをオンラインにする必要があります。オフライン時にはデータは転送できません。
  6. ビジョンシステムをトリガします。 トリガのたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。ファイルは、[設定] タブで指定した FTP サーバに保存されます。
注 :
  • [転送条件] を [なし] (デフォルト) に設定している場合、画像を取り込むたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。 [転送条件] を [なし] 以外に設定している場合、指定のイベントが発生するたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。 例えば、[転送条件] を [ジョブ.FAIL] に設定している場合、ジョブが FAIL するたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。
  • In-Sight エミュレータを FTP サーバとして使用している場合、デフォルトで、ファイルは次のエミュレータフォルダに書き込まれます([ProgramData]\Cognex\In-Sight\Emulators\x.x.x)。 このディレクトリ以外のユーザ指定のロケーションにもファイルを書き込むことができます(FTP ルートディレクトリ)。 FTP ルートディレクトリの詳細については、[オプション] ダイアログトピック (エミュレーションパネル) をご参照ください。

[ファイル] タブ

転送するデータ、データフォーマット、データをいつ、どこに転送するかを定義するパラメータを設定します。

閉じた [有効] チェックボックス

転送操作の実行可否 (デフォルトは ON) を定義したり、VisionView オペレータインタフェースパネルに表示し、オペレータによって編集可能な EasyView アイテム (WriteIFtp_1.ツール_有効など) として公開するかどうかを定義します。

注 : 有効にするには、[有効] チェックボックスを ON にしてください。 テーブル内で設定できるのは、このパラメータのみです。
閉じた 名前

転送するデータの名前を定義します。この名前は、[結果の設定] の各ステップ ([入力/出力]、[出力]、[通信]) で参照されます。デフォルト名は、WriteFtp_1 で、末尾の番号は操作の増加に応じて増加します。 転送条件などに合わせて適切な名前に変更してください。

閉じた 転送条件

ツールの PASS または FAIL 時、または入力を受信したときなど、いつデータを FTP サーバに送信するかを定義します。 デフォルトは、[なし] です。[有効] チェックボックスが ON の場合、画像を取り込むたびにデータを転送します。 [有効] チェックボックスが OFF になっている場合、または参照されたツールが無効になっている場合は、転送は実行されません。

閉じた デバイス

FTP サーバを定義します。FTP サーバは [設定] タブで定義され、転送されるデータを受信します。 デフォルトでは、[デバイス 1] が選択されています。

閉じた ファイルタイプ

転送ファイルのフォーマットを定義します。選択肢は、Text、HTML (デフォルト)、XML または CSV です。

閉じた 書き込みタイプ ([上書き] または [追加])

データをファイルに書き込む方法を指定します。

  • 上書き: ファイル内のデータを上書きします。
  • 追加: ファイルの最後にデータ文字列を追記します。
閉じた ファイルコンテンツ/[カスタムフォーマット] ボタン

ファイルに書き込むデータを [フォーマット文字列] ダイアログを使用して定義します。

閉じた ファイル名プレビュー

転送するファイルの名前のプレビューを表示します。デフォルトでは、「File」が表示されます。 ファイル名は、[デフォルトファイル名]、[リンクの追加] および [タイムスタンプの追加] パラメータを使用してカスタマイズすることができます。

注 :
  • 最低 1 つ以上のパラメータを定義する必要があります。 [デフォルトファイル名] が空白で、[リンクの追加] および [タイムスタンプの追加] パラメータが OFF の場合、ファイルの転送に失敗します。
  • パラメータの順番は変更することはできません。
閉じた デフォルトファイル名

転送するファイルの名前を定義します。デフォルトは「File」です。 ロングファイル名がサポートされています。

閉じた リンクの追加

選択したツールをリンクして、その結果を転送するファイルの名前に追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。

注 :
  • リンクされているツールの文字列に、<、>,、:、"、/、\、|、? または *が含まれている場合、ファイルの転送に失敗します。
  • リンク可能なツールを EasyBuilder が検出できない場合、[リンクの追加] チェックボックスはグレーアウトされます。
  • ジョブからリンクが削除されると、[リンクの追加] チェックボックスは自動的に OFF となります。
  • [リンクの追加] チェックボックスを ON にし、ドロップダウンリストから [未定義] を選択すると、予期しない結果が起こることがあります。
閉じた タイムスタンプの追加

転送するファイルの名前に、タイムスタンプを追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。 ON にすると、ドロップダウンリストから次の定義済タイムスタンプフォーマットを選択することができます: MMDDYY、YYYYMMDD_HHMMSS、DDMMYY_HHMMSS、MM-DD-YYYY_HH.MM.SS、HHMMSS, YYMMDD_HHMMSS または YYDDMM_HHMMSS

注 : In-Sight ビジョンシステムの日付/時刻は、[日付/時刻の設定] ダイアログを使用して設定することができます。
閉じた [追加] ボタン

転送操作をリストに追加します。

閉じた [削除] ボタン

転送操作をリストから削除します。 1 度に削除できるのは、転送操作 1 つのみです。

[設定] タブ

[設定] タブでは、パラメータを使用して 2 台の出力デバイスを定義することができます。 出力先デバイスには、In-Sight エミュレータや、ネットワーク上で FTP サーバとして動作するホストがあります。

閉じた ホスト名

出力先デバイスの FTP サーバのホスト名 (または IP アドレス) を定義します。

注 :
  • 無効な [ホスト名] を指定した場合、最大 30 秒後に接続はタイムアウトします。

  • [ホスト名] または [ユーザ名] を指定している場合、名前の前後にスペースを使用しないようにしてください。 [ホスト名] または [ユーザ名] 設定の前後にスペースがある場合、画像エクスポートに失敗し、指定したサーバに画像を書き込むことができません。

  • FTP サーバがインストールされている PC が他にある場合、保存場所を選択することができます。 In-Sight Explorer ソフトウェアは FTP サーバとして機能するため、 サードパーティーの FTP サーバを使用している場合、In-Sight Explorer を閉じる必要があります。 FTP サーバが動作していないのであれば、In-Sight Explorer を動作させる必要があります。 サードパーティーの FTP サーバを使用している場合、ホスト名のパラメータに PC の IP アドレスを使用してください。
  • FTP サーバ接続のポート番号を変更するには、ホスト名 (または IP アドレス)、コロン (:)、新しいポート番号の順に追記します。 例えば、現在のホスト名が PRODUCTION1 である場合、ポート番号をデフォルト (ポート 21) からポート 34 に変更するには、ホスト名パラメータに PRODUCTION1:34 と指定します。
閉じた ユーザ名

出力先デバイスの FTP サーバ用に有効なユーザ名を定義します。ユーザ名には、最大 255 文字まで使用できます。 ユーザ名は、画像ファイルを転送する In-Sight ビジョンシステム上に存在する必要はありません。

閉じた パスワード

出力デバイスの FTP サーバ用に有効なパスワードを定義します。 パスワードは最大 20 文字で、大文字と小文字の区別があります。

注 :
  • セキュリティの目的から、入力されたパスワードは、フィールド内では "*" の表示でマスクされます。
  • パスワードは、暗号化されたフォーマットでジョブファイルに保存されます。
閉じた 接続タイプ

画像転送の接続タイプを定義します。選択肢は、[標準 FTP]、[SFTP]、[三菱 GOT] です。 [SFTP] は、ファイル転送を保護し、SFTP アプリケーションとともに使用されます。[三菱 GOT] は、三菱 GOT 表示器での画像表示をサポートします。

注 : [設定] タブの [接続タイプ] パラメータを [三菱 GOT] に設定した場合、最良の画質で表示するために [ファイルフォーマット] パラメータは [JPG] に設定してください。
閉じた [FTP の設定] ボタン

[FTP の設定] ダイアログを開きます。

注 : In-Sight センサ間ですべての FTP 接続が行われる In-Sight 専用のローカルネットワークでは、通常、デフォルト設定を変える必要はありません。 ただし、In-Sight ビジョンシステムとほかのネットワークデバイスの間や、別のネットワークの In-Sight センサとの間で FTP 接続が必要になる場合は、デフォルトの FTP 設定を変更しなければならないことがあります。
閉じた 最終ネットワークエラー

転送中にエラーが発生した場合、エラーの原因を示すテキストを表示します。 画像のトリガなど、転送条件発生のイベントはファイルタブで指定されます。フィールドを更新するには、In-Sight ビジョンシステムをオンラインにする必要があります。


SD カードに画像を転送するには

In-Sight ビジョンシステムにイントールされた SD カードに画像を転送するように、In-Sight ビジョンシステムを設定することができます。 このように設定すると、アーカイブ用に取り込んだ画像を (ツールまたはジョブの PASS/FAIL 状態に基づいて) 転送して保存することができます。 また、保存した画像を確認することによって、生産過程で発生した問題の原因究明に役立てることもできます。

注 : この機能は SD カードがインストールされた In-Sight ビジョンシステムのみでサポートされています。

SD カードに画像を送るには

  1. [通信] グループボックスの [SD カード] を選択します。
  2. [画像] タブを選択します。

  3. [追加] ボタンを押してエントリを追加し、画像転送のパラメータを設定します。

    注 : 1 つのジョブで、複数の画像を転送させることもできます。
  4. In-Sight ビジョンシステムをオンラインにします。 画像転送を実行するには、ビジョンシステムをオンラインにする必要があります。オフライン時には画像は転送できません。

  5. ビジョンシステムの画像取り込みをトリガします。 画像を取り込むたびに、画像ファイルを転送し、ビジョンシステムにインストールされた SD カードに保存します。画像ファイルは、[ファイルフォーマット] パラメータで BMP または JPG を指定することができます。

    注 : [転送条件] を [なし] (デフォルト) に設定している場合、画像を取り込むたびに、画像ファイルを転送します。 [転送条件] を [なし] 以外に設定している場合、指定のイベントが発生するたびに、画像ファイルを転送します。 例えば、[転送条件] を [ジョブ.FAIL] に設定している場合、ジョブが FAIL するたびに、画像ファイルを転送し、FTP サーバに保存します。

コントロール

閉じた [有効] チェックボックス

画像転送操作の実行可否 (デフォルトは ON) を定義したり、VisionView オペレータインタフェースパネルに表示し、オペレータによって編集可能な EasyView アイテム (WriteImageLocal_1.ツール_有効など) として公開するかどうかを定義します。

注 : 有効にするには、[有効] チェックボックスを ON にしてください。 テーブル内で設定できるのは、このパラメータのみです。
閉じた 名前

転送する画像の名前を定義します。この名前は、[結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。デフォルト名は、WriteImageLocal_1 で、末尾の番号は操作の増加に応じて増加します。 転送条件などに合わせて適切な名前に変更してください。

閉じた 転送条件

ツールの PASS または FAIL 時、または入力を受信したときなど、いつ画像を SD カードに送信するかを定義します。 デフォルトは、[なし] です。[有効] チェックボックスが ON の場合、画像を取り込むたびに画像を転送します。 [有効] チェックボックスが OFF になっている場合、または参照されたツールが無効になっている場合は、画像転送は実行されません。

注 : 画像取り込みのたびに画像を転送するなど、特定の転送条件を高頻度で実行する場合、In-Sight ビジョンシステムの画像キューが一杯になり、その他の画像転送操作が実行不可能となって、すべての画像が転送されないことがあります。
閉じた ファイルフォーマット

転送画像のファイルフォーマットを定義します。選択肢は、[BMP] (Windows ビットマップフォーマット) または [JPG] (標準エンコード JPEG フォーマット) です。 デフォルトでは、[BMP] が選択されています。

閉じた 画像サイズ

転送画像の解像度を定義します。選択肢は、[フル (1/1)]、[ハーフ(1/2)]、[クォーター (1/4)] です。 デフォルトでは、[フル (1/1)] が選択されています。

閉じた グラフィックを含む

[位置決め] および [検査] ツール用に、オーバレイグラフィックスのデータを含む SVG ファイルを作成するかどうかを定義します。 SVG ファイルおよび画像ファイルを表示するには、SVG ファイルタイプをサポートする (Microsoft Internet Explorer 9.0 など) ウェブブラウザを使用して、SVG ファイルおよび画像ファイルを開きます。 SVG ファイルには、このファイルに関連する取得画像へのリンクが含まれており、ブラウザで SVG ファイルを開くと、このリンクを使用して、取得画像と共にオーバレイグラフィックスを表示します。

注 :
  • 「グラフィックを含む」を有効にするには、右側のグループボックス内、[グラフィックを含む] チェックボックスを ON にしてください。 テーブル内の [グラフィックを含む] チェックボックスは、読み取り専用です。
  • ON にした場合、SVG ファイルは [ファイル名] パラメータで指定した名前を使用します。
  • [設定] タブの [ホスト名] パラメータを In-Sight エミュレータに設定した場合、svg ファイルはエミュレータディレクトリ ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x) に保存され、[In-Sight のファイル]ペインに表示されます。
  • [結果表示のオプション] ダイアログの [ツールのオプション] を使用して、[位置決め] および [検査] ツールのオーバレイグラフィックスを非表示に設定している場合、SVG 画像は出力されません。 デフォルトでは、すべてのツールはオーバレイグラフィックスを表示します。
  • ウェブブラウザといったサードパーティーのアプリケーションを使用してグラフィックスを表示するため、オーバレイグラフィックスのデータは、ピクセル単位で正確に一致しません。
  • In-Sight ファームウェアは、すべての SVG および画像ファイルぺアの送信を保証しません。 In-Sight ビジョンシステムがオーバーロードしている場合、検査や画像取得をミスしないよう、SVG/画像ファイルの片方、または両方の送信をスキップします。
閉じた ファイル名プレビュー

転送する画像ファイルの名前のプレビューを表示します。デフォルトでは、Image999 が表示されます。 ファイル名は、[デフォルトファイル名]、[リンクの追加]、[タイムスタンプの追加]、[カウンターの追加] パラメータを使用してカスタマイズすることができます。

注 :
  • 最低 1 つ以上のパラメータを定義する必要があります。 [デフォルトファイル名] が空白で、[リンクの追加]、[タイムスタンプの追加]、[カウンターの追加] パラメータが OFF の場合、ファイルの転送に失敗します。
  • パラメータの順番は変更することはできません。
  • [カウンターの追加] パラメータを ON にすると、カウンターの最大値が [ファイル名プレビュー] に常に表示されます。
閉じた デフォルトファイル名

転送する画像ファイルの名前を定義します。デフォルトは「Image」です。ロングファイル名がサポートされています。

閉じた リンクの追加

選択したツールをリンクして、その結果を転送するファイルの名前に追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。

注 :
  • リンクされているツールの文字列に、<、>,、:、"、/、\、|、? または *が含まれている場合、ファイルの転送に失敗します。
  • リンク可能なツールを EasyBuilder が検出できない場合、[リンクの追加] チェックボックスはグレーアウトされます。
  • ジョブからリンクが削除されると、[リンクの追加] チェックボックスは自動的に OFF となります。
  • [リンクの追加] チェックボックスを ON にし、ドロップダウンリストから [未定義] を選択すると、予期しない結果が起こることがあります。
閉じた タイムスタンプの追加

転送するファイルの名前に、タイムスタンプを追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。 ON にすると、ドロップダウンリストから次の定義済タイムスタンプフォーマットを選択することができます: MMDDYY、YYYYMMDD_HHMMSS、DDMMYY_HHMMSS、MM-DD-YYYY_HH.MM.SS、HHMMSS, YYMMDD_HHMMSS または YYDDMM_HHMMSS

注 : In-Sight ビジョンシステムの日付/時刻は、[日付/時刻の設定] ダイアログを使用して設定することができます。
閉じた カウンターの追加

転送するファイルの名前に、カウンターを追加するかどうかを定義します。デフォルトは、ON です。 ON にすると、カウンターの最大値を指定することができます (0～9999999; デフォルト = 999)。 各画像ファイルが転送されるごとにカウンタが 1 つ増加します。 カウンタが最大値に達するとリセットされ、出力先のシステムにある画像ファイルは同じ名前の新しいファイルで上書きされます。

閉じた [追加] ボタン

転送操作をリストに追加します。

閉じた [削除] ボタン

転送操作をリストから削除します。 1 度に削除できるのは、転送操作 1 つのみです。

閉じた [すべてのカウンターをリセット] ボタン

リストにある画像転送の [ファイル名] に追加した数値を 000 にリセットします。


SD カードにデータファイルを転送したり、またはデータ文字列の追記を行うには

SD カードにデータファイルを転送したり、またはデータ文字列の追記を行うように、In-Sight ビジョンシステムを設定することができます。 この機能は、データ結果のログ作成に使用されます。 このログはファイルで参照できます。

注 : この機能は SD カードがインストールされた In-Sight ビジョンシステムのみでサポートされています。

SD カードにデータファイルを転送したり、またはデータ文字列の追記を行うには:

  1. [通信] グループボックスの [SD カード] を選択します。
  2. [ファイル] タブを選択します。

  3. [追加] ボタンを押してエントリを追加し、画像転送のパラメータを設定します。

    注 : 1 つのジョブで、複数のファイルを転送させることもできます。
  4. In-Sight ビジョンシステムをオンラインにします。 データ転送を実行するには、ビジョンシステムをオンラインにする必要があります。オフライン時にはデータは転送できません。

  5. ビジョンシステムをトリガします。 トリガのたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。ファイルは、SD カードに保存されます。

    注 : [転送条件] を [なし] (デフォルト) に設定している場合、画像を取り込むたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。 [転送条件] を [なし] 以外に設定している場合、指定のイベントが発生するたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。 例えば、[転送条件] を [ジョブ.FAIL] に設定している場合、ジョブが FAIL するたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します

コントロール

閉じた [有効] チェックボックス

転送操作の実行可否 (デフォルトは ON) を定義したり、VisionView オペレータインタフェースパネルに表示し、オペレータによって編集可能な EasyView アイテム (WriteILocal_1.ツール_有効など) として公開するかどうかを定義します。

注 : 有効にするには、[有効] チェックボックスを ON にしてください。 テーブル内で設定できるのは、このパラメータのみです。
閉じた 名前

転送するデータの名前を定義します。この名前は、[結果の設定] の各ステップ ([入力/出力]、[出力]、[通信]) で参照されます。デフォルト名は、WriteLocal_1 で、末尾の番号は操作の増加に応じて増加します。 転送条件などに合わせて適切な名前に変更してください。

閉じた 転送条件

ツールの PASS または FAIL 時、または入力を受信したときなど、いつ画像を SD カードに送信するかを定義します。 デフォルトは、[なし] です。[有効] チェックボックスが ON の場合、画像を取り込むたびにデータを転送します。 [有効] チェックボックスが OFF になっている場合、または参照されたツールが無効になっている場合は、転送は実行されません。

閉じた ファイルタイプ

転送ファイルのフォーマットを定義します。選択肢は、Text、HTML (デフォルト)、XML または CSV です。

閉じた 書き込みタイプ ([上書き] または [追加])

データをファイルに書き込む方法を指定します。

  • 上書き: ファイル内のデータを上書きします。
  • 追加: ファイルの最後にデータ文字列を追記します。
閉じた ファイルコンテンツ/[カスタムフォーマット] ボタン

ファイルに書き込むデータを [フォーマット文字列] ダイアログを使用して定義します。

閉じた ファイル名プレビュー

転送するファイルの名前のプレビューを表示します。デフォルトでは、「File」が表示されます。 ファイル名は、[デフォルトファイル名]、[リンクの追加] および [タイムスタンプの追加] パラメータを使用してカスタマイズすることができます。

注 :
  • 最低 1 つ以上のパラメータを定義する必要があります。 [デフォルトファイル名] が空白で、[リンクの追加] および [タイムスタンプの追加] パラメータが OFF の場合、ファイルの転送に失敗します。
  • パラメータの順番は変更することはできません。
閉じた デフォルトファイル名

転送するファイルの名前を定義します。デフォルトは「File」です。 ロングファイル名がサポートされています。

閉じた リンクの追加

選択したツールをリンクして、その結果を転送するファイルの名前に追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。

注 :
  • リンクされているツールの文字列に、<、>,、:、"、/、\、|、? または *が含まれている場合、ファイルの転送に失敗します。
  • リンク可能なツールを EasyBuilder が検出できない場合、[リンクの追加] チェックボックスはグレーアウトされます。
  • ジョブからリンクが削除されると、[リンクの追加] チェックボックスは自動的に OFF となります。
  • [リンクの追加] チェックボックスを ON にし、ドロップダウンリストから [未定義] を選択すると、予期しない結果が起こることがあります。
閉じた タイムスタンプの追加

転送するファイルの名前に、タイムスタンプを追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。 ON にすると、ドロップダウンリストから次の定義済タイムスタンプフォーマットを選択することができます: MMDDYY、YYYYMMDD_HHMMSS、DDMMYY_HHMMSS、MM-DD-YYYY_HH.MM.SS、HHMMSS, YYMMDD_HHMMSS または YYDDMM_HHMMSS

注 : In-Sight ビジョンシステムの日付/時刻は、[日付/時刻の設定] ダイアログを使用して設定することができます。
閉じた [追加] ボタン

転送操作をリストに追加します。

閉じた [削除] ボタン

転送操作をリストから削除します。 1 度に削除できるのは、転送操作 1 つのみです。


デバイスの設定

ロボットや PLC などの外部デバイスとデータ通信するには、まず In-Sight センサのネットワークおよびシリアル通信設定を定義する必要があります。

  • PLC/モーションコントローラ と通信するには
  • ロボットと通信するには
  • 三菱電機社製デバイスと通信するには
  • Modbus TCP 上で通信するには
  • TCP/IP 上で通信するには
  • UPD 上で通信するには
  • POWERLINK 上で通信するには
  • 識別ツールにデータを入力するには
  • 出力文字列をフォーマットするには
注 : EasyBuilder では、位置決めまたは検査ツールの出力が無効な場合、そのツールのデフォルト値が出力データバッファに使用されます。 例えば、パターン位置決めツールがマッチするパターンを検出できない場合、そのツールの X および Y データは無効となるため、デフォルト値 0 が出力に使用されます。 したがって、出力データを送信するようにデバイスを設定する場合、ツールの結果だけでなく、ツールの PASS/FAIL ステータスも送信し、ツールのデータが有効であるかどうかを確認することを推奨します。 ツールの結果が無効な際に、出力バッファのデフォルト値を変更するには、In-Sight ネイティブモードコマンドを送信します。データの場合、SetSystemConfig("FormatOutputBufferErrData",-1111)。-1111 は既知のエラーを表します。出力文字列の場合、EV SetSystemConfig("FormatOutputBufferErrString","Error")。"Error" はエラー文字列を表します。

サポートしているプロトコル

最大 2 つまでのプロトコルをジョブに追加することができます。 プロトコルを 2 つ追加する場合、「プライマリ」プロトコル✕ 1 と、「セカンダリ」プロトコル✕ 1 を追加することができます。 例えば、[SLMP スキャナ] プロトコル (プライマリ) の追加後、[デバイスの追加] ボタンをクリックして [TCP/IP] プロトコル (セカンダリ) を追加することができます。

注 : 「プライマリ」プロトコル✕ 2 または、「セカンダリ」プロトコル✕ 2 を追加することはできません。

In-Sight ファームウェア 4.x.x

 | プライマリまたは セカンダリ | Micro 1000 シリーズ | 5000 シリーズ (5705 & 5705C を除く) | 70xx - 74xx シリーズ
CC-Link | プライマリ | X | X | X
イーサネットネイティブ | プライマリ | X | X | X
イーサネットネイティブロボット | プライマリ | X | X | X
イーサネットネイティブ文字列 | プライマリ | X | X | X
EtherNet/IP | プライマリ | X | X | X
Modbus TCP サーバ | プライマリ | X | X | X
POWERLINK | プライマリ |  |  | X
PROFINET | プライマリ | X | X | X
シリアル Kuka | プライマリ | X | X | X
シリアル Motoman | プライマリ | X | X | X
シリアルネイティブ | プライマリ | X | X | X
シリアルネイティブロボット | プライマリ | X | X | X
シリアルネイティブ文字列 | プライマリ | X | X | X
シリアルテキスト | プライマリ | X | X | X
SLMP | プライマリ | X | X | X
SLMP スキャナ | プライマリ | X | X | X
TCP/IP | セカンダリ | X | X | X
UDP | セカンダリ | X | X | X

In-Sight ファームウェア 5.x.x

 | プライマリまたは セカンダリ | 2000 シリーズ | 5705 & 5705C | 7000 Gen2 シリーズ | Micro 8000 シリーズ | 9000 シリーズ
CC-Link IE フィールド Basic | プライマリ | X | X | X | X | X
イーサネットネイティブ | プライマリ |  | X | X | X | X
イーサネットネイティブロボット | プライマリ |  | X | X | X | X
イーサネットネイティブ文字列 | プライマリ |  | X | X | X | X
EtherNet/IP | プライマリ | X | X | X | X | X
Modbus TCP サーバ | プライマリ | X | X | X | X | X
PROFINET | プライマリ | X | X | X | X | X
シリアル Kuka | プライマリ |  | X | X | X | X
シリアル Motoman | プライマリ |  | X | X | X | X
シリアルネイティブ | プライマリ | X (ベーシック) | X | X | X | X
シリアルネイティブロボット | プライマリ |  | X | X | X | X
シリアルネイティブ文字列 | プライマリ |  | X | X | X | X
シリアルテキスト | プライマリ | X | X | X | X | X
SLMP | プライマリ | X | X | X | X | X
SLMP スキャナ | プライマリ | X | X | X | X | X
TCP/IP | セカンダリ | X | X | X | X | X
UDP | セカンダリ | X | X | X | X | X

PLC と通信するには

ロボットと通信するには

三菱電機社製デバイスと通信するには

Modbus TCP 上で通信するには

TCP/IP 上で通信するには

UPD 上で通信するには

POWERLINK 上で通信するには

識別ツールにデータを入力するには

出力文字列をフォーマットするには


PLC/モーションコントローラ と通信するには

PLC/MC と通信するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[PLC/モーションコントローラ] を選択します。
  3. [メーカー] ドロップダウンリストから、PLC/MC のメーカーを選択します。 メーカー名がリストにない場合は、[その他] を選択します。

  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。 選択したメーカーが使用する通信プロトコルがリストに表示されます。

    注 : DeviceNet は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。
  5. [OK] ボタンを押します。
  6. オプションで、[デバイスの追加] ボタンをクリックして「セカンダリ」プロトコルをジョブに追加します。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。

[通信] グループボックスの設定後、設定ペインに表示されるタブを設定して下さい。

利用可能な PLC/モーションコントローラのプロトコル

注 : サポートされているプロトコルの一覧は、[デバイスの設定] をご参照ください。
  • Modbus TCP サーバ
  • CC-Link
  • SLMP
  • SLMP スキャナ
  • EtherNet/IP
  • PROFINET
  • DeviceNet

Modbus TCP 上で通信するには

CC-Link 通信

SLMP 通信

SLMP スキャナ通信

DeviceNet シリアルポートの設定


Modbus TCP 上で通信するには

In-Sight センサを、ネットワーク上にある他の Modbus TCP デバイス用 Modbus サーバとして使用することができます。

In-Sight センサを Modbus サーバとして設定するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。

  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから [PLC] または [その他] を選択します。

    注 : [PLC] を選択した場合、[メーカー] ドロップダウンリストから PLC のメーカーまたは [その他] を選択し、次に [プロトコル] ドロップダウンリストから [Modbus TCP サーバ] を選択します。
  3. [プロトコル] ドロップダウンリストから [Modbus TCP サーバ] を選択します。
  4. [OK] ボタンを押します。
  5. デフォルトで、[フォーマット出力データ] タブが最初に表示されます。 2 つのタブのコントロールは同じで、データの追加後に有効となります。

  6. [追加] ボタンを押して [入力データの選択] または [出力データの選択] (どちらのタブが選択されているかによります) を開きます。 ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータ、およびジョブ全体の結果 (出力のみ) が含まれています。 Modbus マスタに公開するデータをダイアログから選択して、[OK] ボタンを押してください。

  7. 追加されたデータの [名前]、[データタイプ]、[バイト数]、[値] および選択されたデータの [レジスタ] 開始数 (Modbusクライアントの Read および Write コマンドがこの数字を参照し、信号がどのレジスタかどうかを判断します) がテーブルに表示されます。 テーブルの右側は、Modbus 登録のデータフォーマットを表示する Modbus レジスタプレビューウィンドウです。

  8. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

    注 :
    • [データ型] ドロップダウンリストから [文字列] または [バイト変換文字列] を選択すると、[エレメントごとのデータ長 (ワード)] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。
    • EasyBuilder に実装されている Modbus TCP プロトコルは、ビット、8 ビットおよび符号なしデータ型をサポートしていません。

  9. [ハイバイト/ローバイト] チェックボックスを OFF にし、ローバイトを先にするように指定することによって、32 ビット浮動小数点および 32 ビット整数のバイトオーダをカスタマイズすることができます。デフォルトでは、チェックボックスは OFF となります。 また、[ハイワード/ローワード] チェックボックスを OFF にし、ローワードを先にするように指定することによって、32 ビット浮動小数点および 32 ビット整数のワードオーダをカスタマイズすることができます。デフォルトでは、チェックボックスは OFF となります。 変更事項は、Modbus レジスタプレビューウィンドウに更新されます。

    注 : バイトオーダまたはワードオーダに関する変更は、[フォーマット出力データ] および [フォーマット入力データ] タブのすべてのデータ符号に影響します。
  10. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
  11. In-Sight ビジョンシステムの設定が済んだら、In-Sight ビジョンシステムにデータ読み取り/書き込みを命令する、Read および Write コマンドを送信するよう Modbus クライアントを設定する必要があります。
注 : オプションで、[デバイスの追加] ボタンをクリックして「セカンダリ」プロトコルをジョブに追加します。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。


CC-Link 通信

注 : CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

CC-Link プロトコルは、In-Sight CIO-MICRO-CC に接続した In-Sight ビジョンシステムと三菱シーケンサの間でデータを送受信するのに使用されます。 CC-Link 通信は、In-Sight CIO-MICRO-CC I/O モジュール上の CC-link 接続と三菱シーケンサ上の CC-link 接続の間で確立されます。

注 : CC-Link 通信を有効にするには、In-Sight ビジョンシステムを In-Sight CIO-Micro-CC I/O モジュール に接続する必要があります。

CC-link を介して三菱シーケンサ/モーションコントローラと通信するように In-Sight ビジョンシステムを設定するには、まず [CC-Link 通信設定] タブのパラメータを設定し、次に三菱シーケンサと In-Sight ビジョンシステムの間で送受信されるデータを設定します。

  • [CC-Link 通信設定] タブを設定するには
  • [フォーマット入力ビット/ワードデータ] タブおよび [フォーマット出力ビット/ワードデータ] タブを設定するには

[CC-Link 通信設定] タブを設定するには

[フォーマット入力ビット/ワードデータ] タブおよび [フォーマット出力ビット/ワードデータ] タブを設定するには


SLMP 通信

SLMP は、三菱電機社製シーケンサおよびロボットコントローラと In-Sight ビジョンシステム間での、データ送受信に使用されます。

まず、[SLMP 設定] タブのパラメータを設定します。このタブでは、コントローラタイプ、IP アドレス、ポート番号、三菱電機社製シーケンサの読み出し/書き込み先レジスタ、およびタイムアウトの情報を設定します。

次に、[フォーマット入データ] および [フォーマット出力データ] タブを設定します。これらのタブでは、シーケンサに送受信するツールまたはデータを定義します。

注 : In-Sight 2000 シリーズビジョンセンサは、ロボットコントローラをサポートしていません。
  • [SLMP 設定] タブを設定するには
  • [フォーマット入力データ] および [フォーマット出力データ] タブを設定するには

[SLMP/MC プロトコル設定] タブを設定するには

[フォーマット入力データ] および [フォーマット出力データ] タブを設定するには


SLMP スキャナ通信

SLMP スキャナは、三菱電機社製シーケンサおよびロボットコントローラと In-Sight ビジョンシステム間での、データ送受信に使用されます。

まず、[設定] タブのパラメータを設定します。このタブでは、三菱電機社製シーケサまたはロボットコントローラとの通信を確立するのに必要な情報を定義します。

次に、[デバイスのアドレス指定] タブを設定します。このタブでは、シーケンサまたはロボットコントローラのアドレスや、シーケンサまたはロボットコントローラ通信用の各種データブロックのサイズを定義します。

最後に、[フォーマット入力データ] および [フォーマット出力データ] タブを設定します。これらのタブでは、シーケンサまたはロボットコントローラに送受信するツールまたはデータを定義します。

注 :
  • In-Sight 2000 シリーズビジョンセンサは、ロボットコントローラをサポートしていません。
  • SLMP スキャナを設定または変更後、In-Sight ビジョンシステムを再起動することを推奨します。

[設定] タブを設定するには

[デバイスのアドレス指定タブ] を設定するには

[フォーマット入力データ] および [フォーマット出力データ] タブを設定するには


DeviceNet シリアルポートの設定

EasyBuilder は、DeviceNet コントローラの標準シリアルポート設定をデフォルトとして使用します。 コントローラが別の設定を使用する場合は、[シリアルポートの設定] タブをクリックし、DeviceNet コントローラと同じシリアルポート設定をするように、In-Sight ビジョンシステムのシリアルポートを設定してください。 [通信] ステップから他のステップに移るときに、シリアルモード設定は In-Sight ビジョンシステムに保存されます。

注 :
  • DeviceNet は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。
  • DeviceNet の設定には、Cognex 社製以外の RS-232 からの DeviceNet ゲートウェイアダプタが必要です。 これらの設定は、レガシーインストールに使用可能です。新しいアプリケーションでは、RS-232 からの DeviceNet ゲートウェイコンバータがそのアプリケーションに適しているかどうか検証されていない限り、使用しないでください。

  • [シリアルポート設定] オプションは、In-Sight モデルおよび I/O モジュールによって異なります。サポートしている I/O モジュールに接続している場合、[I/O モジュール] ボタンをクリックし、[I/O モジュールの設定] ダイアログを開いて、I/O モジュールを設定します。

  • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。
  • In-Sight 70xx - 74xx シリーズビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように構成されている場合、電源 I/O ケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効です。 I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
  • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • CIO-WENET I/O モジュールは、シリアル通信をサポートしません。


ロボットと通信するには

ロボットガイダンスのアプリケーションでは、EasyBuilder が開発効率を大幅に向上します。EasyBuilder はアプリケーションを自動的に検査して、フィクスチャデータ (または位置決めツールや検査ツールが出力する位置データ) を各メーカーおよびプロトコルに準じたフォーマットに整形します。 その後、再びネイティブモードコマンドを使用して、ロボットが In-Sight センサに対しフォーマットされた文字列を送信するようにリクエストします。

ロボットコントローラと通信するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[ロボット] を選択します。
  3. [メーカー] ドロップダウンリストから、[ロボット] を選択します。 メーカー名がリストにない場合は、[その他] を選択します。
  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。 選択したメーカーが使用する通信プロトコルがリストに表示されます。
  5. [OK] ボタンを押します。
  6. オプションで、[デバイスの追加] ボタンをクリックして「セカンダリ」プロトコルをジョブに追加します。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。

[通信] グループボックスの設定後、データを定義してください。

  • イーサネットネイティブ通信 (ロボット)
  • シリアルネイティブ通信 (ロボット)
  • シリアル Kuka 通信 (ロボット)
  • シリアル Motoman 通信 (ロボット)
  • Ethernet IP 通信 (FANUC ロボットコントローラ)

イーサネットネイティブ通信 (ロボット)

シリアルネイティブ通信 (ロボット)

シリアル Kuka 通信 (ロボット)

シリアル Motoman 通信 (ロボット)

ロボット EtherNet/IP 通信 (FANUC)


イーサネットネイティブ通信 (ロボット)

注 : 次の説明は、[通信] グループボックスで [デバイス] から [ロボット] を選択し、[プロトコル] から [イーサネットネイティブ] を選択した場合のみ適用となります。
  1. [プロトコル] から [イーサネットネイティブ] を選択すると、EasyBuilder は自動的にジョブを検証して、フィクスチャを定義する位置決めツールまたは検査ツールをサーチし、データ文字列を作成します。
  2. [フォーマット出力文字列] タブの [ポジション名] ドロップダウンリストに、フィクスチャを作成するすべてのツールが表示されます。ジョブにポジションを返すツールが 1 つしか含まれていない場合、そのツールがデフォルトとして選択されます。ポジションを返すツールが 2 つ以上ある場合は、[ポジション名] ドロップダウンリストから、送信する出力文字列のツールを選択してください。フォーマットされた文字列が表示されます。また、文字列の文字数も参照用に表示されます。
  3. 文字列がフォーマットされたら、ロボットコントローラは、In-Sight ネイティブモードコマンド、EV GetCellValue("Job.Robot.FormatString") を送信して、データをリクエストすることができるようになります。EV GetCellValue ("Job.Robot.FormatString") は、一回のコマンドで文字列にフォーマットされたすべてのデータを返します。詳細については、『In-Sight® Explorer ヘルプ』ファイルをご参照ください。
注 : 定義済みのフィクスチャがジョブにない場合、またはカスタマイズされた文字列を作成したり、文字列のフォーマットをカスタマイズしたい場合は、[カスタムフォーマット...] ボタンを押して、[FormatString] ダイアログを開いてください。このダイアログを使用して、異なる文字列を追加したり、文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更することができます。文字列の変更を終了したら、[OK] ボタンを押します。


シリアルネイティブ通信 (ロボット)

注 : 次の説明は、[通信] セクションで、[デバイス] から [ロボット] を選択し、[プロトコル] から [シリアルネイティブ] を選択した場合のみに適用となります。
  1. [プロトコル] から [シリアルネイティブ] を選択すると、EasyBuilder は自動的にジョブを検証して、フィクスチャを定義する位置決めツールまたは検査ツールをサーチし、データ列を作成します。
  2. [フォーマット出力文字列] タブの [ポジション名] ドロップダウンリストに、フィクスチャを作成するすべてのツールが表示されます。 ジョブにポジションを返すツールが 1 つしか含まれていない場合、そのツールがデフォルトとして選択されます。 ポジションを返すツールが 2 つ以上ある場合は、[ポジション名] ドロップダウンリストから、送信する出力文字列のツールを選択してください。 フォーマットされた文字列が表示されます。また、文字列の文字数も参照用に表示されます。

  3. [シリアルポートの設定] タブをクリックし、シリアルポートを定義してください (必要な場合のみ)。 EasyBuilder は、[デバイスの設定] グループボックスに基づいて、シリアルプロトコルを自動的に検討します。 [通信] ステップから他のステップに移るときに、シリアルポート設定は In-Sight ビジョンシステムに保存されます。

    注 :

    • [シリアルポート設定] オプションは、In-Sight モデルおよび I/O モジュールによって異なります。サポートしている I/O モジュールに接続している場合、[I/O モジュール] ボタンをクリックし、[I/O モジュールの設定] ダイアログを開いて、I/O モジュールを設定します。

    • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

    • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。
    • In-Sight 70xx - 74xx シリーズビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように構成されている場合、電源 I/O ケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効です。 I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
    • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

    • CIO-WENET I/O モジュールは、シリアル通信をサポートしません。

  4. 文字列がフォーマットされたら、ロボットコントローラは、In-Sight ネイティブモードコマンド、EV GetCellValue("Job.Robot.FormatString") を送信して、データをリクエストすることができるようになります。 EV GetCellValue ("Job.Robot.FormatString") は、一回のコマンドで文字列にフォーマットされたすべてのデータを返します。
注 : 定義済みのフィクスチャがジョブにない場合、またはカスタマイズされた文字列を作成したり、文字列のフォーマットをカスタマイズしたい場合は、[カスタムフォーマット...] ボタンを押して、[FormatString] ダイアログを開いてください。このダイアログを使用して、異なる文字列を追加したり、文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更することができます。文字列の変更を終了したら、[OK] ボタンを押します。


シリアル Kuka 通信 (ロボット)

Kuka ロボットコントローラは、複雑ですが非常に強力なエラーチェックプロトコルを使用して、RS-232 シリアルポート経由でほかのデバイスと通信します。 Kuka シリアル通信用に設定すると、In-Sight ビジョンシステムはこのプロトコルを認識して、Kuka コントローラから受信したコマンドに応答できるようになります。

注 :
  • In-Sight ビジョンシステムと通信するには、Kuka ロボットは P3964R モードである必要があります。また、後述のように、ビジョンシステムは [シリアル Kuka] モードである必要があります。
  • In-Sight ビジョンシステムは、Kuka のデフォルトのプロトコル設定 (すなわち、トランザクションにおいて、Kuka ロボットの優先度が高く、In-Sight ビジョンシステムの優先度が低い設定) を使用するように設定されています。

  1. [プロトコル] から [シリアル Kuka] を選択すると、EasyBuilder は自動的にジョブを検証して、フィクスチャを定義する位置決めツールまたは検査ツールをサーチし、データ列を作成します。 [フォーマット出力文字列] タブの [ポジション名] ドロップダウンリストに、フィクスチャを作成するすべてのツールが表示されます。 ジョブにポジションを返すツールが 1 つしか含まれていない場合、そのツールがデフォルトとして選択されます。 ポジションを返すツールが 2 つ以上ある場合は、[ポジション名] ドロップダウンリストから、送信する出力文字列のツールを選択してください。 フォーマットされた文字列が表示されます。また、文字列の文字数も参照用に表示されます。 また、[エンコードされたロケーション] も表示され、In-Sight ネイティブモードコマンド、GV[EncodedLocation] を入力するときに、Kuka ロボットコントローラが参照するデータが表示されます。

    注 : 定義済みのフィクスチャがジョブにない場合、またはカスタマイズされた文字列を作成したり、文字列のフォーマットをカスタマイズしたい場合は、[カスタムフォーマット...] ボタンを押して、[FormatString] ダイアログを開いてください。このダイアログを使用して、異なる文字列を追加したり、文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更することができます。文字列の変更を終了したら、[OK] ボタンを押します。

  2. EasyBuilder ビジョンシステムは、Kuka コントローラの標準のシリアルポート設定をデフォルトとして使用するようになります。 ただし、コントローラが別の設定を使用する場合には、[シリアルポートの設定] タブをクリックし、Kuka コントローラと同じシリアルポート設定を使用するように、In-Sight を設定してください。 [通信] ステップから他のステップに移るときに、シリアルモード設定は In-Sight ビジョンシステムに保存されます。

    注 :
    • Kuka KR C2 および KR C2 Edition 2005 ロボットコントローラがサポートされます。

    • [シリアルポート設定] オプションは、In-Sight モデルおよび I/O モジュールによって異なります。サポートしている I/O モジュールに接続している場合、[I/O モジュール] ボタンをクリックし、[I/O モジュールの設定] ダイアログを開いて、I/O モジュールを設定します。

    • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

    • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。
    • In-Sight 70xx - 74xx シリーズビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように構成されている場合、電源 I/O ケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効です。 I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
    • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

    • CIO-WENET I/O モジュールは、シリアル通信をサポートしません。

  3. Kuka ロボットコントローラは、In-Sight ビジョンシステムとの間のすべてのデータ通信をネイティブモードコマンドを使用して開始します。 GV[EncodedLocation] コマンドは、このステップで設定された文字列を返します。また、このコマンドは、EasyBuilder で開発されたジョブに使用してください。

シリアル Kuka モードは、In-Sight のネイティブモード通信の拡張です。 シリアル Kuka モードはネイティブモードに基づくので、In-Sight のジョブをネイティブモードで開発してテストした後、実際のロボットコントローラが In-Sight センサに接続されている場合のみシリアル Kuka モードに切り替えることができます。 ジョブにその他の変更を加える必要はありません。

閉じた サポートする In-Sight ネイティブモード (シリアル Kuka 通信)
ネイティブモードコマンド | シンタックス
Get Job | GJ
Get Online | GO
Get Value | GV[EncodedLocation]
Get Value | GV[シンボリック名]
Load File | LF[ファイル名]
Set Event | SE[整数]
Store File | TF[ファイル名]
Set Float | SF[シンボリック名][不動小数点]
Set Integer | SI[シンボリック名][整数]
Set Job | SJ[ID]
Set Online | SO[整数]
Set String | SS[シンボリック名][文字列]


シリアル Motoman 通信 (ロボット)

Motoman MRC、MRC-II、および XRC ロボットコントローラは、複雑ですが非常に強力なエラーチェックプロトコルを使用して、RS-232 シリアルポート経由で他のデバイスと通信します。 Motoman シリアル通信用に設定すると、In-Sight ビジョンシステムはこのプロトコルを認識して、Motoman コントローラから受信したコマンドに応答できるようになります。

注 :
  • コントローラは、DCI モードで通信するように設定する必要があります。 In-Sight から Motoman ロボットコントローラに対して開始された、ホストモードで動作している通信は、現時点ではサポートされていません。
  • Motoman コントローラではフロー制御を「なし」に指定している場合でも、In-Sight ビジョンシステムでは Motoman コントローラとの通信時に「ハードウェア」によるフロー制御 (ハードウェアフロー制御) が必要です。
  • Motoman XRC コントローラのみテスト済みです。
  • シリアルMotoman モードは ネイティブモードに基づくので、In-Sight のジョブをネイティブモードで開発してテストした後、実際のロボットコントローラが In-Sight ビジョンシステムに接続されている場合のみ、シリアル Motoman モードに切り替えることができます。 ジョブにその他の変更を加える必要はありません。

  1. [プロトコル] から [シリアル Motoman] を選択すると、EasyBuilder は自動的にジョブからフィクスチャを定義する位置決めツールまたは検査ツールをサーチし、データ列を作成します。

    注 : 定義済みのフィクスチャがジョブにない場合、またはカスタマイズされた文字列を作成したり、文字列のフォーマットをカスタマイズしたい場合は、[カスタムフォーマット...] ボタンを押して、[FormatString] ダイアログを開いてください。このダイアログを使用して、異なる文字列を追加したり、文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更することができます。文字列の変更を終了したら、[OK] ボタンを押します。
  2. [フォーマット出力文字列] タブの [ポジション名] ドロップダウンリストに、フィクスチャを作成するすべてのツールが表示されます。 ジョブにポジションを返すツールが 1 つしか含まれていない場合、そのツールがデフォルトとして選択されます。 ポジションを返すツールが 2 つ以上ある場合は、[ポジション名] ドロップダウンリストから、送信する出力文字列のツールを選択してください。 フォーマットされた文字列が表示されます。また、文字列の文字数も参照用に表示されます。
  3. [エンコードされたロケーション] に、In-Sight ビジョンシステムからデータを取得するときに、Motoman ロボットコントローラが使用する CC + RRR データが表示されます。

  4. EasyBuilder ビジョンシステムは、Motoman コントローラの標準のシリアルポート設定をデフォルトとして使用するようになります。 ただし、コントローラが別の設定を使用する場合には、[シリアルポートの設定] タブをクリックし、Motoman コントローラと同じシリアルポート設定を使用するように、In-Sight を設定してください。 [通信] ステップから他のステップに移るときに、シリアルモード設定は In-Sight ビジョンシステムに保存されます。

    注 :

    • [シリアルポート設定] オプションは、In-Sight モデルおよび I/O モジュールによって異なります。サポートしている I/O モジュールに接続している場合、[I/O モジュール] ボタンをクリックし、[I/O モジュールの設定] ダイアログを開いて、I/O モジュールを設定します。

    • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

    • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。
    • In-Sight 70xx - 74xx シリーズビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように構成されている場合、電源 I/O ケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効です。 I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
    • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

    • CIO-WENET I/O モジュールは、シリアル通信をサポートしません。

  5. Motoman ロボットコントローラは、In-Sight ビジョンシステムとの間のすべてのデータ通信をネイティブモードコマンドを使用して開始します。 GV[EncodedLocation] コマンドは、このステップで設定された文字列を返します。また、このコマンドは、EasyBuilder で開発されたジョブに使用してください。

シリアル Motoman モードは、In-Sight のネイティブモード通信の拡張です。 Motoman ロボットコントローラは、RS-232 ポートを介して数値テキストのみを送信します。In-Sight の標準ネイティブモードコマンドを送信することはできません。。 その代わりに、Motoman コントローラは、ネイティブモードコマンドの数値表現に必要に応じて追加パラメータを付加したものを In-Sight ビジョンシステムに送信する必要があります


ロボット EtherNet/IP 通信 (FANUC)

FANUC ロボットコントローラと EtherNet/IP (EIP) を介して通信するように、In-Sight ビジョンシステムを設定することができます。

  1. [デバイス] から [ロボット] を選択し、[メーカー] から [FANUC] を選択した後に [EtherNet/IP ロボット] を選択すると、EasyBuilder は自動的にジョブを検証して、フィクスチャを定義する位置決めツールまたは検査ツールをサーチし、データ列を作成します。

    注 :
    • FANUC ロボットコントローラ用に EtherNet/IP Robot 通信を設定する際に、[メーカー] から [その他] を選択すると、EasyBuilder は他のデバイス用の EtherNet/IP 設定を表示します。
    • イーサネットネイティブロボットまたはシリアルネイティブロボットプロトコルを使用して FANUC ロボットコントローラを使用する場合は、イーサネットネイティブロボット通信トピックまたは ロボットシリアルネイティブ通信トピックをご参照ください。
  2. [フォーマット出力文字列] タブの [ポジション名] ドロップダウンリストに、フィクスチャを作成するすべてのツールが表示されます。 ジョブにポジションを返すツールが 1 つしか含まれていない場合、そのツールがデフォルトとして選択されます。 ポジションを返すツールが 2 つ以上ある場合は、[ポジション名] ドロップダウンリストから、送信する出力文字列のツールを選択してください。 出力バッファに文字列が表示されます。また、メッセージサイズ (バイト) も参照用に表示されます。
注 : FANUC ロボットコントローラの詳細については、In-Sight® Explorer ヘルプファイルのロボット通信 - FANUC ロボットコントローラトピックをご参照ください。


三菱電機社製デバイスと通信するには

三菱 PLC/モーションコントローラ - CC-Link、CC-Link IE フィールド Basic、SLMP および SLMP スキャナ

次の手順で設定してください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[PLC/モーションコントローラ] を選択します。
  3. [メーカー] ドロップダウンリストから、[三菱電機] を選択します。

  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。選択肢は、[CC-Link]、[CC-Link IE フィールド Basic]、[SLMP] または [SLMP スキャナ] です。

    注 : CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。
  5. [OK] ボタンを押します。
  6. オプションで、[デバイスの追加] ボタンをクリックして「セカンダリ」プロトコルをジョブに追加します。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。

[通信] グループボックスの設定後、三菱電機社製シーケンサデバイスとの通信を設定してください。

  • CC-Link
  • CC-Link IE フィールド Basic
  • SLMP
  • SLMP スキャナ
注 : In-Sight ビジョンシステムを SLMP、SLMP スキャナ、または CC-Link を介して PLC と通信するように設定した場合、プロトコルはビジョンシステムと PLC 間のデータ転送のみをサポートします。

三菱ロボットコントローラ - イーサネットネイティブ文字列、シリアルネイティブ文字列、SLMP および SLMP スキャナ

注 : In-Sight 2000 シリーズビジョンセンサは、ロボットコントローラをサポートしていません。

次の手順で設定してください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[ロボット] を選択します。
  3. [メーカー] ドロップダウンリストから、[三菱電機] を選択します。
  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。選択肢は、[イーサネットネイティブ文字列]、[シリアルネイティブ文字列]、[SLMP] および [SLMP スキャナ] です。
  5. [OK] ボタンを押します。
  6. オプションで、[デバイスの追加] ボタンをクリックして「セカンダリ」プロトコルをジョブに追加します。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。

[通信] グループボックスの設定後、In-Sight ビジョンシステムとロボット間の通信データを設定して下さい。

  • 三菱イーサネットネイティブ文字列通信を設定するには
  • 三菱イーサネットシリアル文字列通信を設定するには
  • SLMP
  • SLMP スキャナ

CC-Link 通信

CC-Link IE フィールドネットワーク Basic 通信

SLMP/MC プロトコル通信

SLMP/MC スキャナ通信

三菱イーサネットネイティブ文字列ロボット通信を設定するには

三菱シリアルネイティブ文字列ロボット通信を設定するには


[CC-Link 通信設定] タブを設定するには

[CC-Link 通信設定] タブは、CC-Link ネットワーク上の In-Sight CIO-MICRO-CC I/O モジュール通信を設定するのに使用されます。

注 : CIO-MICRO-CC I/O モジュールに接続していない場合、すべてのコントロールは無効となります。
閉じた 有効

CIO-MICRO-CC I/O モジュール上の CC-Link インタフェースを有効にするかどうかを指定します。デフォルトでは、[有効] チェックボックスは ON で、In-Sight CIO-MICRO-CC I/O モジュール上の CC-Link インタフェースは有効となっています。[有効] チェックボックスを OFF にして、必要な場合に CC-Link 接続を診断、デバッグします。

閉じた バージョン

CC-Link の仕様互換性を指定します。選択肢は、[V1] または [V2] です。デフォルトでは、[V1] が選択されています。

閉じた ビット/秒

CC-Link ネットワークの CC Link ビット/秒を指定します。選択肢は、[10M]、[5M]、[2.5M]、[625k]、および [156k] です。デフォルトでは、[10M] が選択されています。

閉じた 局番号:

CC-Link スレーブの局番号を指定します (1～64、 デフォルトは、1)。

注 : [局番号] および [局数] パラメータには、最大 64 までの値を割り当てることができます。
閉じた 局数:

CC-Link ネットワーク上で In-Sight CIO-MICRO-CC I/O モジュールが占める局数を指定します (1～4、 デフォルトは、1)。

注 : [局番号] および [局数] パラメータには、最大 64 までの値を割り当てることができます。
閉じた 拡張サイクル:

CC-Link ネットワーク上で In-Sight CIO-MICRO-CC I/O モジュールが使用する拡張サイクルの数を指定します。選択肢は、[1X (無効) ]、[2X]、[4X]、または [8X] です。デフォルトでは、[1X (無効) ] が選択されています。

注 : このオプションは、[バージョン] パラメータを [V2] に設定した場合のみ有効です。
閉じた 入力

入力ビットで使用可能なビット数、およびワードバッファで使用可能なワード数を表示します。

入力バッファで使用可能なビット数を指定するには

  • [バージョン] パラメータを [V1] に設定した場合: 32× (局数) -16
  • [バージョン] パラメータを [V2] にして、さらに [拡張サイクル] パラメータを [1X (無効) ] に設定した場合: 32× (局数) -16
  • [バージョン] パラメータを [V2]　にして、さらに [拡張サイクル] パラメータを有効にした場合: 32× (局数) × (拡張サイクル) -16

入力バッファで使用可能なワード数を指定するには

  • [バージョン] パラメータを [V1] に設定した場合: 4× (局数)
  • [バージョン] パラメータを [V2] にして、さらに [拡張サイクル] パラメータを [1X (無効) ] に設定した場合: 4× (局数)
  • [バージョン] パラメータを [V2] にして、さらに [拡張サイクル] を有効にした場合: 4× (局数) × (拡張サイクル)
閉じた 出力

出力ビットで使用可能なビット数、およびワードバッファで使用可能なワード数を表示します。

出力バッファで使用可能なビット数を指定するには

  • [バージョン] パラメータを [V1] に設定した場合: 32× (局数) -16
  • [バージョン] パラメータを [V2] にして、さらに [拡張サイクル] パラメータを [1X (無効) ] に設定した場合: 32× (局数) -16
  • [バージョン] パラメータを [V2] にして、さらに [拡張サイクル] パラメータを有効にした場合: 32× (局数) × (拡張サイクル) -16× (拡張サイクル) -16

出力バッファで使用可能なワード数を指定するには

  • [バージョン] パラメータを [V1] に設定した場合: 4× (局数)
  • [バージョン] パラメータを [V2] に、[拡張サイクル] パラメータを [1X (無効) ] に設定した場合: 4× (局数)
  • [バージョン] パラメータを [V2] に、[拡張サイクル] を有効にした場合: 4× (局数) × (拡張サイクル)


[フォーマット入力ビット/ワードデータ] タブおよび [フォーマット出力ビット/ワードデータ] タブを設定するには

[CC-Link 通信設定] タブの設定後、[フォーマット入力ビットデータ]、[フォーマット入力ワードデータ]、[フォーマット出力ビットデータ] および [フォーマット出力ワードデータ] タブを設定します。これらのタブでは、三菱シーケンサと In-Sight ビジョンシステムの間で、CC-Link ネットワークを介し送受信されるツールまたはジョブデータが定義されます。

閉じた [フォーマット入力ビットデータ] を設定するには

[フォーマット入力ビットデータ] タブを使用して、位置決め/検査ツール結果、画像取り込みデータ、または入力によって返されるすブールデータタイプに、ビットオフセットを関連付けます。 最大 32 までの入力を設定することができます。

  1. シーケンサから In-Sight ビジョンシステムに転送されるデータを設定するには、まず [フォーマット入力ビットデータ] タブをクリックします。
  2. [追加] ボタンを押し、[入力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよび入力などのジョブデータが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。
  3. 追加されたデータの [開始アドレス]、入力の [名前]、[データタイプ]、[サイズ] および [値] がテーブルに表示されます。
  4. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
閉じた [フォーマット入力ワードデータ] タブを設定するには

[フォーマット入力ワードデータ] タブを使用して、位置決め/検査ツール結果、画像取り込みデータ、または入力によって返される In-Sight ビジョンシステムへの入力を定義します。 最大 32 までの入力を設定することができます。

注 : ワード数は、[CC-Link 通信設定] タブのパラメータで設定した上限を越えることはできません。
  1. シーケンサから In-Sight ビジョンシステムに転送されるデータを設定するには、まず [フォーマット入力ワードデータ] タブをクリックします。
  2. [追加] ボタンを押し、[入力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよび入力などのジョブデータが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。
  3. 追加されたデータの [開始アドレス] (開始アドレスは、ワードのフィールドオフセット) 、入力の [名前]、[データタイプ]、[サイズ] および [値] がテーブルに表示されます。

  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

    注 :
    • [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数 (最大 128) を選択して文字列長を指定することができます。
    • EasyBuilder に実装されている CC-Link は、8 ビットおよび符号なしデータ型をサポートしていません。
  5. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
閉じた [フォーマット出力ビットデータ] タブを設定するには

[フォーマット出力ビットデータ] タブを使用して、位置決め/検査ツール結果、画像取り込みデータ、またはジョブの結果が返すブールデータタイプに、ビットオフセットを関連付けます。 各ジョブに対し 64 以上の出力を定義することができます。 (ジョブサイズによって上限が変わります) 。

  1. In-Sight ビジョンシステムに転送されるデータを設定するには、まず [フォーマット出力ビットデータ] タブをクリックします。

  2. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよびジョブ全体の結果などが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。

    注 : デフォルトで、Job.Inspection_CountJ データシンボルが自動的に出力データテーブルに追加されます。 このシンボルは、In-Sight ビジョンシステムが新しい画像を取り込み、新しい検査結果が到達したことを、シーケンサに警告します。 このシンボルは、アプリケーションに必要ない場合、削除可能です。
  3. 追加されたデータの [名前]、[データタイプ]、[サイズ]、[値]、および選択中のデータの [開始アドレス] がテーブルに表示されます。 テーブルの右側は、シーケンサレジスタのデータフォーマットを表示するレジスタプレビューウィンドウです。
  4. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
閉じた [フォーマット出力ワードデータ] タブを設定するには

[フォーマット出力ワードデータ] タブを使用して、位置決め/検査ツール結果、画像取り込みデータ、または入力によって返される In-Sight ビジョンシステムへの出力を定義します。 各ジョブに対し 32 以上の出力を定義することができます。 (ジョブサイズによって上限が変わります) 。

  1. In-Sight ビジョンシステムに転送されるデータを設定するには、まず [フォーマット出力ビットデータ] タブをクリックします。

  2. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよびジョブ全体の結果などが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。

    注 : デフォルトで、Job.Inspection_CountJ データシンボルが自動的に出力データテーブルに追加されます。 このシンボルは、In-Sight ビジョンシステムが新しい画像を取り込み、新しい検査結果が到達したことを、シーケンサに警告します。 このシンボルは、アプリケーションに必要ない場合、削除可能です。
  3. 追加されたデータの [名前]、[データタイプ]、[サイズ]、[値]、および選択中のデータの [開始アドレス] (開始アドレスは、ワードでのフィールドオフセット) がテーブルに表示されます。 テーブルの右側は、シーケンサレジスタのデータフォーマットを表示するレジスタプレビューウィンドウです。

  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

    注 :
    • [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数 (最大 128) を選択して文字列長を指定することができます。
    • EasyBuilder に実装されている CC-Link は、8 ビットおよび符号なしデータ型をサポートしていません。
  5. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。


CC-Link IE フィールドネットワーク Basic 通信

CC-Link IE フィールド Basic は、イーサネットデバイスを三菱電機シーケンサに統合するよう設計されたプロトコルです。 既存の SLMP とは対照的に、シーケンサがマスタとして動作し、標準の UDP メッセージングを介してスレーブデバイスと通信します。 通信は、各方向に 1 局当たり 30 点または 27 点の 64 ビットのデータと 32 点の 16 ビットワードのデータをサポートし、各スレーブは最大 4 局をサポートします (デフォルトは 1 局)。 データは、セットアップツール (GXWorks 2/3) を介してコントローラメモリにマッピングされます。

注 : 詳細については、『In-Sight® Explorer ヘルプ』ファイルをご参照ください。または、三菱電機社の『CC-Link IE フィールド Basic リファレンスマニュアル』をご参照ください。
  • [フォーマット入力ビット/ワードデータ] タブおよび [フォーマット出力ビット/ワードデータ] タブを設定するには (CC-Link IE フィールドネットワーク Basic)

[フォーマット入力ビット/ワードデータ] タブおよび [フォーマット出力ビット/ワードデータ] タブを設定するには (CC-Link IE フィールドネットワーク Basic)


[フォーマット入力ビット/ワードデータ] タブおよび [フォーマット出力ビット/ワードデータ] タブを設定するには (CC-Link IE フィールドネットワーク Basic)

[フォーマット入力ビットデータ]、[フォーマット入力ワードデータ]、[フォーマット出力ビットデータ] および [フォーマット出力ワードデータ] タブを設定します。これらのタブでは、三菱シーケンサと In-Sight ビジョンシステムの間で、ツールやジョブが CC-Link IE フィールド Basic プロトコルを介して送受信するデータを定義します。

注 :
  • このトピックでは、「入力」とは In-Sight ビジョンシステムへの入力を示し、「出力」とはビジョンシステムからの出力を示します。
  • 詳細については、『In-Sight® Explorer ヘルプ』ファイルをご参照ください。
タブ | PLC メモリスペース | 開始オフセット | サイズ制限 (1局占有時) | データ型
フォーマット入力ビットデータ | RY | 32 | 32 | ビット
フォーマット入力ワードデータ | RWw | 2 | 30 | 16-ビットワード
フォーマット出力ビットデータ | RX | 32 | 32 | ビット
フォーマット出力ビットデータ | RWr | 5 | 27 | 16-ビットワード
閉じた [フォーマット入力ビットデータ] タブを設定するには

[フォーマット入力ビットデータ] タブを使用して、位置決め/検査ツール結果、画像取り込みデータ、または入力によって返されるブール型のデータを、ビットオフセットに関連付けます。 最大 32 点までの入力を設定することができます。

  1. シーケンサから In-Sight ビジョンシステムに転送されるデータを設定するには、まず [フォーマット入力ビットデータ] タブをクリックします。
  2. [追加] ボタンを押し、[入力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよび入力などのジョブデータが含まれています。 シーケンサから In-Sight ビジョンシステムに転送するデータを選択し、[OK] ボタンを押してください。
  3. 追加されたデータの [開始アドレス]、入力の [名前]、[データタイプ]、[サイズ] および [値] がテーブルに表示されます。
  4. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
閉じた [フォーマット入力ワードデータ] タブを設定するには

[フォーマット入力ワードデータ] タブを使用して、位置決め/検査ツール結果、画像取り込みデータ、または入力によって返される In-Sight ビジョンシステムへの入力を定義します。 最大 30 点の入力を設定することができます。

  1. シーケンサから In-Sight ビジョンシステムに転送されるデータを設定するには、まず [フォーマット入力ワードデータ] タブをクリックします。
  2. [追加] ボタンを押し、[入力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよび入力などのジョブデータが含まれています。 シーケンサから In-Sight ビジョンシステムに転送するデータを選択し、[OK] ボタンを押してください。
  3. 追加されたデータの [開始アドレス] (開始アドレスは、ワードのフィールドオフセット) 、入力の [名前]、[データタイプ]、[サイズ] および [値] がテーブルに表示されます。

  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

    注 :
    • [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数 (最大 128) を選択して文字列長を指定することができます。
    • EasyBuilder に実装されている CC-Link は、8 ビットおよび符号なしデータ型をサポートしていません。
  5. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
閉じた [フォーマット出力ビットデータ] タブを設定するには

[フォーマット出力ビットデータ] タブを使用して、位置決め/検査ツール結果、画像取り込みデータ、またはジョブの結果が返すブール型のデータを、ビットオフセットに関連付けます。 最大 32 点の出力を定義することができます。

  1. In-Sight ビジョンシステムからシーケンサに転送されるデータを設定するには、まず [フォーマット出力ビットデータ] タブをクリックします。

  2. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよびジョブ全体の結果などが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。

    注 : デフォルトで、Job.Inspection_Count データシンボルが自動的に出力データテーブルに追加されます。 このシンボルは、In-Sight ビジョンシステムが新しい画像を取り込み、新しい検査結果が到達したことを、シーケンサに警告します。 このシンボルは、アプリケーションに必要ない場合、削除可能です。
  3. 追加されたデータの [名前]、[データタイプ]、[サイズ]、[値]、および選択中のデータの [開始アドレス] がテーブルに表示されます。 テーブルの右側は、シーケンサレジスタのデータフォーマットを表示するレジスタプレビューウィンドウです。
  4. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
閉じた [フォーマット出力ワードデータ] タブを設定するには

[フォーマット出力ワードデータ] タブを使用して、位置決め/検査ツール結果、画像取り込みデータまたはジョブの結果によって返される In-Sight ビジョンシステムからの出力を定義します。 最大 27 点の出力を定義することができます。

  1. In-Sight ビジョンシステムからシーケンサに転送されるデータを設定するには、まず [フォーマット出力ビットデータ] タブをクリックします。

  2. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよびジョブ全体の結果などが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。

    注 : デフォルトで、Job.Inspection_Count データシンボルが自動的に出力データテーブルに追加されます。 このシンボルは、In-Sight ビジョンシステムが新しい画像を取り込み、新しい検査結果が到達したことを、シーケンサに警告します。 このシンボルは、アプリケーションに必要ない場合、削除可能です。
  3. 追加されたデータの [名前]、[データタイプ]、[サイズ]、[値]、および選択中のデータの [開始アドレス] (開始アドレスは、ワードでのフィールドオフセット) がテーブルに表示されます。 テーブルの右側は、シーケンサレジスタのデータフォーマットを表示するレジスタプレビューウィンドウです。

  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

    注 :
    • [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数 (最大 128) を選択して文字列長を指定することができます。
    • EasyBuilder に実装されている CC-Link IE フィールド Basic は、8 ビットおよび符号なしデータ型をサポートしていません。
  5. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。


[SLMP 設定] タブを設定するには

[SLMP 設定] タブは、シーケンサまたはロボットコントローラのコントローラタイプ、IP アドレス、TCP ポート番号、タイムアウト、読み出し先/書き込み先のレジスタロケーションを設定するのに使用されます。

注 :

[デバイスの設定] グループボックスで選択したデバイスによって、[設定] タブで使用できる [コントローラタイプ] は異なります。 詳細については、三菱電機社製デバイスと通信するにはをご参照ください。

選択したデバイス ([デバイスの設定] グループボックス) 使用可能なコントローラタイプ ([設定] タブ)
PLC/モーションコントローラ
  • iQ-R/Q/L シリーズ (3E フレーム)
  • iQ-F シリーズ (3E フレーム)
  • FX シリーズ (1E フレーム)
ロボットコントローラ
  • CR-800D シリーズ (3E フレーム)
閉じた コントローラタイプ

三菱シーケンサまたはロボットコントローラのタイプを指定します。

  • PLC/MC: iQ-R/Q/L シリーズ (3E フレーム), iQ-F シリーズ (3E フレーム) or FX シリーズ (1E フレーム)。 デフォルトは、iQ-R/Q/L シリーズ (3E フレーム) です。

    注 : iQ-F シリーズ (3E フレーム) オプションは、In-Sight 4.x.x ファームウェアを搭載した In-Sight ビジョンシステムではサポートされていません。
  • ロボットコントローラ: CR800-D シリーズ (3E フレーム)
閉じた IP アドレス

三菱シーケンサまたはロボットコントローラの IP アドレスを指定します。 In-Sight ビジョンシステムに接続する、三菱シーケンサまたはロボットコントローラの IP アドレスを入力してください。

閉じた ポート番号

三菱シーケンサまたはロボットコントローラの TCP ポート番号を 10 進数 または 16 進数で定義します (10 進数: 1～65535、16 進数: 1～0xFFFF。デフォルトは、10 進数 = 12288)。

閉じた タイムアウト (ms)

読み取りおよび書き込み操作のタイムアウト時間 (5～30,000 ミリ秒) を指定します。デフォルトは、1,000 ミリ秒です。

注 : このパラメータの設定によっては、ジョブの実行時間が長くなる可能性があります。読み取りおよび書き込み操作に失敗した場合、両方のタイムアウト時間が重なってしまうため、2 倍のタイムアウト時間がジョブに追加されます。
閉じた 読み出し先
注 : [読み出し先] パラメータを変更する前に、すべてのツールプロパティを [フォーマット入力データ] タブから削除してください。 [読み出し先] パラメータが [なし] に設定されているのに、[フォーマット入力データ] タブにツールプロパティが残っている場合、ツールはエラー状態となります。 また、削除ボタンが無効になり、[フォーマット入力データ] タブに残っているツールは FAIL となるか、削除されるまで実行されません。
閉じた デバイス

三菱シーケンサまたはロボットコントローラの読み出し先デバイスレジスタを定義します。

デバイスタイプ | フォーマット | PLC/MC | ロボット
iQ-R/Q/L シリーズ (3E フレーム) | iQ-F シリーズ (3E フレーム) | FX シリーズ (1E フレーム) | CR800-D シリーズ (3E フレーム)
X - 入力リレー | ビット | X | X | X (8 進数)
Y - 出力リレー | ビット | X | X | X (8 進数)
M - 内部リレー | ビット | X | X | X
L - ラッチリレー | ビット | X
F - アナンシエータ | ビット | X | X
B - リンクリレー | ビット | X
D - データレジスタ | ワード | X | X | X | X
W - リンクレジスタ | ワード | X
R - ファイルブロックレジスタ | ワード | X
ZR - ファイルレジスタ | ワード | X
TN - タイマ値 | ワード | X | X
CN - カウンタ値 | ワード | X | X
R - 拡張レジスタ | ワード | X
S - ステートリレー | ビット | X
注 : デバイスタイプのフォーマットによって、[フォーマット入力データ] タブで使用できるデータの種類が決定されます。 デバイスタイプのフォーマットがビットの場合、[フォーマット入力データ] タブに入力できるデータタイプは [ビット] のみです。
閉じた オフセット

読み出し開始を指定するシーケンサまたはロボットコントローラのデータテーブルの数字部分です。

閉じた 書き込み先
閉じた デバイス

三菱シーケンサまたはロボットコントローラの書き込み先デバイスレジスタを定義します。

デバイスタイプ | フォーマット | PLC/MC | ロボット
iQ-R/Q/L シリーズ (3E フレーム) | iQ-F シリーズ (3E フレーム) | FX シリーズ (1E フレーム) | CR800-D シリーズ (3E フレーム)
X - 入力リレー | ビット | X | X | X (8 進数)
Y - 出力リレー | ビット | X | X | X (8 進数)
M - 内部リレー | ビット | X | X | X
L - ラッチリレー | ビット | X
F - アナンシエータ | ビット | X | X
B - リンクリレー | ビット | X
D - データレジスタ | ワード | X | X | X | X
W - リンクレジスタ | ワード | X
R - ファイルブロックレジスタ | ワード | X
ZR - ファイルレジスタ | ワード | X
TN - タイマ値 | ワード | X | X
CN - カウンタ値 | ワード | X | X
R - 拡張レジスタ | ワード | X
S - ステートリレー | ビット | X
注 : デバイスタイプのフォーマットによって、[フォーマット入力データ] タブで使用できるデータの種類が決定されます。 デバイスタイプのフォーマットがビットの場合、[フォーマット出力データ] タブに入力できるデータタイプは [ビット] のみです。
閉じた オフセット

書き込み開始を指定するシーケンサまたはロボットコントローラのデータテーブルの数字部分です。


[フォーマット入力データ] および [フォーマット出力データ] タブを設定するには (SLMP)

[設定] タブの設定後、[フォーマット入力データ] および [フォーマット出力データ] タブを設定します。これらのタブを使用して、三菱シーケンサまたはロボットコントローラと In-Sight ビジョンシステムの間で送受信されるツールまたはジョブデータを定義します。

閉じた [フォーマット入力データ] タブを設定するには

[フォーマット入力データ] タブを使用して、In-Sight ビジョンシステムへの入力を指定します。各ジョブに対し、最大 32 までの入力を設定することができます。

  1. [フォーマット入力データ] タブを使用して、三菱シーケンサまたはロボットコントローラから、In-Sight ビジョンシステムへの入力を指定します。各ジョブに対し、最大 32 までの入力を設定することができます。

  2. [追加] ボタンを押し、[入力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよび入力などのジョブデータが含まれています。 In-Sight ビジョンシステムからシーケンサまたはロボットに転送するデータを選択し、[OK] ボタンを押してください。

    注 : [設定] タブの [読み出し先] デバイスの設定により、追加できるデータ型が異なります。 各ビットアドレスに対し、[読み出し先] デバイスをビットデバイスに設定した場合は、ブールデータタイプを追加し、使用するビットを割り当てます。 [読み出し先] デバイスをワードデバイスに設定した場合、[データ型] が設定可能となります。その場合、開始アドレスは入力データデバイスアドレスおよびワードのフィールドオフセットとなります。
  3. 追加されたデータの [開始アドレス]、入力の [名前]、[データタイプ]、[サイズ] および [値] がテーブルに表示されます。

  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

    注 :
    • [設定] タブの [読み出し先] デバイスの設定により、追加可能な [データ型] の選択肢が異なります。 [読み出し先] デバイス設定をビットデバイスに設定した場合、[データ型] ドロップダウンリストには、[ビット] のみ含まれます。 [読み出し先] デバイス設定をワードデバイスに設定した場合、[データ型] ドロップダウンリストの選択肢は、[ビット]、[16 ビット整数]、[16 ビット符号なし整数]、[32 ビット整数]、[32 ビット浮動小数点数] および [文字列] となります。
    • [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。 [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)]、[iQ-F シリーズ (3E フレーム)] または [CR800-D シリーズ (3E フレーム)] に指定している場合、最大メッセージサイズは 960 ワードです。 [コントローラタイプ] を [FX シリーズ (1E フレーム)] に指定している場合、最大メッセージサイズは 64 ワードになります。
    • [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)]、[iQ-F シリーズ (3E フレーム)] または [CR800-D シリーズ (3E フレーム))] に指定している場合、最大入力データ長は 1920 バイトです。 [コントローラタイプ] を [FX シリーズ (1E フレーム)] に指定している場合、最大入力データ長は 128 バイトです。 入力データサイズは、[メッセージサイズ (バイト)] フィールドに表示されます。
    • [データタイプのリセット] ボタンは、すべての [データタイプ] をデフォルト設定に戻します。
    • EasyBuilder に実装されている SLMP/MC プロトコルは、8 ビットおよび符号なしデータ型をサポートしていません。
  5. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
閉じた [フォーマット出力データ] タブを設定するには

[フォーマット出力データ] タブを使用して、In-Sight ビジョンシステムからの出力を指定します。各ジョブに対し、最大 128 までの出力を設定することができます。

  1. [フォーマット出力データ] タブを使用して、In-Sight ビジョンシステムから三菱シーケンサまたはロボットコントローラへの出力を指定します。

  2. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよびジョブ全体の結果などが含まれています。 In-Sight ビジョンシステムからシーケンサまたはロボットコントローラに転送するデータを選択し、[OK] ボタンを押してください。

    注 :
    • デフォルトで、Job.Inspection_Count データシンボルが自動的に出力データテーブルに追加されます。 このシンボルは、In-Sight ビジョンシステムが新しい画像を取り込み、新しい検査結果が到達したことを、シーケンサまたはロボットコントローラに警告します。 このシンボルは、アプリケーションに必要ない場合、削除可能です。
    • [設定] タブの [書き込み先] デバイスの設定により、追加できるデータ型が異なります。 [書き込み先] デバイス設定をビットデバイスに設定した場合、[データ型] ドロップダウンリストには、[ビット] のみ含まれます。 [書き込み先] デバイスをワードデバイスに設定した場合、[データ型] ドロップダウンリストの選択肢は、[ビット]、[16 ビット整数]、[16 ビット符号無し整数]、[32 ビット整数]、[32 ビット浮動小数点数] および [文字列] となります。
  3. 追加されたデータの [名前]、[データタイプ]、[サイズ]、[値]、および選択中のデータの [開始アドレス] がテーブルに表示されます。 テーブルの右側は、シーケンサまたはロボットコントローラレジスタのデータフォーマットを表示するレジスタプレビューウィンドウです。

  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

    注 :
    • [設定] タブの [書き込み先] デバイスの設定により、追加可能な [データ型] が異なります。 [書き込み先] デバイス設定をビットデバイスに設定した場合、[データ型] ドロップダウンリストには、[ビット] のみ含まれます。 [書き込み先] デバイスをワードデバイスに設定した場合、[データ型] ドロップダウンリストの選択肢は、[ビット]、[16 ビット整数]、[16 ビット符号無し整数]、[32 ビット整数]、[32 ビット浮動小数点数] および [文字列] となります。
    • [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。 [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)]、[iQ-F シリーズ (3E フレーム)] または [CR800-D シリーズ (3E フレーム)] に指定している場合、最大メッセージサイズは 960 ワードです。 [コントローラタイプ] を [FX シリーズ (1E フレーム)] に指定している場合、最大メッセージサイズは 64 ワードになります。
    • [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)]、[iQ-F シリーズ (3E フレーム)] または [CR800-D シリーズ (3E フレーム)] に指定している場合、最大出力データ長は 1920 バイトです。 [コントローラタイプ] を [FX シリーズ (1E フレーム)] に指定している場合、最大出力データ長は 128 バイトです。 出力データサイズは、[メッセージサイズ (バイト)] フィールドに表示されます。
    • [データタイプのリセット] ボタンは、すべての [データタイプ] をデフォルト設定に戻します。
    • EasyBuilder に実装されている SLMP は、8 ビットおよび符号なしデータ型をサポートしていません。
  5. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。


[設定] タブを設定するには (SLMP スキャナ)

SLMP スキャナの [設定] タブを使用して、三菱電機社製シーケンサまたはロボットコントローラとの接続を確立するのに必要な通信情報を定義します。

注 :

[デバイスの設定] グループボックスで選択したデバイスによって、[設定] タブで使用できる [コントローラタイプ] は異なります。 詳細については、三菱電機社製デバイスと通信するにはをご参照ください。

選択したデバイス ([デバイスの設定] グループボックス) 使用可能なコントローラタイプ ([設定] タブ)
PLC/モーションコントローラ
  • iQ-R/Q/L シリーズ (3E フレーム)
  • iQ-F シリーズ (3E フレーム)
  • FX シリーズ (1E フレーム)
ロボットコントローラ
  • CR-800D シリーズ (3E フレーム)
閉じた コントローラタイプ

三菱シーケンサまたはロボットコントローラのタイプを指定します。

  • PLC/MC: iQ-R/Q/L シリーズ (3E フレーム), iQ-F シリーズ (3E フレーム) or FX シリーズ (1E フレーム)。 デフォルトは、iQ-R/Q/L シリーズ (3E フレーム) です。

    注 : iQ-F シリーズ (3E フレーム) オプションは、In-Sight 4.x.x ファームウェアを搭載した In-Sight ビジョンシステムではサポートされていません。
  • ロボットコントローラ: CR800-D シリーズ (3E フレーム)
閉じた IP アドレス

三菱シーケンサまたはロボットコントローラの IP アドレスを指定します。 In-Sight ビジョンシステムに接続する、三菱シーケンサまたはロボットコントローラの IP アドレスを入力してください。

閉じた ポート番号

三菱シーケンサまたはロボットコントローラの TCP ポート番号を 10 進数 または 16 進数で定義します (10 進数: 1～65535、16 進数: 1～0xFFFF。デフォルトは、10 進数 = 12288)。

注 :
  • この値は、三菱シーケンサまたはロボットコントローラの SLMP ポートで設定するポート番号設定と一致する必要があります。
  • [ポート番号] は、In-Sight Explorer を閉じたときに [10 進値] にリセットされます。
閉じた タイムアウト (ms)

読み取りおよび書き込み操作のタイムアウト時間 (5～30,000 ミリ秒) を指定します。デフォルトは、1,000 ミリ秒です。

注 : このパラメータの設定によっては、ジョブの実行時間が長くなる可能性があります。読み取りおよび書き込み操作に失敗した場合、両方のタイムアウト時間が重なってしまうため、2 倍のタイムアウト時間がジョブに追加されます。
閉じた ポーリング間隔 (ms)

三菱シーケンサまたはロボットコントローラ上のビジョンコントロールのポール間隔を指定します (5 ～30,000 ms。デフォルトは 1,000 ms)。

閉じた リモートステーションに接続
  • [コントローラタイプ] で [iQ-R/Q/L シリーズ (3E フレーム)]、[iQ-F シリーズ (3E フレーム)] または [CR800-D シリーズ (3E フレーム)] を選択している場合、このチェックボックスを ON にすると、[ネットワーク番号]、[PC 番号] および [書込み先モジュール] コントロールを有効にします。
  • [コントローラタイプ] で [FX シリーズ (1E フレーム)] を選択している場合、このチェックボックスを ON にすると、[PC 番号] コントロールを有効にします。

デフォルトは、OFF で、In-Sight ビジョンシステムは [IP アドレス] で指定されたイーサネットモジュールを使用して、PLC またはロボットコントローラに直接接続されています。

閉じた ネットワーク番号

SLMP スキャナのネットワーク番号 (0～239、デフォルトは 0 = ローカルネットワーク) を指定します。 このコントロールは、[リモートステーションに接続] コントロールが ON の場合のみ、有効になります。

閉じた PC 番号 (16 進数)

[書込み先モジュール] で指定したネットワークの識別子を 16 進数で指定します。 このコントロールは、[リモートステーションに接続] コントロールが ON の場合のみ、有効になります。

Hex | 説明
0xFF (デフォルト) | ローカルステーションへの直接接続
0x7E | CC-Link IE フィールド上のマスターステーション
0x1～0x78 | CC Link IE フィールドネットワークアダプタ上のステーション。
閉じた 書込み先モジュール

接続するデバイスのモジュール識別子を指定します。 このコントロールは、[リモートステーションに接続] コントロールが ON の場合のみ、有効になります。

モジュールタイプ
03ff - ローカルステーション (デフォルト)
0x3d0 - コントロールシステム CPU
0x3d1 - スタンドバイシステム CPU
0x3d2 - システム A CPU
0x3d3 - システム B CPU
0x3e0 - CPU 1
0x3e1 - CPU 2
0x3e2 - CPU 3
0x3e3 - CPU 4
閉じた [リセット] ボタン

すべての設定をデフォルト設定にリセットします。

閉じた [テスト接続] ボタン

テスト用に、三菱シーケンサまたはロボットコントローラとの接続を開始します。


[デバイスのアドレス指定] タブを設定するには (SLMP スキャナ)

SLMP スキャナの [デバイスのアドレス指定] タブを使用して、シーケンサまたはロボットコントローラのアドレスや、シーケンサまたはロボットコントローラ通信用の各種データブロックのサイズを定義します。 [デバイスタイプ] およびデータブロックサイズは、[設定] タブで定義する、[コントローラタイプ] ([iQ-R/Q/L シリーズ]、[iQ-F シリーズ]、[FX シリーズ] または [CR800-D シリーズ]) によって異なります。

閉じた 名前

三菱シーケンサまたはロボットコントローラと通信するデータブロックの名前です。

閉じた 選択中のデバイス

データブロックの読み取り、書き込みに使用する三菱シーケンサまたはロボットコントローラデバイスを指定します。 ドロップダウンリストには、次のオプションが含まれています。

デバイスタイプ | フォーマット | PLC/MC |  |  | ロボットコントローラ
 |  | iQ-R/Q/L シリーズ (3E フレーム) | iQ-F シリーズ (3E フレーム) | FX シリーズ (1E フレーム) | CR800-D シリーズ (3E フレーム)
X - 入力リレー* | ビット | X | X | X |
Y - 出力リレー* | ビット | X | X | X |
M - 内部リレー* | ビット | X | X | X |
L - ラッチリレー* | ビット | X |  |  |
F - アナンシエータ* | ビット | X | X |  |
B - リンクリレー* | ビット | X |  |  |
D - データレジスタ | ワード | X | X | X | X
W - リンクレジスタ | ワード | X |  |  |
R - ファイルブロックレジスタ | ワード | X |  |  |
ZR - ファイルレジスタ | ワード | X |  |  |
R - 拡張レジスタ | ワード |  |  | X |
S - ステートリレー* | ビット |  |  | X |
*[コントロール] および [ステータス] データブロックでのみサポートされています。
注 :
  • [選択中のデバイス] を [なし] に設定した場合、SLMP スキャナを設定または変更後、In-Sight ビジョンシステムを再起動してください。
  • [なし] を選択すると、データブロックは通信されません。
  • [タイマ値] および [カウンタ値] デバイスはサポートされていません。
閉じた オフセット

データブロックを読み取ったり、書き込んだりするデバイステーブルのオフセット値を定義します。 オフセット値は、[選択中のデバイス] のタイプにより、10 進数、16 進数または 8 進数で入力します。

デバイスタイプ | フォーマット | PLC/MC |  |  | ロボットコントローラ
 |  | iQ-R/Q/L シリーズ (3E フレーム) | iQ-F シリーズ (3E フレーム) | FX シリーズ (1E フレーム) | CR800-D シリーズ (3E フレーム)
X - 入力リレー* | 16 進数 | X | X | X |
Y - 出力リレー* | 16 進数 | X | X | X |
M - 内部リレー* | 10 進数 | X | X | X |
L - ラッチリレー* | 10 進数 | X |  |  |
F - アナンシエータ* | 10 進数 | X | X |  |
B - リンクリレー* | 16 進数 | X |  |  |
D - データレジスタ | 10 進数 | X | X | X | X
W - リンクレジスタ | 16 進数 | X |  |  |
R - ファイルブロックレジスタ | 10 進数 | X |  |  |
ZR - ファイルレジスタ | 10 進数 | X |  |  |
R - 拡張レジスタ | 10 進数 |  |  | X |
S - ステートリレー* | 10 進数 |  |  | X |
*[コントロール] および [ステータス] データブロックでのみサポートされています。
閉じた デバイス数

三菱シーケンサまたはロボットコントローラと通信するデータブロックのサイズを指定します。 サイズは、シーケンサまたはロボットコントローラの「デバイス」の単位 (ワードまたはビット) で指定してください。入力ブロック、出力ブロック、コマンドおよびコマンド結果の最大データサイズは、[コントローラタイプ] ([iQ-R/Q/L シリーズ]、[iQ-F シリーズ]、[FX シリーズ] または [CR800-D シリーズ]) によって異なります。

ブロック名 | デバイス数
 | iQ-R/Q/L シリーズ、iQ-F シリーズ、CR800-D シリーズ | FX シリーズ
コントロール | 32 ビット (読み取り専用)
ステータス | 32 ビット (読み取り専用)
入力ブロック | 4 + 入力データ長 (最大: 960 ワード) | 4 + 入力データ長 (最大: 64 ワード)
出力ブロック | 12 + 出力データ長 (最大: 960 ワード) | 12 + 出力データ長 (最大: 64 ワード)
コマンド | 0 ～ 960 ワード | 0 ～ 64 ワード
コマンド結果 | 0 ～ 960 ワード | 0 ～ 64 ワード
注 :

iQ-R/Q/L シリーズ、iQ-F シリーズおよび CR800-D シリーズは、現在使用可能なほとんどのフレームフォーマットを処理することができます (3E フレーム)。 しかし、FX シリーズ は、第一世代のプロトコルメッセージフレーム (1E フレーム) のみを処理することが可能で、パケット内で通信できるデータ量も限られています。

 | 最大データサイズ
 | iQ-R/Q/L シリーズ、iQ-F シリーズ、CR800-D シリーズ | FX シリーズ
バッチ読み取りビット | 7904 ビット | 256 ビット
バッチ読み取りワード | 960 ワード | 64 ワード
バッチ書き込みビット | 7904 ビット | 160 ビット
バッチ書き込みワード | 690 ワード | 64 ワード
閉じた 説明

データブロックの説明。


[フォーマット入力データ] および [フォーマット出力データ] タブを設定するには (SLMP スキャナ)

[設定] および [デバイスのアドレス指定] タブの設定後、[フォーマット入力データ] および [フォーマット出力データ] タブを設定します。これらのタブを使用して、三菱シーケンサまたはロボットコントローラと In-Sight ビジョンシステムの間で送受信されるツールまたはジョブデータを定義します。

閉じた [フォーマット入力データ] タブを設定するには

[フォーマット入力データ] タブを使用して、In-Sight ビジョンシステムへの入力を指定します。各ジョブに対し、最大 32 までの入力を設定することができます。

  1. [フォーマット入力データ] タブを使用して、三菱シーケンサまたはロボットコントローラから、In-Sight ビジョンシステムへの入力を指定します。各ジョブに対し、最大 32 までの入力を設定することができます。
  2. [追加] ボタンを押し、[入力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよび入力などのジョブデータが含まれています。 In-Sight ビジョンシステムからシーケンサまたはロボットに転送するデータを選択し、[OK] ボタンを押してください。
  3. 追加されたデータの [開始アドレス]、入力の [名前]、[データタイプ]、[サイズ] および [値] がテーブルに表示されます。

  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

    注 :
    • [データ型] ドロップダウンリストから [文字列] または [バイト変換文字列] を選択すると、[エレメントごとのデータ長 (ワード)] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。
    • [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)]、[iQ-F シリーズ (3E フレーム)] または [CR800-D シリーズ (3E フレーム)] に指定している場合、最大メッセージサイズは 960 ワードです。[FX シリーズ (1E フレーム)] を指定している場合、最大メッセージサイズは 64 ワードです。
    • [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)]、[iQ-F シリーズ (3E フレーム)] または [CR800-D シリーズ (3E フレーム)] に指定している場合、最大入力データ長は 1920 バイトです。 [FX シリーズ (1E フレーム)] に指定している場合、最大入力データ長は 128 バイトです。 入力データサイズは、[メッセージサイズ (バイト)] フィールドに表示されます。
    • [データタイプのリセット] ボタンは、すべての [データタイプ] をデフォルト設定に戻します。
    • EasyBuilder に実装されている SLMP スキャナは、8 ビットデータ型をサポートしていません。

  5. [ハイバイト/ローバイト] チェックボックスを OFF にし、ローバイトを先にするように指定することによって、バイトオーダをカスタマイズすることができます。デフォルトでは、PROFINET を除き、OFF となります。 [ハイワード/ローワード] チェックボックスを OFF にし、ローワードを先にするように指定することによって、ワードオーダをカスタマイズすることができます。デフォルトでは、チェックボックスは OFF となります。

    注 : バイトオーダまたはワードオーダに関する変更は、[フォーマット出力データ] および [フォーマット入力データ] タブのすべてのデータ符号に影響します。

  6. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。

閉じた [フォーマット出力データ] タブを設定するには

[フォーマット出力データ] タブを使用して、In-Sight ビジョンシステムからの出力を指定します。各ジョブに対し、最大 128 までの出力を設定することができます。

  1. [フォーマット出力データ] タブを使用して、In-Sight ビジョンシステムから三菱シーケンサまたはロボットコントローラへの出力を指定します。
  2. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよびジョブ全体の結果などが含まれています。 In-Sight ビジョンシステムからシーケンサまたはロボットコントローラに転送するデータを選択し、[OK] ボタンを押してください。
  3. 追加されたデータの [名前]、[データタイプ]、[サイズ]、[値]、および選択中のデータの [開始アドレス] がテーブルに表示されます。 テーブルの右側は、シーケンサまたはロボットコントローラレジスタのデータフォーマットを表示するレジスタプレビューウィンドウです。

  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

    注 :
    • [データ型] ドロップダウンリストから [文字列] または [バイト変換文字列] を選択すると、[エレメントごとのデータ長 (ワード)] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。
    • [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)]、[iQ-F シリーズ (3E フレーム)] または [CR800-D シリーズ (3E フレーム)] に指定している場合、最大入力データ長は 960 ワードです。 [コントローラタイプ] を [FX シリーズ (1E フレーム)] に指定している場合、最大メッセージサイズは 64 ワードになります。
    • [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)]、[iQ-F シリーズ (3E フレーム)] または [CR800-D シリーズ (3E フレーム)] に指定している場合、最大入力データ長は 1920 バイトです。 [FX シリーズ (1E フレーム)] に指定している場合、最大メッセージサイズは 128 バイトになります。 出力データサイズは、[メッセージサイズ (バイト)] フィールドに表示されます。
    • [データタイプのリセット] ボタンは、すべての [データタイプ] をデフォルト設定に戻します。
    • EasyBuilder に実装されている SLMP スキャナは、8 ビットデータ型をサポートしていません。
  5. [ハイバイト/ローバイト] チェックボックスを OFF にし、ローバイトを先にするように指定することによって、バイトオーダをカスタマイズすることができます。デフォルトでは、PROFINET を除き、OFF となります。 [ハイワード/ローワード] チェックボックスを OFF にし、ローワードを先にするように指定することによって、ワードオーダをカスタマイズすることができます。デフォルトでは、チェックボックスは OFF となります。変更事項は、プレビューウィンドウに更新されます。
  6. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。


三菱イーサネットネイティブ文字列ロボット通信を設定するには

個々のツールやジョブの結果などの EasyBuilder ジョブデータを使用して、ロボットコントローラと通信することができます。 データを選択し文字列にフォーマットした後、ロボットコンローラは、文字列中のすべてのフォーマットデータを返す、ネイティブモードコマンド GetValue (GVJob.Robot.FormatString) を送信してデータを要求することができます。

注 : In-Sight 2000 シリーズビジョンセンサは、ロボットコントローラをサポートしていません。

ネイティブモード通信用にデータを文字列にフォーマットするには、次の手順に従ってください。

注 : これらのコントロールを有効にするには、In-Sight ビジョンシステムをオフラインにしてください。
  1. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータや入力データなどの追加ジョブデータが含まれています。
  2. [出力データの選択] ダイアログから、In-Sight ビジョンシステムから送信するデータを選択し、[OK] ボタンを押します。1 個の文字列には、最大 40 までのアイテムを選択することができます。
  3. データを追加したら、リスト中のアイテムを選択し、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更することができます。また、[削除] ボタンを押して、不必要なアイテムを削除することができます。
  4. アイテムのデータタイプに [浮動小数点] が含まれる場合、[小数部の桁数] コントロールが有効になります。このコントロールを使用して、浮動小数点の小数点の桁数を設定することができます (0~6、デフォルト = 3)
  5. データリストの右にあるウィンドウに、参照用として、フォーマット文字列および文字列長 (文字列中の文字数) が表示されます。文字列中の値を区切るために、コンマが自動的に挿入されます。
  6. 文字列がフォーマットされた後、ロボットコントローラは In-Sight ネイティブモード コマンド、GetValue (GVJob.Robot.FormatString) を送信して、データ文字列を要求することができます。


三菱シリアルネイティブ文字列ロボット通信を設定するには

個々のツールやジョブの結果などの EasyBuilder ジョブデータを使用して、ロボットコントローラと通信することができます。 データを選択し文字列にフォーマットした後、ロボットコンローラは、文字列中のすべてのフォーマットデータを返す、ネイティブモードコマンド GetValue (GVJob.Robot.FormatString) を送信してデータを要求することができます。

注 : In-Sight 2000 シリーズビジョンセンサは、ロボットコントローラをサポートしていません。

ネイティブモード通信用にデータを文字列にフォーマットするには、次の手順に従ってください。

注 : これらのコントロールを有効にするには、In-Sight ビジョンシステムをオフラインにしてください。
  1. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータや入力データなどの追加ジョブデータが含まれています。
  2. [出力データの選択] ダイアログから、In-Sight ビジョンシステムから送信するデータを選択し、[OK] ボタンを押します。1 個の文字列には、最大 40 までのアイテムを選択することができます。
  3. データを追加したら、リスト中のアイテムを選択し、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更することができます。また、[削除] ボタンを押して、不必要なアイテムを削除することができます。
  4. アイテムのデータタイプに [浮動小数点] が含まれる場合、[小数部の桁数] コントロールが有効になります。このコントロールを使用して、浮動小数点の小数点の桁数を設定することができます (0~6、デフォルト = 3)
  5. データリストの右にあるウィンドウに、参照用として、フォーマット文字列および文字列長 (文字列中の文字数) が表示されます。文字列中の値を区切るために、コンマが自動的に挿入されます。
  6. 文字列がフォーマットされた後、ロボットコントローラは In-Sight ネイティブモード コマンド、GetValue (GVJob.Robot.FormatString) を送信して、データ文字列を要求することができます。

  7. [シリアルポートの設定] タブをクリックし、シリアルポートを定義してください (必要な場合のみ)。 EasyBuilder は、[デバイスの設定] グループボックスに基づいて、シリアルプロトコルを自動的に検討します。 [通信] ステップから他のステップに移るときに、シリアルポート設定は In-Sight ビジョンシステムに保存されます。

    注 :

    • [シリアルポート設定] オプションは、In-Sight モデルおよび I/O モジュールによって異なります。サポートしている I/O モジュールに接続している場合、[I/O モジュール] ボタンをクリックし、[I/O モジュールの設定] ダイアログを開いて、I/O モジュールを設定します。

    • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

    • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。
    • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

    • CIO-WENET I/O モジュールは、シリアル通信をサポートしません。


TCP/IP 上で通信するには

In-Sight センサと他の TCP/IP デバイスを接続し、ネットワークを介してデータを共有する TCP/IP クライアントデバイスとして動作するように、In-Sight センサを設定することができます。 TCP/IP 接続が確立したら、EasyBuilder はネットワーク上の他の TCP/IP デバイスと通信を開始することができます。

In-Sight センサを TCP/IP サービスクライアントデバイスとして設定するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから [その他] を選択します。
  3. [プロトコル] ドロップダウンリストから [TCP/IP] を選択します。
  4. [OK] ボタンを押します。
  5. [TCP/IP] タブをダブルクリックし、接続を確定する TCP/IP サービスデバイスの名前を [サーバホスト名] フィールドに入力します。

  6. TCP/IP デバイスとの間で接続を確立する TCP/IP サーバのポート番号を　[ポート] フィールドに入力します。 入力されたポート番号は、サーバにも割り当てる必要があります。

    注 : 有効なポート番号は、In-Sight の通信に使用されるポートを除く、1～65535　の間の未使用の番号です。 PC のサービスで予約されているポート番号との競合を避けるために、In-Sight エミュレータの設定では、必ず 3000 (デフォルト) 以降のポート番号を割り当ててください。
  7. TCP/IP 接続の確立を試みてから中断するまでの待機時間をミリ秒単位 (100～15000、デフォルト = 1000) で指定します。

  8. [終端記号] ドロップダウンリストから、カスタマ終端記号の文字列を選択して、ASCII 文字 (0～255) を指定します。

    閉じた カスタマ終端記号文字列
    終端記号 | 説明
    文字列 CR+LF (デフォルト) | ASCII 文字 13 (キャリッジリターン) と 10 (ラインフィード) が文字列データに追加されます。
    文字列 CR (13) | ASCII 文字 13 (キャリッジリターン) が文字列データに追加されます。
    文字列 LF (10) | ASCII 文字 10 (ラインフィード) が文字列データに追加されます。
    文字列 ヌル文字 (0) | ASCII 文字 0 (ヌル文字) が文字列データに追加されます。
  9. TCP/IP 設定が確立したら、[フォーマット文字列] タブをクリックして、通信されるデータフォーマットを選択します。
注 : TCP/IP は「セカンダリ」プロトコルです。「プライマリ」プロトコルと共にジョブに追加することができます。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。


UPD 上で通信するには

In-Sight ビジョンシステムと他の UDP サーバを接続し、ネットワークを介してデータを共有する UDP サーバまたはクライアントデバイスとして動作するように、In-Sight ビジョンシステムを設定することができます。

TCP の代換プロトコルである UDP (ユーザデータグラムプロトコル)は、インターネット上でメッセージを交換する場合に、限られた量のサービスを提供する、コネクションレス通信トランスポート方法です。 TCP とは異なり、UDP は確認応答したり、データを確実に届けたり、シーケンスパケットを提供したりしません。

ビジョンシステムを UDP クライアントデバイスまたはサーバデバイスとして設定するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから [その他] を選択します。
  3. [プロトコル] ドロップダウンリストから [UDP] を選択します。
  4. [OK] ボタンを押します。
  5. [UDP の設定] タブを設定したら、必要に応じて、入力文字列およびフォーマット出力文字列を選択します。
閉じた [UDP の設定] タブ
閉じた モード

In-Sight ビジョンシステムをクライアントまたはサーバとして設定するかどうかを指定します。選択肢は、[クライアント]、[クライアント (応答あり)]、[サーバ]、[サーバ (応答あり) ] で、デフォルトは、[クライアント] です。 UDP 通信のパラダイムでは、クライアントとは、ネットワーク上の他のコンピュータシステム (サーバ) のリモートサービスにアクセスするシステムのことです。一方、サーバとは、他のネットワーク上のデバイスからのデータ要求を処理する、ネットワーク上のデバイスのことです。

  • クライアント: ビジョンシステムは、指定サーバにデータを送信します。
  • クライアント (応答あり): ビジョンシステムは、指定サーバにデータを送信し、[タイムアウト] パラメータで設定した制限時間中、サーバからの応答メッセージを待ちます。
  • サーバ: ビジョンシステムは、指定サーバからデータを受信します。
  • サーバ (応答あり): ビジョンシステムは、指定サーバとしてデータを受信し、クライアントデバイスに確認応答メッセージを送信します。
閉じた サーバホスト名

UDP サーバのホスト名または IP アドレスを指定します。 [モード] パラメータが [サーバ] または [サーバ (応答あり)] に設定されていると、このパラメータは無効となります。

閉じた ポート

UDP サーバと UDP デバイス間の通信ポート番号を指定します。 In-Sight ビジョンシステムをサーバとして設定し、[サーバホスト名] を指定すると、[ポート] パラメータはデバイスにポート番号を割り当てます。 ビジョンシステムをクライアントとして設定する場合、ポート番号は UDP サーバのポート番号と同一にする必要があります。

閉じた タイムアウト

クライアントデバイスからメッセージが送信されたときに、サーバデバイスからの確認応答を受信するまでの時間制限をミリ秒単位で指定します (100～15000、デフォルト = 1000)。

注 : [タイムアウト] パラメータは、[モード] パラメータを [クライアント (応答あり)] に設定した場合のみ、有効となります。
閉じた [入力文字列] タブ

他のデバイスから EasyBuilder ツールの文字列入力に使用する文字列を指定します。入力文字列には、マッチ文字列 ([検査] ステップの ID コードの読み取り、1D コードの読み取り、1D コードの読み取り (1-20)、2D コードの読み取り、2D コードの読み取り (1-20)、郵便コードの読み取り識別ツール、または文字認識識別ツールで指定します) などがあります。

注 : [入力文字列] タブは、[モード] パラメータを [クライアント] に設定した場合、無効となります。
閉じた 入力名

ドロップダウンメニューから、入力する EasyBuilder ジョブまたはツールプロパティを選択します。

注 : 識別ツールで PLC または PC などの外部デバイスから文字列を入力するには、トピック「識別ツールにデータを入力するには」をご参照ください。
閉じた フォーマット出力文字列

[モード] パラメータを [クライアント]、[クライアント (応答あり)]、または [サーバ (応答あり)] に設定したときに、UDP サーバに送信するデータを指定します。

注 : [フォーマット出力文字列] タブは、[モード] パラメータを [サーバ] に設定した場合、無効となります。
閉じた カスタムフォーマット
  1. [フォーマット出力文字列] タブから、[カスタムフォーマット] ボタンをクリックして、[FormatString] ダイアログ開きます。このダイアログを使用して、ロボットに送信されるデータを追加したり、カスタマイズしたり、データの順番を変更したりすることができます。
  2. ダイアログの [追加] ボタンを押して、[出力データの選択] ダイアログを開きます。
  3. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータおよびジョブ全体の結果が含まれています。 In-Sight センサから送信するデータをダイアログから選択したら、[OK] ボタンを押します。
  4. [FormatString] ダイアログが再び表示されます。
  5. 文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更したりすることができます。 文字列の変更を終了したら、[OK] ボタンを押します。
  6. 文字列がフォーマットされたら、ジョブの終了後に、出力データを送信するようになります。
注 : UDP は「セカンダリ」プロトコルです。「プライマリ」プロトコルと共にジョブに追加することができます。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。


POWERLINK 上で通信するには

注 : DeviceNet、POWERLINK および CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムのみで使用可能です。In-Sight ファームウェア 5.1.0 以降をを搭載した In-Sight ビジョンシステムでは使用できません。 モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

POWERLINK ネットワークと通信するように、In-Sight ビジョンシステムを設定することができます。

POWERLINK と通信するには、次の手順に従ってください。

  1. [通信] アプリケーションステップを開きます。 [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから [PLC] を選択します。
  3. [メーカー] ドロップダウンリストから [B&R] を選択します。
  4. [プロトコル] ドロップダウンリストから [POWERLINK] を選択します。
  5. [OK] ボタンを押します。

[通信] グループボックスの設定後、[設定]、[フォーマット入力データ] および [フォーマット出力データ] タブを設定してください。

  • 閉じた [POWERLINK の設定] ダイアログ

    有効: In-Sight ビジョンシステム上で POWERLINK を有効にします (デフォルト = OFF)。

    ノード ID: POWERLINK ネットワーク上の In-Sight ビジョンシステムのノード ID (1～239、デフォルト = 1) を定義します。 このコントロールは、[有効] チェックボックスが ON の場合のみ、有効になります。 ノード ID を POWERLINK ネットワークの NAT IP アドレスと共に使用することによって、POWERLINK ネットワーク外のデバイスと通信することができます。 例えば、デフォルトの NAT IP アドレスは 192.168.101.0 です。 ノード ID が 26 である In-Sight ビジョンシステムと通信するには、NAT IP アドレスをノード ID と結合し、192.168.101.26 とします。

    注 : POWERLINK プロトコルを有効にするには、In-Sight ビジョンシステムを再起動する必要があります。
  • フォーマット入力/出力タブ
注 :
  • 詳細については、『In-Sight® Explorer ヘルプ』ファイルをご参照ください。
  • オプションで、[デバイスの追加] ボタンをクリックして「セカンダリ」プロトコルをジョブに追加します。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。


識別ツールにデータを入力するには

PLC や PC などの外部デバイスから識別ツールに文字列を入力するには、次の手順に従ってください。

  1. [検査] ステップで、ID コードの読み取り、1D コードの読み取り、1D コードの読み取り (1-20)、2D コードの読み取り、2D コードの読み取り (1-20)、郵便コードの読み取り識別ツール、または文字認識識別ツールを追加します。
  2. ID コードの読み取り、1D コードの読み取り、1D コードの読み取り (1-20)、2D コードの読み取り、2D コードの読み取り (1-20)、郵便コードの読み取り識別ツールでは、[設定] タブの [モード] を [マッチ文字列] に設定します。文字認識ツールでは、[設定] タブの[モード] を [照合] または [認識と照合] に設定します。
  3. [通信] アプリケーションステップをクリックします。
  4. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  5. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから [その他] を選択します。
  6. [プロトコル] ドロップダウンリストから [シリアルテキスト] を選択します。
  7. [OK] ボタンを押します。
  8. [入力文字列] タブをクリックします。
  9. [入力名] ドロップダウンリストから、マッチ文字列の結果を選択します。 EasyBuilder は自動的にジョブを検査し、定義済みツールのマッチ文字列をメニューに表示します。

  10. [シリアルポートの設定] タブをクリックし、アプリケーションに合わせて設定を調整します (必要な場合のみ)。

    注 :

    • [シリアルポート設定] オプションは、In-Sight モデルおよび I/O モジュールによって異なります。サポートしている I/O モジュールに接続している場合、[I/O モジュール] ボタンをクリックし、[I/O モジュールの設定] ダイアログを開いて、I/O モジュールを設定します。

    • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

    • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。
    • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

    • CIO-WENET I/O モジュールは、シリアル通信をサポートしません。

  11. [フォーマット出力文字列] タブをクリックし、[カスタムフォーマット] ボタンを押します。[FormatString] ダイアログから、ツールの結果を選択し、フォーマットします。

    注 : 外部デバイスからマッチ文字列が入力されるまで、ID コードの読み取りツールまたは文字認識ツールの結果は FAIL となり、マッチ文字列フィールドは TRIG を表示します。
  12. ダイアログの [追加] ボタンを押して、[出力データの選択] ダイアログを開きます。
  13. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータおよびジョブ全体の結果が含まれています。 In-Sight センサから送信するデータをダイアログから選択したら、[OK] ボタンを押します。
  14. [FormatString] ダイアログが再び表示されます。
  15. 文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更したりすることができます。 文字列の変更を終了したら、[OK] ボタンを押します。
  16. 文字列がフォーマットされたら、ジョブの終了後に、出力データを送信するようになります。
  17. In-Sight センサをオンラインにすると、ツールは入力文字列を受信し、文字列の読み取りまたは照合を試みます。


出力文字列をフォーマットするには

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[その他] を選択します。
  3. [プロトコル] ドロップダウンリストから、[イーサネットネイティブ]、[シリアルネイティブ]、[シリアルテキスト] または [TCP/IP] を選択します。
  4. [フォーマット出力文字列] タブから、[カスタムフォーマット] ボタンをクリックして、[FormatString] ダイアログ開きます。このダイアログを使用して、ロボットに送信されるデータを追加したり、カスタマイズしたり、データの順番を変更したりすることができます。
  5. ダイアログの [追加] ボタンを押して、[出力データの選択] ダイアログを開きます。
  6. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータおよびジョブ全体の結果が含まれています。In-Sight センサから送信するデータをダイアログから選択したら、[OK] ボタンを押します。
  7. [FormatString] ダイアログが再び表示されます。
  8. 文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更したりすることができます。文字列の変更を終了したら、 [OK] ボタンを押します。
  9. 文字列がフォーマットされたら、ジョブの終了後に、出力データを送信するようになります。


Rockwell ControlLogix PLC と通信するには

ここでは、In-Sight 2000 ビジョンシステムと ControlLogix または CompactLogix PLC の間で、 EtherNet/IP ネットワークを介し、Rockwell RSLogix 5000 ソフトウェアを使用してデータ送受信を行う方法を説明します。

RSLogix の IO Structure で、In-Sight ビジョンシステムを設定するには

PLC 通信用に In-Sight ビジョンシステムを設定するには

In-Sight 2000 ビジョンシステムに RSLogix PLC からジョブをロードするには


RSLogix の IO Structure で、In-Sight ビジョンシステムを設定するには

非明示的接続およびデータ送受信を設定する手順は、ビジョンセンサにインストールされているファームウェアバージョンおよび RSLogix 5000 ソフトウェアのバージョンによって異なります。詳細については、In-Sight® Explorer ヘルプファイルの [Communicate with a Rockwell ControlLogix PLC] トピックをご参照ください。

In-Sight ビジョンシステムを RSLogix 5000 v14-16 に統合するには

In-Sight ビジョンシステムを RSLogix 5000 v17-19 に統合するには

In-Sight ビジョンシステムを RSLogix 5000 v20 に統合するには

In-Sight ビジョンシステムの入出力アセンブリオブジェクト


In-Sight ビジョンシステムを RSLogix 5000 v14-16 に統合するには

このトピックでは、In-Sight 5.2.0 以降のファームウェアを搭載する In-Sight ビジョンシステムを、バージョン 20 以降の RSLogix 5000 に統合する方法について説明します。 RSLogix 5000 のこれらのバージョンは EDS ファイルをサポートしていないため、汎用の ETHERNET-MODULE を使用する必要があります。 In-Sight Explorer には、.L5X ファイルが含まれています。このファイルは、PLC コントローラのタグデータとユーザフレンドリーなプログラムタグの間でコピーすることができ、In-Sight 5.2.x 以降のファームウェアを搭載するビジョンセンサの信号を示します。

  1. RSLogix 5000 を開き、PLC のプロジェクトをロードします。

    注 : RSLogix 5000 に接続を追加するには、PLC がオフラインである必要があります。

  2. Ethernet Communications Card に接続を追加します。 [I/O Configuration] ノードで、Ethernet Module の下にある [Ethernet] ノードを選択し、アイコンを右クリックして、メニューから [New Module] を選択します。

  3. [Catalog] タブの [Select Module Type] ダイアログから、Communication Module Type Category Filter、Allen-Bradley を Module Type Vendor Filter として選択し、更に ETHERNET-MODULE (Generic Ethernet Module) を選択してから、[Create] ボタンを押します。

  4. [New Module] ダイアログに以下を入力します。

    • In-Sight vision センサの名前および IP アドレス。
    • 接続パラメータ。 5.x.x ファームウェアを搭載する In-Sight ビジョンセンサでは、アセンブリインスタンスを定義する入出力アセンブリオブジェクトを設定する必要があります。 詳細については、In-Sight® Explorer ヘルプファイルの Rockwell ControlLogix PLC - In-Sight 5.x.x ファームウェアトピックをご参照ください。

  5. ビジョンセンサを RSLogix プロジェクトに追加後、L5X ラングインポートファイルを使用して、接続用の構造データを作成することができます。 [Main Routine] にアクセスします ([Controller Organizer] ペインの [Tasks] > [Main Task] > [Main Program])。

    注 : ラダープログラムを新規作成する場合、空のラング 0 を使用することができます。 ビジョンセンサを既存のプログラムに統合する場合、他のラダーを実行する前に、更新されたデータがセンサの入出力アセンブリに読み取りまたは書き込みされるよう、ラングをラダーの一番上に追加することを推奨します。

    1. メインプログラム内で、空のラングを右クリックし、[Import Rungs...] オプションを選択します。

    2. .L5X ファイルを選択します。C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

      InSightGenEth_11_CopyRung.L5X ファイルをインポートします。 ファイルを選択したら、 [Import...] をクリックします。

  6. [Import Configuration] を使用して、作成されたタグの名前を、構成と一致するように変更します。 ジェネリックモジュールは、モジュールへの入出力用に、未処理の非構造データからなる単一アレイを作成します。 Input アセンブリは、Status ブロックと Inspection Results アレイから構成される、1 つの連続した配列となります。 Output アセンブリは、Control ブロックと User Data アレイから構成される、連続した配列となります。 両者とも識別タグは付いていません。

    プロジェクトが PLC にダウンロードされ、コピー命令付きのラングが初めて実行されると、タグを含む 2 つの新しいアレイが作成されます。

    1. ジェネリックな名前がついているタグの名前を変更する必要があります。 X マークの付いている上の 2 ラインの名前を変更します。

    2. [Name] フィールドの空白をクリックすると矢印が表示され、デフォルトの [Name] 構造の変更オプションがドロップダウンに表示されます。 リストには、ステップ 4 で指定した名前と一致する名前が含まれています (In-Sight ビジョンセンサの名前。この例では、In-Sight 2000 と指定されたため、リストに表示される名前は、In-Sight 2000:I および In-Sight 2000:O)。

      これらのジェネリックな名前を、ドロップダウンのオプションと置き換えます。

    3. 下 2 ラインも同様に編集する必要があります。 名前をクリックするとカーソルアイコンが表示されます。 "_In" および "_Out" の前のテキストを、ジェネリックモジュール名あるいは簡単に識別できる名前に置き換えます (この例では、1 台のビジョンセンサのみなので、"In-Sight 2000")。

      注 : このインスタンスでは、I/O 構成に追加された各ビジョンセンサに、固有の名前が付ける必要があります。 複数のセンサを配置する場合は、作成されるコピーラングの各インスタンスが特定のセンサを指定するため、各センサごとに、これらの手順を実行する必要があります。 トラブルシューティングのためにも、簡単に識別できる名前を使用してください。

    4. すべてタグ名をデフォルト値から変更したら、[OK] ボタンを押してください。

  7. 追加したラングの下の Main Routine に新しいラングが追加されました (空のラングは削除可能です)。

  8. プロジェクトを PLC にダウンロードし、Run Mode にしてください。

  9. コピー命令付きのラングの実行後、新規タグが [Controller Tags] テーブルに作成されます 。

    この例では、In-Sight 2000:I および In-Sight 2000:O はビジョンセンサからの未処理の入出力アセンブリで、 In-Sight 2000_In および In-Sight 2000_Out は Control および Status ブロック、さらに UserData および InspectionResults アレイを含みます。


In-Sight ビジョンシステムを RSLogix 5000 v17-19 に統合するには

このトピックでは、In-Sight 5.2.0 以降のファームウェアを搭載する In-Sight 2000 ビジョンシステムを、バージョン 14-16 の RSLogix 5000 に統合する方法について説明します。 RSLogix 5000 のこれらのバージョンは EDS ファイルをサポートしていないため、汎用の ETHERNET-MODULE を使用する必要があります。 In-Sight Explorer には、.L5X ファイルが含まれています。このファイルは、PLC コントローラのタグデータとユーザフレンドリーなプログラムタグの間でコピーすることができ、In-Sight 5.2.x 以降のファームウェアを搭載するビジョンセンサの信号を示します。

  1. RSLogix 5000 を開き、PLC のプロジェクトをロードします。

    注 : RSLogix 5000 に接続を追加するには、PLC がオフラインである必要があります。

  2. Ethernet Communications Card に接続を追加します。 [I/O Configuration] ノードで、Ethernet Module の下にある [Ethernet] ノードを選択し、アイコンを右クリックして、メニューから [New Module] を選択します。

  3. [Catalog] タブの [Select Module Type] ダイアログから、Communication Module Type Category Filter、Allen-Bradley を Module Type Vendor Filter として選択し、更に ETHERNET-MODULE (Generic Ethernet Module) を選択してから、[Create] ボタンを押します。

  4. [New Module] ダイアログに以下を入力します。

    • In-Sight vision センサの名前および IP アドレス。
    • 接続パラメータ。 5.x.x ファームウェアを搭載する In-Sight ビジョンセンサでは、アセンブリインスタンスを定義する入出力アセンブリオブジェクトを設定する必要があります。 詳細については、In-Sight® Explorer ヘルプファイルの Rockwell ControlLogix PLC - In-Sight 5.x.x ファームウェアトピックをご参照ください。

  5. ビジョンセンサを RSLogix プロジェクトに追加後、L5X ラングインポートファイルを使用して、接続用の構造データを作成することができます。 [Main Routine] にアクセスします ([Controller Organizer] ペインの [Tasks] > [Main Task] > [Main Program])。

    注 : ラダープログラムを新規作成する場合、空のラング 0 を使用することができます。 ビジョンセンサを既存のプログラムに統合する場合、他のラダーを実行する前に、更新されたデータがセンサの入出力アセンブリに読み取りまたは書き込みされるよう、ラングをラダーの一番上に追加することを推奨します。

    1. メインプログラム内で、空のラングを右クリックし、[Import Rungs...] オプションを選択します。

    2. .L5X ファイルを選択します。C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

      InSightGenEth_11_CopyRung.L5X ファイルをインポートします。 ファイルを選択したら、 [Import...] をクリックします。

  6. [Import Configuration] を使用して、作成されたタグの名前を、構成と一致するように変更します。 ジェネリックモジュールは、モジュールへの入出力用に、未処理の非構造データからなる単一アレイを作成します。 Input アセンブリは、Status ブロックと Inspection Results アレイから構成される、1 つの連続した配列となります。 Output アセンブリは、Control ブロックと User Data アレイから構成される、連続した配列となります。 両者とも識別タグは付いていません。

    プロジェクトが PLC にダウンロードされ、コピー命令付きのラングが初めて実行されると、タグを含む 2 つの新しいアレイが作成されます。

    1. ジェネリックな名前がついているタグの名前を変更する必要があります。 X マークの付いている上の 2 ラインの名前を変更します。

      [Name] フィールドの空白をクリックすると矢印が表示され、デフォルトの [Name] 構造の変更オプションがドロップダウンに表示されます。 リストには、ステップ 4 で指定した名前と一致する名前が含まれています (In-Sight ビジョンセンサの名前。この例では、In-Sight 2000 と指定されたため、リストに表示される名前は、In-Sight 2000:I および In-Sight 2000:O)。

      これらのジェネリックな名前を、ドロップダウンのオプションと置き換えます。

    2. 下 2 ラインも同様に編集する必要があります。 名前をクリックするとカーソルアイコンが表示されます。 "_In" および "_Out" の前のテキストを、ジェネリックモジュール名あるいは簡単に識別できる名前に置き換えます (この例では、1 台のビジョンセンサのみなので、"In-Sight 2000")。

      3. 注 : このインスタンスでは、I/O 構成に追加された各ビジョンセンサに、固有の名前が付ける必要があります。 複数のセンサを配置する場合は、作成されるコピーラングの各インスタンスが特定のセンサを指定するため、各センサごとに、これらの手順を実行する必要があります。 トラブルシューティングのためにも、簡単に識別できる名前を使用してください。

    3. デフォルトのタグ名を変更したら、タグがどこに作成されたのか識別する必要があります。 タグを [Controller Tag] テーブルに置くには、空のボックスを右クリックし、[Toggle Tag Scope] を選択します。

    4. すべてタグ名をデフォルト値から変更したら、[OK] ボタンを押してください。

  7. 追加したラングの下の Main Routine に新しいラングが追加されました (空のラングは削除可能です)。

  8. プロジェクトを PLC にダウンロードし、Run Mode にしてください。

  9. コピー命令付きのラングの実行後、新規タグが [Controller Tags] テーブルに作成されます 。

    この例では、In-Sight 2000:I および In-Sight 2000:O はビジョンセンサからの未処理の入出力アセンブリで、 In-Sight 2000_In および In-Sight 2000_Out は Control および Status ブロック、さらに UserData および InspectionResults アレイを含みます。


In-Sight ビジョンシステムを RSLogix 5000 v20 に統合するには

このトピックでは、In-Sight 5.2.0 以降のファームウェアを搭載する In-Sight 2000 ビジョンシステムを、バージョン 20 以降の RSLogix 5000 に統合する方法について説明します。 EDS ファイルは、バージョン 20 以降の RSLogix 5000 でサポートされています。 In-Sight Explorer には、.L5X ファイルが含まれています。このファイルは、In-Sight 5.2.x 以降のファームウェアを搭載するビジョンセンサの信号が表示するタグデータを、使いやすいプログラムタグに置きかえます。 InSight_11_CopyRung.L5X ファイルは、 5.x ファームウェアを搭載しているセンサに使用されます。

  1. EDS モジュールを RSlogix5000 に作成・追加します。

    1. EDS ファイルは、Insight Explorer ソフトウェアとともに、以下のディレクトリにインストールされます。C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\EDS
    2. RSLogix5000 の [Tools] ドロップダウンメニューから、EDS インストールツールを実行し、In-Sight 2000 用の EDS ファイルをインストールします。
    3. RSLogix5000 の [IO Configuration] セクションのネットワークノードを右クリックして、[New Module] メニューを選択します。

    4. [Select Module] ダイアログの [Communications] ノードを開きます。リストから In-Sight 2000-xxx を選択して OK をクリックします。

      [New Module] ダイアログが開きます。

      ビジョンセンサの名前、IP アドレスおよび接続パラメータを上に示す通りに入力します。 2 台以上のビジョンセンサが接続されている場合、各センサには固有の名前が必要です。 この例では、1 台のビジョンセンサのみを設定します。

      ヒント : ビジョンセンサが搭載するファームウェアバージョンに対応する EtherNet/IP オブジェクトモデル (入出力アセンブリビット) については、『In-Sight Explorer ヘルプ』ファイルをご参照ください。

  2. ラングのインポート

    1. [Main Routine] にアクセスします ([Controller Organizer] ペインの [Tasks] > [Main Task] > [Main Program])。 ラダープログラムを新規作成する場合、空のラング 0 を使用することができます。 ビジョンセンサを既存のプログラムに統合する場合、他のラダーを実行する前に、更新されたデータがセンサの入出力アセンブリに読み取りまたは書き込みされるよう、ラングをラダーの一番上に追加することを推奨します。

    2. ラダーの一番上にある空のラングをライトクリックし、メニューから [Import Rung] を選択します。

    3. [Import Rung] ダイアログで、インポートするラングファイル 2 個が含まれるフォルダロケーションまでナビゲートします。 In-Sight 2000 は 5.x ファームウェアを使用しているので、InSight_11_CopyRung.L5X ファイルを使用します。

    4. 適切なファイルを選択したら、[Import] ボタンをクリックします。

    5. [Import Configuration] ダイアログが開きます。タグ作成には、ジェネリックな名前が使用されています。

  3. タグ名の変更: ジェネリックモジュールは、モジュールへの入出力用に、未処理の非構造化データからなる単一アレイを作成します。 この例では、ジェネリックモジュールは In-Sight 2000:I、In-Sight 2000:0、および In-Sight 2000:C (未使用) を作成しました。 Input アセンブリは、Status ブロックと Inspection Results アレイで構成される 1 つの連続した配列となり、Output アセンブリは、Control ブロックと User Data アレイで構成された連続した配列となります。両者とも、識別タグは付いていません。 プロジェクトが PLC にダウンロードされ、コピー命令付きのラングが初めて実行されると、タグを含む 2 つの新しいアレイが作成されます (アドオン・プロファイル・モジュールが使用可能な場合に表示されるタグと同じです)。

    1. 左にフラグのついた下 2 ラインの、[Name] フィールドの空白をクリックして編集してください。 これらのタグには、In-Sight の I/O アセンブリの未処理の非構造化データが含まれています。 スペースをクリックすると、下向きの矢印が表示されます。

    2. 矢印をクリックすると、デフォルト名の変更オプションがドロップダウンに表示されます。 ここでは、ジェネリックモジュールの名前にマッチする名前が表示されています。 この例では、ジェネリックモジュールの名前が In-Sight 2000 なので、“In-Sight 2000:I” および “In-Sight 2000:O” がリストに表示されています。 両ラインを、ジェネリックモジュールの名前とマッチ/対応する名前に変更します。 注: In-Sight 2000:C は使用されていません。

    3. 次に、[Import Configuration] の上 2 ラインを編集します。 名前のテキストをクリックすると、カーソルが表示されます。 “_In” および “_Out” の前のすべての文字をジェネリックモジュールの名前に置き換えるか、あるいは簡単に識別できる名前に置き換えることを推奨します。 この例では 1 台のビジョンセンサのみを使用しているため、“In-Sight 2000” を使用します。

    4. デフォルトのタグ名がすべて変更されたため、タグがどこに作成されたのか識別する必要があります。 このステップをスキップすると、[Main Routine] の上にある [Program Tag] テーブルに新規タグが置かれることになります。

      タグを [Controller Tag] テーブルに置くには、AOP がある場合と同様に、コントローラカードアイコンのない [Import Names] 横の空のボックスを右クリックします。 これらのボックスは、次のスクリーンショットでハイライトされています。 ボックスを右クリックすると、ドロップダウンメニューが開き、[Toggle Tag Scope] を選択することができます。 選択後、コントローラカードアイコンがこれらのボックスに表示されます。

    5. すべての名前をデフォルト値から変更したら、OK ボタンを押します。

      ヒント : In-Sight 2000_In および In-Sight 2000_Out の名前は、I/O 構成に追加された各ビジョンセンサに固有の名前が付けられているのであれば、どのような名前でも構いません。 複数のセンサを配置する場合は、作成されるコピーラングの各インスタンスが特定のセンサを指定するため、各センサごとに、これらの手順を実行する必要があります。 したがって、将来のトラブルシューティングを容易にし、混乱を避けるため、名前を選択するときは注意が必要です。 例えば、2 台以上のセンサが配置されている場合、センサの名前は、“Line_One_In-Sight 2000_In” および “Line_One_In-Sight 2000_Out" とすることができます。

    6. 新しい、空のラングが [Main Routine] に追加されます。 このラングは削除できます。

  4. PLC へのダウンロード

    1. プロジェクトを PLC にダウンロードします。

    2. PLC を Run Mode にします。 コピー命令付きのラングの実行後、新規タグが [Program Tags] テーブルに作成されます (アド・オン・プロファイルがある場合、同様のことが起こります)。

      この例では、次のテーブルに示されるように、In-Sight 2000:I および In-Sight 2000:O はビジョンセンサからの未処理の入出力アセンブリで、 MyCamera_In および MyCamera_Out は Control および Status ブロック、さらに UserData および InspectionResults アレイが含まれます。


In-Sight ビジョンシステムの入出力アセンブリオブジェクト

詳細については、『In-Sight® Explorer ヘルプ』ファイルをご参照ください。


In-Sight ビジョンシステムを PLC 通信用に設定するには

PLC と通信するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[PLC/モーションコントローラ] を選択します。
  3. [メーカー] ドロップダウンリストから、PLC/MC のメーカーを選択します。 メーカー名がリストにない場合は、[その他] を選択します。
  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。 選択したメーカーが使用する通信プロトコルがリストに表示されます。
  5. [OK] ボタンを押します。

設定後、次の操作が実行できるようになります。

EtherNet/IP 上でトリガするには

Add-On プロファイルを使用して接続を確立するには

In-Sight ビジョンシステムからデータを取得するには

In-Sight ビジョンシステムにデータを送信するには


EtherNet/IP 上でトリガするには

EtherNet/IP 上でトリガするよう、In-Sight 2000 ビジョンセンサを設定するには、次の手順に従ってください。

  1. ビジョンセンサにログオンします。
  2. [画像の設定] ステップで、[トリガ] を [産業用イーサネット] に設定します。

  3. [通信] ステップで、次の設定を行います。

    1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
    2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[PLC/モーションコントローラ] を選択します。
    3. [メーカー] ドロップダウンリストから、PLC/MC のメーカーを選択します。 メーカー名がリストにない場合は、[その他] を選択します。
    4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。 選択したメーカーが使用する通信プロトコルがリストに表示されます。
    5. [OK] ボタンを押します。

  4. In-Sight ビジョンセンサをオンラインにします。

  5. PLC の I/O アセンブリタグで、Trigger Enable ビットをハイ(High) に設定し、Trigger ビットハイ(High) をトリガに設定します (参照されているビットは黄色でハイライトされます)。


Add-On プロファイルを使用して接続を確立するには

すでにビジョンシステムが EDS ファイルを使用して RSLogix プロジェクトに設定されている場合、新しい AOP プロファイルで EDS プロファイルを更新することができます。詳細については、『In-Sight® Explorer ヘルプ』ファイルをご参照ください。


In-Sight 2000 ビジョンセンサからデータを取得するには

In-Sight ビジョンシステムからデータを取得するには

PLC と通信するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[PLC/モーションコントローラ] を選択します。
  3. [メーカー] ドロップダウンリストから、PLC/MC のメーカーを選択します。 メーカー名がリストにない場合は、[その他] を選択します。
  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。 選択したメーカーが使用する通信プロトコルがリストに表示されます。
  5. [OK] ボタンを押します。

通信用にデータを設定します。

各ツールの結果またはジョブ全体の結果 (出力のみ) といった、EasyBuilder ジョブのデータを Ethernet/IP 上で取得することができます。 入力データはセンサが画像を取得した後に読み込まれ、出力データはセンサがジョブ実行を完了した後に送信されます。

  6. [フォーマット入力データ] または [フォーマット出力データ] タブをクリックします。
  7. [追加] ボタンを押し、[入力データの選択] または [出力データの選択] ダイアログを開きます。
  8. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータ、およびジョブ全体の結果 (出力のみ) が含まれています。 In-Sight センサから送信 (または受信) するデータを選択し、[OK] ボタンを押してください。

  9. データを追加したら、[データ型] ドロップダウンリストを使用して、デフォルトのデータタイプを変更することができます。

    注 : [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。
  10. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
  11. In-Sight ビジョンセンサをオンラインにします。
  12. システムをトリガします。

  13. データが、RSLogix 5000 のController -> Program Tags ノードに表示されます。


In-Sight 2000 ビジョンセンサにデータを送信するには

In-Sight ビジョンシステムにデータを送信するには

PLC と通信するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[PLC/モーションコントローラ] を選択します。
  3. [メーカー] ドロップダウンリストから、PLC/MC のメーカーを選択します。 メーカー名がリストにない場合は、[その他] を選択します。
  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。 選択したメーカーが使用する通信プロトコルがリストに表示されます。
  5. [OK] ボタンを押します。

各ツールの結果またはジョブ全体の結果 (出力のみ) といった、EasyBuilder ジョブのデータを Ethernet/IP 上で取得することができます。 入力データはセンサが画像を取得した後に読み込まれ、出力データはセンサがジョブ実行を完了した後に送信されます。

データをフォーマットするには、次の手順に従ってください。

  1. [フォーマット入力データ] または [フォーマット出力データ] タブをクリックします。
  2. [追加] ボタンを押し、[入力データの選択] または [出力データの選択] ダイアログを開きます。
  3. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータ、およびジョブ全体の結果 (出力のみ) が含まれています。 In-Sight センサから送信 (または受信) するデータを選択し、[OK] ボタンを押してください。

  4. データを追加したら、[データ型] ドロップダウンリストを使用して、デフォルトのデータタイプを変更することができます。

    注 : [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。
  5. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
  6. In-Sight ビジョンセンサをオンラインにします。
  7. RSLogix 5000 で、[Program Tags] ダイアログを開き、InSight_Top:O.Data[1] および InSight_Top:O.Data[2] タグの値を変更します。

  8. ユーザデータハンドシェイクが必要かどうかを判断します。 ユーザデータバイパスが有効になっている場合、データエクスチェンジは 4.x.x カメラと同じ動きをします。 ユーザデータバイパスが無効になっている場合 (デフォルト状態)、新ビットにより PLC と In-Sight ビジョンセンサの間のデータエクスチェンジに、新たなハンドシェイクが追加されます。 スプレッドシートにデータを表示するには、追加の手順を実行する必要があります。

    1. [ネットワークの設定] ダイアログの [ユーザデータバイパスの有効化] が ON になっている場合、EasyBuilder 上の値はすぐに更新されます。

    2. [ネットワークの設定] ダイアログの [ユーザデータバイパスの有効化] が ON になっていない場合、

      1. ユーザーデータタグを設定します。SetUserDataビットは名前付きタグです。この例では、InSight_Top：O.Control.SetUserDataとなります。
      2. User Data Ack ビットを受信すると、上記の User Data タグをクリアします。 SetUserDataAck ビットは名前付きタグで、この例では InSIght_Top：I.Status となります。 SetUserDataAck。


In-Sight 2000 ビジョンシステムに RSLogix PLC からジョブをロードするには

詳細については、『In-Sight® Explorer ヘルプ』ファイルをご参照ください。


Universal Robots との統合 - TCP/IP

Cognex 2D ビジョンシステムを Universal Robots コントローラに統合するには、Universal Robots PolyScope ソフトウェアにインストールした Cognex In-Sight 2D Robot Guidance プラグインを使用します。 このプラグインを使用して、ハンドアイキャリブレーションを設定したり、ビジョンシステムからポジション (ポーズ) の情報を取得したりします。これにより、ロボットを正しいターゲットロケーションに動かし、パーツをピックアップすることができます。 また、ビジョンシステムからの応答 (ジョブの PASS/FAIL など) をプログラムできます。 更に、ビジョンシステムがロボットアームに取り付けられている場合、ロボットの参照ポーズも設定することができます。

Cognex 2D ビジョンシステムは、TCP/IP 接続を使用して Universal Robots コントローラと通信します。 ビジョンシステムは、TCP サーバを務め、ロボットはクライアントとなります。 これらのデバイスは同一ネットワーク上にある必要があります。

注 : この機能は In-Sight 2000 ビジョンセンサではサポートされていません。

サポートされている Universal Robots は次の通りです:

  • UR3
  • UR5
  • UR10
  • e-Series

Cognex In-Sight 2D Robot Guidance プラグインは、Universal Robots PolyScope ソフトウェアバージョン 3.5.1 以降のみをサポートします。

ハンドアイキャリブレーションおよびロボットガイダンスアプリケーションを設定するには、次のタスクを実行する必要があります。

  1. Cognex In-Sight 2D Robot Guidance プラグインのインストール
  2. ロボットツールセンターポイント (TCP) を教示する
  3. ビジョンシステムをキャリブレーション用に設定する
  4. ビジョンシステムに接続し、ハンドアイキャリブレーションを実行する
  5. パーツのジョブを作成し、キャリブレーションをインポートする
  6. ビジョンシステムのポーズを設定する
  7. Universal Robots のプログラミング

URCaps Cognex プラグイン

ロボットツールセンターポイント (TCP) をティーチする

ビジョンシステムをキャリブレーション用に設定する

ビジョンシステムに接続し、ハンドアイキャリブレーションを実行する

パーツのジョブを作成し、キャリブレーションをインポートする

ビジョンシステムのポーズを設定する

Universal Robots のプログラム


URCaps Cognex プラグイン

Cognex In-Sight 2D Robot Guidance プラグインのインストール

  1. cognex.com/urcaps ウェブサイトから、Cognex URCaps ソフトウェアファイルをダウンロードします。 ファイル名は、Cognex URCaps v1.3.0.urcap です。
  2. ファイルを USB デバイスに移します。

  3. PolyScope プログラムを開きます。 メインメニューが開きます。

  4. USB デバイスを Universal Robots ティーチペンダントの右側に差し込みます。

  5. メインメニューから、Setup Robot > URCaps を選択します。 [+] ボタンをクリックして、URCaps ファイルを追加します。ファイルは、Cognex In-Sight Robot Guidance と表示されます。

Cognex In-Sight 2D Robot Guidance プラグインは、次の機能を PolyScope ソフトウェアに追加します。

  • [Program] タブに [Cognex] メニューアイテムを追加 ([Program] > [Structure] > [URCaps] > [Cognex Camera Pose])。
  • [Installation] タブの [Cognex] メニューアイテム
  • [Robot Program] ツリー内のノード: CGX_result:=CameraPose
  • 新規の変数 CGX_result を [Program] > [Command] タブに追加。 この変数を使用して、トリガ中にビジョンシステムから送信されたビジョンシステムのポーズ情報を保存します。


ロボットツールセンターポイント (TCP) をティーチする

ロボットツールセンターポイント (TCP) を教示する

ツールセンターポイント (TCP) とは、ワークパーツに接触するロボットの一部です。 TCP を教示することにより、ロボットは複数のアングル (「ウェイポイント」と呼ばれます) から同一のポジションに移動することができるようになります。

TCP は、ビジョンシステムの視野の中にある必要があります。

注 : この手順は PolyScope ソフトウェア固有のものであり、便宜上本ヘルプに含まれています。
  1. PolyScope ソフトウェアを開きます。

  2. メインメニューから、[Program Robot] を選択します。 [New Program] ウィンドウが開きます。

  3. [Pick and Place] を選択します。

  4. [Installation] > [TCP Configuration] を選択します。

  5. TCP を教示する際、次のいずれかの方法で手動で測定することができます。

    • TCP が直接 Z 軸に配置されている場合、TCP とツールフランジの中心の間の距離 (ミリメートル) を Z 軸に対して測定します。 寸法を、Z フィールドに入力します。
    • TCP が直接 Z 軸に配置されていない場合、TCP とツールフランジの中心の間の距離 (ミリメートル) を X、Y、Z 軸に対して測定します。 寸法を、X、Y、Z フィールドに入力します。

    6. 詳細については、PolyScope マニュアルをご参照ください。 このマニュアルは、Universal Robots ウェブサイトからダウンロードすることができます。


ビジョンシステムをキャリブレーション用に設定する

ここでは、次の設定を行います。

  • ロボット TCP のパターンを登録し、ビジョンシステムが位置決めできるようにします。
  • ロボットツールを追加します。
  • .CXD キャリブレーションファイルの名前を入力します。 このファイルは、キャリブレーション完了後、Cognex In-Sight 2D Robot Guidance プラグインによるキャリブレーション情報とともに格納されます。
  1. EasyBuilder からビジョンシステムに接続し、新規ジョブを作成します。
  2. [画像の設定] を選択します。 ツールセンターポイントが、ビジョンシステムの視野内にあることを確認してください。

  3. [画像取り込みの設定] で、[トリガ] を [手動] に設定します。

  4. 画像の設定を調整して、画像にフォーカスが合い、照明が均等に当たるようにします。
  5. [位置決め] を選択し、ロボットグリッパー上の TCP を位置決めするツールを追加します。
  6. [PatMax パターン] ツールをハイライトし、[設定] を選択します。

  7. [水平オフセット] および [垂直オフセット] 設定を使用し、ツールのクロスヘアを調整して TCP の中央に配置します。

  8. 次に、ロボットキャリブレーションツールを追加します ([検査] > [キャリブレーションツール] > [ロボット])。

  9. [追加] をクリックします。

    注 : このツールもスマートフィーチャーを使用します。他の特徴 (円など) を使用して、ロボットキャリブレーションツールにリンクすることができます。

  10. 画像上で、TCP を定義するのに使用したツールのクロスヘアをクリックした後、[OK] をクリックします。 ロボットツールが [パレット] の [結果] タブに追加され、パターンツールとリンクされます。

  11. ツールパレットからロボットキャリブレーションツールを選択します。デフォルトのツール名は、キャリブ_1 です。

  12. [ツールの編集] で、[設定] タブを選択します。

  13. .CXD キャリブレーションファイルの [ファイル名] を入力します。 オプションで現在の日付及び時間をファイル名に含めるには、[日付/時間の追記] チェックボックスを ON にします。 [フルネーム] フィールドに追記分を含めた名前が表示されます。
  14. ビジョンシステムをオンラインに設定します。 ロボットと通信するには、ビジョンシステムをオンラインにする必要があります。
  15. ジョブを保存します。ジョブには、キャリブレーション用のジョブであることを示す名前をつけてください。 Cognex In-Sight 2D Robot Guidance プラグインでキャリブレーションを再度行う必要がある場合、このジョブを再利用することできます。


ビジョンシステムに接続し、ハンドアイキャリブレーションを実行する

Cognex In-Sight 2D Robot Guidance プラグインを使用して、ハンドアイキャリブレーションを実行します。 これにより、ビジョンシステムの視野内での作業面 (work plane) を規定します。また、ロボットがパーツを操作するエリアを決定し、プラグインはキャリブレーションファイル (.CXD) を作成します。このファイルは、のちにメインのジョブにインポートされます。

キャリブレーションを始めるには、作業面の Width (幅) および Height (奥行き) を定義する、3 点のセットポイントを定義します。

  1. PolyScope のメインメニューから、[Program] > [Robot] > [Installation] > [Cognex] を選択します。 Cognex のウインドウが開きます。

  2. [Connection] に、ビジョンシステムの IP アドレスを入力します。 ビジョンシステムの名前がアドレスの下に表示されます。

  3. ロボットがピックするパーツを含む作業面を設定し、その作業面のサイズを書き留めます。 下の画像に Width (幅) および Height (奥行き) のサンプルポイントを示します。
    注 : 次のステップ 4 - 6 では、[OK] をクリックする前に、In-Sight EasyBuilder から手動でビジョンシステムをトリガし、ビジョンシステムが TCP を見ることができるか確認してください。

  4. まず、作業面の Width (幅) を定義します。 [(1) Work Plane Corner] の [Set Point] ボタンを選択します。 [Move] タブが表示されます。 コントロールを使用し、ロボットを作業面の最初のコーナーポイントに動かした後、[OK] を選択します。 Cognex ウィンドウで、[(1) Work Plane Corner] の隣に緑のチェックマークが表示されます。

  5. [(2) Work Plane Corner] の [Set Point] ボタンを選択します。 [Move] タブが再度表示されます。 コントロールを使用し、ロボットを作業面の 2 つ目のコーナーポイントに動かした後、[OK] を選択します。 Cognex ウィンドウで、2 つ目の [Set Point] ボタンの隣に緑のチェックマークが表示されます。

  6. 次に、3 つ目の [Set Point] を使用して、作業面の Height (奥行き) を定義します。 [(3) Work Plane Edge] の [Set Point] ボタンを選択します。 [Move] タブが再度表示されます。 コントロールを使用し、ロボットを作業面の遠端に合うように動かした後、[OK] を選択します。 Cognex ウィンドウで、3 つ目の [Set Point] ボタンの隣に緑のチェックマークが表示されます。 [Width (幅)] と [Height (奥行き)] が表示されます。

    [Start Calibration] ボタンが有効になります。

  7. キャリブレーションを開始する前に、Width　(幅) と Height (奥行き) を再度確認して、それらが満足できるものであることを確認してください。
  8. [Start Calibration] を選択し、キャリブレーションを開始します。 キャリブレーション完了後、「Calibration has finished.」メッセージが表示されます。
  9. [Start Program] または [Continue] を選択し、ウィンドウを閉じます。

キャリブレーション中、次の作業が行われます。

  • ロボットプログラムは、視野内の 15 ポイントにロボットを誘導し、ビジョンシステムに座標を送信します。
  • ビジョンシステムは画像を取得し、TCP の位置を決定します。
  • ロボットプログラムは、TCP の座標をビジョンシステムのピクセル座標にマッピングします。

キャリブレーション完了後、Cognex In-Sight 2D Robot Guidance プラグインは次の作業を行います。

  • 以前に作成したキャリブレーションジョブのロボットツールにメッセージを送信します。
  • キャリブレーションジョブで入力したファイル名で .CXD 拡張子を含むキャリブレーションファイルを作成します。 このキャリブレーションジョブをメインのジョブにインポートします。メインのジョブでは、ロボットがピックするパーツを登録します。
注 : ビジョンシステムがロボットアームに取り付けられている場合、ロボットの参照ポーズを設定するまで登録したパーツを動かさないでください。 ビジョンシステムのポーズ設定後、ロボットの参照ポーズを設定します。


パーツのジョブを作成し、キャリブレーションをインポートする

メインのジョブを作成し、ロボットがパーツをピッキングできるよう登録します。また、Cognex In-Sight 2D Robot Guidance プラグインで作成したキャリブレーションをインポートします。

  1. 新規ジョブを作成し、ビジョンシステムに接続します。 ビジョンシステムの視野内で、パーツがピッキングされることを確認してください。
  2. [画像の設定] を選択します。

  3. [画像取り込みの設定] で、[トリガ] を [手動] に設定します。

  4. [キャリブレーションタイプ] から、[インポート] を選択します。

  5. [ファイル名] から、キャリブレーションのジョブで入力した .CXD ファイル名を選択します。

  6. [位置決め] を選択し、パーツの位置決めをするツールを追加します。
  7. 必要に応じて、追加のジョブ設定を行ってください。
  8. [検査] を選択します。

  9. 演算＆ロジックツール > ロボットガイダンスを選択します。

  10. [追加] を選択し、パーツのクロスヘアをクリックし、[OK] を選択します。 ロボットガイダンスツールが [パレット] の [結果] タブに追加され、パターンツールとリンクされます。

  11. 必要に応じて、[ツールの編集] で [ツール名] やその他の設定を変更します。 ツールの用途に合わせて適切な名前に変更してください。
  12. ビジョンシステムをオンラインに設定します。


ビジョンシステムのポーズを設定する

ビジョンシステムのポーズオプションを設定することによって、ロボットプログラムにビジョンシステムの適切なロケーションが含まれるようになります。

  1. PolyScope プログラムを開きます。 メインメニューが開きます。

  2. PolyScope メインメニューから、[Program Robot] を選択します。 タブのリストが表示されます。

  3. [Empty Program] を選択します。

  4. [Structure] タブを選択します。 [Program Structure Editor] ページが表示されます。

  5. [URCaps] を選択します。 [Cognex Camera Pose] ボタンが表示されます。このボタンは、Cognex In-Sight 2D Robot Guidance プラグインを表します。

  6. [Cognex Camera Pose] ボタンを選択し、[Command] タブを選択します。 左側の [Robot Program] ツリーに [CGX_result;=CameraPose] ノードおよび次の 3 つのノードが表示されます: [Job Pass]、[Job Fail]、[No Response]。

  7. ビジョンシステムによって取得されたくないポジションをロックします。 すべての回転をロック解除したままにすると、ロボットの回転は、ロボットグリッパーの現在の回転 (プログラムが CGX_result; = CameraPose ノードに到達したときに設定される回転) に対する相対回転になります。 ポジションをロックするには、該当するチェックボックスを ON にしてください。
  8. プログラムを保存します。
注 : ビジョンシステムがロボットに取り付けられている場合、ロボット用の参照ポーズを設定してください。 ロボットに参照ポーズを設定するをご参照ください。

ロボットに参照ポーズを設定する


ロボットに参照ポーズを設定する

注 : このタスクは、ビジョンシステムがロボットアームに取り付けられている場合のみに必要です (ビジョンシステムがロボットアームに取り付けられていない場合、オプションになります)。

ロボットの参照ポーズを設定することにより、ロボットグリッパーを登録したパーツにアラインさせることができます。

  1. PolyScope の [Robot Program] ツリーで、[CGX_result;=CameraPose] ノードを選択します。 Cognex Camera Pose ウィンドウが表示されます。

  2. [Set Reference Pose] を選択します。 [Move Tool] が表示されます。

  3. このツールを使用してグリッパーを動かし、登録パーツとアラインさせることができます。
  4. 完了したら、[OK] を選択します。
  5. ビジョンシステムがロボットアーム取り付けられている場合、 [Robot Mounted] チェックボックスを ON にします。

    ビジョンシステムがロボットアーム取り付けられていない場合、チェックボックスは OFF のままにしてください。

  6. 参照ポーズを保存するには、プログラムを保存してください。


Universal Robots のプログラム

Universal Robots のプログラミング

ロボットのキャリブレーションおよび In-Sight ジョブの設定が済んだら、MoveL およびその他のロボットコマンドを使用して、ピックアンドプレイスアプリケーションをロボットにプログラムすることができます。 また、ジョブが PASS、FAIL した場合、あるいはビジョンシステムからの応答がなかった場合に、どういったアクションを取るのかを決定することができます。 Cognex In-Sight 2D Robot Guidance プラグインは、開始するにあたり、次のフレームワークを提供します。

プログラムが完了しアプリケーションを実行する場合、プログラムが CGX_result:=CameraPose ノードに達すると、次の作業が行われます。

  1. ロボットは、登録したパーツの位置を取得するためビジョンシステムに通信します。
  2. ビジョンシステムはトリガし、パーツの位置を表すポーズを返します。
  3. ポーズは、PolyScope の Program Structure Editor に CGX_result 変数として保存されます。

次に、サンプルのプログラム構成を示します。


フィルムストリップ

[フィルムストリップ] ステップを使用して、PC に保存してある画像を再生したり、ビジョンシステムに保存した画像と結果を確認したりすることができます。PC のフィルムストリップは、一般的に、PC 接続時に一時的なセットアップをしたり、既知の PASS および FAIL 画像をモニタリングするのに使用されます。センサのフィルムストリップは、一般的に、ジョブ実行時のモニタリングおよびデバックに使用されます。

注 : フィルムストリップが表示されていない場合、[表示] メニューの [フィルムストリップ] を選択するか、EasyBuilder ツールバーのフィルムストリップボタン [image] をクリックしてください。

センサの設定

PC の設定


センサの設定

ビジョンセンサオンライン時に画像を取り込む場合に、センサのフィルムストリップを使用してジョブのパフォーマンスをモニタすることができます。 画像が取得されると、取り込んだ画像および付随するジョブデータを含む、ジョブの結果がビジョンシステムの RAM に保存されます。 結果がビジョンシステムに保存されると、PASS または FAIL 画像がフィルムストリップに追加されます。 最大 20 の結果を保存することができますが、その数はビジョンシステムの解像度および RAM 空き容量によります。

例: オンラインのビジョンシステムからフィルムストリップの結果をモニタ

閉じた センサを設定するには
注 : フィルムストリップを有効にすると、ジョブの実行時間が長くなります。 このことが問題にならないかをご確認ください。問題となる場合、[キュー] ドロップダウンメニューから [無効] を選択してください。

[センサの設定] グループボックスでは、センサのフィルムストリップを設定することができます。

閉じた [キュー]

保存する結果を指定します。選択肢は、[無効] (結果を保存しません) 、[成功結果]、[失敗結果]、[成功/失敗結果]、または[成功/失敗結果を分ける] です。 デフォルトは、[無効] です。

注 :
  • [成功/失敗結果を分ける] が選択されている場合、
    • [キューのサイズ] ドロップダウンは OFF となります。
    • [PASS サイズ] および [FAIL サイズ] ドロップダウンは ON となります。
    • 成功結果および失敗結果ボタンがフィルムストリップの隣に表示されます。これらのボタンをクリックして、フィルムストリップの PASS/FAIL 結果表示を切り替えることができます。

閉じた [キューのサイズ]

保存する結果の数を指定します。 最大 20 の結果を保存することができますが、その数はビジョンシステムの解像度および RAM 空き容量によります。 指定されたキューのサイズがセンサの空き RAM 容量を超える場合、保存可能な最大結果数が自動的にセンサに割り当てられます。

注 : このオプションは、[成功/失敗結果を分ける] が [キュー] ドロップダウンから選択されている場合、OFF となります。

閉じた PASS サイズ

ビジョンシステムに保存される成功結果の数。 [PASS サイズ] および [FAIL サイズ] の総計は、ビジョンシステムがサポートする [キュー] サイズを超過することはできません。 [キュー] ドロップダウンから、[成功/失敗結果を分ける] が選択されている場合のみ、このオプションは有効になります。(最小 = 1)

閉じた FAIL サイズ

ビジョンシステムに保存される失敗結果の数。 [PASS サイズ] および [FAIL サイズ] の総計は、ビジョンシステムがサポートする [キュー] サイズを超過することはできません。 [キュー] ドロップダウンから、[成功/失敗結果を分ける] が選択されている場合のみ、このオプションは有効になります。(最小 = 1)

閉じた [キューのタイプ]

[最初のみ] または [最後] の X 個の結果を保存するか指定します。X 個 = [キューのサイズ]。 デフォルトは、[最後] です。

閉じた [オンラインモードへの切り替え時にクリアする]

ON の場合 (デフォルト) 、センサがオンラインになるたびにキューをクリアします。

閉じた [表示モード]

FAIL の結果を受け取ったときのフォルムストリップの動作を指定します。選択肢は、[失敗時に停止]、[失敗時に一時停止]、または何もしない ([ノーマル]) です。 デフォルトは、[ノーマル] です。

閉じた [表示停止時間]

[表示モード] で [失敗時に一時停止] を選択した場合に、一時停止の時間を秒単位で指定します。 (1–120、デフォルト = 5)

閉じた [LED スタイル]

フィルムストリップの PASS/FAIL 結果を図形で表示します。(緑の円 [image] および赤の四角 [image])。緑の OK [image] および赤の NG [image] 、または緑のチェックマーク [image] および赤の X [image] 。

閉じた [保存フォルダ]

フィルムストリップ画像を保存するロケーションを指定します。 書き込み権限が必要です。

閉じた センサから結果をモニタするには

フィルムストリップは、ジョブパフォーマンスのモニタ用 (オンライン時) として、または確認用 (オンライン/オフライン時) として使用することができます。

  1. EasyBuilder ツールバーのオンラインボタン [image] をクリックし、ビジョンシステムをオンラインにします。
  2. ビジョンシステム上で画像取り込みをトリガします。 画像が取り込まれると、[センサの設定] グループボックスで指定した [キュー] の設定に基づいて、画像はビジョンシステムに保存され、フィルムストリップに表示されます。
  3. PASS/FAIL 結果を示すステータスグラフィックスが更新され、表示されます。 次の場合、ビジョンシステムはオンラインのままですが、フィルムストリップは更新を停止し、「フリーズ」モードになります (画像ペイン上部の黄色のバーで表示されます)。
    • [表示モード] で [失敗時に停止] または [失敗時に一時停止] が指定され、FAIL の結果を受信した場合。

    • フィルムストリップでステータスグラフィックスが選択され、フィルムストリップの [停止] ボタンがクリックされた場合。

    「フリーズ」モードでは、フィルムストリップの結果をナビゲートしたり、ビジョンシステムから PCに画像を保存したりすることができます。 ジョブのパラメータを誤って編集してしまうのを防ぐために、すべてのアプリケーションステップは、薄く表示されたり、グレーアウトされたりします。 その間、ジョブは引き続き実行されます。 次の場合に、フィルムストリップは更新を再開し、すべてのアプリケーションステップは利用可能となります。

    • 指定された [一時停止時間] が過ぎた場合。
    • [停止] ボタンがクリックされた場合。
    • [すべての結果をクリア] ボタンがクリックされた場合。
  4. 結果のモニタを終了したら、ツールバーのオンラインボタンを再度クリックし、ビジョンシステムをオフラインに切り替えてください。
閉じた センサから PC に結果を保存するには

オンラインまたはオフラインのビジョンシステムから、書き込み権限を持つ PC 上の任意のフォルダに結果を保存することができます。その後、PC の再生モードを使用して、結果を確認します。

閉じた [保存フォルダ] の確認
  1. ビジョンシステムがオフラインであることを確認します。

  2. [保存フォルダ] フィールド右の「参照」ボタンをクリックします。

  3. [フォルダの参照] ダイアログが開きます。保存フォルダを指定してから、[OK] をクリックします。 フォルダのパスが [保存フォルダ] フィールドに表示されます。
閉じた オンラインまたはオフラインのセンサから PC に結果を保存するには
  1. フィルムストリップの結果を選択するか、[停止] ボタンをクリックして、停止モードに入ります。 このモードは、画像ペイン上部の黄色のバーで表示され、フィルムストリップをナビゲートすることができます。 ジョブのパラメータを誤って編集してしまうのを防ぐために、すべてのアプリケーションステップは、薄く表示されたり、グレーアウトされたりします。 その間、ジョブは引き続き実行されます。

  2. フィルムストリップの PC に保存ボタンをクリックします。

  3. 保存先フォルダ内の既存の結果に新しい結果を追加するには、フィルムストリップの [更新再開] ボタンまたはすべての結果をクリアボタンをクリックし、停止モードを終了します。その後、ステップ 1～2 を繰り返してください。


PC の設定

[再生] ボタンを押すと、[記録再生のオプション] ダイアログが開き、各ビジョンシステムおよびエミュレータの記録および再生を設定することができます。ビジョンシステムのオンラインまたはオフライン時にアクセス可能な PC の再生モードでは、最大 10,000 の画像を再生し、ジョブの検証を行うことができます。画像はビジョンシステムに送信され、再生された画像に対しジョブが実行されます。

例: PC から再生中のフィルムストリップ

閉じた [記録] を設定するには
注 : PC にカラー画像を記録する場合、24 ビット画像でなく、16 ビット画像で保存されます。カラー画像を使用して、カラーツールをテストする必要がある場合、FTP 経由で画像をエクスポートし ([通信] アプリケーションステップで FTP デバイスを追加します) 、画像を保存することによってフルカラーを保持することができます。
  1. [PC の設定] グループボックスの [再生] をクリックします。
  2. [記録再生のオプション] ダイアログが開いたら、[記録] タブをクリックします。
  3. [記録フォルダ] を指定してから、残りの記録パラメータを設定してください。
  4. すべての記録設定を指定したら、[OK] をクリックして、[記録再生のオプション] ダイアログを閉じます。
閉じた 画像を記録するには

  1. フィルムストリップの [PC] ボタンをクリックします。

  2. EasyBuilder ツールバーから、記録ボタンをクリックします。
  3. ビジョンシステム上で画像取り込みをトリガします。画像が取り込まれると、PASS および FAIL 画像は自動的にソートされ、指定のフォルダに保存されます。
  4. 記録ボタンを再度クリックして、記録を停止します。
閉じた 再生を設定するには
  1. [PC の設定] グループボックスの [再生] をクリックします。
  2. [記録再生のオプション] ダイアログが開いたら、[再生] タブをクリックします。

  3. [再生フォルダ] を指定してから、残りの記録パラメータを設定してください。

    注 : [再生] フォルダは、デフォルトでEasyBuilder サンプルジョブフォルダを参照しています。これらのサンプルジョブを使用して、[記録再生のオプション] の便利な使い方についてデモンストレーションを行うことができます。記録再生のオプションは、以前に取り込んだ画像を繰り返し再生し、ツール結果を即時に表示することから、しきい値や制限の設定を短時間で行うことができます。
  4. すべての再生設定を指定したら、[OK] をクリックして、[記録再生のオプション] ダイアログを閉じます。
閉じた PC から画像を再生するには
注 : ビジョンシステムのオンラインモード時に画像を再生するには、[画像の設定] アプリケーションステップで [トリガ] パラメータを [外部]、[手動] または [ネットワーク] に設定する必要があります。

  1. フィルムストリップの [PC] ボタンをクリックします。

  2. [トリガ] パラメータ ([画像の設定] アプリケーションステップ) が、[カメラ] または [連続] に設定されている場合、ビジョンシステムをオフラインにしてから、画像を再生してください。[トリガ] パラメータが [外部]、[手動] または [ネットワーク] に設定されている場合、ビジョンシステムはオンラインのまま画像を再生することができます。
  3. フィルムストリップの再生ボタンをクリックして、画像を再生するか、または下に説明されたナビゲーションボタンをクリックして手動で画像を循環させます。
    4. 再生 | 一時停止
最初の画像 | 前の画像
次の画像 | 最後の画像
  4. [ジョブの実行] アプリケーションステップをクリックして、[結果] テーブルを表示します (または、パレットの [結果] タブをクリックします)。


ジョブの保存

このステップを使用して、ファイル管理およびセンサメンテナンスに関するさまざまなタスクを、センサのオフライン中に行うことができます。

注 : [ユーザ] ダイアログの [オンラインでもジョブを保存] チェックボックスを ON にすると、フルアクセスまたはプロテクトのアクセス権を持つユーザは、オンライン中のジョブ保存が許可されます。[オンラインでもジョブを保存] チェックボックスが OFF の場合、ジョブを保存するにはビジョンシステムをオフラインにする必要があります。

ジョブを保存 (または新規保存) するには

スタートアップの設定を行うには

アーカイブコピーをバックアップするには

アーカイブコピーをリストアするには


ジョブを保存 (または新規保存) するには

ジョブを 閉じた 保存する場合、ツールの設定およびジョブの固有情報のみが保存されます。
注 : このステップ以前でもジョブを保存することはできますが、[ジョブの保存] ステップは、ジョブの保存を促す役割を果たします。EasyBuilder には「自動保存」機能はありません。保存されていないジョブは、センサの電源を入れ直すと失われてしまいます。

ジョブをはじめて保存する場合、[保存] は、[名前を付けて保存] と同じ動作をし、[名前を付けて保存] ダイアログを開きます。

閉じた ジョブを保存 (または新規保存) するには
  1. CTRL+S を押すか、[ジョブの上書き保存] グループボックスの [保存] または [名前を付けて保存] をクリックして、[名前を付けて保存] ダイアログを開きます。
  2. ダイアログ中、必要であれば保存するロケーションまで移動します。
  3. ジョブに名前を付けます。
  4. ダイアログの [保存] をクリックします。
閉じた 以前に保存したジョブを保存するには、次のいずれかの作業を行う必要があります。
  • [ジョブの保存] グループボックスの [保存] をクリックします。
  • CTRL+S を押します。
注 : 現在のジョブの画像を保存するには、[ファイル] メニューから [画像に名前を付けて保存] をクリックします。センサ設定およびすべての画像を保存するには、In-Sight センサまたはエミュレータにバックアップを作成します。


スタートアップの設定を行うには

[スタートアップのオプション] のコントロールを使用して、In-Sight ビジョンシステム/センサまたはエミュレータが ON になったときの、ジョブの起動方法を設定できます。この機能によって、ワークフローを効率化することができます。

注 : フルアクセス権を持つユーザのみが、スタートアップの設定をすることができます。 詳細については、[ユーザアクセス設定] ダイアログをご参照ください。詳細については、)[ユーザアクセス設定] ダイアログをご参照ください。

起動ジョブの指定

  1. ボタンをクリックします。 [スタートアップ] ダイアログが開きます。
    1. [スタートアップ時にジョブをロード] チェックボックスを ON にします。 リストが有効になり、接続中のビジョンシステム/センサ、接続中のビジョンシステムにインストールされた SD カードまたはエミュレータに保存されたジョブが表示されます。

    2. ジョブサーバが有効な場合、[スタートアップ時にリモートからジョブをロード] チェックボックスを ON にします。 リストが有効になり、ジョブサーバに保存されたジョブが表示されます。 詳細については、[ジョブサーバの設定] ダイアログをご参照ください。詳細については、[ジョブサーバの設定] ダイアログをご参照ください。

      注 :
      • デフォルトで、ジョブサーバは無効になっています。 [ジョブサーバの設定] ダイアログを使用して、ジョブサーバを有効にしてください。
      • ジョブサーバを有効にした場合、ジョブサーバに保存したジョブのみ選択することができます。 ビジョンシステム上に保存したジョブをスタートアップ時にロードするには、ジョブサーバを無効にしてください。
  2. 起動時に自動的にロードするジョブを選択します。
  3. [OK] をクリックします。 ダイアログを閉じます。

  4. [ジョブ] テキストボックスに、スタートアップジョブが表示されます。

    注 :
    • SD カードに保存されたジョブが選択された場合、[ジョブ] テキストボックスに "SDCARD/xxx.job" と表示されます。
    • [ジョブ] テキストボックスは読み取り専用です。 スタートアップジョブを変更するには、 [image] ボタンをクリックしてください。
  5. スタートアップジョブを未選択にし、空のジョブで起動したい場合は、 [image] ボタンをもう一度クリックし、[スタートアップ時にジョブをロード] または [スタートアップ時にリモートからジョブをロード] チェックボックスを OFF にしてください。

起動時にオンラインモードにする

  1. [起動時にオンラインモードにする] チェックボックスを ON にすると、スタートアップ時に現在接続中のセンサをオンラインモードにします。

    注 : この設定は、[スタートアップ] ダイアログでも有効にすることができます。


アーカイブコピーをバックアップするには

バックアップ機能を使用して、フルアクセスまたはプロテクトのアクセス権を持つユーザは、ジョブ、画像およびセンサ設定のアーカイブコピーを In-Sight ビジョンシステム/センサまたはエミュレータから、ローカル PC のハードディスクに保存することができます。

ビジョンシステム/センサまたはエミュレータのバックアップを行う前に、[システム] メニューの [オプション] ダイアログをクリックし、アーカイブデータの保存先フォルダまたはバックアップディレクトリが正しく設定されているかどうかを確認してください。

現在使用中のセンサまたはエミュレータをバックアップするには、次の手順に従ってください。

  1. [センサのメンテナンス] グループボックスの [バックアップ] をクリックします。
ヒント : [バックアップ] ダイアログ ([システム] > [バックアップ]) を使用して、異なるビジョンシステム/センサ/エミュレータから、PC または In-Sight ビジョンシステムにインストールされている SD カードにバックアップを保存することができます。 詳細については、[バックアップダイアログ] トピックをご参照ください。


アーカイブコピーをリストアするには

リストア機能を使用して、フルアクセスまたはプロテクトのアクセス権を持つユーザは、ジョブ、画像およびセンサ設定のアーカイブコピーをローカル PC のハードディスクから元の In-Sight ビジョンシステム/センサまたはエミュレータに取得することができます。ダイアログを開く前に、PC にコピーをバックアップしてください

現在使用中のセンサまたはエミュレータにアーカイブコピーをリストアするには、次の手順に従ってください。

  1. [センサのメンテナンス] グループボックスの　[リストア] をクリックします。

ヒント : [リストア] ダイアログまたは [選択してリストア] ダイアログ ([システム] > [リストア] または [選択してリストア]) を使用して、アーカイブコピーを異なる In-Sight ビジョンシステム/センサまたはエミュレータに取得したり、SD カードに保存されたバックアップをビジョンセンサにリストアしたりすることができます。 詳細については、[リストア] ダイアログトピックまたは [選択してリストア] ダイアログトピックをご参照ください。


ジョブの実行

すべてのパラメータの設定が済んだら、ジョブを実行し、結果を確認したり、トラブルシューティングの設定を行うこともできます。さらに、必要に応じて、すべてのパラメータが制限範囲内にあるか、In-Sight ビジョンシステムが正確に画像を取り込んでいるかどうかを確認するテストを行います。

センサ上でジョブを実行するには

[結果] テーブルを変更または印刷するには

[結果] テーブルを確認するには

ジョブの最適化およびトラブルシューティング

TestRun™ でジョブをテストするには


センサ上でジョブを実行するには

センサ上でジョブを実行するには、センサをオンラインに切り替える必要があります。

注 : [入力/出力] ステップで、入出力ラインの [強制] の設定を ON または OFF にした場合、[ジョブのステータス] グループボックスに警告が表示されます。 この場合、機器の電源が ON または OFF になっても危険が生じないよう、センサをオンラインまたはオフラインに切り替える前に十分注意してください。

センサをオンラインまたはオフラインに切り替えるには、次の手順に従ってください。

  • オンラインに切り替えるには: 設定ペインの [オンライン] ボタンをクリックします。 このボタンはトグルボタンで、オンライン状態ではオレンジ色となります。
    オフライン時のボタン
  • オフラインに切り替えるには: 設定ペインの [オフライン] ボタンをクリックします。 ボタンの色は青に変わり、オフライン状態に切り替わります。
    オンライン時のボタン


[結果] テーブルを変更または印刷するには

設定ペインの [オプション] をクリックして、[結果表示のオプション] ダイアログを開き、[結果] テーブルを変更することができます。

[結果表示のオプション] ダイアログのコントロールは、次の通りです。

  • 表示オプション 閉じた [列の幅の自動調整] 機能を ON/OFF にしたり、[ツールの　PASS/FAIL 数] をカウント表示またはパーセント表示にしたり、ツールのアイコン、処理時間、結果文字列、依存関係グラフィックス、有効/無効ステータスを [結果] テーブルから削除または追加することができます。

    [ツールの有効/無効ステータス] 列は、[位置決め] または [検査] ステップで定義された、ツールの ON/OFF 状態を示します。
  • ツールのオプション 閉じた 画像ペインのツールのグラフィックスオーバレイを表示/非表示にしたり ([グラフィックスの表示]) 、[結果] テーブルのツールのプロファイルを表示/非表示に切り替えることができます ([ツールの表示])。

    チェックボックスを ON/OFF にして、個々のツールに設定を適用することができます。すべてのツールを ON にするときは、[オプションの変更] の [すべて] ボタンをクリックし、すべてのツールを OFF にするときは [なし] をクリックしてください。デフォルトでは、すべてのチェックボックスは ON となっています。

    デフォルトでは、すべてのチェックボックスは ON となっています。
  • [初期値に戻す] ボタン 閉じた ソートをクリアし、[結果] テーブルをリセットして、デフォルト設定に戻します。デフォルトの表には、PASS/FAIL インジケータ、ツールの依存度関係グラフィックス、ツールのアイコン、名前、結果、PASS/FAIL (カウント表示) および時間が含まれます。列の幅は、EasyBuilder ビューにあわせて自動的に調整されます。

設定ペイン内の [結果] テーブル関連のその他のコントロールは、次の通りです。

  • [印刷] ボタン 閉じた [印刷プレビュー] ウィンドウを開きます。このウィンドウを使用して、すべてのページを印刷したり、プリセットのパーセンテージを使用してズームしたり、一度に表示するページ数を選択したり、特定のページを選択して表示したりすることができます。[ページの設定]　ダイアログを開いて、用紙のサイズ、印刷の向き、ページの余白およびプリンタを選択することができます。
  • PASS/FAIL のクリア 閉じた PASS/FAIL 数を 0 に戻し、カウントを再開します。


[結果] テーブルを確認するには

設定ペインの [結果] テーブルには、各ツールのプロファイルが表示されます。 テーブルを列によって並び替えるには、タイトル欄をクリックします。 並べかえの順番を逆にするときは、タイトル欄をもう一度クリックします テーブル内でツールをドラッグ & ドロップすることによって、ツールの順番を入れ替えることもできます。

注 : [結果] テーブル内のツールをドラッグ & ドロップすることによって、ツールの順番を変更することができます。この操作は、ジョブの実行 [結果] テーブルおよびパレットの [結果] タブの両方で実行でき、その結果は両方のテーブルに反映されます。ドラッグ & ドロップソーティングは、テーブルの [ツールの順番および依存関係グラフィックス] 行を選択しているときのみ、有効となります。行を再度選択すると、順番は逆になります。リストの順番を変更する機能は、ジョブがジョブサイズ制限に近づくと、無効になります。

デフォルトに戻すには、再度タイトル欄をクリックします。

  • PASS/FAIL インジケータ: 緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。 PASS/FAIL の基準は、[位置決め] および [検査] ステップで設定されます。

  • ツールの順番および依存関係グラフィックス: 選択されたツール (オレンジ色で提示) と他のツール間のツールの順番および依存関係を表示します。 この列を選択して、ツールをジョブに追加した順でソートします。 また、ドラッグ & ドロップしてツールの順番を変更することが可能です。 グループ演算 & ロジックツール内のツールも、必要に応じてツールをドラッグすることによって、ツールを追加したり、削除したりすることも可能です。

    注 : グループツールを他のグループツールにドロップすることはできません。また、循環参照が発生するツールをグループツールに追加することはできません。

    ツールが別のツールを参照しているときには依存関係が存在します。 各依存関係には、参照元と参照先の 2 つの部分があり、線で連結されています。 参照元とはデータのソース (入力を提供するツール) のことで、円で表されます。参照先とはデータのディスティネーション (出力を受け取るツール) のことで、矢印で表されます。 青い依存関係グラフィックスは選択したツールが参照先であることを、緑色のグラフィックスは選択したツールが参照元であることを示します。

  • ツールアイコン: 使用されているツールのタイプを視覚的に表示します。(エッジ有無判定ツール、ID コードの読み取りツール、ブロブ計数ツールなど)。
  • 名前: ツールの名前を表示します。[位置決め] または [検査] ステップでデフォルト名から変更できます。

  • 結果: ツールの結果を表示します。[位置決め] または [検査] ステップの [設定] または [制限範囲] タブにも、ツールの結果は表示されます。

    In-Sight モデル | 結果

    In-Sight 2000-110 および 2000-120/120C ビジョンセンサ

             PASS/FAIL ステータスのみ
    In-Sight 2000-130/130C ビジョンセンサ

    寸法測定および計数ツール: 標準の結果 (数値データ)
    有無判定ツール: PASS/FAIL ステータスおよびパターンの得点
    その他のツール:PASS/FAIL ステータスのみ
    In-Sight ビジョンシステム (全モデル) および In-Sight 2000 シリーズ 23X ビジョンセンサ (23M、230) | 標準の結果 (制限無し)
  • PASS: ツールの PASS 率 (PASS 結果数/すべての結果数) を数字 (デフォルト) またはパーセンテージで表示します。

  • FAIL: ツールのFAIL 率 (FAIL 結果数/すべての結果数) を数字 (デフォルト) またはパーセンテージで表示します。

    注 : ツールが OFF になっている場合、その信号は最後の状態のままとなります。 ツールが OFF になったときに FAIL 状態だった場合、PASS は 0、FAIL は 1 となります。 ただし、OFF になったツールの PASS/FAIL は、ジョブの総合 PASS/FAIL 判定には影響しません。
  • 時間 (ms): ツール実行に必要な時間をミリ秒単位で表示します。

  • 種類: ツールの種類を表示します。 例えば、PatMax RedLine™ パターン (1-10) 位置決めツールでは「PatMax RedLine™ パターン (1-10)」が表示され、PatMax® 位置決めパターン (1-10) では「PatMax® パターン (1-10)」が表示されます。

    注 : [種類] コラムを非表示にするには、右クリックして [種類を表示] を選択します。

PASS 率 (PASS/FAIL を最後にクリアしてからの総数) および表示画像のジョブ時間が、テーブル左の [ジョブのステータス] グループボックスに表示されます。

  • [結果] テーブルを変更または印刷するには


ジョブの最適化およびトラブルシューティング

この情報を使用して、トラブルシューティングをしたり、ジョブの設定を最適化 することができます。

[結果] テーブルを使用したトラブルシューティングの例は、次の通りです。

  • PASS/FAIL 数: どのツールが FAIL かを特定します。
  • ツールの依存度グラフィックス: ツールの FAIL 原因が、別の FAIL 結果のツールによるものかどうかを、両ツール間の依存関係を表示して判断します。
  • 結果文字列: どのツールが仕様外かを判断します。

ジョブの最適化を行うことによって、ジョブの処理時間を短くすることができますが、その短縮時間は個々の In-Sight センサの性能によって異なります。ジョブの最適化は、高速ラインを使用したジョブなど、応答時間が鍵となるアプリケーションにおいて有用です。

EasyBuilder ジョブを実行する際に、処理時間が長いのは次の段階です。

  • 画像取り込み時間露光時間 + CCD への転送時間
  • ツール処理: すべてのツールおよび関数の総合処理時間

ジョブの処理時間を短縮するための一般的ガイドラインは次の通りです。

  • 露光時間を短くします。
  • 部分取り込みをします。
  • 検査対象領域を小さくします。
  • 画像の回転を最小限にします。

必要であれば、[画像の設定]、 [位置決め] または [検査] ステップに戻り、パラメータを適宜変更してください。

また、主な位置決めツールおよび検査ツールの相対的な速度は次の通りです (速い順)。

  • エッジ
  • ブロブ
  • パターン

エッジツールとパターンツールを使用して同じ結果が得られるのであれば、エッジツールを使用したほうがジョブの実行時間は短くなります。

注 : 画像取り込みおよび関数処理を同時に行うことがあるので、[ジョブの実行] ステップより設置環境でのランタイムのほうが、実行時間が速いことがあります。


TestRun™ でジョブをテストするには

TestRun™ は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。TestRun は次のテストから構成されます。

  • リミットテスト: 現在のパラメータ値が、設定した上限・下限値内にあるかどうかを決定します。これらのパラメータは、ユーザがジョブ内で直接設定したり、通信プロトコルを介して外部デバイスからジョブまたは値をディスクリート入力で読み取って設定したりすることができます。
  • 画像テスト: 「良品」または「不良品」であることが分かっている一連の画像をビジョンシステムに送信し、現在のジョブ結果が各画像の予想結果と一致するかどうかを決定します。
  • ハードウェアテスト: ビジョンシステムの現在の画像品質を予想画像と比較し、カメラの位置、焦点、照明などに変化が生じたかどうかを決定します。

TestRun を使用する前に

注 : TestRun を使用できるのは、フルアクセス権限のあるユーザのみです。

TestRun は、次の条件を前提としています。

  • マシンビジョンアプリケーションがすでに設置されていて、In-Sight ビジョンシステムにジョブファイルとして保存されている。
  • [接続] ステップで、ビジョンシステムへの接続が確立されており、ジョブファイルがロードされている。
  • アプリケーションで使用される画像を含む画像データベースがすでに作成されている。
注 : 画像データベースには、「良品」 (PASS となる画像) と「不良品」 (FAIL となる画像) の両方の画像が含まれていることが望ましいです。TestRun は、様々な画像データベースファイル構成に対応していますが、TestRun を実行する前に「良品」フォルダと「不良品」フォルダに画像をソートしておくと、プロセスを簡略化することができます。

TestRun を使用するには

In-Sight ビジョンシステムに接続し、ジョブファイルをロードすると、TestRun の設定を始めることができます。TestRun の設定には、ステップバイステップで TestRun をプログラムできる [TestRun 設定] ダイアログを使用します。ダイアログの左にはナビゲーションパネルが表示され、設定するステップのセットアップ画面を選択することができます。

注 : TestRun の初期設定後、ナビゲーションパネルのステップをクリックして、各ステップに戻ることができます。

TestRun を設定するには

  1. [パレット] の [TestRun] タブをクリックします。

    注 : [パレット] が表示されていない場合、[表示] メニューから [パレット] を選択します。
  2. [設定] ボタンを押し、[TestRun 設定] ダイアログを開きます。
  3. ナビゲーションパネルに従いステップバイステップで、TestRun を設定します。詳細については、『In-Sight® Explorer ヘルプ』ファイルをご参照ください。


法律上の表示

本書で説明する本ソフトウェアは、ライセンスのもとで提供されており、かかるライセンス条項にしたがい、かつ本ページに記されている著作権表示を行うことを条件として使用および複製が許諾されます。本ソフトウェア、本書、あるいはそれらのコピーをライセンスの保有者以外に提供することはできません。本ソフトウェアのあらゆる権利は Cognex Corporation あるいは権限を有する第三者に帰属します。Cognex Corporation は、当社の供給によらない装置上での本ソフトウェアの使用または信頼性についていかなる責任も負いません。Cognex Corporation は、本ソフトウェアの商業性、非侵害または特定目的に対する適合性に関して、明示的にも黙示的にも一切の保証を行いません。

本書の内容は、予告なしに変更することがあります。本書のいかなる内容も、Cognex Corporation が何らかの約束を実行するものと解釈されてはなりません。本書あるいは関連するソフトウェアに含まれる誤りについて、Cognex Corporation はいかなる責任も負いません。

本書で例として使用されている企業名、人名およびデータは、特に断りがない限り架空のものです。本書のいかなる部分も、Cognex Corporation の書面による許諾なく複製すること、手段・方法・目的を問わず電子的または機械的に転載すること、他のメディアに変換すること、および他の言語に翻訳することを禁じます。

08/29/2022 7:36

Revision: 5.9.0.2

Copyright © 2008 - 2020。 Cognex Corporation.All Rights Reserved.

Cognex の提供するハードウェアおよびソフトウェアの一部は、下記のウェブサイトに示す米国およびその他の国の特許、または出願中の特許で保護されています。http://www.cognex.com/patents.

下記は Cognex Corporation の登録商標です。

Cognex, 2DMAX, Advantage, AlignPlus, Assemblyplus, Check it with Checker, Checker, Cognex Vision for Industry, Cognex VSOC, CVL, DataMan, DisplayInspect, DVT, EasyBuilder, Hotbars, IDMax, In‑Sight, Laser Killer, MVS‑8000, OmniView, PatFind, PatFlex, PatInspect, PatMax, PatQuick, SensorView, SmartView, SmartAdvisor, SmartLearn, UltraLight, Vision Solutions, VisionPro, VisionView

下記は Cognex Corporation の商標です。

The Cognex logo, 1DMax, 3D‑Locate, 3DMax, BGAII, CheckPoint, Cognex VSoC, CVC‑1000, FFD, iLearn, In‑Sight (design insignia with cross‑hairs), In‑Sight 2000, InspectEdge, Inspection Designer, MVS, NotchMax, OCRMax, PatMax RedLine, ProofRead, SmartSync, ProfilePlus, SmartDisplay, SmartSystem, SMD4, VisiFlex, Xpand

その他の製品名および商標は、各所有者の商標です。


CC-Link IE フィールドネットワーク Basic を介しての三菱電機オートメーションコントローラとの通信

CC-Link IE フィールド Basicは、イーサネットデバイスを三菱電機シーケンサに統合するよう設計されたプロトコルです。既存の　SLMP (MC Protocol) とは対照的に、シーケンサがマスタとして動作し、標準の UDP メッセージングを介してスレーブデバイスと通信します。 通信は、各方向に 1 局当たり 64 ビットのデータと 32 16 ビットワードのデータをサポートし、各スレーブは 4 局をサポートします。 データは、セットアップツール (GXWorks 2/3) を介してコントローラメモリにマッピングされます。

プロトコルを ON にし、ビジョンシステムをシーケンサ上に設定後、シーケンサは要求/応答メカニズムを介してビジョンシステムとの周期的通信を開始します。

In-Sight ビジョンシステムを CC-Link IE フィールド Basic プロトコル用に設定するには

このセクションでは、CC-Link 通信を使用して In-Sight ビジョンシステムに接続し、三菱 Q シリーズシーケンサに接続する方法について説明します。

CC-Link IE Field Basic を有効にする

注 :
  • EasyBuilder から CC-Link IE フィールド Basic を有効にする方法については、EasyBuilder ヘルプをご参照ください (通信 > .デバイスの設定 > 三菱電機社製デバイスと通信するには > CC-Link IE フィールド Basic)。
  • CC-Link IE フィールド Basic についての詳細は、三菱電機社の『CC-Link IE フィールド Basic リファレンスマニュアル』をご参照ください。

In-Sight Explorer

  1. In-Sight Explorer を開き、In-Sight ビジョンシステムに接続します。
  2. [センサ] メニューから、[ネットワークの設定] ダイアログを開きます。
  3. ダイアログの [産業用イーサネットプロトコル] ドロップダウンから、 [CC-Link IE フィールド Basic] を選択します。
  4. In-Sight ビジョンシステムを再起動します。再起動後、CC Link IE フィールド Basic プロトコルが有効になります。

三菱 GX Works 2

  1. 三菱 GX Works 2 ソフトウェアを開き、In-Sight ビジョンシステムに接続します。

  2. [内蔵 Ethernet ポート設定] タブをクリックし、[CC-Link IE フィールド Basic Setting] ボタンをクリックします。

  3. [CC-Link IE フィールド Basic] チェックボックスを ON にします。

  4. [Network Configuration Setting] ボタンをクリックし、[CC-Link IE フィールド Basic Configuration] ダイアログを開きます。

  5. ビジョンシステムをリンクスキャンリストに追加し、ビジョンシステムをスキャンする局数 (1-4) を選択します。

  6. 設定の変更を OK します。

  7. 同期された CC-Link IE フィールド Basic のレジスタの保存に使用する PLC メモリを選択します。

  8. ダイアログのすべてのパラメータを OK し、プロジェクトをオートメーションコントローラにダウンロードします。

  9. PLC の再起動後、CC-Link IE フィールド Basic 上でビジョンシステムをスキャンするようになります。

画像取り込みトリガを受信するための In-Sight ビジョンシステムの設定

  1. AcquireImage 関数のプロパティシートを開きます。
  2. [トリガ] パラメータを [産業用イーサネット] に設定します。
  3. In-Sight ビジョンシステムをオンラインにします。
  4. In-Sight ビジョンシステムは、RY ブロックの Trigger Enable および Trigger ビットを直接操作したり、RX ビットブロックのTrigger Ready、Trigger Ack および Missed Acq ビットをモニタリングしたりすることによって、トリガすることができます。
注 : CC-Link IE フィールドネットワーク Basic のファクトリインターフェイストピックには、In-Sight ビジョンシステムの入出力を処理メモリにマッピングするための情報が詳細に示されています。ただし、ブロックのレイアウトは、In-Sight ビジョンシステムに搭載されている In-Sight ファームウェアのバージョンによって異なります。

In-Sight ビジョンシステムからのデータの取得

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatOutputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。

  2. [FormatOutputBuffer] ダイアログの [追加] ボタンをクリックします。これでセル選択モードになります。シーケンサに転送されるデータを選択します。
  3. 送信する追加データがある場合は、[FormatOutputBuffer] ダイアログで、[追加] ボタンをクリックします。これで再びセル選択モードになります。転送する追加データを選択します。
  4. [OK] ボタンをクリックして、[FormatOutputBuffer] ダイアログを閉じます。
  5. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで WriteResultsBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  6. WriteResultsBuffer 関数の [プロトコル] パラメータを 8 = CC-Link IE フィールド Basic ビット または 9 = CC-Link IE フィールド Basic ワードに設定し、[バッファ] パラメータを、作成したばかりの FormatOutputBuffer 関数のバッファデータ構造体へのセル参照として設定します。
  7. 必要に応じて、結果コードパラメータをスプレッドシートのセルへのセル参照として設定し、検査結果を含む結果コードを取得します。

In-Sight ビジョンシステムへのデータの送信

注 : In-Sight ビジョンシステムをトリガして MELSEC シーケンサからユーザデータを読み取るためには、RY Block ブロックの Set User Data ビットをシーケンサからトリガする必要があります。
  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatInputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  2. [FormatInputBuffer] ダイアログの [追加] ボタンをクリックして、32 ビットの浮動小数点数と 32 ビットの整数をリストに追加します。
  3. [OK] ボタンをクリックして、[FormatInputBuffer] ダイアログを閉じます。
  4. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで ReadUserDataBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  5. ReadUserDataBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatInputBuffer 関数のバッファデータ構造体へのセル参照として設定します。
  6. ReadUserDataBuffer 関数の [プロトコル] パラメータを 8 = CC-Link IE フィールド Basic ビット または 9 = CC-Link IE フィールド Basic ワードに設定します。
  7. 関数が実装されたら、In-Sight ビジョンシステムをオンラインにして、設定をテストします。


CC-Link IE フィールドネットワーク Basic のファクトリインターフェイス

このトピックでは、In-Sight ビジョンシステムと CC-Link IE フィールド Basic の通信について説明します。

ポート

CC-Link IE Field Basic プロトコルは、2 つの UDP ポート上で動作します。

ポート | 説明
61450 | 周期的な要求/応答メッセージ
61451 | NodeSearch および IPAddressSet メッセージ
45237 | ベース SLMP メッセージ (GetCommunicationSetting)

信号のレイアウト

定義済みデータブロックを使用すると、ビジョンシステムがシーケンサとの間でデータの読み取り、および書き込みを行う場所を制御することができます。アプリケーションの設定を用意にするために、コマンド機能に必要なさまざまなコントロールおよびステータスビットは連続したブロックにグループ化され、これらを同時に処理することができます。ビジョンシステムとシーケンサ間の相互の設定をする場合は、データの各ブロックに対して開始アドレスとデバイスタイプを選択する必要があります。

ブロック | アドレス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
RY | 0 | 0 | Set Offline | Reserved |  | Execute Command | Inspection Results Ack | Buffer Results Enable | Trigger | Trigger Enable
 | 8 | 1 | Reserved
 | 16 | 2 | Reserved |  |  |  | Clear Exposure Complete | Clear Error | Reserved | Set User Data
 | 24 | 3 | Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0
 | 32..63* | 4..7 | User Data (Bit Area)
 | *ただし、局占有により 255 点まで可能
RWw | 0 | 0..1 | Command
 | 1..31* | 2..63 | User Data
 | *ただし、局占有により 127 点まで可能
RX | 0 | 0 | Online | Offline Reason |  |  | Missed Acq | Reserved | Trigger Ack | Trigger Ready
 | 8 | 1 | Error | Command Failed | Command Completed | Command Executing | Results Valid | Results Buffer Overrun | Inspection Completed | System Busy
 | 16 | 2 | Reserved |  |  | Job Pass | Exposure Complete | Reserved |  | Set User Data Ack
 | 24 | 3 | Soft Event Ack 7 | Soft Event Ack 6 | Soft Event Ack 5 | Soft Event Ack 4 | Soft Event Ack 3 | Soft Event Ack 2 | Soft Event Ack 1 | Soft Event Ack 0
 | 32..63* | 4..7 | Inspection Results (Bit Area)
 | *ただし、局占有により 255 点まで可能
RWr | 0 | 0..1 | Current Job ID
 | 1 | 2..3 | Error Code
 | 2 | 4..5 | Acquisition ID
 | 3 | 6..7 | Inspection ID
 | 4 | 8..9 | Inspection Result Code
 | 5..31* | 10..63 | Inspection Results
 | *ただし、局占有により 127 点まで可能

RY ブロック

バイト 0

ビット | 名前 | 説明
7 Set Offline

このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。
6-5 | Reserved | 使用されません。
4 | Execute Command | セットされると、ビジョンシステムは Command フィールドで指定したジョブ ID をロードします。 Command Completed 信号がトグルされるまで、High のまま保持する必要があります。 この信号の立ち下がりエッジ (Command Complete 以前の場合) は、中断要求と解釈されます。
3 | Inspection Results Ack | Buffer Results Enable ビットがセットされると、Inspection Results Ack ビットは、PLC/MC が Inspect Count、Inspection Result Code、および Inspection Results データを受信したことを確認応答します。 その後、次の検査結果のセットが PLC/MC に送信されます。 Inspection Results Ack ビットがクリアされると、ビジョンシステムは Results Valid ビットをセットします (バッファが空でなかった場合)。
2 | Buffer Results Enable | このビットがセットされると、Inspection Count、Inspection Result Code、および Inspection Results フィールドは、Inspection Results Ack ビットがセットされて確認応答されるまで変化しません。 最大 8 つの検査が In-Sight ビジョンシステムのバッファに保持されます。 ビジョンシステムは、Results Valid ビットをクリアすることによって、確認応答に応答します。 Inspection Results Ack ビットがクリアされて、PLC/MC に送信される新しい結果セットがあるときには、Results Valid ビットはクリアされません。 Inspection Results Ack ビットがクリアされて、PLC/MC に送信される結果がビジョンシステムのバッファにそれ以上ない場合には、Results Valid ビットはクリアされたままです。
1 Trigger

このビットをセットすると、次の条件が満たされた場合に取り込みがトリガされます。

  • In-Sight ビジョンシステムがオンラインである。
  • Trigger Enable ビットがセットされている。
  • [トリガ] パラメータが [ネットワーク]、[外部] または [産業用イーサネット] に設定されている。
注 :
  • [トリガ] パラメータは、スプレッドシートビューでは AcquireImage 関数、EasyBuilder では [画像の設定] アプリケーションステップで設定することができます。
  • トリガが PLC/MC から送信される場合、[産業用イーサネット] トリガタイプを使用してください。
0 | Trigger Enable | このフィールドは、Trigger ビット経由でトリガできるようにするために設定されます。このビットをクリアすると、ネットワークトリガメカニズムが無効になります。

バイト 1

ビット | 名前 | 説明
7-0 | Reserved | 使用されません。

バイト 2

ビット | 名前 | 説明
7-4 | Reserved | 使用されません。
3 | Clear Exposure Complete | この信号が High のときは、Exposure Complete ステータスはリセットのままです。この信号が Low に設定されると、次の露光完了時に Exposure Complete ステータスが High に設定されます。
2 | Clear Error | Error および Error Code 信号をクリアします。Clear Error 信号は、Error ビットがクリアされるまで High のまま保持する必要があります。 エラーがすでにキューに入っている場合、このビットをクリアにすると、Error および Error Code 信号が次のキューのエラーコードとして設定されます。
1 | Reserved | 使用されません。
0 | Set User Data | このコマンドは、ビジョンシステムにて消費される User Data フィールドを保持バッファに転送する必要がある場合に、PLC/MC から In-Sight ビジョンシステムへ通知します。

バイト 3

ビット | 名前 | 説明
7 | Soft Event 7 | スプレッドシートのソフトイベントのトリガを可能にします。これらのビットをセットすると、スプレッドシート内の関連するソフトイベントがトリガされます。
6 | Soft Event 6
5 | Soft Event 5
4 | Soft Event 4
3 | Soft Event 3
2 | Soft Event 2
1 | Soft Event 1
0 | Soft Event 0

バイト 4..7

ビット | 名前 | 説明
7-0 | User Data (ビットエリア) | ReadUserDataBuffer または ReadLatchedUserDataBuffer 関数を使用してスプレッドシートに読み取ることができるデータバッファ。

RWw ブロック

バイト 0..1

ビット | 名前 | 説明
7-0 | Command | Execute Command ビットが PLC によってセットされたときに、ロードするジョブのジョブ ID 番号 (0-999) を示すのに使用される 16 ビット整数。 Command フィールドは、Execute Command 信号の立ち上がりエッジと Command Completed 信号の立ち上がりエッジの間、あるいは結果が不確定の場合、変化してはなりません。

バイト 2..63

ビット | 名前 | 説明
7-0 | User Data | ReadUserDataBuffer または ReadLatchedUserDataBuffer 関数を使用してスプレッドシートに読み取ることができるデータバッファ。

RX ブロック

バイト 0

ビット | 名前 | 説明
7 | Online | このビットは、In-Sight ビジョンシステムがオンラインのときにセットされ、ビジョンシステムがオフラインのときにクリアされます。ビジョンシステムがオフラインのときには、Offline Reason フィールドを調べて、原因を判断してください。
6-4 Offline Reason このフィールドは、In-Sight ビジョンシステムがオフラインである原因を示すために使用される 3 ビットのフィールドです。
Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注 : 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。
3 Missed Acq 画像取り込み方法に関係なく、In-Sight ビジョンシステムが画像取り込みに失敗したときにセットされます。画像取り込みが正常にトリガされるとクリアされます。
注 : Trigger ビットが設定されているが、ビジョンシステムがオフラインの場合、Missed Acq および Trigger Ack もセットされます。
2 | Reserved | 使用されません。
1 Trigger Ack In-Sight ビジョンシステムが Trigger ビットのセットによってトリガされたことを示します。このビットは、Trigger ビットがクリアされるまでセットされたままです。 さらに、このビットの立ち上がりエッジに Acquisition ID をラッチすることが可能です。
注 : Trigger ビットが設定されているが、ビジョンシステムがオフラインの場合、Missed Acq および Trigger Ack もセットされます。
0 Trigger Ready

In-Sight ビジョンシステムが、Trigger ビットを介して新しいトリガを受け入れられることを示します。 このフィールドは、ビジョンシステムがオンラインであり、Trigger Enable ビットがセットされ、AcquireImage 関数の [トリガ] パラメータが [ネットワーク]、[外部] または [産業用イーサネット] に設定されて、ビジョンシステムが現在画像を取り込んでいないときに真になります。

注 : トリガが PLC/MC から送信される場合、[産業用イーサネット] トリガタイプを使用してください。

バイト 1

ビット | 名前 | 説明
7 | Error | Error Code フィールドで定義されたエラーが発生した場合にセットされます。
6 | Command Failed | ビットが 1 にセットされ、Job Load に失敗し完了まで実行できなかったことを示します。 PLC/HMI により新しいジョブがロードされると、クリアされます。 In-Sight Explorer により新しいジョブがロードされた場合は、変更はありません。 このビットは、常に Command Completed の前にセットされます。
5 | Command Completed | このビットがトグルされ、Job Load が完了したことを示します。 Command が Command Executing ビットを LOW にし、Execute Command がいまだ HIGH の場合、Command Completed がセットされます。 Command を正常に完了できなかった場合にも、Command Failed ビットはセットされます。
4 | Command Executing | このビットは、新規ジョブをロードすると 1 にセットされます。 Command Completed およびCommand Failed ビットは、このビットの立ち下がりエッジの前にセットされます。
3 Results Valid

Inspection Count ビット、Inspection Result Code ビット、Inspection Results ビット、または Job Pass ビットがセットされたときにセットします。Inspection Results Ack ビットがセットされるとクリアされます。

注 : オーバーラップモードでのジョブ処理が有効になっている場合、Buffer Results Enable ビットを有効/セットするか、あるいは Inspection Completed ビットを使用して、検査結果をラッチする必要があります。
2 Results Buffer Overrun

このフィールドは、Buffer Results Enable ビットがセットされていて、Inspection Results Ack ビットをセットすることによって PLC/MC が確認応答しなかったために In-Sight ビジョンシステムが検査結果のセットを破棄したときにセットされます。 最大 8 つの検査がビジョンシステムのバッファに保持されるため、このビットは、9 番目の検査がバッファに追加されたときにセットされます。 9 番目の検査とその後のすべての検査は、バッファに余裕がなくなるまで (結果が承認された時点で) 廃棄されます。 有効な検査が発生して、前の検査が上書きされない限り、このビットはクリアされません。
1 | Inspection Completed | このビットは、検査の完了時にトグルされます。 Inspection Count、Inspection Result Code、Inspection Results、Job Pass ビットが PLC に送信された後、トグルされることを保証します。
0 System Busy

ビジョンシステムがジョブを実行していているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。

バイト 2

ビット | 名前 | 説明
7-5 | Reserved | 使用されません。
4 Job Pass
注 :

ジョブの PASS ビッドの動作は結果バッファリングが無効か有効かによって異なります。

バッファリングが無効 | バッファリングが有効
検査が完了したときに [ジョブの PASS/FAIL] のセルが合格を示すとセットされます。そうでない場合は、クリアされたままです。 Inspection Completed ビットが立つ前のジョブ PASS ビットは有効です。 | 新しい結果が InspectionResults 属性に挿入され、[ジョブの PASS/FAIL] のセルがその結果に対して合格を示すとセットされます。そうでない場合は、クリアされたままです。InspectionResultsAck 属性を真に設定することによって結果が確認応答され、ビットがクリアされるまで、状態は変化しません。 Results Valid ビットがセットされる前のジョブ PASS ビットは有効です。
3 | Exposure Complete | このビットは、In-Sight ビジョンシステムが露光完了するとセットされ、Clear Exposure Complete ビットでリセットされます。このビットは、Clear Exposure Complete 信号が High に設定されると Low に保持されます。
2 - 1 | Reserved | 使用されません。
0 | Set User Data Ack | このビットは、Set User Data コマンド完了を確認して、セットされます。

バイト 3

ビット | 名前 | 説明
7 | Soft Event Ack 7 | これらのビットは、Soft Event コマンドが受信されたことを示すために使用されます。
6 | Soft Event Ack 6
5 | Soft Event Ack 5
4 | Soft Event Ack 4
3 | Soft Event Ack 3
2 | Soft Event Ack 2
1 | Soft Event Ack 1
0 | Soft Event Ack 0

バイト 4..7

ビット | 名前 | 説明
7-0 | Inspection Results (ビットエリア) | WriteResultsBuffer 関数を使用してスプレッドシートから書き出された検査結果データ。

RWr ブロック

バイト 0..1

名前 | 説明
Current Job ID | ビジョンシステムで現在実行中のジョブの ID 番号を示す 16 ビット整数。または、現在のジョブに ID 番号がない場合は 65535。このフィールドは、ジョブ変更の方法に関係なく、ビジョンシステムでジョブが変更されたときに更新されます。

バイト 2..3

名前 説明
Error Code

発生したエラーを 16 ビットで表します。

コード | エラー | 説明
0x0000 | No Error | 発生したエラーを 16 ビットで表します。
0x0100 | Trigger set while disabled | Trigger Enable ビットがクリアされるか、または AcquireImage 関数の [トリガ] パラメータが [外部]、[ネットワーク] または [産業用イーサネット] に設定されているときに、Trigger ビットがセットされると発生します。
0x0101 | Trigger set while Offline | ビジョンシステムオフライン中に、Trigger ビットがセットされると発生します。
0x0400 | Already Executing Error | Execute Command ビットがセットされ、Executing ビットが HIGH の場合に発生します。
0x0401 | Job load requested while Online | ビジョンシステムオンライン中に、Job Load コマンドが発行されたときに発生します。

バイト 4..5

名前 | 説明
Acquisition ID | この ID は、画像取り込み開始および Trigger Ack ビットがセットされたときに増分されます。画像取り込みとその Inspection Results を同期化するために使用できます。

バイト 6..7

名前 | 説明
Inspection ID | この結果セットに関連付けられている取り込み ID。

バイト 8..9

名前 | 説明
Inspection Result Code | 検査結果コードは、WriteResultsBuffer 関数の結果コードパラメータで定義されます。

バイト 10..63

名前 | 説明
Inspection Results | WriteResultsBuffer 関数を使用してスプレッドシートから書き出された検査結果データ。


EtherNet/IP オブジェクトモデルと入出力アセンブリオブジェクト - In-Sight 5.x.x ファームウェア

このトピックでは、In-Sight 5.1.0 以降が実行されている In-Sight ビジョンシステムの In-Sight オブジェクトモデルについて説明します。

注 : モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアのバージョンをご参照ください。 モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

In-Sight オブジェクトモデル

EtherNet/IP ネットワークでは、In-Sight ビジョンシステムはサーバとして機能し、明示的および非明示的 I/O メッセージングの両方をサポートします。例えば、検査データを、明示的メッセージによって、または非明示的接続によって、クライアントに転送することができます。非明示的な接続は、画像取り込み、トリガ、およびスプレッドシートのイベントの制御に使用することもできます。

識別オブジェクト、Ethernet リンクオブジェクト、TCP/IP オブジェクト、およびそのほかの内部オブジェクトは、EtherNet/IP 仕様によって必須とされています。アセンブリオブジェクトのさまざまなインスタンスは、EtherNet/IP クライアントとアプリケーションデータを交換するために使用されます。ビジョンオブジェクトは、In-Sight ビジョンシステムに固有の情報を提供するために、In-Sight システムによって定義されます。これがどのように行われるかという詳細については、「ビジョンオブジェクトの属性とサービス」の節を参照してください。In-Sight ビジョンシステムによって提供される現在のオブジェクトモデルを下の図に示します。

  • アセンブリオブジェクト: アセンブリオブジェクトは、複数のオブジェクトの属性をバインドして、各オブジェクト間でのデータの送受信を 1 つの接続でできるようにします。アセンブリオブジェクトを使用すると、入力データまたは出力データをバインドすることができます。「入力」と「出力」という用語は、ネットワーク側から見た定義です。「入力」はネットワーク上にデータを生成し、「出力」はネットワークからデータを消費します。
  • 識別オブジェクト: このオブジェクトは、デバイスの識別情報とデバイスに関する全般情報を提供します。
  • Ethernet リンクオブジェクト: Ethernet リンクオブジェクトは、Ethernet 802.3 通信インタフェースについて、リンク固有のカウンタとステータス情報を保持します。
  • TCP/IP オブジェクト: TCP/IP オブジェクトは、デバイスの TCP/IP ネットワークインタフェース設定を照会 (可能な場合は設定も) するメカニズムを提供します。該当する項目の例としては、デバイスの IP アドレス、ネットワークマスク、ゲートウェイアドレスなどがあります。
  • ビジョンオブジェクト: ビジョンオブジェクトには、In-Sight ビジョンシステム固有のすべてのサービスと属性が含まれます。これには、画像取り込み、検査、ジョブの変更、および In-Sight Explorer スプレッドシートとの通信などが含まれます。

入出力アセンブリオブジェクト

入出力データの I/O アセンブリデータ属性の形式は、次のとおりです。

ファームウェアのバージョン | 入力アセンブリ | 出力アセンブリ
 | インスタンス | インスタンス
5.1.0 以降 | 13 | 22
注 :
  • EDS で作成されたプロファイルを使用する場合、入力アセンブリの最大サイズが 500 バイトであっても、EDS で作成されたプロファイルは最大 496 バイトの接続しか許可しません。
  • Rockwell RSLogix Studio 5000 バージョン 21 ～ 25 を使用している場合、In-Sight EDS で作成されたプロファイルのデフォルト入出力アセンブリサイズ (各 496 バイト) は編集できず、デフォルトの最大の入出力アセンブリサイズに戻されます。
  • Trigger Ack が生成されて PLC に送信されている場合、Acquition ID は画像取り込みの開始時に増分されます。Inspection ID は、Inspection Completed ビットがトグルするときに増分されます (このとき、Results Valid は high に設定され、Inspecting ビットは low に設定されます)。
  • In-Sight 4.x.x ファームウェアが実行されている In-Sight ビジョンシステムから 5.x.x ファームウェアが実行されているビジョンシステムにアップグレードする場合の入出力アセンブリテーブル間の違いについては、「入出力アセンブリの変更」のトピックを参照してください。

入力アセンブリ　‐ インスタンス 13

インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
13 | 0 | Online | Offline Reason |  |  | Missed Acq | Reserved | Trigger Ack | Trigger Ready
 | 1 | Error | Command Failed | Command Completed | Command Executing | Results Valid | Results Buffer Overrun | Inspection Completed | System Busy
 | 2 | Reserved | Reserved | Reserved (5.1.0 ～ 5.5.x) | Job Pass | Exposure Complete | Reserved | Reserved | Set User Data Ack
 |  |  |  | TestRun Ready (5.6.0 以降)
 | 3 | Soft Event Ack 7 | Soft Event Ack 6 | Soft Event Ack 5 | Soft Event Ack 4 | Soft Event Ack 3 | Soft Event Ack 2 | Soft Event Ack 1 | Soft Event Ack 0
 | 4 | Error Code (16 ビット整数)
 | 5
 | 6 | Reserved (16 ビット整数)
 | 7
 | 8 | Current Job ID (16 ビット整数)
 | 9
 | 10 | Acquisition ID (16 ビット整数)
 | 11
 | 12 | Inspection ID (16 ビット整数)
 | 13
 | 14 | Inspection Result Code (16 ビット整数)
 | 15
 | 16 | Inspection Results 0
 | ... |
 | 499 | Inspection Results 483

バイト 0

ビット | 名前 | 説明
7 | Online | このビットは、In-Sight ビジョンシステムがオンラインのときにセットされ、ビジョンシステムがオフラインのときにクリアされます。ビジョンシステムがオフラインのときには、Offline Reason フィールドを調べて、原因を判断してください。
6 ～ 4 Offline Reason このフィールドは、In-Sight ビジョンシステムがオフラインである原因を示すために使用される 3 ビットのフィールドです。
Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注 : 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。
3 | Missed Acq | 画像取り込み方法に関係なく、In-Sight ビジョンシステムが画像取り込みに失敗したときにセットされます。画像取り込みが正常にトリガされるとクリアされます。
2 | Reserved | 未使用。
1 | Trigger Ack | In-Sight ビジョンシステムが Trigger ビットのセットによってトリガされたことを示します。このビットは、Trigger ビットがクリアされるまでセットされたままです。また、Acquisition ID は、このビットの立ち上がりエッジにラッチできます。
0 Trigger Ready

In-Sight ビジョンシステムが、Trigger ビットを介して新しいトリガを受け入れられることを示します。このフィールドは、ビジョンシステムがオンラインであり、Trigger Enable ビットがセットされ、AcquireImage 関数の [トリガ] パラメータが [ネットワーク]、[外部]、または [産業用イーサネット] に設定されて、ビジョンシステムが現在画像を取り込んでいないときに真になります。

注 : トリガが PLC から送られてきたら、[産業用イーサネット] トリガタイプを使用する必要があります。

バイト 1

ビット | 名前 | 説明
7 | Error | このビットはエラーが発生するとセットされます。これは [エラーコード] フィールドで定義されています。
6 | Command Failed (5.1.0 ～ 5.5.x) | このビットは 1 にセットされて、Job Load の実行に失敗して完了できなかったことを示します。新しいジョブが PLC/HMI によってロードされると、ビットがクリアされます。In-Sight Explorer によってジョブが変更されても、このビットは変わりません。このビットは常に、Command Completed ビットがセットされるより前にセットされます。
 | Command Failed (5.6.0 以降) | このビットは、TestRun 実行または [ジョブを開く] に失敗したことを示すため 1 にセットされます。TestRun シーケンスが実行されるか、PLC/HMI によって新規のジョブがロードされるとクリアされます。In-Sight Explorer でジョブを変更しても、このビットは変わりません。
5 | Command Completed (5.1.0 ～ 5.5.x) | このビットは、[ジョブを開く] が完了したことを示すためにセットされます。コマンドが完了すると、Command Executing ビットが Low になり、Execute Command ビットがまだ High の場合、Command Completed ビットがセットされます。コマンドが完了しなかった場合、Command Failed ビットもセットされます。 注 : Execute Command ビットが Low になると、カメラは Command Completed ビットをクリアします。
 | Command Completed (5.6.0 以降) | このビットは、TestRun 実行または [ジョブを開く] が完了したことを示すためにセットされます。 注 : TestRun を設定せずにジョブで TestRun を実行しようとすると、Command Completed ビットと Command Failed ビットの両方がセットされます。TestRun を実行する前に、TestRun Ready ビットがセットされるのを待つ必要があります。
4 | Command Executing (5.1.0 ～ 5.5.x) | Job Load が開始されると、このビットは 1 にセットされます。Command Completed ビットと Command Failed ビットは、このビットの立ち下がりエッジの前にセットされます。 注 : Command Executing は最大で 2 秒間オンになります。
 | Command Executing (5.6.0 以降) | このビットは、TestRun 実行または [ジョブを開く] が開始されると 1 にセットされます。TestRun の実行が完了すると、このビットはクリアされます。Command Completed ビットと Command Failed ビットは、このビットの立ち下がりエッジの前にセットされます。
3 | Results Valid | Inspection Count ビット、Inspection Result Code ビット、Inspection Results ビット、または Job Pass ビットがセットされたときにセットします。Inspection Results Ack ビットがセットされるとクリアされます。
2 | Results Buffer Overrun | このフィールドは、Buffer Results Enable ビットがセットされていて、Inspection Results Ack ビットをセットすることによって PLC が確認応答しなかったために In-Sight ビジョンシステムが検査結果のセットを破棄したときにセットされます。最大 8 つの検査がビジョンシステムのバッファに保持されるため、このビットは、9 番目の検査がバッファに追加されたときにセットされます。9 番目の検査と後続のすべての検査は、バッファに空きが生じるまで (結果が確認応答されたとき) 破棄されます。有効な検査が発生して、前の検査が上書きされない限り、このビットはクリアされません。
1 | Inspection Completed | このビットは、検査の完了時にトグルされます。Inspection Count、Inspection Result Code、Inspection Results、または Job Pass の各ビットが PLC に送信された後、確実に切り替えられます。 注 : このビットは、結果の読み取り準備ができていることを示すために使用します。データの読み取り時期を指定するには、ResultsValid を使用します。
0 | System Busy | ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。

バイト 2

ビット | 名前 | 説明
7 ～ 6 | Reserved | 未使用。
5 | Reserved (5.1.0 ～ 5.5.x) | 未使用。
TestRun Ready (5.6.0 以降)

このビットは、ビジョンシステムの TestRun 設定が有効な場合に 1 にセットされます。この信号は、TestRun が (TestRun イニシエータに関係なく) 実行されるときにクリアされ、実行完了後に 1 に戻ります。

注 :

  • このビットは、ビジョンシステムがオンラインかオフラインかどうかに関係なく信号として送信されます。

  • 外部デバイスによる TestRun の開始は、In-Sight ファームウェア 5.1.0 ～ 5.5.x が実行されているビジョンシステムではサポートされません。
4 Job Pass このビットは、最後のジョブが [ジョブの PASS/FAIL セルの設定] ダイアログの設定に合格するとセットされます。このビットはジョブが合格しないとクリアされます。
注 :

ジョブの PASS ビッドの動作は結果バッファリングが無効か有効かによって異なります。

バッファリングが無効 | バッファリングが有効
検査が完了したときに [ジョブの PASS/FAIL] のセルが合格を示すとセットされます。そうでない場合は、クリアされたままです。 Inspection Completed ビットが立つ前のジョブ PASS ビットは有効です。 | 新しい結果が InspectionResults 属性に挿入され、[ジョブの PASS/FAIL] のセルがその結果に対して合格を示すとセットされます。そうでない場合は、クリアされたままです。InspectionResultsAck 属性を真に設定することによって結果が確認応答され、ビットがクリアされるまで、状態は変化しません。 Results Valid ビットがセットされる前のジョブ PASS ビットは有効です。
3 | Exposure Complete | このビットは、In-Sight ビジョンシステムが露光完了するとセットされ、Clear Exposure Complete ビットでリセットされます。このビットは、Clear Exposure Complete 信号が High に設定されると Low に保持されます。
2 ～ 1 | Reserved | 未使用。
0 | Set User Data Ack | このビットは、Set User Data コマンドの完了に確認応答するためにセットされます。

バイト 3

ビット | 名前 | 説明
7 | Soft Event Ack 7 | これらのビットは、Soft Event コマンドが受信されたことを示すために使用されます。
6 | Soft Event Ack 6
5 | Soft Event Ack 5
4 | Soft Event Ack 4
3 | Soft Event Ack 3
2 | Soft Event Ack 2
1 | Soft Event Ack 1
0 | Soft Event Ack 0

バイト 4 ～ 5

名前 説明
Error Code (16 ビット整数)

発生したエラーの 16 ビットの数値表現:

コード | Error | 説明
0x0000 | No Error | エラーは発生しませんでした。
0x0100 | Trigger set while disabled | Trigger Enable ビットがクリアされている間に Trigger ビットがセットされた場合、または AcquireImage 関数の Trigger パラメータが、外部、ネットワークまたは産業用イーサネットに設定された場合に発生します。
0x0101 | Trigger set while Offline | ビジョンシステムがオフラインの間に Trigger ビットが設定されるときに発生します。
0x0400 | Already Executing Error | Execute Command ビットがセットされ、Excecuting ビットが High のままになっている場合に発生します。
0x0401 | Job load requested while Online | ビジョンシステムがオンラインの間に [ジョブを開く] コマンドが発行されるときに発生します。
0x0402 | Job load fail | PLC が値を書き込んでも (a 7 など)、a 7 を接頭辞とするジョブがない場合に発生します。

バイト 6 ～ 7

名前 | 説明
Reserved (16 ビット整数) | 未使用。

バイト 8 ～ 9

名前 | 説明
Current Job ID (16 ビット整数) | ビジョンシステムで現在実行中のジョブの ID 番号を示す 16 ビット整数。または、現在のジョブに ID 番号がない場合は 65535。このフィールドは、ジョブ変更の方法に関係なく、ビジョンシステムでジョブが変更されたときに更新されます。

バイト 10 ～ 11

名前 | 説明
Acquisition ID (16 ビット整数) | この ID は、取り込みの開始時と Trigger Ack ビットがセットされると増分され、取り込みとその検査結果の同期に使用できます。

バイト 12 ～ 13

名前 | 説明
Inspection ID (16 ビット整数) | この結果セットに関連付けられている取り込み ID。

バイト 14 ～ 15

名前 | 説明
Inspection Result Code (16 ビット整数) (5.1.0 ～ 5.5.x) | 検査結果コードは、WriteResultsBuffer 関数の [結果コード] パラメータによって定義されます。
Inspection Result Code (16 ビット整数) (5.6.0 以降)

TestRun の最新の実行結果を示します。すべてのテストに合格すると、値が 0 になります。不合格のテストがあった場合、または TestRun 実行中のセットアップまたはクリーンアップに問題があった場合は、その障害を示す 0 以外の値が返されます。

  • このフィールドは、TestRun の実行が正常に完了した場合にのみ有効になります。
  • このフィールドの結果は、TestRun なしのジョブがロードされた場合、別の TestRun ジョブが実行された場合、TestRun が進行中の場合、TestRun の実行またはジョブを開くことに失敗した場合、または TestRun の実行が中止された場合には無効化されることがあります。

バイト 16 ～ 499

名前 説明
Inspection Results (0 ～ 483)

[スプレッドシートビュー] の WriteResultsBuffer 関数、または EasyBuilder GUI の [通信] の手順での [フォーマット出力データ] タブを介して In-Sight Explorer から書き込まれるデータです。

送信されるデータは、In-Sight Explorer GUI での表示どおりに書き込まれ、FormatOutputBuffer 関数 (スプレッドシート) または [フォーマット出力データ] タブ (EasyBuilder) で定義される順序と同じ順序で表示されます。

注 :

  • RSLogix 5000 は Inspection Results データアレイを受信すると、送信されたデータに複数のデータ型が含まれている (つまり、フォーマットされたデータに整数、浮動小数点、ビットが含まれている) かどうかに関係なく、1 つのデータ型をアレイ全体に割り当てます。したがって、送信されているデータにさまざまなデータ型が含まれる場合は、特定の結果 (最初に Inspection Results アレイのバイトオフセット、次にバイト単位の長さ) を、送信されているデータ型の予測を基に RSLogix の User-Defined Data Type にコピーします。

    詳細については、「例: In-Sight ビジョンシステムからの浮動小数点数値データの取得」を参照してください。

  • Buffer Results Enable ビットがセットされていた場合、Inspection Results Ack ビットをパルス出力することによって確認応答されるまで、検査結果は変わりません。

I/O アセンブリデータ属性の形式 - 出力アセンブリ - インスタンス 22

インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
22 | 0 | Set Offline | Reserved |  | Execute Command | Inspection Results Ack | Buffer Results Enable | Trigger | Trigger Enable
 | 1 | Reserved
 | 2 | Reserved |  |  |  | Clear Exposure Complete | Clear Error | Reserved | Set User Data
 | 3 | Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0
 | 4 | Command
 | 5
 | 6 ..7 | Reserved
 | 8 | User Data 0
 | ... |
 | 495 | User Data 487
注 : In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

バイト 0

ビット | 名前 | 説明
7 Set Offline

このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。
6 ～ 5 | Reserved | 未使用。
4 | Execute Command (5.1.0 ～ 5.5.x) | 設定した場合、ビジョンシステムは、[コマンド] フィールドで指定されたジョブ ID をロードするか、[名前を基準にしたジョブのロード] コマンドを実行して、ユーザデータバッファで指定されたジョブ名をロードします。[コマンド完了] シグナルに切り替わるまで、シグナルは [High] のまま維持する必要があります。このシグナルの立ち下がりエッジ ([コマンド完了] の前の場合) は、停止リクエストとして解釈されます。
Execute Command (5.6.0 以降) | セットすると、ビジョンシステムは、Command フィールドで指定されてているジョブ ID をロードするか、Job Load by Name コマンドを実行して User Data バッファにあるジョブ名をロードします。TestRun を使用する場合は、この信号の立ち上がりエッジでコマンドが実行されて TestRun が開始されます。この信号は、Command Completed 信号がトグルされるまで high を維持する必要があります。この信号の立ち下がりエッジ (Command Complete の前) は、中止要求と解釈されます。
3 | Inspection Results Ack | Buffer Results Enable ビットがセットされると、Inspection Results Ack ビットは、PLC が Inspection ID、Inspection Result、および Inspection Results データを受信したことを確認応答します。その後、次の検査結果のセットが PLC に送信されます。Inspection Results Ack ビットがクリアされると、ビジョンシステムは Results Valid ビットをセットします (バッファが空でなかった場合)。結果のバッファ処理が無効になっている場合、Inspection Results Ack ビットをセットして、Results Valid ビットをクリアする必要があります。
2 | Buffer Results Enable | このビットがセットされると、Inspection ID、Inspection Result、Inspection Results フィールドは、Inspection Results Ack フィールドが確認応答してセットされるまで変化しません。最大 8 つの検査がビジョンシステムのバッファに保持されます。In-Sight ビジョンシステムは、Results Valid ビットをクリアすることによって、確認応答に応答します。Inspection Results Ack フィールドがクリアされて、PLC に送信される新しいルールセットがあるときには、Results Valid ビットはクリアされません。Inspection Results Ack ビットがクリアされて、PLC に送信される結果がビジョンシステムのバッファにそれ以上ない場合には、Results Valid ビットはクリアされたままです。
1 Trigger

このビットをセットすると、次の条件が満たされた場合に取り込みがトリガされます。

  • In-Sight ビジョンシステムがオンラインである。
  • Trigger Enable ビットがセットされている。

  • AcquireImage 関数の Trigger パラメータが、ネットワーク、外部、または産業用イーサネットに設定されます。

    注 : トリガが PLC から送られてきたら、[産業用イーサネット] トリガタイプを使用する必要があります。
0 | Trigger Enable | このフィールドは、Trigger ビット経由でトリガできるようにするために設定されます。このビットをクリアすると、ネットワークトリガメカニズムが無効になります。

バイト 1

ビット | 名前 | 説明
7 ～ 0 | Reserved | 未使用。

バイト 2

ビット | 名前 | 説明
7 ～ 4 | Reserved | 未使用。
3 | Clear Exposure Complete | この信号が High のときは、Exposure Complete ステータスはリセットのままです。この信号が Low に設定されると、次の露光完了時に Exposure Complete ステータスが High に設定されます。
2 | Clear Error | このビットをセットすると、エラーシグナルとエラーコードシグナルがクリアされます。Clear Error ビットは、Error ビットがクリアされるまで [High] に維持する必要があります。エラーがキューに入れられた場合、このビットがクリアされると、エラーシグナルとエラーコードシグナルは、キューに入れられた次のエラーコードに対してセットされます。
1 | Reserved | 未使用。
0 | Set User Data | このコマンドは、ビジョンシステムにて消費される User Data フィールドを保持バッファに転送する必要がある場合に、PLC から In-Sight ビジョンシステムへ通知します。

バイト 3

ビット | 名前 | 説明
7 | Soft Event 7 | スプレッドシートのソフトイベントのトリガを可能にします。これらのビットをセットすると、スプレッドシート内の関連するソフトイベントがトリガされます。
6 | Soft Event 6
5 | Soft Event 5
4 | Soft Event 4
3 | Soft Event 3
2 | Soft Event 2
1 | Soft Event 1
0 | Soft Event 0

バイト 4 ～ 5

バイト | 名前 | 説明
4 ～ 5 | Command (5.1.0 ～ 5.5.x) | これは、ロードするジョブのジョブ ID 番号 (0 ～ 999) を示すため、または [名前を基準にしたジョブのロード] コマンド (0x4000) を指定するために使用される 16 ビットの整数です。[コマンド実行] ビットが PLC によって設定されると、ジョブロードが実行されます。[コマンド] フィールドは、[コマンド実行] シグナルの立ち上がりエッジと [コマンド完了] シグナルの立ち上がりエッジとの間で一定に保つ必要があります。そうしないと、結果が不確定になります。[名前を基準にしたジョブのロード] コマンドを使用する場合、[コマンド実行] ビットが設定される前にジョブ名をユーザデータバッファに転送する必要があります。
 | Command (5.6.0 以降) | (missing or bad snippet)

バイト 6 ～ 7

バイト | 名前 | 説明
6 ～ 7 | Reserved | 未使用。

バイト 8 ～ 495

バイト | 名前 | 説明
8-495 | User Data (0 ～ 487) | ReadUserDataBuffer または ReadLatchedUserDataBuffer 関数を使用してスプレッドシートに読み取ることができるデータバッファ。バッファは、PLC の表示どおりに書き込まれ、ビットは、RSLogix 5000 の定義と同じ順序で表示されます。

I/O アセンブリデータ属性コンポーネントのマッピング

次の表に、In-Sight ビジョンシステムの I/O アセンブリデータ属性のマッピングを示します。

データ コンポーネント 名前 | クラス |  | インスタンス 番号 | 属性
 | 名前 | 番号 |  | 名前 | 番号
Set Offline | Vision | 78 Hex | 1 | SetOffline | 8
Trigger Enable | Vision | 78 Hex | 1 | AcqTriggerEnable | 9
Trigger | Vision | 78 Hex | 1 | AcqTrigger | 10
BufferResultsEnable | Vision | 78 Hex | 1 | BufferResultsEnable | 13
Soft Event N | Vision | 78 Hex | 1 | SoftTrigger bit N | 18
Online | Vision | 78 Hex | 1 | Online | 6
OfflineReason | Vision | 78 Hex | 1 | OfflineReason | 7
Trigger Ready Trigger Ack Exposure Complete Missed Acquisition | Vision | 78 Hex | 1 | AcqStatusRegister | 11
User Data | Vision | 78 Hex | 1 | User Data | 12
System Busy Inspection Completed Results Buffer Overrun Results Valid | Vision | 78 Hex | 1 | InspectionStatusRegister | 14
Inspection ID Inspection Data | Vision | 78 Hex | 1 | InspectionResults | 16

ビジョンオブジェクトの属性

このセクションでは、EtherNet/IP ビジョンオブジェクト内に存在するさまざまな属性とサービスについて説明します。

クラスコード: 78 Hex - このオブジェクトは、In-Sight フォームウェア 5.1.0 以降が実行されている In-Sight ビジョンシステムで実行可能なすべての操作をモデル化します。

インスタンス属性

属性 ID

アクセスルール

名前

データ型

属性の説明

6

Get

Online

BOOL

0 = オフライン

1 = オンライン

7

Get

OfflineReason

BYTE

0 = オンライン

1 = プログラミング

2 = ディスクリートオフライン

3 = 通信オフライン

4 ～ 255 = 予約済み

8

Set

SetOffline

BOOL

1 = In-Sight ビジョンシステムをオフラインにします。

9

Set

AcqTriggerEnable

BOOL

0 = 取り込みトリガは無効です。Trigger Ack を 0 にリセットします。

1 = 取り込みトリガは有効です。

10

Set

AcqTrigger

BOOL

AcqTriggerEnable が真のとき、In-Sight ビジョンシステムは AcqTrigger が 0 から 1 に変わると画像を取り込みます。

11

Get

AcqStatusRegister

BYTE

ビット 0: Trigger Ready

ビット 1: Trigger Ack

ビット 2: Exposure Complete

ビット 3: Missed Acquisition

ビット 4 ～ 7: Reserved

12

Set

UserData

BYTE 配列

検査への入力として使用できるユーザ定義データ。

注 :

  • In-Sight ファームウェア 5.1.0 ～ 5.3.x が実行されている In-Sight ビジョンシステムの場合、UserData 属性に書き込まれるデータは、Set User Data サービスが実行されるまで表示されません。

  • In-Sight ファームウェア 5.4.x 以降が実行されており、User Data Holding Buffer Bypass が有効な In-Sight ビジョンシステムの場合は、UserData 属性に書き込まれるデータは書き込まれるときに表示されます。
  • ユーザデータ保持バッファバイパスは、グラフィカルユーザインタフェース (GUI) を介してのみ有効および無効にすることができます。

13

Set

BufferResultsEnable

BOOL

ResultsBufferEnable が真のとき、ResultsAck 属性が真に設定されるまで、検査結果のバッファリングを有効にします。

14

Get

InspectionStatusRegister

BYTE

ビット 0: System Busy

ビット 1: Inspection Completed

ビット 2: Results Buffer Overrun

ビット 3: Results Valid

ビット 4: Job Loading

ビット 5: Job Load Completed

ビット 6: Job Load Failed

ビット 7: Job Pass

15

Set

InspectionResultsAck

BOOL

クライアントが検査結果を受信したことを確認応答します。

16

Get

InspectionResults

STRUCT of (の構造体)

最後の検査結果。

InspectionID

UINT

検査カウンタ。

InspectionResultCode

UINT

WriteResultsBuffer 関数でセットされる検査結果コード。

InspectionResults

BYTE 配列

最後の検査結果。

18

Set

SoftTrigger

BYTE

ビット 0: ソフトトリガ 0

ビット 1: ソフトトリガ 1

ビット 2: ソフトトリガ 2

ビット 3: ソフトトリガ 3

ビット 4: ソフトトリガ 4

ビット 5: ソフトトリガ 5

ビット 6: ソフトトリガ 6

ビット 7: ソフトトリガ 7

19

Set

JobID

INT

現在ロードされているジョブの ID 番号。または、現在のジョブに ID がない場合は -1。

この値を設定すると (0 ～ 999)、関連付けられた ID を持つジョブがロードされます。

20

Set

JobName

STRING

現在ロードされているジョブのファイル名、またはファイル名が不明な場合は空の文字列。

この値を設定すると、ファイル名が関連付けられているジョブがロードされます。

21

Set

 ClearExposureComplete BOOL

Exposure Complete ビットをクリアします。このビットの立ち上がりエッジで Exposure Complete ビットがクリアされます。Clear Exposure Complete ビットがセットされている間に別の Exposure Complete 信号が送信されると、Exposure Complete ビットは Clear Exposure Complete ビットがクリアされるときにセットされます。

22

Set

SoftEventAck 0 ～ 7

BYTE

ビット 0 = ソフトトリガ確認応答 0

ビット 1 = ソフトトリガ確認応答 1

ビット 2 = ソフトトリガ確認応答 2

ビット 3 = ソフトトリガ確認応答 3

ビット 4 = ソフトトリガ確認応答 4

ビット 5 = ソフトトリガ確認応答 5

ビット 6 = ソフトトリガ確認応答 6

ビット 7 = ソフトトリガ確認応答 7

オンライン属性

オンライン属性は、In-Sight ビジョンシステムがオンラインまたはオフライン状態であることを示します。In-Sight ビジョンシステムがオフラインのときには、OfflineReason 属性を使用して、In-Sight ビジョンシステムがオフラインになっている原因を調べることができます。

OfflineReason 属性の値

Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注 : 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。

SetOffline 属性を使用すると、In-Sight ビジョンシステムをオフライン状態にできます。SetOffline 属性を True に設定すると、In-Sight ビジョンシステムがそれ以外の理由なしでオフラインに保持されている場合には、OfflineReason 属性が通信オフラインに設定されます。

画像取り込み属性

注 : ネイティブモード コマンドによる、PLC/モーションコントローラからの取り込みトリガを許可するように、In-Sight ビジョンシステムを設定する場合は、SetEvent and Wait 関数を利用して、イベントコードを 8 (SW8) に設定することを推奨します。これによって、ビジョンシステムは、画像取り込みと検査の両方が完了してから「完了」レスポンスを PLC/モーションコントローラに送り返すようになるため、前の検査結果が PLC/モーションコントローラに送信されることはなくなります。ビジョンシステムからの「完了」レスポンスを使用して、検査結果の読み取り要求を送信する条件付き PLC ロジックを作成することもできます。

画像取り込み属性を使用することによって、画像を取り込むようにビジョンオブジェクトをトリガすることができます。ビジョンオブジェクトの画像取り込み属性をリセットするには、AcqTriggerEnable 属性が偽に設定されている必要があります。ただし、AcqStatusRegister が 0 の場合を除きます。この場合、AcqTriggerEnable 属性を真に設定して、ビジョンオブジェクト経由の取り込みを有効にすることができます。Acquisition Trigger がトリガを受け入れる準備ができると、AcqStatusRegister の Trigger Ready ビットがセットされます。

AcqTriggerEnable 属性が真に設定されている間、ビジョンオブジェクトは、AcqTrigger 属性が 0 から 1 に変わったことを検出するたびに、画像の取り込みを開始します。非明示的メッセージングによってこれを設定するときには、変更がビジョンオブジェクトによって確実に検出されるように、AcqStatusRegister の Trigger Ack ビットによって同じ値が検出されるまで、属性が変更状態に保たれる必要があります。

注 : 明示的メッセージングを使用するときには、変更は常に検出されるので、この必要はありません。

In-Sight ビジョンシステムで画像取り込みを完了したタイミングを判別するには、Exposure Complete ビットと Clear Exposure Complete ビットを利用します。画像取り込みは、Exposure Complete 信号を明示的に確認応答することによって明示的に確認応答される必要があります。Clear Exposure Complete ビットが HIGH の間に Exposure Complete 信号が送信されると、Exposure Complete ビットは Clear Exposure Complete ビットが PLC によってクリアされるときにアサートされます。

この動作により、複数の Exposure Complete 信号が発生しても、信号が 1 つだけ送信された場合と同じ効果が得られ、このシナリオでエラーは報告されません。これにより PLC では、Exposure Complete 信号を検出することによって、画像取り込みがディスクリート入力からトリガされたタイミングを検出できます。

ほかの方法で画像取り込みがトリガされた場合、AcqStatusRegister の Exposure Complete ビットと Missed Acquisition ビットはアクティブなままになります。

検査結果属性

画像取り込みトリガの結果として取り込まれた画像は、検査のためにキューに入れられます。画像の検査の実行中は、InspectionStatusRegister の System Busy ビットがセットされます。検査が完了すると、System Busy ビットはクリアされ、Inspection Completed ビットがトグルされます。

ResultsBufferEnable 属性によって、ビジョンオブジェクトでの検査結果の取り扱い方が決まります。ResultsBufferEnable 属性が偽に設定された場合、検査結果は直ちに InspectionResults 属性に入れられます。

ResultsBufferEnable 属性が真に設定された場合は、InspectionResultsAck 属性を真に設定することによって確認応答されるまで、前の検査結果が InspectionResults 属性に入ったままになります。Results Valid ビットがクリアされたら、新しい結果を InspectionResults 属性に入れることができるようにするため、InspectionResultsAck 属性を偽に設定する必要があります。これを使用して、ビジョンオブジェクトとクライアントの間で結果を取得するためのハンドシェークを確立することができます。

InspectionStatusRegister の動作

Inspection

Status

Register

ビット

 ビット名 バッファリングが無効な場合の結果 バッファリングが有効な場合の結果
0

System Busy

 ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。 ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。
1 | Inspection Completed | このビットは、検査の完了時にトグルされます。Inspection Count、Inspection Result Code、Inspection Results、または Job Pass の各ビットが PLC に送信された後、確実に切り替えられます。 | このビットは、検査の完了時にトグルされます。Inspection Count、Inspection Result Code、Inspection Results、または Job Pass の各ビットが PLC に送信された後、確実に切り替えられます。
2 | Results Buffer Overrun | 常にクリア。 | クライアントが前の結果に確認応答しなかったために、検査結果をキューに入れることができなかったときにセットされます。検査結果が正常にキューに入れられるとクリアされます。
3 Results Valid

Inspection Count ビット、Inspection Result Code ビット、Inspection Results ビット、または Job Pass ビットがセットされたときにセットします。Inspection Results Ack ビットがセットされるとクリアされます。

注 : オーバーラップモード時のジョブの処理を有効にした場合は、Buffer Results Enable ビットを有効/セットするか、Inspection Completed ビットを使って検査結果をラッチします。

Inspection Count ビット、Inspection Result Code ビット、Inspection Results ビット、または Job Pass ビットがセットされたときにセットします。Inspection Results Ack ビットがセットされるとクリアされます。

注 : オーバーラップモード時のジョブの処理を有効にした場合は、Buffer Results Enable ビットを有効/セットするか、Inspection Completed ビットを使って検査結果をラッチします。
7 Job Pass 検査が完了したときに [ジョブの PASS/FAIL] のセルが合格を示すとセットされます。そうでない場合は、クリアされたままです。

Inspection Completed ビットが立つ前のジョブ PASS ビットは有効です。

新しい結果が InspectionResults 属性に挿入され、[ジョブの PASS/FAIL] のセルがその結果に対して合格を示すとセットされます。そうでない場合は、クリアされたままです。InspectionResultsAck 属性を真に設定することによって結果が確認応答され、ビットがクリアされるまで、状態は変化しません。

Results Valid ビットがセットされる前のジョブ PASS ビットは有効です。

ジョブ属性

ビジョンオブジェクトは、JobID および JobName 属性を設定することによって、In-Sight ビジョンシステムの不揮発性フラッシュメモリに格納されたジョブをロードすることができます。ロードが失敗した場合は、セット操作も失敗します。

ビジョンオブジェクトのサービス

共通サービス

ビジョンオブジェクトは、次の共通サービスを提供します。

サービスコード | サービス名 | サービスの説明
05 Hex | Reset | ビジョンオブジェクトをリセットします。
0E Hex | Get_Attribute_Single | 指定された属性の内容を返します。
10 Hex | Set_Attribute_Single | 属性の値を変更します。

リセットサービス

リセットサービスは、ビジョンオブジェクトの画像取り込みトリガシステムをリセットし、無効にします。また、ビジョンオブジェクトの検査結果バッファリングシステムを無効にし、クリアします。

オブジェクト固有サービス

ビジョンオブジェクトは、次のオブジェクト固有サービスを提供します。

サービスコード | サービス名 | サービスの説明
32 Hex | Acquire | 1 回の画像取り込みをトリガします。
33 Hex | Reserved | 廃止。
34 Hex | SendNativeCmd | ネイティブモードコマンドを In-Sight ビジョンシステムに送信します。
35 Hex | GetInspectionResults | InspectionResults 属性を取得します。
36 Hex | Transfer User Data | データをユーザデータ保持バッファの一部に転送します。
37 Hex | Set User Data | ユーザデータ保持バッファをユーザデータフィールドにラッチして、In-Sight にユーザデータへのアクセス権を与えることを、ビジョンシステムに対して通知します。

画像取り込みサービス

ビジョンオブジェクトの画像取り込みサービスは、画像取り込みシステムが画像を取り込む準備ができていた場合、画像取り込みをトリガします。画像取り込みをトリガできなかった場合は、次に画像取り込みが成功するまで、AcqStatusRegister の Missed Acquisition ビットがセットされます。

コマンドが失敗した場合、Acquire Service はベンダー固有のエラーコード 1F を返します。

SendNativeCmd サービス

SendNativeCmd サービスは、ドキュメント化されている任意のネイティブモードコマンド文字列を In-Sight ビジョンシステムに送信します。SendNativeCmd の要求データは、In-Sight ビジョンシステムに送信されるネイティブモードコマンド文字列を含む必要があります。応答データはネイティブモードコマンドの文字列結果を含みます。

SendNativeCmd 要求データのフォーマット

名前 | 型 | 説明
Command | STRING | 処理されるネイティブモードコマンド。

SendNativeCmd 応答データのフォーマット

名前 | 型 | 説明
Result | STRING | ネイティブモードコマンドの文字列結果。

コマンドが失敗した場合、サービスは次のベンダー固有のエラーコードの 1 つを返します。

エラーコード | 説明 | ネイティブモード 戻りコード
1 | 正しくないコマンドです。 | -
4 | 応答なし - システムはビジーです。 |
100 | Command Failed | 0
101 | コマンドを実行できません。 | -1
102 |  | -2
103 |  | -3
104 |  | -4
105 |  | -5
106 |  | -6

GetInspectionResults サービス

GetInspectionResults サービス (コード 0x35) は、ビジョンオブジェクトの InspectionResults 属性からデータを読み取ります。

GetInspectionResults 要求データのフォーマット

名前 | 型 | 説明
Size | UINT | 読み取る InspectionResults 属性のバイト数。
Offset | UINT | InspectionResults 属性へのオフセット。これは、InspectionResults 属性で読み取る最初のバイトを指定します。

GetInspectionResults 応答データのフォーマット

名前 | 型 | 説明
InspectionResults | STRUCT of (の構造体) | 最後の検査結果。
InspectionID | UINT | 検査カウンタ。
InspectionResultCode | UINT | WriteResultsBuffer 関数でセットされる検査結果コード。
InspectionResults | BYTE 配列 | 最後の検査結果。

Transfer User Data コマンド

このコマンドを使用して、データをユーザデータ保持バッファの一部に転送します。ユーザデータ保持バッファは、Set User Data コマンドが発行されたときにユーザデータフィールドにラッチされます。

要求フォーマット

名前 | 型 | 説明
Size | UINT | 書き込む User Data フィールドのバイト数。
Offset | UINT | User Data フィールドへのオフセット。
データ | BYTE 配列 | ユーザデータフィールドに書き込むユーザデータ。

Set User Data コマンド

PLC はこのコマンドを使用して、ユーザデータ保持バッファをユーザデータフィールドにラッチして、In-Sight にユーザデータへのアクセス権を与えることを、ビジョンシステムに対して通知します。

この追加の User Data ハンドシェイクが必要ではなく、通信の動作が 4.x.x カメラでのアセンブリ IO の場合と同じ場合、User Data Command は次の方法でバイパス可能です。

  1. カメラにログオンします。
  2. メインメニューバーで、[センサ] → [ネットワークの設定] を選択します。

  3. [産業用イーサネットのプロトコル] セクションで [EtherNet/IP] を選択します。

  4. 選択した EtherNet/IP の横の有効な [設定] ボタンを選択します。

  5. [ユーザデータバイパスの有効化] チェックボックスをオンにします。

  6. ビジョンシステムを再起動します。

EtherNet/IP の関数

これらの関数は、In-Sight Explorer のスプレッドシートと EtherNet/IP スタックの間のデータの送受信に使用されます。

  • ReadUserDataBuffer 関数
  • ReadLatchedUserDataBuffer 関数
  • WriteResultsBuffer 関数
  • GetBufferData 関数

EtherNet/IP による通信

次のトピックには、EtherNet/IP と In-Sight ビジョンシステムの設定と利用に関する情報とそのための手順が記載されています。

  • EtherNet/IP ネットワーク上の Rockwell ControlLogix PLC との通信


EtherNet/IP による通信

EtherNet/IP は、Rockwell ControlLogix および CompactLogix PLC によって使用されるアプリケーションレベルのプロトコルで、Ethernet の TCP/IP 層と UDP/IP 層の最上位に実装されます。共通の CIP (Control and Information Protocol) を通じて、ControlNet および DeviceNet とオブジェクトモデルを共有しています。

このプロトコルによって、Ethernet 経由でのデータと I/O 信号の転送が可能になります。

非明示的メッセージと明示的メッセージ

EtherNet IP を使用した通信方法には、非明示的メッセージと明示的メッセージの 2 つの方法があります。In-Sight ビジョンシステムは、任意の時点において、1 つの I/O クライアント (ホストビジョンシステムと通信する PLC デバイス) からの明示的または非明示的メッセージをサポートします。

非明示的メッセージ 明示的メッセージ
  • タイムクリティカルなアプリケーション固有の I/O データを送信し、ポイントツーポイントまたはマルチキャストが可能です。
  • UDP/IP プロトコル層を使用します。
  • データは接続時に事前定義され、これによりランタイム中のノードの処理時間が最小化されます。
  • データフィールドにはリアルタイムデータのみが格納されます。
  • 低オーバヘッドの短いメッセージで、これによりタイムクリティカルなパフォーマンスを実現します。
  • ビジョン検査におけるツールからの測定データの受信は、非明示的メッセージが適している処理の一例です。
  • 受信側デバイスからの応答を必要とし、ポイントツーポイント通信します。
  • TCP/IP プロトコル層を使用します。
  • データフィールドでサービスパフォーマンスのプロトコル情報と命令の両方を伝達するメッセージ
  • ノードでは、各メッセージを解釈し、要求されたタスクを実行し、応答を生成する必要があります。この種類のメッセージは一般に、設定、診断、およびイベントデータの送信に使用されます。
  • 頻度の低い操作により適しています。

  • In-Sight Explorer ジョブの変更命令は、明示的メッセージが適している処理の一例です。

In-Sight オブジェクトモデルと入出力アセンブリオブジェクト

In-Sight オブジェクトモデルと入出力アセンブリオブジェクトのレイアウトおよび設定は、In-Sight ファームウェアに依存しています。

  • In-Sight 4.x.x ファームウエアの場合の EtherNet/IP オブジェクトモデルと入出力アセンブリオブジェクト
  • In-Sight 5.x.x ファームウエアの場合の EtherNet/IP オブジェクトモデルと入出力アセンブリオブジェクト

Requested Packet Interval (RPI)

Requested Packet Interval (RPI) により、コントローラと I/O モジュールの間で周期データパケットが交換される頻度が決まり、一般にはミリ秒単位で入力されます。センサは、最初の 15 ミリ秒間に 1 ～ 15 ミリ秒間隔で RPI 値を受け入れます。RPI 値が 15 より大きい場合、センサは 5 ミリ秒の増分で値を受け入れます。16 と 20 の間の値の場合、データは 20 ミリ秒の増分で交換されます。21 と 25 の間の値の場合、データは 25 ミリ秒の増分で交換されます。

これは、4.x および 5.x のファームウェアバージョンに適用されます。


アドオンプロファイル (AOP) を使用した接続の確立

アドオンプロファイル (AOP) を使用して単一の ControlLogix PLC との非明示的メッセージング接続を確立するには、次の手順に従います。

  1. RSLogix 5000 を開き、PLC のプロジェクトをロードします。

    注 : RSLogix 5000 に接続を追加するには、PLC がオフラインである必要があります。

  2. [I/O Configuration] ノードで、Ethernet モジュールの下の Ethernet ノードを選択し、アイコンを右クリックして、メニューから [New Module (新規モジュール)] を選択します。

  3. [Select Module Type (モジュールタイプの選択)] ダイアログで、使用している In-Sight ビジョンシステムを選択します。このオプションは、アドオンプロファイルをインストールした後にのみ表示されます。

  4. In-Sight ビジョンシステムを選択した後に、[New Module (新規モジュール)] ダイアログが表示されます。

    注 : [Time Sync (時刻同期)] タブは、In-Sight 5000 または In-Sight 76xx ～ 79xx シリーズのビジョンシステムを使用するときに表示されます。

    [全般] タブで、以下のフィールドに値を入力します。

    • [名前]: In-Sight ビジョンシステムの名前を入力します。RSLogix 5000 で作成されるタグはこの名前に基づいています。一貫性を保つため、In-Sight ビジョンシステムの名前を使用することを推奨します。
    • [IP アドレス]: In-Sight ビジョンシステムの IP アドレスを入力します。
    • [ホスト名]: (オプション) In-Sight ビジョンシステムのホスト名を入力します。この設定は、ネットワーク上に DNS (Domain Name Server) がある場合にのみ使用してください。

  5. [接続] タブで、以下のフィールドに値を入力します。

    • [Requested Packet Interval (RPI)]: このフィールドは、RPI (Requested Packet Interval) を指定します。これは、非明示的メッセージング接続によるデータ交換の時間間隔 (ミリ秒単位) を定義します。

      注 : 最良の結果を得るため、RPI 時間は、In-Sight ビジョンシステムがジョブ実行を完了してから PLC がデータを要求するまでの時間の半分以下に設定してください。
    • [Major Fault On Controller If Connection Fails While in Run Mode]: このオプションをオンにすると、コントローラは接続が失敗したときにメジャーフォールトを生成します。

    • [Inhibit Module]: PLC が In-Sight ビジョンシステムとの接続の確立を試みることができないようにする場合にオンにします。

      注 : In-Sight ビジョンシステムが「スタンバイ」モードで動作を停止した場合は、モジュールを禁止して再度有効にすることによってそのモジュールを再び動作させることができます。

  6. ControlLogix にモジュールを追加すると、I/O ツリーは次のように表示されます。

  7. 続いて RSLogix 5000 により、デバイスに与えられた名前に基づいて In-Sight ビジョンシステムの入出力データにマップされるタグが作成されます。

    • [is8xxx_AOP:I Scheduled Input]: 下の表に、In-Sight ビジョンシステムから PLC に送信されるデータを示します。

    • [is8xxx_AOP:O Scheduled Output]: 以下の表に、EtherNet/IP クライアント (ControlLogix) から In-Sight ビジョンシステムに送信されるデータを示します。


GetCellValue

指定したシンボリックタグ (EasyBuilder フィクスチャ出力、EasyBuilder の位置決めツールまたは検査ツールの結果、スプレッドシートなど) の内容を XML フォーマットで返します。

注 : ジョブが英語以外の言語で作成および設定されており、[オプション] ダイアログの [ユーザインタフェース] パネルで [英語シンボリックタグを EasyBuilder で使用] オプションが有効 (チェックボックスがオン) になっている場合、このオプションを有効にする前に作成されたシンボリックタグ参照はすべて英語名バージョンに更新される必要があります。

Syntax:EVGetCellValue("Symbolic Tag")

GetCellValueの入力パラメータ

入力 | 説明
"Symbolic Tag" | 位置決めツールまたは検査ツールの結果などのシンボリックタグの名前 ("Distance_1.Distance"など) またはセル参照 (A4 など)。自動生成された EasyBuilder のフィクスチャ出力データの場合、名前は、通信 アプリケーションステップで選択した [デバイス] と [プロトコル] に応じて、"Job.Robot.FormatString" と "Job.FormatString" のどちらかにする必要があります。名前は引用符で囲む必要があります。

GetCellValueの出力

戻り値

ステータスコード。その後に文字数とセルの内容 (整数、浮動小数点値、またはテキスト文字列) が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetCellValue例

EasyBuilder

正確な位置決めが必要とされるロボットガイダンスアプリケーションのフィクスチャデータ、または 位置決めツールまたは検査ツールの結果を取得するには:

正確な位置決めが必要とされるロボットガイダンスアプリケーションのフィクスチャ例

発行可能なコマンドは、通信の手順で選択した [デバイス] と [プロトコル] に応じて、EV GetCellValue("Job.Robot.FormatString") と EV GetCellValue("Job.FormatString") の 2 つです。

EV GetCellValue("Job.Robot.FormatString") は次の状況で使用します。

  • [デバイス] の選択が [Robot] になっている。
  • [デバイス] の選択が [その他] になっており、[プロトコル] で [シリアル Kuka] と [シリアル Motoman] のどちらかが選択されている。

EV GetCellValue("Job.FormatString") は次の状況で使用します。

  • [デバイス] の選択が [その他] になっており、[プロトコル] で、[イーサネットネイティブ]、[シリアルネイティブ]、[シリアルテキスト] または [TCP/IP] が選択されている。

EV GetCellValue("Job.Robot.FormatString")

このコマンドを発行すると次の結果になります。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 で応答します。文字数 (バイト単位) の後にセルの値 (整数、浮動小数点、またはテキスト文字列) が続きます。

EV GetCellValue("Job.FormatString")

このコマンドを発行すると次の結果になります。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 で応答します。文字数 (バイト単位) の後にセルの値 (整数、浮動小数点、またはテキスト文字列) が続きます。

位置決めツールまたは検査ツールの結果例

次の例は、距離寸法ツールの結果を取得するコマンドを発行する場合を示しています。

EV GetCellValue("Distance_1.Distance")

このコマンドを発行すると次の結果になります。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 で応答します。文字数 (バイト単位) の後にセルの値 (整数、浮動小数点、またはテキスト文字列) が続きます。

スプレッドシート

スプレッドシートの特定のセルの値を取得するには、次のコマンドを発行します。

EV GetCellValue("A52")

このコマンドを発行すると次の結果になります。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 で応答します。文字数 (バイト単位) の後にセルの値 (整数、浮動小数点、またはテキスト文字列) が続きます。


Get Job

In-Sight センサ上のアクティブなジョブの ID を返します。

注 :
  • ジョブ ID 番号の機能を使用するには、ロードするジョブが数値 0 ～ 999 の接頭辞を付けて保存されている必要があります。
  • このコマンドを正常に実行するためには、数値の接頭辞を付けてアクティブジョブを保存しておく必要があります。ジョブがドラッグ＆ドロップされたものである場合、ファイル名に数値の接頭辞が付いていなければ、このコマンドは正常に実行されません。
  • Motoman 通信を使用して Get Job コマンドを発行すると、ステータスデータは返されますが、結果データは返されません。Get Job コマンドの代わりに Get File コマンドを使用するか、スプレッドシートの別のセルにジョブ ID 番号を入力し、Get Value コマンドを使用します。

Get Jobの入力パラメータ

Syntax:GJ

Get Jobの出力

戻り値

ステータスコード。その後にアクティブジョブの整数値の ID が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | アクティブジョブが保存されていないか、数値の接頭辞が付いていないため、コマンドを実行できませんでした。

Get Job の例

アクティブジョブのファイル名を返すには、次のコマンドを発行します。GJ

In-Sight センサは、1 で応答して、コマンドが正常に実行されたことを示します。アクティブジョブの名前は、「85.JOB」です。


Get Online

In-Sight センサのオンライン状態を返します。

Get Onlineの入力パラメータ

Syntax:GO

Get Onlineの出力

戻り値 | 0 | In-Sight センサは現在オフラインです。
 | 1 | In-Sight センサは現在オンラインです。

Get Online例

In-Sight センサのオンライン状態を終了するには、次のコマンドを発行します。GO

In-Sight センサは、センサが現在オフラインになっていることを示す 0 を返すことによって応答します。


Get Value

EasyBuilder ビュー

指定したシンボリックタグの内容 (EasyBuilder フィクスチャ出力、EasyBuilder の位置決めツールまたは検査ツールの結果、ジョブデータなど) を返します。

Get Valueの入力パラメータ

Syntax:GV["Symbolic Tag"]

入力 | 説明
"Symbolic Tag" | シンボリックタグ (位置決めツールまたは検査ツールの結果、またはジョブデータ ("Job.Robot.FormatString." や "Job.FormatString" など)) のシンボリックタグの名前。

Get Valueの出力

戻り値

ステータスコード。その後に行の終端文字と、指定したシンボリックタグに格納されている値が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | "Symbolic Tag" が無効です。
-2 | コマンドを実行することができませんでした。
注 : 数値を含むシンボリックタグは、Get Value コマンドによって要求されると、ツールの結果やジョブデータに整数または浮動小数点値が含まれるかどうかに関係なく、小数点以下 3 桁にフォーマットされた浮動小数点値を返します。シンボリックタグに非印字文字 (Structure など) が含まれる場合は、シャープ文字 (#) で非印字文字が置き換えられます。ツール結果またはジョブデータが空の場合は、null 文字列が送信されます。

Get Value例

EasyBuilder (In-Sight ビジョンシステム)

Get Value コマンドを送信することにより、シンボリックタグに格納されているデータ (EasyBuilder の位置決めツールまたは検査ツールの結果やジョブデータなど) を返すことができます。

  1. ユーザのジョブが、三菱ロボットコントローラと通信するように設定されていると想定します。

  2. Get Value Native Mode コマンドを使用して In-Sight ビジョンシステムからデータ文字列を取得する必要があります。次の telnet クライアントウィンドウに示すように、コマンド GVJob.Robot.FormatString を発行します。

  3. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 と、フォーマットされた文字列でデータを返すことによって応答します。

EasyBuilder (In-Sight 2000 シリーズのビジョンセンサ)

In-Sight 2000 シリーズのビジョンセンサがシリアルネイティブと通信するように設定されている場合は、Get Value コマンド GVJob.FormatString を送信することによって EasyBuilder の位置決めツールまたは検査ツールの結果などのデータを返すことができます。

位置決めツールまたは検査ツールから返されるデータ型は、In-Sight 2000 シリーズのモデルによって決まります。

 | モデル | 返される結果
位置決めツール | In-Sight 2000 シリーズのビジョンセンサ、2000-23M を除く | 合格/不合格のみ (0 = False、1 = True)
 | In-Sight 2000-23M | 制限なし
検査ツール | In-Sight 2000-110、120 および 120C ビジョンセンサ | 合格/不合格のみ (0 = False、1 = True)
 | In-Sight 2000-130 および 130C | 寸法測定ツールと計数ツール: 結果値 その他のツール: 合格/不合格のみ (0 = False、1 = True)
 | In-Sight 2000-23M | 制限なし
  1. [通信] アプリケーションステップに移動します。[デバイスの追加] をクリックし、[シリアルネイティブ] を選択します。

  2. [フォーマット出力文字列] タブで、[フォーマット文字列] をクリックします。[フォーマット文字列] ダイアログで、返す項目を追加します。この例では、ダイアログで次のように設定します。

  3. [Set Serial Port Settings　(シリアルポートの設定)] タブを設定します。
  4. In-Sight ビジョンセンサをオンラインにします。

  5. 次のコマンドを発行します。次の telnet クライアントウィンドウに示す GVJob.FormatString

  6. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 と、フォーマットされた文字列でデータを返す (Brightness_1.Pass = True、Circle_1.Pass = True、Pixels_1.Fail = False、Distance_1.Distance = 307.532898) ことによって応答します。

スプレッドシートビュー

指定されたセルに格納されている値を返します。

Get Valueの入力パラメータ

Syntax:GV[Column][Row]

入力 | 説明
列 | 取得するセル値の列文字 (A ～ Z)。
行 | 取得するセル値の行番号。行番号は、3 桁で構成されている必要があります (000 ～ 399)。

Get Valueの出力

戻り値

ステータスコード。その後に行の終端文字と、指定したセルに格納されている値が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | セル ID が無効です。
-2 | コマンドを実行することができませんでした。
注 : 数値が格納されている In-Sight のセルは、Get Value コマンドによって要求されると、セルに整数または浮動小数点値が含まれるかどうかに関係なく、小数点以下 3 桁にフォーマットされた浮動小数点値を返します。セルに非印字文字 (Structure など) が格納されている場合は、シャープ文字 (#) で非印字文字が置き換えられます。セルが空の場合は、null 文字列が送信されます。

Get Value例

  1. セル A1、B0、および B1 が次のような内容であると仮定します。

    A1 = 4.000

    B0 = EditInt(0,10)

    B1 = EditFloat(0,10)

    現在 A1 には値 4 が格納されており、B0 には値 5 が格納されており、B1 には値 3.230 が格納されています。スプレッドシートには次のように表示されます。

    さまざまな GV コマンドを発行すると次のような結果になります。


Load File

指定されたジョブを In-Sight ビジョンシステムのフラッシュメモリ (RAM ディスクまたは SD カード) からロードし、アクティブジョブにします。

注 :
  • In-Sight ビジョンシステムはオフラインになっている必要があります。
  • RAMDisk フォルダに格納されているジョブファイルをロードする場合のシンタックスは、LFRAMDisk/[Filename] です。例えば、ビジョンシステムの RAMDisk フォルダに格納されているファイル「Product.job」をロードするには、次のコマンドを発行します。「LFRAMDisk/Product.job」。
  • SD Card フォルダに格納されているジョブファイルをロードする場合のシンタックスは、LFSDCARD/[Filename] です。例えば、ビジョンシステムの SD Card フォルダに格納されているファイル「Product.job」を読み取るには、次のコマンドを発行します。「LFSDCARD/Product.job」。
  • [ジョブサーバの設定] ダイアログを使用すると、In-Sight ビジョンシステムの In-Sight ジョブファイルをホストする FTP サーバを設定できます。これにより、PLC やロボットコントローラなどの別のデバイスでは、LF および TF ネイティブモードコマンドを介して場所を指定することなくジョブを変更することができます。

Load Fileの入力パラメータ

Syntax:LF[Filename]

入力 | 説明
Filename | ジョブの名前。このコマンドは、.JOB ファイル拡張子があってもなくても実行されます。

Load Fileの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | ファイル名が見つかりません。
-2 | ジョブでのロードに失敗しました。ビジョンシステムがオンラインか、またはファイルが見つかりませんでした。
-4 | ロードするジョブが見つからなかったか、ビジョンシステムがメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Load File例

In-Sight ビジョンシステムで「Product」をアクティブジョブとしてロードするには、次のコマンドを発行します。LFProduct.job

In-Sight センサは、ジョブが正常にロードされてアクティブにされたことを示す 1 を返すことによって応答します。


Motoman コマンドの例

以下に、対応する各ネイティブモードコマンドの機能を複製するために必要な Motoman コマンドシーケンスの例を示します。それぞれの例において、Motoman 変数 D001 はコマンドを保持するために使用され、Motoman 変数 B000 は D001 を指し示すインデックスを保持するために使用され、Motoman 変数 B001 は送信パラメータまたは受信データを保持する Motoman 変数を指し示すインデックスを保持するために使用されます。

Motoman コマンドの例

In-Sight センサのスロット #13 のジョブをアクティブ化します。

ネイティブモードコマンド | Motoman コマンドシーケンス
SJ13 | 0001 SET B000 1 0002 SET D001 100000 0003 SET B001 2 0004 SET B002 13 0005 SAVEV B000 0006 SAVEV D001 0007 SAVEV B001 0008 SAVEV B002
 | Motoman の B 変数 B002 はジョブ番号パラメータを保持します。

アクティブな In-Sight ジョブのジョブ番号を受け取ります。

ネイティブモードコマンド | Motoman コマンドシーケンス
GJ | 0001 SET B000 1 0002 SET D001 200000 0003 SET B001 3 0004 SAVEV B000 0005 SAVEV D001 0006 SAVEV B001 0007 LOADV B003
 | Motoman の B 変数 B003 は、アクティブな In-Sight ジョブの番号 (0 ～ 19) を保持します。

In-Sight をオンラインに設定します。

ネイティブモードコマンド | Motoman コマンドシーケンス
SO1 | 0001 SET B000 1 0002 SET D001 300000 0003 SET B001 4 0004 SET B004 1 0005 SAVEV B000 0006 SAVEV D001 0007 SAVEV B001 0008 SAVEV B004
 | Motoman の B 変数 B004 はパラメータを保持します。In-Sight をオフラインに設定するには、SET B004 0 と指定します。

In-Sight センサのオンライン/オフライン状態を取得します。

ネイティブモードコマンド | Motoman コマンドシーケンス
GO | 0001 SET B000 1 0002 SET D001 400000 0003 SET B001 5 0004 SAVEV B000 0005 SAVEV D001 0006 SAVEV B001 0007 LOADV B005
 | Motoman の B 変数 B005 はオンライン/オフライン状態 (1 または 0) を保持します。

「Soft 7」として指定されているアクティブな In-Sight ジョブでイベントをトリガします。

ネイティブモードコマンド | Motoman コマンドシーケンス
SE7 | 0001 SET B000 1 0002 SET D001 500000 0003 SET B001 6 0004 SET B006 7 0005 SAVEV B000 0006 SAVEV D001 0007 SAVEV B001 0008 SAVEV B006
 | Motoman の B 変数 B006 はイベント番号パラメータを保持します。

アクティブな In-Sight ジョブのセル A13 に格納されている EditInt 関数の値を整数値 69 に設定します。

ネイティブモードコマンド | Motoman コマンドシーケンス
SIA013 69 | 0001 SET B000 1 0002 SET D001 601013 0003 SET B001 7 0004 SET I007 69 0005 SAVEV B000 0006 SAVEV D001 0007 SAVEV B001 0008 SAVEV I007
 | Motoman の I 変数 I007 には、整数パラメータが保存されます。

アクティブな In-Sight ジョブのセル B14 に格納されている EditFloat 関数の値を　double (または real) 値 3.142 に設定します。

ネイティブモードコマンド | Motoman コマンドシーケンス
SFB014 3.142 | 0001 SET B000 1 0002 SET D001 702014 0003 SET B001 8 0004 SET R008 3.142 0005 SAVEV B000 0006 SAVEV D001 0007 SAVEV B001 0008 SAVEV R008
 | Motoman の R 変数 R008 には、double または real パラメータが格納されます。

アクティブな In-Sight ジョブのセル C15 に格納されている EditString 関数の値を文字列 (または P 変数)「1.1,2.2,3.3,4.4,5.5,6.6,00」に設定します。

ネイティブモードコマンド | Motoman コマンドシーケンス
SSC015 1.1,2.2,3.3,4.4,5.5,6.6,00 | 0001 SET B000 1 0002 SET D001 803015 0003 SET B001 9 0004 SET P009 1.1, 2.2, 3.3, 4.4, 5.5, 6.6, 00 0005 SAVEV B000 0006 SAVEV D001 0007 SAVEV B001 0008 SAVEV P009
 | Motoman の P 変数 P009 には、P 変数パラメータが保存されます。
注 : In-Sight ジョブでは、Token$ 関数を使用して P 変数の値を解析する必要があります。

アクティブな In-Sight ジョブのセル C15 に格納されている文字列 (上記の例で設定) を取得し、結果を指定された Motoman 変数に代入します。

ネイティブモードコマンド | Motoman コマンドシーケンス
GVC015 | 0001 SET B000 1 0002 SET D001 903015 0003 SET B001 10 0004 SAVEV B000 0005 SAVEV D001 0006 SAVEV B001 0007 LOADV P010
 | Motoman の P 変数 P10 には「1.1,2.2,3.3,4.4,5.5,6.6,00」が格納されます。

アクティブな In-Sight ジョブのセルに格納されている値を取得し、結果を指定された Motoman 変数に代入します。要求されたデータは、コントローラプログラムの Motoman 変数によって示される指定されたデータ型 (整数または浮動小数点) に適合するようにフォーマットされます。

注 : 数値が格納されている In-Sight のセルは、ネイティブモードコマンド GV によって要求されると、セルに整数または浮動小数点値が含まれるかどうかに関係なく、小数点以下 3 桁にフォーマットされた浮動小数点値を返します。

ネイティブモードコマンド

Motoman コマンドシーケンス

GVD016

0001 SET B000 1
0002 SET D001 904016
0003 SET B001 11
0004 SAVEV B000
0005 SAVEV D001
0006 SAVEV B001
0007 LOADV I011

この例では、1 つの I 変数 (整数) が要求されています。したがって、

  1. セル D016 に格納されている値が 123 の場合、Motoman の I 変数 I011 には「123」が格納されます。
  2. セル D016 に格納されている値が 123.555 の場合も、Motoman の I 変数 I011 に「123」が格納されます。
注 : Motoman モードコマンドでは、浮動小数点値を整数に変換する場合に丸め込み処理は実行されず、小数点以下の部分は単に切り捨てられます。必要に応じて数学的丸め込み関数を実行し、In-Sight の浮動小数点値を Motoman の整数変数に伝達するかどうかは、ユーザに任されています。

ネイティブモードコマンド

Motoman コマンドシーケンス

GVE017

0001 SET B000 1
0002 SET D001 905017
0003 SET B001 12
0004 SAVEV B000
0005 SAVEV D001
0006 SAVEV B001
0007 LOADV R012

この例では、1 つの R 変数 (real) が要求されています。したがって、

  1. セル E017 に格納されている値が 123 の場合、Motoman の R 変数 R012 には「123.000」が格納されます。
  2. セル E017 に格納されている値が 123.555 の場合、Motoman の R 変数 R012 には「123.555」が格納されます。


Motoman コマンド

Motoman ロボットコントローラは、データとコマンドを送信するか、またはデータを受信することにより、コントローラ自体と In-Sight センサの間のすべてのデータ通信を開始します。In-Sight と Motoman コントローラの間の通信は、コントローラから開始される 2 コマンド手順を使用して行われます。

ロボットコントローラから In-Sight センサにコマンドまたはデータを送信するには

4 つの Motoman SAVEV コマンドが使用されます。

  • 最初の SAVEV では、コマンドが格納されている Motoman 変数のインデックスを指定します。
  • 2 番目の SAVEV では、コマンド番号と、必要な場合にはセルアドレスを指定します。
  • 3 番目の SAVEV では、コマンドのパラメータが格納されている Motoman 変数のインデックスを指定します。
  • 4 番目の SAVEV では、コマンド番号に付加するパラメータを指定します。

In-Sight センサからロボットコントローラにデータを取得するには

直後に LOADV コマンドが続く 3 つの SAVEV コマンドが使用されます。

  • 最初の SAVEV では、コマンドが格納されている Motoman 変数のインデックスを指定します。
  • 2 番目の SAVEV では、コマンド番号と、必要な場合にはセルアドレスを指定します。
  • 3 番目の SAVEV では、In-Sight から送信される結果データが格納される Motoman 変数のインデックスを指定します。
  • LOADV によりデータが送信されます。

Motoman コマンド

Motoman モードでは、9 つのネイティブモードコマンドがサポートされます。ロボットコントローラのプログラマは、すべてのコマンドを Motoman の「D」変数として送信する必要があります。サポートされるコマンドと対応する Motoman モードのリストを以下の表に示します。

ネイティブモードコマンド | 対応する Motoman モード
Set Job (SJ) | 100000
Get Job (GJ) | 200000
Set Online (SO) | 300000
Get Online (GO) | 400000
Set Event (SE) | 500000
Set Integer (SI) | 600000
Set Float (SF) | 700000
Set String (SS) | 800000
Get Value (GV) | 900000

コマンド SJ、GJ、SO、GO、SE では、コマンドを完全に指定するために必要な追加のパラメータはありません。したがって、100000 ～ 199999 の間の値はすべての SJ コマンドを表し、200000 ～ 299999 の間の値はすべて GJ コマンドを表し、以下同様です。

コマンド SI、SF、SS、GV では、コマンドの一部として送信されるパラメータを明示する (特に、In-Sight スプレッドシートの 1 つのセルへの参照として) 必要があります。ただし、Motoman ロボットコントローラは英文字を送信しないため、適切な In-Sight セルの列参照は数値で指定する必要があります。列番号は 01000 から 26000 の数字で指定しますが、このとき、01000 は列「A」を、02000 は列「B」を示し、以下同様です (例、26000 は列「Z」を示す)。行番号は現状のまま追加されてセルアドレスを完成させます。

完全な Motoman 同等のネイティブモードコマンドは常に 100000 を超える数字になるため、ロボットコントローラによって送信されるすべてのコマンドは Motoman の D 変数として保存される必要があります。

完全な Motoman モードコマンドは以下のようにして構成されます。

ロボットコントローラの D 値コマンド = N + CC + RRR

    • N はネイティブモードと「同等」{100000 ～ 900000}
    • CC は列番号と「同等」(01000 ～ 26000)
    • RRR は行番号です。

Motoman コマンドの例

アクティブな In-Sight スプレッドシートジョブのセル B123 から値を取得するコマンドは、ネイティブモードで GVB123 として記述されます。Motoman ロボットコントローラから発行される同等のコマンドは、902123 ( 900000 + 02000 + 123 ) です。

その他の Motoman コマンドの例


ネイティブモードでの通信

ネイティブモードのプロトコルについて

In-Sight のネイティブモードのプロトコルは ASCII プロトコルであり、次のいずれからも In-Sight センサを制御することができます。

  • PC 上で動作しているカスタムアプリケーションプログラム
  • 標準シリアル通信をサポートしているリモートホスト
  • Ethernet ネットワークを介する Telnet

ネイティブモードのプロトコルは、基本と拡張の 2 組のコマンドに分けられます。ネイティブモードの基本コマンドは、2 つの文字、パラメータ (必要な場合)、および終端記号で構成されます。ネイティブモードの拡張コマンドには、追加の関数やコマンドが含まれます。コマンドは大文字と小文字が区別されません。Telnet 接続を使用してネイティブモードのコマンドを送信するときの終端記号は、CR + LF (ASCII 文字 13 + 10) です。シリアルポートを介してネイティブモードのコマンドを使用する場合は、[Native モードの詳細設定] ダイアログで、ほかの終端記号を指定することもできます。デフォルトの終端記号は CR (ASCII 文字 13) です。

ネイティブモードのコマンドがリモートから In-Sight センサに発行されると、In-Sight センサはコマンドを処理して、最後に終端記号が付いた ASCII 文字列を応答として返します。値を設定 (set) するコマンドは、「成功」の場合は 1 を返し、「コマンドが認識されない」場合は 0 を返し、「失敗」の場合は負の数を返します。値を取得 (get) するコマンドは、コマンドによって、異なるさまざまな値を返します。

注 :
  • ネイティブモードコマンドのサブセットは、(一般的な Control and Information Protocol CIPメッセージを許可する) 任意の PLC から明示的メッセージを使用して EtherNet/IP 接続を介して送信可能です。
  • In-Sight 2000 シリーズのビジョンセンサには次の制限事項があります。
    • 次のネイティブモードの基本コマンドは In-Sight 2000 シリーズのビジョンセンサではサポートされません。Read Image (RI)、Write Image (WI)、Set Integer (SI)、Set Float (SF)、Set Region (SR)、Set String (SS)、Set Event (SE)、Set Event and Wait (SW)、Send Message (SM)。
    • Get Value (GV) コマンドはシリアルネイティブの場合にのみサポートされます。
    • ネイティブモードの拡張コマンドは、特に注記がない限り、In-Sight 2000 シリーズのビジョンセンサではサポートされません。
    • In-Sight 2000-110、2000-120、および 2000-120C のビジョンセンサで可能なのは、Pass/Fail データを返すことだけです。数値データの取得を試みると、無効な許可 (-6) エラーが返されます。

ネイティブモードの基本シンタックス

ネイティブモードの基本コマンドの一般的なシンタックスは、次のとおりです。

[コマンド] [パラメータ] [終端記号]

[コマンド] は、2 文字で構成されます。一部のネイティブモードコマンドは、オプションの [パラメータ] を取ります。

ネイティブモードの基本コマンドは、[終端記号] で終了します。Telnet 接続を使用してネイティブモードのコマンドを送信するときの終端記号は、CR + LF (ASCII 文字 13 + 10) です。シリアルポートを介してネイティブモードのコマンドを使用する場合は、[Native モードの詳細設定] ダイアログで、ほかの終端記号を指定することもできます。デフォルトの終端記号は CR (ASCII 文字 13) です。

ネイティブモードの基本コマンドでは、大文字と小文字は区別されません。パラメータ間にスペースは存在しません。

注 :

  • ジョブに対して実行されるネイティブモードコマンド (Write Job、Delete Job など) は、主に下位互換性を目的としています。
  • ネイティブモードのファイル転送コマンドでは、標準の 16 ビット CRC (Cyclical Redundancy Check 周期冗長検査) チェックサムが使用されます。

ネイティブモードの拡張シンタックス

ネイティブモードの拡張コマンドの一般的なシンタックスは、次のとおりです。

[コマンド 1] [コマンド 2] [入力パラメータ] [終端記号]

[コマンド 1] は、3 つのネイティブモード拡張コマンド (Get、Put、EV) のいずれかです。[コマンド 2] は、どのデータを [コマンド 1] に基づいて送信、受信、または実行するかを示す、セカンダリコマンドです。[入力パラメータ] は、オプションの補足情報をコマンドに提供します。

ネイティブモードの拡張コマンドは、[終端記号] で終了します。Telnet 接続を使用してネイティブモードのコマンドを送信するときの終端記号は、CR + LF (ASCII 文字 13 + 10) です。シリアルポートを介してネイティブモードのコマンドを使用する場合は、[Native モードの詳細設定] ダイアログで、ほかの終端記号を指定することもできます。デフォルトの終端記号は CR (ASCII 文字 13) です。

ネイティブモードの拡張コマンドでは、大文字と小文字は区別されません。特定の入力パラメータ間にはスペースが存在することに注意してください。

ネイティブモードのコマンドを使用して In-Sight センサとシリアルポート経由で通信するには

ネイティブモードのコマンドを使用して In-Sight センサと Telnet 経由で通信するには

Telnet は、Microsoft Windows に組み込まれているクライアントであり、In-Sight のネイティブモードコマンドを使用して、センサとのリモート通信を行うことができます。

  1. リモートホストで、Telnet クライアントアプリケーションを起動します。
  2. Telnet アプリケーションで、In-Sight センサのホスト名または IP アドレスを指定して、In-Sight センサに接続します。接続に成功すると、「Welcome to In-Sight(tm)」というメッセージが表示され、一緒にハードウェアセンサタイプ (例えば、5100, 5400C) とセッション番号が表示されます。
  3. In-Sight センサの有効なユーザ名とパスワードを入力します。入力するユーザ名とパスワードは、そのセンサのユーザリストに登録されている必要があります。ログオンが成功すると、「User Logged In」というメッセージが表示されます。

Telnet 接続をテストするには、Telnet のプロンプトに対して、ネイティブモードの Get Value コマンド「gva000」を入力します。接続が確立されていた場合、コマンドは 1 を返し、その後に In-Sight センサのスプレッドシートのセル A0 の値 #画像が表示されます。

(リモートホスト上で実行させるための) カスタムアプリケーションを作成して、Telnet のログオンプロセスとネイティブモードデータの送受信を自動化することが可能です。

注 :
  • デフォルトでは、Telnet 経由で接続された場合、デフォルトのタイムアウトはありません。タイムアウト値を設定するには、Put Timeout コマンドを使用します。
  • Telnet クライアントアプリケーションでは、通常、セキュリティの目的から、パスワードはエコーバックされません。

  • UNIX ベースのプラットフォームから Telnet を使用して In-Sight センサにログオンする場合、Telnet コマンドラインは次のフォーマットである必要があります。

    • > telnet <host><port>
    • <host> は、In-Sight センサのホスト名または IP アドレスであり、<port> は、リモートの Telnet ポート (通常は 23) です。ポート番号を指定すると、UNIX のユーザ名とパスワードの認証が無効になり、UNIX システムによってユーザ名とパスワードの入力が求められます。


POWERLINK 通信

注 :
  • POWERLINK は、In-Sight のファームウェアバージョン 4.7.2 以上、および In-Sight Explorer のソフトウェアバージョン 4.7.2 以上を実行している In-Sight 70xx ～ 74xx シリーズのビジョンシステムでのみサポートされています。ファームウェアバージョン 5.1.0 以上ではサポートされません。
  • POWERLINK は、In-Sight 70xx ～ 74xx シリーズのカラービジョンシステム　(In-Sight 7010C、In-Sight 7200C、In-Sight 7400C、In-Sight 7402C) ではサポートされません。
  • In-Sight ビジョンシステムは、B&R Automation Studio バージョン 3.090 以降、および Automation Runtime バージョン 3.08 以降でのみサポートされています。

POWERLINK および In-Sight ビジョンシステム

概要

POWERLINK は、時間が重要なシステムで使用される産業用イーサネットプロトコルです。POWERLINK Ethernet プロトコルは、PLC や産業用 PC などの管理ノード (MN) を使用して、Ethernet 帯域幅を固定時間サイクル (200 ～ 10000 µs) に分割します。In-Sight ビジョンシステムなど、ネットワークで稼動しているもう 1 つのデバイスは、制御ノード (CN) として動作し、MN からのメッセージに対応したデータの送信のみ許可されています。

各サイクルの間、MN は各 CN 宛てのデータを作成し、CN はそれぞれ、ネットワーク上のほかのデバイス宛てのデータで応答します。このデータは等時性メッセージング (決定論が保証されたメッセージング) を使用したノードと非同期メッセージング (決定論の保証されていないメッセージング) を使用したノードの間で送信されます。ネットワーク上のデバイスがすべて同期された後、MN により非同期期間が開始され、1 つのデバイスがネットワーク上で標準 TCP/IP トラフィックを送信できるようになります。

注 : デバイスがネットワーク帯域幅を競合することはないので、POWERLINK ノードをまとめて接続する場合に遅延を軽減するには、スイッチではなくリピーターハブを使用します。

POWERLINK ネットワークのデバイスはすべて、ノード ID 番号 (1 ～ 240) で識別されます。MN のノード ID は常に 240で、CN はノード ID 1 ～ 239 のいずれかを持ちます。このノード ID 番号は固定 IP サブネット 192.168.100.<NodeID> と組み合わせられます。これは、ネットワーク上の各デバイスに、POWERLINK ネットワーク内の固定 IP アドレスを割り当てます。この IP アドレスは、POWERLINK ネットワークの外側にあるほかのデバイスと通信するために使用することもできます。

注 :
  • POWERLINK を有効にしたビジョンシステムを POWERLINK ネットワークから切断し、通常のイーサネットネットワークに切り替える場合、イーサネット通信がロックアップし、帯域幅が 1Mbps に制限されることがあります。通常のイーサネットネットワークを使用している場合、ジョブを編集するには、POWERLINK 通信を無効にしてください。
  • POWERLINK ネットワーク上の In-Sight ビジョンシステムが In-Sight Explorer に接続されている場合に、PLC にダウンロードを試みたり、PLC のソフトウェア再起動を試みたりすると、ビジョンシステムを In-Sight Explorer に接続できなくなることがあります。PLC に変更を加えたり再起動したりする前に、ビジョンシステムを In-Sight Explorer から切断することが推奨されます。この問題が発生した場合、In-Sight Explorer に再度接続するには、ビジョンシステムに電源を再投入してください。

POWERLINK サイクル

POWERLINK ネットワークは、「サイクル」(200 ～ 10000 µs) と呼ばれる固定タイムスライスに分割されます。各サイクルには、等時性メッセージ送信、および非同期メッセージ送信 (時間が許せば) の期間が含まれます。各サイクルのはじめに、MN はサイクルの開始 (SoC) メッセージをネットワークにブロードキャストし、サイクルの等時性フェーズが始まることを知らせます。SoC メッセージの送信後、MN はそのサイクルについて設定された CN それぞれにポーリング要求 (PReq) を送信します。各 CN はポーリング応答 (PRes) メッセージで応答します。PReq および PRes メッセージは、ネットワーク上にデータを作成するために使用されます。

POWERLINK ネットワークでは、CN はクロストラフィック通信を実行できます。つまり、最初に MN を通過しなくても互いにプロセスデータを交換できます。このタイプの設定では、1 つの PLC を POWERLINK MN にすることができます。もう 1 つの PLC は CN として動作し、In-Sight ビジョンシステムの画像取り込みを制御します。In-Sight ファームウェアは、MN 以外に 2 つの CN からのクロストラフィック通信をサポートし、各ノードから最大 100 バイトのデータを受信することができます。

注 : クロストラフィックサポートには、In-Sight 4.8.0 以降のファームウェアが必要です。

CN データが送信されるたびに、MN は非同期の開始 (SoA) メッセージをネットワークに送信し、サイクルの非同期フェーズの開始を知らせます。この間、1 つのノード (SoA フレームに含まれるデータにより示されるもの) がネットワークへの送信を許可されるパケットは 1 つです。このノードに、そのサイクル期間の容量以上のデータがある場合、この送信は複数のサイクルの非同期フェーズに拡散されます。

非同期データ転送

In-Sight ビジョンシステムにとって、POWERLINK ネットワークの非同期データ送信機能は非常に重要です。非同期フェーズは次のタスクを実行するために使用されます。

  • を使用したビジョンシステムの設定とモニタIn-Sight Explorer
  • オンライン状態での In-Sight Explorerまたは Cognex VisionView への画像とデータの転送
  • WriteImageFTP 関数を使用して FTP サーバに画像を送信

POWERLINK ネットワークの設定のうち非同期データスループットに最大の影響を持つものは、最大送信単位 (MTU) 設定とサイクル時間の 2 つです。

MTU

POWERLINK ネットワークの非同期パケットに対する MTU の範囲は 300 ～ 1500 バイトです。デフォルトでは、B&R PLC は MTU を 300 バイトに設定します。デフォルトの MTU を増やすには、非同期データ送信の各サイクルで、さらに時間を確保する必要があります。例えば、MTU では、非同期データ送信のために 27 µs の確保が要求されますが、最大サイズ (1500 バイト) の場合は 123 µs 必要です。

注 : 非同期パケットトランスファ用の MTU 値が、POWERLINK ネットワークで使用されている MTU 値と同じ値でない場合、TCP/IP 通信は正常に機能しません。

サイクル時間

サイクル時間も非同期データ送信を制限します。POWERLINK ネットワークは、1 サイクルにつき、非同期パケットを 1 つだけ送信するように設定されているため、サイクル時間を短縮すると、ネットワークで送信できる非同期パケットの数が増えます。最も一般的な POWERLINK ネットワーク設定の 1 つのサイクル時間は 400 µs です。これは 1 秒間に 2500 サイクル、つまり 1 秒間に送信できる非同期フレームの数は 2500 になります。

In-Sight ビジョンシステムの理想的な MTU とサイクル時間設定

POWERLINK はデータ送信、特に非同期の部分を Ethernet に依存しているため、POWERLINK ネットワークで使用できる帯域幅全体を計算する方法を理解することは、最適なパフォーマンスの確立には重要な決定因子です。この帯域幅全体は POWERLINK ネットワークの非同期送信を通じて通信するすべての CN で共有されます。

POWERLINK ネットワークで使用できる帯域幅全体は、一般に次の式で計算されます。

  • 帯域幅 (Mbps) = MTU × 8 ÷ サイクル時間 (µs)

Cognex では、POWERLINK ネットワーク上の In-Sight ビジョンシステムに対する最適な設定は、MTU 1500 バイト、サイクル時間 400 µs であると決定しました。MTU のサイズが大きく減少したり、サイクル時間が増加したりすると、前セクションに記載されている 3 つの箇条書き項目について、パフォーマンスが大幅に低下します。サイクル時間の計算については、B&R Automation Studio アプリケーションに用意されている B&R Microsoft Excel スプレッドシート (powerlink_cycletime_calculations.xls) をご利用ください。

注 :
  • フル画像の取り込みやフル解像度画像の送信および記録など、取り込まれた画像および画像の更新設定。限られた帯域幅環境の中で、目標は画像の取得レートを削減することです。このためには、部分的な取り込みが行われるように AcquireImage 関数の [取り込み開始行] および [行数] パラメータを設定し、[記録/再生のオプション] ダイアログの [記録] タブで、[画像の解像度] パラメータを [ハーフ] または [クォーター] に設定します。必要に応じて、この方法で設定を行い、バックグラウンドサービス用の帯域幅を増やします。
  • WriteImageFTP または WriteImageSFTP 関数を使用して画像を送信すると、画像解像度の設定に関係なく、 で使用できる帯域幅が削減されますIn-Sight Explorer。

  • POWERLINK サイクル時間が 500µs 未満に設定されている場合、使用できる User Data チャネルは 16 に制限され、Inspection Results は 24 に制限されます。サイクル時間設定が低すぎる場合や、送信するデータの設定が多すぎる場合は、POWERLINK 接続が失敗します。

POWERLINK ネットワークゲートウェイおよび In-Sight ビジョンシステム

B&R PLC は、POWERLINK ネットワーク上のデバイスと、標準 Ethernet ポートを通じて接続されたデバイスの間の TCP/IP トラフィック用ゲートウェイとして動作することができます。In-Sight Explorerには、[In-Sight ネットワーク] ペインに POWERLINK ネットワークを追加する機能があります。[エクスプローラリモートサブネットリスト] ダイアログ ([システム] メニューからアクセス可能) を使用して、POWERLINK ネットワークを追加し、サブネット情報を設定することができます。この設定後、[In-Sight ネットワーク] ペインには、POWERLINK サブネットの In-Sight ビジョンシステムが表示されるようになります。

POWERLINK 通信で使用するために In-Sight ビジョンシステムを設定

このセクションでは、POWERLINK 通信を使用して、B&R PLC を In-Sight ビジョンシステムに接続する方法を説明します。

注 :
  • これらの手順では、POWERLINK ネット経由での送信準備の整ったデータを含むジョブが In-Sight ビジョンシステムにロードされていることを前提にしています。
  • アプリケーション開発では、工場ラインに設置されている In-Sight ビジョンシステムに直接接続することを推奨します。これにより画像の更新速度が速くなるため、焦点の調節や画像の位置揃え、アプリケーションのセットアップがしやすくなります。アプリケーションの開発が完了したら、ジョブを保存してから、POWERLINK を有効化し、リモートサブネットを追加します。このリモートサブネットでは、In-Sight Explorer将来のトラブルシューティングやアプリケーションの追加開発のために、 からビジョンシステムをモニタできます。

In-Sight ビジョンシステムでの POWERLINK 通信の有効化

In-Sight ビジョンシステムを POWERLINK ネットワークに配置するには、まず、In-Sight ビジョンシステムの [ネットワークの設定] ダイアログを使用して、POWERLINK が有効になるようにビジョンシステムを設定する必要があります。

注 : これらの手順では、POWERLINK ネットワークが既に動作していて、ほかのデバイスもこのネットワークにあり、かつ MN が B&R PLC であることを前提にしています。
  1. POWERLINK ネットワークに配置する In-Sight ビジョンシステムを、 が実行されている PC に直接接続しますIn-Sight Explorer。
  2. を開き、In-Sight Explorer目的の In-Sight ビジョンシステムに接続します。
  3. [センサ] メニューから [ネットワークの設定] ダイアログを開きます。
  4. ダイアログの [産業用イーサネットプロトコル] セクションで [POWERLINK] を選択し、[設定] ボタンをクリックして [POWERLINKの設定] ダイアログを開きます。
  5. [POWERLINKの設定] ダイアログは、In-Sight ビジョンシステムのノード ID を定義するために使用されます。
  6. メッセージプロンプトが表示されたら、In-Sight ビジョンシステムを再起動し、電源の再投入後に POWERLINK プロトコルを有効にします。
  7. ビジョンシステムを PC から外し、POWERLINK ネットワークに接続します。

In-Sight ビジョンシステムへの周期接続の確立

In-Sight ビジョンシステムを POWERLINK ネットワークに統合しやすくするために、Cognex は Automatic Studio へのインポート用 In-Sight-7000.xdd ファイル (0000031D_In-Sight-7000.xdd) を作成しました。In-Sight-7000.xdd ファイルは、POWERLINK ネットワーク経由でデータを送信しやすくするために、In-Sight ビジョンシステムから POWERLINK マスターノードへのネットワークインタフェースを記述したものです。

  1. Automation Studio の [ツール] メニューにアクセスし、[Import Fieldbus Device] オプションを選択します。
  2. In-Sight Explorer 4.7.1 に含まれている .xdd ファイル (例えば、C:\Program Files\Cognex\In-Sight\In-Sight Explorer 4.7.1\XDD) に移動し、ファイル (0000031D_In-Sight-7000.xdd) をインポートします。

  3. In-Sight-7000.xdd ファイルのインポート後、In-Sight ビジョンシステムを POWERLINK ネットワークに追加し、ノード ID を割り当てる必要があります。

    注 : Automation Studio へのサードパーティデバイスの追加に関する具体的な情報については、B&R Automation Studio ヘルプの Explorer POWERLINK ヘルプコンテンツを参照してください。
  4. In-Sight ビジョンシステムの追加が正常に終了したら、POWERLINK ネットワークへ周期的に送信されるチャネルを有効化します。In-Sight ビジョンシステムとの通信が確立されたら、[Cyclic transmission] の値を [Write] (ビジョンシステムへ出力) または [Read] (ビジョンシステムから入力) に設定し、このチャネルのデータを送信します。

  5. 有効化されたチャネルも、システム変数にマップすることができます。

    注 : コントロールブロックやステータスブロックなど、ビットレベルのデータには、倍精度整数名にビット位置指定子を追加してアクセスする必要があります。このリリースでは、ビット変数を直接マッピングすることはできません。
  6. 適切に設定されたプロジェクトは B&R PLC にダウンロードされ、その後、PLC は In-Sight ビジョンシステムを使用して、データの周期転送を開始します。
  7. In-Sight ビジョンシステムが正常に動いていることを確認するには、Automation Studio の Monitor モードに入り、ビジョンシステムの I/O マッピングを開いて、ModuleOK チャネルが TRUE であることを確認します。

AcquireImage の [トリガ] パラメータの設定

In-Sight ビジョンシステムを POWERLINK ネットワークに統合すると、POWERLINK ネットワークで画像を取り込むためにビジョンシステムをトリガできるようになります。AcquireImage 関数の [トリガ] パラメータを [産業用イーサネット] に設定すると、POWERLINK が有効化されるときにハードウェア支援のトリガモードが有効化されます。

  1. AcquireImage 関数のプロパティシートを開きます。
  2. [トリガ] パラメータを [産業用イーサネット] に設定します。
  3. In-Sight ビジョンシステムをオンラインにします。
  4. In-Sight ビジョンシステムのトリガを行うには、Inspection Control オブジェクトの [コントロール] フィールドにある Trigger Enable と Trigger ビットを直接操作するか、Inspection Status オブジェクトの [ステータス] 構造体にある Trigger Ready、Trigger Ack、Acquiring、および Missed Acq ビットをモニタします。
  5. Automation Studio で、Inspection Control チャネルから Trigger Enable ビットを True に設定し、Trigger ビットを False から True に切り替えます。また、Trigger Ready ビットは True に設定します。

In-Sight ビジョンシステムからのデータの取得

In-Sight Explorer スプレッドシートからのデータを B&R PLC で取得するには、WriteResultsBuffer 関数を使用して、データを POWERLINK ネットワークに書き込む必要があります。この関数は、FormatOutputBuffer 関数によって作成されたデータのバッファを取り、そのデータを B&R PLC の設定済みデータテーブルに書き込みます。その後、このデータはサイクル時間に関係なく、最大 4 ms おきに同期され、次の更新サイクル中に送信されます。

以下の手順に従って、In-Sight ビジョンシステムから B&R PLC に送信されるデータの書式設定の方法を説明します。

  1. まず、In-Sight Explorer を使用して、新規ジョブを作成します。
  2. [パレット] の [スニペット] タブから、次の 2 つのスニペットをスプレッドシートに追加します。[Acquisition] → [AcqCounter] および [Math & Logic] → [Random]
  3. AcquireImage セルを開いて、[トリガ] パラメータを [連続] に設定します。
  4. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatOutputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  5. [FormatOutputBuffer] ダイアログの [追加] ボタンをクリックします。これでセル選択モードになります。Random スニペットの「Scaled random number」セルを選択します。

  6. [FormatOutputBuffer] ダイアログの [追加] ボタンを再びクリックします。これでセル選択モードになります。AcqCounter スニペットのカウントセルを選択します。

  7. [OK] ボタンを押して、[FormatOutputBuffer] ダイアログを閉じます。
  8. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで WriteResultsBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  9. WriteResultsBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatOutputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  10. In-Sight ビジョンシステムをオンラインにします。
  11. In-Sight ビジョンシステムが正常に動いていることを確認するには、Automation Studio の Monitor モードに入り、ビジョンシステムの I/O マッピングを開いて、ModuleOK チャネルが TRUE であることを確認します。

In-Sight ビジョンシステムへのデータの送信

B&R PLC から In-Sight Explorer スプレッドシートにデータを送信するためには、ReadUserDataBuffer 関数を使用して、データを POWERLINK プロトコルスタックからプルする必要があります。この関数は、FormatInputBuffer 関数内で作成されたデータ形式を取り、B&R PLC から受信したデータを読み取って、このデータを書式設定して In-Sight Explorer スプレッドシートに入れます。In-Sight ビジョンシステムをトリガして B&R PLC からユーザデータを読み取るためには、コントロールブロックの Set User Data ビットを PLC からトリガする必要があります。

例: In-Sight ビジョンシステムへのデータの送信

この例では、In-Sight Explorer 内に新規ジョブを作成した後、以下の手順を実行して、B&R PLC が受信するデータを設定します。

  1. AcquireImage セルを開いて、[トリガ] パラメータを [連続] に設定します。

    注 : 連続トリガモードは、デモンストレーションのみを目的としています。連続トリガモードでは、ビジョンシステムはできる限り多くの画像を取り込み、PLC からイベントが開始されると、PLC からビジョンシステムへのデータ転送を直ちに観察できます。ランタイム操作のためにビジョンシステムを導入する準備ができたら、画像取り込みトリガのソースに基づいて、[トリガ] パラメータを再設定する必要があります。
  2. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatInputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。

  3. [FormatInputBuffer] ダイアログの [追加] ボタンをクリックして、32 ビットの浮動小数点数と 32 ビットの整数をリストに追加します。

  4. [OK] ボタンを押して、[FormatInputBuffer] ダイアログを閉じます。
  5. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックしてから、右側のペインで ReadUserDataBuffer 関数をダブルクリックして、その関数をスプレッドシートに挿入します。
  6. ReadUserDataBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatInputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  7. FormatInputBuffer 関数に追加されたフィールドに基づいて、データアクセス関数が自動的にスプレッドシートに追加されます。
  8. In-Sight ビジョンシステムをオンラインにします。
  9. Automation Studio の Monitor モードに入り、データを強制的に UserData フィールドに入れて、In-Sight ビジョンシステムが正常に動作していることを確認します。
  10. Inspection Control オブジェクトの [コントロール] フィールドで Set User Data ビットを設定します。
  11. Inspection Control オブジェクトの [コントロール] フィールドで「Set User Data」ビットの設定を解除します。ビジョンシステムは連続トリガモードになっているため、画像を取り込み、データ転送を観察することができます。

In-Sight ネットワークへの POWERLINK ネットワークの追加

[In-Sight Network] ペインに POWERLINK ネットワークを追加するには、次の手順に従って操作します。

  1. [システム] メニューで、[リモートサブネット] をクリックします。
  2. [エクスプローラリモートサブネットリスト] ダイアログで [追加] ボタンをクリックして、[サブネットの追加] ダイアログを開きます。
  3. 追加されるサブネットにわかり易い名前を付け、[名前] フィールドに入力します。
  4. [IP アドレス] フィールドの IP アドレスは、POWERLINK ネットワーク用に PLC でプログラミングされた "POWERLINK NAT subnet" IP アドレスと一致する必要があります。
  5. [マスク] フィールドに「255.255.255.0」と入力します。
  6. ネットワークインフラストラクチャが POWERLINK ネットワークへルーティングできない場合、[Use Custom Gateway] オプションをチェックし、[ゲートウェイ] フィールドに標準 Ethernet ネットワークの PLC の IP アドレスを設定します。これにより、PC のルーティングテーブルにリモートサブネットへの経路が確立されます。
  7. [OK] ボタンをクリックして、変更を確定し、[サブネットの追加] ダイアログを閉じます。
  8. 新たに設定されたリモートサブネットが [Explorer Remote Subnet List] ダイアログに表示されます。[OK] ボタンを押して、ダイアログを閉じます。
  9. POWERLINK ネットワークが [In-Sight ネットワーク] ペインに表示されるようになります。

In-Sight ビジョンシステムでの POWERLINK 通信の無効化

POWERLINK ネットワークで動作するように設定された In-Sight ビジョンシステムを無効化するには、次の手順に従って操作します。

  1. In-Sight Explorer が実行されている PC から、In-Sight ビジョンシステムを使用可能な Ethernet ポートの 1 つに接続し、PC で DHCP に設定します。
  2. [システム] メニューで、[センサ/デバイスをネットワークに追加] をクリックします。
  3. [センサ/デバイスをネットワークに追加] ダイアログで、目的の In-Sight ビジョンシステムを選択し、[DHCP で IP アドレスを自動的に取得する] オプションを選択して、[適用] ボタンをクリックします。
  4. 設定が正常に変更されたことを示すメッセージの後、指定したビジョンシステムが [In-Sight ネットワーク] ペインに表示されます。
  5. スプレッドシート または EasyBuilder 開発環境のいずれかで、ビジョンシステムへの接続を開きます。
  6. [センサ] メニューで、[ネットワークの設定] をクリックし、[ネットワークの設定] ダイアログを開きます。
  7. [産業用イーサネットプロトコル] で [なし] を選択し、[OK] ボタンをクリックします。
  8. ビジョンシステムを再起動して、変更を適用します。


PROFINET による通信

分散 I/O (リモート I/O) は PROFINET IO で接続されています。この設定では、PROFIBUS の I/O ビューが保持され、フィールドデバイスからのユーザデータが周期的にコントロールシステムのプロセスモデルに転送されます。

PROFINET IO は、挿入場所 (スロット) と I/O チャネル (サブスロット) のグループで構成されるデバイスモデルを記述します。フィールドデバイスの技術的特性は、XML 形式の GSD (General Station Description) ファイルに記載されています。

PROFINET IO では、次の 3 種類のデバイスが区別されます。

  • IO コントローラ: 自動制御プログラムが実行されるコントローラ。
  • IO デバイス: 遠隔で割り当てられるフィールドデバイスで、IO コントローラに割り当てられるもの。
  • IO スーパーバイザ: コミッショニングおよび診断機能を実行するプログラミングデバイス (PC)。

PROFINET IO のエンジニアリングプロセスは、PROFIBUS と同様です。すなわち、コンフィギュレーション時に、分散化フィールドバスが 1 つ以上の制御システムに割り当てられます。I/O デバイスは、GSD ファイルの内容に基づいて、実際のシステム拡張に応じて構成されます。同時に、I/O デバイスは、統合され、適切にパラメータ化され、PROFINET のトポロジーとして構成されます (1)。

エンジニアリングプロセスの完了後、拡張データが IO コントローラにロードされます (2)。IO コントローラは、IO デバイスとのデータ交換を独自に引き継ぎます (3)。

In-Sight システムは、一度に 2 つのコントローラ (またはスーパーバイザ) からの PROFINET IO 接続をサポートします。下記の手順では、PROFINET IO を使用して In-Sight ビジョンシステムと Siemens PLC の間でデータを転送する方法を示しています。


Set Event

ネイティブモードのコマンドを使用して、スプレッドシート内の指定したイベントをトリガします。

注 :
  • ネイティブモード コマンドによる、PLC/モーションコントローラからの取り込みトリガを許可するように、In-Sight ビジョンシステムを設定する場合は、SetEvent and Wait 関数を利用して、イベントコードを 8 (SW8) に設定することを推奨します。これによって、ビジョンシステムは、画像取り込みと検査の両方が完了してから「完了」レスポンスを PLC/モーションコントローラに送り返すようになるため、前の検査結果が PLC/モーションコントローラに送信されることはなくなります。ビジョンシステムからの「完了」レスポンスを使用して、検査結果の読み取り要求を送信する条件付き PLC ロジックを作成することもできます。SetEvent 関数を PLC/モーションコントローラで使用して画像取り込みをトリガする場合、検査結果も読み取られていない場合にのみ使用してください。それ以外の場合に使用すると、画像取り込みと検査が同期されません。ビジョンシステムは画像が取り込まれるとすぐ、検査完了前に応答を返します。
  • In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

Set Eventの入力パラメータ

Syntax:SE[Int]

入力

説明

Int

設定するイベントコード。

(0 ～ 7) | ソフトトリガ (ソフト 0、ソフト 1、...、ソフト 7) を指定します。
8 | 画像を取り込み、スプレッドシートを更新します。このオプションでは、AcquireImage 関数の [トリガ] パラメータを、[外部]、[手動]、または [ネットワーク] に設定する必要があります。

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | 番号が範囲外 (0 ～ 8 以外) であるか、整数ではありません。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetEvent 関数を使用して、スプレッドシート内のイベントをネイティブモードコマンドでトリガします。

イベント 0 (ソフト 0) をトリガするコマンドは SE0 です。


Set Float

EasyBuilder ビュー

EasyBuilder の位置決めツールまたは検査ツールのパラメータ、あるいはジョブデータなどのシンボリックタグの浮動小数点値を、指定した浮動小数点値に設定します。シンボリックタグは、浮動小数点データ型である必要があります。

Set Floatの入力パラメータ

Syntax:SF["Symbolic Tag"][Space][Float]

入力 | 説明
"Symbolic Tag" | 設定するシンボリックタグ (位置決めツールまたは検査ツールのパラメータ (例: "Pattern_1.Horizontal_Offset") あるいは EasyBuilder ジョブデータ (例: "Acquistion.Exposure_Time")) の名前。
Space | 浮動小数点値から "Symbolic Tag" を切り離す空白スペース。
Float | 設定する浮動小数点数 (小数点文字 (.) を含む)。

Set Floatの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | "Symbolic Tag" が無効か、または指定した値に浮動小数点数が含まれていません。
-2 | コマンドを実行することができなかったか、指定した浮動小数点値がコントロールの有効範囲外です。例えば、指定した名前は有効なデータタイプのコントロールを含んでいません。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Float例

新しい整数値を含む Set Float コマンドを送信することによって、位置決めツールまたは検査ツールのパラメータ、あるいはジョブデータの浮動小数点値を設定することができます。

  1. ジョブにパターン位置決めツールが含まれており、そのツールの現在の [水平オフセット] パラメータ設定がデフォルトの 0.000 に設定されていると仮定します。

  2. このパラメータの設定を Set Float ネイティブモードコマンドを使用して変更します。次の telnet クライアントウィンドウに示すように、コマンド SFPattern_1.Horizontal_Offset 100.302 を発行します。

  3. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。ツールの [水平オフセット] パラメータは、0.000 から 100.302 に正常に変更されました。

スプレッドシートビュー

セルに格納されている編集ボックスコントロールを、指定された浮動小数点値に設定します。編集ボックスコントロールのタイプは EditFloat にする必要があります。

Set Floatの入力パラメータ

Syntax:SF[Column][Row][Float]

入力 | 説明
Column | 設定するセル値の列文字 (A ～ Z)。
Row | 設定するセル値の行番号。行番号は、3 桁で構成されている必要があります (000 ～ 399)。
Float | 設定する浮動小数点数 (小数点文字 (.) を含む)。

Set Floatの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | セル ID が無効か、または指定した値に浮動小数点数が含まれていません。
-2 | コマンドを実行することができませんでした。例えば、指定したセルに編集ボックスコントロールが格納されていないか、編集ボックスコントロールが EditFloat 関数によって作成されませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Float例

セル A2 に格納されている編集ボックスを浮動小数点値 7.2 に設定するコマンドは、SFA0027.2 です。

  1. セル A2 には、次が格納されていると仮定します。

    A2 = EditFloat(0,10)

    A2 に現在格納されている値は 3.5 です。 スプレッドシートには次のように表示されます。

  2. Set Float ネイティブモードコマンドを使用してこの値を 7.2 に変更するには、次の Telnet クライアントウィンドウに示すように、コマンド SFA0027.2 を発行します。

    In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。EditFloat コントロールは、3.5 から 7.2 に正常に変更されました。


Set Integer

EasyBuilder ビュー

EasyBuilder の位置決めツールまたは検査ツールのパラメータ、あるいはジョブデータなどの、シンボリックタグの整数値を指定した整数値に設定します。パラメータまたはジョブデータは整数データタイプである必要があります。

Set Integerの入力パラメータ

Syntax:SI["Name"][Space][Int]

入力 | 説明
"Name" | 設定する位置決めツールまたは検査ツールパラメータ (例: "Pattern_1.Model_Type") あるいは EasyBuilder ジョブデータ (例: "Job.External_Reset_Counters") の名前。
Space | "name" と整数値を切り離す空白スペース。
Int | 設定する整数値。

Set Integerの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | EasyBuilder の "Name" が無効か、整数データタイプではありません。
-2 | コマンドを実行することができなかったか、指定した整数値がコントロールの有効範囲外です。例えば、指定した名前は有効なデータタイプのコントロールを含んでいません。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Integer例

例 1: 整数値を含むパラメータ値を変更する

新しい整数値を含む Set Integer コマンドを送信することによって、位置決めツールまたは検査ツールパラメータ、あるいはジョブデータの整数値を設定することができます。

  1. ジョブにパターン位置決めツールが含まれ、パターン位置決めツールの現在の [タイムアウト] パラメータが、デフォルトの 5000 ミリ秒に設定されていると仮定します。

  2. このパラメータの設定を Set Integer ネイティブモードコマンドを使用して変更します。次の telnet クライアントウィンドウに示すように、コマンド SIPattern_1.Timeout 500 を発行します。

  3. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。ツールの [タイムアウト] パラメータは、5000 から 500 に正常に変更されました。

例 2: チェックボックスを含むパラメータをオフまたはオンにする

Set Integer コマンドを使用して値 1 (有効) または 0 (無効) を送信することにより、ツールのチェックボックスパラメータを有効または無効にすることができます。

  1. ジョブにパターン位置決めツールが含まれ、パターン位置決めツールの現在の [スケール許容] パラメータが、デフォルトの無効 (オフ) に設定されていると仮定します。

  2. このパラメータの設定を、特定のパーツに基づき、プログラムで有効または無効に変更します。次の telnet クライアントウィンドウに示すように、コマンド SIPattern_1.Scale_Tolerance 1 を発行します。

  3. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。ツールの [スケール許容] パラメータは、無効 (オフ) から有効 (オン) に正常に変更されました。

例 3: ドロップダウンリストの選択を変更する

Set Integer コマンドを使用して必要な選択を示す整数を送信することにより、ツールのドロップダウンメニューリストパラメータの選択を変更することができます。ドロップダウンメニュー内の項目は、ListBox コントロールに対応しており、整数値 (ゼロから始まります) が割り当てられています。Set Integer ネイティブモードコマンドを使用して、ドロップダウンメニューを含んでいるパラメータに別の値を割り当てることによって、リストから別の値を「選択」することができます。

  1. ジョブにブロブ計数ツールが含まれ、ブロブ計数ツールの [ブロブの色] パラメータが、デフォルトの [任意]/2 に設定されていると仮定します。

  2. このパラメータの設定を、特定の製品パーツに基づき、プログラムで [黒]/0 または [白]/1 に変更します。次の telnet クライアントウィンドウに示すように、コマンド SIBlobs_1.Blob_Color 1 を発行します。

  3. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。ツールの [ブロブの色] パラメータは、[任意]/2 から [白]/1 に正常に変更されました。

スプレッドシートビュー

セルに含まれているコントロールを指定した整数値に設定します。コントロールは、EditInt、Checkbox、または ListBox タイプである必要があります。

Set Integerの入力パラメータ

Syntax:SI[Column][Row][Int]

入力 | 説明
Column | 設定するセル値の列文字 (A ～ Z)。
Row | 設定するセル値の行番号。行番号は、3 桁で構成されている必要があります (000～399)。
Int | 設定する整数値。

Set Integerの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | セル ID が無効か、または整数ではありませんでした。
-2 | コマンドを実行することができなかったか、指定した整数値がコントロールの有効範囲外です。例えば、指定したセルは有効なタイプのコントロールを含んでいません。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Integer例

例 1: EditInt コントロールの値を変更する

セル A2 の EditInt コントロールを整数値 8 に設定するコマンドは、SIA0028 です。

  1. セル A2 には、次が格納されていると仮定します。

    A2 = EditInt(0,10)

    A2 に現在含まれている値は 3 です。 スプレッドシートには次のように表示されます。

  2. Set Integer ネイティブモードコマンドを使用して、A2 内の値を 8 に変更するには、次の Telnet クライアントウィンドウに示すように、コマンド SIA0028 を発行します。

    In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。スプレッドシート内の EditInt コントロールは、3 から 8 に正常に変更されました。

例 2: CheckBox コントロールの状態を切り替える

Set Integer コマンドを使用し、チェックボックスのあるセルに値 1 (有効) または 0 (無効) を送信することによって、CheckBox コントロールを有効または無効にすることができます。

  1. セル B2、D2、および E2 に次のような値が格納されていると仮定します。

    B2 = CheckBox("Draw circle")

    D2 = 'Check box integer value =

    E2 = $B$2

    次に示すように、チェックボックスは現在オフになっています。

    注 : セル E2 は、CheckBox コントロールの整数値を報告するだけです。

  2. Set Integer ネイティブモードコマンドを使用して、このチェックボックスを選択するには、次の Telnet クライアントウィンドウに示すように、コマンド SIB0021 を発行します。

    In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。チェックボックスが選択されました。

CheckBox コントロールの新しい整数値を反映して、セル E2 は 0 から 1 に変更されました。

例 3: ListBox コントロール内の選択を変更する

ListBox コントロール内の各項目には、整数値 (ゼロから始まります) が割り当てられます。Set Integer ネイティブモードコマンドを使用して、ListBox コントロールを含んでいるセルに別の値を割り当てることによって、リストから別の値を「選択」することができます。

  1. セル B2、C2、および D2 に次のような値が格納されていると仮定します。

    B2 = ListBox("Red", "Orange", "Yellow", "Green", "Blue", "Indigo", "Violet")

    C2 = ' Integer List Value =

    D2 = $B$2

    ListBox コントロールは、現在 Yellow に設定されています。これは、次のスプレッドシートに示すように、整数値 2 に対応します。

    注 : セル D2 は、セル B2 の整数値を報告するだけです。

  2. Set Integer ネイティブモードコマンドを使用して、現在のリスト選択を Blue に変更するには、次の Telnet クライアントウィンドウに示すように、コマンド SIB0024 を発行します。

    In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。スプレッドシート内のリスト選択は、Yellow から Blue に変更されました。

    ListBox コントロールの新しい整数値を反映して、セル D2 は 2 から 4 に変更されました。


Set Job

In-Sight センサのフラッシュメモリにあるジョブスロットの 1 つからジョブをロードし、それをアクティブジョブにします。

注 :
  • In-Sight センサはオフラインになっている必要があります。
  • このコマンドは、In-Sight ビジョンシステムのフラッシュメモリに保存されたジョブに対してのみ機能します。設定済みのジョブサーバ、または In-Sight ビジョンシステムに取り付けられた SD カードにジョブを保存すると、このコマンドは機能しません。
  • ジョブ ID 番号の機能を使用するには、ロードするジョブが数値 0 ～ 999 の接頭辞を付けて保存されている必要があります。

Set Jobの入力パラメータ

Syntax: SJ[ID]

入力 | 説明
ID | ロードするジョブの ID 番号 (0 ～ 999)。

Set Jobの出力

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | ID が 0 未満か、または整数ではありません。
-2 | ジョブのロードに失敗したか、センサがオンラインになっているか、またはファイルが見つからなかったため、コマンドを実行できませんでした。
-4 | In-Sight センサのメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Job例

In-Sight ビジョンシステムで「85Test.job」をアクティブジョブとしてロードするには、次のコマンドを発行します。SJ85

In-Sight センサは、ジョブが正常にロードされてアクティブにされたことを示す 1 を返すことによって応答します。


Set Online

In-Sight センサをオンラインモードまたはオフラインモードに設定します。

注 :
  • In-Sight Explorer ユーザインタフェースで手動により、またはディスクリート入力信号によりセンサがオフラインに設定されている場合は、このコマンドによって In-Sight センサをオンラインモードにすることはできません。
  • In-Sight Explorer アプリケーションは、Set Online コマンドを In-Sight センサに送信して、バックアップやリストアなどの管理機能を実行します。

Set Onlineの入力パラメータ

Syntax:SO[Int]

入力 説明
Int
0 | In-Sight センサをオフラインに設定します。
1 | In-Sight センサをオンラインに設定します。

Set Onlineの出力

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | Int に指定された値が範囲外か、または有効な整数ではありません。
-2 | コマンドを実行することができませんでした。
-5 | 通信フラグは正常でしたが、In-Sight Explorer ユーザインタフェースで手動により、またはディスクリート I/O 信号によりセンサがオフラインに設定されているため、センサがオンラインになりませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Online例

例 1: In-Sight センサをオンラインモードに設定する

In-Sight センサをオンラインモードに設定するには、次のコマンドを発行します。SO1

In-Sight センサは、センサが正常にオンラインになったことを示すステータスコード 1 を返すことによって応答します。

例 2: In-Sight センサをオフラインモードに設定する

In-Sight センサをオフラインモードに設定するには、次のコマンドを発行します。SO0

In-Sight センサは、センサが正常にオフラインになったことを示すステータスコード 1 を返すことによって応答します。


Set String

EasyBuilder ビュー

EasyBuilder の検査ツールのパラメータなどのシンボリックタグの文字列を指定した文字列に設定します。パラメータは文字列データ型にする必要があります。

Set Stringの入力パラメータ

シンタックス: SS["Symbolic Tag"][Space][String]

入力 | 説明
"Symbolic Tag" | 位置決めツールまたは検査ツールの結果のシンボリックタグ名 ("Text_1.Match_String" など)
Space | 設定する文字列から "name" を切り離す空白スペース。
String | 設定する文字列。

Set Stringの出力

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | "Symbolic Tag" が無効です。
-2 | 入力文字列が EditString 関数で指定した最大文字列の長さより長いか、セルに EditString 関数が格納されていません。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set String例

文字認識または ID コードの読み取り検査ツールの文字列は、新規ストリングが指定されている Set String コマンドを送信することによって設定できます。

  1. ジョブに文字認識識別ツールが含まれており、そのツールの現在の [マッチ文字列] パラメータの設定がデフォルトの ABC であると仮定します。

  2. このとき、このパラメータの設定を Set String ネイティブモードコマンドを使用して変更するとします。次の telnet クライアントウィンドウに示すように、コマンド SIText_1.Match_String 604 を発行します。

  3. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。ツールの [マッチ文字列] パラメータは、ABC から 604 に正常に変更されました。

スプレッドシートビュー

セルに格納されている編集ボックスコントロールを、指定された文字列に設定します。編集ボックスコントロールのタイプは EditString にする必要があります。

Set Stringの入力パラメータ

シンタックス: SS[Column][Row][String]

入力 | 説明
Column | 設定するセル値の列文字 (A ～ Z)。
Row | 設定するセル値の行番号。行番号は、3 桁で構成されている必要があります (000～399)。
String | 設定する文字列。

Set Stringの出力

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | セル ID が無効です。
-2 | 入力文字列が EditString 関数で指定した最大文字列の長さより長いか、セルに EditString 関数が格納されていません。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set String例

  1. セル B2 には、次が格納されていると仮定します。

    B2 = EditString(20)

    EditString コントロールには現在、Before SS というテキストが含まれています。スプレッドシートには次のように表示されます。

  2. Set String ネイティブモードコマンドを使用してこのテキストを After SS に変更するには、次の Telnet クライアントウィンドウに示すように、コマンド SSB002After SS を発行します。

    In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。EditString コントロールは、Before SS から After SS に正常に変更されました。


SetSystemConfig

次のパラメータは、SetSystemConfig Evaluate ネイティブモードコマンドと組み合わせて、システムパラメータを設定するために使用されます。

注 : 引用符で囲まれている入力は、In-Sight ビジョンシステムに送信する際に引用符で囲む必要があります。

アクティブセル制限

[アクティブセル制限] ダイアログ内の使用可能なスプレッドシートセルの数を設定します。

関数の入力パラメータ

シンタックス: EVSetSystemConfig("ActiveCellLimit",Limit,WriteProcSet)

入力 | 説明
"ActiveCellLimit" | [アクティブセル制限] ダイアログの設定を参照します。
制限 (Limit) | アクティブセルの制限、セル単位(2048 ～ 10400)、6144* 注 : In-Sight 5000 ビジョンシステムのアクティブセルの制限は 4,096 セルで、変更できません。
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。ビジョンシステム/センサの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。ビジョンシステム/センサの電源を入れ直しても、設定は失われません。
* はデフォルト値を示します。

関数の結果出力

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

入力パラメータ

入力 | 説明
"ActiveCellLimit" | [アクティブセル制限] ダイアログの設定を参照します。
制限 (Limit) | アクティブセルの制限、セル単位(2048 ～ 10400)、6144* 注 : In-Sight 5000 ビジョンシステムのアクティブセルの制限は 4,096 セルで、変更できません。
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。ビジョンシステム/センサの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。ビジョンシステム/センサの電源を入れ直しても、設定は失われません。
* はデフォルト値を示します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

アクティブセル制限を 8,192 に指定するには、次のコマンドを発行します。EV SetSystemConfig("ActiveCellsLimit",8192,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、制限が設定されたことを示す 1、または制限が設定されていないことを示す 0 のどちらかの結果コードが返されます。変更を有効にするには、In-Sight ビジョンシステムの電源を入れ直す必要があります。

DHCP タイムアウト

[ネットワークの設定] ダイアログの [DHCP タイムアウト] の設定を行います。

入力パラメータ

Syntax:EVSetSystemConfig("DHCPTimeout",Timeout,WriteProcSet)

入力 | 説明
"DHCPTimeout" | [DHCP タイムアウト] 設定を参照します。
タイムアウト | (5 ～ 180)、60*
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。ビジョンシステム/センサの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。ビジョンシステム/センサの電源を入れ直しても、設定は失われません。
* はデフォルト値を示します。 |

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

30 秒の DHCP タイムアウトを指定するには、次のコマンドを発行します。EVSetSystemConfig("DHCPTimeout",30,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、18) で応答します。最後に、[DHCP タイムアウト] 設定 (30) が返されます。

Telnet ポート

[ネットワークの設定] ダイアログの [Telnet ポート] の設定を行います。

入力パラメータ

EVSetSystemConfig("DHCPTimeout",Timeout,WriteProcSet)

入力 | 説明
"TelnetPort" | [Telnet ポート] 設定を参照します。
ポート (Port) | (1 ～ 65535)、23*
プロシージャセットの書き込み (WriteProcSet) | 1 = 設定は proc.set ファイルに保存されます。ビジョンシステム/センサの電源を入れ直しても、設定は失われません。
* はデフォルト値を示します。 |
注 :
  • 有効なポート割り当ては、1 ～ 65535 の未使用の番号ですが、21、68、80、502、1069、1070、1212、2222、44818、および 50000 (In-Sight 通信のために予約済み) を除きます。
  • [Telnet ポート] 設定を有効にするには、ビジョンシステムを再起動する必要があります。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

Telnet ポート 2000 を指定するには、次のコマンドを発行します。EVSetSystemConfig("TelnetPort",2000,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、18) で応答します。最後に、[Telnet ポート] 設定 (2000) が返されます。

ネットワーク要求リンクモード

[ネットワークの設定] ダイアログで [リンクスピード] の設定を行います。このコマンドの発行後は、ビジョンシステムを再起動して変更を有効にする必要があります。

警告 : 指定のリンク速度をサポートするようにネットワークデバイスが設定されていない場合、ビジョンシステムにアクセスすることはできません。ビジョンシステムのイーサネット設定に合わせてネットワークデバイスのイーサネット設定を行ってください。

入力パラメータ

Syntax:EVSetSystemConfig("Network.RequestedLinkMode",LinkSpeed,WriteProcSet)

入力 | 説明
"Network.RequestedLinkMode" | [リンクスピード] 設定を参照します。
リンクスピード (LinkSpeed) | 0 = オートネゴシエーション* 100 = 10 Mbps 半二重 101 = 10 Mbps 全二重 102 = 100 Mbps 半二重 103 = 100 Mbps 全二重 104 = 1000 Mbps 全二重
プロシージャセットの書き込み (WriteProcSet) | 1 = 設定は proc.set ファイルに保存されます。ビジョンシステム/センサの電源を入れ直しても、設定は失われません。
* はデフォルト値を示します。
注 :
  • [1000 Mbps 全二重] オプションは、1000 Mbps イーサネット速度をサポートするビジョンシステムだけで使用できます。In-Sight 5600 シリーズのビジョンシステムの場合、128MB 以上の不揮発性フラッシュメモリを搭載したモデルだけで使用できます。
  • GetSystemConfig コマンドを使って、ビジョンシステムでサポートされるリンク速度とデュプレックスモードを決定します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

100 Mbps 全二重を使用するようビジョンシステムを設定するには、次のコマンドを発行します。EVSetSystemConfig("Network.RequestedLinkMode",103,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、現在のリンクスピード (103) が返されます。

ライブ画像

[画像の設定] ダイアログで [ライブ取り込み] の設定を行います。

Syntax:EVSetSystemConfig("LiveImage",Resolution,MaxFrameRate)

入力パラメータ

入力 | 説明
"LiveImage" | [ライブ画像] 設定を参照します。
解像度 | 1 = フル 0 または 2 = ハーフ* 3 = クォーター
最大フレームレート (MaxFrameRate) | (0.016 ～ 100)、0*
* はデフォルト値を示します。 |

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

ハーフ解像度のライブ画像を最大レート 0.064 フレーム/秒で使用するようにビジョンシステムを設定するには、次のコマンドを発行します。EVSetSystemConfig("LiveImage",1,0.064)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、18) で応答します。最後に、[ライブ取り込み] 設定 (1 0.064) が返されます。

オンライン画像

[画像の設定] ダイアログで [オンライン解像度] の設定を行います。

入力パラメータ

Syntax:EVSetSystemConfig("OnlineImage",Resolution,MaxFrameRate)

入力 | 説明
"OnlineImage" | [オンライン画像] 設定を参照します。
解像度 | 0 = 最適* 1 = フル 2 = ハーフ 3 = クォーター
最大フレームレート (MaxFrameRate) | (0.016 ～ 100)、0*
* はデフォルト値を示します。 |

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

ハーフ解像度のオンライン画像を最大レート 0.064 フレーム/秒で使用するようにビジョンシステムを設定するには、次のコマンドを発行します。EVSetSystemConfig("OnlineImage",2,0.064)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、18) で応答します。最後に、[ライブ取り込み] 設定 (2 0.064) が返されます。

有効なサービス

[ネットワークの設定] ダイアログの [プロトコルサービス] の設定を行います。

注 : EtherNet/IP サービスと PROFINET サービスは相互に排他的であるため、両方のサービスを同時に有効にすることはできません。

Syntax:EVSetSystemConfig("ServicesEnabled",Services,Mask)

入力パラメータ

入力 | 説明
"ServicesEnabled" | [プロトコルサービス] 設定を参照します。
サービス (Services)

ビジョンシステム上で有効にするすべてのサービスを指定します。サービス (Services) パラメータは、10 進値に変換されるバイナリ値です。

サービス | バイナリ | 10 進値
iQSS | 01000000 | 64
POWERLINK 注 : ファームウェアバージョン 4.x.x を実行している In-Sight 70xx ～ 74xx シリーズのビジョンシステムのみでサポートされます。 | 00100000 | 32
SLMP スキャナ | 00010000 | 16
Precision Time Protocol (IEEE 1588 PTP) | 00001000 | 8
PROFINET | 00000100 | 4
EtherNet/IP | 00000010 | 2
Modbus Server | 00000001 | 1
なし | 00000000 | 0

複数のサービスを有効にするには、有効にするサービスのバイナリ値を求めて、それを 10 進値に変換します。 閉じた 例

現在、有効になっているサービスはなく、Modbus および PROFINET サービスを有効にする必要があるとします。

  1. サービスの有効化に使用するバイナリ値を求めます。

    サービス | PROFINET | EtherNet/IP | Modbus
    バイナリ | 1 | 0 | 1

  2. バイナリ値を 10 進値に変換します。

    101 = 5

  3. サービスの変更に使用するバイナリ値を求めます。

    サービス | PROFINET | EtherNet/IP | Modbus
    バイナリ | 1 | 0 | 1

  4. バイナリ値を 10 進値に変換します。これによって、マスク (Mask) パラメータ値が得られます。

    101 = 5

  5. 次のコマンドを発行します。EV SetSystemConfig("ServicesEnabled",5,5)

    In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、有効になったサービス (5) が返されます。
マスク (Mask)

ビジョンシステム上で変更するサービスを指定します。マスク (Mask) パラメータは、10 進値に変換されるバイナリ値です。

サービス | バイナリ | 10 進値
iQSS | 01000000 | 64
POWERLINK 注 : ファームウェアバージョン 4.x.x を実行している In-Sight 70xx ～ 74xx シリーズのビジョンシステムのみでサポートされます。 | 00100000 | 32
SLMP スキャナ | 00010000 | 16
Precision Time Protocol (IEEE 1588 PTP) | 00001000 | 8
PROFINET | 00000100 | 4
EtherNet/IP | 00000010 | 2
Modbus Server | 00000001 | 1
なし | 00000000 | 0

複数のサービスを変更するには、変更するサービスのバイナリ値を求めて、それを 10 進値に変換します。 閉じた 例

現在、有効になっているサービスは、PROFINET サービスだけです。EtherNet/IP サービスを有効にして、PROFINET サービスを無効にする必要があるとします。EtherNet/IP サービスを有効にするだけなので、サービス (Service) パラメータは 2 であることがわかります。

  1. サービスの変更に使用するバイナリ値を求めます。これによって、マスク (Mask) パラメータ値が得られます。

    サービス | PROFINET | EtherNet/IP | Modbus
    バイナリ | 1 | 1 | 0

  2. バイナリ値を 10 進値に変換します。

    110 = 6

  3. 次のコマンドを発行します。EV SetSystemConfig("ServicesEnabled",2,6)

    In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、有効になったサービス (2) が返されます。
* はデフォルト値を示します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

1 つのサービスを有効にして変更するには

現在、有効になっているサービスはなく、PROFINET サービスを有効にする必要があるとします。次のコマンドを発行します。EVSetSystemConfig("ServicesEnabled",4,4)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、有効になったサービス (4) が返されます。

すべてのサービスを無効にする

すべてのサービスを無効にするので、サービス (Services) パラメータは 0 であることがわかります。

  1. サービスの変更に使用するバイナリ値を求めます。

    サービス

    PROFINET

    EtherNet/IP

    Modbus

    バイナリ

    1

    1

    1

  2. バイナリ値を 10 進値に変換します。これによって、マスク (Mask) パラメータ値が得られます。

    111 = 7

  3. 次のコマンドを発行します。EVSetSystemConfig("ServicesEnabled",0,7)

    In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、有効になったサービス (0) が返されます。

監査有効化設定

アクティブなビジョンシステムの自動監査メッセージを有効または無効にします。また、監査メッセージが生成されるイベントのタイプを指定します。

入力パラメータ

Syntax:EVSetSystemConfig("AuditEnableSettings",Enabled,SystemEvents,TaggedCells,SystemSettings,WriteProcSet)

入力 | 説明
"AuditEnableSettings" | [監査有効化 (Audit Enable)] 設定を参照します。
有効 (Enabled) | 0* = アクティブなビジョンシステムの自動監査メッセージを無効にします。 1 = アクティブなビジョンシステムの自動監査メッセージを有効にします。
システムイベント (SystemEvents) | 0 = 無効。 1* = In-Sight のシステムイベントが発生した場合 (ビジョンシステムのログオン/ログオフ、ジョブのロードまたは保存、オンラインモードからオフラインモードへの遷移、システムの起動、およびファームウェア更新) に、監査メッセージが生成されます。
タグ付きセル (TaggedCells) | 0 = 無効。 1* = In-Sight Explorer、カスタムアプリケーション、VisionView、または PLC を使用して、シンボリックタグ付きセルを編集する (例えば、セルの数式または対話型コントロールの値を変更する場合) と、監査メッセージが生成されます。
システム設定 (SystemSettings) | 0 = 無効。 1* = システム設定 (proc.set ファイルに保存されている設定) を変更すると、監査メッセージが生成されます。
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。ビジョンシステム/センサの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。ビジョンシステム/センサの電源を入れ直しても、設定は失われません。
* はデフォルト値を示します。 |

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

システム設定値が変更され、その設定値が proc.set ファイルに保存されたときにアクティブなビジョンシステムの監査メッセージの生成を有効にするには、次のメッセージを発行します。EVSetSystemConfig("AuditEnableSettings",1,0,0,1,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、結果が XML フォーマットで返されます。

監査IP設定

監査メッセージサーバの IP アドレスおよび TCP/IP ポートを指定します。

入力パラメータ

Syntax:EVSetSystemConfig("AuditIPSettings","IPAddress",Port,WriteProcSet)

入力 | 説明
"AuditIPSettings" | [監査 IP (Audit IP)] 設定を参照します。
"IPAddress" | 監査メッセージサーバの IP アドレスを指定します。
ポート (Port) | 監査メッセージサーバの TCP/IP ポートを指定します。(デフォルト = 5753) 注 : 有効なポート番号は、In-Sight 通信のために予約されているポートを除いて、1 ～ 65535 の未使用の任意の番号です。
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。ビジョンシステム/センサの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。ビジョンシステム/センサの電源を入れ直しても、設定は失われません。
* はデフォルト値を示します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

監査メッセージサーバの IP アドレスおよび TCP/IP ポートを指定して、設定を proc.set ファイルに保存するには、次のコマンドを発行します。EVSetSystemConfig("AuditIPSettings","192.168.0.13",5753,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、結果が XML フォーマットで返されます。

トリガタイムスタンプ

In-Sight ビジョンシステムが CIP-Sync および Precision Time Protocol (PTP) 経由で通信するように設定されている場合、PLC からタイムスタンプが書き込まれるユーザデータフィールドのオフセットをシステム構成変数 "EIP.TriggerTimestampInputOffset" に設定するには、SetSystemConfig コマンドを使用します。

入力パラメータ

Syntax:EVSetSystemConfig("Eip.TriggerTimestampInputOffset",Offset)

入力 | 説明
"Eip.TriggerTimestampInputOffset" | 64 ビットのタイムスタンプをマイクロ秒単位でキャプチャするための EtherNet/IP 入力アセンブリへのオフセットと、それに続けてビジョンシステムのトリガに使用される 64 ビットのシステム時間オフセットをマイクロ秒単位 (合計 16 バイト) で設定します。
オフセット (Offset) | オフセット (0 ～ 500) を指定します。この設定を無効にするには、この変数を -1 に設定します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

画像バッファを増加

ビジョンシステムの解像度と RAM サイズに基づいて、In-Sight ビジョンシステムに割り当てられる画像バッファのデフォルト数を増やすことができます。このコマンドの実行後、変更を有効化するには、ビジョンシステムの電源を入れ直す必要があります。

入力パラメータ

Syntax:EVSetSystemConfig("StartupImageBuffers",NumberofBuffers,WriteProcSet)

入力 | 説明
"StartupImageBuffers" | 起動時にビジョンシステムに割り当てられる画像バッファの数を設定します。
バッファの数 (NumberofBuffers) | ビジョンシステムに割り当てられるバッファの数を設定します。 注 : バッファの数 (NumberofBuffers) が 0 に設定されている場合、バッファ数のデフォルト値が使用されます。
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。ビジョンシステム/センサの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。ビジョンシステム/センサの電源を入れ直しても、設定は失われません。
* はデフォルト値を示します。 |

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

ExtractBlobs メモリ割り当ての調整

ExtractBlobs 関数に対するメモリを手動で割り当てられるようにします。この設定を使用する場合、指定する値は ExtractBlobs 関数の対象領域 (ROI) 内にあるピクセル数の半分以下でなければなりません。

警告 : ExtractBlobs メモリ割り当ての調整の設定は、メモリ不足のため、ExtractBlobs 関数が #ERR を返した場合のみ適用されます。この関数にメモリを割り当てるときは控えめにしてください。ExtractBlobs 関数にメモリを割り当てすぎると、In-Sight ビジョンシステム全体でメモリの問題を引き起こす場合があります。

入力パラメータ

Syntax:EVSetSystemConfig("ExtractBlobsMemory",k)

入力 | 説明
"ExtractBlobsMemory" | ExtractBlobs 関数の起動時にビジョンシステムに割り当てられるメモリの量を設定します。
k | ExtractBlobs 関数の使用時にビジョンシステムに割り当てられるメモリの量を指定します。k の値は、使用する ROI のサイズおよび画像の品質によって異なります。小さめの値から初めて、少しずつ増やします。例えば、ROI <= 640 × 480 で、斑点のある画像では、値は 8,000 から始めて、1,000 ずつ増やします。ROI <= 1600 × 1200 の場合は 32,000 から始めて 1,000 ずつ増やします。ROI <= 2448 × 2048 の場合は 128,000 から始めて 1,000 ずつ増やしていきます。 注 : ExtractBlobs のデフォルトのメモリ割り当てに戻すには 0 を入力します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

デフォルトのフォーカス位置

In-Sight 7000 シリーズのビジョンシステムがビジョンシステムの proc.set ファイルにフォーカスの位置を保存できるようにします。

注 : DefaultFocusPosition 関数は、フォーカス位置の値を保存するためにのみ使用されます。レンズを移動することはありません。

入力パラメータ

Syntax:EVSetSystemConfig("DefaultFocusPosition",Position,Apply,WriteProcSet)

入力 | 説明
"DefaultFocusPosition" | 起動時にビジョンシステムにより使用されるデフォルトのフォーカス位置を設定します。
位置 (Position) | デフォルトのフォーカス位置 (0 ～ 100) を指定します。この設定を無効にするには、この変数を -1 に設定します。
適用 (Apply) | 0* = In-Sight ビジョンシステムの電源を入れ直した後に設定が適用されます。 1 = 直ちに設定が適用されます。
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。ビジョンシステム/センサの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。ビジョンシステム/センサの電源を入れ直しても、設定は失われません。
* はデフォルト値を示します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

ストロボ開始位置

[出力詳細] ダイアログで [ストロボ開始位置] の設定を行います。

注 : [ストロボ/証明制御のトリガ] の設定を行うには、SetDiscreteOutput ネイティブモードコマンド (例 2 を参照) を使用します。

入力パラメータ

Syntax:EVSetSystemConfig("StrobeStartPosition",Position,WriteProcSet)

入力 | 説明
"StrobeStartPosition" | ストロボを開始するタイミングを指定します。
位置 (Position) | 0* = 画像取り込み開始。ストロボは、In-Sight ビジョンシステムが画像取り込みを開始するときにパルス出力します。In-Sight 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。 1 = カメラトリガ。ストロボは、カメラトリガイベントを受信するとパルス出力します。In-Sight 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。 2 = すべての行を露光。ストロボは、すべてのピクセル行が露光されたときにのみパルス出力します。In-Sight 8405 ビジョンシステムでのみサポートされています。 注 : In-Sight 8405 ビジョンシステムでストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。 詳細については、ローリングシャッターの操作をご参照ください。
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。ビジョンシステム/センサの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。ビジョンシステム/センサの電源を入れ直しても、設定は失われません。
* はデフォルト値を示します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

In-Sight ビジョンシステムが画像取り込みを開始するときにストロボが作動するように指定するには、次のコマンドを発行します。EVSetSystemConfig("StrobeStartPosition",0,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、結果が XML フォーマットで返されます。

PulseJobChangeTiming

ジョブ変更 (パルス) 信号タイプとして設定されている場合に、In-Sight 2000 シリーズのセンサでのジョブをディスクリート入力ライン 0 を介して変更する場合の入力パルスの幅を指定します。ジョブ変更は、パルス幅の異なる入力パルスを検出することによって開始されます。このパルスは外部デバイス (PLC など) によって生成され、In-Sight 2000 センサに送信されます。まず、外部デバイスから開始パルスを生成します。次に、外部デバイスから、パルス間にギャップのあるカウントパルスを発行します。最後に、外部デバイスから停止パルスを発行します。すべてのパルスおよびパルスギャップが指定のパルス長にマッチすると、ジョブ変更リクエストに成功し、ジョブがセンサにロードされます。これらの条件に 1 つでも満たない場合 (パルスまたはパルスギャップのタイミングが正しくない場合)、ジョブ変更リクエストに失敗し、ジョブ変更は起こりません。

入力パラメータ

Syntax:EVSetSystemConfig("PulseJobChangeTiming",StartPulse,StopPulse,CountPulse,PulseGap,Tolerance,WriteProcSet)

入力 | 説明
"PulseJobChangeTiming" | ジョブ変更 (パルス) のタイミングを指定します。
開始パルスの幅 (StartPulseWidth) | 開始パルスの幅を指定します。 1 ミリ秒 ～ 22000 ミリ秒 (デフォルト = 20 ± 1 ミリ秒)
停止パルスの幅 (StopPulseWidth) | 停止パルスの幅を指定します。 1 ミリ秒 ～ 22000 ミリ秒 (デフォルト = 20 ± 1 ミリ秒)
カウントパルスの幅 (CountPulseWidth) | カウントパルスの幅を指定します。 1 ミリ秒 ～ 22000 ミリ秒 (デフォルト = 10 ± 1 ミリ秒)
パルスギャップの幅 (PulseGapWidth) | パルスギャップの幅を指定します。 1 ミリ秒 ～ 22000 ミリ秒 (デフォルト = 10 ± 1 ミリ秒)
許容値 (Tolerance) | パルス幅の許容値を指定します。 > 0 ミリ秒
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。設定は In-Sight センサの電源を入れ直すと失われます。 1 = 設定は、proc.set ファイルに保存され、In-Sight ビジョンシステムの電源を入れ直しても保持されます。
* はデフォルト値を示します。
注 : EV SetSystemConfig("PulseJobChangeTiming") を発行すると、現在のパルス幅値が返されます。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

パルス幅値を指定する

パルスジョブ変換タイミングを指定して設定を proc.set ファイルに保存するには、次のコマンドを発行します。

EV SetSystemConfig("PulseJobChangeTiming",15000,15000,10000,1000,100,1)

In-Sight センサは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、結果が XML フォーマットで返されます。

現在のパルス幅値を取得する

現在のパルス幅値を取得するには、次のコマンドを発行します。EV SetSystemConfig("PulseJobChangeTiming")

In-Sight センサは、ステータスコード (1) とその後の文字数 (バイト単位、45) で応答します。最後に、結果が XML フォーマットで返されます。

起動時にシリアルハローメッセージを発信

In-Sight ビジョン・システムおよびビジョンセンサから、ビジョン・システム/センサの起動が完了し使用可能な状態になったことを警告するハローメッセージを、シリアル接続を介して発信します。

シリアルハローメッセージをリスンしているデバイスに発信するには、次の条件が必要となります。

  • ビジョン・システム/センサに、ハローメッセージが設定されている。
  • ビジョン・システム/センサが、シリアルを介し、メッセージをリスンしているデバイス (HyperTerm を実行している PC など) に接続されている。

  • ビジョン・システム/センサのシリアルポートが、[Text] または [Native] モードに設定されている。デフォルトでは、シリアルポートは [Native] モードに設定されています。詳細については、[シリアルポートの設定] ダイアログをご参照ください。

    注 : [シリアルポートの設定] ダイアログは、スプレッドシートビューのみで表示されます。EasyBuilder ビューのみをサポートしているモデルをご使用の場合、シリアルポートの設定は変更することができません。この場合、常に、[Native] モードに設定されます。

シリアルハローメッセージの設定後、ビジョン・システム/センサを再起動すると、リスンしているデバイスはハローメッセージを起動の最終シーケンスで検出します。検出までに、数分かかることがあります。

Syntax:EV SetSystemConfig("Comms.Serial.Hello","Message",PortNumber,WriteProcSet)

入力パラメータ

入力 | 説明
"Comms.Serial.Hello" | ビジョン・システム/センサを、シリアル通信を介し、ハローメッセージを起動時に発信するように設定します。
"Message" | ハローメッセージを指定します。(例: "I'm here")
PortNumber | ポート番号を指定します。常に "1" となります。
WriteProcSet | 1 = 設定は、proc.set ファイルに保存され、In-Sight ビジョンシステムの電源を入れ直しても保持されます。このコマンドは、ビジョンシステムに電源を再投入後に有効になるため、常に "1" となります。

出力結果

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

次に、telnet を介し、ハローメッセージを設定、取得、無効にする例を示します。

ハローメッセージおよびシリアルポートの設定

  • ハローメッセージ ("I'm here") を設定し、その設定を proc.set ファイルに設定するには、次のコマンドを発行します。

    EV SetSysetmConfig("Comms.Serial.Hello","I'm here",1,1)

    In-Sight ビジョンシステム/センサは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、結果が XML フォーマットで返されます。

    注 : 成功した場合、コマンドは以前に設定されたハローメッセージを上書きします。

ハローメッセージおよびシリアルポートの取得

  • ハローメッセージを取得するには、次のコマンドを発行します。

    EV SetSystemConfig("Comms.Serial.Hello")

    In-Sight ビジョンシステム/センサは、ステータスコード (1) とその後の文字数 (バイト単位、46) で応答します。最後に、メッセージ (&quot;I&apos;m here&quot;) およびポート番号 (1) が XML フォーマットで返されます。

ハローメッセージおよびシリアルポートの無効化

  • ハローメッセージを無効にするには、次のコマンドを発行します。

    EV SetSysetmConfig("Comms.Serial.Hello","",0,1)

    注 : 空の引用符 ("") はハローメッセージ設定を消去します。

    In-Sight ビジョンシステム/センサは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、結果が XML フォーマットで返されます。


Store File

現在のジョブを、In-Sight ビジョンシステムのフラッシュメモリ (RAM ディスクまたは SD カード) に保存します。

注 :

  • [オンラインでもジョブを保存] チェックボックスがオンの場合、[フル] または [プロテクト] レベルのアクセス権を持つユーザは、オンライン中にジョブを保存できます。[オンラインでもジョブを保存] チェックボックスがオフの場合、ジョブを保存するには、ビジョンシステムはオフラインでなければなりません。

  • 現在のジョブファイルを指定したファイル名でビジョンシステムの RAMDisk フォルダに保存するシンタックスは、TFRAMDisk/[Filename] です。例えば、ビジョンシステムの RAMDisk フォルダに「Test.job」を保存するには、次のコマンドを発行します。「TFRAMDisk/Test.job」。
  • 現在のジョブファイルを指定したファイル名でビジョンシステムの SD Card フォルダに保存するシンタックスは、TFSDCARD/[Filename] です。例えば、ビジョンシステムの SD Card フォルダに格納されているファイル「Test.job」を保存するには、次のコマンドを発行します。「TFSDCARD/Test.job」。
  • [ジョブサーバの設定] ダイアログを使用して、In-Sight ビジョンシステムの In-Sight ジョブファイルをホストする FTP サーバを設定します。これにより、PLC やロボットコントローラなどの別のデバイスでは、LF および TF ネイティブモードコマンドを介し、場所を指定することなくジョブを変更することができます。

Store Fileの入力パラメータ

シンタックス: TF[Filename]

入力 | 説明
Filename | ジョブの名前。ファイル拡張子は、.JOB である必要があります。

Store Fileの出力

ステータスコードの後に、行の終端文字が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | ファイル名が見つかりません。
-2 | ジョブの保存に失敗したか、ビジョンシステムがオンラインになっているか、またはファイルが見つからなかったため、コマンドを実行できませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Store File例

現在のジョブに「TEST」という名前を付けて In-Sight ビジョンシステムのフラッシュメモリに保存するには、次のコマンドを発行します。TFTest.job

In-Sight ビジョンシステムは、現在のジョブが正常に保存されたことを示す 1 を返すことによって応答します。


[センサ/デバイスをネットワークに追加] ダイアログ

[センサ/デバイスをネットワークに追加] ダイアログにより、In-Sight EtherNet デバイスを設定できます。このダイアログを使用して、次の設定を行うことができます。

  • TCP/IP サブネットでの通信、または PC への直接接続用に In-Sight デバイスを設定する。

  • 無効なネットワーク設定で In-Sight デバイスを設定する。これらのデバイスは、自動的に検出されてリストに表示されます。また、このダイアログが開いている時に In-Sight デバイスに電源が再投入されると、そのデバイスはリストに追加されます。

    ヒント : デバイスが自動的にリストに表示されない場合は、[すべて表示] ラジオボタンを選択して、サブネットで検出されたすべての In-Sight デバイスが表示されるようにします。
  • 管理用パスワードをリセットします。
  • In-Sight デバイスを工場出荷時のデフォルト設定にリセットします。
注 :
  • [センサ/デバイスをネットワークに追加] の各操作を実行するには、このデバイスに対する管理権限が必要です。
  • ファームウェア 4.1.0 以降が実行されていないデバイスでは、[センサ/デバイスをネットワークに追加] ダイアログの機能の一部が使用できません。最新バージョンへアップグレードすることを推奨します。
  • PC に搭載されているネットワークアダプタにリンクローカル IP アドレスが割り当てられていない場合、一時的なリンクローカル IP アドレスを持つデバイスは自動的に [センサ/デバイスをネットワークに追加] ダイアログに表示されます。このようなデバイスの IP アドレスは、固定または動的 IP アドレスに置き換えることを強く推奨します。
  • リモートネットワーク上のデバイスはこのダイアログには表示されません。リモートネットワーク上のデバイスに接続するには、[システム] メニューの [Explorer のホストテーブル] ダイアログまたは [Explorer Host Table (エクスプローラリモートサブネットリスト)] ダイアログを使用します。

[センサ/デバイスをネットワークに追加] ダイアログの表示

  • [システム] メニューで、[センサ/デバイスをネットワークに追加] をクリックします。または、[In-Sight ネットワーク] ペインで In-Sight センサアイコン [image] を右クリックし、表示されたポップアップメニューから [センサ/デバイスを追加] を選択します。

[センサ/デバイスをネットワークに追加] ダイアログの設定項目

リストでデバイスを選択するまで、このダイアログ内のフィールドは無効のままです。

  • [ホスト名]: ネットワークに接続された In-Sight デバイスの名前を定義します。各デバイスには、初めて起動したときにホスト名が自動的に設定されます。ホスト名を変更するには、このフィールドに変更後の名前を入力します。

    注 :
    • ホスト名に使用できる文字は、A ～ Z (大文字および小文字)、0 ～ 9、ハイフン (-)、コロン (:)、ピリオド (.)、およびアンダースコア (_) です。
    • ホスト名は最大 63 文字です。
  • [DHCP で IP アドレスを自動的に取得する]: In-Sight デバイスのネットワーク設定が起動時に DHCP サーバによって動的に行われるように指定します。
  • [次のネットワーク設定を使用する]: In-Sight デバイスが以下で設定されるネットワーク設定に従って設定されるように指定します。
    • [IP アドレス]: ローカルネットワークの IP アドレス番号付けルールに従って、ネットワーク上の各 In-Sight デバイスの一意な識別子を指定します。
    • [サブネットマスク]: IP アドレスのどの部分がネットワークを示し、どの部分がホストを示すかを定義します。IP アドレスのネットワーク部分は同じサブネットのすべてのホストにおいて共通しており、残りは各ホスト固有です。
    • [デフォルトゲートウェイ]: ネットワーク上に利用できるゲートウェイホストがある場合、その IP アドレスを指定します。ゲートウェイホストは、別々のネットワーク上のホスト間でデータのリレーを行います。
    • [DNS サーバ]: ネットワーク上に、DNS 解決を提供するホストがあれば、その IP アドレスを指定します。

    • [ドメイン名]: ホストネットワークのネットワークドメインを指定します。

      注 : ドメイン名は最大 63 文字です。
  • [PC のネットワーク設定をコピーする]: このチェックボックスをオンにすると、In-Sight デバイスのネットワーク設定が、IP アドレスのホスト部分を除き、すべてローカルコンピュータのネットワーク設定に従って構成されます。
  • [管理者パスワードのリセット]: このチェックボックスをオンにすると、In-Sight ビジョンシステムの管理者パスワードが工場出荷時の状態 (空白) にリセットされます。

  • [センサを工場出荷時の状態に初期化する]: このチェックボックスをオンにすると、In-Sight ビジョンシステムの設定がすべて (このダイアログのネットワーク設定を除き) 工場出荷時のデフォルト状態にリセットされます。例えば、ユーザリスト、ディスクリート入出力、日付/時刻、ホストリスト、シリアルおよび FTP 設定はすべてリセットされます。

    注 :
    • このオプションは、CIO-MICRO モジュール、および CIO-MICRO-CC I/O モジュールについては無効になっています。
    • In-Sight エミュレータは、[オプション] ダイアログからアクセスできる [初期値に戻す] ダイアログの [エミュレーション] オプションを使用して、工場出荷時の状態にリセットすることができます。
  • [LED 点滅開始]: このボタンをクリックすると、In-Sight デバイス上の LED が点滅を開始するため、見つけやすくなります。同時にボタンのラベルが [LED 点滅停止] に変わります。LED は [LED 点滅停止] をクリックするか、[センサ/デバイスをネットワークに追加] ダイアログを閉じるか、またはリストから別のデバイスを選択するまで点滅を続けます。
  • [更新]: In-Sight デバイスのリストを更新します。
  • [すべて表示]: サブネットで検出されたすべての In-Sight デバイスを表示します。
  • [新規を表示] (デフォルト): サブネット上のネットワーク設定が無効な In-Sight デバイスを表示します。このダイアログが開かれている間にサブネット上で電源が入れ直された In-Sight デバイスもこのリストに追加されます。

不正なネットワーク設定を再構成するには

  1. デバイスが物理的にネットワークに接続されていることを確認します。

  2. [センサ/デバイスをネットワークに追加] ダイアログを開き、リストからデバイスを選択します。デバイスがリストに表示されない場合は、[すべて表示] ボタンを選択するか、デバイスの電源を入れ直します。

    注 : In-Sight 70xx ～ 74xx シリーズのビジョンシステムの電源を入れ直す場合、電源の接続を 5 秒以上切断することを推奨します。
  3. ホスト名が正しいことを確認します。

  4. デバイスに動的 IP アドレス、または固定 IP アドレスを使用します。

    動的 IP アドレスを使用する場合:

    1. [DHCP で IP アドレスを自動的に取得する] を選択します。デバイスが DHCP サーバによって起動時に動的に構成されるようになります。

    固定 IP アドレスを使用する場合:

    1. [次のネットワーク設定を使用する] を選択します。
    2. IP アドレスを入力します。
    3. 次のいずれかの操作を行います。
      • [PC のネットワーク設定をコピーする] をクリックします。ローカルコンピュータのサブネットマスク、デフォルトゲートウェイ、DNS サーバ、およびドメイン名が自動的にデバイスに割り当てられます。
      • サブネットマスク、デフォルトゲートウェイ、DNS サーバ、ドメイン名を担当のネットワーク管理者に問い合わせ、手動で入力します。

  5. [適用] をクリックします。

    注 :

    選択したビジョンシステムでファームウェア 3.4.x 以降が実行されている場合:

    • ビジョンシステムの設定が自動的に工場出荷時の状態にリセットされることを示すダイアログが表示されます。
    • 進行状況バーが表示され、ビジョンシステムの電源を入れ直すことを促すメッセージが表示されます (電源を入れ直すと、手順 8 と 9 で説明されているダイアログは表示されなくなります)。
  8. 確認ダイアログが表示されたら、[OK] をクリックします。
  9. 検証ダイアログが表示されたら、[OK] をクリックします。

In-Sight ビジョンシステム設定を工場出荷時の状態にリセットするには

このオプションを選択すると、In-Sight ビジョンシステムの設定がすべて (このダイアログでのネットワーク設定を除き) 工場出荷時のデフォルト状態にリセットされます。例えば、ユーザリスト、ディスクリート入出力、日付/時刻、ホストリスト、シリアルおよび FTP 設定はすべてリセットされます。また、ビジョンシステムのパスワードを忘れたためにデフォルト (<blank>) に戻す必要がある場合にも、この機能が使用できます。

注 :
  • このオプションは、CIO-MICRO モジュール、および CIO-MICRO-CC I/O モジュールについては無効になっています。
  • In-Sight エミュレータは、[オプション] ダイアログからアクセスできる [初期値に戻す] ダイアログの [エミュレーション] オプションを使用して、工場出荷時の状態にリセットすることができます。
  1. デバイスが物理的にネットワークに接続されていることを確認します。

  2. [センサ/デバイスをネットワークに追加] ダイアログを開き、リストからデバイスを選択します。デバイスがリストに表示されない場合は、[すべて表示] ボタンを選択するか、デバイスの電源を入れ直します。

    注 : In-Sight 70xx ～ 74xx シリーズのビジョンシステムの電源を入れ直す場合、電源の接続を 5 秒以上切断することを推奨します。
  3. [センサを工場出荷時の状態に初期化する] を選択します。
  4. [適用] をクリックします。
  5. 確認ダイアログが表示されたら、[OK] をクリックします。

  6. 進行状況バーが表示されます。プロンプトが表示されたらビジョンシステムの電源を入れ直し、設定の変更を有効にします。

    注 : In-Sight 70xx ～ 74xx シリーズのビジョンシステムの電源を入れ直す場合、電源の接続を 5 秒以上切断することを推奨します。
  7. 検証ダイアログが表示されたら、[OK] をクリックします。


[バックアップ] ダイアログ

[バックアップ] ダイアログにより、In-Sight センサまたはエミュレータでのジョブ、画像およびセンサ設定のアーカイブコピーを、PC のハードディスクやビジョンシステムに装着されている SD カードに保存することができます。[ネットワークの設定] は、バックアップ内に保存されますが、バックアップを作成したときと同じセンサにリストアする場合にのみリストアできます。

PC へのバックアップ

アーカイブされたデータの In-Sight ビジョンシステム/エミュレータの宛先フォルダ、つまりバックアップディレクトリは、[オプション] ダイアログで定義します。In-Sight Explorer がビジョンシステムまたはエミュレータからのデータをアーカイブすると、バックアップディレクトリに、ビジョンシステムのホスト名と名前が同じで、その名前に「.000」から始まる数値サフィックスが付加されたフォルダが作成されます。その特定のセンサのバックアップがすでに存在する場合は、数値サフィックスの値が増分されます (is5400_010203.000、is5400_010203.001など)。

注 :
  • 最大 1,000 件のバックアップを In-Sight センサに保存可能です。
  • ホスト名でコロンを 1 つ以上使用するビジョンシステムをバックアップすると、結果のフォルダ名にはコロンの代わりにプラス記号 (+) が使用されます。Windows ではフォルダ名にコロンを使用できないため、これは予期される挙動です。
  • 通常、バックアップ処理は、ファイル転送処理により時間が重要なジョブのパフォーマンスが影響を受ける可能性があるため、In-Sight ビジョンシステムがオフラインの間に実施する必要があります。時間が重要ではないジョブの場合は、[オプション] ダイアログ内の [オンラインでもバックアップを行う] チェックボックスをオンにすることによってオンラインバックアップを有効にすることができます。
  • オンラインセンサでバックアッププロセスが進行している場合、センサのステータスは一時的に [image] に変更されます。バックアップが完了すると、ステータスは [image] に戻ります。

  • [バックアップディレクトリ] のデフォルトのフォルダ位置は、Program Files フォルダから次の場所に移動されており、標準ユーザがアクセスすることができます (In-Sight Explorer 4.5.0 以降)。

    • Windows 7/Windows 10:
      C:\ProgramData\Cognex\In-Sight\In-Sight Explorer x.x.x

ビジョンシステムに装着された SD カードへのバックアップ

SD カードにはバックアップが 1 つだけ保存されます。その後のバックアップでは、前のバックアップが上書きされるからです。

注 : ビジョンシステムは、SD カードにバックアップするために、オフラインになっている必要があります。

[バックアップ] ダイアログを表示するには

  • [システム] メニューで、[バックアップ] をクリックします。

[バックアップ] ダイアログの使用法

  1. 左側にあるチェックボックスをオンにすることによって、バックアップするビジョンシステム/センサまたはエミュレータを選択します。SD カードにバックアップする場合は、[SD カードを使用] チェックボックスをオンにします。

    注 :
    • 目的のビジョンシステム/センサまたはエミュレータは、検索ボックスを使用して動的にサーチすることができます。
    • [SD カードを使用] チェックボックスは、ビジョンシステムに SD カードが装着されている場合にのみ有効になります。
    • SD カードが装着されているビジョンシステムを選択しても、[SD カードを使用] チェックボックスがオフの場合、バックアップデータは PC にアーカイブされます。
  2. [バックアップ] をクリックします。


バッチ実行

[バッチ実行] ダイアログでは、TestRun で使用する複数の In-Sight ジョブファイルのロードと、単一操作としてのテストの実行を行います。

[バッチ実行] ダイアログを表示するには

  1. [パレット] の [TestRun] タブで、[TestRun] ツールバーの [バッチ実行] ボタンを押します。

[バッチ実行] ダイアログの設定項目

  • [選択中のジョブ] テーブル: チェックボックス、ジョブ名、ディレクトリの位置、TestRun の実行中および完了後のジョブのステータス (成功/失敗) が表示されます。
  • [ジョブの追加]: このボタンを押すと、[選択] ダイアログが起動します。このダイアログを使用して、1 つ以上のジョブやディレクトリを選択します。ディレクトリを選択すると、ディレクトリ内のすべての .job ファイルが追加されます。
  • [削除]: ジョブを選択してこのボタンを押すと、ジョブがリストから削除されます。
  • [すべて削除]: リスト内のジョブをすべて選択して削除します。
  • [ジョブのロード]: テーブルからジョブを選択してこのボタンを押すと、接続されている In-Sight エミュレータまたはビジョンシステムにそのジョブがロードされます。
  • [すべてを含む]: このボタンを押すと、テーブル内のすべてのジョブをバッチ実行に自動的に含めることができます。
  • [すべてを除外]: このボタンを押すと、テーブル内のすべてのジョブのバッチ実行を自動的に無効にすることができます。

  • [レポートロケーション]: バッチ実行レポートログのディレクトリの場所を表示します。

    注 :

    [レポートロケーション] が FTP サーバを使用するように設定されている場合は、ホスト名の後にスラッシュを使用する必要があります。

    • 正: ftp://10.28.127.73/
    • 誤: ftp://10.28.127.73
  • [参照]: このボタンを押すと、[開く] ダイアログが起動します。このダイアログを使用して、バッチ実行レポートログを保存するディレクトリの場所を指定します。
  • [レポート名]: バッチ実行レポートログの名前を表示します。
  • [権限]: このボタンを押すと、[権限] ダイアログが起動します。このダイアログでは、ジョブが保存されているフォルダにアクセスするためのユーザ認証を入力します (必要な場合)。このユーザ認証は、TestRun セットアップの [画像データベースフォルダ] のステップで入力する内容と一致している必要があります。
  • [日付 & 時間をレポート名に含める]: バッチ実行レポートログファイル名に、日付と時間を付加するかどうかを指定します。有効にすると、名前とファイルフォーマットの間に日付/タイムスタンプが挿入されます。例えば、レポートの名前が「MyReport」でファイルフォーマットが XML の場合、レポート名は「MyReport.20121011_082345.xml」のようになります。
  • [レポートフォーマット]: バッチ実行レポートのファイルフォーマットを指定します (プレーンテキスト、XML、または HTML。デフォルト = XML)。
  • [実行]: このボタンを押すと、バッチ TestRun 処理が開始します。ジョブを 1 つ以上選択し、レポートロケーションと作成レポート名を指定しなければ、[実行] ボタンは有効になりません。[実行] ボタンを押すと、[選択中のジョブ] テーブルの [ステータス] 列に、テスト実行の進行状況が表示されます。
  • [閉じる]: このボタンを押すと、ダイアログが終了します。


コメントダイアログ

コメントとは、そのほかのセル内容とは別にセルに付加する注釈のことです。コメント付きのセルは、色分けされた三角形のインジケータが右上隅に表示されます。コメント付きのセル上にマウスを置くと、そのセルのコメントが表示されます。例については、 閉じた ここをクリックしてください。

コメントダイアログを表示するには

  1. コメントを挿入するセルをクリックします。
  2. [挿入] メニューで、[コメント] をクリックします。または、コメントを挿入するセルを右クリックして、ショートカットメニューから [コメントの挿入] を選択します。

  3. 表示されるボックスに、コメントのテキストを入力します。

    注 : コメントダイアログは、コメントの挿入を選択した場合でも編集を選択した場合でも、常に [コメントの編集] ダイアログとして表示されます。
  4. コメントテキストの入力を完了した後、[フラグの色] ドロップダウンメニューを使用して、三角形のインジケータの色をカスタマイズすることができます。
  5. テキストとインジケータの色が確定したら、[OK] をクリックしてコメントを挿入します。

コメントを編集するには

  1. コメントがあるセルをクリックします。
  2. [挿入] メニューで、[コメント] をクリックします。または、コメント付きのセルを右クリックして、ショートカットメニューから [コメントの編集] を選択します。
  3. 編集が完了したら、[OK] をクリックして [コメントの編集] ダイアログを終了します。

コメントをセルから削除するには

  1. 削除したいコメントが付いているセルをクリックします。
  2. [編集] メニューの [クリア] オプションを展開し、[コメント] を選択します。または、[挿入] メニューの [コメント] をクリックして、ハイライト表示されたテキストを削除し、[OK] をクリックして [コメントの編集] ダイアログを終了します。

コメントダイアログの設定項目

  • コメントボックス: コメントボックスは、コメントのためのテキストを入力する領域です。コメントには最大 256 文字を入力することができます。
  • [フラグの色]: このドロップダウンリストから色を選択して、三角形のインジケータの色をカスタマイズすることができます。


[日付/時刻の設定] ダイアログ

[日付/時刻の設定] ダイアログは、アクティブな In-Sight ビジョンシステムで、日付と時刻を設定するために使用します。また、IEEE 1588 (バージョン 2) 規格で定義されている CIP-Sync および PTP (Precision Time Protocol) を使用して、非決定性 EtherNet/IP 経由で In-Sight ビジョンシステムと外部デバイス (PLC など) の間のイベントを同期化するようにビジョンシステムを設定するために使用します。ローカルタイムゾーンを設定したり、サマータイムの調整を自動的に行わせたりすることもできます。さらに、SNTP (Simple Network Time Protocol) サーバに接続して、ビジョンシステムの内部時計を自動的に同期化することができます。

注 :
  • [日付/時刻の設定] ダイアログで設定した後、アクティブな In-Sight ビジョンシステムの電源を入れ直す必要があります。
  • [時刻同期] を選択すると、自動的に [SNTP サービス] が無効にされます。また、[SNTP サービス] を有効にすると、自動的に [時刻同期] が無効にされます。1 つのビジョンシステムでは 1 つのサービスのみを有効にすることができます。
  • CIP-Sync/PTP は In-Sight 7000 Gen2 シリーズのビジョンシステム、128MB の不揮発性フラッシュメモリを搭載し、ファームウェアバージョン 4.5.0 以上を実行している In-Sight 5000 シリーズビジョンシステムで使用できます。In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-1R)、In-Sight 5705 ビジョンシステム、In-Sight 5705C ビジョンシステムは例外で、CIP-Sync をサポートしていません。In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-2R) は CIP-Sync/PTP をサポートしています。
  • [日付/時刻の設定] ダイアログは、エミュレータでは使用できません。
  • ファームウェアのリビジョンが 2.40 よりも古い場合、[日付/時刻の設定] ダイアログは使用できません。
  • In-Sight ビジョンシステムが SNTP を使用するように設定されており、[ディスクリート出力ライン] が [Job Complete] に設定され、ビジョンシステムがオンラインの場合は、SNTP 同期が発生すると [Job Complete] 信号が送信されます。

[日付/時刻の設定] ダイアログを表示するには

  • [センサ] メニューで、[日付/時刻の設定] をクリックします。

[日付/時刻の設定] ダイアログの設定項目

  • [日付]: アクティブな In-Sight センサの現在の日付を表示します。アクティブな In-Sight センサの日付を手動で調整できます。
  • [時間]: アクティブな In-Sight センサの現在の時刻を表示します。アクティブな In-Sight センサの時刻を手動で調整できます。
注 : SNTP サーバに接続できない状態で In-Sight システムの電源を入れ直すと、1970 年 1 月 1 日 0 時 00 分に初期化されます。
  • [タイムゾーン]: すべてのタイムゾーンのリストです。
  • [自動的に夏時間の調整を行う]: サマータイムに合わせて調整します。

  • [時刻同期を使用する]: IEEE 1588 (バージョン 2) 規格で定義されている CIP-Sync および PTP (Precision Time Protocol) のサポートを有効にして、非決定性 EtherNet 経由で In-Sight ビジョンシステムと外部デバイス (PLC など) の間のイベントを同期化します。PTP の IEEE 1588 仕様に従うことによって、デバイスは、非決定性ネットワーク上でローカルクロックをマスタクロックに同期化することができます。[時刻同期] を有効にした後、ビジョンシステムの電源を入れ直して PTP の使用を開始し、ビジョンシステムの日付と時刻の設定をマスタと同期化する必要があります。さらに、ビジョンシステムを有効にして電源を入れ直した後で、AcquireImage 関数の [トリガ] パラメータを [タイムスタンプ] に設定すると、EtherNet/IP 経由で送信されたタイムスタンプを介してビジョンシステムをトリガすることができます。

    注 : CIP-Sync/PTP は In-Sight 7000 Gen2 シリーズのビジョンシステム、128MB の不揮発性フラッシュメモリを搭載し、ファームウェアバージョン 4.5.0 以上を実行している In-Sight 5000 シリーズビジョンシステムで使用できます。In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-1R)、In-Sight 5705 ビジョンシステム、In-Sight 5705C ビジョンシステムは例外で、CIP-Sync をサポートしていません。In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-2R) は CIP-Sync/PTP をサポートしています。In-Sight ビジョンシステムを PTP と併用する場合のセットアップと設定の詳細については、「時刻同期の設定」のトピックを参照してください。
  • [同期の詳細設定]: このボタンをクリックすると [Time Synchronization Details] ダイアログが起動し、PTP スタックに関する読み取り専用の詳細な情報が表示されます。

  • [SNTP サービスを使用する]: このチェックボックスを ON にすると、アクティブな In-Sight センサは自動的に SNTP サーバとの日時の同期化を試みます。このチェックボックスが OFF の場合、または SNTP サーバを使用できない場合は、[日付/時刻の設定] ダイアログで手動で日時を設定できます。

    注 : In-Sight センサに固定 IP アドレスが割り当てられている場合、デフォルトゲートウェイが適切に設定されていないと、同期化ができないことがあります。
  • [同期させる]: SNTP サーバと日時を同期化させるには、このボタンをクリックします。手動で設定された日時の値は上書きされます。

  • [更新間隔]: SNTP サーバと日時を同期化する間隔を分単位で指定します。デフォルトの更新間隔は 120 分です。値を小さくすると、より頻繁に同期化を実行します。指定可能な最小更新間隔は、15 分に 1 回です。値を大きくすると、同期化の頻度が低下します。指定可能な最大更新間隔は、1,440 分に 1 回、つまり 1 日 1 回です。

    注 : In-Sight センサでは、12 時間に約 15 秒の割合で時間が遅れます。

  • [DHCP より SNTP サーバを取得]: このチェックボックスを ON にすると、アクティブな In-Sight センサは、DHCP サーバによって提供される SNTP サーバへの接続を試みます。SNTP サーバが DHCP サーバによって提供されない場合や DHCP サーバに接続できない場合は、自動的に主サーバやセカンダリサーバへの接続を試みます。

    SNTP サーバが DHCP サーバによって指定されていない場合に、[主サーバ] や [セカンダリ] のサーバも指定されていないと、In-Sight センサはネットワーク上の任意の SNTP サーバへの接続を試みます。このチェックボックスを OFF にすると、主サーバとセカンダリの SNTP サーバだけが使用されます。

  • [主サーバ]: [DHCP より SNTP サーバを取得] チェックボックスが OFF の場合や DHCP サーバが SNTP サーバを検出できない場合に使用する、プライマリ SNTP サーバの IP アドレスまたはホスト名を指定します。主サーバの SNTP サーバを使用できない場合は、セカンダリサーバが使用されます。
  • [セカンダリ]: [DHCP より SNTP サーバを取得] チェックボックスが OFF で、主サーバの SNTP サーバも使用できない場合に使用する、セカンダリ SNTP サーバの IP アドレスまたはホスト名を指定します。
  • [現在使用中のサーバ]: 現在使用中の SNTP サーバがある場合は、その SNTP サーバの IP アドレスを表示します。そうでない場合は、0.0.0.0 と表示します。


[Delete Cells (セルの削除)] ダイアログ

[セルの削除] ダイアログ

[セルの削除] ダイアログを使用して、1 つのセル、一定範囲のセル、またはスプレッドシートの行または列を削除します。

[セルの削除] ダイアログを表示するには

  1. 削除する 1 つのセル、一定範囲のセル、行または列をクリックします。

  2. [編集] メニューで、[削除] をクリックします。または、削除するセルを右クリックして、ショートカットメニューから [削除] を選択します。

  3. セル、行、または列の削除方法が決まったら、[OK] をクリックしてそれらのセル、行、または列を削除します。

[セルの削除] ダイアログの設定項目

  • [セルを左にシフト]: 選択したセルを削除し、残りのセルを左にシフトします。削除しようとするセルと同じ数のセルを選択します。
  • [セルを上にシフト]: 選択したセルを削除し、残りのセルを上にシフトします。削除しようとするセルと同じ数のセルを選択します。
  • [行全体]: セルの行全体を削除します。削除する行の 1 つのセルをクリックします。例えば、行 5 を削除するには、行 5 内の 1 つのセルをクリックします。
  • [列全体]: セルの列全体を削除します。削除する列の 1 つのセルをクリックします。例えば、列 B を削除するには、列 B 内の 1 つのセルをクリックします。


[Explorer のホストテーブルの設定] ダイアログ

[Explorer のホストテーブルの設定] ダイアログでは、In-Sight Explorer から異なるサブネット上のビジョンシステム/センサまたはエミュレータにアクセスし、ビジョンシステム/センサまたはエミュレータのエイリアスを作成することができます。Explorer のホストテーブルのエントリによって、指定された IP アドレスのホストのネットワーク設定が実際に変更されることはありません。これらのエントリは、追加のビジョンシステム/センサまたはエミュレータとして [In-Sight ネットワーク] ペインに表示されるだけです。

警告 : DHCP を使用して設定されるセンサは、特定の IP アドレスを持つことを保証できません。Explorer のホストテーブルでは、センサと通信するために固定 IP アドレスを必要とするため、異なるサブネット上のすべてのセンサを固定 IP アドレスを指定して設定することを強くお勧めします。

[Explorer のホストテーブルの設定] ダイアログを表示するには

  • [システム] メニューで、[Explorer のホストテーブル] をクリックします。

[Explorer のホストテーブルの設定] ダイアログの設定項目

  • [追加]: ホストテーブルに新規エントリを作成します。[Add Host (ホストの追加)] ダイアログが表示されます。このダイアログでは、新規ホストのホスト名、IP アドレス、およびデバイスタイプを入力できます。終了したら、[OK] をクリックします。

    注 :
    • ホスト名に使用できる文字は、A ～ Z (大文字および小文字)、0 ～ 9、ハイフン (-)、コロン (:)、カンマ (.)、およびアンダースコア (_) です。
    • ホスト名は最大 63 文字です。

  • [編集]: ホストテーブルにある既存のエントリを変更します。リストからエントリを選択して [編集] をクリックします。[Edit Host (ホストの編集)] ダイアログが表示されます。このダイアログでは、選択したホストのホスト名、IP アドレス、またはデバイスタイプを変更できます。終了したら、[OK] をクリックします。

  • [削除]: ホストテーブルからホストを削除します。削除するホストを選択し、[削除] をクリックします。

    ヒント : ホストを複数選択するには、CTRL キーを押しながらホスト名を選択します。

ホストのパラメータ

  • [ホスト名]: 指定した IP アドレスにマップする (割り当てる)、ネットワーク接続された In-Sight ビジョンシステム/センサまたはエミュレータの名前。入力したホスト名は、In-Sight インタフェースの全体でホスト名のすべてのリストに表示されます。
  • [IP アドレス]: 指定したホスト名にマップする、ネットワーク接続された In-Sight ビジョンシステム/センサまたはエミュレータの IP アドレス。
  • [センサタイプ]: 指定したホスト名/ IP アドレスにマップする、ネットワーク接続された In-Sight ビジョンシステム/センサまたはエミュレータのデバイスタイプ。指定したデバイスタイプのアイコンがドロップダウンの横に表示されます。


[エクスプローラリモートサブネットリスト] ダイアログ

リモートサブネットを設定し、[In-Sight ネットワーク] ペインにサブネットを追加して管理します。リモートサブネットワークが設定されていない場合、PC と同じサブネットワークに存在しないビジョンシステムは自動検出時に無視されます。リモートサブネットを設定すると、そのサブネットワークのビジョンシステムは、PC と同じサブネットワークに存在していなくても、PC で検出メッセージが受信されると自動的に In-Sight のネットワークリストに表示されます。

[エクスプローラリモートサブネットリスト] ダイアログの設定項目

  • [システム] メニューで、[リモートサブネット] をクリックします。

  • [名前]: [In-Sight ネットワーク] ペインに表示されているように、サブネットの名前を表示します。
  • [IP アドレス]: リモートサブネットのネットワーク IP アドレスを表示します。
  • [マスク]: リモートサブネットのサブネットマスクを表示します。
  • [カスタムゲートウェイ]: 必要に応じて、ゲートウェイ IP アドレスを表示します。
  • [追加]: [サブネットの追加] ダイアログを起動します。ここで、サブネット情報を追加します。
  • [編集]: [サブネットの編集] ダイアログを起動します。ここで、以前に作成したサブネットを変更することができます。
  • [削除]: 選択したサブネットをリストから削除します。

[サブネットの追加/編集] ダイアログの設定項目

[サブネットの追加] ダイアログは、[エクスプローラリモートサブネットリスト] で [追加] ボタンをクリックすると起動します。[サブネットの編集] ダイアログは、[エクスプローラリモートサブネットリスト] で既存のサブネットを選択して [編集] ボタンを押すか、リスト内で選択したサブネットをダブルクリックすると起動します。

  • [名前]: [In-Sight ネットワーク] ペインに表示されているように、サブネットのわかりやすい名前を指定します。
  • [IP アドレス]: リモートサブネットのネットワーク IP アドレスを指定します。
  • [マスク]: リモートサブネットのサブネットマスクを指定します。
  • [カスタムゲートウェイの使用]: ネットワークインフラストラクチャでネットワークにルーティングできない場合に、サブネットにアクセスするためにカスタムゲートウェイが必要かどうかを指定します。
  • [ゲートウェイ]: リモートサブネットにアクセスするのに使用するゲートウェイ IP アドレスを指定します。


[FormatString] ダイアログ

EasyBuilder ビュー

[FormatString] ダイアログを使用して、位置決めツールおよび検査ツールのデータを選択してフォーマットし、ロボットコントローラなどのリモートデバイスに送信可能な出力文字列を生成します。ロボットの文字列を設定する ([通信] アプリケーションステップの [通信] グループボックスで、[デバイス] を [ロボット] に設定するか、[プロトコル] を [シリアル Kuka] または [シリアル Motoman] に設定する) 場合、[FormatString] ダイアログでは、ジョブで生成されたフィクスチャ出力が自動で選択されます。

[FormatString] ダイアログ内では、参照されたそれぞれのツール結果が個々の項目としてリストに表示されます。各項目は、ラベル、データ型、小数点以下の桁数、固定幅およびパッドを割り当てることによってフォーマットできます。項目をフォーマットするためには、まずリストでハイライト表示する必要があります。出力文字列全体は、先行テキスト、終端テキスト、終端記号および区切り文字を追加することによってフォーマットできます。

注 :
  • 順番に並んでいない複数のアイテムをまとめてフォーマットするには、CTRL キーを押したまま各アイテムを順番にハイライト表示してください。
  • 順番に並んでいる複数のアイテムをまとめてフォーマットするには、SHIFT キーを押したままリストの最初のアイテムをハイライト表示し、次に最後のアイテムをハイライト表示します。

[FormatString] ダイアログの設定項目

  • [先行テキスト]: 出力文字列プレフィックス。文字列の最大長は 30 文字です。
  • [終端テキスト]: 出力文字列サフィックス。文字列の最大長は 30 文字です。
  • [終端記号]: 選択した終端文字を出力文字列に付加します。
    • [なし]: 出力文字列に終端文字は付加されません。
    • [Line Feed (ラインフィード (LF))]: 出力文字列にラインフィードを付加します。
    • [Carriage Return (CR) (キャリッジリターン (CR))]: 出力文字列にキャリッジリターンを付加します。
    • [Carriage Return and Line Feed (CR+LF)　(キャリッジリターンとラインフィード (CR+LF))]: 出力文字列にキャリッジリターンとラインフィードを付加します。
  • [Use Delimiter (区切り文字の使用)]: デフォルトで有効にされ、項目が区切られます。文字列の最大長は 1 文字です。
    • [標準]: 標準の区切り文字 (カンマ、スペース、タブ、セミコロンまたはアンダースコア) を選択できます。
    • [その他]: 1 文字のカスタム区切り文字を入力できます。
  • [追加]: [出力データの選択] ダイアログが開きます。このダイアログには、ジョブに追加されたすべての位置決めおよび検査ツールからのデータが表示されます。適切な結果を選択すると、[FormatString] ダイアログにより、選択した結果ごとに項目が 1 つ返されて作成されます。
  • [削除]: 項目リストからハイライト表示した項目を削除します。ハイライト表示の項目がない場合、[削除] ボタンは無効になります。
  • [上に移動]: ハイライト表示した項目をリストの上方に移動します。項目がリストの先頭にある場合、このボタンは無効になります。
  • [下に移動]: ハイライト表示した項目をリストの下方に移動します。項目がリストの末尾にある場合、このボタンは無効になります。
  • [ラベル]: 各項目には、その項目を識別するラベルを付けることができます。文字列の最大長は 12 文字です。
  • [ラベルを含める]: 有効にすると、項目のラベルが項目の文字列よりも前に置かれて出力文字列に含められます。
  • [データ型]: [FormatString] ダイアログでは、参照された結果の内容に基づいて、項目ごとにデータ型が自動的に判別されます。
    • [整数]: 整数値を含む文字列を返します。
    • [Unsigned Integer (符号なし整数)]: 符号なし整数値を含む文字列を返します。
    • [Integer (hex) (整数 (hex))]: 整数値の 16 進数値を含む小文字の文字列、または英数文字列の最初の文字を返します。
    • [Integer (HEX) (整数 (HEX))]: 整数値の 16 進数値を含む大文字の文字列、または英数文字列の最初の文字を返します。
    • [Integer (Octal) (整数 (8 進数))]: 整数値の 8 進数値を含む文字列、または英数文字列の最初の文字を返します。
    • [浮動小数点]: 浮動小数点値を含む文字列を返します。
    • [Scientific Notation (科学的表記法)]: 科学的表記法値を含む文字列を返します。
    • [文字]: 整数値に対応する ASCII 文字を返します。英数テキスト文字列が入力されると、最初の文字を返します。
    • [文字列]: 整数値を含む文字列を返します。
  • [Decimal Places　(小数点以下の桁数)]: 浮動小数点または科学的表記法のデータ型の小数点以下の桁数を選択します。(0 ～ 6、デフォルト = 6)。
  • [固定幅]: 各項目の文字列を固定幅として設定可能です。
    • [フィールド幅]: 各項目の文字列に含める最小文字数を指定します。(1 ～ 30、デフォルト = 8)。
    • [Pad (パディング)]: 項目の文字列の文字数が指定された [フィールド幅] より少ない場合は、次のいずれかの方法でパディングされます。
      • [Leading Spaces (先行スペース)]: 先行スペースを挿入して右揃えします。
      • Trailing Spaces (末尾スペース)]: 末尾スペースを挿入して左揃えします。
      • [Leading Zero (先行ゼロ)]: 先行ゼロを挿入して右揃えします。

  • [出力文字列]: 出力文字列を表示します。現在ハイライト表示された項目に対応する文字が太字で表示されます。 合計文字数が表示されます。Syntax:<Leading Text (optional)><Label (optional)><Item0><Delimiter (optional)><Item1><Delimiter (optional)>...<Terminator>

スプレッドシートビュー

[FormatString] ダイアログを使用することで、参照されたセルデータを簡単にフォーマットし、リモートデバイスに送信可能な出力文字列を生成できます。[FormatString] ダイアログ内では、参照されたそれぞれのセルが個々の項目としてリストに表示されます。各項目は、ラベル、データ型、小数点以下の桁数、固定幅およびパッドを割り当てることによってフォーマットできます。項目をフォーマットするためには、まずリストでハイライト表示する必要があります。出力文字列全体は、先行テキスト、終端テキスト、終端記号および区切り文字を追加することによってフォーマットできます。

注 :
  • 順番に並んでいない複数のアイテムをまとめてフォーマットするには、CTRL キーを押したまま各アイテムを順番にハイライト表示してください。
  • 順番に並んでいる複数のアイテムをまとめてフォーマットするには、SHIFT キーを押したままリストの最初のアイテムをハイライト表示し、次に最後のアイテムをハイライト表示します。

[FormatString] ダイアログを表示するには

  1. スプレッドシートの空白のセルを選択します。
  2. [挿入] メニューで、[式] をクリックします。
  3. [関数の挿入] ダイアログで、[テキスト] カテゴリを展開します。
  4. 右側のペインで、FormatString をダブルクリックします。

[FormatString] ダイアログの設定項目

  • [先行テキスト]: 出力文字列プレフィックス。文字列の最大長は 30 文字です。
  • [終端テキスト]: 出力文字列サフィックス。文字列の最大長は 30 文字です。
  • [終端記号]: 選択した終端文字を出力文字列に付加します。
    • [なし]: 出力文字列に終端文字は付加されません。
    • [Line Feed (ラインフィード (LF))]: 出力文字列にラインフィードを付加します。
    • [Carriage Return (CR) (キャリッジリターン (CR))]: 出力文字列にキャリッジリターンを付加します。
    • [Carriage Return and Line Feed (CR+LF)　(キャリッジリターンとラインフィード (CR+LF))]: 出力文字列にキャリッジリターンとラインフィードを付加します。
  • [Use Delimiter (区切り文字の使用)]: 有効にすると、項目が区切られます。文字列の最大長は 1 文字です。
    • [標準]: 標準の区切り文字 (カンマ、スペース、タブ、セミコロンまたはアンダースコア) を選択できます。
    • [その他]: 1 文字のカスタム区切り文字を入力できます。
  • [追加]: 1 つ以上のセルを参照するセル選択モードを呼び出します。セルを選択すると、このダイアログにより、選択したセルごとに項目が 1 つ返されて作成されます。
  • [削除]: 項目リストからハイライト表示した項目を削除します。ハイライト表示の項目がない場合、[削除] ボタンは無効になります。
  • [上に移動]: ハイライト表示した項目をリストの上方に移動します。項目がリストの先頭にある場合、このボタンは無効になります。
  • [下に移動]: ハイライト表示した項目をリストの下方に移動します。項目がリストの末尾にある場合、このボタンは無効になります。
  • [ラベル]: 各項目には、その項目を識別するラベルを付けることができます。文字列の最大長は 12 文字です。
  • [ラベルを含める]: 有効にすると、項目のラベルが項目の文字列よりも前に置かれて出力文字列に含められます。
  • [セル]: 各項目には式が 1 つ含まれています。式のほとんどはセル参照です。式内のセル参照は、スプレッドシート内のグラフィックスと一致するように色分けされます。

ヒント: [セル] テキストボックスにカーソルを合わせ F4 を押すと、4 つのセル参照タイプが順に切り替わります。

  • [データ型]: [FormatString] ダイアログでは、参照されたセルの内容に基づいて、項目ごとにデータ型が自動的に判別されます。
    • [整数]: 整数値を含む文字列を返します。
    • [Unsigned Integer (符号なし整数)]: 符号なし整数値を含む文字列を返します。
    • [Integer (hex) (整数 (hex))]: 整数値の 16 進数値を含む小文字の文字列、または英数文字列の最初の文字を返します。
    • [Integer (HEX) (整数 (HEX))]: 整数値の 16 進数値を含む大文字の文字列、または英数文字列の最初の文字を返します。
    • [Integer (Octal) (整数 (8 進数))]: 整数値の 8 進数値を含む文字列、または英数文字列の最初の文字を返します。
    • [浮動小数点]: 浮動小数点値を含む文字列を返します。
    • [Scientific Notation (科学的表記法)]: 科学的表記法値を含む文字列を返します。
    • [文字]: 整数値に対応する ASCII 文字を返します。英数テキスト文字列が入力されると、最初の文字を返します。
    • [文字列]: 整数値を含む文字列を返します。
  • [Decimal Places　(小数点以下の桁数)]: 浮動小数点または科学的表記法のデータ型の小数点以下の桁数を選択します。(0 ～ 6、デフォルト = 6)。
  • [固定幅]: 各項目の文字列を固定幅として設定可能です。
    • [フィールド幅]: 各項目の文字列に含める最小文字数を指定します。(1 ～ 30、デフォルト = 8)。
    • [Pad (パディング)]: 項目の文字列の文字数が指定された [フィールド幅] より少ない場合は、次のいずれかの方法でパディングされます。
      • [Leading Spaces (先行スペース)]: 先行スペースを挿入して右揃えします。
      • Trailing Spaces (末尾スペース)]: 末尾スペースを挿入して左揃えします。
      • [Leading Zero (先行ゼロ)]: 先行ゼロを挿入して右揃えします。
  • [出力文字列]: 出力文字列を表示します。現在ハイライト表示された項目に対応する文字が太字で表示されます。 合計文字数が表示されます。Syntax:<Leading Text (optional)><Label (optional)><Item0><Delimiter (optional)><Item1><Delimiter (optional)>...<Terminator>

FormatString 関数の例

以下の例では、ExtractBlobs 関数を使用して、画像の特徴の位置と角度を検索します。 FormatString 関数では、このデータを参照して、リモートデバイスに送信可能な出力文字列を返します。

  1. DetectBlobs 関数をセル A3 に挿入します。 　データ構造体が返されます。
  2. FormatString 関数をセル A5 に挿入します。[FormatString] ダイアログが自動的に開きます。

  3. [追加] ボタンをクリックして、適切なデータを含むセルを参照します。例えば、 [image] データ構造体で返されるセル C3、D3、E3 をハイライト表示します。

  4. Enter キーを押して、参照セルの選択を適用し、[FormatString] ダイアログに戻ります。参照されたセルがダイアログのリストに項目として表示されます。リストの既存の項目を追加、削除、並べ替えすることができます。
  5. [Leading Text (先行テキスト)] テキストボックスに、「ABC」と入力します。
  6. [Leading Text (末尾テキスト)] テキストボックスに、「XYZ」と入力します。
  7. [終端記号] ドロップダウンリストから、[CR+LF] を選択します。
  8. [区切り文字] チェックボックスをオンにします。
  9. [Standard Delimiter (標準区切り文字)] ドロップダウンリストから、[スペース] を選択します。

  10. リストの先頭の項目をハイライト表示し、セル C3 を参照します。[ラベル] テキストボックスに、([行] スプレッドシートのセルに対応する)「X」と入力します。
  11. リストの　2 番目の項目をハイライト表示し、セル D3 を参照します。[ラベル] テキストボックスに、([Col (列)] スプレッドシートのセルに対応する)「Y」と入力します。
  12. リストの　3 番目の項目をハイライト表示し、セル E3 を参照します。[ラベル] テキストボックスに、([角度] スプレッドシートのセルに対応する)「Angle」と入力します。
  13. SHIFT キーを押さえたままで、リストの最初の項目を選択してからリストの最後の項目を選択します。すべての項目がハイライト表示され、一度にフォーマット可能になります。
  14. [ラベルを含める] チェックボックスをオンにします。
  15. [データ型] が [浮動小数点] になっていることを確認します。
  16. [Decimal Places (小数点以下の桁数)] 入力ボックスに、「3」と入力します。
  17. [固定幅] チェックボックスをオンにします。
  18. [固定幅] テキストボックスに、「8」と入力します。
  19. [Pad (パディング)] ドロップダウンリストから、[先行ゼロ] を選択します。

  20. [OK] をクリックして [FormatString] ダイアログを閉じ、スプレッドシートに戻ります。セル A5 に出力文字列が表示されます。


[FTP の設定] ダイアログ

[FTP の設定] ダイアログでは、ファイル転送プロトコルを使用するほかのネットワークデバイスとの間で、ジョブ、画像および設定を共有するように In-Sight センサを設定します。

すべての FTP 接続が In-Sight センサ間で行われる In-Sight 専用のローカルネットワークでは、通常、ユーザがデフォルト設定を変える必要はありません。ただし、In-Sight センサとほかのネットワークサーバとの間、または別のネットワーク上の In-Sight センサとの間で FTP 接続が必要とされる場合は、デフォルトの FTP 設定を変更しなければならないことがあります。

[FTP の設定] ダイアログを表示するには

  • [センサ] メニューで、[FTP の設定] をクリックします。

[FTP の設定] ダイアログの設定項目

  • [アイドルタイムアウト]: 別のホストからこの In-Sight センサへの接続がタイムアウトする (切断される) までに、その接続をアクティビティなしの状態で開いたままにする時間 (秒)。(デフォルト = 120)
  • [Read Timeout (読み取りタイムアウト)]: アクティブな In-Sight センサがリモート FTP サーバへの接続後にデータを待つときの時間 (秒)。この値は、無応答のピアから復旧するのに使用されます。(デフォルト = 120)
  • [接続リトライ]: In-Sight センサがリモート FTP サーバへの再接続を試みる回数 (最初の接続試行に失敗した場合)。(デフォルト = 1)
  • [ローカルポート]: ローカルポートは、アクティブな In-Sight センサが着信 FTP 接続を待ち受けるときのポートです。(デフォルト = 21)

ローカルポートの例: is5100_010203 という名前の In-Sight センサの [ローカルポート] は 442 に設定されています。is5100_010203 は FTP サーバとして動作し、ポート 442 でリモートセンサからの着信接続を待ち受けています。is5100_010203 に接続するすべての In-Sight センサまたはエミュレータは、[リモートポート] を 442 に設定することが必要になります。In-Sight Explorer で is5100_010203 上のファイルを表示するには、[Explorer の FTP ポート] を 442 に設定する必要があります。

警告 : [ローカルポート] が [Explorer の FTP ポート] と同じ値に設定されていないと、In-Sight Explorer は、In-Sight センサで、バックアップ、リストア、ファームウェア更新、または [In-Sight のファイル] ペインの表示などの操作を実行できなくなります。
  • [リモートポート]: リモートポートは、アクティブな In-Sight センサがほかの In-Sight システムや FTP サーバへの接続を試みるときのポートです。(デフォルト = 21)

リモートポートの例: FLOOR1 という名前の In-Sight センサが、FLOOR2 という名前のリモート In-Sight センサからジョブファイルをロードする必要があると仮定します。FLOOR2 では [ローカルポート] が 2360 に設定されています。言い換えると、FLOOR2 はポート 2360 で FTP サーバを実行しています。この場合 FLOOR1 では、FLOOR2 に接続してジョブファイルをロードするため、その [リモートポート] を 2360 に設定する必要があります。

  • [パッシブ転送]: このチェックボックスをオンにすると、パッシブ FTP クライアント転送が有効になります。この転送方式は、In-Sight センサが、外部から接続が開始されることを許可しないファイアウォールを介して FTP サーバに接続しなければならない場合に必要とされます。(デフォルト = 未選択)


[HMI の設定] ダイアログ

[HMI の設定] ダイアログでは、Web HMI の設定を行うことができます。

注 :
  • Web HMI アプリケーションは、In-Sight ファームウェア 5.6.0 以降を実行しているビジョンシステムまたはセンサでのみ使用できます。
  • HTTPS HMI モードは、In-Sight ファームウェア 5.7.3 以降を実行しているビジョンシステムまたはセンサでのみ使用できます。
  • Web HMI フィルムストリップは、In-Sight ファームウェア 5.8.1 以降を実行しているビジョンシステムまたはセンサでのみ使用できます。
  • Web HMI カスタムビューは、In-Sight ファームウェア 5.9.0 以降を実行しているビジョンシステムまたはセンサでのみ使用できます。

[HMI の設定] ダイアログを表示するには

  • [センサ] メニューで、[HMI の設定] をクリックします。

最大ビュー接続

[最大ビュー接続] 設定を使用して、1 つの In-Sight　ビジョンシステムまたはセンサに接続可能なアプリケーション (In-Sight Explorer、In-Sight 表示コントロール、In-Sight SDK、VisionView または Web HMI) の最大数 (1 ～ 5、デフォルト = 2) を設定します。[最大ビュー接続] の値を変更し、その変更を有効にするには、In-Sight ビジョンシステムまたはセンサを再起動する必要があります。

注 :
  • [最大ビュー接続] を 2 以上に設定すると、In-Sight ビジョンシステムに追加の画像バッファが自動的に割り当てられます。例えば、[最大ビュー接続] を 2 に設定し、[画像バッファ] ダイアログで [画像バッファ] の値を 3 に設定すると、ビジョンシステムまたはセンサに 5 つの画像バッファが割り当てられます。画像バッファの合計数がビジョンシステムまたはセンサで利用可能な画像バッファの最大数を超える場合は、画像バッファの最大数がビジョンシステムまたはセンサに割り当てられます。
  • ビュー接続数を増やすと、ジョブのロードや画像の取り込みなど、そのほかのタスクで使用できる RAM の量が減り、パフォーマンスが低下する場合があります。

接続モード

1 つの In-Sight ビジョンシステムまたはセンサは、標準ビュー接続では 1 つのアプリケーションにのみ、またビュー専用接続では 4 つ以下のアプリケーションに接続できます。

最大ビュー接続 | 標準ビュー接続 (In-Sight Explorer、In-Sight 表示コントロール、In-Sight SDK、VisionView または Web HMI) | ビュー専用接続 (VisionView または/および Web HMI)
1 | 1 | 0
2 | 1 | 1
3 | 1 | 2
4 | 1 | 3
5 | 1 | 4

  • 標準ビュー接続:

    任意のアクセスレベル (フル、プロテクトまたはロック) を許可します。通常、この接続モードは、対話型コントロールの編集、ビジョンシステムまたはセンサのオンライン/オフラインの切り替え、新規ジョブのロード、ビジョンシステムまたはセンサのトリガなどのさまざまな実行モードのアクションを行うアプリケーションで使用されます。

    複数のアプリケーションを In-Sight ビジョンシステムまたはセンサに接続する場合、標準ビュー接続ではアプリケーションを 1 つだけ確立することができます。[最大ビュー接続] を 1 に設定すると、アプリケーションは自動的に標準ビュー接続で接続されます。

    注 : In-Sight Explorer、In-Sight 表示コントロール、および In-Sight SDK は、標準ビュー接続モードでのみ接続できます。

  • ビュー専用接続:

    ロックアクセスのみを許可します。この接続モードの場合、アプリケーションでは、In-Sight ビジョンシステムまたはセンサの動作の表示のみを行うことができます。対話型コントロールや、[トリガ] および [オンライン/オフライン] などのボタンは、すべて無効になります。

HMI サーバ

  • [サーバの有効化]: Web HMI サーバを有効にするには、このチェックボックスをオンにします。

  • [ポート番号]: 選択したビジョンシステムまたはセンサの Web アドレスで使用するポート番号 (デフォルト = 8087) を指定します。ポート番号はデフォルトで 8087 に設定されますが、サーバで使用可能な任意のポートに変更できます。

    注 : 次のポート番号は使用できません。21、22、23、80、502、1069、1070、2222、44818、および 50000。

  • [無通信タイムアウト]: アプリケーションでユーザをログオフするまでに、Web HMI アプリケーションが無通信の状態を続けることができる時間 (0 ～ 60 分、デフォルト = 15) を指定します。[無通信タイムアウト] を無効にするには、値を 0 に設定します。

    注 : [無通信タイムアウト] 設定は、デフォルトの認証情報 (すなわち、パスワードなしの管理ユーザ) を使用するビジョンシステムまたはセンサには適用されません。

  • [ローカルへの保存の許可]: ブラウザで Web HMI の設定 (画像スケール、画像角度、画像オフセット、および表示の設定) を記憶するかどうかを指定します。このチェックボックスをオンにする (デフォルト設定) と、[表示切り替え] ボタンをクリックするか、または画像表示設定を調整するごとに、Web HMI 設定が自動的に保存されます。

    注 : Web ブラウザの設定をチェックし、Cookies と DOM/ローカルストレージが有効になっていることを確認してください。有効になっていないと、Web HMI の設定が保存されず、エラーメッセージが表示されることがあります。
  • [ビュー選択の許可]: Web HMI アプリケーションで [表示切り替え] ボタンを有効にするかどうかを指定します。
  • [オンライン/オフラインの許可]: Web HMI アプリケーションで [オンライン/オフライン] ボタンを有効にするかどうかを指定します。
  • [ライブビデオの許可]: Web HMI アプリケーションで [ライブモード] ボタンを有効にするかどうかを指定します。
  • [トリガの許可]: Web HMI アプリケーションで [トリガ] ボタンを有効にするかどうかを指定します。
  • [画像調整の許可]: Web HMI アプリケーションで画像ツールバーを有効にするかどうかを指定します。


[HMI ビューの選択] ダイアログ

[HMI ビューの選択] ダイアログでは、ヒューマンマシンインタフェース (HMI) アプリケーションからユーザが表示することのできる [実行モード] ビューと、HMI アプリケーションの [表示切り替え] ボタンを押すときに表示されるビューの順序を指定できます。[HMI ビューの選択] 設定はジョブファイルに保存されます。

注 :
  • [現在の画像と最後に FAIL した画像 (水平)] および [現在の画像と最後に FAIL した画像 (垂直)] オプションは、In-Sight Explorer 4.5.0 以降を使用して作成されたジョブファイルに自動的に追加されます。以前のバージョンの In-Sight Explorer を使用してジョブファイルが作成されている場合、これらのオプションが追加されるのは、ジョブに カスタムビューまたは EasyView が含まれていない場合のみです。
  • [現在の画像と最後に FAIL した画像 (水平)]、[現在の画像と最後に FAIL した画像 (垂直)]、および [画像とグラフィックおよびカスタムビュー] の各オプションは、VisionView でのみサポートされています。
  • Web HMI で [実行モード] ビューを切り換えるには、まず [HMI の設定] ダイアログで [ビュー選択の許可] オプションを有効にする必要があります。
  • VisionView で [実行モード] ビューを切り換えるには、まず VisionView の [オペレータコントロール] 画面で [表示切り替え] オプションを有効にする必要があります。

[HMI ビューの選択] ダイアログを表示するには

  • [編集] メニューで、[HMI ビューの選択] を選択します。

[HMI ビューの選択] ダイアログのコントロール

  • [ビュー]: アクティブなジョブファイルで使用可能なすべての Run モードビューのリストを表示します。
    • [画像とグラフィックおよび EasyView]: 画像、ツールグラフィックス、および EasyView を表示します。[画像とグラフィックおよび EasyView] オプションがダイアログに表示されるようにするには、まず In-Sight Explorer 内で EasyView を作成し、ジョブと一緒に保存する必要があります。
    • [画像とグラフィックおよびカスタムビュー] - VisionView のみ: 画像、ツールグラフィックス、およびカスタムビューを表示します。[画像とグラフィックおよびカスタムビュー] オプションがダイアログに表示されるようにするには、まず In-Sight Explorer 内でカスタムビューを作成し、ジョブと一緒に保存する必要があります。
    • [画像のみ]: 画像のみを表示します。
    • [画像とグラフィックス]: 画像とツールグラフィックスを表示します。

    • [現在の画像と最後に FAIL した画像 (水平)] - VisionView のみ: 取り込まれた最新の画像および HMI 表示に送信される最後に取り込みに失敗した検査画像を表示します。画面が半分に分割され、左側に現在の画像、右側に最後に取り込みに失敗した画像が表示されます。

      注 :
      • [VisionView Custom View Position] が [As Specified in Job]、[Upper Left]、[Upper Right]、[Lower Left]、[Lower Right] または [Centered] に設定されている場合は、カスタムビューによって現在の画像が上書きされます。
      • フィルムストリップが停止した場合は、現在の画像の代わりにハイライトされたフィルムストリップ画像が表示され、最後に取り込みに失敗した画像は更新されません。

    • [現在の画像と最後に FAIL した画像 (垂直)] - VisionView のみ: 取り込まれた最新の画像および HMI 表示に送信される最後に取り込みに失敗した検査画像を表示します。画面が半分に分割され、上側に現在の画像、下側に最後に取り込みに失敗した画像が表示されます。

      注 :
      • [VisionView Custom View Position] が [As Specified in Job]、[Upper Left]、[Upper Right]、[Lower Left]、[Lower Right] または [Centered] に設定されている場合は、カスタムビューによって現在の画像が上書きされます。
      • フィルムストリップが停止した場合は、現在の画像の代わりにハイライトされたフィルムストリップ画像が表示され、最後に取り込みに失敗した画像は更新されません。
    • [EasyView のみ]: EasyView のみを表示します。[EasyView のみ] オプションがダイアログに表示されるようにするには、まず In-Sight Explorer 内で EasyView を作成し、ジョブと一緒に保存する必要があります。
  • [表示]: オンの場合は、対応する [実行モード] ビューを HMI アプリケーションから表示できます。
  • [上へ] および [下へ]: [上へ] および [下へ] ボタンを使用して、Web HMI アプリケーションで [表示切り替え] を押した後のビューの順序を指定します。[上へ] ボタンを押すと、ハイライトされたビューがリストの上側に移動し、[下へ] ボタンを押すと、ハイライトされたビューがリストの下側に移動します。HMI アプリケーションを開くと、[HMI ビューの選択] ダイアログでの最初のビューがデフォルトのビューとして表示されます。


[画像バッファ] ダイアログ

[画像バッファ] ダイアログの概要

[画像バッファ] ダイアログでは、[バッファモード] パラメータで [オーバーラップ] が選択されている場合に、起動時に In-Sight ビジョンシステムに割り当てる画像バッファの数を設定します。各ビジョンシステムには、画像取り込みおよびスプレッドシートや関数の実行において利用可能なデフォルトの画像バッファ数が設定されています。利用可能な最初のバッファは、画像取り込みに使用されます。取り込みが完了すると、ほかのバッファがロックされ、次の取り込みに使用されます。バッファされた画像はスプレッドシートに送信され、ジョブが実行されます。バッファは、ジョブが実行されるまでロックされたままです。一部の関数 (WriteImageFTP や WriteSMTP など) では、ジョブが実行された後もバッファがロックされたままになりますが、スプレッドシートでは、関数のバッファがロックされていても別のバッファされた画像を受け入れることができます。ジョブが実行中の場合、または (In-Sight Explorer または VisionView アプリケーションから) 表示するためのキューに画像が入っている場合、バッファされた画像がキューに入れられます。

注 :
  • での画像バッファの数の設定は、[画像バッファ] ダイアログ ファームウェアバージョン 4.6.0 以降が実行されているビジョンシステムでのみサポートされます。ビジョンシステムでファームウェアバージョン 4.5.0 以前が実行されている場合は、ネイティブモードの拡張コマンド SetSystemConfig() を使用して画像バッファの数を設定する必要があります。
  • [カメラトリガ] モードでは、トリガを受信しても画像取り込みにバッファを利用できなければ、画像取り込みは実行されません。また、ディスクリート出力ラインが　[エラー: 画像取り込みミス] を使用するように設定されている場合、この信号は、バッファが使用可能になるまで画像取り込みごとに発信されます。
  • ビジョンシステムが、利用可能な画像バッファの最大数を使用するように設定されていて、ビジョンシステムがオンラインのときにセンサフィルムストリップを使用するようにも設定されている場合、フィルムストリップをビジョンシステムに保存するために利用可能なメモリが十分にないことがあります。この場合は、画像バッファの数を最大値より少なくします。

の表示[画像バッファ] ダイアログ

  • [センサ] メニューで、[画像バッファ] をクリックします。

[画像バッファ] ダイアログの設定項目

スライダコントロールを使用して、起動時にビジョンシステムに割り当てる画像バッファの数を設定することができます。画像バッファのデフォルト数と最大数は、ビジョンシステムの解像度と RAM サイズによって異なります。変更を有効にするには、ビジョンシステムを再起動する必要があります。

注 :
  • ビジョンシステムの RAM サイズを調べるには、[In-Sight のネットワーク] ペイン内でビジョンシステムを右クリックして、[プロパティ] をクリックします。[プロパティ] ダイアログで、[メモリ] タブを選択します。
  • 画像バッファの数を増やすと、ジョブのロードや画像の取り込みなど、そのほかのタスクで使用できる RAM の量が減り、パフォーマンスが低下する場合があります。
  • [HMI の設定] ダイアログの [最大ビュー接続数] が 2 以上に設定されている場合は、追加の画像バッファが自動的に In-Sight ビジョンシステムに割り当てられます。例えば、[最大ビュー接続数] が 2 に設定され、[画像バッファ] が 3 に設定されている場合には、5 つの画像バッファがビジョンシステムに割り当てられます。画像バッファの合計数がビジョンシステムで利用可能な画像バッファの最大数を超える場合は、画像バッファの最大数がビジョンシステムに割り当てられます。

In-Sight ビジョンシステム

In-Sight モデル | 解像度 (ピクセル) | RAM | 画像バッファのデフォルト数 | 画像バッファの最大数
In-Sight Micro 1020、1050、1100、1110、1400、1410 | 640 × 480 | 128MB | 6 | 25
In-Sight Micro 1020、1050、1100、1110、1400、1410 | 640 × 480 | 256MB | 12 | 25
In-Sight Micro 1100C、1400C (128MB RAM) | 640 × 480 | 128MB | 3 | 6
In-Sight Micro 1100C、1400C | 640 × 480 | 256MB | 6 | 25
In-Sight Micro 1402、1412 | 1280 × 1024 | 256MB | 12 | 25
In-Sight Micro 1403、1413 | 1600 × 1200 | 128MB | 3 | 6
In-Sight Micro 1403、1413 | 1600 × 1200 | 256MB | 12 | 25
In-Sight Micro 1403C | 1600 × 1200 | 128MB | 3 | 6
In-Sight Micro 1403C | 1600 × 1200 | 256MB | 6 | 16
In-Sight Micro 1500 | 640 × 4801 | 256MB | 12 | 25
 | 800 × 6001 |  | 12 | 25
5100、5110、5400、5410 | 640 × 480 | 256MB | 12 | 25
5100C、5400C | 640 × 480 | 256MB | 6 | 25
5403、5413 | 1600 × 1200 | 256MB | 12 | 25
5600、5610 | 640 × 480 | 128MB | 6 | 25
5600、5610 | 640 × 480 | 256MB | 12 | 25
5603、5613 (128MB RAM) | 1600 × 1200 | 128MB | 3 | 6
5603、5613 | 1600 × 1200 | 256MB | 12 | 25
ラインスキャン 5604、5614 | 1024 × 2048 | 128MB | 6 | 6
 | 1024 × 8192 |  | 5 | 6
ラインスキャン 5604、5614 | 1024 × 2048 | 256MB | 6 | 25
 | 1024 × 8192 |  | 6 | 16
5605、5615 | 2448 × 2048 | 256MB | 6 | 16
5705、5715 | 2448 × 2048 | 512MB | 12 | 25
5705C | 2448 × 2048 | 512MB | 8 | 16
7010、7020、7050、7200、7210、7230、7400、7410、7430 | 800 × 600 | 256MB | 12 | 25
7010C、7200C、7400C | 800 × 600 | 256MB | 6 | 25
7402、7412、7432 | 1280 × 1024 | 256MB | 12 | 25
7402C | 1280 × 1024 | 256MB | 6 | 25
7600、7800、7900 | 800 × 6001 | 512MB | 12 | 25
 | 640 × 4801 |  | 12 | 25
7600C、7800C、7900C | 800 × 6001 | 512MB | 8 | 25
 | 640 × 4801 |  | 8 | 25
7801、7901 | 1280 × 1024 | 512MB | 12 | 25
7801C、7901C | 1280 × 1024 | 512MB | 8 | 25
7802、7902 | 1600 × 1200 | 512MB | 12 | 25
 | 800 × 600 (低照明モード)1 |  | 12 | 25
7802C、7902C | 1600 × 1200 | 512MB | 8 | 16
 | 800 × 600 (低照明モード)1 |  | 8 | 25
7905 | 2448 × 2048 | 512MB | 12 | 25
7905C | 2448 × 2048 | 512MB | 8 | 16
8200、8400 | 640 × 480 | 512MB | 12 | 25
8200C、8400C | 640 × 480 | 512MB | 6 | 25
8401 | 1280 × 1024 | 512MB | 12 | 25
8401C | 1280 × 1024 | 512MB | 6 | 25
8402 | 1600 × 1200 | 512MB | 12 | 25
8402C | 1600 × 1200 | 512MB | 6 | 25
8405 | 2592 × 1944 | 512MB | 6 | 25
1以下のビジョンシステム/センサの解像度は、[画像の設定] ダイアログで設定できます:In-Sight Micro 1500、In-Sight 2000-130、2000-130C、2000-230、2000-230C、2000-23M、2001-230、2001-230C、In-Sight 7500、7500C、7600、7600C、7800、7800C、7900、7900C、7802、7802C、7902、7902C。

In-Sight 2000 シリーズビジョンセンサ

In-Sight モデル | 解像度 (ピクセル) | RAM | 画像バッファのデフォルト数 | 画像バッファの最小数 | 画像バッファの最大数
2000-110 & 2000-120 | 640 × 480 | 128MB | 6 | 3 | 25
2000-1301 | 640 × 480 | 128MB | 6 | 3 | 25
 | 800 × 600 |  | 3 | 3 | 6
2000-120C | 640 × 480 | 128MB | 3 | 3 | 6
2000-130Ci1 | 640 × 480 | 128MB | 3 | 3 | 6
 | 800 × 600 |  | 3 | 3 | 6
2000-23M | 800 × 600 | 128MB | 3 | 3 | 6
1以下のビジョンシステム/センサの解像度は、[画像の設定] ダイアログで設定できます:In-Sight Micro 1500、In-Sight 2000-130、2000-130C、2000-230、2000-230C、2000-23M、2001-230、2001-230C、In-Sight 7500、7500C、7600、7600C、7800、7800C、7900、7900C、7802、7802C、7902、7902C。


[画像の設定] ダイアログ

[画像の設定] ダイアログでは、ライブ画像およびオンライン画像の解像度とフレームレート、および画像の取り込みで使用する解像度を設定します。

注 :
  • ライブ取り込みとオンライン画像の設定は、In-Sight Explorer ユーザインタフェースに送信される画像にのみ適用され、ビジョンシステムの画像取り込みには適用されません。
  • [解像度] オプションは、In-Sight Micro 1500、In-Sight 7600、In-Sight 7800、In-Sight 7802 ビジョンシステム、および In-Sight 2000-130 と In-Sight 2000-130C ビジョンセンサのみで使用できます。

[画像 の設定] ダイアログを表示するには

  • [センサ] メニューで、[画像の設定] をクリックします。

[画像の設定] ダイアログの設定項目

[ライブ取り込み] (ライブビデオ):

  • [解像度]: In-Sight Explorer ユーザインタフェースに表示されるライブ画像のフル、ハーフおよびクォーター解像度。
  • [ビット深度]: カラー画像を表示するビット深度を指定します ([16 ビット] または [24 ビット]。デフォルト = [16 ビット])。
注 : このオプションは、カラー In-Sight ビジョンシステムでのみ使用可能になります。

  • [最大レートを制限する]: このチェックボックスを ON にすると、[ライブ画像] の [最大レート] テキストボックスが有効になります。

    注 : このオプションは、In-Sight ファームウェア 4.x.x を搭載している In-Sight ビジョンシステムでのみ有効にできます。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは無効になります。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • [最大レート (フレーム/秒)]: ビジョンシステムが 1 秒間に送信可能な最大画像数を指定します (0.016 ～ 100)。この機能を使用すると、画像の送信数を制限することによってネットワークトラフィックを軽減することができます。

    注 : このオプションは、[最大レートを制限する] チェックボックスがオンの場合にのみ有効になります。

[オンライン] (オンラインモード)

  • [解像度]: In-Sight Explorer ユーザインタフェースに表示されるライブ画像の最適化、フル、ハーフおよびクォーター解像度。

    注 : In-Sight ファームウェア 4.x.x が実行されている In-Sight を使用する場合は、最適化により、手動トリガではフルサイズ画像が返され、カメラまたは連続トリガではハーフ解像度の画像が返されます。In-Sight 5.1.0 以降が実行されているビジョンシステムを使用する場合は、最適化により、速度を考慮して In-Sight Explorer に送信される画像の解像度が最適化されます。
  • [ビット深度]: カラー画像を表示するビット深度を指定します ([16 ビット] または [24 ビット]。デフォルト = [16 ビット])。
注 : このオプションは、カラー In-Sight ビジョンシステムでのみ使用可能になります。

  • [最大レートを制限する]: このチェックボックスを ON にすると、[オンライン] の [最大レート] テキストボックスが有効になります。

    注 : このオプションは、In-Sight ファームウェア 4.x.x を搭載している In-Sight ビジョンシステムでのみ有効にできます。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは無効になります。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • [最大レート (フレーム/秒)]: ビジョンシステムが 1 秒間に送信可能な最大画像数を指定します (0.016 ～ 100)。この機能を使用すると、画像の送信数を制限することによってネットワークトラフィックを軽減することができます。

    注 : このオプションは、[最大レートを制限する] チェックボックスがオンの場合にのみ有効になります。

[Acquisition (画像取り込み)]

  • [解像度]: 画像取り込みで使用する解像度を指定します。変更を有効にするには、ビジョンシステムを再起動する必要があります。[Acquisition (画像取り込み)] の [解像度] オプションは、以下のビジョンセンサとビジョンシステムでのみ指定できます。

    In-Sight モデル オプション デフォルト
    In-Sight Micro 1500

    800 × 600

    640 × 480

             640 × 480
    In-Sight 2000-130、2000-130C

    800 × 600

    640 × 480

             640 × 480
    In-Sight 2000-23M

    800 × 600

    640 × 480

             800 × 600
    In-Sight 7600、7600C、7800、7800C、7900、7900C

    800 × 600

    640 × 480

             800 × 600
    In-Sight 7802、7802C、7902、7902C

    1600 × 1200

    800 × 600 (低照明モード)

             1600 × 1200
    注 :
    • In-Sight 2000-130、2000-130C または 2000-23M ビジョンセンサで解像度 640 × 480 を使用する場合、[画像拡大モード] は、[画像の設定] アプリケーションステップで有効化および無効化することができます。In-Sight 2000-130、2000-130C または 2000-23M ビジョンセンサで解像度 800 × 600 を使用する場合、[画像拡大モード] は常に有効であり、無効にすることはできません。詳細については、EasyBuilder ヘルプをご参照ください。
    • In-Sight 7802、7802C、7902 および 7902C で 800 × 600 (低照明モード) を使用すると、低い解像度で照明感度を高めることができます。
    • サポートされる露光、取り込み開始行および行数は、選択した画像取り込み解像度に応じてさまざまです。

[フォーカス]

注 : このグループボックスは、In-Sight 2000 Mini シリーズのビジョンセンサへの接続時にのみ表示されます。
  • [ジョブロード時にフォーカスを上書き]: ビジョンセンサが、Easy Builder の [画像の設定] アプリケーションステップの [フォーカス] タブで設定した [フォーカス距離 (%)] 設定を優先するかどうかを指定します。デフォルトでは、このチェックボックスはオフ (無効) になっています。オンにすると、[設定] ボタンが有効になります。
  • [設定] ボタン: クリックすると、[現在のフォーカス距離 (%)] の値と一致するように [フォーカス距離の上書き (%)] の値が設定されます。
  • [現在のフォーカス距離 (%)]: ビジョンセンサのファームウェアに保存されている現在のフォーカス距離 (%) の値が表示されます。
  • [フォーカス距離の上書き (%)]: ジョブをロードするときに使用するフォーカス距離 (%) の値が表示されます。


[In-Sight ホストテーブル] ダイアログ

[In-Sight ホストテーブル] では、別々のネットワーク (サブネット) に存在する In-Sight ビジョンシステムが相互に通信できるように設定します。ホストテーブルのエントリによって、指定された IP アドレスのホストのネットワークの設定が実際に変更されることはありません。これらのエントリは、アクティブな In-Sight ビジョンシステムへの追加のビジョンシステムとして単に表示されます。

警告 : DHCP を使用して設定されるビジョンシステムの場合は、特定の IP アドレスが割り当てられることを保証することはできません。このホストテーブルでは、ビジョンシステムと通信するために固定 IP アドレスを必要とするため、Cognex では、異なるサブネット上のすべてのビジョンシステムを固定 IP アドレスを指定して設定するよう強くお勧めします。
注 :
  • ホストテーブルは、In-Sight エミュレータからターゲットシステムへの hosts.net ファイルの FTP アップロードを介して、ほかの In-Sight ビジョンシステムと共有可能です。アップロードされるファイルのそれぞれのラインのフォーマットは "xxx.xxx.xxx.xxx host_name" ("xxx.xxx.xxx.xxx" は任意の有効な IP アドレス) に従う必要があります。空白のライン、不完全なライン、および先頭が '#' 文字になっているラインは無視されます。また、ホスト名に続く文字もすべて無視されます。ファイルは FTP 経由でダウンロードすることも可能ですが、アップロードされるファイルの元のフォーマットは維持されません。
  • [ファームウェアアップデート] ダイアログでは、別のネットワーク上に存在するか、[In-Sight ホストテーブル] を使用して In-Sight Explorer に追加された In-Sight ビジョンシステムのファームウェアを更新することはできません。ただし、[エクスプローラリモートサブネットリスト] を使用して In-Sight Explorer に追加される、異なるネットワーク上に存在するビジョンシステムのファームウェアは更新可能です。Cognex では、ファームウェアの更新時にはビジョンシステムをローカルネットワークに配置して、ネットワーク障害を防止するようお勧めします。

[In-Sight ホストテーブル] ダイアログを表示するには

  • [センサ] メニューで、[ホストテーブル] をクリックします。

[In-Sight ホストテーブル] ダイアログの設定項目

  • [追加] ホストテーブルに新規エントリを作成します。[追加] をクリックすると、[Add Host (ホストの追加)] ダイアログが表示されます。このダイアログで、新規ホストのホスト名と IP アドレスを入力します。

    注 :
    • ホスト名に使用できる文字は、A ～ Z (大文字および小文字)、0 ～ 9、ハイフン (-)、コロン (:)、カンマ (.)、およびアンダースコア (_) です。
    • ホスト名は最大 63 文字です。

  • [編集]: 既存のホストテーブルのエントリを変更します。リストからエントリを選択して [編集] をクリックします。[Edit Host (ホストの編集)] 閉じた ダイアログが表示されます。このダイアログで、選択したホストのホスト名や IP アドレスを変更できます。

  • [削除]: ホストテーブルからホストを削除します。削除するホストを選択し、[削除] をクリックします。

    ヒント : 複数のホストを削除するには、CTRL キーを押しながらホスト名を選択します。
  • [ホストテーブルを DNS より優先する]: オンにすると、In-Sight ホスト名のサーチ順序が、(1) ホストテーブル、(2) ネットワークブラウザ、(3) DNS に指定されます。オフにすると、ホスト名のサーチ順序は、(1) ネットワークブラウザ、(2) DNS、(3) ホストテーブルとなります。

ホストのパラメータ

  • [ホスト名]: 指定した IP アドレスにマップする (割り当てる)、ネットワーク接続された In-Sight ビジョンシステムの名前。ホストテーブル内で指定されているホスト名は、アクティブな In-Sight ビジョンシステムからのみアクセス可能です。
  • [IP アドレス]: 指定したホスト名にマップする、ネットワーク接続された In-Sight ビジョンシステムの IP アドレス。


[I/O モジュールの設定] ダイアログ

[I/O モジュールの設定] ダイアログでは、In-Sight Explorer 内で使用する I/O モジュールの設定を行います。

  • [I/O モジュールの設定] ダイアログにアクセスする
  • CIO-1400、CIO-1450、または CIO-1460 を設定する
  • CIO-MICRO または CIO-MICRO-CC を設定する
  • CIO-WENET を設定する

[I/O モジュールの設定] ダイアログにアクセスする

EasyBuilder ビュー

  • [アプリケーションステップ] ペインから、以下の操作を実行します。
    • [入力] または [出力] アプリケーションステップをクリックします。または、
    • [通信] アプリケーションステップをクリックし、シリアルデバイスを追加して、[シリアルポートの設定] タブをクリックします。
  • [I/O モジュール] ボタンをクリックします。

スプレッドシートビュー

  • [センサ] メニューから、以下の操作を実行します。
    • [シリアルポートの設定] を選択します。または
    • [ディスクリート I/O の設定] を選択します
  • [I/O モジュール] ボタンをクリックします。

CIO-1400、CIO-1450、または CIO-1460 を設定する

  1. In-Sight Explorer から、サポートしているビジョンシステムに接続します。
  2. [I/O モジュールの設定] ダイアログを開きます。
  3. [I/O モジュールの選択] ドロップダウンリストから、[CIO-1400]、[CIO-1450]、または [CIO-1460] を選択します。

  4. [OK] をクリックしてダイアログを閉じます。

CIO-MICRO または CIO-MICRO-CC を設定する

  1. In-Sight Explorer から、サポートしているビジョンシステムに接続します。
  2. [I/O モジュールの設定] ダイアログを開きます。

  3. [I/O モジュールの選択] ドロップダウンリストから、[CIO-MICRO] または [CIO-MICRO-CC] を選択します。

  4. [接続先] ドロップダウンリストから適切な I/O モジュールを選択します。

    注 : I/O モジュールのホスト名がリストに表示されない場合は、<IP アドレスによって接続> を選択して、I/O モジュールの IP アドレスを手動で入力します。

  5. [更新間隔] フィールドで、ビジョンシステムと CIO-MICRO または CIO-MICRO-CC I/O モジュールとの間で入出力を同期するために必要な時間間隔 (3 ～ 500 ミリ秒、デフォルト = 20 ミリ秒) を指定します。

    注 :
    • 出力信号の大幅な遅延が問題になる場合は、更新間隔を短くします。ただし、更新間隔はアプリケーションで必要とされる以上に短くしないでください。更新間隔が短くなると、ジョブの実行にかかる時間が長くなることがあります。
    • CIO-MICRO または CIO-MICRO-CC I/O モジュールを設定する場合、指定する [更新間隔] は、予期される最短の入力または出力信号の時間の半分以下にし、信号が正しく送受信されるようにする必要があります。例えば、予期される最短の I/O 信号が 100 ミリ秒の場合、[更新間隔] は 50 ミリ秒以下にします。
  6. 必要に応じて、[設定の変更] ボタンをクリックして、I/O モジュールのネットワーク設定を行います。

    • デフォルトでは、In-Sight CIO-MICRO および CIO-MICRO-CC I/O モジュールは、DHCP サーバによって起動時に動的に設定されます。新しいホスト名を割り当てることもできますが、ダイアログ内のそのほかのフィールドはすべて無効です。

      注 : DHCP サーバが使用できない場合は、I/O モジュールはタイムアウトし、リンクローカル IP アドレスに接続します。

    • CIO-MICRO および CIO-MICRO-CC には、固定 IP アドレスも使用することができます。[DHCP サーバの使用] チェックボックスをオフにして、[IP アドレス]、[サブネットマスク]、[デフォルトゲートウェイ]、[DNS サーバ] および [ドメイン名] フィールドに適切なネットワーク設定を指定します。

  7. [OK] をクリックしてダイアログを閉じます。

CIO-WENET を設定する

注 : In-Sight Explorer で CIO-WENET Ethernet I/O モジュールを設定するには、最初に、モジュールに IP アドレスを割り当てる必要があります。
  1. In-Sight Explorer から、サポートしているビジョンシステムに接続します。
  2. [I/O モジュールの設定] ダイアログを開きます。

  3. [I/O モジュールの選択] ドロップダウンリストから、[CIO-WENET] を選択します。

  4. [IP アドレス] フィールドには、CIO-WENET に事前に割り当てた IP アドレスを指定します。

  5. [更新間隔] フィールドで、In-Sight Micro 1000 シリーズのビジョンシステムと CIO-WENET I/O モジュール間の入出力を同期させるのに必要な時間間隔を指定します (1　～ 500 ミリ秒。デフォルト = 20 ミリ秒)。

    注 :
    • 出力信号の大幅な遅延が問題になる場合は、更新間隔を短くします。ただし、更新間隔はアプリケーションで必要とされる以上に短くしないでください。更新間隔が短くなると、ジョブの実行にかかる時間が長くなることがあります。
    • CIO-WENET では、同期させるのに必要な時間は、[更新時間] より 3ms 長くなります。
  6. [OK] をクリックしてダイアログを閉じます。


[ジョブの PASS/FAIL セルの設定] ダイアログ

[ジョブの PASS/FAIL セルの設定] ダイアログでは、数値の結果を含むセルをモニタし、ジョブ全体の成功/失敗ステータスを判定できます。ジョブのステータスは、センサからの出力として、Cognex VisionView などそのほかのアプリケーションへ送信することができます。

注 :
  • [ジョブの PASS/FAIL セルの設定] ダイアログを使用できるのは、admin レベルのユーザだけです。

  • In-Sight で類似の効果を持つ監視セルが 3 つあります ([ジョブの PASS/FAIL] セル、[フィルムストリップ] 監視セル および [記録/再生] の監視セル)。これらの 3 つの監視セルを個々に設定し、異なる機能を制御することができます。

  • デフォルトでは、EasyBuilder ビューに表示されるすべての EasyBuilder ジョブが、同じジョブの PASS/FAIL セルを参照します。このセル参照が [ジョブの PASS/FAIL セルの設定] ダイアログで変更された場合でも、EasyBuilder ビューでジョブが再表示されると、参照先はデフォルトのセルに戻ります。

ジョブの PASS/FAIL セルを設定するには

  1. [ジョブの PASS/FAIL セルの設定] ダイアログを表示するには、[センサ] メニューの [ジョブの PASS/FAIL] をクリックします (または、セルを右クリックし、[ジョブの PASS/FAIL] をクリックします)。

  2. [ジョブの PASS/FAIL セルを使用する] チェックボックスをオンにし、ダイアログ内のほかのコントロールにアクセスできるようにします。

  3. [セルの選択] をクリックし、[ジョブの PASS/FAIL セルの設定] ダイアログをセル選択モードに切り替えます。
  4. スプレッドシート内の対象のセルを選択し、Enter キーを押してセルの選択を確定します。[ジョブの PASS/FAIL セルの設定] ダイアログが再表示され、[ジョブの PASS/FAIL セル] フィールドに選択したセル参照が示されます (セルをダブルクリックするか、または [ジョブの編集] ツールバーの [OK] [image] ボタンをクリックすることでもセルの選択を確定できます)。
  5. [ジョブのステータス] ドロップダウンリストで、ジョブの成功/失敗の数値結果をジョブの成功/失敗ステータスにマップする方法を定義します。ステータスのオプションには、[なし]、[PASS]、[FAIL]、または [警告] があります。
    • [セル値 < 0]: 選択したセルに、ゼロより小さい数値が含まれています。(デフォルト = FAIL)
    • [セル値 = 0]: 選択したセルに、数値ゼロが含まれています。(デフォルト = FAIL)

    • [セル値 > 0]: 選択したセルに、ゼロより大きい数値が含まれています。(デフォルト = PASS)

      注 :
      • セルに、#ERR 以外の数値ではない結果が含まれている (例: 文字列): PASS
      • セルが空である: なし
      • セルに #ERR が含まれている: FAIL
      • セルが選択されていない: なし

  6. [OK] をクリックします。


[ジョブサーバの設定] ダイアログ

[ジョブサーバの設定] ダイアログを使用して、In-Sight ビジョンシステムの In-Sight ジョブファイルをホストする FTP サーバを設定します。これにより、PLC やロボットコントローラなどの別のデバイスでは、LF および TF ネイティブモードコマンドを介し、場所を指定することなくジョブを変更することができます。

注 :
  • [ジョブサーバの設定] ダイアログは FileZilla FTP サーバソフトウェアでテストされています。
  • 古いバージョンの In-Sight Explorer (In-Sight Explorer 4.9.1 以前) からリモートジョブサーバを使用するように設定されているビジョンシステムに接続する場合、デフォルトでは、In-Sight Explorer がそのビジョンシステムのファイルシステムに設定されます。VisionView オペレータインタフェースパネル経由で接続する場合にも、同様に設定されます。
  • ジョブサーバは、In-Sight 2000 シリーズビジョンセンサではサポートされていません。
  • ジョブサーバに保存されているジョブの場合、ジョブのネイティブモードコマンド (Set Job、Get Job、Delete Job、Store Job、Write Job) は使用できません。

[ジョブサーバの設定] ダイアログを表示するには

  • [センサ] メニューで、[ジョブサーバの設定] をクリックします。

ジョブサーバの使用

ジョブサーバの設定

  1. [ジョブサーバの設定] ダイアログで、[Enable Job Server (ジョブサーバの有効化)] チェックボックスをオンにして、[サーバ]、[サーバポート]、[ユーザ名]、[パスワード]、[ディレクトリ] の各フィールドを有効にします。

  2. FTP サーバの [サーバ]、[サーバポート]、[ユーザ名]、[パスワード] を入力します。必要に応じて、ジョブを保存またはロードする場合の FTP サーバにおけるディレクトリ名 (または、ディレクトリパス) を入力します。

    注 :
    • ユーザには、FTP サーバへの書き込み/読み取り許可が必要です。
    • In-Sight エミュレータがサーバとして指定されている場合:
      • ジョブは Emulator ディレクトリ (C:\ProgramData\Cognex\Emulators\x.x.x) との間で保存またはロードされます。詳細については、[オプション] ダイアログトピック ([エミュレーション] パネル) を参照してください。
      • [ディレクトリ] フィールドはサポートされません。
    • [ユーザ名] は最大 63 文字で、大文字と小文字の区別があります。
    • [パスワード] は最大 127 文字で、大文字と小文字の区別があります。
    • FTP パス全体 (ftp://Username:Password@Server:PortNumber/Directory) は最大 208 文字です。
  3. [OK] をクリックします。In-Sight ビジョンシステムは、ジョブのロードと保存のためにジョブサーバに接続されます。
注 :
  • ジョブサーバを使用したジョブの手動保存またはロードの詳細については、「[保存] および [開く] ダイアログ」のトピックを参照してください。
  • 起動時にジョブサーバからジョブを自動的にロードする方法の詳細については、「[スタートアップ] ダイアログ」のトピックを参照してください。

ジョブサーバの無効化

  1. [ジョブサーバの設定] ダイアログで、[Enable Job Server (ジョブサーバの有効化)] チェックボックスをオフにし、[サーバ]、[サーバポート]、[ユーザ名]、[パスワード]、[ディレクトリ] の各フィールドを無効にします。
  2. [OK] をクリックします。これで、In-Sight ビジョンシステムがジョブサーバから切断されます。

ネイティブモードコマンドによるジョブの保存またはロード

ジョブサーバが有効になると、In-Sight ビジョンシステムでは、ジョブを保存またはロードする場合、TF または LF ネイティブモードコマンドが発行されると自動的にそのジョブサーバを使用します。例えば、ジョブサーバを有効にした後に LFProduct.job が発行されると、ジョブサーバに保存されている LFProduct.job ファイルがビジョンシステムにロードされます。

注 : TF または LF のネイティブモードコマンドの詳細については、「Store File」および「Load File」のトピックを参照してください。


ジョブサイズ制限

ジョブサイズ

[ジョブサイズ制限] ダイアログを使用して、EasyBuilder 開発環境で使用するために特定の In-Sight ビジョンシステムで利用することができるジョブサイズのメモリ割り当てを設定します。

注 : ジョブサイズは、ジョブが開発された開発環境によって異なります。EasyBuilder 開発環境で開発されたジョブの場合、3 つの列で使用可能で残されている行の数として領域が計算されます。スプレッドシート開発環境で開発されたジョブの場合、割り当てられたジョブ領域内のまだ使用可能な未使用のセルの数に基づいて領域が計算され、[アクティブセル制限] ダイアログを使用してセルの数を設定します。

[ジョブサイズ制限] ダイアログを表示するには

[センサ] メニューで [ジョブサイズ制限] を選択します。

注 :

[ジョブサイズ] メニューオプションは、以下の場合に無効となります。

  • In-Sight ビジョンシステムがオンラインの場合、または画像を再生している場合。
  • In-Sight ビジョンシステムがライブビデオになっている場合。
  • ユーザが [位置決め] または [検査]アプリケーションステップを実行中の場合。
  • ユーザに十分な管理権限がない場合。
  • In-Sight ビジョンシステムが、ジョブサイズの調整をサポートしていない場合。

ジョブにツールを追加しているときに、ジョブメモリについてのエラーメッセージ (「ジョブにこのツールを実行するための十分なメモリがありません。」) が表示された場合に、[ジョブサイズの調整] ボタンを押して、このダイアログにアクセスすることも可能です。

ジョブサイズ制限ダイアログの設定項目

スライダコントロールを使用して、In-Sight ビジョンシステムのメモリ割り当てを設定することができます。スライダを調整して、ジョブのメモリサイズの割り当てを設定します。In-Sight ビジョンシステムのジョブサイズ制限を調整するには、ビジョンシステムを再起動する必要があります。再起動を行うと、すべてのジョブと設定ファイルが不揮発性フラッシュメモリから消去されます。続行する前に、ジョブを保存するかバックアップしてください。

注 :
  • ジョブサイズ制限の更新中は、ビジョンシステムの電源を入れ直さないでください。
  • 最小パーセンテージおよび最大パーセンテージは、In-Sight ビジョンシステムのタイプによって異なります。


照明の設定

[照明の設定] ダイアログを使用して、In-Sight 7000 シリーズのビジョンシステムに接続されている照明デバイスを設定します。このダイアログの外観は、ビジョンシステムのタイプおよびビジョンシステムに接続されている照明デバイスのタイプに応じて異なります。

照明の設定ダイアログを表示するには

  • [センサ] メニューで、[照明の設定] をクリックします。

In-Sight 70xx ～ 74xx シリーズ

In-Sight 70xx ～ 74xx シリーズのビジョンシステムでは、照明ケーブルを使用して外部のストロボデバイスまたは連続照明デバイスをビジョンシステムの LIGHT コネクタに接続することができます。接続が検出された場合、[照明の設定] ダイアログを使用して、In-Sight 70xx ～ 74xx シリーズのビジョンシステムに接続されている外部ストロボまたは連続照明デバイスのタイプを指定できます。

注 : 内部 LED リング照明を使用する In-Sight 70xx ～ 74xx シリーズのビジョンシステムの場合は、照明制御の設定を使用して内部 LED リング照明を設定します。

設定

  • [極性]:ビジョンシステムに接続されているストロボデバイスまたは連続照明デバイスのタイプを指定します。
    • [無効]:ビジョンシステムが照明デバイスに接続されていません。
    • [PNP (ソース)]:ビジョンシステムが PNP (現在のソース) 照明デバイスに接続されています。
    • [NPN (シンク)]:ビジョンシステムが NPN (現在のシンク) 照明デバイスに接続されています。

In-Sight 76xx ～ 79xx シリーズ

In-Sight 76xx ～ 79xx シリーズのビジョンシステムでは、ビジョンシステムのフェースプレートへの組み込み照明アクセサリの接続、およびビジョンシステムの LIGHT コネクタへの外部照明の接続がサポートされますが、両方の照明器具を同時に使用することはできません。サポート対象アクセサリの完全な一覧については、『In-Sight® 7000 Gen2 Series Vision System Reference Guide』を参照してください。

  • ビジョンシステムのフェースプレートに組み込み照明アクセサリが取り付けられている場合は、[照明の設定] ダイアログを使用して LED リング照明の照明設定を指定できます。
  • ビジョンシステムの LIGHT コネクタに外部照明が接続されている場合は、[照明の設定] ダイアログを使用して外部ストロボまたは連続照明デバイスの照明設定を指定できます。
注 : IntegratedLightControl または ExternalLightControl 関数がスプレッドシートに挿入されている場合は、[照明の設定] ダイアログで設定の変更を試みると、ダイアログで指定した設定がスプレッドシート関数によって上書きされます。

組み込み: In-Sight 照明

In-Sight 照明アクセサリには、4 つの LED バンクに分かれた 8 のLED が含まれています。

設定

  • [輝度]:照明アクセサリ LED バンクの実効輝度をパーセンテージとして指定します。 すべての LED バンクで共通の輝度値が共有され、輝度は 50% ～ 100% に制限されています。これは、すべての LED バンクで輝度が均等に分散されるようにするためです。(50% ～ 100%、デフォルト = 100%)

  • [露光時間]:画像取得の際に使用する、固定された露光値を指定します。

    In-Sight モデル

             解像度 露光時間 (ミリ秒)
    In-Sight 7600、7600C、7800、7800C、7900、7900C | 800 × 6001 | 0.014 ～ 550 (デフォルト = 1.000)
    In-Sight 7600、7600C、7800、7800C、7900、7900C | 640 × 4801 | 0.014 ～ 520 (デフォルト = 1.000)
    In-Sight 7801、7801C、7901、7901C | 1280 × 1024 | 0.017 ～ 750 (デフォルト = 1.000)
    In-Sight 7802、7802C、7902、7902C | 1600 × 1200 | 0.020 ～ 940 (デフォルト = 1.000)
    In-Sight 7802、7802C、7902、7902C | 800 × 600 (低照明モード)1 | 0.020 ～ 940 (デフォルト = 1.000)
    In-Sight 7905、7905C | 2448 × 2048 | 0.021 ～ 1000 (デフォルト = 1.000)

    1以下のビジョンシステム/センサの解像度は、[画像の設定] ダイアログで設定できます:In-Sight Micro 1500、In-Sight 2000-130、2000-130C、2000-230、2000-230C、2000-23M、2001-230、2001-230C、In-Sight 7500、7500C、7600、7600C、7800、7800C、7900、7900C、7802、7802C、7902、7902C。

    注 :

    • この In-Sight 照明アクセサリには、明度、LED リングライト色、ビジョンシステムの解像度、取り込まれた行数によって左右される最大ストロボパルス幅があります。照明アクセサリは特定の露光時間の間、点灯します。露光時間が最大ストロボパルス幅を超過した場合、LED リングライトは最大ストロボパルス幅の間だけ点灯します。次に例を示します。

      LED リングライト色 | 明度 | 最大ストロボパルス幅 (ミリ秒)

      In-Sight 7600/7800/7900

      800×6001

      In-Sight 7600/7800/7900

      640×4801

      In-Sight 7801/7901

      1280×1024

      In-Sight 7802/7902

      1600×12001

      In-Sight 7802/7902

      800×600 (低照明モード)1

      In-Sight 7905

      2448×2048
      白 100% 0.314 0.232 0.704 1.022 1.022

      1.599
      50% 0.779 0.574 1.744 2.531 2.531

      3.961
      赤 100% 0.375 0.277 0.841 1.220 1.220

      1.847
      50% 1.083 0.799 2.426 3.519 3.519

      5.508
      赤外線 | 100% | 0.351 | 0.259 | 0.786 | 1.140 | 1.140 | 1.785
      50% | 0.857 | 0.632 | 1.921 | 2.787 | 2.787 | 4.361
      青 | 100% | 0.314 | 0.232 | 0.704 | 1.022 | 1.022 | 1.599
      50% | 0.765 | 0.564 | 1.713 | 2.485 | 2.485 | 3.889
      LED リングライト色 | 明度 | 最大ストロボパルス幅 (ミリ秒)

      In-Sight 7600C/7800C/7900C

      800×6001

      In-Sight 7600C/7800C/7900C

      640×4801

      In-Sight 7801C/7901C

      1280×1024

      In-Sight 7802C/7902C

      1600×12001

      In-Sight 7802C/7902C

      800×600 (低照明モード)1

      In-Sight 7905C

      2448×2048
      白 100% 0.314 0.232 0.704 1.022 1.022

      1.599
      50% 0.779 0.574 1.744 2.531 2.531

      3.961

      1以下のビジョンシステム/センサの解像度は、[画像の設定] ダイアログで設定できます:In-Sight Micro 1500、In-Sight 2000-130、2000-130C、2000-230、2000-230C、2000-23M、2001-230、2001-230C、In-Sight 7500、7500C、7600、7600C、7800、7800C、7900、7900C、7802、7802C、7902、7902C。

    • 露光時間が最大ストロボパルス幅を超える場合、LED の効率性が低電流で増すため、輝度が低くなって画像がより明るくなることがあります。
  • [常に ON]:複数の取り込みの間に一貫した光レベルを提供するため、選択された LED バンクは常にオンになります。

  • [ライブビデオ]:照明設定を調整するときに使うライブ画像を表示するために、ビジョンシステムをライブビデオモードにします。[ライブビデオ] ボタンをもう一度クリックすると、ライブビデオモードが終了します。

    ヒント : ビジョンシステムにオートフォーカスアクセサリが取り付けられている場合、レンズのフォーカス位置はライブビデオモードのときに調整可能です。

組み込み: DataMan 標準照明

注 : DataMan 標準照明アクセサリと高出力照明アクセサリは、In-Sight 7905 または 7905C ではサポートされません。

DataMan 標準照明アクセサリには、8 つの LED バンクに分かれた 36 のLED が含まれています。

設定

  • [輝度]:照明アクセサリ LED バンクの実効輝度をパーセンテージとして指定します。 すべての LED バンクが共通の輝度値を共有します。(0% ～ 100%、デフォルト = 100%)
  • [露光時間]:画像取得の際に使用する、固定された露光値を指定します。(0 ミリ秒～ 1000 ミリ秒、デフォルト = 8 ミリ秒)
  • [ライブビデオ]:照明設定を調整するときに使うライブ画像を表示するために、ビジョンシステムをライブビデオモードにします。[ライブビデオ] ボタンをもう一度クリックすると、ライブビデオモードが終了します。

組み込み: DataMan 高出力照明

注 : DataMan 標準照明アクセサリと高出力照明アクセサリは、In-Sight 7905 または 7905C ではサポートされません。

DataMan 高出力照明アクセサリには 8 つの LED が含まれており、これらはすべて自身の LED バンクとして個別にアドレス指定が可能です。

設定

  • [輝度]:LED バンクには輝度の制御がなく、オンまたはオフのいずれかになっています。輝度は 100% に固定されています。
  • [露光時間]:画像取得の際に使用する、固定された露光値を指定します。(0 ミリ秒～ 1000 ミリ秒、デフォルト = 8 ミリ秒)
  • [ライブビデオ]:照明設定を調整するときに使うライブ画像を表示するために、ビジョンシステムをライブビデオモードにします。[ライブビデオ] ボタンをもう一度クリックすると、ライブビデオモードが終了します。

外部

設定

  • [極性]:ビジョンシステムに接続されているストロボデバイスまたは連続照明デバイスのタイプを指定します。
    • [無効]:ビジョンシステムが照明デバイスに接続されていません。
    • [PNP (ソース)]:ビジョンシステムが PNP (現在のソース) 照明デバイスに接続されています。
    • [NPN (シンク)]:ビジョンシステムが NPN (現在のシンク) 照明デバイスに接続されています。
  • [輝度]:接続されたストロボデバイスの有効な照明輝度をパーセンテージで指定します。(0 ～ 100、デフォルト = 100)
  • [ストロボ開始位置]:ストロボ出力を開始する位置を指定します。
    • [画像取り込み開始]:ビジョンシステムが画像取り込みを開始するときにストロボ出力を開始するよう指定します。
    • [カメラトリガ]:カメラトリガイベントを受信したときにストロボ出力を開始するよう指定します。


[ログオン/ログオフ] ダイアログ

[ログオン/ログオフ] ダイアログでは、個々の In-Sight ビジョンシステムへのログオンに使用するユーザ名とパスワードを設定します。

このダイアログを使用して、すべてのビジョンシステムからログオフすることもできます。デフォルトでは、In-Sight Explorer は、admin というユーザ名と空白パスワードを使用してビジョンシステムにログオンします。[オプション] ダイアログで定義されたスタートアップユーザ名およびパスワードが、[ユーザアクセス設定] ダイアログで定義されたユーザ名およびパスワードと一致しない場合に In-Sight Explorer を起動すると、[ログオン/ログオフ] ダイアログが表示されます。

In-Sight Explorer は、ジョブの編集および表示機能に加えて、バックアップ、リストア、レポート作成、ファイル管理などの管理サービスも提供します。これらの管理サービスを使用するには、FTP やネイティブモードプロトコルを使用して In-Sight ビジョンシステムに接続する必要があります。これらの機能は常に利用可能なものとして表示されますが、操作の開始時にビジョンシステムごとにユーザ認証が確認され、現在のユーザ名に基づき、現在のユーザの各ビジョンシステムにおけるアクセスレベルに応じて、これらの機能の実行が許可または拒否されます。

In-Sight ビジョンシステムへのログオン

  1. [システム] メニューで、[ログオン/ログオフ] をクリックします。

  2. ユーザ名とパスワードを入力します。
  3. 入力したユーザ名とパスワードを、次回ログオンするときのために記憶させる場合は、[パスワード保存] チェックボックスをオンにします。デフォルトでは、このオプションはオフになっているため、システムにログオンするたびにパスワードを入力する必要があります。

  4. [ログオン] ボタンをクリックして完了します。前の手順で入力したユーザ名とパスワードを使用して、個々の In-Sight ビジョンシステムにログオンします ([In-Sight ネットワーク] ペインのビジョンシステム名をダブルクリックするとログオンできます)。

    注 : ビジョンシステムにログオンしてユーザ名またはパスワードを変更すると、新しいユーザ情報を認証できないビジョンシステムとの接続が切断される場合があります。

ログオンが完了すると、ログオンを開始した In-Sight ビジョンシステムでのユーザのアクセスレベルにかかわらず、アクセス先のシステムのユーザリストでユーザ名に対して指定されたアクセスレベルが有効になります。


[ネットワークの設定] ダイアログ

[ネットワークの設定] ダイアログでは、TCP/IP ネットワークで通信できるようにアクティブな In-Sight ビジョンシステムを設定します。

注 :
  • ネットワーク設定を変更した後は In-Sight ビジョンシステムを再起動してください。In-Sight Explorer の [ネットワークの設定] ダイアログで新しい設定値が表示されていても、再起動するまではビジョンシステムの内部状態は更新されません。
  • In-Sight エミュレータは、Windows のネットワーク設定を使用します。この設定を、In-Sight Explorer で変更することはできません。エミュレータのネットワーク設定を変更するには、Windows のコントロールパネルでネットワーク設定を開き、必要な変更を加えます。
  • In-Sight は、IPv4 Organization Local Scope (239.192.0.0/14) から EtherNet/IP マルチキャストアドレスを自動的に割り当てます。

[ネットワークの設定] ダイアログの表示

  • [センサ] メニューで、[ネットワークの設定] をクリックします。

[ネットワークの設定] ダイアログの設定項目

  • [ホスト名]: [In-Sight ネットワーク] に表示される In-Sight ビジョンシステムの名前を定義します。ローカルシステムがネットワークに接続され、In-Sight エミュレータを動作させている PC の場合、ホスト名には、Windows オペレーティングシステムで定義されている PC 名が自動的に使用されます。

    各 In-Sight ビジョンシステムには、初めて起動したときにホスト名が自動的に設定されます。この名前は、「In-Sight」を表す「is」で始まり、その後にモデル番号とアンダースコアが続き、ビジョンシステムの一意の MAC アドレスの最後の 6 文字で終わります。例えば、MAC アドレス 00-d0-24-01-02-03 を持つ In-Sight 5100 ビジョンシステムのホスト名は「is5100_010203」です。また、MAC アドレス 00-d0-24-57-09-31 を持つ In-Sight 5400C ビジョンシステムのホスト名は「is5400C_570931」になります。

    ホスト名は、このフィールドに新しい名前を入力することによって変更できます。

    注 :
    • ホスト名に使用できる文字は、A ～ Z (大文字および小文字)、0 ～ 9、ハイフン (-)、コロン (:)、ピリオド (.)、およびアンダースコア (_) です。
    • ホスト名は最大 63 文字です。

    DHCP サーバ

  • [DHCP サーバの使用]: アクティブな In-Sight ビジョンシステムの起動時に DHCP サーバによって動的にネットワークの設定が行われるようにします。
    • [IP アドレス]: ローカルネットワークの IP アドレス割り当てルールに従って、ネットワーク上の各 In-Sight ビジョンシステムに一意なアドレスが割り当てられます。
    • [サブネットマスク]: IP アドレスのどの部分がネットワークを示し、どの部分がホストを示すかを定義します。IP アドレスのネットワーク部分は同じサブネットのすべてのホストにおいて共通しており、残りは各ホスト固有です。
    • [デフォルトゲートウェイ]: ネットワーク上に利用できるゲートウェイホストがある場合、その IP アドレスを指定します。ゲートウェイホストは、別々のネットワーク上のホスト間でデータのリレーを行います。
    • [DNS サーバ]: ネットワーク上に、DNS 解決を提供するホストがあれば、その IP アドレスを指定します。

    • [ドメイン名]: ホストネットワークのネットワークドメインを指定します。

      注 : ドメイン名は最大 63 文字です。

    • [DHCP タイムアウト]: In-Sight ビジョンシステムが DHCP 用に設定されているときに、DHCP サーバが有効な IP アドレスで応答するのをビジョンシステムが待つ時間 (5 ～ 180 秒、デフォルト = 60) を指定します。DHCP サーバからの応答待ち時間がタイムアウトすると、ネットワーク通信は中断されます。ビジョンシステムは電源を入れ直すまでネットワークへの再接続を試みません。

      ヒント: In-Sight ビジョンシステムをネットワークに接続する予定がない場合は、最小時間の 5 秒を指定すると、ビジョンシステムの起動時間を短縮できます。このとき、ビジョンシステムは DHCP 用に設定する必要があります。

リンク

  • [リンクスピード]: ビジョンシステムとネットワークデバイスの間のイーサネットの速度とデュープレックスモードを指定します。

    警告 : 指定のリンク速度をサポートするようにネットワークデバイスが設定されていない場合、ビジョンシステムにアクセスすることはできません。ビジョンシステムのイーサネット設定に合わせてネットワークデバイスのイーサネット設定を行ってください。
    • [オートネゴシエーション] (デフォルト): ビジョンシステムとネットワークデバイスは、両方の出デバイスでサポートされる最速のイーサネット速度とデュープレックスモードを選択するために通信します。
    • [10 Mbps 半二重]: イーサネット速度が 10 メガビット/秒に固定され、データは指定された時刻にのみ送受信可能です。
    • [10 Mbps 全二重]: イーサネット速度が 10 メガビット/秒に固定され、データは任意の時刻に送受信可能です。
    • [100 Mbps 半二重]: イーサネット速度が 100 メガビット/秒に固定され、データは指定された時刻にのみ送受信可能です。
    • [100 Mbps 全二重]]: イーサネット速度が 100 メガビット/秒に固定され、データは任意の時刻に送受信可能です。

    • [1000 Mbps 全二重]: イーサネット速度が 1000 メガビット/秒に固定され、データは任意の時刻に送受信可能です。

      注 : :[1000 Mbps 全二重] オプションは、1000 Mbps イーサネット速度をサポートするビジョンシステムだけで使用できます。In-Sight 5600 シリーズのビジョンシステムの場合、128MB 以上の不揮発性フラッシュメモリを搭載したモデルだけで使用できます。
  • [現在のスピード]: ビジョンシステムの現在のイーサネットリンク速度とデュープレックスモード (全二重または半二重) を表示します。

Telnet

ビジョンシステムの Telnet 設定を指定します。

  • [Telnet ポート番号]: アクティブな In-Sight ビジョンシステム (通信を待っている TCP/IP サーバ) がリモートデバイス (通信を開始する TCP/IP クライアント) からの要求を受け入れる Telnet ポートを割り当てます。 有効なポート割り当ては、In-Sight 通信のために予約されているポートを除いて、1 ～ 65535 の未使用の任意の番号です。

産業用イーサネットプロトコル

In-Sight ビジョンシステム上で、特定のイーサネットプロトコルを有効または無効にします。産業用イーサネットプロトコルを使用している場合、[ロボット] ドロップダウンは [なし] に設定してください。

注 :
  • EasyBuilder を使用している場合、[通信] アプリケーションステップで [産業用イーサネット] デバイスを追加し、設定する必要があります。そうでない場合、フォーマット出力バッファが設定されず、結果データを取得することができません。詳細については、EasyBuilder ヘルプをご参照ください ([通信] > [デバイスの設定])。
  • スプレッドシートを使用している場合、このダイアログを使用して産業用イーサネットプロトコルを設定してください。PROFINET、SLMP スキャナ、POWERLINK または Modbus TCP サーバを選択した場合、[設定] ボタンを使用して設定する必要があります。
  • PROFINET、SLMP スキャナ、POWERLINK および Modbus TCP サーバは相互排他的です。よって、一度に複数のプロトコルを選択することはできません。

  • [EtherNet/IP]: ビジョンシステムの EtherNet/IP サービスを有効にします。選択すると、このオプションの右側にある [設定] ボタンが有効になります。このボタンによって [EtherNet/IP の設定] ダイアログを起動し、[ユーザデータバイパスの有効化] を設定します。[ユーザデータバイパスの有効化] チェックボックスをオンにしてキャッシュデータをバイパスし、未処理のユーザデータを直接読み取ります。デフォルトでは、この設定はオフになっています。

    注 : EtherNet/IP オプションの横の [設定] ボタンは、In-Sight ファームウェア 5.4.0 以降が実行されている In-Sight ビジョンシステムでのみ使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアのバージョンをご参照ください。 モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

  • [PROFINET]: ビジョンシステムの PROFINET サービスを有効にします。選択すると、このオプションの右側にある [設定] ボタンが有効になります。このボタンによって [PROFINET スキャナ設定] ダイアログを起動し、設定を行います。

    注 : POWERLINK は、In-Sight のファームウェアバージョン 4.7.2 以上、および In-Sight Explorer のソフトウェアバージョン 4.7.2 以上を実行している In-Sight 70xx ～ 74xx シリーズのビジョンシステムでのみサポートされています。ファームウェアバージョン 5.1.0 以上ではサポートされません。
  • [SLMP スキャナ]: ビジョンシステムの SLMP スキャナサービスを有効にします。選択すると、このオプションの右側にある [設定] ボタンが有効になります。このボタンによって [SLMP スキャナ設定] ダイアログを起動し、設定を行います。
  • [CC－Link IE フィールド Basic]: ビジョンシステムで CC-Link IE フィールドの基本プロトコルを有効にします。選択すると、このオプションの右側にある [設定] ボタンが有効になります。このボタンによって [CC-Link IE フィールド Basic の設定] ダイアログを起動し、[ユーザデータバイパス] を設定します。
  • [POWERLINK]: ビジョンシステムの POWERLINK プロトコルを有効にします。選択すると、このオプションの右側にある [設定] ボタンが有効になります。このボタンによって [POWERLINK の設定] ダイアログを起動し、設定を行います。

  • [Modbus TCP サーバ]: ビジョンシステムの Modbus TCP サーバサービスを有効にします。選択すると、このオプションの右側にある [設定] ボタンが有効になります。このボタンによって [Modbus TCP サーバの設定] ダイアログを起動し、設定を行います。

    注 : このオプションは、In-Sight ファームウェアバージョン 5.3.0 以降が実行されている In-Sight ビジョンシステムでのみ使用可能です。
  • [なし]: ビジョンシステムの産業用イーサネットプロトコルを無効にします。

[iQ センサソリューションの有効化]: In-Sight ビジョンシステムの iQ Sensor Solution を有効または無効にします。

注 :
  • iQ センサソリューションは、In-Sight ファームウェア 4.x.x または 5.7.4 以降を実装している In-Sight ビジョンシステムだけで使用できます。
  • iQSS (GXWorks) と [ネットワーク設定] ダイアログにおいて、ネットワーク設定を同時に変更しないでください。

ロボット

In-Sight ビジョンシステム上で、ロボットコントローラ通信を有効または無効にします。ロボットコントローラを使用している場合、[産業用イーサネットプロトコル] ドロップダウンは [なし] に設定してください。

注 : In-Sight 2000 シリーズビジョンセンサは、ロボットコントローラをサポートしていません。
  • [なし]: ビジョンシステムのロボットコントローラ通信を無効にします。
  • [三菱電機]: In-Sight ビジョンシステム上で、ロボットコントローラ通信を有効にします。選択すると、このオプションの右側にある [設定] ボタンが有効になります。このボタンによって [SLMP スキャナ設定] ダイアログを起動し、設定を行います。

DHCP による In-Sight ビジョンシステムの自動的な設定

ネットワークで DHCP サーバを使用して IP アドレスを割り当てる場合は、[DHCP サーバの使用] チェックボックスを ON にしてください。アクティブな In-Sight ビジョンシステムは、起動時に DHCP サーバによって動的にネットワークの設定が行われます。必要に応じて、新しいホスト名と DHCP タイムアウトを指定することができますが、[ネットワークの設定] ダイアログのほかのフィールドはすべて無効になります。多数のビジョンシステムを使用するネットワークでは、各ビジョンシステムに手動で構成設定を入力するよりも、DHCP セットアップの方がよく使用されます。しかし、初期設定を完了した後は、ビジョンシステムの DHCP を無効にして、固定 IP アドレスを割り当てることを強く推奨します。

[DHCP サーバの使用] チェックボックスがオフの場合は、アクティブな In-Sight ビジョンシステムのネットワーク設定を手動で行う必要があります。

DHCP サーバを使用していないネットワークでの In-Sight ビジョンシステムの手動による設定

  1. [DHCP サーバの使用] チェックボックスが現在オンになっている場合は、オフにします。

    注 : In-Sight ビジョンシステムのネットワーク設定を以前に手動で行ったことがある場合は、[DHCP サーバの使用] チェックボックスをオフにすると、それらの設定内容が自動的にリストアされます。
  2. [IP アドレス] を入力します。
  3. [サブネットマスク] を入力します。
  4. 必要に応じて、[ホスト名]、[デフォルトゲートウェイ]、[DNS サーバ]、および [ドメイン名] を設定します。
  5. [OK] をクリックします。
  6. すべての変更を有効にするために、ビジョンシステムの電源を入れ直すように求められます。


[オプション] ダイアログ

[オプション] ダイアログを使用すると、In-Sight Explorer のスタートアップおよびデフォルト GUI 環境をカスタマイズしたり、オフライン In-Sight エミュレータを設定したり、ファイルユーティリティ環境を設定したりすることができます。[オプション] ダイアログは、次のオプション設定から構成されます。

[オプション] ダイアログを表示するには

  • [システム] メニューで、[オプション] をクリックします。


[POWERLINK の設定] ダイアログ

POWERLINK 産業用イーサネットプロトコルを設定する際に、In-Sight ビジョンシステムが POWERLINK 通信で使用する [ノード ID] を設定します。

[POWERLINK の設定] ダイアログの表示

  1. [産業用イーサネットプロトコル] グループボックスの [ネットワークの設定] ダイアログで、[POWERLINK] を選択します。
  2. これによって、[POWERLINK] の右側にある [設定] ボタンが有効になります。
  3. [設定] ボタンをクリックして、[POWERLINK の設定] ダイアログを起動します。

[POWERLINK の設定] ダイアログの設定項目

  • [ノード ID]: POWERLINK ネットワーク上にある In-Sight ビジョンシステムのノード ID を指定します (1 ～ 239。デフォルト = 1)。POWERLINK ネットワーク上にあるすべてのデバイスは、ノード ID で識別されます。この ID を固定 ID サブネットと結合し (192.168.100<NodeID>)、ネットワーク上の各デバイスに対して POWERLINK ネットワーク内の固定 IP アドレスを指定します。

ノード ID を POWERLINK ネットワークの NAT IP アドレスと組み合わせて使用することによって、POWERLINK ネットワークの外側にあるほかのデバイスと通信することができます。例えば、デフォルトの NAT IP アドレスは 192.168.101.0 です。ノード ID が 26 である In-Sight ビジョンシステムと通信するには、NAT IP アドレスをノード ID と結合して 192.168.101.26 とします。


[RAM ディスクの設定] ダイアログ

[RAM ディスクの設定] ダイアログによりユーザは、In-Sight センサまたはエミュレータのシステム RAM を利用することによって、ファイルシステムをエミュレートできます。Export/Import Cells 関数、ExportData 関数、および ImportData 関数と併用すれば、RAM ディスクにより、In-Sight センサと外部デバイス (PLC やロボットコントローラなど) の間で外部デバイスを共有できます。RAM ディスクが有効にされ、そのサイズが設定されると、[In-Sight のファイル] ペインに「RAMDisk」という名前のフォルダがセンサまたはエミュレータのサブディレクトリとして表示されます。

注 :
  • ジョブ (.JOB) ファイルとセルデータ (.CXD) ファイルのみがサポートされており、RAMDisk フォルダに格納できます。
  • RAMDisk フォルダに格納されているすべてのファイルが削除されるのは、センサの電源が入れ直されるときか、RAMDisk の設定が無効にされるときです。

[RAM ディスクの設定] ダイアログを表示するには

  • [センサ] メニューで、[RAM ディスクの設定] をクリックします。

    注 : センサまたはエミュレータで RAM ディスクがサポートされていない場合、[RAM ディスクの設定] メニュー項目はグレーアウトされます。ファームウェアバージョン 3.20.00 以降のセンサのみがサポートされています。

[RAM ディスクの設定] の設定項目

  • [有効]: チェックボックスをオンにすると、RAM ディスクの使用が有効になります。デフォルトでは、RAM ディスクは有効ではありません。
  • [サイズ (MB)]: この設定により、RAM ディスクに保存されるデータの最大量 (メガバイト単位) が決まります。RAM ディスクは使用されるメモリの合計量を追跡し、[サイズ] 設定に対してその値を照会します。センサの最大サイズは 32MB で、エミュレータの最大設定は 64MB です。

センサまたはエミュレータの RAM ディスクへのファイルの保存

.JOB ファイルの保存

.JOB ファイルをセンサまたはエミュレータの RAMDisk フォルダに保存するには、[名前を付けて保存] ダイアログを使用し、[ファイルの場所:] ドロップダウンリストを使用してファイルの場所を目的のセンサまたはエミュレータの RAMDisk フォルダに設定します。あるいは、[In-Sight のファイル] ペインから .JOB ファイルをドラッグし、目的のセンサまたはエミュレータの RAMDisk フォルダにドロップすることもできます。または、[In-Sight のファイル] ペインで右クリックのショートカットメニューを使用し、.JOB ファイルをコピーして RAMDisk フォルダに貼り付けることもできます。

.CXD ファイルの保存

複数のスプレッドシートのセルを .CXD ファイルに保存し、そのファイルをセンサまたはエミュレータの RAMDisk フォルダにエクスポートするには、[セルのエクスポート] ダイアログを使用し、目的のセンサまたはエミュレータの RAMDisk フォルダを指定します。単一セルのデータを .CXD ファイルに保存し、そのファイルをセンサまたはエミュレータの RAMDisk フォルダにエクスポートするには、ExportData 関数を使用して、目的のセンサまたはエミュレータの RAMDisk フォルダを指定します。

注 :
  • ファイルに名前を付けるときには、円記号 (¥) を使用しないでください。名前に円記号が含まれているファイルは、ファイル名を変更して円記号をなくしてからでなければ、コピーや削除ができません。また、ファイル名に円記号が含まれていると、リストア操作の際にエラーが発生します。
  • RAMDisk フォルダでは大文字と小文字が区別されませんが、RAMDisk フォルダの名前を変更することはできません。RAMDisk フォルダ自体はコピーされませんが、フォルダの内容はコピー可能です。

センサまたはエミュレータの RAM ディスク内のファイルへのアクセス

.JOB ファイルを開く

センサまたはエミュレータの RAMDisk フォルダの .JOB ファイルを開くには、[開く] ダイアログを使用し、[ファイルの場所:] ドロップダウンリストを使用してファイルの場所を目的のセンサまたはエミュレータの RAMDisk フォルダに設定します。

.CXD ファイルを開く

センサまたはエミュレータの RAMDisk フォルダを開くには、[セルのインポート] ダイアログ (複数のスプレッドシートセルを含むファイルの場合) または ImportData 関数 (単一セルのデータを含むファイルの場合) を使用し、目的のセンサまたはエミュレータの RAMDisk フォルダを指定します。

RAMDisk ファイルへのリモートアクセス

センサまたはエミュレータの RAMDisk フォルダのファイルにリモートアクセスする場合は、次のファイル名のプロトコルに従います。

  • In-Sight センサ: 「ramdisk/filename.type」

  • FTP コマンドプロンプトを使用してセンサに接続します。

    注 :
    • FTP コマンドの CD (change directory) はサポートされません。
    • Web ブラウザから FTP を使用して RAMDisk フォルダにアクセスすることはできません。

ネイティブモード: 「[Command]RAMDisk/filename.job」。例えば、Read File ネイティブモードコマンドを使用して「Model.job」ファイルを読み取るには、「RFRAMDisk/Model.job」コマンドを発行します。

注 : Get Filelist ネイティブモードコマンドを使用して RAMDisk フォルダからファイルリストを取得することはできません。RAMDisk フォルダのファイルリストを取得するには、代わりに FTP プロトコルを使用してください。


[記録/再生のオプション] ダイアログ

EasyBuilder ビュー

[記録/再生のオプション] ダイアログでは、個々のビジョンシステムやエミュレータの記録/再生の設定を行うことができます。このダイアログで設定を行った後、取り込んだ画像の記録と再生を行うことができます。画像は、PC 上の指定した記録フォルダに保存されます。

注 :
  • [オプション] ダイアログの [記録] パネルは、[記録] オプションを初めて実行する前に、その初期値を設定するために使用します。
  • [記録] オプションを初めて実行した後、[オプション] ダイアログの [記録] パネルで行った変更は、アクティブなビジョンシステムまたはエミュレータの [記録/再生のオプション] ダイアログから [初期値に戻す] を選択しない限り、[記録/再生のオプション] ダイアログには反映されません。
  • In-Sight カラービジョンシステムでは、1/4 解像度の画像は記録できません。カラービジョンシステムの [記録/再生のオプション] ダイアログで 1/4 解像度の画像を記録するように設定した場合、実際に記録される画像は 1/2 解像度の画像です。
  • [記録/再生のオプション] ダイアログボックスは、ビジョンシステムに装着された SD カードをサポートしません。

[記録/再生のオプション] ダイアログを表示するには

次のいずれかの操作を行います。

  • [画像] メニューで、[記録/再生のオプション] をクリックします。
  • EasyBuilder ツールバーで、[記録/再生のオプション] ボタン [image] をクリックします。
  • CTRL+T キーを押します。
  • [画像の設定] 設定ペインで [PCから画像をロード] をクリックします。
  • フィルムストリップの設定ペインで [再生] をクリックします。

[記録] タブの設定項目

  • [記録フォルダ]: 画像を保存するためのディレクトリを指定します。

    注 : 記録フォルダのサブディレクトリとして、Good フォルダと Bad フォルダが作成されます。
  • [画像カウント]: [記録フォルダにすべての画像を記録する] を選択している場合、[画像カウント] には、記録フォルダに保存されている画像の数が表示されます。[記録フォルダにすべての画像を記録する] が選択されていない場合、[画像カウント] には、Good/Bad フォルダに保存されている画像の数が表示されます。
  • [ファイル名のフォーマット]: 記録画像のファイル名のフォーマットとファイルの種類。
    • [接頭語]: 記録画像のファイル名の接頭辞。
    • [フォーマット]: 記録画像のファイル名のフォーマット。[フォーマット] オプションは、[Index] と [DateTime] です。
    • [ファイル形式]: 記録画像のファイルの種類。選択できるファイルの種類は、[ビットマップファイル (*.bmp)] と [JPEG ファイル (*.jpg)] です。
    • 例: [フォーマット] および [ファイル形式] ドロップダウンリストで選択した [ファイル名のフォーマット] オプションに基づいて、記録画像ファイルの命名規則の例が表示されます。
  • [最大保存数]: 記録フォルダに保存する画像の最大数。(1 ～ 10,000、デフォルト 10,000)

  • [画像の解像度]: 画像の記録時に使用する In-Sight ビジョンシステムの解像度を指定します。記録が完了すると、ビジョンシステムの解像度は [画像の設定] ダイアログで設定した元の設定に戻ります。保存する画像の解像度として指定できるのは、フルアクセス、ハーフ (1/2)、クォーター (1/4) です。デフォルトの解像度はフルアクセスです。

    注 :
    • ビジョンシステムがフル解像度をサポートしていない場合、このオプションをドロップダウンリストから選択することはできません。
    • この設定は、ビジョンシステムがオンラインのときにのみ使用できます。ビジョンシステムがオフラインのときに記録された画像はすべて、フル解像度で記録されます。

  • [ビット深度]: カラー画像を記録するときのビット深度を指定します ([16 ビット] または [24 ビット]。デフォルト = [24 ビット])。

    注 :
    • このオプションは、カラー In-Sight ビジョンシステムでのみ使用可能になります。
    • JPEG (*.jpg) 画像は常に 24 ビット深度で記録されます。16 ビットで記録する必要がある場合、ビットマップファイル (*.bmp) で画像を記録してください。

  • [記録フォルダのクリア]: [記録された画像の削除]ダイアログが開かれます。このダイアログでは、記録フォルダ、Good フォルダ、および Bad フォルダから画像を削除することができます。

    注 : 記録フォルダと再生フォルダが同じ場合、記録フォルダを選択すると、再生フォルダの画像もすべて削除されます。

  • [Good/Bad フォルダのクリア]: [記録された画像の削除]　ダイアログが開かれます。このダイアログでは、記録フォルダ、Good フォルダ、および Bad フォルダから画像を削除することができます。

    注 : 記録フォルダと再生フォルダが同じ場合、記録フォルダを選択すると、再生フォルダの画像もすべて削除されます。
  • [PASS/FAIL の振り分け]: ジョブの全体的な成功/失敗ステータスに基づいて、画像を特定のフォルダに振り分けます。
    • [記録フォルダにすべての画像を記録する]: すべての画像を記録フォルダに記録します。成功/失敗の振り分けは無効になります。
    • [PASS 画像を Good フォルダに記録する]: 成功 (PASS) した画像を Good フォルダに記録します。
    • [FAIL 画像を Bad フォルダに記録する]: 失敗 (FAIL) した画像を Bad フォルダに記録します。
    • [PASS/FAIL に応じて画像を Good/Bad フォルダに振り分ける]: 成功 (PASS) した画像を Good フォルダに、失敗 (FAIL) した画像を Bad フォルダに振り分け、記録します。
  • [記録/再生の前に、常にこのダイアログを表示する]: このチェックボックスをオンにすると、画像を記録または再生する前に [記録/再生のオプション] ダイアログが開きます。
  • [初期値に戻す]: [記録フォルダ]、[最大保存数]、[画像の解像度]、および [ファイル名のフォーマット] 設定を、[オプション] ダイアログの [記録] パネルの現在の設定に一致するようにリセットします。[記録] タブと [再生] タブの残りの設定は、デフォルトに戻ります。

[再生] タブの設定項目

  • [再生フォルダ]: 再生する画像の保存されているディレクトリを指定します。
  • [画像カウント]: 再生フォルダに保存されている画像の数を示します。

  • [再生モード]: [画像] メニューまたは EasyBuilder ツールバーの [再生] を選択したときの画像の表示方法を決めます。画像はアルファベット順に再生され、次に番号順に再生されます。画像の再生を一時停止した後に [再生] を選択する場合は、[再生] を選択すると、最後に表示された画像から再生が再開されます。[画像] メニューから [最初の画像] を選択するか、[記録/再生] ツールバーの [最初の画像] を選択すると、始めから再生が開始されます。

    注 : ビジョンシステムがオンラインモードのときに画像の再生ができるようにするには、[画像の設定] ステップの [トリガ] パラメータが [外部]、[手動]、または [ネットワーク] に設定されている必要があります。
    • [連続]: 再生フォルダに保存されている画像を連続再生します。
    • [一巡]: 再生フォルダに保存されている画像を 1 回だけ再生します。
  • [一時停止時間]: ある画像を再生してから次の画像を再生するまでの時間遅延 (0 ～ 60 秒、デフォルト = 0.5)。
  • [記録/再生の前に、常にこのダイアログを表示する]: このチェックボックスをオンにすると、画像を記録または再生する前に [記録/再生のオプション] ダイアログが開きます。
  • [初期値に戻す]: [記録フォルダ]、[最大保存数]、[画像の解像度]、および [ファイル名のフォーマット] 設定を、[オプション] ダイアログの [記録] パネルの現在の設定に一致するようにリセットします。[記録] タブと [再生] タブの残りの設定は、デフォルトに戻ります。

スプレッドシートビュー

[記録/再生のオプション] ダイアログでは、個々のビジョンシステムやエミュレータの記録/再生の設定を行うことができます。このダイアログで設定を行った後、取り込んだ画像の記録と再生を行うことができます。画像は、PC 上の指定した記録フォルダに保存されます。

注 :
  • [オプション] ダイアログの [記録] パネルは、[記録] オプションを初めて実行する前に、その初期値を設定するために使用します。
  • [記録] オプションを初めて実行した後、[オプション] ダイアログの [記録] パネルで行った変更は、アクティブなビジョンシステムまたはエミュレータの [記録/再生のオプション] ダイアログから [初期値に戻す] を選択しない限り、[記録/再生のオプション] ダイアログには反映されません。
  • [記録/再生のオプション] ダイアログボックスは、ビジョンシステムに装着された SD カードをサポートしません。

[記録/再生のオプション] ダイアログを表示するには

  • [画像] メニューで、[記録/再生のオプション] をクリックします (または、[記録/再生] ツールバーの [記録/再生のオプション] ボタン [image] をクリックするか、CTRL+T キーを押します)。

[記録] タブの設定項目

  • [記録フォルダ]: 画像を保存するためのディレクトリを指定します。

    注 : 記録フォルダのサブディレクトリとして、Good フォルダと Bad フォルダが作成されます。
  • [画像カウント]: [監視セルを使用しない (記録フォルダにすべて記録する)] を選択している場合、[画像カウント] には、記録フォルダに保存されている画像の数が表示されます。それ以外の振り分け方法を選択している場合、[画像カウント] には、Good/Bad フォルダに保存されている画像の数が表示されます。
  • [ファイル名のフォーマット]: 記録画像のファイル名のフォーマットとファイルの種類。
    • [接頭語]: 記録画像のファイル名の接頭辞。
    • [フォーマット]: 記録画像のファイル名のフォーマット。[フォーマット] オプションは、[Index] と [DateTime] です。
    • [ファイル形式]: 記録画像のファイルの種類。選択できるファイルの種類は、[ビットマップファイル (*.bmp)] と [JPEG ファイル (*.jpg)] です。
    • 例: [フォーマット] および [ファイル形式] ドロップダウンリストで選択した [ファイル名のフォーマット] オプションに基づいて、記録画像ファイルの命名規則の例が表示されます。
  • [最大保存数]: 記録フォルダに保存する画像の最大数。(1 ～ 10,000、デフォルト 10,000)

  • [画像の解像度]: 画像の記録時に使用する In-Sight ビジョンシステムの解像度を指定します。記録が完了すると、ビジョンシステムの解像度は [画像の設定] ダイアログで設定した元の設定に戻ります。保存する画像の解像度として指定できるのは、フルアクセス、ハーフ (1/2)、クォーター (1/4) です。デフォルトの解像度はフルアクセスです。

    注 : ビジョンシステムがフル解像度をサポートしていない場合、このオプションをドロップダウンリストから選択することはできません。

  • [ビット深度]: カラー画像を記録するときのビット深度を指定します ([16 ビット] または [24 ビット]。デフォルト = [24 ビット])。

    注 :
    • このオプションは、カラー In-Sight ビジョンシステムでのみ使用可能になります。
    • JPEG (*.jpg) 画像は常に 24 ビット深度で記録されます。16 ビットで記録する必要がある場合、ビットマップファイル (*.bmp) で画像を記録してください。

  • [記録フォルダのクリア]: [記録された画像の削除]　ダイアログが開かれます。このダイアログでは、記録フォルダ、Good フォルダ、および Bad フォルダから画像を削除することができます。

    注 : 記録フォルダと再生フォルダが同じ場合、記録フォルダを選択すると、再生フォルダの画像もすべて削除されます。

  • [Good/Bad フォルダのクリア]: [記録された画像の削除]　ダイアログが開かれます。このダイアログでは、記録フォルダ、Good フォルダ、および Bad フォルダから画像を削除することができます。

    .

    注 : 記録フォルダと再生フォルダが同じ場合、記録フォルダを選択すると、再生フォルダの画像もすべて削除されます。

  • [監視セルによる振り分け]: 監視セルの値に基づいて、画像を特定のフォルダに保存します。

    注 : In-Sight で類似の効果を持つ監視セルが 3 つあります ([ジョブの PASS/FAIL] セル、[フィルムストリップ] 監視セル および [記録/再生] の監視セル)。これらの 3 つの監視セルを個々に設定し、異なる機能を制御することができます。
    • [監視セルを使用しない (記録フォルダにすべて記録する)]: すべての画像を記録フォルダに記録します。[監視セル] は無効になります。
    • [監視セルの値が 0 でない場合、Good フォルダに記録する]: 画像取り込みの際に、監視セルがゼロ以外の数値を含んでいた場合、画像は Good フォルダに保存されます。画像取り込みの際に、監視セルがゼロまたは #ERR を含んでいた場合、画像は記録されません。
    • [監視セルの値が 0 または #ERR の場合、Bad フォルダに記録]: 画像取り込みの際に、監視セルがゼロまたは #ERR を含んでいた場合、画像は Bad フォルダに保存されます。画像取り込みの際に、監視セルがゼロまたは #ERR を含んでいなかった場合、画像は記録されません。
    • [監視セルの値に応じて Good/Bad フォルダに振り分ける]: 画像取り込みの際に、監視セルがゼロ以外の数値を含んでいた場合、画像は Good フォルダに保存されます。画像取り込みの際に、監視セルがゼロまたは #ERR を含んでいた場合、画像は Bad フォルダに保存されます。
    • [監視セル]: 監視対象のセルを示します。
    • [セルの選択]: このボタンをクリックするとセル選択モードに切り替わり、画像を Good または Bad フォルダに保存するかどうかを判断するための監視セルを参照することができます。
  • [記録/再生の前に、常にこのダイアログを表示する]: このチェックボックスをオンにすると、画像を記録または再生する前に [記録/再生のオプション] ダイアログが開きます。
  • [初期値に戻す]: [記録フォルダ]、[最大保存数]、[画像の解像度]、および [ファイル名のフォーマット] 設定を、[オプション] ダイアログの [記録] パネルの現在の設定に一致するようにリセットします。[記録] タブと [再生] タブの残りの設定は、デフォルトに戻ります。

[再生] タブの設定項目

  • [再生フォルダ]: 再生する画像の保存されているディレクトリを指定します。
  • [画像カウント]: 再生フォルダに保存されている画像の数を示します。

  • [再生モード]: [画像] メニューまたは [記録/再生] ツールバーの [再生] を選択したときの画像の表示方法を決めます。画像はアルファベット順に再生され、次に番号順に再生されます。画像の再生を一時停止した後に [再生] を選択する場合は、[再生] を選択すると、最後に表示された画像から再生が再開されます。[画像] メニューから [最初の画像] を選択するか、[記録/再生] ツールバーの [最初の画像] を選択すると、始めから再生が開始されます。

    注 : ビジョンシステムがオンラインモードのときに画像の再生ができるようにするには、AcquireImage 関数の [トリガ] パラメータが [外部]、[手動]、または [ネットワーク] に設定されている必要があります。
    • [連続]: 再生フォルダに保存されている画像を連続再生します。
    • [一巡]: 再生フォルダに保存されている画像を 1 回だけ再生します。
  • [一時停止時間]: ある画像を再生してから次の画像を再生するまでの時間遅延 (0 ～ 60 秒、デフォルト = 0.5)。
  • [記録/再生の前に、常にこのダイアログを表示する]: このチェックボックスをオンにすると、画像を記録または再生する前に [記録/再生のオプション] ダイアログが開きます。
  • [初期値に戻す]: [記録フォルダ]、[最大保存数]、[画像の解像度]、および [ファイル名のフォーマット] 設定を、[オプション] ダイアログの [記録] パネルの現在の設定に一致するようにリセットします。[記録] タブと [再生] タブの残りの設定は、デフォルトに戻ります。


[リストア] ダイアログ

[リストア] ダイアログでは、In-Sight ビジョンシステム/センサまたはエミュレータから、ジョブ、画像、およびセンサ設定のアーカイブされたコピーを取得できます。これらの情報は、[リストア] ダイアログに表示される前に、ローカル PC にバックアップされる必要があります。このダイアログではまた、In-Sight ビジョンシステムに装着された SD カードに保存されているバックアップを取得することもできます。

PC からのリストア

アーカイブされたバックアップは、[オプション] ダイアログで定義する [バックアップディレクトリ] からリストアされます。In-Sight Explorer は、In-Sight ネットワークからセンサ名が一致するサブフォルダをすべて探し、それらのサブフォルダを [リストア] ダイアログに表示します。

注 :
  • アーカイブされたビジョンシステム/センサの最新のバックアップのみが [リストア] ダイアログのリストに表示されます。古いバックアップからリストアする場合、または別のビジョンシステム/センサからのバックアップをリストアする場合は、代わりに [選択してリストア] ダイアログを使用します。
  • [リストア] 機能を実行するには、ビジョンシステム/センサをオフラインにする必要があります。オンラインのビジョンシステム/センサのリストアを試みると、センサをオフラインにすることについての警告ダイアログが表示されます。
  • リストア時、ビジョンシステム/センサまたはエミュレータ上の同じ名前の既存のファイルが、現在のネットワーク設定を含めて上書きされます。リストア対象の一連のファイルに含まれていない既存のファイルは上書きされません。
  • ビジョンシステム/センサがリストアされるとき、ユーザリストはクリアされません。したがって、ビジョンシステム/センサがリストアされる前にユーザリストに追加したユーザ名は、リストア後もビジョンシステム/センサに保存されています。ビジョンシステム/センサがリストアされた後で、ユーザリストからユーザを手動で追加または削除してください。

  • [バックアップディレクトリ] のデフォルトのフォルダ位置は、Program Files フォルダから次の場所に移動されており、標準ユーザがアクセスすることができます (In-Sight Explorer 4.5.0 以降)。

    • Windows 7/Windows 10:
      C:\ProgramData\Cognex\In-Sight\In-Sight Explorer x.x.x

In-Sight ビジョンシステムに装着された SD カードからのリストア

SD カードにある最新のバックアップが In-Sight ビジョンシステムにリストアされます。

注 :
  • SD カードからリストアするためには、ビジョンシステムがオフラインになっている必要があります。
  • SD カードにはバックアップが 1 つだけ保存されます。その後のバックアップでは、前のバックアップが上書きされるからです。
  • SD カード上のバックアップは、SD カードが装着されている In-Sight ビジョンシステムにのみリストア可能です。

[リストア] ダイアログを表示するには

  • [システム] メニューで、[リストア] をクリックします。

[リストア] ダイアログの使用法

  1. 左側にあるチェックボックスをオンにすることによって、リストアするビジョンシステム/センサまたはエミュレータを選択します。SD カードからリストアする場合は、[SD カードを使用] チェックボックスをオンにします。

    注 :
    • 目的のビジョンシステム/センサまたはエミュレータは、検索ボックスを使用して動的にサーチすることができます。
    • [SD カードを使用] チェックボックスは、ビジョンシステムに SD カードが装着されており、PC で選択したビジョンシステムのバックアップが存在する場合にのみ有効になります。
    • ビジョンシステムに SD カードが装着されていない場合、[SD カードを使用] チェックボックスは無効になります。ビジョンシステムに SD カードが装着されていても、PC 上に選択したビジョンシステムのバックアップが存在しなければ、[SD カードを使用] チェックボックスがオンになって無効になります。
    • SD カードが装着されているビジョンシステムを選択しても、[SD カードを使用] チェックボックスがオフの場合、アーカイブされたデータは PC からリストアされます。アーカイブ先 (PC または SD カード) の詳細については、「[バックアップ] ダイアログ」を参照してください。
  2. [リストア] をクリックします。


[選択してリストア] ダイアログ

[選択してリストア] ダイアログでは、以下のデータを取得できます。

  • In-Sight ビジョンシステム/エミュレータのジョブ、画像、および設定データの最新のアーカイブ。
  • In-Sight ビジョンシステム/エミュレータのジョブ、画像、および設定データの古いアーカイブコピー。
  • 別の In-Sight ビジョンシステム/エミュレータからのアーカイブ。
  • ビジョンシステムに装着された SD カードからのバックアップ

PC からのリストア

In-Sight ビジョンシステム/センサ上のアーカイブされたバックアップは、[オプション] ダイアログで定義する [バックアップディレクトリ] からリストアされます。In-Sight Explorer は、In-Sight ネットワークからセンサ名が一致するサブフォルダをすべて探し、それらのサブフォルダを [リストア] ダイアログに表示します。

そのビジョンシステムが一度だけバックアップされている場合は、右側のペインにその名前のインスタンスが (フォルダ [image] アイコン付き) 1 つだけ表示されます。そのセンサのバックアップが複数回実行されている場合は、センサ名の後に増分値が続く形式の名前 (is5401_010203.000、is5401_010203.001 など) で追加のフォルダが表示されます。最大の数字が対象のセンサの最新バックアップに対応します。

注 :
  • [選択してリストア] 機能を実行するためには、ビジョンシステム/センサをオフラインにする必要があります。オンラインのビジョンシステム/センサのリストアを試みると、センサをオフラインにすることについての警告ダイアログが表示されます。
  • 異なるビジョンシステム/センサのアーカイブから In-Sight ビジョンシステム/センサをリストアする場合は、両方のセンサのモデルが異なっていると　(例えば、In-Sight 5400C のアーカイブから In-Sight Micro 1400 ビジョンシステムにリストアを試みる場合)、予期せぬ動作が引き起こされる可能性があります。例えば、リストア元の In-Sight ビジョンシステム/センサのいくつかのジョブ機能は、リストア先の In-Sight ビジョンシステム/センサではサポートされていないという場合もあります
  • リストア時、ビジョンシステム/センサまたはエミュレータ上の同じ名前の既存のファイルが、現在のネットワーク設定を含めて上書きされます。リストア対象の一連のファイルに含まれていない既存のファイルは上書きされません。
  • ビジョンシステム/センサがリストアされるとき、ユーザリストはクリアされません。したがって、ビジョンシステム/センサがリストアされる前にユーザリストに追加したユーザ名は、リストア後もビジョンシステム/センサに保存されています。ビジョンシステム/センサがリストアされた後で、ユーザリストからユーザを手動で追加または削除してください。

  • [バックアップディレクトリ] のデフォルトのフォルダ位置は、Program Files フォルダから次の場所に移動されており、標準ユーザがアクセスすることができます (In-Sight Explorer 4.5.0 以降)。

    • Windows 7/Windows 10:
      C:\ProgramData\Cognex\In-Sight\In-Sight Explorer x.x.x

In-Sight ビジョンシステムに装着された SD カードからのリストア

SD カードにある最新のバックアップが In-Sight ビジョンシステムにリストアされます。

注 :
  • SD カードからリストアするためには、ビジョンシステムがオフラインになっている必要があります。
  • SD カードにはバックアップが 1 つだけ保存されます。その後のバックアップでは、前のバックアップが上書きされるからです。
  • SD カード上のバックアップは、SD カードが装着されている In-Sight ビジョンシステムにのみリストア可能です。

[選択してリストア] ダイアログを表示するには

  • [システム] メニューで、[選択してリストア] をクリックします。

[選択してリストア] ダイアログの使用法

  1. バックアップからファイルを取り込むビジョンシステムまたはエミュレータを左側のペインから選択します。一度に選択できるビジョンシステムまたはエミュレータは 1 つだけです。
  2. 右側のペインで、リストアするバックアップの場所を選択します。

    1. [SD カード]: 最後のバックアップがリストアされます。

      注 : [SD カード] オプションは、左側のペイン ([Select In-Sight Sensor to Restore (リストアする In-Sight センサを選択)] リストボックス) で SD カードが装着されている In-Sight ビジョンシステムが選択されている場合にのみ有効になります。
    2. [バックアップセット]: リストからアーカイブを選択します。
  3. [選択してリストア] をクリックします。


[保存] および [開く] ダイアログ

[保存] および [開く] ダイアログは、本質的に FTP クライアントとして、2 つの In-Sight ビジョンシステム間の接続を確立します。ジョブおよび画像ファイルは、リモートビジョンシステムからロードしたり、リモートビジョンシステムに保存したりすることができます。

注 :
  • In-Sight ビジョンシステムの設定 (ネットワーク設定など) は、[ジョブに名前を付けて保存] ダイアログを使用して保存することはできません。ビジョンシステム設定ファイル (proc.set) は、標準の FTP コマンドを使用することによってのみ、ネットワーク上の In-Sight エミュレータまたは In-Sight 以外の FTP デバイスから転送することができます。
  • 1 つの In-Sight ビジョンシステムには 1024 個以上のファイルを保存できますが、FTP プロンプトまたは Telnet セッションからファイルリストを表示した場合、リストに表示されるファイルは 1024 個のみで、[保存] および [開く] ダイアログには 1024 ファイルしか表示できません。
  • ワーキングエミュレータのディレクトリは 2 つあります (C:\ProgramData\Cognex\In-Sight\Emulators\5.x.x および C:\ProgramData\Cognex\In-Sight\Emulators\4.x.x)。In-Sight エミュレータを使用する場合は、エミュレーションモデルに応じて、ジョブ/画像を保存したり、開いたりするために別のディレクトリが使用されます。例えば、エミュレータモデルが In-Sight 8405 に設定されている場合、ジョブ/画像は 5.x.x ディレクトリに保存されます。エミュレータモデルが In-Sight Micro 1400 に設定されている場合、ジョブ/画像は 4.x.x ディレクトリに保存されます。したがって、ジョブが 4.x.x エミュレータ (In-Sight Micro 1400 など) に保存される場合に、エミュレータモデルを 5.x.x (標準モデルなど) に変更すると、[開く] ダイアログからジョブを開こうとするときに、そのジョブはダイアログのリストに表示されません。エミュレータモデルとエミュレータのバージョンの詳細については、「[オプション] ダイアログ」のトピック (エミュレーションパネル) を参照してください。

ジョブを開く

[ジョブを開く] ダイアログを使用すると、ジョブファイルを In-Sight ビジョンシステムのメモリにアクティブなジョブとしてロードすることができます。

In-Sight ビジョンシステムからジョブファイルを開くには、以下の操作を実行します。

  1. [ファイル] メニューで、[ジョブを開く] をクリックします。

  2. 開くジョブファイルが格納されている場所を選択します。[ファイルの場所] ドロップダウンリストには、ローカル PC 上のドライブ、ネットワークドライブ、ローカルサブネット上の RAM ディスクフォルダ (有効化および設定済み) と SD カードフォルダを含む、検出された In-Sight ビジョンシステムとエミュレータ、ジョブサーバ と Explorer ホストテーブルで定義されたすべてのデバイスが含まれています。ビジョンシステムで使用可能なジョブを表示するには、ドロップダウンリストから目的のビジョンシステムを選択します。In-Sight ビジョンシステムまたはエミュレータの RAM ディスクフォルダまたは SD カードフォルダを選択するには、まず、目的の RAM ディスクフォルダまたは SD カードフォルダがある In-Sight ビジョンシステムまたはエミュレータをクリックして、表示された「RAMDisk」フォルダまたは「SDCARD」フォルダをダブルクリックします。

  3. 必要なジョブをハイライトして、[開く] をクリックします。または、ジョブファイルをダブルクリックするか、[ファイル名] にファイル名を入力して [開く] をクリックします。

    注 :
    • Explorer のホストテーブルで定義されていない限り、サブネット上に存在しない In-Sight ビジョンシステムが [ファイルの場所] ドロップダウンリストに自動的に表示されることはありません。
    • 次の場合は、[ジョブを開く] ダイアログを使用できません。
      • アクティブな In-Sight ビジョンシステムがオンラインになっている
      • ユーザのアクセスレベルがロックである
    • プロテクトアクセスレベルのユーザは、ユーザリストでその特定ユーザに FTP 読み出し権限が与えられている場合にのみ、[開く] ダイアログを使用できます。
    • In-Sight ビジョンシステムの設定を [ジョブを開く] ダイアログから開くことはできません。ビジョンシステム設定ファイル (proc.set) は、標準の FTP コマンドを使用することによってのみ、ネットワーク上の In-Sight エミュレータまたは In-Sight 以外の FTP デバイスから転送することができます。

    • ジョブサーバの場所は、[ジョブサーバの設定] ダイアログを使ってジョブサーバを有効にしている場合にだけ表示されます。

    • ジョブサーバは、In-Sight 2000 シリーズビジョンセンサではサポートされていません。
    • ダイアログでファイルを右クリックすることにより、ファイルをコピー、削除、または名前変更できます。コピーしたジョブは、ほかの In-Sight ビジョンシステム、エミュレータまたは SD カードに貼り付けることができます。

ジョブを保存する

[ジョブに名前を付けて保存] ダイアログを使用すると、ジョブファイルを In-Sight ビジョンシステムのメモリに格納できます。格納先デバイスが In-Sight エミュレータの場合、ジョブは PC のハードディスク上のファイルに保存されます。

In-Sight ビジョンシステムにジョブファイルを保存するには、以下の操作を実行します。

[ファイル] メニューで、[ジョブに名前を付けて保存] をクリックします。

ファイルを保存する場所を選択します。[ファイルの場所] ドロップダウンリストには、ローカル PC 上のドライブ、ネットワークドライブ、ローカルサブネット上の RAM ディスクフォルダ (有効化および設定済み) と SD カードフォルダを含む、検出された In-Sight ビジョンシステムとエミュレータ、ジョブサーバ と Explorer ホストテーブルで定義されたすべてのデバイスが含まれています。ビジョンシステムで使用可能なジョブを表示するには、ドロップダウンリストから目的のビジョンシステムを選択します。In-Sight ビジョンシステムまたはエミュレータの RAM ディスクフォルダまたは SD カードフォルダを選択するには、まず、目的の RAM ディスクフォルダまたは SD カードフォルダがある In-Sight ビジョンシステムまたはエミュレータをクリックして、表示された「RAMDisk」フォルダまたは「SDCARD」フォルダをダブルクリックします。

アクティブジョブを新規ファイルに保存するには、[ファイル名] テキストボックスに名前を入力して、[保存] をクリックします。既存のファイルに上書き保存するには、そのファイルをリストから選択して、[保存] をクリックします。

注 :
  • ファイルを初めて保存する場合は、ファイル名の指定を求められます。ファイルに名前を付けるときには、円記号 (¥) を使用しないでください。名前に円記号が含まれているファイルは、ファイル名を変更して円記号をなくしてからでなければ、コピーや削除ができません。また、ファイル名に円記号が含まれていると、リストア操作の際にエラーが発生します。
  • ファイル名にはスペースを含めることができます。
  • ファイル名に、/ : , ; * ? " < > | % の各文字を含めることはできません。
  • ジョブの保存中は、ビジョンシステムの電源を入れ直さないでください。ファイルの保存中に電源が遮断された場合は、ファイルをもう一度保存しなおす必要があります。
  • ジョブのサイズやジョブの保存先デバイスの接続速度によっては、ほかのジョブよりも保存に時間がかかるジョブがあります。
  • ファイルのコピーを保存する場合、またはファイルを別の場所に保存する場合は、[ファイル] メニューから [ジョブに名前を付けて保存] を選択します。
  • ジョブファイルのパス名は最大 255 文字です。ジョブファイルのパス名とは、ルートディレクトリからファイル名とファイル拡張子のすべての文字のことです。ネイティブモードコマンドを使用する場合、ファイル名の前のジョブスロットも合計文字数に含める必要があります。
  • Explorer のホストテーブルで定義されていない限り、サブネット上に存在しない In-Sight ビジョンシステムが [ファイルの場所] ドロップダウンリストに自動的に表示されることはありません。
  • 次の場合は、[ジョブに名前を付けて保存] ダイアログを使用できません。

    • アクティブな In-Sight ビジョンシステムがオンラインになっているただし、[ユーザ] ダイアログの [オンラインでもジョブを保存] チェックボックスをオンにすると、[フル] または [プロテクト] アクセス権限を持つユーザは [名前を付けて保存] ダイアログにアクセスできるようになります。

    • ユーザのアクセスレベルがロックである

  • プロテクトアクセスレベルのユーザは、ユーザリストでその特定のユーザに FTP 書き込み権限が与えられている場合にのみ、[名前を付けて保存] ダイアログを使用できます。
  • In-Sight Explorer 4.4.1 以降で、ジョブが保護されている場合は、ドロップダウンメニューのオプション [暗号化] が有効になります。オプションは、[高速 (デフォルト)] と [レガシー] の 2 つです。[高速] オプションでは、特に大規模なジョブファイルのジョブに関連する遅延を低減します。[レガシー] オプションは、In-Sight Explorer 4.4.0 以前を実行中の In-Sight ビジョンシステムと互換性を持たせる必要があるジョブの場合に使用します。[暗号化] ドロップダウンは、ジョブで使用されている現在の暗号化オプションに設定されます。

  • ジョブサーバの場所は、[ジョブサーバの設定] ダイアログを使ってジョブサーバを有効にしている場合にだけ表示されます。

  • ジョブサーバは、In-Sight 2000 シリーズビジョンセンサではサポートされていません。
  • ダイアログでファイルを右クリックすることにより、ファイルをコピー、削除、または名前変更できます。コピーしたジョブは、ほかの In-Sight ビジョンシステム、エミュレータまたは SD カードに貼り付けることができます。

画像を開く

[画像を開く] ダイアログを使用すると、標準の .BMP または .JPG ファイルを In-Sight ビジョンシステムにロードすることができます。画像はロード先ビジョンシステムでアクティブな画像となり、In-Sight ファイルシステムの image.bmp と置き換えられます。

画像ファイルをアクティブな画像として In-Sight ビジョンシステムにロードするには

  1. [ファイル] メニューで、[画像を開く] をクリックします。

  2. 開く画像ファイルが格納されている場所を選択します。開く画像ファイルが格納されている場所を選択します。[ファイルの場所] ドロップダウンリストには、ローカル PC 上のドライブ、ネットワークドライブ、ローカルサブネット上で検出された In-Sight ビジョンシステムとエミュレータ (SD カードフォルダを含む)、および Explorer のホストテーブルで定義されているすべてのデバイスが含まれています。In-Sight ビジョンシステムの SD カードフォルダを選択するには、まず、目的の SD カードフォルダがある In-Sight ビジョンシステムをクリックして、表示された「SDCARD」フォルダをダブルクリックします。

  3. 必要な画像をハイライト表示して、[開く] をクリックします。または、画像ファイルをダブルクリックするか、[ファイル名] にファイル名を入力して [開く] をクリックします。

    注 :
    • 次の場合は、[開く] ダイアログを使用できません。

      • アクティブな In-Sight ビジョンシステムがオンラインになっている

      • ユーザのアクセスレベルがロックである

    • プロテクトアクセスレベルのユーザは、ユーザリストでその特定ユーザに FTP 読み出し権限が与えられている場合にのみ、[開く] ダイアログを使用できます。
    • In-Sight ビジョンシステム (カラービジョンシステムを除く) は、最後に取り込んだ画像を低解像度画像として出力できます。個別の FTP 接続から FTP コマンドの get [ファイル名] を使用することによって、低解像度画像を image2.bmp (1/2 の高さ × 1/2 の幅) または image4.bmp (1/4 の高さ × 1/4 の幅) として入手できます。例えば、FTP コマンドラインから get image2.bmp と入力します。

画像を保存する

[画像に名前を付けて保存] ダイアログを使用すると、In-Sight ビジョンシステムのアクティブな画像を、後で取得するために保存することができます。画像は、ビットマップ (*.BMP) または JPEG (*.JPG) フォーマットで、任意の In-Sight ビジョンシステムまたはエミュレータに保存できます。

注 : 画像を In-Sight ビジョンシステムに保存すると、その画像が、デバイス上の image.bmp と置き換えられてアクティブな画像になります。画像ファイルの別名は、In-Sight ビジョンシステムではサポートされていません。ただし、In-Sight エミュレータでは、画像ファイルの別名が許されます。この場合、画像を保存できる容量は、PC のハードディスクの容量に基づきます。

画像ファイルを In-Sight ビジョンシステムに保存するには

  1. [ファイル] メニューで、[画像に名前を付けて保存] をクリックします。

  2. 画像の保存先 In-Sight ビジョンシステムを選択します。開く画像ファイルが格納されている場所を選択します。[ファイルの場所] ドロップダウンリストには、ローカル PC 上のドライブ、ネットワークドライブ、ローカルサブネット上で検出された In-Sight ビジョンシステムとエミュレータ (SD カードフォルダを含む)、および Explorer のホストテーブルで定義されているすべてのデバイスが含まれています。In-Sight ビジョンシステムの SD カードフォルダを選択するには、まず、目的の SD カードフォルダがある In-Sight ビジョンシステムをクリックして、表示された「SDCARD」フォルダをダブルクリックします。
  3. 画像を新規ファイルとして保存するには、[ファイル名] テキストボックスに名前を入力し、[保存] をクリックします。既存のファイルに上書き保存するには、そのファイルをリストから選択して、[保存] をクリックします。
注 :
  • 画像ファイル名の最大長は 251 文字です (.BMP または .JPG 拡張子以外)。
  • ファイル名に、/ : , ; * ? " < > | % の各文字を含めることはできません。
  • オンラインモード時に自動的に画像を保存するには、スプレッドシートに WriteImageFTP 関数を挿入します。
  • 次の場合は、[名前を付けて保存] ダイアログを使用できません。

    • アクティブな In-Sight ビジョンシステムがオンラインになっている

    • ユーザのアクセスレベルがロックである

  • プロテクトアクセスレベルのユーザは、ユーザリストでその特定のユーザに FTP 書き込み権限が与えられている場合にのみ、[名前を付けて保存] ダイアログを使用できます。


[セルの挿入] ダイアログ

[セルの挿入] ダイアログを使用して、1 つのセル、一定範囲のセル、新しい行または新しい列をスプレッドシートに追加します。

[セルの挿入] ダイアログを表示するには

  1. 新しいセル、一定範囲のセル、新しい行または新しい列を挿入する 1 つのセルまたは一定範囲のセルをクリックします。

  2. [挿入] メニューで、[セル] をクリックします。または、追加のセル、行、または列を挿入するセルを右クリックし、ショートカットメニューから [挿入] を選択します。

  3. 追加のセル、行、または列の追加方法が決まったら、[OK] をクックしてそれらのセル、行、または列を挿入します。

[セルの挿入] ダイアログの設定項目

  • [セルを右にシフト]: 選択したセルの左側に新しいセルを挿入します。挿入しようとするセルと同じ数のセルを選択します。
  • [セルを下にシフト]: 選択したセルの上に新しいセルを挿入します。挿入しようとするセルと同じ数のセルを選択します。
  • [行全体]: セルの行全体を挿入します。新しい行を挿入しようとする行の直下の行のセルをクリックします。例えば、新しい行を行 5 の上に挿入するには、行 5 内のセルをクリックします。
  • [列全体]: セルの列全体を挿入します。新しい列を挿入しようとする列のすぐ右側の列のセルをクリックします。例えば、新しい列を列 B の左側に挿入するには、列 B 内のセルをクリックします。


[スタートアップ] ダイアログ

[スタートアップ] ダイアログでは、デフォルトのジョブやオンライン/オフラインステータスなど、In-Sight ビジョンシステムのジョブ関連の起動時オプションを指定します。ユーザ関連のスタートアップパラメータは [オプション] ダイアログで指定します。

注 :
  • 変更を有効にするには、In-Sight ビジョンシステムを手動で再起動する必要があります。同様に、[スタートアップ] の設定を有効にするには、[オプション] ダイアログで In-Sight エミュレータを無効にして再有効化する必要があります。
  • 指定したスタートアップジョブが存在しない場合でも、警告は表示されません (例えば、ジョブが削除されたり、名前が変更されたりした後)。
  • ジョブサーバに保存されたジョブは、デフォルトジョブとしても使用し、スタートアップ時にビジョンシステムに自動でロードできます。[ジョブサーバの設定] ダイアログを使用して、ジョブサーバを有効にしてください。

[スタートアップ] ダイアログを表示するには

  • [センサ] メニューで、[スタートアップ] をクリックします。

    ジョブサーバが有効な場合は、以下のダイアログが表示されます。

[スタートアップ] ダイアログの設定項目

  • [起動時にジョブをロード]: このチェックボックスをオンにすると、選択したジョブがスタートアップ時に自動的にロードされます。リストには、接続されているビジョンシステム/センサ、接続されているビジョンシステムに装着されている SD カード、またはエミュレータに保存されているジョブが含まれます。

  • [起動時にリモートからジョブをロード]: このチェックボックスをオンにすると、選択したジョブがスタートアップ時に自動的にロードされます。リストには、ジョブサーバに保存されているジョブが含まれます。

    注 :
    • このチェックボックスは、[ジョブサーバの設定] ダイアログでジョブサーバが有効化されている場合にのみ表示されます。
    • ジョブサーバを有効にすると、ジョブサーバ内に保存したジョブを選択できるようなります。ビジョンシステム上に保存したジョブをスタートアップ時にロードするには、ジョブサーバを無効にしてください。

  • [起動時にオンラインモードにする]: このチェックボックスをオンにすると、アクティブな In-Sight ビジョンシステム/センサがオンラインモードで起動します。

    注 : ロボットなどの外部デバイスが不意に作動するのを防止するための安全手段として、In-Sight ビジョンシステムでは、[オンライン] チェックボックスがオンの場合、ジョブのロード時に初期化画像を自動的に取得しません。このため、最初の取得トリガを受信するときに、通常のジョブの処理時間よりも処理に時間を要します。後続の画像は通常の速度で処理されます。


[ユーザアクセス設定] ダイアログ

[ユーザアクセス設定] ダイアログでは、In-Sight ビジョンシステムのセキュリティモードを設定します。

  • [ユーザアクセス設定] ダイアログの設定項目と使用方法
  • 関連項目

[ユーザアクセス設定] ダイアログの設定項目と使用方法

[ユーザアクセス設定] ダイアログでは、以前のリリースと同様に、In-Sight ビジョンシステムおよびエミュレータへのアクセスを許可されたユーザのアクセスレベルや、FTP の読み取り/書き込みの権限を維持管理します。[ユーザアクセス設定] によって、[ログオン/ログオフ] ダイアログから特定の In-Sight ビジョンシステムにログオンできるユーザ、およびユーザがアクティブジョブに加えることができる変更の種類が決まります。各 In-Sight ビジョンシステムは、ネットワーク上のほかのビジョンシステムから分離された独自のユーザリストを持ちます。したがって、あるビジョンシステムにアクセスする必要があるユーザは、既にそのビジョンシステムのユーザリストに登録されているユーザ名とパスワードを確認する必要があります。

注 :
  • すべての In-Sight ビジョンシステムには、あらかじめ admin、operator、monitor の 3 つのユーザ名が設定されています。これらのユーザには、それぞれ、フルアクセス、プロテクト、ロックのアクセスレベルが設定されています。
  • 1 つの In-Sight ビジョンシステムに登録できるユーザの数は最大 32 です。

[ユーザアクセス設定] ダイアログの表示

  • [センサ] メニューで、[ユーザアクセス設定] をクリックします。

[ユーザアクセス設定] ダイアログの設定項目

  • [名前]: ビジョンシステムへのログオンに使用されるユーザ名を指定します。
  • [アクセス]: ユーザのアクセスレベルを指定します。ユーザのアクセス許可を、フルアクセス、プロテクト、ロックという 3 つのレベルで詳細に設定することができます。

  • [表示]: [ジョブビュー] がスプレッドシートビューの場合に、正常にログオンした後に表示するビューを指定します。「標準」が指定されている場合は、ログオン後にスプレッドシートビューが表示されます。「カスタム」が指定されている場合は、ログオン後にカスタムビューが表示されます。

    注 :
    • フルアクセスレベルのユーザの場合は、初期ビューが指定されます。ログオンすると、そのユーザは、F6 を押すか、[ジョブの表示] ツールバーで [カスタムビュー] ボタンをクリックすることにより、スプレッドシートビューとカスタムビューを切り替えることができます。
    • アクセスレベルが「プロテクト」または「ロック」のユーザは、カスタムビューにのみアクセスできます。
  • [FTP 読]: FTP 読み取り権限を指定します。この権限によって、ユーザがビジョンシステムにジョブをロードできるかどうかを制御します。[はい] の場合、ユーザはジョブをロードできます。[いいえ] の場合、ユーザはジョブをロードできません。
  • [FTP 書]: FTP 書き込み権限を指定します。この権限によって、ユーザがビジョンシステムにジョブを保存できるかどうかを制御します。[はい] の場合、ユーザはジョブを保存できます。[いいえ] の場合、ユーザはジョブを保存できません。
  • [オンライン/オフライン]: ユーザがビジョンシステムのオンライン/オフラインステータスを変更できるかどうかを指定します。[有効] の場合、ユーザはビジョンシステムのオンライン/オフライン状態を切り替えることができます。[無効] の場合、ユーザはビジョンシステムのオンライン/オフライン状態を切り替えることができません。
  • [オンライン時にジョブ保存]: ビジョンシステムがオンラインのときに、ユーザがジョブを保存できるかどうかを指定します。[有効] の場合、ユーザはオンラインのときにジョブを保存できます。[無効] の場合、ユーザはオンラインのときはジョブを保存できません。

新しいユーザの作成

  1. [追加] をクリックします。

  2. [ユーザ名] フィールドに英数字文字列を入力します。
  3. 新しいユーザのパスワードを入力します。

  4. [パスワードの確認] フィールドにパスワードを再度入力します。

    注 : ユーザ名とパスワードの文字列は、15 文字を超える長さにすることはできません (ユーザ名は 1 ～ 15 文字、パスワードは 0 ～ 15 文字にする必要があります)。文字、数字、「_」、および「-」を使用できます。

  5. [アクセス] ドロップダウンリストをクリックして、新しいユーザのアクセスレベルを選択します。

    アクセスレベルは、設定変更が誤ってまたは無断で行われないように、現在のユーザに許可されるインタフェースの対話レベルを制御します。選択したアクセスレベルは、指定したユーザ名とパスワードで In-Sight Explorer にログオンすると有効になります。

    アクセスレベルには次の 3 種類があります。

    • [フルアクセス]: ユーザは In-Sight ビジョンシステムの全体に制限なくアクセスできます。すべてのジョブをロード、変更、保存することができ、すべてのメニュー項目を使用できます。デフォルトの admin ユーザアカウントのアクセスレベルは [フルアクセス] です。
    • [プロテクト]: ビジョンシステムに対するユーザのアクセスは制限されます。プロテクトモードでは、ライブビデオモードにアクセスし、ビジョンシステムのオンライン/オフラインステータスを切り替え (ユーザの [オンライン/オフライン切替可] 権限によって許可される場合)、ジョブを開くか保存し (ユーザの [FTP 読み取り/書き込み] 権限によって許可される場合)、[オプション] ダイアログからインタフェースの外観をカスタマイズできます。EasyBuilder ビューのプロテクトモードでは、ツールパラメータの編集はできますが、ツールの追加や削除はできません。スプレッドシートビューの場合、プロテクトモードでは、必ずスプレッドシートのカスタムビューが表示されます。プロテクトモードのユーザは、カスタムビューに表示されるオペレータ I/F 関数のすべての値を編集できますが、関数そのものに変更を加えることはできません。デフォルトの operator ユーザアカウントのアクセスレベルは [プロテクト] です。
    • [ロック]: このモードでは、アクセスは最も制限されます。モニタできるのは、現在の In-Sight ビジョンシステムの動作のみです。デフォルトの monitor ユーザアカウントのアクセスレベルは [ロック] です。

  6. 必要に応じて [ログオン時にカスタムビューを表示] チェックボックスをオフにし、[ジョブビュー] がスプレッドシートビューになっている場合には、正常にログオンした後にスプレッドシートビューが表示されるようにします。デフォルトでは、このチェックボックスはオンになっており、ログオン時にカスタムビューが表示されます。このチェックボックスは、選択したアクセスレベルが [プロテクト] または [ロック] のときには、常にグレーアウトされます。

    注 :
    • このチェックボックスは、デフォルトでは、事前設定された admin ユーザによってオフにされます。
    • このチェックボックスをオンにすると、[ユーザアクセス設定] ダイアログの [表示] 列に「カスタム」と表示されます。このチェックボックスをオフにすると、[ユーザアクセス設定] ダイアログの [表示] 列に「標準」と表示されます。
  7. 必要に応じて、[オンライン/オフライン切替可] チェックボックスをオフにして、プロテクトレベルのユーザに制限を加え、ビジョンシステムのオンライン/オフライン状態を切り替えることができないようにします。このチェックボックスは、選択したアクセスレベルがフルアクセスまたはロックのときには、常にグレーアウトされます。

  8. 必要に応じて、[オンラインでもジョブを保存] チェックボックスをオンにし、フルまたはプロテクトアクセス権限が与えられたユーザがオンライン時にジョブを保存できるようにします。このチェックボックスは、選択したアクセスレベルがロックのときにはグレーアウトされます。

    注 :
    • このチェックボックスをオンにすると、プロテクトアクセス権限を持つユーザは、FTP 書き込み権限がない場合でも、ジョブを保存することができます。

    • [オンラインでもジョブを保存] チェックボックスがオンのとき、最大限のトリガレートでジョブが実行された場合、ジョブの保存中にトリガが失敗することがあります。

  9. ユーザの FTP、読み取り、および書き込み権限を指定します。FTP 読み取り権限は In-Sight ビジョンシステムのジョブまたは画像ファイルを開く操作に適用され、FTP 書き込み権限は In-Sight ビジョンシステムにジョブまたは画像を保存する操作に適用されます。さらに、これらの権限は、ユーザがネットワーク上のリモート FTP クライアントから、アクティブな In-Sight システムにログオンを試みる際にも有効です。
  10. [OK] をクリックします。

既存ユーザの設定の変更

  1. リストのユーザをハイライトします。

  2. [編集] をクリックします。

  3. 必要に応じて、ユーザの設定を変更します。ユーザオプションの詳細については、前のセクション「新しいユーザの作成」を参照してください。

    注 :
    • admin ユーザのパスワードを変更した場合は、ビジョンシステムから一度ログオフし、新しいパスワードでログオンし直す必要があります。そうしないと、エラー が発生します。
    • admin のアクセスレベル、[オンライン/オフライン切替可] 権限、FTP 権限、およびユーザ名は変更できません。
    • [ログオン時にカスタムビューを表示] チェックボックスの影響を受けるのは、スプレッドシートビューのみです。EasyBuilder はカスタムビューをサポートしていません。

ユーザの削除

  1. リストのユーザをハイライトします。

  2. [削除] をクリックします。

    ヒント : 複数のユーザを削除するには、Ctrl キーを押しながらユーザ名を選択します。

  3. 削除することを確認します。

    注 : admin ユーザは削除できません。


入出力データをフォーマットするには

個々のツールの結果またはジョブ全体の結果 (出力のみ) などの EasyBuilder のジョブデータを Ethernet/IP、DeviceNet、Modbus、TCP 、PROFINET および POWERLINK を介して通信することができます。 フォーマットされた入力データは、センサが画像を取り込み、ジョブを完了して出力データが送信された後に読み込まれます。

注 : DeviceNet、POWERLINK および CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムのみで使用可能です。In-Sight ファームウェア 5.1.0 以降をを搭載した In-Sight ビジョンシステムでは使用できません。 モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

データをフォーマットするには、次の手順に従ってください。

  1. [フォーマット入力データ] または [フォーマット出力データ] タブをクリックします。
  2. [追加] ボタンを押し、[入力データの選択] または [出力データの選択] ダイアログを開きます。
  3. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータ、およびジョブ全体の結果 (出力のみ) が含まれています。 In-Sight センサから送信 (または受信) するデータを選択し、[OK] ボタンを押してください。

  4. データを追加したら、[データ型] ドロップダウンリストを使用して、デフォルトのデータタイプを変更することができます。

    注 :
    • [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのバイト数] ドロップダウンリストが有効となり、バイト数を選択して文字列長を指定することができます。
    • PROFINET 使用時の最大入力および出力データ長は 4,000 バイトです。 POWERLINK 使用時の最大入力および出力データ長は 256 バイトです。

  5. [ハイバイト/ローバイト] チェックボックスを OFF にし、ローバイトを先にするように指定することによって、バイトオーダをカスタマイズすることができます。デフォルトでは、PROFINET を除き、OFF となります。 [ハイワード/ローワード] チェックボックスを OFF にし、ローワードを先にするように指定することによって、ワードオーダをカスタマイズすることができます。デフォルトでは、チェックボックスは OFF となります。[フォーマット出力データ] タブで変更を加えると、プレビューウィンドウが更新されます。

    注 : バイトオーダまたはワードオーダに関する変更は、[フォーマット出力データ] および [フォーマット入力データ] タブのすべてのデータ符号に影響します。
  6. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。


ラインスキャンの設定

[ラインスキャンの設定] ダイアログでは、ラインスキャンビジョンシステムのハードウェアエンコーダを設定します。また、このビジョンシステムの特定の診断値を表示します。

注 : 4 位相ハードウェアエンコーダを利用しているときに、ビジョンシステムが画像の取り込みを開始し、4 位相ハードウェアエンコーダが、反対方向に移動してフレームトリガの開始点を通過したという信号を出力した場合、取り込まれた画像は正常には生成されておらず、使用することはできません。 このような状況が発生した場合は、方向を反転したという信号を出力したときに、ビジョンシステムをオフラインにします。 次に、4 位相ハードウェアエンコーダが以前の方向に戻ったという信号を出力したときに、ビジョンシステムをオンラインに戻します。

  • [画像最大高]: ラインスキャンビジョンシステムにおいて、画像の生成に使用される最大行数および最大画像バッファ数を指定します。

    ビジョンシステム 画像最大高
    In-Sight 5604

    2048 (デフォルト)

    4096

    8192
    In-Sight 9902L

    2048

    4096 (デフォルト)

    8192

    12288

    16384
    注 :
    • ラインスキャンビジョンシステムの [画像最大高] の設定を変更するには、ビジョンシステムを再起動する必要があります。その結果、すべてのジョブおよび設定ファイルが不揮発性フラッシュメモリから消去されます。 続行する前に、ジョブを保存するかバックアップしてください。
    • 起動時にビジョンシステムに割り当てられる画像バッファのデフォルト数は、ビジョンシステムの解像度と RAM サイズによって異なります。 [画像最大高] の設定を調整すると、ビジョンシステムで利用可能な画像バッファの最大数が増加または減少します。 必要に応じて、[画像バッファ] ダイアログを使用し、起動時にビジョンシステムに割り当てる画像バッファの数を変更してください。

    • ラインスキャンビジョンシステムを使用する際、[位置決め] または [検査] ツールの領域の幅には、上限があります。 領域の幅を広げるには、スプレッドシートビューにアクセスし、数式バーに領域の値を手動で入力するか、あるいはコントロールまたは構造体関数を作成し、ツールの [領域] パラメータから参照する必要があります。

      ビジョンシステム | 解像度 | 画像最大高 | プロパティシートの最大幅
      In-Sight 5604 | 1024 ✕ 8192 | 8192 | 3072
      In-Sight 9902L 2048 ✕ 16384

      8192 以上

               6144
      1024 ✕ 16384 | 4096 以上 | 3072
  • [ハードウェアエンコーダ]
    注 : [エンコーダタイプ] または [方向] を変更するには、[画像の設定] アプリケーションステップの [ライントリガタイプ] パラメータを [ハードウァアエンコーダ] に設定し、ラインスキャンビジョンシステムをオフラインにし、ユーザはフルアクセスのアクセス権を持っている必要があります。

    • [エンコーダタイプ]: ラインをトリガするために使用されるエンコーダのタイプとして、[単位相] (デフォルト) または [4 位相] を指定します。

      注 :
      • エンコーダタイプを [単位相] に設定した場合、単位相ラインエンコーダを 1 番目のエンコーダ入力に配線する必要があります。2 番目の入力にラインを接続しても、動作しません。
      • [4 位相] エンコーダは、方向に関する情報を提供し、2 点の高速入力が必要です。

    • [方向]: [4 位相] エンコーダの方向を指定します。選択肢は、[プラス] (デフォルト) または [マイナス] になります。 ラインスキャンビジョンシステムは [方向] を使用して、正しい操作方向を決定します。 逆方向のステップは無効とみなされ、現在のフレームは破棄されてしまいます。

      注 : このコントロールは、[エンコーダタイプ] に [単位相] が設定されている場合には無効化されます。
  • [診断]
    • [エンコーダ数]: エンコーダのステップ数 (ソフトウェアエンコーダの場合はミリ秒) を表示します。
    • [ライン数]: カウンタが前回リセットされてから現在までに実行された画像取り込みライン数の合計を表示します。
    • [ラインオーバラップ数]: エンコーダレートが大きすぎたために失われたラインの数を表示します。
    • [バッファオーバラン数]: ラインスキャンビジョンシステムで画像バッファが不足した回数を表示します。
    • [フレーム/秒]: 1 秒あたりに取り込まれたフレームの数を表示します。

    • [ステップ/秒]: 1 秒間に外部エンコーダから受信するステップの数を表示します。

      注 : ソフトウェアエンコーダが使用されている場合、1 秒間のマイクロ秒数を表示します。

    • [リセット] ボタン: すべての診断統計情報を 0 にリセットします。

      注 : 診断統計は、[リセット] ボタンをクリックしたとき、またはビジョンシステムがオンラインまたはオフラインに切り替わったときに、リセットされます。
  • 1K 解像度 (低照明モード): 解像度が減少し、照明感度が向上します。 このオプションは、In-Sight 9902L ビジョンシステムのみでサポートされています。


キャリパアレイ

キャリパアレイは、1D カーネルを用いて各キャリパ内のエッジピークを検出するエッジモデルメソッドを使用し、画像領域内のエッジ成分を検出します。キャリパアレイは、検査対象エッジを含む画像の一部分を 1D で表示しますが、この 1D 画像には、検査対象エッジだけでなく、オリジナルの画像中のノイズやその他の不必要な情報が含まれています。キャリパアレイを使用して、1D 画像にツールの [エッジ] タブの [キャリパサイズ]、[エッジ幅] および [最小コントラスト] パラメータを適用することによって、検査対象エッジの強度を増し、同時に画像中のノイズを軽減します。

アレイ中の各キャリパは個別に評価され、エッジ候補を得点化して、どのエッジを選択するかを決定します。位置欠陥では、検出エッジに基づいて最適ラインを作成し、指定許容範囲外のばらつきに対し、検出エッジと最適ラインを比較して、欠陥を決定します。幅欠陥では、キャリパ内で検出された 2 つのエッジ間の距離を計算して、その距離を決定し、その距離と許容範囲を比較して欠陥を決定します。

領域内のキャリパアレイは、検出可能な欠陥/ギャップのサイズを定義します。検出可能な欠陥またはギャップのサイズは、検出可能なエッジ数によって決定されますが、その数はエッジ上に位置するキャリパ数によって決定されます。[すべてのキャリパを表示] チェックボックスを ON にすると (デフォルトは、OFF)、領域内のキャリパは赤の矩形として表示されます。

注 : 領域内のキャリパ数が多いほど、ツールの実行時間が増大します。


カラーモデルを追加、編集するには

カラーモデルは、画像内の対象物と背景を定義するために使用するカラーの集合です。各カラーモデルは 3 次元色空間を表しています。カラーモデルに対し、取り込む対象物および背景のカラーの RGB 値を加算または減算します。

閉じた カラーモデルを追加する
  1. [設定] タブの [カラーライブラリ] ドロップダウンリストからカラーライブラリを選択します。デフォルトでは、[ExtractColorLibrary_1] が、選択されています。
  2. [カラーの登録] ボタンを押して、[ExtractColor 登録] ダイアログを開きます。
  3. [ExtractColor 登録] ダイアログ、[カラーモデル] グループボックスの、[新規モデル] ボタンを押して、新しいカラーモデルをカラーライブラリに追加します。ツールのデフォルト名は モデル_1 で、末尾の番号はツールに応じて増加します。
  4. 複数のカラーモデルが追加される場合など、必要に応じて、カラーモデル名を変更します。カラーモデルの名前は、該当するカラーモデルをハイライトし、[ライブラリ] リストの上にある名前変更ボタンをクリックすることで、いつでも変更できます。
  5. 必要に応じて、カラーモデルをハイライトし、モデルの削除ボタンをクリックして、カラーモデルを削除できます。
閉じた カラーモデルにカラーを加算または減算する
閉じた カラーモデルに単一のカラーを加算または減算する
  1. 変更するカラーモデルを選択します。
  2. [登録] グループボックスから、[最大ドミナントカラー] を選択します (デフォルト設定)。
  3. [登録] グループボックスから、カラーの定義に使用する領域タイプを選択します。選択肢は、領域、円、ドーナツ領域、ポリゴンまたはフリーハンドです。
  4. [加色の作成] または [減色の作成] ボタンを押し、加算または減算する RGB 値のみが含まれるように、画像内に領域を設定します。
  5. 領域を設定したら、領域をダブルクリックするか、またはジョブの編集ツールバーで [OK] ボタンを押します。
  6. カラーの [追加] 操作では、カラーモデルに加算されたカラーに、領域内のピーク RGB 値が含まれます。また、その値はカラーモデルに累積的に追加されます。
  7. カラーの [減算] 操作では、カラーモデルに加算されたカラーに、領域内のピーク RGB 値が含まれます。また、その値はカラーモデルから累積的に減算されます。
  8. カラーモデル内の色の適用順序を変更できます。リストの上にあるカラーから順に検査に使用されます。
閉じた カラーモデルに複数のカラーを加算または減算する
  1. 変更するカラーモデルを選択します。
  2. [登録] グループボックスから、[マルチカラー] を選択します。
  3. [登録] グループボックスから、カラーの定義に使用する領域タイプを選択します。選択肢は、領域、円、ドーナツ領域、ポリゴンまたはフリーハンドです。
  4. [加色の作成] または [減色の作成] ボタンを押し、加算または減算する RGB 値のみが含まれるように、画像内に領域を設定します。
  5. 領域を設定したら、領域をダブルクリックするか、またはジョブの編集ツールバーで [OK] ボタンを押します。
  6. カラーの [追加] 操作では、カラーモデルに加算されたカラーに、領域内のピーク RGB 値が含まれます。また、その値はカラーモデルに累積的に追加されます。
  7. カラーの [減算] 操作では、カラーモデルに加算されたカラーに、領域内のピーク RGB 値が含まれます。また、その値はカラーモデルから累積的に減算されます。
  8. カラーモデル内の色の適用順序を変更できます。リストの上にあるカラーから順に検査に使用されます。
閉じた [カラー許容値] を調整する

[ExtractColor 登録] ダイアログの[カラー許容値] コントロールとともに [画像マーク] コントロールを使用して、対象物がどの程度検出されるかを決定したり、[カラー許容値] コントロールの [暗]、[明]、[ハイライト]、および [色相] の設定値を使用して、感度を増減したりすることができます。

ヒント: [カラー許容値] コントロールを設定する際には、画像がよく表示されるように [ExtractColor 登録] ダイアログを配置してください。コントロールを調整すると、[画像マーク] で選択したタイプに基づき、変更を反映して画像が更新されます。

閉じた [カラー許容値] コントロール
閉じた 暗

この設定値を大きくすると、黒 (0,0,0) の方向に色空間が加算されます。

閉じた 明

この設定値を大きくすると、白 (255,255,255) の方向に色空間が加算されます。

閉じた ハイライト

この設定値を大きくすると、最初の色の位置から白 (255,255,255) の方向に色空間が加算されます。

閉じた 色相

この設定値を大きくすると、色の 3 次元「ボックス」が色空間の 3 方向に大きくなります。

閉じた [画像マーク] コントロール

[画像マーク] ボタンを使用して、カラーおよびカラーモデルを追加/減算したときに画像内の何をハイライトするかを設定できます。

閉じた すべてのモデルの結果をマーク

カラーモデルのすべての色が画像内でマークされます。

閉じた 選択したカラーまでの結果をマーク

3 つのカラーがあるリストの 2 番目のカラーを選択すると、最初のカラーと 2 番目のカラーが画像内でマークされます。

閉じた 選択したカラーのみをマーク

選択したカラーのみが画像内でマークされます。

閉じた カラーモデルを編集する
  1. [設定] タブの [カラーライブラリ] ドロップダウンリストからカラーライブラリを選択します。
  2. [カラーの登録] ボタンを押して、[ExtractColor 登録] ダイアログを開きます。
  3. 変更するカラーモデルを選択し、ダイアログのコントロールを使用してカラーモデルを編集します。


カラーを追加、編集するには

カラーは領域によって定義され、登録時に領域内に含まれる平均 RGB および HSI 値を保存します。 ライブラリには、検査対象物の RGB/HSI 値によって構成される 100 個までの異なるカラーを含むことができます。

閉じた カラーを追加する
  1. [設定] タブの [カラーライブラリ] ドロップダウンリストからカラーライブラリを選択します。 デフォルトでは、[MatchColorLibrary_1] が、選択されています。
  2. [カラーの登録] ボタンを押して、[MatchColor 登録] ダイアログを開きます。
  3. [登録] グループボックスから、カラーの定義に使用する領域タイプを選択します。選択肢は、領域、円、ドーナツ領域、ポリゴン、フリーハンドで描画または点です。
  4. [加色の作成] ボタンを押し、加算または RGB 値のみが含まれるように、画像内に領域を設定します。
  5. 領域を設定したら、領域をダブルクリックするか、またはジョブの編集ツールバーで [OK] ボタンを押します。
  6. 複数のカラーモデルが追加される場合など、必要に応じて、カラーモデル名を変更します。 カラーの名前は、該当するカラーモデルをハイライトし、[カラーライブラリ] リストの上にある名前変更ボタンをクリックすることで、いつでも変更できます。
  7. 必要に応じて、カラーをハイライトし、カラーの削除ボタンをクリックして、カラーを削除できます。
閉じた カラーの [カラー許容値] を調整する

[MatchColor 登録] ダイアログの [カラー許容値] コントロールを使用して、対象物がどの程度検出されるかを決定したり、[カラー許容値] コントロールの設定値を使用して、感度を増減したりすることができます。

ヒント: [カラー許容値] コントロールを設定する際には、画像がよく表示されるように [MatchColor 登録] ダイアログを配置してください。 コントロールを調整すると、変更を反映して画像が更新されます。

閉じた 暗

暗限界を指定します (0～1.0、デフォルトは 1.0) 。 [色空間] を [RGB] に設定した場合、[暗] の範囲を拡大すると、登録されるカラーは (0,0,0) から登録される色の RGB 値までの線に沿って比的に低くなります。 [色空間] が [HSI] に設定されている場合、[暗] の範囲を拡大すると、登録されるカラーの明度が小さくなります。

閉じた 明

明限界を指定します (1.0～10.0、デフォルトは 1.0) 。 [色空間] を [RGB] に設定した場合、[明] の範囲を拡大すると、登録されるカラーは (0,0,0) から登録される色の RGB 値までの線に沿って比的に高くなります。 [色空間] が [HSI] に設定されている場合、[明] の範囲を拡大すると、登録されるカラーの明度が大きくなります。

閉じた カラーモデルを編集する
  1. [設定] タブの [カラーライブラリ] ドロップダウンリストからカラーライブラリを選択します。
  2. [カラーの登録] ボタンを押して、[ExtractColor 登録] ダイアログを開きます。
  3. 変更するカラーモデルを選択し、ダイアログのコントロールを使用してカラーモデルを編集します。


エッジ候補

キャリパアレイを内蔵したツールを使用している場合、エッジ候補はカラーコード化された小さな円で表示されます。

閉じた 例 - 直線最適ライン (PASS)

閉じた 例 - 直線最適ライン (FAIL)

閉じた 例 - 円状最適ライン (FAIL)


[設定] タブ (シャープネス有無判定ツール)

閉じた スムーズネス

領域内に存在する高周波ノイズを除去する、画像平滑化処理を定義します (0～2; デフォルト = 0)。この値を 0 に設定すると、平滑化は実行されず、処理時間は最速となります。1 に設定すると、平滑化が適用され、領域内の非常に高い周波数のノイズを除去します。2 に設定すると、さらにレベルの高い平滑化が実行され、領域内の高周波ノイズおよび非常に高い周波数のノイズを除去します。


EasyBuilder のサンプルジョブとサンプル画像

EasyBuilder のサンプルジョブとサンプル画像の概要

EasyBuilder には、複数のサンプルジョブと、これに対応するサンプル画像が含まれます。これらのサンプルジョブは、EasyBuilder の検査ツールを使用して実際の応用事例を解決する方法を示します。想定される応用事例を幅広く網羅した EasyBuilder サンプルジョブは、特定の状況で位置決めツール、および検査ツールを使用する方法の有用な例を提供し、フィクスチャツールの検索や使用方式を最適化するために領域グラフィックスを配置する方法を示します。

EasyBuilder サンプルジョブには、[記録/再生のオプション] の有用性を表した例も用意されています。[記録/再生のオプション] によって、あらかじめ取り込んでおいた複数の画像を繰り返し使用できるようになり、ツールの結果を即座にフィードバックし、しきい値や制限を簡単に設定できるようになります。マシンビジョンアプリケーションを設計するときは、検査における「良い」画像と「悪い」画像の例となる多数の画像を広い範囲にわたって取り込んでおくことが理想的です。その後で、「良い」画像を中心に応用事例を設計し、そのほかの画像は許容可能な値の範囲を確立する手段として使用します。

EasyBuilder サンプルジョブのロード

EasyBuilder サンプルジョブを使用するには、サンプルジョブと、それに付随する画像をロードする必要があります。

  1. [接続] ステップから、ローカルエミュレータ、または In-Sight センサに接続します。[ジョブのロード] セクションの [ジョブを開く] ボタンをクリックします。

  2. [開く] ダイアログから In-Sight Explorer EasyBuilder の Sample Jobs ディレクトリに移動し、ロードするサンプルジョブを選択します。

    注 :

    標準ユーザがアクセスできるようにするため、In-Sight Explorer 4.5.0 以降では、Sample Job のデフォルトフォルダの場所は Program Files フォルダから次の場所に変更されています。

    • Windows 7/Windows 10: C:\Users\Public\Documents\Cognex\In-Sight\In-Sight Explorer x.x.x
  3. サンプルジョブをロードしたら、次に対応するサンプル画像をロードする必要があります。

EasyBuilder サンプル画像のロード

サンプルジョブに対応するサンプル画像のロードを開始するには次の 2 つの方法があります。

  • オプション 1: [EasyBuilder] ツールバーの [image] アイコンをクリックします。[記録/再生のオプション] ダイアログが表示されます。
  • オプション 2: [画像の設定] ステップをクリックし、[画像取り込み/ロード] セクションの [PC から画像をロード] ボタンを押します。この方法でも、[記録/再生のオプション] ダイアログが表示されます。
  1. [記録/再生のオプション] ダイアログは、自動的に [再生] タブが表示された状態で開きます。表示されていない場合は、[再生] タブをクリックします。
  2. [再生フォルダ] セクションで [参照] ボタンをクリックし、[フォルダの参照] ダイアログを表示します。[Sample Jobs] → [EasyBuilder] ディレクトリに移動し、サンプルジョブをロードしたときに指定したフォルダを選択します。[OK] ボタンをクリックして続行します。
  3. [再生フォルダ] には指定したディレクトリが表示されます。[画像カウント] はこのディレクトリに保存されている画像の数を示しています。[記録/再生のオプション] ダイアログの [OK] ボタンをクリックして、続行します。
  4. サンプルジョブとサンプル画像を揃えたら、[ジョブの実行] ステップに移動し、[EasyBuilder] ツールバーの [image] ボタンをクリックして、検査ツールの実行を観察するか、または [位置決め] または [検査] ステップに移動して、その応用事例でツールがどのように変更されているかを確認します。


EasyBuilder ジョブおよびスプレッドシート

スプレッドシートでの EasyBuilder ジョブの編集ラウンドトリップアプリケーション開発

ラウンドトリップアプリケーション開発とは、In-Sight Explorer の EasyBuilder とスプレッドシートの両開発環境でマシンビジョンアプリケーションをビルドするプロセスのことを指します。EasyBuilder 環境で開始されたジョブは、スプレッドシート環境で編集することができ、これにより EasyBuilder インタフェースに表示されるパラメータをカスタマイズすることができます。例えば、位置決めツールと検査ツールのパラメータを追加、削除または名前変更したり、スプレッドシート環境でのみ使用可能な追加のロジックと機能を追加して EasyBuilder ジョブを強化したりすることが可能です。

注 : In-Sight ビジョンシステムによっては、スプレッドシートにアクセスできなかったり、スプレッドシート環境で変更された EasyBuilder ジョブをロードできなかったりする場合があります。EasyBuilder 環境で開発されたジョブをスプレッドシート環境で編集する場合、このジョブは、EasyBuilder のみの In-Sight ビジョンシステム/センサに展開できません。

EasyBuilder とスプレッドシート

EasyBuilder 環境でジョブが作成および開発されると、同時に EasyBuilder 固有のスプレッドシートが作成され、EasyBuilder スニペットによってプログラムされます。事前設定され、空間的に定義され、論理的に統合された In-Sight の関数と、特定のタスクを実行する EasyBuilder タグおよびラベルによるグループで、セルデータ (.CXD) ファイルとして保存されます。 EasyBuilder スニペットEasyBuilder スニペットは、EasyBuilder 環境のアプリケーションステップに追加されて設定される機能に相当します。

EasyBuilder 互換スプレッドシートは特定のフォーマットに適合しており、EasyBuilder スニペットの 3 つの垂直セクションで構成されています。

  • セルの列 A ～ H が最初の垂直セクションを形成し、[画像の設定] ステップでの画像取得設定のための EasyBuilder スニペットと、EasyBuilder に追加される位置決めツールと検査ツール用の EasyBuilder スニペットが格納されます。
  • セルの列 J ～ Q は 2 番目の垂直セクションを形成します。この列は通常、最初の列に値が取り込まれていない限り空になっています。この列は、その時点で、EasyBuilder の位置決めツールと検査ツールのスニペットで使用されます。
  • セルの列 S ～ Z は最後の 3 番目のセクションを形成し、全体的なジョブの PASS/FAIL の結果を求める EasyBuilder スニペット、[入力] ステップと [出力] ステップ、[画像の設定] でのキャリブレーション、および [通信] ステップが格納されます。

すべての EasyBuilder スニペットは 8 列以下の列を占めるようにフォーマットされ、3 つの垂直セクションのいずれかに挿入されます。位置決めツールまたは検査ツールが EasyBuilder 環境内のジョブに追加されると、スプレッドシート内の使用可能なスペースに基づいて、対応する EasyBuilder スニペットが EasyBuilder 固有のスプレッドシートに自動的に追加されます。

例えば、ブロブ計数ツールが EasyBuilder 開発環境のジョブに追加されると、スプレッドシート内の使用可能なスペースに基づき、スプレッドシートの最初のセクション (列 A　～ H) か 2 番目のセクション (列 J ～ Q) のどちらかに、EasyBuilder スニペットファイル BlobCount.cxd が自動的に追加されます。

例 - EasyBuilder BlobCount スニペット

EasyBuilder スニペットでは、スニペット内の個々のセルと、ほかの EasyBuilder スニペットのセルの両方の間の絶対セル参照も保持されます。このセル間の空間関係は、セル実行順序を関連付けることと、EasyBuilder 環境でのテキストラベルと表示パラメータの表示順を決めることの両方の働きを持つメカニズムとして利用されます。EasyBuilder スニペットは、左から右に1 行ずつスキャンされ、セルはスニペット内での配置に基づいて個々に実行されます。

例えば、EasyBuilder スニペットファイル BlobCount.cxd では、オペレータ I/F 関数の上の行と下の行のテキストラベル間の空間関係に基づいて、EasyBuilder 環境で表示されるパラメータの名前とコントロールが作成されます。

例 - スプレッドシートビューと EasyBuilder ビュー

EasyBuilder ツールのスニペット構造体

EasyBuilder ツールのスニペットは、EasyBuilder 環境で位置決めツールと検査ツールをビルドするために使用されます。EasyBuilder ツールのスニペットは、スプレッドシート環境から In-Sight のビジョンツール関数のパラメータを表示し、それらのパラメータを EasyBuilder 環境で容易に設定できるようにしています。

EasyBuilder ツールのスニペットは、ツールの複雑さに応じて、さまざまな行数で 8 列以内に収まるようにフォーマットされます。スニペットに含まれる In-Sight の関数および EasyBuilder タグとラベルは、条件付きで有効にされ、スニペット内のセル間の特定の空間関係に依存しています。

例 - EasyBuilder エッジ位置決めツール - EdgeLocation スニペット

例 -EdgeLocation スニペット EnabledStatus セル依存関係

EasyBuilder タグとタグラベル

EasyBuilder タグにより、GUI フォーマットとセル参照のデータが EasyBuilder 環境に提供され、EasyBuilder タグラベルにより、EasyBuilder 環境で表示されるテキストが提供されるか、スプレッドシートでの EasyBuilder タグが示されます。EasyBuilder タグが付いていることは、セルの左下隅に表示される緑の三角形のコメントインジケータによって示されます。また、マウスにより表示されるツールチップが含まれます。

例 - EasyBuilder タグとテキストラベルのセル

EasyBuilder タグのセルは特定のシンタックスに準拠しており、1 つのセル、または事前定義された相互の空間関係を保持する必要があるセルグループを意味します。例えば、EasyBuilder タグ Input:Fixture は、必ず 3 つの連続するセル (EasyBuilder のタグラベル [行]、[列]、および [角度] の行の下) の行で構成される必要があり、これにより EasyBuilder 環境における X、Y、および Angle データが関連付けられます。セルの空間関係を変更したり、特定のセルを削除したりすると、ジョブで予期せぬ動作が引き起こされる可能性があります。

位置決めツールまたは検査ツールが EasyBuilder ジョブに追加されると、EasyBuilder アプリケーションでは、ツールの動作と EasyBuilder 環境で表示される項目を定義する、EasyBuilder タグおよびテキストラベルのセルの EasyBuilder スプレッドシートを解析します。EasyBuilder タグのセルは、ツールのスニペット内のほかの EasyBuilder タグのセル間のセル参照も意味し、さらにジョブ内のほかの EasyBuilder スニペットへのリンクも意味します。例えば、EasyBuilder ツールのスニペットは、EasyBuilder タグのセルを介して、フィクスチャ、キャリブレーション、および全体的な PASS/FAIL ステータスデータを管理します。

In-Sight ビジョンツールの関数

ビジョン処理アルゴリズムを提供する In-Sight ビジョンツールの関数は、EasyBuilder 開発環境における位置決めツールと検査ツールの中核機能です。ほとんどの In-Sight ビジョンツールの関数は、関数のパラメータに含まれる複雑で動的な引数に依存しているため、これらの数式は編集しないことをお勧めします。

例 - EdgeLocation スニペットの FindLine セル依存関係と FindLine プロパティシート

ツールのパラメータ

オペレータ I/F 関数は、In-Sight ビジョンツール関数やほかの In-Sight 関数のプロパティシートのパラメータとリンクされており、これにより、EasyBuilder 環境における位置決めツールと検査ツールのコントロールパラメータが決まります。EasyBuilder 環境で表示されるパラメータは、6 つのオペレータ I/F 関数のいずれか 1 つのすぐ上にあるツールパラメータラベルによって示されます。

  • Button 関数: EasyBuilder 環境でボタンコントロールを表示します。
  • CheckBox 関数: EasyBuilder 環境でチェックボックスコントロールを表示します。
  • EditFloat 関数: EasyBuilder 環境で整数編集コントロールを表示します。
  • EditInt 関数: EasyBuilder 環境で浮動小数点数編集コントロールを表示します。
  • EditString 関数: EasyBuilder 環境でテキスト編集コントロールを表示します。
  • ListBox 関数: EasyBuilder 環境でドロップダウンリストボックスコントロールを表示します。

オペレータ I/F 関数は、In-Sight ビジョンツール関数やほかの In-Sight 関数のプロパティシートのパラメータと相関しています。通常は、スプレッドシートでの絶対セル参照を介して別の入力パラメータにリンクされています。別の状況では、オペレータ I/F 関数がいくつかの関数のパラメータにリンクされていたり、EasyBuilder の位置決めツールまたは検査ツールに追加のロジックを提供するために含められていたりすることもあります。EasyBuilder 開発環境で正常に表示されるためには、オペレータ I/F 関数のすぐ上のセルにツールパラメータラベルを入力する必要があります (テキストの入力前にアポストロフィ (') を入力します)。

例えば、エッジ位置決めツールのエッジコントラストコントロールの場合は、EditInt 関数のすぐ上に「Edge Contrast (エッジコントラスト)」というツールパラメータラベルがあります。このラベルは、FindLine 関数の AcceptThresh パラメータへの絶対セル参照として設定されています。

例 - オペレータ I/F 関数と EasyBuilder パラメータコントロール

表示されるグラフィックスと対象領域

EasyBuilder 環境における対象領域グラフィックスと検出された特徴の表示方法を定義するオペレータ I/F 関数。EasyBuilder の各位置決めツールと検査ツールには領域 (円形または矩形) があり、EditAnnulus または EditRegion 関数を使用して領域の形状を定義します。各円形領域は、EditAnnulus 関数で構成され、その後に、行、列、内側の半径および外側の半径を定義するセルが続きます (これらのセルは、正常に機能するためには、常にこの順序で表示される必要があります)。各矩形領域は、EditRegion 関数で構成され、その後に、行、列、高さ、幅、角度およびカーブのデータを定義するセルが続きます (これらのセルは、正常に機能するためには、常にこの順序で表示される必要があります)。

例 - オペレータ I/F 関数と表示される EasyBuilder のグラフィックス

スプレッドシートでの EasyBuilder ツールパラメータの追加、削除および名前変更

EasyBuilder ツールのスニペットはさまざまな In-Sight 関数で構成され、それらの関数のいくつかには、デフォルトで、EasyBuilder 開発環境では表示されない追加機能が含まれています。これらの追加パラメータは、スプレッドシート環境内で設定することによって、EasyBuilder 環境で有効にして表示することができます。

ヒント : プロパティシートのパラメータは、設定項目をドラッグ & ドロップして、スプレッドシートに配置することができます。プロパティシートからパラメータを選択してから、それをスプレッドシートにドラッグすることによって、パラメータのラベルとエディットコントロールが自動的に作成され、スプレッドシートで参照できるようになります。例えば、ExtractBlobs 関数のプロパティシートが開いている場合に、[しきい値] パラメータをスプレッドシートのセル A2 にドラッグ & ドロップすると、セル A2 に「Threshold (しきい値)」というテキストが入力され、セル A3 に EditInt 関数が入力されます。この場合、ExtractBlobs 関数のプロパティシートにある [しきい値] パラメータが、自動的にセル A3 への絶対参照として設定されます。

スプレッドシートで EasyBuilder ジョブを編集する場合の重要な指針

行を追加または削除するときには、個々のセルをクリックして、[挿入] メニューで [セル] を選択するか、右クリックメニューを使用して [挿入] または [削除] を選択します。これによりそれぞれ、[セルの挿入] ダイアログか [セルの削除] ダイアログが開かれます。必ず、2 つある [セルをシフト] オプションのいずれかを選択してください。

  • EasyBuilder スニペットには列を挿入しないでください。
  • スニペットから EasyBuilder のタグを削除しないでください。
  • 列 I または R には関数または数式を挿入しないでください。

これらのいずれかの操作を実行すると、依存関係が壊れ、EasyBuilder ジョブが正常に機能しなくなる可能性があります。

注 : スプレッドシート環境でジョブを編集するには、ユーザのアクセスレベルがフルアクセスに設定されている必要があります。デフォルトでは、スプレッドシート環境でジョブが誤って編集されるのを防止するため、EasyBuilder ジョブがロックされています。開始前に、[ファイル] メニューで [ジョブの保護を解除...] を選択してジョブの保護を解除してください。

EasyBuilder ツールのスニペットへのパラメータの追加

EasyBuilder のほとんどの位置決めツールと検査ツールには、オペレータ I/F 関数を追加し、次に新規作成されたコントロールをスプレッドシートの既存のプロパティシートパラメータまたはロジックにリンクすることによって追加のパラメータを表示する機能があります。スプレッドシートでのオペレータ I/F　関数の配置により、EasyBuilder 開発環境での表示順序が決まります。

注 : デフォルトでは、スプレッドシート環境でジョブが誤って編集されるのを防止するため、EasyBuilder ジョブがロックされています。開始前に、[ファイル] メニューで [ジョブの保護を解除...] を選択してジョブの保護を解除してください。

スプレッドシート環境で EasyBuilder の位置決めツールまたは検査ツールにパラメータを追加するには:

  1. [パレット] の [結果] タブでツールを右クリックして [Go to this tool in the Spreadsheet (スプレッドシート内のこのツールに移動)] を選択するか、または [表示] メニューで [スプレッドシート] を選択することにより、スプレッドシート環境内のツールに移動します。

    注 : EasyBuilder 環境の [パレット] の [結果] タブでツールがハイライト表示されている場合は、スプレッドシートでツールのスニペットがハイライト表示されます。

  2. 表示されるスプレッドシート関数のパラメータを識別し、パラメータのタイプに基づいてテキストラベルとオペレータ I/F 関数を追加します。各オペレータ I/F 関数では、その上のセルにテキストラベルが表示されている必要があります。ラベルは、EasyBuilder に対して、表示されているパラメータの「名前」と、EasyBuilder の設定ペインおよび [結果の設定] アプリケーションステップ に表示される項目 ([入力]、[出力]、および [通信]) を示します。例えば、エッジ位置決めツールは、EditInt 関数の上に「Edge Width (エッジ幅)」というテキストラベルを追加することによって、FindLine 関数の [エッジ幅] パラメータが表示されるように変更できます。

    注 : スニペットで新しいラベルとコントロールを挿入するため空のセルが不足している場合は、既存のラベルとコントロールを切り取り、追加の行を挿入して、切り取ったラベルとコントロールを新しく作成した領域に貼り付けます。列は挿入しないでください。ラベルのテキストを入力する場合には、テキストの前にアポストロフィ (') を忘れずに入力してください。
  3. 目的の関数のパラメータと新規作成したオペレータ I/F 関数の間の絶対セル参照を作成します。目的の関数のプロパティシートを開き、目的のパラメータを選択して、プロパティシートのツールバーで [絶対参照を挿入] ボタンをクリックします。これにより、セル選択モードに切り替わります。新規作成したオペレータ I/F 関数を選択し、[OK] ボタンをクリックして選択を確定します。
  4. オペレータ I/F 関数の [セル状態] を EasyBuilder タグの EnabledStatus セルに設定して、コントロールを条件付きで有効にします。コントロールは、EasyBuilder 環境で正常に機能して表示されるためには、条件付きで有効化され、この特定のセルへの絶対参照として設定される必要があります。
  5. オペレータ I/F 関数が格納されているセルをハイライト表示し、[編集] メニューから [セル状態] を選択します。これにより、[セル状態] ダイアログが開きます。
  6. [Conditionally Enabled (条件付きで有効化)] オプションを選択し、[Conditional Reference (条件付き参照)] を [絶対] に設定して、[セルの選択] ボタンをクリックします。これで、セル選択モードに切り替わります。「Enabled Status (有効化ステータス)」ラベルのセルの直下にある EasyBuilder タグの EnabledStatus セルを選択します。[OK] ボタンをクリックして選択を確定します。
  7. これで、EasyBuilder 開発環境に戻るときに、新しく追加したコントロールが有効になって表示されます。

例 - エッジ位置決めツールへの EdgeWidth パラメータの追加

この例では、EditInt 関数の上に「Edge Width (エッジ幅)」というテキストラベルを追加することによって、FindLine 関数の [エッジ幅] パラメータが表示されるようにエッジ位置決めツールに変更を加えます。

  1. EasyBuilder 開発環境において、[位置決め] アプリケーションステップ内で、エッジ位置決めツールを追加します。

  2. [パレット] の [結果] タブで、エッジ位置決めツールを右クリックし、[Go to this tool in the Spreadsheet (スプレッドシート内のこのツールに移動)] を選択します。

  3. エッジ位置決めツールには、オペレータ I/F 関数とツールパラメータラベルによる 2 行が含まれており、ツールパラメータラベル「Tool Enabled (ツール有効化)」で始まり、その下に ListBox 関数が配置されます。この例では、EasyBuilder 開発環境で表示される [エッジ幅] パラメータが [Edge Contrast (エッジコントラスト)] パラメータと [Edge Transition (エッジ移動)] パラメータの間に表示されるようにします。したがって、「Edge Contrast (エッジコントラスト)」ラベルと ListBox 関数の右側の 2 行のセルをハイライト表示し、8 個のセルを 1 列右側にカット & ペーストします。

  4. ツールパラメータラベル「Edge Contrast　(エッジコントラスト)」のセルの右側のセルに、「Edge Width (エッジ幅)」という名前でツールパラメータラベルを入力します (テキストを入力する前にアポストロフィ (') を使用します)。

  5. ツールパラメータラベルの下のセルに、右クリックメニューを使用して [関数の挿入] を選択するか、[挿入] メニューで [関数] を選択することによって EditInt 関数を挿入して、[関数の挿入] ダイアログを開きます。

  6. EditInt 関数を挿入すると、関数のプロパティシートが自動的に開きます。EditInt 関数の [最小] と [最大] のパラメータを 0 と 10 に設定し、[OK] ボタンをクリックして変更を確認します。

  7. スニペット内で ( [image] データ構造体によって示される) FindLine 関数を見つけ、そのセルをダブルクリックして関数のプロパティシートを開きます。

  8. FindLine プロパティシートで、EdgeWidth パラメータを選択して、プロパティシートのツールバーで [絶対参照を挿入] ボタンをクリックします。

  9. これによりセル選択モードが開始されるので、EditInt 関数が格納されているセルを選択します。セルをダブルクリックするか、または [ジョブの編集] ツールバーで [OK] ボタンをクリックして、選択を確定します。

  10. FindLine のプロパティシートが再表示されます。EdgeWidth パラメータには、EditInt 関数への絶対セル参照が表示されます。[OK] ボタンをクリックして変更を確定します。

  11. 最後に、FindLine 関数の EdgeWidth パラメータを制御している EditInt 関数は、ツールで実行するように条件付きで有効にされる必要があります。EditInt 関数を右クリックし、右クリックメニューから [セル状態] を選択して [セル状態] ダイアログを開きます。

  12. [セル状態] を [Conditionally Enabled (条件付きで有効化)] に設定し、[セルの選択] ボタンをクリックしてセル選択モードを開始します。

  13. EasyBuilder タグのセル「EnabledStatus」を選択します。セルをダブルクリックするか、または [ジョブの編集] ツールバーで [OK] ボタンをクリックして、選択を確定します。

  14. [セル状態] ダイアログが再び表示されます。[OK] ボタンをクリックして選択を確定します。

  15. EasyBuilder 開発環境に戻ります。ツールの [設定] タブに、[エッジ幅] パラメータが表示されます。

EasyBuilder ツールのスニペットからのパラメータの削除

一部のアプリケーションでは、EasyBuilder の位置決めツールまたは検査ツールにおいて、有効にするコントロールのサブセットの数を制限する必要があります。このような状況では、特定のコントロールを削除してツールを簡素化することができます。

スプレッドシート環境の EasyBuilder の位置決めツールまたは検査ツールからパラメータを削除するには:

  1. [パレット] の [結果] タブでツールを右クリックして [Go to this tool in the Spreadsheet (スプレッドシート内のこのツールに移動)] を選択するか、または [表示] メニューで [スプレッドシート] を選択することにより、スプレッドシート環境内のツールに移動します。

  2. 削除するパラメータのラベルおよびオペレータ I/F 関数が格納されているセルを選択します。ハイライト表示したセルを右クリックし、[コンテンツのクリア] オプションを選択します。

    注 : セルは削除しないでください。セルの位置がずれると依存関係が破れ、ジョブが正常に機能しなくなる可能性があります。
  3. これでセルが空になります。EasyBuilder 開発環境に戻っても、コントロールは表示されません。

EasyBuilder ツールのスニペットのパラメータ名の変更

EasyBuilder の位置決めツールと検査ツールのパラメータ名は、パラメータ名を変更することにより、アプリケーションとジョブに応じてカスタマイズ可能です。

スプレッドシート環境の EasyBuilder の位置決めツールまたは検査ツールからパラメータを削除するには:

  1. [パレット] の [結果] タブでツールを右クリックして [Go to this tool in the Spreadsheet (スプレッドシート内のこのツールに移動)] を選択するか、または [表示] メニューで [スプレッドシート] を選択することにより、スプレッドシート環境内のツールに移動します。
  2. 変更するテキストラベルのセルを選択し、[ジョブの編集] ツールバーの数式エディタに新しい名前を入力します。テキストの前からアポストロフィ (') を削除しないでください。削除すると、テキストラベルが EasyBuilder に認識されなくなります。
  3. これで、EasyBuilder 開発環境に戻ると、コントロールが新しい名前で表示されます。


ソフトウェアの登録

オフラインプログラミングキー

In-Sight Explorer がネットワークで In-Sight ビジョンシステムを検出しない場合、In-Sight ジョブを In-Sight のオフラインのエミュレータ環境でローカルに設定するために、[オプション] ダイアログでオフラインプログラミングキーを入力する必要があります。

注 :
  • いずれかのバージョンの PC Host 用のオフラインプログラミングラインセンスを購入済みの場合は、これらのライセンスを、In-Sight Explorer 用の有効なオフラインプログラミングキーとして使用できます。
  • オフラインプログラミングキーをまだ入力していない場合に、In-Sight Explorer を起動すると、Error 6001 または Error 6047 が表示されることがあります。


ローリングシャッターの操作

In-Sight 8405 ビジョンシステムには、画像線センサの露光を制御するための電子的なローリングシャッターが搭載されています。ビジョンシステムで画像取り込みトリガを受信すると、画像最上部の最初のピクセル行から始めて、画像最下部の最後のピクセル行に至るまで、ピクセル行が順番に露光されます。各ピクセル行は同じ時間露光されますが、各行の露光開始時刻は異なり、隣接する各行はオーバラップして露光されます。すべての行が露光されると、全画像の取り込みが完了し、ピクセル行がリセットされます。次の画像取り込みが開始されると、指定した露光時間の間、ピクセル行が再び読み出されます。

In-Sight 8405 ビジョンシステムの場合、[Row Reset (行のリセット)] 時間と [Row Readout (行の読み出し)] 時間は 36.38µ 秒です。次の数式を使用して、[Total Reset (総リセット)]、[Total Image Readout (全画像読み出し)]、[Total Runtime (総ランタイム)] を算出します。

タイミング | 数式
Total Reset (総リセット) | Row Reset (行のリセット) x (行数 -1)
Total Image Readout (全画像読み出し) | (Row Readout (行の読み出し) x 行数) + 360µ 秒
Total Runtime (総ランタイム) | 露光時間 + Total Image Readout (全画像読み出し)
注 :
  • 最適な画質を確保するには、画像取り込みの間、その部分が静止している必要があります。
  • 電子的なローリングシャッター動作のため、ライブビデオモードの場合には「ローリングライン」効果を見て確認できます。

出力の設定

ビジョンシステムの高速出力は、任意で、[画像取り込み開始] または [画像取り込み終了] の信号タイプとして設定できます。[画像取り込み開始] として設定されている場合は、最初のピクセル行が露光されるときに信号がパルス出力され、[画像取り込み終了] として設定されている場合には、[Total Image Readout (全画像読み出し)] の完了時にパルス出力されます。これらの信号のパルス幅は、[出力詳細] ダイアログで指定します。

ストロボを使用する場合は、システムの HS OUT 1 ラインを [ストロボ] 信号タイプとして設定可能です。[ストロボ] として設定されている場合、[出力詳細] の　[ストロボ開始位置] は [すべての行を露光] に固定され、すべてのピクセル行が露光されると、[Strobe Width (ストロボ幅)] の期間、出力信号がパルス出力されます。

In-Sight 8405 ビジョンシステムの場合、[Row Reset (行のリセット)] 時間は 36.38µ 秒です。次の数式を使用して、[Time to Strobe Start (ストロボ開始までの時間)] と [Strobe Width (ストロボ幅)] を算出します。

タイミング | 数式
Time to Strobe Start (ストロボ開始までの時間) | (Row Reset (行のリセット) x 行数) + 946µ 秒
Strobe Width (ストロボ幅) | 露光時間 - Time to Strobe Start (ストロボ開始までの時間)
注 : In-Sight 8405 でストロボを使用する場合は、露光時間を [Time to Strobe Start (ストロボ開始までの時間)] より長くし、ストロボがパルス出力されるときにすべてのピクセル行が確実に露光されるようにする必要があります。


In-Sight ポート

In-Sight の通信には次のポートが使用されます。

ポート番号 | サービス
TCP 21 | FTP
TCP 23 | Telnet
UDP 68 | DHCP (In-Sight ビジョンシステムのみ)
TCP 80 | HTTP
TCP 502 | Modbus
TCP 1069 | In-Sight プロトコル
UDP 1069 | In-Sight Discovery
TCP 1070 | [マシンステータス] データ
UDP 2222 | EtherNet/IP
TCP 5753 | 監査メッセージサーバ
UDP 45237 | 基本 SLMP メッセージ (GetCommunicationSetting)
TCP 44818 | EtherNet/IP
UDP 44818 | EtherNet/IP
UDP 45237 | iQ センサソリューション
TCP 50000 | DataChannel
UDP 61450 | CC-Link IE フィールド Basic: 周期的な要求/応答メッセージ
UDP 61451 | CC-Link IE フィールド Basic: NodeSearch メッセージと IPAddressSet メッセージ


CalibrateGrid

CalibrateGrid 関数は、ユーザ設定可能なキャリブレーショングリッドパターンを使用して、ピクセル座標系とワールド座標系間で変換を行うための 2D 変換を作成します。また、CalibrateGrid 関数は、線形、非線形、およびレンズ歪みを補正し、Calibrate 関数の中で最も高い精度を実現します。

概要

CalibrateGrid 関数は、キャリブレーションドットグリッドパターンで検出されたドットまたはチェッカボードキャリブレーショングリッドパターンの頂点によって識別される点のセット間での 2D 変換を計算します。さらに、CalibrateGrid 関数は、画像の取り込みに使用されているレンズの放射歪みまたは遠近歪みを自動的に補正します。

注 : 歪みのない画像上でビジョンツールを表示または利用する場合は、TransformImage 関数を使用します。

CalibrateGrid 関数を使用するには、関数をスプレッドシートの空白セルに挿入し、[CalibrateGrid] ダイアログの [セットアップ] ペインを表示します。キャリブレーションパターンは、CalibrateGrid の [セットアップ] ペインで設定します。

  • 使用するキャリブレーショングリッドパターンのタイプ
  • キャリブレーショングリッドパターンの間隔
  • 実世界のタイプ、物理測定単位
  • ポーズの数を 1 ～ 30 に設定

キャリブレーションプレートグリッドがない場合は、オプションで印刷することができます。次に [ポーズ] ペインを使用して、パターンの画像を取り込みます。画像が取り込まれると、CalibrateGrid 関数は可能な限り多くの特徴点を自動的に識別します。[キャリブレーション] ボタンをクリックすると、CalibrateGrid 関数は直ちにキャリブレーションの計算を開始し、特徴点の間隔に基づいた「キャリブレーション得点」を報告します。結果は、[結果] ペインに表示されます。

キャリブレーションの実行が完了すると、キャリブレーションデータは [CalibrateGrid] セルに格納されます。これによって、CalibrateGrid 関数を 1 つのジョブからコピーして別のジョブに貼り付けること、または [セルのエクスポート]、[セルのインポート] を使用して外部ファイルとしてエクスポートおよびインポートすることができるようになります。さらに、必要であれば、各ジョブに異なるキャリブレーションを設定することや、1 つのジョブに複数のキャリブレーションを設定することもできます。なお、キャリブレーション関数を引数として使用するほかの関数は、CalibrateGrid データ構造体を参照することができます。

注 :
  • Calibrate 関数、CalibrateAdvanced 関数、または CalibrateGrid 関数を使用する場合、物理セットアップと光学セットアップ (レンズ、センサ、およびセンサと取り込まれるシーンの間の物理的関係) はキャリブレーション操作とランタイム操作の両方で同一にする必要があります。このうちのいずれかが変更された場合、システムを再キャリブレーションする必要があります。したがって、キャリブレートとランタイム画像の処理の両方で、同じセンサとレンズを使用することを推奨します。センサとレンズでは、元のセットアップおよびキャリブレーション設定を変更しないようにする必要があります。例えば、画像取り込みフォーマットの変更 (解像度の変更による) またはセンサの移動を行うと、ピクセルをワールド座標にマッピングする 2D 変換が不正になります。
  • In-Sight 5604 ラインスキャンビジョンシステムは、ピクセル座標でのみ動作します。In-Sight 5604 で実行されているジョブに Calibrate 関数が追加されていると、不正な結果がもたらされます。

[CalibrateGrid] ダイアログペインとコントロール

[CalibrateGrid] ダイアログはキャリブレーション用の 3 つのペインで構成されます。

[セットアップ] ペイン

コントロール 説明

グリッドタイプ

キャリブレーションの作成に使用するキャリブレーションパターンのタイプを指定します。[フィデューシャルつきチェッカボード]、[フィデューシャルなしチェッカボード]、[フィデューシャルつきドット]、または [フィデューシャルなしドット]

[フィデューシャルつきチェッカボード]

タイル頂点 (4 つのタイルの隅が接する点) は、特徴の位置の判定に使用されます。センサの表面に対する角度が 45 度以内になっていれば、頂点の位置を正確に検出することができます。また、グリッドの原点および実世界空間におけるグリッドの角度を識別するために、フィデューシャルマーカが提供されています。

注 : チェッカボードの格子の幅は、少なくとも 15 ピクセルにする必要があります。

[フィデューシャルなしチェッカボード]

タイル頂点 (4 つのタイルの隅が接する点) は、特徴の位置の判定に使用されます。センサの表面に対する角度が 45 度以内になっていれば、頂点の位置を正確に検出することができます。また、原点は [グリッドの軸] を使用して設定する必要があります。

注 : チェッカボードの格子の幅は、少なくとも 15 ピクセルにする必要があります。

[フィデューシャルつきドット]

チェッカボードのパターンと対比することで、視野全体での照明のばらつきおよび画像のノイズによる影響を少なくします。特徴の位置は、ドットの中心で決まります。ドットの位置は、センサの表面に対する角度が 30 度以内になっていれば検出することができます。また、グリッドの原点および実世界空間におけるグリッド角度を識別するため、さらにグリッド間隔を識別および設定するために、フィデューシャルマーカが提供されます。

注 :
  • 画像内にあるドットの推奨されるピクセルの直径は、15 ～ 30 ピクセルの間です。最小値と最大値の範囲は、6 ～ 50 ピクセルです。ピクセルの直径が 50 を超えるドットまたは 6 未満のドットは、ツールによって検出されません。

  • [フィデューシャルつきドット] キャリブレーションパターンでは、キャリブレーションパターンの中に特別な識別コードがあります。このコードは、[グリッド間隔] フィールドおよび [単位] フィールドの値によって決まります。キャリブレーションパターンが画像として取り込まれると、キャリブレーションツールはこのパターンを読み込み、キャリブレーションパターンにあるコードに基づいて自動的に [グリッド間隔] フィールドと [単位] フィールドの値を設定します。実際のグリッドサイズと埋め込まれているコードが一致していない状況で、印刷された同じ [フィデューシャルつきドット] キャリブレーションパターンを使用する必要がある場合は、[グリッドタイプ] フィールドで [フィデューシャルなしドット] を選択し、[グリッド間隔] フィールドと [単位] フィールドに手動で値を入力します。その後、各ポーズに対して、[グリッドの軸] のフィールド ([原点の選択]、[X 軸の選択]、および [Y 軸の選択]) に値を入力します。コード化されたシンボルを自動的に挿入しない [フィデューシャルつきドット] キャリブレーションパターンを作成するには、単純に、[グリッド間隔] フィールドと [単位] フィールドの値を 15 個ある設定済みパターン以外の組み合わせに設定します。特別な識別コードを持つ 15 個の設定済みキャリブレーションパターンは、次のようになっています。

    インチ単位 | ミリメートル単位
    0.1 | 1
    0.125 | 2
    0.25 | 5
    0.5 | 10
    1 | 20
    2 | 50
    4 | 100
    12

[フィデューシャルなしドット]

チェッカボードのパターンと対比することで、視野全体での照明のばらつきおよび画像のノイズによる影響を少なくします。特徴の位置は、ドットの中心で決まります。ドットの位置は、センサの表面に対する角度が 30 度以内になっていれば検出することができます。また、原点は [グリッドの軸] を使用して設定する必要があります。

注 : 取り込まれた画像内でのドットの直径は、少なくとも 10 ピクセルになっている必要があります (ただし、推奨値は 15)。
[グリッド間隔]: チェッカボードパターン内にある正方形のサイズ、またはドットグリッドパターン内にあるドットの中心から中心への距離のいずれかを指定します (0.0000001 ～ 9999999、デフォルト = 10.00)。
[単位]: 実世界の測定単位 ([ミクロン]、[ミリメートル] (デフォルト設定)、[センチメートル] または [インチ]) で、キャリブレーションはこの単位に基づいています。
[ポーズ数]: キャリブレーションの完了に必要なポーズの数を指定します。1 つのキャリブレーションパターンで視野全体をカバーできない場合は、複数のポーズを使用する必要があります。このタイプのキャリブレーションでは、視野をカバーするために、キャリブレーションパターンはさまざまな物理的位置に配置されます。キャリブレーションパターンの各位置は、「ポーズ」と呼ばれます。CalibrateGrid 関数では、1 ～ 30 個のポーズを処理することができます。2 つ以上のポーズを選択した場合は、[ポーズ位置] のオプションが有効になります。これらのオプションは、ポーズ間におけるキャリブレーションパターンの予想される動きを指定するために使用します。
[レンズモデル]: 画像取得に使用されているレンズタイプに基づいて、歪み補正のタイプ ([放射歪み補正] または [遠近歪み補正]、デフォルト = [放射歪み補正]) を指定します。「放射歪み」とは、視野周辺部の倍率と、視野中央部の倍率が異なる光学レンズに生じる歪みのことです。放射歪みは、通常、視野の広いレンズでより深刻となります。例えば、広角レンズは、望遠レンズより深刻な放射歪みが発生する傾向があります。「遠近歪み」とは、取得されるシーンに対し、ビジョンシステムの光学軸が直角でない場合に発生する歪みのことです。
[グリッドの印刷]:

[グリッドの印刷] ボタンをクリックして、選択した [グリッドタイプ] を印刷します。

注 : [グリッドの印刷] 機能は、高い精度を要求されない測定および検証を行う場合にのみ使用してください。高い精度と確度が要求されるアプリケーションには使用できません (高い精度と確度が要求されるアプリケーションには、正確に作成されたキャリブレーションパターンが必要になります)。
[ポーズ位置] - [自動] (デフォルト): CalibrateGrid 関数による複数のポーズの設定方法を指定します (このオプションを有効にするには、[ポーズ数] パラメータに 2 よりも大きい値を設定する必要があります)。[自動] モードでは、ビジョンシステムでの光学キャリブレーション (遠近とレンズの歪みの修正) のみが可能です。[自動] モードを使用して、キャリブレーショングリッドの複数のビューをつなぎ合わせて最初のポーズビューの座標系にすると、入力が必要となるワールド座標値は、ポーズ 1 内にある原点のワールド座標のみになります。ほかのすべてのポーズは、フィデューシャルが検出されている限り、各ポーズの原点を指定しなくてもキャリブレートすることができます。
[ポーズ位置] - [ユーザ指定]: CalibrateGrid 関数による複数のポーズの設定方法を指定します (このオプションを有効にするには、[ポーズ数] パラメータに 2 よりも大きい値を設定する必要があります)。[ユーザ指定] モードを使用して、ハンドアイキャリブレーションを実行することができます。このキャリブレーションタイプは、遠近とレンズの光学歪みを修正するためのデータを提供するだけでなく、画像座標空間からモーション座標空間へのカメラのキャリブレーションも行います。[ユーザ指定] モードをマルチビューキャリブレーションに使用すると、各ビューでモーションデバイスのポーズを手動で入力する必要があります。

[ポーズ] ペイン

コントロール 説明

[原点の位置 (ワールド座標系)]:

原点の X 位置と Y 位置をワールド座標で指定します。さらに、グリッドの軸の角度関係と実世界軸の間に不一致がある場合は、[角度] を指定することもできます。

注 : [セットアップ] ペインで [ポーズ位置] を有効にして [ユーザ指定] モードを選択した場合、[原点の位置 (ワールド座標系)] を実際に使用して、キャリブレーションプレートの原点の位置と角度ではなく、モーションデバイスのモーションポーズを指定します。

[特徴点検出数]:

 キャリブレーションで使用する抽出された特徴点の総数を表示します。

[画像取り込み]:

画像の取り込み方法を指定します。

[トリガ]: | [トリガ] ボタンを手動でクリックして画像を取り込むように指定します。
[ライブビデオ]: | In-Sight ビジョンシステムがライブビデオモードに切り替わり、ビジョンシステムのフォーカスが調整されます。
[画像ファイルを開く]: | [開く] ダイアログを使用して画像をロードするように指定します。

[グリッドの軸]:

 フィデューシャルなしのキャリブレーションパターン ([フィデューシャルなしチェッカボード]、[フィデューシャルなしドット]) が選択されている場合は、キャリブレーションパターンのグリッドの軸を指定します。

[領域の調整]:

 対話型グラフィックスモードが開始され、キャリブレーションの対象領域を定義します。その対象領域内の特徴のみがキャリブレーションで使用されます。

特徴点テーブル:

画像から抽出された特徴点のピクセル行とピクセル列の座標のほかに、キャリブレーションパターンの位置が原点に対するグリッド座標 (X, Y) で表示されます。原点の値が変わると、常に X 座標と Y 座標が更新されます。抽出された特徴点は、各特徴の位置に緑色の「x」でグラフィカルに表示されます。テーブルから特徴点を選択、またはグラフィックス表示の特徴点をクリックすると、テーブルとグラフィックス表示の両方でその特徴点がハイライトされ、その座標がグラフィカルに表示されます。

[結果] ペイン

コントロール 説明

[特徴点の総数]:

キャリブレーションで使用する抽出された特徴点の総数を表示します。

[平均エラー]:

キャリブレーション中の平均エラーをピクセル単位で表示します。

[最大エラー]:

キャリブレーション中の最大エラーをピクセル単位で表示します。
キャリブレーションのグラフィック:

キャリブレーションをグラフィカル形式で表示します。

  • 非常によい = エラー <= 0.25
  • よい = 0.25 < エラー <= 0.5
  • やや悪い = 0.5 < エラー <= 2.0
  • 悪い = 2.0 < エラー <= 5.0
  • 非常に悪い = 5.0 < エラー

特徴点テーブル:

画像から抽出された特徴点のピクセル行とピクセル列の座標のほかに、キャリブレーションパターンの位置が原点に対するグリッド座標 (X, Y) で表示されます。原点の値が変わると、常に X 座標と Y 座標が更新されます。抽出された特徴点は、各特徴の位置に緑色の「x」でグラフィカルに表示されます。テーブルから特徴点を選択、またはグラフィックス表示の特徴点をクリックすると、テーブルとグラフィックス表示の両方でその特徴点がハイライトされ、その座標がグラフィカルに表示されます。

使用方法 CalibrateGrid

CalibrateGrid 関数を使用するプロセスは、次の手順で構成されています。

CalibrateGrid 関数の挿入

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。
  2. [関数の挿入] ダイアログの左側で、ツールカテゴリの [座標補正] リストを展開します。
  3. 関数リストから CalibrateGrid 関数を選択して、[OK] ボタンを押します。

[セットアップ] ペインを使用したキャリブレーションパターンの設定

CalibrateGrid 関数を初めて挿入すると、[セットアップ] ペインが自動的に表示されます。

注 : いずれかの [CalibrateGrid] ダイアログから [セットアップ] ダイアログに戻るには、ダイアログの左側にあるナビゲーションペインで単純に [セットアップ] を選択します。
  1. キャリブレーションパターンの設定を開始するには、[グリッドタイプ] パラメータからキャリブレーションパターンを選択します。
  2. [グリッド間隔] フィールドの値を設定します。この値は、チェッカボードパターン内にある正方形のサイズ、またはドットグリッドパターン内にあるドットの中心から中心への距離のいずれかを定義するために使用されます。
  3. [単位] フィールドの値を設定します。これは実世界の測定単位で、ワールド座標はこの単位に基づいています。

  4. キャリブレーションの完了に必要なポーズの数を決め、[ポーズ数] パラメータにその値を入力します。1 つのキャリブレーションパターンで視野全体をカバーできない場合は、複数のキャリブレーションパターンを使用する必要があります。このタイプのキャリブレーションでは、視野をカバーするために、キャリブレーションパターンはさまざまな物理的位置に配置されます。キャリブレーションパターンの各位置は、「ポーズ」と呼ばれます。CalibrateGrid 関数では、1 ～ 30 個のポーズを処理することができます。2 つ以上のポーズを選択した場合は、[ポーズ位置] のオプションが有効になります。これらのオプションは、ポーズ間におけるキャリブレーションパターンの予想される動きを指定するために使用します。

    デフォルト設定は [自動] になっています。この設定では、基本的にキャリブレーションパターンを自由に移動することができます。[自動] が選択されると、入力が必要となるワールド座標値はポーズ 1 内にある原点のワールド座標のみになります。ほかのすべてのポーズは、フィデューシャルが検出されている限り、各ポーズの原点を指定しなくてもキャリブレートされます。

    注 : [自動] モードでは、ビジョンシステムでの光学キャリブレーション (遠近とレンズの歪みの修正) のみが可能です。

    モーションデバイスのモーション座標系との関係を確立するため、ハンドアイキャリブレーションを実行する場合は、[ユーザ指定] モードを選択します。各ビューでのモーションデバイスのポーズは、手動で入力する必要があります。キャリブレーションプレートとモーションデバイス間の (位置と方向の) 配置オフセットが分かっていないので、キャリブレーションプレートの元の位置を調べる必要はありません。

    注 : [ユーザ指定] モードでは、光学キャリブレーションとモーションデバイスのキャリブレーションの両方が可能です。
  5. グリッドパターンを印刷する前に、[レンズモデル] ([放射歪み補正] または [遠近歪み補正]) を選択し、画像取得に使用されているレンズタイプに基づいて、歪み補正のタイプを定義します。「放射歪み」(デフォルト設定) とは、視野周辺部の倍率と、視野中央部の倍率が異なる光学レンズに生じる歪みのことです。放射歪みは、通常、視野の広いレンズでより深刻となります。例えば、広角レンズは、望遠レンズより深刻な放射歪みが発生する傾向があります。「遠近歪み」とは、取得されるシーンに対し、ビジョンシステムの光学軸が直角でない場合に発生する歪みのことです。

[グリッドの印刷] ダイアログを使用したキャリブレーションパターンの印刷

注 : [グリッドの印刷] 機能は、高い精度を要求されない測定および検証を行う場合にのみ使用してください。高い精度と確度が要求されるアプリケーションには使用できません (高い精度と確度が要求されるアプリケーションには、正確に作成されたキャリブレーションパターンが必要になります)。
  1. キャリブレーションパターンの設定が完了したら、[グリッドの印刷] ボタンをクリックしてキャリブレーションパターンのコピーを印刷します。
  2. 印刷を実行する前に [ページ設定] ボタンをクリックし、[ページ設定] ダイアログを使用してキャリブレーションパターンを設定します。
  3. [印刷] ボタンをクリックして、[印刷] ダイアログを表示します。このダイアログから、キャリブレーションパターンの印刷を実行することができます。

[ポーズ] ペインを使用したキャリブレーションパターンの画像の取得

[セットアップ] ペインでのキャリブレーションパターンの設定が完了したら、ナビゲーションペインから [ポーズ] (または、複数のポーズを設定する場合は [ポーズ 1]) を選択します。[ポーズ] ペインが表示されます。

  1. キャリブレーション用画像の取り込みには、次の 3 つのオプションがあります。

    • トリガ
    • ライブビデオ
    • 画像ファイルを開く
    注 : 最も正確な結果を得るには、キャリブレーションパターンが視野全体で鮮明になるように焦点を調整します。また、特徴を処理する場合、CalibrateGrid 関数は特徴が白地に黒または黒地に白であるかどうかを判別しません。

  2. 画像の取り込みが完了すると、CalibrateGrid 関数は特徴点を自動的に抽出します。

  3. 抽出された各特徴を示すデータテーブルを表示するには、切り替えボタンをクリックします (テーブルを非表示にするにはボタンをもう一度クリック)。このテーブルには、画像から抽出された特徴点のピクセル行とピクセル列の座標のほかに、キャリブレーションパターンの位置が原点に対するグリッド座標 (X, Y) で表示されます。原点の値が変わると、常に X 座標と Y 座標が更新されます。抽出された特徴点は、各特徴の位置に緑色の「x」でグラフィカルに表示されます。テーブルから特徴点を選択、またはグラフィックス表示の特徴点をクリックすると、上の図のように、テーブルとグラフィックス表示の両方でその特徴点がハイライトされ、その座標がグラフィカルに表示されます。

新しい画像を取り込んだ場合または [ポーズ] ダイアログに戻った場合は常に、領域サイズの調整および特徴点の再抽出が行われ、結果表示も更新されます。デフォルトでは、画像全体が特徴点抽出に使用されます。[領域の調整] ボタンをクリックすると、対話型グラフィックスモードが開始されます。このモードでは、対象領域を定義し、その領域外にある画像部分を無視することができます。

[ポーズ] ペインでの原点の変更または設定 (オプション)

[セットアップ] ペインで [ポーズ位置] を有効にして [自動] モードを選択した場合、[原点の位置] フィールドを使用して、ワールド座標系で原点の X と Y の位置を指定します。さらに、グリッドの軸の角度関係と実世界軸の間に不一致がある場合は、[角度] フィールドを使用してその角度を入力することができます。例えば、原点が画像の隅にあるよりも対象物の中心にある方が便利な場合は、原点を変更することができます。キャリブレーションの原点位置は、[原点の位置 (ワールド座標系)] にある [X]、[Y]、および [角度] フィールドの値を調整することで変更できます。 ボタンをクリックして値を増減するか、または必要な数値を手動で入力します。[自動] が選択されると、入力が必要となるワールド座標値はポーズ 1 内にある原点のワールド座標のみになります。ほかのすべてのポーズは、フィデューシャルが検出されている限り、各ポーズの原点を指定しなくてもキャリブレートされます。

[セットアップ] ペインで [ポーズ位置] を有効にして [ユーザ指定] モードを選択した場合、[原点の位置 (ワールド座標系)] を実際に使用して、キャリブレーションプレートの原点の位置と角度ではなく、モーションデバイスのモーションポーズを指定します。[ユーザ指定] モードを使用してハンドアイキャリブレーションを実行し、モーションデバイスのモーション座標系との関係を確立します。各ビューでのモーションデバイスのポーズは、手動で入力する必要があります。キャリブレーションプレートとモーションデバイス間の (位置と方向の) 配置オフセットが分かっていないので、キャリブレーションプレートの元の位置を調べる必要はありません。

[グリッドの軸] を使用したフィデューシャルなしのキャリブレーションパターンの設定 (オプション)

使用するキャリブレーションパターンにフィデューシャルがない場合は、[グリッドの軸] にある設定を使用して原点および X 座標軸と Y 座標軸を定義する必要があります。[グリッドの軸] にある設定は、フィデューシャルのないキャリブレーションパターンを選択した場合にのみ利用可能になり表示されます。

  1. 画像の処理と特徴の抽出が完了したら、[原点の選択] ボタンをクリックします。

  2. これにより対話型グラフィックスモードが開始されます。このモードからハイライトされている点のいずれかをダブルクリックし、原点として選択します。

    注 : 抽出されたすべての特徴を原点にできるわけではありません。特徴点に 90 度離れている 2 つの隣接点が存在しない場合は、その特徴点を原点として選択することはできません。

  3. 原点の設定が完了すると、次の図のように、[スプレッドシートビュー] ウィンドウで原点がハイライトおよび表示され、データテーブルでは選択した原点座標が自動的にハイライトされます。

  4. 次に、[X 軸の選択] ボタンをクリックすると、対話型グラフィックスモードが開始されます。このモードからハイライトされている点のいずれかをダブルクリックし、X 軸として選択します。

  5. X 軸の設定が完了すると、次の図のように、[スプレッドシートビュー] ウィンドウで X 軸がハイライトおよび表示され、データテーブルでは選択した X 軸座標が自動的にハイライトされます。

  6. 次に、[Y 軸の選択] ボタンをクリックすると、再び対話型グラフィックスモードが開始されます。このモードからハイライトされている点のいずれかをダブルクリックし、Y 軸として選択します。

  7. Y 軸の設定が完了すると、次の図のように、[スプレッドシートビュー] ウィンドウで Y 軸がハイライトおよび表示され、データテーブルでは選択した Y 軸座標が自動的にハイライトされます。

  8. 最後に、原点、X 軸、および Y 軸の設定が完了したら、[キャリブレーション] ボタンをクリックして [結果] ペインに進み、キャリブレーションを終了するか、またはほかのポーズを設定する場合はナビゲーションペインで [ポーズ] を選択します。

[ポーズ] ダイアログを使用した複数のポーズの設定 (オプション)

[自動] モード:

1 つのキャリブレーションパターンで視野全体をカバーできない場合は、複数のキャリブレーションパターンを使用する必要があります。ここで説明する複数のポーズを扱う状況では、フィデューシャルつきのドットグリッドパターンが使用されています。

  1. ポーズ 1 の [原点の位置 (ワールド座標系)] を指定します。

    注 : [自動] が選択されると、入力が必要となるワールド座標値はポーズ 1 内にある原点のワールド座標のみになります。ほかのすべてのポーズは、フィデューシャルが検出されている限り、各ポーズの原点を指定しなくてもキャリブレートされます。
  2. ポーズ 1 に続くポーズごとに、新しい画像をロードするか、取り込む必要があります。
  3. すべてのポーズの設定が完了したら、[キャリブレーション] ボタンをクリックして [結果] ダイアログに進み、キャリブレーションを終了します。

[ユーザ指定] モード:

キャリブレーションのために、各ポーズ用に異なる物理的位置に配置されているパターンを含む複数のポーズが必要になることがあります。その場合、キャリブレーションシーケンスの中で、キャリブレーションパターンを複数の位置に正確に移動する必要があります。これはモーションデバイスを使用して行うこともできますが、モーションデバイス制御ソフトウェアは自動化に対応していません。したがって、モーションデバイスを使用する場合は、処理を進める前に、モーションデバイスコントローラによってモーションデバイスを手動で操作してそれぞれの新しいポーズに移動する必要があります。

  1. 各モーションポーズの [原点の位置 (ワールド座標系)] を指定します。モーションデバイスのポーズは、各ビューに手動で入力する必要があります。

    注 : [原点の位置 (ワールド座標系)] を [ユーザ指定] モードで実際に使用して、キャリブレーションプレートの原点の位置と角度ではなく、モーションデバイスのモーションポーズを指定します。キャリブレーションプレートとモーションデバイス間の (位置と方向の) 配置オフセットが分かっていないので、キャリブレーションプレートの元の位置を調べる必要はありません。
  2. ポーズ 1 に続くポーズごとに、追加の各ポーズの新しい画像を取り込む必要があります。
  3. すべてのポーズの設定が完了したら、[キャリブレーション] ボタンをクリックして [結果] ダイアログに進み、キャリブレーションを終了します。

[結果] ダイアログを使用したキャリブレーションの検証

[キャリブレーション] ボタンをクリックすると、CalibrateGrid 関数が最適な 2D 変換の計算を開始し、画面は自動的に [結果] ペインに切り替わります。[結果] ペインにはキャリブレーションの概要が表示されます。この概要には、検出された特徴点の総数、およびピクセル単位でキャリブレーションの平均エラーと最大エラーが示されます。エラーレベルの評価は、次のレート値を使用して、平均エラーに基づいて割り当てられます。

  • 非常によい = エラー <= 0.25
  • よい = 0.25 < エラー <= 0.5
  • やや悪い = 0.5 < エラー <= 2.0
  • 悪い = 2.0 < エラー <= 5.0
  • 非常に悪い = 5.0 < エラー

この評価は、キャリブレーション全体の「得点」と見ることができます。例えば、特徴点のグリッド上での間隔が不均等になっている場合は、得点が低くなります。また、複数ポーズのキャリブレーションで、ポーズ位置に [ユーザ指定] が選択されていると、ポーズの 1 つが正しく配置されなかった場合も得点が低くなります。

結果が許容可能であれば、[OK] ボタンをクリックしてキャリブレーションを終了します。キャリブレーションが正常に完了すると、スプレッドシートに キャリブデータ構造体が挿入されます。


Event

指定されたイベントトリガでスプレッドシートを更新します。Event 関数は、特定の入出力条件でのみスプレッドシートを更新する重要な依存関係として使用されます。

Eventの入力パラメータ

Syntax:Event(トリガ,手動)

トリガ

In-Sight センサがオンライン時のイベントのトリガソースを指定します。

16 = 画像取り込みエラー | エラー: 画像取り込みミスが発生した場合、またはセンサとの接続が失われた場合に生成されます。 注 : このトリガを使用するには、AcquireImage 関数のプロパティシートの [トリガ] パラメータを [カメラ] に設定しておく必要があります。
17 = ディスクリート I/O エラー | トラックパルスのオーバランが発生した場合、またはトラックパルスのキューがいっぱいである場合に生成されます。
18 = シリアルポート 0 エラー | 実装されていません。
19 = シリアルポート 1 エラー | 実装されていません。
20 = ワークシートエラー | ジョブの実行中に、#ERR が初めてセルに返されたときに生成されます。
21 = システムエラー | 実装されていません。
22 = ネットワークエラー | TCPDevice 関数または WriteResult 関数を使用したときに、これらの関数が低レベルのネットワークライブラリからソケットエラーを受信した場合、TCPDevice 関数を使用したときに、パケットを受信したがジョブの実行中だったので処理できなかった場合、あるいは WriteFTP 関数または WriteImageFTP 関数を使用したときに、ネットワークパラメータ設定 (ホスト名、ユーザ名、パスワードなど) が無効であった場合に生成されます。
32 = 手動 | センサをオンラインにして、手動トリガを開始したときに生成されます。
33 = オンライン/オフライン | In-Sight センサのオンライン/オフライン状態が切り替わったときに生成されます。
35 = ジョブを開く 完了 | ジョブのロード後に生成されます。
39 = 画像取り込みジョブ完了 | 取り込みを開始したジョブの実行の最後に生成されます。 注 : このトリガを使用するには、AcquireImage 関数のプロパティシートの手動パラメータを有効にしておく必要があります。
49 ～ 60 = ディスクリート 0 ～ 11 | 対応するディスクレート入力がイベントトリガとして構成されているときに、指定された信号動作 (つまり、立ち上がりエッジ、立ち下がりエッジ、または両方) が発生した場合に生成されます。
64 = シリアルポート 0 | 実装されていません。
65 = シリアルポート 1 | シリアル ポートが [DeviceNet] または [テキスト] モードで構成されているときに、データがこのシリアルポートで受信された場合に生成されます。
135 = チューニングボタン | In-Sight 76xx ～ 79xx ビジョンシステムのチューニングボタンを押すと生成されます。
80 ～ 87 = ソフト 0 ～ 7 (デフォルト = ソフト 0) | SetEvent 関数、Button 関数、または Timer 関数、もしくは Set Event 関数または Set Event and Wait ネイティブモードコマンド、ソフトトリガが実行された場合に生成されます。
手動

In-Sight ビジョンシステムがオフラインのときにイベントがトリガされた場合に、手動でのトリガを発行するかどうかを指定します。

0 = OFF (デフォルト) | 手動でのトリガは発行されません。
1 = ON | 手動でのトリガが発行されます。

Eventの出力

戻り値 イベントデータ構造体。入力パラメータが無効であれば #ERR を返します。


ID

In-Sight ID ツール関数は、線形 1D および 2D シンボルに含まれている英数字データ文字列を読み取ります。また、必要に応じて、公表されている仕様に従って大半のシンボルの品質を検証することができます。ID ツールには次の関数があります。

  • ReadIDMax 関数: 対象領域内の 1D または 2D シンボル (1D/スタックド、データマトリックス、QR コード、および郵便番号) を検出し、デコードします。この関数を設定して、さまざまなシンボルと多くの結果を取得し、極度の回転および遠近歪みでも処理することができます。オプションで、データマトリックスと QR コードモデルの登録、および品質測定の検証にも使用することができます。

  • ReadIDCode 関数: 1D および 2D のシンボルに含まれている情報をデコードし、必要に応じて品質を検証します。

    注 :
    • ReadIDCode 関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行する In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
    • レガシー関数である ReadIDCode 関数の代わりに ReadIDMax 関数を使用することを推奨します。ReadIDMax 関数には拡張性能機能が搭載されています。
  • ValidateIDData 関数: 1D および 2D シンボルからデコードされたデータを検証します。
  • VerifyIDCode 関数: 1D および 2D シンボルからコードの読み取り易さとマークの品質に関連する方法を抽出するために使用します。

1D および 2D シンボルの読み取り

ReadIDMax および ReadIDCode 関数を使用して、対象領域内の 1D および 2D シンボルを探してデコードします。新しいコード読み取りアプリケーションには、ReadIDMax 関数を使用することを推奨します。この関数は、既存の ReadIDCode 関数を超える次の利点があるからです。

  • 同じ画像内で、混合タイプの複数の 1D シンボルをデコードします。
  • 同じ画像内で、同じタイプの複数の 2D シンボルをデコードします。
  • 最新のシンボルデコードアルゴリズムをサポートしています。

1D および 2D シンボルの品質の検証

1D バーコードシンボルの品質の検証

In-Sight ビジョンシステムは 1D バーコードを読み取り、オプションでバーコードの品質を検証することができます。In-Sight がシンボルの品質の検証に使用する方法は、米国規格協会 (ANSI) によって承認されています。

ReadIDMax または ReadIDCode 関数で [検証] チェックボックスをオンにすると、In-Sight で適用可能なすべてのアプリケーションテストが実行されます。バーコードの品質検証に使用される品質検証テストは複数あります (詳細は、データアクセス関数のトピックの IDMax および IDCode 関数を参照してください)。これらのテストそれぞれに、A (4.0) ～ F (0.0) の「グレード」があります。シンボルの全体的な品質は、いずれかのテストによって獲得される最低のグレードです。ただし、個別の品質テストそれぞれでアルファベットのグレードや同等の数値を返すことはなく、In-Sight では実際の結果の値プラスシンボル全体のグレードを返します。

注 : バーコードの品質は、暗黙的にその読み取り可能性に関係していますが、1 つ以上のテストで低い、または不合格のグレードでありながら、読み取り可能なシンボルもあります。ただし、品質仕様を満たすことができなかったシンボルは、プロセスの問題に原因があるので、照明条件の変化や、再度キャリブレーションが必要な刻印機などについては注意が必要です。

2D シンボルの品質の検証

In-Sight はデータマトリックス、QR コード、PDF 417、および EAN/UCC コンポジットシンボルを読み取り、シンボルの品質も検証します。In-Sight でシンボルの品質の検証に使用する方法は、International Symbology Specification (ISS) のセクション 8 および Annexe N - データマトリックス (BC11-1997)、International Symbology Specification (ISS) のセクション 8 および Annexe M - QR コード (ITS/97-001)、Uniform Symbology Specification (USS) のセクション 3 および ４ - PDF 417 (AIM International が発行し、American National Standards Institute (ANSI) が承認)、および International Standard - バーコードシンボル印刷品質の評価仕様 (ISO/IEC-15416) (International Organization for Standardization (ISO) および International Electrotechnical Commission (IEC) が発行) で定義されています。

ReadIDMax または ReadIDCode 関数で [検証] チェックボックスをオンにすると、In-Sight で適用可能なすべてのアプリケーションテストが実行されます。AIM 仕様で説明されているように、品質検証テストは複数あり、シンボルの品質の検証に使用されます。使用される検証テストのタイプは、選択されているシンボルのタイプに応じて決まります。PDF 417 および EAN/UCC コンポジット 2D コンポーネントは、1D バーコードといくつかの検証テストを共有しています。これらのテストそれぞれに、A (4.0) ～ F (0.0) の「グレード」があります。シンボルの全体的な品質は、いずれかのテストによって獲得される最低のグレードです。ただし、品質テストそれぞれでアルファベットのグレードや同等の数値を返すことはなく、In-Sight では実際の結果の値プラスシンボル全体のグレードを返します。

注 : シンボルの品質は、暗黙的にその読み取り可能性に関係していますが、1 つ以上のテストで低い、または不合格のグレードでありながら、読み取り可能なシンボルもあります。ただし、品質仕様を満たすことができなかったシンボルは、プロセスの問題に原因があるので、照明条件の変化や、再度キャリブレーションが必要な刻印機などについては注意が必要です。

検証および妥当性検査の技術の追加

ReadIDMax および ReadIDCode 関数のビルトイン品質検証測定に加えて、ValidateIDData および VerifyIDCode 関数を使用して、ReadIDMax および ReadIDCode 関数の両方またはどちらかによって読み取られ、デコードされたシンボルの妥当性検査と検証を実行することができます。

ValidateIDData 関数

ValidateIDData 関数を使用して、シンボルのデータの完全性の妥当性検査を行い、そのデータが MIL-STD 130 および GS1 標準に準拠していることを確認します。ValidateIDData データアクセス関数を使用して、データを解析し、適用標準に準拠していることを確認することができます。

VerifyIDCode 関数

VerifyIDCode 関数を使用して、シンボルに対してさらに検証測定を実行し、コードの読み取り可能性とシンボルのマークの品質に関連する方法を抽出します。VerifyIDCode データアクセス関数を使用して、シンボルの検証グレードを抽出することができます。


オンライン

EasyBuilder ビュー

現在のオンライン/オフラインの状態は、ユーザインタフェースの右下隅のステータスバーに表示されます。ステータスバーに [image] と表示されるようにするには、次の 3 つがそれぞれオンライン状態である必要があります。GUI オンライン、通信オンライン、およびディスクリート I/O オンラインです。次のいずれかの操作によって、アクティブなビジョンシステムの GUI オンライン/オフラインのステータスが切り替わります。

  • [センサ] メニューの、[オンライン] をクリックします。
  • EasyBuilder ツールバーで、[オンライン/オフライン] [image] ボタンをクリックします。
  • [ジョブの実行] 設定ペインで [オンライン] ボタンをクリックします。
  • Ctrl + F8 キーを押します。

次の表は、ビジョンシステムのさまざまなオンライン/オフラインモードをまとめたものです。

オンライン/オフラインステータス | 条件
 | 通信およびディスクリート I/O はオンライン状態ですが、ビジョンシステムは GUI からオフライン状態に設定されています。
 | 3 つのそれぞれがオンライン状態です。ビジョンシステムはオンライン操作モードです。
 | ビジョンシステムは GUI からオンラインモードに設定されましたが、通信プロトコル (ProfiNET、EtherNet/IP、ネイティブモードなど) によって、ビジョンシステムはオフラインのままになっています。例えば、ネイティブモードで、ビジョンシステムをオフラインにする Set Online コマンド SO0 が発行されました。ビジョンシステムをオンラインにするには、Set Online コマンド SO1 をビジョンシステムに送信する必要があります。 注 : アプリケーションは、管理関数 (バックアップやリストアなど) を実行するために、Set Online コマンドをビジョンシステムに送信します。
 | ビジョンシステムは GUI からオンラインモードに設定されましたが、オンライン/オフラインタイプとして設定されたディスクリート入力ラインが Low (0) に設定されています。ディスクリート入力信号の状態が High (1) になると、ビジョンシステムはオンラインモードになります。

オンラインモードについて

ビジョンシステムがオンラインの場合、次の操作が可能です。

  • ネットワーク入出力関数を使用して、ネットワークを介して EasyBuilder ジョブのデータの送受信を行う。
  • シリアルポートを介して、テキスト、ネイティブ、デバイスネット、および Motoman モードで EasyBuilder ジョブのデータを送受信する。
  • 「カメラ」、「外部」、および「ネットワーク」画像の取り込みトリガに応答する。
  • ディスクリート入出力の読み取りおよび書き込みを行う。
  • EasyBuilder ジョブの結果テーブルを印刷する。
  • [記録/再生] オプションを使用して画像を表示する (画像取り込みトリガを「手動」に設定する必要があります)。

ビジョンシステムがオンラインの場合、次の操作はできません。

  • ジョブや画像を保存および開く (画像取り込みトリガが手動に設定されている場合を除く。この場合は、オンラインの間に画像を開くことができます)。

    注 : [ユーザ] ダイアログの [オンライン時にジョブ保存] チェックボックスが ON の場合、フルまたはプロテクトレベルのアクセス権を持つユーザはオンライン状態でジョブを保存することができます。
  • EasyBuilder ジョブでのツールの編集、コピー、または貼り付け。
  • ビジョンシステム固有のメニュー項目の実行。ただし、ビジョンシステムをオフラインにすることはできます。

オフラインモードについて

ビジョンシステムはオフラインの場合、画像取り込みトリガに応答することも、ジョブとの間でデータを送受信することもできません。ただし、このビジョンシステムは、シリアル、ネットワーク、およびディスクリートなどの選択によって、特にオンライン状態を切り替えるような入力コマンドに対して応答することができます。

スプレッドシートビュー

現在のオンライン/オフラインの状態は、スプレッドシートの右下隅のステータスバーに表示されます。ステータスバーに [image] と表示されるようにするには、次の 3 つがそれぞれオンライン状態である必要があります。GUI オンライン、通信オンライン、およびディスクリート I/O オンラインです。次のいずれかの操作によって、アクティブなビジョンシステムの GUI オンライン/オフラインのステータスが切り替わります。

  • [センサ] メニューの、[オンライン] をクリックします。
  • [ジョブの表示] ツールバーで、[オンライン] [image] ボタンをクリックします。
  • Ctrl + F8 キーを押します。

次の表は、ビジョンシステムのさまざまなオンライン/オフラインモードをまとめたものです。

オンライン/オフラインステータス | 条件
 | 通信およびディスクリート I/O はオンライン状態ですが、ビジョンシステムは GUI からオフライン状態に設定されています。
 | 3 つのそれぞれがオンライン状態です。ビジョンシステムはオンライン操作モードです。
 | ビジョンシステムは GUI からオンラインモードに設定されましたが、通信プロトコル (ProfiNET、EtherNet/IP、ネイティブモードなど) によって、ビジョンシステムはオフラインのままになっています。例えば、ネイティブモードで、ビジョンシステムをオフラインにする Set Online コマンド SO0 が発行されました。ビジョンシステムをオンラインにするには、Set Online コマンド SO1 をビジョンシステムに送信する必要があります。 注 : アプリケーションは、管理関数 (バックアップやリストアなど) を実行するために、Set Online コマンドをビジョンシステムに送信します。
 | ビジョンシステムは GUI からオンラインモードに設定されましたが、オンライン/オフラインタイプとして設定されたディスクリート入力ラインが Low (0) に設定されています。ディスクリート入力信号の状態が High (1) になると、ビジョンシステムはオンラインモードになります。
ヒント : [スタートアップ] ダイアログで、アクティブなビジョンシステムをオンラインモードで起動するように設定することができます。

オンラインモードについて

ビジョンシステムがオンラインの場合、次の操作が可能です。

  • ネットワーク入出力関数を使用して、ネットワークを介してスプレッドシートのデータの送受信を行う。
  • テキスト、ネイティブ、DeviceNet、および Motoman モードを使用し、シリアルポートを介してスプレッドシートのデータの送受信を行う。
  • 「カメラ」、「外部」、および「ネットワーク」画像の画像取り込みトリガに応答する。
  • ディスクリート入出力の読み込みおよび書き込みを行う。
  • スプレッドシートを印刷する。
  • 記録/再生オプションを使用して画像を表示する (ビジョンシステムの AcquireImage 関数の トリガパラメータは手動に設定しておく必要があります)。

ビジョンシステムがオンラインの場合、次の操作はできません。

  • ジョブや画像を保存および開く (画像取り込みトリガが手動に設定されている場合を除く。この場合は、オンラインの間に画像を開くことができます)。

    注 : [ユーザ] ダイアログの [オンライン時にジョブ保存] チェックボックスが ON の場合、フルまたはプロテクトレベルのアクセス権を持つユーザはオンライン状態でジョブを保存することができます。
  • スプレッドシートのセルの編集、移動、コピー、または貼り付け。
  • ビジョンシステム固有のメニュー項目の実行。ただし、ビジョンシステムをオフラインにすることはできます。
  • 対話型グラフィックスモード (ただし、EditRegion 関数は、ビジョンシステムがオンライン時に修正可能であるため例外)。

オフラインモードについて

ビジョンシステムはオフラインの場合、画像取り込みトリガに応答することも、スプレッドシートとの間でデータを送受信することもできません。ただし、このビジョンシステムは、シリアル、ネットワーク、およびディスクリートなどの選択によって、特にオンライン状態を切り替えるような入力コマンドに対して応答することができます。


WriteResultsBuffer

参照元のバッファデータ構造体からのデータを書き込みます。データは FormatOutputBuffer 関数によって生成され、現在有効なファクトリ通信プロトコル ([ネットワークの設定] ダイアログで有効にする) に書き込まれます。この関数は、ファクトリ通信プロトコルの [Result Code] フィールドにも書き込みます。

注 : PROFINET 通信プロトコルが有効な場合に WriteResultsBuffer 関数を使用すると、バイトがスワップされます。

WriteResultsBufferの入力パラメータ

Syntax:WriteResultsBuffer(イベント , バッファ , 結果コード , プロトコル,バイト/ワードオーダ)

イベント

ファクトリプロトコルへの結果の書き込みのきっかけとなるイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の画像データ構造体。
  • Event 関数を含んでいるセル。
  • Button 関数を含んでいるセル。
バッファ

FormatOutputBuffer 関数によって作成されるバッファ構造体への参照を指定します。この構造体には、自動的にフォーマットされたデータが含まれます。

注 : 出力データの最大長は、4,000 バイトです。
結果コード In-Sight ビジョンシステムによる検査の結果を接続されているデバイスに伝えるために使用できる 16 ビットの整数を指定します。
プロトコル

ユーザデータの書き込み先となるプロトコルを指定します。

注 : このパラメータは、In-Sight 5.1.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアのバージョンをご参照ください。 モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。
0 = EtherNet/IP | EtherNet/IP が有効なファクトリ通信プロトコルであることを指定します。
1 = PROFINET | PROFINET が有効なファクトリ通信プロトコルであることを指定します。
2 = SLMP プロトコルスキャナ | SLMP スキャナが有効なファクトリ通信プロトコルであることを指定します。
3 = Modbus TCP サーバ | Modbus TCP サーバが有効なファクトリ通信プロトコルであることを指定します。 注 : このプロトコルは、In-Sight ファームウェアバージョン 5.3.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。
8 = CC-Link IE フィールド Basic Bit | CC-Link IE フィールド Basic が有効なファクトリ通信プロトコルであることを指定し、結果バッファを RX ビット領域に書き込みます。
9 = CC-Link IE フィールド Basic Word | CC-Link IE フィールド Basic が有効なファクトリ通信プロトコルであることを指定し、結果バッファを RWr ワード領域に書き込みます。
100 = 任意 (デフォルト) | 現在有効なファクトリ通信プロトコルが使用されることを指定します ([ネットワークの設定] ダイアログで有効化)。複数のプロトコルが有効にされている場合は、最初に有効にされたプロトコルが使用されます。
バイト/ワードオーダ

関数によって読み込まれるワードとバイトのビット順序を指定します。

注 : このパラメータは、In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアのバージョンをご参照ください。 モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

0 = ビッグエンディアン (= Modbus のデフォルト)

最上位バイトが最初に格納され、以降のバイトが降順に格納されるように指定します。

1 = リトルエンディアン

最下位バイトが最初に格納され、以降のバイトが昇順に格納されるように指定します。

2 = ビッグエンディアン (ワード変換使用)

ビッグエンディアンのバイトスタイルが適用され、Double ワード型のワードペアオーダが切り替わります。(16 ビットワード)

3 = リトルエンディアン (ワード変換使用)

リトルエンディアンのバイトスタイルが適用され、Double ワード型のワードペアオーダが切り替わります。(16 ビットワード)

100 = デフォルト (選択解除された場合)

次のデフォルト設定が使用されます。

EtherNet/IP | リトルエンディアン
PROFINET | ビッグエンディアン
SLMP プロトコルスキャナ | リトルエンディアン
Modbus TCP サーバ | ビッグエンディアン
CC-Link IE フィールド Basic | リトルエンディアン

例

AB (1 ワードサイズの値): A = 最上位バイト、B = 最下位バイト:

 | 着順
ビッグエンディアン (= デフォルト) | AB
リトルエンディアン | BA
ビッグエンディアン (ワード変換使用) | AB
リトルエンディアン (ワード変換使用) | BA

12AB (2 ワードサイズの値): 1 = 最上位バイト、B = 最下位バイト:

 | 着順
ビッグエンディアン (= デフォルト) | 12 | AB
リトルエンディアン | BA | 21
ビッグエンディアン (ワード変換使用) | AB | 12
リトルエンディアン (ワード変換使用) | 21 | BA

WriteResultsBufferの出力

戻り値

クライアントに送信されたデータを含んだ書き込み結果データ構造体。

注 : In-Sight ファームウェア 4.x.x 以前を実行している In-Sight ビジョンシステムに接続する場合、書き込まれたエレメントの数が返されます。入力パラメータが無効な場合、またはクライアントへの接続が確立されていない場合は、#ERR が返されます。


#ERR

#ERR の意味

#ERR を表示するセルは、そのセルが関数を正常に実行できなかったことを示しています。一般的には、無効な入力パラメータが原因です。 #ERR 状態は、ビジョンアプリケーションの通常の操作によって発生することもあれば、スプレッドシートの論理そのものに含まれるエラーによって発生することもあり、さまざまなことが要因となります。 一般に、次の場合に #ERR が発生します。

  1. 算術演算の基本的なエラー

    セル A4 = A3/A2 で、セル A2 が 0 の場合、セル A4 の関数は「ゼロによる除算」エラーを生成します。

  2. 領域グラフィックスエラー: 領域が画像の範囲外へ移動

    PatFind などの位置決めツールを使用して、ほかのビジョンツールの位置をフィクスチャするとき、ビジョンツールの領域の一部が画像の範囲外に出てしまうことがあります。 この場合、ビジョンツールは、ビジョンツールの有効な結果構造体を返さずに #ERR を報告します。

  3. 「Get」関数のエラー: ビジョンツールが結果を生成しない

    ExtractBlobs ツールとともに GetRow 関数を使用する場合、状況によっては、ExtractBlobs ツールで予想される数のブロブを確認できないことがあります。 このような状況で画像から目的のブロブを検出できなかった場合、GetRow 関数は #ERR を報告します。

  4. 通信エラー: データを送信できない

    WriteImageFTP セルや WriteDevice セルは、スプレッドシートが実行されるたびに、データを In-Sight センサから別のコンピュータに自動的に送信します。 クライアントコンピュータで問題が発生し、データを受信できない場合、In-Sight センサの出力バッファがいっぱいになることがあります。 出力バッファのオーバフロー (データを格納できない状態) が発生すると、これらのセルは #ERR を報告します。

#ERR セルのトラブルシューティングの方法

ほとんどの #ERR 状態はエラー文字列を返します。エラー文字列が生成されている場合、#ERR を含むセルにマウスを合わせると、エラー文字列が表示されます。また、赤い感嘆符 ( [image]) がプロパティシートに表示された場合は、その赤い感嘆符にマウスを合わせるとエラー文字列が表示されます。エラー文字列をスプレッドシート上で取得するには、GetErrorString 関数を使用します。各エラー文字列には個別の診断コード番号が割り当てられています。診断コードは、GetErrorCode 関数で取得できます。最もよく返されるエラー文字列を確認するには、 閉じた ここをクリックしてください。

汎用エラー文字列

診断コード | 対応する情報文字列
00000000 | システムエラーです。
00000001 | メモリ不足のため、操作を完了できません。
00000003 | 入力した引数が間違っています。
00000004 | 入力した引数は範囲外です。
00000005 | 入力した引数の型は互換性がありません。
00000009 | 前のセルでジョブがタイムアウトしたため、セルは実行されませんでした。

汎用ビジョンツールのエラー文字列

診断コード | 対応する情報文字列
00010000 | ビジョンツールエラーです。
00010001 | 無効な画像メモリです。
00010001 | 入力した領域が小さすぎます。
00010002 | 入力した領域が画像境界を超えています。

ReadIDCode 関数のエラー文字列

診断コード | 対応する情報文字列
00019000 | IDMax ビジョン処理エラーです。
04010000 | ReadCompositeCode エラーです。
04010001 | 2D コンポーネントアドレスパターンを検出できません。
04010002 | 無効な 2D コンポーネント画像データが多すぎます。
04010003 | 2D コンポーネントシンボルバージョンを検出できません。
04010004 | 欠落している 2D コンポーネントアドレスパターンを埋めることができません。
04010005 | スキャンラインが無効な画像データを検出しました。
04010006 | スキャンラインが画像境界を超えています。
04010007 | 1D コンポーネントファインダパターンを検出できません。
04010008 | 無効な 1D コンポーネント画像データが多すぎます。
04010009 | 有効なシンボルが見つかりません。
04010010 | 訂正の必要なシンボルエラーが多すぎます。
04010011 | 誤り訂正に失敗しました。
04010012 | 1D と 2D がデコード可能ですが、関連付けられていません。
04010013 | 自動コントラストしきい値計算に失敗しました。
04010014 | コントラスト感度が許容範囲を超えています。
04010015 | スキャンパラメータが許容範囲を超えています。
04020000 | ReadIDCode エラーです。
04020001 | 有効なシンボルが見つかりません。
04020002 | シンボルをデコードできませんでした。
04030001 | シンボルが検出されましたが、デコードできませんでした。
04030002 | シンボルが検出されなかったか、デコードされませんでした。
04030003 | ReadIDCode 操作がタイムアウトになりました。
04030004 | デコードを試みているときに、センサがメモリ不足になりました。
04030005 | ReadIDCode が予期せずに失敗しました。
04030006 | VerifyIDCode に無効な ReadIDCode セル参照があります。
04030007 | ReadIDCode に無効な画像セル参照があります。
04030008 | [アルゴリズム] チェックボックスが ON のときには、No-Read 診断はデータマトリックスまたは QR コードについてのみサポートされます。
04030009 | ReadIDCode プロパティシートの [アルゴリズム] チェックボックスがオンになっていません。

VerifyIDCode 関数および ValidateIDCode 関数のエラー文字列

診断コード | 対応する情報文字列
04040001 | シンボルの識別子エラー。
04040002 | パターンマッチに失敗しました。
04040003 | 無効なフィールド識別子です。
04040004 | 無効なアプリケーション識別子 (AI) です。
04040005 | 無効なデータ識別子 (DI) です。
04040006 | 無効なテキスト要素識別子 (TEI) です。
04040007 | 無効なフィールドデータです。
04040008 | 無効なフィールドセパレータです。
04040009 | データは ISO 15434 準拠ではありません。
04040010 | サポートされないフォーマットです。
04040011 | 無効なフォーマットコードです。
04040012 | ISO 15434 シンタックスは、このコードではサポートされません。
04040013 | フィールドは、このアプリケーションでは無効です。
04040014 | アプリケーションフィールドはサポートされていません。
04040015 | 無効なアプリケーションデータです。
04040016 | 複数のフォーマットが存在します。
04040017 | 重複するフィールドがあります。
04040018 | 無効な DoD UID コンストラクト #1 データです。
04040019 | 無効な DoD UID コンストラクト #2 データです。
04040020 | 無効な DoD UID データです。
04040021 | フォーマットトレーラ文字が欠落しています。
04040022 | メッセージトレーラ文字が欠落しています。

ImportData/ExportData 関数のエラー文字列

診断コード | 対応する情報文字列
05030000 | ファイル名がありません。
05030001 | ユーザ名がありません。
05030002 | ファイルタイプが .CXD ではありません。
05030003 | ファイル名が長すぎます。
05030004 | メモリ割り当てエラーです。
05030006 | ローカルフラッシュメモリがエクスポート先として指定された場合、AcquireImage を ExportData のイベントにすることはできません。
05030007 | サポートされないデータタイプです。
05030008 | データがファイルにありません。
05030009 | データ解析エラーです。
05030010 | サポートされないデータタイプです。
05030011 | ファイル操作エラーです。

PatMax の情報およびエラー文字列

診断コード | 対応する情報文字列
07010000 | パターンに含まれるマッチ特徴が少なすぎることがあります。
07010001 | 特徴の粒度を自動的に設定するのは困難です。
07010100 | 手動で [粒度] を設定してください。登録画像の表示がぼやけているので、パターンが予想より正確でないことがあります。
07010102 | 疎粒度の特徴が同じ方向であるために、パターン結果が不安定になることがあります。
07010200 | 高精度な特徴が多いため、実行時間が長くなることがあります。手動で [粒度] を設定してください。
07010101 | パターンに含まれる情報が不十分なため、角度またはスケールを正確に測定できないことがあります。
07020300 | コントラストが低いため、結果は破棄されました。
07020301 | より正確な結果を得るため、結果は破棄されました。
07020302 | クラッタが多すぎるため、結果は破棄されました。
07020303 | 現在のパラメータ設定に対して、登録パターンに含まれる特徴が少なすぎます。
07030000 | エラー情報はありません。

汎用エラー文字列

診断コード | 対応する情報文字列
09990100 | 対応付けデータのサイズはゼロです。
09990101 | ビューで指定したポイントが 9 未満です。
09990102 | 無限にマップします。
09990103 | 無効なポイント構成です。
09990104 | 固有パラメータの検索に失敗しました。
09990500 | 内部 CalibrateGrid エラーです。

ComputeStats 関数のエラー文字列

診断コード | 対応する情報文字列
03040700 | 関数の入力値が無効です。

畳み込みフィルタのエラー文字列

診断コード | 対応する情報文字列
03210002 | 行と列の数は 1 ～ 10 の範囲でなければなりません。
03210004 | カーネル値は -9999 ～ 9999 の範囲でなければなりません。
注 : #ERR に対応するエラー文字列がない場合、GetErrorCode 関数は -1 を返します。

エラー文字列を返さない #ERR については、エラーとなっているセル関数の各パラメータを調べることによって、#ERR の原因を究明することができます。 数式内のセル参照を調べて、それらの値を確認してください。 複雑なジョブの場合は、いくつかの参照や入れ子型の参照を追跡する必要が生じる場合もあります。

画像取り込み関数の一部の機能 (部分取り込み、照明制御など) は、エミュレータではサポートされていません。In-Sight センサ上でこれらの機能を使用したジョブを作成し、そのジョブをエミュレータにロードすることは可能ですが、このとき、セル A0 の AcquireImage 関数が #ERR を報告することがあります。

#ERR を無視してエラーの拡散を防止する方法

ExtractBlobs ツールにより検出された複数のブロブの合計面積を計算するケースを考えて見ましょう。GetArea 関数を使用して、ブロブ構造体から個々のブロブの面積を取得します。 ブロブが検出されないと、GetArea 関数は正常に実行されませんが、アプリケーションでは正常な状況である場合があります。

セル | 関数 | 説明
A1 | ExtractBlobs([パラメータ]) | ブロブを抽出して、ブロブ構造体を返します。
B1 | GetArea(A1,0) | ブロブ 0 の面積を返します。
B2 | GetArea(A1,1) | ブロブ 1 の面積を返します。
B3 | GetArea(A1,2) | ブロブ 2 の面積を返します。
B4 | Sum(B1:B3) | ブロブの総面積を計算します。
ExtractBlobs 関数が 3 つ以上のブロブを検出できないと、1 つ以上の GetArea セルが #ERR を報告するために、数式 Sum(B1:B3) は、#ERR を報告します。このエラー状態を無視するには、次の ErrFree 関数を使用します。
B4 | Sum(ErrFree(B1:B3)) | ブロブの総面積を計算します。

ErrFree 関数を使用すると #ERR が 0 に置き換えられます。したがって、この Sum の入力パラメータに含まれる #ERR の値はすべて 0 として処理されます。


エラーメッセージ

詳細と可能な解決方法については、次のいずれかのエラーを選択してください。

Error: 参照深度の最大値を超えています。

Error 3000: <番号> は正しい値ではありません。

Error 5000: セグメントが検出されませんでした。

Error 5001: フォントに登録された文字数が最大値に達しています。

Error 5100: 入力した In-Sight ホスト名は既に存在します。

Error 5101: このホスト名は使用できません。

Error 5102: このホスト名は使用できません。

Error 5106: この IP アドレスは使用できません。

Error 5107: IP アドレスは既に定義されています。

Error 5200: パスワードが間違っています。

Error 5201: 入力したユーザ名は既に存在します。

Error 5300: <ホスト名> を再起動できません。

Error 5301: <ホスト名> の再起動の際にエラーが発生しました。

Error 5302: <ホスト名> へのネイティブモード接続を確立できません。

Error 5400: 未知の接続エラーです。

Error 5401: 接続が拒否されました。

Error 5402: 不正なユーザ名またはパスワードです。

Error 5403: 不正なユーザ名またはパスワードです。

Error 5404: <ホスト名> に接続できません。

Error 5405: 内部の接続/切断エラーです。

Error 5406: バージョンが一致しませんでした。

Error 5407: <ユーザ名> に合わせてアクセス権レベルを調整する必要があります。

Error 5408: ユーザ <ユーザ名> は既にこのシステムにローカル接続しています。

Error 5409: <ホスト名> からのユーザ <ユーザ名> は既にこのシステムにリモート接続しています。

Error 5410: ドラッグ & ドロップリストには有効なファイルがありません。

Error 5500: 画像をファイル <ファイル名> に保存できません。

Error 5501: ジョブをファイル「ファイル名」に保存できません。

Error 5502: エミュレータ上のファイル名 image.bmp、image.jpg、screen.bmp または screen.jpg に保存できません。

Error 5503: <フォルダ名> という名前の新しいフォルダを作成できませんでした。

Error 5504: <フォルダ名> という名前のフォルダは既に存在します。

Error 5506: 画像ファイル <ファイル名> を開くことができません。

Error 5507: ジョブファイル <ファイル名> を開くことができません。

Error 5600: IP アドレス <IP アドレス> を持つデバイスがネットワーク上に検出されました。

Error 5700: 数式が複雑すぎます。

Error 5701: 数式が不正です。

Error 5800: 未知のネイティブモード応答です。

Error 5801: 未知のネイティブモードコマンドです。

Error 5802: コマンドを実行できる権限を持っていません。

Error 5803: ネイティブモードコマンドエラーです。

Error 6000: レイアウトを回復できません。

Error 6001: UDP ポート 1069 を開くことができません。

Error 6002: エミュレータを停止できませんでした。

Error 6003: エミュレータを起動できませんでした。

Error 6004: レポートを書き込むことができませんでした。

Error 6005: スタイルシート <ファイル名> をコピーできませんでした。

Error 6006: リリースノート <ファイル名> を表示できませんでした。

Error 6007: <ホスト名> からディレクトリを取得できません。

Error 6008: <ホスト名> へのリンクを確立できませんでした。

Error 6010: ファイル <ファイル名> をバックアップできません。

Error 6011: <ホスト名> のバックアップディレクトリを作成できません。

Error 6012: <ホスト名> への FTP セッションを閉じるときに例外が発生しました。

Error 6015: <ホスト名> のバックアップディレクトリが見つかりません。

Error 6016: <ファイル名> の削除は許可されていません。

Error 6017: <ファイル名> を削除する際にエラーが発生しました。

Error 6018: <ファイル名> をコピーする際にエラーが発生しました。

Error 6019: <ファイル名> のコピーは許可されていません。

Error 6020: In-Sight センサ <ホスト名> はオンラインのままです。

Error 6021: <ホスト名> のオンラインステータスを検出できません。

Error 6022: <ホスト名> のオンラインステータスを設定できません。

Error 6023: <ホスト名> のオフラインステータスを確認できません。

Error 6024: <ホスト名> をバックアップできません。

Error 6025: <ホスト名> のオンラインステータスをリストアできません。

Error 6027: <ホスト名> の再起動がタイムアウトになりました。

Error 6028: <ホスト名> の再起動の際にエラーが発生しました。

Error 6030: <ホスト名> から設定を読み取ることができません。

Error 6031: <ホスト名> からネットワーク設定を取得できません。

Error 6032: <ファイル名> に設定を書き込むことができません。

Error 6033: <ファイル名> にネットワーク設定を書き込むことができません。

Error 6034: <ホスト名> にネットワーク設定を保存することができません。

Error 6035: 不正なホスト名が検出されました。

Error 6036: このホスト名は使用できません。

Error 6037: ホスト名は既に定義されています。

Error 6038: 不正な IP アドレスが検出されました。

Error 6039: この IP アドレスは使用できません。

Error 6040: IP アドレスは既に定義されています。

Error 6041: セキュリティキーが無効です。

Error 6042: レジストリを書き込む際にエラーが発生しました。

Error 6043: エミュレータに接続できませんでした。

Error 6044: Options.xml ファイルの書き出しに失敗しました。

Error 6046: <ホスト名> のバックアップディレクトリを作成できません。

Error 6047: In-Sight センサがネットワーク上で検出されず、オフラインプログラミングライセンスが入力されていなかったため、エミュレータは起動しませんでした。

Error 6304: ディレクトリ <ホスト名> を開くことができません。

Error 6308: <ホスト名> のバックアップディレクトリが見つかりません。

Error 6421: <ホスト名> に接続できません。

Error 6441: <ホスト名> のバックアップディレクトリが見つかりません。

Error 7001: 未知のエラーです。

Error 7003: ホスト <ホスト名> に接続できませんでした。

Error 7700: 入力したアカウントはネットワーク上のどの In-Sight ビジョンセンサに対するフルアクセス権限も持っていません。

Error 7705: IP アドレス <IP アドレス> は既存の In-Sight ビジョンセンサの IP アドレスと競合しています。

Error 7706: IP アドレス <IP アドレス> はネットワーク上に既に存在する別のデバイスと競合しています。

Error 7707: IP アドレス <IP アドレス> は別の In-Sight ビジョンセンサで使用する IP アドレスと競合しています。

Error 7708: ホスト名 <ホスト名> は既存の In-Sight ビジョンセンサのホスト名と競合しています。

Error 7709: ホスト名 <ホスト名> は別の In-Sight ビジョンセンサで使用するホスト名と競合しています。

Error 7711: 設定時に I/O エラーが発生しました。

Error 7712: 設定が失敗しました。

Error 7713: In-Sight ビジョンセンサはオンラインでは設定できません。

Error 7714: ビジョンセンサはオンラインです。設定されませんでした。

Error 7715: In-Sight ビジョンセンサをオフラインにすることができませんでした。

Error 7718: 検証が失敗しました。

Error 7719: 設定が中断されました。

Error 7720: 不正なホスト名が検出されました。

Error 7721: 不正な IP アドレスが検出されました。

Error 7722: 無効な DHCP 設定が検出されました。

Error 7723: 無効な DNS サーバが検出されました。

Error 7724: 無効なデフォルトゲートウェイサーバが検出されました。

Error 7725: 無効なサブネットマスクが検出されました。

Error 7726: 無効なドメインが検出されました。

Error 7727: 不正なユーザ名またはパスワードです。

Error 7728: In-Sight ビジョンセンサに接続できませんでした。

Error 7729: In-Sight ビジョンセンサは正常に再起動されませんでした。

Error 7731: このデバイスではネットワーク設定を行えませんでした。

Error 7740: 選択したネットワークインタフェースが接続されていません。

Error 7741: 選択したネットワークインタフェースは現在 DHCP を使用しています。

Error 7742: 選択したネットワークインタフェースは現在 DHCP を使用しており、0.0.0.0 という IP アドレスを持っています。 この手順を継続するには、ネットワークインタフェースで固定 IP アドレスを再設定する必要があります。

Error: 参照深度の最大値を超えています。

セル参照チェーンに含まれる参照の最大値は 256 セルで、このエラーは、参照チェーンが 256 を上回ったときに表示されます。このエラーは、インデックス番号を作成するときによく発生します (例: B0=0; B1=B0+1; B2=B1+1; B3=B2+1...B255=B254+1; B256=B255+1; B257=B256+1 → エラーがトリガされます)。このエラーを回避するには、参照チェーンにブレイクをハードコーディングします (例: B0=0; B1=B0+1; B2=B1+1; B3=B2+1...B199=B198+1; B200=200 → ハードコーディングされた上限。この結果、参照深度が 56 残るため、チェーンに追加されるほかのセルはこれを使用できます。その後、チェーンを再開します。B201=B200+1...B255=B254+1; B256=B255+1; B257=B256+1 → エラーはトリガされません)。

Error 3000: <番号> は正しい値ではありません。

Explorer のホストテーブルのエントリが持つ IP アドレスの最初のオクテットは、1 ～ 223 である必要があります。また、4 番目のオクテットは、1 ～ 254 である必要があります。0.5.2.8 や 10.40.6.255 などの IP アドレスは使用できません。

Error 5000: OCV セグメントが検出されませんでした。

In-Sight Explorer は、定義されている領域に文字インスタンスを検出できませんでした。[OCV/OCR フォントの登録] ダイアログボックスで極性 ([黒 (白い背景)] または [白 (黒い背景)]) が正しく設定されていることと、必要な文字の周囲をサーチ領域が正しく囲んでいることを確認してください。

Error 5001: フォントに登録された文字数が最大値に達しています。

TrainFont 関数には最大 64 種類の文字を登録できます。新しいモデルを追加する前に、既存の不要なモデルを削除してください。

Error 5100: 入力した In-Sight ホスト名は既に存在します。

既に存在するホストを In-Sight ホストテーブルに追加しようとしました。ほかの名前を指定してください。

Error 5101: このホスト名は使用できません。

ホスト名は必須であり、空白にすることはできません。ホストの名前を選択してください。

Error 5102: このホスト名は使用できません。

無効なホスト名を使用して Explorer のホストテーブルを定義しようとしました。一部のホスト名はシステム専用であり、ホストテーブル名には使用できません。ほかの名前を指定してください。

Error 5106: この IP アドレスは使用できません。

無効な IP アドレスを持つホストを In-Sight ホストテーブルに追加しようとしました。ほかの IP アドレスを指定してください。

Error 5107: IP アドレスは既に定義されています。

既存のホストテーブルエントリに登録済みの IP アドレスを持つホストを In-Sight ホストテーブルに追加しようとしました。ほかの IP アドレスを指定してください。

Error 5201: 入力したユーザ名は既に存在します。

In-Sight のユーザ名は一意である必要があります。既存のユーザと同じ名前で新しいユーザを入力しようとすると、Error 5201 が表示されます。

Error 5302: <ホスト名> へのネイティブモード接続を確立できません。

<ホスト名> のネイティブモードチャネルが In-Sight Explorer への応答を停止しました。センサを再起動して、操作をやり直してください。

Error 5403: 不正なユーザ名またはパスワードです。

別のユーザが既にセンサにログオンしている場合に、有効なユーザ名と間違ったパスワードでセンサにログオンしようとすると、Error 5403 が表示されることがあります。

Error 5404: <ホスト名> に接続できません。

In-Sight Explorer が <ホスト名> への 1069 番ポート経由の TCP ソケットを作成できない場合、Error 5404 が発生します。

このエラーは通常、ファイアウォールによって TCP ソケットの作成が妨げられたか、Windows が適切なネットワークインタフェースカード (NIC) ではなく別の NIC でアクセスしようとして発生します。

一般に、Windows から <ホスト名> への Telnet または FTP 接続を確立できる場合は、In-Sight Explorer によって、センサへの TCP ソケットを作成することができます。

Windows のコマンドプロンプトで、「telnet aaa.bbb.ccc.ddd 1069」 (aaa.bbb.ccc.ddd は <ホスト名> の IP アドレス) と入力してください。Telnet でそのポートへのソケット接続を作成できない場合は、In-Sight Explorer でも作成することはできません。

LMHOSTS に関する注意:

NetBIOS 名前解決用に Microsoft Windows 内の LMHOSTS ファイルを使用しており、異なるサブネットでの通信用にネットワーク設定を最近変更した場合は、LMHOSTS ファイルを調べて、<ホスト名> が適切な IP アドレスに割り当てられていることを確認してください。

Error 5405: 内部の接続/切断エラーです。

In-Sight Explorer は、ウィンドウのタイトルバーに示されているセンサと通信ができなくなりました。センサが起動されており、ネットワーク上で正常に通信していることを確認してください。必要に応じて、センサの電源を入れ直してください。

Error 5406: バージョンが一致しませんでした。

異なるバージョンの In-Sight Explorer または PC Host で作成されたジョブファイルをロードすると、バージョン不一致エラーまたは警告が表示されることがあります。ジョブファイルを保存し直すと、バージョン情報が更新されます。

バージョンスタンプが一致しません。ジョブは <バージョンスタンプ番号> で、センサは <バージョンスタンプ番号> です。ロードを続行しますか？

ロードしようとしているジョブと、ロード先の In-Sight ビジョンシステム/エミュレータとの間でバージョンスタンプが一致しません。このエラーは、ある In-Sight ソフトウェアまたはファームウェアを使用して作成したジョブを、異なるバージョンを使用してロードしようとする場合に発生します。

この警告は、ジョブとビジョンシステムの互換性の問題については表示しません。そのような互換性の問題がある可能性を注意喚起することを意図しています。この警告の後にジョブのロードに失敗したことに関するほかのエラーメッセージが表示されない場合、ビジョンシステム/エミュレータには互換性があるため、これ以上の操作は必要ありません。エラーメッセージが表示される場合は、このジョブファイルを修正して、ビジョンシステム/エミュレータで実行するファームウェアとの完全な互換性を確保する必要があります。

Error 5501: ジョブをファイル <ファイル名> に保存できません。

Error 5501 は、次のエラーメッセージとともに表示されます。

オンライン中はジョブファイルを保存できません
アクティブな In-Sight センサがオンラインのときに、ジョブファイルを保存しようとしました。[フル] または [プロテクト] アクセス権を持つ場合、センサをオフラインにするか、または [ユーザ] ダイアログで [Allow Online Job Save] チェックボックスをオンにしてから、操作をやり直します。このエラーは、ローカルエミュレータを無効にしようとするときに、[オプション] ダイアログで表示されることがあります。

Error 5507: ジョブファイル <ファイル名> を開くことができません。

Error 5507 は、次のエラーメッセージとともに表示されます。

アクセスは拒否されました
このメッセージは、ファイル名に中国語または韓国語の文字が含まれ、In-Sight Explorer の [言語] ([システム] → [オプション] → [言語]) が [中国語] または [韓国語] にそれぞれ設定されていない場合に、Windows エクスプローラからスプレッドシートにジョブファイルをドラッグ & ドロップしたときに表示されることがあります。ファイル名に応じた適切な [言語] を In-Sight Explorer に設定してから再起動し、操作をやり直してください。

Error 5700: 数式が複雑すぎます。

1 つの式で使用できる関数、引数、および演算子の最大数は、全体で 254 です。関数の引数がセルの範囲にある場合、その範囲内の各セルは 1 つの引数としてカウントされます。

例えば、Sum(1,2,A3:A6) という数式は、1 つの関数 (Sum) と 6 つの引数 (1、2、A3、A4、A5、A6) によって構成されています。つまり、この数式では、使用可能な 254 の要素のうちの 7 つを使用しています。

Error 5701: 数式が不正です。

Error 5701 は、数式をスプレッドシートのセルまたは数式バーに入力するときに、数式のいずれかの部分に修正の必要がある場合に表示されます。図のように、無効な構文は赤色でハイライトされます。赤色のテキストが表示されずに Error 5701 だけが表示された場合:

  • 関数名が完全に入力されていないか、その関数に必要なすべての引数が提供されていない可能性があります。
  • 関数が 254 以上の引数を参照している可能性があります。1 つの式で使用できる引数の最大数は 253 です。関数の引数がセルの範囲にある場合、その範囲内の各セルは 1 つの引数としてカウントされます。例えば、「Sum(C1:C254)」は、この関数が範囲 (C1:C254) 内の 254 の引数を参照しているため、このエラーメッセージが表示されます。詳細については、Error 5700 を参照してください。

Error 6000: レイアウトを回復できません。

In-Sight Explorer を起動すると、In-Sight Explorer は、アプリケーションのルートフォルダにある options.xml ファイルからの起動レイアウトのロードを試みます。起動レイアウトで定義されているホストが、ネットワーク上に検出されない場合、このエラーが表示されます。

Error 6000 は、起動レイアウトが保存された後に、問題のセンサまたはエミュレータのホスト名が変更されていると発生します。この問題は、次の手順で [レイアウトを保存する] をもう一度実行すると解決します。

  1. In-Sight Explorer の起動時に自動ログオンさせたい In-Sight センサにログオンします。
  2. 必要に応じて、ビューの表示レイアウト (タイル表示または単一の最大表示) を調整します。
  3. [システム] メニューの [表示レイアウトを保存] をクリックします。

Error 6001: UDP ポート 1069 を開くことができません。

In-Sight Explorer は、UDP ポート 1069 を開いて、TCP/IP ネットワーク上の In-Sight センサと通信します。一部の PC アプリケーション (Microsoft Outlook や Microsoft IIS Admin サービスなど) は、ランダムな UDP ポートを開きます。これによって、In-Sight Explorer の動作が妨げられることがあります。次のエラーメッセージが表示される場合は、

Error 6001: UDP ポート 1069 を開くことができません。In-Sight Explorer はネットワーク上の In-Sight センサを検出することができません。[OK] をクリックして続行します。

すべてのアプリケーションを閉じて、In-Sight Explorer を再起動してください。ほかのすべてのアプリケーションを閉じてもこのエラーメッセージが表示される場合は、PC を再起動してから In-Sight Explorer を起動してください。In-Sight Explorer をインストールすると、そのほかの Windows アプリケーションがこれらのポートを使用できないようにするためのレジストリエントリが作成されますが、このレジストリエントリは PC を再起動するまで有効になりません。

Error 6003: エミュレータを起動できませんでした。

アプリケーションの起動時に、[In-Sight ネットワーク] のツリーに表示された In-Sight センサやエミュレータと通信できない場合、このエラーが表示されることがあります。このエラーは、Explorer のホストテーブルで定義されているホストが、ネットワークでアクセスできない場合に起動レイアウトに含まれていると発生します。

<ホスト名> で示されている In-Sight センサまたはエミュレータの電源が入っており、ネットワークで通信できることを確認してください。このセンサが Explorer のホストテーブルのエントリである場合は、ホストテーブルのエントリの IP アドレスが、ネットワーク設定で定義されている <ホスト名> の実際の IP アドレスと一致することを確認してください。

Error 6003 は、Internet Information Services (IIS) Admin サービスが Windows の [コントロールパネル] で起動している場合に表示されることもあります。このサービスが動作している場合は停止して、In-Sight Explorer を再起動してください。IIS Admin サービスは、In-Sight Explorer が起動した「後」に再起動させることができます。

Error 6003 は Error 6001 とともに表示される場合があり、Error 6001 の解決手順で問題が解決することもあります。

Error 6004: レポートを書き込むことができませんでした。<ファイル名>

In-Sight Explorer は、<ファイル名> をディスクに書き込むことができませんでした。ドライブが存在し、レポートファイルを書き込むための十分な空き容量があることを確認してください。<ファイル名> がネットワークドライブを指している場合は、ドライブが接続されており、そのドライブへの書き込みアクセス権があることを確認してください。

Error 6007: <ホスト名> からディレクトリを取得できません。

In-Sight Explorer は、<ホスト名> からファイルディレクトリ情報を取得できませんでした。このフォルダに含まれる、ファイルを表示する権限が、ユーザアカウントにない可能性があります。<ファイル名> のローカル FTP ポートが、[オプション] ダイアログで指定されている Explorer の FTP ポートと一致していることを確認してください。

Error 6008: <ホスト名> へのリンクを確立できませんでした。

In-Sight Explorer は、アクセス先ホストにリンクできませんでした。ホストがダウンしているか、メッセージが表示されたときに、リンクを完了しないことを選択している可能性があります。

接続が拒否されました: 接続

In-Sight Explorer は、現在 [In-Sight ネットワーク] で選択されているセンサと通信できません。[表示] メニューで [更新] を選択して、[In-Sight ネットワーク] の表示を更新してください。それでもセンサにアクセスできない場合は、センサの電源を入れ直して、操作をやり直してください。

パスワードが間違っていました。ログインできません。

現在のユーザは、<ホスト名> のファイルを表示するためのアクセス権を持っていません。このセンサに保存されているファイルを表示できるアクセス権を持つ、別のユーザとしてログオンして、操作をやり直してください。

Error 6010: ファイル <ファイル名> をバックアップできません。

Error 6010 は、次のエラーメッセージとともに表示されます。

ファイルが見つかりません

<ファイル名> は、In-Sight ファイルシステムに対して無効である可能性があります。ファイル名に記号や特殊文字が含まれていないことを確認してください。ファイル名を変更して、操作をやり直してください。

Error 6011: <ホスト名> のバックアップディレクトリを作成できません。

[システム] メニューで、[オプション] をクリックします。[バックアップディレクトリ] が有効なフォルダ名であり、このフォルダに Windows エクスプローラからアクセスできることを確認してください。

In-Sight センサのフラッシュメモリ空き容量が不足しているためにファイルを保存できないとき

このエラーは、In-Sight ファイルシステムに対してファイル名が長すぎたり、ファイルサイズが大きすぎてコピー先センサに保存できなかったりすると、表示されることがあります。次のパスにあるバックアップディレクトリを確認してください。

<ISE dir>\Backups\<ホスト名>

ここで <ISE dir> は、In-Sight Explorer がインストールされているフォルダです。また <ホスト名> は、コピー先 In-Sight センサの名前です。<ファイル名> は最大 251 文字 (拡張子を除く) です。コピー先センサに多数のファイルが保存されている場合は、ほかのファイルを削除して、リストア操作をやり直してください。または、[In-Sight のファイル] ペインや Windows エクスプローラを使用して、ファイルを手動でコピーしてください。

エミュレータ上のファイルをリストアしているとき

エミュレータのリストアを試みているときに、ファイル (image1A.bmp、image1B.bmp、image2A.bmp など) が読み取り専用の場合、このエラーが発生します。読み取り専用属性を削除してから、リストア操作をやり直してください。

Error 6015: <ホスト名> のバックアップディレクトリが見つかりません。

In-Sight Explorer は、<ホスト名> のバックアップフォルダを確認できませんでした。バックアップフォルダが次のパスに格納されていることを確認してください。

<InSight2>\Backups

ここで <InSight2> は、In-Sight Explorer がインストールされているフォルダです。バックアップはセンサのホスト名と同じ名前のサブフォルダとして格納されます。このフォルダが移動または削除されたり、フォルダの名前が変更されたりしていないか確認してください。バックアップディレクトリの命名方法の詳細については、Error 6046 を参照してください。

Error 6016: <ファイル名> の削除は許可されていません。

In-Sight ファイルシステム内の一部のファイルはセンサの動作に不可欠であるため、削除できません。次のファイルは、In-Sight センサやエミュレータから削除できません。

  • proc.set
  • image.bmp
  • image.jpg
  • screen.bmp
  • screen.jpg

Error 6017: <ファイル名> を削除する際にエラーが発生しました。

In-Sight Explorer は、In-Sight システムから <ファイル名> を削除できませんでした。ファイルが読み取り専用でないことを確認してください。

ファイルがリモートで削除された可能性があります。ファイルを選択し、F5 キーを押して、[In-Sight のファイル] ペインを更新してください。

Error 6018: <ファイル名> をコピーする際にエラーが発生しました。

In-Sight Explorer は、<ファイル名> をコピー先 In-Sight センサにコピーできませんでした。Error 6018 とともに、次のメッセージが表示される場合があります。

転送に失敗しました - メモリが不足しています

ファイルを転送するために必要なフラッシュメモリ空き容量が不足している可能性があります。いくつかのファイルを削除してから、ファイルをコピーし直してください。

書き込みの権限がありません

上書きしようとしたファイルは、読み取り専用でした。アクセス制限を解除して、コピーし直してください。

ファイルが見つかりません

コピーしようとしたファイルが、コピー元センサに存在しませんでした。[In-Sight のファイル] ペインを更新して (F5 キー)、コピー元センサにファイルが存在することを確認してください。

ファイルのドラッグ & ドロップ操作に問題があります

問題 #1: 英語版のオペレーティングシステムで、韓国語または中国語の文字を含むファイル名を Windows エクスプローラから [In-Sight のファイル] ペインにドラッグ & ドロップすると、Error 6018 が発生します。

問題 #2: 韓国語版のオペレーティングシステムでは、Windows エクスプローラから [In-Sight のファイル] ペインにドラッグ & ドロップできるのは韓国語または英語の文字を含むファイル名だけです。そのほかの文字では Error 6018 が発生します。

問題 #3: 中国語版のオペレーティングシステムでは、Windows エクスプローラから [In-Sight のファイル] ペインにドラッグ & ドロップできるのは中国語または英語の文字を含むファイル名だけです。そのほかの文字では Error 6018 が発生します。

回避策:

  • [ジョブを開く] ダイアログ ([ファイル] → [ジョブを開く]) を使用して、ファイルをロードします。
  • ファイル名には英語の文字を使用します。

Error 6019: <ファイル名> のコピーは許可されていません。

一部のファイル (proc.set など) は非常に重要なネットワーク設定を含むため、別のセンサに単純にコピーすることはできません。

Error 6035: ホスト名が不正です。

Error 6035 は、新しいホストを Explorer のホストテーブルに追加する際に、[ホスト名] フィールドが空白のままになっていると表示されます。ホスト名を入力して、[OK] をクリックしてください。

Error 6036: このホスト名は使用できません。

Error 6036 は、Explorer のホストテーブルのエントリにあるホスト名を PC と同じ名前に設定しようとすると表示されます。ほかのホスト名を指定して、[OK] をクリックしてください。

Error 6037: ホスト名は既に定義されています。

Explorer のホストテーブルに追加しようとしたホスト名は、既にホストテーブルに存在します。ほかのホスト名を指定して、[OK] をクリックしてください。

Error 6038: IP アドレスが不正です。

一部の IP アドレス (0.0.0.0 など) は、Explorer のホストテーブルのエントリには使用できません。有効な IP アドレスを指定してください。

Error 6039: この IP アドレスは使用できません。

Error 6039 は、新しいホストを Explorer のホストテーブルに追加する際に、[IP アドレス] フィールドが空白のままになっていると表示されます。一部の IP アドレス (ルックバックアドレスの 127.x.x.x など) は、Explorer のホストテーブルのエントリには使用できません。有効な IP アドレスを指定してください。

Error 6040: IP アドレスは既に定義されています。

1 つの IP アドレスは、Explorer のホストテーブルにある 1 つのホストテーブルエントリにのみ、対応することができます。同じ IP アドレスで 2 つ目のセンサを追加しようとすると、Error 6040 が表示されます。

Error 6041: セキュリティキーが無効です。

[オプション] ダイアログに入力したオフラインプログラミングキーは無効です。弊社の販売代理店または弊社テクニカルサポートに連絡して、有効なキーを入手してください。

Error 6042: レジストリを書き込む際にエラーが発生しました。

Error 6042 は、管理者権限を持たないユーザとして Windows にログオンしている場合に、オフラインプログラミングキーを入力したときに表示されることがあります。 Windows からログオフして、管理者として PC にログオンし直してください。 その後、操作をやり直してください。

Error 6044: Options.xml ファイルの書き出しに失敗しました。

In-Sight Explorer は、オプションファイルを保存できませんでした。options.xml (In-Sight Explorer のインストールフォルダにあります) が読み取り専用になっていないことと、別のアプリケーションで開かれていないことを確認してください。

Error 6046: <ホスト名> のバックアップディレクトリを作成できません。

In-Sight Explorer では、センサ名ごとに最大 256 のバックアップを作成することができます。これ以上のバックアップを作成しようとすると、Error 6046 が表示されることがあります。新しいインクリメンタルバックアップ (sensor.002 や sensor.003 など) は、フォルダ内で一番大きな番号が付けられているバックアップに基づいて作成されます。

例えば、IS3K という名前の In-Sight センサのバックアップを既に 100 個作成している場合、バックアップディレクトリには IS3K、IS3K.001、IS3K.002、...、IS3K.099 という名前のフォルダが作成されています。IS3K.099 が存在する限り、次に作成されるバックアップは、(ほかのすべてのバックアップが削除されていても) IS3K.100 に格納されます。

Error 6046 を解決するには、Windows エクスプローラでバックアップディレクトリを参照して、<ホスト名> の大きな番号が付いたバックアップを削除してください。または、バックアップを別のフォルダに移動してください。ただし、In-Sight Explorer がバックアップをリストアするには、バックアップしたファイルがバックアップディレクトリに存在する必要があるので注意してください。

Error 6047: In-Sight センサがネットワーク上で検出されず、オフラインプログラミングライセンスが入力されていなかったため、エミュレータは起動しませんでした。

Error 6047 は、オフラインプログラミングキーが入力されていない状態で、かつ、In-Sight センサがネットワーク上で検出されなかった場合に表示されます。このエラーは、アクティブなネットワーク接続がない場合に発生することがあります。ネットワーク上にセンサが検出されない場合、このキーが入力されていないとローカルエミュレータは起動しません。

Error 6304: ディレクトリ <ホスト名> を開くことができません。

In-Sight Explorer は、<ホスト名> でバックアップを実行できませんでした。[オプション] ダイアログで適切なバックアップディレクトリが定義されていることと、そのディレクトリが読み取り専用になっていないことを確認してください。

Error 6308: <ホスト名> のバックアップディレクトリが見つかりません。

<ホスト名> のリストア操作を実行しようとしましたが、In-Sight Explorer は、このセンサのバックアップファイルを確認できませんでした。[オプション] ダイアログで定義されているバックアップディレクトリが適切であることと、<ホスト名> のバックアップが保存されているフォルダを適切に指定していることを確認してください。

Error 6421: <ホスト名> に接続できません。

このエラーは、バックアップからセンサをリストアしようとすると表示されることがあります。このセンサにアクセスする権限が、ユーザアカウントにない可能性があります。また、In-Sight センサの電源が入っていることと、ネットワークケーブルが適切に接続されていることを確認してください。

Error 6441: <ホスト名> のバックアップディレクトリが見つかりません。

バックアップされていないセンサをリストアしようとしたか、PC からそのセンサのバックアップフォルダにアクセスできませんでした。<ホスト名> でのバックアップ操作が既に実行されていることと、[オプション] ダイアログで適切なバックアップディレクトリが定義されていることを確認してください。

Error 7003: ホスト <ホスト名> に接続できませんでした。

In-Sight Explorer は、<ホスト名> への接続を確立できませんでした。Error 7003 は、次のエラーメッセージとともに表示されることがあります。

<ホスト名> からのユーザ <ユーザ名> は既にこのシステムにリモート接続しています。

操作を完了するには、[はい] をクリックして、ログオンからやり直してください。

Error 7708: ホスト名 <ホスト名> は既存の In-Sight ビジョンセンサのホスト名と競合しています。

既に存在するホストを Explorer のホストテーブルに追加しようとしました。ほかの名前を指定してください。

Error 7712: 設定が失敗しました。

[センサ/デバイスをネットワークに追加] ダイアログは、In-Sight センサを適切に設定できませんでした。詳細なトラブルシューティング情報については、ダイアログで Error 7712 の後に表示されるエラーメッセージを参照してください。

Error 7718: 検証が失敗しました。

[センサ/デバイスをネットワークに追加] ダイアログを使用して設定しようとしたネットワーク設定は適用できませんでした。固有のトラブルシューティング情報については、ダイアログで Error 7718 の後に表示されるエラーメッセージを参照してください。

Error 7719: 設定が中断されました。

[センサ/デバイスをネットワークに追加] ダイアログで、1 つまたは複数の In-Sight センサの設定を終了することを選択しました。

Error 7720: 不正なホスト名が検出されました。

Error 7720 は、新しいホストを Explorer のホストテーブルに追加する際に、[ホスト名] フィールドが空白のままになっていると表示されます。ホスト名を入力して、[OK] をクリックしてください。

Error 7721: 不正な IP アドレスが検出されました。

指定した IP アドレスを In-Sight センサに割り当てることができませんでした。[センサ/デバイスをネットワークに追加] ダイアログでこのエラーメッセージが表示された場合は、In-Sight センサに IP Address Lock が設定されていないか確認してください。IP Address Lock が設定されていると、センサの IP アドレスは変更できません。Telnet セッションでセンサに SL0 を発行すると、IP Address Lock が解除されます(注: この設定を変更するには、フルアクセス権限を持つユーザとしてログオンする必要があります)。

Error 7728: In-Sight ビジョンセンサに接続できませんでした。

[センサ/デバイスをネットワークに追加] ダイアログは、In-Sight センサとの通信を確立できませんでした。センサの電源が入っていることと、ネットワーク接続がアクティブであることを確認してください。詳細なトラブルシューティングのヒントについては、Error 5404 を参照してください。

Error 7731: このデバイスではネットワーク設定を行えませんでした。

詳細なトラブルシューティング情報については、ダイアログで Error 7731 の後に表示される注意を参照してください。

また、このデバイスが PC と同じ物理サブネットに接続され、電源が入っていることも確認します。デバイスへのイーサネットケーブル接続もすべて確認してください。

それでも問題が解決されない場合は、デバイスを PC に直接接続し、デバイスの電源を一度切ってから、再び入れてください。


セル参照

セル参照は別のセルへのリンクです。ソースのセルのデータが変更されると、ディスティネーションのセル (参照が含まれるセル) の値が自動的に更新されます。ただし、ソースのセルは別のセルによって参照されていることが分からないため、このリンクは一方向です。

セル参照について

セル参照には、次の 2 種類が存在します。

  • 相対: 相対セル参照は、新しい位置にコピーされると、行および列のアドレスが変化する参照のことです。変化の量は、コピーされたセルと貼り付けられたセルの間の距離 (行および列の両方に関して) と同じです。例えば、セル A2 に相対参照 A1 が含まれているとします。セル A2 がセル S43 にコピーされると、S43 には S42 が含まれます。この場合、セル参照は「常に 1 つ上のセルを指し示す」ことになります。
  • 絶対: 絶対セル参照は、新しい位置にコピーされても変化しないセル参照のことです。数式では、ドル記号 ($) が絶対参照であることを示します。この記号は、任意の行または列 (あるいはその両方) と組み合わせて絶対セル参照を構成することができます。

相対参照と絶対参照を組み合わせて、「混合」参照を作成することができます。

次の表は、4 種類の絶対セル参照および相対セル参照と、それぞれが別のセルにコピーおよび貼り付けされるとどうなるかを示しています。

説明 | 参照の種類 | 例 | 新しいセルに貼り付けた結果
相対列と相対行 | 相対 | B4 | 行 (4) と列 (B) の両方が、元のセルからの距離に基づいて変化します。
固定列と固定行 | 絶対 | $A$1 | 常に $A$1 になります。
固定列と相対行 | 混合 | $D9 | 列は常に D になりますが、行 (9) は元のセルからの距離 (行数) に基づいて変化します。
相対列と固定行 | 混合 | G$3 | 列の G は、元のセルからの距離 (列数) に基づいて変化しますが、行は常に 3 のままになります。

セル参照作成用のショートカット

  • 相対: CTRL+SHIFT+R キーを押すか、または相対参照 [image] ボタンをクリックします。セル選択モードでは、参照する目的のセルを選択することができます。
  • 絶対: CTRL+SHIFT+A キーを押すか、または絶対参照 [image] ボタンをクリックします。セル選択モードでは、参照する目的のセルをスプレッドシートからグラフィカルに選択することができます。

セル参照の例

閉じた 相対列と相対行 (相対参照)

セル C9 に E14 が含まれているとします。C9 が B1 にコピーされた場合、B1 に D6 が含まれます。

閉じた 固定列と固定行 (絶対参照)

セル E2 に $F$7 が含まれているとします。E2 が R7 にコピーされた場合、R7 に $F$7 が含まれます。

閉じた 固定列と相対行 (混合参照)

別のセルにコピーする際に、常に列 A を参照するものの、行アドレスは、元のセルからコピー先セルへの距離の変化に関連して変化するセル参照を必要としていると仮定します。図のように、セル A2、A3、および A4 に 3 つのデータポイント (5、18、および 55) が存在するとします。

この場合、列の前にドル記号を使用しますが ($A) 、行 (2) の前には使用せず、$A2 のセル参照を作成します。この参照はセル B2 に配置できます。次にセル B2 がセル B3、B4、C2、C3 および C4 にコピーされ貼り付けられます。貼り付けられたセルは常に列 A を参照しますが、行は、参照を貼り付けたセルと相対的に決定されることに注目してください。

閉じた 相対列と固定行 (混合参照)

別のセルにコピーする際に、常に行 2 を参照するものの、列アドレスは、コピー先列までの距離の変化に関連して変化するセル参照を必要としていると仮定します。図のように、セル A2、B2、および C2 に 3 つのデータポイント (13、20、および 26) が存在するとします。

この場合、列を相対的 (A)、行を絶対的 ($2) に参照して、A$2 のセル参照を作成します。この参照はセル A3 に配置できます。次にセル A3 がセル A4、B3、B4、C3 および C4 にコピーされ、貼り付けられます。貼り付けられたセルは常に行 2 を参照しますが、列は、参照を貼り付けたセルと相対的に決定されることに注目してください。


ファームウェアのバージョン

In-Sight ビジョンシステムおよびセンサでサポートされているファームウェアのバージョンを次のトピックに示します。

注 : モデル一覧およびサポートされているファームウェアバージョンについての最新情報は、英語版In-Sight Explorer オンラインヘルプの「Firmware Versions」(ファームウェアバージョンのトピック) をご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation\Help\Help_ISE_EN.chm です。
  • ファームウェアバージョン 4.x.x 以前
  • ファームウェアバージョン 5.x.x 以降


ファームウェアバージョン 4.x.x 以前

次の表は、In-Sight モデル番号、不揮発性フラッシュメモリの量 (利用可能な場合)、部品番号/製品タイプ、およびサポートされているファームウェアのバージョンをまとめたものです。

注 :
  • 最後の対応ファームウェアがバージョン「4.9.x」であるモデルは、ファームウェアバージョン 5.1.0 以降にアップグレードすることはできません。
  • 末尾が「R」の部品番号/製品タイプは、RoHS 指令に適合していることを示します。
In-Sight モデル | 部品番号/製品タイプ | 最初の対応ファームウェア | 最後の対応ファームウェア
1000 1010 1000C (4MB の不揮発性フラッシュメモリ) | 800-5740-1 800-5749-1 800-5760-1 | 2.00.00 2.00.00 2.20.00 | 2.71.00 PR1
3000 (4MB の不揮発性フラッシュメモリ) | 800-5747-1 | 2.00.00 | 2.52.03
4000 4100 4001 (8MB の不揮発性フラッシュメモリ) | 800-5762-1 800-5763-1 800-5770-1 | 2.30.00 | 2.71.00 PR1
3400 (16MB の不揮発性フラッシュメモリ) | 800-5809-1 | 2.51.00 | 4.2.0
5100 5110 (16MB の不揮発性フラッシュメモリ) | 800-5834-1/2/3 800-5854-1 | 2.53.00 | 4.2.0
5400 5410 (16MB の不揮発性フラッシュメモリ) | 800-5828-1/2/3 | 2.53.00 | 4.2.0
5101 5111 (16MB の不揮発性フラッシュメモリ) | 800-5838-1/2/3 | 2.65.00 | 4.2.0
5100C (16MB の不揮発性フラッシュメモリ) | 800-5837-1/2/3 | 2.65.00 | 4.2.0
5000 (16MB の不揮発性フラッシュメモリ) | 800-5840-1/2/3 | 2.70.00 | 4.2.0
5400C 5400CS (16MB の不揮発性フラッシュメモリ) | 800-5837-1/2/3 | 2.80.00 | 4.2.0
5401 5411 (16MB の不揮発性フラッシュメモリ) | 800-5838-1/2/3 | 2.80.00 | 4.2.0
5403 5403S (16MB の不揮発性フラッシュメモリ) | 800-5830-1/2/3 | 2.80.00 | 4.2.0
5000 (32MB の不揮発性フラッシュメモリ) | 800-5840-4/5/6 | 2.80.01 PR1 | 4.2.0
5400R (32MB の不揮発性フラッシュメモリ) | 800-5829-1/1R | 2.80.01 PR1 | 4.5.0
5100 5110 (32MB の不揮発性フラッシュメモリ) | 800-5870-1/1R/2/2R/3/3R | 2.80.01 PR1 | 4.7.3
5400 5410 5400S 5410S (32MB の不揮発性フラッシュメモリ) | 800-5855-1/1R/2/2R/3/3R | 2.80.01 PR1 | 4.7.3
5400C 5400CS (32MB の不揮発性フラッシュメモリ) | 800-5837-4/4R/5/5R/6/6R | 2.80.01 PR1 | 4.7.3
5401 5411 (32MB の不揮発性フラッシュメモリ) | 800-5838-4/4R/5/5R/6/6R | 2.80.01 PR1 | 4.7.3
5403 5413 5403S (32MB の不揮発性フラッシュメモリ) | 800-5830-4/4R/5/5R/6/6R | 2.80.01 PR1 | 4.7.3
5100C (32MB の不揮発性フラッシュメモリ) | 800-5837-4/4R/5/5R/6/6R | 3.4.0 | 4.7.3
5600 5610 (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | 800-5871-1/1R/2/2R/3/3R | 3.4.0 | 4.10.x
5603 5613 (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | 800-5873-1/1R | 3.4.0 | 4.10.x
In-Sight Micro 1020 1050 1100 1110 1400 1410 (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0002-1R Type 821-0002-5R | 4.1.0 | 4.10.x
In-Sight Micro 1403 1413 (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0003-1R Type 821-0003-5R | 4.1.0 | 4.10.x
CIO-MICRO I/O Module | Type 821-0016-1R Type 821-0016-2R | 4.2.0 | 4.9.3
CIO-MICRO-CC I/O Module | Type 821-0017-1R Type 821-0017-2R | 4.3.0 | 4.9.3
In-Sight Micro 1100C 1400C (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0002-2R Type 821-0002-6R | 4.3.0 | 4.10.x
In-Sight Micro 1403C (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0003-2R Type 821-0003-6R | 4.3.0 | 4.10.x
5604 (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 800-5874-1R Type 800-5874-2R | 4.3.1 | 4.10.x
5605 5615 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0032-1R Type 821-0032-2R | 4.4.1 | 4.10.x
5100 5110 5400 5410 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0034-1R | 4.4.3 | 4.10.x
5100C 5400C (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0036-1R | 4.4.3 | 4.10.x
5400S 5410S (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0038-1R | 4.4.3 | 4.10.x
5400CS (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0039-1R | 4.4.3 | 4.10.x
5401 5411 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0035-1R | 4.4.3 | 4.10.x
5403 5413 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0037-1R | 4.4.3 | 4.10.x
5403S (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0040-1R | 4.4.3 | 4.10.x
5600 5610 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0041-1R | 4.4.3 | 4.10.x
5603 5613 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0042-1R | 4.4.3 | 4.10.x
5604 5614 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0051-1R | 4.4.3 | 4.10.x
In-Sight Micro 1020 1050 1100 1110 1400 1410 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0043-1R | 4.4.3 | 4.10.x
In-Sight Micro 1100C 1400C (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0044-1R | 4.4.3 | 4.10.x
In-Sight Micro 1403 1413 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0047-1R | 4.4.3 | 4.10.x
In-Sight Micro 1403C (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0048-1R | 4.4.3 | 4.10.x
In-Sight Micro 1402 1412 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Type 821-0078-1R | 4.6.0 | 4.10.x
C-Mount Lens Configuration: 7010 7020 7050 7200 7210 7230 7400 7410 7430 7402 7412 7432 (512MB の不揮発性フラッシュメモリ。最大 134.2MB のファイルサイズを利用可能) | Type 821-0084-1R Type 821-0084-3R Type 821-0084-5R Type 821-0084-9R | 4.9.0 | 4.10.x
M12 Lens Configuration: 7010 7020 7050 7200 7210 7230 7400 7410 7430 7402 7412 7432 (512MB の不揮発性フラッシュメモリ。最大 134.2MB のファイルサイズを利用可能) | Type 821-0084-2R Type 821-0084-4R Type 821-0084-6R | 4.9.0 | 4.10.x
C-Mount Lens Configuration: 7010C 7200C 7400C 7402C (512MB の不揮発性フラッシュメモリ。最大 134.2MB のファイルサイズを利用可能) | Type 821-0100-1R Type 821-0100-3R | 4.9.0 | 4.10.x
M12 Lens Configuration: 7010C 7200C 7400C 7402C (512MB の不揮発性フラッシュメモリ。最大 134.2MB のファイルサイズを利用可能) | Type 821-0100-2R Type 821-0100-4R | 4.9.0 | 4.10.x
In-Sight Micro 1500 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | Regulatory Model 1AAN | 4.9.1 | 4.10.x


ファームウェアバージョン 5.x.x 以降

次の表は、In-Sight モデル番号、不揮発性フラッシュメモリの量 (利用可能な場合)、部品番号/製品タイプ、およびサポートされているファームウェアのバージョンをまとめたものです。

In-Sight モデル | 規制モデル | サポートされるファームウェアバージョン
In-Sight 2000-110 2000-120 2000-130 (32MB の不揮発性フラッシュメモリ。最大 15.9MB のファイルサイズを利用可能) 注 : ファームウェアバージョン 5.7.3 以降を搭載した In-Sight 2000-110/120/130 ビジョンセンサをご購入の場合、ファームウェアバージョン 5.5.0 以前にダウングレードすることはできません。 | 規制モデル R00039 | 5.2.1 5.2.3 5.3.0 5.4.0 5.5.0 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 2000-120C 2000-130C (32MB の不揮発性フラッシュメモリ。最大 15.9MB のファイルサイズを利用可能) 注 : ファームウェアバージョン 5.7.3 以降を搭載した In-Sight 2000-120C/130C ビジョンセンサをご購入の場合、ファームウェアバージョン 5.5.0 以前にダウングレードすることはできません。 | 規制モデル R00039 | 5.3.0 5.4.0 5.5.0 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 2000-110 Mini 2000-120 Mini 2000-130 Mini 2000-120C Mini 2000-130C Mini (32MB の不揮発性フラッシュメモリ。最大 15.9MB のファイルサイズを利用可能) 注 : ファームウェアバージョン 5.7.3 以降を搭載した In-Sight 2000-110 Mini/120 Mini/130 Mini/120C Mini/130C Mini ビジョンセンサをご購入の場合、ファームウェアバージョン 5.5.0 以前にダウングレードすることはできません。 | 規制モデル 1ABD | 5.5.0 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 2000-23M (32MB の不揮発性フラッシュメモリ。最大 15.9MB のファイルサイズを利用可能) 注 : ファームウェアバージョン 5.7.3 以降を搭載した In-Sight 2000-23M ビジョンセンサをご購入の場合、ファームウェアバージョン 5.5.0 以前にダウングレードすることはできません。 | 規制モデル R00039 | 5.5.0 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 2000-23M Mini (32MB の不揮発性フラッシュメモリ。最大 15.9MB のファイルサイズを利用可能) 注 : ファームウェアバージョン 5.7.3 以降を搭載した In-Sight 2000-23M Mini ビジョンセンサをご購入の場合、ファームウェアバージョン 5.5.0 以前にダウングレードすることはできません。 | 規制モデル 1ABD | 5.5.0 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 2000-230/230C 2001-230/230C (32MB の不揮発性フラッシュメモリ。最大 15.9MB のファイルサイズを利用可能) | 規制モデル R00039 | 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4
In-Sight 2000-230 Mini/230C Mini 2001-230 Mini/230C Mini (32MB の不揮発性フラッシュメモリ。最大 15.9MB のファイルサイズを利用可能) | 規制モデル 1ABD | 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight Mini PoE Models 2000-110 Mini 2000-120 Mini/120C Mini 2000-130 Mini/130C Mini 2000-23M Mini 2000-230 Mini/230C Mini 2001-230 Mini/230C Mini (32MB の不揮発性フラッシュメモリ。最大 15.9MB のファイルサイズを利用可能) | 規制モデル 1ABF | 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 5705 & 5715 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | 規制モデル 1AAF | 5.1.0 5.2.0 5.3.0 5.4.0 5.5.0 5.6.0 5.6.1 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 7500 7600 7800 7801 7802 (7.2GB の不揮発性フラッシュメモリ。最大 1.0GB のファイルサイズを利用可能) 注 : ファームウェアバージョン 5.5.0 以降を搭載した In-Sight 7000 Gen2 シリーズビジョンシステムをご購入後、5.4.1 以前のファームウェアバージョンにダウングレードしたときに、ビジョンシステムが電源が再投入され再起動するのに約 4 分かかる場合があります。 | 規制モデル 1AAB | 5.4.0 5.5.0 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 7501 7600C 7800C 7801C 7802C 7900 7902 (7.2GB の不揮発性フラッシュメモリ。最大 1.0GB のファイルサイズを利用可能) 注 : ファームウェアバージョン 5.5.0 以降を搭載した In-Sight 7000 Gen2 シリーズビジョンシステムをご購入後、5.4.1 以前のファームウェアバージョンにダウングレードしたときに、ビジョンシステムが電源が再投入され再起動するのに約 4 分かかる場合があります。 | 規制モデル 1AAB | 5.5.0 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 7900C 7901 7901C 7902C (7.2GB の不揮発性フラッシュメモリ。最大 1.0GB のファイルサイズを利用可能) | 規制モデル 1AAB | 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 7902P | 規制モデル R00063 | 5.7.4 5.8.0
In-Sight 7905 7905C (7.2GB の不揮発性フラッシュメモリ。最大 1.0GB のファイルサイズを利用可能) | 規制モデル R00063 | 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 8200 8400 8401 8402 (512MB の不揮発性フラッシュメモリ。最大 234MB のファイルサイズを利用可能) | 規制モデル 1AAW | 5.2.0 5.3.0 5.4.0 5.5.0 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 8200C 8400C 8401C 8402C (512MB の不揮発性フラッシュメモリ。最大 234MB のファイルサイズを利用可能) | 規制モデル 1AAW | 5.5.0 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.8.0
In-Sight 8405 (512MB の不揮発性フラッシュメモリ。最大 234MB のファイルサイズを利用可能) | 規制モデル 1AAU | 5.1.1 5.2.0 5.3.0 5.4.0 5.5.0 5.6.0 5.6.1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 9902L (7.2GB の不揮発性フラッシュメモリ。最大 1.0GB のファイルサイズを利用可能) | 規制モデル 1AA9 | 5.6.1 PR1 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0
In-Sight 9912 9912C (7.2GB の不揮発性フラッシュメモリ。最大 1.0GB のファイルサイズを利用可能) | 規制モデル R00064 | 5.7.0 5.7.1 5.7.2 5.7.3 5.7.4 5.8.0


In-Sight のファイル

[In-Sight のファイル] ペインには 2 種類の情報が表示されます。最初は、[In-Sight のファイル] ペインには、ネットワーク上で検出されたすべての In-Sight ビジョンシステムと、Explorer のホストテーブルにある任意のエントリが表示されます。デバイスをダブルクリックすると、そのデバイスに保存されているファイル、および設定済みで使用可能な RAM ディスクのフォルダと SD カードのフォルダが表示されます。

ヒント: In-Sight Explorer をカスタマイズすることによって、[In-Sight のファイル] ペインをドッキング表示 (ウィンドウの端に固定) またはフロート表示にしたり、移動したり、サイズを変更したりすることができます。

[In-Sight のファイル] ペインを表示/非表示するには

  • [表示] メニューで [In-Sight のファイル] をクリックします (または、[Explorer] ツールバーの [In-Sight のファイル] [image] ボタンをクリックするか、Ctrl+Shift+2 キーを押します)。

    注 : [In-Sight のファイル] ペインに AAF ファイル (*.aaf) が表示されることがあります。AAF ファイルは、監査メッセージサーバがアクセス不可能な場合に In-Sight フラッシュメモリに保存される監査メッセージです。監査メッセージサーバへの接続が再度確立されると、AAF ファイルは 1 つずつ送信され、監査メッセージサーバの想定される応答が受け取られると、削除されます。

[In-Sight のファイル] ペインの使用法

ドラッグ ＆ ドロップ

ジョブまたは画像ファイルは、[In-Sight のファイル] ペインからスプレッドシート上にドラッグするだけで、In-Sight ビジョンシステムにロードできます。ファイルは、[In-Sight のファイル] ペインと Windows エクスプローラのフォルダの両方から [In-Sight のネットワーク] ペイン内の任意のデバイスにドラッグでき、この操作でファイルがコピーされます。

注 :
  • ビジョンシステムのタイトルバーには、アクティブなジョブのビジョンシステム名とファイル名が表示されます。PC からジョブファイルをドラッグ ＆ ドロップした場合、ジョブがビジョンシステムに保存されるまでは、タイトルバーにジョブ名は表示されません。
  • PC からジョブファイルをドラッグ ＆ ドロップすると、ジョブがビジョンシステムに保存されるまでは、[センサのステータス] ビューの現在のジョブには「Drag And Drop Job」が表示されます。
  • [In-Sight のファイル] ペインからジョブファイルをドラッグ ＆ ドロップし、スプレッドシートビューのスクロールバーをクリックしてから、マウスのホイールを使用してスクロールをすると、[スプレッドシート] ペインではなく [In-Sight のファイル] ペインがスクロールされます。スプレッドシートビューをスクロールするには、マウスのホイールではなく矢印またはスライダを使用します。

コピー、削除、名前変更

[In-Sight のファイル] ペインでファイルを右クリックすると、 閉じた ファイルをコピー、削除、または名前変更するためのショートカットメニューが表示されます。コピーしたジョブは、ほかの In-Sight ビジョンシステム、エミュレータや SD カードに貼り付けることができます。コピーした画像を貼り付けることもできますが、In-Sight ビジョンシステムでは、貼り付けたファイルは貼り付け先のビジョンシステムのアクティブな画像として image.bmp および image.jpg と置き換えられます。元のファイル名は保持されないので注意してください。

注 : image.bmp、image.jpg、image2.bmp および image4.bmp はエミュレータに貼り付けることはできません。

削除不可能なファイル

次の In-Sight システムファイルを削除することはできません。

  • hosts.net: In-Sight のホストテーブルのエントリを含む
  • image.jpg: アクティブな画像
  • image.bmp: アクティブな画像
  • image 2.bmp: アクティブな画像の高さと幅が 1/2 のバージョン (ファームウェアバージョン 2.60 以降)。
  • image 4.bmp: アクティブな画像の高さと幅が 1/4 のバージョン (ファームウェアバージョン 2.60 以降。
  • proc.set: ネットワーク構成およびビジョンシステム設定を含む

画像をファイルとして In-Sight ビジョンシステムにとして格納することはできません。画像ファイル をビジョンシステムの [In-Sight のファイル] ペインまたはアクティブビューにドラッグすると、そのビジョンシステムのアクティブな画像になります。ただし、In-Sight の エミュレータでは、任意のファイル名で画像を格納することができます。

SD カードおよび RAM ディスクのフォルダ

SD カードフォルダ

SD カードがビジョンシステムに搭載されている場合、SD カードフォルダは [In-Sight のファイル] ペインに表示されます。SD カードでは、ジョブ/画像 ([保存] および [開く] ダイアログ) とセルデータ ([セルのエクスポート]、[セルのインポート] ダイアログ、ExportData および ImportData 関数) がサポートされます。

注 :
  • SD カードでは、次のダイアログおよび機能はサポートされません。[記録/再生のオプション] および フィルムストリップ。
  • 次のパスを使用して SD カードのファイルにアクセスします。SDCARD/filename.type
  • SNTP サービスが有効化されており、かつ SNTP サーバがネットワーク時刻を取得可能でない限り、SD カード上でファイルが作成された時刻は、正確にはなりません。

RAM ディスクフォルダ

ビジョンシステムまたはエミュレータに、有効化され、設定された RAM ディスクフォルダがある場合、この RAM フォルダは [In-Sight のファイル] ペインに表示されます。詳細については、[RAM ディスクの設定] ダイアログのトピックを参照してください。


TestRun - EasyBuilder ビュー

対象となる In-Sight ビジョンシステムに接続し、該当する .job ファイルをビジョンシステムにロードしたら、TestRun の設定を開始する必要があります。TestRun を設定するには、[TestRun セットアップ] ダイアログを使用します。ここでは、TestRun をプログラムするための一連の画面がステップ単位で表示されます。ダイアログの左側にはナビゲーションペインが表示されており、ここで設定画面のいずれかを選択できます。

注 : TestRun の初期設定が完了した後に、いずれかのステップを再度確認するには、ナビゲーションペインでそのステップを選択します。

[TestRun セットアップ] ダイアログを設定したら、[パレット] に戻り、次のボタンを使用してそれぞれの処理を行います。

  • [新規]:新しい TestRun テストを作成します。
  • [設定]:[TestRun セットアップ] ダイアログを起動します。
  • [実行]:既存の TestRun テストを実行します。
    • 注 : In-Sight ファームウェアバージョン 4.10.x、または In-Sight ファームウェア 5.6.0 以上を実行している In-Sight ビジョンシステムでは、EtherNet/IP 通信または PROFINET 通信経由で、PLC などの外部デバイスからも TestRun を開始できるようになりました。
  • [修復]:壊れたテストまたは値を修復します。
  • [インポート]:以前に作成したテストをインポートします。
  • [エクスポート]:テストをエクスポートします。
  • [バッチ実行]: TestRun を設定して .job ファイルのバッチを実行する際に使用する [TestRun バッチ実行] ダイアログを開きます。

TestRun を表示するには

  1. [パレット] で、[TestRun™] タブをクリックします。

    注 : [パレット] が表示されない場合は、[表示] メニューから [パレット] を選択します。
  2. [設定] ボタンをクリックして、[TestRun セットアップ] ダイアログを起動します。

  3. [TestRun セットアップ] ダイアログのステップをすべて設定したら、[パレット] の [TestRun] タブにある [image] [実行] ボタンをクリックして、テストを実行します。

    注 : [TestRun セットアップ] ダイアログの設定を完了したら、[パレット] で使用できるすべてのボタンが表示された右クリックメニューが選択できるようになります。さらに、テストの特定のセクションからテストを実行する機能も使用できるようになります (例えば、ジョブテストを実行せずにハードウェアテストから開始する、など)。

[画像データベースフォルダ]

TestRun を EasyBuilder ビューで使用している場合、[TestRun セットアップ] ダイアログの最初のステップで表示される画面は、[画像データベースフォルダ] です。[画像データベースフォルダ] ステップでは、テストを作成するのに使用される格納画像へのリンクを生成します。

このステップでは、テスト画像データベースへのパスを生成します。ディレクトリパスでは、次のいずれかのフォーマットを使用する必要があります。

  • C:\TestRun\BracketJob
  • file:///\\TestRun\BracketJob
  • ftp://TestRunServer/BracketJob
  • ftp://10.28.127.73/BracketJob
注 : シグナル駆動の TestRun 用に設定されたビジョンシステムの場合、FTP サーバを使用するように [画像データベースフォルダ] を設定する必要があります。

画像はすべて、1 つの共通のルートフォルダに格納する必要があります。画像が複数のフォルダに格納されている場合は、すべての画像とそのサブフォルダが含まれているフォルダを選択します。TestRun が各種ファイル構造に対応できる場合は、次のタイプの構造を使用することを推奨します。

このタイプの構造を使用すると、「画像データベース」フォルダが選択されます。

最後に、[未知の画像] ドロップダウンメニューを設定します (無視、Pass と仮定、Fail と仮定、デフォルト = 無視)。[未知の画像] ドロップダウンを使用して、[画像の選択] ステップでは明示的に TestRun に追加されなかった画像の、TestRun による処理方法を決定します。ドロップダウンを [無視] に設定すると、設定されていない画像を TestRun で単純に無視することができます。ドロップダウンを [Pass と仮定] に設定すると、画像に対するジョブは TestRun で成功したものとみなされます。ドロップダウンを [Fail と仮定] に設定すると、画像に対するジョブは TestRun で失敗したものとみなされます。

TestRun 画像データベースで使用するフォルダの選択

  1. [参照] ボタンをクリックします。

  2. [フォルダの参照] ダイアログで、保存先の画像フォルダに移動して選択します。フォルダを選択してから [OK] ボタンをクリックします。

    注 :
    • 既に画像フォルダにアクセスしている場合は、ドロップダウンメニューから選択できます。

    • シグナル駆動の TestRun 用に設定されたビジョンシステムの場合、FTP サーバを使用するように [画像データベースフォルダ] を設定する必要があります。

  3. 必要に応じて、画像ディレクトリにアクセスするためのユーザ名とパスワードを入力します。

    注 : TestRun の [画像データベースフォルダ] 設定時に、ジョブの開発者が自分自身の特定のユーザ認証を使用して、TestRun が別のアプリケーションで使用するフォルダにアクセスした場合 (例えば、Windows Explorer を使用して、ネットワークフォルダの画像を表示する場合など) に、別のユーザ認証が指定されている場合 (例えば、ライン上のオペレータが使用する汎用のユーザ名とパスワードなど)、TestRun はそのフォルダにアクセスすることはできません。この状態から復旧するには、フォルダにアクセスしているアプリケーションを閉じてから、[TestRun セットアップ] ダイアログを閉じて再度開きます。
  4. 必要に応じて、ドメインの情報を入力します。
  5. [次へ] ボタンをクリックして、TestRun の設定を続行します。
  6. このステップから抜けると、TestRun は、自動的に .jpg および .bmp 画像ファイル用の画像ディレクトリを検索します。
注 :
  • 以前にこのステップを設定済みの場合、TestRun は、ディレクトリに格納されているファイルに関する情報を保持します。画像の場所が変更されると、画像の場所を基準にしたパスに基づいて画像を照合し、照合した画像ごとにそのプロパティを転送します。
  • フォルダが生成されると、ドロップダウンメニューの下に次の項目が表示されます。フォルダ内の画像の総数、以前に [ジョブ]　→ [画像の選択] 画面で設定した画像の数、以前に設定した際にはフォルダ内に存在していたが、現在は存在していない画像の数、および最後に設定してからフォルダに新しく追加された画像の数。

[バリアントの設定]

通常 1 つのジョブには、1 つ以上の検査が含まれています。ジョブ内のそれぞれの検査は、ジョブバリアントとみなされます。例えば、以降何度もジョブを変更するのを避けるために、複数の製品を処理するようにジョブを作成するとします。この場合、ジョブ内のそれぞれの検査は、ジョブバリアントとみなされます。

通常、外部入力 (例えば、PLC からのコマンド) によって複数のバリアントを選択します。各バリアントには、独自のビジョンツールセット、別のサーチ領域、別の露光設定値などがあります。TestRun では、ジョブ内のすべてのバリアントをテストできます。

注 : 各ジョブバリアントは、個別に設定します。

ジョブバリアントの追加

  1. デフォルトでは、「ジョブ」という名前のバリアントが自動的に追加されます。

    注 : 名前を変更するには、対象のバリアントを選択し、[名前の変更] ボタンをクリックしてから、新しい名前を入力します。名前を変更したら、設定ステップペインにある名前が自動的に更新されます。
  2. [追加] ボタンをクリックして、新しいバリアントを作成します。
  3. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブバリアントの並べ替え

注 : バリアントの順序を変更すると、TestRun テストの実行順序が変更されます。
  1. バリアントを選択します。
  2. 目的の方向に応じて、[上に移動] または [下に移動] のいずれかのボタンをクリックします。
  3. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブ/バリアント - アクションのセットアップ

テストを開始するには、TestRun でジョブの一部のパラメータを設定し、実行する特定のバリアントを設定する際にオペレータが実行する動作をコピーします。通常、ジョブに複数のバリアントがある場合は、設定の一部を、選択したバリアント用のジョブに合わせる必要があります。TestRun で特定のバリアント用の画像を処理するには、最初にそれに応じてジョブの状態を設定する必要があります。[アクションのセットアップ] のステップでは、選択したバリアントの画像に必要なパラメータを設定します。

[アクションのセットアップ] 画面は、2 つの列から構成されます。1 つは [シンボル] 列で、ここにはシンボリックタグ付きジョブの設定値がすべて表示されます。もう 1 つは [アクションのセットアップ] 列で、ここには TestRun で設定するジョブのパラメータ設定値がすべて表示されます。

ジョブを設定して現在のバリアントをテスト

  1. [シンボル] 列のリストからパラメータ設定を選択します。必要に応じて、プラス記号をクリックし、リストを展開します。
  2. 設定を有効にするには、設定の横にあるチェックボックスをオンにします。[アクションのセットアップ] 列に設定が自動的に入力されます。
  3. 設定を有効にして [アクションのセットアップ] 列でその設定を選択すると、2 つの列の下に設定のエディットコントロールが表示されます。
  4. 必要に応じて、設定を調整します。
  5. 設定が複数ある場合は、[上に移動]/[下に移動] ボタンを使用して、設定を実行順に並べます。TestRun では、この画面に表示されている順序に従って、設定操作を実行します。
  6. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブ/バリアント - リミットテスト

マシンビジョンアプリケーションには多数のパラメータが用意されており、これらは必要に応じてマシンオペレータやメンテナンス技術者が調整できます。ビジョンアプリケーションの開発者は、TestRun のリミットテストを使用して、テストする調整可能なパラメータの選択、そのパラメータの上限値および下限値の設定、およびそのパラメータが設定した限界値内に収まっているかどうかの判別を行うことができます。例えば、開発者はシステムを引き続き動作させるために、TestRun のハードコーディングされた限界値をオペレータや技術者が柔軟に調整できるように設定することができます。さらに、パラメータが範囲を外れたことを確認することもできます。

[リミットテスト] 画面では、編集可能なパラメータ限界値に関するテストを設定できます。この画面は、2 つの列から構成されています。1 つは [シンボル] 列で、ここにはシンボリックタグ付きジョブの設定値がすべて表示されます。もう 1 つは [リミットテスト] 列で、ここには TestRun でテストするジョブのパラメータ設定値がすべて表示されます。

限界をテストするための変数の選択と設定

  1. [シンボル] 列のリストからパラメータ設定を選択します。必要に応じて、プラス記号をクリックし、リストを展開します。
  2. 設定を有効にするには、設定の横にあるチェックボックスをオンにします。[リミットテスト] 列に設定が自動的に入力されます。
  3. 設定を有効にして [リミットテスト] 列でその設定を選択すると、2 つの列の下に設定のエディットコントロールが表示されます。

  4. 必要に応じて、設定を調整します。使用可能なテストのタイプは、編集可能なパラメータのタイプに応じて決まります。

    • EditInt 関数: [Is In Range]
    • EditFloat 関数: [Is In Range]
    • EditString 関数: [Is Equal]
    • ListBox 関数: [Is Equal]
    • CheckBox 関数: [Is Equal]
  5. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブ/バリアント - 画像の選択

この画面では、特定のバリアントのテスト時に使用される画像を選択し、「良好」または「不良」のいずれかとして定義します。この場合、「良好」画像の状態は合格で、「不良」画像の状態は不合格です。

注 : 画像はバリアント内で共有できます。

このバリアントの画像を選択し、画像を「良好」または「不良」として定義します。

  1. ツリーコントロールを使用して、画像のディレクトリを展開します。
  2. ディレクトリに「良好」および「不良」画像が混在して含まれている場合に個別の画像を選択するには、その画像をオンにしてから、ディレクトリの下にあるセレクタを使用し、[良好] または [不良] として定義します。必要に応じて、画像に関するコメントを追加します。
  3. ディレクトリが「良好」および「不良」画像を含む別々のディレクトリに分割されている場合は、トップレベルをオンにしてそのグループ内にあるすべての画像をオンにし、トップレベルで同じ分類 ([良好] または [不良]) を共有します。
  4. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブ/バリアント - 欠陥テスト

[欠陥テスト] 画面では、画像とそれに対応して想定される欠陥が互いに関連付けられており、データベース内の各画像に対して、想定される結果を示すデータベースが作成されています。この画面で欠陥テストを設定するには、各画像に存在する欠陥 (ある場合) を選択して、その欠陥をジョブのパラメータの想定される結果に関連付けます。

初期のデフォルト設定では、各画像に対して [ジョブ FAIL] という欠陥が存在しています。これは、「不良」画像として指定されたすべての画像に対して自動的にオンになります。欠陥がチェック (オン) されることは、その画像に欠陥が存在することを示します。欠陥テストは、ビジョンアプリケーションが画像の合格または不合格を誤って判定した理由を特定するのに役立ちます。大部分のビジョンアプリケーションでは、1 つの画像に対して複数の検査が実行され、それを総合して全体の合格/不合格の結果が生成されます。ビジョン設計者は、TestRun を使用すると、個別の画像の合格/不合格を判定できるだけではなく、特定の欠陥を想定して実際に検出することができます。

例えば、穴が欠落しているために部品が「不良」と判定された場合、TestRun では、実際に部品に穴が欠落しているとジョブで判定されたために、その部品が不合格になったことを確認するのに役立ちます。フィクスチャとして使用したツールが、穴が欠落しているために部品を不合格と判定したとします。これは、ツールのサーチ領域が穴が欠落していることを特定して画像を取り込むのに十分な大きさを持っていたからで、元々このツールは穴の欠落を特定するためのツールではなかった場合、ジョブのロジックは正常には実行されておらず、TestRun はその不一致を特定するのに使用できます。

注 : [欠陥テスト] 画面に移動すると、現在選択されているバリアントに対して設定操作が実行され、ジョブの状態が適切に設定されているかどうかが確認されます。

テストする欠陥の定義

  1. 画像を選択します。
  2. デフォルトの欠陥 [ジョブ FAIL] を設定します。
  3. 必要に応じて別の欠陥を追加し、それに対して想定される結果を定義します。

画像の選択

  1. 処理を開始するには、最初に [画像] グループボックスにある画像再生ボタンを使用して、画像を選択します。[次の画像] ボタンをクリックして、画像を進めます。

    注 : TestRun では、[画像の選択] ステップで定義した画像が使用されます。
  2. [画像] グループボックスおよび EasyBuilder ビューに画像が表示されます。画像とその名前が含まれるフォルダが、画面上部のドロップダウンに表示されます。
  3. 以前に定義した欠陥に対して想定される結果も更新されます。

欠陥 [ジョブ FAIL] の想定される結果の設定

  1. デフォルトでは、欠陥 [ジョブ FAIL] が自動的に追加されて有効になります (チェックボックスがオンになります)。欠陥 [ジョブ FAIL] では、ジョブ全体がエラーを返すかどうかを決定するための想定される結果が定義されます。
  2. 欠陥 [ジョブ FAIL] を定義するには、[欠陥] グループボックスで、「次の場合、欠陥　"(欠陥名)"　が存在します」テキストの下にあるドロップダウンメニューを使用し、該当するシンボリックタグを選択します (デフォルトでは、「<ジョブ PASS/FAIL>」が選択されています)。[ジョブ FAIL] はシンボリックタグではありませんが、[<ジョブ PASS/FAIL>] のセルとして設定されたセルをテストします。
  3. 選択したシンボリックタグの [テストタイプ] ドロップダウンメニューを適切に設定します。

別の欠陥の追加および想定される結果の定義

  1. [追加] ボタンをクリックします。

  2. デフォルトの名前が「欠陥」である欠陥が追加されます。デフォルトでは、新しく追加した欠陥が有効にされます (チェックボックスがオンになります)。

    注 : 既に欠陥が追加されており、デフォルトの名前のままである場合、TestRun は名前の数値を 1 つ増加させます (例えば、「Defect01」、「Defect02」など)。[名前の変更] ボタンをクリックして、デフォルトの名前を編集し、欠陥にわかりやすい名前を割り当てます。
  3. [欠陥] グループボックスで、「次の場合欠陥　"欠陥"　が存在します」テキストの下にあるドロップダウンメニューを使用し、該当するシンボリックタグを選択します。
  4. 選択したシンボリックタグの [テストタイプ] ドロップダウンメニューを適切に設定します。
  5. 必要に応じて、オンにしたエディットコントロールを使用し、テストを設定します。
  6. 必要に応じて、手順 1 ～ 4 を繰り返し、欠陥を追加します。

欠陥の編集

  1. リストから欠陥を選択します。
  2. [欠陥] グループボックスで、「次の場合欠陥 "(欠陥名)" が存在します」テキストの下にあるドロップダウンメニューを使用し、該当するシンボリックタグを選択します。
  3. 選択したシンボリックタグの [テストタイプ] ドロップダウンメニューを適切に設定します。

[ハードウェアテスト-アクションのセットアップ]

TestRun でテストを行い、In-Sight ビジョンシステムが正しい画像を取り込んでいるかを確認するには、最初にそれに応じてジョブの状態を設定する必要があります。この画面では、テストを行う前にパラメータ設定を有効にして、ビジョンシステムが正しい画像を取り込んでいるかを確認します。

ジョブを設定して TestRun のハードウェアテストを実行

  1. [シンボル] 列のリストからパラメータ設定を選択します。必要に応じて、プラス記号をクリックし、リストを展開します。
  2. 設定を有効にするには、設定の横にあるチェックボックスをオンにします。[アクションのセットアップ] 列に設定が自動的に入力されます。
  3. 設定を有効にして [アクションのセットアップ] 列でその設定を選択すると、2 つの列の下に設定のエディットコントロールが表示されます。
  4. 必要に応じて、設定を調整します。
  5. 設定が複数ある場合は、[上に移動]/[下に移動] ボタンを使用して、設定を実行順に並べます。TestRun では、この画面に表示されている順序に従って、設定操作を実行します。
  6. [次へ] ボタンをクリックして、TestRun の設定を続行します。
  7. [アクションのセットアップ] のプログラムを実行したら、TestRun は自動的に In-Sight ビジョンシステムをトリガし、画像を取り込みます。

[ハードウェアテスト - テスト]

このステップでは、テストを設定して、取り込んだ画像が正しいかを確認します。TestRun では、特定のジョブパラメータとその想定される結果を画像と関連付けることによって、画像が正しい結果を生成しているかどうかを判別することができます。例えば、レンズが汚れているために、画像が不鮮明、傷がついている、または暗くなっているとします。この場合、In-Sight ビジョンシステムに不用意に接触すると、その視野 (FOV) が変わることがあります。または、ビジョンシステムに接続されているレンズのフォーカスや絞りが、振動によって時間とともに変化することがあります。このような状態をテストするには、ジョブパラメータを想定される結果に関連付けます。想定される結果が返されない場合は、画像処理に問題が発生しています。

FOV が正しいかどうかを判別するには、部品の特徴 (または、部品がない場合の背景) を使用します。画像に特徴が存在しない場合、FOV が変わっています。部品が検査前にフィクスチャに置かれている場合は、フィクスチャの 4 つの隅の特徴を使用して適切な FOV を設定できます。特徴がない場合、FOV が変わっています。または、特徴が近すぎるか離れすぎている場合は、In-Sight ビジョンシステムと FOV の間の距離が変化している可能性があります。特徴が矩形を形成しているが、四辺形ではない場合、ビジョンシステムに接触して軸がずれ、遠近歪みが生じている可能性があります。

TestRun ビジョンシステムの画像取り込みテストの定義

  1. 画像を取り込みます。
  2. 必要に応じて、テストを追加し、設定します。

画像の取り込み

  1. [画像] グループボックスの下の [手動トリガ] ボタンをクリックし、In-Sight ビジョンシステムから画像を取り込みます。
  2. [画像] グループボックスおよび EasyBuilder ビューに画像が表示されます。
注 : または、[画像のロード] ボタンをクリックして [開く] ダイアログを表示し、画像ファイルに移動します。

テストの追加と設定

  1. [ハードウェアテスト] グループボックスで、[追加] ボタンをクリックします。

  2. デフォルトの名前が「テスト」というテストが追加され、[テスト] グループボックスに置かれます。ここで、設定を行うことができます。

    注 : 既にテストが追加されており、デフォルトの名前のままである場合、TestRun は名前の数値を 1 つ増加させます (例えば、「Test01」、「Test02」など)。[名前変更] ボタンをクリックして、デフォルトの名前を編集し、テストにわかりやすい名前を割り当てます。
  3. [テスト] グループボックスで、「次の場合欠陥 "xxx" が存在します」テキストの下にあるドロップダウンメニューを使用し、該当するシンボリックタグを選択します。
  4. 選択したシンボリックタグの [テストタイプ] ドロップダウンメニューを適切に設定します。
  5. 必要に応じて、手順 1 ～ 4 を繰り返し、テストを追加します。

クリーンアップアクション

テストが完了したら、それに応じてジョブの状態を設定する必要があります。このステップでは、TestRun がテストを完了した後、ジョブを目的の状態に設定するのに必要な設定操作を定義します。

TestRun を設定して、テスト後にジョブパラメータを設定

  1. [シンボル] 列のリストからパラメータ設定を選択します。必要に応じて、プラス記号をクリックし、リストを展開します。
  2. 設定を有効にするには、設定の横にあるチェックボックスをオンにします。[アクションのセットアップ] 列に設定が自動的に入力されます。
  3. 設定を有効にして [アクションのセットアップ] 列でその設定を選択すると、2 つの列の下に設定のエディットコントロールが表示されます。
  4. 必要に応じて、設定を調整します。
  5. 設定が複数ある場合は、[上に移動]/[下に移動] ボタンを使用して、設定を実行順に並べます。TestRun では、この画面に表示されている順序に従って、設定操作を実行します。
  6. [閉じる] ボタンをクリックして、TestRun の設定を完了します。
  7. [TestRun セットアップ] ダイアログを閉じたら、[パレット] の [TestRun] タブにある [image] [実行] アイコンをクリックして、TestRun テストを実行します。
注 : [TestRun セットアップ] ダイアログの設定を完了したら、[パレット] で使用できるすべてのボタンが表示された右クリックメニューが選択できるようになります。さらに、テストの特定のセクションからテストを実行する機能も使用できるようになります (例えば、ジョブテストを実行せずにハードウェアテストから開始する、など)。


[EasyView] ペイン

Web HMI アプリケーションで [EasyView] ペインを表示するには、次のことを実行する必要があります。

  1. In-Sight Explorer または EasyBuilder 内で EasyView を作成し、ジョブとともに保存します。
  2. [HMI ビューの選択] ダイアログで [画像とグラフィックおよび EasyView] および/または [EasyView のみ] を選択します。
  3. [画像とグラフィックおよび EasyView] または [EasyView のみ] のいずれも [HMI ビューの選択] ダイアログで最初に表示されない場場合、[HMI の設定] ダイアログで [ビュー選択の許可] を有効にします。
注 : ユーザのアクセスレベルがロックであるか、または Web HMI 接続モードがビュー専用接続である場合、EasyView ペインは読み取り専用になります。