Établir une connexion

Bienvenue dans EasyBuilder®, qui décrit étape par étape comment créer des applications ou des projets de vision industrielle. L'étape Établir une connexion permet de se connecter à des systèmes de vision, des capteurs de vision et/ou des émulateurs In-Sight et de configurer leurs paramètres, et de commencer le processus de création de projets.

Remarque :
  • Lors de la création de votre projet, enregistrez régulièrement votre travail en appuyant sur les touches CTRL+S. Si la case à cocher Autoriser l'enregistrement en ligne des projets dans la boîte de dialogue Utilisateur est activée, les utilisateurs disposant d'un accès complet ou protégé sont autorisés à enregistrer des projets lorsqu'ils sont en ligne. Si la case à cocher Autoriser l'enregistrement en ligne des projets n'est pas activée, le système de vision doit être Hors ligne pour enregistrer des projets.
  • Une étape d'application EasyBuilder peut être désactivée selon votre niveau d'accès, la tâche que vous êtes en train d'effectuer ou si vous êtes connecté ou non à un système de vision ou émulateur.

Aide EasyBuilder

Le fichier d'aide EasyBuilder est fourni dans deux formats : aide de la palette et aide en ligne. L'aide de la palette EasyBuilder est affichée sur l'onglet Aide de la palette, et l'aide en ligne EasyBuilder se trouve dans un système d'aide au format CHM, avec des fonctions de recherche. Pour ouvrir le fichier d'aide en ligne EasyBuilder, appuyez sur la touche F1 du clavier, cliquez sur le bouton Aide [image] de l'onglet Aide de la palette ou sélectionnez Aide EasyBuilder dans le menu Aide.

Connexion à un capteur ou un émulateur In-Sight

Démarrer ou ouvrir un projet EasyBuilder

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

Aide EasyBuilder | 08/29/2022 | Revision: 5.9.0.2


Connexion à un capteur ou un émulateur In-Sight

La zone de groupe Sélectionner un capteur ou émulateur In-Sight répertorie les capteurs/systèmes de vision et émulateurs In-Sight disponibles. Un seul système de vision/capteur ou émulateur peut être connecté à la fois. Les informations relatives au système de vision/capteur connecté (nom, modèle, etc.) seront affichées dans la zone de groupe Informations sur les capteurs.

Si vous n’êtes pas connecté au système de vision/capteur ou émulateur souhaité dans la liste, effectuez l'une des actions suivantes :

  • Doublez-cliquez sur le système de vision/capteur ou l’émulateur souhaité dans la liste.
  • Sélectionnez le système de vision/capteur ou l’émulateur souhaité dans la liste et cliquez sur le bouton Connexion.

Cliquez sur le bouton Déconnexion pour couper la connexion avec ce capteur ou cet émulateur.

Le volet des paramètres contient d’autres commandes pour :

  • Ajouter un capteur à la liste
  • Modifier le mode d'émulation local
Remarque :
  • Si un utilisateur est déjà connecté au système de vision/capteur/émulateur auquel vous voulez accéder, un message d’avertissement s’affiche. Cliquer Oui pour déconnecter l’autre utilisateur du système visé et poursuivre votre connexion. Cliquer Non pour annuler la tentative de connexion et revenir à EasyBuilder.
  • Si l’autorisation de connexion au système de vision/capteur/émulateur concerné ne vous est pas accordée, la boîte de dialogue Connexion/Déconnexion s’affiche.
  • Si vous avez des difficultés à vous connecter à votre système de vision/capteur ainsi qu’au réseau en général, le problème peut venir de votre carte réseau.
  • Si vous réglez le Type de déclenchement sur Continu sur le capteur de vision In-Sight série 2000, il est probable que la communication entre In-Sight Explorer et le capteur soit impossible, ceci car le processeur du capteur se retrouve en surcharge. Veuillez, dans ce cas, choisir un autre Type de déclenchement ou ajuster l’Intervalle de déclenchement.
  • Lors de la connexion à des systèmes de vision/capteurs In-Sight, les Positions et Outils d’inspection disponibles dépendent du modèle.

Ajouter un capteur à la liste

Modifier le mode d’émulation local


Connexion à un capteur non affiché dans la liste

Si le capteur souhaité ne s'affiche pas dans la liste alors qu'il est physiquement connecté au réseau local, cliquez sur le bouton Actualiser ou Ajouter, en fonction des paramètres réseau du capteur.

  • Le bouton Actualiser actualise la liste de manière à afficher tous les capteurs In-Sight connectés au sous-réseau local. Les paramètres réseau de ces capteurs sont compatibles avec le sous-réseau, ce qui vous permet de communiquer avec eux.
  • Le bouton Ajouter ouvre la boîte de dialogue Ajouter un périphérique au réseau, qui permet aux utilisateurs possédant un accès « complet » de reconfigurer les paramètres réseau des capteurs connectés au réseau local qui sont incompatibles avec le sous-réseau local. Une fois les paramètres corrigés, les capteurs sont automatiquement ajoutés au sous-réseau. Il est alors possible de communiquer avec eux.

Si le capteur souhaité est connecté à un sous-réseau différent, sélectionnez Table d'hôtes d'Explorer dans le menu Système pour ouvrir la boîte de dialogue de configuration Table d'hôtes d'Explorer.


Modifier le mode d'émulation local

  1. Dans la zone de groupe Sélectionner un capteur ou émulateur In-Sight, sélectionnez l'émulateur de votre choix dans la liste en cliquant dessus.
  2. Cliquez sur le bouton Émulateur pour ouvrir la boîte de dialogue Options d'émulation, qui comprend tous les systèmes de vision In-Sight pris en charge et les outils disponibles sur ces capteurs.
  3. Dans la liste déroulante Modèle, sélectionnez le modèle de capteur In-Sight à émuler. Le mode Standard est sélectionné par défaut. Le mode Standard fournit les fonctionnalités de base disponibles sur la plupart des capteurs de vision In-Sight, avec une résolution d'image de 640 x 480.
  4. Une fois la sélection effectuée, cliquez sur le bouton OK pour modifier le paramètre d'émulation.
Remarque : lorsque vous avez cliqué sur le bouton OK, EasyBuilder doit d'abord se déconnecter du précédent émulateur et met donc un certain temps à démarrer le nouvel émulateur sélectionné.


Démarrer ou ouvrir un projet EasyBuilder

Fermé Démarrer un nouveau projet :
  1. Vérifiez que le système de vision n'est pas En ligne.
  2. Cliquez sur le bouton Nouveau projet dans la zone de groupe Charger projet ou appuyez sur CTRL+N (ces deux actions ouvrent la boîte de dialogue Nouveau projet).
  3. Dans la boîte de dialogue Nouveau projet, cliquez sur Oui pour effacer toutes les données du projet actuel. (Pour enregistrer les données, cliquez sur Non dans la boîte de dialogue, appuyez sur CTRL+S et terminez le processus "d'enregistrement" avant de démarrer un nouveau projet.)

Le nom du nouveau projet ne s'affiche pas dans la zone Projet actuel : de la zone de groupe Informations du capteur tant que le projet n'est pas enregistré et nommé.

Fermé Ouverture d'un projet en cours :
  1. Vérifiez que le système de vision n'est pas En ligne.
  2. Cliquez sur Ouvrir projet dans la zone de groupe Charger projet ou appuyez sur CTRL+O (ces deux actions ouvrent la boîte de dialogue Ouvrir).
  3. Dans cette boîte de dialogue, accédez au projet.
  4. Double-cliquez sur le projet ou sélectionnez-le et cliquez sur Ouvrir.
  5. La boîte de dialogue Charger fichier s'affiche ; dans cette boîte de dialogue, cliquez sur Oui pour effacer toutes les données du projet actuel. (Pour enregistrer les données, cliquez sur Non dans la boîte de dialogue, appuyez sur CTRL+S et terminez le processus "d'enregistrement" avant d'ouvrir un projet.)

Le nom du projet ouvert s'affiche dans la zone Projet actuel.

Remarque :
  • Les fichiers de projet créés sur les capteurs de vision In-Sight série 2000 ne sont pas compatibles avec ceux créés sur d'autres modèles In-Sight.
  • Un système de vision "EasyBuilder uniquement" ne peut pas ouvrir des projets EasyBuilder modifiés dans la vue Tableur.
  • EasyBuilder ne peut pas modifier des projets créés dans la vue Tableur d'In-Sight Explorer. Si un projet est ouvert dans un tableur, les étapes d'application sont désactivées. Toutefois, vous pouvez travailler sur le projet depuis l'environnement In-Sight Explorer en cliquant sur Tableur dans le menu Vue d'EasyBuilder.
  • Lorsqu'un projet est créé à l'aide d'In-Sight 4.7.3 ou d'une version antérieure, puis qu'il est chargé sur un système de vision avec un micrologiciel In-Sight de version 5.x.x, les balises symboliques (balises EasyBuilder) du projet sont supprimées.


Configurer l'image

L'étape Configurer l'image sert à acquérir ou charger une image, ajuster les paramètres d'acquisition du capteur In-Sight et, si votre application nécessite des résultats en unités réelles, par exemple millimètres ou pouces, vous pouvez calibrer les coordonnées de pixels de l'image.

Acquisition ou chargement d’une image

Réglage des paramètres d’acquisition

Calibrer l’image avec des unités réelles


Acquisition ou chargement d'une image

La zone de groupe Acquérir/Charger une image permet d'acquérir instantanément une image du capteur de vision, d'afficher une vidéo en direct depuis le capteur de vision ou de charger les images acquises précédemment à partir d'un PC.

Capteurs de vision In-Sight série 2000

  • Acquisition ou chargement d'une image

Systèmes de vision In-Sight

  • Acquisition ou chargement d'une image

Capteurs de vision In-Sight série 2000

Systèmes de vision In-Sight

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

Aide EasyBuilder | 08/29/2022 | Revision: 5.9.0.2


Acquisition ou chargement d'une image

Remarque : cette rubrique décrit l'interface utilisateur en étant connecté à un capteurs de vision In-Sight série 2000. En cas de connexion à des systèmes de vision In-Sight, reportez-vous à Acquisition ou chargement d'une image.
Fermé Déclencheur

Le bouton Déclencheur permet d'acquérir une image unique à partir du capteur de vision. Cliquez sur le bouton Déclencheur pour acquérir une image unique. Vous pouvez également utiliser le bouton F5 du clavier ou cliquer sur le [image] bouton de la barre d'outils d'EasyBuilder : (Déclencheur doit être configuré sur Manuel).

Fermé Vidéo directe

Le bouton Vidéo directe permet d'activer le capteur de vision pour diffuser des images, ce qui vous permet de régler la mise au point de l'objectif monté sur le capteur de vision, et d'en régler l'ouverture pour obtenir la luminosité d'image optimale. Votre application fonctionnera de manière optimale lorsque les images seront parfaitement au point et que la luminosité sera équilibrée afin de maximiser le contraste.

Remarque :
  • Vous pouvez également accéder au mode Vidéo directe en sélectionnant Vidéo directe dans le menu Image ou en cliquant sur le [image] bouton de la barre d'outils d'EasyBuilder. Ces options de Vidéo directe sont disponibles à toutes les étapes de l'application.
  • Vous pouvez régler les paramètres Exposition auto/manuelle, Exposition (ms), Exposition optimale, Mode de contrôle de l'éclairage et Mode d'agrandissement de l'image lorsque vous êtes en mode Vidéo directe.

L'option Indice de Netteté figurant sous l'image vous aide à déterminer le score de mise au point d'une image qui indique le degré d'intégration des plus petits détails, de l'image ou une région de l'image, et qui peuvent être résolus dans une « scène ».

Remarque :
  • Lorsque vous êtes connecté aux capteurs de vision d'In-Sight série 2000, les valeurs d'Indice de Netteté, Minimum, Maximum et Mise au point sont masquées.
  • Vous pouvez désactiver l'Indice de Netteté en cliquant sur l'icône Indice de Netteté [image] de la barre d'outils d'EasyBuilder lorsque vous êtes en Vidéo directe. Vous pouvez également sélectionner Indice de Netteté depuis le menu Vue.
Fermé Réglage de la mise au point
  1. Cliquez sur le bouton Vidéo directe. Vous pouvez également cliquer sur le [image] bouton de la barre d'outils d'EasyBuilder.
Remarque : le capteur de vision doit être hors ligne.
  2. Si vous utilisez le capteur de vision In-Sight série 2000 Mini, vous pouvez automatiquement mettre au point l'objectif à l'aide du bouton Autofocus. Vous pouvez également régler manuellement la mise au point à l'aide du curseur Distance de mise au point (%) afin de pouvoir vérifier si les détails des caractéristiques à inspecter sont nets et contrastés.
  3. Si vous utilisez un autre capteur de vision qu'In-Sight série 2000, réglez manuellement le module d'éclairage monté sur le capteur de vision afin de pouvoir vérifier si les détails des caractéristiques à inspecter sont nets et contrastés.
  4. Lorsque vous êtes satisfait de la qualité de l'image, cliquez à nouveau sur le bouton Vidéo directe.
Fermé Réglage de la luminosité
  1. Cliquez sur le bouton Vidéo directe. Vous pouvez également cliquer sur le [image] bouton de la barre d'outils d'EasyBuilder.

  2. Dans la barre d'outils d'EasyBuilder, cliquez sur Analyse de la luminosité pour l'activer. Les zones de l'image trop sombres sont mises en surbrillance bleue, tandis que les zones de l'image en surbrillance rouge correspondent aux zones sursaturées (trop claires).

    Remarque : vous pouvez également sélectionner Afficher analyse de luminosité dans le menu Image pour activer Analyse de luminosité.
  3. Vous pouvez régler la luminosité de l'image selon l'une des méthodes suivantes :
  • Réglez manuellement l'ouverture de l'objectif monté sur le capteur de vision jusqu'à ce que les zones rouges et bleues de l'image soient minimisées.
  • Réglez le curseur Exposition jusqu'à ce que les zones rouges et bleues de l'image soient minimisées. Pour plus d'informations, reportez-vous à Exposition.
  • Sélectionnez Exposition automatique. Pour plus d'informations, reportez-vous à Exposition automatique.

  4. Lorsque vous êtes satisfait de la qualité de l'image, cliquez à nouveau sur l'icône Analyse de luminosité [image] pour éteindre l'écran.

    Remarque : vous pouvez également sélectionner Afficher analyse de luminosité dans le menu Image pour désactiver Analyse de luminosité.
Fermé Chargement d'images depuis un PC

Le bouton Charger les images depuis le PC permet d'ouvrir la boîte de dialogue Options d'enregistrement/de lecture, qui est utilisée pour configurer les paramètres d'enregistrement et de lecture de capteurs de vision et d'émulateurs individuels. Après avoir configuré les paramètres de la boîte de dialogue, vous pouvez enregistrer les images acquises dans le Dossier Enregistrement et lire les images acquises stockées dans le Dossier Lecture, qui se trouve sur le PC.

Remarque :
  • Pour la surveillance et le débogage d'exécution, il est possible de stocker des images dans le capteur de vision plutôt que sur le PC ; utilisez l'étape Application Séquence vidéo pour configurer les Paramètres du capteur.
  • Lorsque des images couleur sont enregistrées sur l'ordinateur, elles sont enregistrées sous forme d'images de 16 bits plutôt que de 24 bits. lorsque des images couleur doivent être utilisées pour tester les outils couleur, vous pouvez exporter les images par le biais d'un serveur FTP (en ajoutant un serveur FTP à l'étape d'application Communication) pour enregistrer les images et préserver leur profondeur d'échantillonnage complète.
Fermé Onglet Lecture

Après avoir configuré les paramètres de l'onglet Lecture, lorsque vous cliquez sur le bouton Lecture (dans la séquence vidéo PC), les images stockées dans le Dossier Lecture du PC sont envoyées au capteur de vision et le projet s'exécute avec l'image en cours de lecture. Par défaut, le Dossier Lecture se rapporte au dossier Modèles de projets d'EasyBuilder.

Fermé Onglet Enregistrement

Après avoir configuré les paramètres de l'onglet Enregistrement, lorsque vous cliquez sur le bouton Enregistrement (dans la barre d'outils d'EasyBuilder) et que les images sont acquises, les images ayant réussi et celles ayant échoué sont enregistrées et sauvegardées dans le Dossier Enregistrement spécifié sur le PC. Vous pouvez enregistrer les images depuis un capteur de vision en ligne ou hors ligne dans tous les dossiers ayant des privilèges en « écriture ». Vous pouvez enregistrer jusqu'à 10 000 images sur le PC.


Acquisition ou chargement d'une image

La zone de groupe Acquérir/Charger une image permet d'acquérir instantanément une image du système de vision, d'afficher une vidéo active en direct depuis le système de vision ou de charger les images acquises précédemment à partir d'un PC.

Fermé Déclencheur

Le bouton Déclencheur sert à acquérir une seule image depuis le système de vision. Cliquez sur le bouton Déclencheur pour acquérir une seule image. Sinon, vous pouvez utiliser la touche F5 du clavier ou cliquer sur le bouton [image] dans la barre d'outils EasyBuilder (la commande Déclencheur de la zone de groupe Modifier les paramètres d'acquisition doit être définie sur Manuel).

Fermé Vidéo en direct

Le bouton Vidéo en direct active le système de vision pour qu'il produise un flux d'images sans les acquérir, ce qui permet de régler l'objectif fixé au système de vision et de compenser l'exposition et la luminosité. L'application fonctionne de manière optimale lorsque les images sont nettes et que la luminosité est équilibrée afin de maximiser le contraste.

La Métrique d'objectif fournie sous l'image aide à déterminer un score foyer-image, qui indique le degré auquel l'image, ou une région de celle-ci (à l'aide du bouton Région de mise au point), inclut les plus petites caractéristiques de réglage dans une scène (c'est-à-dire l'objet et son arrière-plan, comme capturé dans l'image).

Remarque :
  • Pour fournir des données utiles, le score Métrique d'objectif doit être comparé à un autre score Métrique d'objectif de la même scène (les scènes étant identiques).
  • La Métrique d'objectif peut être désactivée en cliquant sur l'icône Métrique d'objectif [image] dans la barre d'outils EasyBuilder en étant en mode Vidéo en direct.
Fermé Réglage de l'objectif
Fermé Systèmes de vision In-Sight série 5000, In-Sight série Micro, In-Sight série 7000 et In-Sight série 8000 avec objectif à monture C

  1. Appuyez sur le bouton Vidéo en direct. Sinon, vous pouvez appuyer sur le bouton [image] dans la barre d'outils EasyBuilder.

    Remarque : Le système de vision doit être hors ligne.
  2. Réglez manuellement la bague de mise au point de l'objectif fixée au système de vision afin que les détails des caractéristiques à inspecter soient nets et fortement contrastés et que le score Métrique d'objectif soit acceptable.
  3. Quand la qualité de l'image et son score vous conviennent, appuyez à nouveau sur le bouton Vidéo en direct.
  4. La dernière image acquise après avoir cliqué sur le bouton Vidéo en direct s'affiche alors.
Fermé Systèmes de vision In-Sight série 7000 avec objectif M12 à mise au point automatique
Remarque : Pour les systèmes de vision In-Sight série 70xx - 74xx, les contrôles de mise au point sont disponibles uniquement pour les systèmes de vision exécutant In-Sight Explorer 4.7.3 ou version ultérieure et le micrologiciel In-Sight 4.7.3 ou version ultérieure.

  1. Appuyez sur le bouton Vidéo en direct. Sinon, vous pouvez appuyer sur le bouton [image] dans la barre d'outils EasyBuilder.

    Remarque : Le système de vision doit être hors ligne.

  2. Cliquez sur le bouton Mise au point auto ou réglez manuellement le curseur de la position du foyer afin que les détails des caractéristiques à inspecter soient nets et fortement contrastés et que le score Métrique d'objectif soit acceptable.

    Remarque : lorsque vous cliquez sur le bouton Mise au point auto, le curseur de la position du foyer et le bouton Enregistrer la mise au point se désactivent.
  3. Après avoir cliqué sur le bouton Mise au point auto, la valeur de la position du foyer se met à jour et une nouvelle image s'affiche.
  4. Quand la qualité de l'image et son score vous conviennent, appuyez sur le bouton Enregistrer la mise au point. La position actuelle du foyer est enregistrée comme la position du foyer par défaut et l'objectif est automatiquement déplacé vers cette position au prochain démarrage du système de vision.
Fermé Réglage de la luminosité
  1. Appuyez sur le bouton Vidéo en direct. Sinon, vous pouvez appuyer sur le bouton [image] dans la barre d'outils EasyBuilder.
  2. Dans la barre d'outils EasyBuilder, appuyez sur Avis sur la luminosité. Les zones de l'image qui sont trop foncées sont mises en surbrillance en bleu alors que celles mises en surbrillance en rouge sont trop claires.

  3. Vous pouvez ajuster la luminosité de l'image en employant une des méthodes suivantes :

    • Réglez manuellement l'ouverture de l'objectif fixé au système de vision jusqu'à ce que les zones rouges et bleues de l'image soient réduites au minimum.
    • Dans la zone de groupe Modifier les paramètres d'acquisition, augmentez le contrôle Exposition jusqu'à ce que les zones rouges et bleues de l'image soient réduites au minimum.
    • Dans la zone de groupe Modifier les paramètres d'acquisition, activez le contrôle d'exposition automatique du système en sélectionnant Continue ou Capture unique dans le menu déroulant Exposition automatique. L'option Continue active le système de vision de manière à régler automatiquement l'exposition, en fonction des conditions d'éclairage, pour chaque image acquise. L'option Capture unique règle l'exposition du système de vision en se basant sur la première image acquise. Les paramètres d'exposition ne changent pas pour l'acquisition des images suivantes.
  4. Quand la qualité de l'image vous convient, appuyez à nouveau sur l'icône Avis sur la luminosité [image] pour arrêter l'affichage.
Fermé Chargement d'images depuis un PC

Le bouton Charger des images depuis un PC lance la boîte de dialogue Options d'enregistrement/lecture, qui sert à configurer les paramètres d'enregistrement et de lecture pour chaque système de vision et émulateur. Après configuration des paramètres de la boîte de dialogue, vous pouvez enregistrer les images acquises dans le Dossier d'enregistrement et lire les images acquises stockées dans le Dossier de lecture, situés tous deux sur le PC

Remarque :
  • Pour le suivi et le débogage lors de l'exécution, les images peuvent être stockées sur le système de vision plutôt que sur le PC ; utilisez l'étape de l'application pellicule pour configurer les Paramètres du capteur.
  • Lorsque des images couleur sont enregistrées sur l'ordinateur, elles sont enregistrées sous forme d'images de 16 bits plutôt que de 24 bits. lorsque des images couleur doivent être utilisées pour tester les outils couleur, vous pouvez exporter les images par le biais d'un serveur FTP (en ajoutant un serveur FTP à l'étape d'application Communication) pour enregistrer les images et préserver leur profondeur d'échantillonnage complète.
Fermé Onglet Lecture

Après configuration des paramètres de l'onglet Lecture, en cliquant sur le bouton Lecture (dans la pellicule PC), les images stockées dans le Dossier de lecture indiqué sur le PC sont envoyées au système de vision et le projet s'exécute par rapport à l'image en cours de lecture. Par défaut, le Dossier de lecture fait référence au dossier Modèles de projet EasyBuilder.

Remarque : Le répertoire de lecture est défini par défaut sur le répertoire d'exemples de projets (Sample Jobs) d'EasyBuilder. Les exemples de projets EasyBuilder illustrent à quel point les options d'enregistrement/de lecture sont utiles. Elles permettent, par exemple, de parcourir une série d'images déjà acquises, affichant instantanément les résultats des outils afin de pouvoir en configurer rapidement les seuils et les limites.
Fermé Onglet Enregistrement

Après configuration des paramètres de l'onglet Enregistrement, si l'on appuie sur le bouton Enregistrer (dans la barre d'outils EasyBuilder) et que les images sont acquises, celles ayant réussi et échoué sont enregistrées et sauvegardées dans le Dossier d'enregistrement indiqué du PC. Vous pouvez enregistrer les images depuis un système de vision en ligne et hors ligne dans n'importe quel dossier disposant des droits d'écriture. Il est possible d'enregistrer jusqu'à 10 000 images sur le PC.


Réglage des paramètres d'acquisition

L’étape de paramétrage d'image vous permet de régler les modes de prise de vue, de contrôler l’exposition et de contrôler l’éclairage des systèmes de vision In-Sight.

Capteurs de vision In-Sight série 2000

  • Paramètres d'image

Systèmes de vision In-Sight

  • Contrôles du déclencheur
  • Contrôles de l'exposition
  • Contrôles de transfert du capteur d'image
  • Contrôles de l'éclairage
  • HDR (High Dynamic Range)
  • Balance des blancs
  • Région de mise au point
  • Contrôles de mise au point
  • Paramètres de lumière
  • Paramètres de balayage des lignes

Capteurs de vision In-Sight série 2000

Systèmes de vision In-Sight

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

Aide EasyBuilder | 08/29/2022 | Revision: 5.9.0.2


Paramètres d'image

Remarque : Cette rubrique décrit l'interface utilisateur en étant connecté à un capteur de vision In-Sight série 2000. En cas de connexion aux systèmes de vision In-Sight, voir la section Système de vision In-Sight de Réglage des paramètres d'acquisition.

Déclencheur

Les paramètres type, délai et intervalle pour le déclenchement d'image vous permettent d'adapter votre acquisition afin de réaliser un contrôle performant.

Remarque : Si vous réglez le Type de déclenchement sur Continu sur le capteur de vision In-Sight série 2000, il est probable que la communication entre In-Sight Explorer et le capteur soit impossible, ceci car le processeur du capteur se retrouve en surcharge. Veuillez, dans ce cas, choisir un autre Type de déclenchement ou ajuster l’Intervalle de déclenchement.
Fermé Type

Le menu déroulant permet d'indiquer la source du déclencheur d'acquisition d'image lorsque le capteur de vision In-Sight est En ligne.

Caméra | Permet d'acquérir les images sur un front montant capté au niveau de l'entrée de déclenchement d'acquisition dédiée du système de vision.
Continue (par défaut) | Permet d'acquérir les images aussi rapidement que possible.
Manuel | Permet d'acquérir une image en appuyant sur la touche F5. Remarque : Vous pouvez déclencher manuellement le capteur en appuyant sur le bouton TRG du capteur de vision.
Ethernet industriel | Permet le déclenchement à partir d'un protocole Ethernet industriel, comme EtherNet/IP, PROFINET, Scanner SLMP ou CC-Link IE Field Basic.
Fermé Retard (en ms)

Le contrôle permet d'indiquer un retard en millisecondes (0 à 10 000) entre l'heure de réception du déclenchement et l'heure de début d'acquisition par le capteur de vision In-Sight. Le Type de déclencheur doit être défini sur Caméra.

Remarque :
  • Le Retard a une précision d'une milliseconde, plus ou moins la durée d'exposition de ligne maximale, qui est de 64 microsecondes.
  • Si le début de l'acquisition correspond au Type de signal indiqué à l'étape Entrées/sorties, ces sorties sont retardées de la durée indiquée.
Fermé Intervalle (en ms)

Le contrôle permet de définir un intervalle, en millisecondes (0 à 10 000 ; 0 par défaut), entre les acquisitions lorsque le contrôle Type est défini sur Continu.

Remarque : Ce délai dépend de la durée de traitement de l'image requise par le projet. Par exemple, si l'intervalle est défini sur 500 millisecondes, le capteur de vision In-Sight fait l'acquisition d'une image toutes les 500 millisecondes, sous réserve que le projet ait fini de traiter l'image dans ces 500 millisecondes. Sinon, le capteur de vision In-Sight acquerra une image dès qu'elle aura été traitée.

Mise au point (uniquement les capteurs de vision In-Sight 2000 avec Autofocus)

L'onglet Mise au point sert à contrôler la position de mise au point de l'objectif sur les capteurs de vision In-Sight série 2000, grâce à la fonction Autofocus, par une mise au point automatique de l'objectif ou un déplacement de l'objectif vers une position de mise au point spécifique.

Fermé Région de mise au point automatique

Spécifie la région de l'image qui sera utilisée lors de la mise au point automatique de l'objectif. Appuyez sur le bouton Région de mise au point automatique pour configurer la région.

Fermé Bouton Mise au point automatique

Met automatiquement au point l'objectif afin de maximiser la netteté de l'image au niveau de la région.

Fermé Mise au point auto au chargement du projet
  • Non cochée (= par défaut) : la distance actuelle de mise au point (%) sera enregistrée avec le projet.
  • Cochée : le capteur de vision procède automatiquement à la mise au point au chargement du projet.
Fermé Distance de mise au point (%)

Ajuste manuellement la position du foyer (0 - 100 %. Par défaut : objectif de 6,2 mm = 66 %, objectif de 16 mm = 69,2 %). Lors d'une tentative de mise au point sur un objet placé à proximité du capteur de vision, déplacez la poignée vers la gauche (vers 0 %). Lors d'une tentative de mise au point sur un objet placé loin du capteur de vision, déplacez la poignée vers la droite (vers 100 %). Vous pouvez déplacer la poignée quel que soit l'état du mode Vidéo directe.

Remarque : 0% représente le plan de mise au point le plus proche possible. Par exemple, lorsqu'un objet est placé très près du capteur de vision, vous pouvez voir 0 %. 100 % représente le plan de mise au point le plus éloigné qui soit pris en charge, lequel est essentiellement une « mise au point à l'infini ».

Éclairage

Remarque : dans certaines circonstances, l'éclairage du capteur de vision In-Sight série 2000 Mini avec Autofocus peut être plus sombre que celui d'un autre capteur de vision In-Sight série 2000.
Fermé Exposition automatique

Détermine automatiquement l'exposition après chaque acquisition. Cette option aide également à compenser les conditions d'éclairage variables, telles que les reflets de surfaces métalliques brillantes, les ombres variables et les changements d'éclairage en arrière-plan. L'exposition automatique est désactivée par défaut.

Fermé Exposition manuelle

Définit une valeur d'exposition fixe à utiliser pour chaque acquisition d'image. L'exposition manuelle est activée par défaut. Pour la désactiver, cochez Exposition automatique

Fermé Luminosité image cible

Permet d'indiquer le niveau de luminosité voulu (0 à 100, valeur par défaut = 50) en réglant la poignée ou en saisissant une valeur dans la zone d'édition correspondante. La valeur correspond à un pourcentage des pixels de la région d'exposition pouvant être saturés (c'est-à-dire blancs).

Astuce : vous pouvez également déplacer la poignée à l'aide des touches des FLÈCHES (HAUT, BAS, DROITE et GAUCHE).
Fermé Exposition (ms)

Le contrôle Exposition détermine la durée d'exposition lors de l'acquisition d'une image (0,000 à 1000,000 ; valeur par défaut = 0,250). Plus la valeur d'exposition est élevée, plus l'image acquise est lumineuse. Ce contrôle est désactivé lorsque l'option Exposition automatique est sélectionnée.

Fermé Intensité d'éclairage
Remarque : la barre de défilement Intensité d'éclairage n'est pas prise en charge sur les capteurs de vision In-Sight série 2000 Mini.

Permet d'indiquer l'intensité effective des LED en pourcentage (0 à 100, valeur par défaut = 70 ; OFF = 0) en réglant la poignée ou en saisissant une valeur dans la zone d'édition correspondante. L'intensité d'éclairage sera enregistrée avec le projet.

Astuce : vous pouvez également déplacer la poignée à l'aide des touches des FLÈCHES (HAUT, BAS, DROITE et GAUCHE).

L'arrière-plan bleu indique la valeur maximale d'intensité lumineuse disponible pour les paramètres actuels. La valeur maximale d'intensité lumineuse varie selon les autres paramètres d'image comme la Luminosité image cible, l'Exposition, la Hauteur de la zone d'image ou le Mode d'agrandissement de l'image.

Remarque : la valeur maximale s'affiche en survolant le curseur avec le pointeur de la souris.
Fermé Bouton Région d'exposition (Configurer la Région)

Définit la région à utiliser lors du calcul automatique de l'exposition.

  1. Cliquez sur le bouton Région de l'exposition.
  2. Placez la région autour de la zone de l'image que le capteur utilisera pour déterminer l'exposition automatique à employer pour la prochaine image acquise.
  3. Cliquez sur le bouton OK.

L'exposition est alors calculée automatiquement d'après la luminosité de la zone d'image située dans la région de l'exposition. Par exemple, si la zone de l'image située dans la région de l'exposition est plus lumineuse que le reste de l'image, la prochaine image acquise sera plus foncée.

Définir la région de l'exposition | Prochaine image acquise
Remarque : cliquez sur Réinitialiser à la région par défaut pour revenir au paramètre par défaut.
Fermé Exposition optimale

Optimise automatiquement la valeur d'exposition. La même valeur d'exposition sera utilisée pour chaque acquisition d'image suivante.

Fermé Mode de contrôle de l'éclairage

On (Exposition) permet d'activer l'anneau lumineux uniquement pendant la durée de l'exposition (par défaut). Lorsqu'il est désactivé (Off), l'éclairage est éteint et le capteur dépend de l'éclairage ambiant (de la pièce).

Balance des blancs (capteurs In-Sight 2000 couleur uniquement)

Fermé Région de balance des blancs et Définir balance des blancs

Suppression des dominances de couleur dans une image couleur en calculant les valeurs de rouge, le vert et le bleu de l'image (RGB) puis en les corrigeant. Ainsi, les éléments blancs en réalité, par exemple, apparaîtront blancs dans l'image.

Lors de la création d'un nouveau projet, c'est la balance des blancs la plus récemment utilisée qui sera exécutée. La définition de balance des blancs est enregistrée avec le projet et sera restaurée lors du chargement du projet.

Remarque :
  • La définition de balance des blancs doit être configurée à l'aide de l'option Exposition manuelle.

  • Pour garantir la reproduction de couleur la plus précise dans l'image, la balance des blancs est recommandée après avoir réalisé d'importants ajustements de l'intensité lumineuse.

  1. Faites la mise au point du capteur de vision In-Sight sur un objet de test plat, tel qu'un morceau de papier blanc mat, puis ajustez les contrôles d'éclairages afin que l'image ne soit pas surexposée.

  2. Cliquez sur Région de balance des blancs, puis incluez une région de l'image ne contenant que des pixels clairs et aucun « point sensible ».

    Remarque : Cliquez sur Réinitialiser à la région par défaut pour inclure de nouveau l'image entière.
  3. Cliquez sur Définir balance des blancs. Toute acquisition suivante d'images utilisera désormais ce paramètre.
Image avant Balance des blancs | Balance des blancs appliquée | Image après Balance des blancs

Image

Fermé Hauteur de la zone d'image

Définit le nombre de lignes d'image à acquérir pour réduire la durée d'acquisition d'image lorsque la zone intéressante est toujours limitée à la même bande de ligne dans l'image. Vous pouvez définir les valeurs en déplaçant les poignées gauche (ligne de départ) et droite (ligne de fin) ou en saisissant des valeurs dans les zones d'édition correspondantes.

Astuce : vous pouvez également déplacer la poignée à l'aide des touches des FLÈCHES (HAUT, BAS, DROITE et GAUCHE).
Modèle In-Sight | Résolution | Valeur de ligne de départ | Valeur de ligne de fin
2000-110 | 640 x 480 | 0 à 479 (par défaut = 0) | 0 à 479 (par défaut = 479)
2000-120/120C | 640 x 480 | 0 à 479 (par défaut = 0) | 0 à 479 (par défaut = 479)
2000-130/130C1 2000-230/230C1 | 640 à 480 (par défaut) | 0 à 479 (par défaut = 0) | 0 à 479 (par défaut = 479)
 | 800 x 600 | 0 à 599 (par défaut = 0) | 0 à 599 (par défaut = 599)
2000-23M1 | 640 x 480 | 0 à 479 (par défaut = 0) | 0 à 479 (par défaut = 479)
 | 800 à 600 (par défaut) | 0 à 599 (par défaut = 0) | 0 à 599 (par défaut = 599)
2001-230/230C1 | 640 x 480 | 0 à 479 (par défaut = 0) | 0 à 479 (par défaut = 479)
 | 800 x 600 | 0 à 599 (par défaut = 0) | 0 à 599 (par défaut = 599)
 | 1280 à 960 (par défaut) | 0 à 959 (par défaut = 0) | 0 à 959 (par défaut = 959)
1Vous pouvez configurer la résolution dans la boîte de dialogue Paramètres de l'image.
Fermé Mode d'agrandissement de l'image

Active le mode d'agrandissement de l'image. Lorsqu'il est activé, le FOV est réduit de 50 % alors que la résolution optique est augmentée de 200 %.

Modèle In-Sight | Résolution | Mode d'agrandissement de l'image
2000-110 | 640 x 480 | Non pris en charge
2000-120/120C | 640 x 480 | Peut être activé et désactivé
2000-130/130C1 2000-230/230C1 | 640 à 480 (par défaut) | Peut être activé et désactivé
 | 800 x 600 | Toujours activé
2000-23M1 | 640 x 480 | Peut être activé et désactivé
 | 800 à 600 (par défaut) | Toujours activé
2001-230/230C1 | 640 x 480 | Peut être activé et désactivé
 | 800 x 600 | Toujours activé
 | 1280 à 960 (par défaut) | Toujours activé
1Vous pouvez configurer la résolution dans la boîte de dialogue Paramètres de l'image.
Mode d'agrandissement de l'image Désactivé | Mode d'agrandissement de l'image Activé
Fermé Type de calibrage

Vous permet de convertir ou de calibrer les mesures des outils d'inspection des pixels en unités réelles. Deux options sont possibles : Champ de vue ou Importer.

Remarque :
  • L'option Champ de vue n'est disponible que sur les capteurs de vision In-Sight 2000-110 et 2000-120/120C.
  • L'option Importer n'est disponible que sur les capteurs de vision In-Sight 2000-23M.
Fermé Champ de vue

Conversion des résultats des outils de mesure à partir des pixels en unités réelles de mesure (millimètres, centimètres et/ou pouces).

Champ de vue (largeur) = 640 pixels/125 millimètres
  1. Sélectionnez Champ de vue (largeur) dans le menu déroulant Type de calibrage.
  2. Sélectionnez l'unité réelle de mesure à utiliser (millimètres, centimètres ou pouces) dans le menu déroulant. Pixels est sélectionné par défaut et la valeur ne peut pas être modifiée.
  3. Mesurez la largeur du Champ de vue le plus précisément possible dans l'unité de mesure sélectionnée, puis entrez la valeur mesurée.

  4. La conversion du résultat de mesure sera immédiatement appliquée. Par exemple, si le Champ de vue (largeur) est défini sur 125 millimètres et que la distance mesurée entre les deux bords est de 490 pixels, le résultat de mesure sera de 95,703 mm.

    Remarque :
    • Ci-dessous la formule et le calcul réel utilisés dans l'exemple :
      • Champ de vue (unités réelles) / Champ de vue (pixels) * Mesure (pixels) = Résultats (unités réelles)
      • 125/640*490 = 95.703 mm
Fermé Importer

Le type Calibrage Importer permet de charger un fichier de calibrage créé par un Outil de calibrage du point N et exporté dans le système de fichier local du capteur de vision In-Sight. Le fichier de calibrage Importer calibre automatiquement le projet actuel dès qu'il est chargé.

Remarque : avant de sélectionner Importer comme type de calibrage, commencez par ajouter et configurer un outil de calibrage du point N, puis exportez le fichier de calibrage dans le système de fichier local du capteur de vision In-Sight.

L'outil de calibrage du point N génère une transformation 2D pour effectuer une conversion entre les systèmes de pixels et de coordonnées réelles. L'outil effectue les transformations suivantes :

  • Translation en deux dimensions (utilisation d'au moins 2 paires de points).
  • Rotation sur trois axes (utilisation d'au moins 4 paires de points).
  • Mise à l'échelle en deux dimensions (utilisation d'au moins 2 paires de points).
  • Déformation de la perspective (utilisation d'au moins 4 paires de points).
  • Formation d'un parallélogramme ou d'une obliquité (utilisation d'au moins 4 paires de points).

Méthode d'utilisation

  1. Sélectionnez Importer dans le menu déroulant Type de calibrage.
  2. EasyBuilder examine automatiquement votre projet à la recherche de fichiers de calibrage générés par un outil de calibrage du point N et charge le fichier de calibrage. Si vous avez créé plus d'un fichier de calibrage, sélectionnez celui que vous souhaitez dans le menu déroulant Nom du fichier.
  3. Dans le menu déroulant Unités, sélectionnez les unités de mesure réelles qui définissent le calibrage : Microns, Millimètres (par défaut), Centimètres ou Pouces.
  4. Le calibrage est appliqué dès que cette option est sélectionnée et que les valeurs sont configurées.


Contrôles du déclencheur

Les contrôles du déclencheur Déclenchement, Retard de déclenchement et Intervalle de déclenchement permettent de personnaliser le mode et l'heure d'acquisition d'une image.

  • Déclenchement : Définit la source du déclencheur d'acquisition d'image lorsque le système de vision est En ligne.

    • Caméra (par défaut) : Permet d'acquérir les images sur un front montant capté au niveau de l'entrée de déclenchement d'acquisition dédiée du système de vision.
    • Continue : Permet d'acquérir les images aussi rapidement que possible.

    • Externe : Permet d'acquérir les images au moyen d'une commande série ou sur le front montant appliqué à un bit d'entrée discrète configuré en tant que déclencheur d'acquisition.

      Remarque :
      • Il est possible d'obtenir des fréquences de déclenchement plus rapides en utilisant l'entrée intégrée du déclencheur d'acquisition du système de vision (en définissant le paramètre Déclencheur de la fonction AcquireImage sur Caméra) plutôt que de déclencher les événements du système de vision avec une ligne d'entrée générale configurée en tant que Déclencheur d'acquisition (en définissant le paramètre Déclencheur de la fonction AcquireImage sur Externe).
      • Si le paramètre Déclencheur de la fonction AcquireImage est défini sur Externe et qu'une acquisition échoue, la sortie ERR : Échec de l'acquisition n'est pas émise du système de vision. Le signal ERR : Acquisition manquée est uniquement pris en charge lorsque le paramètre Déclencheur de la fonction AcquireImage est défini sur Caméra.
    • Manuel : Permet d'acquérir une image en appuyant sur la touche F5.
    • Ethernet industriel : Permet le déclenchement à partir d'un protocole Ethernet industriel, comme EtherNet/IP, POWERLINK, Profinet, SLMP Scanner ou CC-Link IE Field Basic.
    • Horodatage : Permet d'acquérir une image lorsqu'un déclencheur temporel est envoyé au système de vision par Ethernet/IP depuis un PLC. L'option Horodatage n'est disponible que sur les systèmes de vision suivants :

      • Systèmes de vision In-Sight série 5000 avec 128 Mo de mémoire Flash non volatile fonctionnant avec la version 4.5.0 ou ultérieure du micrologiciel

        Remarque : Les systèmes de vision In-Sight 5605 (type 821-0032-1R), In-Sight 5705 et In-Sight 5705C ne sont pas pris en charge.
      • Systèmes de vision In-Sight série 7000 Gen2
      • Systèmes de vision In-Sight série 9000

  • Retard de déclenchement : Spécifie un retard en millisecondes (0 à 10.000) entre la réception du déclenchement et le début de l'acquisition par le système de vision.

    Remarque :
    • Le contrôle Déclencheur doit être défini sur Caméra ou Réseau pour activer cette fonctionnalité.
    • Le retard est indiqué avec précision à la milliseconde demandée, plus ou moins la durée d'exposition de ligne maximale qui est de 64 microsecondes.
    • Si le début de l'acquisition ou l'unité stroboscopique correspond au Type de signal indiqué à l'étape Entrées/sorties, ces sorties sont retardées de la durée indiquée.

  • Intervalle de déclenchement : Spécifie un intervalle, en millisecondes (0 à 10.000 ; 500 par défaut), entre les acquisitions lorsque le contrôle Déclencheur est défini sur Continue.

    Remarque : Ce délai dépend de la durée de traitement de l'image requise par le projet. Par exemple, si l'intervalle de déclenchement est défini sur 5.000 millisecondes, le système de vision fait l'acquisition d'une image toutes les 5.000 millisecondes, sous réserve que le projet ait fini de traiter l'image dans ces 5.000 millisecondes. Sinon, le système de vision In-Sight acquerra une image dès qu'elle aura été traitée.


Contrôles de l'exposition

Les contrôles de l'exposition permettent de personnaliser l'application afin de mieux gérer les conditions d'éclairage variables et d'équilibrer la luminosité. Cela optimise les détails des caractéristiques lors de l'inspection.

Fermé Exposition

Le contrôle Exposition permet d'indiquer la durée d'exposition. Lorsque le système de vision In-Sight reçoit un signal de déclenchement, l'éclairage est intégré dans le capteur d'image pendant la durée indiquée.

Remarque :
  • Vous pouvez configurer la résolution dans la boîte de dialogue Paramètres de l'image pour les systèmes de vision/capteurs suivants : In-Sight Micro 1500, In-Sight 2000-130, 2000-130C, 2000-230, 2000-230C, 2000-23M, 2001-230, 2001-230C, In-Sight 7500, 7500C, 7600, 7600C, 7800, 7800C, 7900, 7900C, 7802, 7802C, 7902, 7902C.
  • Pour les systèmes de vision linéaires 5604 et 5614, la Hauteur d'image peut être configurée dans la boîte de dialogue Paramètres de balayage des lignes.
  • Pour le système de vision linéaire 9902L, la Résolution 1K (Mode d'éclairage bas) et la Hauteur maximale d'image peuvent être configurées dans la boîte de dialogue Paramètres de balayage des lignes.
  • En cas de connexion à un système de vision In-Sight 5604, 5614 ou 9902L à balayage de ligne, la durée d'exposition est définie en microsecondes.
  • En cas d'utilisation d'une unité stroboscopique avec système de vision In-Sight 8405, une exposition minimale de 72 ms est conseillée pour une capture d'image complète, afin de garantir l'exposition de toutes les lignes de pixels quand l'unité stroboscopique est pulsée.

  • Même si, techniquement, l'exposition peut être définie sur 0, la durée d'exposition dépend du système de vision In-Sight et une valeur d'exposition de 0 est redéfinie par défaut sur la durée d'exposition minimale (en millisecondes ou microsecondes) du système de vision sélectionné.

Modèle In-Sight | Résolution | Type de capteur | Durée d'exposition (ms)
Micro 1020, 1050, 1100, 1110, 1100C, 1400, 1410, 1400C | 640 x 480 | CCD, obturateur global | 0,016 à 1000
Micro 1402, 1412 | 1280 x 1024 | CMOS, obturateur global | 0,016 à 950
Micro 1403, 1413, 1403C | 1600 x 1200 | CCD, obturateur global | 0,052 à 1000
Micro 1500 | 640 x 480 | CMOS, obturateur global | 0,004 à 500
 | 800 x 600 | CMOS, obturateur global | 0,005 à 500
2000-110, 2000-120, 2000-120C, 2000-130, 2000-130C, 2000-230, 2000-230C, 2000-23M, 2001-230, 2001-230C | 640 x 480 | CMOS, obturateur global | 0,001 à 1000
2000-130, 2000-130C, 2000-230, 2000-230C, 2000-23M, 2001-230, 2001-230C | 800 x 600 | CMOS, obturateur global | 0,001 à 1000
2001-230, 2001-230C | 1280 x 960 | CMOS, obturateur global | 0,001 à 1000
5100, 5110, 5100C, 5400, 5410, 5400C, 5600, 5610 | 640 x 480 | CCD, obturateur global | 0,016 à 1000
5403, 5413, 5603, 5613 | 1600 x 1200 | CCD, obturateur global | 0,027 à 1000
Balayage de ligne 5604 et 5614 | 1024 x 8192 | CCD, obturateur global | 1,33 µsec à 1000 µsec
5605, 5615, 5705, 5715 | 2448 x 2048 | CCD, obturateur global | 0,014 à 1000
5705C | 2448 x 2048 | CCD, obturateur global | 0,016 à 1000
7010, 7010C, 7020, 7050, 7200, 7210, 7230, 7200C, 7400, 7410, 7430, 7400C | 800 x 600 | CMOS, obturateur global | 0,016 à 950
7402, 7412, 7432, 7402C | 1280 x 1024 | CMOS, obturateur global | 0,016 à 950
7500, 7500C, 7600, 7600C, 7800, 7800C, 7900, 7900C | 800 x 600 | CMOS, obturateur global | 0,014 à 550
 | 640 x 480 | CMOS, obturateur global | 0,014 à 520
7501, 7501C, 7801, 7801C, 7901, 7901C | 1280 x 1024 | CMOS, obturateur global | 0,017 à 750
7802, 7802C, 7902, 7902C | 1600 x 1200 | CMOS, obturateur global | 0,020 à 940
 | 800 x 600 (Mode d'éclairage bas) | CMOS, obturateur global | 0,020 à 940
7802P, 7902P | 1920 x 1200 | CMOS, obturateur global | 0,021 à 1000
7905, 7905C | 2448 x 2048 | CMOS, obturateur global | 0,021 à 1000
8100, 8100C, 8200, 8200C, 8400, 8400C | 640 x 480 | CMOS, obturateur global | 0,014 à 520
8101, 8101C, 8401, 8401C | 1280 x 1024 | CMOS, obturateur global | 0,0174 à 750
8402, 8402C | 1600 x 1200 | CMOS, obturateur global | 0,020 à 940
8405 | 2592 x 1944 | CMOS, obturateur roulant | 0,032 à 1000
8505P | 2448 x 2048 | CMOS, obturateur global | 0,021 à 1000
9902L à balayage de ligne | 2048 x 16384 | CMOS, obturateur global | 2,00 µsec à 1000 µsec
 | 1024 x 16384
9912, 9912C | 4096 x 3000 | CMOS, obturateur global | 0,021 à 1000
Fermé Exposition automatique

Le contrôle Exposition automatique permet au système de vision de déterminer automatiquement l'exposition. Il aide également à compenser les conditions d'éclairage variables, telles que les reflets de surfaces métalliques brillantes, les ombres décalées et les changements d'éclairage en arrière-plan.

  • Continue : Active le système de vision de manière à régler automatiquement l'exposition, en fonction des conditions d'éclairage, pour chaque image acquise.

    Remarque : le mode Continue augmente l'intervalle entre les acquisitions.
  • Capture unique : Capture unique permet d'ajuster l'exposition du système de vision en fonction de la première acquisition d'image ; les paramètres d'exposition sont conservés pour chaque acquisition d'image ultérieure.
    • Première acquisition : Si le système de vision est hors ligne, la première acquisition sert à déterminer l'exposition et l'exposition est sauvegardée jusqu'à ce que l'option Capture unique soit désactivée. Si aucune acquisition n'a été effectuée pendant que le système de vision est hors ligne, lorsqu'il repasse en ligne, la première acquisition est utilisée pour déterminer l'exposition.
    • Acquisitions suivantes : le système de vision acquiert l'image en utilisant la valeur d'exposition calculée lors de la première acquisition.
    Remarque :
    • Si le système de vision ou le capteur de vision ne prend pas en charge cette fonctionnalité, elle ne s'affiche pas.
    • Si un autre mode d'exposition automatique est sélectionné, la valeur d'exposition est réinitialisée. La première acquisition effectuée après la réinitialisation de la valeur d'exposition sera utilisée pour déterminer une nouvelle valeur d'exposition.
Fermé Bouton Région de l'exposition

Définit la région à utiliser lors du calcul automatique de l'exposition.

Remarque : Pour activer cette fonction, vous devez sélectionner l'option Continue ou Capture unique dans le menu déroulant Exposition automatique.
  1. Cliquez sur le bouton Région de l'exposition.
  2. Placez la région autour de la zone de l'image que le capteur utilisera pour déterminer l'exposition automatique à employer pour la prochaine image acquise.
  3. Cliquez sur le bouton OK.

L'exposition est alors calculée automatiquement d'après la luminosité de la zone d'image située dans la région de l'exposition. Par exemple, si la zone de l'image située dans la région de l'exposition est plus lumineuse que le reste de l'image, la prochaine image acquise sera plus foncée.

Définir la région de l'exposition | Prochaine image acquise
Fermé Durée d'exposition max.

Cette option permet d'indiquer la durée d'exposition maximale lors du réglage de l'exposition correcte.

Fermé Luminosité image cible

Cette option permet d'indiquer le niveau de luminosité souhaité (0 à 100).

Remarque : Pour activer cette fonction, vous devez sélectionner l'option Continue ou Capture unique dans le menu déroulant Exposition automatique.


Contrôles de transfert du capteur d'image

Les contrôles de transfert du capteur d'image permettent de définir la ligne du capteur d'image (CCD ou CMOS) à partir de laquelle l'image sera transférée et le nombre de lignes du capteur d'image utilisées pour créer l'image.

Les systèmes de vision In-Sight acquièrent toutes les images à l'aide d'une réinitialisation asynchrone et d'un balayage progressif. Les systèmes de vision In-Sight en noir et blanc produisent des images à 8bits et les systèmes de vision In-Sight couleur produisent des images à 24 bits. La procédure d'acquisition d'image commence approximativement dans les 250 µs pour tous les systèmes de vision et se poursuit de la manière suivante:

  1. Le capteur d'image intègre la lumière pendant la durée spécifiée par les contrôles d'exposition.
  2. L'image cumulée dans le capteur d'image est transférée ligne par ligne dans un registre à décalage série.
  3. Pour chaque transfert de ligne, le système de vision temporise la sortie registre à décalage, pixel par pixel, du capteur d'image.
  4. Le transfert commence à la ligne de départ et se poursuit sur le nombre de lignes spécifié.
Fermé Ligne de départ

Définit la première ligne à transférer du capteur d'image vers la mémoire du système de vision In-Sight :

Résolution | Valeurs de ligne de départ valides
640 x 480 | 0 à 479
800 x 600 | 0 à 599
1024 x 768 | 0 à 767
1280 x 1024 | 0 à 1023
1600 x 1200 | 0 à 1199
2448 x 2048 | 0 à 2047
2592 x 1944 | 0 à 1943
Fermé Nombre de lignes

Définit le nombre de lignes à transférer vers la mémoire du système de vision In-Sight :

Résolution | Nombre de lignes valide
640 x 480 | 1 à 480
800 x 600 | 1 à 600
1024 x 768 | 1 à 768
1280 x 1024 | 1 à 1024
1600 x 1200 | 1 à 1200
2448 x 2048 | 1 à 2048
2592 x 1944 | 1 à 1944
Remarque : Si vous vous connectez à un émulateur et souhaitez afficher des images d'un système de vision In-Sight sur lequel les images ont été acquises avec les paramètres d'images partielles activés, définissez les paramètres Ligne de départ et Nombre de lignes de l'émulateur sur les mêmes valeurs que celles du système de vision In-Sight.


Contrôles de l'éclairage

Les contrôles de l'éclairage permettent de configurer des séries de LED et des anneaux lumineux LED pour les systèmes de vision In-Sight.

Remarque : Pour activer cette fonction, vous devez sélectionner l'option Continue ou Capture unique dans le menu déroulant Exposition automatique.
Fermé Mode de contrôle de l'éclairage (In-Sight série 5000 et In-Sight série 70xx - 74xx uniquement)

Le mode de contrôle de l'éclairage indique si l'anneau lumineux sur un système de vision In-Sight série 5000 ou série 70xx - 74xx est activé uniquement pendant la durée de l'exposition indiquée ou constamment. On (Exposition) permet d'activer l'anneau lumineux uniquement pendant la durée de l'exposition. On (Continue) permet l'activation constante de l'anneau lumineux, réduisant ainsi l'effet stroboscopique, en laissant les LED allumés à 50 % d'intensité lorsqu'aucune image n'est exposée.

Fermé Contrôle de l'éclairage (In-Sight série 5000 uniquement)

Contrôle quatre (4) séries de LED au maximum dans le système de vision In-Sight.

Fermé Exemple - Système de vision In-Sight série 5000 avec anneau lumineux

  • Horizontal active les deux séries de LED horizontales.
  • Vertical active les deux séries de LED verticales.
  • Tout active les deux séries de LED horizontales et verticales.
Fermé Intensité d'éclairage (In-Sight série 70xx - 74xx uniquement)

Contrôle l'intensité effective des LED. L'intensité d'éclairage sera enregistrée avec le projet.

  • Système de vision In-Sight série 70xx - 74xx : 0 à 100 ; par défaut = 1 : DÉSACTIVÉ = 0.
Fermé Gain (In-Sight série 7000 et 9912 uniquement)

Contrôle le gain de l'étage amplificateur précédant le convertisseur analogue/numérique.

Modèle In-Sight | Paramètres du gain
Série 70xx - 74xx | 0 à 7 ; par défaut = 0
7500, 7501, 7600, 7600C, 7800, 7800C, 7801, 7801C, 7802, 7802C, 7900, 7900C, 7901, 7901C, 7902, 7902C | 0 à 6 ; par défaut = 0
7802P, 7902P, 7905, 7905C | 0 à 240 ; par défaut = 60
9912, 9912C | 0 à 255 ; par défaut = 60


HDR (High Dynamic Range)

La technologie HDR (High Dynamic Range) permet d’obtenir un meilleur contraste et une luminosité plus forte sur les zones les plus sombres d’une image. Cet effet est obtenu en une seule acquisition.

Remarque : Le mode HDR est pris en charge uniquement sur les systèmes de vision monochromes 7802P, 7902P, 7905, 8505P et 9912.

  • Mode HDR : Permet de définit la méthode HDR à utiliser.
    • Désactivé (par défaut) = HDR non utilisé.
    • HDR+ : Ajuste la valeur de niveau de gris de chaque pixel en fonction des pixels qui l'entourent (selon taille du noyau choisie). Cette méthode permet d’obtenir un contraste plus fort dans les zones sombres (sous-exposées) et lumineuses (surexposées) par rapport à la méthode HDR simple.
    • HDR : Ajuste la valeur de niveau de gris de chaque pixel individuellement. Cela permet d’obtenir plus de contraste dans les zones sombres (sous-exposées) de l’image d’entrée.
  • HDR - taille du noyau : Permet de définir le nombre de pixels traités simultanément avec HDR+.
    • Faible : 121 pixels (grille 11x11)
    • Importante : 484 pixels (grille 22x22)


Balance des blancs (systèmes de vision In-Sight couleur uniquement)

Remarque : Cette rubrique décrit la caractéristique balance des blancs en étant connecté à un système de vision In-Sight couleur. En cas de connexion à un capteur de vision In-Sight couleur série 2000, voir la section Balance des blancs de Paramètres d'image.

Disponible uniquement pour les systèmes de vision In-Sight couleur et les émulateurs activés pour la couleur, le bouton Balance des blancs supprime les dominances de couleur dans une image colorée en calculant les valeurs de rouge, de vert et de bleu (RGB) de l'image et en les corrigeant selon les tables des couleurs enregistrées dans le projet In-Sight. Ainsi, les éléments blancs en réalité, par exemple, apparaîtront blancs dans l'image.

Image avant Balance des blancs | Balance des blancs appliquée | Image après Balance des blancs

Vous créez les tables des couleurs en acquérant une image de référence « neutre » (c'est-à-dire une référence avec les même valeurs RGB ; par exemple 18-18-18), tout en vous assurant que l'image ne frôle pas la saturation (255-255-255). Après avoir cliqué sur le bouton Balance des blancs, EasyBuilder génère un histogramme de chaque canal de couleur (rouge, vert et bleu) et « égalise » les valeurs de couleurs en considérant la plus grande valeur comme base et en la divisant par chaque valeur de couleur pour produire des facteurs d'échelle ; ils sont ensuite utilisés pour créer les tables de couleurs (par exemple, des valeurs RGB de 200-100-50 donnent des facteurs d'échelle de 1-2-4).

Les tables des couleurs, pour les paramètres du système de vision actuel, sont enregistrés dans le fichier du projet. Pour garantir que pour la Balance des blancs, les informations appropriées sont employées, chargez le projet avant de charger ou d'acquérir une image.

Pour utiliser la fonction Balance des blancs :

  1. Faites la mise au point du capteur de vision In-Sight sur un objet de test plat, tel qu'un morceau de papier blanc avec des écritures noires, puis définissez la Luminosité image cible de façon appropriée.

    Remarque : Le bouton Région de balance des blancs est utilisé pour spécifier la région utilisée pour le calcul de la balance des blancs de l'image. Cliquez sur le bouton Région de balance des blancs pour indiquer la région.
  2. Au lieu de l'objet de test plat, insérez un autre objet tel qu'un morceau de papier blanc. La taille du deuxième objet doit convenir au champ de vue de la même façon que le premier.

  3. Cliquez sur le bouton Balance des blancs.

  4. EasyBuilder va maintenant enregistrer ces paramètres dans le fichier du projet et toutes les acquisitions suivantes d'images utiliseront ce paramètre de balance de couleur.

    Remarque : Pour les systèmes de vision In-Sight couleur, le paramètre Balance des blancs est enregistré dans le fichier du projet et pas sur le système de vision In-Sight. Lors de la création d'un nouveau projet, vous devez répéter ces étapes pour appliquer les paramètres Balance des blancs à ce fichier de projet. EasyBuilder ne permet pas de conserver les paramètres Balance des blancs sur le système de vision.


Région de mise au point

Le bouton Région de mise au point permet de spécifier la région de l'image qui sera utilisée pour calculer la mise au point de l'image pour la mesure de la mise au point en mode direct. Cliquez sur le bouton Région de mise au point pour configurer la région.


Contrôles de mise au point

Les contrôles de mise au point sont utilisés pour contrôler la position de la mise au point de l'objectif sur les systèmes de vision In-Sight série 7000 pris en charge, soit en mettant automatiquement au point l'objectif soit en le déplaçant à une position particulière de mise au point.

Remarque :
  • Pour les systèmes de vision In-Sight série 70xx - 74xx, les contrôles de mise au point sont disponibles uniquement pour les systèmes de vision exécutant In-Sight Explorer 4.7.3 ou version ultérieure et le micrologiciel In-Sight 4.7.3 ou version ultérieure.
  • Les contrôles de mise au point ne fonctionnent que lorsque le système de vision est hors ligne.
  • Les boutons Autofocus et Enregistrer la mise au point sont également accessibles depuis le mode Vidéo directe dans la Vue Tableur et la Vue EasyBuilder.
Fermé Contrôles de mise au point

Définit si les Contrôles de mise au point sont activés ou non. Par défaut, si un capteur possède une position de mise au point par défaut, les Contrôles de mise au point sont activés ; si aucune position de mise au point n'a été établie, les Contrôles de mise au point sont désactivés.

Fermé Bouton Mise au point automatique

Met automatiquement au point l'objectif afin de maximiser la netteté de l'image au niveau de la région.

Fermé Offset de l’autofocus (In-Sight série 70xx - 74xx uniquement)

Définit un décalage à appliquer à la position (-100 à 100 ; par défaut = 0) de l'objectif une fois l'autofocus effectué.

Remarque : Ce réglage n'est pas pris en charge pour le système de vision In-Sight série 7000 Gen2.
Fermé Position du foyer

Déplace l'objectif à une position de mise au point particulière et procède à l'acquisition d'une nouvelle image.

  • In-Sight série 70xx - 74xx : 0 à 100 ; par défaut = 0.
  • In-Sight série 7000 Gen2 : 0 à 250 ; par défaut = 0.
Fermé Enregistrer la mise au point avec le projet

Définit si la position du foyer doit être enregistrée avec le projet et appliquée à l'objectif lorsque le projet est rechargé. Par défaut, la case Enregistrer la mise au point avec le projet est cochée.


Contrôles Balayage de ligne

Les contrôles Balayage de ligne permettent de configurer les paramètres de votre système de vision à balayage de ligne In-Sight 5604 ou 9902L. Le système de vision à balayage de ligne assemble une image ligne après ligne à mesure que l'objet cible passe sous le système. Cette technique permet de réaliser des images complètes, « à plat », d'objets cylindriques ou des coupes continues d'une surface. Grâce à un encodeur fourni par l'utilisateur, le système de vision à balayage de ligne permet d'obtenir des images de haute précision, malgré les variations de vitesse de la cible.

Remarque :
  • Vous devez vous connecter à un système de vision In-Sight 5604 ou 9902L à balayage de ligne ou à un émulateur pour activer ces contrôles.
  • Le niveau d'accès de l'utilisateur doit être réglé sur Complet pour pouvoir modifier ces réglages.
  • Le système de vision à balayage de ligne doit être Hors ligne.

  • Déclencheur : Définit la source du déclencheur d'acquisition d'image lorsque le système de vision à balayage de ligne est En ligne.

    • Caméra (par défaut) : Permet d'acquérir les images sur un front montant capté au niveau de l'entrée de déclenchement d'acquisition dédiée du système de vision.
    • Continue : Permet d'acquérir les images aussi rapidement que possible.

    • Externe : Permet d'acquérir les images au moyen d'une commande série ou sur le front montant appliqué à un bit d'entrée discrète configuré en tant que déclencheur d'acquisition.

      Remarque :
      • Il est possible d'obtenir des fréquences de déclenchement plus rapides en utilisant l'entrée intégrée du déclencheur d'acquisition du système de vision (en définissant le paramètre Déclencheur de la fonction AcquireImage sur Caméra) plutôt que de déclencher les événements du système de vision avec une ligne d'entrée générale configurée en tant que Déclencheur d'acquisition (en définissant le paramètre Déclencheur de la fonction AcquireImage sur Externe).
      • Si le paramètre Déclencheur de la fonction AcquireImage est défini sur Externe et qu'une acquisition échoue, la sortie ERR : Échec de l'acquisition n'est pas émise du système de vision. Le signal ERR : Acquisition manquée est uniquement pris en charge lorsque le paramètre Déclencheur de la fonction AcquireImage est défini sur Caméra.
    • Manuel : Permet d'acquérir une image en appuyant sur la touche F5.
    • Ethernet industriel : Permet le déclenchement à partir d'un protocole Ethernet industriel, comme EtherNet/IP, POWERLINK, Profinet, SLMP Scanner ou CC-Link IE Field Basic.
    • Horodatage : Permet d'acquérir une image lorsqu'un déclencheur temporel est envoyé au système de vision par Ethernet/IP depuis un PLC. L'option Horodatage n'est disponible que sur les systèmes de vision suivants :

      • Systèmes de vision In-Sight série 5000 avec 128 Mo de mémoire Flash non volatile fonctionnant avec la version 4.5.0 ou ultérieure du micrologiciel

        Remarque : Les systèmes de vision In-Sight 5605 (type 821-0032-1R), In-Sight 5705 et In-Sight 5705C ne sont pas pris en charge.
      • Systèmes de vision In-Sight série 7000 Gen2
      • Systèmes de vision In-Sight série 9000

  • Retard de ligne (lignes) : Définit le nombre de lignes d'attente d'acquisition d'image, une fois que le déclenchement d'une caméra a eu lieu.

    Remarque : Le paramètre Déclencheur doit être réglé sur Caméra pour activer ce contrôle.
  • Intervalle de déclenchement : Permet de définir un intervalle en millisecondes entre les acquisitions lorsque le contrôle Déclencheur est défini sur Continue (0 à 10 000, 500 par défaut). Ce délai dépend de la durée de traitement de l'image requise par le projet. Par exemple, si l'intervalle de déclenchement est défini sur 5 000 millisecondes, le système de vision In-Sight fait l'acquisition d'une image toutes les 5 000 millisecondes, sous réserve que le projet ait fini de traiter l'image dans ces 5 000 millisecondes. Sinon, le système de vision In-Sight procède à l'acquisition d'une image dès que la précédente a été traitée.

  • Exposition (µs) : Définit le temps d'exposition, en microsecondes (0 à 1 000 µs ; 8 µs par défaut). Lorsque le système de vision reçoit un signal de déclenchement, le capteur CCD de balayage de ligne est exposé à la lumière pendant la durée spécifiée.

    Remarque :
    • Sur le modèle 5604, bien que ce paramètre puisse être défini sur 0, toute valeur inférieure à 1,33 µs entraînera une exposition effective de 1,33 µs, quelle que soit la valeur de la propriété Exposition.
    • Sur le modèle 9902L, bien que ce paramètre puisse être défini sur 0, toute valeur inférieure à 2,00 µs entraînera une exposition effective de 2,00 µs, quelle que soit la valeur de la propriété Exposition.
  • Type de déclencheur de ligne : Définit le type d'encodeur : Encodeur logiciel ou Encodeur matériel. Vous devez vous connecter à un système de vision In-Sight 5604 ou 9902L pour activer ce contrôle. Ce contrôle est désactivé pour les émulateurs à balayage de ligne.
    • Encodeur matériel : Indique que le paramètre Étapes par ligne et un encodeur matériel externe serviront à piloter les déclenchements de ligne. Un Encodeur matériel est un appareil qui numérise la position de l'objet cible en émettant un signal de transition à chaque déplacement de la cible dans une direction spécifique ou d'une distance spécifique. Les systèmes In-Sight 5604 et In-Sight 9902L prennent en charge deux types différents d'encodeurs matériels : Simple ou Quadrature. Ce réglage peut être défini dans la boîte de dialogue Paramètres de balayage des lignes.
    • Encodeur logiciel (par défaut) : Indique que le paramètre Période de ligne servira d'horloge de synchronisation pour piloter les déclenchements de ligne. Un Encodeur logiciel est l'émulation logicielle d'un encodeur matériel et permet l'acquisition de lignes à la fréquence définie. Cette méthode est principalement utilisée pour les opérations d'installation et de dépannage, car elle est sensible aux variations de vitesse de la cible (accélération à basse fréquence et tremblement à haute fréquence). Ces situations peuvent entraîner des artéfacts dans le sens vertical.
  • Nombre de lignes : Définit le nombre de lignes acquises pour que le système de vision à balayage de ligne construise une image.
    • Par défaut, le système In-Sight 5604 construit des zones d'image standard d'une résolution de 1024 x 2048. Il n'est pas possible de modifier la largeur. Il est possible de modifier la hauteur maximale de l'image en appuyant sur le bouton Configuration de l'encodeur afin d'ouvrir la boîte de dialogue Paramètres de balayage des lignes. La plage de valeurs Nombre de lignes est compris entre 1 et la Hauteur maximale d'image.
    • Par défaut, le système In-Sight 9902L construit des zones d'image standard d'une résolution de 2048 x 4096. Il est possible de modifier la hauteur et la largeur maximales de l'image en appuyant sur le bouton Configuration de l'encodeur afin d'ouvrir la boîte de dialogue Paramètres de balayage des lignes. Lorsque la case Résolution 1K (Mode d'éclairage bas) est activée, la largeur est réduite à 1024 pour une plus grande sensibilité à la lumière. La plage de valeurs Nombre de lignes est compris entre 1 et la Hauteur maximale d'image.
    Modèle In-Sight | Résolution maximale | Minimum | Maximum | Valeur par défaut
    In-Sight 5604 | 1024 x 8192 | 1 | 8192 | 2048
    In-Sight 9902L | 2048 x 16384 | 1 | 16384 | 4096
    1024 x 16384
    Remarque :
    • Pour l'acquisition d'images à partir de cibles en rotation, la valeur Nombre de lignes doit être inférieure au nombre de lignes entre deux déclenchements de trame pour éviter les pertes d'image.
    • Bien que ce paramètre puisse être défini sur 1, toute valeur inférieure à 8 entraînera l'échec de l'acquisition d'image.

  • Étapes par ligne : Lorsque Type de déclencheur de ligne est défini sur Encodeur matériel, ce paramètre définit le nombre d'étapes d'encodeur par ligne de l'image. Une "étape" est un cycle complet du signal de l'encodeur (ou des signaux dans le cas d'un encodeur matériel en quadrature). Pour un encodeur matériel à ligne simple, cela équivaut à deux transitions de signaux, et pour un encodeur matériel en quadrature à quatre transitions de signaux.

    Modèle In-Sight | Étapes par ligne
    In-Sight 5604 | 0.250 à 256.000 ; par défaut = 40.000
    In-Sight 9902L | 0.250 à 8191.000 ; par défaut = 40.000
    Remarque :
    • La valeur Étapes par ligne doit être incrémentée de 0.5 pour un encodeur matériel à ligne simple et de 0.25 pour un encodeur matériel en quadrature.
    • Sur le système 5604, pour éviter la perte de déclencheurs de ligne, la valeur Étapes par ligne doit être définie de façon à ce que l'intervalle de temps le plus court entre deux lignes soit supérieur de 21,47 µs à la valeur de l'Exposition (minimum 1,33 µs).
    • Sur le système 9902L, pour éviter la perte de déclencheurs de ligne, la valeur Étapes par ligne doit être définie de façon à ce que l'intervalle de temps le plus court entre deux lignes soit supérieur de 3 µs à la valeur de l'Exposition ou égal à 15 µs, selon la valeur la plus élevée.
    Fermé Chronogramme des pas par ligne de l'encodeur matériel

  • Période de ligne (µs) : Lorsque Type de déclencheur de ligne est défini sur Encodeur logiciel, ce paramètre définit la durée, en microsecondes, par ligne de l'image.

    Modèle In-Sight | Période de ligne
    In-Sight 5604 | 21.000 à 1000000.000 ; par défaut = 40.000
    In-Sight 9902L | 21.000 à 1000000.000 ; par défaut = 40.000
    Émulateur In-Sight | 10.000 à 1000000.000 ; par défaut = 40.000
    Remarque :
    • Sur le système 5604, pour éviter la perte de déclencheurs de ligne, la valeur Période de ligne doit être définie de façon à ce que l'intervalle de temps le plus court entre deux lignes soit supérieur de 21,47 µs à la valeur de l'Exposition (minimum 1,33 µs).
    • Sur le système 9902L, pour éviter la perte de déclencheurs de ligne, la valeur Période de ligne doit être définie de façon à ce que l'intervalle de temps le plus court entre deux lignes soit supérieur de 3 µs à la valeur de l'Exposition ou égal à 15 µs, selon la valeur la plus élevée.
  • Mode de coupure : Permet de définir une action consécutive à la réception d'un déclencheur d'acquisition d'image alors que le nombre de lignes défini n'a pas encore été acquis.
    • Pas de coupure (par défaut) : Indique que le déclencheur d'image sera ignoré et qu'un événement "Erreur d'acquisition" sera généré.
    • Remplir les lignes manquantes en noir : Indique que les lignes restantes seront remplies par des pixels noirs et que l'acquisition de la nouvelle image débutera immédiatement. Aucun événement "Erreur d'acquisition" n'est alors généré.

    • Image partielle : Indique que l'image actuelle sera réduite aux dimensions du nombre de lignes déjà acquises, et que l'acquisition de la nouvelle image débutera immédiatement.

    Remarque :
    • Si vous avez sélectionné Remplir en noir ou Réduire les lignes d'image :
      • Définissez le Type de déclenchement sur Caméra pour couper correctement les images. Avec tout autre Type de déclenchement, si le déclenchement se produit alors qu'une image est en cours d'acquisition, celle-ci n’est pas coupée et le déclenchement est ignoré.
      • Si une commande en mode natif Set Event est envoyée pour déclencher une acquisition et que le déclenchement se produit alors qu'une image est en cours d'acquisition, celle-ci n’est pas coupée et le déclenchement est ignoré.
    • Pour des applications en temps réel, sélectionnez l'option Réduire les lignes d'image. Ou, si vous utilisez l'option Remplir en noir, ne configurez qu'une centaine de lignes.
      • Pour le système 5604, l'option Remplir en noir termine une ligne en environ 2 µs (c'est-à-dire 0,2 milliseconde pour 100 lignes).
      • Pour le système 9902L, l'option Remplir en noir termine une ligne en environ 3 µs (c'est-à-dire 0,3 milliseconde pour 100 lignes).
  • Durée d'acquisition : Indique quand arrêter l'acquisition d'image lorsque le paramètre Mode de coupure est réglé sur Remplir en noir ou Réduire les lignes d'image. Pour le système de vision In-Sight 9902L, cette option est prise en charge uniquement lorsque le Type de déclenchement sélectionné est Caméra.
    • 0 = Déclencheur suivant (par défaut) : L'acquisition de l'image commence sur le front montant de l'impulsion de déclenchement et se termine au début du signal de déclenchement suivant.
    • 1 = Fin du Déclencheur : L'acquisition de l'image commence sur le front montant de l'impulsion de déclenchement et se termine au front descendant de cette même impulsion. Deux facteurs déterminent si l'acquisition d'une image est terminée :
      • Le nombre de lignes spécifié a été acquis, même si le front descendant de l'impulsion de déclenchement n'est pas encore atteint.

      • Le front descendant de l'impulsion survient et arrête l'acquisition avant que le nombre de lignes acquises corresponde au Nombre de lignes.

        Remarque : Si Fin du Déclencheur est sélectionné, le paramètre Délai est désactivé et aucun délai n'est appliqué à l'acquisition.

Paramètres de balayage des lignes


Paramètres de balayage des lignes

La boîte de dialogue Paramètres de balayage des lignes permet de configurer les paramètres de l'encodeur matériel sur les systèmes de vision à balayage de ligne In-Sight 5604 et 9902L, et indique des informations de diagnostic relatives au système de vision.

Remarque : Avec un encodeur matériel en quadrature, si le système de vision commence l'acquisition d'une image et que l'encodeur en quadrature signale qu'il se déplace en sens inverse et dépasse le début du déclencheur d'image, l'image résultante sera assemblée dans le mauvais ordre et sera inutilisable. Si cette situation se produit, placez le système de vision Hors ligne lorsque l'encodeur à quadrature indique qu'il change de direction. Replacez le système de vision En ligne une fois que l'encodeur en quadrature indique qu'il reprend sa direction précédente.

  • Hauteur maximale d'image : Spécifie le nombre maximum de lignes à utiliser pour construire l'image et le nombre maximum de tampons d'images pour les systèmes de vision à balayage de ligne :

    Système de vision Hauteur maximale d'image
    In-Sight 5604

    2048 (par défaut)

    4096

    8192
    In-Sight 9902L

    2048

    4096 (par défaut)

    8192

    12288

    16384
    Remarque :
    • Toute modification de la Hauteur maximale d'image du système de vision à balayage de ligne nécessite son redémarrage. Vous perdez ainsi tous les fichiers de projet et de paramètres stockés en mémoire non volatile. Sauvegardez ou enregistrez votre projet avant de poursuivre.
    • Le nombre par défaut de tampons d'image affectés au démarrage du système de vision dépend de la résolution et de la capacité en RAM du système de vision. La modification du paramètre Hauteur maximale d'image entraîne la diminution ou l'augmentation du nombre maximal de tampons d'images disponibles pour le système de vision. Si nécessaire, utilisez la boîte de dialogue Mémoires tampons d'images pour modifier le nombre de tampons d'image affectés au démarrage du système de vision.

    • Si vous utilisez un système de vision à balayage de ligne, la Largeur de la région de la Position ou des Outils d'inspection présente une limite maximale. Si vous devez choisir une valeur plus grande pour la Largeur de la région, vous devez accéder à la Vue tableur et entrer manuellement la valeur de la région dans la Barre de formule, ou créer une fonction Contrôles ou Structure distincte et la référencer à la place du paramètre Région de l'outil.

      Système de vision | Résolution | Hauteur maximale d'image | Largeur maximale dans la feuille de propriétés
      In-Sight 5604 | 1024 x 8192 | 8192 | 3072
      In-Sight 9902L 2048 x 16384

      Supérieure à 8192

               6144
      1024 x 16384 | Supérieure à 4096 | 3072
  • Encodeur matériel
    Remarque : Pour modifier le type ou la direction de l'Encodeur, le paramètre Type de déclencheur de ligne, visible à l'étape Configurer image, doit être défini sur Encodeur matériel, le système de vision à balayage de ligne doit être Hors ligne et les utilisateurs doivent disposer d'un accès complet.

    • Type d'encodeur : Spécifie le type d'encodeur matériel utilisé pour déclencher les acquisitions de ligne : Simple (par défaut) ou Quadrature.

      Remarque :
      • Lorsque le Type d'encodeur est réglé sur Simple, l'encodeur à ligne simple doit être raccordé à la première entrée de l'encodeur. La seconde entrée n'ayant aucun effet.
      • Les encodeurs en quadrature donnent des informations de direction et nécessitent donc deux entrées rapides.

    • Direction : Précise la direction que l'on doit considérer comme la marche avant de l'encodeur en quadrature : Positive (par défaut) ou Négative. Le système de vision à balayage de ligne utilise cette Direction pour déterminer le sens de fonctionnement correct. Les étapes se déroulant dans la direction inverse sont considérées comme invalides et entraînent l'annulation de la trame en cours.

      Remarque : Ce contrôle est désactivé lorsque le Type d'encodeur est Simple.
  • Diagnostics
    • Compte de l'encodeur : Affiche le nombre d'étapes de l'encodeur matériel (ou la durée en microsecondes pour un encodeur logiciel).
    • Nombre de lignes : Affiche le total cumulé des lignes acquises depuis la dernière réinitialisation des compteurs.
    • Total de dépassement de lignes : Affiche le nombre de lignes perdues à cause de taux d'encodage trop élevés.
    • Compte du dépassement de la mémoire tampon : Affiche le nombre de fois qu'un système de vision à balayage de ligne a manqué de tampons d'images.
    • Images par seconde : Affiche le nombre d'images acquises par seconde.

    • Étapes par seconde : Affiche le nombre de pas par seconde provenant d'un encodeur matériel externe.

      Remarque : Si un encodeur logiciel est utilisé, la valeur affichée correspond au nombre de microsecondes par seconde.

    • Bouton Remise à zéro : Réinitialise toutes les statistiques de diagnostic.

      Remarque : Les statistiques de diagnostic sont effacées dans deux situations : sur pression du bouton Remise à zéro, ou lorsque le système de vision à balayage de ligne est mis En ligne ou Hors ligne.
  • Résolution 1K (Mode d'éclairage bas) : Permet une plus grande sensibilité à la lumière avec une résolution plus faible. Cette option est uniquement prise en charge par le système de vision In-Sight 9902L.


Calibrer l'image avec des unités réelles

Remarque : Cette rubrique décrit la caractéristique calibration en étant connecté à un système de vision In-Sight. Si vous êtes connecté à un capteur de vision In-Sight 2000-130/130C ou 2000 série 23X, reportez-vous à la section Champ de vue (largeur) de Paramètres d'image.

La zone de groupe Calibrer l'image avec des unités réelles vous permet de calibrer les outils de recherche et d'inspection en affichant leurs résultats en unités de mesure réelles (microns, millimètres, centimètres et/ou pouces) plutôt qu'en valeurs de pixels.

Sur les systèmes de vision In-Sight, le calibrage désigne le processus « d'association » de la zone de l'image par l'établissement d'une relation entre les caractéristiques de l'image et les unités de mesure réelles connues. Au cours de ce processus, une conversion bidimensionnelle (2D) associe mathématiquement les points des coordonnées de pixels d'une image à des coordonnées réelles. Une fois l'image calibrée, les outils de recherche et d'inspection renvoient leurs résultats dans les unités (réelles) calibrées.

Six types de calibrage, avec divers degrés de précision, sont utilisés pour calibrer un système de vision In-Sight : Échelle X/Y, Transition à transition, Transition à transition X/Y, Cercle, Grille, Importer et En 9 points.

Afin de spécifier un calibrage pour le projet, sélectionnez une option de calibrage dans le menu déroulant Type de calibrage :

  • Aucun (par défaut)
  • Échelle X/Y
  • Transition à transition
  • Transition à transition X/Y
  • En 9 points
  • Cercle
  • Grille
  • Importer
Remarque :
  • Les options de calibrage Échelle X/Y, Transition à transition, Transition à transition X/Y, Cercle, Importer et En 9 points reposent sur 1 à 16 points définis par l'utilisateur, respectivement, dans l'image pour définir les mesures réelles des objets inspectés. Ces options de calibrage se contentent de compenser les déformations linéaires et non linéaires. Pour le plus haut niveau de précision, utilisez l'option Grille.
  • Si le paramètre par défaut Aucun est utilisé comme Type de calibrage, tous les résultats d'outils seront affichés en coordonnées de pixels.
  • Cochez la case Orientation classique pour afficher les résultats calibrés avec les coordonnées (Y/X) conventionnelles de la vue Tableur.
  • Lors de l'application d'un calibrage, la configuration physique et optique (objectif, système de vision et relation physique entre le système de vision et la scène acquise) doit être identique pour le calibrage et en cours d'exécution. Si un de ces éléments est modifié, le système doit être recalibré. Il est par conséquent recommandé d'utiliser les mêmes systèmes de vision et objectif pour calibrer et traiter les images obtenues en cours d'exécution. Les paramètres de configuration et de calibrage d'origine du système de vision et de l'objectif doivent également être conservés. Par exemple, toute modification apportée au format d'acquisition (en changeant la résolution) ou tout déplacement du système de vision rend invalide la conversion 2D calculée qui associe les pixels à des coordonnées réelles.

Types de calibrage Échelle X/Y, Transition à transition, Transition à transition X/Y et Cercle

Type de calibrage en 9 points

Calibrage avec une grille

Type de calibrage Importer


Types de calibrage Échelle X/Y, Transition à transition, Transition à transition X/Y et Cercle

Les options de calibrage Échelle X/Y, Transition à transition, Transition à transition X/Y et Cercle s'avèrent utiles dans des applications dans lesquelles vous inspectez une pièce ou un objet dont vous connaissez les mesures réelles.

Remarque : les options de calibrage à l'échelle ne prennent pas en compte la déformation de l'objectif. Pour obtenir le degré de précision le plus élevé possible, vous devez donc vous assurer que le système de vision In-Sight est à angle droit par rapport à la surface inspectée. Si ce n'est pas le cas, vous pouvez utiliser la fonction Calibrage avec une grille pour supprimer la déformation et calibrer votre image de manière plus précise.
Fermé Échelle X/Y

Utilisée lorsque vous connaissez les valeurs d'échelle X et Y pour calculer un calibrage simple.

Remarque : cette option ne prend pas en compte la déformation.
  1. Sélectionnez Échelle X/Y dans le menu déroulant Type de calibrage.
  2. Dans le menu déroulant Unités, sélectionnez les unités réelles (Microns, Millimètres, Centimètres ou Pouces).
  3. Sous Échelle horizontale, saisissez la valeur d'échelle horizontale (0 à 9 999 999)
  4. Sous Échelle verticale, saisissez la valeur d'échelle verticale (0 à 9 999 999)
  5. Le calibrage est appliqué dès que cette option est sélectionnée et que les valeurs sont configurées.
Fermé Transition à transition

Utilisée lorsque vous connaissez la distance entre deux caractéristiques de transition.

  1. Sélectionnez Transition à transition dans le menu déroulant Type de calibrage.
  2. Cliquez sur le bouton Sélectionner les transitions. EasyBuilder examine alors l'image et affiche (en cyan) les Smart Features qu'il a automatiquement détectées.
  3. Commencez par sélectionner une des Smart Features disponibles en cliquant dessus : elle devient rose et est reliée à un trait.

  4. Sélectionnez la seconde Smart Feature.

    Remarque : si les caractéristiques que vous souhaitez utiliser ne sont pas automatiquement détectées par EasyBuilder, décochez la case Smart Features et positionnez la région sur la caractéristique que vous souhaitez définir à la place.
  5. Cliquez sur le bouton OK pour définir vos caractéristiques.
  6. Dans le menu déroulant Unités, sélectionnez les unités réelles (Microns, Millimètres, Centimètres ou Pouces).
  7. Saisissez la mesure réelle connue de la caractéristique dans le champ Dimension.
  8. Cliquez sur le bouton Calibrer pour terminer la procédure de calibrage. Les résultats des outils de recherche et d'inspection s'affichent alors en unités réelles.
Fermé Transition à transition X/Y

Utilisée lorsque vous connaissez la distance entre deux paires de transitions, l'une sur l'axe horizontal et l'autre sur l'axe vertical. Le fait de combiner la mesure et dimension horizontale à la mesure et dimension verticale crée deux échelles indépendantes.

  1. Sélectionnez Transition à transition X/Y dans le menu déroulant Type de calibrage.
  2. Cliquez sur le bouton Définir la mesure horizontale. EasyBuilder examine alors l'image et affiche (en cyan) les Smart Features qu'il a automatiquement détectées.
  3. Commencez par sélectionner une des Smart Features disponibles en cliquant dessus : elle devient rose et est reliée à un trait.

  4. Sélectionnez la seconde Smart Feature.

    Remarque : si les caractéristiques que vous souhaitez utiliser ne sont pas automatiquement détectées par EasyBuilder, décochez la case Smart Features et positionnez la région sur la caractéristique que vous souhaitez définir à la place.
  5. Cliquez sur le bouton OK pour définir vos caractéristiques.
  6. Cliquez sur le bouton Définir la mesure verticale. EasyBuilder examine alors l'image et affiche (en cyan) les Smart Features qu'il a automatiquement détectées.
  7. Commencez par sélectionner une des Smart Features disponibles en cliquant dessus : elle devient rose et est reliée à un trait.
  8. Sélectionnez la seconde Smart Feature.
  9. Cliquez sur le bouton OK pour définir vos caractéristiques.
  10. Dans le menu déroulant Unités, sélectionnez les unités réelles (Microns, Millimètres, Centimètres ou Pouces).
  11. Saisissez la dimension horizontale réelle connue de la caractéristique dans le champ Dimension horizontale.
  12. Saisissez la dimension verticale réelle connue de la caractéristique dans le champ Dimension verticale.
  13. Cliquez sur le bouton Calibrer pour terminer la procédure de calibrage. Les résultats des outils de recherche et d'inspection s'affichent alors en unités réelles.
Fermé Cercle

Utilisée lorsque vous connaissez le diamètre d'une caractéristique circulaire.

  1. Sélectionnez Cercle dans le menu déroulant Type de calibrage.
  2. Cliquez sur le bouton Sélectionner le cercle. EasyBuilder examine alors l'image et affiche (en cyan) les Smart Features qu'il a automatiquement détectées.

  3. Sélectionnez une des Smart Features disponibles en cliquant simplement dessus. Elle devient rose.

    Remarque : si les caractéristiques que vous souhaitez utiliser ne sont pas automatiquement détectées par EasyBuilder, décochez la case Smart Features et positionnez la région sur la caractéristique que vous souhaitez définir à la place.
  4. Cliquez sur le bouton OK pour définir votre caractéristique.
  5. Dans le menu déroulant Unités, sélectionnez les unités réelles (Microns, Millimètres, Centimètres ou Pouces).
  6. Saisissez la mesure réelle connue de la caractéristique dans le champ Dimension.
  7. Cliquez sur le bouton Calibrer pour terminer la procédure de calibrage. Les résultats des outils de recherche et d'inspection s'affichent alors en unités réelles.


Type de calibrage en 9 points

L'option de calibrage en 9 points s'avère utile dans des applications robotiques dans lesquelles vous souhaitez créer l'espace de coordonnées correct pour l'automate. Cette option de calibrage est basée sur une cible circulaire, comme illustré ci-dessous. Idéalement, la plaque de calibrage doit être composée de neuf cibles espacées uniformément, dans une grille de partition. La distance horizontale et verticale entre les cibles doit être connue avant le début de la procédure de calibrage.

Remarque :
  • La cible au centre des neuf cibles est considérée comme l'origine (0,0) dans le système de coordonnées de l'automate.
  • L'espacement entre les cibles horizontales, et entre les cibles verticales, doit être cohérent et identique. Cependant, l'espacement entre les cibles horizontales et verticales ne doit pas nécessairement être identique.
  • Le diamètre du cercle de chaque cible doit faire au moins 25 pixels.
Fermé Exemple - Cible unique

Fermé Exemple - Neuf cibles

Remarque : les coordonnées sont insérées à des fins d'illustration uniquement et ne doivent pas apparaître dans l'image réelle.
Remarque : l'option de calibrage en 9 points ne prend pas en compte la déformation de l'objectif. Pour obtenir le degré de précision le plus élevé possible, vous devez donc vous assurer que le système de vision In-Sight est à angle droit par rapport à la surface inspectée.

Avant de commencer la procédure de calibrage, acquérez une image de la plaque de calibrage qui contient les neuf cibles espacées uniformément.

  1. Sélectionnez En 9 points dans le menu déroulant Type de calibrage.

  2. Cliquez sur le bouton Modifier le modèle et configurez la région de façon à ce qu'elle englobe la cible centrale, puis cliquez sur le bouton OK. Lorsque vous configurez la région autour de la cible, assurez-vous qu'il y a un espace d'au moins 3 à 4 pixels entre la transition extérieure du cercle et la région. Essayez également de centrer le plus possible la région au-dessus de la cible.

    Fermé Exemple

  3. Après avoir configuré le modèle, EasyBuilder détecte automatiquement toutes les cibles dans l'image et affiche une croix verte sur les cibles détectées.

    Remarque : si le point de calibrage de la cible est détecté, mais pas le cercle autour du point de calibrage, une croix rouge est affichée. Pour résoudre le problème, apprenez à nouveau le modèle ou acquérez une nouvelle image.
  4. Dans le menu déroulant Unités, sélectionnez les unités réelles (Microns, Millimètres, Centimètres ou Pouces).
  5. Dans le champ Dimension X, saisissez la mesure réelle de la distance horizontale entre deux cibles de la même ligne (mesurée à partir du centre de chaque cible).
  6. Dans le champ Dimension Y, saisissez la mesure réelle de la distance verticale entre deux cibles de la même colonne (mesurée à partir du centre de chaque cible).
  7. Cliquez sur le bouton Calibrer pour terminer la procédure de calibrage. Les résultats des outils de recherche et d'inspection s'affichent alors en unités réelles.


Calibrage avec une grille

Dans son environnement de déploiement, le système de vision In-Sight peut acquérir des images qui présentent des déformations dues à certaines conditions de configuration, telles que les déformations d'objectif et de perspective. Un objectif peut produire des modèles de déformation radiale en barillet ou en coussinet, selon lesquels des lignes droites dans la réalité apparaissent courbées dans l'image. La déformation de perspective est induite lorsqu'un système de vision In-Sight ne peut pas être monté perpendiculairement à la zone d'inspection. Dans ce cas, les caractéristiques de l'image peuvent sembler étirées ou allongées, selon leur emplacement dans le champ de vue, produisant des résultats imprécis.

L'option Calibrage avec une grille crée une « carte » de la zone de l'image en acquérant une image d'une grille de partition formée de points ou de carrés en damier. Elle associe ensuite les caractéristiques localisées de la grille (points ou intersections de carrés) à l'espacement de la grille de partition défini par l'utilisateur. Ce processus donne lieu à un calcul extrêmement précis, qui peut ensuite être utilisé pour rétablir la forme correcte des caractéristiques déformées.

Le calibrage d'un système de vision In-Sight vous permet de localiser plus précisément des objets aux transitions de l'image et offre une plus grande flexibilité de montage, notamment la possibilité de monter le système de vision In-Sight jusqu'à 45° de la surface d'inspection.

Astuce : si l'application nécessite un calibrage avec une grille, vous pouvez utiliser l'outil de filtre d'image de transformation pour afficher les résultats non déformés et faire en sorte que les autres outils d'inspection se basent sur sa sortie Image d'outil.
  1. Sélectionnez Grille dans le menu déroulant Type de calibrage.
  2. Cliquez sur le bouton Calibrer pour ouvrir la boîte de dialogue CalibrateGrid. Pour des informations complémentaires, consultez le fichier d’aide In‑Sight® Explorer.


Type de calibrage Importer

Le type de calibrage Importer permet de charger un fichier de calibrage créé par un outil de calibrage du point N ou de calibrage du point N séquentiel et exporté vers le système de fichiers local du système de vision In-Sight. Le fichier de calibrage importé calibre automatiquement le projet actuel dès qu'il a été chargé.

Remarque : avant de sélectionner Importer comme Type de calibrage, ajoutez et configurez un outil de calibrage du point N ou de calibrage du point N séquentiel, puis exportez le fichier de calibrage vers le système de fichiers local du système de vision In-Sight.

Les outils de calibrage du point N et du point N séquentiel créent une conversion en 2D entre un système de coordonnées de pixels et un système de coordonnées réelles. Au cours de ce processus, les outils prennent en compte la déformation linéaire et non linéaire et offrent un plus haut niveau de précision que les méthodes de calibrage Échelle X/Y, Transition à transition, Transition à transition X/Y ou Cercle lorsque cinq paires de points ou plus sont utilisées. Ils effectuent les conversions suivantes :

  • la translation en deux dimensions (en utilisant au moins deux paires de points) ;
  • la rotation autour de trois axes (en utilisant au moins quatre paires de points) ;
  • l'échelle en deux dimensions (en utilisant au moins deux paires de points) ;
  • la distorsion de perspective (en utilisant au moins quatre paires de points) ;
  • la torsion ou le parallélogramme (en utilisant au moins quatre paires de points).
Fermé Importer
  1. Sélectionnez Importer dans le menu déroulant Type de calibrage.
  2. EasyBuilder recherche automatiquement les fichiers de calibrage éventuellement créés par un outil de calibrage du point N ou de calibrage du point N séquentiel dans le projet et en charge un. Si vous avez créé plusieurs fichiers de calibrage, sélectionnez celui de votre choix dans le menu déroulant Nom du fichier.
  3. Dans le menu déroulant Unités, sélectionnez les unités de mesure réelles qui définissent le calibrage : Microns, Millimètres (par défaut), Centimètres ou Pouces.
  4. Le calibrage est appliqué dès que cette option est sélectionnée et que les valeurs sont configurées.


Localiser pièce

Les outils de recherche servent à définir une caractéristique dans l'image qui fournit des données de position. Les outils de recherche créent un repère qui est utilisé pour localiser rapidement et de manière fiable une pièce dans l'image, même si la pièce inspectée tourne ou apparaît à différents emplacements de l'image. Pour plus d'informations, consultez Repère.

Remarque :
  • Si votre projet ne requiert pas de données de position, ou si votre pièce sera présentée au capteur In-Sight au même emplacement dans toutes les images, reportez-vous à Inspecter une pièce.
  • Les capteurs de vision In-Sight 2000-110 et 120/120C ne vous permettent d'ajouter qu'un seul repère dans un projet.
  • l'onglet Liens n'est pas pris en charge par les capteurs de vision In-Sight série 2000.

Les outils de recherche renvoient les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000-110 et 2000-120/120C | État Succès/Échec uniquement
Capteur de vision In-Sight 2000-130/130C | Outil de recherche de modèle : État Réussite/Échec et score de modèle Autres outils de recherche : État Succès/Échec uniquement
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Résultats standard (Données de position et état succès/échec). L'outil renvoie les résultats en pixels, sauf si l'image a été calibrée en unités réelles dans Configurer l'image.

Ajout, suppression et modification d’outils de recherche

Sélection d’un outil de recherche

Créer des liens entre les outils de recherche et d’inspection


Ajout, suppression et modification d'outils de recherche

Fermé Ajout d'un outil

Pour ajouter un outil à votre projet, sélectionnez l'outil voulu dans le groupe Ajouter un outil, puis cliquez sur Ajouter ou double-cliquez sur l'outil. Définissez ensuite la caractéristique dans l'image. Vous pouvez pour cela sélectionner des Smart Features EasyBuilder, ajuster les graphiques de région dans l'image ou positionner des graphiques de référence géométriques.

Une fois la caractéristique définie, vous pouvez régler les contrôles de l'outil en ajustant les différents paramètres.

Remarque : Vous pouvez rechercher des outils de manière dynamique à l'aide de la zone de recherche d'outils.
Fermé Suppression d'un outil

Pour supprimer un outil de votre projet, effectuez simplement l'une des opérations suivantes :

  • Sélectionnez l'outil dans le tableau de résultats (situé sous l'onglet Résultats de la palette) et appuyez sur la touche Suppr de votre clavier.
  • Sélectionnez l'outil dans le tableau de résultats (situé sous l'onglet Résultats de la palette) et cliquez sur l'icône Supprimer de la barre d'outils Standard.
  • Cliquez avec le bouton droit sur l'outil dans le tableau de résultats (situé sous l'onglet Résultats de la palette) et sélectionnez l'option Supprimer dans le menu.
Fermé Modification d'un outil

Pour modifier un outil dans une étape d'EasyBuilder, effectuez simplement l'une des opérations suivantes :

  • Double-cliquez sur l'outil dans le tableau de résultats (situé sous l'onglet Résultats de la palette).
  • Cliquez avec le bouton droit sur l'outil dans le tableau de résultats , puis sélectionnez l'option Afficher et modifier cet outil dans le menu.

Pour modifier un outil dans les étapes Localiser la pièce ou Inspecter une pièce, effectuez simplement l'une des opérations suivantes :

  • Sélectionnez le graphique de région de l'outil dans l'image.
  • Double-cliquez sur l'outil dans le tableau de résultats (situé sous l'onglet Résultats de la palette).
  • Cliquez avec le bouton droit sur l'outil dans le tableau de résultats, puis sélectionnez l'option Afficher et modifier cet outil dans le menu.
  • Double-cliquez sur l'outil dans le tableau de résultats dans l'étape d'application Exécuter le projet.
Remarque :
  • Si votre système de vision In-Sight permet d'accéder à l'environnement de programmation du tableur d'In-Sight Explorer, l'option Afficher cet outil dans le tableur apparaît dans le menu contextuel. N'accédez à l'environnement de programmation du tableur que si vous le connaissez et en comprenez le fonctionnement. Reportez-vous à la rubrique EasyBuilder Jobs and the Spreadsheet (Projets EasyBuilder et le tableur) du fichier d'aide en ligne d'In-Sight Explorer avant de procéder.
  • Les outils peuvent être réorganisés dans le tableau de résultats en les glissant-déposant dans l'ordre souhaité. Cela peut être fait dans le tableau de résultats de l'étape Exécuter le projet comme dans le tableau sous l'onglet Résultats de la palette, et met à jour les deux tableaux. Le tri par glisser-déposer n'est activé que lorsque la colonne Ordre et graphiques de dépendances des outils du tableau est sélectionnée (cette colonne est sélectionnée par défaut). Sélectionnez une nouvelle fois la colonne pour inverser l'ordre. La liste ne peut plus être réorganisée si la limite de taille du projet est proche ou a été atteinte.
Remarque : S'il n'y a pas suffisamment d'espace dans le projet pour ajouter des outils, quittez les étapes d'application Localiser la pièce ou Inspecter la pièce et sélectionnez Limite de la taille du projet, dans le menu Capteur. Dans la boîte de dialogue, réglez la taille du projet afin de pouvoir ajouter davantage d'outils. Le réglage de la limite de taille du projet d'un système de vision In-Sight nécessite le redémarrage du système de vision et entraîne la suppression de l'ensemble des fichiers de projets et de paramètres de la mémoire flash non volatile. Enregistrez ou sauvegardez le projet avant de poursuivre.

Fonctions

Régions

Repère


Caractéristiques

Dans le domaine de la vision industrielle, les caractéristiques sont également appelées « objets d'intérêt de l'image » et les inspections sont conçues en fonction des types de caractéristiques localisées dans l'image.

Types de caractéristiques détectées dans l'étape Localiser la pièce :

Fermé Transitions

Zones limitrophes linéaires entre des pixels sombres et clairs. Les transitions peuvent correspondre aux extrémités d'une pièce, aux broches d'un circuit imprimé ou aux filets d'une vis. Les transitions comptent parmi les caractéristiques les plus rapides à détecter au cours d'une inspection. Mais si elles sont utilisées comme repère, elles doivent se déplacer dans une seule direction (horizontale ou verticale) et présenter un contraste élevé.

Fermé Exemple de transition repère

Dans cet exemple, les applicateurs des purificateurs d'air n'apparaissent pas au même emplacement sur chaque image. Ils apparaissent dans le même plan vertical, mais se déplacent horizontalement. Deux outils de recherche de transition sont utilisés comme repères : celui de gauche recherche la transition extérieure de la partie inférieure du capuchon de l'applicateur et oriente les régions des autres outils d'inspection du côté gauche ; celui de droite oriente les outils du côté droit.

Fermé Cercles

Les cercles sont en fait des transitions, c'est-à-dire des zones délimitées par une frontière entre pixels clairs et sombres qui définit leur forme géométrique. Ils comptent aussi parmi les caractéristiques rapidement reconnaissables, à condition toutefois de présenter un contraste élevé. Mais ils ne fournissent aucune donnée d'orientation angulaire lorsqu'ils sont utilisés comme repère.

Fermé Exemple de cercle repère

Dans cet exemple, deux repères sont utilisés. Le premier (un outil de recherche de blob) recherche l'extérieur du tuyau, et le deuxième (un outil de recherche de cercle) recherche la forme circulaire de base du tuyau dans le blob localisé. Du fait des contraintes de l'application, la longueur des vis est déterminée en mesurant leur distance à partir d'un point par rapport à une forme localisée (qui doit être uniforme).

Fermé Modèles

Un modèle peut incarner différents éléments, depuis un simple groupe de formes répétitives à des configurations complexes telles que des logos ou des étiquettes. Il s'agit du type de caractéristique le plus fiable à utiliser comme repère. Les modèles offrent la plus vaste plage de variations en termes de rotation, de déplacement et d'échelle, mais leur inspection demande généralement beaucoup de temps.

Fermé Exemple de modèle repère

Dans cet exemple, le code 2D est placé et orienté différemment dans chaque image. Un outil de recherche de modèles PatMax est utilisé pour créer un repère et mieux cibler la recherche de l'outil d'identification Lire les codes ID. L'outil de recherche de modèles PatMax est utilisé pour sa capacité à localiser des formes complexes tout en reconnaissant une grande variété d'emplacements, d'orientations et d'échelles.

Fermé Blobs

Groupe de pixels sombres ou clairs connectés, tel qu'une tâche de peinture blanche sur un arrière-plan noir ou une vis noire sur un convoyeur blanc. Les blobs se situent entre les transitions et les modèles en termes de rapidité de détection. Ils incluent des formes et des tailles plus diverses qu'un modèle mais disposent d'une valeur d'orientation angulaire limitée lorsqu'ils sont utilisés comme repère.

Fermé Exemple de blob repère

Dans cet exemple, deux repères sont utilisés. Les caractéristiques inspectées (les vis) se trouvent en effet dans un objet (le tuyau) dont l'orientation et l'emplacement vertical et horizontal peuvent varier d'une image à l'autre. Les brides du tuyau créant une forme irrégulière, un outil de recherche de blob est utilisé pour définir un repère qui localise le tuyau dans le champ de vue.


Régions

Les régions définissent la zone de l'image dans laquelle l'outil de recherche ou d'inspection exécute son opération, aussi appelée « région d'intérêt ».

Différents types de régions sont utilisées par les outils de recherche et d'inspection dans EasyBuilder, selon le type d'outil utilisé, notamment :

  • Rectangle
  • Cercle
  • Anneau
  • Polygone

Régions annulaires

Régions circulaires

Régions polygonales

Régions rectangulaires


Régions annulaires

Les régions annulaires sont utilisées pour définir des caractéristiques de transition circulaires. La région annulaire comprend un rayon intérieur et extérieur, permettant de définir une caractéristique de transition circulaire tout en ignorant le centre du cercle.

Fermé Actions de la souris dans les régions annulaires

 | Contrôles | Description
1 | Déplacement | En plaçant le curseur de la souris entre les rayons intérieur et extérieur, son icône change automatiquement de forme, permettant de faire glisser la région n'importe où dans l'image.
2 | Changement de taille | En plaçant le curseur de la souris sur le rayon intérieur ou extérieur de la région annulaire, son icône change automatiquement de forme, permettant de faire glisser le rayon intérieur ou extérieur pour le redimensionner (les rayons intérieur et extérieur doivent être redimensionnés indépendamment l'un de l'autre).
Fermé Sens de balayage des régions circulaires

Les régions circulaires recherchent des caractéristiques circulaires du rayon intérieur au rayon extérieur.

Fermé Codes couleurs des régions annulaires

 | Description
1 | Région annulaire récemment ajoutée désélectionnée.
2 | Région annulaire sélectionnée non confirmée.
3 | Région annulaire sélectionnée, configurée et de succès.
4 | Région annulaire désélectionnée, configurée et de succès.
5 | Région annulaire sélectionnée, configurée et d'échec.
6 | Région annulaire désélectionnée, configurée et d'échec.


Régions circulaires

Les régions circulaires sont utilisées pour définir des caractéristiques circulaires. La région circulaire acquiert tout ce qui se trouve à l'intérieur du cercle. Pour définir une caractéristique circulaire tout en ignorant le centre du cercle, utilisez une région annulaire.

Fermé Actions de la souris dans les régions circulaires

 | Contrôles | Description
1 | Déplacement | En plaçant le curseur de la souris dans la région, son icône change automatiquement de forme, permettant de faire glisser la région n'importe où dans l'image.
2 | Changement de taille | En plaçant le curseur de la souris sur la limite de la région circulaire, son icône change automatiquement de forme, permettant de faire glisser la région pour la redimensionner.
Fermé Sens de balayage des régions circulaires

Les régions circulaires recherchent des caractéristiques du centre du cercle au rayon extérieur.

Fermé Codes couleurs des régions circulaires

 | Description
1 | Région circulaire récemment ajoutée désélectionnée.
2 | Région circulaire sélectionnée non confirmée.
3 | Région circulaire sélectionnée, configurée et de succès.
4 | Région circulaire désélectionnée, configurée et de succès.
5 | Région circulaire sélectionnée, configurée et d'échec.
6 | Région circulaire désélectionnée, configurée et d'échec.


Régions polygonales

Les régions polygonales sont utilisées pour définir des caractéristiques irrégulières en créant une forme sortant des segments linéaires. Configurez la région polygonale dans la forme de votre choix.

Fermé Légende des régions polygonales

 | Contrôles | Description
1 | Limite de point de terminaison redimensionnable | Définit les trois points de terminaison initiaux de la région polygonale (100 points au maximum peuvent être créés pour une région polygonale). Cliquez sur une limite de point de terminaison pour redimensionner la région à partir de l'un de ses coins.
2 | Contrôle de rotation | Permet de faire pivoter la région de 360°.
Fermé Actions de la souris dans les régions polygonales

En plaçant le curseur de la souris sur diverses parties de la région, son icône change automatiquement de forme, permettant les actions suivantes :

Icône du curseur | Description
 | Permet de faire glisser la région polygonale complète n'importe où dans l'image.
 | Permet de définir l'échelle de la région complète horizontalement ou verticalement.
 | Permet de faire pivoter la région complète de 360° par rapport à son orientation actuelle.
 | Permet de déplacer un des points de la limite de point de terminaison redimensionnable de la région polygonale.
 | Permet d'ajouter un point de limite de point de terminaison redimensionnable dans la région polygonale.
Fermé Sens de balayage des régions polygonales

 | Contrôles | Description
1 | Haut | Indique un sens de balayage sur l'axe horizontal.
2 | Côté | Indique un sens de balayage sur l'axe vertical.
Fermé Codes couleurs des régions polygonales

 | Description
1 | Région polygonale récemment ajoutée désélectionnée.
2 | Région polygonale sélectionnée non confirmée.
3 | Région polygonale sélectionnée, configurée et de succès.
4 | Région polygonale désélectionnée, configurée et de succès.
5 | Région polygonale sélectionnée, configurée et d'échec.
6 | Région polygonale désélectionnée, configurée et d'échec.


Régions rectangulaires

Les régions rectangulaires sont les plus utilisées pour définir une inspection. Elles peuvent être redimensionnées en arcs de cercle ou en régions annulaires pour mieux répondre aux besoins de votre application spécifique.

Fermé Légende des régions rectangulaires

 | Contrôles | Description
1 | Limite de point de terminaison redimensionnable (x4) | Définit les quatre coins de la région rectangulaire. Cliquez sur une limite de point de terminaison pour redimensionner la région à partir de l'un de ses coins.
2 | Indicateur de sens de balayage (x2) | Définit le sens dans lequel la région rectangulaire recherche les caractéristiques.
3 | Contrôle de courbure | Permet de courber la région rectangulaire en arc de cercle ou dans une forme circulaire.
4 | Contrôle de rotation | Permet de faire pivoter la région de 360°.
Fermé Actions du curseur dans la région rectangulaire

 | Contrôles | Description
1 | Déplacer | En plaçant le curseur dans la région concernée, l'icône du curseur se transforme automatiquement, ce qui vous permet de faire glisser la région n'importe où dans l'image.
2 | Courber | En plaçant le curseur sur la Poignée de courbure, l'icône du curseur se transforme automatiquement, ce qui vous permet de redéfinir la région rectangulaire dans une forme en arc ou en anneau. Les quatre côtés de la forme peuvent alors être redimensionnés de façon circulaire, par exemple.
3 | Redimensionner | En plaçant le curseur sur l'une des quatre extrémités, ou le long d'un des côtés, l'icône du curseur se transforme automatiquement, ce qui vous permet de faire glisser la région pour la redimensionner.
4 | Effectuer une rotation | En plaçant le curseur sur la Poignée de courbure, l'icône du curseur se transforme automatiquement, ce qui vous permet de faire pivoter la région à 360° par rapport à sa situation actuelle.
Fermé Sens de balayage des régions rectangulaires

 | Contrôles | Description
1 | Haut | Indique un sens de balayage sur l'axe horizontal.
2 | Côté | Indique un sens de balayage sur l'axe vertical.
Fermé Codes couleurs des régions rectangulaires

 | Description
1 | Région rectangulaire récemment ajoutée désélectionnée.
2 | Région rectangulaire sélectionnée non confirmée.
3 | Région rectangulaire sélectionnée, configurée et de succès.
4 | Région rectangulaire désélectionnée, configurée et de succès.
5 | Région rectangulaire sélectionnée, configurée et d'échec.
6 | Région rectangulaire désélectionnée, configurée et d'échec.


Repère

Les outils de recherche disponibles à l'étape Localiser la pièce créent une sortie appelée repère, qui sert de point de référence à d'autres outils d'inspection de vision.

Pour créer un repère, observez la pièce sur l'image et déterminez le type de caractéristique (modèle, transition, cercle ou blob) le plus facilement et le plus rapidement reconnaissable et qui apparaît sur toutes les images de la pièce. Sélectionnez ensuite un outil de recherche correspondant au type de caractéristique présente sur la pièce pour définir la caractéristique.

Lorsqu'une caractéristique est utilisée comme repère au cours d'une inspection, le capteur In-Sight commence par rechercher la caractéristique. Lorsqu'il l'a localisée, sa position est utilisée comme point de référence par les autres outils d'inspection de vision qui l'utilisent pour positionner leurs régions.

Fermé Exemple - Projet avec repère Modèle

Fermé Exemple - Projet sans repère Modèle

Remarque :
  • L'utilisation d'un repère est inutile si la pièce est présentée au capteur In-Sight au même emplacement sur chaque image.
  • Vous pouvez créer et utiliser plusieurs repères dans un projet. Différents repères peuvent également être liés entre eux.
  • Les outils d'inspection suivants créent une sortie de repère qui peut être utilisée par d'autres outils : outil de présence/absence de transition, outil de présence/absence de modèle PatMax, outil de présence/absence de modèle, outil d'identification Lire les codes ID, outil d'identification de modèles PatMax, outil d'identification de forme, outil de mesure d'angle, outil de mesure de distance, outil de mesure de concentricité de cercle, outil de mesure de diamètre, outil géométrique de définition de point médian de deux points et outil géométrique de définition de cercle à partir de N points.


Sélection d'un outil de recherche

Examinez votre pièce et déterminez le type de caractéristique (ou caractéristiques) le mieux adapté à votre application.

Outils de recherche | Systèmes de vision In-Sight (micrologiciel 5.x.x) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Modèle PatMax RedLine 1 | X |  |  |  |  |
Modèle PatMax® | X |  |  |  |  |
Modèle | X | X | X | X | X | X
Modèles PatMax RedLine™ (1-10) 1 | X |  |  |  |  |
Modèles PatMax® (1-10) | X |  |  |  |  |
Modèles (1-10) | X |  |  |  | X |
Transition | X |  |  | X | X | X
Intersection de transition | X |  |  | X | X | X
Blob 2 | X |  |  |  | X |
Blobs (1-10) 2 | X |  |  |  | X |
Blob de couleur 3 | X |  |  |  | X |
Blobs de couleur (1-10) 3 | X |  |  |  | X |
Cercle | X |  |  | X | X | X
Calcul du repère | X |  |  |  |  | X
1Micrologiciel In-Sight 5.x.x uniquement. 2Modèles monochromes uniquement. 3Modèles de couleurs uniquement.

Modèle PatMax RedLine, modèle PatMax, modèles PatMax RedLine (1-10) et modèles PatMax (1-10)

Modèle et modèles (1-10)

Transition

Intersection de transition

Blob et blobs (1-10)

Blob de couleur et Blobs de couleur (1-10)

Circle

Calcul du repère


Outils d'identification - Modèle PatMax RedLine, modèle PatMax, modèles PatMax RedLine (1-10) et modèles PatMax (1-10)

Remarque :
  • À partir du micrologiciel In-Sight firmware 5.5.0 et versions ultérieures, l'algorithme de l'outil a été modifié afin de renvoyer des résultats plus précis et de réduire la durée d'exécution dans certains cas.
  • En raison de cette modification, un message d'erreur s'affiche lors d'une tentative de chargement d'un projet contenant cet outil configuré selon le micrologiciel In-Sight version 5.5.0 ou ultérieure sur un système de vision In-Sight exécutant le micrologiciel In-Sight version 5.4.x ou antérieure.
  • L'outil de recherche de modèle PatMax RedLine et l'outil de recherche de modèles PatMax RedLine (1-10) sont uniquement disponibles sur des systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.2.0 et ultérieures.

L'outil d'identification de modèle PatMax RedLine, l'outil d'identification de modèle PatMax, l'outil d'identification de modèles PatMax RedLine (1-10) et l'outil d'identification de modèles PatMax (1-10) permettent d'identifier la position des caractéristiques de modèle, à l'aide de l'algorithme PatMax RedLine ou PatMax, en fonction d'une représentation apprise de ce modèle (appelée un Modèle). Les outils Modèle PatMax RedLine et Modèle PatMax permettent d'identifier un modèle unique, alors que les outils Modèles PatMax RedLine (1-10) et Modèles PatMax (1-10) permettent d'identifier un maximum de 10 modèles.

Remarque : L'outil reporte les coordonnées X,Y en pixels, sauf si l'image a été calibrée en unités réelles dans Configurer l'image.

Ces outils sont utiles dans des applications nécessitant un positionnement précis, par exemple des applications robotiques guidées par vision. Ces outils sont également très utiles comme Repère pour d'autres outils de vision, orientant leur recherche dans l'image.

Configuration des outils

Réglage des paramètres de l’outil


Configuration des outils d'identification de modèle PatMax RedLine, modèle PatMax, modèles PatMax RedLine (1-10) et modèles PatMax (1-10)

Après avoir ajouté l'outil, sélectionnez le type des régions et configurer ces dernières pour définir votre modèle (la région Modèle) et l'emplacement du modèle dans l'image (la région Recherche).

  1. Dans le menu déroulant Modèle, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Placez ensuite la région de Modèle sur le modèle utilisé comme modèle d'apprentissage ; assurez-vous que la région de Modèle ne couvre que les caractéristiques importantes du modèle.Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Dans le menu déroulant Recherche, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Puis positionnez la région Recherche de manière à ce qu'elle recouvre les zones de l'image dans lesquelles la forme peut apparaître. Pour optimiser l'exécution de l'outil, créez des régions Recherche de petite taille. Plus la région Recherche est étendue, plus l'outil mettra de temps à effectuer l'inspection.

  3. Cliquez sur le bouton OK pour confirmer les régions (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  4. La région de Modèle sera remplacée par l'icône [image], indiquant l'emplacement et l'orientation angulaire du modèle identifié.
  5. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  6. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Sélection d’un modèle

Modèles PatMax RedLine, modèles PatMax et modèles


Sélection d'un modèle

Lorsque vous choisissez un modèle pour une inspection, tenez compte des instructions suivantes pour garantir des résultats optimaux :

  • Le même modèle doit être présent dans toutes les images.
  • Le modèle doit contenir un nombre aussi élevé que possible de caractéristiques uniques, présentes dans chaque image. L'aspect des caractéristiques constituant le modèle et leur position les unes par rapport aux autres doivent par ailleurs être cohérents. Les caractéristiques doivent également être clairement définies.
  • Choisissez si possible un grand modèle. Les grands modèles contiennent généralement davantage de caractéristiques uniques, ce qui permet une détection plus cohérente et plus précise.


Modèles PatMax RedLine, modèles PatMax et modèles

Remarque : L'outil de recherche de modèle PatMax RedLine et l'outil de recherche de modèles PatMax RedLine (1-10) sont uniquement disponibles sur des systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.2.0 et ultérieures.

Les modèles PatMax RedLine, les modèles PatMax et les modèles localisent des modèles de forme appris et proposent la plus grande précision parmi les outils de recherche et d'inspection. Cependant les modèles de PatMax RedLine et les modèles de PatMax sont plus performants que les modèles, modifiant considérablement les conditions d'éclairage et la position du modèle. Ils permettent également de mieux reconnaître les modifications apportées à l'échelle et à la rotation du modèle, l'occlusion des éléments du modèle et les modifications apportées à l'apparence du modèle, en raison des variations d'éclairage.

La vitesse constitue la principale différence entre les modèles PatMax RedLine et les modèles PatMax ; le modèle PatMax RedLine utilise le modèle le plus récent correspondant à l'algorithme et permet de localiser des caractéristiques apprises dans une image mégapixel 5, 7 fois plus rapidement que les modèles PatMax. Les modèles PatMax RedLine conviennent donc pour des systèmes de vision de haute résolution.

Les modèles (dans la plupart des cas) sont plus rapides que PatMax, mais certains cas nécessitent la précision et la fiabilité de la version PatMax RedLine ou PatMax :

  • Lorsque les variations d'éclairage et de reflets sont difficiles à contrôler. Par exemple, des pièces en métal peuvent réfléchir la lumière dans des directions aléatoires.
  • Lorsque le modèle inspecté présente une forme ou une ombre similaire par rapport à un élément en arrière-plan, ou le modèle est superposé ou partiellement caché par d'autres objets dans l'image.
  • Lorsque vous souhaitez reconnaître avec précision un type de modèle parmi d'autres modèles, des modèles identiques.
  • Lorsque les conditions de votre environnement de déploiement sont trop exigeantes pour l'outil Modèle, en termes de cohérence et de fiabilité.


Réglage des paramètres des outils d'identification de modèle PatMax RedLine, modèle PatMax, modèles PatMax RedLine (1-10) et modèles PatMax (1-10)

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres des outils d'identification de Modèle PatMax RedLine, Modèle PatMax, Modèles PatMax RedLine (1-10) et Modèles PatMax (1-10) comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglets Modèle et Recherche
  • Onglet Image d'apprentissage
  • Onglet Tableau
Remarque : L'onglet Table est uniquement activé pour les outils d'identification Modèles PatMax RedLine (1-10) et Modèles PatMax Patterns (1-10).
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglets Modèle et Recherche

Onglet Image d’apprentissage

Onglet Tableau


Outil d'identification de modèle PatMax RedLine, modèle PatMax, modèles PatMax RedLine (1-10) et modèles PatMax (1-10) - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Modèle_1 » s'il s'agit du premier outil de modèle ajouté au projet. Sinon, il est incrémenté (par exemple, « Modèle_2 », « Modèle_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outils d'identification de modèle PatMax RedLine, modèle PatMax, modèles PatMax RedLine (1-10) et modèles PatMax (1-10) - Onglet Paramètres

Fermé Nombre à chercher

Définit le nombre d'instances du modèle de forme à détecter (1 à 10 ; valeur par défaut = 1). La plupart des applications ne nécessitent qu'un seul repère. Plusieurs instances du modèle de forme peuvent toutefois être localisées, ce qui s'avère utile dans des applications dans lesquelles l'image comporte plusieurs pièces ou objets. Plus l'outil doit identifier d'instances apprises, plus sa durée d'exécution est importante.

Fermé Seuil d'acceptation

Définit le degré de similitude qui doit exister entre le modèle de forme et le modèle localisé (0 à 100 ; valeur par défaut = 50). Les modèles localisés affichant une valeur supérieure ou égale au seuil défini sont considérés comme correspondants. Cet outil s'exécute plus rapidement lorsque ce paramètre est élevé, ce qui requiert également un degré de similitude plus important entre le modèle de forme et le modèle localisé. Moins les paramètres sont élevés, moins les résultats seront précis. Des modèles semblables seront détectés, mais pas par rapport au modèle de forme.

Fermé Seuil de contraste

Définit le contraste minimum acceptable qui doit être défini dans le modèle identifié ; le contraste pour un modèle identifié doit être supérieur à la valeur Seuil de contraste à considérer comme une instance valide. La valeur par défaut pour le(s) modèle(s) PatMax RedLine est 0 et la plage valide de paramètres est 0-100. La valeur par défaut pour le(s) modèle(s) PatMax est 10 et la plage valide de paramètres est 0-255. Une faible valeur Seuil de contraste est utilisée pour des images peu contrastées, alors qu'une valeur élevée Seuil de contraste est utilisée pour des images extrêmement contrastées.

Remarque : Le contraste de modèle(s) PatMax RedLine désigne la mesure « relative » d'une modification de contraste entre les caractéristiques du modèle appris et les caractéristiques de correspondance de l'image de recherche, en pourcentage. Ainsi si le contraste de caractéristique est supérieur ou égal au contraste de modèle, le contraste rapporté sera ~100. Si le contraste de caractéristique est inférieur au contraste de modèle, le contraste rapporté sera <100. Le contraste de modèle(s) PatMax RedLine est différent du contraste de modèle(s) PatMax qui représente le contraste d'image « absolu » de la région d'intérêt de recherche, en niveau de gris
Fermé Tolérance angulaire

Définit dans quelle mesure le modèle localisé peut pivoter par rapport à la position du modèle de forme, tout en étant identifié comme un modèle valide (± 0 à 180° ; valeur par défaut = 15°). Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps.

Fermé Tolérance en échelle

Définit le pourcentage autorisé de mise à l'échelle (variations de taille) entre le modèle identifié et le modèle de forme (0-50 ; par défaut = 0). La valeur représente un pourcentage plus ou moins, par exemple une valeur 5 déclenchera l'outil de recherche de modèles dont la taille est comprise entre 95 % et 105% du modèle de forme. Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps.

Fermé Mode de recherche

Définit le mode de recherche utilisé pour les modèles d'apprentissage et de reconnaissance, PatMax ou PatQuick. L'option PatMax est sélectionnée par défaut. PatMax propose une plus grande précision que PatQuick mais nécessite un temps d'exécution plus long alors que PatQuick propose une plus faible précision que PatMax mais nécessite un temps d'exécution moins long.

Fermé Score strict

Définit si des caractéristique manquantes ou cachées du modèle trouvé affecteront le score (par défaut = désactivé, décoché). Lorsque Score strict est appliqué (Activé, coché), si les caractéristiques du modèle sont absentes ou bloquées, le score du modèle trouvé sera plus faible.

Fermé Ignorer la polarité

Définit si des modèles localisés peuvent ou non contenir des caractéristiques de correspondance avec inversion des couleurs par rapport au modèle de forme (option désactivée par défaut). Lorsque le paramètre Ignorer la polarité est appliqué (option cochée), les modèles détectés avec des caractéristiques d'inversion des couleurs, comme noir/blanc et blanc/noir dans le modèle de forme, par exemple, sont considérés comme correspondants au modèle de forme.

Fermé Trier par

Définit comment les modèles localisés sont triés, Score (valeur par défaut), X ou Y. Lorsque Score est sélectionné, les modèles localisés sont triés en fonction de leur score, par ordre décroissant, le modèle au score le plus élevé apparaissant en tête de liste. Lorsque X est sélectionné, les modèles localisés sont triés en fonction de leur distance par rapport à l'axe X, par ordre décroissant, du plus proche au plus éloigné. Lorsque Y est sélectionné, les modèles localisés sont triés en fonction de leur distance par rapport à l'axe Y, par ordre décroissant, du plus proche au plus éloigné.

Fermé Offset horizontal

Définit une position décalée sur l'axe horizontal (mesurée en pixels) à partir du centre du modèle localisé par rapport au modèle de forme appris. Cela permet d'affecter des coordonnées distantes du centre du modèle de forme, ce qui s'avère utile lors de la définition d'un point de sélection dans les applications robotiques guidées par vision.

Fermé Offset vertical

Définit une position décalée sur l'axe vertical (mesurée en pixels) à partir du centre du modèle localisé par rapport au modèle de forme appris. Cela permet d'affecter des coordonnées distantes du centre du modèle de forme, ce qui s'avère utile lors de la définition d'un point de sélection dans les applications robotiques guidées par vision.

Fermé Délai d'attente
Définit la durée, en millisecondes (0 à 30 000), pendant laquelle l'outil recherche le(s) modèle(s) avant que l'exécution ne soit interrompue et que l'outil ne renvoie un échec. Par défaut, ce paramètre est activé sur 5000.
Fermé Résultat

Affiche les coordonnées X,Y du centre du modèle localisé et son orientation angulaire, ainsi que son score par rapport au modèle de forme. Si un offset horizontal ou vertical a été appliqué, les coordonnées X,Y sont ajustées conformément à la valeur spécifiée dans les champs d'offset.

Remarque : si le paramètre Nombre à chercher est supérieur à 1 et que le paramètre Trier par n'est pas défini sur X ou Y, le résultat affiché correspondra toujours au modèle localisé au score le plus élevé.
Remarque :
  • Les outils d'identification de modèle PatMax RedLine et modèles PatMax RedLine (1-10) ne doivent pas contenir le paramètre Mode de recherche.
  • Les paramètres Nombre à chercher et Trier par sont uniquement pris en charge par les outils d'identification de modèles PatMax RedLine (1-10) et modèles PatMax (1-10) .


Outils d'identification de modèle PatMax RedLine, modèle PatMax, modèles PatMax RedLine (1-10) et modèles PatMax (1-10) - Onglets Modèle et Recherche

Les onglets Modèle et Recherche sont utilisés pour configurer la région composite pour les régions Modèle et Recherche de l'outil. Les régions composite sont un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Dans l'onglet Modèle, les régions composite sont activées uniquement après avoir cliqué sur le bouton Région modèle.
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils d'identification de modèle PatMax RedLine, modèle PatMax, modèles PatMax RedLine (1-10) et modèles PatMax (1-10) - Onglet Image d'apprentissage

L'image affichée sous l'onglet Image d'apprentissage est une miniature du modèle de forme. Cliquez sur le bouton Région du modèle pour redimensionner ou déplacer la région, puis sur le bouton Apprendre pour apprendre à nouveau le modèle de forme.


Outils d'identification de modèles PatMax RedLine (1-10) et de modèles PatMax (1-10) - Onglet Tableau

Le tableau créé dans l'onglet Tableau publie les résultats des modèles identifiés :

Fermé Index

Désigne l'ordre des modèles identifiés ; 1 à 10 (l'ordre numérique dans EasyBuilder est basé sur 0=1).

Fermé X

Désigne le centre de la coordonnée X identifiée du modèle. Si un offset horizontal a été appliqué, la coordonnée X sera ajustée conformément à la valeur spécifiée.

Fermé Y

Désigne le centre de la coordonnée Y identifiée du modèle. Si un offset vertical a été appliqué, la coordonnée Y sera ajustée conformément à la valeur spécifiée.

Fermé Angle

Désigne l'angle du modèle identifié par rapport au modèle de forme.

Fermé Score

Désigne le degré de similitude entre le modèle identifié et le modèle de forme.

Fermé Échelle

Désigne l'échelle du modèle identifié.


Outils de recherche - Modèle et Modèles (1-10)

L'outil de recherche de modèle et l'outil de recherche de modèles (1-10) permettent de rechercher la position des caractéristiques de modèle, en fonction d'une représentation apprise de ce modèle (appelée un Modèle). L'outil Modèle permet de rechercher un modèle unique, alors que l'outil Modèles (1-10) permet de rechercher 10 modèles au maximum.

L'outil de recherche de modèle et l'outil de recherche de modèles (1-10) sont utiles dans des applications nécessitant un positionnement précis, par exemple des applications robotiques guidées par vision. Ces outils sont également très utiles comme Repères pour d'autres outils de vision, orientant leur recherche dans l'image.

Astuce :
  • Pour plus d'informations sur la sélection d'un outil de recherche de modèle, consultez Sélection d'un modèle.
  • Pour plus d'informations les outils de recherche de modèle, consultez Modèles PatMax RedLine, modèles PatMax et modèles.

L'outil renvoie les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000-110 et 2000-120/120C | État Succès/Échec uniquement
Capteur de vision In-Sight 2000-130/130C | État Réussite/Échec et score de modèle
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | coordonnées X/Y*, orientation angulaire, score et état succès/échec
* L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration des outils

Réglage des paramètres des outils


Configuration des outils de recherche de modèle et de modèles (1-10)

Après avoir ajouté l'outil, configurez les régions de l'image définissant votre modèle (la région Modèle) et l'emplacement du modèle dans l'image (la région Recherche).

  1. Positionnez la région Modèle sur le modèle qui sera utilisé comme forme d'apprentissage. Assurez-vous que la région Modèle recouvre uniquement les caractéristiques importantes du modèle.

  2. Positionnez la région Recherche de manière à ce qu'elle recouvre les zones de l'image dans lesquelles la forme peut apparaître. Pour optimiser l'exécution de l'outil, créez des régions Recherche de petite taille. Plus la région Recherche est étendue, plus l'outil mettra de temps à effectuer l'inspection.

    les régions Modèle et Recherche ne peuvent pas être courbées en arc de cercle ou dans une forme circulaire.

  3. Cliquez sur le bouton OK pour confirmer les régions (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  4. La région Modèle est remplacée par l'icône [image], indiquant l'emplacement et l'orientation angulaire du modèle localisé.
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres des outils de recherche de modèle et de modèles (1-10)

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Capteurs de vision In-Sight série 2000

Outil de modèle

  • Zone de groupe Outil d'édition

Outil de modèles (1-10)

  • Onglet Général
  • Onglet Paramètres
  • Onglet Image d'apprentissage
  • Onglet Tableau

Systèmes de vision In-Sight

Les volets de paramètres des outils de recherche de modèle et de modèles (1-10) comprennent les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Image d'apprentissage
  • Onglet Tableau
Remarque : L'onglet Tableau est activé uniquement pour l'outil de recherche de modèles (1-10).
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Capteurs de vision In-Sight série 2000

Systèmes de vision In-Sight

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

Aide EasyBuilder | 08/29/2022 | Revision: 5.9.0.2


Réglage des paramètres de l'outil de recherche de modèle

Remarque :
  • Cette rubrique décrit l'interface utilisateur de l'outil de recherche de modèle, en étant connecté à un capteur de vision In-Sight série 2000. En cas de connexion aux systèmes de vision In-Sight ou d'utilisation de l'outil de recherche de modèles (1-10), voir la section Système de vision In-Sight de Réglage des paramètres des outils de recherche de modèle et de modèles (1-10).
  • Si vous essayez de charger un projet contenant cet outil configuré sur un micrologiciel In-Sight de version 5.7.0 ou ultérieure sur un système de vision In-Sight dont le micrologiciel est de la version 5.6.x ou antérieure, un message d'erreur s’affiche et le chargement du projet échoue.

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Fermé Indicateur de succès/échecs

Affiche un cercle vert [image] ou un rectangle rouge [image] pour représenter respectivement les succès et les échecs.

Fermé Tolérance angulaire

Définit dans quelle mesure le modèle trouvé peut pivoter par rapport à la position du modèle appris, tout en étant toujours identifié comme un modèle valide (± 0 à 180° ; valeur par défaut = ±45°). Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps. La poignée gauche définit la tolérance angulaire négative et la poignée droite définit la tolérance angulaire positive. Vous pouvez régler la tolérance angulaire en ajustant les poignées ou en saisissant des valeurs dans les zones d'édition correspondantes.

Astuce : vous pouvez également déplacer la poignée à l'aide des touches des FLÈCHES (HAUT, BAS, DROITE et GAUCHE).
Fermé Compteur de localisation de pièce

Le compteur de localisation de pièce affiche le degré d'exactitude de l'outil pour trouver la caractéristique et définit le seuil d'acceptation minimal. Vous pouvez définir manuellement la valeur du seuil d'acceptation minimal (0 à 100, valeur par défaut = 50) en réglant la poignée ou en saisissant une valeur dans la zone d'édition correspondante.

Astuce : vous pouvez également déplacer la poignée à l'aide des touches des FLÈCHES (HAUT, BAS, DROITE et GAUCHE).

Si le compteur est supérieur au seuil, l'outil considère la pièce comme trouvée et le compteur devient vert. S'il est inférieur au seuil, il considère la pièce comme non trouvée et le compteur disparait. Si l'outil détecte des choses qui ne correspondent pas aux pièces ou la mauvaise caractéristique, déplacez la poignée vers la droite. Si l'outil ne détecte pas certaines pièces, déplacez la poignée vers la gauche (ou créez une nouvelle Région du modèle). Moins les paramètres sont élevés, moins les résultats seront précis. Des modèles semblables seront détectés, mais pas par rapport au modèle de forme.

SUCCÈS
ÉCHEC
Remarque : Les valeurs de résultat et de seuil s'affichent en survolant le curseur avec le pointeur de la souris.
Fermé Tolérance en échelle de ± 10 %

Définit si l'outil permet ou pas un écart de taille de ±10 % entre le modèle trouvé et le modèle de forme.

Modèle appris | Modèle trouvé : +10 % | Modèle trouvé : -10%
DÉSACTIVÉ (par défaut) | (Échec) | (Échec)
ACTIVÉ | (Succès) | (Succès)
Fermé Utilisation du délai manuel

Définit si le réglage du délai est appliqué ou non.

  • Désactivé (par défaut) : le réglage du délai est désactivé (pas de délai).

  • Activé : le réglage du délai est activé. Vous pouvez manuellement définir la valeur du délai en millisecondes (0 à 30 000), à l'aide de la zone d'édition.

    Remarque : le réglage de la valeur sur 0 désactive le réglage et aucun délai n'est appliqué.
Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Nom

Définit le nom de votre outil d'inspection. Le nom par défaut est « Modèle_1 » (si c'est le premier outil Modèle ajouté au projet, sinon, il est incrémenté, par exemple « Modèle_2 », « Modèle_3 », etc.).

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Activé

Définit si l'outil d'inspection doit s'exécuter et à quel moment (le paramètre par défaut est Activé).

  • Sélectionnez "Désactivé" pour désactiver l'outil.
  • Sélectionnez une ligne d'entrée pour que l'outil soit associé à une ligne d'entrée discrète spécifique, où il peut être activé ou désactivé (un signal élevé 1 signifie activé, un signal faible 0 signifie désactivé). La connexion de l'outil à une entrée permet à un système de contrôle, un PLC par exemple, de déterminer quels outils doivent s'exécuter, et à quel moment.
Fermé Repère

Sélectionne un repère pour l'outil. Le bouton Repère devient orange quand le contrôle de repère est activé.

Remarque : ce contrôle peut être activé uniquement si un autre outil qui définit un repère a déjà été ajouté.
Fermé Apprendre entrée

Définit s'il faut ou pas apprendre un modèle de forme sur une ligne d'entrée (le paramètre par défaut est « Off », désactivé).

  • Entrée : Apprend un modèle de forme sur une ligne d'entrée. La ligne d'entrée sélectionnée sera utilisée comme signal d'apprentissage.

    Remarque :
    • Cette option ne sera pas affichée quand le système de vision In-Sight n'a pas d'entrées discrètes (p. ex., système de vision In-Sight série 8000 avec E/S directes).
    • Le type de signal de la ligne d'entrée sélectionnée doit être défini sur Déclencheur d'événement à l'étape d'application Entrées/Sorties.
    • L'apprentissage d'un modèle de forme utilise l'image la plus récente acquise par le système/capteur de vision. Il n'est pas nécessaire de redéclencher le système/capteur de vision pour effectuer l'apprentissage.
    • Pour en savoir plus, reportez-vous à la rubrique Entrées : apprentissage d'un modèle de forme sur une ligne d'entrée
Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Fermé Région du modèle

L'image est une vignette du Modèle. Cliquez sur le bouton Région du modèle pour redimensionner ou déplacer la région du Modèle, puis sur le bouton Apprendre pour apprendre à nouveau le Modèle de forme.


Outil de recherche de modèle et de modèles (1-10) - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties, et Communication). Le nom par défaut est « Modèle_1 » s'il s'agit du premier outil de modèle ajouté au projet. Sinon, il est incrémenté (par exemple, « Modèle_2 », « Modèle_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de recherche de modèle et de modèles (1-10) - Onglet Paramètres

Fermé Apprendre entrée

Définit s'il faut ou pas apprendre un modèle de forme sur une ligne d'entrée (le paramètre par défaut est « Off », désactivé).

  • Entrée : Apprend un modèle de forme sur une ligne d'entrée. La ligne d'entrée sélectionnée sera utilisée comme signal d'apprentissage.

    Remarque :
    • Cette option ne sera pas affichée quand le système de vision In-Sight n'a pas d'entrées discrètes (p. ex., système de vision In-Sight série 8000 avec E/S directes).
    • Le type de signal de la ligne d'entrée sélectionnée doit être défini sur Déclencheur d'événement à l'étape d'application Entrées/Sorties.
    • L'apprentissage d'un modèle de forme utilise l'image la plus récente acquise par le système/capteur de vision. Il n'est pas nécessaire de redéclencher le système/capteur de vision pour effectuer l'apprentissage.
    • Pour en savoir plus, reportez-vous à la rubrique Entrées : apprentissage d'un modèle de forme sur une ligne d'entrée
Fermé Nombre à chercher

Définit le nombre d'instances du modèle de forme à détecter (1 à 10 ; valeur par défaut = 1). La plupart des applications ne nécessitent qu'un seul repère. Plusieurs instances du modèle de forme peuvent toutefois être localisées, ce qui s'avère utile dans des applications dans lesquelles l'image comporte plusieurs pièces ou objets. Plus l'outil doit identifier d'instances apprises, plus sa durée d'exécution est importante.

Fermé Seuil d'acceptation

Définit le degré de similitude qui doit exister entre le modèle de forme et le modèle localisé (0 à 100 ; valeur par défaut = 50). Les modèles localisés affichant une valeur supérieure ou égale au seuil défini sont considérés comme correspondants. Cet outil s'exécute plus rapidement lorsque ce paramètre est élevé, ce qui requiert également un degré de similitude plus important entre le modèle de forme et le modèle localisé. Moins les paramètres sont élevés, moins les résultats seront précis. Des modèles semblables seront détectés, mais pas par rapport au modèle de forme.

Fermé Tolérance angulaire

Définit dans quelle mesure le modèle localisé peut pivoter par rapport à la position du modèle de forme, tout en étant identifié comme un modèle valide (± 0 à 180° ; valeur par défaut = 15°). Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps.

Fermé Tolérance en échelle

Définit le pourcentage autorisé de mise à l'échelle (variations comprises dans une plage de ± 10 %) entre le modèle localisé et le modèle de forme. Ce paramètre est désactivé par défaut (option pas cochée), ce qui désactive les ajustements d'échelle. Dans ce mode de fonctionnement, l'outil trouve toujours les modèles compris dans la plage de ± 10 %, mais le score de la caractéristique diminue à mesure que le pourcentage de mise à l'échelle augmente.

Fermé Trier par

Définit le mode de classement des modèles localisés : par Score (paramètre par défaut) ou en fonction du repère X ou Y. Lorsque Score est sélectionné, les modèles localisés sont triés en fonction de leur score, par ordre décroissant, le modèle au score le plus élevé apparaissant en tête de liste. Lorsque X est sélectionné, les modèles localisés sont triés en fonction de leur distance par rapport à l'axe X, par ordre décroissant, du plus proche au plus éloigné. Lorsque Y est sélectionné, les modèles localisés sont triés en fonction de leur distance par rapport à l'axe Y, par ordre décroissant, du plus proche au plus éloigné.

Fermé Offset horizontal

Définit une position décalée sur l'axe horizontal (mesurée en pixels) à partir du centre du modèle localisé par rapport au modèle de forme appris. Cela permet d'affecter des coordonnées distantes du centre du modèle de forme, ce qui s'avère utile lors de la définition d'un point de sélection dans les applications robotiques guidées par vision.

Fermé Offset vertical

Définit une position décalée sur l'axe vertical (mesurée en pixels) à partir du centre du modèle localisé par rapport au modèle de forme appris. Cela permet d'affecter des coordonnées distantes du centre du modèle de forme, ce qui s'avère utile lors de la définition d'un point de sélection dans les applications robotiques guidées par vision.

Fermé Type de modèle

Définit comment l'outil construit le modèle de forme : Modèle de surface ou Modèle de transition (valeur par défaut). Modèle de surface crée un modèle de forme basé sur un échantillonnage uniforme de valeurs de niveaux de gris de la région modèle. Modèle de transition crée un modèle de forme basé sur les transitions détectées (transitions claires/sombres) de la caractéristique de modèle dans la région modèle.

Fermé Précision

Définit comment l'outil qualifie le compromis entre précision/fiabilité et vitesse d'exécution : Précis, Moyen (valeur par défaut) et Rapide. Précis indique que l'accent est mis sur une précision/fiabilité plus élevée et une vitesse d'exécution plus lente , Rapide indique que l'accent est mis sur une vitesse d'exécution plus élevée plutôt que sur la précision/fiabilité ; et Moyen indique un réglage intermédiaire entre les deux.

Fermé Délai d'attente

Définit la durée, en millisecondes (0 à 30 000), pendant laquelle l'outil recherche le ou les modèles avant que l'exécution ne soit interrompue et que l'outil ne renvoie un échec.

Fermé Résultat

Affiche les coordonnées X,Y du centre du modèle localisé et son orientation angulaire, ainsi que son score par rapport au modèle de forme. Si un offset horizontal ou vertical a été appliqué, les coordonnées X,Y sont ajustées conformément à la valeur spécifiée dans les champs d'offset.

Remarque : si le paramètre Nombre à chercher est supérieur à 1 et que le paramètre Trier par n'est pas défini sur X ou Y, le résultat affiché correspondra toujours au modèle localisé au score le plus élevé.
Remarque : l'outil de recherche de modèles ne contient ni le paramètre Nombre à chercher ni le paramètre Trier par.


Outil de recherche de modèles (1-10) - Onglet Tableau

Le tableau créé sur l'onglet Tableau publie les résultats des modèles localisés :

Fermé Index

Indique l'ordre des modèles localisés, de 1 à 10 (dans l'ordre numérique d'EasyBuilder, 0=1).

Fermé X

Désigne le centre de la coordonnée X du modèle localisé.

Fermé Y

Désigne le centre de la coordonnée Y du modèle localisé.

Fermé Angle

Indique l'angle du modèle localisé par rapport au modèle de forme.

Fermé Score

Indique le degré de similitude du modèle localisé avec le modèle de forme.


Outil de recherche de modèle et de modèles (1-10) - Onglet Image d'apprentissage

L'image affichée sur l'onglet Image d'apprentissage est une miniature du modèle de forme. Cliquez sur le bouton Région du modèle pour redimensionner ou déplacer la région Modèle, puis sur le bouton Apprendre pour apprendre à nouveau le modèle de forme.


Outils de recherche - Transition

L'outil de recherche de transition sert à localiser les caractéristiques de bords linéaires se trouvant dans les paramètres indiqués.

L'outil de recherche de transition est l'un des plus rapides, il peut reconnaître des caractéristiques de bords plus vite qu'un outil de recherche de modèles. Cet outil est également utile comme repère pour les autres outils de vision, lorsque la caractéristique de bord a un contraste élevé, se déplace dans un seul sens (horizontal ou vertical) et ne subit pas de rotation supérieure à 10°.

L'outil renvoie les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000 Séries 1XX (110, 120, 130) | État Succès/Échec uniquement
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Coordonnées X,Y du milieu du bord trouvé*, orientation angulaire et état succès/échec.
* L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de recherche de transition

Une fois l'outil ajouté, définissez la caractéristique de transition qui sera utilisée comme repère :

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Sélectionnez l'une des caractéristiques disponibles en cliquant simplement dessus. Elle devient rose.

  3. Confirmez votre choix en cliquant sur le bouton OK (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet). EasyBuilder crée automatiquement une région de transition autour de la transition sélectionnée et insère l'icône [image] indiquant l'emplacement et l'orientation angulaire de la transition localisée.

    Remarque : le cas échéant, il est possible de faire pivoter ou de redimensionner la région autour de la transition localisée.
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de recherche de transition

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de recherche de transition comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Graphique
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Graphique


Outil de recherche de transition - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Transition_1 » s'il s'agit du premier outil de transition ajouté au projet. Sinon, il est incrémenté (par exemple, « Transition_2 », « Transition_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de recherche transition - Onglet Paramètres

Fermé Contraste de bord

Définit le score minimum de contraste de bord acceptable pour le bord détecté (1-100 ; par défaut = un « Paramètre intelligent » qui est généralement décrémenté jusqu’à détection du bord). Ce paramètre détermine la sensibilité de détection des bords de l’outil (sa capacité à faire la distinction entre la caractéristique et l’arrière-plan) ; utilisez ce paramètre avec l’option Graphique pour définir une plage acceptable.

Remarque : Si ce paramètre est configuré sur 0, l'outil peut trouver des bords inattendus.
Fermé Normalisation du score

Définit si les scores des bords seront normalisés par rapport à l’histogramme des niveaux de gris de la région.Ce paramètre permet de rechercher les bords dans des régions de faible contraste. Désactiver ce paramètre si vous êtes certains que les bords à détecter présentent un contraste élevé.

  • Coché (par défaut) : Normalise le score.
  • Non coché : Ne normalise pas le score.
Fermé Transition de bord

Définit la transition sur le bord (Sombre au clair, Clair au sombre ou Les deux ; par défaut = Les deux). Les flèches de direction de balayage de la région indiquent le sens dans lequel EasyBuilder va procéder au balayage du bord ; pour augmenter la précision et la vitesse de traitement, indiquez le type de transition.

Fermé Largeur de transition

Définit la distance de pixels (1 à 50 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Chercher par

Définit la manière dont l’outil fait la distinction entre des transitions trouvées si plusieurs transitions sont présentes (par défaut = Meilleur score).

  • Meilleur score = la transition dont la définition est la meilleure (contraste et luminosité les plus élevés).
  • Premier bord = la transition la plus proche de l’origine du balayage de la région.
  • Dernier bord = la transition la plus éloignée de l’origine du balayage de la région.
Fermé Gamme d’écart angulaire

Définit la valeur maximale de la transposition angulaire que peut subir la transition trouvée (0-10° ; par défaut = 10°). Plus la variance autorisée de l’angle est importante, plus l’outil mettra de temps à procéder à l’exécution.

Fermé Résultat

Affiche les coordonnées X/Y du milieu du bord trouvé et son orientation angulaire.


Outil de recherche de transition - Graphique

Le Graphique est une représentation de la première dérivée des valeurs de niveau de gris contenues dans la région, les crêtes et vallées représentent le niveau des transitions majeures des bords.

Pour les outils détectant les bords (outils Bord et Cercle), l'axe du Score est une mesure pour la correspondance du bord trouvé avec les paramètres définis :

  • Un score positif indique que le bord fait la transition du sombre vers le clair ;
  • Un score négatif indique que le bord fait la transition du clair vers le sombre ;
  • Un score de 0 indique qu'aucun bord n'a été détecté.

L'axe Offset fait référence à la région définissant la fonction du bord, avec 0 représentant la limite de départ de la région, et l'autre valeur représentant la largeur maximum (en pixels) de la région. Le sommet des crêtes et des vallées le long de l'axe Offset indique la position du bord trouvé.

Remarque : Le graphique s'affiche sans tenir compte de l'état En ligne/Hors ligne et de l'état succès/échec de l'outil. Cependant, si l'outil est en échec, il est possible que le graphique ne soit pas mis à jour.


Outils de recherche - Intersection de transition

L'outil de recherche d'intersection de transition sert à identifier le point où se croisent deux caractéristiques des bords.

L'outil renvoie les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000 Séries 1XX (110, 120, 130) | État Succès/Échec uniquement
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Coordonnées X,Y du point d'intersection*, angle de bissection entre les deux bords et état succès/échec.
* L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de recherche d'intersection de transition

Une fois l'outil ajouté, définissez les caractéristiques de transition formant une intersection :

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Commencez par sélectionner une des caractéristiques disponibles en cliquant dessus : elle devient rose et est reliée à un trait.
  3. Ensuite, sélectionnez la caractéristique de transition qui va former une intersection.
  4. Une fois la seconde caractéristique sélectionnée, EasyBuilder détermine automatiquement le point d'intersection des lignes et insère une icône [image] pour indiquer l'emplacement et l'orientation du point localisé. EasyBuilder insère également automatiquement un outil de présence/absence de transition pour chacune des caractéristiques de transition qui n'est pas encore définie.
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de recherche d'intersection de transition

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil de recherche d'intersection de transition comprend les éléments suivants :

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « Intersection_1 » s'il s'agit du premier outil de recherche d'intersection de transition, outil géométrique d'intersection cercle à ligne ou d'intersection de lignes ajouté au projet. Autrement, il est incrémenté (par exemple, « Intersection_2 », « Intersection_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.


Outils de recherche - Blob et Blobs (1-10)

Les outils de recherche de blob et de blobs(1-10) permettent de localiser les caractéristiques de blob qui correspondent aux paramètres spécifiés. Ils renvoient les coordonnées X,Y du centre de gravité du blob localisé, ainsi que l'angle du centre de gravité du blob. L'outil Blob permet de mesurer un blob unique alors que l'outil Blobs (1-10) est utilisé pour mesurer jusqu'à 10 blobs correspondant aux critères de l'inspection.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Les performances des outils de recherche de blob et de blobs (1-10) se situent entre celles des outils de transition/cercle et des outils de modèles. Ces outils permettent de localiser les caractéristiques de blob plus rapidement qu'un outil de recherche de modèles mais leur exécution demande généralement plus de temps que les outils de transition ou de cercle. Ces outils sont, par exemple, utiles pour fournir des repères à d'autres outils de vision lorsque vous tentez d'ancrer votre inspection sur une forme inclassable, telle qu'une tache de peinture noire sur fond blanc, ou lorsque la forme évolue au-delà des limites des outils de modèles.

Configuration des outils

Réglage des paramètres des outils


Configuration des outils de recherche de blob et de blobs (1-10)

Une fois l'outil sélectionné, choisissez le type de région et configurez cette dernière dans l'image dans laquelle vous pensez détecter la ou les caractéristiques de blob :

  1. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Placez et configurez la région là où vous souhaitez voir apparaître le(s) blob(s). Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. En sélectionnant un blob comme Repère, choisissez un blob présent sensiblement au même emplacement dans chaque image.

    Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Lorsque la région a été acceptée, l'icône [image] apparaît sur le centre de gravité du blob, indiquant l'emplacement et l'orientation de la caractéristique localisée.
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres des outils de recherche de blob et de blobs (1-10)

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Les volets de paramètres des outils de recherche de blob et de blobs (1-10) comprennent les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Tableau
  • Onglet Histogramme
  • Onglet Région composite
Remarque : L'onglet Tableau est activé uniquement pour l'outil de recherche de blobs (1-10).
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Tableau

Onglet Région composite

Histogramme


Outil de recherche de blob et de blobs (1-10) - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Blob_1 » s'il s'agit du premier outil de blob ajouté au projet. Sinon, il est incrémenté (par exemple, « Blob_2 », « Blob_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de recherche de blob et de blobs (1-10) - Onglet Paramètres

Fermé Mode seuil

Définit le mode utilisé pour déterminer la valeur de niveau de gris servant à séparer les blobs de l'arrière-plan. Lorsque le paramètre Auto est sélectionné (paramètre par défaut), l'outil compense les changements de luminosité d'une image à l'autre à chaque acquisition d'image. Lorsque le paramètre Manuel est sélectionné, vous devez saisir et ajuster la valeur manuellement.

Fermé Seuil du blob

Définit la valeur de niveau de gris utilisée pour séparer les blobs de l'arrière-plan (0 à 255, lorsque l'option est activée). Ce contrôle, désactivé par défaut, requiert que le mode du seuil soit défini sur Manuel pour être activé. Utilisez l'histogramme pour définir une valeur optimale pour votre application.

Fermé Couleur du blob

Définit la couleur du blob (Noir, Blanc ou Indifférent ; valeur par défaut = Indifférent).

  • Indifférent = la couleur du blob n’est pas déterminée.
  • Noir = renvoie uniquement les blobs qui se trouvent sous le Seuil blob.
  • Blanc = renvoie uniquement les blobs qui se trouvent au-dessus du Seuil blob.
Fermé Limite

Définit l'une des deux méthodes de gestion des blobs situés à la limite de la région du blob (option désactivée par défaut) :

  • Désactivée : n'inclut pas les blobs situés à la limite de la région. Le blob doit être entièrement compris dans la région à détecter.
  • Activée : inclut les blobs touchant le bord de la région. Ces derniers sont détectés s'ils remplissent aussi les autres critères.
Fermé Surface minimale

Définit une limite de surface minimale sous la forme d'un nombre de pixels (0 à 16 777 216 ; valeur par défaut = 100) pour tous les blobs détectés. Seuls les blobs dont la surface est supérieure à la surface minimale seront reconnus.

Fermé Surface maximale

Définit une limite de surface maximale sous la forme d'un nombre de pixels (0 à 16 777 216 ; valeur par défaut = 100 000) pour tous les blobs détectés. Seuls les blobs dont la surface est inférieure à la surface maximale seront reconnus.

Fermé Ignorer l'angle

Définit si l'orientation angulaire du centre de gravité du blob doit ou non être prise en compte (option activée par défaut).

Remarque : les blobs fournissent généralement une valeur d'orientation angulaire limitée. Ce paramètre est par conséquent activé par défaut.
Fermé Nombre à chercher

Définit le nombre de blobs à détecter (1-10 ; par défaut = 1). La plupart des applications ne nécessitent qu'un seul repère. Plusieurs blobs peuvent toutefois être localisés, ce qui s'avère utile dans des applications dans lesquelles l'image comporte plusieurs pièces ou objets. Plus l'outil doit identifier de blobs, plus sa durée d'exécution est importante.

Fermé Trier par

Définit comment l'outil mesure et trie les blobs localisés (Surface, Ligne, Col, Grille : Ligne puis Col en partant du repère, Grille : Col puis Ligne en partant du repère, Distance par rapport à l'origine du repère, Angle par rapport à l'axe X du repère (sens antihoraire), Distance angulaire ; valeur par défaut = Surface) :

  • Surface = trie les blobs localisés en fonction de leur surface, de la plus grande à la plus petite.
  • Ligne = trie selon la distance le long de l'axe X de l'image, de la plus proche à la plus éloignée, par ordre décroissant.
  • Col = trie selon la distance le long de l'axe Y de l'image, de la plus proche à la plus éloignée, par ordre décroissant.
  • Grille : Ligne puis Col en partant du repère = trie selon la distance le long de l'axe X de l'image du repère en premier, puis le long de l'axe Y de l'image, de la plus proche à la plus éloignée, par ordre décroissant..
  • Grille : Col puis Ligne en partant du repère = trie selon la distance le long de l'axe Y de l'image du repère en premier, puis le long de l'axe X de l'image, de la plus proche à la plus éloignée, par ordre décroissant.
  • Distance par rapport à l'origine du repère = trie selon la distance entre le repère de référence et le centre de gravité du blob, de la plus proche à la plus éloignée, par ordre décroissant.
  • Angle par rapport à l'axe X du repère (sens antihoraire) = trie selon l'angle (0 à 360°) mesuré entre l'axe X de l'image du repère et le segment défini par le centre de gravité du blob et l'origine du repère, du plus proche au plus éloigné, par ordre décroissant.
  • Distance angulaire = trie selon la valeur absolue de l'angle (de -180 à 180°) mesuré entre l'axe X de l'image du repère et un segment défini par le centre de gravité du blob et l'origine du repère, du plus proche au plus éloigné.
Fermé Résultat

Affiche les coordonnées X,Y et l'angle (toujours indiqué comme égal à 90° lorsque la case Ignorer l'angle est cochée) du centre de gravité du blob localisé, ainsi que son score.

Remarque : si le paramètre Nombre à chercher est supérieur à 1 et que le paramètre Trier par n'est pas défini sur X ou Y, le résultat affiché correspondra toujours au modèle localisé au score le plus élevé.
Remarque : l'outil de recherche de blob ne contient pas le paramètre Nombre à trouver.


Outil de recherche de blobs (1-10) - Tableau

Remarque :
  • L'outil de recherche de blob ne prend pas en charge l'onglet Tableau, qui n'est disponible que pour l'outil de recherche des blobs (1-10).
  • Lorsque le paramètre Trier par est défini sur une autre option que Surface, les colonnes Ligne pixel et Col. pixel sont ajoutées au tableau. Ligne pixel et Col. pixel correspondent aux coordonnées de l'image basées sur la grille 2D du capteur d'image du système de vision In-Sight (lignes et colonnes du groupe). Il s'agit des valeurs (Y/X) opposées des coordonnées (X/Y) réelles.

  • Si l'option Orientation classique est activée (cochée) dans la zone de groupe Calibrer l'image avec des unités réelles de l'étape Configurer l'image, les coordonnées X et Y se trouveront dans le même espace de coordonnées que les coordonnées de l'image (Y/X).

Remarque : L'onglet Tableau affiche les résultats des blobs détectés, en fonction du paramètre Nombre à chercher de l'onglet Paramètres :
Fermé Index

Indique l'ordre des blobs localisés, en fonction du paramètre Trier par de l'onglet Paramètres ; de 1 à 10 (dans l'ordre numérique d'EasyBuilder, 0=1).

Fermé X

Renvoie l'abscisse du centre de gravité du blob localisé ; à moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.

Fermé Y

Renvoie l'ordonnée du centre de gravité du blob localisé ; à moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.

Fermé Angle

Renvoie l'angle du centre de gravité du blob localisé par rapport au centre de la région.

Fermé Surface

Renvoie la surface du blob localisé (mesurée en pixels).

Fermé Ligne pixel

Renvoie l'abscisse (X) de l'image du centre de gravité du blob localisé.

Fermé Col. pixel

Renvoie l'ordonnée (Y) de l'image du centre de gravité du blob localisé.


Outil de recherche de blob et de blobs (1-10) Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outil de recherche de blob et de blobs (1-10) - Histogramme

L'Histogramme affiche un graphique des valeurs de niveau de gris des pixels dans la région.

  • L'axe X du graphique représente le nombre total de valeurs de niveau de gris (0 à 255, ou 256 nuances de gris au total).
  • L'axe Y du graphique représente le nombre de pixels pour une valeur de niveau de gris donnée, l'échelle est établie en affichant la valeur de niveau de gris avec le plus grand nombre de pixels.
  • La ligne bleue verticale indique le seuil utilisé pour séparer la région de l'image en pixels noirs et blancs ; les valeurs situées à gauche de la ligne sont considérées comme noires et les valeurs de droite comme blanches.
Remarque : Le graphique s'affiche sans tenir compte de l'état En ligne/Hors ligne et de l'état succès/échec de l'outil. Cependant, si l'outil est en échec, il est possible que le graphique ne soit pas mis à jour.


Outils de recherche - Blob de couleur et Blobs de couleur (1-10)

Les outils de recherche de blob de couleur et de blobs de couleur (1-10) permettent de localiser les caractéristiques de blob qui correspondent aux paramètres spécifiés. Ils renvoient les coordonnées X,Y du centre de gravité du blob localisé, ainsi que l'angle du centre de gravité du blob. L'outil Blob de couleur permet de mesurer un blob unique alors que l'outil Blobs de couleur (1-10) est utilisé pour mesurer jusqu'à 10 blobs correspondant aux critères de l'inspection.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Les outils Blob de couleur et Blobs de couleur (1-10) utilisent une bibliothèque de modèles de couleurs appris pour déterminer le nombre de pixels présents dans la région qui correspondent aux modèles de couleurs sélectionnés et appris de la bibliothèque. L'outil crée ensuite une image de sortie binaire en niveau de gris, ou chaque pixel correspondant à un Modèle de couleur actif est défini sur Blanc (255), tandis que les autres pixels sont définis sur Noir (0). Les outils utilisent cette image de sortie binaire pour rechercher, dans l'image, les caractéristiques de blob créées par les modèles de couleurs actifs.

Configuration des outils

Réglage des paramètres des outils


Configuration des outils de recherche de blob de couleur et de blobs de couleur (1-10)

Une fois l'outil sélectionné, choisissez le type de région et configurez cette dernière dans l'image dans laquelle vous pensez détecter la ou les caractéristiques de blob :

  1. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Placez et configurez la région là où vous souhaitez voir apparaître le(s) blob(s). Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. En sélectionnant un blob comme Repère, choisissez un blob présent sensiblement au même emplacement dans chaque image.

    Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Une fois la région de recherche configurée, configurez la bibliothèque de couleurs de l'outil et activez le ou les modèles de couleurs appropriés :

    • Si un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire) est ajouté pour la première fois, commencez par configurer une ou plusieurs bibliothèques de couleurs et leur(s) modèle(s) de couleurs.

    • Si un autre outil a déjà été ajouté et que vous souhaitez utiliser une bibliothèque de couleurs existante et ses modèles de couleurs appris, sélectionnez la bibliothèque de couleurs de votre choix sous l'onglet Paramètres, puis activez les modèles de couleurs voulus en les cochant sous l'onglet Bibliothèque.

    • Par défaut, l'outil déclenche automatiquement un échec tant qu'aucune bibliothèque de couleurs n'a été définie. Si une bibliothèque de couleurs a été définie, l'outil utilise automatiquement cette bibliothèque et active tous les modèles de couleurs qu'elle contient.

  4. Une fois le ou les modèles de couleurs et la ou les bibliothèques de couleurs configurés, l'outil traite l'image et tous les pixels de la région de recherche qui correspondent au ou aux modèles de couleurs sélectionnés deviennent blancs (255), alors que ceux qui ne correspondent pas au ou aux modèles de couleurs sélectionnés deviennent noirs (0).

  5. Lorsque la région a été acceptée, l'icône [image] apparaît sur le centre de gravité du blob, indiquant l'emplacement et l'orientation de la caractéristique localisée.

  6. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  7. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres des outils de recherche de blob de couleur et de blobs de couleur (1-10)

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Les volets de paramètres des outils de recherche de blob de couleur et de blobs de couleur (1-10) comprennent les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Bibliothèque de couleurs
  • Onglet Tableau
  • Onglet Région composite
Remarque : l'onglet Tableau n'est activé que pour l'outil de recherche de blobs de couleur (1-10).
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Région composite

Onglet Tableau

Bibliothèque


Outil de recherche de blobs de couleur - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « BlobCouleur_1 » s'il s'agit du premier outil de blob de couleur ajouté au projet. Sinon, il est incrémenté (par exemple, « BlobCouleur_2 », « BlobCouleur_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outils de recherche Blob de couleur et Blobs de couleur (1-10) - Onglet Paramètres

Fermé Apprendre la couleur

Affiche la boîte de dialogue Apprentissage ExtractColor , utilisée pour définir le ou les modèles de couleurs de la bibliothèque de couleurs sélectionnée.

Fermé Bibliothèque de couleurs

Définit la bibliothèque de couleurs utilisée comme référence par l'outil. Sur la liste déroulante, sélectionnez la bibliothèque de couleurs à modifier puis cliquez sur le bouton Apprendre la couleur pour afficher la boîte de dialogue Apprentissage ExtractColor. Chaque bibliothèque de couleurs peut compter jusqu'à 100 modèles de couleurs distincts, composés de couleurs individuelles.

Les projets EasyBuilder peuvent contenir 5 bibliothèques de couleurs maximum, qui peuvent être partagées par les outils suivants :

  • Outil de recherche de blob de couleur
  • Outil de recherche de blobs de couleur (1-10)
  • Outil de présence/absence basé sur le comptage de pixels
  • Outil de mesure de surface de blob de couleur
  • Outil de mesure de surfaces des blobs de couleur (1-10)
  • Outil de comptage de blobs de couleur
  • Outil d'identification du modèle de couleurs
  • Outil de filtre d'image couleur -> binaire
Fermé Limite

Définit l'une des deux méthodes de gestion des blobs situés à la limite de la région du blob (option désactivée par défaut) :

  • Désactivée : n'inclut pas les blobs situés à la limite de la région. Le blob doit être entièrement compris dans la région à détecter.
  • Activée : inclut les blobs touchant le bord de la région. Ces derniers sont détectés s'ils remplissent aussi les autres critères.
Fermé Surface minimale

Définit une limite de surface minimale sous la forme d'un nombre de pixels (0 à 16 777 216 ; valeur par défaut = 100) pour tous les blobs détectés. Seuls les blobs dont la surface est supérieure à la surface minimale seront reconnus.

Fermé Surface maximale

Définit une limite de surface maximale sous la forme d'un nombre de pixels (0 à 16 777 216 ; valeur par défaut = 100 000) pour tous les blobs détectés. Seuls les blobs dont la surface est inférieure à la surface maximale seront reconnus.

Fermé Ignorer l'angle

Définit si l'orientation angulaire du centre de gravité du blob doit ou non être prise en compte (option activée par défaut).

Remarque : Les blobs fournissent généralement une valeur d'orientation angulaire limitée. Ce paramètre est par conséquent activé par défaut.
Fermé Nombre à trouver

Définit le nombre de blobs de couleur à détecter (1 à 10 ; valeur par défaut = 1). La plupart des applications ne nécessitent qu'un seul repère. Plusieurs blobs peuvent toutefois être localisés, ce qui s'avère utile dans des applications dans lesquelles l'image comporte plusieurs pièces ou objets. Plus l'outil doit identifier de blobs, plus sa durée d'exécution est importante.

Remarque : Ce contrôle est uniquement disponible pour l'outil de recherche Blobs de couleur (1-10).
Fermé Trier par

Définit comment l'outil mesure et trie les blobs localisés (Surface, Ligne, Col, Grille : Ligne puis Col en partant du repère, Grille : Col puis Ligne en partant du repère, Distance par rapport à l'origine du repère, Angle par rapport à l'axe X du repère (sens antihoraire), Distance angulaire ; valeur par défaut = Surface) :

  • Surface = trie les blobs localisés en fonction de leur surface, de la plus grande à la plus petite.
  • Ligne = trie selon la distance le long de l'axe X de l'image, de la plus proche à la plus éloignée, par ordre décroissant.
  • Col = trie selon la distance le long de l'axe Y de l'image, de la plus proche à la plus éloignée, par ordre décroissant.
  • Grille : Ligne puis Col en partant du repère = trie selon la distance le long de l'axe X de l'image du repère en premier, puis le long de l'axe Y de l'image, de la plus proche à la plus éloignée, par ordre décroissant..
  • Grille : Col puis Ligne en partant du repère = trie selon la distance le long de l'axe Y de l'image du repère en premier, puis le long de l'axe X de l'image, de la plus proche à la plus éloignée, par ordre décroissant.
  • Distance par rapport à l'origine du repère = trie selon la distance entre le repère de référence et le centre de gravité du blob, de la plus proche à la plus éloignée, par ordre décroissant.
  • Angle par rapport à l'axe X du repère (sens antihoraire) = trie selon l'angle (0 à 360°) mesuré entre l'axe X de l'image du repère et le segment défini par le centre de gravité du blob et l'origine du repère, du plus proche au plus éloigné, par ordre décroissant.
  • Distance angulaire = trie selon la valeur absolue de l'angle (de -180 à 180°) mesuré entre l'axe X de l'image du repère et un segment défini par le centre de gravité du blob et l'origine du repère, du plus proche au plus éloigné.
Fermé Facteur de lissage

Définit le facteur (0 à 25 ; valeur par défaut = 1) à utiliser pour le lissage de l'image. Pour spécifier l'absence de tout lissage, définissez la valeur sur 0.

Fermé Afficher l'image d'origine
  • Désactivé (par défaut) : La région sélectionnée affiche une image de sortie binaire en niveaux de gris.
  • Activée : La région sélectionnée affiche une image d'entrée d'origine.
Fermé Résultat

Affiche les coordonnées X,Y et l'angle (toujours indiqué comme égal à 90° lorsque la case Ignorer l'angle est cochée) du centre de gravité du blob localisé, ainsi que son score.


Outils de recherche de blob de couleur et de blobs de couleur (1-10) Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outil de recherche de blobs de couleur (1-10) - Onglet Tableau

Remarque :
  • L'outil de recherche de blob de couleur ne prend pas en charge l'onglet Tableau, qui n'est disponible que pour l'outil de recherche de blobs de couleur (1-10).
  • Lorsque le paramètre Trier par est défini sur une autre option que Surface, les colonnes Ligne pixel et Col. pixel sont ajoutées au tableau. Ligne pixel et Col. pixel correspondent aux coordonnées de l'image basées sur la grille 2D du capteur d'image du système de vision In-Sight (lignes et colonnes du groupe). Il s'agit des valeurs (Y/X) opposées des coordonnées (X/Y) réelles.

  • Si l'option Orientation classique est activée (cochée) dans la zone de groupe Calibrer l'image avec des unités réelles de l'étape Configurer l'image, les coordonnées X et Y se trouveront dans le même espace de coordonnées que les coordonnées de l'image (Y/X).

L'onglet Tableau affiche les résultats des blobs détectés, en fonction du paramètre Nombre à chercher de l'onglet Paramètres :

Fermé Index

Indique l'ordre des blobs localisés, en fonction du paramètre Trier par de l'onglet Paramètres ; de 1 à 10 (dans l'ordre numérique d'EasyBuilder, 0=1).

Fermé X

Renvoie l'abscisse du centre de gravité du blob localisé ; à moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.

Fermé Y

Renvoie l'ordonnée du centre de gravité du blob localisé ; à moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.

Fermé Angle

Renvoie l'angle du centre de gravité du blob localisé par rapport au centre de la région.

Fermé Surface

Renvoie la surface du blob localisé (mesurée en pixels).

Fermé Ligne pixel

Renvoie l'abscisse (X) de l'image du centre de gravité du blob localisé.

Fermé Col. pixel

Renvoie l'ordonnée (Y) de l'image du centre de gravité du blob localisé.


Outils de recherche de blob de couleur et de blobs de couleur (1-10) - Bibliothèque

Fermé Liste Modèles de couleurs

Affiche une liste en lecture seule de modèle(s) de couleurs contenus dans la bibliothèque de couleurs sélectionnée. Les modèles de couleurs sont activés et désactivés en cochant ou décochant la case en regard de Modèles de couleurs.

Fermé Tableau de couleurs

Affiche un tableau ordonné en lecture seule de la ou des couleurs dans le modèle de couleurs sélectionné.

Fermé Nom de la couleur

Affiche le nom de la ou des couleurs du modèle de couleurs sélectionné.

Fermé RVB

Affiche les valeurs RVB de la ou des couleurs du modèle de couleurs sélectionné.

Fermé Opération

Affiche l'opération (Ajouter ou Soustraire) de la ou des couleurs du modèle de couleurs sélectionné.


Outils de recherche - Cercle

L'outil de recherche de cercle sert à localiser une caractéristique circulaire se trouvant dans les paramètres indiqués.

L'outil de recherche de cercle est l'un des plus rapides, il peut reconnaître des caractéristiques circulaires plus vite qu'un outil de recherche de modèles. Ces outils sont également utiles comme repères pour les autres outils de vision, lors de l'inspection d'objets circulaires ou bien d'une pièce ou d'un objet qui ne pivote pas.

L'outil renvoie les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000 Séries 1XX (110, 120, 130) | État Succès/Échec uniquement
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Les coordonnées X,Y du cercle trouvé (son centre), diamètre* et son état succès/échec.
* L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de recherche de cercle

Après avoir ajouté l'outil, vous devrez configurer la région de l'image qui servira à définir la transition circulaire :

  1. Positionnez la région circulaire sur la caractéristique de transition circulaire, en vous assurant qu'elle englobe complètement la caractéristique. Lorsque vous définissez un cercle comme repère, assurez-vous que son emplacement reste sensiblement identique d'une image à l'autre et qu'il présente un contraste élevé entre les pixels clairs et sombres.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. EasyBuilder crée automatiquement une région de transition annulaire autour de la transition circulaire et insère l'icône [image] indiquant l'emplacement et l'orientation angulaire du cercle localisé.
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de recherche de cercle

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de recherche de cercle comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Graphique
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Graphique


Outil de recherche de cercle - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Cercle_1 » s'il s'agit du premier outil de cercle ajouté au projet. Sinon, il est incrémenté (par exemple, « Cercle_2 », « Cercle_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de recherche le cercle - Onglet Paramètres

Fermé Contraste de bord

Définit le score minimum de contraste de transition acceptable pour la transition circulaire trouvée (1-100 ; par défaut = un « Paramètre intelligent » qui est généralement décrémenté jusqu’à ce qu’une transition circulaire soit détectée). Ce paramètre détermine la sensibilité de détection des bords de l’outil (sa capacité à faire la distinction entre la caractéristique et l’arrière-plan) ; utilisez ce paramètre avec l’option Graphique pour définir une plage acceptable.

Remarque : Si ce paramètre est configuré sur 0, l'outil peut trouver des bords inattendus.
Fermé Normalisation du score

Définit si les scores des bords seront normalisés par rapport à l’histogramme des niveaux de gris de la région.Ce paramètre permet de rechercher les bords dans des régions de faible contraste. Désactiver ce paramètre si vous êtes certains que les bords à détecter présentent un contraste élevé.

  • Coché (par défaut) : Normalise le score.
  • Non coché : Ne normalise pas le score.
Fermé Transition de bord

Définit la transition sur le bord (Sombre au clair, Clair au sombre ou Les deux ; par défaut = Les deux). Les régions annulaires recherchent des transitions de bord depuis la région annulaire interne vers la région annulaire externe ; pour augmenter la précision et la vitesse de traitement, indiquez le type de transition.

Fermé Largeur de transition

Définit la distance de pixels (1 à 50 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Chercher par

Définit la manière dont l’outil fait la distinction entre des transitions circulaires trouvées si plusieurs transitions circulaires sont présentes (par défaut = Meilleur score).

  • Meilleur score : la transition circulaire présentant la transition la mieux définie (contraste et luminosité les plus élevés) est choisie.
  • Le plus petit cercle : la transition circulaire ayant le diamètre le plus petit est choisie.
  • Le plus grand cercle : la transition circulaire ayant le diamètre le plus grand est choisie.
Fermé Résultat

Affiche les coordonnées X, Y du centre du cercle trouvé et son diamètre.


Outil de recherche de cercle - Graphique

Le Graphique est une représentation de la première dérivée des valeurs de niveau de gris contenues dans la région, les crêtes et vallées représentent le niveau des transitions majeures des bords.

Pour les outils détectant les bords (outils Bord et Cercle), l'axe du Score est une mesure pour la correspondance du bord trouvé avec les paramètres définis :

  • Un score positif indique que le bord fait la transition du sombre vers le clair ;
  • Un score négatif indique que le bord fait la transition du clair vers le sombre ;
  • Un score de 0 indique qu'aucun bord n'a été détecté.

L'axe Offset fait référence à la région définissant la fonction du bord, avec 0 représentant la limite de départ de la région, et l'autre valeur représentant la largeur maximum (en pixels) de la région. Le sommet des crêtes et des vallées le long de l'axe Offset indique la position du bord trouvé.

Remarque : Le graphique s'affiche sans tenir compte de l'état En ligne/Hors ligne et de l'état succès/échec de l'outil. Cependant, si l'outil est en échec, il est possible que le graphique ne soit pas mis à jour.


Outils de recherche - Calcul du repère

L'outil de recherche de calcul de repère permet de calculer l'emplacement d'un repère en fonction d'expressions mathématiques liées aux sorties d'autres outils de recherche et/ou d'inspection. L'outil renvoie les coordonnées X, Y et d'angle du repère calculé.

Remarque :
    L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.
  • Si cet outil est utilisé en association avec le calibrage avec une grille, des résultats imprécis peuvent être produits si la valeur du calibrage change. Dans ce cas, un calibrage Transition à transition, circulaire ou importé peut être utilisé à la place.

L'outil de recherche de calcul de repère permet d'utiliser des points, lignes ou données d'angle spécifiques produits par des outils de recherche et/ou d'inspection pour calculer un repère, pour créer un repère basé sur deux transitions, leur point d'intersection et l'angle de bissection qui en résulte, par exemple. Dans cette situation, deux outils de présence/absence de transition peuvent être utilisés pour définir les transitions et un outil géométrique de bissectrice de l'angle définit les valeurs X, Y et Angle. L'outil de recherche de calcul de repère utilise ensuite les données de sortie de l'outil géométrique de bissectrice de l'angle comme entrées pour les expressions X (Bissect_1.Point.X), Y (Bissect_1.Point.Y) et Angle (Bissect_1.Angle).

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de recherche de calcul de repère

Une fois l'outil ajouté, il vous faudra créer l'expression pour les valeurs X, Y et Angle.

Remarque : cet outil requiert que d'autres outils de recherche et/ou d'inspection soient utilisés comme entrées. Regroupez les autres outils de recherche et/ou d'inspection qui seront utilisés comme entrées dans l'outil avant d'ajouter cet outil. Sans cela, vous ne pourrez pas créer les expressions et devrez ajouter les outils de recherche et/ou d'inspection nécessaires puis revenir à cet outil après avoir configuré les autres outils.
  1. Créez chaque Expression en sélectionnant puis en entrant les fonctions mathématiques côté gauche du volet de paramètres et/ou les valeurs (données de projet et d'outil) côté droit. Pour entrer une fonction ou une valeur dans l'éditeur de formules Expression, sélectionnez la fonction ou la valeur et appuyez sur la touche Entrée, double-cliquez sur la fonction ou la valeur ou appuyez sur le bouton Insérer.
  2. Une fois les Expressions créées, l'outil insère une icône [image] dans l'image, indiquant l'emplacement et l'orientation du point calculé.
  3. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  4. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de recherche de calcul de repère

Après avoir ajouté l'outil au projet, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil de recherche de calcul de repère comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglets X, Y et Angle
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglets X, Y et Angle


Outil de recherche de calcul de repère - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Repère_1 » s'il s'agit du premier outil de calcul de repère ajouté au projet. Sinon, il est incrémenté (par exemple, « Repère_2 », « Repère_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de recherche de calcul de repère - Onglet Paramètres

Fermé Résultat

Affiche les valeurs d'angle et de coordonnées X,Y calculées.

Fermé Couleur

Spécifie la couleur de l'emplacement du repère calculé : Par défaut (= vert), rouge foncé, vert foncé, jaune foncé, bleu foncé, magenta foncé, cyan foncé, rouge, vert, jaune, bleu, magenta, cyan, gris foncé, gris, noir ou blanc.


Outil de recherche de calcul de repère - Onglets X, Y et Angle

Les onglets X, Y et Angle permettent de créer les formules mathématiques qui définiront les coordonnées X et Y et d'angle du repère.

Remarque : ces contrôles sont désactivés lorsque le système de vision In-Sight est en ligne.
Fermé Expression

La zone de texte Expression permet de créer une formule mathématique capable de traiter les résultats et données de l'outil. Pour rédiger la formule, entrez les données en saisissant, sur le clavier, le nom de la fonction mathématique ou les données du projet/de l'outil ou en utilisant l'arborescence Outils de vision, Mathématiques, Texte et/ou Résultats de vision à gauche, et l'arborescence de symboles de données de projets et d'outils, à droite. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque :
  • Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
  • Lors de la création de formules, EasyBuilder ne décompose pas correctement les noms d'outils qui commencent par une adresse de cellule (par ex. A3_MyTool ou P10_SortTool). Si des expressions doivent être créées pour ces outils, renommez l'outil avant de créer la formule.
Fermé Outils de vision

L'arborescence Outils de vision contient des fonctions de transitions supplémentaires pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Transition, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Transition et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions mathématiques

L'arborescence de fonctions mathématiques contient les fonctions mathématiques pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Mathématiques, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Mathématiques et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions texte

L'arborescence de fonctions texte contient des fonctions permettant de formater les données alphanumériques à afficher et à transmettre, et peut être utilisée pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Texte, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Texte et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Résultats de vision

L'arborescence Résultats de vision contient des données supplémentaires non disponibles par défaut et pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Résultats de vision, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Résultats de vision et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque :
  • La liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
  • EasyBuilder prend uniquement en charge les fonctions de résultats de vision Blobs, Transitions et Modèles.
Fermé Arborescence de symboles de données de projets et d'outils

L'Arborescence de symboles de données de projets et d'outils contient les données de sortie des outils de recherche et/ou d'inspection, ainsi que les lignes d'entrée et des données de projet telles que les paramètres d'acquisition d'images. Les données de projets et d'outils sont des références symboliques aux valeurs figurant dans ces données. Des symboles peuvent être ajoutés à l'Expression par l'une des trois méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée puis cliquez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
  • À l'aide d'un clavier, tapez le nom de la référence symbolique souhaitez directement dans la zone de texte de l'Expression.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer est utilisé pour placer des fonctions mathématiques et des symboles dans l'expression. Sélectionnez la fonction mathématique ou le symbole de votre choix et cliquez sur le bouton Insérer pour l'ajouter dans l'expression.

Remarque : ce contrôle fonctionne en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, le bouton Insérer est activé.
Fermé Boutons de parenthèse gauche, virgule, parenthèse droite

Les boutons de parenthèse gauche, virgule et parenthèse droite sont utilisés pour créer des formules mathématiques. Cliquez sur le bouton approprié pour les insérer dans la formule.

Remarque : ces contrôles fonctionnent en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, les boutons sont activés.


Créer des liens entre les outils de recherche et d'inspection

Lorsque les outils de recherche et/ou d'inspection ont été ajoutés dans le projet, leurs propriétés (paramètres d'entrée et résultats) peuvent être entrelacées sous l'onglet Liens de la palette. L'onglet Liens permet d'utiliser le résultat d'un outil comme paramètre d'entrée pour un autre outil.

Fermé Utilisation de l'onglet Liens

L'onglet Liens de la palette affiche une arborescence de tous les outils de recherche et/ou d'inspection actuellement chargés dans le projet. Les propriétés des outils (paramètres d'entrée et résultats) sont référencées au moyen d'une balise symbolique, qui est une référence symbolique aux valeurs qu'ils contiennent. Chaque valeur est associée à un type de données (Action, Virgule flottante, Entier ou Chaîne).

Les propriétés des outils sont réparties en propriétés d'entrée et de sortie, et les liens ne peuvent être établis que des propriétés de sortie aux propriétés d'entrée. Les propriétés de sortie peuvent être liées à plusieurs propriétés d'entrée distinctes, mais chaque propriété d'entrée ne peut être liée qu'à une propriété de sortie.

Pour sélectionner les propriétés d'outil à afficher et pouvant être configurées sous l'onglet Liens, cliquez avec le bouton droit sur une propriété d'outil et ouvrez la boîte de dialogue Sélectionner les propriétés. La boîte de dialogue Sélectionner les propriétés affiche une arborescence de tous les outils du projet, et toutes les propriétés d'outil associées, d'entrée et de sortie. Vous pouvez personnaliser les propriétés d'outil à afficher sous l'onglet Liens en sélectionnant celles que vous souhaitez voir apparaître (utilisez les boutons Ajouter/Supprimer pour ajouter ou supprimer plusieurs sélections après les avoir mises en surbrillance).

Fermé Contrôles de l'onglet Liens
Contrôles de l'onglet Liens
Ouvre toutes les propriétés d'outil contenues dans le projet.
Ferme toutes les propriétés d'outil contenues dans le projet.

Appuyez sur ce bouton pour basculer entre les trois options d'affichage des propriétés d'outil :

  • Par défaut : affiche uniquement les propriétés d'outil sélectionnées dans le menu Sélectionner les propriétés.
  • Afficher les propriétés standard : affiche un sous-ensemble plus petit des propriétés d'outil, dans lequel les propriétés Description, Inclure_dans_le_succès, ComptErr, Durée_d_exécution, Totaux_échecs, Totaux_succès, État_activé_des_outils et Inverser sont automatiquement masquées.
  • Afficher toutes les propriétés : affiche toutes les propriétés d'outil.

Appuyez sur ce bouton pour basculer entre les trois options de tri :

  • Par défaut : affiche les outils dans l'ordre dans lequel ils ont été ajoutés dans le projet, avec le premier outil ajouté en haut de la liste.
  • Par ordre alphabétique : affiche les outils dans l'ordre alphabétique croissant, en fonction de leur nom.
  • Ordre des dépendances : affiche les outils en fonction des dépendances, avec les propriétés d'entrée placées au-dessus des propriétés de sortie.
Remarque :
  • Si un outil lié à d'autres outils du projet est supprimé, les liens sont automatiquement supprimés.
  • Si un outil dont des propriétés d'entrée et de sortie sont liées est copié et collé dans le projet, seules les propriétés d'entrée sont conservées.
Fermé Création de liens entre des outils

Pour créer des liens entre des propriétés d'entrée et de sortie d'outil, faites glisser le nœud de la propriété de sortie sur le nœud de la propriété d'entrée applicable, ou cliquez avec le bouton droit sur la propriété d'entrée puis sélectionnez la propriété de sortie applicable dans le menu contextuel Lien établi depuis.

Remarque : si les propriétés sont liées par glisser-déplacer, une icône de raccourci s'affiche et une ligne fléchée bleu foncée suit le curseur. Le curseur affiche une icône de blocage si la propriété ne peut pas être liée.

Une fois les propriétés d'outils liées, le paramètre de la propriété d'entrée est grisé et rendu indisponible, avec une icône de lien [image] affichée à droite. Une infobulle indiquant la source du lien s'affiche lorsque l'on passe la souris sur l'icône de lien, et un menu contextuel permettant de supprimer le lien s'ouvre si l'on clique avec le bouton droit sur l'icône de lien.

Remarque : pour annuler un lien créé, cliquez sur le bouton Annuler de la barre d'outils EasyBuilder (ou utilisez CTRL+Z).
Fermé Suppression de liens entre des outils

Pour supprimer des liens entre des propriétés d'entrée et de sortie, sélectionnez la propriété comprenant le lien d'entrée puis appuyez sur la touche SUPPRIMER ou sélectionnez Déconnecter dans le menu contextuel.

Remarque : pour annuler la suppression d'un lien, cliquez sur le bouton Annuler de la barre d'outils EasyBuilder (ou utilisez CTRL+Z).
Fermé Exemple
Fermé Lier un outil d'identification Lire les codes ID à un outil d'identification Lire le texte

Un outil d'identification Lire le texte peut être utilisé pour vérifier si le texte renvoyé par un outil d'identification Lire les codes ID est correct. L'outil d'identification Lire le texte est configuré avec la chaîne de correspondance prévue et le paramètre Mode est défini sur Vérifier. En liant le résultat de Chaîne de l'outil Lire les codes ID au paramètre d'entrée Chaîne_de_correspondance de l'outil Lire le texte, l'outil Lire le texte vérifie si le code inspecté par l'outil Lire les codes ID contient le texte correct.


Inspecter une pièce

L'étape Inspecter une pièce sert à assembler et configurer les Outils d'inspection qui seront utilisés pour créer votre projet. Examinez votre pièce ou l'objet à inspecter et déterminez quels types de caractéristiques se prêtent le mieux aux besoins de votre application et quels Outils d'inspection sont le mieux adaptés à la résolution de votre problème. Pour plus d'informations, consultez Caractéristiques.

Remarque : l'onglet Liens n'est pas pris en charge par les capteurs de vision In-Sight série 2000.

Les outils d'inspection renvoient les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000-110 et 2000-120/120C | État Succès/Échec uniquement
Capteurs de vision In-Sight 2000-130/130C | Outils d'inspection de comptage et de mesure : Résultats standard (données numériques) Outil de présence/absence de modèle : État Réussite/Échec et score de modèle Autres outils : État Succès/Échec uniquement
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Résultats standard (aucune limitation)

Ajout, suppression et modification d’outils d’inspection

Sélection des outils d’inspection

Créer des liens entre les outils de recherche et d’inspection


Ajout, suppression et modification d'outils d'inspection

Fermé Ajout d'un outil

Pour ajouter un outil à votre projet, sélectionnez l'outil voulu dans le groupe Ajouter un outil, puis cliquez sur Ajouter ou double-cliquez sur l'outil. Définissez ensuite la caractéristique dans l'image. Vous pouvez pour cela sélectionner des Smart Features EasyBuilder, ajuster les graphiques de région dans l'image ou positionner des graphiques de référence géométriques.

Une fois la caractéristique définie, vous pouvez régler les contrôles de l'outil en ajustant les différents paramètres.

Remarque : Vous pouvez rechercher des outils de manière dynamique à l'aide de la zone de recherche d'outils.
Fermé Suppression d'un outil

Pour supprimer un outil de votre projet, effectuez simplement l'une des opérations suivantes :

  • Sélectionnez l'outil dans le tableau de résultats (situé sous l'onglet Résultats de la palette) et appuyez sur la touche Suppr de votre clavier.
  • Sélectionnez l'outil dans le tableau de résultats (situé sous l'onglet Résultats de la palette) et cliquez sur l'icône Supprimer de la barre d'outils Standard.
  • Cliquez avec le bouton droit sur l'outil dans le tableau de résultats (situé sous l'onglet Résultats de la palette) et sélectionnez l'option Supprimer dans le menu.
Fermé Modification d'un outil

Pour modifier un outil dans une étape d'EasyBuilder, effectuez simplement l'une des opérations suivantes :

  • Double-cliquez sur l'outil dans le tableau de résultats (situé sous l'onglet Résultats de la palette).
  • Cliquez avec le bouton droit sur l'outil dans le tableau de résultats , puis sélectionnez l'option Afficher et modifier cet outil dans le menu.

Pour modifier un outil dans les étapes Localiser la pièce ou Inspecter une pièce, effectuez simplement l'une des opérations suivantes :

  • Sélectionnez le graphique de région de l'outil dans l'image.
  • Double-cliquez sur l'outil dans le tableau de résultats (situé sous l'onglet Résultats de la palette).
  • Cliquez avec le bouton droit sur l'outil dans le tableau de résultats, puis sélectionnez l'option Afficher et modifier cet outil dans le menu.
  • Double-cliquez sur l'outil dans le tableau de résultats dans l'étape d'application Exécuter le projet.
Remarque :
  • Si votre système de vision In-Sight permet d'accéder à l'environnement de programmation du tableur d'In-Sight Explorer, l'option Afficher cet outil dans le tableur apparaît dans le menu contextuel. N'accédez à l'environnement de programmation du tableur que si vous le connaissez et en comprenez le fonctionnement. Reportez-vous à la rubrique EasyBuilder Jobs and the Spreadsheet (Projets EasyBuilder et le tableur) du fichier d'aide en ligne d'In-Sight Explorer avant de procéder.
  • Les outils peuvent être réorganisés dans le tableau de résultats en les glissant-déposant dans l'ordre souhaité. Cela peut être fait dans le tableau de résultats de l'étape Exécuter le projet comme dans le tableau sous l'onglet Résultats de la palette, et met à jour les deux tableaux. Le tri par glisser-déposer n'est activé que lorsque la colonne Ordre et graphiques de dépendances des outils du tableau est sélectionnée (cette colonne est sélectionnée par défaut). Sélectionnez une nouvelle fois la colonne pour inverser l'ordre. La liste ne peut plus être réorganisée si la limite de taille du projet est proche ou a été atteinte.
Remarque : S'il n'y a pas suffisamment d'espace dans le projet pour ajouter des outils, quittez les étapes d'application Localiser la pièce ou Inspecter la pièce et sélectionnez Limite de la taille du projet, dans le menu Capteur. Dans la boîte de dialogue, réglez la taille du projet afin de pouvoir ajouter davantage d'outils. Le réglage de la limite de taille du projet d'un système de vision In-Sight nécessite le redémarrage du système de vision et entraîne la suppression de l'ensemble des fichiers de projets et de paramètres de la mémoire flash non volatile. Enregistrez ou sauvegardez le projet avant de poursuivre.

Fonctions

Régions

Fonctions automatiques d’EasyBuilder


Caractéristiques

Dans le domaine de la vision industrielle, les caractéristiques sont également appelées « objets d'intérêt de l'image » et les inspections sont conçues en fonction des types de caractéristiques localisées dans l'image.

Types de caractéristiques détectées dans l'étape Inspecter une pièce :

Fermé Transitions

Zones limitrophes entre des pixels sombres et clairs, dans le sens horizontal ou vertical, ou en arcs de cercle ou circulaires. Les transitions peuvent correspondre aux extrémités d'une pièce, aux broches d'un circuit imprimé, aux filets d'une vis, aux fonds de bouteilles ou à la spire d'un ressort. Il s'agit généralement des types de caractéristiques les plus rapides et les plus faciles à détecter.

Fermé Exemple de transitions

Fermé Cercles, lignes et points

Figures géométriques de référence standard, pouvant être utilisées pour effectuer les mesures.

Fermé Exemple de cercles, lignes et points

Fermé Modèles

Un modèle peut incarner différents éléments, depuis un simple groupe de formes répétitives à des configurations complexes telles que des logos ou des étiquettes. Type de caractéristique le plus fiable, les modèles offrent la plus vaste plage de variations de rotation, de déplacement et d'échelle, mais leur inspection demande généralement beaucoup de temps.

Fermé Exemple de modèles

Fermé Blobs

Groupe de pixels sombres ou clairs connectés, tel qu'une tache de peinture blanche sur un arrière-plan noir ou une vis noire sur un convoyeur blanc. Comptant également parmi les caractéristiques que l'on trouve le plus rapidement, ils permettent des variations de forme et de taille de la caractéristique de blob mais ont une valeur d'orientation angulaire limitée.

Fermé Exemple de blobs

Fermé Texte

Chaînes de caractères alphanumériques.

Fermé Exemple de texte

Fermé Codes

Codes barres 1D et codes et symboles de matrices 2D contenant des chaînes de données alphanumériques.

Fermé Exemple de codes

Fermé Filet

Un filet est une paire de transitions continues, mais pas nécessairement fermées, qui marquent la limite entre deux régions de valeurs de pixels différentes, avec une valeur de largeur qui les définit. Par exemple, un chemin de métal soudé, un chemin d'adhésif ou un chemin de produit d'étanchéité sont désignés comme des chemins de « filet ».

Fermé Exemple de filets


Régions

Les régions définissent la zone de l'image dans laquelle l'outil de recherche ou d'inspection exécute son opération, aussi appelée « région d'intérêt ».

Différents types de régions sont utilisées par les outils de recherche et d'inspection dans EasyBuilder, selon le type d'outil utilisé, notamment :

  • Rectangle
  • Cercle
  • Anneau
  • Polygone
  • Région masquée
  • Chemin polylinéaire

Régions annulaires

Régions circulaires

Régions masquées

Régions polygonales

Régions de chemin polylinéaire

Régions rectangulaires


Régions masquées

La région masquée est utilisée pour définir une zone de l'image dans laquelle analyser les transitions. Ce type de région est utilisé en conjonction avec des groupes Caliper pour détecter les transitions de façon précise.

Fermé Légende des régions masquées

Contrôles | Description
1 | Limite de point de terminaison redimensionnable (x4) | Définit les quatre coins de la région rectangulaire. Cliquez sur une limite de point de terminaison pour redimensionner la région à partir de l'un de ses coins.
2 Masque

Définit la zone de l'image qui ne sera PAS analysée. Le masque peut être déplacé et redimensionné dans la région. 99 masques au total peuvent être ajoutés dans une région. Lorsqu'un masque est ajouté, il est inséré au début de la région (si aucun autre masque n'a été ajouté), ou derrière le masque précédemment ajouté.

Remarque : Les masques ne doivent pas se chevaucher. S'ils sont configurés de telle sorte qu'ils se chevauchent, 1 pixel est automatiquement inséré entre eux pour éviter tout chevauchement.
3 | Indicateur de sens de balayage (x2) | Définit le sens dans lequel la région masquée recherche les caractéristiques.
4 | Indicateur de détection de transitions | Définit la zone au sein de la région dans laquelle les transitions seront détectées et permet d'ajouter de nouveaux masques à la région.
5 | Contrôle de rotation | Permet de faire pivoter la région de 360°.
6 | Contrôle de courbure | Permet de courber la région rectangulaire en arc de cercle ou dans une forme circulaire.
Fermé Actions de la souris dans les régions masquées

En plaçant le curseur de la souris sur diverses parties de la région, son icône change automatiquement de forme, permettant les actions suivantes :

Icône du curseur | Description
 | Permet de faire glisser la région masquée complète n'importe où dans l'image.
 | Permet de définir l'échelle de la région complète horizontalement ou verticalement. Également utilisé pour redimensionner le masque.
 | Permet deux actions distinctes selon l'endroit où le curseur de la souris est placé. Lorsque le curseur de la souris est placé sur le contrôle de rotation, vous pouvez faire pivoter la région de 360° par rapport à son orientation actuelle. Lorsque le curseur de la souris est placé sur le contrôle de courbure, vous pouvez transformer la région en un arc de cercle ou dans une forme circulaire pour détecter des caractéristiques de transition circulaires.
 | Permet de faire glisser le masque dans la région.
 | Permet d'ajouter ou de supprimer un masque dans la région. Lorsque cette icône apparaît, cliquez avec le bouton droit de la souris pour ouvrir un menu contenant deux options : Ajouter un masque ou Supprimer un masque.


Régions de chemin polylinéaire

La région de chemin polylinéaire est utilisée pour définir une zone de l'image dans laquelle analyser les transitions. Ce type de région est utilisé conjointement aux groupes Caliper pour détecter les transitions de façon précise.

Remarque :
  • Un menu contextuel est disponible pendant la modification graphique, permettant d'ajouter ou de supprimer un segment de chemin.
  • Le bouton Agrandir la région de la barre d'outils EasyBuilder est désactivé pour la région de chemin polylinéaire.
Fermé Légende des régions de chemin polylinéaire

 | Contrôles | Description
1 | Sommet de chemin polylinéaire (3) | Définit le chemin du ou des segments polylinéaires. Cliquez sur un sommet pour positionner la polyligne.
2 | Indicateur de sens de balayage (2) | Définit le sens dans lequel la région de chemin polylinéaire recherche les caractéristiques.
3 | Chemin polylinéaire | Affiche géographiquement le tracé de la polyligne.
4 | Contrôle de rotation | Permet de faire pivoter la région de 360°.
Fermé Actions de la souris dans les régions de chemin polylinéaire

En plaçant le curseur de la souris sur diverses parties de la région, son icône change automatiquement de forme, permettant les actions suivantes :

Icône du curseur | Description
 | Permet de faire glisser la région de chemin polylinéaire complète n'importe où dans l'image.
 | Permet de définir l'échelle de la région complète horizontalement ou verticalement. Également utilisé pour redimensionner le masque.
 | Permet de faire pivoter la région de 360° par rapport à son orientation actuelle.
 | Permet de déplacer le chemin polylinéaire dans la région.
 | Permet d'ajouter un point au chemin polylinéaire. Jusqu'à 99 points peuvent être ajoutés à une polyligne. Si 99 points ont déjà été ajoutés à une polyligne, cette option est désactivée.


Fonctions automatiques d'EasyBuilder

Les fonctions automatiques d'EasyBuilder (Smart Features, limites automatiques et paramètres automatiques) vous permettent d'accélérer le déploiement de votre application en déterminant automatiquement des valeurs de seuil par défaut basées sur les exigences de l'outil et de l'application.

Remarque : lorsque vous développez une application dans EasyBuilder, utilisez une image de votre pièce ou objet ayant généré un « succès » pour permettre à EasyBuilder de définir les seuils par défaut adaptés à votre application.
  • Smart Features
  • Limites automatiques
  • Paramètres automatiques

Smart Features

Limites automatiques

Paramètres automatiques


Smart Features

Certains outils de recherche et d'inspection affichent automatiquement les caractéristiques de l'image qui présentent un intérêt, selon l'outil sélectionné, vous permettant de sélectionner les caractéristiques adaptées à votre inspection par simple pointer-cliquer.

Lorsque vous ajoutez un de ces outils à votre projet, il examine votre image et détermine automatiquement les caractéristiques qui correspondent à ses paramètres. L'outil de recherche de transition, par exemple, affiche uniquement les transitions horizontales ou verticales, alors que les outils de mesure de diamètre et de concentricité de cercle affichent uniquement les caractéristiques circulaires.

Fermé Exemple
Fermé Smart Features - Transitions

Fermé Smart Features - Cercles

Si une caractéristique n'a pas encore été définie, elle est affichée en bleu. Les caractéristiques déjà présentes (telles que les modèles, centres de gravité de blobs, distances, transitions ou cercles définis par d'autres outils aux étapes Localiser la pièce ou Inspecter une pièce) apparaissent en vert.

Fermé Exemple

Smart Features – Nouvellement détectées et déjà présentes

Cliquez simplement sur la caractéristique que vous souhaitez utiliser : EasyBuilder crée alors automatiquement la région appropriée, s'il n'en existe encore aucune.

Remarque :

si la caractéristique souhaitée n'apparaît sous la forme d'une Smart Feature, effectuez l'une des opérations suivantes :

  • Sélectionnez une Smart Feature disponible et repositionnez la région générée automatiquement à partir de celle-ci sur la caractéristique à utiliser à la place. Réglez ensuite les paramètres de l'outil jusqu'à ce que la caractéristique souhaitée ait été correctement détectée.
  • Définissez, avec l'outil de présence/absence ou géométrique approprié, la caractéristique que vous souhaitez utiliser. Puis ajoutez l'outil et sélectionnez la caractéristique que vous venez de définir.


Limites automatiques

Les outils d'inspection comprenant un onglet Limites de plages déterminent automatiquement les limites Maximum et Minimum.

Remarque : pour utiliser les outils de façon optimale avec les limites automatiques, commencez par les tester sur une bonne image (ayant généré un « succès »).

Lorsqu'un outil comprenant un onglet Limites de plages est ajouté à votre projet, il examine votre image et détermine automatiquement les limites Maximum et Minimum appropriées en fonction de ses propres paramètres. Les limites de plages Maximum et Minimum des outils de mesure de distance et d'angle, par exemple, correspondent à ±5 % des valeurs Distance et Angle, respectivement, alors que les limites de plages des outils de comptage sont définies par le nombre de caractéristiques localisées dans l'image initiale.


Paramètres automatiques

Les outils de recherche et d'inspection qui définissent des cercles et des transitions incrémentent automatiquement le paramètre de contraste jusqu'à ce qu'une caractéristique de transition ait été localisée, vous permettant de définir rapidement les seuils en fonction des besoins de votre application.

Remarque : pour utiliser les outils de façon optimale avec les limites automatiques, commencez par les tester sur une bonne image (ayant généré un « succès »).

Lorsque vous ajoutez un outil de recherche ou d'inspection de cercle ou de transition à votre projet, il examine votre image et détermine automatiquement le paramètre de contraste approprié, puis l'abaisse de deux niveaux pour définir le seuil. Le paramètre de contraste par défaut est défini sur 25, et le minimum sur 5.


Sélection des outils d'inspection

Les outils d'inspection sont regroupés par types :

Fermé Outils de présence/absence

Les outils de présence/absence sont utilisés pour déterminer si une caractéristique est présente ou absente de l'image.

Outils de présence/absence | Systèmes de vision In-Sight (micrologiciel 5.x.x) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Luminosité | X |  | X | X | X | X
Contraste | X |  | X | X | X | X
Modèle PatMax RedLine 1 | X |  |  |  |  |
Modèle PatMax | X |  |  |  |  |
Modèle | X | X | X | X | X | X
Nombre de pixels 2 | X |  | X | X | X | X
Nombre de pixels de couleur 3 | X |  | X | X | X |
Blob 1 | X |  |  |  | X |
Blob de couleur 2 | X |  |  |  | X |
Transition | X |  |  | X | X | X
Cercle | X |  |  | X | X | X
Netteté | X |  |  |  | X |
1Micrologiciel In-Sight 5.x.x uniquement. 2Modèles monochromes uniquement. 3Modèles de couleurs uniquement.
Fermé Outils de mesure

Les outils de mesure sont utilisés pour mesurer les distances, diamètres, angles et surfaces des caractéristiques de l'image.

Outils de mesure | Systèmes de vision In-Sight | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Distance | X |  |  | X | X | X
Angle | X |  |  | X | X | X
Surface de blob 1 | X |  |  |  | X |
Surfaces des blobs (1-10) 1 | X |  |  |  | X |
Surface du blob de couleur 2 | X |  |  |  | X |
Surfaces des blobs de couleur (1-10) 2 | X |  |  |  | X |
Diamètre du cercle | X |  |  | X | X | X
Concentricité du cercle | X |  |  |  |  | X
Mesure du rayon | X |  |  |  | X | X
Points Min./Max. | X |  |  |  |  |
1Modèles monochromes uniquement. 2Modèles de couleurs uniquement.
Fermé Outils de comptage

Les outils de comptage sont utilisés pour compter les types de caractéristiques dans l'image.

Outils de comptage | Systèmes de vision In-Sight | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Blobs 1 | X |  |  |  | X |
Blobs de couleur 2 | X |  |  |  | X |
Transitions | X |  |  | X | X | X
Paires de transitions | X |  |  |  |  |
Modèles PatMax RedLine 3 | X |  |  |  |  |
Modèles PatMax | X |  |  |  |  |
Modèles | X |  |  | X | X | X
1Modèles monochromes uniquement. 2Modèles de couleurs uniquement. 3Micrologiciel In-Sight 5.x.x uniquement.
Fermé Outils d'identification

Les outils d'identification sont utilisés pour identifier et vérifier les codes 1D et 2D et les symboles, les caractères alphanumériques, les caractéristiques de modèle et les couleurs dans l'image.

Outils d'identification | Systèmes de vision In-Sight (micrologiciel 5.x.x) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Lire le code 1D | X |  |  |  |  |
Lire les codes 1D (1-20) | X |  |  |  |  |
Lire le code 2D | X |  |  |  |  |
Lire les codes 2D (1-20) | X |  |  |  |  |
Lire le code postal | X |  |  |  |  |
Lire codes ID 1 |  |  |  |  |  |
Lire texte 1 |  |  |  |  |  |
Lire le texte (OCRMax) | X |  |  |  | X |
Modèles PatMax RedLine (1-10) 2 | X |  |  |  |  |
Modèles PatMax (1-10) | X |  |  |  |  |
Modèles (1-10) | X |  |  |  | X |
Couleur 3 | X |  |  |  |  |
Modèle de couleurs 2 | X |  |  |  |  |
1Lire les codes ID et Lire le texte sont des outils hérités non pris en charge par les systèmes qui exécutent In-Sight Explorer 4.7.0 ou les versions ultérieures. 2Micrologiciel In-Sight 5.x.x uniquement. 3Modèles de couleurs uniquement.
Fermé Outils géométriques

Les outils géométriques sont utilisés pour créer des figures géométriques de référence dans l'image, qui peuvent être utilisées par d'autres outils d'inspection tels que les outils mathématiques logiques et les outils de mesure.

Outils géométriques | Systèmes de vision In-Sight | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Point à point : Ligne | X |  |  |  | X | X
Point à point : Point médian | X |  |  |  | X | X
Point à point : Dimension | X |  |  |  | X | X
Ligne perpendiculaire | X |  |  |  |  | X
Intersection de lignes | X |  |  |  | X | X
Bissectrice de l'angle | X |  |  |  |  | X
Ligne à partir de N points | X |  |  |  |  | X
Cercle à partir de N points | X |  |  |  |  | X
Intersection de lignes circulaires | X |  |  |  |  | X
Point défini par l'utilisateur | X |  |  |  |  | X
Ligne définie par l'utilisateur | X |  |  |  |  | X
Ajustement du cercle | X |  |  |  |  |
Ajustement de la ligne | X |  |  |  |  |
Fermé Outils mathématiques & logiques

Les outils mathématiques et logiques sont utilisés pour lier les outils de manière conditionnelle en fonction des données de projets et d'outils, exécuter des opérations mathématiques sur les sorties des outils, traiter les statistiques des outils, regrouper des outils et créer des étapes pour l'ordre des opérations.

Outils mathématiques & logiques | Systèmes de vision In-Sight | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Mathématiques | X |  |  |  | X | X
Logique | X | X | X | X | X | X
Tendance | X |  |  |  |  | X
Statistiques | X |  |  |  |  | X
Groupe | X |  |  | X | X | X
Séquence | X |  |  |  |  |
Calcul du point | X |  |  |  |  | X
Variables | X |  |  |  | X | X
Guidage de robot | X |  |  |  |  |
Fermé Outils de tracé

Les outils de tracé sont utilisés pour tracer des graphiques dans l'image à l'aide d'expressions mathématiques.

Outils de tracé | Systèmes de vision In-Sight | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Arc | X |  |  |  | X | X
Cercle | X |  |  |  | X | X
Croix | X |  |  |  | X | X
Ligne | X |  |  |  | X | X
Point | X |  |  |  | X | X
Région | X |  |  |  | X | X
Chaîne | X |  |  |  | X | X
Fermé Outils de filtre d'image

Les outils de filtre d'image sont utilisés pour améliorer une image ou une zone d'une image à des fins d'analyse plus poussée.

Outils de filtre d'image | Systèmes de vision In-Sight (micrologiciel 5.x.x) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Filtre | X |  |  |  | X |
Voisin 1 |  |  |  |  |  |
Correction de scène 1 |  |  |  |  |  |
Point 1 |  |  |  |  |  |
Couleur -> niveaux de gris 2 | X |  |  |  |  |
Couleur -> binaire 2 | X |  |  |  |  |
Transformer | X |  |  |  |  |
Comparer | X |  |  |  |  |
1Pris en charge uniquement sur les systèmes de vision In-Sight avec un micrologiciel de version 4.x.x. 2Modèles de couleurs uniquement.
Fermé Outils de détection des défauts

Les outils de détection des défauts sont utilisés pour déterminer si une pièce ou un objet présente un défaut, tel qu'une fêlure, un pli, une entaille, un écart, une égratignure ou une rayure.

Remarque : Les Outils de détection des défauts sont pris en charge uniquement sur les systèmes de vision In-Sight.
  • Défaut de surface
  • Transition
  • Paire de transitions
  • Largeur de transition
  • Détecteur de filet
  • Contrôleur de filet
Fermé Outils de calibrage

Les outils de calibrage permettent de créer un fichier de calibrage qui peut être utilisé dans plusieurs projets.

Outils de calibrage | Systèmes de vision In-Sight | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Robot | X |  |  |  |  |
Point N | X |  |  |  |  | X
Point N séquentiel | X |  |  |  |  |

Outils de présence/absence

Outils de mesure

Outils de comptage

Outils d’identification

Outils géométriques

Outils mathématiques & logiques

Outils de tracé

Outils de filtre d’image

Outils de calibrage


Outils de présence/absence - Luminosité

L'outil de présence/absence de luminosité détermine si une caractéristique est présente ou absente, en fonction d'une valeur moyenne d'échelle de gris (c'est-à-dire luminosité) des pixels dans la région, puis rapporte cette valeur.

Cet outil renvoie les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000 Séries 1XX (110, 120, 130) | État Succès/Échec uniquement
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Résultats standard (aucune limitation)

L'outil de présence/absence de luminosité est utile dans les cas où une caractéristique d'une pièce conforme est plus foncée ou plus claire que la caractéristique d'une pièce non conforme. Les augmentations ou diminutions de luminosité d'une caractéristique représentent une bonne indication de la présence ou de l'absence d'une pièce ou d'un objet. Par exemple, il est facile de mesurer rapidement si une capsule de bouteille de couleur claire ou foncée est présente ou absente grâce à la luminosité de la région.

Astuce : Pour plus d'informations sur la sélection d'une caractéristique, consultez Sélection d'une caractéristique.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de présence/absence de luminosité

Une fois l'outil ajouté, sélectionnez le type de région et configurez cette dernière dans l'image pour isoler votre caractéristique :

  1. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région sur la caractéristique et assurez-vous que les limites de la région couvrent la caractéristique. Les limites doivent être configurées de façon à englober uniquement la caractéristique que vous souhaitez mesurer - si la région est plus grande que la caractéristique, les résultats peuvent être altérés puisque les pixels de l'arrière-plan sont également calculés. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la ou des caractéristique(s) reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

    Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Sélection d’une caractéristique


Sélection d'une caractéristique

Lorsque vous choisissez une caractéristique pour une inspection, tenez compte des instructions suivantes pour garantir des résultats optimaux :

  • Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la caractéristique reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel de la caractéristique.
  • L'outil de luminosité s'avère utile dans des applications où la caractéristique inspectée correspond à une valeur de niveau de gris lorsqu'elle est présente (noir, par exemple), et à l'opposé lorsqu'elle est absente.
Fermé Exemple


Réglage des paramètres de l'outil de présence/absence de luminosité

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Capteurs de vision In-Sight série 2000

  • Zone de groupe Outil d'édition

Systèmes de vision In-Sight

Le volet de paramètres de l'outil de présence/absence de luminosité comprend les onglets suivants :

  • Onglet Général
  • Onglet Limites de plages
  • Onglet Histogramme
  • Onglet Région composite
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Capteurs de vision In-Sight série 2000

Systèmes de vision In-Sight

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

Aide EasyBuilder | 08/29/2022 | Revision: 5.9.0.2


Réglage des paramètres de l'outil de présence/absence de luminosité

Remarque : Cette rubrique décrit l'interface utilisateur en étant connecté à un capteur de vision In-Sight série 2000. En cas de connexion aux systèmes de vision In-Sight, voir la section Système de vision In-Sight de Réglage des paramètres de l'outil de présence/absence de luminosité.

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Fermé Indicateur de succès/échecs

Affiche un cercle vert [image] ou un rectangle rouge [image] pour représenter respectivement les succès et les échecs.

Fermé Curseur Compteur de luminosité et plage de succès

Définit le niveau de luminosité maximal et minimal. Vous pouvez définir manuellement les valeurs en ajustant les poignées ou en saisissant des valeurs dans les zones d'édition correspondantes.

Astuce : vous pouvez également déplacer la poignée à l'aide des touches des FLÈCHES (HAUT, BAS, DROITE et GAUCHE).
  • Poignée gauche : Définit la limite moyenne d'échelle de gris minimale acceptable (0 à 255).
  • Poignée droite : Définit la limite moyenne d'échelle de gris maximale acceptable (0 à 255).
  • Indicateur de résultat : Affiche la valeur moyenne d'échelle de gris des pixels dans la région. Si l'indicateur est entre les poignées gauche et droite, l'outil obtient un succès et l'indicateur de résultat est vert. Sinon, l'outil obtient un échec et l'indicateur de résultat est rouge.
SUCCÈS
ÉCHEC
Remarque : Les valeurs Résultat et Plage de succès s'affichent en survolant le curseur avec le pointeur de la souris.
Fermé Bouton Automatique

Définit automatiquement les limites de plage pour qu'elles correspondent au résultat le plus récent de l'outil, +/- 10 % de la valeur maximale du résultat de l'outil. Par exemple, si la valeur maximale du résultat de l'outil est 255 et le résultat le plus récent 150, un clic sur le bouton Automatique définit la limite minimale de la plage à 125 (=150 - 25) et la limite maximale de la plage à 175 (=150 + 25).

Fermé Inverser le résultat

Lorsque l'option est activée, l'outil échoue si le résultat est dans les limites de la plage. (Par défaut = Désactivé)

Succès/échec | (Inverser) | Succès/échec
Succès/échec | (Inverser) | Succès/échec
Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Nom

Définit le nom de l'outil de luminosité. Le nom par défaut est Luminosité_1 (si c'est le premier outil Modèle ajouté au projet, sinon, il est incrémenté, par exemple, Luminosité_2, Luminosité_3, etc.).

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Activé

Définit si l'outil d'inspection doit s'exécuter et à quel moment (le paramètre par défaut est Activé).

  • Sélectionnez "Désactivé" pour désactiver l'outil.
  • Sélectionnez une ligne d'entrée pour que l'outil soit associé à une ligne d'entrée discrète spécifique, où il peut être activé ou désactivé (un signal élevé 1 signifie activé, un signal faible 0 signifie désactivé). La connexion de l'outil à une entrée permet à un système de contrôle, un PLC par exemple, de déterminer quels outils doivent s'exécuter, et à quel moment.
Fermé Repère

Sélectionne un repère pour l'outil. Le bouton Repère devient orange quand le contrôle de repère est activé.

Remarque : ce contrôle peut être activé uniquement si un autre outil qui définit un repère a déjà été ajouté.
Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de présence/absence de luminosité - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Luminosité_1 » s'il s'agit du premier outil de Luminosité ajouté au projet. Sinon, il est incrémenté (par exemple, « Luminosité_2 », « Luminosité_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de présence/absence de luminosité - Onglet Limites de plages

Fermé Minimum

Définit la valeur moyenne de niveaux de gris minimale acceptable (0 à 255). L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Luminosité

Renvoie la valeur moyenne de niveaux de gris des pixels détectés dans la région (0 à 255). Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Fermé Maximum

Définit la valeur moyenne de niveaux de gris maximale acceptable (0 à 255). L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux limites de plages.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux limites de plages.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outil de présence/absence de luminosité - Onglet Histogramme

L'onglet Histogramme affiche un histogramme des valeurs de niveau de gris des pixels dans la région.

  • L'axe X du graphique représente le nombre total de valeurs de niveau de gris (0 à 255, ou 256 nuances de gris au total).
  • L'axe Y du graphique représente le nombre de pixels pour une valeur de niveau de gris donnée, l'échelle est établie en affichant la valeur de niveau de gris avec le plus grand nombre de pixels.
  • Les trois lignes bleues verticales indiquent respectivement la valeur minimum de niveau de gris des pixels, la luminosité et la valeur maximum de niveau de gris des pixels.
Remarque : Le graphique s'affiche sans tenir compte de l'état En ligne/Hors ligne et de l'état succès/échec de l'outil. Cependant, si l'outil est en échec, il est possible que le graphique ne soit pas mis à jour.


Outil de présence/absence de luminosité - Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils de présence/absence - Contraste

L'outil de présence/absence de contraste détermine si une caractéristique est présente ou absente, en se basant sur la valeur du contraste (différence entre la valeur d'échelle de gris moyenne supérieure au seuil et la valeur d'échelle de gris moyenne inférieure au seuil) entre les caractéristiques des pixels dans la région, puis rapporte cette valeur.

Cet outil renvoie les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000 Séries 1XX (110, 120, 130) | État Succès/Échec uniquement
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Résultats standard (aucune limitation)

L'outil de présence/absence de contraste est utile dans les cas où la caractéristique d'une pièce conforme comporte des zones claires et/ou foncées très distinctes par rapport à celles d'une pièce non conforme. Par exemple, vérification de la présence d'impressions foncées sur une étiquette blanche.

Astuce : Pour plus d'informations sur la sélection d'une caractéristique, consultez Sélection d'une caractéristique.

Configuration de l’outil


Configuration de l'outil de présence/absence de contraste

Une fois l'outil ajouté, sélectionnez le type de région et configurez cette dernière dans l'image pour isoler votre caractéristique :

  1. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région sur la caractéristique et assurez-vous que les limites de la région couvrent la caractéristique. Les limites doivent être configurées de façon à englober uniquement la caractéristique que vous souhaitez mesurer - si la région est plus grande que la caractéristique, les résultats peuvent être altérés puisque les pixels de l'arrière-plan sont également calculés. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la ou des caractéristique(s) reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

    Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Sélection d’une caractéristique

Réglage des paramètres de l’outil


Sélection d'une caractéristique

Lorsque vous choisissez une caractéristique pour une inspection, tenez compte des instructions suivantes pour garantir des résultats optimaux :

  • Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la caractéristique reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel de la caractéristique.
  • L'outil de contraste s'avère utile dans des applications où la caractéristique inspectée contient des niveaux de gris mélangés lorsqu'elle est présente, et un ensemble uniforme de niveaux de gris lorsqu'elle est absente.
  • Si vous devez distinguer de façon plus subtile les différences de luminosité et de contraste, vous pouvez utiliser l'outil de comptage de pixels. Il évalue ces différences de façon plus précise que l'outil de contraste.
Fermé Exemple


Réglage des paramètres de l'outil de présence/absence de contraste

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Capteurs de vision In-Sight série 2000

  • Zone de groupe Outil d'édition

Systèmes de vision In-Sight

Le volet de paramètres de l'outil de présence/absence de contraste comprend les onglets suivants :

  • Onglet Général
  • Onglet Limites de plages
  • Onglet Histogramme
  • Onglet Région composite
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Capteurs de vision In-Sight série 2000

Systèmes de vision In-Sight

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

Aide EasyBuilder | 08/29/2022 | Revision: 5.9.0.2


Réglage des paramètres de l'outil de présence/absence de contraste

Remarque : Cette rubrique décrit l'interface utilisateur en étant connecté à un capteur de vision In-Sight série 2000. En cas de connexion aux systèmes de vision In-Sight, voir la section Système de vision In-Sight de Réglage des paramètres de l'outil de présence/absence de contraste.

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Fermé Indicateur de succès/échecs

Affiche un cercle vert [image] ou un rectangle rouge [image] pour représenter respectivement les succès et les échecs.

Fermé Curseur Compteur de contraste et plage de succès

Définit le niveau de contraste maximal et minimal. Vous pouvez définir manuellement les valeurs en ajustant les poignées ou en saisissant des valeurs dans les zones d'édition correspondantes.

Astuce : vous pouvez également déplacer la poignée à l'aide des touches des FLÈCHES (HAUT, BAS, DROITE et GAUCHE).
  • Poignée gauche : Définit la limite moyenne d'échelle de gris minimale acceptable (0 à 255).
  • Poignée droite : Définit la limite moyenne d'échelle de gris maximale acceptable (0 à 255).
  • Indicateur de résultat : Affiche la valeur moyenne d'échelle de gris des pixels dans la région. Si l'indicateur est entre les poignées gauche et droite, l'outil obtient un succès et l'indicateur de résultat est vert. Sinon, l'outil obtient un échec et l'indicateur de résultat est rouge.
SUCCÈS
ÉCHEC
Remarque : Le résultat s'affiche en survolant le curseur avec le pointeur de la souris.
Fermé Bouton Automatique

Définit automatiquement les limites de plage pour qu'elles correspondent au résultat le plus récent de l'outil, +/- 10 % de la valeur maximale du résultat de l'outil. Par exemple, si la valeur maximale du résultat de l'outil est 255 et le résultat le plus récent 150, un clic sur le bouton Automatique définit la limite minimale de la plage à 125 (=150 - 25) et la limite maximale de la plage à 175 (=150 + 25).

Fermé Inverser le résultat

Lorsque l'option est activée, l'outil échoue si le résultat est dans les limites de la plage. (Par défaut = Désactivé)

Succès/échec | (Inverser) | Succès/échec
Succès/échec | (Inverser) | Succès/échec
Fermé Nom

Définit le nom de votre outil d'inspection. Le nom par défaut est Contraste_1 (si c'est le premier outil Modèle ajouté au projet, sinon, il est incrémenté, par exemple, Contraste_2, Contraste_3, etc.).

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Activé

Définit si l'outil d'inspection doit s'exécuter et à quel moment (le paramètre par défaut est Activé).

  • Sélectionnez "Désactivé" pour désactiver l'outil.
  • Sélectionnez une ligne d'entrée pour que l'outil soit associé à une ligne d'entrée discrète spécifique, où il peut être activé ou désactivé (un signal élevé 1 signifie activé, un signal faible 0 signifie désactivé). La connexion de l'outil à une entrée permet à un système de contrôle, un PLC par exemple, de déterminer quels outils doivent s'exécuter, et à quel moment.
Fermé Repère

Sélectionne un repère pour l'outil. Le bouton Repère devient orange quand le contrôle de repère est activé.

Remarque : ce contrôle peut être activé uniquement si un autre outil qui définit un repère a déjà été ajouté.
Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de présence/absence de contraste - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Contraste_1 » s'il s'agit du premier outil de contraste ajouté au projet. Sinon, il est incrémenté (par exemple, « Contraste_2 », « Contraste_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de présence/absence de contraste - Onglet Limites de plages

Fermé Maximum

Définit la valeur de contraste maximale acceptable (0 à 255). L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Contraste

Renvoie la différence entre les valeurs moyennes de niveaux de gris au-dessus et au-dessous du seuil automatique créé par l'outil, détectées dans la région. Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Fermé Minimum

Définit la valeur de contraste minimale acceptable (0 à 255). L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux limites de plages.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux limites de plages.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outil de présence/absence de contraste - Onglet Histogramme

L'onglet Histogramme affiche un histogramme des valeurs de niveau de gris des pixels dans la région.

  • L'axe X du graphique représente le nombre total de valeurs de niveau de gris (0 à 255, ou 256 nuances de gris au total).
  • L'axe Y du graphique représente le nombre de pixels pour une valeur de niveau de gris donnée, l'échelle est établie en affichant la valeur de niveau de gris avec le plus grand nombre de pixels.
  • Les trois lignes bleues verticales indiquent respectivement la valeur moyenne de niveau de gris en dessous du seuil, le seuil et la valeur de niveau de gris moyenne au dessus du seuil.
Remarque : Le graphique s'affiche sans tenir compte de l'état En ligne/Hors ligne et de l'état succès/échec de l'outil. Cependant, si l'outil est en échec, il est possible que le graphique ne soit pas mis à jour.


Outil de présence/absence de contraste - Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils de présence/absence - Modèle PatMax RedLine et modèle PatMax

Remarque :
  • À partir du micrologiciel In-Sight firmware 5.5.0 et versions ultérieures, l'algorithme de l'outil a été modifié afin de renvoyer des résultats plus précis et de réduire la durée d'exécution dans certains cas.
  • En raison de cette modification, un message d'erreur s'affiche lors d'une tentative de chargement d'un projet contenant cet outil configuré selon le micrologiciel In-Sight version 5.5.0 ou ultérieure sur un système de vision In-Sight exécutant le micrologiciel In-Sight version 5.4.x ou antérieure.
  • L'outil de recherche de modèle PatMax RedLine et l'outil de recherche de modèles PatMax RedLine (1-10) sont uniquement disponibles sur des systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.2.0 et ultérieures.

L'outil de modèle PatMax RedLine et l'outil de présence/absence de modèle PatMax sont utilisés pour déterminer la présence ou l'absence d'une caractéristique de modèle via l'algorithme PatMax RedLine ou PatMax, en fonction d'une représentation apprise de ce modèle (appelée un Modèle).

Ces outils sont utiles lorsque la caractéristique d'une pièce conforme dispose d'un modèle identifiable absent sur des pièces non conformes ou vice-versa. Par exemple, si vous essayez de vérifier si un montage mécanique dispose d'un modèle de tête de vis Philips.

Configuration des outils

Réglage des paramètres des outils


Configuration des outils de présence/absence de modèle PatMax RedLine et de modèle PatMax

Après avoir ajouté l'outil, sélectionnez le type des régions et configurer ces dernières pour définir votre modèle (la région Modèle) et l'emplacement du modèle dans l'image (la région Recherche).

  1. Dans le menu déroulant Modèle, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Placez ensuite la région de Modèle sur le modèle utilisé comme modèle d'apprentissage ; assurez-vous que la région de Modèle ne couvre que les caractéristiques importantes du modèle.Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Dans le menu déroulant Recherche, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Puis positionnez la région Recherche de manière à ce qu'elle recouvre les zones de l'image dans lesquelles la forme peut apparaître. Pour optimiser l'exécution de l'outil, créez des régions Recherche de petite taille. Plus la région Recherche est étendue, plus l'outil mettra de temps à effectuer l'inspection.
  3. Cliquez sur le bouton OK pour confirmer les régions (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  4. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  5. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Modèle PatMax RedLine, modèle PatMax et modèle

Sélection d’un modèle


Modèle PatMax RedLine, modèle PatMax et modèle

Remarque : L'outil de présence/absence de modèle PatMax RedLine est uniquement disponible sur des systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.2.0 et ultérieures.

Les modèles PatMax RedLine, les modèles PatMax et les modèles localisent des modèles de forme appris et proposent la plus grande précision parmi les outils de recherche et d'inspection. Cependant les modèles de PatMax RedLine et les modèles de PatMax sont plus performants que les modèles, modifiant considérablement les conditions d'éclairage et la position du modèle. Ils permettent également de mieux reconnaître les modifications apportées à l'échelle et à la rotation du modèle, l'occlusion des éléments du modèle et les modifications apportées à l'apparence du modèle, en raison des variations d'éclairage.

La vitesse constitue la principale différence entre les modèles PatMax RedLine et les modèles PatMax ; le modèle PatMax RedLine utilise le modèle le plus récent correspondant à l'algorithme et permet de localiser des caractéristiques apprises dans une image mégapixel 5, 7 fois plus rapidement que les modèles PatMax. Les modèles PatMax RedLine conviennent donc pour des systèmes de vision de haute résolution.

Les modèles (dans la plupart des cas) sont plus rapides que PatMax, mais certains cas nécessitent la précision et la fiabilité de la version PatMax RedLine ou PatMax :

  • Lorsque les variations d'éclairage et de reflets sont difficiles à contrôler. Par exemple, des pièces en métal peuvent réfléchir la lumière dans des directions aléatoires.
  • Lorsque le modèle inspecté présente une forme ou une ombre similaire par rapport à un élément en arrière-plan, ou le modèle est superposé ou partiellement caché par d'autres objets dans l'image.
  • Lorsque vous souhaitez reconnaître avec précision un type de modèle parmi d'autres modèles, des modèles identiques.
  • Lorsque les conditions de votre environnement de déploiement sont trop exigeantes pour l'outil Modèle, en termes de cohérence et de fiabilité.


Réglages des paramètres de l'outil de présence/absence de modèle PatMax RedLine et de modèle PatMax

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres des outils de présence/absence de modèle PatMax et de modèle PatMax RedLine comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglets Modèle et Recherche
  • Onglet Image d'apprentissage
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglets Modèle et Recherche

Onglet Image d’apprentissage


Outil de présence/absence de modèle PatMax RedLine et de modèle PatMax - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Modèle_1 » s'il s'agit du premier outil de modèle ajouté au projet. Sinon, il est incrémenté (par exemple, « Modèle_2 », « Modèle_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outils de modèle PatMax RedLine et de Présence/absence de modèle PatMax - Onglet Paramètres

Fermé Seuil d'acceptation

Définit le degré de similitude qui doit exister entre le modèle de forme et le modèle localisé (0 à 100 ; valeur par défaut = 50). Les modèles localisés affichant une valeur supérieure ou égale au seuil défini sont considérés comme correspondants. Cet outil s'exécute plus rapidement lorsque ce paramètre est élevé, ce qui requiert également un degré de similitude plus important entre le modèle de forme et le modèle localisé. Moins les paramètres sont élevés, moins les résultats seront précis. Des modèles semblables seront détectés, mais pas par rapport au modèle de forme.

Fermé Seuil de contraste

Définit le contraste minimum acceptable qui doit être défini dans le modèle identifié ; le contraste pour un modèle identifié doit être supérieur à la valeur Seuil de contraste à considérer comme une instance valide. La valeur par défaut pour le(s) modèle(s) PatMax RedLine est 0 et la plage valide de paramètres est 0-100. La valeur par défaut pour le(s) modèle(s) PatMax est 10 et la plage valide de paramètres est 0-255. Une faible valeur Seuil de contraste est utilisée pour des images peu contrastées, alors qu'une valeur élevée Seuil de contraste est utilisée pour des images extrêmement contrastées.

Remarque : Le contraste de modèle(s) PatMax RedLine désigne la mesure « relative » d'une modification de contraste entre les caractéristiques du modèle appris et les caractéristiques de correspondance de l'image de recherche, en pourcentage. Ainsi si le contraste de caractéristique est supérieur ou égal au contraste de modèle, le contraste rapporté sera ~100. Si le contraste de caractéristique est inférieur au contraste de modèle, le contraste rapporté sera <100. Le contraste de modèle(s) PatMax RedLine est différent du contraste de modèle(s) PatMax qui représente le contraste d'image « absolu » de la région d'intérêt de recherche, en niveau de gris
Fermé Tolérance angulaire

Définit dans quelle mesure le modèle localisé peut pivoter par rapport à la position du modèle de forme, tout en étant identifié comme un modèle valide (± 0 à 180° ; valeur par défaut = 15°). Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps.

Fermé Tolérance en échelle

Définit le pourcentage autorisé de mise à l'échelle (variations de taille) entre le modèle identifié et le modèle de forme (0-50 ; par défaut = 0). La valeur représente un pourcentage plus ou moins, par exemple une valeur 5 déclenchera l'outil de recherche de modèles dont la taille est comprise entre 95 % et 105% du modèle de forme. Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps.

Fermé Mode de recherche

Définit le mode de recherche utilisé pour les modèles d'apprentissage et de reconnaissance, PatMax ou PatQuick. L'option PatMax est sélectionnée par défaut. PatMax propose une plus grande précision que PatQuick mais nécessite un temps d'exécution plus long alors que PatQuick propose une plus faible précision que PatMax mais nécessite un temps d'exécution moins long.

Fermé Scores stricts

Définit si des caractéristiques manquantes ou cachées du modèle trouvé affecteront le score (par défaut = Off, décoché). Lorsque Score strict est appliqué (Activé, coché), si les caractéristiques du modèle sont absentes ou bloquées, le score du modèle trouvé sera plus faible.

Fermé Score strict

Définit si des caractéristiques manquantes ou cachées du modèle trouvé affecteront le score (par défaut = Off, décoché). Lorsque Score strict est appliqué (Activé, coché), si les caractéristiques du modèle sont absentes ou bloquées, le score du modèle trouvé sera plus faible.

Fermé Ignorer la polarité

Définit si des modèles localisés peuvent ou non contenir des caractéristiques de correspondance avec inversion des couleurs par rapport au modèle de forme (option désactivée par défaut). Lorsque le paramètre Ignorer la polarité est appliqué (option cochée), les modèles détectés avec des caractéristiques d'inversion des couleurs, comme noir/blanc et blanc/noir dans le modèle de forme, par exemple, sont considérés comme correspondants au modèle de forme.

Fermé Inverser
Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Délai d'attente
Définit la durée, en millisecondes (0 à 30 000), pendant laquelle l'outil recherche le(s) modèle(s) avant que l'exécution ne soit interrompue et que l'outil ne renvoie un échec. Par défaut, ce paramètre est réglé sur 5 000.
Fermé Résultat

Affiche le résultat de l'outil : Présent si la caractéristique du modèle a été détectée et qu’un score indique le niveau de similarité du modèle avec le Modèle de forme ; Absent(e) si cette caractéristique est introuvable ou si plusieurs instances du modèle ont été détectées. Présent équivaut à une valeur booléenne de 1 (succès) ; Absent(e) équivaut à une valeur booléenne de 0 (échec).

Remarque : Le(s) modèle(s) PatMax RedLine ne contient/contiennent pas le paramètre Mode de recherche.


Outils de présence/absence de modèle PatMax RedLine et de modèle PatMax - Onglets Modèle et Recherche

Les onglets Modèle et Recherche sont utilisés pour configurer la région composite pour les régions Modèle et Recherche de l'outil. Les régions composite sont un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Dans l'onglet Modèle, les régions composite sont activées uniquement après avoir cliqué sur le bouton Région modèle.
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).
Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils de présence/absence de modèle PatMax RedLine et de modèle PatMax - Onglet Image d'apprentissage

L'image affichée sous l'onglet Image d'apprentissage est une miniature du modèle de forme. Cliquez sur le bouton Région du modèle pour redimensionner ou déplacer la région, puis sur le bouton Apprendre pour apprendre à nouveau le modèle de forme.


Outils de présence/absence - Modèle

L'outil présence/absence de modèle sert à déterminer la présence ou l'absence d'une caractéristique de modèle, d'après une représentation apprise de ce modèle (nommée Modèle).

L'outil présence/absence de modèle est pratique dans des situations où la caractéristique d'une partie correcte possède un modèle reconnaissable qui n'est pas présent sur les mauvaises parties, ou vice versa. Par exemple, si vous essayez de vérifier si un tournevis cruciforme est présent ou non dans un ensemble mécanique.

Cet outil renvoie les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000-110 et 2000-120/120C | État Succès/Échec uniquement
Capteur de vision In-Sight 2000-130/130C | État Réussite/Échec et score de modèle
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Résultats standard (aucune limitation)

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de présence/absence de modèle

Après avoir ajouté l'outil, configurez les régions de l'image définissant votre modèle (la région Modèle) et l'emplacement du modèle dans l'image (la région Recherche).

  1. Positionnez la région Modèle sur le modèle qui sera utilisé comme forme d'apprentissage. Assurez-vous que la région Modèle recouvre uniquement les caractéristiques importantes du modèle.

  2. Positionnez la région Recherche de manière à ce qu'elle recouvre les zones de l'image dans lesquelles la forme peut apparaître. Pour optimiser l'exécution de l'outil, créez des régions Recherche de petite taille. Plus la région Recherche est étendue, plus l'outil mettra de temps à effectuer l'inspection.

    Remarque : les régions Modèle et Recherche ne peuvent pas être courbées en arc de cercle ou dans une forme circulaire.
  3. Cliquez sur le bouton OK pour confirmer les régions (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de présence/absence de modèle

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Capteurs de vision In-Sight série 2000

  • Zone de groupe Outil d'édition

Systèmes de vision In-Sight

Le volet de paramètres de l'outil de présence/absence de modèle comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Image d'apprentissage
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Capteurs de vision In-Sight série 2000

Systèmes de vision In-Sight

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

Aide EasyBuilder | 08/29/2022 | Revision: 5.9.0.2


Réglage des paramètres de l'outil de présence/absence de modèle

Remarque :
  • Cette rubrique décrit l'interface utilisateur en étant connecté à un capteur de vision In-Sight série 2000. En cas de connexion aux systèmes de vision In-Sight, voir la section Système de vision In-Sight de Réglage des paramètres des outils de recherche de modèle et de modèles (1-10).
  • Si vous essayez de charger un projet contenant cet outil configuré sur un micrologiciel In-Sight de version 5.7.0 ou ultérieure sur un système de vision In-Sight dont le micrologiciel est de la version 5.6.x ou antérieure, un message d'erreur s’affiche et le chargement du projet échoue.

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Fermé Indicateur de succès/échecs

Affiche un cercle vert [image] ou un rectangle rouge [image] pour représenter respectivement les succès et les échecs.

Fermé Tolérance angulaire

Définit dans quelle mesure le modèle trouvé peut pivoter par rapport à la position du modèle appris, tout en étant toujours identifié comme un modèle valide (± 0 à 180° ; valeur par défaut = ±45°). Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps. La poignée gauche définit la tolérance angulaire négative et la poignée droite définit la tolérance angulaire positive. Vous pouvez régler la tolérance angulaire en ajustant les poignées ou en saisissant des valeurs dans les zones d'édition correspondantes.

Astuce : vous pouvez également déplacer la poignée à l'aide des touches des FLÈCHES (HAUT, BAS, DROITE et GAUCHE).
Fermé Compteur de localisation de pièce

Le compteur de localisation de pièce affiche le degré d'exactitude de l'outil pour trouver la caractéristique et définit le seuil d'acceptation minimal. Vous pouvez définir manuellement la valeur du seuil d'acceptation minimal (0 à 100, valeur par défaut = 50) en réglant la poignée ou en saisissant une valeur dans la zone d'édition correspondante.

Astuce : vous pouvez également déplacer la poignée à l'aide des touches des FLÈCHES (HAUT, BAS, DROITE et GAUCHE).

Si le compteur est supérieur au seuil, l'outil considère la pièce comme trouvée et le compteur devient vert. S'il est inférieur au seuil, il considère la pièce comme non trouvée et le compteur disparait. Si l'outil détecte des choses qui ne correspondent pas aux pièces ou la mauvaise caractéristique, déplacez la poignée vers la droite. Si l'outil ne détecte pas certaines pièces, déplacez la poignée vers la gauche (ou créez une nouvelle Région du modèle). Moins les paramètres sont élevés, moins les résultats seront précis. Des modèles semblables seront détectés, mais pas par rapport au modèle de forme.

SUCCÈS
ÉCHEC
Remarque : Les valeurs de résultat et de seuil s'affichent en survolant le curseur avec le pointeur de la souris.
Fermé Inverser le résultat

Lorsque l'option est activée, l'outil échoue si le résultat est dans les limites de la plage. (Par défaut = Désactivé)

Succès/échec | (Inverser) | Succès/échec
Succès/échec | (Inverser) | Succès/échec
Fermé Tolérance en échelle de ± 10 %

Définit si l'outil permet ou pas un écart de taille de ±10 % entre le modèle trouvé et le modèle de forme.

Modèle appris | Modèle trouvé : +10 % | Modèle trouvé : -10%
DÉSACTIVÉ (par défaut) | (Échec) | (Échec)
ACTIVÉ | (Succès) | (Succès)
Fermé Utilisation du délai manuel

Définit si le réglage du délai est appliqué ou non.

  • Désactivé (par défaut) : le réglage du délai est désactivé (pas de délai).

  • Activé : le réglage du délai est activé. Vous pouvez manuellement définir la valeur du délai en millisecondes (0 à 30 000), à l'aide de la zone d'édition.

    Remarque : le réglage de la valeur sur 0 désactive le réglage et aucun délai n'est appliqué.
Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Nom

Définit le nom de votre outil d'inspection. Le nom par défaut est « Modèle_1 » (si c'est le premier outil Modèle ajouté au projet, sinon, il est incrémenté, par exemple « Modèle_2 », « Modèle_3 », etc.).

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Activé

Définit si l'outil d'inspection doit s'exécuter et à quel moment (le paramètre par défaut est Activé).

  • Sélectionnez "Désactivé" pour désactiver l'outil.
  • Sélectionnez une ligne d'entrée pour que l'outil soit associé à une ligne d'entrée discrète spécifique, où il peut être activé ou désactivé (un signal élevé 1 signifie activé, un signal faible 0 signifie désactivé). La connexion de l'outil à une entrée permet à un système de contrôle, un PLC par exemple, de déterminer quels outils doivent s'exécuter, et à quel moment.
Fermé Repère

Sélectionne un repère pour l'outil. Le bouton Repère devient orange quand le contrôle de repère est activé.

Remarque : ce contrôle peut être activé uniquement si un autre outil qui définit un repère a déjà été ajouté.
Fermé Apprendre entrée

Définit s'il faut ou pas apprendre un modèle de forme sur une ligne d'entrée (le paramètre par défaut est « Off », désactivé).

  • Entrée : Apprend un modèle de forme sur une ligne d'entrée. La ligne d'entrée sélectionnée sera utilisée comme signal d'apprentissage.

    Remarque :
    • Cette option ne sera pas affichée quand le système de vision In-Sight n'a pas d'entrées discrètes (p. ex., système de vision In-Sight série 8000 avec E/S directes).
    • Le type de signal de la ligne d'entrée sélectionnée doit être défini sur Déclencheur d'événement à l'étape d'application Entrées/Sorties.
    • L'apprentissage d'un modèle de forme utilise l'image la plus récente acquise par le système/capteur de vision. Il n'est pas nécessaire de redéclencher le système/capteur de vision pour effectuer l'apprentissage.
    • Pour en savoir plus, reportez-vous à la rubrique Entrées : apprentissage d'un modèle de forme sur une ligne d'entrée
Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Fermé Région du modèle

L'image est une vignette du Modèle. Cliquez sur le bouton Région du modèle pour redimensionner ou déplacer la région du Modèle, puis sur le bouton Apprendre pour apprendre à nouveau le Modèle de forme.


Outil de présence/absence de modèle - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties, et Communication). Le nom par défaut est « Modèle_1 » s'il s'agit du premier outil de modèle ajouté au projet. Sinon, il est incrémenté (par exemple, « Modèle_2 », « Modèle_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de présence/absence de modèle - Onglet Paramètres

Fermé Apprendre entrée

Définit s'il faut ou pas apprendre un modèle de forme sur une ligne d'entrée (le paramètre par défaut est « Off », désactivé).

  • Entrée : Apprend un modèle de forme sur une ligne d'entrée. La ligne d'entrée sélectionnée sera utilisée comme signal d'apprentissage.

    Remarque :
    • Cette option ne sera pas affichée quand le système de vision In-Sight n'a pas d'entrées discrètes (p. ex., système de vision In-Sight série 8000 avec E/S directes).
    • Le type de signal de la ligne d'entrée sélectionnée doit être défini sur Déclencheur d'événement à l'étape d'application Entrées/Sorties.
    • L'apprentissage d'un modèle de forme utilise l'image la plus récente acquise par le système/capteur de vision. Il n'est pas nécessaire de redéclencher le système/capteur de vision pour effectuer l'apprentissage.
    • Pour en savoir plus, reportez-vous à la rubrique Entrées : apprentissage d'un modèle de forme sur une ligne d'entrée
Fermé Seuil d'acceptation

Définit le degré de similitude qui doit exister entre le modèle de forme et le modèle localisé (0 à 100 ; valeur par défaut = 50). Les modèles localisés affichant une valeur supérieure ou égale au seuil défini sont considérés comme correspondants. Cet outil s'exécute plus rapidement lorsque ce paramètre est élevé, ce qui requiert également un degré de similitude plus important entre le modèle de forme et le modèle localisé. Moins les paramètres sont élevés, moins les résultats seront précis. Des modèles semblables seront détectés, mais pas par rapport au modèle de forme.

Fermé Tolérance angulaire

Définit dans quelle mesure le modèle localisé peut pivoter par rapport à la position du modèle de forme, tout en étant identifié comme un modèle valide (± 0 à 180° ; valeur par défaut = 15°). Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps.

Fermé Tolérance en échelle

Définit la tolérance de l'outil aux variations d'échelle du modèle, avec une marge de ± 10 % par rapport à la taille du modèle appris. Ce paramètre est désactivé par défaut (option pas cochée), ce qui désactive les ajustements d'échelle. Dans ce mode de fonctionnement, l'outil trouve toujours les modèles compris dans la plage de ± 10 %, mais le score de la caractéristique diminue à mesure que le pourcentage de mise à l'échelle augmente.

Fermé Inverser résultat
Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Type de modèle

Définit comment l'outil construit le modèle de forme : Modèle de surface ou Modèle de transition (valeur par défaut). Modèle de surface crée un modèle de forme basé sur un échantillonnage uniforme de valeurs de niveaux de gris de la région modèle. Modèle de transition crée un modèle de forme basé sur les transitions détectées (transitions claires/sombres) de la caractéristique de modèle dans la région modèle.

Fermé Précision

Définit comment l'outil qualifie le compromis entre précision/fiabilité et vitesse d'exécution : Précis, Moyen (valeur par défaut) et Rapide. Précis indique que l'accent est mis sur une précision/fiabilité plus élevée et une vitesse d'exécution plus lente , Rapide indique que l'accent est mis sur une vitesse d'exécution plus élevée plutôt que sur la précision/fiabilité ; et Moyen indique un réglage intermédiaire entre les deux.

Fermé Délai d'attente

Définit la durée, en millisecondes (0 à 30 000), pendant laquelle l'outil recherche le ou les modèles avant que l'exécution ne soit interrompue et que l'outil ne renvoie un échec.

Fermé Résultat

Affiche le résultat de l'outil : Présent si la caractéristique de modèle a été détectée et qu'un score indique le degré de similitude entre le modèle localisé et le Modèle de forme; Absent(e) si elle n'a pas été détectée ou si plusieurs instances du modèle ont été détectées. Présent équivaut à la valeur booléenne 1 (Succès) et Absent(e) à la valeur booléenne 0 (Échec).


Outil de présence/absence de modèle - Onglet Image d'apprentissage

L'image affichée sur l'onglet Image d'apprentissage est une miniature du modèle de forme. Cliquez sur le bouton Région du modèle pour redimensionner ou déplacer la région Modèle, puis sur le bouton Apprendre pour apprendre à nouveau le modèle de forme.


Outils de présence/absence - Comptage de pixels

L'outil de présence/absence basé sur le comptage de pixels détermine si une caractéristique est présente ou absente, en fonction du nombre de pixels blancs ou noirs dans la région, puis rapporte cette valeur.

L'outil calcule la valeur optimale du seuil d'échelle de gris (de 0 à 255) qui sépare l'image en pixels blancs et noirs, puis effectue un comptage des pixels qui tombent au-dessus ou en dessous de ce seuil (en fonction des paramètres).

L'outil de présence/absence basé sur le comptage de pixels est utile dans les cas où vous devez déterminer si une caractéristique est présente ou absente, en fonction du nombre de pixels blancs ou noirs dans une région. Par exemple, pour vérifier que la bonne quantité de soudure a été dispensée autour d'un fil de circuit imprimé ou pour vérifier la présence d'une chaîne de texte complète imprimée sur une étiquette.

Cet outil renvoie les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000 Séries 1XX (110, 120, 130) | État Succès/Échec uniquement
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Résultats standard (aucune limitation)

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de présence/absence basé sur le comptage de pixels

Une fois l'outil ajouté, sélectionnez le type de région et configurez cette dernière dans l'image pour isoler votre caractéristique :

  1. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région sur la caractéristique et assurez-vous que les limites de la région couvrent la caractéristique. Les limites doivent être configurées de façon à englober uniquement la caractéristique que vous souhaitez mesurer - si la région est plus grande que la caractéristique, les résultats peuvent être altérés puisque les pixels de l'arrière-plan sont également calculés. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la ou des caractéristique(s) reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

    Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Sélection d’une caractéristique


Sélection d'une caractéristique

Lorsque vous choisissez une caractéristique pour une inspection, tenez compte des instructions suivantes pour garantir des résultats optimaux :

  • Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la caractéristique reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel de la caractéristique.
  • L'outil de comptage de pixels s'avère utile dans des applications où la caractéristique inspectée contient des niveaux de gris mélangés lorsqu'elle est présente, et un ensemble uniforme de niveaux de gris lorsqu'elle est absente.
  • L'outil de comptage de pixels est capable de distinguer les différences subtiles de luminosité et de contraste, et évalue ces différences de façon plus précise que les outils de présence/absence de luminosité et de contraste.
Fermé Exemple


Réglage des paramètres de l'outil de présence/absence basé sur le comptage de pixels

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Capteurs de vision In-Sight série 2000

  • Zone de groupe Outil d'édition

Systèmes de vision In-Sight

Le volet de paramètres de l'outil de présence/absence basé sur le comptage de pixels comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
  • Onglet Histogramme
  • Onglet Région composite
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Capteurs de vision In-Sight série 2000

Systèmes de vision In-Sight

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

Aide EasyBuilder | 08/29/2022 | Revision: 5.9.0.2


Réglage des paramètres de l'outil de présence/absence basé sur le comptage de pixels

Remarque : Cette rubrique décrit l'interface utilisateur en étant connecté à un capteur de vision In-Sight série 2000. En cas de connexion aux systèmes de vision In-Sight, voir la section Système de vision In-Sight de Réglage des paramètres de l'outil de présence/absence basé sur le comptage de pixels .

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Fermé Indicateur de succès/échecs

Affiche un cercle vert [image] ou un rectangle rouge [image] pour représenter respectivement les succès et les échecs.

Fermé Sélecteur de pixels

Définit la manière dont l'outil segmente l'image en zones de pixels noirs et de pixels blancs. Par défaut, l'outil compte les pixels noirs et les pixels blancs sont mis en surbrillance en jaune dans la région.

Image d'origine
Sélectionné Couleur des pixels = Noir

La poignée de gauche définit la valeur inférieure du seuil (0 à 255) et la poignée de droite définit la valeur supérieure du seuil (0 à 255). Vous pouvez définir manuellement les valeurs en ajustant les poignées ou en saisissant des valeurs dans les zones d'édition correspondantes.

Astuce : vous pouvez également déplacer la poignée à l'aide des touches des FLÈCHES (HAUT, BAS, DROITE et GAUCHE).

Pour compter les pixels blancs, appuyez sur [image]. Les pixels blancs sont maintenant mis en surbrillance en jaune dans la région sélectionnée.

Sélectionné Couleur des pixels = Blanc
Fermé Bouton Automatique

Définit automatiquement les limites de plage pour qu'elles correspondent au résultat le plus récent de l'outil, +/- 10 % de la valeur maximale du résultat de l'outil. Par exemple, si la valeur maximale du résultat de l'outil est 255 et le résultat le plus récent 150, un clic sur le bouton Automatique définit la limite minimale de la plage à 125 (=150 - 25) et la limite maximale de la plage à 175 (=150 + 25).

Fermé Compteur de pixels et plage de succès

Définit le nombre de pixels acceptable dans la région. Les poignées définissent le nombre minimal et maximal de pixels noirs ou blancs devant être comptés dans les limites de la plage pour que l'outil obtienne un succès.

SUCCÈS
ÉCHEC

Si le résultat est entre les poignées gauche et droite, l'outil obtient un succès et la bordure verte s'affiche autour du compteur. Sinon, l'outil obtient un échec et bordure rouge s'affiche autour du compteur.

Vous pouvez définir manuellement les valeurs en ajustant les poignées ou en saisissant des valeurs dans les zones d'édition correspondantes.

Astuce : vous pouvez également déplacer la poignée à l'aide des touches des FLÈCHES (HAUT, BAS, DROITE et GAUCHE).
Remarque : Les valeurs Résultat (nombre de pixels trouvés dans la région) et Plage de succès s'affichent en survolant le curseur avec le pointeur de la souris.
Fermé Inverser le résultat

Lorsque l'option est activée, l'outil échoue si le résultat est dans les limites de la plage. (Par défaut = Désactivé)

Succès/échec | (Inverser) | Succès/échec
Succès/échec | (Inverser) | Succès/échec
Fermé Afficher les détails

Définit si les pixels comptés sont toujours affichés ou pas dans la zone d'image (surlignés en jaune).

Astuce : Pour afficher les pixels comptés sur VisionView, sélectionnez le nom symbolique Afficher_détails dans EasyView dans l'étape d'application Communication et cochez la case Afficher_détails dans l'application VisionView. Pour en savoir plus sur le mode d'affichage des données dans VisionView, reportez-vous à Configuration d'un élément EasyView.
  • Activé ( [image] = par défaut) : les pixels comptés sont toujours affichés dans la zone d'image sauf si un autre outil de recherche ou d'inspection est modifié.

  • Désactivé ( [image]) :les pixels comptés sont affichés dans la zone d'image uniquement si cet outil est modifié.

Fermé Inverser les pixels sélectionnés

Définit la couleur des pixels pour le comptage - Noir [image] ou Blanc [image] (par défaut = Noir).

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Nom

Définit le nom de votre outil d'inspection. Le nom par défaut est Pixels_1 (si c'est le premier outil Modèle ajouté au projet, sinon, il est incrémenté, par exemple, Pixels_2, Pixels_3, etc.).

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Activé

Définit si l'outil d'inspection doit s'exécuter et à quel moment (le paramètre par défaut est Activé).

  • Sélectionnez "Désactivé" pour désactiver l'outil.
  • Sélectionnez une ligne d'entrée pour que l'outil soit associé à une ligne d'entrée discrète spécifique, où il peut être activé ou désactivé (un signal élevé 1 signifie activé, un signal faible 0 signifie désactivé). La connexion de l'outil à une entrée permet à un système de contrôle, un PLC par exemple, de déterminer quels outils doivent s'exécuter, et à quel moment.
Fermé Repère

Sélectionne un repère pour l'outil. Le bouton Repère devient orange quand le contrôle de repère est activé.

Remarque : ce contrôle peut être activé uniquement si un autre outil qui définit un repère a déjà été ajouté.
Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de présence/absence basé sur le comptage de pixels - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Pixels_1 » s'il s'agit du premier outil de comptage de pixels ajouté au projet. Sinon, il est incrémenté (par exemple, « Pixels_2 », « Pixels_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de présence/absence basé sur le comptage de pixels - Onglet Paramètres

Fermé Mode du seuil

Définit le mode de détermination de la valeur de niveau de gris qui segmente la région de l'image en pixels blancs et noirs. Quand Automatique est sélectionné (valeur par défaut = Automatique), l'outil crée un « Paramètre automatique » par défaut d'après l'image, chaque fois qu'une image est acquise, en ajustant constamment les modifications de luminosité image après image. Si Manuel est sélectionné, vous saisissez et ajustez manuellement les deux valeurs seuils.

Fermé Seuil inférieur

Définit la valeur de niveau de gris qui sépare les pixels noirs des blancs (0 à 255 si le contrôle est activé). Si la valeur Seuil supérieur est ≥ à la valeur Seuil inférieur, les pixels blancs sont définis comme des valeurs ≤ à la valeur Seuil inférieur et ≤ au Seuil supérieur ; si Seuil supérieur < Seuil inférieur, les pixels blancs sont définis comme valeurs ≤ au Seuil supérieur ou des valeurs ≤ au Seuil inférieur. Ce contrôle est désactivé par défaut et requiert que le mode du seuil soit défini sur Manuel pour pouvoir être activé. Utilisez l'onglet Histogramme afin de définir une valeur optimale pour votre application.

  • Seuil inférieur ≤ Seuil supérieur : Toute valeur comprise entre les seuils est considérée comme valeur « blanche » quelle que soit la valeur de niveau de gris réelle. Toute valeur en dehors des seuils est considérée comme valeur « noire » quelle que soit la valeur de niveau de gris réelle.
  • Seuil supérieur ≤ Seuil inférieur : Toute valeur comprise entre les seuils est considérée comme valeur « noire » quelle que soit la valeur de niveau de gris réelle. Toute valeur en dehors des seuils est considérée comme valeur « blanche » quelle que soit la valeur de niveau de gris réelle.
Fermé Seuil supérieur

Définit la valeur de niveau de gris qui sépare les pixels noirs des blancs (0 à 255 si le contrôle est activé). Si la valeur Seuil supérieur est ≥ à la valeur Seuil inférieur, les pixels blancs sont définis comme des valeurs ≤ à la valeur Seuil inférieur et ≤ au Seuil supérieur ; si Seuil supérieur < Seuil inférieur, les pixels blancs sont définis comme valeurs ≤ au Seuil supérieur ou des valeurs ≤ au Seuil inférieur. Ce contrôle est désactivé par défaut et requiert que le mode du seuil soit défini sur Manuel pour pouvoir être activé. Utilisez l'onglet Histogramme afin de définir une valeur optimale pour votre application.

  • Seuil inférieur ≤ Seuil supérieur : Toute valeur comprise entre les seuils est considérée comme valeur « blanche » quelle que soit la valeur de niveau de gris réelle. Toute valeur en dehors des seuils est considérée comme valeur « noire » quelle que soit la valeur de niveau de gris réelle.
  • Seuil supérieur ≤ Seuil inférieur : Toute valeur comprise entre les seuils est considérée comme valeur « noire » quelle que soit la valeur de niveau de gris réelle. Toute valeur en dehors des seuils est considérée comme valeur « blanche » quelle que soit la valeur de niveau de gris réelle.
Fermé Polarité

Définit la couleur des pixels pour le comptage - Noir ou blanc (par défaut = blanc).


Outil de présence/absence basé sur le comptage de pixels - Onglet Limites de plages

Fermé Maximum

Définit le nombre de pixels maximal acceptable dans la région. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Pixels

Renvoie le nombre de pixels localisés dans la région (la valeur peut aller de 0 à la surface maximale de la région). Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Fermé Minimum

Définit le nombre de pixels minimal acceptable dans la région. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux limites de plages.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux limites de plages.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outil de présence/absence basé sur le comptage de pixels - Onglet Histogramme

L'onglet Histogramme affiche un histogramme des valeurs de niveau de gris des pixels dans la région.

  • L'axe X du graphique représente le nombre total de valeurs de niveau de gris (0 à 255, ou 256 nuances de gris au total).
  • L'axe Y du graphique représente le nombre de pixels pour une valeur de niveau de gris donnée, l'échelle est établie en affichant la valeur de niveau de gris avec le plus grand nombre de pixels.
  • La ligne bleue verticale indique le seuil utilisé pour séparer la région de l'image en pixels noirs et blancs ; les valeurs situées à gauche de la ligne sont considérées comme noires et les valeurs de droite comme blanches.
Remarque : Le graphique s'affiche sans tenir compte de l'état En ligne/Hors ligne et de l'état succès/échec de l'outil. Cependant, si l'outil est en échec, il est possible que le graphique ne soit pas mis à jour.


Outil de présence/absence basé sur le comptage de pixels - Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils de présence/absence - Nombre de pixels de couleur

L'outil de présence/absence basé sur le comptage de pixels de couleur détermine si une caractéristique est présente ou absente, à partir du nombre de pixels correspondant aux couleurs mémorisées dans la Table des couleurs (capteurs de vision couleur In-Sight série 2000) ou des Modèles de couleurs sélectionnés dans la Bibliothèque de couleurs (systèmes de vision couleur In-Sight) présents dans la région, et renvoie cette valeur.

Cet outil renvoie les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000 Séries 1XX (110, 120, 130) | État Succès/Échec uniquement
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Résultats standard (aucune limitation)

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de présence/absence basé sur le comptage de pixels de couleur

Une fois l'outil ajouté, sélectionnez le type de région et configurez cette dernière dans l'image pour isoler votre caractéristique :

Capteurs de vision couleur In-Sight série 2000

Systèmes de vision couleur In-Sight

Capteurs de vision couleur In-Sight série 2000

  1. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région sur la caractéristique et assurez-vous que les limites de la région couvrent la caractéristique. Les limites doivent être configurées de façon à englober uniquement la caractéristique que vous souhaitez mesurer - si la région est plus grande que la caractéristique, les résultats peuvent être altérés puisque les pixels de l'arrière-plan sont également calculés. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la ou des caractéristique(s) reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

    Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Une fois que la région a été configurée, vous devez remplir les paramètres de l'outil de couleur.

    Remarque : Par défaut, l'outil sera automatiquement en Échec jusqu'à ce que la sélection des couleurs soit complète.

  4. Cliquez sur le bouton Apprendre couleurs. Le volet de contexte d'apprentissage des couleurs s'affiche.
  5. Pour ajouter des couleurs, cliquez sur [image].
  6. Déplacez le curseur vers la zone d'image. Dans le volet de contexte, un gros plan s'affiche pour vous aider à trouver la couleur voulue.

  7. Cliquez pour sélectionner la couleur voulue. Après avoir cliqué, la couleur est ajoutée à la table des couleurs en dessous et tous les pixels présents dans la région et correspondant à la couleur sélectionnée deviendront jaunes.

    Avant d'ajouter une couleur Sélectionner une couleur Après avoir ajouté une couleur
  8. Effectuez de nouveau les étapes 6 et 7 jusqu'à ce que la table des couleurs contienne toutes les couleurs nécessaires.
  9. Pour soustraire des couleurs, cliquez sur [image], puis effectuez de nouveau les étapes 6 à 8.
  10. Cliquez sur le bouton Terminer la sélection de couleur pour revenir au volet de contexte général.
  11. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  12. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres périphériques externes.

Systèmes de vision couleur In-Sight

L'outil de présence/absence basé sur le comptage de pixels de couleur fait référence à une bibliothèque mémorisée de Modèles de couleurs, puis détermine le nombre de pixels présents dans la région et correspondant avec les Modèles de couleurs sélectionnés et mémorisés dans la bibliothèque mémorisée. L'outil crée ensuite une image de sortie binaire en niveau de gris, ou chaque pixel correspondant à un Modèle de couleur actif est défini sur Blanc (255), tandis que les autres pixels sont définis sur Noir (0). À l'aide de cette image de sortie binaire, l'outil parcourt alors l'image et enregistre le nombre de pixels correspondant au(x) Modèle(s) de couleur(s) actif(s).

  1. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région sur la caractéristique et assurez-vous que les limites de la région couvrent la caractéristique. Les limites doivent être configurées de façon à englober uniquement la caractéristique que vous souhaitez mesurer - si la région est plus grande que la caractéristique, les résultats peuvent être altérés puisque les pixels de l'arrière-plan sont également calculés. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la ou des caractéristique(s) reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

    Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Une fois la région de recherche configurée, configurez la bibliothèque de couleurs de l'outil et activez le ou les modèles de couleurs appropriés :

    • Si un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire) est ajouté pour la première fois, commencez par configurer une ou plusieurs bibliothèques de couleurs et leur(s) modèle(s) de couleurs.

    • Si un autre outil de couleur a déjà été ajouté et que vous souhaitez utiliser une Bibliothèque de couleurs existante ainsi que ses Modèles de couleurs, accédez à l'onglet Paramètres et sélectionnez la Bibliothèque de couleurs de votre choix, puis activez les Modèles de couleurs choisis en les cochant dans l'onglet Bibliothèque.

    • Par défaut, l'outil déclenche automatiquement un échec tant qu'aucune bibliothèque de couleurs n'a été définie. Si une bibliothèque de couleurs a été définie, l'outil utilise automatiquement cette bibliothèque et active tous les modèles de couleurs qu'elle contient.

  4. Une fois le ou les modèles de couleurs et la ou les bibliothèques de couleurs configurés, l'outil traite l'image et tous les pixels de la région de recherche qui correspondent au ou aux modèles de couleurs sélectionnés deviennent blancs (255), alors que ceux qui ne correspondent pas au ou aux modèles de couleurs sélectionnés deviennent noirs (0).
  5. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  6. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de présence/absence basé sur le comptage de pixels de couleur

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Capteurs de vision In-Sight série 2000

  • Zone de groupe Outil d'édition

Systèmes de vision In-Sight

Le volet de paramètres de l'outil de présence/absence basé sur le comptage de pixels de couleur comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
  • Onglet Bibliothèque de couleurs
  • Onglet Région composite
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Capteurs de vision In-Sight série 2000

Systèmes de vision In-Sight

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

Aide EasyBuilder | 08/29/2022 | Revision: 5.9.0.2


Réglage des paramètres de l'outil de présence/absence basé sur le comptage de pixels de couleur

Remarque : Cette rubrique décrit l'interface utilisateur en étant connecté à un capteur de vision In-Sight série 2000. En cas de connexion aux systèmes de vision In-Sight, voir la section Système de vision In-Sight de Réglage des paramètres de l'outil de présence/absence basé sur le comptage de pixels .

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Volet Contexte général

Fermé Indicateur de succès/échecs

Affiche un cercle vert [image] ou un rectangle rouge [image] pour représenter respectivement les succès et les échecs.

Fermé Apprendre couleurs

Ouvre le volet de contexte d'apprentissage des couleurs

Fermé Tuiles de couleur

Affiche les 5 premières couleurs mémorisées ajoutées par le bouton Sélectionner les couleurs à ajouter [image] dans le volet de contexte d'apprentissage des couleurs. Vous pouvez accéder au volet de contexte d'apprentissage des couleurs en cliquant sur une tuile de couleur.

Fermé Compteur de pixels et plage de succès

Définit le nombre de pixels acceptable dans la région. Les poignées définissent le nombre minimal et maximal de pixels devant être comptés dans les limites de la plage pour que l'outil obtienne un succès.

SUCCÈS
ÉCHEC

Si le résultat est entre les poignées gauche et droite, l'outil obtient un succès et la bordure verte s'affiche autour du compteur. Sinon, l'outil obtient un échec et bordure rouge s'affiche autour du compteur.

Vous pouvez définir manuellement les valeurs en ajustant les poignées ou en saisissant des valeurs dans les zones d'édition correspondantes.

Astuce : vous pouvez également déplacer la poignée à l'aide des touches des FLÈCHES (HAUT, BAS, DROITE et GAUCHE).
Remarque : Les valeurs Résultat (nombre de pixels trouvés dans la région) et Plage de succès s'affichent en survolant le curseur avec le pointeur de la souris.
Fermé Bouton Automatique

Définit automatiquement les limites de plage pour qu'elles correspondent au résultat le plus récent de l'outil, +/- 10 % de la valeur maximale du résultat de l'outil. Par exemple, si la valeur maximale du résultat de l'outil est 255 et le résultat le plus récent 150, un clic sur le bouton Automatique définit la limite minimale de la plage à 125 (=150 - 25) et la limite maximale de la plage à 175 (=150 + 25).

Fermé Inverser le résultat

Lorsque l'option est activée, l'outil échoue si le résultat est dans les limites de la plage. (Par défaut = Désactivé)

Succès/échec | (Inverser) | Succès/échec
Succès/échec | (Inverser) | Succès/échec
Fermé Afficher les détails

Définit si les pixels comptés sont toujours affichés ou pas dans la zone d'image (surlignés en jaune).

Astuce : Pour afficher les pixels comptés sur VisionView, sélectionnez le nom symbolique Afficher_détails dans EasyView dans l'étape d'application Communication et cochez la case Afficher_détails dans l'application VisionView. Pour en savoir plus sur le mode d'affichage des données dans VisionView, reportez-vous à Configuration d'un élément EasyView.
  • Activé ( [image] = par défaut) : les pixels comptés sont toujours affichés dans la zone d'image sauf si un autre outil de recherche ou d'inspection est modifié.

  • Désactivé ( [image]) :les pixels comptés sont affichés dans la zone d'image uniquement si cet outil est modifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Nom

Définit le nom de votre outil d'inspection. Le nom par défaut est ColorPixels_1 (si c'est le premier outil Modèle ajouté au projet, sinon, il est incrémenté, par exemple, ColorPixels_2, ColorPixels_3, etc.).

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Activé

Définit si l'outil d'inspection doit s'exécuter et à quel moment (le paramètre par défaut est Activé).

  • Sélectionnez "Désactivé" pour désactiver l'outil.
  • Sélectionnez une ligne d'entrée pour que l'outil soit associé à une ligne d'entrée discrète spécifique, où il peut être activé ou désactivé (un signal élevé 1 signifie activé, un signal faible 0 signifie désactivé). La connexion de l'outil à une entrée permet à un système de contrôle, un PLC par exemple, de déterminer quels outils doivent s'exécuter, et à quel moment.
Fermé Repère

Sélectionne un repère pour l'outil. Le bouton Repère devient orange quand le contrôle de repère est activé.

Remarque : ce contrôle peut être activé uniquement si un autre outil qui définit un repère a déjà été ajouté.
Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Volet de contexte d'apprentissage des couleurs

Fermé Boutons Sélectionner les couleurs à ajouter et Sélectionner les couleurs à soustraire

  • Sélectionner les couleurs à ajouter : Ajoutez « couleurs à ajouter » à la table des couleurs. Les couleurs sélectionnées à l'aide de ce bouton seront incluses pour déterminer le nombre de pixels présents dans la région. Après avoir sélectionné une couleur que vous souhaitez ajouter, tous les pixels présents dans la région et correspondant à la couleur sélectionnée deviendront jaunes.

    Remarque : Les 5 premières couleurs sélectionnées à l'aide de ce bouton seront affichées comme des « tuiles de couleur » dans le volet de contexte général.
    Avant d'ajouter une couleur Après avoir ajouté une couleur
  • Sélectionner les couleurs à soustraire : Ajoutez « couleurs à soustraire » à la table des couleurs. Les couleurs sélectionnées à l'aide de ce bouton seront exclues pour déterminer le nombre de pixels dans la région.

Une fois que le bouton Sélectionner les couleurs à ajouter ou Sélectionner les couleurs à soustraire est sélectionné et que le curseur est déplacé dans la zone d'image, l'image apparaîtra en gros plan dans le volet Contexte pour faciliter la sélection d'une couleur.

Gros plan sur image
Fermé Table des couleurs

  • Couleur : affiche les couleurs ajoutées à l'aide des boutons Sélectionner les couleurs à ajouter et Sélectionner les couleurs à soustraire.

    Remarque : Les valeurs RBG s'affichent en survolant le curseur avec le pointeur de la souris.

  • Tolérance : définit le paramètre Tolérance de couleur (0 - 10 ; par défaut = 2). Vous pouvez augmenter/diminuer la Tolérance pour inclure plus/moins de nuances de la couleur mémorisée.

    Remarque : La valeur de Tolérance s'affiche en survolant le curseur avec le pointeur de la souris.
    Image d'origine

    Tolérance = 0,5

             Tolérance = 2 (par défaut) Tolérance = 7
  • Opérations :
    • Modifier pour soustraire une couleur : la couleur est mise en surbrillance jaune dans la région et incluses pour déterminer le nombre de pixels présents dans la région. Pour modifier pour soustraire une couleur, cliquez sur ce bouton.
    • Modifier pour ajouter une couleur : la couleur est exclue pour déterminer le nombre de pixels dans la région. Pour modifier pour ajouter une couleur, cliquez sur ce bouton.

    • Déplacer vers le Haut/Bas : modifie l'ordre des opérations concernant les couleurs de la table. L'opération de couleur sera exécutée du haut vers le bas.

    • Supprimer une couleur : supprime une couleur de la table.
Fermé Ignorer luminosité

Lorsque la case à cocher Ignorer luminosité est cochée (par défaut), une grand nombre de pixels plus foncés/clairs que les couleurs mémorisées seront comptés. Cela peut contribuer à améliorer la performance de l'outil si l'intensité de l'image n'est pas uniforme dans le champ de vue. Cependant, si les pixels noirs et/ou blancs sont comptés en plus des couleurs mémorisées, cette option devra être décochée.

Fermé Terminer la sélection de couleur

Retour au volet de contexte général.

Exemples d'opérations de couleur

Fermé Exemples

Dans cet exemple, vous souhaitez sélectionnez les craies « bleues » et « vertes » dans l'image.

Exemple 1

  1. Sélectionnez « bleu » et « vert » dans l'image à l'aide du bouton Sélectionner les couleurs à ajouter [image].

    Image d'origine Sélectionnez « Bleu (Ajouter) » & « Vert (Ajouter) »

  2. Ainsi, les craies mauves sont également partiellement mises en surbrillance car ces couleurs (bleu, vert et mauve) sont très similaires. Le « mauve » vient du « bleu » (voir l'image ci-dessous) ; si vous sélectionnez le bleu (ou cyan foncé), des couleurs similaires au mauve seront également sélectionnées.

  3. Vous souhaitez désormais le « mauve » de l'image. Sélectionnez « mauve » dans la zone en surbrillance de la craie mauve à l'aide du bouton Sélectionner les couleurs à soustraire [image].

    Sélectionnez « Mauve (Soustraire) »
  4. Vous avez bien sélectionné les craies bleue et verte.

Exemple 2

Dans cet exemple, vous souhaitez également sélectionner les craies « bleue » et « mauve » dans l'image, mais vous n'atteindrez peut-être pas le résultat désiré car l'ordre des opérations de couleur est différent.

  1. Sélectionnez « bleu » dans l'image à l'aide du bouton Sélectionner les couleurs à ajouter [image].

  2. Sélectionnez « mauve » dans l'image à l'aide du bouton Sélectionner les couleurs à soustraire [image].

    Sélectionnez « Bleu (Ajouter) » & « Mauve (Soustraire) »

  3. Sélectionnez « vert » dans l'image à l'aide du bouton Sélectionner les couleurs à ajouter [image].

    Sélectionnez « Vert (Ajouter) »
  4. Ainsi, les craies mauves sont partiellement mises en surbrillance car le « vert » et le « mauve » sont très similaires. Si vous sélectionnez le vert, des couleurs similaires au mauve seront également sélectionnées.
  5. Pour supprimer le « mauve » de l'image, déplacez l'opération mauve vers le bas à l'aide du bouton « Déplacer vers le bas » [image]. Sinon, vous pouvez ajouter la deuxième opération mauve à l'aide du bouton Sélectionner les couleurs à soustraire [image], après le « vert ».


Outil de présence/absence basé sur le comptage de pixels de couleur - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Pixels_1 » s'il s'agit du premier outil de comptage de pixels ajouté au projet. Sinon, il est incrémenté (par exemple, « Pixels_2 », « Pixels_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de présence/absence basé sur le comptage de pixels de couleur - Onglet Paramètres

Fermé Apprendre la couleur

Affiche la boîte de dialogue Apprentissage ExtractColor , utilisée pour définir le ou les modèles de couleurs de la bibliothèque de couleurs sélectionnée.

Fermé Bibliothèque de couleurs

Définit la bibliothèque de couleurs utilisée comme référence par l'outil. Sur la liste déroulante, sélectionnez la bibliothèque de couleurs à modifier puis cliquez sur le bouton Apprendre la couleur pour afficher la boîte de dialogue Apprentissage ExtractColor. Chaque bibliothèque de couleurs peut compter jusqu'à 100 modèles de couleurs distincts, composés de couleurs individuelles.

Les projets EasyBuilder peuvent contenir 5 bibliothèques de couleurs maximum, qui peuvent être partagées par les outils suivants :

  • Outil de recherche de blob de couleur
  • Outil de recherche de blobs de couleur (1-10)
  • Outil de présence/absence basé sur le comptage de pixels
  • Outil de mesure de surface de blob de couleur
  • Outil de mesure de surfaces des blobs de couleur (1-10)
  • Outil de comptage de blobs de couleur
  • Outil d'identification du modèle de couleurs
  • Outil de filtre d'image couleur -> binaire


Outil de présence/absence basé sur le comptage de pixels de couleur - Onglet Limites de plages

Fermé Maximum

Définit le nombre de pixels maximal acceptable dans la région. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Pixels

Renvoie le nombre de pixels localisés dans la région (la valeur peut aller de 0 à la surface maximale de la région). Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Fermé Minimum

Définit le nombre de pixels minimal acceptable dans la région. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outil de présence/absence basé sur le comptage de pixels de couleur - Onglet Bibliothèque de couleurs

Fermé Liste Modèles de couleurs

Affiche une liste en lecture seule de modèle(s) de couleurs contenus dans la bibliothèque de couleurs sélectionnée. Les modèles de couleurs sont activés et désactivés en cochant ou décochant la case en regard de Modèles de couleurs.

Fermé Tableau de couleurs

Affiche un tableau ordonné en lecture seule de la ou des couleurs dans le modèle de couleurs sélectionné.

Fermé Nom de la couleur

Affiche le nom de la ou des couleurs du modèle de couleurs sélectionné.

Fermé RVB

Affiche les valeurs RVB de la ou des couleurs du modèle de couleurs sélectionné.

Fermé Opération

Affiche l'opération (Ajouter ou Soustraire) de la ou des couleurs du modèle de couleurs sélectionné.


Outil de présence/absence basé sur le comptage de pixels de couleur - Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils de présence/absence - Blob

L'outil de présence/absence de blob détermine si une caractéristique de blob est présente ou absente. Si le blob est détecté, l'outil indique "Présent" et affiche le résultat Succès. Si le blob n'est pas détecté, ou si le blob détecté se trouve en dehors des limites spécifiées, l'outil affiche le résultat Échec.

L'outil de présence/absence de blob est l'un des outils les plus rapides, et permet de localiser les caractéristiques de blob plus rapidement qu'un outil de présence/absence de modèle. Cet outil est utile lorsque vous essayez de vérifier la présence ou l'absence d'une caractéristique constituée de pixels connectés. Par exemple, pour vérifier si un trou est présent ou non sur une pièce métallique estampillée.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de présence/absence de blob

Une fois l'outil sélectionné, choisissez le type de région et configurez cette dernière dans l'image dans laquelle vous pensez détecter la ou les caractéristiques de blob :

  1. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région dans l'image dans laquelle vous pensez voir apparaître le ou les blob(s), en vous assurant qu'elle englobe complètement le ou les blob(s) et leurs emplacements possibles, et configurez-la. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement du ou des blob(s) reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

    Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de présence/absence de blob

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de présence/absence de blobs comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Histogramme
  • Onglet Région composite
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Histogramme

Onglet Région composite


Outil de présence/absence de blob - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Blob_1 » s'il s'agit du premier outil de blob ajouté au projet. Sinon, il est incrémenté (par exemple, « Blob_2 », « Blob_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de présence/absence de blob - Onglet Paramètres

Fermé Mode du seuil

Définit le mode utilisé pour déterminer la valeur de niveau de gris servant à séparer les blobs de l'arrière-plan. Lorsque le paramètre Auto est sélectionné (paramètre par défaut), l'outil compense les changements de luminosité d'une image à l'autre à chaque acquisition d'image. Lorsque le paramètre Manuel est sélectionné, vous devez saisir et ajuster la valeur manuellement.

Fermé Seuil du blob

Définit la valeur de niveau de gris utilisée pour séparer les blobs de l'arrière-plan (0 à 255, lorsque l'option est activée). Ce contrôle, désactivé par défaut, requiert que le Mode du seuil soit défini sur Manuel pour être activé. Utilisez le graphique pour définir une valeur optimale pour votre application.

Fermé Couleur du blob

Définit la couleur du blob (Noir, Blanc ou Indifférent ; valeur par défaut = Indifférent).

  • Indifférent : il n'existe aucune exigence relative à la couleur du blob.
  • Noir : renvoie uniquement les blobs inférieurs au Seuil du blob.
  • Blanc : renvoie uniquement les blobs supérieurs au Seuil du blob.
Fermé Limite

Définit l'une des deux méthodes de gestion des blobs situés à la limite de la région du blob (option désactivée par défaut) :

  • Désactivée – N'inclut pas les blobs situés à la limite de la région. Le blob doit être entièrement compris dans la région à détecter.
  • Activée – Inclut les blobs situés à la limite de la région. Ces derniers sont détectés s'ils remplissent aussi les autres critères.
Fermé Surface minimale

Définit une limite de surface minimale sous la forme d'un nombre de pixels (0 à 900000 ; valeur par défaut = 100) pour tous les blobs détectés. Seuls les blobs dont la surface est supérieure à la surface minimale seront reconnus.

Fermé Surface maximale

Définit une limite de surface maximale sous la forme d'un nombre de pixels (0 à 900000 ; valeur par défaut = 100000) pour tous les blobs détectés. Seuls les blobs dont la surface est inférieure à la surface maximale seront reconnus.

Fermé Résultat

Affiche le résultat de l'outil : Présent si la caractéristique de blob a été détectée ; Absent(e) si elle n'a pas été détectée ou si le blob détecté se trouvait en dehors des limites spécifiées. Présent équivaut à la valeur booléenne 1 (Succès), et Absent(e) à la valeur booléenne 0 (Échec).

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.


Outil de présence/absence de blob - Onglet Histogramme

L'Histogramme affiche un graphique des valeurs de niveau de gris des pixels dans la région.

  • L'axe X du graphique représente le nombre total de valeurs de niveau de gris (0 à 255, ou 256 nuances de gris au total).
  • L'axe Y du graphique représente le nombre de pixels pour une valeur de niveau de gris donnée, l'échelle est établie en affichant la valeur de niveau de gris avec le plus grand nombre de pixels.
  • La ligne bleue verticale indique le seuil utilisé pour séparer la région de l'image en pixels noirs et blancs ; les valeurs situées à gauche de la ligne sont considérées comme noires et les valeurs de droite comme blanches.
Remarque : Le graphique s'affiche sans tenir compte de l'état En ligne/Hors ligne et de l'état succès/échec de l'outil. Cependant, si l'outil est en échec, il est possible que le graphique ne soit pas mis à jour.


Outil de présence/absence de blob - Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils de présence/absence - Blob de couleur

L'outil de présence/absence de blob de couleur détermine si une caractéristique de blob est présente ou absente.

L'outil Blob de couleur utilise une bibliothèque de modèles de couleurs appris pour déterminer le nombre de pixels présents dans la région qui correspondent aux modèles de couleurs sélectionnés et appris de la bibliothèque. L'outil crée ensuite une image de sortie binaire en niveau de gris, ou chaque pixel correspondant à un Modèle de couleur actif est défini sur Blanc (255), tandis que les autres pixels sont définis sur Noir (0). L'outil utilise cette image de sortie binaire pour rechercher, dans l'image, les caractéristiques de blob créées par les modèles de couleurs actifs.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de présence/absence de blob de couleur

Une fois l'outil sélectionné, choisissez le type de région et configurez cette dernière dans l'image dans laquelle vous pensez détecter la ou les caractéristiques de blob :

  1. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région dans l'image dans laquelle vous pensez voir apparaître le ou les blob(s), en vous assurant qu'elle englobe complètement le ou les blob(s) et leurs emplacements possibles, et configurez-la. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement du ou des blob(s) reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques. Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Une fois la région de recherche configurée, configurez la bibliothèque de couleurs de l'outil et activez le ou les modèles de couleurs appropriés :
    • Si un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire) est ajouté pour la première fois, commencez par configurer une ou plusieurs bibliothèques de couleurs et leur(s) modèle(s) de couleurs.
    • Si un autre outil a déjà été ajouté et que vous souhaitez utiliser une bibliothèque de couleurs existante et ses modèles de couleurs appris, sélectionnez la bibliothèque de couleurs de votre choix sous l'onglet Paramètres, puis activez les modèles de couleurs voulus en les cochant sous l'onglet Bibliothèque.

    • Par défaut, l'outil déclenche automatiquement un échec tant qu'aucune bibliothèque de couleurs n'a été définie. Si une bibliothèque de couleurs a été définie, l'outil utilise automatiquement cette bibliothèque et active tous les modèles de couleurs qu'elle contient.

  4. Une fois le ou les modèles de couleurs et la ou les bibliothèques de couleurs configurés, l'outil traite l'image et tous les pixels de la région de recherche qui correspondent au ou aux modèles de couleurs sélectionnés deviennent blancs (255), alors que ceux qui ne correspondent pas au ou aux modèles de couleurs sélectionnés deviennent noirs (0).
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de présence/absence de blob de couleur

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de présence/absence de blob de couleur comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Bibliothèque de couleurs
  • Onglet Région composite
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Région composite

Onglet Bibliothèque de couleurs


Outil de présence/absence de blob de couleur - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Pixels_1 » s'il s'agit du premier outil de comptage de pixels ajouté au projet. Sinon, il est incrémenté (par exemple, « Pixels_2 », « Pixels_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de présence/absence de blob de couleur - Onglet Paramètres

Fermé Apprendre la couleur

Affiche la boîte de dialogue Apprentissage ExtractColor , utilisée pour définir le ou les modèles de couleurs de la bibliothèque de couleurs sélectionnée.

Fermé Bibliothèque de couleurs

Définit la bibliothèque de couleurs utilisée comme référence par l'outil. Sur la liste déroulante, sélectionnez la bibliothèque de couleurs à modifier puis cliquez sur le bouton Apprendre la couleur pour afficher la boîte de dialogue Apprentissage ExtractColor. Chaque bibliothèque de couleurs peut compter jusqu'à 100 modèles de couleurs distincts, composés de couleurs individuelles.

Les projets EasyBuilder peuvent contenir 5 bibliothèques de couleurs maximum, qui peuvent être partagées par les outils suivants :

  • Outil de recherche de blob de couleur
  • Outil de recherche de blobs de couleur (1-10)
  • Outil de présence/absence basé sur le comptage de pixels
  • Outil de mesure de surface de blob de couleur
  • Outil de mesure de surfaces des blobs de couleur (1-10)
  • Outil de comptage de blobs de couleur
  • Outil d'identification du modèle de couleurs
  • Outil de filtre d'image couleur -> binaire
Fermé Limite

Définit l'une des deux méthodes de gestion des blobs situés à la limite de la région du blob (option désactivée par défaut) :

  • Désactivée : n'inclut pas les blobs situés à la limite de la région. Le blob doit être entièrement compris dans la région à détecter.
  • Activée : inclut les blobs touchant le bord de la région. Ces derniers sont détectés s'ils remplissent aussi les autres critères.
Fermé Surface minimale

Définit une limite de surface minimale sous la forme d'un nombre de pixels (0 à 16 777 216 ; valeur par défaut = 100) pour tous les blobs détectés. Seuls les blobs dont la surface est supérieure à la surface minimale seront reconnus.

Fermé Surface maximale

Définit une limite de surface maximale sous la forme d'un nombre de pixels (0 à 16 777 216 ; valeur par défaut = 100 000) pour tous les blobs détectés. Seuls les blobs dont la surface est inférieure à la surface maximale seront reconnus.

Fermé Facteur de lissage

Définit le facteur (0 à 25 ; valeur par défaut = 1) à utiliser pour le lissage de l'image. Pour spécifier l'absence de tout lissage, définissez la valeur sur 0.

Fermé Afficher l'image d'origine
  • Désactivé (par défaut) : La région sélectionnée affiche une image de sortie binaire en niveaux de gris.
  • Activée : La région sélectionnée affiche une image d'entrée d'origine.
Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Résultat

Affiche le résultat de l’outil : Présent si la caractéristique de blob a été détectée ; Absent(e) si elle n'a pas été détectée ou si le blob détecté se trouvait en dehors des limites spécifiées. Présent équivaut à une valeur booléenne de 1 (succès) ; Absent(e) équivaut à une valeur booléenne de 0 (échec).


Outil de présence/absence de blob de couleur - Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outil de présence/absence de blob de couleur - Bibliothèque de couleurs

Fermé Liste Modèles de couleurs

Affiche une liste en lecture seule de modèle(s) de couleurs contenus dans la bibliothèque de couleurs sélectionnée. Les modèles de couleurs sont activés et désactivés en cochant ou décochant la case en regard de Modèles de couleurs.

Fermé Tableau de couleurs

Affiche un tableau ordonné en lecture seule de la ou des couleurs dans le modèle de couleurs sélectionné.

Fermé Nom de la couleur

Affiche le nom de la ou des couleurs du modèle de couleurs sélectionné.

Fermé RVB

Affiche les valeurs RVB de la ou des couleurs du modèle de couleurs sélectionné.

Fermé Opération

Affiche l'opération (Ajouter ou Soustraire) de la ou des couleurs du modèle de couleurs sélectionné.


Outils de présence/absence - Transition

L'outil de présence/absence de transition sert à déterminer la présence ou l'absence de caractéristiques de bords linéaires se trouvant dans les paramètres indiqués.

L'outil de présence/absence de transition est l'un des plus rapides, il peut reconnaître des caractéristiques de bords plus vite qu'un outil de présence/absence de modèle.

Cet outil renvoie les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000 Séries 1XX (110, 120, 130) | État Succès/Échec uniquement
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Résultats standard (aucune limitation)

Configuration de l’outil

Réglage des paramètres de l’outil


Utilisation de l'outil de présence/absence de transition

Une fois l'outil ajouté, sélectionnez le type de région et configurez cette dernière dans l'image pour isoler votre caractéristique :

  1. Positionnez la région linéaire le long de la transition.

    Fermé Exemple

    Positionnement de la région linéaire le long de la transition

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. EasyBuilder crée automatiquement une région de transition autour de la transition sélectionnée.

    Fermé Exemple

    Région créée automatiquement

  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de présence/absence de transition

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de recherche de transition comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Graphique
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Graphique


Outil de présence/absence de transition - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Transition_1 » s'il s'agit du premier outil de transition ajouté au projet. Sinon, il est incrémenté (par exemple, « Transition_2 », « Transition_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outils de présence/absence de transition - Onglet Paramètres

Fermé Contraste de bord

Définit le plus petit score de contraste de transition acceptable pour la transition localisée (1 à 100 ; valeur par défaut = un paramètre automatique décrémenté automatiquement jusqu'à ce qu'une transition soit détectée). Ce paramètre détermine la sensibilité de détection de transition de l'outil, c'est-à-dire sa capacité à distinguer la caractéristique de l'arrière-plan. Utilisez-le conjointement au graphique de l'outil pour définir une plage acceptable.

Remarque : Si ce paramètre est configuré sur 0, l'outil peut trouver des bords inattendus.
Fermé Normalisation du score

Définit si les scores des bords seront normalisés par rapport à l’histogramme des niveaux de gris de la région.Ce paramètre permet de rechercher les bords dans des régions de faible contraste. Désactiver ce paramètre si vous êtes certains que les bords à détecter présentent un contraste élevé.

  • Coché (par défaut) : Normalise le score.
  • Non coché : Ne normalise pas le score.
Fermé Transition de bord

Définit le type de transition (Sombre vers clair, Clair vers sombre ou Les deux ; valeur par défaut = Les deux). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Largeur de transition

Définit la distance de pixels (1 à 50 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Chercher par

Définit la manière dont l'outil distingue les transitions localisées lorsque plusieurs transitions sont présentes (valeur par défaut = Le meilleur score).

  • Le meilleur score : la transition présentant le contraste le plus élevé sera choisie.
  • La première transition : la transition la plus proche de l'origine du sens de balayage de la région sera choisie.
  • La dernière transition : la transition la plus éloignée de l'origine du sens de balayage de la région sera choisie.
Fermé Gamme d’écart angulaire

Définit la valeur maximale de la transposition angulaire que peut subir la transition trouvée (0-10° ; par défaut = 10°). Plus la variance autorisée de l’angle est importante, plus l’outil mettra de temps à procéder à l’exécution.

Fermé Résultat

Affiche le résultat de l’outil : Présent si la transition a été détectée ; Absent(e) si elle n’a pas été détectée ou si la transition détectée se trouve en dehors des limites spécifiées. Présent équivaut à une valeur booléenne de 1 (succès) ; Absent(e) équivaut à une valeur booléenne de 0 (échec).

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.


Outils de présence/absence de transition - Graphique

Le Graphique est une représentation de la première dérivée des valeurs de niveau de gris contenues dans la région, les crêtes et vallées représentent le niveau des transitions majeures des bords.

Pour les outils détectant les bords (outils Bord et Cercle), l'axe du Score est une mesure pour la correspondance du bord trouvé avec les paramètres définis :

  • Un score positif indique que le bord fait la transition du sombre vers le clair ;
  • Un score négatif indique que le bord fait la transition du clair vers le sombre ;
  • Un score de 0 indique qu'aucun bord n'a été détecté.

L'axe Offset fait référence à la région définissant la fonction du bord, avec 0 représentant la limite de départ de la région, et l'autre valeur représentant la largeur maximum (en pixels) de la région. Le sommet des crêtes et des vallées le long de l'axe Offset indique la position du bord trouvé.

Remarque : Le graphique s'affiche sans tenir compte de l'état En ligne/Hors ligne et de l'état succès/échec de l'outil. Cependant, si l'outil est en échec, il est possible que le graphique ne soit pas mis à jour.


Outils de présence/absence - Cercle

L'outil de présence/absence de cercle sert à déterminer la présence ou l'absence de caractéristiques de bords circulaires se trouvant dans les paramètres indiqués.

L'outil de recherche de cercle est l'un des plus rapides, il peut reconnaître des bords circulaires plus vite qu'un outil de présence/absence de modèle.

Cet outil renvoie les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000 Séries 1XX (110, 120, 130) | État Succès/Échec uniquement
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Résultats standard (aucune limitation)

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de présence/absence de cercle

Une fois l'outil ajouté, sélectionnez le type de région et configurez cette dernière dans l'image pour isoler votre caractéristique :

  1. Positionnez la région circulaire sur la caractéristique de transition circulaire, en vous assurant qu'elle englobe complètement la caractéristique circulaire, et configurez-la.

    Fermé Exemple

    Positionnement de la région circulaire sur une caractéristique

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. EasyBuilder crée automatiquement une région de transition annulaire autour de la transition circulaire.

    Fermé Exemple

    Région annulaire autour d'une caractéristique de transition circulaire

  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de présence/absence de cercle

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de présence/absence de cercle comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Graphique
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Graphique


Outil de présence/absence de cercle - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Cercle_1 » s'il s'agit du premier outil de cercle ajouté au projet. Sinon, il est incrémenté (par exemple, « Cercle_2 », « Cercle_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outils de présence/absence de cercle - Onglet Paramètres

Fermé Contraste de bord

Définit le score minimum de contraste de bord acceptable pour le bord détecté (1-100 ; par défaut = un « Paramètre intelligent » qui est généralement décrémenté jusqu’à détection du bord). Ce paramètre détermine la sensibilité de détection des bords de l’outil (sa capacité à faire la distinction entre la caractéristique et l’arrière-plan) ; utilisez ce paramètre avec l’option Graphique pour définir une plage acceptable.

Remarque : Si ce paramètre est configuré sur 0, l'outil peut trouver des bords inattendus.
Fermé Normalisation du score

Définit si les scores des bords seront normalisés par rapport à l’histogramme des niveaux de gris de la région.Ce paramètre permet de rechercher les bords dans des régions de faible contraste. Désactiver ce paramètre si vous êtes certains que les bords à détecter présentent un contraste élevé.

  • Coché (par défaut) : Normalise le score.
  • Non coché : Ne normalise pas le score.
Fermé Transition de bord

Définit le type de transition (Sombre vers clair, Clair vers sombre ou Les deux ; valeur par défaut = Les deux). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Largeur de transition

Définit la distance de pixels (1 à 50 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Chercher par

Définit la manière dont l’outil fait la distinction entre des transitions circulaires trouvées si plusieurs transitions circulaires sont présentes (par défaut = Meilleur score).

  • Meilleur score : la transition circulaire présentant le contraste le plus élevé sera choisie.
  • Le plus petit cercle : la transition circulaire ayant le diamètre le plus petit est choisie.
  • Le plus grand cercle : la transition circulaire ayant le diamètre le plus grand est choisie.
Fermé Résultat

Affiche le résultat de l’outil : Présent si une transition circulaire a été détectée ; Absent(e) si elle n’a pas été détectée ou si la transition circulaire détectée se trouve en dehors des limites spécifiées. Présent équivaut à une valeur booléenne de 1 (succès) ; Absent(e) équivaut à une valeur booléenne de 0 (échec).

Fermé Inverser le résultat
Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.


Outils de présence/absence de cercle - Graphique

Le Graphique est une représentation de la première dérivée des valeurs de niveau de gris contenues dans la région, les crêtes et vallées représentent le niveau des transitions majeures des bords.

Pour les outils détectant les bords (outils Bord et Cercle), l'axe du Score est une mesure pour la correspondance du bord trouvé avec les paramètres définis :

  • Un score positif indique que le bord fait la transition du sombre vers le clair ;
  • Un score négatif indique que le bord fait la transition du clair vers le sombre ;
  • Un score de 0 indique qu'aucun bord n'a été détecté.

L'axe Offset fait référence à la région définissant la fonction du bord, avec 0 représentant la limite de départ de la région, et l'autre valeur représentant la largeur maximum (en pixels) de la région. Le sommet des crêtes et des vallées le long de l'axe Offset indique la position du bord trouvé.

Remarque : Le graphique s'affiche sans tenir compte de l'état En ligne/Hors ligne et de l'état succès/échec de l'outil. Cependant, si l'outil est en échec, il est possible que le graphique ne soit pas mis à jour.


Outils de présence/absence - Netteté

L'outil de présence/absence de netteté détermine si une image est mise au point correctement ou non, en fonction du score de netteté dans la région. Il calcule une mesure de la netteté relative d'une image d'entrée, dans le cadre du processus itératif pour refaire la mise au point de l'objectif d'un système de vision In-Sight.

Le score de netteté de l'image indique le degré auquel la région dans l'image inclut les caractéristiques les plus petites pouvant être discernées dans une « scène » (c'est-à-dire l'objet et son arrière-plan, tels qu'ils ont été acquis dans l'image).

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de présence/absence de netteté

Une fois que l'outil a été ajouté, vous devez configurer la région dans l'image :

  1. Positionnez la région dans l'image de telle sorte qu'elle englobe les parties importantes de la « scène » (c'est-à-dire, l'objet et son arrière-plan). Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que la scène mesurée se trouve dans le même emplacement dans chaque image.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Une fois que l'outil a été ajouté, le score de netteté de l'image doit être comparée à un autre score de netteté d'image, pour la même scène identique (l'objet et l'arrière-plan sont les mêmes, le système de vision In-Sight reste dans la même orientation et position, l'éclairage reste le même, etc.). Un score de netteté d'une image unique ne transmet pas suffisamment d'informations sur la netteté absolue de l'intérieur de la région de l'image.
  4. Allez à l'étape Configurer l'image, et passez en mode Vidéo directe. Refaites la mise au point de l'objectif du système In-Sight, en vous assurant que rien d'autre n'a été modifié dans la scène.
  5. Quittez le mode Vidéo directe. L'outil calculera un nouveau score de netteté de l'image.
  6. Comparez le nouveau score au score précédent ; plus le score est élevé, plus la mise au point est précise.
  7. Répétez les étapes 4 et 5 jusqu'à ce que la mise au point soit considérée comme acceptable.
Remarque : Si la mise au point n'est toujours pas acceptable, pensez à changer l'objectif, régler la distance entre l'objectif et l'objet ou un autre paramètre d'acquisition d'image dans l'étape d'application Configurer l'image.


Réglage des paramètres de l'outil de présence/absence de netteté

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de présence/absence de netteté comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Limites de plages


Outil de présence/absence de netteté - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Netteté_1 » s'il s'agit du premier outil de netteté ajouté au projet. Sinon, il est incrémenté (par exemple, « Netteté_2 », « Netteté_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de présence/absence de netteté - Onglet Limites de plages

Fermé Maximum

Définit le score de netteté de l'image maximale acceptable. L'outil crée une « limite automatique » par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Netteté

Indique le score de netteté de l'image. Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Fermé Minimum

Définit le score de netteté de l'image minimal acceptable. L'outil crée une « limite automatique » par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outils de mesure - Distance

L'outil de mesure de distance calcule la distance entre deux caractéristiques d'entrée quelconques et rapporte la distance calculée.

Remarque : . L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

L'outil de mesure de distance est utile dans les cas où vous devez mesurer avec précision une pièce ou un objet. Par exemple, pour déterminer la distance entre les extrémités d'une pièce ou la distance entre les centres de deux trous.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de mesure de distance

Une fois l'outil ajouté, définissez les caractéristiques à mesurer.

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Commencez par sélectionner une des caractéristiques disponibles en cliquant dessus : elle devient rose et est reliée à un trait.
  3. Puis sélectionnez la deuxième caractéristique.
  4. EasyBuilder calcule alors automatiquement la distance entre les caractéristiques sélectionnées. EasyBuilder insère également un outil de présence/absence de transition et/ou un outil de présence/absence de cercle pour chacune des caractéristiques pas encore définies (selon l'outil et le type de caractéristique).
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de mesure de distance

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil de mesure de distance comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Limites de plages


Outil de mesure de distance - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Distance_1 » s'il s'agit du premier outil de Distance ajouté au projet. Sinon, il est incrémenté (par exemple, « Distance_2 », « Distance_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de mesure de distance - Onglet Paramètres

Fermé Mesure

Indique comment la distance sera calculée entre deux caractéristiques de transition : Point médian à ligne (paramètre par défaut, mesure la distance perpendiculaire entre les segments de transition) ou Point médian à Point médian.

Remarque :

ce contrôle est activé uniquement lors de la mesure de la distance par rapport à au moins une caractéristique de transition. Sinon, la distance est calculée automatiquement de la manière suivante :

  • Cercle à ligne : mesure la distance du centre du cercle à l'intersection perpendiculaire de la transition ou de la ligne de référence.
  • Point à ligne : mesure la distance du point à l'intersection perpendiculaire d'une transition ou d'une ligne de référence.
  • Cercle à point : mesure la distance du centre du cercle au point.
  • Cercle à cercle : mesure la distance du centre d'un cercle au centre d'un autre cercle.
  • Point à point : mesure la distance entre les deux points.

Les points font référence à une caractéristique (blob, cercle, transition, modèle ou point) déjà définie et sont reconnus comme suit :

  • Blob : mesure la distance à partir des coordonnées X,Y du centre de gravité du blob.
  • Cercle : mesure la distance à partir des coordonnées de centre X,Y du cercle.
  • Transition : mesure la distance à partir des coordonnées de point médian X,Y de la transition.
  • Modèle : mesure la distance à partir des coordonnées d'origine X,Y du modèle de forme.
  • Point : mesure la distance à partir des coordonnées X,Y du point.


Outil de mesure de distance - Onglet Limites de plages

Fermé Maximum

Définit la valeur de distance maximale acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Distance

Indique la distance actuelle mesurée entre deux caractéristiques. Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Remarque : à moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les mesures en pixels.
Fermé Minimum

Définit la valeur de distance minimale acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux limites de plages.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux limites de plages.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outils de mesure - Angle

L'Outil de mesure d'angle calcule l'angle entre deux caractéristiques des bords.

Par exemple, l'outil de mesure d'angle est utile dans les cas où vous devez mesurer avec précision une pièce ou un objet.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de mesure d'angle

Une fois l'outil ajouté, définissez les caractéristiques d'entrée à mesurer.

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Commencez par sélectionner une des caractéristiques disponibles en cliquant dessus : elle devient rose et est reliée à un trait.
  3. Puis sélectionnez la deuxième caractéristique.
  4. EasyBuilder calcule alors automatiquement l'angle entre les caractéristiques sélectionnées et dessine un graphique dans l'image, indiquant le point de mesure de l'angle et d'intersection des deux transitions. EasyBuilder insère également un outil de présence/absence de transition et/ou un outil de présence/absence de cercle pour chacune des caractéristiques pas encore définies (selon l'outil et le type de caractéristique).
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de mesure d'angle

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil de mesure d'angle comprend les éléments suivants :

  • Onglet Général
  • Onglet Limites de plages
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Limites de plages


Outil de mesure d'angle - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Angle_1 » s'il s'agit du premier outil de mesure d'angle ajouté au projet. Sinon, il est incrémenté (par exemple, « Angle_2 », « Angle_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de mesure d'angle - Onglet Limites de plages

Fermé Maximum

Définit la valeur d'angle maximale acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Distance

Indique l'angle mesuré actuel entre deux caractéristiques. Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Remarque : à moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les coordonnées X,Y en pixels.
Fermé Minimum

Définit la valeur d'angle minimale acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux limites de plages.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux limites de plages.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outils de mesure - Surface du blob et Surfaces des blobs (1-10)

Les outils de mesure de surface de blob et de surfaces des blobs (1-10) mesurent la surface de la caractéristique de blob la plus large localisée et en indiquent la taille. L'outil Surface de blob permet de mesurer un blob unique alors que l'outil Surfaces des blobs (1-10) est utilisé pour mesurer jusqu'à 10 blobs.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Les outils de mesure de surface de blob et de surfaces des blobs (1-10) sont utiles, par exemple, lorsque vous tentez d'évaluer la surface attendue d'une caractéristique ou de détecter des trous obstrués.

Configuration des outils

Réglage des paramètres des outils


Configuration des outils de mesure de surface de blob et de surfaces des blobs (1-10)

Une fois l'outil sélectionné, choisissez le type de région et configurez cette dernière dans l'image dans laquelle vous pensez détecter la ou les caractéristiques de blob :

  1. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région dans l'image dans laquelle vous pensez voir apparaître le ou les blob(s), en vous assurant qu'elle englobe complètement le ou les blob(s) et leurs emplacements possibles, et configurez-la. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement du ou des blob(s) reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

    Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres des outils de mesure de surface de blob et de surfaces des blobs (1-10)

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Les volets de paramètres des outils de mesure de surface de blob et de surfaces des blobs (1-10) comprennent les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
  • Onglet Tableau
  • Onglet Histogramme
  • Onglet Région composite
Remarque :
  • L'onglet Histogramme n'est pas affiché en cas d'échec de l'outil.
  • L'onglet Tableau est activé uniquement pour l'outil de mesure de surfaces des blobs (1-10).
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Limites de plages

Tableau

Histogramme

Onglet Région composite


Outil de mesure de surface de blob et de surfaces des blobs (1-10) - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Blob_1 » s'il s'agit du premier outil de blob ajouté au projet. Sinon, il est incrémenté (par exemple, « Blob_2 », « Blob_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de mesure de surface de blob et de surfaces des blobs (1-10) – Onglet Paramètres

Fermé Mode seuil

Définit le mode utilisé pour déterminer la valeur de niveau de gris servant à séparer les blobs de l'arrière-plan. Lorsque le paramètre Auto est sélectionné (paramètre par défaut), l'outil compense les changements de luminosité d'une image à l'autre à chaque nouvelle image acquise. Lorsque le paramètre Manuel est sélectionné, vous devez saisir et ajuster la valeur manuellement.

Fermé Seuil du blob

Définit la valeur de niveau de gris utilisée pour séparer les blobs de l'arrière-plan (0 à 255, lorsque l'option est activée). Ce contrôle, désactivé par défaut, requiert que le mode du seuil soit défini sur Manuel pour être activé. Utilisez l'histogramme pour définir une valeur optimale pour votre application.

Fermé Couleur du blob

Définit la couleur du blob (Noir, Blanc ou Indifférent ; valeur par défaut = Indifférent).

  • Indifférent = la couleur du blob n’est pas déterminée.
  • Noir = renvoie uniquement les blobs qui se trouvent sous le Seuil blob.
  • Blanc = renvoie uniquement les blobs qui se trouvent au-dessus du Seuil blob.
Fermé Limite

Définit l'une des deux méthodes de gestion des blobs situés à la limite de la région du blob (option désactivée par défaut) :

  • Désactivée : n'inclut pas les blobs situés à la limite de la région. Le blob doit être entièrement compris dans la région à détecter.
  • Activée : inclut les blobs situés à la limite de la région. Ces derniers sont détectés s'ils remplissent aussi les autres critères.
Fermé Surface minimale

Définit une limite de surface minimale sous la forme d'un nombre de pixels (0 à 16 777 216 ; valeur par défaut = 50) pour la détection des blobs. Seuls les blobs dont la surface est supérieure à la Surface minimale seront renvoyés.

Remarque : Le paramètre Minimum de l'onglet Limite de plage permet de définir les critères de succès ou d'échec de l'outil, alors que le paramètre Surface minimale permet de définir si les blobs doivent être signalés ou non.
Fermé Surface maximale

Définit une limite de surface maximale sous la forme d'un nombre de pixels (0 à 16 777 216 ; valeur par défaut = 307 200) pour la détection des blobs. Seuls les blobs dont la surface est inférieure à la Surface maximale seront renvoyés.

Remarque : Le paramètre Maximum de l'onglet Limite de plage permet de définir les critères de succès ou d'échec de l'outil, alors que le paramètre Surface maximale permet de définir si les blobs doivent être signalés ou non.
Fermé Nombre à chercher

Définit le nombre de blobs à détecter (1-10 ; par défaut = 1). La plupart des applications ne nécessitent qu'un seul repère. Plusieurs blobs peuvent toutefois être localisés, ce qui s'avère utile dans des applications dans lesquelles l'image comporte plusieurs pièces ou objets. Plus l'outil doit identifier de blobs, plus sa durée d'exécution est importante.

Fermé Trier par

Définit comment l'outil mesure et trie les blobs localisés (Surface, Ligne, Col, Grille : Ligne puis Col en partant du repère, Grille : Col puis Ligne en partant du repère, Distance par rapport à l'origine du repère, Angle par rapport à l'axe X du repère (sens antihoraire), Distance angulaire ; valeur par défaut = Surface) :

  • Surface = trie les blobs localisés en fonction de leur surface, de la plus grande à la plus petite.
  • Ligne = trie selon la distance le long de l'axe X de l'image, de la plus proche à la plus éloignée, par ordre décroissant.
  • Col = trie selon la distance le long de l'axe Y de l'image, de la plus proche à la plus éloignée, par ordre décroissant.
  • Grille : Ligne puis Col en partant du repère = trie selon la distance le long de l'axe X de l'image du repère en premier, puis le long de l'axe Y de l'image, de la plus proche à la plus éloignée, par ordre décroissant..
  • Grille : Col puis Ligne en partant du repère = trie selon la distance le long de l'axe Y de l'image du repère en premier, puis le long de l'axe X de l'image, de la plus proche à la plus éloignée, par ordre décroissant.
  • Distance par rapport à l'origine du repère = trie selon la distance entre le repère de référence et le centre de gravité du blob, de la plus proche à la plus éloignée, par ordre décroissant.
  • Angle par rapport à l'axe X du repère (sens antihoraire) = trie selon l'angle (0 à 360°) mesuré entre l'axe X de l'image du repère et le segment défini par le centre de gravité du blob et l'origine du repère, du plus proche au plus éloigné, par ordre décroissant.
  • Distance angulaire = trie selon la valeur absolue de l'angle (de -180 à 180°) mesuré entre l'axe X de l'image du repère et un segment défini par le centre de gravité du blob et l'origine du repère, du plus proche au plus éloigné.
Remarque : L'outil de mesure de surface de blob ne contient pas le paramètre Nombre à trouver.


Outil de mesure de surface de blob et de surfaces des blobs (1-10) - Onglet Limites de plages

Fermé Maximum

Définit la valeur de surface du blob maximale acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Surface du blob

Indique la surface du blob mesurée actuelle. Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Remarque : à moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les mesures en pixels.

Fermé Minimum

Définit la valeur de surface du blob minimale acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outil de mesure de surfaces des blobs (1-10) - Tableau

Remarque :
  • L'outil de mesure de blob ne prend pas en charge l'onglet Tableau, qui n'est disponible que pour l'outil de mesure des blobs (1-10).
  • Lorsque le paramètre Trier par est défini sur une autre option que Surface, les colonnes Ligne pixel et Col. pixel sont ajoutées au tableau. Ligne pixel et Col. pixel correspondent aux coordonnées de l'image basées sur la grille 2D du capteur d'image du système de vision In-Sight (lignes et colonnes du groupe). Il s'agit des valeurs (Y/X) opposées des coordonnées (X/Y) réelles.

  • Si l'option Orientation classique est activée (cochée) dans la zone de groupe Calibrer l'image avec des unités réelles de l'étape Configurer l'image, les coordonnées X et Y se trouveront dans le même espace de coordonnées que les coordonnées de l'image (Y/X).

L'onglet Tableau affiche les résultats des blobs détectés, en fonction du paramètre Nombre à chercher de l'onglet Paramètres :

Fermé Index

Indique l'ordre des blobs localisés, en fonction du paramètre Trier par de l'onglet Paramètres ; de 1 à 10 (dans l'ordre numérique d'EasyBuilder, 0=1).

Fermé Surface

Renvoie la surface du blob localisé (mesurée en pixels).

Fermé X

Renvoie l'abscisse du centre de gravité du blob localisé ; à moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.

Fermé Y

Renvoie l'ordonnée du centre de gravité du blob localisé ; à moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.

Fermé Angle

Renvoie l'angle du centre de gravité du blob localisé par rapport au centre de la région.

Fermé Erreur

Renvoie les erreurs détectées, le cas échéant, pour les blobs localisés.

Fermé Ligne pixel

Renvoie l'abscisse (X) de l'image du centre de gravité du blob localisé.

Fermé Col. pixel

Renvoie l'ordonnée (Y) de l'image du centre de gravité du blob localisé.


Outil de mesure de surface de blob et de surfaces des blobs (1-10) - Histogramme

L'Histogramme affiche un graphique des valeurs de niveau de gris des pixels dans la région.

  • L'axe X du graphique représente le nombre total de valeurs de niveau de gris (0 à 255, ou 256 nuances de gris au total).
  • L'axe Y du graphique représente le nombre de pixels pour une valeur de niveau de gris donnée, l'échelle est établie en affichant la valeur de niveau de gris avec le plus grand nombre de pixels.
  • La ligne bleue verticale indique le seuil utilisé pour séparer la région de l'image en pixels noirs et blancs ; les valeurs situées à gauche de la ligne sont considérées comme noires et les valeurs de droite comme blanches.
Remarque : Le graphique s'affiche sans tenir compte de l'état En ligne/Hors ligne et de l'état succès/échec de l'outil. Cependant, si l'outil est en échec, il est possible que le graphique ne soit pas mis à jour.


Outils de mesure de surface de blob et de surfaces des blobs (1-10) - Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils de mesure - Surface du blob de couleur et Surfaces des blobs de couleur (1-10)

Les outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10) mesurent la surface de la caractéristique de blob la plus large localisée et en indiquent la taille. L'outil Surface du blob de couleur permet de mesurer un blob unique alors que l'outil Surfaces des blobs de couleur (1-10) est utilisé pour mesurer jusqu'à 10 blobs.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Les outils Surface du blob de couleur et Surfaces des blobs de couleur (1-10) utilisent une bibliothèque de modèles de couleurs appris pour déterminer le nombre de pixels présents dans la région qui correspondent aux modèles de couleurs sélectionnés et appris de la bibliothèque. L'outil crée ensuite une image de sortie binaire en niveau de gris, ou chaque pixel correspondant à un Modèle de couleur actif est défini sur Blanc (255), tandis que les autres pixels sont définis sur Noir (0). L'outil utilise cette image de sortie binaire pour rechercher, dans l'image, les caractéristiques de blob créées par les modèles de couleurs actifs.

Configuration des outils

Réglage des paramètres des outils


Configuration des outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10)

Une fois l'outil sélectionné, choisissez le type de région et configurez cette dernière dans l'image dans laquelle vous pensez détecter la ou les caractéristiques de blob :

  1. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région dans l'image dans laquelle vous pensez voir apparaître le ou les blob(s), en vous assurant qu'elle englobe complètement le ou les blob(s) et leurs emplacements possibles, et configurez-la. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement du ou des blob(s) reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

    Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Une fois la région de recherche configurée, configurez la bibliothèque de couleurs de l'outil et activez le ou les modèles de couleurs appropriés :

    • Si un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire) est ajouté pour la première fois, commencez par configurer une ou plusieurs bibliothèques de couleurs et leur(s) modèle(s) de couleurs.

    • Si un autre outil a déjà été ajouté et que vous souhaitez utiliser une bibliothèque de couleurs existante et ses modèles de couleurs appris, sélectionnez la bibliothèque de couleurs de votre choix sous l'onglet Paramètres, puis activez les modèles de couleurs voulus en les cochant dans l'onglet Bibliothèque.

    • Par défaut, l'outil déclenche automatiquement un échec tant qu'aucune bibliothèque de couleurs n'a été définie. Si une bibliothèque de couleurs a été définie, l'outil utilise automatiquement cette bibliothèque et active tous les modèles de couleurs qu'elle contient.

  4. Une fois le ou les modèles de couleurs et la ou les bibliothèques de couleurs configurés, l'outil traite l'image et tous les pixels de la région de recherche qui correspondent au ou aux modèles de couleurs sélectionnés deviennent blancs (255), alors que ceux qui ne correspondent pas au ou aux modèles de couleurs sélectionnés deviennent noirs (0).
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres des outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10)

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Les volets de paramètres des outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10) comprennent les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
  • Onglet Bibliothèque de couleurs
  • Onglet Tableau
  • Onglet Région composite
Remarque : l'onglet Tableau n'est activé que pour l'outil de mesure de surfaces des blobs de couleur (1-10).
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Limites de plages

Onglet Bibliothèque

Onglet Tableau

Onglet Région composite


Outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10) - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « SurfacesBlobCouleur_1 » s'il s'agit du premier outil de surface de blob de couleur ajouté au projet. Sinon, il est incrémenté (par exemple, « SurfacesBlobCouleur_2 », « SurfacesBlobCouleur_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10) - Onglet Paramètres

Fermé Apprendre la couleur

Affiche la boîte de dialogue Apprentissage ExtractColor , utilisée pour définir le ou les modèles de couleurs de la bibliothèque de couleurs sélectionnée.

Fermé Bibliothèque de couleurs

Définit la bibliothèque de couleurs utilisée comme référence par l'outil. Sur la liste déroulante, sélectionnez la bibliothèque de couleurs à modifier puis cliquez sur le bouton Apprendre la couleur pour afficher la boîte de dialogue Apprentissage ExtractColor. Chaque bibliothèque de couleurs peut compter jusqu'à 100 modèles de couleurs distincts, composés de couleurs individuelles.

Les projets EasyBuilder peuvent contenir 5 bibliothèques de couleurs maximum, qui peuvent être partagées par les outils suivants :

  • Outil de recherche de blob de couleur
  • Outil de recherche de blobs de couleur (1-10)
  • Outil de présence/absence basé sur le comptage de pixels
  • Outil de mesure de surface de blob de couleur
  • Outil de mesure de surfaces des blobs de couleur (1-10)
  • Outil de comptage de blobs de couleur
  • Outil d'identification du modèle de couleurs
  • Outil de filtre d'image couleur -> binaire
Fermé Limite

Définit l'une des deux méthodes de gestion des blobs situés à la limite de la région du blob (option désactivée par défaut) :

  • Désactivée : n'inclut pas les blobs situés à la limite de la région. Le blob doit être entièrement compris dans la région à détecter.
  • Activée : inclut les blobs touchant le bord de la région. Ces derniers sont détectés s'ils remplissent aussi les autres critères.
Fermé Trier par

Définit comment l'outil mesure et trie les blobs localisés (Surface, Ligne, Col, Grille : Ligne puis Col en partant du repère, Grille : Col puis Ligne en partant du repère, Distance par rapport à l'origine du repère, Angle par rapport à l'axe X du repère (sens antihoraire), Distance angulaire ; valeur par défaut = Surface) :

  • Surface = trie les blobs localisés en fonction de leur surface, de la plus grande à la plus petite.
  • Ligne = trie selon la distance le long de l'axe X de l'image, de la plus proche à la plus éloignée, par ordre décroissant.
  • Col = trie selon la distance le long de l'axe Y de l'image, de la plus proche à la plus éloignée, par ordre décroissant.
  • Grille : Ligne puis Col en partant du repère = trie selon la distance le long de l'axe X de l'image du repère en premier, puis le long de l'axe Y de l'image, de la plus proche à la plus éloignée, par ordre décroissant..
  • Grille : Col puis Ligne en partant du repère = trie selon la distance le long de l'axe Y de l'image du repère en premier, puis le long de l'axe X de l'image, de la plus proche à la plus éloignée, par ordre décroissant.
  • Distance par rapport à l'origine du repère = trie selon la distance entre le repère de référence et le centre de gravité du blob, de la plus proche à la plus éloignée, par ordre décroissant.
  • Angle par rapport à l'axe X du repère (sens antihoraire) = trie selon l'angle (0 à 360°) mesuré entre l'axe X de l'image du repère et le segment défini par le centre de gravité du blob et l'origine du repère, du plus proche au plus éloigné, par ordre décroissant.
  • Distance angulaire = trie selon la valeur absolue de l'angle (de -180 à 180°) mesuré entre l'axe X de l'image du repère et un segment défini par le centre de gravité du blob et l'origine du repère, du plus proche au plus éloigné.
Fermé Nombre à trouver

Définit le nombre de blobs à détecter (1 à 10 ; valeur par défaut = 1). Plus l'outil doit identifier de blobs, plus sa durée d'exécution est importante.

Remarque : Ce contrôle est uniquement disponible pour l'outil de mesure de surfaces des blobs de couleur (1-10).
Fermé Surface minimale

Définit une limite de surface minimale sous la forme d'un nombre de pixels (0 à 16 777 216 ; valeur par défaut = 100) pour la détection des blobs. Seuls les blobs dont la surface est supérieure à la Surface minimale seront renvoyés.

Remarque : Le paramètre Minimum de l'onglet Limite de plage permet de définir les critères de succès ou d'échec de l'outil, alors que le paramètre Surface minimale permet de définir si les blobs doivent être signalés ou non.
Fermé Surface maximale

Définit une limite de surface maximale sous la forme d'un nombre de pixels (0 à 16 777 216 ; valeur par défaut = 100 000) pour la détection des blobs. Seuls les blobs dont la surface est inférieure à la Surface maximale seront renvoyés.

Remarque : Le paramètre Maximum de l'onglet Limite de plage permet de définir les critères de succès ou d'échec de l'outil, alors que le paramètre Surface maximale permet de définir si les blobs doivent être signalés ou non.
Fermé Facteur de lissage

Définit le facteur (0 à 25 ; valeur par défaut = 1) à utiliser pour le lissage de l'image. Pour spécifier l'absence de tout lissage, définissez la valeur sur 0.

Fermé Afficher l'image d'origine
  • Désactivé (par défaut) : La région sélectionnée affiche une image de sortie binaire en niveaux de gris.
  • Activée : La région sélectionnée affiche une image d'entrée d'origine.


Outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10) - Onglet Limites de plages

Fermé Maximum

Définit la valeur de surface du blob maximale acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Surface du blob

Indique la surface du blob mesurée actuelle. Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Remarque : à moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les mesures en pixels.
Fermé Minimum

Définit la valeur de surface du blob minimale acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10) - Onglet Bibliothèque

Fermé Liste Modèles de couleurs

Affiche une liste en lecture seule de modèle(s) de couleurs contenus dans la bibliothèque de couleurs sélectionnée. Les modèles de couleurs sont activés et désactivés en cochant ou décochant la case en regard de Modèles de couleurs.

Fermé Tableau de couleurs

Affiche un tableau ordonné en lecture seule de la ou des couleurs dans le modèle de couleurs sélectionné.

Fermé Nom de la couleur

Affiche le nom de la ou des couleurs du modèle de couleurs sélectionné.

Fermé RVB

Affiche les valeurs RVB de la ou des couleurs du modèle de couleurs sélectionné.

Fermé Opération

Affiche l'opération (Ajouter ou Soustraire) de la ou des couleurs du modèle de couleurs sélectionné.


Outil de mesure de surfaces des blobs de couleur (1-10) - Onglet Tableau

Remarque :
  • l'outil de mesure de surface de blob de couleur ne prend pas en charge l'onglet Tableau, qui n'est disponible que pour l'outil de mesure de surfaces des blobs de couleur (1-10).
  • Lorsque le paramètre Trier par est défini sur une autre option que Surface, les colonnes Ligne pixel et Col. pixel sont ajoutées au tableau. Ligne pixel et Col. pixel correspondent aux coordonnées de l'image basées sur la grille 2D du capteur d'image du système de vision In-Sight (lignes et colonnes du groupe). Il s'agit des valeurs (Y/X) opposées des coordonnées (X/Y) réelles.

  • Si l'option Orientation classique est activée (cochée) dans la zone de groupe Calibrer l'image avec des unités réelles de l'étape Configurer l'image, les coordonnées X et Y se trouveront dans le même espace de coordonnées que les coordonnées de l'image (Y/X).

L'onglet Tableau affiche les résultats des blobs détectés, en fonction du paramètre Nombre à chercher de l'onglet Paramètres :

Fermé Index

Indique l'ordre des blobs localisés, en fonction du paramètre Trier par de l'onglet Paramètres ; de 1 à 10 (dans l'ordre numérique d'EasyBuilder, 0=1).

Fermé Surface

Renvoie la surface du blob localisé (mesurée en pixels).

Fermé X

Renvoie l'abscisse du centre de gravité du blob localisé ; à moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.

Fermé Y

Renvoie l'ordonnée du centre de gravité du blob localisé ; à moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.

Fermé Angle

Renvoie l'angle du centre de gravité du blob localisé par rapport au centre de la région.

Fermé Erreur

Renvoie les erreurs détectées, le cas échéant, pour les blobs localisés.

Fermé Ligne pixel

Renvoie l'abscisse (X) de l'image du centre de gravité du blob localisé.

Fermé Col. pixel

Renvoie l'ordonnée (Y) de l'image du centre de gravité du blob localisé.


Outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10) - Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils de mesure - Diamètre du cercle

L'outil de mesure de diamètre du cercle sert à mesurer le diamètre d'une caractéristique circulaire.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de mesure de diamètre

Une fois l'outil ajouté, sélectionnez la caractéristique d'entrée à mesurer.

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Sélectionnez une des Smart Features disponibles en cliquant simplement dessus. Elle devient rose.
  3. Confirmez votre choix en cliquant sur le bouton OK (ou cliquez sur le bouton Annuler pour annuler l'action).
  4. EasyBuilder calcule alors automatiquement le diamètre de la caractéristique sélectionnée. EasyBuilder insère également un outil de présence/absence de transition et/ou un outil de présence/absence de cercle pour chacune des caractéristiques pas encore définies (selon l'outil et le type de caractéristique).
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de mesure de diamètre

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil de mesure de diamètre comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
  • Graphique
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Limites de plages

Graphique


Outil de mesure de diamètre - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Cercle_1 » s'il s'agit du premier outil de cercle ajouté au projet. Sinon, il est incrémenté (par exemple, « Cercle_2 », « Cercle_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de mesure de diamètre du cercle - Onglet Paramètres

Fermé Contraste de bord

Définit le score minimum de contraste de bord acceptable pour le bord détecté (1-100 ; par défaut = un Paramètre intelligent qui est généralement décrémenté jusqu’à détection du bord). Ce paramètre détermine la sensibilité de détection des bords de l’outil (sa capacité à faire la distinction entre la caractéristique et l’arrière-plan) ; utilisez ce paramètre avec l’option Graphique pour définir une plage acceptable.

Remarque : Si ce paramètre est configuré sur 0, l'outil peut trouver des bords inattendus.
Fermé Normalisation du score

Définit si les scores des bords seront normalisés par rapport à l’histogramme des niveaux de gris de la région.Ce paramètre permet de rechercher les bords dans des régions de faible contraste. Désactiver ce paramètre si vous êtes certains que les bords à détecter présentent un contraste élevé.

  • Coché (par défaut) : Normalise le score.
  • Non coché : Ne normalise pas le score.
Fermé Transition de bord

Définit le type de transition (Sombre vers clair, Clair vers sombre ou Les deux ; valeur par défaut = Les deux). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Largeur de transition

Définit la distance de pixels (1 à 50 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Chercher par

Définit la manière dont l’outil fait la distinction entre des transitions circulaires trouvées si plusieurs transitions circulaires sont présentes (par défaut = Meilleur score).

  • Meilleur score : la transition circulaire présentant la transition la mieux définie (contraste et luminosité les plus élevés) est choisie.
  • Le plus petit cercle : la transition circulaire ayant le diamètre le plus petit est choisie.
  • Le plus grand cercle : la transition circulaire ayant le diamètre le plus grand est choisie.


Outil de mesure de diamètre - Onglet Limites de plages

Fermé Maximum

Définit le plus grand diamètre acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Diamètre

Indique le diamètre mesuré actuel de la transition circulaire localisée. Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Remarque : À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
Fermé Minimum

Définit le plus petit diamètre acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux limites de plages.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux limites de plages.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outil de mesure de diamètre - Graphique

Le Graphique est une représentation de la première dérivée des valeurs de niveau de gris contenues dans la région, les crêtes et vallées représentent le niveau des transitions majeures des bords.

Pour les outils détectant les bords (outils Bord et Cercle), l'axe du Score est une mesure pour la correspondance du bord trouvé avec les paramètres définis :

  • Un score positif indique que le bord fait la transition du sombre vers le clair ;
  • Un score négatif indique que le bord fait la transition du clair vers le sombre ;
  • Un score de 0 indique qu'aucun bord n'a été détecté.

L'axe Offset fait référence à la région définissant la fonction du bord, avec 0 représentant la limite de départ de la région, et l'autre valeur représentant la largeur maximum (en pixels) de la région. Le sommet des crêtes et des vallées le long de l'axe Offset indique la position du bord trouvé.

Remarque : Le graphique s'affiche sans tenir compte de l'état En ligne/Hors ligne et de l'état succès/échec de l'outil. Cependant, si l'outil est en échec, il est possible que le graphique ne soit pas mis à jour.


Outils de mesure - Concentricité du cercle

L'outil de mesure de concentricité de cercle permet de mesurer la distance entre les centres de deux caractéristiques de transition circulaires.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Cet outil permet, par exemple, de vérifier qu'une étiquette ronde est bien centrée sur un bouchon circulaire ou de mesurer la concentricité d'un trou fraisé.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de mesure de concentricité de cercle

Une fois l'outil ajouté, définissez les caractéristiques d'entrée (caractéristiques circulaires ou cercles de référence) qui serviront à mesurer la concentricité du cercle :

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Commencez par sélectionner une des caractéristiques disponibles en cliquant dessus : elle devient rose et est reliée à un trait.
  3. Puis sélectionnez la deuxième caractéristique.
  4. EasyBuilder calcule alors automatiquement la distance entre les caractéristiques sélectionnées EasyBuilder insère également un outil de présence/absence de transition et/ou un outil de présence/absence de cercle pour chacune des caractéristiques pas encore définies (selon l'outil et le type de caractéristique).
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de mesure de concentricité de cercle

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil de mesure de concentricité de cercle comprend les éléments suivants :

  • Onglet Général
  • Onglet Limites de plages
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Limites de plages


Outil de mesure de concentricité de cercle - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Concentricité_1 » s'il s'agit du premier outil de Concentricité du cercle ajouté au projet. Sinon, il est incrémenté (par exemple, « Concentricité_2 », « Concentricité_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de mesure de concentricité de cercle - Onglet Limites de plages

Fermé Distance

Indique la distance actuelle mesurée entre les centres des deux transitions circulaires localisées. Les valeurs égales à ou comprises entre 0 et le paramètre Maximum sont classées comme Succès.

Remarque : à moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les mesures en pixels.
Fermé Maximum

Définit la valeur de distance maximale acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux limites de plages.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux limites de plages.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outils de mesure - Mesure du rayon

L'outil de mesure du rayon permet de définir une caractéristique de transition en arc de cercle et de créer une ligne et un point de référence afin de représenter l'axe de la courbure. Il renvoie le rayon de courbure.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Utilisation de l'outil de mesure de rayon

Après avoir ajouté l'outil, vous devrez configurer la région de l'image qui servira à définir la caractéristique de transition en arc de cercle :

  1. Positionnez la région sur la caractéristique de transition en arc de cercle.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. EasyBuilder calcule alors automatiquement le rayon de courbure et crée une ligne et un point de référence représentant l'axe de la courbure.
  4. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et réglez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de mesure de rayon

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de mesure de rayon comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Limites de plages


Outil de mesure de rayon - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « Courbure_1 » s'il s'agit du premier outil de mesure de rayon ajouté au projet. Sinon, il est incrémenté (par exemple, « Courbure_2 », « Courbure_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil Mesure du rayon - Onglet Paramètres

Fermé Contraste de bord

Définit le plus petit score de contraste de transition acceptable pour la transition localisée (1 à 100 ; valeur par défaut = un paramètre automatique décrémenté automatiquement jusqu'à ce qu'une transition soit détectée). Ce paramètre détermine la sensibilité de détection de transition de l'outil, c'est-à-dire sa capacité à distinguer la caractéristique de l'arrière-plan. Utilisez-le conjointement au graphique de l'outil pour définir une plage acceptable.

Remarque : Si ce paramètre est configuré sur 0, l'outil peut trouver des bords inattendus.
Fermé Normalisation du score

Définit si les scores des bords seront normalisés par rapport à l’histogramme des niveaux de gris de la région.Ce paramètre permet de rechercher les bords dans des régions de faible contraste. Désactiver ce paramètre si vous êtes certains que les bords à détecter présentent un contraste élevé.

  • Coché (par défaut) : Normalise le score.
  • Non coché : Ne normalise pas le score.
Fermé Transition de bord

Définit le type de transition (Sombre vers clair, Clair vers sombre ou Les deux ; valeur par défaut = Les deux). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Largeur de transition

Définit la distance de pixels (1 à 50 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Chercher par

Définit la manière dont l'outil distingue les transitions localisées lorsque plusieurs transitions sont présentes (valeur par défaut = Le meilleur score).

  • Le meilleur score : la transition présentant le contraste le plus élevé sera choisie.
  • La première transition : la transition la plus proche de l'origine du sens de balayage de la région sera choisie.
  • La dernière transition : la transition la plus éloignée de l'origine du sens de balayage de la région sera choisie.


Outil de mesure de rayon - Onglet Limites de plages

Fermé Maximum

Définit le plus grand rayon acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Rayon (unités)

Indique le rayon mesuré actuel de la transition en arc de cercle localisée. Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Remarque : À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
Fermé Minimum

Définit le plus petit rayon acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outils de mesure - Points Min./Max.

L'outil de mesure de points Min./Max. mesure la position des transitions et détermine les points de transitions les plus proches et les plus éloignés de la transition détectée ou de la région qui définit la transition. Il utilise des groupes Caliper d'analyse des transitions pour obtenir les emplacements précis des transitions. Une fois la transition identifiée, l'outil construit une ligne ou un cercle ajusté(e) de façon optimale (selon que la transition présente ou non une courbe) sur la transition. Il renvoie ensuite les points de transitions les plus proches et les plus éloignés de la ligne ou du cercle ajusté(e) de façon optimale.

Remarque :
  • À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
  • Toutes les valeurs d'entrée sont en pixels, que l'outil ait ou non été calibré avec des unités réelles.

L'outil de mesure de points Min./Max. permet de s'assurer que la pièce ou l'objet ne contient aucune transition décalée par rapport à sa position attendue. Par exemple, pour vous assurer que la transition d'une lame ne présente pas de petites égratignures ou entailles, ni d'ergots.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de mesure de points Min./Max.

Après avoir ajouté l'outil, vous devrez configurer la région masquée de l'image sur la transition à inspecter :

  1. Positionnez et configurez la région dans l'image sur la transition. Lors du positionnement de la région, assurez-vous que les transitions sont parallèles au sens de recherche de la région, et que la région englobe le plus possible la transition, tout en excluant le bruit superflu ou indésirable de la région.

    Remarque : La ligne en pointillés jaune dans la Région masquée définit la zone au sein de la région dans laquelle les transitions seront détectées.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Après avoir confirmé la région, sélectionnez les divers onglets, Transitions, Score de la transition et Ajustement, et réglez les paramètres et la région selon le besoin pour s'assurer que l'outil détecte les transitions possibles correctes et crée la ligne ou le cercle ajusté(e) de façon optimale correct(e). Lors de la configuration initiale de l'outil, utilisez une image qui contient la transition idéale. Les acquisitions d'images suivantes contiendront alors les transitions possibles qui seront inspectées pour déterminer la présence éventuelle de déviations telles que des défauts ou des écarts.
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de mesure de points Min./Max.

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de mesure de points Min./Max. comprend les onglets suivants :

  • Onglet Général
  • Onglet Transitions
  • Onglet Score de la transition
  • Onglet Ajustement
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Transitions

Onglet Score de la transition

Onglet Ajustement


Outil de mesure de points Min./Max. - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrée/Sorties et Communication). Le nom par défaut est « PointsMinMax_1 » s'il s'agit du premier outil de mesure de points min./max. ajouté au projet. Sinon, il est incrémenté (par exemple, « PointsMinMax_2 », « PointsMinMax_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de mesure de points Min./Max. - Onglet Transitions

Lorsque l'onglet Transitions est sélectionné, l'outil affiche toutes les transitions détectées (en vert foncé) au sein de la région. Vous pouvez ajuster les paramètres Taille du caliper, Espacement de caliper, Largeur de transition et Contraste minimum, selon le besoin, pour isoler les transitions voulues.

Vous pouvez également choisir d'afficher tous les calipers en activant le paramètre Afficher tous les calipers.

La région peut également être sélectionnée et ajustée sous cet onglet.

Fermé Taille du caliper

Définit le nombre de pixels, par caliper, à analyser dans le sens de l'inspection (1 à 639 ; valeur par défaut = 5).

Fermé Espacement de caliper

Définit la distance, en pixels, entre la fin d'un caliper et le début du caliper suivant (-1 à 639 ; valeur par défaut = 0).

Fermé Largeur de transition

Définit la distance de pixels (1 à 10 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Contraste minimum

Définit la transition de contraste minimale en niveaux de gris (1 à 255 ; valeur par défaut = 10) pour être considérée comme une transition.

Fermé Nombre de calipers

Affiche le nombre total de calipers dans la région.

Fermé Index du caliper

Définit le caliper individuel à isoler et à afficher.

Fermé Afficher tous les calipers

Définit si tous les calipers dans la région sont ou non affichés à tout moment. Les calipers sont masqués par défaut.


Outil de mesure de points Min./Max. - Onglet Score de la transition

Lorsque l'onglet Score de la transition est sélectionné, l'outil affiche toutes les transitions possibles détectées (indiquées par des petits cercles de couleur) au sein de la région (qui peut être sélectionnée et ajustée) et la ligne ou le cercle ajusté(e) de façon optimale résultant(e). Les transitions possibles sont les transitions qui peuvent être prises en compte lors de la construction de la ligne ou du cercle ajusté(e) de façon optimale. Réglez les paramètres pour isoler les transitions possibles voulues.

Tous les défauts et écarts détectés sont également affichés.

Fermé Détection du sens de la transition

Définit le sens dans lequel l'outil tente de détecter les transitions par rapport à la région (Gauche -> droite ou Droite -> gauche ; valeur par défaut = Gauche -> droite).

Fermé Transition

Définit le type de transition (Sombre vers clair, Clair vers sombre ou Indifférent; valeur par défaut = Indifférent). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Règle:Première transition

Définit si la première paire de transitions détectée est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Règle:Transition la plus marquée

Définit si la transition affichant le contraste le plus élevé est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Seuil de score

Définit un seuil de score pour filtrer les transitions avec des scores (0 à 255 ; valeur par défaut = 10) inférieurs à cette valeur.


Outil de mesure de points Min./Max. - Onglet Ajustement

Lorsque l'onglet Ajustement est sélectionné, l'outil affiche toutes les transitions possibles détectées au sein de la région et la ligne ou le cercle ajusté(e) de façon optimale résultant(e). Les transitions possibles, indiquées par des petits cercles, sont les transitions qui peuvent être prises en compte lors de la construction de la ligne ou du cercle ajusté(e) de façon optimale.

Fermé Ajustement de la ligne

Définit le type de ligne ajustée de façon optimale (Aucun, Ajustement de la ligne droite; Ajustement du cercle, Ajustement automatique ou Région ; valeur par défaut = Ajustement automatique) qui sera construite à partir des transitions détectées.

  • Lorsque Aucun est sélectionné, l'outil ne crée pas de ligne ajustée de façon optimale et la position des transitions détectées est mesurée par rapport au centre de la région.
  • Lorsque Ajustement de la ligne droite est sélectionné, l'outil crée une ligne droite ajustée de façon optimale à partir des transitions détectées, et la position des transitions détectées est mesurée par rapport à la ligne ajustée de façon optimale.
  • Lorsque Ajustement du cercle est sélectionné, l'outil crée une ligne circulaire ajustée de façon optimale à partir des transitions détectées, et la position des transitions détectées est mesurée par rapport à la ligne ajustée de façon optimale.
  • Lorsque Ajustement automatique est sélectionné, l'outil crée automatiquement une ligne droite ou circulaire ajustée de façon optimale à partir des transitions détectées, et la position des transitions détectées est mesurée par rapport à la ligne ajustée de façon optimale.
  • Lorsque Région est sélectionné, l'outil crée automatiquement une ligne droite ou circulaire ajustée de façon optimale à partir des transitions détectées, et la position des transitions détectées est mesurée par rapport au côté de la région.
Fermé Observations aberrantes du filtre

Définit si l'outil supprime ou non les points de la ligne ajustée de façon optimale qui se trouvent au-delà de la distance définie par le paramètre Ajuster le filtre de distance (ce paramètre est désactivé par défaut).

Fermé Ajuster le filtre de distance

Définit la distance (1 à 1 920 ; valeur par défaut = 2), en pixels, à laquelle une transition doit se trouver par rapport à la ligne ajustée de façon optimale d'origine pour être utilisée dans un nouveau calcul d'ajustement. Ce paramètre aide à éviter que les défauts n'affectent l'ajustement de ligne.

Remarque : le paramètre Observations aberrantes du filtre doit être coché (activé) pour utiliser ce paramètre.
Fermé Distance de filtrage du point le plus éloigné

Définit la distance (1 à 1 920 ; valeur par défaut = 1 000) au-delà de laquelle les transitions ne sont pas utilisées pour déterminer les distances minimale et maximale. Toute transition supérieure à cette valeur sera ignorée.

Fermé Nouveau score

Définit si les transitions détectées sont réévaluées pour s'assurer que les transitions détectées initialement ignorées ont été filtrées correctement (ce paramètre est activé par défaut).

Fermé Nouvel ajustement

Définit si l'outil réajuste ou non la ligne ajustée de façon optimale après la réévaluation des transitions (ce paramètre est activé par défaut).

Remarque : l'outil est plus précis lorsque ce paramètre est activé, mais sa durée d'exécution est plus longue.
Fermé Résultat

Affiche la ligne ajustée de façon optimale dans l'image et renvoie l'emplacement des points les plus proches et les plus éloignés de la ligne ajustée de façon optimale.


Outils de comptage - Blobs

L'outil de comptage de blobs compte le nombre de blobs présents dans une région de l'image.

L'outil de comptage de blobs est l'un des outils les plus rapides. Il permet notamment de localiser les caractéristiques de blob plus rapidement qu'un outil de présence/absence de modèle. Utile dans de nombreuses applications de comptage, il permet, par exemple, de s'assurer que le nombre de broches d'un connecteur est correct ou de compter le nombre de pépites de chocolat dans un biscuit.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de comptage de blobs

Une fois l'outil sélectionné, choisissez le type de région et configurez cette dernière dans l'image dans laquelle vous pensez détecter la ou les caractéristiques de blob :

Remarque : En choisissant les blobs à utiliser pour votre inspection, sélectionnez des blobs présentant un contraste important entre les pixels clairs et foncés.

  1. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région dans l'image dans laquelle vous pensez voir apparaître le ou les blob(s), en vous assurant qu'elle englobe complètement le ou les blob(s) et leurs emplacements possibles, et configurez-la. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement du ou des blob(s) reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

    Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  4. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de comptage de blobs

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de comptage de blobs comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
  • Onglet Histogramme
  • Onglet Région composite
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Limites de plages

Onglet Histogramme

Onglet Région composite


Outil de comptage de blobs - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Blob_1 » s'il s'agit du premier outil de blob ajouté au projet. Sinon, il est incrémenté (par exemple, « Blob_2 », « Blob_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de comptage de blobs - Onglet Paramètres

Fermé Mode du seuil

Définit le mode utilisé pour déterminer la valeur de niveau de gris servant à séparer les blobs de l'arrière-plan. Lorsque le paramètre Auto est sélectionné (paramètre par défaut), l'outil compense les changements de luminosité d'une image à l'autre à chaque acquisition d'image. Lorsque le paramètre Manuel est sélectionné, vous devez saisir et ajuster la valeur manuellement.

Fermé Seuil du blob

Définit la valeur de niveau de gris utilisée pour séparer les blobs de l'arrière-plan (0 à 255, lorsque l'option est activée). Ce contrôle, désactivé par défaut, requiert que le Mode du seuil soit défini sur Manuel pour être activé. Utilisez le graphique pour définir une valeur optimale pour votre application.

Fermé Couleur du blob

Définit la couleur du blob (Noir, Blanc ou Indifférent ; valeur par défaut = Indifférent).

  • Indifférent : il n'existe aucune exigence relative à la couleur du blob.
  • Noir : renvoie uniquement les blobs inférieurs au Seuil du blob.
  • Blanc : renvoie uniquement les blobs supérieurs au Seuil du blob.
Fermé Limite

Définit l'une des deux méthodes de gestion des blobs situés à la limite de la région du blob (option désactivée par défaut) :

  • Désactivée - N'inclut pas les blobs situés à la limite de la région. Le blob doit être entièrement compris dans la région à détecter.
  • Activée - Inclut les blobs situés à la limite de la région. Ces derniers sont détectés s'ils remplissent aussi les autres critères.
Fermé Surface minimale

Définit une limite de surface minimale sous la forme d'un nombre de pixels (0 à 900000 ; valeur par défaut = 100) pour tous les blobs détectés. Seuls les blobs dont la surface est supérieure à la surface minimale seront reconnus.

Fermé Surface maximale

Définit une limite de surface maximale sous la forme d'un nombre de pixels (0 à 900000 ; valeur par défaut = 100000) pour tous les blobs détectés. Seuls les blobs dont la surface est inférieure à la surface maximale seront reconnus.


Outil de comptage de blobs - Onglet Limites de plages

Fermé Maximum

Définit le plus grand nombre acceptable de blobs à détecter. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Nombre de blobs

Indique le nombre actuel de blobs détectés (les blobs comptabilisés dans l'image sont basés sur un ordre numérique où 0 = 1). Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Fermé Minimum

Définit le plus petit nombre acceptable de blobs à détecter. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outil de comptage de blobs - Onglet Histogramme

L'Histogramme affiche un graphique des valeurs de niveau de gris des pixels dans la région.

  • L'axe X du graphique représente le nombre total de valeurs de niveau de gris (0 à 255, ou 256 nuances de gris au total).
  • L'axe Y du graphique représente le nombre de pixels pour une valeur de niveau de gris donnée, l'échelle est établie en affichant la valeur de niveau de gris avec le plus grand nombre de pixels.
  • La ligne bleue verticale indique le seuil utilisé pour séparer la région de l'image en pixels noirs et blancs ; les valeurs situées à gauche de la ligne sont considérées comme noires et les valeurs de droite comme blanches.
Remarque : Le graphique s'affiche sans tenir compte de l'état En ligne/Hors ligne et de l'état succès/échec de l'outil. Cependant, si l'outil est en échec, il est possible que le graphique ne soit pas mis à jour.


Outil de comptage de blobs - Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).
Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils de comptage - Blobs de couleur

L'outil de comptage de blobs de couleur compte le nombre de blobs présents dans une région de l'image.

L'outil de comptage de blobs de couleur est l'un des outils les plus rapides. Il permet notamment de localiser les caractéristiques de blob plus rapidement qu'un outil de présence/absence de modèle. Utile dans de nombreuses applications de comptage, il permet, par exemple, de s'assurer que le nombre de broches d'un connecteur est correct ou de compter le nombre de pépites de chocolat dans un biscuit.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de comptage de blobs de couleur

Une fois l'outil sélectionné, choisissez le type de région et configurez cette dernière dans l'image dans laquelle vous pensez détecter la ou les caractéristiques de blob :

  1. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région dans l'image dans laquelle vous pensez voir apparaître le ou les blob(s), en vous assurant qu'elle englobe complètement le ou les blob(s) et leurs emplacements possibles, et configurez-la. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement du ou des blob(s) reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

    Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Une fois la région de recherche configurée, configurez la bibliothèque de couleurs de l'outil et activez le ou les modèles de couleurs appropriés :

    • Si un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire) est ajouté pour la première fois, commencez par configurer une ou plusieurs bibliothèques de couleurs et leur(s) modèle(s) de couleurs.

    • Si un autre outil a déjà été ajouté et que vous souhaitez utiliser une bibliothèque de couleurs existante et ses modèles de couleurs appris, sélectionnez la bibliothèque de couleurs de votre choix dans l'onglet Paramètres, puis activez les modèles de couleurs voulus en les cochant sous l'onglet Bibliothèque.

    • Par défaut, l'outil déclenche automatiquement un échec tant qu'aucune bibliothèque de couleurs n'a été définie. Si une bibliothèque de couleurs a été définie, l'outil utilise automatiquement cette bibliothèque et active tous les modèles de couleurs qu'elle contient.

  4. Une fois le ou les modèles de couleurs et la ou les bibliothèques de couleurs configurés, l'outil traite l'image et tous les pixels de la région de recherche qui correspondent au ou aux modèles de couleurs sélectionnés deviennent blancs (255), alors que ceux qui ne correspondent pas au ou aux modèles de couleurs sélectionnés deviennent noirs (0).
  5. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et réglez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de comptage de blobs de couleur

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de comptage de blobs de couleur comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
  • Onglet Bibliothèque de couleurs
  • Onglet Région composite
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Limites de plages

Onglet Bibliothèque de couleurs

Onglet Région composite


Outil de comptage de blobs de couleur - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Blob_1 » s'il s'agit du premier outil de blob ajouté au projet. Sinon, il est incrémenté (par exemple, « Blob_2 », « Blob_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de comptage de blobs de couleur - Onglet Paramètres

Fermé Apprendre la couleur

Affiche la boîte de dialogue Apprentissage ExtractColor , utilisée pour définir le ou les modèles de couleurs de la bibliothèque de couleurs sélectionnée.

Fermé Bibliothèque de couleurs

Définit la bibliothèque de couleurs utilisée comme référence par l'outil. Sur la liste déroulante, sélectionnez la bibliothèque de couleurs à modifier puis cliquez sur le bouton Apprendre la couleur pour afficher la boîte de dialogue Apprentissage ExtractColor. Chaque bibliothèque de couleurs peut compter jusqu'à 100 modèles de couleurs distincts, composés de couleurs individuelles.

Les projets EasyBuilder peuvent contenir 5 bibliothèques de couleurs maximum, qui peuvent être partagées par les outils suivants :

  • Outil de recherche de blob de couleur
  • Outil de recherche de blobs de couleur (1-10)
  • Outil de présence/absence basé sur le comptage de pixels
  • Outil de mesure de surface de blob de couleur
  • Outil de mesure de surfaces des blobs de couleur (1-10)
  • Outil de comptage de blobs de couleur
  • Outil d'identification du modèle de couleurs
  • Outil de filtre d'image couleur -> binaire
Fermé Limite

Définit l'une des deux méthodes de gestion des blobs situés à la limite de la région du blob (option désactivée par défaut) :

  • Désactivée : n'inclut pas les blobs situés à la limite de la région. Le blob doit être entièrement compris dans la région à détecter.
  • Activée : inclut les blobs touchant le bord de la région. Ces derniers sont détectés s'ils remplissent aussi les autres critères.
Fermé Surface minimale

Définit une limite de surface minimale sous la forme d'un nombre de pixels (0 à 16 777 216 ; valeur par défaut = 100) pour tous les blobs détectés. Seuls les blobs dont la surface est supérieure à la surface minimale seront reconnus.

Fermé Surface maximale

Définit une limite de surface maximale sous la forme d'un nombre de pixels (0 à 16 777 216 ; valeur par défaut = 100 000) pour tous les blobs détectés. Seuls les blobs dont la surface est inférieure à la surface maximale seront reconnus.

Fermé Facteur de lissage

Définit le facteur (0 à 25 ; valeur par défaut = 1) à utiliser pour le lissage de l'image. Pour spécifier l'absence de tout lissage, définissez la valeur sur 0.

Fermé Afficher l'image d'origine
  • Désactivé (par défaut) : La région sélectionnée affiche une image de sortie binaire en niveaux de gris.
  • Activée : La région sélectionnée affiche une image d'entrée d'origine.


Outil de comptage de blobs de couleur - Onglet Limites de plages

Fermé Maximum

Définit le plus grand nombre acceptable de blobs à détecter. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Nombre de blobs

Indique le nombre actuel de blobs détectés (les blobs comptabilisés dans l'image sont basés sur un ordre numérique où 0 = 1). Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Fermé Minimum

Définit le plus petit nombre acceptable de blobs à détecter. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outil de comptage de blobs de couleur - Onglet Bibliothèque de couleurs

Fermé Liste Modèles de couleurs

Affiche une liste en lecture seule de modèle(s) de couleurs contenus dans la bibliothèque de couleurs sélectionnée. Les modèles de couleurs sont activés et désactivés en cochant ou décochant la case en regard de Modèles de couleurs.

Fermé Tableau de couleurs

Affiche un tableau ordonné en lecture seule de la ou des couleurs dans le modèle de couleurs sélectionné.

Fermé Nom de la couleur

Affiche le nom de la ou des couleurs du modèle de couleurs sélectionné.

Fermé RVB

Affiche les valeurs RVB de la ou des couleurs du modèle de couleurs sélectionné.

Fermé Opération

Affiche l'opération (Ajouter ou Soustraire) de la ou des couleurs du modèle de couleurs sélectionné.


Outil de comptage de blobs de couleur - Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils de comptage - Transitions

L'outil de comptage de transitions compte le nombre de caractéristiques des bords présentes dans une région de l'image.

Cet outil est utile, par exemple, pour le comptage du nombre de filets sur une vis ou le comptage du nombre de biscuits sur un plateau.

Configuration de l’outil

Réglage des paramètres de l’outil


Utilisation de l'outil de comptage de transitions

Après avoir ajouté l'outil, vous devrez configurer la région de l'image qui servira à définir l'endroit où détecter la ou les transitions :

  1. Positionnez la région sur la zone des caractéristiques de transition, en vous assurant qu'elle englobe complètement les transitions et leurs emplacements possibles, puis configurez-la. Faites particulièrement attention aux flèches indiquant le sens de balayage sur la région pour vous assurer que la région est positionnée de façon à optimiser la détection des transitions souhaitées.

    Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement des transitions reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de comptage de transitions

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de comptage de transitions comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
  • Graphique
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Limites de plages

Graphique


Outil de comptage de transitions - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Transitions_1 » s'il s'agit du premier outil de ajouté au projet qui définit une transition. Sinon, il est incrémenté (par exemple, « Transitions_2 », « Transitions_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de comptage de transitions - Onglet Paramètres

Fermé Contraste de bord

Définit le score minimum de contraste de bord acceptable pour le bord détecté (1-100 ; par défaut = un « Paramètre intelligent » qui est généralement décrémenté jusqu’à détection du bord). Ce paramètre détermine la sensibilité de détection des bords de l’outil (sa capacité à faire la distinction entre la caractéristique et l’arrière-plan) ; utilisez ce paramètre avec l’option Graphique pour définir une plage acceptable.

Remarque : Si ce paramètre est configuré sur 0, l'outil peut trouver des bords inattendus.
Fermé Normalisation du score

Définit si les scores des bords seront normalisés par rapport à l’histogramme des niveaux de gris de la région.Ce paramètre permet de rechercher les bords dans des régions de faible contraste. Désactiver ce paramètre si vous êtes certains que les bords à détecter présentent un contraste élevé.

  • Coché (par défaut) : Normalise le score.
  • Non coché : Ne normalise pas le score.
Fermé Transition de bord

Définit le type de transition (Sombre vers clair, Clair vers sombre ou Les deux ; valeur par défaut = Les deux). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Largeur de transition

Définit la distance de pixels (1 à 50 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Gamme d’écart angulaire

Définit la valeur maximale de la transposition angulaire que peut subir la transition trouvée (0-10° ; par défaut = 10°). Plus la variance autorisée de l’angle est importante, plus l’outil mettra de temps à procéder à l’exécution.


Outil de comptage de transitions - Onglet Limites de plages

Fermé Maximum

Définit le nombre maximal acceptable de transitions à détecter. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Transitions

Renvoie le nombre actuel de transitions détectées (les transitions comptabilisées dans l'image sont basées sur un ordre numérique où 0 = 1). Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Fermé Minimum

Définit le nombre minimal acceptable de transitions à détecter. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outil de comptage de transitions - Graphique

Le Graphique est une représentation de la première dérivée des valeurs de niveau de gris contenues dans la région, les crêtes et vallées représentent le niveau des transitions majeures des bords.

Pour les outils détectant les bords (outils Bord et Cercle), l'axe du Score est une mesure pour la correspondance du bord trouvé avec les paramètres définis :

  • Un score positif indique que le bord fait la transition du sombre vers le clair ;
  • Un score négatif indique que le bord fait la transition du clair vers le sombre ;
  • Un score de 0 indique qu'aucun bord n'a été détecté.

L'axe Offset fait référence à la région définissant la fonction du bord, avec 0 représentant la limite de départ de la région, et l'autre valeur représentant la largeur maximum (en pixels) de la région. Le sommet des crêtes et des vallées le long de l'axe Offset indique la position du bord trouvé.

Remarque : Le graphique s'affiche sans tenir compte de l'état En ligne/Hors ligne et de l'état succès/échec de l'outil. Cependant, si l'outil est en échec, il est possible que le graphique ne soit pas mis à jour.


Outils de comptage - Paires de transitions

L'outil de comptage de paires de transitions compte le nombre de paires de transitions linéaires présentes dans une région de l'image.

L'outil de comptage de paires de transitions est différent de l'outil de comptage de transitions. L'outil de comptage de paires de transitions permet en effet de définir une largeur attendue entre les paires de transitions. Cela s'avère utile, par exemple, dans les applications utilisées pour compter le nombre de dents d'un engrenage ou le nombre de broches d'une puce informatique.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de comptage de paires de transitions

Après avoir ajouté l'outil, vous devrez configurer la région de l'image qui servira à définir l'endroit où détecter la ou les transitions :

  1. Positionnez la région sur la zone des caractéristiques de transition, en vous assurant qu'elle englobe complètement les transitions et leurs emplacements possibles, puis configurez-la.

    Le sens de balayage de la région, les paramètres de l'onglet Paramètres et les limites de plages configurées jouent un rôle important pour définir le nombre de paires de transitions détectées :

    2. Fermé Exemple 1

    Fermé Exemple 2

    Fermé Exemple 3

    Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement des transitions reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de comptage de paires de transitions

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de comptage de paires de transitions comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
  • Graphique
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Limites de plages

Graphique


Outil de comptage de paires de transitions - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « PairesTransitions_1 » s'il s'agit du premier outil de comptage de paires de transitions ajouté au projet. Sinon, il est incrémenté (par exemple, « PairesTransitions_2 », « PairesTransitions_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de comptage des paires de bords - Onglet Paramètres

Fermé Contraste de bord

Définit le score minimum de contraste de bord acceptable pour le bord détecté (1-100 ; par défaut = un Paramètre intelligent qui est généralement décrémenté jusqu’à détection du bord). Ce paramètre détermine la sensibilité de détection des bords de l’outil (sa capacité à faire la distinction entre la caractéristique et l’arrière-plan).

Remarque : Si ce paramètre est configuré sur 0, l'outil peut trouver des bords inattendus.
Fermé Normalisation du score

Définit si les scores des bords seront normalisés par rapport à l’histogramme des niveaux de gris de la région.Ce paramètre permet de rechercher les bords dans des régions de faible contraste. Désactiver ce paramètre si vous êtes certains que les bords à détecter présentent un contraste élevé.

  • Coché (par défaut) : Normalise le score.
  • Non coché : Ne normalise pas le score.
Fermé Première transition

Définit la transition sur le premier bord (Sombre au clair, Clair au sombre ou Les deux ; par défaut = Les deux). Pour augmenter la précision et la vitesse de traitement, indiquez le type de transition.

Fermé Deuxième Transition

Définit la transition sur le second bord (Sombre au clair, Clair au sombre ou Les deux ; par défaut = Les deux). Pour augmenter la précision et la vitesse de traitement, indiquez le type de transition.

Fermé Largeur de transition

Définit la distance de pixels (1 à 50 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Gamme d’écart angulaire

Définit la valeur maximale de la transposition angulaire que peut subir la transition trouvée (0-10° ; par défaut = 10°). Plus la variance autorisée de l’angle est importante, plus l’outil mettra de temps à procéder à l’exécution.

Fermé Distance minimale

Définit une distance minimale, en nombre de pixels (0 à 900 000 ; par défaut = 10), entre les transitions de toutes les paires de bords détectées ; seules des paires de bords dont la distance est supérieure à la distance minimale sont reconnues.

Fermé Distance maximale

Définit une distance maximale, en nombre de pixels (0 à 900 000 ; par défaut = 50), entre les transitions de toutes les paires de bords détectées ; seules les paires de bords dont la distance est inférieure à la distance maximale sont reconnues.


Outil de comptage de paires de transitions - Onglet Limites de plages

Fermé Maximum

Définit le nombre maximal acceptable de paires de transitions à détecter. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Paires de transitions

Renvoie le nombre actuel de paires de transitions détectées (les paires de transitions comptabilisées dans l'image sont basées sur un ordre numérique où 0 = 1). Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Fermé Minimum

Définit le nombre minimal acceptable de paires de transitions à détecter. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outils de comptage - Modèles PatMax RedLine et modèles PatMax

Remarque :
  • À partir du micrologiciel In-Sight firmware 5.5.0 et versions ultérieures, l'algorithme de l'outil a été modifié afin de renvoyer des résultats plus précis et de réduire la durée d'exécution dans certains cas.
  • En raison de cette modification, un message d'erreur s'affiche lors d'une tentative de chargement d'un projet contenant cet outil configuré selon le micrologiciel In-Sight version 5.5.0 ou ultérieure sur un système de vision In-Sight exécutant le micrologiciel In-Sight version 5.4.x ou antérieure.
  • L'outil de comptage de modèles PatMax RedLine est uniquement disponible sur des systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.2.0 et ultérieures.

L'outil de modèles PatMax RedLine et l'outil de comptage de modèles PatMax sont utilisés pour comptabiliser les instances d'un modèle, utilisant l'algorithme PatMax RedLine ou PatMax en fonction d'une représentation apprise de ce modèle (appelée Modèle).

Ces outils sont utiles, par exemple dans des applications telles que le comptage du nombre de verrous d'un montage mécanique ou le comptage du nombre de flacons sur un plateau.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration des outils de comptage de modèles PatMax RedLine et de modèles PatMax

Après avoir ajouté l'outil, sélectionnez le type des régions et configurer ces dernières pour définir votre modèle (la région Modèle) et l'emplacement du modèle dans l'image (la région Recherche).

  1. Dans le menu déroulant Modèle, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Placez ensuite la région de Modèle sur le modèle utilisé comme modèle d'apprentissage ; assurez-vous que la région de Modèle ne couvre que les caractéristiques importantes du modèle.Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  2. Dans le menu déroulant Recherche, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Puis positionnez la région Recherche de manière à ce qu'elle recouvre les zones de l'image dans lesquelles la forme peut apparaître. Pour optimiser l'exécution de l'outil, créez des régions Recherche de petite taille. Plus la région Recherche est étendue, plus l'outil mettra de temps à effectuer l'inspection.
  3. Cliquez sur le bouton OK pour confirmer les régions (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  4. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  5. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Sélection d’un modèle

Modèles PatMax RedLine, modèle PatMax et modèle


Modèles PatMax RedLine, modèles PatMax et modèles

Remarque : L'outil de comptage de modèles PatMax RedLine est uniquement disponible sur des systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.2.0 et ultérieures.

Les modèles PatMax RedLine, les modèles PatMax et les modèles localisent des modèles de forme appris et proposent la plus grande précision parmi les outils de recherche et d'inspection. Cependant les modèles de PatMax RedLine et les modèles de PatMax sont plus performants que les modèles, modifiant considérablement les conditions d'éclairage et la position du modèle. Ils permettent également de mieux reconnaître les modifications apportées à l'échelle et à la rotation du modèle, l'occlusion des éléments du modèle et les modifications apportées à l'apparence du modèle, en raison des variations d'éclairage.

La vitesse constitue la principale différence entre les modèles PatMax RedLine et les modèles PatMax ; le modèle PatMax RedLine utilise le modèle le plus récent correspondant à l'algorithme et permet de localiser des caractéristiques apprises dans une image mégapixel 5, 7 fois plus rapidement que les modèles PatMax. Les modèles PatMax RedLine conviennent donc pour des systèmes de vision de haute résolution.

Les modèles (dans la plupart des cas) sont plus rapides que PatMax, mais certains cas nécessitent la précision et la fiabilité de la version PatMax RedLine ou PatMax :

  • Lorsque les variations d'éclairage et de reflets sont difficiles à contrôler. Par exemple, des pièces en métal peuvent réfléchir la lumière dans des directions aléatoires.
  • Lorsque le modèle inspecté présente une forme ou une ombre similaire par rapport à un élément en arrière-plan, ou le modèle est superposé ou partiellement caché par d'autres objets dans l'image.
  • Lorsque vous souhaitez reconnaître avec précision un type de modèle parmi d'autres modèles, des modèles identiques.
  • Lorsque les conditions de votre environnement de déploiement sont trop exigeantes pour l'outil Modèle, en termes de cohérence et de fiabilité.


Réglages des paramètres des outils de comptage de modèles PatMax RedLine et de modèles PatMax

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres des outils de comptage de modèles PatMax RedLine et de modèles PatMax comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
  • Onglets Modèle et Recherche
  • Onglet Image d'apprentissage
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Limites de plages

Onglets Modèle et Recherche

Onglet Image d’apprentissage


Outil de comptage de modèles PatMax RedLine et de modèles PatMax - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties, et Communication). Le nom par défaut est « Modèle_1 » s'il s'agit du premier outil de modèle ajouté au projet. Sinon, il est incrémenté (par exemple, « Modèle_2 », « Modèle_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outils de comptage de modèles PatMax RedLine et de modèles PatMax - Onglet Paramètres

Fermé Seuil d'acceptation

Définit le degré de similitude qui doit exister entre le modèle de forme et le modèle localisé (0 à 100 ; valeur par défaut = 50). Les modèles localisés affichant une valeur supérieure ou égale au seuil défini sont considérés comme correspondants. Cet outil s'exécute plus rapidement lorsque ce paramètre est élevé, ce qui requiert également un degré de similitude plus important entre le modèle de forme et le modèle localisé. Moins les paramètres sont élevés, moins les résultats seront précis. Des modèles semblables seront détectés, mais pas par rapport au modèle de forme.

Fermé Seuil de contraste

Définit le contraste minimum acceptable qui doit être défini dans le modèle identifié ; le contraste pour un modèle identifié doit être supérieur à la valeur Seuil de contraste à considérer comme une instance valide. La valeur par défaut pour le(s) modèle(s) PatMax RedLine est 0 et la plage valide de paramètres est 0-100. La valeur par défaut pour le(s) modèle(s) PatMax est 10 et la plage valide de paramètres est 0-255. Une faible valeur Seuil de contraste est utilisée pour des images peu contrastées, alors qu'une valeur élevée Seuil de contraste est utilisée pour des images extrêmement contrastées.

Remarque : Le contraste de modèle(s) PatMax RedLine désigne la mesure « relative » d'une modification de contraste entre les caractéristiques du modèle appris et les caractéristiques de correspondance de l'image de recherche, en pourcentage. Ainsi si le contraste de caractéristique est supérieur ou égal au contraste de modèle, le contraste rapporté sera ~100. Si le contraste de caractéristique est inférieur au contraste de modèle, le contraste rapporté sera <100. Le contraste de modèle(s) PatMax RedLine est différent du contraste de modèle(s) PatMax qui représente le contraste d'image « absolu » de la région d'intérêt de recherche, en niveau de gris
Fermé Tolérance angulaire

Définit dans quelle mesure le modèle localisé peut pivoter par rapport à la position du modèle de forme, tout en étant identifié comme un modèle valide (± 0 à 180° ; valeur par défaut = 15°). Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps.

Fermé Tolérance en échelle

Définit le pourcentage autorisé de mise à l'échelle (variations de taille) entre le modèle identifié et le modèle de forme (0-50 ; par défaut = 0). La valeur représente un pourcentage plus ou moins, par exemple une valeur 5 déclenchera l'outil de recherche de modèles dont la taille est comprise entre 95 % et 105% du modèle de forme. Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps.

Fermé Mode de recherche

Définit le mode de recherche utilisé pour les modèles d'apprentissage et de reconnaissance, PatMax ou PatQuick. L'option PatMax est sélectionnée par défaut. PatMax propose une plus grande précision que PatQuick mais nécessite un temps d'exécution plus long alors que PatQuick propose une plus faible précision que PatMax mais nécessite un temps d'exécution moins long.

Fermé Scores stricts

Définit si des caractéristiques manquantes ou cachées du modèle trouvé affecteront le score (par défaut = Off, décoché). Lorsque Score strict est appliqué (Activé, coché), si les caractéristiques du modèle sont absentes ou bloquées, le score du modèle trouvé sera plus faible.

Fermé Ignorer la polarité

Définit si des modèles localisés peuvent ou non contenir des caractéristiques de correspondance avec inversion des couleurs par rapport au modèle de forme (option désactivée par défaut). Lorsque le paramètre Ignorer la polarité est appliqué (option cochée), les modèles détectés avec des caractéristiques d'inversion des couleurs, comme noir/blanc et blanc/noir dans le modèle de forme, par exemple, sont considérés comme correspondants au modèle de forme.

Fermé Délai d'attente
Définit la durée, en millisecondes (0 à 30 000), pendant laquelle l'outil recherche le(s) modèle(s) avant que l'exécution ne soit interrompue et que l'outil ne renvoie un échec. Par défaut, ce paramètre est réglé sur 5 000.
Remarque : Le(s) modèle(s) PatMax RedLine ne contient/contiennent pas le paramètre Mode de recherche.


Outils de comptage de modèles PatMax RedLine et de modèles PatMax - Onglet Limites de plages

Fermé Maximum

Définit le nombre maximal acceptable de modèles à détecter ; l'outil crée une option par défaut « Limite automatique » en fonction de votre image, que vous pouvez personnaliser selon les besoins de votre application.

Fermé Modèles

Renvoie le nombre actuel de modèles détectés (les modèles comptabilisés dans l'image sont basés sur un ordre numérique où 0 = 1) ; les valeurs exactes ou situées entre les paramètres Minimum et Maximum sont acceptées.

Fermé Minimum

Définit le nombre minimum acceptable de modèles à détecter ; l'outil crée une option par défaut « Limite automatique » en fonction de votre image, que vous pouvez personnaliser selon les besoins de votre application.

Fermé Inverser

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outils de comptage de modèles PatMax RedLine et de modèles PatMax - Onglets Modèle et Recherche

Les onglets Modèle et Recherche sont utilisés pour configurer la région composite pour les régions Modèle et Recherche de l'outil. Les régions composite sont un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Dans l'onglet Modèle, les régions composite sont activées uniquement après avoir cliqué sur le bouton Région modèle.
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).
Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils de comptage de modèles PatMax RedLine et de modèles PatMax - Onglet Image d'apprentissage

L'image affichée sous l'onglet Image d'apprentissage est une miniature du modèle de forme. Cliquez sur le bouton Région du modèle pour redimensionner ou déplacer la région, puis sur le bouton Apprendre pour apprendre à nouveau le modèle de forme.


Outils de comptage - Modèles

L'outil de comptage de modèles sert à compter les instances d'une caractéristique de modèle, d'après une représentation apprise de ce modèle (nommée un Modèle).

L'outil de comptage de modèles est utile, par exemple, dans des applications telles que le comptage du nombre de boulons d'un assemblage mécanique ou le comptage du nombre de flacons sur un plateau.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de comptage de modèles

Après avoir ajouté l'outil, configurez les régions de l'image définissant votre modèle (la région Modèle) et l'emplacement du modèle dans l'image (la région Recherche).

  1. Positionnez la région Modèle sur le modèle qui sera utilisé comme forme d'apprentissage. Assurez-vous que la région Modèle recouvre uniquement les caractéristiques importantes du modèle.

  2. Positionnez la région Recherche de manière à ce qu'elle recouvre les zones de l'image dans lesquelles la forme peut apparaître. Pour optimiser l'exécution de l'outil, créez des régions Recherche de petite taille. Plus la région Recherche est étendue, plus l'outil mettra de temps à effectuer l'inspection.

    les régions Modèle et Recherche ne peuvent pas être courbées en arc de cercle ou dans une forme circulaire.

  3. Cliquez sur le bouton OK pour confirmer les régions (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Sélection d’un modèle


Réglage des paramètres de l'outil de comptage de modèles

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de comptage de modèles comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Limites de plages
  • Onglet Image d'apprentissage
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Limites de plages

Onglet Image d’apprentissage


Outil de comptage de modèles - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Modèle_1 » s'il s'agit du premier outil de modèle ajouté au projet. Sinon, il est incrémenté (par exemple, « Modèle_2 », « Modèle_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de comptage de modèles - Onglet Paramètres

Fermé Apprendre entrée

Définit s'il faut ou pas apprendre un modèle de forme sur une ligne d'entrée (le paramètre par défaut est « Off », désactivé).

  • Entrée : Apprend un modèle de forme sur une ligne d'entrée. La ligne d'entrée sélectionnée sera utilisée comme signal d'apprentissage.

    Remarque :
    • Cette option ne sera pas affichée quand le système de vision In-Sight n'a pas d'entrées discrètes (p. ex., système de vision In-Sight série 8000 avec E/S directes).
    • Le type de signal de la ligne d'entrée sélectionnée doit être défini sur Déclencheur d'événement à l'étape d'application Entrées/Sorties.
    • L'apprentissage d'un modèle de forme utilise l'image la plus récente acquise par le système/capteur de vision. Il n'est pas nécessaire de redéclencher le système/capteur de vision pour effectuer l'apprentissage.
    • Pour en savoir plus, reportez-vous à la rubrique Entrées : apprentissage d'un modèle de forme sur une ligne d'entrée
Fermé Seuil d'acceptation

Définit le degré de similitude qui doit exister entre le modèle de forme et le modèle localisé (0 à 100 ; valeur par défaut = 50). Les modèles localisés affichant une valeur supérieure ou égale au seuil défini sont considérés comme correspondants. Cet outil s'exécute plus rapidement lorsque ce paramètre est élevé, ce qui requiert également un degré de similitude plus important entre le modèle de forme et le modèle localisé. Moins les paramètres sont élevés, moins les résultats seront précis. Des modèles semblables seront détectés, mais pas par rapport au modèle de forme.

Fermé Tolérance angulaire

Définit dans quelle mesure le modèle localisé peut pivoter par rapport à la position du modèle de forme, tout en étant identifié comme un modèle valide (± 0 à 180° ; valeur par défaut = 15°). Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps.

Fermé Tolérance en échelle

Définit la tolérance de l'outil aux variations d'échelle du modèle, avec une marge de ± 10 % par rapport à la taille du modèle appris. Ce paramètre est désactivé par défaut (option pas cochée), ce qui désactive les ajustements d'échelle. Dans ce mode de fonctionnement, l'outil trouve toujours les modèles compris dans la plage de ± 10 %, mais le score de la caractéristique diminue à mesure que le pourcentage de mise à l'échelle augmente.

Fermé Type de modèle

Définit comment l'outil construit le modèle de forme : Modèle de surface ou Modèle de transition (valeur par défaut). Modèle de surface crée un modèle de forme basé sur un échantillonnage uniforme de valeurs de niveaux de gris de la région modèle. Modèle de transition crée un modèle de forme basé sur les transitions détectées (transitions claires/sombres) de la caractéristique de modèle dans la région modèle.

Fermé Précision

Définit comment l'outil qualifie le compromis entre précision/fiabilité et vitesse d'exécution : Précis, Moyen (valeur par défaut) et Rapide. Précis indique que l'accent est mis sur une précision/fiabilité plus élevée et une vitesse d'exécution plus lente , Rapide indique que l'accent est mis sur une vitesse d'exécution plus élevée plutôt que sur la précision/fiabilité ; et Moyen indique un réglage intermédiaire entre les deux.

Fermé Délai d'attente

Définit la durée, en millisecondes (0 à 30 000), pendant laquelle l'outil recherche le ou les modèles avant que l'exécution ne soit interrompue et que l'outil ne renvoie un échec.


Outil de comptage de modèles - Onglet Limites de plages

Fermé Maximum

Définit le nombre maximal acceptable de modèles à détecter. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Modèles

Renvoie le nombre actuel de modèles détectés (les modèles comptabilisés dans l'image sont basés sur un ordre numérique où 0 = 1). Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Fermé Minimum

Définit le nombre minimal acceptable de modèles à détecter. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outil de comptage de modèles - Onglet Image d'apprentissage

L'image affichée sur l'onglet Image d'apprentissage est une miniature du modèle de forme. Cliquez sur le bouton Région du modèle pour redimensionner ou déplacer la région Modèle, puis sur le bouton Apprendre pour apprendre à nouveau le modèle de forme.


/ Outils d'identification - Lire le code 1D et Lire les codes 1D (1-20)

Les outils d'identification Lire le code 1D et Lire les codes 1D (1-20) décodent ou vérifient les codes barres 1D et en pile avec l'algorithme ReadIDMax®. Les outils indiquent les informations décodées et la réussite si le ou les codes ont été décodés correctement et si le code se trouvait dans les limites de seuil spécifiées.

L'outil d'identification Lire le code 1D est utilisé pour lire et/ou vérifier un code unique dans la région, tandis que l'outil d'identification Lire les codes 1D (1-20) permet de lire et/ou vérifier jusqu'à 20 codes dans la région.

Configuration des outils

Réglage des paramètres des outils


/ Configuration des outils d'identification Lire le code 1D et Lire les codes 1D (1-20)

Une fois que l'outil a été ajouté, vous devez configurer la région dans l'image :

  1. Pour l'outil d'identification Lire le code 1D, positionnez la région sur le code/symbole, en vous assurant qu'elle l'englobe complètement. Pour l'outil d'identification Lire les codes 1D (1-20), positionnez la région sur la zone dans laquelle le code/symbole peut apparaître, en vous assurant qu'elle englobe complètement le code/symbole à décoder. Pour accélérer l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Une fois que la région a été confirmée, vous devez définir les paramètres dans Onglet Paramètres :
    1. Paramètre Mode, qui définit le mode de fonctionnement de l'outil : Lecture ou Chaîne de correspondance (le Mode est défini sur Lecture par défaut).
    2. Pour l'outil d'identification Lire les codes 1D (1-20), vous devez également définir le paramètre Résultats maximum, qui définit le nombre de codes/symboles à décoder (valeur par défaut = 1).
  4. L'outil trace un cadre non modifiable autour du code/symbole décodé et insère une icône [image] pour indiquer le repère créé à partir du code/symbole décodé.
  5. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  6. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


/ Ajustement des paramètres des outils d'identification Lire le code 1D et Lire les codes 1D (1-20)

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet Paramètres des outils d'identification Lire le code 1D et Lire les codes 1D (1-20) comporte les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet 1D
  • Onglet Empilé
  • Onglet Résultats
  • Onglet Tableau
Remarque :
  • L'onglet Résultats n'est activé que pour l'outil d'identification Lire le code 1D.
  • L'onglet Tableau n'est activé que pour l'outil d'identification Lire les codes 1D (1-20).
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglets Général

Onglets Paramètres

Onglet 1D

Onglets Empilé

Onglet Résultats

Tableau


/ Outils d'identification Lire le code 1D et Lire les codes 1D (1-20) - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats Entrées/Sorties et Communication. Le nom par défaut est « IDCode_1 » s'il s'agit du premier outil d'identification Lire le code 1D, Lire les codes 1D (1-20), Lire le code 2D, Lire les codes 2D (1-20) ou Lire le code postal ajouté au projet. Sinon, il est incrémenté (par exemple, « IDCode_2 », « IDCode_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


/ Outil d'identification Lire le code 1D et Lire les codes 1D (1-20) - Onglets Paramètres

Fermé Résultats maximums

Définit le nombre maximum de codes/symboles à lire (1 à 20 ; valeur par défaut = 1).

Remarque : si la valeur Résultats maximum spécifiée dépasse le nombre de codes/symboles dans le champ de vue, l'outil continue à rechercher le nombre de codes/symboles spécifié. Si le nombre de codes/symboles dans le champ de vue varie, le temps d'exécution de l'outil peut être réduit en ajustant la valeur dans le paramètre Délai d'attente.
Fermé appris

Indique si l'outil a été appris ou non sur un code/symbole spécifique ; affiche 1 lorsque l'outil a été appris et 0 lorsqu'il n'a pas été appris.

Fermé Apprendre

Apprend un modèle de code/symbole lu ; les informations apprises sont conservées tant que vous n'avez pas cliqué sur le bouton Supprimer l'apprentissage. Pour apprendre de nouveau un code/symbole, cliquez sur le bouton Supprimer l'apprentissage, puis sur le bouton Apprendre avec le nouveau code/symbole présenté. L'apprentissage permet d'améliorer la vitesse et les performances de l'outil en indiquant à l'outil quel type de code/symbole décoder. Lorsque vous utilisez et apprenez l'outil d'identification Lire les codes 1D (1-20) ou Lire les codes 2D (1-20), configurez la région autour d'un code/symbole unique avant de cliquer sur le bouton Apprendre. Une fois le code/symbole appris, vous pouvez ajuster la région afin de rechercher plusieurs codes/symboles dans un champ de vue plus étendu. L'apprentissage ne fonctionne qu'avec un code/symbole unique dans la région. Si vous cliquez sur le bouton Apprendre avec plusieurs codes/symboles dans la région, il n'est pas possible d'indiquer le code/symbole à apprendre. Avant l'apprentissage, vérifiez que les types de code corrects sont sélectionnés dans les onglets 1D et Empilé.

Fermé Désapprendre

Annule l'apprentissage d'un modèle de code/symbole appris. Pour apprendre de nouveau un symbole, cliquez sur le bouton Supprimer l'apprentissage, puis sur le bouton Apprendre avec le nouveau code présenté.

Fermé Mode

Définit le mode de fonctionnement de l'outil (Lecture ou Chaîne de correspondance ; valeur par défaut = Lecture).

  • Le mode Lecture est utilisé lorsque les informations figurant dans le code/symbole sont inconnues. L'outil décode automatiquement les informations contenues dans le code/symbole, puis affiche les informations décodées dans le paramètre Chaîne.
  • Le mode Chaîne de correspondance permet de vérifier qu'un code barres/symbole connu est présent et lisible. L'outil décode les informations contenues dans les codes barres/symboles, puis compare les informations décodées à celles saisies dans le champ Chaîne de correspondance.
Fermé Chaîne de correspondance

Définit la chaîne attendue à lire (cette option n'est activée que lorsque le paramètre Mode est défini sur Chaîne de correspondance). Saisissez les informations que vous souhaitez que l'outil décode.

Remarque : vous pouvez entrer la chaîne de correspondance à partir d'un autre périphérique. Lorsque vous exécutez le projet, l'outil d'identification peut lire la chaîne de texte à partir du périphérique sur lequel vous l'avez entrée et la comparer au code ID/symbole reconnu. L'outil génère le résultat Échec et le champ Chaîne de correspondance affiche TRIG jusqu'à ce que la chaîne de correspondance soit entrée à partir du périphérique externe.
Fermé Mode de correspondance

Définit si, pour aboutir, les codes/symboles décodés dans la région doivent correspondre, ou non, à la chaîne définie dans le paramètre Chaîne de correspondance. Le paramètre Chaîne de correspondance doit être configuré de manière à activer cette option.

  • Toutes les correspondances = tous les codes/symboles décodés doivent correspondre à la chaîne définie dans le paramètre Chaîne de correspondance.
  • N'importe quelle correspondance = au moins un des codes/symboles décodés doit correspondre à la chaîne définie dans le paramètre Chaîne de correspondance.
Fermé Total de contrôle

Définit si le code/symbole va être validé ou non pour garantir la fiabilité lors de l'utilisation d'un algorithme de détection des défauts (par défaut, ce paramètre est désactivé). Le checksum ne s'applique qu'aux codes/symboles incluant des algorithmes de checksum ; chaque code/symbole possède son propre algorithme de checksum spécifique. Le type de checksum, le cas échéant, utilisé dépend du type de code/symbole sélectionné.

Remarque : les codes 128 et 93, et les codes barres RSS, UPC et EAN sont validés par un checksum quel que soit le paramètre sélectionné. Si le checksum est activé pour un autre code barres, et qu'aucun checksum n'est encodé, la lecture échoue.
Fermé Mode de tri

Définit l'ordre, le cas échéant, dans lequel les résultats sont renvoyés (Aucun, De haut en bas, De gauche à droite, Alphabétique ou Longueur de la chaîne ; valeur par défaut = Aucun).

  • L'option Aucun permet de trier les résultats par ordre de décodage. Les résultats non décodés apparaissent après les résultats décodés.
  • L'ordre De haut en bas permet de trier dans l'ordre croissant des valeurs d'abscisse dans le repère.
  • L'ordre De gauche à droite permet de trier dans l'ordre croissant des valeurs d'ordonnée dans le repère.
  • L'ordre Alphabétique permet de trier les résultats par ordre alphabétique.
  • L'ordre Longueur de la chaîne permet de trier les résultats par longueur croissante de chaîne.
  • L'option Ligne = permet de trier les résultats en regroupant les symboles dans des lignes, puis de les trier de gauche à droite au sein de chaque ligne.
  • L'option Colonne = permet de trier les résultats en regroupant les symboles dans des colonnes, puis de les trier de haut en bas au sein de chaque colonne.
Fermé Autoriser les symboles identiques 1D

Définit si l'outil doit décoder tous les symboles dans la région, même s'ils sont identiques. Les deux symboles sont considérés comme étant identiques s'ils ont la même longueur, le même type de symbologie et la même chaîne décodée (par défaut, cette option est désactivée).

Fermé Vérifier

Indique si les tests de qualité d'impression seront effectués (par défaut, ce paramètre est désactivé).

Fermé Développer UPC-E

Définit si le symbole décodé renvoie la chaîne à 6 chiffres UPC-E ou la chaîne équivalente développée UPC-A à 11 chiffres (par défaut cette option est activée).

Remarque : Le paramètre Développer UPC-E est pris en charge uniquement sur les systèmes de vision In-Sight Micro série 1000, In-Sight série 5000 et In-Sight série 70xx - 74xx dotés de la version 4.10.1 ou ultérieure du micrologiciel In-Sight.
Fermé Délai d'attente

Définit le temps, en millisecondes (0 à 30 000 ; valeur par défaut = 0), pendant lequel l'outil recherche un code/symbole valide avant l'arrêt de l'exécution avec un échec.

Fermé Numéro décodé

Affiche le nombre de codes/symboles décodés.

Remarque : Les paramètres Résultats maximums, Mode de correspondance, Mode de tri, Autoriser les symboles identiques 1D et Numéro décodé ne sont disponibles que pour l'outil d'identification Lire les codes 1D (1-20) .


/ Outils d'identification Lire le code 1D et Lire les codes 1D (1-20) - Onglet 1D

Cet onglet définit les codes/symboles à décoder. Par défaut, tous les types de code/symbole sont activés. Plusieurs symbologies peuvent être sélectionnées et lues.

Fermé Code 128

Définit si l'outil tente de lire le code 128.

Fermé Code 39

Définit si l'outil tente de lire le code 39 (également connu sous code 3 de 9 et BC39).

Fermé Entrelacé 2 de 5

Définit si l'outil tente de lire ITF-14.

Fermé Pharmacode

Définit si l'outil tente de lire le pharmacode.

Fermé UPC/EAN

Définit si l'outil tente de lire l'UPC (code universel des produits) et l'EAN (numérotation européenne par article). L'UPC prend en charge la version A (version classique), la version E (version de suppression de zéros), les codes à barres UPC et les encodages supplémentaires à deux et cinq caractères. EAN prend en charge les codes à barres EAN-8 et EAN-13 ainsi que les encodages supplémentaires à deux et cinq caractères.

Fermé Code 93

Définit si l'outil tente de lire le code 93.

Fermé Codabar

Définit si l'outil tente de lire le codabar (également connu sous USD-4 et code 2 de 7).


/ Outils d'identification Lire le code 1D et Lire les codes 1D (1-20) - Onglet Empilé

Cet onglet définit les codes/symboles à décoder. Par défaut, tous les types de code/symbole sont activés. Plusieurs symbologies peuvent être sélectionnées et lues.

Fermé PDF 417

Définit si l'outil tente de lire les éléments PDF 417.

Fermé DataBar

Définit si l'outil tente de lire les éléments DataBar.

Fermé DataBar Limited

Définit si l'outil tente de lire les éléments DataBar Limited.

Fermé DataBar Expanded

Définit si l'outil tente de lire les éléments DataBar Expanded.

Fermé EAN.UCC Composite

Définit si l'outil tente de lire les éléments EAN.UCC Composite.


Outil d'identification Lire le code 1D - Onglet Résultats

L'onglet Résultats affiche les informations suivantes sur le code/symbole décodé :

Fermé Chaîne

Renvoie la chaîne contenue dans le code/symbole décodé.

Fermé Symbologie

Renvoie le type de symbole décodé.

Fermé Grade

Renvoie le grade donné au code/symbole décodé.


Outil d'identification Lire les codes 1D (1-20) - Tableau

Le tableau présente les informations suivantes pour chaque code/symbole décodé :

Fermé Index

Désigne l'ordre du code/symbole décodé en fonction du paramètre Mode de tri ; 1 à 20 (tri par ordre numérique dans EasyBuilder basé sur 0=1).

Fermé Chaîne

Renvoie la chaîne contenue dans le code/symbole décodé.

Fermé Symbologie

Renvoie le type de symbole décodé.

Fermé X

Renvoie l'abscisse de la sortie de repère de code/symbole décodé.

Fermé Y

Renvoie l'ordonnée de la sortie de repère de code/symbole décodé.

Fermé Angle

Renvoie la valeur d'angle de la sortie de repère de code/symbole décodé.

Fermé Grade

Renvoie le grade donné au code/symbole décodé.


/ Outils d'identification - Lire le code 2D et Lire les codes 2D (1-20)

Les outils d'identification Lire le code 2D et Lire les codes 2D (1-20) décodent et/ou vérifient les codes QR et/ou les symbologies de matrice de données avec l'algorithme ReadIDMax®. Les outils indiquent les informations décodées et la réussite si le ou les codes ont été décodés correctement et si le code se trouvait dans les limites de seuil spécifiées.

L'outil d'identification Lire le code 2D est utilisé pour lire et/ou vérifier un symbole unique dans la région, tandis que l'outil d'identification Lire les codes 2D (1-20) permet de lire et/ou vérifier jusqu'à 20 symboles dans la région.

Configuration des outils

Réglage des paramètres des outils


/ Configuration des outils d'identification Lire le code 2D et Lire les codes 2D (1-20)

Une fois que l'outil a été ajouté, vous devez configurer la région dans l'image :

  1. Pour l'outil d'identification Lire le code 2D, positionnez la région sur le code/symbole, en vous assurant qu'elle l'englobe complètement. Pour l'outil d'identification Lire les codes 2D (1-20), positionnez la région sur la zone dans laquelle le code/symbole peut apparaître, en vous assurant qu'elle englobe complètement le code/symbole à décoder. Pour accélérer l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter.

    Remarque : lors de la lecture de codes 2D, il est important de laisser une « zone silencieuse » entre le code et la région. La « zone silencieuse » implique une séparation d'au moins 3 pixels entre le bord du code et la région qui définit le code.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Une fois que la région a été confirmée, vous devez définir les paramètres dans Onglet Paramètres :
    1. Le paramètre Groupe de symbologies, qui définit le type de symbologie, Matrice de données ou Code QR (valeur par défaut = Matrice de données.
    2. Paramètre Mode, qui définit le mode de fonctionnement de l'outil : Lecture ou Chaîne de correspondance (le Mode est défini sur Lecture par défaut).
    3. Pour l'outil d'identification Lire les codes 2D (1-20), vous devez également définir le paramètre Résultats maximum, qui définit le nombre de codes/symboles à décoder (valeur par défaut = 1).
  4. L'outil trace un cadre non modifiable autour du code/symbole décodé et insère une icône [image] pour indiquer le repère créé à partir du code/symbole décodé.
  5. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  6. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


/ Ajustement des paramètres des outils d'identification Lire le code 2D et Lire les codes 2D (1-20)

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet Paramètres des outils d'identification Lire le code 2D et Lire les codes 2D (1-20) comporte les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Résultats
  • Onglet Tableau
Remarque :
  • L'onglet Résultats n'est activé que pour l'outil d'identification Lire le code 2D.
  • L'onglet Tableau n'est activé que pour l'outil d'identification Lire les codes 2D (1-20).
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglets Général

Onglets Paramètres

Onglet Résultats

Tableau


/ Outils d'identification Lire le code 2D et Lire les codes 2D (1-20) - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats Entrées/Sorties et Communication. Le nom par défaut est « IDCode_1 » s'il s'agit du premier outil d'identification Lire le code 1D, Lire les codes 1D (1-20), Lire le code 2D, Lire les codes 2D (1-20) ou Lire le code postal ajouté au projet. Sinon, il est incrémenté (par exemple, « IDCode_2 », « IDCode_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


/ Outils d'identification Lire le code 2D et Lire les code 2D (1-20) - Onglets Paramètres

Fermé Groupe de symbologie

Définit le type de symbologie (Matrice de données ou Code QR ; par défaut = Matrice de données) pour tenter de décoder.

Remarque : Lorsque le Code QR est sélectionné, l'outil tente de décoder tous les types de Codes QR (Modèle QR 1/2, Micro QR et Modèle QR 1/2).
Fermé Résultats maximums

Définit le nombre maximum de codes/symboles à lire (1 à 20 ; valeur par défaut = 1).

Remarque : si la valeur Résultats maximum spécifiée dépasse le nombre de codes/symboles dans le champ de vue, l'outil continue à rechercher le nombre de codes/symboles spécifié. Si le nombre de codes/symboles dans le champ de vue varie, le temps d'exécution de l'outil peut être réduit en ajustant la valeur dans le paramètre Délai d'attente.
Fermé appris

Indique si l'outil a été appris ou non sur un code/symbole spécifique ; affiche 1 lorsque l'outil a été appris et 0 lorsqu'il n'a pas été appris.

Fermé Apprendre

Apprend un modèle de code/symbole lu ; les informations apprises sont conservées tant que vous n'avez pas cliqué sur le bouton Supprimer l'apprentissage. Pour apprendre de nouveau un code/symbole, cliquez sur le bouton Supprimer l'apprentissage, puis sur le bouton Apprendre avec le nouveau code/symbole présenté. L'apprentissage permet d'améliorer la vitesse et les performances de l'outil en indiquant à l'outil quel type de code/symbole décoder. Lorsque vous utilisez et apprenez l'outil d'identification Lire les codes 1D (1-20) ou Lire les codes 2D (1-20), configurez la région autour d'un code/symbole unique avant de cliquer sur le bouton Apprendre. Une fois le code/symbole appris, vous pouvez ajuster la région afin de rechercher plusieurs codes/symboles dans un champ de vue plus étendu. L'apprentissage ne fonctionne qu'avec un code/symbole unique dans la région. Si vous cliquez sur le bouton Apprendre avec plusieurs codes/symboles dans la région, il n'est pas possible d'indiquer le code/symbole à apprendre. Avant d'apprendre, assurez-vous que le bon groupe de symbologie (Matrice de données ou QR) est sélectionné dans le paramètre Groupe de symbologie.

Fermé Désapprendre

Annule l'apprentissage d'un modèle de code/symbole appris. Pour apprendre de nouveau un symbole, cliquez sur le bouton Supprimer l'apprentissage, puis sur le bouton Apprendre avec le nouveau code présenté.

Fermé Perspective

Définit les paramètres de décodage (Sans perspective, Perspective ou Perspective d'apprentissage ; par défaut = Sans perspective) pour les symbologies de Matrices de données. le paramètre Groupe de symbologie doit être défini sur Matrice de données pour activer ce paramètre.

  • Sans perspective = décode les symboles de Matrices de données qui n'ont pas de distorsion de perspective.
  • Perspective = décode les symboles de Matrices de données avec une distorsion de perspective ; la distorsion de perspective est estimée de façon indépendante lors de l'apprentissage du modèle et la durée d'exécution.
  • Perspective d'apprentissage = décode les symboles de Matrices de données avec une distorsion de perspective connue. La perspective est apprise en même temps que d'autres attributs lors de l'utilisation d'un modèle de symbole appris. Lors de l'exécution, le symbole est examiné dans un espace où la distorsion de perspective dans l'image d'entrée est compensée à l'aide des attributs appris. Cette option requiert que le symbole d'exécution soit placé sur le même plan que celui du symbole en apprentissage. Cette option vous permet de décoder des symboles très endommagés et présentant une distorsion de perspective connue.
Astuce : Il est recommandé de fixer le système de vision In-Sight de façon à ce que l'angle d'incidence (l'angle située entre l'axe optique du capteur et le vecteur normal du plan sur lequel le symbole est présenté) ne dépasse pas 40 degrés et que la résolution du symbole soit d'au moins 5 pixels par cellule.
Fermé Mode

Définit le mode de fonctionnement de l'outil (Lecture ou Chaîne de correspondance ; valeur par défaut = Lecture).

  • Le mode Lecture est utilisé lorsque les informations figurant dans le code/symbole sont inconnues. L'outil décode automatiquement les informations contenues dans le code/symbole, puis affiche les informations décodées dans le paramètre Chaîne.
  • Le mode Chaîne de correspondance permet de vérifier qu'un code barres/symbole connu est présent et lisible. L'outil décode les informations contenues dans les codes barres/symboles, puis compare les informations décodées à celles saisies dans le champ Chaîne de correspondance.
Fermé Chaîne de correspondance

Définit la chaîne attendue à lire (cette option n'est activée que lorsque le paramètre Mode est défini sur Chaîne de correspondance). Saisissez les informations que vous souhaitez que l'outil décode.

Remarque : vous pouvez entrer la chaîne de correspondance à partir d'un autre périphérique. Lorsque vous exécutez le projet, l'outil d'identification peut lire la chaîne de texte à partir du périphérique sur lequel vous l'avez entrée et la comparer au code ID/symbole reconnu. L'outil génère le résultat Échec et le champ Chaîne de correspondance affiche TRIG jusqu'à ce que la chaîne de correspondance soit entrée à partir du périphérique externe.
Fermé Mode de correspondance

Définit si, pour aboutir, les codes/symboles décodés dans la région doivent correspondre, ou non, à la chaîne définie dans le paramètre Chaîne de correspondance. Le paramètre Chaîne de correspondance doit être configuré de manière à activer cette option.

  • Toutes les correspondances = tous les codes/symboles décodés doivent correspondre à la chaîne définie dans le paramètre Chaîne de correspondance.
  • N'importe quelle correspondance = au moins un des codes/symboles décodés doit correspondre à la chaîne définie dans le paramètre Chaîne de correspondance.
Fermé Mode de tri

Définit l'ordre, le cas échéant, dans lequel les résultats sont renvoyés (Aucun, De haut en bas, De gauche à droite, Alphabétique ou Longueur de la chaîne ; valeur par défaut = Aucun).

  • L'option Aucun permet de trier les résultats par ordre de décodage. Les résultats non décodés apparaissent après les résultats décodés.
  • L'ordre De haut en bas permet de trier dans l'ordre croissant des valeurs d'abscisse dans le repère.
  • L'ordre De gauche à droite permet de trier dans l'ordre croissant des valeurs d'ordonnée dans le repère.
  • L'ordre Alphabétique permet de trier les résultats par ordre alphabétique.
  • L'ordre Longueur de la chaîne permet de trier les résultats par longueur croissante de chaîne.
  • L'option Ligne = permet de trier les résultats en regroupant les symboles dans des lignes, puis de les trier de gauche à droite au sein de chaque ligne.
  • L'option Colonne = permet de trier les résultats en regroupant les symboles dans des colonnes, puis de les trier de haut en bas au sein de chaque colonne.
Fermé Vérifier

Indique si les tests de qualité d'impression seront effectués (par défaut, ce paramètre est désactivé).

Fermé Autoriser les résultats binaires

Définit si la fonction décode aussi bien les symboles de Matrice de données hex ASCII encodés que les données binaires de base-256 (par défaut, ce paramètre est désactivé).

Fermé Délai d'attente

Définit la durée, en millisecondes (0 à 30000 ; valeur par défaut = 5000), pendant laquelle l'outil recherche un code/symbole valide avant que l'exécution ne soit interrompue et que l'outil ne renvoie un échec.

Fermé Numéro décodé

Affiche le nombre de codes/symboles décodés.

Remarque : Les paramètres Résultats maximums, Mode de correspondance, Mode de tri, et Numéro décodé ne sont disponibles que pour l'outil d'identification Lire les codes 2D (1-20) .


Outil d'identification Lire le code 2D - Onglet Résultats

L'onglet Résultats affiche les informations suivantes sur le code/symbole décodé :

Fermé Chaîne

Renvoie la chaîne contenue dans le code/symbole décodé.

Fermé Symbologie

Renvoie le type de symbole décodé.

Fermé Grade

Renvoie le grade donné au code/symbole décodé.


Outil d'identification Lire les codes 2D (1-20) - Tableau

Le tableau présente les informations suivantes pour chaque code/symbole décodé :

Fermé Index

Désigne l'ordre du code/symbole décodé en fonction du paramètre Mode de tri ; 1 à 20 (tri par ordre numérique dans EasyBuilder basé sur 0=1).

Fermé Chaîne

Renvoie la chaîne contenue dans le code/symbole décodé.

Fermé Symbologie

Renvoie le type de symbole décodé.

Fermé X

Renvoie l'abscisse de la sortie de repère de code/symbole décodé.

Fermé Y

Renvoie l'ordonnée de la sortie de repère de code/symbole décodé.

Fermé Angle

Renvoie la valeur d'angle de la sortie de repère de code/symbole décodé.

Fermé Niveau

Renvoie le grade donné au code/symbole décodé.


Outils d'identification - Lire les codes ID

L'outil d'identification Lire les codes ID décode et vérifie automatiquement les informations contenues dans les codes barres 1D et les symboles de matrices 2D.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil d'identification Lire les codes ID

Une fois l'outil ajouté, sélectionnez le type de région et configurez cette dernière dans l'image :

  1. Positionnez la région sur la zone dans laquelle le code ou symbole peut apparaître, en vous assurant qu'elle englobe complètement le code ou le symbole. Pour accélérer l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter.

    Remarque : lors de la lecture de codes 2D, il est important de laisser une « zone silencieuse » entre le code et la région. La « zone silencieuse » implique une séparation d'au moins 3 pixels entre le bord du code et la région qui définit le code.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Lorsque vous avez confirmé la région, définissez le mode de fonctionnement : Lecture ou Chaîne de correspondance (le Mode est défini sur Lecture par défaut). Vous pouvez configurer ce paramètre sous l'onglet Paramètres.
  4. L'outil mémorise le type de code et recherche ce type de code spécifique lorsqu'il est exécuté. Si le type de code change, cliquez sur le bouton Apprendre de l'onglet Paramètres pour permettre à l'outil d'identifier le nouveau type de code pour ensuite le rechercher.
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Codes ID pris en charge


Codes ID pris en charge

L'outil d'identification Lire les codes ID prend en charge les types de codes et de symboles suivants :

    Code 39 | Code 128
Code I2of5 (2 parmi 5 entrelacé) | UPC
EAN | PharmaCode
POSTNET | PLANET
RSS-14 et empilé | RSS limité
Codabar (NW-7) | Code 93
UPU 4-États | Australia Post 4-États
Japan Post 4-États | USPS OneCode 4-États
DataMatrix | QR
RSS CC-A | RSS CC-B
PDF 417 |


Réglage des paramètres de l'outil d'identification Lire les codes ID

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil d'identification Lire les codes ID comprend quatre onglets :

  • Onglet Général
  • Onglet Paramètres
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres


Outil d'identification Lire les codes ID - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « IDCode_1 » s'il s'agit du premier outil d'identification Lire les codes ID ajouté au projet. Sinon, il est incrémenté (par exemple, « IDCode_2 », « IDCode_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil d'identification Lire les codes ID - Onglet Paramètres

Fermé Bouton Apprendre

Définit un nouveau type de code ou symbole. Le bouton Apprendre vous permet de soumettre un nouveau code ou symbole à l'outil. Présentez le nouveau code ou symbole à l'outil et cliquez sur le bouton Apprendre : l'outil tente automatiquement de décoder le code ou symbole. Une fois qu'il l'a décodé, l'outil ne lira ou ne vérifiera que les codes ou symboles de ce type.

Fermé Code

Affiche le type du code ou symbole décodé.

Fermé Mode

Définit le mode de fonctionnement de l'outil : Lecture ou Chaîne de correspondance.

Le mode Lecture (Mode par défaut) est utilisé lorsque les informations dans le code ou le symbole sont inconnues. L'outil décode automatiquement les informations contenues dans le code ou le symbole, puis affiche les informations décodées dans le champ Chaîne.

Le mode Chaîne de correspondance permet de vérifier qu'un code barres ou symbole connu est présent et lisible. L'outil décode les informations contenues dans les codes barres ou les symboles puis compare les informations décodées à celles entrées dans le champ Chaîne de correspondance.

Remarque : l'outil peut avoir deux états : Succès ou Échec. Lorsque le contrôle Mode de l'outil est défini sur Chaîne de correspondance, l'outil renvoie un échec dans deux types de situations : en cas d'échec de la lecture, ou lorsque la lecture a réussi mais que les informations décodées ne correspondent pas à la chaîne de texte entrée dans le champ Chaîne de correspondance.

Dans ce dernier cas, l'outil affiche les données de non correspondance (Non correspondance et Nombre de non correspondances) qui peuvent être utilisées par EasyView et d'autres périphériques de communication dans l'étape d'application Communication. Les données de non correspondance peuvent être sélectionnées dans les boîtes de dialogue Sélectionner des éléments EasyView, Sélectionner les balises OPC ou Sélectionner les données d'entrée/de sortie.

Les données de non correspondance s'avèrent utiles lorsque l'utilisateur doit déterminer si l'outil ne peut pas lire le code ou si le code peut être lu mais que les informations décodées ne correspondent pas à la Chaîne de correspondance spécifiée. Ainsi, quand l'outil ne peut pas lire le code, cela peut indiquer un problème du processus d'impression des étiquettes ou de configuration du système de vision. Lorsque le code peut être lu mais que les informations décodées ne correspondent pas à la Chaîne de correspondance spécifiée, la mauvaise étiquette risque d'être imprimée.
Fermé Chaîne de correspondance

Définit la chaîne attendue à lire (cette option n'est activée que lorsque le paramètre Mode est défini sur Chaîne de correspondance). Entrez les informations que vous souhaitez que l'outil décode.

Remarque : vous pouvez entrer la chaîne de correspondance à partir d'un autre périphérique. Lorsque vous exécutez le projet, l'outil d'identification peut lire la chaîne de texte à partir du périphérique sur lequel vous l'avez entrée et la comparer au code ID reconnu. L'outil Lire les codes ID génère le résultat Échec et le champ Chaîne de correspondance affiche TRIG jusqu'à ce que la chaîne de correspondance soit entrée à partir du périphérique externe.
Fermé Délai d'attente

Définit la durée, en millisecondes (0 à 30 000), pendant laquelle l'outil recherche les codes avant que l'exécution ne soit interrompue et que l'outil ne renvoie un échec.

Fermé Chaîne

Affiche les informations décodées.


Outils d'identification - Couleur

L'outil d'identification de couleur permet de déterminer, à partir d'une bibliothèque de couleurs apprises, la couleur qui correspond le mieux à la couleur dans l'image.

Cet outil s'avère utile, par exemple, pour s'assurer que le produit correct défile sur la chaîne de production d'après la couleur d'une pièce ou d'un objet, ou pour identifier le produit qui défile et communiquer ces informations aux autres périphériques de l'usine.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil d'identification de couleur

Une fois l'outil ajouté, sélectionnez le type de région et configurez cette dernière dans l'image :

  1. Dans le menu déroulant Modèle, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région dans l'image dans laquelle vous pensez voir apparaître la ou les couleur(s), en vous assurant qu'elle englobe complètement la ou les couleur(s) et leurs emplacements possibles, et configurez-la. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la ou des couleur(s) reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

    2. Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Une fois la région de recherche configurée, configurez la bibliothèque de couleurs de l'outil et activez la ou les couleurs appropriées :

    • Si un outil d'identification de couleur est ajouté pour la première fois, commencez par configurer une ou plusieurs bibliothèques de couleurs et leur ou leurs modèles de couleurs.
    • Si un autre outil d'identification de couleur a déjà été ajouté et que vous souhaitez utiliser une bibliothèque de couleurs existante et ses couleurs apprises, sélectionnez la bibliothèque de couleurs de votre choix sous l'onglet Paramètres, puis activez les couleurs voulues en les cochant sous l'onglet Bibliothèque.
    • Par défaut, l'outil déclenche automatiquement un échec tant qu'aucune bibliothèque de couleurs n'a été définie. Si une bibliothèque de couleurs a été définie, l'outil utilise automatiquement cette bibliothèque et active toutes les couleurs qu'elle contient.
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Composants de couleur d’un pixel


Composants de couleur d'un pixel

Chaque couleur est constituée de trois composants distincts. Ces composants peuvent être représentés sous forme de combinaisons de rouge, vert et bleu (RVB) ou de teinte, saturation et intensité (TSI). Pour les combinaisons RVB et TSI, chaque composant d'un pixel est converti en une valeur comprise entre 0 et 255.

Fermé RVB

Les couleurs RVB sont créées en combinant les nuances de rouge (255, 0, 0), de vert (0, 255, 0) et de bleu (0, 0, 255) dans des proportions différentes. Cette combinaison produit une couleur spécifique pour chaque pixel.

Fermé TSI

Pour TSI, la teinte d'une couleur correspond à son emplacement dans la portion visible du spectre électromagnétique de radiation.

La saturation d'une couleur est le degré de mélange de la couleur avec du gris ou du blanc. Une couleur entièrement saturée est pure. Plus elle contient de blanc (ou de gris), moins elle est saturée.

L'intensité d'une couleur est une mesure de sa luminosité. Elle est définie comme la valeur moyenne des composants rouge, vert et bleu constituant la couleur. Le mélange de teinte, de saturation et d'intensité résultant produit la couleur correcte pour chaque pixel.

Fermé Valeurs RVB et TSI comparées

Valeurs RVB = 255, 0, 0

Valeurs TSI = 0, 255, 85

Valeurs RVB = 0, 255, 0

Valeurs TSI = 85, 255, 85

Valeurs RVB = 0, 0, 255

Valeurs TSI = 170, 255, 85


Réglage des paramètres de l'outil d'identification de couleur

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil d'identification de couleur comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Tableau
  • Onglet Bibliothèque
  • Onglet Région composite
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Tableau

Onglet Bibliothèque de couleurs

Onglet Région composite


Outil d'identification de couleur - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats Entrées/Sorties et Communication. Le nom par défaut est « IDCouleur_1 » s'il s'agit du premier outil d'identification de couleur ajouté au projet. Sinon, il est incrémenté (par exemple, « IDCouleur_2 », « IDCouleur_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil d'identification de couleur - Onglet Paramètres

Fermé Apprendre la couleur

Affiche la boîte de dialogue Apprentissage MatchColor , utilisée pour définir la ou les couleurs de la bibliothèque de couleurs sélectionnée.

Fermé Bibliothèque de couleurs

Définit la bibliothèque de couleurs utilisée comme référence par l'outil. Sur la liste déroulante, sélectionnez la bibliothèque de couleurs à modifier puis cliquez sur le bouton Apprendre la couleur pour afficher la boîte de dialogue Apprentissage MatchColor. Les projets EasyBuilder peuvent contenir 5 bibliothèques de couleurs de correspondance maximum. Chaque bibliothèque de couleurs peut compter jusqu'à 100 couleurs distinctes, composées des valeurs RVB/TSI de l'objet inspecté.

Fermé Espace de couleur

Définit les valeurs que l'outil utilisera dans son calcul comparatif : RVB (valeur par défaut) ou TSI. Chaque pixel de couleur est constitué de trois composants distincts. Ces composants sont représentés sous forme de combinaisons de rouge, vert et bleu (RVB) ou de teinte, saturation et intensité (TSI). Les combinaisons RVB et TSI convertissent chaque composant du pixel en une valeur comprise entre 0 et 255.

Fermé Mode

Définit le mode de fonctionnement de l'outil : Identifier (par défaut) ou Correspondance.

  • Identifier : utilisé lorsque les couleurs de l'image sont inconnues. L'outil détermine le modèle de couleurs qui correspond le mieux aux couleurs de l'image et organise et classe les résultats en fonction de leur comptage de pixels, s'il y a plusieurs modèles de couleurs actifs dans la bibliothèque de couleurs sélectionnée.
  • Correspondance : utilisé pour vérifier si un modèle de couleurs attendu est présent dans l'image. L'outil traite l'image et détermine si les couleurs qu'elle contient correspondent ou non à celles attendues d'après le modèle de couleurs spécifié dans le paramètre Couleur de correspondance.
Fermé Couleur de correspondance

Définit la couleur attendue à détecter. Ce champ n'est activé que si le paramètre Mode est défini sur Correspondance. Entrez le nom de la couleur que vous pensez détecter dans le champ.

Fermé Seuil d'acceptation

Définit le degré de similitude qui doit exister entre la couleur et la couleur localisée (0 à 100 ; valeur par défaut = 90).

Fermé Résultat

Affiche le nom de la couleur localisée.


Outil d'identification de couleur - Onglet Tableau

L'onglet Tableau affiche une liste en lecture seule des couleurs localisées, triées en fonction de leur rang et score dans les 10 meilleures correspondances.

Fermé Rang

Affiche le classement numérique de la ou des couleurs qui correspondent le mieux aux critères de l'inspection, de 1 à 10.

Fermé Nom de la couleur

Affiche le nom de la ou des couleurs localisées.

Fermé Score

Affiche le score de la couleur localisée.


Outil d'identification de couleur - Onglet Bibliothèque de couleurs

Fermé Nom de la couleur

Affiche une liste en lecture seule des couleurs de la bibliothèque de couleurs de correspondance sélectionnée. Les couleurs sont activées et désactivées en cochant ou décochant la case en regard de Nom de la couleur.

Remarque : par défaut, toute couleur déjà présente dans une bibliothèque de couleurs de correspondance est automatiquement activée (cochée) lorsqu'un outil est ajouté pour la première fois. Les couleurs doivent être désactivées manuellement pour chaque outil utilisant la bibliothèque de couleurs sélectionnée. Si aucune couleur n'a été apprise pour la bibliothèque de couleurs sélectionnée, la liste est vide.
Fermé RVB

Affiche une liste en lecture seule des valeurs RVB moyennes des couleurs de la bibliothèque de couleurs de correspondance sélectionnée.

Fermé TSI

Affiche une liste en lecture seule des valeurs TSI moyennes des couleurs de la bibliothèque de couleurs de correspondance sélectionnée.


Outil d'identification de couleur - Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).
Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils d'identification - Lire le code postal

L'outil d'identification Lire le code postal décode et/ou vérifie un symbole empilé de code postal dans une région avec l'algorithme ReadIDMax®. L'outil indique les informations décodées et la réussite si le code/symbole a été décodé correctement et s'il se trouvait dans les limites de seuil spécifiées.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil d'identification Lire le code postal

Une fois que l'outil a été ajouté, vous devez configurer la région dans l'image :

  1. Positionnez la région sur le code/symbole, en vous assurant qu'elle l'englobe complètement. Pour accélérer l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Une fois que la région a été confirmée, vous devez définir les paramètres dans Onglet Paramètres : Paramètre Mode, qui définit le mode de fonctionnement de l'outil : Lecture ou Chaîne de correspondance (le Mode est défini sur Lecture par défaut).
  4. L'outil trace un cadre non modifiable autour du code/symbole décodé et insère une icône [image] pour indiquer le repère créé à partir du code/symbole décodé.
  5. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  6. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Ajustement des paramètres de l'outil d'identification Lire le code postal

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil d'identification Lire le code postal comporte les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Code postal
  • Onglet Résultats
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Code postal

Onglet Résultats


Outil d'identification Lire le code postal - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats Entrées/Sorties et Communication. Le nom par défaut est « IDCode_1 » s'il s'agit du premier outil d'identification Lire le code 1D, Lire les codes 1D (1-20), Lire le code 2D, Lire les codes 2D (1-20) ou Lire le code postal ajouté au projet. Sinon, il est incrémenté (par exemple, « IDCode_2 », « IDCode_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil d'identification Lire le code postal - Onglet Paramètres

Fermé Appris(e)

Indique si l'outil a été appris ou non sur un code/symbole spécifique ; affiche 1 lorsque l'outil a été appris et 0 lorsqu'il n'a pas été appris.

Fermé Apprendre

Apprend un modèle de code/symbole lu ; les informations apprises sont conservées tant que vous n'avez pas cliqué sur le bouton Supprimer l'apprentissage. Pour apprendre de nouveau un code/symbole, cliquez sur le bouton Supprimer l'apprentissage, puis sur le bouton Apprendre avec le nouveau code/symbole présenté. L'apprentissage permet d'améliorer la vitesse et les performances de l'outil en indiquant à l'outil quel type de code/symbole décoder. Lorsque vous utilisez et apprenez l'outil d'identification Lire les codes 1D (1-20) ou Lire les codes 2D (1-20), configurez la région autour d'un code/symbole unique avant de cliquer sur le bouton Apprendre. Une fois le code/symbole appris, vous pouvez ajuster la région afin de rechercher plusieurs codes/symboles dans un champ de vue plus étendu. L'apprentissage ne fonctionne qu'avec un code/symbole unique dans la région. Si vous cliquez sur le bouton Apprendre avec plusieurs codes/symboles dans la région, il n'est pas possible d'indiquer le code/symbole à apprendre. Avant l'apprentissage, assurez-vous que les types de code appropriés sont sélectionnés sous l'onglet Code postal.

Fermé Supprimer l'apprentissage

Annule l'apprentissage d'un modèle de code/symbole appris. Pour apprendre de nouveau un symbole, cliquez sur le bouton Supprimer l'apprentissage, puis sur le bouton Apprendre avec le nouveau code présenté.

Fermé Mode

Définit le mode de fonctionnement de l'outil (Lecture ou Chaîne de correspondance ; valeur par défaut = Lecture).

  • Le mode Lecture est utilisé lorsque les informations figurant dans le code/symbole sont inconnues. L'outil décode automatiquement les informations contenues dans le code/symbole, puis affiche les informations décodées dans le paramètre Chaîne.
  • Le mode Chaîne de correspondance permet de vérifier qu'un code barres/symbole connu est présent et lisible. L'outil décode les informations contenues dans les codes barres/symboles, puis compare les informations décodées à celles saisies dans le champ Chaîne de correspondance.
Fermé Chaîne de correspondance

Définit la chaîne attendue à lire (cette option n'est activée que lorsque le paramètre Mode est défini sur Chaîne de correspondance). Saisissez les informations que vous souhaitez que l'outil décode.

Remarque : vous pouvez entrer la chaîne de correspondance à partir d'un autre périphérique. Lorsque vous exécutez le projet, l'outil d'identification peut lire la chaîne de texte à partir du périphérique sur lequel vous l'avez entrée et la comparer au code ID/symbole reconnu. L'outil génère le résultat Échec et le champ Chaîne de correspondance affiche TRIG jusqu'à ce que la chaîne de correspondance soit entrée à partir du périphérique externe.
Fermé Mode de correspondance

Définit si, pour aboutir, les codes/symboles décodés dans la région doivent correspondre, ou non, à la chaîne définie dans le paramètre Chaîne de correspondance. Le paramètre Chaîne de correspondance doit être configuré de manière à activer cette option.

  • Toutes les correspondances = tous les codes/symboles décodés doivent correspondre à la chaîne définie dans le paramètre Chaîne de correspondance.
  • N'importe quelle correspondance = au moins un des codes/symboles décodés doit correspondre à la chaîne définie dans le paramètre Chaîne de correspondance.
Fermé Vérifier

Indique si les tests de qualité d'impression seront effectués (par défaut, ce paramètre est désactivé).

Fermé Délai d'attente

Définit le temps, en millisecondes (0 à 30 000 ; valeur par défaut = 0), pendant lequel l'outil recherche un code/symbole valide avant l'arrêt de l'exécution avec un échec.

Fermé Omnidirectionnel

Définit si l'outil tentera de trouver le code barres grâce au mode omnidirectionnel (ce paramètre est désactivé par défaut). Ce paramètre établit la direction dans laquelle les lignes de balayage (pour les symboles 1D, le code barres est divisé en 10 lignes maximum à intervalles égaux, appelées lignes de balayage et disposées perpendiculairement aux barres) sont projetées au sein de la région, afin de détecter tous les éléments dans le code barres. Pour que le test de décodage réussisse, il faut au moins une ligne de balayage projetée sur chaque élément du code barres. Lorsque ce paramètre est désactivé, les lignes de balayage sont projetées dans une seule direction, pour détecter un code barres parallèle à la région. Lorsqu'il est activé, les lignes de balayage sont projetées à différents angles afin de détecter un code barres dont l'orientation diffère de la région.


Outil d'identification Lire le code postal - Onglet Code postal

Cet onglet définit les codes/symboles à décoder. Par défaut, tous les types de code/symbole sont activés. Plusieurs symbologies peuvent être sélectionnées et lues.

Fermé POSTNET

Définit si l'outil tente de lire les éléments POSTNET.

Fermé PLANET

Définit si l'outil tente de lire les éléments PLANET.

Fermé Japan Post

Définit si l'outil tente de lire les éléments Japan Post.

Fermé Australia Post

Définit si l'outil tente de lire les éléments Australia Post.

Fermé UPU

Définit si l'outil tente de lire les éléments UPU.

Fermé Intelligent Mail Barcode

Définit si l'outil tente de lire les éléments Intelligent Mail Barcode.


Outil d'identification Lire le code postal - Onglet Résultats

L'onglet Résultats affiche les informations suivantes sur le code/symbole décodé :

Fermé Chaîne

Renvoie la chaîne contenue dans le code/symbole décodé.

Fermé Symbologie

Renvoie le type de symbole décodé.

Fermé Grade

Renvoie le grade donné au code/symbole décodé.


Outils d'identification - Lire le texte (OCRMax)

L'outil d'identification Lire le texte (OCRMax) est utilisé pour lire et/ou vérifier une chaîne de texte dans une région, après l'apprentissage et la création de polices de caractères définies par l'utilisateur.

L'outil d'identification Lire le texte (OCRMax) effectue une reconnaissance optique des caractères (ROC) par le biais d'un processus de segmentation et de classification. La segmentation survient en premier, utilisant des techniques de seuillage pour identifier les zones de l'image semblant contenir des lignes de texte. Une fois le texte segmenté en caractères, les caractères sont appris et stockés sous forme de base de données. La classification survient pendant l'exécution, assurant la lecture de tout texte trouvé après exécution de la segmentation. Pour cela, les images des caractères segmentés sont comparées aux caractères appris dans la police.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil d'identification Lire le texte (OCRMax)

Le fonctionnement de l'outil d'identification Lire le texte (OCRMax) implique deux phases : la phase d'apprentissage et la phase d'exécution.

  • La phase d'apprentissage implique le chargement de plusieurs images des caractères qui seront lus, leur extraction de l'image, leur segmentation et la création d'une base de données de polices apprises pour les caractères.
  • La phase d'exécution implique la mise en ligne du système de vision In-Sight, l'acquisition des images et l'extraction et la classification des caractères en fonction de la base de données de polices apprises.
Remarque : avant de commencer à configurer l'outil, chargez les images d'apprentissage. Lors de l'apprentissage d'une base de données de polices, Cognex recommande de commencer le processus avec des images qui représentent au mieux l'aspect que les caractères devraient avoir (utilisez d'abord vos meilleures images), en travaillant des meilleures images vers les plus mauvaises.
Fermé Apprentissage de l'outil d'identification Lire le texte (OCRMax)
  1. Chargez la première image d'apprentissage.
  2. Ajoutez l'outil d'identification Lire le texte (OCRMax) au projet.
  3. Une fois l'outil ajouté, vous devez configurer la région dans l'image. Positionnez la région de l'outil sur la ligne de texte à lire :
    • L'axe X de la région doit être parallèle à la ligne de base du texte, et l'axe Y doit être parallèle aux traits verticaux des caractères. S'il n'y pas d'inclinaison, l'axe Y est perpendiculaire à l'axe X.
    • Le sens positif de l'axe X correspond au sens de lecture.
    • La région doit comporter une seule ligne de texte à lire et un arrière-plan. L'arrière-plan peut être bruyant et avoir des gradients/un ombrage significatifs.
    • Dans les images avec texte clairement imprimées et comportant peu de bruit, la région peut être considérablement plus grande que la ligne de texte.
    • Dans le cas d'images bruyantes, la région doit être relativement étroite autour de la ligne de texte.

    • En règle générale, la région doit être plus grande que la ligne de texte d'au moins une demi-largeur de caractère sur tous ses côtés, si possible (à moins, par exemple, qu'une bordure de cette taille entraîne l'inclusion d'autres caractéristiques dans la région).

      Remarque :
      • La ligne de base du texte peut avoir n'importe quel angle (0-360) dans l'image, tant que l'angle d'orientation de la région est à peu près similaire.
      • La région ne doit contenir aucune caractéristique significative autre que la ligne de texte dans l'image. Elle ne peut, par exemple, englober partiellement la ligne d'un texte environnant, ou le bord d'une étiquette.
      • Si la zone est courbe, l'outil place automatiquement l'image dans la zone de sortie redressée en utilisant le nom « Position de la zone courbe », qui peut être repositionné sur l'image afin de permettre son affichage.

  4. L'outil crée automatiquement des régions de caractère autour du texte que l'outil détermine comme étant constitué de caractères, sur la base des paramètres par défaut définis sous l'onglet Segmentation.

  5. Si la fonction n'a pas correctement tracé les régions de caractère autour du texte, il existe deux options :
    • Utilisez la boîte de dialogue Mise au point automatique et autorisez l'outil d'identification Lire le texte (OCRMax) à calculer automatiquement les paramètres de segmentation optimaux. La boîte de dialogue Mise au point automatique associe les phases de segmentation et d'apprentissage dans une seule étape. Suivez les instructions dans la rubrique de la boîte de dialogue Mise au point automatique afin de segmenter et d'apprendre correctement une base de données de polices.

    • Accédez à l'onglet Segmentation et réglez les paramètres jusqu'à ce que le texte soit correctement inclus dans chacune des régions de caractère. Suivez le processus de segmentation afin de segmenter correctement tous les caractères dans la base de données d'images avant l'apprentissage.

      Remarque :
      • Pour les images bruyantes et le texte difficile à lire, les paramètres de l'onglet Avancé peuvent permettre de compenser les conditions difficiles.
      • S'il y a des espaces entre les caractères, accédez à l'onglet Espaces et ajustez les paramètres pour compenser les espaces.
Fermé Apprentissage manuel de l'outil d'identification Lire le texte (OCRMax) après la segmentation

Une fois le texte segmenté, les caractères sont prêts à être appris et ajoutés à la police. Commencez par sélectionner une base de données de polices en accédant à l'onglet Paramètres puis en sélectionnant une police dans le paramètre Bibliothèque de polices.

  • Si vous créez une police personnalisée, accédez à l'onglet Apprentissage et saisissez la chaîne de texte exacte à apprendre, puis cliquez sur le bouton Apprendre tous. Les caractères seront ajoutés et enregistrés dans la police personnalisée sélectionnée.

Pour ajouter des caractères supplémentaires à une police personnalisée existante, acquérez ou chargez une autre image contenant les caractères à apprendre. Si nécessaire, reconfigurez la région et les paramètres de segmentation pour garantir que les caractères sont segmentés correctement, puis cliquez sur le bouton Apprendre nouveaux ou Apprendre sélectionnés sous l'onglet Apprentissage.

Remarque : une police personnalisée peut être exportée ou importée comme fichier de données OCRMax (*.ocm) depuis l'onglet Apprentissage.
  • Si vous utilisez une police OCRA ou OCRB prédéfinie, positionnez simplement la région de l'outil sur le texte à lire. L'outil segmente ensuite automatiquement les caractères de la région en fonction des paramètres de segmentation et avancés définis.
Remarque : les polices OCRA ou OCRB prédéfinies ne peuvent pas être modifiées.
Fermé Opération d'exécution

Une fois que l'outil a une base de données de polices apprises, il est prêt pour l'opération d'exécution.

  1. Définissez le Mode d'inspection en cours d'exécution de l'outil, qui détermine si l'outil se contentera de lire le texte présent dans sa région ou s'il lira la chaîne et vérifiera que la chaîne correcte a été lue.
  2. À l'exécution, le système de vision In-Sight est mis en ligne et acquiert les images comme défini par le projet. Lorsqu'une image est acquise, la chaîne de texte de l'image est segmentée automatiquement sur la base des paramètres de segmentation, et les caractères sont comparés aux instances apprises des caractères.


Réglage des paramètres de l'outil d'identification Lire le texte (OCRMax)

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil d'identification Lire le texte (OCRMax) comporte les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Segmentation
  • Onglet Avancé
  • Onglet Espaces
  • Onglet Longueur variable
  • Onglet Apprentissage
  • Onglet Recherche ciblée
  • Onglet Diagnostics
  • Onglet Résultats
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Segmentation

Onglet Avancé

Onglet Espaces

Onglet Longueur variable

Onglet Apprentissage

Onglet Recherche ciblée

Onglet Diagnostics

Onglet Résultats


Outil d'identification Lire le texte (OCRMax) - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Texte_1 » s'il s'agit du premier outil d'identification Lire le texte (OCRMax) ajouté au projet. Sinon, il est incrémenté (par exemple, « Texte_2 », « Texte_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil d'identification Lire le texte (OCRMax) - Onglet Paramètres

Fermé Bibliothèque de polices

Définit une base de données de polices de référence pour l'outil. Sélectionnez un type de police prédéfini parmi quatre (OCRA ou OCRB, Blanc sur Noir ou Noir sur Blanc) ou créez une base de données de polices personnalisée en apprenant des caractères (jusqu'à huit bases de données de polices personnalisées peuvent être créées par projet).

Remarque : les quatre polices OCRA et OCRB sont en lecture seule et ne peuvent pas être de nouveau apprises, effacées ou renommées.
  • Lorsque vous sélectionnez une des polices prédéfinies, positionnez simplement la région de l'outil sur le texte à lire. L'outil segmente ensuite automatiquement les caractères de la région.
  • Lorsque vous sélectionnez une police personnalisée, suivez les étapes de la rubrique Configuration de l'outil d'identification Lire le texte (OCRMax) pour commencer par créer la base de données de polices personnalisée. Si une police personnalisée existante est modifiée, tous les autres outils Lire le texte (OCRMax) qui utilisent cette même police personnalisée seront également affectés.
Fermé Mode d'inspection

Définit le mode de fonctionnement de l'outil : Lire (valeur par défaut) ou Lire/Vérifier.

  • Lire : l'outil tente de lire les caractères de la région, sur la base des instances apprises des caractères.
  • Lire/Vérifier : l'outil tente de lire les caractères de la région, sur la base des instances apprises des caractères, puis de vérifier que les caractères lus correspondent à la chaîne de texte spécifiée dans le paramètre Chaîne de correspondance.
Fermé Chaîne de correspondance

Définit la chaîne de texte à laquelle les résultats doivent correspondre en mode d'inspection Lire/Vérifier.

Fermé Seuil d'acceptation

Définit le score de correspondance minimal acceptable (0 à 100 ; valeur par défaut = 80) pour chaque caractère. Tout caractère avec un score de correspondance inférieur au seuil d'acceptation sera refusé.

Fermé Seuil de confusion

Définit la différence minimale requise entre les scores de correspondance du caractère au score le plus élevé et le second caractère au score le plus élevé (0 à 40 ; valeur par défaut = 0).

Fermé Utiliser le sous-échantillonnage

Indique si le sous-échantillonnage doit être activé, réduisant la résolution des caractères pour accélérer la vitesse de lecture.

Fermé Délai d'attente

Définit le temps, en millisecondes (0 à 30 000 ; valeur par défaut = 5 000), pendant lequel l'outil recherche des caractères avant que l'exécution ne soit interrompue et qu'elle n'aboutisse à un échec. Si la valeur est définie sur 0, le paramètre est désactivé et aucun délai d'attente n'est appliqué.

Fermé Afficher les caractères

Indique si les caractères et leur région de caractère sont affichés dans les autres étapes d'application, ou uniquement dans les étapes Localiser la pièce et Inspecter une pièce (ce paramètre est activé par défaut).

Fermé Position du nom de caractère

Définit où le nom des caractères sera positionné par rapport à leur région : Au-dessus du caractère (valeur par défaut), À droite du caractère, Sous le caractère ou À gauche du caractère.


Outil d'identification Lire le texte (OCRMax) - Onglet Segmentation

L'onglet Segmentation est utilisé pour ajuster et modifier les paramètres qui segmentent les caractères dans une région. Les valeurs et paramètres par défaut permettent généralement de lire la majorité du texte. Cependant, dans les cas les plus complexes, il peut être nécessaire d'ajuster certaines valeurs de paramètres. Dans ces types de cas, spécifier une largeur minimale des caractères, une largeur maximale et/ou un pas minimal (la distance entre caractères, par exemple, du bord gauche d'un caractère au bord gauche du caractère suivant) permet généralement de résoudre les difficultés. Dans les cas difficiles, et pour accélérer la création de la base de données utilisée pour la police, utilisez le bouton Mise au point automatique pour ouvrir la boîte de dialogue Mise au point automatique et permettre à l'outil de calculer automatiquement les paramètres de segmentation optimaux.

Fermé Consignes de segmentation
  • Les images contenant un arrière-plan à texture marquée et/ou un bruit tel que les caractères se fondent dans l'arrière-plan seront difficiles à segmenter.
  • La région doit contenir uniquement les caractères à lire, et non des caractéristiques externes marquées, telles que d'autres caractères ou des bords d'étiquettes.
  • Dans les cas où deux caractères se touchent, les paramètres devront probablement être ajustés. Il est possible de compenser les caractères à largeur fixe qui se touchent en spécifiant la largeur des caractères. Néanmoins, les polices proportionnelles contenant des caractères qui se touchent sont problématiques, la fonction traitant correctement certains cas, d'autres pas.
  • Dans les cas de courtes lignes de texte (trois caractères ou moins) ou de lignes relativement courtes présentant un scintillement important, spécifier la Plage angulaire attendue doit permettre à la fonction de compenser correctement l'incertitude inhérente à la détermination de l'orientation d'une courte ligne de texte.
  • Tous les caractères d'une ligne de caractères doivent avoir la même orientation et la même inclinaison.
  • Pour le texte à matrice de points clairement séparés (les points ne se touchent pas), il peut être nécessaire d'ajuster certains paramètres tels que Taille minimale des fragments de caractère pour segmenter correctement les caractères.
  • La largeur de trait des caractères doit être supérieure ou égale à deux pixels.
  • La taille minimale des grands caractères (généralement alphanumériques) est 8 x 8 pixels. La taille minimale des petits caractères (comme les points) est 2 x 2 pixels.
Fermé Mise au point automatique

Ouvre la boîte de dialogue Mise au point automatique, utilisée en association avec l'outil d'identification Lire le texte (OCRMax) pour configurer les paramètres de segmentation de l'outil et apprendre une base de données utilisée pour la police, via la construction d'enregistrements de mise au point automatique pour créer un modèle de mise au point automatique. Un enregistrement de mise au point automatique comporte une image, la chaîne d'apprentissage et l'emplacement vérifié par l'utilisateur des caractères de l'image. Le modèle de mise au point automatique comporte un ou plusieurs enregistrements de mise au point automatique, ainsi que les paramètres de segmentation optimale de toutes les images des enregistrements de mise au point automatique.

Remarque :
  • Lors de l'utilisation de la boîte de dialogue Mise au point automatique, Cognex recommande d'effectuer le réglage de la segmentation sur un émulateur In-Sight plutôt que sur un système de vision In-Sight. L'algorithme de mise au point automatique de l'outil Lire le texte (OCRMax) nécessite une puissance de calcul élevée et les performances seront meilleures sur l'émulateur par rapport à un système de vision.
  • Lors de l'apprentissage d'une base de données utilisée pour la police et de l'utilisation de la boîte de dialogue Mise au point automatique pour segmenter les caractères, Cognex recommande de commencer le processus avec des images qui représentent au mieux l'aspect que les caractères devraient avoir (utilisez d'abord vos meilleures images), en travaillant des meilleures images vers les plus mauvaises. Cela permet à l'algorithme de l'outil Lire le texte (OCRMax) d'effectuer un réglage plus efficace.
Fermé Polarité des caractères

Définit la polarité des caractères dans l'image d'entrée : Noir sur blanc, Blanc sur noir ou Automatique (valeur par défaut).

Remarque : pour améliorer les performances de l'outil, définissez la polarité du texte.
  • Noir sur blanc : la polarité du texte est un texte noir sur fond blanc.
  • Blanc sur noir : la polarité du texte est un texte blanc sur fond noir.
  • Automatique : l'outil détermine automatiquement la polarité du texte et l'arrière-plan.
Fermé Type de largeur des caractères

Définit la manière dont la largeur des caractères de la police doit varier : Automatique (valeur par défaut), Fixe ou Variable.

Remarque : la largeur de caractère correspond à la largeur du rectangle de caractère, pas la région.
  • Automatique : la largeur de caractère est inconnue ; la largeur de la police peut être fixe ou proportionnelle.
  • Fixe : tous les rectangles de caractère de la police ont la même largeur.
  • Variable : les caractères de la police ont des rectangles de caractère de largeur différente.
Fermé Largeur minimale des caractères

Définit la largeur minimale du rectangle de caractère d'un caractère, en pixels (1 à 1 000 ; valeur par défaut = 3), qu'un caractère doit avoir pour être signalé.

Fermé Hauteur minimale des caractères

Définit la hauteur minimale du rectangle de caractère d'un caractère, en pixels (1 à 1 000 ; valeur par défaut = 3), qu'un caractère doit avoir pour être signalé.

Fermé Utiliser la largeur maximale des caractères

Indique si l'outil tient compte de la largeur maximale autorisée du rectangle de caractère d'un caractère (ce paramètre est désactivé par défaut).

Remarque : si ce paramètre est activé, les caractères plus grands que la valeur spécifiée sont divisés en segments de taille acceptable.
Fermé Largeur maximale des caractères

Définit la largeur maximale du rectangle de caractère d'un caractère, en pixels (1 à 5 000 ; valeur par défaut = 100), qu'un caractère doit avoir pour être signalé.

Fermé Utiliser la hauteur maximale des caractères

Indique si l'outil tient compte de la hauteur maximale autorisée du rectangle de caractère d'un caractère (ce paramètre est désactivé par défaut).

Remarque : cette valeur est utilisée de deux manières. D'une part, lorsque la ligne est trouvée, dans son ensemble, pour rejeter le bruit adjacent verticalement et/ou d'autres lignes de caractères adjacents verticalement. D'autre part, en rognant tout caractère individuel dont la hauteur dépasse cette valeur pour obtenir la hauteur spécifiée.
Fermé Hauteur maximale des caractères

Définit la hauteur maximale du rectangle de caractère d'un caractère, en pixels (1 à 5 000 ; valeur par défaut = 100), qu'un caractère doit avoir pour être signalé.

Fermé Utiliser le rapport des caractères minimal

Indique si la fonction tient compte du rapport minimal autorisé d'un caractère, où le rapport est défini comme la hauteur de la ligne complète de caractères, divisée par la largeur du rectangle de caractère du caractère (ce paramètre est activé par défaut).

Remarque : lorsque ce paramètre est activé, un caractère dont le rapport est inférieur à cette valeur (sa largeur est trop grande) est divisé en segments de largeur acceptable.
Fermé Rapport des caractères minimal

Définit le rapport minimal autorisé (0 à 500 ; valeur par défaut = 80) d'un caractère.

Fermé Plage angulaire

Définit la plage de recherche angulaire (0 - 45 ; valeur par défaut = 0) en degrés.

Remarque : Toute valeur supérieure à 0 augmente le délai d'exécution du processus de segmentation.
Fermé Plage d'inclinaison

Définit la plage de recherche d'inclinaison (0 - 45 ; valeur par défaut = 0) en degrés.

Remarque : Toute valeur supérieure à 0 augmente le délai d'exécution du processus de segmentation.
Fermé Afficher les diagnostics

Indique si les données de diagnostic graphique doivent être affichées sur l'image. Une fois activées, les régions sont tracées autour des caractères conservés (en vert), des caractères rejetés (en rouge), des fragments conservés (en cyan), des fragments rejetés (en jaune), de la ligne principale du texte (en bleu) et de la ligne principale étendue du texte (en magenta).


Outil d'identification Lire le texte (OCRMax) - Onglet Avancé

Fermé Mode de fusion des fragments de caractère

Définit la manière dont l'outil doit fusionner les fragments de caractère lors de la formation de caractères pendant la segmentation : Chevauchement requis (valeur par défaut), Définir l'écart minimal entre les caractères ou Définir les écarts minimal/maximal entre les caractères.

  • Chevauchement requis : les fragments de caractère doivent se chevaucher horizontalement d'au moins un pixel pour être fusionnés.
  • Définir l'écart minimal entre les caractères : les fragments de caractère présentant un écart horizontal entre eux peuvent être fusionnés pour former des caractères, où deux fragments dont l'écart est inférieur à la valeur définie dans le paramètre d'écart minimal entre les caractères seront fusionnés.
  • Définir les écarts minimal/maximal entre les caractères : les fragments de caractère présentant un écart horizontal entre eux peuvent être fusionnés pour former des caractères, la décision de fusionner deux fragments étant basée sur les valeurs définies dans les paramètres d'écart minimal entre les caractères et d'écart maximal entre les caractères.
Fermé Chevauchement minimal des fragments de caractère

Définit la valeur fractionnaire minimale (0 à 100 ; valeur par défaut = 0) de chevauchement de deux fragments de caractère dans le sens des abscisses pour que les deux fragments soient considérés comme faisant partie du même caractère.

Fermé Écart maximal entre les caractères

Définit la taille de l'écart maximal, en pixels (0 à 1 000 ; valeur par défaut = 5), pouvant se produire au sein d'un caractère unique, même pour les caractères endommagés.

Fermé Écart minimal entre les caractères

Définit la taille de l'écart minimal, en pixels (0 à 1 000 ; valeur par défaut = 0), pouvant se produire entre deux caractères. L'écart est mesuré du bord droit du rectangle de caractère d'un caractère au bord gauche du rectangle de caractère du caractère suivant. Si l'écart entre deux fragments est inférieur à cette valeur, les fragments doivent être considérés comme faisant partie du même caractère, à moins que le caractère combiné ne soit trop grand (tel que spécifié par les paramètres Largeur maximale des caractères et/ou Rapport des caractères minimal).

Fermé Taille minimale des fragments de caractère

Définit le nombre minimal de pixels du premier plan (c.-à-d. le texte) (0 à 1 000 ; valeur par défaut = 15) qu'un fragment doit avoir pour qu'il soit considéré comme pouvant être inclus dans un caractère. Un fragment de caractère est un blob dans l'image binarisée.

Fermé Taille minimale des caractères

Définit le nombre minimal de pixels du premier plan (c.-à-d. le texte) (0 à 5 000 ; valeur par défaut = 30) qu'un fragment doit avoir pour être signalé.

Fermé Mode de normalisation

Définit le mode utilisé pour normaliser l'image : Aucun, Global, Local ou Local avancé (valeur par défaut).

Remarque : Ce paramètre doit être le même pour l'apprentissage et l'exécution ; la modification de ce paramètre après l'apprentissage risque d'entraîner des problèmes de classification.
  • Aucun : aucune normalisation n'est effectuée.
  • Global : une normalisation globale est effectuée, en utilisant les informations de la région complète, et non des variations locales.
  • Local : une normalisation locale est effectuée, en utilisant les informations relatives à chaque rectangle de caractère local de la région pour normaliser l'image.
  • Local avancé : une normalisation locale est effectuée, en utilisant les informations relatives à chaque rectangle de caractère local de la région pour normaliser l'image, incluant les réglages non seulement de l'arrière-plan, mais également de contraste du premier plan.
Fermé Utiliser un filtre de largeur de trait

Indique si tout ce qui n'a pas la même largeur de trait que le reste de l'image doit être supprimé de l'image normalisée (par défaut, ce paramètre est activé). Ce paramètre s'avère utile si, par exemple, les caractères semblent reliés les uns aux autres par de fines bandes de bruit. Néanmoins, l'utilisation de ce paramètre peut également entraîner la suppression incorrecte de caractères réels, si leur largeur de trait n'est pas cohérente.

Remarque : Ce paramètre doit être le même pour l'apprentissage et l'exécution ; la modification de ce paramètre après l'apprentissage risque d'entraîner des problèmes de classification.
Fermé Ignorer les fragments de bordures

Indique si la fonction ignore complètement les fragments touchant une des bordures de la région (par défaut, ce paramètre est désactivé). Ignorer de tels fragments peut être utile pour les caractéristiques non textuelles, telles que les bords d'étiquettes, pouvant être inclus dans la région.

Remarque : si un fragment s'étend du bord du rectangle de caractère à la ligne principale du texte, il est considéré comme un caractère. Il ne doit pas s'étendre à la ligne principale du texte pour être exclu lorsque ce paramètre est activé.
Fermé Seuil de binarisation

Définit un modificateur de pourcentage (0 à 100 ; valeur par défaut = 50) dans la plage utilisée pour calculer le seuil de binarisation, dans l'image normalisée, qui binarise l'image entre le premier plan et l'arrière-plan.

Fermé Seuil de contraste de fragment de caractère

Définit le contraste minimal [dans les niveaux de gris de l'image normalisée (0 à 255 ; valeur par défaut = 30)] qu'un fragment doit afficher, par rapport au seuil de binarisation, pour qu'il soit considéré comme pouvant être inclus dans un caractère.

Fermé Distance de fragment max. par rapport à la ligne principale

Définit la distance, en pixels (0 à 1 000 ; valeur par défaut = 0), à laquelle un fragment peut être supprimé de la ligne principale longeant le texte horizontalement.

Fermé Mode d'analyse de la segmentation

Définit le type de mode d'analyse des caractères à effectuer pour déterminer la segmentation optimale des caractères : Minimale ou Standard (valeur par défaut).

  • Minimal : effectue une segmentation simple, selon les paramètres de segmentation.
  • Standard : effectue une analyse de la ligne dans son ensemble, y compris l'espacement des caractères, pour déterminer la segmentation optimale.
Fermé Pas minimal

Définit le pas minimal, en pixels (0 à 1 000 ; valeur par défaut = 0), pouvant se produire entre deux caractères, le pas étant calculé selon le paramètre Position du pas de caractères. Si le pas entre deux fragments est inférieur à cette plage, ils doivent être considérés comme faisant partie du même caractère, à moins que le caractère combiné ne soit trop grand (tel que spécifié par les paramètres Largeur maximale des caractères et/ou Rapport des caractères minimal). Le pas se définit comme la distance entre les points correspondants (approximativement) de deux caractères adjacents, et non la distance entre la fin d'un caractère et le début du caractère suivant (appelé écart entre les caractères).

Fermé Position du pas de caractères

Définit la manière dont le pas entre les caractères sera mesuré : Automatique (valeur par défaut), Gauche -> gauche, Centre -> Centre ou Droite -> droite.

Remarque :
  • Si le paramètre Mode d'analyse de la segmentation est défini sur Minimal, il est désactivé.
  • Les termes « gauche » et « droite » sont relatifs à l'axe de coordonnées défini par la région, « droite » correspondant au sens des abscisses positives.
  • Automatique : indique qu'une unité métrique inconnue est utilisée ; le pas adéquat peut correspondre à n'importe laquelle des autres positions du pas, ou il n'existe pas de position constante du pas (comme ce peut être le cas avec une police de pas proportionnelle).
  • Gauche -> gauche : indique que le pas est mesuré comme la distance entre le côté gauche du rectangle de caractère d'un caractère et le côté gauche du rectangle de caractère du caractère suivant.
  • Centre à centre : indique que le pas est mesuré comme la distance entre le centre du rectangle de caractère d'un caractère et le centre du rectangle de caractère du caractère suivant.
  • Droite -> droite : indique que le pas est mesuré comme la distance entre le côté droit du rectangle de caractère d'un caractère et le côté droit du rectangle de caractère du caractère suivant.
Fermé Type de pas des caractères

Indique l'unité métrique utilisée pour définir l'espacement des caractères. Automatique (valeur par défaut), Fixe, Proportionnel ou Variable.

Remarque : Si le paramètre Mode d'analyse de la segmentation est défini sur Minimal, il est désactivé.
  • Automatique : indique que le type de pas est inconnu, mais que le type attendu est fixe ou proportionnel, et non variable.
  • Fixe : indique que le pas est fixe, ce qui signifie que le pas entre n'importe quelle paire de caractères est constant, indépendamment de la largeur du rectangle de caractère des caractères. Le pas est mesuré selon le paramètre Position du pas de caractères.

  • Proportionnel : indique que le pas est proportionnel, ce qui signifie que le pas entre n'importe quelle paire de caractères dépend des caractères spécifiques.

    Remarque :
    • Même si aucune mesure de pas n'est constante dans une chaîne, généralement l'écart entre les caractères, qui correspond à la distance entre le côté droit du rectangle de caractère d'un caractère et le côté gauche du rectangle de caractère du caractère suivant, est à peu près constante.
    • Les termes « gauche » et « droite » sont relatifs à l'axe de coordonnées défini par la région, « droite » correspondant au sens des abscisses positives.
  • Variable : indique qu'aucune unité métrique de distance entre caractères n'est cohérente dans une chaîne, autrement dit la position des caractères est irrégulière, et le pas n'est ni fixe, ni proportionnel.
Remarque : le pas variable diffère du pas automatique, puisqu'Automatique suppose que le pas est fixe ou proportionnel, mais cette donnée est inconnue.
Fermé Ignorer la validation supplémentaire des caractères

Indique si l'outil effectue ou non une validation supplémentaire des caractères pendant la classification (ce paramètre est désactivé par défaut). Lorsque ce paramètre est désactivé, l'outil effectue une validation supplémentaire des caractères pendant la classification ; ceci réduit le risque d'erreurs de lecture (par exemple, la fausse acceptation d'un caractère).

Fermé Graphique d'image de sortie

Définit le type d'image de sortie à afficher : Image d'entrée (valeur par défaut), Image normalisée ou Image binarisée.

  • Image d'entrée : l'image d'entrée active est affichée.
  • Image normalisée : la version normalisée de l'image est affichée.
  • Image binarisée : la version binarisée de l'image est affichée.


Outil d'identification Lire le texte (OCRMax) - Onglet Espaces

L'onglet Espaces est utilisé pour spécifier la manière dont l'outil tient compte des espaces entre les caractères, au besoin. L'outil d'identification Lire le texte (OCRMax) traite les écarts entre les caractères en les classant comme caractères d'espace, et ils sont définis par l'utilisateur.

Fermé Chercher les espaces

Définit comment l'outil traite l'insertion de caractères d'espace dans les écarts entre les autres caractères : Aucun (valeur par défaut), Insérer un seul espace ou Insérer plusieurs espaces.

  • Aucun : l'outil n'insère jamais de caractères d'espace, quelle que soit la taille de l'écart entre les caractères.
  • Insérer un seul espace : l'outil insère un seul caractère d'espace par écart entre les caractères, quelle que soit la taille de l'écart entre les caractères.
  • Insérer plusieurs espaces : l'outil insère un nombre x (zéro ou plus) de caractères d'espace par écart entre les caractères.
Fermé Mode de scores d'espaces

Définit comment la fonction calcule les scores pour les espaces : Score toujours égal à 100 (valeur par défaut) ou Score basé sur l'encombrement.

  • Score toujours égal à 100 : les caractères d'espace reçoivent toujours un score égal à 100.
  • Score basé sur l'encombrement : le score d'un caractère d'espace est basé sur la fraction de pixels constituant l'arrière-plan ; un caractère d'espace consistant entièrement en pixels d'arrière-plan reçoit un score de 100.
Fermé Largeur minimale d'un espace

Définit la largeur minimale d'un caractère d'espace, en pixels (0 à 1 000 ; valeur par défaut = 10).

Fermé Largeur maximale d'un espace

Définit la largeur maximale d'un caractère d'espace, en pixels (0 à 1 000 ; valeur par défaut = 100).


Outil d'identification Lire le texte (OCRMax) - Onglet Longueur variable

L'onglet Longueur variable est utilisé pour fournir des informations relatives aux caractères prévus aux différentes positions de la chaîne.

Remarque : ces paramètres sont uniquement utilisés lorsque les paramètres de l'onglet Recherche ciblée ont été activés et configurés.
Fermé Longueur de la chaîne

Indique si la recherche ciblée doit être exécutée en mode de longueur fixe (valeur par défaut) ou variable.

  • Variable : l'outil fonctionne en mode de longueur variable.
  • Fixe : l'outil fonctionne en mode de longueur fixe.
Fermé Longueur de chaîne maximale

Définit la longueur de chaîne maximale acceptable (0 à 100 ; valeur par défaut = 15).

Remarque : ce paramètre est désactivé si le paramètre Longueur de la chaîne est réglé sur Fixe.
Fermé Longueur de chaîne minimale

Définit la longueur de chaîne minimale acceptable (0 à 100 ; valeur par défaut = 5).

Remarque : ce paramètre est désactivé si le paramètre Longueur de la chaîne est réglé sur Fixe.
Fermé Index maximum du dernier caractère ciblé

Détermine les sous-séquences de recherche ciblée à prendre en compte, devant commencer à une position inférieure ou égale à cette valeur d'index (0 à 100 ; valeur par défaut = 100).

Remarque : ce paramètre est désactivé si le paramètre Longueur de la chaîne est réglé sur Fixe.
Fermé Index minimum du premier caractère ciblé

Détermine les sous-séquences de recherche ciblée à prendre en compte, devant se terminer à une position supérieure ou égale à cette valeur d'index (0 à 100 ; valeur par défaut = 0).

Remarque : ce paramètre est désactivé si le paramètre Longueur de la chaîne est réglé sur Fixe.


Outil d'identification Lire le texte (OCRMax) - Onglet Apprentissage

L'onglet Apprentissage est utilisé pour apprendre, afficher, renommer et supprimer les caractères. Cet onglet est divisé en deux groupes : Apprentissage, dans lequel les paramètres d'apprentissage des caractères sont définis, et Caractères, dans lequel les polices apprises sont gérées.

Remarque :
  • sous l'onglet Apprentissage, la région peut être ajustée et les graphiques de segmentation (rectangles de caractère) sont mis à jour lorsque la région est modifiée.
  • Les noms de caractère à plusieurs octets (par exemple, Kanji) ne sont pas pris en charge. Les caractères à plusieurs octets peuvent être appris, mais le nom donné au caractère doit être à un octet.
Fermé Contrôles d'apprentissage

Remarque : pour que les caractères puissent être appris, ils doivent être correctement segmentés.

  • Chaîne d'apprentissage : spécifie la chaîne de texte à apprendre. Le nombre de caractères de la zone de texte Chaîne d'apprentissage doit correspondre au nombre de caractères segmentés. 50 caractères maximum peuvent être appris.
  • Apprendre tous : spécifie que tous les caractères de la région seront appris. Les caractères à apprendre sont saisis dans la zone de texte Chaîne d'apprentissage, avant de cliquer sur le bouton Apprendre tous. Le nombre de caractères de la zone de texte Chaîne d'apprentissage doit correspondre au nombre de caractères segmentés.
  • Apprendre nouveaux : spécifie que seuls les caractères nouveaux de la région seront appris. Les caractères à apprendre sont saisis dans la zone de texte Chaîne d'apprentissage, avant de cliquer sur le bouton Apprendre nouveaux. Le nombre de caractères de la zone de texte Chaîne d'apprentissage doit correspondre au nombre de caractères segmentés.
  • Apprendre sélectionnés : spécifie que des caractères spécifiques de la région seront appris. Lorsque cette option est sélectionnée, la zone de texte Chaîne d'apprentissage est désactivée, et le bouton Apprendre sélectionnés entraîne l'affichage de la boîte de dialogue Ajouter les caractères sélectionnés à la police. Cette boîte de dialogue contient une image sans habillage de la région, ainsi qu'un nom et une zone de texte en dessous de chaque caractère segmenté. Le nom correspond au symbole actuellement associé au caractère (« ? » indique un caractère inconnu ou non appris). Une zone de texte est présente en dessous du nom. Saisissez le nom du caractère segmenté dans la zone de texte ; laissez le champ vide pour ne pas réapprendre le caractère. Cliquez sur le bouton Apprendre pour fermer la boîte de dialogue.
Fermé Contrôles de caractères

Après l'apprentissage, chaque caractère appris est visible dans l'arborescence, où il reçoit un dossier et un nom, et où les caractères sont regroupés (pour les caractères de même nom).

  • Sélectionnez le dossier racine de la police pour afficher tous les caractères de la police dans le panneau à droite. Les caractères apparaissent sous forme d'icônes avec un nom en dessous.
  • Sélectionnez un dossier de caractère pour afficher toutes les instances apprises de ce caractère dans le panneau à droite. Les caractères apparaissent sous forme d'icônes avec un nom en dessous.
  • Sélectionnez l'instance apprise d'un caractère pour afficher ce caractère, dont la taille est ajustée au panneau à droite.
Astuce : doter l'outil de plusieurs instances d'apprentissage de chaque caractère à lire pendant l'exécution permet à la fonction de mieux faire la distinction entre les types de caractère similaires. Néanmoins, l'apprentissage de plusieurs instances des mêmes caractères présente des avantages et des inconvénients. L'avantage de l'apprentissage de plusieurs instances est le fait que les performances de classification sont généralement meilleures, en particulier pour la lecture de texte risquant d'être mal classé (par exemple, 8 et B). Les inconvénients liés à l'apprentissage de plusieurs instances sont : une diminution du délai d'exécution de la fonction ; la diminution éventuelle des scores de confiance, étant donné que l'apprentissage de plusieurs instances entraîne l'amélioration non seulement du score le plus élevé, mais également du second plus élevé ; et l'apprentissage éventuel de caractères incorrects.
  • Importer : affiche la boîte de dialogue Ouvrir où une police, enregistrée comme fichier de données OCRMax (*.ocm), peut être importée.
  • Exporter : affiche la boîte de dialogue Enregistrer sous où une police peut être enregistrée comme fichier de données (*.ocm).
  • Renommer : cliquez sur ce bouton après avoir sélectionné un élément pour le renommer. Tout élément de l'arborescence ou du panneau de liste à droite peut être renommé.
Remarque : renommer un groupe de caractères modifie le nom de tous les caractères du groupe. Renommer un caractère unique modifie le nom de ce caractère unique sélectionné ; le caractère est déplacé vers un nouveau groupe ou un groupe différent de l'arborescence.
  • Supprimer : cliquez sur ce bouton après avoir sélectionné un élément pour le supprimer de la police. Tout élément de l'arborescence ou du panneau de liste à droite peut être renommé.
Remarque : la suppression du dossier de la police supprime la police ; tous les caractères sont supprimés. La suppression d'un groupe de caractères supprime tous les caractères dont le nom correspond au nom du groupe supprimé.


Outil d'identification Lire le texte (OCRMax) - Onglet Recherche ciblée

L'onglet Recherche ciblée offre un moyen graphique de créer et de modifier les paramètres Chaîne du champ et Définitions du champ de l'outil d'identification Lire le texte (OCRMax). Les résultats sont insérés dans l'outil comme chaînes littérales.

La fonction Recherche ciblée permet de vérifier et de corriger les chaînes, renvoyant les meilleures correspondances de chaînes valides. Cette fonction recouvre deux utilisations principales :

  • La vérification des résultats OCR, selon laquelle la chaîne renvoyée est déterminée comme étant correcte ou non selon les paramètres Chaîne du champ et Définitions du champ.
  • La correction des résultats OCR, selon laquelle la chaîne renvoyée ne figure pas sur la liste des résultats acceptables, et une tentative de recherche de chaîne acceptable autorisée par le champ le plus proche de la chaîne renvoyée est effectuée.

Une utilisation classique de la recherche ciblée est lorsque la chaîne contient des préfixes et/ou des suffixes, et que la recherche ciblée est utilisée pour ignorer ces préfixes/suffixes. Dans ce cas, les paramètres Chaîne du champ et Définitions du champ déterminent l'offset de la position de la chaîne dans la région.

Fermé Chaîne de recherche ciblée

Détermine le nombre de caractères contenus dans la chaîne de caractères. Une entrée Chaîne du champ peut être tout caractère alphanumérique inclus dans la boîte de dialogue de l'éditeur de texte, dont les caractères (A à Z), (a à z), (0 à 9), le tiret (-), les points (.) et les espaces ( ).

Chaque caractère de la Chaîne du champ correspond à une position de champ indexée entre 0 et 31. La Chaîne du champ doit compter au moins autant de positions qu'il y a de caractères dans la chaîne pour que la lecture réussisse (par exemple, si 10 caractères sont présents et que la Chaîne du champ ne spécifie que 9 caractères, les 9 meilleures correspondances sont renvoyées ; cependant, si 8 caractères sont présents et que la Chaîne du champ spécifie 9 caractères, la fonction renvoie #ERR). Par défaut, chaque position de la Chaîne du champ est représentée par un astérisque (*), c'est-à-dire un « caractère générique » alphanumérique. Ceci signifie que tout caractère est valide à toute position de la chaîne.

Cependant, une position particulière de la Chaîne du champ peut être limitée afin de ne prendre en compte qu'un sous-ensemble de caractères possibles à cette position. Cela permet d'augmenter les performances et la fiabilité de l'opération, car les caractères qui ne sont pas acceptables à une position ne seront pas pris en compte lors d'une lecture.

Les entrées de Chaîne du champ prédéfinies sont les suivantes :

Chaîne du champ Entrée | Description | Caractères valides
* | Caractère générique | Tout caractère appris dans la police.
N | Numérique | 0123456789
A | Alphabétique en majuscules | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | Alphabétique en minuscules | abcdefghijklmnopqrstuvwxyz
H | Hexadécimal, alphabétique en majuscules et numérique | 0123456789ABCDEF
h | Hexadécimal, alphabétique en minuscules et numérique | 0123456789abcdef
O | Octal | 01234567
Remarque :
  • Pour restreindre une position dans une Chaîne du champ afin de ne prendre en compte qu'un seul caractère, il suffit de saisir ce caractère. Celui-ci doit avoir été appris dans la police et ne peut pas être l'une des entrées de Chaîne du champ prédéfinies indiquées plus haut, sauf s'il a été remappé à l'aide du paramètre Définitions du champ.
  • Pour lire une chaîne contenant une espace, tapez l'espace dans la Chaîne du champ. ReadText ne lit pas une espace si l'entrée de Chaîne du champ correspondant à cette position est un astérisque (*).
Fermé Exemple 1 de chaîne du champ

Si la Chaîne du champ est **********AN, tous les caractères de la police sont valides dans les 10 premières positions de Chaîne du champ. À la onzième position, seuls les caractères alpha majuscules sont pris en compte lors de la lecture. À la douzième position, seuls des caractères numériques sont pris en considération.

Fermé Exemple 2 de chaîne du champ

La police ne compte que les caractères numériques 0-9 et le caractère /. Si la Chaîne du champ est NN/NN/NN, seuls les caractères numériques seront pris en compte aux première et deuxième, quatrième et cinquième, septième et huitième positions. Seule la barre oblique (/) sera prise en considération aux troisième et sixième positions.

Cependant, si la Chaîne du champ est NN/NN/AA, la lecture renvoie #ERR, car la police ne contient pas de caractères alpha.

Fermé Ignorer les caractères non ciblés

Indique s'il faut, à chaque position de caractère, restreindre les résultats pour qu'ils ne contiennent que les caractères spécifiés par la recherche ciblée. Lorsque ce paramètre est activé, tous les autres caractères de la police sont ignorés, indépendamment de leur score de classification.

Fermé Définitions du champ

Vous pouvez utiliser le paramètre Définition du champ afin de créer des entrées personnalisées pour la Chaîne du champ. Lorsqu'elles sont incluses dans la Chaîne du champ, ces entrées limitent la liste des caractères valides aux positions auxquelles elles sont insérées. Il existe plusieurs définitions du champ prédéfinies, et des définitions du champ définies par l'utilisateur peuvent être ajoutées. Les définitions prédéfinies apparaissent en gris et ne peuvent pas être supprimées ou modifiées, seulement activées ou désactivées. Les définitions définies par l'utilisateur apparaissent en noir et peuvent être ajoutées, supprimées ou modifiées. Pour ajouter une définition du champ, cliquez sur Ajouter nouvelle, affectez une icône et une définition au caractère.

Les caractères listés pour une entrée de Définitions du champ doivent être inclus dans la police. Par exemple : #=123 est valide si 1, 2 et 3 se trouvent dans la police apprise par l'utilisateur. Cependant, #=123 est incorrect si 1, 2 et 3 ne font pas partie de la police.

Remarque : l'utilisation de l'une des entrées prédéfinies (*, A, a, N, H, h, O) dans le paramètre Définition du champ remappe la liste de caractères valides dans la nouvelle définition.
Fermé Exemple 1 de définitions du champ

Si la valeur de Définitions du champ est #=123;$=3456;%=789, et que celle de Chaîne du champ est #$%*******, les seuls caractères valides en première position seront 1, 2 ou 3. Les seuls caractères valides en deuxième position seront 3, 4, 5 ou 6. En troisième position, seuls 7, 8 ou 9 seront valides. Tous les caractères de la police sont valides de la quatrième à la dixième position.

Fermé Exemple 2 de définitions du champ

Si la valeur de Définitions du champ est #=123;$=3456;%=789, A=A et que celle de Chaîne du champ est #$%******A, les seuls caractères valides en première position seront 1, 2 ou 3. Les seuls caractères valides en deuxième position seront 3, 4, 5 ou 6. En troisième position, seuls 7, 8 ou 9 seront valides. Tous les caractères de la police sont valides de la quatrième à la neuvième position. Seul le caractère A sera pris en compte à la dixième position, car la Définition du champ A=A remappe l'entré Chaîne du champ prédéfinie.


Outil d'identification Lire le texte (OCRMax) - Onglet Diagnostics

L'onglet Diagnostics affiche les informations sur la façon dont l'outil Lire le texte (OCRMax) segmente les caractères dans la région. Ces données peuvent être utiles dans la définition des paramètres à régler, et de leur nombre, si les caractères et/ou les fragments de caractères ne sont pas correctement segmentés. Utilisez cet onglet avec le paramètre Afficher les diagnostics pour un affichage graphique des données de diagnostic.

Fermé Angle de la ligne principale

Affiche la mesure d'orientation angulaire des régions de caractères, par rapport à la région, en degrés.

Fermé Inclinaison des caractères

Affiche la mesure d'inclinaison angulaire des régions de caractères, par rapport à la région, en degrés.

Fermé Écart entre caractères

Affiche les mesures maximale et minimale de l'écart entre les caractères, en pixels.

Fermé Écart intra caractères

Affiche les mesures maximale et minimale de l'écart dans le caractère, en pixels.

Fermé Pas d’un caractère

Affiche les mesures maximale et minimale de pas des caractères, en pixels.

Fermé Taille de fragment acceptée

Affiche les mesures maximale et minimale de la taille des fragments acceptés, en pixels.

Fermé Contraste de fragment accepté

Affiche les mesures maximale et minimale de contraste des fragments acceptés, en pourcentage.

Fermé Distance de fragment acceptée par rapport à la ligne principale (%)

Affiche la distance Y maximale de tous les fragments acceptés, en pourcentage de la hauteur de la ligne principale.

Fermé Taille de fragment rejetée

Affiche les mesures maximale et minimale de la taille des fragments rejetés, en pixels.

Fermé Contraste de fragment rejeté

Affiche les mesures maximale et minimale de contraste des fragments rejetés, en pourcentage.

Fermé Distance de fragment rejetée par rapport à la ligne principale (%)

Affiche la distance Y maximale de tous les fragments rejetés, en pourcentage de la hauteur de la ligne principale.

Fermé Largeur de caractère acceptée

Affiche les mesures maximale et minimale de la largeur des caractères acceptés, en pixels.

Fermé Hauteur de caractère acceptée

Affiche les mesures maximale et minimale de la hauteur des caractères acceptés, en pixels.

Fermé Taille de caractère acceptée

Affiche les mesures maximale et minimale de la taille des caractères acceptés, en pixels.

Fermé Largeur de caractère rejetée

Affiche les mesures maximale et minimale de la largeur des caractères rejetés, en pixels.

Remarque : si aucun caractère n'est rejeté, #ERR est affiché.
Fermé Hauteur de caractère rejetée

Affiche les mesures maximale et minimale de la hauteur des caractères rejetés, en pixels.

Remarque : si aucun caractère n'est rejeté, #ERR est affiché.
Fermé Taille de caractère rejetée

Affiche les mesures maximale et minimale de la taille des caractères rejetés, en pixels.

Remarque : si aucun caractère n'est rejeté, #ERR est affiché.


Outil d'identification Lire le texte (OCRMax) - Onglet Résultats

Fermé Caractère

Affiche le caractère lu à cette position.

Fermé État

Affiche l'état (Mal lu, Bien lu, Ignoré, Confus, Disparité, Disparité confuse, Non lu ou Échec de validation) du caractère lu.

  • Mal lu : Aucun caractère n'a un score assez élevé au-dessus du seuil d'acceptation pour être considéré comme bien lu.
  • Bien lu : L'outil a correctement lu le caractère à cette position.
  • Ignoré : Quand la recherche ciblée est activée, si une chaîne de recherche ciblée est spécifiée et qu'elle est plus courte que la chaîne lue par la fonction, les caractères de début ou de fin de la chaîne sont segmentés (en jaune), mais ne sont pas inclus dans le résultat global. Par exemple, si la définition de recherche ciblée est ABC et que la chaîne lue par la fonction est « 12ABC34 », « 1234 » est ignoré.
  • Confus : L'outil a identifié un caractère dont le score est assez élevé pour être considéré comme bien lu (supérieur à la valeur du paramètre Seuil d'acceptation), cependant, un caractère différent a un score assez proche du même score (dans la valeur du paramètre Seuil de confusion), de sorte que l'outil n'est pas sûr d'avoir relevé le bon caractère [Confus = (Score primaire - Score secondaire)/Seuil de confiance].
  • Disparité : L'outil a trouvé un caractère qui ne correspond pas à la recherche ciblée, mais dont le score est nettement supérieur à tous les autres caractères qui ne correspondent pas à la recherche ciblée. Il est possible qu'un caractère qui ne correspond pas à la recherche ciblée ait été imprimé à cette position. La recherche ciblée doit être activée pour renvoyer cet état.
  • Disparité confuse : La fonction a trouvé un caractère qui répond à la fois aux conditions de Confus et Disparité.
  • Échec de validation : Si le paramètre Ignorer la validation supplémentaire de caractères est désactivé, la fonction décompose les caractères lors d'une étape de validation supplémentaire pour garantir que la fonction ne produise pas de fausses lectures.
Fermé Score

Affiche un score qui mesure le niveau de correspondance du caractère lu par rapport au caractère appris dans la base de données de polices.

Fermé Confusion

Affiche le caractère suivant correspondant le mieux.

Fermé Score de confusion

Affiche une mesure du niveau de certitude de la fonction par rapport à la correspondance choisie, en la comparant avec la meilleure correspondance suivante.


Outils d'identification - Lire le texte

L'outil d'identification Lire le texte sert à lire et/ou vérifier les chaînes de texte alpha-numériques à l'aide de modèles de caractères appris.

Remarque : Dans In-Sight Explorer 4.7.0 et versions ultérieures, l'outil d'identification Lire le texte est disponible uniquement sur les systèmes de vision In-Sight qui ne prennent pas en charge OCRMax, il n'est pas disponible sur les systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.1.0 et ultérieures.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil d'identification Lire le texte

Une fois l'outil ajouté, sélectionnez le type de région et configurez cette dernière dans l'image :

  1. Positionnez la région sur le texte, en vous assurant qu'elle l'englobe complètement (pour plus d'informations, reportez-vous à la rubrique Sélection du texte à lire). Pour accroître la rapidité de l'outil, créez des régions de petite taille. Plus la région est grande, plus l'outil mettra de temps à effectuer l'inspection.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Une fois la région acceptée, définissez le mode de fonctionnement (Lire, Vérifier ou Lire et vérifier), choisissez le type de police (OCR-A Noir sur Blanc, OCR-A Blanc sur Noir, OCR-B Noir sur Blanc, OCR-B Blanc sur Noir ou Personnalisée) et indiquez le nombre de caractères dans la Chaîne du champ ou Chaîne de correspondance sous l'onglet Paramètres, selon le mode.
    • Si vous avez sélectionné le mode de fonctionnement Lire et une police OCR-A ou OCR-B, il vous suffit d'indiquer le nombre de caractères dans la Chaîne du champ, puis de cliquer sur le bouton Mettre au point pour définir l'échelle correcte.

    • Si vous avez sélectionné le mode de fonctionnement Vérifier ou Lire et vérifier et une police OCR-A ou OCR-B, indiquez le nombre de caractères dans la Chaîne de correspondance, puis cliquez sur le bouton Mettre au point pour définir l'échelle correcte.

      Remarque : si vous utilisez des polices OCR-A ou OCR-B, la hauteur des caractères dans l'image doit être comprise entre 15 et 60 pixels. Cliquez sur le bouton Mettre au point pour mettre les caractères à l'échelle correcte. Si la taille des caractères est inférieure à 15 pixels ou supérieure à 60 pixels, vous devez créer une police personnalisée.
    • Si vous avez sélectionné le type de police Personnalisée, cliquez sur le bouton Apprendre la police pour créer une bibliothèque de polices. Une fois la bibliothèque de polices créée, définissez le mode de fonctionnement et indiquez le nombre de caractères dans la Chaîne du champ (paramètre du Mode de lecture) ou dans la Chaîne de correspondance (modes Vérifier ou Lire et vérifier).
    • Un projet unique peut comprendre jusqu'à quatre polices personnalisées (par exemple, « Personnalisée_1 », « Personnalisée_2 », « Personnalisée_3 » et « Personnalisée_4 »), et une police apprise peut être partagée entre différents outils d'identification de lecture de texte lorsque plusieurs polices personnalisées sont ajoutées au projet.
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Création d’une police personnalisée

Sélection du texte à lire


Création d'une police personnalisée

  1. Pour définir une police personnalisée, cliquez sur le bouton Apprendre la police de l'onglet Paramètres. Cela ouvre la boîte de dialogue Apprendre la police, qui vous permet de configurer le texte pour votre application.

    Remarque : un projet unique peut comprendre jusqu'à quatre polices personnalisées (par exemple, « Personnalisée_1 », « Personnalisée_2 », « Personnalisée_3 » et « Personnalisée_4 »).
  2. Sur l'onglet Apprentissage, entrez un nom personnalisé pour la police, si nécessaire (particulièrement utile si vous pensez créer plusieurs bibliothèques de polices).

  3. Définissez la polarité des caractères : si les caractères à apprendre sont plus clairs que leur arrière-plan, sélectionnez Clair sur foncé. Sinon, sélectionnez Foncé sur clair.

    Remarque : assurez-vous de définir la polarité correcte avant de cliquer sur Ajouter à la police. Vous ne pourrez plus modifier la polarité une fois que les modèles de caractères auront été ajoutés à la police.
  4. Entrez la chaîne de texte souhaitée. Vérifiez que la casse de la chaîne de texte attendue correspond à celle des caractères du modèle (majuscules et minuscules) et ajoutez des espaces à la chaîne attendue si le modèle comprend des espaces.
  5. Une fois la chaîne de texte entrée, cliquez sur le bouton Segment. Vérifiez que chaque caractère comporte une région et un identifiant individuels. Si ce n'est pas le cas, effectuez les opérations suivantes dans la zone Ajustements des segments :
    • Cliquez sur le bouton Modifier pour ajuster la région autour d'une instance de caractère spécifique.
    • Cliquez sur le bouton Renommer pour attribuer un nouveau nom à l'instance de caractère.
    • Cliquez sur le bouton Supprimer pour supprimer une instance de caractère.
  6. Si l'identification des caractères vous convient, cliquez sur le bouton Ajouter à la police. Votre police doit maintenant contenir les instances de chaque caractère identifié à partir de la chaîne souhaitée.
  7. Votre police contient maintenant plusieurs modèles de caractères, qui peuvent eux-mêmes contenir plusieurs instances. Tous les caractères, espaces et ponctuation compris, sont segmentés et affectés à des modèles de caractères.

  8. Vous pouvez alors parcourir vos modèles de caractères et ajouter, supprimer, modifier et renommer ou activer/désactiver un modèle ou une instance de caractère spécifique.

    Remarque : une police apprise peut être partagée entre différents outils d'identification de lecture de texte lorsque plusieurs polices personnalisées sont ajoutées au projet.
  9. Lorsque votre police apprise vous convient, cliquez sur le bouton OK.


Sélection du texte à lire

Les instructions et conseils suivants visent à vous aider à obtenir des résultats cohérents :

Fermé Polices
  • Utilisez les polices spéciales conçues pour les applications OCR/OCV.
  • Assurez-vous que la largeur de segment des caractères est d'au moins 5 pixels, le but étant que les caractères remplissent le plus possible l'image. Plus les caractères comprennent de pixels, plus l'outil est précis. L'exécution prendra toutefois légèrement plus de temps.
  • Si l'image comprend plusieurs types de polices, utilisez un outil d'identification Lire le texte distinct pour chaque type.
  • Si l'image comprend des polices de taille différente, utilisez un outil d'identification Lire le texte distinct pour chaque taille.
Fermé Polices OCR/OCV spécifiques

Fermé Modèles de caractères et instances
  • Pour créer des modèles de caractères clairs et distincts, utilisez des caractères avec une résolution élevée.
  • L'outil d'identification Lire le texte prend en charge jusqu'à 255 modèles de caractères, et chaque modèle de caractère peut comprendre jusqu'à 8 instances apprises de ce modèle de caractère. L'apprentissage d'instances supplémentaires d'un modèle de caractère augmente la tolérance de l'outil aux variations dans le modèle de caractère. Si votre application ne tolère pas beaucoup de variation, apprenez vos modèles de caractères sur un seul bon exemple. Si votre application doit tolérer les variations, apprenez le modèle de caractère sur le nombre d'instances le plus élevé possible.
  • Lors des instances d'apprentissage d'un modèle de caractère, assurez-vous que l'impression des caractères est la plus cohérente possible. Des changements de forme et de taille de caractère importants créent des modèles de caractères médiocres et entraînent des défaillances lors de l'exécution.
Fermé Exemples d'instances d'apprentissage

Instances d'apprentissage correctes d'un modèle de caractère.

Instances d'apprentissage incorrectes d'un modèle de caractère.


Réglage des paramètres de l'outil d'identification Lire le texte

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil d'identification Lire le texte comprend trois onglets :

  • Onglet Général
  • Onglet Paramètres
  • Tableau de modèles de caractères
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Tableau de modèles de caractères


Outil d'identification Lire le texte - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Texte_1 » s'il s'agit du premier outil d'identification Lire le texte ajouté au projet. Sinon, il est incrémenté (par exemple, « Texte_2 », « Texte_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil d'identification Lire le texte - Onglet Paramètres

Fermé Bouton Apprendre la police

Ouvre la boîte de dialogue Apprendre la police, qui vous permet de définir et de modifier vos polices (les modèles de caractères et leurs instances).

Fermé Mode

Définit le mode de fonctionnement de l'outil : Lire, Vérifier ou Lire et vérifier.

  • Lire : l'outil décode la chaîne de texte en se basant sur les modèles de caractères appris. La chaîne de texte décodée doit correspondre au nombre de caractères défini dans le champ Chaîne du champ.
  • Vérifier : l'outil décode la chaîne de texte en se basant sur celle qui a été définie dans le champ Chaîne de correspondance.
  • Lire et vérifier : l'outil décode la chaîne de texte et la compare à la chaîne qui a été définie dans le champ Chaîne de correspondance. La chaîne de texte décodée doit correspondre à la chaîne définie dans le champ Chaîne de correspondance pour pouvoir être classée comme Succès.
Remarque : l'outil peut avoir deux états : Succès ou Échec. Lorsque le contrôle Mode de l'outil est défini sur Vérifier ou sur Lire et vérifier, l'outil renvoie un échec dans deux types de situations : en cas d'échec de la lecture, ou lorsque la lecture a réussi mais ne correspond pas à la chaîne de texte entrée dans le champ Chaîne de correspondance.

Dans ce dernier cas, lorsque que le mode Lire et vérifier est sélectionné, l'outil affiche les données de non correspondance (Non correspondance et Nombre de non correspondances) qui peuvent être utilisées par EasyView et d'autres périphériques de communication dans l'étape d'application Communication. Les données de non correspondance peuvent être sélectionnées dans les boîtes de dialogue Sélectionner des éléments EasyView, Sélectionner les balises OPC ou Sélectionner les données d'entrée/de sortie.

Les données de non correspondance s'avèrent utiles lorsque l'utilisateur doit déterminer si l'outil ne peut pas lire le texte ou si le texte peut être lu mais ne correspond pas à la Chaîne de correspondance spécifiée. Ainsi, quand l'outil ne peut pas lire le texte, cela peut indiquer un problème du processus d'impression du texte ou de configuration du système de vision. Lorsque le texte peut être lu mais ne correspond pas à la Chaîne de correspondance spécifiée, le mauvais texte risque d'être imprimé.
Fermé Police

Définit le type de la police. Vous pouvez sélectionner un type de police prédéfini (OCR-A ou OCR-B, Noir sur Blanc ou Blanc sur Noir) ou créer une police personnalisée en apprenant des modèles de caractères.

Remarque : un projet unique peut comprendre jusqu'à quatre polices personnalisées (par exemple, « Custom_1 », « Custom_2 », « Custom_3 » et « Custom_4 »).
Fermé Chaîne du champ

Définit le nombre de caractères contenus dans la chaîne de texte pour une opération Lire. Chaque caractère de la Chaîne du champ correspond à une position indexée entre 0 et 31 (nombre maximum de caractères). Le nombre de positions dans une chaîne de champ doit être égal au nombre de caractères dans la chaîne de texte.

Une entrée de chaîne de champ peut inclure du texte en majuscules ou en minuscules, des nombres, des tirets, des points et des espaces. Par défaut, chaque position de la chaîne du champ est représentée par un * (caractère générique alphanumérique), qui peut représenter n'importe quel caractère à cette position de la chaîne de texte.

Vous pouvez définir des positions individuelles dans la chaîne du champ de façon à ce que l'outil ne prenne en compte qu'un sous-ensemble de caractères possibles à cette position et soit encore plus performant et fiable.

Entrée Chaîne du champ | Description | Caractères valides
* | Caractère générique | Tout caractère appris dans la police.
N | Numérique | 0123456789
A | Alphabétique en majuscules | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | Alphabétique en minuscules | abcdefghijklmnopqrstuvwxyz
H | Hexadécimal, alphabétique en majuscules et numérique | 0123456789ABCDEF
h | Hexadécimal, alphabétique en minuscules et numérique | 0123456789abcdef
O | Octal | 01234567
Fermé Chaîne de correspondance

Définit la chaîne attendue à lire (cette option est activée uniquement lorsque le paramètre Mode est défini sur Vérifier ou Lire et vérifier). Entrez les informations que vous souhaitez que l'outil décode.

Remarque : vous pouvez entrer la chaîne de correspondance à partir d'un autre périphérique. Lorsque vous exécutez le projet, l'outil d'identification peut lire la chaîne de texte à partir du périphérique sur lequel vous l'avez entrée et la comparer au texte reconnu. L'outil Lire le texte génère le résultat Échec et le champ Chaîne de correspondance affiche TRIG jusqu'à ce que la chaîne de correspondance soit entrée à partir du périphérique externe.
Fermé Bouton Mettre au point

Calcule la différence d'échelle (50 à 200 %) entre les modèles de caractères appris de la bibliothèque de polices et les caractères dans l'image. Le bouton Mettre au point ne peut être utilisé que lorsque la différence entre la taille des modèles de caractères et les caractères de la chaîne de texte est supérieure à ±5 %.

Fermé Seuil d'acceptation

Définit le score minimal acceptable (0 à 100 ; valeur par défaut = 70) pour chaque caractère dans la chaîne de texte. Si un caractère de la chaîne de texte est en dessous du seuil d'acceptation, cela résulte en un échec pour toute la chaîne de texte.

Fermé Mode de lecture

Définit le mode de l'algorithme de lecture du texte : Vitesse ou Précision. Le mode Vitesse (mode de lecture par défaut) est plus efficace avec les images de bonne qualité et très contrastées qui requièrent une exécution d'outil très rapide. Le mode Précision se prête davantage aux images plus difficiles et peu contrastées qui ne nécessitent pas que l'outil s'exécute rapidement.

Fermé Différence autorisée

Définit la différence minimale acceptable entre les deux premiers scores les plus élevés d'un caractère (0 à 20 ; valeur par défaut = 0). Si une différence de scores est inférieure ou égale à la différence autorisée, cela résulte en un échec pour toute la chaîne de texte.

Fermé Arrière-plan pouvant prêter à confusion

Compense les conditions dans lesquelles d'autres caractéristiques de l'image sont confondues avec la chaîne de texte (option désactivée par défaut). Lorsque l'option Arrière-plan pouvant prêter à confusion est activée, la durée d'exécution de l'outil augmente légèrement. Cette option s'avère particulièrement utile lorsque d'autres caractéristiques de la région sont prises par erreur pour le début de la chaîne de texte.

Fermé Tolérance en échelle

Permet des variations de l'échelle des caractères (option désactivée par défaut).

Fermé Délai d'attente

Définit la durée, en millisecondes (0 à 30 000), pendant laquelle l'outil recherche le texte avant que l'exécution ne soit interrompue et que l'outil ne renvoie un échec.

Fermé Résultat

Affiche les informations décodées ou vérifiées de la chaîne de texte.


Outil d'identification Lire le texte - Tableau de modèles de caractères

Fermé Index

Indique la position du caractère dans la chaîne de texte.

Fermé Caractère

Affiche le caractère du modèle avec le score le plus élevé (c.-à-d. le caractère du modèle le plus proche du caractère de la chaîne de texte).

Fermé Score

Indique le niveau de confiance du caractère du modèle avec le score le plus élevé. Si la valeur renvoyée est inférieure ou égale à la valeur du seuil d'acceptation, cela résulte en un échec pour toute la chaîne de texte.

Fermé Accepté

Indique si le caractère est accepté ou a échoué, selon que les valeurs des colonnes Score et Différence de caractères sont inférieures ou égales (Échec), ou supérieures (Succès) aux paramètres Seuil d'acceptation et Différence autorisée, respectivement.

Fermé 2ème caractère

Affiche le caractère du modèle avec le second score le plus élevé (c.-à-d. le second caractère du modèle le plus proche du caractère de la chaîne de texte).

Fermé 2ème score

Indique le niveau de confiance du caractère du modèle avec le second score le plus élevé.

Fermé Différence de caractères

Affiche la différence entre les deux premiers scores les plus élevés. Si la valeur renvoyée est inférieure ou égale au paramètre Différence autorisée, cela résulte en un échec pour toute la chaîne de texte.


Outils d'identification - Modèles PatMax RedLine (1-10) et modèles PatMax (1-10)

Remarque :
  • À partir du micrologiciel In-Sight firmware 5.5.0 et versions ultérieures, l'algorithme de l'outil a été modifié afin de renvoyer des résultats plus précis et de réduire la durée d'exécution dans certains cas.
  • En raison de cette modification, un message d'erreur s'affiche lors d'une tentative de chargement d'un projet contenant cet outil configuré selon le micrologiciel In-Sight version 5.5.0 ou ultérieure sur un système de vision In-Sight exécutant le micrologiciel In-Sight version 5.4.x ou antérieure.
  • L'outil d'identification de modèles PatMax RedLine est uniquement disponible sur des systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.2.0 et ultérieures.

Les outils d'identification de modèles PatMax RedLine et PatMax sont utilisés pour apprendre les occurrences de caractéristiques de modèle, à l'aide des algorithmes PatMax RedLine ou PatMax, puis vérifier ou identifier l'occurrence spécifique des caractéristiques de modèle dans l'image.

Ces outils sont utiles, par exemple dans des applications où vous souhaitez vérifier que le bon produit est exécuté sur la ligne de production en fonction d'un logo, d'un nom ou d'une pièce, ou pour reconnaître le produit exécuté et communiquer cette information aux autres périphériques d'usine.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration des outils d'identification de modèles PatMax RedLine (1-10) et de modèles PatMax (1-10)

Après avoir ajouté l'outil, sélectionnez le type des régions et configurer ces dernières pour définir votre modèle (la région Modèle) et l'emplacement du modèle dans l'image (la région Recherche).

Les outils d'identification de modèles PatMax RedLine (1-10) et de modèles PatMax 1-10) permettent de créer une bibliothèque de 10 modèles différents de forme au maximum. Chaque modèle de forme doit être appris en utilisant une image distincte. L'outil recherche les instances individuelles des modèles appris dans l'image et ne reconnaît pas les instances multiples d'un modèle dans l'image.

  1. Dans le menu déroulant Modèle, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Placez ensuite la région de Modèle sur le modèle utilisé comme modèle d'apprentissage ; assurez-vous que la région de Modèle ne couvre que les caractéristiques importantes du modèle.Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.

  2. Dans le menu déroulant Recherche, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Puis positionnez la région Recherche de manière à ce qu'elle recouvre les zones de l'image dans lesquelles la forme peut apparaître. Pour optimiser l'exécution de l'outil, créez des régions Recherche de petite taille. Plus la région Recherche est étendue, plus l'outil mettra de temps à effectuer l'inspection.

  3. Cliquez sur le bouton OK pour confirmer les régions (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet). La région Modèle est alors remplacée par un contour vert du modèle appris.

  4. Pour définir un autre modèle de forme, chargez ou acquérez une nouvelle image avec un nouveau modèle, sélectionnez un modèle non appris dans la Table (marquée "Non appris" dans la colonne Appris), appuyez sur le bouton Région du modèle et répétez les étapes 1 à 3.
  5. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  6. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Sélection d’un modèle

Modèle PatMax RedLine, modèle PatMax et modèle


Modèle PatMax RedLine, modèle PatMax et modèle

Remarque : L'outil d'identification de modèles PatMax RedLine est uniquement disponible sur des systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.2.0 et ultérieures.

Les modèles PatMax RedLine, les modèles PatMax et les modèles localisent des modèles de forme appris et proposent la plus grande précision parmi les outils de recherche et d'inspection. Cependant les modèles de PatMax RedLine et les modèles de PatMax sont plus performants que les modèles, modifiant considérablement les conditions d'éclairage et la position du modèle. Ils permettent également de mieux reconnaître les modifications apportées à l'échelle et à la rotation du modèle, l'occlusion des éléments du modèle et les modifications apportées à l'apparence du modèle, en raison des variations d'éclairage.

La vitesse constitue la principale différence entre les modèles PatMax RedLine et les modèles PatMax ; le modèle PatMax RedLine utilise le modèle le plus récent correspondant à l'algorithme et permet de localiser des caractéristiques apprises dans une image mégapixel 5, 7 fois plus rapidement que les modèles PatMax. Les modèles PatMax RedLine conviennent donc pour des systèmes de vision de haute résolution.

Les modèles (dans la plupart des cas) sont plus rapides que PatMax, mais certains cas nécessitent la précision et la fiabilité de la version PatMax RedLine ou PatMax :

  • Lorsque les variations d'éclairage et de reflets sont difficiles à contrôler. Par exemple, des pièces en métal peuvent réfléchir la lumière dans des directions aléatoires.
  • Lorsque le modèle inspecté présente une forme ou une ombre similaire par rapport à un élément en arrière-plan, ou le modèle est superposé ou partiellement caché par d'autres objets dans l'image.
  • Lorsque vous souhaitez reconnaître avec précision un type de modèle parmi d'autres modèles, des modèles identiques.
  • Lorsque les conditions de votre environnement de déploiement sont trop exigeantes pour l'outil Modèle, en termes de cohérence et de fiabilité.


Réglages des paramètres des outils d'identification de modèles PatMax RedLine (1-10) et de modèles PatMax (1-10)

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres des outils d'identification de modèles PatMax RedLine (1-10) et de modèles PatMax (1-10) comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglets Modèle et Recherche
  • Onglet Tableau
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglets Modèle et Recherche

Onglet Tableau


Outil d'identification de modèles PatMax RedLine (1-10) et de modèles PatMax (1-10) - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « IDProduit_1 » (s'il s'agit du premier outil d'identification de modèles PatMax ajouté au projet. Sinon, il est incrémenté par exemple, « IDProduit_2 », « IDProduit_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Modèles PatMax RedLine (1-10) et modèles PatMax (1-10) Outils d'identification – Onglet Paramètres

Fermé Mode

Permet de définir le mode opérationnel de l’outil : Identifier ou Vérifier.

Identifier (le mode par défaut) est utilisé lorsque le modèle en cours d’inspection est inconnu. L’outil examine automatiquement l’image (sur la base de vos régions) et détermine le modèle, sélectionné dans la bibliothèque d’apprentissage des modèles, qui s’affiche puis rapporte ces informations dans le paramètre Résultat.

Vérifier est utilisé pour vérifier si le modèle correct est présent. L’outil examine l’image pour un modèle spécifié puis compare le modèle trouvé au modèle spécifié dans le paramètre Modèle.

Fermé Modèle

Permet de définir le modèle appris à vérifier (pour activer ce paramètre, le Mode doit être défini sur Vérifier). Choisissez ce modèle parmi ceux que vous avez appris.

Fermé Seuil d'acceptation

Définit le degré de similitude qui doit exister entre le modèle de forme et le modèle localisé (0 à 100 ; valeur par défaut = 65). Les modèles localisés affichant une valeur supérieure ou égale au seuil défini sont considérés comme correspondants. Cet outil s'exécute plus rapidement lorsque ce paramètre est élevé, ce qui requiert également un degré de similitude plus important entre le modèle de forme et le modèle localisé. Moins les paramètres sont élevés, moins les résultats seront précis. Des modèles semblables seront détectés, mais pas par rapport au modèle de forme.

Fermé Seuil de contraste

Définit le contraste minimum acceptable qui doit être défini dans le modèle identifié ; le contraste pour un modèle identifié doit être supérieur à la valeur Seuil de contraste à considérer comme une instance valide. La valeur par défaut pour le(s) modèle(s) PatMax RedLine est 0 et la plage valide de paramètres est 0-100. La valeur par défaut pour le(s) modèle(s) PatMax est 10 et la plage valide de paramètres est 0-255. Une faible valeur Seuil de contraste est utilisée pour des images peu contrastées, alors qu'une valeur élevée Seuil de contraste est utilisée pour des images extrêmement contrastées.

Remarque : Le contraste de modèle(s) PatMax RedLine désigne la mesure « relative » d'une modification de contraste entre les caractéristiques du modèle appris et les caractéristiques de correspondance de l'image de recherche, en pourcentage. Ainsi si le contraste de caractéristique est supérieur ou égal au contraste de modèle, le contraste rapporté sera ~100. Si le contraste de caractéristique est inférieur au contraste de modèle, le contraste rapporté sera <100. Le contraste de modèle(s) PatMax RedLine est différent du contraste de modèle(s) PatMax qui représente le contraste d'image « absolu » de la région d'intérêt de recherche, en niveau de gris
Fermé Tolérance angulaire

Définit dans quelle mesure le modèle localisé peut pivoter par rapport à la position du modèle de forme, tout en étant identifié comme un modèle valide (± 0 à 180° ; valeur par défaut = 15°). Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps.

Fermé Tolérance en échelle

Définit le pourcentage autorisé de mise à l'échelle (variations de taille) entre le modèle identifié et le modèle de forme (0-50 ; par défaut = 0). La valeur représente un pourcentage plus ou moins, par exemple une valeur 5 déclenchera l'outil de recherche de modèles dont la taille est comprise entre 95 % et 105% du modèle de forme. Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps.

Fermé Différence autorisée

Définit la différence acceptable, en matière de score, qui peut exister entre le modèle trouvé et l’un des modèles appris de Modèle (0 à 20 ; valeur par défaut = 0). Différence de score entre deux modèles quelconques de la liste des Modèles appris, par ex. une valeur de 5 permet de s’assurer que l’outil trouve les modèles dont le score est au moins supérieur de 5 au score de n’importe quel Modèle.

Fermé Mode de recherche

Définit le mode de recherche utilisé pour les modèles d'apprentissage et de reconnaissance, PatMax ou PatQuick. L'option PatMax est sélectionnée par défaut. PatMax propose une plus grande précision que PatQuick mais nécessite un temps d'exécution plus long alors que PatQuick propose une plus faible précision que PatMax mais nécessite un temps d'exécution moins long.

Fermé Scores stricts

Définit si des caractéristiques manquantes ou cachées du modèle trouvé affecteront le score (par défaut = Off, décoché). Lorsque Score strict est appliqué (Activé, coché), si les caractéristiques du modèle sont absentes ou bloquées, le score du modèle trouvé sera plus faible.

Fermé Délai d'attente
Définit la durée, en millisecondes (0 à 30 000), pendant laquelle l'outil recherche le(s) modèle(s) avant que l'exécution ne soit interrompue et que l'outil ne renvoie un échec. Par défaut, ce paramètre est réglé sur 1 000.
Fermé Résultat

Affiche le nom du modèle identifié.

Remarque : Le(s) modèle(s) PatMax RedLine ne contient/contiennent pas le paramètre Mode de recherche.


Outils d'identification de modèles PatMax RedLine (1-10) et de modèles PatMax (1-10) - Onglets Modèle et Recherche

Les onglets Modèle et Recherche sont utilisés pour configurer la région composite pour les régions Modèle et Recherche de l'outil. Les régions composite sont un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Dans l'onglet Modèle, les régions composite sont activées uniquement après avoir cliqué sur le bouton Région modèle.
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils d'identification de modèles PatMax RedLine (1-10) et de modèles PatMax (1-10) - Onglet Tableau

L'onglet Tableau contient le tableau de modèles appris ainsi que des miniatures des modèles appris.

Fermé Onglet Tableau

Nom : Cette zone définit le nom du modèle appris. Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Appris : Cette zone indique si un modèle a été appris. La zone renvoie « Appris » si le modèle a été appris et « Non appris » s'il n'a pas été appris.

Score: Cette zone renvoie le score du modèle appris trouvé.

Remarque :
  • Pour supprimer un modèle de l'outil, cliquez avec le bouton droit sur le modèle sur l'onglet Tableau et sélectionnez l'option Supprimer du menu.
  • Le volet de paramètres Tableau comprend trois options d'affichage : Grandes icônes, Détails (valeur par défaut) et Mosaïque. Pour changer l'option d'affichage sélectionnée sur le volet de paramètres, cliquez avec le bouton droit sur le volet Tableau et sélectionnez l'option voulue dans le sous-menu Affichage.
Fermé Bouton Région du modèle

Ce bouton initialise l'apprentissage de modèles.

Fermé Bouton Renommer

Sélectionnez un modèle appris dans la table puis cliquez sur ce bouton pour renommer le modèle par un nom associé à votre application spécifique.

Fermé Miniature apprise

L'image affichée sous le bouton Région du modèle est une miniature du modèle de forme. Cliquez sur le bouton Région du modèle pour redimensionner ou déplacer la région du modèle, puis sur le bouton Apprendre pour apprendre à nouveau le modèle de forme.


Outils d'identification - Modèles

L'outil d'identification de forme permet d'apprendre les occurrences de modèles, puis de vérifier ou d'identifier une occurrence spécifique des modèles dans l'image.

Cet outil s'avère utile, par exemple, pour s'assurer que le produit correct défile sur la chaîne de production d'après un logo, une étiquette ou une pièce, ou pour identifier le produit qui défile et communiquer ces informations aux autres périphériques de l'usine.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil d'identification de forme

Après avoir ajouté l'outil, configurez les régions de l'image définissant votre modèle (la région Modèle) et l'emplacement du modèle dans l'image (la région Recherche).

L'outil d'identification de forme (1-10) permet de créer une bibliothèque pouvant compter jusqu'à 10 modèles de forme différents. Chaque modèle de forme doit être appris en utilisant une image distincte. L'outil recherche les instances individuelles des modèles appris dans l'image et ne reconnaît pas les instances multiples d'un modèle dans l'image.

  1. Positionnez la région Modèle sur le premier modèle à utiliser comme modèle d'apprentissage initial, en vous assurant que la région Modèle recouvre uniquement les caractéristiques importantes du modèle.

  2. Positionnez la région Recherche de manière à ce qu'elle recouvre les zones de l'image dans lesquelles les modèles doivent apparaître. Pour optimiser l'exécution de l'outil, créez des régions Recherche de petite taille. Plus la région Recherche est étendue, plus l'outil mettra de temps à effectuer l'inspection.

    les régions Modèle et Recherche ne peuvent pas être courbées en arc de cercle ou dans une forme circulaire.

  3. Cliquez sur le bouton OK pour confirmer les régions (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet). La région Modèle est alors remplacée par un contour vert du modèle appris.
  4. Pour définir un autre modèle de forme, chargez ou acquérez une nouvelle image avec un nouveau modèle, sélectionnez un produit non appris dans le Tableau (libellé comme « Non appris » dans la colonne Appris), cliquez sur le bouton Région du modèle, puis répétez les étapes 1 à 3.
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil d'identification de forme (1-10)

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil d'identification de forme (1-10) comprend quatre onglets :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Tableau
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Tableau


Outil d'identification de modèles - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « IDModèle_1 » s'il s'agit du premier outil d'identification de modèles ajouté au projet. Sinon, il est incrémenté (par exemple, « IDModèle_2 », « IDModèle_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil d'identification de forme - Onglet Paramètres

Fermé Mode

Définit le mode de fonctionnement de l'outil : Identifier ou Vérifier.

Identifier (mode par défaut) est utilisé lorsque le modèle à inspecter est inconnu. L'outil examine automatiquement l'image (en fonction de vos régions) et utilise la bibliothèque de modèles appris pour déterminer le modèle affiché, puis renvoie cette information dans le paramètre Résultat.

Vérifier est utilisé pour vérifier que le modèle correct est présent. L'outil examine l'image d'un modèle indiqué et compare le modèle localisé au modèle spécifié dans le paramètre Modèle.

Fermé Modèle

Définit le modèle appris à vérifier (pour activer ce paramètre, le mode doit être défini sur Vérifier). Sélectionnez un des modèles appris.

Fermé Seuil d'acceptation

Définit le degré de similitude qui doit exister entre le modèle de forme et le modèle localisé (0 à 100 ; valeur par défaut = 50). Les modèles localisés affichant une valeur supérieure ou égale au seuil défini sont considérés comme correspondants. Cet outil s'exécute plus rapidement lorsque ce paramètre est élevé, ce qui requiert également un degré de similitude plus important entre le modèle de forme et le modèle localisé. Moins les paramètres sont élevés, moins les résultats seront précis. Des modèles semblables seront détectés, mais pas par rapport au modèle de forme.

Fermé Tolérance angulaire

Définit dans quelle mesure le modèle localisé peut pivoter par rapport à la position du modèle de forme, tout en étant identifié comme un modèle valide (± 0 à 180° ; valeur par défaut = 15°). Plus la tolérance angulaire du modèle est importante, plus l'exécution de l'outil prend de temps.

Fermé Tolérance en échelle

Définit la tolérance de l'outil aux variations d'échelle du modèle, avec une marge de ± 10 % par rapport à la taille du modèle appris. Ce paramètre est désactivé par défaut (option pas cochée), ce qui désactive les ajustements d'échelle. Dans ce mode de fonctionnement, l'outil trouve toujours les modèles compris dans la plage de ± 10 %, mais le score de la caractéristique diminue à mesure que le pourcentage de mise à l'échelle augmente.

Fermé Différence autorisée

Définit la différence de scores autorisée pouvant exister entre le modèle localisé et un des modèles appris (1 à 20 ; par défaut, 0). La valeur correspond à la différence de score entre deux modèles de forme appris. Par exemple, une valeur de 5 garantit que l'outil trouve les modèles dont le score est au moins supérieur de 5 au score d'un autre modèle de forme.

Fermé Type de modèle

Définit comment l'outil construit le modèle de forme : Modèle de surface ou Modèle de transition (valeur par défaut). Modèle de surface crée un modèle de forme basé sur un échantillonnage uniforme de valeurs de niveaux de gris de la région modèle. Modèle de transition crée un modèle de forme basé sur les transitions détectées (transitions claires/sombres) de la caractéristique de modèle dans la région modèle.

Fermé Précision

Définit comment l'outil qualifie le compromis entre précision/fiabilité et vitesse d'exécution : Précis, Moyen (valeur par défaut) et Rapide. Précis indique que l'accent est mis sur une précision/fiabilité plus élevée et une vitesse d'exécution plus lente , Rapide indique que l'accent est mis sur une vitesse d'exécution plus élevée plutôt que sur la précision/fiabilité ; et Moyen indique un réglage intermédiaire entre les deux.

Fermé Délai d'attente

Définit la durée, en millisecondes (0 à 30 000), pendant laquelle l'outil recherche le ou les modèles avant que l'exécution ne soit interrompue et que l'outil ne renvoie un échec.

Fermé Résultat

Affiche le nom du modèle identifié.


Outil d'identification de modèles (1-10) - Onglet Tableau

L'onglet Tableau contient le tableau ainsi que des miniatures des modèles appris.

Fermé Onglet Tableau

Nom : définit le nom du modèle appris. Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Appris : indique si un modèle a été appris ou non. Il indique « Appris » si le modèle a été appris et « Non appris » s'il n'a pas été appris.

Score : indique le score du modèle appris localisé.

Remarque :
  • Pour supprimer un modèle de l'outil, cliquez avec le bouton droit sur le modèle sur l'onglet Tableau et sélectionnez l'option Supprimer du menu.
  • Le volet de paramètres Tableau comprend trois options d'affichage : Grandes icônes, Détails (valeur par défaut) et Mosaïque. Pour changer l'option d'affichage sélectionnée sur le volet de paramètres, cliquez avec le bouton droit sur le volet Tableau et sélectionnez l'option voulue dans le sous-menu Affichage.
Fermé Bouton Région du modèle

Ce bouton initialise l'apprentissage des modèles.

Fermé Bouton Renommer

Pour attribuer à un modèle un nouveau nom associé à une application spécifique, sélectionnez un modèle appris dans le tableau puis cliquez sur ce bouton.

Fermé Miniature Image d'apprentissage

L'image affichée sous le bouton Région du modèle est une miniature du modèle de forme. Cliquez sur le bouton Région du modèle pour redimensionner ou déplacer la région Modèle, puis sur le bouton Apprendre pour apprendre à nouveau le modèle de forme.


Outils d'identification - Modèle de couleurs

L'outil d'identification du modèle de couleurs permet de déterminer, à partir d'une bibliothèque de modèles de couleurs, le modèle de couleurs qui correspond le mieux aux couleurs de l'image, renvoyant le nom du modèle de couleurs correspondant.

L'outil Modèle de couleurs utilise une bibliothèque de modèles de couleurs appris pour déterminer le nombre de pixels présents dans la région qui correspondent aux modèles de couleurs sélectionnés et appris de la bibliothèque. Selon son mode de fonctionnement, Identifier (paramètre par défaut) ou Correspondance, l'outil renvoie le nom du modèle de couleurs qui correspond le mieux aux critères de l'inspection. Il crée également une image de sortie en niveaux de gris binaire, dans laquelle chaque pixel correspondant à un modèle de couleurs actif est défini sur Blanc (255) alors que tous les autres pixels sont définis sur Noir (0).

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil d'identification du modèle de couleurs

Une fois l'outil ajouté, sélectionnez le type de région et configurez cette dernière dans l'image :

  1. Dans le menu déroulant Modèle, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région dans l'image dans laquelle vous pensez voir apparaître la ou les couleur(s), en vous assurant qu'elle englobe complètement la ou les couleur(s) et leurs emplacements possibles, et configurez-la. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la ou des couleur(s) reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.

    2. Remarque : Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Une fois la région de recherche configurée, configurez la bibliothèque de couleurs de l'outil et activez le ou les modèles de couleurs appropriés :

    • Si un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire) est ajouté pour la première fois, commencez par configurer une ou plusieurs bibliothèques de couleurs et leur(s) modèle(s) de couleurs.

    • Si un autre outil a déjà été ajouté et que vous souhaitez utiliser une bibliothèque de couleurs existante et ses modèles de couleurs appris, sélectionnez la bibliothèque de couleurs de votre choix sous l'onglet Paramètres, puis activez les modèles de couleurs voulus en les cochant sous l'onglet Bibliothèque.

    • Par défaut, l'outil déclenche automatiquement un échec tant qu'aucune bibliothèque de couleurs n'a été définie. Si une bibliothèque de couleurs a été définie, l'outil utilise automatiquement cette bibliothèque et active tous les modèles de couleurs qu'elle contient.

  4. Une fois le ou les modèles de couleurs et la ou les bibliothèques de couleurs configurés, l'outil traite l'image et tous les pixels de la région de recherche qui correspondent au ou aux modèles de couleurs sélectionnés deviennent blancs (255), alors que ceux qui ne correspondent pas au ou aux modèles de couleurs sélectionnés deviennent noirs (0).
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil d'identification du modèle de couleurs

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil d'identification du modèle de couleurs comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Tableau
  • Onglet Bibliothèque de couleurs
  • Onglet Région composite
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Bibliothèque de couleurs

Onglet Tableau

Onglet Région composite


Outil d'identification du modèle de couleurs - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats Entrées/Sorties et Communication. Le nom par défaut est « IdentificationModèleDeCouleurs_1 » s'il s'agit du premier outil d'identification du modèle de couleurs ajouté au projet. Sinon, il est incrémenté (par exemple, « IdentificationModèleDeCouleurs_2 », « IdentificationModèleDeCouleurs_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil d'identification du modèle de couleurs - Onglet Paramètres

Fermé Apprendre la couleur

Affiche la boîte de dialogue Apprentissage ExtractColor , utilisée pour définir le ou les modèles de couleurs de la bibliothèque de couleurs sélectionnée.

Fermé Bibliothèque de couleurs

Définit la bibliothèque de couleurs utilisée comme référence par l'outil. Sur la liste déroulante, sélectionnez la bibliothèque de couleurs à modifier puis cliquez sur le bouton Apprendre la couleur pour afficher la boîte de dialogue Apprentissage ExtractColor. Chaque bibliothèque de couleurs peut compter jusqu'à 100 modèles de couleurs distincts, composés de couleurs individuelles.

Les projets EasyBuilder peuvent contenir 5 bibliothèques de couleurs maximum, qui peuvent être partagées par les outils suivants :

  • Outil de recherche de blob de couleur
  • Outil de recherche de blobs de couleur (1-10)
  • Outil de présence/absence basé sur le comptage de pixels
  • Outil de mesure de surface de blob de couleur
  • Outil de mesure de surfaces des blobs de couleur (1-10)
  • Outil de comptage de blobs de couleur
  • Outil d'identification du modèle de couleurs
  • Outil de filtre d'image couleur -> binaire
Fermé Mode

Définit le mode de fonctionnement de l'outil : Identifier (par défaut) ou Correspondance.

  • Identifier : utilisé lorsque les couleurs de l'image sont inconnues. L'outil détermine le modèle de couleurs qui correspond le mieux aux couleurs de l'image et organise et classe les résultats en fonction de leur comptage de pixels, s'il y a plusieurs modèles de couleurs actifs dans la bibliothèque de couleurs sélectionnée.
  • Correspondance : utilisé pour vérifier si un modèle de couleurs attendu est présent dans l'image. L'outil traite l'image et détermine si les couleurs qu'elle contient correspondent ou non à celles attendues d'après le modèle de couleurs spécifié dans le paramètre Couleur de correspondance.
Fermé Couleur de correspondance

Définit le modèle de couleurs attendu à détecter. Ce champ n'est activé que si le paramètre Mode est défini sur Correspondance. Entrez le nom du modèle de couleurs que vous pensez détecter dans le champ.

Fermé Nombre minimal de pixels

Définit le seuil de comptage de pixels minimal (0 à 9 999 999 ; par défaut = 1000) pour déterminer si un modèle de couleurs peut ou non être considéré comme une correspondance. Par exemple, en mode Identifier, si le seuil est défini sur 1000, tous les modèles de couleurs affichant moins de 1000 pixels sont automatiquement exclus ; en mode Correspondance, si le modèle de couleurs attendu comprend moins de 1000 pixels correspondants, l'outil renvoie un échec.

Fermé Résultat

Affiche le nom du modèle de couleurs localisé.


Outil d'identification du modèle de couleurs - Bibliothèque de couleurs

Fermé Liste Modèles de couleurs

Affiche une liste en lecture seule de modèle(s) de couleurs contenus dans la bibliothèque de couleurs sélectionnée. Les modèles de couleurs sont activés et désactivés en cochant ou décochant la case en regard de Modèles de couleurs.

Fermé Tableau de couleurs

Affiche un tableau ordonné en lecture seule de la ou des couleurs dans le modèle de couleurs sélectionné.

Fermé Nom de la couleur

Affiche le nom de la ou des couleurs du modèle de couleurs sélectionné.

Fermé RVB

Affiche les valeurs RVB de la ou des couleurs du modèle de couleurs sélectionné.

Fermé Opération

Affiche l'opération (Ajouter ou Soustraire) de la ou des couleurs du modèle de couleurs sélectionné.


Outil d'identification du modèle de couleurs - Onglet Tableau

L'onglet Tableau affiche une liste en lecture seule des modèles de couleurs localisés, triés en fonction de leur rang et score dans les 10 meilleures correspondances.

Fermé Rang

Affiche le classement numérique du ou des modèles de couleurs qui correspondent le mieux aux critères de l'inspection, de 1 à 10.

Fermé Nom

Affiche le nom du ou des modèles de couleurs localisés.

Fermé Comptage de pixels

Affiche le comptage de pixels du ou des modèles de couleurs localisés.


Outil d'identification du modèle de couleurs - Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).

Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils géométriques - Point à point : Ligne

L'outil géométrique de définition de ligne point à point crée une ligne de référence entre deux caractéristiques d'entrée (points, origines de repères ou centre de caractéristiques circulaires), et renvoie les coordonnées X,Y des points d'extrémité de la ligne créée.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil géométrique de ligne point à point

Une fois l'outil ajouté, définissez les caractéristiques d'entrée (points, origines de repères ou centre de caractéristiques circulaires) qui serviront à créer la ligne de référence:

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Commencez par sélectionner une des caractéristiques disponibles en cliquant dessus : elle devient rose et est reliée à un trait.
  3. Puis sélectionnez la deuxième caractéristique.
  4. Une fois la seconde caractéristique sélectionnée, EasyBuilder crée automatiquement une ligne entre les caractéristiques. EasyBuilder insère également un outil de présence/absence de transition et/ou un outil de présence/absence de cercle pour chacune des caractéristiques pas encore définies (selon l'outil et le type de caractéristique).
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil géométrique de définition de ligne point à point

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil géométrique de définition de ligne point à point comprend les éléments suivants :

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « Ligne_1 » s'il s'agit du premier outil de définition de ligne ajouté au projet. Sinon, il est incrémenté (par exemple, « Ligne_2 », « Ligne_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.


Outils géométriques - Point à point : Point intermédiaire

L'outil géométrique de définition de point médian de deux points calcule le point médian entre deux caractéristiques d'entrée (points, origines de repères ou centre de caractéristiques circulaires), crée une ligne de référence entre les deux caractéristiques et renvoie l'angle du point médian par rapport au repère et les coordonnées X,Y du point médian.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil géométrique de définition de point médian de deux points

Une fois l'outil ajouté, définissez les caractéristiques d'entrée (points, origines de repères ou centre de caractéristiques circulaires) qui serviront à créer la ligne de référence:

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).

  2. Commencez par sélectionner une des caractéristiques disponibles en cliquant dessus : elle devient rose et est reliée à un trait.

  3. Puis sélectionnez la deuxième caractéristique.

  4. Une fois la seconde caractéristique sélectionnée, EasyBuilder crée automatiquement une ligne entre les caractéristiques et insère le repère [image] à l'emplacement du point médian. EasyBuilder insère également un outil de présence/absence de transition et/ou un outil de présence/absence de cercle pour chacune des caractéristiques pas encore définies (selon l'outil et le type de caractéristique).
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil géométrique de définition de point médian de deux points

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil géométrique de définition de point médian de deux points comprend les éléments suivants :

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « Point_1 » s'il s'agit du premier outil de définition de point ajouté au projet. Sinon, il est incrémenté (par exemple, « Point_2 », « Point_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Fermé Onglet Paramètres
Fermé Point médian

Indique les coordonnées X,Y du point médian entre les deux caractéristiques d'entrée, et son orientation angulaire par rapport au repère.

Remarque : À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.


Outils géométriques - Point à point : Dimension

L'outil géométrique de dimension point à point calcule la distance entre deux points médians de deux caractéristiques d'entrée (points, origines de repères ou centre de caractéristiques circulaires) par rapport à une transition ou une ligne, et crée une ligne de référence pour représenter, et indiquer, la distance calculée.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

L'outil géométrique de dimension point à point vous permet, par exemple, d'évaluer la précision de l'alignement d'un assemblage.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil géométrique de dimension point à point

Une fois l'outil ajouté, définissez les caractéristiques d'entrée (points, origines de repères ou centre de caractéristiques circulaires) qui serviront à créer la ligne de référence:

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Commencez par sélectionner une des caractéristiques disponibles en cliquant dessus : elle devient rose et est reliée à un trait.
  3. Puis sélectionnez la deuxième caractéristique.
  4. Une fois la deuxième caractéristique sélectionnée, EasyBuilder examine une nouvelle fois automatiquement votre image et affiche une sélection de Smart Features de transition ou linéaires utilisable comme ligne de référence pour la mesure. Sélectionnez une caractéristique de transition ou linéaire de référence.
  5. EasyBuilder projette alors les lignes de référence à partir des points médians des caractéristiques perpendiculaires à la transition ou ligne de référence. Et il calcule la distance en fonction de la relation entre les lignes de référence perpendiculaires projetées et la transition ou ligne de référence sélectionnée. EasyBuilder insère également un outil de présence/absence de transition et/ou un outil de présence/absence de cercle pour chacune des caractéristiques pas encore définies (selon l'outil et le type de caractéristique).
  6. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  7. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil géométrique de dimension point à point

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil géométrique de dimension point à point comprend les éléments suivants :

  • Onglet Général
  • Onglet Limites de plages
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Limites de plages


Outil géométrique de dimension point à point - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « Dimension_1 » s'il s'agit du premier outil géométrique de dimension point à point ajouté au projet. Sinon, il est incrémenté (par exemple, « Dimension_2 », « Dimension_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil géométrique de dimension point à point - Onglet Limites de plages

Fermé Maximum

Définit la plus grande distance acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Distance

Indique la distance actuelle mesurée entre les lignes de référence perpendiculaires projetées des points médians des deux caractéristiques par rapport à la transition ou ligne de référence. Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Remarque : À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
Fermé Minimum

Définit la plus petite distance acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outils géométriques - Ligne perpendiculaire

L'outil géométrique de définition de ligne perpendiculaire crée une ligne de référence perpendiculaire à une autre ligne ou caractéristique de transition, et renvoie les coordonnées X,Y des points d'extrémité de la ligne de référence créée.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil géométrique de définition de ligne perpendiculaire

Une fois l'outil ajouté, définissez la ligne perpendiculaire à rechercher pour une ligne ou une caractéristique de transition :

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Sélectionnez une ligne ou une transition parmi les caractéristiques disponibles en cliquant dessus. EasyBuilder détermine alors automatiquement le point d'intersection de la ligne perpendiculaire à la ligne ou transition sélectionnée. Il insère une ligne de référence pour la définir, ainsi qu'un outil de présence/absence de transition pour chacune des transitions pas encore définies.
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil géométrique de définition de ligne perpendiculaire

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil géométrique de définition de ligne perpendiculaire comprend les éléments suivants :

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « Ligne_1 » s'il s'agit du premier outil de définition de ligne ajouté au projet. Sinon, il est incrémenté (par exemple, « Ligne_2 », « Ligne_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.


Outils géométriques - Intersection de lignes

L'outil géométrique d'intersection de lignes permet d'identifier le point où deux caractéristiques de transition et/ou lignes de référence se croisent, et renvoie les coordonnées X,Y du point d'intersection.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil géométrique d'intersection de lignes

Une fois l'outil ajouté, définissez les caractéristiques de transition et/ou les lignes qui se croiseront :

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Commencez par sélectionner une des caractéristiques disponibles en cliquant dessus : elle devient rose et est reliée à un trait.
  3. Puis, sélectionnez la transition ou ligne à croiser.
  4. Une fois la deuxième caractéristique sélectionnée, EasyBuilder détermine automatiquement le point où les lignes se croisent et insère un point pour définir l'intersection. EasyBuilder insère également un outil de présence/absence de transition et/ou un outil de présence/absence de cercle pour chacune des caractéristiques pas encore définies (selon l'outil et le type de caractéristique).
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil géométrique d'intersection de lignes

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil géométrique d'intersection de lignes comprend les éléments suivants :

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « Intersection_1 » s'il s'agit du premier outil géométrique d'intersection cercle à ligne ou d'intersection de lignes ajouté au projet. Sinon, il est incrémenté (par exemple, « Intersection_2 », « Intersection_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.


Outils géométriques - Bissectrice de l'angle

L'outil géométrique Bissectrice de l'angle crée une ligne de référence représentant l'angle de bissection entre deux caractéristiques de transition ou lignes, et renvoie la bissectrice de l'angle et les coordonnées X,Y des points d'extrémité de la ligne créée.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

L'outil géométrique Bissectrice de l'angle vous permet d'identifier la bissectrice de l’angle entre des caractéristiques de votre pièce et peut aussi utiliser la bissectrice de l’angle comme point de référence pour d'autres mesures.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil géométrique d'angle de bissection

Une fois l'outil ajouté, définissez les caractéristiques de transition ou lignes qui serviront à créer la ligne de référence de bissection :

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Commencez par sélectionner une des caractéristiques disponibles en cliquant dessus. Elle devient rose.
  3. Puis sélectionnez la seconde transition ou ligne qui définira la zone à diviser en cliquant dessus.
  4. EasyBuilder trace alors automatiquement une ligne de référence entre les transitions ou lignes sélectionnées. EasyBuilder insère également un outil de présence/absence de transition et/ou un outil de présence/absence de cercle pour chacune des caractéristiques pas encore définies (selon l'outil et le type de caractéristique).
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil géométrique d'angle de bissection

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil géométrique d'angle de bissection comprend les éléments suivants :

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « Bissection_1 » s'il s'agit du premier outil géométrique d'angle de bissection ajouté au projet. Sinon, il est incrémenté (par exemple, « Bissection_2 », « Bissection_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.


Outils géométriques - Ligne à partir de N points

L'outil géométrique de définition de ligne à partir de N points crée une ligne de référence ajustée à partir de 2 à 10 caractéristiques d'entrée (points, origines de repères ou centre de caractéristiques circulaires), et renvoie les coordonnées X,Y des points d'extrémité de la ligne créée.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

L'outil géométrique de définition de ligne à partir de N points vous permet de créer une ligne de référence à partir de caractéristiques présentes dans l'image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil géométrique de définition de ligne à partir de N points

Une fois l'outil ajouté, définissez les caractéristiques d'entrée (points, origines de repères ou centre de caractéristiques circulaires) qui serviront à créer la ligne de référence:

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Commencez par sélectionner une des caractéristiques disponibles en cliquant dessus. Elle devient rose.
  3. Puis sélectionnez les autres caractéristiques utilisées pour définir la ligne (deux au minimum et dix au maximum).
  4. Une fois toutes les caractéristiques voulues sélectionnées, cliquez sur le bouton OK (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  5. EasyBuilder trace alors automatiquement une ligne de référence avec les caractéristiques d'entrée sélectionnées. EasyBuilder insère également un outil de présence/absence de transition et/ou un outil de présence/absence de cercle pour chacune des caractéristiques pas encore définies (selon l'outil et le type de caractéristique).
  6. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  7. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil géométrique de définition de ligne à partir de N points

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil géométrique de définition de ligne à partir de N points comprend les éléments suivants :

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « Ligne_1 » s'il s'agit du premier outil de définition de ligne ajouté au projet. Sinon, il est incrémenté (par exemple, « Ligne_2 », « Ligne_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.


Outils géométriques - Cercle à partir de N points

L'outil géométrique de définition de cercle à partir de N points crée un cercle de référence à partir de 3 à 10 caractéristiques d'entrée (points, origines de repères ou centre de caractéristiques circulaires), et renvoie le diamètre du cercle créé.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

L'outil géométrique de définition de cercle à partir de N points vous permet de créer un cercle de référence à partir de caractéristiques présentes dans l'image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil géométrique de définition de cercle à partir de N points

Une fois l'outil ajouté, définissez les caractéristiques d'entrée (points, origines de repères ou centre de caractéristiques circulaires) qui serviront à créer le cercle de référence :

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Commencez par sélectionner une des caractéristiques disponibles en cliquant dessus. Elle devient rose.
  3. Puis sélectionnez les autres caractéristiques utilisées pour définir le cercle (trois au minimum et dix au maximum).
  4. Une fois toutes les caractéristiques voulues sélectionnées, cliquez sur le bouton OK (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  5. EasyBuilder trace alors automatiquement un cercle de référence avec les caractéristiques d'entrée sélectionnées. EasyBuilder insère également un outil de présence/absence de transition et/ou un outil de présence/absence de cercle pour chacune des caractéristiques pas encore définies (selon l'outil et le type de caractéristique).
  6. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  7. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil géométrique de définition de cercle à partir de N points

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil géométrique de définition de cercle à partir de N points comprend les éléments suivants :

  • Onglet Général
  • Onglet Limites de plages
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Limites de plages


Outil géométrique de définition de cercle à partir de N points - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « Cercle_1 » s'il s'agit du premier outil de définition de cercle ajouté au projet. Sinon, il est incrémenté (par exemple, « Cercle_2 », « Cercle_3 », etc.). PPersonnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil géométrique de définition de cercle à partir de N points - Onglet Limites de plages

Fermé Maximum

Définit le plus grand diamètre acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Diamètre

Indique le diamètre mesuré actuel du cercle créé. Les valeurs égales aux ou comprises entre les paramètres Minimum et Maximum sont classées comme Succès.

Remarque : À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
Fermé Minimum

Définit le plus petit diamètre acceptable. L'outil crée une limite automatique par défaut basée sur votre image, que vous pouvez personnaliser en fonction des besoins de votre application.

Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.


Outils géométriques - Intersection cercle à ligne

L'outil géométrique d'intersection cercle à ligne permet d'identifier les points d'intersection d'une ligne sur un cercle, et renvoie les coordonnées X,Y des points où la ligne coupe le cercle.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

L'outil géométrique d'intersection cercle à ligne vous permet, par exemple, de vérifier l'alignement correct entre une caractéristique circulaire et une transition.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil géométrique d'intersection cercle à ligne

Une fois l'outil ajouté, définissez la caractéristique circulaire et la transition ou ligne qui coupera le cercle :

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert).
  2. Commencez par sélectionner une des caractéristiques circulaires disponibles en cliquant dessus : elle devient rose et est reliée à un trait.
  3. Puis sélectionnez la transition ou ligne qui coupera le cercle.
  4. Une fois la deuxième caractéristique sélectionnée, EasyBuilder détermine automatiquement les points où la ligne coupe le cercle et insère deux points pour définir l'intersection. EasyBuilder insère également un outil de présence/absence de transition et/ou un outil de présence/absence de cercle pour chacune des caractéristiques pas encore définies (selon l'outil et le type de caractéristique).
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil géométrique d'intersection cercle à ligne

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil géométrique d'intersection cercle à ligne comprend les éléments suivants :

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « Intersection_1 » s'il s'agit du premier outil géométrique d'intersection cercle à ligne ou d'intersection de lignes ajouté au projet. Sinon, il est incrémenté (par exemple, « Intersection_2 », « Intersection_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Fermé Onglet Paramètres
Fermé Inverser le résultat

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.


Outils géométriques - Point défini manuellement

L'outil géométrique de définition manuelle d'un point permet de positionner un point de référence n'importe où dans l'image et renvoie les coordonnées X,Y du point.

L'outil géométrique de définition manuelle d'un point permet, par exemple, de déterminer une mesure en fonction d'un point de référence non défini comme une caractéristique sur la pièce ou l'objet en cours d'inspection.

Remarque :
  • L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.
  • Le point de l'outil peut aussi être utilisé comme repère pour d'autres outils, même si le point ne fournit aucune information d'angle.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil géométrique de définition manuelle d'un point

  1. Une fois l'outil ajouté, un repère en croix rose apparaît sur l'image.
  2. Positionnez le repère en croix à l'emplacement de votre choix sur l'image et cliquez sur le bouton OK pour en accepter la position.
  3. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.

  4. Si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

    Remarque : Le point de l'outil peut aussi être utilisé comme repère pour d'autres outils, même si le point ne fournit aucune information d'angle.


Réglage des paramètres de l'outil géométrique de définition manuelle d'un point

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil géométrique de définition manuelle d'un point comprend les éléments suivants :

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « Point_1 » s'il s'agit du premier outil de définition de point ajouté au projet. Sinon, il est incrémenté (par exemple, « Point_2 », « Point_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.


Outils géométriques - Ligne définie manuellement

L'outil géométrique de définition manuelle d'une ligne vous permet de positionner une ligne de référence n'importe où dans l'image et renvoie les coordonnées X,Y des points d'extrémité de la ligne.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

L'outil géométrique de définition manuelle d'une ligne permet, par exemple, de déterminer une mesure en fonction d'une ligne de référence non définie comme repère sur la pièce ou l'objet en cours d'inspection.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil géométrique de définition manuelle d'une ligne

  1. Une fois l'outil ajouté, une ligne rose apparaît sur l'image.
  2. Positionnez la ligne à l'emplacement de votre choix sur l'image et cliquez sur le bouton OK pour en accepter la position.
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil géométrique de définition manuelle d'une ligne

Après avoir défini et accepté les entrées de l'outil, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil géométrique de définition manuelle d'une ligne comprend les éléments suivants :

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées, Sorties et Communication). Le nom par défaut est « Ligne_1 » s'il s'agit du premier outil de définition de ligne ajouté au projet. Sinon, il est incrémenté (par exemple, « Ligne_2 », « Ligne_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Fermé Onglet Paramètres
Fermé Ligne

Indique les coordonnées X,Y des points d'extrémité du segment de ligne créé.

Remarque : À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.


Outils géométriques - Ajustement du cercle

L'outil géométrique d'ajustement de cercle construit un cercle ajusté de façon optimale en fonction des transitions détectées. Il utilise des groupes Caliper d'analyse des transitions pour obtenir les emplacements précis des transitions. Une fois la transition identifiée, l'outil construit un cercle ajusté de façon optimale sur la transition puis renvoie le rayon du cercle et son point central.

Remarque :
  • À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
  • Toutes les valeurs d'entrée sont en pixels, que l'outil ait ou non été calibré avec des unités réelles.

L'outil géométrique d'ajustement de cercle permet de s'assurer que la pièce ou l'objet a la même forme. Cet outil est capable de créer un cercle ajusté de façon optimale avec plus de précision, mais plus lentement, que l'outil géométrique de définition de cercle à partir de N points, par exemple.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil géométrique d'ajustement de cercle

Après avoir ajouté l'outil, vous devrez configurer la région masquée de l'image sur la transition à inspecter :

  1. Positionnez et configurez la région masquée circulaire dans l'image sur la transition. Vous pouvez régler le rayon extérieur et le rayon intérieur de l'anneau pour vous assurer qu'il détecte les transitions correctes. Lors du positionnement et de la configuration de la région, assurez-vous que les transitions sont parallèles au sens de recherche de la région, et que la région englobe le plus possible la transition, tout en excluant le bruit superflu ou indésirable de la région.

    Remarque : La ligne en pointillés jaune dans la Région masquée définit la zone au sein de la région dans laquelle les transitions seront détectées.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Après avoir confirmé la région, sélectionnez les divers onglets, Transitions, Score de la transition et Ajustement, et réglez les paramètres et la région selon le besoin pour s'assurer que l'outil détecte les transitions possibles correctes et crée la ligne ou le cercle ajusté(e) de façon optimale correct(e).
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage de l'outil géométrique d'ajustement de cercle

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil géométrique d'ajustement de cercle comprend les éléments suivants :

  • Onglet Général
  • Onglet Bords
  • Onglet Score de la transition
  • Onglet Ajustement
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Ajustement

Onglet Transitions

Onglet Score de la transition


Outil géométrique d'ajustement de cercle - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « AjustementCercle_1 » s'il s'agit du premier outil géométrique d'ajustement de cercle ajouté au projet. Sinon, il est incrémenté (par exemple, « AjustementCercle_2 », « AjustementCercle_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil géométrique d'ajustement de cercle - Onglet Ajustement

Lorsque l'onglet Ajustement est sélectionné, l'outil affiche toutes les transitions possibles détectées au sein de la région et le cercle ajusté de façon optimale résultant. Les transitions possibles, indiquées par des petits cercles de couleur, sont les transitions qui peuvent être prises en compte lors de la construction du cercle ajusté de façon optimale.

Fermé Observations aberrantes du filtre

Définit si l'outil supprime ou non les points de la ligne ajustée de façon optimale qui se trouvent au-delà de la distance définie par le paramètre Ajuster le filtre de distance (ce paramètre est activé par défaut).

Fermé Ajuster le filtre de distance

Définit la distance (1 à 1 920 ; valeur par défaut = 2), en pixels, à laquelle une transition doit se trouver par rapport à la ligne ajustée de façon optimale d'origine pour être utilisée dans un nouveau calcul d'ajustement. Ce paramètre aide à éviter que les défauts n'affectent l'ajustement de ligne.

Remarque : le paramètre Observations aberrantes du filtre doit être coché (activé) pour utiliser ce paramètre.
Fermé Distance de filtrage du point le plus éloigné

Définit la distance (1 à 1 920 ; valeur par défaut = 1 000) au-delà de laquelle les transitions ne sont pas utilisées pour déterminer les distances minimale et maximale. Toute transition supérieure à cette valeur sera ignorée.

Fermé Nouveau score

Définit si les transitions détectées sont réévaluées pour s'assurer que les transitions détectées initialement ignorées ont été filtrées correctement (ce paramètre est activé par défaut).

Fermé Nouvel ajustement

Définit si l'outil réajuste ou non la ligne ajustée de façon optimale après la réévaluation des transitions (ce paramètre est activé par défaut).

Remarque : l'outil est plus précis lorsque ce paramètre est activé, mais sa durée d'exécution est plus longue.
Fermé Résultat

Affiche la ligne ajustée de façon optimale dans l'image et renvoie le rayon du cercle ajusté de façon optimale et son point central.


Outil géométrique d'ajustement de cercle - Onglet Transitions

Lorsque l'onglet Transitions est sélectionné, l'outil affiche toutes les transitions détectées (en vert foncé) au sein de la région. Vous pouvez ajuster les paramètres Taille du caliper, Espacement de caliper, Largeur de transition et Contraste minimum, selon le besoin, pour isoler les transitions voulues.

Vous pouvez également choisir d'afficher tous les calipers en activant le paramètre Afficher tous les calipers.

La région peut également être sélectionnée et ajustée sous cet onglet.

Fermé Taille du caliper

Définit le nombre de pixels, par caliper, à analyser dans le sens de l'inspection (1 à 639 ; valeur par défaut = 5).

Fermé Espacement de caliper

Définit la distance, en pixels, entre la fin d'un caliper et le début du caliper suivant (-1 à 639 ; valeur par défaut = 0).

Fermé Largeur de transition

Définit la distance de pixels (1 à 10 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Contraste minimum

Définit la transition de contraste minimale en niveaux de gris (1 à 255 ; valeur par défaut = 10) pour être considérée comme une transition.

Fermé Nombre de calipers

Affiche le nombre total de calipers dans la région.

Fermé Index du caliper

Définit le caliper individuel à isoler et à afficher.

Fermé Afficher tous les calipers

Définit si tous les calipers dans la région sont ou non affichés à tout moment. Les calipers sont masqués par défaut.


Outil géométrique d'ajustement de cercle - Onglet Score de la transition

Lorsque l'onglet Score de la transition est sélectionné, l'outil affiche toutes les transitions possibles détectées (indiquées par des petits cercles de couleur) au sein de la région (qui peut être sélectionnée et ajustée) et la ligne ou le cercle ajusté(e) de façon optimale résultant(e). Les transitions possibles sont les transitions qui peuvent être prises en compte lors de la construction de la ligne ou du cercle ajusté(e) de façon optimale. Réglez les paramètres pour isoler les transitions possibles voulues.

Tous les défauts et écarts détectés sont également affichés.

Fermé Détection du sens de la transition

Définit le sens dans lequel l'outil tente de détecter les transitions par rapport à la région (Gauche -> droite ou Droite -> gauche ; valeur par défaut = Gauche -> droite).

Fermé Transition

Définit le type de transition (Sombre vers clair, Clair vers sombre ou Indifférent; valeur par défaut = Indifférent). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Règle:Première transition

Définit si la première paire de transitions détectée est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Règle:Transition la plus marquée

Définit si la transition affichant le contraste le plus élevé est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Seuil de score

Définit un seuil de score pour filtrer les transitions avec des scores (0 à 255 ; valeur par défaut = 10) inférieurs à cette valeur.


Outils géométriques - Ajustement de la ligne

L'outil géométrique d'ajustement de ligne construit une ligne ajustée de façon optimale en fonction des transitions détectées. Il utilise des groupes Caliper d'analyse des transitions pour obtenir les emplacements précis des transitions. Une fois la transition identifiée, l'outil construit une ligne ajustée de façon optimale sur la transition puis renvoie les coordonnées X/Y des points de départ et de fin du segment.

Remarque :
  • À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
  • Toutes les valeurs d'entrée sont en pixels, que l'outil ait ou non été calibré avec des unités réelles.

L'outil géométrique d'ajustement de ligne permet de s'assurer que la pièce ou l'objet a la même forme. Cet outil est capable de créer une ligne ajustée de façon optimale avec plus de précision, mais plus lentement, que l'outil géométrique de définition de ligne à partir de N points, par exemple.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil géométrique d'ajustement de ligne

Après avoir ajouté l'outil, vous devrez configurer la région masquée de l'image sur la transition à inspecter :

  1. Positionnez et configurez la région dans l'image sur la transition. Lors du positionnement de la région, assurez-vous que les transitions sont parallèles au sens de recherche de la région, et que la région englobe le plus possible la transition, tout en excluant le bruit superflu ou indésirable de la région.

    Remarque : La ligne en pointillés jaune dans la Région masquée définit la zone au sein de la région dans laquelle les transitions seront détectées.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Après avoir confirmé la région, sélectionnez les divers onglets, Transitions, Score de la transition et Ajustement, et réglez les paramètres et la région selon le besoin pour s'assurer que l'outil détecte les transitions possibles correctes et crée la ligne ou le cercle ajusté(e) de façon optimale correct(e).
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage de l'outil géométrique d'ajustement de ligne

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil géométrique d'ajustement de ligne comprend les éléments suivants :

  • Onglet Général
  • Onglet Bords
  • Onglet Score de la transition
  • Onglet Ajustement
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Ajustement

Onglet Transitions

Onglet Score de la transition


Outil géométrique d'ajustement de ligne - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « AjustementLigne_1 » s'il s'agit du premier outil géométrique d'ajustement de ligne ajouté au projet. Sinon, il est incrémenté (par exemple, « AjustementLigne_2 », « AjustementLigne_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil géométrique d'ajustement de ligne - Onglet Ajustement

Lorsque l'onglet Ajustement est sélectionné, l'outil affiche toutes les transitions possibles détectées au sein de la région et la ligne ajustée de façon optimale résultante. Les transitions possibles, indiquées par des petits cercles de couleur, sont les transitions qui peuvent être prises en compte lors de la construction de la ligne ajustée de façon optimale.

Fermé Observations aberrantes du filtre

Définit si l'outil supprime ou non les points de la ligne ajustée de façon optimale qui se trouvent au-delà de la distance définie par le paramètre Ajuster le filtre de distance (ce paramètre est activé par défaut).

Fermé Ajuster le filtre de distance

Définit la distance (1 à 1 920 ; valeur par défaut = 2), en pixels, à laquelle une transition doit se trouver par rapport à la ligne ajustée de façon optimale d'origine pour être utilisée dans un nouveau calcul d'ajustement. Ce paramètre aide à éviter que les défauts n'affectent l'ajustement de ligne.

Remarque : le paramètre Observations aberrantes du filtre doit être coché (activé) pour utiliser ce paramètre.
Fermé Distance de filtrage du point le plus éloigné

Définit la distance (1 à 1 920 ; valeur par défaut = 1 000) au-delà de laquelle les transitions ne sont pas utilisées pour déterminer les distances minimale et maximale. Toute transition supérieure à cette valeur sera ignorée.

Fermé Nouveau score

Définit si les transitions détectées sont réévaluées pour s'assurer que les transitions détectées initialement ignorées ont été filtrées correctement (ce paramètre est activé par défaut).

Fermé Nouvel ajustement

Définit si l'outil réajuste ou non la ligne ajustée de façon optimale après la réévaluation des transitions (ce paramètre est activé par défaut).

Remarque : l'outil est plus précis lorsque ce paramètre est activé, mais sa durée d'exécution est plus longue.
Fermé Résultat

Affiche la ligne ajustée de façon optimale dans l'image, et renvoie les coordonnées X/Y des points de départ et de fin du segment.


Outil géométrique d'ajustement de ligne - Onglet Transitions

Lorsque l'onglet Transitions est sélectionné, l'outil affiche toutes les transitions détectées (en vert foncé) au sein de la région. Vous pouvez ajuster les paramètres Taille du caliper, Espacement de caliper, Largeur de transition et Contraste minimum, selon le besoin, pour isoler les transitions voulues.

Vous pouvez également choisir d'afficher tous les calipers en activant le paramètre Afficher tous les calipers.

La région peut également être sélectionnée et ajustée sous cet onglet.

Fermé Taille du caliper

Définit le nombre de pixels, par caliper, à analyser dans le sens de l'inspection (1 à 639 ; valeur par défaut = 5).

Fermé Espacement de caliper

Définit la distance, en pixels, entre la fin d'un caliper et le début du caliper suivant (-1 à 639 ; valeur par défaut = 0).

Fermé Largeur de transition

Définit la distance de pixels (1 à 10 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Contraste minimum

Définit la transition de contraste minimale en niveaux de gris (1 à 255 ; valeur par défaut = 10) pour être considérée comme une transition.

Fermé Nombre de calipers

Affiche le nombre total de calipers dans la région.

Fermé Index du caliper

Définit le caliper individuel à isoler et à afficher.

Fermé Afficher tous les calipers

Définit si tous les calipers dans la région sont ou non affichés à tout moment. Les calipers sont masqués par défaut.


Outil géométrique d'ajustement de ligne - Onglet Score de la transition

Lorsque l'onglet Score de la transition est sélectionné, l'outil affiche toutes les transitions possibles détectées (indiquées par des petits cercles de couleur) au sein de la région (qui peut être sélectionnée et ajustée) et la ligne ou le cercle ajusté(e) de façon optimale résultant(e). Les transitions possibles sont les transitions qui peuvent être prises en compte lors de la construction de la ligne ou du cercle ajusté(e) de façon optimale. Réglez les paramètres pour isoler les transitions possibles voulues.

Tous les défauts et écarts détectés sont également affichés.

Fermé Détection du sens de la transition

Définit le sens dans lequel l'outil tente de détecter les transitions par rapport à la région (Gauche -> droite ou Droite -> gauche ; valeur par défaut = Gauche -> droite).

Fermé Transition

Définit le type de transition (Sombre vers clair, Clair vers sombre ou Indifférent; valeur par défaut = Indifférent). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Règle:Première transition

Définit si la première paire de transitions détectée est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Règle:Transition la plus marquée

Définit si la transition affichant le contraste le plus élevé est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Seuil de score

Définit un seuil de score pour filtrer les transitions avec des scores (0 à 255 ; valeur par défaut = 10) inférieurs à cette valeur.


Outils mathématiques & logiques - Mathématiques

L'outil mathématique & logique Mathématiques permet de créer une formule mathématique capable de traiter les données de projets et d'outils au moyen d'opérateurs mathématiques et de fonctions logiques, statistiques et trigonométriques standard.

L'outil mathématique & logique Mathématiques permet, par exemple, d'ajouter le nombre de défauts de deux outils ou de renvoyer la moyenne des outils de mesure.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil mathématique & logique Mathématiques

Remarque : cet outil requiert que d'autres outils de recherche et/ou d'inspection soient utilisés comme entrées. Regroupez les autres outils de recherche et/ou d'inspection qui seront utilisés comme entrées dans l'outil avant d'ajouter cet outil. Sans cela, vous ne pourrez pas créer les expressions et devrez ajouter les outils de recherche et/ou d'inspection nécessaires puis revenir à cet outil après avoir configuré les autres outils.

Une fois l'outil ajouté, vous devez créer votre Expression.

  1. Créez votre Expression en sélectionnant puis en entrant les fonctions mathématiques côté gauche du volet de paramètres et les valeurs (données de projet et d'outil) côté droit. Pour entrer une fonction ou une valeur dans l'éditeur de formules Expression, sélectionnez la fonction ou la valeur et appuyez sur la touche Entrée, double-cliquez sur la fonction ou la valeur ou appuyez sur le bouton Insérer.

  2. Une fois votre Expression créée, définissez les limites de plage de l'outil en cliquant sur l'onglet Limites de plages. Par défaut le Maximum est défini sur 9 999 999 et le Minimum est défini sur -9 999 999 mais vous pouvez personnaliser les limites en fonction des besoins de votre application.

    Remarque : Si le résultat de l'Expression renvoie une chaîne de texte, les limites Maximum et Minimum seront désactivées.
  3. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  4. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil mathématique & logique Mathématiques

Après avoir ajouté l'outil au projet, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil mathématique & logique Mathématiques comprend les éléments suivants :

  • Onglet Général
  • Onglet Limites de plages
  • Expression
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Expression

Onglet Limites de plages


Outil mathématique & logique Mathématiques - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Mathématiques_1 » (s'il s'agit du premier outil mathématique & logique Mathématiques ajouté au projet. Sinon, il est incrémenté par exemple, « Mathématiques_2 », « Mathématiques_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil mathématique & logique Mathématiques - Expression

Remarque : ces contrôles sont désactivés lorsque le système de vision In-Sight est en ligne.
Fermé Expression

La zone de texte Expression permet de créer une formule mathématique capable de traiter les résultats et données de l'outil. Pour rédiger la formule, entrez les données en saisissant, sur le clavier, le nom de la fonction mathématique ou les données du projet/de l'outil ou en utilisant l'arborescence Outils de vision, Mathématiques, Texte et/ou Résultats de vision à gauche, et l'arborescence de symboles de données de projets et d'outils, à droite. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque :
  • Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
  • Lors de la création de formules, EasyBuilder ne décompose pas correctement les noms d'outils qui commencent par une adresse de cellule (par ex. A3_MyTool ou P10_SortTool). Si des expressions doivent être créées pour ces outils, renommez l'outil avant de créer la formule.
Astuce :

pour déterminer si une chaîne de texte correspond à une autre chaîne, utilisez la fonction Exact. La fonction If est utilisée pour comparer des valeurs ; EasyBuilder renvoie une erreur si la fonction If tente de comparer des chaînes.

Exemple :

  • la chaîne de texte utilisée par un outil d'identification Lire les codes ID doit être comparée à une chaîne lue par un outil d'identification Lire le texte pour s'assurer qu'elles correspondent. La formule suivante peut être utilisée dans l'expression : Exact(IDCode_1.String,Text_1.Result).
Fermé Outils de vision

L'arborescence Outils de vision contient des fonctions de transitions supplémentaires pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Transition, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Transition et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions mathématiques

L'arborescence de fonctions mathématiques contient les fonctions mathématiques pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Mathématiques, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Mathématiques et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions texte

L'arborescence de fonctions texte contient des fonctions permettant de formater les données alphanumériques à afficher et à transmettre, et peut être utilisée pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Texte, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Texte et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Résultats de vision

L'arborescence Résultats de vision contient des données supplémentaires non disponibles par défaut et pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Résultats de vision, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Résultats de vision et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque :
  • La liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
  • EasyBuilder prend uniquement en charge les fonctions de résultats de vision Blobs, Transitions et Modèles.
Fermé Arborescence de symboles de données de projets et d'outils

L'Arborescence de symboles de données de projets et d'outils contient les données de sortie des outils de recherche et/ou d'inspection, ainsi que les lignes d'entrée et des données de projet telles que les paramètres d'acquisition d'images. Les données de projets et d'outils sont des références symboliques aux valeurs figurant dans ces données. Des symboles peuvent être ajoutés à l'Expression par l'une des trois méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée puis cliquez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
  • À l'aide d'un clavier, tapez le nom de la référence symbolique souhaitez directement dans la zone de texte de l'Expression.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer est utilisé pour placer des fonctions mathématiques et des symboles dans l'expression. Sélectionnez la fonction mathématique ou le symbole de votre choix et cliquez sur le bouton Insérer pour l'ajouter dans l'expression.

Remarque : ce contrôle fonctionne en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, le bouton Insérer est activé.
Fermé Boutons de parenthèse gauche, virgule, parenthèse droite

Les boutons de parenthèse gauche, virgule et parenthèse droite sont utilisés pour créer des formules mathématiques. Cliquez sur le bouton approprié pour les insérer dans la formule.

Remarque : ces contrôles fonctionnent en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, les boutons sont activés.


Outil mathématique & logique Mathématiques - Onglet Limites de plages

Fermé Maximum

Définit le nombre maximum acceptable pour la formule ; par défaut, l'outil affecte un maximum de 9 999 999. Vous devez personnaliser cette valeur pour votre application.

Fermé Résultat

Renvoie le résultat de l'expression ; les valeurs exactes ou comprises entre les paramètres Minimum et Maximum sont acceptées.

Fermé Minimum

Définit le nombre minimum acceptable pour la formule ; par défaut, l'outil affecte un maximum de -9 999 999. Vous devez personnaliser cette valeur pour votre application.

Fermé Inverser

Définit si la logique Succès/Échec de l'outil doit être inversée (option désactivée par défaut) :

  • Désactivée - Les résultats standard sont appliqués : le résultat de l'outil est un Succès si la caractéristique a été détectée et correspond aux paramètres spécifiés.
  • Activée - Inverse les résultats : le résultat de l'outil est un Échec si la caractéristique a été détectée et correspond aux paramètres spécifiés.
Fermé Bouton Limites auto

Permet de définir les limites basées sur les paramètres Limites automatiques. Ce bouton permet d’ajuster les limites lorsqu’un paramètre a été modifié, ou qu’un outil a été ajouté et que les limites n’ont pas été définies.

Remarque : Si le résultat de l'Expression renvoie une chaîne de texte, les limites Maximum et Minimum seront désactivées.


Outils mathématiques & logiques - Logique

L'outil mathématique & logique Logique permet de créer une formule de traitement des données ayant réussi et échoué, via des opérateurs logiques booléens standard.

Cet outil renvoie les résultats suivants :

Modèles In-Sight | Résultats
Capteurs de vision In-Sight 2000 Séries 1XX (110, 120, 130) | État Succès/Échec uniquement
Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Résultats standard (aucune limitation)

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil mathématique & logique Logique

Remarque : cet outil requiert que d'autres outils de recherche et/ou d'inspection soient utilisés comme entrées. Regroupez les autres outils de recherche et/ou d'inspection qui seront utilisés comme entrées dans l'outil avant d'ajouter cet outil. Sans cela, vous ne pourrez pas créer les expressions et devrez ajouter les outils de recherche et/ou d'inspection nécessaires puis revenir à cet outil après avoir configuré les autres outils.

Une fois l'outil ajouté, vous devez créer votre expression. La zone de texte Expression permet de créer une formule logique capable de traiter les résultats ayant réussi et abouti de l'outil.

Capteurs de vision In-Sight série 2000

  1. Créez votre Expression en ajoutant le résultat Succès ou Échec de l'outil. Pour entrer un résultat Succès ou Échec dans l'éditeur de formules Expression, sélectionnez le résultat et double-cliquez dessus ou appuyez sur le bouton Insérer.
  2. Une fois que vous avez créé votre Expression, vous pouvez facultativement inverser la logique Succès/Échec de l'outil.
  3. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser vos résultats.
  4. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Systèmes de vision In-Sight

  1. Créez votre Expression en ajoutant le résultat Succès ou Échec de l'outil. Pour entrer un résultat Succès ou Échec dans l'éditeur de formules Expression, sélectionnez le résultat et double-cliquez dessus ou appuyez sur le bouton Insérer.
  2. Une fois que vous avez créé votre Expression, vous pouvez inverser la logique Succès/Échec de l'outil dans l'onglet Options.
  3. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser vos résultats.
  4. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil mathématique & logique Logique

Après avoir ajouté l'outil au projet, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Capteurs de vision In-Sight série 2000

  • Zone de groupe Outil d'édition

Systèmes de vision In-Sight

Le volet de paramètres de l'outil logique mathématique & logique comprend les onglets :

  • Onglet Général
  • Onglet Paramètres
  • Expression
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Capteurs de vision In-Sight série 2000

Systèmes de vision In-Sight

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

Aide EasyBuilder | 08/29/2022 | Revision: 5.9.0.2


Réglage des paramètres de l'outil mathématique & logique Logique

Remarque : Cette rubrique décrit l'interface utilisateur en étant connecté à un capteur de vision In-Sight série 2000. en cas de connexion aux systèmes de vision In-Sight, voir la section Système de vision In-Sight de Réglage des paramètres de l'outil mathématique & logique Logique.
Fermé Expression

La zone de texte Expression permet de créer une formule logique capable de traiter les résultats ayant réussi et abouti de l'outil. Utilisez l'Arborescence de symboles de données de projets et d'outils pour rédiger la formule. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque : Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
Fermé Arborescence de symboles de données de projets et d'outils

L'arborescence de symboles de données de projets et d'outils contient l'édition de résultats ayant réussi et abouti de l'outil par les outils de recherche et/ou d'inspection. Les données de projets et d'outils sont des références symboliques aux valeurs figurant dans ces données. Des symboles peuvent être ajoutés à l'Expression par l'une des deux méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée puis cliquez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer permet de placer des symboles dans l'Expression. Sélectionnez le symbole souhaité puis cliquez sur le bouton Insérer pour ajouter le symbole à l'Expression.

Fermé Boutons Ouvrir les parenthèses, Virgule, Fermer les parenthèses, ET, OU et SAUF

Les boutons Ouvrir les parenthèses, Virgule, Fermer les parenthèses, ET, OU et SAUF permettent de créer des formules. Cliquez sur le bouton approprié pour l'ajouter à la formule.

Fermé Bouton Supprimer

Le bouton Supprimer permet de supprimer de l'Expression les mots ou symboles mis en surbrillance. Mettez en surbrillance le mot ou le symbole pertinent, puis appuyez sur Supprimer.

Fermé Inverser le résultat

Lorsque l'option est activée, l'outil échoue si le résultat est dans les limites de la plage. (Par défaut = Désactivé)

Succès/échec | (Inverser) | Succès/échec
Succès/échec | (Inverser) | Succès/échec
Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Nom

Définit le nom de votre outil d'inspection. Le nom par défaut est Logique_1 (si c'est le premier outil mathématique & logique Logique ajouté au projet, sinon, il est incrémenté, par exemple, Logique_2, Logique_3, etc.).

Fermé Activé

Définit si l'outil d'inspection doit s'exécuter et à quel moment (le paramètre par défaut est Activé).

  • Sélectionnez "Désactivé" pour désactiver l'outil.
  • Sélectionnez une ligne d'entrée pour que l'outil soit associé à une ligne d'entrée discrète spécifique, où il peut être activé ou désactivé (un signal élevé 1 signifie activé, un signal faible 0 signifie désactivé). La connexion de l'outil à une entrée permet à un système de contrôle, un PLC par exemple, de déterminer quels outils doivent s'exécuter, et à quel moment.
Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil logique mathématique & logique - Onglet Général

Fermé Nom de l'outil

Définit le nom de votre outil d'inspection. Le nom par défaut est Logique_1 (si c'est le premier outil mathématique & logique Logique ajouté au projet, sinon, il est incrémenté, par exemple, Logique_2, Logique_3, etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil logique mathématique & logique - Expression

Remarque : ces contrôles sont désactivés lorsque le système de vision In-Sight est en ligne.
Fermé Expression

La zone de texte Expression permet de créer une formule logique capable de traiter les résultats ayant réussi et abouti de l'outil. Utilisez l'Arborescence de symboles de données de projets et d'outils pour rédiger la formule. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque :
  • Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
  • Lors de la création de formules, EasyBuilder ne décompose pas correctement les noms d'outils qui commencent par une adresse de cellule (par ex. A3_MyTool ou P10_SortTool). Si des expressions doivent être créées pour ces outils, renommez l'outil avant de créer la formule.
Fermé Arborescence de symboles de données de projets et d'outils

L'arborescence de symboles de données de projets et d'outils contient l'édition de résultats ayant réussi et abouti de l'outil par les outils de recherche et/ou d'inspection. Les données de projets et d'outils sont des références symboliques aux valeurs figurant dans ces données. Des symboles peuvent être ajoutés à l'Expression par l'une des trois méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée puis cliquez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
  • À l'aide d'un clavier, tapez le nom de la référence symbolique souhaitez directement dans la zone de texte de l'Expression.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer permet de placer des symboles dans l'Expression. Sélectionnez le symbole souhaité puis cliquez sur le bouton Insérer pour ajouter le symbole à l'Expression.

Fermé Boutons Ouvrir les parenthèses, Virgule, Fermer les parenthèses, ET, OU et SAUF

Les boutons Ouvrir les parenthèses, Virgule, Fermer les parenthèses, ET, OU et SAUF permettent de créer des formules. Cliquez sur le bouton approprié pour l'ajouter à la formule.

Fermé Bouton Supprimer

Le bouton Supprimer permet de supprimer de l'Expression les mots ou symboles mis en surbrillance. Mettez en surbrillance le mot ou le symbole pertinent, puis appuyez sur Supprimer.


Outil logique mathématique & logique - Onglet Options

Fermé Résultat

Renvoie le résultat de l'expression.

Fermé Inverser

Définit si le résultat succès ou échec de l'outil doit être inversé :

  • Non coché (par défaut : le résultat succès/échec n'est pas inversé.
  • Coché : le résultat succès/échec est inversé.


Outils mathématiques & logiques - Tendance

L'outil mathématique & logique Tendance renvoie des statistiques de maximum, de minimum, de moyenne, d'échantillon et d'écart standard d'une valeur d'un outil de recherche ou d'inspection ou bien d'une ligne d'entrée pour un nombre spécifié d'échantillons avant la réinitialisation.

L'outil mathématique & logique Tendance est utile lorsque vous voulez accumuler des informations statistiques sur les résultats d'un outil donné pendant une période d'exécution de projets, par exemple pour analyser votre processus de fabrication.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil mathématique & logique Tendance

Une fois l'outil ajouté, définissez la valeur à calculer et configurez les paramètres de l'outil.

  1. Configurez les paramètres sous l'onglet Général en fonction des besoins de votre application.
  2. Cliquez sur l'onglet Paramètres pour définir une valeur sur laquelle accumuler les statistiques. EasyBuilder examine votre application et indique les valeurs pouvant être référencées dans le paramètre Dernière valeur. Sélectionnez une valeur et configurez les autres paramètres de l'onglet.
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil mathématique & logique Tendance

Après avoir ajouté l'outil au projet, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil mathématique & logique Tendance comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Tableau
  • Onglet Valeur
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Valeur

Onglet Tableau


Outil mathématique & logique Tendance - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Tendance_1 » (s'il s'agit du premier outil mathématique & logique Tendance ajouté au projet. Sinon, il est incrémenté par exemple, « Tendance_2 », « Tendance_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil mathématique & logique de tendance - Onglet Paramètres

Fermé Dernière valeur

Permet de définir la valeur qui sera calculée par l’outil ; par défaut, Non-défini est sélectionné, et les statistiques ne sont pas cumulées. Sélectionnez une valeur renvoyée par un outil ou une entrée du projet qui sera utilisée comme données statistiques.

Fermé Exemples max.

Définit le nombre maximum d’exemples (échantillons) utilisés pour obtenir des statistiques de l’outil. Par défaut, 100 exemples sont utilisés. La taille maximale des échantillons, ou exemples, est de 2 à 5 000. Une fois que l’outil a atteint le nombre maximum d’exemples, les valeurs les plus anciennes sont effacées à mesure que les nouvelles sont cumulées.

Fermé Afficher

Définit la valeur calculée à afficher : Dernière valeur, Minimum, Maximum, Moyenne ou Std Dev (Déviation standard). L'option Dernière valeur est sélectionnée par défaut.

Fermé Résultat

Affiche la valeur actuelle calculée, définie dans le paramètre Afficher.

Fermé Bouton Remise à zéro

Remet les données cumulées à 0.

Fermé Remise à zéro en ligne

Définit sil l’outil remet automatiquement le cumul de données à zéro à chaque fois que le système de vision In-Sight est placé En ligne. Par défaut, ce réglage n’est pas activé, il vous faut alors remettre les données à zéro manuellement.

Fermé Réinitialisation du chargement du projet

Définit si l’outil remet automatiquement le cumul de données à zéro à chaque fois que le système de vision In-Sight charge le projet contenant l’outil. Par défaut, ce réglage n’est pas activé, il vous faut alors remettre les données à zéro manuellement.


Outil mathématique & logique Tendance - Onglet Valeur

Affiche une représentation graphique de la valeur sous forme de diagramme.


Outil mathématique & logique Tendance - Onglet Tableau

Le tableau de l'outil mathématique & logique Tendance affiche les résultats accumulés de la valeur définie dans le paramètre Dernière valeur, par le nombre d'échantillons défini dans le paramètre Exemples max. de l'onglet Paramètres.


Outils mathématiques & logiques - Statistiques

L'outil mathématique & logique Statistiques renvoie des statistiques de maximum, de minimum, de moyenne, d'échantillon et d'écart standard d'une valeur d'un outil de recherche ou d'inspection ou bien d'une ligne d'entrée.

L'outil mathématique & logique Statistique est utile lorsque vous voulez accumuler des informations statistiques sur les résultats d'un outil donné, par exemple pour analyser votre processus de fabrication.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil mathématique & logique Statistiques

Une fois l'outil ajouté, définissez la valeur à calculer et configurez les paramètres de l'outil.

  1. Configurez les paramètres sous l'onglet Général en fonction des besoins de votre application.
  2. Cliquez sur l'onglet Paramètres pour définir une valeur sur laquelle accumuler les statistiques. EasyBuilder examine votre application et indique les valeurs pouvant être référencées dans le paramètre Dernière valeur. Sélectionnez une valeur et configurez les autres paramètres de l'onglet.
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil mathématique & logique Statistiques

Après avoir ajouté l'outil au projet, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil mathématique & logique Statistiques comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Tableau
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Tableau


Outil mathématique & logique Statistiques - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Statistiques_1 » (s'il s'agit du premier outil mathématique & logique Statistiques ajouté au projet. Sinon, il est incrémenté par exemple, « Statistiques_2 », « Statistiques_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil mathématique & logique Statistiques - Onglet Paramètres

Fermé Dernière valeur

Définit la valeur qui sera calculée par l'outil. « Indéfini » est sélectionné par défaut, et aucune statistique n'est collectée. Sélectionnez une valeur renvoyée par un outil ou une entrée dans le projet pour accumuler les statistiques de la valeur de cet outil ou de cette entrée.

Fermé Affichage

Définit la valeur calculée à afficher : Dernière valeur, Minimum, Maximum, Moyenne ou Écart type. « Dernière valeur » est sélectionné par défaut.

Fermé Résultat

Affiche la valeur calculée actuelle définie dans le paramètre Affichage.

Fermé Compter hors ligne

Définit si les résultats doivent ou non inclure les images acquises lorsque le système de vision In-Sight est hors ligne. Ce paramètre est coché par défaut, et les statistiques sont accumulées lorsque le système de vision est hors ligne. Décochez la case pour n'accumuler les statistiques que lorsque le système de vision In-Sight est en ligne.

Fermé Bouton Remise à zéro

Remet l'accumulation des données à 0.

Fermé Remise à zéro en ligne

Définit si l'outil remet ou non automatiquement l'accumulation des données à zéro à chaque fois que le système de vision In-Sight est mis en ligne. Ce paramètre est désactivé par défaut, ce qui nécessite une remise à zéro manuelle.

Fermé Réinitialisation du chargement du projet

Définit si l'outil remet ou non automatiquement l'accumulation des données à zéro à chaque fois que le système de vision In-Sight charge le projet auquel il appartient. Ce paramètre est désactivé par défaut, ce qui nécessite une remise à zéro manuelle.


Outil mathématique & logique Statistiques - Tableau

Le tableau de l'outil mathématique & logique Statistiques affiche les résultats accumulés de la valeur définie dans le paramètre Dernière valeur de l'onglet Paramètres.


Outils mathématiques & logiques - Outil Groupe

L'outil mathématique & logique Groupe combine des outils de recherche et/ou d'inspection dans un groupe et crée un état d'activation partagé entre les outils du groupe, qui lie leur exécution.

L'outil mathématique & logique Groupe permet, par exemple, de déterminer si une caractéristique de produit unique réussit lorsque plusieurs outils sont utilisés, pour des projets qui requièrent plusieurs acquisitions ou des projets qui incluent un grand nombre d'outils.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil mathématique & logique Groupe

Remarque : cet outil requiert que d'autres outils de recherche et/ou d'inspection soient utilisés comme entrées. Regroupez les autres outils de recherche et/ou d'inspection qui seront utilisés comme entrées dans l'outil avant d'ajouter cet outil. Sans cela, vous ne pourrez pas créer les expressions et devrez ajouter les outils de recherche et/ou d'inspection nécessaires puis revenir à cet outil après avoir configuré les autres outils.

Une fois l'outil ajouté, définissez les outils à intégrer au groupe.

  1. Après avoir ajouté l'outil, EasyBuilder examine votre projet et dresse la liste de tous les outils qu'il contient dans la colonne de gauche de l'onglet Groupe d'outils.
  2. Sélectionnez les outils à intégrer dans le groupe (en maintenant la touche CTRL enfoncée pour sélectionner plusieurs outils non consécutifs, ou la touche MAJ pour sélectionner une suite d'outils consécutifs), puis cliquez sur le bouton Ajouter.
  3. Une fois le groupe créé, vous pouvez sélectionner l'onglet Activer l'expression pour y créer une expression personnalisée qui fournisse la logique permettant de contrôler l'exécution du groupe. Par défaut, l'expression est définie sur 1, ce qui signifie que le groupe est toujours activé.
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil mathématique & logique Groupe

Après avoir ajouté l'outil au projet, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil mathématique & logique Groupe comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Groupe d'outils
  • Onglet Activer l'expression
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Groupe d’outils

Onglet Activer l’expression


Outil mathématique & logique Groupe - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Groupe_1 » (s'il s'agit du premier outil logique & mathématique Groupe ajouté au projet. Sinon, il est incrémenté par exemple, « Groupe_2 », « Groupe_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Remarque : Si vous avez configuré l'onglet Activer l'expression afin d'utiliser une Expression, le paramètre Outil activé doit être défini sur Expression pour fonctionner correctement.
Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil mathématique & logique Groupe - Onglet Paramètres

Fermé ID du groupe

Le numéro d'ID du groupe signale une erreur lorsque les outils de l'outil mathématique & logique Groupe échouent. L'outil mathématique & logique Groupe renvoie un 0 en cas de réussite, et le numéro d'ID du groupe en cas d'échec. L'ID du groupe s'étend de 1 à 9 999 999. Il est défini par défaut sur 10 et n'est pas incrémenté lors de l'ajout d'un nouvel outil mathématique & logique Groupe.


Outil mathématique & logique Groupe - Onglet Groupe d'outils

L'onglet Groupe d'outils permet d'ajouter et de supprimer des outils dans l'outil mathématique & logique Groupe sélectionné.

La liste de gauche affiche les outils non inclus dans le groupe, et celle de droite les outils qui y sont compris. Par défaut, la liste de droite est vide.

Fermé Bouton Ajouter

La sélection d'un outil à gauche active le bouton Ajouter.

  • Pour ajouter des outils, sélectionnez-les individuellement et cliquez sur le bouton Ajouter.
  • Pour sélectionner plusieurs outils non consécutifs, cliquez dessus en maintenant la touche CTRL enfoncée, puis cliquez sur le bouton Ajouter.
  • Pour sélectionner une suite d'outils consécutifs, cliquez sur le premier puis sur le dernier outil de la liste tout en maintenant la touche MAJ enfoncée, puis cliquez sur le bouton Ajouter.
Fermé Bouton Supprimer

La sélection d'un outil à droite active le bouton Supprimer.

  • Pour supprimer des outils, sélectionnez-les individuellement et cliquez sur le bouton Supprimer.
  • Pour sélectionner plusieurs outils non consécutifs, cliquez dessus en maintenant la touche CTRL enfoncée, puis cliquez sur le bouton Supprimer.
  • Pour sélectionner une suite d'outils consécutifs, cliquez sur le premier puis sur le dernier outil de la liste tout en maintenant la touche MAJ enfoncée, puis cliquez sur le bouton Ajouter.
Remarque :
  • Un outil ne peut appartenir qu'à un seul outil mathématique & logique Groupe. Pour transférer un outil d'un outil mathématique & logique Groupe à un autre, il doit d'abord être supprimé du premier outil mathématique & logique Groupe avant de pouvoir être ajouté dans l'autre.
  • Un outil mathématique & logique Groupe ne peut pas contenir un autre outil mathématique & logique Groupe.
  • Lors du copier/coller d'un outil mathématique & logique Groupe, tous les outils qui y sont inclus sont également copiés et collés.
  • Lors de la suppression d'un outil mathématique & logique Groupe, un message de confirmation s'affiche ; la suppression d'un outil mathématique & logique Groupe supprime en effet tous les outils qu'il contient. Si vous ne voulez pas supprimer les outils du groupe, retirez-les du groupe avant de supprimer l'outil mathématique & logique Groupe.


Outil mathématique & logique de groupe - Onglet Activer l'expression

Remarque : ces contrôles sont désactivés lorsque le système de vision In-Sight est en ligne.

L'onglet Activer l'expression permet de construire une formule mathématique qui détermine l'exécution de l'outil ; par défaut , l'Expression est configurée sur 1, ce qui signifie que l'outil exécute toujours un déclencheur d'acquisition. Pour activer ce contrôle, le contrôle Outil activé de l'onglet Général doit être configuré sur Expression.

Capteurs de vision In-Sight 2000-130/130C

Fermé Expression

La zone de texte Expression permet de créer une formule logique capable de traiter les résultats ayant réussi et abouti de l'outil. Utilisez l'Arborescence de symboles de données de projets et d'outils pour rédiger la formule. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque : Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
Fermé Arborescence des symboles de données de projets et d'outils

L'Arborescence des symboles de données de projets et d'outils contient la sortie des résultats de réussite et d'échec de l'outil par les outils de position et/ou d'inspection. Les données de projets et d'outils sont des références symboliques vers les valeurs qui s'y trouvent. Il est possible d'ajouter des symboles à l'Expression selon l'une des deux méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée et appuyez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer permet de placer des symboles dans l'Expression. Sélectionnez le symbole souhaité puis cliquez sur le bouton Insérer pour ajouter le symbole à l'Expression.

Fermé Boutons Parenthèse ouvrante, virgule, parenthèse fermante, ET, OU et SAUF

Les boutons Ouvrir les parenthèses, Virgule, Fermer les parenthèses, ET, OU et SAUF permettent de créer des formules. Cliquez sur le bouton approprié pour l'ajouter à la formule.

Fermé Bouton Supprimer

Le bouton Supprimer permet de supprimer de l'Expression les mots ou symboles mis en surbrillance. Mettez en surbrillance le mot ou le symbole pertinent, puis appuyez sur Supprimer.

Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230)

Remarque : pour lier l'exécution d'un Outil mathématique et logique de groupe et d'un Outil mathématique et logique séquence, l'Expression de l'Outil mathématique et logique de groupe doit être configurée sur l'outil mathématique et logique Séquence (par exemple « Séquence_1. Étape_actuelle =1 ») et le contrôle Outil activé dans l'onglet Général doit être configuré sur Expression.
Fermé Expression

La zone de texte Expression permet de créer une formule mathématique capable de traiter les résultats et données de l'outil. Pour rédiger la formule, entrez les données en saisissant, sur le clavier, le nom de la fonction mathématique ou les données du projet/de l'outil ou en utilisant l'arborescence Outils de vision, Mathématiques, Texte et/ou Résultats de vision à gauche, et l'arborescence de symboles de données de projets et d'outils, à droite. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque :
  • Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
  • Lors de la création de formules, EasyBuilder ne décompose pas correctement les noms d'outils qui commencent par une adresse de cellule (par ex. A3_MyTool ou P10_SortTool). Si des expressions doivent être créées pour ces outils, renommez l'outil avant de créer la formule.
Fermé Outils de vision

L'arborescence Outils de vision contient des fonctions de transitions supplémentaires pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Transition, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Transition et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions mathématiques

L'arborescence de fonctions mathématiques contient les fonctions mathématiques pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Mathématiques, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Mathématiques et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions texte

L'arborescence de fonctions texte contient des fonctions permettant de formater les données alphanumériques à afficher et à transmettre, et peut être utilisée pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Texte, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Texte et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Résultats de vision

L'arborescence Résultats de vision contient des données supplémentaires non disponibles par défaut et pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Résultats de vision, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Résultats de vision et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque :
  • La liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
  • EasyBuilder prend uniquement en charge les fonctions de résultats de vision Blobs, Transitions et Modèles.
Fermé Arborescence de symboles de données de projets et d'outils

L'Arborescence de symboles de données de projets et d'outils contient les données de sortie des outils de recherche et/ou d'inspection, ainsi que les lignes d'entrée et des données de projet telles que les paramètres d'acquisition d'images. Les données de projets et d'outils sont des références symboliques aux valeurs figurant dans ces données. Des symboles peuvent être ajoutés à l'Expression par l'une des trois méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée puis cliquez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
  • À l'aide d'un clavier, tapez le nom de la référence symbolique souhaitez directement dans la zone de texte de l'Expression.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer est utilisé pour placer des fonctions mathématiques et des symboles dans l'expression. Sélectionnez la fonction mathématique ou le symbole de votre choix et cliquez sur le bouton Insérer pour l'ajouter dans l'expression.

Remarque : ce contrôle fonctionne en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, le bouton Insérer est activé.
Fermé Boutons de parenthèse gauche, virgule, parenthèse droite

Les boutons de parenthèse gauche, virgule et parenthèse droite sont utilisés pour créer des formules mathématiques. Cliquez sur le bouton approprié pour les insérer dans la formule.

Remarque : ces contrôles fonctionnent en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, les boutons sont activés.


Outils mathématiques & logiques - Séquence

L'outil mathématique & logique Séquence définit le nombre d'étapes des projets nécessitant plusieurs acquisitions d'images ou étapes dans le processus d'assemblage. Cet outil est utilisé avec l'outil mathématique & logique Groupe pour contrôler l'exécution séquentielle des outils dans le groupe.

L'outil mathématique & logique Séquence permet notamment de synchroniser l'acquisition des images ou l'exécution des outils d'inspection sur la séquence de votre processus d'assemblage/de production. Par exemple, si vous fabriquez une pièce et souhaitez l'inspecter au cours de différentes étapes de l'assemblage pour décider si vous devez, ou non, continuer en fonction des résultats d'une séquence particulière dans le processus d'assemblage.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil mathématique & logique Séquence

Une fois l'outil ajouté, configurez-en les paramètres.

  1. Configurez les paramètres sous l'onglet Général en fonction des besoins de votre application.

  2. Cliquez sur l'onglet Paramètres et configurez les paramètres en fonction des besoins de votre application.

    Remarque : pour lier l'exécution d'un outil mathématique & logique Groupe et d'un outil mathématique & logique Séquence, l'expression de l'outil mathématique & logique Groupe doit être définie à l'aide du symbole Étape_actuelle de l'outil mathématique & logique Séquence. Exemple : Groupe_1.Activer=Séquence_1.Étape_actuelle=1
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil mathématique & logique Séquence

Après avoir ajouté l'outil au projet, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil mathématique & logique Séquence comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres


Outil mathématique & logique Séquence - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Étape_1 » (s'il s'agit du premier outil mathématique & logique Séquence ajouté au projet. Sinon, il est incrémenté par exemple, « Étape_2 », « Étape_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil mathématique & logique Séquence - Onglet Paramètres

Fermé Étapes

Définit le nombre d'étapes contrôlées par l'outil. 4 étapes sont utilisées par défaut.

Fermé Bouton Réinitialiser l'étape

Réinitialise et redémarre la séquence, en commençant par l'étape initiale lors de la prochaine acquisition.

Fermé Prochaine étape activée

Définit si le paramètre Prochaine étape sera ou non contrôlé par un périphérique externe. Par défaut, ce paramètre n'est pas activé et donc non contrôlé par un périphérique externe. Lorsque ce paramètre est activé, le numéro d'étape transmis à l'outil par le périphérique externe devient l'étape actuelle lors de la prochaine acquisition. Dans cette configuration, les étapes ne doivent pas nécessairement être effectuées de manière séquentielle et certaines étapes peuvent être omises, en fonction du numéro d'étape entré (par exemple si le nombre d'étapes était de 6 et l'outil se trouvait actuellement à l'étape 2 lorsqu'il a reçu l'entrée Prochaine étape 5, les étapes 3 et 4 seraient omises).

Fermé Prochaine étape

Définit l'étape qui doit commencer la prochaine étape dans la séquence. 1 est sélectionné par défaut. Ce contrôle est uniquement activé si le paramètre Prochaine étape activée est activé. Pour réinitialiser l'outil à partir d'un périphérique externe, tel qu'un automate programmable ou un panneau d'interface opérateur VisionView®, cochez la case Prochaine étape activée et configurez le type de données Next_Step du paramètre Étape suivante de l'étape Communication.

Fermé Étape actuelle

Indique l'étape active ; par défaut, 1.000 est affiché et définit l'étape actuelle.


Outils mathématiques & logiques - Calcul du point

L'outil mathématique & logique Calcul du point permet de calculer un point dans l'image en fonction d'expressions mathématiques liées aux sorties d'autres outils de recherche et/ou d'inspection, qui peut être utilisé comme référence par d'autres outils. L'outil renvoie les coordonnées X, Y du point calculé.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

L'outil mathématique & logique Calcul du point s'avère utile pour identifier, par programme, un point de l'image qui puisse être utilisé comme référence par d'autres outils, par opposition à un point statique défini graphiquement dans l'image, comme celui d'un outil géométrique de définition manuelle d'un point. Par exemple, si vous souhaitez placer le point dans l'image en fonction du résultat d'une fonction mathématique ou du résultat d'un outil spécifique (comme le point médian d'une transition localisée par un outil de présence/absence de transition), l'outil mathématique & logique Calcul du point peut être configuré pour utiliser les résultats de ces outils comme entrées pour calculer le point. La position du point dans l'image change en conséquence, pour refléter la sortie des outils référencés. Le point calculé peut également être utilisé par les outils mathématiques Mathématiques & logique pour prendre d'autres décisions logiques basées sur le point.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil mathématique & logique Calcul du point

Remarque : cet outil requiert que d'autres outils de recherche et/ou d'inspection soient utilisés comme entrées. Regroupez les autres outils de recherche et/ou d'inspection qui seront utilisés comme entrées dans l'outil avant d'ajouter cet outil. Sans cela, vous ne pourrez pas créer les expressions et devrez ajouter les outils de recherche et/ou d'inspection nécessaires puis revenir à cet outil après avoir configuré les autres outils.

Une fois l'outil ajouté, il vous faudra créer l'expression pour les valeurs X et Y.

  1. Créez chaque Expression en sélectionnant puis en entrant les fonctions mathématiques côté gauche du volet de paramètres et/ou les valeurs (données de projet et d'outil) côté droit. Pour entrer une fonction ou une valeur dans l'éditeur de formules Expression, sélectionnez la fonction ou la valeur et appuyez sur la touche Entrée, double-cliquez sur la fonction ou la valeur ou appuyez sur le bouton Insérer.
  2. Une fois les Expressions créées, l'outil insère une icône de point dans l'image, indiquant l'emplacement du point calculé.
  3. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  4. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil mathématique & logique Calcul du point

Après avoir ajouté l'outil au projet, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil mathématique & logique Calcul du point comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglets X et Y
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglets X, Y


Outil mathématique & logique Calcul du point - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Point_1 » (s'il s'agit du premier outil mathématique & logique Calcul du point ajouté au projet, ou d'un autre outil géométrique de définition de point ayant été ajouté auparavant. Sinon, il est incrémenté par exemple, « Point_2 », « Point_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique..

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil mathématique & logique Calcul du point - Onglet Paramètres

Fermé Résultat

Affiche le résultat des expressions X et Y calculées.


Outil mathématique & logique Calcul du point - Onglets X, Y

Remarque : ces contrôles sont désactivés lorsque le système de vision In-Sight est en ligne.

Les onglets X et Y permettent de créer les formules mathématiques qui définiront les coordonnées X et Y du point.

Fermé Expression

La zone de texte Expression permet de créer une formule mathématique capable de traiter les résultats et données de l'outil. Pour rédiger la formule, entrez les données en saisissant, sur le clavier, le nom de la fonction mathématique ou les données du projet/de l'outil ou en utilisant l'arborescence Outils de vision, Mathématiques, Texte et/ou Résultats de vision à gauche, et l'arborescence de symboles de données de projets et d'outils, à droite. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque :
  • Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
  • Lors de la création de formules, EasyBuilder ne décompose pas correctement les noms d'outils qui commencent par une adresse de cellule (par ex. A3_MyTool ou P10_SortTool). Si des expressions doivent être créées pour ces outils, renommez l'outil avant de créer la formule.
Fermé Outils de vision

L'arborescence Outils de vision contient des fonctions de transitions supplémentaires pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Transition, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Transition et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions mathématiques

L'arborescence de fonctions mathématiques contient les fonctions mathématiques pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Mathématiques, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Mathématiques et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions texte

L'arborescence de fonctions texte contient des fonctions permettant de formater les données alphanumériques à afficher et à transmettre, et peut être utilisée pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Texte, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Texte et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Résultats de vision

L'arborescence Résultats de vision contient des données supplémentaires non disponibles par défaut et pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Résultats de vision, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Résultats de vision et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque :
  • La liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
  • EasyBuilder prend uniquement en charge les fonctions de résultats de vision Blobs, Transitions et Modèles.
Fermé Arborescence de symboles de données de projets et d'outils

L'Arborescence de symboles de données de projets et d'outils contient les données de sortie des outils de recherche et/ou d'inspection, ainsi que les lignes d'entrée et des données de projet telles que les paramètres d'acquisition d'images. Les données de projets et d'outils sont des références symboliques aux valeurs figurant dans ces données. Des symboles peuvent être ajoutés à l'Expression par l'une des trois méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée puis cliquez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
  • À l'aide d'un clavier, tapez le nom de la référence symbolique souhaitez directement dans la zone de texte de l'Expression.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer est utilisé pour placer des fonctions mathématiques et des symboles dans l'expression. Sélectionnez la fonction mathématique ou le symbole de votre choix et cliquez sur le bouton Insérer pour l'ajouter dans l'expression.

Remarque : ce contrôle fonctionne en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, le bouton Insérer est activé.
Fermé Boutons de parenthèse gauche, virgule, parenthèse droite

Les boutons de parenthèse gauche, virgule et parenthèse droite sont utilisés pour créer des formules mathématiques. Cliquez sur le bouton approprié pour les insérer dans la formule.

Remarque : ces contrôles fonctionnent en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, les boutons sont activés.


Outils mathématiques & logiques - Variables

L'outil mathématique & logique Variables définit les entiers, valeurs à virgule flottante ou chaînes de texte pouvant être saisis dans le projet à partir d'un périphérique externe. Ces valeurs peuvent ensuite être référencées par d'autres outils de recherche ou d'inspection, ou d'autres périphériques externes, tels qu'un automate programmable ou un panneau d'interface opérateur VisionView®.

L'outil mathématique & logique Variables permet notamment de saisir une valeur dans un outil de recherche ou d'inspection depuis un périphérique externe, tel qu'un automate programmable, ou sous forme de valeur dans l'expression d'un outil mathématique & logique Mathématiques ou outil mathématique & logique Groupe. Par exemple, si vous avez une application dans laquelle vous souhaitez intégrer une chaîne de texte pour un outil d'identification Lire le texte, un entier pour contrôler le nombre de blobs à rechercher à l'aide d'un outil de comptage de blobs et une valeur à virgule flottante dans la formule d'exécution d'un outil mathématique & logique Groupe, ces valeurs peuvent être créées dans l'outil mathématique & logique Variables puis être référencées symboliquement par d'autres outils ou dans l'étape Communication.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil mathématique & logique Variables

Une fois l'outil ajouté, il vous faudra définir les valeurs qui seront utilisées comme variables d'entrée.

  1. Configurez les paramètres dans l'onglet Général selon votre application.
  2. Dans le volet de paramètres à côté de l'onglet Général se trouve le Tableau de variables d'entrée. Appuyez sur le bouton Ajouter des valeurs de type Boolean si votre valeur est une valeur logique booléenne ; appuyez sur le bouton Ajouter un nombre entier si votre valeur est un nombre entier ; appuyez sur le bouton Ajouter une virgule flottante si votre valeur est une valeur à virgule flottante ; appuyez sur le bouton Ajouter chaîne si votre valeur est une chaîne de texte.
  3. Une fois vos variables d'entrée ajoutées, vous pouvez les personnaliser pour répondre aux besoins spécifiques de votre application.
  4. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.

  5. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

    Remarque : Pour supprimer une variable de la liste, cochez la case à côté de la variable puis appuyez sur le bouton Supprimer (la case doit être cochée pour activer le bouton Supprimer).


Réglage des paramètres de l'outil mathématique & logique Variables

Après avoir ajouté l'outil au projet, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil mathématique & logique Variables comprend les éléments suivants :

  • Onglet Général
  • Tableau de variables d'entrée
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Tableau de variables d’entrée


Outil mathématique & logique Variables - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Variables_1 » (s'il s'agit du premier outil mathématique & logique Variables ajouté au projet. Sinon, il est incrémenté par exemple, « Variables_2 », « Variables_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil mathématique et logique Variables - Tableau de variables d'entrée

Le tableau de variables d'entrée de l'outil mathématique et logique Variables permet d'ajouter, de modifier et de supprimer des variables d'entrée. Chaque outil mathématique et logique Variables peut comprendre jusqu'à 32 variables d'entrée.

Fermé Ajouter une valeur booléenne

Cliquez sur le bouton Ajouter une valeur booléenne s'il s'agit d'une valeur de logique booléenne ; la valeur booléenne ajoutée par défaut est 0 (cochez la case à droite pour définir la valeur booléenne sur 1) et le nom attribué est Booléenne0 (s'il s'agit de la première valeur booléenne ajoutée à l'outil, sinon son nom sera incrémenté, par ex. « Booléenne1 », « Booléenne2 », etc.). Personnalisez la valeur en lui attribuant un nom associé à votre application spécifique.

Fermé Bouton Ajouter un entier

Cliquez sur le bouton Ajouter un entier si la valeur est un nombre entier. Par défaut, l'entier ajouté est 0 et son nom « Entier0 » s'il s'agit de la première valeur entière ajoutée à l'outil. Sinon, il est incrémenté (par exemple, « Entier1 », « Entier2 », etc.). Personnalisez la valeur en lui attribuant un nom associé à votre application spécifique. Les entiers peuvent être compris entre 9 999 999 et -9 999 999.

Fermé Bouton Ajouter une virgule flottante

Cliquez sur le bouton Ajouter une virgule flottante si la valeur est à virgule flottante. Par défaut, la virgule flottante est 0 et son nom « Virgule flottante0 » s'il s'agit de la première valeur à virgule flottante ajoutée à l'outil. Sinon, il est incrémenté (par exemple, « Virgule flottante1 », « Virgule flottante2 », etc.). Personnalisez la valeur en lui attribuant un nom associé à votre application spécifique. Les valeurs à virgule flottante peuvent être comprises entre 9 999 999 et -9 999 999.

Fermé Bouton Ajouter une chaîne

Cliquez sur le bouton Ajouter une chaîne si la valeur est une chaîne de texte. Par défaut, la zone de saisie de la chaîne de texte est vide et son nom « Chaîne0 » s'il s'agit de la première chaîne de texte ajoutée à l'outil. Sinon, il est incrémenté (par exemple, « Chaîne1 », « Chaîne2 », etc.). Personnalisez la valeur en lui attribuant un nom associé à votre application spécifique. Les chaînes de texte peuvent comprendre jusqu'à 32 caractères.

Fermé Bouton Supprimer

Cliquez sur le bouton Supprimer pour supprimer une valeur du tableau. Pour supprimer une variable de la liste, cochez la case située à gauche de la variable et cliquez sur le bouton Supprimer (la case doit être cochée pour activer le bouton Supprimer).


Outils mathématiques & logiques – Guidage de robot

L’outil Mathématiques et logique de guidage de robot permet au système de vision de communiquer la position de la pièce au robot.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l’outil Guidage de robot

Astuce : une fois le calibrage configuré, il est recommandé d'enregistrer le fichier de projet. Pour les prochains calibrages, il suffira alors de charger le projet de calibrage, d'acquérir l'image puis d'exporter automatiquement le fichier de calibrage mis à jour dans tous les projets qui l'utilisent.

Une fois l’outil ajouté, vous devez définir les caractéristiques de l’entrée (points, origines de l’outil ou le centre des caractéristiques circulaires) qui seront utilisées pour créer le calibrage :

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features (points, origines de repères ou centre de caractéristiques circulaires) qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert). EasyBuilder insère automatiquement un outil de présence/absence de cercle pour chacune des caractéristiques circulaires pas encore définies.

  2. Sélectionnez une des caractéristiques dans la liste de celles disponibles en cliquant dessus, sa couleur passe alors au magenta.

  3. Après avoir sélectionné la caractéristique, appuyez sur le bouton OK (appuyez sur Annuler pour ne pas ajouter l’outil au projet).

  4. Enregistrez le fichier de projet.
  5. Avec l'outil initialement configuré, ajustez ses paramètres selon vos besoins.
  6. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l’outil Guidage de robot

Après avoir ajouté l'outil au projet, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil de calibrage du Guidage de robot comprend les onglets suivants :

  • Onglet Général

Onglet Général


Outil Guidage de robot – Onglet Général

Fermé Nom d'outil

Permet de définit le nom de votre outil d’inspection, celui-ci sera utilisé pour la configuration des résultats (Configurer image, Entrées/sorties et Communication) ; le nom par défaut est « Guidance_1 ». Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique. Vous ne pouvez ajouter qu’un seul Outil Guidage de robot à un projet.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outils de tracé - Arc

L'outil de tracé d'arc permet de tracer un graphique en arc sur une image à l'aide d'expressions mathématiques qui en définissent les valeurs suivantes : Centre X, Centre Y, Rayon, Angle de départ et Portée. L'outil trace le graphique sur l'image et renvoie les valeurs qui définissent l'arc.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de tracé d'arc

Une fois l'outil ajouté, créez les expressions qui définiront le graphique.

  1. Pour créer les expressions mathématiques qui seront utilisées pour définir le graphique, sélectionnez et insérez des fonctions mathématiques du côté gauche du volet de paramètres, et des valeurs (données d'outils et de projets) du côté droit. Pour entrer une fonction ou une valeur dans l'éditeur de formules de l'expression, sélectionnez la fonction ou la valeur et appuyez sur la touche Entrée, double-cliquez sur la fonction ou la valeur ou cliquez sur le bouton Insérer.
  2. Une fois que vous avez créé les expressions qui définiront le graphique tracé sur l'image, EasyBuilder traite les données et crée le graphique.
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de tracé d'arc

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de tracé d'arc comprend les onglets suivants :

  • Onglets Général et Paramètres
  • Onglets Expression Centre X, Centre Y, Rayon, Angle de départ et Portée
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglets Général et Paramètres

Onglets Expression Centre X, Centre Y, Rayon, Angle de départ et Portée.


Outil de tracé d'arc - Onglets Général et Paramètres

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Arc_1 » s'il s'agit du premier outil de tracé d'arc ajouté au projet. Sinon, il est incrémenté (par exemple, « Arc_2 », « Arc_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Fermé Onglet Paramètres
Fermé Couleur

Définit la couleur du graphique affiché. La couleur par défaut est celle actuellement utilisée par les autres outils du projet.

Fermé Résultat

Renvoie le résultat des onglets Expression de l'outil ; affiche les valeurs X, Y, Rayon, Angle de départ et Portée de l'arc.


Outil de tracé d'arc - Onglets Expression Centre X, Centre Y, Rayon, Angle de départ et Portée

L'outil de tracé d'arc se compose des onglets Expression suivants (partageant tous les mêmes contrôles) pour créer le graphique tracé : Onglets Expression Centre X, Centre Y, Rayon, Angle de départ et Portée. Si un des onglets Expression affiche un état d'erreur (#ERR), le graphique n'est pas tracé dans l'image et un message d'erreur indiquant le ou les onglets Expression erronés est renvoyé.

Remarque : ces contrôles sont désactivés lorsque le système de vision In-Sight est en ligne.
Fermé Expression

La zone de texte Expression permet de créer une formule mathématique capable de traiter les résultats et données de l'outil. Pour rédiger la formule, entrez les données en saisissant, sur le clavier, le nom de la fonction mathématique ou les données du projet/de l'outil ou en utilisant l'arborescence Outils de vision, Mathématiques, Texte et/ou Résultats de vision à gauche, et l'arborescence de symboles de données de projets et d'outils, à droite. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque :
  • Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
  • Lors de la création de formules, EasyBuilder ne décompose pas correctement les noms d'outils qui commencent par une adresse de cellule (par ex. A3_MyTool ou P10_SortTool). Si des expressions doivent être créées pour ces outils, renommez l'outil avant de créer la formule.
Fermé Outils de vision

L'arborescence Outils de vision contient des fonctions de transitions supplémentaires pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Transition, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Transition et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions mathématiques

L'arborescence de fonctions mathématiques contient les fonctions mathématiques pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Mathématiques, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Mathématiques et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions texte

L'arborescence de fonctions texte contient des fonctions permettant de formater les données alphanumériques à afficher et à transmettre, et peut être utilisée pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Texte, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Texte et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Résultats de vision

L'arborescence Résultats de vision contient des données supplémentaires non disponibles par défaut et pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Résultats de vision, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Résultats de vision et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque :
  • La liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
  • EasyBuilder prend uniquement en charge les fonctions de résultats de vision Blobs, Transitions et Modèles.
Fermé Arborescence de symboles de données de projets et d'outils

L'Arborescence de symboles de données de projets et d'outils contient les données de sortie des outils de recherche et/ou d'inspection, ainsi que les lignes d'entrée et des données de projet telles que les paramètres d'acquisition d'images. Les données de projets et d'outils sont des références symboliques aux valeurs figurant dans ces données. Des symboles peuvent être ajoutés à l'Expression par l'une des trois méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée puis cliquez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
  • À l'aide d'un clavier, tapez le nom de la référence symbolique souhaitez directement dans la zone de texte de l'Expression.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer est utilisé pour placer des fonctions mathématiques et des symboles dans l'expression. Sélectionnez la fonction mathématique ou le symbole de votre choix et cliquez sur le bouton Insérer pour l'ajouter dans l'expression.

Remarque : ce contrôle fonctionne en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, le bouton Insérer est activé.
Fermé Boutons de parenthèse gauche, virgule, parenthèse droite

Les boutons de parenthèse gauche, virgule et parenthèse droite sont utilisés pour créer des formules mathématiques. Cliquez sur le bouton approprié pour les insérer dans la formule.

Remarque : ces contrôles fonctionnent en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, les boutons sont activés.


Outils de tracé - Cercle

L'outil de tracé de cercle sert à tracer un graphique en cercle sur une image à l'aide d'expressions mathématiques qui en définissent les valeurs suivantes : X, Y et Rayon. L'outil trace le graphique sur l'image et renvoie les valeurs qui définissent le cercle.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de tracé de cercle

Une fois l'outil ajouté, créez les expressions qui définiront le graphique.

  1. Pour créer les expressions mathématiques qui seront utilisées pour définir le graphique, sélectionnez et insérez des fonctions mathématiques du côté gauche du volet de paramètres, et des valeurs (données d'outils et de projets) du côté droit. Pour entrer une fonction ou une valeur dans l'éditeur de formules de l'expression, sélectionnez la fonction ou la valeur et appuyez sur la touche Entrée, double-cliquez sur la fonction ou la valeur ou cliquez sur le bouton Insérer.
  2. Une fois que vous avez créé les expressions qui définiront le graphique tracé sur l'image, EasyBuilder traite les données et crée le graphique.
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de tracé de cercle

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de tracé de cercle comprend les onglets suivants :

  • Onglets Général et Paramètres
  • Onglets Expression X, Y et Rayon
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglets Général et Paramètres

Onglets Expression X, Y et Rayon.


Outil de tracé de cercle - Onglets Général et Paramètres

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Cercle_1 » s'il s'agit du premier outil de tracé de cercle ajouté au projet. Sinon, il est incrémenté (par exemple, « Cercle_2 », « Cercle_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Fermé Onglet Paramètres
Fermé Couleur

Définit la couleur du graphique affiché. La couleur par défaut est celle actuellement utilisée par les autres outils du projet.

Fermé Résultat

Renvoie le résultat des onglets Expression de l'outil ; affiche les valeurs X, Y et Rayon du cercle.


Outil de tracé de cercle - Onglets Expression X, Y et Rayon

L'outil de tracé de cercle se compose des onglets Expression suivants (partageant tous les mêmes contrôles) pour créer le graphique tracé : Onglets Expression X, Y et Rayon. Si un des onglets Expression affiche un état d'erreur (#ERR), le graphique n'est pas tracé dans l'image et un message d'erreur indiquant le ou les onglets Expression erronés est renvoyé.

Remarque : ces contrôles sont désactivés lorsque le système de vision In-Sight est en ligne.
Fermé Expression

La zone de texte Expression permet de créer une formule mathématique capable de traiter les résultats et données de l'outil. Pour rédiger la formule, entrez les données en saisissant, sur le clavier, le nom de la fonction mathématique ou les données du projet/de l'outil ou en utilisant l'arborescence Outils de vision, Mathématiques, Texte et/ou Résultats de vision à gauche, et l'arborescence de symboles de données de projets et d'outils, à droite. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque :
  • Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
  • Lors de la création de formules, EasyBuilder ne décompose pas correctement les noms d'outils qui commencent par une adresse de cellule (par ex. A3_MyTool ou P10_SortTool). Si des expressions doivent être créées pour ces outils, renommez l'outil avant de créer la formule.
Fermé Outils de vision

L'arborescence Outils de vision contient des fonctions de transitions supplémentaires pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Transition, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Transition et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions mathématiques

L'arborescence de fonctions mathématiques contient les fonctions mathématiques pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Mathématiques, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Mathématiques et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions texte

L'arborescence de fonctions texte contient des fonctions permettant de formater les données alphanumériques à afficher et à transmettre, et peut être utilisée pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Texte, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Texte et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Résultats de vision

L'arborescence Résultats de vision contient des données supplémentaires non disponibles par défaut et pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Résultats de vision, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Résultats de vision et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque :
  • La liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
  • EasyBuilder prend uniquement en charge les fonctions de résultats de vision Blobs, Transitions et Modèles.
Fermé Arborescence de symboles de données de projets et d'outils

L'Arborescence de symboles de données de projets et d'outils contient les données de sortie des outils de recherche et/ou d'inspection, ainsi que les lignes d'entrée et des données de projet telles que les paramètres d'acquisition d'images. Les données de projets et d'outils sont des références symboliques aux valeurs figurant dans ces données. Des symboles peuvent être ajoutés à l'Expression par l'une des trois méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée puis cliquez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
  • À l'aide d'un clavier, tapez le nom de la référence symbolique souhaitez directement dans la zone de texte de l'Expression.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer est utilisé pour placer des fonctions mathématiques et des symboles dans l'expression. Sélectionnez la fonction mathématique ou le symbole de votre choix et cliquez sur le bouton Insérer pour l'ajouter dans l'expression.

Remarque : ce contrôle fonctionne en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, le bouton Insérer est activé.
Fermé Boutons de parenthèse gauche, virgule, parenthèse droite

Les boutons de parenthèse gauche, virgule et parenthèse droite sont utilisés pour créer des formules mathématiques. Cliquez sur le bouton approprié pour les insérer dans la formule.

Remarque : ces contrôles fonctionnent en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, les boutons sont activés.


Outils de tracé - Croix

L'outil de tracé de croix sert à tracer un graphique en croix sur une image à l'aide d'expressions mathématiques qui en définissent les valeurs suivantes : X, Y et Angle. L'outil trace le graphique sur l'image et renvoie les valeurs qui définissent la croix.

Remarque :
  • L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.
  • Le résultat renvoyé par l'outil de tracé de croix peut être utilisé comme Repère par d'autres outils.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de tracé de croix

Une fois l'outil ajouté, créez les expressions qui définiront le graphique.

  1. Pour créer les expressions mathématiques qui seront utilisées pour définir le graphique, sélectionnez et insérez des fonctions mathématiques du côté gauche du volet de paramètres, et des valeurs (données d'outils et de projets) du côté droit. Pour entrer une fonction ou une valeur dans l'éditeur de formules de l'expression, sélectionnez la fonction ou la valeur et appuyez sur la touche Entrée, double-cliquez sur la fonction ou la valeur ou cliquez sur le bouton Insérer.
  2. Une fois que vous avez créé les expressions qui définiront le graphique tracé sur l'image, EasyBuilder traite les données et crée le graphique.
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de tracé de croix

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de tracé de croix comprend les onglets suivants :

  • Onglet Général et Paramètres
  • Onglets Expression X, Y et Angle
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglets Général et Paramètres

Onglets Expression X, Y et Angle.


Outil de tracé de croix - Onglets Général et Paramètres

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Croix_1 » s'il s'agit du premier outil de tracé de croix ajouté au projet. Sinon, il est incrémenté (par exemple, « Croix_2 », « Croix_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Fermé Onglet Paramètres
Fermé Couleur

Définit la couleur du graphique affiché. La couleur par défaut est celle actuellement utilisée par les autres outils du projet.

Fermé Résultat

Renvoie le résultat des onglets Expression de l'outil ; affiche les valeurs X, Y et Angle de la croix.


Outil de tracé de croix - Onglets Expression X, Y et Angle

L'outil de tracé de croix se compose des onglets Expression suivants (partageant tous les mêmes contrôles) pour créer le graphique tracé : Onglets Expression X, Y et Angle. Si un des onglets Expression affiche un état d'erreur (#ERR), le graphique n'est pas tracé dans l'image et un message d'erreur indiquant le ou les onglets Expression erronés est renvoyé.

Remarque : ces contrôles sont désactivés lorsque le système de vision In-Sight est en ligne.
Fermé Expression

La zone de texte Expression permet de créer une formule mathématique capable de traiter les résultats et données de l'outil. Pour rédiger la formule, entrez les données en saisissant, sur le clavier, le nom de la fonction mathématique ou les données du projet/de l'outil ou en utilisant l'arborescence Outils de vision, Mathématiques, Texte et/ou Résultats de vision à gauche, et l'arborescence de symboles de données de projets et d'outils, à droite. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque :
  • Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
  • Lors de la création de formules, EasyBuilder ne décompose pas correctement les noms d'outils qui commencent par une adresse de cellule (par ex. A3_MyTool ou P10_SortTool). Si des expressions doivent être créées pour ces outils, renommez l'outil avant de créer la formule.
Fermé Outils de vision

L'arborescence Outils de vision contient des fonctions de transitions supplémentaires pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Transition, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Transition et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions mathématiques

L'arborescence de fonctions mathématiques contient les fonctions mathématiques pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Mathématiques, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Mathématiques et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions texte

L'arborescence de fonctions texte contient des fonctions permettant de formater les données alphanumériques à afficher et à transmettre, et peut être utilisée pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Texte, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Texte et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Résultats de vision

L'arborescence Résultats de vision contient des données supplémentaires non disponibles par défaut et pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Résultats de vision, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Résultats de vision et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque :
  • La liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
  • EasyBuilder prend uniquement en charge les fonctions de résultats de vision Blobs, Transitions et Modèles.
Fermé Arborescence de symboles de données de projets et d'outils

L'Arborescence de symboles de données de projets et d'outils contient les données de sortie des outils de recherche et/ou d'inspection, ainsi que les lignes d'entrée et des données de projet telles que les paramètres d'acquisition d'images. Les données de projets et d'outils sont des références symboliques aux valeurs figurant dans ces données. Des symboles peuvent être ajoutés à l'Expression par l'une des trois méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée puis cliquez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
  • À l'aide d'un clavier, tapez le nom de la référence symbolique souhaitez directement dans la zone de texte de l'Expression.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer est utilisé pour placer des fonctions mathématiques et des symboles dans l'expression. Sélectionnez la fonction mathématique ou le symbole de votre choix et cliquez sur le bouton Insérer pour l'ajouter dans l'expression.

Remarque : ce contrôle fonctionne en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, le bouton Insérer est activé.
Fermé Boutons de parenthèse gauche, virgule, parenthèse droite

Les boutons de parenthèse gauche, virgule et parenthèse droite sont utilisés pour créer des formules mathématiques. Cliquez sur le bouton approprié pour les insérer dans la formule.

Remarque : ces contrôles fonctionnent en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, les boutons sont activés.


Outils de tracé - Ligne

L'outil de tracé de ligne sert à tracer un graphique en ligne sur une image à l'aide d'expressions mathématiques qui en définissent les valeurs suivantes : X de début, Y de début, X de fin et Y de fin. L'outil trace le graphique sur l'image et renvoie les valeurs qui définissent les points de début et de fin de la ligne sous forme de coordonnées X/Y.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de tracé de ligne

Une fois l'outil ajouté, créez les expressions qui définiront le graphique.

  1. Pour créer les expressions mathématiques qui seront utilisées pour définir le graphique, sélectionnez et insérez des fonctions mathématiques du côté gauche du volet de paramètres, et des valeurs (données d'outils et de projets) du côté droit. Pour entrer une fonction ou une valeur dans l'éditeur de formules de l'expression, sélectionnez la fonction ou la valeur et appuyez sur la touche Entrée, double-cliquez sur la fonction ou la valeur ou cliquez sur le bouton Insérer.
  2. Une fois que vous avez créé les expressions qui définiront le graphique tracé sur l'image, EasyBuilder traite les données et crée le graphique.
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de tracé de ligne

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de tracé de ligne comprend les onglets suivants :

  • Onglet Général et Paramètres
  • Onglets Expression X de début, Y de début, X de fin et Y de fin
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglets Général et Paramètres

Onglets Expression X de début, Y de début, X de fin et Y de fin.


Outil de tracé de ligne - Onglets Général et Paramètres

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Ligne_1 » s'il s'agit du premier outil de tracé de ligne ajouté au projet. Sinon, il est incrémenté (par exemple, « Ligne_2 », « Ligne_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Fermé Onglet Paramètres
Fermé Couleur

Définit la couleur du graphique affiché. La couleur par défaut est celle actuellement utilisée par les autres outils du projet.

Fermé Résultat

Renvoie le résultat des onglets Expression de l'outil ; affiche les valeurs X, Y de début et de fin de la ligne.


Outil de tracé de ligne - Onglets Expression X de début, Y de début, X de fin et Y de fin

L'outil de tracé de ligne se compose des onglets Expression suivants (partageant tous les mêmes contrôles) pour créer le graphique tracé : Onglets Expression X de début, Y de début, X de fin et EY de fin. Si un des onglets Expression affiche un état d'erreur (#ERR), le graphique n'est pas tracé dans l'image et un message d'erreur indiquant le ou les onglets Expression erronés est renvoyé.

Remarque : ces contrôles sont désactivés lorsque le système de vision In-Sight est en ligne.
Fermé Expression

La zone de texte Expression permet de créer une formule mathématique capable de traiter les résultats et données de l'outil. Pour rédiger la formule, entrez les données en saisissant, sur le clavier, le nom de la fonction mathématique ou les données du projet/de l'outil ou en utilisant l'arborescence Outils de vision, Mathématiques, Texte et/ou Résultats de vision à gauche, et l'arborescence de symboles de données de projets et d'outils, à droite. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque :
  • Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
  • Lors de la création de formules, EasyBuilder ne décompose pas correctement les noms d'outils qui commencent par une adresse de cellule (par ex. A3_MyTool ou P10_SortTool). Si des expressions doivent être créées pour ces outils, renommez l'outil avant de créer la formule.
Fermé Outils de vision

L'arborescence Outils de vision contient des fonctions de transitions supplémentaires pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Transition, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Transition et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions mathématiques

L'arborescence de fonctions mathématiques contient les fonctions mathématiques pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Mathématiques, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Mathématiques et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions texte

L'arborescence de fonctions texte contient des fonctions permettant de formater les données alphanumériques à afficher et à transmettre, et peut être utilisée pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Texte, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Texte et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Résultats de vision

L'arborescence Résultats de vision contient des données supplémentaires non disponibles par défaut et pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Résultats de vision, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Résultats de vision et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque :
  • La liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
  • EasyBuilder prend uniquement en charge les fonctions de résultats de vision Blobs, Transitions et Modèles.
Fermé Arborescence de symboles de données de projets et d'outils

L'Arborescence de symboles de données de projets et d'outils contient les données de sortie des outils de recherche et/ou d'inspection, ainsi que les lignes d'entrée et des données de projet telles que les paramètres d'acquisition d'images. Les données de projets et d'outils sont des références symboliques aux valeurs figurant dans ces données. Des symboles peuvent être ajoutés à l'Expression par l'une des trois méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée puis cliquez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
  • À l'aide d'un clavier, tapez le nom de la référence symbolique souhaitez directement dans la zone de texte de l'Expression.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer est utilisé pour placer des fonctions mathématiques et des symboles dans l'expression. Sélectionnez la fonction mathématique ou le symbole de votre choix et cliquez sur le bouton Insérer pour l'ajouter dans l'expression.

Remarque : ce contrôle fonctionne en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, le bouton Insérer est activé.
Fermé Boutons de parenthèse gauche, virgule, parenthèse droite

Les boutons de parenthèse gauche, virgule et parenthèse droite sont utilisés pour créer des formules mathématiques. Cliquez sur le bouton approprié pour les insérer dans la formule.

Remarque : ces contrôles fonctionnent en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, les boutons sont activés.


Outils de tracé - Point

L'outil de tracé de point sert à tracer un point sur une image à l'aide d'expressions mathématiques qui en définissent les valeurs suivantes : X et Y. L'outil trace le graphique sur l'image et renvoie les valeurs qui définissent le point.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de tracé de point

Une fois l'outil ajouté, créez les expressions qui définiront le graphique.

  1. Pour créer les expressions mathématiques qui seront utilisées pour définir le graphique, sélectionnez et insérez des fonctions mathématiques du côté gauche du volet de paramètres, et des valeurs (données d'outils et de projets) du côté droit. Pour entrer une fonction ou une valeur dans l'éditeur de formules de l'expression, sélectionnez la fonction ou la valeur et appuyez sur la touche Entrée, double-cliquez sur la fonction ou la valeur ou cliquez sur le bouton Insérer.
  2. Une fois que vous avez créé les expressions qui définiront le graphique tracé sur l'image, EasyBuilder traite les données et crée le graphique.
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de tracé de point

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de tracé de point comprend les onglets suivants :

  • Onglets Général et Paramètres
  • Onglets Expression X et Y
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglets Général et Paramètres

Onglets Expression X et Y


Outil de tracé de point - Onglets Général et Paramètres

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Point_1 » s'il s'agit du premier outil de tracé de point ajouté au projet. Sinon, il est incrémenté (par exemple, « Point_2 », « Point_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Fermé Onglet Paramètres
Fermé Couleur

Définit la couleur du graphique affiché. La couleur par défaut est celle actuellement utilisée par les autres outils du projet.

Fermé Résultat

Renvoie le résultat des onglets Expression de l'outil ; affiche les valeurs X et Y du point.


Outil de tracé de point - Onglets Expression X et Y

L'outil de tracé de point se compose des onglets Expression suivants (partageant tous les mêmes contrôles) pour créer le graphique tracé : Onglets Expression X et Y. Si un des onglets Expression affiche un état d'erreur (#ERR), le graphique n'est pas tracé dans l'image et un message d'erreur indiquant le ou les onglets Expression erronés est renvoyé.

Remarque : ces contrôles sont désactivés lorsque le système de vision In-Sight est en ligne.
Fermé Expression

La zone de texte Expression permet de créer une formule mathématique capable de traiter les résultats et données de l'outil. Pour rédiger la formule, entrez les données en saisissant, sur le clavier, le nom de la fonction mathématique ou les données du projet/de l'outil ou en utilisant l'arborescence Outils de vision, Mathématiques, Texte et/ou Résultats de vision à gauche, et l'arborescence de symboles de données de projets et d'outils, à droite. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque :
  • Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
  • Lors de la création de formules, EasyBuilder ne décompose pas correctement les noms d'outils qui commencent par une adresse de cellule (par ex. A3_MyTool ou P10_SortTool). Si des expressions doivent être créées pour ces outils, renommez l'outil avant de créer la formule.
Fermé Outils de vision

L'arborescence Outils de vision contient des fonctions de transitions supplémentaires pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Transition, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Transition et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions mathématiques

L'arborescence de fonctions mathématiques contient les fonctions mathématiques pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Mathématiques, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Mathématiques et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions texte

L'arborescence de fonctions texte contient des fonctions permettant de formater les données alphanumériques à afficher et à transmettre, et peut être utilisée pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Texte, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Texte et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Résultats de vision

L'arborescence Résultats de vision contient des données supplémentaires non disponibles par défaut et pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Résultats de vision, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Résultats de vision et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque :
  • La liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
  • EasyBuilder prend uniquement en charge les fonctions de résultats de vision Blobs, Transitions et Modèles.
Fermé Arborescence de symboles de données de projets et d'outils

L'Arborescence de symboles de données de projets et d'outils contient les données de sortie des outils de recherche et/ou d'inspection, ainsi que les lignes d'entrée et des données de projet telles que les paramètres d'acquisition d'images. Les données de projets et d'outils sont des références symboliques aux valeurs figurant dans ces données. Des symboles peuvent être ajoutés à l'Expression par l'une des trois méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée puis cliquez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
  • À l'aide d'un clavier, tapez le nom de la référence symbolique souhaitez directement dans la zone de texte de l'Expression.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer est utilisé pour placer des fonctions mathématiques et des symboles dans l'expression. Sélectionnez la fonction mathématique ou le symbole de votre choix et cliquez sur le bouton Insérer pour l'ajouter dans l'expression.

Remarque : ce contrôle fonctionne en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, le bouton Insérer est activé.
Fermé Boutons de parenthèse gauche, virgule, parenthèse droite

Les boutons de parenthèse gauche, virgule et parenthèse droite sont utilisés pour créer des formules mathématiques. Cliquez sur le bouton approprié pour les insérer dans la formule.

Remarque : ces contrôles fonctionnent en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, les boutons sont activés.


Outils de tracé - Région

L'outil de tracé de région sert à tracer un graphique en forme de région sur une image à l'aide d'expressions mathématiques qui définissent les valeurs suivantes : X, Y, hauteur, largeur, angle, courbure. L'outil trace le graphique sur l'image et renvoie les valeurs qui définissent l'emplacement, la forme et la taille de la région.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de tracé de région

Une fois l'outil ajouté, créez les expressions qui définiront le graphique.

  1. Pour créer les expressions mathématiques qui seront utilisées pour définir le graphique, sélectionnez et insérez des fonctions mathématiques du côté gauche du volet de paramètres, et des valeurs (données d'outils et de projets) du côté droit. Pour entrer une fonction ou une valeur dans l'éditeur de formules de l'expression, sélectionnez la fonction ou la valeur et appuyez sur la touche Entrée, double-cliquez sur la fonction ou la valeur ou cliquez sur le bouton Insérer.
  2. Une fois que vous avez créé les expressions qui définiront le graphique tracé sur l'image, EasyBuilder traite les données et crée le graphique.
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de tracé de région

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de tracé de région comprend les onglets suivants :

  • Onglet Général et Paramètres
  • Onglets Expression X, Y, Hauteur, Largeur, Angle et Courbure
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglets Général et Paramètres

Onglets Expression X, Y, Hauteur, Largeur, Angle et Courbure.


Outil de tracé de région - Onglets Général et Paramètres

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Région_1 » s'il s'agit du premier outil de tracé de région ajouté au projet. Sinon, il est incrémenté (par exemple, « Région_2 », « Région_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Fermé Onglet Paramètres
Fermé Couleur

Définit la couleur du graphique affiché. La couleur par défaut est celle actuellement utilisée par les autres outils du projet.

Fermé Résultat

Renvoie le résultat des onglets Expression de l'outil ; affiche les valeurs X, Y, Hauteur, Largeur, Angle et Courbe de la région.


Outil de tracé de région - Onglets Expression X, Y, Hauteur, Largeur, Angle et Courbure

L'outil de tracé de région se compose des onglets Expression suivants (partageant tous les mêmes contrôles) pour créer le graphique tracé : Onglets Expression X, Y, Hauteur, Largeur et Courbure. L'onglet Expression X définit l'emplacement du premier sommet de la région ; l'onglet Expression Y définit l'autre sommet de la région ; l'onglet Expression Hauteur définit la dimension de la région le long de l'axe X positif ; l'onglet Expression Largeur définit la dimension de la région le long de l'axe positif Y ; l'onglet Expression Angle définit l'angle de la région en degrés, de l'axe positif X à la première bordure de la région ; et l'onglet Expression Courbure définit l'angle en degrés entre les deux bordures latérales de la région. Si un des onglets Expression affiche un état d'erreur (#ERR), le graphique n'est pas tracé dans l'image et un message d'erreur indiquant le ou les onglets Expression erronés est renvoyé.

Remarque : ces contrôles sont désactivés lorsque le système de vision In-Sight est en ligne.
Fermé Expression

La zone de texte Expression permet de créer une formule mathématique capable de traiter les résultats et données de l'outil. Pour rédiger la formule, entrez les données en saisissant, sur le clavier, le nom de la fonction mathématique ou les données du projet/de l'outil ou en utilisant l'arborescence Outils de vision, Mathématiques, Texte et/ou Résultats de vision à gauche, et l'arborescence de symboles de données de projets et d'outils, à droite. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque :
  • Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
  • Lors de la création de formules, EasyBuilder ne décompose pas correctement les noms d'outils qui commencent par une adresse de cellule (par ex. A3_MyTool ou P10_SortTool). Si des expressions doivent être créées pour ces outils, renommez l'outil avant de créer la formule.
Fermé Outils de vision

L'arborescence Outils de vision contient des fonctions de transitions supplémentaires pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Transition, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Transition et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions mathématiques

L'arborescence de fonctions mathématiques contient les fonctions mathématiques pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Mathématiques, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Mathématiques et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions texte

L'arborescence de fonctions texte contient des fonctions permettant de formater les données alphanumériques à afficher et à transmettre, et peut être utilisée pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Texte, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Texte et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Résultats de vision

L'arborescence Résultats de vision contient des données supplémentaires non disponibles par défaut et pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Résultats de vision, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Résultats de vision et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque :
  • La liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
  • EasyBuilder prend uniquement en charge les fonctions de résultats de vision Blobs, Transitions et Modèles.
Fermé Arborescence de symboles de données de projets et d'outils

L'Arborescence de symboles de données de projets et d'outils contient les données de sortie des outils de recherche et/ou d'inspection, ainsi que les lignes d'entrée et des données de projet telles que les paramètres d'acquisition d'images. Les données de projets et d'outils sont des références symboliques aux valeurs figurant dans ces données. Des symboles peuvent être ajoutés à l'Expression par l'une des trois méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée puis cliquez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
  • À l'aide d'un clavier, tapez le nom de la référence symbolique souhaitez directement dans la zone de texte de l'Expression.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer est utilisé pour placer des fonctions mathématiques et des symboles dans l'expression. Sélectionnez la fonction mathématique ou le symbole de votre choix et cliquez sur le bouton Insérer pour l'ajouter dans l'expression.

Remarque : ce contrôle fonctionne en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, le bouton Insérer est activé.
Fermé Boutons de parenthèse gauche, virgule, parenthèse droite

Les boutons de parenthèse gauche, virgule et parenthèse droite sont utilisés pour créer des formules mathématiques. Cliquez sur le bouton approprié pour les insérer dans la formule.

Remarque : ces contrôles fonctionnent en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, les boutons sont activés.


Outils de tracé - Chaîne

L'outil de tracé de chaîne sert à tracer un graphique sous forme de chaîne de caractères sur une image à l'aide d'expressions mathématiques qui en définissent les valeurs suivantes : coordonnées X et Y de l'emplacement. L'outil trace le graphique sur l'image et renvoie les valeurs qui définissent les coordonnées X et Y de l'emplacement de la chaîne.

Remarque : L'outil renvoie les résultats en pixels, sauf si l'image était calibrée en unités réelles (systèmes de vision In-Sight) ou si le Champ de vue (largeur) est réglé sur des unités réelles (capteurs de vision de série In-Sight 2000) dans l'étape d'application Configurer image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de tracé de chaîne

Une fois l'outil ajouté, créez les expressions qui définiront le graphique.

  1. Pour créer les expressions mathématiques qui seront utilisées pour définir le graphique, sélectionnez et insérez des fonctions mathématiques du côté gauche du volet de paramètres, et des valeurs (données d'outils et de projets) du côté droit. Pour entrer une fonction ou une valeur dans l'éditeur de formules de l'expression, sélectionnez la fonction ou la valeur et appuyez sur la touche Entrée, double-cliquez sur la fonction ou la valeur ou cliquez sur le bouton Insérer.
  2. Une fois que vous avez créé les expressions qui définiront le graphique tracé sur l'image, EasyBuilder traite les données et crée le graphique.
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de tracé de chaîne

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de tracé de chaîne comprend les onglets suivants :

  • Onglets Général et Paramètres
  • Onglet Expression
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglets Général et Paramètres

Onglets Expression X, Y et Chaîne.


Outil de tracé de chaîne - Onglets Général et Paramètres

Fermé Onglet Général
Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Chaîne_1 » s'il s'agit du premier outil de tracé de chaîne ajouté au projet. Sinon, il est incrémenté (par exemple, « Chaîne_2 », « Chaîne_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.

Fermé Onglet Paramètres
Fermé Résultat

Renvoie le résultat des onglets Expression de l'outil ; affiche la chaîne et ses valeurs X et Y.

Fermé Couleur

Définit la couleur du graphique affiché. La couleur par défaut est celle actuellement utilisée par les autres outils du projet.

Fermé Nom de police

Définit le type de police qui sera utilisé pour le graphique de la chaîne, Arial est sélectionné par défaut.

Fermé Style de police

Définit le style (Normal, Italique, Gras ou Italique gras) de la police utilisée pour le graphique de la chaîne ; par défaut, le style est Normal.

Fermé Taille de police

Définit la taille de police utilisée pour le graphique de la chaîne ; par défaut la taille de police est définie sur 9 points.


Outil de tracé de chaîne - Onglets Expression X, Y et Chaîne

L'outil de tracé de chaîne se compose des onglets Expression suivants (partageant tous les mêmes contrôles) pour créer le graphique tracé : Onglets Expression X, Y et Chaîne. Si un des onglets Expression affiche un état d'erreur (#ERR), le graphique n'est pas tracé dans l'image et un message d'erreur indiquant le ou les onglets Expression erronés est renvoyé.

Remarque : ces contrôles sont désactivés lorsque le système de vision In-Sight est en ligne.
Fermé Expression

La zone de texte Expression permet de créer une formule mathématique capable de traiter les résultats et données de l'outil. Pour rédiger la formule, entrez les données en saisissant, sur le clavier, le nom de la fonction mathématique ou les données du projet/de l'outil ou en utilisant l'arborescence Outils de vision, Mathématiques, Texte et/ou Résultats de vision à gauche, et l'arborescence de symboles de données de projets et d'outils, à droite. Pour entrer des éléments, vous pouvez double-cliquer dessus ou les sélectionner puis cliquer sur le bouton Insérer.

Remarque :
  • Si l'expression fait référence à un outil qui a été supprimé, la référence est automatiquement remplacée par « Job.MissingArg » dans la formule. L'outil renvoie un état d'échec jusqu'à ce que la référence soit corrigée.
  • Lors de la création de formules, EasyBuilder ne décompose pas correctement les noms d'outils qui commencent par une adresse de cellule (par ex. A3_MyTool ou P10_SortTool). Si des expressions doivent être créées pour ces outils, renommez l'outil avant de créer la formule.
Fermé Outils de vision

L'arborescence Outils de vision contient des fonctions de transitions supplémentaires pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Transition, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Transition et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions mathématiques

L'arborescence de fonctions mathématiques contient les fonctions mathématiques pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Mathématiques, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Mathématiques et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Arborescence de fonctions texte

L'arborescence de fonctions texte contient des fonctions permettant de formater les données alphanumériques à afficher et à transmettre, et peut être utilisée pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Texte, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Texte et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque : la liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
Fermé Résultats de vision

L'arborescence Résultats de vision contient des données supplémentaires non disponibles par défaut et pouvant être utilisées pour créer votre expression. Pour ajouter des fonctions à l'expression, vous pouvez procéder de trois façons :

  • Développez l'arborescence Résultats de vision, sélectionnez la fonction voulue puis cliquez sur le bouton Insérer.
  • Développez l'arborescence Résultats de vision et double-cliquez sur la fonction voulue.
  • Sur le clavier, entrez le nom de la fonction voulue directement dans la zone de texte Expression.
Remarque :
  • La liste de fonctions disponibles dépend de la position du curseur dans l'expression. Si le curseur se trouve à un endroit de l'expression dans lequel il est impossible d'ajouter une fonction mathématique, les fonctions ne sont pas disponibles jusqu'à ce que le curseur soit situé à un endroit permettant d'en ajouter.
  • EasyBuilder prend uniquement en charge les fonctions de résultats de vision Blobs, Transitions et Modèles.
Fermé Arborescence de symboles de données de projets et d'outils

L'Arborescence de symboles de données de projets et d'outils contient les données de sortie des outils de recherche et/ou d'inspection, ainsi que les lignes d'entrée et des données de projet telles que les paramètres d'acquisition d'images. Les données de projets et d'outils sont des références symboliques aux valeurs figurant dans ces données. Des symboles peuvent être ajoutés à l'Expression par l'une des trois méthodes suivantes :

  • Développez l'arborescence, sélectionnez la référence symbolique souhaitée puis cliquez sur le bouton Insérer.
  • Développez l'arborescence et double-cliquez sur la référence symbolique souhaitée.
  • À l'aide d'un clavier, tapez le nom de la référence symbolique souhaitez directement dans la zone de texte de l'Expression.
Remarque : La liste des symboles disponibles dépend de la position du curseur dans l'Expression. Si le curseur se trouve dans l'Expression à un endroit où l'ajout d'un symbole est interdit, ces symboles ne sont pas disponibles jusqu'à ce que le curseur se trouve dans un emplacement autorisant l'ajout de symboles.
Fermé Bouton Insérer

Le bouton Insérer est utilisé pour placer des fonctions mathématiques et des symboles dans l'expression. Sélectionnez la fonction mathématique ou le symbole de votre choix et cliquez sur le bouton Insérer pour l'ajouter dans l'expression.

Remarque : ce contrôle fonctionne en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, le bouton Insérer est activé.
Fermé Boutons de parenthèse gauche, virgule, parenthèse droite

Les boutons de parenthèse gauche, virgule et parenthèse droite sont utilisés pour créer des formules mathématiques. Cliquez sur le bouton approprié pour les insérer dans la formule.

Remarque : ces contrôles fonctionnent en conjonction avec les arborescences de fonctions mathématiques et de symboles de données de projets et d'outils. Si l'élément sélectionné dans une des listes peut être inséré à la position actuelle du curseur dans la zone de texte Expression, les boutons sont activés.


Outils de filtre d'image - Filtre

Remarque : Cet outil est disponible uniquement sur les systèmes de vision In-Sight exécutant le micrologiciel In-Sight 5.1.0 et versions ultérieures.

L'Outil de filtre d'image -Filtre filtre une région de l'image au moyen de techniques d'amélioration d'image locales et globales. Il génère une image d'outil pouvant être utilisée comme référence par d'autres outils de recherche ou d'inspection.

L'Outil de filtre d'image -Filtre est un outil polyvalent qui produit une image de sortie en couleurs ou en niveaux de gris, utilisée pour améliorer les images à faible contraste et/ou les caractéristiques d'exposition d'une image. Cet outil aide à accentuer les caractéristiques voulues et minimise celles qui ne sont pas souhaitées pour la plupart des pièces. Quand il est utilisé efficacement, cet outil rend les applications d'inspection plus fiables et reproductibles.

L'Outil de filtre d'image -Filtre propose toute une gamme de techniques d'amélioration d'image locales et globales. La technique d'amélioration d'image est définie en sélectionnant un type de filtre.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de filtre d'image Filtre

Une fois l'outil ajouté, configurez la région qui servira à définir la zone de l'image à améliorer.

  1. Positionnez la région de façon à ce qu'elle englobe uniquement la zone de l'image à filtrer. Si la région englobe des zones à ne pas filtrer, cela risque de produire des résultats incorrects. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la zone de l'image à filtrer reste sensiblement identique d'une image à l'autre.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  4. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de filtre d'image Filtre

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de filtre d'image Filtre comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres


Outil de filtre d'image Filtre - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Filtre_1 » s'il s'agit du premier outil de filtre d'image ajouté au projet. Sinon, il est incrémenté (par exemple, « Filtre_2 », « Filtre_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de filtre d'image Filtre - Onglet Paramètres

Fermé Type de filtre

Définit la technique d'amélioration d'image qui sera appliquée à la région. Le résultat de la technique d'amélioration d'image sera automatiquement mis à jour dans la région.

Type de filtre | Description
Binariser (par défaut)

Filtre l'image d'après un seuil de niveaux de gris pour obtenir du blanc (255) ou du noir (0). Produit une image où les valeurs de pixel d'entrée égales ou supérieures à la valeur du seuil sont blanches et les valeurs inférieures au seuil sont noires.

Remarque : si l'image d'entrée est en couleurs, l'image de sortie est en niveaux de gris.
Bas de forme

Filtre tout sauf les caractéristiques sombres inférieures à la taille du filtre. Produit une image qui affiche les caractéristiques sombres sous forme de pixels clairs sur un arrière-plan sombre.

Remarque : Cette opération active les paramètres Lignes du noyau et Colonnes du noyau. Le noyau doit être constitué de valeurs entières impaires.
Coupure

Filtre l'image en comparant la valeur de niveaux de gris de chaque pixel à une valeur de niveaux de gris minimale et maximale. Produit une image où les bords du spectre de niveaux de gris sont éliminées afin d'uniformiser les caractéristiques.
Fermé

Filtre les caractéristiques sombres d'une taille inférieure à celle du filtre. Produit une image d'un niveau de luminosité global légèrement augmenté.

Remarque : Cette opération active les paramètres Lignes du noyau et Colonnes du noyau. Le noyau doit être constitué de valeurs entières impaires.
Dilatation

Augmente les caractéristiques claires et réduit les caractéristiques sombres. Produit une image dont les zones de pixels clairs sont plus grandes. Ce filtre est utile pour supprimer les points ou les taches sombres.

Remarque : Cette opération active les paramètres Lignes du noyau et Colonnes du noyau. Le noyau doit être constitué de valeurs entières impaires.
Amplitude de transition

Filtre les caractéristiques sombres et claires. Produit une image où les bords sont représentés sous forme de pixels clairs. Cette opération tient compte des bords en diagonale et elle est plus lente que l'opération « Gradient complet ».

Remarque : Cette opération active les paramètres Lignes du noyau et Colonnes du noyau. Le noyau doit être constitué de valeurs entières impaires.
Égalisation | Filtre d'après une égalisation d'histogramme, où les valeurs de niveaux de gris les plus fréquentes sont égalisées pour créer une répartition plus égale. Produit une image dont le contraste est amélioré.
Érosion

Augmente les caractéristiques sombres et réduit les caractéristiques claires. Produit une image dont les zones de pixels sombres sont plus grandes. Ce filtre est utile pour supprimer les points ou les taches clairs.

Remarque : Cette opération active les paramètres Lignes du noyau et Colonnes du noyau. Le noyau doit être constitué de valeurs entières impaires.
Remplir les trous sombres | Les pixels sombres entourés de pixels clairs sont convertis en pixels clairs. Produit une image où les trous sombres sont remplis.
Remplir les trous clairs | Les pixels clairs entourés de pixels sombres sont convertis en pixels sombres. Produit une image où les trous clairs sont remplis.
Gradient complet | Filtre les caractéristiques des bords verticaux et horizontaux. Produit une image où les bords verticaux et horizontaux sont représentés par des pixels clairs. Cette opération ne tient pas compte des bords en diagonale, mais elle est plus rapide que l'opération « Amplitude de transition ».
Gradient horizontal | Filtre les caractéristiques des bords horizontaux. Produit une image où les bords horizontaux sont représentés par des pixels clairs.
Gradient vertical | Filtre les caractéristiques des bords verticaux. Produit une image où les bords verticaux sont représentés par des pixels clairs.
Distance en niveaux de gris

Filtre selon la valeur en niveaux de gris de chaque pixel de sortie, sous forme de différence entre la valeur en niveaux de gris de chaque pixel d'entrée et le niveau seuil. Produit une image où, par exemple, la valeur du pixel de sortie est 75 si la valeur du pixel d'entrée est 100 et celle du seuil 25.
Transfert élevé

Filtre les caractéristiques des bords et supprime les autres. Produit une image où les bords sont étendus par rapport aux zones ayant un gradient de niveaux de gris plus cohérent.

Remarque : Cette opération active les paramètres Lignes du noyau et Colonnes du noyau. Le noyau doit être constitué de valeurs entières impaires.
Inverser | Filtre selon une inversion des niveaux de gris des valeurs de pixels. Produit une image « négative » de l'image d'entrée.
Médian local

Spécifie une opération qui calcule la valeur de pixel médiane des valeurs de pixels au voisinage du noyau, puis utilise ce résultat comme valeur de pixel de l'image de sortie.

Remarque : Cette opération active les paramètres Lignes du noyau et Colonnes du noyau. Le noyau doit être constitué de valeurs entières impaires.
Normalisation du médian local

Spécifie un moyen de soustraire l'arrière-plan d'une image. Cette opération soustrait le médian local de l'image d'entrée de cette dernière, décale le résultat d'une unité, puis ajoute 128 pour produire la valeur du pixel de sortie.

Remarque : Cette opération active les paramètres Lignes du noyau et Colonnes du noyau. Le noyau doit être constitué de valeurs entières impaires.
Transfert faible

Filtre les caractéristiques des bords et rend flou le bord avec les autres caractéristiques. Produit une image où les bords sont lissés ou rendus flous.

Remarque : Cette opération active les paramètres Lignes du noyau et Colonnes du noyau. Le noyau doit être constitué de valeurs entières impaires.
Max (haut de forme/bas de forme)

Spécifie une opération qui utilise le maximum des opérations Haut de forme et Bas de forme.

Remarque : Cette opération active les paramètres Lignes du noyau et Colonnes du noyau. Le noyau doit être constitué de valeurs entières impaires.
Ouvert

Filtre les caractéristiques claires d'une taille inférieure à celle du filtre. Produit une image d'un niveau de luminosité global légèrement diminué.

Remarque : Cette opération active les paramètres Lignes du noyau et Colonnes du noyau. Le noyau doit être constitué de valeurs entières impaires.
Densité optique

Filtre d'après une inversion des valeurs de pixel sur une échelle logarithmique. Produit une image qui révèle la densité des objets et des caractéristiques en mesurant la quantité de lumière qui les traverse. Les objets et caractéristiques plus denses sont représentés par des pixels plus clairs dans l'image de sortie.
Accentuer

Spécifie une opération de « netteté » utilisée pour étendre les bords. L'opération évalue le contraste entre les pixels adjacents et augmente le contraste quand il est élevé. Une différence de contraste importante entre des pixels adjacents représente habituellement un bord. Cependant, cette opération ne doit pas être utilisée pour localiser les bords. Les effets produits par cette opération dépendant du contenu et de la résolution de l'image.

  • Le paramètre Gain impose l'intensité de l'accentuation, il indique au filtre d'ignorer une certaine différence entre les pixels lors de l'accentuation afin que les zones légèrement texturées ne soient pas sur-accentuées.
Étirer | Filtre par mise à l'échelle linéaire ou « étirement » des valeurs de niveaux de gris. Produit une image dont le contraste est augmenté.
Plage de seuil

Filtre selon un seuil binaire (noir et blanc) qui compare chaque pixel d'entrée aux valeurs seuils (minimum et maximum) afin de déterminer si le pixel de sortie est blanc ou noir. Produit une image où le pixel de sortie est blanc si la valeur du pixel d'entrée et égale ou supérieure au minimum ou au maximum, le pixel de sortie est noir si la valeur du pixel d'entrée se situe entre le minimum et le maximum.
Haut de forme

Filtre tout sauf les caractéristiques claires inférieures à la taille du filtre. Produit une image qui affiche les caractéristiques claires sous forme de pixels clairs sur un arrière-plan sombre.

Remarque : Cette opération active les paramètres Lignes du noyau et Colonnes du noyau. Le noyau doit être constitué de valeurs entières impaires.
Fermé Lignes du noyau

Spécifie le nombre de lignes (1 à 25 ; valeur par défaut = 3) du noyau. Un noyau est un tableau rectangulaire de nombres qui définit le voisinage de traitement pour les opérations effectuées sur chaque emplacement de pixel d'une image. Les valeurs de niveaux de gris des voisins d'un pixel définissent la valeur de niveaux de gris de cet emplacement de pixel dans l'image de sortie.

Remarque :

  • Le noyau est non pondéré.

  • Le noyau doit être constitué de valeurs entières impaires. Un noyau est habituellement de 3 x 3, mais sa taille est arbitraire.

Ce paramètre est activé quand le Type de filtre est défini sur un des éléments suivants :

  • Bas de forme
  • Fermé
  • Dilatation
  • Amplitude de transition
  • Érosion
  • Transfert élevé
  • Médian local
  • Normalisation du médian local
  • Transfert faible
  • Max (haut de forme/bas de forme)
  • Ouvert
  • Haut de forme
Fermé Colonnes du noyau

Spécifie le nombre de colonnes (1 à 25 ; valeur par défaut = 3) du noyau. Un noyau est un tableau rectangulaire de nombres qui définit le voisinage de traitement pour les opérations effectuées sur chaque emplacement de pixel d'une image. Les valeurs de niveaux de gris des voisins d'un pixel définissent la valeur de niveaux de gris de cet emplacement de pixel dans l'image de sortie.

Remarque :

  • Le noyau est non pondéré.

  • Le noyau doit être constitué de valeurs entières impaires. Un noyau est habituellement de 3 x 3, mais sa taille est arbitraire.

Ce paramètre est activé quand le Type de filtre est défini sur un des éléments suivants :

  • Bas de forme
  • Fermé
  • Dilatation
  • Amplitude de transition
  • Érosion
  • Transfert élevé
  • Médian local
  • Normalisation du médian local
  • Transfert faible
  • Max (haut de forme/bas de forme)
  • Ouvert
  • Haut de forme
Fermé Mode du seuil

Spécifie si l'outil détermine automatiquement un niveau de seuil lorsque le Type de filtre est défini sur Binariser, Distance en niveaux de gris ou Plage de seuil.

  • Manuel : active le paramètre Seuil et spécifie manuellement les niveaux de seuil.
  • Automatique (par défaut) :
    • Lorsque le Type de filtre est défini sur Binariser, l'outil calcule automatiquement un niveau de seuil d'après les valeurs de niveaux de grisdans la région indiquée.
    • Lorsque le Type de filtre est défini sur Distance en niveaux de gris, l'outil calcule automatiquement un niveau de seuil d'après la valeur de niveaux de grismoyenne dans la région indiquée.
    • Lorsque le Type de filtre est défini sur Plage de seuil, ce qui suit s'applique automatiquement :
      • Les valeurs de pixel seront définies selon l'arrière-plan si elles sont inférieures à la définition du paramètre Min ou si elles sont supérieures à la définition du paramètre Max.
      • Les valeurs de pixel seront définies selon le premier plan si elles se situent entre les définitions des paramètres Min et Max.
Fermé Seuil

Définit les niveaux de seuil (0 à 255 ; valeur par défaut = 128) lorsque le Type de filtre est défini sur Binariser, Distance en niveaux de gris ou Plage de seuil.

Fermé Min

Définit la valeur de niveaux de gris minimale (0 à 255 ; valeur par défaut = 128) lorsque le Type de filtre est défini sur Couper, Étirer ou Plage de seuil.

Fermé Max

Définit la valeur de niveaux de gris maximale (0 à 255 ; valeur par défaut = 128) lorsque le Type de filtre est défini sur Couper, Étirer ou Plage de seuil.

Fermé Gain

Définit la valeur du gain (0 à 10 ; valeur par défaut = 1) lorsque le Type de filtre est défini sur Accentuer. Ce paramètre impose l'intensité de l'accentuation qui sera appliquée en contrôlant le niveau d'amélioration du contraste des bords. Les pixels autour d'un bord sont amenés à leur valeur minimale ou maximale afin d'accentuer l'apparence du bord.

Fermé Lissé

Définit la valeur du lissé (1 à 4 ; valeur par défaut = 1) lorsque le Type de filtre est défini sur Accentuer. Le lissé contrôle l'écart standard du noyau gaussien. Des valeurs de lissé plus élevées entraînent une ouverture plus large de l'opération de lissé, ce qui favorise l'accentuation des caractéristiques.

Remarque : gaussien fait référence à une courbe en forme de cloche appliquée sous forme de moyenne pondérée aux pixels situés dans la région d'intérêt.


Outils de filtre d'image - Point

Remarque : Cet outil est disponible uniquement sur les systèmes de vision In-Sight exploitant le micrologiciel In-Sight 4.x.x, mais pas sur les systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.1.0 et ultérieures. Reportez-vous à Versions du micrologiciel pour obtenir une liste complète des modèles et des versions du micrologiciel prises en charge.

L'outil de filtre d'image Point filtre une région de l'image au moyen d'une technique d'amélioration d'image « de voisinage » pixel par pixel, comme le seuillage, l'inversion, l'égalisation, l'atténuation, la coupure ou l'étirement. Il génère une image d'outil pouvant être utilisée comme référence par d'autres outils de recherche ou d'inspection.

Les opérations d'amélioration d'image « globales » impliquent l'affectation d'une valeur de niveaux de gris au pixel de sortie d'après les valeurs de niveaux de gris individuelles des pixels dans la région de l'outil.

L'outil de filtre d'image Point est utile dans les cas où vous devez améliorer une zone de l'image pour mieux détecter une caractéristique pour une inspection, par exemple couper les points sensibles d'une surface pour mieux lire des caractères OCR ou étendre les caractéristiques d'une pièce pour obtenir un meilleur contraste.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de filtre d'image de point

Une fois l'outil ajouté, configurez la région qui servira à définir la zone de l'image à améliorer.

  1. Positionnez la région de façon à ce qu'elle englobe uniquement la zone de l'image à filtrer. Si la région englobe des zones à ne pas filtrer, cela risque de produire des résultats incorrects. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la zone de l'image à filtrer reste sensiblement identique d'une image à l'autre.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Outils de filtre d’image et outils de couleur - Image d’outil


Outils de filtre d'image et outils de couleur - Image d'outil

Les outils de filtre d'image (Filtre, Voisin, Point, Correction de scène, Couleur -> niveaux de gris, Couleur -> binaire, Transformer et Comparer) et les outils de couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), nombre de pixels de couleur et les outils de présence/absence de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire) génèrent une image pouvant être utilisée comme entrée d'image outil des outils de recherche et d'inspection.

Le paramètre Image d'outil se trouve sous l'onglet Général de tous les outils qui acceptent une image autre que l'image d'acquisition lorsqu'un outil qui crée une image d'outil a été ajouté au projet, ou apparaît sous forme d'option dans le menu déroulant du volet de paramètres Directions lorsqu'un outil est ajouté après l'ajout d'un outil qui crée une image d'outil.

Lorsque le paramètre Image d'outil d'un outil de recherche ou d'inspection est défini sur un outil qui produit une image d'outil (un outil de filtre d'image peut aussi utiliser un autre outil de filtre d'image comme entrée), ces outils effectuent l'inspection en utilisant l'image filtrée. Leurs régions doivent par ailleurs toujours rester dans les limites de l'outil qui crée la région de l'image d'outil.

Pour définir un outil de filtre d'image comme paramètre Image d'outil d'un outil, commencez par ajouter un outil de filtre d'image, puis revenez sous l'onglet Général de l'outil précédent et sélectionnez l'outil de filtre d'image que vous venez d'ajouter comme paramètre Image d'outil.

Remarque : dès lors qu'un outil de filtre d'image ou outil de couleur qui produit une image d'outil a été ajouté à un projet, vous devez définir l'image d'entrée de cet outil dans la zone de groupe Directions du volet de paramètres à chaque fois qu'un nouvel outil qui accepte l'utilisation d'une image autre que l'image d'acquisition est ajouté. L'option par défaut correspond à l'image non filtrée en cours d'acquisition.


Réglage des paramètres de l'outil de filtre d'image Filtre de point

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de filtre d'image Filtre de point comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglets Avant/Après
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglets Avant/Après


Outil de filtre d'image de point - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrée/Sorties et Communication). Le nom par défaut est « Filtre_1 » s'il s'agit du premier outil de filtre d'image ajouté au projet. Sinon, il est incrémenté (par exemple, « Filtre_2 », « Filtre_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de filtre d'image de point - Onglet Paramètres

Fermé Opération

Définit la technique d'amélioration d'image qui sera appliquée à la région. Le résultat de la technique d'amélioration d'image sera automatiquement mis à jour dans la région.

Opération | Description
Binariser (par défaut) | Filtre l'image d'après un seuil de niveaux de gris pour obtenir du blanc (255) ou du noir (0). Produit une image où les valeurs de pixel d'entrée égales ou supérieures à la valeur du seuil sont blanches et les valeurs inférieures au seuil sont noires.
Coupure | Filtre l'image en comparant la valeur de niveaux de gris de chaque pixel à une valeur de niveaux de gris minimale et maximale. Produit une image où les bords du spectre de niveaux de gris sont éliminées afin d'uniformiser les caractéristiques.
Égalisation | Filtre d'après une égalisation d'histogramme, où les valeurs de niveaux de gris les plus fréquentes sont égalisées pour créer une répartition plus égale. Produit une image dont le contraste est amélioré.
Distance en niveaux de gris | Filtre selon la valeur en niveaux de gris de chaque pixel de sortie, sous forme de différence entre la valeur en niveaux de gris de chaque pixel d'entrée et le niveau seuil. Produit une image où, par exemple, la valeur du pixel de sortie est 75 si la valeur du pixel d'entrée est 100 et celle du seuil 25.
Inverser | Filtre selon une inversion des niveaux de gris des valeurs de pixels. Produit une image « négative » de l'image d'entrée.
Plage de seuil | Filtre selon un seuil binaire (noir et blanc) qui compare chaque pixel d'entrée aux valeurs seuils (minimum et maximum) afin de déterminer si le pixel de sortie est blanc ou noir. Produit une image où le pixel de sortie est blanc si la valeur du pixel d'entrée et égale ou supérieure au minimum ou au maximum, le pixel de sortie est noir si la valeur du pixel d'entrée se situe entre le minimum et le maximum.
Densité optique | Filtre d'après une inversion des valeurs de pixel sur une échelle logarithmique. Produit une image qui révèle la densité des objets et des caractéristiques en mesurant la quantité de lumière qui les traverse. Les objets et caractéristiques plus denses sont représentés par des pixels plus clairs dans l'image de sortie.
Étirer | Filtre par mise à l'échelle linéaire ou « étirement » des valeurs de niveaux de gris. Produit une image dont le contraste est augmenté.
Fermé Minimum

Définit la valeur minimale de niveau de gris (0 à 255) pour les opérations Couper et Plage de seuil. Ce contrôle est activé uniquement quand une des deux opérations est activée.

Fermé Maximum

Définit la valeur maximale de niveau de gris (0 à 255) pour les opérations Couper et Plage de seuil. Ce contrôle est activé uniquement quand une des deux opérations est activée.

Fermé Mode du seuil

Définit le mode de détermination de la valeur de niveau de gris qui segmente la région de l'image en pixels blancs et noirs quand l'opération est définie sur Binariser, Distance en niveaux de gris ou Plage de seuil. Quand Automatique est sélectionné (valeur par défaut), l'outil crée un Paramètre automatique par défaut d'après l'image, chaque fois qu'une image est acquise, en ajustant constamment les modifications de luminosité image après image. Si Manuel est sélectionné, vous saisissez et ajustez manuellement la valeur.

Fermé Seuil

Définit la valeur de niveau de gris qui sépare les pixels noirs des blancs (0 à 255 si le contrôle est activé) pour les opérations Binariser, Distance en niveaux de gris ou Plage de seuil. Les valeurs de pixel inférieures au seuil sont classées comme étant noires et les valeurs de pixels supérieures au seuil comme étant blanches. Ce contrôle est désactivé par défaut et requiert que le mode du seuil soit défini sur Manuel pour pouvoir être activé. Utilisez le Graphique afin de définir une valeur optimale pour votre application.


Outil de filtre d'image de point - Onglets Avant/Après

Les onglets Avant/Après affichent une représentation des valeurs de niveaux de gris des pixels dans la région sous forme d'histogramme. L'onglet Avant affiche l'histogramme de la zone de l'image avant qu'elle ne soit traitée, et l'onglet Après affiche l'histogramme de la zone après son traitement.

  • L'axe X du graphique représente le nombre total de valeurs de niveaux de gris (0 à 255, soit 256 niveaux de gris au total).
  • L'axe Y du graphique représente le nombre de pixels correspondant à une valeur de niveau de gris donnée. L'échelle est établie en affichant la valeur de niveau de gris comportant le plus grand nombre de pixels.
  • La ligne verticale verte indique le seuil utilisé pour diviser la région de l'image en pixels noirs et blancs. Les valeurs situées à gauche de la ligne sont considérées comme noires, et les valeurs situées à droite sont considérées comme blanches.


Outils de filtre d'image - Voisin

Remarque : Cet outil est disponible uniquement sur les systèmes de vision In-Sight exploitant le micrologiciel In-Sight 4.x.x, mais pas sur les systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.1.0 et ultérieures. Reportez-vous à Versions du micrologiciel pour obtenir une liste complète des modèles et des versions du micrologiciel prises en charge.

L'outil de filtre d'image Voisin filtre une région de l'image au moyen d'une technique d'amélioration d'image « de voisinage » pixel par pixel, comme l'atténuation, l'extension, le remplissage, le lissage ou l'amélioration des bords. Il génère une image d'outil pouvant être utilisée comme référence par d'autres outils de recherche ou d'inspection.

Les opérations d'amélioration d'image « voisines » impliquent l'affectation d'une valeur de niveaux de gris au pixel de sortie d'après les valeurs de niveaux de gris des pixels « voisins » dans la région de l'outil. La taille du « voisinage » est déterminée par les paramètres Lignes et Colonnes du filtre

L'outil de filtre d'image Voisin est utile dans les cas où vous devez améliorer une zone de l'image pour mieux détecter une caractéristique pour une inspection, par exemple atténuer la brillance d'une surface métallique pour mieux lire un code marqué spar micro-percussion ou étendre l'extrémité claire du spectre de niveaux de gris pour supprimer les taches sombres lors de la lecture des caractères OCR.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de filtre d'image de voisinage

Une fois l'outil ajouté, configurez la région qui servira à définir la zone de l'image à améliorer.

  1. Positionnez la région de façon à ce qu'elle englobe uniquement la zone de l'image à filtrer. Si la région englobe des zones à ne pas filtrer, cela risque de produire des résultats incorrects. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la zone de l'image à filtrer reste sensiblement identique d'une image à l'autre.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de filtre d'image Filtre de voisin

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de filtre d'image Filtre de voisin comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres


Outil de filtre d'image de voisinage - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Filtre_1 » s'il s'agit du premier outil de filtre d'image ajouté au projet. Sinon, il est incrémenté (par exemple, « Filtre_2 », « Filtre_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de filtre d'image de voisinage - Onglet Paramètres

Fermé Opération

Définit la technique d'amélioration d'image qui sera appliquée à la région. Le résultat de la technique d'amélioration d'image est mis automatiquement à jour dans la région.

Opération | Description
Bas de forme | Supprime tout sauf les caractéristiques sombres plus petites que la taille du filtre définie. Génère une image affichant les caractéristiques sombres sous forme de pixels clairs sur un arrière-plan sombre.
Fermer | Supprime les caractéristiques sombres plus petites que la taille du filtre définie. Génère une image avec un niveau de luminosité global légèrement plus élevé.
Dilatation | Amplifie les caractéristiques claires et atténue les caractéristiques sombres. Génère une image comprenant des zones de pixels clairs plus importantes. Ce filtre peut être utilisé pour supprimer les points ou taches sombres.
Amplitude transitions | Filtre les caractéristiques sombres et claires. Génère une image dans laquelle les transitions sont représentées sous forme de pixels clairs. Cette opération, plus lente que l'opération Gradient Complet, tient compte des transitions diagonales.
Érosion | Amplifie les caractéristiques sombres et atténue les caractéristiques claires. Génère une image comprenant des zones de pixels sombres plus importantes. Ce filtre peut être utilisé pour supprimer les points ou taches clairs.
Remplir les trous foncés | Les pixels sombres entourés de pixels clairs sont convertis en pixels clairs. Génère une image dans laquelle les trous sombres sont remplis.
Remplir les trous clairs | Les pixels clairs entourés de pixels sombres sont convertis en pixels sombres. Génère une image dans laquelle les trous clairs sont remplis.
Gradient Vertical | Filtre les transitions verticales. Génère une image dans laquelle les transitions verticales sont représentées par des pixels clairs.
Gradient Horizontal | Filtre les transitions horizontales. Génère une image dans laquelle les transitions horizontales sont représentées par des pixels clairs.
Gradient complet | Filtre les transitions verticales et horizontales. Génère une image dans laquelle les transitions verticales et horizontales sont représentées par des pixels clairs. Cette opération ne tient pas compte des transitions diagonales, mais elle est plus rapide que l'opération Amplitude transitions.
Passe-haut | Filtre les transitions et supprime les autres caractéristiques. Génère une image dans laquelle les transitions sont mises en évidence par rapport aux zones dont les niveaux de gris sont plus importants.
Passe bas (par défaut) | Filtre les caractéristiques de transition et adoucit la transition avec d'autres caractéristiques. Génère une image dans laquelle les transitions sont « lissées » ou adoucies.
Ouvrir | Supprime les caractéristiques claires plus petites que la taille du filtre définie. Génère une image avec un niveau de luminosité global légèrement plus faible.
Haut de forme | Supprime tout sauf les caractéristiques claires plus petites que la taille du filtre définie. Génère une image affichant les caractéristiques claires sous forme de pixels clairs sur un arrière-plan sombre.
Fermé Filtrer les lignes

Détermine la taille du voisinage de traitement d'image sur l'axe horizontal.

Fermé Filtrer les colonnes

Détermine la taille du voisinage de traitement d'image sur l'axe vertical.


Outils de filtre d'image - Correction de scène

Remarque : Cet outil est disponible uniquement sur les systèmes de vision In-Sight exploitant le micrologiciel In-Sight 4.x.x, mais pas sur les systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.1.0 et ultérieures. Reportez-vous à Versions du micrologiciel pour obtenir une liste complète des modèles et des versions du micrologiciel prises en charge.

L'outil de filtre d'image de correction de scène filtre une région de l'image au moyen d'une technique d'amélioration d'image « de voisinage » pixel par pixel, appelée « intensité moyenne ». Il génère une image d'outil pouvant être utilisée comme référence par d'autres outils de recherche ou d'inspection.

La technique d'amélioration d'image « intensité moyenne » filtre les images en fonction de l'intensité des pixels présents dans le voisinage de traitement, qui est défini par les paramètres Nombre de lignes et Nombre de colonnes. Ce filtre simule l'élimination de l'éclairage ou des ombres irrégulières sur une image en comparant la valeur d'intensité de chaque pixel à l'intensité moyenne des pixels présents dans le voisinage de traitement. Les zones de l'image qui ne présentent peu, voire aucune, variation d'intensité, auront un rendu gris neutre, indépendamment de l'intensité d'origine. Les pixels plus sombres que les pixels adjacents seront rendus avec une ombre plus sombre que le gris neutre, en fonction de leur niveau d'assombrissement par rapport aux pixels adjacents. De la même façon, les pixels plus clairs que les pixels adjacents seront rendus avec une ombre plus claire que le gris neutre. Les bords et les transitions nettes sont préservés, comme avec l'opération « passe-haut ».

L'outil de filtre d'image de correction de scène est utile dans les situations d'application où il existe un éclairage ou des ombres irrégulières sur l'image.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de filtre d'image de correction de scène

Une fois l'outil ajouté, configurez la région qui servira à définir la zone de l'image à améliorer.

  1. Positionnez la région de façon à ce qu'elle englobe uniquement la zone de l'image à filtrer. Si la région englobe des zones à ne pas filtrer, cela risque de produire des résultats incorrects. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la zone de l'image à filtrer reste sensiblement identique d'une image à l'autre.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  4. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de filtre d'image de correction de scène

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de filtre d'image de correction de scène comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres


Outil de filtre d'image de correction de scène - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Filtre_1 » s'il s'agit du premier outil de filtre d'image ajouté au projet. Sinon, il est incrémenté (par exemple, « Filtre_2 », « Filtre_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de filtre d'image de correction de scène - Onglet Paramètres

Fermé Nombre de lignes

Définit la taille du voisinage de traitement d'image (1 – Hauteur max. de l'image ; valeur par défaut = 11) sur l'axe horizontal.

Remarque :
  • La valeur maximale est définie par la taille maximale de la zone d'image du système de vision In-Sight (par ex., 640 x 480, 1 024 x 768 ou 1 600 x 1 200).
  • Seules des valeurs impaires peuvent être utilisées pour définir la taille du voisinage de traitement d'image. Toute valeur paire saisie sera automatiquement arrondie à l'entier inférieur.
Fermé Nombre de colonnes

Définit la taille du voisinage de traitement d'image (1 – Largeur max. de l'image ; valeur par défaut = 11) sur l'axe vertical.

Remarque :
  • La valeur maximale est définie par la taille maximale de la zone d'image du système de vision In-Sight (par ex., 640 x 480, 1 024 x 768 ou 1 600 x 1 200).
  • Seules des valeurs impaires peuvent être utilisées pour définir la taille du voisinage de traitement d'image. Toute valeur paire saisie sera automatiquement arrondie à l'entier inférieur.
Fermé Délai d'attente

Définit la durée, en millisecondes (0 à 30000 ; valeur par défaut = 0), pendant laquelle l'outil calcule l'intensité de l'image avant que l'exécution ne soit interrompue et que l'outil ne renvoie un échec. Le réglage de la valeur sur 0 désactive le paramètre.


Outils de filtre d'image - Couleur -> niveaux de gris

L'outil de filtre d'image couleur -> niveaux de gris filtre une région de l'image en convertissant chaque pixel de couleur de la région en une valeur de niveau de gris, en fonction de l'opération spécifiée. Il produit une image d'outil pouvant être utilisée comme référence par d'autres outils de recherche ou d'inspection.

L'outil Couleur -> niveaux de gris convertit chaque pixel de couleur de la région en une valeur de niveau de gris sur la base d'un simple filtre consistant en un paramètre de couleur : rouge, vert ou bleu (RVB) « pur » ; teinte, saturation et intensité (TSI) ; luminance ou interpolation de la moyenne pondérée des composants RVB.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de filtre d'image couleur -> niveaux de gris

Une fois l'outil ajouté, configurez la région qui servira à définir la zone de l'image à améliorer.

  1. Positionnez la région de façon à ce qu'elle englobe uniquement la zone de l'image à filtrer. Si la région englobe des zones à ne pas filtrer, cela risque de produire des résultats incorrects. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la zone de l'image à filtrer reste sensiblement identique d'une image à l'autre.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de filtre d'image couleur -> niveaux de gris

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de filtre d'image couleur -> niveaux de gris comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres


Outil de filtre d'image couleur -> niveaux de gris - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « FiltreCouleur_1 » s'il s'agit du premier outil de filtre d'image binaire -> couleur ajouté au projet. Sinon, il est incrémenté (par exemple, « FiltreCouleur_2 », « FiltreCouleur_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de filtre d'image couleur -> niveaux de gris - Onglet Paramètres

Fermé Opération
Opération | Description
Luminance (par défaut) | Crée une image de la luminance. Le concept de la luminance est étroitement lié à l'intensité. La luminance est une mesure de la quantité de lumière émise ou réfléchie par une surface particulière. Plus un pixel de l'image d'entrée émet de lumière, plus il sera clair dans l'image de sortie.
Rouge | Crée une image qui filtre tout sauf le composant Rouge (255,0,0) du pixel. Plus la valeur Rouge d'un pixel de l'image d'entrée est élevée, plus le pixel sera clair dans l'image de sortie.
Vert | Crée une image qui filtre tout sauf le composant Vert (0,255,0) du pixel. Plus la valeur Vert d'un pixel de l'image d'entrée est élevée, plus le pixel sera clair dans l'image de sortie.
Bleu | Crée une image qui filtre tout sauf le composant Bleu (0,0,255) du pixel. Plus la valeur Bleu d'un pixel de l'image d'entrée est élevée, plus le pixel sera clair dans l'image de sortie.
Teinte | Crée une image qui filtre tout sauf le composant Teinte du pixel. Plus la valeur Teinte d'un pixel de l'image d'entrée est élevée, plus le pixel sera clair dans l'image de sortie.
Saturation | Crée une image qui filtre tout sauf le composant Saturation du pixel. Plus la valeur Saturation d'un pixel de l'image d'entrée est élevée, plus le pixel sera clair dans l'image de sortie.
Intensité | Crée une image qui filtre tout sauf le composant Intensité du pixel, et détermine l'intensité moyenne des composants RVB du pixel. Plus la valeur Intensité d'un pixel de l'image d'entrée est élevée, plus le pixel sera clair dans l'image de sortie.
Interpolation | Crée un filtre d'image qui utilise l'interpolation, la moyenne pondérée des composants RVB (rouge, vert, bleu) d'un pixel. Comme avec l'opération Intensité, l'interpolation filtre tout sauf le composant Intensité du pixel. Plus la valeur Intensité d'un pixel de l'image d'entrée est élevée, plus le pixel sera clair dans l'image de sortie. L'interpolation détermine toutefois l'intensité moyenne pondérée des composants RVB et n'est pas un filtre de conversion standard.


Outils de filtre d'image - Couleur -> binaire

L'outil de filtre d'image couleur -> binaire filtre une région de l'image en convertissant les pixels qui correspondent à un ou plusieurs modèles de couleurs actifs en blanc et tous les autres pixels en noir. Il produit une image d'outil pouvant être utilisée comme référence par d'autres outils de recherche ou d'inspection.

L'outil Couleur -> binaire utilise une bibliothèque de modèles de couleurs appris pour déterminer le nombre de pixels présents dans la région qui correspondent aux modèles de couleurs sélectionnés et appris de la bibliothèque. Il crée ensuite une image de sortie en niveaux de gris binaire, dans laquelle chaque pixel correspondant à un modèle de couleurs actif est défini sur Blanc (255) alors que tous les autres pixels sont définis sur Noir (0).

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de filtre d'image couleur -> binaire

Une fois l'outil ajouté, configurez la région qui servira à définir la zone de l'image à améliorer.

  1. Positionnez la région de façon à ce qu'elle englobe uniquement la zone de l'image à filtrer. Si la région englobe des zones à ne pas filtrer, cela risque de produire des résultats incorrects. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la zone de l'image à filtrer reste sensiblement identique d'une image à l'autre.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Une fois la région de recherche configurée, configurez la bibliothèque de couleurs de l'outil et activez le ou les modèles de couleurs appropriés :

    • Si un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire) est ajouté pour la première fois, commencez par configurer une ou plusieurs bibliothèques de couleurs et leur(s) modèle(s) de couleurs.

    • Si un autre outil a déjà été ajouté et que vous souhaitez utiliser une bibliothèque de couleurs existante et ses modèles de couleurs appris, sélectionnez la bibliothèque de couleurs de votre choix sous l'onglet Paramètres, puis activez les modèles de couleurs voulus en les cochant sous l'onglet Bibliothèque.

    • Par défaut, l'outil déclenche automatiquement un échec tant qu'aucune bibliothèque de couleurs n'a été définie. Si une bibliothèque de couleurs a été définie, l'outil utilise automatiquement cette bibliothèque et active tous les modèles de couleurs qu'elle contient.

  4. Une fois le ou les modèles de couleurs et la ou les bibliothèques de couleurs configurés, l'outil traite l'image et tous les pixels de la région de recherche qui correspondent au ou aux modèles de couleurs sélectionnés deviennent blancs (255), alors que ceux qui ne correspondent pas au ou aux modèles de couleurs sélectionnés deviennent noirs (0).

  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de filtre d'image couleur -> binaire

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de filtre d'image couleur -> binaire comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Bibliothèque de couleurs
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Bibliothèque de couleurs


Outil de filtre d'image binaire -> couleur - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « FiltreCouleur_1 » s'il s'agit du premier outil de filtre d'image binaire -> couleur ajouté au projet. Sinon, il est incrémenté (par exemple, « FiltreCouleur_2 », « FiltreCouleur_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de filtre d'image couleur -> binaire - Onglet Paramètres

Fermé Apprendre la couleur

Affiche la boîte de dialogue Apprentissage ExtractColor , utilisée pour définir le ou les modèles de couleurs de la bibliothèque de couleurs sélectionnée.

Fermé Bibliothèque de couleurs

Définit la bibliothèque de couleurs utilisée comme référence par l'outil. Sur la liste déroulante, sélectionnez la bibliothèque de couleurs à modifier puis cliquez sur le bouton Apprendre la couleur pour afficher la boîte de dialogue Apprentissage ExtractColor. Chaque bibliothèque de couleurs peut compter jusqu'à 100 modèles de couleurs distincts, composés de couleurs individuelles.

Les projets EasyBuilder peuvent contenir 5 bibliothèques de couleurs maximum, qui peuvent être partagées par les outils suivants :

  • Outil de recherche de blob de couleur
  • Outil de recherche de blobs de couleur (1-10)
  • Outil de présence/absence basé sur le comptage de pixels
  • Outil de mesure de surface de blob de couleur
  • Outil de mesure de surfaces des blobs de couleur (1-10)
  • Outil de comptage de blobs de couleur
  • Outil d'identification du modèle de couleurs
  • Outil de filtre d'image couleur -> binaire


Outil de filtre d'image couleur -> binaire - Onglet Bibliothèque de couleurs

Fermé Liste Modèles de couleurs

Affiche une liste en lecture seule de modèle(s) de couleurs contenus dans la bibliothèque de couleurs sélectionnée. Les modèles de couleurs sont activés et désactivés en cochant ou décochant la case en regard de Modèles de couleurs.

Fermé Tableau de couleurs

Affiche un tableau ordonné en lecture seule de la ou des couleurs dans le modèle de couleurs sélectionné.

Fermé Nom de la couleur

Affiche le nom de la ou des couleurs du modèle de couleurs sélectionné.

Fermé RVB

Affiche les valeurs RVB de la ou des couleurs du modèle de couleurs sélectionné.

Fermé Opération

Affiche l'opération (Ajouter ou Soustraire) de la ou des couleurs du modèle de couleurs sélectionné.


Outils de filtre d'image - Transformer

L'outil de filtre de transformation de l'image filtre les déformations linéaires, non linéaires et/ou d'objectif d'une région de l'image et applique la transformation entre les unités réelles et les pixels calibrés avec une grille à l'étape Configurer l'image. Il produit une image d'outil utilisable comme référence par d'autres outils de recherche ou d'inspection.

L'outil de filtre de transformation de l'image est utilisé en conjonction avec le calibrage avec une grille à l'étape Configurer l'image pour compenser et corriger les déformations optiques, renvoyer des mesures extrêmement précises et convertir les unités de pixels en unités de mesure réelles telles que des millimètres ou des pouces. Cet outil et le calibrage avec une grille permettent de localiser plus précisément des objets aux transitions de l'image et offrent une plus grande flexibilité de montage, notamment la capacité de monter le système de vision In-Sight jusqu'à 45° de la surface d'inspection.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de filtre de transformation de l'image

Remarque : avant d'ajouter cet outil, assurez-vous que l'image a été calibrée avec une grille à l'étape Configurer l'image.

Une fois l'outil ajouté, configurez la région qui servira à définir la zone de l'image à améliorer.

  1. Positionnez la région de façon à ce qu'elle englobe uniquement la zone de l'image à filtrer. Si la région englobe des zones à ne pas filtrer, cela risque de produire des résultats incorrects. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la zone de l'image à filtrer reste sensiblement identique d'une image à l'autre.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de filtre de transformation de l'image

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de filtre de transformation de l'image comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres


Outil de filtre de transformation de l'image - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrée/Sorties et Communication). Le nom par défaut est « Transformation_1 » s'il s'agit du premier outil de filtre de transformation d'image ajouté au projet. Sinon, il est incrémenté (par exemple, « Transformation_2 », « Transformation_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de filtre de transformation de l'image - Onglet Paramètres

Fermé Échelle de l'image

Définit l'échelle à laquelle l'image transformée est affichée (0,01 à 10 ; par défaut = 1).

Fermé Centre de référence

Définit le point de référence d'origine pour la transformation : le Centre de l'image (paramètre par défaut), qui définit le point de référence comme le centre de l'image, ou le Centre de la région, qui définit le point de référence comme le centre de la région.

Fermé Afficher l'image

Indique si l'image transformée est affichée à la place de l'image acquise. Ce paramètre est coché (activé) par défaut et l'image transformée est toujours affichée.

Remarque : il est possible que d'autres outils de recherche et d'inspection effectuent des inspections sur les images d'acquisition, sans appliquer le filtre de transformation. Leurs graphiques superposés peuvent cependant apparaître hors contexte par rapport à l'image transformée affichée. Vous pouvez masquer les graphiques superposés de ces outils sous Exécuter le projet, en décochant l'option Afficher le graphique des outils.


Outils de filtre d'image - Comparer

L'outil de filtre de comparaison des images filtre une image en fonction d'un modèle pour produire une image de sortie en niveaux de gris dans laquelle chaque pixel représente la différence normalisée. Il produit une image d'outil pouvant être utilisée comme référence par d'autres outils de recherche ou d'inspection.

Le processus d'amélioration d'image « comparer » compare les pixels de l'image modèle avec ceux de l'image d'entrée puis produire une image de sortie en niveaux de gris dans laquelle les pixels qui ne correspondent pas à l'image modèle sont affichés en blanc.

L'outil de filtre de comparaison des images s'avère utile pour détecter des défauts dans une pièce ou un objet en cours de production. Par exemple, l'outil de filtre de comparaison des images est appliqué sur une pièce ou un objet sans défaut, puis exécute l'image apprise sur chaque image acquise par la suite. D'autres outils, tels qu'un outil de comptage de blobs, effectuent ensuite leur inspection sur l'image d'outil produite par l'outil de filtre de comparaison des images, avec la logique de l'outil de comptage de blobs inversée, afin que l'outil affiche un succès s'il ne dénombre aucun blob et un échec s'il en détecte.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de filtre de comparaison des images

Une fois l'outil ajouté, configurez la région qui servira à définir la zone de l'image à améliorer.

Remarque : l'outil fonctionne de façon optimale sur des images présentant peu, voire pas de bruit de fond, et lorsque chaque image est presque identique, c.-à-d. où la pièce ou l'objet est au même emplacement et où le défaut, le cas échéant, est évident et grand. Si l'image présente du bruit, vous pouvez utiliser un outil de filtre d'image Filtre de point configuré pour l'opération Binariser afin de supprimer les différences de niveaux de gris dans l'image.
  1. Positionnez la région de façon à ce qu'elle englobe uniquement la zone de l'image à filtrer. Si la région englobe des zones à ne pas filtrer, cela risque de produire des résultats incorrects. Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement de la zone de l'image à filtrer reste sensiblement identique d'une image à l'autre.
  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  3. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  4. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de filtre de comparaison des images

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de filtre de comparaison des images comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Onglet Image d'apprentissage
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Onglet Image d’apprentissage


Outil de filtre de comparaison des images - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Filtre_1 » s'il s'agit du premier outil de filtre d'image ajouté au projet. Sinon, il est incrémenté (par exemple, « Filtre_2 », « Filtre_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de filtre de comparaison des images - Onglet Paramètres

Fermé Comparaison des pixels

Définit le type de comparaison des pixels qui sera appliqué lors de la mise en correspondance de l'image modèle avec l'image d'entrée : Plus proche voisin ou Bi-linéaire.

Plus proche voisin (paramètre par défaut) met les images en correspondance lorsque chaque pixel du modèle est comparé au pixel le plus proche dans l'image d'entrée, pour calculer la différence de niveaux de gris normalisée pour chaque pixel. Cette méthode de mise en correspondance d'images est plus rapide mais moins précise.

Bi-linéaire met les images en correspondance lorsque chaque pixel du modèle est comparé à une moyenne pondérée (qui représente la valeur de niveaux de gris des quatre pixels les plus proches dans l'image d'entrée), pour calculer la différence de niveaux de gris normalisée pour chaque pixel. Cette méthode de mise en correspondance d'images est plus précise, mais plus lente.

Fermé Tolérance de transition

Définit le nombre de pixels autour d'une transition qui sera toléré pendant la comparaison des images (0-24 ; par défaut = 3). Plus ce nombre est élevé, moins il y a de chances que les transitions mal appariées soient présentées comme des différences dans l'image de sortie.


Outil de filtre de comparaison des images - Onglet Image d'apprentissage

L'image affichée sous l'onglet Image d'apprentissage est une miniature de l'image modèle. Cliquez sur le bouton Région du modèle pour redimensionner ou déplacer la région Modèle, puis sur le bouton Apprendre pour apprendre à nouveau l'image modèle.


Outils de détection des défauts - Défaut de surface

L'Outil de détection des défauts de surface est utilisé pour détecter les petits défauts en se basant sur les variations d'intensité des pixels. Il permet notamment de détecter des défauts tels que des rayures, égratignures, déchirures, altérations de couleur ou ébréchures, sur des images en nuances de gris ou couleur.

L'Outil de détection des défauts de surface est conçu pour détecter les zones d'intensité locale et de variations de couleur. Il utilise une opération de filtrage interne pour mettre tout d'abord en surbrillance les bords et les zones présentant des variations soudaines de couleur ou de niveau de gris, avant d'appliquer une analyse des blobs pour déterminer si des défauts existent. Cet outil convient aux applications où une partie devrait présenter une surface uniforme à inspecter, de sorte que toute variation soudaine de l'intensité est identifiée comme étant un défaut.

Si nécessaire, l'outil Défaut de surface fournit également un masque d'image intégré, pour mettre en surbrillance les zones de l'image aux fins d'inspection, en excluant les autres zones.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de détection des défauts de surface

La configuration de cet outil exige l'établissement de seuils qui sont utilisés pour déterminer la présence de défauts. Avant le début de la configuration, une base de données d'images de la partie à inspecter (à la fois dans son état de réussite et d'échec) doit être chargée, via le chargement d'images à partir d'un PC.

  1. Pour commencer, chargez une image de la partie concernée dans son état de réussite (sans erreur). Ajoutez ensuite l'outil Défaut de surface.

  2. Configurez la région dans l'image. Dans le menu déroulant Type de région, sélectionnez le type de région : Rectangle (par défaut), Cercle, Anneau ou Polygone. Positionnez la région dans l'image dans laquelle vous pensez voir apparaître le ou les défauts, en vous assurant qu'elle englobe complètement le ou les défauts et leurs emplacements possibles, et configurez-la.

    Remarque :
    • Pour optimiser l'exécution de l'outil, créez des régions de petite taille. Les régions de grande taille sont plus longues à inspecter. Si vous n'utilisez pas de repère, assurez-vous que l'emplacement du ou des défauts reste sensiblement identique d'une image à l'autre ou que la région est suffisamment grande pour intégrer le déplacement éventuel des caractéristiques.
    • Après avoir ajouté l'outil, vous pouvez modifier le type de région en effectuant un clic droit dans l'image et en sélectionnant la forme désirée via l'option Remplacer la région en.
  3. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  4. Avec la partie de l'image à l'état de réussite (sans erreur), réglez les paramètres de l'outil de façon à ce que l'outil n'identifie pas tous les défauts. Utilisez le paramètre Image affichée dans l'onglet Candidats de défaut pour des informations visuelles présentant l'impact du réglage des paramètres sur les résultats de l'outil. Définissez le paramètre Image affichée sur Candidats de défaut pour commencer, de sorte que tous les défauts détectés soient intégrés dans un cadre englobant rouge.

    Remarque : un masque peut éventuellement être créé pour mettre en surbrillance les zones de l'image en vue de l'inspection, tout en excluant les autres zones. Les masques sont très utiles lors de la configuration d'une inspection impliquant du texte, des noms ou d'autres caractéristiques qui doivent être ignorés.
  5. Lors du réglage des paramètres, commencez par la région de l'outil pour être sûr que la région d'intérêt (ROI) englobe bien la zone à inspecter : sans caractéristiques externes, telles que des noms, le bord des caractères ou logos, par exemple. Si l'inspection inclut le bord d'une partie, la région doit être placée parallèlement au bord (cela s'applique également aux régions circulaires, l'arc de cercle de la région devant être parallèle au bord de la partie).
  6. Tentez ensuite de régler les paramètres Facteur d'échantillonnage et Facteur de lissage. Augmentez la valeur du paramètre Échantillonnage lorsque vous tentez de détecter des défauts à faible gradient ou des défauts larges de faible contraste. Augmentez la valeur du paramètre Facteur de lissage pour faciliter l'élimination de faux petits défauts.
  7. Après avoir réglé ces paramètres, utilisez les différentes options associées aux paramètres Type de détection, Taille de détection et Axe de détection. Pour la plupart des applications, le paramètre Type de détection peut être défini sur Rapide, avec une Taille de détection de 1. Pour les applications impliquant des Défauts clairs, Défauts foncés ou des Défauts clairs et foncés, le paramètre Taille de détection doit être défini sur une taille supérieure à celle du rayon du défaut à détecter. Si la région a été configurée pour être parallèle à un bord, l'axe de détection doit être défini pour être parallèle à la région.
  8. Réglez ensuite les paramètres Zone de défaut minimale, Zone de défaut maximale et Contraste minimum.
  9. Une fois que l'outil a inspecté la partie à son état sans erreur, chargez une image de la partie contenant un défaut. Exécutez de nouveau le processus de réglage des paramètres jusqu'à ce que l'outil identifie correctement les défauts voulus. Chargez davantage d'images de la partie contenant des défauts et réglez les paramètres selon les besoins pour identifier des défauts supplémentaires.
  10. Une fois les défauts identifiés, rechargez les images de la partie à son état sans erreur et assurez-vous que l'inspection ne révèle toujours aucun défaut. Une fois correctement configuré, l'outil peut être utilisé pour exécuter des inspections.
  11. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.

Configuration du masque de l’outil


Configuration du masque de l'outil de détection des défauts de surface

Une fois l'outil de détection des défauts de surface ajouté, un masque interne peut être créé pour mettre en surbrillance les zones à inspecter, tout en excluant les autres zones.

  1. Affichez l'onglet Masque et cochez la case Activer le masque pour activer le masque.
  2. Déterminez la méthode de génération du masque : segment le plus large ou bords. Par défaut, les bords sont utilisés (le paramètre Méthode de génération de masque est défini sur Masque de bord par défaut) pour générer un masque d'image basé sur l'amplitude de transition. Avec ce masque d'image, seuls les pixels de bord sont masqués, tous les autres pixels étant visibles. Si vous choisissez le segment le plus large, la zone de caractéristique à inspecter doit devenir le segment le plus large, l'arrière-plan étant exclu de l'inspection.
  3. Réglez le paramètre Image de masque d'affichage sur le type de masque à générer pour faciliter la mise en surbrillance des caractéristiques du masque en affichant les segments indexés et de couleur.
  4. Commencez à régler le paramètre Facteur de lissage du masque pour garantir la mise en surbrillance appropriée des bords de l'image.
  5. Réglez ensuite les paramètres Taille maximale de remplissage des petits trous, Taille de noyau médian et Érosion du nombre de masque. Ces paramètres peuvent être utilisés respectivement pour remplir les trous, lisser les bordures et/ou supprimer des bandes étroites du masque d'image. Si Masque de bord est sélectionné, le paramètre Taille maximale de remplissage des petits trous doit être défini sur 0.
  6. Lorsque le masque effectue correctement la mise en surbrillance des caractéristiques voulues en excluant celles qui doivent l'être, cliquez sur le bouton Apprendre pour valider le masque.
Remarque : tout changement de paramètre, à l'exception de la région, entraîne la mise à jour du masque et le force à un nouvel apprentissage. Si la région est déplacée ou redimensionnée, le bouton Apprendre doit être utilisé pour actualiser le masque en conséquence.


Réglage des paramètres de l'outil de détection des défauts de surface

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de détection des défauts de surface comprend les onglets suivants :

  • Onglet Général
  • Onglet Masque
  • Onglet Détection des défauts
  • Onglets Statistiques, Défauts et Région composite
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Masque

Onglet Détection des défauts

Onglet Statistiques, Défauts et Région composite


Outil de détection des défauts de surface - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « DéfautSurface_1 » s'il s'agit du premier outil de détection des défauts de surface ajouté au projet. Sinon, il est incrémenté (par exemple, « DéfautSurface_2 », « DéfautSurface_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de détection des défauts de surface - Onglet Masque

Fermé Activer le masque

Définit si le masque est utilisé (valeur par défaut = Désactivé).

Fermé Masque d'apprentissage

Définit que le masque apprend les paramètres configurés.

Fermé Méthode de masque

Définit la façon dont l'outil construit le masque (Plus large segment ou Masque de bord ; valeur par défaut = Masque de bord).

  • Plus large segment : l'outil utilise le segment le plus large pour générer le masque.
  • Masque de bord : l'outil utilise les bords pour générer le masque (le paramètre Contraste de transition minimum détermine les bords utilisés).
Fermé Image de masque affichée

Définit l'image de sortie à afficher (Image d'entrée, Image de transition, Image segmentée ou Image de masque ; valeur par défaut = Image de masque).

  • Image d'entrée : l'image acquise actuelle est affichée.
  • Image de transition : une image de l'amplitude de transition est affichée.
  • Image segmentée : une image segmentée de couleur est affichée.
  • Image de masque : l'image de masque binaire, créée après la segmentation et le processus de génération de masque, est affichée (après avoir pris en considération l'entrée du repère). Valeurs des pixels de 255 = tenir compte des pixels ; valeurs des pixels de 0 = ne pas tenir compte des pixels.
Remarque : cette image est uniquement destinée à l'affichage et ne doit pas être utilisée comme image d'entrée pour une autre fonction.
Fermé Facteur de lissage de masque

Définit le facteur sigma (0 à 100 ; valeur par défaut = 1) à utiliser pour le lissage de l'image.

Fermé Contraste de transition minimum

Définit le contraste minimum (1 à 100 ; valeur par défaut = 10) utilisé pour détecter les défauts.

Remarque : ce paramètre n'est activé que si le paramètre Méthode de masque est réglé sur Masque de bord.
Fermé Taille de segment minimale

Définit la surface minimale (1 à 50000 ; valeur par défaut = 1000), en pixels, que doit avoir un segment afin de pouvoir être extrait.

Fermé Taille maximale de remplissage des trous

Définit la taille maximale (0 à 1000 ; valeur par défaut = 0) que doit avoir un trou afin de pouvoir être rempli (pour ne plus être comptabilisé comme un trou).

Fermé Taille de noyau médian

Définit la taille de noyau médian (0 à 50000 ; valeur par défaut = 0) utilisée pour procéder au lissage des transitions dans l'image de masque.

Fermé Érosion du nombre de masque

Définit le nombre d'opérations d'érosion (-100 à 100 ; valeur par défaut = 0) appliquées à l'image générée. Cette valeur peut être un nombre négatif ou positif. Les valeurs négatives entraînent la dilatation de l'image.

Fermé Inverser

Définit si le masque doit être inversé (blanc sur noir, noir sur blanc).


Outil de détection des défauts de surface - Onglet Détection des défauts

Fermé Type de détection

Définit le type de traitement d'image à appliquer à l'image pour déterminer la présence éventuelle de défaut (Rapide, Défauts clairs, Défauts foncés ou Défauts clairs et foncés ; valeur par défaut = Rapide).

  • Rapide : cette option convient parfaitement à la détection de transitions d'intensité de type « bord » sur une surface, telles que des bandes ou des rayures. Elle applique une opération de dilatation-érosion, qui met en surbrillance le bord d'un défaut. Cette option offre le meilleur délai d'exécution. Cependant, en cas de détection de défauts, le périmètre du défaut est signalé, mais pas sa surface.
  • Défauts clairs : cette option convient à la détection des défauts clairs de type « blob » sur un arrière-plan sombre, ainsi qu'à la détection de défauts basée sur la taille en pixels de leur surface. Elle applique une opération de filtrage de haut de forme, qui permet de tout filtrer à l'exception des caractéristiques claires dont la taille est inférieure à celle du paramètre Taille de détection, pour détecter les défauts éventuels.
  • Défauts foncés : cette option convient à la détection des défauts foncés de type « blob » sur un arrière-plan sombre, ainsi qu'à la détection de défauts basée sur la taille en pixels de leur surface. Elle applique une opération de filtrage de bas de forme, qui permet de tout filtrer à l'exception des caractéristiques sombres dont la taille est inférieure à celle du paramètre Taille de détection.
  • Défauts clairs et foncés : cette option convient à la détection des défauts de type « blob », clairs et foncés, ainsi qu'à la détection de défauts basée sur la taille en pixels de leur surface. Elle applique des opérations de filtrage de bas et haut de forme et utilise les résultats maximum des deux opérations.
Remarque : si Défauts clairs, Défauts foncés ou Défauts clairs et foncés est le type sélectionné pour l'opération de détection de défauts, le paramètre Taille de détection doit être défini sur la taille du défaut le plus large à détecter.
Fermé Image affichée

Définit l'image de sortie à afficher (Image d'entrée, Image échantillonnée, Candidats de défaut ou Image de défaut ; valeur par défaut = Image de défaut).

  • Image d'entrée : l'image acquise actuelle est affichée.
  • Image échantillonnée : l'image lissée et échantillonnée est affichée. Si une zone inclinée ou courbe a été utilisée en entrée, la version transformée et redressée est affichée en plus des effets de lissage et d'échantillonnage.
  • Candidats de défaut : les défauts éventuels sont affichés et mis en surbrillance pour illustrer le contraste par rapport à l'arrière-plan.
  • Image de défaut : les défauts sont affichés et dessinés en blanc, alors que toutes les autres zones sont dessinées en noir. Cette option d'affichage comprend les défauts qui se trouvent en dehors des limites des défauts définis (Zone de défaut minimale et Zone de défaut maximale).
Remarque : cette image est uniquement destinée à l'affichage et ne doit pas être utilisée comme image d'entrée pour une autre fonction.
Fermé Facteur d'échantillonnage

Définit la valeur (1 à 99999 ; valeur par défaut = 1) à partir de laquelle l'échantillonnage de l'image d'entrée doit être effectué, en réduisant sa résolution. L'échantillonnage est utilisé pour réduire le délai d'exécution de l'outil, au détriment cependant de la précision. Lors de la détermination de la valeur d'échantillonnage appropriée, une valeur de 1 indique l'absence d'échantillonnage, c'est-à-dire que l'image d'entrée est utilisée en pleine résolution. Des valeurs supérieures indiquent une résolution et une précision inférieures, mais des délais d'exécution supérieurs.

Fermé Lissage automatique

Définit si la fonction doit déterminer le facteur de lissage optimal à partir duquel l'image doit être lissée (valeur par défaut = Désactivé). Lorsque la fonction peut sélectionner le facteur de lissage optimal, les performances sont généralement améliorées.

Remarque : le paramètre Lissage automatique est désactivé par défaut. Pour l'activer, le paramètre Facteur d'échantillonnage doit être défini sur une valeur supérieure à 1. Si le paramètre Facteur d'échantillonnage est défini sur une valeur supérieure à 1 et que le lissage automatique n'est pas souhaité, désactivez le paramètre et définissez la valeur appropriée à l'aide du paramètre Facteur de lissage à la place.
Fermé Facteur de lissage

Définit le facteur (0 à 99999 ; valeur par défaut = 0) à utiliser pour le lissage de l'image. Lors de la détermination de la valeur optimale, commencez par utiliser une valeur comparable à celle spécifiée pour le paramètre Facteur d'échantillonnage. Pour spécifier l'absence de tout lissage, définissez la valeur sur 0.

Remarque : ce paramètre est désactivé lorsque le paramètre Lissage automatique est activé. Si le paramètre Lissage automatique est activé, définissez le paramètre Facteur d'échantillonnage sur une valeur supérieure à 1, puis désactivez le paramètre Lissage automatique. La valeur du paramètre Facteur d'échantillonnage peut maintenant être augmentée.
Fermé Axe de détection

Définit l'axe sur lequel la détection de défauts éventuels doit s'appliquer (X, Y et X et Y ; valeur par défaut = X et Y).

Fermé Taille de détection

Définit la taille du voisinage de détection (1 à 99999 ; valeur par défaut = 1), en pixels. Ce paramètre sert à construire le voisinage de traitement, ou noyau, utilisé par le paramètre Opération de détection de défauts. Pour toutes les opérations de détection de défauts, à l'exception des opérations Rapide, la valeur de taille spécifiée doit correspondre à la longueur ou la largeur des défauts à détecter.

Fermé Contraste de défaut minimum

Définit le seuil d'intensité (1 à 255 ; valeur par défaut = 20) utilisé pour détecter les défauts. Pour qu'un défaut soit détecté, la différence de son intensité par rapport à l'arrière-plan doit correspondre à cette valeur.

Fermé Surface de défaut minimale

Définit la surface minimale (1 à 99999 ; valeur par défaut = 30), en pixels, des défauts à détecter.

Remarque : Cette valeur est toujours exprimée en pixels, même si le projet a été calibré pour utiliser des unités de mesure réelles à l'étape Configurer l'image.
Fermé Surface de défaut maximale

Définit la surface maximale (1 à 99999 ; valeur par défaut = 99999), en pixels, des défauts à détecter.

Remarque : Cette valeur est toujours exprimée en pixels, même si le projet a été calibré pour utiliser des unités de mesure réelles à l'étape Configurer l'image.
Fermé Délai d'attente

Définit la durée, en millisecondes (0 à 30 000 ; valeur par défaut = 5 000), pendant laquelle l'outil recherche les défauts avant que l'exécution ne soit interrompue et que l'outil ne renvoie un échec.

Fermé Total de défauts

Affiche le nombre total de défauts détectés.


Outil de détection des défauts de surface - Onglets Statistiques, Défauts et Région composite

Fermé Onglet Statistiques

L'onglet Statistiques affiche les données concernant le nombre total de défauts et leur taille respective cumulée.

Fermé Onglet Défauts

Le tableau sous l'onglet Défauts répertorie les 10 premiers défauts détectés, classés par zone, du plus grand au plus petit. Il indique l'emplacement des défauts sur l'image (coordonnées X/Y), la zone, le périmètre, l'arrondi et l'intensité.

Fermé Onglet Région composite

L'onglet Région composite est utilisé pour configurer une région composite, un ensemble de sous-régions (Rectangle, Anneau, Cercle, ou Polygone) qui soit font Ajouter à la région (la région sera incluse dans l'analyse de l'image) , soit Soustraire de la région (la région sera exclue de l'analyse de l'image ; également connue comme « masquage »).

Remarque :
  • Un maximum de 32 sous-régions peut être utilisé pour créer une région composite.
  • Un menu est disponible en effectuant un clic droit lors de l'interaction avec la région dans l'image, ce qui vous permet de modifier la forme d'une sous-région sélectionnée, d'ajouter/supprimer une sous-région, ou modifier une sous-région sélectionnée Opération (Ajouter ou Soustraire).
Fermé Table Région composite

Affiche le type de sous-région(s) qui composent la région composite, ainsi que leur Opération (Ajouter ou Soustraire). Sélectionnez une sous-région pour activer les boutons Supprimer, Déplacer vers le haut ou Déplacer vers le bas. Lorsque vous cliquez sur le bouton Supprimer, les sous-régions sélectionnées sont supprimées de la liste ; en cliquant sur le bouton Déplacer vers le haut, les sous-régions sélectionnées sont déplacées vers le haut dans la liste ; enfin, en cliquant sur le bouton Déplacer vers le bas, les sous-régions sélectionnées sont déplacées vers le bas dans la liste.

Remarque :

La région composite est créée à partir de ses séquences de sous-régions dans la liste. En plaçant les sous-régions et leur Opération Soustraire ou Ajouter dans un ordre spécifique, certaines parties de l'image peuvent être mises en surbrillance et d'autres peuvent être ignorées. L'image ci-dessous présente un exemple de la façon appropriée de classer les sous-régions pour exclure une partie de l'image tout en se concentrant sur d'autres zones. Dans le premier ensemble, un Rectangle avec une Opération Ajouter est configuré, puis un Cercle avec une Opération Soustraire est configuré au milieu. Ensuite, un plus petit Rectangle avec une Opération Ajouter est configuré au milieu du Cercle. Le Cercle exclut une partie de l'image, tandis que le plus petit Rectangle ajoute à nouveau une partie de la zone d'image dans l'analyse de l'image. Dans le deuxième ensemble, le plus petit Rectangle est ajouté avant le Cercle et le Cercle masque le plus petit Rectangle, l'excluant de l'analyse de l'image.

Fermé Forme

Affiche la forme de la sous-région sélectionnée (Rectangle, Cercle, Anneau ou Polygone). Pour modifier la forme, sélectionnez le type de région souhaité dans le menu déroulant.

Fermé Opération

Définit l'action de la sous-région sélectionnée dans la région : Ajouter ou Soustraire. Ajouter indique que la sous-région est comprise dans l'analyse de l'image alors que Soustraire indique que la sous-région est exclue de l'analyse de l'image (également appelée « masquage »).

Fermé Rectangle

Insère une sous-région rectangulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Anneau

Insère une sous-région annulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Cercle

Insère une sous-région circulaire dans la région composite. Configure la forme et la taille de la région de façon appropriée.

Fermé Polygone

Insère une sous-région polygonale dans la région composite. Configure la forme et la taille de la région de façon appropriée.


Outils de détection des défauts - Transition

L'outil de détection des défauts de transition construit une ligne ou un cercle ajusté(e) de façon optimale en utilisant des groupes Caliper d'analyse des transitions pour obtenir les emplacements précis des transitions. Une fois la transition identifiée, l'outil construit une ligne ou un cercle ajusté(e) de façon optimale (selon que la transition présente ou non une courbe) sur la transition pour déterminer si elle présente des déviations, telles que des défauts ou des écarts, et renvoie le nombre de défauts et/ou d'écarts détectés.

Remarque :
  • À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
  • Toutes les valeurs d'entrée sont en pixels, que l'outil ait ou non été calibré avec des unités réelles.

L'outil de détection des défauts de transition permet de s'assurer que la pièce ou l'objet ne contient aucune transition avec des déviations, telles que des défauts ou des écarts. Par exemple, pour déterminer si la forme extérieure de la pièce/l'objet est préservée et ne présente pas de petites entailles ou égratignures.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de détection des défauts de transition

Après avoir ajouté l'outil, vous devrez configurer la région masquée de l'image sur la transition à inspecter :

  1. Positionnez et configurez la région dans l'image sur la transition. Lors du positionnement de la région, assurez-vous que les transitions sont parallèles au sens de recherche de la région, et que la région englobe le plus possible la transition, tout en excluant le bruit superflu ou indésirable de la région.

    Remarque : La ligne en pointillés jaune dans la Région masquée définit la zone au sein de la région dans laquelle les transitions seront détectées.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Après avoir confirmé la région, sélectionnez les divers onglets, Transitions, Score de la transition, Ajustement, Défauts et Écarts, et réglez les paramètres et la région selon le besoin pour s'assurer que l'outil détecte les transitions possibles correctes et crée la ligne ou le cercle ajusté(e) de façon optimale correct(e). Lors de la configuration initiale de l'outil, utilisez une image qui contient la transition idéale. Les acquisitions d'images suivantes contiendront alors les transitions possibles qui seront inspectées pour déterminer la présence éventuelle de déviations telles que des défauts ou des écarts.
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de détection des défauts de transition

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de détection des défauts de transition comprend les onglets suivants :

  • Onglet Général
  • Onglet Bords
  • Onglet Score de la transition
  • Onglet Ajustement
  • Onglet Défauts
  • Onglet Écarts
  • Onglets tableaux Écarts et Défauts de position
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Transitions

Onglet Score de la transition

Onglet Ajustement

Onglet Défauts

Onglet Écarts

Onglets Tableaux Défauts et Écarts


Outil de détection des défauts de transition - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « DéfautDeTransition_1 » s'il s'agit du premier outil de détection des défauts de transition ajouté au projet. Sinon, il est incrémenté (par exemple, « DéfautDeTransition_2 », « DéfautDeTransition_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de détection des défauts de transition - Onglet Transitions

Lorsque l'onglet Transitions est sélectionné, l'outil affiche toutes les transitions détectées (en vert foncé) au sein de la région. Vous pouvez ajuster les paramètres Taille du caliper, Espacement de caliper, Largeur de transition et Contraste minimum, selon le besoin, pour isoler les transitions voulues.

Vous pouvez également choisir d'afficher tous les calipers en activant le paramètre Afficher tous les calipers.

La région peut également être sélectionnée et ajustée sous cet onglet.

Fermé Taille du caliper

Définit le nombre de pixels, par caliper, à analyser dans le sens de l'inspection (1 à 639 ; valeur par défaut = 5).

Fermé Espacement de caliper

Définit la distance, en pixels, entre la fin d'un caliper et le début du caliper suivant (-1 à 639 ; valeur par défaut = 0).

Fermé Largeur de transition

Définit la distance de pixels (1 à 10 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Contraste minimum

Définit la transition de contraste minimale en niveaux de gris (1 à 255 ; valeur par défaut = 10) pour être considérée comme une transition.

Fermé Nombre de calipers

Affiche le nombre total de calipers dans la région.

Fermé Index du caliper

Définit le caliper individuel à isoler et à afficher.

Fermé Afficher tous les calipers

Définit si tous les calipers dans la région sont ou non affichés à tout moment. Les calipers sont masqués par défaut.


Outil de détection des défauts de transition - Onglet Score de la transition

Lorsque l'onglet Score de la transition est sélectionné, l'outil affiche toutes les transitions possibles détectées (indiquées par des petits cercles de couleur) au sein de la région (qui peut être sélectionnée et ajustée) et la ligne ou le cercle ajusté(e) de façon optimale résultant(e). Les transitions possibles sont les transitions qui peuvent être prises en compte lors de la construction de la ligne ou du cercle ajusté(e) de façon optimale. Réglez les paramètres pour isoler les transitions possibles voulues.

Tous les défauts et écarts détectés sont également affichés.

Fermé Détection du sens de la transition

Définit le sens dans lequel l'outil tente de détecter les transitions par rapport à la région (Gauche -> droite ou Droite -> gauche ; valeur par défaut = Gauche -> droite).

Fermé Transition

Définit le type de transition (Sombre vers clair, Clair vers sombre ou Indifférent; valeur par défaut = Indifférent). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Règle:Première transition

Définit si la première paire de transitions détectée est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Règle:Transition la plus marquée

Définit si la transition affichant le contraste le plus élevé est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Seuil de score

Définit un seuil de score pour filtrer les transitions avec des scores (0 à 255 ; valeur par défaut = 10) inférieurs à cette valeur.


Outil de détection des défauts de transition - Onglet Ajustement

Lorsque l'onglet Ajustement est sélectionné, l'outil affiche toutes les transitions possibles détectées au sein de la région et la ligne ou le cercle ajusté(e) de façon optimale résultant(e). Les transitions possibles, indiquées par des petits cercles de couleur, sont les transitions qui peuvent être prises en compte lors de la construction de la ligne ou du cercle ajusté(e) de façon optimale.

La région peut également être sélectionnée et ajustée sous cet onglet.

Fermé Observations aberrantes du filtre

Définit si l'outil supprime ou non les points de la ligne ajustée de façon optimale qui se trouvent au-delà de la distance définie par le paramètre Ajuster le filtre de distance (ce paramètre est activé par défaut).

Fermé Ajuster le filtre de distance

Définit la distance (1 à 1 920 ; valeur par défaut = 2), en pixels, à laquelle une transition doit se trouver par rapport à la ligne ajustée de façon optimale d'origine pour être utilisée dans un nouveau calcul d'ajustement. Ce paramètre aide à éviter que les défauts n'affectent l'ajustement de ligne.

Remarque : le paramètre Observations aberrantes du filtre doit être coché (activé) pour utiliser ce paramètre.
Fermé Distance de filtrage du point le plus éloigné

Définit la distance (1 à 1 920 ; valeur par défaut = 1 000) au-delà de laquelle les transitions ne sont pas utilisées pour déterminer les distances minimale et maximale. Toute transition supérieure à cette valeur sera ignorée.

Fermé Nouveau score

Définit si les transitions détectées sont réévaluées pour s'assurer que les transitions détectées initialement ignorées ont été filtrées correctement (ce paramètre est activé par défaut).

Fermé Nouvel ajustement

Définit si l'outil réajuste ou non la ligne ajustée de façon optimale après la réévaluation des transitions (ce paramètre est activé par défaut).

Remarque : l'outil est plus précis lorsque ce paramètre est activé, mais sa durée d'exécution est plus longue.


Outil de détection des défauts de transition - Onglet Défauts

Lorsque l'onglet Défauts est sélectionné, l'outil affiche la ligne ou le cercle ajusté(e) de façon optimale résultant(e), et tous les défauts ou écarts détectés. Les « défauts » sont définis comme des déviations de transition par rapport à la ligne ou au cercle ajusté(e) de façon optimale.

La région peut également être sélectionnée et ajustée sous cet onglet.

Fermé Distance min.

Définit que toute distance en pixels (0,001 à 1 920 ; valeur par défaut = 4), par rapport à la transition et à la ligne ou au cercle ajusté(e) de façon optimale, inférieure à cette valeur n'est pas un défaut.

Fermé Distance max.

Définit que toute distance en pixels (0,001 à 1 920 ; valeur par défaut = 1 000), par rapport à la transition et à la ligne ou au cercle ajusté(e) de façon optimale, supérieure à cette valeur n'est pas un défaut.

Fermé Taille activée

Définit si l'outil tient ou non compte des défauts de taille (qui prennent en compte la longueur le long de la transition). Ce paramètre est activé par défaut.

Remarque : lorsque les paramètres Taille activée et Surface activée sont tous les deux activés, seuls les défauts qui ne remplissent pas les deux conditions sont affichés.
Fermé Taille min.

Définit la taille minimale des défauts (0,001 à 1 920 ; valeur par défaut = 10), en pixels ; les écarts continus par rapport à la ligne ou au cercle ajusté(e) de façon optimale inférieurs à cette valeur ne sont pas considérés comme des défauts.

Fermé Taille max.

Définit la taille maximale des défauts (0,001 à 1 920 ; valeur par défaut = 1 000), en pixels ; les écarts continus par rapport à la ligne ou au cercle ajusté(e) de façon optimale supérieurs à cette valeur ne sont pas considérés comme des défauts.

Fermé Surface activée

Définit si l'outil tient ou non compte des défauts de surface. Ce paramètre est désactivé par défaut. Les défauts de surface prennent en compte la longueur le long de la ligne ou du cercle ajusté(e) de façon optimale et l'éloignement de la transition défectueuse par rapport à la ligne ou au cercle ajusté(e) de façon optimale.

Remarque : lorsque les paramètres Taille activée et Surface activée sont tous les activés, seuls les défauts qui ne remplissent pas les deux conditions sont affichés.
Fermé Surface min.

Définit la surface minimale des défauts de surface (0,001 à 1 000 000 ; valeur par défaut = 10), en pixels ; une surface inférieure à cette valeur n'est pas considérée comme un défaut.

Fermé Surface max.

Définit la surface maximale des défauts de surface (0,001 à 1 000 000 ; valeur par défaut = 1 000 000), en pixels ; une surface supérieure à cette valeur n'est pas considérée comme un défaut.

Fermé Filtre de défauts

Définit si oui ou non les défauts seront filtrés en fonction de leur position, relative à l'ajustement de la ligne (Pas de filtre, Ignorer défauts à gauche de l'ajustement de ligne, Ignorer défauts à droite de l'ajustement de ligne ; valeur par défaut = Pas de filtre).


Outil de détection des défauts de transition - Onglet Écarts

Lorsque l'onglet Écarts est sélectionné, l'outil affiche la ligne ou le cercle ajusté(e) de façon optimale résultant(e), et tous les défauts ou écarts détectés. Les « écarts » sont définis comme des déviations de transition par rapport à la ligne ou au cercle ajusté(e) de façon optimale.

La région peut également être sélectionnée et ajustée sous cet onglet.

Fermé Détection d'écarts

Définit si l'outil tient ou non compte des écarts dans la transition détectée. Ce paramètre est activé par défaut.

Fermé Écart minimal

Définit l'écart minimal (0,001 à 1 920 ; valeur par défaut = 3), en pixels. Les écarts inférieurs à cette valeur ne sont pas considérés comme des écarts.

Fermé Écart maximal

Définit l'écart maximal (0,001 à 1 920 ; valeur par défaut = 1 000), en pixels. Les écarts supérieurs à cette valeur ne sont pas considérés comme des écarts.

Fermé Ignorer les écarts de fin

Définit si l'outil tient ou non compte des écarts détectés au début et à la fin de la région. Ce paramètre est désactivé par défaut.

Fermé Résultat

Affiche le nombre total de défauts et/ou écarts détectés.


Outil de détection des défauts de transition - Onglets tableaux Écarts et Défauts de position

Les onglets tableaux Défauts et Écarts renvoient les 10 premiers défauts/écarts localisés, triés en fonction de leur position le long de la transition.

Fermé Index

Indique l'ordre des défauts/écarts localisés, triés en fonction de leur position le long de la transition ; de 1 à 10 (dans l'ordre numérique d'EasyBuilder, 0=1).

Fermé X

Renvoie l'abscisse (si le paramètre Unités calibrées est sélectionné et que l'image a été calibrée à l'étape Configurer l'image ; sinon renvoie les valeurs en pixels) du rectangle englobant le défaut/l'écart.

Fermé Y

Renvoie l'ordonnée (si le paramètre Unités calibrées est sélectionné et que l'image a été calibrée à l'étape Configurer l'image ; sinon renvoie les valeurs en pixels) du rectangle englobant le défaut/l'écart.

Fermé Surface

Renvoie la surface du rectangle englobant le défaut/l'écart.

Fermé Taille

Renvoie la taille (longueur) du défaut/de l'écart le long de la transition.

Fermé Calipers

Renvoie la plage de calipers couverte par le défaut/l'écart.

Fermé Unités calibrées/Pixels

Définit si le tableau affiche ou non les résultats dans les coordonnées réelles (Unités calibrées) ou en pixels (Pixels).

Remarque : À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.


Outils de détection des défauts - Paire de transitions

L'outil de détection des défauts de paire de transitions construit une paire de lignes ou cercles ajusté(e)s de façon optimale en utilisant des groupes Caliper d'analyse des transitions pour obtenir les emplacements précis des transitions. Une fois les transitions identifiées, l'outil construit une paire de lignes ou cercles ajusté(e)s de façon optimale (selon que les transitions présentent ou non une courbe) sur les transitions pour déterminer si elles présentent des déviations, telles que des défauts ou des écarts, et renvoie le nombre de défauts et/ou d'écarts détectés.

Remarque :
  • À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
  • Toutes les valeurs d'entrée sont en pixels, que l'outil ait ou non été calibré avec des unités réelles.

L'outil de détection des défauts de paire de transitions permet de s'assurer que la pièce ou l'objet ne contient aucune transition avec des déviations, telles que des défauts ou des écarts. Par exemple, pour déterminer si la pièce/l'objet comporte des transitions qui maintiennent leur forme et si les transitions ne présentent pas de petites entailles ou égratignures.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de détection des défauts de paire de transitions

Après avoir ajouté l'outil, vous devrez configurer la région masquée de l'image sur la transition à inspecter :

  1. Positionnez et configurez la région dans l'image sur la transition. Lors du positionnement de la région, assurez-vous que les transitions sont parallèles au sens de recherche de la région, et que la région englobe le plus possible la transition, tout en excluant le bruit superflu ou indésirable de la région.

    Remarque : La ligne en pointillés jaune dans la Région masquée définit la zone au sein de la région dans laquelle les transitions seront détectées.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Après avoir confirmé la région, sélectionnez les divers onglets, Transitions, Score de la transition, Ajustement, Défauts et Écarts, et réglez les paramètres et la région selon le besoin pour s'assurer que l'outil détecte les transitions possibles correctes et crée la ligne ou le cercle ajusté(e) de façon optimale correct(e). Lors de la configuration initiale de l'outil, utilisez une image qui contient la transition idéale. Les acquisitions d'images suivantes contiendront alors les transitions possibles qui seront inspectées pour déterminer la présence éventuelle de déviations telles que des défauts ou des écarts.
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de détection des défauts de paire de transitions

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de détection des défauts de paire de transition comprend les onglets suivants :

  • Onglet Général
  • Onglet Bords
  • Onglet Score de la transition
  • Onglet Ajustement
  • Onglet Défauts
  • Onglet Écarts
  • Onglets tableaux Écarts, Défauts 0 de transition et Défauts 1 de transition
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Transitions

Onglet Score de la transition

Onglet Ajustement

Onglet Défauts

Onglet Écarts

Onglets Tableaux Défauts de transition 0, Défauts de transition 1 et Écarts


Outil de détection des défauts de paire de transitions - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « DéfautPaireDeTransitions_1 » s'il s'agit du premier outil de détection des défauts de paire de transitions ajouté au projet. Sinon, il est incrémenté (par exemple, « DéfautPaireDeTransitions_2 », « DéfautPaireDeTransitions_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de détection des défauts de paire de transitions - Onglet Transitions

Lorsque l'onglet Transitions est sélectionné, l'outil affiche toutes les transitions détectées (en vert foncé) au sein de la région. Vous pouvez ajuster les paramètres Taille du caliper, Espacement de caliper, Largeur de transition et Contraste minimum, selon le besoin, pour isoler les transitions voulues.

Vous pouvez également choisir d'afficher tous les calipers en activant le paramètre Afficher tous les calipers.

La région peut également être sélectionnée et ajustée sous cet onglet.

Fermé Taille du caliper

Définit le nombre de pixels, par caliper, à analyser dans le sens de l'inspection (1 à 639 ; valeur par défaut = 5).

Fermé Espacement de caliper

Définit la distance, en pixels, entre la fin d'un caliper et le début du caliper suivant (-1 à 639 ; valeur par défaut = 0).

Fermé Largeur de transition

Définit la distance de pixels (1 à 10 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Contraste minimum

Définit la transition de contraste minimale en niveaux de gris (1 à 255 ; valeur par défaut = 10) pour être considérée comme une transition.

Fermé Nombre de calipers

Affiche le nombre total de calipers dans la région.

Fermé Index du caliper

Définit le caliper individuel à isoler et à afficher.

Fermé Afficher tous les calipers

Définit si tous les calipers dans la région sont ou non affichés à tout moment. Les calipers sont masqués par défaut.


Outil de détection des défauts de paire de transitions - Onglet Score de la transition

Lorsque l'onglet Score de la transition est sélectionné, l'outil affiche toutes les transitions possibles détectées (indiquées par des petits cercles de couleur) au sein de la région (qui peut être sélectionnée et ajustée) et la ligne ou le cercle ajusté(e) de façon optimale résultant(e). Les transitions possibles sont les transitions qui peuvent être prises en compte lors de la construction de la ligne ou du cercle ajusté(e) de façon optimale. Réglez les paramètres pour isoler les transitions possibles voulues.

Tous les défauts et écarts détectés sont également affichés.

Fermé Détection du sens de la transition

Définit le sens dans lequel l'outil tente de détecter les transitions par rapport à la région (Gauche -> droite, Droite -> gauche, Centre -> extérieur ou Extérieur -> intérieur ; valeur par défaut = Gauche -> droite).

Fermé Transition transition0

Définit le type de la première transition détectée (Sombre vers clair, Clair vers sombre ou Indifférent ; valeur par défaut = Indifférent). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Transition transition1
(missing or bad snippet)
Fermé Règle:Première transition

Définit si la première paire de transitions détectée est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Règle:Transition la plus marquée

Définit si la transition affichant le contraste le plus élevé est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Règle:Taille des paires

Définit si la paire de transitions détectée avec la taille la plus proche du paramètre Taille des paires est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est désactivé par défaut).

Fermé Taille des paires

Définit la taille des paires de transitions à laquelle le score le plus élevé est atteint (1 à 1 920 ; valeur par défaut = 5). Lorsque ce paramètre est activé, le score des paires de transitions inférieur ou supérieur est déterminé proportionnellement. Par exemple, si Taille des paires est défini sur 10 et que deux paires de transitions possibles sont détectées, l'une avec une valeur de 8 et l'autre avec une valeur de 14, la paire de transitions avec la valeur de 8 est sélectionnée car elle est plus proche de la limite que la deuxième paire de transitions. Le paramètre Règle:Taille des paires doit être ACTIVÉ pour activer ce paramètre.

Fermé Seuil de score

Définit un seuil de score pour filtrer les transitions avec des scores (0 à 255 ; valeur par défaut = 10) inférieurs à cette valeur.


Outil de détection des défauts de paire de transitions - Onglet Ajustement

Lorsque l'onglet Ajustement est sélectionné, l'outil affiche toutes les transitions possibles détectées au sein de la région et la ligne ou le cercle ajusté(e) de façon optimale résultant(e). Les transitions possibles, indiquées par des petits cercles de couleur, sont les transitions qui peuvent être prises en compte lors de la construction de la ligne ou du cercle ajusté(e) de façon optimale.

La région peut également être sélectionnée et ajustée sous cet onglet.

Fermé Observations aberrantes du filtre

Définit si l'outil supprime ou non les points de la ligne ajustée de façon optimale qui se trouvent au-delà de la distance définie par le paramètre Ajuster le filtre de distance (ce paramètre est activé par défaut).

Fermé Ajuster le filtre de distance

Définit la distance (1 à 1 920 ; valeur par défaut = 2), en pixels, à laquelle une transition doit se trouver par rapport à la ligne ajustée de façon optimale d'origine pour être utilisée dans un nouveau calcul d'ajustement. Ce paramètre aide à éviter que les défauts n'affectent l'ajustement de ligne.

Remarque : le paramètre Observations aberrantes du filtre doit être coché (activé) pour utiliser ce paramètre.
Fermé Distance de filtrage du point le plus éloigné

Définit la distance (1 à 1 920 ; valeur par défaut = 1 000) au-delà de laquelle les transitions ne sont pas utilisées pour déterminer les distances minimale et maximale. Toute transition supérieure à cette valeur sera ignorée.

Fermé Nouveau score

Définit si les transitions détectées sont réévaluées pour s'assurer que les transitions détectées initialement ignorées ont été filtrées correctement (ce paramètre est activé par défaut).

Fermé Nouvel ajustement

Définit si l'outil réajuste ou non la ligne ajustée de façon optimale après la réévaluation des transitions (ce paramètre est activé par défaut).

Remarque : l'outil est plus précis lorsque ce paramètre est activé, mais sa durée d'exécution est plus longue.


Outil de détection des défauts de paire de transition - Onglet Défauts

Lorsque l'onglet Défauts est sélectionné, l'outil affiche la ligne ou le cercle ajusté(e) de façon optimale résultant(e), et tous les défauts ou écarts détectés. Les « défauts » sont définis comme des déviations de transition par rapport à la ligne ou au cercle ajusté(e) de façon optimale.

La région peut également être sélectionnée et ajustée sous cet onglet.

Fermé Distance min.

Définit que toute distance en pixels (0,001 à 1 920 ; valeur par défaut = 4), par rapport à la transition et à la ligne ou au cercle ajusté(e) de façon optimale, inférieure à cette valeur n'est pas un défaut.

Fermé Distance max.

Définit que toute distance en pixels (0,001 à 1 920 ; valeur par défaut = 1 000), par rapport à la transition et à la ligne ou au cercle ajusté(e) de façon optimale, supérieure à cette valeur n'est pas un défaut.

Fermé Taille activée

Définit si l'outil tient ou non compte des défauts de taille (qui prennent en compte la longueur le long de la transition). Ce paramètre est activé par défaut.

Remarque : lorsque les paramètres Taille activée et Surface activée sont tous les deux activés, seuls les défauts qui ne remplissent pas les deux conditions sont affichés.
Fermé Taille min.

Définit la taille minimale des défauts (0,001 à 1 920 ; valeur par défaut = 10), en pixels ; les écarts continus par rapport à la ligne ou au cercle ajusté(e) de façon optimale inférieurs à cette valeur ne sont pas considérés comme des défauts.

Fermé Taille max.

Définit la taille maximale des défauts (0,001 à 1 920 ; valeur par défaut = 1 000), en pixels ; les écarts continus par rapport à la ligne ou au cercle ajusté(e) de façon optimale supérieurs à cette valeur ne sont pas considérés comme des défauts.

Fermé Surface activée

Définit si l'outil tient ou non compte des défauts de surface. Ce paramètre est désactivé par défaut. Les défauts de surface prennent en compte la longueur le long de la ligne ou du cercle ajusté(e) de façon optimale et l'éloignement de la transition défectueuse par rapport à la ligne ou au cercle ajusté(e) de façon optimale.

Remarque : lorsque les paramètres Taille activée et Surface activée sont tous les activés, seuls les défauts qui ne remplissent pas les deux conditions sont affichés.
Fermé Surface min.

Définit la surface minimale des défauts de surface (0,001 à 1 000 000 ; valeur par défaut = 10), en pixels ; une surface inférieure à cette valeur n'est pas considérée comme un défaut.

Fermé Surface max.

Définit la surface maximale des défauts de surface (0,001 à 1 000 000 ; valeur par défaut = 1 000 000), en pixels ; une surface supérieure à cette valeur n'est pas considérée comme un défaut.

Fermé Filtre de défauts

Définit si oui ou non les défauts seront filtrés en fonction de leur position, relative à l'ajustement de la ligne (Pas de filtre, Ignorer défauts à gauche de l'ajustement de ligne, Ignorer défauts à droite de l'ajustement de ligne ; valeur par défaut = Pas de filtre).


Outil de détection des défauts de paire de transitions - Onglet Écarts

Lorsque l'onglet Écarts est sélectionné, l'outil affiche la ligne ou le cercle ajusté(e) de façon optimale résultant(e), et tous les défauts ou écarts détectés. Les « écarts » sont définis comme des déviations de transition par rapport à la ligne ou au cercle ajusté(e) de façon optimale.

La région peut également être sélectionnée et ajustée sous cet onglet.

Fermé Détection d'écarts

Définit si l'outil tient ou non compte des écarts dans la transition détectée. Ce paramètre est activé par défaut.

Fermé Écart minimal

Définit l'écart minimal (0,001 à 1 920 ; valeur par défaut = 3), en pixels. Les écarts inférieurs à cette valeur ne sont pas considérés comme des écarts.

Fermé Écart maximal

Définit l'écart maximal (0,001 à 1 920 ; valeur par défaut = 1 000), en pixels. Les écarts supérieurs à cette valeur ne sont pas considérés comme des écarts.

Fermé Ignorer les écarts de fin

Définit si l'outil tient ou non compte des écarts détectés au début et à la fin de la région. Ce paramètre est désactivé par défaut.

Fermé Résultat

Affiche le nombre total de défauts et/ou écarts détectés.


Outil de détection des défauts de paire de transition - Onglets des tableaux des Défauts de transition 0, Défauts de transition 1 et Écarts

Les onglets à tableaux Défauts de transition 0, Défauts de transition 1 et Écarts renvoient les 10 premiers défauts/écarts localisés, triés en fonction de leur position le long de la transition. La Transition 0 se réfère à la première transition localisée de la paire, alors que Transition 1 se réfère à la deuxième transition.

Fermé Index

Indique l'ordre des défauts/écarts localisés, triés en fonction de leur position le long de la transition ; de 1 à 10 (dans l'ordre numérique d'EasyBuilder, 0=1).

Fermé X

Renvoie l'abscisse (si le paramètre Unités calibrées est sélectionné et que l'image a été calibrée à l'étape Configurer l'image ; sinon renvoie les valeurs en pixels) du rectangle englobant le défaut/l'écart.

Fermé Y

Renvoie l'ordonnée (si le paramètre Unités calibrées est sélectionné et que l'image a été calibrée à l'étape Configurer l'image ; sinon renvoie les valeurs en pixels) du rectangle englobant le défaut/l'écart.

Fermé Surface

Renvoie la surface du rectangle englobant le défaut/l'écart.

Fermé Taille

Renvoie la taille (longueur) du défaut/de l'écart le long de la transition.

Fermé Calipers

Renvoie la plage de calipers couverte par le défaut/l'écart.

Fermé Unités calibrées/Pixels

Définit si le tableau affiche ou non les résultats dans les coordonnées réelles (Unités calibrées) ou en pixels (Pixels).

Remarque : À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.


Outils de détection des défauts - Largeur de transition

L'outil de détection des défauts de largeur de transition mesure l'épaisseur d'une paire de transitions et vérifie qu'elle est dans les tolérances. Il utilise des groupes Caliper d'analyse des transitions pour obtenir les emplacements précis des transitions pour déterminer si elles présentent des déviations, telles que des défauts ou des écarts, et renvoie le nombre de défauts et/ou d'écarts détectés.

Remarque :
  • À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
  • Toutes les valeurs d'entrée sont en pixels, que l'outil ait ou non été calibré avec des unités réelles.

L'outil de détection des défauts de largeur de transition permet de s'assurer que la pièce ou l'objet ne contient aucune transition avec des déviations, telles que des défauts ou des écarts. Par exemple, pour déterminer si une soudure en continu conserve ou non la largeur appropriée à chaque fois.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de détection des défauts de largeur de transition

Après avoir ajouté l'outil, vous devrez sélectionner le type de région puis configurer cette dernière dans l'image sur la transition à inspecter :

  1. Dans le menu déroulant Type de région, sélectionnez la région : Région masquée ou Chemin polylinéaire. Positionnez et configurez la région dans l'image sur la transition. Lors du positionnement de la région, assurez-vous que les transitions sont parallèles au sens de recherche de la région, et que la région englobe le plus possible la transition, tout en excluant le bruit superflu ou indésirable de la région.

    Remarque : La ligne en pointillés jaune dans la Région masquée définit la zone au sein de la région dans laquelle les transitions seront détectées.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Après avoir confirmé la région, sélectionnez les divers onglets, Transitions, Score de la transition, Observations aberrantes, Défauts et Écarts, et réglez les paramètres et la région selon le besoin pour s'assurer que l'outil détecte les transitions possibles correctes. Lors de la configuration initiale de l'outil, utilisez une image qui contient la transition idéale. Les acquisitions d'images suivantes contiendront alors les transitions possibles qui seront inspectées pour déterminer la présence éventuelle de déviations telles que des défauts ou des écarts.

    Remarque : l'outil peut également créer une ligne ou un cercle ajusté(e) de façon optimale si le paramètre Nouveau score de l'onglet Observations aberrantes est activé.
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de détection des défauts de largeur de transition

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de détection des défauts de largeur de transition comprend les onglets suivants :

  • Onglet Général
  • Onglet Transitions
  • Onglet Score de la transition
  • Onglet Observations aberrantes
  • Onglet Défauts
  • Onglet Écarts
  • Onglets tableaux Défauts de largeur et Écarts
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Transitions

Onglet Score de la transition

Onglet Observations aberrantes

Onglet Défauts

Onglet Écarts

Onglets tableaux Défauts de largeur et Écarts


Outil de détection des défauts de largeur de transition - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « LargeurDeTransition_1 » s'il s'agit du premier outil de détection des défauts de largeur de transition ajouté au projet. Sinon, il est incrémenté (par exemple, « LargeurDeTransition_2 », « LargeurDeTransition_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Type de région

Définit le type de région (Région masquée ou Chemin polyligne ; par défaut = Région masquée) que l'outil va utiliser pour détecter les caractéristiques de la transition.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de détection des défauts de largeur de transition - Onglet Transitions

Lorsque l'onglet Transitions est sélectionné, l'outil affiche toutes les transitions détectées (en vert foncé) au sein de la région. Vous pouvez ajuster les paramètres Taille du caliper, Espacement de caliper, Largeur de transition et Contraste minimum, selon le besoin, pour isoler les transitions voulues.

Vous pouvez également choisir d'afficher tous les calipers en activant le paramètre Afficher tous les calipers.

La région peut également être sélectionnée et ajustée sous cet onglet.

Fermé Taille du caliper

Définit le nombre de pixels, par caliper, à analyser dans le sens de l'inspection (1 à 639 ; valeur par défaut = 5).

Fermé Espacement de caliper

Définit la distance, en pixels, entre la fin d'un caliper et le début du caliper suivant (-1 à 639 ; valeur par défaut = 0).

Fermé Largeur de transition

Définit la distance de pixels (1 à 10 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Contraste minimum

Définit la transition de contraste minimale en niveaux de gris (1 à 255 ; valeur par défaut = 10) pour être considérée comme une transition.

Fermé Nombre de calipers

Affiche le nombre total de calipers dans la région.

Fermé Index du caliper

Définit le caliper individuel à isoler et à afficher.

Fermé Afficher tous les calipers

Définit si tous les calipers dans la région sont ou non affichés à tout moment. Les calipers sont masqués par défaut.


Outil de détection des défauts de largeur de transition - Onglet Score de la transition

Lorsque l'onglet Score de la transition est sélectionné, l'outil affiche toutes les transitions possibles détectées (indiquées par des petits cercles de couleur) au sein de la région (qui peut être sélectionnée et ajustée). Réglez les paramètres pour isoler les transitions possibles voulues.

Remarque : l'outil peut également créer une ligne ou un cercle ajusté(e) de façon optimale si le paramètre Nouveau score de l'onglet Observations aberrantes est activé.

Tous les défauts et écarts détectés sont également affichés, ainsi que les largeurs minimale et maximale des transitions, indiquées avec des lignes jaunes.

Fermé Détection du sens de la transition

Définit le sens dans lequel l'outil tente de détecter les transitions par rapport à la région (Gauche -> droite, Droite -> gauche, Centre -> extérieur ou Extérieur -> intérieur ; valeur par défaut = Gauche -> droite).

Fermé Transition transition0

Définit le type de la première transition détectée (Sombre vers clair, Clair vers sombre ou Indifférent ; valeur par défaut = Indifférent). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Transition transition1
(missing or bad snippet)
Fermé Règle:Première transition

Définit si la première paire de transitions détectée est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Règle:Transition la plus marquée

Définit si la transition affichant le contraste le plus élevé est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Limite de contraste supérieure

Définit la limite supérieure de la transition de contraste de transition (2 à 255 ; valeur par défaut = 255) à considérer comme une transition. Les transitions dont la valeur de contraste est supérieure à cette valeur auront le même score le plus élevé.

Fermé Règle:Taille des paires

Définit si la paire de transitions détectée avec la taille la plus proche du paramètre Taille des paires est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est désactivé par défaut).

Fermé Taille des paires

Définit la taille des paires de transitions à laquelle le score le plus élevé est atteint (1 à 1 920 ; valeur par défaut = 5). Lorsque ce paramètre est activé, le score des paires de transitions inférieur ou supérieur est déterminé proportionnellement. Par exemple, si Taille des paires est défini sur 10 et que deux paires de transitions possibles sont détectées, l'une avec une valeur de 8 et l'autre avec une valeur de 14, la paire de transitions avec la valeur de 8 est sélectionnée car elle est plus proche de la limite que la deuxième paire de transitions. Le paramètre Règle:Taille des paires doit être ACTIVÉ pour activer ce paramètre.

Fermé Seuil de score

Définit un seuil de score pour filtrer les transitions avec des scores (0 à 255 ; valeur par défaut = 10) inférieurs à cette valeur.


Outil de détection des défauts de largeur de transition - Onglet Observations aberrantes

Lorsque l'onglet Observations aberrantes est sélectionné, l'outil affiche toutes les transitions possibles détectées au sein de la région et la ligne ou le cercle ajusté(e) de façon optimale résultant(e). Les transitions possibles, indiquées par des petits cercles de couleur, sont les transitions qui peuvent être prises en compte lors de la construction de la ligne ou du cercle ajusté(e) de façon optimale.

La région peut également être sélectionnée et ajustée dans cet onglet.

Tous les défauts et écarts détectés sont également affichés, ainsi que les largeurs minimale et maximale des transitions, indiquées avec des lignes jaunes.

Fermé Nouveau score

Définit si l'outil réajuste ou non la ligne ajustée de façon optimale après la réévaluation des transitions (ce paramètre est désactivé par défaut).

Remarque : L'outil est plus précis lorsque ce paramètre est activé, mais sa durée d'exécution est plus longue.
Fermé Ajustement de la ligne

Définit le type de ligne ajustée de façon optimale (Ajustement automatique, Ajustement de la ligne droite ou Ajustement du cercle ; valeur par défaut = Ajustement automatique) à construire à partir des transitions détectées.

Remarque : Le paramètre Nouveau score doit être coché (activé) pour utiliser ce paramètre.
Fermé Observations aberrantes du filtre

Définit si l'outil supprime ou non les points de la ligne ajustée de façon optimale qui se trouvent au-delà de la distance définie par le paramètre Ajuster le filtre de distance (ce paramètre est désactivé par défaut).

Fermé Ajuster le filtre de distance

Définit la distance (1 à 1 920 ; valeur par défaut = 2), en pixels, à laquelle une transition doit se trouver par rapport à la ligne ajustée de façon optimale d'origine pour être utilisée dans un nouveau calcul d'ajustement. Ce paramètre aide à éviter que les défauts n'affectent l'ajustement de ligne.

Remarque : le paramètre Observations aberrantes du filtre doit être coché (activé) pour utiliser ce paramètre.


Outil de détection des défauts de largeur de transition - Onglet Défauts

Lorsque l'onglet Défauts est sélectionné, l'outil affiche (avec des lignes jaunes) les épaisseurs minimale et maximale de la paire de transitions détectée, et tous les défauts et/ou écarts détectés.

La région peut également être sélectionnée et ajustée dans cet onglet.

Fermé Largeur min.

Définit que toute distance en pixels (0,001 à 1 920 ; valeur par défaut = 3), entre les paires de transition détectées, inférieure à cette valeur n'est pas un défaut.

Fermé Largeur max.

Définit que toute distance en pixels (0,001 à 1 920 ; valeur par défaut = 1 000), entre les paires de transition détectées, supérieure à cette valeur n'est pas un défaut.

Fermé Taille activée

Définit si l'outil tient ou non compte des défauts de taille (qui prennent en compte la longueur le long de la transition). Ce paramètre est activé par défaut.

Remarque : lorsque les paramètres Taille activée et Surface activée sont tous les deux activés, seuls les défauts qui ne remplissent pas les deux conditions sont affichés.
Fermé Taille min.

Définit la taille minimale des défauts (0,001 à 1 920 ; valeur par défaut = 10), en pixels ; les écarts continus par rapport à la ligne ou au cercle ajusté(e) de façon optimale inférieurs à cette valeur ne sont pas considérés comme des défauts.

Fermé Taille max.

Définit la taille maximale des défauts (0,001 à 1 920 ; valeur par défaut = 1 000), en pixels ; les écarts continus par rapport à la ligne ou au cercle ajusté(e) de façon optimale supérieurs à cette valeur ne sont pas considérés comme des défauts.

Fermé Surface activée

Définit si l'outil tient ou non compte des défauts de surface. Ce paramètre est désactivé par défaut. Les défauts de surface prennent en compte la longueur le long de la ligne ou du cercle ajusté(e) de façon optimale et l'éloignement de la transition défectueuse par rapport à la ligne ou au cercle ajusté(e) de façon optimale.

Remarque : lorsque les paramètres Taille activée et Surface activée sont tous les activés, seuls les défauts qui ne remplissent pas les deux conditions sont affichés.
Fermé Surface min.

Définit la surface minimale des défauts de surface (0,001 à 1 000 000 ; valeur par défaut = 10), en pixels ; une surface inférieure à cette valeur n'est pas considérée comme un défaut.

Fermé Surface max.

Définit la surface maximale des défauts de surface (0,001 à 1 000 000 ; valeur par défaut = 1 000 000), en pixels ; une surface supérieure à cette valeur n'est pas considérée comme un défaut.


Outil de détection des défauts de largeur de transition - Onglet Écarts

Lorsque l'onglet Écarts est sélectionné, l'outil affiche la ligne ou le cercle ajusté(e) de façon optimale (si le paramètre est activé), et tous les défauts ou écarts détectés. Les « écarts » sont définis comme des déviations de transition par rapport à la ligne ou au cercle ajusté(e) de façon optimale.

La région peut également être sélectionnée et ajustée dans cet onglet.

Fermé Détection d'écarts

Définit si l'outil tient ou non compte des écarts dans la transition détectée. Ce paramètre est activé par défaut.

Fermé Écart minimal

Définit l'écart minimal (0,001 à 1 920 ; valeur par défaut = 3), en pixels. Les écarts inférieurs à cette valeur ne sont pas considérés comme des écarts.

Fermé Écart maximal

Définit l'écart maximal (0,001 à 1 920 ; valeur par défaut = 1 000), en pixels. Les écarts supérieurs à cette valeur ne sont pas considérés comme des écarts.

Fermé Ignorer les écarts de fin

Définit si l'outil tient ou non compte des écarts détectés au début et à la fin de la région. Ce paramètre est désactivé par défaut.

Fermé Résultat

Affiche le nombre total de défauts et/ou écarts détectés.


Outil de détection des défauts de largeur de transition - Onglets à tableaux Défauts de largeur et Écarts

Les onglets à tableaux Défauts de largeur et Écarts renvoient les 10 premiers défauts/écarts localisés, triés en fonction de leur position le long de la transition.

Fermé Index

Indique l'ordre des défauts/écarts localisés, triés en fonction de leur position le long de la transition ; de 1 à 10 (dans l'ordre numérique d'EasyBuilder, 0=1).

Fermé X

Renvoie l'abscisse (si le paramètre Unités calibrées est sélectionné et que l'image a été calibrée à l'étape Configurer l'image ; sinon renvoie les valeurs en pixels) du rectangle englobant le défaut/l'écart.

Fermé Y

Renvoie l'ordonnée (si le paramètre Unités calibrées est sélectionné et que l'image a été calibrée à l'étape Configurer l'image ; sinon renvoie les valeurs en pixels) du rectangle englobant le défaut/l'écart.

Fermé Surface

Renvoie la surface du rectangle englobant le défaut/l'écart.

Fermé Taille

Renvoie la taille (longueur) du défaut/de l'écart le long de la transition.

Fermé Calipers

Renvoie la plage de calipers couverte par le défaut/l'écart.

Fermé Unités calibrées/Pixels

Définit si le tableau affiche ou non les résultats dans les coordonnées réelles (Unités calibrées) ou en pixels (Pixels).

Remarque : À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.


Outils de détection des défauts - Détecteur de filet

L'outil de détection des défauts de détecteur de filet identifie un filet (défini par une paire de transitions), quelle qu'en soit la forme, en détectant le centre du filet et en créant une région pouvant être utilisée pour inspecter la largeur du filet. Il utilise des groupes Caliper d'analyse des transitions pour obtenir les emplacements précis des transitions. Une fois le filet identifié, l'outil trace le filet et signale les variations hors tolérances dans son épaisseur comme des défauts ou des écarts.

Remarque :
  • À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
  • Toutes les valeurs d'entrée sont en pixels, que l'outil ait ou non été calibré avec des unités réelles.

L'outil de détection des défauts de détecteur de filet est utile pour identifier et vérifier l'épaisseur d'une caractéristique de filet, telle qu'un filet de colle, qui apparaît de façon aléatoire dans le champ de vue.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de détection des défauts de détecteur de filet

Après avoir ajouté l'outil, vous devrez sélectionner le type de région puis configurer cette dernière dans l'image sur la transition à inspecter :

  1. Dans le menu déroulant Type de région, sélectionnez la région : Région masquée ou Chemin polylinéaire. Positionnez et configurez la région dans l'image sur la transition. Lors du positionnement de la région, assurez-vous que les transitions sont parallèles au sens de recherche de la région, et que la région englobe le plus possible la transition, tout en excluant le bruit superflu ou indésirable de la région.

    Remarque : La ligne en pointillés jaune dans la Région masquée définit la zone au sein de la région dans laquelle les transitions seront détectées.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Après avoir confirmé la région, sélectionnez les divers onglets, Détection de filet, Transitions, Score de la transition, Défauts et Écarts, et réglez les paramètres et la région selon le besoin pour s'assurer que l'outil détecte les transitions possibles correctes et crée la polyligne correcte. Lors de la configuration initiale de l'outil, utilisez une image qui contient la transition idéale. Les acquisitions d'images suivantes contiendront alors les transitions possibles qui seront inspectées pour déterminer la présence éventuelle de déviations telles que des défauts ou des écarts.
  4. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  5. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de détection des défauts de détecteur de filet

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de détection des défauts de détecteur de filet comprend les onglets suivants :

  • Onglet Général
  • Détection de filet
  • Onglet Transitions
  • Onglet Score de la transition
  • Onglet Défauts
  • Onglet Écarts
  • Onglets tableaux Statistiques, Défauts de largeur et Écarts
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Détection de filet

Onglet Transitions

Onglet Score de la transition

Onglet Défauts

Onglet Écarts

Onglets tableaux Statistiques, Défauts de largeur et Écarts


Outil de détection des défauts de détecteur de filet - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « DétecteurDeFilet_1 » s'il s'agit du premier outil de détection des défauts de détecteur de filet ajouté au projet. Sinon, il est incrémenté (par exemple, « DétecteurDeFilet_2 », « DétecteurDeFilet_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Type de région

Définit le type de région utilisé pour définir la zone de l'image analysée : Région masquée (par défaut) ou Chemin polylinéaire.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de détection des défauts de détecteur de filet - Onglet Détection de filet

Lorsque l'onglet Détection de filet est sélectionné, l'outil affiche les graphiques permettant de localiser le filet. L'outil affiche toutes les transitions détectées (en vert foncé), les transitions possibles sélectionnées (indiquées par des petits cercles de couleur) au sein de la région (qui peut être sélectionnée et ajustée) et l'emplacement du filet sous la forme d'une polyligne bleue.

Vous pouvez ajuster les paramètres pour isoler les transitions voulues et les transitions possibles à utiliser pour construire le chemin polylinéaire qui délimite le filet.

Fermé Taille de calipers de détection de filet

Définit le nombre de pixels, par caliper, à analyser dans le sens de l'inspection pour localiser le filet (1 à 639 ; valeur par défaut = 8).

Fermé Espacement de calipers de détection de filet

Définit la distance, en pixels, entre la fin d'un caliper et le début du caliper suivant (-1 à 639 ; valeur par défaut = 0).

Fermé Largeur de transition de détection de filet

Définit la distance de pixels (1 à 10 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Contraste minimum de détection de filet

Définit la transition de contraste minimale en niveaux de gris (1 à 255 ; valeur par défaut = 10) pour être considérée comme une transition.

Fermé Sens de transition de détection de filet

Définit le sens dans lequel l'outil tente de détecter les transitions par rapport à la région (Gauche -> droite, Droite -> gauche, Centre -> extérieur ou Extérieur -> intérieur ; valeur par défaut = Gauche -> droite).

Fermé Transition transition0 de détection de filet

Définit le type de la première transition détectée (Sombre vers clair, Clair vers sombre ou Indifférent ; valeur par défaut = Indifférent). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Transition transition1 de détection de filet
(missing or bad snippet)
Fermé Règle de détection de filet:Première transition

Définit si la première paire de transitions détectée est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Règle de détection de filet:Transition la plus marquée

Définit si la transition affichant le contraste le plus élevé est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Limite de contraste supérieure de détection de filet

Définit la limite supérieure de la transition de contraste de transition (2 à 255 ; valeur par défaut = 255) à considérer comme une transition. Les transitions dont la valeur de contraste est supérieure à cette valeur auront le même score le plus élevé.

Fermé Règle de détection de filet:Taille de la paire

Définit si la paire de transitions détectée avec la taille la plus proche du paramètre Taille des paires est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est désactivé par défaut).

Fermé Seuil de score de détection de filet

Définit un seuil de score pour filtrer les transitions avec des scores (0 à 255 ; valeur par défaut = 10) inférieurs à cette valeur.

Fermé Calipers de détection de filet

Affiche le nombre total de calipers dans la région.

Fermé Index de calipers de détection de filet

Définit le caliper individuel à isoler et à afficher.

Fermé Afficher tous les calipers de détection de filet

Définit si tous les calipers dans la région sont ou non affichés à tout moment. Les calipers sont masqués par défaut.


Outil de détection des défauts de détecteur de filet - Onglet Transitions

Lorsque l'onglet Transitions est sélectionné, l'outil affiche l'emplacement du chemin de filet en bleu, toutes les transitions détectées en vert et les calipers qui définissent le chemin polylinéaire (généré à partir de l'emplacement du chemin de filet) en turquoise. Les calipers en turquoise ne peuvent être ajustés que par le biais du paramètre Largeur de la polyligne.Vous pouvez ajuster les paramètres Largeur de la polyligne, Taille du caliper, Espacement de caliper et Contraste minimum, selon le besoin, pour isoler les transitions voulues.

Fermé Largeur de la polyligne

Définit la largeur des calipers utilisés pour définir la polyligne (1 à 1 920 ; valeur par défaut = 25).

Fermé Taille du caliper

Définit le nombre de pixels, par caliper, à analyser dans le sens de l'inspection (1 à 639 ; valeur par défaut = 5).

Fermé Espacement de caliper

Définit la distance, en pixels, entre la fin d'un caliper et le début du caliper suivant (-1 à 639 ; valeur par défaut = 0).

Fermé Largeur de transition

Définit la distance de pixels (1 à 10 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Contraste minimum

Définit la transition de contraste minimale en niveaux de gris (1 à 255 ; valeur par défaut = 10) pour être considérée comme une transition.

Fermé Nombre de calipers

Affiche le nombre total de calipers dans la région.

Fermé Index du caliper

Définit le caliper individuel à isoler et à afficher.

Fermé Afficher tous les calipers

Définit si tous les calipers dans la région sont ou non affichés à tout moment. Les calipers sont masqués par défaut.


Outil de détection des défauts de détecteur de filet - Onglet Score de la transition

Lorsque l'onglet Score de la transition est sélectionné, l'outil affiche toutes les transitions possibles détectées (indiquées par des petits cercles de couleur) au sein de la région, les transitions détectées (indiquées en vert foncé), l'emplacement du filet sous la forme d'une polyligne bleue, les largeurs minimale et maximale du filet avec des lignes jaunes et tous les défauts ou écarts détectés.

Fermé Détection du sens de la transition

Définit le sens dans lequel l'outil tente de détecter les transitions par rapport à la région (Gauche -> droite, Droite -> gauche, Centre -> extérieur ou Extérieur -> intérieur ; valeur par défaut = Extérieur -> intérieur).

Fermé Transition transition0

Définit le type de la première transition détectée (Sombre vers clair, Clair vers sombre ou Indifférent ; valeur par défaut = Indifférent). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Transition transition1
(missing or bad snippet)
Fermé Règle:Première transition

Définit si la première paire de transitions détectée est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Règle:Transition la plus marquée

Définit si la transition affichant le contraste le plus élevé est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Limite de contraste supérieure

Définit la limite supérieure de la transition de contraste de transition (2 à 255 ; valeur par défaut = 255) à considérer comme une transition. Les transitions dont la valeur de contraste est supérieure à cette valeur auront le même score le plus élevé.

Fermé Règle:Taille des paires

Définit si la paire de transitions détectée avec la taille la plus proche du paramètre Taille des paires est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est désactivé par défaut).

Fermé Taille des paires

Définit la taille des paires de transitions à laquelle le score le plus élevé est atteint (1 à 1 920 ; valeur par défaut = 5). Lorsque ce paramètre est activé, le score des paires de transitions inférieur ou supérieur est déterminé proportionnellement. Par exemple, si Taille des paires est défini sur 10 et que deux paires de transitions possibles sont détectées, l'une avec une valeur de 8 et l'autre avec une valeur de 14, la paire de transitions avec la valeur de 8 est sélectionnée car elle est plus proche de la limite que la deuxième paire de transitions. Le paramètre Règle:Taille des paires doit être ACTIVÉ pour activer ce paramètre.

Fermé Seuil de score

Définit un seuil de score pour filtrer les transitions avec des scores (0 à 255 ; valeur par défaut = 10) inférieurs à cette valeur.


Outil de détection des défauts de détecteur de filet - Onglet Défauts

Lorsque l'onglet Défauts est sélectionné, l'outil affiche les graphiques liés pour identifier et/ou classer les erreurs dans la pièce ou l'objet. L'outil affiche l'emplacement du filet sous la forme d'une polyligne bleue, les épaisseurs minimale et maximale du filet avec des lignes jaunes et tous les défauts et/ou écarts détectés.

Fermé Largeur min.

Définit que toute distance en pixels (0,001 à 1 920 ; valeur par défaut = 3), entre les paires de transition détectées, inférieure à cette valeur n'est pas un défaut.

Fermé Largeur max.

Définit que toute distance en pixels (0,001 à 1 920 ; valeur par défaut = 1 000), entre les paires de transition détectées, supérieure à cette valeur n'est pas un défaut.

Fermé Taille activée

Définit si l'outil tient ou non compte des défauts de taille (qui prennent en compte la longueur le long de la transition). Ce paramètre est activé par défaut.

Remarque : lorsque les paramètres Taille activée et Surface activée sont tous les deux activés, seuls les défauts qui ne remplissent pas les deux conditions sont affichés.
Fermé Taille min.

Définit la taille minimale des défauts (0,001 à 1 920 ; valeur par défaut = 3), en pixels ; les écarts continus par rapport à la polyligne inférieurs à cette valeur ne sont pas considérés comme des défauts.

Fermé Taille max.

Définit la taille maximale des défauts (0,001 à 1 920 ; valeur par défaut = 1 000), en pixels ; les écarts continus par rapport à la polyligne supérieurs à cette valeur ne sont pas considérés comme des défauts.

Fermé Surface activée

Définit si l'outil tient ou non compte des défauts de surface. Ce paramètre est activé par défaut. Les défauts de surface prennent en compte la longueur le long de la polyligne et l'éloignement de la transition défectueuse par rapport à la polyligne.

Remarque : Lorsque les paramètres Taille activée et Surface activée sont tous les activés, seuls les défauts qui ne remplissent pas les deux conditions sont affichés.
Fermé Surface min.

Définit la surface minimale des défauts de surface (0,001 à 1 000 000 ; valeur par défaut = 10), en pixels ; une surface inférieure à cette valeur n'est pas considérée comme un défaut.

Fermé Surface max.

Définit la surface maximale des défauts de surface (0,001 à 1 000 000 ; valeur par défaut = 1 000 000), en pixels ; une surface supérieure à cette valeur n'est pas considérée comme un défaut.


Outil de détection des défauts de détecteur de filet - Onglet Écarts

Lorsque l'onglet Écarts est sélectionné, l'outil affiche les graphiques liés pour identifier et/ou classer les erreurs dans la pièce ou l'objet. L'outil affiche l'emplacement du filet sous la forme d'une polyligne bleue, les épaisseurs minimale et maximale du filet avec des lignes jaunes et tous les défauts et/ou écarts détectés.

Fermé Détection d'écarts

Définit si l'outil tient ou non compte des écarts dans la transition détectée. Ce paramètre est désactivé par défaut.

Fermé Écart minimal

Définit l'écart minimal (0,001 à 1 920 ; valeur par défaut = 3), en pixels. Les écarts inférieurs à cette valeur ne sont pas considérés comme des écarts.

Fermé Écart maximal

Définit l'écart maximal (0,001 à 1 920 ; valeur par défaut = 1 000), en pixels. Les écarts supérieurs à cette valeur ne sont pas considérés comme des écarts.

Fermé Ignorer les écarts de fin

Définit si l'outil tient ou non compte des écarts détectés au début et à la fin de la région. Ce paramètre est désactivé par défaut.

Fermé Résultat

Affiche le nombre total de défauts et/ou écarts détectés.


Outil de détection des défauts de détecteur de filet - Onglets tableaux Statistiques, Défauts de largeur et Écarts

L'onglet tableau Statistiques enregistre les données sur le fonctionnement de l'outil sur une période de temps. Les onglets tableaux Défauts de largeur et Écarts renvoient les 10 premiers défauts/écarts.

Fermé Index

Indique l'ordre des défauts/écarts localisés, triés en fonction de leur position le long de la transition ; de 1 à 10 (dans l'ordre numérique d'EasyBuilder, 0=1).

Fermé X

Renvoie l'abscisse (si le paramètre Unités calibrées est sélectionné et que l'image a été calibrée à l'étape Configurer l'image ; sinon renvoie les valeurs en pixels) du rectangle englobant le défaut/l'écart.

Fermé Y

Renvoie l'ordonnée (si le paramètre Unités calibrées est sélectionné et que l'image a été calibrée à l'étape Configurer l'image ; sinon renvoie les valeurs en pixels) du rectangle englobant le défaut/l'écart.

Fermé Surface

Renvoie la surface du rectangle englobant le défaut/l'écart.

Fermé Taille

Renvoie la taille (longueur) du défaut/de l'écart le long de la transition.

Fermé Calipers

Renvoie la plage de calipers couverte par le défaut/l'écart.

Fermé Unités calibrées/Pixels

Définit si le tableau affiche ou non les résultats dans les coordonnées réelles (Unités calibrées) ou en pixels (Pixels).

Remarque : À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.


Outils de détection des défauts - Contrôleur de filet

L'outil de détection des défauts de contrôleur de filet inspecte l'emplacement, la forme et la largeur d'un filet (défini par une paire de transitions). Il utilise des groupes Caliper d'analyse des transitions pour obtenir les emplacements précis des transitions en se basant sur un modèle de filet créé par l'utilisateur. Une fois le modèle de filet créé, l'outil compare, en cours d'exécution, les filets détectés dans les images acquises au modèle de filet pour déterminer si le filet est dans la position correcte et s'il présente des variations, telles que des défauts ou des écarts, et renvoie le nombre de défauts et/ou d'écarts détectés.

Remarque :
  • À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.
  • Toutes les valeurs d'entrée sont en pixels, que l'outil ait ou non été calibré avec des unités réelles.

L'outil de détection des défauts de contrôleur de filet permet de s'assurer qu'un filet, tel qu'un cordon de soudure, est au même emplacement et que sa forme ou son épaisseur ne présente aucune variation.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de détection des défauts de contrôleur de filet

Après avoir ajouté l'outil, vous devrez sélectionner le type de région puis configurer cette dernière dans l'image sur la transition à inspecter :

  1. Dans le menu déroulant Type de région, sélectionnez la région : Région masquée ou Chemin polylinéaire. Positionnez et configurez la région dans l'image sur la transition. Lors du positionnement de la région, assurez-vous que les transitions sont parallèles au sens de recherche de la région, et que la région englobe le plus possible la transition, tout en excluant le bruit superflu ou indésirable de la région. Lors de la configuration initiale de l'outil, utilisez une image qui contient la transition idéale. Les acquisitions d'images suivantes contiendront alors les transitions possibles qui seront inspectées pour déterminer la présence éventuelle de déviations telles que des défauts ou des écarts.

    Remarque : La ligne en pointillés jaune dans la Région masquée définit la zone au sein de la région dans laquelle les transitions seront détectées.

  2. Cliquez sur le bouton OK pour confirmer la région (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  3. Après avoir confirmé la région, sélectionnez les divers onglets, Apprentissage de filet, Transitions, Score de la transition, Défauts, Écarts et Position, et réglez les paramètres et la région selon le besoin pour s'assurer que l'outil détecte les transitions possibles correctes et crée la polyligne correcte.
  4. Une fois la région et les paramètres correctement réglés, affichez l'onglet Apprentissage de filet et cliquez sur le bouton Apprendre pour créer le modèle de filet. Les acquisitions d'images suivantes seront alors comparées au modèle de filet appris.
  5. Avec l'outil initialement configuré, chargez plusieurs images et réglez les paramètres de l'outil selon le besoin de façon à compenser les plages de variations prévues.
  6. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de détection des défauts de contrôleur de filet

Après positionnement de la région de l'outil, vous pouvez optimiser l'outil pour votre application.

Le volet de paramètres de l'outil de détection des défauts de contrôleur de filet comprend les onglets suivants :

  • Onglet Général
  • Apprentissage de filet
  • Onglet Transitions
  • Onglet Score de la transition
  • Onglet Défauts
  • Onglet Écarts
  • Onglet Position
  • Onglets tableaux Statistiques, Défauts de largeur, Écarts et Défauts de position
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Apprentissage de filet

Onglet Transitions

Onglet Score de la transition

Onglet Défauts

Onglet Position

Onglets tableaux Statistiques, Défauts de largeur, Écarts et Défauts de position

Onglet Écarts


Outil de détection des défauts de contrôleur de filet - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « ContrôleurDeFilet_1 » s'il s'agit du premier outil de détection des défauts de contrôleur de filet ajouté au projet. Sinon, il est incrémenté (par exemple, « ContrôleurDeFilet_2 », « ContrôleurDeFilet_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Image d'outil

Définit l'image que l'outil utilisera pour effectuer l'inspection ; l'image non filtrée en cours d'acquisition (paramètre par défaut) ou l'image de sortie d'un outil de filtre d'image ou d'un outil couleur (outils de recherche de blob de couleur et de blobs de couleur (1-10), outils de présence/absence basé sur le comptage de pixels et de blob de couleur, outils de mesure de surface de blob de couleur et de surfaces des blobs de couleur (1-10), outil de comptage de blobs de couleur, outil d'identification du modèle de couleurs ou outil de filtre d'image couleur -> binaire). Ce contrôle n'est activé que si un outil de filtre d'image ou un outil couleur a été ajouté.

Fermé Repère de l'outil

Définit un repère pour l'outil. Ce contrôle n'est activé que si un autre outil définissant un repère a déjà été ajouté.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Type de région

Définit le type de région utilisé pour définir la zone de l'image analysée : Région masquée (par défaut) ou Chemin polylinéaire.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de détection des défauts de contrôleur de filet - Onglet Apprentissage de filet

Lorsque l'onglet Apprentissage de filet est sélectionné, l'outil affiche les graphiques permettant de localiser le filet. L'outil affiche toutes les transitions possibles détectées (indiquées par des petits cercles de couleur) au sein de la région, l'emplacement du filet sous la forme d'une polyligne bleue, et la région peut être ajustée.

Fermé Bouton Apprendre

Définit le modèle de filet. Le bouton Apprendre est utilisé lors de la configuration d'un modèle de filet. Cliquez sur le bouton Apprendre après avoir configuré les paramètres de l'outil et la région pour accentuer les caractéristiques du modèle de filet qui présentent un intérêt. Une fois le modèle de filet appris, l'outil compare le filet détecté dans les images acquises au modèle de filet appris pour déterminer s'il présente des variations, telles que des défauts ou des écarts.

Remarque : L'outil renvoie un état d'échec jusqu'à ce que le modèle de filet ait été appris.
Fermé Taille de calipers d'apprentissage de filet

Définit le nombre de pixels, par caliper, à analyser dans le sens de l'inspection pour localiser le filet (1 à 639 ; valeur par défaut = 8).

Fermé Espacement de calipers d'apprentissage de filet

Définit la distance, en pixels, entre la fin d'un caliper et le début du caliper suivant (-1 à 639 ; valeur par défaut = 0).

Fermé Largeur de transition d'apprentissage de filet

Définit la distance de pixels (1 à 10 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Contraste minimum d'apprentissage de filet

Définit la transition de contraste minimale en niveaux de gris (1 à 255 ; valeur par défaut = 10) pour être considérée comme une transition.

Fermé Sens de transition d'apprentissage de filet

Définit le sens dans lequel l'outil tente de détecter les transitions par rapport à la région (Gauche -> droite, Droite -> gauche, Centre -> extérieur ou Extérieur -> intérieur ; valeur par défaut = Gauche -> droite).

Fermé Transition transition0 d'apprentissage de filet

Définit le type de la première transition détectée (Sombre vers clair, Clair vers sombre ou Indifférent ; valeur par défaut = Indifférent). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Transition transition1 d'apprentissage de filet
(missing or bad snippet)
Fermé Règle d'apprentissage de filet:Première transition

Définit si la première paire de transitions détectée est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Règle d'apprentissage de filet:Transition la plus marquée

Définit si la transition affichant le contraste le plus élevé est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Limite de contraste supérieure d'apprentissage de filet

Définit la limite supérieure de la transition de contraste de transition (2 à 255 ; valeur par défaut = 255) à considérer comme une transition. Les transitions dont la valeur de contraste est supérieure à cette valeur auront le même score le plus élevé.

Fermé Règle d'apprentissage de filet:Taille de la paire

Définit si la paire de transitions détectée avec la taille la plus proche du paramètre Taille des paires est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est désactivé par défaut).

Fermé Seuil de score d'apprentissage de filet

Définit un seuil de score pour filtrer les transitions avec des scores (0 à 255 ; valeur par défaut = 10) inférieurs à cette valeur.

Fermé Calipers d'apprentissage de filet

Affiche le nombre total de calipers dans la région.

Fermé Index de calipers d'apprentissage de filet

Définit le caliper individuel à isoler et à afficher.

Fermé Afficher tous les calipers d'apprentissage de filet

Définit si tous les calipers dans la région sont ou non affichés à tout moment. Les calipers sont masqués par défaut.


Outil de détection des défauts de contrôleur de filet - Onglet Transitions

Lorsque l'onglet Transitions est sélectionné, l'outil affiche l'emplacement du chemin de filet en bleu, toutes les transitions détectées en vert et les calipers qui définissent le chemin polylinéaire (généré à partir de l'emplacement du chemin de filet) en turquoise. Les calipers en turquoise ne peuvent être ajustés que par le biais du paramètre Largeur de la polyligne.Vous pouvez ajuster les paramètres Largeur de la polyligne, Taille du caliper, Espacement de caliper et Contraste minimum, selon le besoin, pour isoler les transitions voulues.

Fermé Largeur de la polyligne

Définit la largeur des calipers utilisés pour définir la polyligne (1 à 1 920 ; valeur par défaut = 25).

Fermé Taille du caliper

Définit le nombre de pixels, par caliper, à analyser dans le sens de l'inspection (1 à 639 ; valeur par défaut = 5).

Fermé Espacement de caliper

Définit la distance, en pixels, entre la fin d'un caliper et le début du caliper suivant (-1 à 639 ; valeur par défaut = 0).

Fermé Largeur de transition

Définit la distance de pixels (1 à 10 ; valeur par défaut = 3) au-delà de laquelle on est en présence d'une transition. Ce paramètre aide à filtrer le bruit de l'image.

Fermé Contraste minimum

Définit la transition de contraste minimale en niveaux de gris (1 à 255 ; valeur par défaut = 10) pour être considérée comme une transition.

Fermé Nombre de calipers

Affiche le nombre total de calipers dans la région.

Fermé Index du caliper

Définit le caliper individuel à isoler et à afficher.

Fermé Afficher tous les calipers

Définit si tous les calipers dans la région sont ou non affichés à tout moment. Les calipers sont masqués par défaut.


Outil de détection des défauts de contrôleur de filet - Onglet Score de la transition

Lorsque l'onglet Score de la transition est sélectionné, l'outil affiche toutes les transitions possibles détectées (indiquées par des petits cercles de couleur) au sein de la région, les transitions détectées (indiquées en vert foncé), l'emplacement du filet sous la forme d'une polyligne bleue, les largeurs minimale et maximale du filet avec des lignes jaunes et tous les défauts ou écarts détectés.

Fermé Détection du sens de la transition

Définit le sens dans lequel l'outil tente de détecter les transitions par rapport à la région (Gauche -> droite, Droite -> gauche, Centre -> extérieur ou Extérieur -> intérieur ; valeur par défaut = Extérieur -> intérieur).

Fermé Transition transition0

Définit le type de la première transition détectée (Sombre vers clair, Clair vers sombre ou Indifférent ; valeur par défaut = Indifférent). Le fait de spécifier le type de transition permet d'accroître la précision et la vitesse.

Fermé Transition transition1
(missing or bad snippet)
Fermé Règle:Première transition

Définit si la première paire de transitions détectée est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Règle:Transition la plus marquée

Définit si la transition affichant le contraste le plus élevé est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est activé par défaut).

Fermé Limite de contraste supérieure

Définit la limite supérieure de la transition de contraste de transition (2 à 255 ; valeur par défaut = 255) à considérer comme une transition. Les transitions dont la valeur de contraste est supérieure à cette valeur auront le même score le plus élevé.

Fermé Règle:Taille des paires

Définit si la paire de transitions détectée avec la taille la plus proche du paramètre Taille des paires est ou non considérée comme prioritaire lorsque l'on détermine si une transition possible remplit ou non les critères requis pour être considérée comme une transition (ce paramètre est désactivé par défaut).

Fermé Taille des paires

Définit la taille des paires de transitions à laquelle le score le plus élevé est atteint (1 à 1 920 ; valeur par défaut = 5). Lorsque ce paramètre est activé, le score des paires de transitions inférieur ou supérieur est déterminé proportionnellement. Par exemple, si Taille des paires est défini sur 10 et que deux paires de transitions possibles sont détectées, l'une avec une valeur de 8 et l'autre avec une valeur de 14, la paire de transitions avec la valeur de 8 est sélectionnée car elle est plus proche de la limite que la deuxième paire de transitions. Le paramètre Règle:Taille des paires doit être ACTIVÉ pour activer ce paramètre.

Fermé Seuil de score

Définit un seuil de score pour filtrer les transitions avec des scores (0 à 255 ; valeur par défaut = 10) inférieurs à cette valeur.


Outil de détection des défauts de contrôleur de filet - Onglet Défauts

Lorsque l'onglet Défauts est sélectionné, l'outil affiche les graphiques liés pour identifier et/ou classer les erreurs dans la pièce ou l'objet. L'outil affiche l'emplacement du filet sous la forme d'une polyligne bleue, les épaisseurs minimale et maximale du filet avec des lignes jaunes et tous les défauts et/ou écarts détectés.

Fermé Largeur min.

Définit que toute distance en pixels (0,001 à 1 920 ; valeur par défaut = 3), entre les paires de transition détectées, inférieure à cette valeur n'est pas un défaut.

Fermé Largeur max.

Définit que toute distance en pixels (0,001 à 1 920 ; valeur par défaut = 1 000), entre les paires de transition détectées, supérieure à cette valeur n'est pas un défaut.

Fermé Taille activée

Définit si l'outil tient ou non compte des défauts de taille (qui prennent en compte la longueur le long de la transition). Ce paramètre est activé par défaut.

Remarque : lorsque les paramètres Taille activée et Surface activée sont tous les deux activés, seuls les défauts qui ne remplissent pas les deux conditions sont affichés.
Fermé Taille min.

Définit la taille minimale des défauts (0,001 à 1 920 ; valeur par défaut = 10), en pixels ; les écarts continus par rapport à la polyligne inférieurs à cette valeur ne sont pas considérés comme des défauts.

Fermé Taille max.

Définit la taille maximale des défauts (0,001 à 1 920 ; valeur par défaut = 1 000), en pixels ; les écarts continus par rapport à la polyligne supérieurs à cette valeur ne sont pas considérés comme des défauts.

Fermé Surface activée

Définit si l'outil tient ou non compte des défauts de surface. Ce paramètre est activé par défaut. Les défauts de surface prennent en compte la longueur le long de la polyligne et l'éloignement de la transition défectueuse par rapport à la polyligne.

Remarque : Lorsque les paramètres Taille activée et Surface activée sont tous les activés, seuls les défauts qui ne remplissent pas les deux conditions sont affichés.
Fermé Surface min.

Définit la surface minimale des défauts de surface (0,001 à 1 000 000 ; valeur par défaut = 10), en pixels ; une surface inférieure à cette valeur n'est pas considérée comme un défaut.

Fermé Surface max.

Définit la surface maximale des défauts de surface (0,001 à 1 000 000 ; valeur par défaut = 1 000 000), en pixels ; une surface supérieure à cette valeur n'est pas considérée comme un défaut.


Outil de détection des défauts de contrôleur de filet - Onglet Position

Lorsque l'onglet Position est sélectionné, l'outil affiche les graphiques liés pour identifier et/ou classer les erreurs de position dans la pièce ou l'objet. L'outil affiche le dernier emplacement mémorisé du filet sous la forme d'une polyligne bleue, les épaisseurs minimale et maximale du filet avec des lignes jaunes et tous les défauts et/ou écarts détectés.

Fermé Défauts de position activés

Définit si les défauts de position sont ou non pris en compte. Ce paramètre est activé par défaut.

Fermé Distance min. des défauts de position

Définit la valeur minimale (0,001 à 1 920 ; valeur par défaut = 3), en pixels, d'éloignement d'une transition possible par rapport au centre du modèle de filet pour qu'elle ne soit pas considérée comme une erreur.

Fermé Taille des défauts de position activée

Définit si des critères de taille sont ou non aussi utilisés pour définir les erreurs de position (ce paramètre est activé par défaut). Les erreurs de taille sont détectées le long de la transition.

Remarque : Lorsque les paramètres Taille activée et Surface activée sont tous les activés, seuls les défauts qui ne remplissent pas les deux conditions sont affichés.
Fermé Taille min. des défauts de position

Définit la taille minimale des défauts (0,001 à 1 920 ; valeur par défaut = 3), en pixels ; les écarts continus par rapport à la polyligne inférieurs à cette valeur ne sont pas considérés comme des défauts.

Fermé Taille max. des défauts de position

Définit la taille maximale des défauts (0,001 à 1 920 ; valeur par défaut = 1 000), en pixels ; les écarts continus par rapport à la polyligne supérieurs à cette valeur ne sont pas considérés comme des défauts.

Fermé Surface des défauts de position activée

Définit si l'outil tient ou non compte des défauts de surface. Ce paramètre est activé par défaut. Les défauts de surface prennent en compte la longueur le long de la polyligne et l'éloignement de la transition défectueuse par rapport à la polyligne.

Remarque : Lorsque les paramètres Taille activée et Surface activée sont tous les activés, seuls les défauts qui ne remplissent pas les deux conditions sont affichés.
Fermé Surface min. des défauts de position

Définit la surface minimale des défauts de surface (0,001 à 1 000 000 ; valeur par défaut = 10), en pixels ; une surface inférieure à cette valeur n'est pas considérée comme un défaut.

Fermé Surface max. des défauts de position

Définit la surface maximale des défauts de surface (0,001 à 1 000 000 ; valeur par défaut = 1 000 000), en pixels ; une surface supérieure à cette valeur n'est pas considérée comme un défaut.

Fermé Résultat

Affiche le nombre total de défauts, écarts et/ou erreurs de position détectés.


Outil de détection des défauts de contrôleur de filet - Onglets tableaux Statistiques, Défauts de largeur, Écarts et Défauts de position

L'onglet tableau Statistiques enregistre les données sur le fonctionnement de l'outil sur une période de temps. Les onglets tableaux Défauts de largeur, Écarts et Défauts de position renvoient les 10 premiers défauts/écarts et erreurs de position.

Fermé Index

Indique l'ordre des défauts/écarts localisés, triés en fonction de leur position le long de la transition ; de 1 à 10 (dans l'ordre numérique d'EasyBuilder, 0=1).

Fermé X

Renvoie l'abscisse (si le paramètre Unités calibrées est sélectionné et que l'image a été calibrée à l'étape Configurer l'image ; sinon renvoie les valeurs en pixels) du rectangle englobant le défaut/l'écart.

Fermé Y

Renvoie l'ordonnée (si le paramètre Unités calibrées est sélectionné et que l'image a été calibrée à l'étape Configurer l'image ; sinon renvoie les valeurs en pixels) du rectangle englobant le défaut/l'écart.

Fermé Surface

Renvoie la surface du rectangle englobant le défaut/l'écart.

Fermé Taille

Renvoie la taille (longueur) du défaut/de l'écart le long de la transition.

Fermé Calipers

Renvoie la plage de calipers couverte par le défaut/l'écart.

Fermé Unités calibrées/Pixels

Définit si le tableau affiche ou non les résultats dans les coordonnées réelles (Unités calibrées) ou en pixels (Pixels).

Remarque : À moins que l'image n'ait été calibrée avec des unités réelles à l'étape Configurer l'image, l'outil renvoie les résultats en pixels.


Outil de détection des défauts de contrôleur de filet - Onglet Écarts

Lorsque l'onglet Écarts est sélectionné, l'outil affiche les graphiques liés pour identifier et/ou classer les erreurs dans la pièce ou l'objet. L'outil affiche l'emplacement du filet sous la forme d'une polyligne bleue, les épaisseurs minimale et maximale du filet avec des lignes jaunes et tous les défauts et/ou écarts détectés.

Fermé Détection d'écarts

Définit si l'outil tient ou non compte des écarts dans la transition détectée. Ce paramètre est activé par défaut.

Fermé Écart minimal

Définit l'écart minimal (0,001 à 1 920 ; valeur par défaut = 3), en pixels. Les écarts inférieurs à cette valeur ne sont pas considérés comme des écarts.

Fermé Écart maximal

Définit l'écart maximal (0,001 à 1 920 ; valeur par défaut = 1 000), en pixels. Les écarts supérieurs à cette valeur ne sont pas considérés comme des écarts.

Fermé Ignorer les écarts de fin

Définit si l'outil tient ou non compte des écarts détectés au début et à la fin de la région. Ce paramètre est désactivé par défaut.

Fermé Résultat

Affiche le nombre total de défauts et/ou écarts détectés.


Outils de calibrage – Robot

Cet outil permet de relier un outil de vision à une fonction de calibrage de robot et de transformer les coordonnées des pixels en poses du robot puis de créer automatiquement un fichier de calibrage dans EasyBuilder.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l’outil Calibrage du robot

Astuce : une fois le calibrage configuré, il est recommandé d'enregistrer le fichier de projet. Pour les prochains calibrages, il suffira alors de charger le projet de calibrage, d'acquérir l'image puis d'exporter automatiquement le fichier de calibrage mis à jour dans tous les projets qui l'utilisent.

Une fois l’outil ajouté, vous devez définir les caractéristiques de l’entrée (points, origines de l’outil ou le centre des caractéristiques circulaires) qui seront utilisées pour créer le calibrage :

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features (points, origines de repères ou centre de caractéristiques circulaires) qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert). EasyBuilder insère automatiquement un outil de présence/absence de cercle pour chacune des caractéristiques circulaires pas encore définies.

  2. Sélectionnez une des caractéristiques dans la liste de celles disponibles en cliquant dessus, sa couleur passe alors au magenta.

  3. Après avoir sélectionné la caractéristique, appuyez sur le bouton OK (appuyez sur Annuler pour ne pas ajouter l’outil au projet).

  4. Enregistrez le fichier de projet.
  5. Avec l'outil initialement configuré, ajustez ses paramètres selon vos besoins.
  6. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l’outil Calibrage du robot

Après avoir ajouté l'outil au projet, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil Calibrage du robot comprend les onglets suivants :

  • Onglet Général
  • Onglet Paramètres

Onglet Général

Onglet Paramètres


Outil de calibrage du robot – onglet Général

Fermé Nom d'outil

Permet de définit le nom de votre outil d’inspection, celui-ci sera utilisé pour la configuration des résultats (Configurer image, Entrées/sorties et Communication) ; le nom par défaut est « Calib_1 » Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique. Vous ne pouvez ajouter qu’un seul Outil Robot à un projet.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Calibrage du robot – Onglet Paramètres

Fermé Nom du fichier

Permet de définir le nom du fichier de calibrage (le nom par défaut est « Par défaut »).

Fermé Nom complet

Affiche le nom complet du fichier de calibrage du robot, avec son extension .CXD.

Fermé Ajouter date/heure

Activez cette case à cocher si vous souhaitez inclure la date et l’heure actuelles dans le nom du fichier.


Outils de calibrage - Point N

L'outil de calibrage du point N permet de créer un fichier de calibrage en utilisant 2 à 16 caractéristiques d'entrée et leurs coordonnées réelles associées. Ce fichier de calibrage peut être exporté et appliqué comme type de calibrage à l'étape Configurer l'image, et utilisé dans d'autres projets.

Astuce : une fois le calibrage configuré, il est recommandé d'enregistrer le fichier de projet. Pour les prochains calibrages, il suffira alors de charger le projet de calibrage, d'acquérir l'image puis d'exporter automatiquement le fichier de calibrage mis à jour dans tous les projets qui l'utilisent.

Cet outil est utile lorsque vous inspectez une pièce ou un objet dont vous connaissez les dimensions réelles (d'un dessin de CAO, par exemple) et que vous souhaitez appliquer ces valeurs pour le calibrage. Dans ce type d'application, le système de vision In-Sight acquiert une image de la pièce ou de l'objet et les valeurs réelles sont associées aux coordonnées de pixels de l'image. Enregistré dans le système de fichiers local du système de vision In-Sight, le calibrage résultant peut être appliqué à d'autres projets.

Remarque :
  • Cet outil requiert que d'autres outils de recherche et/ou d'inspection soient utilisés comme entrées pour définir les points pour le calibrage. Regroupez les outils de recherche et/ou d'inspection nécessaires qui seront utilisés comme entrées avant d'ajouter cet outil.
  • Lors de l'utilisation d'un outil de calibrage du point N ou de calibrage du point N séquentiel, la configuration physique et optique (objectif, système de vision et relation physique entre le système de vision et la scène acquise) doit être identique pour le calibrage et en cours d'exécution. Si un de ces éléments est modifié, le système doit être recalibré. Il est par conséquent recommandé d'utiliser les mêmes système de vision et objectif pour calibrer et traiter les images obtenues en cours d'exécution. Les paramètres de configuration et de calibrage d'origine du système de vision et de l'objectif doivent également être conservés. Par exemple, toute modification du format d'acquisition (en changeant la résolution) ou tout déplacement du système de vision rend invalide la conversion 2D calculée qui associe les pixels à des coordonnées réelles.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de calibrage du point N

Astuce : une fois le calibrage configuré, il est recommandé d'enregistrer le fichier de projet. Pour les prochains calibrages, il suffira alors de charger le projet de calibrage, d'acquérir l'image puis d'exporter automatiquement le fichier de calibrage mis à jour dans tous les projets qui l'utilisent.

Une fois l'outil ajouté, définissez les caractéristiques d'entrée (points, origines de repères ou centre de caractéristiques circulaires) qui serviront à créer le calibrage :

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features (points, origines de repères ou centre de caractéristiques circulaires) qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert). EasyBuilder insère automatiquement un outil de présence/absence de cercle pour chacune des caractéristiques circulaires pas encore définies.

  2. Commencez par sélectionner une des caractéristiques disponibles en cliquant dessus. Elle devient rose.

  3. Puis, sélectionnez les autres caractéristiques utilisées pour définir le calibrage (deux au minimum et seize au maximum).

  4. Une fois toutes les caractéristiques voulues sélectionnées, cliquez sur le bouton OK (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).

  5. Une fois l'outil ajouté et les caractéristiques d'entrée définies, définissez les valeurs de mesure réelles de chaque caractéristique d'entrée. Dans le tableau de points, sélectionnez un point puis saisissez les valeurs de mesure réelles correspondantes dans les champs X réel et Y réel en saisissant manuellement le nombre ou en l'augmentant/le réduisant à l'aide des contrôles.
  6. Enregistrez le fichier du projet.
  7. Cliquez sur le bouton Exporter de l'onglet Paramètres pour copier le fichier de calibrage dans le système de fichiers local du système de vision In-Sight. Cela permet également de définir l'option Importer pour le calibrage dans le menu déroulant Type de calibrage de l'étape Configurer l'image.
  8. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et ajustez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  9. Enfin, si vous le souhaitez, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de calibrage du point N

Après avoir ajouté l'outil au projet, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil de calibrage du point N comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Tableau de points
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Tableau de points


Outil de calibrage du point N - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection, qui sera utilisé pour configurer les résultats (Configurer l'image, Entrées/Sorties et Communication). Le nom par défaut est « Calibrage_1 » s'il s'agit du premier outil de calibrage ajouté au projet. Sinon, il est incrémenté (par exemple, « Calibrage_2 », « Calibrage_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de calibrage du point N - Onglet Paramètres

Fermé Nom du fichier

Définit le nom du fichier de calibrage (nom par défaut = Default).

Fermé Nom complet

Affiche le nom complet du fichier de calibrage qui s'affiche lors de l'étape Configurer l'image lorsque le type de calibrage est configuré sur Importer. Pour que le fichier s'affiche lors de l'étape Configurer l'image, il doit être exporté.

Fermé Exporter

Exporte le fichier de calibrage vers le système de fichiers local du système de vision In-Sight.

Fermé Exportation automatique

Définit si le fichier de calibrage doit être exporter automatiquement sur le premier déclenchement après le chargement du fichier de projet ou l'acquisition d'une image. Lorsqu'il est activé (coché), l'outil exporte automatiquement son fichier de calibrage sur le premier déclenchement après le chargement du fichier de projet ou l'acquisition d'une image (par défaut ce paramètre est désactivé/décoché).

Remarque : Si l'Exportation automatique est activée, le fichier de projet contenant les données de calibrage doit d'abord être enregistré avant l'exportation du fichier de calibrage. Une fois le fichier de projet enregistré, si le fichier de calibrage n'apparaît pas dans le volet de Fichiers In-Sight, cliquez sur un autre système de vision In-Sight ou un émulateur, puis revenez en arrière et sélectionnez le système de vision souhaité. Le fichier doit maintenant apparaître.


Outil de calibrage du point N - Tableau de points

Le tableau de points de coordonnées de pixels et réelles permet d'afficher et de définir les valeurs des coordonnées réelles pour le calibrage.

Fermé Point

Affiche une liste indexée en lecture seule des points localisés, de 1 à 16 (dans l'ordre numérique d'EasyBuilder, 0=1).

Fermé Ligne pixel

Affiche l'abscisse (X) du pixel du point.

Fermé Col. pixel

Affiche l'ordonnée (X) de l'image du point.

Fermé X réel

Affiche la valeur de l'abscisse (X) réelle du point.

Fermé Y réel

Affiche la valeur de l'ordonnée (Y) réelle du point.

Fermé X réel

Définit la valeur de l'abscisse (X) réelle du point sélectionné.

Fermé Y réel

Définit la valeur de l'ordonnée (Y) réelle du point sélectionné.

Fermé Sélectionner des points

Permet de sélectionner les caractéristiques d'entrée sous forme de points. Lorsque ce bouton a été sélectionné, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features (points, origines de repères ou centre de caractéristiques circulaires) qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert). Sélectionnez une des caractéristiques disponibles en cliquant dessus. Elle devient rose.


Outils de calibrage - Point N séquentiel

L'outil de calibrage du point N séquentiel permet de créer un fichier de calibrage en utilisant une caractéristique d'entrée et ses coordonnées réelles associées au cours d'acquisitions d'images séquentielles. Ce fichier de calibrage peut être exporté et appliqué comme type de calibrage à l'étape Configurer l'image, et utilisé dans d'autres projets.

Astuce : une fois le calibrage configuré, il est recommandé d'enregistrer le fichier de projet. Pour les prochains calibrages, il suffira alors de charger le projet de calibrage, d'acquérir l'image puis d'exporter automatiquement le fichier de calibrage mis à jour dans tous les projets qui l'utilisent.

Cet outil s'avère utile lorsque vous calibrez un système de vision In-Sight et le système de coordonnées d'un automate. Dans ce type d'application, l'automate présente un objet au système de vision à différents emplacements, à raison d'un emplacement et d'une acquisition d'image à la fois. Chaque acquisition ajoute un point dans le tableau de calibrage. Lorsque l'automate a visité tous les emplacements et que chaque point est enregistré, le fichier de calibrage peut être exporté et le fichier du projet enregistré.

Remarque :
  • Cet outil requiert que d'autres outils de recherche et/ou d'inspection soient utilisés comme entrées pour définir les points pour le calibrage. Regroupez les outils de recherche et/ou d'inspection nécessaires qui seront utilisés comme entrées avant d'ajouter cet outil.
  • Lors de l'utilisation d'un outil de calibrage du point N ou de calibrage du point N séquentiel, la configuration physique et optique (objectif, système de vision et relation physique entre le système de vision et la scène acquise) doit être identique pour le calibrage et en cours d'exécution. Si un de ces éléments est modifié, le système doit être recalibré. Il est par conséquent recommandé d'utiliser les mêmes système de vision et objectif pour calibrer et traiter les images obtenues en cours d'exécution. Les paramètres de configuration et de calibrage d'origine du système de vision et de l'objectif doivent également être conservés. Par exemple, toute modification du format d'acquisition (en changeant la résolution) ou tout déplacement du système de vision rend invalide la conversion 2D calculée qui associe les pixels à des coordonnées réelles.

Configuration de l’outil

Réglage des paramètres de l’outil


Configuration de l'outil de calibrage du point N séquentiel

Astuce : une fois le calibrage configuré, il est recommandé d'enregistrer le fichier de projet. Pour les prochains calibrages, il suffira alors de charger le projet de calibrage, d'acquérir l'image puis d'exporter automatiquement le fichier de calibrage mis à jour dans tous les projets qui l'utilisent.

Une fois l'outil ajouté, définissez la caractéristique d'entrée (point, origine d'un repère ou centre d'une caractéristique circulaire) qui servira à créer le calibrage :

  1. Après avoir ajouté l'outil, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features (points, origines de repères ou centre de caractéristiques circulaires) qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert). EasyBuilder insère automatiquement un outil de présence/absence de cercle pour chacune des caractéristiques circulaires pas encore définies.
  2. Sélectionnez une des caractéristiques disponibles en cliquant dessus. Elle devient rose.
  3. Une fois la caractéristique voulue sélectionnée, cliquez sur le bouton OK (ou sur le bouton Annuler pour ne pas ajouter l'outil au projet).
  4. Sous l'onglet Paramètres, indiquez le nombre de points/d'acquisitions qui définiront le calibrage dans le paramètre Nombre de points.
  5. Positionnez l'automate sur le prochain emplacement et déclenchez une acquisition d'image du point à son nouvel emplacement. Continuez ainsi jusqu'à ce que tous les points aient été acquis.
  6. Lorsque tous les points ont été ajoutés, vous devez en définir les valeurs de mesure réelles. Dans le tableau de points, sélectionnez un point puis entrez les valeurs de mesure réelles correspondantes dans les champs X réel et Y réel en saisissant manuellement le nombre ou en l'augmentant/le réduisant à l'aide des contrôles.
  7. Cliquez sur le bouton Exporter de l'onglet Paramètres pour copier le fichier de calibrage dans le système de fichiers local du système de vision In-Sight. Cela permet également de définir l'option Importer pour le calibrage dans le menu déroulant Type de calibrage de l'étape Configurer l'image.
  8. Avec l'outil initialement configuré, chargez le cas échéant plusieurs images et réglez les paramètres de l'outil de façon à compenser les plages de variations prévues.
  9. Enfin, le cas échéant, utilisez les propriétés d'entrée/sortie de l'outil pour partager les données de l'outil avec d'autres outils et/ou d'autres périphériques externes.


Réglage des paramètres de l'outil de calibrage du point N séquentiel

Après avoir ajouté l'outil au projet, vous pouvez commencer à le personnaliser et à l'ajuster aux besoins de votre application.

Le volet de paramètres de l'outil de calibrage du point N séquentiel comprend les éléments suivants :

  • Onglet Général
  • Onglet Paramètres
  • Tableau de points
Astuce : testez votre projet en utilisant TestRun. TestRun exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. Cela permet de savoir si le projet se comporte ou non comme prévu, ou si vous devez régler certains paramètres pour la plage de variations autorisée.

Onglet Général

Onglet Paramètres

Tableau de points


Outil de calibrage du point N séquentiel - Onglet Général

Fermé Nom de l'outil

Définit le nom de l'outil d'inspection qui sera utilisé pour configurer les résultats (Entrées/Sorties et Communication). Le nom par défaut est « Calibrage_1 » s'il s'agit du premier outil de calibrage ajouté au projet. Sinon, il est incrémenté (par exemple, « Calibrage_2 », « Calibrage_3 », etc.). Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.

Fermé Outil activé

Définit quand et si l'outil d'inspection doit ou non être exécuté (le paramètre par défaut est « Activé »). Sélectionnez « Désactivé » pour désactiver l'outil. Sélectionnez « Expression » pour lier l'exécution de l'outil au résultat d'une expression (ce contrôle n'est activé que pour les outils possédant un paramètre d'expression). Ou, sélectionnez une « Entrée » si vous souhaitez que l'outil soit associé à une ligne d'entrée discrète spécifique où il pourra être activé ou désactivé (un signal Haut, 1, signifie Activé ; un signal Bas, 0, signifie Désactivé). Le fait d'associer l'outil à une entrée permet à un système de contrôle, tel qu'un automate programmable, de déterminer les outils qui doivent fonctionner.

Fermé Inclure dans le succès

Définit si l'état de succès/échec de l'outil doit ou non être inclus dans l'état de succès/échec global du projet. Cet état est activé par défaut et sera inclus dans l'état de succès/échec global du projet. Décochez la case pour séparer l'état de succès/échec de l'outil de celui des autres outils du projet. Ne cochez pas ce contrôle si un outil à des chances de générer un échec. Par exemple, si deux outils d'identification de modèles PatMax sont utilisés pour déterminer si la pièce doit être installée à droite ou à gauche, un des outils génèrera forcément un échec à chaque fois. Cette situation entraînerait l'échec systématique du projet si cette case est cochée, quel que soit le côté de la pièce identifié.

Fermé Durée d'exécution (ms)

Affiche le temps, en millisecondes, que l'outil a mis pour effectuer l'inspection. Ce délai peut varier en fonction de la complexité de la scène dans l'image, de la position de la caractéristique dans l'image et de la plage de tolérance autorisée par les paramètres.

Fermé Description

Commentaire qui décrit l'objectif de l'outil (par défaut, le champ est vide) Il est possible d'utiliser jusqu'à 255 caractères alpha-numériques ou 127 caractères de langues asiatiques.


Outil de calibrage du point N séquentiel - Onglet Paramètres

Fermé Nombre de points

Définit le nombre de points à acquérir (2 à 16 ; valeur par défaut = 12).

Fermé Remise à zéro

Remet le nombre d'acquisitions à 0.

Fermé Remise à zéro en ligne

Définit si le nombre d'acquisitions doit ou non être remis à zéro lorsqu'un système de vision In-Sight est mis en ligne. Cette option est désactivée (décochée) par défaut.

Fermé Réinitialisation du chargement du projet

Définit si le nombre d'acquisitions doit ou non être remis à zéro au chargement du fichier de projet. Cette option est activée (cochée) par défaut.

Fermé Nom du fichier

Définit le nom du fichier de calibrage (nom par défaut = Default).

Fermé Nom complet

Affiche le nom complet du fichier de calibrage qui s'affiche lors de l'étape Configurer l'image lorsque le type de calibrage est configuré sur Importer. Pour que le fichier s'affiche lors de l'étape Configurer l'image, il doit être exporté.

Fermé Exporter

Exporte le fichier de calibrage vers le système de fichiers local du système de vision In-Sight.

Fermé Exportation automatique

Définit si le fichier de calibrage doit être exporter automatiquement sur le premier déclenchement après le chargement du fichier de projet ou l'acquisition d'une image. Lorsqu'il est activé (coché), l'outil exporte automatiquement son fichier de calibrage sur le premier déclenchement après le chargement du fichier de projet ou l'acquisition d'une image (par défaut ce paramètre est désactivé/décoché).

Remarque : Si l'Exportation automatique est activée, le fichier de projet contenant les données de calibrage doit d'abord être enregistré avant l'exportation du fichier de calibrage. Une fois le fichier de projet enregistré, si le fichier de calibrage n'apparaît pas dans le volet de Fichiers In-Sight, cliquez sur un autre système de vision In-Sight ou un émulateur, puis revenez en arrière et sélectionnez le système de vision souhaité. Le fichier doit maintenant apparaître.
Fermé Résultat

Affiche l'état de succès/échec de l'outil.


Outil de calibrage du point N séquentiel - Tableau de points

Le tableau de points de coordonnées de pixels et réelles permet d'afficher et de définir les valeurs des coordonnées réelles pour le calibrage.

Fermé Point

Affiche une liste indexée en lecture seule des points localisés, de 1 à 16 (dans l'ordre numérique d'EasyBuilder, 0=1).

Fermé Ligne pixel

Affiche l'abscisse (X) du pixel du point.

Fermé Col. pixel

Affiche l'ordonnée (X) de l'image du point.

Fermé X réel

Affiche la valeur de l'abscisse (X) réelle du point.

Fermé Y réel

Affiche la valeur de l'ordonnée (Y) réelle du point.

Fermé X réel

Définit la valeur de l'abscisse (X) réelle du point sélectionné.

Fermé Y réel

Définit la valeur de l'ordonnée (Y) réelle du point sélectionné.

Fermé Sélectionner des points

Permet de sélectionner les caractéristiques d'entrée sous forme de points. Lorsque ce bouton a été sélectionné, EasyBuilder examine votre image et affiche (en cyan) une sélection de Smart Features (points, origines de repères ou centre de caractéristiques circulaires) qu'il a automatiquement détectées, ainsi que toutes les caractéristiques précédemment définies avec un autre outil (affichées en vert). Sélectionnez une des caractéristiques disponibles en cliquant dessus. Elle devient rose.


Entrées/sorties

L'étape Entrées/sorties permet de définir les paramètres des lignes d'entrée et de sortie discrètes des systèmes de vision In-Sight et des modules d'E/S pris en charge. Vous pouvez personnaliser le nom de la ligne, définir le type de signal et sélectionner le type de transition de bord et les résultats des outils, et forcer les entrées et les sorties pour tester votre application.

Remarque :
  • Cette étape d'application est désactivée lors de l'utilisation d'un émulateur.
  • Avant de configurer les lignes d'entrée ou de sortie, regardez si votre périphérique de sortie est de type PNP (à excitation de courant) ou NPN (à consommation de courant), et assurez-vous qu'il est correctement connecté au capteur In-Sight ou au module d'E/S. Pour en savoir plus, consultez le manuel d'installation du capteur In-Sight ou du module d'E/S concerné.

Connexion des lignes d'entrée et de sortie

Entrées : Chargement d'un fichier de projet

Entrées : Activation et désactivation des outils de recherche et d'inspection

Entrées : Déclenchement de l'acquisition d'image

Entrées : apprentissage d'un modèle de forme sur une ligne d'entrée

Sorties : Signalement de l'échec d'une acquisition d'image

Sorties : Déclenchement d'un éclairage pour l'acquisition d'image

Sorties : Définition d'une ligne sur le résultat d'un outil de recherche ou d'inspection


Connexion des lignes d'entrée et de sortie

  1. Vous pouvez également appuyer sur le bouton Module d'E/S pour ouvrir la boîte de dialogue Configuration du module d'E/S. Configurez le module d'E/S et cliquez sur le bouton OK pour fermer la boîte de dialogue Configuration du module d'E/S. Lorsque la connexion initiale entre le système de vision et le module d'E/S est établie, le message « (connecté) » apparaît à côté du module d'E/S sur la liste. Lorsque vous êtes correctement connecté à un module d'E/S, vous pouvez commencer à personnaliser les lignes.
  2. Sélectionnez une ligne d'entrée ou de sortie à configurer. Le nombre d'entrées et de sorties accessibles varie en fonction du modèle In-Sight et du module d'E/S applicable. Consultez cette rubrique pour plus d'informations.
  3. In-Sight séries 7000 Gen2 et 9912 uniquement : Si la ligne prend en charge l'E/S bidirectionnelle, sélectionnez Entrée ou Sortie dans la liste déroulante Direction.
  4. Vous pouvez personnaliser la ligne par défaut Nom en saisissant un nouveau nom spécifique à votre application. Le nom peut comprendre jusqu'à 15 octets, à titre de référence uniquement. Il ne modifie pas la fonctionnalité de la ligne et ne peut pas être référencé.

  5. Ensuite, définissez un Type de signal pour la ligne d'entrée sélectionnée. Chaque ligne peut être configurée pour l'une des fonctions suivantes :

    Type de signal d'entrée Description
    Données utilisateur

    Ligne d'entrée générale, utilisée pour activer ou désactiver les outils de recherche et d'inspection.

    Remettre les compteurs à zéro

    Remet à zéro les compteurs EasyBuilder (Projet.Nombre_échecs, Projet.Nombre_inspections, Projet.Nombre_succès, <Outil>.Nombre_échecs et <Outil>.Nombre_succès).

    Remarque :
    • Ce type de signal ne fonctionne que lorsque le système de vision est en ligne.
    • Seule une ligne d'entrée peut être configurée pour Remettre les compteurs à zéro.
    • Lorsqu'un nouveau projet est créé après avoir défini l'une des lignes d'entrée sur Remettre les compteurs à zéro, le nouveau projet rétablit automatiquement la ligne d'entrée sur Déclencheur d'événements (vide, lors de l'utilisation du capteur de vision In-Sight série 2000).

    Déclencheur d'événement

    Déclenche un événement, par le biais de la logique créée dans la vue Tableur. Pour qu'un Déclencheur d'événements mette à jour le tableur, ce dernier doit contenir une structure Event avec un paramètre Déclencheur défini sur ce numéro de ligne d'entrée discrète.

    Remarque :
    • Ce type de signal ne fonctionne que lorsque le système de vision est en ligne.
    • Cette option requiert un accès à la vue Tableur ; sauf si elle est utilisée pour apprendre un modèle de forme sur une ligne d'entrée.

    Numéro du projet

    Fournit un bit d'un numéro de projet, chargé lorsque l'état d'une autre ligne d'entrée discrète de type Chargement de projet est activé.

    Remarque :
    • Pour utiliser la fonction Numéro du projet, le projet à charger doit être enregistré avec un préfixe numérique (0 à 127).
    • Le bit le moins significatif du Numéro du projet correspond à la ligne d'entrée discrète numérotée la plus basse du module d'E/S.

    En ligne/Hors ligne

    Met le système de vision In-Sight En ligne ou Hors ligne (0 = Hors ligne et 1 = En ligne). Ce type d'entrée ne peut pas être utilisé sur plus d'une ligne d'entrée à la fois.

    Remarque : Lorsque le type du signal est défini sur En ligne, il se peut que le système de vision soit toujours hors ligne s'il a été défini sur Hors ligne manuellement dans l'interface utilisateur d'In-Sight Explorer ou si une commande Set Online du Mode natif (SO0) a été émise pour indiquer au système de vision de passer hors ligne.

    Déclencheur d'acquisition
    (Non pris en charge par les capteurs In-Sight série 2000 et CIO-1400)

    Déclenche le système de vision pour acquérir une image. Ce type d'entrée ne peut pas être utilisé sur plus d'une ligne d'entrée à la fois.

    Remarque :
    • Le paramètre Déclencheur dans la zone de groupe Modifier les paramètres d'acquisition doit être défini sur Externe pour employer l'entrée Déclencheur d'acquisition et une ligne de signal doit être physiquement connectée à l'entrée du système de vision In-Sight pour utiliser l'entrée Déclencheur d'acquisition.
    • Il est possible d'obtenir des fréquences de déclenchement plus rapides en utilisant l'entrée intégrée du déclencheur d'acquisition du système de vision (en définissant le Déclencheur sur Caméra) plutôt que de déclencher les événements du système de vision avec une ligne d'entrée générale configurée en tant que Déclencheur d'acquisition (en définissant Déclencheur sur Externe).
    • Si le paramètre Déclencheur est défini sur Externe et qu'une acquisition échoue, la sortie ERR : Acquisition manquée n'est pas émise du système de vision ; le signal ERR : Acquisition manquée est uniquement pris en charge lorsque le paramètre Déclencheur est défini sur Caméra.

    Interrupteur de chargement de tâche

    ACTIVÉ lit l'ensemble des numéros de projets et charge le projet indiqué. Ce type d'entrée ne peut pas être utilisé sur plus d'une ligne d'entrée à la fois.

    Remarque : le système de vision doit être hors ligne.

    Changement de programme (train d’impulsions)

    (Uniquement pris en charge sur les capteurs In-Sight série 2000 à l'aide d'E/S direct)

    Initialise le changement de programme fondé sur la détection d'impulsions d'entrées, différenciées par la largeur des impulsions. Les impulsions sont générées par un périphérique externe (tel qu'un PLC), et envoyées au capteur In-Sight 2000. Tout d'abord, le périphérique externe émet une impulsion de départ. Ensuite, le périphérique externe émet des impulsions de décompte, avec un écart d'impulsion entre chaque impulsion de décompte. Enfin, le périphérique externe émet une impulsion de fin.

    Type d'impulsion | Durée d'impulsion
    Impulsion de départ | 20 ms (±2 ms)
    Impulsion de décompte | 10 ms (±1 ms)
    Écart d'impulsion | 10 ms (±1 ms)
    Impulsion de fin | 20 ms (±2 ms)

    Lorsque toutes les impulsions et les écarts d'impulsion correspondent aux longueurs d'impulsion spécifiées, la demande de changement de programme aboutit et le projet est chargé vers le capteur. Si l'une des conditions n'est pas remplie (c'est-à-dire une impulsion incorrecte ou un mauvais délai d'écart d'impulsion), la demande de changement de projet échoue et aucun changement n'a lieu.

    Remarque :
    • Ce type de signal ne fonctionne que lorsque le système de vision est en ligne.
    • Afin d'utiliser la fonction Changement de programme (train d’impulsions), au moins un projet doit être enregistré dans le capteur, avec un préfixe numérique compris entre 0 et 31 au format #nomduprojet.job (par exemple 1InspectionAiguille.job). Le nombre d'impulsions de décompte émises doit correspondre au préfixe numérique du projet à charger.
    • La commande en mode natif SetSystemConfig("PulseJobChangeTiming") peut être utilisée pour configurer les largeurs de l'impulsion de démarrage, de l'impulsion de comptage, de l'écart entre les impulsions et de l'impulsion d'arrêt.
    • Il est possible de configurer une ligne de sortie discrète comme un type de Chargement du projet terminé ou Chargement du projet échoué pour impulser la sortie et signaler le succès ou l'échec de la demande de changement de programme.

    Réception série
    (E/S direct uniquement)

    Configure cette ligne comme une ligne de réception série.

    Remarque :
    • Ce type de signal est uniquement valide pour la ligne d'entrée 1, lorsque E/S directe est sélectionnée.
    • Il existe deux options pour activer la communication série pour le système de vision In-Sight série 70xx - 74xx : utiliser le câble breakout ou le module d'E/S CIO-MICRO ou CIO-MICRO-CC. Lorsqu'il est branché au câble breakout (sans connexion à un module d'E/S), le système de vision permet de configurer une ligne d'entrée discrète et une ligne de sortie discrète en tant que Réception série et Transmission série, respectivement.
    • Si le système de vision In-Sight série 70xx - 74xx est configuré pour être utilisé avec le module d'E/S CIO-MICRO ou CIO-MICRO-CC, les broches TRANSMISSION RS-232 et RÉCEPTION RS-232 du câble breakout sont désactivées. Utilisez le port RS-232 OUT (DB9) du module d'E/S pour raccorder le système à un périphérique série.

  6. Sélectionnez un Type de transition pour la ligne d'entrée sélectionnée, qui contrôle la sensibilité de la ligne d'entrée au niveau des transitions.

    • Front montant : Modifie l'état de la ligne d'entrée selon le premier front d'une impulsion.
    • Front descendant : modifie l'état de l'entrée selon le dernier front d'une impulsion.
    • Les deux fronts : Modifie l'état de la ligne d'entrée selon les premier et dernier fronts d'une impulsion. Cette option est disponible uniquement lorsque le type Déclencheur d'événement est sélectionné.

  7. Ensuite, définissez un Type de signal pour la ligne de sortie sélectionnée. Chaque ligne peut être configurée pour l'une des fonctions suivantes :

    Type de signal de sortie | Description
    Résultat du projet (par défaut) | Active le résultat d'un outil de recherche ou d'inspection afin de contrôler l'état de cette ligne de sortie. Pulsé ou en continu.
    Haut | Force la sortie sur HAUT (1).
    Bas | Force la sortie sur BAS (0).
    Début de l'acquisition

    Signale que le système de vision a lancé une acquisition. Toujours pulsé.

    Remarque : pour le système de vision In-Sight 8405, le signal de début d'acquisition est pulsé quand la première ligne de pixels est exposée.
    Fin de l'acquisition

    Signale la fin de l'acquisition du système de vision. Toujours pulsé.

    Remarque : pour le système de vision In-Sight 8405, le signal de fin d'acquisition est pulsé quand la lecture totale de l'image est terminée.
    Fin d'exécution | Signale chaque fin de mise à jour par EasyBuilder. Toujours pulsé.
    Système occupé | HAUT lorsque le système de vision exécute un projet ou qu'il répond à une entrée utilisateur, BAS lorsque le système de vision est inactif..
    Tâche chargée | Signale le chargement réussi du projet. Toujours pulsé.
    Échec du chargement de la tâche | Signale l'échec de l'ouverture d'un projet. Toujours pulsé.
    ERR : échec de l'acquisition

    Signaux indiquant que le déclenchement d'une acquisition a été reçu avant l'envoi d'un signal Fin d'acquisition, ou qu'aucune mémoire tampon d'image n'était disponible pour l'acquisition des images lorsqu'un déclenchement d'acquisition a été reçu. Toujours pulsé.

    Remarque : Le paramètre Déclencheur de la zone de groupe Modifier les paramètres d'acquisition de l'étape Configurer l'image doit être défini sur Caméra pour utiliser la sortie ERR : Échec de l'acquisition.
    ERR : Dépassement de suivi

    Signale qu'EasyBuilder a lancé un signal de sortie discrète temporisée peu après le moment où il avait été prévu. Toujours pulsé.

    Remarque : Ce signal n'est pas pris en charge par CIO-1400 et CIO-MICRO.
    ERR : Liste de suivi pleine | Signale que EasyBuilder a lancé un signal de sortie discrète temporisée pour une ligne sur laquelle le déclenchement d'une autre sortie avait déjà été programmé au même moment. Toujours pulsé.
    En ligne/Hors ligne | HAUT (1) lorsque le système de vision est en ligne, BAS (0) lorsque le système de vision est hors ligne.
    Stroboscopique | Le front montant ou descendant du signal peut être utilisé pour déclencher une unité stroboscopique.
    Contrôle de l'éclairage
    (CIO-1460 uniquement)     		Le front montant ou descendant du signal peut être utilisé pour déclencher un éclairage.
    Module d'E/S en attente
    (CIO-1450 et CIO-1460 uniquement)

    ON signifie que le module d'E/S a détecté une erreur de communication entre le système de vision et lui-même et qu'il essaie de rétablir la connexion. La ligne est OFF dès que le module d'E/S détecte que la condition de l'erreur a été corrigée.

    Remarque : ce type de sortie n'est valide que pour les lignes 0 à 7 lors de la configuration des modules CIO-1450 ou CIO-1460.
    Lifeline
    (CIO-MICRO et CIO-MICRO-CC uniquement)     		HAUT lorsque le système de vision est activement connecté au CIO-MICRO ou CIO-MICRO-CC. BAS en cas d'échec de la connexion au système de vision.
    Forme d'onde

    Active une fonction de forme d'onde, WriteWaveformPulseTrain ou WriteWaveformClocked, dans le tableur afin de contrôler l'état de cette ligne de sortie.

    Remarque : Cette option requiert un accès à la vue Tableur.
    Transmission série

    Configure la ligne comme une ligne de transmission série.

    Remarque :
    • La Transmission série est disponible uniquement pour la connexion de In-Sight Explorer 4.7.1 ou version ultérieure à un système de vision In-Sight série 70xx - 74xx, avec un micrologiciel In-Sight 4.7.1 ou version ultérieure.
    • Ce type de sortie n'est valide que pour la ligne de sortie 1 lorsque E/S direct est sélectionné.
    • Il existe deux options pour activer la communication série pour le système de vision In-Sight série 70xx - 74xx : utiliser le câble breakout ou le module d'E/S CIO-MICRO ou CIO-MICRO-CC. Lorsqu'il est branché au câble breakout (sans connexion à un module d'E/S), le système de vision permet de configurer une ligne d'entrée discrète et une ligne de sortie discrète en tant que Réception série et Transmission série, respectivement.
    Succès/échec du projet (In-Sight série 7000 Gen2 et In-Sight série 9000 uniquement) | Lorsqu'il est sélectionné, l'anneau de l'indicateur et la LED indiquant les succès/échecs du système de vision s'allument en vert (succès) ou en rouge (échec) selon l'état global de la tâche réussie/échouée.
  8. Cliquez sur le bouton Détails pour ouvrir la boîte de dialogue de détails de la ligne de sortie sélectionnée (s'il existe des informations détaillées relatives au type de signal de sortie défini).

  9. Vous pouvez cocher la case Désactiver les sorties en mode Hors ligne pour désactiver les sorties lorsque le système de vision est mis hors ligne.

    Remarque : Si la case Désactiver les sorties en mode Hors ligne est cochée et que le module d'E/S CIO-MICRO ou CIO-MICRO-CC présente une ligne de sortie configurée comme type de signal LifeLine, la ligne reste Haut lorsque le système de vision connecté est mis hors ligne.
  10. Vous pouvez également utiliser Forcer la sortie pour tester ou déboguer une application avant ou après son déploiement. L'option Forcer annule les paramètres définis de ligne, ce qui vous permet de « forcer » le fonctionnement d'une ligne d'entrée ou de sortie pour tester le résultat lorsque le capteur In-Sight est en ligne.
    1. Choisissez la ligne que vous souhaitez tester.
    2. Configurez le paramètre Forcer sur Activé. Cela va forcer la ligne à effectuer l'action configurée pour elle.
    3. Mettez le système de vision en ligne et déclenchez-le.

    4. Après avoir fini de tester la ligne, mettez le système de vision en ligne et définissez le paramètre Forcer sur Désactivé ou Aucun.

    Remarque :
    • Pour les lignes de sortie, la fonction Forcer ne génère pas de sortie réelle. Elle modifie uniquement la valeur d'une sortie qui aurait lieu autrement.
    • Si vous souhaitez juste tester la connexion électrique sur votre ligne de sortie, il est recommandé de définir la ligne de sortie sur « Haut » ou « Bas » au lieu d'utiliser Forcer, puis configurez le système de vision sur En ligne. Cela maintient le signal de sortie haut ou bas tant que le système de vision est en mode En ligne. Vous pouvez alors utiliser un multimètre pour déterminer si votre circuit électrique fonctionne correctement.
  11. Toutes les modifications apportées à ces paramètres sont automatiquement enregistrées dans le système de vision (et non dans le fichier .job) lorsque vous quittez l'étape.

Configuration du module d'E/S

Nombre de lignes d'entrée et de sortie

Lignes d'entrée et de sortie par défaut

Commandes de la boîte de dialogue de détails de la sortie


Configuration du module d'E/S

Fermé Configuration du module CIO-1400, CIO-1450 ou CIO-1460
  1. Connectez-vous à un système de vision pris en charge depuis In-Sight Explorer.
  2. Ouvrez la boîte de dialogue Configuration du module d'E/S.
  3. Sélectionnez CIO-1400, CIO-1450 ou CIO-1460 dans la liste déroulante Sélectionner le module d'E/S.
  4. Cliquez sur OK pour fermer la boîte de dialogue.
Fermé Configuration du module CIO-MICRO ou CIO-MICRO-CC
  1. Connectez-vous à un système de vision pris en charge depuis In-Sight Explorer.
  2. Ouvrez la boîte de dialogue Configuration du module d'E/S.
  3. Sélectionnez CIO-MICRO ou CIO-MICRO-CC dans la liste déroulante Sélectionner le module d'E/S.

  4. Sélectionnez le module d'E/S approprié dans la liste déroulante Connecter à.

    Remarque : Si le nom d'hôte du module d'E/S ne figure pas dans la liste, sélectionnez <Connecter par adresse IP>, puis saisissez manuellement l'adresse IP du module d'E/S.

  5. Dans le champ Durée de mise à jour, indiquez l'intervalle de temps requis pour la synchronisation d'entrée et sortie (1 ms à 500 ms ; par défaut = 20 ms) entre le système de vision In-Sight Micro et le module d'E/S CIO-MICRO ou CIO-MICRO-CC.

    Remarque : si une latence excessive du signal de sortie pose problème, diminuez la Durée de mise à jour. Toutefois, réduisez la Durée de mise à jour au strict nécessaire pour votre application, parce que si la Durée de mise à jour diminue, la durée d'exécution du projet peut augmenter.
  6. Si nécessaire, cliquez sur le bouton Modifier les paramètres... pour configurer les paramètres réseau du module d'E/S.

    • Par défaut, les modules d'E/S CIO-MICRO et CIO-MICRO-CC In-Sight sont configurés dynamiquement par le serveur DHCP au démarrage. Un nouveau nom d'hôte peut être affecté, mais tous les autres champs de la boîte de dialogue sont désactivés.

      Remarque : Si aucun serveur DHCP n'est disponible, le module d'E/S arrive au bout de son délai et se connecte à une adresse IP locale de liaison.
    • Une adresse IP statique peut être utilisée pour le module CIO-MICRO ou CIO-MICRO-CC en décochant la case Utiliser un serveur DHCP et en définissant les paramètres réseau appropriés dans les champs Adresse IP, Masque de sous-réseau, Passerelle par défaut, Serveur DNS et Nom de domaine.
  7. Cliquez sur OK pour fermer la boîte de dialogue.
Fermé Configuration du module CIO-WENET

Pour que le module d'E/S CIO-WENET puisse être configuré dans In-Sight Explorer, vous devez d'abord affecter une adresse IP au module. Une fois l'adresse IP affectée au module, il peut être configuré dans In-Sight Explorer :

  1. Connectez-vous à un système de vision pris en charge depuis In-Sight Explorer.
  2. Ouvrez la boîte de dialogue Configuration du module d'E/S.
  3. Sélectionnez CIO-WENET dans la liste déroulante Sélectionner le module d'E/S.
  4. Dans le champ Adresse IP, indiquez l'adresse IP que vous venez d'affecter au module CIO-WENET.

  5. Dans le champ Durée de mise à jour, indiquez l'intervalle de temps requis pour la synchronisation d'entrée et sortie (1 ms à 500 ms ; par défaut = 20 ms) entre le système de vision In-Sight Micro et le module d'E/S CIO-WENET.

    Remarque :
    • si une latence excessive du signal de sortie pose problème, diminuez la Durée de mise à jour. Toutefois, réduisez la Durée de mise à jour au strict nécessaire pour votre application, parce que si la Durée de mise à jour diminue, la durée d'exécution du projet peut augmenter.
    • Pour le module CIO-WENET, la durée de synchronisation est 3 ms plus longue que la Durée de mise à jour.
  6. Cliquez sur OK pour fermer la boîte de dialogue.


Nombre de lignes d'entrée et de sortie

Le nombre de sorties directes (intégrées) varie en fonction du système de vision In-Sight, comme suit :

Système de vision In-Sight | Entrées directes (intégrées) | Sorties directes (intégrées)
In-Sight Micro série 1000 | Aucun | 2 sorties rapides 2 LED pouvant être configurées par l'utilisateur (1 verte et 1 rouge)
In-Sight série 2000 | 1 entrée générale | 4 sorties rapides 2 LED pouvant être configurées par l'utilisateur (1 verte ou rouge, 1 jaune)
In-Sight série 5000 | Aucun | 2 sorties rapides 2 LED pouvant être configurées par l'utilisateur (1 verte et 1 rouge)
In-Sight série 70xx - 74xx | 3 entrées générales | 4 sorties rapides 2 LED pouvant être configurées par l'utilisateur (1 verte et 1 rouge)
In-Sight série 76xx - 79xx | Jusqu'à 3 entrées générales | Jusqu'à 4 sorties rapides 2 LED pouvant être configurées par l'utilisateur (1 verte ou rouge, 1 rouge)
In-Sight série 8000 | Aucun | 2 sorties rapides 2 LED pouvant être configurées par l'utilisateur (1 verte et 1 rouge)
In-Sight 9902L | 1 entrée générale | 2 sorties rapides 2 LED pouvant être configurées par l'utilisateur (1 verte ou rouge, 1 rouge)
In-Sight 9912 | Jusqu'à 3 entrées générales | Jusqu'à 4 sorties rapides 2 LED pouvant être configurées par l'utilisateur (1 verte ou rouge, 1 rouge)
Remarque :
  • Les systèmes de vision In-Sight ont une entrée de déclenchement d'acquisition dédiée sur le système de vision. Pour en savoir plus, reportez-vous au manuel d'installation du système de vision inclus avec le logiciel In-Sight Explorer.
  • Lorsqu'il est connecté au câble breakout, les systèmes de vision In-Sight séries 76xx - 79xx et 9912 prennent en charge des sorties haute vitesse bidirectionnelles et des entrées générales pour les bornes HS OUT 2 / IN 2 et HS OUT 3 / IN 3. Par défaut, ces lignes sont configurées comme des sorties.

Un module d'E/S peut être utilisé pour fournir des entrées et sorties discrètes supplémentaires. Le nombre d'entrées et de sorties discrètes varie par module d'E/S applicable, comme suit :

Module d'E/S | Système de vision In-Sight pris en charge | Entrées discrètes | Sorties discrètes
CIO-1400 | In-Sight série 2000, In-Sight série 5000 (à l’exception de 5604), In-Sight séries 76xx - 79xx, In-Sight série 9000 | 7 entrées générales | 6 sorties générales
CIO-MICRO | In-Sight Micro série 1000, In-Sight série 5000, In-Sight séries 70xx - 79xx, In-Sight série 8000, In-Sight série 9000 | 8 entrées générales | 8 sorties générales
CIO-MICRO-CC | In-Sight Micro série 1000, In-Sight série 5000 (sauf 5705, 5705C et 5715), In-Sight série 70xx - 74xx | 8 entrées générales | 8 sorties générales
CIO-1450 | In-Sight série 5000 (sauf 5604, 5705, 5705C et 5715) | 8 entrées générales | 8 sorties générales
CIO-1460 | In-Sight série 5000 (sauf 5604, 5605, 5705, 5705C et 5715) | 8 entrées générales | 8 sorties générales
CIO-WENET | In-Sight Micro série 1000 | 8 entrées générales | 8 sorties générales
Remarque :
  • Le module d'E/S CIO-1400 prend en charge les capteurs de vision In-Sight série 2000 avec la version 5.3.0 du micrologiciel ou les versions ultérieures.
  • Le module d'E/S CIO-1400 prend en charge le système de vision In-Sight série 76xx - 79xx avec In-Sight Explorer 5.4.0 et les versions ultérieures. Si vous vous connectez au système de vision à l'aide d'une version précédente d'In-Sight Explorer, que vous vous connectez au module d'E/S CIO-1400 et que vous configurez les lignes d'E/S, les modifications ne sont pas conservées.
  • Le module d'E/S CIO-MICRO prend en charge les systèmes de vision In-Sight 5705, 5705C, 5715 et In-Sight série 8000 avec la version 5.3.0 du micrologiciel ou les versions ultérieures.
  • Les modules d'E/S CIO-MICRO & CIO-MICRO-CC ne prennent en charge que les systèmes de vision In-Sight série 5100 et série 5400 avec une mémoire flash non volatile de 128 Mo au minimum. Les modèles peuvent être identifiés par le numéro de type (821-xxxx-xx). Le numéro de type se trouve sur l'étiquette apposée sur le système de vision.
  • Les modules d'E/S CIO-1450, CIO-1460 et CIO-WENET sont obsolètes et ne sont plus disponibles à l'achat, ils sont toutefois encore pris en charge dans In-Sight Explorer, mais uniquement à des fins de rétrocompatibilité.


Lignes d'entrée et de sortie par défaut

Fermé In-Sight Micro série 1000
Remarque :
  • HS OUT 0 et HS OUT 1 sont des sorties rapides, provenant directement du système de vision.
  • Le système de vision prend en charge un signal de type Stroboscopique sur la ligne HSOUT 1.

E/S direct

Sortie | Nom
0 | HSOUT 0
1 | HSOUT 1
4 | LED verte
5 | LED rouge

CIO-MICRO ou CIO-MICRO-CC

Entrée | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
Sortie | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
8 | HSOUT 0
9 | HSOUT 1
10 | LED verte
11 | LED rouge

CIO-WENET

Entrée | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
Sortie | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
8 | HSOUT 0
9 | HSOUT 1
10 | LED verte
11 | LED rouge
Fermé In-Sight série 2000
Remarque :
  • IN 0 est une entrée intégrée, directement depuis le capteur de vision.

  • HS OUT 0, HS OUT 1, HS OUT 2 et HS OUT 3 sont des sorties rapides, provenant directement du capteur de vision.

  • Le capteur de vision prend en charge un signal de type Stroboscopique sur la ligne HSOUT 1.
  • LED verte/LED rouge est une sortie LED unique dont les deux états rouge et vert peuvent être configurés par l'utilisateur.

E/S direct

Entrée | Nom
0 | IN 0
Sortie | Nom
0 | HSOUT 0
1 | HSOUT 1
2 | HSOUT 2
3 | HSOUT 3
4 | LED verte
 | LED rouge
5 | LED jaune

CIO-1400

Entrée | Nom
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
Sortie | Nom
0 | HSOUT 0
1 | HSOUT 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
 | Ligne 5
5 | Ligne 6
7 | Ligne 7
8 | LED verte
9 | LED rouge
10 | LED jaune
11 | Désactivé
12 | Désactivé
Fermé In-Sight série 5000

Direct / CIO-1350

Sortie | Nom
0 | HSOUT 0
1 | HSOUT 1
4 | LED verte
5 | LED rouge

CIO-1400

Entrée | Nom
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
Sortie | Nom
0 | HSOUT 0
1 | HSOUT 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
8 | LED verte
9 | LED rouge

CIO-1450

Remarque : Lorsque des sorties discrètes pulsées sont émises depuis un module d'E/S CIO-1450, il est possible que les impulsions durent 10 millisecondes de plus que le paramètre indiqué.
Entrée | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
Sortie | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
8 | HSOUT 0
9 | HSOUT 1
10 | LED verte
11 | LED rouge

CIO-1460

Remarque : Lors du redémarrage d'un module d'E/S CIO-1460, les sorties discrètes peuvent se déclencher pendant environ 250 microsecondes au cours de l'initialisation.
Entrée | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
Sortie | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
8 | HSOUT 0
9 | HSOUT 1
10 | LED verte
11 | LED rouge
12 | Désactivé
13 | Désactivé

CIO-MICRO/CIO-MICRO-CC

Remarque :
  • Le module d'E/S CIO-MICRO prend en charge les systèmes de vision In-Sight 5705, 5705C, 5715 avec la version 5.3.0 du micrologiciel ou les versions suivantes.
  • Les modules d'E/S CIO-MICRO et CIO-MICRO-CC I/O prennent en charge les systèmes de vision In-Sight série 5100 et série 5400 avec une mémoire flash non volatile de 128 Mo au minimum. Les modèles peuvent être identifiés par le numéro de type (821-xxxx-xx). Le numéro de type se trouve sur l'étiquette apposée sur le système de vision.
Entrée | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
Sortie | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
8 | HSOUT 0
9 | HSOUT 1
10 | LED verte
11 | LED rouge
Fermé In-Sight série 70xx - 74xx
Remarque :
  • Le système de vision In-Sight série 70xx - 74xx prend en charge la connexion simultanée au câble breakout et au module d'E/S CIO-MICRO ou CIO-MICRO-CC.
  • IN 1, IN 2 et IN 3 sont des entrées intégrées, provenant directement du système de vision. Les entrées directes (intégrées) sont uniquement prises en charge lorsque le système de vision est connecté au câble breakout.
  • HS OUT 0, HS OUT 1, HS OUT 2 et HS OUT 3 sont des sorties rapides, provenant directement du système de vision. Les sorties rapides des systèmes de vision In-Sight série 70xx - 74xx sont uniquement prises en charge lorsque le système de vision est connecté au câble breakout.
  • Le système de vision prend en charge un signal de type Stroboscopique sur la ligne HSOUT 0.
  • Si vous connectez un équipement stroboscopique externe au câble d'éclairage externe du système de vision In-Sight séries 70xx - 74xx, utilisez la boîte de dialogue Paramètres de lumière pour en configurer les paramètres.
  • Il existe deux options pour activer la communication série pour le système de vision In-Sight série 70xx - 74xx : utiliser le câble breakout ou le module d'E/S CIO-MICRO ou CIO-MICRO-CC. Lorsqu'il est branché au câble breakout (sans connexion à un module d'E/S), le système de vision permet de configurer une ligne d'entrée discrète et une ligne de sortie discrète en tant que Réception série et Transmission série, respectivement.

E/S direct

Entrée | Nom
1 | IN 1/Réception série
2 | IN 2
3 | IN 3
Sortie | Nom
0 | HS OUT 0
1 | HS OUT 1/Transmission série
2 | HS OUT 2
3 | HS OUT 3
4 | LED verte
5 | LED rouge

CIO-MICRO/CIO-MICRO-CC

Remarque :
  • Lorsque le système de vision est connecté au câble breakout et qu'une connexion Ethernet sur un module d'E/S CIO-MICRO I/O a été établie :
    • Le port d'E/S (DB15) et les bornes TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 et HS COMMON du module d'E/S ne sont pas pris en charge. Ne connectez pas les câbles de périphériques distants sur ces bornes.
    • Le port d'E/S (DB15) du module d'E/S n'est pas pris en charge. Ne connectez rien à ce port.
    • Les broches RS-232 TRANSMIT et RS-232 RECEIVE du câble breakout sont désactivées. Utilisez le port RS-232 OUT (DB9) du module d'E/S pour connecter un périphérique série.
Entrée | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
9 | IN 1
10 | IN 2
11 | IN 3
Sortie | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
8 | HS OUT 0
9 | HS OUT 1
10 | HS OUT 2
11 | HS OUT 3
12 | LED verte
13 | LED rouge
Fermé In-Sight série 7000 Gen2
Remarque :
  • Le système de vision prend en charge la connexion simultanée au câble breakout et au module d'E/S CIO-MICRO.
  • IN 1, IN 2 et IN 3 sont des entrées intégrées, provenant directement du système de vision. Les entrées directes (intégrées) sont uniquement prises en charge lorsque le système de vision est connecté au câble breakout.
  • HS OUT 0, HS OUT 1, HS OUT 2 et HS OUT 3 sont des sorties rapides, provenant directement du système de vision.
  • Le système de vision prend en charge un signal de type Stroboscopique sur la ligne HSOUT 1.
  • Si vous connectez un équipement stroboscopique externe au câble d'éclairage externe du système de vision In-Sight séries 7000 Gen2, ou si vous connectez un accessoire d'éclairage au panneau de commandes du système de vision, utilisez la boîte de dialogue Paramètres de lumière pour en configurer les paramètres.

E/S direct

Remarque : Le système de vision prend en charge des sorties haut débit bidirectionnelles et des entrées générales pour les bornes IN 2 / HS OUT 2 et IN 3 / HS OUT 3. Par défaut, ces lignes sont configurées comme des sorties.
Entrée | Direction | Nom
1 | Entrée fixe | IN 1
2 | Entrée | IN 2
3 | Entrée | IN 3
Sortie | Direction | Nom
0 | Sortie fixe | HSOUT 0
1 | Sortie fixe | HSOUT 1
2 | Sortie | HSOUT 2
3 | Sortie | HSOUT 3
4 | Sortie fixe | LED Réussite/Échec
5 | Sortie fixe | LED Erreur

CIO-MICRO

Remarque :
  • Lorsque le système de vision est connecté au câble breakout et qu'une connexion Ethernet sur un module d'E/S CIO-MICRO I/O a été établie :
    • Le système de vision prend en charge des sorties haut débit bidirectionnelles et des entrées générales pour les bornes IN 2 / HS OUT 2 et IN 3 / HS OUT 3. Par défaut, ces lignes sont configurées comme des sorties.
    • Les bornes TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 et HS COMMON du module d'E/S CIO-MICRO ne sont pas prises en charge. Ne connectez pas les câbles de périphériques distants sur ces bornes.
    • Les broches RS-232 TRANSMIT et RS-232 RECEIVE du câble breakout sont désactivées. Utilisez le port RS-232 OUT (DB9) du module d'E/S pour connecter un périphérique série.
  • Lorsque le système de vision est connecté au module d'E/S CIO-MICRO via le câble du module d'E/S :
    • Les lignes IN 1, IN 2, IN 3, HS OUT 2 et HS OUT 3 du système de vision sont affichées dans la boîte de dialogue Paramètres des E/S discrètes, mais ne sont pas prises en charge. Ces lignes sont uniquement prises en charge lorsque le système de vision est connecté au câble breakout.
    • Les bornes TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 et HS COMMON sont connectées via les bornes du module d'E/S CIO-MICRO.
    • Les accessoires d'éclairage montés sur la plaque frontale du système de vision ou le connecteur LIGHT ne sont pas pris en charge. Si ces accessoires d'éclairage sont montés, le câble breakout doit être utilisé pour alimenter le système de vision et une connexion au module d'E/S doit être établie uniquement via Ethernet.
Entrée | Direction | Nom
0 | Entrée fixe | Ligne 0
1 | Entrée fixe | Ligne 1
2 | Entrée fixe | Ligne 2
3 | Entrée fixe | Ligne 3
4 | Entrée fixe | Ligne 4
5 | Entrée fixe | Ligne 5
6 | Entrée fixe | Ligne 6
7 | Entrée fixe | Ligne 7
9 | Entrée fixe | IN 1
10 | Entrée | IN 2
11 | Entrée | IN 3
Sortie | Direction | Nom
0 | Sortie fixe | Ligne 0
1 | Sortie fixe | Ligne 1
2 | Sortie fixe | Ligne 2
3 | Sortie fixe | Ligne 3
4 | Sortie fixe | Ligne 4
5 | Sortie fixe | Ligne 5
6 | Sortie fixe | Ligne 6
7 | Sortie fixe | Ligne 7
8 | Sortie fixe | HSOUT 0
9 | Sortie fixe | HSOUT 1
10 | Sortie | HSOUT 2
11 | Sortie | HSOUT 3
12 | Sortie fixe | LED Réussite/Échec
13 | Sortie fixe | LED Erreur

CIO-1400

Remarque :
  • Lorsqu'elles sont connectées au module d'E/S CIO-1400, les lignes IN 1, IN 2, IN 3, HS OUT 2 et HS OUT 3 du système de vision ne sont pas prises en charge.
  • Le module d'E/S CIO-1400 prend en charge le système de vision In-Sight série 7000 Gen2 avec In-Sight Explorer 5.4.0 et les versions ultérieures. Si vous vous connectez au système de vision à l'aide d'une version précédente d'In-Sight Explorer, que vous vous connectez au module d'E/S CIO-1400 et que vous configurez les lignes d'E/S, les modifications ne sont pas conservées.
Entrée | Nom
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
Sortie | Nom
0 | HSOUT 0
1 | HSOUT 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
8 | LED Réussite/Échec
9 | LED Erreur
Fermé In-Sight série 8000
Remarque :
  • HS OUT 0 et HS OUT 1 sont des sorties rapides, provenant directement du système de vision.
  • Le système de vision prend en charge un signal de type Stroboscopique sur la ligne HSOUT 1.
  • En cas d'utilisation d'une unité stroboscopique avec système de vision In-Sight 8405, une exposition minimale de 72 ms est conseillée pour une capture d'image complète, afin de garantir l'exposition de toutes les lignes de pixels quand l'unité stroboscopique est pulsée.

E/S directe

Sortie | Nom
0 | HSOUT 0
1 | HSOUT 1
4 | LED verte
5 | LED rouge

CIO-MICRO

Remarque :
  • Le module d’E/S CIO-MICRO prend en charge les systèmes de vision In-Sight série 8000 avec la version 5.3.0 du micrologiciel ou les versions ultérieures.
  • Le système de vision In-Sight 8505P doit être connecté à une source d’alimentation PoE de classe 0, 3 ou 4, d’une puissance minimale de 12,95 W. Le module d’E/S CIO-Micro est un équipement PoE de Classe 2, son port PoE ne peut donc pas être utilisé pour alimenter le système de vision In-Sight 8505P. Au lieu de cela, branchez le câble Ethernet du système de vision à une alimentation PoE de Classe 0, 3 ou 4, et connectez-vous au module d’E/S depuis le réseau local à l’aide d’In-Sight Explorer.
Entrée | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
Sortie | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
8 | HSOUT 0
9 | HSOUT 1
10 | LED verte
11 | LED rouge
Fermé Système de vision à balayage de ligne In-Sight 9902L
Remarque :
  • Le système de vision prend en charge la connexion simultanée au câble breakout et au module d'E/S CIO-MICRO.
  • IN 1, IN 2 et IN 3 sont des entrées intégrées, provenant directement du système de vision. Les entrées directes (intégrées) sont uniquement prises en charge lorsque le système de vision est connecté au câble breakout.
  • HS OUT 0 et HS OUT 1 sont des sorties rapides, provenant directement du système de vision.
  • Le système de vision prend en charge un signal de type Stroboscopique sur la ligne HSOUT 1.
  • Si vous utilisez un stroboscope avec le système de vision à balayage de ligne In-Sight 9902L :
    • La configuration de câblage du stroboscope doit être PNP et le déclencheur Stroboscopique/Contrôle de la lumière doit être défini sur Front montant.
    • Lorsque le système de vision reçoit un déclencheur d'acquisition, la ligne de sortie émet une impulsion et le stroboscope clignote pendant la durée définie par Durée d'exposition. Une fois l'exposition terminée, le prochain déclencheur d'acquisition ne pourra démarrer avant un délai de 100 µs sous peine d'altérer le fonctionnement du stroboscope.

E/S direct

Entrée | Nom
1 | IN 1
Sortie | Nom
0 | HSOUT 0
1 | HSOUT 1
4 | LED Réussite/Échec
5 | LED Erreur

CIO-MICRO

Remarque :
  • Lorsque le système de vision est connecté au câble breakout et qu'une connexion Ethernet sur un module d'E/S CIO-MICRO I/O a été établie :
    • Les bornes TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 et HS COMMON du module d'E/S CIO-MICRO ne sont pas prises en charge. Ne connectez pas les câbles de périphériques distants sur ces bornes.
    • Les broches RS-232 TRANSMIT et RS-232 RECEIVE du câble breakout sont désactivées. Utilisez le port RS-232 OUT (DB9) du module d'E/S pour connecter un périphérique série.
  • Lorsque le système de vision est connecté au module d'E/S CIO-MICRO via le câble du module d'E/S :
    • Les entrées ENTRÉE CODEUR A et ENTRÉE CODEUR B de système de vision ne sont pas prises en charge.

    • La ligne IN 1 du système de vision est affichée la boîte de dialogue Paramètres des E/S discrètes, mais n'est pas prise en charge. La ligne IN 1 est uniquement prise en charge lorsque le système de vision est connecté au câble breakout.

    • Les bornes TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 et HS COMMON sont connectées via les bornes du module d'E/S CIO-MICRO.
Entrée | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
9 | IN 1
Sortie | Nom
0 | Ligne 0
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
8 | HSOUT 0
9 | HSOUT 1
10 | LED Réussite/Échec
11 | LED Erreur

CIO-1400

Remarque : Les entrées ENTRÉE CODEUR A, ENTRÉE CODEUR B et IN 1 du système de vision ne sont pas prises en charge si celui-ci est connecté au module d’E/S CIO-1400.
Entrée | Nom
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
Sortie | Nom
0 | HSOUT 0
1 | HSOUT 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
8 | LED Réussite/Échec
9 | LED Erreur
Fermé In-Sight 9912
Remarque :
  • Le système de vision prend en charge la connexion simultanée au câble breakout et au module d'E/S CIO-MICRO.
  • IN 1, IN 2 et IN 3 sont des entrées intégrées, provenant directement du système de vision. Les entrées directes (intégrées) sont uniquement prises en charge lorsque le système de vision est connecté au câble breakout.
  • HS OUT 0, HS OUT 1, HS OUT 2 et HS OUT 3 sont des sorties rapides, provenant directement du système de vision.
  • Le système de vision prend en charge un signal de type Stroboscopique sur la ligne HSOUT 1.
  • Si vous connectez un équipement stroboscopique externe au câble d'éclairage externe du système de vision In-Sight 9912, utilisez la boîte de dialogue Paramètres de lumière pour en configurer les paramètres.

E/S direct

Remarque : Le système de vision prend en charge des sorties haut débit bidirectionnelles et des entrées générales pour les bornes IN 2 / HS OUT 2 et IN 3 / HS OUT 3. Par défaut, ces lignes sont configurées comme des sorties.
Entrée | Direction | Nom
1 | Entrée fixe | IN 1
2 | Entrée | IN 2
3 | Entrée | IN 3
Sortie | Direction | Nom
0 | Sortie fixe | HSOUT 0
1 | Sortie fixe | HSOUT 1
2 | Sortie | HSOUT 2
3 | Sortie | HSOUT 3
4 | Sortie fixe | LED Réussite/Échec
5 | Sortie fixe | LED Erreur

CIO-MICRO

Remarque :
  • Lorsque le système de vision est connecté au câble breakout et qu'une connexion Ethernet sur un module d'E/S CIO-MICRO I/O a été établie :
    • système de vision prend en charge des sorties haut débit bidirectionnelles et des entrées générales pour les bornes IN 2 / HS OUT 2 et IN 3 / HS OUT 3. Par défaut, ces lignes sont configurées comme des sorties.
    • Les bornes TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 et HS COMMON du module d'E/S CIO-MICRO ne sont pas prises en charge. Ne connectez pas les câbles de périphériques distants sur ces bornes.
    • Les broches RS-232 TRANSMIT et RS-232 RECEIVE du câble breakout sont désactivées. Utilisez le port RS-232 OUT (DB9) du module d'E/S pour connecter un périphérique série.
  • Lorsque le système de vision est connecté au module d'E/S CIO-MICRO via le câble du module d'E/S :
    • Les lignes IN 1, IN 2, IN 3, HS OUT 2 et HS OUT 3 du système de vision sont affichées dans la boîte de dialogue Paramètres des E/S discrètes, mais ne sont pas prises en charge. Ces lignes sont uniquement prises en charge lorsque le système de vision est connecté au câble breakout.
    • Les bornes TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 et HS COMMON sont connectées via les bornes du module d'E/S CIO-MICRO.
    • Les accessoires d'éclairage reliés au connecteur LIGHT ne sont pas pris en charge. Si ces accessoires d'éclairage sont montés, le câble breakout doit être utilisé pour alimenter le système de vision et une connexion au module d'E/S doit être établie uniquement via Ethernet.
Entrée | Direction | Nom
0 | Entrée fixe | Ligne 0
1 | Entrée fixe | Ligne 1
2 | Entrée fixe | Ligne 2
3 | Entrée fixe | Ligne 3
4 | Entrée fixe | Ligne 4
5 | Entrée fixe | Ligne 5
6 | Entrée fixe | Ligne 6
7 | Entrée fixe | Ligne 7
9 | Entrée fixe | IN 1
10 | Entrée | IN 2
11 | Entrée | IN 3
Sortie | Direction | Nom
0 | Sortie fixe | Ligne 0
1 | Sortie fixe | Ligne 1
2 | Sortie fixe | Ligne 2
3 | Sortie fixe | Ligne 3
4 | Sortie fixe | Ligne 4
5 | Sortie fixe | Ligne 5
6 | Sortie fixe | Ligne 6
7 | Sortie fixe | Ligne 7
8 | Sortie fixe | HSOUT 0
9 | Sortie fixe | HSOUT 1
10 | Sortie | HSOUT 2
11 | Sortie | HSOUT 3
12 | Sortie fixe | LED Réussite/Échec
13 | Sortie fixe | LED Erreur

CIO-1400

Remarque : Lorsqu'elles sont connectées au module d'E/S CIO-1400, les lignes IN 1, IN 2, IN 3, HS OUT 2 et HS OUT 3 du système de vision ne sont pas prises en charge.
Entrée | Nom
1 | Ligne 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
Sortie | Nom
0 | HSOUT 0
1 | HSOUT 1
2 | Ligne 2
3 | Ligne 3
4 | Ligne 4
5 | Ligne 5
6 | Ligne 6
7 | Ligne 7
8 | LED Réussite/Échec
9 | LED Erreur


Commandes de la boîte de dialogue de détails de la sortie

  • Impulsion: lorsque cette case est cochée, la sortie est pulsée. Décochez la case pour une sortie continue. La sortie doit être pulsée lorsque le délai d'acquisition est supérieur à 0.

  • Durée de l'impulsion (ms) : durée d'une impulsion de sortie.

    Système de vision/capteur de vision | Durée minimale de l'impulsion | Durée maximale de l'impulsion | Durée de l'impulsion par défaut
    Sortie générale | Sortie rapide
    In-Sight Micro série 1000 (sauf 1402, 1412 et 1500) | 10 ms | 10 ms | 1000 ms | 10 ms
    In-Sight Micro 1402, 1412 et 1500 | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight série 2000 | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight série 5000 | 10 ms | 10 ms | 1000 ms | 10 ms
    In-Sight série 70xx - 74xx | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight série 76xx - 79xx | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight série 8000 | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight 9902L | 1 ms | 1 ms | 1000 ms | 10 ms
    In-Sight 9912 | 1 ms | 1 ms | 1000 ms | 10 ms
    Remarque :

    Remarque :

    • Lors de l'utilisation du module CIO-Micro ou d'E/S CIO-Micro-CC avec les systèmes de vision pris en charge, la durée minimale de l'impulsion pour les sorties générales est limitée par le paramètre Durée de mise à jour dans la boîte de dialogue Configuration du module d'E/S. Par exemple, si le paramètre Durée de mise à jour est de 20 ms, la durée minimale d'impulsion ne peut pas être configurée en dessous de 30 ms. Pour plus d'informations, reportez-vous à la boîte de dialogue Configuration du module d'E/S.
    • Pour les systèmes de vision In-Sight séries 76xx - 79xx et 8000, la durée minimale d'impulsion de 1 ms est uniquement prise en charge si vous utilisez le micrologiciel In-Sight version 5.5.0 et les versions ultérieures. Si vous utilisez une version précédente du micrologiciel, la durée minimale d'impulsion est de 10 ms.

  • Délai d'acquisition (N): le nombre d'impulsions d'acquisition ou de suivi (0 à 1000) Pour retarder la sortie après la réception d'une impulsion de signal par une ligne de sortie. Si Délai d'acquisition = 0, le système de vision In-Sight met immédiatement à jour la ligne de sortie lors de l'évaluation du projet EasyBuilder. Si Délai d'acquisition est supérieur à 0, la ligne de sortie est toujours pulsée.

    Remarque : les options Délai d'acquisition et Durée après le déclenchement ne peuvent pas être utilisées simultanément ; elles doivent être utilisées individuellement, c'est-à-dire que si Délai d'acquisition est activé, la durée après le déclenchement est désactivé et vice versa.

  • Durée après le déclenchement (ms) : lorsque cette case est cochée, la sortie est déclenchée après la durée spécifiée (0 à 10 000 ms).

    Remarque : les options Délai d'acquisition et Durée après le déclenchement ne peuvent pas être utilisées simultanément ; elles doivent être utilisées individuellement, c'est-à-dire que si Délai d'acquisition est activé, la durée après le déclenchement est désactivé et vice versa.

  • Déclencheur stroboscopique/contrôle de la lumière: le front montant ou descendant du signal peut être utilisé pour déclencher une unité stroboscopique ou un contrôle d'éclairage.
    • Configuration PNP : S'il est défini sur front montant le signal est ÉLEVÉ lorsque le capteur d'image est exposé, sinon le signal est FAIBLE. S'il est défini sur front descendant le signal est FAIBLE lorsque le capteur d'image est exposé, sinon le signal est ÉLEVÉ. Toujours pulsé pendant la durée de l'exposition. Le temps d'Exposition doit être supérieur de 0,50 ms à la durée de pulsation de l'unité stroboscopique spécifiée dans l'appareil d'éclairage externe.

    • Configuration PNP : S'il est défini sur front montant le signal est FAIBLE lorsque le capteur d'image est exposé, sinon le signal est ÉLEVÉ. S'il est défini sur front descendant le signal est ÉLEVÉ lorsque le capteur d'image est exposé, sinon le signal est FAIBLE. Toujours pulsé pendant la durée de l'exposition. Le temps d'Exposition doit être supérieur de 0,50 ms à la durée de pulsation de l'unité stroboscopique spécifiée dans l'appareil d'éclairage externe.

      Remarque :

      Remarque :

      • Pour les systèmes de vision In-Sight 5600, 5705, 5705C, 5715 et 9902L, le comportement du stroboscope est inversé (c'est-à-dire que pour un câblage NPN, le Front montant et le Front descendant se comportent comme dans le cadre d'une configuration PNP).
      • Si vous utilisez un stroboscope avec le système de vision à balayage de ligne In-Sight 9902L :
        • La configuration de câblage du stroboscope doit être PNP et le déclencheur Stroboscopique/Contrôle de la lumière doit être défini sur Front montant.
        • Lorsque le système de vision reçoit un déclencheur d'acquisition, la ligne de sortie émet une impulsion et le stroboscope clignote pendant la durée définie par Durée d'exposition. Une fois l'exposition terminée, le prochain déclencheur d'acquisition ne pourra démarrer avant un délai de 100 µs sous peine d'altérer le fonctionnement du stroboscope.
  • Position de départ de l'unité stroboscopique : Indique quand l'unité stroboscopique doit émettre des impulsions. Cette option n'est pas prise en charge pour le système de vision In-Sight 9902L.
    • Début d'acquisition : Spécifie que l'unité stroboscopique sera pulsée dès que le système de vision In-Sight commencera son acquisition. Pris en charge sur tous les modèles de système de vision sauf In-Sight 8405.
    • Déclenchement de la caméra : Spécifie que l'unité stroboscopique va pulser à la réception d'un événement de déclenchement de la caméra. Pris en charge sur tous les modèles de système de vision sauf In-Sight 8405.

    • Toutes les lignes exposées : Spécifie que l'unité stroboscopique va pulser uniquement quand toutes les lignes de pixels sont exposées. Pris en charge uniquement sur le système de vision In-Sight 8405.

      Remarque : En cas d'utilisation d'une unité stroboscopique avec In-Sight 8405, une exposition minimale de 72 ms est conseillée pour une capture d'image complète, afin de garantir l'exposition de toutes les lignes de pixels quand l'unité stroboscopique est pulsée.

  • LED tricolore : configure le comportement des lignes à LED tricolores. (Désactivé/vert, Désactivé/rouge, Rouge/vert ; par défaut = Désactivé/vert) Cette option est uniquement disponible si la ligne prend en charge les LED tricolores.

    Remarque : Cette option est prise en charge par les systèmes de vision In-Sight série 76xx - 79xx et In-Sight série 9000 pour les LED Réussite/Échec, mais elle n'est pas disponible si Cellule de projet réussite/échec est le Type de signal sélectionné.


Entrées : Chargement d'un fichier de projet

Capteurs de vision In-Sight série 2000

Afin d'utiliser cette fonction, au moins un projet doit être enregistré dans le capteur et le projet doit être enregistré avec un préfixe numérique de 0 à 31 au format #nomduprojet.job (par exemple 2InspectionAiguille.job).

  1. Sélectionnez la ligne d'entrée 0 et définissez Type de signal sur Changement de programme (train d'impulsions).

  2. Pour charger 2InspectionAiguille.job sur le capteur, un périphérique externe (tel qu'un PLC) émet une série d'impulsions vers le capteur In-Sight 2000.

    Type d'impulsion | Durée d'impulsion
    Impulsion de départ | 20 ms (±2 ms)
    Impulsion de décompte | 10 ms (±1 ms)
    Écart d'impulsion | 10 ms (±1 ms)
    Impulsion de fin | 20 ms (±2 ms)
    1. Le périphérique externe émet une impulsion de départ suivie d'un écart d'impulsion.
    2. Le périphérique externe émet alors trois impulsions de décompte. Se trouve alors un écart d'impulsion entre chaque impulsion de décompte et un autre après la dernière impulsion de décompte. Le nombre d'impulsions de décompte émises doit correspondre au préfixe numérique du projet à charger (par exemple, deux impulsions de décompte sont nécessaires pour charger 2PinInspection.job).
    3. Le périphérique externe émet une impulsion de fin. Lorsque toutes les impulsions et les écarts d'impulsion correspondent à la longueur d'impulsion spécifiée, la demande de changement de programme aboutit et 2InspectionAiguille.job est chargé vers le capteur. Si l'une des conditions vient à manquer (c'est-à-dire une mauvaise incorrecte ou un mauvais délai d'écart d'impulsion), la demande de changement de programme échoue et aucun changement de programme n'a lieu.
    Remarque :
    • La commande en mode natif SetSystemConfig("PulseJobChangeTiming") peut être utilisée pour configurer les largeurs de l'impulsion de démarrage, de l'impulsion de comptage, de l'écart entre les impulsions et de l'impulsion d'arrêt.
    • Il est possible de configurer une ligne de sortie discrète comme un type de Chargement du projet terminé ou Chargement du projet échoué pour impulser la sortie et signaler le succès ou l'échec de la demande de changement de programme. Si les longueurs d'impulsions d'entrée spécifiées ne sont pas utilisées, la sortie ne sera pas impulsée pour indiquer un échec de chargement de projet.

Systèmes de vision In-Sight

Pour pouvoir utiliser cette fonctionnalité, au moins un projet doit être enregistré et les projets à charger doivent être enregistrés avec un préfixe numérique de 0 à 127, par exemple 1InspectionAiguille.job.

  1. Sélectionnez une ligne d'entrée à configurer, puis définissez le Type de signal sur Chargement de projet. Le fichier de projet qui est chargé est indiqué par l'état (0 ou 1) de toute autre ligne d'entrée définie sur Numéro du projet.
  2. Définissez au moins un autre Type de signal de ligne d'entrée sur Numéro du projet.
  3. Une entrée définie sur Numéro du projet représente un bit d'un nombre binaire. Les entrées des lignes suivantes définies sur Numéro du projet représentent les bits supplémentaires du nombre binaire. Le nombre binaire complet représente le préfixe numérique (n° décimal) d'un fichier de projet enregistré au format suivant : #nomduprojet.job.

Exemple 1

Trois entrées discrètes sont définies sur Numéro du projet, ce qui représente un nombre binaire à 3 bits. Lorsque les états des trois entrées sont respectivement 0,1 et 0, le nombre binaire 010 indique qu'un fichier de projet ayant le préfixe 2 (010 en décimal) doit être chargé.

Exemple 2

Vous avez trois fichiers de projet différents nommés 3inspection.job, 6inspection.job et 9inspection.job. Vous voulez indiquer que le fichier .job nommé 6inspection.job doit être chargé lorsque le capteur reçoit un signal HAUT d'un PLC. L'entrée discrète 1 est actuellement utilisée comme déclencheur d'acquisition d'image.

  1. Connectez la ligne d'entrée 1 au PLC.
  2. Définissez le Type de signal de la ligne d'entrée 1 sur Interrupteur de chargement de tâche.
  3. Comme le préfixe des noms de fichier de projet va de 3 à 9, vous devez définir 4 entrées sur Numéro du projet. (9 correspond à 1001 en binaire).

  4. Lorsque les états des lignes Numéro du projet sont respectivement 1, 1, 0 et 0 (6 correspond à 1100 en binaire) et l'état de la ligne d'entrée 2 est HAUT (1), le projet nommé 6inspection.job est chargé.

    Remarque : Si plusieurs projets ayant le même préfixe numérique sont stockés dans le capteur In-Sight, le fichier comportant l'ordre alphanumérique le plus élevé sera chargé.


Entrées : Activation et désactivation des outils de recherche et d'inspection

Les outils de recherche et d'inspection peuvent être associés à une ligne d'entrée. L'association de l'outil à une entrée permet à un système de contrôle, un PLC par exemple, de déterminer quels outils doivent s'exécuter.

  1. Sélectionnez une ligne d'entrée, puis définissez le Type de signal sur Données utilisateur.
  2. Accédez à l'outil de recherche ou d'inspection que vous souhaitez contrôler et accédez au contrôle Activation de l'outil de l'outil. Dans la liste déroulante, sélectionnez le numéro d'entrée que vous avez défini dans l'étape ci-dessus.
  3. L'outil peut alors être activé ou désactivé (un signal élevé 1 signifie activé, un signal faible 0 signifie désactivé) par le système de contrôle.


Entrées : Déclenchement de l'acquisition d'image

Pour configurer votre système de vision In-Sight afin de recevoir un déclencheur d'acquisition par l'intermédiaire d'une ligne d'entrée d'un PLC, d'un capteur Photo Eye ou d'un autre périphérique, appliquez la procédure suivante.

  1. Cliquez sur l'étape Configurer l'image.

  2. Dans la zone de groupe Modifier les paramètres d'acquisition, sélectionnez Externe dans le menu déroulant Déclencheur.

    Remarque :
    • Le déclencheur externe n'est pas pris en charge par le capteur de vision In-Sight série 2000.
    • Il est possible d'obtenir des fréquences de déclenchement plus rapides en utilisant l'entrée intégrée du déclencheur d'acquisition du système de vision (en définissant le paramètre Déclencheur de la fonction AcquireImage sur Caméra) plutôt que de déclencher les événements du système de vision avec une ligne d'entrée générale configurée en tant que Déclencheur d'acquisition (en définissant le paramètre Déclencheur de la fonction AcquireImage sur Externe).
    • Si le paramètre Déclencheur de la fonction AcquireImage est défini sur Externe et qu'une acquisition échoue, la sortie ERR : Échec de l'acquisition n'est pas émise du système de vision. Le signal ERR : Acquisition manquée est uniquement pris en charge lorsque le paramètre Déclencheur de la fonction AcquireImage est défini sur Caméra.
  3. Revenez à l'étape Entrées/Sorties.

  4. Sélectionnez une ligne d'entrée, puis définissez le Type de signal sur Déclencheur d'acquisition.

    Remarque : Déclencheur d'acquisition n'est pas pris en charge sur le module d'E/S CIO-1400.
  5. Définissez le Type de transition du signal sur Front montant ou Front descendant.
  6. Raccordez les fils de votre périphérique d'entrée à l'entrée du déclencheur, sur un câble breakout ou module d'E/S du système de vision In-Sight. Consultez le manuel d'installation du système de vision In-Sight ou du module d'E/S concerné pour plus d'informations.


Entrées : apprentissage d'un modèle de forme sur une ligne d'entrée

Pour configurer votre système de vision In-Sight afin d'apprendre un modèle de forme sur une ligne d'entrée, d'un capteur appliquez la procédure suivante.

  1. Dans l'outil de recherche de modèle et de modèles (1 - 10), l'outil de présence/absence de modèle ou l'outil de comptage de modèles, sélectionnez une ligne d'entrée à utiliser comme signal d'apprentissage dans la liste déroulante Apprendre entrée.

    Remarque : Lorsqu'un système de vision In-Sight ou à un capteur de vision In-Sight 2000-23M est connecté, la liste déroulante Apprendre entrée se trouve dans l'onglet Paramètres.
  2. Revenez à l'étape d'application Entrées/Sorties.
  3. Définissez le type de signal de la ligne d'entrée sélectionnée sur Déclencheur d'événement.
  4. Définissez le type de transition du signal sur Front montant, Front descendant ou Les deux fronts.

  5. Mettez le système/capteur de vision In-Sight en ligne.

    Remarque : L'apprentissage d'un modèle de forme utilise l'image la plus récente acquise par le système de vision/capteur. Il n'est pas nécessaire de redéclencher le système/capteur de vision pour effectuer l'apprentissage.

  6. Le ou les fronts du type de transition sélectionné vont déclencher un apprentissage du modèle de forme.


Sorties : Signalement de l'échec d'une acquisition d'image

Pour signaler l'échec d'une acquisition d'image :

  1. Cliquez sur l'étape Configurer l'image.
  2. Dans la zone de groupe Modifier les paramètres d'acquisition, sélectionnez Caméra dans le menu déroulant Déclencheur.
  3. Revenez à l'étape Entrées/Sorties.
  4. Sélectionnez une ligne de sortie, puis définissez le Type de signal sur Fin d'acquisition. Spécifiez la longueur de l'impulsion en appuyant sur le bouton Détails.
  5. Sélectionnez une autre ligne de sortie, puis définissez le Type de signal sur ERR : Échec de l'acquisition. Cette action indique que le déclenchement d'une acquisition a été reçu avant l'envoi d'un signal Fin d'acquisition, ou qu'aucune mémoire tampon d'image n'était disponible pour l'acquisition des images lorsqu'un déclenchement d'acquisition a été reçu.
  6. Spécifiez la longueur de l'impulsion en appuyant sur le bouton Détails.


Sorties : Déclenchement d'un éclairage pour l'acquisition d'image

Fermé Déclenchement d'une unité stroboscopique

Le front montant ou descendant du signal peut être utilisé pour déclencher une unité stroboscopique.

Pour envoyer un signal de déclenchement d'une unité stroboscopique :

  1. Définissez les paramètres de déclenchement de l'acquisition à l'étape Configurer l'image. Vérifiez que le temps d'exposition est supérieur de 0,50 ms à la durée de pulsation de l'unité stroboscopique spécifiée dans l'appareil d'éclairage externe.
  2. Définissez le Type de signal de la ligne de sortie sur Unité stroboscopique.
  3. Appuyez sur le bouton Détails et spécifiez si l'unité stroboscopique doit être déclenchée par le front montant ou le front descendant du signal.
    • Configuration PNP : S'il est défini sur front montant le signal est ÉLEVÉ lorsque le capteur d'image est exposé, sinon le signal est FAIBLE. S'il est défini sur front descendant le signal est FAIBLE lorsque le capteur d'image est exposé, sinon le signal est ÉLEVÉ. Toujours pulsé pendant la durée de l'exposition. Le temps d'Exposition doit être supérieur de 0,50 ms à la durée de pulsation de l'unité stroboscopique spécifiée dans l'appareil d'éclairage externe.

    • Configuration PNP : S'il est défini sur front montant le signal est FAIBLE lorsque le capteur d'image est exposé, sinon le signal est ÉLEVÉ. S'il est défini sur front descendant le signal est ÉLEVÉ lorsque le capteur d'image est exposé, sinon le signal est FAIBLE. Toujours pulsé pendant la durée de l'exposition. Le temps d'Exposition doit être supérieur de 0,50 ms à la durée de pulsation de l'unité stroboscopique spécifiée dans l'appareil d'éclairage externe.

      Remarque :
      • Pour les systèmes de vision In-Sight 5600, 5705, 5705C, 5715 et 9902L, le comportement du stroboscope est inversé (c'est-à-dire que pour un câblage NPN, le Front montant et le Front descendant se comportent comme dans le cadre d'une configuration PNP).
      • Si vous utilisez un stroboscope avec le système de vision à balayage de ligne In-Sight 9902L :
        • La configuration de câblage du stroboscope doit être PNP et le déclencheur Stroboscopique/Contrôle de la lumière doit être défini sur Front montant.
        • Lorsque le système de vision reçoit un déclencheur d'acquisition, la ligne de sortie émet une impulsion et le stroboscope clignote pendant la durée définie par Durée d'exposition. Une fois l'exposition terminée, le prochain déclencheur d'acquisition ne pourra démarrer avant un délai de 100 µs sous peine d'altérer le fonctionnement du stroboscope.
  4. Indiquez la Position de départ de l'unité stroboscopique. Cette option n'est pas prise en charge pour le système de vision In-Sight 9902L.
    • Début d'acquisition : Spécifie que l'unité stroboscopique sera pulsée dès que le système de vision In-Sight commencera son acquisition. Pris en charge sur tous les modèles de système de vision sauf In-Sight 8405.
    • Déclenchement de la caméra : Spécifie que l'unité stroboscopique va pulser à la réception d'un événement de déclenchement de la caméra. Pris en charge sur tous les modèles de système de vision sauf In-Sight 8405.

    • Toutes les lignes exposées : Spécifie que l'unité stroboscopique va pulser uniquement quand toutes les lignes de pixels sont exposées. Pris en charge uniquement sur le système de vision In-Sight 8405.

      Remarque :
      • Le système de vision In-Sight et l'appareil d'éclairage doivent être reliés à la même masse pour que l'appareil d'éclairage fonctionne correctement.
      • Les systèmes de vision In-Sight Micro 1000, In-Sight Micro 5000 (à l'exception du 5604), In-Sight séries 76xx - 79xx, In-Sight 8000 et In-Sight 9000 prennent en charge les signaux de type stroboscopique sur la ligne HSOUT 1.
      • Le système de vision In-Sight séries 70xx - 74xx prend en charge un signal de type Stroboscopique sur la ligne HSOUT 0.
      • Pour le système de vision In-Sight 8405, la position de départ de l'unité stroboscopique est fixée sur Toutes les lignes exposées et le signal de sortie est pulsé uniquement pendant la durée où toutes les lignes de pixels sont exposées. En cas d'utilisation d'une unité stroboscopique avec In-Sight 8405, une exposition minimale de 72 ms est conseillée pour une capture d'image complète, afin de garantir l'exposition de toutes les lignes de pixels quand l'unité stroboscopique est pulsée.
Fermé Déclenchement d'un éclairage externe (CIO-1460 uniquement)

Le front montant ou descendant du signal peut être utilisé pour déclencher un éclairage externe.

Pour envoyer un signal de déclenchement d'éclairage externe :

  1. Connectez-vous à un système de vision In-Sight série 5000 et à un module d'E/S CIO-1460.
  2. Définissez les paramètres de déclenchement de l'acquisition à l'étape Configurer l'image. Vérifiez que le temps d'exposition est supérieur de 0,50 ms à la durée de pulsation de l'unité stroboscopique spécifiée dans l'appareil d'éclairage externe.
  3. Définissez le Type de signal pour HSOUT 1 sur Contrôle de l'éclairage.

  4. Appuyez sur le bouton Détails et spécifiez si l'unité stroboscopique doit être déclenchée par le front montant ou le front descendant du signal.

    Remarque :
    • Le système de vision In-Sight et l'appareil d'éclairage doivent être reliés à la même masse pour que l'appareil d'éclairage fonctionne correctement.
    • Ce type de sortie est uniquement valide pour la ligne de sortie 1 rapide (HSOUT 1) lors de la configuration du module d'E/S CIO-1460 du système de vision In-Sight série 5000.


Sorties : Définition d'une ligne sur le résultat d'un outil de recherche ou d'inspection

Pour envoyer un signal d'après le résultat d'un outil de recherche ou d'inspection :

  1. Sélectionnez une ligne de sortie, puis définissez le Type de signal sur Résultat du projet.
  2. Dans la liste déroulante Résultat du projet, sélectionnez le résultat d'un outil. Les résultats de l'outil répertoriés (par exemple Texte_1, Modèle_1, etc.) représentent le succès/échec global pour l'outil individuel. Les résultats du projet sont un succès/échec cumulé pour tous les outils. Le signal sera élevé (HIGH) (1) lorsque le résultat de l'outil sera un succès et faible (LOW) (0) lorsque le résultat sera un échec.
  3. Appuyez sur le bouton Détails pour spécifier la longueur de l'impulsion et le délai d'acquisition. Si ces paramètres ne sont pas spécifiés, le signal ne sera pas pulsé.


Communication

L'étape Communication permet de définir les résultats d'inspection pour partager les données sur un serveur OPC, de configurer un élément EasyView pour le panneau d'interface de l'opérateur VisionView®, en exportant des images via FTP ou sur la carte SD, et de configurer le réseau et les paramètres de communication série des systèmes de vision In-Sight afin qu'ils puissent échanger des données avec d'autres périphériques, tels qu'un robot ou un automate programmable (PLC)/contrôleur de mouvement (MC).

Remarque :
  • Le capteur In-Sight doit être hors ligne pour activer l'étape Communication.
  • Les protocoles de communication de votre projet peuvent être configurés et enregistrés au moyen d'un émulateur, puis chargés sur un système de vision In-Sight pour l'exécution. Les protocoles ProfiNET et CC-Link, toutefois, peuvent être sélectionnés, mais pas simulés sur l'émulateur. Pour ces protocoles, les protocoles de communication du projet doivent être développés et enregistrés sur un système de vision In-Sight connecté au réseau ProfiNET ou CC-Link.

Protocoles pris en charge

Vous pouvez ajouter jusqu'à deux protocoles à un projet. Si vous ajoutez deux protocoles, vous pouvez ajouter un protocole « principal » et un protocole « secondaire ». Par exemple, après avoir ajouté le protocole de Scanner SLMP (principal), cliquez à nouveau sur le bouton Ajouter un périphérique et ajoutez le protocole TCP/IP (secondaire).

Remarque : vous ne pouvez pas ajouter deux protocoles « principaux » ni deux protocoles « secondaires » à un projet.

Micrologiciel In-Sight 4.x.x

 | Principal ou Secondaire | Micro série 1000 | Série 5000 (sauf 5705 & 5705C) | Série 70xx - 74xx
CC-Link | Principal | X | X | X
Ethernet natif | Principal | X | X | X
Robot Ethernet natif | Principal | X | X | X
Chaîne Ethernet natif | Principal | X | X | X
EtherNet/IP | Principal | X | X | X
Serveur ModBus TCP | Principal | X | X | X
POWERLINK | Principal |  |  | X
PROFINET | Principal | X | X | X
Kuka série | Principal | X | X | X
Motoman série | Principal | X | X | X
Natif série | Principal | X | X | X
Robot en mode natif série | Principal | X | X | X
Chaîne en mode natif série | Principal | X | X | X
Texte série | Principal | X | X | X
SLMP | Principal | X | X | X
Scanner SLMP | Principal | X | X | X
TCP/IP | Secondaire | X | X | X
UDP | Secondaire | X | X | X

Micrologiciel In-Sight 5.x.x

 | Principal ou Secondaire | Série 2000 | 5705 et 5705C | Série 7000 Gen2 | Série 8000 | Série 9000
CC-Link IE Field Basic | Principal | X | X | X | X | X
Ethernet natif | Principal |  | X | X | X | X
Robot Ethernet natif | Principal |  | X | X | X | X
Chaîne Ethernet natif | Principal |  | X | X | X | X
EtherNet/IP | Principal | X | X | X | X | X
Serveur ModBus TCP | Principal | X | X | X | X | X
PROFINET | Principal | X | X | X | X | X
Kuka série | Principal |  | X | X | X | X
Motoman série | Principal |  | X | X | X | X
Natif série | Principal | X (Basic) | X | X | X | X
Robot en mode natif série | Principal |  | X | X | X | X
Chaîne en mode natif série | Principal |  | X | X | X | X
Texte série | Principal | X | X | X | X | X
SLMP | Principal | X | X | X | X | X
Scanner SLMP | Principal | X | X | X | X | X
TCP/IP | Secondaire | X | X | X | X | X
UDP | Secondaire | X | X | X | X | X

Partage de données via le serveur OPC

Configuration d’un élément EasyView

Exportation des images via FTP

Exportation d’un fichier de données ou ajout d’une chaîne de données à un fichier via FTP

Exportation d’images sur une carte SD

Exportation d’un fichier de données ou ajout d’une chaîne de données à un fichier sur une carte SD

Configuration du périphérique

Communications avec des PLC Rockwell ControlLogix

Intégration avec Universal Robots – TCP/IP


Partage de données via le serveur OPC

Si votre application comprend d’autres périphériques qui utilisent un serveur OPC pour communiquer, vous pouvez activer la transmission des résultats d’inspection (ou des données d’entrées) vers un serveur In-Sight OPC UA ou vers un serveur In-Sight OPC classique.

Les serveurs OPC UA In-Sight et OPC In-Sight classique sont pris en charge sur les modèles suivants.

Système/capteur de vision | Prise en charge du serveur OPC UA In-Sight | Prise en charge du serveur OPC In-Sight classique
In-Sight Micro série 1000 | Non pris en charge | Firmware 4.x.x
In-Sight série 2000 | Firmware 5.8.0 et versions ultérieures | Non pris en charge
In-Sight 5400 et série 5600 | Non pris en charge | Firmware 4.x.x
In-Sight 5705 et 5705C | Non pris en charge | firmware 5.x.x
In-Sight série 7000 | Non pris en charge | Firmware 4.x.x
In-Sight série 7000 Gen2 | Firmware 5.8.0 et versions ultérieures | firmware 5.x.x
In-Sight série 8000 | Firmware 5.8.0 et versions ultérieures | firmware 5.x.x
In-Sight série 9000 | Firmware 5.8.0 et versions ultérieures | firmware 5.x.x
Émulateurs | Non pris en charge | Pris en charge

Balises OPC

Ajout de balises OPC à un fichier de projet

OPC UA


Balises OPC

Une balise OPC est un nom symbolique applicable aux résultats d’inspection EasyBuilder d’un système/capteur de vision In-Sight pris en charge. La balise OPC est visible par les clients OPC UA pour leur permettre d’accéder aux données du projet In-Sight. Dans le cadre de l’implémentation d’OPC UA d’In-Sight, il existe deux types de balises OPC : les balises projet et les balises système.

Une balise OPC peut représenter les types de données suivants :

  • Boolean : représente des balises qui ne contiennent que des valeurs booléennes.
  • Virgule flottante : représente des balises qui ne contiennent que des valeurs à virgule flottante.
  • Entier : représente des balises qui ne contiennent que des valeurs entières.

  • Chaîne de caractères : représente des balises qui ne contiennent que des chaînes de texte.

    Remarque :
    • La taille maximale des chaînes de texte est de 256 caractères.
    • Les chaînes de texte sont envoyées au client OPC au format Unicode.

L’accessibilité des balises OPC est gérée par les niveaux d’accès Lecture ou Lecture/Écriture. La capacité des clients OPC UA à lire ou à écrire des données dans le fichier de projet In-Sight dépend du niveau d’accès de la balise OPC.

  • Lecture : le client OPC UA peut uniquement accéder aux valeurs contenues dans les balises.
  • Lecture/Écriture : le client OPC UA peut lire ou modifier les valeurs contenues dans les balises.


Ajout de balises OPC à un fichier de projet

Bien que chaque système/capteur de vision In-Sight compatible OPC UA dispose de balises système prédéfinies pour les clients OPC UA, ces balises ne permettent probablement pas d’afficher toutes les options auxquelles vous voulez accéder depuis le client OPC UA. Pour cette raison, vous pouvez ajouter une balise de projet aux résultats d’inspection et de projet EasyBuilder pour les rendre accessibles par le client.

  1. Dans la zone de groupe Communications, sélectionnez OPC.
  2. Dans la section Balises OPC sélectionnées, appuyez sur le bouton Ajouter pour lancer la boîte de dialogue Sélectionner les balises OPC.
  3. La boîte de dialogue Sélectionner les balises OPC contient les données de tous les outils de recherche ou d’inspection ajoutés à votre projet, ainsi que les résultats du projet global. Dans cette boîte de dialogue, sélectionnez les données que vous désirez activer.
  4. Après sélection des données voulues, cliquez sur le bouton OK pour accepter vos modifications. Les balises OPC sont désormais affichées dans la section Balises OPC sélectionnées.
  5. Configurez le serveur OPC.
    • Si vous utilisez le serveur OPC UA, consultez OPC UA.
    • Si vous utilisez le serveur OPC classique, reportez-vous à l'aide du serveur In-Sight® classique.


OPC UA

OPC UA (Open Platform Communications – Unified Architecture) est un protocole de communication moderne, développé par l’OPC Foundation, proposant une architecture ouverte, sécurisée et indépendante de la plateforme aux périphériques et systèmes industriels. Pour In-Sight, le système de vision ou le capteur de vision tient lieu de serveur OPC UA et peut communiquer directement avec un client OPC UA, sans avoir besoin d’un matériel supplémentaire.

Les serveurs OPC UA In-Sight et OPC In-Sight classique sont pris en charge sur les modèles suivants. Pour plus d'informations sur le serveur OPC In-Sight classique, reportez-vous à l'aide du serveur OPC In-Sight® classique.

Système/capteur de vision | Prise en charge du serveur OPC UA In-Sight | Prise en charge du serveur OPC In-Sight classique
In-Sight Micro série 1000 | Non pris en charge | Firmware 4.x.x
In-Sight série 2000 | Firmware 5.8.0 et versions ultérieures | Non pris en charge
In-Sight 5400 et série 5600 | Non pris en charge | Firmware 4.x.x
In-Sight 5705 et 5705C | Non pris en charge | firmware 5.x.x
In-Sight série 7000 | Non pris en charge | Firmware 4.x.x
In-Sight série 7000 Gen2 | Firmware 5.8.0 et versions ultérieures | firmware 5.x.x
In-Sight série 8000 | Firmware 5.8.0 et versions ultérieures | firmware 5.x.x
In-Sight série 9000 | Firmware 5.8.0 et versions ultérieures | firmware 5.x.x
Émulateurs | Non pris en charge | Pris en charge

Le client OPC UA peut accéder aux données suivantes des systèmes/capteurs de vision In-Sight :

  • Nombre d’acquisitions
  • Nom du projet actif
  • État En ligne (notamment NativeOnline, DiscreteOnline et GUIOnline)
  • État du mode vidéo directe

Outre la récupération des données, le serveur OPC UA In-Sight permet aux clients OPC UA de réaliser les opérations suivantes :

  • Enregistrer le projet actif
  • Charger un projet
  • Déclencher des événements d’acquisition
  • Basculer en mode en ligne
  • Basculer en mode vidéo directe
Remarque : Il incombe au concepteur de l’application de limiter l’accès aux balises exposées du serveur, telles que l’écriture d’un nouveau fichier projet, l’écriture dans une cellule ou le changement d’état En ligne/Hors ligne d’un système/capteur de vision.

De plus, vous pouvez configurer le client OPC pour surveiller les modifications des valeurs des nœuds AddressSpace (ou « éléments surveillés »). Plutôt que de scruter constamment des modifications de ces valeurs, vous pouvez créer des abonnements aux nœuds afin de surveiller ces éléments. Lorsqu’un changement est détecté, une notification est générée et transférée au client OPC UA par le canal d’abonnement. Le nombre de sessions, de clients et de nœuds pris en charge pour les éléments surveillés dépend du système/capteur de vision :

Système/capteur de vision | Nombre de sessions/clients | Nœuds AddressSpace
In-Sight série 2000 | Une session sur un client OPC UA. | 50 nœuds entre 20 abonnements par session/client.
In-Sight série 7000 Gen2 | Deux sessions entre deux clients OPC UA. | 250 nœuds entre 20 abonnements par session/client.
In-Sight série 8000 | Deux sessions entre deux clients OPC UA. | 250 nœuds entre 20 abonnements par session/client.
In-Sight série 9000 | Deux sessions entre deux clients OPC UA. | 250 nœuds entre 20 abonnements par session/client.

Activer le serveur OPC UA

Balises projet et système OPC UA

Méthodes OPC UA

SetSystemConfig : OPC UA Time Sync

Étapes de dépannage


Activer le serveur OPC UA

Si vous utilisez OPC UA, vous devez d’abord activer le serveur In-Sight OPC UA sur le système/capteur de vision, puis vous y connecter à partir du client OPC UA.

Astuce : Si vous avez besoin de configurer l’heure pour l’horodatage des balises OPC UA, utilisez la commande en mode natif étendu SetSystemConfig OPCUA.TimeSync avant d’activer le serveur OPC UA. Pour plus d’informations, consultez SetSystemConfig : OPC UA Time Sync.
  1. Dans la zone de groupe Communications, sélectionnez OPC.

  2. Activez la case à cocher Activer le serveur OPC UA.

  3. Cliquez sur OK.
  4. Lorsque vous y êtes invité, cliquez sur Oui pour redémarrer le système/capteur de vision. Une fois redémarré, le serveur OPC UA est initialisé et s’exécute, et le point de terminaison de découverte est à l’écoute des requêtes du client OPC UA.
  5. Lancez le client OPC UA.

  6. Depuis le client OPC UA, entrez l’URL du point de terminaison pour vous connecter au serveur OPC UA. L’URL du point de terminaison doit être au format suivant, où <Adresse IP> est l’adresse IP du système/capteur de vision :

    opc.tcp://<Adresse IP>:4840

    Par exemple : opc.tcp://192.168.0.8:4840


Balises projet et système OPC UA

Les balises projet représentent une valeur enregistrée dans le fichier de projet In-Sight et qui est visible pour les clients OPC UA. Ces balises sont configurables par l’utilisateur. Les balises projet sont enregistrées dans le fichier projet.

Les balises système sont toujours disponibles sur tout système/capteur de vision prenant en charge le serveur OPC UA, et peuvent être ajoutées à votre configuration. Ces balises sont des balises par défaut. Les balises système ne sont pas enregistrées dans le fichier de projet.

Balise système

Accessibilité

Type de données

Description

AcquisitionCount

Lecture seule

Entier

Renvoie le nombre d’acquisitions depuis la mise en route du système/capteur de vision.

DiscreteOnline

Lecture seule

Boolean

Renvoie Faux si une ligne d’entrée discrète (configurée avec un type En ligne/Hors ligne) est définie sur le niveau bas (0). Dans le cas contraire, la valeur renvoyée est Vrai.

GuiOnline

Lecture seule

Boolean

Renvoie Vrai si l’interface graphique In-Sight Explorer est réglée sur le mode En ligne (Menu Capteur > En ligne).

JobName

Lecture seule

Chaîne

Renvoie le nom du projet actif chargé dans le système/capteur de vision, si le travail actif a été enregistré.

Remarque : La balise JobName étant en lecture seule, utilisez la méthode SaveJobAs pour renommer le fichier de projet. Pour plus d’informations, consultez Méthodes OPC UA.

LiveMode

Lecture/Écriture

Boolean
  • Lecture : renvoie Vrai si le système/capteur est en mode Vidéo directe. Dans le cas contraire, la valeur renvoyée est Faux.
  • Écriture : l'écriture de toute valeur non nulle dans la balise LiveMode place le système/capteur de vision en mode Vidéo directe. L’écriture de zéro dans la balise LiveMode permet de quitter le mode Vidéo directe.
Remarque : Si l’Affichage du projet d’un système/capteur de vision est ouvert dans In‑Sight Explorer après l’écriture de Vrai dans la balise LiveMode, In‑Sight Explorer n’affiche pas l’image en direct et la barre d’état de la fenêtre Affichage du projet n’indique pas le mode Vidéo directe.

NativeOnline

Lecture/Écriture

Boolean
  • Lecture : renvoie Faux si la commande en ligne en mode natif « SO0 » a été envoyée au capteur/système de vision. Dans le cas contraire, la valeur renvoyée est Vrai.
  • Écriture : l’écriture de toute valeur non nulle dans la balise NativeOnline place le système/capteur de vision In-Sight hors ligne par le biais du mode natif (équivalent à l’envoi de la commande en ligne en mode natif « SO0 »). L’écriture de zéro dans la balise NativeOnline place le système/capteur de vision In-Sight en ligne (équivalent à l’envoi de la commande en ligne en mode natif « SO1 »).

En ligne

Lecture seule

Boolean

Renvoie le résultat d’un ET logique des balises suivantes : (DiscreteOnline ET NativeOnline ET GuiOnline).


Méthodes OPC UA

Les méthodes par défaut suivantes sont toujours disponibles sur tout système/capteur de vision compatible avec le serveur OPC UA et peuvent être ajoutées à votre configuration. Les méthodes ne sont pas enregistrées dans le fichier de projet.

Méthode

Accessibilité

Type de données

Description
LoadJob(nom de fichier) Lecture/Écriture Chaîne

Charge le nom du projet spécifié dans le système de vision.

Remarque :

  • Le projet spécifié doit exister sous forme de fichier sur le système/capteur de vision. Sinon, une erreur est renvoyée.

  • Si l’une ou l’autre des erreurs suivantes se produit lors du chargement de fichiers de projet volumineux, modifiez le délai d’attente par défaut pour correspondre au temps nécessaire au chargement de votre projet.
    • La méthode LoadJob présente un délai d’attente par défaut de 10 secondes. Si le délai d’attente par défaut est dépassé, l’erreur correspondante est affichée dans le client OPC UA. Le travail est chargé et les communications fonctionneront.
    • Le délai de surveillance de connexion est de 5 secondes par défaut. Lorsque le projet est en cours de chargement, le système/capteur de vision n’actualise pas le client OPC UA. Si cette situation persiste et que le délai d’attente par défaut est dépassé, une erreur relative à l’expiration du délai de surveillance de connexion s’affiche sur le client OPC UA. Une fois le projet chargé, la connexion est rétablie et les communications reprennent automatiquement.
SaveJobAs(nom de fichier) Lecture/Écriture Chaîne

Enregistre le fichier de projet actif avec le nom précisé par la chaîne en paramètre.

Remarque : Le système/capteur de vision doit être hors ligne pour pouvoir appeler la méthode SaveJobAs. Sinon, une erreur est renvoyée.
TriggerManualAcquisition Lecture/Écriture S. O.

Déclenche une acquisition manuelle pour le système/capteur de vision.
TriggerSoftEvent(index) Lecture/Écriture Entier

Active un déclencheur logiciel « Soft » sur le système de vision. Entrez une valeur entière « n » de 0 à 7 dans la cellule de la méthode TriggerSoftEvent pour activer le déclencheur logiciel « Soft n » correspondant dans la feuille de calcul.


SetSystemConfig : OPC UA Time Sync

Configure la synchronisation horaire des horodatages des balises OPC UA.

Remarque : Cette commande en mode natif étendu est prise en charge pour le capteur de vision In-Sight 2000.

Entrées

Syntax: EV SetSystemConfig("OPCUA.TimeSync",[TimeSyncFrequency],[InitialTimeoutSec],[TimeSyncFrequencySec],[WriteProcSet])

Paramètre

 Description

"OPCUA.TimeSync"

Fait référence aux paramètres de synchronisation d’OPC UA.

TimeSyncFrequency
  • 0 = La date et l’heure sont synchronisées une seule fois, au démarrage du système (par défaut).
  • 1 = La date/heure est synchronisée en permanence, à la fréquence indiquée par la valeur du paramètre TimeSyncFrequencySec. Ce réglage est recommandé pour une synchronisation de haute précision.
InitialTimeoutSec

Spécifie le temps d’attente du serveur OPC UA (en secondes) avant que le changement de date/heure n’entre en vigueur (par défaut = 15 secondes).

Remarque :
  • Le serveur OPC UA ne démarre pas tant que la durée spécifiée par InitialTimeoutSec n’est pas écoulée.
  • Si les paramètres Date/heure du système/capteur de vision ont été configurés manuellement et qu’un serveur SNTP ou tout autre équipement externe configuré pour le protocole PTP (Precision Time Protocol) est introuvable lors de la mise en route du système/capteur de vision, la date/heure initiale est réinitialisée au jeudi 1er janvier 1970, 12:00:00. Dans ce cas, augmentez la valeur du paramètre InitialTimeoutSec et, après la mise sous tension du système/capteur de vision, configurez manuellement les paramètres Date/heure.
TimeSyncFrequencySec

Spécifie la fréquence de synchronisation lorsque la valeur du paramètre TimeSyncFrequency est définie sur 1 (par défaut = 1 seconde).

WriteProcSet
  • 0 = Les réglages ne sont pas enregistrés dans le fichier proc.set. Les réglages ne sont pas conservés si le système/capteur de vision In-Sight est mis hors tension. (par défaut)
  • 1 = Les réglages sont enregistrés dans le fichier proc.set. Les réglages sont conservés si le système/capteur de vision In-Sight est mis hors tension.

Sorties

Renvoie un code d’état, suivi du nombre de caractères (en octets) des résultats, puis les résultats au format XML. Les codes d’état sont :

Codes d’état | Description
1 | La commande a été exécutée avec succès.
0 | La commande est inconnue.
-2 | La commande n’a pas pu être exécutée.
-6 | L’utilisateur ne dispose pas de l’accès complet nécessaire à l’exécution de la commande.


Étapes de dépannage

Problème Résolution

Si vous utilisez le client UaExpert, après quatorze à seize expirations de sessions de 30 secondes, le système de vision cesse de répondre aux demandes d’UC OPC et les clients UaExpert ne peuvent plus s’y connecter.

Lorsque cela se produit, les nouveaux clients et les clients dont le délai d’attente a expiré reçoivent l’erreur suivante lorsqu’ils tentent de se connecter :

"Error ’BadTimeout’ was returned during OpenSecureChannel" (Erreur : ’BadTimeout’ a été renvoyé durant OpenSecureChannel)

Remarque : Dans cet état, toutes les autres fonctions sont normales. Vous pouvez vérifier combien le nombre d’expirations de délai de session en utilisant la Vue de l’état du capteur dans In-Sight Explorer (Fenêtre > Afficher la Vue de l’état du capteur).

Pour UaExpert :

  • SecureChannelLifetime : Détermine la durée d’activité du canal. (Par défaut = une heure. Minimum = 5 minutes.)
  • SessionTimeout : Détermine le temps d’attente avant la déconnexion d’une session sans réponse. Remarquez que le canal sécurisé reste actif après expiration d’un délai d’attente. (Par défaut = 20 minutes. Minimum = 30 secondes.)
  1. Attendez une heure pour la réinitialisation de SecureChannelLifetime.
  2. Si SecureChannelLifetime est très long et que de nombreux délais d’expiration de sessions ont été dépassés durant cette période, redémarrez le système/capteur de vision.


Configuration d'un élément EasyView

Grâce à une application IHM, vous pouvez créer un élément EasyView afin de personnaliser l'affichage des données et de déterminer si les données peuvent être modifiées par l'opérateur. Créez d'abord l'élément EasyView dans EasyBuilder, puis enregistrez-le avec le projet du capteur. Puis, obtenez un aperçu de l'élément EasyView à l'aide de l'application VisionView PC Demo ou de l'application IHM Web pour vous assurer qu'il est correctement configuré.

Pour configurer un élément EasyView :

  1. Dans la zone de groupe Communications, sélectionnez EasyView.
  2. Dans la section Éléments EasyView sélectionnés, appuyez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les éléments EasyView.

  3. La boîte de dialogue Sélectionner les éléments EasyView contient les données de tous les outils de recherche ou d'inspection ajoutés à votre projet, ainsi que les paramètres d'acquisition et du projet. Dans la boîte de dialogue, sélectionnez les données appropriées de l'outil à inclure dans l'élément EasyView en mettant en surbrillance les éléments voulus, puis en appuyant sur le bouton Ajouter, ou bien en cochant la case EasyView de l'élément.

    Remarque :
    • Pour sélectionner plusieurs éléments non consécutifs, maintenez la touche CTRL enfoncée tout en sélectionnant les éléments.
    • Pour sélectionner plusieurs éléments consécutifs, maintenez la touche MAJ enfoncée, puis sélectionnez dans la liste le premier élément et le dernier.

  4. Après sélection des données de l'outil voulues, cliquez sur le bouton OK pour accepter vos modifications. Les données de l'outil sont désormais affichées dans la section Éléments EasyView sélectionnés.

    Remarque :
    • Pour sélectionner plusieurs éléments non consécutifs, maintenez la touche CTRL enfoncée tout en sélectionnant les éléments.
    • Pour sélectionner plusieurs éléments consécutifs, maintenez la touche MAJ enfoncée, puis sélectionnez dans la liste le premier élément et le dernier.

  5. Après avoir ajouté les données de l'outil, vous pouvez éventuellement cocher la case Modifiable pour permettre à l'opérateur de modifier les données de l'outil à partir de VisionView.

    Remarque : les données de l'outil doivent disposer d'autorisations de lecture-écriture pour pouvoir être modifiées depuis VisionView.
  6. Vous pouvez également sur le bouton Insérer une étiquette pour créer une étiquette d'en-tête. Les étiquettes sont utiles pour regrouper les données d'outil.
  7. La Légende correspond au nom qui s'affiche dans l'application IHM. Vous pouvez modifier la Légende par défaut en cliquant dans le champ Légende des données d'outil ou dans l'étiquette, puis en saisissant un nom descriptif. Appuyez sur la touche ENTRÉE ou cliquez en dehors du champ Légende pour appliquer la modification ; appuyez sur la touche ECHAP pour annuler la modification.
  8. Vous pouvez réorganiser l'ordre des données d'outil et/ou des étiquettes en les sélectionnant dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.

  9. Enregistrez le fichier de projet.

    Remarque : les paramètres EasyView sont aussi enregistrés automatiquement dans le capteur In-Sight à la fin de l'étape Communication.

  10. Pour avoir un aperçu de la manière dont l'élément EasyView sera affiché, ouvrez l'application VisionView PC Demo ou l'IHM Web.

    Remarque : si l'application VisionView PC Demo est installée sur votre PC, son répertoire d'installation par défaut est : C:/Program Files/Cognex/VisionView/PC Demo x.x.x. Si l'application VisionView PC Demo n'est pas installée sur votre PC, vous pouvez la télécharger depuis le site de support VisionView.
  11. Une fois que l'application VisionView PC Demo ou l'IHM Web est lancée, déconnectez-vous du capteur à l'étape Établir une connexion.

  12. Si vous utilisez l'IHM Web, vous pouvez obtenir un aperçu de l'élément EasyView dans le volet EasyView.

    Si vous utilisez l'application VisionView PC Demo, ajoutez votre capteur à la liste Capteurs sélectionnés, passez en mode exécution, puis cliquez sur le bouton Changer la vue pour afficher l'aperçu de l'élément EasyView.

    Remarque :
    • Pour obtenir un aperçu de l'élément EasyView, vous devez d'abord activer les options EasyView dans la boîte de dialogue Sélection de vue IHM.
    • l'application VisionView PC Demo comporte un délai d'attente automatique de 45 minutes. Pour acheter une version sous licence qui fournit des fonctionnalités complètes et sans délai d'attente, installez le logiciel VisionView PC, qui peut être téléchargé depuis le site de support VisionView.
    • L'aspect et la convivialité de l'application VisionView PC Demo sont légèrement différents de ceux du panneau d'interface opérateur VisionView.
    • Pour afficher un aperçu de l'élément EasyView en étant connecté à un émulateur, vous devez d'abord ajouter manuellement l'émulateur à la liste Capteurs sélectionnés dans l'application VisionView.


Exportation des images via FTP

Vous pouvez configurer votre système de vision In-Sight pour exporter des images sur un serveur FTP sur le réseau. Cela vous permet de stocker des images acquises (basées sur un outil ou une condition de succès/échec d'un projet) vers un autre périphérique à des fins d'archivage. Vous pouvez examiner ces images, ce qui vous aide à diagnostiquer les problèmes qui pourraient être survenus au cours du processus de production.

Pour configurer une connexion FTP :

  1. Dans la zone de groupe Communications, sélectionnez FTP.
  2. Sélectionnez l'onglet Image.

  3. Appuyez sur le bouton Ajouter pour ajouter une entrée et configurer les paramètres d'exportation d'images.

    Remarque : vous pouvez ajouter plus d'une opération d'exportation d'images à un projet.
  4. Sélectionnez l'onglet Paramètres et configurez les paramètres du serveur FTP.
  5. Mettez le système de vision In-Sight en ligne. Le système de vision doit être en ligne pour s'exécuter ; sinon, aucune image n'est exportée.
  6. Déclenchez le système de vision pour acquérir des images. Pour chaque image acquise, un fichier d'image (BMP ou JPG, selon le paramètre Format du fichier) est exporté et stocké sur l'hôte spécifié dans le paramètre Nom d'hôte.
Remarque :
  • Lorsque Condition du transfert est configurée sur Aucune (valeur par défaut), un fichier d'image est exporté chaque fois qu'une image est acquise. Lorsque Condition du transfert est configurée sur une autre valeur qu'Aucune, un fichier d'image est exporté chaque fois que l'événement spécifié se produit. Par exemple, lorsque Condition du transfert est configurée sur Projet.Échec, un fichier d'image est exporté et stocké sur le serveur FTP chaque fois que le projet échoue.
  • Lorsque vous utilisez l'émulateur In-Sight comme un serveur FTP, par défaut, les fichiers sont écrits dans le dossier de l'Émulateur ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x). En plus de ce répertoire, il est possible d'écrire des fichiers à un emplacement défini par l'utilisateur (Répertoire FTP autorisé). Pour plus d'informations sur le répertoire FTP autorisé, reportez-vous à la rubrique Boîte de dialogue Options (volet Émulation).

Onglet Image

Fournit les paramètres permettant de définir l'image exportée, son format, le moment où l'image est exportée et l'emplacement où elle est exportée.

Fermé Case cochée

Définit si l'opération d'exportation d'image est ou non opérationnelle (par défaut, la case est cochée), et si elle est exposée ou non comme un élément EasyView (par exemple, WriteImageFTP_1.Tool_Enabled), qui peut être affiché dans le panneau d'interface opérateur VisionView et qui est modifiable par l'opérateur.

Remarque : pour l'activer, cochez la case Activer dans le tableau. Il s'agit du seul paramètre que vous puissiez configurer dans le tableau.
Fermé Nom

Définit le nom de votre opération d'exportation d'image, qui peut être utilisé dans la configuration des résultats (Entrées/sorties et Communication) ; le nom par défaut est « WriteImageFtp_1 » (s'il s'agit de la première opération d'exportation d'image ajoutée au projet, sinon il est incrémenté, par exemple « WriteImageFtp_2 », « WriteImageFtp_3 », etc.). Personnalisez l'opération en lui donnant un nom, par exemple associé à sa condition de transfert.

Fermé Condition du transfert

Définit quand les données doivent être envoyées sur le serveur FTP, par exemple en cas de réussite ou d'échec d'un outil particulier ou lorsqu'une entrée est reçue. Par défaut, Aucun est sélectionné, ce qui assure que les données seront exportées à chaque acquisition d'image, si la case Activé est cochée. Si la case Activé n'est pas cochée ou si l'outil référencé est désactivé, l'opération d'exportation ne s'exécute pas.

Fermé Périphérique

Définit le serveur FTP configuré dans l'onglet Paramètres et qui recevra les données exportées. Par défaut, Périphérique 1 est sélectionné.

Fermé Format du fichier

Définit le format du fichier de l'image exportée : BMP (format bitmap Windows) ou JPG (format JPEG à encodage standard). L'option BMP est sélectionnée par défaut.

Fermé Taille de l'image

Définit la résolution de l'image exportée : Complet, Demi ou Quart. L'option Complet est sélectionnée par défaut.

Fermé Inclure les graphiques

Définit si un fichier SVG qui contient des données de graphiques superposés pour les outils de recherche et d'inspection sera créé ou non. Pour afficher le fichier SVG et un fichier d'image, ouvrez-le à l'aide d'un navigateur Web qui prend en charge le type de fichier SVG (par exemple Microsoft Internet Explorer 9.0). Le fichier SVG contient un lien interne vers l'image acquise qui lui est associée, et lorsque le navigateur ouvre le fichier SVG, il suit le lien pour ouvrir et afficher l'image acquise avec des graphiques superposés.

Remarque :
  • Pour l'activer, cochez la case Inclure les graphiques dans la zone de groupe de droite. Dans le tableau, la case Inclure les graphiques est en lecture seule.
  • Lorsqu'elle est cochée, le fichier SVG utilise le nom spécifié dans le paramètre Nom du fichier.
  • Lorsque le paramètre Nom d'hôte de l'onglet Paramètres est configuré sur un émulateur In-Sight, les fichiers SVG sont enregistrés dans le répertoire de l'émulateur ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x) et affichés dans le volet Fichiers In-Sight.
  • Si un outil de recherche et/ou d'inspection a été configuré pour masquer ses graphiques superposés en modifiant les Options d'outils dans la boîte de dialogue Options d'affichage des résultats, les graphiques SVG ne font pas l'objet d'une sortie. Par défaut, tous les outils affichent leurs graphiques superposés.
  • Comme les graphiques sont rendus par une application tierce, telle qu'un navigateur Web, les données des graphiques superposés ne correspondent pas au pixel près.
  • Le micrologiciel d'In-Sight ne garantit pas la transmission de toutes les paires de fichiers SVG et d'image. Si le système de vision In-Sight est surchargé, il peut ignorer la transmission de l'un ou des deux fichiers SVG et/ou d'image pour s'assurer que les inspections et/ou les acquisitions d'images ne manqueront pas.
Fermé Aperçu du nom du fichier

Fournit un aperçu du nom du fichier d'image exporté ; par défaut, Image999 est affiché. Il est possible de personnaliser le nom du fichier en configurant les paramètres suivants : Nom du fichier par défaut, Ajouter liaison, Ajouter horodatage et Ajouter compteur.

Remarque :
  • Définissez au moins un paramètre pour le fichier d'image. Si le champ Nom du fichier par défaut est vierge et que les cases Ajouter liaison, Ajouter horodatage et Ajouter compteur ne sont pas cochées, l'opération d'exportation de fichier échoue.
  • Il est impossible de modifier l'ordre des paramètres.
  • Lorsque le paramètre Ajouter compteur est activé, la Valeur maximale du compteur est toujours affichée dans l'Aperçu du nom du fichier.
Fermé Nom du fichier par défaut

Définit le nom du fichier d'image exporté ; le nom par défaut est « Image ». Les noms de fichiers longs sont pris en charge.

Fermé Ajouter liaison

Définit si l'outil sélectionné sera lié et ajouté ou non au nom du fichier exporté. Par défaut, cette case est décochée.

Remarque :
  • L'opération d'exportation échouera si l'outil sélectionné est lié à une chaîne qui contient l'un des caractères non valides suivants : <, >, :, ", /, \, |, ? ou *.
  • La case Ajouter liaison est grisée quand EasyBuilder ne peut trouver aucun outil qui puisse être lié.
  • Si l'outil lié est supprimé de la tâche, la case Ajouter liaison est automatiquement décochée.
  • Lorsque la case Ajouter liaison est cochée, ne sélectionnez pas Indéfini dans la liste déroulante ; cela pourrait générer des résultats indéfinis.
Fermé Ajouter horodatage

Définit si un horodatage sera ajouté ou non au nom du fichier d'image exporté. Par défaut, cette case est décochée. Lorsqu'elle est cochée, vous pouvez sélectionner les formats d'horodatage pré-configurés suivants dans la liste déroulante : MMJJAA, AAAAMMJJ_HHMMSS, JJMMAA_HHMMSS, MM-JJ-AAAA_HH.MM.SS, HHMMSS, AAMMJJ_HHMMSS ou AAJJMM_HHMMSS.

Remarque : vous pouvez configurer les paramètres de date/heure du système de vision In-Sight dans la boîte de dialogue Date/Time Setting (Réglage de la date et de l'heure).
Fermé Ajouter compteur

Définit si un compteur sera ajouté ou non au nom du fichier d'image exporté (par défaut = activé). Lorsque l'option est activée, il est possible de spécifier la valeur maximale du compteur (de 0 à 9 999 999 ; par défaut = 999). Chaque fichier d'image exporté incrémente un compteur. Le compteur est automatiquement réinitialisé lorsqu'il est égal à la valeur maximale ; les fichiers d'image existants sont remplacés par les nouveaux fichiers de même nom.

Fermé Bouton Ajouter

Ajoute une nouvelle opération d'exportation à la liste.

Fermé Bouton Supprimer

Supprime une opération d'exportation de la liste. Une seule opération d'exportation peut être supprimée à la fois.

Fermé Bouton Remettre tous les compteurs à zéro

Réinitialise à 000 la valeur ajoutée au nom du fichier d'image pour chaque opération d'exportation d'image de la liste.

Onglet Paramètres

L'onglet Paramètres fournit les paramètres permettant de définir deux périphériques cible. Le périphérique cible peut être un émulateur In-Sight ou un autre hôte se comportant comme un serveur FTP sur le réseau.

Fermé Nom d'hôte

Définit le nom d'hôte (ou l'adresse IP) du serveur FTP du périphérique cible.

Remarque :
  • Si un Nom d'hôte non valide est spécifié, l'expiration du délai de la connexion peut prendre jusqu'à 30 secondes.

  • Lorsque vous spécifiez le Nom d'hôte ou le Nom d'utilisateur, n'utilisez pas d'espace avant ni après le nom. Si le nom spécifié dans le paramètre Nom d'hôte ou Nom d'utilisateur comporte un espace avant ou après le nom, l'opération d'exportation d'image ne parviendra pas à écrire l'image sur le serveur spécifié.

  • Si vous disposez d'un autre PC avec un serveur FTP installé, vous pouvez le choisir comme emplacement de stockage. Veuillez noter que le logiciel In-Sight Explorer est considéré comme un serveur FTP. Si vous utilisez un serveur FTP tiers, vous devez fermer In-Sight Explorer. Si aucun autre serveur FTP n'est utilisé, In-Sight Explorer doit être ouvert. Si vous utilisez un serveur FTP tiers, l'adresse IP du PC doit être utilisée dans le paramètre Nom d'hôte.
  • Le numéro de port de la connexion du serveur FTP doit être modifié en ajoutant le Nom d'hôte (ou l'adresse IP) avec deux points (:) et le nouveau numéro de port. Par exemple, si le Nom d'hôte actuel était PRODUCTION1, pour remplacer le numéro de port par défaut (21) par le port 34, le paramètre Nom d'hôte devient : PRODUCTION1:34.
Fermé Nom d'utilisateur

Définit le nom d'utilisateur valide pour le serveur FTP du périphérique cible (ne doit pas excéder 255 caractères). Ce nom ne doit pas exister sur le système de vision In-Sight qui exporte les fichiers ou les données d'image.

Fermé Mot de passe

Définit le mot de passe valide pour le serveur FTP du périphérique cible. Le mot de passe est sensible à la casse et sa longueur ne doit pas excéder 20 caractères.

Remarque :
  • Pour des raisons de sécurité, mot de passe que vous saisissez est masqué par des « * » dans le champ.
  • Le mot de passe est enregistré dans le fichier de projet sous forme cryptée.
Fermé Type de connexion

Définit le type de connexion d'exportation d'image : FTP standard (sélection par défaut), FTP sécurisé ou GOT Mitsubishi. FTP sécurisé offre un protocole de transmission sécurisé pour une utilisation avec des applications SFTP et Mitsubishi GOT offre la prise en charge pour l'affichage d'images sur un terminal GOT Mitsubishi.

Remarque : lorsque le paramètre Type de connexion est configuré sur GOT Mitsubishi, assurez-vous que le paramètre Format du fichier de l'onglet Images est configuré sur JPG pour bénéficier des meilleurs résultats d'affichage.
Fermé Bouton Paramètres FTP

Permet d'ouvrir la boîte de dialogue Paramètres FTP.

Remarque : en général, vous n'avez pas besoin de modifier les paramètres par défaut sur des réseaux locaux In-Sight dédiés où toutes les connexions FTP se font entre des systèmes de vision In-Sight. Toutefois, si des connexions FTP sont nécessaires entre des systèmes de vision In-Sight et d'autres serveurs réseau, ou entre des systèmes de vision sur différents réseaux, vous pouvez être amené à modifier les paramètres FTP par défaut.
Fermé Dernière erreur réseau

Affiche la cause d'une erreur si elle est survenue pendant une opération d'exportation. Un événement spécifié dans l'onglet Fichier - Condition du transfert doit s'être produit, par exemple le déclenchement d'une image, ou vous devez mettre le système de vision In-Sight en ligne pour que ce champ soit mis à jour.


Exportation d'un fichier de données ou ajout d'une chaîne de données à un fichier via FTP

Vous pouvez configurer votre système de vision In-Sight pour exporter un fichier de données ou ajouter une chaîne de données à un fichier sur un serveur FTP sur le réseau. Utilisez cette fonction pour enregistrer dans un journal les résultats des données que vous pouvez voir dans un fichier.

Pour configurer une connexion FTP :

  1. Dans la zone de groupe Communications, sélectionnez FTP.
  2. Sélectionnez l'onglet Fichier.

  3. Appuyez sur le bouton Ajouter pour ajouter une entrée et configurez les paramètres d'exportation.

    Remarque : vous pouvez ajouter plus d'une opération d'exportation de fichiers à un projet.
  4. Sélectionnez l'onglet Paramètres et configurez les paramètres du serveur FTP.
  5. Mettez le système de vision In-Sight en ligne. Le système de vision doit être en ligne pour l'exécution ; sinon aucune donnée n'est exportée.
  6. Déclenchez le système de vision. Pour chaque déclenchement, un fichier de données est exporté ou une chaîne de données est ajoutée à un fichier ; ces données sont stockées sur le serveur FTP spécifié dans l'onglet Paramètres.
Remarque :
  • Lorsque Condition du transfert est configurée sur Aucune (par défaut), un fichier de données est exporté ou une chaîne de données est ajoutée à un fichier chaque fois qu'une nouvelle image est acquise. Lorsque Condition du transfert est configurée sur une autre valeur qu'Aucune, un fichier de données est exporté ou une chaîne de données est ajoutée à un fichier chaque fois que l'événement spécifié se produit. Par exemple, lorsque Condition du transfert est configurée sur Projet.Échec, un fichier de données est exporté ou une chaîne de données est ajoutée à un fichier ; ces données sont stockées sur le serveur FTP chaque fois que le projet échoue.
  • Lorsque vous utilisez l'émulateur In-Sight comme un serveur FTP, par défaut, les fichiers sont écrits dans le dossier de l'Émulateur ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x). En plus de ce répertoire, il est possible d'écrire des fichiers à un emplacement défini par l'utilisateur (Répertoire FTP autorisé). Pour plus d'informations sur le répertoire FTP autorisé, reportez-vous à la rubrique Boîte de dialogue Options (volet Émulation).

Onglet Fichier

Fournit les paramètres permettant de définir les données exportées, leur format, le moment et l'emplacement où les données sont exportées.

Fermé Case cochée

Définit si l'opération d'exportation est ou non opérationnelle (par défaut, la case est cochée), et si elle est exposée ou non comme un élément EasyView (par exemple, WriteLocal_1.Outil_Activé), qui peut être affiché dans le panneau d'interface opérateur VisionView et qui est modifiable par l'opérateur.

Remarque : pour l'activer, cochez la case Activer dans le tableau. Il s'agit du seul paramètre que vous puissiez configurer dans le tableau.
Fermé Nom

Définit le nom de votre opération d'exportation de données, qui peut être utilisé dans la configuration des résultats (Entrées/sorties et Communication) ; le nom par défaut est « WriteFtp_1 » (s'il s'agit de la première opération d'exportation d'image ajoutée au projet, sinon il est incrémenté, par exemple « WriteFtp_2 », « WriteFtp_3 », etc.). Personnalisez l'opération en lui donnant un nom, par exemple associé à sa condition de transfert.

Fermé Condition du transfert

Définit quand les données doivent être envoyées sur le serveur FTP, par exemple en cas de réussite ou d'échec d'un outil particulier ou lorsqu'une entrée est reçue. Par défaut, Aucun est sélectionné, ce qui assure que les données seront exportées à chaque acquisition d'image, si la case Activé est cochée. Si la case Activé n'est pas cochée ou si l'outil référencé est désactivé, l'opération d'exportation ne s'exécute pas.

Fermé Périphérique

Définit le serveur FTP configuré dans l'onglet Paramètres et qui recevra les données exportées. Par défaut, Périphérique 1 est sélectionné.

Fermé Type de fichier

Définit le format du fichier exporté : Texte, HTML (default), XML ou CSV.

Fermé Type à écrire (Remplacer ou Ajouter)

Définit le la manière dont les données sont écrites dans le fichier.

  • Remplacer : remplace les données existantes dans le fichier.
  • Ajouter (par défaut) : ajoute la chaîne de données à la fin du fichier.
Fermé Bouton Contenu du fichier/(Format String) Format de la chaîne

Définit les données écrites dans le fichier à l'aide de la boîte de dialogue FormatString (Format de la chaîne).

Fermé Aperçu du nom du fichier

Fournit un aperçu du nom du fichier exporté ; par défaut, Fichier est affiché. Vous pouvez personnaliser le nom du fichier en configurant les paramètres suivants : Nom du fichier par défaut, Ajouter liaison et Ajouter horodatage.

Remarque :
  • Définissez au moins un paramètre pour le fichier. Si le champ Nom du fichier par défaut est vide et que les cases Ajouter liaison et Ajouter horodatage sont décochées, l'opération d'exportation de fichier échouera.
  • Il est impossible de modifier l'ordre des paramètres.
Fermé Nom du fichier par défaut

Définit le nom du fichier qui est exporté ; le nom par défaut est « Fichier ». Les noms de fichiers longs sont pris en charge.

Fermé Ajouter liaison

Définit si l'outil sélectionné sera lié et ajouté ou non au nom du fichier exporté. Par défaut, cette case est décochée.

Remarque :
  • L'opération d'exportation échouera si l'outil sélectionné est lié à une chaîne qui contient l'un des caractères non valides suivants : <, >, :, ", /, \, |, ? ou *.
  • La case Ajouter liaison est grisée quand EasyBuilder ne peut trouver aucun outil qui puisse être lié.
  • Si l'outil lié est supprimé de la tâche, la case Ajouter liaison est automatiquement décochée.
  • Lorsque la case Ajouter liaison est cochée, ne sélectionnez pas Indéfini dans la liste déroulante ; cela pourrait générer des résultats indéfinis.
Fermé Ajouter horodatage

Définit si un horodatage sera ajouté ou non au nom du fichier d'image exporté. Par défaut, cette case est décochée. Lorsqu'elle est cochée, vous pouvez sélectionner les formats d'horodatage pré-configurés suivants dans la liste déroulante : MMJJAA, AAAAMMJJ_HHMMSS, JJMMAA_HHMMSS, MM-JJ-AAAA_HH.MM.SS, HHMMSS, AAMMJJ_HHMMSS ou AAJJMM_HHMMSS.

Remarque : vous pouvez configurer les paramètres de date/heure du système de vision In-Sight dans la boîte de dialogue Date/Time Setting (Réglage de la date et de l'heure).
Fermé Bouton Ajouter

Ajoute une nouvelle opération d'exportation à la liste.

Fermé Bouton Supprimer

Supprime une opération d'exportation de la liste. Une seule opération d'exportation peut être supprimée à la fois.

Onglet Paramètres

L'onglet Paramètres fournit les paramètres permettant de définir deux périphériques cible. Le périphérique cible peut être un émulateur In-Sight ou un autre hôte se comportant comme un serveur FTP sur le réseau.

Fermé Nom d'hôte

Définit le nom d'hôte (ou l'adresse IP) du serveur FTP du périphérique cible.

Remarque :
  • Si un Nom d'hôte non valide est spécifié, l'expiration du délai de la connexion peut prendre jusqu'à 30 secondes.

  • Lorsque vous spécifiez le Nom d'hôte ou le Nom d'utilisateur, n'utilisez pas d'espace avant ni après le nom. Si le nom spécifié dans le paramètre Nom d'hôte ou Nom d'utilisateur comporte un espace avant ou après le nom, l'opération d'exportation d'image ne parviendra pas à écrire l'image sur le serveur spécifié.

  • Si vous disposez d'un autre PC avec un serveur FTP installé, vous pouvez le choisir comme emplacement de stockage. Veuillez noter que le logiciel In-Sight Explorer est considéré comme un serveur FTP. Si vous utilisez un serveur FTP tiers, vous devez fermer In-Sight Explorer. Si aucun autre serveur FTP n'est utilisé, In-Sight Explorer doit être ouvert. Si vous utilisez un serveur FTP tiers, l'adresse IP du PC doit être utilisée dans le paramètre Nom d'hôte.
  • Le numéro de port de la connexion du serveur FTP doit être modifié en ajoutant le Nom d'hôte (ou l'adresse IP) avec deux points (:) et le nouveau numéro de port. Par exemple, si le Nom d'hôte actuel était PRODUCTION1, pour remplacer le numéro de port par défaut (21) par le port 34, le paramètre Nom d'hôte devient : PRODUCTION1:34.
Fermé Nom d'utilisateur

Définit le nom d'utilisateur valide pour le serveur FTP du périphérique cible (ne doit pas excéder 255 caractères). Ce nom ne doit pas exister sur le système de vision In-Sight qui exporte les fichiers ou les données d'image.

Fermé Mot de passe

Définit le mot de passe valide pour le serveur FTP du périphérique cible. Le mot de passe est sensible à la casse et sa longueur ne doit pas excéder 20 caractères.

Remarque :
  • Pour des raisons de sécurité, mot de passe que vous saisissez est masqué par des « * » dans le champ.
  • Le mot de passe est enregistré dans le fichier de projet sous forme cryptée.
Fermé Type de connexion

Définit le type de connexion d'exportation d'image : FTP standard (sélection par défaut), FTP sécurisé ou GOT Mitsubishi. FTP sécurisé offre un protocole de transmission sécurisé pour une utilisation avec des applications SFTP et Mitsubishi GOT offre la prise en charge pour l'affichage d'images sur un terminal GOT Mitsubishi.

Remarque : lorsque le paramètre Type de connexion est configuré sur GOT Mitsubishi, assurez-vous que le paramètre Format du fichier de l'onglet Images est configuré sur JPG pour bénéficier des meilleurs résultats d'affichage.
Fermé Bouton Paramètres FTP

Permet d'ouvrir la boîte de dialogue Paramètres FTP.

Remarque : en général, vous n'avez pas besoin de modifier les paramètres par défaut sur des réseaux locaux In-Sight dédiés où toutes les connexions FTP se font entre des systèmes de vision In-Sight. Toutefois, si des connexions FTP sont nécessaires entre des systèmes de vision In-Sight et d'autres serveurs réseau, ou entre des systèmes de vision sur différents réseaux, vous pouvez être amené à modifier les paramètres FTP par défaut.
Fermé Dernière erreur réseau

Affiche la cause d'une erreur si elle est survenue pendant une opération d'exportation. Un événement spécifié dans l'onglet Fichier - Condition du transfert doit s'être produit, par exemple le déclenchement d'une image, ou vous devez mettre le système de vision In-Sight en ligne pour que ce champ soit mis à jour.


Exportation d'images sur une carte SD

Vous pouvez configurer votre système de vision In-Sight pour exporter des images sur la carte SD installée dessus. Cela vous permet de stocker des images acquises (basées sur un outil ou une condition de succès/échec d'un projet) à des fins d'archivage. Vous pouvez examiner ces images, ce qui vous aide à diagnostiquer les problèmes qui pourraient être survenus au cours du processus de production.

Remarque : Cette caractéristique est prise en charge uniquement sur les systèmes de vision In-Sight sur lesquels est installée une carte SD.

Pour envoyer des images sur la carte SD :

  1. Dans la zone de groupe Communications, sélectionnez Carte SD.
  2. Sélectionnez l'onglet Image.

  3. Appuyez sur le bouton Ajouter pour ajouter une entrée et configurer les paramètres d'exportation d'images.

    Remarque : vous pouvez ajouter plus d'une opération d'exportation d'images à un projet.
  4. Mettez le système de vision In-Sight en ligne. Le système de vision doit être en ligne pour s'exécuter ; sinon, aucune image n'est exportée.

  5. Déclenchez le système de vision pour acquérir des images. Pour chaque image acquise, un fichier d'image (BMP ou JPG, selon le paramètre Format du fichier) est exporté et stocké sur la carte SD installée sur le système de vision.

    Remarque : lorsque Condition du transfert est configurée sur Aucune (= valeur par défaut), un fichier d'image est exporté chaque fois qu'une image est acquise. Lorsque Condition du transfert est configurée sur une autre valeur qu'Aucune, un fichier d'image est exporté chaque fois que l'événement spécifié se produit. Par exemple, lorsque Condition du transfert est configurée sur Échec.Projet, un fichier d'image est exporté et stocké sur la carte SD chaque fois que le projet échoue.

Contrôles

Fermé Case cochée

Définit si l'opération d'exportation d'image est ou non opérationnelle (par défaut, la case est cochée), et si elle est exposée ou non comme un élément EasyView (par exemple, WriteImageLocal_1.Tool_Enabled), qui peut être affiché dans le panneau d'interface opérateur VisionView et qui est modifiable par l'opérateur.

Remarque : pour l'activer, cochez la case Activer dans le tableau. Il s'agit du seul paramètre que vous puissiez configurer dans le tableau.
Fermé Nom

Définit le nom de votre opération d'exportation d'image, qui peut être utilisé dans la configuration des résultats (Entrées/sorties et Communication) ; le nom par défaut est « WriteImageLocal_1 » (s'il s'agit de la première opération d'exportation d'image ajoutée au projet, sinon il est incrémenté, par exemple « WriteImageLocal_2 » ou « WriteImageLocal_3 », etc.). Personnalisez l'opération en lui donnant un nom, par exemple associé à sa condition de transfert.

Fermé Condition du transfert

Définit quand l'image doit être envoyée sur la carte SD, par exemple en cas de réussite ou d'échec d'un outil particulier ou lorsqu'une entrée est reçue. Par défaut, Aucun est sélectionné, ce qui assure qu'une image sera exportée chaque fois à chaque acquisition d'image, si la case Activé est cochée. Si la case Activé n'est pas cochée ou si l'outil référencé est désactivé, l'opération d'exportation d'image ne s'exécute pas.

Remarque : si la Condition du transfert d'une opération particulière d'exportation d'image se produit fréquemment, par exemple à chaque acquisition d'image, la file d'attente des images du système de vision In-Sight peut être saturée et empêcher l'exportation d'opérations supplémentaires d'exportation d'images, certaines images n'étant alors pas transférées.
Fermé Format du fichier

Définit le format du fichier de l'image exportée : BMP (format bitmap Windows) ou JPG (format JPEG à encodage standard). L'option BMP est sélectionnée par défaut.

Fermé Taille de l'image

Définit la résolution de l'image exportée : Complet, Demi ou Quart. L'option Complet est sélectionnée par défaut.

Fermé Inclure les graphiques

Définit si un fichier SVG qui contient des données de graphiques superposés pour les outils de recherche et d'inspection sera créé ou non. Pour afficher le fichier SVG et un fichier d'image, ouvrez-le à l'aide d'un navigateur Web qui prend en charge le type de fichier SVG (par exemple Microsoft Internet Explorer 9.0). Le fichier SVG contient un lien interne vers l'image acquise qui lui est associée, et lorsque le navigateur ouvre le fichier SVG, il suit le lien pour ouvrir et afficher l'image acquise avec des graphiques superposés.

Remarque :
  • Pour l'activer, cochez la case Inclure les graphiques dans la zone de groupe de droite. Dans le tableau, la case Inclure les graphiques est en lecture seule.
  • Lorsqu'elle est cochée, le fichier SVG utilise le nom spécifié dans le paramètre Nom du fichier.
  • Lorsque le paramètre Nom d'hôte de l'onglet Paramètres est configuré sur un émulateur In-Sight, les fichiers SVG sont enregistrés dans le répertoire de l'émulateur ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x) et affichés dans le volet Fichiers In-Sight.
  • Si un outil de recherche et/ou d'inspection a été configuré pour masquer ses graphiques superposés en modifiant les Options d'outils dans la boîte de dialogue Options d'affichage des résultats, les graphiques SVG ne font pas l'objet d'une sortie. Par défaut, tous les outils affichent leurs graphiques superposés.
  • Comme les graphiques sont rendus par une application tierce, telle qu'un navigateur Web, les données des graphiques superposés ne correspondent pas au pixel près.
  • Le micrologiciel d'In-Sight ne garantit pas la transmission de toutes les paires de fichiers SVG et d'image. Si le système de vision In-Sight est surchargé, il peut ignorer la transmission de l'un ou des deux fichiers SVG et/ou d'image pour s'assurer que les inspections et/ou les acquisitions d'images ne manqueront pas.
Fermé Aperçu du nom du fichier

Fournit un aperçu du nom du fichier d'image exporté ; par défaut, Image999 est affiché. Il est possible de personnaliser le nom du fichier en configurant les paramètres suivants : Nom du fichier par défaut, Ajouter liaison, Ajouter horodatage et Ajouter compteur.

Remarque :
  • Définissez au moins un paramètre pour le fichier d'image. Si le champ Nom du fichier par défaut est vierge et que les cases Ajouter liaison, Ajouter horodatage et Ajouter compteur ne sont pas cochées, l'opération d'exportation de fichier échoue.
  • Il est impossible de modifier l'ordre des paramètres.
  • Lorsque le paramètre Ajouter compteur est activé, la Valeur maximale du compteur est toujours affichée dans l'Aperçu du nom du fichier.
Fermé Nom du fichier par défaut

Définit le nom du fichier d'image exporté ; le nom par défaut est « Image ». Les noms de fichiers longs sont pris en charge.

Fermé Ajouter liaison

Définit si l'outil sélectionné sera lié et ajouté ou non au nom du fichier exporté. Par défaut, cette case est décochée.

Remarque :
  • L'opération d'exportation échouera si l'outil sélectionné est lié à une chaîne qui contient l'un des caractères non valides suivants : <, >, :, ", /, \, |, ? ou *.
  • La case Ajouter liaison est grisée quand EasyBuilder ne peut trouver aucun outil qui puisse être lié.
  • Si l'outil lié est supprimé de la tâche, la case Ajouter liaison est automatiquement décochée.
  • Lorsque la case Ajouter liaison est cochée, ne sélectionnez pas Indéfini dans la liste déroulante ; cela pourrait générer des résultats indéfinis.
Fermé Ajouter horodatage

Définit si un horodatage sera ajouté ou non au nom du fichier d'image exporté. Par défaut, cette case est décochée. Lorsqu'elle est cochée, vous pouvez sélectionner les formats d'horodatage pré-configurés suivants dans la liste déroulante : MMJJAA, AAAAMMJJ_HHMMSS, JJMMAA_HHMMSS, MM-JJ-AAAA_HH.MM.SS, HHMMSS, AAMMJJ_HHMMSS ou AAJJMM_HHMMSS.

Remarque : vous pouvez configurer les paramètres de date/heure du système de vision In-Sight dans la boîte de dialogue Date/Time Setting (Réglage de la date et de l'heure).
Fermé Ajouter compteur

Définit si un compteur sera ajouté ou non au nom du fichier d'image exporté (par défaut = activé). Lorsque l'option est activée, il est possible de spécifier la valeur maximale du compteur (de 0 à 9 999 999 ; par défaut = 999). Chaque fichier d'image exporté incrémente un compteur. Le compteur est automatiquement réinitialisé lorsqu'il est égal à la valeur maximale ; les fichiers d'image existants sont remplacés par les nouveaux fichiers de même nom.

Fermé Bouton Ajouter

Ajoute une nouvelle opération d'exportation à la liste.

Fermé Bouton Supprimer

Supprime une opération d'exportation de la liste. Une seule opération d'exportation peut être supprimée à la fois.

Fermé Bouton Remettre tous les compteurs à zéro

Réinitialise à 000 la valeur ajoutée au nom du fichier d'image pour chaque opération d'exportation d'image de la liste.


Exportation d'un fichier de données ou ajout d'une chaîne de données à un fichier sur une carte SD

Vous pouvez configurer votre système de vision In-Sight pour exporter un fichier de données ou ajouter une chaîne de données à un fichier sur la carte SD. Utilisez cette fonction pour enregistrer dans un journal les résultats des données que vous pouvez voir dans un fichier.

Remarque : Cette caractéristique est prise en charge uniquement sur les systèmes de vision In-Sight sur lesquels est installée une carte SD.

Pour exporter des données ou ajouter une chaîne de données à un fichier sur la carte SD :

  1. Dans la zone de groupe Communications, sélectionnez Carte SD.
  2. Sélectionnez l'onglet Fichier.

  3. Appuyez sur le bouton Ajouter pour ajouter une entrée et configurer les paramètres dans l'onglet Fichier.

    Remarque : vous pouvez ajouter plus d'une opération d'exportation de fichiers à un projet.
  4. Mettez le système de vision In-Sight en ligne. Le système de vision doit être en ligne pour l'exécution ; sinon aucune donnée n'est exportée.

  5. Déclenchez le système de vision. Pour chaque déclenchement, un fichier de données est exporté ou une chaîne de données est ajoutée à un fichier ; ces données sont stockées sur la carte SD installée sur le système de vision.

    Remarque : Lorsque Condition du transfert est configurée sur Aucune (par défaut), un fichier de données est exporté ou une chaîne de données est ajoutée à un fichier chaque fois qu'une nouvelle image est acquise. Lorsque Condition du transfert est configurée sur une autre valeur qu'Aucune, un fichier de données est exporté ou une chaîne de données est ajoutée à un fichier chaque fois que l'événement spécifié se produit. Par exemple, lorsque Condition du transfert est configurée sur Échec.Projet, un fichier de données est exporté ou une chaîne de données est ajoutée à un fichier ; ces données sont stockées sur la carte SD chaque fois que le projet échoue.

Contrôles

Fermé Case cochée

Définit si l'opération d'exportation est ou non opérationnelle (par défaut, la case est cochée), et si elle est exposée ou non comme un élément EasyView (par exemple, WriteLocal_1.Outil_Activé), qui peut être affiché dans le panneau d'interface opérateur VisionView et qui est modifiable par l'opérateur.

Remarque : pour l'activer, cochez la case Activer dans le tableau. Il s'agit du seul paramètre que vous puissiez configurer dans le tableau.
Fermé Nom

Définit le nom de votre opération d'exportation de données, qui peut être utilisé dans la configuration des résultats (Entrées/sorties et Communication) ; le nom par défaut est « WriteLocal_1 » (s'il s'agit de la première opération d'exportation d'image ajoutée au projet, sinon il est incrémenté, par exemple « WriteLocal_2 » ou « WriteLocal_3 », etc.). Personnalisez l'opération en lui donnant un nom, par exemple associé à sa condition de transfert.

Fermé Condition du transfert

Définit quand les données doivent être envoyées sur la carte SD, par exemple en cas de réussite ou d'échec d'un outil particulier ou lorsqu'une entrée est reçue. Par défaut, Aucun est sélectionné, ce qui assure que les données seront exportées à chaque acquisition d'image, si la case Activé est cochée. Si la case Activé n'est pas cochée ou si l'outil référencé est désactivé, l'opération d'exportation ne s'exécute pas.

Fermé Type de fichier

Définit le format du fichier exporté : Texte, HTML (default), XML ou CSV.

Fermé Type à écrire (Remplacer ou Ajouter)

Définit le la manière dont les données sont écrites dans le fichier.

  • Remplacer : remplace les données existantes dans le fichier.
  • Ajouter (par défaut) : ajoute la chaîne de données à la fin du fichier.
Fermé Bouton Contenu du fichier/(Format String) Format de la chaîne

Définit les données écrites dans le fichier à l'aide de la boîte de dialogue FormatString (Format de la chaîne).

Fermé Aperçu du nom du fichier

Fournit un aperçu du nom du fichier exporté ; par défaut, Fichier est affiché. Vous pouvez personnaliser le nom du fichier en configurant les paramètres suivants : Nom du fichier par défaut, Ajouter liaison et Ajouter horodatage.

Remarque :
  • Définissez au moins un paramètre pour le fichier. Si le champ Nom du fichier par défaut est vide et que les cases Ajouter liaison et Ajouter horodatage sont décochées, l'opération d'exportation de fichier échouera.
  • Il est impossible de modifier l'ordre des paramètres.
Fermé Nom du fichier par défaut

Définit le nom du fichier qui est exporté ; le nom par défaut est « Fichier ». Les noms de fichiers longs sont pris en charge.

Fermé Ajouter liaison

Définit si l'outil sélectionné sera lié et ajouté ou non au nom du fichier exporté. Par défaut, cette case est décochée.

Remarque :
  • L'opération d'exportation échouera si l'outil sélectionné est lié à une chaîne qui contient l'un des caractères non valides suivants : <, >, :, ", /, \, |, ? ou *.
  • La case Ajouter liaison est grisée quand EasyBuilder ne peut trouver aucun outil qui puisse être lié.
  • Si l'outil lié est supprimé de la tâche, la case Ajouter liaison est automatiquement décochée.
  • Lorsque la case Ajouter liaison est cochée, ne sélectionnez pas Indéfini dans la liste déroulante ; cela pourrait générer des résultats indéfinis.
Fermé Ajouter horodatage

Définit si un horodatage sera ajouté ou non au nom du fichier d'image exporté. Par défaut, cette case est décochée. Lorsqu'elle est cochée, vous pouvez sélectionner les formats d'horodatage pré-configurés suivants dans la liste déroulante : MMJJAA, AAAAMMJJ_HHMMSS, JJMMAA_HHMMSS, MM-JJ-AAAA_HH.MM.SS, HHMMSS, AAMMJJ_HHMMSS ou AAJJMM_HHMMSS.

Remarque : vous pouvez configurer les paramètres de date/heure du système de vision In-Sight dans la boîte de dialogue Date/Time Setting (Réglage de la date et de l'heure).
Fermé Bouton Ajouter

Ajoute une nouvelle opération d'exportation à la liste.

Fermé Bouton Supprimer

Supprime une opération d'exportation de la liste. Une seule opération d'exportation peut être supprimée à la fois.


Configuration du périphérique

Pour pouvoir échanger des données avec d'autres périphériques, tels qu'un robot ou un PLC/MC, vous devez définir le réseau et les paramètres de communication série du capteur In-Sight.

  • Communication avec un PLC/contrôleur de mouvement
  • Communication avec un robot
  • Communication avec les périphériques Mitsubishi
  • Communication via Modbus TCP
  • Communication via TCP/IP
  • Communication via UDP
  • Communication via POWERLINK
  • Entrée de données pour les outils d'identification
  • Formatage des données de sortie
Remarque : dans EasyBuilder, lorsque la sortie d'un outil de recherche ou d'inspection est incorrecte, la valeur par défaut pour cet outil est placée dans la mémoire tampon des données de sortie. Par exemple, si un outil de recherche de modèles ne trouve pas de modèle correspondant, les données X et Y pour cet outil sont incorrectes et définies sur zéro par défaut, ce qui correspond alors à la sortie. Lors de la configuration du périphérique pour qu'il envoie les données de sortie, il est recommandé, en plus d'envoyer les résultats d'un outil, d'envoyer également l'état de succès/échec de l'outil pour s'assurer que les données de l'outil sont correctes. Pour modifier la valeur par défaut de la mémoire tampon de sortie lorsque le résultat d'un outil est incorrect, envoyez les commandes de mode natif In-Sight suivantes : pour les données, EV SetSystemConfig("FormatOutputBufferErrData",-1111), « -1111 » représentant une erreur connue ; pour les chaînes de sortie, EV SetSystemConfig("FormatOutputBufferErrString","Error"), « Error » représentant la chaîne d'erreur.

Protocoles pris en charge

Vous pouvez ajouter jusqu'à deux protocoles à un projet. Si vous ajoutez deux protocoles, vous pouvez ajouter un protocole « principal » et un protocole « secondaire ». Par exemple, après avoir ajouté le protocole de Scanner SLMP (principal), cliquez à nouveau sur le bouton Ajouter un périphérique et ajoutez le protocole TCP/IP (secondaire).

Remarque : vous ne pouvez pas ajouter deux protocoles « principaux » ni deux protocoles « secondaires » à un projet.

Micrologiciel In-Sight 4.x.x

 | Principal ou Secondaire | Micro série 1000 | Série 5000 (sauf 5705 & 5705C) | Série 70xx - 74xx
CC-Link | Principal | X | X | X
Ethernet natif | Principal | X | X | X
Robot Ethernet natif | Principal | X | X | X
Chaîne Ethernet natif | Principal | X | X | X
EtherNet/IP | Principal | X | X | X
Serveur ModBus TCP | Principal | X | X | X
POWERLINK | Principal |  |  | X
PROFINET | Principal | X | X | X
Kuka série | Principal | X | X | X
Motoman série | Principal | X | X | X
Natif série | Principal | X | X | X
Robot en mode natif série | Principal | X | X | X
Chaîne en mode natif série | Principal | X | X | X
Texte série | Principal | X | X | X
SLMP | Principal | X | X | X
Scanner SLMP | Principal | X | X | X
TCP/IP | Secondaire | X | X | X
UDP | Secondaire | X | X | X

Micrologiciel In-Sight 5.x.x

 | Principal ou Secondaire | Série 2000 | 5705 et 5705C | Série 7000 Gen2 | Série 8000 | Série 9000
CC-Link IE Field Basic | Principal | X | X | X | X | X
Ethernet natif | Principal |  | X | X | X | X
Robot Ethernet natif | Principal |  | X | X | X | X
Chaîne Ethernet natif | Principal |  | X | X | X | X
EtherNet/IP | Principal | X | X | X | X | X
Serveur ModBus TCP | Principal | X | X | X | X | X
PROFINET | Principal | X | X | X | X | X
Kuka série | Principal |  | X | X | X | X
Motoman série | Principal |  | X | X | X | X
Natif série | Principal | X (Basic) | X | X | X | X
Robot en mode natif série | Principal |  | X | X | X | X
Chaîne en mode natif série | Principal |  | X | X | X | X
Texte série | Principal | X | X | X | X | X
SLMP | Principal | X | X | X | X | X
Scanner SLMP | Principal | X | X | X | X | X
TCP/IP | Secondaire | X | X | X | X | X
UDP | Secondaire | X | X | X | X | X

Communication avec un PLC

Communication avec un robot

Communication avec les périphériques Mitsubishi

Communication via Modbus TCP

Communication via TCP/IP

Communication via UDP

Communication via POWERLINK

Entrée de données pour les outils d’identification

Formatage des chaînes de sortie


Communication avec un PLC/contrôleur de mouvement

Pour communiquer avec un PLC/contrôleur de mouvement, procédez d'abord comme suit :

  1. Dans la zone de groupe Communications, cliquez sur le bouton Ajouter un périphérique.
  2. Dans la zone de groupe Configuration du périphérique, sélectionnez PLC/contrôleur de mouvement dans la liste déroulante Périphérique.
  3. Sur la liste déroulante Fabricant, sélectionnez le fabricant du PLC/contrôleur de mouvement. Si le fabricant de votre PLC/contrôleur de mouvement ne figure pas sur la liste, sélectionnez Autre.

  4. Sur la liste déroulante Protocole, sélectionnez le protocole de communication : Les protocoles de communication listés dépendent de la sélection du Fabricant.

    Remarque : DeviceNet est disponible uniquement sur les systèmes de vision In-Sight exploitant le micrologiciel In-Sight 4.x.x, mais pas sur les systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.1.0 et ultérieures. Reportez-vous à Versions du micrologiciel pour obtenir une liste complète des modèles et des versions du micrologiciel prises en charge.
  5. Cliquez sur le bouton OK.
  6. En option, cliquez à nouveau sur le bouton Ajouter un périphérique pour ajouter un protocole secondaire supplémentaire au projet. Pour en savoir plus, reportez-vous à la rubrique Protocoles pris en charge sur Configuration du périphérique.

Une fois ces paramètres activés, configurez les onglets qui s'affichent dans le volet de paramètres.

Protocoles disponibles du PLC/contrôleur de mouvement

Remarque : Reportez-vous à la section Configuration du périphérique pour obtenir une liste complète des protocoles pris en charge.
  • Modbus TCP Server
  • CC-Link
  • SLMP
  • Scanner SLMP
  • EtherNet/IP
  • PROFINET
  • DeviceNet

Communication via Modbus TCP

Communications CC-Link

Communications SLMP

Communications SLMP Scanner

Paramètres du port série DeviceNet


Communication via Modbus TCP

Le capteur In-Sight peut servir de serveur Modbus pour les autres périphériques Modbus TCP en réseau.

Pour configurer votre capteur In-Sight comme serveur Modbus :

  1. Dans la zone de groupe Communications, cliquez sur le bouton Ajouter un périphérique.

  2. Dans la zone de groupe Configuration du périphérique, sélectionnez PLC ou Autre dans la liste déroulante Périphérique.

    Remarque : Si vous sélectionnez PLC, sélectionnez votre fabricant PLC ou Autre dans la liste déroulante Fabricant pour activer Serveur Modbus TC comme option dans la liste déroulante Protocole.
  3. Sélectionnez Serveur Modbus TCP dans la liste déroulante Protocole.
  4. Cliquez sur le bouton OK.
  5. Par défaut, l'onglet Formater les données de sortie s'affiche en premier. Les contrôles des deux onglets sont identiques et sont activés après l'ajout des données.

  6. Cliquez sur le bouton Ajouter pour lancer la boîte de dialogue Sélectionner les données d'entrée ou Sélectionner les données de sortie (selon l'onglet sélectionné). La boîte de dialogue Sélectionner les données d'entrée ou Sélectionner les données de sortie contient les données de tous les outils de recherche ou d'inspection ajoutés à votre projet, ainsi que les résultats du projet global (sortie uniquement). Dans la boîte de dialogue, sélectionnez les données à exposer via Modbus, puis cliquez sur le bouton OK.

  7. Après avoir ajouté vos données, elles vont s'afficher dans le tableau : nom, type de données, taille, valeur et numéro du registre de départ des données sélectionnées (ce numéro est référencé par les commandes Lire et Écrire du client Modbus, il définit quel signal est destiné à quel registre). À droite du tableau se trouve une fenêtre d'aperçu des registres Modbus, qui affiche comment les données sont formatées dans les registres Modbus.

  8. Vous pouvez personnaliser le type de données par défaut en sélectionnant un type de données différent dans la liste déroulante Type de données.

    Remarque :
    • Si vous sélectionnez Chaîne ou Chaîne convertie en octets dans la liste déroulante Type de données, le contrôle Taille d'élément (mots) est activé et vous pouvez spécifier la longueur de chaîne en choisissant le nombre de mots approprié.
    • L'implémentation du protocole Modbus TCP dans EasyBuilder ne prend pas en charge les types de données bit, 8 bits ou non signés.

  9. Vous pouvez également personnaliser l'ordre des octets des nombres flottants de 32 bits et des entiers en spécifiant Octet de poids faible en premier ou Octet de poids fort en premier en décochant la case Octet de poids fort/Octet de poids faible (elle est non cochée par défaut). Vous pouvez également personnaliser l'ordre des mots des nombres flottants de 32 bits et des entiers en spécifiant Mot de poids faible en premier ou Mot de poids fort en premier en décochant la case Mot de poids fort/Mot de poids faible (elle est non cochée par défaut). Toute modification sera mise à jour dans la fenêtre d'aperçu des registres Modbus.

    Remarque : Toute modification apportée à l'ordre des octets ou des mots affectera l'ensemble des signaux de données dans les onglets Formater les données de sortie et Formater les données d'entrée.
  10. Vous pouvez réorganiser l'ordre des données qui seront envoyées ou reçues en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.

  11. Une fois la configuration du système de vision In-Sight terminée, vous devrez configurer votre client Modbus pour envoyer les commandes Lire et Écrire, qui seront envoyées au système de vision In-Sight pour lire/écrire les données.

    Remarque : En option, cliquez à nouveau sur le bouton Ajouter un périphérique pour ajouter un protocole secondaire supplémentaire au projet. Pour en savoir plus, reportez-vous à la rubrique Protocoles pris en charge sur Configuration du périphérique.


Communications CC-Link

Remarque : CC-Link est disponible uniquement sur les systèmes de vision In-Sight exploitant le micrologiciel In-Sight 4.x.x, mais pas sur les systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.1.0 et ultérieures. Reportez-vous à Versions du micrologiciel pour obtenir une liste complète des modèles et des versions du micrologiciel prises en charge.

Le protocole CC-Link permet à des systèmes de vision In-Sight d'échanger des données avec le module d'E/S CIO-Micro-CC In-Sight et un PLC/contrôleur de mouvement Mitsubishi auxquels ils sont connectés. Les communications CC-Link sont établies entre le connecteur CC-Link du module d'E/S CIO-Micro-CC In-Sight et le connecteur CC-Link du PLC/MC Mitsubishi.

Remarque : pour activer les communications CC-Link, le système de vision In-Sight doit être connecté au module d'E/S CIO-Micro-CC In-Sight.

Pour configurer les communications d'un système de vision In-Sight avec un PLC/MC Mitsubishi par le biais du protocole CC-Link, des paramètres doivent d'abord être définis sous l'onglet Paramètres CC-Link. Les données à échanger entre le PLC/MC Mitsubishi et le système de vision In-Sight doivent ensuite être configurées.

  • Configuration de l'onglet Paramètres CC-Link
  • Configuration des onglets Données de bits/mots d'entrée et des onglets Données de bits/mots de sortie

Configuration de l’onglet Paramètres CC-Link

Configuration des onglets Données de bits/mots d’entrée et des onglets Données de bits/mots de sortie


Communications SLMP

Le protocole SLMP permet à un PLC/MC/automate Mitsubishi d'échanger des données avec des systèmes de vision In-Sight.

Commencez par configurer les paramètres de l'onglet Paramètres SLMP, qui définit le type d'automate, l'adresse IP, le numéro de port et les registres source et de destination du PLC/MC ou automate Mitsubishi, ainsi que les informations sur l'expiration de délai.

Puis configurez les onglets Formater les données de sortie et Formater les données d'entrée pour définir les données d'outil ou de projet à échanger avec le PLC/MC.

Remarque : Le capteur de vision In-Sight série 2000 ne prend pas en charge les automates/contrôleurs de robot.
  • Configuration de l'onglet Paramètres SLMP
  • Configuration des onglets Formater les données de sortie et Formater les données d'entrée

Configuration de l’onglet Paramètres de protocole SLMP/MC

Configuration des onglets Formater les données de sortie et Formater les données d’entrée


Communications SLMP Scanner

SLMP Scanner est un protocole qui permet à un PLC/Contrôleur de mouvement/Automate Mitsubishi d’échanger des données avec le système de vision In-Sight.

Pour commencer, configurez d’abord les paramètres de l’onglet Paramètres qui définissent les informations requises pour établir une connexion avec le PLC/MC ou l’automate Mitsubishi.

Ensuite, configurez les champs de l’onglet Adressage du périphérique qui définissent l’adresse du PLC/MC ou de l’automate et la taille des différents blocs de données à communiquer au PLC/MC/automate.

Enfin, configurez les onglets Formater les données de sortie et Formater les données d’entrée pour définir les données d’outil ou de projet à échanger avec le PLC/MC ou l’automate.

Remarque :
  • Le capteur de vision In-Sight série 2000 ne prend pas en charge les automates/contrôleurs de robot.
  • Cognex recommande de redémarrer le système de vision In-Sight après configuration ou modification des paramètres SLMP Scanner.

Configuration de l’onglet Paramètres

Configuration de l’onglet Adressage du périphérique

Configuration des onglets Formater les données de sortie et Formater les données d’entrée


Paramètres du port série DeviceNet

EasyBuilder définit automatiquement les paramètres de port série standard de l'automate DeviceNet comme paramètres par défaut. Si votre automate utilise des paramètres différents, cliquez sur l'onglet Paramètres du port série et configurez le système de vision In-Sight pour qu'il utilise les mêmes paramètres de port série. Les paramètres du port série seront enregistrés dans le système de vision In-Sight à la fin de l'étape Communication.

Remarque :
  • DeviceNet est disponible uniquement sur les systèmes de vision In-Sight exploitant le micrologiciel In-Sight 4.x.x, mais pas sur les systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.1.0 et ultérieures. Reportez-vous à Versions du micrologiciel pour obtenir une liste complète des modèles et des versions du micrologiciel prises en charge.
  • Les paramètres DeviceNet requièrent un adaptateur Passerelle RS232 à DeviceNet tiers. Ces paramètres sont disponibles pour les installations héritées et ne doivent pas être utilisés dans les nouvelles applications, sauf si le convertisseur Passerelle RS232 à DeviceNet a été complètement testé pour s'assurer qu'il est adapté à l'application.

  • Les options Paramètres du port série varient selon le modèle In-Sight et le module d'E/S applicable. Si le système est connecté à un module d'E/S pris en charge, commencez par cliquer sur le bouton Module d'E/S pour ouvrir la boîte de dialogue de configuration du module d'E/S et configurer le module d'E/S.

  • Les systèmes de vision In-Sight Micro série 1000 prennent en charge la communication série uniquement lorsqu'ils sont connectés au module CIO-MICRO ou E/S CIO-Micro-CC.

  • Il existe deux options pour activer la communication série pour le système de vision In-Sight série 70xx - 74xx : utiliser le câble breakout ou le module d'E/S CIO-MICRO ou CIO-MICRO-CC. Lorsqu'il est branché au câble breakout (sans connexion à un module d'E/S), le système de vision permet de configurer une ligne d'entrée discrète et une ligne de sortie discrète en tant que Réception série et Transmission série, respectivement.
  • Si le système de vision In-Sight série 70xx - 74xx est configuré pour être utilisé avec le module d'E/S CIO-MICRO ou CIO-MICRO-CC, les broches TRANSMISSION RS-232 et RÉCEPTION RS-232 du câble breakout et de module d'E/S sont désactivées. Utilisez le port RS-232 OUT (DB9) du module d'E/S pour raccorder le système à un périphérique série.
  • Les systèmes de vision In-Sight série 8000 prennent en charge la communication série uniquement lorsqu'ils sont connectés au module E/S CIO-MICRO.

  • Le module d'E/S CIO-WENET ne prend pas en charge les communications série.


Communication avec un robot

EasyBuilder accélère le développement des applications robotiques guidées par vision en les examinant et en convertissant automatiquement les données de sortie sur la base d'un repère (ou de la sortie d'un autre outil de recherche ou d'inspection renvoyant des données de position) dans un format fabricant/protocole spécifique. Une fois la chaîne formatée, l'automate peut demander les données en envoyant une seule commande de mode natif In-Sight, qui renvoie toutes les données formatées dans la chaîne.

Pour communiquer avec un automate, procédez d'abord comme suit :

  1. Dans la zone de groupe Communications, cliquez sur le bouton Ajouter un périphérique.
  2. Dans la zone de groupe Configuration du périphérique, sélectionnez Robot sur la liste déroulante Périphérique.
  3. Sur la liste déroulante Fabricant, sélectionnez le fabricant du robot. Si le fabricant de votre robot ne figure pas sur la liste, sélectionnez Autre.
  4. Sur la liste déroulante Protocole, sélectionnez le protocole de communication : Les protocoles de communication affichés dépendent de la sélection du Fabricant.
  5. Cliquez sur le bouton OK.
  6. En option, cliquez à nouveau sur le bouton Ajouter un périphérique pour ajouter un protocole secondaire supplémentaire au projet. Pour en savoir plus, reportez-vous à la rubrique Protocoles pris en charge sur Configuration du périphérique.

Une fois ces paramètres configurés, vous pouvez définir les données.

  • Communications en mode Ethernet natif avec un robot
  • Communications en mode natif série avec un robot
  • Communications en mode Kuka série avec un robot
  • Communications en mode Motoman série avec un robot
  • Communications Ethernet IP avec un robot (automate FANUC)

Communications en mode Ethernet natif avec un robot

Communications en mode natif série avec un robot

Communications en mode Kuka série avec un robot

Communications en mode Motoman série avec un robot

Communications en mode Ethernet/IP avec un robot (FANUC)


Communications en mode Ethernet natif

Pour commencer, vous devez ajouter les données qui seront incluses dans la chaîne envoyée au robot.

  1. Sur l'onglet Chaîne de données de sortie, cliquez sur le bouton Format pour ouvrir la boîte de dialogue FormatString, qui vous permet d'ajouter, de personnaliser et de modifier l'ordre des données envoyées au robot.

  2. Dans la boîte de dialogue FormatString, cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue de Sélectionner les données de sortie.

    Fermé Exemple - Boîte de dialogue Sélectionner les données de sortie

  3. La boîte de dialogue Sélectionner les données de sortie contient les données de tous les outils de recherche ou d'inspection qui ont été ajoutés à votre projet. Généralement, dans les applications robotiques guidées par vision, le robot demande les informations de position provenant du capteur In-Sight. Ces valeurs sont répertoriées dans la boîte de dialogue Sélectionner les données de sortie sous la forme « NomOutil ».Repère.Angle, « NomOutil ».Repère.X, « NomOutil ».Repère.Y, « NomOutil ».Offset_Horizontal et « NomOutil ».Offset_Vertical. Par exemple, si vous utilisiez un outil de recherche de modèles pour identifier les repères X, Y et l'orientation angulaire d'une pièce pour une application de manutention robotique, vous sélectionneriez Modèle_1.Repère.Angle, Modèle_1.Repère.X, Modèle_1.Repère.Y dans la boîte de dialogue. Dans la boîte de dialogue, sélectionnez les données à envoyer depuis le capteur In-Sight, puis cliquez sur le bouton OK.
  4. Lorsque les données ont été sélectionnées dans la boîte de dialogue Sélectionner les données de sortie, la boîte de dialogue FormatString s'affiche à nouveau.

  5. Vous pouvez modifier les chaînes et/ou réorganiser l'ordre des données qui seront envoyées en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité. Une fois les chaînes modifiées, cliquez sur le bouton OK.

    Fermé Exemple - Boîte de dialogue FormatString

  6. Maintenant que la chaîne a été formatée, l'automate peut demander les données en envoyant la commande du mode natif In-Sight, EV GetCellValue(« Job.Robot.FormatString »). La commande EV GetCellValue(« Job.Robot.FormatString ») renvoie toutes les données formatées dans la chaîne avec une commande unique.


Communications en mode natif série avec un robot

Remarque : Ces étapes s'appliquent uniquement lorsque le périphérique Robot et le protocole Natif série sont sélectionnés dans la section Communication.
  1. Lorsque Natif série a été défini comme Protocole, EasyBuilder recherche automatiquement dans le projet tous les outils de recherche ou d'inspection définissant un repère et génère une chaîne de données représentant le repère.
  2. Sous l'onglet Chaîne de données de sortie, tous les outils générant un repère sont répertoriés sur la liste déroulante Nom de la position. Si le projet ne contient qu'un seul outil renvoyant des données de position, il est sélectionné par défaut. Sinon, sélectionnez, sur la liste déroulante Nom de la position, l'outil dont vous souhaitez envoyer la chaîne de sortie. La chaîne formatée et le nombre de caractères qu'elle contient s'affichent à titre de référence.

  3. Le cas échéant, cliquez sur l'onglet Paramètres du port série pour définir les paramètres de communication série. EasyBuilder détermine automatiquement le protocole série en fonction des sélections effectuées dans la zone de groupe Configuration du périphérique. Les paramètres du port série sont enregistrés dans le système de vision à la fin de l'étape Communication.

    Remarque :

    • Les options Paramètres du port série varient selon le modèle In-Sight et le module d'E/S applicable. Si le système est connecté à un module d'E/S pris en charge, commencez par cliquer sur le bouton Module d'E/S pour ouvrir la boîte de dialogue de configuration du module d'E/S et configurer le module d'E/S.

    • Les systèmes de vision In-Sight Micro série 1000 prennent en charge la communication série uniquement lorsqu'ils sont connectés au module CIO-MICRO ou E/S CIO-Micro-CC.

    • Il existe deux options pour activer la communication série pour le système de vision In-Sight série 70xx - 74xx : utiliser le câble breakout ou le module d'E/S CIO-MICRO ou CIO-MICRO-CC. Lorsqu'il est branché au câble breakout (sans connexion à un module d'E/S), le système de vision permet de configurer une ligne d'entrée discrète et une ligne de sortie discrète en tant que Réception série et Transmission série, respectivement.
    • Si le système de vision In-Sight série 70xx - 74xx est configuré pour être utilisé avec le module d'E/S CIO-MICRO ou CIO-MICRO-CC, les broches TRANSMISSION RS-232 et RÉCEPTION RS-232 du câble breakout et de module d'E/S sont désactivées. Utilisez le port RS-232 OUT (DB9) du module d'E/S pour raccorder le système à un périphérique série.
    • Les systèmes de vision In-Sight série 8000 prennent en charge la communication série uniquement lorsqu'ils sont connectés au module E/S CIO-MICRO.

    • Le module d'E/S CIO-WENET ne prend pas en charge les communications série.

  4. Une fois la chaîne formatée, l'automate peut demander les données en envoyant la commande du mode natif In-Sight, EV GetCellValue(« Job.Robot.FormatString »). La commande EV GetCellValue(« Job.Robot.FormatString ») renvoie toutes les données formatées dans la chaîne avec une commande unique.
Remarque : Si vous n'avez pas défini de repère dans votre projet, ou si vous souhaitez créer une chaîne personnalisée ou personnaliser le format de votre chaîne, cliquez sur le bouton Format personnalisé... pour ouvrir la boîte de dialogue FormatString. Dans cette boîte de dialogue, vous pouvez ajouter une autre chaîne, modifier les chaînes et/ou réorganiser les données qui seront envoyées en sélectionnant les données dans la liste puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité. Une fois les chaînes modifiées, cliquez sur le bouton OK.


Communications en mode Kuka série avec un robot

Les automates Kuka communiquent avec les autres périphériques via des ports série RS-232 en utilisant un protocole de contrôle d'erreurs complexe, mais très fiable. Lorsqu'il est configuré pour des communications série Kuka, le système de vision In-Sight comprend ce protocole et peut répondre aux commandes qu'il reçoit de l'automate Kuka.

Remarque :
  • Le robot Kuka doit être en mode P3964R pour communiquer avec un système de vision In-Sight, et le système de vision doit être en mode Kuka série, comme décrit ci-dessous.
  • Les systèmes de vision In-Sight sont configurés pour utiliser les paramètres du protocole Kuka par défaut (le robot Kuka a une priorité élevée et le système de vision une priorité faible pour les transactions).

  1. Lorsque Kuka série a été défini comme Protocole, EasyBuilder recherche automatiquement dans le projet tous les outils de recherche ou d'inspection définissant un repère et produit une chaîne de données représentant le repère. Tous les outils produisant un repère figurent sur la liste déroulante Nom de la position. Si le projet ne contient qu'un seul outil renvoyant des données de position, il est sélectionné par défaut. Sinon, sélectionnez, sur la liste déroulante Nom de la position, l'outil dont vous souhaitez envoyer la chaîne de sortie. La chaîne formatée et le nombre de caractères qu'elle contient s'affichent à titre de référence. Le champ Code de la position est également inclus. Il indique les données auxquelles l'automate Kuka fait référence lors de l'exécution de la commande de mode natif In-Sight GV[codedeposition].

    Remarque : Si vous n'avez pas défini de repère dans votre projet, ou si vous souhaitez créer une chaîne personnalisée ou personnaliser le format de votre chaîne, cliquez sur le bouton Format personnalisé... pour ouvrir la boîte de dialogue FormatString. Dans cette boîte de dialogue, vous pouvez ajouter une autre chaîne, modifier les chaînes et/ou réorganiser les données qui seront envoyées en sélectionnant les données dans la liste puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité. Une fois les chaînes modifiées, cliquez sur le bouton OK.

  2. EasyBuilder définit automatiquement les paramètres de port série standard de l'automate Kuka comme paramètres par défaut. Si votre automate utilise des paramètres différents, cliquez sur l'onglet Paramètres du port série et configurez le système de vision pour qu'il utilise les mêmes paramètres de port série. Les paramètres du port série seront enregistrés dans le système de vision à la fin de l'étape Communication.

    Remarque :
    • Les automates Kuka KR C2 et KR C2 Edition 2005 sont pris en charge.

    • Les options Paramètres du port série varient selon le modèle In-Sight et le module d'E/S applicable. Si le système est connecté à un module d'E/S pris en charge, commencez par cliquer sur le bouton Module d'E/S pour ouvrir la boîte de dialogue de configuration du module d'E/S et configurer le module d'E/S.

    • Les systèmes de vision In-Sight Micro série 1000 prennent en charge la communication série uniquement lorsqu'ils sont connectés au module CIO-MICRO ou E/S CIO-Micro-CC.

    • Il existe deux options pour activer la communication série pour le système de vision In-Sight série 70xx - 74xx : utiliser le câble breakout ou le module d'E/S CIO-MICRO ou CIO-MICRO-CC. Lorsqu'il est branché au câble breakout (sans connexion à un module d'E/S), le système de vision permet de configurer une ligne d'entrée discrète et une ligne de sortie discrète en tant que Réception série et Transmission série, respectivement.
    • Si le système de vision In-Sight série 70xx - 74xx est configuré pour être utilisé avec le module d'E/S CIO-MICRO ou CIO-MICRO-CC, les broches TRANSMISSION RS-232 et RÉCEPTION RS-232 du câble breakout et de module d'E/S sont désactivées. Utilisez le port RS-232 OUT (DB9) du module d'E/S pour raccorder le système à un périphérique série.
    • Les systèmes de vision In-Sight série 8000 prennent en charge la communication série uniquement lorsqu'ils sont connectés au module E/S CIO-MICRO.

    • Le module d'E/S CIO-WENET ne prend pas en charge les communications série.

  3. L'automate Kuka initialise toutes les communications de données entre lui-même et le système de vision en envoyant des commandes du mode natif In-Sight. La commande GV[codedeposition] renvoie la chaîne configurée dans ces étapes et doit être utilisée avec tous les projets développés dans EasyBuilder.

Kuka série est une extension des communications en mode natif In-Sight. Le mode Serial Kuka étant basé sur le mode natif, un projet de système de vision In-Sight ne peut être conçu et testé en mode natif, puis passé en mode Kuka série que lorsque l'automate est connecté au système de vision. Aucune autre modification du projet n'est nécessaire.

Fermé Commandes de mode natif In-Sight prises en charge pour les communications Kuka série :
Commandes du mode natif | Syntaxe
Get Job | GJ
Get Online | GO
Get Value | GV[codedeposition]
Get Value | GV[nomsymbolique]
Load File | LF[nomdufichier]
Set Event | SE[ent]
Store File | TF[nomdufichier]
Set Float | SF[nomsymbolique][valeuràvirguleflottante]
Set Integer | SF[nomsymbolique][entier]
Set Job | SJ[ID]
Set Online | SO[entier]
Set String | SS[nomsymbolique][chaîne]


Communications en mode Motoman série avec un robot

Les automates Motoman MRC, MRC-II et XRC communiquent avec les autres périphériques via des ports série RS-232 en utilisant un protocole de contrôle d'erreurs complexe, mais très fiable. Lorsqu'il est configuré pour des communications série Motoman, le système de vision In-Sight comprend ce protocole et peut répondre aux commandes qu'il reçoit de l'automate Motoman.

Remarque :
  • Configurez l'automate Motoman de manière à communiquer en mode DCI. Les communications initialisées à partir d'un système de vision In-Sight vers un automate Motoman fonctionnant en mode Hôte ne sont pas prises en charge actuellement.
  • Bien que les automates Motoman n'exigent « Aucun » contrôle de flux spécifique, les systèmes de vision In-Sight requièrent un contrôle de flux « matériel » pour communiquer avec un automate Motoman.
  • Seuls les automates Motoman XRC ont été testés.
  • Le mode Serial Motoman étant basé sur le mode natif, un projet In-Sight ne peut être conçu et testé en mode natif, puis passé en mode Kuka Motoman que lorsque l'automate est connecté au système de vision. Aucune autre modification du projet n'est nécessaire.

  1. Lorsque Motoman série a été défini comme Protocole, EasyBuilder recherche automatiquement dans le projet tous les outils de recherche ou d'inspection définissant un repère et génère une chaîne de données représentant le repère.

    Remarque : Si vous n'avez pas défini de repère dans votre projet, ou si vous souhaitez créer une chaîne personnalisée ou personnaliser le format de votre chaîne, cliquez sur le bouton Format personnalisé... pour ouvrir la boîte de dialogue FormatString. Dans cette boîte de dialogue, vous pouvez ajouter une autre chaîne, modifier les chaînes et/ou réorganiser les données qui seront envoyées en sélectionnant les données dans la liste puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité. Une fois les chaînes modifiées, cliquez sur le bouton OK.
  2. Sous l'onglet Chaîne de données de sortie, tous les outils générant un repère sont répertoriés sur la liste déroulante Nom de la position. Si le projet ne contient qu'un seul outil renvoyant des données de position, il est sélectionné par défaut. Sinon, sélectionnez, sur la liste déroulante Nom de la position, l'outil dont vous souhaitez envoyer la chaîne de sortie. La chaîne formatée et le nombre de caractères qu'elle contient s'affichent à titre de référence.
  3. Le champ Code de la position affiche les données CC + RRR que l'automate Motoman utilise pour récupérer les données d'un système de vision.

  4. EasyBuilder définit automatiquement les paramètres de port série standard de l'automate Motoman comme paramètres par défaut. Si votre automate utilise des paramètres différents, cliquez sur l'onglet Paramètres du port série et configurez le système de vision pour qu'il utilise les mêmes paramètres de port série. Les paramètres du port série seront enregistrés dans le système de vision à la fin de l'étape Communication.

    Remarque :

    • Les options Paramètres du port série varient selon le modèle In-Sight et le module d'E/S applicable. Si le système est connecté à un module d'E/S pris en charge, commencez par cliquer sur le bouton Module d'E/S pour ouvrir la boîte de dialogue de configuration du module d'E/S et configurer le module d'E/S.

    • Les systèmes de vision In-Sight Micro série 1000 prennent en charge la communication série uniquement lorsqu'ils sont connectés au module CIO-MICRO ou E/S CIO-Micro-CC.

    • Il existe deux options pour activer la communication série pour le système de vision In-Sight série 70xx - 74xx : utiliser le câble breakout ou le module d'E/S CIO-MICRO ou CIO-MICRO-CC. Lorsqu'il est branché au câble breakout (sans connexion à un module d'E/S), le système de vision permet de configurer une ligne d'entrée discrète et une ligne de sortie discrète en tant que Réception série et Transmission série, respectivement.
    • Si le système de vision In-Sight série 70xx - 74xx est configuré pour être utilisé avec le module d'E/S CIO-MICRO ou CIO-MICRO-CC, les broches TRANSMISSION RS-232 et RÉCEPTION RS-232 du câble breakout et de module d'E/S sont désactivées. Utilisez le port RS-232 OUT (DB9) du module d'E/S pour raccorder le système à un périphérique série.
    • Les systèmes de vision In-Sight série 8000 prennent en charge la communication série uniquement lorsqu'ils sont connectés au module E/S CIO-MICRO.

    • Le module d'E/S CIO-WENET ne prend pas en charge les communications série.

  5. L'automate Motoman initialise toutes les communications de données entre lui-même et le système de vision en envoyant des commandes de mode natif In-Sight. La commande GV[codedeposition] renvoie la chaîne configurée dans ces étapes et doit être utilisée avec tous les projets développés dans EasyBuilder.

Motoman série est une extension des communications en mode natif In-Sight. Les automates Motoman envoient uniquement du texte numérique via leurs ports RS-232. Les commandes du mode natif In-Sight standard ne peuvent pas être émises. À la place, l'automate Motoman doit envoyer une représentation numérique des commandes du mode natif au système de vision, en joignant des paramètres supplémentaires, le cas échéant.


Communications en mode Ethernet/IP avec un robot (FANUC)

Il est possible de configurer un système de vision In-Sight pour communiquer avec un automate FANUC par le biais d'EtherNet/IP (EIP).

  1. Lorsque Robot a été défini comme Périphérique, FANUC comme Fabricant et RobotEtherNet/IP comme Protocole, EasyBuilder recherche automatiquement dans le projet tous les outils de recherche ou d'inspection définissant un repère et génère une chaîne de données représentant le repère.

    Remarque :
    • Pour configurer les communications en mode EthernetIP avec un automateFANUC, vous devez sélectionner FANUC sur la liste déroulante Fabricant. Si vous sélectionnez Autre sur la liste déroulante Fabricant, EasyBuilder affiche le volet de paramètres Ethernet/IP d'autres périphériques.
    • Si le protocole Robot en mode Ethernet natif ou Robot en mode natif série est utilisé pour communiquer avec un automateFANUC, reportez-vous à la rubrique Communications en mode Ethernet natif avec un robot ou à la rubrique Communications en mode natif série avec un robot, respectivement.
  2. Sur l'onglet Formater les données de sortie, tous les outils générant un repère sont répertoriés dans la liste déroulante Nom de la position. Si le projet ne contient qu'un seul outil renvoyant des données de position, il est sélectionné par défaut. Sinon, sélectionnez, sur la liste déroulante Nom de la position, l'outil dont vous souhaitez envoyer la chaîne de sortie. La chaîne Mémoire tampon de sortie est affichée, ainsi que la Taille du message en octets à titre de référence.
Remarque : Pour plus d'informations sur l'automate FANUC, reportez-vous à la rubrique Communications avec un robot - Automate FANUC dans l'aide In-Sight® Explorer.


Communication avec les périphériques Mitsubishi

PLC / Contrôleur de mouvement (MC) Mitsubishi : CC-Link, CC-Link IE Field Basic, SLMP et Scanner SLMP

Pour communiquer avec un PLC/contrôleur de mouvement Mitsubishi, procédez d'abord comme suit :

  1. Dans la zone de groupe Communications, cliquez sur le bouton Ajouter un périphérique.
  2. Dans la zone de groupe Configuration du périphérique, sélectionnez PLC/contrôleur de mouvement sur la liste déroulante Périphérique.
  3. Dans la liste déroulante Fabricant, sélectionnez Mitsubishi.

  4. Sur la liste déroulante Protocole, sélectionnez le protocole de communication : CC-Link, CC-Link IE Field Basic, SLMP ou Scanner SLMP.

    Remarque : CC-Link est disponible uniquement sur les systèmes de vision In-Sight exploitant le micrologiciel In-Sight 4.x.x, mais pas sur les systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.1.0 et ultérieures. Reportez-vous à Versions du micrologiciel pour obtenir une liste complète des modèles et des versions du micrologiciel prises en charge.
  5. Cliquez sur le bouton OK.
  6. En option, cliquez à nouveau sur le bouton Ajouter un périphérique pour ajouter un protocole secondaire supplémentaire au projet. Pour en savoir plus, reportez-vous à la rubrique Protocoles pris en charge sur Configuration du périphérique.

Une fois ces paramètres activés, vous pouvez configurer les paramètres de communication avec les PLC/MC Mitsubishi :

  • CC-Link
  • CC-Link IE Field Basic
  • SLMP
  • Scanner SLMP
Remarque : lorsqu'un système de vision In-Sight est configuré pour communiquer avec un PLC/MC sur SLMP, un scanner SLMP ou CC-Link, les protocoles ne prennent en charge que le transfert de données entre le système de vision et le PLC/MC.

Automate Mitsubishi – Chaîne en mode Ethernet natif, Chaîne en mode natif série, SLMP et Scanner SLMP

Remarque : Le capteur de vision In-Sight série 2000 ne prend pas en charge les automates/contrôleurs de robot.

Pour communiquer avec un contrôleur du robot Mitsubishi, procédez d'abord comme suit :

  1. Dans la zone de groupe Communications, cliquez sur le bouton Ajouter un périphérique.
  2. Dans la zone de groupe Configuration du périphérique, sélectionnez Robot depuis la liste déroulante Périphérique.
  3. Dans la liste déroulante Fabricant, sélectionnez Mitsubishi.
  4. Sur la liste déroulante Protocole, sélectionnez le protocole de communication : Chaîne en mode Ethernet natif,Chaîne en mode natif série, SLMP ou Scanner SLMP.
  5. Cliquez sur le bouton OK.
  6. En option, cliquez à nouveau sur le bouton Ajouter un périphérique pour ajouter un protocole secondaire supplémentaire au projet. Pour en savoir plus, reportez-vous à la rubrique Protocoles pris en charge sur Configuration du périphérique.

Une fois ces paramètres activés, vous pouvez configurer les données qui seront communiquées entre le système de vision In-Sight et le robot :

  • Configuration des communications de chaîne en mode Ethernet natif Mitsubishi
  • Configuration des communications de chaîne en mode natif série Mitsubishi
  • SLMP
  • Scanner SLMP

Communications CC-Link

Communications CC-Link IE Field Network Basic

Communications via le protocole SLMP/MC

Communications du protocole de scanner SLMP/MC

Configuration des communications de chaîne du robot Mitsubishi en mode Ethernet natif

Configuration des communications de chaîne du robot Mitsubishi en mode natif série


Configuration de l'onglet Paramètres CC-Link

L'onglet Paramètres CC-Link est utilisé pour configurer les communications du module d'E/S CIO-Micro-CC In-Sight sur le réseau CC-Link.

Remarque : si vous n'êtes pas connecté à un module d'E/S CIO-Micro-CC In-Sight, tous les contrôles sont désactivés jusqu'à ce que la connexion soit établie.
Fermé Activer

Définit si l'interface CC-Link du module d'E/S CIO-Micro-CC In-Sight est activée ou désactivée. La case Activer est cochée, et l'interface CC-Link du module d'E/S CIO-Micro-CC In-Sight est activée par défaut. Décochez la case Activer pour le diagnostic et le débogage de votre connexion CC-Link, le cas échéant.

Fermé Version

Définit la compatibilité avec CC-Link, V1 ou V2. L'option V1 est sélectionnée par défaut.

Fermé Débit en bauds

Définit le débit en bauds du réseau CC-Link : 10M, 5M, 2,5M, 625k, 156k. L'option 10M est sélectionnée par défaut.

Fermé Numéro de station

Définit le numéro de station de l'esclave CC-Link (de 1 à 64). 1 est sélectionné par défaut.

Remarque : les valeurs des paramètres Numéro de station et Nombre de stations ne peuvent pas dépasser 64.
Fermé Nombre de stations

Définit le nombre de stations occupées par le module d'E/S CIO-Micro-CC In-Sight sur le réseau CC-Link (de 1 à 4). 1 est sélectionné par défaut.

Remarque : les valeurs des paramètres Numéro de station et Nombre de stations ne peuvent pas dépasser 64.
Fermé Cycles d'extension

Définit le nombre de cycles d'extension utilisés par le module d'E/S CIO-Micro-CC In-Sight sur le réseau CC-Link : 1X (Désactivé), 2X, 4X ou 8X. 1X (Désactivé) est sélectionné par défaut.

Remarque : cette option n'est disponible que lorsque le paramètre Version est défini sur V2.
Fermé Entrées

Affiche le nombre de bits et de mots disponibles dans les mémoires tampons de bits et de mots d'entrée, respectivement.

Pour déterminer le nombre de bits disponibles dans la mémoire tampon d'entrée :

  • Lorsque le paramètre Version est défini sur V1 : 32 x (Nombre de stations)-16
  • Lorsque le paramètre Version est défini sur V2 et le paramètre Cycles d'extension sur 1X (Désactivé) : 32 x (Nombre de stations)-16
  • Lorsque le paramètre Version est défini sur V2 et que le paramètre Cycles d'extension est activé : 32 x (Nombre de stations) x (Cycles d'extension) - 16 x (Cycles d'extension) - 16

Pour déterminer le nombre de mots disponibles dans la mémoire tampon d'entrée :

  • Lorsque le paramètre Version est défini sur V1 : 4 x (Nombre de stations)
  • Lorsque le paramètre Version est défini sur V2 et le paramètre Cycles d'extension sur 1X (Désactivé) : 4 x (Nombre de stations)
  • Lorsque le paramètre Version est défini sur V2 et que le paramètre Cycles d'extension est activé : 4 x (Nombre de stations) x (Cycles d'extension)
Fermé Sorties

Affiche le nombre de bits et de mots disponibles dans les mémoires tampons de bits et de mots de sortie, respectivement.

Pour déterminer le nombre de bits disponibles dans la mémoire tampon de sortie :

  • Lorsque le paramètre Version est défini sur V1 : 32 x (Nombre de stations)-16
  • Lorsque le paramètre Version est défini sur V2 et le paramètre Cycles d'extension sur 1X (Désactivé) : 32 x (Nombre de stations)-16
  • Lorsque le paramètre Version est défini sur V2 et que le paramètre Cycles d'extension est activé : 32 x (Nombre de stations) x (Cycles d'extension) - 16 x (Cycles d'extension) - 16

Pour déterminer le nombre de mots disponibles dans la mémoire tampon de sortie :

  • Lorsque le paramètre Version est défini sur V1 : 4 x (Nombre de stations)
  • Lorsque le paramètre Version est défini sur V2 et le paramètre Cycles d'extension sur 1X (Désactivé) : 4 x (Nombre de stations)
  • Lorsque le paramètre Version est défini sur V2 et que le paramètre Cycles d'extension est activé : 4 x (Nombre de stations) x (Cycles d'extension)


Configuration des onglets Données de bits/mots d'entrée et des onglets Données de bits/mots de sortie

Après avoir configuré l'onglet Paramètres CC-Link, vous devez configurer les onglets Données de bits d'entrée, Données de mots d'entrée, Données de bits de sortie et Données de mots de sortie, qui définissent les données d'outil ou de projet à échanger entre le PLC/MC Mitsubishi et le système de vision In-Sight via le réseau CC-Link.

Fermé Configuration de l'onglet Données de bits d'entrée

L'onglet Données de bits d'entrée sert à associer les décalages de bits aux données de type booléen renvoyées par les résultats des outils de recherche ou d'inspection, les données d'acquisition ou les entrées. 32 entrées au maximum peuvent être définies par projet.

  1. Cliquez sur l'onglet Données de bits d'entrée pour commencer à configurer les données à transférer du PLC/MC au système de vision In-Sight.
  2. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données d'entrée, qui contient les données du projet, telles que les outils de recherche ou d'inspection ajoutés au projet, les données d'acquisition et les entrées. Sélectionnez les données à transférer au système de vision In-Sight du PLC/MC et cliquez sur le bouton OK.
  3. Après avoir ajouté les données, elles apparaissent dans le tableau en indiquant l'adresse du périphérique, le nom de l'entrée et le type, la taille et la valeur des données.
  4. Vous pouvez réorganiser l'ordre des données qui seront envoyées ou reçues en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.
Fermé Configuration de l'onglet Données de mots d'entrée

L'onglet Données de mots d'entrée sert à définir les entrées dans le système de vision In-Sight renvoyées par les résultats des outils de recherche ou d'inspection, les données d'acquisition ou les entrées. 32 entrées au maximum peuvent être définies par projet.

Remarque : Le nombre de mots ne peut pas excéder la limite définie par les paramètres configurés dans l'onglet Paramètres CC-Link.
  1. Cliquez sur l'onglet Données de mots d'entrée pour commencer à configurer les données à transférer du PLC/MC au système de vision In-Sight.
  2. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données d'entrée, qui contient les données du projet, telles que les outils de recherche ou d'inspection ajoutés au projet, les données d'acquisition et les entrées. Sélectionnez les données à transférer au système de vision In-Sight du PLC/MC et cliquez sur le bouton OK.
  3. Après avoir ajouté les données, elles apparaissent dans le tableau en indiquant l'adresse du périphérique (le début de l'adresse est le décalage du champ, en mots), le nom de l'entrée, le type, la taille et la valeur des données.

  4. Vous pouvez personnaliser le type de données par défaut en sélectionnant un type de données différent dans la liste déroulante Type de données.

    Remarque :
    • Si vous sélectionnez Chaîne dans la liste déroulante Type de données, le contrôle Taille d'élément (mots) est activé et vous pouvez spécifier la longueur de chaîne en choisissant le nombre de mots approprié (128 au maximum).
    • L'implémentation de CC-Link dans EasyBuilder ne prend pas en charge les types de données de 8 bits ou non signés.
  5. Vous pouvez réorganiser l'ordre des données qui seront envoyées ou reçues en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.
Fermé Configuration de l'onglet Données de bits de sortie

L'onglet Données de bits de sortie sert à associer les décalages de bits aux données de type booléen renvoyées par les résultats des outils de recherche ou d'inspection, les données d'acquisition ou les résultats de projet. Il est possible de définir au moins 64 sorties par projet (vous pouvez en ajouter davantage, le maximum dépend de la taille du projet).

  1. Cliquez sur l'onglet Données de bits de sortie pour commencer à configurer les données à transférer du système de vision In-Sight au PLC/MC.

  2. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données de sortie qui contient les données du projet, telles que les outils de recherche ou d'inspection ajoutés au projet, les données d'acquisition et les résultats du projet global. Sélectionnez les données à transférer du système de vision In-Sight au PLC/MC et cliquez sur le bouton OK.

    Remarque : Par défaut, le symbole de données Projet.Nombre_inspections est automatiquement ajouté dans le tableau des données de sortie. Ce symbole avertit le PLC/MC que le système de vision In-Sight a acquis une nouvelle image et qu'un nouvel ensemble de résultats d'inspection a été transmis. Ce symbole peut être supprimé s'il n'est pas indispensable à l'application.
  3. Une fois les données ajoutées, elles apparaissent dans le tableau, indiquant le nom, le type, la taille, la valeur et le numéro de registre initial des données sélectionnées. À droite du tableau se trouve une fenêtre d'aperçu des registres, qui affiche comment les données sont formatées dans les registres du PLC/MC.
  4. Vous pouvez réorganiser l'ordre des données qui seront envoyées ou reçues en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.
Fermé Configuration de l'onglet Données de mots de sortie

L'onglet Données de mots de sortie sert à définir les sorties du système de vision In-Sight renvoyées par les résultats des outils de recherche ou d'inspection, les données d'acquisition ou les résultats de projet. Il est possible de définir au moins 32 sorties par projet (vous pouvez en ajouter davantage, le maximum dépend de la taille du projet).

  1. Cliquez sur l'onglet Données de bits de sortie pour commencer à configurer les données à transférer du système de vision In-Sight au PLC/MC.

  2. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données de sortie qui contient les données du projet, telles que les outils de recherche ou d'inspection ajoutés au projet, les données d'acquisition et les résultats du projet global. Sélectionnez les données à transférer du système de vision In-Sight au PLC/MC et cliquez sur le bouton OK.

    Remarque : Par défaut, le symbole de données Projet.Nombre_inspections est automatiquement ajouté dans le tableau des données de sortie. Ce symbole avertit le PLC/MC que le système de vision In-Sight a acquis une nouvelle image et qu'un nouvel ensemble de résultats d'inspection a été transmis. Ce symbole peut être supprimé s'il n'est pas indispensable à l'application.
  3. Une fois les données ajoutées, elles apparaissent dans le tableau, indiquant le nom, le type, la taille et la valeur des données ainsi que le numéro de registre initial des données sélectionnées (le début de l'adresse est le décalage du champ, en mots). À droite du tableau se trouve une fenêtre d'aperçu des registres, qui affiche comment les données sont formatées dans les registres du PLC/MC.

  4. Vous pouvez personnaliser le type de données par défaut en sélectionnant un type de données différent dans la liste déroulante Type de données.

    Remarque :
    • Si vous sélectionnez Chaîne dans la liste déroulante Type de données, le contrôle Taille d'élément (mots) est activé et vous pouvez spécifier la longueur de chaîne en choisissant le nombre de mots approprié (128 au maximum).
    • L'implémentation de CC-Link dans EasyBuilder ne prend pas en charge les types de données de 8 bits ou non signés.
  5. Vous pouvez réorganiser l'ordre des données qui seront envoyées ou reçues en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.


Communications CC-Link IE Field Network Basic

CC-Link IE Field Basic est un protocole conçu pour intégrer des équipements Ethernet à un contrôleur Mitsubishi. Au contraire du protocole SLMP (MC) existant, les contrôleurs Mitsubishi tiennent le rôle de « maître », pilotant ainsi les communications avec les équipements « esclaves » par messages UDP. Ce protocole prend en charge des mots de 64, 32 et 16 bits par station, dans chaque sens. Chaque esclave prend en charge 4 stations. Les données sont mappées dans la mémoire du contrôleur à l’aide des outils de programmation Mitsubishi (GX Works 2/3).

Remarque : Pour des informations complémentaires, consultez le fichier d’aide In‑Sight® Explorer. Des informations détaillées sont également disponibles dans le manuel de référence Mitsubishi CC-Link IE Field Network Basic.
  • Configuration des onglets Formater les données de bits/mots d'entrée et des onglets Formater les données de bits/mots de sortie (CC-Link IE Field Basic)

Configuration des onglets Formater les données de bits/mots d'entrée et des onglets Formater les données de bits/mots de sortie (CC-Link IE Field Basic)


Configuration des onglets Formater les données de bits/mots d'entrée et des onglets Formater les données de bits/mots de sortie (CC-Link IE Field Basic)

Les onglets Formater les données de bits d'entrée, Formater les données de mots d'entrée, Formater les données de bits de sortie et Formater les données de mots de sortie servent à définir les données d’outil ou de projet qui seront échangées entre le PLC/MC Mitsubishi et le système de vision In-Sight par le biais du protocole CC-Link IE Field Basic.

Remarque :
  • Dans cette rubrique, le terme « entrée » désigne une entrée du système de vision In-Sight et celui de « sortie » désigne une sortie du système de vision.
  • Pour des informations complémentaires, consultez le fichier d’aide In‑Sight® Explorer.
Tabulation | Espace mémoire du PLC | Offset de départ | Limitation de taille (Pour 1 station) | Type de données
Formater les données de bits d'entrée | RY | 32 | 32 | bits
Formater les données de mots d'entrée | RWw | 2 | 30 | Mots de 16 bits
Formater les données de bits de sortie | RX | 32 | 32 | bits
Formater les données de mots de sortie | RWr | 5 | 27 | Mots de 16 bits

Fermé Configuration de l'onglet Formater les données d'entrée

L’onglet Formater les données de bits d'entrée permet d’associer des offsets de bits aux données de type booléen renvoyées par les outils de Position ou d’Inspection, les données d’acquisition ou les Entrées. Il est possible de définir au maximum 32 entrées par projet.

  1. Cliquez sur l'onglet Formater les données de bits d'entrée pour commencer à configurer les données à transférer du PLC/MC au système de vision In-Sight.
  2. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données d'entrée, qui contient les données du projet, telles que les outils de recherche ou d'inspection ajoutés au projet, les données d'acquisition et les entrées. Sélectionnez les données à transférer au système de vision In-Sight du PLC/MC et cliquez sur le bouton OK.
  3. Une fois les données ajoutées, elles apparaissent dans le tableau, indiquant l’Adresse du périphérique, le nom, le type, la taille et la valeur de l’entrée.
  4. Vous pouvez réorganiser l'ordre des données qui seront envoyées ou reçues en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.
Fermé Configuration de l'onglet Formater les données de mots d'entrée

L’onglet Formater les données de mots d'entrée permet de définir les entrées du système de vision In-Sight renvoyées par les outils de Position ou d’Inspection, les données d'acquisition ou les Entrées. Il est possible de définir au maximum 30 entrées par projet.

  1. Cliquez sur l'onglet Formater les données de mots d'entrée pour commencer à configurer les données à transférer du PLC/MC au système de vision In-Sight.
  2. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données d'entrée, qui contient les données du projet, telles que les outils de recherche ou d'inspection ajoutés au projet, les données d'acquisition et les entrées. Sélectionnez les données à transférer au système de vision In-Sight du PLC/MC et cliquez sur le bouton OK.
  3. Une fois les données ajoutées, elles apparaissent dans le tableau, indiquant l’Adresse du périphérique (le début de l’adresse est l’offset, en mots) le nom, le type, la taille et la valeur de l’entrée.

  4. Vous pouvez personnaliser le type de données par défaut en sélectionnant un type de données différent dans la liste déroulante Type de données.

    Remarque :
    • Si vous sélectionnez Chaîne dans la liste déroulante Type de données, le contrôle Taille d'élément (mots) est activé et vous pouvez spécifier la longueur de chaîne en choisissant le nombre de mots approprié (maximum 128).
    • L'implémentation de CC-Link dans EasyBuilder ne prend pas en charge les types de données de 8 bits.
  5. Vous pouvez réorganiser l'ordre des données qui seront envoyées ou reçues en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.
Fermé Configuration de l'onglet Formater les données de bits de sortie

L’onglet Formater les données de bits de sortie permet d’associer des offsets de bits aux données de type booléen renvoyées par les outils de Position ou d’Inspection, les données d'acquisition ou les projets. Il est possible de définir au maximum 32 sorties par projet.

  1. Cliquez sur l'onglet Formater les données de bits de sortie pour commencer à configurer les données à transférer du système de vision In-Sight au PLC/MC.

  2. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données de sortie qui contient les données du projet, telles que les outils de recherche ou d'inspection ajoutés au projet, les données d'acquisition et les résultats du projet global. Sélectionnez les données à transférer du système de vision In-Sight au PLC/MC et cliquez sur le bouton OK.

    Remarque : Par défaut, le symbole des données Projet.Nombre_inspections est ajouté automatiquement dans le tableau de données en sortie. Ce symbole alerte le PLC/MC que le système de vision In-Sight a terminé l’acquisition d’une nouvelle image et qu’une nouvelle série de résultats d’inspection est arrivée. Il est possible de supprimer ce symbole s’il n’est pas nécessaire à l’application.
  3. Une fois les données ajoutées, elles apparaissent dans le tableau, indiquant le nom, le type, la taille, la valeur et le numéro de registre initial des données sélectionnées. À droite du tableau se trouve une fenêtre d'aperçu des registres, qui affiche comment les données sont formatées dans les registres du PLC/MC.
  4. Vous pouvez réorganiser l'ordre des données qui seront envoyées ou reçues en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.
Fermé Configuration de l'onglet Formater les données de mots de sortie

L’onglet Formater les données de mots de sortie permet de définir les sorties du système de vision In-Sight renvoyées par les outils de Position ou d’Inspection, les données d'acquisition ou les projets. Il est possible de définir au maximum 27 sorties par projet.

  1. Cliquez sur l'onglet Formater les données de bits de sortie pour commencer à configurer les données à transférer du système de vision In-Sight au PLC/MC.

  2. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données de sortie qui contient les données du projet, telles que les outils de recherche ou d'inspection ajoutés au projet, les données d'acquisition et les résultats du projet global. Sélectionnez les données à transférer du système de vision In-Sight au PLC/MC et cliquez sur le bouton OK.

    Remarque : Par défaut, le symbole des données Projet.Nombre_inspections est ajouté automatiquement dans le tableau de données en sortie. Ce symbole alerte le PLC/MC que le système de vision In-Sight a terminé l’acquisition d’une nouvelle image et qu’une nouvelle série de résultats d’inspection est arrivée. Il est possible de supprimer ce symbole s’il n’est pas nécessaire à l’application.
  3. Une fois les données ajoutées, elles apparaissent dans le tableau, indiquant le nom, le type, la taille, la valeur et le numéro de registre initial des données sélectionnées (le début de l’adresse est l’offset du champ, en mots). À droite du tableau se trouve une fenêtre d'aperçu des registres, qui affiche comment les données sont formatées dans les registres du PLC/MC.

  4. Vous pouvez personnaliser le type de données par défaut en sélectionnant un type de données différent dans la liste déroulante Type de données.

    Remarque :
    • Si vous sélectionnez Chaîne dans la liste déroulante Type de données, le contrôle Taille d'élément (mots) est activé et vous pouvez spécifier la longueur de chaîne en choisissant le nombre de mots approprié (maximum 128).
    • L'implémentation de CC-Link IE Field Basic dans EasyBuilder ne prend pas en charge les types de données de 8 bits.
  5. Vous pouvez réorganiser l'ordre des données qui seront envoyées ou reçues en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.


Configuration de l'onglet Paramètres SLMP

L'onglet Paramètres SLMP permet de configurer le type d'automate et l'adresse IP du PLC/MC ou de l'automate, le numéro de port TCP, les expirations de délai et l'emplacement des registres source et de destination du PLC/MC ou de l'automate.

Remarque :

Selon le Périphérique sélectionné dans la zone de groupe Configuration du périphérique, les Types d'automates présents dans l'onglet Paramètres diffèrent. Pour plus d'informations, reportez-vous à Communication avec les périphériques Mitsubishi.

Périphérique sélectionné (zone de groupe Configuration du périphérique) Types d'automate disponibles (onglet Paramètres)
PLC / Contrôleur de mouvement
  • Série iQ-R/Q/L (trame 3E)
  • Série iQ-F (trame 3E)
  • Série FX (trame 1E)
Automate
  • Série CR-800D (trame 3E)
Fermé Type de contrôleur

Définit le type de PLC/MC ou d'automate Mitsubishi avec lequel communiquer :

  • PLC/MC : Série iQ-R/Q/L (trame 3E), Série iQ-F (trame 3E) ou Série FX (trame 1E). Par défaut = Série iQ-R/Q/L (trame 3E).

    Remarque : L'option Série iQ-F (trame 3E) n'est pas disponible sur les systèmes de vision In-Sight exécutant le micrologiciel In-Sight 4.x.x.
  • Automate : Série CR800-D (trame 3E)
Fermé Adresse IP

Définit l'adresse IP du PLC/MC ou de l'automate Mitsubishi. Saisissez l'adresse IP du PLC/MC ou de l'automate Mitsubishi qui sera connecté au système de vision In-Sight.

Fermé Port d'hôte

Définit le numéro du portTCP, au format décimal (Dec) ou hexadécimal (Hex), du PLC/contrôleur de mouvement ou de l'automate Mitsubishi (1 - 65535 en décimal, 1 - 0xFFFF en hexadécimal ; valeur par défaut = 12288 en décimal).

Fermé Délai (ms)

Définit le délai d'expiration (5 à 30 000 millisecondes ; valeur par défaut = 1 000 ms) des opérations de lecture et d'écriture.

Remarque : Ce paramètre peut allonger la durée du projet. Si les opérations de lecture et d'écriture échouent toutes les deux, leurs délais s'accumulent et la durée ajoutée au projet correspond alors au double de la valeur Délai.
Fermé Périphérique source
Remarque : Avant de modifier le paramètre Périphérique source, supprimez toutes les propriétés d'outil dans l'onglet Formater les données d'entrée. Si le paramètre Périphérique source est réglé sur <Aucun> alors que l'onglet Formater les données d'entrée contient encore des propriétés d'outil, ces outils affichent un état d'erreur. En outre, le bouton Supprimer est désactivé et l'exécution des outils encore présents dans l'onglet Formater les données d'entrée échoue jusqu'à ce que les outils soient supprimés.
Fermé Adresse du périphérique de données d'entrée

Définit le registre de périphérique du PLC/MC ou de l'automate Mitsubishi à partir duquel lire les données :

Type de périphérique | Format | PLC/MC | Robot
Série iQ-R/Q/L (trame 3E) | Série iQ-F (trame 3E) | Série FX (trame 1E) | Série CR800-D (trame 3E)
X - Relais d'entrée | Bit | X | X | X (Oct)
Y - Relais de sortie | Bit | X | X | X (Oct)
M - Relais interne | Bit | X | X | X
L - Relais de verrouillage | Bit | X
F - Indicateur | Bit | X | X
B - Relais de liaison | Bit | X
D - Registre de données | Mot | X | X | X | X
W - Registre de liens | Mot | X
R - Registre de groupes de fichiers | Mot | X
ZR - Registre de fichiers | Mot | X
TN - Valeur temporelle | Mot | X | X
CN - Valeur de compteur | Mot | X | X
R - Registre d'extension | Mot | X
S - Relais d'état | Bit | X
Remarque : le Format du Type de périphérique détermine les types de données disponibles sous l'onglet Formater la mémoire tampon d'entrée. Si le Format du Type de périphérique est Bit, l'onglet Formater la mémoire tampon d'entrée permet uniquement de saisir des données de bits.
Fermé Offset

Partie numérique du tableau de données du PLC/MC ou de l'automate qui définit le point de départ de la lecture.

Fermé Périphérique de destination
Fermé Adresse du périphérique de données de sortie

Définit le registre de périphérique du PLC/MC ou de l'automate Mitsubishi vers lequel lire les données :

Type de périphérique | Format | PLC/MC | Robot
Série iQ-R/Q/L (trame 3E) | Série iQ-F (trame 3E) | Série FX (trame 1E) | Série CR800-D (trame 3E)
X - Relais d'entrée | Bit | X | X | X (Oct)
Y - Relais de sortie | Bit | X | X | X (Oct)
M - Relais interne | Bit | X | X | X
L - Relais de verrouillage | Bit | X
F - Indicateur | Bit | X | X
B - Relais de liaison | Bit | X
D - Registre de données | Mot | X | X | X | X
W - Registre de liens | Mot | X
R - Registre de groupes de fichiers | Mot | X
ZR - Registre de fichiers | Mot | X
TN - Valeur temporelle | Mot | X | X
CN - Valeur de compteur | Mot | X | X
R - Registre d'extension | Mot | X
S - Relais d'état | Bit | X
Remarque : le Format du Type de périphérique détermine les types de données disponibles sous l'onglet Formater la mémoire tampon de sortie. Si le Format du Type de périphérique est Bit, l'onglet Formater la mémoire tampon de sortie permet uniquement de saisir des données de bits.
Fermé Offset

Partie numérique du tableau de données du PLC/MC ou de l'automate qui définit le point de départ de l'écriture.


Configuration des onglets Formater les données de sortie et Formater les données d'entrée (SLMP)

Après avoir configuré les paramètres de l'onglet Paramètres SLMP, vous devez configurer les onglets Formater les données d'entrée et Formater les données de sortie, qui définissent les données d'outil ou de projet à échanger entre le PLC/MC ou l'automate Mitsubishi et le système de vision In-Sight.

Fermé Configuration de l'onglet Formater les données d'entrée

L'onglet Formater les données d'entrée permet de définir les entrées sur le système de vision In-Sight. 32 entrées maximum peuvent être définies par projet.

  1. Cliquez sur l'onglet Formater les données d'entrée pour commencer à configurer les données à transférer du PLC/MC ou de l'automate au système de vision In-Sight.

  2. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données d'entrée, qui contient les données du projet, telles que les outils de recherche ou d'inspection ajoutés au projet, les données d'acquisition et les entrées.Sélectionnez les données à transférer au système de vision In-Sight du PLC/MC ou de l'automate et cliquez sur le bouton OK.

    Remarque : Le paramètre Périphérique source de l'onglet Paramètres SLMP influence le type de données qui peuvent être ajoutées. Si le paramètre Périphérique source est configuré sur un périphérique au format bit, vous pouvez, pour chaque adresse de bit, ajouter des données de type Boolean et les affecter à un bit particulier. Si le paramètre Périphérique source est configuré sur un périphérique au format mot, le type de données peut être configuré et l'adresse de début correspond à l'adresse du périphérique de données d'entrée et à l'offset du champ, en mots.
  3. Une fois les données ajoutées, elles apparaissent dans le tableau, indiquant l’Adresse du périphérique, le nom, le type, la taille et la valeur de l’entrée.

  4. Pour personnaliser le type de données par défaut, sélectionnez un autre type de données sur la liste déroulante Type de données.

    Remarque :
    • Les options Type de données disponibles dépendent du paramètre Périphérique source défini sous l'onglet Paramètres SLMP.Lorsque le paramètre Périphérique source est configuré sur un périphérique au format bit, la liste déroulante Type de données inclut uniquement l'option Bit.Lorsque le paramètre Périphérique source est configuré sur un périphérique au format mot, la liste déroulante Type de données inclut les options suivantes : Bit, Nombre entier de 16 bits, Nombre entier non signé de 16 bits, Nombre entier de 32 bits, Virgule flottante de 32 bits et Chaîne.
    • Si vous sélectionnez Chaîne dans la liste déroulante Type de données, le contrôle Taille d'élément (mots) est activé et vous pouvez spécifier la longueur de chaîne en choisissant le nombre de mots approprié. Lorsque Série iQ-R/Q/L (trame 3E), Série iQ-F (trame 3E) ou Série CR800-D (trame 3E) est le Type d'automate sélectionné, la taille totale maximale des messages est de 960 mots. Lorsque Série FX (trame 1E) est le Type d'automate sélectionné, la taille maximale des messages est de 64 mots.
    • Lorsque Série iQ-R/Q/L (trame 3E), Série iQ-F (trame 3E) ou Série CR800-D (trame 3E) est le Type d'automate sélectionné, la longueur maximale des données d'entrée est de 1920 octets.Lorsque Série FX (trame 1E) est le type d'automate sélectionné, la longueur maximale des données d'entrée est de 128 octets.La taille des données d'entrée est affichée dans le champ Taille du message (octets).
    • Le bouton Remettre à zéro les types de données rétablit les paramètres par défaut de tous les types de données.
    • L'implémentation du protocole SLMP dans EasyBuilder ne prend pas en charge les types de données de 8 bits ou non signés.
  5. Vous pouvez réorganiser les données qui seront envoyées ou reçues en sélectionnant les données sur la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.
Fermé Configuration de l'onglet Formater les données de sortie

L'onglet Formater les données de sortie permet de définir les sorties du système de vision In-Sight. 128 sorties maximum peuvent être définies par projet.

  1. Cliquez sur l'onglet Formater les données de sortie pour commencer à configurer les données à transférer du système de vision In-Sight au PLC/MC ou à l'automate.

  2. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données de sortie qui contient les données du projet, telles que les outils de recherche ou d'inspection ajoutés au projet, les données d'acquisition et les résultats du projet global. Sélectionnez les données à transférer au système de vision In-Sight du PLC/MC ou de l'automate et cliquez sur le bouton OK.

    Remarque :
    • Par défaut, le symbole des données Projet.Nombre_inspections est ajouté automatiquement dans le tableau de données en sortie. Ce symbole alerte le PLC/MC ou l'automate que le système de vision In-Sight a terminé l'acquisition d'une nouvelle image et qu'une nouvelle série de résultats d'inspection est arrivée. Il est possible de supprimer ce symbole s’il n’est pas nécessaire à l’application.
    • Le paramètre Périphérique de destination de l'onglet Paramètres SLMP influence le type de données qui peuvent être ajoutées. Si le paramètre Destination est configuré sur un périphérique au format bit, vous pouvez, pour chaque adresse de bit, ajouter des données de type Boolean et les affecter à un bit particulier. Si le paramètre Destination est configuré sur un périphérique au format mot, le type de données peut être configuré et l'adresse de début correspond à l'adresse du périphérique de données de sortie et à l'offset du champ, en mots.
  3. Une fois les données ajoutées, elles apparaissent dans le tableau, indiquant le nom, le type, la taille, la valeur et le numéro de registre initial des données sélectionnées. À droite du tableau se trouve une fenêtre d'aperçu des registres, qui affiche comment les données sont formatées dans les registres du PLC/MC ou de l'automate.

  4. Pour personnaliser le type de données par défaut, sélectionnez un autre type de données sur la liste déroulante Type de données.

    Remarque :
    • Les options Type de données disponibles dépendent du paramètre Périphérique de destination défini sous l'onglet Paramètres SLMP. Lorsque le paramètre Périphérique de destination est configuré sur un périphérique au format bit, la liste déroulante Type de données inclut uniquement l'option Bit. Lorsque le paramètre Périphérique de destination est configuré sur un périphérique au format mot, la liste déroulante Type de données inclut les options suivantes : Bit, Nombre entier de 16 bits, Nombre entier non signé de 16 bits, Nombre entier de 32 bits, Virgule flottante de 32 bits et Chaîne.
    • Si vous sélectionnez Chaîne dans la liste déroulante Type de données, le contrôle Taille d'élément (mots) est activé et vous pouvez spécifier la longueur de chaîne en choisissant le nombre de mots approprié. Lorsque Série iQ-R/Q/L (trame 3E), Série iQ-F (trame 3E) ou Série CR800-D (trame 3E) est le Type d'automate sélectionné, la taille totale maximale des messages est de 960 mots. Lorsque Série FX (trame 1E) est le Type d'automate sélectionné, la taille maximale des messages est de 64 mots.
    • Lorsque Série iQ-R/Q/L (trame 3E), Série iQ-F (trame 3E) ou Série CR800-D (trame 3E) est le Type d'automate sélectionné, la longueur maximale des données de sortie est de 1.920 octets. Lorsque Série FX (trame 1E) est le type d'automate sélectionné, la longueur maximale des données de sortie est de 128 octets. La taille des données de sortie est affichée dans le champ Taille du message (octets).
    • Le bouton Remettre à zéro les types de données rétablit les paramètres par défaut de tous les types de données.
    • L'implémentation du protocole SLMP dans EasyBuilder ne prend pas en charge les types de données de 8 bits ou non signés.
  5. Vous pouvez réorganiser les données qui seront envoyées ou reçues en sélectionnant les données sur la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.


Configuration de l'onglet Paramètres (scanner SLMP)

L'onglet Paramètres du scanner SLMP permet de définir les informations sur les connexions requises pour établir une connexion avec le PLC/MC Mitsubishi.

Remarque :

Selon le Périphérique sélectionné dans la zone de groupe Configuration du périphérique, les Types d'automates présents dans l'onglet Paramètres diffèrent. Pour plus d'informations, reportez-vous à Communication avec les périphériques Mitsubishi.

Périphérique sélectionné (zone de groupe Configuration du périphérique) Types d'automate disponibles (onglet Paramètres)
PLC / Contrôleur de mouvement
  • Série iQ-R/Q/L (trame 3E)
  • Série iQ-F (trame 3E)
  • Série FX (trame 1E)
Automate
  • Série CR-800D (trame 3E)
Fermé Type de contrôleur

Définit le type de PLC/MC ou d'automate Mitsubishi avec lequel communiquer :

  • PLC/MC : Série iQ-R/Q/L (trame 3E), Série iQ-F (trame 3E) ou Série FX (trame 1E). Par défaut = Série iQ-R/Q/L (trame 3E).

    Remarque : L'option Série iQ-F (trame 3E) n'est pas disponible sur les systèmes de vision In-Sight exécutant le micrologiciel In-Sight 4.x.x.
  • Automate : Série CR800-D (trame 3E)
Fermé Adresse IP

Définit l'adresse IP du PLC/MC ou de l'automate Mitsubishi. Saisissez l'adresse IP du PLC/MC ou de l'automate Mitsubishi qui sera connecté au système de vision In-Sight.

Fermé Port d'hôte

Définit le numéro du portTCP, au format décimal (Dec) ou hexadécimal (Hex), du PLC/contrôleur de mouvement ou de l'automate Mitsubishi (1 - 65535 en décimal, 1 - 0xFFFF en hexadécimal ; valeur par défaut = 12288 en décimal).

Remarque :
  • Cette valeur doit correspondre au paramètre Port d'hôte défini sur le port SLMP du PLC/MC ou de l'automate Mitsubishi.
  • Le format du numéro de port d'hôte est réinitialisé en décimales (Dec) lorsque vous fermez In-Sight Explorer.
Fermé Délai (ms)

Définit le délai d'expiration (5 à 30 000 millisecondes ; valeur par défaut = 1 000 ms) des opérations de lecture et d'écriture.

Remarque : Ce paramètre peut allonger la durée du projet. Si les opérations de lecture et d'écriture échouent toutes les deux, leurs délais s'accumulent et la durée ajoutée au projet correspond alors au double de la valeur Délai.
Fermé Intervalle d'interrogation (ms)

Définit la durée (5 à 30.000 millisecondes ; valeur par défaut = 1.000 ms) entre les interrogations successives du bloc de contrôles de vision sur le PLC/MC ou l'automate Mitsubishi.

Fermé Se connecter à la station distante
  • Lorsque cette case est cochée et que Série iQ-R/Q/L (trame 3E), Série iQ-F (trame 3E) or Série CR800-D (trame 3E) est le Type d'automate sélectionné, les contrôles Numéro de réseau, Numéro d'ordinateur et Module de destination sont activés.
  • Lorsque cette case est cochée et que Série FX (trame 1E) est le Type d'automate sélectionné, le contrôle Numéro d'ordinateur est activé.

Par défaut, la case est décochée et le système de vision In-Sight est directement connecté au PLC/MC ou à l'automate avec un module Ethernet spécifié par l'adresse IP entrée.

Fermé Numéro de réseau

Définit le numéro de réseau du protocole SLMP (0 à 239 ; valeur par défaut = 0, réseau local) avec lequel communiquer. Cette zone est activée lorsque la case Se connecter à la station distante est cochée.

Fermé Numéro d'ordinateur (hex)

Définit l'identifiant de station sur le réseau spécifié du Module de destination, au format hexadécimal. Cette zone est activée lorsque la case Se connecter à la station distante est cochée.

Hexadécimal | Description
0xFF (valeur par défaut) | Connexion directe à la station locale
0x7E | Station maître sur le champ CC-Link IE.
0x1 - 0x78 | Station sur la carte réseau du champ CC-Link IE.
Fermé Module de destination

Définit l'identifiant du module du périphérique auquel se connecter. Cette zone est activée lorsque la case Se connecter à la station distante est cochée.

Type de module
03ff - Station locale (valeur par défaut)
0x3d0 - Processeur de système de contrôle
0x3d1 - Processeur de système en attente
0x3d2 - Processeur de système A
0x3d3 - Processeur de système B
0x3e0 - Processeur 1
0x3e1 - Processeur 2
0x3e2 - Processeur 3
0x3e3 - Processeur 4
Fermé Bouton Remise à zéro

Permet de restaurer tous les paramètres par défaut.

Fermé Bouton Tester la connexion

Démarre la connexion avec le PLC/MC ou l'automate Mitsubishi pour la tester.


Configuration de l’onglet Adressage du périphérique (SLMP Scanner)

L’onglet Adressage du périphérique du protocole SLMP Scanner permet de définir l’adresse du PLC/MC ou de l’automate et la taille des divers blocs de données à communiquer au PLC/MC ou à l’automate. Le Type de périphérique et la taille des blocs de données varient en fonction du Type de contrôleur (série iQ-R/Q/L, série iQ-F ou série FX ou série CR800-D) défini dans l’onglet Paramètres .

Fermé Nom

Nom du bloc de données pouvant être échangé avec le PLC/MC ou l’automate Mitsubishi.

Fermé Périphérique sélectionné

Définit le PLC/MC ou l’automate Mitsubishi utilisé pour lire ou écrire le bloc de données. La liste déroulante comprend les options suivantes :

Type de périphérique | Format | PLC/MC |  |  | Automate
 |  | Série iQ-R/Q/L (trame 3E) | Série iQ-F (trame 3E) | Série FX (trame 1E) | Série CR800-D (trame 3E)
X - Relais d’entrée* | Bit | X | X | X |
Y - Relais de sortie* | Bit | X | X | X |
M - Relais interne* | Bit | X | X | X |
L - Relais de verrouillage* | Bit | X |  |  |
F - Indicateur* | Bit | X | X |  |
B - Relais de liaison* | Bit | X |  |  |
D - Registre de données | Mot | X | X | X | X
W - Registre de liens | Mot | X |  |  |
R - Registre de groupes de fichiers | Mot | X |  |  |
ZR - Registre de fichiers | Mot | X |  |  |
R - Registre d’extension | Mot |  |  | X |
S - Relais d’état* | Bit |  |  | X |
*Pris en charge uniquement par les blocs de données Contrôle et État .
Remarque :
  • Lorsque l’option Périphérique sélectionné est réglée sur Aucun, redémarrez le système de vision In-Sight une fois que les paramètres du SLMP Scanner ont été configurés ou modifiés.
  • Si Aucun est sélectionné, le bloc de données ne sera pas communiqué.
  • Les périphériques Valeur de temps et Valeur du compteur ne sont pas pris en charge.
Fermé Offset

Définit l’offset de lecture ou écriture du bloc de données dans le tableau de périphériques. La valeur d’offset doit être saisie au format décimal, hexadécimal ou octal, selon le type de Périphérique sélectionné .

Type de périphérique | Valeur | PLC/MC |  |  | Automate
 |  | Série iQ-R/Q/L (trame 3E) | Série iQ-F (trame 3E) | Série FX (trame 1E) | Série CR800-D (trame 3E)
X - Relais d’entrée* | Hexadécimal | X | X | X |
Y - Relais de sortie* | Hexadécimal | X | X | X |
M - Relais interne* | Décimale | X | X | X |
L - Relais de verrouillage* | Décimale | X |  |  |
F - Indicateur* | Décimale | X | X |  |
B - Relais de liaison* | Hexadécimal | X |  |  |
D - Registre de données | Décimale | X | X | X | X
W - Registre de liens | Hexadécimal | X |  |  |
R - Registre de groupes de fichiers | Décimale | X |  |  |
ZR - Registre de fichiers | Décimale | X |  |  |
R - Registre d’extension | Décimale |  |  | X |
S - Relais d’état* | Décimale |  |  | X |
*Pris en charge uniquement par les blocs de données Contrôle et État .
Fermé Nombre de périphériques

Définit la taille du bloc de données échangé avec le PLC/MC ou l’automate Mitsubishi. La taille est spécifiée dans les unités des « périphériques » PLC/MC ou automate (mots ou bits). La taille maximale des données pour le Bloc d’entrée, le Bloc de sortie, la Commande et le Résultat de la commande varie en fonction du Type de contrôleur sélectionné (série iQ-R/Q/L, série iQ-F, série FX ou série CR800-D).

Nom du bloc | Nombre de périphériques
 | Série iQ-R/Q/L, Série iQ-F, Série CR800-D | FX Series
Contrôle | 32 bits (en lecture seule)
État | 32 bits (en lecture seule)
Bloc d’entrée | 4 + longueur des données d’entrée (maximum : 960 mots) | 4 + longueur des données d’entrée (maximum : 64 mots)
Bloc de sortie | 12 + longueur des données de sortie (maximum : 960 mots) | 12 + longueur des données de sortie (maximum : 64 mots)
Commande | 0 - 960 mots | 0 - 64 mots
Résultat de la commande | 0 - 960 mots | 0 - 64 mots
Remarque :

Un automate de la série iQ-R/Q/L, iQ-F ou CR800-D peut gérer la plupart des formats de trame de message disponibles actuellement (trame 3E). Toutefois, l’automate de la série FX peut gérer uniquement la première génération de trame de message de protocole (trame 1E), et la quantité de données pouvant être transmise dans un paquet est limitée.

 | Taille maximale des données
 | Série iQ-R/Q/L, Série iQ-F, Série CR800-D | Série FX
Bits de lecture de lot | 7904 bits | 256 bits
Mots de lecture de lot | 960 mots | 64 mots
Bits d’écriture de lot | 7904 bits | 160 bits
Mots d’écriture de lot | 690 mots | 64 mots
Fermé Description

Description textuelle du bloc de données.


Configuration des onglets Formater les données de sortie et Formater les données d'entrée (Scanner SLMP)

Après avoir configuré les onglets Paramètres et Adressage du périphérique, vous devez configurer les onglets Formater les données d'entrée et Formater les données de sortie, qui définissent les données d'outil ou de projet à échanger entre le PLC/MC ou l'automate Mitsubishi et le système de vision In-Sight.

Fermé Configuration de l'onglet Formater les données d'entrée

L'onglet Formater les données d'entrée permet de définir les entrées sur le système de vision In-Sight. 32 entrées maximum peuvent être définies par projet.

  1. Cliquez sur l'onglet Formater les données d'entrée pour commencer à configurer les données à transférer du PLC/MC ou de l'automate au système de vision In-Sight.
  2. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données d'entrée, qui contient les données du projet, telles que les outils de recherche ou d'inspection ajoutés au projet, les données d'acquisition et les entrées.Sélectionnez les données à transférer au système de vision In-Sight du PLC/MC ou de l’automate et cliquez sur le bouton OK.
  3. Une fois les données ajoutées, elles apparaissent dans le tableau, indiquant l’Adresse du périphérique, le nom, le type, la taille et la valeur de l’entrée.

  4. Pour personnaliser le type de données par défaut, sélectionnez un autre type de données sur la liste déroulante Type de données.

    Remarque :
    • Si vous sélectionnez Chaîne ou Chaîne convertie en octets dans la liste déroulante Type de données, le contrôle Taille d'élément (mots) est activé et vous pouvez spécifier la longueur de chaîne en choisissant le nombre de mots approprié.
    • Lorsque Série iQ-R/Q/L (trame 3E), Série iQ-F (trame 3E) ou Série CR800-D (trame 3E) est le Type d'automate sélectionné, la taille totale maximale des messages est de 960 mots.Lorsque Série FX (trame 1E) est le Type d'automate sélectionné, la taille maximale des messages est de 64 mots.
    • Lorsque Série iQ-R/Q/L (trame 3E), Série iQ-F (trame 3E) ou Série CR800-D (trame 3E) est le Type d'automate sélectionné, la longueur totale maximale des données d'entrée est de 1.920 octets.Lorsque Série FX (trame 1E) est le type d'automate sélectionné, la longueur maximale des données d'entrée est de 128 octets.La taille des données d'entrée est affichée dans le champ Taille du message (octets).
    • Le bouton Remettre à zéro les types de données rétablit les paramètres par défaut de tous les types de données.
    • L'implémentation du scanner SLMP dans EasyBuilder ne prend pas en charge les types de données de 8 bits.

  5. Vous pouvez également personnaliser l'ordre des octets en spécifiant Octet de poids faible en premier ou Octet de poids fort en premier en décochant la case Octet de poids fort/Octet de poids faible (elle est décochée par défaut pour tous les protocoles sauf PROFINET). Vous pouvez personnaliser l'ordre des mots en spécifiant Mot de poids faible en premier ou Mot de poids fort en premier en décochant la case Mot de poids fort/Mot de poids faible (elle est décochée par défaut).

    Remarque : Toute modification apportée à l'ordre des octets ou des mots affectera l'ensemble des signaux de données dans les onglets Formater les données de sortie et Formater les données d'entrée.

  6. Vous pouvez réorganiser les données qui seront envoyées ou reçues en sélectionnant les données sur la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.

Fermé Configuration de l'onglet Formater les données de sortie

L'onglet Formater les données de sortie permet de définir les sorties du système de vision In-Sight. 128 sorties maximum peuvent être définies par projet.

  1. Cliquez sur l'onglet Formater les données de sortie pour commencer à configurer les données à transférer du système de vision In-Sight au PLC/MC ou à l'automate.
  2. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données de sortie qui contient les données du projet, telles que les outils de recherche ou d'inspection ajoutés au projet, les données d'acquisition et les résultats du projet global. Sélectionnez les données à transférer au système de vision In-Sight du PLC/MC ou de l'automate et cliquez sur le bouton OK.
  3. Une fois les données ajoutées, elles apparaissent dans le tableau, indiquant le nom, le type, la taille, la valeur et le numéro de registre initial des données sélectionnées. À droite du tableau se trouve une fenêtre d'aperçu des registres, qui affiche comment les données sont formatées dans les registres du PLC/MC ou de l'automate.

  4. Pour personnaliser le type de données par défaut, sélectionnez un autre type de données sur la liste déroulante Type de données.

    Remarque :
    • Si vous sélectionnez Chaîne ou Chaîne convertie en octets dans la liste déroulante Type de données, le contrôle Taille d'élément (mots) est activé et vous pouvez spécifier la longueur de chaîne en choisissant le nombre de mots approprié.
    • Lorsque Série iQ-R/Q/L (trame 3E), Série iQ-F (trame 3E) ou Série CR800-D (trame 3E) est le Type d'automate sélectionné, la taille totale maximale des messages est de 960 mots. Lorsque Série FX (trame 1E) est le Type d'automate sélectionné, la taille maximale des messages est de 64 mots.
    • Lorsque Série iQ-R/Q/L (trame 3E), Série iQ-F (trame 3E) ou Série CR800-D (trame 3E) est le Type d'automate sélectionné, la longueur maximale des données de sortie est de 1.920 octets. Lorsque Série FX (trame 1E) est le type d'automate sélectionné, la longueur maximale des données de sortie est de 128 octets. La taille des données de sortie est affichée dans le champ Taille du message (octets).
    • Le bouton Remettre à zéro les types de données rétablit les paramètres par défaut de tous les types de données.
    • L'implémentation du scanner SLMP dans EasyBuilder ne prend pas en charge les types de données de 8 bits.
  5. Vous pouvez également personnaliser l'ordre des octets en spécifiant Octet de poids faible en premier ou Octet de poids fort en premier en décochant la case Octet de poids fort/Octet de poids faible (elle est décochée par défaut pour tous les protocoles sauf PROFINET). Vous pouvez personnaliser l'ordre des mots en spécifiant Mot de poids faible en premier ou Mot de poids fort en premier en décochant la case Mot de poids fort/Mot de poids faible (elle est décochée par défaut). Toute modification sera mise à jour dans la fenêtre d'aperçu.
  6. Vous pouvez réorganiser les données qui seront envoyées ou reçues en sélectionnant les données sur la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.


Configuration des communications de chaîne du robot Mitsubishi en mode Ethernet natif

Les données provenant de projets EasyBuilder, notamment les résultats d'outils individuels ou de projets peuvent être communiquées à un contrôleur de robot (automate). Une fois les données sélectionnées et mise en forme en une chaîne de caractères, le contrôleur de robot peut récupérer ces données par le biais d’une seule commande en mode natif In-Sight, GetValue (GVJob.Robot.FormatString). Celle-ci renvoie les données mises au format chaîne de caractères.

Remarque : Le capteur de vision In-Sight série 2000 ne prend pas en charge les automates/contrôleurs de robot.

Pour mettre vos données en format dans une chaîne de caractères permettant de les communiquer en mode natif :

Remarque : Le système de vision In-Sight doit être en Hors ligne.
  1. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données de sortie, qui contient les données des outils de recherche ou d'inspection ajoutés au projet, ainsi que d'autres données du projet, comme les données d'acquisition et d'entrée.
  2. Dans la boîte de dialogue Sélectionner les données de sortie, sélectionnez les données à envoyer depuis le système de vision In-Sight, puis cliquez sur le bouton OK. Il est possible de sélectionner un maximum de 40 données pour une chaîne.
  3. Une fois les données ajoutées, l'ordre de celles-ci peut être modifié en sélectionnant une donnée sur la liste et en cliquant sur le bouton Haut ou Bas pour définir l'ordre souhaité. De même, vous pouvez supprimer des données indésirables en cliquant sur le bouton Supprimer.
  4. Si l'une des données est de type virgule flottante, le contrôle Virgules décimales est activé et le nombre de chiffres après la virgule pour les valeurs à virgule flottante peut être défini (0-6 ; valeur par défaut = 3).
  5. Dans la fenêtre à droite de la liste de données, la chaîne formatée s'affiche, ainsi que sa longueur (nombre de caractères dans la chaîne) à titre de référence. Une virgule est insérée automatiquement pour délimiter les valeurs dans la chaîne.
  6. Une fois la chaîne formatée, l'automate peut demander la chaîne de données en envoyant la commande de mode natif In-Sight, GetValue (GVJob.Robot.FormatString).


Configuration des communications de chaîne du robot Mitsubishi en mode natif série

Les données provenant de projets EasyBuilder, notamment les résultats d'outils individuels ou de projets peuvent être communiquées à un contrôleur de robot (automate). Une fois les données sélectionnées et mise en forme en une chaîne de caractères, le contrôleur de robot peut récupérer ces données par le biais d’une seule commande en mode natif In-Sight, GetValue (GVJob.Robot.FormatString). Celle-ci renvoie les données mises au format chaîne de caractères.

Remarque : Le capteur de vision In-Sight série 2000 ne prend pas en charge les automates/contrôleurs de robot.

Pour mettre vos données en format dans une chaîne de caractères permettant de les communiquer en mode natif :

Remarque : Le système de vision In-Sight doit être en Hors ligne.
  1. Cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données de sortie, qui contient les données des outils de recherche ou d'inspection ajoutés au projet, ainsi que d'autres données du projet, comme les données d'acquisition et d'entrée.
  2. Dans la boîte de dialogue Sélectionner les données de sortie, sélectionnez les données à envoyer depuis le système de vision In-Sight, puis cliquez sur le bouton OK. Il est possible de sélectionner un maximum de 40 données pour une chaîne.
  3. Une fois les données ajoutées, l'ordre de celles-ci peut être modifié en sélectionnant une donnée sur la liste et en cliquant sur le bouton Haut ou Bas pour définir l'ordre souhaité. De même, vous pouvez supprimer des données indésirables en cliquant sur le bouton Supprimer.
  4. Si l'une des données est de type virgule flottante, le contrôle Virgules décimales est activé et le nombre de chiffres après la virgule pour les valeurs à virgule flottante peut être défini (0-6 ; valeur par défaut = 3).
  5. Dans la fenêtre à droite de la liste de données, la chaîne formatée s'affiche, ainsi que sa longueur (nombre de caractères dans la chaîne) à titre de référence. Une virgule est insérée automatiquement pour délimiter les valeurs dans la chaîne.
  6. Une fois la chaîne formatée, l'automate peut demander la chaîne de données en envoyant la commande de mode natif In-Sight, GetValue (GVJob.Robot.FormatString).

  7. Le cas échéant, cliquez sur l'onglet Paramètres du port série pour définir les paramètres de communication série. EasyBuilder détermine automatiquement le protocole série en fonction des sélections effectuées dans la zone de groupe Configuration du périphérique. Les paramètres du port série sont enregistrés dans le système de vision In-Sight à la fin de l'étape Communication.

    Remarque :

    • Les options Paramètres du port série varient selon le modèle In-Sight et le module d'E/S applicable. Si le système est connecté à un module d'E/S pris en charge, commencez par cliquer sur le bouton Module d'E/S pour ouvrir la boîte de dialogue de configuration du module d'E/S et configurer le module d'E/S.

    • Les systèmes de vision In-Sight Micro série 1000 prennent en charge la communication série uniquement lorsqu'ils sont connectés au module CIO-MICRO ou E/S CIO-Micro-CC.

    • Il existe deux options pour activer la communication série pour le système de vision In-Sight série 70xx - 74xx : utiliser le câble breakout ou le module d'E/S CIO-MICRO ou CIO-MICRO-CC. Lorsqu'il est branché au câble breakout (sans connexion à un module d'E/S), le système de vision permet de configurer une ligne d'entrée discrète et une ligne de sortie discrète en tant que Réception série et Transmission série, respectivement.
    • Les systèmes de vision In-Sight série 8000 prennent en charge la communication série uniquement lorsqu'ils sont connectés au module E/S CIO-MICRO.

    • Le module d'E/S CIO-WENET ne prend pas en charge les communications série.


Communication via TCP/IP

Un capteur In-Sight peut être configuré pour agir en tant que périphérique client TCP/IP, en ouvrant une connexion entre le capteur In-Sight et un autre périphérique TCP/IP afin de partager des données sur le réseau. Une fois la connexion TCP/IP établie, EasyBuilder initialise la communication avec un autre périphérique TCP/IP sur le réseau.

Pour configurer un capteur In-Sight pour le service TCP/IP de périphérique client :

  1. Dans la zone de groupe Communications, cliquez sur le bouton Ajouter un périphérique.
  2. Dans la zone de groupe Configuration du périphérique, sélectionnez Autre sur la liste déroulante Périphérique.
  3. Sélectionnez TCP/IP dans la liste déroulante Protocole.
  4. Cliquez sur le bouton OK.
  5. Cliquez sur l'onglet Paramètres TCP/IP et saisissez le nom du périphérique de service TCP/IP avec lequel la connexion doit être établie dans le champ Nom d'hôte du serveur.

  6. Dans le champ Port, saisissez le numéro de port du serveur TCP/IP sur lequel la connexion entre les périphériques TCP/IP sera établie. Le numéro de port saisi doit également être affecté sur le serveur.

    Remarque : un port valide correspond à tout numéro inutilisé compris entre 1 et 65535, à l'exception des ports utilisés pour les communications In-Sight. Les utilisateurs de l'émulateur In-Sight doivent toujours affecter les numéros de port 3000 (le port par défaut) et supérieurs pour éviter les conflits potentiels avec les ports réservés à des services sur le PC.
  7. Le nombre de millisecondes (100 à 15000 ; 1000 par défaut) d'attente d'une connexion TCP/IP avant l'abandon de la tentative de connexion dans le champ Délai d'attente.

  8. Sur la liste déroulante Terminaison, sélectionnez Chaîne avec terminaison personnalisée pour indiquer un caractère ASCII (0 à 255).

    Fermé Descriptions des terminaisons client des chaînes
    Terminaison | Description
    Chaîne CR+LF (par défaut) | Les caractères ASCII 13 (retour chariot) et 10 (saut de ligne) sont attachés à la chaîne de données.
    Chaîne CR (13) | Le caractère ASCII 13 (retour chariot) est attaché à la chaîne de données.
    Chaîne LF (10) | Le caractère ASCII 10 (saut de ligne) est attaché à la chaîne de données.
    Chaîne Nullchar (0) | Le caractère ASCII 0 (zéro) est attaché à la chaîne de données.
  9. Une fois les paramètres TCP/IP définis, cliquez sur Chaîne de données de sortie pour sélectionner et formater les données qui seront transmises.
Remarque : Le protocole TCP/IP est un protocole « secondaire », il peut être ajouté à un projet en plus du protocole « primaire ». Pour en savoir plus, reportez-vous à la rubrique Protocoles pris en charge sur Configuration du périphérique.


Communication via UDP

Un système de vision In-Sight peut être configuré pour servir de serveur UDP ou de périphérique client, en ouvrant une connexion entre le système de vision et un autre périphérique UDP afin de partager des données sur le réseau.

Le protocole UDP (User Datagram Protocol), alternative à TCP, est une méthode de transport de communications sans connexion qui propose une quantité limitée de services lorsque des messages sont échangés avec le protocole Internet. Contrairement à TCP, UDP n'accuse pas réception et ne garantit pas la livraison, et ne fournit pas non plus de paquets de séquencement.

Pour configurer un système de vision comme périphérique client ou serveur pour le service UDP :

  1. Dans la zone de groupe Communications, cliquez sur le bouton Ajouter un périphérique.
  2. Dans la zone de groupe Configuration du périphérique, sélectionnez Autre sur la liste déroulante Périphérique.
  3. Sélectionnez UDP dans la liste déroulante Protocole.
  4. Cliquez sur le bouton OK.
  5. Vous devez ensuite configurer l'onglet Paramètres UDP, puis sélectionner une chaîne d'entrée et une chaîne de sortie (le cas échéant).
Fermé Onglet Paramètres UDP
Fermé Mode

Définit si le système de vision In-Sight sera configuré comme client ou serveur (Client, Client avec réponse, Serveur ou Serveur avec réponse ; par défaut = Client). Dans le paradigme de communication UDP, un client est un système qui accède à un service distant sur un autre système informatique (le serveur) par le biais d'un réseau ; tandis qu'un serveur est un périphérique en réseau qui gère les demandes de données d'un autre périphérique en réseau.

  • Client : le système de vision transmet des données au serveur indiqué.
  • Client avec réponse : le système de vision transmet des données au serveur indiqué, puis attend un message de réponse du serveur pendant la limite de temps définie dans le paramètre Délai d'attente.
  • Serveur : le système de vision reçoit des données en tant que serveur indiqué.
  • Serveur avec réponse : le système de vision reçoit des données en tant que serveur indiqué, puis retourne un message de réponse au périphérique client.
Fermé Nom d'hôte du serveur

Définit le nom d'hôte ou l'adresse IP du serveur UDP. Si le paramètre Mode est défini sur Serveur ou Serveur avec réponse, ce paramètre est désactivé.

Fermé Port

Définit le numéro du port de communication entre le serveur UDP et le périphérique UDP. Si le système de vision In-Sight est configuré comme Serveur et qu'un Nom d'hôte de serveur a été saisi, le paramètre Port affecte le numéro de port à ce périphérique. Si le système de vision est configuré comme Client, le numéro de port doit être identique à celui du serveur UDP.

Fermé Délai d'attente

Définit la durée en millisecondes (100 à 15 000 ; par défaut = 1000) nécessaire pour recevoir une réponse du périphérique serveur lorsqu'un message est envoyé par le périphérique client.

Remarque : Le paramètre Délai d'attente est activé uniquement quand le paramètre Mode est défini sur Client avec réponse.
Fermé Onglet Chaîne d'entrée

L'onglet Chaîne d'entrée permet de définir une chaîne représentant l'entrée d'un autre périphérique dans une entrée de chaîne d'un outil EasyBuilder, par exemple un paramètre Chaîne de correspondance d'un outil d'identification Lire les codes ID , Lire le code 1D, Lire les codes 1D (1-20), Lire le code 2D, Lire les codes 2D (1-20), Lire le code postal ou Lire le texte durant l'étape Inspecter une pièce.

Remarque : L'onglet Chaîne d'entrée est désactivé si le paramètre Mode est défini sur Client.
Fermé Nom d'entrée

Dans le menu déroulant, sélectionnez le projet EasyBuilder ou la propriété d'outil qui sera entrée.

Remarque : Pour saisir une chaîne de texte à partir d'un périphérique externe, tel qu'un PLC ou un ordinateur, afin de l'utiliser avec un outil d'identification, consultez la rubrique : Entrée de données pour les outils d'identification.

Fermé Chaîne de données de sortie

L'onglet Chaîne de données de sortie permet de définir les données qui seront envoyées au serveur UDP quand le paramètre Mode est configuré comme Client, Client avec réponse ou Serveur avec réponse.

Remarque : L'onglet Chaîne de données de sortie est désactivé si le paramètre Mode est défini sur Serveur.
Fermé Format de la chaîne
  1. Dans l'onglet Chaîne de données de sortie, cliquez sur le bouton Format de la chaîne, qui ouvrira la boîte de dialogue FormatString, dans laquelle vous pouvez ajouter, personnaliser et modifier l'ordre des données envoyées.
  2. Dans la boîte de dialogue FormatString, cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données de sortie.
  3. La boîte de dialogue Sélectionner les données de sortie contient les données de tous les outils de recherche ou d'inspection ajoutés à votre projet, ainsi que les résultats du projet global. Dans la boîte de dialogue, sélectionnez les données à envoyer depuis le capteur In-Sight, puis cliquez sur le bouton OK.
  4. Lorsque les données ont été sélectionnées dans la boîte de dialogue Sélectionner les données de sortie, la boîte de dialogue FormatString s'affiche à nouveau.
  5. Vous pouvez modifier les chaînes et/ou réorganiser l'ordre des données qui seront envoyées en sélectionnant les données sur la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité. Une fois les chaînes modifiées, cliquez sur le bouton OK.
  6. Maintenant que la chaîne a été formatée, les données de sortie seront envoyées une fois que le capteur aura terminé l'exécution du projet.
Remarque : le protocole UDP est un protocole « secondaire », il peut être ajouté à un projet en plus d'un protocole « primaire ». Pour en savoir plus, reportez-vous à la rubrique Protocoles pris en charge sur Configuration du périphérique.


Communication via POWERLINK

Remarque : Ce protocole est disponible uniquement sur les systèmes de vision In-Sight exploitant le micrologiciel In-Sight 4.x.x, mais pas sur les systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.1.0 et ultérieures. Reportez-vous à Versions du micrologiciel pour obtenir une liste complète des modèles et des versions du micrologiciel prises en charge.

Il est possible de configurer un système de vision In-Sight pour communiquer avec le réseau POWERLINK.

Pour communiquer via POWERLINK, procédez d'abord comme suit :

  1. Accédez à l'étape d'application Communication. Dans la zone de groupe Communications, cliquez sur le bouton Ajouter un périphérique.
  2. Dans la zone de groupe Configuration du périphérique, sélectionnez PLC dans la liste déroulante Périphérique.
  3. Sélectionnez B&R dans la liste déroulante Fabricant.
  4. Sélectionnez POWERLINK dans la liste déroulante Protocole.
  5. Cliquez sur le bouton OK.

Une fois ces paramètres activés, les onglets Paramètres et Formater les données d'entrée/sortie peuvent être configurés.

  • Fermé Onglet Paramètres POWERLINK

    Activé : active POWERLINK sur le système de vision In-Sight (par défaut = non coché).

    ID de nœud : Définit l'ID de nœud (1 à 239, par défaut = 1) du système de vision In-Sight sur le réseau POWERLINK. Ce contrôle est activé lorsque la case Activé est cochée. L'ID de nœud, ajouté à l'adresse IP NAT du réseau POWERLINK, peut être utilisé pour communiquer avec les autres périphériques hors du réseau POWERLINK. Par exemple, l'adresse IP NAT par défaut est 192.168.101.0. Pour communiquer avec un système de vision In-Sight dont l'ID de noeud est 26, combinez l'adresse IP NAT à l'ID de noeud : 192.168.101.26.

    Remarque : le système de vision In-Sight doit être redémarré pour activer le protocole POWERLINK.

  • Onglet Formater les données d'entrée/sortie

    Remarque :
    • Pour des informations complémentaires, consultez le fichier d’aide In‑Sight® Explorer.
    • En option, cliquez à nouveau sur le bouton Ajouter un périphérique pour ajouter un protocole secondaire supplémentaire au projet. Pour en savoir plus, reportez-vous à la rubrique Protocoles pris en charge sur Configuration du périphérique.


Entrée de données pour les outils d'identification

Pour saisir une chaîne de texte à partir d'un périphérique externe, tel qu'un PLC ou un ordinateur, afin de l'utiliser avec un outil d'identification, procédez comme suit :

  1. Ajoutez un outil d'identification Lire les codes ID, Lire le code 1D, Lire les codes 1D (1-20), Lire le code 2D, Lire les codes 2D (1-20), Lire le code postal ou Lire le texte à l'étape Inspecter une pièce.
  2. Dans l'onglet Paramètres de l'outil Lire les codes ID , Lire le code 1D, Lire les codes 1D (1-20), Lire le code 2D, Lire les codes 2D (1-20) ou Lire le code postal, définissez le Mode sur Chaîne de correspondance ; pour l'outil Lire le texte, définissez le Mode sur Vérifier ou Lire et Vérifier.
  3. Sélectionnez l'étape d'application Communication.
  4. Dans la zone de groupe Communications, cliquez sur le bouton Ajouter un périphérique.
  5. Dans la zone de groupe Configuration du périphérique, sélectionnez Autre sur la liste déroulante Périphérique.
  6. Sélectionnez Texte série dans le menu déroulant Protocole.
  7. Cliquez sur le bouton OK.
  8. Cliquez sur l'onglet Chaîne d'entrée.
  9. Sur la liste déroulante Nom d'entrée, sélectionnez l'entrée Chaîne de correspondance de l'outil souhaité. EasyBuilder examinera automatiquement le projet et inclura toutes les entrées Chaîne de correspondance des outils définis dans le projet.

  10. Cliquez sur l'onglet Paramètres du port série et adaptez les paramètres à votre application, si nécessaire.

    Remarque :

    • Les options Paramètres du port série varient selon le modèle In-Sight et le module d'E/S applicable. Si le système est connecté à un module d'E/S pris en charge, commencez par cliquer sur le bouton Module d'E/S pour ouvrir la boîte de dialogue de configuration du module d'E/S et configurer le module d'E/S.

    • Les systèmes de vision In-Sight Micro série 1000 prennent en charge la communication série uniquement lorsqu'ils sont connectés au module CIO-MICRO ou E/S CIO-Micro-CC.

    • Il existe deux options pour activer la communication série pour le système de vision In-Sight série 70xx - 74xx : utiliser le câble breakout ou le module d'E/S CIO-MICRO ou CIO-MICRO-CC. Lorsqu'il est branché au câble breakout (sans connexion à un module d'E/S), le système de vision permet de configurer une ligne d'entrée discrète et une ligne de sortie discrète en tant que Réception série et Transmission série, respectivement.
    • Les systèmes de vision In-Sight série 8000 prennent en charge la communication série uniquement lorsqu'ils sont connectés au module E/S CIO-MICRO.

    • Le module d'E/S CIO-WENET ne prend pas en charge les communications série.

  11. Cliquez sur l'onglet Chaîne de données de sortie, puis cliquez sur le bouton Format de la chaîne, qui ouvrira la boîte de dialogue FormatString, dans laquelle vous pouvez sélectionner et formater le résultat de votre outil.

    Remarque : Les outils Lire les codes ID ou Lire le texte seront en Échec et le champ Chaîne de correspondance affichera TRIG jusqu'à ce que Chaîne de correspondance soit saisi sur le périphérique externe.
  12. Dans la boîte de dialogue FormatString, cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue Sélectionner les données de sortie.
  13. La boîte de dialogue Sélectionner les données de sortie contient les données de tous les outils de recherche ou d'inspection ajoutés à votre projet, ainsi que les résultats du projet global. Dans la boîte de dialogue, sélectionnez les données à envoyer depuis le capteur In-Sight, puis cliquez sur le bouton OK.
  14. Lorsque les données ont été sélectionnées dans la boîte de dialogue Sélectionner les données de sortie, la boîte de dialogue FormatString s'affiche à nouveau.
  15. Vous pouvez modifier les chaînes et/ou réorganiser l'ordre des données qui seront envoyées en sélectionnant les données sur la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité. Une fois les chaînes modifiées, cliquez sur le bouton OK.
  16. Maintenant que la chaîne a été formatée, les données de sortie seront envoyées une fois que le capteur aura terminé l'exécution du projet.
  17. Une fois que le capteur In-Sight a été mis hors ligne, l'outil reçoit la chaîne d'entrée et tente de lire et/ou de vérifier la chaîne au sein de l'image.


Formatage des chaînes de sortie

  1. Sur l'onglet Chaîne de données de sortie, cliquez sur le bouton Format pour ouvrir la boîte de dialogue FormatString, qui vous permet d'ajouter, de personnaliser et de modifier l'ordre des données envoyées au robot.

  2. Dans la boîte de dialogue FormatString, cliquez sur le bouton Ajouter pour ouvrir la boîte de dialogue de Sélectionner les données de sortie.

    Fermé Exemple - Boîte de dialogue Sélectionner les données de sortie

  3. La boîte de dialogue Sélectionner les données de sortie contient les données de tous les outils de recherche ou d'inspection qui ont été ajoutés à votre projet. Dans la boîte de dialogue, sélectionnez les données à envoyer depuis le capteur In-Sight, puis cliquez sur le bouton OK.
  4. Lorsque les données ont été sélectionnées dans la boîte de dialogue Sélectionner les données de sortie, la boîte de dialogue FormatString s'affiche à nouveau.

  5. Vous pouvez modifier les chaînes et/ou réorganiser l'ordre des données qui seront envoyées en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité. Une fois les chaînes modifiées, cliquez sur le bouton OK.

    Fermé Exemple - Boîte de dialogue FormatString

  6. Maintenant que la chaîne a été formatée, les données de sortie seront envoyées quand le capteur aura terminé d'exécuter le projet.


Communications avec des PLC Rockwell ControlLogix

Cette section explique comment transférer des données entre un système de vision In-Sight et un PLC ControlLogix ou CompactLogix sur un réseau Ethernet/IP à l'aide du logiciel Rockwell RSLogix 5000.

Configuration des systèmes de vision In-Sight dans la structure d’E/S de RSLogix

Configuration des systèmes de vision In-Sight pour les communications PLC

Exemple de chargement d’un projet de système de vision In-Sight à partir d’un PLC RSLogix


Configuration du système de vision In-Sight dans la structure d'E/S de RSLogix

Les étapes pour configurer une connexion implicite et le transfert de données dépendent de la version du micrologiciel installé sur le capteur de vision et de la version du logiciel RSLogix 5000. Pour des informations détaillées, consultez la rubrique Communication avec un PLC Rockwell ControlLogix dans l'aide In-Sight® Explorer.

Intégration des systèmes de vision In-Sight au RSLogix 5000 v14-16

Intégration des systèmes de vision In-Sight Vision dans RSLogix 5000 v17-19

Intégration des systèmes de vision In-Sight Vision dans RSLogix 5000 v20

Objets d’assemblage d’entrée et de sortie du système de vision In-Sight


Intégration des systèmes de vision In-Sight au RSLogix 5000 v14-16

Cette rubrique couvre l'intégration des systèmes de vision In-Sight qui utilisent le micrologiciel In-Sight 5.2.0 ou une version ultérieure dans RSLogix 5000, version 14-16. Ces versions de RSLogix 5000 ne prennent pas en charge les fichiers EDS et un MODULE ETHERNET générique doit être utilisé à la place. In-Sight Explorer comprend des fichiers .L5X qui peuvent être utilisés pour copier les données de la balise du contrôleur PLC vers/depuis des balises de programme convivial, représentant des signaux dans le capteur de vision exécutant les versions de micrologiciel 5.2 et versions ultérieures.

  1. Ouvrez RSLogix 5000 et chargez le projet du PLC.

    Remarque : Le PLC doit être hors ligne pour ajouter des connexions dans RSLogix 5000.

  2. Ajoutez une connexion à votre carte de communication Ethernet. Dans le nœud de configuration des E/S, sélectionnez Nœud Ethernet dans le module Ethernet, cliquez avec le bouton droit de la souris sur l'icône, puis sélectionnez Nouveau module dans le menu.

  3. Dans l'onglet Catalogue de la boîte de dialogue Sélectionner un type de module, sélectionnez le filtre de catégorie du type de module Communication, Allen-Bradley comme filtre fournisseur du type de module, sélectionnez MODULE ETHERNET (Module Ethernet générique) et cliquez sur le bouton Créer.

  4. Dans la boîte de dialogue New Module (Nouveau module), entrez les informations suivantes :

    • Le nom et l'adresse IP du capteur de vision In-Sight.
    • Les paramètres de connexion (Connection Parameters). Pour les capteurs de vision In-Sight avec un micrologiciel de version 5.x.x, la section Objets d'assemblage d'entrée et de sortie définit l'instance d'assemblage Assembly Instance à configurer. Pour plus d'informations, reportez-vous à la rubrique PLC Rockwell ControlLogix – Micrologiciel In-Sight 5.x.x de l'aide In-Sight® Explorer.

  5. Après avoir ajouté le capteur de vision au projet RSLogix, le fichier d'importation de l'échelon L5X peut être utilisé pour créer des données structurées pour la connexion. Vous pouvez accéder au programme principal dans le dossier Tâches > Tâche principale > Programme principal du volet Organisateur du contrôleur.

    Remarque : S'il s'agit d'un nouveau programme en échelle, l'échelon vide 0 peut être utilisé. Si le capteur de vision est intégré à un programme existant, Cognex recommande d'ajouter un échelon en haut de l'échelle pour s'assurer que les données mises à jour sont lues et écrites dans les assemblages d'entrée et de sortie du capteur avant le reste de l'échelle qui s'exécute.

    1. Dans le programme principal, cliquez avec le bouton droit de la souris sur un échelon vide et sélectionnez l'option Importer des échelons....

    2. Accédez au fichier .L5X. Les fichiers se trouvent à l'emplacement suivant : C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

      Importez le fichier InSightGenEth_11_CopyRung.L5X. Une fois le fichier sélectionné, cliquez sur le bouton Importer....

  6. La boîte de dialogue Configuration de l'importation est ensuite utilisée pour modifier les noms des balises créées pour correspondre à la configuration. Le module générique va créer un tableau unique de données brutes non structurées pour l'entrée et la sortie vers le module. L'assemblage d'entrée sera un tableau contigu comprenant le bloc d'état et le tableau des résultats de l'inspection. L'assemblage de sortie sera un tableau contigu comprenant le bloc de contrôle et le tableau des données utilisateur. Aucun des deux n'inclura de balises d'identification.

    Une fois que le projet est téléchargé vers le PLC et que l'échelon contenant les instructions relatives à la copie est exécuté pour la première fois, deux nouveaux tableaux contenant les balises sont créés.

    1. Les noms génériques des balises devront être modifiés. Les deux lignes supérieures comporteront un X et chaque nom devra être modifié.

    2. En cliquant dans l'espace blanc du champ Nom, une flèche apparaît et un menu déroulant contenant les options de remplacement pour la structure Nom par défaut s'affiche. La liste doit contenir les noms qui correspondent au nom donné à l'étape 4 (le nom du capteur de vision In-Sight. Dans cet exemple, le nom attribué était In-Sight 2000. La liste contient donc In-Sight 2000:E et In-Sight 2000:S).

      Remplacez les deux noms génériques par les options du menu déroulant.

    3. Les deux lignes inférieures doivent également être modifiées. Cliquez sur le texte du nom pour faire apparaître l'icône du curseur, puis remplacez le texte précédant « _In » et « _Out » par le nom du module générique ou par un nom facilement identifiable (par exemple "In-Sight 2000" étant donné qu'il n'y a qu'un seul capteur de vision).

      Remarque : Le nom attribué dans ce cas doit être unique à chaque capteur de vision ajouté à la configuration d'E/S. Si plusieurs capteurs de vision sont déployés, il est nécessaire de suivre ces étapes pour chaque capteur de vision, car chaque instance des échelons de copie qui sont créés pointera vers un capteur de vision spécifique. Par conséquent, pour la résolution de problèmes futurs, assurez-vous que les noms utilisés sont facilement identifiables.

    4. Une fois que toutes les balises ont été mises à jour à partir de leurs valeurs par défaut, cliquez sur le bouton OK.

  7. Un nouvel échelon sera ajouté au programme principal sous l'échelon qui a été ajouté (l'échelon vide peut être supprimé).

  8. Le projet peut désormais être téléchargé vers le PLC et le PLC peut être mis en mode d'exécution.

  9. Une fois que les échelons contenant les instructions relatives à la copie ont été exécutés, les nouvelles balises sont créées dans le tableau Balises du contrôleur.

    Dans cet exemple, les balises In-Sight 2000:E et In-Sight 2000:S sont les assemblages d'entrée et de sortie bruts du système de vision, etIn-Sight 2000_In et In-Sight 2000_Out contiennent les blocs de contrôle et d'état, ainsi que les tableaux Données utilisateur et Résultats de l'inspection.


Intégration des systèmes de vision In-Sight Vision dans RSLogix 5000 v17-19

Cette rubrique couvre l'intégration des systèmes de vision In-Sight qui utilisent le micrologiciel 5.2.0 ou une version ultérieure dans RSLogix 5000 version 17-19. Ces versions de RSLogix 5000 ne prennent pas en charge les fichiers EDS et un MODULE ETHERNET générique doit être utilisé à la place. In-Sight Explorer comprend des fichiers .L5X qui peuvent être utilisés pour copier les données de la balise du contrôleur PLC vers/depuis des balises de programme convivial, représentant des signaux dans le capteur de vision exécutant les versions de micrologiciel 5.2 et versions ultérieures.

  1. Ouvrez RSLogix 5000 et chargez le projet du PLC.

    Remarque : Le PLC doit être hors ligne pour ajouter des connexions dans RSLogix 5000.

  2. Ajoutez une connexion à votre carte de communication Ethernet. Dans le nœud de configuration des E/S, sélectionnez Nœud Ethernet dans le module Ethernet, cliquez avec le bouton droit de la souris sur l'icône, puis sélectionnez Nouveau module dans le menu.

  3. Dans l'onglet Catalogue de la boîte de dialogue Sélectionner un type de module, sélectionnez le filtre de catégorie du type de module Communication, Allen-Bradley comme filtre fournisseur du type de module, sélectionnez MODULE ETHERNET (Module Ethernet générique) et cliquez sur le bouton Créer.

  4. Dans la boîte de dialogue New Module (Nouveau module), entrez les informations suivantes :

    • Le nom et l'adresse IP du capteur de vision In-Sight.
    • Les paramètres de connexion (Connection Parameters). Pour les capteurs de vision In-Sight avec un micrologiciel de version 5.x.x, la section Objets d'assemblage d'entrée et de sortie définit l'instance d'assemblage Assembly Instance à configurer. Pour plus d'informations, reportez-vous à la rubrique PLC Rockwell ControlLogix – Micrologiciel In-Sight 5.x.x de l'aide In-Sight® Explorer.

  5. Après avoir ajouté le capteur de vision au projet RSLogix, le fichier d'importation de l'échelon L5X peut être utilisé pour créer des données structurées pour la connexion. Vous pouvez accéder au programme principal dans le dossier Tâches > Tâche principale > Programme principal du volet Organisateur du contrôleur.

    Remarque : S'il s'agit d'un nouveau programme en échelle, l'échelon vide 0 peut être utilisé. Si le capteur de vision est intégré à un programme existant, Cognex recommande d'ajouter un échelon en haut de l'échelle pour s'assurer que les données mises à jour sont lues et écrites dans les assemblages d'entrée et de sortie du capteur avant le reste de l'échelle qui s'exécute.

    1. Dans le programme principal, cliquez avec le bouton droit de la souris sur un échelon vide et sélectionnez l'option Importer des échelons....

    2. Accédez au fichier .L5X. Les fichiers se trouvent à l'emplacement suivant : C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

      Importez le fichier InSightGenEth_11_CopyRung.L5X. Une fois le fichier sélectionné, cliquez sur le bouton Importer....

  6. La boîte de dialogue Configuration de l'importation est ensuite utilisée pour modifier les noms des balises créées pour correspondre à la configuration. Le module générique va créer un tableau unique de données brutes non structurées pour l'entrée et la sortie vers le module. L'assemblage d'entrée sera un tableau contigu comprenant le bloc d'état et le tableau des résultats de l'inspection. L'assemblage de sortie sera un tableau contigu comprenant le bloc de contrôle et le tableau des données utilisateur. Aucun des deux n'inclura de balises d'identification.

    Une fois que le projet est téléchargé vers le PLC et que l'échelon contenant les instructions relatives à la copie est exécuté pour la première fois, deux nouveaux tableaux contenant les balises sont créés.

    1. Les noms génériques des balises devront être modifiés. Les deux lignes supérieures comporteront un X et chaque nom devra être modifié.

      En cliquant dans l'espace blanc du champ Nom, une flèche apparaît et un menu déroulant contenant les options de remplacement pour la structure Nom par défaut s'affiche. La liste doit contenir les noms qui correspondent au nom donné à l'étape 4 (le nom du capteur de vision In-Sight. Dans cet exemple, le nom attribué était In-Sight 2000. La liste contient donc In-Sight 2000:E et In-Sight 2000:S).

      Remplacez les deux noms génériques par les options du menu déroulant.

    2. Les deux lignes inférieures doivent également être modifiées. Cliquez sur le texte du nom pour faire apparaître l'icône du curseur, puis remplacez le texte précédant « _In » et « _Out » par le nom du module générique ou par un nom facilement identifiable (par exemple "In-Sight 2000" étant donné qu'il n'y a qu'un seul capteur de vision).

      3. Remarque : Le nom attribué dans ce cas doit être unique à chaque capteur de vision ajouté à la configuration d'E/S. Si plusieurs capteurs de vision sont déployés, il est nécessaire de suivre ces étapes pour chaque capteur de vision, car chaque instance des échelons de copie qui sont créés pointera vers un capteur de vision spécifique. Par conséquent, pour la résolution de problèmes futurs, assurez-vous que les noms utilisés sont facilement identifiables.

    3. Une fois le nom des balises par défaut modifié, il est nécessaire d'indiquer où les balises seront créées. Pour placer les balises dans le tableau Controller Tag (Balise du contrôleur), cliquez avec le bouton droit de la souris dans la zone vide (mise en surbrillance ci-dessous) et sélectionnez Toggle Tag Scope (Changer la portée de la balise).

    4. Une fois que toutes les balises ont été mises à jour à partir de leurs valeurs par défaut, cliquez sur le bouton OK.

  7. Un nouvel échelon sera ajouté au programme principal sous l'échelon qui a été ajouté (l'échelon vide peut être supprimé).

  8. Le projet peut désormais être téléchargé vers le PLC et le PLC peut être mis en mode d'exécution.

  9. Une fois que les échelons contenant les instructions relatives à la copie ont été exécutés, les nouvelles balises sont créées dans le tableau Balises du contrôleur.

    Dans cet exemple, les balises In-Sight 2000:E et In-Sight 2000:S sont les assemblages d'entrée et de sortie bruts du système de vision, etIn-Sight 2000_In et In-Sight 2000_Out contiennent les blocs de contrôle et d'état, ainsi que les tableaux Données utilisateur et Résultats de l'inspection.


Intégration des systèmes de vision In-Sight Vision dans RSLogix 5000 v20

Cette rubrique couvre l'intégration des systèmes de vision In-Sight qui utilisent le micrologiciel In-Sight 5.2.0 ou une version ultérieure dans RSLogix 5000, version 20 et les versions ultérieures. Ces versions de RSLogix 5000 prennent en charge les fichiers EDS. In-Sight Explorer comprend des fichiers .L5X, qui placent les données des balises dans des balises de programme conviviales et qui représentent des signaux dans le capteur de vision qui utilise le micrologiciel In-Sight 5.2.x ou une version ultérieure. Le fichier InSight_11_CopyRung.L5X sera utilisé pour les capteurs qui utilisent le micrologiciel 5.X.

  1. Créez et ajoutez un module EDS dansRSlogix5000

    1. Les fichiers EDS sont installés avec le logiciel Insight Explorer à l'emplacement suivant : C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.2.3\Factory Protocol Description\EDS
    2. À partir du menu déroulant Outils de RSLogix5000, lancez l'installation de l'outil EDS pour installer le fichier EDS pour In-Sight 2000.
    3. À partir de la section IO Configuration (Configuration d'E/S) du RSLogix5000, cliquez avec le bouton droit de la souris sur le nœud du réseau et sélectionnez New module (Nouveau module) dans le menu.

    4. À partir de la boîte de dialogue Select module (Sélectionner un module), ouvrez le nœud Communications et sélectionnez In-Sight 2000-xxx dans la liste, puis cliquez sur OK.

      La boîte de dialogue est remplacée par la boîte de dialogue de configuration New module (Nouveau module).

      Saisissez le nom du capteur de vision, son adresse IP et ses paramètres de connexion, comme indiqué ci-dessus. S'il existe plusieurs capteurs de vision, chacun d'eux doit porter un nom unique. Il n'existe qu'un seul capteur de vision à configurer.

      Astuce : reportez-vous aux fichiers d'aide d'In-Sight Explorer pour le Modèle d'objet EtherNet/IP (bits d'assemblage d'entrée et de sortie) qui correspondent à la version du micrologiciel utilisé sur le capteur de vision.

  2. Échelon d'importation

    1. Accédez à la Routine principale qui se trouve dans le dossier Tâches > Tâche principale > Programme principal du volet Organisateur du contrôleur. S'il s'agit d'un nouveau programme à enchaînement en échelle, il est possible d'utiliser l'échelon vide zéro. Si le capteur de vision doit être intégré à un programme existant, il est recommandé d'ajouter un échelon en haut de l'échelle pour s'assurer que les données mises à jour sont lues et écrites dans les assemblages d'entrée et de sortie du capteur avant l'exécution du reste de l'échelle.

    2. Lorsqu'il se retrouve à un échelon vide en haut du programme à enchaînement en échelle, cliquez avec le bouton droit de la souris sur cet échelon et sélectionnez Importer un échelon dans le menu.

    3. Utilisez la boîte de dialogue Importer un échelon pour accéder à l'emplacement du dossier qui contient ce document et les deux fichiers d'échelon à importer. Comme Insight 2000 utilise un micrologiciel 5.X, le fichier InSight_11_CopyRung.L5X sera utilisé.

    4. Une fois le fichier approprié sélectionné, cliquez sur le bouton Importer.

    5. La boîte de dialogue Confirmation de l'importation s'affiche avec les noms génériques à utiliser pour la génération des balises.

  3. Modification du nom des balises : le module générique créera un tableau unique de données brutes non structurées pour l'entrée vers/depuis le module. Dans cet exemple, le module générique a créé In-Sight 2000:I, In-Sight 2000:0 et In-Sight 2000:C (qui n'est pas utilisé). L'assemblage d'entrée sera un tableau contigu qui se compose du bloc d'état et du tableau des résultats de l'inspection et l'assemblage de sortie sera un tableau contigu comprenant le bloc de contrôle et le tableau des données utilisateur, aucun des deux n'incluant de balises d'identification. Une fois que le projet est téléchargé vers le PLC et que l'échelon contenant les instructions relatives à la copie est exécuté pour la première fois, deux nouveaux tableaux contenant les balises sont créés (identiques aux balises que vous pourriez visualiser si un module de profil AOP (Add-On Profile) était disponible).

    1. Les deux lignes inférieures avec un indicateur situé à leur gauche devront être modifiées en cliquant dans l'espace blanc du champ Nom. Ces balises contiennent les données brutes non structurées des assemblages d'E/S dans In-Sight. Une flèche vers le bas apparaîtra après avoir cliqué dans l'espace.

    2. Cliquer sur la flèche fait apparaître un menu déroulant avec des options de remplacement du nom par défaut. Cette liste comprend des noms qui correspondent au nom du module générique. Dans cet exemple, le module générique a été nommé In-Sight 2000. Ainsi, « In-Sight 2000:i » et « In-Sight 2000:o » apparaissent dans la liste. Remplacez les deux lignes par le nom correspondant au nom du module générique. Veuillez noter qu'In-Sight 2000:C n'est pas utilisé.

    3. Ensuite, modifiez les deux lignes dans la configuration d'importation. Cliquez sur le texte du nom pour faire apparaître le curseur. Il est suggéré de remplacer tout ce qui précède « _In » et « Out » par le nom du module générique ou par un autre nom facilement identifiable. Cet exemple n'utilisant qu'un seul capteur de vision, le nom « In-Sight 2000 » a été utilisé.

    4. Maintenant que tous les noms des balises par défaut ont été modifiés, il est nécessaire de spécifier l'emplacement de création des balises. Ignorer cette étape va placer les nouvelles balises dans le tableau Balise du programme juste au-dessus du programme principal.

      Pour insérer les balises dans le tableau Balise du contrôleur, comme un profil AOP le ferait s'il était disponible, cliquez avec le bouton droit de la souris dans la zone vide en regard de chaque nom d'importation, là où ne figure pas d'icône de carte de contrôleur. Ces espaces ont été mis en surbrillance dans la capture d'écran ci-dessous. Cliquer avec le bouton droit de la souris dans cet espace fait apparaître un menu déroulant où vous pouvez sélectionner Modifier le périmètre de la balise. Cette opération placera l'icône de carte du contrôleur dans la zone précédemment vide.

    5. Après avoir remplacé toutes les valeurs par défaut par un autre nom, cliquez sur le bouton OK.

      Astuce : vous pouvez attribuer n'importe quel nom pour In-Sight 2000_In et In-Sight 2000_Out, du moment qu'il est unique pour chaque capteur de vision ajouté à la configuration d'E/S. Si plusieurs capteurs sont déployés, il est nécessaire de suivre ces étapes pour chaque capteur, car chaque instance des échelons de copie qui sont créés pointera vers un capteur spécifique. Soyez vigilant lorsque vous choisissez des noms pour faciliter la résolution d'éventuels problèmes et pour éviter les confusions. Par exemple, s'il existe plusieurs capteurs, vous pouvez attribuer des noms comme « Ligne_une_In- Sight 2000_In » et « Ligne_une_In-Sight 2000_Out ».

    6. Un nouvel échelon vide sera ajouté à la routine principale. Il est possible de supprimer cet échelon.

  4. Téléchargement vers le PLC

    1. Téléchargez le projet vers le PLC.

    2. Mettez le PLC en mode Exécution. Après avoir exécuté les échelons contenant les instructions relatives à la copie, les nouvelles balises seront créées dans le tableau Balises du programme (comme avec le profil AOP s'il existait).

      Dans cet exemple, In-Sight 2000:I et In-Sight 2000:O sont les assemblages d'entrée et de sortie bruts du capteur de vision, et MyCamera_In et MyCamera_Out contiennent les blocs de contrôle et d'état, ainsi que les tableaux Données utilisateur et Résultats de l'inspection, comme indiqué dans le tableau suivant :


Objets d'assemblage d'entrée et de sortie du système de vision In-Sight

Pour des informations complémentaires, consultez le fichier d’aide In‑Sight® Explorer.


Configuration des systèmes de vision In-Sight pour les communications PLC

Pour communiquer avec un PLC, procédez d'abord comme suit :

  1. Dans la zone de groupe Communications, cliquez sur le bouton Ajouter un périphérique.
  2. Dans la zone de groupe Configuration du périphérique, sélectionnez PLC/contrôleur de mouvement dans la liste déroulante Périphérique.
  3. Sur la liste déroulante Fabricant, sélectionnez le fabricant du PLC/contrôleur de mouvement. Si le fabricant de votre PLC/contrôleur de mouvement ne figure pas sur la liste, sélectionnez Autre.
  4. Sur la liste déroulante Protocole, sélectionnez le protocole de communication : Les protocoles de communication listés dépendent de la sélection du Fabricant.
  5. Cliquez sur le bouton OK.

Ensuite, vous pouvez effectuer les opérations suivantes :

Déclencheur Over Ethernet/IP

Établissement de la connexion à l'aide du profil Add-On

Obtenir les données depuis un système de vision In-Sight

Envoyer des données sur un système de vision In-Sight


Effectuer un déclenchement sur EtherNet/IP

Pour configurer le déclenchement du capteur de vision In-Sight série 2000 sur EtherNet/IP :

  1. Connectez-vous au capteur de vision.
  2. Dans l'étape Configurer l'image, définissez le Type de déclenchement sur Ethernet industriel.

  3. Dans l'étape Communication :

    1. Dans la zone de groupe Communications, cliquez sur le bouton Ajouter un périphérique.
    2. Dans la zone de groupe Configuration du périphérique, sélectionnez PLC/contrôleur de mouvement dans la liste déroulante Périphérique.
    3. Sur la liste déroulante Fabricant, sélectionnez le fabricant du PLC/contrôleur de mouvement. Si le fabricant de votre PLC/contrôleur de mouvement ne figure pas sur la liste, sélectionnez Autre.
    4. Sur la liste déroulante Protocole, sélectionnez le protocole de communication : Les protocoles de communication listés dépendent de la sélection du Fabricant.
    5. Cliquez sur le bouton OK.

  4. Mettez le capteur de vision In-Sight en ligne.

  5. Dans les balises d'assemblage d'E/S sur le PLC, définissez le bit Activation du déclenchement sur Élevé, puis définissez le bit de déclenchement élevé à déclencher (les bits référencés sont surlignés en jaune).


Établissement de la connexion à l'aide du profil Add-On

Si un système de vision a déjà été configuré dans votre projet RSLogix avec le fichier EDS, vous pouvez mettre à jour le profil EDS avec le nouveau profil AOP. Pour des informations détaillées, reportez-vous à la rubrique Profil EDS précédemment installé avec le nouveau profil AOP. Pour des informations complémentaires, consultez le fichier d’aide In‑Sight® Explorer.


Obtenir les données depuis un système de vision In-Sight 2000

Obtenir les données depuis un système de vision In-Sight

Configurer la communication entre le système de vision In-Sight et le PLC :

  1. Dans la zone de groupe Communications, cliquez sur le bouton Ajouter un périphérique.
  2. Dans la zone de groupe Configuration du périphérique, sélectionnez PLC/contrôleur de mouvement sur la liste déroulante Périphérique.
  3. Sur la liste déroulante Fabricant, sélectionnez le fabricant du PLC/contrôleur de mouvement. Si le fabricant de votre PLC/contrôleur de mouvement ne figure pas sur la liste, sélectionnez Autre.
  4. Dans la liste déroulante Protocole, sélectionnez le protocole de communication. Les protocoles de communication listés dépendent de la sélection du Fabricant.
  5. Cliquez sur le bouton OK.

Configuration des données pour la communication :

Les données provenant de projets EasyBuilder, notamment les résultats d'outils individuels ou de projets globaux (sortie uniquement), peuvent être communiquées via Ethernet/IP. Les données d'entrée seront lues une fois que le capteur aura acquis une image et les données de sortie seront envoyées une fois que le capteur aura terminé l'exécution du projet.

  6. Cliquez sur l'onglet Formater les données d'entrée ou Formater les données de sortie.
  7. Cliquez sur le bouton Ajouter pour lancer la boîte de dialogue Sélectionner les données d'entrée ou Sélectionner les données de sortie.
  8. La boîte de dialogue Sélectionner les données d'entrée ou Sélectionner les données de sortie contient les données de tous les outils de recherche ou d'inspection ajoutés à votre projet, ainsi que les résultats du projet global (sortie uniquement). Dans la boîte de dialogue, sélectionnez les données à envoyer depuis (ou vers) le capteur In-Sight, puis cliquez sur le bouton OK.

  9. Après avoir ajouté vos données, vous pouvez modifier le type de données par défaut des données sélectionnées en choisissant un type de données différent dans la liste déroulante Type de données.

    Remarque : Si vous sélectionnez Chaîne dans la liste déroulante Type de données, le contrôle Taille d'élément (octets) est activé et vous pouvez spécifier la longueur de chaîne en choisissant le nombre d'octets approprié.
  10. Réorganisez l'ordre des données qui seront envoyées ou reçues en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.
  11. Mettez le capteur de vision In-Sight en ligne.
  12. Déclenchez le système.

  13. Les données doivent maintenant s'afficher dans le nœud Controller -> Program Tags du RSLogix 5000.


Envoyer des données sur un capteur de vision In-Sight 2000

Envoyer des données sur un système de vision In-Sight

Configurer la communication entre le système de vision In-Sight et le PLC :

  1. Dans la zone de groupe Communications, cliquez sur le bouton Ajouter un périphérique.
  2. Dans la zone de groupe Configuration du périphérique, sélectionnez PLC/contrôleur de mouvement sur la liste déroulante Périphérique.
  3. Sur la liste déroulante Fabricant, sélectionnez le fabricant du PLC/contrôleur de mouvement. Si le fabricant de votre PLC/contrôleur de mouvement ne figure pas sur la liste, sélectionnez Autre.
  4. Dans la liste déroulante Protocole, sélectionnez le protocole de communication. Les protocoles de communication listés dépendent de la sélection du Fabricant.
  5. Cliquez sur le bouton OK.

Les données provenant de projets EasyBuilder, notamment les résultats d'outils individuels ou de projets globaux (sortie uniquement), peuvent être communiquées via Ethernet/IP. Les données d'entrée seront lues une fois que le capteur aura acquis une image et les données de sortie seront envoyées une fois que le capteur aura terminé l'exécution du projet.

Pour formater vos données :

  1. Cliquez sur l'onglet Formater les données d'entrée ou Formater les données de sortie.
  2. Cliquez sur le bouton Ajouter pour lancer la boîte de dialogue Sélectionner les données d'entrée ou Sélectionner les données de sortie.
  3. La boîte de dialogue Sélectionner les données d'entrée ou Sélectionner les données de sortie contient les données de tous les outils de recherche ou d'inspection ajoutés à votre projet, ainsi que les résultats du projet global (sortie uniquement). Dans la boîte de dialogue, sélectionnez les données à envoyer depuis (ou vers) le capteur In-Sight, puis cliquez sur le bouton OK.

  4. Après avoir ajouté vos données, vous pouvez modifier le type de données par défaut des données sélectionnées en choisissant un type de données différent dans la liste déroulante Type de données.

    Remarque : Si vous sélectionnez Chaîne dans la liste déroulante Type de données, le contrôle Taille d'élément (octets) est activé et vous pouvez spécifier la longueur de chaîne en choisissant le nombre d'octets approprié.
  5. Réorganisez l'ordre des données qui seront envoyées ou reçues en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.
  6. Mettez le capteur de vision In-Sight en ligne.
  7. Dans le RSLogix 5000, ouvrez la boîte de dialogue Program Tags (Balises du programme) et modifiez la valeur des balises InSight_Top:O.Data[1] et InSight_Top:O.Data[2] .

  8. Déterminez si l'établissement d'une liaison pour les données utilisateur est nécessaire. Si le Contournement des données utilisateur est activé, l'échange des données imite celui des caméras 4.x.x. Si le Contournement des données utilisateur n'est pas activé (état par défaut), ce nouveau bit ajoute une liaison supplémentaire à l'échange de données entre le PLC et le capteur de vision In-Sight. Des étapes supplémentaires seront nécessaires pour afficher les données dans le tableur.

    1. Si l'option Activer le contournement des données utilisateur est activée dans la boîte de dialogue Paramètres réseau de la caméra, les valeurs dans EasyBuilder sont immédiatement mises à jour.

    2. Si l'option Activer le contournement des données utilisateur n'est PAS activée dans la boîte de dialogue Paramètres réseau de la caméra :

      1. Configurez la balise User Data (Données utilisateur), le bit SetUserData est une balise portant un nom ; dans cet exemple, il s'agit de InSight_Top:O.Control.SetUserData.
      2. Effacez la balise Données utilisateur ci-dessus une fois que vous avez reçu le bit d'AR des données utilisateur. Le bit SetUserDataAck est une balise portant un nom ; dans cet exemple, il s'agit de InSIght_Top:I.Status. SetUserDataAck.


Exemple de chargement d'un projet de système de vision In-Sight à partir d'un PLC RSLogix

Pour des informations complémentaires, consultez le fichier d’aide In‑Sight® Explorer.


Intégration avec Universal Robots – TCP/IP

Les systèmes de vision Cognex 2D peuvent être intégrés aux contrôleurs Universal Robot à l’aide du plugin Cognex In-Sight 2D Robot Guidance. Il suffit pour cela d’installer ce module dans le logiciel Universal Robot PolyScope. Ce plugin permet la calibration main-œil. Le système de vision communique les informations de configuration au robot, ce qui lui permet de faire le bon mouvement pour récupérer la pièce. Vous pouvez programmer les réponses provenant du système de vision, comme par exemple l’échec ou le succès d’un test. Vous pouvez également définir une configuration de référence pour le robot si le système de vision est placé sur le bras de celui-ci.

Les systèmes de vision Cognex 2D communiquent avec les contrôleurs Universal Robot par le biais d’une liaison TCP/IP. Le système de vision héberge le serveur TCP, le robot est client. Ces périphériques doivent se trouver sur le même réseau.

Remarque : Cette fonctionnalité n'est pas prise en charge par les capteurs de vision In-Sight 2000.

Les contrôleurs Universal Robot suivants sont pris en charge :

  • UR3
  • UR5
  • UR10
  • e-Series

Le plugin Cognex In-Sight 2D Robot Guidance est uniquement pris en charge avec un logiciel Universal Robot PolyScope de version 3.5.1 ou ultérieure.

L’installation du protocole de calibrage de coordination main-œil et de l’application de guidage de robot nécessite de réaliser les tâches suivantes :

  1. Installer le plugin Cognex In-Sight 2D Robot Guidance
  2. Apprentissage du TCP (point central d'outil)
  3. Configurer le système de vision pour calibrage
  4. Connecter le système de vision et réaliser le calibrage de coordination main-œil
  5. Créer un projet Pièce et importer le calibrage
  6. Configurer la configuration du système de vision
  7. Programmer le contrôleur Universal Robot

Installer le plugin URCap Cognex

Apprentissage du TCP (point central d'outil)

Configurer le système de vision pour calibrage

Connecter le système de vision et réaliser le calibrage de coordination main-œil

Créer un projet Pièce et importer le calibrage

Configurer la configuration du système de vision

Programmer le contrôleur Universal Robot


Installer le plugin URCap Cognex

Installer le plugin Cognex In-Sight 2D Robot Guidance

  1. Naviguez jusqu’à cognex.com/urcaps et téléchargez le fichier Cognex URCaps v1.3.0.urcap.
  2. Copiez ce fichier sur une clé USB.

  3. Exécutez le programme PolyScope. Le menu principal s’affiche :

  4. Insérez la clé USB dans la prise située sur le côté droit du boîtier de commande Universal Robot.

  5. Dans le menu principal, sélectionnez Setup Robot > URCaps. Cliquez sur le bouton (+) pour ajouter le fichier du plugin URCap Cognex, celui-ci est indiqué par Cognex In-Sight Robot Guidance.

Le plugin Cognex In-Sight 2D Robot Guidance ajoute les éléments suivants au logiciel PolyScope :

  • Un élément de menu Cognex dans l’onglet Programme (Program > Structure > URCaps > Cognex Camera Pose).
  • Un élément de menu Cognex dans l’onglet Installation.
  • Un nœud dans l’architecture Robot Program appelé CGX_result:=CameraPose.
  • Une nouvelle variable, CGX_result, dans l’onglet Program > Command. Pendant l’acquisition d'image, le système de vision stocke sa configuration dans cette variable.


Apprentissage du TCP (point central d'outil)

Le TCP (point central d'outil) est la partie du robot qui entre en contact avec la pièce cible. Vous apprenez ce TCP (point central d'outil) pour que le robot puisse se déplacer à la même position depuis différents angles (appelés « waypoints », points de passage).

Le TCP (point central d'outil) doit être dans le champ de vision du système de vision.

Remarque : Cette procédure est inhérente au logiciel PolyScope et vous est présentée dans ce document pour des raisons pratiques.
  1. Exécutez le logiciel PolyScope.

  2. Dans le menu principal, sélectionnez Program Robot (Programmer le robot). La fenêtre New Program (Nouveau programme) s’affiche.

  3. Sélectionnez Pick and Place (Bras-transfert).

  4. Sélectionnez Installation > TCP Configuration (Installation > Configuration TCP).

  5. Pour apprendre le TCP (point central d'outil), vous pouvez le mesurer manuellement de l’une des manières suivantes :

    • Si le TCP (point central d'outil) est placé directement sur l’axe Z, mesurez la distance entre le TCP (point central d'outil) et le centre de la bride de l’outil (en millimètres) sur l’axe Z. Entrez cette valeur dans le champ Z.
    • Si le TCP (point central d'outil) N’EST PAS placé directement sur l’axe Z, mesurez la distance entre le TCP (point central d'outil) et le centre de la bride de l’outil (en millimètres) sur les axes X, Y et Z. Entrez les valeurs correspondantes dans les champs respectifs X, Y et Z.

    6. Consultez le Manuel PolyScope pour de plus amples informations. Vous pouvez télécharger ce manuel depuis le site Web Universal Robots.


Configurer le système de vision pour calibrage

Les objectifs de cette procédure sont les suivants :

  • Apprendre le modèle du point d'outil du robot pour qu’il puisse être repéré par le système de vision.
  • Ajouter un outil de robot.
  • Entrer un nom pour le fichier de calibrage .CXD. Ce fichier est destiné aux informations de calibrage fournies par le plugin Cognex In-Sight 2D Robot Guidance une fois le calibrage terminé.
  1. Dans EasyBuilder, connectez-vous au système de vision et créez un nouveau projet.
  2. Sélectionnez Configurer image. Assurez-vous que le point d'outil se trouve dans le champ de vision du système de vision.

  3. Dans Modifier les paramètres de capture, réglez Déclencheur sur Manuel.

  4. Modifiez les paramètres de l’image de façon à ce qu’elle soit nette et exposée de manière homogène.
  5. Sélectionnez Localiser pièce et ajoutez tout outil privilégié pour repérer le point d'outil sur l’organe de préhension.
  6. Sélectionnez l’outil Modèle PatMax et sélectionnez Paramètres.

  7. À l’aide des paramètres Décalage horizontal et Décalage vertical, ajustez la position du réticule sur votre outil de façon à ce qu’il soit centré sur le point d'outil.

  8. Ajoutez ensuite l’outil Calibrage du robot en sélectionnant Inspecter pièce > Outils de calibrage > Robot.

  9. Sélectionnez Ajouter.
    Remarque : Cet outil utilise également des Caractéristiques intelligentes, vous pouvez ainsi utiliser d’autres caractéristiques, telles des cercles, à associer à l’outil Calibrage du robot.

  10. Sur l’image, cliquez sur le réticule associé à l’outil utilisé pour définir le point d'outil puis cliquez su OK. L’outil Robot s’affiche dans l’onglet Résultats de la Palette et est connecté à l’outil Modèle.

  11. Sélectionnez l’outil Calibrage du robot dans la palette Outil (il se nomme Calib_1 par défaut).

  12. Dans Modifier outil, sélectionnez l’onglet Paramètres.

  13. Entrer un nom dans le champ Nom du fichier du fichier de calibrage .CXD. Si vous souhaitez inclure la date et l’heure actuelles dans le nom du fichier, activez la case à cocher Ajouter date/heure. Le champ Nom complet affiche le nom complet du fichier.
  14. Mettez le système de vision En ligne. De cette façon, le système de vision peut communiquer avec le robot.
  15. Enregistrez le projet en lui donnant un nom qui indique qu’il s’agit d’un projet de calibrage. Vous pourrez ainsi réutiliser ce projet pour relancer le calibrage dans le plugin Cognex In-Sight 2D Robot Guidance.


Connecter le système de vision et réaliser le calibrage de coordination main-œil

Vous faites un calibrage de coordination main-œil en utilisant le plugin Cognex In-Sight 2D Robot Guidance. Ceci détermine la zone de travail du robot, se situant dans le champ de vision, dans laquelle le robot pourra manipuler un objet. Le plugin crée un fichier de calibrage (.CXD) à importer ultérieurement dans votre projet principal.

Commencez le calibrage en définissant trois points fixes qui déterminent la hauteur et la largeur du plan de travail.

  1. Dans le menu principal de PolyScope, sélectionnez Program > Robot > Installation > Cognex. La fenêtre Cognex s’affiche.
  2. Dans Connection, entrez l’adresse IP IP Address du système de vision. Le nom du système de vision s’affiche sous cette adresse.

  3. Si la connexion échoue, reportez-vous aux informations ci-après pour procéder au dépannage :

    Si cette erreur s’affiche : Procédez comme suit :
    Assurez-vous que la caméra est en ligne et que le fichier de projet attendu est chargé. | Dans In-Sight Explorer, vérifiez que l’état de la caméra est En ligne.
    Le format de l’adresse IP est invalide (exemple d’adresse IP : 192.168.0.1) | Dans le logiciel du robot, vérifiez que l’adresse IP de la caméra concernée est effectivement renseignée.
    Délai d’attente expiré. Assurez-vous que l’adaptateur réseau est activé dans Setup Robot Network (Configuration du réseau du robot). | Dans le logiciel du robot, vérifiez que le robot se trouve effectivement sur le bon réseau.

  4. Relevez visuellement la taille du plan de travail dans lequel se trouve la pièce à récupérer par le robot. Le graphique ci-après illustre des exemples de points de largeur et de hauteur.

    Remarque : Dans les étapes 4 à 6 présentées ci-après, vérifiez, avant de cliquer sur OK, que le système de vision voit toujours le TCP (point central d'outil) en déclenchant manuellement une image dans In-Sight EasyBuilder.

  5. Premièrement, vous devez définir la largeur du plan de travail. Sélectionnez le bouton Set Point (Définir point) pour (1) Work Plane Corner (Coin du plan de travail). L’onglet Move (Déplacer) s’affiche. Utilisez les commandes pour déplacer le robot jusqu’au premier coin du plan de travail puis sélectionnez OK. Une coche verte s’affiche à côté du premier bouton Set Point (Définir point) dans la fenêtre Cognex.

  6. Sélectionnez le bouton Set Point (Définir point) pour (2) Work Plane Corner (Coin du plan de travail). L’onglet Move (Déplacer) s’affiche à nouveau. Utilisez les commandes pour déplacer le robot jusqu’au deuxième coin du plan de travail puis sélectionnez OK. Une coche verte s’affiche à côté du deuxième bouton Set Point (Définir point) dans la fenêtre Cognex.

  7. Définissez maintenant la hauteur, en créant un troisième point. Sélectionnez le bouton Set Point (Définir point) pour (3) Work Plane Edge (Bord du plan de travail). L’onglet Move (Déplacer) s’affiche à nouveau. Utilisez les commandes pour déplacer le robot jusqu’au bord opposé du plan de travail puis sélectionnez OK. Une coche verte s’affiche à côté du troisième bouton Set Point (Définir point) dans la fenêtre Cognex. Les valeurs Width (Largeur) et Height (Hauteur) s’affichent.

    Le bouton Start Calibration (Démarrer calibrage) est maintenant actif.

  8. Avant de commencer le calibrage, vérifiez une nouvelle fois que la largeur et la hauteur correspondent à la réalité.
  9. Pour commencer le calibrage, sélectionnez Start Calibration (Démarrer calibrage). Une fois le calibrage terminé, le message suivant s’affiche : Calibration has finished (Le calibrage est terminé).
  10. Sélectionnez Start Program (Démarrer programme) ou Continue (Continuer) pour fermer la fenêtre.

Voici ce qui se produit lors du calibrage :

  • Le programme du robot le dirige vers 15 points du champ de vision et transmet les coordonnées au système de vision.
  • Le système de vision capture une image et détermine l’emplacement du TCP (point central d'outil).
  • Le programme du robot associe les coordonnées du TCP (point central d'outil) aux coordonnées d’un pixel du système de vision.

Une fois le calibrage terminé, le plugin Cognex In-Sight 2D Robot Guidance procède aux opérations suivantes :

  • Il envoie un message à l’outil robot du projet de calibrage que vous avez créé précédemment.
  • Il crée un fichier de calibrage avec le nom de fichier que vous avez renseigné dans le projet de calibrage et y ajoute l’extension .CXD. Vous allez ensuite importer ce calibrage dans votre projet principal. C’est dans ce projet que vous allez procéder à l’apprentissage de la pièce que le robot doit attraper.
Remarque : Si le système de vision est placé sur le bras du robot, ne déplacez pas la pièce à apprendre tant que vous n’avez pas défini de configuration de référence pour le robot. Vous devez définir la configuration de référence du robot après avoir défini la configuration du système de vision.


Créer un projet Pièce et importer le calibrage

Créez le projet principal destiné à l’apprentissage de la pièce que le robot doit attraper et à l’importation du calibrage créé par le plugin de guidage de robot Cognex In-Sight 2D Robot Guidance.

  1. Créez un nouveau projet et connectez-vous au système de vision. Assurez-vous que la pièce à attraper se trouve dans le champ de vision du système de vision.
  2. Sélectionnez Configurer image.

  3. Dans Modifier les paramètres de capture, réglez Déclencheur sur Manuel.

  4. Dans Type de calibrage, sélectionnez Importer.

  5. Dans Nom du fichier, sélectionnez le nom du fichier .CXD que vous avez entré dans le projet de calibrage.

  6. Sélectionnez Localiser pièce et ajoutez tout outil privilégié pour repérer la pièce.
  7. Si nécessaire, procédez à des réglages supplémentaires sur le projet.
  8. Sélectionnez Inspecter une pièce.

  9. Sélectionnez Outils mathématiques & logiques > Guidage de robot.

  10. Sélectionnez Ajouter, cliquez sur le réticule de la pièce puis sélectionnez OK. L’outil Guidage de robot s’affiche dans l’onglet Résultats de la Palette et est connecté à l’outil Modèle.

  11. Dans Modifier outil, changez le Nom d'outil et tous les paramètres que vous souhaitez. Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.Personnalisez l'outil en lui attribuant un nom associé à votre application spécifique.
  12. Mettez le système de vision En ligne.


Configurer la configuration du système de vision

Paramétrez les options de configuration du robot. Ainsi, le programme connait exactement la localisation du système de vision.

  1. Exécutez le programme PolyScope que vous avez créé. Le menu principal s’affiche :

  2. Dans le menu principal de PolyScope, sélectionnez Program Robot (Programme du robot). Une série d’onglets s’affiche.

  3. Sélectionnez Empty Program (Programme vierge).

  4. Sélectionnez l’onglet Structure. La page de l’éditeur Program Structure Editor (Éditeur structure programme) s’affiche.

  5. Sélectionnez URCaps. Le bouton Cognex Camera Pose (Configuration de caméra Cognex) s’affiche, il représente le plugin Cognex In-Sight 2D Robot Guidance.

  6. Sélectionnez le bouton Cognex Camera Pose (Configuration de caméra Cognex) puis l’onglet Command (Commande). L’architecture du programme du robot placé sur la gauche contient maintenant le nœud CGX_result;=CameraPose et trois autres nœuds supplémentaires : Job Pass, Job Fail et No Response (Échec, Succès et Pas de réponse).

    Un fichier nommé CGX_result est créé, il sera utilisé pour enregistrer la configuration du système de vision. La configuration correspond à l’emplacement de la pièce trouvé par le système de vision.

  7. Désactivez les positions que vous ne souhaitez pas obtenir par le système de vision. Si vous laissez toutes les rotations libres, la rotation du robot s’effectue relativement à la rotation actuelle au niveau de la pince, qui est la rotation définie lorsque le programme atteint le nœud CGX_result;=CameraPose. Pour verrouiller une position, cochez la case correspondante.
  8. Enregistrez le programme.
Remarque : Si le système de vision est placé sur le bras du robot, définissez une configuration de référence pour le robot. Consultez Définir une configuration de référence pour le robot.

Définir une configuration de référence pour le robot


Définir une configuration de référence pour le robot

Remarque : Cette tâche est nécessaire uniquement si le système de vision est installé sur le bras du robot (opération facultative dans le cas contraire).

Vous pouvez définir une configuration de référence pour le robot de façon à ce que l’organe de préhension soit aligné avec la pièce apprise.

  1. Dans l’architecture Robot Program de PolyScope, sélectionnez le nœud CGX_result;=CameraPose. La fenêtre Cognex Camera Pose s’affiche.

  2. Sélectionnez Set Reference Pose (Définir configuration de référence). L’outil Move (Déplacer) s’affiche.

  3. Utilisez cet outil pour déplacer l’organe de préhension en face de la pièce apprise.
  4. Une fois terminé, sélectionnez OK.
  5. Si le système de vision est placé sur le bras du robot, cochez Robot Mounted (Sur robot).

    Si le système de vision est placé sur le bras du robot, laissez cette case désactivée (décochée).

  6. Enregistrez le programme pour sauvegarder la configuration de référence.


Programmer le contrôleur Universal Robot

Une fois le calibrage du robot terminé et les projets In-Sight créés, vous pouvez programmer le robot pour votre application bras-transfert à l’aide de MoveL et d’autres commandes. Vous pouvez également décider des mesures à prendre selon que le système de vision communique : projet réussit, échec ou sans réponse. Le plugin Cognex In-Sight 2D Robot Guidance propose le cadre suivant :

Une fois la programmation terminée, lorsque vous exécutez le programme et qu’il atteint le nœud CGX_result:=CameraPose, les événements suivants se produisent :

  1. Le système de vision capture une image, et renvoie la configuration adaptée à la localisation de la pièce.
  2. Le système de vision se déclenche et renvoie la configuration représentant la position de la pièce.
  3. La configuration est enregistrée dans la variable CGX_result dans l’éditeur Program Structure Editor de PolyScope.

Voici un exemple de programme :


Séquence vidéo

L'étape Séquence vidéo sert à configurer un système de vision ou un émulateur afin de lire les images enregistrées sur le PC ou examiner les images et résultats enregistrés sur le système de vision. La séquence vidéo du PC est habituellement utilisée pour la configuration et le suivi à court terme des images ayant réussi et échoué lors de la connexion à un PC. La séquence vidéo du capteur est habituellement utilisée pour le suivi et le débogage lors de l'exécution.

Remarque : Si la séquence vidéo n'est pas affichée, cliquez sur Séquence vidéo dans le menu Afficher ou sur le bouton Séquence vidéo [image] de la barre d'outils EasyBuilder.

Paramètres du capteur

Paramètres du PC


Paramètres du capteur

Lorsque le système de vision est en ligne et acquiert des images, la séquence vidéo du capteur peut être utilisée pour surveiller les performances d'un projet. Au fur et à mesure de l'acquisition des images, les résultats du projet, comprenant l'image acquise et les données de projet qui l'accompagnent sont stockées dans la mémoire vive du système de vision. Au fur et à mesure que les résultats sont stockés dans le système de vision, un graphique de réussite ou d'échec est ajouté à la séquence vidéo. Selon la résolution du système de vision et la mémoire disponible, jusqu'à 20 résultats peuvent être enregistrés.

Résultats d'un suivi de séquence vidéo d'un système de vision en ligne

Fermé Configuration des paramètres du capteur
Remarque : L'activation de la séquence vidéo du capteur peut augmenter la durée d'exécution du projet. Vérifiez que l'augmentation de la durée est acceptable pour votre application. Si elle n'est pas acceptable, sélectionnez Désactivé dans le menu déroulant File d'attente.

La zone de groupe Paramètres du capteur permet de configurer les paramètres de la séquence vidéo du capteur :

Fermé File d'attente

Indique les résultats à stocker ; Désactivé (aucun résultat n'est stocké), Succès, Échecs, Succès et échecs ou Succès et échecs séparés. (Par défaut = Désactivé)

Remarque :
  • Quand Succès et échecs séparés est sélectionné :
    • La liste déroulante File d'attente est désactivée.
    • Les listes déroulantes Taille succès et Taille échecs sont activées.
    • Les boutons Succès et Échecs sont affichés en regard de la séquence vidéo ; utilisez ces boutons pour afficher les résultats des succès et/ou des échecs dans la séquence vidéo.

Fermé Taille de file d'attente

Spécifie le nombre de résultats à stocker. Selon la résolution du système de vision et la mémoire disponible, jusqu'à 20 résultats peuvent être enregistrés. Si la taille de file d'attente indiquée dépasse la mémoire vive disponible du système de vision, le plus grand nombre de résultats possible est automatiquement attribué au système de vision.

Remarque : Cette option est désactivée quand Succès et échecs séparés est sélectionné dans la liste déroulante File d'attente.

Fermé Taille succès :

Nombre de succès stockés dans le système de vision. Les Taille du Succès et Taille de l'Échec n'excèdent pas la Taille de la liste prise en charge et réservée sur le système de vision. Cette option est uniquement activée lorsque Séparer les résultats (Échec/Succès) est sélectionné dans la Liste déroulante. (Minimum = 1)

Fermé Taille échecs :

Nombre d'échecs stockés dans le système de vision. Les Taille du Succès et Taille de l'Échec n'excèdent pas la Taille de la liste prise en charge et réservée sur le système de vision. Cette option est uniquement activée lorsque Séparer les résultats (Échec/Succès) est sélectionné dans la Liste déroulante. (Minimum = 1)

Fermé Type de file d'attente

Spécifie s'il faut enregistrer le Premier uniquement ou le nombre (X) de résultats Plus récent, où X = Taille de file d'attente. (Par défaut = Plus récent)

Fermé Effacer en passant au mode En ligne

Si cette option est activée (par défaut), la file d'attente est effacée à chaque fois que le système de vision est placé en ligne.

Fermé Mode affichage

Spécifie si la séquence vidéo doit Se figer en cas d'échec, S'interrompre en cas d'échec ou ne rien faire en réponse à un échec (Normal). (Par défaut = Normal)

Fermé Délai de pause

Spécifie la durée de la pause en secondes si l'option S'interrompre en cas d'échec est choisie comme mode d'affichage. (1 à 120 ; par défaut = 5)

Fermé Style LED

Affiche les succès et échecs dans la séquence vidéo en tant que formes géométriques (rond vert [image] et rectangle rouge [image]), OK vert [image] et NG rouge [image] ou coche verte [image] et X rouge [image].

Fermé Chemin d'enregistrement

Spécifie un emplacement pour enregistrer les images de la séquence vidéo. L'utilisateur doit disposer des droits d'écriture pour l'emplacement indiqué.

Fermé Résultats de surveillance du capteur

La séquence vidéo peut être utilisée pour la surveillance en ligne ou la révision en ligne/hors ligne des résultats d'un projet.

  1. Cliquez sur le bouton En ligne [image] de la barre d'outils EasyBuilder pour placer le système de vision en ligne.
  2. Déclenchez l'acquisition d'images sur le système de vision. Au fil de l'acquisition des images, elles sont stockées sur le système de vision et alimentent la séquence vidéo en fonction du paramètre de file d'attente spécifié dans la zone de groupe Paramètres du capteur.
  3. Affichez dans la séquence vidéo les graphiques de statut mis à jour qui représentent les résultats des succès/échecs. Le système de vision reste en ligne, mais la séquence vidéo n'est plus mise à jour et passe en mode « figé » (indiqué par une barre jaune en haut de la zone d'affichage) si l'un des faits suivants se produit :
    • Un statut d'échec est attribué à un résultat et Se figer en cas d'échec ou S'interrompre en cas d'échec est spécifié dans la zone de groupe Paramètres du capteur.

    • Un graphique de statut est sélectionné dans la séquence vidéo, un bouton de navigation ou le bouton Figer a été utilisé.

      En mode « figé », vous pouvez parcourir les résultats dans la séquence vidéo ou enregistrer les images du système de vision sur l'ordinateur. Toutes les étapes de l'application sont désactivées pour éviter la modification accidentelle des paramètres du projet. Pendant ce temps, l'exécution du projet continue, mais aucun élément n'est ajouté à la file d'attente. La séquence vidéo reprend sa mise à jour et toutes les étapes de l'application sont activées si l'un des faits suivants se produit :

    • Le Délai de pause spécifié est écoulé.
    • Vous cliquez sur le bouton Continuer.
    • Vous cliquez sur le bouton Effacer la file d'attente.
  4. Quand la surveillance des résultats est terminée, cliquez à nouveau sur le bouton En ligne de la barre d'outils pour mettre le système de vision hors ligne.
Fermé Enregistrement des images du capteur sur l'ordinateur

Vous pouvez enregistrer les images d'un système de vision en ligne ou hors ligne sur l'ordinateur dans un dossier pour lequel vous disposez des droits d'écriture, et utiliser le mode Lecture sur PC pour lire les images.

Fermé Vérifiez le chemin d'enregistrement.
  1. Vérifiez que le système de vision est placé Hors ligne.

  2. Cliquez sur le bouton « Parcourir » en regard du champ Chemin d'enregistrement.

  3. Dans la boîte de dialogue Rechercher le dossier qui s'affiche, spécifiez le dossier de destination voulu et cliquez sur OK. Le chemin d'accès au dossier sélectionné s'affiche alors dans le champ Chemin d'enregistrement.
Fermé Enregistrement d'images d'un système de vision en ligne ou hors ligne sur un ordinateur.
  1. Sélectionnez un résultat dans la séquence vidéo ou cliquez sur le bouton Figer pour passer en mode « figé ». Ce mode est indiqué par une barre jaune en haut de la zone d'affichage. Toutes les étapes de l'application sont désactivées pour éviter la modification accidentelle des paramètres du projet. Pendant ce temps, l'exécution du projet continue, mais aucun élément n'est ajouté à la file d'attente.

  2. Cliquez sur le bouton Enregistrer sur le PC dans la séquence vidéo.

  3. Pour ajouter des images au dossier de destination, quittez le mode « figé » en cliquant sur le bouton Continuer ou Effacer la file d'attente dans la séquence vidéo, laissez un autre ensemble de résultats s'ajouter dans la file d'attente, puis répétez les étapes 1 et 2.


Paramètres du PC

Le bouton Lecture ouvre la boîte de dialogue d'options d'enregistrement/de lecture qui permet de configurer les paramètres d'enregistrement et de lecture de chaque système de vision et émulateur. Le mode de lecture sur l'ordinateur, accessible que le système de vision soit en ligne ou hors ligne, permet de lire jusqu'à 10 000 images pour vous aider à valider un projet. L'image est envoyée au système de vision et le projet est exécuté par rapport à l'image lue.

Exemple de séquence d'images lue depuis l'ordinateur

Fermé Configurer les paramètres d'enregistrement
Remarque : Lorsque des images couleur sont enregistrées sur l'ordinateur, elles sont enregistrées sous forme d'images de 16 bits plutôt que de 24 bits. lorsque des images couleur doivent être utilisées pour tester les outils couleur, vous pouvez exporter les images par le biais d'un serveur FTP (en ajoutant un serveur FTP à l'étape d'application Communication) pour enregistrer les images et préserver leur profondeur d'échantillonnage complète.
  1. Cliquez sur Lecture dans la zone de groupe Paramètres du PC.
  2. Dans la boîte de dialogue d'options d'enregistrement/de lecture qui s'affiche, cliquez sur l'onglet Enregistrement.
  3. Sélectionnez le répertoire souhaité comme répertoire d'enregistrement et configurez les autres paramètres d'enregistrement.
  4. Une fois tous les paramètres d'enregistrement spécifiés, cliquez sur OK pour fermer la boîte de dialogue d'options d'enregistrement/de lecture.
Fermé Enregistrer des images
  1. Dans la séquence d'images, cliquez sur le bouton PC.
  2. Cliquez sur le bouton Enregistrement de la barre d'outils EasyBuilder.
  3. Déclenchez l'acquisition d'image sur le système de vision. Au fur et à mesure que les images sont acquises, les images de succès/d'échec sont automatiquement triées et stockées dans le répertoire spécifié.
  4. Cliquez à nouveau sur le bouton Enregistrement pour arrêter l'enregistrement.
Fermé Configurer les paramètres de lecture
  1. Cliquez sur Lecture dans la zone de groupe Paramètres du PC.
  2. Dans la boîte de dialogue d'options d'enregistrement/de lecture qui s'affiche, cliquez sur l'onglet Lecture.

  3. Sélectionnez le répertoire souhaité comme répertoire de lecture et configurez les autres paramètres de lecture.

    Remarque : Le répertoire de lecture est défini par défaut sur le répertoire d'exemples de projets (Sample Jobs) d'EasyBuilder. Les exemples de projets EasyBuilder illustrent à quel point les options d'enregistrement/de lecture sont utiles. Elles permettent, par exemple, de parcourir une série d'images déjà acquises, affichant instantanément les résultats des outils afin de pouvoir en configurer rapidement les seuils et les limites.
  4. Une fois tous les paramètres de lecture spécifiés, cliquez sur OK pour fermer la boîte de dialogue d'options d'enregistrement/de lecture.
Fermé Lire les images depuis l'ordinateur
Remarque : pour pouvoir lire des images lorsque le système de vision est en ligne, le paramètre Déclencheur de l'étape d'application Configurer l'image doit être défini sur Externe, Manuel ou Réseau.

  1. Dans la séquence d'images, cliquez sur le bouton PC.

  2. Si le paramètre Déclencheur (à l'étape d'application Configurer l'image) est défini sur Caméra ou Continu, mettez le système de vision hors ligne pour lire les images. Si le paramètre Déclencheur est défini sur Externe, Manuel ou Réseau, le système de vision peut rester en ligne pour lire les images.
  3. Dans la séquence d'images, cliquez sur le bouton Lecture pour lire les images ou cliquez sur les boutons de navigation (présentés ci-dessous) pour parcourir manuellement les images.

    4. Lecture | Pause
Lire la première image | Lire l'image précédente
Lire l'image suivante | Lire la dernière image
  4. Cliquez sur l'étape d'application Exécuter le projet pour afficher le tableau de résultats (ou cliquez sur l'onglet Résultats de la palette).


Enregistrer le projet

Cette étape vous permet d'effectuer différentes tâches de gestion des fichiers et de maintenance des capteurs.

Remarque : Si la case à cocher Autoriser l'enregistrement en ligne des projets dans la boîte de dialogue Utilisateur est activée, les utilisateurs disposant d'un accès complet ou protégé sont autorisés à enregistrer des projets lorsqu'ils sont en ligne. Si la case à cocher Autoriser l'enregistrement en ligne des projets n'est pas activée, le système de vision doit être Hors ligne pour enregistrer des projets.

Enregistrer un projet (sous un nom spécifique)

Configurer les paramètres de démarrage

Sauvegarde d’une archive de sécurité

Restaurer une archive de sécurité


Enregistrer un projet (sous un nom spécifique)

Lorsque vous enregistrez un projet, seuls les paramètres d'outils et les informations spécifiques à ce projet sont enregistrés.

Remarque : vous pouvez enregistrer votre projet lors des précédentes étapes d'EasyBuilder, mais l'étape Enregistrer le projet constitue un rappel important. EasyBuilder ne fournit aucune fonction de « sauvegarde automatique ». Toute modification non enregistrée sera par conséquent perdue si le capteur est mis hors puis de nouveau sous tension.

Si un projet n'a pas encore été enregistré, la fonction Enregistrer fonctionne de manière identique à la fonction Enregistrer sous, qui ouvre la boîte de dialogue Enregistrer sous.

Fermé Enregistrer un projet (sous un nom spécifique) :
  1. Appuyez sur CTRL+S ou cliquez sur Enregistrer ou Enregistrer sous dans la zone de groupe Enregistrer le projet (ces actions ouvrent toutes la boîte de dialogue Enregistrer sous).
  2. Dans la boîte de dialogue, accédez à l'emplacement souhaité, le cas échéant.
  3. Attribuez un nom au projet.
  4. Cliquez sur Enregistrer dans la boîte de dialogue.
Fermé Pour enregistrer un projet existant, effectuez l'une des opérations suivantes :
  • Cliquez sur Enregistrer dans la zone de groupe Enregistrer le projet.
  • Appuyez sur CTRL+S.
Remarque : pour enregistrer l'image actuelle du projet, cliquez sur Enregistrer l'image sous... dans le menu Fichier. Pour enregistrer les paramètres et toutes les images du capteur, sauvegardez votre capteur ou émulateur In-Sight.


Configurer les paramètres de démarrage

Les commandes de la zone de groupe Options de démarrage permettent de spécifier les tâches qui s'exécutent automatiquement lorsqu'un système de vision/capteur ou émulateur In-Sight est activé, y compris le chargement d'un projet par défaut et la mise en ligne du système de vision/capteur.

Remarque : Seuls les utilisateurs disposant d'un accès complet peuvent configurer les paramètres de démarrage.

Sélectionner une Projet de démarrage

  1. Cliquez sur le bouton [image]. La boîte de dialogue Démarrage s'ouvre.
    1. Dans celle-ci, activez la case à cocher Charger projet au démarrage. La liste est activée et affiche les projets enregistrés sur le système de vision/capteur connecté, la carte SD du système de vision connecté, ou l'émulateur.

    2. Si Serveur de projets est activé, cochez la case Charger projet à distance au démarrage dans la boîte de dialogue. La liste est activée et affiche les projets enregistrés sur le Serveur de projets.

      Remarque :
      • Le Serveur de projets est désactivé par défaut. Utilisez la boîte de dialogue Paramètres du serveur de projets pour activer et configurer le serveur de projets.
      • Quand le Serveur de projets est activé, seul un projet enregistré dans le serveur de projets peut être sélectionné. Si un projet enregistré dans le système de vision doit être chargé au démarrage, désactivez le serveur de projets.
  2. Sélectionnez le projet que vous souhaitez charger automatiquement au démarrage.
  3. Cliquez sur OK. La boîte de dialogue se ferme.

  4. Dans la zone de texte Projet, le projet de démarrage sélectionné est affiché.

    Remarque :
    • Si le projet sélectionné se trouve sur la carte SD, la zone de texte Projet indique « SDCARD/xxx.job ».
    • La zone de texte Projet est en lecture seule. Pour modifier le projet de démarrage, cliquez sur le bouton [image].
  5. Si vous souhaitez désélectionner le projet de démarrage et commencer par un projet vide, cliquez à nouveau sur le bouton [image] et désactivez la case à cocher Charger projet au démarrage ou Charger projet à distance au démarrage.

Démarrer le capteur en mode En ligne

  1. Activez la case à cocher Démarrer le capteur en mode En ligne pour lancer automatiquement le capteur actif en mode en ligne au démarrage.

    Remarque : Vous pouvez également activer ce paramètre depuis la boîte de dialogue Démarrage.


Sauvegarde d'une archive de sécurité

Le bouton Sauvegarde permet aux utilisateurs disposant d'un accès total ou protégé de stocker une archive de sécurité des projets, des images et des paramètres de capteur d'un système/capteur de vision In-Sight ou d'un émulateur sur le disque dur de leur PC local.

Avant de sauvegarder un système/capteur de vision ou un émulateur sur le PC, cliquez sur Options dans le menu Système pour vous assurer que le dossier de destination ou le répertoire de sauvegarde destiné aux données archivées est défini selon vos besoins.

Sauvegarde du capteur ou émulateur actuel :

  1. Cliquez sur Sauvegarder dans la zone de groupe Maintenance du capteur.
Astuce : À l'aide de la boîte de dialogue Sauvegarde (système > Sauvegarder), vous pouvez stocker les sauvegardes de différents systèmes de vision/capteurs/émulateurs sur le PC ou la carte SD installée sur le système de vision. Pour en savoir plus, reportez-vous à la rubrique Boîte de dialogue Sauvegarde.


Restaurer une archive de sécurité

Le bouton Restaurer permet aux utilisateurs disposant d'un accès total ou protégé de récupérer une archive de sécurité des projets, des images et des paramètres de capteur depuis leur PC local pour les restaurer sur le système/capteur de vision In-Sight ou l'émulateur d'origine. La copie doit être sauvegardée sur le PC pour que ses fichiers apparaissent dans la boîte de dialogue.

Restauration d'une archive de sécurité sur le capteur ou l'émulateur actuel :

  1. Cliquez sur Restaurer dans la zone de groupe Maintenance du capteur.

Astuce : À l'aide de la boîte de dialogue Restaurer ou de la boîte de dialogue Restaurer depuis (Système > Restaurer depuis), vous pouvez restaurer une archive de sécurité sur un système de vision/capteur/émulateur différent ou bien restaurer une sauvegarde stockée sur la carte SD du système de vision. Pour en savoir plus, reportez-vous à la rubrique Boîte de dialogue Restaurer ou boîte de dialogue Restaurer depuis.


Exécuter le projet

Une fois que tous les paramètres du projet sont définis, vous pouvez l'exécuter, examiner les résultats et modifier ou dépanner les paramètres si nécessaire, puis tester votre projet pour vérifier que tous ses paramètres respectent leurs limites et que le système de vision In-Sight acquiert les images avec précision.

Exécuter votre projet sur un capteur

Modification ou impression du tableau de résultats

Afficher le tableau de résultats

Optimisation de projet et dépannage

Test de votre projet avec TestRun™


Exécuter votre projet sur un capteur

L'exécution d'un projet sur un capteur consiste simplement à placer le capteur en ligne.

Remarque : Si une ligne d'entrée ou de sortie fait l'objet d'une activation ou désactivation forcée durant l'étape d'application Entrées/Sorties, un avertissement s'affiche dans la zone de groupe Statut du projet. Dans ce cas, vérifiez qu'aucun dommage ne se produit si l'équipement est mis sous tension ou hors tension avant de placer le capteur en ligne ou hors ligne.

Placement du capteur en ligne et hors ligne :

  • Pour le placer en ligne : Cliquez sur le bouton En ligne du volet des paramètres. Le bouton est à bascule, il devient orange pour indiquer l'état En ligne.
    Apparence du bouton quand il est hors ligne
  • Pour le placer hors ligne : Cliquez sur le bouton orange En ligne du volet des paramètres. Le bouton reprend sa couleur d'origine pour indiquer l'état Hors ligne.
    Apparence du bouton quand il est en ligne


Modification ou impression du tableau de résultats

Cliquez sur Options dans le volet de paramètres pour ouvrir la boîte de dialogue Options d'affichage des résultats, qui vous permet de modifier le tableau de résultats.

La boîte de dialogue Options d'affichage des résultats contient les contrôles suivants :

  • Options d'affichage Fermé : vous permettent d'activer ou de désactiver le dimensionnement automatique de la largeur des colonnes, d'afficher les taux de succès/d'échecs sous forme de pourcentages ou de totaux et de supprimer/ajouter l'icône des outils et les colonnes Durée, Résultat, de graphiques de dépendances des outils, Succès/Échec et d'affichage de l'état activé des outils du/dans le tableau de résultats.

    La colonne d'affichage de l'état activé indique l'état d'un outil (Activé, Désactivé ou ligne d'entrée associée), défini dans les étapes Localiser la pièce et Inspecter une pièce .
  • Options d'outils Fermé : vous permettent de masquer/afficher les graphiques superposés d'un outil dans le volet Image (colonne Afficher le graphique) et de masquer/afficher le profil d'un outil dans le tableau de résultats (colonne Afficher l'outil).

    Pour appliquer ces paramètres à des outils individuels, activez ou désactivez les cases à cocher correspondantes. Pour les appliquer à la totalité ou à aucun des outils du projet, cliquez sur les boutons Tout ou Aucun de la section Options de modification.

    Par défaut, toutes les cases sont cochées.
  • Paramètres par défaut Fermé : ce contrôle annule les préférences de tri et rétablit les paramètres par défaut du tableau de résultats. Les colonnes par défaut incluent l'indicateur de succès/d'échecs, les graphiques de dépendances et l'icône des outils, le nom, le résultat, le nombre de succès/d'échecs (affichés sous forme de totaux) et la durée. La taille des colonnes s'adapte automatiquement à la largeur de la Vue EasyBuilder.

Le volet de paramètres comprend d'autres contrôles liés au tableau de résultats, notamment :

  • Imprimer Fermé : ouvre la fenêtre Aperçu avant impression, qui vous permet d'imprimer toutes les pages, d'effectuer un zoom à l'aide des pourcentages prédéfinis, de sélectionner le nombre de pages à afficher en même temps ou de sélectionner une page spécifique à afficher. Vous pouvez également ouvrir la boîte de dialogue Mise en page et sélectionner le format, la source et l'orientation du papier, les marges des pages et l'imprimante.
  • Effacer les totaux succès/échecs Fermé : remet les totaux de succès/échecs à 0 et reprend le comptage depuis le début.


Afficher le tableau de résultats

Le tableau de résultats, affiché dans le volet de paramètres, présente le profil de chaque outil du projet. Pour trier le tableau par colonne, cliquez sur le titre de la colonne. Pour inverser l'ordre de tri, cliquez à nouveau sur le titre de la colonne. Pour restaurer le tri par défaut, cliquez une troisième fois sur le titre de la colonne. Les outils peuvent également être réorganisés dans le tableau en les glissant-déposant dans l'ordre souhaité dans le tableau.

Remarque : Les outils peuvent être réorganisés dans le tableau de résultats en les glissant-déposant dans l'ordre souhaité. Cela peut être fait dans le tableau de résultats de l'étape Exécuter le projet comme dans le tableau sous l'onglet Résultats de la palette, et met à jour les deux tableaux. Le tri par glisser-déposer n'est activé que lorsque la colonne Ordre et graphiques de dépendances des outils du tableau est sélectionnée (cette colonne est sélectionnée par défaut). Sélectionnez une nouvelle fois la colonne pour inverser l'ordre. La liste ne peut plus être réorganisée si la limite de taille du projet est proche ou a été atteinte.

Le tableau de résultats comprend les colonnes par défaut suivantes (de gauche à droite) :

  • Indicateur de succès/échecs : utilise un cercle vert [image] et un rectangle rouge [image] pour représenter les succès et les échecs, respectivement. Les critères de succès/d'échec sont définis aux étapes Localiser la pièce et Inspecter une pièce.

  • Ordre et graphiques de dépendances des outils : affiche l'ordre des outils et les dépendances entre l'outil sélectionné (affiché en orange) et les autres outils. Sélectionnez cette colonne pour trier les outils selon l'ordre dans lequel ils ont été ajoutés au projet. Définir le tri sur cette colonne vous permet également de glisser-déposer les outils dans l'ordre que vous souhaitez. Les outils d'un Outil mathématique & logique Groupe peuvent être ajoutés ou supprimés du groupe en développant l'outil, puis en faisant glisser l'outil voulu dans le groupe ou en dehors de celui-ci.

    Remarque : les outils Groupe ne peuvent pas être déposés dans d'autre outils Groupe, et les outils qui entraîneraient une référence circulaire ne peuvent pas être ajoutés à un outil Groupe.

    Il existe une dépendance lorsqu'un outil référence un autre outil. Il y a deux parties dans chaque dépendance : un précédente et un dépendant, qui sont reliés par une ligne. Le précédent, représenté par un cercle, renvoie à la source des données (c'est-à-dire l'outil envoyant l'entrée). Le dépendant, représenté par une flèche, indique la destination des données (c'est-à-dire l'outil qui reçoit la sortie). Les graphiques de dépendances bleus indiquent que l'outil sélectionné est la destination ; les verts indiquent que l'outil sélectionné est la source.

  • Icône d'outil : indique visuellement le type d'outil utilisé (par exemple, de présence/absence de transition, d'identification Lire le texte ou de comptage de blobs).
  • Nom : affiche le nom de l'outil, dont le nom par défaut peut être modifié à l'étape Localiser la pièce ou Inspecter une pièce.

  • Résultat : affiche les résultats de l'outil, qui sont également affichés dans l'onglet Paramètres ou Limites de plages du volet de paramètres des étapes Localiser la pièce ou Inspecter une pièce.

    Modèles In-Sight | Résultats

    Capteurs de vision In-Sight 2000-110 et 2000-120/120C

             État Succès/Échec uniquement
    Capteurs de vision In-Sight 2000-130/130C

    Outils d'inspection de comptage et de mesure : Résultats standard (données numériques)
    Outil de présence/absence de modèle : État Réussite/Échec et score de modèle
    Autres outils : État Succès/Échec uniquement
    Systèmes de vision In-Sight (tous modèles) et capteurs de vision In-Sight 2000 série 23X (23M, 230) | Résultats standard (aucune limitation)
  • Succès : affiche le taux de succès de l'outil sous forme de pourcentage ou en renvoyant le nombre de résultats valides par rapport au total de résultats (par défaut).
  • Échec : affiche le taux d'échec de l'outil sous forme de pourcentage ou en renvoyant le nombre de résultats non valides par rapport au total de résultats (par défaut).
    • Remarque : Lorsqu'un outil est désactivé, ses signaux restent dans leur dernier état. Si l'outil était en échec il est alors désactivé, Succès sera alors 0 et Échec 1. Cependant, le Succès/Échec du succès global ne sera pas affecté par le Succès/Échec de l'outil désactivé.
  • Durée (ms) : affiche la durée, en millisecondes, requise pour l'exécution de l'outil.

  • Type : affiche le type d'outil. Par exemple, « Modèles PatMax RedLine™ (1-10) » est affiché pour l'outil de recherche « Modèles PatMax RedLine™ (1-10) » et « Modèles PatMax® (1-10) » est affiché pour l'outil de recherche « Modèles PatMax® (1-10) ».

    Remarque : Pour masquer la colonne Type, effectuez un clic droit et sélectionnez Afficher la colonne Type.

La zone de groupe État du projet, à gauche du tableau de résultats, affiche le taux de succès global (Taux) de toutes les images affichées depuis la dernière fois que les totaux succès/échecs ont été effacés, ainsi que la durée du projet (Durée) de l'image actuelle.

  • Modification ou impression du tableau de résultats


Optimisation de projet et dépannage

Vous pouvez utiliser ces informations pour localiser les éventuels problèmes ou optimiser les paramètres du projet.

Voici quelques exemples indiquant comment le tableau de résultats peut vous aider à résoudre les problèmes rencontrés :

  • Totaux succès/échecs : permettent d'identifier les outils défaillants.
  • Graphiques de dépendances des outils : permettent de déterminer si la défaillance d'un outil est associée à la défaillance d'un autre outil en affichant les relations de dépendance entre les outils.
  • Chaînes de résultat : permettent de déterminer les outils qui sont hors spécifications.

L'optimisation d'un projet implique souvent de réduire la durée d'exécution, qui peut varier en fonction des capacités des différents capteurs In-Sight. L'optimisation des projets n'est importante que dans le cadre d'applications programmées (telles que les applications impliquant des vitesses de ligne élevées).

Lors de l'exécution d'un projet EasyBuilder, les étapes suivantes sont celles qui demandent le plus de temps :

  • Délai d'acquisition : durée d'exposition + durée du transfert vers le CCD (dispositif à couplage de charges)
  • Exécution des outils : somme de la durée d'exécution de tous les outils et fonctions

Vous trouverez ci-dessous quelques directives générales qui vous permettront de réduire la durée d'exécution des projets :

  • Réduire la durée d'exposition.
  • Effectuer une acquisition partielle.
  • Définir une région d'intérêt plus petite.
  • Limiter la rotation de l'image.

Si nécessaire, vous pouvez retourner à l'étape Configurer l'image, Localiser la pièce ou Inspecter une pièce pour modifier les paramètres à votre guise.

Voici, par ailleurs, les vitesses relatives des principaux outils de recherche et d'inspection de pièces (du plus rapide au plus lent) :

  • Transition
  • Blob
  • Modèle

Ainsi, si un outil de transition et un outil de modèle fournissent le même résultat, utilisez l'outil de transition.

Remarque : du fait du chevauchement possible des fonctions d'acquisition et de traitement, la durée d'exécution réelle en production peut s'avérer inférieure à celle définie à l'étape Exécuter le projet.


Test de votre projet avec TestRun™

TestRun™ exécute les tests dans le système de vision In-Sight et compare les résultats de ces tests aux valeurs attendues. TestRun comprend les tests suivants pour un système de vision In-Sight :

  • Tests de limites : vérifie une liste de paramètres et détermine si la valeur actuelle est comprise dans les limites maximum et minimum, comme défini pour ce paramètre. Ces paramètres peuvent être configurés par les utilisateurs directement dans le projet, les entrées discrètes peuvent être lues dans le projet ou les valeurs peuvent être envoyées par un périphérique externe grâce à un protocole de communication.
  • Tests d’image : envoie une série d'images de qualité connue (« bonne » ou « mauvaise ») à un système de vision, et détermine si les résultats du projet actuel correspondent aux résultats attendus pour chaque image.
  • Tests de matériel : compare la qualité d'une image actuelle dans le système de vision à la qualité attendue d'une image, pour déterminer s'il y a eu des variations dans la position de la caméra, la mise au point, les conditions d'éclairage, etc.

Avant d'utiliser TestRun

Remarque : TestRun est uniquement disponible aux utilisateurs ayant un droit d'accès complet.

TestRun présume les éléments suivants :

  • l'application de vision industrielle a déjà été conçue et est enregistrée comme un fichier .job dans un système de vision In-Sight ;
  • lors de l'étape Établir une connexion, la connexion au système de vision a été établie et le fichier .job a été chargé ;
  • une base de données contenant les images utilisées par l'application a été créée.
Remarque : la base de données d'images contiendra, idéalement, des exemples d'images « bonnes » (des images qui génèrent un résultat de Succès) et des images « mauvaises » (des images qui génèrent un résultat d'Échec). TestRun est capable de fonctionner avec différentes structures d'organisation de fichiers pour la base de données d'images. Cependant, il sera utile de classer les images dans des dossiers d'images « bonnes » et « mauvaises » avant de lancer TestRun afin de simplifier le processus.

Utilisation de TestRun

La configuration de TestRun peut commencer après s'être connecté au système de vision In-Sight souhaité et après avoir chargé le fichier .job approprié dans le système de vision. TestRun est configuré grâce à la boîte de dialogue Paramétrage TestRun, qui présente des écrans permettant de programmer TestRun étape par étape. Un volet de navigation est fourni à gauche de la boîte de dialogue, et à partir duquel les écrans de paramétrage peuvent être sélectionnés.

Remarque : après avoir configuré TestRun pour la première fois, vous pouvez revenir sur n'importe quelle étape en sélectionnant l'étape dans le volet de navigation.

Configuration de TestRun

  1. Dans la Palette, cliquez sur l'onglet TestRun.
Remarque : si la Palette n'est pas visible, sélectionnez Palette à partir du menu Affichage.
  2. Cliquez sur le bouton Configurer pour lancer la boîte de dialogue Paramétrage TestRun.
  3. Suivez les écrans étape par étape pour configurer TestRun. Pour des informations complémentaires, consultez le fichier d’aide In‑Sight® Explorer.


Informations juridiques

Le logiciel décrit dans le présent document est fourni sous licence. Il ne peut être copié ou utilisé qu'en accord avec les dispositions de ladite licence, accompagnée de la notice de copyright présentée sur cette page. Le logiciel, le présent document ou toute copie de ce document ne peuvent en aucun cas être remis ou mis à la disposition d'une personne autre que le titulaire de la licence. Les droits et la propriété de ce logiciel sont conservés par Cognex Corporation ou par le concédant de la licence. Cognex Corporation n'assume aucune responsabilité quant à l'utilisation ou la fiabilité de son logiciel sur un équipement non fourni par Cognex Corporation. Cognex Corporation exclut toute garantie, explicite ou implicite, en ce qui concerne le logiciel décrit dans ce document, sa qualité marchande, l'absence de contrefaçon et son adéquation à un usage particulier.

Les informations contenues dans le présent document pourront faire l'objet de modifications sans préavis, et elles ne peuvent être interprétées comme un engagement de la part de Cognex Corporation. Cognex Corporation n'est pas responsable des erreurs éventuellement présentes dans cette documentation ou dans le logiciel qui lui est associé.

Les entreprises, noms et données utilisés dans les exemples du présent manuel sont fictifs, sauf indication contraire. Aucune partie de ce document ne peut être copiée ou transmise, sous quelque forme ou par quelque moyen, électronique ou mécanique, à quelque fin que ce soit, ni transférée vers un autre support ou traduite dans une autre langue sans l'autorisation écrite de Cognex Corporation.

08/29/2022 07:05

Revision: 5.9.0.2

Copyright © 2008 - 2020. Cognex Corporation. Tous droits réservés.

Des parties du matériel et du logiciel fournis par Cognex peuvent être couvertes par un ou plusieurs brevets américains ou étrangers, ainsi que par des brevets américains ou étrangers en instance, répertoriés sur le site Web Cognex à l'adresse : http://www.cognex.com/patents.

Marques déposées de Cognex Corporation :

Cognex, 2DMAX, Advantage, AlignPlus, Assemblyplus, Check it with Checker, Checker, Cognex Vision for Industry, Cognex VSOC, CVL, DataMan, DisplayInspect, DVT, EasyBuilder, Hotbars, IDMax, In‑Sight, Laser Killer, MVS‑8000, OmniView, PatFind, PatFlex, PatInspect, PatMax, PatQuick, SensorView, SmartView, SmartAdvisor, SmartLearn, UltraLight, Vision Solutions, VisionPro, VisionView

Marques commerciales de Cognex Corporation :

Le logo Cognex, 1DMax, 3D‑Locate, 3DMax, BGAII, CheckPoint, Cognex VSoC, CVC‑1000, FFD, iLearn, In‑Sight (design insignia avec réticule), In‑Sight 2000, InspectEdge, Inspection Designer, MVS, NotchMax, OCRMax, PatMax RedLine, ProofRead, SmartSync, ProfilePlus, SmartDisplay, SmartSystem, SMD4, VisiFlex, Xpand

Les autres marques commerciales de produits et de sociétés identifiées dans le présent document appartiennent à leurs propriétaires respectifs.


Formatage des données d'entrée/de sortie

Les données issues des projets EasyBuilder, comme les résultats de l'outil individuel ou les résultats du projet global (sortie uniquement), peuvent être communiquées sur Ethernet/IP, DeviceNet, Modbus TCP, PROFINET et POWERLINK. Les données d'entrée formatées seront lues une fois que le capteur aura acquis une image et les données de sortie seront envoyées une fois que le capteur aura terminé l'exécution du projet.

Remarque : DeviceNet, POWERLINK, et CC-Link sont disponibles uniquement sur les systèmes de vision In-Sight exploitant le micrologiciel In-Sight 4.x.x, mais pas sur les systèmes de vision In-Sight exploitant les versions de micrologiciel In-Sight 5.1.0 et ultérieures. Reportez-vous à Versions du micrologiciel pour obtenir une liste complète des modèles et des versions du micrologiciel prises en charge.

Pour formater vos données :

  1. Cliquez sur l'onglet Formater les données d'entrée ou Formater les données de sortie.
  2. Cliquez sur le bouton Ajouter pour lancer la boîte de dialogue Sélectionner les données d'entrée ou Sélectionner les données de sortie.
  3. La boîte de dialogue Sélectionner les données d'entrée ou Sélectionner les données de sortie contient les données de tous les outils de recherche ou d'inspection ajoutés à votre projet, ainsi que les résultats du projet global (sortie uniquement). Dans la boîte de dialogue, sélectionnez les données à envoyer depuis (ou vers) le capteur In-Sight, puis cliquez sur le bouton OK.

  4. Après avoir ajouté vos données, vous pouvez modifier le type de données par défaut des données sélectionnées en choisissant un type de données différent dans la liste déroulante Type de données.

    Remarque :
    • Si vous sélectionnez Chaîne ou Chaîne convertie en octets dans la liste déroulante Type de données, le contrôle Taille d'élément (octets) est activé et vous pouvez spécifier la longueur de chaîne en choisissant le nombre d'octets approprié.
    • Si vous utilisez PROFINET, la longueur maximale des données d'entrée et de sortie est de 4 000 octets. Si vous utilisez POWERLINK, la longueur maximale des données d'entrée et de sortie est de 256 octets.

  5. Vous pouvez également personnaliser l'ordre des octets en spécifiant Octet de poids faible en premier ou Octet de poids fort en premier en décochant la case Octet de poids fort/Octet de poids faible (elle est décochée par défaut pour tous les protocoles sauf PROFINET). Vous pouvez personnaliser l'ordre des mots en spécifiant Mot de poids faible en premier ou Mot de poids fort en premier en décochant la case Mot de poids fort/Mot de poids faible (elle est décochée par défaut). Toutes les modifications apportées dans l'onglet Format des données de sortie sont mises à jour dans la fenêtre d'aperçu.

    Remarque : Toute modification apportée à l'ordre des octets ou des mots affectera l'ensemble des signaux de données dans les onglets Formater les données de sortie et Formater les données d'entrée.
  6. Réorganisez l'ordre des données qui seront envoyées ou reçues en sélectionnant les données dans la liste, puis en cliquant sur les boutons Haut ou Bas pour définir l'ordre souhaité.


Groupe Caliper

Les groupes Caliper permettent d'isoler des transitions dans une région de l'image, en utilisant la méthode de modèle de transition dans laquelle les crêtes de transitions sont détectées dans chaque caliper au moyen d'un noyau 1D. Le groupe Caliper génère une représentation 1D de la partie de l'image qui contient les transitions d'intérêt. Cette image 1D contiendra non seulement les transitions d'intérêt, mais aussi d'autres transitions causées par le bruit et d'autres informations indésirables dans l'image d'origine. L'application, sur une image 1D, des paramètres Taille du caliper, Largeur de transition et Contraste minimum de l'onglet Transitions des outils qui utilisent le Groupe Caliper augmente la force des transitions d'intérêt tout en réduisant le bruit de l'image.

Chaque caliper du groupe est évalué individuellement, et les transitions possibles qu'il contient sont évaluées pour déterminer la transition à sélectionner. Pour les défauts de position, une ligne ajustée de façon optimale est créée sur la base de chaque transition localisée. Les défauts sont ensuite déterminés en comparant la transition localisée à la ligne ajustée de façon optimale pour détecter les variations par rapport aux tolérances spécifiées. Pour les défauts de largeur, la distance entre les deux transitions localisées dans le caliper est calculée pour être déterminée, et les défauts sont déterminés en comparant la distance par rapport à la plage prévue.

Le groupe Caliper dans la région définit la taille des défauts et/ou écarts détectables. La taille des défauts ou écarts détectables est déterminée par le nombre de transitions pouvant être détectées, lui-même déterminé par le nombre de calipers placés le long de la transition. Les calipers sont affichés dans la région sous forme de rectangles rouges lorsque la case Afficher tous les calipers est cochée (décochée par défaut).

Remarque : Plus le nombre de calipers appliqués dans la région est élevé, plus l'exécution de l'outil prend de temps.


Ajout et modification de modèles de couleurs

Un modèle de couleurs est un ensemble de couleurs utilisées pour définir un objet et l'arrière-plan dans une image. Chaque modèle de couleurs représente un espace de couleur 3D dans lequel vous ajoutez ou soustrayez les valeurs RVB des couleurs de l'objet et de l'arrière-plan en cours d'acquisition.

Fermé Ajout d'un modèle de couleurs
  1. Dans le menu déroulant Bibliothèque de couleurs de l'onglet Paramètres, sélectionnez la bibliothèque de couleurs à utiliser. Par défaut, la première bibliothèque de couleurs (ExtractColorLibrary_1) est sélectionnée.
  2. Cliquez sur le bouton Apprendre la couleur pour afficher la boîte de dialogue Apprentissage ExtractColor.
  3. Dans la zone de groupe Modèles de couleurs de la boîte de dialogue Apprentissage ExtractColor, cliquez sur le bouton Nouveau modèle pour ajouter un nouveau modèle de couleurs dans la bibliothèque de couleurs. Le nom par défaut est « Modèle_1 » s'il s'agit du premier modèle de couleurs ajouté dans la bibliothèque de couleurs. Sinon, il est incrémenté (par exemple, « Modèle_2 », « Modèle_3 », etc.).
  4. Le cas échéant, remplacez le nom du modèle de couleurs par un nom plus spécifique à votre application, notamment si vous prévoyez d'avoir plusieurs modèles de couleurs. Un modèle de couleurs peut être renommé à tout moment. Pour cela, mettez le modèle de couleurs en surbrillance et cliquez sur le bouton Renommer situé au-dessus du répertoire Bibliothèque de couleurs.
  5. Pour supprimer un modèle de couleurs de la liste, sélectionnez le modèle de couleurs et cliquez sur le bouton Supprimer le modèle.
Fermé Ajout et soustraction de couleurs dans un modèle de couleurs
Fermé Ajout ou soustraction d'une seule couleur dans un modèle de couleurs
  1. Sélectionnez le modèle de couleurs à modifier.
  2. Dans la zone de groupe Apprendre, sélectionnez Couleur la plus dominante (paramètre par défaut).
  3. Dans la zone de groupe Apprendre, sélectionnez le type de région à utiliser pour définir la couleur : Région, Cercle, Anneau, Polygone ou À main levée.
  4. Cliquez sur le bouton Ajouter une nouvelle couleur ou Soustraire une nouvelle couleur et configurez la région de l'image de façon à ce qu'elle englobe uniquement les valeurs RVB à ajouter ou soustraire.
  5. Lorsque vous avez terminé, double-cliquez sur la région ou cliquez sur le bouton OK de la barre d'outils Modifier le projet.
  6. Pour une opération Ajouter, la couleur ajoutée au modèle de couleurs contient les valeurs RVB de crête issues de la région et ces valeurs seront ajoutées au modèle de couleurs global.
  7. Pour une opération Soustraire, la couleur ajoutée au modèle de couleurs contient les valeurs RVB de crête issues de la région et ces valeurs seront soustraites du modèle de couleurs global.
  8. Les couleurs de la liste Modèle de couleurs peuvent être déplacées sur la liste pour modifier la couleur qui commence ou termine l'opération. La première couleur appliquée lors de l'inspection est la première de la liste.
Fermé Ajout ou soustraction de plusieurs couleurs dans un modèle de couleurs
  1. Sélectionnez le modèle de couleurs à modifier.
  2. Dans la zone de groupe Apprendre, sélectionnez Plusieurs couleurs.
  3. Dans la zone de groupe Apprendre, sélectionnez le type de région à utiliser pour définir la couleur : Région, Cercle, Anneau, Polygone ou À main levée.
  4. Cliquez sur le bouton Ajouter une nouvelle couleur ou Soustraire une nouvelle couleur et configurez la région de l'image de façon à ce qu'elle englobe uniquement les valeurs RVB à ajouter ou soustraire.
  5. Lorsque vous avez terminé, double-cliquez sur la région ou cliquez sur le bouton OK de la barre d'outils Modifier le projet.
  6. Pour une opération Ajouter, la couleur ajoutée au modèle de couleurs contient les valeurs RVB de crête issues de la région et ces valeurs seront ajoutées au modèle de couleurs global.
  7. Pour une opération Soustraire, la couleur ajoutée au modèle de couleurs contient les valeurs RVB de crête issues de la région et ces valeurs seront soustraites du modèle de couleurs global.
  8. Les couleurs de la liste Modèle de couleurs peuvent être déplacées sur la liste pour modifier la couleur qui commence ou termine l'opération. La première couleur appliquée lors de l'inspection est la première de la liste.
Fermé Réglage de la tolérance d'une couleur

L'utilisation combinée des contrôles de marquage d'image et de tolérance de couleur permet de déterminer le pourcentage de détection de l'objet. Vous pouvez régler les contrôles de tolérance de couleur pour augmenter ou réduire la sensibilité de l'outil en utilisant les paramètres Plus sombre, Plus clair, Mises en surbrillance et Teintes de la zone de groupe Tolérance de couleur de la boîte de dialogue Apprentissage ExtractColor.

Astuce : lors de la configuration des contrôles de tolérance de couleur, positionnez la boîte de dialogue Apprentissage ExtractColor de façon à ce qu'elle ne masque pas l'image. Selon le type de marquage d'image sélectionné, l'image reflète en effet les modifications au fur et à mesure que vous réglez les contrôles.
Fermé Contrôles de tolérance de couleur
Fermé Plus sombre

L'augmentation de ce paramètre étend l'espace de la couleur vers le noir (0, 0, 0).

Fermé Plus clair

L'augmentation de ce paramètre étend l'espace de la couleur vers le blanc (255, 255, 255).

Fermé Mises en surbrillance

L'augmentation de ce paramètre étend l'espace de la couleur de la position de couleur initiale vers le blanc (255, 255, 255).

Fermé Teintes

L'augmentation de ce paramètre augmente la « zone » 3D de la couleur initiale en trois dimensions dans l'espace de couleur.

Fermé Contrôles de marquage d'image

Les boutons Marquage d'image permettent de définir ce qui est mis en surbrillance dans l'image lorsque vous ajoutez/soustrayez une ou plusieurs couleurs et un ou plusieurs modèles de couleurs.

Fermé Marquer les résultats du groupe entier

Toutes les couleurs de votre modèle de couleurs sont marquées dans l'image.

Fermé Marquer les résultats jusqu'à la couleur sélectionnée

Si vous sélectionnez la deuxième couleur d'une liste en comportant trois, les première et deuxième couleurs sont marquées dans l'image.

Fermé Marquer les couleurs sélectionnées uniquement

Seule la couleur sélectionnée est marquée dans l'image.

Fermé Modification d'un modèle de couleurs
  1. Dans le menu déroulant Bibliothèque de couleurs de l'onglet Paramètres, sélectionnez la bibliothèque de couleurs à utiliser.
  2. Cliquez sur le bouton Apprendre la couleur pour afficher la boîte de dialogue Apprentissage ExtractColor.
  3. Sélectionnez le modèle de couleurs à modifier et utilisez les contrôles de la boîte de dialogue pour le modifier.


Ajout et modification de couleurs

Les couleurs sont définies par une région et stockent les valeurs moyennes RGB et HSI contenues dans cette région au moment de l'apprentissage. La bibliothèque peut contenir jusqu'à 100 couleurs différentes composées de valeurs RGB/HSI de l'objet en cours d'examen.

Fermé Ajout d'une couleur
  1. Dans l'onglet Paramètres, sélectionnez la Bibliothèque de couleurs à référencer dans le menu déroulant Bibliothèque de couleurs. Par défaut, la première Bibliothèque de couleurs (BibliothèqueCouleursCorrespondantes_1) est sélectionnée.
  2. Appuyez sur le bouton Apprendre couleurs pour lancer la boîte de dialogue Apprentissage des couleurs correspondantes.
  3. Dans la zone de groupe Apprentissage, sélectionnez le type de région qui servira à définir la couleur : Région, Cercle, Anneau, Polygone, Dessin à main levée ou Point.
  4. Cliquez sur le bouton Ajouter une couleur et configurez la région dans l'image de manière à ce qu'elle inclue uniquement les valeurs RGB que vous désirez ajouter ou enlever.
  5. Double-cliquez sur la région ou appuyez sur le bouton OK de la barre d'outils Modification de projet après avoir configuré la région.
  6. Le cas échéant, renommez la couleur avec un nom plus spécifique à votre application, surtout si vous avez plusieurs couleurs. Une couleur peut être renommée à tout moment en la mettant en surbrillance, puis en appuyant sur le bouton Renommer placé au-dessus du répertoire Bibliothèque de couleurs.
  7. Les couleurs peuvent être supprimées de la liste en les sélectionnant, puis en appuyant sur le bouton Supprimer modèle.
Fermé Ajustement de la tolérance d'une couleur

En utilisant les contrôles Tolérance des couleurs, vous pouvez déterminer la proportion de votre objet qui est détectée et ajuster les contrôles Tolérance des couleurs pour augmenter ou réduire la sensibilité de l'outil à l'aide des paramètres de la zone de groupe Tolérance des couleurs de la boîte de dialogue Apprentissage des couleurs correspondantes.

Astuce : en configurant les contrôles Tolérance des couleurs, placez la boîte de dialogue Apprentissage des couleurs correspondantes de manière à voir facilement l'image. En ajustant les contrôles, l'image se met à jour pour refléter les modifications.
Fermé Plus foncé

Spécifie la limite Plus foncé (0 à 1.0 ; par défaut = 1.0). Quand l'espace de couleur est défini sur RGB, la limite Plus foncé développe la couleur apprise proportionnellement moins le long d'une ligne allant de (0,0,0) à la valeur RGB de la couleur apprise. Quand l'espace de couleur est défini sur HSI, la limite Plus foncé développe moins la valeur d'intensité de la couleur apprise.

Fermé Plus clair

Spécifie la limite Plus clair (1.0 à 10.0 ; par défaut = 1.0). Quand l'espace de couleur est défini sur RGB, la limite Plus clair développe la couleur apprise proportionnellement plus le long d'une ligne allant de (0,0,0) à la valeur RGB de la couleur apprise. Quand l'espace de couleur est défini sur HSI, la limite Plus clair développe plus la valeur d'intensité de la couleur apprise.

Fermé Modification d'un modèle de couleur
  1. Dans l'onglet Paramètres, sélectionnez la Bibliothèque de couleurs à référencer dans le menu déroulant Bibliothèque de couleurs.
  2. Appuyez sur le bouton Apprendre couleurs pour lancer la boîte de dialogue Apprentissage de couleur extraite.
  3. Sélectionnez le Modèle de couleur à modifier et utilisez les contrôles de la boîte de dialogue pour modifier le Modèle de couleur.


Transitions possibles

Lorsque vous utilisez un outil qui intègre des groupes de Calipers, les transitions possibles sont illustrées par des petits cercles de couleur.

Fermé Exemple - Réussite de ligne droite ajustée de façon optimale

Fermé Exemple - Échec de ligne droite ajustée de façon optimale

Fermé Exemple - Échec de ligne circulaire ajustée de façon optimale


Outil de présence/absence de netteté - Onglet Paramètres

Fermé Lissé

Définit une opération de lissage de l'image (0-2; valeur par défaut = 0) pour aider à éliminer le bruit de haute fréquence pouvant être présent dans la région. Lorsqu'il est défini sur 0, aucun lissage n'est effectué et ce paramètre fournit les performances les plus rapides. Lorsqu'il est défini sur 1, un degré de lissage sera appliqué, qui élimine le bruit de haute fréquence dans la région. Lorsqu'il est défini sur 2, un degré de lissage plus élevé est appliqué, qui élimine le bruit de haute fréquence et de basse fréquence dans la région.