Verbindung herstellen

Willkommen bei EasyBuilder®, einer Möglichkeit zur schrittweisen Erstellung von Vision-Anwendungen oder Jobs. Der Schritt Verbindung herstellen dient zum Herstellen einer Verbindung mit In-Sight-Vision-Systemen, Vision-Sensoren und/oder Emulatoren sowie zum Konfigurieren deren Einstellungen, um mit der Erstellung von Jobs zu beginnen.

Hinweis:
  • Speichern Sie Ihre Fortschritte beim Erstellen eines Jobs regelmäßig durch Drücken von STRG+S. Ist im Dialogfeld Benutzer das Kontrollkästchen Speichern von Onlinejob zulassen aktiviert, können Benutzer mit Vollzugriff oder geschütztem Zugriff Jobs im Onlinestatus speichern. Ist das Kontrollkästchen Speichern von Onlinejob zulassen nicht aktiviert, muss das Vision-System offline sein, um Jobs speichern zu können.
  • Manche EasyBuilder-Anwendungsschritte sind abhängig von Ihren Zugriffsrechten, der momentan ausgeführten Aufgabe oder dem verbundenen Sensor oder Emulator unter Umständen deaktiviert.

EasyBuilder-Hilfe

Die EasyBuilder-Hilfedatei wird in zwei Formaten zur Verfügung gestellt: als Paletten-Hilfe und Onlinehilfe. Die EasyBuilder-Palettenhilfe wird auf der Registerkarte "Hilfe" der Palette bereitgestellt, während die EasyBuilder-Onlinehilfe im CHM-Format mit Suchfunktionen bereitgestellt wird. Zum Starten der EasyBuilder-Onlinehilfe drücken Sie auf der Tastatur die F1-Taste, klicken Sie in der Registerkarte Hilfe der Palette auf die Schaltfläche Hilfe [image], oder wählen Sie im Menü Hilfe die Option EasyBuilder-Hilfe.

Herstellen einer Verbindung mit einem In-Sight-Sensor oder -Emulator

Starten oder Öffnen eines EasyBuilder-Jobs

Copyright © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder-Hilfe | 2022 August 22 | Revision: 5.9.0.2


Herstellen einer Verbindung mit einem In-Sight-Sensor oder -Emulator

Das Gruppenfeld In-Sight-Sensor oder Emulator auswählen listet die zur Verfügung stehenden In-Sight Vision-Systeme/Sensoren und -Emulatoren auf. Gleichzeitig kann nur ein Vision-System/Sensor oder -Emulator verbunden sein. Die Informationen über das verbundene Vision-System/Sensor (Name, Modell, etc.) werden im Gruppenfeld Sensorinformationen angezeigt.

Gehen Sie wie folgt vor, falls keine Verbindung zu einem bestimmten, in der Liste angeführten Sensor bzw. Emulator besteht:

  • Doppelklicken Sie in der Liste auf den gewünschten Sensor oder Emulator.
  • Wählen Sie den gewünschten Sensor oder Emulator in der Liste aus, und klicken Sie auf die Schaltfläche Verbinden.

Klicken Sie auf Trennen der Verbindung, wenn Sie die Verbindung mit dem verbundenen Sensor oder Emulator beenden möchten.

Das Einstellungsfenster enthält weitere Steuerelemente für folgende Aufgaben:

  • Hinzufügen eines Sensors zur Liste
  • Ändern des Modus für einen lokalen Emulator
Hinweis:
  • Wenn bereits ein anderer Benutzer beim gewünschten Vision-System/Sensor/Emulator angemeldet ist, wird eine Warnmeldung angezeigt. Klicken Sie auf Ja , um den anderen Benutzer vom Zielsystem zu trennen und den Anmeldeprozess fortzusetzen. Klicken Sie auf Nein , um den Anmeldeversuch abzubrechen und zu EasyBuilder zurückzukehren.
  • Wenn Sie keine Berechtigung haben, eine Verbindung mit dem gewünschten Vision-System/Sensor/Emulator herzustellen, erscheint das Dialogfeld Anmelden/Abmelden.
  • Wenn Sie beim Herstellen einer Verbindung zum Sensor und Netzwerk Schwierigkeiten haben, kann die Netzwerkkarte das Problem sein.
  • Wenn bei einem Vision-Sensor der In-Sight 2000-Serie der Triggertyp „Kontinuierlich“ aktiviert wird, schlägt die Kommunikation zwischen In-Sight Explorer und Sensor mit hoher Wahrscheinlichkeit fehl, da die Sensor-CPU stark belastet wird. Wählen Sie in diesem Fall einen anderen Triggertyp aus oder passen Sie das Triggerintervall an.
  • Wenn eine Verbindung mit In-Sight Vision-Systemen/Sensoren hergestellt wird, hängt die Verfügbarkeit bestimmter Positions- und Inspektionswerkzeugen vom Modelltyp ab.

Hinzufügen eines Sensors zur Liste

Ändern des Modus für einen lokalen Emulator


Herstellen der Verbindung zu einem nicht in der Liste aufgeführten Sensor

Wenn der gewünschte Sensor physisch mit dem lokalen Netzwerk verbunden ist, aber nicht in der Liste angezeigt wird, klicken Sie abhängig von den Netzwerkeinstellungen des Sensors auf die Schaltfläche Aktualisieren oder Hinzufügen.

  • Mit Aktualisieren wird die Liste aktualisiert, sodass alle mit dem lokalen Subnetz verbundenen In-Sight-Sensoren angezeigt werden. Die Netzwerkeinstellungen dieser Sensoren sind mit dem Subnetz kompatibel. Dies ermöglicht eine Kommunikation mit den Sensoren.
  • Mit Hinzufügen öffnen Sie das Dialogfeld "Sensor/Gerät zum Netzwerk hinzufügen". In diesem Dialogfeld können Benutzer mit vollständigen Zugriff die Netzwerkeinstellungen der Sensoren erneut konfigurieren, die mit dem lokalen Netzwerk verbunden, jedoch nicht mit dem lokalen Subnetz kompatibel sind. Nach der Korrektur der Einstellungen werden die Sensoren dem Subnetz automatisch hinzugefügt und ermöglichen die Kommunikation.

Befindet sich der gewünschte Sensor in einem anderen Subnetz, klicken Sie im Menü "System" auf Explorer-Hosttabelle, um das Dialogfeld "Explorer-Hosttabelle" zu öffnen.


Ändern des Modus für einen lokalen Emulator

  1. Wählen Sie im Gruppenfeld In-Sight-Sensor oder Emulator auswählen den gewünschten Emulator aus, indem Sie in der Liste darauf klicken.
  2. Klicken Sie auf die Schaltfläche Emulator, um das Dialogfeld Emulatoroptionen zu öffnen. Es enthält alle unterstützten In-Sight Vision-Systeme und die Tools, die für diese Sensoren verfügbar sind.
  3. Wählen Sie in der Dropdownliste Modell das Modell des zu emulierenden In-Sight-Sensors. Standard ist standardmäßig ausgewählt. Standard enthält die Basisfunktionen, die sich auf den meisten In-Sight Vision-Sensoren mit einer Bildauflösung von 640 x 480 befinden.
  4. Klicken Sie anschließend auf OK, um die Emulationseinstellung zu ändern.
Hinweis: Nach dem Klicken auf OK tritt eine Verzögerung auf, da EasyBuilder vom vorherigen Emulator getrennt und erneut gestartet wird.


Starten oder Öffnen eines EasyBuilder-Jobs

Geschlossen Starten eines neuen Jobs:
  1. Stellen Sie sicher, dass das Vision-System nicht Online ist.
  2. Klicken Sie im Abschnitt Job laden auf Neuer Job, oder drücken Sie STRG+N. Daraufhin wird das Dialogfeld Neuer Job geöffnet.
  3. Klicken Sie im Dialogfeld Neuer Job auf Ja, um sämtliche Daten des aktuellen Jobs zu entfernen. (Zum Speichern der Daten klicken Sie im Dialogfeld Sie auf Nein, drücken STRG+S und führen vor dem Start eines neuen Jobs die entsprechenden Schritte zum Speichern aus.)

Solange der Job nicht gespeichert und benannt wird, wird im Gruppenfeld Sensorinformationen der Name des neuen Jobs nicht im Feld Aktueller Job angezeigt.

Geschlossen Öffnen eines aktuellen Jobs:
  1. Stellen Sie sicher, dass das Vision-System nicht Online ist.
  2. Klicken Sie im Abschnitt Job laden auf Job öffnen oder drücken Sie STRG+O. Daraufhin wird das Dialogfeld Öffnen angezeigt.
  3. Navigieren Sie in diesem Dialogfeld zum gewünschten Job.
  4. Doppelklicken Sie auf den Job bzw. markieren Sie ihn, und klicken Sie auf Öffnen.
  5. Das Dialogfeld zum Laden von Dateien wird angezeigt. Klicken Sie in diesem Dialogfeld auf Ja, um sämtliche Daten des aktuellen Jobs zu entfernen. (Zum Speichern der Daten klicken Sie im Dialogfeld auf Nein, drücken STRG+S und führen vor dem Start eines neuen Jobs die entsprechenden Schritte zum Speichern aus.)

Der Name des geöffneten Jobs wird im Feld Aktueller Job angezeigt.

Hinweis:
  • Die auf den Vision-Sensoren der In-Sight 2000-Serie erstellten Jobdateien sind nicht mit den auf anderen In-Sight-Modellen erstellten Jobdateien kompatibel.
  • Ein „Nur EasyBuilder“ Vision-System kann keine EasyBuilder-Jobs öffnen, die in der Tabellenansicht bearbeitet wurden.
  • EasyBuilder kann keine Jobs öffnen, die in der Tabellenansicht von In-Sight Explorer erstellt wurden. Wenn ein Tabellenansicht-Job geöffnet wird, sind die verbleibenden Anwendungsschritte deaktiviert. Sie können den Job jedoch mittels In-Sight Explorer bearbeiten. Klicken Sie dazu im EasyBuilder-Menü „Ansicht“ auf Tabelle.
  • Wenn ein EasyBuilder-Job mit In-Sight 4.7.3 oder früher erstellt wurde und auf ein Vision-System mit In-Sight Firmwareversion 5.x.x geladen wird, werden Symbol-Tags (EasyBuilder-Tags) im Job u. U. gelöscht.


Bild einrichten

Der Schritt Bild einrichten dient zum Aufnehmen oder Laden eines Bildes und Anpassen der Aufnahmeeinstellungen des In-Sight-Sensors. Wenn Ihre Anwendung Ergebnisse in reellen Einheiten wie Millimeter oder Zoll erfordert, können Sie zudem die Pixelkoordinaten des Bildes kalibrieren.

Aufnehmen oder Laden eines Bildes

Aufnahmeeinstellungen bearbeiten

Kalibrieren des Bildes in reellen Einheiten


Aufnehmen oder Laden eines Bildes

Das Gruppenfeld Bild aufnehmen/laden ermöglicht Ihnen die sofortige Aufnahme eines Bildes vom Vision-System, das Anzeigen aktiver Live-Videobilder vom Vision-Sensor oder das Laden von zuvor aufgenommenen Bildern von einem PC.

Vision-Sensoren der In-Sight 2000-Serie

  • Aufnehmen oder Laden eines Bildes

In-Sight Vision-Systeme

  • Aufnehmen oder Laden eines Bildes

Vision-Sensoren der In-Sight 2000-Serie

In-Sight-Vision-Systeme


Aufnehmen oder Laden eines Bildes

Hinweis: Dieser Abschnitt beschreibt die Benutzeroberfläche bei Verbindung mit einem Vision-Sensor der In-Sight 2000-Serie. Bei Verbindung mit In-Sight Vision-Systemen siehe Aufnehmen oder Laden eines Bildes.
Geschlossen Trigger

Mit der Schaltfläche Trigger kann ein einzelnes Bild vom Vision-Sensor aufgenommen werden. Drücken Sie die Schaltfläche Trigger, um ein einzelnes Bild aufzunehmen. Alternativ können Sie die F5-Taste auf der Tastatur verwenden oder auf der EasyBuilder-Symbolleiste auf die Schaltfläche [image] klicken (das Steuerelement Trigger muss auf Manuell gesetzt sein).

Geschlossen Live-Video

Die Schaltfläche Live-Video aktiviert den Vision-Sensor, sodass Bilder kontinuierlich gelesen werden. Dies gibt Ihnen die Möglichkeit, die Bildschärfe des im Vision-Sensors angebrachten Objektivs einzustellen und die Blendenöffnung anzupassen, um die optimale Bildhelligkeit zu erzielen. Ihre Anwendung funktioniert optimal, wenn das Bild scharf und die Helligkeit zur Kontrastmaximierung optimal eingestellt ist.

Hinweis:
  • Alternativ können Sie in den Live-Video-Modus wechseln, indem Sie im Menü „Bild“ die Option „Live-Video“ auswählen oder in der EasyBuilder-Symbolleiste auf die Schaltfläche [image] klicken. Diese Live-Video-Optionen stehen in allen Anwendungsschritten zur Verfügung.
  • Sie können die Einstellungen Automatische/Manuelle Belichtung, Belichtung (ms), Optimale Belichtung, Lichtsteuerungsmodus und Bildvergrößerungsmodus anpassen, während Sie sich im Live-Video-Modus befinden.

Mit der unter dem Bild angegebenen Fokussiermetrik können Sie eine Bildfokussiergüte bestimmen, die angibt, bis zu welchem Grad das Bild oder ein Bildbereich die kleinsten auflösbaren Merkmale einer „Szene“ enthält.

Hinweis:
  • Bei Verbindung mit einem Vision-Sensor der In-Sight 2000-Serie sind die Werte „Minimum“, „Maximum“ und „Fokus“ der Fokussiermetrik ausgeblendet.
  • Die Fokussiermetrik kann durch Klicken auf das Symbol Fokussiermetrik [image] in der EasyBuilder-Symbolleiste deaktiviert werden, während das System im Live Video-Modus ist. Alternativ können Sie im Menü „Ansicht“ die Option Fokussiermetrik auswählen.
Geschlossen Einstellen der Bildschärfe

  1. Klicken Sie auf die Schaltfläche Live-Video. Alternativ können Sie auf der EasyBuilder-Symbolleiste auf die Schaltfläche [image] klicken.

    Hinweis: Der Vision-Sensor muss offline geschaltet sein.
  2. Wenn Sie den Vision-Sensor der In-Sight 2000 Mini-Serie verwenden, können Sie das Objektiv automatisch fokussieren, indem Sie die Schaltfläche „Autofokus“ verwenden. Alternativ dazu können Sie die Bildschärfe mit dem Schieberegler „Fokusabstand (%)“ manuell anpassen, sodass die Details der geprüften Merkmale klar und mit hohem Kontrast angezeigt werden.
  3. Wenn Sie einen anderen Vision-Sensor der In-Sight 2000-Serie verwenden, können Sie das zum Vision-Sensor gehörende Lichtmodul manuell anpassen, damit die Details der geprüften Merkmale klar und hochkontrastig angezeigt werden.
  4. Wenn Sie mit der Bildqualität zufrieden sind, klicken Sie erneut auf die Schaltfläche Live-Video.
Geschlossen Einstellen der Helligkeit
  1. Klicken Sie auf die Schaltfläche Live-Video. Alternativ können Sie auf der EasyBuilder-Symbolleiste auf die Schaltfläche [image] klicken.

  2. Klicken Sie auf der EasyBuilder-Symbolleiste auf das Symbol für die Helligkeitsmessung. Zu dunkle Bereiche des Bildes werden blau hervorgehoben, und übersättigte (zu helle) Bereiche werden rot hervorgehoben.

    Hinweis: Alternativ können Sie im Menü „Bild“ die Option Helligkeitsmessung anzeigen auswählen, um die Helligkeitsmessung zu aktivieren.
  3. Sie können die Helligkeit des Bildes mit den folgenden Methoden einstellen:
    • Stellen Sie die Objektivöffnung des am Vision-Sensor angebrachten Objektivs manuell ein, bis sowohl die roten als auch die blauen Bereiche des Bilds minimiert sind.
    • Passen Sie den Schieberegler Belichtung an, bis sowohl die roten als auch die blauen Bereiche des Bilds minimiert sind. Weitere Informationen finden Sie unter Belichtung.
    • Wählen Sie Automatische Belichtung aus. Weitere Informationen finden Sie unter Automatische Belichtung.

  4. Wenn Sie mit der Bildqualität zufrieden sind, klicken Sie erneut auf das Symbol für die Helligkeitsmessung [image], um die Anzeige zu deaktivieren.

    Hinweis: Alternativ können Sie im Menü „Bild“ die Option Helligkeitsmessung anzeigen auswählen, um die Helligkeitsmessung zu deaktivieren.
Geschlossen Laden von Bildern von einem PC

Durch Klicken auf die Schaltfläche Bilder von PC laden wird das Dialogfeld Optionen für Aufzeichnen/Wiedergabe geöffnet, in dem Sie Aufzeichnungs- und Wiedergabeoptionen für individuelle Vision-Sensoren und Emulatoren konfigurieren können. Nach der Konfiguration der Einstellungen des Dialogfelds können Sie aufgezeichnete Bilder im Aufzeichnungsordner speichern und Bilder wiedergeben, die im Wiedergabeordner auf dem PC gespeichert sind.

Hinweis:
  • Für die Laufzeitüberwachung und -fehlerbehebung können Bilder auf dem Vision-Sensor statt auf dem PC gespeichert werden. Konfigurieren Sie im Anwendungsschritt Bildstreifen die Sensoreinstellungen.
  • Werden Farbbilder auf dem PC gespeichert, werden sie als 16- und nicht als 24-Bit-Bilder gespeichert. Sollen Farbbilder zum Testen von Farbwerkzeugen verwendet werden, können Sie die Bilder per FTP exportieren (durch Hinzufügen eines FTP-Geräts im Anwendungsschritt Kommunikation), um die Bilder zu speichern und die volle Farbtiefe beizubehalten.
Geschlossen Wiedergabe (Registerkarte)

Nach der Konfiguration der Einstellungen auf der Registerkarte „Wiedergabe“ werden nach dem Klicken auf die Schaltfläche Abspielen (im PC-Bildstreifen) die im angegebenen Wiedergabeordner auf dem PC gespeicherten Bilder zum Vision-Sensor gesendet, und der Job wird für das wiedergegebene Bild ausgeführt. Der Wiedergabeordner verweist standardmäßig auf den EasyBuilder-Ordner für Beispieljobs.

Geschlossen Aufzeichnen (Registerkarte)

Nachdem die Einstellungen auf der Registerkarte „Aufzeichnen“ festgelegt wurden, werden beim Klicken auf die Schaltfläche Aufzeichnen (auf der EasyBuilder-Symbolleiste) die aufgezeichneten fehlerhaften und fehlerfreien Bilder im angegebenen Aufzeichnungsordner auf dem PC gespeichert. Sie können Bilder von einem Vision-Sensor im Online- oder Offlinemodus in jedem Ordner speichern, für den Sie über Schreibberechtigungen verfügen Es können bis zu 10000 Bilder auf dem PC gespeichert werden.


Aufnehmen oder Laden eines Bildes

Das Gruppenfeld Bild aufnehmen/laden ermöglicht Ihnen die sofortige Aufnahme eines Bildes vom Vision-System, das Anzeigen aktiver Live-Videobilder vom Vision-System oder das Laden von zuvor aufgenommenen Bildern von einem PC.

Geschlossen Trigger

Mit der Schaltfläche Trigger kann ein einzelnes Bild vom Vision-System aufgenommen werden. Drücken Sie die Taste Trigger, um ein einzelnes Bild aufzunehmen. Alternativ können Sie die F5-Taste auf der Tastatur verwenden oder auf der EasyBuilder-Symbolleiste auf die Schaltfläche [image] klicken (das Steuerelement Trigger im Gruppenfeld Aufnahmeeinstellungen bearbeiten muss auf Manuell gesetzt sein).

Geschlossen Live-Video

Die Schaltfläche Live-Video aktiviert das Vision-System, sodass Bilder kontinuierlich gelesen, aber nicht aufgenommen werden. Dies gibt Ihnen die Möglichkeit, die Bildschärfe des im Vision-Systems angebrachten Objektivs einzustellen und die Belichtung und Helligkeit anzupassen. Ihre Anwendung funktioniert optimal, wenn das Bild scharf und die Helligkeit zur Kontrastmaximierung optimal eingestellt ist.

Mit der unter dem Bild angegebenen Fokussiermetrik können Sie eine Bildfokussiergüte bestimmen, die angibt, bis zu welchem Grad das Bild oder ein Bildbereich (mithilfe der Schaltfläche Region fokussieren definiert) die kleinsten auflösbaren Merkmale einer „Szene“ enthält (d.h. das im Bild erfasste Objekt und dessen Hintergrund).

Hinweis:
  • Zur Bereitstellung relevanter Daten sollte die Fokussiermetrik mit einer anderen Fokussiermetrik derselben Szene (identische Szenen) verglichen werden.
  • Die Fokussiermetrik kann durch Klicken auf das Symbol Fokussiermetrik [image] in der EasyBuilder-Symbolleiste ausgeschaltet werden, während das System im Live Video-Modus ist.
Geschlossen Einstellen der Bildschärfe
Geschlossen Vision System der In-Sight 5000-, In-Sight Micro-. In-Sight 7000- und In-Sight 8000-Serie mit C-Mount-Objektiven

  1. Klicken Sie auf die Schaltfläche Live-Video. Alternativ können Sie auf der EasyBuilder-Symbolleiste auf die Schaltfläche [image] klicken.

    Hinweis: Das Vision-System muss offline geschaltet sein.
  2. Stellen Sie den Fokusring des am Vision-System angebrachten Objektivs so ein, dass die Details der zu inspizierenden Merkmale scharf und mit hohem Kontrast dargestellt werden und die Fokussiermetrik akzeptabel ist.
  3. Wenn Sie mit der Bildqualität und deren Güte zufrieden sind, klicken Sie erneut auf die Schaltfläche Live-Video.
  4. Das letzte Bild wird aufgenommen, nachdem Sie auf Live-Video geklickt haben, und wird dann angezeigt.
Geschlossen Vision-Systeme der In-Sight 7000-Serie mit Autofokus-M12-Objektiv
Hinweis: Für Vision-Systeme der 70xx-74xx-Serie sind die Fokus-Steuerungen nur für Vision-Systeme verfügbar, die In-Sight Explorer 4.7.3 oder höher und die In-Sight 4.7.3-Firmware oder höher ausführen.

  1. Klicken Sie auf die Schaltfläche Live-Video. Alternativ können Sie auf der EasyBuilder-Symbolleiste auf die Schaltfläche [image] klicken.

    Hinweis: Das Vision-System muss offline geschaltet sein.

  2. Klicken Sie auf die Schaltfläche Autofocus, oder stellen Sie den Schieberegler „Fokusposition“ manuell ein, bis die zu prüfenden Merkmale scharf und mit hohem Kontrast dargestellt werden und die Fokussiermetrik akzeptabel ist.

    Hinweis: Beim Klicken auf die Schaltfläche Autofokus sind der Schieberegler Fokusposition und die Schaltfläche Fokus speichern deaktiviert.
  3. Nach dem Klicken auf die Schaltfläche Autofokus wird der Fokuspositionswert aktualisiert, und das neue Bild wird angezeigt.
  4. Wenn Sie mit der Bildqualität und deren Güte zufrieden sind, klicken Sie erneut auf die Schaltfläche Fokus speichern. Die aktuelle Fokusposition wird als Standardfokusposition gespeichert, und das Objektiv nimmt beim nächsten Starten des Vision-Systems automatisch diese Position ein.
Geschlossen Einstellen der Helligkeit
  1. Klicken Sie auf die Schaltfläche Live-Video. Alternativ können Sie auf der EasyBuilder-Symbolleiste auf die Schaltfläche [image] klicken.
  2. Klicken Sie auf der EasyBuilder-Symbolleiste auf das Symbol für die Helligkeitsmessung. Zu dunkle Bereiche des Bildes werden blau hervorgehoben, und zu helle Bereiche werden rot hervorgehoben.
  3. Sie können die Helligkeit des Bildes mit den folgenden Methoden einstellen:
    • Stellen Sie die Objektivöffnung des am Vision-Sytems angebrachten Objektivs manuell ein, bis sowohl die roten als auch die blauen Bereiche des Bilds minimiert sind.
    • Erhöhen Sie im Gruppenfeld Aufnahmeeinstellungen bearbeiten die Einstellung von Belichtung, bis sowohl die roten als auch die blauen Bereiche des Bildes minimiert sind.
    • Aktivieren Sie im Gruppenfeld Aufnahmeeinstellungen bearbeiten die automatische Belichtungssteuerung des Vision-Systems, indem Sie im Dropdownmenü Automatische Belichtung die Einstellung Kontinuierlich oder Einzelaufnahme auswählen. Bei Auswahl von Kontinuierlich stellt das Vision-System die Belichtung automatisch entsprechend den Lichtverhältnissen für jede Bildaufnahme ein. Bei Auswahl von Einzelaufnahme wird die Belichtung des Vision-Systems basierend auf der ersten Bildaufnahme eingestellt. Die Belichtungseinstellungen werden für nachfolgende Aufnahmen übernommen.
  4. Wenn Sie mit der Bildqualität zufrieden sind, klicken Sie erneut auf das Symbol für die Helligkeitsmessung [image], um die Anzeige zu deaktivieren.
Geschlossen Laden von Bildern von einem PC

Durch Klicken auf die Schaltfläche Bilder von PC laden wird das Dialogfeld Optionen für Aufzeichnen/Wiedergabe geöffnet, in dem Sie Aufzeichnungs- und Wiedergabeoptionen für individuelle Vision-Systeme und Emulatoren konfigurieren können. Nach der Konfiguration der Einstellungen des Dialogfelds können Sie aufgezeichnete Bilder im Aufzeichnungsordner speichern und Bilder wiedergeben, die im Wiedergabeordner auf dem PC gespeichert sind.

Hinweis:
  • Für die Laufzeitüberwachung und -fehlerbehebung können Bilder statt auf dem Vision-System auf dem PC gespeichert werden. Konfigurieren Sie im Anwendungsschritt Bildstreifen die Sensoreinstellungen.
  • Werden Farbbilder auf dem PC gespeichert, werden sie als 16- und nicht als 24-Bit-Bilder gespeichert. Sollen Farbbilder zum Testen von Farbwerkzeugen verwendet werden, können Sie die Bilder per FTP exportieren (durch Hinzufügen eines FTP-Geräts im Anwendungsschritt Kommunikation), um die Bilder zu speichern und die volle Farbtiefe beizubehalten.
Geschlossen Wiedergabe (Registerkarte)

Nach der Konfiguration der Einstellungen auf der Registerkarte „Wiedergabe“ werden nach dem Klicken auf die Schaltfläche Abspielen (im PC-Bildstreifen) die im angegebenen Wiedergabeordner auf dem PC gespeicherten Bilder zum Vision-System gesendet, und der Job wird für das wiedergegebene Bild ausgeführt. Der Wiedergabeordner verweist standardmäßig auf den EasyBuilder-Ordner für Beispieljobs.

Hinweis: Der Ordner Wiedergabe verweist standardmäßig auf den Ordner mit den EasyBuilder-Beispiel-Parametersätzen. Die EasyBuilder-Beispiel-Parametersätze veranschaulichen eindrucksvoll die Nützlichkeit der Aufzeichnungs- und Wiedergabeoptionen. Mithilfe der Aufzeichnungs- und Wiedergabeoptionen können Sie eine Serie zuvor aufgenommener Bilder der Reihe nach durchlaufen und erhalten so sofortiges Feedback zu den Werkzeugergebnissen. Dies ermöglicht eine schnelle Konfiguration von Schwellen- und Grenzwerten.
Geschlossen Aufzeichnen (Registerkarte)

Nachdem die Einstellungen auf der Registerkarte Aufzeichnen festgelegt wurden, werden beim Klicken auf die Schaltfläche Aufzeichnen (auf der EasyBuilder-Symbolleiste) die aufgezeichneten fehlerhaften und fehlerfreien Bilder im angegebenen Aufzeichnungsordner auf dem PC gespeichert. Sie können Bilder von einem Vision-System im Online- oder Offlinemodus in jedem Ordner speichern, für den Sie über Schreibberechtigungen verfügen. Auf dem PC können bis zu 10000 Bilder gespeichert werden.


Aufnahmeeinstellungen bearbeiten

Der Anwendungsschritt Aufnahmeeinstellungen bearbeiten dient zum Einstellen der Aufnahmetrigger-Steuerelemente, zum Ausgleichen von Belichtung und Helligkeit sowie zum Steuern des Lichts für In-Sight-Vision-Systeme.

Vision-Sensoren der In-Sight 2000-Serie

  • Bildeinstellungen

In-Sight Vision-Systeme

  • Triggersteuerelemente
  • Belichtungssteuerelemente
  • Bildsensorübertragung – Steuerelemente
  • Lichtsteuerelemente
  • High Dynamic Range (HDR)
  • Weißabgleich
  • Region fokussieren
  • Fokussier-Steuerelemente
  • Beleuchtungseinstellungen
  • Zeilenscaneinstellungen

Vision-Sensoren der In-Sight 2000-Serie

In-Sight-Vision-Systeme


Bildeinstellungen

Hinweis: Dieser Abschnitt beschreibt die Benutzeroberfläche bei Verbindung mit einem Vision-Sensor der In-Sight 2000-Serie. Bei Verbindung mit In-Sight Vision-Systemen finden Sie weitere Informationen unter Aufnahmeeinstellungen bearbeiten im Abschnitt „In-Sight Vision-Systeme“.

Trigger

Mit den Trigger-Steuerelementen Typ, Verzögerung und Intervall können Sie anpassen, wie und wann ein Bild aufgenommen und die Inspektion durchgeführt werden soll.

Hinweis: Wenn bei einem Vision-Sensor der In-Sight 2000-Serie der Triggertyp „Kontinuierlich“ aktiviert wird, schlägt die Kommunikation zwischen In-Sight Explorer und Sensor mit hoher Wahrscheinlichkeit fehl, da die Sensor-CPU stark belastet wird. Wählen Sie in diesem Fall einen anderen Triggertyp aus oder passen Sie das Triggerintervall an.
Geschlossen Typ

In dem Dropdownmenü können Sie die Quelle des Bildaufnahmetriggers auswählen, wenn der In-Sight Vision-Sensor auf Online gesetzt ist.

Kamera | Aktiviert die Bildaufnahme über eine vom dezidierten Triggereingang des Vision-Systems erkannte steigende Flanke.
Kontinuierlich (Standard) | Aktiviert „freilaufende“ (möglichst schnelle) Bildaufnahmen.
Manuell | Aktiviert die Bildaufnahme durch Drücken der Taste F5. Hinweis: Sie können den Sensor durch Drücken des TRG-Knopfes am Vision-Sensor manuell triggern.
Industrial Ethernet | Ermöglicht das Triggern via Industrial Ethernet-Protokoll, z. B. EtherNet/IP, PROFINET, SLMP-Scanner oder CC-Link IE Field Basic.
Geschlossen Verzögerung (ms)

Mit diesem Steuerelement können Sie eine Verzögerung in Millisekunden (0 bis 10.000) zwischen dem Empfang des Triggers und dem Start der Aufnahme durch den In-Sight-Vision-Sensor festlegen. Der Triggertyp muss auf Kamera eingestellt werden.

Hinweis:
  • Die Verzögerung ist auf die Millisekunde genau, zuzüglich oder abzüglich der maximalen Belichtungszeit von 64 Mikrosekunden.
  • Wenn im Schritt Eingänge/Ausgänge als Signaltyp die Option Aufnahmestart festgelegt ist, werden diese Ausgänge um die angegebene Zeit verzögert.
Geschlossen Intervall (ms)

Mit dem Steuerelement können Sie zwischen Aufnahmen ein Intervall in Millisekunden (0 bis 10.000, Standard ist 0) angeben, wenn das Steuerelement Trigger auf Kontinuierlich eingestellt ist.

Hinweis: Diese Verzögerung hängt davon ab, wie lange der Job für die Verarbeitung des Bildes benötigt. Als Beispiel, wenn das Intervall auf 500 Millisekunden eingestellt wurde, wird der In-Sight Vision-Sensor alle 500 Millisekunden ein Bild aufnehmen, vorausgesetzt, der Job beendet die Verarbeitung des Bildes innerhalb von 500 Millisekunden. Ist dies nicht der Fall, nimmt der In-Sight-Vision-Sensor ein Bild auf, sobald er die Bildverarbeitung abgeschlossen hat.

Fokus (nur Vision-Sensoren der In-Sight 2000-Serie)

Die Registerkarte „Fokus“ wird zur Steuerung der Fokusposition des Objektivs auf unterstützten Vision-Sensoren der In-Sight 2000-Serie verwendet. Der Fokus wird entweder automatisch geregelt oder kann auf eine bestimmte Fokusposition eingestellt werden.

Geschlossen Autofokus-Bereich

Gibt den Bereich des Bilds an, der beim automatischen Fokussieren des Objektivs verwendet wird. Klicken Sie auf die Schaltfläche „Autofokus.Bereich“, um den Bereich zu konfigurieren.

Geschlossen Schaltfläche Autofokus

Fokussiert das Objektiv automatisch, um die bestmögliche Bildschärfe im Bereich zu erzielen.

Geschlossen Autofokus beim Laden des Jobs
  • Deaktiviert (= Standard): Der aktuelle Fokusabstand (%) wird mit dem Job gespeichert.
  • Aktiviert: Der Vision-Sensor fokussiert das Objektiv beim Laden des Jobs automatisch.
Geschlossen Fokusabstand (%):

Passt die Fokusposition automatisch an (0-100%. Standard: 6,2-mm-Objektiv = 66%, 16-mm-Objektiv = 69,2%) Wenn Sie versuchen, ein Objekt in der Nähe des Vision-Sensors zu fokussieren, bewegen Sie den Ziehgriff nach links (in Richtung 0%). Wenn Sie versuchen, ein Objekt in größerer Entfernung vom Vision-Sensor zu fokussieren, bewegen Sie den Ziehgriff nach rechts (in Richtung 100%). Sie können den Ziehgriff unabhängig vom Status des Live-Video-Modus bewegen.

Hinweis: 0% steht für die nächstmögliche Fokusebene. Wenn z. B. ein Objekt sehr nahe am Vision-Sensor platziert wird, wird 0% angezeigt. 100% steht für die am weitesten entfernte unterstützte Fokusebene, im Prinzip „unendlicher Fokus“.

Beleuchtung

Hinweis: In einigen Fällen kann die Beleuchtung auf den Vision-Sensoren der In-Sight 2000 Mini-Serie mit Autofokus dunkler als die eines anderen Vision-Sensors der In-Sight 2000-Serie sein.
Geschlossen Automatische Belichtung

Die Belichtung nach jeder Aufnahme automatisch bestimmen. Diese Option hilft in der Ausgleichung uneinheitlicher Lichtbedingungen wie Reflexionen von glänzenden Metalloberflächen, sich bewegende Schatten und Änderungen der Hintergrundbeleuchtung. Automatische Belichtung ist standardmäßig deaktiviert.

Geschlossen Manuelle Belichtung

Gibt einen festen Belichtungswert an für Gebrauch bei jeder Bildaufnahme. Manuelle Belichtung ist standardmäßig aktiviert. Zum Deaktivieren markieren Sie Automatische Belichtung.

Geschlossen Zielbildhelligkeit

Ermöglicht die Angabe der gewünschten Helligkeitsstufe (0 - 100; Standard = 50) durch Einstellen des Ziehgriffes oder durch Eingeben eines Wertes in dem entsprechenden Eingabefeld. Der Wert stellt den Prozentsatz der Pixel im Belichtungsbereich dar, die gesättigt (d.h. weiß) sein können.

Tipp: Sie können den Schieberegler auch mithilfe der PFEILTASTEN (NACH-OBEN, NACH-UNTEN-, NACH-LINKS- und NACH-RECHTS) bewegen.
Geschlossen Belichtung (ms)

Das Steuerelement Belichtung legt die Dauer der Belichtung fest, wenn ein Bild aufgenommen wird (0,000 - 1000,000; Standard = 0,250). Je höher der Belichtungswert ist, desto heller wird das aufgenommene Bild sein. Diese Option ist ausgeblendet, wenn Automatische Belichtung angewählt ist.

Geschlossen Lichtintensität
Hinweis: Der Schieberegler „Lichtintensität“ wird für Vision-Sensoren der In-Sight 2000 Mini-Serie nicht unterstützt.

Ermöglicht die prozentuale Angabe der effektiven Intensität der LEDs [(0 bis 100); Standard = 70; AUS = 0] durch Einstellen des Ziehgriffes oder durch Eingeben eines Wertes im entsprechenden Eingabefeld. Die Lichtintensität wird mit dem Job gespeichert.

Tipp: Sie können den Schieberegler auch mithilfe der PFEILTASTEN (NACH-OBEN, NACH-UNTEN-, NACH-LINKS- und NACH-RECHTS) bewegen.

Der blaue Hintergrund zeigt den bei den aktuellen Einstellungen maximal zur Verfügung stehenden Lichtintensitätswert an. Der maximale Lichtintensitätswert variiert in Abhängigkeit von anderen Bildeinstellungen, wie z.B. der Zielbildhelligkeit, der Belichtung, der Höhe des Bildbereichs oder dem Vergrößerungsmodus.

Hinweis: Der maximale Wert wird angezeigt, wenn der Mauszeiger über den Ziehgriff gehalten wird.
Geschlossen Schaltfläche Belichtungsbereich (Set Region)

Gibt die Region an, die bei der automatischen Berechnung der Belichtung verwendet werden soll.

  1. Klicken Sie auf die Schaltfläche Belichtungsbereich.
  2. Positionieren Sie den Bereich um den Bildbereich, den der Sensor verwenden wird, die automatische Belichtung für das nächste aufgenommene Bild zu berechnen.
  3. Klicken Sie auf die Schaltfläche OK.

Die Belichtung wird jetzt auf Basis der Helligkeit des Bildbereiches innerhalb des Belichtungsbereiches automatisch berechnet . Als Beispiel, wenn der Bildbereich innerhalb des Belichtungsbereiches heller ist als der Rest des Bildes, wird das nächste aufgenommene Bild dunkler sein.

Belichtungsbereich bestimmen | Nächstes aufgenommenes Bild
Hinweis: Klicken Sie auf Auf Standardbereich zurückstellen, um den Bereich auf die Standardeinstellung zurückzustellen.
Geschlossen Optimale Belichtung

Optimiert automatisch den Belichtungswert. Der gleiche Belichtungswert wird für jede nachfolgende Bildaufnahme verwendet.

Geschlossen Lichtsteuerungsmodus

Bei Auswahl von Ein (Belichtungsgesteuert) leuchtet die Ringleuchte nur für die Dauer der Belichtung (Standard). Wenn deaktiviert bzw. Aus, wird die Beleuchtung ausgeschaltet und der Sensor hängt vom Umgebungslicht (Raum) ab.

Weißabgleich (nur In-Sight 2000-Farb-Vision-Sensoren)

Geschlossen Region für Weißabgleich und Weißabgleich einstellen

Entfernt Farbstiche in einem Farbbild, indem die RGB-Werte (Rot, Grün und Blau) des Bildes berechnet und korrigiert werden. Dadurch erscheinen z. B. Elemente, die tatsächlich weiß sind, im Bild weiß.

Beim Erstellen eines neuen Jobs, wird der zuletzt durchgeführte Weißabgleich effektiv sein. Die Weißabgleich-Einstellung wird mit dem Job gespeichert und wird beim Laden des Jobs wiederhergestellt.

Hinweis:
  • Die Weißabgleich-Einstellung muss konfiguriert werden, während das System auf manuelle Belichtung eingestellt ist.

  • Um die genaueste Farbdarstellung im Bild herauszuholen, empfehlen wir nach jeder größeren Änderung der Lichtintensität einen Weißabgleich durchzuführen.

  1. Stellen Sie den Fokus des In-Sight Vision-Sensors auf ein flaches Testobjekt, wie zum Beispiel auf ein Blatt mattes weißes Papier und stellen Sie die Steuerelemente für die Beleuchtung so ein, dass das Bild nicht überbelichtet wird.

  2. Klicken Sie auf Bereich für Weißabgleich, und umschließen Sie einen Bereich des Bildes, das nur helle Pixel und keine „Hotspots“ enthält.

    Hinweis: Klicken Sie auf Auf Standardbereich zurückstellen, wenn Sie das ganze Bild einschließen möchten.
  3. Klicken Sie auf Weißabgleich einstellen. Bei allen weiteren Bildaufnahmen wird jetzt diese Einstellung verwendet.
Bild vor Weißabgleich | Unter Weißabgleich | Bild nach Weißabgleich

Bild

Geschlossen Höhe des Bildbereichs

Legt die Anzahl der aufzunehmenden Bildzeilen fest, damit Aufnahmezeiten abgekürzt werden, wenn der Inspektionsbereich sich immer auf den selben Streifen von Zeilen im Bild begrenzt ist. Sie können die Werte durch Bewegen des linken Ziehgriffs (Startzeile) und des rechten Ziehgriffs (Endzeile) oder durch Eintragen der Werte in die entsprechenden Felder angeben.

Tipp: Sie können den Schieberegler auch mithilfe der PFEILTASTEN (NACH-OBEN, NACH-UNTEN-, NACH-LINKS- und NACH-RECHTS) bewegen.
In-Sight-Modell | Auflösung | Startzeilenwert | Endzeilenwert
2000-110 | 640 x 480 | 0 - 479 (Standard= 0) | 0 - 479 (Standard = 479)
2000-120/120C | 640 x 480 | 0 - 479 (Standard= 0) | 0 - 479 (Standard = 479)
2000-130/130C1 2000-230/230C1 | 640 x 480 (Standard) | 0 - 479 (Standard= 0) | 0 - 479 (Standard = 479)
 | 800 x 600 | 0 - 599 (Standard = 0) | 0 - 599 (Standard = 599)
2000-23M1 | 640 x 480 | 0 - 479 (Standard= 0) | 0 - 479 (Standard = 479)
 | 800 x 600 (Standard) | 0 - 599 (Standard = 0) | 0 - 599 (Standard = 599)
2001-230/230C1 | 640 x 480 | 0 - 479 (Standard= 0) | 0 - 479 (Standard = 479)
 | 800 x 600 | 0 - 599 (Standard = 0) | 0 - 599 (Standard = 599)
 | 1280 x 960 (Standard) | 0 - 959 (Standard = 0) | 0 - 959 (Standard= 959)
1Die Auflösung kann im Dialogfeld „Bildeinstellungen“ festgelegt werden. Weitere Informationen finden Sie unter Dialogfeld „Bildeinstellungen“.
Geschlossen Bildvergrößerungsmodus

Aktiviert die Bildvergrößerungsmodus. Wenn aktiviert, wird das Betrachtungsfeld um 50% reduziert, während die optische Auflösung um 200% vergrößert wird.

In-Sight-Modell | Auflösung | Bildvergrößerungsmodus
2000-110 | 640 x 480 | Nicht unterstützt
2000-120/120C | 640 x 480 | Kann aktiviert/deaktiviert werden
2000-130/130C1 2000-230/230C1 | 640 x 480 (Standard) | Kann aktiviert/deaktiviert werden
 | 800 x 600 | Immer aktiviert
2000-23M1 | 640 x 480 | Kann aktiviert/deaktiviert werden
 | 800 x 600 (Standard) | Immer aktiviert
2001-230/230C1 | 640 x 480 | Kann aktiviert/deaktiviert werden
 | 800 x 600 | Immer aktiviert
 | 1280 x 960 (Standard) | Immer aktiviert
1Die Auflösung kann im Dialogfeld „Bildeinstellungen“ festgelegt werden. Weitere Informationen finden Sie unter Dialogfeld „Bildeinstellungen“.
Bildvergrößerungsmodus Deaktiviert | Bildvergrößerungsmodus Aktiviert
Geschlossen Kalibrierungstyp

Ermöglicht Ihnen das Konvertieren oder Kalibrieren der Inspektionswerkzeuge von Pixeln zu reellen Maßeinheiten. Es gibt zwei Optionen: Betrachtungsfeld oder Importieren.

Hinweis:
  • Die Option „Betrachtungsfeld“ steht nicht für die Vision-Sensoren In-Sight 2000-110 und 2000-120/120C zur Verfügung.
  • Die Option „Importieren“ steht nur beim Vision-Sensor In-Sight 2000-23M zur Verfügung.
Geschlossen Betrachtungsfeld

Rechnet die Ergebnisse der Messungswerkzeuge von Pixeln in reelle Maßeinheiten (Millimeter, Zentimeter und/oder Zoll) um.

Betrachtungsfeld (Breite) = 640 Pixel/125 Millimeter
  1. Wählen Sie im Dropdownmenü „Kalibrierungstyp“ die Option Betrachtungsfeld (Breite) aus.
  2. Wählen Sie im Dropdownmenü die zu verwendende reelle Maßeinheit aus (Millimeter, Zentimeters oder Zoll). Pixel ist standardmäßig ausgewählt und der Wert kann nicht geändert werden.
  3. Messen Sie die Breite des Betrachtungsfeldes in der ausgewählten Maßeinheit so genau wie möglich ab und tragen Sie dann den gemessenen Wert ein.

  4. Die Umrechnung des Messergebnisses wird sofort angewandt. Als Beispiel, wenn das Betrachtungsfeld (Breite) auf 125 Millimeter eingestellt wurde und der gemessene Abstand zwischen den zwei Kanten 490 Pixel beträgt, wird das Messergebnis als 95,703 mm zurückgegeben werden.

    Hinweis:
    • Im Folgenden finden Sie die Formel und die im Beispiel verwendete konkrete Berechnung:
      • Betrachtungsfeld (reelle Einheiten) / Betrachtungsfeld (Pixel) * Messung (Pixel) = Ergebnis (reelle Einheiten)
      • 125/640*490 = 95,703 mm
Geschlossen Importieren

Das Importieren eines Kalibrierungstyps wird verwendet, um eine Kalibrierungsdatei zu laden, die mit einem N-Punkt-Kalibrierungswerkzeug erstellt und an das lokale Dateisystem des In-Sight Vision-Sensors exportiert wurde. Die importierte Kalibrierungsdatei kalibriert automatisch den aktuellen Job, sobald er geladen ist.

Hinweis: Vor der Auswahl von Importieren als Kalibrierungstyp muss das N-Punkt-Kalibrierungswerkzeug hinzugefügt und konfiguriert und dann die Kalibrierungsdatei an das lokale Dateisystem des In-Sight Vision-Sensors exportiert werden.

Das N-Punkt-Kalibrierungswerkzeug erstellt eine 2D-Transformation, um zwischen Pixeln und reellen Koordinatensystemen zu konvertieren. Das Werkzeug führt die folgenden Transformationen aus:

  • Übertragung in zwei Dimensionen (mit 2 oder mehr Punktepaaren).
  • Drehung um drei Achsen (mit 4 oder mehr Punktepaaren).
  • Skalierung in zwei Dimensionen (mit 2 oder mehr Punktepaaren).
  • Perspektivenverzerrung (mit 4 oder mehr Punktepaaren).
  • Parallelogramm oder Krümmung (mit mindestens 4 Punktpaaren)

Vorgehensweise

  1. Wählen Sie im Dropdownmenü „Kalibrierungstyp“ die Option Importieren aus.
  2. EasyBuilder prüft automatisch, ob in Ihrem Job Kalibrierungsdateien vorhanden sind, die von einem N-Punkt-Kalibrierungswerkzeug generiert wurden, und lädt die Kalibrierungsdatei. Wenn Sie mehr als eine Kalibrierungsdatei erstellt haben, wählen Sie die gewünschte Datei im Dropdownmenü „Dateiname“ aus.
  3. Wählen Sie im Dropdownmenü „Einheiten“ die reellen Maßeinheiten aus, die die Kalibrierung definieren: Mikrometer, Millimeter (Standard), Zentimeter oder Zoll.
  4. Die Kalibrierung wird angewendet, sobald diese Option ausgewählt und die Werte konfiguriert wurden.


Triggersteuerelemente

Mit den Triggersteuerelementen Trigger, Triggerverzögerung und Triggerintervall können Sie festlegen, wie und wann ein Bild aufgenommen wird.

  • Trigger: Definiert die Quelle des Bildaufnahmetriggers, wenn das Vision-System online ist.

    • Kamera (Standard): Aktiviert die Bildaufnahme über eine vom dezidierten Triggereingang des Vision-Systems erkannte steigende Flanke.
    • Kontinuierlich: Aktiviert „freilaufende“ (möglichst schnelle) Bildaufnahmen.

    • Extern: Aktiviert die Bildaufnahme über einen seriellen Befehl oder über die steigende Flanke, die auf ein als Aufnahmetrigger konfiguriertes diskretes Eingangsbit angewendet wird.

      Hinweis:
      • Höhere Triggergeschwindigkeiten werden durch die Verwendung des integrierten Triggereingangs des Systems erzielt (indem der Parameter Trigger auf Kamera gesetzt wird), anstatt das Vision-System mit einer als Triggereingang konfigurierten Allzweckeingangsleitung zu triggern (indem der Parameter Trigger auf Extern gesetzt wird).
      • Falls der Parameter „Trigger“ der AcquireImage-Funktion auf „Extern“ gestellt ist und eine Aufnahme verpasst wird, sendet das Vision-System kein diskretes „FEHLER: Bild verpasst“-Signal. Das „FEHLER: Bild verpasst“-Signal wird nur unterstützt, wenn der Parameter „Trigger“ der AcquireImage-Funktion auf „Kamera“ gestellt ist.
    • Manuell: Aktiviert die Bildaufnahme durch Drücken der Taste F5.
    • Industrial Ethernet: Ermöglicht das Triggern via Industrial Ethernet-Protokoll, z. B. EtherNet/IP, POWERLINK, Profinet, SLMP-Scanner oder CC-Link IE Field Basic.
    • Zeitstempel: Aktiviert die Bildaufnahme, wenn von einer SPS über EtherNet/IP ein Zeitstempel-Trigger an das Vision-System gesendet wird. Die Option „Zeitstempel“ wird nur auf folgenden Vision-Systemen unterstützt:

      • In-Sight Vision-Systeme der 5000-Serie mit 128MB nicht flüchtigem Flashspeicher und mit Firmwareversion ab 4.5.0.

        Hinweis: Die Vision-Systeme In-Sight 5605 (Hardware-Typ 821-0032-1R), In-Sight 5705 und In-Sight 5705C werden nicht unterstützt.
      • Vision-Systeme der In-Sight 7000 Gen2-Serie
      • Vision-Systeme der In-Sight 9000-Serie

  • Triggerverzögerung: Legt eine Verzögerung in Millisekunden (0 bis 10.000) zwischen dem Empfang des Triggers und dem Start der Aufnahme durch das In-Sight-Vision-System fest.

    Hinweis:
    • Das Steuerelement Trigger muss zum Aktivieren dieser Funktion auf Kamera oder Netzwerk eingestellt werden.
    • Die Verzögerung ist auf die Millisekunde genau, zuzüglich oder abzüglich der maximalen Belichtungszeit von 64 Mikrosekunden.
    • Wenn im Schritt Eingänge/Ausgänge als Signaltyp die Option Akquisitionsstart oder Blitzimpuls festgelegt ist, werden diese Ausgänge um die angegebene Zeit verzögert.

  • Triggerintervall: Legt ein Intervall in Millisekunden (0 bis 10.000, Standard ist 500) fest, das zwischen Aufnahmen eingehalten wird, wenn das Steuerelement Trigger auf Kontinuierlich eingestellt ist.

    Hinweis: Diese Verzögerung hängt davon ab, wie lange der Job für die Verarbeitung des Bildes benötigt. Ist das Triggerintervall beispielsweise auf 5.000 Millisekunden eingestellt, erfasst das Vision-System alle 5.000 Millisekunden ein Bild, sofern der Job die Bildverarbeitung innerhalb von 5.000 Millisekunden abgeschlossen hat. Ist dies nicht der Fall, erfasst das In-Sight-Vision-System ein Bild, sobald es die Bildverarbeitung abgeschlossen hat.


Belichtungssteuerelemente

Die Belichtungssteuerelemente dienen zum Anpassen der Anwendung an uneinheitliche Lichtbedingungen und Ausgleichen der Helligkeit, um die Details der inspizierten Merkmale zu maximieren.

Geschlossen Belichtung

Mit dem Steuerelement „Belichtung“ können Sie die Belichtungszeit festlegen. Empfängt das In-Sight-Vision-System ein Triggersignal, wird für die definierte Dauer Licht in der Bildsensorreihe integriert.

Hinweis:
  • Bei folgenden Vision-Systemen/Sensoren kann die Auflösung im Dialogfeld „Bildeinstellungen“ festgelegt werden: In-Sight Micro 1500, In-Sight 2000-130, 2000-130C, 2000-230, 2000-230C, 2000-23M, 2001-230, 2001-230C, In-Sight 7500, 7500C, 7600, 7600C, 7800, 7800C, 7900, 7900C, 7802, 7802C, 7902, 7902C.
  • Bei den Zeilenscan-Vision-Systemen 5604 und 5614 kann die Bildhöhe im Dialogfeld „Zeilenscaneinstellungen“ festgelegt werden.
  • Beim Zeilenscan-Vision-System 9902L können die Auflösung 1K (Restlicht-Modus) und die maximale Bildhöhe im Dialogfeld „Zeilenscaneinstellungen“ festgelegt werden.
  • Beim Anschluss an ein Zeilenscan-Vision-System In-Sight 5604, 5614 oder 9902L wird die Belichtungszeit in Mikrosekunden (µs) definiert.
  • Wenn das Vision-System In-Sight 8405 mit einem Blitz verwendet wird, wird ein Mindestbelichtungswert von 72 ms für Vollbildaufnahmen empfohlen, damit alle Pixelzeilen belichtet sind, wenn der Blitz gestartet wird. Weitere Informationen finden Sie in den Hinweisen zum Betrieb des Rolling-Shutter.

  • Es ist möglich, die Belichtung auf 0 zu stellen. Die Belichtungszeit ist vom In-Sight-Vision-System abhängig, und bei einem Wert von 0 für die Belichtungszeit wird standardmäßig die Mindestbelichtungszeit (in Millisekunden oder Mikrosekunden) des ausgewählten Vision-Systems verwendet.

In-Sight-Modell | Lösung | Sensortyp | Belichtungszeit (ms)
Micro 1020, 1050, 1100, 1110, 1100C, 1400, 1410, 1400C | 640 x 480 | CCD, globale Blende | 0,016 bis 1000
Micro 1402, 1412 | 1280 x 1024 | CMOS, globale Blende | 0,016 bis 950
Micro 1403, 1413, 1403C | 1600 x 1200 | CCD, globale Blende | 0,052 bis 1000
Micro 1500 | 640 x 480 | CMOS, globale Blende | 0,004 bis 500
 | 800 x 600 | CMOS, globale Blende | 0,005 bis 500
2000-110, 2000-120, 2000-120C, 2000-130, 2000-130C, 2000-230, 2000-230C, 2000-23M, 2001-230, 2001-230C | 640 x 480 | CMOS, globale Blende | 0,001 bis 1000
2000-130, 2000-130C, 2000-230, 2000-230C, 2000-23M, 2001-230, 2001-230C | 800 x 600 | CMOS, globale Blende | 0,001 bis 1000
2001-230, 2001-230C | 1280 x 960 | CMOS, globale Blende | 0,001 bis 1000
5100, 5110, 5100C, 5400, 5410, 5400C, 5600, 5610 | 640 x 480 | CCD, globale Blende | 0,016 bis 1000
5403, 5413, 5603, 5613 | 1600 x 1200 | CCD, globale Blende | 0,027 bis 1000
5604 & 5614 Zeilenscan | 1024 x 8192 | CCD, globale Blende | 1,33 µs bis 1000 µs
5605, 5615, 5705, 5715 | 2448 x 2048 | CCD, globale Blende | 0,014 bis 1000
5705C | 2448 x 2048 | CCD, globale Blende | 0,016 bis 1000
7010, 7010C, 7020, 7050, 7200, 7210, 7230, 7200C, 7400, 7410, 7430, 7400C | 800 x 600 | CMOS, globale Blende | 0,016 bis 950
7402, 7412, 7432, 7402C | 1280 x 1024 | CMOS, globale Blende | 0,016 bis 950
7500, 7500C, 7600, 7600C, 7800, 7800C, 7900, 7900C | 800 x 600 | CMOS, globale Blende | 0,014 bis 550
 | 640 x 480 | CMOS, globale Blende | 0,014 bis 520
7501, 7501C, 7801, 7801C, 7901, 7901C | 1280 x 1024 | CMOS, globale Blende | 0,017 bis 750
7802, 7802C, 7902, 7902C | 1600 x 1200 | CMOS, globale Blende | 0,020 bis 940
 | 800 x 600 (Restlicht-Modus) | CMOS, globale Blende | 0,020 bis 940
7802P, 7902P | 1920 x 1200 | CMOS, globale Blende | 0,021 bis 1000
7905, 7905C | 2448 x 2048 | CMOS, globale Blende | 0,021 bis 1000
8100, 8100C, 8200, 8200C, 8400, 8400C | 640 x 480 | CMOS, globale Blende | 0,014 bis 520
8101, 8101C, 8401, 8401C | 1280 x 1024 | CMOS, globale Blende | 0,0174 bis 750
8402, 8402C | 1600 x 1200 | CMOS, globale Blende | 0,020 bis 940
8405 | 2592 x 1944 | CMOS, Rolling-Shutter | 0,032 bis 1000
8505P | 2448 x 2048 | CMOS, globale Blende | 0,021 bis 1000
9902L Zeilenscan | 2048 x 16384 | CMOS, globale Blende | 2,00 µs bis 1000 µs
 | 1024 x 16384
9912, 9912C | 4096 x 3000 | CMOS, globale Blende | 0,021 bis 1000
Geschlossen Automatische Belichtung

Das Steuerelement Automatische Belichtung ermöglicht dem Vision-System das automatische Bestimmen der Belichtung. Dieses Steuerelement gleicht uneinheitliche Lichtbedingungen wie Reflexionen von glänzenden Metalloberflächen, sich bewegende Schatten und Änderungen der Hintergrundbeleuchtung aus.

  • Kontinuierlich: Das Vision-System stellt die Belichtung automatisch entsprechend den Lichtverhältnissen für jede Bildaufnahme ein.

    Hinweis: Die Zeit zwischen Aufnahmen verlängert sich im Modus „Kontinuierlich“.
  • Einzelaufnahme: Bei Auswahl von Einzelaufnahme wird die Belichtung des Vision-Systems basierend auf der ersten Bildaufnahme eingestellt. Die Belichtungseinstellungen werden für nachfolgende Aufnahmen übernommen.
    • Erste Aufnahme: Ist das Vision-System offline, wird anhand der ersten Aufnahme die Belichtung ermittelt. Der Belichtungswert wird gespeichert, bis die Einzelaufnahme wieder deaktiviert wird. Wurde kein Bild aufgenommen, während das Vision-System Offline war, wird die Belichtung nach dem Online-Schalten anhand der ersten Aufnahme ermittelt.
    • Nachfolgende Aufnahmen: Das Vision-System nimmt das Bild mit dem Belichtungswert auf, der bei der ersten Aufnahme berechnet wurde.
    Hinweis:
    • Wenn das Vision-System oder der Vision-Sensor diese Funktion nicht unterstützen, wird diese Option nicht angezeigt.
    • Durch Auswahl eines anderen Modus für „Automatische Belichtung“ wird der Belichtungswert zurückgesetzt. Die erste Aufnahme nach dem Zurücksetzen des Belichtungswerts wird verwendet, um einen neuen Belichtungswert zu ermitteln.
Geschlossen Schaltfläche Belichtungsbereich

Gibt die Region an, die bei der automatischen Berechnung der Belichtung verwendet werden soll.

Hinweis: Um diese Funktion zu aktivieren, muss im Dropdownmenü Automatische Belichtung entweder Kontinuierlich oder Einzelaufnahme gewählt werden.
  1. Klicken Sie auf die Schaltfläche Belichtungsbereich.
  2. Positionieren Sie den Bereich um den Bildbereich, den der Sensor verwenden wird, die automatische Belichtung für das nächste aufgenommene Bild zu berechnen.
  3. Klicken Sie auf die Schaltfläche OK.

Die Belichtung wird jetzt auf Basis der Helligkeit des Bildbereiches innerhalb des Belichtungsbereiches automatisch berechnet . Als Beispiel, wenn der Bildbereich innerhalb des Belichtungsbereiches heller ist als der Rest des Bildes, wird das nächste aufgenommene Bild dunkler sein.

Belichtungsbereich bestimmen | Nächstes aufgenommenes Bild
Geschlossen Maximale Belichtungszeit

Hiermit können Sie die maximale Belichtungszeit zum Ermitteln der korrekten Belichtung festlegen.

Geschlossen Zielbildhelligkeit

Hiermit können Sie eine gewünschte Helligkeitsstufe festlegen (0 bis 100).

Hinweis: Um diese Funktion zu aktivieren, muss im Dropdownmenü Automatische Belichtung entweder Kontinuierlich oder Einzelaufnahme gewählt werden.


Bildsensorübertragung – Steuerelemente

Mit den Steuerelementen für die Bildsensorübertragung können Sie festlegen, bei welcher Zeile des Bildsensors (CCD oder CMOS) die Bildübertragung beginnt und wie viele Zeilen des Bildsensors für den Bildaufbau verwendet werden.

In-Sight-Vision-Systeme nehmen alle Bilder mithilfe eines asynchronen Rücksetzvorgangs und eines progressiven Scanvorgangs auf. In-Sight-Grau-Vision-Systeme erzeugen 8-Bit-Bilder, während In-Sight-Farb-Vision-Systeme 24-Bit-Bilder erzeugen. Der Bildaufnahmevorgang beginnt bei allen Vision-Systemen innerhalb von ca. 250 Mikrosekunden (µs). Der Vorgang läuft folgendermaßen ab:

  1. Der Bildsensor integriert Licht während der durch die Belichtungssteuerung definierten Zeit.
  2. Das im Bildsensor erfasste Bild wird Zeile für Zeile in ein serielles Register übertragen.
  3. Bei jeder Zeilenübertragung taktet das Vision-System das Register Pixel für Pixel aus dem Bildsensor.
  4. Die Übertragung beginnt bei der "Startzeile" und wird für die definierte "Anzahl der Zeilen" fortgesetzt.
Geschlossen X-Wert Start

Definiert die erste Zeile, die vom Bildsensor in den Speicher des In-Sight-Vision-Systems übertragen werden soll:

Auflösung | Gültige Startzeilenwerte
640 x 480 | 0 bis 479
800 x 600 | 0 bis 599
1024 x 768 | 0 bis 767
1280 x 1024 | 0 bis 1023
1600 x 1200 | 0 bis 1199
2448 x 2048 | 0 bis 2047
2592 x 1944 | 0 bis 1943
Geschlossen Anzahl der Zeilen

Bestimmt, wie viele Zeilen in den Speicher des In-Sight-Vision-Systems übertragen werden:

Auflösung | Gültige Zeilenanzahl
640 x 480 | 1 bis 480
800 x 600 | 1 bis 600
1024 x 768 | 1 bis 768
1280 x 1024 | 1 bis 1024
1600 x 1200 | 1 bis 1200
2448 x 2048 | 1 bis 2048
2592 x 1944 | 1 to 1944
Hinweis: Falls Sie eine Verbindung zu einem Emulator herstellen und Bilder von einem In-Sight-Vision-System anzeigen möchten, das bei aktivierter Erfassung von Teilbildern Bilder aufgenommen hat, setzen Sie die Parameter Startzeile und Anzahl der Zeilen des Emulators auf die gleichen Werte wie für das In-Sight-Vision-System.


Lichtsteuerelemente

Mit den Lichtsteuerelementen werden die LED-Gruppen und -Ringe für In-Sight-Vision-Systeme konfiguriert.

Hinweis: Um diese Funktion zu aktivieren, muss im Dropdownmenü Automatische Belichtung entweder Kontinuierlich oder Einzelaufnahme gewählt werden.
Geschlossen Lichtsteuerungsmodus (nur In-Sight 5000-Serie und In-Sight 70xx-74xx-Serie)

Der Lichtsteuerungsmodus legt fest, ob die Ringleuchte eines In-Sight Vision-Systems der 5000- oder 70xx-74xx-Serie nur für die Dauer der definierten Belichtung oder immer leuchtet. Bei Auswahl von Ein (Aufnahme) leuchtet die Ringleuchte nur für die Dauer der Belichtung. Bei Auswahl von Ein (kontinuierlich) leuchtet die Ringleuchte immer. Da die LEDs in diesem Modus mit 50 % Intensität leuchten, wenn kein Bild belichtet wird, reduziert dies den Blitzeffekt.

Geschlossen Lichtsteuerung (nur In-Sight 5000-Serie)

Steuert bis zu vier (4) LED-Gruppen in In-Sight-Vision-Systemen.

Geschlossen Beispiel - In-Sight 5000-Vision-System mit Ringleuchte

  • Horizontal aktiviert die beiden horizontalen LED-Gruppen.
  • Vertikal aktiviert die beiden vertikalen LED-Gruppen.
  • Alle aktiviert sowohl die beiden horizontalen als auch die beiden vertikalen LED-Gruppen.
Geschlossen Lichtintensität (nur In-Sight 70xx-74xx-Serie)

Steuert die tatsächliche Intensität der LEDs. Die Lichtintensität wird mit dem Job gespeichert.

  • In-Sight Vision-Systeme der 70xx-74xx-Serie: 0 bis 100; Standard = 1; AUS = 0
Geschlossen Gain (nur In-Sight 7000-Serie und 9912)

Definiert die Verstärkung der Verstärkerstufe vor dem Analog-Digital-Wandler in der Kamera.

In-Sight-Modell | Einstellungen für Gain
70xx-74xx-Serie | 0 bis 7; Standard = 0
7500, 7501, 7600, 7600C, 7800, 7800C, 7801, 7801C, 7802, 7802C, 7900, 7900C, 7901, 7901C, 7902, 7902C | 0 bis 6; Standard = 0
7802P, 7902P, 7905, 7905C | 0 bis 240; Standard = 60
9912, 9912C | 0 bis 255; Standard = 60


High Dynamic Range (HDR)

Durch HDR (High Dynamic Range, hoher Dynamikumfang) werden ein höherer Kontrast und mehr Helligkeit für dunklere Bildbereiche erzielt. Dieser Effekt wird in einer einzigen Aufnahme erzielt.

Hinweis: HDR wird nur von den Monochrom-Vision-Systemen In-Sight 7802P, 7902P, 7905, 8505P und 9912 unterstützt.

  • HDR-Modus: Legt das eingesetzte HDR-Verfahren fest.
    • Deaktiviert (Standard): HDR wird nicht verwendet.
    • HDR+: Die Graustufen der einzelnen Pixel werden durch Betrachtung der benachbarten Pixel (in Abhängigkeit von der Kernelgröße) angepasst. Dadurch wird im Vergleich zu HDR ein besserer Kontrast in dunklen (unterbelichteten) und hellen (überbelichteten) Regionen erzielt.
    • HDR: Die Graustufen der einzelnen Pixel werden individuell angepasst. Dadurch wird der Kontrast in dunklen (unterbelichteten) Bildbereichen erhöht.
  • HDR-Kernelgröße: Gibt die Gesamtanzahl der Pixel an, die gleichzeitig mit HDR+ verarbeitet werden.
    • Klein: 121 Pixel (Quadrat 11x11)
    • Groß: 484 Pixel (Quadrat 22x22)


Weißabgleich (nur In-Sight Color-Vision-Systeme)

Hinweis: Dieses Thema beschreibt die Weißabgleich-Funktion, wenn man mit einem In-Sight Color-Vision-System verbunden ist. Besteht eine Verbindung mit einem In-Sight Color-Sensor der 2000 Serie, finden Sie weitere Informationen im Abschnitt Weißabgleich von Bildeinstellungen.

Verfügbar nur für In-Sight Vision-Systeme und Emulatoren mit Farbunterstützung, die Schaltfläche Weißabgleich entfernt Farbstiche in einem Farbbild, indem die Rot-, Grün- und Blau-Werte (RGB) des Bildes berechnet und entsprechend den im In-Sight-Job gespeicherten Farbtabellen korrigiert werden. Dadurch erscheinen z. B. Elemente, die tatsächlich weiß sind, im Bild weiß.

Bild vor Weißabgleich | Nach Weißabgleich | Bild nach Weißabgleich

Die Farbtabellen werden erstellt, indem Sie ein Bild mit "neutraler" Referenz aufnehmen (d. h., ein Bild mit gleichen RGB-Werten, z. B. 18-18-18) und dabei sicherstellen, dass das Bild nicht die Sättigung erreicht (255-255-255). Nachdem Sie auf Weißabgleich geklickt haben, generiert EasyBuilder ein Histogramm jedes Farbkanals (rot, grün und blau), und die Farbwerte werden ausgeglichen. Dabei wird der höchste Wert als Basis herangezogen und durch jeden Farbwert dividiert, um Skalierungsfaktoren zu erhalten, die dann zum Erstellen der Farbtabellen verwendet werden (ein RGB-Wert von 200-100-50 ergibt z. B. die Skalierungsfaktoren 1-2-4).

Die Farbtabellen für die aktuellen Vision-System-Einstellungen werden in der Jobdatei gespeichert. Laden Sie den Job vor dem Laden oder Aufnehmen eines Bildes, um sicherzustellen, dass die korrekten Informationen für den Weißabgleich angewendet werden.

So verwenden Sie die Funktion Weißabgleich:

  1. Fokussieren Sie den In-Sight-Sensor auf einem flachen Testobjekt, z. B. einem Stück weißen Papier mit schwarzer Schrift, und stellen Sie die Zielbildhelligkeit entsprechend ein.

    Hinweis: Über die Schaltfläche Bereich für Weißabgleich wird der Bereich für die Berechnung des Weißabgleichs des Bildes festgelegt. Klicken Sie auf die Schaltfläche Bereich für Weißabgleich, um den Bereich zu bestimmen.
  2. Setzen Sie anstelle des flachen Testobjekts ein anderes Objekt ein, z. B. ein leeres weißes Papier. Das zweite Objekt sollte wie das Originalobjekt in das Bildfeld eingepasst werden.

  3. Klicken Sie auf die Schaltfläche Weißabgleich.

  4. EasyBuilder speichert diese Einstellungen jetzt in der Jobdatei, und bei allen nachfolgenden Bildaufnahmen wird diese Farbabgleicheinstellung verwendet.

    Hinweis: Die Einstellung für den Weißabgleich wird in der Jobdatei und nicht auf dem In-Sight-Vision-System gespeichert. Beim Erstellen eines neuen Jobs müssen diese Schritte wiederholt werden, um die Einstellungen für den Weißabgleich für die Jobdatei zu übernehmen. EasyBuilder gestattet nicht die Speicherung der Einstellungen für den Weißabgleich auf dem Vision-System.


Region fokussieren

Mit der Schaltfläche Region fokussieren bestimmen Sie die Region des Bildes, das zur Berechung des Bildfokus für die Fokussiermetrik Live-Modus verwendet wird. Klicken Sie auf die Schaltfläche Region fokussieren, um die Region zu konfigurieren.


Fokussier-Steuerelemente

Die Fokussier-Steuerelemente werden zur Steuerung der Fokusposition des Objektivs auf unterstützten In-Sight Vision-Systemen der 7000-er Serie verwendet. Der Fokus des Objektivs wird entweder automatisch geregelt oder kann auf eine bestimmte Fokusposition eingestellt werden.

Hinweis:
  • Für Vision-Systeme der 70xx-74xx-Serie sind die Fokus-Steuerungen nur für Vision-Systeme verfügbar, die In-Sight Explorer 4.7.3 oder höher und die In-Sight 4.7.3-Firmware oder höher ausführen.
  • Die Fokussier-Steuerelemente funktionieren nur, wenn das Vision-System Offline geschaltet ist.
  • Die Schaltflächen „Autofokus“ und „Fokus speichern“ sind auch im Live Video-Modus zugänglich, sowohl in der Tabellenansicht als auch in der EasyBuilder-Ansicht.
Geschlossen Fokussier-Steuerelemente

Definiert, ob die Fokus-Steuerung aktiviert oder nicht aktiviert ist. Wenn ein Sensor eine gültige Standard-Fokusposition hat, sind die Fokus-Steuerelemente standardmäßig aktiviert. Ist eine Fokusposition nicht eingerichtet, sind die Fokus-Steuerelemente deaktiviert.

Geschlossen Schaltfläche Autofokus

Fokussiert das Objektiv automatisch, um die bestmögliche Bildschärfe im Bereich zu erzielen.

Geschlossen Autofokus-Versatz (Nur In-Sight 70xx-74xx-Serie)

Definiert einen auf die Objektivposition angewandten Versatz (-100 bis 100; Standard = 0) nach Abschluss des automatischen Fokussierens.

Hinweis: Diese Einstellung wird von Vision-Systemen der In-Sight 7000 Gen2-Serie nicht unterstützt.
Geschlossen Fokusposition

Bewegt das Objektiv in eine bestimmte Fokusposition und nimmt ein neues Bild auf.

  • In-Sight 70xx-74xx-Serie: 0-100; Standard= 0
  • In-Sight 7000 Gen2-Serie: 0-250; Standard= 0
Geschlossen Fokusposition mit Job speichern

Definiert, ob die Fokusposition mit dem Job gespeichert und beim erneuten Laden des Jobs auf das Objektiv angewendet wird. Das Kontrollkästchen Fokusposition mit Job speichern ist standardmäßig aktiviert.


Zeilenscan-Steuerelemente

Mit den Steuerelementen für den Zeilenscan können Sie die Einstellungen für das Zeilenscan-Vision-System In-Sight 5604 bzw. 9902L konfigurieren. Das Zeilenscan-Vision-System setzt ein Bild Zeile für Zeile zusammen, während das Zielobjekt unter dem Gerät durchläuft. Diese Vorgehensweise ermöglicht vollständige Bilder von zylindrischen Objekten oder in einzelne Streifen unterteilte, fortlaufende Bilder einer Oberfläche. Mit einem vom Anwender bereitgestellten Drehgeber sind trotz variabler Zielgeschwindigkeit hochpräzise Bilder möglich.

Hinweis:
  • Um diese Steuerelemente zu aktivieren, müssen Sie an einem Zeilenscan-Vision-System In-Sight 5604 bzw. 9902L oder bei einem Emulator angemeldet sein.
  • Zur Konfiguration der Einstellungen benötigt der Anwender die Zugriffsstufe „Vollzugriff“.
  • Das Zeilenscan-Vision-System muss offline geschaltet sein.

  • Trigger: Definiert die Quelle des Bildaufnahmetriggers, wenn das Zeilenscan-Vision-System online ist.

    • Kamera (Standard): Aktiviert die Bildaufnahme über eine vom dezidierten Triggereingang des Vision-Systems erkannte steigende Flanke.
    • Kontinuierlich: Aktiviert „freilaufende“ (möglichst schnelle) Bildaufnahmen.

    • Extern: Aktiviert die Bildaufnahme über einen seriellen Befehl oder über die steigende Flanke, die auf ein als Aufnahmetrigger konfiguriertes diskretes Eingangsbit angewendet wird.

      Hinweis:
      • Höhere Triggergeschwindigkeiten werden durch die Verwendung des integrierten Triggereingangs des Systems erzielt (indem der Parameter Trigger auf Kamera gesetzt wird), anstatt das Vision-System mit einer als Triggereingang konfigurierten Allzweckeingangsleitung zu triggern (indem der Parameter Trigger auf Extern gesetzt wird).
      • Falls der Parameter „Trigger“ der AcquireImage-Funktion auf „Extern“ gestellt ist und eine Aufnahme verpasst wird, sendet das Vision-System kein diskretes „FEHLER: Bild verpasst“-Signal. Das „FEHLER: Bild verpasst“-Signal wird nur unterstützt, wenn der Parameter „Trigger“ der AcquireImage-Funktion auf „Kamera“ gestellt ist.
    • Manuell: Aktiviert die Bildaufnahme durch Drücken der Taste F5.
    • Industrial Ethernet: Ermöglicht das Triggern via Industrial Ethernet-Protokoll, z. B. EtherNet/IP, POWERLINK, Profinet, SLMP-Scanner oder CC-Link IE Field Basic.
    • Zeitstempel: Aktiviert die Bildaufnahme, wenn von einer SPS über EtherNet/IP ein Zeitstempel-Trigger an das Vision-System gesendet wird. Die Option „Zeitstempel“ wird nur auf folgenden Vision-Systemen unterstützt:

      • In-Sight Vision-Systeme der 5000-Serie mit 128MB nicht flüchtigem Flashspeicher und mit Firmwareversion ab 4.5.0.

        Hinweis: Die Vision-Systeme In-Sight 5605 (Hardware-Typ 821-0032-1R), In-Sight 5705 und In-Sight 5705C werden nicht unterstützt.
      • Vision-Systeme der In-Sight 7000 Gen2-Serie
      • Vision-Systeme der In-Sight 9000-Serie

  • Zeilenverzögerung (Zeilen): Definiert die Anzahl der zu verzögernden Zeilen, nachdem der Kameratrigger stattgefunden hat und bevor die Aufnahme eines Bildes beginnt.

    Hinweis: Der Parameter Trigger muss zur Aktivierung dieses Steuerelements auf Kamera eingestellt werden.
  • Triggerintervall: Definiert ein Intervall in Millisekunden, das zwischen Aufnahmen eingehalten wird, wenn das Steuerelement Trigger auf Kontinuierlich eingestellt ist (0 bis 10.000, Standard ist 500). Diese Verzögerung hängt davon ab, wie lange der Job für die Verarbeitung des Bildes benötigt. Ist das Triggerintervall beispielsweise auf 5.000 Millisekunden eingestellt, erfasst das In-Sight-Vision-System alle 5.000 Millisekunden ein Bild, sofern der Job die Bildverarbeitung innerhalb von 5.000 Millisekunden abgeschlossen hat. Andernfalls erfasst In-Sight ein Bild, sobald es die Bildverarbeitung abgeschlossen hat.

  • Belichtung (µs): Definiert die Belichtungszeit in Mikrosekunden (0 bis 1.000 µs; Standard ist 8 µs). Empfängt das Vision-System ein Triggersignal, wird für die definierte Dauer Licht in den Zeilenscan-CCD-Sensor integriert.

    Hinweis:
    • Obwohl dieser Parameter beim 5604 technisch auf 0 gesetzt werden kann, führt jeder Wert unter 1,33 µs dazu, dass 1,33 µs lang belichtet wird, unabhängig vom Wert unter Belichtung.
    • Obwohl dieser Parameter beim 9902L technisch auf 0 gesetzt werden kann, führt jeder Wert unter 2,00 µs dazu, dass 2,00 µs lang belichtet wird, unabhängig vom Wert unter Belichtung.
  • Zeilentriggertyp: Definiert die Art des Drehgebers: Software-Drehgeber oder Hardware-Drehgeber. Um dieses Steuerelement zu aktivieren, müssen Sie an einem Zeilenscan-Vision-System In-Sight 5604 bzw. 9902L angemeldet sein; für Zeilenscan-Emulatoren ist diese Funktion nicht verfügbar.
    • Hardware-Drehgeber: Definiert, dass die Einstellungen für Schritte pro Zeile und ein externer Hardware-Drehgeber für die Bewegung der Zeilentrigger verwendet werden. Ein Hardware-Drehgeber ist ein Gerät, das die Position des Zielobjekts digitalisiert. Dies geschieht, indem bei jeder Bewegung des Ziels in eine angegebene Richtung oder über eine angegebene Distanz eine Signalflanke erfolgt. Das In-Sight 5604 und das In-Sight 9902L unterstützen zwei verschiedene Typen von Hardware-Drehgebern: Einzelzeilen- und Quadratur-Drehgeber. Der Typ kann im Dialogfeld Zeilenscaneinstellungen ausgewählt werden.
    • Software-Drehgeber (Standard): Legt fest, dass die Einstellung für die Zeilenperiode als Takt zum Bewegen der Zeilentrigger in einem definierten Intervall verwendet werden soll. Ein Software-Drehgeber ist eine Softwareemulation eines Hardware-Drehgebers und nimmt Zeilen mit einer definierten Rate auf. Diese Methode wird hauptsächlich für die Einrichtung und die Fehlerbehebung verwendet, da die Methode empfindlich auf Änderungen der Zielgeschwindigkeit (Niederfrequenzbeschleunigung und höherfrequente Erschütterung) reagiert, die zu vertikalen Bildartefakten führen können.
  • Zeilenanzahl: Legt die Anzahl der Zeilen fest bis, die für den Aufbau eines Bildes aus dem Zeilenscan-Vision-System aufgenommen werden.
    • In der Standardeinstellung produziert das In-Sight 5604-System Standardbereichsbilder in einer Auflösung von 1024 x 2048 Pixeln. Die Breite kann nicht verändert werden. Die maximale Bildhöhe kann über die Schaltfläche „Drehgeber-Setup...“ eingestellt werden, mit der das Dialogfeld „Zeilenscaneinstellungen“ geöffnet wird. Der Wert für „Zeilenanzahl“ kann zwischen 1 und der maximalen Bildhöhe betragen.
    • In der Standardeinstellung produziert das In-Sight 9902L-System Standardbereichsbilder in einer Auflösung von 2048 x 4096 Pixeln. Die Breite und die maximale Bildhöhe können über die Schaltfläche „Drehgeber-Setup...“ eingestellt werden, mit der das Dialogfeld „Zeilenscaneinstellungen“ geöffnet wird. Wenn das Kontrollkästchen „Auflösung 1K (Restlicht-Modus)“ aktiviert wurde, wird die Breite auf 1024 reduziert. Dadurch ist die Lichtempfindlichkeit höher. Der Wert für „Zeilenanzahl“ kann zwischen 1 und der maximalen Bildhöhe betragen.
    In-Sight-Modell | Maximale Auflösung | Minimum | Maximum | Standard
    In-Sight 5604 | 1024 x 8192 | 1 | 8192 | 2048
    In-Sight 9902L | 2048 x 16384 | 1 | 16384 | 4096
    1024 x 16384
    Hinweis:
    • Wenn ein rotierendes Zielobjekt aufgenommen werden soll, muss der Wert Zeilenanzahl kleiner als die Anzahl der Zeilen zwischen zwei beliebigen Einzelbildtriggern sein. So werden fehlende Bildtrigger vermieden.
    • Obwohl dieser Parameter technisch auf 1 gesetzt werden kann, führt jeder Wert kleiner als 8 zu einer erfolglosen Bildaufnahme.

  • Schritte pro Zeile: Definiert die Anzahl der Drehgeberschritte pro Bildzeile, wenn der Zeilentriggertyp auf Hardware-Drehgeber gesetzt ist. Ein „Schritt“ ist ein kompletter Zyklus des Drehgebersignals bzw. (bei Verwendung eines Quadratur-Drehgebers) der Drehgebersignale. Bei einem Einzelzeilen-Hardware-Drehgeber entspricht dies zwei Signalflanken und bei einem Quadratur-Hardware-Drehgeber entspricht dies vier Signalflanken.

    In-Sight-Modell | Schritte pro Zeile
    In-Sight 5604 | 0,250 bis 256.000; Standard = 40.000
    In-Sight 9902L | 0,250 bis 8191,000; Standard = 40,000
    Hinweis:
    • Der Wert für Schritte pro Zeile muss für Einzelzeilen-Hardware-Drehgeber um 0,5 und für Quadratur-Hardware-Drehgeber um 0,25 erhöht werden.
    • Der Wert für Schritte pro Zeile muss beim 5604 so eingestellt sein, dass der kürzeste Zeitraum zwischen zwei beliebigen Zeilen 21,47 µs länger als der für die Belichtung eingestellte Wert ist (minimal 1,33 µs). So wird fehlenden Zeilentriggern vorgebeugt.
    • Der Wert für Schritte pro Zeile muss beim 9902L so eingestellt sein, dass der kürzeste Zeitraum zwischen zwei beliebigen Zeilen 3 µs länger als der für die Belichtung eingestellte Wert oder 15 µs ist (der höhere Wert muss verwendet werden). So wird fehlenden Zeilentriggern vorgebeugt.
    Geschlossen Schritte pro Zeile/Hardware-Drehgeber – Zeitvorgabe-Diagramm

  • Zeilenperiode (µs): Definiert die Zeit pro Bildzeile in Mikrosekunden, wenn der Zeilentriggertyp auf Software-Drehgeber gesetzt ist.

    In-Sight-Modell | Zeilenperiode
    In-Sight 5604 | 21,000 bis 1000000,000; Standard = 40,000
    In-Sight 9902L | 21,000 bis 1000000,000; Standard = 40,000
    In-Sight-Emulator | 10,000 bis 1000000,000; Standard = 40,000
    Hinweis:
    • Der Wert für Zeilenperiode muss beim 5604 so eingestellt sein, dass der kürzeste Zeitraum zwischen zwei beliebigen Zeilen 21,47 µs länger als der für die Belichtung eingestellte Wert ist (minimal 1,33 µs). So wird fehlenden Zeilentriggern vorgebeugt.
    • Der Wert für die Zeilenperiode muss beim 9902L so eingestellt sein, dass der kürzeste Zeitraum zwischen zwei beliebigen Zeilen 3 µs länger als der für die Belichtung eingestellte Wert oder 15 µs ist (der höhere Wert muss verwendet werden). So wird fehlenden Zeilentriggern vorgebeugt.
  • Schnittmodus: Legt eine Aktion fest, wenn ein Bildaufnahmetrigger empfangen wurde, aber die angegebene Zeilenanzahl noch nicht aufgenommen wurde.
    • Kein Abschneiden (Standard): Legt fest, dass der Bildtrigger ignoriert und ein Bildaufnahme-Fehler-Ereignis generiert werden soll.
    • Schwarz füllen: Legt fest, dass die restlichen Zeilen mit schwarzen Pixeln gefüllt werden und umgehend ein neues Bild gestartet wird. Es wird kein Bildaufnahme-Fehler-Ereignis generiert.

    • Anzahl Bildzeilen verringern: Legt fest, dass das aktuelle Bild auf die Größe der aktuell aufgenommenen Zeilen verringert und umgehend ein neues Bild gestartet werden soll.

    Hinweis:
    • Wenn „Schwarz füllen“ oder „Anzahl Bildzeilen verringern“ ausgewählt ist:
      • Damit Bilder genau abgeschnitten werden können, muss der Triggertyp auf Kamera eingestellt sein. Wenn bei jedem anderen Triggertyp der Trigger während einer Bildaufnahme eintrifft, wird das aktuelle Bild nicht abgeschnitten und der Trigger wird verpasst.
      • Wenn der Native-Modus-Befehl „Set Event“ zum Triggern einer Aufnahme gesendet wird und der Trigger während einer Bildaufnahme eintrifft, wird das aktuelle Bild nicht abgeschnitten und der Trigger wird verpasst.
    • Bei zeitkritischen Anwendungen wählen Sie die Option „Anzahl Bildzeilen verringern“. Falls Sie die Option „Schwarz füllen“ ausgewählt haben, sollten damit nicht mehr als ein paar Hundert Zeilen gefüllt werden.
      • Bei der Option „Schwarz füllen“ dauert das Füllen einer Zeile beim 5604 circa 2 µs (z.B. 0,2 Millisekunden für 100 Zeilen).
      • Bei der Option „Schwarz füllen“ dauert das Füllen einer Zeile beim 9902L circa 3 µs (z.B. 0,3 Millisekunden für 100 Zeilen).
  • Dauer der Bildaufnahme: Legt fest, wann die Bildaufnahme beendet wird, wenn der Schnittmodus auf „Schwarz füllen“ oder „Anzahl Bildzeilen verringern“ gesetzt wurde. Diese Option wird nur auf dem Vision-System In-Sight 9902L unterstützt, wenn als Triggertyp Kamera ausgewählt wurde.
    • 0 = Nächster Trigger (Standard): Die Bildaufnahme beginnt an der steigenden Flanke des Triggerimpulses und endet am Anfang des nächsten Triggersignals.
    • 1 = Ende des Triggers: Die Bildaufnahme beginnt an der steigenden Flanke des Triggerimpulses und endet an der nachführenden Flanke des Triggerimpulses. Die Bildaufnahme ist in folgenden Fällen abgeschlossen:
      • Die angegebene Zeilenanzahl wurde aufgenommen, selbst wenn die nachführende Flanke des Triggerimpulses noch nicht erreicht wurde; oder

      • die nachführende Flanke des Triggerimpulses wird erreicht und beendet die Aufnahme, bevor die angegebene Zeilenanzahl aufgenommen wurde.

        Hinweis: Wenn „Ende des Triggers“ ausgewählt wird, steht der Parameter „Verzögerung“ nicht zur Verfügung und die Aufnahme wird nicht verzögert.

Zeilenscaneinstellungen


Zeilenscaneinstellungen

Mit dem Dialogfeld „Zeilenscaneinstellungen“ werden bei Verwendung der Zeilenscan-Vision-Systeme In-Sight 5604 und 9902L die Einstellungen für den Hardware-Drehgeber konfiguriert und Diagnosedaten des Vision-Systems angezeigt.

Hinweis: Beim Einsatz eines Quadratur-Hardware-Drehgebers wird das aufgenommene Bild falsch kombiniert und somit unbrauchbar, wenn der Quadratur-Drehgeber nach Beginn der Bildaufnahme mit dem Vision-System signalisiert, dass er sich in die entgegengesetzte Richtung hinter den Einzelbildtrigger bewegt. Schalten Sie das Vision-System in diesem Fall offline, wenn der Quadratur-Drehgeber die Umkehr der Richtung signalisiert. Schalten Sie das Vision-System wieder online, wenn der Quadratur-Drehgeber die Bewegung in der ursprünglichen Richtung wieder aufnimmt.

  • Maximale Bildhöhe: Gibt für Zeilenscan-Vision-Systeme die maximale Anzahl der Zeilen zur Erstellung des Bildes und die maximale Anzahl von Bild-Zwischenspeichern an:

    Vision-System Maximale Bildhöhe
    In-Sight 5604

    2048 (Standard)

    4096

    8192
    In-Sight 9902L

    2048

    4096 (Standard)

    8192

    12288

    16384
    Hinweis:
    • Für die Anpassung der maximalen Bildhöhe eines In-Sight Vision-Systems muss das Vision-System neu gestartet werden. Hierbei werden alle Job- und Einstellungsdateien aus dem nicht flüchtigen Flash-Speicher gelöscht. Speichern bzw. sichern Sie den Job und fahren Sie anschließend fort.
    • Die Standardanzahl der dem Vision-System beim Start zugeteilten Bild-Zwischenspeicher ist vom Modell des Vision-Systems und dessen RAM-Größe abhängig. Die Veränderung der Einstellung von „Max Bildhöhe“ kann die maximale Anzahl der Bildpuffer, die dem Vision-System beim Start zur Verfügung stehen, erhöhen oder verringern. Benutzen Sie deswegen gegebenenfalls das Dialogfeld Bild-Zwischenspeicher für das Ändern der Anzahl der Bild-Zwischenspeicher, die dem Vision-System beim Start zugewiesen werden.

    • Bei Zeilenscan-Vision-System haben die Einstellungen der Bereichsbreite für die Werkzeuge Position und Inspektion einen Höchstwert. Wenn die Bereichsbreite auf einen höheren Wert eingestellt werden muss, können Sie dies in der Tabellenansicht vornehmen: Geben Sie entweder den Bereichswert manuell in der Formelleiste ein oder erstellen Sie eine eigene Steuerelement- oder Strukturfunktion und verweisen statt auf den Bereichsparameter des Werkzeugs auf diese.

      Vision-System | Auflösung | Maximale Bildhöhe | Maximale Breite im Eigenschaftsblatt
      In-Sight 5604 | 1024 x 8192 | 8192 | 3072
      In-Sight 9902L 2048 x 16384

      8192 und größer

               6144
      1024 x 16384 | 4096 und größer | 3072
  • Hardware-Drehgeber
    Hinweis: Zur Änderung des Typs oder der Richtung des Drehgebers muss der Parameter „Zeilentriggertyp“ im Anwendungsschritt „Bild einrichten“ auf „Hardware-Drehgeber“ gesetzt sein, das Zeilenscan-Vision-System muss offline geschaltet sein und der Benutzer muss über Vollzugriff verfügen.

    • Drehgeber-Typ: Gibt die Art des Hardware-Drehgebers an, mit dem die Zeilenaufnahmen getriggert werden: „Einzeln“ (Standard) oder „Quadratur“.

      Hinweis:
      • Wenn der Drehgeber-Typ auf „Einzeln“ gesetzt wurde, muss der Einzelzeilen-Drehgeber an den ersten Drehgeber-Eingang angeschlossen werden; wenn er an den zweiten Eingang angeschlossen wird, bleibt dies wirkungslos.
      • Quadratur-Drehgeber stellen Richtungsdaten bereit; hierfür sind zwei Hochgeschwindigkeitseingänge notwendig.

    • Richtung: Gibt an, welche Richtung für den Quadratur-Drehgeber als „Vorwärts“ angesehen werden soll: Positiv (Standard) oder Negativ. Das Zeilenscan-Vision-System bestimmt anhand der Richtung die richtige Betriebsrichtung. Schritte in der anderen Richtung gelten als ungültig; dadurch wird das aktuelle Bild abgebrochen.

      Hinweis: Dieses Steuerelement ist nicht aktiviert, falls der Drehgeber-Typ auf „Einzeln“ eingestellt ist.
  • Diagnose
    • Drehgeber - Anzahl: Zeigt die Anzahl der Hardware-Drehgeberschritte an (bzw. bei Software-Drehgebern die Mikrosekunden).
    • Zeilenanzahl: Zeigt die fortlaufende Gesamtanzahl der Zeilen an, die seit dem letzten Zurücksetzen der Zähler aufgenommen wurden.
    • Zeilenüberlaufanzahl: Zeigt die Anzahl der Zeilen an, die aufgrund zu hoher Drehgebergeschwindigkeiten verloren gegangen sind.
    • Pufferüberlauf - Anzahl: Zeigt an, wie oft im Zeilenscan-Vision-System zu geringer Bildpuffer vorhanden war.
    • Bilder pro Sekunde: Zeigt die Anzahl der Bilder an, die pro Sekunde aufgenommen werden.

    • Schritte pro Sekunde: Zeigt die Anzahl der Schritte an, die vom externen Hardware-Drehgeber pro Sekunde eingehen.

      Hinweis: Wenn ein Software-Drehgeber verwendet wird, gibt der angezeigte Wert die Anzahl der Mikrosekunden pro Sekunde an.

    • Schaltfläche „Zurücksetzen“: Diese Schaltfläche setzt alle Diagnosestatistiken auf Null zurück.

      Hinweis: Wenn auf die Schaltfläche „Zurücksetzen“ geklickt wird oder wenn das Zeilenscan-Vision-System online oder offline gestellt wird, werden alle Diagnosestatistiken auf Null zurückgesetzt.
  • Auflösung 1K (Restlicht-Modus): Erhöht die Lichtempfindlichkeit durch Reduzierung der Auflösung. Diese Option wird nur auf dem Vision-System In-Sight 9902L unterstützt.


Kalibrieren des Bildes in reellen Einheiten

Hinweis: Dieser Abschnitt beschreibt die Kalibrierfunktion, wenn man mit einem In-Sight Vision-System verbunden ist. Wenn eine Verbindung mit einem Vision-Sensor In-Sight 2000-130/130C oder In-Sight 2000-Serie 23X besteht, finden Sie weitere Informationen unter Bildeinstellungen im Abschnitt „Betrachtungsfeld (Breite)“.

Mit dem Gruppenfeld Bild in realen Einheiten kalibrieren können Sie die Ergebnisse der Werkzeuge für den Speicherort und die Inspektion kalibrieren. Dabei werden statt Pixelwerten echte Einheiten (Mikrometer, Millimeter, Zentimeter und/oder Zoll) verwendet.

Bei In-Sight-Vision-Systemen bezieht sich die Kalibrierung auf den Vorgang des "Zuordnens" des Bildbereichs. Dabei wird eine Beziehung zwischen den Merkmalen im Bild und echten Maßeinheiten hergestellt. Bei diesem Vorgang werden von einer zweidimensionalen (2D) Transformation Bildpunkte mit Pixelkoordinaten echten Koordinaten mathematisch zugeordnet. Nach der Kalibrierung eines Bilds geben die Positions- und Inspektionswerkzeuge die Ergebnisse in den kalibrierten (echten) Maßeinheiten aus.

Es gibt sechs verschiedene Arten von Kalibrierungen von unterschiedlichem Genauigkeitsgrad, die zur kalibrierung eines In-Sight Vision-Systems herangezogen werden können: X/Y-Skalierung, Kante zu Kante, Kante zu Kante (X/Y), Kreis, Raster, Importieren oder 9-Punkt.

Wählen Sie eine Kalibrierungsoption im Dropdownmenü Kalibrierungstyp, um dem Job eine Kalibrierung zuzuweisen:

  • Keine (Standard)
  • X-/Y-Skalierung
  • Kante zu Kante
  • Kante zu Kante (X/Y)
  • 9-Punkt
  • Kreis
  • Raster
  • Importieren
Hinweis:
  • Die Kalibrierungsoptionen X/Y-Skalierung, Kante zu Kante, Kante zu Kante (X/Y), Kreis, Importieren und 9-Punkt beruhen jeweils auf 16 benutzerdefinierten Punkten im Bild, die zur Herstellung einer Beziehung zu den echten Abmessungen der inspizierten Objekte verwendet werden. Diese Kalibrierungsoptionen können nur zum Ausgleich linearer und nicht linearer Verzerrungen eingesetzt werden. Verwenden Sie die Kalibrierungsoption Raster, um die höchste Genauigkeit zu erzielen.
  • Wird die standardmäßige Einstellung Keine als Kalibrierungstyp verwendet, werden alle Werkzeugergebnisse in Pixelkoordinaten zurückgegeben.
  • Aktivieren Sie das Kontrollkästchen Klassische Ausrichtung, um die kalibrierten Ergebnisse gemäß den herkömmlichen Koordinaten der Arbeitsblattansicht (Y/X) anzuzeigen.
  • Beim Anwenden einer Kalibrierung müssen die physischen und optischen Einstellungen (Objektiv, Vision-System und das physische Verhältnis zwischen dem Vision-System und der aufgezeichneten Szene) des Kalibrierungs- und Laufzeitvorgangs übereinstimmen. Wird eines der Elemente geändert, muss das System erneut kalibriert werden. Daher wird empfohlen, dasselbe Vision-System und Objektiv sowohl zur Kalibrierung als auch zur Verarbeitung der Laufzeitbilder zu verwenden. Die Einrichtungs- und Kalibrierungseinstellungen des Vision-Systems und des Objektivs dürfen ebenfalls nicht geändert werden. Beispielsweise wird durch Änderung des Aufzeichnungsformats (durch Änderung der Auflösung) oder des Standorts des Vision-Systems die berechnete 2D-Transformation ungültig, die Pixel echten Koordinaten zuordnet.

Kalibrierungstypen „X-/Y-Skalierung“, „Kante zu Kante“, „Kante zu Kante (X/Y)“ und „Kreis“

9-Punkt-Kalibrierung

Rasterkalibrierung

Importieren eines Kalibrierungstyps


Kalibrierungstypen "X/Y-Skalierung", "Kante zu Kante", "Kante zu Kante (X/Y)" und "Kreis"

Die Kalibrierungsoptionen X/Y-Skalierung, Kante zu Kante, Kante zu Kante (X/Y) und Kreis sind nützlich für Anwendungen, bei denen ein Teil oder ein Objekt inspiziert wird und die reellen Abmessungen des Teils oder des Objekts bekannt sind.

Hinweis: Bei den Skalierungskalibrierungsoptionen werden Linsenverzerrungen nicht berücksichtigt. Um maximale Genauigkeit zu erzielen, sollten Sie daher sicherstellen, dass das In-Sight-Vision-System senkrecht zur inspizierten Oberfläche montiert wird. Andernfalls können Sie ggf. die Rasterkalibrierung verwenden, um die Verzerrung zu beseitigen und das Bild genauer zu kalibrieren.
Geschlossen X-/Y-Skalierung

Wird verwendet, wenn die X- und Y-Skalierungswerte für die Berechnung einer einfachen Kalibrierung bekannt sind.

Hinweis: Bei dieser Option wird die Verzerrung nicht berücksichtigt.
  1. Klicken Sie im Dropdownmenü Kalibrierungstyp auf X/Y-Skalierung.
  2. Wählen Sie im Dropdownmenü Maßeinheiten die reellen Einheiten aus (Mikrometer, Millimeter, Zentimeter oder Zoll).
  3. Geben Sie in den Parameter Horizontale Skalierung den horizontalen Skalierungswert ein (0 bis 9 999 999).
  4. Geben Sie in den Parameter Vertikale Skalierung den vertikalen Skalierungswert ein (0 bis 9 999 999).
  5. Die Kalibrierung wird angewendet, sobald die Option ausgewählt und die Werte konfiguriert wurden.
Geschlossen Kante zu Kante

Wird verwendet, wenn die Entfernung zwischen zwei Kantenmerkmalen bekannt ist.

  1. Klicken Sie im Dropdownmenü Kalibrierungstyp auf Kante zu Kante.
  2. Klicken Sie auf die Schaltfläche Kanten auswählen. EasyBuilder untersucht das Bild und stellt eine Auswahl von automatisch erkannten Smart Features bereit (zyanfarben hervorgehoben).
  3. Wählen Sie zunächst eines der verfügbaren Smart Features per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta, und eine Linie in Verlängerung des Merkmals wird angezeigt.

  4. Wählen Sie anschließend das zweite Smart Feature aus.

    Hinweis: Wenn die gewünschten Merkmale nicht automatisch von EasyBuilder gefunden werden, deaktivieren Sie das Kontrollkästchen Smart Features, und platzieren Sie stattdessen den Bereich über dem zu definierenden Merkmal.
  5. Klicken Sie zum Definieren der Merkmale auf OK.
  6. Wählen Sie im Dropdownmenü Maßeinheiten die reellen Einheiten aus (Mikrometer, Millimeter, Zentimeter oder Zoll).
  7. Geben Sie das bekannte reelle Maß in das Feld Abmessung ein.
  8. Klicken Sie auf die Schaltfläche Kalibrieren, um den Kalibrierungsprozess abzuschließen. Die Ergebnisse von Positions- und Inspektionswerkzeugen werden jetzt in reellen Einheiten angezeigt.
Geschlossen Kante zu Kante (X/Y)

Wird verwendet, wenn der Abstand zwischen zwei Eckpaaren bekannt ist (eines in horizontaler Richtung und ein weiteres in vertikaler Richtung). Durch die Kombination der horizontalen Abmessung mit der vertikalen Abmessung werden zwei unabhängige Skalierungen erstellt.

  1. Klicken Sie im Dropdownmenü Kalibrierungstyp auf Kante zu Kante (X/Y).
  2. Klicken Sie auf die Schaltfläche zum Definieren der horizontalen Abmessung. EasyBuilder untersucht das Bild und stellt eine Auswahl von automatisch erkannten Smart Features bereit (zyanfarben hervorgehoben).
  3. Wählen Sie zunächst eines der verfügbaren Smart Features per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta, und eine Linie in Verlängerung des Merkmals wird angezeigt.

  4. Wählen Sie anschließend das zweite Smart Feature aus.

    Hinweis: Wenn die gewünschten Merkmale nicht automatisch von EasyBuilder gefunden werden, deaktivieren Sie das Kontrollkästchen Smart Features, und platzieren Sie stattdessen den Bereich über dem zu definierenden Merkmal.
  5. Klicken Sie zum Definieren der Merkmale auf OK.
  6. Klicken Sie auf die Schaltfläche zum Definieren der vertikalen Abmessung. EasyBuilder untersucht das Bild und stellt eine Auswahl von automatisch erkannten Smart Features bereit (zyanfarben hervorgehoben).
  7. Wählen Sie zunächst eines der verfügbaren Smart Features per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta, und eine Linie in Verlängerung des Merkmals wird angezeigt.
  8. Wählen Sie anschließend das zweite Smart Feature aus.
  9. Klicken Sie zum Definieren der Merkmale auf OK.
  10. Wählen Sie im Dropdownmenü Maßeinheiten die reellen Einheiten aus (Mikrometer, Millimeter, Zentimeter oder Zoll).
  11. Geben Sie die bekannte reelle horizontale Abmessung in das Feld Horizontale Dimension ein.
  12. Geben Sie die bekannte reelle vertikale Abmessung in das Feld Vertikale Dimension ein.
  13. Klicken Sie auf die Schaltfläche Kalibrieren, um den Kalibrierungsprozess abzuschließen. Die Ergebnisse von Positions- und Inspektionswerkzeugen werden jetzt in reellen Einheiten angezeigt.
Geschlossen Kreis

Wird verwendet, wenn der Durchmesser eines kreisförmigen Merkmals bekannt ist.

  1. Klicken Sie im Dropdownmenü Kalibrierungstyp auf Kreis.
  2. Klicken Sie auf die Schaltfläche Kreis auswählen. EasyBuilder untersucht das Bild und stellt ein Auswahl von automatisch erkannten Smart Features bereit (zyanfarben hervorgehoben).

  3. Wählen Sie eines der verfügbaren Smart Features per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta.

    Hinweis: Wenn die gewünschten Merkmale nicht automatisch von EasyBuilder gefunden werden, deaktivieren Sie das Kontrollkästchen Smart Features, und platzieren Sie stattdessen den Bereich über dem zu definierenden Merkmal.
  4. Klicken Sie zum Definieren des Merkmals auf OK.
  5. Wählen Sie im Dropdownmenü Maßeinheiten die reellen Einheiten aus (Mikrometer, Millimeter, Zentimeter oder Zoll).
  6. Geben Sie das bekannte reelle Maß in das Feld Abmessung ein.
  7. Klicken Sie auf die Schaltfläche Kalibrieren, um den Kalibrierungsprozess abzuschließen. Die Ergebnisse von Positions- und Inspektionswerkzeugen werden jetzt in reellen Einheiten angezeigt.


9-Punkt-Kalibrierung

Die Kalibrierungsoption "9-Punkt" ist für Robotikanwendungen hilfreich, um den korrekten Koordinatenraum für den Roboter zu erstellen. Diese Kalibrierungsoption basiert auf einem Kreisziel, wie unten dargestellt. Die Kalibrierplatte sollte neun Ziele in gleichem Abstand in einem Rastermuster umfassen. Der horizontale und vertikale Abstand zwischen Zielen sollte vor dem Kalibriervorgang bekannt sein.

Hinweis:
  • Das Ziel in der Mitte der neun Ziele gilt als Ursprung (0,0) im Robotikkoordinatensystem.
  • Der Abstand zwischen horizontalen Zielen muss konsistent und gleich sein. Dasselbe gilt für den Abstand zwischen den vertikalen Zielen. Der Abstand zwischen den horizontalen und vertikalen Zielen muss allerdings nicht gleich sein.
  • Jedes Ziel muss mindestens einen Kreisdurchmesser von 25 Pixeln aufweisen.
Geschlossen Beispiel – Einzelziel

Geschlossen Beispiel – neun Ziele

Hinweis: Die Koordinaten sollten im eigentlichen Bild nicht enthalten sein, sie wurden nur zur Veranschaulichung eingefügt.
Hinweis: Bei der Kalibrierungsoption "9-Punkt" werden Linsenverzerrungen nicht berücksichtigt. Um eine maximale Genauigkeit zu erzielen, sollten Sie daher sicherstellen, dass das In-Sight Vision-System senkrecht zur inspizierten Oberfläche montiert wird.

Nehmen Sie vor Beginn der Kalibrierung ein Bild von der Kalibrierplatte mit den neun Zielen im gleichen Abstand auf.

  1. Wählen Sie im Dropdownmenü Kalibrierungstyp die Option 9-Punkt.

  2. Klicken Sie auf die Schaltfläche Modell bearbeiten, und konfigurieren Sie den Bereich so, dass er das mittlere Ziel einschließt. Klicken Sie anschließend auf die Schaltfläche OK . Lassen Sie beim Konfigurieren des Bereichs um das Ziel herum zwischen dem äußeren Rand des Kreises und dem Bereich mindestens 3 bis 4 leere Pixel Platz. Versuchen Sie außerdem, den Berich so weit wie möglich über dem Ziel zu zentrieren.

    Geschlossen Beispiel

  3. Nach dem Konfigurieren des Modells werden von EasyBuilder automatisch alle Ziele auf dem Bild erkannt und die erkannten Ziele mit einem grünen X markiert.

    Hinweis: Ein rotes X erscheint, wenn die Bildkoordinaten des Ziels erkannt werden, der Kreis um die Bildkoordinaten jedoch nicht erkannt wird. Zur Lösung des Problems trainieren Sie entweder das Modell neu, oder Sie nehmen ein neues Bild auf.
  4. Wählen Sie im Dropdownmenü Maßeinheiten die reellen Einheiten aus (Mikrometer, Millimeter, Zentimeter oder Zoll).
  5. Geben Sie ins Feld X-Dimension das reelle Maß des horizontalen Abstands zwischen zwei Zielen in derselben Zeile ein (gemessen ab der Mitte jedes Ziels).
  6. Geben Sie ins Feld Y-Dimension das reelle Maß des vertikalen Abstands zwischen zwei Zielen in derselben Spalte ein (gemessen ab der Mitte jedes Ziels).
  7. Klicken Sie auf die Schaltfläche Kalibrieren, um den Kalibrierungsprozess abzuschließen. Die Ergebnisse von Positions- und Inspektionswerkzeugen werden jetzt in reellen Einheiten angezeigt.


Rasterkalibrierung

In der Bereitstellungsumgebung zeichnet das In-Sight-Vision-System möglicherweise Bilder auf, die aufgrund von bestimmten Einrichtungsbedingungen (z. B. Linsen- und Perspektivenverzerrungen) Verzerrungen aufweisen. Einige Objektive erzeugen möglicherweise kissen- oder tonnenförmige Verzerrungsmuster, wodurch gerade Linien auf dem Bild gekrümmt dargestellt werden. Perspektivische Verzerrung kann auftreten, wenn das In-Sight-Vision-System nicht senkrecht zum Inspektionsbereich angebracht werden kann. Je nach Position im Gesichtsfeld können in diesen Fällen die Bildmerkmale gestreckt bzw. länglich dargestellt werden, was zu fehlerhaften Ergebnissen führt.

Die Option Rasterkalibrierung erstellt durch die Aufzeichnung eines Rastermusters (Punkte oder Schachbrett) eine Art Karte des Bildbereichs. Diese Option stellt anschließend eine Beziehung zwischen den ermittelten Rastermerkmalen (Punkte oder Schnittstellen der Schachbrettlinien) und den benutzerdefinierten Abständen des Rastermusters her. Dieser Vorgang stellt eine äußerst genaue Berechnungsmethode dar, die zur Korrektur verzerrter Bildmerkmale verwendet werden kann.

Durch die Kalibrierung eines In-Sight-Vision-Systems können die Positionen von Objekten am Bildrand genauer ermittelt werden, und Sie erzielen mehr Flexibilität hinsichtlich der Befestigung. Das In-Sight-Vision-System kann so bis zu 45° zur Inspektionsoberfläche geneigt angebracht werden.

Tipp: Ist für Ihren Anwendungsbedarf die Rasterkalibrierung erforderlich, können Sie das Tool zur Bildumwandlung verwenden, um unverzerrte Ergebnisse anzuzeigen und von anderen Inspektionswerkzeugen Verweise auf die Werkzeugbild-Ausgabe erstellen zu lassen.
  1. Klicken Sie im Dropdownmenü Kalibrierungstyp auf Raster.
  2. Klicken Sie auf die Schaltfläche Kalibrieren. Weitere Informationen finden Sie in der In‑Sight® Explorer-Hilfe.


Importieren eines Kalibrierungstyps

Mit der Funktion zum Importieren eines Kalibrierungstyps kann eine Kalibrierungsdatei geladen werden, die von einem N-Punkt- oder einem sequentiellen N-Punkt-Kalibrierungswerkzeug erstellt und in das lokale Dateisystem des In-Sight-Vision-Systems exportiert wurde. Die importierte Kalibrierungsdatei kalibriert automatisch den aktuellen Job, nachdem dieser geladen wurde.

Hinweis: Bevor Sie als Kalibrierungstyp die Option Importieren auswählen, fügen Sie zunächst ein N-Punkt- oder ein sequentielles N-Punkt-Kalibrierungswerkzeug hinzu, konfigurieren Sie dieses, und exportieren Sie anschließend die Kalibrierungsdatei in das lokale Dateisystem des In-Sight-Vision-Systems.

Die N-Punkt- und sequenziellen N-Punkt-Kalibrierungswerkzeuge erstellen eine 2D-Transformation zur Konvertierung von Pixelkoordinaten in echte Koordinaten. Bei diesem Prozess berücksichtigen die Werkzeuge lineare und nicht lineare Verzerrung und bieten bei der Verwendung von fünf oder mehr Punktpaaren eine höhere Genauigkeit als die Kalibrierungsmethoden X/Y-Skalierung, Kante zu Kante, Kante zu Kante (X/Y) oder Kreis. Folgende Transformationen werden vom Tool ausgeführt:

  • Verschiebung in zwei Richtungen (mit mindestens 2 Punktpaaren)
  • Drehung um drei Achsen (mit mindestens vier Punktpaaren)
  • Skalierung in zwei Richtungen (mit mindestens zwei Punktpaaren)
  • Verzerrung der Perspektive (mit mindestens vier Punktpaaren)
  • Parallelogramm oder Krümmung (mit mindestens vier Punktpaaren)
Geschlossen Importieren
  1. Klicken Sie im Dropdownmenü Kalibrierungstyp auf Importieren.
  2. EasyBuilder sucht im Job automatisch nach Kalibrierungsdateien, die von einem N-Punkt- oder einem sequenziellen N-Punkt-Kalibrierungswerkzeug erstellt wurden, und lädt die Kalibrierungsdatei. Sind mehrere Kalibrierungsdateien vorhanden, wählen Sie die gewünschte Datei im Dropdownmenü Dateiname aus.
  3. Wählen Sie im Dropdownmenü Maßeinheiten die reellen Einheiten zur Definition der Kalibrierung aus: Mikrometer, Millimeter (Standard), Zentimeter oder Zoll.
  4. Die Kalibrierung wird angewendet, sobald die Option ausgewählt und die Werte konfiguriert wurden.


Teil suchen

Die Positionswerkzeuge dienen zum Festlegen eines Merkmals im Bild, das Positionsdaten aufweist. Mit den Positionswerkzeugen wird eine Vorrichtung für die schnelle und zuverlässige Ermittlung eines Bildteils erstellt. Dies gilt auch für zu inspizierende Teile, die sich drehen oder an verschiedenen Positionen im Bild erscheinen. Weitere Informationen finden Sie unter Vorrichtung.

Hinweis:
  • Sind für den Job keine Positionsdaten erforderlich oder wird dem In-Sight-Sensor die Komponente in jedem Bild an derselben Position angezeigt, erhalten Sie weitere Informationen unter Teil inspizieren.
  • Mit den Vision-Sensoren In-Sight 2000-110 und 120/120C kann nur eine Vorrichtung zu einem Job hinzugefügt werden.
  • Auf den Vision-Sensoren der In-Sight 2000-Serie wird die Registerkarte „Links“ nicht unterstützt.

Die Positionswerkzeuge berichten die folgenden Ergebnisse:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren In-Sight 2000-110 und 2000-120/120C | Nur bei Bestanden/Nicht bestanden-Status.
Vision-Sensor In-Sight 2000-130/130C | Positionswerkzeug „Muster“: Gut/Schlecht-Status und Mustergüte Andere Positionswerkzeuge: Nur bei Bestanden/Nicht bestanden-Status.
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | Standardergebnisse (Positionsdaten und „Bestanden/Nicht bestanden“-Status). Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.

Hinzufügen, Löschen und Bearbeiten von Positionswerkzeugen

Auswählen eines Positionswerkzeugs

Erstellen von Links zwischen Positions- und Inspektionswerkzeugen


Hinzufügen, Löschen und Bearbeiten von Positionswerkzeugen

Geschlossen Hinzufügen eines Werkzeugs

Wählen Sie zum Hinzufügen eines Werkzeugs zu einem Job in der Gruppe Werkzeug hinzufügen ein geeignetes Werkzeug aus, und klicken Sie auf die Schaltfläche Hinzufügen. Doppelklicken Sie alternativ auf das Werkzeug. Sie werden dann zum Festlegen des Merkmals im Bild aufgefordert, entweder über die EasyBuilder-Optionen unter Smart Features, durch Anpassen des Bereichsdiagramms im Bild oder durch Positionieren geometrischer Referenzgrafiken.

Nach der erstmaligen Festlegung des Merkmals können Sie die Steuerelemente des Werkzeugs durch Anpassung der verschiedenen Parameter optimieren.

Hinweis: Sie können mithilfe des Suchfelds dynamisch nach den Werkzeugen suchen.
Geschlossen Löschen eines Werkzeugs

Gehen Sie zum Löschen eines Werkzeugs aus einem Job wie folgt vor:

  • Wählen Sie das Werkzeug auf der Registerkarte Ergebnisse der Palette in der Tabelle Ergebnisse aus und drücken Sie die Taste Entf.
  • Wählen Sie das Werkzeug auf der Registerkarte Ergebnisse der Palette in der Tabelle Ergebnisse aus und klicken Sie auf das Symbol Löschen in der Symbolleiste Standard.
  • Wählen Sie das Werkzeug auf der Registerkarte Ergebnisse der Palette in der Tabelle Ergebnisse aus und wählen Sie im Menü die Option Löschen aus.
Geschlossen Bearbeiten eines Werkzeugs

Gehen Sie zum Bearbeiten eines Werkzeugs in einem beliebigen EasyBuilder-Schritt wie folgt vor:

  • Doppelklicken Sie auf das Werkzeug in der Tabelle Ergebnisse. Diese Tabelle befindet sich auf der Registerkarte Ergebnisse der Palette.
  • Klicken Sie mit der rechten Maustaste in der Tabelle Ergebnisse auf das Werkzeug, und wählen Sie im Menü die Option zum Aufrufen und Bearbeiten des gewünschten Werkzeugs aus.

Gehen Sie zum Bearbeiten eines Werkzeugs in den Schritten Teil suchen oder Teil inspizieren wie folgt vor:

  • Wählen Sie das Bereichsdiagramm im Bild aus.
  • Doppelklicken Sie auf das Werkzeug in der Tabelle Ergebnisse. Diese Tabelle befindet sich auf der Registerkarte Ergebnisse der Palette.
  • Klicken Sie mit der rechten Maustaste in der Tabelle Ergebnisse auf das Werkzeug, und wählen Sie im Menü die Option zum Aufrufen und Bearbeiten des gewünschten Werkzeugs aus.
  • Doppelklicken Sie in der Ergebnistabelle im Anwendungsschritt Job ausführen auf das Werkzeug.
Hinweis:
  • Falls Ihr In-Sight-Vision-System das Aufrufen der Tabellenansicht-Programmierumgebung von In-Sight Explorer unterstützt, wird im Kontextmenü (Rechtsklick) die Option Dieses Werkzeug in der Tabellenansicht aufrufen angezeigt. Die Verwendung der Tabellenansicht-Programmierumgebung wird nur empfohlen, wenn Sie mit dieser Umgebung vertraut sind und ihre Funktionsweise verstehen. Lesen Sie die entsprechenden Informationen in der Online-Hilfe zu In-Sight Explorer sorgfältig durch, bevor Sie fortfahren.
  • Ordnen Sie die Werkzeuge in der Tabelle Ergebnisse neu, indem Sie sie mittels Drag&Drop in die gewünschte Reihenfolge bringen. Das Neuordnen ist in der Tabelle mit den Ergebnissen zu Job ausführen und in der Tabelle mit den Palettenergebnissen möglich und wird in beiden Tabellen übernommen. Das Sortieren mittels Drag&Drop ist nur aktiviert, wenn die Spalte Werkzeugabhängigkeitsgrafiken ausgewählt ist (diese Spalte ist standardmäßig ausgewählt). Wählen Sie die Spalte ein zweites Mal aus, um die Reihenfolge umzukehren. Das Neuordnen ist nicht möglich, wenn der Job nahe am Jobumfanglimit liegt.
Hinweis: Verfügt der Job nicht über genug Platz, um weitere Werkzeuge hinzuzufügen, behalten Sie die Anwendungsschritte Suchen oder Teil inspizieren bei, und wählen Sie im Menü Sensor die Option Jobumfanglimit. Passen Sie im Dialogfeld den Jobumfang an, um weitere Werkzeuge hinzufügen zu können. Das Anpassen des Jobumfanglimits eines In-Sight-Vision-Systems erfordert das Aus- und Einschalten des Vision-Systems, wodurch alle Job- und Einstellungsdateien aus dem nichtflüchtigen Flash-Speicher gelöscht werden. Speichern bzw. sichern Sie den Job, und fahren Sie anschließend fort.

Merkmale

Regionen

Vorrichtung


Merkmale

Im Bereich "Vision" werden Merkmale auch als "Analyseobjekte eines Bildes" bezeichnet. Zudem sind Vision-Inspektionen auf die in einem Bild gefundenen Merkmalstypen ausgerichtet.

Zu den Merkmalstypen im Schritt Teil suchen gehören:

Geschlossen Kanten

Hierbei handelt es sich um lineare Bereiche bei Übergängen zwischen hellen und dunklen Pixeln. Kanten können Elemente wie die Enden von Teilen, Pins einer Platine oder das Gewinde einer Schraube sein. Kanten gehören zu den Merkmalstypen, die während einer Inspektion schneller erkannt werden. Dienen sie jedoch als Vorrichtung, sollten sie sich nur in eine Richtung bewegen (horizontal oder vertikal) und einen hohen Kontrast aufweisen.

Geschlossen Beispiel für Vorrichtung "Kante"

In diesem Beispiel erscheinen die Lufterfrischerapplikatoren in den einzelnen Bildern nicht an der gleichen Position. Sie werden zwar in der gleichen senkrechten Ebene, aber waagerecht verschoben angezeigt. Als Vorrichtungen werden zwei Positionswerkzeuge für Kanten verwendet. Das Werkzeug auf der linken Seite ermittelt die äußere Kante des unteren Gehäuses des Applikators und richtet die Bereiche der anderen Inspektionswerkzeuge auf der linken Seite aus. Das andere Werkzeug richtet dagegen die Werkzeuge auf der rechten Seite aus.

Geschlossen Kreise

Kreise sind im Wesentlichen Kanten – Bereiche, die durch einen Übergang zwischen hellen und dunklen Pixeln, der die geometrische Form bestimmt, festgelegt werden. Sie gehören ebenfalls zu den Merkmalstypen, die schneller erkannt werden, sofern sie einen hohen Kontrast aufweisen. Kreise verfügen jedoch über keine Winkeldaten, wenn sie als Vorrichtung verwendet werden.

Geschlossen Beispiel für Vorrichtung "Kreis"

In diesem Beispiel werden zwei Vorrichtungen verwendet. Die erste Vorrichtung, ein Werkzeug für Blobpositionen, ermittelt das Äußere des Rohrs, während die zweite Vorrichtung, ein Werkzeug für Kreispositionen, die grundlegende kreisförmige Form des Rohrs im gefundenen Blob ermittelt. Aufgrund der Anforderungen der Anwendung wird die Länge der Schrauben ermittelt, indem ihr Abstand zu einem Punkt relativ zu einer gefundenen Form ermittelt wird, die gleichmäßig sein muss.

Geschlossen Muster

Muster können aus einer einfachen Gruppe aus sich wiederholenden Formen bis hin zu komplexen Konfigurationen wie Logos oder Beschriftungen bestehen. Muster sind der zuverlässigste Merkmalstyp bei Verwendung als Vorrichtung und bieten die größte Flexibilität bei Drehungen, Bewegungen und Skalierungsunterschieden. Die Inspektion von Mustern dauert jedoch im Allgemeinen am längsten.

Geschlossen Beispiel für Vorrichtung "Muster"

In diesem Beispiel erscheint der 2D-Code in jedem Bild an verschiedenen Positionen und in unterschiedlichen Ausrichtungen. Ein Werkzeug für PatMax-Musterpositionen wird verwendet, um eine Vorrichtung zu erstellen und die Suche des Identifizierungswerkzeugs "ID-Codes lesen" auszurichten. Das Werkzeug für PatMax-Musterpositionen wird verwendet, da es komplizierte Muster ermitteln kann und eine große Vielzahl von Positionen, Ausrichtungen und Skalierungen handhaben kann.

Geschlossen Blobs

Blobs bestehen aus einer Gruppe aus dunklen bzw. hellen und zusammenhängenden Pixeln, beispielsweise einem Klecks weißer Farbe auf einem schwarzen Hintergrund oder einer schwarzen Schraube auf einem weißen Fließband. Blobs liegen in Bezug auf die Schnelligkeit bei der Erkennung zwischen Kanten und Mustern. Zudem ermöglichen Blobs mehr Variationen der Form und Größe von Blobmerkmalen im Vergleich zu einem Muster. Sie weisen jedoch bei Verwendung als Vorrichtung beschränkte Winkeldaten auf.

Geschlossen Beispiel für Vorrichtung "Blob"

In diesem Beispiel werden zwei Vorrichtungen verwendet, da die zu inspizierenden Merkmale (die Schrauben) sich in einem Objekt (dem Rohr) befinden, dessen Ausrichtung und senkrechte und waagerechte Position sich von Bild zu Bild unterscheiden kann. Die Flansche des Rohrs haben eine unregelmäßige Form, sodass ein Werkzeug für Blobpositionen zum Erstellen einer Vorrichtung verwendet wird, die das Rohr im Sichtfeld ermittelt.


Bereiche

Bereiche definieren einen Bereich des Bildes, in dem das Positionswerkzeug oder Inspektionswerkzeug einen entsprechenden Vorgang ausführt. Dieser Bereich wird auch "relevanter Bereich" genannt.

In EasyBuilder werden abhängig vom verwendeten Werkzeugtyp (Positionswerkzeug und Inspektionswerkzeug) verschiedene Bereichstypen verwendet. EasyBuilder verwendet die folgenden Bereichstypen:

  • Rechteck
  • Kreis
  • Annulus
  • Polygon

Ringförmige Bereiche

Kreisförmige Bereiche

Polygonförmige Bereiche

Rechteckige Bereiche


Ringförmige Bereiche

Ringförmige Bereiche werden zum Definieren kreisförmiger Kantenmerkmale verwendet. Der ringförmige Bereich besitzt einen inneren und einen äußeren Radius und ermöglicht das Definieren eines kreisförmigen Kantenmerkmals mit ignorierter Kreismitte.

Geschlossen Ringförmiger Bereich – Mausaktionen

 | Steuerelemente | Beschreibung
1 | Bewegen | Durch Platzieren des Mauszeigers zwischen dem inneren und äußeren Radius wird der Mauszeiger automatisch umgewandelt, wodurch der Bereich an eine beliebige Stelle im Bild gezogen werden kann.
2 | Größe ändern | Durch Platzieren des Mauszeigers über dem inneren oder äußeren Radius des ringförmigen Bereichs wird der Mauszeiger automatisch umgewandelt, wodurch der innere bzw. der äußere Radius vergrößert bzw. verkleinert werden kann (die Größe des inneren und äußeren Radius muss unabhängig voneinander angepasst werden).
Geschlossen Ringförmiger Bereich – Scanrichtung

Ringförmige Bereiche suchen vom inneren zum äußeren Radius nach Kreismerkmalen.

Geschlossen Ringförmiger Bereich – Farbcodes

 | Beschreibung
1 | Ein neu hinzugefügter, nicht ausgewählter ringförmiger Bereich.
2 | Ein ausgewählter, nicht bestätigter ringförmiger Bereich.
3 | Ein ausgewählter, konfigurierter ringförmiger Bereich, der die Überprüfung bestanden hat.
4 | Ein nicht ausgewählter, konfigurierter ringförmiger Bereich, der die Überprüfung bestanden hat.
5 | Ein ausgewählter, konfigurierter, fehlerhafter ringförmiger Bereich.
6 | Ein nicht ausgewählter, konfigurierter, fehlerhafter ringförmiger Bereich.


Kreisförmige Bereiche

Kreisförmige Bereiche werden zum Definieren kreisförmiger Merkmale verwendet. Der kreisförmige Bereich erfasst alles im Kreis. Verwenden Sie einen ringförmigen Bereich, um ein kreisförmiges Merkmal mit ignorierter Kreismitte zu definieren.

Geschlossen Kreisförmiger Bereich – Mausaktionen

 | Steuerelemente | Beschreibung
1 | Bewegen | Durch Platzieren des Mauszeigers innerhalb des Bereichs wird der Mauszeiger automatisch umgewandelt, wodurch der Bereich an eine beliebige Stelle im Bild gezogen werden kann.
2 | Größe ändern | Durch Platzieren des Mauszeigers über den Grenzen des kreisförmigen Bereichs wird der Mauszeiger automatisch umgewandelt, wodurch der Bereich beliebig vergrößert oder verkleinert werden kann.
Geschlossen Kreisförmiger Bereich – Scanrichtung

Kreisförmige Bereiche suchen von der Kreismitte in Richtung Außenradius nach Merkmalen.

Geschlossen Kreisförmiger Bereich – Farbcodes

 | Beschreibung
1 | Ein neu hinzugefügter, nicht ausgewählter kreisförmiger Bereich.
2 | Ein ausgewählter, nicht bestätigter kreisförmiger Bereich.
3 | Ein ausgewählter, konfigurierter kreisförmiger Bereich, der die Überprüfung bestanden hat.
4 | Ein nicht ausgewählter, konfigurierter kreisförmiger Bereich, der die Überprüfung bestanden hat.
5 | Ein ausgewählter, konfigurierter, fehlerhafter kreisförmiger Bereich.
6 | Ein nicht ausgewählter, konfigurierter, fehlerhafter kreisförmiger Bereich.


Polygonförmige Bereiche

Polygonbereiche werden zum Definieren unregelmäßiger Merkmale verwendet, indem aus Liniensegmenten eine Form gebildet wird. Konfigurieren Sie den Polygonbereich in der gewünschten Form.

Geschlossen Polygonförmiger Bereich – Legende

 | Steuerelemente | Beschreibung
1 | In der Größe veränderbare Endpunktbegrenzung | Definiert die ursprünglichen drei Endpunkte des Polygonbereichs (für einen Polygonbereich können bis zu 100 Punkte erstellt werden). Klicken Sie auf eine Endpunktbegrenzung, um die Größe des Bereichs von einer Ecke aus anzupassen.
2 | Rotationsziehgriff | Ermöglicht das Drehen des Bereichs um 360°.
Geschlossen Polygonförmiger Bereich – Mausaktionen

Durch Platzieren des Mauszeigers über verschiedenen Teilen des Bereichs wird der Mauszeiger automatisch umgewandelt, um die folgenden Aktionen zu ermöglichen:

Mauszeigersymbol | Beschreibung
 | Ermöglicht das Ziehen des gesamten Polygonbereichs an eine beliebige Stelle im Bild.
 | Ermöglicht das Skalieren des gesamten Bereichs in horizontaler oder vertikaler Richtung.
 | Ermöglicht eine 360°-Drehung des gesamten Bereichs ab der aktuellen Ausrichtung.
 | Ermöglicht das Verschieben eines der in der Größe veränderbaren Endpunktbegrenzungspunkte des Polygonbereichs.
 | Ermöglicht das Hinzufügen eines in der Größe veränderbaren Endpunktbegrenzungspunkts zum Polygonbereich.
Geschlossen Polygonförmiger Bereich – Scanrichtung

 | Steuerelemente | Beschreibung
1 | Oben | Zeigt die Scanrichtung in horizontaler Richtung an.
2 | Seite | Zeigt die Scanrichtung in vertikaler Richtung an.
Geschlossen Polygonförmiger Bereich – Farbcodes

 | Beschreibung
1 | Ein neu hinzugefügter, nicht ausgewählter polygonförmiger Bereich.
2 | Ein ausgewählter, nicht bestätigter polygonförmiger Bereich.
3 | Ein ausgewählter, konfigurierter polygonförmiger Bereich, der die Überprüfung bestanden hat.
4 | Ein nicht ausgewählter, konfigurierter polygonförmiger Bereich, der die Überprüfung bestanden hat.
5 | Ein ausgewählter, konfigurierter, fehlerhafter polygonförmiger Bereich.
6 | Ein nicht ausgewählter, konfigurierter, fehlerhafter polygonförmiger Bereich.


Rechteckige Bereiche

Rechteckige Bereiche sind die gebräuchlichste Methode zum Definieren einer Inspektion. Sie können durch Verändern der Größe in Bogensegmente oder ringförmige Bereiche umgewandelt werden, um den Anforderungen der speziellen Anwendung besser gerecht zu werden.

Geschlossen Rechteckiger Bereich – Legende

 | Steuerelemente | Beschreibung
1 | Größenveränderliche Endpunktbegrenzung (x4) | Definiert die vier Ecken des rechteckigen Bereichs. Klicken Sie auf eine Endpunktbegrenzung, um den Bereich von einer Ecke aus größenmäßig anzupassen.
2 | Scanrichtungsanzeige (x2) | Definiert, welche Richtung des rechteckigen Bereichs nach Merkmalen durchsucht wird.
3 | Krümmungsziehpunkt | Ermöglicht die bogen- oder kreisförmige Krümmung des rechteckigen Bereichs.
4 | Rotationsziehgriff | Ermöglicht die Rotation des Bereichs um 360°.
Geschlossen Rechteckiger Bereich – Mausaktionen

 | Steuerelemente | Beschreibung
1 | Bewegen | Durch Platzieren des Mauszeigers innerhalb des Bereichs wird der Mauszeiger automatisch umgewandelt, wodurch der Bereich an eine beliebige Stelle im Bild gezogen werden kann.
2 | Krümmung | Durch Platzieren des Mauszeigers auf dem Krümmungsziehpunkt wird der Mauszeiger automatisch umgewandelt, wodurch die Form des rechteckigen Bereichs bogen- oder ringförmig angepasst werden kann. Die vier Seiten der Form können dann beispielsweise in eine Kreisform gebracht werden.
3 | Größe ändern | Durch Platzieren des Mauszeigers über eine der vier Endpunktgrenzen oder entlang einer der vier Seiten wird der Mauszeiger automatisch umgewandelt, wodurch der Bereich beliebig vergrößert oder verkleinert werden kann.
4 | Drehen | Durch Platzieren des Mauszeigers auf dem Rotationsziehgriff, wird der Mauszeiger automatisch umgewandelt, wodurch der Bereich relativ zu seiner aktuellen Ausrichtung 360° rotiert werden kann.
Geschlossen Rechteckiger Bereich – Scanrichtung

 | Steuerelemente | Beschreibung
1 | Oben | Zeigt die Scanrichtung in horizontaler Richtung an.
2 | Seite | Zeigt die Scanrichtung in vertikaler Richtung an.
Geschlossen Rechteckiger Bereich – Farbcodes

 | Beschreibung
1 | Ein neu hinzugefügter, nicht ausgewählter rechteckiger Bereich.
2 | Ein ausgewählter, nicht bestätigter rechteckiger Bereich.
3 | Ein ausgewählter, konfigurierter rechteckiger Bereich, der die Überprüfung bestanden hat.
4 | Ein nicht ausgewählter, konfigurierter rechteckiger Bereich, der die Überprüfung bestanden hat.
5 | Ein ausgewählter, konfigurierter, fehlerhafter rechteckiger Bereich.
6 | Ein nicht ausgewählter, konfigurierter, fehlerhafter rechteckiger Bereich.


Vorrichtung

Mit den Positionswerkzeugen im Schritt Teil suchen wird eine Ausgabe erstellt, die Vorrichtung genannt wird. Diese dient als Referenzpunkt für andere Vision-Inspektionswerkzeuge.

Sehen Sie sich bei der Erstellung einer Vorrichtung die Komponente im Bild an und ermitteln Sie, welcher Merkmalstyp – ein Muster, eine Kante, ein Kreis oder ein Blob – am schnellsten und einfachsten zu erkennen und in jedem Bild der Komponente zu sehen ist. Wählen Sie anschließend auf Basis des Merkmalstyps Ihrer Komponente ein geeignetes Positionswerkzeug aus, um das Merkmal zu definieren.

Dient ein Merkmal während einer Inspektion als Vorrichtung, sucht der In-Sight-Sensor zunächst nach dem Merkmal. Wurde das Merkmal gefunden, dient die Merkmalsposition als Referenzpunkt für die anderen Vision-Inspektionswerkzeuge. Diese verwenden die Merkmalsposition zur Ausrichtung der zugehörigen Bereiche.

Geschlossen Beispiel – Job mit Mustervorrichtung

Geschlossen Beispiel – Job ohne Vorrichtung

Hinweis:
  • Eine Vorrichtung ist nicht erforderlich, wenn die Komponente dem In-Sight-Sensor in jedem Bild an derselben Position angezeigt wird.
  • Mehrere Vorrichtungen können in einem Job erstellt und verwendet werden. Zudem lassen sich Vorrichtungen verknüpfen.
  • Die folgenden Inspektionswerkzeuge produzieren eine Vorrichtungsausgabe, die von anderen Werkzeugen verwendet werden kann: An-/Abwesenheitswerkzeug „Kante“, An-/Abwesenheitswerkzeug „PatMax-Muster“, An-/Abwesenheitswerkzeug „PatMax-Muster“, Identifizierungswerkzeug „ID-Codes lesen“, Identifizierungswerkzeug „PatMax-Muster“, Identifizierungswerkzeug „Muster“, Messungswerkzeug „Winkel“, Messungswerkzeug „Abstand“, Messungswerkzeug „Kreiskonzentrizität“, Messungswerkzeug „Kreisdurchmesser“, Geometriewerkzeug „Punkt-zum-Punkt-Mittelpunkt“ und Geometriewerkzeug „Kreis aus N Punkten“.


Auswählen eines Positionswerkzeugs

Analysieren Sie die Komponente und ermitteln Sie, welcher Typ von Merkmalen die Anforderungen Ihrer Anwendung erfüllt.

Positionswerkzeuge | In-Sight Vision-Systeme (Firmware 5.x.x) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
PatMax RedLine-Muster 1 | X |  |  |  |  |
PatMax®-Muster | X |  |  |  |  |
Muster | X | X | X | X | X | X
PatMax RedLine™-Muster (1-10) 1 | X |  |  |  |  |
PatMax®-Muster (1-10) | X |  |  |  |  |
Muster (1-10) | X |  |  |  | X |
Kante | X |  |  | X | X | X
Kantenschnittpunkt | X |  |  | X | X | X
Blob 2 | X |  |  |  | X |
Blobs (1-10) 2 | X |  |  |  | X |
Farb-Blob 3 | X |  |  |  | X |
Farb-Blobs (1-10) 3 | X |  |  |  | X |
Kreis | X |  |  | X | X | X
Vorrichtung berechnen | X |  |  |  |  | X
1 Nur In-Sight-Firmware 5.x.x. 2Nur Monochrom-Modelle. 3Nur Farbmodelle.

PatMax RedLine-Muster, PatMax-Muster, PatMax RedLine-Muster (1-10) und PatMax-Muster (1-10)

Muster und Muster (1-10)

Kante

Kantenschnittpunkt

Blob und Blobs (1-10)

Farb-Blob und Farb-Blobs (1-10)

Circle

Vorrichtung berechnen


Positionswerkzeuge: PatMax RedLine-Muster, PatMax-Muster, PatMax RedLine-Muster (1-10) und PatMax-Muster (1-10)

Hinweis:
  • Ab der In-Sight-Firmwareversion 5.5.0 oder höher wurde der Algorithmus des Werkzeugs geändert. Es gibt jetzt genauere Ergebnisse zurück und verringert in einigen Fällen die Ausführungszeit.
  • Aufgrund dieser Änderung wird bei dem Versuch, einen Job, der mit der In-Sight-Firmwareversion 5.5.0 oder höher konfiguriert wurde, in ein In-Sight Vision-System zu laden, das die Firmwareversion 5.4.x oder früher ausführt, eine Fehlermeldung angezeigt.
  • Die Positionswerkzeuge PatMax RedLine-Muster und PatMax RedLine-Muster (1-10) ist nur auf In-Sight Vision-Systemen mit In-Sight-Firmware 5.2.0 und höher verfügbar. Eine komplette Modelliste mit unterstützten Firmwareversionen finden Sie im Abschnitt Firmwareversionen.

Die Positionswerkzeuge PatMax RedLine-Muster, PatMax-Muster, PatMax RedLine-Muster (1-10) und PatMax-Muster (1-10) werden verwendet, um die Postion von Mustermerkmalen zu bestimmen. Dafür wird der PatMax RedLine- oder PatMax-Algorithmus verwendet, basierend auf einer eingelernten Darstellung dieses Musters (als Modell bezeichnet). Die Werkzeuge PatMax RedLine-Muster und PatMax-Muster werden verwendet, um nach einem einzelnen Muster zu suchen, während mit den Werkzeugen PatMax RedLine-Muster (1-10) und PatMax-Muster (1-10) bis zu 10 Muster gesucht werden können.

Hinweis: Das Werkzeug gibt die X- und Y-Koordinaten in Pixeln an, sofern das Bild nicht in reellen Einheiten im Schritt Bild einrichten kalibriert wurde.

Diese Werkzeuge sind nützlich in Anwendungen, bei denen genaue Positionierungen erforderlich sind, wie visuell gesteuerten Roboteranwendungen. Diese Werkzeuge eignen sich zudem sehr gut als Vorrichtung für andere Vision-Werkzeuge, da die Suche im Bild orientiert wird.

Einrichtung der Werkzeuge

Anpassen der Werkzeugparameter


Einrichten der Positionswerkzeuge "PatMax RedLine-Muster", "PatMax-Muster", "PatMax RedLine-Muster (1-10)" und "PatMax-Muster (1-10)" einrichten

Wählen Sie nach dem Hinzufügen des Werkzeugs die Bereichstypen aus und konfigurieren Sie sie, um das Muster zu definieren (den Modellbereich) und den Bereich im Bild festzulegen, an der das Muster gefunden wird (den Suchbereich).

  1. Wählen Sie im Dropdown-Menü Modell den Bereichstypaus: Rechteck (Standard), Kreis, Annulus oder Polygon. Platzieren Sie den Modellbereich über dem Muster, das als Trainingsmodell dient. Stellen Sie sicher, dass der Modellbereich nur die wichtigen Merkmale des Musters abdeckt.Hinweis:Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Wählen Sie im Dropdownmenü Suchen den Bereichstyp "Rechteck" (Standard), "Kreis", "Annulus" oder "Polygon". Platzieren Sie anschließend den Suchbereich so, dass er die Bereiche im Bild abdeckt, in denen das Muster Ihrer Meinung nach erscheint. Erstellen Sie kleinere Suchbereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Suchbereich ist, desto länger dauert die Inspektion mit dem Werkzeug.

  3. Klicken Sie auf OK, um die Bereiche zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  4. Der Modellbereich wird durch das Symbol [image] ersetzt. Dies gibt die Position und Winkelausrichtung des gefundenen Musters an.
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

Auswählen eines Mustermerkmals

PatMax RedLine-Muster, PatMax-Muster und Muster


Auswählen eines Mustermerkmals

Beachten Sie bei der Auswahl eines Musters für eine Inspektion die folgenden Kriterien, um die besten Ergebnisse zu erzielen:

  • Das Muster ist in jedem Bild durchweg präsent.
  • Das Muster besteht aus möglichst vielen eindeutigen und gleichmäßigen Merkmalen. Zudem sind die Merkmale, aus denen das Muster besteht, klar definiert und weisen eine gleichmäßige Darstellung und relative Geometrie auf.
  • Wählen Sie - sofern möglich - ein größeres Muster aus. Größere Muster beinhalten mehr eindeutige Merkmale. Dies ermöglicht eine gleichmäßigere und genauere Erkennung.


PatMax RedLine-Muster und PatMax-Muster und Muster

Hinweis: Die Positionswerkzeuge PatMax RedLine-Muster und PatMax RedLine-Muster (1-10) ist nur auf In-Sight Vision-Systemen mit In-Sight-Firmware 5.2.0 und höher verfügbar. Eine komplette Modelliste mit unterstützten Firmwareversionen finden Sie im Abschnitt Firmwareversionen.

Die Werkzeuge PatMax RedLine-Muster, PatMax-Muster und Muster suchen nach eingelernten Modellmustern und bieten die höchste Genauigkeit im Vergleich zu anderen Inspektionswerkzeugen. Die Werkzeuge PatMax RedLine-Muster und PatMax-Muster sind jedoch leistungsstärker als das Werkzeug Muster. Sie können stärkere Änderungen der Lichtverhältnisse und der Musterposition berücksichtigen . Zudem bieten sie eine genauere Erkennung von Änderungen im Hinblick auf die Musterskalierung, Musterdrehung, Verdeckung von Musterelementen sowie Änderungen der Musterdarstellung in Abhängigkeit von Lichtverhältnissen.

Der Hauptunterschied zwischen PatMax RedLine-Muster und PatMax-Muster liegt in der Geschwindigkeit. PatMax RedLine-Muster verwendet den neuesten Muster-Übereinstimmungsalgorithmus und kann in einem 5-Megapixel Bild eingelernte Merkmale bis zu 7x schneller als PatMax-Muster finden. Deshalb ist PatMax RedLine-Muster die ideale Wahl für Vision-Systeme mit hoher Auflösung.

Das Werkzeug Muster ist in den meisten Fällen schneller als PatMax. Jedoch spielen in folgenden Situationen die Genauigkeit und Zuverlässigkeit der PatMax RedLine- und PatMax-Version eine wesentliche Rolle:

  • Änderungen von Lichtverhältnissen und Reflektionen sind schwer zu kontrollieren. Beispielsweise können Metallteile Licht in zufälligen Richtungen reflektieren.
  • Das zu inspizierende Muster ist ähnlich geformt oder schattiert wie ein Hintergrundelement oder das Muster überschneidet sich mit Bildobjekten bzw. wird teilweise von diesen verdeckt.
  • Sie möchten einen Mustertyp von anderen, ähnlichen Mustern genau differenzieren.
  • Die Bedingungen der Bereitstellungsumgebung sind zu komplex für das Werkzeug Muster, um gleichmäßige und zuverlässige Ergebnisse zu erzielen.


Anpassen der Parameter der Positionswerkzeuge "PatMax RedLine-Muster", "PatMax-Muster", "PatMax RedLine-Muster (1-10)" und "PatMax-Muster (1-10)"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster der Positionswerkzeuge PatMax RedLine-Muster, PatMax-Muster, PatMax RedLine-Muster (1-10) und PatMax-Muster (1-10) beinhaltet die folgenden Registerkarten.

  • Registerkarte Allgemein
  • Registerkarte Einstellungen
  • Registerkarten Modell und Suchen
  • Registerkarte Trainiertes Bild
  • Registerkarte Tabelle
Hinweis: Die Registerkarte Tabelle ist nur für die Positionswerkzeuge PatMax RedLine-Muster (1-10) und PatMax-Muster (1-10) aktiviert.
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarten „Modell“ und „Suchen“

Registerkarte „Trainiertes Bild“

Registerkarte „Tabelle“


Positionswerkzeuge „PatMax RedLine-Muster“, „PatMax-Muster“, „PatMax RedLine-Muster (1-10)“ und „PatMax-Muster (1-10)“ - Registerkarte „Allgemein“

Geschlossen Werkzeugname

Definiert den Namen des Inspektionswerkzeugs, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Pattern_1“, sofern es sich um das erste Musterwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Pattern_2“, „Pattern_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Positionswerkzeuge "PatMax RedLine-Muster", "PatMax-Muster", "PatMax RedLine-Muster (1-10)" und "PatMax-Muster (1-10)" - Registerkarte "Einstellungen"

Geschlossen Anzahl

Gibt die Anzahl der zu erkennenden Instanzen des Musters Modell an (0 - 10; Standard = 1). Bei den meisten Anwendungen ist nur eine Vorrichtung erforderlich. Es können jedoch mehrere Instanzen des Musters Modell ermittelt werden. Dies ist bei Anwendungen mit mehreren Teilen oder Objekten in einem Bild hilfreich. Je mehr eingelernte Instanzen das Werkzeug erkennen soll, desto länger dauert die Ausführung des Werkzeugs.

Geschlossen Akzeptanzschwellenwert

Gibt den Übereinstimmungsgrad an, der zwischen dem Muster Modell und dem gefundenen Muster vorhanden sein muss (0 - 100; Standard = 50). Liegen die Werte der gefundenen Muster über der Einstellung bzw. entsprechen sie dieser, liegt eine Übereinstimmung vor. Dieses Werkzeug lässt sich mit einer höheren Einstellung schneller ausführen. Dies erfordert ebenfalls einen höheren Übereinstimmungsgrad zwischen dem Modell und dem gefundenen Muster. Niedrigere Einstellungen beinhalten eine höhere Wahrscheinlichkeit für ungenauere Ergebnisse, beispielsweise die Erkennung von Mustern, die dem Muster Modell ähneln, diesem jedoch nicht entsprechen.

Geschlossen Kontrastschwellenwert

Definiert den geringsten akzeptablen Kontrastwert, den das gefundene Muster aufweisen muss. Der Kontrast des gefundenen Musters muss höher als der Wert für den Kontrastschwellenwert sein, um als gültige Instanz zu gelten. Der Standardwert liegt bei PatMax RedLine-Muster bei 0 und der gültige Parameterbereich liegt zwischen 0-100. Der Standardwert liegt bei PatMax-Muster bei 10 und der gültige Parameterbereich liegt zwischen 0-255. Ein niedriger Kontrastschwellenwert wird für Bilder mit einem niedrigen Kontrast verwendet, während ein hoher Kontrastschwellenwert für Bilder mit hohem Kontrast verwendet wird.

Hinweis: PatMax RedLine-Muster kontrastiert das "relative" Maß von Kontrast zwischen Merkmalen im eingelernten Muster im trainierten Bild prozentuell mit den Übereinstimmungsmerkmalen im Suchbild. Wenn ein Merkmal einen ähnlich hohen Kontrast wie der Kontrast des Musters aufweist, wird der berichtete Kontrastwert deswegen ungefähr bei 100 liegen. Wenn ein Merkmal einen geringeren Kontrast hat, als der Kontrast des Musters, wird der berichtete Kontrastwert kleiner als 100 sein. Kontrast bei PatMax RedLine-Muster ist anders interpretiert als Kontrast bei PatMax-Muster, wo er den "absoluten" Bildkontrast des Suchbereiches in Graustufen ausdrückt.
Geschlossen Winkeltoleranz

Gibt an, wie weit das gefundene Muster von der Position des Musters "Modell" entfernt sein und dennoch als gültiges Muster erkannt werden kann (± 0 - 180°; Standard = 15°). Bei einem größeren Bereich für die Rotationsabweichung des Musters verlängert sich die Ausführung des Werkzeugs.

Geschlossen Skalierungstoleranz

Gibt den zulässigen Prozentsatz der Skalierung (Größenunterschiede) zwischen dem gefundenen Muster und dem Muster Modell an (0 - 50; Standard = 0). Der Wert entspricht einem positiven oder negativen Prozentsatz. Beispielsweise lassen sich mit dem Werkzeug bei einem Wert von "5" Muster finden, die zu 95 % bis 105 % der Größe des Musters Modell entsprechen. Bei einem größeren Bereich für die Skalierungsabweichung des Musters verlängert sich die Ausführung des Werkzeugs.

Geschlossen Modus suchen

Gibt den zum Einlernen und Erkennen von Mustern verwendeten Suchmodus an: PatMax oder PatQuick. In der Standardeinstellung ist PatMax ausgewählt. PatMax bietet eine höhere Genauigkeit als PatQuick, erfordert für die Ausführung aber mehr Zeit. PatQuick ist weniger genau als PatMax, die Ausführungsdauer ist dafür jedoch kürzer.

Geschlossen Genaue Bewertung

Gibt an, ob fehlende oder verdeckte Merkmale des gefundenen Musters die Güte beeinflussen (Standard = Aus, nicht aktiviert). Bei Verwendung der genauen Bewertung („An“, aktiviert) verringert sich die Güte des gefundenen Musters, falls Mustermerkmale fehlen oder blockiert werden.

Geschlossen Polarität ignorieren

Definiert, ob gefundene Muster im Hinblick auf das Muster Modell farblich invertierte Übereinstimmungsmerkmale enthalten dürfen (standardmäßig = Aus, deaktiviert). Wird Polarität ignorieren angewendet (An, aktiviert), werden gefundene Muster mit farblich invertierten Merkmalen, z. B. schwarz/weiß im Gegensatz zu weiß/schwarz im Muster Modell, als mit dem Muster Modell übereinstimmend betrachtet.

Geschlossen Sortieren nach

Gibt an, wie gefundene Muster sortiert werden: nach Güte (Standardeinstellung), X oder Y. Bei Auswahl von Güte werden die gefundenen Muster basierend auf ihrer Güte sortiert. Dabei wird das Muster mit der höchsten Güte als Erstes aufgeführt, und die nachfolgenden Muster werden in absteigender Reihenfolge aufgelistet. Bei Auswahl von X werden die gefundenen Muster basierend auf ihrem Abstand von der X-Achse sortiert. Dabei werden die Muster in absteigender Reihenfolge beginnend mit dem Muster mit dem kürzesten Abstand aufgelistet. Bei Auswahl von Y werden die gefundenen Muster basierend auf ihrem Abstand von der y-Achse sortiert. Dabei werden die Muster in absteigender Reihenfolge beginnend mit dem Muster mit dem kürzesten Abstand aufgelistet.

Geschlossen Horizontaler Versatz

Gibt die Position eines horizontalen Versatzes in Pixeln an, gemessen von der Mitte des gefundenen Musters (relativ zum eingelernten Modellmuster). So können Koordinaten ausgehend von der Mitte des gefundenen Modellmusters zugeordnet werden. Dadurch lässt sich in visuell gesteuerten Roboteranwendungen ein Anhaltspunkt definieren.

Geschlossen Vertikaler Versatz

Gibt die Position eines vertikalen Versatzes in Pixeln an, gemessen von der Mitte des gefundenen Musters (relativ zum eingelernten Modellmuster). So können Koordinaten ausgehend von der Mitte des gefundenen Modellmusters zugeordnet werden. Dadurch lässt sich in visuell gesteuerten Roboteranwendungen ein Anhaltspunkt definieren.

Geschlossen Timeout
Definiert den Zeitraum in Millisekunden (0 bis 30000), in dem das Werkzeug nach Mustern sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird. Dieser Parameter ist standardmäßig auf 5,000 gestellt.
Geschlossen Ergebnis

Zeigt die X- und Y-Koordinaten der Mitte des gefundenen Musters und Winkeldaten sowie die relative Güte des Musters Modell an. Wenn ein horizontaler und/oder vertikaler Versatz angewendet wurde, werden die X- und Y-Koordinaten mit dem in den Versatzfeldern angegebenen Wert angepasst.

Hinweis: Wird für den Parameter Anzahl ein höherer Wert als 1 festgelegt, ist das angezeigte Ergebnis immer das gefundene Muster mit der höchsten Güte, es sei denn der Parameter Sortieren nach wurde auf X oder Y festgelegt.
Hinweis:
  • Bei den Positionswerkzeugen PatMax RedLine-Muster and PatMax RedLine-Muster (1-10) steht der Parameter Suchmodus nicht zur Verfügung.
  • Die Parameter Anzahl und Sortieren nach werden nur von den Positionswerkzeugen PatMax RedLine-Muster (1-10) und PatMax-Muster (1-10) unterstützt.


Positionswerkzeuge "PatMax RedLine-Muster", "PatMax-Muster", "PatMax RedLine-Muster (1-10)" und "PatMax-Muster (1-10)" - Registerkarten "Modell" und "Suchen"

Die Registerkarten Modell und Suchen werden zum Konfigurieren des zusammengesetzten Bereichs für den Modell- und Suchbereich des Werkzeugs verwendet. Zusammengesetzter Bereiche sind Ansammlungen von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon), die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • In der Registerkarte Modell sind zusammengesetzte Bereiche nur aktiviert, nachdem die Schaltfläche Modellbereich einmal angeklickt wurde.
  • Es können einem Zusammengesetzten Bereich maximal 32 Unterbereiche hinzugefügt werden können.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


Positionswerkzeuge "PatMax RedLine-Muster", "PatMax-Muster", "PatMax RedLine-Muster (1-10)" und "PatMax-Muster (1-10)" - Registerkarte "Trainiertes Bild"

Das auf der Registerkarte „Trainiertes Bild“ angezeigte Bild ist eine Miniaturansicht des Musters Modell. Klicken Sie auf die Schaltfläche Modellbereich, um die Größe des Modellbereichs zu ändern oder diesen zu verschieben. Klicken Sie anschließend auf die Schaltfläche Einlernen, um das Muster Modell erneut einzulernen.


Positionswerkzeuge "PatMax RedLine-Muster (1-10)" und "PatMax-Muster (1-10)" - Registerkarte "Tabelle"

Die auf der Registerkarte "Tabelle" erstellte Tabelle umfasst die Ergebnisse der gefundenen Muster:

Geschlossen Index

Gibt die Reihenfolge der gefundenen Muster an; 1 bis 10 (numerische Reihenfolge in EasyBuilder basiert auf 0 = 1).

Geschlossen X

Gibt die Mitte der X-Koordinate des gefundenen Musters an. Wurde Horizontaler Versatz angewendet, wird die x-Koordinate dem angegebenen Wert angeglichen.

Geschlossen Y

Gibt die Mitte der Y-Koordinate des gefundenen Musters an. Wurde Vertikaler Versatz angewendet, wird die y-Koordinate dem angegebenen Wert angeglichen.

Geschlossen Winkel

Gibt den Winkel des gefundenen Musters an, relativ zum Muster "Modell".

Geschlossen Güte

Gibt an, wie stark das gefundene Muster mit dem Muster "Modell" übereinstimmt.

Geschlossen Skalierung

Gibt die Skalierung des gefundenen Musters an.


Positionswerkzeuge – „Muster„ und „Muster (1-10)“

Das Positionswerkzeug „Muster“ und das Positionswerkzeug „Muster (1-10)“ dienen zum Ermitteln der Positionen von Mustermerkmalen auf der Basis einer trainierten Darstellung dieses Musters (Modell genannt). Das Werkzeug Muster dient dem Ermitteln der Position eines einzigen Musters, während das Werkzeug Muster (1-10) für das Suchen von bis zu 10 Mustern verwendet wird.

Das Positionswerkzeug „Muster“ und das Positionswerkzeug „Muster (1-10)“ sind hilfreich bei Anwendungen, bei denen genaue Positionierung erforderlich ist, z.B. bei visuell gesteuerten Roboteranwendungen. Das Werkzeug eignet sich zudem als Vorrichtung für andere Vision-Werkzeuge, da die Suche im Bild erfolgt.

Tipp:
  • Weitere Informationen zur Auswahl eines Mustermerkmals finden Sie unter Auswählen eines Mustermerkmals.
  • Weitere Informationen zu den „Muster“-Positionswerkzeugen finden Sie unter PatMax RedLine-Muster und PatMax-Muster und Muster.

Das Werkzeug berichtet die folgenden Ergebnisse:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren In-Sight 2000-110 und 2000-120/120C | Nur bei Bestanden/Nicht bestanden-Status.
Vision-Sensor In-Sight 2000-130/130C | Gut/Schlecht-Status und Mustergüte
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | X/Y-Koordinaten*, Winkelausrichtung, Güte und Bestanden/Nicht bestanden-Status
* Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung der Werkzeuge

Anpassen der Werkzeugparameter


Einrichten der Positionswerkzeuge "Muster" und "Muster (1-10)"

Wählen Sie nach dem Hinzufügen des Werkzeugs die Bereiche im Bild aus, mit denen das Muster definiert (der Modellbereich) und die Position im Bild festgelegt werden, an der das Muster gefunden wird (der Suchbereich).

  1. Platzieren Sie den Modellbereich über dem Muster, das als Trainingsmodell dient. Stellen Sie sicher, dass der Modellbereich nur die wichtigen Merkmale des Musters abdeckt.

  2. Platzieren Sie den Suchbereich so, dass er die Bereiche im Bild abdeckt, in denen das Muster Ihrer Meinung nach erscheint. Erstellen Sie kleinere Suchbereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Suchbereich ist, desto länger dauert die Inspektion mit dem Werkzeug.

    3. Hinweis: Die Bereiche Modell und Suchen können nicht in Bogen- oder Ringform gebogen werden.

  3. Klicken Sie auf OK, um die Bereiche zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  4. Der Modellbereich wird durch das Symbol [image] ersetzt. Dies gibt die Position und Winkelausrichtung des gefundenen Musters an.
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter der Positionswerkzeuge „Muster“ und „Muster (1-10)“

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Vision-Sensoren der In-Sight 2000-Serie

Werkzeug „Muster“

  • Gruppenfeld „Werkzeug bearbeiten“

Werkzeug „Muster (1-10)“

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
  • Registerkarte Trainiertes Bild
  • Registerkarte Tabelle

In-Sight Vision-Systeme

Die Einstellungsfenster der Positionswerkzeuge Muster und Muster (1-10) enthalten folgende Registerkarten:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
  • Registerkarte Trainiertes Bild
  • Registerkarte Tabelle
Hinweis: Die Registerkarte Tabelle ist nur für das Positionswerkzeug „Muster (1-10)“ aktiviert.
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Vision-Sensoren der In-Sight 2000-Serie

In-Sight-Vision-Systeme


Anpassen der Parameter des Positionswerkzeugs „Muster“

Hinweis:
  • Dieser Abschnitt beschreibt die Benutzeroberfläche des Positionswerkzeugs „Muster“ bei Verbindung mit einem Vision-Sensor der In-Sight 2000-Serie. Wenn eine Verbindung mit einem In-Sight Vision-System besteht oder das Positionswerkzeug „Muster (1-10)“ verwendet wird, finden Sie weitere Informationen im Abschnitt „In-Sight Vision-Systeme“ von Anpassen der Parameter der Positionswerkzeuge „Muster“ und „Muster (1-10)“.
  • Beim Versuch, einen Job mit diesem Werkzeug, der in In-Sight-Firmwareversion 5.7.0 oder höher konfiguriert wurde, in ein In-Sight Vision-System mit Firmwareversion 5.6.x oder früher zu laden, wird eine Fehlermeldung angezeigt. Der Ladevorgang schlägt anschließend fehl.

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Geschlossen Anzeige von Bestanden/Nicht bestanden

Zeigt einen grünen Kreis [image] oder ein rotes Rechteck [image] zur Angabe des Erfolgs bzw. Fehlschlags an.

Geschlossen Rotationstoleranz

Gibt an, wie weit das gefundene Muster von der Position des Musters Modell gedreht werden und dennoch als gültiges Muster erkannt werden kann (± 0 bis 180°; Standard = 45°). Bei einem größeren Bereich für die Rotationsabweichung des Musters verlängert sich die Ausführung des Werkzeugs. Der linke Schieberegler stellt die negative und der rechte Schieberegler die positive Rotationstoleranz ein. Sie können die Rotationstoleranz durch Bewegen des linken und des rechten Schiebereglers oder durch Eingeben von Werten in die entsprechenden Bearbeitungsfelder einstellen.

Tipp: Sie können den Schieberegler auch mithilfe der PFEILTASTEN (NACH-OBEN, NACH-UNTEN-, NACH-LINKS- und NACH-RECHTS) bewegen.
Geschlossen Teildetektoranzeige

Die Teildetektoranzeige zeigt an, wie gut das Merkmal vom Werkzeug befunden wurde. Sie legt die minimale Akzeptanzschwelle fest. Sie können eine minimale Akzeptanzschwelle auch manuell (0 - 100; Standard = 50), mithilfe des Schiebereglers oder durch Eingeben eines Wertes in entsprechende Bearbeitungsfeld festlegen.

Tipp: Sie können den Schieberegler auch mithilfe der PFEILTASTEN (NACH-OBEN, NACH-UNTEN-, NACH-LINKS- und NACH-RECHTS) bewegen.

Ist die Messanzeige über der Schwelle, betrachtet das Tool das Teil als gefunden und die Anzeige wird grün. Ist die Messanzeige unter dem Schwellwert, betrachtet es das Teil als nicht gefunden, und die Anzeige verschwindet. Wenn das Tool Sachen findet, die keine Teile sind oder wenn es die falschen Merkmale findet, bewegen Sie den Schieberegler nach rechts. Wenn das Tool einige Teile nicht findet, bewegen Sie den Schieberegler nach links (oder erstellen Sie einen neuen Modellebreich). Niedrigere Einstellungen beinhalten eine höhere Wahrscheinlichkeit für ungenauere Ergebnisse, beispielsweise die Erkennung von Mustern, die dem Muster Modell ähneln, diesem jedoch nicht entsprechen.

BESTANDEN
NICHT BESTANDEN
Hinweis: Fährt man mit der Maustaste über den Schieberegler, werden die Werte Ergebnis und Schwelle angezeigt.
Geschlossen ± 10% Skalierungstoleranz

Gibt den zulässigen Prozentsatz für die Skalierung (Größenunterschiede innerhalb von ±10 %) zwischen dem gefundenen Muster und dem Muster "Modell" an.

Eingelerntes Muster | Gefundenes Muster: +10% | Gefundenes Muster: - 10%
AUS (Standard) | (Schlecht) | (Schlecht)
EIN | (Gut) | (Gut)
Geschlossen Manuelles Zeitlimit verwenden

Definiert, ob die Zeitlimiteinstellung angewendet wird.

  • Aus (Standard): Die Zeitlimiteinstellung ist deaktiviert (kein Zeitlimit).

  • Ein: Die Zeitlimiteinstellung ist aktiviert. Sie können den Zeitlimitwert mithilfe des Bearbeitungsfeldes in Millisekunden angeben (0 bis 30000).

    Hinweis: Ist als Wert 0 festgelegt, wird diese Einstellung deaktiviert und es gilt kein Zeitlimit.
Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Name

Legt den Namen des Inspektionswerkzeuges fest. Der Standardname ist „Muster_1“ (wenn dies das erste Werkzeug „Muster“ ist, das dem Job hinzugefügt wurde, andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Muster_2“, „Muster_3“ usw.).

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Aktiviert

Definiert, wann und ob das Inspektionswerkzeug ausgeführt werden soll (Standardeinstellung ist „Ein“).

  • Wählen Sie „Aus“, wenn Sie das Werkzeug deaktivieren möchten.
  • Wählen Sie eine Eingangsleitung aus, wenn das Werkzeug an eine bestimmte diskrete Eingangsleitung gebunden sein soll, wo es ein- oder ausgeschaltet werden kann (ein High-Signal, 1, bedeutet „Ein“, ein Low-Signal, 0, bedeutet „Aus“). Durch die Verbindung des Werkzeugs mit einem Eingang kann mithilfe eines Kontrollsystems (z. B. SPS) festgelegt werden, welche Werkzeuge wann ausgeführt werden sollen.
Geschlossen Vorrichtung

Gibt eine Vorrichtung für das Werkzeug an. Wird das Steuerelement Vorrichtung aktiviert, verwandelt sich die Schaltfläche Vorrichtung in ein Orange.

Hinweis: Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.
Geschlossen Eingang Einlernen

Definiert, ob ein Modellmuster über eine Eingangsleitung eingelernt werden soll oder nicht (die Standardeinstellung ist „Aus“, deaktiviert).

  • Eingang: Einlernen eines Modellmusters über eine Eingangsleitung. Die ausgewählte Eingangsleitung wird als Einlernsignal verwendet.

    Hinweis:
    • Diese Option wird nicht angezeigt, wenn das In-Sight Vision-System nicht über diskrete Eingänge verfügt (z. B. Vision-Systeme der In-Sight 8000-Serie, die direktes E/A verwenden).
    • Der Signaltyp der ausgewählten Eingangsleitung muss im Anwendungsschritt Eingänge/Ausgänge auf Ereignistrigger gestellt sein.
    • Beim Einlernen eines Modellmusters wird das Bild verwendet, das zuletzt vom Vision-System/Sensor aufgezeichnet wurde. Es ist nicht erforderlich, das Vision-System/den Sensor erneut auszulösen, um einzulernen.
    • Weitere Informationen finden Sie unter Eingänge: Einlernen eines Modellmusters über eine Eingangsleitung
Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Geschlossen Modellbereich

Das Bild ist eine Miniaturansicht vom Muster Modell. Klicken Sie auf die Schaltfläche Modellbereich, um die Größe des Modellbereichs zu ändern oder diesen zu verschieben. Klicken Sie anschließend auf die Schaltfläche Trainieren, um das Muster Modell erneut einzulernen.


Positionswerkzeuge „Muster“ und „Muster (1-10)“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Definiert den Namen des Inspektionswerkzeugs, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Pattern_1“, sofern es sich um das erste Musterwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Pattern_2“, „Pattern_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Positionswerkzeuge „Muster“ und „Muster (1-10)“ – Registerkarte „Einstellungen“

Geschlossen Eingang Einlernen

Definiert, ob ein Modellmuster über eine Eingangsleitung eingelernt werden soll oder nicht (die Standardeinstellung ist „Aus“, deaktiviert).

  • Eingang: Einlernen eines Modellmusters über eine Eingangsleitung. Die ausgewählte Eingangsleitung wird als Einlernsignal verwendet.

    Hinweis:
    • Diese Option wird nicht angezeigt, wenn das In-Sight Vision-System nicht über diskrete Eingänge verfügt (z. B. Vision-Systeme der In-Sight 8000-Serie, die direktes E/A verwenden).
    • Der Signaltyp der ausgewählten Eingangsleitung muss im Anwendungsschritt Eingänge/Ausgänge auf Ereignistrigger gestellt sein.
    • Beim Einlernen eines Modellmusters wird das Bild verwendet, das zuletzt vom Vision-System/Sensor aufgezeichnet wurde. Es ist nicht erforderlich, das Vision-System/den Sensor erneut auszulösen, um einzulernen.
    • Weitere Informationen finden Sie unter Eingänge: Einlernen eines Modellmusters über eine Eingangsleitung
Geschlossen Anzahl

Definiert die Anzahl der Instanzen des Modell-Musters, die gefunden werden sollen (1-10; Standard = 1) Für die meisten Anwendungen wird nur eine Vorrichtung benötigt; es können aber mehrere Instanzen des Modell-Musters gesucht werden, was in Anwendungen nützlich ist, in denen das Bild mehr als ein Teil oder Objekt enthält. Je mehr eingelernte Instanzen das Werkzeug identifizieren muss, desto länger ist seine Ausführungszeit.

Geschlossen Automatischer Schwellwert

Gibt den Übereinstimmungsgrad an, der zwischen dem Muster Modell und dem gefundenen Muster vorhanden sein muss (0 - 100; Standard = 50). Liegen die Werte der gefundenen Muster über der Einstellung bzw. entsprechen sie dieser, liegt eine Übereinstimmung vor. Dieses Werkzeug lässt sich mit einer höheren Einstellung schneller ausführen. Dies erfordert ebenfalls einen höheren Übereinstimmungsgrad zwischen dem Modell und dem gefundenen Muster. Niedrigere Einstellungen beinhalten eine höhere Wahrscheinlichkeit für ungenauere Ergebnisse, beispielsweise die Erkennung von Mustern, die dem Muster Modell ähneln, diesem jedoch nicht entsprechen.

Geschlossen Rotationstoleranz

Gibt an, wie weit das gefundene Muster von der Position des Musters „Modell“ entfernt sein und dennoch als gültiges Muster erkannt werden kann (± 0 - 180°; Standard = 15°). Bei einem größeren Bereich für die Rotationsabweichung des Musters verlängert sich die Ausführung des Werkzeugs.

Geschlossen Skalierung

Gibt den zulässigen Prozentsatz der Skalierung (Größenunterschiede innerhalb von ±10%) zwischen dem gefundenen Muster und dem Modell-Muster an. Standardmäßig ist diese Einstellung deaktiviert, wodurch Skalierungsanpassungen deaktiviert sind. In diesem Modus findet das Werkzeug nach wie vor Muster, die sich innerhalb des Bereichs von ±10% befinden, aber die Güte der Funktion nimmt ab, während der Skalierungsprozentsatz zunimmt.

Geschlossen Sortieren nach

Definiert, wie gefundene Muster sortiert werden: Güte (der Standard), X oder Y. Wenn Güte ausgewählt wird, werden die gefundenen Muster anhand ihrer Güte sortiert. Dabei wird das Muster mit der höchsten Güte zuerst aufgelistet, danach die darauffolgenden Mustern in absteigender Reihenfolge. Wenn X ausgewählt wird, werden die gefundenen Muster basierend auf ihrem Abstand von der X-Achse vom nächstgelegenen bis zum am weitesten entfernten in absteigender Reihenfolge sortiert. Wenn Y ausgewählt wird, werden die gefundenen Muster basierend auf ihrem Abstand von der Y-Achse vom nächstgelegenen bis zum am weitesten entfernten in absteigender Reihenfolge sortiert.

Geschlossen Horizontaler Versatz

Definiert eine horizontale Versatzposition (gemessen in Pixeln) von der Mitte des gefundenen Musters bezüglich des eingelernten Modell-Musters. Damit können Sie Koordinaten von der Mitte des Modell-Musters weg zuweisen, was nützlich zum Definieren eines Pick-Punkts für visuell gesteuerte Roboteranwendungen ist.

Geschlossen Vertikaler Versatz

Definiert eine vertikale Versatzposition (gemessen in Pixeln) von der Mitte des gefundenen Musters bezüglich des eingelernten Modell-Musters. Damit können Sie Koordinaten von der Mitte des Modell-Musters weg zuweisen, was nützlich zum Definieren eines Pick-Punkts für visuell gesteuerte Roboteranwendungen ist.

Geschlossen Modelltyp

Definiert die Art und Weise, auf die vom Werkzeug das Muster Modell erstellt wird: Flächenmodell oder Kantenmodell (Standard). Die Option Flächenmodell erstellt das Muster Modell auf Grundlage einheitlichen Samplings der Graustufenwerte im Bereich Modell. Die Option Kantenmodell erstellt das Muster Modell auf Grundlage der ermittelten Kanten (Hell/dunkel-Übergänge) des Mustermerkmals im Modellbereich.

Geschlossen Genauigkeit

Definiert, wie das Werkzeug den Kompromiss zwischen Genauigkeit/Zuverlässigkeit und Ausführungsgeschwindigkeit bewertet: Genau, Mittel (Standard) und Schnell. Mit Genau erreichen Sie eine höhere Genauigkeit/Zuverlässigkeit und eine niedrigere Ausführungsgeschwindigkeit, mit Schnell erreichen Sie eine niedrigere Genauigkeit/Zuverlässigkeit und eine höhere Ausführungsgeschwindigkeit, und mit Mittel erhalten Sie eine mittlere Genauigkeit/Zuverlässigkeit und eine mittlere Ausführungsgeschwindigkeit.

Geschlossen Zeitüberschreitung

Definiert den Zeitraum in Millisekunden (0 bis 30 000), in dem das Werkzeug nach Mustern sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird.

Geschlossen Ergebnis

Zeigt die X,Y-Koordinaten des Mittelpunkts des gefundenen Musters sowie dessen Winkelausrichtung und die Güte im Vergleich zum Modell-Muster an. Wenn ein Horizontaler Versatz und/oder Vertikaler Versatz angewendet wurden, werden die X,Y-Koordinaten um den in den Versatzfeldern angegebenen Betrag angepasst.

Hinweis: Wird für den Parameter Anzahl ein höherer Wert als 1 festgelegt, ist das angezeigte Ergebnis immer das gefundene Muster mit der höchsten Güte, es sei denn der Parameter Sortieren nach wurde auf X oder Y festgelegt.
Hinweis: Das Positionswerkzeug „Muster“ enthält nicht die Parameter Anzahl oder Sortieren nach.


Positionswerkzeug „Muster (1-10)“ – Registerkarte „Tabelle“

Die auf der Registerkarte "Tabelle" erstellte Tabelle umfasst die Ergebnisse der gefundenen Muster:

Geschlossen Index

Gibt die Reihenfolge der gefundenen Muster an; 1 bis 10 (numerische Reihenfolge in EasyBuilder basiert auf 0 = 1).

Geschlossen X

Gibt die Mitte der X-Koordinate des gefundenen Musters an.

Geschlossen Y

Gibt die Mitte der Y-Koordinate des gefundenen Musters an.

Geschlossen Winkel

Gibt den Winkel des gefundenen Musters an, relativ zum Muster "Modell".

Geschlossen Güte

Gibt an, wie stark das gefundene Muster mit dem Muster "Modell" übereinstimmt.


Positionswerkzeuge „Muster“ und „Muster (1-10)“ – Registerkarte „Trainiertes Bild“

Das auf der Registerkarte Trainiertes Bild angezeigte Bild ist eine Miniaturansicht des Musters Modell. Klicken Sie auf die Schaltfläche Modellbereich, um die Größe des Modellbereichs zu ändern oder diesen zu verschieben. Klicken Sie anschließend auf die Schaltfläche Einlernen, um das Muster Modell erneut einzulernen.


Positionswerkzeuge – Kante

Das Positionswerkzeug "Kante" dient zum Ermitteln eines linearen Kantenmerkmals, das den festgelegten Parametern entspricht.

Das Werkzeug für Kantenpositionen ist eines der schnelleren Werkzeuge und erkennt Kantenmerkmale deutlich schneller als ein Werkzeug für Musterpositionen. Dieses Werkzeug eignet sich zudem als Vorrichtung für andere Vision-Werkzeuge, wenn das Kantenmerkmal einen hohen Kontrast aufweist, sich in nur einer Richtung bewegt (horizontal oder vertikal) und seine Drehung nicht mehr als 10° beträgt.

Das Werkzeug berichtet die folgenden Ergebnisse:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren der In-Sight 2000-Serie 1xx (110, 120, 130) | Nur bei Bestanden/Nicht bestanden-Status.
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | X- und Y-Koordinaten vom Mittelpunkt der gefundenen Kante*, Winkelausrichtung und Bestanden/Nicht bestanden-Status.
* Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Positionswerkzeugs "Kante"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie das Kantenmerkmal definieren, das als Vorrichtung verwendet wird:

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie unter den verfügbaren Merkmalen per Mausklick eine Kante aus. Die Farbe des Merkmals ändert sich dadurch in Magenta.

  3. Bestätigen Sie Ihre Auswahl durch Klicken auf OK (oder klicken Sie auf Abbrechen, um das Werkzeug nicht zum Job hinzuzufügen). EasyBuilder erstellt automatisch einen Kantenbereich um das ausgewählte Kantenmerkmal und fügt das Symbol [image] ein, das die Position und Ausrichtung der gefundenen Kante angibt.

    Hinweis: Bei Bedarf kann der Bereich um die ermittelte Kante gedreht oder größenmäßig angepasst werden.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Werkzeugs für Kantenpositionen

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Werkzeugs für Kantenpositionen umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Diagramm
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Diagramm


Werkzeug für Kantenpositionen – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Edge_1“, sofern es sich um das erste Kantenwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Edge_2“, „Edge_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Positionswerkzeug „Kante“ – Registerkarte „Einstellungen“

Geschlossen Kantenkontrast

Definiert die akzeptable Mindestkontrastgüte für die gefundene Kante (1-100; Standard = eine „Smart-Einstellung“, die automatisch schrittweise bis zur Erkennung einer Kante reduziert wird). Diese Einstellung bestimmt die Empfindlichkeit des Werkzeugs bei der Kantenerkennung, d. h. seine Fähigkeit, zwischen dem Merkmal und dem Hintergrund zu unterscheiden. Verwenden Sie diese Einstellung in Verbindung mit dem Diagramm des Werkzeugs, um einen akzeptablen Bereich festzulegen.

Hinweis: Wenn dieser Parameter auf „0“ gesetzt ist, werden möglicherweise unerwartete Kanten gefunden.
Geschlossen Güte normalisieren

Legt fest, ob die Kantengüten durch das Graustufen-Histogramm des Bereichs normalisiert werden.Dieser Parameter ist für die Suche nach Kanten in Bereichen mit niedrigem Kontrast nützlich. Deaktivieren Sie diesen Parameter, wenn nur Kanten mit hohem Kontrast erwartet werden.

  • Aktiviert (Standard): Normalisiert die Güte.
  • Deaktiviert: Normalisiert die Güte nicht.
Geschlossen Kantenübergang

Definiert den Übergang der Kante („Dunkel zu Hell“, „Hell zu Dunkel“ oder „Beides“; Standard = Beides). Die Pfeile für die Scanrichtung im Bereich geben die Richtung an, in der EasyBuilder nach der Kante sucht. Durch Festlegen des Übergangstyps können Sie die Genauigkeit und Geschwindigkeit erhöhen.

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 50; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Suchkriterium

Definiert, wie das Werkzeug zwischen gefundenen Kanten unterscheidet, wenn mehrere Kanten vorhanden sind (Standard = Beste Güte).

  • Beste Güte = Das Kantenmerkmal mit der am besten definierten Kante (höchster Kontrast).
  • Erste Kante Das Kantenmerkmal, das dem Beginn der Scanrichtung des Bereichs am nächsten liegt.
  • Letzte Kante Das Kantenmerkmal, das am weitesten vom Beginn der Scanrichtung des Bereichs entfernt ist.
Geschlossen Winkelbereich

Definiert die maximale Winkelverschiebung, die bei der gefundenen Kante möglich ist (0-10°; Standard = 10°). Je größer die zulässige Winkelvariation, desto länger dauert die Ausführung des Werkzeugs.

Geschlossen Ergebnis

Zeigt die X/Y-Koordinate des Mittelpunkts der gefundenen Kante sowie ihre Winkelausrichtung an.


Werkzeug für Kantenpositionen – Diagramm

Das Diagramm ist eine Darstellung der ersten Ableitung von den Graustufenwerten eines Bereichs. Spitzen- und Talwerte stellen die deutlichsten Kantenübergänge dar.

Bei Werkzeugen zur Kantenerkennung (Werkzeuge für Kanten und Kreise) gibt die Güte-Achse an, wie stark die gefundene Kante mit den festgelegten Parametern übereinstimmt:

  • Eine positive Güte weist darauf hin, dass der Kantenübergang von dunkel zu hell erfolgt.
  • Eine negative Güte weist darauf hin, dass der Kantenübergang von hell zu dunkel erfolgt.
  • Bei einer Güte mit einem Wert von 0 wurde keine Kante erkannt.

Die Versatz-Achse gibt den Bereich an, mit dem das Kantenmerkmal definiert wird. Der Wert "0" bezieht sich auf die Anfangspunktbegrenzung des Bereichs. Der andere Wert steht für die maximale Breite des Bereichs in Pixeln. Der Scheitelpunkt der Spitzen- und Talwerte an der Versatz-Achse gibt die Position der gefundenen Kante an.

Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


Positionswerkzeuge – Kantenschnittpunkt

Das Positionswerkzeug "Kantenschnittpunkt" wird zur Identifikation des Punktes, wo zwei Kantenmerkmale sich schneiden, verwendet.

Das Werkzeug berichtet die folgenden Ergebnisse:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren der In-Sight 2000-Serie 1xx (110, 120, 130) | Nur bei Bestanden/Nicht bestanden-Status.
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | X- und Y-Koordinaten des Schnittpunktes*, der Schnittwinkel zwischen den zwei Kanten und Bestanden/Nicht bestanden-Status.
* Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Positionswerkzeugs "Kantenschnittpunkt"

Nachdem das Werkzeug hinzugefügt wurde, definieren Sie die sich überschneidenden Kantenmerkmale:

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie zunächst eines der verfügbaren Merkmale per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta, und eine Linie in Verlängerung des Merkmals wird angezeigt.
  3. Wählen Sie als Nächstes das Kantenmerkmal aus, das sich überschneidet.
  4. Nach Auswahl des zweiten Merkmals ermittelt EasyBuilder automatisch den Schnittpunkt der Linien und fügt das Symbol [image] ein, das die Position und die Ausrichtung des gefundenen Punkts angibt. EasyBuilder fügt zudem automatisch ein An-/Abwesenheitswerkzeug "Kante" für alle Kantenmerkmale hinzu, die zuvor nicht definiert wurden.
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Positionswerkzeugs „Kantenschnittpunkt“

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Positionswerkzeugs „Kantenschnittpunkt“ enthält Folgendes:

Geschlossen Registerkarte „Allgemein“
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge, Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Schneiden_1“, sofern es sich um das erste Positionswerkzeug „Kantenschnittpunkt“ oder Kreis-Linie oder das Geometriewerkzeug „Linie-Schnittpunkt“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Schneiden_2“, „Schneiden_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.


Positionswerkzeuge – „Blob“ und „Blobs (1-10)“

Die Positionswerkzeuge Blob und Blobs (1-10) erkennen Blob-Merkmale, die in die festgelegten Parameter fallen. Das Werkzeug gibt die X,Y-Koordinaten des Zentroids des erkannten Blobs sowie den Winkel des Blob-Zentroids zurück. Das Werkzeug Blob dient dem Ermitteln der Position eines einzigen Blobs, das Werkzeug Blobs (1-10) wird für das Suchen von bis zu 10 Blobs, die den Inspektionskriterien entsprechen, verwendet.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Die Leistung der Positionswerkzeuge Blob bzw. Blob (1-10) liegt zwischen der Leistung der Kanten-/Kreiswerkzeuge und der Muster-Werkzeuge. Blob-Merkmale werden schneller als mit einem Positionswerkzeug „Muster“ erkannt, die Ausführung dauert jedoch in der Regel länger als mit den Kanten-/Kreiswerkzeugen. Diese Werkzeuge sind zum Beispiel als Vorrichtungen für andere Vision-Tools nützlich, wenn die Inspektion an einer nicht klassifizierbaren Form (z. B. schwarzer Farbklecks auf weißem Hintergrund) verankert werden soll, oder wenn die Formänderung die Möglichkeiten der Muster-Werkzeuge übersteigt.

Einrichtung der Werkzeuge

Anpassen der Werkzeugparameter


Einrichten der Positionswerkzeuge "Blob" und "Blobs (1-10)"

Nach der Auswahl des Werkzeugs müssen Sie den Bereichstyp festlegen und in dem Bild konfigurieren, in dem Sie die Blobmerkmale erwarten:

  1. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp ein: Rechteck (Standard), Kreis, Annulus oder Polygon. Positionieren und konfigurieren Sie den Bereich dorthin, wo die Blobs erwartet werden. Erstellen Sie zur Verbesserung der Leistung des Werkzeugs kleinere Bereiche. Je größer ein Bereich, desto länger dauert die Inspektion. Stellen Sie bei Verwendung eines Blobmerkmals als Vorrichtung sicher, dass es sich in jedem Bild nahezu an derselben Position befindet.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Nach dem Bestätigen des Bereichs wird das Symbol [image] über dem Flächenmittelpunkt des Blobs eingefügt. Dies gibt die Position und Ausrichtung des gefundenen Merkmals an.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter der Positionswerkzeuge "Blob" und "Blobs (1-10)"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Die Einstellungsfenster der Positionswerkzeuge Blob und Blobs (1-10) enthalten folgende Registerkarte:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Tabelle"
  • Registerkarte „Histogramm“
  • Registerkarte „Zusammengesetzter Bereich“
Hinweis: Die Registerkarte Tabelle ist nur für das Positionswerkzeug „Blobs (1-10)“ verfügbar.
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Tabelle

Registerkarte „Zusammengesetzter Bereich“

Histogramm


Positionswerkzeug „Blob“ und „Blobs (1-10)“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Blob_1“, sofern es sich um das erste Blobwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Blob_2“, „Blob_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Positionswerkzeug „Blob“ und „Blobs (1-10)“ – Registerkarte „Einstellungen“

Geschlossen Schwellenwertmodus

Hier wird der Wert für die Festlegung des Graustufenwerts definiert, mit dem Blobs vom Hintergrund unterschieden werden. Bei Auswahl von „Automatisch“ (= Standardeinstellung) gleicht das Werkzeug bei jeder Bildaufnahme Helligkeitsänderungen von Bild zu Bild kontinuierlich aus. Wurde „Manuell“ ausgewählt, müssen die Werte manuell eingegeben und angepasst werden.

Geschlossen Blobschwellenwert

Definiert den Graustufenwert, der zur Unterscheidung der Blobs vom Hintergrund verwendet wird (0 bis 255, sofern aktiviert). Dieses Steuerelement ist standardmäßig deaktiviert. Zur Aktivierung muss der Schwellenwertmodus auf „Manuell“ gesetzt sein. Verwenden Sie das Histogramm, um einen optimalen Wert für Ihre Anwendung festzulegen.

Geschlossen Blobfarbe

Legt die Farbe des Blobs fest (Schwarz, Weiß oder Beides; Standard = Beides).

  • Beides = keine Anforderungen für die Blobfarbe vorhanden.
  • Schwarz = gibt nur Blobs zurück, die unter dem angegebenen Blobschwellenwert liegen.
  • Weiß = gibt nur Blobs zurück, die über dem angegebenen Blobschwellenwert liegen.
Geschlossen Begrenzung

Legt eine von zwei Methoden für die Handhabung von Blobs fest, die den Rand des Bereichs überschneiden (Standard = Aus, deaktiviert):

  • Kontrollkästchen deaktiviert – Blobs, die den Bereichsrand überschneiden, werden nicht aufgenommen; d. h. der Blob muss sich vollständig im Erfassungsbereich befinden.
  • Kontrollkästchen aktiviert – Blobs, die den Bereichsrand überschneiden, werden erfasst; d. h. Blobs, die den Bereichsrand überschneiden, werden erkannt, wenn die anderen Kriterien erfüllt werden.
Geschlossen Kleinste Fläche

Definiert ein minimales Flächenlimit, in Anzahl von Pixeln (0 bis 16777216; Standard = 100), für alle erkannten Blobs. Nur Blobs mit einer Fläche, die größer als die kleinste Fläche ist, werden erkannt.

Geschlossen Größte Fläche

Definiert ein maximales Flächenlimit, in Anzahl von Pixeln (0 bis 16777216; Standard = 100000), für alle erkannten Blobs. Nur Blobs mit einer Fläche, die kleiner als die größte Fläche sind, werden erkannt.

Geschlossen Winkel ignorieren

Legt fest, ob die Winkelausrichtung des Blob-Zentroids berücksichtigt werden soll (Standard = Ein, aktiviert).

Hinweis: Der Winkelausrichtungswert für Blobs ist in der Regel eingeschränkt, daher ist dieser Parameter standardmäßig aktiviert.
Geschlossen Zu suchende Anzahl

Definiert die Anzahl der Blobs, die ermittelt werden sollen (1-10, Standard = 1). Bei den meisten Anwendungen ist nur eine Vorrichtung erforderlich. Es können jedoch mehrere Blobs ermittelt werden. Dies ist bei Anwendungen mit mehreren Teilen oder Objekten in einem Bild hilfreich. Je mehr Blobs vom Werkzeug erkannt werden sollen, desto länger dauert die Ausführung des Werkzeugs.

Geschlossen Sortieren nach

Definiert, wie die gefundenen Blobs vom Werkzeug gemessen und sortiert werden (Fläche, Zeile, Spalte, Raster: Zeile dann Spalte von Vorrichtung, Raster: Spalte dann Zeile von Vorrichtung, Abstand vom Ausgangspunkt der Vorrichtung, Winkel (CCW) von Vorrichtung der Zeilenachse, Winkelabstand. Standard = Fläche):

  • Fläche = Sortiert nach der Fläche der gefundenen Blobs, von der kleinsten bis zur größten.
  • Zeile = Sortiert nach dem Abstand entlang der Zeilenbildachse, von der nächsten bis zur weitesten, in absteigender Reihenfolge.
  • Spalte = Sortiert nach dem Abstand entlang der Spaltenbildachse, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Raster: Zeile dann Spalte von Vorrichtung = Sortiert zunächst nach dem Abstand entlang der Zeilenbildachse der Vorrichtung und anschließend nach dem Abstand entlang der Spaltenbildachse, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Raster: Spalte dann Zeile von Vorrichtung = Sortiert zunächst nach dem Abstand entlang der Spaltenbildachse der Vorrichtung und anschließend nach dem Abstand entlang der Zeilenbildachse, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Abstand vom Ausgangspunkt der Vorrichtung = Sortiert nach Abstand vom Ausgangspunkt der Vorrichtung bis zum Mittelpunkt des Blobs, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Winkel (CCW) von Vorrichtung der Zeilenachse = Sortiert nach Winkel (0 bis 360°), wie gemessen zwischen der Zeilenbildachse der Vorrichtung und dem Liniensegment, das durch den Mittelpunkt des Blobs und den Ursprung der Vorrichtung definiert wird, vom kleinsten bis zum größten, in absteigender Reihenfolge.
  • Winkelabstand = Sortiert nach dem absoluten Winkelwert (-180 bis 180°), wie gemessen zwischen der Zeilenbildachse der Vorrichtung und dem Liniensegment, das durch den Mittelpunkt des Blobs und den Ursprung der Vorrichtung definiert wird, vom kleinsten bis zum größten.
Geschlossen Ergebnis

Zeigt die X,Y-Koordinaten und den Winkel des Zentroids des gefundenen Blobs sowie dessen Wertung an. Der Winkel beträgt immer 90°, sofern das Kontrollkästchen Winkel ignorieren nicht deaktiviert ist.

Hinweis: Wird für den Parameter Anzahl ein höherer Wert als 1 festgelegt, ist das angezeigte Ergebnis immer das gefundene Muster mit der höchsten Güte, es sei denn der Parameter Sortieren nach wurde auf X oder Y festgelegt.
Hinweis: Beim Positionswerkzeug Blob gibt es den Parameter Anzahl nicht.


Positionswerkzeug „Blobs (1-10)“ – Tabelle

Hinweis:
  • Das Positionswerkzeug „Blob“ unterstützt nicht die Registerkarte Tabelle. Die Registerkarte ist nur für das Positionswerkzeug „Blobs (1-10)“ verfügbar.
  • Wenn der Parameter Sortieren nach auf eine andere Option als Fläche festgelegt ist, werden die Spalten Pixel x-Wert und Pixel y-Wert der Tabelle hinzugefügt. Pixel x-Wert und Pixel y-Wert beziehen sich auf die Bildkoordinaten, die auf Grundlage des 2D-Rasters des Bildsensors des In-Sight-Vision-Systems (Reihen und Spalten der Region) erstellt werden, und sind das Gegenteil (Y/X) von reellen Koordinaten (X/Y).

  • Wenn die klassische Ausrichtung im Schritt Bild einrichten im Gruppenfeld Bild in realen Einheiten kalibrieren aktiviert ist, befinden sich die X- und Y-Koordinaten im selben Koordinatenraum wie die Bildkoordinaten (Y/X).

Hinweis: Auf der Registerkarte Tabelle werden abhängig vom Parameter Anzahl auf der Registerkarte „Einstellungen“ die Ergebnisse der gefundenen Blobs veröffentlicht:
Geschlossen Index

Bezieht sich auf die Reihenfolge der gefundenen Blobs auf Grundlage des Parameters Sortieren nach auf derRegisterkarte „Einstellungen“, 1 bis 10 (die numerische Sortierung in EasyBuilder basiert auf 0 = 1).

Geschlossen X

Gibt die X-Koordinate des gefundenen Mittelpunkts des Blobs zurück. Das Werkzeug gibt das Ergebnis in Pixeln zurück, außer das Bild wurde in reellen Einheiten im Abschnitt Bild einrichten kalibriert.

Geschlossen Y

Gibt die Y-Koordinate des gefundenen Mittelpunkts des Blobs zurück. Das Werkzeug gibt das Ergebnis in Pixeln zurück, außer das Bild wurde in reellen Einheiten im Abschnitt Bild einrichten kalibriert.

Geschlossen Winkel

Gibt den Winkel zwischen dem gefundenen Mittelpunkt des Blobs und dem Mittelpunkt des Bereichs an.

Geschlossen Fläche

Gibt die Fläche des gefundenen Blobs in Pixeln zurück.

Geschlossen Pixel x-Wert

Gibt die Bildzeilenkoordinate (X-Wert) des gefundenen Mittelpunkts des Blobs zurück.

Geschlossen Pixel y-Wert

Gibt die Bildspaltenkoordinate (Y-Wert) des gefundenen Mittelpunkts des Blobs zurück.


Positionswerkzeuge "Blob" und "Blobs (1-10)" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


Positionswerkzeuge "Blob" und "Blobs (1-10)" – Registerkarte "Histogramm"

Das Histogramm ist eine grafische Dastellung der Graustufenwerte für die Pixel in einem bestimmten Bereich.

  • Die X-Achse des Diagramms steht für die Gesamtzahl der Graustufenwerte (0 bis 255 oder insgesamt 256 Grauschattierungen).
  • Die Y-Achse des Diagramms gibt die Anzahl der Pixel eines bestimmten Graustufenwerts an. Zudem erfolgt die Skalierung durch Anzeige des Graustufenwerts mit der höchsten Anzahl an Pixeln.
  • Die blaue vertikale Linie steht für den Schwellenwert, mit dem der Bildbereich in schwarze und weiße Pixel aufgeteilt wird. Werte auf der linken Seite der Linie entsprechen schwarzen Pixeln und Werte auf der rechten Seite entsprechen weißen Pixeln.
Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


Positionswerkzeuge – „Farb-Blob“ und „Farb-Blobs (1-10)“

Die Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10) erkennen Farb-Blob-Merkmale, die in die festgelegten Parameter fallen. Die Werkzeuge geben die X,Y-Koordinaten des Zentroids des erkannten Blobs sowie den Winkel des Blob-Zentroids zurück. Das Werkzeug Farb-Blob dient dem Ermitteln der Position eines einzigen Blobs, das Werkzeug Farb-Blobs (1-10) wird für das Suchen von bis zu 10 Blobs, die den Inspektionskriterien entsprechen, verwendet.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Die Werkzeuge Farb-Blob und Farb-Blobs (1-10) greifen auf eine eingelernte Bibliothek von Farbmodellen zurück und ermitteln anschließend die im Bereich vorhandene Anzahl der Pixel, die mit den ausgewählten und eingelernten Farbmodellen in der eingelernten Bibliothek übereinstimmen. Außerdem wird vom Werkzeug ein binäres Graustufenausgabebild erstellt, indem jedes Pixel, das mit einem aktiven Farbmodell übereinstimmt, auf Weiß (255) festgelegt wird. Alle anderen Pixel werden auf Schwarz (0) festgelegt. Anhand dieses binären Ausgabebilds durchsucht das Werkzeug das Bild nach Blob-Merkmalen, die von den aktiven Farbmodellen erstellt wurden.

Einrichtung der Werkzeuge

Anpassen der Werkzeugparameter


Einrichten der Positionswerkzeuge "Farb-Blob" und "Farb-Blobs (1-10)"

Nach der Auswahl des Werkzeugs müssen Sie den Bereichstyp festlegen und in dem Bild konfigurieren, in dem Sie die Blobmerkmale erwarten:

  1. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp ein: Rechteck (Standard), Kreis, Annulus oder Polygon. Positionieren und konfigurieren Sie den Bereich dorthin, wo die Blobs erwartet werden. Erstellen Sie zur Verbesserung der Leistung des Werkzeugs kleinere Bereiche. Je größer ein Bereich, desto länger dauert die Inspektion. Stellen Sie bei Verwendung eines Blobmerkmals als Vorrichtung sicher, dass es sich in jedem Bild nahezu an derselben Position befindet.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Nach der Konfiguration des Suchbereichs müssen die Farbbibliothek des Werkzeugs konfiguriert und die entsprechenden Farbmodelle aktiviert werden:

    • Wurde das erste Mal ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“) hinzugefügt, müssen zunächst die Farbbibliotheken und die Farbmodelle definiert werden.

    • Wurde zuvor ein weiteres Farbwerkzeug hinzugefügt und sollen eine vorhandene Farbbibliothek und ihre eingelernten Farbmodelle verwendet werden, wählen Sie auf der Registerkarte "Einstellungen" die gewünschte Farbbibliothek, und aktivieren Sie anschließend mithilfe der Kontrollkästchen auf der Registerkarte "Bibliothek" die gewünschten Farbmodelle.

    • Wurde keine Farbbibliothek definiert, gibt das Werkzeug automatisch eine Fehlermeldung aus. Wurde eine Farbbibliothek definiert, wird sie automatisch vom Werkzeug verwendet und alle darin enthaltenen Farbmodelle werden aktiviert.

  4. Nachdem die Farbmodelle und die Farbbibliotheken festgelegt wurden, wird das Bild vom Werkzeug verarbeitet und alle Pixel innerhalb des Suchbereichs, die mit dem ausgewählten Farbmodell übereinstimmen, werden in die unbunte Farbe Weiß (255) umgewandelt. Die Pixel, die nicht mit dem ausgewählten Farbmodell übereinstimmen, erhalten die unbunte Farbe Schwarz (0).

  5. Nach dem Bestätigen des Bereichs wird das Symbol [image] über dem Flächenmittelpunkt des Blobs eingefügt. Dies gibt die Position und Ausrichtung des gefundenen Merkmals an.

  6. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  7. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter der Positionswerkzeuge "Farb-Blob" und "Farb-Blobs (1-10)"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Die Einstellungsfenster der Positionswerkzeuge Farb-Blobs und Farb-Blobs (1-10) enthalten folgende Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Farbbibliothek"
  • Registerkarte "Tabelle"
  • Registerkarte "Zusammengesetzter Bereich"
Hinweis: Die Registerkarte Tabelle ist nur für das Positionswerkzeug "Farb-Blobs (1-10)" aktiviert.
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Zusammengesetzter Bereich“

Registerkarte „Tabelle“

Bibliothek


Positionswerkzeug „Farb-Blobs“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „ColorBlob_1“, sofern es sich um das erste Werkzeug „Farb-Blob“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „ColorBlob_2“, „ColorBlob_3“ usw. Passen Sie das Werkzeug an, indem Sie ihm beispielsweise einen Namen geben, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Verwenden der Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“ – Registerkarte „Einstellungen“

Geschlossen Farbe einlernen

Öffnet das Dialogfeld „ExtractColor – Einlernen“, das zur Definition der ausgewählten Farbmodelle der Farbbibliothek verwendet wird.

Geschlossen Farbbibliothek

Definiert die Farbbibliothek, auf die vom Tool verwiesen wird. Wählen Sie in der Dropdownliste die Farbbibliothek aus, die geändert werden soll, und klicken Sie auf die Schaltfläche Farbe einlernen, um das Dialogfeld „ExtractColor – Einlernen“ zu öffnen. Jede Farbbibliothek kann bis zu 100 unterschiedliche Farbmodelle enthalten, die aus individuellen Farben zusammengesetzt sind.

EasyBuilder-Jobs können maximal 5 Farbbibliotheken enthalten, die unter folgenden Werkzeugen aufgeteilt werden können:

  • Positionswerkzeug „Farb-Blob“
  • Positionswerkzeug „Farb-Blobs (1-10)“
  • An-/Abwesenheitswerkzeug „Farbpixelanzahl“
  • Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“
  • Messungswerkzeug „Farb-Blob-Bereich (1-10)“
  • Zählwerkzeug „Farb-Blobs“
  • Identifizierungswerkzeug „Farbmodell“
  • Filterwerkzeug für Bilder „Farbe zu binär“
Geschlossen Begrenzung

Legt eine von zwei Methoden für die Handhabung von Blobs fest, die den Rand des Bereichs überschneiden (Standard = Aus, deaktiviert):

  • Kontrollkästchen deaktiviert – Blobs, die den Bereichsrand überschneiden, werden nicht aufgenommen; d. h. der Blob muss sich vollständig im Erfassungsbereich befinden.
  • Kontrollkästchen aktiviert – Blobs, die den Bereichsrand überschneiden, werden erfasst; d. h. Blobs, die den Bereichsrand überschneiden, werden erkannt, wenn die anderen Kriterien erfüllt werden.
Geschlossen Kleinste Fläche

Definiert ein minimales Flächenlimit, in Anzahl von Pixeln (0 bis 16777216; Standard = 100), für alle erkannten Blobs. Nur Blobs mit einer Fläche, die größer als die kleinste Fläche ist, werden erkannt.

Geschlossen Größte Fläche

Definiert ein maximales Flächenlimit, in Anzahl von Pixeln (0 bis 16777216; Standard = 100000), für alle erkannten Blobs. Nur Blobs mit einer Fläche, die kleiner als die größte Fläche sind, werden erkannt.

Geschlossen Winkel ignorieren

Legt fest, ob die Winkelausrichtung des Blob-Zentroids berücksichtigt werden soll (Standard = Ein, aktiviert).

Hinweis: Der Winkelausrichtungswert für Blobs ist in der Regel eingeschränkt, daher ist dieser Parameter standardmäßig aktiviert.
Geschlossen Anzahl

Legt die Anzahl der Farbblobs fest, die erkannt werden sollen (1-10, Standard = 1). Bei den meisten Anwendungen ist nur eine Vorrichtung erforderlich. Es können jedoch mehrere Blobs ermittelt werden. Dies ist bei Anwendungen mit mehreren Teilen oder Objekten in einem Bild hilfreich. Je mehr Blobs das Werkzeug erkennen soll, desto länger dauert die Ausführung des Werkzeugs.

Hinweis: Diese Einstellung steht nur für das Positionswerkzeug Farb-Blobs (1-10) zur Verfügung.
Geschlossen Sortieren nach

Definiert, wie die gefundenen Blobs vom Werkzeug gemessen und sortiert werden (Fläche, Zeile, Spalte, Raster: Zeile dann Spalte von Vorrichtung, Raster: Spalte dann Zeile von Vorrichtung, Abstand vom Ausgangspunkt der Vorrichtung, Winkel (CCW) von Vorrichtung der Zeilenachse, Winkelabstand. Standard = Fläche):

  • Fläche = Sortiert nach der Fläche der gefundenen Blobs, von der kleinsten bis zur größten.
  • Zeile = Sortiert nach dem Abstand entlang der Zeilenbildachse, von der nächsten bis zur weitesten, in absteigender Reihenfolge.
  • Spalte = Sortiert nach dem Abstand entlang der Spaltenbildachse, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Raster: Zeile dann Spalte von Vorrichtung = Sortiert zunächst nach dem Abstand entlang der Zeilenbildachse der Vorrichtung und anschließend nach dem Abstand entlang der Spaltenbildachse, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Raster: Spalte dann Zeile von Vorrichtung = Sortiert zunächst nach dem Abstand entlang der Spaltenbildachse der Vorrichtung und anschließend nach dem Abstand entlang der Zeilenbildachse, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Abstand vom Ausgangspunkt der Vorrichtung = Sortiert nach Abstand vom Ausgangspunkt der Vorrichtung bis zum Mittelpunkt des Blobs, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Winkel (CCW) von Vorrichtung der Zeilenachse = Sortiert nach Winkel (0 bis 360°), wie gemessen zwischen der Zeilenbildachse der Vorrichtung und dem Liniensegment, das durch den Mittelpunkt des Blobs und den Ursprung der Vorrichtung definiert wird, vom kleinsten bis zum größten, in absteigender Reihenfolge.
  • Winkelabstand = Sortiert nach dem absoluten Winkelwert (-180 bis 180°), wie gemessen zwischen der Zeilenbildachse der Vorrichtung und dem Liniensegment, das durch den Mittelpunkt des Blobs und den Ursprung der Vorrichtung definiert wird, vom kleinsten bis zum größten.
Geschlossen Glättungsfaktor

Definiert den Faktor (0 bis 25; Standard = 1), um den das Bild geglättet werden soll. Tragen Sie den Wert 0 ein, wenn keine Glättung erfolgen soll.

Geschlossen Originalbild anzeigen
  • Deaktiviert (Standard): Im ausgewählten Bereich wird ein binäres Ausgabebild in Graustufen angezeigt.
  • Aktiviert: Im ausgewählten Bereich wird das ursprüngliche Eingabebild angezeigt.
Geschlossen Ergebnis

Zeigt die X,Y-Koordinaten und den Winkel des Zentroids des gefundenen Blobs sowie dessen Wertung an. Der Winkel beträgt immer 90°, sofern das Kontrollkästchen Winkel ignorieren nicht deaktiviert ist.


Verwenden der Positionswerkzeuge "Farb-Blob" und "Farb-Blobs (1-10)" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


Positionswerkzeug „Farb-Blobs (1-10)“ – Registerkarte „Tabelle“

Hinweise:
  • Das Positionswerkzeug „Farb-Blob“ unterstützt nicht die Registerkarte Tabelle. Die Registerkarte ist nur für das Positionswerkzeug „Farb-Blobs (1-10)“ verfügbar.
  • Wenn der Parameter Sortieren nach auf eine andere Option als Fläche festgelegt ist, werden die Spalten Pixel x-Wert und Pixel y-Wert der Tabelle hinzugefügt. Pixel x-Wert und Pixel y-Wert beziehen sich auf die Bildkoordinaten, die auf Grundlage des 2D-Rasters des Bildsensors des In-Sight-Vision-Systems (Reihen und Spalten der Region) erstellt werden, und sind das Gegenteil (Y/X) von reellen Koordinaten (X/Y).

  • Wenn die klassische Ausrichtung im Schritt Bild einrichten im Gruppenfeld Bild in realen Einheiten kalibrieren aktiviert ist, befinden sich die X- und Y-Koordinaten im selben Koordinatenraum wie die Bildkoordinaten (Y/X).
Hinweis: Auf der Registerkarte Tabelle werden abhängig vom Parameter Anzahl auf der Registerkarte „Einstellungen“ die Ergebnisse der gefundenen Blobs veröffentlicht:
Geschlossen Index

Bezieht sich auf die Reihenfolge der gefundenen Blobs auf Grundlage des Parameters Sortieren nach auf der Registerkarte „Einstellungen“, 1 bis 10 (die numerische Sortierung in EasyBuilder basiert auf 0 = 1).

Geschlossen X

Gibt die X-Koordinate des gefundenen Mittelpunkts des Blobs zurück. Das Werkzeug gibt das Ergebnis in Pixeln zurück, außer das Bild wurde in reellen Einheiten im Abschnitt Bild einrichten kalibriert.

Geschlossen Y

Gibt die Y-Koordinate des gefundenen Mittelpunkts des Blobs zurück. Das Werkzeug gibt das Ergebnis in Pixeln zurück, außer das Bild wurde in reellen Einheiten im Abschnitt Bild einrichten kalibriert.

Geschlossen Winkel

Gibt den Winkel zwischen dem gefundenen Mittelpunkt des Blobs und dem Mittelpunkt des Bereichs an.

Geschlossen Fläche

Gibt die Fläche des gefundenen Blobs in Pixeln zurück.

Geschlossen Pixel x-Wert

Gibt die Bildzeilenkoordinate (X-Wert) des gefundenen Mittelpunkts des Blobs zurück.

Geschlossen Pixel y-Wert

Gibt die Bildspaltenkoordinate (Y-Wert) des gefundenen Mittelpunkts des Blobs zurück.


Verwenden der Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“ – Bibliothek

Geschlossen Liste Farbmodell

Zeigt eine schreibgeschützte Liste der Farbmodelle in der ausgewählten Übereinstimmungsfarbbibliothek an. Die Farbmodelle werden mittels der Kontrollkästchen neben dem Namen der Farbmodelle aktiviert oder deaktiviert.

Geschlossen Farbtabelle

Zeigt eine schreibgeschützte sortierte Liste der Farben der ausgewählten Farbbibliothek an.

Geschlossen Farbname

Zeigt die Namen der Farben im ausgewählten Farbmodell an.

Geschlossen RGB

Zeigt die RGB-Werte der Farben im ausgewählten Farbmodell an.

Geschlossen Funktion

Zeigt die Funktion der Farben (Hinzufügen oder Subtrahieren) im ausgewählten Farbmodell an.


Positionswerkzeuge – Kreis

Das Positionswerkzeug "Kreis" dient zum Ermitteln eines kreisförmigen Merkmals, das den festgelegten Parametern entspricht.

Das Positionswerkzeug "Kreis" ist eines der schnelleren Werkzeuge und erkennt Kantenmerkmale deutlich schneller als ein Werkzeug für Musterpositionen. Diese Werkzeuge eignen sich auch als Vorrichtungen für andere Vision-Werkzeuge, wenn Sie kreisförmige Objekte bzw. eine Komponente oder ein Objekt ohne Drehung inspizieren.

Das Werkzeug berichtet die folgenden Ergebnisse:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren der In-Sight 2000-Serie 1xx (110, 120, 130) | Nur bei Bestanden/Nicht bestanden-Status.
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | X/Y-Koordinaten des Kreises (sein Mittelpunkt), Durchmesser* und Gut/Schlecht-Status gefunden.
* Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Positionswerkzeugs "Kreis"

Wählen Sie nach dem Hinzufügen des Werkzeugs den Bereich im Bild aus, mit dem die kreisförmige Kante definiert wird:

  1. Platzieren Sie den kreisförmigen Bereich über dem kreisförmigen Kantenmerkmal. Passen Sie die Größe des kreisförmigen Bereichs so an, dass sie mit der Größe und den Abmessungen des Kreismerkmals übereinstimmt. Wenn Sie einen Kreis als Vorrichtung auswählen, sollten Sie sicherstellen, dass sich der Kreis in allen Bildern ungefähr an der gleichen Position befindet und einen hohen Kontrast zwischen hellen und dunklen Pixeln aufweist.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. EasyBuilder erstellt automatisch einen ringförmigen Kantenbereich um das kreisförmige Kantenmerkmal und fügt das Symbol [image] ein. Dies gibt die Position und Winkelausrichtung des gefundenen Kreises an.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Werkzeugs für Kreispositionen

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Werkzeugs für Kreispositionen umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Diagramm
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Diagramm


Werkzeug für Kreispositionen – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Circle_1“, sofern es sich um das erste Kreiswerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Circle_2“, „Circle_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Positionswerkzeug „Kreis“ – Registerkarte „Einstellungen“

Geschlossen Kantenkontrast

Definiert die akzeptable Mindestkontrastgüte für die gefundene kreisförmige Kante (1-100; Standard = eine „Smart-Einstellung“, die automatisch schrittweise bis zur Erkennung einer kreisförmigen Kante reduziert wird). Diese Einstellung bestimmt die Empfindlichkeit des Werkzeugs bei der Kantenerkennung, d. h. seine Fähigkeit, zwischen dem Merkmal und dem Hintergrund zu unterscheiden. Verwenden Sie diese Einstellung in Verbindung mit dem Diagramm des Werkzeugs, um einen akzeptablen Bereich festzulegen.

Hinweis: Wenn dieser Parameter auf „0“ gesetzt ist, werden möglicherweise unerwartete Kanten gefunden.
Geschlossen Güte normalisieren

Legt fest, ob die Kantengüten durch das Graustufen-Histogramm des Bereichs normalisiert werden.Dieser Parameter ist für die Suche nach Kanten in Bereichen mit niedrigem Kontrast nützlich. Deaktivieren Sie diesen Parameter, wenn nur Kanten mit hohem Kontrast erwartet werden.

  • Aktiviert (Standard): Normalisiert die Güte.
  • Deaktiviert: Normalisiert die Güte nicht.
Geschlossen Kantenübergang

Definiert den Übergang der Kante („Dunkel zu Hell“, „Hell zu Dunkel“ oder „Beides“; Standard = Beides). Ringförmige Bereiche suchen nach Kantenübergängen vom inneren ringförmigen Bereich zum äußeren ringförmigen Bereich. Durch Festlegen des Übergangstyps können Sie die Genauigkeit und Geschwindigkeit erhöhen.

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 50; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Suchkriterium

Definiert, wie das Werkzeug zwischen gefundenen kreisförmigen Kanten unterscheidet, wenn mehrere kreisförmige Kanten vorhanden sind (Standard = Beste Güte).

  • Beste Güte = Das kreisförmige Kantenmerkmal mit der am besten definierten Kante (höchster Kontrast und höchste Helligkeit) wird ausgewählt.
  • Kleinster Kreis = Das kreisförmige Kantenmerkmal mit dem kleinsten Durchmesser wird ausgewählt.
  • Größter Kreis = Das kreisförmige Kantenmerkmal mit dem größten Durchmesser wird ausgewählt.
Geschlossen Ergebnis

Zeigt die gefundenen X- und Y-Koordinaten (von der Mitte) sowie den Durchmesser des gefundenen Kreises an.


Werkzeug für Kreispositionen – Diagramm

Das Diagramm ist eine Darstellung der ersten Ableitung von den Graustufenwerten eines Bereichs. Spitzen- und Talwerte stellen die deutlichsten Kantenübergänge dar.

Bei Werkzeugen zur Kantenerkennung (Werkzeuge für Kanten und Kreise) gibt die Güte-Achse an, wie stark die gefundene Kante mit den festgelegten Parametern übereinstimmt:

  • Eine positive Güte weist darauf hin, dass der Kantenübergang von dunkel zu hell erfolgt.
  • Eine negative Güte weist darauf hin, dass der Kantenübergang von hell zu dunkel erfolgt.
  • Bei einer Güte mit einem Wert von 0 wurde keine Kante erkannt.

Die Versatz-Achse gibt den Bereich an, mit dem das Kantenmerkmal definiert wird. Der Wert "0" bezieht sich auf die Anfangspunktbegrenzung des Bereichs. Der andere Wert steht für die maximale Breite des Bereichs in Pixeln. Der Scheitelpunkt der Spitzen- und Talwerte an der Versatz-Achse gibt die Position der gefundenen Kante an.

Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


Positionswerkzeuge – Vorrichtung berechnen

Mit dem Positionswerkzeug „Vorrichtung berechnen“ wird eine Vorrichtungsposition anhand von mathematischen Ausdrücken berechnet, die mit den Ausgängen anderer Positions- bzw. Inspektionswerkzeuge zusammenhängen. Das Werkzeug gibt die X,Y-Koordinaten und den Winkel der berechneten Vorrichtung zurück.

Hinweis:
    Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).
  • Wenn das Werkzeug gemeinsam mit der Rasterkalibrierung verwendet wird, können ungenaue Ergebnisse auftreten, wenn sich der Winkelwert der Kalibrierung ändert. In diesen Fällen können stattdessen „Kante zu Kante“, „Kreisförmig“ oder eine importierte Kalibrierung verwendet werden.

Das Positionswerkzeug „Vorrichtung berechnen“ ist in Situationen nützlich, wenn Sie mit bestimmten Punkt-, Linien- oder Winkeldaten, die von einem Positions- oder Inspektionswerkzeug erzeugt werden, eine Vorrichtung berechnen möchten; z. B. wenn Sie eine Vorrichtung anhand von zwei Kanten, deren Schnittpunkt und dem dazugehörigen Schnittwinkel konstruieren möchten. In diesem Beispiel können zwei An-/Abwesenheitswerkzeuge „Kante“ zur Definition der Kanten und ein Geometriewerkzeug „Winkel halbieren“ zur Definition der Werte für X, Y und den Winkel verwendet werden. Das Positionswerkzeug „Vorrichtung berechnen“ verwendet dann die Ausgabedaten des Geometriewerkzeugs „Winkel halbieren“ für die Ausdrücke X (Halbieren_1.Punkt.X), Y (Halbieren_1.Punkt.Y) und Winkel (Halbieren_1.Winkel).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Positionswerkzeugs "Vorrichtung berechnen"

Nach dem Hinzufügen des Werkzeugs muss der Ausdruck für die X-, Y- und Winkelwerte konstruiert werden.

Hinweis: Das Werkzeug erfordert andere Positionswerkzeuge und/oder Inspektionswerkzeuge als Eingabe. Stellen Sie vor dem Hinzufügen des Werkzeugs die notwendigen Positions- und/oder Inspektionswerkzeuge für die Eingabe zusammen. Andernfalls können die Ausdrücke nicht erstellt werden, und Sie müssen zu diesem Schritt zurückkehren.
  1. Erstellen Sie Ausdrücke, indem Sie mathematische Funktionen im linken Bereich des Einstellungsfensters und/oder Werte (Werkzeug- und Jobdaten) im rechten Fensterbereich auswählen und dann eingeben. Zum Eingeben einer Funktion oder eines Wert im Formula Editor für Ausdrücke wählen Sie die Funktion oder den Wert aus, und drücken Sie die Eingabetaste. Doppelklicken Sie anschließend auf die Funktion bzw. auf den Wert, oder klicken Sie auf die Schaltfläche Einfügen.
  2. Nachdem alle drei Ausdrücke konstruiert wurden, platziert das Werkzeug ein [image] -Symbol im Bild, um die Position der berechneten Vorrichtung anzuzeigen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Positionswerkzeugs „Vorrichtung berechnen“

Nach dem Hinzufügen des Werkzeugs zu einem Job können Sie es für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Werkzeugs für Kreispositionen enthält folgende Elemente:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
  • Registerkarten „X“, „Y“ und „Winkel“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarten „X“, „Y“ und „Winkel“


Positionswerkzeug „Vorrichtung berechnen“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Fixture_1“, sofern es sich um das erste Werkzeug „Vorrichtung berechnen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Fixture_2“, „Fixture_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Positionswerkzeug "Vorrichtung berechnen" – Registerkarte "Einstellungen"

Geschlossen Ergebnis

Zeigt die berechneten X- und Y-Werte und Winkelwerte an.

Geschlossen Farbe

Gibt die Farbe der berechneten Position der Vorrichtung an: Standard (=Grün), Dunkelrot, Dunkelgrün, Dunkelgelb, Dunkelblau, Dunkelmagenta, Dunkeltürkis, Rot, Grün, Gelb, Blau, Magenta, Türkis, Dunkelgrau, Grau, Schwarz oder Weiß.


Positionswerkzeug „Vorrichtung berechnen“ – Registerkarten „X“,„Y“ und „Winkel“

Die Registerkarten X, Y und Winkel dienen zum Erstellen der mathematischen Formeln, die die X-, Y- und Winkelkoordinaten der Vorrichtung definieren.

Hinweis: Diese Steuerelemente sind deaktiviert, während das In-Sight Vision-System online ist.
Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen und -daten erstellt. Geben Sie mathematische Funktionen oder Job-/Werkzeugdaten entweder mithilfe des Keyboards ein, oder verwenden Sie die Vision Tools-, Mathematik- und/oder Textansicht bzw. die Vision-Datenzugriffsansicht auf der linken Seite und die Symbol-Baumstruktur für Job- und Werkzeugdaten auf der rechten Seite, um diese Formel zusammenzusetzen. Geben Sie Elemente ein, indem Sie einen Doppelklick darauf durchführen oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis:
  • Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch "Job.MissingArg" ersetzt. Das Werkzeug gibt so lange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
  • Beim Erstellen von Formeln analysiert EasyBuilder Werkzeugnamen, die mit einer Zelladresse beginnen (e.g. A3_MyTool or P10_SortTool), nicht korrekt. Müssen für diese Werkzeuge Ausdrücke erstellt werden, benennen Sie das Werkzeug um, bevor Sie die Formel erstellen.
Geschlossen Vision Tool:

Die Struktur Vision Tools enthält zusätzliche Kantenfunktionen zum Erstellen des Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Kante, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Kante, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit mathematischen Funktionen

Die Struktur mit mathematischen Funktionen enthält mathematische Funktionen zum Erstellen Ihres Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Mathematik, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Mathematik, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit Textfunktionen

Die Struktur mit Textfunktionen enthält Funktionen zum Formatieren alphanumerischer Daten für die Anzeige und zur Kommunikation und kann zur Konstruktion des Ausdrucks verwendet werden. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Textstruktur, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Textstruktur, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Datenzugriff

Die Struktur Datenzugriff enthält zusätzliche Daten, die standardmäßig nicht verfügbar sind und zur Konstruktion des Ausdrucks verwendet werden können. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Datenzugriff, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Datenzugriff, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis:
  • Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
  • EasyBuilder unterstützt ausschließlich Datenzugriffsfunktionen für Blobs, Kanten und Muster.
Geschlossen Struktur mit Symbolen für Job- und Werkzeugdaten

Die Struktur mit Symbolen für Job- und Werkzeugdaten enthält die Datenausgabe von Positions- und/oder Inspektionswerkzeugen sowie Eingangsleitungen und Jobdaten, wie Bildaufnahmeparameter. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt drei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
  • Geben Sie den Namen des gewünschten symbolischen Verweises über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche "Einfügen"

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Wählen Sie eine mathematische Funktion oder ein Symbol aus, und klicken Sie anschließend auf die Schaltfläche Einfügen, um die Funktion bzw. das Symbol in den Ausdruck einzufügen.

Hinweis: Dieses Steuerelement wird in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, ist die Schaltfläche Einfügen aktiviert.
Geschlossen Schaltflächen für öffnende und schließende Klammern sowie für Kommas

Die Schaltflächen für öffnende Klammern, Kommas und schließende Klammern werden zum Erstellen mathematischer Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um eine Klammer oder ein Komma einzufügen.

Hinweis: Diese Steuerelemente werden in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, sind die Schaltflächen aktiviert.


Erstellen von Links zwischen Positions- und Inspektionswerkzeugen

Nachdem dem Job Positionswerkzeuge und/oder Inspektionswerkzeuge hinzugefügt wurden, können ihre Eigenschaften (ihre Eingabeparameter und Ausgabeergebnisse) mithilfe der Registerkarte Links in der Palette verknüpft werden. Mithilfe der Registerkarte Links können Sie das Ausgabeergebnis eines Werkzeugs als Eingabeparameter für ein weiteres Werkzeug verwenden.

Geschlossen Verwenden der Registerkarte "Links"

Die Registerkarte Links der Palette enthält eine Strukturansicht aller Positionswerkzeuge und/oder Inspektionswerkzeuge, die derzeit im Job geladen sind. Auf die Eigenschaften der Werkzeuge (Eingabeparameter und Ausgabeergebnisse) wird mit einem Symbol-Tag verwiesen. Hierbei handelt es sich um einen symbolischen Verweis auf die enthaltenen Werte. Der Wert besitzt einen zugewiesenen Datentyp (entweder Aktion, Fließpunkt, Ganzzahl oder Zeichenfolge).

Die Werkzeugeigenschaften werden in Eingangs-/Ausgangseigenschaften unterteilt, und Verknüpfungen lassen sich nur von Ausgangseigenschaften zu Eingangseigenschaften einrichten. Ausgangseigenschaften können mit mehreren getrennten Eingangseigenschaften verknüpft werden, während eine Eingangseigenschaft nur die eingehende Verknüpfung einer einzelnen Ausgangseigenschaft akzeptiert.

Um auszuwählen, welche Werkzeugeigenschaften auf der Registerkarte Links angezeigt und konfiguriert werden können, klicken Sie mit der rechten Maustaste auf eine Werkzeugeigenschaft, und öffnen Sie das Dialogfeld Eigenschaften auswählen. Das Dialogfeld Eigenschaften auswählen enthält eine Strukturansicht aller im Job verwendeten Werkzeuge mit allen zugewiesenen Ausgangs- und Eingangs-Werkzeugeigenschaften. Sie legen fest, welche Werkzeugeigenschaften auf der Registerkarte angezeigt werden (nachdem Sie die gewünschten Eigenschaften markiert haben, können Sie sie mit den Schaltflächen Hinzufügen/Entfernen hinzufügen oder entfernen).

Geschlossen Links-Registerkartensteuerelemente
Links-Registerkartensteuerelemente
Öffnet alle im Job enthaltenen Werkzeugeigenschaften.
Schließt alle im Job enthaltenen Werkzeugeigenschaften.

Klicken Sie darauf, um zwischen den drei Werkzeugeigenschaft-Anzeigeoptionen zu wechseln:

  • Standard: Zeigt nur die im Menü "Eigenschaften auswählen" gewählten Werkzeugeigenschaften an.
  • Standardeigenschaften anzeigen: Zeigt eine kleine Untergruppe der Werkzeugeigenschaften an, wobei die Eigenschaften Beschreibung, In_Gesamtergebnis_einschließen, Fehleranzahl, Zeit_für_Ausführung, Schlecht_Anzahl, Gut_Anzahl, Werkzeug_aktiviert_Status und Invertiert automatisch ausgeblendet werden.
  • Alle Eigenschaften anzeigen: Zeigt alle Werkzeugeigenschaften an.

Klicken Sie darauf, um zwischen den drei Sortieroptionen zu wechseln:

  • Standard: Zeigt die Werkzeuge in der Reihenfolge an, in der sie dem Job hinzugefügt wurden, wobei das zuerst hinzugefügte Werkzeug am Listenanfang steht.
  • Alphabetische Reihenfolge: Zeigt die Werkzeuge basierend auf dem Werkzeugnamen in alphabetisch aufsteigender Reihenfolge an.
  • Abhängigkeitsreihenfolge: Zeigt die Werkzeuge basierend auf Abhängigkeiten an, wobei die Eingangseigenschaften über den Ausgangseigenschaften stehen.
Hinweis:
  • Wird ein Werkzeug mit Verknüpfungen zu anderen Werkzeugen im Job gelöscht, werden die Verknüpfungen automatisch gelöscht.
  • Wird ein Werkzeug mit verknüpften Eingangs- und Ausgangseigenschaften im Job kopiert und eingefügt, werden nur die Eingangseigenschaften beibehalten.
Geschlossen Erstellen von Verknüpfungen zwischen Werkzeugen

Sie können Verknüpfungen zwischen den Ausgangs- Eingangseigenschaften eines Werkzeugs erstellen, indem Sie entweder den Ausgangseigenschaftsknoten auf den entsprechenden Eingangseigenschaftsknoten ziehen, oder indem Sie mit der rechten Maustaste auf die Eingangseigenschaft klicken und im Kontextmenü Link von die entsprechende Ausgangseigenschaft wählen.

Hinweis: Beim Verknüpfen von Eigenschaften durch Ziehen und Ablegen wird ein Verknüpfungssymbol angezeigt, und der Mauszeiger wird mit einem dunkelblauen Strich und Pfeil dargestellt. Kann die Eigenschaft nicht verknüpft werden, erscheint der Mauszeiger als Blocksymbol.

Wenn die Werkzeugeigenschaften gebunden sind, wird der nicht mehr verfügbare Eingangseigenschaftsparameter in grau dargestellt, und rechts davon erscheint ein Verknüpfungssymbol [image]. Wenn Sie den Mauszeiger auf dem Verknüpfungssymbol platzieren, erscheint eine QuickInfo mit der Verknüpfungsquelle. Durch Rechtsklick auf das Verknüpfungssymbol wird ein Kontextmenü geöffnet, über das die Verknüpfung gelöst werden kann.

Hinweis: Klicken Sie auf der EasyBuilder-Symbolleiste auf die Schaltfläche Rückgängig (oder drücken Sie STRG+Z), um die Verknüpfung wieder aufzulösen.
Geschlossen Entfernen von Verknüpfungen zwischen Werkzeugen

Entfernen Sie eine Verknüpfung zwischen einer Eingangs- und Ausgangseigenschaft, indem Sie die Eigenschaft mit der Eingangsverknüpfung markieren und entweder die ENTFERNEN-Taste drücken oder im Kontextmenü den Befehl zum Trennen der Verknüpfung wählen.

Hinweis: Klicken Sie auf der EasyBuilder-Symbolleiste auf die Schaltfläche "Rückgängig" (oder drücken Sie STRG+Z), um das Entfernen der Verknüpfung aufzuheben.
Geschlossen Beispiel
Geschlossen Verknüpfen eines Identifizierungswerkzeugs zum Lesen von ID-Codes mit einem Identifizierungswerkzeug "Text lesen"

Ein Identifizierungswerkzeug "Text lesen" kann verwendet werden, um zu überprüfen, ob der von einem Identifizierungswerkzeug zum Lesen von ID-Codes zurückgegebene Text korrekt ist. Das Textlesewerkzeug wird mit der erwarteten übereinstimmenden Zeichenfolge konfiguriert, und der Parameter Modus wird auf Bewertung gesetzt. Durch das Verknüpfen der ausgegebenen Zeichenfolge des Identifizierungswerkzeugs zum Lesen von ID-Codes mit dem Eingabeparameter Match_String des Textlesewerkzeugs überprüft das Textlesewerkzeug, ob der vom Identifizierungswerkzeug zum Lesen von ID-Codes überprüfte Code den korrekten Text enthält.


Teil inspizieren

Im Schritt Teil inspizieren werden die Inspektionswerkzeuge, die zum Erstellen Ihres Jobs verwendet werden, zusammengebaut und integriert. Analysieren Sie das zu inspizierende Teil oder Objekt und bestimmen Sie, welche Merkmalstypen die Anforderungen Ihrer Anwendung erfüllen. Ermitteln Sie außerdem, welche Inspektionswerkzeuge sich am besten zur Lösung Ihres Problems eignen. Weitere Informationen finden Sie unter Merkmale.

Hinweis: Auf den Vision-Sensoren der In-Sight 2000-Serie wird die Registerkarte „Links“ nicht unterstützt.

Die Inspektionswerkzeuge berichten die folgenden Ergebnisse:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren In-Sight 2000-110 und 2000-120/120C | Nur bei Bestanden/Nicht bestanden-Status.
Vision-Sensoren In-Sight 2000-130/130C | Messungs- und Zähl-Inspektionswerkzeuge: Standardergebnisse (numerische Daten) An-/Abwesenheitswerkzeug "Muster": Gut/Schlecht-Status und Mustergüte Andere Werkzeuge: Nur bei Bestanden/Nicht bestanden-Status.
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | Standardergebnisse (keine Einschränkungen)

Hinzufügen, Löschen und Bearbeiten von Inspektionswerkzeugen

Auswählen von Inspektionswerkzeugen

Erstellen von Links zwischen Positions- und Inspektionswerkzeugen


Hinzufügen, Löschen und Bearbeiten von Inspektionswerkzeugen

Geschlossen Hinzufügen eines Werkzeugs

Wählen Sie zum Hinzufügen eines Werkzeugs zu einem Job in der Gruppe Werkzeug hinzufügen ein geeignetes Werkzeug aus, und klicken Sie auf die Schaltfläche Hinzufügen. Doppelklicken Sie alternativ auf das Werkzeug. Sie werden dann zum Festlegen des Merkmals im Bild aufgefordert, entweder über die EasyBuilder-Optionen unter Smart Features, durch Anpassen des Bereichsdiagramms im Bild oder durch Positionieren geometrischer Referenzgrafiken.

Nach der erstmaligen Festlegung des Merkmals können Sie die Steuerelemente des Werkzeugs durch Anpassung der verschiedenen Parameter optimieren.

Hinweis: Sie können mithilfe des Suchfelds dynamisch nach den Werkzeugen suchen.
Geschlossen Löschen eines Werkzeugs

Gehen Sie zum Löschen eines Werkzeugs aus einem Job wie folgt vor:

  • Wählen Sie das Werkzeug auf der Registerkarte Ergebnisse der Palette in der Tabelle Ergebnisse aus und drücken Sie die Taste Entf.
  • Wählen Sie das Werkzeug auf der Registerkarte Ergebnisse der Palette in der Tabelle Ergebnisse aus und klicken Sie auf das Symbol Löschen in der Symbolleiste Standard.
  • Wählen Sie das Werkzeug auf der Registerkarte Ergebnisse der Palette in der Tabelle Ergebnisse aus und wählen Sie im Menü die Option Löschen aus.
Geschlossen Bearbeiten eines Werkzeugs

Gehen Sie zum Bearbeiten eines Werkzeugs in einem beliebigen EasyBuilder-Schritt wie folgt vor:

  • Doppelklicken Sie auf das Werkzeug in der Tabelle Ergebnisse. Diese Tabelle befindet sich auf der Registerkarte Ergebnisse der Palette.
  • Klicken Sie mit der rechten Maustaste in der Tabelle Ergebnisse auf das Werkzeug, und wählen Sie im Menü die Option zum Aufrufen und Bearbeiten des gewünschten Werkzeugs aus.

Gehen Sie zum Bearbeiten eines Werkzeugs in den Schritten Teil suchen oder Teil inspizieren wie folgt vor:

  • Wählen Sie das Bereichsdiagramm im Bild aus.
  • Doppelklicken Sie auf das Werkzeug in der Tabelle Ergebnisse. Diese Tabelle befindet sich auf der Registerkarte Ergebnisse der Palette.
  • Klicken Sie mit der rechten Maustaste in der Tabelle Ergebnisse auf das Werkzeug, und wählen Sie im Menü die Option zum Aufrufen und Bearbeiten des gewünschten Werkzeugs aus.
  • Doppelklicken Sie in der Ergebnistabelle im Anwendungsschritt Job ausführen auf das Werkzeug.
Hinweis:
  • Falls Ihr In-Sight-Vision-System das Aufrufen der Tabellenansicht-Programmierumgebung von In-Sight Explorer unterstützt, wird im Kontextmenü (Rechtsklick) die Option Dieses Werkzeug in der Tabellenansicht aufrufen angezeigt. Die Verwendung der Tabellenansicht-Programmierumgebung wird nur empfohlen, wenn Sie mit dieser Umgebung vertraut sind und ihre Funktionsweise verstehen. Lesen Sie die entsprechenden Informationen in der Online-Hilfe zu In-Sight Explorer sorgfältig durch, bevor Sie fortfahren.
  • Ordnen Sie die Werkzeuge in der Tabelle Ergebnisse neu, indem Sie sie mittels Drag&Drop in die gewünschte Reihenfolge bringen. Das Neuordnen ist in der Tabelle mit den Ergebnissen zu Job ausführen und in der Tabelle mit den Palettenergebnissen möglich und wird in beiden Tabellen übernommen. Das Sortieren mittels Drag&Drop ist nur aktiviert, wenn die Spalte Werkzeugabhängigkeitsgrafiken ausgewählt ist (diese Spalte ist standardmäßig ausgewählt). Wählen Sie die Spalte ein zweites Mal aus, um die Reihenfolge umzukehren. Das Neuordnen ist nicht möglich, wenn der Job nahe am Jobumfanglimit liegt.
Hinweis: Verfügt der Job nicht über genug Platz, um weitere Werkzeuge hinzuzufügen, behalten Sie die Anwendungsschritte Suchen oder Teil inspizieren bei, und wählen Sie im Menü Sensor die Option Jobumfanglimit. Passen Sie im Dialogfeld den Jobumfang an, um weitere Werkzeuge hinzufügen zu können. Das Anpassen des Jobumfanglimits eines In-Sight-Vision-Systems erfordert das Aus- und Einschalten des Vision-Systems, wodurch alle Job- und Einstellungsdateien aus dem nichtflüchtigen Flash-Speicher gelöscht werden. Speichern bzw. sichern Sie den Job, und fahren Sie anschließend fort.

Merkmale

Regionen

EasyBuilder Smart-Optionen


Merkmale

Im Bereich Vision werden Merkmale auch als "Analyseobjekte eines Bildes" bezeichnet. Zudem sind Vision-Inspektionen auf die in einem Bild gefundenen Merkmalstypen ausgerichtet.

Zu den Merkmalstypen im Schritt Teil inspizieren gehören:

Geschlossen Kanten

Übergangsbereiche zwischen hellen und dunklen Pixeln; in horizontaler oder vertikaler Richtung oder kreisförmig oder gewölbt. Kanten können Elemente wie die Enden von Teilen, Pins einer Platine, das Gewinde einer Schraube, der Boden einer Flasche oder die Spirale einer Sprungfeder sein. Diese Merkmalstypen lassen sich im Allgemeinem am schnellsten und einfachsten erkennen.

Geschlossen Beispiel für Kanten

Geschlossen Kreise, Linien und Punkte

Geometrische Standardbezüge, die zum Berechnen von Abmessungen verwendet werden können.

Geschlossen Beispiel für Kreise, Linien und Punkte

Geschlossen Muster

Muster können aus einer einfachen Gruppe aus sich wiederholenden Formen bis hin zu komplexen Konfigurationen wie Logos oder Beschriftungen bestehen. Muster sind der zuverlässigste Merkmalstyp und bieten die größte Flexibilität bei Drehungen, Bewegungen und Skalierungsunterschieden. Die Inspektion von Mustern dauert jedoch im Allgemeinen am längsten.

Geschlossen Beispiel für Muster

Geschlossen Blobs

Blobs bestehen aus einer Gruppe aus dunklen bzw. hellen und zusammenhängenden Pixeln, beispielsweise einem Klecks weißer Farbe auf einem schwarzen Hintergrund oder einer schwarzen Schraube auf einem weißen Fließband. Sie zählen zu den Merkmalen, die schneller gefunden werden, und ermöglichen mehr Variationen der Form und Größe des Blobmerkmals. Sie besitzen jedoch beschränkte Winkeldaten.

Geschlossen Beispiel für Blobs

Geschlossen Text

Alphanumerische Textzeichenfolgen.

Geschlossen Beispiel für Text

Geschlossen Codes

1D-Barcodes und 2D-Matrixcodes sowie Symbole mit alphanumerischen Datenzeichenfolgen.

Geschlossen Beispiel für Codes

Geschlossen Sicke

Eine Sicke ist ein durchgehendes, aber nicht unbedingt geschlossenes Kantenpaar, das die Grenze zwischen zwei Bereichen unterschiedlicher Pixelwerte festlegt. Sie werden durch einen Breitenwert definiert. Als Sickenpfad werden beispielsweise ein geschweißter Metallpfad, ein Klebstoffpfad oder ein Dichtungspfad bezeichnet.

Geschlossen Beispiel für Sicke


Bereiche

Bereiche definieren einen Bereich des Bildes, in dem das Positionswerkzeug oder Inspektionswerkzeug einen entsprechenden Vorgang ausführt. Dieser Bereich wird auch "relevanter Bereich" genannt.

In EasyBuilder werden abhängig vom verwendeten Werkzeugtyp (Positionswerkzeug und Inspektionswerkzeug) verschiedene Bereichstypen verwendet. EasyBuilder verwendet die folgenden Bereichstypen:

  • Rechteck
  • Kreis
  • Annulus
  • Polygon
  • Maskierter Bereich
  • Polylinienpfad

Ringförmige Bereiche

Kreisförmige Bereiche

Maskierte Bereiche

Polygonförmige Bereiche

Polylinienpfadbereiche

Rechteckige Bereiche


Maskierter Bereich

Der maskierte Bereich wird zur Definition eines Bildbereichs verwendet, für den die Kantenanalyse durchgeführt wird. Dieser Bereich wird gemeinsam mit Caliperarrays für die exakte Kantenerkennung verwendet.

Geschlossen Maskierter Bereich – Legende

Steuerelemente | Beschreibung
1 | Größenveränderliche Endpunktbegrenzung (x4) | Definiert die vier Ecken des rechteckigen Bereichs. Klicken Sie auf eine Endpunktbegrenzung, um den Bereich von einer Ecke aus größenmäßig anzupassen.
2 Maske

Definiert den Bildbereich, für den KEINE Bildanalyse durchgeführt wird. Innerhalb des Bereichs kann die Maske verschoben und ihre Größe verändert werden. Insgesamt können einem Bereich 99 Masken hinzugefügt werden. Eine Maske wird am Anfang des Bereichs hinzugefügt (sofern keine anderen Masken hinzugefügt wurden) oder hinter der zuvor hinzugefügten Maske.

Hinweis: Masken dürfen nicht überlappen. Bei einer Überlappung der Masken wird automatisch ein 1-Pixel-Puffer eingefügt, um die Überlappung zu verhindern.
3 | Scanrichtungsanzeige (x2) | Definiert, in welcher Richtung der maskierte Bereich nach Merkmalen durchsucht wird.
4 | Kantenerkennungsanzeige | Definiert die Fläche innerhalb des Bereichs, in der Kantenübergänge erkannt werden. Ermöglicht auch das Hinzufügen neuer Masken zum Bereich.
5 | Rotationsziehgriff | Ermöglicht die Rotation des Bereichs um 360°.
6 | Krümmungsziehpunkt | Ermöglicht die bogen- oder kreisförmige Krümmung des rechteckigen Bereichs.
Geschlossen Maskierter Bereich – Mausaktionen

Durch Platzieren des Mauszeigers über verschiedenen Teilen des Bereichs wird dieser automatisch umgewandelt, um die folgenden Aktionen zu ermöglichen:

Mauszeigersymbol | Beschreibung
 | Ermöglicht das Ziehen des gesamten maskierten Bereichs an eine beliebige Stelle im Bild.
 | Ermöglicht das Skalieren des gesamten Bereichs in horizontaler oder vertikaler Richtung. Wird auch zur Größenanpassung der Maske verwendet.
 | Ermöglicht je nach Position des Mauszeigers zwei separate Aktionen. Durch Platzieren des Mauszeigers auf den Rotationsziehgriff können Sie den Bereich von seiner aktuellen Ausrichtung um 360° drehen. Durch Platzieren des Mauszeigers auf den Krümmungsziehpunkt können Sie die Form des Bereichs zur Erkennung kreisförmiger Kantenmerkmale bogen- oder ringförmig anpassen.
 | Ermöglicht das Ziehen der Maske im Bereich.
 | Ermöglicht das Hinzufügen oder Löschen einer Maske aus dem Bereich. Wird dieses Symbol angezeigt, klicken Sie mit der rechten Maustaste, um ein Menü mit zwei Optionen zu öffnen: Maske hinzufügen oder Maske löschen.


Polylinienpfadbereiche

Der maskierte Polylinienpfadbereich wird zur Definition eines Bildbereichs verwendet, für den die Kantenanalyse durchgeführt wird. Dieser Bereich wird gemeinsam mit Caliperarrays für die exakte Kantenerkennung verwendet.

Hinweis:
  • Bei der grafischen Bearbeitung ist ein Kontextmenü verfügbar, mit dem Sie Pfadsegmente hinzufügen oder löschen können.
  • Für den Polylinienpfadbereich ist auf der EasyBuilder-Symbolleiste die Schaltfläche Bereich maximieren deaktiviert.
Geschlossen Polylinienpfadbereich – Legende

 | Steuerelemente | Beschreibung
1 | Polylinienpfad-Scheitel (x3) | Legt den Pfad der Polyliniensegmente fest. Klicken Sie auf einen Scheitel, um die Polylinie zu positionieren.
2 | Scanrichtungsanzeige (x2) | Definiert, in welcher Richtung der Polylinienpfadbereich nach Merkmalen durchsucht wird.
3 | Polylinienpfad | Zeigt die grafische Darstellung der Polylinie an.
4 | Rotationsziehgriff | Ermöglicht die Rotation des Bereichs um 360°.
Geschlossen Polylinienpfadbereich – Mausaktionen

Durch Platzieren des Mauszeigers über verschiedenen Teilen des Bereichs wird dieser automatisch umgewandelt, um die folgenden Aktionen zu ermöglichen:

Mauszeigersymbol | Beschreibung
 | Ermöglicht das Ziehen des gesamten Polylinienpfadbereichs an eine beliebige Stelle im Bild.
 | Ermöglicht das Skalieren des gesamten Bereichs in horizontaler oder vertikaler Richtung. Wird auch zur Größenanpassung der Maske verwendet.
 | Ermöglicht eine 360°-Drehung des Bereichs ab der aktuellen Ausrichtung.
 | Ermöglicht das Verschieben des Polylinienpfads im Bereich.
 | Ermöglicht das Hinzufügen von Punkten zum Polylinienpfad. Einer Polylinie können bis zu 99 Punkte hinzugefügt werden. Nachdem einer Polylinie 99 Punkte hinzugefügt wurden, wird diese Option deaktiviert.


EasyBuilder Smart-Optionen

EasyBuilder Smart-Optionen – Smart Features, Smart Limits und Smart-Einstellungen – beschleunigen die Bereitstellung Ihrer Anwendung, indem sie automatisch intelligente Standardschwellenwerte bestimmen, die auf den Anforderungen des Werkzeugs und der Anwendung basieren.

Hinweis: Verwenden Sie beim Entwickeln von Anwendungen in EasyBuilder ein Bild des Teils oder Objekts mit dem Ergebnis "Bestanden", damit EasyBuilder die entsprechenden Standardschwellenwerte für die Anwendung festlegen kann.
  • Smart Features
  • Smart Limits
  • Smart-Einstellungen

Smart Features

Smart Limits

Smart-Einstellungen


Smart Features

Bestimmte Positions- und Inspektionswerkzeuge extrahieren automatisch die relevanten Merkmale aus dem Bild, basierend auf dem ausgewählten Werkzeug, sodass Sie die entsprechenden Merkmale für die Inspektion einfach per Point-and-Click auswählen können.

Wenn Sie eines dieser Werkzeuge zum Job hinzufügen, untersucht das Werkzeug automatisch das Bild und ermittelt, welche Merkmale mit den Anforderungen des Werkzeugs übereinstimmen. Das Werkzeug für Kantenpositionen gibt beispielsweise nur horizontale oder vertikale Kantenmerkmale zurück, und die Messungswerkzeuge Kreisdurchmesser und Kreiskonzentrizität geben nur kreisförmige Merkmale zurück.

Geschlossen Beispiel
Geschlossen Smart Features – Kanten

Geschlossen Smart Features – Kreise

Wenn ein Merkmal zuvor nicht definiert wurde, wird es in hellblau hervorgehoben. Vorhandene Merkmale (z. B. Muster, Flächenmittelpunkte von Blobs, Kanten oder Kreise, die durch andere Werkzeuge vom Typ Teil suchen oder Teil inspizieren definiert wurden) werden dagegen grün hervorgehoben.

Geschlossen Beispiel

Smart Features – Neu ermittelt und bereits zuvor definiert

Klicken Sie einfach auf das Merkmal, das Sie verwenden möchten. EasyBuilder erstellt dann automatisch den entsprechenden Bereich, wenn dieser nicht bereits zuvor definiert wurde.

Hinweis:

Gehen Sie wie folgt vor, wenn das gewünschte Merkmal (Feature) nicht als Smart Feature-Option verfügbar ist:

  • Wählen Sie ein verfügbares Smart Feature, und positionieren Sie den automatisch erstellten Bereich über dem Merkmal, das Sie stattdessen verwenden möchten. Passen Sie anschließend die Werkzeugparameter an, bis das gewünschte Merkmal ordnungsgemäß erkannt wird.
  • Definieren Sie zuerst das zu verwendende Merkmal mit einem entsprechenden An-/Abwesenheitswerkzeug oder Geometriewerkzeug. Fügen Sie das Werkzeug dann erneut hinzu, und wählen Sie das definierte Merkmal aus.


Smart Limits

Die Werkzeuge Teil inspizieren mit einer Registerkarte Bereichsbeschränkungen ermitteln automatisch die Beschränkungen Maximum und Minimum.

Hinweis: Damit Sie beim Verwenden von Werkzeugen mit Smart Limits die besten Ergebnisse erzielen, sollten Sie damit beginnen, die Werkzeuge auf Grundlage Ihres Bildes mit dem Ergebnis "Bestanden" zu trainieren.

Wenn ein Werkzeug mit einer Registerkarte Bereichsbeschränkungen dem Job hinzugefügt wird, untersucht das Werkzeug automatisch das Bild und ermittelt basierend auf den Werkzeuganforderungen die entsprechenden Beschränkungen Maximum und Minimum. Beispielsweise betragen die Bereichsbeschränkungen Maximum und Minimum der Messungswerkzeuge Abstand und Winkel ±5 % des Wertes für Abstand und Winkel, während die Bereichsbeschränkungen des Zählwerkzeugs "Kanten" durch die Anzahl der Merkmale bestimmt werden, die im anfänglichen Bild gefunden werden.


Smart-Einstellungen

Die Werkzeuge Teil suchen und Teil inspizieren, die Kreise und Kanten definieren, erhöhen den Parameter Kontrast automatisch, bis ein Kantenmerkmal gefunden wurde. Dies ermöglicht ein schnelles Festlegen der Schwellenwerte basierend auf der Anwendung.

Hinweis: Damit Sie beim Verwenden von Werkzeugen mit Smart Limits die besten Ergebnisse erzielen, sollten Sie damit beginnen, die Werkzeuge auf Grundlage Ihres Bildes mit dem Ergebnis "Bestanden" zu trainieren.

Wenn dem Job ein Positions- oder Inspektionswerkzeug für Kreise oder Kanten hinzugefügt wird, untersucht das Tool automatisch das Bild, ermittelt die entsprechende Einstellung für den Kontrast und senkt den Wert um zwei Stufen, um den Schwellenwert festzulegen. Die Standardeinstellung für den Kontrast ist 25. Der Mindestwert lautet 5.


Auswählen von Inspektionswerkzeugen

Die Werkzeuge Teil inspizieren sind in Inspektionstypen unterteilt:

Geschlossen An-/Abwesenheitswerkzeuge

Die An-/Abwesenheitswerkzeuge dienen zum Ermitteln, ob ein Merkmal im Bild vorhanden ist.

An-/Abwesenheitswerkzeuge | In-Sight Vision-Systeme (Firmware 5.x.x) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Helligkeit | X |  | X | X | X | X
Kontrast | X |  | X | X | X | X
PatMax RedLine-Muster 1 | X |  |  |  |  |
PatMax-Muster | X |  |  |  |  |
Muster | X | X | X | X | X | X
Pixelanzahl 2 | X |  | X | X | X | X
Farbpixelanzahl 3 | X |  | X | X | X |
Blob 1 | X |  |  |  | X |
Farb-Blob 2 | X |  |  |  | X |
Kante | X |  |  | X | X | X
Kreis | X |  |  | X | X | X
Schärfe | X |  |  |  | X |
1Nur In-Sight-Firmware 5.x.x. 2Nur Monochrom-Modelle. 3Nur Farbmodelle.
Geschlossen Messwerkzeuge

Die Messungswerkzeuge dienen zum Messen von Abständen, Durchmessern, Winkeln und von Merkmalsflächen im Bild.

Messwerkzeuge | In-Sight Vision-Systeme | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Abstand | X |  |  | X | X | X
Winkel, | X |  |  | X | X | X
Blobbereich 1 | X |  |  |  | X |
Blobbereiche (1-10) 1 | X |  |  |  | X |
Farb-Blob-Bereich 2 | X |  |  |  | X |
Farb-Blob-Bereiche (1-10) 2 | X |  |  |  | X |
Kreisdurchmesser | X |  |  | X | X | X
Kreiskonzentrizität | X |  |  |  |  | X
Radius messen | X |  |  |  | X | X
Min./Max. Punkte | X |  |  |  |  |
1Nur Monochrom-Modelle. 2Nur Farbmodelle.
Geschlossen Zählwerkzeuge

Die Zählwerkzeuge dienen zum Zählen der Merkmalstypen im Bild.

Zählwerkzeuge | In-Sight Vision-Systeme | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Blobs 1 | X |  |  |  | X |
Farb-Blobs 2 | X |  |  |  | X |
Kanten | X |  |  | X | X | X
Kantenpaare | X |  |  |  |  |
PatMax RedLine-Muster 3 | X |  |  |  |  |
PatMax-Muster | X |  |  |  |  |
Patterns | X |  |  | X | X | X
1Nur Monochrom-Modelle. 2Nur Farbmodelle. 3Nur In-Sight-Firmware 5.x.x.
Geschlossen Identifizierungswerkzeuge

Die Identifizierungswerkzeuge dienen zur Identifizierung und Prüfung von 1D- und 2D-Codes und Zeichen, alphanumerischem Text, Mustermerkmalen und Farben im Bild.

Identifizierungswerkzeuge | In-Sight Vision-Systeme (Firmware 5.x.x) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
1D-Code lesen | X |  |  |  |  |
1D-Codes lesen (1-20) | X |  |  |  |  |
2D-Code lesen | X |  |  |  |  |
2D-Codes lesen (1-20) | X |  |  |  |  |
Postleitzahl lesen | X |  |  |  |  |
ID-Codes lesen 1 |  |  |  |  |  |
Text lesen 1 |  |  |  |  |  |
Text lesen (OCRMax) | X |  |  |  | X |
PatMax RedLine-Muster (1-10) 2 | X |  |  |  |  |
PatMax-Muster (1-10) | X |  |  |  |  |
Muster (1-10) | X |  |  |  | X |
Farbe 3 | X |  |  |  |  |
Farbmodell 2 | X |  |  |  |  |
1Die Werkzeuge „ID-Codes lesen“ und „Text lesen“ sind ältere Werkzeuge und werden auf Systemen mit In-Sight Explorer ab Version 4.7.0 nicht unterstützt. 2Nur In-Sight-Firmware 5.x.x. 3Nur Farbmodelle.
Geschlossen Geometriewerkzeuge

Die Geometriewerkzeuge dienen zum Erstellen geometrischer Referenzen im Bild. Diese können von anderen Inspektionswerkzeugen, beispielsweise von Mathematik- und Logikwerkzeugen oder Messungswerkzeugen, verwendet werden.

Geometriewerkzeuge | In-Sight Vision-Systeme | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Punkt-zum-Punkt: Line | X |  |  |  | X | X
Punkt-zum-Punkt: Mittelpunkt | X |  |  |  | X | X
Punkt-zum-Punkt: Abmessung | X |  |  |  | X | X
Senkrechte Linie | X |  |  |  |  | X
Linie-Schnittpunkt | X |  |  |  | X | X
Winkel halbieren | X |  |  |  |  | X
Linie aus N Punkten | X |  |  |  |  | X
Kreis aus N Punkten | X |  |  |  |  | X
Kreis-Linie-Schnittpunkt | X |  |  |  |  | X
Benutzerdefinierter Punkt | X |  |  |  |  | X
Benutzerdefinierte Linie | X |  |  |  |  | X
An Kreis anpassen | X |  |  |  |  |
An Linie anpassen | X |  |  |  |  |
Geschlossen Mathematik- und Logikwerkzeuge

Die Mathematik- und Logikwerkzeuge dienen zum konditionellen Verknüpfen von Werkzeugen basierend auf Werkzeug- und Jobdaten, zum Durchführen mathematischer Operationen mit Ergebnissen von Werkzeugen, zum Verarbeiten von Statistiken von Werkzeugen, zum Kombinieren von Werkzeugen zu Gruppen und zum Erstellen von Schritten für die Reihenfolge während eines Vorgangs.

Mathematik- und Logikwerkzeuge | In-Sight Vision-Systeme | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Mathe | X |  |  |  | X | X
Logik | X | X | X | X | X | X
Trend | X |  |  |  |  | X
Statistik: | X |  |  |  |  | X
Gruppieren | X |  |  | X | X | X
Sequenz | X |  |  |  |  |
Punkt berechnen | X |  |  |  |  | X
Variablen | X |  |  |  | X | X
Roboterführung | X |  |  |  |  |
Geschlossen Darstellungswerkzeuge

Die Darstellungswerkzeuge werden verwendet, um Grafiken im Bild auf der Grundlage von mathematischen Ausdrücken zu berechnen.

Darstellungswerkzeuge | In-Sight Vision-Systeme | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Bogen darstellen | X |  |  |  | X | X
Kreis darstellen | X |  |  |  | X | X
Kreuz darstellen | X |  |  |  | X | X
Linie darstellen | X |  |  |  | X | X
Punkt darstellen | X |  |  |  | X | X
Bereich darstellen | X |  |  |  | X | X
Zeichenfolge darstellen | X |  |  |  | X | X
Geschlossen Filterwerkzeuge für Bilder

Die Filterwerkzeuge für Bilder dienen zum Vergrößern eines Bildes oder Bildbereichs zur weiteren Bildanalyse.

Filterwerkzeuge für Bilder | In-Sight Vision-Systeme (Firmware 5.x.x) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Filter | X |  |  |  | X |
Nachbar 1 |  |  |  |  |  |
Szenenkorrektur 1 |  |  |  |  |  |
Punkt 1 |  |  |  |  |  |
Farbe zu Graustufe 2 | X |  |  |  |  |
Farbe zu Binär 2 | X |  |  |  |  |
Umrechnungen | X |  |  |  |  |
Vergleichen | X |  |  |  |  |
1Wird nur auf In-Sight Vision-Systemen mit Firmwareversion 4.x.x unterstützt. 2Nur Farbmodelle.
Geschlossen Werkzeuge zur Fehlererkennung

Die Werkzeuge zur Fehlererkennung werden verwendet, um festzulegen, ob ein Teil oder Objekt mit einem Fehler (z.B. Riss, Falte, Delle, Zwischenraum, Kerbe oder Kratzer) produziert wurde.

Hinweis: Die Werkzeuge zur Fehlererkennung werden nur auf den In-Sight-Vision-Systemen unterstützt.
  • Flächenfehler
  • Kante
  • Kantenpaar
  • Kantenbreite
  • Sickensuche
  • Sickenverfolgung
Geschlossen Kalibrierungswerkzeuge

Die Kalibrierungswerkzeuge werden zur Erstellung einer Kalibrierungsdatei verwendet, die zwischen Jobs aufgeteilt werden kann.

Kalibrierungswerkzeuge | In-Sight Vision-Systeme | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Roboter | X |  |  |  |  |
N-Punkt | X |  |  |  |  | X
Sequenzielle N-Punkt-Kalibrierung | X |  |  |  |  |

An-/Abwesenheitswerkzeuge

Messwerkzeuge

Zählwerkzeuge

Identifizierungswerkzeuge

Geometriewerkzeuge

Mathematik- und Logikwerkzeuge

Darstellungswerkzeuge

Filterwerkzeuge für Bilder

Kalibrierungswerkzeuge


An-/Abwesenheitswerkzeuge – Helligkeit

Das An-/Abwesenheitswerkzeug „Helligkeit“ überprüft basierend auf einem durchschnittlichen Grauskala-Wert (der Helligkeit) der Pixel im Bereich, ob ein Merkmal an- oder abwesend ist, und gibt den ermittelten Wert zurück.

Das Werkzeug gibt die folgenden Ergebnisse zurück:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren der In-Sight 2000-Serie 1xx (110, 120, 130) | Nur bei Bestanden/Nicht bestanden-Status.
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | Standardergebnisse (keine Einschränkungen)

Das An-/Abwesenheitswerkzeug „Helligkeit“ ist in Situationen nützlich, in denen ein Merkmal eines guten Teils sehr viel dunkler oder heller als das Merkmal eines schlechten Teils ist. Die Zu- oder Abnahme der Helligkeit eines Merkmals ist ein guter Hinweis auf die An- oder Abwesenheit eines Teils oder Objekts. So lässt sich beispielsweise die An- oder Abwesenheit eines hellen oder dunklen Flaschendeckels rasch ermitteln, indem die Helligkeit im Bereich gemessen wird.

Tipp: Weitere Informationen zur Auswahl eines Merkmals finden Sie unter Auswählen eines Merkmals.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des An-/Abwesenheitswerkzeugs "Helligkeit"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereichstyp festlegen und im Bild konfigurieren, um das Merkmal zu isolieren:

  1. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp ein: Rechteck (Standard), Kreis, Annulus oder Polygon. Platzieren Sie den Bereich über dem Merkmal, und stellen Sie sicher, dass die Bereichsbegrenzungen das Merkmal abdecken. Die Bereichsbegrenzungen sollten so konfiguriert sein, dass sie nur das zu messende Merkmal abdecken – wenn der Bereich größer als das Merkmal ist, kann dies zu ungenauen Ergebnissen führen, da auch die Pixel im Hintergrund berechnet werden. Erstellen Sie zur Verbesserung der Leistung des Werkzeugs kleinere Bereiche. Je größer ein Bereich, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich das Merkmal in jedem Bild nahezu an derselben Position befindet oder der Bereich groß genug ist für die erwartete Bewegung des Merkmals.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

Auswählen eines Merkmals


Auswählen eines Merkmals

Beachten Sie bei der Auswahl eines Merkmals für eine Inspektion die folgenden Kriterien, um die besten Ergebnisse zu erzielen:

  • Wenn Sie keinen Lageausgleich verwenden, müssen Sie sicherstellen, dass sich das Merkmal in jedem Bild nahezu an derselben Position befindet oder der Bereich groß genug ist für die erwartete Positionsänderung des Merkmals.
  • Das Helligkeitswerkzeug eignet sich für Anwendungen, bei denen das inspizierte Merkmal einen Graustufenwert besitzt, wenn es vorhanden ist (z. B. Schwarz), und den entgegengesetzten Wert, wenn es nicht vorhanden ist.
Geschlossen Beispiel


Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Helligkeit"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Vision-Sensoren der In-Sight 2000-Serie

  • Gruppenfeld Werkzeug bearbeiten

In-Sight Vision-Systeme

Das Einstellungsfenster des An-/Abwesenheitswerkzeugs "Helligkeit" umfasst folgende Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Bereichsbeschränkungen"
  • Registerkarte „Histogramm“
  • Registerkarte „Zusammengesetzter Bereich“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Vision-Sensoren der In-Sight 2000-Serie

In-Sight-Vision-Systeme


Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Helligkeit"

Hinweis: Dieses Thema beschreibt die Benutzeroberfläche, wenn man mit einem Vision-Sensor der In-Sight 2000-Serie verbunden ist. Wenn eine Verbindung mit In-Sight-Vision-Systemen besteht, finden Sie weitere Informationen im Abschnitt „In-Sight-Vision-Systeme“ von Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Helligkeit".

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Geschlossen Anzeige von Bestanden/Nicht bestanden

Zeigt einen grünen Kreis [image] oder ein rotes Rechteck [image] zur Angabe des Erfolgs bzw. Fehlschlags an.

Geschlossen Helligkeitsanzeige und Schieberegler für Bestanden-Bereich

Stellt die minimale und maximale Helligkeitsstufen ein. Sie können die Werte durch Bewegen der Schieberegler oder durch Eingeben von Werten in die entsprechenden Bearbeitungsfelder einstellen.

Tipp: Sie können den Schieberegler auch mithilfe der PFEILTASTEN (NACH-OBEN, NACH-UNTEN-, NACH-LINKS- und NACH-RECHTS) bewegen.
  • Linker Schieberegler: Legt die minimal akzeptable durchschnittliche Graustufengrenze fest (0 - 255).
  • Rechter Schieberegler: Legt die maximal akzeptable durchschnittliche Graustufengrenze fest (0 - 255).
  • Ergebnisanzeige: Zeigt den durchschnittlichen Graustufenwert der Pixel im Bereich an. Eine Messanzeige zwischen dem rechten und dem linken Schieberegler interpretiert das Werkzeug als Bestanden und die Ergebnisanzeige wird grün. Andernfalls gibt das Tool Unbestanden und die Anzeige wird rot
Gut
Schlecht
Hinweis: Fährt man mit der Maustaste über den Schieberegler, werden die Werte Ergebnis und Schwelle angezeigt.
Geschlossen Schaltfläche Automatisch

Setzt die Bereichsbeschränkungen auf die aktuellsten Werkzeugergebnisse, +/- 10% des maximalen Ergebniswertes vom Werkzeug. Als Beispiel, wenn das maximale Ergebniswert vom Werkzeug 255 ist und das aktuellste Werkzeugergebnis 150 ist, hat ein Klicken auf die Schaltfläche Automatisch die Folge, dass die minimale Bereichsbeschränkung auf 125 (=150 - 25), und die maximale Bereichsbeschränkung auf 175 (=150 + 25) gestellt wird.

Geschlossen Ergebnis umkehren

Wenn aktiviert, gibt das Wekzeug eine Falsch zurück, falls das Ergebnis zwischen die Bereichsbeschränkungen fällt. (Standard = Aus)

Job gut/schlecht | Invertieren | Job gut/schlecht
Job gut/schlecht | (Invertieren) | Job gut/schlecht
Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Name

Legt den Namen des Helligkeits-Werkzeuges fest. Der Standardname lautet „Helligkeit_1“ (wenn es das erste Werkzeug „Muster“ ist, das dem Job hinzugefügt wurde, andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Helligkeit_2“, „Helligkeit_3“ usw.).

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Aktiviert

Definiert, wann und ob das Inspektionswerkzeug ausgeführt werden soll (Standardeinstellung ist „Ein“).

  • Wählen Sie „Aus“, wenn Sie das Werkzeug deaktivieren möchten.
  • Wählen Sie eine Eingangsleitung aus, wenn das Werkzeug an eine bestimmte diskrete Eingangsleitung gebunden sein soll, wo es ein- oder ausgeschaltet werden kann (ein High-Signal, 1, bedeutet „Ein“, ein Low-Signal, 0, bedeutet „Aus“). Durch die Verbindung des Werkzeugs mit einem Eingang kann mithilfe eines Kontrollsystems (z. B. SPS) festgelegt werden, welche Werkzeuge wann ausgeführt werden sollen.
Geschlossen Vorrichtung

Gibt eine Vorrichtung für das Werkzeug an. Wird das Steuerelement Vorrichtung aktiviert, verwandelt sich die Schaltfläche Vorrichtung in ein Orange.

Hinweis: Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.
Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeug „Helligkeit“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Brightness_1“, sofern es sich um das erste Helligkeitswerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Brightness_2“, „Brightness_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeug "Helligkeit" - Registerkarte "Bereichsbeschränkungen"

Geschlossen Minimum

Definiert den minimal zulässigen durchschnittlichen Graustufenwert (0 bis 255). Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Helligkeit

Zeigt den durchschnittlichen Graustufenwert der im Bereich gefundenen Pixel an (0 bis 255). Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Geschlossen Maximum

Definiert den maximal zulässigen durchschnittlichen Graustufenwert (0 bis 255). Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert - Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
  • Aktiviert - Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


An-/Abwesenheitswerkzeug "Helligkeit" – Registerkarte "Histogramm"

Die Registerkarte Histogramm ist ein Histogramm der Graustufenwerte für die Pixel in einem bestimmten Bereich.

  • Die X-Achse des Diagramms steht für die Gesamtzahl der Graustufenwerte (0 bis 255 oder insgesamt 256 Grauschattierungen).
  • Die Y-Achse des Diagramms gibt die Anzahl der Pixel eines bestimmten Graustufenwerts an. Zudem erfolgt die Skalierung durch Anzeige des Graustufenwerts mit der höchsten Anzahl an Pixeln.
  • Die drei blauen vertikalen Linien zeigen die Pixel-Graustufenwerte "Minimum", "Helligkeit" und "Maximum" an.
Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


An-/Abwesenheitswerkzeug "Helligkeit" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


An-/Abwesenheitswerkzeuge – Kontrast

Das An-/Abwesenheitswerkzeug „Kontrast“ bestimmt, ob ein Merkmal an- oder abwesend ist, basierend auf dem Kontrastwert (der Differenz zwischen dem durchschnittlichen Grauskalawert oberhalb des Grenzwerts und dem durchschnittlichen Grauskalawert unterhalb des Grenzwerts) zwischen Merkmalen der Pixel im Bereich, und gibt diesen Wert zurück.

Das Werkzeug gibt die folgenden Ergebnisse zurück:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren der In-Sight 2000-Serie 1xx (110, 120, 130) | Nur bei Bestanden/Nicht bestanden-Status.
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | Standardergebnisse (keine Einschränkungen)

Das An-/Abwesenheitswerkzeug „Kontrast“ ist in Situationen nützlich, in denen das Merkmal eines guten Teils sehr deutliche helle und/oder dunkle Bereiche im Vergleich zu denen eines schlechten Teils aufweist. Beispiel: Prüfen der Anwesenheit von dunklem Druck auf einem weißen Etikett.

Tipp: Weitere Informationen zur Auswahl eines Merkmals finden Sie unter Auswählen eines Merkmals.

Einrichtung des Werkzeugs


Einrichten des An-/Abwesenheitswerkzeugs "Kontrast"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereichstyp festlegen und im Bild konfigurieren, um das Merkmal zu isolieren:

  1. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp ein: Rechteck (Standard), Kreis, Annulus oder Polygon. Platzieren Sie den Bereich über dem Merkmal, und stellen Sie sicher, dass die Bereichsbegrenzungen das Merkmal abdecken. Die Bereichsbegrenzungen sollten so konfiguriert sein, dass sie nur das zu messende Merkmal abdecken – wenn der Bereich größer als das Merkmal ist, kann dies zu ungenauen Ergebnissen führen, da auch die Pixel im Hintergrund berechnet werden. Erstellen Sie zur Verbesserung der Leistung des Werkzeugs kleinere Bereiche. Je größer ein Bereich, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich das Merkmal in jedem Bild nahezu an derselben Position befindet oder der Bereich groß genug ist für die erwartete Bewegung des Merkmals.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

Auswählen eines Merkmals

Anpassen der Werkzeugparameter


Auswählen eines Merkmals

Beachten Sie bei der Auswahl eines Merkmals für eine Inspektion die folgenden Kriterien, um die besten Ergebnisse zu erzielen:

  • Wenn Sie keinen Lageausgleich verwenden, müssen Sie sicherstellen, dass sich das Merkmal in jedem Bild nahezu an derselben Position befindet oder der Bereich groß genug ist für die erwartete Positionsänderung des Merkmals.
  • Das Kontrastwerkzeug eignet sich für Anwendungen, bei denen das inspizierte Merkmal bei Vorhandensein eine Mischung von Graustufenwerten und bei Nichtvorhandensein einheitliche Graustufenwerte enthält.
  • Falls Ihre Anwendung eine feinere Differenzierung zwischen den Helligkeits- und -Kontrastunterschieden erfordert, sollten Sie ggf. das Werkzeug "Pixelanzahl" verwenden. Dieses Werkzeug ermöglicht eine genauere Messung solcher Unterschiede als das Kontrastwerkzeug.
Geschlossen Beispiel


Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Kontrast"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Vision-Sensoren der In-Sight 2000-Serie

  • Gruppenfeld Werkzeug bearbeiten

In-Sight Vision-Systeme

Das Einstellungsfenster des An-/Abwesenheitswerkzeugs "Kontrast" umfasst folgende Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Bereichsbeschränkungen"
  • Registerkarte „Histogramm“
  • Registerkarte „Zusammengesetzter Bereich“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Vision-Sensoren der In-Sight 2000-Serie

In-Sight-Vision-Systeme


Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Kontrast"

Hinweis: Dieses Thema beschreibt die Benutzeroberfläche, wenn man mit einem Vision-Sensor der In-Sight 2000-Serie verbunden ist. Wenn eine Verbindung mit In-Sight-Vision-Systemen besteht, finden Sie weitere Informationen im Abschnitt „In-Sight-Vision-Systeme“ von Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Kontrast".

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Geschlossen Anzeige von Bestanden/Nicht bestanden

Zeigt einen grünen Kreis [image] oder ein rotes Rechteck [image] zur Angabe des Erfolgs bzw. Fehlschlags an.

Geschlossen Kontrastanzeige und Schieberegler für Bestanden-Bereich

Stellt die minimale und maximale Kontraststufen ein. Sie können die Werte durch Bewegen der Schieberegler oder durch Eingeben von Werten in die entsprechenden Bearbeitungsfelder einstellen.

Tipp: Sie können den Schieberegler auch mithilfe der PFEILTASTEN (NACH-OBEN, NACH-UNTEN-, NACH-LINKS- und NACH-RECHTS) bewegen.
  • Linker Schieberegler: Legt die minimal akzeptable durchschnittliche Graustufengrenze fest (0 - 255).
  • Rechter Schieberegler: Legt die maximal akzeptable durchschnittliche Graustufengrenze fest (0 - 255).
  • Ergebnisanzeige: Zeigt den durchschnittlichen Graustufenwert der Pixel im Bereich an. Eine Messanzeige zwischen dem rechten und dem linken Schieberegler interpretiert das Werkzeug als Bestanden und die Ergebnisanzeige wird grün. Andernfalls gibt das Tool Unbestanden und die Anzeige wird rot
Gut
Schlecht
Hinweis: Fährt man mit der Maustaste über den Schieberegler, wird das Ergebnis angezeigt.
Geschlossen Schaltfläche Automatisch

Setzt die Bereichsbeschränkungen auf die aktuellsten Werkzeugergebnisse, +/- 10% des maximalen Ergebniswertes vom Werkzeug. Als Beispiel, wenn das maximale Ergebniswert vom Werkzeug 255 ist und das aktuellste Werkzeugergebnis 150 ist, hat ein Klicken auf die Schaltfläche Automatisch die Folge, dass die minimale Bereichsbeschränkung auf 125 (=150 - 25), und die maximale Bereichsbeschränkung auf 175 (=150 + 25) gestellt wird.

Geschlossen Ergebnis umkehren

Wenn aktiviert, gibt das Wekzeug eine Falsch zurück, falls das Ergebnis zwischen die Bereichsbeschränkungen fällt. (Standard = Aus)

Job gut/schlecht | Invertieren | Job gut/schlecht
Job gut/schlecht | (Invertieren) | Job gut/schlecht
Geschlossen Name

Legt den Namen des Inspektionswerkzeuges fest. Der Standardname lautet „Kontrast_1“ (wenn es das erste Muster-Werkzeug ist, das dem Job hinzugefügt wurde, andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Kontrast_2“, „Kontrast_3“ usw.).

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Aktiviert

Definiert, wann und ob das Inspektionswerkzeug ausgeführt werden soll (Standardeinstellung ist „Ein“).

  • Wählen Sie „Aus“, wenn Sie das Werkzeug deaktivieren möchten.
  • Wählen Sie eine Eingangsleitung aus, wenn das Werkzeug an eine bestimmte diskrete Eingangsleitung gebunden sein soll, wo es ein- oder ausgeschaltet werden kann (ein High-Signal, 1, bedeutet „Ein“, ein Low-Signal, 0, bedeutet „Aus“). Durch die Verbindung des Werkzeugs mit einem Eingang kann mithilfe eines Kontrollsystems (z. B. SPS) festgelegt werden, welche Werkzeuge wann ausgeführt werden sollen.
Geschlossen Vorrichtung

Gibt eine Vorrichtung für das Werkzeug an. Wird das Steuerelement Vorrichtung aktiviert, verwandelt sich die Schaltfläche Vorrichtung in ein Orange.

Hinweis: Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.
Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeug „Kontrast“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Contrast_1“, sofern es sich um das erste Kontrastwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Contrast_2“, „Contrast_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeug "Kontrast" - Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert den maximal zulässigen Kontrastwert (0 bis 255). Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Kontrast

Zeigt die Differenz zwischen den im Bereich gefundenen durchschnittlichen Graustufenwerten über und unter dem vom Werkzeug erstellten "Smart"-Schwellwert an. Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Geschlossen Minimum

Definiert den minimal zulässigen Kontrastwert (0 bis 255). Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert - Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
  • Aktiviert - Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


An-/Abwesenheitswerkzeug "Kontrast" – Registerkarte "Histogramm"

Die Registerkarte Histogramm ist ein Histogramm der Graustufenwerte für die Pixel in einem bestimmten Bereich.

  • Die X-Achse des Diagramms steht für die Gesamtzahl der Graustufenwerte (0 bis 255 oder insgesamt 256 Grauschattierungen).
  • Die Y-Achse des Diagramms gibt die Anzahl der Pixel eines bestimmten Graustufenwerts an. Zudem erfolgt die Skalierung durch Anzeige des Graustufenwerts mit der höchsten Anzahl an Pixeln.
  • Die drei blauen vertikalen Linien zeigen den mittleren Graustufenwert unter dem Schwellenwert, den Schwellenwert und den mittleren Graustufenwert über dem Schwellenwert an.
Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


An-/Abwesenheitswerkzeug "Kontrast" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


An-/Abwesenheitswerkzeuge – PatMax RedLine-Muster und PatMax-Muster

Hinweis:
  • Ab der In-Sight-Firmwareversion 5.5.0 oder höher wurde der Algorithmus des Werkzeugs geändert. Es gibt jetzt genauere Ergebnisse zurück und verringert in einigen Fällen die Ausführungszeit.
  • Aufgrund dieser Änderung wird bei dem Versuch, einen Job, der mit der In-Sight-Firmwareversion 5.5.0 oder höher konfiguriert wurde, in ein In-Sight Vision-System zu laden, das die Firmwareversion 5.4.x oder früher ausführt, eine Fehlermeldung angezeigt.
  • Die Positionswerkzeuge PatMax RedLine-Muster und PatMax RedLine-Muster (1-10) ist nur auf In-Sight Vision-Systemen mit In-Sight-Firmware 5.2.0 und höher verfügbar. Eine komplette Modelliste mit unterstützten Firmwareversionen finden Sie im Abschnitt Firmwareversionen.

Die Werkzeuge PatMax RedLine-Muster und PatMax-Muster dienen zum Feststellen der An-/Abwesenheit eines Mustermerkmals. Dabei wird der PatMax RedLine- oder PatMax-Algorithmus auf Basis einer eingelernten Darstellung dieses Musters (als Modell bezeichnet) verwendet.

Diese Werkzeuge sind in Situationen nützlich, in denen das Merkmal eines guten Teils ein erkennbares Muster aufweist, das an schlechten Teilen fehlt, bzw. umgekehrt. Beispiel: Sie möchten überprüfen, ob ein Philips-Schraubenkopfmuster in einer mechanischen Baugruppe vorhanden ist oder nicht.

Einrichtung der Werkzeuge

Anpassen der Werkzeugparameter


Einrichten der An-/Abwesenheitswerkzeuge "PatMax RedLine-Muster" und "PatMax-Muster"

Wählen Sie nach dem Hinzufügen des Werkzeugs die Bereichstypen aus und konfigurieren Sie sie, um das Muster zu definieren (den Modellbereich) und den Bereich im Bild festzulegen, an der das Muster gefunden wird (den Suchbereich).

  1. Wählen Sie im Dropdown-Menü Modell den Bereichstypaus: Rechteck (Standard), Kreis, Annulus oder Polygon. Platzieren Sie den Modellbereich über dem Muster, das als Trainingsmodell dient. Stellen Sie sicher, dass der Modellbereich nur die wichtigen Merkmale des Musters abdeckt.Hinweis:Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Wählen Sie im Dropdownmenü Suchen den Bereichstyp "Rechteck" (Standard), "Kreis", "Annulus" oder "Polygon". Platzieren Sie anschließend den Suchbereich so, dass er die Bereiche im Bild abdeckt, in denen das Muster Ihrer Meinung nach erscheint. Erstellen Sie kleinere Suchbereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Suchbereich ist, desto länger dauert die Inspektion mit dem Werkzeug.
  3. Klicken Sie auf OK, um die Bereiche zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

PatMax RedLine-Muster, PatMax-Muster und Muster

Auswählen eines Mustermerkmals


PatMax RedLine-Muster und PatMax-Muster und Muster

Hinweis: Das Das An-/Abwesenheitswerkzeug PatMax RedLine-Muster ist nur auf In-Sight Vision-Systemen mit In-Sight-Firmware 5.2.0 und höher verfügbar. Eine komplette Modelliste mit unterstützten Firmwareversionen finden Sie im Abschnitt Firmwareversionen.

Die Werkzeuge PatMax RedLine-Muster, PatMax-Muster und Muster suchen nach eingelernten Modellmustern und bieten die höchste Genauigkeit im Vergleich zu anderen Inspektionswerkzeugen. Die Werkzeuge PatMax RedLine-Muster und PatMax-Muster sind jedoch leistungsstärker als das Werkzeug Muster. Sie können stärkere Änderungen der Lichtverhältnisse und der Musterposition berücksichtigen . Zudem bieten sie eine genauere Erkennung von Änderungen im Hinblick auf die Musterskalierung, Musterdrehung, Verdeckung von Musterelementen sowie Änderungen der Musterdarstellung in Abhängigkeit von Lichtverhältnissen.

Der Hauptunterschied zwischen PatMax RedLine-Muster und PatMax-Muster liegt in der Geschwindigkeit. PatMax RedLine-Muster verwendet den neuesten Muster-Übereinstimmungsalgorithmus und kann in einem 5-Megapixel Bild eingelernte Merkmale bis zu 7x schneller als PatMax-Muster finden. Deshalb ist PatMax RedLine-Muster die ideale Wahl für Vision-Systeme mit hoher Auflösung.

Das Werkzeug Muster ist in den meisten Fällen schneller als PatMax. Jedoch spielen in folgenden Situationen die Genauigkeit und Zuverlässigkeit der PatMax RedLine- und PatMax-Version eine wesentliche Rolle:

  • Änderungen von Lichtverhältnissen und Reflektionen sind schwer zu kontrollieren. Beispielsweise können Metallteile Licht in zufälligen Richtungen reflektieren.
  • Das zu inspizierende Muster ist ähnlich geformt oder schattiert wie ein Hintergrundelement oder das Muster überschneidet sich mit Bildobjekten bzw. wird teilweise von diesen verdeckt.
  • Sie möchten einen Mustertyp von anderen, ähnlichen Mustern genau differenzieren.
  • Die Bedingungen der Bereitstellungsumgebung sind zu komplex für das Werkzeug Muster, um gleichmäßige und zuverlässige Ergebnisse zu erzielen.


Anpassen der Parameter der An-/Abwesenheitswerkzeuge "PatMax RedLine-Muster" und "PatMax-Muster"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Der Einstellungsbereich für die An-/Abwesenheitswerkzeuge PatMax RedLine-Muster (1-10) und PatMax-Muster (1-10) beinhaltet folgende Registerkarten:

  • Registerkarte Allgemein
  • Registerkarte Einstellungen
  • Registerkarten Modell und Suchen
  • Registerkarte Trainiertes Bild
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarten „Modell“ und „Suchen“

Registerkarte „Trainiertes Bild“


An-/Abwesenheitswerkzeuge „PatMax RedLine-Muster“ und „PatMax-Muster“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Definiert den Namen des Inspektionswerkzeugs, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Pattern_1“, sofern es sich um das erste Musterwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Pattern_2“, „Pattern_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeuge „PatMax RedLine-Muster“ und „PatMax-Muster“ – Registerkarte „Einstellungen“

Geschlossen Akzeptanzschwellenwert

Gibt den Übereinstimmungsgrad an, der zwischen dem Muster Modell und dem gefundenen Muster vorhanden sein muss (0 – 100; Standard = 50). Liegen die Werte der gefundenen Muster über der Einstellung bzw. entsprechen sie dieser, liegt eine Übereinstimmung vor. Dieses Werkzeug lässt sich mit einer höheren Einstellung schneller ausführen. Dies erfordert ebenfalls einen höheren Übereinstimmungsgrad zwischen dem Modell und dem gefundenen Muster. Niedrigere Einstellungen beinhalten eine höhere Wahrscheinlichkeit für ungenauere Ergebnisse, beispielsweise die Erkennung von Mustern, die dem Muster Modell ähneln, diesem jedoch nicht entsprechen.

Geschlossen Kontrastschwellenwert

Definiert den geringsten akzeptablen Kontrastwert, den das gefundene Muster aufweisen muss. Der Kontrast des gefundenen Musters muss höher als der Wert für den Kontrastschwellenwert sein, um als gültige Instanz zu gelten. Der Standardwert liegt bei PatMax RedLine-Muster bei 0 und der gültige Parameterbereich liegt zwischen 0-100. Der Standardwert liegt bei PatMax-Muster bei 10 und der gültige Parameterbereich liegt zwischen 0-255. Ein niedriger Kontrastschwellenwert wird für Bilder mit einem niedrigen Kontrast verwendet, während ein hoher Kontrastschwellenwert für Bilder mit hohem Kontrast verwendet wird.

Hinweis: PatMax RedLine-Muster kontrastiert das "relative" Maß von Kontrast zwischen Merkmalen im eingelernten Muster im trainierten Bild prozentuell mit den Übereinstimmungsmerkmalen im Suchbild. Wenn ein Merkmal einen ähnlich hohen Kontrast wie der Kontrast des Musters aufweist, wird der berichtete Kontrastwert deswegen ungefähr bei 100 liegen. Wenn ein Merkmal einen geringeren Kontrast hat, als der Kontrast des Musters, wird der berichtete Kontrastwert kleiner als 100 sein. Kontrast bei PatMax RedLine-Muster ist anders interpretiert als Kontrast bei PatMax-Muster, wo er den "absoluten" Bildkontrast des Suchbereiches in Graustufen ausdrückt.
Geschlossen Winkeltoleranz

Gibt an, wie weit das gefundene Muster von der Position des Musters „Modell“ gedreht und dennoch als gültiges Muster erkannt werden kann (± 0 – 180°; Standard =15°). Bei einem größeren Bereich für die Rotationsabweichung des Musters verlängert sich die Ausführung des Werkzeugs.

Geschlossen Skalierungstoleranz

Gibt den zulässigen Prozentsatz der Skalierung (Größenunterschiede) zwischen dem gefundenen Muster und dem Muster Modell an (0 - 50; Standard = 0). Der Wert entspricht einem positiven oder negativen Prozentsatz. Beispielsweise lassen sich mit dem Werkzeug bei einem Wert von "5" Muster finden, die zu 95 % bis 105 % der Größe des Musters Modell entsprechen. Bei einem größeren Bereich für die Skalierungsabweichung des Musters verlängert sich die Ausführung des Werkzeugs.

Geschlossen Suchmodus

Gibt den zum Einlernen und Erkennen von Mustern verwendeten Suchmodus an: PatMax oder PatQuick. In der Standardeinstellung ist PatMax ausgewählt. PatMax bietet eine höhere Genauigkeit als PatQuick, erfordert für die Ausführung aber mehr Zeit. PatQuick ist weniger genau als PatMax, die Ausführungsdauer ist dafür jedoch kürzer.

Geschlossen Genaue Bewertung

Gibt an, ob fehlende oder verdeckte Merkmale des gefundenen Musters die Güte beeinflussen (Standard = „Aus“, nicht aktiviert). Bei Verwendung der genauen Bewertung („An“, aktiviert) verringert sich die Güte des gefundenen Musters, falls Mustermerkmale fehlen oder blockiert werden.

Geschlossen Genaue Bewertung

Gibt an, ob fehlende oder verdeckte Merkmale des gefundenen Musters die Güte beeinflussen (Standard = „Aus“, nicht aktiviert). Bei Verwendung der genauen Bewertung („An“, aktiviert) verringert sich die Güte des gefundenen Musters, falls Mustermerkmale fehlen oder blockiert werden.

Geschlossen Polarität ignorieren

Definiert, ob gefundene Muster im Hinblick auf das Muster Modell farblich invertierte Übereinstimmungsmerkmale enthalten dürfen (standardmäßig = Aus, deaktiviert). Wird Polarität ignorieren angewendet (An, aktiviert), werden gefundene Muster mit farblich invertierten Merkmalen, z. B. schwarz/weiß im Gegensatz zu weiß/schwarz im Muster Modell, als mit dem Muster Modell übereinstimmend betrachtet.

Geschlossen Invertiert
Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Zeitlimit
Definiert den Zeitraum in Millisekunden (0 bis 30000), in dem das Werkzeug nach Mustern sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird. Dieser Parameter ist standardmäßig auf 5.000 gestellt.
Geschlossen Ergebnis

Zeigt das Ergebnis des Werkzeugs Vorhanden, wenn das Mustermerkmal erkannt wurde (in diesem Fall wird zudem eine Güte angezeigt, die angibt, wie genau das gefundene Muster dem Modellmuster entspricht), und Nicht vorhanden, wenn das Mustermerkmal nicht gefunden wurde oder mehrere Instanzen des Musters erkannt wurden.Vorhanden entspricht dem booleschen Wert 1 (Bestanden). Nicht vorhanden entspricht dem booleschen Wert 0 (Fehler).

Hinweis: PatMax RedLine-Muster beinhaltet keinen Parameter Suchmodus.


An-/Abwesenheitswerkzeuge "PatMax RedLine-Muster" und "PatMax-Muster" - Registerkarten "Modell" und "Suchen"

Die Registerkarten Modell und Suchen werden zum Konfigurieren des zusammengesetzten Bereichs für den Modell- und Suchbereich des Werkzeugs verwendet. Zusammengesetzter Bereiche sind Ansammlungen von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon), die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • In der Registerkarte Modell sind zusammengesetzte Bereiche nur aktiviert, nachdem die Schaltfläche Modellbereich einmal angeklickt wurde.
  • Es können einem Zusammengesetzten Bereich maximal 32 Unterbereiche hinzugefügt werden können.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


An-/Abwesenheitswerkzeuge "PatMax RedLine-Muster" und "PatMax-Muster" - Registerkarte "Trainiertes Bild"

Das auf der Registerkarte „Trainiertes Bild“ angezeigte Bild ist eine Miniaturansicht des Musters Modell. Klicken Sie auf die Schaltfläche Modellbereich, um die Größe des Modellbereichs zu ändern oder diesen zu verschieben. Klicken Sie anschließend auf die Schaltfläche Einlernen, um das Muster Modell erneut einzulernen.


An-/Abwesenheitswerkzeuge – Muster

Das An-/Abwesenheitswerkzeug „Muster“ dient zum Bestimmen der An- oder Abwesenheit eines Mustermerkmals anhand einer eingelernten Darstellung dieses Musters (als Modell bezeichnet).

Das An-/Abwesenheitswerkzeug „Muster“ ist in Situationen nützlich, in denen das Merkmal eines guten Teils ein erkennbares Muster aufweist, das an schlechten Teilen fehlt, bzw. umgekehrt. Beispiel: Sie möchten überprüfen, ob ein Philips-Schraubenkopf in einer mechanischen Baugruppe vorhanden ist oder nicht.

Das Werkzeug gibt die folgenden Ergebnisse zurück:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren In-Sight 2000-110 und 2000-120/120C | Nur bei Bestanden/Nicht bestanden-Status.
Vision-Sensor In-Sight 2000-130/130C | Gut/Schlecht-Status und Mustergüte
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | Standardergebnisse (keine Einschränkungen)

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des An-/Abwesenheitswerkzeugs "Muster"

Wählen Sie nach dem Hinzufügen des Werkzeugs die Bereiche im Bild aus, mit denen das Muster definiert (der Modellbereich) und die Position im Bild festgelegt werden, an der das Muster gefunden wird (der Suchbereich).

  1. Platzieren Sie den Modellbereich über dem Muster, das als Trainingsmodell dient. Stellen Sie sicher, dass der Modellbereich nur die wichtigen Merkmale des Musters abdeckt.

  2. Platzieren Sie den Suchbereich so, dass er die Bereiche im Bild abdeckt, in denen das Muster Ihrer Meinung nach erscheint. Erstellen Sie kleinere Suchbereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Suchbereich ist, desto länger dauert die Inspektion mit dem Werkzeug.

    Hinweis: Die Bereiche Modell und Suchen können nicht in Bogen- oder Ringform gebogen werden.
  3. Klicken Sie auf OK, um die Bereiche zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Muster"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Vision-Sensoren der In-Sight 2000-Serie

  • Gruppenfeld Werkzeug bearbeiten

In-Sight Vision-Systeme

Das Einstellungsfenster des An-/Abwesenheitswerkzeugs "Muster" umfasst Folgendes:

  • Registerkarte Allgemein
  • Registerkarte Einstellungen
  • Registerkarte Trainiertes Bild
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Vision-Sensoren der In-Sight 2000-Serie

In-Sight-Vision-Systeme


Anpassen der Parameter des An-/Abwesenheitswerkzeugs „Muster“

Hinweis:
  • Dieses Thema beschreibt die Benutzeroberfläche, wenn man mit einem Vision-Sensor der In-Sight 2000-Serie verbunden ist. Wenn eine Verbindung mit einem In-Sight Vision-System besteht, finden Sie weitere Informationen im Abschnitt „In-Sight Vision-Systeme“ von Anpassen der Parameter der Positionswerkzeuge „Muster“ und „Muster (1-10)“.
  • Beim Versuch, einen Job mit diesem Werkzeug, der in In-Sight-Firmwareversion 5.7.0 oder höher konfiguriert wurde, in ein In-Sight Vision-System mit Firmwareversion 5.6.x oder früher zu laden, wird eine Fehlermeldung angezeigt. Der Ladevorgang schlägt anschließend fehl.

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Geschlossen Anzeige von Bestanden/Nicht bestanden

Zeigt einen grünen Kreis [image] oder ein rotes Rechteck [image] zur Angabe des Erfolgs bzw. Fehlschlags an.

Geschlossen Rotationstoleranz

Gibt an, wie weit das gefundene Muster von der Position des Musters Modell gedreht werden und dennoch als gültiges Muster erkannt werden kann (± 0 bis 180°; Standard = 45°). Bei einem größeren Bereich für die Rotationsabweichung des Musters verlängert sich die Ausführung des Werkzeugs. Der linke Schieberegler stellt die negative und der rechte Schieberegler die positive Rotationstoleranz ein. Sie können die Rotationstoleranz durch Bewegen des linken und des rechten Schiebereglers oder durch Eingeben von Werten in die entsprechenden Bearbeitungsfelder einstellen.

Tipp: Sie können den Schieberegler auch mithilfe der PFEILTASTEN (NACH-OBEN, NACH-UNTEN-, NACH-LINKS- und NACH-RECHTS) bewegen.
Geschlossen Teildetektoranzeige

Die Teildetektoranzeige zeigt an, wie gut das Merkmal vom Werkzeug befunden wurde. Sie legt die minimale Akzeptanzschwelle fest. Sie können eine minimale Akzeptanzschwelle auch manuell (0 - 100; Standard = 50), mithilfe des Schiebereglers oder durch Eingeben eines Wertes in entsprechende Bearbeitungsfeld festlegen.

Tipp: Sie können den Schieberegler auch mithilfe der PFEILTASTEN (NACH-OBEN, NACH-UNTEN-, NACH-LINKS- und NACH-RECHTS) bewegen.

Ist die Messanzeige über der Schwelle, betrachtet das Tool das Teil als gefunden und die Anzeige wird grün. Ist die Messanzeige unter dem Schwellwert, betrachtet es das Teil als nicht gefunden, und die Anzeige verschwindet. Wenn das Tool Sachen findet, die keine Teile sind oder wenn es die falschen Merkmale findet, bewegen Sie den Schieberegler nach rechts. Wenn das Tool einige Teile nicht findet, bewegen Sie den Schieberegler nach links (oder erstellen Sie einen neuen Modellebreich). Niedrigere Einstellungen beinhalten eine höhere Wahrscheinlichkeit für ungenauere Ergebnisse, beispielsweise die Erkennung von Mustern, die dem Muster Modell ähneln, diesem jedoch nicht entsprechen.

BESTANDEN
NICHT BESTANDEN
Hinweis: Fährt man mit der Maustaste über den Schieberegler, werden die Werte Ergebnis und Schwelle angezeigt.
Geschlossen Ergebnis umkehren

Wenn aktiviert, gibt das Wekzeug eine Falsch zurück, falls das Ergebnis zwischen die Bereichsbeschränkungen fällt. (Standard = Aus)

Job gut/schlecht | Invertieren | Job gut/schlecht
Job gut/schlecht | (Invertieren) | Job gut/schlecht
Geschlossen ± 10% Skalierungstoleranz

Gibt den zulässigen Prozentsatz für die Skalierung (Größenunterschiede innerhalb von ±10 %) zwischen dem gefundenen Muster und dem Muster "Modell" an.

Eingelerntes Muster | Gefundenes Muster: +10% | Gefundenes Muster: - 10%
AUS (Standard) | (Schlecht) | (Schlecht)
EIN | (Gut) | (Gut)
Geschlossen Manuelles Zeitlimit verwenden

Definiert, ob die Zeitlimiteinstellung angewendet wird.

  • Aus (Standard): Die Zeitlimiteinstellung ist deaktiviert (kein Zeitlimit).

  • Ein: Die Zeitlimiteinstellung ist aktiviert. Sie können den Zeitlimitwert mithilfe des Bearbeitungsfeldes in Millisekunden angeben (0 bis 30000).

    Hinweis: Ist als Wert 0 festgelegt, wird diese Einstellung deaktiviert und es gilt kein Zeitlimit.
Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Name

Legt den Namen des Inspektionswerkzeuges fest. Der Standardname ist „Muster_1“ (wenn dies das erste Werkzeug „Muster“ ist, das dem Job hinzugefügt wurde, andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Muster_2“, „Muster_3“ usw.).

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Aktiviert

Definiert, wann und ob das Inspektionswerkzeug ausgeführt werden soll (Standardeinstellung ist „Ein“).

  • Wählen Sie „Aus“, wenn Sie das Werkzeug deaktivieren möchten.
  • Wählen Sie eine Eingangsleitung aus, wenn das Werkzeug an eine bestimmte diskrete Eingangsleitung gebunden sein soll, wo es ein- oder ausgeschaltet werden kann (ein High-Signal, 1, bedeutet „Ein“, ein Low-Signal, 0, bedeutet „Aus“). Durch die Verbindung des Werkzeugs mit einem Eingang kann mithilfe eines Kontrollsystems (z. B. SPS) festgelegt werden, welche Werkzeuge wann ausgeführt werden sollen.
Geschlossen Vorrichtung

Gibt eine Vorrichtung für das Werkzeug an. Wird das Steuerelement Vorrichtung aktiviert, verwandelt sich die Schaltfläche Vorrichtung in ein Orange.

Hinweis: Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.
Geschlossen Eingang Einlernen

Definiert, ob ein Modellmuster über eine Eingangsleitung eingelernt werden soll oder nicht (die Standardeinstellung ist „Aus“, deaktiviert).

  • Eingang: Einlernen eines Modellmusters über eine Eingangsleitung. Die ausgewählte Eingangsleitung wird als Einlernsignal verwendet.

    Hinweis:
    • Diese Option wird nicht angezeigt, wenn das In-Sight Vision-System nicht über diskrete Eingänge verfügt (z. B. Vision-Systeme der In-Sight 8000-Serie, die direktes E/A verwenden).
    • Der Signaltyp der ausgewählten Eingangsleitung muss im Anwendungsschritt Eingänge/Ausgänge auf Ereignistrigger gestellt sein.
    • Beim Einlernen eines Modellmusters wird das Bild verwendet, das zuletzt vom Vision-System/Sensor aufgezeichnet wurde. Es ist nicht erforderlich, das Vision-System/den Sensor erneut auszulösen, um einzulernen.
    • Weitere Informationen finden Sie unter Eingänge: Einlernen eines Modellmusters über eine Eingangsleitung
Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Geschlossen Modellbereich

Das Bild ist eine Miniaturansicht vom Muster Modell. Klicken Sie auf die Schaltfläche Modellbereich, um die Größe des Modellbereichs zu ändern oder diesen zu verschieben. Klicken Sie anschließend auf die Schaltfläche Trainieren, um das Muster Modell erneut einzulernen.


An-/Abwesenheitswerkzeug „Muster“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Definiert den Namen des Inspektionswerkzeugs, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Pattern_1“, sofern es sich um das erste Musterwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Pattern_2“, „Pattern_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeug „Muster“ – Registerkarte „Einstellungen“

Geschlossen Eingang Einlernen

Definiert, ob ein Modellmuster über eine Eingangsleitung eingelernt werden soll oder nicht (die Standardeinstellung ist „Aus“, deaktiviert).

  • Eingang: Einlernen eines Modellmusters über eine Eingangsleitung. Die ausgewählte Eingangsleitung wird als Einlernsignal verwendet.

    Hinweis:
    • Diese Option wird nicht angezeigt, wenn das In-Sight Vision-System nicht über diskrete Eingänge verfügt (z. B. Vision-Systeme der In-Sight 8000-Serie, die direktes E/A verwenden).
    • Der Signaltyp der ausgewählten Eingangsleitung muss im Anwendungsschritt Eingänge/Ausgänge auf Ereignistrigger gestellt sein.
    • Beim Einlernen eines Modellmusters wird das Bild verwendet, das zuletzt vom Vision-System/Sensor aufgezeichnet wurde. Es ist nicht erforderlich, das Vision-System/den Sensor erneut auszulösen, um einzulernen.
    • Weitere Informationen finden Sie unter Eingänge: Einlernen eines Modellmusters über eine Eingangsleitung
Geschlossen Automatischer Schwellwert

Gibt den Übereinstimmungsgrad an, der zwischen dem Muster Modell und dem gefundenen Muster vorhanden sein muss (0 - 100; Standard = 50). Liegen die Werte der gefundenen Muster über der Einstellung bzw. entsprechen sie dieser, liegt eine Übereinstimmung vor. Dieses Werkzeug lässt sich mit einer höheren Einstellung schneller ausführen. Dies erfordert ebenfalls einen höheren Übereinstimmungsgrad zwischen dem Modell und dem gefundenen Muster. Niedrigere Einstellungen beinhalten eine höhere Wahrscheinlichkeit für ungenauere Ergebnisse, beispielsweise die Erkennung von Mustern, die dem Muster Modell ähneln, diesem jedoch nicht entsprechen.

Geschlossen Rotationstoleranz

Gibt an, wie weit das gefundene Muster von der Position des Musters „Modell“ entfernt sein und dennoch als gültiges Muster erkannt werden kann (± 0 - 180°; Standard = 15°). Bei einem größeren Bereich für die Rotationsabweichung des Musters verlängert sich die Ausführung des Werkzeugs.

Geschlossen Skalierung

Definiert die Toleranz des Werkzeugs für Änderungen an der Skalierung des Musters, innerhalb von ±10% der eingelernten Größe des Musters. Standardmäßig ist diese Einstellung deaktiviert, wodurch Skalierungsanpassungen deaktiviert sind. In diesem Modus findet das Werkzeug nach wie vor Muster, die sich innerhalb des Bereichs von ±10% befinden, aber die Güte der Funktion nimmt ab, während der Skalierungsprozentsatz zunimmt.

Geschlossen Ergebnis invertieren
Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Modelltyp

Definiert die Art und Weise, auf die vom Werkzeug das Muster Modell erstellt wird: Flächenmodell oder Kantenmodell (Standard). Die Option Flächenmodell erstellt das Muster Modell auf Grundlage einheitlichen Samplings der Graustufenwerte im Bereich Modell. Die Option Kantenmodell erstellt das Muster Modell auf Grundlage der ermittelten Kanten (Hell/dunkel-Übergänge) des Mustermerkmals im Modellbereich.

Geschlossen Genauigkeit

Definiert, wie das Werkzeug den Kompromiss zwischen Genauigkeit/Zuverlässigkeit und Ausführungsgeschwindigkeit bewertet: Genau, Mittel (Standard) und Schnell. Mit Genau erreichen Sie eine höhere Genauigkeit/Zuverlässigkeit und eine niedrigere Ausführungsgeschwindigkeit, mit Schnell erreichen Sie eine niedrigere Genauigkeit/Zuverlässigkeit und eine höhere Ausführungsgeschwindigkeit, und mit Mittel erhalten Sie eine mittlere Genauigkeit/Zuverlässigkeit und eine mittlere Ausführungsgeschwindigkeit.

Geschlossen Zeitüberschreitung

Definiert den Zeitraum in Millisekunden (0 bis 30 000), in dem das Werkzeug nach Mustern sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird.

Geschlossen Ergebnis

Zeigt das Ergebnis des Werkzeugs Anwesend an, wenn das Mustermerkmal erkannt wurde, und eine Güte, die angibt, wie stark das gefundene Muster dem Modell-Muster gleicht; Nicht anwesend, wenn es nicht erkannt wurde oder wenn mehr als eine Instanz des Musters erkannt wurde. Anwesend entspricht einem booleschen Wert von 1 (Gut); Nicht anwesend entspricht einem booleschen Wert von 0 (Schlecht).


An-/Abwesenheitswerkzeug "Muster" - Registerkarte "Trainiertes Bild"

Das auf der Registerkarte Trainiertes Bild angezeigte Bild ist eine Miniaturansicht des Modellmusters. Klicken Sie auf die Schaltfläche Modellbereich, um die Größe des Modellbereichs zu ändern oder diesen zu verschieben. Klicken Sie anschließend auf die Schaltfläche Einlernen, um das Muster Modell erneut einzulernen.


An-/Abwesenheitswerkzeuge – Pixelanzahl

Das An-/Abwesenheitswerkzeug "Pixelanzahl" überprüft basierend auf der Anzahl der weißen oder schwarzen Pixel im Bereich, ob ein Merkmal vorhanden ist, und zeigt den ermittelten Wert an.

Das Werkzeug berechnet den optimalen Graustufen-Schwellenwert (0 bis 255), der das Bild in weiße und schwarze Pixel aufteilt, und führt dann eine Zählung der Pixel über oder unter diesem Schwellenwert aus (abhängig von den Einstellungen).

Das An-/Abwesenheitswerkzeug "Pixelanzahl" eignet sich für Situationen, in denen Sie anhand der Anzahl von weißen oder schwarzen Pixeln in einem Bereich feststellen müssen, ob ein Merkmal vorhanden ist. Sie können mit diesem Werkzeug z. B. überprüfen, ob die korrekte Menge Lötmittel um einen Anschlussdraht auf einer Platine verteilt wurde oder eine mittels Tintenstrahldrucker gedruckte Textzeichenfolge vollständig auf einem Etikett vorhanden ist.

Das Werkzeug gibt die folgenden Ergebnisse zurück:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren der In-Sight 2000-Serie 1xx (110, 120, 130) | Nur bei Bestanden/Nicht bestanden-Status.
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | Standardergebnisse (keine Einschränkungen)

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des An-/Abwesenheitswerkzeugs "Pixelanzahl"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereichstyp festlegen und im Bild konfigurieren, um das Merkmal zu isolieren:

  1. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp ein: Rechteck (Standard), Kreis, Annulus oder Polygon. Platzieren Sie den Bereich über dem Merkmal, und stellen Sie sicher, dass die Bereichsbegrenzungen das Merkmal abdecken. Die Bereichsbegrenzungen sollten so konfiguriert sein, dass sie nur das zu messende Merkmal abdecken – wenn der Bereich größer als das Merkmal ist, kann dies zu ungenauen Ergebnissen führen, da auch die Pixel im Hintergrund berechnet werden. Erstellen Sie zur Verbesserung der Leistung des Werkzeugs kleinere Bereiche. Je größer ein Bereich, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich das Merkmal in jedem Bild nahezu an derselben Position befindet oder der Bereich groß genug ist für die erwartete Bewegung des Merkmals.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

Auswählen eines Merkmals


Auswählen eines Merkmals

Beachten Sie bei der Auswahl eines Merkmals für eine Inspektion die folgenden Kriterien, um die besten Ergebnisse zu erzielen:

  • Wenn Sie keinen Lageausgleich verwenden, müssen Sie sicherstellen, dass sich das Merkmal in jedem Bild nahezu an derselben Position befindet oder der Bereich groß genug ist für die erwartete Positionsänderung des Merkmals.
  • Das Werkzeug "Pixelanzahl" eignet sich für Anwendungen, bei denen das inspizierte Merkmal bei Vorhandensein eine Mischung von Graustufenwerten und bei Nichtvorhandensein einheitliche Graustufenwerte enthält.
  • Das Werkzeug "Pixelanzahl" kann feine Helligkeits- und Kontrastunterschiede differenzieren und misst solche Unterschiede genauer als die An-/Abwesenheitswerkzeuge Helligkeit oder Kontrast.
Geschlossen Beispiel


Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Pixelanzahl"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Vision-Sensoren der In-Sight 2000-Serie

  • Gruppenfeld Werkzeug bearbeiten

In-Sight Vision-Systeme

Das Einstellungsfenster des An-/Abwesenheitswerkzeugs „Pixelanzahl“ enthält folgende Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Bereichsbeschränkungen"
  • Registerkarte „Histogramm“
  • Registerkarte „Zusammengesetzter Bereich“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Vision-Sensoren der In-Sight 2000-Serie

In-Sight-Vision-Systeme


Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Pixelanzahl"

Hinweis: Dieses Thema beschreibt die Benutzeroberfläche, wenn man mit einem Vision-Sensor der In-Sight 2000-Serie verbunden ist. Wenn eine Verbindung mit In-Sight Vision-Systemen besteht, schlagen Sie im Abschnitt „In-Sight Vision-System“ von Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Pixelanzahl"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Geschlossen Anzeige von Bestanden/Nicht bestanden

Zeigt einen grünen Kreis [image] oder ein rotes Rechteck [image] zur Angabe des Erfolgs bzw. Fehlschlags an.

Geschlossen Pixelauswahl

Definiert, wie das Werkzeug das Bild in Bereiche mit schwarzen und weißen Pixeln segmentiert. Standardmäßig zählt das Werkzeug die schwarzen Pixel, und die schwarzen Pixel werden im Bereich gelb markiert.

Originalbild
Ausgewählte Pixelfarbe = Schwarz

Der linke Schieberegler stellt den unteren Schwellenwert (0 - 255) und der rechte Schieberegler den oberen Schwellenwert (0 - 255) ein. Sie können die Werte durch Bewegen der Schieberegler oder durch Eingeben von Werten in die entsprechenden Bearbeitungsfelder einstellen.

Tipp: Sie können den Schieberegler auch mithilfe der PFEILTASTEN (NACH-OBEN, NACH-UNTEN-, NACH-LINKS- und NACH-RECHTS) bewegen.

Um die weißen Pixel zu zählen, klicken Sie auf [image]. Jetzt werden die weißen Pixel im ausgewählten Bereich gelb markiert.

Ausgewählte Pixelfarbe = Weiß
Geschlossen Schaltfläche Automatisch

Setzt die Bereichsbeschränkungen auf die aktuellsten Werkzeugergebnisse, +/- 10% des maximalen Ergebniswertes vom Werkzeug. Als Beispiel, wenn das maximale Ergebniswert vom Werkzeug 255 ist und das aktuellste Werkzeugergebnis 150 ist, hat ein Klicken auf die Schaltfläche Automatisch die Folge, dass die minimale Bereichsbeschränkung auf 125 (=150 - 25), und die maximale Bereichsbeschränkung auf 175 (=150 + 25) gestellt wird.

Geschlossen Pixelzählanzeige und Bestanden-Bereich

Legt die akzeptable Anzahl der Pixel im Bereich fest. Mithilfe der Ziehgriffe kann die minimale und maximale Anzahl der schwarzen oder weißen Pixel eingestellt werden, die innerhalb des Bereichs gezählt werden müssen, damit das Werkzeug ein Bestanden zurückgibt.

Gut
Schlecht

Fallen die Ergebnisse zwischen den linken und den rechten Wert, gibt das Tool ein „Bestanden“ zurück und es wird eine grüne Umrandung um den Zähler angezeigt. Andernfalls liefert das Werkzeug ein „Nicht bestanden“ und es wird eine rote Umrandung um den Zähler angezeigt.

Sie können die Werte durch Bewegen der Schieberegler oder durch Eingeben von Werten in die entsprechenden Bearbeitungsfelder einstellen.

Tipp: Sie können den Schieberegler auch mithilfe der PFEILTASTEN (NACH-OBEN, NACH-UNTEN-, NACH-LINKS- und NACH-RECHTS) bewegen.
Hinweis: Das Ergebnis (die Anzahl der im Bereich gefundenen Pixel) und Werte für Bestanden-Bereich werden angezeigt, wenn der Mauszeiger über das Steuerelement Schieberegler gehalten wird.
Geschlossen Ergebnis umkehren

Wenn aktiviert, gibt das Wekzeug eine Falsch zurück, falls das Ergebnis zwischen die Bereichsbeschränkungen fällt. (Standard = Aus)

Job gut/schlecht | Invertieren | Job gut/schlecht
Job gut/schlecht | (Invertieren) | Job gut/schlecht
Geschlossen Details anzeigen

Definiert, ob die gezählten Pixel immer im Bildbereich (gelb markiert) angezeigt werden.

Tipp: Um die gezählten Pixel in VisionView anzuzeigen, wählen Sie in EasyView den symbolischen Namen „Details_anzeigen“ im Anwendungsschritt „Kommunikation“ und aktivieren Sie das Kontrollkästchen „Details_anzeigen“ in der VisionView-Anwendung. Weitere Informationen dazu, wie Daten in VisionView angezeigt werden, finden Sie unter Konfigurieren einer EasyView.
  • Ein ( [image] = Standard): Die gezählten Pixel werden immer im Bildbereich angezeigt, es sei denn, ein anderes Positions- oder Inspektionswerkzeug wird bearbeitet.

  • Aus( [image]):Die gezählten Pixel werden nur im Bildbereich angezeigt, wenn dieses Werkzeug bearbeitet wird.

Geschlossen Invertierung ausgewählter Pixel

Ändert die Farbe der zu zählenden Pixel - Schwarz [image] oder Weiß [image] (Standard = Schwarz).

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Name

Definiert den Namen des Inspektionswerkzeuges. Der Standardname lautet „Pixel_1“ (wenn dies das erste Werkzeug „Muster“ ist, das dem Job hinzugefügt wurde, andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Pixel_2“, „Pixel_3“ usw.).

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Aktiviert

Definiert, wann und ob das Inspektionswerkzeug ausgeführt werden soll (Standardeinstellung ist „Ein“).

  • Wählen Sie „Aus“, wenn Sie das Werkzeug deaktivieren möchten.
  • Wählen Sie eine Eingangsleitung aus, wenn das Werkzeug an eine bestimmte diskrete Eingangsleitung gebunden sein soll, wo es ein- oder ausgeschaltet werden kann (ein High-Signal, 1, bedeutet „Ein“, ein Low-Signal, 0, bedeutet „Aus“). Durch die Verbindung des Werkzeugs mit einem Eingang kann mithilfe eines Kontrollsystems (z. B. SPS) festgelegt werden, welche Werkzeuge wann ausgeführt werden sollen.
Geschlossen Vorrichtung

Gibt eine Vorrichtung für das Werkzeug an. Wird das Steuerelement Vorrichtung aktiviert, verwandelt sich die Schaltfläche Vorrichtung in ein Orange.

Hinweis: Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.
Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeug „Pixelanzahl“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Pixel_1“, sofern es sich um das erste Zählwerkzeug „Pixel“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Pixel_2“, „Pixel_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeug "Pixelanzahl" – Registerkarte "Einstellungen"

Geschlossen Schwellenwertmodus

Legt den Modus für die Ermittlung des Graustufenwerts fest, der den Bildbereich in schwarze und weiße Pixel segmentiert. Bei Auswahl von Automatisch (Standardeinstellung = Automatisch) erstellt das Werkzeug bei jeder Bildaufnahme basierend auf Ihrem Bild eine standardmäßige "Smart-Einstellung". Dabei werden Helligkeitsänderungen von Bild zu Bild kontinuierlich ausgeglichen. Bei Auswahl von Manuell wird der Wert manuell eingegeben und die zwei Schwellwerte angepasst.

Geschlossen Niedrigschwellenwert

Definiert den Graustufenwert, der zur Unterscheidung der schwarzen Pixel von den weißen Pixeln verwendet wird (0 bis 255, sofern aktiviert). Wenn der Hochschwellenwert ≥ Niedrigschwellenwert, haben weiße Pixel folgende Werte: Niedrigschwellenwert ≤ Wert ≤ Hochschwellenwert. Wenn Hochschwellenwert < Niedrigschwellenwert ist, haben weiße Pixel folgende Werte: Wert ≤ Hochschwellenwert oder Niedrigschwellenwert ≤ Wert. Dieses Steuerelement ist standardmäßig deaktiviert. Zur Aktivierung muss der Schwellenwertmodus auf Manuell gesetzt sein. Verwenden Sie das Histogramm, um einen optimalen Wert für Ihre Anwendung festzulegen.

  • Niedrigschwellenwert ≤ Hochschwellenwert: Es wird, unabhängig von den aktuellen Graustufenwerten, alles zwischen den Schwellenwerten als "weiß" interpretiert. Alles außerhalb der Schwellenwerte, unabhängig von den aktuellen Graustufenwerten, wird als "schwarz" interpretiert.
  • Hochschwellenwert ≤ Niedrigschwellenwert: Es wird, unabhängig von den aktuellen Graustufenwerten, alles zwischen den Schwellenwerten als "schwarz" interpretiert. Alles außerhalb der Schwellenwerte, unabhängig von den aktuellen Graustufenwerten, wird als "weiß" interpretiert.
Geschlossen Hochschwellenwert

Definiert den Graustufenwert, der zur Unterscheidung der schwarzen Pixel von den weißen Pixeln verwendet wird (0 bis 255, sofern aktiviert). Wenn der Hochschwellenwert ≥ Niedrigschwellenwert, haben weiße Pixel folgende Werte: Niedrigschwellenwert ≤ Wert ≤ Hochschwellenwert. Wenn Hochschwellenwert < Niedrigschwellenwert ist, haben weiße Pixel folgende Werte: Wert ≤ Hochschwellenwert oder Niedrigschwellenwert ≤ Wert. Dieses Steuerelement ist standardmäßig deaktiviert. Zur Aktivierung muss der Schwellenwertmodus auf Manuell gesetzt sein. Verwenden Sie das Histogramm, um einen optimalen Wert für Ihre Anwendung festzulegen.

  • Niedrigschwellenwert ≤ Hochschwellenwert: Es wird, unabhängig von den aktuellen Graustufenwerten, alles zwischen den Schwellenwerten als "weiß" interpretiert. Alles außerhalb der Schwellenwerte, unabhängig von den aktuellen Graustufenwerten, wird als "schwarz" interpretiert.
  • Hochschwellenwert ≤ Niedrigschwellenwert: Es wird, unabhängig von den aktuellen Graustufenwerten, alles zwischen den Schwellenwerten als "schwarz" interpretiert. Alles außerhalb der Schwellenwerte, unabhängig von den aktuellen Graustufenwerten, wird als "weiß" interpretiert.
Geschlossen Polarität

Legt die Farbe der zu zählenden Pixel fest: "Schwarz" oder "Weiß" (Standard = Schwarz).


An-/Abwesenheitswerkzeug "Pixelanzahl" - Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert die zulässige Höchstanzahl von Pixeln im Bereich. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Pixel

Zeigt die Anzahl der im Bereich gefundenen Pixel an (der Wert kann zwischen 0 und dem Höchstwert des Bereichs liegen). Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Geschlossen Minimum

Definiert die zulässige Mindestanzahl von Pixeln im Bereich. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert - Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
  • Aktiviert - Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


An-/Abwesenheitswerkzeug "Pixelanzahl" – Registerkarte "Histogramm"

Die Registerkarte Histogramm ist ein Histogramm der Graustufenwerte für die Pixel in einem bestimmten Bereich.

  • Die X-Achse des Diagramms steht für die Gesamtzahl der Graustufenwerte (0 bis 255 oder insgesamt 256 Grauschattierungen).
  • Die Y-Achse des Diagramms gibt die Anzahl der Pixel eines bestimmten Graustufenwerts an. Zudem erfolgt die Skalierung durch Anzeige des Graustufenwerts mit der höchsten Anzahl an Pixeln.
  • Die blaue vertikale Linie steht für den Schwellenwert, mit dem der Bildbereich in schwarze und weiße Pixel aufgeteilt wird. Werte auf der linken Seite der Linie entsprechen schwarzen Pixeln und Werte auf der rechten Seite entsprechen weißen Pixeln.
Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


An-/Abwesenheitswerkzeug "Pixelanzahl" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


An-/Abwesenheitswerkzeuge – Farbpixelanzahl

Das An-/Abwesenheitswerkzeug „Farbpixelanzahl“ ermittelt, basierend auf der Anzahl der Pixel, die mit den eingelernten Farben in der Farbtabelle (Color-Vision-Sensoren der In-Sight 2000-Serie) oder den ausgewählten Farbmodellen in der Bibliothek der eingelernten Farben (In-Sight Color-Vision-Systeme) übereinstimmen, ob ein Merkmal im Bereich vorhanden oder abwesend ist, und berichtet diesen Wert.

Das Werkzeug gibt die folgenden Ergebnisse zurück:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren der In-Sight 2000-Serie 1xx (110, 120, 130) | Nur bei Bestanden/Nicht bestanden-Status.
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | Standardergebnisse (keine Einschränkungen)

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des An-/Abwesenheitswerkzeugs "Farbpixelanzahl"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereichstyp festlegen und im Bild konfigurieren, um das Merkmal zu isolieren:

Color Vision-Sensoren der In-Sight 2000-Serie

In-Sight Color Vision-Systeme

Color Vision-Sensoren der In-Sight 2000-Serie

  1. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp ein: Rechteck (Standard), Kreis, Annulus oder Polygon. Platzieren Sie den Bereich über dem Merkmal, und stellen Sie sicher, dass die Bereichsbegrenzungen das Merkmal abdecken. Die Bereichsbegrenzungen sollten so konfiguriert sein, dass sie nur das zu messende Merkmal abdecken – wenn der Bereich größer als das Merkmal ist, kann dies zu ungenauen Ergebnissen führen, da auch die Pixel im Hintergrund berechnet werden. Erstellen Sie zur Verbesserung der Leistung des Werkzeugs kleinere Bereiche. Je größer ein Bereich, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich das Merkmal in jedem Bild nahezu an derselben Position befindet oder der Bereich groß genug ist für die erwartete Bewegung des Merkmals.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Wenn der Bereich eingestellt wurde, werden Sie die Farbeinstellungen des Werkzeugs einstellen müssen.

    Hinweis: Wurde die Farbauswahl nicht getroffen, gibt das Werkzeug automatisch eine Fehlermeldung aus.
  4. Klicken Sie auf die Schaltfläche Farben einlernen. Der Kontextbereich für Farbtraining wird angezeigt.
  5. Zum Hinzufügen von Farben klicken Sie auf [image].
  6. Bewegen Sie den Mauszeiger zum Bildbereich. Es wird eine Lupe im Kontextbereich angezeigt, mit der Sie die Farbe einfacher auswählen können.

  7. Klicken Sie auf die gewünschte Farbe, um sie auszuwählen . Nachdem Sie die Farbe geklickt haben, wird sie der Tabelle unten hinzugefügt und es werden sich alle Pixel im Bereich, die mit der ausgewählten Farbe übereinstimmen, gelb verfärben.

    Vor dem Hinzufügen der Farbe Farbe auswählen Nach dem Hinzufügen der Farbe
  8. Wiederholen Sie Schritte 6 und 7, bis die Farbtabelle alle benötigten Farben beinhaltet.
  9. Um Farben zu subtrahieren, klicken Sie auf [image] und wiederholen Sie Schritte 6 bis 8.
  10. Klicken Sie auf die Schaltfläche Farbauswahl beenden, um zum allgemeinen Kontextbereich zurückzukehren.
  11. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  12. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

In-Sight Color Vision-Systeme

Das An-/Abwesenheitswerkzeug Farbpixelanzahl verweist auf eine eingelernte Bibliothek von Farbmodellen und ermittelt anschließend die im Bereich vorhandene Anzahl der Pixel, die mit den ausgewählten und eingelernten Farbmodellen in der eingelernten Bibliothek übereinstimmen. Außerdem wird vom Werkzeug ein binäres Graustufenausgabebild erstellt, indem jedes Pixel, das mit einem aktiven Farbmodell übereinstimmt, auf Weiß (255) festgelegt wird. Alle anderen Pixel werden auf Schwarz (0) festgelegt. Anhand dieses binären Ausgabebilds durchsucht das Werkzeug das Bild und protokolliert die Anzahl von Pixeln, die mit den aktiven Farbmodellen übereinstimmen.

  1. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp ein: Rechteck (Standard), Kreis, Annulus oder Polygon. Platzieren Sie den Bereich über dem Merkmal, und stellen Sie sicher, dass die Bereichsbegrenzungen das Merkmal abdecken. Die Bereichsbegrenzungen sollten so konfiguriert sein, dass sie nur das zu messende Merkmal abdecken – wenn der Bereich größer als das Merkmal ist, kann dies zu ungenauen Ergebnissen führen, da auch die Pixel im Hintergrund berechnet werden. Erstellen Sie zur Verbesserung der Leistung des Werkzeugs kleinere Bereiche. Je größer ein Bereich, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich das Merkmal in jedem Bild nahezu an derselben Position befindet oder der Bereich groß genug ist für die erwartete Bewegung des Merkmals.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Nach der Konfiguration des Suchbereichs müssen die Farbbibliothek des Werkzeugs konfiguriert und die entsprechenden Farbmodelle aktiviert werden:

    • Wurde das erste Mal ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“) hinzugefügt, müssen zunächst die Farbbibliotheken und die Farbmodelle definiert werden.

    • Wurde zuvor ein weiteres Farbwerkzeug hinzugefügt und sollen eine vorhandene Farbbibliothek und ihre eingelernten Farbmodelle verwendet werden, wählen Sie auf der Registerkarte Einstellungen die gewünschte Farbbibliothek, und aktivieren Sie anschließend mithilfe der Kontrollkästchen auf der Registerkarte Bibliothek die gewünschten Farbmodelle.

    • Wurde keine Farbbibliothek definiert, gibt das Werkzeug automatisch eine Fehlermeldung aus. Wurde eine Farbbibliothek definiert, wird sie automatisch vom Werkzeug verwendet und alle darin enthaltenen Farbmodelle werden aktiviert.

  4. Nachdem die Farbmodelle und die Farbbibliotheken festgelegt wurden, wird das Bild vom Werkzeug verarbeitet und alle Pixel innerhalb des Suchbereichs, die mit dem ausgewählten Farbmodell übereinstimmen, werden in die unbunte Farbe Weiß (255) umgewandelt. Die Pixel, die nicht mit dem ausgewählten Farbmodell übereinstimmen, erhalten die unbunte Farbe Schwarz (0).
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Farbpixelanzahl"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Vision-Sensoren der In-Sight 2000-Serie

  • Gruppenfeld Werkzeug bearbeiten

In-Sight Vision-Systeme

Das Einstellungsfenster des An-/Abwesenheitswerkzeugs „Farbpixelanzahl“ enthält folgende Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Bereichsbeschränkungen"
  • Registerkarte „Farbbibliothek“
  • Registerkarte „Zusammengesetzter Bereich“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Vision-Sensoren der In-Sight 2000-Serie

In-Sight-Vision-Systeme


Anpassen der Parameter des An-/Abwesenheitswerkzeugs „Farbpixelanzahl“

Hinweis: Dieses Thema beschreibt die Benutzeroberfläche, wenn man mit einem Vision-Sensor der In-Sight 2000-Serie verbunden ist. Wenn eine Verbindung mit In-Sight Vision-Systemen besteht, schlagen Sie im Abschnitt „In-Sight Vision-System“ von Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Pixelanzahl" nach.

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Bereich „Allgemeiner Kontext“

Geschlossen Anzeige von Bestanden/Nicht bestanden

Zeigt einen grünen Kreis [image] oder ein rotes Rechteck [image] zur Angabe des Erfolgs bzw. Fehlschlags an.

Geschlossen Farben einlernen

Öffnet den Kontextbereich für Farbtraining.

Geschlossen Farbrechtecke

Zeigt die ersten 5 eingelernten Farben, die im Kontextbereich für Farbtraining mithilfe der Schaltfläche Farben zum Hinzufügen auswählen [image] hinzugefügt wurden. Sie können zum Kontextbereich für Farbtraining wechseln, indem Sie auf ein Farbrechteck klicken.

Geschlossen Pixelzählanzeige und Bestanden-Bereich

Legt die akzeptable Anzahl der Pixel im Bereich fest. Mithilfe der Ziehgriffe kann die minimale und maximale Anzahl der Pixel eingestellt werden, die innerhalb des Intervalls gezählt werden müssen, damit das Werkzeug ein „Bestanden“ zurückgibt.

Gut
Schlecht

Fallen die Ergebnisse zwischen den linken und den rechten Wert, gibt das Tool ein „Bestanden“ zurück und es wird eine grüne Umrandung um den Zähler angezeigt. Andernfalls liefert das Werkzeug ein „Nicht bestanden“ und es wird eine rote Umrandung um den Zähler angezeigt.

Sie können die Werte durch Bewegen der Schieberegler oder durch Eingeben von Werten in die entsprechenden Bearbeitungsfelder einstellen.

Tipp: Sie können den Schieberegler auch mithilfe der PFEILTASTEN (NACH-OBEN, NACH-UNTEN-, NACH-LINKS- und NACH-RECHTS) bewegen.
Hinweis: Das Ergebnis (die Anzahl der im Bereich gefundenen Pixel) und Werte für den Bestanden-Bereich werden angezeigt, wenn der Mauszeiger über den Schieberegler gehalten wird.
Geschlossen Schaltfläche Automatisch

Setzt die Bereichsbeschränkungen auf die aktuellsten Werkzeugergebnisse, +/- 10% des maximalen Ergebniswertes vom Werkzeug. Als Beispiel, wenn das maximale Ergebniswert vom Werkzeug 255 ist und das aktuellste Werkzeugergebnis 150 ist, hat ein Klicken auf die Schaltfläche Automatisch die Folge, dass die minimale Bereichsbeschränkung auf 125 (=150 - 25), und die maximale Bereichsbeschränkung auf 175 (=150 + 25) gestellt wird.

Geschlossen Ergebnis umkehren

Wenn aktiviert, gibt das Wekzeug eine Falsch zurück, falls das Ergebnis zwischen die Bereichsbeschränkungen fällt. (Standard = Aus)

Job gut/schlecht | Invertieren | Job gut/schlecht
Job gut/schlecht | (Invertieren) | Job gut/schlecht
Geschlossen Details anzeigen

Definiert, ob die gezählten Pixel immer im Bildbereich (gelb markiert) angezeigt werden.

Tipp: Um die gezählten Pixel in VisionView anzuzeigen, wählen Sie in EasyView den symbolischen Namen „Details_anzeigen“ im Anwendungsschritt „Kommunikation“ und aktivieren Sie das Kontrollkästchen „Details_anzeigen“ in der VisionView-Anwendung. Weitere Informationen dazu, wie Daten in VisionView angezeigt werden, finden Sie unter Konfigurieren einer EasyView.
  • Ein ( [image] = Standard): Die gezählten Pixel werden immer im Bildbereich angezeigt, es sei denn, ein anderes Positions- oder Inspektionswerkzeug wird bearbeitet.

  • Aus( [image]):Die gezählten Pixel werden nur im Bildbereich angezeigt, wenn dieses Werkzeug bearbeitet wird.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Name

Legt den Namen des Inspektionswerkzeuges fest. Standardname ist „ColorPixels_1” (wenn dies das erste Werkzeug „Muster“ ist, das dem Job hinzugefügt wurde, andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „ColorPixels_2”, „ColorPixels_3” usw.).

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Aktiviert

Definiert, wann und ob das Inspektionswerkzeug ausgeführt werden soll (Standardeinstellung ist „Ein“).

  • Wählen Sie „Aus“, wenn Sie das Werkzeug deaktivieren möchten.
  • Wählen Sie eine Eingangsleitung aus, wenn das Werkzeug an eine bestimmte diskrete Eingangsleitung gebunden sein soll, wo es ein- oder ausgeschaltet werden kann (ein High-Signal, 1, bedeutet „Ein“, ein Low-Signal, 0, bedeutet „Aus“). Durch die Verbindung des Werkzeugs mit einem Eingang kann mithilfe eines Kontrollsystems (z. B. SPS) festgelegt werden, welche Werkzeuge wann ausgeführt werden sollen.
Geschlossen Vorrichtung

Gibt eine Vorrichtung für das Werkzeug an. Wird das Steuerelement Vorrichtung aktiviert, verwandelt sich die Schaltfläche Vorrichtung in ein Orange.

Hinweis: Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.
Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Kontextbereich für Farbtraining

Geschlossen Schaltflächen „Farben zum Hinzufügen auswählen“ und „Farben zum Subtrahieren auswählen“

  • Farben zum Hinzufügen auswählen: Fügen Sie der Tabelle die „hinzufügenden Farben“ hinzu. Die Farben, die mit dieser Schaltfläche ausgewählt werden, werden bei der Feststellung der im Bereich vorhandenen Pixelanzahl miteinbezogen. Nachdem Sie eine Farbe ausgewählt haben, die Sie hinzufügen wollen, werden sich alle Pixel im Bereich, die mit der ausgewählten Farbe übereinstimmen, gelb verfärben.

    Hinweis: Die ersten 5 Farben, die mit dieser Schaltfläche ausgewählt wurden, werden als „Farbrechtecke“ im Bereich für den allgemeinen Kontext angezeigt.
    Vor dem Hinzufügen der Farbe Nach dem Hinzufügen der Farbe
  • Farben zum Subtrahieren auswählen: Fügen Sie der Tabelle die „zu subtrahierenden Farben“ hinzu. Die Farben, die mit dieser Schaltfläche ausgewählt werden, werden bei der Feststellung der im Bereich vorhandenen Pixelanzahl ausgeklammert.

Nachdem auf die Schaltfläche Farben zum Hinzufügen auswählen oder Farben zum Subtrahieren auswählen geklickt wurde und der Mauszeiger in den Bildbereich bewegt wird, wird im Kontextbereich eine Bildlupe angezeigt, mit deren Hilfe Sie die Farbe finden können, die Sie auswählen möchten.

Bildlupe
Geschlossen Farbentabelle

  • Farbe: Zeigt die Farben an, die mithilfe der Schaltflächen Farben zum Hinzufügen auswählen oder Farben zum Subtrahieren auswählen hinzugefügt wurden.

    Hinweis: Die RGB-Werte werden angezeigt, wenn der Mauszeiger über den Schieberegler gehalten wird.

  • Toleranz: Legt die Einstellung „Toleranz“ der Farbe fest (0-10; Standard = 2). Sie können die Toleranz erhöhen/verringern, damit mehr/weniger Farbtöne der eingelernten Farbe miteinbezogen werden.

    Hinweis: Der Toleranzwert wird angezeigt, wenn der Mauszeiger über den Schieberegler gehalten wird.
    Originalbild

    Toleranz = 0,5

             Toleranz = 2 (Standard) Toleranz = 7
  • Operationen:
    • Ändern, um Farbe zu subtrahieren: Die Farbe wird im Bereich gelb markiert und bei der Feststellung der im Bereich vorhandenen Pixelanzahl miteinbezogen. Diese Schaltfläche ist ein Umschalter. Klicken Sie auf die Schaltfläche, wenn Sie zu „Farbe subtrahieren“ wechseln möchten.
    • Ändern, um Farbe hinzuzufügen: Die Farbe wird bei der Feststellung der im Bereich vorhandenen Pixelanzahl ausgeklammert. Diese Schaltfläche ist ein Umschalter. Klicken Sie die Schaltfläche, wenn Sie zu „Farbe hinzufügen“ wechseln möchten.

    • Nach oben/unten bewegen: Ändert die Reihenfolge der Operationen der Farben in der Tabelle. Die Farboperation wird von oben nach unten ausgeführt.

    • Farbe löschen: Löscht die Farbe aus der Tabelle.
Geschlossen Helligkeit ignorieren

Ist das Kontrollkästchen „Helligkeit ignorieren“ markiert (Standard), wird eine größere Anzahl Pixel, die dunkler/heller als die eingelernte(n) Farbe(n) sind, gezählt. Dies kann zur Steigerung der Werkzeugleistung beitragen, wenn die Bildintensität über dem Betrachtungsfeld nicht einheitlich ist. Diese Option sollte jedoch nicht markiert werden, wenn zusätzlich zu den eingelernten Farben auch schwarze oder weiße Pixel gezählt werden.

Geschlossen Farbauswahl beenden

Kehrt zum allgemeinen Kontextbereich zurück.

Farboperationen - Beispiele

Geschlossen Beispiele

In diesem Beispiel möchten Sie die „blauen“ und „grünen“ Kreidestifte im Bild auswählen.

Beispiel 1

  1. Wählen Sie mithilfe der Schaltfläche Farben zum Hinzufügen auswählen [image] „blau“ und „grün“ im Bild aus.

    Originalbild Wählen Sie „Blau (Hinzufügen)“ und „Grün (Hinzufügen)“

  2. Als Ergebnis werden die violetten Kreidestifte zum Teil auch hervorgehoben, weil diese Farben (Blau, Grün und Violett) einander sehr ähnlich sind. „Violett“ wird mit Blau gemischt (siehe Bild unten). Wenn Sie eine blaue (oder eine dunkelblaue) Farbe auswählen, werden Farben, die violett ähnlich sind, auch ausgewählt.

  3. Nun wollen Sie „Violett“ aus dem Bild subtrahieren. Wählen Sie mithilfe der Schaltfläche Farben zum Subtrahieren auswählen [image] „Violett“ vom markierten Bereich des violetten Kreidestiftes aus.

    Wählen Sie „Violett (Subtrahieren)“
  4. Jetzt haben Sie die blauen und grünen Kreidestifte erfolgreich markiert.

Beispiel 2

Auch in diesem Beispiel möchten Sie die „blauen“ und „grünen“ Kreidestifte im Bild markieren. Das gewünschte Ergebnis kann hier jedoch u. U. nur schwierig erzielt werden, da die Reihenfolge der Farboperationen anders ausgelegt ist.

  1. Wählen Sie mithilfe der Schaltfläche Farben zum Hinzufügen auswählen [image] „Blau“ im Bild aus.

  2. Wählen Sie mithilfe der Schaltfläche Farben zum Subtrahieren auswählen [image] „Violett“ im Bild aus.

    Wählen Sie „Blau (Hinzufügen)“ und „Violett (Subtrahieren)“

  3. Wählen Sie „Blau“ im Bild mithilfe der Schaltfläche Farben zum Hinzufügen auswählen [image] aus.

    Wählen Sie „Grün (Hinzufügen)“
  4. Als Ergebnis werden die violetten Kreidestifte zum Teil hervorgehoben, weil Grün und Violett einander sehr ähnlich sind. Wenn Sie eine grüne Farbe markieren, werden ähnliche Farben im violetten Bereich auch markiert.
  5. Um „Violett“ aus dem Bild zu entfernen, bewegen Sie die violette Operation mithilfe der Schaltfläche Nach unten bewegen [image] ganz nach unten. Alternativ können Sie auch nach Grün eine zweite violette Operation mithilfe der Schaltfläche Farben zum Subtrahieren auswählen [image] hinzufügen.


An-/Abwesenheitswerkzeug „Farbpixelanzahl“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Pixel_1“, sofern es sich um das erste Zählwerkzeug „Pixel“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Pixel_2“, „Pixel_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeug „Farbpixelanzahl“ – Registerkarte „Einstellungen“

Geschlossen Farbe einlernen

Öffnet das Dialogfeld „ExtractColor – Einlernen“, das zur Definition der ausgewählten Farbmodelle der Farbbibliothek verwendet wird.

Geschlossen Farbbibliothek

Definiert die Farbbibliothek, auf die vom Tool verwiesen wird. Wählen Sie in der Dropdownliste die Farbbibliothek aus, die geändert werden soll, und klicken Sie auf die Schaltfläche Farbe einlernen, um das Dialogfeld „ExtractColor – Einlernen“ zu öffnen. Jede Farbbibliothek kann bis zu 100 unterschiedliche Farbmodelle enthalten, die aus individuellen Farben zusammengesetzt sind.

EasyBuilder-Jobs können maximal 5 Farbbibliotheken enthalten, die unter folgenden Werkzeugen aufgeteilt werden können:

  • Positionswerkzeug „Farb-Blob“
  • Positionswerkzeug „Farb-Blobs (1-10)“
  • An-/Abwesenheitswerkzeug „Farbpixelanzahl“
  • Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“
  • Messungswerkzeug „Farb-Blob-Bereich (1-10)“
  • Zählwerkzeug „Farb-Blobs“
  • Identifizierungswerkzeug „Farbmodell“
  • Filterwerkzeug für Bilder „Farbe zu binär“


An-/Abwesenheitswerkzeug „Farbpixelanzahl“ – Registerkarte „Bereichsbeschränkungen“

Geschlossen Maximum

Definiert die zulässige Höchstanzahl von Pixeln im Bereich. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Pixel

Zeigt die Anzahl der im Bereich gefundenen Pixel an (der Wert kann zwischen 0 und dem Höchstwert des Bereichs liegen). Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Geschlossen Minimum

Definiert die zulässige Mindestanzahl von Pixeln im Bereich. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


An-/Abwesenheitswerkzeug „Farbpixelanzahl“ – Registerkarte „Farbbibliothek“

Geschlossen Liste Farbmodell

Zeigt eine schreibgeschützte Liste der Farbmodelle in der ausgewählten Übereinstimmungsfarbbibliothek an. Die Farbmodelle werden mittels der Kontrollkästchen neben dem Namen der Farbmodelle aktiviert oder deaktiviert.

Geschlossen Farbtabelle

Zeigt eine schreibgeschützte sortierte Liste der Farben der ausgewählten Farbbibliothek an.

Geschlossen Farbname

Zeigt die Namen der Farben im ausgewählten Farbmodell an.

Geschlossen RGB

Zeigt die RGB-Werte der Farben im ausgewählten Farbmodell an.

Geschlossen Funktion

Zeigt die Funktion der Farben (Hinzufügen oder Subtrahieren) im ausgewählten Farbmodell an.


An-/Abwesenheitswerkzeug "Farbpixelanzahl" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


An-/Abwesenheitswerkzeuge – Blob

Das An-/Abwesenheitswerkzeug „Blob“ überprüft, ob ein Blob-Merkmal vorhanden ist oder nicht. Wenn ein Blob erkannt wird, gibt das Werkzeug „Vorhanden“ aus, und das Werkzeugergebnis lautet „Bestanden“. Wenn kein Blob erkannt wird oder der erkannte Blob außerhalb der angegebenen Grenzwerte liegt, lautet das Werkzeugergebnis „Fehler“.

Das An-/Abwesenheitswerkzeug „Blob“ ist eines der schnelleren Werkzeuge und findet Blobmerkmale deutlich schneller als ein An-/Abwesenheitswerkzeug „Muster“. Dieses Werkzeug ist in Situationen hilfreich, wenn die An- oder Abwesenheit von Merkmalen, die aus zusammenhängenden Pixeln bestehen, überprüft werden soll. Beispiel: Sie können überprüfen, ob ein Loch in einem gestanzten Metallteil vorhanden ist.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des An-/Abwesenheitswerkzeugs "Blob"

Nach der Auswahl des Werkzeugs müssen Sie den Bereichstyp festlegen und in dem Bild konfigurieren, in dem Sie die Blobmerkmale erwarten:

  1. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp aus: Rechteck (Standard), Kreis, Annulus oder Polygon. Positionieren und konfigurieren Sie den Bereich im Bild, in dem die Blobs voraussichtlich erscheinen werden. Die Grenzen des Bereichs müssen die Blobs und ihre möglichen Positionen einschließen. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich die Blobs in jedem Bild nahezu an derselben Position befinden oder der Bereich groß genug ist für die erwartete Bewegung der Merkmale.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Blob"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des An-/Abwesenheitswerkzeugs "Blob" umfasst folgende Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte „Histogramm“
  • Registerkarte „Zusammengesetzter Bereich“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Histogramm“

Registerkarte „Zusammengesetzter Bereich“


An-/Abwesenheitswerkzeug „Blob“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Blob_1“, sofern es sich um das erste Blobwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Blob_2“, „Blob_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeug "Blob" – Registerkarte "Einstellungen"

Geschlossen Schwellenwertmodus

Gibt den Modus zum Ermitteln des Graustufenwerts an, mit dem Blobs vom Hintergrund unterschieden werden. Bei Auswahl von "Automatisch" (Standardeinstellung), gleicht das Werkzeug bei jeder Bildaufnahme die Helligkeitsänderungen von Bild zu Bild aus. Bei Auswahl von "Manuell" wird der Wert manuell eingegeben und angepasst.

Geschlossen Blobschwellenwert

Definiert den Graustufenwert, der zur Unterscheidung der Blobs vom Hintergrund verwendet wird (0 - 255, sofern aktiviert). Dieses Steuerelement ist standardmäßig deaktiviert. Zur Aktivierung muss der Schwellenwertmodus auf "Manuell" gesetzt sein. Verwenden Sie das Diagramm, um einen optimalen Wert für Ihre Anwendung festzulegen.

Geschlossen Blobfarbe

Gibt die Blobfarbe an ("Schwarz", "Weiß" oder "Beide"; Standard = "Beide").

  • Beide: Keine Anforderungen für die Blobfarbe vorhanden.
  • Schwarz: Gibt nur Blobs zurück, die unter dem Blobschwellenwert liegen.
  • Weiß: Gibt nur Blobs zurück, die über dem Blobschwellenwert liegen.
Geschlossen Grenze

Gibt eine von zwei Möglichkeiten für die Verwaltung von Blobs an, die die Begrenzung des Blobbereichs überschneiden (Standard = "Aus", nicht aktiviert):

  • Nicht aktiviert: Umfasst keine Blobs, die die Bereichsbegrenzung überschneiden. Der Blob muss sich vollständig innerhalb des zu erkennenden Bereichs befinden.
  • Aktiviert: Umfasst Blobs, die die Bereichsbegrenzung überschneiden (Blobs mit Überschneidung werden erkannt, sofern sie die anderen Kriterien erfüllen).
Geschlossen Mindestbereich

Steht für eine Mindestbereichsbeschränkung in Pixeln (0 bis 900.000; Standard = 100) für alle erkannten Blobs. Es werden nur Blobs mit einem Bereich erkannt, der größer als der Mindestbereich ist.

Geschlossen Höchstbereich

Steht für eine Höchstbereichsbeschränkung in Pixeln (0 bis 900.000; Standard = 100000) für alle erkannten Blobs. Es werden nur Blobs mit einem Bereich erkannt, der kleiner als der Höchstbereich ist.

Geschlossen Ergebnis

Zeigt das Ergebnis des Werkzeugs an: Vorhanden, wenn das Blobmerkmal erkannt wurde, und Nicht vorhanden, wenn es nicht gefunden wurde oder außerhalb der festgelegten Grenzen lag. Vorhanden entspricht dem booleschen Wert 1 (Bestanden). Nicht vorhanden entspricht dem booleschen Wert 0 (Fehler).

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.


An-/Abwesenheitswerkzeug "Blob" – Registerkarte "Histogramm"

Das Histogramm ist eine grafische Dastellung der Graustufenwerte für die Pixel in einem bestimmten Bereich.

  • Die X-Achse des Diagramms steht für die Gesamtzahl der Graustufenwerte (0 bis 255 oder insgesamt 256 Grauschattierungen).
  • Die Y-Achse des Diagramms gibt die Anzahl der Pixel eines bestimmten Graustufenwerts an. Zudem erfolgt die Skalierung durch Anzeige des Graustufenwerts mit der höchsten Anzahl an Pixeln.
  • Die blaue vertikale Linie steht für den Schwellenwert, mit dem der Bildbereich in schwarze und weiße Pixel aufgeteilt wird. Werte auf der linken Seite der Linie entsprechen schwarzen Pixeln und Werte auf der rechten Seite entsprechen weißen Pixeln.
Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


An-/Abwesenheitswerkzeug "Blob" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


An-/Abwesenheitswerkzeuge – Farb-Blob

Das An-/Abwesenheitswerkzeug „Farb-Blob“ überprüft, ob ein Farb-Blob-Merkmal vorhanden ist oder nicht.

Das Werkzeug Farb-Blob greift auf eine eingelernte Bibliothek von Farbmodellen zurück und ermittelt anschließend die im Bereich vorhandene Anzahl der Pixel, die mit den ausgewählten und eingelernten Farbmodellen in der eingelernten Bibliothek übereinstimmen. Außerdem wird vom Werkzeug ein binäres Graustufenausgabebild erstellt, indem jedes Pixel, das mit einem aktiven Farbmodell übereinstimmt, auf Weiß (255) festgelegt wird. Alle anderen Pixel werden auf Schwarz (0) festgelegt. Anhand dieses binären Ausgabebilds durchsucht das Werkzeug das Bild nach Blob-Merkmalen, die von den aktiven Farbmodellen erstellt wurden.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des An-/Abwesenheitswerkzeugs "Farb-Blob"

Nach der Auswahl des Werkzeugs müssen Sie den Bereichstyp festlegen und in dem Bild konfigurieren, in dem Sie die Blobmerkmale erwarten:

  1. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp aus: Rechteck (Standard), Kreis, Annulus oder Polygon. Positionieren und konfigurieren Sie den Bereich im Bild, in dem die Blobs voraussichtlich erscheinen werden. Die Grenzen des Bereichs müssen die Blobs und ihre möglichen Positionen einschließen. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich die Blobs in jedem Bild nahezu an derselben Position befinden oder der Bereich groß genug ist für die erwartete Bewegung der Merkmale.Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Nach der Konfiguration des Suchbereichs müssen die Farbbibliothek des Werkzeugs konfiguriert und die entsprechenden Farbmodelle aktiviert werden:
  4. Wurde das erste Mal ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“) hinzugefügt, müssen zunächst die Farbbibliotheken und die Farbmodelle definiert werden.
  5. Wurde zuvor ein weiteres Farbwerkzeug hinzugefügt und sollen eine vorhandene Farbbibliothek und ihre eingelernten Farbmodelle verwendet werden, wählen Sie auf der Registerkarte "Einstellungen" die gewünschte Farbbibliothek, und aktivieren Sie anschließend mithilfe der Kontrollkästchen auf der Registerkarte "Bibliothek" die gewünschten Farbmodelle.

  6. Wurde keine Farbbibliothek definiert, gibt das Werkzeug automatisch eine Fehlermeldung aus. Wurde eine Farbbibliothek definiert, wird sie automatisch vom Werkzeug verwendet und alle darin enthaltenen Farbmodelle werden aktiviert.

  7. Nachdem die Farbmodelle und die Farbbibliotheken festgelegt wurden, wird das Bild vom Werkzeug verarbeitet und alle Pixel innerhalb des Suchbereichs, die mit dem ausgewählten Farbmodell übereinstimmen, werden in die unbunte Farbe Weiß (255) umgewandelt. Die Pixel, die nicht mit dem ausgewählten Farbmodell übereinstimmen, erhalten die unbunte Farbe Schwarz (0).
  8. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  9. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen des An-/Abwesenheitswerkzeugs "Farb-Blob"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des An-/Abwesenheitswerkzeugs "Farb-Blob" enthält folgende Elemente:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Farbbibliothek"
  • Registerkarte "Zusammengesetzter Bereich"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Zusammengesetzter Bereich“

Farbbibliothek


An-/Abwesenheitswerkzeug „Farb-Blob“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Pixel_1“, sofern es sich um das erste Zählwerkzeug „Pixel“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Pixel_2“, „Pixel_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeug „Farb-Blob“ – Registerkarte „Einstellungen“

Geschlossen Farbe einlernen

Öffnet das Dialogfeld „ExtractColor – Einlernen“, das zur Definition der ausgewählten Farbmodelle der Farbbibliothek verwendet wird.

Geschlossen Farbbibliothek

Definiert die Farbbibliothek, auf die vom Tool verwiesen wird. Wählen Sie in der Dropdownliste die Farbbibliothek aus, die geändert werden soll, und klicken Sie auf die Schaltfläche Farbe einlernen, um das Dialogfeld „ExtractColor – Einlernen“ zu öffnen. Jede Farbbibliothek kann bis zu 100 unterschiedliche Farbmodelle enthalten, die aus individuellen Farben zusammengesetzt sind.

EasyBuilder-Jobs können maximal 5 Farbbibliotheken enthalten, die unter folgenden Werkzeugen aufgeteilt werden können:

  • Positionswerkzeug „Farb-Blob“
  • Positionswerkzeug „Farb-Blobs (1-10)“
  • An-/Abwesenheitswerkzeug „Farbpixelanzahl“
  • Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“
  • Messungswerkzeug „Farb-Blob-Bereich (1-10)“
  • Zählwerkzeug „Farb-Blobs“
  • Identifizierungswerkzeug „Farbmodell“
  • Filterwerkzeug für Bilder „Farbe zu binär“
Geschlossen Begrenzung

Legt eine von zwei Methoden für die Handhabung von Blobs fest, die den Rand des Bereichs überschneiden (Standard = Aus, deaktiviert):

  • Kontrollkästchen deaktiviert – Blobs, die den Bereichsrand überschneiden, werden nicht aufgenommen; d. h. der Blob muss sich vollständig im Erfassungsbereich befinden.
  • Kontrollkästchen aktiviert – Blobs, die den Bereichsrand überschneiden, werden erfasst; d. h. Blobs, die den Bereichsrand überschneiden, werden erkannt, wenn die anderen Kriterien erfüllt werden.
Geschlossen Kleinste Fläche

Definiert ein minimales Flächenlimit, in Anzahl von Pixeln (0 bis 16777216; Standard = 100), für alle erkannten Blobs. Nur Blobs mit einer Fläche, die größer als die kleinste Fläche ist, werden erkannt.

Geschlossen Größte Fläche

Definiert ein maximales Flächenlimit, in Anzahl von Pixeln (0 bis 16777216; Standard = 100000), für alle erkannten Blobs. Nur Blobs mit einer Fläche, die kleiner als die größte Fläche sind, werden erkannt.

Geschlossen Glättungsfaktor

Definiert den Faktor (0 bis 25; Standard = 1), um den das Bild geglättet werden soll. Tragen Sie den Wert 0 ein, wenn keine Glättung erfolgen soll.

Geschlossen Originalbild anzeigen
  • Deaktiviert (Standard): Im ausgewählten Bereich wird ein binäres Ausgabebild in Graustufen angezeigt.
  • Aktiviert: Im ausgewählten Bereich wird das ursprüngliche Eingabebild angezeigt.
Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Ergebnis

Zeigt das Ergebnis des Werkzeugs: Vorhanden, wenn das Blob-Merkmal erkannt wurde; Nicht vorhanden, wenn es nicht erkannt wurde oder außerhalb der angegebenen Grenzwerte liegt.Vorhanden entspricht dem booleschen Wert 1 (Bestanden). Nicht vorhanden entspricht dem booleschen Wert 0 (Fehler).


An-/Abwesenheitswerkzeug "Farb-Blob" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


An-/Abwesenheitswerkzeug „Farb-Blob“ – Farbbibliothek

Geschlossen Liste Farbmodell

Zeigt eine schreibgeschützte Liste der Farbmodelle in der ausgewählten Übereinstimmungsfarbbibliothek an. Die Farbmodelle werden mittels der Kontrollkästchen neben dem Namen der Farbmodelle aktiviert oder deaktiviert.

Geschlossen Farbtabelle

Zeigt eine schreibgeschützte sortierte Liste der Farben der ausgewählten Farbbibliothek an.

Geschlossen Farbname

Zeigt die Namen der Farben im ausgewählten Farbmodell an.

Geschlossen RGB

Zeigt die RGB-Werte der Farben im ausgewählten Farbmodell an.

Geschlossen Funktion

Zeigt die Funktion der Farben (Hinzufügen oder Subtrahieren) im ausgewählten Farbmodell an.


An-/Abwesenheitswerkzeuge – Kante

Das An-/Abwesenheitswerkzeug „Kante“ dient zum Ermitteln der An- oder Abwesenheit eines linearen Kantenmerkmals, das den festgelegten Parametern entspricht.

Das An-/Abwesenheitswerkzeug „Kante“ ist eines der schnelleren Werkzeuge und erkennt Kantenmerkmale deutlich schneller als ein An-/Abwesenheitswerkzeug „Muster“.

Das Werkzeug gibt die folgenden Ergebnisse zurück:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren der In-Sight 2000-Serie 1xx (110, 120, 130) | Nur bei Bestanden/Nicht bestanden-Status.
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | Standardergebnisse (keine Einschränkungen)

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Verwenden des An-/Abwesenheitswerkzeugs "Kante"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereichstyp festlegen und im Bild konfigurieren, um das Merkmal zu isolieren:

  1. Platzieren Sie den Linienbereich entlang dem Kantenmerkmal.

    Geschlossen Beispiel

    Platzieren Sie den Linienbereich entlang dem Kantenmerkmal.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. EasyBuilder erstellt automatisch einen Kantenbereich um das ausgewählte Kantenmerkmal.

    Geschlossen Beispiel

    Automatisch erstellter Bereich.

  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Kante"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Werkzeugs für Kantenpositionen umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Diagramm
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Diagramm


An-/Abwesenheitswerkzeug „Kante“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Edge_1“, sofern es sich um das erste Kantenwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Edge_2“, „Edge_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeug „Kante“ – Registerkarte „Einstellungen“

Geschlossen Kantenkontrast

Gibt den minimal zulässigen Kantenkontrastwert für die gefundene Kante an (1 - 100; Standard = eine Smart-Einstellung, die automatisch verringert wird, bis eine Kante gefunden wird). Mit dieser Einstellung wird die Werkzeugempfindlichkeit für die Kantenerkennung bestimmt, eine Funktion zur Unterscheidung des Merkmals vom Hintergrund. Verwenden Sie diese Einstellung in Verbindung mit dem Diagramm des Werkzeugs, um einen geeigneten Bereich festzulegen.

Hinweis: Wenn dieser Parameter auf „0“ gesetzt ist, werden möglicherweise unerwartete Kanten gefunden.
Geschlossen Güte normalisieren

Legt fest, ob die Kantengüten durch das Graustufen-Histogramm des Bereichs normalisiert werden.Dieser Parameter ist für die Suche nach Kanten in Bereichen mit niedrigem Kontrast nützlich. Deaktivieren Sie diesen Parameter, wenn nur Kanten mit hohem Kontrast erwartet werden.

  • Aktiviert (Standard): Normalisiert die Güte.
  • Deaktiviert: Normalisiert die Güte nicht.
Geschlossen Kantenübergang

Gibt den Übergang der Kante an (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie zur Erhöhung der Genauigkeit und Geschwindigkeit den Übergangstyp an.

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 50; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Suchkriterium

Gibt an, inwiefern das Werkzeug die gefundenen Kanten unterscheidet, sofern mehrere Kanten vorhanden sind (Standard = Beste Güte).

  • Beste Güte: Das Kantenmerkmal mit der Kante mit dem höchsten Kontrast.
  • Erste Kante: Das Kantenmerkmal, das dem Beginn der Bereichsscanrichtung am nächsten ist.
  • Letzte Kante: Das Kantenmerkmal mit der größten Entfernung zum Beginn der Bereichsscanrichtung.
Geschlossen Winkelbereich

Definiert die maximale Winkelverschiebung, die bei der gefundenen Kante möglich ist (0-10°; Standard = 10°). Je größer die zulässige Winkelvariation, desto länger dauert die Ausführung des Werkzeugs.

Geschlossen Ergebnis

Zeigt das Ergebnis des Werkzeugs: Vorhanden , wenn das Kantenmerkmal erkannt wurde; Nicht vorhanden , wenn es nicht erkannt wurde oder außerhalb der angegebenen Beschränkungen liegt. Vorhanden entspricht dem booleschen Wert 1 (Bestanden); Nicht vorhanden entspricht dem booleschen Wert 0 (Fehler);

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.


An-/Abwesenheitswerkzeug "Kante" – Diagramm

Das Diagramm ist eine Darstellung der ersten Ableitung von den Graustufenwerten eines Bereichs. Spitzen- und Talwerte stellen die deutlichsten Kantenübergänge dar.

Bei Werkzeugen zur Kantenerkennung (Werkzeuge für Kanten und Kreise) gibt die Güte-Achse an, wie stark die gefundene Kante mit den festgelegten Parametern übereinstimmt:

  • Eine positive Güte weist darauf hin, dass der Kantenübergang von dunkel zu hell erfolgt.
  • Eine negative Güte weist darauf hin, dass der Kantenübergang von hell zu dunkel erfolgt.
  • Bei einer Güte mit einem Wert von 0 wurde keine Kante erkannt.

Die Versatz-Achse gibt den Bereich an, mit dem das Kantenmerkmal definiert wird. Der Wert "0" bezieht sich auf die Anfangspunktbegrenzung des Bereichs. Der andere Wert steht für die maximale Breite des Bereichs in Pixeln. Der Scheitelpunkt der Spitzen- und Talwerte an der Versatz-Achse gibt die Position der gefundenen Kante an.

Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


An-/Abwesenheitswerkzeuge – Kreis

Das An-/Abwesenheitswerkzeug „Kreis“ dient zum Ermitteln der An- oder Abwesenheit eines kreisförmigen Kantenmerkmals, das den festgelegten Parametern entspricht.

Das Positionswerkzeug „Kreis“ ist eines der schnelleren Werkzeuge und erkennt Kantenmerkmale deutlich schneller als ein An-/Abwesenheitswerkzeug „Muster“.

Das Werkzeug gibt die folgenden Ergebnisse zurück:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren der In-Sight 2000-Serie 1xx (110, 120, 130) | Nur bei Bestanden/Nicht bestanden-Status.
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | Standardergebnisse (keine Einschränkungen)

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des An-/Abwesenheitswerkzeugs "Kreis"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereichstyp festlegen und im Bild konfigurieren, um das Merkmal zu isolieren:

  1. Platzieren und konfigurieren Sie den kreisförmigen Bereich direkt über dem kreisförmigen Kantenmerkmal. Passen Sie die Größe des kreisförmigen Bereichs so an, dass sie mit der Größe und den Abmessungen des Kreismerkmals übereinstimmt.

    Geschlossen Beispiel

    Positionieren des kreisförmigen Bereichs über einem Merkmal

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. EasyBuilder erstellt automatisch einen ringförmigen Kantenbereich um das kreisförmige Kantenmerkmal.

    Geschlossen Beispiel

    Ringförmiger Bereich um ein kreisförmiges Merkmal

  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des An-/Abwesenheitswerkzeugs "Kreis"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des An-/Abwesenheitswerkzeugs "Kreis" umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Diagramm
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Diagramm


An-/Abwesenheitswerkzeug „Kreis“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Circle_1“, sofern es sich um das erste Kreiswerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Circle_2“, „Circle_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeug „Kreis“ – Registerkarte „Einstellungen“

Geschlossen Kantenkontrast

Definiert die akzeptable Mindestkontrastgüte für die gefundene Kante (1-100; Standard = eine „Smart-Einstellung“, die automatisch schrittweise bis zur Erkennung einer Kante reduziert wird). Diese Einstellung bestimmt die Empfindlichkeit des Werkzeugs bei der Kantenerkennung, d. h. seine Fähigkeit, zwischen dem Merkmal und dem Hintergrund zu unterscheiden. Verwenden Sie diese Einstellung in Verbindung mit dem Diagramm des Werkzeugs, um einen akzeptablen Bereich festzulegen.

Hinweis: Wenn dieser Parameter auf „0“ gesetzt ist, werden möglicherweise unerwartete Kanten gefunden.
Geschlossen Güte normalisieren

Legt fest, ob die Kantengüten durch das Graustufen-Histogramm des Bereichs normalisiert werden.Dieser Parameter ist für die Suche nach Kanten in Bereichen mit niedrigem Kontrast nützlich. Deaktivieren Sie diesen Parameter, wenn nur Kanten mit hohem Kontrast erwartet werden.

  • Aktiviert (Standard): Normalisiert die Güte.
  • Deaktiviert: Normalisiert die Güte nicht.
Geschlossen Kantenübergang

Gibt den Übergang der Kante an (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie zur Erhöhung der Genauigkeit und Geschwindigkeit den Übergangstyp an.

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 50; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Suchkriterium

Definiert, wie das Werkzeug zwischen gefundenen kreisförmigen Kanten unterscheidet, wenn mehrere kreisförmige Kanten vorhanden sind (Standard = Beste Güte).

  • Beste Güte = Das kreisförmige Kantenmerkmal mit dem höchsten Kontrast wird ausgewählt.
  • Kleinster Kreis = Das kreisförmige Kantenmerkmal mit dem kleinsten Durchmesser wird ausgewählt.
  • Größter Kreis = Das kreisförmige Kantenmerkmal mit dem größten Durchmesser wird ausgewählt.
Geschlossen Ergebnis

Zeigt das Ergebnis des Werkzeugs: Vorhanden , wenn das kreisförmige Kantenmerkmal erkannt wurde; Nicht vorhanden , wenn es nicht erkannt wurde oder außerhalb der angegebenen Beschränkungen liegt. Vorhanden entspricht dem booleschen Wert 1 (Bestanden); Nicht vorhanden entspricht dem booleschen Wert 0 (Fehler);

Geschlossen Ergebnis umkehren
Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.


An-/Abwesenheitswerkzeug "Kreis" – Diagramm

Das Diagramm ist eine Darstellung der ersten Ableitung von den Graustufenwerten eines Bereichs. Spitzen- und Talwerte stellen die deutlichsten Kantenübergänge dar.

Bei Werkzeugen zur Kantenerkennung (Werkzeuge für Kanten und Kreise) gibt die Güte-Achse an, wie stark die gefundene Kante mit den festgelegten Parametern übereinstimmt:

  • Eine positive Güte weist darauf hin, dass der Kantenübergang von dunkel zu hell erfolgt.
  • Eine negative Güte weist darauf hin, dass der Kantenübergang von hell zu dunkel erfolgt.
  • Bei einer Güte mit einem Wert von 0 wurde keine Kante erkannt.

Die Versatz-Achse gibt den Bereich an, mit dem das Kantenmerkmal definiert wird. Der Wert "0" bezieht sich auf die Anfangspunktbegrenzung des Bereichs. Der andere Wert steht für die maximale Breite des Bereichs in Pixeln. Der Scheitelpunkt der Spitzen- und Talwerte an der Versatz-Achse gibt die Position der gefundenen Kante an.

Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


An-/Abwesenheitswerkzeuge – „Schärfe“

Mit dem An-/Abwesenheitswerkzeug „Schärfe“ wird anhand eines Bildschärfewerts bestimmt, ob ein Bild scharf ist. Das Werkzeug berechnet die relative Bildschärfe eines Eingabebilds im Rahmen eines iterativen Refokussierungsprozesses des Objektivs eines In-Sight-Vision-Systems.

Der Bildschärfewert gibt an, wie gut kleinste Merkmale im Bildbereich (d. h. dem Objekt und dessen Hintergrund, die im Bild enthalten sind), aufgelöst werden können.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des An-/Abwesenheitswerkzeugs „Schärfe“

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie den Bereich im Bild konfigurieren:

  1. Positionieren Sie den Bereich innerhalb des Bilds, sodass die wichtigen Teile der „Szene“ (Objekt und Hintergrund) erfasst werden. Erstellen Sie zur Verbesserung der Leistung des Werkzeugs kleinere Bereiche. Je größer ein Bereich, desto länger dauert die Inspektion. Wenn Sie keinen Bezugspunkt verwenden, stellen Sie sicher, dass sich die Szene, für die die Messung erfolgt, in jedem Bild an der gleichen Stelle befindet.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Nach dem Hinzufügen des Werkzeugs muss der Bildschärfewert mit einem anderen Bildschärfewert aus der gleichen (identischen) Szene verglichen werden – Objekt und Hintergrund müssen also gleich sein, das In-Sight-Vision-System muss sich in der gleichen Ausrichtung und an der gleichen Position befinden, die Beleuchtung muss unverändert sein usw. Ein einzelner Bildschärfewert liefert nicht genügend Informationen über die absolute Schärfe innerhalb des Bildbereichs.
  4. Wechseln Sie zum Schritt Bild einrichten und starten Sie den Modus Live-Video. Refokussieren Sie die Linse des In-Sight-Vision-Systems, und stellen Sie dabei sicher, dass alles andere an der Szene unverändert bleibt.
  5. Beenden Sie den Modus Live-Video. Ein neuer Bildschärfewert wird berechnet.
  6. Vergleichen Sie den neuen Wert mit den vorherigen Wert. Je höher der Wert, desto schärfer der Fokus.
  7. Wiederholen Sie die Schritte 4 und 5, bis ein akzeptabler Fokus erzielt wurde.
Hinweis: Lässt sich kein akzeptabler Fokus erzielen, wechseln Sie ggf. die Linse, oder passen Sie im Anwendungsschritt „Bild einrichten“ den Abstand zwischen Linse und dem Objekt oder einen anderen Bildaufnahmeparameter an.


Anpassen der Parameter des An-/Abwesenheitswerkzeugs „Schärfe“

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des An-/Abwesenheitswerkzeugs „Schärfe“ umfasst Folgendes:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
  • Registerkarte „Bereichsbeschränkungen“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Grenzwerte“


An-/Abwesenheitswerkzeug „Schärfe“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Sharpness_1“, sofern es sich um das erste Schärfewerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Sharpness_2“, „Sharpness_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


An-/Abwesenheitswerkzeug „Schärfe“ – Registerkarte „Bereichsbeschränkungen“

Geschlossen Maximum

Definiert den maximal zulässigen Bildschärfewert. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limit-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Schärfe

Gibt den Bildschärfewert des Bereichs zurück. Werte, die genau auf die Einstellungen für „Minimum“ und „Maximum“ oder zwischen diese Einstellungen fallen, werden als „Bestanden“ qualifiziert.

Geschlossen Minimum

Definiert den zulässigen Mindestwert für die durchschnittliche Bildschärfe. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limit-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Messungswerkzeuge – Abstand

Das Messungswerkzeug „Abstand“ berechnet den Abstand zwischen zwei beliebigen Eingangsmerkmalen und zeigt den berechneten Abstand an.

Hinweis: . Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Das Messungswerkzeug „Abstand“ eignet sich für Situationen, in denen Sie ein Teil oder Objekt genau messen müssen. Sie können mit diesem Werkzeug z. B. den Abstand zwischen den Enden eines Teiles oder den Abstand zwischen den Mittelpunkten zweier Bohrungen messen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Messungswerkzeugs "Abstand"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Merkmale definieren, die gemessen werden:

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie zunächst eines der verfügbaren Merkmale per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta, und eine Linie in Verlängerung des Merkmals wird angezeigt.
  3. Wählen Sie anschließend das zweite Merkmal aus.
  4. Nach der Auswahl des zweiten Merkmals berechnet EasyBuilder automatisch den Abstand zwischen den Merkmalen. EasyBuilder fügt zudem ein An-/Abwesenheitswerkzeug „Kante“ und/oder ein An-/Abwesenheitswerkzeug „Kreis“ für alle Merkmale hinzu, die zuvor nicht definiert wurden (abhängig vom Merkmalstyp).
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Messungswerkzeugs "Abstand"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Messungswerkzeugs "Abstand" umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Bereichsbeschränkungen"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Grenzwerte“


Messungswerkzeug „Abstand“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Distance_1“, sofern es sich um das erste Abstandswerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Distance_2“, „Distance_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Messungswerkzeug "Abstand" – Registerkarte "Einstellungen"

Geschlossen Abmessungen

Legt fest, wie der Abstand zwischen zwei Kantenmerkmalen berechnet wird: "Mittelpunkt zur Linie" (misst den senkrechten Abstand zwischen den Kantensegmenten, Standardeinstellung) oder "Mittelpunkt zu Mittelpunkt".

Hinweis:

Dieses Steuerelement ist nur beim Messen des Abstands von mindestens einem Kantenmerkmal aktiviert. Andernfalls wird der Abstand automatisch wie folgt berechnet:

  • Kreis zur Linie: Misst den Abstand vom Mittelpunkt des Kreises zum senkrechten Schnittpunkt eines Kantenmerkmals oder einer Referenzlinie.
  • Punkt zur Linie: Misst den Abstand vom Punkt zum senkrechten Schnittpunkt eines Kantenmerkmals oder einer Referenzlinie.
  • Kreis zum Punkt: Misst den Abstand vom Mittelpunkt des Kreises zum Punkt.
  • Kreis zum Kreis: Misst den Abstand vom Mittelpunkt eines Kreises zum Mittelpunkt eines anderen Kreises.
  • Punkt zum Punkt: Misst den Abstand zwischen den zwei Punkten.

Ein Punkt bezieht sich auf ein zuvor definiertes Merkmal (Blob, Kreis, Kante, Muster oder Punkt) und wird wie folgt erkannt:

  • Blob: Wird von den X- und Y-Koordinaten des Flächenmittelpunkts des Blobs gemessen.
  • Kreis: Wird von den X- und Y-Mittelpunktkoordinaten des Kreises gemessen.
  • Kante: Wird von den X- und Y-Mittelpunktkoordinaten der Kante gemessen.
  • Muster: Wird von den X- und Y-Ursprungskoordinaten des Modellmusters gemessen.
  • Punkt: Wird von den X- und Y-Koordinaten des Punktes gemessen.


Meßwerkzeug "Abstand" - Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert den maximal zulässigen Abstandswert. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Abstand

Zeigt den aktuell gemessenen Abstand zwischen den beiden Merkmalen an. Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Hinweis: Das Werkzeug zeigt die Messungen in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in Längen-Einheiten kalibriert wurde.
Geschlossen Minimum

Definiert den minimal zulässigen Abstandswert. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert - Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
  • Aktiviert - Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Messungswerkzeuge – Winkel

Das Messungswerkzeug "Winkel" berechnet den Winkel zwischen zwei Kantenmerkmalen.

Das Messungswerkzeug "Winkel" eignet sich z. B. für Situationen, in denen Sie ein Teil oder Objekt genau messen müssen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Messungswerkzeugs "Winkel"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Eingangsmerkmale definieren, die gemessen werden.

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie zunächst eines der verfügbaren Merkmale per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta, und eine Linie in Verlängerung des Merkmals wird angezeigt.
  3. Wählen Sie anschließend das zweite Merkmal aus.
  4. Nach Auswahl des zweiten Merkmals berechnet EasyBuilder automatisch den Winkel zwischen den Merkmalen. Im Bild wird eine Grafik gezeichnet, die den gemessenen Winkel und den Schnittpunkt der beiden Kanten zeigt. EasyBuilder fügt zudem ein An-/Abwesenheitswerkzeug „Kante“ und/oder ein An-/Abwesenheitswerkzeug „Kreis“ für alle Merkmale hinzu, die zuvor nicht definiert wurden (abhängig vom Merkmalstyp).
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Messungswerkzeugs „Winkel“

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Messungswerkzeugs „Winkel“ enthält folgende Elemente:

  • Registerkarte „Allgemein“
  • Registerkarte „Bereichsbeschränkungen“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Grenzwerte“


Messungswerkzeug „Winkel“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Angle_1“, sofern es sich um das erste Winkelwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Angle_2“, „Angle_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Meßwerkzeug "Winkel" - Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert den maximal zulässigen Winkelwert. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Abstand

Zeigt den aktuell gemessenen Winkel zwischen den beiden Merkmalen an. Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Hinweis: Das Werkzeug gibt die X- und Y-Koordinaten in Pixeln an, sofern das Bild nicht in Längen Einheiten im Schritt Bild einrichten kalibriert wurde.
Geschlossen Minimum

Definiert den minimal zulässigen Winkelwert. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert - Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
  • Aktiviert - Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Messwerkzeuge – „Blob-Bereich“ und „Blob-Bereich (1-10)“

Die Messwerkzeuge Blob-Bereich und Blob-Bereich (1-10) vermessen den Bereich des größten gefundenen Blob-Merkmals und geben die Größe des größten Blobs zurück. Das Werkzeug Blob-Bereich dient der Vermessung eines einzigen Blobs, das Werkzeug Blob-Bereiche (1-10) wird für die Vermessung von bis zu 10 Blobs verwendet.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Die Messwerkzeuge Blob-Bereich und Blob-Bereiche (1-10) sind zum Beispiel hilfreich, wenn die erwartete Fläche eines Merkmals vermessen werden soll oder wenn fälschlicherweise nicht durchgehende Bohrungen erkannt werden sollen.

Einrichtung der Werkzeuge

Anpassen der Werkzeugparameter


Einrichten der Messungswerkzeuge "Blobbereich" und "Blobbereiche (1-10)"

Nach der Auswahl des Werkzeugs müssen Sie den Bereichstyp festlegen und in dem Bild konfigurieren, in dem Sie die Blobmerkmale erwarten:

  1. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp aus: Rechteck (Standard), Kreis, Annulus oder Polygon. Positionieren und konfigurieren Sie den Bereich im Bild, in dem die Blobs voraussichtlich erscheinen werden. Die Grenzen des Bereichs müssen die Blobs und ihre möglichen Positionen einschließen. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich die Blobs in jedem Bild nahezu an derselben Position befinden oder der Bereich groß genug ist für die erwartete Bewegung der Merkmale.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter der Messungswerkzeuge "Blobbereich" und "Blobbereiche (1-10)"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Die Einstellungen für die Messungswerkzeuge Blobbereich und Blobbereiche (1-10) enthalten die folgenden Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Bereichsbeschränkungen"
  • Registerkarte "Tabelle"
  • Registerkarte "Histogramm"
  • Registerkarte "Zusammengesetzter Bereich"
Hinweis:
  • Die Registerkarte "Histogramm" wird nicht angezeigt, wenn im Werkzeug ein Fehler auftritt.
  • Die Registerkarte Tabelle steht nur für das Messungswerkzeug Blobbereiche (1-10) zur Verfügung.
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Grenzwerte“

Tabelle

Histogramm

Registerkarte „Zusammengesetzter Bereich“


Messungswerkzeug „Blobbereich“ und „Blobbereiche (1-10)“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Blob_1“, sofern es sich um das erste Blobwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Blob_2“, „Blob_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Messwerkzeug „Blobbereich“ und „Blobbereiche (1-10)“ – Registerkarte „Einstellungen“

Geschlossen Schwellenwertmodus

Hier wird der Wert für die Festlegung des Graustufenwerts definiert, mit dem Blobs vom Hintergrund unterschieden werden. Bei Auswahl von „Automatisch“ (= Standardeinstellung) gleicht das Werkzeug bei jeder Bildaufnahme Helligkeitsänderungen von Bild zu Bild kontinuierlich aus. Wurde „Manuell“ ausgewählt, müssen die Werte manuell eingegeben und angepasst werden.

Geschlossen Blobschwellenwert

Definiert den Graustufenwert, der zur Unterscheidung der Blobs vom Hintergrund verwendet wird (0 bis 255, sofern aktiviert). Dieses Steuerelement ist standardmäßig deaktiviert. Zur Aktivierung muss der Schwellenwertmodus auf „Manuell“ gesetzt sein. Verwenden Sie das Histogramm, um einen optimalen Wert für Ihre Anwendung festzulegen.

Geschlossen Blobfarbe

Legt die Farbe des Blobs fest (Schwarz, Weiß oder Beides; Standard = Beides).

  • Beides = keine Anforderungen für die Blobfarbe vorhanden.
  • Schwarz = gibt nur Blobs zurück, die unter dem angegebenen Blobschwellenwert liegen.
  • Weiß = gibt nur Blobs zurück, die über dem angegebenen Blobschwellenwert liegen.
Geschlossen Begrenzung

Legt eine von zwei Methoden für die Handhabung von Blobs fest, die den Rand des Bereichs überschneiden (Standard = Aus, deaktiviert):

  • Kontrollkästchen deaktiviert – Blobs, die den Bereichsrand überschneiden, werden nicht aufgenommen; d. h. der Blob muss sich vollständig im Erfassungsbereich befinden.
  • Kontrollkästchen aktiviert – Blobs, die den Bereichsrand überschneiden, werden erfasst; d. h. Blobs, die den Bereichsrand überschneiden, werden erkannt, wenn die anderen Kriterien erfüllt werden.
Geschlossen Mindestbereich

Legt ein minimales Flächenlimit in Anzahl von Pixeln (0 bis 16777216; Standard = 50) für die Bloberkennung fest. Nur Blobs mit einer Fläche, die größer als der Mindestbereich ist, werden zurückgegeben.

Hinweis: Mit dem Parameter Minimum auf der Registerkarte Grenzwerte wird festgelegt, ob das Werkzeug besteht oder fehlschlägt; mit dem Parameter Mindestbereich wird festgelegt, ob Blobs zurückgegeben werden oder nicht.
Geschlossen Höchstbereich

Legt ein maximales Flächenlimit in Anzahl von Pixeln (0 bis 16777216; Standard = 307.200) für die Bloberkennung fest. Nur Blobs mit einer Fläche, die kleiner als der Höchstbereich ist, werden zurückgegeben.

Hinweis: Mit dem Parameter Maximum auf der Registerkarte Grenzwerte wird festgelegt, ob das Werkzeug besteht oder fehlschlägt; mit dem Parameter Höchstbereich wird festgelegt, ob Blobs zurückgegeben werden oder nicht.
Geschlossen Zu suchende Anzahl

Definiert die Anzahl der Blobs, die ermittelt werden sollen (1-10, Standard = 1). Bei den meisten Anwendungen ist nur eine Vorrichtung erforderlich. Es können jedoch mehrere Blobs ermittelt werden. Dies ist bei Anwendungen mit mehreren Teilen oder Objekten in einem Bild hilfreich. Je mehr Blobs vom Werkzeug erkannt werden sollen, desto länger dauert die Ausführung des Werkzeugs.

Geschlossen Sortieren nach

Definiert, wie die gefundenen Blobs vom Werkzeug gemessen und sortiert werden (Fläche, Zeile, Spalte, Raster: Zeile dann Spalte von Vorrichtung, Raster: Spalte dann Zeile von Vorrichtung, Abstand vom Ausgangspunkt der Vorrichtung, Winkel (CCW) von Vorrichtung der Zeilenachse, Winkelabstand. Standard = Fläche):

  • Fläche = Sortiert nach der Fläche der gefundenen Blobs, von der kleinsten bis zur größten.
  • Zeile = Sortiert nach dem Abstand entlang der Zeilenbildachse, von der nächsten bis zur weitesten, in absteigender Reihenfolge.
  • Spalte = Sortiert nach dem Abstand entlang der Spaltenbildachse, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Raster: Zeile dann Spalte von Vorrichtung = Sortiert zunächst nach dem Abstand entlang der Zeilenbildachse der Vorrichtung und anschließend nach dem Abstand entlang der Spaltenbildachse, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Raster: Spalte dann Zeile von Vorrichtung = Sortiert zunächst nach dem Abstand entlang der Spaltenbildachse der Vorrichtung und anschließend nach dem Abstand entlang der Zeilenbildachse, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Abstand vom Ausgangspunkt der Vorrichtung = Sortiert nach Abstand vom Ausgangspunkt der Vorrichtung bis zum Mittelpunkt des Blobs, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Winkel (CCW) von Vorrichtung der Zeilenachse = Sortiert nach Winkel (0 bis 360°), wie gemessen zwischen der Zeilenbildachse der Vorrichtung und dem Liniensegment, das durch den Mittelpunkt des Blobs und den Ursprung der Vorrichtung definiert wird, vom kleinsten bis zum größten, in absteigender Reihenfolge.
  • Winkelabstand = Sortiert nach dem absoluten Winkelwert (-180 bis 180°), wie gemessen zwischen der Zeilenbildachse der Vorrichtung und dem Liniensegment, das durch den Mittelpunkt des Blobs und den Ursprung der Vorrichtung definiert wird, vom kleinsten bis zum größten.
Hinweis: Beim Messwerkzeug Blobbereich gibt es den Parameter Anzahl nicht.


Messungswerkzeug „Blobbereich“ und „Blobbereiche (1-10)“ – Registerkarte „Bereichsbeschränkungen“

Geschlossen Maximum

Definiert den maximal zulässigen Blobbereichswert. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Blobbereich

Zeigt den aktuell gemessenen Blobbereich an. Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Hinweis: Das Werkzeug zeigt die Messungen in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
Geschlossen Minimum

Definiert den minimal zulässigen Blobbereichswert. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Messungswerkzeug „Blobbereiche (1-10)“ – Tabelle

Hinweis:
  • Das Messungswerkzeug „Blob“ unterstützt nicht die Registerkarte Tabelle. Die Registerkarte ist nur für das Messungswerkzeug „Blobs (1-10)“ verfügbar.
  • Wenn der Parameter Sortieren nach auf eine andere Option als Fläche festgelegt ist, werden die Spalten Pixel x-Wert und Pixel y-Wert der Tabelle hinzugefügt. Pixel x-Wert und Pixel y-Wert beziehen sich auf die Bildkoordinaten, die auf Grundlage des 2D-Rasters des Bildsensors des In-Sight-Vision-Systems (Reihen und Spalten der Region) erstellt werden, und sind das Gegenteil (Y/X) von reellen Koordinaten (X/Y).

  • Wenn die klassische Ausrichtung im Schritt Bild einrichten im Gruppenfeld Bild in realen Einheiten kalibrieren aktiviert ist, befinden sich die X- und Y-Koordinaten im selben Koordinatenraum wie die Bildkoordinaten (Y/X).

Auf der Registerkarte Tabelle werden abhängig vom Parameter Anzahl auf der Registerkarte „Einstellungen“ die Ergebnisse der gefundenen Blobs veröffentlicht:

Geschlossen Index

Bezieht sich auf die Reihenfolge der gefundenen Blobs auf Grundlage des Parameters Sortieren nach auf der Registerkarte „Einstellungen“, 1 bis 10 (die numerische Sortierung in EasyBuilder basiert auf 0 = 1).

Geschlossen Fläche

Gibt die Fläche des gefundenen Blobs in Pixeln zurück.

Geschlossen X

Gibt die X-Koordinate des gefundenen Mittelpunkts des Blobs zurück. Das Werkzeug gibt das Ergebnis in Pixeln zurück, außer das Bild wurde in reellen Einheiten im Abschnitt Bild einrichten kalibriert.

Geschlossen Y

Gibt die Y-Koordinate des gefundenen Mittelpunkts des Blobs zurück. Das Werkzeug gibt das Ergebnis in Pixeln zurück, außer das Bild wurde in reellen Einheiten im Abschnitt Bild einrichten kalibriert.

Geschlossen Winkel

Gibt den Winkel zwischen dem gefundenen Mittelpunkt des Blobs und dem Mittelpunkt des Bereichs an.

Geschlossen Fehler

Gibt, sofern vorhanden, Fehlerergebnisse für die gefundenen Blobs zurück.

Geschlossen Pixel x-Wert

Gibt die Bildzeilenkoordinate (X-Wert) des gefundenen Mittelpunkts des Blobs zurück.

Geschlossen Pixel y-Wert

Gibt die Bildspaltenkoordinate (Y-Wert) des gefundenen Mittelpunkts des Blobs zurück.


Messungswerkzeug "Blobbereich" und "Blobbereiche (1-10)" – "Histogramm"

Das Histogramm ist eine grafische Dastellung der Graustufenwerte für die Pixel in einem bestimmten Bereich.

  • Die X-Achse des Diagramms steht für die Gesamtzahl der Graustufenwerte (0 bis 255 oder insgesamt 256 Grauschattierungen).
  • Die Y-Achse des Diagramms gibt die Anzahl der Pixel eines bestimmten Graustufenwerts an. Zudem erfolgt die Skalierung durch Anzeige des Graustufenwerts mit der höchsten Anzahl an Pixeln.
  • Die blaue vertikale Linie steht für den Schwellenwert, mit dem der Bildbereich in schwarze und weiße Pixel aufgeteilt wird. Werte auf der linken Seite der Linie entsprechen schwarzen Pixeln und Werte auf der rechten Seite entsprechen weißen Pixeln.
Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


Messungswerkzeug "Blobbereich" und "Blobbereiche (1-10)" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


Messwerkzeuge – „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“

Die Messwerkzeuge Farb-Blob-Bereich und Farb-Blob-Bereich (1-10) vermessen den Bereich des größten gefundenen Blob-Merkmals und geben die Größe des größten Blobs zurück. Das Werkzeug Farb-Blob-Bereich dient der Vermessung eines einzigen Blobs, das Werkzeug Farb-Blob-Bereiche (1-10) wird für die Vermessung von bis zu 10 Blobs verwendet.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Die Werkzeuge Farb-Blob-Bereich und Farb-Blob-Bereiche (1-10) greifen auf eine eingelernte Bibliothek von Farbmodellen zurück und ermitteln anschließend die im Bereich vorhandene Anzahl der Pixel, die mit den ausgewählten und eingelernten Farbmodellen in der Bibliothek übereinstimmen. Außerdem wird vom Werkzeug ein binäres Graustufenausgabebild erstellt, indem jedes Pixel, das mit einem aktiven Farbmodell übereinstimmt, auf Weiß (255) festgelegt wird. Alle anderen Pixel werden auf Schwarz (0) festgelegt. Anhand dieses binären Ausgabebilds durchsucht das Werkzeug das Bild nach Blob-Merkmalen, die von den aktiven Farbmodellen erstellt wurden.

Einrichtung der Werkzeuge

Anpassen der Werkzeugparameter


Einrichten der Messungswerkzeuge "Farb-Blobbereich" und "Farb-Blobbereiche (1-10)"

Nach der Auswahl des Werkzeugs müssen Sie den Bereichstyp festlegen und in dem Bild konfigurieren, in dem Sie die Blobmerkmale erwarten:

  1. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp aus: Rechteck (Standard), Kreis, Annulus oder Polygon. Positionieren und konfigurieren Sie den Bereich im Bild, in dem die Blobs voraussichtlich erscheinen werden. Die Grenzen des Bereichs müssen die Blobs und ihre möglichen Positionen einschließen. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich die Blobs in jedem Bild nahezu an derselben Position befinden oder der Bereich groß genug ist für die erwartete Bewegung der Merkmale.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Nach der Konfiguration des Suchbereichs müssen die Farbbibliothek des Werkzeugs konfiguriert und die entsprechenden Farbmodelle aktiviert werden:

    • Wurde das erste Mal ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“) hinzugefügt, müssen zunächst die Farbbibliotheken und die Farbmodelle definiert werden.

    • Wurde zuvor ein weiteres Farbwerkzeug hinzugefügt und sollen eine vorhandene Farbbibliothek und ihre eingelernten Farbmodelle verwendet werden, wählen Sie auf der Registerkarte "Einstellungen" die gewünschte Farbbibliothek, und aktivieren Sie anschließend mithilfe der Kontrollkästchen auf der Registerkarte "Bibliothek" die gewünschten Farbmodelle.

    • Wurde keine Farbbibliothek definiert, gibt das Werkzeug automatisch eine Fehlermeldung aus. Wurde eine Farbbibliothek definiert, wird sie automatisch vom Werkzeug verwendet und alle darin enthaltenen Farbmodelle werden aktiviert.

  4. Nachdem die Farbmodelle und die Farbbibliotheken festgelegt wurden, wird das Bild vom Werkzeug verarbeitet und alle Pixel innerhalb des Suchbereichs, die mit dem ausgewählten Farbmodell übereinstimmen, werden in die unbunte Farbe Weiß (255) umgewandelt. Die Pixel, die nicht mit dem ausgewählten Farbmodell übereinstimmen, erhalten die unbunte Farbe Schwarz (0).
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter der Messungswerkzeuge "Farb-Blobbereich" und "Farb-Blobbereiche (1-10)"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster der Messungswerkzeuge Farb-Blobbereich und Farb-Blobbereiche (1-10) enthält folgende Elemente:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Bereichsbeschränkungen"
  • Registerkarte "Farbbibliothek"
  • Registerkarte "Tabelle"
  • Registerkarte "Zusammengesetzter Bereich"
Hinweis: Die Registerkarte Tabelle ist nur für das Messungswerkzeug "Farb-Blobbereiche (1-10)" aktiviert.
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Grenzwerte“

Registerkarte „Bibliothek“

Registerkarte „Tabelle“

Registerkarte „Zusammengesetzter Bereich“


Messungswerkzeuge – „Farb-Blob-Bereich“ und „Farb-Blob-Bereiche (1-10)“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „ColorBlobAreas_1“, sofern es sich um das erste Werkzeug „Farb-Blob-Bereich“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „ColorBlobAreas_2“, „ColorBlobAreas_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Messwerkzeuge – „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“ – Registerkarte „Einstellungen“

Geschlossen Farbe einlernen

Öffnet das Dialogfeld „ExtractColor – Einlernen“, das zur Definition der ausgewählten Farbmodelle der Farbbibliothek verwendet wird.

Geschlossen Farbbibliothek

Definiert die Farbbibliothek, auf die vom Tool verwiesen wird. Wählen Sie in der Dropdownliste die Farbbibliothek aus, die geändert werden soll, und klicken Sie auf die Schaltfläche Farbe einlernen, um das Dialogfeld „ExtractColor – Einlernen“ zu öffnen. Jede Farbbibliothek kann bis zu 100 unterschiedliche Farbmodelle enthalten, die aus individuellen Farben zusammengesetzt sind.

EasyBuilder-Jobs können maximal 5 Farbbibliotheken enthalten, die unter folgenden Werkzeugen aufgeteilt werden können:

  • Positionswerkzeug „Farb-Blob“
  • Positionswerkzeug „Farb-Blobs (1-10)“
  • An-/Abwesenheitswerkzeug „Farbpixelanzahl“
  • Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“
  • Messungswerkzeug „Farb-Blob-Bereich (1-10)“
  • Zählwerkzeug „Farb-Blobs“
  • Identifizierungswerkzeug „Farbmodell“
  • Filterwerkzeug für Bilder „Farbe zu binär“
Geschlossen Begrenzung

Legt eine von zwei Methoden für die Handhabung von Blobs fest, die den Rand des Bereichs überschneiden (Standard = Aus, deaktiviert):

  • Kontrollkästchen deaktiviert – Blobs, die den Bereichsrand überschneiden, werden nicht aufgenommen; d. h. der Blob muss sich vollständig im Erfassungsbereich befinden.
  • Kontrollkästchen aktiviert – Blobs, die den Bereichsrand überschneiden, werden erfasst; d. h. Blobs, die den Bereichsrand überschneiden, werden erkannt, wenn die anderen Kriterien erfüllt werden.
Geschlossen Sortieren nach

Definiert, wie die gefundenen Blobs vom Werkzeug gemessen und sortiert werden (Fläche, Zeile, Spalte, Raster: Zeile dann Spalte von Vorrichtung, Raster: Spalte dann Zeile von Vorrichtung, Abstand vom Ausgangspunkt der Vorrichtung, Winkel (CCW) von Vorrichtung der Zeilenachse, Winkelabstand. Standard = Fläche):

  • Fläche = Sortiert nach der Fläche der gefundenen Blobs, von der kleinsten bis zur größten.
  • Zeile = Sortiert nach dem Abstand entlang der Zeilenbildachse, von der nächsten bis zur weitesten, in absteigender Reihenfolge.
  • Spalte = Sortiert nach dem Abstand entlang der Spaltenbildachse, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Raster: Zeile dann Spalte von Vorrichtung = Sortiert zunächst nach dem Abstand entlang der Zeilenbildachse der Vorrichtung und anschließend nach dem Abstand entlang der Spaltenbildachse, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Raster: Spalte dann Zeile von Vorrichtung = Sortiert zunächst nach dem Abstand entlang der Spaltenbildachse der Vorrichtung und anschließend nach dem Abstand entlang der Zeilenbildachse, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Abstand vom Ausgangspunkt der Vorrichtung = Sortiert nach Abstand vom Ausgangspunkt der Vorrichtung bis zum Mittelpunkt des Blobs, vom kürzesten bis zum längsten, in absteigender Reihenfolge.
  • Winkel (CCW) von Vorrichtung der Zeilenachse = Sortiert nach Winkel (0 bis 360°), wie gemessen zwischen der Zeilenbildachse der Vorrichtung und dem Liniensegment, das durch den Mittelpunkt des Blobs und den Ursprung der Vorrichtung definiert wird, vom kleinsten bis zum größten, in absteigender Reihenfolge.
  • Winkelabstand = Sortiert nach dem absoluten Winkelwert (-180 bis 180°), wie gemessen zwischen der Zeilenbildachse der Vorrichtung und dem Liniensegment, das durch den Mittelpunkt des Blobs und den Ursprung der Vorrichtung definiert wird, vom kleinsten bis zum größten.
Geschlossen Anzahl

Legt die Anzahl der Blobs fest, die erkannt werden sollen (1-10, Standard = 1). Je mehr Blobs das Werkzeug erkennen soll, desto länger dauert die Ausführung des Werkzeugs.

Hinweis: Diese Einstellung steht nur für das Messwerkzeug Farb-Blob-Bereich (1-10) zur Verfügung.
Geschlossen Mindestbereich

Legt ein minimales Flächenlimit in Anzahl von Pixeln (0 bis 16777216; Standard = 100) für die Bloberkennung fest. Nur Blobs mit einer Fläche, die größer als der Mindestbereich ist, werden zurückgegeben.

Hinweis: Mit dem Parameter Minimum auf der Registerkarte Grenzwerte wird festgelegt, ob das Werkzeug besteht oder fehlschlägt; mit dem Parameter Mindestbereich wird festgelegt, ob Blobs zurückgegeben werden oder nicht.
Geschlossen Höchstbereich

Legt ein maximales Flächenlimit in Anzahl von Pixeln (0 bis 16777216; Standard = 100000) für die Bloberkennung fest. Nur Blobs mit einer Fläche, die kleiner als der Höchstbereich ist, werden zurückgegeben.

Hinweis: Mit dem Parameter Maximum auf der Registerkarte Grenzwerte wird festgelegt, ob das Werkzeug besteht oder fehlschlägt; mit dem Parameter Höchstbereich wird festgelegt, ob Blobs zurückgegeben werden oder nicht.
Geschlossen Glättungsfaktor

Definiert den Faktor (0 bis 25; Standard = 1), um den das Bild geglättet werden soll. Tragen Sie den Wert 0 ein, wenn keine Glättung erfolgen soll.

Geschlossen Originalbild anzeigen
  • Deaktiviert (Standard): Im ausgewählten Bereich wird ein binäres Ausgabebild in Graustufen angezeigt.
  • Aktiviert: Im ausgewählten Bereich wird das ursprüngliche Eingabebild angezeigt.


Messungswerkzeuge – „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“ – Registerkarte „Bereichsgrenzen“

Geschlossen Maximum

Definiert den maximal zulässigen Blobbereichswert. Das Werkzeug erstellt basierend auf dem Bild eine „Smart Limit“-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Blobbereich

Zeigt den aktuell gemessenen Blobbereich an. Werte, die genau auf die Einstellungen für „Minimum“ und „Maximum“ oder zwischen diese Einstellungen fallen, werden als „Bestanden“ qualifiziert.

Hinweis: Das Werkzeug zeigt die Messungen in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
Geschlossen Minimum

Definiert den minimal zulässigen Blobbereichswert. Das Werkzeug erstellt basierend auf dem Bild eine „Smart Limit“-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Messungswerkzeuge – „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“ – Registerkarte „Bibliothek“

Geschlossen Liste Farbmodell

Zeigt eine schreibgeschützte Liste der Farbmodelle in der ausgewählten Übereinstimmungsfarbbibliothek an. Die Farbmodelle werden mittels der Kontrollkästchen neben dem Namen der Farbmodelle aktiviert oder deaktiviert.

Geschlossen Farbtabelle

Zeigt eine schreibgeschützte sortierte Liste der Farben der ausgewählten Farbbibliothek an.

Geschlossen Farbname

Zeigt die Namen der Farben im ausgewählten Farbmodell an.

Geschlossen RGB

Zeigt die RGB-Werte der Farben im ausgewählten Farbmodell an.

Geschlossen Funktion

Zeigt die Funktion der Farben (Hinzufügen oder Subtrahieren) im ausgewählten Farbmodell an.


Messungswerkzeug „Farb-Blob-Bereich (1-10)“ – Registerkarte „Tabelle“

Hinweis:
  • Das Messungswerkzeug „Farb-Blob-Bereich“ unterstützt nicht die Registerkarte Tabelle. Die Registerkarte ist nur für das Messungswerkzeug „Farb-Blob-Bereich (1-10)“ verfügbar.
  • Wenn der Parameter Sortieren nach auf eine andere Option als Fläche festgelegt ist, werden die Spalten Pixel x-Wert und Pixel y-Wert der Tabelle hinzugefügt. Pixel x-Wert und Pixel y-Wert beziehen sich auf die Bildkoordinaten, die auf Grundlage des 2D-Rasters des Bildsensors des In-Sight-Vision-Systems (Reihen und Spalten der Region) erstellt werden, und sind das Gegenteil (Y/X) von reellen Koordinaten (X/Y).

  • Wenn die klassische Ausrichtung im Schritt Bild einrichten im Gruppenfeld Bild in realen Einheiten kalibrieren aktiviert ist, befinden sich die X- und Y-Koordinaten im selben Koordinatenraum wie die Bildkoordinaten (Y/X).

Auf der Registerkarte Tabelle werden abhängig vom Parameter Anzahl auf der Registerkarte „Einstellungen“ die Ergebnisse der gefundenen Blobs veröffentlicht:

Geschlossen Index

Bezieht sich auf die Reihenfolge der gefundenen Blobs auf Grundlage des Parameters Sortieren nach auf derRegisterkarte „Einstellungen“, 1 bis 10 (die numerische Sortierung in EasyBuilder basiert auf 0 = 1).

Geschlossen Fläche

Gibt die Fläche des gefundenen Blobs in Pixeln zurück.

Geschlossen X

Gibt die X-Koordinate des gefundenen Mittelpunkts des Blobs zurück. Das Werkzeug gibt das Ergebnis in Pixeln zurück, außer das Bild wurde in reellen Einheiten im Abschnitt Bild einrichten kalibriert.

Geschlossen Y

Gibt die Y-Koordinate des gefundenen Mittelpunkts des Blobs zurück. Das Werkzeug gibt das Ergebnis in Pixeln zurück, außer das Bild wurde in reellen Einheiten im Abschnitt Bild einrichten kalibriert.

Geschlossen Winkel

Gibt den Winkel zwischen dem gefundenen Mittelpunkt des Blobs und dem Mittelpunkt des Bereichs an.

Geschlossen Fehler

Gibt, sofern vorhanden, Fehlerergebnisse für die gefundenen Blobs zurück.

Geschlossen Pixel x-Wert

Gibt die Bildzeilenkoordinate (X-Wert) des gefundenen Mittelpunkts des Blobs zurück.

Geschlossen Pixel y-Wert

Gibt die Bildspaltenkoordinate (Y-Wert) des gefundenen Mittelpunkts des Blobs zurück.


Messungswerkzeuge – "Farb-Blob-Bereich" und "Farb-Blob-Bereich (1-10)" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


Messungswerkzeuge – Kreisdurchmesser

Das Messungswerkzeugs „Kreisdurchmesser“ misst den Durchmesser eines kreisförmigen Merkmals.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Messungswerkzeugs "Kreisdurchmesser"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie das zu messende Eingangsmerkmal auswählen.

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie eines der verfügbaren Smart Features per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta.
  3. Bestätigen Sie Ihre Auswahl durch Klicken auf OK (oder klicken Sie auf Abbrechen, um den Vorgang rückgängig zu machen).
  4. Nach dem Bestätigen des Merkmals berechnet EasyBuilder automatisch den Durchmesser des Merkmals. EasyBuilder fügt zudem ein An-/Abwesenheitswerkzeug „Kante“ und/oder ein An-/Abwesenheitswerkzeug „Kreis“ für alle Merkmale hinzu, die zuvor nicht definiert wurden (abhängig vom Merkmalstyp).
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Messungswerkzeugs "Kreisdurchmesser"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Messungswerkzeugs "Kreisdurchmesser" umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Bereichsbeschränkungen"
  • Diagramm
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Grenzwerte“

Diagramm


Messungswerkzeug „Kreisdurchmesser“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Circle_1“, sofern es sich um das erste Kreiswerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Circle_2“, „Circle_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Messwerkzeug „Kreisdurchmesser“ – Registerkarte „Einstellungen“

Geschlossen Kantenkontrast

Definiert die akzeptable Mindestkontrastgüte für die gefundene Kante (1-100; Standard = eine Smart-Einstellung , die automatisch schrittweise bis zur Erkennung einer Kante reduziert wird). Diese Einstellung bestimmt die Empfindlichkeit des Werkzeugs bei der Kantenerkennung, d. h. seine Fähigkeit, zwischen dem Merkmal und dem Hintergrund zu unterscheiden. Verwenden Sie diese Einstellung in Verbindung mit dem Diagramm des Werkzeugs, um einen akzeptablen Bereich festzulegen.

Hinweis: Wenn dieser Parameter auf „0“ gesetzt ist, werden möglicherweise unerwartete Kanten gefunden.
Geschlossen Güte normalisieren

Legt fest, ob die Kantengüten durch das Graustufen-Histogramm des Bereichs normalisiert werden.Dieser Parameter ist für die Suche nach Kanten in Bereichen mit niedrigem Kontrast nützlich. Deaktivieren Sie diesen Parameter, wenn nur Kanten mit hohem Kontrast erwartet werden.

  • Aktiviert (Standard): Normalisiert die Güte.
  • Deaktiviert: Normalisiert die Güte nicht.
Geschlossen Kantenübergang

Gibt den Übergang der Kante an (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie zur Erhöhung der Genauigkeit und Geschwindigkeit den Übergangstyp an.

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 50; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Suchkriterium

Definiert, wie das Werkzeug zwischen gefundenen kreisförmigen Kanten unterscheidet, wenn mehrere kreisförmige Kanten vorhanden sind (Standard = Beste Güte).

  • Beste Güte = Das kreisförmige Kantenmerkmal mit der am besten definierten Kante (höchster Kontrast und höchste Helligkeit) wird ausgewählt.
  • Kleinster Kreis = Das kreisförmige Kantenmerkmal mit dem kleinsten Durchmesser wird ausgewählt.
  • Größter Kreis = Das kreisförmige Kantenmerkmal mit dem größten Durchmesser wird ausgewählt.


Messungswerkzeug "Kreisdurchmesser" – Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert den maximal zulässigen Durchmesserwert. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limit-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Durchmesser

Zeigt den aktuell gemessenen Durchmesser des gefundenen kreisförmigen Kantenmerkmals an. Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Hinweis: Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
Geschlossen Minimum

Definiert den minimal zulässigen Durchmesserwert. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limit-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Messungswerkzeug "Kreisdurchmesser" – Diagramm

Das Diagramm ist eine Darstellung der ersten Ableitung von den Graustufenwerten eines Bereichs. Spitzen- und Talwerte stellen die deutlichsten Kantenübergänge dar.

Bei Werkzeugen zur Kantenerkennung (Werkzeuge für Kanten und Kreise) gibt die Güte-Achse an, wie stark die gefundene Kante mit den festgelegten Parametern übereinstimmt:

  • Eine positive Güte weist darauf hin, dass der Kantenübergang von dunkel zu hell erfolgt.
  • Eine negative Güte weist darauf hin, dass der Kantenübergang von hell zu dunkel erfolgt.
  • Bei einer Güte mit einem Wert von 0 wurde keine Kante erkannt.

Die Versatz-Achse gibt den Bereich an, mit dem das Kantenmerkmal definiert wird. Der Wert "0" bezieht sich auf die Anfangspunktbegrenzung des Bereichs. Der andere Wert steht für die maximale Breite des Bereichs in Pixeln. Der Scheitelpunkt der Spitzen- und Talwerte an der Versatz-Achse gibt die Position der gefundenen Kante an.

Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


Messwerkzeuge – Kreiskonzentrizität

Das Messwerkzeug „Kreiskonzentrizität“ wird verwendet, um den Abstand zwischen den Mittelpunkten zweier Kreismerkmale zu messen.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Dieses Werkzeug kann beispielsweise verwendet werden, um zu überprüfen, ob ein kreisförmiges Etikett zentriert auf einem kreisförmigen Deckel sitzt, oder um die Konzentrizität eines gebohrten Senklochs zu messen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Messungswerkzeugs "Kreiskonzentrizität"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Eingangsmerkmale (zirkuläre Merkmale oder Referenzkreise) definieren, die zum Konstruieren der Kreiskonzentrizitätmessung verwendet werden:

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie zunächst eines der verfügbaren Merkmale per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta, und eine Linie in Verlängerung des Merkmals wird angezeigt.
  3. Wählen Sie anschließend das zweite Merkmal aus.
  4. Nach der Auswahl des zweiten Merkmals berechnet EasyBuilder automatisch den Abstand zwischen den Merkmalen. EasyBuilder fügt zudem ein An-/Abwesenheitswerkzeug „Kante“ und/oder ein An-/Abwesenheitswerkzeug „Kreis“ für alle Merkmale hinzu, die zuvor nicht definiert wurden (abhängig vom Merkmalstyp).
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Messungswerkzeugs "Kreiskonzentrizität"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Messungswerkzeugs "Kreiskonzentrizität" umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Bereichsbeschränkungen"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Grenzwerte“


Messungswerkzeug „Kreiskonzentrizität“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Concentricity_1“, sofern es sich um das erste Werkzeug „Kreiskonzentrizität“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Concentricity_2“, „Concentricity_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Meßwerkzeug "Kreiskonzentrizität" - Registerkarte "Bereichsbeschränkungen"

Geschlossen Abstand

Zeigt den aktuell gemessenen Abstand zwischen den Mittelpunkten der zweier gefundener kreisförmigen Kantenmerkmale an. Werte, die genau auf 0 oder die Einstellung für Maximum oder zwischen diese Werte fallen, werden als "Bestanden" qualifiziert.

Hinweis: Das Werkzeug zeigt die Meßergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in Längen-Einheiten kalibriert wurde.
Geschlossen Maximum

Definiert den maximal zulässigen Abstandswert. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert - Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
  • Aktiviert - Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der Bereichsbeschränkungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Messwerkzeuge – Radius messen

Das Messwerkzeug „Radius messen“ wird verwendet, um ein gebogenes Kantenmerkmal zu definieren und eine Referenzlinie und einen Punkt zu konstruieren, die die Achse der Kurve darstellen. Das Werkzeug gibt den Radius der Kurve zurück.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Anpassen der Parameter des Messungswerkzeugs "Radius messen"

Wählen Sie nach dem Hinzufügen des Werkzeugs den Bereich im Bild aus, mit dem das Merkmal der gebogenen Kante definiert wird:

  1. Platzieren Sie den Bereich über dem gebogenen Kantenmerkmal.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. EasyBuilder berechnet dann automatisch den Radius der Kurve und konstruiert eine Referenzlinie und einen Punkt, die die Achse der Kurve darstellen.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Messungswerkzeugs "Radius messen"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Messungswerkzeugs "Radius messen" umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Bereichsbeschränkungen"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Grenzwerte“


Messungswerkzeug "Radius messen" – Registerkarte "Allgemein"

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge, Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet "Kurve_1", sofern es sich um das erste Geometriewerkzeug "Radius messen" handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Kurve_2", "Kurve_3" usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Messswerkzeug „Radius messen“ – Registerkarte „Einstellungen“

Geschlossen Kantenkontrast

Gibt den minimal zulässigen Kantenkontrastwert für die gefundene Kante an (1 - 100; Standard = eine Smart-Einstellung, die automatisch verringert wird, bis eine Kante gefunden wird). Mit dieser Einstellung wird die Werkzeugempfindlichkeit für die Kantenerkennung bestimmt, eine Funktion zur Unterscheidung des Merkmals vom Hintergrund. Verwenden Sie diese Einstellung in Verbindung mit dem Diagramm des Werkzeugs, um einen geeigneten Bereich festzulegen.

Hinweis: Wenn dieser Parameter auf „0“ gesetzt ist, werden möglicherweise unerwartete Kanten gefunden.
Geschlossen Güte normalisieren

Legt fest, ob die Kantengüten durch das Graustufen-Histogramm des Bereichs normalisiert werden.Dieser Parameter ist für die Suche nach Kanten in Bereichen mit niedrigem Kontrast nützlich. Deaktivieren Sie diesen Parameter, wenn nur Kanten mit hohem Kontrast erwartet werden.

  • Aktiviert (Standard): Normalisiert die Güte.
  • Deaktiviert: Normalisiert die Güte nicht.
Geschlossen Kantenübergang

Gibt den Übergang der Kante an (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie zur Erhöhung der Genauigkeit und Geschwindigkeit den Übergangstyp an.

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 50; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Suchkriterium

Gibt an, inwiefern das Werkzeug die gefundenen Kanten unterscheidet, sofern mehrere Kanten vorhanden sind (Standard = Beste Güte).

  • Beste Güte: Das Kantenmerkmal mit der Kante mit dem höchsten Kontrast.
  • Erste Kante: Das Kantenmerkmal, das dem Beginn der Bereichsscanrichtung am nächsten ist.
  • Letzte Kante: Das Kantenmerkmal mit der größten Entfernung zum Beginn der Bereichsscanrichtung.


Messungswerkzeug "Radius messen" – Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert den maximal zulässigen Radiuswert. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limit-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Radius (Einheiten)

Zeigt den aktuell gemessenen Radius des gefundenen gebogenen Kantenmerkmals an. Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Hinweis: Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
Geschlossen Minimum

Definiert den minimal zulässigen Radiuswert. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limit-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Messungswerkzeuge – Min./Max. Punkte

Das Messungswerkzeug "Min./Max. Punkte" misst die Position von Kanten und ermittelt die Kantenpunkte, die der gefundenen Kante oder dem die Kante definierenden Bereich am nächsten liegen oder am weitesten davon entfernt sind. Das Werkzeug verwendet Kantenanalyse-Caliperarrays, um die exakte Position der Kantenmerkmale zu ermitteln. Sobald die Kante identifiziert wurde, konstruiert das Werkzeug eine eingepasste Linie oder einen eingepassten Kreis (je nachdem, ob das Kantenmerkmal eine Kurve beinhaltet) über dem Kantenmerkmal. Das Werkzeug zeigt dann die Kantenpunkte an, die der eingepassten Linie oder dem eingepassten Kreis am nächsten liegen oder am weitesten davon entfernt sind.

Hinweis:
  • Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
  • Alle Eingabewerte werden in Pixeln angegeben, auch wenn das Werkzeug in reellen Einheiten kalibriert wurde.

Das Messungswerkzeug "Min./Max. Punkte" ist hilfreich, um sicherzustellen, dass die Kantenmerkmale des Teils oder Objekts nicht von der erwarteten Position abweichen. So können Sie beispielsweise sicherstellen, dass die Schneide einer Klinge keine Dellen, Kerben oder Kantenausläufer aufweist.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Messungswerkzeugs "Min./Max. Punkte"

Wählen Sie nach dem Hinzufügen des Werkzeugs den maskierten Bereich im Bild über dem Kantenmerkmal aus, das Sie inspizieren möchten:

  1. Positionieren und konfigurieren Sie den Bereich innerhalb des Bildes über dem Kantenmerkmal. Stellen Sie beim Platzieren des Bereichs sicher, dass die Kanten parallel zur Suchrichtung des Bereichs verlaufen und der Bereich so viel wie möglich vom Kantenmerkmal umschließt, wobei unnötiges oder unerwünschtes Rauschen aus dem Bereich ausgeschlossen wird.

    Hinweis: Die gestrichelte gelbe Linie im Maskierten Bereich legt eine Fläche innerhalb des Bereichs fest, in der Kantenübergänge ermittelt werden.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Wählen Sie nach der Bestätigung des Bereichs die verschiedenen Registerkarten Kanten, Kantengüte und Passform, und passen Sie die Parameter und den Bereich nach Bedarf an, um sicherzustellen, dass das Werkzeug die korrekten Kantenkandidaten ermittelt und die korrekte eingepasste Linie oder den eingepassten Kreis erzeugt. Verwenden Sie beim ersten Einrichten des Werkzeugs ein Bild, das ideale Kantenmerkmale enthält. Nachfolgende Bildaufnahmen enthalten dann Kantenkandidaten, die auf Abweichungen wie Fehler oder Zwischenräume untersucht werden.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um die erwarteten Bereiche und Abweichungen auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Messungswerkzeugs "Min./Max. Punkte"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Messungswerkzeugs "Min./Max. Punkte" umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Kanten"
  • Registerkarte "Kantengüte"
  • Registerkarte "Passform"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Kanten“

Registerkarte „Kantengüte“

Registerkarte „Passform“


Messungswerkzeug „Min./Max. Punkte“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „MinMaxPoints_1“, sofern es sich um das erste Messungswerkzeug „Min./Max. Punkte“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „MinMaxPoints_2“, „MinMaxPoints_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Messungswerkzeug "Min./Max. Punkte" – Registerkarte "Kanten"

Bei Auswahl der Registerkarte Kanten zeigt das Werkzeug alle ermittelten Kanten im Bereich grün hervorgehoben an. Sie können die Parameter Caliper-Größe, Caliper-Abstand, Kantenbreite und Mindestkontrast nach Bedarf anpassen, um die gewünschten Kanten zu isolieren.

Sie können auch alle Caliper anzeigen, indem Sie den Parameter Alle Caliper anzeigen aktivieren.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Caliper-Größe

Definiert die pro Caliper zu analysierende Pixelanzahl in Inspektionsrichtung (1 bis 639; Standard = 5).

Geschlossen Caliper-Abstand

Definiert den Abstand in Pixel zwischen dem Ende eines Caliper und dem Anfang des nächsten Caliper (-1 bis 639; Standard = 0).

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 10; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Minimaler Kontrast

Definiert den minimalen Graustufen-Kontrastübergang (1 bis 255; Standard = 10), der als Kante gewertet wird.

Geschlossen Caliper-Anzahl

Zeigt die Gesamtanzahl der Caliper im Bereich an.

Geschlossen Caliper-Index

Legt die einzelnen Caliper fest, die isoliert und angezeigt werden.

Geschlossen Alle Caliper anzeigen

Definiert, ob alle Caliper in dem Bereich immer angezeigt werden. Standardmäßig sind die Caliper ausgeblendet.


Messungswerkzeug "Min./Max. Punkte" – Registerkarte "Kantengüte"

Bei Auswahl der Registerkarte Kantengüte zeigt das Werkzeug mithilfe kleiner, farbcodierter Kreise alle gefundenen Kantenkandidaten im Bereich (der ausgewählt oder angepasst werden kann) und die eingepasste Linie oder den eingepassten Kreis an. Die Kantenkandidaten stellten die möglichen Kanten dar, die beim Erzeugen der eingepassten Linie oder des eingepassten Kreises berücksichtigt werden. Passen Sie die Parameter an, um die gewünschten Kantenkandidaten zu isolieren.

Alle erkannten Fehler und Zwischenräume werden ebenfalls angezeigt.

Geschlossen Kantenrichtung suchen

Definiert die Richtung, in der das Werkzeug relativ zum Bereich Kanten ermittelt (Links nach rechts oder Rechts nach links; Standard = Links nach rechts).

Geschlossen Kantenübergang

Gibt den Übergang der Kante an (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Regel:Erste Kante

Definiert, ob die erste ermittelte Kante bei der Entscheidung, ob ein Kantenkandidat als Kante gewertet wird, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Regel:Stärkste Kante

Definiert, ob die Kante mit dem stärksten Kontrastübergang bei der Entscheidung, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Schwellenwert für Güte

Definiert einen Schwellenwert für die Güte, um Kanten mit einer Güte (0 bis 255; Standard = 10) unterhalb dieses Werts herauszufiltern.


Messungswerkzeug "Min./Max. Punkte" – Registerkarte "Passform"

Bei Auswahl der Registerkarte Passform zeigt das Werkzeug alle gefundenen Kantenkandidaten innerhalb des Bereichs und der eingepassten Linie oder des Kreises an. Die Kantenkandidaten sind die möglichen Kanten, die beim Erzeugen von eingepassten Linien bzw. Kreisen berücksichtigt werden. Sie werden durch kleine Kreise angezeigt.

Geschlossen An Linie anpassen

Legt den Typ der eingepassten Linie fest ("Keine", "An gerade Linie anpassen", "An Kreislinie anpassen", "Automatisch anpassen" oder "Bereich"; Standard = "Automatisch anpassen"), die aus den ermittelten Kanten erstellt wird.

  • Bei Auswahl von Keine erzeugt das Werkzeug keine eingepasste Linie, und die Position der gefundenen Kanten wird relativ zur Bereichsmitte gemessen.
  • Bei Auswahl von An gerade Linie anpassen erzeugt das Werkzeug eine gerade, eingepasste Linie aus den ermittelten Kanten. Die Position der ermittelten Kanten wird relativ zur eingepassten Linie gemessen.
  • Bei Auswahl von An Kreislinie anpassen erzeugt das Werkzeug eine eingepasste Kreislinie aus den ermittelten Kanten. Die Position der ermittelten Kanten wird relativ zur eingepassten Linie gemessen.
  • Bei Auswahl von Automatisch anpassen erzeugt das Werkzeug automatisch entweder eine gerade, eingepasste Linie oder eine eingepasste Kreislinie aus den ermittelten Kanten. Die Position der ermittelten Kanten wird relativ zur eingepassten Linie gemessen.
  • Bei Auswahl von Bereich erzeugt das Werkzeug automatisch entweder eine gerade, eingepasste Linie oder eine eingepasste Kreislinie aus den ermittelten Kanten. Die Position der ermittelten Kanten wird relativ zu den Seiten des Bereichs gemessen.
Geschlossen Ausreißer filtern

Legt fest, ob das Werkzeug Punkte aus der eingepassten Linie entfernt, deren Abstand größer ist als durch den Parameter "Abstandfilter anpassen" definiert (standardmäßig ist dieser Parameter deaktiviert).

Geschlossen Abstandfilter anpassen

Definiert den Abstand (1 bis 1920; Standard = 2) in Pixeln einer Kante von der ursprünglichen eingepassten Linie, der zur Berechnung der erneuten Anpassung verwendet wird. Mithilfe dieses Parameters wird vermieden, dass Fehler die Linienanpassung beeinträchtigen.

Hinweis: Der Parameter "Ausreißer filtern" muss aktiviert sein, um diesen Parameter zu verwenden.
Geschlossen Höchster Punktfilterabstand

Definiert den Ausreißerabstand (1 bis 1920; Standard = 1000), bei dessen Überschreitung Kanten nicht zur Bestimmung der Mindest- und Höchstabstände verwendet werden. Alle Kanten, die diesen Wert überschreiten, werden ignoriert.

Geschlossen Erneut auswerten

Definiert, ob die ermittelten Kanten erneut ausgewertet werden, um sicherzustellen, dass ermittelte Kanten, die ursprünglich gelöscht wurden, korrekt gefiltert wurden (standardmäßig ist dieser Parameter aktiviert).

Geschlossen Erneut anpassen

Legt fest, ob das Werkzeug die eingepasste Linie nach der erneuten Auswertung der Kanten erneut anpasst (dieser Parameter ist standardmäßig aktiviert).

Hinweis: Die Genauigkeit des Werkzeugs ist höher, wenn dieser Parameter aktiviert ist. Die Verarbeitungszeit erhöht sich jedoch.
Geschlossen Ergebnis

Zeigt die eingepasste Linie im Bild und die Position der Punkte an, die der eingepassten Linie am nächsten liegen und am weitesten von ihr entfernt sind.


Zählwerkzeuge – Blobs

Das Zählwerkzeug "Blobs" zählt die Anzahl der Blobmerkmale in einem Bereich des Bildes.

Das Zählwerkzeug "Blobs" ist eines der schnelleren Werkzeuge und findet Blobmerkmale deutlich schneller als ein An-/Abwesenheitswerkzeug "Muster". Dieses Werkzeug ist in vielen Zählanwendungen hilfreich, z. B. zum Überprüfen, ob die korrekte Anzahl von Pins an einem Stecker vorhanden ist, oder zum Zählen der Schokoladenstückchen in einem Plätzchen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Zählwerkzeugs "Blobs"

Nach der Auswahl des Werkzeugs müssen Sie den Bereichstyp festlegen und in dem Bild konfigurieren, in dem Sie die Blobmerkmale erwarten:

Hinweis: Versuchen Sie, bei der Auswahl von Blobs für eine Inspektion die Blobs auszuwählen, die einen hohen Kontrast zwischen hellen und dunklen Pixeln aufweisen.

  1. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp aus: Rechteck (Standard), Kreis, Annulus oder Polygon. Positionieren und konfigurieren Sie den Bereich im Bild, in dem die Blobs voraussichtlich erscheinen werden. Die Grenzen des Bereichs müssen die Blobs und ihre möglichen Positionen einschließen. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich die Blobs in jedem Bild nahezu an derselben Position befinden oder der Bereich groß genug ist für die erwartete Bewegung der Merkmale.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Zählwerkzeugs "Blobs"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Zählwerkzeugs "Blobs" umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Bereichsbeschränkungen"
  • Registerkarte „Histogramm“
  • Registerkarte „Zusammengesetzter Bereich“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Grenzwerte“

Registerkarte „Histogramm“

Registerkarte „Zusammengesetzter Bereich“


Zählwerkzeug „Blobs“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Blob_1“, sofern es sich um das erste Blobwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Blob_2“, „Blob_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Zählwerkzeug "Blobs" - Registerkarte "Einstellungen"

Geschlossen Schwellwertmodus

Gibt den Modus zum Ermitteln des Graustufenwerts an, mit dem Blobs vom Hintergrund unterschieden werden. Bei Auswahl von "Automatisch" (Standardeinstellung), gleicht das Werkzeug bei jeder Bildaufnahme die Helligkeitsänderungen von Bild zu Bild aus. Bei Auswahl von "Manuell" wird der Wert manuell eingegeben und angepasst.

Geschlossen Blobschwellwert

Definiert den Graustufenwert, der zur Unterscheidung von Blobs und dem Hintergrund verwendet wird (0 - 255, sofern aktiviert). Dieses Steuerelement ist standardmäßig deaktiviert. Zur Aktivierung muss der Schwellwertmodus auf "Manuell" gesetzt sein. Verwenden Sie das Diagramm, um einen optimalen Wert für Ihre Anwendung festzulegen.

Geschlossen Blobfarbe

Gibt die Blobfarbe an ("Schwarz", "Weiß" oder "Beide"; Standard = "Beide").

  • Beide: Keine Anforderungen für die Blobfarbe vorhanden.
  • Schwarz: Gibt nur Blobs zurück, die unter dem Blobschwellwert liegen.
  • Weiß: Gibt nur Blobs zurück, die über dem Blobschwellwert liegen.
Geschlossen Begrenzung

Gibt eine von zwei Möglichkeiten für die Blobverwaltung an, die die Begrenzung des Blobbereichs überschneiden (Standard = "Aus", nicht aktiviert):

  • Nicht aktiviert: Umfasst keine Blobs, die die Bereichsbegrenzung überschneiden. Der Blob muss sich beispielsweise vollständig innerhalb des zu erkennenden Bereichs befinden.
  • Aktiviert: Umfasst Blobs, die die Bereichsbegrenzung überschneiden (beispielsweise werden Blobs mit Überschneidung erkannt, sofern diese die anderen Kriterien erfüllen).
Geschlossen Mindestgröße

Steht für eine Mindestgröße in Pixeln (0 bis 900.000; Standard = 100) für alle erkannten Blobs. Es werden nur Blobs erkannt, deren Größe über der Mindestgröße liegt.

Geschlossen Maximale Größe

Steht für eine maximale Größe in Pixeln (0 bis 900.000; Standard = 100000) für alle erkannten Blobs. Es werden nur Blobs erkannt, deren Größe unter dem Höchstwert liegt.


Zählwerkzeug "Blobs" – Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert die zulässige Höchstanzahl zu erkennender Blobs. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limits-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Blobanzahl

Zeigt die aktuelle Anzahl erkannter Blobs an (die im Bild gezählten Blobs basieren auf einer numerischen Reihenfolge, wobei 0 = 1 ist). Werte, die genau auf die Einstellungen für Minimum und Maximum oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Geschlossen Minimum

Definiert die zulässige Mindestanzahl zu erkennender Blobs. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limits-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Zählwerkzeug "Blobs" – Registerkarte "Histogramm"

Das Histogramm ist eine grafische Dastellung der Graustufenwerte für die Pixel in einem bestimmten Bereich.

  • Die X-Achse des Diagramms steht für die Gesamtzahl der Graustufenwerte (0 bis 255 oder insgesamt 256 Grauschattierungen).
  • Die Y-Achse des Diagramms gibt die Anzahl der Pixel eines bestimmten Graustufenwerts an. Zudem erfolgt die Skalierung durch Anzeige des Graustufenwerts mit der höchsten Anzahl an Pixeln.
  • Die blaue vertikale Linie steht für den Schwellenwert, mit dem der Bildbereich in schwarze und weiße Pixel aufgeteilt wird. Werte auf der linken Seite der Linie entsprechen schwarzen Pixeln und Werte auf der rechten Seite entsprechen weißen Pixeln.
Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


Zählwerkzeug "Blobs" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.
Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


Zählwerkzeuge – Farb-Blobs

Das Zählwerkzeug "Farb-Blobs" zählt die Anzahl der Blobmerkmale in einem Bereich des Bildes.

Das Zählwerkzeug "Farb-Blobs" ist eines der schnelleren Werkzeuge und findet Blobmerkmale deutlich schneller als ein An-/Abwesenheitswerkzeug "Muster". Dieses Werkzeug ist in vielen Zählanwendungen hilfreich, z. B. zum Überprüfen, ob die korrekte Anzahl von Pins an einem Stecker vorhanden ist, oder zum Zählen der Schokoladenstückchen in einem Plätzchen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Zählwerkzeugs "Farb-Blobs"

Nach der Auswahl des Werkzeugs müssen Sie den Bereichstyp festlegen und in dem Bild konfigurieren, in dem Sie die Blobmerkmale erwarten:

  1. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp aus: Rechteck (Standard), Kreis, Annulus oder Polygon. Positionieren und konfigurieren Sie den Bereich im Bild, in dem die Blobs voraussichtlich erscheinen werden. Die Grenzen des Bereichs müssen die Blobs und ihre möglichen Positionen einschließen. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich die Blobs in jedem Bild nahezu an derselben Position befinden oder der Bereich groß genug ist für die erwartete Bewegung der Merkmale.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Nach der Konfiguration des Suchbereichs müssen die Farbbibliothek des Werkzeugs konfiguriert und die entsprechenden Farbmodelle aktiviert werden:

    • Wurde das erste Mal ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“) hinzugefügt, müssen zunächst die Farbbibliotheken und die Farbmodelle definiert werden.

    • Wurde zuvor ein weiteres Farbwerkzeug hinzugefügt und sollen eine vorhandene Farbbibliothek und ihre eingelernten Farbmodelle verwendet werden, wählen Sie auf der Registerkarte "Einstellungen" die gewünschte Farbbibliothek, und aktivieren Sie anschließend mithilfe der Kontrollkästchen auf der Registerkarte "Bibliothek" die gewünschten Farbmodelle.

    • Wurde keine Farbbibliothek definiert, gibt das Werkzeug automatisch eine Fehlermeldung aus. Wurde eine Farbbibliothek definiert, wird sie automatisch vom Werkzeug verwendet und alle darin enthaltenen Farbmodelle werden aktiviert.

  4. Nachdem die Farbmodelle und die Farbbibliotheken festgelegt wurden, wird das Bild vom Werkzeug verarbeitet und alle Pixel innerhalb des Suchbereichs, die mit dem ausgewählten Farbmodell übereinstimmen, werden in die unbunte Farbe Weiß (255) umgewandelt. Die Pixel, die nicht mit dem ausgewählten Farbmodell übereinstimmen, erhalten die unbunte Farbe Schwarz (0).
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Zählwerkzeugs "Farb-Blobs"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Zählwerkzeugs "Farb-Blobs" enthält folgende Objekte:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Bereichsbeschränkungen"
  • Registerkarte "Farbbibliothek"
  • Registerkarte "Zusammengesetzter Bereich"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Grenzwerte“

Registerkarte „Farbbibliothek“

Registerkarte „Zusammengesetzter Bereich“


Zählwerkzeug „Farb-Blobs“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Blob_1“, sofern es sich um das erste Blobwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Blob_2“, „Blob_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Zählwerkzeug „Farb-Blobs“ – Registerkarte „Einstellungen“

Geschlossen Farbe einlernen

Öffnet das Dialogfeld „ExtractColor – Einlernen“, das zur Definition der ausgewählten Farbmodelle der Farbbibliothek verwendet wird.

Geschlossen Farbbibliothek

Definiert die Farbbibliothek, auf die vom Tool verwiesen wird. Wählen Sie in der Dropdownliste die Farbbibliothek aus, die geändert werden soll, und klicken Sie auf die Schaltfläche Farbe einlernen, um das Dialogfeld „ExtractColor – Einlernen“ zu öffnen. Jede Farbbibliothek kann bis zu 100 unterschiedliche Farbmodelle enthalten, die aus individuellen Farben zusammengesetzt sind.

EasyBuilder-Jobs können maximal 5 Farbbibliotheken enthalten, die unter folgenden Werkzeugen aufgeteilt werden können:

  • Positionswerkzeug „Farb-Blob“
  • Positionswerkzeug „Farb-Blobs (1-10)“
  • An-/Abwesenheitswerkzeug „Farbpixelanzahl“
  • Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“
  • Messungswerkzeug „Farb-Blob-Bereich (1-10)“
  • Zählwerkzeug „Farb-Blobs“
  • Identifizierungswerkzeug „Farbmodell“
  • Filterwerkzeug für Bilder „Farbe zu binär“
Geschlossen Begrenzung

Legt eine von zwei Methoden für die Handhabung von Blobs fest, die den Rand des Bereichs überschneiden (Standard = Aus, deaktiviert):

  • Kontrollkästchen deaktiviert – Blobs, die den Bereichsrand überschneiden, werden nicht aufgenommen; d. h. der Blob muss sich vollständig im Erfassungsbereich befinden.
  • Kontrollkästchen aktiviert – Blobs, die den Bereichsrand überschneiden, werden erfasst; d. h. Blobs, die den Bereichsrand überschneiden, werden erkannt, wenn die anderen Kriterien erfüllt werden.
Geschlossen Kleinste Fläche

Definiert ein minimales Flächenlimit, in Anzahl von Pixeln (0 bis 16777216; Standard = 100), für alle erkannten Blobs. Nur Blobs mit einer Fläche, die größer als die kleinste Fläche ist, werden erkannt.

Geschlossen Größte Fläche

Definiert ein maximales Flächenlimit, in Anzahl von Pixeln (0 bis 16777216; Standard = 100000), für alle erkannten Blobs. Nur Blobs mit einer Fläche, die kleiner als die größte Fläche sind, werden erkannt.

Geschlossen Glättungsfaktor

Definiert den Faktor (0 bis 25; Standard = 1), um den das Bild geglättet werden soll. Tragen Sie den Wert 0 ein, wenn keine Glättung erfolgen soll.

Geschlossen Originalbild anzeigen
  • Deaktiviert (Standard): Im ausgewählten Bereich wird ein binäres Ausgabebild in Graustufen angezeigt.
  • Aktiviert: Im ausgewählten Bereich wird das ursprüngliche Eingabebild angezeigt.


Zählwerkzeug „Farb-Blobs“ – Registerkarte „Bereichsbeschränkungen“

Geschlossen Maximum

Definiert die zulässige Höchstanzahl zu erkennender Blobs. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limits-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Blobanzahl

Zeigt die aktuelle Anzahl erkannter Blobs an (die im Bild gezählten Blobs basieren auf einer numerischen Reihenfolge, wobei 0 = 1 ist). Werte, die genau auf die Einstellungen für Minimum und Maximum oder zwischen diese Einstellungen fallen, werden als „gut“ qualifiziert.

Geschlossen Minimum

Definiert die zulässige Mindestanzahl zu erkennender Blobs. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limits-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Zählwerkzeug „Farb-Blobs“ – Farbbibliothek

Geschlossen Liste Farbmodell

Zeigt eine schreibgeschützte Liste der Farbmodelle in der ausgewählten Übereinstimmungsfarbbibliothek an. Die Farbmodelle werden mittels der Kontrollkästchen neben dem Namen der Farbmodelle aktiviert oder deaktiviert.

Geschlossen Farbtabelle

Zeigt eine schreibgeschützte sortierte Liste der Farben der ausgewählten Farbbibliothek an.

Geschlossen Farbname

Zeigt die Namen der Farben im ausgewählten Farbmodell an.

Geschlossen RGB

Zeigt die RGB-Werte der Farben im ausgewählten Farbmodell an.

Geschlossen Funktion

Zeigt die Funktion der Farben (Hinzufügen oder Subtrahieren) im ausgewählten Farbmodell an.


Zählwerkzeug "Farb-Blobs" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


Zählwerkzeuge – Kanten

Das Zählwerkzeug "Kanten" zählt die Anzahl von Kantenmerkmalen in einem Bereich des Bildes.

Dieses Werkzeug eignet sich z. B. zum Zählen der Gewindegänge einer Schraube oder der Cracker in einer Verpackungsschale.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Verwenden des Zählwerkzeugs "Kanten"

Wählen Sie nach dem Hinzufügen des Werkzeugs den Bereich im Bild aus, in dem nach Kanten gesucht werden soll:

  1. Platzieren und konfigurieren Sie den Bereich über dem Bereich der Kantenmerkmale, und vergewissern Sie sich, dass die Kanten und ihre möglichen Positionen innerhalb der Grenzen des Bereichs liegen. Achten Sie besonders auf die Scanrichtungspfeile im Bereich, um sicherzustellen, dass der Bereich zur optimalen Erkennung der gewünschten Kanten platziert ist.

    Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich die Kanten in jedem Bild nahezu an derselben Position befinden oder der Bereich groß genug für die erwartete Bewegung des Merkmals ist.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Zählwerkzeugs "Kanten"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Zählwerkzeugs "Kanten" umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Bereichsbeschränkungen"
  • Diagramm
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Grenzwerte“

Diagramm


Zählwerkzeug „Kanten“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Edges_1“, sofern es sich um das erste Werkzeug zum Definieren einer Kante handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Edges_2“, „Edges_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Zählwerkzeug „Kanten“ – Registerkarte „Einstellungen“

Geschlossen Kantenkontrast

Definiert die akzeptable Mindestkontrastgüte für die gefundene Kante (1-100; Standard = eine „Smart-Einstellung“, die automatisch schrittweise bis zur Erkennung einer Kante reduziert wird). Diese Einstellung bestimmt die Empfindlichkeit des Werkzeugs bei der Kantenerkennung, d. h. seine Fähigkeit, zwischen dem Merkmal und dem Hintergrund zu unterscheiden. Verwenden Sie diese Einstellung in Verbindung mit dem Diagramm des Werkzeugs, um einen akzeptablen Bereich festzulegen.

Hinweis: Wenn dieser Parameter auf „0“ gesetzt ist, werden möglicherweise unerwartete Kanten gefunden.
Geschlossen Güte normalisieren

Legt fest, ob die Kantengüten durch das Graustufen-Histogramm des Bereichs normalisiert werden.Dieser Parameter ist für die Suche nach Kanten in Bereichen mit niedrigem Kontrast nützlich. Deaktivieren Sie diesen Parameter, wenn nur Kanten mit hohem Kontrast erwartet werden.

  • Aktiviert (Standard): Normalisiert die Güte.
  • Deaktiviert: Normalisiert die Güte nicht.
Geschlossen Kantenübergang

Gibt den Übergang der Kante an (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie zur Erhöhung der Genauigkeit und Geschwindigkeit den Übergangstyp an.

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 50; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Winkelbereich

Definiert die maximale Winkelverschiebung, die bei der gefundenen Kante möglich ist (0-10°; Standard = 10°). Je größer die zulässige Winkelvariation, desto länger dauert die Ausführung des Werkzeugs.


Zählwerkzeug "Kanten" – Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert die zulässige Höchstanzahl zu erkennender Kanten. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Kanten

Zeigt die aktuelle Anzahl erkannter Kanten an (die im Bild gezählten Kanten basieren auf einer numerischen Reihenfolge, wobei 0 = 1 ist). Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Geschlossen Minimum

Definiert die zulässige Mindestanzahl zu erkennender Kanten. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Zählwerkzeug "Kanten" – Diagramm

Das Diagramm ist eine Darstellung der ersten Ableitung von den Graustufenwerten eines Bereichs. Spitzen- und Talwerte stellen die deutlichsten Kantenübergänge dar.

Bei Werkzeugen zur Kantenerkennung (Werkzeuge für Kanten und Kreise) gibt die Güte-Achse an, wie stark die gefundene Kante mit den festgelegten Parametern übereinstimmt:

  • Eine positive Güte weist darauf hin, dass der Kantenübergang von dunkel zu hell erfolgt.
  • Eine negative Güte weist darauf hin, dass der Kantenübergang von hell zu dunkel erfolgt.
  • Bei einer Güte mit einem Wert von 0 wurde keine Kante erkannt.

Die Versatz-Achse gibt den Bereich an, mit dem das Kantenmerkmal definiert wird. Der Wert "0" bezieht sich auf die Anfangspunktbegrenzung des Bereichs. Der andere Wert steht für die maximale Breite des Bereichs in Pixeln. Der Scheitelpunkt der Spitzen- und Talwerte an der Versatz-Achse gibt die Position der gefundenen Kante an.

Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


Zählwerkzeuge – Kantenpaare

Das Zählwerkzeug "Kantenpaare" zählt die Anzahl der linearen Kantenpaare in einem Bereich des Bildes.

Das Zählwerkzeug "Kantenpaare" unterscheidet sich insofern vom Zählwerkzeug "Kanten", als Sie im Zählwerkzeug "Kantenpaare" einen erwarteten Abstand (Breite) zwischen Kantenpaaren festlegen können. Dies ist z. B. in Anwendungen wie dem Zählen der korrekten Zähneanzahl eines Zahnrads oder dem Zählen der Anschlussdrähte auf einem Computerchip hilfreich.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Zählwerkzeugs "Kantenpaare"

Wählen Sie nach dem Hinzufügen des Werkzeugs den Bereich im Bild aus, in dem nach Kanten gesucht werden soll:

  1. Platzieren und konfigurieren Sie den Bereich über dem Bereich der Kantenmerkmale, und vergewissern Sie sich, dass die Kanten und ihre möglichen Positionen innerhalb der Grenzen des Bereichs liegen.

    Die Scanrichtung des Bereichs, die Parameter auf der Registerkarte "Einstellungen" und die konfigurierten Bereichsbeschränkungen sind bei der Ermittlung der Anzahl erkannter Kantenpaare entscheidend:

    2. Geschlossen Beispiel 1

    Geschlossen Beispiel 2

    Geschlossen Beispiel 3

    Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich die Kanten in jedem Bild nahezu an derselben Position befinden oder der Bereich groß genug für die erwartete Bewegung des Merkmals ist.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Zählwerkzeugs "Kantenpaare"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Zählwerkzeugs "Kantenpaare" umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Bereichsbeschränkungen"
  • Diagramm
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Grenzwerte“

Diagramm


Zählwerkzeug „Kantenpaare“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „EdgePairs_1“. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „EdgePairs_2“, „EdgePairs_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Zählwerkzeug „Kantenpaare“ – Registerkarte „Einstellungen“

Geschlossen Kantenkontrast

Definiert die akzeptable Mindestkontrastgüte für die gefundene Kante (1-100; Standard = eine Smart-Einstellung , die automatisch schrittweise bis zur Erkennung einer Kante reduziert wird). Diese Einstellung bestimmt die Empfindlichkeit des Werkzeugs bei der Kantenerkennung, d. h. seine Fähigkeit, zwischen dem Merkmal und dem Hintergrund zu unterscheiden.

Hinweis: Wenn dieser Parameter auf „0“ gesetzt ist, werden möglicherweise unerwartete Kanten gefunden.
Geschlossen Güte normalisieren

Legt fest, ob die Kantengüten durch das Graustufen-Histogramm des Bereichs normalisiert werden.Dieser Parameter ist für die Suche nach Kanten in Bereichen mit niedrigem Kontrast nützlich. Deaktivieren Sie diesen Parameter, wenn nur Kanten mit hohem Kontrast erwartet werden.

  • Aktiviert (Standard): Normalisiert die Güte.
  • Deaktiviert: Normalisiert die Güte nicht.
Geschlossen Erster Kantenübergang

Definiert den Übergang der ersten Kante („Dunkel zu Hell“, „Hell zu Dunkel“ oder „Beides“; Standard = Beides). Durch Festlegen des Übergangstyps können Sie die Genauigkeit und Geschwindigkeit erhöhen.

Geschlossen Zweiter Kantenübergang

Definiert den Übergang der zweiten Kante („Dunkel zu Hell“, „Hell zu Dunkel“ oder „Beides“; Standard = Beides). Durch Festlegen des Übergangstyps können Sie die Genauigkeit und Geschwindigkeit erhöhen.

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 50; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Winkelbereich

Definiert die maximale Winkelverschiebung, die bei der gefundenen Kante möglich ist (0-10°; Standard = 10°). Je größer die zulässige Winkelvariation, desto länger dauert die Ausführung des Werkzeugs.

Geschlossen Mindestabstand

Definiert einen Mindestabstand in Pixel (0 bis 900000; Standard = 10) zwischen Kanten für alle erkannten Kantenpaare. Es werden nur Kantenpaare erkannt, deren Abstand über dem Mindestabstand liegt.

Geschlossen Maximaler Abstand

Definiert einen Höchstabstand in Pixel (0 bis 900000; Standard = 50) zwischen Kanten für alle erkannten Kantenpaare. Es werden nur Kantenpaare erkannt, deren Abstand unter dem Höchstabstand liegt.


Zählwerkzeug "Kantenpaare" – Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert die zulässige Höchstanzahl zu erkennender Kantenpaare. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Kantenpaare

Zeigt die aktuelle Anzahl erkannter Kantenpaare an (die im Bild gezählten Kantenpaare basieren auf einer numerischen Reihenfolge, wobei 0 = 1 ist). Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Geschlossen Minimum

Definiert die zulässige Mindestanzahl zu erkennender Kantenpaare. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Zählwerkzeug "Kantenpaare" – Diagramm

Das Diagramm ist eine Darstellung der ersten Ableitung von den Graustufenwerten eines Bereichs. Spitzen- und Talwerte stellen die deutlichsten Kantenübergänge dar.

Bei Werkzeugen zur Kantenerkennung (Werkzeuge für Kanten und Kreise) gibt die Güte-Achse an, wie stark die gefundene Kante mit den festgelegten Parametern übereinstimmt:

  • Eine positive Güte weist darauf hin, dass der Kantenübergang von dunkel zu hell erfolgt.
  • Eine negative Güte weist darauf hin, dass der Kantenübergang von hell zu dunkel erfolgt.
  • Bei einer Güte mit einem Wert von 0 wurde keine Kante erkannt.

Die Versatz-Achse gibt den Bereich an, mit dem das Kantenmerkmal definiert wird. Der Wert "0" bezieht sich auf die Anfangspunktbegrenzung des Bereichs. Der andere Wert steht für die maximale Breite des Bereichs in Pixeln. Der Scheitelpunkt der Spitzen- und Talwerte an der Versatz-Achse gibt die Position der gefundenen Kante an.

Hinweis: Das Diagramm wird unabhängig vom Online/Offline-Status oder dem Bestanden/Nicht bestanden-Status des Tools angezeigt. Das Diagramm wird jedoch nicht aktualisiert, wenn ein Werkzeug fortlaufend ein Nicht bestanden liefert.


Zählwerkzeuge: PatMax RedLine-Muster und PatMax-Muster

Hinweis:
  • Ab der In-Sight-Firmwareversion 5.5.0 oder höher wurde der Algorithmus des Werkzeugs geändert. Es gibt jetzt genauere Ergebnisse zurück und verringert in einigen Fällen die Ausführungszeit.
  • Aufgrund dieser Änderung wird bei dem Versuch, einen Job, der mit der In-Sight-Firmwareversion 5.5.0 oder höher konfiguriert wurde, in ein In-Sight Vision-System zu laden, das die Firmwareversion 5.4.x oder früher ausführt, eine Fehlermeldung angezeigt.
  • Das Zählwerkzeug PatMax RedLine-Muster ist nur auf In-Sight Vision-Systemen mit In-Sight-Firmware 5.2.0 und höher verfügbar. Eine komplette Modelliste mit unterstützten Firmwareversionen finden Sie im Abschnitt Firmwareversionen.

Die Zählwerkzeuge PatMax RedLine-Muster und PatMax-Muster dienen zum Zählen der Instanzen eines Mustermerkmals. Dabei wird der PatMax RedLine- oder PatMax-Algorithmus auf Basis einer eingelernten Darstellung dieses Musters (als Modell bezeichnet) verwendet.

Diese Werkzeuge eignen sich z. B. für Anwendungen wie dem Zählen der Schrauben in einer mechanischen Baugruppe oder dem Zählen der Ampullen in einer Verpackungsschale.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten der Zählwerkzeuge "PatMax-Muster" und "PatMax-Muster"

Wählen Sie nach dem Hinzufügen des Werkzeugs die Bereichstypen aus und konfigurieren Sie sie, um das Muster zu definieren (den Modellbereich) und den Bereich im Bild festzulegen, an der das Muster gefunden wird (den Suchbereich).

  1. Wählen Sie im Dropdown-Menü Modell den Bereichstypaus: Rechteck (Standard), Kreis, Annulus oder Polygon. Platzieren Sie den Modellbereich über dem Muster, das als Trainingsmodell dient. Stellen Sie sicher, dass der Modellbereich nur die wichtigen Merkmale des Musters abdeckt.Hinweis:Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Wählen Sie im Dropdownmenü Suchen den Bereichstyp "Rechteck" (Standard), "Kreis", "Annulus" oder "Polygon". Platzieren Sie anschließend den Suchbereich so, dass er die Bereiche im Bild abdeckt, in denen das Muster Ihrer Meinung nach erscheint. Erstellen Sie kleinere Suchbereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Suchbereich ist, desto länger dauert die Inspektion mit dem Werkzeug.
  3. Klicken Sie auf OK, um die Bereiche zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

Auswählen eines Mustermerkmals

PatMax RedLine-Muster, PatMax-Muster und Muster


Auswählen eines Mustermerkmals

Beachten Sie bei der Auswahl eines Musters für eine Inspektion die folgenden Kriterien, um die besten Ergebnisse zu erzielen:

  • Das Muster ist in jedem Bild durchweg präsent .
  • Das Muster besteht aus möglichst vielen eindeutigen und gleichmäßigen Merkmalen. Zudem sind die Merkmale, aus denen das Muster besteht, klar definiert und weisen eine gleichmäßige Darstellung und relative Geometrie auf.
  • Wählen Sie - sofern möglich - ein größeres Muster aus. Größere Muster beinhalten mehr eindeutige Merkmale. Dies ermöglicht eine gleichmäßigere und genauere Erkennung.


PatMax RedLine-Muster und PatMax-Muster und Muster

Hinweis: Das Zählwerkzeug PatMax RedLine-Muster ist nur auf In-Sight Vision-Systemen mit In-Sight-Firmware 5.2.0 und höher verfügbar. Eine komplette Modelliste mit unterstützten Firmwareversionen finden Sie im Abschnitt Firmwareversionen.

Die Werkzeuge PatMax RedLine-Muster, PatMax-Muster und Muster suchen nach eingelernten Modellmustern und bieten die höchste Genauigkeit im Vergleich zu anderen Inspektionswerkzeugen. Die Werkzeuge PatMax RedLine-Muster und PatMax-Muster sind jedoch leistungsstärker als das Werkzeug Muster. Sie können stärkere Änderungen der Lichtverhältnisse und der Musterposition berücksichtigen . Zudem bieten sie eine genauere Erkennung von Änderungen im Hinblick auf die Musterskalierung, Musterdrehung, Verdeckung von Musterelementen sowie Änderungen der Musterdarstellung in Abhängigkeit von Lichtverhältnissen.

Der Hauptunterschied zwischen PatMax RedLine-Muster und PatMax-Muster liegt in der Geschwindigkeit. PatMax RedLine-Muster verwendet den neuesten Muster-Übereinstimmungsalgorithmus und kann in einem 5-Megapixel Bild eingelernte Merkmale bis zu 7x schneller als PatMax-Muster finden. Deshalb ist PatMax RedLine-Muster die ideale Wahl für Vision-Systeme mit hoher Auflösung.

Das Werkzeug Muster ist in den meisten Fällen schneller als PatMax. Jedoch spielen in folgenden Situationen die Genauigkeit und Zuverlässigkeit der PatMax RedLine- und PatMax-Version eine wesentliche Rolle:

  • Änderungen von Lichtverhältnissen und Reflektionen sind schwer zu kontrollieren. Beispielsweise können Metallteile Licht in zufälligen Richtungen reflektieren.
  • Das zu inspizierende Muster ist ähnlich geformt oder schattiert wie ein Hintergrundelement oder das Muster überschneidet sich mit Bildobjekten bzw. wird teilweise von diesen verdeckt.
  • Sie möchten einen Mustertyp von anderen, ähnlichen Mustern genau differenzieren.
  • Die Bedingungen der Bereitstellungsumgebung sind zu komplex für das Werkzeug Muster, um gleichmäßige und zuverlässige Ergebnisse zu erzielen.


Anpassen der Parameter der Zählwerkzeuge "PatMax RedLine-Muster" und "PatMax-Muster"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster der Zählwerkzeuge PatMax RedLine Muster und PatMax Muster enthält folgende Elemente:

  • Registerkarte Allgemein
  • Registerkarte Einstellungen
  • Registerkarte Bereichsbeschränkungen
  • Registerkarten Modell und Suchen
  • Registerkarte Trainiertes Bild
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Grenzwerte“

Registerkarten „Modell“ und „Suchen“

Registerkarte „Trainiertes Bild“


Zählwerkzeuge PatMax RedLine-Muster und PatMax-Muster – Registerkarte Allgemein

Geschlossen Werkzeugname

Definiert den Namen des Inspektionswerkzeugs, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Pattern_1“, sofern es sich um das erste Musterwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Pattern_2“, „Pattern_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Zählwerkzeuge „PatMax RedLine-Muster“ und „PatMax-Muster“ – Registerkarte „Einstellungen“

Geschlossen Akzeptanzschwellenwert

Gibt den Übereinstimmungsgrad an, der zwischen dem Muster Modell und dem gefundenen Muster vorhanden sein muss (0 – 100; Standard = 50). Liegen die Werte der gefundenen Muster über der Einstellung bzw. entsprechen sie dieser, liegt eine Übereinstimmung vor. Dieses Werkzeug lässt sich mit einer höheren Einstellung schneller ausführen. Dies erfordert ebenfalls einen höheren Übereinstimmungsgrad zwischen dem Modell und dem gefundenen Muster. Niedrigere Einstellungen beinhalten eine höhere Wahrscheinlichkeit für ungenauere Ergebnisse, beispielsweise die Erkennung von Mustern, die dem Muster Modell ähneln, diesem jedoch nicht entsprechen.

Geschlossen Kontrastschwellenwert

Definiert den geringsten akzeptablen Kontrastwert, den das gefundene Muster aufweisen muss. Der Kontrast des gefundenen Musters muss höher als der Wert für den Kontrastschwellenwert sein, um als gültige Instanz zu gelten. Der Standardwert liegt bei PatMax RedLine-Muster bei 0 und der gültige Parameterbereich liegt zwischen 0-100. Der Standardwert liegt bei PatMax-Muster bei 10 und der gültige Parameterbereich liegt zwischen 0-255. Ein niedriger Kontrastschwellenwert wird für Bilder mit einem niedrigen Kontrast verwendet, während ein hoher Kontrastschwellenwert für Bilder mit hohem Kontrast verwendet wird.

Hinweis: PatMax RedLine-Muster kontrastiert das "relative" Maß von Kontrast zwischen Merkmalen im eingelernten Muster im trainierten Bild prozentuell mit den Übereinstimmungsmerkmalen im Suchbild. Wenn ein Merkmal einen ähnlich hohen Kontrast wie der Kontrast des Musters aufweist, wird der berichtete Kontrastwert deswegen ungefähr bei 100 liegen. Wenn ein Merkmal einen geringeren Kontrast hat, als der Kontrast des Musters, wird der berichtete Kontrastwert kleiner als 100 sein. Kontrast bei PatMax RedLine-Muster ist anders interpretiert als Kontrast bei PatMax-Muster, wo er den "absoluten" Bildkontrast des Suchbereiches in Graustufen ausdrückt.
Geschlossen Winkeltoleranz

Gibt an, wie weit das gefundene Muster von der Position des Musters „Modell“ gedreht und dennoch als gültiges Muster erkannt werden kann (± 0 – 180°; Standard =15°). Bei einem größeren Bereich für die Rotationsabweichung des Musters verlängert sich die Ausführung des Werkzeugs.

Geschlossen Skalierungstoleranz

Gibt den zulässigen Prozentsatz der Skalierung (Größenunterschiede) zwischen dem gefundenen Muster und dem Muster Modell an (0 - 50; Standard = 0). Der Wert entspricht einem positiven oder negativen Prozentsatz. Beispielsweise lassen sich mit dem Werkzeug bei einem Wert von "5" Muster finden, die zu 95 % bis 105 % der Größe des Musters Modell entsprechen. Bei einem größeren Bereich für die Skalierungsabweichung des Musters verlängert sich die Ausführung des Werkzeugs.

Geschlossen Suchmodus

Gibt den zum Einlernen und Erkennen von Mustern verwendeten Suchmodus an: PatMax oder PatQuick. In der Standardeinstellung ist PatMax ausgewählt. PatMax bietet eine höhere Genauigkeit als PatQuick, erfordert für die Ausführung aber mehr Zeit. PatQuick ist weniger genau als PatMax, die Ausführungsdauer ist dafür jedoch kürzer.

Geschlossen Genaue Bewertung

Gibt an, ob fehlende oder verdeckte Merkmale des gefundenen Musters die Güte beeinflussen (Standard = „Aus“, nicht aktiviert). Bei Verwendung der genauen Bewertung („An“, aktiviert) verringert sich die Güte des gefundenen Musters, falls Mustermerkmale fehlen oder blockiert werden.

Geschlossen Polarität ignorieren

Definiert, ob gefundene Muster im Hinblick auf das Muster Modell farblich invertierte Übereinstimmungsmerkmale enthalten dürfen (standardmäßig = Aus, deaktiviert). Wird Polarität ignorieren angewendet (An, aktiviert), werden gefundene Muster mit farblich invertierten Merkmalen, z. B. schwarz/weiß im Gegensatz zu weiß/schwarz im Muster Modell, als mit dem Muster Modell übereinstimmend betrachtet.

Geschlossen Zeitlimit
Definiert den Zeitraum in Millisekunden (0 bis 30000), in dem das Werkzeug nach Mustern sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird. Dieser Parameter ist standardmäßig auf 5.000 gestellt.
Hinweis: PatMax RedLine-Muster beinhaltet keinen Parameter Suchmodus.


Zählwerkzeuge "PatMax RedLine-Muster" und "PatMax-Muster" – Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert die zulässige Höchstanzahl zu erkennender Muster. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Musteranzahl

Zeigt die aktuelle Anzahl erkannter Muster an (die im Bild gezählten Muster basieren auf einer numerischen Reihenfolge, wobei 0 = 1 ist). Werte, die genau auf die Einstellungen für Minimum und Maximum oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Geschlossen Minimum

Definiert die zulässige Mindestanzahl zu erkennender Muster. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limit -Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Invertiert

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Zählwerkzeuge "PatMax RedLine-Muster" und "PatMax-Muster" – Registerkarten "Modell" und "Suchen"

Die Registerkarten Modell und Suchen werden zum Konfigurieren des zusammengesetzten Bereichs für den Modell- und Suchbereich des Werkzeugs verwendet. Zusammengesetzter Bereiche sind Ansammlungen von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon), die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • In der Registerkarte Modell sind zusammengesetzte Bereiche nur aktiviert, nachdem die Schaltfläche Modellbereich einmal angeklickt wurde.
  • Es können einem Zusammengesetzten Bereich maximal 32 Unterbereiche hinzugefügt werden können.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.
Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


Zählwerkzeuge "PatMax RedLine-Muster" und "PatMax-Muster" – Registerkarte "Bild"

Das auf der Registerkarte „Trainiertes Bild“ angezeigte Bild ist eine Miniaturansicht des Musters Modell. Klicken Sie auf die Schaltfläche Modellbereich, um die Größe des Modellbereichs zu ändern oder diesen zu verschieben. Klicken Sie anschließend auf die Schaltfläche Einlernen, um das Muster Modell erneut einzulernen.


Zählwerkzeuge – Muster

Das Zählwerkzeug Muster dient zum Zählen der Vorkommen eines Mustermerkmals. Die Zählung wird anhand einer eingelernten Darstellung dieses Musters (genannt Modell) vorgenommen.

Das Zählwerkzeug „Muster“ eignet sich z. B. für Anwendungen wie dem Zählen der Schrauben in einer mechanischen Baugruppe oder dem Zählen der Ampullen in einer Verpackungsschale.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Zählwerkzeugs "Muster"

Wählen Sie nach dem Hinzufügen des Werkzeugs die Bereiche im Bild aus, mit denen das Muster definiert (der Modellbereich) und die Position im Bild festgelegt werden, an der das Muster gefunden wird (der Suchbereich).

  1. Platzieren Sie den Modellbereich über dem Muster, das als Trainingsmodell dient. Stellen Sie sicher, dass der Modellbereich nur die wichtigen Merkmale des Musters abdeckt.

  2. Platzieren Sie den Suchbereich so, dass er die Bereiche im Bild abdeckt, in denen das Muster Ihrer Meinung nach erscheint. Erstellen Sie kleinere Suchbereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Suchbereich ist, desto länger dauert die Inspektion mit dem Werkzeug.

    Hinweis: Die Bereiche Modell und Suchen können nicht in Bogen- oder Ringform gebogen werden.
  3. Klicken Sie auf OK, um die Bereiche zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

Auswählen eines Mustermerkmals


Anpassen der Parameter des Zählwerkzeugs „Muster“

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Zählwerkzeugs „Muster“ enthält folgende Objekte:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
  • Registerkarte „Bereichsbeschränkungen“
  • Registerkarte „Trainiertes Bild“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Grenzwerte“

Registerkarte „Trainiertes Bild“


Zählwerkzeug „Muster“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Definiert den Namen des Inspektionswerkzeugs, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Pattern_1“, sofern es sich um das erste Musterwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Pattern_2“, „Pattern_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Zählwerkzeug „Muster“ – Registerkarte „Einstellungen“

Geschlossen Eingang Einlernen

Definiert, ob ein Modellmuster über eine Eingangsleitung eingelernt werden soll oder nicht (die Standardeinstellung ist „Aus“, deaktiviert).

  • Eingang: Einlernen eines Modellmusters über eine Eingangsleitung. Die ausgewählte Eingangsleitung wird als Einlernsignal verwendet.

    Hinweis:
    • Diese Option wird nicht angezeigt, wenn das In-Sight Vision-System nicht über diskrete Eingänge verfügt (z. B. Vision-Systeme der In-Sight 8000-Serie, die direktes E/A verwenden).
    • Der Signaltyp der ausgewählten Eingangsleitung muss im Anwendungsschritt Eingänge/Ausgänge auf Ereignistrigger gestellt sein.
    • Beim Einlernen eines Modellmusters wird das Bild verwendet, das zuletzt vom Vision-System/Sensor aufgezeichnet wurde. Es ist nicht erforderlich, das Vision-System/den Sensor erneut auszulösen, um einzulernen.
    • Weitere Informationen finden Sie unter Eingänge: Einlernen eines Modellmusters über eine Eingangsleitung
Geschlossen Automatischer Schwellwert

Gibt den Übereinstimmungsgrad an, der zwischen dem Muster Modell und dem gefundenen Muster vorhanden sein muss (0 - 100; Standard = 50). Liegen die Werte der gefundenen Muster über der Einstellung bzw. entsprechen sie dieser, liegt eine Übereinstimmung vor. Dieses Werkzeug lässt sich mit einer höheren Einstellung schneller ausführen. Dies erfordert ebenfalls einen höheren Übereinstimmungsgrad zwischen dem Modell und dem gefundenen Muster. Niedrigere Einstellungen beinhalten eine höhere Wahrscheinlichkeit für ungenauere Ergebnisse, beispielsweise die Erkennung von Mustern, die dem Muster Modell ähneln, diesem jedoch nicht entsprechen.

Geschlossen Rotationstoleranz

Gibt an, wie weit das gefundene Muster von der Position des Musters „Modell“ entfernt sein und dennoch als gültiges Muster erkannt werden kann (± 0 - 180°; Standard = 15°). Bei einem größeren Bereich für die Rotationsabweichung des Musters verlängert sich die Ausführung des Werkzeugs.

Geschlossen Skalierung

Definiert die Toleranz des Werkzeugs für Änderungen an der Skalierung des Musters, innerhalb von ±10% der eingelernten Größe des Musters. Standardmäßig ist diese Einstellung deaktiviert, wodurch Skalierungsanpassungen deaktiviert sind. In diesem Modus findet das Werkzeug nach wie vor Muster, die sich innerhalb des Bereichs von ±10% befinden, aber die Güte der Funktion nimmt ab, während der Skalierungsprozentsatz zunimmt.

Geschlossen Modelltyp

Definiert die Art und Weise, auf die vom Werkzeug das Muster Modell erstellt wird: Flächenmodell oder Kantenmodell (Standard). Die Option Flächenmodell erstellt das Muster Modell auf Grundlage einheitlichen Samplings der Graustufenwerte im Bereich Modell. Die Option Kantenmodell erstellt das Muster Modell auf Grundlage der ermittelten Kanten (Hell/dunkel-Übergänge) des Mustermerkmals im Modellbereich.

Geschlossen Genauigkeit

Definiert, wie das Werkzeug den Kompromiss zwischen Genauigkeit/Zuverlässigkeit und Ausführungsgeschwindigkeit bewertet: Genau, Mittel (Standard) und Schnell. Mit Genau erreichen Sie eine höhere Genauigkeit/Zuverlässigkeit und eine niedrigere Ausführungsgeschwindigkeit, mit Schnell erreichen Sie eine niedrigere Genauigkeit/Zuverlässigkeit und eine höhere Ausführungsgeschwindigkeit, und mit Mittel erhalten Sie eine mittlere Genauigkeit/Zuverlässigkeit und eine mittlere Ausführungsgeschwindigkeit.

Geschlossen Zeitüberschreitung

Definiert den Zeitraum in Millisekunden (0 bis 30 000), in dem das Werkzeug nach Mustern sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird.


Zählwerkzeug "Muster" – Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert die zulässige Höchstanzahl zu erkennender Muster. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Musteranzahl

Zeigt die aktuelle Anzahl erkannter Muster an (die im Bild gezählten Muster basieren auf einer numerischen Reihenfolge, wobei 0 = 1 ist). Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Geschlossen Minimum

Definiert die zulässige Mindestanzahl zu erkennender Muster. Das Werkzeug erstellt basierend auf dem Bild eine "Smart Limit"-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Zählwerkzeug "Muster" - Registerkarte "Trainiertes Bild"

Das auf der Registerkarte Trainiertes Bild angezeigte Bild ist eine Miniaturansicht des Musters Modell. Klicken Sie auf die Schaltfläche Modellbereich, um die Größe des Modellbereichs zu ändern oder diesen zu verschieben. Klicken Sie anschließend auf die Schaltfläche Einlernen, um das Muster Modell erneut einzulernen.


/ Identifizierungswerkzeuge – "1D-Code lesen" und "1D-Codes lesen (1-20)"

Die Identifizierungswerkzeuge 1D-Code lesen und 1D-Codes lesen (1-20) decodieren und/oder überprüfen 1D-Barcodes und/oder gestapelte Barcodes mittels ReadIDMax®-Algorithmus. Von den Werkzeugen werden die decodierten Informationen sowie ein positives Ergebnis angezeigt, falls die Codes korrekt decodiert wurden und sich in den angegebenen Schwellenwerten befinden.

Das Identifizierungswerkzeug "1D-Code lesen" wird zum Lesen und/oder Überprüfen eines einzelnen Codes im Bereich verwendet. Das Identifizierungswerkzeug "1D-Codes lesen (1-20)" kann hingegen bis zu 20 Codes im Bereich lesen und/oder überprüfen.

Einrichtung der Werkzeuge

Anpassen der Werkzeugparameter


/ Einrichten der Identifizierungswerkzeuge "1D-Code lesen" und "1D-Codes lesen (1-20)"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie den Bereich im Bild konfigurieren:

  1. Platzieren Sie beim Identifizierungswerkzeug "1D-Code lesen" den Bereich über dem Code bzw. Symbol, und stellen Sie sicher, dass die Grenzen des Bereichs den Code bzw. das Symbol vollständig umschließen. Platzieren Sie beim Identifizierungswerkzeug "1D-Codes lesen (1-20)" den Bereich über der Fläche, auf der die Codes/Symbole erscheinen sollen, und stellen Sie sicher, dass die Grenzen des Bereichs alle zu decodierenden Codes/Symbole umschließen. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Nach dem Bestätigen des Bereichs müssen Sie die Parameter festlegen in Registerkarte Einstellungen:
    1. Der Parameter Modus, der die Betriebsart des Werkzeugs festlegt: Lesen oder Übereinstimmende Zeichenfolge (der Modus ist standardmäßig auf Lesen gesetzt).
    2. Sie müssen beim Identifizierungswerkzeug "1D-Codes lesen (1-20)" auch den Parameter Maximale Ergebnisse festlegen, der die Anzahl der zu decodierenden Codes/Symbole angibt. Standardmäßig ist "1" festgelegt.
  4. Das Werkzeug zieht ein nicht bearbeitbares Umrandungsfeld um den decodierten Code bzw. das decodierte Symbol und fügt das Symbol [image] ein, um die aus dem decodierten Code/Symbol erstellte Vorrichtung anzugeben.
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


/ Anpassen der Parameter der Identifizierungswerkzeuge "1D-Code lesen" und "1D-Codes lesen (1-20)"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster der Identifizierungswerkzeuge "1D-Code lesen" und "1D-Codes lesen (1-20)" enthält die folgenden Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "1D"
  • Registerkarte "Stacked"
  • Registerkarte "Ergebnisse"
  • Tabelle
Hinweis:
  • Die Registerkarte Ergebnisse ist nur für das Identifizierungswerkzeug "1D-Code lesen" aktiviert.
  • Die Registerkarte Tabelle ist nur für das Identifizierungswerkzeug "1D-Codes lesen (1-20)" aktiviert.
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarten „Allgemein“

Registerkarten „Einstellungen“

Registerkarte „1D“

Registerkarten „Stacked“

Registerkarte „Ergebnisse“

Tabelle


/ Identifizierungswerkzeuge „1D-Code lesen“ und „1D-Codes lesen (1-20)“ – Registerkarten „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „IDCode_1“, sofern es sich um das erste Identifizierungswerkzeug „1D-Code lesen“, „1D-Codes lesen (1-20)“, „2D-Codes lesen“, „2D-Codes lesen (1-20)“ oder „Postleitzahl lesen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „IDCode_2“, „IDCode_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


/ Identifizierungswerkzeuge "1D-Code lesen" und "1D-Codes lesen (1-20)" – Registerkarte "Einstellungen"

Geschlossen Maximale Ergebnisse

Legt die maximale Anzahl der zu lesenden Codes/Symbole fest (1 bis 20; Standard = 1).

Hinweis: Überschreitet der angegebene Wert für Maximale Ergebnisse die Anzahl der Codes/Symbole im Bildfeld, wird vom Werkzeug weiterhin nach der angegebenen Anzahl der Codes/Symbole gesucht. Variiert die Anzahl der Codes/Symbole im Bildfeld, kann die Ausführungszeit des Werkzeugs durch Anpassen des Werts im Parameter Zeitlimit verringert werden.
Geschlossen Trainiert

Zeigt an, ob das Werkzeug für einen bestimmten Code bzw. ein bestimmtes Symbol trainiert wurde. Zeigt "1" an, wenn das Werkzeug eingelernt wurde, und "0", wenn es nicht eingelernt wurde.

Geschlossen Trainieren

Lernt ein Modell des gelesenen Codes/Symbols ein; eingelernte Informationen werden beibehalten, bis auf die Schaltfläche Training aufheben geklickt wird. Klicken Sie zum Neutrainieren eines Codes/Symbols auf die Schaltfläche Training aufheben, und klicken Sie anschließend auf Trainieren, wenn der neue Code bzw. das neue Symbol vorliegt. Das Trainieren wird zum Steigern der Werkzeuggeschwindigkeit und -leistung verwendet. Das Werkzeug lernt dabei, welche Art von Code/Symbol decodiert werden soll. Konfigurieren Sie bei Verwendung der Identifizierungswerkzeuge "1D-Codes lesen (1-20)" oder "2D-Codes lesen (1-20)" und des Trainings den Bereich um einen einzelnen Code bzw. ein einzelnes Symbol, bevor Sie auf die Schaltfläche Trainieren klicken. Sie können nach dem Einlernen des Codes/Symbols den Bereich anpassen, um mehrere Codes/Symbole im Bildfeld zu suchen. Das Training funktioniert nur mit einem einzelnen Code/Symbol im Bereich. Wenn Sie auf die Schaltfläche Trainieren klicken und mehrere Codes/Symbole im Bereich vorhanden sind, können Sie nicht vorgeben, welcher Code bzw. welches Symbol eingelernt werden soll. Stellen Sie vor dem Trainieren sicher, dass auf den Registerkarten 1D und Stacked die korrekten Codetypen ausgewählt sind.

Geschlossen Löschen

Hebt das Training eines eingelernten Modellcodes/-symbols auf. Klicken Sie zum Neutrainieren eines Symbols auf die Schaltfläche Training aufheben, und klicken Sie anschließend auf Trainieren, wenn der neue Code vorliegt.

Geschlossen Modus

Legt den Betriebsmodus (Lesen oder Übereinstimmende Zeichenfolge; Standard = Lesen) des Werkzeugs fest.

  • Lesen = Wird verwendet, wenn die Informationen im Code/Symbol unbekannt sind. Das Werkzeug decodiert automatisch die Informationen im Code/Symbol und zeigt die decodierten Informationen unter Zeichenfolge an.
  • Übereinstimmende Zeichenfolge = Wird verwendet, um zu überprüfen, ob ein bekannter Code bzw. ein bekanntes Symbol vorhanden und lesbar ist. Das Werkzeug decodiert die Informationen in Codes/Symbolen und vergleicht die decodierten Informationen mit den Informationen, die Sie in Übereinstimmende Zeichenfolge eingegeben haben.
Geschlossen Suchzeichenkette

Legt die erwartete Zeichenfolge fest (ist nur aktiviert, wenn der Parameter Modus auf Übereinstimmende Zeichenfolge eingestellt ist). Geben Sie die Informationen ein, die das Werkzeug erwartungsgemäß decodieren wird.

Hinweis: Die Übereinstimmungszeichenfolge kann über ein anderes Gerät eingegeben werden. Wenn Sie den Job ausführen, kann das Identifizierungswerkzeug die Textzeichenfolge vom Eingabegerät lesen und mit dem erkannten ID-Code/Symbol vergleichen. Das Werkzeug gibt einen Fehler aus, und im Feld Übereinstimmende Zeichenfolge wird TRIG angezeigt, bis die Übereinstimmende Zeichenfolge vom externen Gerät eingegeben wird.
Geschlossen Übereinstimmungsmodus

Legt fest, ob zum Bestehen alle decodierten Codes/Symbole im Bereich mit der im Parameter Übereinstimmende Zeichenfolge festgelegten Zeichenfolge übereinstimmen sollten. Der Parameter Übereinstimmende Zeichenfolge muss zum Aktivieren dieser Option konfiguriert werden.

  • Alle Übereinstimmungen = Alle decodierten Codes/Symbole müssen mit der im Parameter Übereinstimmende Zeichenfolge festgelegten Zeichenfolge übereinstimmen.
  • Beliebige Übereinstimmungen = Mindestens ein Code bzw. ein Symbol der decodierten Codes/Symbole muss mit der im Parameter Übereinstimmende Zeichenfolge festgelegten Zeichenfolge übereinstimmen.
Geschlossen Prüfsumme

Legt fest, ob der Code bzw. das Symbol mithilfe eines Algorithmus zur Fehlererkennung überprüft wird, um Zuverlässigkeit zu gewährleisten. Standardmäßig ist die Einstellung deaktiviert. Die Prüfsumme wird nur auf Codes/Symbole angewendet, die optionale Prüfsummenalgorithmen enthalten. Jeder Code bzw. jedes Symbol besitzt einen eigenen eindeutigen Prüfsummenalgorithmus. Der verwendete Typ der Prüfsumme, falls zutreffend, hängt vom ausgewählten Code-/Symboltyp ab.

Hinweis: Die Barcodes Code 128, Code 93, RSS, UPC und EAN werden unabhängig von der Parameterauswahl mit einer Prüfsumme überprüft. Wird Prüfsumme für andere Strichcodes aktiviert, wird keine Prüfsumme codiert, und beim Lesevorgang tritt ein Fehler auf.
Geschlossen Sortiermodus

Legt ggf. die Reihenfolge fest, in der Ergebnisse zurückgegeben werden (Keine, Abwärts, Links nach rechts, Alphabetisch oder Zeichenfolgenlänge; Standard = Keine).

  • Keine = Sortiert zuerst nach decodierten Ergebnissen. Nicht decodierte Ergebnisse werden nach den decodierten Ergebnissen angezeigt.
  • Abwärts = Sortiert in aufsteigender Reihenfolge nach X-Fixture-Koordinatenwert.
  • Links nach rechts = Sortiert in aufsteigender Reihenfolge nach Y-Fixture-Koordinatenwert.
  • Alphabetisch = Alphabetische Reihenfolge der Ergebnisse
  • Zeichenfolgenlänge = Sortiert die Ergebnisse nach Zeichenfolgenlänge (kurz zu lang).
  • Zeile = Sortiert die Ergebnisse durch Gruppieren der Symbole in Zeilen und anschließendes Sortieren von links nach rechts innerhalb der einzelnen Zeilen.
  • Spalte = Sortiert die Ergebnisse durch Gruppieren der Symbole in Spalten und anschließendes Sortieren von oben nach unten innerhalb der einzelnen Spalten.
Geschlossen Identische 1D-Symbole zulassen

Legt fest, ob die Funktion alle Symbole innerhalb des Bereiches, auch wenn sie identisch sind, dekodieren soll oder nicht. Zwei Symbole werden für identisch gehalten, wenn sie gleiche Länge, Symbologietyp und dekodierte Zeichenfolge aufweisen (Standardmäßig ist diese Einstellung deaktiviert).

Geschlossen Bewertung

Legt fest, ob die Druckqualitätstests ausgeführt werden sollen (standardmäßig ist diese Einstellung deaktiviert).

Geschlossen UPC-E erweitern

Definiert ob das dekodierte Symbol die 6-stellige UPC-E -Zeichenfolge oder die erweiterte 11-stellige UPC-A-äquivalente Zeichenfolge zurückgeben soll (standardmäßig ist diese Einstellung aktiviert).

Hinweis: Der Parameter Expand UPC-E wird nur auf Vision-Systemen der In-Sight Micro 1000-Serie, der In-Sight 5000-Serie und der 70xx-74xx-Serie mit Firmwareversion 4.10.1 und höher unterstützt.
Geschlossen Timeout

Definiert den Zeitraum in Millisekunden (0 bis 30000; Standard = 0), in dem das Werkzeug nach einem gültigen Code/Symbol sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird.

Geschlossen Anzahl Codes

Zeigt die Anzahl der decodierten Codes/Symbole an.

Hinweis: Die Parameter Maximale Ergebnisse, Übereinstimmungsmodus, Sortiermodus, Identische 1D-Symbole zulassen und Anzahl Codes sind nur beim Identifizierungswerkzeug 1D Codes lesen (1-20) aktiviert.


Identifizierungswerkzeuge "1D-Code lesen" und "1D-Codes lesen (1-20)" – Registerkarte "1D"

Auf dieser Registerkarte wird festgelegt, welche Codes/Symbole decodiert werden sollen. Standardmäßig sind alle Code-/Symboltypen aktiviert. Es können mehrere Symbologien ausgewählt und gelesen werden.

Geschlossen Code 128

Definiert, ob das Werkzeug Code 128 Lesen versuchen soll.

Geschlossen Code 39

Definiert, ob das Werkzeug Code 39 für das Lesen versuchen soll (auch bekannt als Code 3 von 9 und BC39).

Geschlossen Interleaved 2 of 5

Definiert, ob das Werkzeug Code ITF-14 für das Lesen versuchen soll.

Geschlossen Pharmacode

Definiert, ob das Werkzeug Code PharmaCode für das Lesen versuchen soll.

Geschlossen UPC/EAN

Wählt UPC (Universal Product Code) und EAN (European Article Numbering) für das Lesen aus. UPC unterstützt sowohl Version A (Normale Version) und Version E (Null-unterdrückende Version) UPC-Barcodes, als auch 2- und 5-Zeichen ergänzende Enkodierungen. EAN unterstützt sowohl EAN-8- und EAN-13-Barcodes, als auch 2- und 5-Zeichen ergänzende Enkodierungen.

Geschlossen Code 93

Definiert, ob das Werkzeug Code Code 93 für das Lesen versuchen soll.

Geschlossen Codabar

Definiert, ob das Werkzeug Codabar für das Lesen versuchen soll (auch bekannt als USD-4 und Code 2 von 7).


/ Identifizierungswerkzeuge "1D-Code lesen" und "1D-Codes lesen (1-20)" – Registerkarten "Stacked"

Auf dieser Registerkarte wird festgelegt, welche Codes/Symbole decodiert werden sollen. Standardmäßig sind alle Code-/Symboltypen aktiviert. Es können mehrere Symbologien ausgewählt und gelesen werden.

Geschlossen PDF 417

Legt fest, ob das Werkzeug versucht, PDF 417 zu lesen.

Geschlossen DataBar

Legt fest, ob das Werkzeug versucht, DataBar zu lesen.

Geschlossen DataBar Limited

Legt fest, ob das Werkzeug versucht, DataBar Limited zu lesen.

Geschlossen DataBar Expanded

Legt fest, ob das Werkzeug versucht, DataBar Expanded zu lesen.

Geschlossen EAN.UCC Composite

Legt fest, ob das Werkzeug versucht, EAN.UCC Composite zu lesen.


Identifizierungswerkzeug "1D-Code lesen" – Registerkarte "Ergebnisse"

Auf der Registerkarte Ergebnisse werden die folgenden Informationen zum decodierten Code/Symbol angezeigt:

Geschlossen Zeichenfolge

Gibt die in einem decodierten Code/Symbol enthaltene Zeichenfolge zurück.

Geschlossen Symbologie

Gibt den Typ der decodierten Symbologie zurück.

Geschlossen Grad

Gibt den einem decodierten Code/Symbol zugewiesenen Grad zurück.


Identifizierungswerkzeug "1D-Codes lesen (1-20)" – Tabelle

Auf der Registerkarte Tabelle werden für alle decodierten Codes/Symbole die folgenden Informationen angezeigt:

Geschlossen Index

Bezieht sich auf die Reihenfolge des decodierten Codes/Symbols auf Grundlage des Parameters Sortiermodus; 1 bis 20 (die numerische Sortierung in EasyBuilder basiert auf 0 = 1).

Geschlossen Zeichenfolge

Gibt die in einem decodierten Code/Symbol enthaltene Zeichenfolge zurück.

Geschlossen Symbologie

Gibt den Typ der decodierten Symbologie zurück.

Geschlossen X

Gibt die X-Koordinate der Vorrichtungsausgabe des decodierten Codes/Symbols zurück.

Geschlossen Y

Gibt die Y-Koordinate der Vorrichtungsausgabe des decodierten Codes/Symbols zurück.

Geschlossen Winkel

Gibt den Winkelwert der Vorrichtungsausgabe des decodierten Codes/Symbols zurück.

Geschlossen Grad

Gibt den einem decodierten Code/Symbol zugewiesenen Grad zurück.


/ Identifizierungswerkzeuge – "2D-Code lesen" und "2D-Codes lesen (1-20)"

Die Identifizierungswerkzeuge 2D-Code lesen und 2D-Codes lesen (1-20) decodieren und/oder überprüfen QR-Codes und/oder Data Matrix-Symbologien mittels ReadIDMax®-Algorithmus. Von den Werkzeugen werden die decodierten Informationen sowie ein positives Ergebnis angezeigt, falls die Codes korrekt decodiert wurden und sich in den angegebenen Schwellenwerten befinden.

Das Identifizierungswerkzeug "2D-Code lesen" wird zum Lesen und/oder Überprüfen eines einzelnen Symbols im Bereich verwendet. Das Identifizierungswerkzeug "2D-Codes lesen (1-20)" hingegen kann bis zu 20 Symbole im Bereich lesen und/oder überprüfen.

Einrichtung der Werkzeuge

Anpassen der Werkzeugparameter


/ Einrichten der Identifizierungswerkzeuge "2D-Code lesen" und "2D-Codes lesen (1-20)"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie den Bereich im Bild konfigurieren:

  1. Platzieren Sie beim Identifizierungswerkzeug "2D-Code lesen" den Bereich über dem Code bzw. Symbol, und stellen Sie sicher, dass die Grenzen des Bereichs den Code bzw. das Symbol vollständig umschließen. Platzieren Sie beim Identifizierungswerkzeug "2D-Codes lesen (1-20)" den Bereich über der Fläche, auf der die Codes/Symbole erscheinen sollen, und stellen Sie sicher, dass die Grenzen des Bereichs alle zu decodierenden Codes/Symbole umschließen. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion.
Hinweis: Beim Lesen von 2D-Codes muss eine "Ruhezone" zwischen dem Code und dem Bereich eingehalten werden. Die "Ruhezone" erfordert einen Mindestabstand von 3 Pixel zwischen der Kante des Codes und dem Bereich, der den Code definiert.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Nach dem Bestätigen des Bereichs müssen Sie die Parameter festlegen in Registerkarte Einstellungen:
    1. Der Parameter Symbologiegruppe, der den Typ der Symbologie (Data Matrix oder QR-Code) angibt. Standardmäßig wird für die Symbologie Data Matrix festgelegt.
    2. Der Parameter Modus, der die Betriebsart des Werkzeugs festlegt: Lesen oder Übereinstimmende Zeichenfolge (der Modus ist standardmäßig auf Lesen gesetzt).
    3. Sie müssen beim Identifizierungswerkzeug "2D-Codes lesen (1-20)" auch den Parameter Maximale Ergebnisse festlegen, der die Anzahl der zu decodierenden Codes/Symbole angibt. Standardmäßig ist "1" festgelegt.
  4. Das Werkzeug zieht ein nicht bearbeitbares Umrandungsfeld um den decodierten Code bzw. das decodierte Symbol und fügt das Symbol [image] ein, um die aus dem decodierten Code/Symbol erstellte Vorrichtung anzugeben.
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


/ Anpassen der Parameter der Identifizierungswerkzeuge "2D-Code lesen" und "2D-Codes lesen (1-20)"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster der Identifizierungswerkzeuge "2D-Code lesen" und "2D-Codes lesen (1-20)" enthält die folgenden Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Ergebnisse"
  • Tabelle
Hinweis:
  • Die Registerkarte Ergebnisse ist nur für das Identifizierungswerkzeug "2D-Code lesen" aktiviert.
  • Die Registerkarte Tabelle ist nur für das Identifizierungswerkzeug "2D-Codes lesen (1-20)" aktiviert.
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarten „Allgemein“

Registerkarten „Einstellungen“

Registerkarte „Ergebnisse“

Tabelle


/ Identifizierungswerkzeuge „2D-Code lesen“ und „2D-Codes lesen (1-20)“ – Registerkarten „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „IDCode_1“, sofern es sich um das erste Identifizierungswerkzeug „1D-Code lesen“, „1D-Codes lesen (1-20)“, „2D-Codes lesen“, „2D-Codes lesen (1-20)“ oder „Postleitzahl lesen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „IDCode_2“, „IDCode_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


/ Identifizierungswerkzeuge "2D-Code lesen" und "2D-Codes lesen (1-20)" – Registerkarten "Einstellungen"

Geschlossen Symbologie-Gruppe

Definiert den Symbologietyp (Datenmatrix oder QR-Code; Standard = Datenmatrix) für den Dekodierversuch.

Hinweis: Wenn QR-Code gewählt wird, bezieht das Werkzeug alle QR-Codetypen (QR Model 1/2, Micro QR und QR Model 1/2) in den Dekodierversuch ein.
Geschlossen Maximale Ergebnisse

Legt die maximale Anzahl der zu lesenden Codes/Symbole fest (1 bis 20; Standard = 1).

Hinweis: Überschreitet der angegebene Wert für Maximale Ergebnisse die Anzahl der Codes/Symbole im Bildfeld, wird vom Werkzeug weiterhin nach der angegebenen Anzahl der Codes/Symbole gesucht. Variiert die Anzahl der Codes/Symbole im Bildfeld, kann die Ausführungszeit des Werkzeugs durch Anpassen des Werts im Parameter Zeitlimit verringert werden.
Geschlossen Trainiert

Zeigt an, ob das Werkzeug für einen bestimmten Code bzw. ein bestimmtes Symbol trainiert wurde. Zeigt "1" an, wenn das Werkzeug eingelernt wurde, und "0", wenn es nicht eingelernt wurde.

Geschlossen Train

Lernt ein Modell des gelesenen Codes/Symbols ein; eingelernte Informationen werden beibehalten, bis auf die Schaltfläche Training aufheben geklickt wird. Klicken Sie zum Neutrainieren eines Codes/Symbols auf die Schaltfläche Training aufheben, und klicken Sie anschließend auf Trainieren, wenn der neue Code bzw. das neue Symbol vorliegt. Das Trainieren wird zum Steigern der Werkzeuggeschwindigkeit und -leistung verwendet. Das Werkzeug lernt dabei, welche Art von Code/Symbol decodiert werden soll. Konfigurieren Sie bei Verwendung der Identifizierungswerkzeuge "1D-Codes lesen (1-20)" oder "2D-Codes lesen (1-20)" und des Trainings den Bereich um einen einzelnen Code bzw. ein einzelnes Symbol, bevor Sie auf die Schaltfläche Trainieren klicken. Sie können nach dem Einlernen des Codes/Symbols den Bereich anpassen, um mehrere Codes/Symbole im Bildfeld zu suchen. Das Training funktioniert nur mit einem einzelnen Code/Symbol im Bereich. Wenn Sie auf die Schaltfläche Trainieren klicken und mehrere Codes/Symbole im Bereich vorhanden sind, können Sie nicht vorgeben, welcher Code bzw. welches Symbol eingelernt werden soll.Stellen Sie vor dem Einlernen sicher, dass im Parameter Symbologiegruppe die richtige Symbologiegruppe (Datenmatrix oder QR) ausgewählt wird.

Geschlossen Untrainieren

Hebt das Training eines eingelernten Modellcodes/-symbols auf. Klicken Sie zum Neutrainieren eines Symbols auf die Schaltfläche Training aufheben, und klicken Sie anschließend auf Trainieren, wenn der neue Code vorliegt.

Geschlossen Perspektive

Legt die Dekodiereinstellungen (Keine Perspektive, Perspektive oder Perspektive trainieren; Standard = Keine Perspektive) für die Datenmatrix-Symbologien fest. Für den Parameter Symbologiegruppe muss Datenmatrix festgelegt werden, um diesen Parameter zu aktivieren.

  • Keine Perspektive = Dekodiert Datenmatrix- und QR-Code-Symbole, die keine perspektivische Verzerrung aufweisen.
  • Perspektive = Dekodiert Datenmatrix und QR-Code-Symbole mit perspektivischer Verzerrung. Die perspektivische Verzerrung wird während des Trainings des Modells und der Laufzeit unabhängig eingeschätzt.
  • Perspektive trainieren = Dekodiert Datenmatrix- und QR-Code-Symbole mit einer bekannten perspektivischen Verzerrung. Wenn ein eingelerntes Modell eines Symbols verwendet wird, wird die Perspektive zusammen mit anderen Eigenschaften eingelernt. Während der Laufzeit wird nach dem Symbol gesucht, dessen perspektivische Verzerrung im Eingangsbild mit den eingelernten Eigenschaften kompensiert wird. Diese Option benötigt, dass das Laufzeitsymbol auf der gleichen Ebene ist als des Symbols während der Trainingszeit. Diese Option ermöglicht sogar die Dekodierung von schwer beschädigten Symbole mit bekannter perspektivischer Verzerrung.
Tipp: Wir empfehlen, den Sensor so zu montieren, dass der Inzidenzwinkel (der Winkel zwischen der optischen Achse des Sensors und dem Normalvektor der Fläche auf dem das Symbol präsentiert wird) nicht größer als 40 Grad ist und die Auflösung des Symbols mindesten 5 Pixel pro Zelle ist.
Geschlossen Mode

Legt den Betriebsmodus (Lesen oder Übereinstimmende Zeichenfolge; Standard = Lesen) des Werkzeugs fest.

  • Lesen = Wird verwendet, wenn die Informationen im Code/Symbol unbekannt sind. Das Werkzeug decodiert automatisch die Informationen im Code/Symbol und zeigt die decodierten Informationen unter Zeichenfolge an.
  • Übereinstimmende Zeichenfolge = Wird verwendet, um zu überprüfen, ob ein bekannter Code bzw. ein bekanntes Symbol vorhanden und lesbar ist. Das Werkzeug decodiert die Informationen in Codes/Symbolen und vergleicht die decodierten Informationen mit den Informationen, die Sie in Übereinstimmende Zeichenfolge eingegeben haben.
Geschlossen Suchzeichenkette

Legt die erwartete Zeichenfolge fest (ist nur aktiviert, wenn der Parameter Modus auf Übereinstimmende Zeichenfolge eingestellt ist). Geben Sie die Informationen ein, die das Werkzeug erwartungsgemäß decodieren wird.

Hinweis: Die Übereinstimmungszeichenfolge kann über ein anderes Gerät eingegeben werden. Wenn Sie den Job ausführen, kann das Identifizierungswerkzeug die Textzeichenfolge vom Eingabegerät lesen und mit dem erkannten ID-Code/Symbol vergleichen. Das Werkzeug gibt einen Fehler aus, und im Feld Übereinstimmende Zeichenfolge wird TRIG angezeigt, bis die Übereinstimmende Zeichenfolge vom externen Gerät eingegeben wird.
Geschlossen Übereinstimmungsmodus

Legt fest, ob zum Bestehen alle decodierten Codes/Symbole im Bereich mit der im Parameter Übereinstimmende Zeichenfolge festgelegten Zeichenfolge übereinstimmen sollten. Der Parameter Übereinstimmende Zeichenfolge muss zum Aktivieren dieser Option konfiguriert werden.

  • Alle Übereinstimmungen = Alle decodierten Codes/Symbole müssen mit der im Parameter Übereinstimmende Zeichenfolge festgelegten Zeichenfolge übereinstimmen.
  • Beliebige Übereinstimmungen = Mindestens ein Code bzw. ein Symbol der decodierten Codes/Symbole muss mit der im Parameter Übereinstimmende Zeichenfolge festgelegten Zeichenfolge übereinstimmen.
Geschlossen Sortiermodus

Legt ggf. die Reihenfolge fest, in der Ergebnisse zurückgegeben werden (Keine, Abwärts, Links nach rechts, Alphabetisch oder Zeichenfolgenlänge; Standard = Keine).

  • Keine = Sortiert zuerst nach decodierten Ergebnissen. Nicht decodierte Ergebnisse werden nach den decodierten Ergebnissen angezeigt.
  • Abwärts = Sortiert in aufsteigender Reihenfolge nach X-Fixture-Koordinatenwert.
  • Links nach rechts = Sortiert in aufsteigender Reihenfolge nach Y-Fixture-Koordinatenwert.
  • Alphabetisch = Alphabetische Reihenfolge der Ergebnisse
  • Zeichenfolgenlänge = Sortiert die Ergebnisse nach Zeichenfolgenlänge (kurz zu lang).
  • Zeile = Sortiert die Ergebnisse durch Gruppieren der Symbole in Zeilen und anschließendes Sortieren von links nach rechts innerhalb der einzelnen Zeilen.
  • Spalte = Sortiert die Ergebnisse durch Gruppieren der Symbole in Spalten und anschließendes Sortieren von oben nach unten innerhalb der einzelnen Spalten.
Geschlossen Bewertung

Legt fest, ob die Druckqualitätstests ausgeführt werden sollen (standardmäßig ist diese Einstellung deaktiviert).

Geschlossen Binärergebnisse zulassen

Legt fest, ob die Funktion als hexadezimale ASCII-Datenmatrix-Symbole kodierte Symbole als Base-256 Binäre Daten dekodieren soll (standardmäßig ist diese Einstellung deaktiviert).

Geschlossen Timeout

Definiert den Zeitraum in Millisekunden (0 bis 30000; Standard = 5000), in dem das Werkzeug nach gültigen Codes/Symbolen sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird.

Geschlossen Nummer dekodiert

Zeigt die Anzahl der decodierten Codes/Symbole an.

Hinweis: Die Parameter Maximale Ergebnisse, Übereinstimmungsmodus, Sortiermodus und Nummer dekodiert stehen nur für das Identifizierungswerkzeug 2D-Codes lesen (1-20) zur Verfügung.


Identifizierungswerkzeug "2D-Code lesen" – Registerkarte "Ergebnisse"

Auf der Registerkarte Ergebnisse werden die folgenden Informationen zum decodierten Code/Symbol angezeigt:

Geschlossen Zeichenfolge

Gibt die in einem decodierten Code/Symbol enthaltene Zeichenfolge zurück.

Geschlossen Symbology

Gibt den Typ der decodierten Symbologie zurück.

Geschlossen Grade

Gibt den einem decodierten Code/Symbol zugewiesenen Grad zurück.


Identifizierungswerkzeug "2D-Codes lesen (1-20)" – Tabelle

Auf der Registerkarte Tabelle werden für alle decodierten Codes/Symbole die folgenden Informationen angezeigt:

Geschlossen Index

Bezieht sich auf die Reihenfolge des decodierten Codes/Symbols auf Grundlage des Parameters Sortiermodus; 1 bis 20 (die numerische Sortierung in EasyBuilder basiert auf 0 = 1).

Geschlossen Zeichenfolge

Gibt die in einem decodierten Code/Symbol enthaltene Zeichenfolge zurück.

Geschlossen Symbologie

Gibt den Typ der decodierten Symbologie zurück.

Geschlossen X

Gibt die X-Koordinate der Vorrichtungsausgabe des decodierten Codes/Symbols zurück.

Geschlossen Y

Gibt die Y-Koordinate der Vorrichtungsausgabe des decodierten Codes/Symbols zurück.

Geschlossen Winkel

Gibt den Winkelwert der Vorrichtungsausgabe des decodierten Codes/Symbols zurück.

Geschlossen Note

Gibt den einem decodierten Code/Symbol zugewiesenen Grad zurück.


Identifizierungswerkzeuge – ID-Codes lesen

Das Identifizierungswerkzeug "ID-Codes lesen" decodiert und überprüft automatisch Informationen in 1D-Barcodes und 2D-Matrixsymbolen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Identifizierungswerkzeugs "ID-Codes lesen"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereichstyp festlegen und im Bild konfigurieren:

  1. Platzieren Sie den Bereich über der Stelle, an der der Code oder das Symbol voraussichtlich angezeigt wird, und stellen Sie sicher, dass die Grenzen des Bereichs den gesamten Code oder das gesamte Symbol umschließen. Erstellen Sie zur Verbesserung der Leistungsstärke des Werkzeugs kleinere Bereiche. Je größer ein Bereich ist, desto länger dauert die Inspektion.

    Hinweis: Beim Lesen von 2D-Codes muss eine "Ruhezone" zwischen dem Code und dem Bereich eingehalten werden. Die "Ruhezone" erfordert einen Mindestabstand von 3 Pixeln zwischen der Kante des Codes und dem Bereich, der den Code definiert.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Nach dem Bestätigen des Bereichs muss der Betriebsmodus festgelegt werden: Lesen oder Übereinstimmende Zeichenfolge (der Modus ist standardmäßig auf Lesen gesetzt). Diese Einstellung wird auf der Registerkarte Einstellungen konfiguriert.
  4. Das Werkzeug speichert den Codetyp und sucht bei der Ausführung zur Laufzeit nach diesem spezifischen Codetyp. Wenn sich der Codetyp ändert, klicken Sie auf der Registerkarte Einstellungen auf Lernen, damit das Werkzeug den neuen Codetyp identifizieren kann. Suchen Sie anschließend nach diesem Codetyp.
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

Unterstützte ID-Codes


Unterstützte ID-Codes

Das Identifizierungswerkzeug "ID-Codes lesen" unterstützt die folgenden Code- und Symboltypen:

    Code 39 | Code 128
Code 2/5 überlappend | UPC
EAN | PharmaCode
POSTNET | PLANET
RSS-14 & Stacked | RSS-Limited
Codabar (NW-7) | Code 93
UPU 4-State | Australia Post 4-State
Japan Post 4-State | USPS OneCode 4-State
Datenmatrix | QR
RSS CC-A | RSS CC-B
PDF 417 |


Anpassen der Parameter des Identifizierungswerkzeug "ID-Codes lesen"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Identifizierungswerkzeugs "ID-Codes lesen" umfasst vier Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“


Identifizierungswerkzeug „ID-Codes lesen“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „IDCode_1“, sofern es sich um das erste Identifizierungswerkzeug „ID-Codes lesen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „IDCode_2“, „IDCode_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Identifizierungswerkzeug "ID-Codes lesen" – Registerkarte "Einstellungen"

Geschlossen Schaltfläche "Lernen"

Definiert einen neuen Codetyp oder ein neues Symbol. Die Schaltfläche Lernen wird verwendet, wenn Sie für das Werkzeug einen neuen Code oder ein neues Symbol einführen. Klicken Sie auf die Schaltfläche Lernen, nachdem Sie für das Werkzeug einen neuen Code oder ein neues Symbol eingeführt haben. Das Werkzeug versucht dann automatisch, den neuen Code oder das neue Symbol zu decodieren. Nach der erfolgreichen Decodierung liest oder verifiziert das Werkzeug anschließend nur Codes oder Symbole dieses Typs.

Geschlossen Code

Zeigt den Typ des decodierten Codes oder Symbols an.

Geschlossen Modus

Legt den Betriebsmodus des Werkzeugs fest: Lesen oder Übereinstimmende Zeichenfolge.

Lesen (der Standardmodus) wird verwendet, wenn die Informationen im Code oder Symbol unbekannt sind. Das Werkzeug decodiert automatisch die Informationen im Code oder Symbol und zeigt die decodierten Informationen unter Zeichenfolge an.

Übereinstimmende Zeichenfolge wird verwendet, um zu überprüfen, ob ein bekannter Barcode oder ein bekanntes Symbol vorhanden und lesbar ist. Das Werkzeug decodiert die Informationen in Barcodes oder Symbolen und vergleicht die decodierten Informationen mit den Informationen, die Sie in Übereinstimmende Zeichenfolge eingegeben haben.

Hinweis: Das Werkzeug verfügt über zwei Status: „Gut“ oder „Schlecht“. Ist der Modus des Werkzeugs auf Übereinstimmende Zeichenfolge festgelegt, wird in zwei unterschiedlichen Szenarios ein negatives Ergebnis ausgegeben: Wenn der Lesevorgang nicht erfolgreich ist, oder wenn der Lesevorgang erfolgreich ist aber die entschlüsselten Informationen nicht mit der im Parameter Übereinstimmende Zeichenfolge eingegebenen Zeichenfolge übereinstimmen.

Ist letzteres der Fall, gibt das Werkzeug die nicht übereinstimmenden Daten aus (Konflikt und Konflikt_Anzahl), die von EasyView und anderen Kommunikationsgeräten im Anwendungsschritt „Kommunikation“ verwendet werden können. Die Konfliktdaten können im Dialogfeld EasyView-Elemente auswählen, im Dialogfeld OPC-Tags auswählen oder im Dialogfeld Eingabe-/Ausgabedaten auswählen ausgewählt werden.

Die Konfliktdaten sind hilfreich, wenn festgestellt werden soll, ob das Werkzeug den Code nicht lesen kann, oder wenn der Code gelesen werden kann, aber die entschlüsselten Informationen nicht mit der definierten übereinstimmenden Zeichenfolge übereinstimmen. Wenn der Code beispielsweise nicht vom Werkzeug gelesen werden kann, tritt möglicherweise ein Problem beim Beschriftungsvorgang oder der Einrichtung des Vision-Systems auf. Kann der Code zwar gelesen werden aber stimmen die entschlüsselten Informationen nicht mit der definierten übereinstimmenden Zeichenfolge überein, könnte die falsche Beschriftung erstellt werden.
Geschlossen Übereinstimmende Zeichenfolge

Legt die erwartete Zeichenfolge fest (ist nur aktiviert, wenn der Parameter Modus auf Übereinstimmende Zeichenfolge eingestellt ist). Geben Sie die Informationen ein, die das Werkzeug erwartungsgemäß decodieren wird.

Hinweis: Die Übereinstimmungszeichenfolge kann über ein anderes Gerät eingegeben werden. Wenn Sie den Job ausführen, kann das Identifizierungswerkzeug die Textzeichenfolge vom Eingabegerät lesen und mit dem erkannten ID-Code vergleichen. Das Werkzeug ID-Codes lesen gibt einen Fehler aus, und im Feld Übereinstimmende Zeichenfolge wird TRIG angezeigt, bis die Übereinstimmende Zeichenfolge vom externen Gerät eingegeben wird.
Geschlossen Zeitüberschreitung

Definiert den Zeitraum in Millisekunden (0 bis 30 000), in dem das Werkzeug nach Codes sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird.

Geschlossen Zeichenfolge

Zeigt die decodierten Informationen an.


Identifizierungswerkzeuge – Farbe

Das Identifizierungswerkzeug "Farbe" wird verwendet, um anhand einer Bibliothek eingelernter Farben festzustellen, welche Farbe am besten der Farbe im Bild entspricht.

Dieses Werkzeug eignet sich z. B. für Anwendungen, in denen Sie basierend auf der Farbe des Teiles oder Objekts sicherstellen möchten, dass sich das richtige Produkt in der Fertigungsstraße befindet, oder in denen Sie das Produkt in der Fertigungsstraße erkennen und diese Information an andere Geräte im Produktionsbereich übermitteln möchten.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Identifizierungswerkzeugs "Farbe"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereichstyp festlegen und im Bild konfigurieren:

  1. Wählen Sie im Dropdown-Menü Modell den Bereichstypaus: Rechteck (Standard), Kreis, Annulus oder Polygon. Positionieren und Konfigurieren Sie den Bereich im Bild, in dem die Farben voraussichtlich erscheinen werden. Die Grenzen des Bereichs müssen die Farben und ihre möglichen Positionen einschließen. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich die Farben in jedem Bild nahezu an derselben Position befinden oder der Bereich groß genug ist für die erwartete Bewegung der Farben.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Nach der Konfiguration des Suchbereichs müssen die Farbbibliothek des Werkzeugs konfiguriert und die entsprechenden Farben aktiviert werden:
    • Beim ersten Hinzufügen des Farbidentifizierungswerkzeugs müssen zunächst die Farbbibliotheken und ihre Farben definiert werden.
    • Wurde zuvor ein weiteres Farbidentifizierungswerkzeug hinzugefügt und sollen eine vorhandene Farbbibliothek und ihre eingelernten Farben verwendet werden, wählen Sie auf der Registerkarte "Einstellungen" die gewünschte Farbbibliothek, und aktivieren Sie anschließend mithilfe der Kontrollkästchen auf der Registerkarte "Bibliothek" die gewünschte Farbe.
    • Wurde keine Farbbibliothek definiert, gibt das Werkzeug automatisch eine Fehlermeldung aus. Wurde eine Farbbibliothek definiert, wird sie automatisch vom Werkzeug verwendet und alle darin enthaltenen Farben werden aktiviert.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

Farbkomponenten eines Pixels


Farbkomponenten eines Pixels

Jede Farbe setzt sich aus drei separaten Farbkomponenten zusammen. Diese Komponenten können als Kombinationen von Rot, Grün und Blau (RGB) oder von Farbton, Sättigung und Intensität (HSI) dargestellt werden. Sowohl für RGB als auch für HSI wird jede Komponente eines Pixels in einen Wert zwischen 0 und 255 konvertiert.

Geschlossen RGB

RGB-Farben werden erstellt, indem Schattierungen von Rot (255, 0, 0), Grün (0, 255, 0) und Blau (0, 0, 255) in unterschiedlichen Verhältnissen kombiniert werden. Die Kombination führt zu einer spezifischen Farbe für jedes Pixel.

Geschlossen HSI

Bei HSI entspricht der Farbton einer Farbe der Position der Farbe innerhalb des sichtbaren Teiles des elektromagnetischen Strahlungsspektrums.

Die Sättigung einer Farbe ist der Grad, zu dem die Farbe mit Grau oder Weiß gemischt ist. Eine vollständig gesättigte Farbe ist rein. Wenn eine Farbe mit Grau oder Weiß gemischt wird, nimmt ihre Sättigung ab.

Die Intensität einer Farbe ist ein Maß für die Helligkeit der Farbe. Die Intensität einer Farbe ist als der Mittelwert der Rot-, Grün- und Blaukomponenten definiert, aus denen die Farbe besteht. Die resultierende Mischung aus Farbton, Sättigung und Intensität führt zu der korrekten Farbe für jedes Pixel.

Geschlossen Vergleich von RGB- und HSI-Werten

RGB-Werte = 255, 0, 0

HSI-Werte = 0, 255, 85

RGB-Werte = 0, 255, 0

HSI-Werte = 85, 255, 85

RGB-Werte = 0, 0, 255

HSI-Werte = 170, 255, 85


Anpassen der Parameter des Identifizierungswerkzeugs "Farbe"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Identifizierungswerkzeugs "Farbe" umfasst die folgenden Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Tabelle"
  • Registerkarte "Bibliothek"
  • Registerkarte "Zusammengesetzter Bereich"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Tabelle“

Registerkarte „Farbbibliothek“

Registerkarte „Zusammengesetzter Bereich“


Identifizierungswerkzeug „Farbe“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „ColorD_1“, sofern es sich um das erste Identifizierungswerkzeug „Farbe“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „ColorID_2“, „ColorID_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Identifizierungswerkzeug „Farbe“ – Registerkarte „Einstellungen“

Geschlossen Farbe einlernen

Öffnet das Dialogfeld „MatchColor – Einlernen“, das zur Definition der ausgewählten Farben der Farbbibliothek verwendet wird.

Geschlossen Farbbibliothek

Definiert die Farbbibliothek, auf die vom Tool verwiesen wird. Wählen Sie in der Dropdownliste die Farbbibliothek aus, die geändert werden soll, und klicken Sie auf die Schaltfläche Farbe einlernen, um das Dialogfeld „MatchColor – Einlernen" zu öffnen. EasyBuilder-Jobs können bis zu 5 Übereinstimmungsfarbbibliotheken enthalten. Jede Farbbibliothek kann bis zu 100 verschiedene Farben enthalten, die sich aus den RGB/HSI-Werten des Objekts zusammensetzen, das inspiziert wird.

Geschlossen Farbspektrum

Legt fest, welche Werte das Werkzeug in der vergleichenden Berechnung verwendet: RGB (Standard) oder HSI. Jedes Farbpixel setzt sich aus drei separaten Farbkomponenten zusammen. Diese Komponenten werden als Kombinationen von Rot, Grün und Blau (RGB) oder von Farbton, Sättigung und Intensität (HSI) dargestellt. Sowohl bei RGB- als auch bei HSI-Werten wird jede Komponente des Pixels in einen Wert zwischen 0 und 255 konvertiert.

Geschlossen Modus

Definiert den Betriebsmodus des Werkzeugs: Identifizieren (Standard) oder Übereinstimmung.

  • Identifizieren: Wird verwendet, wenn die Farben des Bilds nicht bekannt sind. Das Werkzeug bestimmt, welches Farbmodell die höchste Übereinstimmung mit den Farben des Bilds erzielt. Sind mehrere aktive Farbmodelle in der ausgewählten Farbbibliothek vorhanden, werden die Ergebnisse ihren Pixelanzahlen entsprechend sortiert und bewertet.
  • Übereinstimmung: Mit diesem Modus wird geprüft, ob das Bild das erwartete Farbmodell aufweist. Das Werkzeug verarbeitet das Bild und ermittelt, ob die Farben des Bilds mit den erwarteten Farben des angegebenen Farbmodells im Parameter Übereinstimmung der Farbe übereinstimmen.
Geschlossen Übereinstimmung der Farbe

Definiert die voraussichtlich zu ermittelnde Farbe. Das Feld wird nur aktiviert, wenn der Parameter Modus auf Übereinstimmung festgelegt wird. Geben Sie den Namen der Farbe ein, die das Feld voraussichtlich aufweist.

Geschlossen Akzeptanzschwellenwert

Gibt den Übereinstimmungsgrad an, der zwischen der Farbe und der gefundenen Farbe vorhanden sein muss (0 - 100; Standard = 90).

Geschlossen Ergebnis

Zeigt den Namen der gefundenen Farbe an.


Identifizierungswerkzeug „Farbe“ – Registerkarte „Tabelle“

Die Registerkarte Tabelle zeigt eine schreibgeschützte Liste der gefundenen Farben an (sortiert nach Bewertung und Güte der 10 besten Übereinstimmungen).

Geschlossen Rang

Zeigt eine numerische Bewertung der Farben an, die die höchste Übereinstimmung mit den Inspektionskriterien aufweisen (von 1 bis 10).

Geschlossen Farbname

Zeigt die Namen der gefundenen Farben an.

Geschlossen Güte

Zeigt die Güte der gefundenen Farbe an.


Identifizierungswerkzeug „Farbe“ – Registerkarte „Farbbibliothek“

Geschlossen Farbname

Zeigt eine schreibgeschützte Liste der Farben in der ausgewählten Übereinstimmungsfarbbibliothek an. Die Farben werden mittels der Kontrollkästchen neben dem Farbnamen aktiviert oder deaktiviert.

Hinweis: Standardmäßig sind alle bereits vorhandenen Farben einer Übereinstimmungsfarbbibliothek beim ersten Hinzufügen eines Werkzeugs automatisch aktiviert. Die Farben müssen für jedes Werkzeug, das auf die ausgewählte Farbbibliothek verweist, manuell deaktiviert werden. Wurden keine Farben für die ausgewählte Farbbibliothek eingelernt, enthält die Liste keine Einträge.
Geschlossen RGB

Zeigt eine schreibgeschützte Liste der mittleren RGB-Werte der Farben in der ausgewählten Übereinstimmungsfarbbibliothek an.

Geschlossen HSI

Zeigt eine schreibgeschützte Liste der mittleren HSI-Werte der Farben in der ausgewählten Übereinstimmungsfarbbibliothek an.


Identifizierungswerkzeug "Farbe" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


Identifizierungswerkzeuge – Postleitzahl lesen

Das Identifizierungswerkzeug "Postleitzahl lesen" decodiert und/oder überprüft ein einzelnes gestapeltes Postleitzahlsymbol in einem Bereich mittels ReadIDMax®-Algorithmus. Vom Werkzeug werden die decodierten Informationen sowie ein positives Ergebnis angezeigt, falls der Code bzw. das Symbol korrekt decodiert wurde und sich in den angegebenen Schwellenwerten befindet.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Identifizierungswerkzeugs "Postleitzahl lesen"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie den Bereich im Bild konfigurieren:

  1. Platzieren Sie den Bereich über dem Code bzw. Symbol, und stellen Sie sicher, dass die Grenzen des Bereichs den Code bzw. das Symbol vollständig umschließen. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Nach dem Bestätigen des Bereichs müssen Sie die Parameter festlegen in Registerkarte Einstellungen: Der Parameter Modus, der die Betriebsart des Werkzeugs festlegt: Lesen oder Übereinstimmende Zeichenfolge (der Modus ist standardmäßig auf Lesen gesetzt).
  4. Das Werkzeug zieht ein nicht bearbeitbares Umrandungsfeld um den decodierten Code bzw. das decodierte Symbol und fügt das Symbol [image] ein, um die aus dem decodierten Code/Symbol erstellte Vorrichtung anzugeben.
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Identifizierungswerkzeug "Postleitzahl lesen"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Identifizierungswerkzeugs "Postleitzahl lesen" umfasst die folgenden Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Postal"
  • Registerkarte "Ergebnisse"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Post“

Registerkarte „Ergebnisse“


Identifizierungswerkzeug „Postleitzahl lesen“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „IDCode_1“, sofern es sich um das erste Identifizierungswerkzeug „1D-Code lesen“, „1D-Codes lesen (1-20)“, „2D-Codes lesen“, „2D-Codes lesen (1-20)“ oder „Postleitzahl lesen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „IDCode_2“, „IDCode_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Identifizierungswerkzeug "Postleitzahl lesen" – Registerkarte "Einstellungen"

Geschlossen Trainiert

Zeigt an, ob das Werkzeug für einen bestimmten Code bzw. ein bestimmtes Symbol trainiert wurde. Zeigt "1" an, wenn das Werkzeug eingelernt wurde, und "0", wenn es nicht eingelernt wurde.

Geschlossen Trainieren

Lernt ein Modell des gelesenen Codes/Symbols ein; eingelernte Informationen werden beibehalten, bis auf die Schaltfläche Training aufheben geklickt wird. Klicken Sie zum Neutrainieren eines Codes/Symbols auf die Schaltfläche Training aufheben, und klicken Sie anschließend auf Trainieren, wenn der neue Code bzw. das neue Symbol vorliegt. Das Trainieren wird zum Steigern der Werkzeuggeschwindigkeit und -leistung verwendet. Das Werkzeug lernt dabei, welche Art von Code/Symbol decodiert werden soll. Konfigurieren Sie bei Verwendung der Identifizierungswerkzeuge "1D-Codes lesen (1-20)" oder "2D-Codes lesen (1-20)" und des Trainings den Bereich um einen einzelnen Code bzw. ein einzelnes Symbol, bevor Sie auf die Schaltfläche Trainieren klicken. Sie können nach dem Einlernen des Codes/Symbols den Bereich anpassen, um mehrere Codes/Symbole im Bildfeld zu suchen. Das Training funktioniert nur mit einem einzelnen Code/Symbol im Bereich. Wenn Sie auf die Schaltfläche Trainieren klicken und mehrere Codes/Symbole im Bereich vorhanden sind, können Sie nicht vorgeben, welcher Code bzw. welches Symbol eingelernt werden soll. Stellen Sie vor dem Trainieren sicher, dass auf der Registerkarte Postal die korrekten Codetypen ausgewählt sind.

Geschlossen Training aufheben

Hebt das Training eines eingelernten Modellcodes/-symbols auf. Klicken Sie zum Neutrainieren eines Symbols auf die Schaltfläche Training aufheben, und klicken Sie anschließend auf Trainieren, wenn der neue Code vorliegt.

Geschlossen Modus

Legt den Betriebsmodus (Lesen oder Übereinstimmende Zeichenfolge; Standard = Lesen) des Werkzeugs fest.

  • Lesen = Wird verwendet, wenn die Informationen im Code/Symbol unbekannt sind. Das Werkzeug decodiert automatisch die Informationen im Code/Symbol und zeigt die decodierten Informationen unter Zeichenfolge an.
  • Übereinstimmende Zeichenfolge = Wird verwendet, um zu überprüfen, ob ein bekannter Code bzw. ein bekanntes Symbol vorhanden und lesbar ist. Das Werkzeug decodiert die Informationen in Codes/Symbolen und vergleicht die decodierten Informationen mit den Informationen, die Sie in Übereinstimmende Zeichenfolge eingegeben haben.
Geschlossen Suchzeichenkette

Legt die erwartete Zeichenfolge fest (ist nur aktiviert, wenn der Parameter Modus auf Übereinstimmende Zeichenfolge eingestellt ist). Geben Sie die Informationen ein, die das Werkzeug erwartungsgemäß decodieren wird.

Hinweis: Die Übereinstimmungszeichenfolge kann über ein anderes Gerät eingegeben werden. Wenn Sie den Job ausführen, kann das Identifizierungswerkzeug die Textzeichenfolge vom Eingabegerät lesen und mit dem erkannten ID-Code/Symbol vergleichen. Das Werkzeug gibt einen Fehler aus, und im Feld Übereinstimmende Zeichenfolge wird TRIG angezeigt, bis die Übereinstimmende Zeichenfolge vom externen Gerät eingegeben wird.
Geschlossen Modus "Übereinstimmung"

Legt fest, ob zum Bestehen alle decodierten Codes/Symbole im Bereich mit der im Parameter Übereinstimmende Zeichenfolge festgelegten Zeichenfolge übereinstimmen sollten. Der Parameter Übereinstimmende Zeichenfolge muss zum Aktivieren dieser Option konfiguriert werden.

  • Alle Übereinstimmungen = Alle decodierten Codes/Symbole müssen mit der im Parameter Übereinstimmende Zeichenfolge festgelegten Zeichenfolge übereinstimmen.
  • Beliebige Übereinstimmungen = Mindestens ein Code bzw. ein Symbol der decodierten Codes/Symbole muss mit der im Parameter Übereinstimmende Zeichenfolge festgelegten Zeichenfolge übereinstimmen.
Geschlossen Bewertung

Legt fest, ob die Druckqualitätstests ausgeführt werden sollen (standardmäßig ist diese Einstellung deaktiviert).

Geschlossen Zeitlimit

Definiert den Zeitraum in Millisekunden (0 bis 30000; Standard = 0), in dem das Werkzeug nach einem gültigen Code/Symbol sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird.

Geschlossen Omnidirektional

Definiert, ob das Werkzeug versucht, den Barcode im Modus "Omnidirektional" zu finden (diese Einstellung ist standardmäßig deaktiviert). Diese Einstellung gibt die Richtung an, in der Scanzeilen (bei 1D-Symbolen wird der Barcode in maximal 10 in gleichmäßigem Abstand angeordnete Linien unterteilt; diese Linien werden als Scanzeilen bezeichnet und verlaufen senkrecht zur Richtung der Striche) innerhalb des Bereichs projiziert werden, um alle Elemente des Barcodes zu erkennen. Ein erfolgreiches Decodieren setzt voraus, dass über jedes Element des Barcodes mindestens eine Scanzeile projiziert wird. Bei deaktivierter Option werden die Scanzeilen in einer Richtung projiziert, um einen Barcode parallel zum Bereich zu erkennen. Bei aktivierter Option werden die Scanzeilen in verschiedenen Richtungen projiziert, um einen relativ zum Bereich gedrehten Barcode zu erkennen.


Identifizierungswerkzeug "Postleitzahl lesen" – Registerkarte "Postal"

Auf dieser Registerkarte wird festgelegt, welche Codes/Symbole decodiert werden sollen. Standardmäßig sind alle Code-/Symboltypen aktiviert. Es können mehrere Symbologien ausgewählt und gelesen werden.

Geschlossen POSTNET

Legt fest, ob das Werkzeug versucht, POSTNET zu lesen.

Geschlossen PLANET

Legt fest, ob das Werkzeug versucht, PLANET zu lesen.

Geschlossen Japan Post

Legt fest, ob das Werkzeug versucht, Japan Post zu lesen.

Geschlossen Australia Post

Legt fest, ob das Werkzeug versucht, Australia Post zu lesen.

Geschlossen UPU

Legt fest, ob das Werkzeug versucht, UPU zu lesen.

Geschlossen Intelligent Mail-Barcode

Legt fest, ob das Werkzeug versucht, Intelligent Mail-Barcode zu lesen.


Identifizierungswerkzeug "Postleitzahl lesen" – Registerkarte "Ergebnisse"

Auf der Registerkarte Ergebnisse werden die folgenden Informationen zum decodierten Code/Symbol angezeigt:

Geschlossen Zeichenfolge

Gibt die in einem decodierten Code/Symbol enthaltene Zeichenfolge zurück.

Geschlossen Symbologie

Gibt den Typ der decodierten Symbologie zurück.

Geschlossen Grad

Gibt den einem decodierten Code/Symbol zugewiesenen Grad zurück.


Identifizierungswerkzeuge – Text lesen (OCRMax)

Das Identifikationswerkzeug Text lesen (OCRMax) wird nach dem Trainieren und Erstellen von benutzerdefinierten Zeichensätzen zum Lesen und/oder Prüfen einer Textzeichenfolge in einem Bereich verwendet.

Das Identifikationswerkzeug Text lesen (OCRMax) führt die optische Zeichenerkennung (OCR) aus und segmentiert und klassifiziert. Die Segmentierung wird zuerst durchgeführt. Unter Verwendung von Schwellwerttechniken werden Teile des Bilds identifiziert, die Textzeilen zu enthalten scheinen. Nach dem Segmentieren des Texts in Zeichen werden die Zeichen trainiert und als Zeichensatz gespeichert. Die Klassifizierung findet während der Laufzeit statt. Dabei wird der bei der Segmentierung gefundene Text "gelesen". Die Bilder der segmentierten Zeichen werden dazu mit den trainierten Zeichen im Datensatz verglichen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Identifizierungswerkzeugs „Text lesen (OCRMax)“

Der Betrieb des Identifizierungswerkzeugs Text lesen (OCRMax) erfolgt in zwei Phasen: eine Trainingsphase und eine Laufzeitphase.

  • Die Trainingsphase umfasst das Laden mehrerer Bilder und Zeichen, die gelesen werden, das Extrahieren aus dem Bild, das Segmentieren und das Erstellen einer Zeichensatzdatenbank mit Zeichen.
  • Die Laufzeitphase umfasst das Onlineschalten des In-Sight-Vision-Systems, das Aufnehmen von Bildern und das Extrahieren und Klassifizieren von Zeichen basierend auf der Zeichensatzdatenbank mit trainierten Zeichen.
Hinweis: Laden Sie die Trainingsbilder vor dem Einrichten des Werkzeugs. Beim Trainieren einer Zeichensatzdatenbank empfiehlt Cognex, den Vorgang mit Bildern zu beginnen, die am besten darstellen, wie die Zeichen aussehen sollten. Verwenden Sie also die besten Bilder zuerst.
Geschlossen Trainieren des Identifizierungswerkzeugs „Text lesen (OCRMax)“
  1. Laden Sie das erste Trainingsbild.
  2. Fügen Sie dem Job das Identifizierungswerkzeug Text lesen (OCRMax) hinzu.
  3. Nachdem das Werkzeug hinzugefügt wurde, konfigurieren Sie den Bereich im Bild. Positionieren Sie den Bereich des Werkzeugs auf der zu lesenden Textzeile:
    • Die x-Achse des Bereichs sollte parallel zur Grundlinie des Texts verlaufen und die y-Achse parallel zu den vertikalen Strichen der Zeichen. Liegt keine Krümmung vor, verläuft die x-Achse senkrecht zur y-Achse.
    • Die positive Richtung der x-Achse entspricht der Leserichtung.
    • Der Bereich sollte nur eine zu lesende Textzeile und etwas Hintergrund enthalten. Der Hintergrund enthält u. U. Rauschen und ausgeprägte Farbverläufe/-schattierungen.
    • Bei Bildern mit Text, die deutlich gedruckt sind und wenig Rauschen enthalten, kann der Bereich erheblich größer sein als die Textzeile.
    • Weisen Bilder Rauschen auf, sollte der Bereich kaum größer sein als die Textzeile.

    • Als ungefähre Faustregel empfiehlt sich ein Bereich, der die Textzeile wenn möglich um mindestens eine halbe Zeichenbreite überragt (nur wenn durch diese Randgröße keine anderen Merkmale im Bereich eingeschlossen werden).

      Hinweis:
      • Die Grundlinie des Texts kann im Bild einen beliebigen Winkel (0 bis 360°) aufweisen, solange der Bereich ungefähr im gleichen Winkel ausgerichtet ist.
      • Der Bereich sollte außer der Textzeile keine ausgeprägten Merkmale im Bild enthalten. Der Bereich sollte beispielsweise keine Teile von umliegenden anderen Textzeilen oder Etikettkanten einschließen.
      • Ist der Bereich gebogen, wandelt das Werkzeug das Bild automatisch in einen begradigten Ausgabebereich um und fügt die Bezeichnung „Position des gebogenen Bereichs“ hinzu. Die Bezeichnung kann zur Anpassung der Darstellung innerhalb des Bildes an einer anderen Stelle positioniert werden.

  4. Das Werkzeug erstellt automatisch Zeichenbereiche um den „Text“, den es basierend auf den Standardeinstellungen auf der Registerkarte Segmentierung als Zeichen erkennt.

  5. Sie haben zwei Optionen, wenn die Funktion die Zeichenbereiche nicht ordnungsgemäß um den Text gezogen hat:
    • Verwenden Sie das Dialogfeld Auto-Tune, um mit dem Identifizierungswerkzeug Text lesen (OCRMax) automatisch die optimalen Segmentierungseinstellungen zu berechnen. Das Dialogfeld „Auto-Tune“ kombiniert die Segmentierungs- und Trainingsphase zu einem Schritt. Folgen Sie den Anweisungen im Abschnitt über das Dialogfeld „Auto-Tune“, um eine Zeichensatzdatenbank erfolgreich zu segmentieren und zu trainieren.
    • Passen Sie auf der Registerkarte Segmentierung die Parameter an, bis der Text erfolgreich in einzelnen Zeichenbereichen eingeschlossen ist. Führen Sie den Segmentierungsprozess durch, und segmentieren Sie vor dem Training alle Zeichen in der Bilddatenbank.
Hinweis:
  • Bei verrauschten Bildern und schwer lesbarem Text können Sie mithilfe der Parameter auf der Registerkarte Erweitert die schwierigen Bedingungen u. U. kompensieren.
  • Befinden sich zwischen Zeichen Leerstellen, öffnen Sie die Registerkarte Leerstellen, und passen Sie die Parameter an, um die Leerstellen zu kompensieren.
Geschlossen Manuelles Trainieren des Identifizierungswerkzeugs „Text lesen (OCRMax)“ nach der Segmentierung

Sobald der Text segmentiert wurde, können die Zeichen eingelernt und dem Zeichensatz hinzugefügt werden. Wählen Sie zuerst eine Zeichensatzdatenbank, indem Sie auf der Registerkarte Einstellungen aus dem Parameter Schriftartbibliothek eine Schriftart auswählen.

  • Öffnen Sie die Registerkarte Training, wenn Sie eine neue benutzerdefinierte Schriftart erstellen möchten, und geben Sie die einzulernende Textzeichenfolge exakt ein. Klicken Sie anschließend auf die Schaltfläche Alle trainieren. Die Zeichen werden hinzugefügt und in der ausgewählten benutzerdefinierten Schriftart gespeichert.

Zum Hinzufügen weiterer Zeichen zu einer benutzerdefinierten Schriftart können Sie ein weiteres Bild mit den einzulernenden Zeichen aufnehmen oder laden. Falls nötig, konfigurieren Sie den Bereich und die Parameter für die Segmentierung neu, um sicherzustellen, dass die Zeichen korrekt segmentiert sind. Anschließend klicken Sie auf der Registerkarte Training auf die Schaltfläche Neu trainieren oder Auswahl trainieren.

Hinweis: Eine benutzerdefinierte Schriftart kann auf der Registerkarte Training als OCRMax-Datendatei (*.ocm) exportiert oder importiert werden.
  • Bei Verwendung einer vordefinierten OCRA- oder OCRB-Schriftart positionieren Sie einfach den Bereich des Werkzeugs über dem zu lesenden Text, und das Werkzeug segmentiert daraufhin die Zeichen im Bereich automatisch gemäß den Einstellungen der Parameter Segmentierung und Erweitert.
Hinweis: Die vordefinierten OCRA- oder OCRB-Schriftarten sind nicht bearbeitbar.
Geschlossen Laufzeitbetrieb

Nachdem dem Werkzeug eine trainierte Zeichensatzdatenbank zugewiesen wurde, ist es bereit für den Laufzeitbetrieb.

  1. Stellen Sie den Laufzeit-Inspektionsmodus des Werkzeugs ein, um festzulegen, ob das Werkzeug Text innerhalb des Bereichs nur lesen soll oder ob es lesen und prüfen soll, ob die Zeichenfolge korrekt gelesen wurde.
  2. Während der Laufzeit ist das In-Sight-Vision-System online geschaltet und nimmt wie im Job definiert Bilder auf. Bei der Aufnahme eines Bildes wird die Textzeichenfolge im Bild entsprechend den Segmentierungsparametern automatisch segmentiert und die Zeichen werden mit den eingelernten Instanzen der Zeichen verglichen.


Anpassen der Parameter des Identifizierungswerkzeugs "Text lesen (OCRMax)"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Identifizierungswerkzeugs "Text lesen (OCRMax)" umfasst die folgenden Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Segmentierung"
  • Registerkarte "Erweitert"
  • Registerkarte "Leerstellen"
  • Registerkarte "Variable Länge"
  • Registerkarte "Training"
  • Registerkarte "Feld"
  • Registerkarte "Diagnose"
  • Registerkarte "Ergebnisse"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Segmentierung“

Registerkarte „Erweitert“

Registerkarte „Leerstellen“

Registerkarte „Variable Länge“

Registerkarte „Training“

Registerkarte „Feld“

Registerkarte Diagnose

Registerkarte „Ergebnisse“


Identifizierungswerkzeug „Text lesen (OCRMax)“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Text_1“, sofern es sich um das erste Identifizierungswerkzeug „Text lesen (OCRMax)“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Text_2“, „Text_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Identifizierungswerkzeug "Text lesen (OCRMax)" – Registerkarte "Einstellungen"

Geschlossen Schriftartbibliothek

Definiert einen Zeichensatzdatenbankverweis für das Werkzeug. Wählen Sie aus vier vordefinierten Schriftarten (OCRA oder OCRB, entweder Weiß-auf-Schwarz oder Schwarz-auf-Weiß), oder erstellen Sie eine benutzerdefinierte Zeichensatzdatenbank durch Trainieren von Zeichen (pro Job können bis zu acht benutzerdefinierte Zeichensatzdatenbanken erstellt werden).

Hinweis: Die vier OCRA- und OCRB-Schriftarten sind schreibgeschützt und können nicht neu trainiert, gelöscht oder umbenannt werden.
  • Beim Auswählen einer dieser vordefinierten Schriftarten positionieren Sie einfach den Bereich des Werkzeugs über dem zu lesenden Text, und das Werkzeug segmentiert automatisch die Zeichen im Bereich.
  • Folgen Sie beim Auswählen einer benutzerdefinierten Schriftart den Schritten unter Einrichten des Identifizierungswerkzeugs "Text lesen (OCRMax)", wenn Sie zuerst die benutzerdefinierte Zeichensatzdatenbank erstellen. Wird eine vorhandene benutzerdefinierte Schriftart geändert, sind alle anderen "Text lesen (OCRMax)"-Werkzeuge, die die gleiche benutzerdefinierte Schriftart verwenden, ebenfalls davon betroffen.
Geschlossen Inspektionsmodus

Legt den Betriebsmodus des Werkzeugs fest: Lesen (Standard) oder Lesen/Überprüfen.

  • Gelesen: Das Werkzeug versucht, basierend auf den eingelernten Zeicheninstanzen, die Zeichen in der Region zu lesen.
  • Lesen/Überprüfen: Das Werkzeug versucht zunächst, basierend auf den eingelernten Zeicheninstanzen die Zeichen in der Region zu lesen, und überprüft anschließend, ob die gelesenen Zeichen der im Parameter Übereinstimmende Zeichenfolge festgelegten Textzeichenfolge entsprechen.
Geschlossen Übereinstimmende Zeichenfolge

Gibt die Textzeichenfolge an, für die im Inspektionsmodus Lesen/Überprüfen eine korrekte Übereinstimmung erforderlich ist.

Geschlossen Akzeptanzschwellenwert

Definiert die minimal zulässige Übereinstimmungsgüte (0 bis 100; Standard = 80) für jedes Zeichen. Ein Zeichen, dessen Übereinstimmungsgüte den Akzeptanzschwellenwert unterschreitet, wird nicht zugelassen.

Geschlossen Verwechslungsschwellenwert

Definiert den Mindestdifferenzwert, der zwischen den Übereinstimmungsgüten der Zeichen mit der höchsten und der zweithöchsten Güte erforderlich ist (0 bis 40; Standard = 0).

Geschlossen Teilproben verwenden

Gibt an, ob das Verwenden von Teilproben aktiviert ist; dabei wird die Zeichenauflösung reduziert, um die Lesegeschwindigkeit der Funktion zu erhöhen.

Geschlossen Timeout

Definiert den Zeitraum in Millisekunden (0 bis 30000; Standard = 5000), in dem das Werkzeug nach Zeichen sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird. Ist als Wert 0 festgelegt, wird diese Einstellung deaktiviert, und es gilt kein Zeitlimit.

Geschlossen Zeichen anzeigen

Legt fest, ob Zeichen und dazugehörige Zeichenbereiche auch in den anderen Anwendungsschritten oder nur in den Schritten Teil suchen und Teil inspizieren angezeigt werden.

Geschlossen Position der Zeichenbenennung

Definiert, wo die Zeichenbenennung im Verhältnis zum Zeichenbereich positioniert wird: Über dem Zeichen (Standard), Rechts vom Zeichen, Unter dem Zeichen oder Links vom Zeichen.


Identifizierungswerkzeug "Text lesen (OCRMax)" – Registerkarte "Segmentierung"

Auf der Registerkarte Segmentierung werden die Einstellungen zur Zeichensegmentierung im Bereich angepasst und geändert. Mit den Standardwerten und -einstellungen kann Text meist gelesen werden. Bei schwierigeren Fällen ist jedoch u. U. eine Anpassung einiger Parameterwerte erforderlich. In solchen Fällen kann das Problem üblicherweise behandelt werden, indem eine Mindestzeichenbreite, eine Höchstbreite und/oder eine Mindestneigung (d. h. der Abstand von Zeichen zu Zeichen, z. B. von der linken Kante eines Zeichens bis zur linken Kante des darauffolgenden Zeichens) festgelegt werden. Für schwierige Fälle und zur schnelleren Erstellung der Zeichensatzdatenbank öffnen Sie mit der Schaltfläche Auto-Tune das Dialogfeld "Auto-Tune", um mit dem Werkzeug automatisch die optimalen Segmentierungseinstellungen zu berechnen.

Geschlossen Richtlinien für die Segmentierung
  • Enthalten Bilder Hintergründe mit starken Strukturen oder so viel Rauschen, dass die Zeichen mit dem Hintergrund verschwimmen, ist die Segmentierung der Bilder schwierig.
  • Der Bereich sollte nur die zu lesenden Zeichen enthalten, keine stark ausgeprägten, nicht dazugehörigen Merkmale wie etwa andere Zeichen oder Etikettkanten.
  • Berühren sich zwei Zeichen, ist höchstwahrscheinlich eine Anpassung von Parametern erforderlich. Berühren sich Zeichen mit fester Breite, kann das Problem durch das Festlegen der Zeichenbreite behoben werden. Berührungen zwischen Zeichen proportionaler Schriftarten sind jedoch problematisch, da einige Fälle von der Funktion korrekt verarbeitet werden können, andere jedoch nicht.
  • In Fällen mit kurzen Textzeilen (z. B. höchstens drei Zeichen) oder verhältnismäßig kurzen Zeilen mit viel Zeilenflattern sollte der erwartete Winkelbereich festgelegt werden, damit der Unsicherheitsfaktor bei der Bestimmung der Ausrichtung einer kurzen Textzeile von der Funktion kompensiert werden kann.
  • Alle Zeichen in einer Zeichenzeile müssen dieselbe Ausrichtung und Neigung haben.
  • Für eindeutig getrennten Punktmatrixdruck (z. B. Punkte berühren sich nicht) ist u. U. das Anpassen von Parametern wie Zeichenfragment Mindestgröße erforderlich, damit die Zeichen ordnungsgemäß segmentiert werden können.
  • Die Zeichenstrichbreite muss mindestens zwei Pixel betragen.
  • Die Mindestzeichengröße für große Zeichen (normalerweise alphanumerisch) beträgt 8 x 8 Pixel. Die Mindestzeichengröße für kleine Zeichen (wie z. B. Punkte) beträgt 2 x 2 Pixel.
Geschlossen Auto-Tune

Öffnet das Dialogfeld "Auto-Tune", das in Verbindung mit dem Identifizierungswerkzeug "Text lesen (OCRMax)" verwendet wird, um mittels Auto-Tune-Datensätzen zum Erstellen eines Auto-Tune-Modells die Segmentierungsparameter des Werkzeugs zu konfigurieren und eine Zeichensatzdatenbank zu trainieren. Ein Auto-Tune-Datensatz umfasst ein Bild, die Trainingszeichenfolge und die vom Benutzer bestätigte Position der Zeichen im Bild. Das Auto-Tune-Modell besteht aus mindestens einem Auto-Tune-Datensatz und den Einstellungen, die alle Bilder in den Auto-Tune-Datensätzen am besten segmentieren.

Hinweis:
  • Cognex empfiehlt bei Verwendung des Dialogfelds "Auto-Tune", dass die Segmentierung auf einem In-Sight-Emulator und nicht auf einem In-Sight-Vision-System erfolgt. Der Auto-Tune-Algorithmus des Werkzeugs "Text lesen (OCRMax)" erfordert eine hohe Computerleistung, weshalb die Performance auf dem Emulator im Vergleich zu einem Vision-System besser sein wird.
  • Beim Trainieren einer Zeichensatzdatenbank und Verwenden des Dialogfelds "Auto-Tune" zum Segmentieren der Zeichen empfiehlt Cognex, den Vorgang mit Bildern zu beginnen, die am besten darstellen, wie die Zeichen aussehen sollten. Verwenden Sie also die besten Bilder zuerst. Auf diese Weise wird mit dem Auto-Tune-Algorithmus des Werkzeugs "Text lesen (OCRMax)" eine bessere Optimierung erzielt.
Geschlossen Zeichenpolarität

Gibt die Polarität der Zeichen im Eingabebild an: Schwarz auf Weiß, Weiß auf Schwarz oder Automatisch (Standard).

Hinweis: Legen Sie die Polarität des Texts fest, um die Leistung des Werkzeugs zu verbessern.
  • Schwarz auf Weiß: Die Polarität des Texts ist schwarzer Text auf weißem Hintergrund.
  • Weiß auf Schwarz: Die Polarität des Texts ist weißer Text auf schwarzem Hintergrund.
  • Automatisch: Das Werkzeug erkennt die Polarität von Text und Hintergrund automatisch.
Geschlossen Zeichenbreitentyp

Gibt an, welche Variationen der Zeichenbreite im Zeichensatz zu erwarten sind: Automatisch (Standard), Fest oder Variabel.

Hinweis: Die Zeichenbreite beschreibt die Breite des Zeichenrechtecks, nicht den Bereich.
  • Automatisch: Die Zeichenbreite ist nicht bekannt; die Breite des Zeichensatzes ist entweder fest oder proportional.
  • Fest: Alle Zeichenrechtecke im Zeichensatz haben dieselbe Breite.
  • Variabel: Die Zeichen im Zeichensatz haben u. U. Zeichenrechtecke mit unterschiedlicher Breite.
Geschlossen Mindestzeichenbreite

Gibt die Mindestbreite eines Zeichenrechtecks in Pixeln (1 bis 1000; Standard = 3) an, die für das Erkennen eines Zeichens erforderlich ist.

Geschlossen Mindestzeichenhöhe

Gibt die Mindesthöhe eines Zeichenrechtecks in Pixeln (1 bis 1000; Standard = 3) an, die für das Erkennen eines Zeichens erforderlich ist.

Geschlossen Maximale Zeichenbreite verwenden

Gibt an, ob das Werkzeug die maximal zulässige Breite eines Zeichenrechtecks berücksichtigt (der Parameter ist standardmäßig deaktiviert).

Hinweis: Ist dieser Parameter aktiviert, wird ein Zeichen, dessen Breite den festgelegten Wert überschreitet, in nicht zu breite Segmente geteilt.
Geschlossen Maximale Zeichenbreite

Gibt die maximale Breite eines Zeichenrechtecks in Pixeln (1 bis 5000; Standard = 100) an, die für das Erkennen eines Zeichens eingehalten werden muss.

Geschlossen Maximale Zeichenhöhe verwenden

Gibt an, ob das Werkzeug die maximal zulässige Höhe eines Zeichenrechtecks berücksichtigt (der Parameter ist standardmäßig deaktiviert).

Hinweis: Dieser Wert hat zwei Funktionen: Zum einen wird dieser Wert beim Erkennen der gesamten Zeile verwendet, z. B. zum Verwerfen von vertikal angrenzendem Rauschen, und/oder anderer Zeilen vertikal angrenzender Zeichen. Zum anderen wird ein einzelnes Zeichen, dessen Höhe diesen Wert überschreitet, darauf zugeschnitten.
Geschlossen Maximale Zeichenhöhe

Gibt die maximale Höhe eines Zeichenrechtecks in Pixeln (1 bis 5000; Standard = 100) an, die für das Erkennen eines Zeichens eingehalten werden muss.

Geschlossen Mindestseitenverhältnis des Zeichens verwenden

Gibt an, ob die Funktion das zulässige Mindestseitenverhältnis eines Zeichens berücksichtigt, wenn das Seitenverhältnis als die Höhe der gesamten Zeichenzeile geteilt durch die Breite des Zeichenrechtecks definiert ist (dieser Parameter ist standardmäßig aktiviert).

Hinweis: Ist dieser Parameter aktiviert, wird ein Zeichen, dessen Seitenverhältnis diesen Wert unterschreitet (d. h. dessen Breite zu groß ist), in nicht zu breite Segmente geteilt.
Geschlossen Mindestseitenverhältnis des Zeichens

Gibt das zulässige Mindestseitenverhältnis (0 bis 500; Standard = 80) eines Zeichens an.

Geschlossen Winkelbereich

Gibt den Winkelsuchbereich in Grad an (0 bis 45; Standard = 0).

Hinweis: Alle Werte über 0 verlängern die Ausführungszeit des Segmentierungsprozesses.
Geschlossen Krümmungsbereich

Gibt den Krümmungssuchbereich in Grad an (0 bis 45; Standard = 0).

Hinweis: Alle Werte über 0 verlängern die Ausführungszeit des Segmentierungsprozesses.
Geschlossen Diagnose anzeigen

Gibt an, ob auf dem Bild grafische Diagnosedaten angezeigt werden. Falls aktiviert, werden um beibehaltene Zeichen (grün), abgelehnte Zeichen (rot), beibehaltene Fragmente (zyan), abgelehnte Fragmente (gelb), die Hauptlinie des Texts (blau) und die erweiterte Hauptlinie des Texts (magenta) Bereiche gezeichnet.


Identifizierungswerkzeug "Text lesen (OCRMax)" – Registerkarte "Erweitert"

Geschlossen Modus Zeichenfragmentverbindung

Legt fest, wie das Tool beim Abbilden von Zeichen während der Segmentierung Zeichenfragmente verbindet: Überlappung erforderlich (Standard), Mindestzwischenraum zwischen Zeichen festlegen oder Mindestzwischenraum zwischen Zeichen/Maximalzwischenraum in Zeichen festlegen.

  • Überlappung erforderlich: Zeichenfragmente müssen eine horizontale Überlappung von mindestens einem Pixel aufweisen, um zusammengeführt zu werden.
  • Mindestzwischenraum zwischen Zeichen festlegen: Zeichenfragmente mit horizontalem Abstand können zur Abbildung von Zeichen zusammengeführt werden, wenn es sich um zwei Fragmente handelt, deren Abstand geringer ist, als im Parameter "Mindestzwischenraum zwischen Zeichen" festgelegt.
  • Mindestzwischenraum zwischen Zeichen/Maximalzwischenraum in Zeichen festlegen: Zeichenfragmente mit horizontalem Abstand können zur Abbildung von Zeichen zusammengeführt werden, wenn es sich um zwei Fragmente handelt, deren Zusammenführung auf den Parameterwerten Mindestzwischenraum zwischen Zeichen und Maximalzwischenraum in Zeichen basiert.
Geschlossen Zeichenfragment-Mindestüberlappung

Gibt den Mindestbruchteil (0 bis 100; Standard = 0) an, den zwei Zeichenfragmente in Richtung x überlappen müssen, um als Teil desselben Zeichens zu gelten.

Geschlossen Maximalzwischenraum in Zeichen

Gibt auch bei beschädigten Zeichen die maximale Zwischenraumgröße, die in einem einzelnen Zeichen auftreten kann, in Pixeln an (0 bis 1000; Standard = 5).

Geschlossen Mindestzwischenraum zwischen Zeichen

Gibt die Mindestgröße des Zwischenraums zwischen zwei Zeichen in Pixeln an (0 bis 1000; Standard = 0). Der Zwischenraum wird von der rechten Kante des Rechtecks eines Zeichens bis zur linken Kante des Rechtecks des nächsten Zeichens gemessen. Unterschreitet der Abstand zwischen zwei Fragmenten diesen Wert, wird angenommen, dass es sich um Teile desselben Zeichens handelt, es sei denn das verbundene Zeichen ist zu breit (wie in den Parametern Maximale Zeichenbreite und/oder Mindestseitenverhältnis des Zeichens festgelegt).

Geschlossen Zeichenfragment Mindestgröße

Gibt die Mindestanzahl der Vordergrundpixel (d. h. Textpixel) an, (0 bis 1000, Standard = 15), die ein Fragment aufweisen muss, um als zu einem Zeichen gehörig zu gelten. Ein Zeichenfragment ist ein Blob im binarisierten Bild.

Geschlossen Mindestzeichengröße

Gibt die Mindestanzahl der Vordergrundpixel (d. h. Textpixel) an, (0 bis 5000, Standard = 30), die ein Zeichen aufweisen muss, um gemeldet zu werden.

Geschlossen Normalisierungsmodus

Gibt den Modus zum Normalisieren des Bildes an: Keine, Global, Lokal oder Lokal erweitert (Standard).

Hinweis: Für das Einlernen und die Laufzeit wird dieselbe Einstellung empfohlen, da das Ändern der Einstellung nach dem Einlernen u. U. Klassifizierungsprobleme verursacht.
  • Keine: Keine Normalisierung wird ausgeführt.
  • Global: Eine globale Normalisierung wird ausgeführt. Dabei werden Informationen im ganzen Bereich und keine lokalen Abweichungen verwendet.
  • Lokal: Eine lokale Normalisierung wird ausgeführt. Dabei werden zur Normalisierung des Bilds Informationen zu jedem lokalen Zeichenrechteck im Bereich verwendet.
  • Lokal erweitert: Eine lokale Normalisierung wird ausgeführt. Dabei werden zur Normalisierung des Bilds Informationen zu jedem lokalen Zeichenrechteck im Bereich verwendet, einschließlich Anpassungen nicht nur für den Hintergrund, sondern auch für den Vordergrundkontrast.
Geschlossen Strichbreitenfilter verwenden

Gibt an, ob aus einem normalisierten Bild alles entfernt wird, was nicht die gleiche Strichbreite wie der Rest des Bildes hat (diese Einstellung ist standardmäßig aktiviert). Diese Einstellung ist z. B. hilfreich, wenn Zeichen durch dünne Rauschlinien miteinander verbunden zu sein scheinen. Bei Verwendung dieser Einstellung werden jedoch u. U. auch echte Zeichen entfernt, deren Strichbreiten inkonsistent sind.

Hinweis: Für das Einlernen und die Laufzeit wird dieselbe Einstellung empfohlen, da das Ändern der Einstellung nach dem Einlernen u. U. Klassifizierungsprobleme verursacht.
Geschlossen Randfragmente ignorieren

Legt fest, ob die Funktion Fragmente, die einen Rand des Bereichs berühren, vollständig ignoriert (diese Option ist standardmäßig deaktiviert). Das Ignorieren solcher Fragmente ist hilfreich, wenn der Bereich Nicht-Text-Merkmale wie etwa Etikettkanten einschließt.

Hinweis: Erstreckt sich ein Fragment vom Rand des Zeichenrechtecks bis zur Hauptlinie des Texts, wird das Fragment als Zeichen erkannt. Ist dieser Parameter aktiviert, darf das auszuschließende Fragment nicht bis zur Hauptlinie des Texts reichen.
Geschlossen Grenzwert Binarisierung

Gibt einen Prozentmodifizierer (0 bis 100; Standard = 50) im Bereich an, der zum Berechnen des Binarisierungsgrenzwerts im normalisierten Bild verwendet wird, bei dem das Bild zwischen Vordergrund und Hintergrund binarisiert wird.

Geschlossen Kontrastgrenzwert Zeichenfragment

Gibt den Mindestkontrastwert an [in Graustufenwerten vom normalisierten Bild (0 bis 255; Standard = 30)], den ein Fragment relativ zum Binarisierungsgrenzwert haben muss, um als zu einem Zeichen gehörig zu gelten.

Geschlossen Max. Fragmentabstand zur Hauptlinie

Gibt den Abstand in Pixeln an (0 bis 1000; Standard = 0), den ein Fragment zur "Hauptlinie" haben kann, die horizontal durch den Text verläuft.

Geschlossen Segmentierungsanalysemodus

Gibt den Typ des auszuführenden Zeichenananalysemodus an, um die optimale Zeichensegmentierung zu bestimmen: Minimal oder Standard (Standard).

  • Minimal: Führt eine einfache Segmentierung entsprechend den Segmentierungsparametern durch.
  • Standard: Führt eine Analyse der gesamten Zeile einschließlich des Zeichenabstands durch, um die optimale Segmentierung zu bestimmen.
Geschlossen Mindestneigung

Gibt die minimale Neigung zwischen zwei Zeichen in Pixeln (0 bis 1000) an, wenn die Neigung basierend auf dem Parameter Zeichenneigung – Position berechnet wird. Unterschreitet die Neigung zwischen zwei Fragmenten diesen Wert, wird angenommen, dass es sich um Teile desselben Zeichens handelt, es sei denn, das verbundene Zeichen ist zu breit (wie in den Parametern Maximale Zeichenbreite und/oder Mindestseitenverhältnis des Zeichens festgelegt). Die Neigung ist der Abstand zwischen (ungefähr) korrespondierenden oder benachbarten Zeichen und nicht der Abstand zwischen dem Ende eines Zeichens und dem Anfang des nächsten Zeichens (dieser Abstand wird als Zeichenzwischenraum bezeichnet).

Geschlossen Zeichenneigung – Position

Gibt an, wie die Neigung zwischen Zeichen gemessen wird: Automatisch (Standard), "Links zu links", "Mitte zu Mitte" oder "Rechts zu rechts".

Hinweis:
  • Ist der Parameter Segmentierungsanalysemodus auf Minimal gesetzt, wird dieser Parameter deaktiviert.
  • Die Begriffe "links" und "rechts" gelten relativ zu der durch den Bereich definierten Koordinatenachse, d. h. "rechts" entspricht der positiven x-Richtung.
  • Automatisch: Gibt an, dass eine unbekannte Metrik verwendet wird. Die richtige Neigung kann eine beliebige der anderen Neigungspositionen sein, oder es ist keine konstante Neigungsposition vorhanden (wie es bei der Neigung proportionaler Schriftarten der Fall sein kann).
  • Links zu links: Legt die Neigung als den Abstand zwischen der linken Seite eines Zeichenrechtecks zur linken Seite des benachbarten Zeichenrechtecks fest.
  • Mitte zu Mitte: Legt die Neigung als den Abstand zwischen der Mitte eines Zeichenrechtecks zur Mitte des benachbarten Zeichenrechtecks fest.
  • Rechts zu rechts: Legt die Neigung als die Distanz von der rechten Seite eines Zeichenrechtecks bis zur rechten Seite des benachbarten Zeichenrechtecks fest.
Geschlossen Typ Zeichenneigung

Legt die Metrik fest, die zum Definieren des Zeichenabstands verwendet wird: Automatisch (Standard), Fest, Proportional oder Variabel.

Hinweis: Ist der Parameter Segmentierungsanalysemodus auf Minimal gesetzt, wird dieser Parameter deaktiviert.
  • Automatisch: Gibt an, dass der Neigungstyp unbekannt ist, wahrscheinlich aber entweder fest oder proportional und nicht variabel ist.
  • Fest: Gibt an, dass die Neigung fest ist, d. h., die Neigung zwischen allen Zeichenpaaren ist konstant, unabhängig von der Breite der Zeichenrechtecke oder der Zeichen. Die Neigung wird basierend auf dem Parameter Zeichenneigung – Position gemessen.

  • Proportional: Gibt an, dass die Neigung proportional ist, d. h., die Neigung zwischen einem Zeichenpaar hängt von den jeweiligen Zeichen ab.

    Hinweis:
    • Die Neigungsmessungen in einer Zeichenfolge sind nicht konstant. Der Zeichenzwischenraum – der Abstand zwischen der rechten Seite eines Zeichenrechtecks und der linken Seite des benachbarten Zeichenrechtecks – ist jedoch annähernd konstant.
    • Die Begriffe "links" und "rechts" gelten relativ zu der durch den Bereich definierten Koordinatenachse, d. h. "rechts" entspricht der positiven x-Richtung.
  • Variabel: Gibt an, dass in einer Zeichenfolge keine Abstandsmetrik zwischen zwei Zeichen konstant ist. Die Zeichenplatzierung ist z. B. unregelmäßig, und die Neigung ist weder fest noch proportional.
Hinweis: Variable Neigung unterscheidet sich von Automatisch dadurch, dass bei Automatisch von einer entweder festen oder proportionalen Neigung ausgegangen wird, was aber nicht bekannt ist.
Geschlossen Zusätzliche Zeichenprüfung überspringen

Legt fest, ob das Werkzeug während der Klassifizierung eine zusätzliche Zeichenprüfung ausführt (standardmäßig ist dieser Parameter deaktiviert). Ist dieser Parameter deaktiviert, führt das Werkzeug während der Klassifizierung eine zusätzliche Zeichenprüfung aus, um die Wahrscheinlichkeit von Lesefehlern (d. h. das fälschliche Akzeptieren eines Zeichens) zu reduzieren.

Geschlossen Ausgabe Bildgrafik

Gibt den Typ des anzuzeigenden Ausgabebilds an: Eingabebild (Standard), Normalisiertes Bild oder Binarisiertes Bild.

  • Eingabebild: Das aktive Eingabebild wird angezeigt.
  • Normalisiertes Bild: Die normalisierte Version des Bilds wird angezeigt.
  • Binarisiertes Bild: Die binarisierte Version des Bilds wird angezeigt.


Identifizierungswerkzeug "Text lesen (OCRMax)" – Registerkarte "Leerzeichen"

Auf der Registerkarte Leerzeichen wird festgelegt, wie das Werkzeug die Leerzeichen zwischen Zeichen berücksichtigt, falls erforderlich. Das Identifizierungswerkzeug "Text lesen" (OCRMax) verarbeitet Zwischenräume zwischen Zeichen, indem sie als Leerzeichen klassifiziert werden. Leerzeichen sind benutzerdefiniert.

Geschlossen Leerzeichen finden

Legt die Eingabe von Leerzeichen in die Zwischenräume zwischen anderen Zeichen durch das Werkzeug fest: Keine (Standard), Einzelnes Leerzeichen einfügen oder Mehrere Leerzeichen einfügen.

  • Keine: Das Werkzeug fügt nie ein Leerzeichen ein, unabhängig von der Größe der Zwischenräume zwischen Zeichen.
  • Einzelnes Leerzeichen einfügen: Das Werkzeug fügt ein einzelnes Leerzeichen pro Zwischenraum zwischen Zeichen ein, unabhängig von der Größe der Zwischenräume.
  • Mehrere Leerzeichen einfügen: Das Werkzeug fügt eine Anzahl x (mindestens null) von Leerzeichen pro Zeichenzwischenraum ein.
Geschlossen Leerzeichenwert – Modus

Legt fest, wie die Funktion Werte für Leerzeichen berechnet: Immer Ergebnis 100 (Standard) oder Ergebnis basierend auf Qualität.

  • Immer Ergebnis 100: Der Ergebniswert für Leerzeichen ist immer 100.
  • Ergebnis basierend auf Qualität: Der Wert für ein Leerzeichen basiert auf dem Bruchteil an Hintergrundpixeln; ein Leerzeichen, das vollständig aus Hintergrundpixeln besteht, erzielt einen Wert von 100.
Geschlossen Mindestbreite Leerzeichen

Gibt die Mindestbreite eines Leerzeichens in Pixeln an (0 bis 1000; Standard = 10).

Geschlossen Max. Breite Leerzeichen

Gibt die maximale Breite eines Leerzeichens in Pixeln an (0 bis 1000; Standard = 100).


Identifizierungswerkzeug "Text lesen (OCRMax)" – Registerkarte "Variable Länge"

Auf der Registerkarte Variable Länge erfahren Sie, welche Zeichen an verschiedenen Positionen der Zeichenfolge erwartet werden.

Hinweis: Diese Parameter werden nur verwendet, wenn die Parameter der Registerkarte Feld aktiviert und konfiguriert sind.
Geschlossen Zeichenfolgenlänge

Legt fest, ob "Feld" im Modus mit fester Länge (Standard) oder variabler Länge ausgeführt wird.

  • Variabel: Das Werkzeug arbeitet im Modus "Variable Länge".
  • Fest: Das Werkzeug arbeitet im Modus mit fester Länge.
Geschlossen Max. Zeichenfolgenlänge

Legt die maximal zulässige Zeichenfolgenlänge fest (0 bis 100; Standard = 15).

Hinweis: Dieser Parameter ist deaktiviert, wenn der Parameter Zeichenfolgenlänge auf Fest gesetzt ist.
Geschlossen Mindestzeichenfolgenlänge

Legt die zulässige Zeichenfolgen-Mindestlänge fest (0 bis 100; Standard = 5).

Hinweis: Dieser Parameter ist deaktiviert, wenn der Parameter Zeichenfolgenlänge auf Fest gesetzt ist.
Geschlossen Letzter Feldindex – Maximum

Legt die Untersequenzen fest, die für "Feld" berücksichtigt werden; deren Startposition darf diesen Indexwert nicht überschreiten (0 bis 100; Standard = 100).

Hinweis: Dieser Parameter ist deaktiviert, wenn der Parameter Zeichenfolgenlänge auf Fest gesetzt ist.
Geschlossen Erster Feldindex – Minimum

Legt die Untersequenzen fest, die für "Feld" berücksichtigt werden; deren Endposition darf diesen Indexwert nicht unterschreiten (0 bis 100; Standard = 0).

Hinweis: Dieser Parameter ist deaktiviert, wenn der Parameter Zeichenfolgenlänge auf Fest gesetzt ist.


Identifizierungswerkzeug "Text lesen (OCRMax)" – Registerkarte "Training"

Die Registerkarte Training dient zum Trainieren, Anzeigen, Umbenennen und Entfernen von Zeichen. Die Registerkarte ist in zwei Gruppen unterteilt: "Training", wo die Parameter für das Trainieren von Zeichen definiert sind, und "Zeichen", wo die trainierten Zeichensätze verwaltet werden.

Hinweis:
  • Auf der Registerkarte Training kann der Bereich angepasst werden, und die Segmentierungsgrafiken (Zeichenrechtecke) werden beim Ändern des Bereichs aktualisiert.
  • Mehrbytezeichennamen (z. B. Kanji) werden nicht unterstützt. Mehrbytezeichen können eingelernt werden, dem Zeichen muss jedoch ein Einzelbytename gegeben werden.
Geschlossen Training – Steuerelemente
Hinweis: Zeichen müssen korrekt segmentiert sein, bevor sie eingelernt werden können.
  • Trainingszeichenfolge: Gibt die zu trainierende Textzeichenfolge an. Die Anzahl der Zeichen im Texteingabefeld Trainingszeichenfolge muss der Anzahl der segmentierten Zeichen entsprechen. Maximal 50 Zeichen können trainiert werden.
  • Alle trainieren: Legt fest, dass alle Zeichen im Bereich eingelernt werden. Die zu trainierenden Zeichen werden in das Texteingabefeld Trainingszeichenfolge eingegeben, anschließend wird die Schaltfläche Alle trainieren gedrückt. Die Anzahl der Zeichen im Texteingabefeld Trainingszeichenfolge muss der Anzahl der segmentierten Zeichen entsprechen.
  • Neu trainieren: Legt fest, dass nur neue Zeichen im Bereich eingelernt werden. Die zu trainierenden Zeichen werden in das Texteingabefeld Trainingszeichenfolge eingegeben, anschließend wird die Schaltfläche Trainieren gedrückt. Die Anzahl der Zeichen im Texteingabefeld Trainingszeichenfolge muss der Anzahl der segmentierten Zeichen entsprechen.
  • Auswahl trainieren: Legt fest, dass nur bestimmte Zeichen im Bereich eingelernt werden. Ist diese Option aktiviert, wird das Texteingabefeld Trainingszeichenfolge deaktiviert, und mit der Schaltfläche Auswahl trainieren wird das Dialogfeld Dem Zeichensatz die ausgewählten Zeichen hinzufügen aufgerufen. Dieses Dialogfeld enthält eine vollständige Abbildung des Bereichs, und unter jedem segmentierten Zeichen eine Bezeichnung und Texteingabefelder. Die Bezeichnung ist das derzeit dem Zeichen zugewiesene Symbol (unbekannte oder nicht eingelernte Zeichen werden mit einem Fragezeichen "?" gekennzeichnet). Unter der Bezeichnung befindet sich ein Texteingabefeld. Geben Sie in das Texteingabefeld eine Bezeichnung für jedes segmentierte Zeichen ein. Sollen Zeichen nicht neu trainiert werden, lassen Sie das Texteingabefeld leer. Klicken Sie auf die Schaltfläche Trainieren, um das Dialogfeld zu schließen.
Geschlossen Zeichen – Steuerelemente

Nach dem Einlernen ist jedes trainierte Zeichen in der Struktur sichtbar, in der dem Zeichen ein Ordner und eine Bezeichnung zugewiesen wird. Gegebenenfalls werden die Zeichen auch gruppiert (wenn die Bezeichnungen mehrerer Zeichen übereinstimmen).

  • Wählen Sie den Zeichensatz-Stammordner, um im rechten Bereich alle Zeichen im Zeichensatz anzuzeigen. Die Zeichen werden als Symbole über einer Bezeichnung angezeigt.
  • Wählen Sie einen Zeichenordner, um im rechten Bereich alle eingelernten Instanzen dieses Zeichens anzuzeigen. Die Zeichen werden als Symbole über einer Bezeichnung angezeigt.

  • Wählen Sie eine eingelernte Instanz eines Zeichens, um das Zeichen auf den rechten Bereich angepasst anzuzeigen.

    Hinweis: Geben Sie mehrere Einlerninstanzen der Zeichen an, die während der Laufzeit gelesen werden sollen, damit die Funktion ähnliche Zeichentypen besser unterscheiden kann. Das Trainieren mehrerer Instanzen desselben Zeichens birgt jedoch Vor- und Nachteile. Der Vorteil des Einlernens mehrerer Instanzen ist die zu erwartende bessere Klassifizierungsleistung, vor allem beim Lesen von Text, der leicht falsch klassifiziert werden kann (z. B. 8 und B). Das Einlernen mehrerer Instanzen hat folgende Nachteile: eine verringerte Ausführungszeit der Funktion; u. U. eine Verringerung der Vertrauensergebnisse, da mehrere Einlerninstanzen nicht nur die höchste Güte, sondern auch die zweithöchste Güte verbessern; u. U. das Einlernen ungültiger Zeichen.
  • Importieren: Öffnet das Dialogfeld "Öffnen", mit dem ein als OCRMax-Datendatei (*.ocm) gespeicherter Zeichensatz importiert werden kann.
  • Exportieren: Öffnet das Dialogfeld "Speichern unter", mit dem ein Zeichensatz als OCRMax-Datendatei (*.ocm) gespeichert werden kann.

  • Umbenennen: Wählen Sie ein umzubenennendes Element, und klicken Sie anschließend auf diese Schaltfläche. Jedes Element in der Struktur oder im Listenbereich rechts kann umbenannt werden.

    Hinweis: Durch das Umbenennen einer Gruppe von Zeichen wird allen Zeichen in der Gruppe eine neue Bezeichnung zugewiesen. Durch das Umbenennen eines einzelnen Zeichens wird diesem einzelnen, ausgewählten Zeichen eine neue Bezeichnung zugewiesen. Außerdem wird das Zeichen in der Struktur in eine neue oder andere Gruppe verschoben.

  • Löschen: Wählen Sie im Zeichensatz ein zu entfernendes Element, und klicken Sie anschließend auf diese Schaltfläche. Jedes Element in der Struktur oder im Listenbereich rechts kann umbenannt werden.

    Hinweis: Das Löschen des Zeichensatzordners entfernt den Zeichensatz. Alle Zeichen werden gelöscht. Das Löschen einer Zeichengruppe entfernt alle Zeichen, deren Bezeichnung mit der Bezeichnung der gelöschten Gruppe übereinstimmt.


Identifizierungswerkzeug "Text lesen (OCRMax)" – Registerkarte "Feld"

Die Registerkarte Feld ermöglicht eine grafische Erstellung und Bearbeitung der Parameter Zeichenbereich und Bereichsdefinitionen des Identifizierungswerkzeugs "Text lesen (OCRMax)". Die Ergebniswerte werden in das Werkzeug als Literalzeichenfolgen eingefügt.

"Feld" bietet die Möglichkeit, Zeichenfolgen zu überprüfen und zu korrigieren, damit die passendsten gültigen Zeichenfolgen zurückgegeben werden. "Feld" hat zwei Hauptfunktionen:

  • Überprüfen der OCR-Ergebnisse, um festzustellen, ob die zurückgegebene Zeichenfolge korrekt ist oder nicht auf den Parametern Zeichenbereich und Bereichsdefinitionen basiert.
  • Korrektur der OCR-Ergebnisse, wenn sich die zurückgegebene Zeichenfolge nicht in der Liste akzeptabler Ergebnisse befindet und versucht wird, eine akzeptable Zeichenfolge zu finden, die der zurückgegebenen Zeichenfolge am ähnlichsten ist.

Ein typischer Anwendungsfall für "Feld" sind Zeichenfolgen, die Präfix- oder Suffixzeichen enthalten, die unter Verwendung von "Feld" ignoriert werden. In diesem Fall wird durch die Parameter Zeichenbereich und Bereichsdefinitionen der Versatz der Position der Zeichenfolge im Bereich ermittelt.

Geschlossen Feldzeichenfolge

Gibt die im Zeichensatz enthaltene Anzahl von Zeichen an. Ein Eintrag für den Zeichenbereich kann ein beliebiges, im Dialogfeld zur Texteingabe gefundenes Zeichen sein, einschließlich A bis Z, a bis z, 0 bis 9, Bindestrichen (-), Punkten (.) und Leerzeichen ( ).

Jedes Zeichen im Feld Zeichenbereich entspricht einer indizierten Feldposition zwischen 0 und 31. Der Zeichenbereich muss mindestens so viele Positionen enthalten, wie die Zeichenfolge Zeichen enthält, damit die Lesung erfolgreich ist. (Wenn 10 Zeichen vorhanden sind, der Zeichenbereich aber nur 9 Zeichen enthält, werden die 9 Zeichen mit der besten Übereinstimmung zurückgegeben. Sind jedoch 8 Zeichen vorhanden, und der Zeichenbereich definiert 9 Zeichen, gibt die Funktion eine Fehlermeldung aus.) Standardmäßig wird jede Position im Zeichenbereich als Sternchen (*) oder alphanumerischer Platzhalter dargestellt. Das bedeutet, dass jedes Zeichen an jeder Position der Zeichenfolge gültig ist.

Im Zeichenbereich können jedoch einzelne Positionen begrenzt werden, damit an dieser Position nur eine Teilmenge möglicher Zeichen berücksichtigt wird. Dadurch wird die Gesamtleistung und Zuverlässigkeit verbessert, da an einer Position nicht mögliche Zeichen bei einer Lesung nicht berücksichtigt werden.

Die vordefinierten Zeichenbereicheinträge lauten:

Zeichenbereich Eintrag | Beschreibung | Gültige Zeichen
* | Platzhalter | Beliebiges eingelerntes Zeichen im Zeichensatz.
N | Ziffern | 0123456789
A | Großbuchstaben | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | Kleinbuchstaben | abcdefghijklmnopqrstuvwxyz
H | Hexadezimalzeichen, Großbuchstaben und Ziffern | 0123456789ABCDEF
h | Hexadezimalzeichen, Kleinbuchstaben und Ziffern | 0123456789abcdef
O | Oktalzeichen | 01234567
Hinweis:
  • >Soll eine Position in einem Zeichenbereich auf ein einzelnes Zeichen beschränkt werden, geben Sie einfach dieses Zeichen ein. Das Zeichen muss im Zeichensatz trainiert sein und kann nicht zu den oben aufgeführten vordefinierten Zeichenbereicheinträgen gehören, außer es wurde mithilfe des Parameters Bereichsdefinitionen neu zugeordnet.
  • >Soll eine Zeichenfolge gelesen werden, die ein Leerzeichen enthält, geben Sie im Zeichenbereich das Leerzeichen an. Leerzeichen werden von ReadText nicht gelesen, wenn der entsprechende Eintrag für den Zeichenbereich an dieser Position ein Sternchen (*) ist.
Geschlossen Zeichenbereich – Beispiel 1

Lautet der Zeichenbereich **********AN, ist an den ersten 10 Zeichenbereichpositionen jedes Zeichen im Zeichensatz gültig. An der 11. Position werden jedoch nur Alphazeichen in Großschrift beim Lesevorgang berücksichtigt. An der 12. Position werden nur numerische Zeichen berücksichtigt.

Geschlossen Zeichenbereich – Beispiel 2

Der Zeichensatz enthält nur die numerischen Zeichen 0 bis 9 und /. Lautet der Zeichenbereich NN/NN/NN, werden an der ersten und zweiten, vierten und fünften sowie siebten und achten Position nur numerische Zeichen berücksichtigt. An der dritten und sechsten Position wird nur der Schrägstrich (/) berücksichtigt.

Lautet der Zeichenbereich jedoch NN/NN/AA, wird bei der Lesung eine Fehlermeldung ausgegeben, da der Zeichensatz keine Alphazeichen enthält.

Geschlossen Nicht-Feldzeichen ignorieren

Gibt an, ob an jeder Zeichenposition die Ergebnisse auf Zeichen beschränkt werden, die im Feld des Zeichens festgelegt sind. Ist diese Option aktiviert, werden alle anderen Zeichen im Zeichensatz unabhängig von ihrer Klassifizierungsgüte ignoriert.

Geschlossen Felddefinitionen

Die Einstellungen für die Felddefinitionen können optional verwendet werden, um benutzerdefinierte Einträge für den Zeichenbereich zu erstellen. Werden diese Einträge in den Zeichenbereich eingeschlossen, beschränken sie die Liste von gültigen Zeichen an den zugehörigen Einfügepositionen. Mehrere vordefinierte Felddefinitionen stehen zur Verfügung, und benutzerdefinierte Felddefinitionen können hinzugefügt werden. Die vordefinierten Definitionen werden als grauer Text angezeigt und können lediglich aktiviert oder deaktiviert werden. Sie können jedoch nicht entfernt oder bearbeitet werden. Benutzerdefinierte Definitionen werden als schwarzer Text angezeigt und können hinzugefügt, entfernt oder bearbeitet werden. Wenn Sie eine Felddefinition hinzufügen möchten, klicken Sie auf die Schaltfläche Neue hinzufügen, und weisen Sie dem Zeichen ein Symbol und anschließend eine Definition zu.

Zeichen für einen Felddefinitionen-Eintrag müssen im Datensatz enthalten sein. Beispiel: #=123 ist gültig, wenn 1, 2 und 3 im benutzerdefinierten, trainierten Zeichensatz enthalten sind. Sind 1, 2 und 3 jedoch nicht im Datensatz enthalten, ist #=123 ungültig.

Hinweis: Wird einer der vordefinierten Einträge (*, A, a, N, H, h, O) im Parameter Felddefinitionen verwendet, werden die gültigen Zeichen in der neuen Definition erneut zugeordnet.
Geschlossen Felddefinitionen – Beispiel 1

Lautet der Wert von Felddefinitionen #=123;$=3456;%=789 und der Zeichenbereich #$%*******, sind an der ersten Position nur die Zeichen 1, 2 oder 3 gültig. An der zweiten Position sind nur die Zeichen 3, 4, 5 oder 6 gültig. An der dritten Position sind nur 7, 8 oder 9 gültig. An den Positionen vier bis zehn sind alle Zeichen im Zeichensatz gültig.

Geschlossen Felddefinitionen – Beispiel 2

Lautet der Wert von Felddefinitionen #=123;$=3456;%=789, A=A und der Zeichenbereich #$%******A, sind an der ersten Position nur die Zeichen 1, 2 oder 3 gültig. An der zweiten Position sind nur die Zeichen 3, 4, 5 oder 6 gültig. An der dritten Position sind nur 7, 8 oder 9 gültig. An den Positionen vier bis neun sind alle Zeichen im Zeichensatz gültig. An der zehnten Position wird nur das Zeichen A berücksichtigt, da die Felddefinition A=A den vordefinierten Eintrag für den Zeichenbereich erneut zuordnet.


Identifizierungswerkzeug "Text lesen (OCRMax)" – Registerkarte "Diagnose"

Die Registerkarte "Diagnose" enthält Informationen darüber, wie das Werkzeug "Text lesen (OCRMax)" die Zeichen in einem Bereich segmentiert hat. Diese Daten sind möglicherweise hilfreich, um festzustellen, inwiefern bestimmte Parameter anzupassen sind, oder ob Zeichen und/oder Zeichenfragmente korrekt segmentiert sind. Verwenden Sie diese Registerkarte in Verbindung mit dem Parameter Diagnose anzeigen, um Diagnosedaten grafisch darzustellen.

Geschlossen Hauptlinienwinkel

Gibt die Winkelausrichtungsdaten der Zeichenbereiche relativ zum Bereich in Grad an.

Geschlossen Zeichenkrümmung

Gibt die Winkelkrümmungsdaten der Zeichenbereiche relativ zum Bereich in Grad an.

Geschlossen Zwischenraum zwischen Zeichen

Gibt das Minimum und Maximum der gemessenen Zwischenräume zwischen Zeichen in Pixeln an.

Geschlossen Zwischenraum in Zeichen

Gibt das Minimum und Maximum der gemessenen Zwischenräume in Zeichen in Pixeln an.

Geschlossen Zeichenneigung

Gibt das Minimum und Maximum der Neigungsmessung des Zeichens in Pixeln an.

Geschlossen Größe akzeptierter Fragmente

Gibt das Minimum und Maximum der gemessenen Größe akzeptierter Fragmente in Pixeln an.

Geschlossen Kontrast akzeptierter Fragmente

Gibt das Minimum und Maximum des gemessenen Kontrasts akzeptierter Fragmente als Prozentwert an.

Geschlossen Abstand akzeptierter Fragmente zur Hauptlinie (%)

Gibt den maximalen Y-Abstand aller akzeptierten Fragmente als Prozentwert der Hauptlinienhöhe an.

Geschlossen Größe abgelehnter Fragmente

Gibt das Minimum und Maximum der gemessenen Größe abgelehnter Fragmente in Pixeln an.

Geschlossen Kontrast abgelehnter Fragmente

Gibt das Minimum und Maximum des gemessenen Kontrasts abgelehnter Fragmente als Prozentwert an.

Geschlossen Abstand abgelehnter Fragmente zur Hauptlinie (%)

Gibt den maximalen Y-Abstand aller abgelehnten Fragmente als Prozentwert der Hauptlinienhöhe an.

Geschlossen Breite akzeptierter Zeichen

Gibt das Minimum und Maximum der gemessenen Breite akzeptierter Zeichen in Pixeln an.

Geschlossen Höhe akzeptierter Zeichen

Gibt das Minimum und Maximum der gemessenen Höhe akzeptierter Zeichen in Pixeln an.

Geschlossen Größe akzeptierter Zeichen

Gibt das Minimum und Maximum der gemessenen Größe akzeptierter Zeichen in Pixeln an.

Geschlossen Breite abgelehnter Zeichen

Gibt das Minimum und Maximum der gemessenen Breite abgelehnter Zeichen in Pixeln an.

Hinweis: Sind keine abgelehnten Zeichen vorhanden, wird #ERR angezeigt.
Geschlossen Höhe abgelehnter Zeichen

Gibt das Minimum und Maximum der gemessenen Höhe abgelehnter Zeichen in Pixeln an.

Hinweis: Sind keine abgelehnten Zeichen vorhanden, wird #ERR angezeigt.
Geschlossen Größe abgelehnter Zeichen

Gibt das Minimum und Maximum der gemessenen Größe abgelehnter Zeichen in Pixeln an.

Hinweis: Sind keine abgelehnten Zeichen vorhanden, wird #ERR angezeigt.


Identifizierungswerkzeug "Text lesen (OCRMax)" – Registerkarte "Ergebnisse"

Geschlossen Zeichen

Zeigt das an dieser Position gelesene Zeichen an.

Geschlossen Status

Zeigt den Status des gelesenen Zeichens an (Ungültiger Lesevorgang, Guter Lesevorgang, Ignoriert, Verwechselt, Konflikt, Verwechselt-Nichtübereinstimmung, Erfolgloser Lesevorgang oder Prüfung fehlgeschlagen).

  • Ungültiger Lesevorgang: Keine Zeichen erzielten ein Ergebnis, das über dem Akzeptanzschwellenwert lag und als "Guter Leservorgang" gewertet werden konnte.
  • Guter Lesevorgang: Das Werkzeug hat das Zeichen an dieser Position erfolgreich gelesen.
  • Ignoriert: Ist "Feld" aktiviert und ein Zeichenbereich festgelegt, der kürzer als die von der Funktion gelesene Zeichenfolge ist, werden die Zeichen am Anfang oder Ende der Zeichenfolge segmentiert (in Gelb). Sie sind jedoch nicht im Gesamtergebnis enthalten. Lautet beispielsweise die Felddefinition ABC und die von der Funktion gelesene Zeichenfolge "12ABC34", dann wird "1234" ignoriert.
  • Verwechselt: Das Werkzeug hat ein Zeichen identifiziert, dessen Wert hoch genug ist, um als "Guter Lesevorgang" zu gelten (über dem Parameterwert Akzeptanzschwellenwert). Ein anderes Zeichen weist jedoch einen ähnlichen Wert (im Rahmen des Parameterwerts Verwechslungsschwellenwert) auf, und das richtige Zeichen konnte nicht eindeutig identifiziert werden [Verwechselt = (Primärwert – Sekundärwert)/Vertrauensschwelle].
  • Konflikt: Das Werkzeug hat ein Zeichen identifiziert, das nicht mit "Feld" übereinstimmt und einen viel höheren Wert aufweist, als alle Zeichen, die nicht mit "Feld" übereinstimmen. An dieser Position wurde wahrscheinlich ein Zeichen gedruckt, das nicht mit "Feld" übereinstimmt. Feld muss aktiviert sein, damit dieser Status zurückgegeben wird.
  • Verwechselt-Nichtübereinstimmung: Die Funktion hat ein Zeichen identifiziert, das sowohl die Anforderungen von Verwechselt als auch Konflikt erfüllt.
  • Prüfung fehlgeschlagen: Ist der Parameter "Zusätzliche Zeichenprüfung überspringen" deaktiviert, analysiert die Funktion die Zeichen in einem zusätzlichen Überprüfungsschritt, um sicherzustellen, dass bei Lesevorgängen keine Fehler auftreten.
Geschlossen Güte

Zeigt an, inwieweit das gelesene Zeichen mit dem trainierten Zeichen in der Zeichensatzdatenbank übereinstimmt.

Geschlossen Verwechselt

Zeigt das nächste Zeichen mit der besten Übereinstimmung an.

Geschlossen Verwechslungsergebnis

Zeigt die Wahrscheinlichkeit an, mit der die ausgewählte Übereinstimmung im Vergleich zur nächstbesten Übereinstimmung das richtige Ergebnis ist.


Identifizierungswerkzeuge – Text lesen

Das Identifizierungswerkzeug "Text lesen" dient zum Lesen und/oder Überprüfen alphanumerischer Textzeichenfolgen anhand von eingelernten Zeichenmodellen.

Hinweis: Beim In-Sight Explorer 4.7.0 und höher steht das Identifizierungswerkzeug "Text lesen" nur auf In-Sight Vision-Systemen zur Verfügung, die OCRMax nicht unterstützen und ist auf In-Sight Vision-Systemen, die In-Sight Firmware 5.1.0 und höher verwenden, auch nicht verfügbar.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Identifizierungswerkzeugs "Text lesen"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereichstyp festlegen und im Bild konfigurieren:

  1. Platzieren Sie den Bereich über dem Text, und stellen Sie sicher, dass der Bereich den Text abdeckt (weitere Informationen finden Sie unter Auswählen des zu lesenden Textes). Erstellen Sie zur Verbesserung der Leistungsstärke des Werkzeugs kleinere Bereiche. Je größer ein Bereich ist, desto länger dauert die Inspektion mit dem Werkzeug.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Nachdem der Bereich akzeptiert wurde, müssen Sie den Modus des Vorgangs definieren (Lesen, Überprüfen oder Lesen und überprüfen), den Typ der Schriftart auswählen (OCR-A Schwarz-auf-Weiß, OCR-A Weiß-auf-Schwarz, OCR-B Schwarz-auf-Weiß, OCR-B Weiß-auf-Schwarz oder Benutzerdefiniert) und die Anzahl der Zeichen im Parameter Zeichenbereich oder Übereinstimmende Zeichenfolge auf der Registerkarte Einstellungen angeben (abhängig vom Modus).
    • Wurde Lesen als Modus des Vorgangs und OCR-A oder OCR-B für den Typ der Schriftart ausgewählt, legen Sie im Parameter Zeichenbereich die Anzahl von Zeichen fest, und klicken Sie dann auf Einstellen, um die richtige Skalierung einzustellen.

    • Wurde Überprüfen oder Lesen und überprüfen als Modus des Vorgangs gewählt und OCR-A oder OCR-B für den Typ der Schriftart ausgewählt, geben Sie im Parameter Übereinstimmende Zeichenfolge die Zeichen ein, und klicken Sie auf Einstellen, um die richtige Skalierung einzustellen.

      Hinweis: Bei Verwendung der OCR-A- oder OCR-B-Schriftarten muss das Bild zwischen 15 und 60 Pixel hoch sein. Klicken Sie auf Einstellen, um die Zeichen korrekt zu skalieren. Wenn die Zeichen kleiner als 15 Pixel oder größer als 60 Pixel sind, müssen Sie eine benutzerdefinierte Schriftart erstellen.
    • Wenn Sie Benutzerdefiniert für den Typ der Schriftart ausgewählt haben, klicken Sie zuerst auf die Schaltfläche Schriftart trainieren und erstellen Sie eine Schriftartbibliothek. Wählen Sie nach dem Erstellen der Schriftartbibliothek den Modus des Vorgangs, und geben Sie die Anzahl der Zeichen im Parameter Zeichenbereich für den Modus Lesen ein, oder geben Sie die Anzahl der Zeichen im Parameter Übereinstimmende Zeichenfolge für den Modus Überprüfen oder Lesen und überprüfen ein.
    • Sie können in einem einzelnen Job bis zu vier benutzerdefinierte Schriftarten (beispielsweise "Benutzerdefiniert_1", "Benutzerdefiniert_2", "Benutzerdefiniert_3" und "Benutzerdefiniert_4") verwenden, und eine trainierte Schriftart kann für alle Identifizierungswerkzeuge "Text lesen" freigegeben werden, wenn dem Job mehrere benutzerdefinierte Schriftarten hinzugefügt werden.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

Erstellen eines benutzerdefinierten Zeichensatzes

Auswählen des zu lesenden Textes


Erstellen eines benutzerdefinierten Zeichensatzes

  1. Klicken Sie zum Definieren eines benutzerdefinierten Zeichensatzes auf die Registerkarte Einstellungen, und klicken Sie auf die Schaltfläche Schriftart trainieren. Daraufhin wird das Dialogfeld Schriftart trainieren geöffnet, in dem Sie den Text für Ihre Anwendung konfigurieren können.

    Hinweis: Sie können in einem einzelnen Job bis zu vier benutzerdefinierte Schriftarten verwenden (beispielsweise "Benutzerdefiniert_1", "Benutzerdefiniert_2","Benutzerdefiniert_3" und "Benutzerdefiniert_4").
  2. Geben Sie auf der Registerkarte Training einen benutzerdefinierten Namen für den Zeichensatz ein (dies ist besonders hilfreich, wenn Sie mit mehreren Zeichensatzbibliotheken arbeiten).

  3. Legen Sie die Polarität der Zeichen fest: Wenn die eingelernten Zeichen heller als ihr Hintergrund sind, wählen Sie Hell auf Dunkel aus. Wählen Sie andernfalls Dunkel auf Hell aus.

    Hinweis: Vergewissern Sie sich, dass die korrekte Polarität eingestellt ist, bevor Sie auf Zu Zeichensatz hinzufügen klicken. Die Polarität kann nicht mehr geändert werden, nachdem dem Zeichensatz Zeichenmodelle hinzugefügt wurden.
  4. Geben Sie die erwartete Textzeichenfolge ein. Achten Sie darauf, dass die Groß-/Kleinschreibung und die Leerzeichen in der Textzeichenfolge den Modellzeichen entsprechen.
  5. Klicken Sie anschließend auf die Schaltfläche Segment. Stellen Sie sicher, dass jedes Zeichen über einen eigenen Bereich und eine Nummer verfügt. Nehmen Sie andernfalls unter Segmentanpassungen die folgenden Einstellungen vor:
    • Klicken Sie auf die Schaltfläche Ändern, um den Bereich um eine bestimmte Zeicheninstanz zu ändern.
    • Klicken Sie auf die Schaltfläche Umbenennen, um einer Zeicheninstanz einen neuen Namen zuzuweisen.
    • Klicken Sie auf die Schaltfläche Löschen, um eine Zeicheninstanz zu entfernen.
  6. Wenn Sie mit der Identifizierung Ihrer Zeichen zufrieden sind, klicken Sie auf Zu Zeichensatz hinzufügen. Der Zeichensatz enthält jetzt Instanzen für jedes Zeichen, das in der erwarteten Zeichenfolge identifiziert wurde.
  7. Der Zeichensatz enthält jetzt mehrere Zeichenmodelle, die wiederum mehrere Instanzen enthalten können. Alle Zeichen, einschließlich Leerzeichen und Interpunktion, werden segmentiert und Zeichenmodellen zugeordnet.

  8. Sie können Ihre Zeichenmodelle jetzt durchsuchen und Zeichenmodelle oder -instanzen hinzufügen, löschen, bearbeiten, umbenennen oder aktivieren/deaktivieren.

    Hinweis: Eine eingelernte Schriftart kann für alle Identifizierungswerkzeuge "Text lesen" freigegeben werden, wenn dem Job mehrere benutzerdefinierte Schriftarten hinzugefügt werden.
  9. Klicken Sie auf die Schaltfläche OK, wenn Sie mit dem eingelernten Zeichensatz zufrieden sind.


Auswählen des zu lesenden Textes

Die folgenden Richtlinien und Hinweise können Ihnen dabei helfen, konsistente Ergebnisse zu erzielen:

Geschlossen Schriftarten/Zeichensätze
  • Verwenden Sie speziell für OCR/OCV-Anwendungen entwickelte Schriftarten.
  • Vergewissern Sie sich, dass die Zeichenbreite mindestens 5 Pixel pro Strich beträgt. Die Zeichen sollten das Bild soweit wie möglich ausfüllen. Je mehr Pixel pro Zeichen verwendet werden, desto höher ist die Genauigkeit des Werkzeugs. Die Ausführung wird dadurch jedoch etwas verlangsamt.
  • Wenn Sie mehrere Schriftarttypen in Ihrem Bild verwenden, sollte für jeden Typ ein separates Identifizierungswerkzeug "Text lesen" eingesetzt werden.
  • Wenn Sie mehrere Schriftgrade in Ihrem Bild verwenden, sollte für jeden Schriftgrad ein separates Identifizierungswerkzeug "Text lesen" eingesetzt werden.
Geschlossen Spezielle OCR/OCV-Schriftarten

Geschlossen Zeichenmodelle und -instanzen
  • Verwenden Sie Zeichen mit hoher Auflösung, um klare und scharfe Zeichenmodelle zu erstellen.
  • Ein Identifizierungswerkzeug "Text lesen" unterstützt bis zu 255 Zeichenmodelle, und jedes Zeichenmodell basiert auf bis zu 8 eingelernten Instanzen dieses Zeichenmodells. Das Einlernen weiterer Instanzen eines Zeichenmodells erhöht die Toleranz des Werkzeugs gegenüber Abweichungen im Zeichenmodell. Wenn Ihre Anwendung keine großen Abweichungen zulässt, lernen Sie Ihre Zeichenmodelle mit nur einem guten Beispiel ein. Muss Ihre Anwendung Abweichungen zulassen, sollten Sie möglichst viele Instanzen zum Einlernen des Zeichenmodells verwenden.
  • Achten Sie beim Einlernen der Instanzen eines Zeichenmodells darauf, dass das Druckmuster der Zeichen möglichst gleichmäßig ist. Bei erheblichen Änderungen der Form und Größe eines Zeichens erhalten Sie ungenügende Zeichenmodelle, die zur Laufzeit zu Fehlern führen.
Geschlossen Beispiele für das Einlernen von Instanzen

Gute Einlerninstanzen eines Zeichenmodells.

Schlechte Einlerninstanzen eines Zeichenmodells.


Anpassen der Parameter des Identifizierungswerkzeugs "Text lesen"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Identifizierungswerkzeugs "Text lesen" umfasst vier Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Zeichenmodelltabelle
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Zeichenmodelltabelle


Identifizierungswerkzeug „Text lesen“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Text_1“, sofern es sich um das erste Identifizierungswerkzeug „Text lesen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Text_2“, „Text_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Identifizierungswerkzeug "Text lesen" – Registerkarte "Einstellungen"

Geschlossen Schaltfläche "Schriftart trainieren"

Öffnet das Dialogfeld Schriftart trainieren, in dem Sie Ihre Zeichensätze (Zeichenmodelle und deren Instanzen) definieren und bearbeiten.

Geschlossen Modus

Legt den Betriebsmodus des Werkzeugs fest: Lesen, Überprüfen oder Lesen und überprüfen.

  • Lesen: Das Werkzeug decodiert die Textzeichenfolge basierend auf den eingelernten Zeichenmodellen. Die decodierte Textzeichenfolge muss der mit dem Parameter Zeichenbereich definierten Anzahl von Zeichen entsprechen.
  • Überprüfen: Das Werkzeug decodiert die Textzeichenfolge basierend auf der im Parameter Übereinstimmende Zeichenfolge definierten Zeichenfolge.
  • Lesen und überprüfen: Das Werkzeug decodiert die Textzeichenfolge und vergleicht die decodierte Zeichenfolge mit der im Parameter Übereinstimmende Zeichenfolge definierten Zeichenfolge. Die decodierte Textzeichenfolge muss der im Parameter Übereinstimmende Zeichenfolge definierten Zeichenfolge entsprechen, um als "Bestanden" klassifiziert zu werden.
Hinweis: Das Werkzeug verfügt über zwei Status: „Gut“ oder „Schlecht“. Ist der Modus des Werkzeugs auf Überprüfen oder Lesen und überprüfen festgelegt, wird in zwei unterschiedlichen Szenarios ein negatives Ergebnis ausgegeben: Wenn der Lesevorgang nicht erfolgreich ist, oder wenn der Lesevorgang erfolgreich ist aber nicht mit der im Parameter Übereinstimmende Zeichenfolge eingegebenen Zeichenfolge übereinstimmt.

Ist letzteres der Fall (Modus Lesen und überprüfen), gibt das Werkzeug die nicht übereinstimmenden Daten aus (Konflikt und Konflikt_Anzahl), die von EasyView und anderen Kommunikationsgeräten im Anwendungsschritt „Kommunikation“ verwendet werden können. Die Konfliktdaten können im Dialogfeld EasyView-Elemente auswählen, im Dialogfeld OPC-Tags auswählen oder im Dialogfeld Eingabe-/Ausgabedaten auswählen ausgewählt werden.

Die Konfliktdaten sind hilfreich, wenn festgestellt werden soll, ob das Werkzeug den Text nicht lesen kann, oder wenn der Text gelesen werden kann, aber nicht mit der definierten übereinstimmenden Zeichenfolge übereinstimmt. Wenn der Text beispielsweise nicht vom Werkzeug gelesen werden kann, tritt möglicherweise ein Problem beim Texterstellungsvorgang oder der Einrichtung des Vision-Systems auf. Kann der Text zwar gelesen werden aber stimmt nicht mit der definierten übereinstimmenden Zeichenfolge überein, könnte der falsche Text erstellt werden.
Geschlossen Schriftart

Definiert den Zeichensatztyp. Sie können einen vordefinierten Zeichensatztyp (OCR-A oder OCR-B, Weiß-auf-Schwarz oder Schwarz-auf-Weiß) auswählen oder durch Trainieren bzw. Einlernen von Zeichenmodellen einen benutzerdefinierten Zeichensatz erstellen.

Hinweis: Sie können in einem einzelnen Job bis zu vier benutzerdefinierte Schriftarten verwenden (beispielsweise "Benutzerdefiniert_1", "Benutzerdefiniert_2","Benutzerdefiniert_3" und "Benutzerdefiniert_4").
Geschlossen Zeichenbereich

Definiert die Anzahl von Zeichen in der Textzeichenfolge für einen Vorgang im Modus Lesen. Jedes Zeichen im Feld Zeichenbereich entspricht einer indizierten Position zwischen 0 und 31 (maximale Anzahl von Zeichen). Die Anzahl von Positionen in einem Zeichenbereich muss der Anzahl von Zeichen in der Textzeichenfolge entsprechen.

Ein Eintrag im Feld "Zeichenbereich" kann Groß- und Kleinbuchstaben, Zahlen, Bindestriche, Punkte und Leerzeichen enthalten. Standardmäßig wird jede Position im Zeichenbereich als "*" dargestellt (ein alphanumerischer "Platzhalter"). Dies bedeutet, dass an dieser Position in der Textzeichenfolge jedes Zeichen gültig ist.

Im Zeichenbereich können einzelne Positionen definiert werden, sodass das Werkzeug an dieser Position nur eine Teilmenge möglicher Zeichen berücksichtigt. Dadurch wird die Gesamtleistung und Zuverlässigkeit des Werkzeugs verbessert.

Eintrag für den Zeichenbereich | Beschreibung | Gültige Zeichen
* | Platzhalter | Beliebiges eingelerntes Zeichen im Zeichensatz.
N | Ziffern | 0123456789
A | Großbuchstaben | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | Kleinbuchstaben | abcdefghijklmnopqrstuvwxyz
H | Hexadezimalzeichen, Großbuchstaben und Ziffern | 0123456789ABCDEF
h | Hexadezimalzeichen, Kleinbuchstaben und Ziffern | 0123456789abcdef
O | Oktal | 01234567
Geschlossen Übereinstimmende Zeichenfolge

Legt die erwartete Textzeichenfolge fest (diese Option ist nur aktiviert, wenn der Parameter Modus auf Überprüfen oder Lesen und überprüfen eingestellt ist). Geben Sie die Informationen ein, die das Werkzeug erwartungsgemäß decodieren wird.

Hinweis: Die Übereinstimmungszeichenfolge kann über ein anderes Gerät eingegeben werden. Wenn Sie den Job ausführen, kann das Identifizierungswerkzeug die Textzeichenfolge vom Eingabegerät lesen und mit dem erkannten Text vergleichen. Das Werkzeug Text lesen gibt einen Fehler aus, und im Feld Übereinstimmende Zeichenfolge wird TRIG angezeigt, bis die Übereinstimmende Zeichenfolge vom externen Gerät eingegeben wird.
Geschlossen Schaltfläche "Einstellen"

Berechnet den Skalierungsunterschied (50 % bis 200 %) zwischen den eingelernten Zeichenmodellen und der Zeichensatzbibliothek im Vergleich zu den Zeichen im Bild. Die Schaltfläche "Einstellen" sollte nur verwendet werden, wenn der Größenunterschied zwischen den Zeichenmodellen und den Zeichen in der Textzeichenfolge größer als ±5 % ist.

Geschlossen Akzeptanzschwellenwert

Definiert die minimal zulässige Güte (0-100; Standard = 70) für jedes Zeichen in der Textzeichenfolge. Wenn ein Zeichen in der Textzeichenfolge unter dem Akzeptanzschwellenwert liegt, ist das Ergebnis für die gesamte Textzeichenfolge ein Fehler.

Geschlossen Lesemodus

Legt den Algorithmusmodus für das Lesen von Text fest: Geschwindigkeit oder Genauigkeit. Der Modus "Geschwindigkeit" (Standard-Lesemodus) ist bei guten Bildern mit hohem Kontrast, die eine sehr schnelle Ausführungszeit des Werkzeugs erfordern, effektiver. Der Modus "Genauigkeit" eignet sich dagegen besser für schwierigere Bilder mit geringem Kontrast, bei denen eine schnelle Ausführung des Werkzeugs nicht erforderlich ist.

Geschlossen Differenz annehmen

Definiert den zulässigen Mindestdifferenzwert, der zwischen der höchsten und der zweithöchsten Güte eines Zeichens erforderlich ist (0-20; Standard = 0). Ist die Differenz kleiner oder gleich dem Wert von "Differenz annehmen", ist das Ergebnis für die gesamte Textzeichenfolge ein Fehler.

Geschlossen Unterscheidung vom Hintergrund schwierig

Kompensiert Merkmale im Bild, die mit der Textzeichenfolge verwechselt werden können (diese Option ist standardmäßig deaktiviert). Wenn Unterscheidung vom Hintergrund schwierig aktiviert ist, verlangsamt sich die Ausführungszeit des Werkzeugs geringfügig. Diese Option ist besonders nützlich, wenn andere Merkmale im Bereich fälschlich als Anfang der Textzeichenfolge interpretiert werden.

Geschlossen Skalierungstoleranz

Lässt in Form einer Toleranz Abweichungen der Zeichenskalierung zu (diese Option ist standardmäßig deaktiviert).

Geschlossen Timeout

Definiert den Zeitraum in Millisekunden (0 bis 30 000), in dem das Werkzeug nach Text sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird.

Geschlossen Ergebnis

Zeigt die decodierten oder überprüften Informationen aus der Textzeichenfolge an.


Identifizierungswerkzeug "Text lesen" - Zeichenmodelltabelle

Geschlossen Index

Zeigt die Position des Zeichens in der Zeichenfolge an.

Geschlossen Zeichen

Zeigt das Modellzeichen mit der höchsten Güte an (d. h. das Modellzeichen, das dem Zeichen in der Zeichenfolge am genauesten entspricht).

Geschlossen Güte

Gibt an, in welchem Maß dem Modellzeichen mit der höchsten Güte "vertraut" wird. Ist der zurückgegebene Wert kleiner oder gleich dem Wert von Akzeptanzschwellwert, ist das Ergebnis für die gesamte Zeichenfolge ein Fehler.

Geschlossen Bestanden

Zeigt an, ob das Zeichen bestanden hat. Diese Angabe beruht darauf, ob die Werte in den Spalten Güte und Zeichenunterschied kleiner oder gleich (Fehler) oder größer (Bestanden) als die Werte der Parameter Akzeptanzschwellwert und Differenz annehmen sind.

Geschlossen Zweites Zeichen

Zeigt das Modellzeichen mit der zweithöchsten Güte an (d. h. das Modellzeichen, das dem Zeichen in der Zeichenfolge am zweitbesten entspricht).

Geschlossen Zweite Güte

Gibt an, in welchem Maß dem Modellzeichen mit der zweithöchsten Güte "vertraut" wird.

Geschlossen Zeichenunterschied

Zeigt die Differenz zwischen der höchsten und der zweithöchsten Güte an. Ist der zurückgegebene Wert kleiner oder gleich dem Wert von Differenz annehmen, ist das Ergebnis für die gesamte Zeichenfolge ein Fehler.


Identifizierungswerkzeuge – PatMax RedLine-Muster (1-10) und PatMax-Muster (1-10)

Hinweis:
  • Ab der In-Sight-Firmwareversion 5.5.0 oder höher wurde der Algorithmus des Werkzeugs geändert. Es gibt jetzt genauere Ergebnisse zurück und verringert in einigen Fällen die Ausführungszeit.
  • Aufgrund dieser Änderung wird bei dem Versuch, einen Job, der mit der In-Sight-Firmwareversion 5.5.0 oder höher konfiguriert wurde, in ein In-Sight Vision-System zu laden, das die Firmwareversion 5.4.x oder früher ausführt, eine Fehlermeldung angezeigt.
  • Das Identifizierungswerkzeug PatMax RedLine-Muster ist nur auf In-Sight Vision-Systemen mit In-Sight-Firmware 5.2.0 und höher verfügbar. Eine komplette Modelliste mit unterstützten Firmwareversionen finden Sie im Abschnitt Firmwareversionen.

Die Identifizierungswerkzeuge PatMax RedLine-Muster und PatMax-Muster werden verwendet, um Vorkommen von Mustermerkmalen einzulernen. Dabei werden die PatMax RedLine- oder PatMax-Algorithmen verwendet und dann das bestimmte Vorkommen der Mustermerkmale im Bild identifiziert.

Diese Werkzeuge sind beispielsweise in Anwendungen nützlich, in denen Sie anhand eines Logos, eines Etiketts oder eines Teils sicherstellen möchten, dass das richtige Produkt an der Produktionslinie ausgeführt wird, oder in denen erkannt werden soll, welches Produkt ausgeführt wird, um diese Informationen an andere Geräte im Produktionsbereich weiterzugeben.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten der Identifizierungswerkzeuge "PatMax RedLine-Muster (1-10)" und "PatMax-Muster (1-10)"

Wählen Sie nach dem Hinzufügen des Werkzeugs die Bereichstypen aus und konfigurieren Sie sie, um das Muster zu definieren (den Modellbereich) und den Bereich im Bild festzulegen, an der das Muster gefunden wird (den Suchbereich).

Die Identifizierungswerkzeuge PatMax RedLine-Muster (1-10) und PatMax-Muster (1-10) ermöglichen die Erstellung einer Bibliothek von bis zu 10 verschiedenen Modellmustern.Das Werkzeug durchsucht das Bild nach einzelnen Vorkommen der eingelernten Muster. Mehrere Vorkommen eines Musters im Bild werden nicht erkannt.

  1. Wählen Sie im Dropdown-Menü Modell den Bereichstypaus: Rechteck (Standard), Kreis, Annulus oder Polygon. Platzieren Sie den Modellbereich über dem Muster, das als Trainingsmodell dient. Stellen Sie sicher, dass der Modellbereich nur die wichtigen Merkmale des Musters abdeckt.Hinweis:Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.

  2. Wählen Sie im Dropdownmenü Suchen den Bereichstyp "Rechteck" (Standard), "Kreis", "Annulus" oder "Polygon". Platzieren Sie anschließend den Suchbereich so, dass er die Bereiche im Bild abdeckt, in denen das Muster Ihrer Meinung nach erscheint. Erstellen Sie kleinere Suchbereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Suchbereich ist, desto länger dauert die Inspektion mit dem Werkzeug.

  3. Klicken Sie auf OK, um die Bereiche zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen. Der Modellbereich wird durch einen grünen Umriss des eingelernten Musters ersetzt.

  4. Um ein weiteres Modellmuster zu definieren, laden Sie ein neues Bild mit einem neuen Muster (oder nehmen Sie ein neues Bild auf), wählen Sie in der Tabelle ein nicht eingelerntes Muster aus (in der Spalte Trainiert mit Nicht trainiert gekennzeichnet), und klicken Sie auf die Schaltfläche Modellbereich. Wiederholen Sie dann die Schritte 1 bis 3.
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

Auswählen eines Mustermerkmals

PatMax RedLine-Muster, PatMax-Muster und Muster


PatMax RedLine-Muster und PatMax-Muster und Muster

Hinweis: Das Identifizierungswerkzeug PatMax RedLine-Muster ist nur auf In-Sight Vision-Systemen mit In-Sight-Firmware 5.2.0 und höher verfügbar. Eine komplette Modelliste mit unterstützten Firmwareversionen finden Sie im Abschnitt Firmwareversionen.

Die Werkzeuge PatMax RedLine-Muster, PatMax-Muster und Muster suchen nach eingelernten Modellmustern und bieten die höchste Genauigkeit im Vergleich zu anderen Inspektionswerkzeugen. Die Werkzeuge PatMax RedLine-Muster und PatMax-Muster sind jedoch leistungsstärker als das Werkzeug Muster. Sie können stärkere Änderungen der Lichtverhältnisse und der Musterposition berücksichtigen . Zudem bieten sie eine genauere Erkennung von Änderungen im Hinblick auf die Musterskalierung, Musterdrehung, Verdeckung von Musterelementen sowie Änderungen der Musterdarstellung in Abhängigkeit von Lichtverhältnissen.

Der Hauptunterschied zwischen PatMax RedLine-Muster und PatMax-Muster liegt in der Geschwindigkeit. PatMax RedLine-Muster verwendet den neuesten Muster-Übereinstimmungsalgorithmus und kann in einem 5-Megapixel Bild eingelernte Merkmale bis zu 7x schneller als PatMax-Muster finden. Deshalb ist PatMax RedLine-Muster die ideale Wahl für Vision-Systeme mit hoher Auflösung.

Das Werkzeug Muster ist in den meisten Fällen schneller als PatMax. Jedoch spielen in folgenden Situationen die Genauigkeit und Zuverlässigkeit der PatMax RedLine- und PatMax-Version eine wesentliche Rolle:

  • Änderungen von Lichtverhältnissen und Reflektionen sind schwer zu kontrollieren. Beispielsweise können Metallteile Licht in zufälligen Richtungen reflektieren.
  • Das zu inspizierende Muster ist ähnlich geformt oder schattiert wie ein Hintergrundelement oder das Muster überschneidet sich mit Bildobjekten bzw. wird teilweise von diesen verdeckt.
  • Sie möchten einen Mustertyp von anderen, ähnlichen Mustern genau differenzieren.
  • Die Bedingungen der Bereitstellungsumgebung sind zu komplex für das Werkzeug Muster, um gleichmäßige und zuverlässige Ergebnisse zu erzielen.


Anpassen der Parameter der Identifizierungswerkzeuge "PatMax RedLine-Muster (1-10)" und "PatMax-Muster (1-10)"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster für die Identifizierungswerkzeuge PatMax RedLine-Muster (1-10) und PatMax-Muster (1-10) beinhaltet folgende Registerkarten:

  • Registerkarte Allgemein
  • Registerkarte Einstellungen
  • Registerkarten Modell und Suchen
  • Registerkarte Tabelle
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarten „Modell“ und „Suchen“

Registerkarte „Tabelle“


Identifizierungswerkzeuge PatMax RedLine-Muster (1-10) und PatMax-Muster (1-10) - Registerkarte Allgemein

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „ProductID_1“, sofern es sich um das erste Identifizierungswerkzeug „PatMax-Muster“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „ProductID_2“, „ProductID_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Identifizierungswerkzeuge „PatMax RedLine-Muster (1-10)“ und „PatMax-Muster (1-10)“ – Registerkarte „Einstellungen“

Geschlossen Modus

Legt den Betriebsmodus des Werkzeugs fest: Identifizieren oder Überprüfen.

Identifizieren (der Standardmodus) wird verwendet, wenn das inspizierte Muster unbekannt ist. Das Werkzeug untersucht das Bild automatisch (basierend auf den festgelegten Bereichen) und stellt fest, welches Muster aus der Bibliothek eingelernter Muster angezeigt wird. Diese Information wird dann im Parameter „Ergebnis“ gemeldet.

Überprüfen wird verwendet, um festzustellen, ob das korrekte Muster vorhanden ist. Das Werkzeug überprüft, ob das Bild ein festgelegtes Muster enthält, und vergleicht das gefundene Muster mit dem im Parameter Muster angegebenen Muster.

Geschlossen Muster

Legt fest, welches eingelernte Muster überprüft wird (um diese Einstellung zu aktivieren, muss der Modus auf Überprüfen gestellt werden). Wählen Sie eines der eingelernten Muster aus.

Geschlossen Akzeptanzschwellenwert

Gibt den Übereinstimmungsgrad an, der zwischen dem Muster Modell und dem gefundenen Muster vorhanden sein muss (0 – 100; Standard = 65). Liegen die Werte der gefundenen Muster über der Einstellung bzw. entsprechen sie dieser, liegt eine Übereinstimmung vor. Dieses Werkzeug lässt sich mit einer höheren Einstellung schneller ausführen. Dies erfordert ebenfalls einen höheren Übereinstimmungsgrad zwischen dem Modell und dem gefundenen Muster. Niedrigere Einstellungen beinhalten eine höhere Wahrscheinlichkeit für ungenauere Ergebnisse, beispielsweise die Erkennung von Mustern, die dem Muster Modell ähneln, diesem jedoch nicht entsprechen.

Geschlossen Kontrastschwellenwert

Definiert den geringsten akzeptablen Kontrastwert, den das gefundene Muster aufweisen muss. Der Kontrast des gefundenen Musters muss höher als der Wert für den Kontrastschwellenwert sein, um als gültige Instanz zu gelten. Der Standardwert liegt bei PatMax RedLine-Muster bei 0 und der gültige Parameterbereich liegt zwischen 0-100. Der Standardwert liegt bei PatMax-Muster bei 10 und der gültige Parameterbereich liegt zwischen 0-255. Ein niedriger Kontrastschwellenwert wird für Bilder mit einem niedrigen Kontrast verwendet, während ein hoher Kontrastschwellenwert für Bilder mit hohem Kontrast verwendet wird.

Hinweis: PatMax RedLine-Muster kontrastiert das "relative" Maß von Kontrast zwischen Merkmalen im eingelernten Muster im trainierten Bild prozentuell mit den Übereinstimmungsmerkmalen im Suchbild. Wenn ein Merkmal einen ähnlich hohen Kontrast wie der Kontrast des Musters aufweist, wird der berichtete Kontrastwert deswegen ungefähr bei 100 liegen. Wenn ein Merkmal einen geringeren Kontrast hat, als der Kontrast des Musters, wird der berichtete Kontrastwert kleiner als 100 sein. Kontrast bei PatMax RedLine-Muster ist anders interpretiert als Kontrast bei PatMax-Muster, wo er den "absoluten" Bildkontrast des Suchbereiches in Graustufen ausdrückt.
Geschlossen Winkeltoleranz

Gibt an, wie weit das gefundene Muster von der Position des Musters „Modell“ gedreht und dennoch als gültiges Muster erkannt werden kann (± 0 – 180°; Standard =15°). Bei einem größeren Bereich für die Rotationsabweichung des Musters verlängert sich die Ausführung des Werkzeugs.

Geschlossen Skalierungstoleranz

Gibt den zulässigen Prozentsatz der Skalierung (Größenunterschiede) zwischen dem gefundenen Muster und dem Muster Modell an (0 - 50; Standard = 0). Der Wert entspricht einem positiven oder negativen Prozentsatz. Beispielsweise lassen sich mit dem Werkzeug bei einem Wert von "5" Muster finden, die zu 95 % bis 105 % der Größe des Musters Modell entsprechen. Bei einem größeren Bereich für die Skalierungsabweichung des Musters verlängert sich die Ausführung des Werkzeugs.

Geschlossen Differenz annehmen

Legt die zulässige Gütedifferenz zwischen dem gefundenen Muster und einem der eingelernten Modellmuster fest (0-20; Standard = 0). Der Wert ist die Gütedifferenz zwischen zwei beliebigen eingelernten Modellmustern. Ein Wert von 5 gewährleistet z. B., dass das Werkzeug Muster findet, deren Güte mindestens um 5 höher ist als die anderer Modellmuster.

Geschlossen Suchmodus

Gibt den zum Einlernen und Erkennen von Mustern verwendeten Suchmodus an: PatMax oder PatQuick. In der Standardeinstellung ist PatMax ausgewählt. PatMax bietet eine höhere Genauigkeit als PatQuick, erfordert für die Ausführung aber mehr Zeit. PatQuick ist weniger genau als PatMax, die Ausführungsdauer ist dafür jedoch kürzer.

Geschlossen Genaue Bewertung

Gibt an, ob fehlende oder verdeckte Merkmale des gefundenen Musters die Güte beeinflussen (Standard = „Aus“, nicht aktiviert). Bei Verwendung der genauen Bewertung („An“, aktiviert) verringert sich die Güte des gefundenen Musters, falls Mustermerkmale fehlen oder blockiert werden.

Geschlossen Zeitlimit
Definiert den Zeitraum in Millisekunden (0 bis 30000), in dem das Werkzeug nach Mustern sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird. Dieser Parameter ist standardmäßig auf 1.000 gestellt.
Geschlossen Ergebnis

Zeigt den Namen des identifizierten Musters an.

Hinweis: PatMax RedLine-Muster beinhaltet keinen Parameter Suchmodus.


Identifizierungswerkzeuge "PatMax RedLine-Muster (1-10)" und "PatMax-Muster (1-10)" - Registerkarten "Modell" und "Suchen"

Die Registerkarten Modell und Suchen werden zum Konfigurieren des zusammengesetzten Bereichs für den Modell- und Suchbereich des Werkzeugs verwendet. Zusammengesetzter Bereiche sind Ansammlungen von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon), die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • In der Registerkarte Modell sind zusammengesetzte Bereiche nur aktiviert, nachdem die Schaltfläche Modellbereich einmal angeklickt wurde.
  • Es können einem Zusammengesetzten Bereich maximal 32 Unterbereiche hinzugefügt werden können.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


Identifizierungswerkzeuge "PatMax RedLine-Muster (1-10)" und "PatMax-Muster (1-10)" - Registerkarte "Tabelle"

Die Registerkarte "Tabelle" enthält die Tabelle der eingelernten Muster sowie Miniaturansichten der eingelernten Muster.

Geschlossen Registerkarte "Tabelle"

Name: Dieses Feld enthält den Namen des eingelernten Musters. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Trainiert: Dieses Feld gibt an, ob ein Muster eingelernt wurde. Das Feld enthält für eingelernte Muster den Hinweis "Trainiert" und für nicht eingelernte Muster den Hinweis "Nicht trainiert".

Güte: Dieses Feld gibt die Güte des gefundenen eingelernten Musters an.

Hinweis:
  • Zum Löschen eines Muster vom Werkzeug klicken Sie mit der rechten Maustaste auf die Registerkarte Tabelle und wählen aus dem Menü die Option Löschen aus.
  • Im Einstellungsfenster Tabelle sind drei Optionen für die Ansicht verfügbar: Große Symbole , Details (Standard) und Kachel. Zum Auswählen einer anderen Anzeigeoption für das Einstellungsfenster klicken Sie mit der rechten Maustaste auf eine beliebige Position innerhalb der Tabelle, und wählen Sie die gewünschte Option aus dem Untermenü „Ansicht“ aus.
Geschlossen Schaltfläche "Modellbereich"

Diese Schaltfläche initiiert das Einlernen von Mustern.

Geschlossen Schaltfläche "Umbenennen"

Wählen Sie in der Tabelle ein eingelerntes Muster aus, und klicken Sie dann auf diese Schaltfläche, um das Muster in einen geeigneten Namen für Ihre spezielle Anwendung umzubenennen.

Geschlossen Miniaturansicht Trainiertes Bild

Das unter der Schaltfläche Modellbereich angezeigte Bild ist eine Miniaturansicht des Modellmusters. Klicken Sie auf die Schaltfläche Modellbereich, um die Größe des Modellbereichs zu ändern oder diesen zu verschieben. Klicken Sie anschließend auf die Schaltfläche Einlernen, um das Muster Modell erneut einzulernen.


Identifizierungswerkzeuge – Muster

Das Identifizierungswerkzeug "Muster" dient zum Einlernen von Mustermerkmalen und ermöglicht anschließend das Überprüfen oder Identifizieren der im Bild vorhandenen Mustermerkmale.

Dieses Werkzeug eignet sich z. B. für Anwendungen, in denen Sie basierend auf einem Logo, Etikett oder Teil sicherstellen möchten, dass das richtige Produkt in der Fertigungsstraße ist, oder in denen Sie das Produkt in der Fertigungsstraße erkennen und diese Information an andere Geräte im Produktionsbereich übermitteln möchten.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Identifizierungswerkzeugs "Muster"

Wählen Sie nach dem Hinzufügen des Werkzeugs die Bereiche im Bild aus, mit denen das Muster definiert (der Modellbereich) und die Position im Bild festgelegt werden, an der das Muster gefunden wird (der Suchbereich).

Das Identifizierungswerkzeug „Muster (1-10)“ ermöglicht Ihnen, eine Bibliothek mit bis zu 10 unterschiedlichen Modellmustern zu erstellen. Das Werkzeug durchsucht das Bild nach einzelnen Vorkommen der eingelernten Muster. Mehrere Vorkommen eines Musters im Bild werden nicht erkannt.

  1. Platzieren Sie den Modellbereich über dem ersten Muster, das als erstes Trainingsmodell dient. Stellen Sie sicher, dass der Modellbereich nur die wichtigen Merkmale des Musters abdeckt.

  2. Platzieren Sie den Suchbereich so, dass er die Bereiche im Bild abdeckt, in denen die Muster Ihrer Meinung nach erscheinen. Erstellen Sie kleinere Suchbereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Suchbereich ist, desto länger dauert die Inspektion mit dem Werkzeug.

    Hinweis: Die Bereiche Modell und Suchen können nicht in Bogen- oder Ringform gebogen werden.
  3. Klicken Sie auf OK, um die Bereiche zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen. Der Modellbereich wird durch einen grünen Umriss des eingelernten Musters ersetzt.
  4. Um ein weiteres Modellmuster zu definieren, laden Sie ein neues Bild mit einem neuen Muster (oder nehmen Sie ein neues Bild auf), wählen Sie in der Tabelle ein nicht eingelerntes Muster aus (in der Spalte Trainiert mit Nicht trainiert gekennzeichnet), und klicken Sie auf die Schaltfläche Modellbereich. Wiederholen Sie dann die Schritte 1 bis 3.
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Identifizierungswerkzeugs „Muster (1-10)“

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Identifizierungswerkzeugs „Muster (1-10)“ enthält vier Registerkarten:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
  • Registerkarte „Tabelle“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Tabelle“


Identifizierungswerkzeug „Muster“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „PatternID_1“, sofern es sich um das erste Identifizierungswerkzeug „Muster“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „PatternID_2“, „PatternID_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Identifizierungswerkzeug "Muster" – Registerkarte "Einstellungen"

Geschlossen Mode

Legt den Betriebsmodus des Werkzeugs fest: Identifizieren oder Überprüfen.

Identifizieren (der Standardmodus) wird verwendet, wenn das inspizierte Muster unbekannt ist. Das Werkzeug untersucht das Bild automatisch (basierend auf den festgelegten Bereichen) und stellt fest, welches Muster aus der Bibliothek eingelernter Muster angezeigt wird. Diese Information wird dann unter "Ergebnis" gemeldet.

Überprüfen wird verwendet, um festzustellen, ob das korrekte Muster vorhanden ist. Das Werkzeug überprüft, ob das Bild ein festgelegtes Muster enthält, und vergleicht das gefundene Muster mit dem in Muster angegebenen Muster.

Geschlossen Muster

Legt fest, welches eingelernte Muster überprüft wird (um diese Einstellung zu aktivieren, muss der Modus auf Überprüfen eingestellt werden). Wählen Sie eines der eingelernten Muster aus.

Geschlossen Akzeptanzschwellenwert

Gibt den Übereinstimmungsgrad an, der zwischen dem Muster Modell und dem gefundenen Muster vorhanden sein muss (0 - 100; Standard = 50). Liegen die Werte der gefundenen Muster über der Einstellung bzw. entsprechen sie dieser, liegt eine Übereinstimmung vor. Dieses Werkzeug lässt sich mit einer höheren Einstellung schneller ausführen. Dies erfordert ebenfalls einen höheren Übereinstimmungsgrad zwischen dem Modell und dem gefundenen Muster. Niedrigere Einstellungen beinhalten eine höhere Wahrscheinlichkeit für ungenauere Ergebnisse, beispielsweise die Erkennung von Mustern, die dem Muster Modell ähneln, diesem jedoch nicht entsprechen.

Geschlossen Winkeltoleranz

Gibt an, wie weit das gefundene Muster von der Position des Musters "Modell" entfernt sein und dennoch als gültiges Muster erkannt werden kann (± 0 - 180°; Standard = 15°). Bei einem größeren Bereich für die Rotationsabweichung des Musters verlängert sich die Ausführung des Werkzeugs.

Geschlossen Skalierungstoleranz

Definiert die Toleranz des Werkzeugs gegenüber Änderungen der Musterskalierung innerhalb ±10 % der Größe des eingelernten Musters. Diese Einstellung ist standardmäßig deaktiviert. Dadurch sind keine Skalierungsanpassungen möglich. In diesem Betriebsmodus erkennt das Werkzeug nach wie vor Muster in einem Bereich von ±10 %. Die Güte des Merkmals verringert sich jedoch, während sich der Skalierungsprozentsatz erhöht.

Geschlossen Differenz annehmen

Legt die zulässige Gütedifferenz zwischen dem gefundenen Muster und einem der eingelernten Modellmuster fest (1-20; Standard = 0). Der Wert ist die Gütedifferenz zwischen zwei beliebigen eingelernten Modellmustern. Ein Wert von 5 gewährleistet z. B., dass das Werkzeug Muster findet, deren Güte mindestens um 5 höher ist als die anderer Modellmuster.

Geschlossen Modelltyp

Definiert die Art und Weise, auf die vom Werkzeug das Muster Modell erstellt wird: Flächenmodell oder Kantenmodell (Standard). Die Option Flächenmodell erstellt das Muster Modell auf Grundlage einheitlichen Samplings der Graustufenwerte im Bereich Modell. Die Option Kantenmodell erstellt das Muster Modell auf Grundlage der ermittelten Kanten (Hell/dunkel-Übergänge) des Mustermerkmals im Modellbereich.

Geschlossen Genauigkeit

Definiert, wie das Werkzeug den Kompromiss zwischen Genauigkeit/Zuverlässigkeit und Ausführungsgeschwindigkeit bewertet: Genau, Mittel (Standard) und Schnell. Mit Genau erreichen Sie eine höhere Genauigkeit/Zuverlässigkeit und eine niedrigere Ausführungsgeschwindigkeit, mit Schnell erreichen Sie eine niedrigere Genauigkeit/Zuverlässigkeit und eine höhere Ausführungsgeschwindigkeit, und mit Mittel erhalten Sie eine mittlere Genauigkeit/Zuverlässigkeit und eine mittlere Ausführungsgeschwindigkeit.

Geschlossen Zeitüberschreitung

Definiert den Zeitraum in Millisekunden (0 bis 30 000), in dem das Werkzeug nach Mustern sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird.

Geschlossen Ergebnis

Zeigt den Namen des identifizierten Musters an.


Identifizierungswerkzeug „Muster (1-10)“ – Registerkarte „Tabelle“

Die Registerkarte Tabelle enthält die Tabelle der eingelernten Muster sowie Miniaturansichten der eingelernten Muster.

Geschlossen Registerkarte "Tabelle"

Name: Dieses Feld enthält den Namen des eingelernten Musters. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Trainiert: Dieses Feld gibt an, ob ein Muster eingelernt wurde. Das Feld enthält für eingelernte Muster den Hinweis "Trainiert" und für nicht eingelernte Muster den Hinweis "Nicht trainiert".

Güte: Dieses Feld gibt die Güte des gefundenen eingelernten Musters an.

Hinweis:
  • Zum Löschen eines Muster vom Werkzeug klicken Sie mit der rechten Maustaste auf die Registerkarte Tabelle und wählen aus dem Menü die Option Löschen aus.
  • Im Einstellungsfenster Tabelle sind drei Optionen für die Ansicht verfügbar: Große Symbole , Details (Standard) und Kachel. Zum Auswählen einer anderen Anzeigeoption für das Einstellungsfenster klicken Sie mit der rechten Maustaste auf eine beliebige Position innerhalb der Tabelle, und wählen Sie die gewünschte Option aus dem Untermenü „Ansicht“ aus.
Geschlossen Schaltfläche "Modellbereich"

Diese Schaltfläche initiiert das Einlernen von Mustern (Training).

Geschlossen Schaltfläche "Umbenennen"

Wählen Sie in der Tabelle ein eingelerntes Muster aus, und klicken Sie dann auf diese Schaltfläche, um das Muster in einen geeigneten Namen für Ihre spezielle Anwendung umzubenennen.

Geschlossen Miniaturansicht "Trainiertes Bild"

Das unter der Schaltfläche Modellbereich angezeigte Bild ist eine Miniaturansicht des Modellmusters. Klicken Sie auf die Schaltfläche Modellbereich, um die Größe des Modellbereichs zu ändern oder diesen zu verschieben. Klicken Sie anschließend auf die Schaltfläche Einlernen, um das Muster Modell erneut einzulernen.


Identifizierungswerkzeuge – Farbmodell

Mit dem Identifizierungswerkzeug "Farbmodell" kann in einer Bibliothek von Farbmodellen bestimmt werden, welches Farbmodell für die Farben des Bildes am geeignetsten ist. Der Name des geeigneten Farbmodells wird anschließend vom Werkzeug ausgegeben.

Das Werkzeug Farbmodell verweist auf eine eingelernte Bibliothek von Farbmodellen und ermittelt anschließend die im Bereich vorhandene Anzahl von Pixeln, die mit dem ausgewählten und eingelernten Farbmodell in der Bibliothek übereinstimmen. Abhängig vom Modus des Vorgangs – Identifizieren (Standardeinstellung) oder Übereinstimmung – gibt das Werkzeug den Namen des Farbmodells zurück, das die höchste Übereinstimmung mit den Inspektionskriterien aufweist. Außerdem wird vom Werkzeug ein binäres Graustufenausgabebild erstellt, indem jedes Pixel, das mit einem aktiven Farbmodell übereinstimmt, auf Weiß (255) festgelegt wird. Alle anderen Pixel werden auf Schwarz (0) festgelegt.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Identifizierungswerkzeugs "Farbmodell"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereichstyp festlegen und im Bild konfigurieren:

  1. Wählen Sie im Dropdown-Menü Modell den Bereichstypaus: Rechteck (Standard), Kreis, Annulus oder Polygon. Positionieren und Konfigurieren Sie den Bereich im Bild, in dem die Farben voraussichtlich erscheinen werden. Die Grenzen des Bereichs müssen die Farben und ihre möglichen Positionen einschließen. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich die Farben in jedem Bild nahezu an derselben Position befinden oder der Bereich groß genug ist für die erwartete Bewegung der Farben.

    Hinweis: Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Nach der Konfiguration des Suchbereichs müssen die Farbbibliothek des Werkzeugs konfiguriert und die entsprechenden Farbmodelle aktiviert werden:

    • Wurde das erste Mal ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“) hinzugefügt, müssen zunächst die Farbbibliotheken und die Farbmodelle definiert werden.

    • Wurde zuvor ein weiteres Farbwerkzeug hinzugefügt und sollen eine vorhandene Farbbibliothek und ihre eingelernten Farbmodelle verwendet werden, wählen Sie auf der Registerkarte "Einstellungen" die gewünschte Farbbibliothek und aktivieren Sie anschließend mithilfe der Kontrollkästchen auf der Registerkarte "Bibliothek" die gewünschten Farbmodelle.

    • Wurde keine Farbbibliothek definiert, gibt das Werkzeug automatisch eine Fehlermeldung aus. Wurde eine Farbbibliothek definiert, wird sie automatisch vom Werkzeug verwendet und alle darin enthaltenen Farbmodelle werden aktiviert.

  4. Nachdem die Farbmodelle und die Farbbibliotheken festgelegt wurden, wird das Bild vom Werkzeug verarbeitet und alle Pixel innerhalb des Suchbereichs, die mit dem ausgewählten Farbmodell übereinstimmen, werden in die unbunte Farbe Weiß (255) umgewandelt. Die Pixel, die nicht mit dem ausgewählten Farbmodell übereinstimmen, erhalten die unbunte Farbe Schwarz (0).
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Identifizierungswerkzeugs "Farbmodell"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Identifizierungswerkzeugs "Farbmodell" enthält folgende Objekte:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Tabelle"
  • Registerkarte "Farbbibliothek"
  • Registerkarte "Zusammengesetzter Bereich"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Farbbibliothek

Registerkarte „Tabelle“

Registerkarte „Zusammengesetzter Bereich“


Identifizierungswerkzeug „Farbmodell“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „ColorModelIdentification_1“, sofern es sich um das erste Identifizierungswerkzeug „Farbmodell“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „ColorModelIdentification_2“, „ColorModelIdentification_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Identifizierungswerkzeug „Farbmodell“ – Registerkarte „Einstellungen“

Geschlossen Farbe einlernen

Öffnet das Dialogfeld „ExtractColor – Einlernen“, das zur Definition der ausgewählten Farbmodelle der Farbbibliothek verwendet wird.

Geschlossen Farbbibliothek

Definiert die Farbbibliothek, auf die vom Tool verwiesen wird. Wählen Sie in der Dropdownliste die Farbbibliothek aus, die geändert werden soll, und klicken Sie auf die Schaltfläche Farbe einlernen, um das Dialogfeld „ExtractColor – Einlernen“ zu öffnen. Jede Farbbibliothek kann bis zu 100 unterschiedliche Farbmodelle enthalten, die aus individuellen Farben zusammengesetzt sind.

EasyBuilder-Jobs können maximal 5 Farbbibliotheken enthalten, die unter folgenden Werkzeugen aufgeteilt werden können:

  • Positionswerkzeug „Farb-Blob“
  • Positionswerkzeug „Farb-Blobs (1-10)“
  • An-/Abwesenheitswerkzeug „Farbpixelanzahl“
  • Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“
  • Messungswerkzeug „Farb-Blob-Bereich (1-10)“
  • Zählwerkzeug „Farb-Blobs“
  • Identifizierungswerkzeug „Farbmodell“
  • Filterwerkzeug für Bilder „Farbe zu binär“
Geschlossen Modus

Definiert den Betriebsmodus des Werkzeugs: Identifizieren (Standard) oder Übereinstimmung.

  • Identifizieren: Wird verwendet, wenn die Farben des Bilds nicht bekannt sind. Das Werkzeug bestimmt, welches Farbmodell die höchste Übereinstimmung mit den Farben des Bilds erzielt. Sind mehrere aktive Farbmodelle in der ausgewählten Farbbibliothek vorhanden, werden die Ergebnisse ihren Pixelanzahlen entsprechend sortiert und bewertet.
  • Übereinstimmung: Mit diesem Modus wird geprüft, ob das Bild das erwartete Farbmodell aufweist. Das Werkzeug verarbeitet das Bild und ermittelt, ob die Farben des Bilds mit den erwarteten Farben des angegebenen Farbmodells im Parameter Übereinstimmung der Farbe übereinstimmen.
Geschlossen Übereinstimmung der Farbe

Definiert das voraussichtlich zu ermittelnde Farbmodell. Das Feld wird nur aktiviert, wenn der Parameter Modus auf Übereinstimmung festgelegt wird. Geben Sie den Namen des Farbmodells ein, das das Feld voraussichtlich aufweist.

Geschlossen Pixelmindestanzahl

Definiert die Schwelle für die Pixelmindestanzahl (0 bis 9 999 999, standardmäßig 1 000), mit der ermittelt wird, ob ein Farbmodell übereinstimmt. Wird beispielsweise im Modus Identifizieren die Schwelle auf 1 000 festgelegt, werden alle Farbmodelle automatisch ausgeschlossen, deren Pixelanzahl weniger als 1 000 beträgt. Im Modus Übereinstimmung gibt das Werkzeug in diesem Fall eine Fehlermeldung aus, wenn weniger als 1 000 Pixel mit dem erwarteten Farbmodell übereinstimmen.

Geschlossen Ergebnis

Zeigt den Namen des gefundenen Farbmodells an.


Identifizierungswerkzeug „Farbmodell“ – Farbbibliothek

Geschlossen Liste Farbmodell

Zeigt eine schreibgeschützte Liste der Farbmodelle in der ausgewählten Übereinstimmungsfarbbibliothek an. Die Farbmodelle werden mittels der Kontrollkästchen neben dem Namen der Farbmodelle aktiviert oder deaktiviert.

Geschlossen Farbtabelle

Zeigt eine schreibgeschützte sortierte Liste der Farben der ausgewählten Farbbibliothek an.

Geschlossen Farbname

Zeigt die Namen der Farben im ausgewählten Farbmodell an.

Geschlossen RGB

Zeigt die RGB-Werte der Farben im ausgewählten Farbmodell an.

Geschlossen Funktion

Zeigt die Funktion der Farben (Hinzufügen oder Subtrahieren) im ausgewählten Farbmodell an.


Identifizierungswerkzeug „Farbmodell“ – Registerkarte „Tabelle“

Die Registerkarte Tabelle zeigt eine schreibgeschützte Liste der gefundenen Farbmodelle an (sortiert nach Bewertung und Güte der 10 besten Übereinstimmungen).

Geschlossen Rang

Zeigt eine numerische Bewertung der Farbmodelle an, die die höchste Übereinstimmung mit den Inspektionskriterien aufweisen (von 1 bis 10).

Geschlossen Name

Zeigt die Namen der gefundenen Farbmodelle an.

Geschlossen Pixelanzahl

Zeigt die Pixelanzahl der gefundenen Farbmodelle an.


Identifizierungswerkzeug "Farbmodell" – Registerkarte "Zusammengesetzter Bereich"

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.

Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


Geometriewerkzeuge – Punkt zum Punkt: Leitung

Das Geometriewerkzeug „Punkt zum Punkt: Linie“ konstruiert eine Referenzgerade zwischen zwei beliebigen Eingangsmerkmalen (Punkte, die Ursprünge von Vorrichtungen oder der Mittelpunkt von Kreismerkmalen) und gibt die X,Y-Koordinaten der beiden Endpunkte der konstruierten Strecke zurück.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Geometriewerkzeugs "Punkt zum Punkt: Linie"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Eingangsmerkmale (Punkte, Ursprünge von Vorrichtungen oder Mittelpunkt von kreisförmigen Merkmalen) definieren, die zum Konstruieren der Referenzlinie verwendet werden:

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie zunächst eines der verfügbaren Merkmale per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta, und eine Linie in Verlängerung des Merkmals wird angezeigt.
  3. Wählen Sie anschließend das zweite Merkmal aus.
  4. Nach der Auswahl des zweiten Merkmals konstruiert EasyBuilder automatisch eine Linie zwischen den Merkmalen. EasyBuilder fügt zudem ein An-/Abwesenheitswerkzeug „Kante“ und/oder ein An-/Abwesenheitswerkzeug „Kreis“ für alle Merkmale hinzu, die zuvor nicht definiert wurden (abhängig vom Merkmalstyp).
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Geometriewerkzeugs "Punkt-zu-Punkt-Linie"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Geometriewerkzeugs "Punkt-zu-Punkt-Linie" umfasst Folgendes:

Geschlossen Registerkarte "Allgemein"
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge, Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet "Linie_1", sofern es sich um das erste Werkzeug handelt, das dem Job hinzugefügt und zum Definieren einer Linie verwendet wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Linie_2", "Linie_3" usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.


Geometriewerkzeuge – Punkt zum Punkt: Mittelpunkt

Das Geometriewerkzeug „Punkt zum Punkt: Mittelpunkt“ berechnet den Mittelpunkt zwischen zwei Eingangsmerkmalen (Punkte, die Ursprünge von Vorrichtungen oder der Mittelpunkt von Kreismerkmalen), konstruiert eine Referenzgerade zwischen den beiden Merkmalen und gibt den Winkel des Mittelpunktes im Verhältnis zur Vorrichtung und die X,Y-Koordinaten des Mittelpunkts zurück.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Geometriewerkzeugs "Punkt zum Punkt: Mittelpunkt"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Eingangsmerkmale (Punkte, Ursprünge von Vorrichtungen oder Mittelpunkt von kreisförmigen Merkmalen) definieren, die zum Konstruieren der Referenzlinie verwendet werden:

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.

  2. Wählen Sie zunächst eines der verfügbaren Merkmale per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta, und eine Linie in Verlängerung des Merkmals wird angezeigt.

  3. Wählen Sie anschließend das zweite Merkmal aus.

  4. Nach der Auswahl des zweiten Merkmals konstruiert EasyBuilder automatisch eine Linie zwischen den Merkmalen und platziert das Symbol [image] an der Position des Mittelpunkts. EasyBuilder fügt zudem ein An-/Abwesenheitswerkzeug „Kante“ und/oder ein An-/Abwesenheitswerkzeug „Kreis“ für alle Merkmale hinzu, die zuvor nicht definiert wurden (abhängig vom Merkmalstyp).
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Geometriewerkzeugs "Punkt-zu-Punkt-Mittelpunkt"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Geometriewerkzeugs "Punkt-zu-Punkt-Mittelpunkt" umfasst Folgendes:

Geschlossen Registerkarte "Allgemein"
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge, Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet "Punkt_1", sofern es sich um das erste Werkzeug handelt, das dem Job hinzugefügt wird und zum Definieren eines Punktes verwendet wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Punkt_2", "Punkt_3" usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Geschlossen Registerkarte "Einstellungen"
Geschlossen Mittelpunkt

Gibt die X/Y-Koordinaten des Mittelpunkts zwischen den beiden Eingangsmerkmalen sowie die Winkelausrichtung des Mittelpunkts relativ zur Vorrichtung an.

Hinweis: Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.


Geometriewerkzeuge – Punkt zum Punkt: Abmessung

Das Geometriewerkzeug „Punkt zum Punkt: Abmessung“ berechnet den Abstand zwischen den Mittelpunkten von zwei Eingangsmerkmalen (Punkte, Ursprünge von Vorrichtungen oder der Mittelpunkt von Kreismerkmalen) in Bezug auf eine Kante oder Linie und konstruiert eine Referenzgerade zur Darstellung des berechneten Abstands. Zudem wird der berechnete Abstand zurückgegeben.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Das Geometriewerkzeug „Punkt zum Punkt: Abmessung“ ist in Situationen nützlich, in denen die Genauigkeit der Ausrichtung einer Baugruppe gemessen werden muss.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Geometriewerkzeugs "Punkt zum Punkt: Dimension"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Eingangsmerkmale (Punkte, Ursprünge von Vorrichtungen oder Mittelpunkt von kreisförmigen Merkmalen) definieren, die zum Konstruieren der Referenzlinie verwendet werden:

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie zunächst eines der verfügbaren Merkmale per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta, und eine Linie in Verlängerung des Merkmals wird angezeigt.
  3. Wählen Sie anschließend das zweite Merkmal aus.
  4. Nach Auswahl des zweiten Merkmals untersucht EasyBuilder automatisch das Bild und stellt eine Auswahl der Smart Features für Kanten und Linien bereit, die als Referenzlinie für die Messung verwendet werden können. Wählen Sie ein Kanten- oder Linienmerkmal als Referenz aus.
  5. EasyBuilder projiziert dann Referenzlinien von den Mittelpunkten der Merkmale, die senkrecht zur Referenzkante oder -linie verlaufen, und der Abstand wird basierend auf der Beziehung zwischen den senkrecht projizierten Referenzlinien und der ausgewählten Referenzkante oder -linie berechnet. EasyBuilder fügt zudem ein An-/Abwesenheitswerkzeug „Kante“ und/oder ein An-/Abwesenheitswerkzeug „Kreis“ für alle Merkmale hinzu, die zuvor nicht definiert wurden (abhängig vom Merkmalstyp).
  6. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  7. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Geometriewerkzeugs "Punkt-zu-Punkt-Dimension"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Geometriewerkzeugs "Punkt-zu-Punkt-Dimension" umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Bereichsbeschränkungen"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Grenzwerte“


Punkt-zu-Punkt-Dimension – Registerkarte "Allgemein"

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge, Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet "Dimension_1", sofern es sich um das erste Geometriewerkzeug "Punkt-zu-Punkt-Dimension" handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Dimension_2", "Dimension_3" usw.). Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Geometriewerkzeug "Punkt-zu-Punkt-Dimension" – Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert den maximal zulässigen Abstandswert. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limit-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Abstand

Gibt den aktuellen gemessenen Abstand zwischen den senkrecht projizierten Referenzlinien der Mittelpunkte der beiden Merkmale relativ zur Referenzkante oder -linie an. Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Hinweis: Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
Geschlossen Minimum

Definiert den minimal zulässigen Abstandswert. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limit-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Geometriewerkzeuge – Senkrechte Linie

Das Geometriewerkzeug „Senkrechte Linie“ konstruiert eine Referenzgerade, die senkrecht zu einer anderen Gerade oder einem Kantenmerkmal steht, und gibt die X,Y-Koordinaten der Endpunkte der konstruierten Referenzstrecke zurück.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Geometriewerkzeugs "Senkrechte Linie"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie definieren, welche senkrechte Linie eines Linien- oder Kantenmerkmals Sie finden möchten:

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie per Mausklick unter den verfügbaren Merkmalen das gewünschte Linien- oder Kantenmerkmal aus. EasyBuilder ermittelt dann automatisch den Schnittpunkt, an dem sich die senkrechte Linie und das ausgewählte Linien- oder Kantenmerkmal überschneiden, und fügt zur Definition des Schnittpunkts eine Referenzlinie ein. Zudem fügt EasyBuilder ein An-/Abwesenheitswerkzeug "Kante" für Kantenmerkmale hinzu, die zuvor nicht definiert wurden.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter für das Geometriewerkzeug "Senkrechte Linie"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Geometriewerkzeugs "Senkrechte Linie" umfasst Folgendes:

Geschlossen Registerkarte "Allgemein"
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge, Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet "Linie_1", sofern es sich um das erste Werkzeug handelt, das dem Job hinzugefügt und zum Definieren einer Linie verwendet wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Linie_2", "Linie_3" usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.


Geometriewerkzeuge – Linie-Schnittpunkt

Das Geometriewerkzeug „Linie-Schnittpunkt“ wird verwendet, um den Punkt zu identifizieren, an dem sich zwei Kantenmerkmale oder Referenzgeraden schneiden; es gibt die X,Y-Koordinaten des Schnittpunkts zurück.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Geometriewerkzeugs "Linie-Schnittpunkt"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Kantenmerkmale und/oder die Linien definieren, die sich überschneiden:

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie zunächst eines der verfügbaren Merkmale per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta, und eine Linie in Verlängerung des Merkmals wird angezeigt.
  3. Wählen Sie als Nächstes das Kantenmerkmal oder die Linie aus, die sich überschneidet.
  4. Nach Auswahl des zweiten Merkmals ermittelt EasyBuilder automatisch den Schnittpunkt der Linien, und fügt einen Punkt zum Definieren der Überschneidung ein. EasyBuilder fügt zudem ein An-/Abwesenheitswerkzeug „Kante“ und/oder ein An-/Abwesenheitswerkzeug „Kreis“ für alle Merkmale hinzu, die zuvor nicht definiert wurden (abhängig vom Merkmalstyp).
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter für das Geometriewerkzeug "Linie-Schnittpunkt"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Geometriewerkzeugs "Linie-Schnittpunkt" umfasst Folgendes:

Geschlossen Registerkarte "Allgemein"
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge, Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet "Schnittpunkt_1", sofern es sich um das erste Geometriewerkzeug "Kreis-Linie-Schnittpunkt" oder "Linie-Schnittpunkt" handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Schnittpunkt_2", "Schnittpunkt_3" usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.


Geometriewerkzeuge – Winkel halbieren

Mit dem Geometriewerkzeug „Winkel halbieren“ wird eine Referenzgerade konstruiert, die den Halbierungswinkel zwischen zwei Kantenmerkmalen oder Geraden angibt und den Halbierungswinkel sowie die X,Y-Koordinaten der Endpunkte der konstruierten Strecke zurückgibt.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Das Geometriewerkzeug „Winkel halbieren“ ist in Situationen nützlich, in denen Sie den Halbierungswinkel zwischen Merkmalen des Teils identifizieren und den Halbierungswinkel als Referenzpunkt z. B. für weitere Messungen verwenden möchten.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Geometriewerkzeugs "Winkel halbieren"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Kantenmerkmale oder Linien definieren, die zum Konstruieren der Halbierungsreferenzlinie verwendet werden:

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie zuerst die Merkmale per Mausklick aus den verfügbaren Merkmalen aus. Die Farbe des Merkmals ändert sich dadurch in Magenta.
  3. Wählen Sie als Nächstes die zweite Kante oder Linie zum Definieren des zu halbierenden Bereichs per Mausklick aus.
  4. EasyBuilder konstruiert dann automatisch eine Referenzlinie aus den ausgewählten Kantenmerkmalen oder Linien. EasyBuilder fügt zudem ein An-/Abwesenheitswerkzeug „Kante“ und/oder ein An-/Abwesenheitswerkzeug „Kreis“ für alle Merkmale hinzu, die zuvor nicht definiert wurden (abhängig vom Merkmalstyp).
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter für das Geometriewerkzeug "Winkel halbieren"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Geometriewerkzeugs "Winkel halbieren" umfasst Folgendes:

Geschlossen Registerkarte "Allgemein"
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge, Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet "Halbieren_1", sofern es sich um das erste Geometriewerkzeug "Winkel halbieren" handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Halbieren_2", "Halbieren_3" usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.


Geometriewerkzeuge – Linie aus N Punkten

Das Geometriewerkzeug „Linie aus N Punkten“ konstruiert eine Referenzgerade, die zwischen 2 bis 10 Eingangsmerkmale passt (Punkte, die Ursprünge von Vorrichtungen oder der Mittelpunkt von Kreismerkmalen), und gibt die X,Y-Koordinaten der Endpunkte der konstruierten Strecke zurück.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Das Geometriewerkzeug „Linie aus N Punkten“ ist in Situationen nützlich, in denen Sie eine Referenzgerade aus mehreren vorhandenen Merkmalen im Bild erstellen möchten.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Geometriewerkzeugs "Linie aus N Punkten"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Eingangsmerkmale (Punkte, Ursprünge von Vorrichtungen oder Mittelpunkt von kreisförmigen Merkmalen) definieren, die zum Konstruieren der Referenzlinie verwendet werden:

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie zuerst die Merkmale per Mausklick aus den verfügbaren Merkmalen aus. Die Farbe des Merkmals ändert sich dadurch in Magenta.
  3. Wählen Sie als Nächstes die restlichen Merkmale aus, die zum Definieren der Linie verwendet werden. Wählen Sie mindestens zwei bzw. maximal zehn Eingangsmerkmale aus.
  4. Klicken Sie nach Auswahl der gewünschten Merkmale auf die Schaltfläche OK (klicken Sie auf die Schaltfläche Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen).
  5. EasyBuilder konstruiert dann automatisch eine Referenzlinie aus den ausgewählten Eingangsmerkmalen. EasyBuilder fügt zudem ein An-/Abwesenheitswerkzeug „Kante“ und/oder ein An-/Abwesenheitswerkzeug „Kreis“ für alle Merkmale hinzu, die zuvor nicht definiert wurden (abhängig vom Merkmalstyp).
  6. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  7. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter für das Geometriewerkzeug "Linie aus N Punkten"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Geometriewerkzeugs "Linie aus N Punkten" umfasst Folgendes:

Geschlossen Registerkarte "Allgemein"
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge, Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet "Linie_1", sofern es sich um das erste Werkzeug handelt, das dem Job hinzugefügt und zum Definieren einer Linie verwendet wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Linie_2", "Linie_3" usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.


Geometriewerkzeuge – Kreis aus N Punkten

Das Geometriewerkzeug „Kreis aus N Punkten“ konstruiert einen Referenzkreis aus 3 bis 10 Eingangsmerkmalen (Punkte, die Ursprünge von Vorrichtungen oder der Mittelpunkt von Kreismerkmalen) und gibt den Durchmesser des konstruierten Kreises zurück.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Das Geometriewerkzeug „Kreis aus N Punkten“ ist in Situationen nützlich, in denen Sie einen Referenzkreis aus vorhandenen Merkmalen im Bild erstellen möchten.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Geometriewerkzeugs "Kreis aus N Punkten"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Eingangsmerkmale (Punkte, Ursprünge von Vorrichtungen oder Mittelpunkt von kreisförmigen Merkmalen) definieren, die zum Konstruieren des Referenzkreises verwendet werden:

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie zuerst die Merkmale per Mausklick aus den verfügbaren Merkmalen aus. Die Farbe des Merkmals ändert sich dadurch in Magenta.
  3. Wählen Sie als Nächstes die restlichen Merkmale aus, die zum Definieren des Kreises verwendet werden. Wählen Sie mindestens drei und maximal zehn Eingangsmerkmale aus.
  4. Klicken Sie nach Auswahl der gewünschten Merkmale auf die Schaltfläche OK (klicken Sie auf die Schaltfläche Abbrechen, wenn das Werkzeug dem Job nicht hinzugefügt werden soll).
  5. EasyBuilder konstruiert dann automatisch einen Referenzkreis aus den ausgewählten Eingangsmerkmalen. EasyBuilder fügt zudem ein An-/Abwesenheitswerkzeug „Kante“ und/oder ein An-/Abwesenheitswerkzeug „Kreis“ für alle Merkmale hinzu, die zuvor nicht definiert wurden (abhängig vom Merkmalstyp).
  6. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  7. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter für das Geometriewerkzeug "Kreis aus N Punkten"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Geometriewerkzeugs "Kreis aus N Punkten" umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Bereichsbeschränkungen"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Grenzwerte“


Geometriewerkzeug "Kreis aus N Punkten" – Registerkarte "Allgemein"

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge, Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet "Kreis_1", sofern es sich um das erste Werkzeug handelt, das dem Job hinzugefügt wird und zum Definieren eines Kreises verwendet wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Kreis_2", "Kreis_3" usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Geometriewerkzeug "Kreis aus N Punkten" – Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert den maximal zulässigen Durchmesserwert. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limit-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Durchmesser

Zeigt den aktuell gemessenen Durchmesser des konstruierten Kreises an. Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Hinweis: Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
Geschlossen Minimum

Definiert den minimal zulässigen Durchmesserwert. Das Werkzeug erstellt basierend auf dem Bild eine Smart Limit-Standardeinstellung, die Sie entsprechend den Anforderungen Ihrer Anwendung anpassen können.

Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.


Geometriewerkzeuge – Kreis-Linie-Schnittpunkt

Das Geometriewerkzeug „Kreis-Linie-Schnittpunkt“ wird verwendet, um die Punkte auf einem Kreis zu identifizieren, in denen eine Linie den Kreis schneidet, und gibt die X,Y-Koordinaten der Schnittpunkte des Kreises mit der Linie zurück.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Das Geometriewerkzeug „Kreis-Linie-Schnittpunkt“ ist in Situationen nützlich, in denen Sie beispielsweise die korrekte Ausrichtung zwischen einem Kreismerkmal und einem Kantenmerkmal prüfen möchten.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Geometriewerkzeugs "Kreis-Linie-Schnittpunkt"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie das Kreis- und Kantenmerkmal oder die Linie definieren, die den Kreis kreuzt:

  1. EasyBuilder untersucht nach dem Hinzufügen des Werkzeugs das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit.
  2. Wählen Sie zunächst eines der verfügbaren kreisförmigen Merkmale per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta, und eine Linie in Verlängerung des Merkmals wird angezeigt.
  3. Wählen Sie als Nächstes das Kantenmerkmal oder die Linie aus, die den Kreis kreuzt.
  4. Nach Auswahl des zweiten Merkmals ermittelt EasyBuilder automatisch die Schnittpunkte, an denen die Linie den Kreis kreuzt, und fügt zwei Punkte zum Definieren der Überschneidung ein. EasyBuilder fügt zudem ein An-/Abwesenheitswerkzeug „Kante“ und/oder ein An-/Abwesenheitswerkzeug „Kreis“ für alle Merkmale hinzu, die zuvor nicht definiert wurden (abhängig vom Merkmalstyp).
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter für das Geometriewerkzeug "Kreis-Linie-Schnittpunkt"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Geometriewerkzeugs "Kreis-Linie-Schnittpunkt" umfasst Folgendes:

Geschlossen Registerkarte "Allgemein"
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge, Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet "Schneiden_1", sofern es sich um das erste Geometriewerkzeug Kreis-Linie-Schnittpunkt oder Linie-Schnittpunkt handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Schneiden_2", "Schneiden_3" usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Geschlossen Registerkarte "Einstellungen"
Geschlossen Ergebnis umkehren

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.


Geometriewerkzeuge – Benutzerdefinierter Punkt

Mit dem Geometriewerkzeug „Benutzerdefinierter Punkt“ können Sie die Position eines Referenzpunkts an beliebiger Stelle im Bild auftragen. Es gibt die X,Y-Koordinaten des Punkts zurück.

Das Geometriewerkzeug „Benutzerdefinierter Punkt“ ist in Situationen nützlich, in denen Sie die Messung basierend auf einem Referenzpunkt bestimmen möchten, der kein Merkmal des geprüften Teils oder Objekts ist.

Hinweis:
  • Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).
  • Die Spitze des Werkzeugs kann als Vorrichtung für andere Werkzeuge verwendet werden. Die Spitze bietet jedoch keinerlei Winkelinformationen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Geometriewerkzeugs "Benutzerdefinierter Punkt"

  1. Nachdem das Werkzeug hinzugefügt wurde, erscheint eine magentafarbene Fadenkreuzgrafik auf dem Bild.
  2. Platzieren Sie die Fadenkreuzgrafik an der gewünschten Position im Bild, und klicken Sie auf OK, um diese Position zu bestätigen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.

  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

    Hinweis: Die Spitze des Werkzeugs kann als Vorrichtung für andere Werkzeuge verwendet werden. Die Spitze bietet jedoch keinerlei Winkelinformationen.


Anpassen der Parameter für das Geometriewerkzeug "Benutzerdefinierter Punkt"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Geometriewerkzeugs "Benutzerdefinierter Punkt" umfasst Folgendes:

Geschlossen Registerkarte "Allgemein"
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge, Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet "Punkt_1", sofern es sich um das erste Werkzeug handelt, das dem Job hinzugefügt wird und zum Definieren eines Punktes verwendet wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Punkt_2", "Punkt_3" usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.


Geometriewerkzeuge – Benutzerdefinierte Linie

Mit dem Geometriewerkzeug „Benutzerdefinierte Linie“ können Sie die Position einer Referenzgerade an beliebiger Stelle im Bild auftragen. Es gibt die X,Y-Koordinaten der Endpunkte der Strecke zurück.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Das Geometriewerkzeug „Benutzerdefinierte Linie“ ist in Situationen nützlich, in denen Sie die Messung basierend auf einer Referenzgerade bestimmen möchten, die kein Merkmal des geprüften Teils oder Objekts ist.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Geometriewerkzeugs "Benutzerdefinierte Linie"

  1. Nachdem das Werkzeug hinzugefügt wurde, erscheint eine magentafarbene Linie auf dem Bild.
  2. Platzieren Sie die Linie an der gewünschten Position im Bild, und klicken Sie auf OK, um diese Position zu bestätigen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter für das Geometriewerkzeug "Benutzerdefinierte Linie"

Nach dem Festlegen und Bestätigen der Werkzeugeingänge können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Geometriewerkzeugs "Benutzerdefinierte Linie" umfasst Folgendes:

Geschlossen Registerkarte "Allgemein"
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge, Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet "Linie_1", sofern es sich um das erste Werkzeug handelt, das dem Job hinzugefügt und zum Definieren einer Linie verwendet wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Linie_2", "Linie_3" usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Registerkarte "Einstellungen"
Geschlossen Linie

Gibt die X/Y-Koordinaten der Endpunkte der konstruierten Strecke an.

Hinweis: Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.


Geometriewerkzeuge – An Kreis anpassen

Das Geometriewerkzeug "An Kreis anpassen" konstruiert auf Grundlage der ermittelten Kanten einen eingepassten Kreis. Das Werkzeug verwendet Kantenanalyse-Caliperarrays, um die exakte Position der Kantenmerkmale zu ermitteln. Sobald die Kante ermittelt wurde, erzeugt das Werkzeug einen eingepassten Kreis über dem Kantenmerkmal. Das Werkzeug zeigt dann den Radius des eingepassten Kreises und seinen Mittelpunkt an.

Hinweis:
  • Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
  • Alle Eingabewerte werden in Pixeln angegeben, auch wenn das Werkzeug in reellen Einheiten kalibriert wurde.

Das Geometriewerkzeug "An Kreis anpassen" ist hilfreich, wenn Sie sicherstellen möchten, dass Ihr Teil oder Objekt die gleiche Form aufweist. Dieses Werkzeug kann den eingepassten Kreis genauer, wenn auch langsamer erzeugen als beispielsweise das Geometriewerkzeug "Kreis aus N Punkten".

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Geometriewerkzeugs "An Kreis anpassen"

Wählen Sie nach dem Hinzufügen des Werkzeugs den maskierten Bereich im Bild über dem Kantenmerkmal aus, das Sie inspizieren möchten:

  1. Positionieren und konfigurieren Sie den ringförmigen Bereich im Bild über dem Kantenmerkmal. Sie können sowohl den Außen- als auch den Innenradius des Rings anpassen, um die Erkennung der korrekten Kanten sicherzustellen. Stellen Sie beim Positionieren und Konfigurieren des Bereichs sicher, dass die Kanten parallel zur Suchrichtung des Bereichs verlaufen und der Bereich so viel wie möglich vom Kantenmerkmal umschließt, wobei unnötiges oder unerwünschtes Rauschen aus dem Bereich ausgeschlossen wird.

    Hinweis: Die gestrichelte gelbe Linie im Maskierten Bereich legt eine Fläche innerhalb des Bereichs fest, in der Kantenübergänge ermittelt werden.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Wählen Sie nach der Bestätigung des Bereichs die verschiedenen Registerkarten Kanten, Kantengüte und Passform, und passen Sie die Parameter und den Bereich nach Bedarf an, um sicherzustellen, dass das Werkzeug die korrekten Kantenkandidaten ermittelt und die korrekte eingepasste Linie oder den eingepassten Kreis erzeugt.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um die erwarteten Bereiche und Abweichungen auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen des Geometriewerkzeugs "An Kreis anpassen"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Messungswerkzeugs "An Kreis anpassen" umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Kanten"
  • Registerkarte "Kantengüte"
  • Registerkarte "Anpassen"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Passform“

Registerkarte „Kanten“

Registerkarte „Kantengüte“


Geometriewerkzeug „An Kreis anpassen“ – Registerkarte „Kanten“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „CircleFit_1“, sofern es sich um das erste Geometriewerkzeug „An Kreis anpassen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „CircleFit_2“, „CircleFit_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Geometriewerkzeug "An Kreis anpassen" – Registerkarte "Passform"

Bei Auswahl der Registerkarte Passform zeigt das Werkzeug alle gefundenen Kantenkandidaten innerhalb des Bereichs und des eingepassten Kreises an. Die Kantenkandidaten sind die möglichen Kanten, die beim Erzeugen des eingepassten Kreises berücksichtigt werden. Sie werden durch kleine, farbcodierte Kreise angezeigt.

Geschlossen Ausreißer filtern

Legt fest, ob das Werkzeug Punkte aus der eingepassten Linie entfernt, deren Abstand größer ist als durch den Parameter "Abstandfilter anpassen" definiert (standardmäßig ist dieser Parameter aktiviert).

Geschlossen Abstandfilter anpassen

Definiert den Abstand (1 bis 1920; Standard = 2) in Pixeln einer Kante von der ursprünglichen eingepassten Linie, der zur Berechnung der erneuten Anpassung verwendet wird. Mithilfe dieses Parameters wird vermieden, dass Fehler die Linienanpassung beeinträchtigen.

Hinweis: Der Parameter "Ausreißer filtern" muss aktiviert sein, um diesen Parameter zu verwenden.
Geschlossen Höchster Punktfilterabstand

Definiert den Ausreißerabstand (1 bis 1920; Standard = 1000), bei dessen Überschreitung Kanten nicht zur Bestimmung der Mindest- und Höchstabstände verwendet werden. Alle Kanten, die diesen Wert überschreiten, werden ignoriert.

Geschlossen Erneut auswerten

Definiert, ob die ermittelten Kanten erneut ausgewertet werden, um sicherzustellen, dass ermittelte Kanten, die ursprünglich gelöscht wurden, korrekt gefiltert wurden (standardmäßig ist dieser Parameter aktiviert).

Geschlossen Erneut anpassen

Legt fest, ob das Werkzeug die eingepasste Linie nach der erneuten Auswertung der Kanten erneut anpasst (dieser Parameter ist standardmäßig aktiviert).

Hinweis: Die Genauigkeit des Werkzeugs ist höher, wenn dieser Parameter aktiviert ist. Die Verarbeitungszeit erhöht sich jedoch.
Geschlossen Ergebnis

Zeigt die eingepasste Linie im Bild und zeigt dann den Radius des eingepassten Kreises und seinen Mittelpunkt an.


Geometriewerkzeug "An Kreis anpassen" – Registerkarte "Kanten"

Bei Auswahl der Registerkarte Kanten zeigt das Werkzeug alle ermittelten Kanten im Bereich grün hervorgehoben an. Sie können die Parameter Caliper-Größe, Caliper-Abstand, Kantenbreite und Mindestkontrast nach Bedarf anpassen, um die gewünschten Kanten zu isolieren.

Sie können auch alle Caliper anzeigen, indem Sie den Parameter Alle Caliper anzeigen aktivieren.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Caliper-Größe

Definiert die pro Caliper zu analysierende Pixelanzahl in Inspektionsrichtung (1 bis 639; Standard = 5).

Geschlossen Caliper-Abstand

Definiert den Abstand in Pixel zwischen dem Ende eines Caliper und dem Anfang des nächsten Caliper (-1 bis 639; Standard = 0).

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 10; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Minimaler Kontrast

Definiert den minimalen Graustufen-Kontrastübergang (1 bis 255; Standard = 10), der als Kante gewertet wird.

Geschlossen Caliper-Anzahl

Zeigt die Gesamtanzahl der Caliper im Bereich an.

Geschlossen Caliper-Index

Legt die einzelnen Caliper fest, die isoliert und angezeigt werden.

Geschlossen Alle Caliper anzeigen

Definiert, ob alle Caliper in dem Bereich immer angezeigt werden. Standardmäßig sind die Caliper ausgeblendet.


Geometriewerkzeug "An Kreis anpassen" – Registerkarte "Kantengüte"

Bei Auswahl der Registerkarte Kantengüte zeigt das Werkzeug mithilfe kleiner, farbcodierter Kreise alle gefundenen Kantenkandidaten im Bereich (der ausgewählt oder angepasst werden kann) und die eingepasste Linie oder den eingepassten Kreis an. Die Kantenkandidaten stellten die möglichen Kanten dar, die beim Erzeugen der eingepassten Linie oder des eingepassten Kreises berücksichtigt werden. Passen Sie die Parameter an, um die gewünschten Kantenkandidaten zu isolieren.

Alle erkannten Fehler und Zwischenräume werden ebenfalls angezeigt.

Geschlossen Kantenrichtung suchen

Definiert die Richtung, in der das Werkzeug relativ zum Bereich Kanten ermittelt (Links nach rechts oder Rechts nach links; Standard = Links nach rechts).

Geschlossen Kantenübergang

Gibt den Übergang der Kante an (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Regel:Erste Kante

Definiert, ob die erste ermittelte Kante bei der Entscheidung, ob ein Kantenkandidat als Kante gewertet wird, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Regel:Stärkste Kante

Definiert, ob die Kante mit dem stärksten Kontrastübergang bei der Entscheidung, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Schwellenwert für Güte

Definiert einen Schwellenwert für die Güte, um Kanten mit einer Güte (0 bis 255; Standard = 10) unterhalb dieses Werts herauszufiltern.


Geometriewerkzeuge – An Linie anpassen

Das Geometriewerkzeug "An Linie anpassen" konstruiert auf Grundlage der ermittelten Kanten eine eingepasste Linie. Das Werkzeug verwendet Kantenanalyse-Caliperarrays, um die exakte Position der Kantenmerkmale zu ermitteln. Sobald die Kante ermittelt wurde, erzeugt das Werkzeug eine eingepasste Linie über dem Kantenmerkmal. Das Werkzeug zeigt dann die X/Y-Koordinaten der Start- und Endpunkte des Liniensegments an.

Hinweis:
  • Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
  • Alle Eingabewerte werden in Pixeln angegeben, auch wenn das Werkzeug in reellen Einheiten kalibriert wurde.

Das Geometriewerkzeug "An Linie anpassen" ist hilfreich, wenn Sie sicherstellen möchten, dass Ihr Teil oder Objekt die gleiche Form aufweist. Dieses Werkzeug kann die eingepasste Linie genauer, wenn auch langsamer, erzeugen als beispielsweise das Geometriewerkzeug "Kreis aus N Punkten".

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Geometriewerkzeugs "An Linie anpassen"

Wählen Sie nach dem Hinzufügen des Werkzeugs den maskierten Bereich im Bild über dem Kantenmerkmal aus, das Sie inspizieren möchten:

  1. Positionieren und konfigurieren Sie den Bereich innerhalb des Bildes über dem Kantenmerkmal. Stellen Sie beim Platzieren des Bereichs sicher, dass die Kanten parallel zur Suchrichtung des Bereichs verlaufen und der Bereich so viel wie möglich vom Kantenmerkmal umschließt, wobei unnötiges oder unerwünschtes Rauschen aus dem Bereich ausgeschlossen wird.

    Hinweis: Die gestrichelte gelbe Linie im Maskierten Bereich legt eine Fläche innerhalb des Bereichs fest, in der Kantenübergänge ermittelt werden.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Wählen Sie nach der Bestätigung des Bereichs die verschiedenen Registerkarten Kanten, Kantengüte und Passform, und passen Sie die Parameter und den Bereich nach Bedarf an, um sicherzustellen, dass das Werkzeug die korrekten Kantenkandidaten ermittelt und die korrekte eingepasste Linie oder den eingepassten Kreis erzeugt.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um die erwarteten Bereiche und Abweichungen auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen des Geometriewerkzeugs "An Linie anpassen"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Messungswerkzeugs "An Linie anpassen" umfasst Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Kanten"
  • Registerkarte "Kantengüte"
  • Registerkarte "Anpassen"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Passform“

Registerkarte „Kanten“

Registerkarte „Kantengüte“


Geometriewerkzeug „An Linie anpassen“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „LineFit_1“, sofern es sich um das erste Geometriewerkzeug „An Linie anpassen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „LinieFit_2“, „LineFit_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Geometriewerkzeug "An Linie anpassen" – Registerkarte "Passform"

Bei Auswahl der Registerkarte Passform zeigt das Werkzeug alle gefundenen Kantenkandidaten innerhalb des Bereichs und der eingepassten Linie oder des Kreises an. Die Kantenkandidaten sind die möglichen Kanten, die beim Erzeugen der eingepassten Linie berücksichtigt werden. Sie werden durch kleine, farbcodierte Kreise angezeigt.

Geschlossen Ausreißer filtern

Legt fest, ob das Werkzeug Punkte aus der eingepassten Linie entfernt, deren Abstand größer ist als durch den Parameter "Abstandfilter anpassen" definiert (standardmäßig ist dieser Parameter aktiviert).

Geschlossen Abstandfilter anpassen

Definiert den Abstand (1 bis 1920; Standard = 2) in Pixeln einer Kante von der ursprünglichen eingepassten Linie, der zur Berechnung der erneuten Anpassung verwendet wird. Mithilfe dieses Parameters wird vermieden, dass Fehler die Linienanpassung beeinträchtigen.

Hinweis: Der Parameter "Ausreißer filtern" muss aktiviert sein, um diesen Parameter zu verwenden.
Geschlossen Höchster Punktfilterabstand

Definiert den Ausreißerabstand (1 bis 1920; Standard = 1000), bei dessen Überschreitung Kanten nicht zur Bestimmung der Mindest- und Höchstabstände verwendet werden. Alle Kanten, die diesen Wert überschreiten, werden ignoriert.

Geschlossen Erneut auswerten

Definiert, ob die ermittelten Kanten erneut ausgewertet werden, um sicherzustellen, dass ermittelte Kanten, die ursprünglich gelöscht wurden, korrekt gefiltert wurden (standardmäßig ist dieser Parameter aktiviert).

Geschlossen Erneut anpassen

Legt fest, ob das Werkzeug die eingepasste Linie nach der erneuten Auswertung der Kanten erneut anpasst (dieser Parameter ist standardmäßig aktiviert).

Hinweis: Die Genauigkeit des Werkzeugs ist höher, wenn dieser Parameter aktiviert ist. Die Verarbeitungszeit erhöht sich jedoch.
Geschlossen Ergebnis

Zeigt die eingepasste Linie im Bild und die Position der X/Y-Koordinaten der Start- und Endpunkte des Liniensegments an.


Geometriewerkzeug "An Linie anpassen" – Registerkarte "Kanten"

Bei Auswahl der Registerkarte Kanten zeigt das Werkzeug alle ermittelten Kanten im Bereich grün hervorgehoben an. Sie können die Parameter Caliper-Größe, Caliper-Abstand, Kantenbreite und Mindestkontrast nach Bedarf anpassen, um die gewünschten Kanten zu isolieren.

Sie können auch alle Caliper anzeigen, indem Sie den Parameter Alle Caliper anzeigen aktivieren.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Caliper-Größe

Definiert die pro Caliper zu analysierende Pixelanzahl in Inspektionsrichtung (1 bis 639; Standard = 5).

Geschlossen Caliper-Abstand

Definiert den Abstand in Pixel zwischen dem Ende eines Caliper und dem Anfang des nächsten Caliper (-1 bis 639; Standard = 0).

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 10; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Minimaler Kontrast

Definiert den minimalen Graustufen-Kontrastübergang (1 bis 255; Standard = 10), der als Kante gewertet wird.

Geschlossen Caliper-Anzahl

Zeigt die Gesamtanzahl der Caliper im Bereich an.

Geschlossen Caliper-Index

Legt die einzelnen Caliper fest, die isoliert und angezeigt werden.

Geschlossen Alle Caliper anzeigen

Definiert, ob alle Caliper in dem Bereich immer angezeigt werden. Standardmäßig sind die Caliper ausgeblendet.


Geometriewerkzeug "An Linie anpassen" – Registerkarte "Kantengüte"

Bei Auswahl der Registerkarte Kantengüte zeigt das Werkzeug mithilfe kleiner, farbcodierter Kreise alle gefundenen Kantenkandidaten im Bereich (der ausgewählt oder angepasst werden kann) und die eingepasste Linie oder den eingepassten Kreis an. Die Kantenkandidaten stellten die möglichen Kanten dar, die beim Erzeugen der eingepassten Linie oder des eingepassten Kreises berücksichtigt werden. Passen Sie die Parameter an, um die gewünschten Kantenkandidaten zu isolieren.

Alle erkannten Fehler und Zwischenräume werden ebenfalls angezeigt.

Geschlossen Kantenrichtung suchen

Definiert die Richtung, in der das Werkzeug relativ zum Bereich Kanten ermittelt (Links nach rechts oder Rechts nach links; Standard = Links nach rechts).

Geschlossen Kantenübergang

Gibt den Übergang der Kante an (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Regel:Erste Kante

Definiert, ob die erste ermittelte Kante bei der Entscheidung, ob ein Kantenkandidat als Kante gewertet wird, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Regel:Stärkste Kante

Definiert, ob die Kante mit dem stärksten Kontrastübergang bei der Entscheidung, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Schwellenwert für Güte

Definiert einen Schwellenwert für die Güte, um Kanten mit einer Güte (0 bis 255; Standard = 10) unterhalb dieses Werts herauszufiltern.


Mathematik- und Logikwerkzeuge – Mathe

Mit dem Mathematik- und Logikwerkzeug „Mathe” können Sie eine mathematische Formel zur Verarbeitung von Werkzeug- und Jobdaten erstellen. Hierfür stehen mathematische Standardoperatoren sowie Logik-, Statistik- und Trigonometriefunktionen zur Verfügung.

Das Mathematik- und Logikwerkzeug „Mathe” eignet sich beispielsweise für Situationen, in denen Sie die Defektanzahl zweier Werkzeuge zusammenrechnen oder den Durchschnitt von Messungswerkzeugen zurückgeben möchten.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Mathematik- und Logikwerkzeugs "Mathe"

Hinweis: Das Werkzeug erfordert andere Positionswerkzeuge und/oder Inspektionswerkzeuge als Eingabe. Stellen Sie vor dem Hinzufügen des Werkzeugs die notwendigen Positions- und/oder Inspektionswerkzeuge für die Eingabe zusammen. Andernfalls können die Ausdrücke nicht erstellt werden, und Sie müssen zu diesem Schritt zurückkehren.

Nach dem Hinzufügen des Werkzeugs müssen Sie Ihren Ausdruck erstellen.

  1. Erstellen Sie Ihren Ausdruck, indem Sie mathematische Funktionen im linken Bereich des Einstellungsfensters und Werte (Werkzeug- und Jobdaten) im rechten Fensterbereich auswählen und dann eingeben. Um eine Funktion oder einen Wert im Formula Editor für Ausdrücke einzugeben, wählen Sie die Funktion oder den Wert aus, und drücken Sie die Eingabetaste, doppelklicken Sie auf die Funktion bzw. den Wert, oder klicken Sie auf die Schaltfläche Einfügen.

  2. Klicken Sie nach dem Erstellen Ihres Ausdrucks auf die Registerkarte Bereichsbeschränkungen, um die Bereichsbeschränkungen des Werkzeugs zu bestimmen. Maximum ist standardmäßig auf 9.999.999 eingestellt und Minimum auf -9.999.999. Passen Sie die Beschränkungen an die Anforderungen Ihrer Anwendung an.

    Hinweis: Wenn das Ergebnis des Ausdrucks eine Textzeichenfolge zurückgibt, werden die Beschränkungen Maximum und Minimum deaktiviert.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Mathematik- und Logikwerkzeugs "Mathe"

Nach dem Hinzufügen des Werkzeugs zu einem Job können Sie es für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Mathematik- und Logikwerkzeugs "Mathe" enthält Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Bereichsbeschränkungen"
  • Ausdruck
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Ausdruck

Registerkarte „Grenzwerte“


Mathematik- und Logikwerkzeug „Mathe“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Math_1“, sofern es sich um das erste Mathematik- und Logikwerkzeug „Mathe“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Math_2“, „Math_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Mathematik- und Logikwerkzeug "Mathe" - Ausdruck

Hinweis: Diese Steuerelemente sind deaktiviert, während das In-Sight Vision-System online ist.
Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen und -daten erstellt. Geben Sie mathematische Funktionen oder Job-/Werkzeugdaten entweder mithilfe des Keyboards ein, oder verwenden Sie die Vision Tools-, Mathematik- und/oder Textansicht bzw. die Vision-Datenzugriffsansicht auf der linken Seite und die Symbol-Baumstruktur für Job- und Werkzeugdaten auf der rechten Seite, um diese Formel zusammenzusetzen. Geben Sie Elemente ein, indem Sie einen Doppelklick darauf durchführen oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis:
  • Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch "Job.MissingArg" ersetzt. Das Werkzeug gibt so lange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
  • Beim Erstellen von Formeln analysiert EasyBuilder Werkzeugnamen, die mit einer Zelladresse beginnen (e.g. A3_MyTool or P10_SortTool), nicht korrekt. Müssen für diese Werkzeuge Ausdrücke erstellt werden, benennen Sie das Werkzeug um, bevor Sie die Formel erstellen.
Tipp:

Verwenden Sie die Funktion Exact um zu ermitteln, ob eine Textzeichenfolge mit einer anderen Zeichenfolge übereinstimmt. Die Funktion If wird für den Vergleich von Werten verwendet. EasyBuilder gibt einen Fehler aus, wenn die Funktion If versucht, Zeichenfolgen zu vergleichen.

Beispiel: Die vom Identifizierungswerkzeug zum Lesen von ID-Codes verwendete Textzeichenfolge soll zur Gewährleistung der Übereinstimmung mit einer Zeichenfolge verglichen werden, die vom Identifizierungswerkzeug „Text lesen“ gelesen wird. Folgende Formel könnte im Ausdruck erstellt werden: Exact(IDCode_1.String,Text_1.Result).

Geschlossen Vision Tool:

Die Struktur Vision Tools enthält zusätzliche Kantenfunktionen zum Erstellen des Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Kante, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Kante, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit mathematischen Funktionen

Die Struktur mit mathematischen Funktionen enthält mathematische Funktionen zum Erstellen Ihres Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Mathematik, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Mathematik, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit Textfunktionen

Die Struktur mit Textfunktionen enthält Funktionen zum Formatieren alphanumerischer Daten für die Anzeige und zur Kommunikation und kann zur Konstruktion des Ausdrucks verwendet werden. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Textstruktur, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Textstruktur, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Datenzugriff

Die Struktur Datenzugriff enthält zusätzliche Daten, die standardmäßig nicht verfügbar sind und zur Konstruktion des Ausdrucks verwendet werden können. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Datenzugriff, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Datenzugriff, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis:
  • Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
  • EasyBuilder unterstützt ausschließlich Datenzugriffsfunktionen für Blobs, Kanten und Muster.
Geschlossen Struktur mit Symbolen für Job- und Werkzeugdaten

Die Struktur mit Symbolen für Job- und Werkzeugdaten enthält die Datenausgabe von Positions- und/oder Inspektionswerkzeugen sowie Eingangsleitungen und Jobdaten, wie Bildaufnahmeparameter. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt drei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
  • Geben Sie den Namen des gewünschten symbolischen Verweises über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche "Einfügen"

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Wählen Sie eine mathematische Funktion oder ein Symbol aus, und klicken Sie anschließend auf die Schaltfläche Einfügen, um die Funktion bzw. das Symbol in den Ausdruck einzufügen.

Hinweis: Dieses Steuerelement wird in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, ist die Schaltfläche Einfügen aktiviert.
Geschlossen Schaltflächen für öffnende und schließende Klammern sowie für Kommas

Die Schaltflächen für öffnende Klammern, Kommas und schließende Klammern werden zum Erstellen mathematischer Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um eine Klammer oder ein Komma einzufügen.

Hinweis: Diese Steuerelemente werden in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, sind die Schaltflächen aktiviert.


Mathematik- und Logikwerkzeug "Mathe" – Registerkarte "Bereichsbeschränkungen"

Geschlossen Maximum

Definiert die zulässige Höchstanzahl für die Formel. Standardmäßig kann das Werkzeug ein Maximum von 9,999,999 zuweisen. Sie müssen diesen Wert an Ihre Anwendung anpassen.

Geschlossen Ergebnis

Zeigt das Ergebnis des Ausdrucks an. Werte, die genau auf die Einstellungen für "Minimum" und "Maximum" oder zwischen diese Einstellungen fallen, werden als "Bestanden" qualifiziert.

Geschlossen Minimum

Definiert die zulässige Mindestanzahl für die Formel. Standardmäßig kann das Werkzeug ein Minimum von -9,999,999 zuweisen. Sie müssen diesen Wert an Ihre Anwendung anpassen.

Geschlossen Invertiert

Legt fest, ob die Bestanden/Fehler-Logik des Werkzeugs umgekehrt werden soll (Standard = deaktiviert):

  • Deaktiviert – Es werden Standardergebnisse verwendet, d. h., das Werkzeugergebnis lautet "Bestanden", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
  • Aktiviert – Die Ergebnisse werden umgekehrt, d. h., das Werkzeugergebnis lautet "Fehler", wenn das Merkmal erkannt wurde und innerhalb der definierten Einstellungen liegt.
Geschlossen Schaltfläche „Automatische Beschränkungen“

Definiert die Grenzwerte anhand der Einstellung unter Smart Limits. Diese Schaltfläche ist nützlich, wenn ein Parameter geändert wurde und die Grenzwerte angepasst werden müssen oder wenn das Werkzeug hinzugefügt wurde, aber keine Grenzwerte festgelegt wurden.

Hinweis: Wenn das Ergebnis des Ausdrucks eine Textzeichenfolge zurückgibt, werden die Bereichsbeschränkungen Maximum und Minimum deaktiviert.


Mathematik- und Logikwerkzeuge – Logik

Das Mathematik- und Logikwerkzeug „Logik“ ermöglicht das Erstellen von Formeln mit boolschen logischen Standardoperatoren zur Bearbeitung der Gut/Nicht bestanden-Ergebnissen

Das Werkzeug gibt die folgenden Ergebnisse zurück:

In-Sight-Modelle | Ergebnisse
Vision-Sensoren der In-Sight 2000-Serie 1xx (110, 120, 130) | Nur bei Bestanden/Nicht bestanden-Status.
In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | Standardergebnisse (keine Einschränkungen)

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Mathematik- und Logikwerkzeugs "Logik"

Hinweis: Das Werkzeug erfordert andere Positionswerkzeuge und/oder Inspektionswerkzeuge als Eingabe. Stellen Sie vor dem Hinzufügen des Werkzeugs die notwendigen Positions- und/oder Inspektionswerkzeuge für die Eingabe zusammen. Andernfalls können die Ausdrücke nicht erstellt werden, und Sie müssen zu diesem Schritt zurückkehren.

Nach dem Hinzufügen des Werkzeugs müssen Sie Ihren Ausdruck erstellen. Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen erstellt.

Vision-Sensoren der In-Sight 2000-Serie

  1. Erstellen Sie Ihren Ausdruck durch Hinzufügen des "Bestanden"- oder "Nicht bestanden"-Ergebnisses des Werkzeugs. Um ein "Bestanden"- oder "Nicht bestanden"-Ergebnis im Formula Editor für Ausdrücke einzugeben, wählen Sie das Ergebnis aus, und drücken Sie die Eingabetaste, doppelklicken Sie auf das Ergebnis oder klicken Sie auf die Schaltfläche Einfügen.
  2. Nachdem Sie Ihren Ausdruck erstellt haben, können Sie die Bestanden-/Nicht bestanden-Logik des Werkzeugs optional invertieren.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder und passen Sie die Parameter des Werkzeugs nach Bedarf an, um diese an Ihre Ergebnisse anzupassen
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

In-Sight Vision-Systeme

  1. Erstellen Sie Ihren Ausdruck durch Hinzufügen des "Bestanden"- oder "Nicht bestanden"-Ergebnisses des Werkzeugs. Um einen "Bestanden"- oder "Nicht bestanden"-Ergebnis im Formula Editor für Ausdrücke einzugeben, wählen Sie das Ergebnis aus, und drücken Sie die Eingabetaste, doppelklicken Sie auf das Ergebnis oder klicken Sie auf die Schaltfläche Einfügen.
  2. Nachdem Sie Ihren Ausdruck erstellt haben, können Sie die Bestanden-/Nicht bestanden-Logik des Werkzeugs optional über die Registerkarte Einstellungen invertieren.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder und passen Sie die Parameter des Werkzeugs nach Bedarf an, um diese an Ihre Ergebnisse anzupassen
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Mathematik- und Logikwerkzeugs "Logik"

Nach dem Hinzufügen des Werkzeugs zu einem Job können Sie es für Ihre Anwendung anpassen und optimieren.

Vision-Sensoren der In-Sight 2000-Serie

  • Gruppenfeld Werkzeug bearbeiten

In-Sight Vision-Systeme

Das Einstellungsfenster des Mathematik- und Logikwerkzeugs "Logik" enthält Folgendes:

  • Registerkarte Allgemein
  • Registerkarte Einstellungen
  • Ausdruck
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Vision-Sensoren der In-Sight 2000-Serie

In-Sight-Vision-Systeme


Anpassen der Parameter des Mathematik- und Logikwerkzeugs "Logik"

Hinweis: Dieses Thema beschreibt die Benutzeroberfläche, wenn man mit einem Vision-Sensor der In-Sight 2000-Serie verbunden ist.Wenn mit In-Sight Vision-Systemen verbunden, finden Sie weitere Informationen im Abschnitt "In-Sight Vision-Systeme" von Anpassen der Parameter des Mathematik- und Logikwerkzeugs "Logik".
Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen erstellt. Verwenden Sie die Symbol-Baumstruktur für Job- und Werkzeugdaten zum Erstellen der Formel. Geben Sie Elemente ein, indem Sie auf sie doppelklicken oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis: Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch „Job.MissingArg“ ersetzt. Das Werkzeug gibt solange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
Geschlossen Struktur mit Symbolen für Job- und Werkzeugdaten

Die Struktur mit Symbolen für Job- und Werkzeugdaten beinhaltet die durch die Positions- und/oder Inspektionswerkzeuge ausgegebene Bestanden- und Nicht bestanden- Ergebnisse des Werkzeugs. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt zwei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
Hinweis: Die Liste der verfügbaren Symbole hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche "Zurücksetzen"

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Heben Sie das gewünschte Symbol hervor und klicken Sie auf die Schaltfläche Einfügen, um das Symbol in den Ausdruck einzufügen.

Geschlossen Schaltflächen "Klammer auf", "Komma", "Klammer zu", AND, OR und NOT

Die Schaltflächen Klammer auf, Komma, Klammer zu, AND, OR und NOT werden zum Erstellen von Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um diese der Formel hinzuzufügen.

Geschlossen Schaltfläche "Löschen"

Mit der Schaltfläche Löschen können Sie hervorgehobene Worte oder Symbole aus dem Ausdruck löschen. Wählen Sie das gewünschte Wort oder Symbol aus und klicken Sie auf die Schaltfläche Löschen.

Geschlossen Ergebnis umkehren

Wenn aktiviert, gibt das Wekzeug eine Falsch zurück, falls das Ergebnis zwischen die Bereichsbeschränkungen fällt. (Standard = Aus)

Job gut/schlecht | Invertieren | Job gut/schlecht
Job gut/schlecht | (Invertieren) | Job gut/schlecht
Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Name

Legt den Namen des Inspektionswerkzeuges fest. Der Standardname ist “Logik_1” (wenn es das erste Mathematik- und Logikwerkzeug Logik ist, das dem Job hinzugefügt wurde, andernfalls wird er Name inkrementiert, z.B. “Logik_2”, “Logik_3”, etc.).

Geschlossen Aktiviert

Definiert, wann und ob das Inspektionswerkzeug ausgeführt werden soll (Standardeinstellung ist „Ein“).

  • Wählen Sie „Aus“, wenn Sie das Werkzeug deaktivieren möchten.
  • Wählen Sie eine Eingangsleitung aus, wenn das Werkzeug an eine bestimmte diskrete Eingangsleitung gebunden sein soll, wo es ein- oder ausgeschaltet werden kann (ein High-Signal, 1, bedeutet „Ein“, ein Low-Signal, 0, bedeutet „Aus“). Durch die Verbindung des Werkzeugs mit einem Eingang kann mithilfe eines Kontrollsystems (z. B. SPS) festgelegt werden, welche Werkzeuge wann ausgeführt werden sollen.
Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Mathematik- und Logikwerkzeug "Logik" – Registerkarte "Allgemein"

Geschlossen Werkzeugname

Legt den Namen des Inspektionswerkzeuges fest. Der Standardname ist “Logik_1” (wenn es das erste Mathematik- und Logikwerkzeug Logik ist, das dem Job hinzugefügt wurde, andernfalls wird er Name inkrementiert, z.B. “Logik_2”, “Logik_3”, etc.). Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Mathematik- und Logikwerkzeug "Logik" - Ausdruck

Hinweis: Diese Steuerelemente sind deaktiviert, während das In-Sight Vision-System online ist.
Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen erstellt. Verwenden Sie die Symbol-Baumstruktur für Job- und Werkzeugdaten zum Erstellen der Formel. Geben Sie Elemente ein, indem Sie auf sie doppelklicken oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis:
  • Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch „Job.MissingArg“ ersetzt. Das Werkzeug gibt solange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
  • Beim Erstellen von Formeln analysiert EasyBuilder Werkzeugnamen, die mit einer Zelladresse beginnen (e.g. A3_MyTool or P10_SortTool), nicht korrekt. Müssen für diese Werkzeuge Ausdrücke erstellt werden, benennen Sie das Werkzeug um, bevor Sie die Formel erstellen.
Geschlossen Symbol-Baumstruktur für Job- und Werkzeugdaten

Die Symbol-Baumstruktur für Job- und Werkzeugdaten beinhaltet die durch die Positions- und/oder Inspektionswerkzeuge ausgegebenen Werkzeugergebnisse. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt drei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
  • Geben Sie den Namen des gewünschten symbolischen Verweises über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Symbole hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche "Einfügen"

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Heben Sie das gewünschte Symbol hervor und klicken Sie auf die Schaltfläche Einfügen, um das Symbol in den Ausdruck einzufügen.

Geschlossen Schaltflächen "Klammer auf", "Komma", "Klammer zu", AND, OR und NOT

Die Schaltflächen Klammer auf, Komma, Klammer zu, AND, OR und NOT werden zum Erstellen von Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um diese der Formel hinzuzufügen.

Geschlossen Schaltfläche "Löschen"

Mit der Schaltfläche Löschen können Sie hervorgehobene Worte oder Symbole aus dem Ausdruck löschen. Wählen Sie das gewünschte Wort oder Symbol aus und klicken Sie auf die Schaltfläche Löschen.


Mathematik- und Logikwerkzeug "Logik" – Registerkarte "Einstellungen"

Geschlossen Ergebnis

Berichtet das Ergebnis des Ausdrucks.

Geschlossen Invertieren

Legt fest, ob das Bestanden"- oder "Nicht bestanden"-Ergebnis vom Werkzeug invertiert werden soll oder nicht:

  • Abgewählt (Standard): Das Bestanden-/Nicht bestanden-Ergebnis wird nicht invertiert.
  • Angekreuzt: Das Bestanden-/Nicht bestanden-Ergebnis wird invertiert.


Mathematik- und Logikwerkzeuge – Trend

Das Mathematik- und Logikwerkzeug „Trend“ gibt Statistiken zu Maximum, Minimum, Mittelwert (Durchschnitt), Stichprobe und Standardabweichung für den Wert eines Positions- oder Inspektionswerkzeugs oder eine Eingangsleitung für eine festgelegte Anzahl von Stichproben an, bevor zurückgesetzt wird.

Das Mathematik- und Logikwerkzeug „Trend“ ist in Situationen nützlich, in denen Sie statistische Informationen zu den Ergebnissen eines bestimmten Werkzeugs über eine Reihe von Jobausführungen hinweg sammeln möchten, um beispielsweise den Fertigungsprozess zu analysieren.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Mathematik- und Logikwerkzeugs "Trend"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie den zu verarbeitenden Wert definieren und die Parameter des Werkzeugs konfigurieren.

  1. Passen Sie die Einstellungen auf der Registerkarte Allgemein an Ihre Anwendung an.
  2. Klicken Sie auf die Registerkarte Einstellungen, um einen Wert zu definieren, für den Statistiken gesammelt werden sollen. Nach dem Hinzufügen des Werkzeugs untersucht EasyBuilder Ihre Anwendung und führt die Werte auf, die im Parameter Letzter Wert referenziert werden können. Wählen Sie einen Wert aus, und konfigurieren Sie anschließend die restlichen Parameter auf der Registerkarte.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Mathematik- und Logikwerkzeugs "Trend"

Nach dem Hinzufügen des Werkzeugs zu einem Job können Sie es für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Mathematik- und Logikwerkzeugs "Trend" enthält Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Tabelle"
  • Registerkarte "Wert"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Wert“

Registerkarte „Tabelle“


Mathematik- und Logikwerkzeug „Trend“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Trend_1“, sofern es sich um das erste Mathematik- und Logikwerkzeug „Trend“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Trend_2“, „Trend_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Mathematik- und Logikwerkzeug „Trend“ – Registerkarte „Einstellungen“

Geschlossen Letzter Wert

Legt fest, welcher Wert vom Werkzeug berechnet wird; in der Standardeinstellung ist „Nicht definiert“ ausgewählt und es werden keine Statistiken erfasst. Wählen Sie einen Wert aus, der von einem Werkzeug oder einer Eingabe in den Job zurückgegeben wird, um Statistiken für diesen Wert zu erfassen.

Geschlossen Max. Testwerte

Legt die maximale Anzahl von Testwerten fest, die bei der Erfassung der Statistiken für ein Werkzeug verwendet werden. In der Standardeinstellung werden 100 Testwerte verwendet. Es können zwischen 2 und 5.000 Testwerten verwendet werden. Sobald das Werkzeug die maximale Anzahl von Testwerten erreicht, werden die ältesten Werte verworfen, wenn neue Werte erfasst werden.

Geschlossen Anzeige

Legt fest, welcher berechnete Wert angezeigt wird: Letzter Wert, Minimum, Maximum, Mittelwert oder Std-Abw. (Standardabweichung). In der Standardeinstellung ist Letzter Wert ausgewählt.

Geschlossen Ergebnis

Zeigt den derzeit berechneten Wert, der im Parameter „Anzeige“ festgelegt ist.

Geschlossen Schaltfläche „Zurücksetzen“

Setzt die Datenerfassung auf „0“ zurück.

Geschlossen Online-Zurücksetzen

Legt fest, ob das Werkzeug die Datenerfassung automatisch jedes Mal zurücksetzt, wenn das In-Sight-Vision-System online geschaltet wird; in der Standardeinstellung ist diese Einstellung deaktiviert (d. h. es muss manuell zurückgesetzt werden).

Geschlossen Job laden zurücksetzen

Legt fest, ob das Werkzeug die Datenerfassung automatisch jedes Mal zurücksetzt, wenn das In-Sight-Vision-System den Job mit dem Werkzeug lädt; in der Standardeinstellung ist diese Einstellung deaktiviert (d. h. es muss manuell zurückgesetzt werden).


Mathematik- und Logikwerkzeug "Trend" - Registerkarte "Wert"

Stellt den Wert in einem Diagrammformat grafisch dar.


Mathematik- und Logikwerkzeug "Trend" - Registerkarte "Tabelle"

Die Tabelle des Mathematik- und Logikwerkzeugs "Trend" zeigt die Ergebnisse an, die für den mit dem Parameter Letzter Wert auf der Registerkarte Einstellungen definierten Wert gesammelt wurden. Dieser Parameter richtet sich nach der Anzahl der Beispiele, die über den Parameter Max. Beispiele festgelegt ist.


Mathematik- und Logikwerkzeuge – Statistik

Das Mathematik- und Logikwerkzeug „Statistik“ gibt Statistiken zu Maximum, Minimum, Mittelwert (Durchschnitt), Stichprobe und Standardabweichung für den Wert eines Positions- oder Inspektionswerkzeugs oder eine Eingangsleitung an.

Das Mathematik- und Logikwerkzeug „Statistik“ ist in Situationen nützlich, in denen Sie statistische Informationen zu den Ergebnissen eines bestimmten Werkzeugs sammeln möchten, um beispielsweise den Fertigungsprozess zu analysieren.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Mathematik- und Logikwerkzeugs „Statistik”

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie den zu verarbeitenden Wert definieren und die Parameter des Werkzeugs konfigurieren.

  1. Passen Sie die Einstellungen auf der Registerkarte Allgemein an Ihre Anwendung an.
  2. Klicken Sie auf die Registerkarte Einstellungen, um einen Wert zu definieren, für den Statistiken gesammelt werden sollen. Nach dem Hinzufügen des Werkzeugs untersucht EasyBuilder Ihre Anwendung und führt die Werte auf, die im Parameter Letzter Wert referenziert werden können. Wählen Sie einen Wert aus, und konfigurieren Sie anschließend die restlichen Parameter auf der Registerkarte.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Mathematik- und Logikwerkzeugs "Statistik"

Nach dem Hinzufügen des Werkzeugs können Sie es für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Mathematik- und Logikwerkzeugs "Statistik" enthält Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Tabelle
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Tabelle


Mathematik- und Logikwerkzeug „Statistik“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Stats_1“, sofern es sich um das erste Mathematik- und Logikwerkzeug „Statistik“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Stats_2“, „Stats_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Mathematik- und Logikwerkzeug "Statistik" - Registerkarte "Einstellungen"

Geschlossen Letzter Wert

Bestimmt, welchen Wert das Werkzeug berechnet. Standardmäßig werden keine Statistiken gesammelt. Wählen Sie einen Wert aus, der von einem Werkzeug zurückgegeben oder in den Job eingegeben wurde, um Statistiken für den Wert dieses Werkzeugs bzw. diese Eingabe zu sammeln.

Geschlossen Anzeigen

Definiert, welcher berechnete Wert angezeigt wird: Letzter Wert, Minimum, Maximum, Mittelwert oder StdDev (Standardabweichung). Standardmäßig ist "Letzter Wert" ausgewählt.

Geschlossen Ergebnis

Zeigt den aktuellen berechneten Wert an, der im Parameter "Anzeigen" definiert ist.

Geschlossen Zählen im Offline-Modus

Legt fest, ob die Ergebnisse Aufnahmen umfassen sollen, die gemacht werden, während das In-Sight-Vision-System offline ist. Diese Einstellung ist standardmäßig aktiviert, sodass auch Statistiken gesammelt werden, wenn das Vision-System offline ist. Deaktivieren Sie dieses Kontrollkästchen, falls nur dann Statistiken gesammelt werden sollen, wenn das In-Sight-Vision-System online ist.

Geschlossen Schaltfläche "Zurücksetzen"

Setzt die Datensammlung auf 0 zurück.

Geschlossen Online-Zurücksetzen

Legt fest, ob das Werkzeug das Sammeln von Daten immer zurücksetzt, wenn das In-Sight-Vision-System online geschaltet wird. Diese Einstellung ist standardmäßig deaktiviert, sodass ein manuelles Zurücksetzen erforderlich ist.

Geschlossen Job laden zurücksetzen

Legt fest, ob das Werkzeug das Sammeln von Daten immer zurücksetzt, wenn das In-Sight-Vision-System den Job mit dem Werkzeug lädt. Diese Einstellung ist standardmäßig deaktiviert, sodass ein manuelles Zurücksetzen erforderlich ist.


Mathematik- und Logikwerkzeug "Statistik" - Registerkarte "Tabelle"

Die Registerkarte "Tabelle" des Mathematik- und Logikwerkzeugs "Statistik" zeigt die Ergebnisse an, die für den Wert gesammelt werden, der auf der Registerkarte Einstellungen mit dem Parameter Letzter Wert definiert ist.


Mathematik- und Logikwerkzeuge – Gruppenwerkzeug

Das Mathematik- und Logikwerkzeug Gruppe vereint Positions- und/oder Inspektionswerkzeuge in einer Gruppe und erstellt einen gemeinsamen Aktivierungsstatus für die Werkzeuge in der Gruppe, sodass sie gemeinsam ausgeführt werden.

Das Mathematik- und Logikwerkzeug Gruppe eignet sich beispielsweise für Situationen, in denen mehrere Werkzeuge zur Überprüfung eines einzelnen Produktmerkmals verwendet werden, für Jobs, die mehrere Aufnahmen erfordern, oder für Jobs, die viele Werkzeuge umfassen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Mathematik- und Logikwerkzeugs „Gruppe”

Hinweis: Das Werkzeug erfordert andere Positionswerkzeuge und/oder Inspektionswerkzeuge als Eingabe. Stellen Sie vor dem Hinzufügen des Werkzeugs die notwendigen Positions- und/oder Inspektionswerkzeuge für die Eingabe zusammen. Andernfalls können die Ausdrücke nicht erstellt werden, und Sie müssen zu diesem Schritt zurückkehren.

Nachdem das Werkzeug hinzugefügt wurde, definieren Sie die Werkzeuge, die Teil dieser Gruppe sein sollen.

  1. Nach dem Hinzufügen des Werkzeugs untersucht EasyBuilder Ihren Job und führt alle in Ihrem Job enthaltenen Werkzeuge in der linken Spalte der Registerkarte Werkzeuggruppe auf.
  2. Wählen Sie die Werkzeuge für die Gruppe aus. Halten Sie dabei die Strg-Taste gedrückt, um mehrere einzelne Werkzeuge auszuwählen, oder halten Sie die Umschalttaste gedrückt, um mehrere aufeinander folgende Werkzeuge auszuwählen. Klicken Sie anschließend auf die Schaltfläche Hinzufügen.
  3. Wenn die Gruppe fertig ist, wechseln Sie zur Registerkarte Ausdruck aktivieren. Hier können Sie einen benutzerdefinierten Ausdruck erstellen, der die Logik zur Steuerung der Ausführung der Gruppe bereitstellt. Ausdruck ist standardmäßig auf 1 eingestellt, wodurch die Gruppe immer aktiviert ist.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Mathematik- und Logikwerkzeugs "Gruppe"

Nach dem Hinzufügen des Werkzeugs zu einem Job können Sie es für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Mathematik- und Logikwerkzeugs "Gruppe" enthält Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarte "Werkzeuggruppe"
  • Registerkarte "Ausdruck aktivieren"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Werkzeuggruppe“

Registerkarte „Ausdruck aktivieren“


Mathematik- und Logikwerkzeug „Gruppe“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Group_1“, sofern es sich um das erste Mathematik- und Logikwerkzeug „Gruppe“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Group_2“, „Group_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Hinweis: Wenn Sie auf der Registerkarte Ausdruck aktivieren die Verwendung eines Ausdrucks konfiguriert haben, muss der Parameter Werkzeug aktiviert auf „Ausdruck“ festgelegt sein, um korrekt zu funktionieren.
Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Mathematik- und Logikwerkzeug "Gruppe" - Registerkarte "Einstellungen"

Geschlossen Gruppen-ID

Die Gruppen-ID wird zur Anzeige eines Fehlers verwendet, wenn die Werkzeuge im Mathematik- und Logikwerkzeug "Gruppe" fehlschlagen. Das Mathematik- und Logikwerkzeug "Gruppe" gibt 0 ("Bestanden") oder die Gruppen-ID ("Fehler") zurück. Die Gruppen-ID liegt zwischen 1 und 9.999.999 und ist standardmäßig auf 10 gesetzt. Sie wird nicht erhöht, wenn ein neues Mathematik- und Logikwerkzeug "Gruppe" hinzugefügt wird.


Mathematik- und Logikwerkzeug "Gruppe" - Registerkarte "Werkzeuggruppe"

Auf der Registerkarte Werkzeuggruppe können Sie dem ausgewählten Mathematik- und Logikwerkzeug "Gruppe" Werkzeuge hinzufügen und Werkzeuge daraus entfernen.

Die Liste im linken Bildschirmbereich zeigt Werkzeuge an, die nicht in der Gruppe sind, und die Liste rechts zeigt die in der Gruppe enthaltenen Werkzeuge an. Die Liste im rechten Bildschirmbereich ist standardmäßig leer.

Geschlossen Schaltfläche "Hinzufügen"

Die Schaltfläche Hinzufügen wird aktiviert, wenn im linken Bildschirmbereich ein Werkzeug ausgewählt ist.

  • Sie können Werkzeuge einzeln hinzufügen, indem Sie das gewünschte Werkzeug auswählen und auf die Schaltfläche Hinzufügen klicken.
  • Halten Sie zum Auswählen mehrerer nicht aufeinander folgender Werkzeuge die Strg-Taste gedrückt und markieren Sie die Werkzeuge. Klicken Sie anschließend auf die Schaltfläche Hinzufügen.
  • Wenn Sie mehrere aufeinander folgende Werkzeuge auswählen möchten, halten Sie die Umschalttaste gedrückt, markieren Sie nacheinander das erste und das letzte gewünschte Werkzeug und klicken Sie auf die Schaltfläche Hinzufügen.
Geschlossen Schaltfläche "Entfernen"

Die Schaltfläche Entfernen wird aktiviert, wenn im rechten Bildschirmbereich ein Werkzeug ausgewählt ist.

  • Sie können Werkzeuge einzeln entfernen, indem Sie das gewünschte Werkzeug auswählen und auf die Schaltfläche Entfernen klicken.
  • Halten Sie zum Auswählen mehrerer nicht aufeinander folgender Werkzeuge die Strg-Taste gedrückt, markieren Sie die Werkzeuge, und klicken Sie dann auf die Schaltfläche Entfernen.
  • Wenn Sie mehrere aufeinander folgende Werkzeuge auswählen möchten, halten Sie die Umschalttaste gedrückt, markieren Sie nacheinander das erste und das letzte gewünschte Werkzeug, und klicken Sie dann auf die Schaltfläche Entfernen.
Hinweis:
  • Ein Werkzeug kann nur zu einem Mathematik- und Logikwerkzeug "Gruppe" gehören. Wenn Sie ein Werkzeug aus einem Mathematik- und Logikwerkzeug "Gruppe" einem anderen Mathematik- und Logikwerkzeug "Gruppe" hinzufügen möchten, muss das Werkzeug zunächst aus dem ersten Mathematik- und Logikwerkzeug "Gruppe" entfernt werden, bevor es der anderen Mathematik- und Logikwerkzeug "Gruppe" hinzugefügt werden kann.
  • Ein Mathematik- und Logikwerkzeug "Gruppe" kann kein anderes Mathematik- und Logikwerkzeug "Gruppe" enthalten.
  • Beim Kopieren und Einfügen eines Mathematik- und Logikwerkzeugs "Gruppe" werden alle darin enthaltenen Werkzeuge ebenfalls kopiert und eingefügt.
  • Beim Löschen eines Mathematik- und Logikwerkzeugs "Gruppe" werden Sie zunächst zur Bestätigung aufgefordert. Durch das Löschen eines Mathematik- und Logikwerkzeugs "Gruppe" werden alle darin enthaltenen Werkzeuge gelöscht. Falls die Werkzeuge in der Gruppe nicht gelöscht werden sollen, entfernen Sie sie aus der Gruppe, bevor Sie das Mathematik- und Logikwerkzeug "Gruppe" löschen.


Mathematik- und Logikwerkzeug "Gruppe" - Registerkarte "Ausdruck aktivieren"

Hinweis: Diese Steuerelemente sind deaktiviert, während das In-Sight Vision-System online ist.

Die Registerkarte Ausdruck aktivieren wird zum Erstellen einer mathematischen Formel verwendet, die die Ausführung des Werkzeugs bestimmt. Standardmäßig ist die Option Ausdruck auf „1“ eingestellt, sodass das Werkzeug bei jedem Bildaufnahmetrigger ausgeführt wird. Zur Aktivierung dieses Steuerelements muss das Steuerelement Werkzeug aktiviert auf der Registerkarte Allgemein auf Ausdruck eingestellt sein.

Vision-Sensoren In-Sight 2000-130/130C

Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen erstellt. Verwenden Sie die Symbol-Baumstruktur für Job- und Werkzeugdaten zum Erstellen der Formel. Geben Sie Elemente ein, indem Sie auf sie doppelklicken oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis: Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch „Job.MissingArg“ ersetzt. Das Werkzeug gibt solange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
Geschlossen Struktur mit Symbolen für Job- und Werkzeugdaten

Die Struktur mit Symbolen für Job- und Werkzeugdaten beinhaltet die durch die Positions- und/oder Inspektionswerkzeuge ausgegebenen Werkzeugergebnisse. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt zwei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
Hinweis: Die Liste der verfügbaren Symbole hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche „Einfügen“

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Heben Sie das gewünschte Symbol hervor und klicken Sie auf die Schaltfläche Einfügen, um das Symbol in den Ausdruck einzufügen.

Geschlossen Schaltflächen "Klammer auf", "Komma", "Klammer zu", AND, OR und NOT

Die Schaltflächen Klammer auf, Komma, Klammer zu, AND, OR und NOT werden zum Erstellen von Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um diese der Formel hinzuzufügen.

Geschlossen Schaltfläche "Löschen"

Mit der Schaltfläche Löschen können Sie hervorgehobene Worte oder Symbole aus dem Ausdruck löschen. Wählen Sie das gewünschte Wort oder Symbol aus und klicken Sie auf die Schaltfläche Löschen.

In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230)

Hinweis: Um die Ausführung des Mathematik- und Logikwerkzeugs „Gruppe“ an das Mathematik- und Logikwerkzeug „Sequenz“ zu binden, muss der Ausdruck des Mathematik- und Logikwerkzeugs „Gruppe“ auf das Mathematik- und Logikwerkzeug „Sequenz“ eingestellt sein (z. B. „Sequenz_1.Aktueller_Schritt=1“) und das Steuerelement Werkzeug aktiviert auf der Registerkarte Allgemein muss auf Ausdruck gesetzt sein.
Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen und -daten erstellt. Geben Sie mathematische Funktionen oder Job-/Werkzeugdaten entweder mithilfe des Keyboards ein, oder verwenden Sie die Vision Tools-, Mathematik- und/oder Textansicht bzw. die Vision-Datenzugriffsansicht auf der linken Seite und die Symbol-Baumstruktur für Job- und Werkzeugdaten auf der rechten Seite, um diese Formel zusammenzusetzen. Geben Sie Elemente ein, indem Sie einen Doppelklick darauf durchführen oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis:
  • Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch "Job.MissingArg" ersetzt. Das Werkzeug gibt so lange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
  • Beim Erstellen von Formeln analysiert EasyBuilder Werkzeugnamen, die mit einer Zelladresse beginnen (e.g. A3_MyTool or P10_SortTool), nicht korrekt. Müssen für diese Werkzeuge Ausdrücke erstellt werden, benennen Sie das Werkzeug um, bevor Sie die Formel erstellen.
Geschlossen Vision Tool:

Die Struktur Vision Tools enthält zusätzliche Kantenfunktionen zum Erstellen des Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Kante, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Kante, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit mathematischen Funktionen

Die Struktur mit mathematischen Funktionen enthält mathematische Funktionen zum Erstellen Ihres Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Mathematik, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Mathematik, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit Textfunktionen

Die Struktur mit Textfunktionen enthält Funktionen zum Formatieren alphanumerischer Daten für die Anzeige und zur Kommunikation und kann zur Konstruktion des Ausdrucks verwendet werden. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Textstruktur, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Textstruktur, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Datenzugriff

Die Struktur Datenzugriff enthält zusätzliche Daten, die standardmäßig nicht verfügbar sind und zur Konstruktion des Ausdrucks verwendet werden können. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Datenzugriff, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Datenzugriff, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis:
  • Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
  • EasyBuilder unterstützt ausschließlich Datenzugriffsfunktionen für Blobs, Kanten und Muster.
Geschlossen Struktur mit Symbolen für Job- und Werkzeugdaten

Die Struktur mit Symbolen für Job- und Werkzeugdaten enthält die Datenausgabe von Positions- und/oder Inspektionswerkzeugen sowie Eingangsleitungen und Jobdaten, wie Bildaufnahmeparameter. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt drei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
  • Geben Sie den Namen des gewünschten symbolischen Verweises über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche "Einfügen"

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Wählen Sie eine mathematische Funktion oder ein Symbol aus, und klicken Sie anschließend auf die Schaltfläche Einfügen, um die Funktion bzw. das Symbol in den Ausdruck einzufügen.

Hinweis: Dieses Steuerelement wird in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, ist die Schaltfläche Einfügen aktiviert.
Geschlossen Schaltflächen für öffnende und schließende Klammern sowie für Kommas

Die Schaltflächen für öffnende Klammern, Kommas und schließende Klammern werden zum Erstellen mathematischer Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um eine Klammer oder ein Komma einzufügen.

Hinweis: Diese Steuerelemente werden in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, sind die Schaltflächen aktiviert.


Mathematik- und Logikwerkzeuge – Sequenz

Das Mathematik- und Logikwerkzeug "Sequenz" bestimmt die Anzahl der Schritte für Jobs, die mehrere Bildaufnahmen oder Montagephasen erfordern. Dieses Werkzeug steuert in Verbindung mit dem Mathematik- und Logikwerkzeug „Gruppe” die Ausführungsfolge der Werkzeuge in der Gruppe.

Das Mathematik- und Logikwerkzeug "Sequenz" eignet sich für Situationen, in denen Sie die Aufnahme von Bildern oder die Ausführung von Inspektionswerkzeugen gemäß der Sequenz Ihres Montage-/Fertigungsprozesses synchronisieren möchten. Beispielsweise können Sie ein von Ihnen gefertigtes Teil in mehreren Phasen der Montage inspizieren, um anhand der Ergebnisse in einer bestimmten Sequenz des Montageprozesses zu bestimmen, ob der Vorgang fortgeführt werden soll.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Mathematik- und Logikwerkzeugs "Sequenz"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie dessen Parameter konfigurieren.

  1. Passen Sie die Einstellungen auf der Registerkarte Allgemein an Ihre Anwendung an.

  2. Klicken Sie auf die Registerkarte Einstellungen, und konfigurieren Sie die Parameter für Ihre Anwendung.

    Hinweis: Um die Ausführung eines Mathematik- und Logikwerkzeugs „Gruppe” und eines Mathematik- und Logikwerkzeugs "Sequenz" miteinander zu verknüpfen, muss der Ausdruck des Mathematik- und Logikwerkzeugs „Gruppe” mithilfe des Symbols Current_Step des Mathematik- und Logikwerkzeugs "Sequenz" erstellt werden. Beispiel: Gruppe_1.Aktivieren=Sequenz_1.Current_Step=1
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Mathematik- und Logikwerkzeugs "Sequenz"

Nach dem Hinzufügen des Werkzeugs zu einem Job können Sie es für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Mathematik- und Logikwerkzeugs "Sequenz" enthält Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“


Mathematik- und Logikwerkzeug „Sequenz“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Step_1“, sofern es sich um das erste Mathematik- und Logikwerkzeug „Sequenz“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Step_2“, „Step_3“ usw. Passen Sie das Werkzeug an, indem Sie ihm beispielsweise einen Namen geben, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Mathematik- und Logikwerkzeug "Sequenz" - Registerkarte "Einstellungen"

Geschlossen Schritte

Bestimmt die Anzahl von Schritten, die vom Werkzeug gesteuert werden. Standardmäßig werden vier Schritte verwendet.

Geschlossen Schaltfläche "Schritt zurücksetzen"

Führt eine Zurücksetzung auf 0 durch und startet die Sequenz bei der nächsten Aufnahme beginnend mit dem ersten Schritt neu.

Geschlossen Nächster Schritt aktiviert

Legt fest, ob der Parameter Nächster Schritt von einem externen Gerät gesteuert wird. Diese Einstellung ist standardmäßig deaktiviert, sodass keine Steuerung durch ein externes Gerät möglich ist. Wenn dieser Parameter aktiviert wird, wird die vom externen Gerät an das Werkzeug gesendete Schrittanzahl bei der nächsten Aufnahme der aktuelle Schritt. Bei dieser Anordnung müssen die Schritte nicht aufeinander folgend ausgeführt werden, und einige Schritte können abhängig von der eingegebenen Schrittanzahl übersprungen werden (z. B., wenn die Anzahl der Schritte sechs (6) beträgt und das Werkzeug, das sich gerade bei Schritt 2 befindet, als nächsten Schritt 5 empfängt, werden die Schritte 3 und 4 ausgelassen).

Geschlossen Nächster Schritt

Bestimmt, welcher Schritt den nächsten Schritt in der Sequenz starten soll. Standardmäßig ist "1" ausgewählt. Dieses Steuerelement ist nur aktiviert, falls der Parameter Nächster Schritt aktiviert aktiviert ist. Um das Werkzeug über ein externes Gerät (beispielsweise eine PLC oder eine VisionView®-Benutzeroberfläche zurückzusetzen, aktivieren Sie das Kontrollkästchen Nächster Schritt aktiviert, und konfigurieren Sie den Datentyp "Next_Step" im Schritt des Parameters Nächster Schritt im Schritt Kommunikation.

Geschlossen Aktueller Schritt

Meldet den aktiven Schritt. Standardmäßig wird 1.000 angezeigt, und der aktuelle Schritt wird definiert.


Mathematik- und Logikwerkzeuge – Punkt berechnen

Das Mathematik- und Logikwerkzeug „Punkt berechnen“ wird verwendet, um einen Punkt im Bild basierend auf mathematischen Ausdrücken zu berechnen, die mit den Ausgaben anderer Positions- bzw. Inspektionswerkzeuge zusammenhängen, und der durch andere Werkzeuge referenziert werden kann. Das Werkzeug gibt die X,Y-Koordinaten des berechneten Punkts zurück.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Das Mathematik- und Logikwerkzeug „Punkt berechnen“ ist in Situationen nützlich, in denen Sie programmgesteuert einen Punkt im Bild identifizieren möchten, der von anderen Werkzeugen referenziert werden kann, im Gegensatz zu einem statischen Punkt, der grafisch im Bild definiert wird, wie z. B. im Fall des Geometriewerkzeugs „Benutzerdefinierter Punkt“. Wenn Sie z. B. den Punkt im Bild basierend auf dem Ergebnis einer mathematischen Funktion oder eines bestimmten Werkzeugs platzieren möchten, wie dem Mittelpunkt einer Kante, die von einem An-/Abwesenheitswerkzeug „Kante“ gefunden wurde, kann das Mathematik- und Logikwerkzeug „Punkt berechnen“ so konstruiert werden, dass die Ergebnisse dieser Werkzeuge als Eingaben zum Berechnen des Punkts verwendet werden, und die Position des Punkts im Bild ändert sich, um der Ausgabe der referenzierten Werkzeugs zu entsprechen. Der berechnete Punkt kann auch von den Mathematik- und Logikwerkzeugen „Mathe“ für weitere auf dem Punkt basierende Logikentscheidungen verwendet werden.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Mathematik- und Logikwerkzeugs "Punkt berechnen"

Hinweis: Das Werkzeug erfordert andere Positionswerkzeuge und/oder Inspektionswerkzeuge als Eingabe. Stellen Sie vor dem Hinzufügen des Werkzeugs die notwendigen Positions- und/oder Inspektionswerkzeuge für die Eingabe zusammen. Andernfalls können die Ausdrücke nicht erstellt werden, und Sie müssen zu diesem Schritt zurückkehren.

Nach dem Hinzufügen des Werkzeugs muss der Ausdruck für die X- und Y-Werte konstruiert werden.

  1. Erstellen Sie Ausdrücke, indem Sie mathematische Funktionen im linken Bereich des Einstellungsfensters und/oder Werte (Werkzeug- und Jobdaten) im rechten Fensterbereich auswählen und dann eingeben. Zum Eingeben einer Funktion oder eines Wert im Formula Editor für Ausdrücke wählen Sie die Funktion oder den Wert aus, und drücken Sie die Eingabetaste. Doppelklicken Sie anschließend auf die Funktion bzw. auf den Wert, oder klicken Sie auf die Schaltfläche Einfügen.
  2. Nachdem die Ausdrücke konstruiert wurden, platziert das Werkzeug ein Punktsymbol im Bild, um die Position des berechneten Punkts anzuzeigen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Mathematik- und Logikwerkzeugs „Punkt berechnen“

Nach dem Hinzufügen des Werkzeugs zu einem Job können Sie es für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Mathematik- und Logikwerkzeugs „Punkt berechnen“ enthält folgende Elemente:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
  • Registerkarten „X“ und „Y“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarten „X“ und „Y“


Mathematik- und Logikwerkzeug „Punkt berechnen“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Point_1“, sofern es sich um das erste Mathematik- und Logikwerkzeug „Punkt berechnen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Point_2“, „Point_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht..

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Mathematik- und Logikwerkzeug „Punkt berechnen“ – Registerkarte „Einstellungen“

Geschlossen Ergebnis

Zeigt das Ergebnis der berechneten X- und Y-Ausdrücke an.


Mathematik- und Logikwerkzeug "Punkt berechnen" – Registerkarten "X" und "Y"

Hinweis: Diese Steuerelemente sind deaktiviert, während das In-Sight Vision-System online ist.

Die Registerkarten X und Y dienen zum Konstruieren der mathematischen Formeln, die die X- und Y-Koordinaten des Punkts definieren.

Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen und -daten erstellt. Geben Sie mathematische Funktionen oder Job-/Werkzeugdaten entweder mithilfe des Keyboards ein, oder verwenden Sie die Vision Tools-, Mathematik- und/oder Textansicht bzw. die Vision-Datenzugriffsansicht auf der linken Seite und die Symbol-Baumstruktur für Job- und Werkzeugdaten auf der rechten Seite, um diese Formel zusammenzusetzen. Geben Sie Elemente ein, indem Sie einen Doppelklick darauf durchführen oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis:
  • Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch "Job.MissingArg" ersetzt. Das Werkzeug gibt so lange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
  • Beim Erstellen von Formeln analysiert EasyBuilder Werkzeugnamen, die mit einer Zelladresse beginnen (e.g. A3_MyTool or P10_SortTool), nicht korrekt. Müssen für diese Werkzeuge Ausdrücke erstellt werden, benennen Sie das Werkzeug um, bevor Sie die Formel erstellen.
Geschlossen Vision Tool:

Die Struktur Vision Tools enthält zusätzliche Kantenfunktionen zum Erstellen des Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Kante, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Kante, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit mathematischen Funktionen

Die Struktur mit mathematischen Funktionen enthält mathematische Funktionen zum Erstellen Ihres Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Mathematik, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Mathematik, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit Textfunktionen

Die Struktur mit Textfunktionen enthält Funktionen zum Formatieren alphanumerischer Daten für die Anzeige und zur Kommunikation und kann zur Konstruktion des Ausdrucks verwendet werden. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Textstruktur, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Textstruktur, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Datenzugriff

Die Struktur Datenzugriff enthält zusätzliche Daten, die standardmäßig nicht verfügbar sind und zur Konstruktion des Ausdrucks verwendet werden können. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Datenzugriff, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Datenzugriff, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis:
  • Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
  • EasyBuilder unterstützt ausschließlich Datenzugriffsfunktionen für Blobs, Kanten und Muster.
Geschlossen Struktur mit Symbolen für Job- und Werkzeugdaten

Die Struktur mit Symbolen für Job- und Werkzeugdaten enthält die Datenausgabe von Positions- und/oder Inspektionswerkzeugen sowie Eingangsleitungen und Jobdaten, wie Bildaufnahmeparameter. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt drei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
  • Geben Sie den Namen des gewünschten symbolischen Verweises über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche "Einfügen"

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Wählen Sie eine mathematische Funktion oder ein Symbol aus, und klicken Sie anschließend auf die Schaltfläche Einfügen, um die Funktion bzw. das Symbol in den Ausdruck einzufügen.

Hinweis: Dieses Steuerelement wird in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, ist die Schaltfläche Einfügen aktiviert.
Geschlossen Schaltflächen für öffnende und schließende Klammern sowie für Kommas

Die Schaltflächen für öffnende Klammern, Kommas und schließende Klammern werden zum Erstellen mathematischer Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um eine Klammer oder ein Komma einzufügen.

Hinweis: Diese Steuerelemente werden in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, sind die Schaltflächen aktiviert.


Mathematik- und Logikwerkzeuge – Variablen

Das Mathematik- und Logikwerkzeug „Variablen” definiert Ganzzahl-, Fließpunkt- und Zeichenkettenwerte, die ein externes Gerät für einen Job eingeben kann. Diese Werte können dann von anderen Positions- oder Inspektionswerkzeugen oder von anderen externen Geräten (beispielsweise von einer programmierbaren Steuerung oder einer VisionView®-Benutzeroberfläche) referenziert werden.

Das Mathematik- und Logikwerkzeug „Variablen” eignet sich für Situationen, in denen Sie von einem externen Gerät (beispielsweise von einer programmierbaren Steuerung) einen Wert in ein Positions- oder Inspektionswerkzeug eingeben möchten. Es ist auch möglich, ihn als Wert in einem Ausdruck eines Mathematik- und Logikwerkzeugs „Mathe” oder eines Mathematik- und Logikwerkzeugs „Gruppe” einzugeben. Beispiel: Sie möchten in Ihrer Anwendung eine Textzeichenkette für ein Identifizierungswerkzeug "Text lesen", einen Ganzzahlwert zur Steuerung der Anzahl von Blobs, nach denen ein Zählwerkzeug "Blobs" sucht, und einen Fließpunktwert als Teil der Ausführungsformel für ein Mathematik- und Logikwerkzeug „Gruppe” eingeben. Diese Werte können im Mathematik- und Logikwerkzeug „Variablen” erstellt und anschließend durch die anderen Werkzeuge oder im Schritt Kommunikation symbolisch referenziert werden.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Mathematik- und Logikwerkzeugs "Variablen"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Werte definieren, die als Eingabevariablen verwendet werden.

  1. Passen Sie die Einstellungen auf der Registerkarte Allgemein an Ihre Anwendung an.
  2. Im Einstellungsfenster neben der Registerkarte Allgemein befindet sich die Eingabevariablentabelle. Klicken Sie auf die Schaltfläche Boolesch Hinzufügen wenn Ihr Wert ein Boolscher logischer Wert ist. Klicken Sie auf die Schaltfläche GanzZahl hinzufügen wenn Ihr Wert ein Ganzzahlwert ist. Klicken Sie auf die Schaltfläche Fließpunkt hinzufügen, wenn Ihr Wert ein Fließpunktwert ist. Klicken Sie die Schaltfläche Zeichenfolge hinzufügen, wenn Ihr Wert eine Zeichenfolge ist.
  3. Nach dem Hinzufügen der Eingabevariablen können Sie sie an Ihre Anwendung anpassen.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.

  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

    Hinweis: Um eine Variable aus der Liste zu entfernen, aktivieren Sie das Kontrollkästchen neben der Variable und klicken Sie anschließend auf die Schaltfläche Entfernen. (Die Schaltfläche Entfernen ist nur aktiv, wenn das Kontrollkästchen aktiviert ist.)


Anpassen der Parameter des Mathematik- und Logikwerkzeugs "Variablen"

Nach dem Hinzufügen des Werkzeugs zu einem Job können Sie es für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Mathematik- und Logikwerkzeugs "Variablen" enthält Folgendes:

  • Registerkarte "Allgemein"
  • Eingabevariablentabelle
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Eingabevariablentabelle


Mathematik- und Logikwerkzeug „Variablen“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Variables_1“, sofern es sich um das erste Mathematik- und Logikwerkzeug „Variablen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Variables_2“, „Variables_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Mathematik- und Logikwerkzeug "Variablen" – Eingabevariablentabelle

Die Eingabevariablentabelle des Mathematik- und Logikwerkzeugs "Variablen" wird zum Hinzufügen, Bearbeiten und Entfernen von Eingabevariablen verwendet. Für jedes Mathematik- und Logikwerkzeug "Variablen" können bis zu 32 Eingabevariablen erstellt werden.

Geschlossen Schaltfläche "Boolesch hinzufügen"

Klicken Sie auf die Schaltfläche Boolesch hinzufügen, wenn der Wert ein boolescher logischer Wert ist. Standardmäßig wird der boolesche Wert 0 hinzugefügt (aktivieren Sie das rechte Kontrollkästchen, um den booleschen Wert auf 1 zu setzen), und der Wert "Boolean0" wird vergeben (wenn es sich um den ersten Wert handelt, der dem Werkzeug hinzugefügt wird, andernfalls wird der Wert entsprechend erhöht wie z. B. "Boolean1", "Boolean2" usw.). Passen Sie den Wert an. Legen Sie dazu einen Namen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Schaltfläche "Ganzzahl hinzufügen"

Klicken Sie auf die Schaltfläche Ganzzahl hinzufügen, wenn Ihr Wert eine Ganzzahl ist. Der hinzugefügte Ganzzahlwert ist standardmäßig 0 und hat den Namen "Ganzzahl0", sofern es sich um den ersten Ganzzahlwert handelt, der dem Werkzeug hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Ganzzahl1", "Ganzzahl2" usw. Passen Sie den Wert an. Legen Sie dazu einen Namen fest, der mit einer bestimmten Anwendung in Zusammenhang steht. Ganzzahlwerte können von 9.999.999 bis -9.999.999 reichen.

Geschlossen Schaltfläche "Fließpunkt hinzufügen"

Klicken Sie auf die Schaltfläche Fließpunkt hinzufügen, wenn es sich bei dem Wert um einen Fließpunktwert handelt. Der hinzugefügte Fließpunktwert ist standardmäßig 0 und hat den Namen "Fließkomma0", sofern es sich um den ersten Fließpunktwert handelt, der dem Werkzeug hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Fließkomma1", "Fließkomma2" usw. Passen Sie den Wert an. Legen Sie dazu einen Namen fest, der mit einer bestimmten Anwendung in Zusammenhang steht. Fließpunktwerte können von 9.999.999 bis -9.999.999 reichen.

Geschlossen Schaltfläche "Zeichenfolge hinzufügen"

Klicken Sie auf die Schaltfläche Zeichenfolge hinzufügen, wenn es sich bei dem Wert um eine Zeichenkette handelt. Das Zeichenketten-Textfeld ist standardmäßig leer und die Zeichenkette hat den Namen "Zeichenkette0", sofern es sich um den ersten Textzeichenketten-Wert handelt, der dem Werkzeug hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. "Zeichenkette1", "Zeichenkette2" usw. Passen Sie den Wert an. Legen Sie dazu einen Namen fest, der mit einer bestimmten Anwendung in Zusammenhang steht. Textzeichenketten können aus bis zu 32 Zeichen bestehen.

Geschlossen Schaltfläche "Entfernen"

Klicken Sie auf die Schaltfläche Entfernen, um einen Wert aus der Tabelle zu löschen. Um eine Variable aus der Liste zu entfernen, aktivieren Sie das Kontrollkästchen links neben der Variablen, und klicken Sie anschließend auf die Schaltfläche Entfernen. Die Schaltfläche Entfernen ist nur aktiv, wenn das Kontrollkästchen aktiviert ist.


Mathematik- und Logikwerkzeuge – Roboterführung

Mit dem Mathematik- und Logikwerkzeug „Roboterführung“ kann das Vision-System dem Roboter die Position eines Teils mitteilen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichtung des Werkzeugs „Roboterführung“

Tipp: Nach der Erstellung der Kalibrierung ist es empfehlenswert, die Jobdatei zu speichern. Für spätere Kalibrierungen können Sie einfach den Kalibrierungsjob laden, das Bild aufzeichnen und anschließend die aktualisierte Kalibrierungsdatei automatisch in alle Jobs exportieren, auf die die Kalibrierungsdatei verweist.

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Eingabemerkmale (Punkte, Vorrichtungsursprung oder Mittelpunkt kreisförmiger Merkmale) definieren, die zur Konstruktion der Kalibrierung verwendet werden:

  1. EasyBuilder untersucht das Bild, nachdem das Werkzeug hinzugefügt wurde, und stellt eine Auswahl von automatisch erkannten Smart Features (Punkte, Ursprünge von Vorrichtungen oder Mittelpunkt von kreisförmigen Merkmalen) (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit. EasyBuilder fügt automatisch ein An-/Abwesenheitswerkzeug „Kreis“ für alle kreisförmigen Merkmale hinzu, die zuvor nicht definiert wurden.

  2. Wählen Sie eines der verfügbaren Merkmale per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta.

  3. Klicken Sie auf die Schaltfläche OK, wenn Sie alle Merkmale ausgewählt haben (mit Abbrechen wird das Werkzeug nicht zum Job hinzugefügt).

  4. Speichern Sie die Jobdatei.
  5. Anschließend können Sie die Parameter des Werkzeugs bei Bedarf anpassen.
  6. Verwenden Sie ggf. die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen bzw. anderen externen Geräten auszutauschen.


Anpassen der Parameter des Werkzeugs „Roboterführung“

Nach dem Hinzufügen des Werkzeugs zu einem Job können Sie es für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Kalibrierungswerkzeugs „Roboterführung“ umfasst die folgenden Registerkarten:

  • Registerkarte „Allgemein“

Registerkarte „Allgemein“


Werkzeug „Roboterführung“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Bild einrichten, Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Guidance_1“. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht. Sie können nur ein Werkzeug „Roboterführung“ zu einem Job hinzufügen.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Darstellungswerkzeuge – Bogen darstellen

Das Darstellungswerkzeug „Bogen darstellen“ wird verwendet, um einen Bogen grafisch auf dem Bild darzustellen, basierend auf mathematischen Ausdrücken, die die Werte für Mittelpunkt X, Mittelpunkt Y, Radius, Startwinkel und Spannweite des Bogens definieren. Das Werkzeug stellt die Grafik auf dem Bild dar und gibt die Werte zurück, die den Bogen definieren.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Darstellungswerkzeugs "Bogen darstellen"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Ausdrücke erstellen, die die Grafik definieren.

  1. Erstellen Sie die mathematischen Ausdrücke, die zum Definieren der Grafik verwendet werden, indem Sie die mathematischen Funktionen im linken Bereich des Einstellungsfensters und die Werte (Werkzeug- und Jobdaten) im rechten Fensterbereich auswählen und dann eingeben. Um eine Funktion oder einen Wert im Formula Editor für Ausdrücke einzugeben, wählen Sie die Funktion oder den Wert aus, und drücken Sie die Eingabetaste, doppelklicken Sie auf die Funktion bzw. den Wert oder klicken Sie auf die Schaltfläche Einfügen.
  2. Nach dem Konstruieren der Ausdrücke, die die im Bild dargestellte Grafik definieren, werden von EasyBuilder die Daten verarbeitet und die Grafik erstellt.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Darstellungswerkzeugs "Bogen darstellen"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Darstellungswerkzeugs "Bogen darstellen" umfasst Folgendes:

  • Registerkarten "Allgemein" und "Einstellungen"
  • "Ausdruck"-Registerkarten "Mittelpunkt X", "Mittelpunkt Y", "Radius", "Winkelanfang" und "Spannweite"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarten „Allgemein“ und „Einstellungen“

Registerkarten „Mittelpunkt X“, „Mittelpunkt Y“, „Radius“, „Winkelanfang“ und „Spannweite“


Darstellungswerkzeug „Bogen darstellen“ – Registerkarten „Allgemein“ und „Einstellungen“

Geschlossen Registerkarte „Allgemein“
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Arc_1“, sofern es sich um das erste Bogendarstellungswerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Arc_2“, „Arc_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Geschlossen Registerkarte „Einstellungen“
Geschlossen Farbe

Definiert die Farbe der dargestellten Grafik. Die Standardfarbe ist die derzeit von anderen Werkzeugen im Job verwendete Farbe.

Geschlossen Ergebnis

Gibt die Ausgabe der Registerkarten „Ausdruck“ des Werkzeugs zurück; zeigt die Werte für X, Y, Radius, Startwinkel und Spannweite des Bogens an.


Darstellungswerkzeug "Bogen darstellen" – "Ausdruck"-Registerkarten "Mittelpunkt X", "Mittelpunkt Y", "Radius", "Winkelanfang" und "Spannweite"

Das Darstellungswerkzeug Bogen darstellen besteht aus den folgenden "Ausdruck"-Registerkarten (mit gemeinsamen Steuerelementen) für das Erstellen der darzustellenden Grafik: Registerkarten für den Ausdruck Mittelpunkt X, Mittelpunkt Y, Radius, Winkelanfang und Spannweite.Besitzt eine der Ausdruck-Registerkarten einen Fehlerstatus (#ERR), wird die Grafik nicht auf dem Bild dargestellt und es wird eine Fehlermeldung mit Informationen zu den fehlerhaften Ausdruck-Registerkarten angezeigt.

Hinweis: Diese Steuerelemente sind deaktiviert, während das In-Sight Vision-System online ist.
Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen und -daten erstellt. Geben Sie mathematische Funktionen oder Job-/Werkzeugdaten entweder mithilfe des Keyboards ein, oder verwenden Sie die Vision Tools-, Mathematik- und/oder Textansicht bzw. die Vision-Datenzugriffsansicht auf der linken Seite und die Symbol-Baumstruktur für Job- und Werkzeugdaten auf der rechten Seite, um diese Formel zusammenzusetzen. Geben Sie Elemente ein, indem Sie einen Doppelklick darauf durchführen oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis:
  • Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch "Job.MissingArg" ersetzt. Das Werkzeug gibt so lange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
  • Beim Erstellen von Formeln analysiert EasyBuilder Werkzeugnamen, die mit einer Zelladresse beginnen (e.g. A3_MyTool or P10_SortTool), nicht korrekt. Müssen für diese Werkzeuge Ausdrücke erstellt werden, benennen Sie das Werkzeug um, bevor Sie die Formel erstellen.
Geschlossen Vision Tool:

Die Struktur Vision Tools enthält zusätzliche Kantenfunktionen zum Erstellen des Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Kante, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Kante, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit mathematischen Funktionen

Die Struktur mit mathematischen Funktionen enthält mathematische Funktionen zum Erstellen Ihres Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Mathematik, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Mathematik, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit Textfunktionen

Die Struktur mit Textfunktionen enthält Funktionen zum Formatieren alphanumerischer Daten für die Anzeige und zur Kommunikation und kann zur Konstruktion des Ausdrucks verwendet werden. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Textstruktur, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Textstruktur, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Datenzugriff

Die Struktur Datenzugriff enthält zusätzliche Daten, die standardmäßig nicht verfügbar sind und zur Konstruktion des Ausdrucks verwendet werden können. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Datenzugriff, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Datenzugriff, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis:
  • Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
  • EasyBuilder unterstützt ausschließlich Datenzugriffsfunktionen für Blobs, Kanten und Muster.
Geschlossen Struktur mit Symbolen für Job- und Werkzeugdaten

Die Struktur mit Symbolen für Job- und Werkzeugdaten enthält die Datenausgabe von Positions- und/oder Inspektionswerkzeugen sowie Eingangsleitungen und Jobdaten, wie Bildaufnahmeparameter. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt drei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
  • Geben Sie den Namen des gewünschten symbolischen Verweises über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche "Einfügen"

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Wählen Sie eine mathematische Funktion oder ein Symbol aus, und klicken Sie anschließend auf die Schaltfläche Einfügen, um die Funktion bzw. das Symbol in den Ausdruck einzufügen.

Hinweis: Dieses Steuerelement wird in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, ist die Schaltfläche Einfügen aktiviert.
Geschlossen Schaltflächen für öffnende und schließende Klammern sowie für Kommas

Die Schaltflächen für öffnende Klammern, Kommas und schließende Klammern werden zum Erstellen mathematischer Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um eine Klammer oder ein Komma einzufügen.

Hinweis: Diese Steuerelemente werden in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, sind die Schaltflächen aktiviert.


Darstellungswerkzeuge – Kreis darstellen

Das Darstellungswerkzeug „Kreis darstellen“ wird verwendet, um einen Kreis grafisch auf dem Bild darzustellen, basierend auf mathematischen Ausdrücken, die die Werte für X, Y und Radius des Kreises definieren. Das Werkzeug stellt die Grafik auf dem Bild dar und gibt die Werte zurück, die den Kreis definieren.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Darstellungswerkzeugs "Kreis darstellen"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Ausdrücke erstellen, die die Grafik definieren.

  1. Erstellen Sie die mathematischen Ausdrücke, die zum Definieren der Grafik verwendet werden, indem Sie die mathematischen Funktionen im linken Bereich des Einstellungsfensters und die Werte (Werkzeug- und Jobdaten) im rechten Fensterbereich auswählen und dann eingeben. Um eine Funktion oder einen Wert im Formula Editor für Ausdrücke einzugeben, wählen Sie die Funktion oder den Wert aus, und drücken Sie die Eingabetaste, doppelklicken Sie auf die Funktion bzw. den Wert oder klicken Sie auf die Schaltfläche Einfügen.
  2. Nach dem Konstruieren der Ausdrücke, die die im Bild dargestellte Grafik definieren, werden von EasyBuilder die Daten verarbeitet und die Grafik erstellt.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Darstellungswerkzeugs "Kreis darstellen"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Darstellungswerkzeugs "Kreis darstellen" umfasst Folgendes:

  • Registerkarten "Allgemein" und "Einstellungen"
  • Registerkarten "X", "Y" und "Radius"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarten „Allgemein“ und „Einstellungen“

Ausdruck-Registerkarten „X“, „Y“ und „Radius“


Darstellungswerkzeug „Kreis darstellen“ – Registerkarten „Allgemein“ und „Einstellungen“

Geschlossen Registerkarte „Allgemein“
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Circle_1“, sofern es sich um das erste Kreisdarstellungswerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Circle_2“, „Circle_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Geschlossen Registerkarte „Einstellungen“
Geschlossen Farbe

Definiert die Farbe der dargestellten Grafik. Die Standardfarbe ist die derzeit von anderen Werkzeugen im Job verwendete Farbe.

Geschlossen Ergebnis

Gibt die Ausgabe der Registerkarten „Ausdruck“ des Werkzeugs zurück; zeigt die Werte für X, Y und, Radius des Kreises an.


Darstellungswerkzeug "Kreis darstellen" – "Ausdruck"-Registerkarten "X", "Y" und "Radius"

Das Darstellungswerkzeug Kreis darstellen besteht aus den folgenden Registerkarten für den Ausdruck (mit gemeinsamen Steuerelementen) für das Erstellen der darzustellenden Grafik: "Ausdruck"-Registerkarten X, Y, und Radius. Besitzt eine der Ausdruck-Registerkarten einen Fehlerstatus (#ERR), wird die Grafik nicht auf dem Bild dargestellt und es wird eine Fehlermeldung mit Informationen zu den fehlerhaften Ausdruck-Registerkarten angezeigt.

Hinweis: Diese Steuerelemente sind deaktiviert, während das In-Sight Vision-System online ist.
Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen und -daten erstellt. Geben Sie mathematische Funktionen oder Job-/Werkzeugdaten entweder mithilfe des Keyboards ein, oder verwenden Sie die Vision Tools-, Mathematik- und/oder Textansicht bzw. die Vision-Datenzugriffsansicht auf der linken Seite und die Symbol-Baumstruktur für Job- und Werkzeugdaten auf der rechten Seite, um diese Formel zusammenzusetzen. Geben Sie Elemente ein, indem Sie einen Doppelklick darauf durchführen oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis:
  • Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch "Job.MissingArg" ersetzt. Das Werkzeug gibt so lange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
  • Beim Erstellen von Formeln analysiert EasyBuilder Werkzeugnamen, die mit einer Zelladresse beginnen (e.g. A3_MyTool or P10_SortTool), nicht korrekt. Müssen für diese Werkzeuge Ausdrücke erstellt werden, benennen Sie das Werkzeug um, bevor Sie die Formel erstellen.
Geschlossen Vision Tool:

Die Struktur Vision Tools enthält zusätzliche Kantenfunktionen zum Erstellen des Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Kante, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Kante, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit mathematischen Funktionen

Die Struktur mit mathematischen Funktionen enthält mathematische Funktionen zum Erstellen Ihres Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Mathematik, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Mathematik, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit Textfunktionen

Die Struktur mit Textfunktionen enthält Funktionen zum Formatieren alphanumerischer Daten für die Anzeige und zur Kommunikation und kann zur Konstruktion des Ausdrucks verwendet werden. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Textstruktur, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Textstruktur, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Datenzugriff

Die Struktur Datenzugriff enthält zusätzliche Daten, die standardmäßig nicht verfügbar sind und zur Konstruktion des Ausdrucks verwendet werden können. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Datenzugriff, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Datenzugriff, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis:
  • Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
  • EasyBuilder unterstützt ausschließlich Datenzugriffsfunktionen für Blobs, Kanten und Muster.
Geschlossen Struktur mit Symbolen für Job- und Werkzeugdaten

Die Struktur mit Symbolen für Job- und Werkzeugdaten enthält die Datenausgabe von Positions- und/oder Inspektionswerkzeugen sowie Eingangsleitungen und Jobdaten, wie Bildaufnahmeparameter. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt drei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
  • Geben Sie den Namen des gewünschten symbolischen Verweises über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche "Einfügen"

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Wählen Sie eine mathematische Funktion oder ein Symbol aus, und klicken Sie anschließend auf die Schaltfläche Einfügen, um die Funktion bzw. das Symbol in den Ausdruck einzufügen.

Hinweis: Dieses Steuerelement wird in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, ist die Schaltfläche Einfügen aktiviert.
Geschlossen Schaltflächen für öffnende und schließende Klammern sowie für Kommas

Die Schaltflächen für öffnende Klammern, Kommas und schließende Klammern werden zum Erstellen mathematischer Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um eine Klammer oder ein Komma einzufügen.

Hinweis: Diese Steuerelemente werden in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, sind die Schaltflächen aktiviert.


Darstellungswerkzeuge – Kreuz darstellen

Das Darstellungswerkzeug „Kreuz darstellen“ wird verwendet, um ein Kreuz grafisch auf dem Bild darzustellen, basierend auf mathematischen Ausdrücken, die die Werte für X, Y und Radius des Kreuzes definieren. Das Werkzeug stellt die Grafik auf dem Bild dar und gibt die Werte zurück, die das Kreuz definieren.

Hinweis:
  • Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).
  • Die Ausgabe des Darstellungswerkzeugs „Kreuz darstellen“ kann als Vorrichtung für andere Werkzeuge verwendet werden.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Darstellungswerkzeugs "Kreuz darstellen"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Ausdrücke erstellen, die die Grafik definieren.

  1. Erstellen Sie die mathematischen Ausdrücke, die zum Definieren der Grafik verwendet werden, indem Sie die mathematischen Funktionen im linken Bereich des Einstellungsfensters und die Werte (Werkzeug- und Jobdaten) im rechten Fensterbereich auswählen und dann eingeben. Um eine Funktion oder einen Wert im Formula Editor für Ausdrücke einzugeben, wählen Sie die Funktion oder den Wert aus, und drücken Sie die Eingabetaste, doppelklicken Sie auf die Funktion bzw. den Wert oder klicken Sie auf die Schaltfläche Einfügen.
  2. Nach dem Konstruieren der Ausdrücke, die die im Bild dargestellte Grafik definieren, werden von EasyBuilder die Daten verarbeitet und die Grafik erstellt.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Darstellungswerkzeugs "Kreuz darstellen"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Darstellungswerkzeugs "Kreuz darstellen" umfasst Folgendes:

  • Registerkarten "Allgemein" und "Einstellungen"
  • Registerkarten "X", "Y" und "Winkel"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarten „Allgemein“ und „Einstellungen“

Ausdruck-Registerkarten „X“, „Y“ und „Winkel“


Darstellungswerkzeug „Kreuz darstellen“ – Registerkarten „Allgemein“ und „Einstellungen“

Geschlossen Registerkarte „Allgemein“
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Cross_1“, sofern es sich um das erste Kreuzdarstellungswerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Cross_2“, „Cross_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Geschlossen Registerkarte „Einstellungen“
Geschlossen Farbe

Definiert die Farbe der dargestellten Grafik. Die Standardfarbe ist die derzeit von anderen Werkzeugen im Job verwendete Farbe.

Geschlossen Ergebnis

Gibt die Ausgabe der Registerkarten „Ausdruck“ des Werkzeugs zurück; zeigt die Werte für X, Y und Winkel des Kreuzes an.


Darstellungswerkzeug "Kreuz darstellen" – "Ausdruck"-Registerkarten "X", "Y" und "Winkel"

Das Darstellungswerkzeug Kreuz darstellen besteht aus den folgenden Registerkarten für den Ausdruck (mit gemeinsamen Steuerelementen) für das Erstellen der darzustellenden Grafik: "Ausdruck"-Registerkarten X, Y, und Radius. Besitzt eine der Ausdruck-Registerkarten einen Fehlerstatus (#ERR), wird die Grafik nicht auf dem Bild dargestellt und es wird eine Fehlermeldung mit Informationen zu den fehlerhaften Ausdruck-Registerkarten angezeigt.

Hinweis: Diese Steuerelemente sind deaktiviert, während das In-Sight Vision-System online ist.
Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen und -daten erstellt. Geben Sie mathematische Funktionen oder Job-/Werkzeugdaten entweder mithilfe des Keyboards ein, oder verwenden Sie die Vision Tools-, Mathematik- und/oder Textansicht bzw. die Vision-Datenzugriffsansicht auf der linken Seite und die Symbol-Baumstruktur für Job- und Werkzeugdaten auf der rechten Seite, um diese Formel zusammenzusetzen. Geben Sie Elemente ein, indem Sie einen Doppelklick darauf durchführen oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis:
  • Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch "Job.MissingArg" ersetzt. Das Werkzeug gibt so lange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
  • Beim Erstellen von Formeln analysiert EasyBuilder Werkzeugnamen, die mit einer Zelladresse beginnen (e.g. A3_MyTool or P10_SortTool), nicht korrekt. Müssen für diese Werkzeuge Ausdrücke erstellt werden, benennen Sie das Werkzeug um, bevor Sie die Formel erstellen.
Geschlossen Vision Tool:

Die Struktur Vision Tools enthält zusätzliche Kantenfunktionen zum Erstellen des Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Kante, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Kante, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit mathematischen Funktionen

Die Struktur mit mathematischen Funktionen enthält mathematische Funktionen zum Erstellen Ihres Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Mathematik, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Mathematik, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit Textfunktionen

Die Struktur mit Textfunktionen enthält Funktionen zum Formatieren alphanumerischer Daten für die Anzeige und zur Kommunikation und kann zur Konstruktion des Ausdrucks verwendet werden. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Textstruktur, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Textstruktur, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Datenzugriff

Die Struktur Datenzugriff enthält zusätzliche Daten, die standardmäßig nicht verfügbar sind und zur Konstruktion des Ausdrucks verwendet werden können. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Datenzugriff, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Datenzugriff, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis:
  • Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
  • EasyBuilder unterstützt ausschließlich Datenzugriffsfunktionen für Blobs, Kanten und Muster.
Geschlossen Struktur mit Symbolen für Job- und Werkzeugdaten

Die Struktur mit Symbolen für Job- und Werkzeugdaten enthält die Datenausgabe von Positions- und/oder Inspektionswerkzeugen sowie Eingangsleitungen und Jobdaten, wie Bildaufnahmeparameter. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt drei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
  • Geben Sie den Namen des gewünschten symbolischen Verweises über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche "Einfügen"

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Wählen Sie eine mathematische Funktion oder ein Symbol aus, und klicken Sie anschließend auf die Schaltfläche Einfügen, um die Funktion bzw. das Symbol in den Ausdruck einzufügen.

Hinweis: Dieses Steuerelement wird in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, ist die Schaltfläche Einfügen aktiviert.
Geschlossen Schaltflächen für öffnende und schließende Klammern sowie für Kommas

Die Schaltflächen für öffnende Klammern, Kommas und schließende Klammern werden zum Erstellen mathematischer Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um eine Klammer oder ein Komma einzufügen.

Hinweis: Diese Steuerelemente werden in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, sind die Schaltflächen aktiviert.


Darstellungswerkzeuge – Linie darstellen

Das Darstellungswerkzeug „Linie darstellen“ wird verwendet, um eine Linie grafisch auf dem Bild darzustellen, basierend auf mathematischen Ausdrücken, die die Werte für X-Anfang, Y-Anfang, X-Ende und Y-Ende der Linie definieren. Das Werkzeug stellt die Grafik auf dem Bild dar und gibt die Werte zurück, die die Anfangs- und End-X/Y-Werte der Linie definieren.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Darstellungswerkzeugs "Linie darstellen"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Ausdrücke erstellen, die die Grafik definieren.

  1. Erstellen Sie die mathematischen Ausdrücke, die zum Definieren der Grafik verwendet werden, indem Sie die mathematischen Funktionen im linken Bereich des Einstellungsfensters und die Werte (Werkzeug- und Jobdaten) im rechten Fensterbereich auswählen und dann eingeben. Um eine Funktion oder einen Wert im Formula Editor für Ausdrücke einzugeben, wählen Sie die Funktion oder den Wert aus, und drücken Sie die Eingabetaste, doppelklicken Sie auf die Funktion bzw. den Wert oder klicken Sie auf die Schaltfläche Einfügen.
  2. Nach dem Konstruieren der Ausdrücke, die die im Bild dargestellte Grafik definieren, werden von EasyBuilder die Daten verarbeitet und die Grafik erstellt.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Darstellungswerkzeugs "Linie darstellen"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Darstellungswerkzeugs "Linie darstellen" umfasst Folgendes:

  • Registerkarten "Allgemein" und "Einstellungen"
  • "Ausdruck"-Registerkarten "X-Anfang", "Y-Anfang", "X-Ende" und "Y-Ende"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarten „Allgemein“ und „Einstellungen“

Ausdruck-Registerkarten „X-Anfang“, „Y-Anfang“, „X-Ende“ und „Y-Ende“


Darstellungswerkzeug „Linie darstellen“ – Registerkarten „Allgemein“ und „Einstellungen“

Geschlossen Registerkarte „Allgemein“
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Line_1“, sofern es sich um das erste Werkzeug „Linie darstellen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Line_2“, „Line_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Geschlossen Registerkarte „Einstellungen“
Geschlossen Farbe

Definiert die Farbe der dargestellten Grafik. Die Standardfarbe ist die derzeit von anderen Werkzeugen im Job verwendete Farbe.

Geschlossen Ergebnis

Gibt die Ausgabe der Registerkarten „Ausdruck“ des Werkzeugs zurück; zeigt die Anfangs- und Endwerte für X und Y der Linie an.


Darstellungswerkzeug "Linie darstellen" – "Ausdruck"-Registerkarten "X-Anfang", "Y-Anfang", "X-Ende" und "Y-Ende"

Das Darstellungswerkzeug Linie darstellen besteht aus den folgenden Registerkarten für den Ausdruck (mit gemeinsamen Steuerelementen) für das Erstellen der darzustellenden Grafik: "Ausdruck"-Registerkarten X-Anfang, Y-Anfang, X-Ende und Y-Ende. Besitzt eine der Ausdruck-Registerkarten einen Fehlerstatus (#ERR), wird die Grafik nicht auf dem Bild dargestellt und es wird eine Fehlermeldung mit Informationen zu den fehlerhaften Ausdruck-Registerkarten angezeigt.

Hinweis: Diese Steuerelemente sind deaktiviert, während das In-Sight Vision-System online ist.
Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen und -daten erstellt. Geben Sie mathematische Funktionen oder Job-/Werkzeugdaten entweder mithilfe des Keyboards ein, oder verwenden Sie die Vision Tools-, Mathematik- und/oder Textansicht bzw. die Vision-Datenzugriffsansicht auf der linken Seite und die Symbol-Baumstruktur für Job- und Werkzeugdaten auf der rechten Seite, um diese Formel zusammenzusetzen. Geben Sie Elemente ein, indem Sie einen Doppelklick darauf durchführen oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis:
  • Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch "Job.MissingArg" ersetzt. Das Werkzeug gibt so lange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
  • Beim Erstellen von Formeln analysiert EasyBuilder Werkzeugnamen, die mit einer Zelladresse beginnen (e.g. A3_MyTool or P10_SortTool), nicht korrekt. Müssen für diese Werkzeuge Ausdrücke erstellt werden, benennen Sie das Werkzeug um, bevor Sie die Formel erstellen.
Geschlossen Vision Tool:

Die Struktur Vision Tools enthält zusätzliche Kantenfunktionen zum Erstellen des Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Kante, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Kante, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit mathematischen Funktionen

Die Struktur mit mathematischen Funktionen enthält mathematische Funktionen zum Erstellen Ihres Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Mathematik, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Mathematik, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit Textfunktionen

Die Struktur mit Textfunktionen enthält Funktionen zum Formatieren alphanumerischer Daten für die Anzeige und zur Kommunikation und kann zur Konstruktion des Ausdrucks verwendet werden. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Textstruktur, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Textstruktur, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Datenzugriff

Die Struktur Datenzugriff enthält zusätzliche Daten, die standardmäßig nicht verfügbar sind und zur Konstruktion des Ausdrucks verwendet werden können. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Datenzugriff, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Datenzugriff, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis:
  • Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
  • EasyBuilder unterstützt ausschließlich Datenzugriffsfunktionen für Blobs, Kanten und Muster.
Geschlossen Struktur mit Symbolen für Job- und Werkzeugdaten

Die Struktur mit Symbolen für Job- und Werkzeugdaten enthält die Datenausgabe von Positions- und/oder Inspektionswerkzeugen sowie Eingangsleitungen und Jobdaten, wie Bildaufnahmeparameter. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt drei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
  • Geben Sie den Namen des gewünschten symbolischen Verweises über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche "Einfügen"

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Wählen Sie eine mathematische Funktion oder ein Symbol aus, und klicken Sie anschließend auf die Schaltfläche Einfügen, um die Funktion bzw. das Symbol in den Ausdruck einzufügen.

Hinweis: Dieses Steuerelement wird in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, ist die Schaltfläche Einfügen aktiviert.
Geschlossen Schaltflächen für öffnende und schließende Klammern sowie für Kommas

Die Schaltflächen für öffnende Klammern, Kommas und schließende Klammern werden zum Erstellen mathematischer Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um eine Klammer oder ein Komma einzufügen.

Hinweis: Diese Steuerelemente werden in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, sind die Schaltflächen aktiviert.


Darstellungswerkzeuge – Punkt darstellen

Das Darstellungswerkzeug „Punkt darstellen“ wird verwendet, um einen Punkt grafisch auf dem Bild darzustellen, basierend auf mathematischen Ausdrücken, die die Werte für X und Y des Punktes definieren. Das Werkzeug stellt die Grafik auf dem Bild dar und gibt die Werte zurück, die den Punkt definieren.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Darstellungswerkzeugs "Punkt darstellen"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Ausdrücke erstellen, die die Grafik definieren.

  1. Erstellen Sie die mathematischen Ausdrücke, die zum Definieren der Grafik verwendet werden, indem Sie die mathematischen Funktionen im linken Bereich des Einstellungsfensters und die Werte (Werkzeug- und Jobdaten) im rechten Fensterbereich auswählen und dann eingeben. Um eine Funktion oder einen Wert im Formula Editor für Ausdrücke einzugeben, wählen Sie die Funktion oder den Wert aus, und drücken Sie die Eingabetaste, doppelklicken Sie auf die Funktion bzw. den Wert oder klicken Sie auf die Schaltfläche Einfügen.
  2. Nach dem Konstruieren der Ausdrücke, die die im Bild dargestellte Grafik definieren, werden von EasyBuilder die Daten verarbeitet und die Grafik erstellt.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Darstellungswerkzeugs "Punkt darstellen"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Darstellungswerkzeugs "Punkt darstellen" umfasst Folgendes:

  • Registerkarten "Allgemein" und "Einstellungen"
  • "Ausdruck"-Registerkarten "X" und "Y"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarten „Allgemein“ und „Einstellungen“

Ausdruck-Registerkarten „X“ und „Y“


Darstellungswerkzeug „Punkt darstellen“ – Registerkarten „Allgemein“ und „Einstellungen“

Geschlossen Registerkarte „Allgemein“
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Point_1“, sofern es sich um das erste Werkzeug „Punkt darstellen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Point_2“, „Point_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Geschlossen Registerkarte „Einstellungen“
Geschlossen Farbe

Definiert die Farbe der dargestellten Grafik. Die Standardfarbe ist die derzeit von anderen Werkzeugen im Job verwendete Farbe.

Geschlossen Ergebnis

Gibt die Ausgabe der Registerkarten „Ausdruck“ des Werkzeugs zurück; zeigt die Werte für X und Y des Punkts an.


Darstellungswerkzeug "Punkt darstellen" – "Ausdruck"-Registerkarten "X" und "Y"

Das Darstellungswerkzeug Punkt darstellen besteht aus den folgenden Registerkarten für den Ausdruck (mit gemeinsamen Steuerelementen) für das Erstellen der darzustellenden Grafik: "Ausdruck"-Registerkarten X und YBesitzt eine der Ausdruck-Registerkarten einen Fehlerstatus (#ERR), wird die Grafik nicht auf dem Bild dargestellt und es wird eine Fehlermeldung mit Informationen zu den fehlerhaften Ausdruck-Registerkarten angezeigt..

Hinweis: Diese Steuerelemente sind deaktiviert, während das In-Sight Vision-System online ist.
Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen und -daten erstellt. Geben Sie mathematische Funktionen oder Job-/Werkzeugdaten entweder mithilfe des Keyboards ein, oder verwenden Sie die Vision Tools-, Mathematik- und/oder Textansicht bzw. die Vision-Datenzugriffsansicht auf der linken Seite und die Symbol-Baumstruktur für Job- und Werkzeugdaten auf der rechten Seite, um diese Formel zusammenzusetzen. Geben Sie Elemente ein, indem Sie einen Doppelklick darauf durchführen oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis:
  • Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch "Job.MissingArg" ersetzt. Das Werkzeug gibt so lange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
  • Beim Erstellen von Formeln analysiert EasyBuilder Werkzeugnamen, die mit einer Zelladresse beginnen (e.g. A3_MyTool or P10_SortTool), nicht korrekt. Müssen für diese Werkzeuge Ausdrücke erstellt werden, benennen Sie das Werkzeug um, bevor Sie die Formel erstellen.
Geschlossen Vision Tool:

Die Struktur Vision Tools enthält zusätzliche Kantenfunktionen zum Erstellen des Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Kante, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Kante, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit mathematischen Funktionen

Die Struktur mit mathematischen Funktionen enthält mathematische Funktionen zum Erstellen Ihres Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Mathematik, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Mathematik, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit Textfunktionen

Die Struktur mit Textfunktionen enthält Funktionen zum Formatieren alphanumerischer Daten für die Anzeige und zur Kommunikation und kann zur Konstruktion des Ausdrucks verwendet werden. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Textstruktur, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Textstruktur, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Datenzugriff

Die Struktur Datenzugriff enthält zusätzliche Daten, die standardmäßig nicht verfügbar sind und zur Konstruktion des Ausdrucks verwendet werden können. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Datenzugriff, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Datenzugriff, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis:
  • Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
  • EasyBuilder unterstützt ausschließlich Datenzugriffsfunktionen für Blobs, Kanten und Muster.
Geschlossen Struktur mit Symbolen für Job- und Werkzeugdaten

Die Struktur mit Symbolen für Job- und Werkzeugdaten enthält die Datenausgabe von Positions- und/oder Inspektionswerkzeugen sowie Eingangsleitungen und Jobdaten, wie Bildaufnahmeparameter. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt drei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
  • Geben Sie den Namen des gewünschten symbolischen Verweises über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche "Einfügen"

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Wählen Sie eine mathematische Funktion oder ein Symbol aus, und klicken Sie anschließend auf die Schaltfläche Einfügen, um die Funktion bzw. das Symbol in den Ausdruck einzufügen.

Hinweis: Dieses Steuerelement wird in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, ist die Schaltfläche Einfügen aktiviert.
Geschlossen Schaltflächen für öffnende und schließende Klammern sowie für Kommas

Die Schaltflächen für öffnende Klammern, Kommas und schließende Klammern werden zum Erstellen mathematischer Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um eine Klammer oder ein Komma einzufügen.

Hinweis: Diese Steuerelemente werden in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, sind die Schaltflächen aktiviert.


Darstellungswerkzeuge – Bereich darstellen

Das Darstellungswerkzeug „Bereich darstellen“ wird verwendet, um einen Kreis grafisch auf dem Bild darzustellen, basierend auf mathematischen Ausdrücken, die die Werte für X, Y, Höhe, Breite, Winkel und Kurve des Bereichs definieren. Das Werkzeug stellt die Grafik auf dem Bild dar und gibt die Werte zurück, die die Position, Form und Größe des Bereichs definieren.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Darstellungswerkzeugs "Rechteck darstellen"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Ausdrücke erstellen, die die Grafik definieren.

  1. Erstellen Sie die mathematischen Ausdrücke, die zum Definieren der Grafik verwendet werden, indem Sie die mathematischen Funktionen im linken Bereich des Einstellungsfensters und die Werte (Werkzeug- und Jobdaten) im rechten Fensterbereich auswählen und dann eingeben. Um eine Funktion oder einen Wert im Formula Editor für Ausdrücke einzugeben, wählen Sie die Funktion oder den Wert aus, und drücken Sie die Eingabetaste, doppelklicken Sie auf die Funktion bzw. den Wert oder klicken Sie auf die Schaltfläche Einfügen.
  2. Nach dem Konstruieren der Ausdrücke, die die im Bild dargestellte Grafik definieren, werden von EasyBuilder die Daten verarbeitet und die Grafik erstellt.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Darstellungswerkzeugs "Rechteck darstellen"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Darstellungswerkzeugs "Rechteck darstellen" umfasst Folgendes:

  • Registerkarten "Allgemein" und "Einstellungen"
  • "Ausdruck"-Registerkarten "X", "Y", "Höhe", "Breite", "Winkel" und "Krümmung"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarten „Allgemein“ und „Einstellungen“

Ausdruck-Registerkarten X, Y, Höhe, Breite, Winkel und Krümmung


Darstellungswerkzeug „Bereich darstellen“ – Registerkarten „Allgemein“ und „Einstellungen“

Geschlossen Registerkarte „Allgemein“
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Region_1“, sofern es sich um das erste Werkzeug „Bereich darstellen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Region_2“, „Region_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Geschlossen Registerkarte „Einstellungen“
Geschlossen Farbe

Definiert die Farbe der dargestellten Grafik. Die Standardfarbe ist die derzeit von anderen Werkzeugen im Job verwendete Farbe.

Geschlossen Ergebnis

Gibt die Ausgabe der Registerkarten „Ausdruck“ des Werkzeugs zurück; zeigt die Werte für X, Y, Höhe, Breite, Winkel und Kurve des Bereichs an.


Darstellungswerkzeug "Bereich darstellen" – "Ausdruck"-Registerkarten "X", "Y", "Höhe", "Breite", "Winkel" und "Krümmung"

Das Darstellungswerkzeug Bereich darstellen besteht aus den folgenden Registerkarten für den Ausdruck (mit gemeinsamen Steuerelementen) für das Erstellen der darzustellenden Grafik: "Ausdruck"-Registerkarten X, Y, Höhe, Breite, Winkel und Krümmung Die "Ausdruck"-Registerkarte X definiert die Position des ersten Scheitelpunktes vom Bereich. Die "Ausdruck"-Registerkarte Y definiert die Position des anderen Scheitelpunktes vom Bereich. Die "Ausdruck"-Registerkarte Höhe definiert das Maß des Bereichs entlang der positiven x-Achse. Die "Ausdruck"-Registerkarte Breite definiert das Maß des Bereichs entlang der positiven y-Achse. Die 'Ausdruck'-Registerkarte Winkel definiert den Winkel des Bereichs (in Grad) von der positiven x-Achse bis zur ersten Kante des Bereichs gerechnet. Schließlich definiert die "Ausdruck"-Registerkarte Krümmung den Winkel (in Grad) zwischen der zwei Seitenkanten des Bereichs.Besitzt eine der Ausdruck-Registerkarten einen Fehlerstatus (#ERR), wird die Grafik nicht auf dem Bild dargestellt und es wird eine Fehlermeldung mit Informationen zu den fehlerhaften Ausdruck-Registerkarten angezeigt.

Hinweis: Diese Steuerelemente sind deaktiviert, während das In-Sight Vision-System online ist.
Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen und -daten erstellt. Geben Sie mathematische Funktionen oder Job-/Werkzeugdaten entweder mithilfe des Keyboards ein, oder verwenden Sie die Vision Tools-, Mathematik- und/oder Textansicht bzw. die Vision-Datenzugriffsansicht auf der linken Seite und die Symbol-Baumstruktur für Job- und Werkzeugdaten auf der rechten Seite, um diese Formel zusammenzusetzen. Geben Sie Elemente ein, indem Sie einen Doppelklick darauf durchführen oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis:
  • Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch "Job.MissingArg" ersetzt. Das Werkzeug gibt so lange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
  • Beim Erstellen von Formeln analysiert EasyBuilder Werkzeugnamen, die mit einer Zelladresse beginnen (e.g. A3_MyTool or P10_SortTool), nicht korrekt. Müssen für diese Werkzeuge Ausdrücke erstellt werden, benennen Sie das Werkzeug um, bevor Sie die Formel erstellen.
Geschlossen Vision Tool:

Die Struktur Vision Tools enthält zusätzliche Kantenfunktionen zum Erstellen des Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Kante, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Kante, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit mathematischen Funktionen

Die Struktur mit mathematischen Funktionen enthält mathematische Funktionen zum Erstellen Ihres Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Mathematik, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Mathematik, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit Textfunktionen

Die Struktur mit Textfunktionen enthält Funktionen zum Formatieren alphanumerischer Daten für die Anzeige und zur Kommunikation und kann zur Konstruktion des Ausdrucks verwendet werden. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Textstruktur, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Textstruktur, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Datenzugriff

Die Struktur Datenzugriff enthält zusätzliche Daten, die standardmäßig nicht verfügbar sind und zur Konstruktion des Ausdrucks verwendet werden können. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Datenzugriff, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Datenzugriff, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis:
  • Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
  • EasyBuilder unterstützt ausschließlich Datenzugriffsfunktionen für Blobs, Kanten und Muster.
Geschlossen Struktur mit Symbolen für Job- und Werkzeugdaten

Die Struktur mit Symbolen für Job- und Werkzeugdaten enthält die Datenausgabe von Positions- und/oder Inspektionswerkzeugen sowie Eingangsleitungen und Jobdaten, wie Bildaufnahmeparameter. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt drei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
  • Geben Sie den Namen des gewünschten symbolischen Verweises über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche "Einfügen"

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Wählen Sie eine mathematische Funktion oder ein Symbol aus, und klicken Sie anschließend auf die Schaltfläche Einfügen, um die Funktion bzw. das Symbol in den Ausdruck einzufügen.

Hinweis: Dieses Steuerelement wird in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, ist die Schaltfläche Einfügen aktiviert.
Geschlossen Schaltflächen für öffnende und schließende Klammern sowie für Kommas

Die Schaltflächen für öffnende Klammern, Kommas und schließende Klammern werden zum Erstellen mathematischer Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um eine Klammer oder ein Komma einzufügen.

Hinweis: Diese Steuerelemente werden in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, sind die Schaltflächen aktiviert.


Darstellungswerkzeuge – Zeichenfolge darstellen

Das Darstellungswerkzeug „Zeichenfolge darstellen“ wird verwendet, um eine Textzeichenfolge grafisch auf dem Bild darzustellen, basierend auf mathematischen Ausdrücken, die die Zeichenfolge und die Werte für die X- und Y-Position der Zeichenfolge definieren. Das Werkzeug stellt die Grafik auf dem Bild dar und gibt die Werte zurück, die den X/Y-Position der Zeichenfolge definieren.

Hinweis: Das Werkzeug gibt die Ergebnisse in Pixeln zurück, sofern das Bild nicht im Anwendungsschritt „Bild einrichten“ in reellen Einheiten kalibriert wurde (In-Sight Vision-Systeme) oder im Anwendungsschritt „Bild einrichten“ die Option Betrachtungsfeld (Breite) auf reelle Einheiten gesetzt wurde (Vision-Sensoren der In-Sight 2000-Serie).

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Darstellungswerkzeugs "Text darstellen"

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Ausdrücke erstellen, die die Grafik definieren.

  1. Erstellen Sie die mathematischen Ausdrücke, die zum Definieren der Grafik verwendet werden, indem Sie die mathematischen Funktionen im linken Bereich des Einstellungsfensters und die Werte (Werkzeug- und Jobdaten) im rechten Fensterbereich auswählen und dann eingeben. Um eine Funktion oder einen Wert im Formula Editor für Ausdrücke einzugeben, wählen Sie die Funktion oder den Wert aus, und drücken Sie die Eingabetaste, doppelklicken Sie auf die Funktion bzw. den Wert oder klicken Sie auf die Schaltfläche Einfügen.
  2. Nach dem Konstruieren der Ausdrücke, die die im Bild dargestellte Grafik definieren, werden von EasyBuilder die Daten verarbeitet und die Grafik erstellt.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Darstellungswerkzeugs "Text darstellen"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Darstellungswerkzeugs "Text darstellen" umfasst Folgendes:

  • Registerkarten "Allgemein" und "Einstellungen"
  • Registerkarte "Ausdruck"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarten „Allgemein“ und „Einstellungen“

Ausdruck-Registerkarten „X“, „Y“ und „Zeichenfolge“


Darstellungswerkzeug „Zeichenfolge darstellen“ – Registerkarten „Allgemein“ und „Einstellungen“

Geschlossen Registerkarte „Allgemein“
Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „String_1“, sofern es sich um das erste Werkzeug „Zeichenfolge darstellen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „String_2“, „String_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.

Geschlossen Registerkarte „Einstellungen“
Geschlossen Ergebnis

Gibt die Ausgabe der Registerkarten „Ausdruck“ des Werkzeugs zurück; zeigt die Zeichenfolge und deren X- und Y-Werte an.

Geschlossen Farbe

Definiert die Farbe der dargestellten Grafik. Die Standardfarbe ist die derzeit von anderen Werkzeugen im Job verwendete Farbe.

Geschlossen Name der Schriftart

Definiert den Schrifttyp, der für die Zeichenfolgengrafik verwendet wird; standardmäßig ist Ariel ausgewählt.

Geschlossen Schriftschnitt

Definiert den Stil (Normal, Kursiv, Fett oder Fett kursiv) der Schriftart, die für die Zeichenfolgengrafik verwendet wird; standardmäßig ist der Schriftschnitt „Normal“.

Geschlossen Schriftgröße

Definiert die Größe der Schriftart, die für die Zeichenfolgengrafik verwendet wird; standardmäßig ist die Schriftgröße auf 9 Punkte festgelegt.


Darstellungswerkzeug "Zeichenfolge darstellen" – "Ausdruck"-Registerkarten "X", "Y" und "Zeichenfolge"

Das Darstellungswerkzeug Zeichenfolge darstellen besteht aus den folgenden Registerkarten für den Ausdruck (mit gemeinsamen Steuerelementen) für das Erstellen der darzustellenden Grafik: "Ausdruck"-Registerkarten X, Y und Zeichenfolge. Besitzt eine der Ausdruck-Registerkarten einen Fehlerstatus (#ERR), wird die Grafik nicht auf dem Bild dargestellt und es wird eine Fehlermeldung mit Informationen zu den fehlerhaften Ausdruck-Registerkarten angezeigt.

Hinweis: Diese Steuerelemente sind deaktiviert, während das In-Sight Vision-System online ist.
Geschlossen Ausdruck

Mithilfe des Textfelds Ausdruck wird eine mathematische Formel zur Verarbeitung von Werkzeugergebnissen und -daten erstellt. Geben Sie mathematische Funktionen oder Job-/Werkzeugdaten entweder mithilfe des Keyboards ein, oder verwenden Sie die Vision Tools-, Mathematik- und/oder Textansicht bzw. die Vision-Datenzugriffsansicht auf der linken Seite und die Symbol-Baumstruktur für Job- und Werkzeugdaten auf der rechten Seite, um diese Formel zusammenzusetzen. Geben Sie Elemente ein, indem Sie einen Doppelklick darauf durchführen oder indem Sie sie markieren und auf die Schaltfläche Einfügen klicken.

Hinweis:
  • Falls der Ausdruck auf ein gelöschtes Werkzeug verweist, wird der entsprechende Verweis in der Formel automatisch durch "Job.MissingArg" ersetzt. Das Werkzeug gibt so lange eine Fehlermeldung aus, bis der Verweis korrigiert wird.
  • Beim Erstellen von Formeln analysiert EasyBuilder Werkzeugnamen, die mit einer Zelladresse beginnen (e.g. A3_MyTool or P10_SortTool), nicht korrekt. Müssen für diese Werkzeuge Ausdrücke erstellt werden, benennen Sie das Werkzeug um, bevor Sie die Formel erstellen.
Geschlossen Vision Tool:

Die Struktur Vision Tools enthält zusätzliche Kantenfunktionen zum Erstellen des Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Kante, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Kante, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit mathematischen Funktionen

Die Struktur mit mathematischen Funktionen enthält mathematische Funktionen zum Erstellen Ihres Ausdrucks. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Mathematik, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Mathematik, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Struktur mit Textfunktionen

Die Struktur mit Textfunktionen enthält Funktionen zum Formatieren alphanumerischer Daten für die Anzeige und zur Kommunikation und kann zur Konstruktion des Ausdrucks verwendet werden. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Textstruktur, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Textstruktur, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Datenzugriff

Die Struktur Datenzugriff enthält zusätzliche Daten, die standardmäßig nicht verfügbar sind und zur Konstruktion des Ausdrucks verwendet werden können. Es gibt drei Möglichkeiten, dem Ausdruck Funktionen hinzuzufügen:

  • Erweitern Sie die Struktur Datenzugriff, wählen Sie die gewünschte Funktion aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur Datenzugriff, und doppelklicken Sie auf die gewünschte Funktion.
  • Geben Sie den Namen der gewünschten Funktion über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis:
  • Die Liste der verfügbaren Funktionen hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der keine mathematische Funktion hinzugefügt werden kann, sind diese Funktionen nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
  • EasyBuilder unterstützt ausschließlich Datenzugriffsfunktionen für Blobs, Kanten und Muster.
Geschlossen Struktur mit Symbolen für Job- und Werkzeugdaten

Die Struktur mit Symbolen für Job- und Werkzeugdaten enthält die Datenausgabe von Positions- und/oder Inspektionswerkzeugen sowie Eingangsleitungen und Jobdaten, wie Bildaufnahmeparameter. Die Job- und Werkzeugdaten sind symbolische Verweise auf die darin enthaltenen Werte. Es gibt drei Möglichkeiten, dem Ausdruck Symbole hinzuzufügen:

  • Erweitern Sie die Struktur, wählen Sie den gewünschten symbolischen Verweis aus, und klicken Sie anschließend auf die Schaltfläche Einfügen.
  • Erweitern Sie die Struktur, und doppelklicken Sie auf den gewünschten symbolischen Verweis.
  • Geben Sie den Namen des gewünschten symbolischen Verweises über die Tastatur direkt in das Textfeld des Ausdrucks ein.
Hinweis: Die Liste der verfügbaren hängt von der Position des Cursors im Ausdruck ab. Befindet sich der Cursor an einer Stelle im Ausdruck, an der kein Symbol hinzugefügt werden kann, sind diese Symbole nicht verfügbar und werden erst wieder angezeigt, wenn sich der Cursor an einer entsprechenden Stelle befindet.
Geschlossen Schaltfläche "Einfügen"

Mit der Schaltfläche Einfügen werden mathematische Funktionen und Symbole in den Ausdruck eingefügt. Wählen Sie eine mathematische Funktion oder ein Symbol aus, und klicken Sie anschließend auf die Schaltfläche Einfügen, um die Funktion bzw. das Symbol in den Ausdruck einzufügen.

Hinweis: Dieses Steuerelement wird in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, ist die Schaltfläche Einfügen aktiviert.
Geschlossen Schaltflächen für öffnende und schließende Klammern sowie für Kommas

Die Schaltflächen für öffnende Klammern, Kommas und schließende Klammern werden zum Erstellen mathematischer Formeln verwendet. Klicken Sie auf die entsprechende Schaltfläche, um eine Klammer oder ein Komma einzufügen.

Hinweis: Diese Steuerelemente werden in Verbindung mit der Struktur mit mathematischen Funktionen und der Symbol-Baumstruktur für Job- und Werkzeugdaten verwendet. Wenn das in einer der Listen ausgewählte Element an der aktuellen Cursorposition im Textfeld Ausdruck eingefügt werden kann, sind die Schaltflächen aktiviert.


Bildfilterwerkzeuge – Filtern

Hinweis: Dieses Werkzeug ist nur in In-Sight Vision-Systemen mit In-Sight Firmware 5.1.0 und höher verfügbar. Eine vollständige Liste der Modelle und der unterstützten Firmwareversionen finden Sie unter Firmwareversionen.

Das Filterwerkzeug Bild filtern filtert einen Bereich des Bildes mit lokalen als auch globalen Bildverbesserungstechnologie und gibt ein Werkzeugbild aus, auf das von anderen Positions- oder Inspektionswerkzeugen verwiesen werden kann.

Das Filterwerkzeug Bild filtern ist ein Mehrzweckfilter und fertigt ein Farb- oder Graustufen-Ausgabebild an, das Bilder mit geringem Kontrast verbessert oder Eigenschaften in einem Bild hervorhebt. Dieses Werkzeug unterstützt das Hervorheben erwünschter und das Minimieren unerwünschter Merkmale bei den meisten Teilen. Bei einer effektiven Nutzung des Werkzeugs werden Inspektionsanwendungen zuverlässiger und wiederholbar.

Das Filterwerkzeug Bild filtern enthält eine ganze Palette lokaler und globaler Bildverbesserungstechnologien; die Bildverbesserungstechnologie wird durch die Auswahl eines Filterart definiert.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Bildfilterwerkzeugs

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereich konfigurieren, der den Bildbereich definiert, der verbessert werden soll.

  1. Bei der Positionierung des Bereichs müssen die Grenzen den Bildbereich einschließen, der gefiltert werden soll. Wenn der Bereich Flächen enthält, die nicht gefiltert werden sollen, können die Ergebnisse ungenau werden. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, stellen Sie sicher, dass sich der zu filternde Bereich in allen Bildern in etwa an derselben Position befindet.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem zu Beginn konfigurierten Werkzeug verschiedene Bilder und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Bildfilterwerkzeugs

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Filterwerkzeugs Bild filtern umfasst die folgenden Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“


Bildfilterwerkzeug „Filter“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Filter_1“, sofern es sich um das erste Bildfilterwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Filter_2“, „Filter_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Bildfilterwerkzeug – Registerkarte "Einstellungen"

Geschlossen Filterart

Definiert die Bildverbesserungstechnologie, die in diesem Bereich angewendet wird. Das Ergebnis der Bildverbesserungstechnologie wird automatisch in dem Bereich aktualisiert.

Filterart | Beschreibung
Binarisieren (standard)

Filtert das Bild anhand eines Graustufen-Schwellenwerts in Weiß (255) oder Schwarz (0). Gibt ein Bild aus, bei dem Eingabepixelwerte, die dem Schwellenwert entsprechen oder darüber liegen, weiß sind, während Werte unterhalb des Schwellenwerts schwarz angezeigt werden.

Hinweis: Wenn ein Eingangsbild in Farbe verwendet wird, erscheint das Ausgabebild in Graustufen.
Bottom Hat

Filtert alle Merkmale mit Ausnahme von dunklen Merkmalen, die kleiner als die Filtergröße sind, heraus. Gibt ein Bild aus, das dunkle Merkmale als helle Pixel auf einem dunklen Hintergrund anzeigt.

Hinweis: Dieses Verfahren aktiviert die Parameter Kernel-Reihen und Kernel-Spalten. Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein.
Abschneiden

Filtert das Bild durch Vergleichen des Graustufenwerts jedes einzelnen Pixels mit einem minimalen und einem maximalen Graustufenwert. Gibt ein Bild aus, bei dem die Extreme des Graustufenspektrums eliminiert sind, wodurch die Merkmale einheitlicher sind.
Schließen

Filtert dunkle Merkmale heraus, die kleiner als die Filtergröße sind. Gibt ein Bild mit einer insgesamt leicht erhöhten Helligkeit aus.

Hinweis: Dieses Verfahren aktiviert die Parameter Kernel-Reihen und Kernel-Spalten. Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein.
Dilatation

Vergrößert helle Merkmale und verkleinert dunkle Merkmale. Gibt ein Bild mit größeren Bereichen heller Pixel aus. Dieser Filter eignet sich zum Entfernen dunkler Stellen und Flecken.

Hinweis: Dieses Verfahren aktiviert die Parameter Kernel-Reihen und Kernel-Spalten. Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein.
Kantengerüst

Filtert dunkle und helle Merkmale heraus. Gibt ein Bild aus, bei dem die Kanten als helle Pixel dargestellt werden. Diese Operation berücksichtigt diagonale Kanten und ist langsamer als die Operation "Vollständiger Gradient".

Hinweis: Dieses Verfahren aktiviert die Parameter Kernel-Reihen und Kernel-Spalten. Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein.
Ausgleichen | Filtert anhand eines Histogrammausgleichs, bei dem die häufigsten Graustufenwerte ausgeglichen werden, um eine gleichmäßigere Verteilung zu erzielen. Gibt ein Bild mit erhöhtem Kontrast aus.
Erosion

Vergrößert dunkle Merkmale und verkleinert helle Merkmale. Gibt ein Bild mit größeren Bereichen dunkler Pixel aus. Dieser Filter eignet sich zum Entfernen heller Stellen und Flecken.

Hinweis: Dieses Verfahren aktiviert die Parameter Kernel-Reihen und Kernel-Spalten. Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein.
Schwarze Löcher füllen | Dunkle Pixel, die von hellen Pixeln umgeben sind, werden in helle Pixel umgewandelt. Gibt ein Bild aus, in dem die dunklen Löcher gefüllt sind.
Helle Löcher füllen | Helle Pixel, die von dunklen Pixeln umgeben sind, werden in dunkle Pixel umgewandelt. Gibt ein Bild aus, in dem die hellen Löcher gefüllt sind.
Vollständiger Gradient | Filtert vertikale und horizontale Kantenmerkmale heraus. Gibt ein Bild aus, bei dem die vertikalen und horizontalen Kanten als helle Pixel dargestellt werden. Diese Operation berücksichtigt keine diagonalen Kanten, ist aber schneller als die Operation "Kantengerüst".
Horizontaler Gradient | Filtert horizontale Kantenmerkmale heraus. Gibt ein Bild aus, bei dem die horizontalen Kanten als helle Pixel dargestellt werden.
Vertikaler Gradient | Filtert vertikale Kantenmerkmale heraus. Gibt ein Bild aus, bei dem die vertikalen Kanten als helle Pixel dargestellt werden.
Graustufenabstand

Filtert das Bild anhand des Graustufenwerts jedes Ausgabepixels als Differenz zwischen dem Graustufenwert jedes Eingabepixels und dem Schwellenwert. Gibt ein Bild aus, bei dem beispielsweise ein Eingabepixelwert von 100 und ein Schwellenwert von 25 einen Ausgabepixelwert von 75 ergeben.
Hochpassfilter

Filtert Kantenmerkmale heraus und unterdrückt andere Merkmale. Gibt ein Bild aus, in dem Kanten in Relation zu Bereichen mit gleichmäßigerem Graustufenverlauf hervorgehoben werden.

Hinweis: Dieses Verfahren aktiviert die Parameter Kernel-Reihen und Kernel-Spalten. Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein.
Invertiert | Filtert das Bild anhand einer Graustufeninvertierung der Pixelwerte. Gibt ein Bild aus, das ein "Negativ" des Eingabebilds ist.
Lokaler Median

Beschreibt ein Verfahren, das den mittleren Pixelwert der Pixelwerte in der Kernelumgebung berechnet und dieses Ergebnis als Pixelwert für das Ausgabebild verwendet.

Hinweis: Dieses Verfahren aktiviert die Parameter Kernel-Reihen und Kernel-Spalten. Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein.
Lokaler Median normalisiert

Beschreibt eine Möglichkeit, den Hintergrund aus einem Bild zu entfernen. Dieses Verfahren entfernt den lokalen Median des Eingangsbildes vom Eingabebild, verschiebt das Ergebnis genau um eins und addiert 128, um den Ausgabepixelwert zu erzeugen.

Hinweis: Dieses Verfahren aktiviert die Parameter Kernel-Reihen und Kernel-Spalten. Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein.
Tiefpassfilter

Filtert Kantenmerkmale heraus und macht die Kante mit anderen Merkmalen unscharf. Gibt ein Bild aus, in dem Kanten geglättet oder unscharf sind.

Hinweis: Dieses Verfahren aktiviert die Parameter Kernel-Reihen und Kernel-Spalten. Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein.
Maximum (Top Hat/Bot Hat)

Beschreibt ein Verfahren, das ein Maximum an Top Hat und Bottom Hat verwendet.

Hinweis: Dieses Verfahren aktiviert die Parameter Kernel-Reihen und Kernel-Spalten. Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein.
Öffnen

Filtert helle Merkmale aus, die kleiner als die Filtergröße sind und ergibt ein Ausgabebild mit einer etwas geringeren Helligkeitsstufe.

Hinweis: Dieses Verfahren aktiviert die Parameter Kernel-Reihen und Kernel-Spalten. Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein.
Optische Dichte

Filtert das Bild anhand einer Invertierung der Pixelwerte über eine logarithmische Skala. Gibt ein Bild aus, das die Dichte von Objekten und Merkmalen durch Messung der Lichtmenge aufzeigt, die sie durchströmt. Dichtere Objekte und Merkmale werden im Ausgabebild durch hellere Pixel dargestellt.
Schärfen

Beschreibt ein "Schärfeverfahren“, das zur Verstärkung von Kanten verwendet wird. Das Verfahren wertet den Kontrast zwischen benachbarten Pixeln aus und erhöht den Kontrast, wenn der Kontrast stark ist. Ein starker Kontrast zwischen benachbarten Pixeln gibt normalerwiese eine Kante wieder. Dieses Verfahren sollte jedoch nicht zur Ermittlung von Kanten verwendet werden. Die Ergebnisse dieses Verfahrens hängen vom Bildinhalt und seiner Auflösung ab

  • Der Verstärkungs-Parameter bestimmt die Stärke der Schärfung. Der Filter wird darauf ausgerichtet, eine bestimmte Differenz zwischen Pixeln beim Schärfen zu ignorieren, um schwach strukturierte Bereiche nicht übermäßig zu Schärfen.
Dehnen | Filtert das Bild durch lineares Skalieren oder "Dehnen" der Graustufenwerte. Gibt ein Bild mit erhöhtem Kontrast aus.
Schwellwertbereich

Filtert das Bild anhand eines binären (schwarz/weiß) Schwellenwerts, der jeden Eingabepixel mit zwei Schwellenwerten (Mindest- und Höchstwert) vergleicht, um zu bestimmen, ob der Ausgabepixel weiß oder schwarz ist. Bei der Bildausgabe sind alle Pixel weiß, deren Eingabepixelwerte dem Mindest- oder dem Höchstwert entsprechen oder diesen überschreiten, während alle Pixel schwarz sind, deren Werte im Bereich zwischen dem Mindest- und Höchstwert liegen.
Top Hat

Filtert alle Merkmale mit Ausnahme von hellen Merkmalen heraus, die kleiner als die Filtergröße sind. Gibt ein Bild aus, das helle Merkmale als helle Pixel auf einem dunklen Hintergrund anzeigt.

Hinweis: Dieses Verfahren aktiviert die Parameter Kernel-Reihen und Kernel-Spalten. Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein.
Geschlossen Kernel-Reihen

Gibt die Zahl der Reihen (1–25; standardmäßig = 3) des Kernels an. Ein Kernel ist eine rechteckige Anordnung von Zahlen, die die Verarbeitungsumgebung für Verfahren festlegt, die in jedem Pixelbereich eines Bildes durchgeführt werden. Die Graustufenwerte von benachbarten Pixeln legen den Graustufenwert für diese Pixelposition im Ausgabebild fest.

Hinweis:
  • Der Kernel ist nicht gewichtet.
  • Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein. Die Kernelgröße beträgt normalerweise 3 x 3, ist jedoch willkürlich.

Dieser Parameter ist aktiviert, wenn die Filterart auf eine der folgenden Arten eingestellt ist:

  • Bottom Hat
  • Verschließen
  • Erweitern
  • Kantenstärke
  • Erodieren
  • Hochpassfilter
  • Lokaler Median
  • Lokaler Median normalisiert
  • Tiefpassfilter
  • Maximum (Top Hat/Bot Hat)
  • Öffnen
  • Top Hat
Geschlossen Kernel-Spalten

Gibt die Zahl der Spalten (1–25; standardmäßig = 3) des Kernels an. Ein Kernel ist eine rechteckige Anordnung von Zahlen, die die Verarbeitungsumgebung für Verfahren festlegt, die in jedem Pixelbereich eines Bildes durchgeführt werden. Die Graustufenwerte von benachbarten Pixeln legen den Graustufenwert für diese Pixelposition im Ausgabebild fest.

Hinweis:
  • Der Kernel ist nicht gewichtet.
  • Der Kernel muss aus ungeraden ganzen Zahlen aufgebaut sein. Die Kernelgröße beträgt normalerweise 3 x 3, ist jedoch willkürlich.

Dieser Parameter ist aktiviert, wenn die Filterart auf eine der folgenden Arten eingestellt ist:

  • Bottom Hat
  • Verschließen
  • Erweitern
  • Kantenstärke
  • Erodieren
  • Hochpassfilter
  • Lokaler Median
  • Lokaler Median normalisiert
  • Tiefpassfilter
  • Maximum (Top Hat/Bot Hat)
  • Öffnen
  • Top Hat
Geschlossen Schwellwert-Modus

Gibt an, ob das Werkzeug automatisch einen Schwellwert festlegt, wenn die Filterart auf Binarisieren, Graustufenabstand oder Schwellwertbereich eingestellt ist.

  • Manuell: Aktiviert den Schwellwertparameter und bestimmt die Schwellwerte manuell.
  • Automatisch (Standard):
    • Wenn die Filterart auf Binarisieren eingestellt ist, berechnet das Werkzeug anhand der Graustufenwerte innerhalb eines angegebenen Bereichs automatisch einen Schwellwert.
    • Wenn die Filterart auf Graustufenabstand eingestellt ist, berechnet das Werkzeug anhand des durchschnittlichen Graustufenwerts innerhalb eines angegebenen Bereichs automatisch einen Schwellwert.
    • Wenn die Filterart auf Schwellwertbereich eingestellt ist, werden folgende Einstellungen angewendet:
      • Wenn die Pixelwerte geringer als die Minimumparametereinstellung oder größer als die Maximumparametereinstellung sind, werden die Pixelwerte als Hintergrund eingestellt.
      • Wenn die Pixelwerte zwischen den Minimum- und Maximumparametereinstellungen sind, werden die Pixelwerte als Vordergrund eingestellt.
Geschlossen Schwellwert

Gibt den Schwellwert an (0–255; standardmäßig = 128), wenn die Filterart auf Binarisieren, Graustufenabstand oder Schwellwertbereich gestellt ist.

Geschlossen Min

Gibt den minimalen Graustufenwert an (0–255; standardmäßig = 128), wenn die Filterart auf Abschneiden, Dehnen oder Schwellwertbereich gestellt ist.

Geschlossen Max

Gibt den maximalen Graustufenwert an (0–255; standardmäßig = 128), wenn die Filterart auf Abschneiden, Dehnen oder Schwellwertbereich gestellt ist.

Geschlossen Verstärkung

Definiert den Verstärkungswert (0–10; standardmäßig = 1), wenn die Filterart auf Schärfen gestellt ist. Dieser Parameter bestimmt die Stärke der Schärfung, indem die Höhe der Kantenkontrastverstärkung gesteuert wird. Pixels um eine Kante werden auf ihre Minimum- oder Maximumwerte gestellt, um Kanten schärfer abzubilden.

Geschlossen Glättung

Definiert den Glättungswert (1–4; standardmäßig = 1) des Gaußschen Kernels, wenn die Filterart auf Schärfen gestellt ist. Die Glättung steuert die Standardabweichung des Gaußschen Kernels. Höhere Glättungswerte führen zu einer größeren "Blende“ im Glättungsvorgang und helfen beim Schärfen von Merkmalen.

Hinweis: Gauß bezieht sich auf eine Glockenkurve, die als gewichteter Mittelwert auf die ROI-Pixel angewendet wird.


Bildfilterwerkzeuge – Punkt

Hinweis: Dieses Werkzeug wird nur in In-Sight Vision-Systemen mit In-Sight Firmware 4.x.x verfügbar und nicht in In-Sight Vision-Systemen mit In-Sight Firmware 5.1.0 und höher. Beachten Sie die Firmwareversionen für eine vollständige Liste aller Modelle und unterstützter Firmwareversionen.

Das Bildfilterwerkzeug Punkt filtert einen Bildbereich pixelweise mit einer "globalen" Bildverbesserungstechnik wie Schwellwertbildung, Invertieren, Entzerren, Abschneiden oder Strecken, und es gibt ein Werkzeugbild aus, auf das von anderen Positions- oder Inspektionswerkzeugen verwiesen werden kann.

Bei den "globalen" Bildverbesserungsoperationen werden den Ausgabepixeln Graustufenwerte zugewiesen. Diese basieren auf den Graustufenwerten der einzelnen Pixel im Werkzeugbereich.

Das Bildfilterwerkzeug Punkt eignet sich für Situationen, in denen Sie einen Bildbereich verbessern müssen, um ein Merkmal für eine Inspektion besser zu erkennen, beispielsweise beim Ausschneiden der Hotspots einer Oberfläche, um OCR-Zeichen besser zu lesen, oder beim Strecken der Merkmale eines Teils, um den Kontrast zu erhöhen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Bildfilterwerkzeugs "Punkt"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereich konfigurieren, der den Bildbereich definiert, der verbessert werden soll.

  1. Bei der Positionierung des Bereichs müssen die Grenzen den Bildbereich einschließen, der gefiltert werden soll. Wenn der Bereich Flächen enthält, die nicht gefiltert werden sollen, können die Ergebnisse ungenau werden. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, stellen Sie sicher, dass sich der zu filternde Bereich in allen Bildern in etwa an derselben Position befindet.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

Filterwerkzeuge für Bilder und Farbwerkzeuge – Werkzeugbild


Filterwerkzeuge für Bilder und Farbwerkzeuge – Werkzeugbild

Die Filterwerkzeuge für Bilder (Filter, Nachbar , Punkt, Szenenkorrektur, Farbe zu Graustufe, Farbe zu Binär, Umrechnen und Vergleichen) sowie die Farbwerkzeuge (Positionswerkzeuge Farb-Blob und Farb-Blobs (1-10), Farbpixelanzahl und Messungswerkzeuge An-/Abwesenheitswerkzeuge – Farb-Blob, Farb-Blob-Bereich und Farb-Blob-Bereiche (1-10), Zählwerkzeug Farb-Blobs, Identifizierungswerkzeug Farbmodell, Filterwerkzeuge für Bilder Farbe zu Binär) geben ein Bild aus, das als Werkzeugbild-Eingabe für Positions- und Inspektionswerkzeuge verwendet werden kann.

Die Einstellung Werkzeugbild befindet sich auf der Registerkarte Allgemein aller Werkzeuge, die ein anderes Bild als das Aufnahmebild akzeptieren, nachdem dem Job ein Werkzeug hinzugefügt wurde, das ein Werkzeugbild ausgibt. Anderenfalls erscheint sie als Dropdownmenüoption im Einstellungsfenster Richtung, wenn ein Werkzeug nach einem anderen Werkzeug hinzugefügt wird, das ein Werkzeugbild ausgibt.

Wird der Parameter für das Werkzeugbild eines Positions- oder Inspektionswerkzeugs für ein Werkzeug festgelegt, das ein Werkzeugbild ausgibt (ein Filterwerkzeug für Bilder verwendet möglicherweise auch ein anderes Filterwerkzeug für Bilder als Eingabe), führen diese Werkzeuge die Inspektion mithilfe des gefilterten Bildes durch, und ihre Bereiche müssen sich stets innerhalb der Grenzen des Werkzeugs befinden, das den Bereich für das Werkzeugbild ausgibt.

Wenn Sie den Parameter Werkzeugbild eines Werkzeugs auf ein Filterwerkzeug für Bilder einstellen möchten, fügen Sie zunächst ein Filterwerkzeug für Bilder hinzu und setzen Sie dann auf der Registerkarte Allgemein des vorherigen Werkzeugs den Parameter Werkzeugbild auf das neu hinzugefügte Filterwerkzeug für Bilder.

Hinweis: Nachdem dem Job ein Filterwerkzeug für Bilder oder ein Farbwerkzeug hinzugefügt wurde, das ein Werkzeugbild ausgibt, werden Sie jedes Mal, wenn ein neues Werkzeug hinzugefügt wird, das die Verwendung eines anderen Bilds als des Aufnahmebilds unterstützt, zur Festlegung des Eingabebilds des Werkzeugs im Einstellungsfenster im Gruppenfeld Richtung aufgefordert. Standardmäßig ist das zuletzt aufgenommene ungefilterte Bild ausgewählt.


Anpassen der Parameter des Bildfilterwerkzeugs "Punktfilter"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Bildfilterwerkzeugs "Punktfilter" enthält Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
  • Registerkarten "Vor" und "Nach"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarten „Vor“ und „Nach“


Bildfilterwerkzeug „Punkt“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Filter_1“, sofern es sich um das erste Bildfilterwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Filter_2“, „Filter_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Bildfilterwerkzeug Punkt – Registerkarte "Einstellungen"

Geschlossen Verfahren

Definiert die Bildverbesserungstechnologie, die in diesem Bereich angewendet wird. Das Ergebnis der Bildverbesserungstechnologie wird automatisch in dem Bereich aktualisiert.

Verfahren | Beschreibung
Binarisieren (Standard) | Filtert das Bild anhand eines Graustufen-Schwellenwerts in Weiß (255) oder Schwarz (0). Gibt ein Bild aus, bei dem Eingabepixelwerte, die dem Schwellenwert entsprechen oder darüber liegen, weiß sind, während Werte unterhalb des Schwellenwerts schwarz angezeigt werden.
Abschneiden | Filtert das Bild durch Vergleichen des Graustufenwerts jedes einzelnen Pixels mit einem minimalen und einem maximalen Graustufenwert. Gibt ein Bild aus, bei dem die Extreme des Graustufenspektrums eliminiert sind, wodurch die Merkmale einheitlicher sind.
Ausgleichen | Filtert anhand eines Histogrammausgleichs, bei dem die häufigsten Graustufenwerte ausgeglichen werden, um eine gleichmäßigere Verteilung zu erzielen. Gibt ein Bild mit erhöhtem Kontrast aus.
Graustufenabstand | Filtert das Bild anhand des Graustufenwerts jedes Ausgabepixels als Differenz zwischen dem Graustufenwert jedes Eingabepixels und dem Schwellenwert. Gibt ein Bild aus, bei dem beispielsweise ein Eingabepixelwert von 100 und ein Schwellenwert von 25 einen Ausgabepixelwert von 75 ergeben.
Invertiert | Filtert das Bild anhand einer Graustufeninvertierung der Pixelwerte. Gibt ein Bild aus, das ein "Negativ" des Eingabebilds ist.
Schwellwertbereich | Filtert das Bild anhand eines binären (schwarz/weiß) Schwellenwerts, der jeden Eingabepixel mit zwei Schwellenwerten (Mindest- und Höchstwert) vergleicht, um zu bestimmen, ob der Ausgabepixel weiß oder schwarz ist. Bei der Bildausgabe sind alle Pixel weiß, deren Eingabepixelwerte dem Mindest- oder dem Höchstwert entsprechen oder diesen überschreiten, während alle Pixel schwarz sind, deren Werte im Bereich zwischen dem Mindest- und Höchstwert liegen.
Optische Dichte | Filtert das Bild anhand einer Invertierung der Pixelwerte über eine logarithmische Skala. Gibt ein Bild aus, das die Dichte von Objekten und Merkmalen durch Messung der Lichtmenge aufzeigt, die sie durchströmt. Dichtere Objekte und Merkmale werden im Ausgabebild durch hellere Pixel dargestellt.
Dehnen | Filtert das Bild durch lineares Skalieren oder "Dehnen" der Graustufenwerte. Gibt ein Bild mit erhöhtem Kontrast aus.
Geschlossen Minimum

Definiert den minimalen Graustufenwert (0 bis 255) für die Verfahren Ausschneiden und Schwellwertbereich. Dieses Steuerelement ist nur aktiviert, wenn eines der beiden Verfahren ausgewählt wurde.

Geschlossen Maximum

Definiert den maximalen Graustufenwert (0 bis 255) für die Verfahren Ausschneiden und Schwellwertbereich. Dieses Steuerelement ist nur aktiviert, wenn eines der beiden Verfahren ausgewählt wurde.

Geschlossen Schwellwert-Modus

Definiert den Modus für die Bestimmung des Graustufenwerts, das den Bereich des Bildes in schwarze und weiße Pixel segmentiert, wenn das Verfahren auf Binarisieren, Graustufenabstand oder Schwellwertbereich eingestellt ist. Wenn Automatisch ausgewählt wurde (Standard = automatisch), erstellt das Werkzeug bei jeder Aufnahme eines Bildes anhand des Bildes eine Standard-Smart-Einstellung, die fortlaufend Änderungen in der Helligkeit von Bild zu Bild anpasst. Wurde Manuell ausgewählt, müssen die Werte manuell eingegeben und angepasst werden.

Geschlossen Schwellwert

Definiert den Graustufenwert, der für die Verfahren Binarisieren, Graustufenabstand und Schwellwertbereich schwarze Pixel von weißen trennt (0 – 255, falls aktiviert). Pixelwerte unterhalb des Schwellwerts werden als schwarz, Pixelwerte darüber als weiß klassifiziert. Dieses Steuerelement ist standardmäßig deaktiviert. Für seine Aktivierung muss der Schwellwertmodus auf "Manuell" eingestellt sein. Verwenden Sie das Diagramm, um einen optimalen Wert für Ihre Anwendung einzustellen.


Filterwerkzeug für Bilder „Punkt“ – Registerkarten „Vor“ und „Nach“

Auf den Registerkarten Vor und Nach wird ein Histogramm der Graustufenwerte für die Pixel in einem bestimmten Bereich angezeigt. Die Registerkarte Vor zeigt das Histogramm des Bildbereichs vor der Bearbeitung, während auf der Registerkarte Nach das Histogramm des Bereichs nach der Bearbeitung angezeigt wird.

  • Die X-Achse des Diagramms steht für die Gesamtzahl der Graustufenwerte (0 bis 255 oder insgesamt 256 Grauschattierungen).
  • Die Y-Achse des Diagramms gibt die Anzahl der Pixel eines bestimmten Graustufenwerts an. Zudem erfolgt die Skalierung durch Anzeige des Graustufenwerts mit der höchsten Anzahl an Pixeln.
  • Die grüne vertikale Linie steht für den Schwellenwert, mit dem der Bildbereich in schwarze und weiße Pixel aufgeteilt wird. Werte auf der linken Seite der Linie entsprechen schwarzen Pixeln und Werte auf der rechten Seite entsprechen weißen Pixeln.


Bildfilterwerkzeug – Nachbar

Hinweis: Dieses Werkzeug wird nur in In-Sight Vision-Systemen mit In-Sight Firmware 4.x.x verfügbar und nicht in In-Sight Vision-Systemen mit In-Sight Firmware 5.1.0 und höher. Beachten Sie die Firmwareversionen für eine vollständige Liste aller Modelle und unterstützter Firmwareversionen.

Das Bildfilterwerkzeug Nachbar filtert einen Bildbereich pixelweise mit einer entsprechenden Bildverbesserungstechnologie für benachbarte Pixel, wie Verkleinern, Erweitern, Ausfüllen, Glätten oder Kantenhervorheben, und gibt ein Werkzeugbild aus, auf das von anderen Positions- oder Inspektionswerkzeugen verwiesen werden kann.

Bei den Bildverbesserungsoperationen für benachbarte Pixel werden den Ausgabepixeln Graustufenwerte zugewiesen. Diese basieren auf den Graustufenwerten der benachbarten Pixel im Werkzeugbereich. Wie groß die Umgebung ist, bestimmen die Parameter "Zeilen filtern" und "Spalten filtern".

Das Bildfilterwerkzeug Nachbar eignet sich für Situationen, in denen Sie einen Bildbereich verbessern müssen, um ein Merkmal für eine Inspektion besser zu erkennen. So können Sie beispielsweise Blendungen von Metalloberflächen verkleinern, um einen Dot-Peen-Code besser lesen zu können, oder Sie können das helle Ende des Grauskalenspektrums ausweiten, um beim Lesen von OCR-Zeichen dunkle Flecken zu entfernen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Bildfilterwerkzeugs "Nachbar"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereich konfigurieren, der den Bildbereich definiert, der verbessert werden soll.

  1. Bei der Positionierung des Bereichs müssen die Grenzen den Bildbereich einschließen, der gefiltert werden soll. Wenn der Bereich Flächen enthält, die nicht gefiltert werden sollen, können die Ergebnisse ungenau werden. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, stellen Sie sicher, dass sich der zu filternde Bereich in allen Bildern in etwa an derselben Position befindet.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Bildfilterwerkzeugs "Nachbarfilter"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Bildfilterwerkzeugs "Nachbarfilter" enthält Folgendes:

  • Registerkarte "Allgemein"
  • Registerkarte "Einstellungen"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“


Bildfilterwerkzeug „Nachbar“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Filter_1“, sofern es sich um das erste Bildfilterwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Filter_2“, „Filter_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Filterwerkzeug für Bilder „Nachbar“ – Registerkarte „Einstellungen“

Geschlossen Funktion

Definiert die Bildverbesserungstechnik, die auf den Bereich angewendet wird. Das Ergebnis der Bildverbesserung wird automatisch in dem entsprechenden Bereich aktualisiert.

Funktion | Beschreibung
Bot Hat | Filtert alle Merkmale mit Ausnahme von dunklen Merkmalen, die kleiner als die Filtergröße sind, heraus. Gibt ein Bild aus, das dunkle Merkmale als helle Pixel auf einem dunklen Hintergrund anzeigt.
Schließen | Filtert dunkle Merkmale heraus, die kleiner als die Filtergröße sind. Gibt ein Bild mit einer insgesamt leicht erhöhten Helligkeit aus.
Dilatation | Vergrößert helle Merkmale und verkleinert dunkle Merkmale. Gibt ein Bild mit größeren Bereichen heller Pixel aus. Dieser Filter eignet sich zum Entfernen dunkler Stellen und Flecken.
Kantengerüst | Filtert dunkle und helle Merkmale heraus. Gibt ein Bild aus, bei dem die Kanten als helle Pixel dargestellt werden. Diese Operation berücksichtigt diagonale Kanten und ist langsamer als die Operation "Vollständiger Gradient".
Erosion | Vergrößert dunkle Merkmale und verkleinert helle Merkmale. Gibt ein Bild mit größeren Bereichen dunkler Pixel aus. Dieser Filter eignet sich zum Entfernen heller Stellen und Flecken.
Schwarze Löcher füllen | Dunkle Pixel, die von hellen Pixeln umgeben sind, werden in helle Pixel umgewandelt. Gibt ein Bild aus, in dem die dunklen Löcher gefüllt sind.
Helle Löcher füllen | Helle Pixel, die von dunklen Pixeln umgeben sind, werden in dunkle Pixel umgewandelt. Gibt ein Bild aus, in dem die hellen Löcher gefüllt sind.
Vertikaler Gradient | Filtert vertikale Kantenmerkmale heraus. Gibt ein Bild aus, bei dem die vertikalen Kanten als helle Pixel dargestellt werden.
Horizontaler Gradient | Filtert horizontale Kantenmerkmale heraus. Gibt ein Bild aus, bei dem die horizontalen Kanten als helle Pixel dargestellt werden.
Vollständiger Gradient | Filtert vertikale und horizontale Kantenmerkmale heraus. Gibt ein Bild aus, bei dem die vertikalen und horizontalen Kanten als helle Pixel dargestellt werden. Diese Operation berücksichtigt keine diagonale Kanten, ist aber schneller als die Operation "Kantengerüst".
Hochpass | Filtert Kantenmerkmale heraus und unterdrückt andere Merkmale. Gibt ein Bild aus, in dem Kanten in Relation zu Bereichen mit gleichmäßigerem Graustufenverlauf hervorgehoben werden.
Tiefpass (Standard) | Filtert Kantenmerkmale heraus und macht die Kante mit anderen Merkmalen unscharf. Gibt ein Bild aus, in dem Kanten geglättet oder unscharf sind.
Öffnen | Filtert helle Merkmale heraus, die kleiner als die Filtergröße sind. Gibt ein Bild mit einer insgesamt leicht geringeren Helligkeit aus.
Top Hat | Filtert alle Merkmale mit Ausnahme von hellen Merkmalen heraus, die kleiner als die Filtergröße sind. Gibt ein Bild aus, das helle Merkmale als helle Pixel auf einem dunklen Hintergrund anzeigt.
Geschlossen Zeilen filtern

Legt die Größe der Bildverarbeitungsumgebung in horizontaler Richtung fest.

Geschlossen Spalten filtern

Legt die Größe der Bildverarbeitungsumgebung in vertikaler Richtung fest.


Bildfilterwerkzeug – Szenenkorrektur

Hinweis: Dieses Werkzeug wird nur in In-Sight Vision-Systemen mit In-Sight Firmware 4.x.x verfügbar und nicht in In-Sight Vision-Systemen mit In-Sight Firmware 5.1.0 und höher. Beachten Sie die Firmwareversionen für eine vollständige Liste aller Modelle und unterstützter Firmwareversionen.

Das Bildfilterwerkzeug Szenenkorrektur filtert einen Bildbereich pixelweise mit einer entsprechenden Bildverbesserungstechnologie für benachbarte Pixel namens "Mittlere Intensität“ und gibt ein Werkzeugbild aus, auf das von anderen Positions- oder Inspektionswerkzeugen verwiesen werden kann.

Die Bildverbesserungstechnologie "Mittlere Intensität“ filtert Bilder basierend auf der Pixelintensität der Pixel innerhalb der Verarbeitungsumgebung, die wiederum von den Parametern Anzahl der Zeilen und Anzahl der Spalten festgelegt wird. Dieser Filter simuliert das Löschen von ungleichmäßiger Beleuchtung oder Schattierung aus einem Bild, indem der Intensitätswert jedes Pixels mit der durchschnittlichen Intensität der Pixel innerhalb der Verarbeitungsumgebung verglichen wird. Bildbereiche mit wenig oder keiner Schwankung werden als neutrales Grau gerendert, und zwar unabhängig von der ursprünglichen Intensität. Pixel, die dunkler als die sie umgebenden Pixel sind, werden in Relation zu ihrer Umgebung dunkler als das neutrale Grau schattiert. Ebenso werden Pixel, die heller als die sie umgebenden Pixel sind, heller als das neutrale Grau schattiert. Ähnlich wie bei der Operation "Hochpass“ bleiben Kanten und scharfe Übergänge erhalten.

Das Filterwerkzeug für Bilder Szenenkorrektur ist nützlich für Bilder mit ungleichmäßiger Beleuchtung oder Schattierung.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Filterwerkzeugs für Bilder „Szenenkorrektur“

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereich konfigurieren, der den Bildbereich definiert, der verbessert werden soll.

  1. Bei der Positionierung des Bereichs müssen die Grenzen den Bildbereich einschließen, der gefiltert werden soll. Wenn der Bereich Flächen enthält, die nicht gefiltert werden sollen, können die Ergebnisse ungenau werden. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, stellen Sie sicher, dass sich der zu filternde Bereich in allen Bildern in etwa an derselben Position befindet.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Filterwerkzeugs für Bilder „Szenenkorrektur“

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Filterwerkzeugs für Bilder „Szenenkorrektur“ umfasst die folgenden Registerkarten:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“


Bildfilterwerkzeug „Szenenkorrektur“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Filter_1“, sofern es sich um das erste Bildfilterwerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Filter_2“, „Filter_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Filterwerkzeug für Bilder „Szenenkorrektur“ – Registerkarte „Einstellungen“

Geschlossen Anzahl der Zeilen

Legt die Größe der Bildverarbeitungsumgebung (1 bis Max Bildhöhe; Standard = 11) in horizontaler Richtung fest.

Hinweis:
  • Der maximale Wert wird durch die maximale Größe des Bildbereichs des In-Sight-Vision-Systems festgelegt (z. B. 640 x 480, 1024 x 768 oder 1600 x 1200).
  • Für die Größe der Bildverarbeitungsumgebung können nur ungerade Werte eingetragen werden; bei Eingabe eines geraden Werts wird dieser automatisch abgerundet.
Geschlossen Anzahl der Spalten

Legt die Größe der Bildverarbeitungsumgebung (1 bis Max Bildbreite; Standard = 11) in vertikaler Richtung fest.

Hinweis:
  • Der maximale Wert wird durch die maximale Größe des Bildbereichs des In-Sight-Vision-Systems festgelegt (z. B. 640 x 480, 1024 x 768 oder 1600 x 1200).
  • Für die Größe der Bildverarbeitungsumgebung können nur ungerade Werte eingetragen werden; bei Eingabe eines geraden Werts wird dieser automatisch abgerundet.
Geschlossen Timeout

Definiert den Zeitraum in Millisekunden (0 bis 30000; Standard = 0), in dem das Werkzeug die Bildintensität berechnet, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird. Ist als Wert 0 festgelegt, wird dieser Parameter deaktiviert.


Filterwerkzeuge für Bilder – Farbe zu Graustufe

Das Bildfilterwerkzeug "Farbe zu Graustufe" filtert auf Grundlage des angegebenen Vorgangs einen Bildbereich, indem jeder Pixel eines Farbbildes in einen Graustufenwert umgewandelt wird. Es wird ein Werkzeugbild ausgegeben, auf das von anderen Positions- oder Inspektionswerkzeugen verwiesen werden kann.

Das Werkzeug Farbe zu Graustufe wandelt auf Grundlage eines einfachen Einfarbenparameters jeden Farbpixel im Bereich in einen Graustufenwert um: "reines" Rot, Grün oder Blau (RGB), Farbton, Sättigung oder Intensität (HSI), Leuchtdichte oder Interpolation des gewichteten Durchschnitts der RGB-Komponenten.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Bildfilterwerkzeugs "Farbe zu Graustufe"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereich konfigurieren, der den Bildbereich definiert, der verbessert werden soll.

  1. Bei der Positionierung des Bereichs müssen die Grenzen den Bildbereich einschließen, der gefiltert werden soll. Wenn der Bereich Flächen enthält, die nicht gefiltert werden sollen, können die Ergebnisse ungenau werden. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, stellen Sie sicher, dass sich der zu filternde Bereich in allen Bildern in etwa an derselben Position befindet.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Filterwerkzeugs für Bilder „Farbe zu Graustufen“

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Filterwerkzeugs für Bilder „Farbe zu Graustufen“ enthält folgende Elemente:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“


Filterwerkzeug für Bilder „Farbe zu Graustufen“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „ColorFilter_1“, sofern es sich um das erste Filterwerkzeug „Binär zu Farbe“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „ColorFilter_2“, „ColorFilter_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Filterwerkzeug für Bilder „Farbe zu Graustufen“ – Registerkarte „Einstellungen“

Geschlossen Funktion
Funktion | Beschreibung
Leuchtdichte (Standard) | Gibt ein Bild der Leuchtdichte aus. Die Leuchtdichte ist im Konzept eng mit der Intensität verwandt und ist ein Maß für die Lichtmenge, die von einem bestimmten Bereich abgegeben oder reflektiert wird. Je mehr Licht von einem Pixel im Eingabebild abgegeben wird, desto heller wird er im Ausgabebild angezeigt.
Rot | Gibt ein Bild aus, mit dem bis auf die rote Komponente (255,0,0) alle anderen Komponenten des Pixels herausgefiltert werden. Je höher der Rotwert eines Pixels ist, desto heller erscheint er im Ausgabebild.
Grün | Gibt ein Bild aus, mit dem bis auf die grüne Komponente (0,255,0) alle anderen Komponenten des Pixels herausgefiltert werden. Je höher der Grünwert eines Pixels ist, desto heller erscheint er im Ausgabebild.
Blau | Gibt ein Bild aus, mit dem bis auf die blaue Komponente (0,0,255) alle anderen Komponenten des Pixels herausgefiltert werden. Je höher der Blauwert eines Pixels ist, desto heller erscheint er im Ausgabebild.
Farbton | Gibt ein Bild aus, mit dem bis auf die Farbtonkomponente alle anderen Komponenten des Pixels herausgefiltert werden. Je höher der Farbtonwert eines Pixels ist, desto heller erscheint er im Ausgabebild.
Sättigung | Gibt ein Bild aus, mit dem bis auf die Sättigungskomponente alle anderen Komponenten des Pixels herausgefiltert werden. Je höher der Sättigungswert eines Pixels ist, desto heller erscheint er im Ausgabebild.
Intensität | Gibt ein Bild aus, das alle Komponenten bis auf die Intensitätskomponente des Pixels herausfiltert und mit dem die durchschnittliche Intensität der RGB-Komponenten ermittelt wird. Je höher der Intensitätswert eines Pixels ist, desto heller erscheint er im Ausgabebild.
Interpolation | Gibt einen Bildfilter aus, der Interpolation verwendet (ein gewichteter Durchschnitt der roten, grünen und blauen (RGB) Komponenten eines Pixels). Wie bei der Intensitätsfunktion werden bis auf die Intensitätskomponente alle anderen Komponenten des Pixels herausgefiltert. Je höher der Intensitätswert eines Pixels ist, desto heller erscheint er im Ausgabebild. Die Interpolation, die ein nicht standardisierter Konversionsfilter ist, ermittelt jedoch die gewichtete Durchschnittsintensität der RGB-Komponenten.


Filterwerkzeuge für Bilder – Farbe zu binär

Das Bildfilterwerkzeug "Farbe zu Binär" filtert einen Bildbereich, indem Pixel, die mit einem aktiven Farbmodell übereinstimmen, in Weiß und alle anderen Pixel in Schwarz umgewandelt werden. Es wird ein Werkzeugbild ausgegeben, auf das von einem anderen Speicherort oder anderen Inspektionswerkzeugen aus verwiesen werden kann.

Das Werkzeug Farbe zu binär verweist auf eine eingelernte Bibliothek von Farbmodellen und ermittelt anschließend die im Bereich vorhandene Anzahl von Pixeln, die mit dem ausgewählten und eingelernten Farbmodell in der Bibliothek übereinstimmen. Außerdem wird vom Werkzeug ein binäres Graustufenausgabebild erstellt, indem jedes Pixel, das mit einem aktiven Farbmodell übereinstimmt, auf Weiß (255) festgelegt wird. Alle anderen Pixel werden auf Schwarz (0) festgelegt.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Bildfilterwerkzeugs "Farbe zu binär"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereich konfigurieren, der den Bildbereich definiert, der verbessert werden soll.

  1. Bei der Positionierung des Bereichs müssen die Grenzen den Bildbereich einschließen, der gefiltert werden soll. Wenn der Bereich Flächen enthält, die nicht gefiltert werden sollen, können die Ergebnisse ungenau werden. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, stellen Sie sicher, dass sich der zu filternde Bereich in allen Bildern in etwa an derselben Position befindet.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Nach der Konfiguration des Suchbereichs müssen die Farbbibliothek des Werkzeugs konfiguriert und die entsprechenden Farbmodelle aktiviert werden:

    • Wurde das erste Mal ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“) hinzugefügt, müssen zunächst die Farbbibliotheken und die Farbmodelle definiert werden.

    • Wurde zuvor ein weiteres Farbwerkzeug hinzugefügt und sollen eine vorhandene Farbbibliothek und ihre eingelernten Farbmodelle verwendet werden, wählen Sie auf der Registerkarte "Einstellungen" die gewünschte Farbbibliothek, und aktivieren Sie anschließend mithilfe der Kontrollkästchen auf der Registerkarte "Bibliothek" die gewünschten Farbmodelle.

    • Wurde keine Farbbibliothek definiert, gibt das Werkzeug automatisch eine Fehlermeldung aus. Wurde eine Farbbibliothek definiert, wird sie automatisch vom Werkzeug verwendet und alle darin enthaltenen Farbmodelle werden aktiviert.

  4. Nachdem die Farbmodelle und die Farbbibliotheken festgelegt wurden, wird das Bild vom Werkzeug verarbeitet und alle Pixel innerhalb des Suchbereichs, die mit dem ausgewählten Farbmodell übereinstimmen, werden in die unbunte Farbe Weiß (255) umgewandelt. Die Pixel, die nicht mit dem ausgewählten Farbmodell übereinstimmen, erhalten die unbunte Farbe Schwarz (0).

  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Filterwerkzeugs für Bilder „Farbe zu binär“

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Filterwerkzeugs für Bilder „Farbe zu binär“ enthält folgende Elemente:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
  • Registerkarte „Farbbibliothek“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Farbbibliothek“


Filterwerkzeug für Bilder „Binär zu Farbe“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „ColorFilter_1“, sofern es sich um das erste Bildfilterwerkzeug „Binär zu Farbe“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „ColorFilter_2“, „ColorFilter_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Filterwerkzeug für Bilder „Farbe zu binär“ – Registerkarte „Einstellungen“

Geschlossen Farbe einlernen

Öffnet das Dialogfeld „ExtractColor – Einlernen“, das zur Definition der ausgewählten Farbmodelle der Farbbibliothek verwendet wird.

Geschlossen Farbbibliothek

Definiert die Farbbibliothek, auf die vom Tool verwiesen wird. Wählen Sie in der Dropdownliste die Farbbibliothek aus, die geändert werden soll, und klicken Sie auf die Schaltfläche Farbe einlernen, um das Dialogfeld „ExtractColor – Einlernen“ zu öffnen. Jede Farbbibliothek kann bis zu 100 unterschiedliche Farbmodelle enthalten, die aus individuellen Farben zusammengesetzt sind.

EasyBuilder-Jobs können maximal 5 Farbbibliotheken enthalten, die unter folgenden Werkzeugen aufgeteilt werden können:

  • Positionswerkzeug „Farb-Blob“
  • Positionswerkzeug „Farb-Blobs (1-10)“
  • An-/Abwesenheitswerkzeug „Farbpixelanzahl“
  • Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“
  • Messungswerkzeug „Farb-Blob-Bereich (1-10)“
  • Zählwerkzeug „Farb-Blobs“
  • Identifizierungswerkzeug „Farbmodell“
  • Filterwerkzeug für Bilder „Farbe zu binär“


Filterwerkzeug für Bilder „Farbe zu binär“ – Registerkarte „Farbbibliothek“

Geschlossen Liste Farbmodell

Zeigt eine schreibgeschützte Liste der Farbmodelle in der ausgewählten Übereinstimmungsfarbbibliothek an. Die Farbmodelle werden mittels der Kontrollkästchen neben dem Namen der Farbmodelle aktiviert oder deaktiviert.

Geschlossen Farbtabelle

Zeigt eine schreibgeschützte sortierte Liste der Farben der ausgewählten Farbbibliothek an.

Geschlossen Farbname

Zeigt die Namen der Farben im ausgewählten Farbmodell an.

Geschlossen RGB

Zeigt die RGB-Werte der Farben im ausgewählten Farbmodell an.

Geschlossen Funktion

Zeigt die Funktion der Farben (Hinzufügen oder Subtrahieren) im ausgewählten Farbmodell an.


Filterwerkzeuge für Bilder – Umrechnen

Das Bildfilterwerkzeug „Umrechnen“ filtert lineare, nicht lineare Verzerrung und/oder Linsenverzerrung aus einem Bildbereich und wendet die Umrechnung zwischen reellen Einheiten und Pixeln, die von der Rasterkalibrierung kalibriert wurden, im Schritt Bild einrichten an. Es wird ein Werkzeugbild ausgegeben, auf das von anderen Positions- und Inspektionswerkzeugen verwiesen werden kann.

Das Bildfilterwerkzeug "Umrechnen" arbeitet mit der Rasterkalibrierung im Schritt Bild einrichten zusammen, um optische Verzerrungen auszugleichen und zu korrigieren und exakte Maße zurückzugeben. Zudem werden Pixeleinheiten in echte Maßeinheiten (z. B. Millimeter oder Zoll) umgewandelt. Mit diesem Werkzeug und der Rasterkalibrierung können die Positionen von Objekten am Bildrand genauer ermittelt werden, und Sie erzielen mehr Flexibilität hinsichtlich der Befestigung. Das In-Sight-Vision-System kann so bis zu 45° zur Inspektionsoberfläche geneigt angebracht werden.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Bildfilterwerkzeugs "Umrechnen"

Hinweis: Vor dem Hinzufügen dieses Werkzeugs muss das Bild mit der Rasterkalibrierung im Schritt Bild einrichten kalibriert worden sein.

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereich konfigurieren, der den Bildbereich definiert, der verbessert werden soll.

  1. Bei der Positionierung des Bereichs müssen die Grenzen den Bildbereich einschließen, der gefiltert werden soll. Wenn der Bereich Flächen enthält, die nicht gefiltert werden sollen, können die Ergebnisse ungenau werden. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, stellen Sie sicher, dass sich der zu filternde Bereich in allen Bildern in etwa an derselben Position befindet.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Filterwerkzeugs für Bilder „Umrechnen“

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Filterwerkzeugs für Bilder „Umrechnen“ enthält folgende Elemente:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“


Filterwerkzeug für Bilder „Umrechnen“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Transform_1“, sofern es sich um das erste Bildfilterwerkzeug „Umrechnen“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Transform_2“, „Transform_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Filterwerkzeug für Bilder „Umrechnen“ – Registerkarte „Einstellungen“

Geschlossen Bildskalierung

Definiert die Skala, auf der das umgerechnete Bild angezeigt werden soll (0,01 bis 10, Standard = 1,0).

Geschlossen Referenzmittelpunkt

Definiert den Referenzpunkt für die Umrechnung. Der Referenzmittelpunkt (Standard) definiert den Referenzpunkt als Bildmittelpunkt. Die Bereichsmitte definiert den Referenzpunkt als Mitte des Bereichs.

Geschlossen Bild anzeigen

Definiert, ob anstelle des aufgenommenen Bildes das umgerechnete Bild angezeigt wird. Dieser Parameter ist standardmäßig aktiviert, und das umgerechnete Bild wird ständig angezeigt.

Hinweis: Andere Positions- und Inspektionswerkzeuge können weiterhin zur Inspektion aufgenommener Bilder verwendet werden, ohne dabei den Filter für die Umrechnung anwenden zu müssen. Die Grafiküberlagerungen können jedoch im Vergleich zum angezeigten umgerechneten Bild irrelevant erscheinen. Blenden Sie die Grafiküberlagerungen des Werkzeugs aus, indem Sie unter Job ausführen die Option Grafik anzeigen deaktivieren.


Filterwerkzeuge für Bilder – Vergleichen

Das Bildfilterwerkzeug "Vergleichen" filtert ein Bild anhand eines Vorlagenbildes und gibt ein Graustufenausgabebild aus, bei dem jedes Pixel den normalisierten Unterschied darstellt. Ein Werkzeugbild wird ausgegeben, auf das von anderen Positions- oder Inspektionswerkzeugen verwiesen werden kann.

Beim Bildverbesserungsprozess "Vergleichen" werden die Pixel des Vorlagenbildes zu Vergleichszwecken dem Eingabebild zugewiesen. Ein Graustufenausgabebild wird erstellt, bei dem Pixel, die nicht mit dem Vorlagenbild übereinstimmen, als weiße Pixel angezeigt werden.

Das Bildfilterwerkzeug "Vergleichen" ist hilfreich, wenn während des Herstellungsprozesses Fehler in einem Teil oder einem Objekt ermittelt werden sollen. Das Bildfilterwerkzeug "Vergleichen" wird beispielsweise auf ein fehlerfreies Teil oder ein Objekt angewendet, und anschließend vergleicht das Werkzeug das eingelernte Bild mit jedem folgenden aufgezeichneten Bild. Anschließend wird die vom Bildfilterwerkzeug "Vergleichen" erstellte Werkzeugbildausgabe von weiteren Werkzeugen, wie dem Zählwerkzeug "Blobs" inspiziert. Dabei ist die Logik des Zählwerkzeugs "Blobs" invertiert, sodass die Inspektion erfolgreich ist, wenn keine Blobs gezählt werden, und eine Fehlermeldung ausgegeben wird, wenn Blobs gezählt werden.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Bildfilterwerkzeugs "Vergleichen"

Nach dem Hinzufügen des Werkzeugs müssen Sie den Bereich konfigurieren, der den Bildbereich definiert, der verbessert werden soll.

Hinweis: Das Werkzeug liefert die besten Ergebnisse bei Bildern mit wenig bis keinem Hintergrundrauschen, und stellt sicher, dass jedes Bild fast identisch ist, d. h., das Teil oder das Objekt befindet sich an derselben Position und der Fehler, sofern vorhanden, ist offensichtlich und groß. Weist das Bild Rauschen auf, sollten Sie ggf. das Bildfilterwerkzeug "Punktfilter" verwenden, das für das Binarisieren konfiguriert wurde, um den Graustufenunterschied im Bild zu entfernen.
  1. Bei der Positionierung des Bereichs müssen die Grenzen den Bildbereich einschließen, der gefiltert werden soll. Wenn der Bereich Flächen enthält, die nicht gefiltert werden sollen, können die Ergebnisse ungenau werden. Erstellen Sie kleinere Bereiche, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, stellen Sie sicher, dass sich der zu filternde Bereich in allen Bildern in etwa an derselben Position befindet.
  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.
  3. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  4. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Filterwerkzeugs für Bilder „Vergleichen“

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Filterwerkzeugs für Bilder „Vergleichen“ enthält folgende Elemente:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
  • Registerkarte „Trainiertes Bild“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Registerkarte „Trainiertes Bild“


Filterwerkzeug für Bilder „Vergleichen“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Filter_1“, sofern es sich um das erste Filterwerkzeug für Bilder handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Filter_2“, „Filter_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Filterwerkzeug für Bilder „Vergleichen“ – Registerkarte „Einstellungen“

Geschlossen Pixelvergleich

Definiert die Art des Pixelvergleichs, der bei der Zuordnung der Vorlage zum Eingabebild durchgeführt wird: Nächstgelegener Nachbar oder Bilinear.

Bei der Einstellung Nächstgelegener Nachbar (Standardeinstellung) wird eine Bildzuordnung durchgeführt, bei der jedes Pixel der Vorlage mit dem nächstgelegenen Pixel im Eingabebild verglichen wird, um den normalisierten Graustufenunterschied für jedes Pixel zu errechnen. Diese Bildzuordnungsmethode ist zwar schnell, aber nicht sehr genau.

Bei der Einstellung Bilinear wird eine Bildzuordnung durchgeführt, bei der jedes Pixel der Vorlage mit einem gewichteten Durchschnitt, der dem Graustufenwert der vier nächstliegenden Pixel im Eingabebild entspricht, verglichen wird, um den normalisierten Graustufenunterschied für jedes Pixel zu errechnen. Diese Bildzuordnungsmethode ist langsamer, aber genauer.

Geschlossen Kantentoleranz

Definiert die Pixelanzahl um eine Kante, die beim Bildvergleich (0-24, standardmäßig 3) toleriert wird. Je höher die Anzahl, desto weniger wahrscheinlich ist es, dass nicht exakt zugewiesene Kanten als Unterschiede im Ausgabebild dargestellt werden.


Filterwerkzeug für Bilder „Vergleichen“ – Registerkarte „Trainiertes Bild“

Das auf der Registerkarte Trainiertes Bild angezeigte Bild ist eine Miniaturansicht des Vorlagenbilds Modell. Klicken Sie auf die Schaltfläche Modellbereich, um die Größe des Modellbereichs zu ändern oder diesen zu verschieben. Klicken Sie anschließend auf die Schaltfläche Einlernen, um das Vorlagenbild Modell erneut einzulernen.


Fehlererkennungswerkzeuge – Flächenfehler

Das Fehlererkennungswerkzeug Flächenfehler wird verwendet, um kleine Fehler aufgrund von Schwankungen in der Pixelintensität zu erkennen. Mit diesem Werkzeug lassen sich Fehler wie Kratzer, Dellen, Risse, Flecken oder Abplatzungen auf Graustufen- oder Farbbildern erkennen.

Das Fehlererkennungswerkzeug Flächenfehler wird verwendet, um Bereiche mit lokaler Intensität und Farbschwankungen zu erkennen. Das Werkzeug nutzt eine interne Filteroperation, um zunächst Kanten und Bereiche mit plötzlichen Farb- oder Graustufenschwankungen zu markieren. Anschließend wird eine Blob-Analyse durchgeführt, um zu bestimmen, ob tatsächliche Fehler vorhanden sind. Das Werkzeug eignet sich am besten für Anwendungen, bei denen ein Teil als einheitlicher Bereich untersucht werden soll, sodass eine plötzliche Intensitätsänderung als Fehler kategorisiert werden kann.

Falls nötig, kann das Werkzeug „Flächenfehler“ auch eine integrierte Bildmaske anbieten, um Bereiche des Bildes zur Untersuchung zu markieren und andere Bereiche davon auszuschließen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Fehlererkennungswerkzeugs "Flächenfehler"

Wenn Sie dieses Werkzeug einrichten, müssen Sie die Schwellenwerte angeben, die verwendet werden, um zu bestimmen, ob Fehler vorhanden sind oder nicht. Vor Beginn sollte über Laden von Bildern von einem PC eine Datenbank mit Bildern des zu untersuchenden Teils (sowohl gute als auch schlechte Teile) geladen werden.

  1. Laden Sie zuerst ein Bild des Teils in einem fehlerfreien Zustand. Anschließend fügen Sie das Werkzeug Flächenfehler hinzu.

  2. Stellen Sie den Bereich im Bild ein. Wählen Sie im Dropdown-Menü Bereichstyp den Bereichstyp ein: Rechteck (Standard), Kreis, Annulus oder Polygon. Positionieren und konfigurieren Sie den Bereich im Bild, in dem die Fehler voraussichtlich erscheinen werden. Die Grenzen des Bereichs müssen den bzw. die Fehler und ihre möglichen Positionen einschließen.

    Hinweis:
    • Versuchen Sie kleinere Bereiche einzustellen, um die Leistungsstärke des Werkzeugs zu verbessern. Je größer ein Bereich ist, desto länger dauert die Inspektion. Wenn Sie keine Vorrichtung verwenden, müssen Sie sicherstellen, dass sich die Fehler in jedem Bild nahezu an derselben Position befinden oder der Bereich groß genug für die erwartete Bewegung des Merkmals ist.
    • Nachdem das Werkzeug hinzugefügt wurde, können Sie den Bereichstyp verändern, indem Sie nach einem Rechtsklick auf den Bereich im Bild die gewünschte Form aus den verfügbaren Optionen in Bereich ändern auf auswählen.
  3. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  4. Passen Sie die Parameter des Werkzeugs anhand des Teils in seinem fehlerfreien Zustand an, um sicherzustellen, dass das Werkzeug keine Fehler identifiziert. Verwenden Sie den Parameter Anzeigebild auf der Registerkarte Fehlerkandidaten, um visuelles Feedback dazu anzeigen zu lassen, inwieweit sich die Anpassungen des Parameters auf die Ergebnisse des Werkzeugs auswirken. Setzen Sie zu Anfang den Parameter Anzeigebild auf Fehlerkandidaten, damit alle erkannten Fehler in einem roten Umrandungsfeld eingeschlossen sind.

    Hinweis: Optional kann eine Maske erstellt werden, um Bereiche des Bildes zur Untersuchung zu markieren und andere Bereiche davon auszuschließen. Masken sind sehr hilfreich, wenn Sie eine Inspektion mit Text, Bezeichnungen oder anderen zu ignorierenden Merkmalen konfigurieren wollen.
  5. Fangen Sie beim Einstellen der Parameter mit dem Bereih des Werkzeugs an, so dass der Inspektionsbereich den zu inspizierenden Bereich ordnungsgemäß umrandet - er sollte keine irrelevante Merkmale, wie zum Beispiel Etiketten, Ränder von Zeichen oder Logos enthalten. Wenn die Inspektion eine Kante eines Teils beinhaltet, muss der Bereich parallel zur Kante positioniert werden (das Gleiche gilt für kreisförmige Bereiche, bei denen der kreisförmige Bereichsbogen parallel zur Kante des Teils liegen muss).
  6. Passen Sie als Nächstes die Parameter Abtastfaktor und Glättungsfaktor an. Erhöhen Sie den Parameter für das Abtasten, wenn Sie kleine Gradientenfehler oder große Fehler mit geringem Kontrast erkennen möchten. Erhöhen Sie den Parameter „Glättungsfaktor“, um kleinere, falsche Fehler zu übergehen.
  7. Nachdem Sie diese Parameter angepasst haben, verwenden Sie die verschiedenen Optionen der Parameter Erkennungsart, Erkennungsgröße und Erkennungsachse. Bei den meisten Anwendungen kann der Parameter Erkennungsart auf Schnell gesetzt werden. Die Erkennungsgröße beträgt dann 1. Bei Anwendungen, die „Helle Fehler“, „Dunkle Fehler“ oder „Helle und dunkle Fehler“ benötigen, muss der Parameter „Erkennungsgröße“ auf einen Wert gesetzt werden, der größer ist als der Radius des zu erkennenden Fehlers. Wenn der Bereich parallel zu einer Kante konfiguriert wurde, muss die Erkennungsachse auch parallel zum Bereich verlaufen.
  8. Passen Sie dann die Parameter Minimale Fehlerfläche, Maximale Fehlerfläche und Minimaler Kontrast an.
  9. Sobald das Werkzeug das Teil in seinem fehlerfreien Zustand inspiziert, laden Sie ein Bild des Teils mit einem Fehler. Passen Sie wiederum die Parameter an, bis das Werkzeug die entsprechenden Fehler korrekt erkennt. Laden Sie weitere Bilder des Teils mit Fehlern und passen Sie, falls nötig, die Parameter an, um zusätzliche Fehler zu identifizieren.
  10. Nachdem die Fehler erkannt wurden, laden Sie erneut die Bilder des Teils in seinem fehlerfreien Zustand, um sicherzustellen, dass es nach wie vor als fehlerfrei erkannt wird. Das Werkzeug ist nach der korrekten Konfiguration bereit für Laufzeit-Inspektionen.
  11. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.

Einrichtung der Maske des Werkzeugs


Einrichten der Maske des Fehlererkennungswerkzeugs „Flächenfehler“

Nachdem das Fehlererkennungswerkzeug „Flächenfehler“ hinzugefügt wurde, kann eine interne Maske erstellt werden, um Bereiche des Bildes zur Untersuchung zu markieren und andere Bereiche davon auszuschließen.

  1. Gehen Sie zur Registerkarte Maske und aktivieren Sie das Kontrollkästchen, um die Maske einzuschalten.
  2. Legen Sie fest, wie die Maske erzeugt werden soll: „Größtes Segment“ oder „Kanten“. Standardmäßig werden Kanten verwendet (der Parameter „Maskierungsmethode“ ist standardmäßig auf „Kantenmaske“ eingestellt), um eine Bildmaske basierend auf dem Kantengerüst zu erzeugen. Mit dieser Bildmaske werden nur Kantenpixel maskiert, alle anderen Pixel werden angezeigt. Wenn Sie das größte Segment wählen, sollte der zu untersuchende Bereich das größte Segment sein, und der Hintergrund sollte von der Untersuchung ausgeschlossen werden.
  3. Legen Sie im Parameter „Anzeigebild maskieren“ den Maskentyp fest, den Sie erzeugen wollen, um die Maskenmerkmale durch das Anzeigen der indizierten und farbcodierten Segmente hervorzuheben.
  4. Passen Sie zunächst den Parameter „Glättungsfaktor maskieren“ an, um sicherzustellen, dass die Kanten im Bild korrekt hervorgehoben werden.
  5. Passen Sie anschließend die Parameter „Maximale Füllgröße für kleine Löcher“, „Median-Kernel-Größe“ und „Zahl der Maskenerodierungen“ an. Mit diesen Optionen können Löcher gefüllt, Ränder geglättet und/oder schmale Streifen in der Bildmaske entfernt werden. Wenn „Kantenmaske“ ausgewählt ist, sollte der Parameter „Maximale Füllgröße für kleine Löcher“ auf 0 gesetzt werden.
  6. Sobald die Maske die gewünschten Merkmale korrekt hervorhebt und andere ausschließt, klicken Sie auf die Schaltfläche „Trainieren“, um die Maske festzulegen.
Hinweis: Alle Änderungen an Parametern (Ausnahme: Bereich) aktualisieren die Maske, die anschließend neu trainiert werden muss. Wenn der Bereich bewegt oder vergrößert/verkleinert wird, muss die Schaltfläche „Trainieren“ angeklickt werden, damit die Maske entsprechend aktualisiert wird.


Anpassen der Parameter des Fehlererkennungswerkzeugs „Flächenfehler“

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Fehlererkennungswerkzeugs „Flächenfehler“ umfasst die folgenden Registerkarten:

  • Registerkarte „Allgemein“
  • Registerkarte „Maske“
  • Registerkarte „Fehlererkennung“
  • Registerkarten „Statistik“, „Fehler“ und „Zusammengesetzter Bereich“
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Maske“

Registerkarte „Fehlererkennung“

Registerkarten „Statistik“, „Fehler“ und „Zusammengesetzter Bereich“


Fehlererkennungswerkzeug „Flächenfehler“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „SurfaceFlaw_1“, sofern es sich um das erste Fehlererkennungswerkzeug „Flächenfehler“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „SurfaceFlaw_2“, „SurfaceFlaw_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Fehlererkennungswerkzeug "Flächenfehler" – Registerkarte "Maske"

Geschlossen Maske aktivieren

Legt fest, ob die Maske verwendet werden soll (Standard = Aus).

Geschlossen Maske trainieren

Legt fest, dass die Maske anhand der aktuell konfigurierten Parametereinstellungen trainiert werden soll.

Geschlossen Maskierungsmethode

Legt fest, wie das Werkzeug die Maske konstruieren soll ("Größtes Segment" oder "Kantenmaske"; Standard = Kantenmaske).

  • Größtes Segment: Das Werkzeug verwendet zur Generierung der Maske das größte Segment.
  • Kantenmaske: Das Werkzeug nutzt Kanten zur Generierung der Maske (der Parameter "Minimaler Kantenkontrast" legt fest, welche Kanten verwendet werden).
Geschlossen Anzeigebild maskieren

Legt das anzuzeigende Ausgabebild fest ("Eingabebild", "Kantenbild", "Segmentiertes Bild" oder "Maskenbild"; Standard = "Maskenbild").

  • Eingabebild: Das gerade aufgenommene Bild wird angezeigt.
  • Kantenbild: Ein Bild mit Kantengerüst wird angezeigt.
  • Segmentiertes Bild: Ein farbcodiertes, segmentiertes Bild wird angezeigt.
  • Maskenbild: Das binäre Maskenbild, das nach der Segmentierung und Maskengenerierung erstellt wird, wird angezeigt (nach Berücksichtigung des Vorrichtungseingangs). Pixelwerte von 255 = Pixel beachten; Pixelwerte von 0 = Pixelwerte nicht beachten.
Hinweis: Dieses Bild dient nur zu Anzeigezwecken und sollte nicht als Eingabe für andere Funktionen verwendet werden.
Geschlossen Glättungsfaktor maskieren

Definiert den Sigmafaktor (0 bis 100; Standard = 1) zur Glättung des Bildes.

Geschlossen Minimaler Kantenkontrast

Definiert den Mindestkontrast (1 bis 100; Standard = 10) zum Erkennen von Kanten.

Hinweis: Dieser Parameter wird nur aktiviert, wenn der Parameter "Maskierungsmethode" auf "Kantenmaske" festgelegt wird.
Geschlossen Minimale Segmentgröße

Definiert den erforderlichen Mindestbereich in Pixeln (1 bis 50000; Standard = 1000), den ein Segment einnehmen muss, damit es extrahiert werden kann.

Geschlossen Maximale Lochfüllgröße

Definiert die maximale Größe in Pixeln (0 bis 1000; Standard = 0), die ein kleines Loch haben muss, damit es gefüllt werden kann (wird nicht als Loch gezählt).

Geschlossen Median-Kernel-Größe

Definiert die Median-Kernel-Größe (0 bis 50000; Standard = 0) zur Glättung der Kanten im Maskenbild.

Geschlossen Zahl der Maskenerodierungen

Definiert, wie oft (-100 bis 100; Standard = 0) das generierte Bild erodiert wird. Dieser Wert kann positiv oder negativ sein. Negative Werte dilatieren das Bild.

Geschlossen Invertiert

Definiert, ob die Maske invertiert werden soll, d. h. Weiß statt Schwarz, Schwarz statt Weiß.


Fehlererkennungswerkzeug "Flächenfehler" – Registerkarte "Fehlererkennung"

Geschlossen Erkennungsart

Legt die Art der Bildverarbeitung für das Bild fest, um zu bestimmen, ob Fehler vorhanden sind ("Schnell", "Helle Fehler", "Dunkle Fehler" oder "Helle und dunkle Fehler"; Standard = "Schnell").

  • Schnell: Diese Option eignet sich am besten zum Erkennen von "kantigen" Übergängen auf einer Oberfläche, beispielsweise Streifen oder Kratzer. Es wird hierbei ein Erodierungs-Dilationsvorgang durchgeführt, bei dem die Kante eines Fehlers hervorgehoben wird. Diese Option hat die schnellste Ausführungszeit, jedoch wird bei Meldungen zu Fehlern lediglich der Umriss des Fehlers, nicht seine Fläche ausgegeben.
  • Helle Fehler: Diese Option eignet sich am besten zum Erkennen von hellen "Blob-artigen" Fehlern auf einem dunklen Hintergrund sowie zum Erkennen von Fehlern aufgrund der Pixelgröße ihrer Fläche. Es wird eine "Top Hat"-Filteroperation durchgeführt, die zum Erkennen von potenziellen Fehlern alles außer hellen Merkmalen herausfiltert, die kleiner sind als der Parameter der Erkennungsgröße.
  • Dunkle Fehler: Diese Option eignet sich am besten zum Erkennen von dunklen "Blob-artigen" Fehlern auf einem hellen Hintergrund sowie zum Erkennen von Fehlern aufgrund der Pixelgröße ihrer Fläche. Es wird eine "Bottom Hat"-Filteroperation durchgeführt, die zum Erkennen von potenziellen Fehlern alles außer dunklen Merkmalen herausfiltert, die kleiner sind als der Parameter der Erkennungsgröße.
  • Helle und dunkle Fehler: Diese Option eignet sich am besten zum Erkennen von "Blob-artigen" Fehlern, die dunkel oder hell sein können, sowie zum Erkennen von Fehlern aufgrund der Pixelgröße ihrer Fläche. Es werden sowohl "Bottom Hat"- als auch "Top Hat"-Operationen durchgeführt, und das maximale Ergebnis beider Operationen wird verwendet.
Hinweis: Wenn "Helle Fehler", "Dunkle Fehler" oder "Helle und dunkle Fehler" zur Fehlererkennung ausgewählt ist, muss der Parameter "Erkennungsgröße" auf den Wert des größten zu erkennenden Fehlers eingestellt sein.
Geschlossen Anzeigebild

Legt das anzuzeigende Ausgabebild fest ("Eingabebild", "Abgetastetes Bild", "Fehlerkandidaten" oder "Fehlermaskenbild"; Standard = "Fehlermaskenbild").

  • Eingabebild: Das gerade aufgenommene Bild wird angezeigt.
  • Abgetastetes Bild: Das geglättete und abgetastete Bild wird angezeigt. Wenn als Eingabe ein gedrehter oder gebogener Bereich verwendet wurde, wird neben der geglätteten und abgetasteten Version die umgerechnete und begradigte Version des Bildes angezeigt.
  • Fehlerkandidaten: Die potenziellen Fehler werden angezeigt. Potenzielle Fehler werden als Kontrast zum Hintergrund hervorgehoben.
  • Fehlerbild: Fehler werden angezeigt. Fehler werden weiß dargestellt, während alle anderen Flächen schwarz dargestellt werden. Diese Anzeigeoption schließt auch Fehler außerhalb der definierten Fehlergrenzen ("Minimale Fehlerfläche" und "Maximale Fehlerfläche") ein.
Hinweis: Dieses Bild dient nur zu Anzeigezwecken und sollte nicht als Eingabe für andere Funktionen verwendet werden.
Geschlossen Abtastfaktor

Definiert die Rate (1 bis 99999; Standard = 1), mit der das Eingabebild abgetastet und gleichzeitig seine Auflösung verringert wird. Abtasten wird verwendet, um die Ausführungszeit des Werkzeugs zu verkürzen, jedoch geschieht dies zulasten der Genauigkeit. Wird bei der Abtastrate der Wert 1 eingetragen, findet kein Abtasten statt, d. h., das Eingabebild wird in voller Auflösung verwendet. Höhere Werte bedeuten eine geringere Auflösung und Genauigkeit, aber auch schnellere Ausführungszeiten.

Geschlossen Automatische Glättung

Legt fest, ob die Funktion den optimalen Glättungsfaktor zum Glätten des Bildes ermitteln soll (Standard = Aus). Im Allgemeinen wird die Leistung verbessert, wenn die Funktion den optimalen Glättungsfaktor auswählen soll.

Hinweis: Der Parameter "Automatische Glättung" ist automatisch deaktiviert. Zum Aktivieren des Parameters muss der Parameter "Abtastfaktor" auf einen Wert größer als 1 gestellt werden. Ist der Parameter "Abtastfaktor" auf einen Wert größer als 1 gestellt, und wird keine automatische Glättung gewünscht, deaktivieren Sie den Parameter, und setzen Sie den gewünschten Wert mit dem Parameter "Glättungsfaktor".
Geschlossen Glättungsfaktor

Definiert den Faktor (0 bis 99999; Standard = 0), um den das Bild geglättet werden soll. Beginnen Sie zum Ermitteln des optimalen Wertes mit einem ähnlichen Wert wie beim Parameter "Abtastfaktor". Tragen Sie den Wert 0 ein, wenn keine Glättung erfolgen soll.

Hinweis: Dieser Parameter ist deaktiviert, wenn der Parameter "Automatische Glättung" aktiviert ist. Ist der Parameter "Automatische Glättung" aktiviert, setzen Sie den Parameter "Abtastfaktor" auf einen Wert größer als 1, und deaktivieren Sie anschließend den Parameter "Automatische Glättung". Jetzt können Sie den Parameter "Abtastfaktor" einstellen.
Geschlossen Erkennungsachse

Definiert die Achse, auf der potenzielle Fehler erkannt werden sollen ("X", "Y" und "X und Y"; Standard = "X und Y").

Geschlossen Erkennungsgröße

Definiert die Größe der Erkennungsumgebung (1 bis 99999; Standard = 1) in Pixeln. Dieser Parameter wird verwendet, um die Verarbeitungsumgebung oder den Kernel für den Parameter "Fehlererkennungsvorgang" zu konstruieren. Für alle anderen Fehlererkennungsvorgänge außer Schnell muss der Wert mindestens so groß sein wie die Länge bzw. Breite des zu erkennenden Fehlers.

Geschlossen Minimaler Fehlerkontrast

Definiert den Intensitätsschwellenwert (1 bis 255; Standard = 20) für die Fehlererkennung. Damit ein Fehler erkannt werden kann, muss er sich in der Intensität um diesen Wert vom Hintergrund abheben.

Geschlossen Minimale Fehlerfläche

Definiert die Mindestgröße (1 bis 99999; Standard = 30) der zu erkennenden Fehler in Pixeln.

Hinweis: Dieser Wert wird immer in Pixeln angegeben, auch wenn der Job im Schritt Bild einrichten kalibriert und in reelle Maßeinheiten umgewandelt wurde.
Geschlossen Maximale Fehlerfläche

Definiert die Maximalgröße (1 bis 99999; Standard = 99999) der zu erkennenden Fehler in Pixeln.

Hinweis: Dieser Wert wird immer in Pixeln angegeben, auch wenn der Job im Schritt Bild einrichten kalibriert und in reelle Maßeinheiten umgewandelt wurde.
Geschlossen Timeout

Definiert den Zeitraum in Millisekunden (0 bis 30000; Standard = 5000), in dem das Werkzeug nach Fehlern sucht, bevor die Ausführung angehalten und eine Fehlermeldung ausgegeben wird.

Geschlossen Fehler insgesamt

Zeigt die Anzahl aller Fehler an, die erkannt wurden.


Fehlererkennungswerkzeug „Flächenfehler“ – Registerkarten „Statistik“, „Fehler“ und „Zusammengesetzter Bereich“

Geschlossen Registerkarte „Statistik“

In der Registerkarte „Statistik“ werden Daten zur Gesamtanzahl der Fehler und ihrer kumulativen Größe angezeigt.

Geschlossen Registerkarte „Fehler“

In der Tabelle der Registerkarte „Fehler“ werden die ersten 10 erkannten Fehler (sortiert nach Bereichen, vom kleinsten bis zum größten) erfasst. Die Tabelle führt die Position des Fehlers im Bild (X/Y-Koordinaten), den Bereich, den Umfang, die Rundheit und die Intensität auf.

Geschlossen Registerkarte „Zusammengesetzter Bereich“

Mithilfe der Registerkarte Zusammengesetzter Bereich wird ein zusammengesetzter Bereich konfiguriert, der eine Ansammlung von Teilbereichen (vom Typ Rechteck, Annulus, Kreis oder Polygon) enthält, die dem Bereich Hinzufügen (der Teilbereich wird in die Bildanalyse miteinbezogen) oder von ihm Subtrahieren (der Bereich wird von der Bildanalyse ausgeklammert (dies wird auch maskieren "genannt").

Hinweis:
  • Es können einem Zusammengesetzten Bereich maximal 32 Teilbereiche hinzugefügt werden.
  • Zur Interaktion mit dem Bereich im Bild steht ein Kontextmenü zur Verfügung, das die Änderung der Form eines Teilbereichs, das Hinzufügen oder Löschen eines Teilbereichs oder die Änderung der Operation ausgewählter Teilbereiche (Hinzufügen oder Subtrahieren) ermöglicht.
Geschlossen Tabelle „Zusammengesetzter Bereich“

Zeigt die Typen der Teilbereiche an, die den zusammengesetzten Bereich ergeben, sowohl als auch ihre Operationen (Hinzufügen oder Subtrahieren). Wählen Sie einen Teilbereich, damit die Schaltflächen Löschen, Nach oben oder Nach unten aktiviert werden. Wird die Schaltfläche Löschen geklickt, wird der ausgewählte Teilbereich aus der Liste gelöscht. Wird die Schaltfläche Nach oben geklickt, wird der ausgewählte Teilbereich in der Liste nach oben verschoben und wird die Schaltfläche Nach unten geklickt, wird der ausgewählte Teilbereich in der Liste nach unten verschoben.

Hinweis:

Der zusammengesetzte Bereich wird anhand der Sequenz der Teilbereiche in der Liste erstellt. Durch Setzen der Teilbereiche und ihrer Hinzufügen- oder Subtrahieren-Operation, in einer bestimmten Reihenfolge, können Teile des Bildes hervorgehoben, während andere Teile ignoriert werden können. Das Bild unten zeigt ein Beispiel, wie die Teilbereiche richtig angeordnet werden können, Teile des Bildes auszuschließen, während man auf andere Teile fokussiert. Im ersten Satz wird ein Rechteck mit einer Hinzufügen-Operation eingestellt, und dann ein Kreis, mit einer Subtrahieren-Operation in die Mitte gesetzt. Dann wird ein kleineres Rechteck mit einer Hinzufügen-Operation in der Mitte des Kreises eingestellt. Der Kreis schließt einen Teil des Bildes aus, wahrend das kleinere Rechteck einen Teil des Bildbereichs wieder der Bildanalyse hinzufügt. Im zweiten Satz, wird das kleinere Rechteck vor dem Hinzufügen des Kreises hinzugefügt, und der Kreis maskiert das kleinere Rechteck, und schließt es aus der Bildanalyse aus.

Geschlossen Form

Zeigt die Form des ausgewählten Teilbereichs (Rechteck, Kreis, Annulus oder Polygon) an. Zur Änderung der Form wählen Sie den gewünschten Bereichstyp aus dem Dropdown-Menü.

Geschlossen Operation

Legt die Aktion des ausgewählten Teilbereichs innerhalb des Bereichs fest: Hinzufügen oder Subtrahieren. Hinzufügen deutet an, dass der Teilbereich in der Bildanalyse inkludiert werden soll, während Subtrahieren andeutet, dass der Teilbereich aus der Bildanalyse ausgeschlossen werden soll (dies wird auch "maskieren" genannt.)

Geschlossen Rechteck

Fügt einen rechteckigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Annulus

Fügt einen ringförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Kreis

Fügt einen kreisförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.

Geschlossen Polygon

Fügt einen polygonförmigen Teilbereich in den zusammengesetzten Bereich ein. Konfigurieren Sie die Form und Größe des Bereichs nach Bedarf.


Werkzeuge zur Fehlererkennung – Kante

Das Fehlererkennungswerkzeug "Kante" erzeugt eine eingepasste Linie oder einen eingepassten Kreis mithilfe von Kantenanalyse-Caliperarrays und ermittelt so die die exakte Position der Kantenmerkmale. Sobald die Kante ermittelt wurde, erzeugt das Werkzeug eine eingepasste Linie oder einen eingepassten Kreis (je nachdem, ob das Kantenmerkmal eine Kurve beinhaltet) über dem Kantenmerkmal und prüft die Kante auf Abweichungen wie Fehler oder Zwischenräume. Die Anzahl der Fehler oder Zwischenräume wird angezeigt.

Hinweis:
  • Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
  • Alle Eingabewerte werden in Pixeln angegeben, auch wenn das Werkzeug in reellen Einheiten kalibriert wurde.

Das Fehlererkennungswerkzeug "Kante" ist hilfreich, um sicherzustellen, dass die Kantenmerkmale des Teils oder Objekts keine Abweichungen wie Fehler oder Zwischenräume aufweisen. So kann beispielsweise festgestellt werden, ob die Außenseite des Teils bzw. Objekts die gleiche Form beibehält und ob sie kleine Dellen oder Kerben aufweist.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Fehlererkennungswerkzeugs "Kante"

Wählen Sie nach dem Hinzufügen des Werkzeugs den maskierten Bereich im Bild über dem Kantenmerkmal aus, das Sie inspizieren möchten:

  1. Positionieren und konfigurieren Sie den Bereich innerhalb des Bildes über dem Kantenmerkmal. Stellen Sie beim Platzieren des Bereichs sicher, dass die Kanten parallel zur Suchrichtung des Bereichs verlaufen und der Bereich so viel wie möglich vom Kantenmerkmal umschließt, wobei unnötiges oder unerwünschtes Rauschen aus dem Bereich ausgeschlossen wird.

    Hinweis: Die gestrichelte gelbe Linie im Maskierten Bereich legt eine Fläche innerhalb des Bereichs fest, in der Kantenübergänge ermittelt werden.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Wählen Sie nach der Bestätigung des Bereichs die verschiedenen Registerkarten Kanten, Kantengüte, Passform, Fehler und Zwischenräume, und passen Sie die Parameter und den Bereich nach Bedarf an, um sicherzustellen, dass das Werkzeug die korrekten Kantenkandidaten ermittelt und die korrekte eingepasste Linie bzw. den korrekten eingepassten Kreis erzeugt. Verwenden Sie beim ersten Einrichten des Werkzeugs ein Bild, das die idealen Kantenmerkmale enthält. Nachfolgende Bildaufnahmen enthalten dann Kantenkandidaten, die auf Abweichungen wie Fehler oder Zwischenräume untersucht werden.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um die erwarteten Bereiche und Abweichungen auszugleichen.
  5. Verwenden Sie auf Wunsch die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Fehlererkennungswerkzeugs "Kante"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Fehlererkennungswerkzeugs "Kante" umfasst die folgenden Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Kanten"
  • Registerkarte "Kantengüte"
  • Registerkarte "Anpassen"
  • Registerkarte "Fehler"
  • Registerkarte "Zwischenräume"
  • Registerkarten "Fehler" und "Zwischenräume"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Kanten“

Registerkarte „Kantengüte“

Registerkarte „Passform“

Registerkarte „Fehler“

Registerkarte „Zwischenräume“

Registerkarte „Fehler“ und „Zwischenraumtabelle“


Fehlererkennungswerkzeug „Kante“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „EdgeDefect_1“, sofern es sich um das erste Fehlererkennungswerkzeug „Kante“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „EdgeDefect_2“, „EdgeDefect_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Fehlererkennungswerkzeug "Kante" – Registerkarte "Kanten"

Bei Auswahl der Registerkarte Kanten zeigt das Werkzeug alle ermittelten Kanten im Bereich grün hervorgehoben an. Sie können die Parameter Caliper-Größe, Caliper-Abstand, Kantenbreite und Mindestkontrast nach Bedarf anpassen, um die gewünschten Kanten zu isolieren.

Sie können auch alle Caliper anzeigen, indem Sie den Parameter Alle Caliper anzeigen aktivieren.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Caliper-Größe

Definiert die pro Caliper zu analysierende Pixelanzahl in Inspektionsrichtung (1 bis 639; Standard = 5).

Geschlossen Caliper-Abstand

Definiert den Abstand in Pixel zwischen dem Ende eines Caliper und dem Anfang des nächsten Caliper (-1 bis 639; Standard = 0).

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 10; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Minimaler Kontrast

Definiert den minimalen Graustufen-Kontrastübergang (1 bis 255; Standard = 10), der als Kante gewertet wird.

Geschlossen Caliper-Anzahl

Zeigt die Gesamtanzahl der Caliper im Bereich an.

Geschlossen Caliper-Index

Legt die einzelnen Caliper fest, die isoliert und angezeigt werden.

Geschlossen Alle Caliper anzeigen

Definiert, ob alle Caliper in dem Bereich immer angezeigt werden. Standardmäßig sind die Caliper ausgeblendet.


Fehlererkennungswerkzeug "Kante" – Registerkarte "Kantengüte"

Bei Auswahl der Registerkarte Kantengüte zeigt das Werkzeug mithilfe kleiner, farbcodierter Kreise alle gefundenen Kantenkandidaten im Bereich (der ausgewählt oder angepasst werden kann) und die eingepasste Linie oder den eingepassten Kreis an. Die Kantenkandidaten stellten die möglichen Kanten dar, die beim Erzeugen der eingepassten Linie oder des eingepassten Kreises berücksichtigt werden. Passen Sie die Parameter an, um die gewünschten Kantenkandidaten zu isolieren.

Alle erkannten Fehler und Zwischenräume werden ebenfalls angezeigt.

Geschlossen Kantenrichtung suchen

Definiert die Richtung, in der das Werkzeug relativ zum Bereich Kanten ermittelt (Links nach rechts oder Rechts nach links; Standard = Links nach rechts).

Geschlossen Kantenübergang

Gibt den Übergang der Kante an (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Regel:Erste Kante

Definiert, ob die erste ermittelte Kante bei der Entscheidung, ob ein Kantenkandidat als Kante gewertet wird, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Regel:Stärkste Kante

Definiert, ob die Kante mit dem stärksten Kontrastübergang bei der Entscheidung, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Schwellenwert für Güte

Definiert einen Schwellenwert für die Güte, um Kanten mit einer Güte (0 bis 255; Standard = 10) unterhalb dieses Werts herauszufiltern.


Fehlererkennungswerkzeug "Kante" – Registerkarte "Anpassen"

Wenn die Registerkarte Passform ausgewählt ist, zeigt das Werkzeug alle gefundenen Kantenkandidaten innerhalb des Bereichs und des eingepassten Kreises oder der eingepassten Linie an. Die Kantenkandidaten sind die möglichen Kanten, die beim Erzeugen des eingepassten Kreises oder der eingepassten Linie berücksichtigt werden. Sie werden durch kleine, farbcodierte Kreise angezeigt.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Ausreißer filtern

Legt fest, ob das Werkzeug Punkte aus der eingepassten Linie entfernt, deren Abstand größer ist als durch den Parameter "Abstandfilter anpassen" definiert (standardmäßig ist dieser Parameter aktiviert).

Geschlossen Abstandfilter anpassen

Definiert den Abstand (1 bis 1920; Standard = 2) in Pixeln einer Kante von der ursprünglichen eingepassten Linie, der zur Berechnung der erneuten Anpassung verwendet wird. Mithilfe dieses Parameters wird vermieden, dass Fehler die Linienanpassung beeinträchtigen.

Hinweis: Der Parameter "Ausreißer filtern" muss aktiviert sein, um diesen Parameter zu verwenden.
Geschlossen Höchster Punktfilterabstand

Definiert den Ausreißerabstand (1 bis 1920; Standard = 1000), bei dessen Überschreitung Kanten nicht zur Bestimmung der Mindest- und Höchstabstände verwendet werden. Alle Kanten, die diesen Wert überschreiten, werden ignoriert.

Geschlossen Erneut auswerten

Definiert, ob die ermittelten Kanten erneut ausgewertet werden, um sicherzustellen, dass ermittelte Kanten, die ursprünglich gelöscht wurden, korrekt gefiltert wurden (standardmäßig ist dieser Parameter aktiviert).

Geschlossen Erneut anpassen

Legt fest, ob das Werkzeug die eingepasste Linie nach der erneuten Auswertung der Kanten erneut anpasst (dieser Parameter ist standardmäßig aktiviert).

Hinweis: Die Genauigkeit des Werkzeugs ist höher, wenn dieser Parameter aktiviert ist. Die Verarbeitungszeit erhöht sich jedoch.


Fehlererkennungswerkzeug "Kante" – Registerkarte "Fehler"

Bei Auswahl der Registerkarte Fehler zeigt das Werkzeug den eingepassten Kreis oder die eingepasste Linie sowie alle ermittelten Fehler oder Zwischenräume. "Fehler" werden als Kantenabweichungen von der eingepassten Linie bzw. dem eingepassten Kreis angegeben.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Mindestabstand

Legt fest, dass ein beliebiger Abstand (0,001 bis 1920; Standard = 4) in Pixeln von der Kante und der eingepassten Linie oder dem eingepassten Kreis unterhalb dieses Werts nicht als Fehler gewertet wird.

Geschlossen Höchstabstand

Legt fest, dass ein beliebiger Abstand (0,001 bis 1920; Standard = 1000) in Pixeln von der Kante und der eingepassten Linie oder dem eingepassten Kreis, der diesen Wert überschreitet, nicht als Fehler gewertet wird.

Geschlossen Größe aktiviert

Legt fest, ob das Werkzeug Größenfehler (entlang der Kantenlänge) erkennt. Standardmäßig ist dieser Parameter aktiviert.

Hinweis: Wenn die Optionen Größe aktiviert und Fläche aktiviert beide auf Ein gesetzt sind, werden nur Fehler angezeigt, die beide Bedingungen nicht erfüllen.
Geschlossen Mindestgröße

Definiert die minimale Fehlergröße (0,001 bis 1920; Standard = 10) in Pixeln. Durchgängige Abweichungen von der eingepassten Linie oder dem eingepassten Kreis, die diesen Wert überschreiten, werden nicht als Fehler gewertet.

Geschlossen Maximalgröße

Definiert die maximale Fehlergröße (0,001 bis 1920; Standard = 1000) in Pixeln. Durchgängige Abweichungen von der eingepassten Linie oder dem eingepassten Kreis, die diesen Wert überschreiten, werden nicht als Fehler gewertet.

Geschlossen Fläche aktiviert

Legt fest, ob das Werkzeug Flächenfehler berücksichtigt. Standardmäßig ist dieser Parameter deaktiviert. Flächenfehler werden entlang der eingepassten Linie oder des eingepassten Kreises erkannt. Außerdem wird der Abstand der fehlerhaften Kante von der eingepassten Linie oder dem eingepassten Kreis ermittelt.

Hinweis: Wenn die Optionen Größe aktiviert und Fläche aktiviert beide auf Ein gesetzt sind, werden nur Fehler angezeigt, die beide Bedingungen nicht erfüllen.
Geschlossen Mindestbereich

Legt den Mindestflächenfehler (0,001 bis 1000000; Standard = 10) in Pixeln fest. Ein Bereich, der diesen Wert unterschreitet, wird nicht als Fehler gewertet.

Geschlossen Max Fläche

Legt den maximalen Flächenfehler (0,001 bis 1000000; Standard = 1000000) in Pixeln fest. Ein Bereich, der diesen Wert überschreitet, wird nicht als Fehler gewertet.

Geschlossen Fehlerfilter

Legt fest, ob Fehler basierend auf ihrer Position in Bezug auf die Linienanpassung gefiltert werden ("Kein Filter", "Fehler links neben der Linienanpassung ignorieren", "Fehler rechts neben der Linienanpassung ignorieren"; Standard = "Kein Filter").


Fehlererkennungswerkzeug "Kante" – Registerkarte "Zwischenräume"

Wenn die Registerkarte Zwischenräume ausgewählt ist, zeigt das Werkzeug den eingepassten Kreis bzw. die Linie sowie alle ermittelten Fehler oder Zwischenräume. Zwischenräume sind Kantenabweichungen von der eingepassten Linie bzw. dem eingepassten Kreis.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Zwischenräume suchen

Legt fest, ob das Werkzeug Zwischenräume in der gefundenen Kante erkennt. Standardmäßig ist dieser Parameter aktiviert.

Geschlossen Minimaler Zwischenraum

Definiert den minimalen Zwischenraum (0,001 bis 1920; Standard = 3) in Pixeln. Zwischenräume, die diesen Wert unterschreiten, werden nicht als Zwischenräume gewertet.

Geschlossen Maximaler Zwischenraum

Definiert den maximalen Zwischenraum (0,001 bis 1920; Standard = 1000) in Pixeln. Zwischenräume, die diesen Wert überschreiten, werden nicht als Zwischenräume gewertet.

Geschlossen Endzwischenräume ignorieren

Legt fest, ob das Werkzeug Zwischenräume am Anfang und am Ende des Bereichs erkennt. Standardmäßig ist dieser Parameter deaktiviert.

Geschlossen Ergebnis

Zeigt die Gesamtzahl der ermittelten Fehler bzw. Zwischenräume an.


Fehlererkennungswerkzeug "Kante" – Registerkarten "Fehler" und "Zwischenräume"

Die Registerkarten Fehler und Zwischenräume zeigen die ersten 10 ermittelten Fehler bzw. Zwischenräume, die nach Position entlang der Kante sortiert werden.

Geschlossen Index

Gibt die Reihenfolge der ermittelten Fehler bzw. Zwischenräume an, die nach der Position entlang der Kante sortiert werden; 1 bis 10 (numerische Reihenfolge in EasyBuilder basiert auf 0 = 1).

Geschlossen X

Gibt die X-Koordinate des Rechtecks zurück, das den Fehler bzw. Zwischenraum umgibt (wenn "Kalibrierte Einheiten" ausgewählt ist und das Bild im Schritt Bild einrichten kalibriert wurde; andernfalls wird der Pixelwert angezeigt).

Geschlossen Y

Gibt die Y-Koordinate des Rechtecks zurück, das den Fehler bzw. Zwischenraum umgibt (wenn "Kalibrierte Einheiten" ausgewählt ist und das Bild im Schritt Bild einrichten kalibriert wurde; andernfalls wird der Pixelwert angezeigt).

Geschlossen Fläche

Gibt die Fläche des Rechtecks zurück, das den Fehler bzw. den Zwischenraum umgibt.

Geschlossen Größe

Gibt die Größe (Länge) des Fehlers bzw. Zwischenraums entlang der Kante zurück.

Geschlossen Caliper

Gibt den Bereich von Calipern ein, den der Fehler bzw. Zwischenraum umfasst.

Geschlossen Kalibrierte Einheiten/Pixel

Legt fest, ob die Tabelle Ergebnisse in echten Koordinaten (Kalibrierte Einheiten) oder in Pixel (Pixel) anzeigt.

Hinweis: Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.


Werkzeuge zur Fehlererkennung – Kantenpaar

Das Fehlererkennungswerkzeug "Kantenpaar" erzeugt eingepasste Linien oder Kreise mithilfe von Kantenanalyse-Caliperarrays, die die exakte Position der Kantenmerkmale ermitteln. Sobald die Kanten ermittelt wurden, erzeugt das Werkzeug eingepasste Linien oder Kreise (je nachdem, ob das Kantenmerkmal eine Kurve beinhaltet) über den Kantenmerkmalen und prüft die Kante auf Abweichungen wie Fehler oder Zwischenräume. Die Anzahl der Fehler oder Zwischenräume wird angezeigt.

Hinweis:
  • Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
  • Alle Eingabewerte werden in Pixeln angegeben, auch wenn das Werkzeug in reellen Einheiten kalibriert wurde.

Das Fehlerkennungswerkzeug "Kantenpaar" ist hilfreich, um sicherzustellen, dass die Kantenmerkmale des Teils oder Objekts keine Abweichungen wie Fehler oder Zwischenräume aufweisen. Sie können beispielsweise feststellen, ob die Kanten des Teils bzw. Objekts ihre Form beibehalten und ob die Kanten Dellen oder Kerben aufweisen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Fehlererkennungswerkzeugs "Kantenpaar"

Wählen Sie nach dem Hinzufügen des Werkzeugs den maskierten Bereich im Bild über dem Kantenmerkmal aus, das Sie inspizieren möchten:

  1. Positionieren und konfigurieren Sie den Bereich innerhalb des Bildes über dem Kantenmerkmal. Stellen Sie beim Platzieren des Bereichs sicher, dass die Kanten parallel zur Suchrichtung des Bereichs verlaufen und der Bereich so viel wie möglich vom Kantenmerkmal umschließt, wobei unnötiges oder unerwünschtes Rauschen aus dem Bereich ausgeschlossen wird.

    Hinweis: Die gestrichelte gelbe Linie im Maskierten Bereich legt eine Fläche innerhalb des Bereichs fest, in der Kantenübergänge ermittelt werden.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Wählen Sie nach der Bestätigung des Bereichs die verschiedenen Registerkarten Kanten, Kantengüte, Passform, Fehler und Zwischenräume, und passen Sie die Parameter und den Bereich nach Bedarf an, um sicherzustellen, dass das Werkzeug die korrekten Kantenkandidaten ermittelt und die korrekte eingepasste Linie bzw. den korrekten eingepassten Kreis erzeugt. Verwenden Sie beim ersten Einrichten des Werkzeugs ein Bild, das die idealen Kantenmerkmale enthält. Nachfolgende Bildaufnahmen enthalten dann Kantenkandidaten, die auf Abweichungen wie Fehler oder Zwischenräume untersucht werden.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um die erwarteten Bereiche und Abweichungen auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Fehlererkennungswerkzeugs "Kantenpaar"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Fehlererkennungswerkzeugs "Kantenpaar" umfasst die folgenden Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Kanten"
  • Registerkarte "Kantengüte"
  • Registerkarte "Anpassen"
  • Registerkarte "Fehler"
  • Registerkarte "Zwischenräume"
  • Registerkarten "Kante 0 Fehler", "Kante 1 Feler" und "Zwischenräume"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Kanten“

Registerkarte „Kantengüte“

Registerkarte „Passform“

Registerkarte „Fehler“

Registerkarte „Zwischenräume“

Registerkarten „Kante 0 Fehler“, „Kante 1 Fehler“ und „Zwischenraumtabelle“


Fehlererkennungswerkzeug „Kantenpaar“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „EdgePairDefect_1“, sofern es sich um das erste Fehlererkennungswerkzeug „Kantenpaar“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „EdgePairDefect_2“, „EdgePairDefect_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Fehlererkennungswerkzeug "Kantenpaare" – Registerkarte "Kanten"

Bei Auswahl der Registerkarte Kanten zeigt das Werkzeug alle ermittelten Kanten im Bereich grün hervorgehoben an. Sie können die Parameter Caliper-Größe, Caliper-Abstand, Kantenbreite und Mindestkontrast nach Bedarf anpassen, um die gewünschten Kanten zu isolieren.

Sie können auch alle Caliper anzeigen, indem Sie den Parameter Alle Caliper anzeigen aktivieren.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Caliper-Größe

Definiert die pro Caliper zu analysierende Pixelanzahl in Inspektionsrichtung (1 bis 639; Standard = 5).

Geschlossen Caliper-Abstand

Definiert den Abstand in Pixel zwischen dem Ende eines Caliper und dem Anfang des nächsten Caliper (-1 bis 639; Standard = 0).

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 10; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Minimaler Kontrast

Definiert den minimalen Graustufen-Kontrastübergang (1 bis 255; Standard = 10), der als Kante gewertet wird.

Geschlossen Caliper-Anzahl

Zeigt die Gesamtanzahl der Caliper im Bereich an.

Geschlossen Caliper-Index

Legt die einzelnen Caliper fest, die isoliert und angezeigt werden.

Geschlossen Alle Caliper anzeigen

Definiert, ob alle Caliper in dem Bereich immer angezeigt werden. Standardmäßig sind die Caliper ausgeblendet.


Fehlererkennungswerkzeug "Kantenpaar" – Registerkarte "Kantengüte"

Bei Auswahl der Registerkarte Kantengüte zeigt das Werkzeug mithilfe kleiner, farbcodierter Kreise alle gefundenen Kantenkandidaten im Bereich (der ausgewählt oder angepasst werden kann) und die eingepasste Linie oder den eingepassten Kreis an. Die Kantenkandidaten stellten die möglichen Kanten dar, die beim Erzeugen der eingepassten Linie oder des eingepassten Kreises berücksichtigt werden. Passen Sie die Parameter an, um die gewünschten Kantenkandidaten zu isolieren.

Alle erkannten Fehler und Zwischenräume werden ebenfalls angezeigt.

Geschlossen Kantenrichtung suchen

Definiert die Richtung, in der das Werkzeug relativ zum Bereich Kanten ermittelt (Links nach rechts, Rechts nach links, Mitte nach außen oder Außen nach innen ; Standard = Links nach rechts).

Geschlossen Übergang Kante 0

Definiert den Übergang der ersten ermittelten Kante (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Übergang Kante1

Definiert den Übergang der zweiten ermittelten Kante (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Regel:Erste Kante

Definiert, ob die erste ermittelte Kante bei der Entscheidung, ob ein Kantenkandidat als Kante gewertet wird, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Regel:Stärkste Kante

Definiert, ob die Kante mit dem stärksten Kontrastübergang bei der Entscheidung, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Regel:Paargröße

Legt fest, ob das ermittelte Kantenpaar mit der zum Parameter "Paargröße" nächstliegenden Größe die höchste Priorität erhält, wenn entschieden wird, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt (standardmäßig ist diese Einstellung deaktiviert).

Geschlossen Paargröße

Definiert die Kantenpaargröße, bei der die höchste Güte erreicht wird (1 bis 1920; Standard = 5). Bei Aktivierung dieses Parameters werden ermittelte Kantenpaare oberhalb oder unterhalb dieses Wertes proportional zu diesem Wert ausgewertet. Wenn beispielsweise die Paargröße auf 10 eingestellt ist und zwei Kantenpaarkandidaten jeweils mit den Werten 8 und 14 ermittelt wurden, wird das Kantenpaar mit dem Wert 8 ausgewählt, weil es näher an der Grenze liegt als das zweite Kantenpaar. Der Parameter Regel: Paargröße muss auf EIN gesetzt sein, um diesen Parameter zu aktivieren.

Geschlossen Schwellenwert für Güte

Definiert einen Schwellenwert für die Güte, um Kanten mit einer Güte (0 bis 255; Standard = 10) unterhalb dieses Werts herauszufiltern.


Fehlererkennungswerkzeugs "Kantenpaar" - Registerkarte "Anpassen"

Wenn die Registerkarte Passform ausgewählt ist, zeigt das Werkzeug alle gefundenen Kantenkandidaten innerhalb des Bereichs und des eingepassten Kreises oder der eingepassten Linie an. Die Kantenkandidaten sind die möglichen Kanten, die beim Erzeugen des eingepassten Kreises oder der eingepassten Linie berücksichtigt werden. Sie werden durch kleine, farbcodierte Kreise angezeigt.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Ausreißer filtern

Legt fest, ob das Werkzeug Punkte aus der eingepassten Linie entfernt, deren Abstand größer ist als durch den Parameter "Abstandfilter anpassen" definiert (standardmäßig ist dieser Parameter aktiviert).

Geschlossen Abstandfilter anpassen

Definiert den Abstand (1 bis 1920; Standard = 2) in Pixeln einer Kante von der ursprünglichen eingepassten Linie, der zur Berechnung der erneuten Anpassung verwendet wird. Mithilfe dieses Parameters wird vermieden, dass Fehler die Linienanpassung beeinträchtigen.

Hinweis: Der Parameter "Ausreißer filtern" muss aktiviert sein, um diesen Parameter zu verwenden.
Geschlossen Höchster Punktfilterabstand

Definiert den Ausreißerabstand (1 bis 1920; Standard = 1000), bei dessen Überschreitung Kanten nicht zur Bestimmung der Mindest- und Höchstabstände verwendet werden. Alle Kanten, die diesen Wert überschreiten, werden ignoriert.

Geschlossen Erneut auswerten

Definiert, ob die ermittelten Kanten erneut ausgewertet werden, um sicherzustellen, dass ermittelte Kanten, die ursprünglich gelöscht wurden, korrekt gefiltert wurden (standardmäßig ist dieser Parameter aktiviert).

Geschlossen Erneut anpassen

Legt fest, ob das Werkzeug die eingepasste Linie nach der erneuten Auswertung der Kanten erneut anpasst (dieser Parameter ist standardmäßig aktiviert).

Hinweis: Die Genauigkeit des Werkzeugs ist höher, wenn dieser Parameter aktiviert ist. Die Verarbeitungszeit erhöht sich jedoch.


Fehlererkennungswerkzeug "Kantenpaar" – Registerkarte "Fehler"

Bei Auswahl der Registerkarte Fehler zeigt das Werkzeug den eingepassten Kreis oder die eingepasste Linie sowie alle ermittelten Fehler oder Zwischenräume. "Fehler" werden als Kantenabweichungen von der eingepassten Linie bzw. dem eingepassten Kreis angegeben.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Mindestabstand

Legt fest, dass ein beliebiger Abstand (0,001 bis 1920; Standard = 4) in Pixeln von der Kante und der eingepassten Linie oder dem eingepassten Kreis unterhalb dieses Werts nicht als Fehler gewertet wird.

Geschlossen Höchstabstand

Legt fest, dass ein beliebiger Abstand (0,001 bis 1920; Standard = 1000) in Pixeln von der Kante und der eingepassten Linie oder dem eingepassten Kreis, der diesen Wert überschreitet, nicht als Fehler gewertet wird.

Geschlossen Größe aktiviert

Legt fest, ob das Werkzeug Größenfehler (entlang der Kantenlänge) erkennt. Standardmäßig ist dieser Parameter aktiviert.

Hinweis: Wenn die Optionen Größe aktiviert und Fläche aktiviert beide auf Ein gesetzt sind, werden nur Fehler angezeigt, die beide Bedingungen nicht erfüllen.
Geschlossen Mindestgröße

Definiert die minimale Fehlergröße (0,001 bis 1920; Standard = 10) in Pixeln. Durchgängige Abweichungen von der eingepassten Linie oder dem eingepassten Kreis, die diesen Wert überschreiten, werden nicht als Fehler gewertet.

Geschlossen Maximalgröße

Definiert die maximale Fehlergröße (0,001 bis 1920; Standard = 1000) in Pixeln. Durchgängige Abweichungen von der eingepassten Linie oder dem eingepassten Kreis, die diesen Wert überschreiten, werden nicht als Fehler gewertet.

Geschlossen Fläche aktiviert

Legt fest, ob das Werkzeug Flächenfehler berücksichtigt. Standardmäßig ist dieser Parameter deaktiviert. Flächenfehler werden entlang der eingepassten Linie oder des eingepassten Kreises erkannt. Außerdem wird der Abstand der fehlerhaften Kante von der eingepassten Linie oder dem eingepassten Kreis ermittelt.

Hinweis: Wenn die Optionen Größe aktiviert und Fläche aktiviert beide auf Ein gesetzt sind, werden nur Fehler angezeigt, die beide Bedingungen nicht erfüllen.
Geschlossen Mindestbereich

Legt den Mindestflächenfehler (0,001 bis 1000000; Standard = 10) in Pixeln fest. Ein Bereich, der diesen Wert unterschreitet, wird nicht als Fehler gewertet.

Geschlossen Max Fläche

Legt den maximalen Flächenfehler (0,001 bis 1000000; Standard = 1000000) in Pixeln fest. Ein Bereich, der diesen Wert überschreitet, wird nicht als Fehler gewertet.

Geschlossen Fehlerfilter

Legt fest, ob Fehler basierend auf ihrer Position in Bezug auf die Linienanpassung gefiltert werden ("Kein Filter", "Fehler links neben der Linienanpassung ignorieren", "Fehler rechts neben der Linienanpassung ignorieren"; Standard = "Kein Filter").


Fehlererkennungswerkzeugs "Kantenpaar" - Registerkarte "Zwischenräume"

Wenn die Registerkarte Zwischenräume ausgewählt ist, zeigt das Werkzeug den eingepassten Kreis bzw. die Linie sowie alle ermittelten Fehler oder Zwischenräume. Zwischenräume sind Kantenabweichungen von der eingepassten Linie bzw. dem eingepassten Kreis.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Zwischenräume suchen

Legt fest, ob das Werkzeug Zwischenräume in der gefundenen Kante erkennt. Standardmäßig ist dieser Parameter aktiviert.

Geschlossen Minimaler Zwischenraum

Definiert den minimalen Zwischenraum (0,001 bis 1920; Standard = 3) in Pixeln. Zwischenräume, die diesen Wert unterschreiten, werden nicht als Zwischenräume gewertet.

Geschlossen Maximaler Zwischenraum

Definiert den maximalen Zwischenraum (0,001 bis 1920; Standard = 1000) in Pixeln. Zwischenräume, die diesen Wert überschreiten, werden nicht als Zwischenräume gewertet.

Geschlossen Endzwischenräume ignorieren

Legt fest, ob das Werkzeug Zwischenräume am Anfang und am Ende des Bereichs erkennt. Standardmäßig ist dieser Parameter deaktiviert.

Geschlossen Ergebnis

Zeigt die Gesamtzahl der ermittelten Fehler bzw. Zwischenräume an.


Fehlererkennungswerkzeug "Kantenpaar" – Registerkarten "Kante 0 Fehler", "Kante 1 Fehler" und Tabelle "Zwischenräume"

Die Registerkarten Kante 0 Fehler, Kante 1 Fehler und die Tabelle Zwischenräume zeigen die ersten 10 ermittelten Fehler bzw. Zwischenräume, die nach Position entlang der Kante sortiert werden. Kante 0 bezieht sich auf die erste ermittelte Kante des Paars und Kante 1 auf die zweite Kante.

Geschlossen Index

Gibt die Reihenfolge der ermittelten Fehler bzw. Zwischenräume an, die nach der Position entlang der Kante sortiert werden; 1 bis 10 (numerische Reihenfolge in EasyBuilder basiert auf 0 = 1).

Geschlossen X

Gibt die X-Koordinate des Rechtecks zurück, das den Fehler bzw. Zwischenraum umgibt (wenn "Kalibrierte Einheiten" ausgewählt ist und das Bild im Schritt Bild einrichten kalibriert wurde; andernfalls wird der Pixelwert angezeigt).

Geschlossen Y

Gibt die Y-Koordinate des Rechtecks zurück, das den Fehler bzw. Zwischenraum umgibt (wenn "Kalibrierte Einheiten" ausgewählt ist und das Bild im Schritt Bild einrichten kalibriert wurde; andernfalls wird der Pixelwert angezeigt).

Geschlossen Fläche

Gibt die Fläche des Rechtecks zurück, das den Fehler bzw. den Zwischenraum umgibt.

Geschlossen Größe

Gibt die Größe (Länge) des Fehlers bzw. Zwischenraums entlang der Kante zurück.

Geschlossen Caliper

Gibt den Bereich von Calipern ein, den der Fehler bzw. Zwischenraum umfasst.

Geschlossen Kalibrierte Einheiten/Pixel

Legt fest, ob die Tabelle Ergebnisse in echten Koordinaten (Kalibrierte Einheiten) oder in Pixel (Pixel) anzeigt.

Hinweis: Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.


Werkzeuge zur Fehlererkennung – Kantenbreite

Das Fehlererkennungswerkzeug "Kantenbreite" misst die Stärke eines Kantenpaars und prüft, dass diese Stärke innerhalb der Toleranzwerte liegt. Das Werkzeug verwendet Kantenanalyse-Caliperarrays, um die exakte Position der Kantenmerkmale zu ermitteln und Abweichungen der Kanten, wie Fehler oder Zwischenräume festzustellen. Die Anzahl der Fehler bzw. Zwischenräume wird angezeigt.

Hinweis:
  • Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
  • Alle Eingabewerte werden in Pixeln angegeben, auch wenn das Werkzeug in reellen Einheiten kalibriert wurde.

Das Fehlerkennungswerkzeug "Kantenbreite" ist hilfreich, um sicherzustellen, dass die Kantenmerkmale des Teils oder Objekts keine Abweichungen wie Fehler oder Zwischenräume aufweisen. Sie können beispielsweise feststellen, ob eine geschweißte Naht jedes Mal die richtige Breite behält.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Fehlererkennungswerkzeugs "Kantenbreite"

Wählen Sie nach dem Hinzufügen des Werkzeugs den Typ des Bereichs aus, und konfigurieren Sie ihn im Bild über dem Kantenmerkmal, das Sie inspizieren möchten:

  1. Wählen Sie aus dem Dropdownmenü Bereichstyp Ihren Bereich: Maskierter Bereich oder Polylinienpfad. Positionieren und konfigurieren Sie den Bereich innerhalb des Bildes über dem Kantenmerkmal. Stellen Sie beim Platzieren des Bereichs sicher, dass die Kanten parallel zur Suchrichtung des Bereichs verlaufen und der Bereich so viel wie möglich vom Kantenmerkmal umschließt, wobei unnötiges oder unerwünschtes Rauschen aus dem Bereich ausgeschlossen wird.

    Hinweis: Die gestrichelte gelbe Linie im Maskierten Bereich legt eine Fläche innerhalb des Bereichs fest, in der Kantenübergänge ermittelt werden.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Wählen Sie nach der Bestätigung des Bereichs die verschiedenen Registerkarten Kanten, Kantengüte, Ausreißer, Fehler und Zwischenräume, und passen Sie die Parameter und den Bereich nach Bedarf an, um sicherzustellen, dass das Werkzeug die korrekten Kantenkandidaten ermittelt. Verwenden Sie beim ersten Einrichten des Werkzeugs ein Bild, das die idealen Kantenmerkmale enthält. Nachfolgende Bildaufnahmen enthalten dann Kantenkandidaten, die auf Abweichungen wie Fehler oder Zwischenräume untersucht werden.

    Hinweis: Das Werkzeug erstellt optional eine eingepasste Linie oder einen eingepassten Kreis, wenn auf der Registerkarte Ausreißer der Parameter Erneut auswerten aktiviert ist.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um die erwarteten Bereiche und Abweichungen auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Fehlererkennungswerkzeugs "Kantenbreite"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Fehlererkennungswerkzeugs "Kantenbreite" umfasst die folgenden Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Kanten"
  • Registerkarte "Kantengüte"
  • Registerkarte "Ausreißer"
  • Registerkarte "Fehler"
  • Registerkarte "Zwischenräume"
  • Registerkarten "Breitenfehler" und "Zwischenraumtabelle"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Kanten“

Registerkarte „Kantengüte“

Registerkarte „Ausreißer“

Registerkarte „Fehler“

Registerkarte „Zwischenräume“

Registerkarten „Breitenfehler“ und „Zwischenraumtabelle“


Fehlererkennungswerkzeug „Kantenbreite“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „EdgeWidth_1, sofern es sich um das erste Fehlererkennungswerkzeug „Kantenbreite“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „EdgeWidth_2“, „EdgeWidth_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen Bereichstyp

Definiert den Typ des Bereichs (Maskierter Bereich oder Polylinienpfad; Standard = Maskierter Bereich), der vom Werkzeug zum Erkennen der Kantenmerkmale verwendet wird.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Fehlererkennungswerkzeug "Kantenbreite" – Registerkarte "Kanten"

Bei Auswahl der Registerkarte Kanten zeigt das Werkzeug alle ermittelten Kanten im Bereich grün hervorgehoben an. Sie können die Parameter Caliper-Größe, Caliper-Abstand, Kantenbreite und Mindestkontrast nach Bedarf anpassen, um die gewünschten Kanten zu isolieren.

Sie können auch alle Caliper anzeigen, indem Sie den Parameter Alle Caliper anzeigen aktivieren.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Caliper-Größe

Definiert die pro Caliper zu analysierende Pixelanzahl in Inspektionsrichtung (1 bis 639; Standard = 5).

Geschlossen Caliper-Abstand

Definiert den Abstand in Pixel zwischen dem Ende eines Caliper und dem Anfang des nächsten Caliper (-1 bis 639; Standard = 0).

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 10; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Minimaler Kontrast

Definiert den minimalen Graustufen-Kontrastübergang (1 bis 255; Standard = 10), der als Kante gewertet wird.

Geschlossen Caliper-Anzahl

Zeigt die Gesamtanzahl der Caliper im Bereich an.

Geschlossen Caliper-Index

Legt die einzelnen Caliper fest, die isoliert und angezeigt werden.

Geschlossen Alle Caliper anzeigen

Definiert, ob alle Caliper in dem Bereich immer angezeigt werden. Standardmäßig sind die Caliper ausgeblendet.


Fehlererkennungswerkzeug "Kantenbreite" – Registerkarte "Kantengüte"

Wenn die Registerkarte Kantengüte ausgewählt ist, zeigt das Werkzeug alle gefundenen Kantenkandidaten mithilfe von kleinen, farbcodierten Kreisen innerhalb des Bereichs an (der hier auch ausgewählt oder angepasst werden kann). Passen Sie die Parameter an, um die gewünschten Kantenkandidaten zu isolieren.

Hinweis: Das Werkzeug erstellt optional eine eingepasste Linie oder einen eingepassten Kreis, wenn auf der Registerkarte Ausreißer der Parameter Erneut auswerten aktiviert ist.

Alle ermittelten Fehler und Zwischenräume werden ebenfalls angezeigt, sowie die minimale und maximale Breite der Kanten, die durch gelbe Linien gekennzeichnet sind.

Geschlossen Kantenrichtung suchen

Definiert die Richtung, in der das Werkzeug relativ zum Bereich Kanten ermittelt (Links nach rechts, Rechts nach links, Mitte nach außen oder Außen nach innen ; Standard = Links nach rechts).

Geschlossen Übergang Kante 0

Definiert den Übergang der ersten ermittelten Kante (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Übergang Kante1

Definiert den Übergang der zweiten ermittelten Kante (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Regel:Erste Kante

Definiert, ob die erste ermittelte Kante bei der Entscheidung, ob ein Kantenkandidat als Kante gewertet wird, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Regel:Stärkste Kante

Definiert, ob die Kante mit dem stärksten Kontrastübergang bei der Entscheidung, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Kontrastobergrenze

Definiert den oberen Grenzwert des Kantenkontrastübergangs (2 bis 255; Standard = 255), der als Kante gewertet wird. Kanten, deren Kantenkontrastübergang über diesem Wert liegt, haben den gleichen Höchstwert.

Geschlossen Regel:Paargröße

Legt fest, ob das ermittelte Kantenpaar mit der zum Parameter "Paargröße" nächstliegenden Größe die höchste Priorität erhält, wenn entschieden wird, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt (standardmäßig ist diese Einstellung deaktiviert).

Geschlossen Paargröße

Definiert die Kantenpaargröße, bei der die höchste Güte erreicht wird (1 bis 1920; Standard = 5). Bei Aktivierung dieses Parameters werden ermittelte Kantenpaare oberhalb oder unterhalb dieses Wertes proportional zu diesem Wert ausgewertet. Wenn beispielsweise die Paargröße auf 10 eingestellt ist und zwei Kantenpaarkandidaten jeweils mit den Werten 8 und 14 ermittelt wurden, wird das Kantenpaar mit dem Wert 8 ausgewählt, weil es näher an der Grenze liegt als das zweite Kantenpaar. Der Parameter Regel: Paargröße muss auf EIN gesetzt sein, um diesen Parameter zu aktivieren.

Geschlossen Schwellenwert für Güte

Definiert einen Schwellenwert für die Güte, um Kanten mit einer Güte (0 bis 255; Standard = 10) unterhalb dieses Werts herauszufiltern.


Fehlererkennungswerkzeug "Kantenbreite" – Registerkarte "Ausreißer"

Wenn die Registerkarte Ausreißer ausgewählt ist, zeigt das Werkzeug alle gefundenen Kantenkandidaten innerhalb des Bereichs und der eingepassten Linie oder des eingepassten Kreises an. Die Kantenkandidaten sind die möglichen Kanten, die beim Erzeugen von eingepassten Linien bzw. Kreisen berücksichtigt werden. Sie werden durch kleine, farbcodierte Kreise angezeigt.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Alle ermittelten Fehler und Zwischenräume werden ebenfalls angezeigt, sowie die minimale und maximale Breite der Kanten, die durch gelbe Linien gekennzeichnet sind.

Geschlossen Erneut auswerten

Legt fest, ob das Werkzeug die eingepasste Linie nach der erneuten Auswertung der Kanten erneut anpasst (dieser Parameter ist standardmäßig deaktiviert).

Hinweis: Die Genauigkeit des Werkzeugs ist höher, wenn dieser Parameter aktiviert ist. Die Verarbeitungszeit erhöht sich jedoch.
Geschlossen An Linie anpassen

Legt den Typ der eingepassten Linie fest ("Automatisch anpassen", "An gerade Linie anpassen" oder "An Kreislinie anpassen"; Standard = "Automatisch anpassen"), die aus den ermittelten Kanten erstellt wird.

Hinweis: Der Parameter "Erneut auswerten" muss aktiviert sein, um diesen Parameter zu verwenden.
Geschlossen Ausreißer filtern

Legt fest, ob das Werkzeug Punkte aus der eingepassten Linie entfernt, deren Abstand größer ist als durch den Parameter "Abstandfilter anpassen" definiert (standardmäßig ist dieser Parameter deaktiviert).

Geschlossen Abstandfilter anpassen

Definiert den Abstand (1 bis 1920; Standard = 2) in Pixeln einer Kante von der ursprünglichen eingepassten Linie, der zur Berechnung der erneuten Anpassung verwendet wird. Mithilfe dieses Parameters wird vermieden, dass Fehler die Linienanpassung beeinträchtigen.

Hinweis: Der Parameter "Ausreißer filtern" muss aktiviert sein, um diesen Parameter zu verwenden.


Fehlererkennungswerkzeug "Kantenbreite" – Registerkarte "Fehler"

Bei Auswahl der Registerkarte Fehler zeigt das Werkzeug (mithilfe gelber Linien) die minimale und maximale Stärke des erkannten Kantenpaars sowie alle erkannten Fehler oder Zwischenräume an.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Min Breite

Gibt an, dass ein Breitenabstand (0,001 bis 1920; Standard = 3) (in Pixeln) zwischen ermittelten Kantenpaaren, der diesen Wert unterschreitet, nicht als Fehler gewertet wird.

Geschlossen Max Breite

Gibt an, dass ein Breitenabstand (0,001 bis 1920; Standard = 1000) (in Pixeln) zwischen ermittelten Kantenpaaren, der diesen Wert überschreitet, nicht als Fehler gewertet wird.

Geschlossen Größe aktiviert

Legt fest, ob das Werkzeug Größenfehler (entlang der Kantenlänge) erkennt. Standardmäßig ist dieser Parameter aktiviert.

Hinweis: Wenn die Optionen Größe aktiviert und Fläche aktiviert beide auf Ein gesetzt sind, werden nur Fehler angezeigt, die beide Bedingungen nicht erfüllen.
Geschlossen Mindestgröße

Definiert die minimale Fehlergröße (0,001 bis 1920; Standard = 10) in Pixeln. Durchgängige Abweichungen von der eingepassten Linie oder dem eingepassten Kreis, die diesen Wert überschreiten, werden nicht als Fehler gewertet.

Geschlossen Maximalgröße

Definiert die maximale Fehlergröße (0,001 bis 1920; Standard = 1000) in Pixeln. Durchgängige Abweichungen von der eingepassten Linie oder dem eingepassten Kreis, die diesen Wert überschreiten, werden nicht als Fehler gewertet.

Geschlossen Fläche aktiviert

Legt fest, ob das Werkzeug Flächenfehler berücksichtigt. Standardmäßig ist dieser Parameter deaktiviert. Flächenfehler werden entlang der eingepassten Linie oder des eingepassten Kreises erkannt. Außerdem wird der Abstand der fehlerhaften Kante von der eingepassten Linie oder dem eingepassten Kreis ermittelt.

Hinweis: Wenn die Optionen Größe aktiviert und Fläche aktiviert beide auf Ein gesetzt sind, werden nur Fehler angezeigt, die beide Bedingungen nicht erfüllen.
Geschlossen Mindestbereich

Legt den Mindestflächenfehler (0,001 bis 1000000; Standard = 10) in Pixeln fest. Ein Bereich, der diesen Wert unterschreitet, wird nicht als Fehler gewertet.

Geschlossen Max Fläche

Legt den maximalen Flächenfehler (0,001 bis 1000000; Standard = 1000000) in Pixeln fest. Ein Bereich, der diesen Wert überschreitet, wird nicht als Fehler gewertet.


Fehlererkennungswerkzeug "Kantenbreite" – Registerkarte "Zwischenräume"

Wenn die Registerkarte Zwischenräume ausgewählt ist, zeigt das Werkzeug den eingepassten Kreis oder die eingepasste Linie (falls aktiviert) sowie alle ermittelten Fehler oder Zwischenräume. Zwischenräume sind Kantenabweichungen von eingepassten Linien bzw. Kreisen.

Auf dieser Registerkarte kann auch der Bereich ausgewählt und angepasst werden.

Geschlossen Zwischenräume suchen

Legt fest, ob das Werkzeug Zwischenräume in der gefundenen Kante erkennt. Standardmäßig ist dieser Parameter aktiviert.

Geschlossen Minimaler Zwischenraum

Definiert den minimalen Zwischenraum (0,001 bis 1920; Standard = 3) in Pixeln. Zwischenräume, die diesen Wert unterschreiten, werden nicht als Zwischenräume gewertet.

Geschlossen Maximaler Zwischenraum

Definiert den maximalen Zwischenraum (0,001 bis 1920; Standard = 1000) in Pixeln. Zwischenräume, die diesen Wert überschreiten, werden nicht als Zwischenräume gewertet.

Geschlossen Endzwischenräume ignorieren

Legt fest, ob das Werkzeug Zwischenräume am Anfang und am Ende des Bereichs erkennt. Standardmäßig ist dieser Parameter deaktiviert.

Geschlossen Ergebnis

Zeigt die Gesamtzahl der ermittelten Fehler bzw. Zwischenräume an.


Fehlererkennungswerkzeug "Kantenbreite" – Registerkarten "Breitenfehler" und "Zwischenraumtabelle".

Die Registerkarten Breitenfehler und Zwischenräume zeigen die ersten 10 ermittelten Fehler bzw. Zwischenräume, die nach Position entlang der Kante sortiert werden.

Geschlossen Index

Gibt die Reihenfolge der ermittelten Fehler bzw. Zwischenräume an, die nach der Position entlang der Kante sortiert werden; 1 bis 10 (numerische Reihenfolge in EasyBuilder basiert auf 0 = 1).

Geschlossen X

Gibt die X-Koordinate des Rechtecks zurück, das den Fehler bzw. Zwischenraum umgibt (wenn "Kalibrierte Einheiten" ausgewählt ist und das Bild im Schritt Bild einrichten kalibriert wurde; andernfalls wird der Pixelwert angezeigt).

Geschlossen Y

Gibt die Y-Koordinate des Rechtecks zurück, das den Fehler bzw. Zwischenraum umgibt (wenn "Kalibrierte Einheiten" ausgewählt ist und das Bild im Schritt Bild einrichten kalibriert wurde; andernfalls wird der Pixelwert angezeigt).

Geschlossen Fläche

Gibt die Fläche des Rechtecks zurück, das den Fehler bzw. den Zwischenraum umgibt.

Geschlossen Größe

Gibt die Größe (Länge) des Fehlers bzw. Zwischenraums entlang der Kante zurück.

Geschlossen Caliper

Gibt den Bereich von Calipern ein, den der Fehler bzw. Zwischenraum umfasst.

Geschlossen Kalibrierte Einheiten/Pixel

Legt fest, ob die Tabelle Ergebnisse in echten Koordinaten (Kalibrierte Einheiten) oder in Pixel (Pixel) anzeigt.

Hinweis: Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.


Werkzeuge zur Fehlererkennung – Sickensuche

Das Fehlererkennungswerkzeug "Sickensuche" identifiziert formunabhängig ein Sickenmerkmal (definiert durch ein Kantenpaar). Das Werkzeug sucht die Mitte der Sicke und erstellt einen Bereich, der zur Inspektion der Sickenbreite verwendet werden kann. Das Werkzeug verwendet Kantenanalyse-Caliperarrays, um die exakte Position der Kantenmerkmale zu ermitteln. Sobald das Sickenmerkmal identifiziert wurde, zeigt das Werkzeug eine Abbildung der Sicke. Alle Toleranzabweichungen bei der Sickenstärke werden entweder als Fehler oder Zwischenräume dargestellt.

Hinweis:
  • Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
  • Alle Eingabewerte werden in Pixeln angegeben, auch wenn das Werkzeug in reellen Einheiten kalibriert wurde.

Das Fehlererkennungswerkzeug "Sickensuche" ist hilfreich, um die Stärke eines Sickenmerkmals (z. B. einer geklebten Sicke), das stichprobenweise im Bildfeld angezeigt wird, zu ermitteln und zu überprüfen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Fehlererkennungswerkzeugs "Sickensuche"

Wählen Sie nach dem Hinzufügen des Werkzeugs den Typ des Bereichs aus, und konfigurieren Sie ihn im Bild über dem Kantenmerkmal, das Sie inspizieren möchten:

  1. Wählen Sie aus dem Dropdownmenü Bereichstyp Ihren Bereich: Maskierter Bereich oder Polylinienpfad. Positionieren und konfigurieren Sie den Bereich innerhalb des Bildes über dem Kantenmerkmal. Stellen Sie beim Platzieren des Bereichs sicher, dass die Kanten parallel zur Suchrichtung des Bereichs verlaufen und der Bereich so viel wie möglich vom Kantenmerkmal umschließt, wobei unnötiges oder unerwünschtes Rauschen aus dem Bereich ausgeschlossen wird.

    Hinweis: Die gestrichelte gelbe Linie im Maskierten Bereich legt eine Fläche innerhalb des Bereichs fest, in der Kantenübergänge ermittelt werden.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Wählen Sie nach der Bestätigung des Bereichs die verschiedenen Registerkarten Sicke suchen, Kanten, Kantengüte, Fehler und Zwischenräume, und passen Sie die Parameter und den Bereich nach Bedarf an, um sicherzustellen, dass das Werkzeug die korrekten Kantenkandidaten ermittelt und die korrekte Polylinie erzeugt. Verwenden Sie beim ersten Einrichten des Werkzeugs ein Bild, das die idealen Kantenmerkmale enthält. Nachfolgende Bildaufnahmen enthalten dann Kantenkandidaten, die auf Abweichungen wie Fehler oder Zwischenräume untersucht werden.
  4. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um die erwarteten Bereiche und Abweichungen auszugleichen.
  5. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Fehlererkennungswerkzeugs "Sickensuche"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Fehlererkennungswerkzeugs "Sickensuche" umfasst die folgenden Registerkarten:

  • Registerkarte „Allgemein“
  • Registerkarte "Sicke suchen"
  • Registerkarte "Kanten"
  • Registerkarte "Kantengüte"
  • Registerkarte "Fehler"
  • Registerkarte "Zwischenräume"
  • Registerkarten "Statistik", "Breitenfehler" und "Zwischenraumtabelle"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Sickensuche“

Registerkarte „Kanten“

Registerkarte „Kantengüte“

Registerkarte „Fehler“

Registerkarte „Zwischenräume“

Registerkarten „Statistik“, „Breitenfehler“ und „Zwischenraumtabelle“


Fehlererkennungswerkzeug „Sickensuche“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „BeadFinder_1“, sofern es sich um das erste Fehlererkennungswerkzeug „Sickensuche“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „BeadFinder_2“, „BeadFinder_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen Bereichstyp

Legt den Bereichstyp fest, der zur Definition des zu analysierenden Bildbereichs verwendet wird: Maskierter Bereich (Standard) oder Polylinienpfad.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Fehlererkennungswerkzeug "Sickensuche" – Registerkarte "Sickensuche"

Bei Auswahl der Registerkarte Sickensuche zeigt das Werkzeug Grafiken, die für das Ermitteln des Sickenmerkmals relevant sind. Das Werkzeug zeigt Folgendes an: alle ermittelten Kanten (grün hervorgehoben); die ausgewählten Kantenkandidaten (angezeigt durch kleine, farbcodierte Kreise) innerhalb des Bereichs (der ausgewählt und angepasst werden kann); die Position der Sicke als blaue Polylinie.

Sie können die Parameter zur Isolierung der gewünschten Kanten und Kantenkandidaten anpassen, die zur Erstellung des Polylinienpfads für das Sickenmerkmal verwendet werden.

Geschlossen Sicke-Caliper-Größe suchen

Definiert die pro Caliper zu analysierende Pixelanzahl in Inspektionsrichtung zur Suche des Sickenmerkmals (1 bis 639; Standard = 8).

Geschlossen Sicke-Caliper-Abstand suchen

Definiert den Abstand in Pixel zwischen dem Ende eines Caliper und dem Anfang des nächsten Caliper (-1 bis 639; Standard = 0).

Geschlossen Sicke-Kantenbreite suchen

Definiert den Pixelabstand (1 bis 10; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Sicke-Mindestkontrast suchen

Definiert den minimalen Graustufen-Kontrastübergang (1 bis 255; Standard = 10), der als Kante gewertet wird.

Geschlossen Sicke-Kantenrichtung suchen

Definiert die Richtung, in der das Werkzeug relativ zum Bereich Kanten ermittelt (Links nach rechts, Rechts nach links, Mitte nach außen oder Außen nach innen ; Standard = Links nach rechts).

Geschlossen Sicke-Übergang Kante 0 suchen

Definiert den Übergang der ersten ermittelten Kante (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Sicke-Übergang Kante 1 suchen

Definiert den Übergang der zweiten ermittelten Kante (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Sickenregel suchen:Erste Kante

Definiert, ob die erste ermittelte Kante bei der Entscheidung, ob ein Kantenkandidat als Kante gewertet wird, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Sickenregel suchen:Stärkste Kante

Definiert, ob die Kante mit dem stärksten Kontrastübergang bei der Entscheidung, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Sicken-Kontrastobergrenze suchen

Definiert den oberen Grenzwert des Kantenkontrastübergangs (2 bis 255; Standard = 255), der als Kante gewertet wird. Kanten, deren Kantenkontrastübergang über diesem Wert liegt, haben den gleichen Höchstwert.

Geschlossen Sickenregel suchen:Paargröße

Legt fest, ob das ermittelte Kantenpaar mit der zum Parameter "Paargröße" nächstliegenden Größe die höchste Priorität erhält, wenn entschieden wird, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt (standardmäßig ist diese Einstellung deaktiviert).

Geschlossen Sicke-Schwellenwert für Güte suchen

Definiert einen Schwellenwert für die Güte, um Kanten mit einer Güte (0 bis 255; Standard = 10) unterhalb dieses Werts herauszufiltern.

Geschlossen Sicke-Caliper suchen

Zeigt die Gesamtanzahl der Caliper im Bereich an.

Geschlossen Sicke-Caliper-Index suchen

Legt die einzelnen Caliper fest, die isoliert und angezeigt werden.

Geschlossen Sicke suchen – alle Caliper anzeigen

Definiert, ob alle Caliper in dem Bereich immer angezeigt werden. Standardmäßig sind die Caliper ausgeblendet.


Fehlererkennungswerkzeug "Sickensuche" – Registerkarte "Kanten"

Bei Auswahl der Registerkarte Kanten zeigt das Werkzeug Folgendes an: die Position des Sickenpfads in Blau, alle erkannten Kanten in Grün und die Caliper, die den Polylinienpfad definieren und aus der Position des Sickenpfads erzeugt werden, in Aquamarinblau. Die aquamarinblauen Caliper können nur mithilfe des Parameters Polylinienbreite angepasst werden.Sie können die Parameter Polylinienbreite, Caliper-Größe, Caliper-Abstand und Mindestkontrast nach Bedarf anpassen, um die gewünschten Kanten zu isolieren.

Geschlossen Polylinienbreite

Legt die Breite der Caliper fest, die zur Definition der Polylinie verwendet wird (1 bis 1920; Standard = 25).

Geschlossen Caliper-Größe

Definiert die pro Caliper zu analysierende Pixelanzahl in Inspektionsrichtung (1 bis 639; Standard = 5).

Geschlossen Caliper-Abstand

Definiert den Abstand in Pixel zwischen dem Ende eines Caliper und dem Anfang des nächsten Caliper (-1 bis 639; Standard = 0).

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 10; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Minimaler Kontrast

Definiert den minimalen Graustufen-Kontrastübergang (1 bis 255; Standard = 10), der als Kante gewertet wird.

Geschlossen Caliper-Anzahl

Zeigt die Gesamtanzahl der Caliper im Bereich an.

Geschlossen Caliper-Index

Legt die einzelnen Caliper fest, die isoliert und angezeigt werden.

Geschlossen Alle Caliper anzeigen

Definiert, ob alle Caliper in dem Bereich immer angezeigt werden. Standardmäßig sind die Caliper ausgeblendet.


Fehlererkennungswerkzeug "Sickensuche" – Registerkarte "Kantengüte"

Bei Auswahl der Registerkarte Kantengüte zeigt das Werkzeug alle erkannten Kantenkandidaten (angezeigt durch kleine, farbcodierte Kreise) innerhalb des Bereichs, ermittelte Kanten (dunkelgrün hervorgehoben), die Position der Sicke als blaue Polylinie, die minimale und maximale Breite der Sicke als gelbe Linien und alle gefundenen Fehler oder Zwischenräume an.

Geschlossen Kantenrichtung suchen

Definiert die Richtung, in der das Werkzeug relativ zum Bereich Kanten ermittelt (Links nach rechts, Rechts nach links, Mitte nach außen oder Außen nach innen; Standard = Außen nach innen).

Geschlossen Übergang Kante 0

Definiert den Übergang der ersten ermittelten Kante (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Übergang Kante1

Definiert den Übergang der zweiten ermittelten Kante (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Regel:Erste Kante

Definiert, ob die erste ermittelte Kante bei der Entscheidung, ob ein Kantenkandidat als Kante gewertet wird, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Regel:Stärkste Kante

Definiert, ob die Kante mit dem stärksten Kontrastübergang bei der Entscheidung, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Kontrastobergrenze

Definiert den oberen Grenzwert des Kantenkontrastübergangs (2 bis 255; Standard = 255), der als Kante gewertet wird. Kanten, deren Kantenkontrastübergang über diesem Wert liegt, haben den gleichen Höchstwert.

Geschlossen Regel:Paargröße

Legt fest, ob das ermittelte Kantenpaar mit der zum Parameter "Paargröße" nächstliegenden Größe die höchste Priorität erhält, wenn entschieden wird, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt (standardmäßig ist diese Einstellung deaktiviert).

Geschlossen Paargröße

Definiert die Kantenpaargröße, bei der die höchste Güte erreicht wird (1 bis 1920; Standard = 5). Bei Aktivierung dieses Parameters werden ermittelte Kantenpaare oberhalb oder unterhalb dieses Wertes proportional zu diesem Wert ausgewertet. Wenn beispielsweise die Paargröße auf 10 eingestellt ist und zwei Kantenpaarkandidaten jeweils mit den Werten 8 und 14 ermittelt wurden, wird das Kantenpaar mit dem Wert 8 ausgewählt, weil es näher an der Grenze liegt als das zweite Kantenpaar. Der Parameter Regel: Paargröße muss auf EIN gesetzt sein, um diesen Parameter zu aktivieren.

Geschlossen Schwellenwert für Güte

Definiert einen Schwellenwert für die Güte, um Kanten mit einer Güte (0 bis 255; Standard = 10) unterhalb dieses Werts herauszufiltern.


Fehlererkennungswerkzeug "Sickensuche" – Registerkarte "Fehler"

Bei Auswahl der Registerkarte Fehler zeigt das Werkzeug Grafiken zur Identifikation bzw. Klassifikation von Fehlern im Teil oder Objekt. Das Werkzeug zeigt die Position der Sicke als blaue Polylinie, kennzeichnet die minimale und maximale Stärke der Sicke durch gelbe Linien und zeigt alle erkannten Fehler bzw. Zwischenräume an.

Geschlossen Min Breite

Gibt an, dass ein Breitenabstand (0,001 bis 1920; Standard = 3) (in Pixeln) zwischen ermittelten Kantenpaaren, der diesen Wert unterschreitet, nicht als Fehler gewertet wird.

Geschlossen Max Breite

Gibt an, dass ein Breitenabstand (0,001 bis 1920; Standard = 1000) (in Pixeln) zwischen ermittelten Kantenpaaren, der diesen Wert überschreitet, nicht als Fehler gewertet wird.

Geschlossen Größe aktiviert

Legt fest, ob das Werkzeug Größenfehler (entlang der Kantenlänge) erkennt. Standardmäßig ist dieser Parameter aktiviert.

Hinweis: Wenn die Optionen Größe aktiviert und Fläche aktiviert beide auf Ein gesetzt sind, werden nur Fehler angezeigt, die beide Bedingungen nicht erfüllen.
Geschlossen Mindestgröße

Definiert die Mindestfehlergröße (0,001 - 1920; Standard = 3) in Pixeln; durchgängige Abweichungen von der Polylinie, die diesen Wert unterschreiten, werden nicht als Fehler gewertet.

Geschlossen Maximalgröße

Definiert die maximale Fehlergröße (0,001 - 1920; Standard = 1000) in Pixeln; durchgängige Abweichungen von der Polylinie, die diesen Wert überschreiten, werden nicht als Fehler gewertet.

Geschlossen Fläche aktiviert

Legt fest, ob das Werkzeug Flächenfehler berücksichtigt. Standardmäßig ist dieser Parameter aktiviert. Flächenfehler berücksichtigen die Länge entlang der Polylinie und den Abstand der fehlerhaften Kante von der Polylinie.

Hinweis: Wenn die Optionen Größe aktiviert und Fläche aktiviert beide auf Ein gesetzt sind, werden nur Fehler angezeigt, die beide Bedingungen nicht erfüllen.
Geschlossen Mindestbereich

Legt den Mindestflächenfehler (0,001 bis 1000000; Standard = 10) in Pixeln fest. Ein Bereich, der diesen Wert unterschreitet, wird nicht als Fehler gewertet.

Geschlossen Max Fläche

Legt den maximalen Flächenfehler (0,001 bis 1000000; Standard = 1000000) in Pixeln fest. Ein Bereich, der diesen Wert überschreitet, wird nicht als Fehler gewertet.


Fehlererkennungswerkzeug "Sickensuche" – Registerkarte "Zwischenräume"

Bei Auswahl der Registerkarte Zwischenräume zeigt das Werkzeug Grafiken zur Identifikation bzw. Klassifikation von Fehlern im Teil oder Objekt. Das Werkzeug zeigt die Position der Sicke als blaue Polylinie, kennzeichnet die minimale und maximale Stärke der Sicke durch gelbe Linien und zeigt alle erkannten Fehler bzw. Zwischenräume an.

Geschlossen Zwischenräume suchen

Legt fest, ob das Werkzeug Zwischenräume in der gefundenen Kante erkennt. Standardmäßig ist dieser Parameter deaktiviert.

Geschlossen Minimaler Zwischenraum

Definiert den minimalen Zwischenraum (0,001 bis 1920; Standard = 3) in Pixeln. Zwischenräume, die diesen Wert unterschreiten, werden nicht als Zwischenräume gewertet.

Geschlossen Maximaler Zwischenraum

Definiert den maximalen Zwischenraum (0,001 bis 1920; Standard = 1000) in Pixeln. Zwischenräume, die diesen Wert überschreiten, werden nicht als Zwischenräume gewertet.

Geschlossen Endzwischenräume ignorieren

Legt fest, ob das Werkzeug Zwischenräume am Anfang und am Ende des Bereichs erkennt. Standardmäßig ist dieser Parameter deaktiviert.

Geschlossen Ergebnis

Zeigt die Gesamtzahl der ermittelten Fehler bzw. Zwischenräume an.


Fehlererkennungswerkzeug "Sickensuche" – Registerkarten "Statistik", "Breitenfehler" und "Zwischenraumtabelle".

Die Registerkarte Statistiktabelle zeichnet Daten über die Funktionsweise des Werkzeugs in einem bestimmten Zeitraum auf. Die Registerkarten Breitenfehler und Zwischenraumtabelle zeigen die ersten zehn Fehler/Zwischenräume an.

Geschlossen Index

Gibt die Reihenfolge der ermittelten Fehler bzw. Zwischenräume an, die nach der Position entlang der Kante sortiert werden; 1 bis 10 (numerische Reihenfolge in EasyBuilder basiert auf 0 = 1).

Geschlossen X

Gibt die X-Koordinate des Rechtecks zurück, das den Fehler bzw. Zwischenraum umgibt (wenn "Kalibrierte Einheiten" ausgewählt ist und das Bild im Schritt Bild einrichten kalibriert wurde; andernfalls wird der Pixelwert angezeigt).

Geschlossen Y

Gibt die Y-Koordinate des Rechtecks zurück, das den Fehler bzw. Zwischenraum umgibt (wenn "Kalibrierte Einheiten" ausgewählt ist und das Bild im Schritt Bild einrichten kalibriert wurde; andernfalls wird der Pixelwert angezeigt).

Geschlossen Fläche

Gibt die Fläche des Rechtecks zurück, das den Fehler bzw. den Zwischenraum umgibt.

Geschlossen Größe

Gibt die Größe (Länge) des Fehlers bzw. Zwischenraums entlang der Kante zurück.

Geschlossen Caliper

Gibt den Bereich von Calipern ein, den der Fehler bzw. Zwischenraum umfasst.

Geschlossen Kalibrierte Einheiten/Pixel

Legt fest, ob die Tabelle Ergebnisse in echten Koordinaten (Kalibrierte Einheiten) oder in Pixel (Pixel) anzeigt.

Hinweis: Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.


Werkzeuge zur Fehlererkennung – Sickenverfolgung

Das Fehlererkennungswerkzeug "Sickenverfolgung" untersucht die Position und Stärke eines Sickenmerkmals (definiert durch ein Kantenpaar). Auf Grundlage eines vom Benutzer erstellten Kantenmodells eines Sickenmerkmals verwendet das Werkzeug Kantenanalyse-Caliperarrays, um die exakte Position der Kantenmerkmale zu ermitteln. Nach dem Erstellen des Modells mit den Sickenmerkmalen vergleicht das Werkzeug während der Laufzeit die Sickenmerkmale in den erfassten Bildern mit dem Sickenmodell, um zu prüfen, ob die Sicke sich an der korrekten Position befindet und ob Abweichungen wie Fehler oder Zwischenräume vorliegen. Die Anzahl der ermittelten Fehler bzw. Zwischenräume wird angezeigt.

Hinweis:
  • Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.
  • Alle Eingabewerte werden in Pixeln angegeben, auch wenn das Werkzeug in reellen Einheiten kalibriert wurde.

Das Fehlererkennungswerkzeug "Sickenverfolgung" ist hilfreich, um zu prüfen, ob sich ein Sickenmerkmal, z. B. eine geschweißte Sicke, an der gleichen Position befindet und keine Abweichungen in der Form oder Stärke der Sicke vorliegen.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Fehlererkennungswerkzeugs "Sickenverfolgung"

Wählen Sie nach dem Hinzufügen des Werkzeugs den Typ des Bereichs aus, und konfigurieren Sie ihn im Bild über dem Kantenmerkmal, das Sie inspizieren möchten:

  1. Wählen Sie aus dem Dropdownmenü Bereichstyp Ihren Bereich: Maskierter Bereich oder Polylinienpfad. Positionieren und konfigurieren Sie den Bereich innerhalb des Bildes über dem Kantenmerkmal. Stellen Sie beim Platzieren des Bereichs sicher, dass die Kanten parallel zur Suchrichtung des Bereichs verlaufen und der Bereich so viel wie möglich vom Kantenmerkmal umschließt, wobei unnötiges oder unerwünschtes Rauschen aus dem Bereich ausgeschlossen wird. Verwenden Sie beim ersten Einrichten des Werkzeugs ein Bild, das die idealen Kantenmerkmale enthält. Nachfolgende Bildaufnahmen enthalten dann Kantenkandidaten, die auf Abweichungen wie Fehler oder Zwischenräume untersucht werden.

    Hinweis: Die gestrichelte gelbe Linie im Maskierten Bereich legt eine Fläche innerhalb des Bereichs fest, in der Kantenübergänge ermittelt werden.

  2. Klicken Sie auf OK, um den Bereich zu bestätigen. Klicken Sie auf Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen.

  3. Wählen Sie nach der Bestätigung des Bereichs die verschiedenen Registerkarten Sicke trainieren, Kanten, Kantengüte, Fehler, Zwischenräume und Position, und passen Sie die Parameter und den Bereich nach Bedarf an, um sicherzustellen, dass das Werkzeug die korrekten Kantenkandidaten ermittelt und die korrekte Polylinie erzeugt.
  4. Sobald der Bereich und die Parameter ordnungsgemäß eingestellt wurden, wechseln Sie zur Registerkarte Sicke trainieren, und klicken Sie auf die Schaltfläche Trainieren, um das Sickenkantenmodell zu erzeugen. Nachfolgende Bildaufnahmen werden dann mit dem trainierten Sickenkantenmodell verglichen.
  5. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um die erwarteten Bereiche und Abweichungen auszugleichen.
  6. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des Fehlererkennungswerkzeugs "Sickenverfolgung"

Nach dem Festlegen und Bestätigen des Werkzeugbereichs können Sie das Werkzeug für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Fehlererkennungswerkzeugs "Sickensuche" umfasst die folgenden Registerkarten:

  • Registerkarte "Allgemein"
  • Registerkarte "Sicke trainieren"
  • Registerkarte "Kanten"
  • Registerkarte "Kantengüte"
  • Registerkarte "Fehler"
  • Registerkarte "Zwischenräume"
  • Registerkarte "Position"
  • Registerkarten "Statistik", "Breitenfehler" und "Zwischenraumtabelle"
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Sicke trainieren“

Registerkarte „Kanten“

Registerkarte „Kantengüte“

Registerkarte „Fehler“

Registerkarte „Position“

Registerkarten „Statistik“, „Breitenfehler“, „Zwischenraumtabelle“ und „Positionsfehlertabelle“

Registerkarte „Zwischenräume“


Fehlererkennungswerkzeug „Sickenverfolgung“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „BeadTracker_1“, sofern es sich um das erste Fehlererkennungswerkzeug „Sickenverfolgung“ handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „BeadTracker_2“, „BeadTracker_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeugbild

Bestimmt, welches Bild das Werkzeug für die Inspektion verwendet: das Ausgabebild eines Bildfilterwerkzeugs oder ein Farbwerkzeug (Positionswerkzeuge „Farb-Blob“ und „Farb-Blobs (1-10)“, An-/Abwesenheitswerkzeuge Farbpixelanzahl und Farb-Blob, Messungswerkzeuge „Farb-Blob-Bereich“ und „Farb-Blob-Bereich (1-10)“, Zählwerkzeug „Farb-Blobs“, Identifizierungswerkzeug „Farbmodell“ oder Filterwerkzeug für Bilder „Farbe zu binär“). Dieses Steuerelement ist nur aktiviert, wenn ein Filterwerkzeug für Bilder oder eine Farbe hinzugefügt wurde.

Geschlossen Positionsreferenz

Gibt eine Vorrichtung für das Werkzeug an. Dieses Steuerelement ist nur aktiviert, wenn bereits ein anderes Werkzeug, das eine Vorrichtung definiert, hinzugefügt wurde.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen Bereichstyp

Legt den Bereichstyp fest, der zur Definition des zu analysierenden Bildbereichs verwendet wird: Maskierter Bereich (Standard) oder Polylinienpfad.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Fehlererkennungswerkzeug "Sickenverfolgung" – Registerkarte "Sicke trainieren"

Bei Auswahl der Registerkarte Sicke trainieren zeigt das Werkzeug Grafiken, die für das Ermitteln des Sickenmerkmals relevant sind. Das Werkzeug zeigt alle ermittelten Kantenkandidaten (angezeigt durch kleine, farbcodierte Kreise) innerhalb des Bereichs und die Position der Sicke als blaue Polylinie an. Außerdem kann der Bereich angepasst werden.

Geschlossen Schaltfläche "Trainieren"

Definiert das Sickenkantenmodell. Die Schaltfläche Trainieren wird bei der Konfiguration eines Sickenkantenmodells verwendet. Klicken Sie nach der Konfiguration der Parameter und des Bereichs des Werkzeugs auf die Schaltfläche Trainieren, um die relevanten Merkmale des Sickenkantenmodells hervorzuheben. Nach dem Trainieren des Sickenkantenmodells vergleicht das Werkzeug das Sickenmerkmal in den aufgenommenen Bildern mit dem trainierten Sickenkantenmodell, um Abweichungen wie Fehler oder Zwischenräume zu ermitteln.

Hinweis: Das Werkzeug zeigt ein negatives Ergebnis, bis das Sickenkantenmodell trainiert wurde.
Geschlossen Sicke-Caliper-Größe trainieren

Definiert die pro Caliper zu analysierende Pixelanzahl in Inspektionsrichtung zur Suche des Sickenmerkmals (1 bis 639; Standard = 8).

Geschlossen Sicke-Caliper-Abstand trainieren

Definiert den Abstand in Pixel zwischen dem Ende eines Caliper und dem Anfang des nächsten Caliper (-1 bis 639; Standard = 0).

Geschlossen Sicke-Kantenbreite trainieren

Definiert den Pixelabstand (1 bis 10; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Sicke-Mindestkontrast trainieren

Definiert den minimalen Graustufen-Kontrastübergang (1 bis 255; Standard = 10), der als Kante gewertet wird.

Geschlossen Sicke-Kantenrichtung trainieren

Definiert die Richtung, in der das Werkzeug relativ zum Bereich Kanten ermittelt (Links nach rechts, Rechts nach links, Mitte nach außen oder Außen nach innen ; Standard = Links nach rechts).

Geschlossen Sicke-Übergang Kante 0 trainieren

Definiert den Übergang der ersten ermittelten Kante (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Sicke-Übergang Kante 1 trainieren

Definiert den Übergang der zweiten ermittelten Kante (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Sickenregel trainieren:Erste Kante

Definiert, ob die erste ermittelte Kante bei der Entscheidung, ob ein Kantenkandidat als Kante gewertet wird, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Sickenregel trainieren:Stärkste Kante

Definiert, ob die Kante mit dem stärksten Kontrastübergang bei der Entscheidung, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Sicke trainieren – Kontrastobergrenze suchen

Definiert den oberen Grenzwert des Kantenkontrastübergangs (2 bis 255; Standard = 255), der als Kante gewertet wird. Kanten, deren Kantenkontrastübergang über diesem Wert liegt, haben den gleichen Höchstwert.

Geschlossen Sickenregel trainieren:Paargröße

Legt fest, ob das ermittelte Kantenpaar mit der zum Parameter "Paargröße" nächstliegenden Größe die höchste Priorität erhält, wenn entschieden wird, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt (standardmäßig ist diese Einstellung deaktiviert).

Geschlossen Sicke-Schwellenwert für Güte trainieren

Definiert einen Schwellenwert für die Güte, um Kanten mit einer Güte (0 bis 255; Standard = 10) unterhalb dieses Werts herauszufiltern.

Geschlossen Sicke-Caliper trainieren

Zeigt die Gesamtanzahl der Caliper im Bereich an.

Geschlossen Sicke-Caliper-Index trainieren

Legt die einzelnen Caliper fest, die isoliert und angezeigt werden.

Geschlossen Sicke trainieren – alle Caliper anzeigen

Definiert, ob alle Caliper in dem Bereich immer angezeigt werden. Standardmäßig sind die Caliper ausgeblendet.


Fehlererkennungswerkzeug "Sickenverfolgung" – Registerkarte "Kanten"

Bei Auswahl der Registerkarte Kanten zeigt das Werkzeug Folgendes an: die Position des Sickenpfads in Blau, alle erkannten Kanten in Grün und die Caliper, die den Polylinienpfad definieren und aus der Position des Sickenpfads erzeugt werden, in Aquamarinblau. Die aquamarinblauen Caliper können nur mithilfe des Parameters Polylinienbreite angepasst werden.Sie können die Parameter Polylinienbreite, Caliper-Größe, Caliper-Abstand und Mindestkontrast nach Bedarf anpassen, um die gewünschten Kanten zu isolieren.

Geschlossen Polylinienbreite

Legt die Breite der Caliper fest, die zur Definition der Polylinie verwendet wird (1 bis 1920; Standard = 25).

Geschlossen Caliper-Größe

Definiert die pro Caliper zu analysierende Pixelanzahl in Inspektionsrichtung (1 bis 639; Standard = 5).

Geschlossen Caliper-Abstand

Definiert den Abstand in Pixel zwischen dem Ende eines Caliper und dem Anfang des nächsten Caliper (-1 bis 639; Standard = 0).

Geschlossen Kantenbreite

Definiert den Pixelabstand (1 bis 10; Standard = 3), über dem ein Kantenübergang stattfindet. Diese Einstellung dient dazu, Rauschen aus dem Bild zu filtern.

Geschlossen Minimaler Kontrast

Definiert den minimalen Graustufen-Kontrastübergang (1 bis 255; Standard = 10), der als Kante gewertet wird.

Geschlossen Caliper-Anzahl

Zeigt die Gesamtanzahl der Caliper im Bereich an.

Geschlossen Caliper-Index

Legt die einzelnen Caliper fest, die isoliert und angezeigt werden.

Geschlossen Alle Caliper anzeigen

Definiert, ob alle Caliper in dem Bereich immer angezeigt werden. Standardmäßig sind die Caliper ausgeblendet.


Fehlererkennungswerkzeug "Sickenverfolgung" – Registerkarte "Kantengüte"

Bei Auswahl der Registerkarte Kantengüte zeigt das Werkzeug alle erkannten Kantenkandidaten (angezeigt durch kleine, farbcodierte Kreise) innerhalb des Bereichs, ermittelte Kanten (dunkelgrün hervorgehoben), die Position der Sicke als blaue Polylinie, die minimale und maximale Breite der Sicke als gelbe Linien und alle gefundenen Fehler oder Zwischenräume an.

Geschlossen Kantenrichtung suchen

Definiert die Richtung, in der das Werkzeug relativ zum Bereich Kanten ermittelt (Links nach rechts, Rechts nach links, Mitte nach außen oder Außen nach innen; Standard = Außen nach innen).

Geschlossen Übergang Kante 0

Definiert den Übergang der ersten ermittelten Kante (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Übergang Kante1

Definiert den Übergang der zweiten ermittelten Kante (dunkel zu hell, hell zu dunkel oder beides; Standard = beides). Geben Sie den Übergangstyp an, um die Genauigkeit und Geschwindigkeit zu erhöhen.

Geschlossen Regel:Erste Kante

Definiert, ob die erste ermittelte Kante bei der Entscheidung, ob ein Kantenkandidat als Kante gewertet wird, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Regel:Stärkste Kante

Definiert, ob die Kante mit dem stärksten Kontrastübergang bei der Entscheidung, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt, die höchste Priorität erhält (standardmäßig ist diese Einstellung aktiviert).

Geschlossen Kontrastobergrenze

Definiert den oberen Grenzwert des Kantenkontrastübergangs (2 bis 255; Standard = 255), der als Kante gewertet wird. Kanten, deren Kantenkontrastübergang über diesem Wert liegt, haben den gleichen Höchstwert.

Geschlossen Regel:Paargröße

Legt fest, ob das ermittelte Kantenpaar mit der zum Parameter "Paargröße" nächstliegenden Größe die höchste Priorität erhält, wenn entschieden wird, ob ein Kantenkandidat die Kriterien für eine Kante erfüllt (standardmäßig ist diese Einstellung deaktiviert).

Geschlossen Paargröße

Definiert die Kantenpaargröße, bei der die höchste Güte erreicht wird (1 bis 1920; Standard = 5). Bei Aktivierung dieses Parameters werden ermittelte Kantenpaare oberhalb oder unterhalb dieses Wertes proportional zu diesem Wert ausgewertet. Wenn beispielsweise die Paargröße auf 10 eingestellt ist und zwei Kantenpaarkandidaten jeweils mit den Werten 8 und 14 ermittelt wurden, wird das Kantenpaar mit dem Wert 8 ausgewählt, weil es näher an der Grenze liegt als das zweite Kantenpaar. Der Parameter Regel: Paargröße muss auf EIN gesetzt sein, um diesen Parameter zu aktivieren.

Geschlossen Schwellenwert für Güte

Definiert einen Schwellenwert für die Güte, um Kanten mit einer Güte (0 bis 255; Standard = 10) unterhalb dieses Werts herauszufiltern.


Fehlererkennungswerkzeug "Sickenverfolgung" – Registerkarte "Fehler"

Bei Auswahl der Registerkarte Fehler zeigt das Werkzeug Grafiken zur Identifikation bzw. Klassifikation von Fehlern im Teil oder Objekt. Das Werkzeug zeigt die Position der Sicke als blaue Polylinie, kennzeichnet die minimale und maximale Stärke der Sicke durch gelbe Linien und zeigt alle erkannten Fehler bzw. Zwischenräume an.

Geschlossen Min Breite

Gibt an, dass ein Breitenabstand (0,001 bis 1920; Standard = 3) (in Pixeln) zwischen ermittelten Kantenpaaren, der diesen Wert unterschreitet, nicht als Fehler gewertet wird.

Geschlossen Max Breite

Gibt an, dass ein Breitenabstand (0,001 bis 1920; Standard = 1000) (in Pixeln) zwischen ermittelten Kantenpaaren, der diesen Wert überschreitet, nicht als Fehler gewertet wird.

Geschlossen Größe aktiviert

Legt fest, ob das Werkzeug Größenfehler (entlang der Kantenlänge) erkennt. Standardmäßig ist dieser Parameter aktiviert.

Hinweis: Wenn die Optionen Größe aktiviert und Fläche aktiviert beide auf Ein gesetzt sind, werden nur Fehler angezeigt, die beide Bedingungen nicht erfüllen.
Geschlossen Mindestgröße

Definiert die Mindestfehlergröße (0,001 - 1920; Standard = 10) in Pixeln; durchgängige Abweichungen von der Polylinie, die diesen Wert unterschreiten, werden nicht als Fehler gewertet.

Geschlossen Maximalgröße

Definiert die maximale Fehlergröße (0,001 - 1920; Standard = 1000) in Pixeln; durchgängige Abweichungen von der Polylinie, die diesen Wert überschreiten, werden nicht als Fehler gewertet.

Geschlossen Fläche aktiviert

Legt fest, ob das Werkzeug Flächenfehler berücksichtigt. Standardmäßig ist dieser Parameter aktiviert. Flächenfehler berücksichtigen die Länge entlang der Polylinie und den Abstand der fehlerhaften Kante von der Polylinie.

Hinweis: Wenn die Optionen Größe aktiviert und Fläche aktiviert beide auf Ein gesetzt sind, werden nur Fehler angezeigt, die beide Bedingungen nicht erfüllen.
Geschlossen Mindestbereich

Legt den Mindestflächenfehler (0,001 bis 1000000; Standard = 10) in Pixeln fest. Ein Bereich, der diesen Wert unterschreitet, wird nicht als Fehler gewertet.

Geschlossen Max Fläche

Legt den maximalen Flächenfehler (0,001 bis 1000000; Standard = 1000000) in Pixeln fest. Ein Bereich, der diesen Wert überschreitet, wird nicht als Fehler gewertet.


Fehlererkennungswerkzeug "Sickenverfolgung" – Registerkarte "Position"

Bei Auswahl der Registerkarte Position zeigt das Werkzeug Grafiken zur Identifikation bzw. Klassifikation von Positionsfehlern im Teil oder Objekt. Das Werkzeug zeigt die letzte trainierte Position der Sicke als blaue Polylinie, kennzeichnet die minimale und maximale Stärke der Sicke durch gelbe Linien und zeigt alle erkannten Fehler bzw. Zwischenräume an.

Geschlossen Positionsfehler aktiviert

Legt fest, ob das Werkzeug Positionsfehler berücksichtigt (standardmäßig ist dieser Parameter aktiviert).

Geschlossen Min Positionsfehlerabstand

Legt den Mindestwert (0,001 bis 1920; Standard = 3) in Pixeln für den Abstand eines Kantenkandidats von der Mitte des Sickenkantenmodells fest, der nicht als Fehler gewertet wird.

Geschlossen Positionsfehlergröße aktiviert

Legt fest, ob Größenkriterien auch zur Definition von Positionsfehlern verwendet werden (standardmäßig ist dieser Parameter aktiviert). Größenfehler werden entlang der Kantenlänge erkannt.

Hinweis: Wenn die Optionen Größe aktiviert und Fläche aktiviert beide auf Ein gesetzt sind, werden nur Fehler angezeigt, die beide Bedingungen nicht erfüllen.
Geschlossen Min Positionsfehlergröße

Definiert die Mindestfehlergröße (0,001 bis 1920; Standard = 3) in Pixeln; durchgängige Abweichungen von der Polylinie, die diesen Wert unterschreiten, werden nicht als Fehler gewertet.

Geschlossen Max Positionsfehlergröße

Definiert die maximale Fehlergröße (0,001 bis 1920; Standard = 1000) in Pixeln; durchgängige Abweichungen von der Polylinie, die diesen Wert überschreiten, werden nicht als Fehler gewertet.

Geschlossen Positionsfehlerfläche aktiviert

Legt fest, ob das Werkzeug Flächenfehler berücksichtigt. Standardmäßig ist dieser Parameter aktiviert. Flächenfehler berücksichtigen die Länge entlang der Polylinie und den Abstand der fehlerhaften Kante von der Polylinie.

Hinweis: Wenn die Optionen Größe aktiviert und Fläche aktiviert beide auf Ein gesetzt sind, werden nur Fehler angezeigt, die beide Bedingungen nicht erfüllen.
Geschlossen Min Positionsfehlerfläche

Legt den Mindestflächenfehler (0,001 bis 1000000; Standard = 10) in Pixeln fest. Ein Bereich, der diesen Wert unterschreitet, wird nicht als Fehler gewertet.

Geschlossen Max Positionsfehlerfläche

Legt den maximalen Flächenfehler (0,001 bis 1000000; Standard = 1000000) in Pixeln fest. Ein Bereich, der diesen Wert überschreitet, wird nicht als Fehler gewertet.

Geschlossen Ergebnis

Zeigt die Gesamtzahl der ermittelten Fehler, Zwischenräume bzw. Positionsfehler an.


Fehlererkennungswerkzeug "Sickensuche" – Registerkarten "Statistik", "Breitenfehler", "Zwischenräume" und "Positionsfehler"

Die Registerkarte Statistiktabelle zeichnet Daten über die Funktionsweise des Werkzeugs in einem bestimmten Zeitraum auf. Die Registerkarten Breitenfehler, Zwischenräume und Positionsfehler zeigen die ersten zehn Fehler/Zwischenräume und Positionsfehler an.

Geschlossen Index

Gibt die Reihenfolge der ermittelten Fehler bzw. Zwischenräume an, die nach der Position entlang der Kante sortiert werden; 1 bis 10 (numerische Reihenfolge in EasyBuilder basiert auf 0 = 1).

Geschlossen X

Gibt die X-Koordinate des Rechtecks zurück, das den Fehler bzw. Zwischenraum umgibt (wenn "Kalibrierte Einheiten" ausgewählt ist und das Bild im Schritt Bild einrichten kalibriert wurde; andernfalls wird der Pixelwert angezeigt).

Geschlossen Y

Gibt die Y-Koordinate des Rechtecks zurück, das den Fehler bzw. Zwischenraum umgibt (wenn "Kalibrierte Einheiten" ausgewählt ist und das Bild im Schritt Bild einrichten kalibriert wurde; andernfalls wird der Pixelwert angezeigt).

Geschlossen Fläche

Gibt die Fläche des Rechtecks zurück, das den Fehler bzw. den Zwischenraum umgibt.

Geschlossen Größe

Gibt die Größe (Länge) des Fehlers bzw. Zwischenraums entlang der Kante zurück.

Geschlossen Caliper

Gibt den Bereich von Calipern ein, den der Fehler bzw. Zwischenraum umfasst.

Geschlossen Kalibrierte Einheiten/Pixel

Legt fest, ob die Tabelle Ergebnisse in echten Koordinaten (Kalibrierte Einheiten) oder in Pixel (Pixel) anzeigt.

Hinweis: Das Werkzeug zeigt die Ergebnisse in Pixeln an, sofern das Bild im Schritt Bild einrichten nicht in reellen Einheiten kalibriert wurde.


Fehlererkennungswerkzeug "Sickenverfolgung" – Registerkarte "Zwischenräume"

Bei Auswahl der Registerkarte Zwischenräume zeigt das Werkzeug Grafiken zur Identifikation bzw. Klassifikation von Fehlern im Teil oder Objekt. Das Werkzeug zeigt die Position der Sicke als blaue Polylinie, kennzeichnet die minimale und maximale Stärke der Sicke durch gelbe Linien und zeigt alle erkannten Fehler bzw. Zwischenräume an.

Geschlossen Zwischenräume suchen

Legt fest, ob das Werkzeug Zwischenräume in der gefundenen Kante erkennt. Standardmäßig ist dieser Parameter aktiviert.

Geschlossen Minimaler Zwischenraum

Definiert den minimalen Zwischenraum (0,001 bis 1920; Standard = 3) in Pixeln. Zwischenräume, die diesen Wert unterschreiten, werden nicht als Zwischenräume gewertet.

Geschlossen Maximaler Zwischenraum

Definiert den maximalen Zwischenraum (0,001 bis 1920; Standard = 1000) in Pixeln. Zwischenräume, die diesen Wert überschreiten, werden nicht als Zwischenräume gewertet.

Geschlossen Endzwischenräume ignorieren

Legt fest, ob das Werkzeug Zwischenräume am Anfang und am Ende des Bereichs erkennt. Standardmäßig ist dieser Parameter deaktiviert.

Geschlossen Ergebnis

Zeigt die Gesamtzahl der ermittelten Fehler bzw. Zwischenräume an.


Kalibrierungswerkzeuge – Roboter

Mit diesem Werkzeug wird ein Vision-Tool mit einer Kalibrierungsfunktion für Roboter verknüpft, die Pixelkoordinaten werden in eine Roboterstellung umgewandelt und eine Kalibrierungsdatei wird automatisch in EasyBuilder erstellt.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des Kalibrierungswerkzeugs „Roboter“

Tipp: Nach der Erstellung der Kalibrierung ist es empfehlenswert, die Jobdatei zu speichern. Für spätere Kalibrierungen können Sie einfach den Kalibrierungsjob laden, das Bild aufzeichnen und anschließend die aktualisierte Kalibrierungsdatei automatisch in alle Jobs exportieren, auf die die Kalibrierungsdatei verweist.

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Eingabemerkmale (Punkte, Vorrichtungsursprung oder Mittelpunkt kreisförmiger Merkmale) definieren, die zur Konstruktion der Kalibrierung verwendet werden:

  1. EasyBuilder untersucht das Bild, nachdem das Werkzeug hinzugefügt wurde, und stellt eine Auswahl von automatisch erkannten Smart Features (Punkte, Ursprünge von Vorrichtungen oder Mittelpunkt von kreisförmigen Merkmalen) (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit. EasyBuilder fügt automatisch ein An-/Abwesenheitswerkzeug „Kreis“ für alle kreisförmigen Merkmale hinzu, die zuvor nicht definiert wurden.

  2. Wählen Sie eines der verfügbaren Merkmale per Mausklick aus. Die Farbe des Merkmals ändert sich dadurch in Magenta.

  3. Klicken Sie auf die Schaltfläche OK, wenn Sie das Merkmal ausgewählt haben (mit Abbrechen wird das Werkzeug nicht zum Job hinzugefügt).

  4. Speichern Sie die Jobdatei.
  5. Anschließend können Sie die Parameter des Werkzeugs bei Bedarf anpassen.
  6. Verwenden Sie ggf. die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten mit anderen Werkzeugen bzw. anderen externen Geräten auszutauschen.


Anpassen der Parameter des Kalibrierungswerkzeugs „Roboter“

Nach dem Hinzufügen des Werkzeugs zu einem Job können Sie es für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des Kalibrierungswerkzeugs „Roboter“ umfasst die folgenden Registerkarten:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“

Registerkarte „Allgemein“

Registerkarte „Einstellungen“


Kalibrierungswerkzeug „Roboter“ – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Bild einrichten, Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Guidance_1“. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht. Sie können nur ein Werkzeug „Roboter“ zu einem Job hinzufügen.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Roboterkalibrierung – Registerkarte „Einstellungen“

Geschlossen Dateiname

Legt den Namen der Roboterkalibrierungsdatei fest (Standardwert: „Default“).

Geschlossen Vollständiger Name

Zeigt den vollständigen Namen der Roboterkalibrierungsdatei mit der Dateiendung .CXD an.

Geschlossen Datum/Uhrzeit anhängen

Aktivieren Sie dieses Kontrollkästchen, wenn das aktuelle Datum und die aktuelle Uhrzeit an den Dateinamen angehängt werden sollen.


Kalibrierungswerkzeuge – N-Punkt

Das N-Punkt-Kalibrierungswerkzeug wird zum Erstellen einer Kalibrierungsdatei mit 2 bis 16 Eingabemerkmalen und ihren zugehörigen reellen Koordinaten verwendet. Diese Kalibrierungsdatei kann exportiert und als Kalibrierungstyp im Schritt Bild einrichten sowie in weiteren Jobs verwendet werden.

Tipp: Nach der Erstellung der Kalibrierung ist es empfehlenswert, die Jobdatei zu speichern. Für spätere Kalibrierungen können Sie einfach den Kalibrierungsjob laden, das Bild aufzeichnen und anschließend die aktualisierte Kalibrierungsdatei automatisch in alle Jobs exportieren, auf die die Kalibrierungsdatei verweist.

Das Werkzeug ist in Situationen hilfreich, in denen die reellen Abmessungen eines Teils oder Objekts bekannt sind (z. B. bei einer CAD-Zeichnung) und diese Werte zur Kalibrierung verwendet werden sollen. Bei dieser Art der Anwendung wird ein Bild eines Teils oder Objekts vom In-Sight-Vision-System aufgezeichnet, und die reellen Werte werden den Bildpixelkoordinaten zugewiesen. Speichern Sie diese Kalibrierung im lokalen Dateisystem des Vision-Systems, um sie auch für andere Jobs zu verwenden.

Hinweis:
  • Dieses Werkzeug erfordert weitere Positions- und/oder Inspektionswerkzeuge als Eingabe, um die Punkte für die Kalibrierung zu definieren. Stellen Sie vor dem Hinzufügen des Werkzeugs die notwendigen Positions- und/oder Inspektionswerkzeuge für die Eingabe zusammen.
  • Bei der Verwendung des N-Punkt-Kalibrierungswerkzeugs oder des sequenziellen N-Punkt-Kalibrierungswerkzeugs müssen die physischen und optischen Einstellungen (Objektiv, Vision-System und das physische Verhältnis zwischen dem Vision-System und der aufgezeichneten Szene) des Kalibrierungs- und Laufzeitvorgangs übereinstimmen. Wird eines der Elemente geändert, muss das System erneut kalibriert werden. Daher wird empfohlen, dasselbe Vision-System und Objektiv sowohl zur Kalibrierung als auch zur Verarbeitung der Laufzeitbilder zu verwenden. Die Einrichtungs- und Kalibrierungseinstellungen des Vision-Systems und des Objektivs dürfen ebenfalls nicht geändert werden. Beispielsweise wird durch Änderung des Aufzeichnungsformats (durch Änderung der Auflösung) oder des Standorts des Vision-Systems die berechnete 2D-Transformation ungültig, die Pixel echten Koordinaten zuordnet.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des N-Punkt-Kalibrierungswerkzeugs

Tipp: Nach der Erstellung der Kalibrierung ist es empfehlenswert, die Jobdatei zu speichern. Für spätere Kalibrierungen können Sie einfach den Kalibrierungsjob laden, das Bild aufzeichnen und anschließend die aktualisierte Kalibrierungsdatei automatisch in alle Jobs exportieren, auf die die Kalibrierungsdatei verweist.

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie die Eingangsmerkmale (Punkte, Ursprünge von Vorrichtungen oder Mittelpunkt von kreisförmigen Merkmalen) definieren, die zum Erstellen der Kalibrierung verwendet werden:

  1. EasyBuilder untersucht das Bild, nachdem das Werkzeug hinzugefügt wurde, und stellt eine Auswahl von automatisch erkannten Smart Features (Punkte, Ursprünge von Vorrichtungen oder Mittelpunkt von kreisförmigen Merkmalen) (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit. EasyBuilder fügt automatisch ein An-/Abwesenheitswerkzeug „Kreis“ für alle kreisförmigen Merkmale hinzu, die zuvor nicht definiert wurden.

  2. Wählen Sie zuerst die Merkmale per Mausklick aus den verfügbaren Merkmalen aus. Die Farbe des Merkmals ändert sich dadurch in Magenta.

  3. Wählen Sie als Nächstes die restlichen Merkmale aus, die zum Definieren der Kalibrierung verwendet werden. Wählen Sie mindestens zwei bzw. maximal sechzehn Eingangsmerkmale aus.

  4. Klicken Sie nach Auswahl der gewünschten Merkmale auf die Schaltfläche OK (klicken Sie auf die Schaltfläche Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen).

  5. Nachdem das Werkzeug erfolgreich hinzugefügt wurde und die Eingangsmerkmale definiert wurden, müssen die reellen Abmessungen für jedes Eingangsmerkmal definiert werden. Wählen Sie in der Punktetabelle einen Punkt aus, und geben Sie anschließend den zugehörigen reellen Abmessungswert in die Felder Welt X-Wert und Welt Y-Wert ein. Geben Sie hierfür die Zahl entweder manuell ein oder mithilfe der Steuerelemente zur schrittweisen Erhöhung bzw. Senkung.
  6. Speichern Sie die Jobdatei.
  7. Klicken Sie auf der Registerkarte Einstellungen auf die Schaltfläche Exportieren, um die Kalibrierungsdatei im lokalen Dateisystem des In-Sight-Vision-Systems abzulegen. Hierdurch kann die Kalibrierung in der Einstellung Kalibrierungstyp des Schritts Bild einrichten als Importoption ausgewählt werden.
  8. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  9. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des N-Punkt-Kalibrierungswerkzeugs

Nach dem Hinzufügen des Werkzeugs zu einem Job können Sie es für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des N-Punkt-Kalibrierungswerkzeugs beinhaltet folgende Objekt:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
  • Punktetabelle
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Punktetabelle


N-Punkt-Kalibrierungswerkzeug – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Bild einrichten, Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Calib_1“, sofern es sich um das erste Kalibrierungswerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Calib_2“, „Calib_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


N-Punkt-Kalibrierungswerkzeug – Registerkarte „Einstellungen“

Geschlossen Dateiname

Definiert den Dateinamen der Kalibrierungsdatei. Der Standardname lautet „Standard“.

Geschlossen Vollständiger Name

Zeigt den vollständigen Namen der Kalibrierungsdatei an, der im Schritt Bild einrichten bei der Konfiguration des Kalibrierungstyps für Import angezeigt wird. Die Datei muss vor dem Anzeigen im Schritt Bild einrichten exportiert werden.

Geschlossen Exportieren

Exportiert die Kalibrierungsdatei in das lokale Dateisystem des In-Sight-Vision-Systems.

Geschlossen Automatisch exportieren

Definiert, ob nach dem Laden des Jobs die Kalibrierungsdatei automatisch exportiert oder ein Bild aufgezeichnet werden soll. Ist diese Option aktiviert, wird die Kalibrierungsdatei automatisch exportiert, wenn der Job geladen wird oder wenn ein Bild aufgezeichnet wird. Diese Option ist standardmäßig deaktiviert/abgewählt.

Hinweis: Wenn Automatisch exportieren aktiviert ist, muss die Jobdatei mit den Kalibrierdaten zuerst gespeichert werden, bevor die Kalibrierungsdatei exportiert wird. Wenn nach Speichern der Jobdatei die Kalibrierungsdatei nicht im In-Sight Dateibereich erscheint, klicken Sie auf ein anderes In-Sight Vision-System oder einen Emulator und kehren Sie zurück und wählen Sie das gewünschte Vision-System. Die Datei sollte jetzt erscheinen.


N-Punkt-Kalibrierungswerkzeug – Punktetabelle

Die Punktetabelle für Pixelkoordinaten und reelle Koordinaten wird zum Anzeigen und Definieren der reellen Koordinatenwerte für die Kalibrierung verwendet.

Geschlossen Punkt

Zeigt eine schreibgeschützte indexierte Liste der gefundenen Punkte an, von 1 bis 16 (die numerische Reihenfolge in EasyBuilder basiert auf 0=1).

Geschlossen Pixel x-Wert

Zeigt die Pixelzeilenposition (X-Wert) des Punkts an.

Geschlossen Pixel y-Wert

Zeigt die Bildspaltenkoordinate (X-Wert) des Punkts an.

Geschlossen Welt X-Wert

Zeigt den reellen X-Koordinatenwert des Punkts an.

Geschlossen Welt Y-Wert

Zeigt den reellen Y-Koordinatenwert des Punkts an.

Geschlossen Welt X-Wert

Definiert den reellen X-Koordinatenwert für den ausgewählten Punkt.

Geschlossen Welt Y-Wert

Definiert den reellen Y-Koordinatenwert für den ausgewählten Punkt.

Geschlossen Punkte auswählen

Aktiviert die Auswahl von Eingangsmerkmalen als Punkte. EasyBuilder untersucht nach dem Klicken auf diese Schaltfläche das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (Punkte, Ursprünge von Vorrichtungen oder Mittelpunkt von kreisförmigen Merkmalen) (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit. Wählen Sie per Mausklick die Merkmale aus den verfügbaren Merkmalen aus. Die Farbe des Merkmals ändert sich dadurch in Magenta.


Kalibrierungswerkzeuge – sequenzieller N-Punkt

Das sequenzielle N-Punkt-Kalibrierungswerkzeug wird zum Erstellen einer Kalibrierungsdatei mithilfe eines Eingabemerkmals und seinen zugehörigen reellen Koordinaten über sequenziellen Bildaufnahmen verwendet. Diese Kalibrierungsdatei kann exportiert und als Kalibrierungstyp im Schritt Bild einrichten sowie in weiteren Jobs verwendet werden.

Tipp: Nach der Erstellung der Kalibrierung ist es empfehlenswert, die Jobdatei zu speichern. Für spätere Kalibrierungen können Sie einfach den Kalibrierungsjob laden, das Bild aufzeichnen und anschließend die aktualisierte Kalibrierungsdatei automatisch in alle Jobs exportieren, auf die die Kalibrierungsdatei verweist.

Das Werkzeug ist in Situationen hilfreich, in denen ein In-Sight-Vision-System und ein Robotikkoordinatensystem kalibriert werden müssen. Bei dieser Art der Anwendung wird dem Vision-System von der Robotiksteuerung ein Objekt an verschiedenen Positionen angezeigt, wobei bei jeder neuen Position ein Bild aufgezeichnet wird. Bei jeder Aufnahme wird der Kalibrierungstabelle ein Punkt hinzugefügt. Nachdem alle Positionen verarbeitet wurden und jeder Punkt gespeichert wurde, können die Kalibrierungsdatei exportiert und der Job gespeichert werden.

Hinweis:
  • Dieses Werkzeug erfordert weitere Positions- und/oder Inspektionswerkzeuge als Eingabe, um die Punkte für die Kalibrierung zu definieren. Stellen Sie vor dem Hinzufügen des Werkzeugs die notwendigen Positions- und/oder Inspektionswerkzeuge für die Eingabe zusammen.
  • Bei der Verwendung des N-Punkt-Kalibrierungswerkzeugs oder des sequenziellen N-Punkt-Kalibrierungswerkzeugs müssen die physischen und optischen Einstellungen (Objektiv, Vision-System und das physische Verhältnis zwischen dem Vision-System und der aufgezeichneten Szene) des Kalibrierungs- und Laufzeitvorgangs übereinstimmen. Wird eines der Elemente geändert, muss das System erneut kalibriert werden. Daher wird empfohlen, dasselbe Vision-System und Objektiv sowohl zur Kalibrierung als auch zur Verarbeitung der Laufzeitbilder zu verwenden. Die Einrichtungs- und Kalibrierungseinstellungen des Vision-Systems und des Objektivs dürfen ebenfalls nicht geändert werden. Beispielsweise wird durch Änderung des Aufzeichnungsformats (durch Änderung der Auflösung) oder des Standorts des Vision-Systems die berechnete 2D-Transformation ungültig, die Pixel echten Koordinaten zuordnet.

Einrichtung des Werkzeugs

Anpassen der Werkzeugparameter


Einrichten des sequenziellen N-Punkt-Kalibrierungswerkzeugs

Tipp: Nach der Erstellung der Kalibrierung ist es empfehlenswert, die Jobdatei zu speichern. Für spätere Kalibrierungen können Sie einfach den Kalibrierungsjob laden, das Bild aufzeichnen und anschließend die aktualisierte Kalibrierungsdatei automatisch in alle Jobs exportieren, auf die die Kalibrierungsdatei verweist.

Nachdem das Werkzeug hinzugefügt wurde, müssen Sie das Eingangsmerkmal (Punkt, Ursprung einer Vorrichtung oder Mittelpunkt eines kreisförmigen Merkmals) definieren, das zum Erstellen der Kalibrierung verwendet wird:

  1. EasyBuilder untersucht das Bild, nachdem das Werkzeug hinzugefügt wurde, und stellt eine Auswahl von automatisch erkannten Smart Features (Punkte, Ursprünge von Vorrichtungen oder Mittelpunkt von kreisförmigen Merkmalen) (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit. EasyBuilder fügt automatisch ein An-/Abwesenheitswerkzeug „Kreis“ für alle kreisförmigen Merkmale hinzu, die zuvor nicht definiert wurden.
  2. Wählen Sie per Mausklick die Merkmale aus den verfügbaren Merkmalen aus. Die Farbe des Merkmals ändert sich dadurch in Magenta.
  3. Klicken Sie nach Auswahl des gewünschten Merkmals auf die Schaltfläche OK (klicken Sie auf die Schaltfläche Abbrechen, um das Werkzeug dem Job nicht hinzuzufügen).
  4. Definieren Sie auf der Registerkarte "Einstellungen" den Parameter Anzahl der Punkte, indem Sie die Anzahl der Punkte/Aufnahmen der Kalibrierung angeben.
  5. Bewegen Sie die Robotiksteuerung zur nächsten Position und zeichnen Sie ein Bild des Punkts an der neuen Position auf. Wiederholen Sie den Vorgang, bis alle Punkte aufgezeichnet wurden.
  6. Nachdem die Punkte erfolgreich hinzugefügt wurden, müssen die reellen Abmessungswerte für die Punkte definiert werden. Wählen Sie in der Punktetabelle einen Punkt aus, und geben Sie anschließend den zugehörigen reellen Abmessungswert in die Felder Welt X-Wert und Welt Y-Wert ein. Geben Sie hierfür die Zahl entweder manuell ein oder mithilfe der Steuerelemente zur schrittweisen Erhöhung bzw. Senkung.
  7. Klicken Sie auf der Registerkarte Einstellungen auf die Schaltfläche zum Exportieren, um die Kalibrierungsdatei im lokalen Dateisystem des In-Sight-Vision-Systems abzulegen. Hierdurch kann die Kalibrierung in der Einstellung Kalibrierungstyp des Schritts Bild einrichten als Importoption ausgewählt werden.
  8. Laden Sie mit dem konfigurierten Werkzeug verschiedene Bilder, und passen Sie die Parameter des Werkzeugs nach Bedarf an, um erwartete Variationsbereiche auszugleichen.
  9. Verwenden Sie bei Bedarf die Eingangs-/Ausgangseigenschaften, um Werkzeugdaten zwischen anderen Werkzeugen und/oder anderen externen Geräten auszutauschen.


Anpassen der Parameter des sequenziellen N-Punkt-Kalibrierungswerkzeugs

Nach dem Hinzufügen des Werkzeugs zu einem Job können Sie es für Ihre Anwendung anpassen und optimieren.

Das Einstellungsfenster des sequenziellen N-Punkt-Kalibrierungswerkzeugs beinhaltet folgende Objekte:

  • Registerkarte „Allgemein“
  • Registerkarte „Einstellungen“
  • Punktetabelle
Tipp: Prüfen Sie Ihren Job mit TestRun. TestRun prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. Auf diese Weise stellen Sie fest, ob sich der Job wie erwartet verhält oder ob Sie bestimmte Parameter für zulässige Abweichungen anpassen müssen.

Registerkarte „Allgemein“

Registerkarte „Einstellungen“

Punktetabelle


Sequenzielles N-Punkt-Kalibrierungswerkzeug – Registerkarte „Allgemein“

Geschlossen Werkzeugname

Gibt den Namen des Inspektionswerkzeugs an, das zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet wird. Der Standardname lautet „Calib_1“, sofern es sich um das erste Kalibrierungswerkzeug handelt, das dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Calib_2“, „Calib_3“ usw. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.

Geschlossen Werkzeug aktiviert

Gibt an, ob und wann das Inspektionswerkzeug ausgeführt wird (standardmäßig aktiviert). Wählen Sie "Aus", um das Werkzeug zu deaktivieren. Wählen Sie "Ausdruck", um die Ausführung des Werkzeugs an das Ergebnis eines Ausdrucks zu binden (dieses Steuerelement ist nur für Werkzeuge aktiviert, die den Parameter "Ausdruck" bereitstellen). Wählen Sie "Eingang", um das Werkzeug einer bestimmten, diskreten Eingangsleitung zuzuordnen, über die es aktiviert oder deaktiviert werden kann. Die Aktivierung erfolgt durch das Signal "High", die Deaktivierung durch das Signal "Low". Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Steuerungssystems (z.B. SPS) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

Geschlossen In Gesamtergebnis einschließen

Bestimmt, ob der Gut/Schlecht-Status des Werkzeugs im Gut/Schlecht-Gesamtstatus des Jobs enthalten sein soll. Diese Option ist standardmäßig aktiviert, wodurch der Status in den Gut/Schlecht-Gesamtstatus des Jobs übernommen wird. Deaktivieren Sie das Kontrollkästchen, um den Gut/Schlecht-Status des Werkzeugs vom Gut/Schlecht-Gesamtstatus des Jobs zu trennen. Dieses Steuerelement sollte deaktiviert werden, wenn erwartet wird, dass ein Werkzeug fehlschlägt. Werden beispielsweise zwei Identifizierungswerkzeuge "PatMax-Muster" verwendet, um festzustellen, ob es sich um ein rechts- oder linksseitiges Teil handelt, ist davon auszugehen, dass jeweils eines der beiden Werkzeuge fehlschlägt. Ist dieses Kontrollkästchen aktiviert, schlägt der Job jedes Mal fehl, unabhängig davon, welche Seite des Teils erkannt wurde.

Geschlossen Zeit für Ausführung (ms)

Gibt an, in welchem Zeitraum (in Millisekunden) das Werkzeug die Inspektion ausgeführt hat. Dieser Zeitraum variiert in Abhängigkeit der Komplexität einer Bildszene, der Position des Merkmals im Bild sowie der gemäß den Parametern zulässigen Varianz.

Geschlossen Beschreibung

Ein Kommentar, der den Verwendungszweck des Werkzeugs beschreibt (das Feld ist standardmäßig leer). Es können bis zu 255 alphanumerische Zeichen oder 127 asiatische eingefügt werden.


Sequenzielles N-Punkt-Kalibrierungswerkzeug – Registerkarte „Einstellungen“

Geschlossen Punkteanzahl

Definiert die Anzahl der Punkte, die aufgezeichnet werden sollen (2 bis 16, standardmäßig 12).

Geschlossen Zurücksetzen

Setzt die Aufnahmeanzahl auf 0 zurück.

Geschlossen Online-Zurücksetzen

Gibt an, ob die Aufnahmeanzahl zurückgesetzt werden soll, wenn das In-Sight-Vision-System online geschaltet wird. Standardmäßig ist diese Option deaktiviert.

Geschlossen Job laden zurücksetzen

Gibt an, ob die Aufnahmeanzahl beim Laden der Jobdatei zurückgesetzt werden soll. Standardmäßig ist diese Option aktiviert.

Geschlossen Dateiname

Definiert den Dateinamen der Kalibrierungsdatei. Der Standardname lautet „Standard“.

Geschlossen Vollständiger Name

Zeigt den vollständigen Namen der Kalibrierungsdatei an, der im Schritt Bild einrichten bei der Konfiguration des Kalibrierungstyps für Import angezeigt wird. Die Datei muss vor dem Anzeigen im Schritt Bild einrichten exportiert werden.

Geschlossen Exportieren

Exportiert die Kalibrierungsdatei in das lokale Dateisystem des In-Sight-Vision-Systems.

Geschlossen Automatisch exportieren

Definiert, ob nach dem Laden des Jobs die Kalibrierungsdatei automatisch exportiert oder ein Bild aufgezeichnet werden soll. Ist diese Option aktiviert, wird die Kalibrierungsdatei automatisch exportiert, wenn der Job geladen wird oder wenn ein Bild aufgezeichnet wird. Diese Option ist standardmäßig deaktiviert/abgewählt.

Hinweis: Wenn Automatisch exportieren aktiviert ist, muss die Jobdatei mit den Kalibrierdaten zuerst gespeichert werden, bevor die Kalibrierungsdatei exportiert wird. Wenn nach Speichern der Jobdatei die Kalibrierungsdatei nicht im In-Sight Dateibereich erscheint, klicken Sie auf ein anderes In-Sight Vision-System oder einen Emulator und kehren Sie zurück und wählen Sie das gewünschte Vision-System. Die Datei sollte jetzt erscheinen.
Geschlossen Ergebnis

Zeigt den Status des Werkzeugs an („Bestanden/Fehler“ bzw. „gut/schlecht“).


Sequenzielles N-Punkt-Kalibrierungswerkzeug – Punktetabelle

Die Punktetabelle für Pixelkoordinaten und reelle Koordinaten wird zum Anzeigen und Definieren der reellen Koordinatenwerte für die Kalibrierung verwendet.

Geschlossen Punkt

Zeigt eine schreibgeschützte indexierte Liste der gefundenen Punkte an, von 1 bis 16 (die numerische Reihenfolge in EasyBuilder basiert auf 0=1).

Geschlossen Pixel x-Wert

Zeigt die Pixelzeilenposition (X-Wert) des Punkts an.

Geschlossen Pixel y-Wert

Zeigt die Bildspaltenkoordinate (X-Wert) des Punkts an.

Geschlossen Welt X-Wert

Zeigt den reellen X-Koordinatenwert des Punkts an.

Geschlossen Welt Y-Wert

Zeigt den reellen Y-Koordinatenwert des Punkts an.

Geschlossen Welt X-Wert

Definiert den reellen X-Koordinatenwert für den ausgewählten Punkt.

Geschlossen Welt Y-Wert

Definiert den reellen Y-Koordinatenwert für den ausgewählten Punkt.

Geschlossen Punkte auswählen

Aktiviert die Auswahl von Eingangsmerkmalen als Punkte. EasyBuilder untersucht nach dem Klicken auf diese Schaltfläche das Bild und stellt eine Auswahl von automatisch erkannten Smart Features (Punkte, Ursprünge von Vorrichtungen oder Mittelpunkt von kreisförmigen Merkmalen) (zyanfarben hervorgehoben) und aller zuvor mit einem anderen Werkzeug definierten Merkmale (grün hervorgehoben) bereit. Wählen Sie per Mausklick die Merkmale aus den verfügbaren Merkmalen aus. Die Farbe des Merkmals ändert sich dadurch in Magenta.


Eingänge/Ausgänge

Der Schritt Eingänge/Ausgänge dient zum Definieren der Einstellungen der diskreten Ein- und Ausgangsleitungen von unterstützten In-Sight Vision-Systemen und E/A-Modulen. Sie können den Namen der Leitung anpassen, den Signaltyp festlegen, den Flankenübergang des Signals auswählen und die Aktivierung von Ein- und Ausgängen zum Testen Ihrer Anwendung erzwingen.

Hinweis:
  • Dieser Anwendungsschritt ist bei Verwendung eines Emulators deaktiviert.
  • Überprüfen Sie vor der Konfiguration Ein- oder Ausgabeleitungen, ob das Ausgabegerät ein PNP-Gerät (stromliefernd) oder ein NPN-Gerät (stromziehend) ist. Stellen Sie zudem sicher, dass das Gerät ordnungsgemäß an den In-Sight-Sensor bzw. das E/A-Modul angeschlossen ist. Weitere Informationen finden Sie im Installationshandbuch für den In-Sight-Sensor oder das E/A-Modul.

Konfigurieren der Eingangs- und Ausgangsleitungen

Eingänge: Laden einer Job-Datei

Eingänge: Aktivieren und Deaktivieren von Positions- und Inspektionswerkzeugen

Eingänge: Auslösen der Bildaufnahme

Eingänge: Einlernen eines Modellmusters über eine Eingangsleitung

Ausgänge: Signalisieren einer fehlgeschlagenen Bildaufnahme

Ausgänge: Triggern einer Beleuchtung für die Bildaufnahme

Ausgänge: Einstellen einer Ausgangsleitung auf das Ergebnis eines Positions- oder Inspektionswerkzeugs


Konfigurieren der Eingangs- und Ausgangsleitungen

  1. Klicken Sie optional auf die Schaltfläche E/A-Modul, um das Dialogfeld E/A-Modulkonfiguration zu öffnen. Konfigurieren Sie das E/A-Modul, und klicken Sie auf OK, um das Dialogfeld „E/A-Modulkonfiguration“ zu schließen. Nach dem ersten erfolgreichen Verbindungsaufbau zwischen dem Vision-System und dem E/A-Modul wird in der Liste neben dem Modul der Hinweis „(angefügt)“ angezeigt. Nachdem Sie eine Verbindung zu einem E/A- Modul hergestellt haben, können Sie mit dem Anpassen der Leitungen beginnen.
  2. Wählen Sie eine zu konfigurierende Ein- oder Ausgangsleitung aus. Die Anzahl verfügbarer Eingänge und Ausgänge variiert abhängig vom In-Sight-Modell und dem entsprechenden E/A-Modul. Weitere Informationen finden Sie in diesem Hilfethema.
  3. Nur In-Sight 7000 Gen2-Serie und 9912: Wenn die Leitung die bidirektionale E/A unterstützt, wählen Sie im Dropdownmenü „Richtung“ die Option Eingang oder Ausgang aus.
  4. Sie können den Namen der Standardleitung anpassen, indem Sie einen neuen, für Ihre Anwendung spezifischen Namen eingeben. Der Name kann bis zu 15 Zeichen lang sein und dient nur zu Referenzzwecken. Er hat keinen Einfluss auf die Funktionalität der Leitung, und es kann nicht auf ihn verwiesen werden.

  5. Definieren Sie anschließend einen Signaltyp für die ausgewählte Eingangsleitung. Jede Leitung kann für eine der folgenden Funktionen konfiguriert werden:

    Eingangssignaltyp Beschreibung
    Benutzerdaten

    Allzweck-Eingangsleitung. Dient zum Aktivieren und Deaktivieren der Positions- und Inspektionswerkzeuge.

    Zähler zurücksetzen

    Setzt die EasyBuilder-Zähler (Job.Schlecht_Anzahl, Job.Inspektion_Anzahl, Job.Gut_Anzahl, <Werkzeug>.Fehleranzahl, <Werkzeug>.Schlecht_Anzahl und <Werkzeug>.Gut_Anzahl) auf 0 zurück.

    Hinweis:
    • Dieser Signaltyp funktioniert nur, wenn das Vision-System online ist.
    • Für Zähler zurücksetzen kann nur eine Eingangsleitung konfiguriert werden.
    • Wird ein neuer Job erstellt, nachdem eine der Eingangsleitungen auf Zähler zurücksetzen gestellt wurde, stellt der Job die Eingangsleitung automatisch auf Ereignis-Trigger um (leer, wenn der Vision-Sensor der In-Sight 2000-Serie verwendet wird).

    Ereignis-Trigger

    Triggert über eine in der Arbeitsblattansicht erstellte Logik ein Ereignis. Damit die Tabelle durch einen Ereignis-Trigger aktualisiert wird, muss sie eine Ereignisstruktur enthalten, und der Parameter „Trigger“ muss auf diese Leitungsnummer des diskreten Eingangs eingestellt sein. Weitere Informationen finden Sie unter Ereignis.

    Hinweis:
    • Dieser Signaltyp funktioniert nur, wenn das Vision-System online ist.
    • Diese Option erfordert Zugriff auf die Arbeitsblattansicht, außer wenn sie zum Trainieren eines Modellmusters über eine Eingangsleitung verwendet wird.

    Auftrags-ID

    Stellt ein Bit einer Job-ID bereit, das geladen wird, wenn der Status einer anderen Eingangsleitung mit dem Typ Job Load Switch (Schalter – Job laden) auf ON steht.

    Hinweis:
    • Zur Verwendung der Funktion Job-ID muss der zu ladende Job mit einem numerischen Präfix zwischen 0 und 127 gespeichert werden.
    • Das niederwertigste Bit der Job-ID entspricht der diskreten Eingangsleitung mit der niedrigsten Nummer an Ihrem E/A-Modul.

    Online/Offline

    Zwingt das In-Sight Vision-System Offline oder Online (0 = Offline, und 1 = Online). Dieser Eingangstyp kann nur für jeweils eine Leitung gleichzeitig verwendet werden.

    Hinweis: Wenn der Signaltyp auf „Online“ eingestellt ist, kann das Vision-System immer noch offline sein, falls es in In-Sight Explorer manuell oder durch den Nativ Native Mode-Befehl „Set Online“ (SO0) offline geschaltet wurde. Weitere Informationen finden Sie unter Set Online.

    Auslöser für die Aufnahme
    (Nicht unterstützt auf Sensoren der In-Sight 2000-Serie oder auf dem CIO-1400)

    Startet das Vision-System für die Aufnahme eines Bilds. Dieser Eingangstyp kann nur für jeweils eine Leitung gleichzeitig verwendet werden.

    Hinweis:
    • Der Parameter „Trigger“ im Gruppenfeld „Aufnahmeeinstellungen bearbeiten“ muss auf Extern gestellt sein, damit der Eingang Bildaufnahmetrigger verwendet werden kann. Außerdem muss eine Signalleitung physisch mit dem Eingang des In-Sight Vision-Systems verbunden sein, damit der Eingang Bildaufnahmetrigger verwendet werden kann.
    • Höhere Triggergeschwindigkeiten werden durch die Verwendung des integrierten Triggereingangs des Systems erzielt (indem der Trigger auf „Kamera“ gesetzt wird), anstatt das Vision-System mit einer als Triggereingang konfigurierten Allzweckeingangsleitung zu triggern (indem der Trigger auf „Extern“ gesetzt wird).
    • Falls der Parameter „Trigger“ auf Extern gestellt ist und eine Aufnahme verpasst wird, sendet das Vision-System kein FEHLER: Bild verpasst-Signal. Das FEHLER: Bild verpasst-Signal wird nur unterstützt, wenn der Parameter „Trigger“ auf Kamera gestellt ist.

    Auftragsladeschalter

    Bei „ON“ werden alle Job-ID-Leitungen gelesen und der angegebene Job geladen. Dieser Eingangstyp kann nur für jeweils eine Leitung gleichzeitig verwendet werden.

    Hinweis: Das Vision-System muss offline geschaltet sein.

    Jobänderung (Gepulst)

    (Nur unterstützt auf Sensoren der In-Sight 2000-Serie mit direktem E/A)

    Initiiert eine Jobänderung anhand des Erkennens von Eingangsimpulsen, differenziert nach der Breite der Impulse. Die Impulse werden durch ein externes Gerät (wie eine SPS) generiert und an den In-Sight 2000 Sensor gesendet. Zuerst sendet das externe Gerät einen Startimpuls. Dann gibt das externe Gerät Zählimpulse aus, mit einem Impulsabstand zwischen jedem Zählimpuls. Am Ende sendet das externe Gerät einen Stoppimpuls.

    Impulstyp | Impulslänge
    Startimpuls | 20ms (±2ms)
    Zählimpuls | 10ms (±1ms)
    Impulsabstand | 10ms (± 1ms)
    Stoppimpuls | 20ms (±2ms)

    Wenn alle Impulse und Impulsabstände mit der angegebenen Impulslänge übereinstimmen, wird der Jobänderungswunsch als erfolgreich betrachtet und der Job in den Sensor geladen. Sollte der Vorgang wegen mindestens einer der Bedingungen fehlschlagen (d.h. falscher Impuls oder falsches Timing des Impulsabstands), schlägt der Jobänderungswunsch fehl und es findet keine Jobänderung statt.

    Hinweis:
    • Dieser Signaltyp funktioniert nur, wenn das Vision-System online ist.
    • Um den Signaltyp „Jobänderung (Gepulst)“ zu verwenden, muss mindestens ein Job mit dem numerischen Präfix 0 bis 31 und im Format #jobdateiname.job (z.B. 1KontaktInspektion.job) gespeichert worden sein. Die Anzahl der ausgegebenen Zählimpulse muss dem numerischen Präfix des zu ladenden Jobs entsprechen.
    • Der Native Mode-Befehl SetSystemConfig("PulseJobChangeTiming") kann für daie Konfiguration der Impulsbreiten des Startimpulses, Zählimpuleses, des Impulsabstands und des Stopimpulses verwendet werden.
    • Optional kann eine diskrete Ausgangsleitung als Typ Laden des Auftrags OK oder Laden des Auftrags fehlgeschlagen für das Pulsen des Ausgangs konfiguriert werden und so über den Erfolg bzw. das Fehlschlagen des Jobänderungswunsches berichten.

    Seriell Empfangen
    (Nur direkter E/A)

    Konfiguriert diese Leitung als eine serielle Empfangsleitung.

    Hinweis:
    • Dieser Signaltyp ist nur gültig für Eingangsleitung 1, wenn Direkter E/A ausgewählt wurde.
    • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.
    • Ist das Vision-System der In-Sight 70xx-74xx-Serie für die Verwendung mit dem E/A-Modul CIO-MICRO oder CIO-MICRO-CC konfiguriert, sind die Pins des RS-232-Ausgangs und des RS-232-Eingangs am E/A-Breakout-Kabel deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.

  6. Wählen Sie einen Kantentyp für die ausgewählte Eingangsleitung aus, der die Empfindlichkeit der Eingangsleitung steuert, um Übergänge abzugleichen.

    • Steigende Kante: Ändert den Status der Eingangsleitung auf der steigenden Flanke eines Impulses.
    • Fallende Kante: Ändert den Status der Eingangsleitung auf der fallenden Flanke eines Impulses.
    • Beide Kanten: Ändert den Status der Eingangsleitung auf der steigenden und fallenden Flanke eines Impulses. Diese Option ist nur verfügbar, wenn Event Trigger (Ereignistrigger) als Signaltyp ausgewählt wurde.

  7. Definieren Sie anschließend einen Signaltyp für die ausgewählte Ausgangsleitung. Jede Leitung kann für eine der folgenden Funktionen konfiguriert werden:

    Ausgabesignaltyp | Beschreibung
    Jobergebnis (Standard) | Ermöglicht die Steuerung des Status dieser Ausgangsleitung durch das Ergebnis eines Positions- oder Inspektionswerkzeugs. Entweder gepulster oder steter Status.
    Hoch | Zwingt den Ausgang auf HOCH (1).
    Gering | Zwingt den Ausgang auf NIEDRIG (0).
    Start Bildaufnahme

    Signalisiert, dass das Vision-System eine Bildaufnahme initiiert hat. Immer gepulst.

    Hinweis: Im In-Sight 8405 Vision-System wird das Signal zum Aufnahmestart gepulst, sobald die erste Pixelreihe belichtet ist. Weitere Informationen finden Sie in den Hinweisen zum Betrieb des Rolling-Shutter.
    Ende Bildaufnahme

    Signalisiert das Ende der Vision-Systemaufnahme. Immer gepulst.

    Hinweis: Im In-Sight 8405 Vision-System wird das Signal zum Aufnahmeende gepulst, wenn die gesamte Bildausgabe abgeschlossen ist. Weitere Informationen finden Sie in den Hinweisen zum Betrieb des Rolling-Shutter.
    Auftrag ausgeführt | Signalisiert den Abschluss jeder Aktualisierung durch EasyBuilder. Immer gepulst.
    System ausgelastet | HIGH, wenn das Vision-System einen Job ausführt oder auf eine Benutzereingabe reagiert, LOW bei Leerlauf des Vision-Systems..
    Laden des Auftrags OK | Gibt an, dass der Job erfolgreich geladen wurde. Immer gepulst.
    Fehler beim Laden des Jobs | Signalisiert einen Fehler beim Laden eines Jobs. Immer gepulst.
    FEHLER: Aufnahme fehlgeschlagen

    Zeigt an, dass ein Aufnahmetrigger empfangen wurde, bevor ein Signal zum Aufnahmeende gesendet wurde; oder dass kein Bild-Zwischenspeicher für die Bildaufnahme zur Verfügung stand, als der Aufnahmetrigger empfangen wurde. Immer gepulst. Weitere Informationen finden Sie unter Dialogfeld „Bild-Zwischenspeicher“.

    Hinweis: Der Parameter "Trigger" im Gruppenfeld "Aufnahmeeinstellungen bearbeiten" des Schrittes "Bild einrichten" muss auf Kamera eingestellt werden, wenn Sie das Ausgangssignal FEHLER: Bild verpasst verwenden
    FEHLER: Überlauf

    Signalisiert, dass EasyBuilder nach dem erwarteten Zeitpunkt ein verzögertes diskretes Ausgangssignal ausgegeben hat. Immer gepulst.

    Hinweis: Dieses Signal wird auf dem CIO-1400 und dem CIO-Micro nicht unterstützt.
    FEHLER: Erkennungswarteschlange voll | Signalisiert, dass EasyBuilder ein verzögertes diskretes Ausgangssignal für eine Leitung ausgegeben hat, für die zuvor eine andere Ausgabe zum gleichen Zeitpunkt geplant war. Immer gepulst.
    Online/Offline | HIGH (1), wenn das Vision-System online ist, LOW (0), wenn das Vision-System offline ist.
    Blitzimpuls | Mit der steigenden oder fallenden Flanke des Signals kann ein Blitzimpuls getriggert werden.
    Lichtsteuerung
    (Nur CIO-1460)     		Mit der steigenden oder fallenden Flanke des Signals kann eine Beleuchtung getriggert werden.
    I/O Module Standby (I/O-Modul bereit)
    (Nur CIO-1450 und CIO-1460)

    ON bedeutet, dass das E/A-Modul einen Kommunikationsfehler zwischen dem Vision-System und dem E/A-Modul erkannt hat und versucht, die Kommunikation wiederherzustellen. Die Leitung wird deaktiviert (OFF), wenn das E/A-Modul erkennt, dass der Fehler behoben wurde.

    Hinweis: Dieser Ausgangstyp ist nur für die Leitungen 0 bis 7 beim Konfigurieren des CIO-1450 oder CIO-1460 gültig.
    Rettungsleine
    [Nur CIO-MICRO und CIO-MICRO-CC]     		HIGH, wenn das Vision-System mit dem CIO-MICRO oder dem CIO-MICRO-CC verbunden ist. LOW, wenn die Verbindung mit dem Vision-System fehlschlägt.
    Waveform (Wellenform)

    Aktiviert die Waveform-Funktion WriteWaveformPulseTrain oder WriteWaveformClocked zum Steuern des Status dieser Ausgangsleitung.

    Hinweis: Diese Option erfordert Zugriff auf die Arbeitsblattansicht.
    Seriell Übertragen

    Konfiguriert die Leitung als eine serielle Übertragungsleitung.

    Hinweis:
    • „Seriell übertragen“ ist nur bei Verbindung eines Vision-Systems der In-Sight 70xx-74xx-Serie mit In-Sight Explorer 4.7.1 oder höher und In-Sight 4.7.1-Firmware oder höher verfügbar.
    • Dieser Ausgangstyp ist für Ausgangsleitung 1 nur gültig, wenn „Direkte E/A“ ausgewählt ist.
    • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.
    Job gut/schlecht (nur bei den Serien In-Sight 7000 Gen2 und In-Sight 9000) | Wenn markiert, leuchtet die „Gut/schlecht“-LED und der Leuchtring des Vision-Systems grün (gut) oder rot (schlecht) anhand des aktuellen Status der angegebenen Zelle für den „Gut/schlecht“-Jobstatus.
  8. Klicken Sie auf die Schaltfläche Details, um das Dialogfeld Output Details für die ausgewählte Ausgangsleitung anzuzeigen, wenn detaillierte Einstellungen für den festgelegten Signaltyp des Ausgangs verfügbar sind.

  9. Aktivieren Sie ggf. das Kontrollkästchen Deaktiviert die Ausgänge im Offlinezustand, um die Ausgänge zu deaktivieren, während das Vision-System offline ist.

    Hinweis: Wenn das Kontrollkästchen Deaktiviert die Ausgänge im Offlinezustand aktiviert ist und für das E/A-Modul CIO-MICRO oder CIO-MICRO-CC eine Eingangsleitung mit dem Signaltyp Rettungsleine konfiguriert ist, bleibt die Leitung auf HOCH, auch wenn das verbundene Vision-System offline geschaltet wird.
  10. Die Option Erzwingen ermöglicht es Ihnen, die Anwendung vor oder nach der Bereitstellung zu testen und Fehler zu beheben. Die Option Erzwingen überschreibt die definierten Leitungseinstellungen und ermöglicht das „Erzwingen“ einer Eingangs- oder Ausgangsleitung, damit das Ergebnis getestet werden kann, während der In-Sight-Sensor Online ist.
    1. Wählen Sie die auszuführenden Aktionen aus.
    2. Legen Sie die Einstellung Erzwingen auf Ein fest. Dadurch wird die Eingangsleitung „gezwungen“, die für sie konfigurierte Aktion auszuführen.
    3. Stellen Sie das Vision-System Online und triggern Sie das Vision-System.

    4. Nachdem Sie die Tests der Leitung beendet haben, schalten Sie das Vision-System offline und setzen die Einstellung Erzwingen auf Aus oder Keine.

    Hinweis:
    • Für Ausgangsleitungen generiert die Funktion Erzwingen keinen konkreten Ausgang. Sie ändert bloß den Wert eines Ausgangs, der sonst passieren würde.
    • Wenn Sie die elektrische Verbindung auf Ihrer Ausgangsleitung einfach testen wollen, ist es besser, wenn Sie für die Ausgangsleitung „HOCH“ oder „GERING“ festlegen und das Vision-System online stellen, anstatt Erzwingen zu verwenden. Damit wird die Ausgangsleitung High oder Low gehalten, solange das Vision-System sich im Online-Modus befindet. Sie können dann einen Multimeter zur Bestimmung verwenden, ob der elektrische Pfad wie erwartet arbeitet.
  11. Änderungen an den Einstellungen werden automatisch im Vision-System (nicht in der Job-Datei) gespeichert, wenn Sie den Schritt verlassen.

E/A-Modulkonfiguration

Anzahl der Ein- und Ausgangsleitungen

Standard Ein- und Ausgangsleitungen

Steuerelemente im Dialogfeld „Output Details“


E/A-Modulkonfiguration

Geschlossen Konfiguration des CIO-1400, CIO-1450 oder CIO-1460
  1. Stellen Sie mithilfe von In-Sight Explorer die Verbindung mit einem unterstützten Vision-System her.
  2. Öffnen Sie das Dialogfeld E/A-Modulkonfiguration.
  3. Wählen Sie im DropdownE/A-Modul auswählen die Option CIO-1400, CIO-1450 oder CIO-1460 aus.
  4. Klicken Sie zum Schließend des Dialogfelds auf OK.
Geschlossen Konfiguration des CIO-MICRO oder CIO-MICRO-CC
  1. Stellen Sie mithilfe von In-Sight Explorer die Verbindung mit einem unterstützten Vision-System her.
  2. Öffnen Sie das Dialogfeld E/A-Modulkonfiguration.
  3. Wählen Sie im DropdownE/A-Modul auswählen die Option CIO-MICRO oder CIO-MICRO-CC aus.

  4. Wählen Sie im DropdownVerbindung herstellen zu das entsprechende E/A-Modul aus.

    Hinweis: Wird der Hostname des E/A-Moduls nicht in der Liste angezeigt, aktivieren Sie <Über IP-Adresse verbinden>, und geben Sie manuell die IP-Adresse des E/A-Moduls ein.

  5. Geben Sie im Feld Aktualisierungszeit das Zeitintervall an, das für die Eingangs- und Ausgangssynchronisierung (1ms - 500ms; Standard = 20ms) zwischen dem In-Sight Micro-Vision-System und dem E/A-Modul CIO-MICRO- oder CIO-MICRO-CC erforderlich ist.

    Hinweis: Wenn eine zu hohe Latenz des Ausgangssignals ein Problem darstellt, verringern Sie die Aktualisierungszeit. Verringern Sie die Aktualisierungszeit für die Anwendung jedoch so wenig wie möglich. Wenn die Aktualisierungszeit verringert wird, kann die Jobausführungszeit zunehmen.
  6. Klicken Sie optional auf die Schaltfläche Einstellungen ändern..., um die Netzwerkeinstellungen des E/A-Moduls zu konfigurieren.

    • Standardmäßig werden die E/A-Module In-Sight CIO-MICRO und CIO-MICRO-CC beim Start dynamisch vom DHCP-Server konfiguriert. Ein neuer Hostname kann zugewiesen werden, doch alle anderen Felder im Dialogfeld sind deaktiviert.

      Hinweis: Ist kein DHCP-Server verfügbar, verwendet das E/A-Modul nach Ablauf einer bestimmten Zeit, eine Link Local IP-Adresse.
    • Eine statische IP-Adresse kann für das CIO-MICRO und CIO-MICRO-CC verwendet werden. Deaktivieren Sie dazu das Kontrollkästchen DHCP-Server verwenden, und legen Sie in den Feldern für IP-Adresse, Subnetzmaske, Standardgateway, DNS-Server und Domänenname die entsprechenden Netzwerkeinstellungen fest.
  7. Klicken Sie zum Schließend des Dialogfelds auf OK.
Geschlossen Konfiguration von CIO-WENET

Bevor das CIO-WENET-E/A-Modul in In-Sight Explorer konfiguriert werden kann, muss dem Modul zuerst eine IP-Adresse zugewiesen werden. Nach dem Zuweisen der IP-Adresse zum Modul kann dieses in In-Sight Explorer konfiguriert werden:

  1. Stellen Sie mithilfe von In-Sight Explorer die Verbindung mit einem unterstützten Vision-System her.
  2. Öffnen Sie das Dialogfeld E/A-Modulkonfiguration.
  3. Wählen Sie im DropdownE/A-Modul auswählen die Option CIO-WENET aus.
  4. Geben Sie im Feld IP-Adresse die IP-Adresse an, die Sie zuvor dem CIO-WENET zugewiesen haben.

  5. Geben Sie im Feld Aktualisierungszeit das Zeitintervall an, das für die Eingangs- und Ausgangssynchronisierung (1ms - 500ms; Standard = 20ms) zwischen dem In-Sight Micro-Vision-System und dem CIO-WENET-E/A-Modul erforderlich ist.

    Hinweis:
    • Wenn eine zu hohe Latenz des Ausgangssignals ein Problem darstellt, verringern Sie die Aktualisierungszeit. Verringern Sie die Aktualisierungszeit für die Anwendung jedoch so wenig wie möglich. Wenn die Aktualisierungszeit verringert wird, kann die Jobausführungszeit zunehmen.
    • Für das CIO-WENET ist die Synchronisierungszeit 3 ms länger als die Aktualisierungszeit.
  6. Klicken Sie zum Schließend des Dialogfelds auf OK.


Anzahl der Ein- und Ausgangsleitungen

Die Anzahl der direkten (integrierten) Ausgänge variiert je nach In-Sight-Vision-System wie folgt:

In-Sight Vision-System | Direkte (integrierte) Eingänge | Direkte (integrierte) Ausgänge
In-Sight Micro 1000-Serie | Keine | 2 Hochgeschwindigkeitsausgänge 2 benutzerkonfigurierbare LEDs (1 grün, 1 rot)
In-Sight 2000-Serie | 1 Allzweckeingang | 4 Hochgeschwindigkeitsausgänge 2 benutzerkonfigurierbare LEDs (1 grün oder rot, 1 gelb)
In-Sight 5000-Serie | Keine | 2 Hochgeschwindigkeitsausgänge 2 benutzerkonfigurierbare LEDs (1 grün, 1 rot)
In-Sight 70xx-74xx-Serie | 3 Allzweckeingänge | 4 Hochgeschwindigkeitsausgänge 2 benutzerkonfigurierbare LEDs (1 grün, 1 rot)
In-Sight 76xx-79xx-Serie | Bis zu 3 Allzweckeingänge | Bis zu 4 Hochgeschwindigkeitsausgänge 2 benutzerkonfigurierbare LEDs (1 grün oder rot, 1 rot)
In-Sight 8000-Serie | Keine | 2 Hochgeschwindigkeitsausgänge 2 benutzerkonfigurierbare LEDs (1 grün, 1 rot)
In-Sight 9902L | 1 Allzweckeingang | 2 Hochgeschwindigkeitsausgänge 2 benutzerkonfigurierbare LEDs (1 grün oder rot, 1 rot)
In-Sight 9912 | Bis zu 3 Allzweckeingänge | Bis zu 4 Hochgeschwindigkeitsausgänge 2 benutzerkonfigurierbare LEDs (1 grün oder rot, 1 rot)
Hinweis:
  • In-Sight Vision-Systeme besitzen einen fest zugeordneten Aufnahmetriggereingang im Vision-System. Weitere Informationen finden Sie im Vision-System Installationshandbuch, das in der In-Sight Explorer Software enthalten ist.
  • Wenn Vision-Systeme der In-Sight-Serie 76xx – 79xx oder In-Sight 9912 mit dem Breakout-Kabel angeschlossen sind, sind bidirektionale Hochgeschwindigkeitsausgänge und Allzweckeingänge für HS OUT 2/IN 2 und HS OUT 3/IN 3 möglich. Diese Leitungen sind standardmäßig als Ausgänge konfiguriert.

Mit einem E/A-Modul können zusätzliche diskrete Ein- und Ausgänge zur Verfügung gestellt werden. Die Anzahl der diskreten Ein- und Ausgänge variiert je nach E/A-Modul wie folgt:

E/A-Modul | Unterstütztes In-Sight Vision-System | Diskrete Eingänge | Diskrete Ausgänge
CIO-1400 | In-Sight 2000-Serie, In-Sight 5000-Serie (außer 5604), In-Sight 76xx-79xx-Serie, In-Sight 9000-Serie | 7 Allzweckeingänge | 6 Allzweckausgänge
CIO-MICRO | In-Sight Micro 1000-Serie, In-Sight 5000-Serie, In-Sight 70xx-79xx-Serie, In-Sight 8000-Serie, In-Sight 9000-Serie | 8 Allzweckeingänge | 8 Allzweckausgänge
CIO-MICRO-CC | In-Sight Micro 1000-Serie, In-Sight 5000-Serie (außer 5705, 5705C und 5715), In-Sight 70xx-74xx-Serie | 8 Allzweckeingänge | 8 Allzweckausgänge
CIO-1450 | In-Sight 5000-Serie (außer 5604, 5705, 5705C und 5715) | 8 Allzweckeingänge | 8 Allzweckausgänge
CIO-1460 | In-Sight 5000-Serie (außer 5604, 5605, 5705, 5705C und 5715) | 8 Allzweckeingänge | 8 Allzweckausgänge
CIO-WENET | In-Sight Micro 1000-Serie | 8 Allzweckeingänge | 8 Allzweckausgänge
Hinweis:
  • Das E/A-Modul CIO-1400 unterstützt die Vision-Sensoren der In-Sight 2000-Serie mit Firmwareversion 5.3.0 und höher.
  • Das E/A-Modul CIO-1400 unterstützt die Vision-Systeme der In-Sight 76xx-79xx-Serie unter In-Sight Explorer 5.4.0 und höher. Wenn Sie sich mit einer früheren Version von In-Sight Explorer am Vision-System anmelden, wird die Verbindung zum E/A-Modul CIO-1400 hergestellt und die E/A-Leitungen können auch konfiguriert werden, die Änderungen werden jedoch nicht gespeichert.
  • Das E/A-Modul CIO-MICRO unterstützt die Vision-Systeme 5705, 5705C, 5715 und die Vision-Systeme der In-Sight 8000-Serie mit Firmwareversion 5.3.0 und höher.
  • Von den CIO-MICRO- und CIO-MICRO-CC-E/A-Modulen werden nur die In-Sight-Vision-Systeme der Serien 5100 und 5400 mit mindestens 128 MB nicht flüchtigem Flashspeicher unterstützt. Die Modelle sind anhand der Typnummer erkennbar (821-xxxx-xx). Die Typnummer befindet sich auf dem am Vision-System befestigten Etikett. Eine vollständige Liste mit Modellen sowie Angaben zu Typnummer nicht-flüchtigem Flashspeicher finden Sie hier.
  • Die Module CIO-1450, CIO-1460 und CIO-WENET I/O sind veraltet und werden nicht mehr zum Kauf angeboten. Sie werden jedoch weiterhin im In-Sight Explorer unterstützt, sind allerdings nur abwärtskompatibel.


Standard Ein- und Ausgangsleitungen

Geschlossen In-Sight Micro 1000-Serie
Hinweis:
  • HS OUT 0 und HS OUT 1 sind direkte, integrierte Hochgeschwindigkeitsausgänge des Vision-Systems.
  • Das Vision-System unterstützt den Signaltyp „Blitzimpuls“ für die Leitung HSOUT 1.

Direkte E/A

Ausgang | Name
0 | HSOUT 0
1 | HSOUT 1
4 | Grüne LED
5 | Rote LED

CIO-MICRO oder CIO-MICRO-CC

Eingang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
Ausgang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
8 | HSOUT 0
9 | HSOUT 1
10 | Grüne LED
11 | Rote LED

CIO-WENET

Eingang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
Ausgang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
8 | HSOUT 0
9 | HSOUT 1
10 | Grüne LED
11 | Rote LED
Geschlossen In-Sight 2000-Serie
Hinweis:
  • IN 0 ist ein direkter, integrierter Eingang vom Vision-Sensor.

  • HS OUT 0, HS OUT 1, HS OUT 2 und HS OUT 3 sind direkte, integrierte Hochgeschwindigkeitsausgänge vom Vision-Sensor.

  • Der Vision-Sensor unterstützt den Signaltyp „Blitzimpuls“ für die Leitung HSOUT 1.
  • Bei „grüne LED/rote LED“ handelt es sich um einen einzigen LED-Ausgang, der sowohl einen roten als auch einen grünen Zustand hat, den der Anwender konfigurieren kann.

Direkte E/A

Eingang | Name
0 | IN 0
Ausgang | Name
0 | HSOUT 0
1 | HSOUT 1
2 | HSOUT 2
3 | HSOUT 3
4 | Grüne LED
 | Rote LED
5 | Gelbe LED

CIO-1400

Eingang | Name
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
Ausgang | Name
0 | HSOUT 0
1 | HSOUT 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
 | Leitung 5
5 | Leitung 6
7 | Leitung 7
8 | Grüne LED
9 | Rote LED
10 | Gelbe LED
11 | Deaktiviert
12 | Deaktiviert
Geschlossen In-Sight 5000-Serie

Direkt / CIO-1350

Ausgang | Name
0 | HSOUT 0
1 | HSOUT 1
4 | Grüne LED
5 | Rote LED

CIO-1400

Eingang | Name
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
Ausgang | Name
0 | HSOUT 0
1 | HSOUT 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
8 | Grüne LED
9 | Rote LED

CIO-1450

Hinweis: Wenn gepulste diskrete Ausgaben von einem CIO-1450 E/A-Modul gesendet werden, können die Impulse 10 Millisekunden länger sein als angegeben.
Eingang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
Ausgang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
8 | HSOUT 0
9 | HSOUT 1
10 | Grüne LED
11 | Rote LED

CIO-1460

Hinweis: Beim Aus- und Einschalten eines CIO-1460 E/A-Moduls sind diskrete Ausgänge während der Initialisierung ca. 250 Mikrosekunden lang aktiv.
Eingang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
Ausgang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
8 | HSOUT 0
9 | HSOUT 1
10 | Grüne LED
11 | Rote LED
12 | Deaktiviert
13 | Deaktiviert

CIO-MICRO/CIO-MICRO-CC

Hinweis:
  • Das E/A-Modul CIO-MICRO unterstützt In-Sight 5705, 5705C, 5715 mit Firmwareversion 5.3.0 und höher.
  • Von den CIO-MICRO- und CIO-MICRO-CC-E/A-Modulen werden nur die In-Sight-Vision-Systeme der Serien 5100 und 5400 mit mindestens 128 MB nicht flüchtigem Flashspeicher unterstützt. Die Modelle sind anhand der Typnummer erkennbar (821-xxxx-xx). Die Typnummer befindet sich auf dem am Vision-System befestigten Etikett. Eine vollständige Liste der Modelle und der unterstützten Firmwareversionen finden Sie unter Firmwareversionen.
Eingang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
Ausgang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
8 | HSOUT 0
9 | HSOUT 1
10 | Grüne LED
11 | Rote LED
Geschlossen In-Sight 70xx-74xx-Serie
Hinweis:
  • Das Vision-System der In-Sight 70xx-74xx-Serie unterstützt den gleichzeitigen Anschluss des Breakout-Kabels und des CIO-MICRO- oder CIO-MICRO-CC E/A-Moduls.
  • IN 1, IN 2 und IN 3 sind direkte, integrierte Eingänge des Vision-Systems. Direkte (integrierte) Eingänge werden nur unterstützt, wenn das Vision-System mit dem Breakout-Kabel verbunden ist.
  • HS OUT 0, HS OUT 1, HS OUT 2 und HS OUT 3 sind direkte, integrierte Hochgeschwindigkeitsausgänge des Vision-Systems. Hochgeschwindigkeitsausgänge von Vision-Systemen der In-Sight 70xx-74xx-Serie werden nur unterstützt, wenn das Vision-System mit dem Breakout-Kabel verbunden ist.
  • Das Vision-System unterstützt den Signaltyp „Blitzimpuls“ für die Leitung HSOUT 0.
  • Verwenden Sie das Dialogfeld „Beleuchtungseinstellungen“ für die Einstellungen der externen Beleuchtung, wenn Sie einen externen Stroboskopblitz an das Kabel „Externe Beleuchtung“ des In-Sight Vision-Systems der Serien 70xx – 74xx anschließen.
  • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.

Direkte E/A

Eingang | Name
1 | IN 1/Seriell empfangen
2 | IN 2
3 | IN 3
Ausgang | Name
0 | HS OUT 0
1 | HS OUT 1/Seriell Übertragen
2 | HS OUT 2
3 | HS OUT 3
4 | Grüne LED
5 | Rote LED

CIO-MICRO/CIO-MICRO-CC

Hinweis:
  • Wenn das In-Sight Vision-System mit einem Breakout-Kabel verbunden ist und eine Ethernet-Verbindung zu einem E/A-Modul CIO-MICRO hergestellt wurde:
    • Der E/A-Port des E/A-Moduls (DB15) und die Anschlussklemmen TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 und HS COMMON werden nicht unterstützt. Verbinden Sie niemals die Adern von entfernten Geräten mit diesen Anschlussklemmen.
    • Der E/A-Port (DB15) des E/A-Moduls wird nicht unterstützt. Verbinden Sie diesen Anschluss nicht.
    • Die Pins des RS-232-Ausgangs und des RS-232-Eingangs am Breakout-Kabel sind deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.
Eingang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
9 | IN 1
10 | IN 2
11 | IN 3
Ausgang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
8 | HS OUT 0
9 | HS OUT 1
10 | HS OUT 2
11 | HS OUT 3
12 | Grüne LED
13 | Rote LED
Geschlossen In-Sight 7000 Gen2-Serie
Hinweis:
  • Das Vision-System unterstützt den gleichzeitigen Anschluss des Breakout-Kabels und des E/A-Moduls CIO-MICRO. Eine Liste der unterstützten E/A-Hardware-Konfigurationen finden Sie unter E/A-Hardware-Konfigurationen für In-Sight 7000 Gen2.
  • IN 1, IN 2 und IN 3 sind direkte, integrierte Eingänge des Vision-Systems. Direkte (integrierte) Eingänge werden nur unterstützt, wenn das Vision-System mit dem Breakout-Kabel verbunden ist.
  • HS OUT 0, HS OUT 1, HS OUT 2 und HS OUT 3 sind direkte, integrierte Hochgeschwindigkeitsausgänge des Vision-Systems.
  • Das Vision-System unterstützt den Signaltyp „Blitzimpuls“ für die Leitung HSOUT 1.
  • Verwenden Sie das Dialogfeld „Beleuchtungseinstellungen“ für die Einstellungen der externen Beleuchtung, wenn Sie einen externen Stroboskopblitz an das Kabel „Externe Beleuchtung“ des In-Sight-Vision-Systems der In-Sight 7000 Gen2-Serie oder Beleuchtungszubehör an die Frontplatte des Vision-Systems anschließen.

Direkte E/A

Hinweis: Das Vision-System unterstützt bidirektionale Hochgeschwindigkeitsausgänge und Allzweckeingänge für IN 2/HS OUT 2 und IN 3/HS OUT 3. Diese Leitungen sind standardmäßig als Ausgänge konfiguriert.
Eingang | Richtung | Name
1 | Fixer Eingang | IN 1
2 | Eingang | IN 2
3 | Eingang | IN 3
Ausgang | Richtung | Name
0 | Fixer Ausgang | HSOUT 0
1 | Fixer Ausgang | HSOUT 1
2 | Ausgang | HSOUT 2
3 | Ausgang | HSOUT 3
4 | Fixer Ausgang | Gut/Schlecht-LED
5 | Fixer Ausgang | Fehler-LED

CIO-MICRO

Hinweis:
  • Wenn das In-Sight Vision-System mit einem Breakout-Kabel verbunden ist und eine Ethernet-Verbindung zu einem E/A-Modul CIO-MICRO hergestellt wurde:
    • Das Vision-System unterstützt bidirektionale Hochgeschwindigkeitsausgänge und Allzweckeingänge für IN 2/HS OUT 2 und IN 3/HS OUT 3. Diese Leitungen sind standardmäßig als Ausgänge konfiguriert.
    • Die Anschlussklemmen TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 und HS COMMON des E/A-Moduls CIO-MICRO werden nicht unterstützt. Verbinden Sie niemals die Adern von entfernten Geräten mit diesen Anschlussklemmen.
    • Die Pins des RS-232-Ausgangs und des RS-232-Eingangs am Breakout-Kabel sind deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.
  • Ist ein In-Sight Vision-System mit einem E/A-Modul CIO-MICRO über das E/A-Modulkabel verbunden:
    • Die Leitungen IN 1, IN 2, IN 3, HS OUT 2 und HS OUT 3 des Vision-Systems werden im Dialogfeld „Diskrete E/A-Einstellungen“ zwar angezeigt, aber nicht unterstützt. Diese Leitungen werden nur unterstützt, wenn das Vision-System mit dem Breakout-Kabel verbunden ist.
    • TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 und HS COMMON sind über die Anschlussklemmen des CIO-MICRO E/A-Moduls angeschlossen.
    • An die Frontplatte des Vision-Systems oder den LIGHT-Anschluss angebrachtes Beleuchtungszubehör wird nicht unterstützt. Wenn dieses Beleuchtungszubehör angebracht ist, muss für die Stromversorgung des Vision-Systems das Breakout-Kabel verwendet und das E/A-Modul ausschließlich über Ethernet verbunden sein.
Eingang | Richtung | Name
0 | Fixer Eingang | Linie 0
1 | Fixer Eingang | Linie 1
2 | Fixer Eingang | Leitung 2
3 | Fixer Eingang | Leitung 3
4 | Fixer Eingang | Leitung 4
5 | Fixer Eingang | Leitung 5
6 | Fixer Eingang | Leitung 6
7 | Fixer Eingang | Leitung 7
9 | Fixer Eingang | IN 1
10 | Eingang | IN 2
11 | Eingang | IN 3
Ausgang | Richtung | Name
0 | Fixer Ausgang | Linie 0
1 | Fixer Ausgang | Linie 1
2 | Fixer Ausgang | Leitung 2
3 | Fixer Ausgang | Leitung 3
4 | Fixer Ausgang | Leitung 4
5 | Fixer Ausgang | Leitung 5
6 | Fixer Ausgang | Leitung 6
7 | Fixer Ausgang | Leitung 7
8 | Fixer Ausgang | HSOUT 0
9 | Fixer Ausgang | HSOUT 1
10 | Ausgang | HSOUT 2
11 | Ausgang | HSOUT 3
12 | Fixer Ausgang | Gut/Schlecht-LED
13 | Fixer Ausgang | Fehler-LED

CIO-1400

Hinweis:
  • Bei Verbindung mit dem E/A-Modul CIO-1400 werden die Leitungen IN 1, IN 2, IN 3, HS OUT 2 und HS OUT 3 des Vision-Systems nicht unterstützt.
  • Das E/A-Modul CIO-1400 unterstützt die Vision-Systeme der In-Sight 7000 Gen2-Serie unter In-Sight Explorer 5.4.0 und höher. Wenn Sie sich mit einer früheren Version von In-Sight Explorer am Vision-System anmelden, wird die Verbindung zum E/A-Modul CIO-1400 hergestellt und die E/A-Leitungen können auch konfiguriert werden, die Änderungen werden jedoch nicht gespeichert.
Eingang | Name
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
Ausgang | Name
0 | HSOUT 0
1 | HSOUT 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
8 | Gut/Schlecht-LED
9 | Fehler-LED
Geschlossen In-Sight 8000-Serie
Hinweis:
  • HS OUT 0 und HS OUT 1 sind direkte, integrierte Hochgeschwindigkeitsausgänge des Vision-Systems.
  • Das Vision-System unterstützt den Signaltyp „Blitzimpuls“ für die Leitung HSOUT 1.
  • Wenn das Vision-System In-Sight 8405 mit einem Blitz verwendet wird, wird ein Mindestbelichtungswert von 72 ms für Vollbildaufnahmen empfohlen, damit alle Pixelzeilen belichtet sind, wenn der Blitz gestartet wird. Weitere Informationen finden Sie in den Hinweisen zum Betrieb des Rolling-Shutter.

Direkte E/A

Ausgang | Name
0 | HSOUT 0
1 | HSOUT 1
4 | Grüne LED
5 | Rote LED

CIO-MICRO

Hinweis:
  • Das E/A-Modul CIO-MICRO unterstützt die Vision-Systeme der In-Sight 8000-Serie mit Firmwareversion 5.3.0 und höher.
  • Das In-Sight 8505P vision-System muss an eine PoE-Stromquelle der Klasse 0, 3 oder 4 mit einer max. Belastbarkeit von mindestens 12,95 Watt angeschlossen werden. Das CIO-MICRO E/A-Modul ist ein PoE-Gerät der Klasse 2 und kann daher nicht zur Stromversorgung des In-Sight 8505P vision-System über den PoE-Anschluss des E/A-Moduls verwendet werden. Schließen Sie stattdessen das Ethernet-Kabel des vision-System an eine PoE-Stromversorgung der Klasse 0, 3 oder 4 an und stellen Sie in In-Sight Explorer eine LAN-Verbindung mit dem E/A-Modul her.
Eingang | Name
0 | Leitung 0
1 | Leitung 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
Ausgang | Name
0 | Leitung 0
1 | Leitung 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
8 | HSOUT 0
9 | HSOUT 1
10 | Grüne LED
11 | Rote LED
Geschlossen Zeilenscan-Vision-System In-Sight 9902L
Hinweis:
  • Das Vision-System unterstützt den gleichzeitigen Anschluss des Breakout-Kabels und des E/A-Moduls CIO-MICRO. Eine Liste der unterstützten E/A-Hardware-Konfigurationen finden Sie unter E/A-Hardware-Konfigurationen für In-Sight 9902L.
  • IN 1, IN 2 und IN 3 sind direkte, integrierte Eingänge des Vision-Systems. Direkte (integrierte) Eingänge werden nur unterstützt, wenn das Vision-System mit dem Breakout-Kabel verbunden ist.
  • HS OUT 0 und HS OUT 1 sind direkte, integrierte Hochgeschwindigkeitsausgänge des Vision-Systems.
  • Das Vision-System unterstützt den Signaltyp „Blitzimpuls“ für die Leitung HSOUT 1.
  • Bei der Verwendung eines Blitzimpulses beim Zeilenscan-Vision-System In-Sight 9902L:
    • Der Blitzimpuls sollte eine PNP-Verdrahtung verwenden; die Option „Blitzimpuls/Beleuchtung Trigger“ muss auf „Steigende Flanke“ gesetzt werden.
    • Wenn beim Vision-System ein Aufnahme-Trigger eingeht, sendet die Ausgangsleitung einen Impuls und der Blitzimpuls blitzt für die Dauer der Belichtungszeit. Nach Abschluss der Belichtung müssen mindestens 100µs vergehen, bevor der nächste Aufnahme-Trigger empfangen wird. Andernfalls funktioniert der Blitzimpuls u. U. nicht richtig.

Direkte E/A

Eingang | Name
1 | IN 1
Ausgang | Name
0 | HSOUT 0
1 | HSOUT 1
4 | Gut/Schlecht-LED
5 | Fehler-LED

CIO-MICRO

Hinweis:
  • Wenn das In-Sight Vision-System mit einem Breakout-Kabel verbunden ist und eine Ethernet-Verbindung zu einem E/A-Modul CIO-MICRO hergestellt wurde:
    • Die Anschlussklemmen TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 und HS COMMON des E/A-Moduls CIO-MICRO werden nicht unterstützt. Verbinden Sie niemals die Adern von entfernten Geräten mit diesen Anschlussklemmen.
    • Die Pins des RS-232-Ausgangs und des RS-232-Eingangs am Breakout-Kabel sind deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.
  • Ist ein In-Sight Vision-System mit einem E/A-Modul CIO-MICRO über das E/A-Modulkabel verbunden:
    • DREHGEBER A EINGANG und DREHGEBER B EINGANG des vision-Systems werden nicht unterstützt.

    • Leitung IN 1 des Vision-Systems wird im Dialogfeld „Diskrete E/A-Einstellungen“ zwar angezeigt, aber nicht unterstützt. IN 1 wird nur unterstützt, wenn das Vision-System mit dem Breakout-Kabel angeschlossen ist.

    • TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 und HS COMMON sind über die Anschlussklemmen des CIO-MICRO E/A-Moduls angeschlossen.
Eingang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
9 | IN 1
Ausgang | Name
0 | Linie 0
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
8 | HSOUT 0
9 | HSOUT 1
10 | Gut/Schlecht-LED
11 | Fehler-LED

CIO-1400

Hinweis: Wenn das E/A-Modul CIO-1400 angeschlossen ist, werden die Leitungen DREHGEBER A EINGANG, DREHGEBER B EINGANG und IN 1 des Vision-Systems nicht unterstützt.
Eingang | Name
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
Ausgang | Name
0 | HSOUT 0
1 | HSOUT 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
8 | Gut/Schlecht-LED
9 | Fehler-LED
Geschlossen In-Sight 9912
Hinweis:
  • Das Vision-System unterstützt den gleichzeitigen Anschluss des Breakout-Kabels und des E/A-Moduls CIO-MICRO. Eine Liste der unterstützten E/A-Hardware-Konfigurationen finden Sie unter E/A-Hardware-Konfigurationen für In-Sight 9912.
  • IN 1, IN 2 und IN 3 sind direkte, integrierte Eingänge des Vision-Systems. Direkte (integrierte) Eingänge werden nur unterstützt, wenn das Vision-System mit dem Breakout-Kabel verbunden ist.
  • HS OUT 0, HS OUT 1, HS OUT 2 und HS OUT 3 sind direkte, integrierte Hochgeschwindigkeitsausgänge des Vision-Systems.
  • Das Vision-System unterstützt den Signaltyp „Blitzimpuls“ für die Leitung HSOUT 1.
  • Wenn Sie einen externen Stroboskopblitz an das Kabel „Externe Lampe“ des In-Sight Vision-Systems 9912 anschließen, kann die externe Lampe mit dem Dialogfeld „Einstellungen externe Lampe“ konfiguriert werden.

Direkte E/A

Hinweis: Das Vision-System unterstützt bidirektionale Hochgeschwindigkeitsausgänge und Allzweckeingänge für IN 2/HS OUT 2 und IN 3/HS OUT 3. Diese Leitungen sind standardmäßig als Ausgänge konfiguriert.
Eingang | Richtung | Name
1 | Fixer Eingang | IN 1
2 | Eingang | IN 2
3 | Eingang | IN 3
Ausgang | Richtung | Name
0 | Fixer Ausgang | HSOUT 0
1 | Fixer Ausgang | HSOUT 1
2 | Ausgang | HSOUT 2
3 | Ausgang | HSOUT 3
4 | Fixer Ausgang | Gut/Schlecht-LED
5 | Fixer Ausgang | Fehler-LED

CIO-MICRO

Hinweis:
  • Wenn das In-Sight Vision-System mit einem Breakout-Kabel verbunden ist und eine Ethernet-Verbindung zu einem E/A-Modul CIO-MICRO hergestellt wurde:
    • Das vision-System unterstützt bidirektionale Hochgeschwindigkeitsausgänge und Allzweckeingänge für IN 2/HS OUT 2 und IN 3/HS OUT 3. Diese Leitungen sind standardmäßig als Ausgänge konfiguriert.
    • Die Anschlussklemmen TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 und HS COMMON des E/A-Moduls CIO-MICRO werden nicht unterstützt. Verbinden Sie niemals die Adern von entfernten Geräten mit diesen Anschlussklemmen.
    • Die Pins des RS-232-Ausgangs und des RS-232-Eingangs am Breakout-Kabel sind deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.
  • Ist ein In-Sight Vision-System mit einem E/A-Modul CIO-MICRO über das E/A-Modulkabel verbunden:
    • Die Leitungen IN 1, IN 2, IN 3, HS OUT 2 und HS OUT 3 des Vision-Systems werden im Dialogfeld „Diskrete E/A-Einstellungen“ zwar angezeigt, aber nicht unterstützt. Diese Leitungen werden nur unterstützt, wenn das Vision-System mit dem Breakout-Kabel verbunden ist.
    • TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 und HS COMMON sind über die Anschlussklemmen des CIO-MICRO E/A-Moduls angeschlossen.
    • An den LIGHT-Anschluss des Vision-Systems angeschlossenes Beleuchtungszubehör wird nicht unterstützt. Wenn dieses Beleuchtungszubehör angebracht ist, muss für die Stromversorgung des Vision-Systems das Breakout-Kabel verwendet und das E/A-Modul ausschließlich über Ethernet verbunden sein.
Eingang | Richtung | Name
0 | Fixer Eingang | Linie 0
1 | Fixer Eingang | Linie 1
2 | Fixer Eingang | Leitung 2
3 | Fixer Eingang | Leitung 3
4 | Fixer Eingang | Leitung 4
5 | Fixer Eingang | Leitung 5
6 | Fixer Eingang | Leitung 6
7 | Fixer Eingang | Leitung 7
9 | Fixer Eingang | IN 1
10 | Eingang | IN 2
11 | Eingang | IN 3
Ausgang | Richtung | Name
0 | Fixer Ausgang | Linie 0
1 | Fixer Ausgang | Linie 1
2 | Fixer Ausgang | Leitung 2
3 | Fixer Ausgang | Leitung 3
4 | Fixer Ausgang | Leitung 4
5 | Fixer Ausgang | Leitung 5
6 | Fixer Ausgang | Leitung 6
7 | Fixer Ausgang | Leitung 7
8 | Fixer Ausgang | HSOUT 0
9 | Fixer Ausgang | HSOUT 1
10 | Ausgang | HSOUT 2
11 | Ausgang | HSOUT 3
12 | Fixer Ausgang | Gut/Schlecht-LED
13 | Fixer Ausgang | Fehler-LED

CIO-1400

Hinweis: Bei Verbindung mit dem E/A-Modul CIO-1400 werden die Leitungen IN 1, IN 2, IN 3, HS OUT 2 und HS OUT 3 des Vision-Systems nicht unterstützt.
Eingang | Name
1 | Linie 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
Ausgang | Name
0 | HSOUT 0
1 | HSOUT 1
2 | Leitung 2
3 | Leitung 3
4 | Leitung 4
5 | Leitung 5
6 | Leitung 6
7 | Leitung 7
8 | Gut/Schlecht-LED
9 | Fehler-LED


Steuerelemente im Dialogfeld „Output Details“

  • Impuls: Wenn dieses Kontrollkästchen aktiviert ist, wird der Ausgang gepulst. Deaktivieren Sie das Kontrollkästchen, wenn das Ausgangssignal statisch sein soll. Der Ausgang muss gepulst werden, wenn die Bildaufnahmeverzögerung größer als 0 ist.

  • Impulslänge (ms): Dauer eines Ausgangsimpulses.

    Vision-System/Vision-Sensor | Mindestimpulslänge | Höchstimpulslänge | Standardimpulslänge
    Allzweckausgang | Hochgeschwindigkeitsausgang
    In-Sight Micro 1000-Serie (außer 1402, 1412 und 1500) | 10 ms | 10 ms | 1000 ms | 10 ms
    In-Sight Micro 1402, 1412 und 1500 | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight 2000-Serie | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight 5000-Serie | 10 ms | 10 ms | 1000 ms | 10 ms
    In-Sight 70xx-74xx-Serie | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight 76xx-79xx-Serie | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight 8000-Serie | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight 9902L | 1 ms | 1 ms | 1000 ms | 10 ms
    In-Sight 9912 | 1 ms | 1 ms | 1000 ms | 10 ms
    Hinweis:
    • Bei CIO-Micro- oder CIO-Micro-CC E/A-Modulen mit unterstützten Vision-Systemen ist die minimale Pulslänge für Allzweckausgänge durch die Einstellung von „Zeit für Aktualisierung“ im Dialogfeld „E/A-Modulkonfiguration“ begrenzt. Wenn zum Beispiel „Zeit für Aktualisierung“ auf 20 ms eingestellt ist, kann die minimale Impulslänge nicht unter 30 ms eingestellt werden. Weitere Informationen finden Sie unter Dialogfeld E/A-Modulkonfiguration.
    • Bei den Vision-Systemen der Serien In-Sight 76xx – 79xx sowie 8000 wird die Mindestimpulslänge von 1 ms nur bei Verwendung der In-Sight-Firmwareversion 5.5.0 oder höher unterstützt. Bei einer niedrigere Firmwareversion beträgt die Mindestimpulslänge 10 ms.

  • Bildaufnahmeverzögerung (N):: Die Anzahl der Bildaufnahme- oder Erkennungsimpulse (0 bis 1000) für die Verzögerung der Ausgabe, nachdem ein Signalimpuls von einer Ausgangsleitung empfangen wurde. Ist die Bildaufnahmeverzögerung gleich 0, aktualisiert das In-Sight Vision-System die Ausgangsleitung sofort bei der Auswertung des EasyBuilder-Jobs. Bei einer Bildaufnahmeverzögerung größer als 0 wird die Ausgangsleitung immer gepulst.

    Hinweis: Eine gleichzeitige Verwendung von Bildaufnahmeverzögerung und Zeit nach Trigger ist nicht möglich. Diese Optionen können nur einzeln verwendet werden. Bei aktivierter Bildaufnahmeverzögerung ist Zeit nach Trigger deaktiviert und umgekehrt.

  • Zeit nach Trigger (ms): Ist dieses Kontrollkästchen aktiviert, wird der Ausgang nach der festgelegten Zeitspanne (0 bis 10000 ms) ausgelöst.

    Hinweis: Eine gleichzeitige Verwendung von Bildaufnahmeverzögerung und Zeit nach Trigger ist nicht möglich. Diese Optionen können nur einzeln verwendet werden. Bei aktivierter Bildaufnahmeverzögerung ist Zeit nach Trigger deaktiviert und umgekehrt.
  • Blitz/Beleuchtung Trigger:: Mit der steigenden oder fallenden Flanke des Signals kann ein Blitzimpuls oder eine Lichtsteuerung getriggert werden.
    • NPN-Konfiguration: Wenn auf Steigende Flanke gestellt ist, ist das Signal HIGH, wenn der Bildsensor belichtet wird, andernfalls ist das Signal LOW. Bei Fallende Flanke ist das Signal LOW, wenn der Bildsensor belichtet wird, andernfalls ist das Signal HIGH. Immer gepulst für die Dauer der Belichtung. Die Belichtungszeit muss 0,50 ms höher sein, als die Blitz-Pulsdauer, die am externen Blitzgerät festgelegt wurde.

    • PNP-Konfiguration: Wenn auf Steigende Flanke gestellt ist, ist das Signal LOW, wenn der Bildsensor belichtet wird, andernfalls ist das Signal HIGH. Bei Fallende Flanke ist das Signal HIGH, wenn der Bildsensor belichtet wird, andernfalls ist das Signal LOW. Immer gepulst für die Dauer der Belichtung. Die Belichtungszeit muss 0,50 ms höher sein, als die Blitz-Pulsdauer, die am externen Blitzgerät festgelegt wurde.

      Hinweis:
      • Bei Vision-Systemen der In-Sight 5600-Serie, 5705, 5705C, 5715 und 9902L ist das Blitzimpulsverhalten umgekehrt (z. B. verhalten sich bei NPN-Verdrahtung die steigende und die fallende Flanke wie bei einer PNP-Verdrahtung).
      • Bei der Verwendung eines Blitzimpulses beim Zeilenscan-Vision-System In-Sight 9902L:
        • Der Blitzimpuls sollte eine PNP-Verdrahtung verwenden; die Option „Blitzimpuls/Beleuchtung Trigger“ muss auf „Steigende Flanke“ gesetzt werden.
        • Wenn beim Vision-System ein Aufnahme-Trigger eingeht, sendet die Ausgangsleitung einen Impuls und der Blitzimpuls blitzt für die Dauer der Belichtungszeit. Nach Abschluss der Belichtung müssen mindestens 100µs vergehen, bevor der nächste Aufnahme-Trigger empfangen wird. Andernfalls funktioniert der Blitzimpuls u. U. nicht richtig.
  • Blitzimpuls-Startposition: Gibt an, wann der Blitzimpuls pulsieren sollte. Diese Option wird auf dem Vision-System In-Sight 9902L nicht unterstützt.
    • Start Bildaufnahme: Legt fest, dass der Blitz beginnt, wenn das In-Sight-Vision-System mit der Aufnahme beginnt. Wird von allen Vision-Systemen außer dem In-Sight 8405 Vision-System unterstützt.
    • Kameratrigger: Legt fest, dass der Blitz beim Empfang eines Kameratriggers beginnt. Wird von allen Vision-Systemen außer dem In-Sight 8405 Vision-System unterstützt.

    • Alle Zeilen belichtet: Legt fest, dass der Blitz nur gestartet wird, wenn alle Pixelzeilen belichtet werden. Wird nur vom In-Sight 8405 Vision-System unterstützt.

      Hinweis: Bei der Verwendung eines Blitzes mit dem In-Sight 8405 wird eine Mindestbelichtung von 72ms für Vollbildaufnahmen empfohlen, damit alle Pixelzeilen belichtet sind, wenn der Blitz gestartet wird. Weitere Informationen finden Sie in den Hinweisen zum Betrieb des Rolling-Shutter.

  • Dreifarben-LED: Konfiguriert das verhalten der dreifarbigen LED-Leitungen. (Aus/Grün, Aus/Rot, Rot/Grün; Standard = Aus/Grün) Diese Option ist nur verfügbar, wenn die Leitung Dreifarben-LEDs unterstützt.

    Hinweis: Diese Option wird in Vision-Systemen der In-Sight 76xx-79xx-Serie und der In-Sight 9000-Serie für die „Gut/schlecht“-LED unterstützt, steht aber nicht zur Verfügung, wenn die Zelle für den „Gut/schlecht“-Jobstatus der ausgewählte Signaltyp ist.


Eingänge: Laden einer Job-Datei

Vision-Sensoren der In-Sight 2000-Serie

Um diese Funktionalität zu verwenden, muss mindestens ein Job, mit dem numerischen Präfix 0 bis 31 und im Format #JobDateiname.job (z.B., 2BolzenInspektion.job) gespeichert worden sein.

  1. Wählen Sie die Eingangsleitung 0 aus und setzen Sie den Signaltyp auf Parametersatzänderung (Gepulst).

  2. Um 2PinInspektion.job in den Sensor zu laden, sendet ein externes Gerät (wie z.B. eine SPS) eine Serie an Impulsen auf den In-Sight 2000-Sensor.

    Impulstyp | Impulslänge
    Startimpuls | 20ms (±2ms)
    Zählimpuls | 10ms (±1ms)
    Impulsabstand | 10ms (± 1ms)
    Stoppimpuls | 20ms (±2ms)
    1. Das externe Gerät gibt ein Startimpuls aus, dem ein Impulsabstand folgt.
    2. Das externe Gerät gibt dann drei Zählimpulse aus. Es gibt immer einen Impulsabstand zwischen zwei Impulsen und auch einen Impulsabstand nach dem letzten Zählimpuls. Die Anzahl der ausgegebenen Zählimpulse muss dem numerischen Präfix des zu ladenden Jobs entsprechen. Zum Laden von 2PinInspection.job sind beispielsweise zwei Zählimpulse erforderlich.

    3. Am Ende gibt das externe Gerät einen Stopimpuls aus. Wenn alle Impulse und Impulsabstände mit der angegebenen Impulslänge übereinstimmen, wird der Jobänderungswunsch als erfolgreich betrachtet und 2BolzenInspektion.job in den Sensor geladen. Sollte der Vorgang wegen mindestens einer der Bedingungen fehlschlagen (d.h. ein nicht richtiger Impuls oder falsches Timing des Impulsabstands), schlägt der Jobänderungswunsch fehl und es findet keine Jobänderung statt.

      Hinweis:
      • Der Native Mode-Befehl SetSystemConfig("PulseJobChangeTiming") kann für daie Konfiguration der Impulsbreiten des Startimpulses, Zählimpuleses, des Impulsabstands und des Stopimpulses verwendet werden.
      • Optional kann eine diskrete Ausgangsleitung als Typ Laden des Auftrags OK oder Laden des Auftrags fehlgeschlagen für das Pulsen des Ausgangs konfiguriert werden und so über den Erfolg bzw. das Fehlschlagen des Jobänderungswunsches berichten. Wenn die angegebene Eingangsimpulslänge nicht verwendet wird, wird der Ausgang nicht gepulst, um zu zeigen, dass der Job nicht geladen werden konnte.

In-Sight Vision-Systeme

Zur Verwendung dieser Funktion müssen Sie zuvor mindestens einen Job gespeichert haben, und die zu ladenden Jobs müssen mit einem numerischen Präfix zwischen 0 und 127 gespeichert sein, z. B. "1BolzenInspektion.job".

  1. Wählen Sie eine zu konfigurierende Eingangsleitung aus und setzen Sie den Signaltyp auf Auftragsladeschalter. Die geladene Jobdatei wird anhand des Status (0 oder 1) anderer Eingangsleitungen angegeben, die auf Auftrags-ID eingestellt sind.
  2. Stellen Sie für mindestens eine andere Eingangsleitung den Signaltyp auf Auftrags-ID ein.
  3. Ein auf Auftrags-ID festgelegter Eingang stellt ein Bit einer binären Zahl dar. Nachfolgende auf Auftrags-ID festgelegte Eingangsleitungen stellen zusätzliche Bits der binären Zahl dar. Die vollständige binäre Zahl stellt das numerische Präfix (Dezimalzahl) einer in folgendem Format gespeicherten Jobdatei dar: #JobDateiname.job.

Beispiel 1

Drei diskrete Eingänge sind auf Auftrags-ID festgelegt und stellen eine binäre 3-Bit-Zahl dar. Angenommen, der jeweilige Status der drei Eingänge ist 0, 1 bzw. 0. In diesem Fall gibt die binäre Zahl 010 an, dass eine Jobdatei mit dem Präfix 2 (010 als Dezimalzahl) geladen werden soll.

Beispiel 2

Sie haben drei verschiedene Jobdateien namens "3inspektion.job", "6inspektion.job" und "9inspektion.job". Die Jobdatei "6inspektion.job" soll geladen werden, sobald der Sensor ein HIGH-Signal von einer programmierbaren Steuerung empfängt. Der diskrete Eingang 1 wird zurzeit als Bildaufnahmetrigger verwendet.

  1. Verbinden Sie die Eingabeleitung 1 mit der SPS.
  2. Stellen Sie den Signaltyp von Eingangsleitung 1 auf Auftragsladeschalter ein.
  3. Da das Präfix des Jobdateinamens die Ziffern 3 bis 9 umfasst, müssen vier Eingänge auf Auftrags-ID eingestellt werden. Dabei entspricht 9 binär 1001.

  4. Wenn der jeweilige Status der Job-ID-Leitungen 1, 1, 0 und 0 (6 entspricht 1100 binär) und der Status Eingangsleitung 2 "HIGH (1)" ist, wird der Job namens "6inspektion.job" geladen.

    Hinweis: Hinweis: Werden mehrere Jobs mit demselben numerischen Präfix im In-Sight-Sensor gespeichert, wird die Datei mit der alphabetisch höchsten Position geladen.


Eingänge: Aktivieren und Deaktivieren von Positions- und Inspektionswerkzeugen

Die Ausführung von Positions- und Inspektionswerkzeugen ist an eine Eingangsleitung gebunden. Durch die Zuordnung des Werkzeugs zu einem Eingang kann mithilfe eines Kontrollsystems (z. B. PLC) festgelegt werden, welche Werkzeuge ausgeführt werden sollen.

  1. Wählen Sie eine Eingangsleitung aus, und stellen Sie den Signaltyp auf Benutzerdaten ein.
  2. Rufen Sie das gewünschte Positions- oder Inspektionswerkzeug auf, und zeigen Sie das zugehörige Steuerelement Tool Enable an. Wählen Sie im Dropdowndie im obigen Schritt festgelegte Eingangsnummer aus.
  3. Das Werkzeug kann jetzt vom Steuerungssystem aktiviert oder deaktiviert werden (ein HIGH-Signal 1 bedeutet EIN, ein LOW-Signal 0 bedeutet AUS).


Eingänge: Auslösen der Bildaufnahme

Führen Sie die folgenden Schritte aus, um das In-Sight-Vision-System zum Empfangen eines Bildaufnahmetriggers über eine Eingangsleitung von einer SPS, einem Fotodetektor oder einem anderen Gerät zu konfigurieren:

  1. Klicken Sie auf den Schritt Bild einrichten.

  2. Wählen Sie im Gruppenfeld Aufnahmeeinstellungen bearbeiten im Dropdownmenü Trigger die Option Extern.

    Hinweis:
    • Externer Trigger wird auf dem Vision-Sensor der In-Sight 2000-Serie nicht unterstützt.
    • Höhere Triggergeschwindigkeiten werden durch die Verwendung des integrierten Triggereingangs des Systems erzielt (indem der Parameter Trigger auf Kamera gesetzt wird), anstatt das Vision-System mit einer als Triggereingang konfigurierten Allzweckeingangsleitung zu triggern (indem der Parameter Trigger auf Extern gesetzt wird).
    • Falls der Parameter „Trigger“ der AcquireImage-Funktion auf „Extern“ gestellt ist und eine Aufnahme verpasst wird, sendet das Vision-System kein diskretes „FEHLER: Bild verpasst“-Signal. Das „FEHLER: Bild verpasst“-Signal wird nur unterstützt, wenn der Parameter „Trigger“ der AcquireImage-Funktion auf „Kamera“ gestellt ist.
  3. Kehren Sie zum Schritt Eingänge/Ausgänge zurück.

  4. Wählen Sie eine Eingangsleitung aus und stellen Sie den Signaltyp auf Bildaufnahmetrigger ein.

    Hinweis: Bildaufnahmetrigger wird auf dem E/A-Modul CIO-1400 nicht unterstützt.
  5. Stellen Sie den Kantentyp des Signals auf Steigende Flanke oder Fallende Flanke ein.
  6. Verbinden Sie die Kabel des Eingabegeräts mit dem Triggereingang am Breakout-Kabel eines In-Sight-Vision-Systems oder am E/A-Modul. Weitere Informationen finden Sie im Installationshandbuch für das In-Sight-Vision-System oder für das E/A-Modul.


Eingänge: Einlernen eines Modellmusters über eine Eingangsleitung

Führen Sie die folgenden Schritte aus, um das In-Sight-Vision-System zum Einlernen eines Modellmusters über eine Eingangsleitung zu konfigurieren.

  1. Wählen Sie im Positionswerkzeug „Muster/Muster (1-10)“, im An-/Abwesenheitswerkzeug „Muster“ oder im Zählwerkzeug „Muster“ eine Eingangsleitung, die als Einlernsignal verwendet werden soll, aus der Dropdownliste „Eingang Einlernen“ aus.

    Hinweis: Wenn eine Verbindung zu einem In-Sight Vision-System oder einem In-Sight 2000-23M-Vision-Sensor besteht, ist die Dropdownliste Eingang Einlernen auf der Registerkarten „Einstellungen“ enthalten.
  2. Kehren Sie zum Anwendungsschritt „Eingänge/Ausgänge“ zurück.
  3. Legen Sie als Signaltyp der ausgewählten Eingangsleitung Ereignistrigger aus.
  4. Stellen Sie den Flankentyp des Signals auf Steigende Flanke, Fallende Flanke oder Beide Flanken ein.

  5. Schalten Sie das In-Sight-Vision-System/den Sensor online.

    Hinweis: Beim Einlernen eines Modellmusters wird das Bild verwendet, das zuletzt vom Vision-System/Sensor aufgezeichnet wurde. Es ist nicht erforderlich, das Vision-System/den Sensor erneut auszulösen, um einzulernen.

  6. Die Flanke(n) des ausgewählten Flankentyps löst/lösen ein Training des Modellmusters aus.


Ausgänge: Signalisieren einer fehlgeschlagenen Bildaufnahme

So signalisieren Sie eine fehlgeschlagene Bildaufnahme:

  1. Klicken Sie auf den Schritt Bild einrichten.
  2. Wählen Sie im Gruppenfeld Aufnahmeeinstellungen bearbeiten im Dropdownmenü Trigger die Option Kamera.
  3. Kehren Sie zum Schritt Eingänge/Ausgänge zurück.
  4. Wählen Sie eine Ausgangsleitung aus, und stellen Sie den Signaltyp auf Aufnahmeende ein. Klicken Sie auf Details, um die Impulslänge festzulegen.
  5. Wählen Sie eine andere Ausgangsleitung aus, und stellen Sie den Signaltyp auf FEHLER: Bild verpasst. Dies signalisiert, dass ein Bildaufnahmetrigger empfangen wurde, bevor ein Aufnahmeende-Signal gesendet wurde, oder dass kein Bildpuffer für die Bildaufnahme verfügbar war, als der Bildaufnahmetrigger empfangen wurde.
  6. Klicken Sie auf Details, um die Impulslänge festzulegen.


Ausgänge: Triggern einer Beleuchtung für die Bildaufnahme

Geschlossen Triggern eines Blitzimpulses

Mit der steigenden oder fallenden Flanke des Signals kann ein Blitzimpuls getriggert werden.

Zum Senden eines Signals zum Triggern eines Blitzes:

  1. Legen Sie die Einstellungen für den Bildaufnahmetrigger im Schritt Bild einrichten fest. Vergewissern Sie sich, dass die Belichtungszeit 0,50 ms länger ist als die Abtastimpulsdauer, die auf dem externen Beleuchtungsgerät festgelegt wurde.
  2. Stellen Sie den Signaltyp der ursprünglichen Ausgangslinie auf Blitzimpuls ein.
  3. Klicken Sie auf die Schaltfläche Details, und legen Sie fest, ob der Abtastimpuls durch eine Steigende Flanke oder eine Fallende Flanke) getriggert werden soll.
    • NPN-Konfiguration: Wenn auf Steigende Flanke gestellt ist, ist das Signal HIGH, wenn der Bildsensor belichtet wird, andernfalls ist das Signal LOW. Bei Fallende Flanke ist das Signal LOW, wenn der Bildsensor belichtet wird, andernfalls ist das Signal HIGH. Immer gepulst für die Dauer der Belichtung. Die Belichtungszeit muss 0,50 ms höher sein, als die Blitz-Pulsdauer, die am externen Blitzgerät festgelegt wurde.

    • PNP-Konfiguration: Wenn auf Steigende Flanke gestellt ist, ist das Signal LOW, wenn der Bildsensor belichtet wird, andernfalls ist das Signal HIGH. Bei Fallende Flanke ist das Signal HIGH, wenn der Bildsensor belichtet wird, andernfalls ist das Signal LOW. Immer gepulst für die Dauer der Belichtung. Die Belichtungszeit muss 0,50 ms höher sein, als die Blitz-Pulsdauer, die am externen Blitzgerät festgelegt wurde.

      Hinweis:
      • Bei Vision-Systemen der In-Sight 5600-Serie, 5705, 5705C, 5715 und 9902L ist das Blitzimpulsverhalten umgekehrt (z. B. verhalten sich bei NPN-Verdrahtung die steigende und die fallende Flanke wie bei einer PNP-Verdrahtung).
      • Bei der Verwendung eines Blitzimpulses beim Zeilenscan-Vision-System In-Sight 9902L:
        • Der Blitzimpuls sollte eine PNP-Verdrahtung verwenden; die Option „Blitzimpuls/Beleuchtung Trigger“ muss auf „Steigende Flanke“ gesetzt werden.
        • Wenn beim Vision-System ein Aufnahme-Trigger eingeht, sendet die Ausgangsleitung einen Impuls und der Blitzimpuls blitzt für die Dauer der Belichtungszeit. Nach Abschluss der Belichtung müssen mindestens 100µs vergehen, bevor der nächste Aufnahme-Trigger empfangen wird. Andernfalls funktioniert der Blitzimpuls u. U. nicht richtig.
  4. Legen Sie die Blitzimpuls-Startposition fest. Diese Option wird auf dem Vision-System In-Sight 9902L nicht unterstützt.
    • Start Bildaufnahme: Legt fest, dass der Blitz beginnt, wenn das In-Sight-Vision-System mit der Aufnahme beginnt. Wird von allen Vision-Systemen außer dem In-Sight 8405 Vision-System unterstützt.
    • Kameratrigger: Legt fest, dass der Blitz beim Empfang eines Kameratriggers beginnt. Wird von allen Vision-Systemen außer dem In-Sight 8405 Vision-System unterstützt.

    • Alle Zeilen belichtet: Legt fest, dass der Blitz nur gestartet wird, wenn alle Pixelzeilen belichtet werden. Wird nur vom In-Sight 8405 Vision-System unterstützt.

Hinweis:
  • Das In-Sight Vision-System und die externe Beleuchtungseinrichtung müssen an dieselbe Masse angeschlossen sein, damit der Blitz korrekt funktioniert.
  • Vision-Systeme der Serien In-Sight Micro 1000, In-Sight 5000 (mit Ausnahme des 5604), In-Sight 76xx – 79xx, In-Sight 8000 und In-Sight 9000 unterstützen den Signaltyp „Blitzimpuls“ für die Leitung HSOUT 1.
  • Vision-Systeme der Serien In-Sight 70xx – 74xx unterstützen den Signaltyp „Blitzimpuls“ für die Leitung HSOUT 0.
  • Beim Vision-System In-Sight 8405 ist Blitzimpuls-Startposition fix auf „Alle Zeilen belichtet“ eingestellt und das Ausgangssignal wird nur während der Zeit gepulst, in der alle Pixelzeilen belichtet sind. Bei der Verwendung eines Blitzes mit dem In-Sight 8405 wird eine Mindestbelichtung von 72ms für Vollbildaufnahmen empfohlen, damit alle Pixelzeilen belichtet sind, wenn der Blitz gestartet wird. Weitere Informationen finden Sie in den Hinweisen zum Betrieb des Rolling-Shutter.
Geschlossen Triggern einer externen Lampe (Nur bei CIO-1460)

Mit der steigenden oder fallenden Flanke des Signals kann eine externe Lampe getriggert werden.

So senden Sie ein Signal zum Triggern einer externen Lampe:

  1. Melden Sie sich bei einem Vision-System der In-Sight 5000-Serie an und stellen Sie eine Verbindung zu einem E/A-Modul CIO-1460 her.
  2. Legen Sie die Einstellungen für den Bildaufnahmetrigger im Schritt Bild einrichten fest. Vergewissern Sie sich, dass die Belichtungszeit 0,50 ms länger ist als die Abtastimpulsdauer, die auf dem externen Beleuchtungsgerät festgelegt wurde.
  3. Stellen Sie den Signaltyp für HSOUT 1 auf Lichtsteuerung ein.
  4. Klicken Sie auf die Schaltfläche Details, und legen Sie fest, ob der Abtastimpuls durch eine Steigende Flanke oder eine Fallende Flanke) getriggert werden soll.
Hinweis:
  • Das In-Sight Vision-System und die externe Beleuchtungseinrichtung müssen an dieselbe Masse angeschlossen sein, damit der Blitz korrekt funktioniert.
  • Dieser Ausgangssignaltyp ist nur für die Hochgeschwindigkeits-Ausgangsleitung 1 (HSOUT 1) beim Konfigurieren des CIO-1460 E/A-Erweiterungsmoduls für das Vision-System der In-Sight 5000-Serie gültig.


Ausgänge: Einstellen einer Ausgangsleitung auf das Ergebnis eines Positions- oder Inspektionswerkzeugs

So senden Sie ein Signal basierend auf dem Ergebnis eines Positions- oder Inspektionswerkzeugs:

  1. Wählen Sie eine Ausgangsleitung aus, und stellen Sie den Signaltyp auf Jobergebnis ein.
  2. Wählen Sie im DropdownJobergebnis ein Werkzeugergebnis für die Ausgabe aus. Die aufgelisteten Werkzeugergebnisse (z. B. "Text_1", "Muster_1" usw.) stellen einen Gesamtstatus "Bestanden/Fehler" für das jeweilige Werkzeug dar. Die Jobergebnisse sind bei allen Werkzeugen kumulativ (Bestanden/Fehler). Bei einem Werkzeugergebnis "Bestanden" ist das Signal HIGH (1), und bei einem Werkzeugergebnis "Fehler" ist es "LOW" (0).
  3. Klicken Sie auf die Schaltfläche Details, um die Impulslänge und die Bildaufnahmeverzögerung festzulegen. Werden diese Einstellungen nicht festgelegt, wird das Signal nicht gepulst.


Kommunikation

Im Schritt Kommunikation können die Inspektionsergebnisse für den öffentlichen Datenzugriff und -austausch (OPC) definiert, eine EasyView für die VisionView®-Benutzeroberfläche konfiguriert, Bilder per FTP oder auf die SD-Karte exportiert und Einstellungen für das Netzwerk und die serielle Kommunikation von In-Sight Vision-Systemen definiert werden. Diese Einstellungen ermöglichen die Datenübertragung an andere Geräte und von anderen Geräten (z. B. Roboter oder speicherprogrammierbare Steuerung (SPS)/Bewegungssteuerung).

Hinweis:
  • Der In-Sight-Sensor muss für den Schritt Kommunikation auf Offline gesetzt sein.
  • Die Kommunikationsprotokolle des Jobs können mithilfe eines Emulators konfiguriert und gespeichert und dann für die Laufzeitbereitstellung in ein In-Sight Vision-System geladen werden. Die ProfiNET- und CC-Link-Protokolle können zwar ausgewählt, aber nicht im Emulator simuliert werden. Bei diesen Protokollen müssen die Kommunikationsprotokolle des Jobs in einem mit dem ProfiNET- oder CC-Link-Netzwerk verbundenen In-Sight Vision-System entwickelt und gespeichert werden.

Unterstützte Protokolle

Es können bis zu zwei Protokolle zu einem Job hinzugefügt werden. Wenn Sie zwei Protokolle hinzufügen, können Sie ein „primäres“ und ein „sekundäres“ Protokoll hinzufügen. Beispiel: Klicken Sie nach dem Hinzufügen des SLMP-Scanner-Protokolls (primär) erneut auf die Schaltfläche Gerät hinzufügen, und fügen Sie das TCP/IP Protokoll (sekundär) hinzu.

Hinweis: Sie können nicht zwei „primäre“ oder zwei „sekundäre“ Protokolle zu einem Job hinzufügen.

In-Sight-Firmwareversion 4.x.x

 | Primär oder Sekundär | Micro 1000-Serie | 5000-Serie (ausgenommen 5705 & 5705C) | 70xx-74xx-Serie
CC-Link | Primär | X | X | X
Ethernet Native | Primär | X | X | X
Ethernet Native Roboter | Primär | X | X | X
Ethernet Native-Zeichenfolge | Primär | X | X | X
Ethernet/IP | Primär | X | X | X
Modbus-TCP-Server | Primär | X | X | X
POWERLINK | Primär |  |  | X
PROFINET | Primär | X | X | X
Kuka (seriell) | Primär | X | X | X
Motoman (seriell) | Primär | X | X | X
Native (seriell) | Primär | X | X | X
Serieller Native Roboter | Primär | X | X | X
Serielle Native-Zeichenfolge | Primär | X | X | X
Text (seriell) | Primär | X | X | X
SLMP | Primär | X | X | X
SLMP-Scanner | Primär | X | X | X
TCP/IP | Sekundär | X | X | X
UDP | Sekundär | X | X | X

In-Sight Explorer 5.x.x.

 | Primär oder Sekundär | 2000-Serie | 5705 und 5705C | 7000 Gen2-Serie | 8000-Serie | 9000-Serie
CC-Link IE Field Basic | Primär | X | X | X | X | X
Ethernet Native | Primär |  | X | X | X | X
Ethernet Native Roboter | Primär |  | X | X | X | X
Ethernet Native-Zeichenfolge | Primär |  | X | X | X | X
Ethernet/IP | Primär | X | X | X | X | X
Modbus-TCP-Server | Primär | X | X | X | X | X
PROFINET | Primär | X | X | X | X | X
Kuka (seriell) | Primär |  | X | X | X | X
Motoman (seriell) | Primär |  | X | X | X | X
Native (seriell) | Primär | X (Basic) | X | X | X | X
Serieller Native Roboter | Primär |  | X | X | X | X
Serielle Native-Zeichenfolge | Primär |  | X | X | X | X
Text (seriell) | Primär | X | X | X | X | X
SLMP | Primär | X | X | X | X | X
SLMP-Scanner | Primär | X | X | X | X | X
TCP/IP | Sekundär | X | X | X | X | X
UDP | Sekundär | X | X | X | X | X

Datenfreigabe über OPC-Server

Konfigurieren einer EasyView

Exportieren von Bildern über FTP

Exportieren einer Datendatei oder Anhängen einer Datenzeichenfolge an eine Datei über FTP

Exportieren von Bildern auf eine SD-Karte

Exportieren einer Datendatei oder Anhängen einer Datenzeichenfolge an eine Datei auf einer SD-Karte

Geräte-Einrichtung

Kommunikation mit einer Rockwell ControlLogix SPS

Integration von Universal Robots – TCP/IP


Datenfreigabe über OPC-Server

Umfasst Ihre Anwendung andere Geräte, die zur Kommunikation einen OPC-Server verwenden, können die Inspektionsergebnisse (oder Eingabedaten) an einen In-Sight OPC UA Server oder einen In-Sight OPC Classic Server übertragen werden.

In-Sight OPC UA Server und In-Sight OPC Classic Server werden auf folgenden Modellen unterstützt.

Vision-System/-Sensor | Unterstützung für In-Sight OPC UA Server | Unterstützung für In-Sight OPC Classic Server
In-Sight Micro 1000-Serie | Nicht unterstützt | Firmware 4.x.x
In-Sight 2000-Serie | Firmware ab 5.8.0 | Nicht unterstützt
Serien In-Sight 5400 und 5600 | Nicht unterstützt | Firmware 4.x.x
In-Sight 5705 und 5705C | Nicht unterstützt | Firmware 5.x.x
In-Sight 7000-Serie | Nicht unterstützt | Firmware 4.x.x
In-Sight 7000 Gen2-Serie | Firmware ab 5.8.0 | Firmware 5.x.x
In-Sight 8000-Serie | Firmware ab 5.8.0 | Firmware 5.x.x
In-Sight 9000-Serie | Firmware ab 5.8.0 | Firmware 5.x.x
Emulatoren | Nicht unterstützt | Unterstützt

OPC-Tags

OPC-Tags zu einer Job-Datei hinzufügen

OPC-UA


OPC-Tags

Ein OPC-Tag ist ein symbolischer Name, der auf die EasyBuilder-Inspektionsergebnisse eines unterstützten In-Sight-Vision-Systems/-Sensors angewendet werden kann. Das OPC-Tag ist für OPC-UA-Clients sichtbar, sodass diese auf die In-Sight-Job-Daten zugreifen können. Im Kontext der In-Sight-OPC-UA-Implementierung gibt es zwei Arten von OPC-Tags: Job-Tags und System-Tags.

Ein OPC-Tag kann für folgende Datentypen stehen:

  • Boolescher Wert: Für Tags, die nur boolesche Werte enthalten.
  • Fließpunkt: Für Tags, die nur Fließpunktwerte enthalten.
  • Ganzzahl: Für Tags, die nur Ganzzahlen enthalten.

  • Textzeichenfolge: Für Tags, die nur Textzeichenfolgen enthalten.

    Hinweis:
    • Bei Textzeichenfolgen werden maximal 256 Zeichen unterstützt.
    • Textzeichenfolgen werden als Unicode an den OPC-Client geschickt.

Für OPC-Tags gibt es die Zugriffsstufen „Lesen“ oder „Lesen/Schreiben“. Ob OPC-UA-Clients Daten aus der In-Sight-Job-Datei lesen oder in diese schreiben können, hängt von der Zugriffsstufe des OPC-Tags ab.

  • Lesen: Die Tag-Werte können vom OPC-UA-Client nur abgerufen werden.
  • Read/Write: Die Tag-Werte können vom OPC-UA-Client abgerufen und geändert werden.


OPC-Tags zu einer Job-Datei hinzufügen

Auf allen In-Sight-Vision-Systemen/-Sensoren, die OPC UA unterstützen, wurden System-Tags für OPC-UA-Clients vordefiniert. Diese Tags machen jedoch wahrscheinlich nicht alle Daten sichtbar, auf die Sie über den OPC-UA-Client zugreifen möchten. Daher können Job-Tags zu EasyBuilder-Inspektions- und Jobergebnissen hinzufügt werden, durch die die Werte für die Clients verfügbar werden.

  1. Wählen Sie im Gruppenfeld „Kommunikation“ die Option OPC aus.
  2. Klicken Sie im Abschnitt „Ausgewählte OPC-Tags“ auf die Schaltfläche Hinzufügen, um das Dialogfeld „OPC-Tags auswählen“ zu öffnen.
  3. Das Dialogfeld „OPC-Tags auswählen“ beinhaltet die Daten aus den jeweiligen Positions- oder Inspektions-Werkzeugen, die Ihrem Job hinzugefügt wurden, sowie die Gesamtergebnisse. Wählen Sie im Dialogfeld die entsprechenden Daten aus, die Sie aktivieren möchten.
  4. Klicken Sie nach der Auswahl der gewünschten Daten auf OK, um die Änderungen zu übernehmen. Die OPC-Tags werden nun im Abschnitt „Ausgewählte OPC-Tags“ angezeigt.
  5. Konfigurieren Sie den OPC-Server.
    • Informationen zum Einsatz von OPC UA Server finden Sie unter OPC-UA.
    • Informationen zum Einsatz von In-Sight OPC Classic Server finden Sie in der Hilfe zu In-Sight® OPC Classic Server.


OPC-UA

Open Platform Communications – Unified Architecture (OPC UA) ist ein modernes Kommunikationsprotokoll, das von der OPC Foundation entwickelt wurde und eine plattformunabhängige, sichere Lösung mit offener Architektur für Industriegeräte und ‑systeme bereitstellt. Für In-Sight dient das Vision-System bzw. der Vision-Sensor als OPC-UA-Server, der direkt mit einem OPC-UA-Client kommunizieren kann. Dadurch ist keine zusätzliche Hardware notwendig.

In-Sight OPC UA Server und In-Sight OPC Classic Server werden auf folgenden Modellen unterstützt. Weitere Informationen zum In-Sight OPC Classic Server finden Sie in der Hilfe zu In-Sight® OPC Classic Server.

Vision-System/-Sensor | Unterstützung für In-Sight OPC UA Server | Unterstützung für In-Sight OPC Classic Server
In-Sight Micro 1000-Serie | Nicht unterstützt | Firmware 4.x.x
In-Sight 2000-Serie | Firmware ab 5.8.0 | Nicht unterstützt
Serien In-Sight 5400 und 5600 | Nicht unterstützt | Firmware 4.x.x
In-Sight 5705 und 5705C | Nicht unterstützt | Firmware 5.x.x
In-Sight 7000-Serie | Nicht unterstützt | Firmware 4.x.x
In-Sight 7000 Gen2-Serie | Firmware ab 5.8.0 | Firmware 5.x.x
In-Sight 8000-Serie | Firmware ab 5.8.0 | Firmware 5.x.x
In-Sight 9000-Serie | Firmware ab 5.8.0 | Firmware 5.x.x
Emulatoren | Nicht unterstützt | Unterstützt

Der OPC-UA-Client kann auf folgende Daten von In-Sight-Vision-Systemen/‑Sensoren zugreifen:

  • Anzahl der Aufnahmen
  • Name des aktiven Jobs
  • Online-Status (mit Native Online, Discrete Online und GUI Online)
  • Status des Live-Video-Modus

Zusätzlich zum Abruf der Daten können OPC-UA-Clients mit In-Sight OPC UA Server folgende Vorgänge ausführen:

  • aktiven Job speichern
  • Job laden
  • Aufnahmeereignisse triggern
  • Online-Modus umschalten
  • Live-Video-Modus umschalten
Hinweis: Es liegt im Verantwortungsbereich des Designers der benutzerdefinierten Anwendung, den Zugriff auf die sichtbaren Tags des Servers (z. B. Schreiben neuer Job-Dateien, Schreiben von Zellwerten und Umschalten des Online-/Offline-Status) auf dem Vision-System/‑Sensor einzuschränken.

Außerdem kann der OPC-Client so konfiguriert werden, dass Änderungen an Werten für AddressSpace-Knoten („überwachte Elemente“) überwacht werden. Statt diese Werte konstant auf Änderungen abzufragen, können Sie Abonnements für Knoten erstellen, mit denen diese Elemente überwacht werden. Wenn eine Änderung erkannt wird, wird im Rahmen des Abonnements eine Benachrichtigung erstellt und an den OPC-UA-Client geschickt. Die Anzahl der unterstützten Sitzungen, Clients und Knoten für die überwachten Elemente hängt vom Vision-System/‑Sensor ab:

Vision-System/-Sensor | Anzahl der Sitzungen/Clients | AddressSpace-Knoten
In-Sight 2000-Serie | Eine Sitzung auf einem OPC-UA-Client. | 50 Knoten in 20 Abonnements pro Sitzung/Client.
In-Sight 7000 Gen2-Serie | Zwei Sitzungen auf zwei OPC-UA-Clients. | 250 Knoten in 20 Abonnements pro Sitzung/Client.
In-Sight 8000-Serie | Zwei Sitzungen auf zwei OPC-UA-Clients. | 250 Knoten in 20 Abonnements pro Sitzung/Client.
In-Sight 9000-Serie | Zwei Sitzungen auf zwei OPC-UA-Clients. | 250 Knoten in 20 Abonnements pro Sitzung/Client.

OPC-UA-Server aktivieren

Job-Tags und System-Tags von OPC-UA

OPC-UA-Methoden

SetSystemConfig: Zeitsynchronisierung für OPC UA

Fehlerbehebung


OPC-UA-Server aktivieren

Wenn OPC UA verwendet wird, muss zuerst der In-Sight OPC UA Server auf dem Vision-System/‑Sensor aktiviert werden. Anschließend können Sie über den OPC-UA-Client eine Verbindung damit herstellen.

Tipp: Wenn die Zeitsynchronisierung für OPC-UA-Tag-Zeitstempel konfiguriert werden muss, verwenden Sie den erweiterten Native-Mode-Befehl „SetSystemConfig OPCUA.TimeSync“, bevor der OPC-UA-Server aktiviert wird. Weitere Informationen finden Sie unter SetSystemConfig: Zeitsynchronisierung für OPC UA.
  1. Wählen Sie im Gruppenfeld „Kommunikation“ die Option OPC aus.

  2. Aktivieren Sie das Kontrollkästchen OPC-UA-Server aktivieren.

  3. Klicken Sie auf OK.
  4. Klicken Sie in der Aufforderung auf Ja, um das Vision-System/den Vision-Sensor neu zu starten. Nach dem Neustart wird der OPC-UA-Server initialisiert und ist betriebsbereit. Der Erkennungsendpunkt ist für Anfragen des OPC-UA-Clients empfangsbereit.
  5. Öffnen Sie den OPC-UA-Client.

  6. Im OPC-UA-Client muss die Endpunkt-URL eingegeben werden, um eine Verbindung zum OPC-UA-Server herzustellen. Die Endpunkt-URL muss in folgendem Format angegeben werden. <IP-Adresse> ist hierbei die IP-Adresse des Vision-Systems/-Sensors:

    opc.tcp://<IP-Adresse>:4840

    Beispiel: opc.tcp://192.168.0.8:4840


Job-Tags und System-Tags von OPC-UA

Job-Tags sind Tags, die vom Benutzer konfiguriert werden können und die einen Wert repräsentieren, der in der In-Sight-Job-Datei gespeichert ist; sie können von den OPC-UA-Clients eingesehen werden. Job-Tags werden in der Job-Datei gespeichert.

System-Tags sind Standard-Tags, die immer auf allen Vision-Systemen/-Sensoren, die OPC UA Server unterstützen, verfügbar sind; sie können zur Konfiguration hinzugefügt werden. System-Tags werden nicht in der Job-Datei gespeichert.

System-Tag

Verfügbarkeit

Datentyp

Beschreibung

AcquisitionCount

Schreibgeschützt

Ganzzahl

Gibt die Anzahl der Aufnahmen seit dem Einschalten des Vision-Systems/-Sensors zurück.

DiscreteOnline

Schreibgeschützt

Boolescher Wert

Gibt „Falsch“ zurück, wenn eine diskrete Eingangsleitung (als Typ „Online/Offline“ konfiguriert) auf „Niedrig“ (0) gesetzt ist. Andernfalls wird „Wahr“ zurückgegeben.

GuiOnline

Schreibgeschützt

Boolescher Wert

Gibt „Wahr“ zurück, wenn die Benutzeroberfläche von In-Sight Explorer in den Online-Modus versetzt wurde (Menü „Sensor“ > Online).

JobName

Schreibgeschützt

Zeichenfolge

Gibt den Namen des aktiven Jobs, der auf dem Vision-System/-Sensor geladen ist, zurück, wenn der aktive Job gespeichert wurde.

Hinweis: Da das Tag „JobName“ schreibgeschützt ist, kann die Job-Datei mit der Methode „SaveJobAs“ umbenannt werden. Weitere Informationen finden Sie unter OPC-UA-Methoden.

LiveMode

Lesen/Schreiben

Boolescher Wert
  • Lesen: Gibt „Wahr“ aus, wenn sich das System/der Sensor im Modus „Live-Video“ befindet. Andernfalls wird „Falsch“ zurückgegeben.
  • Schreiben: Wenn ein anderer Wert als Null in das LiveMode-Tag geschrieben wird, wird auf dem Vision-System/-Sensor der Live-Video-Modus aktiviert. Mit Null im LiveMode-Tag wird der Live-Video-Modus beendet.
Hinweis: Wenn die Job-Ansicht eines Vision-Systems/‑Sensors in In-Sight Explorer geöffnet ist, nachdem der Wert „Wahr“ in das LiveMode-Tag geschrieben wurde, zeigt In-Sight Explorer das Live-Bild nicht an und auf der Statusleiste „Job-Ansicht“ wird nicht „Live-Video“ angezeigt.

NativeOnline

Lesen/Schreiben

Boolescher Wert
  • Lesen: Gibt „Falsch“ aus, wenn der Native-Mode-Befehl „SO0“ für „Online schalten“ an das Vision-System/den Vision-Sensor ausgegeben wurde. Andernfalls wird „Wahr“ zurückgegeben.
  • Schreiben: Wenn ein anderer Wert als Null in das NativeOnline-Tag geschrieben wird, wird das In-Sight-Vision-System/der In-Sight-Vision-Sensor über den Native Mode offline geschaltet (entspricht der Ausgabe des Native-Mode-Befehls für „Online schalten“ „SO0“). Wenn Null in das NativeOnline-Tag geschrieben wird, kann das In-Sight-Vision-System/der In-Sight-Vision-Sensor online geschaltet werden (entspricht der Ausgabe des Native-Mode-Befehls für „Online schalten“ „SO1“).

Online

Schreibgeschützt

Boolescher Wert

Gibt die logische „AND“-Verknüpfung für Folgendes aus: (DiscreteOnline AND NativeOnline AND GuiOnline).


OPC-UA-Methoden

Folgende Standardmethoden sind immer auf allen Vision-Systemen/-Sensoren, die OPC UA Server unterstützen, verfügbar; sie können zur Konfiguration hinzugefügt werden. Methoden werden nicht in der Job-Datei gespeichert.

Methode

Verfügbarkeit

Datentyp

Beschreibung
LoadJob(Dateiname) Lesen/Schreiben Zeichenfolge

Lädt den angegebenen Jobnamen auf das Vision-System.

Hinweis:

  • Der angegebene Jobname muss als Datei auf dem Vision-System/-Sensor vorhanden sein. Andernfalls wird ein Fehler ausgegeben.

  • Wenn beim Laden großer Job-Dateien einer der folgenden Fehler auftritt, wird empfohlen, die Standardwerte für die Zeitüberschreitung entsprechend der Ladezeiten für den Job zu ändern.
    • Das Standard-Zeitlimit für LoadJob beträgt 10 Sekunden. Beim Überschreiten des Standard-Zeitlimits wird im OPC-UA-Client der Fehler „Zeitüberschreitung für Methode“ angezeigt. Der Job wird dennoch geladen und die Kommunikation funktioniert auch weiterhin.
    • Das Standard-Zeitlimit für den Verbindungs-Watchdog beträgt 5 Sekunden. Beim Laden des Jobs aktualisiert das Vision-System/der Vision-Sensor den OPC-UA-Client nicht. Wenn der Zustand anhält und das Standard-Zeitlimit überschritten wird, wird im OPC-UA-Client der Fehler „Zeitüberschreitung für Watchdog“ angezeigt. Nach dem Laden des Jobs wird die Verbindung automatisch wiederhergestellt und die Kommunikation wird automatisch wieder aufgenommen.
SaveJobAs(Dateiname) Lesen/Schreiben Zeichenfolge

Die aktive Job-Datei wird als die angegebene Zeichenfolge gespeichert.

Hinweis: Zum Aufruf der Methode „SaveJobAs“ muss das Vision-System/der Vision-Sensor offline sein. Andernfalls wird ein Fehler ausgegeben.
TriggerManualAcquisition Lesen/Schreiben Nicht verfügbar

Löst eine manuelle Bildaufnahme im Vision-System/-Sensor aus.
TriggerSoftEvent(Index) Lesen/Schreiben Ganzzahl

Löst einen Soft-Trigger im Vision-System aus. Eine Ganzzahl von 0 bis 7 in der Methode „TriggerSoftEvent“ löst den entsprechenden „Software-Trigger n“ in der Tabelle aus (dabei ist „n“ die angegebene Ganzzahl).


SetSystemConfig: Zeitsynchronisierung für OPC UA

Konfiguriert die Zeitsynchronisierung für OPC-UA-Tag-Zeitstempel.

Hinweis: Dieser erweiterte Native-Mode-Befehl wird auf dem Vision-Sensor In-Sight 2000 unterstützt.

Eingaben

Syntax: EV SetSystemConfig("OPCUA.TimeSync",[TimeSyncFrequency],[InitialTimeoutSec],[TimeSyncFrequencySec],[WriteProcSet])

Parameter

 Beschreibung

"OPCUA.TimeSync"

Verweis auf die Zeitsynchronisierungseinstellungen für OPC UA.

TimeSyncFrequency
  • 0 = Datum/Uhrzeit werden nur einmal, während des Systemstarts, synchronisiert. (Standardeinstellung)
  • 1 = Datum/Uhrzeit werden kontinuierlich synchronisiert, abhängig vom Wert im Parameter „TimeSyncFrequencySec“. Diese Einstellung wird für eine präzise Zeitsynchronisierung empfohlen.
InitialTimeoutSec

Legt fest, wie lange der OPC-UA-Server warten wird (in Sekunden), bevor Datum und Uhrzeit übernommen werden. (Standard = 15 Sekunden)

Hinweis:
  • Der OPC-UA-Server startet erst nach Ablauf der Zeit, die in InitialTimeoutSec festgelegt wurde.
  • Wenn die Datums-/Zeiteinstellungen auf dem Vision-System/‑Sensor manuell konfiguriert wurden und beim Neustart des Vision-Systems/-Sensors weder ein SNTP-Server noch ein für das Precision Time Protocol (PTP) konfiguriertes externes Gerät gefunden wird, wird die Ausgangszeit auf Donnerstag, 01. Januar 1970 12:00:00 Uhr zurückgesetzt. Erhöhen Sie in diesem Fall InitialTimeoutSec und konfigurieren Sie die Datums-/Zeiteinstellungen nach dem Einschalten des Vision-Systems/-Sensors manuell.
TimeSyncFrequencySec

Gibt die Häufigkeit für die Zeitsynchronisation an, wenn der Parameter TimeSyncFrequency auf 1 gesetzt wird. (Standard = 1 Sekunde)

WriteProcSet
  • 0 = Die Einstellungen werden nicht in der Datei Proc.set gespeichert. Sie bleiben bei einem Neustart des In-Sight-Vision-Systems/-Sensors nicht erhalten. (Standard)
  • 1 = Die Einstellungen werden in der Datei Proc.set gespeichert. Sie bleiben bei einem Neustart des In-Sight-Vision-Systems/-Sensors erhalten.

Ausgänge

Gibt einen Statuscode aus, gefolgt von der Anzahl der Zeichen (in Byte) für die Ergebnisse, und nachfolgend die Ergebnisse im XML-Format. Es gibt folgende Statuscodes:

Statuscodes | Beschreibung
1 | Der Befehl wurde erfolgreich ausgeführt.
0 | Unbekannter Befehl.
-2 | Der Befehl konnte nicht ausgeführt werden.
-6 | Der Benutzer besitzt nicht den erforderlichen Vollzugriff zur Ausführung des Befehls.


Fehlerbehebung

Problem Lösung

Wenn UaExpert als Client verwendet wird, reagiert das Vision-System nach 14 bis 16 Sitzungs-Zeitüberschreitungen mit einer Länge von 30 Sekunden nicht mehr auf OPC-UA-Anfragen, und die UaExpert-Clients können keine Verbindung mit dem Vision-System herstellen.

In diesem Fall erhalten neue Clients sowie die Clients, bei denen die Zeitüberschreitungen aufgetreten sind, folgenden Fehler beim Verbindungsversuch:

„Error 'BadTimeout' was returned during OpenSecureChannel“ (Zeitüberschreitungsfehler wurde während OpenSecureChannel zurückgegeben).

Hinweis: In diesem Zustand funktioniert alles andere wie erwartet. Sie können die Anzahl der eingetretenen Sitzungs-Zeitüberschreitungen in der Sensorstatusansicht im In-Sight Explorer (Fenster > Sensorstatusansicht anzeigen) überprüfen.

Für UaExpert:

  • SecureChannelLifetime: Legt fest, wie lang der Kanal aktiv bleiben soll. (Standard = eine Stunde. Minimum = 5 Minuten.)
  • SessionTimeout: Legt fest, wie lange gewartet werden soll, bis die Verbindung zu einer nicht reagierenden Sitzung getrennt wird. Beachten Sie, dass der sichere Kanal auch nach einer Zeitüberschreitung aktiv bleibt. (Standard = 20 Minuten. Minimum = 30 Sekunden.)
  1. Warten Sie eine Stunde, bis SecureChannelLifetime zurückgesetzt wird.
  2. Starten Sie das Vision-System/den Vision-Sensor neu, wenn die SecureChannelLifetime sehr lang ist und in diesem Zeitraum viele Sitzungs-Zeitüberschreitungen auftreten.


Konfigurieren einer EasyView

Sie können mit einer HMI-Anwendung eine EasyView erstellen, die Datenanzeige anpassen und festlegen, ob und welche Daten der Bediener bearbeiten kann. Erstellen Sie die EasyView in EasyBuilder, und speichern Sie sie unter dem Job des Sensors. Sehen Sie sich dann eine Vorschau der EasyView im VisionView PC-Demo oder der Web HMI-Anwendung an, um sich zu vergewissern, dass sie richtig konfiguriert ist.

So konfigurieren Sie eine EasyView:

  1. Wählen Sie im Gruppenfeld Kommunikation die Option EasyView aus.
  2. Klicken Sie im Abschnitt Ausgewählte EasyView-Elemente auf die Schaltfläche Hinzufügen, um das Dialogfeld EasyView-Elemente auswählen zu starten.

  3. Das Dialogfeld EasyView-Elemente auswählen enthält die Daten aus allen Positions- oder Inspektionswerkzeugen des Jobs sowie Aufnahme- und Jobeinstellungen. Wählen Sie im Dialogfeld die entsprechenden Werkzeugdaten aus, die Sie in die EasyView aufnehmen möchten. Markieren Sie dazu die gewünschten Elemente, und klicken Sie auf Hinzufügen, oder aktivieren Sie das Kontrollkästchen „EasyView“ des Elements.

    Hinweis:
    • Wenn Sie mehrere, nicht aufeinander folgende Elemente auswählen möchten, halten Sie die STRG-Taste gedrückt und markieren Sie die Elemente.
    • Wenn Sie mehrere aufeinander folgende Elemente auswählen möchten, halten Sie die Umschalttaste gedrückt und markieren Sie das erste und letzte Element in der Liste.

  4. Klicken Sie nach der Auswahl der gewünschten Werkzeugdaten auf OK, um die Änderungen zu übernehmen. Die Werkzeugdaten werden nun im Abschnitt EasyView-Elemente auswählen angezeigt.

    Hinweis:
    • Wenn Sie mehrere, nicht aufeinander folgende Elemente auswählen möchten, halten Sie die STRG-Taste gedrückt und markieren Sie die Elemente.
    • Wenn Sie mehrere aufeinander folgende Elemente auswählen möchten, halten Sie die Umschalttaste gedrückt und markieren Sie das erste und letzte Element in der Liste.

  5. Nachdem Sie die Werkzeugdaten hinzugefügt haben, können Sie das Kontrollkästchen Bearbeitbar aktivieren, um dem Bediener die Möglichkeit zu geben, die Werkzeugdaten in VisionView zu ändern.

    Hinweis: Zur Bearbeitung der Werkzeugdaten in VisionView sind Lese-und Schreibberechtigungen erforderlich.
  6. Sie können optional auf die Schaltfläche Beschriftung einfügen klicken, um eine Beschriftung für die Kopfzeile zu erstellen. Beschriftungen sind zur Gliederung von Werkzeugdaten nützlich.
  7. Die Beschriftung ist der Name, der in HMI-Anwendung angezeigt wird. Sie können die Standardbeschriftung ändern, indem Sie in das Feld Beschriftung der Werkzeugdaten oder Werkzeugbeschriftung klicken und einen beschreibenden Namen eingeben. Drücken Sie die EINGABETASTE, oder klicken Sie außerhalb des Felds Beschriftung, um die Änderung zu übernehmen. Drücken Sie die ESCAPE-Taste, um die Änderung zu verwerfen.
  8. Sie können die Anzeige der Werkzeugdaten und/oder Beschriftungen ändern, indem Sie sie in der Liste auswählen und auf die Schaltfläche Nach oben oder Nach unten klicken, um die gewünschte Reihenfolge festzulegen.

  9. Speichern Sie die Jobdatei.

    Hinweis: Die EasyView-Einstellungen werden auch automatisch im In-Sight-Sensor gespeichert, wenn Sie den Schritt Kommunikation verlassen.

  10. Starten Sie das VisionView PC-Demo oder die Web HMI-Anwendung, um sich in einer Vorschau anzusehen, wie die EasyView später angezeigt wird.

    Hinweis: Wenn das VisionView PC-Demo auf Ihrem PC installiert ist, ist das Standard-Installationsverzeichnis: C:/Program Files/Cognex/VisionView/PC Demo x.x.x. Wenn das VisionView PC-Demo nicht auf Ihrem PC installiert ist, können Sie die Anwendung von der VisionView-Supportwebsite herunterladen.
  11. Nachdem das VisionView PC-Demo gestartet wurde, trennen Sie die Verbindung zum Sensor im Schritt Verbindung herstellen.

  12. Bei Verwendung der Web HMI-Anwendung können Sie eine Vorschau der EasyView im EasyView-Fenster anzeigen.

    Fügen Sie den Sensor im VisionView PC-Demo der Liste Ausgewählte Sensoren hinzu, starten Sie den Betriebsmodus, und klicken Sie auf die Schaltfläche Ansicht wechseln, um eine Vorschau der EasyView anzuzeigen.

    Hinweis:
    • Um eine Vorschau einer EasyView anzuzeigen, müssen Sie zuerst im Dialogfeld HMI-Ansichtsauswahl die EasyView-Optionen aktivieren.
    • Das VisionView PC-Demo hat ein automatisches Zeitlimit von 45 Minuten. Laden Sie die VisionView-PC-Software von der VisionView-Supportwebsite herunter, und installieren Sie sie, um eine lizenzierte Version mit voller Funktionalität und ohne Zeitlimit zu erhalten.
    • Aussehen und Handhabung von VisionView PC-Demo und VisionView-Benutzeroberfläche unterscheiden sich geringfügig.
    • Um während der Anmeldung bei einem Emulator eine Vorschau der EasyView anzuzeigen, müssen Sie den Emulator erst manuell zur Liste Ausgewählte Sensoren in VisionView hinzufügen.


Exportieren von Bildern über FTP

Sie können das In-Sight Vision-System so konfigurieren, dass es Bilder an einen FTP-Server im Netzwerk exportiert. So können Sie aufgenommene Bilder (auf Basis eines Werkzeugs oder des Gut/Schlecht-Status eines Jobs) zu Archivierungszwecken auf einem anderen Gerät speichern. Diese Bilder können dann überprüft werden, um mögliche Fertigungsprobleme zu diagnostizieren.

So konfigurieren Sie eine FTP-Verbindung:

  1. Wählen Sie im Gruppenfeld Kommunikation die Option FTP aus.
  2. Wählen Sie die Registerkarte Bild aus.

  3. Klicken Sie auf die Schaltfläche Hinzufügen, um einen Eintrag hinzuzufügen und die Parameter für den Bildexport zu konfigurieren.

    Hinweis: Sie können einem Job mehrere Bildexportvorgänge hinzufügen.
  4. Wählen Sie die Registerkarte Einstellungen aus, und konfigurieren Sie die Einstellungen für den FTP-Server.
  5. Schalten Sie das In-Sight Vision-System online. Das Vision-System muss für die Ausführung online sein. Andernfalls werden keine Bilder exportiert.
  6. Triggern Sie das Vision-System für die Aufnahme von Bildern. Für jedes aufgenommene Bild wird eine Bilddatei (BMP oder JPG, je nach Einstellung des Parameters Dateiformat) exportiert und auf dem mit dem Parameter Hostname festgelegten Host gespeichert.
Hinweis:
  • Wenn Übertragungsbedingung auf Keine (Standard) gesetzt ist, wird bei jeder neuen Bildaufnahme eine Bilddatei exportiert. Wenn Übertragungsbedingung auf eine andere Option als Keine (Standard) gesetzt ist, wird bei jedem Auftreten des angegebenen Ereignisses eine Bilddatei exportiert. Beispiel: Wenn Übertragungsbedingung auf Job.Schlecht gesetzt ist, wird bei jedem fehlgeschlagenen Job eine Bilddatei exportiert und auf dem FTP-Server gespeichert.
  • Wenn Sie den In-Sight-Emulator als FTP-Server verwenden, werden Dateien standardmäßig in den Emulatorordner ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x) geschrieben. Zusätzlich zu diesem Verzeichnis können die Dateien in ein benutzerdefiniertes Verzeichnis geschrieben werden (Autorisiertes FTP-Verzeichnis). Weitere Informationen zum autorisierten FTP-Verzeichnis finden Sie unter Dialogfeld „Optionen“ (Emulationsbereich).

Registerkarte Bild

Enthält Parameter, über die Sie das exportierte Bild, dessen Format sowie den Zeitpunkt und das Ziel des Bildexports definieren können.

Geschlossen Kontrollkästchen „Aktiviert“

(Standardmäßig ausgewählt) Bestimmt, ob der Bildexportvorgang aktiv ist und ob er als EasyView-Element (beispielsweise WriteImageFTP_1.Werkzeug_aktiviert) angezeigt wird. Diese Elemente können auf der VisionView-Benutzeroberfläche dargestellt und vom Bediener bearbeitet werden.

Hinweis: Zum Aktivieren markieren Sie in der Tabelle das Kontrollkästchen Aktiviert. Dies ist der einzige konfigurierbare Parameter in der Tabelle.
Geschlossen Name

Gibt den Namen des Bildexportvorgangs an, der zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet werden kann. Der Standardname lautet „WriteImageFtp_1“, sofern es sich um den ersten Bildexportvorgang handelt, der dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. “WriteImageFtp_2”, “WriteImageFtp_3” usw.). Passen Sie den Vorgang an, indem Sie ihm beispielsweise einen Namen geben, der mit seiner Übertragungsbedingung in Zusammenhang steht.

Geschlossen Übertragungsbedingung

Legt fest, wann die Daten an den FTP-Server gesendet werden sollen. Dies kann beispielsweise dann geschehen, wenn ein bestimmtes Werkzeug ein „Gut“ oder „Schlecht“ ergibt oder ein Eingangssignal empfangen wird. Standardmäßig ist Keine ausgewählt. Dies bedeutet, dass bei ausgewähltem Kontrollkästchen Aktiviert bei jeder Aufnahme eines Bildes die Daten exportiert werden. Sollte das Kontrollkästchen Aktiviert nicht ausgewählt oder das verwiesene Werkzeug deaktiviert sein, wird der Exportvorgang nicht durchgeführt.

Geschlossen Gerät

Gibt den FTP-Server an, der auf der Registerkarte Einstellungen konfiguriert ist und die exportierten Daten empfängt. Standardmäßig ist Gerät 1 ausgewählt.

Geschlossen Dateiformat

Legt das Dateiformat des exportierten Bildes fest: BMP (Windows-Bitmapformat) oder JPG (JPEG-Standardformat). BMP ist standardmäßig ausgewählt.

Geschlossen Bildgröße

Legt die Auflösung des exportierten Bildes fest: Voll, Halb oder Viertel. Standardmäßig ist Voll ausgewählt.

Geschlossen Einschließlich Grafiken

Legt fest, ob eine SVG-Datei erstellt wird, die Overlay-Grafikdaten für unterstützte Positionswerkzeuge und Inspektionswerkzeuge enthält. Zum Anzeigen der SVG-Datei und Bilddatei öffnen Sie die SVG-Datei in einem Webbrowser, der den Dateityp SVG unterstützt (z. B. Microsoft Internet Explorer 9.0). Die SVG-Datei enthält eine interne Verknüpfung zu dem entsprechenden Bild. Wenn der Browser die SVG-Datei öffnet, wird mithilfe der Verknüpfung das aufgenommene Bild gemeinsam mit den Overlay-Grafiken angezeigt.

Hinweis:
  • >Zum Aktivieren markieren Sie im Gruppenfeld rechts das Kontrollkästchen Einschließlich Grafiken. Das Kontrollkästchen Einschließlich Grafiken in der Tabelle ist schreibgeschützt.
  • >Falls aktiviert, verwendet die SVG-Datei den mit dem Parameter Dateiname festgelegten Dateinamen.
  • >Wenn der Parameter „Hostname“ in der Registerkarte „Einstellungen“ auf einen In-Sight-Emulator gesetzt ist, werden die SVG-Dateien im Emulatorverzeichnis ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x) gespeichert und auf der Seite In-Sight-Dateien angezeigt.
  • >Wurde ein Positionswerkzeug und/oder Inspektionswerkzeug durch Ändern von Werkzeugoptionen im Dialogfeld Optionen zur Ergebnisanzeige zum Ausblenden seiner Overlay-Grafiken konfiguriert, werden die SVG-Grafiken nicht ausgegeben. Standardmäßig zeigen alle Werkzeuge ihre Overlay-Grafiken an.
  • >Da die Grafiken von einer Drittanbieteranwendung wie einem Webbrowser gerendert werden, stimmen die Overlay-Grafikdaten nicht exakt Pixel für Pixel überein.
  • >Die In-Sight-Firmware garantiert nicht die Übertragung jedes SVG-Datei-Bilddatei-Paars. Ist das In-Sight-Vision-System überlastet, überspringt es u. U. die Übertragung der SVG-Datei und/oder Bilddatei, um sicherzustellen, dass keine Inspektionen und/oder Bildaufnahmen ausfallen.
Geschlossen Dateinamenvorschau

Zeigt den Namen der exportierten Bilddatei an. Der Standardname lautet Image999. Passen Sie den Dateinamen durch Konfigurieren der folgenden Parameter an: Standarddateiname, Verbindung hinzufügen, Zeitstempel hinzufügen und Zähler hinzufügen.

Hinweis:
  • Definieren Sie mindestens einen Parameter für die Bilddatei. Wenn das Feld Standarddateiname leer bleibt und die Kontrollkästchen Verbindung hinzufügen, Zeitstempel hinzufügen und Zähler hinzufügen deaktiviert sind, schlägt der Export fehl.
  • Die Reihenfolge der Parameter kann nicht geändert werden.
  • Bei aktiviertem Parameter Zähler hinzufügen wird in der Dateinamenvorschau immer der maximale Wert des Zählers angezeigt.
Geschlossen Standarddateiname

Bestimmt den Namen der exportierten Bilddatei. Der Standardname ist Bild. Lange Dateinamen werden unterstützt.

Geschlossen Verbindung hinzufügen

Definiert, ob das ausgewählte Werkzeug verbunden und dem Namen der exportierten Bilddatei hinzugefügt wird. Dieses Kontrollkästchen ist standardmäßig deaktiviert.

Hinweis:
  • Der Exportvorgang schlägt fehl, wenn das ausgewählte Werkzeug mit einer Zeichenfolge verbunden wird, die eines der folgenden unzulässigen Zeichen enthält: <, >, :, ", /, \, |, ? or *.
  • Das Kontrollkästchen Verbindung hinzufügen ist nicht verfügbar, wenn EasyBuilder kein Werkzeug findet, das verbunden werden kann.
  • Wenn Sie das verbundene Werkzeug aus dem Job entfernen, wird das Kontrollkästchen Verbindung hinzufügen automatisch deaktiviert.
  • Ist das Kontrollkästchen Verbindung hinzufügen aktiviert, wählen Sie in der Dropdownliste nicht Nicht definiert aus, da sonst u. U. nicht definierte Ergebnisse auftreten.
Geschlossen Zeitstempel hinzufügen

Definiert, ob dem Namen der exportierten Bilddatei ein Zeitstempel hinzugefügt wird. Dieses Kontrollkästchen ist standardmäßig deaktiviert. Bei aktivierten Kontrollkästchen stehen in der Dropdownliste die folgenden Zeitstempelformate zur Auswahl: MMDDYY, YYYYMMDD_HHMMSS, DDMMYY_HHMMSS, MM-DD-YYYY_HH.MM.SS, HHMMSS, YYMMDD_HHMMSS oder YYDDMM_HHMMSS.

Hinweis: Sie können die Einstellungen für das Datum/die Uhrzeit des In-Sight Vision-Systems im Dialogfeld „Datums-/Zeiteinstellungen“ konfigurieren.
Geschlossen Zähler hinzufügen

Definiert, ob dem Namen der exportierten Bilddatei ein Zähler hinzugefügt wird oder nicht (Standard = aktiviert). Wenn aktiviert, kann der maximale Wert des Zählers festgelegt werden (0 bis 9999999; Standard = 999). Der Zählerwert erhöht sich mit jeder exportierten Bilddatei. Der Zähler wird automatisch zurückgesetzt, wenn der den Maximalwert erreicht. Vorhandene Bilddateien werden mit Dateien mit gleichem Namen überschrieben.

Geschlossen Schaltfläche „Hinzufügen“

Fügt der Liste einen neuen Exportvorgang hinzu.

Geschlossen Schaltfläche „Entfernen“

Entfernt einen Exportvorgang aus der Liste. Sie können jeweils nur einen Exportvorgang entfernen.

Geschlossen Schaltfläche „Alle Zähler zurücksetzten“

Setzt den Wert, der dem Bilddateinamen für jeden Bildexportvorgang in der Liste hinzugefügt wird, auf 000 zurück.

Registerkarte "Einstellungen"

Auf der Registerkarte „Einstellungen“ stehen Parameter für die Definition von zwei Zielgeräten zur Verfügung. Das Zielgerät kann ein In-Sight-Emulator oder ein anderer, im Netzwerk als FTP-Server eingesetzter Host sein.

Geschlossen Hostname

Gibt den Hostnamen (oder die IP-Adresse) des FTP-Servers für das Zielgerät an.

Hinweis:
  • Falls der angegebene Hostname ungültig ist, dauert es bis zu 30 Sekunden, bis das Zeitlimit für die Verbindung abläuft.

  • Verwenden Sie bei der Angabe des Hostnamens oder Benutzernamens vor und nach dem Namen keine Leerzeichen. Steht vor oder nach dem Hostnamen oder Benutzernamen ein Leerzeichen, wird das Bild beim Export nicht auf dem angegebenen Server gespeichert.

  • Sofern Sie über einen anderen PC verfügen, auf dem ein FTP-Server installiert ist, können Sie diesen als Speicherort festlegen. Beachten Sie, dass die Anwendung In-Sight Explorer ein FTP-Server ist. Falls Sie einen FTP-Server eines Drittanbieters verwenden, sollte In-Sight Explorer geschlossen werden. Sofern kein anderer FTP-Server aktiv ist, muss In-Sight Explorer ausgeführt werden. Bei Verwendung eines FTP-Servers eines Drittanbieters muss die IP-Adresse des PCs für den Parameter Hostname verwendet werden.
  • Die Anschlussnummer der FTP-Serververbindung kann geändert werden. Setzen Sie dazu hinter den Hostnamen (oder die IP-Adresse) einen Doppelpunkt (:) und die neue Anschlussnummer. Lautet der aktuelle Hostname beispielsweise FERTIGUNG1, und Sie möchten die Standardanschlussnummer (21) in Anschluss 34 ändern, dann setzen Sie den Parameter Hostname auf FERTIGUNG1:34.
Geschlossen Benutzername

Gibt den gültigen Benutzernamen für den FTP-Server des Zielgeräts an (maximal 255 Zeichen). Dieser Name muss nicht auf dem In-Sight Vision-System existieren, das die Bilddatei oder -daten exportiert.

Geschlossen Kennwort

Definiert das gültige Kennwort für den FTP-Server des Zielgeräts. Beim Kennwort muss die Groß-/Kleinschreibung beachtet werden und es darf nicht länger als 20 Zeichen sein.

Hinweis:
  • Aus Sicherheitsgründen wird das eingegebene Kennwort mit Sternchen (*) dargestellt.
  • Das Kennwort wird in verschlüsselter Form in der Jobdatei gespeichert.
Geschlossen Verbindungstyp

Definiert die Art der Bildexportverbindung: Standard-FTP (Standard), Sicheres FTP oder Mitsubishi GOT. Sicheres FTP bietet ein sicheres Übertragungsprotokoll für die Verwendung mit SFTP-Anwendungen, während Mitsubishi GOT die Anzeige von Bildern auf einem Mitsubishi GOT-Terminal unterstützt.

Hinweis: Falls der Parameter Verbindungstyp auf Mitsubishi GOT festgelegt ist, erzielen Sie die besten Anzeigeergebnisse, wenn Sie den Parameter Dateiformat auf der Registerkarte Bilder auf JPG einstellen.
Geschlossen Schaltfläche „FTP-Einstellungen“

Öffnet das Dialogfeld FTP-Einstellungen.

Hinweis: Normalerweise müssen die Standardeinstellungen für dedizierte lokale In-Sight-Netzwerke, bei denen alle FTP-Verbindungen zwischen In-Sight Vision-Systemen stattfinden, nicht geändert werden. Sollten jedoch FTP-Verbindungen zwischen In-Sight Vision-Systemen und anderen Netzwerkservern oder zwischen Vision-Systemen in anderen Netzwerken erforderlich sein, müssen Sie die FTP-Einstellungen möglicherweise ändern.
Geschlossen Letzter Netzwerkfehler

Zeigt die Ursache eines Fehlers an, sofern beim Exportvorgang einer aufgetreten ist. Damit dieses Feld aktualisiert wird, muss ein auf der Registerkarte „Datei“ unter „Übertragungsbedingung“ angegebenes Ereignis aufgetreten sein (z. B. das Triggern eines Bildes), oder Sie müssen das In-Sight Vision-System online geschaltet haben.


Exportieren einer Datendatei oder Anhängen einer Datenzeichenfolge an eine Datei über FTP

Sie können Ihr In-Sight Vision-System so konfigurieren, dass eine Datendatei exportiert oder einer Datei auf einem FTP-Server im Netzwerk eine Datenzeichenfolge angehängt wird. Mit dieser Funktion können Sie die in einer Datei angezeigten Datenergebnisse protokollieren.

So konfigurieren Sie eine FTP-Verbindung:

  1. Wählen Sie im Gruppenfeld Kommunikation die Option FTP aus.
  2. Wählen Sie die Registerkarte Datei aus.

  3. Klicken Sie auf die Schaltfläche Hinzufügen, um einen Eintrag hinzuzufügen und die Exportparameter zu konfigurieren.

    Hinweis: Sie können einem Job mehrere Dateiexportvorgänge hinzufügen.
  4. Wählen Sie die Registerkarte Einstellungen aus, und konfigurieren Sie die Einstellungen für den FTP-Server.
  5. Schalten Sie das In-Sight Vision-System online. Das Vision-System muss für die Ausführung online sein. Andernfalls werden keine Daten exportiert.
  6. Triggern Sie das Vision-System. Für jeden Trigger wird eine Datendatei exportiert oder einer Datei eine Datenzeichenfolge angehängt und auf dem auf der Registerkarte Einstellungen im Vision-System angegebenen FTP-Server gespeichert.
Hinweis:
  • Wenn Übertragungsbedingung auf Keine (Standard) gesetzt ist, wird bei jeder neuen Bildaufnahme eine Datendatei exportiert oder einer Datei eine Datenzeichenfolge angehängt. Wenn Übertragungsbedingung auf eine andere Option als Keine (Standard) gesetzt ist, wird einer Datei bei jedem Auftreten des angegebenen Ereignisses eine Datenzeichenfolge angehängt. Beispiel: Wenn Übertragungsbedingung auf Job.Schlecht gesetzt ist, wird bei jedem fehlgeschlagenen Job eine Datendatei exportiert und einer Datei eine Datenzeichenfolge angehängt und auf dem FTP-Server gespeichert.
  • Wenn Sie den In-Sight-Emulator als FTP-Server verwenden, werden Dateien standardmäßig in den Emulatorordner ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x) geschrieben. Zusätzlich zu diesem Verzeichnis können die Dateien in ein benutzerdefiniertes Verzeichnis geschrieben werden (Autorisiertes FTP-Verzeichnis). Weitere Informationen zum autorisierten FTP-Verzeichnis finden Sie unter Dialogfeld „Optionen“ (Emulationsbereich).

Datei (Registerkarte)

Enthält Parameter, über die Sie die exportierten Daten, deren Format sowie den Zeitpunkt und das Ziel des Datenexports definieren können.

Geschlossen Kontrollkästchen „Aktiviert“

(Standardmäßig ausgewählt) Bestimmt, ob der Exportvorgang aktiv ist und ob er als EasyView-Element (beispielsweise WriteLocal_1.Werkzeug_aktiviert) angezeigt wird. Diese Elemente können auf der VisionView-Benutzeroberfläche dargestellt und vom Bediener bearbeitet werden.

Hinweis: Zum Aktivieren markieren Sie in der Tabelle das Kontrollkästchen Aktiviert. Dies ist der einzige konfigurierbare Parameter in der Tabelle.
Geschlossen Name

Gibt den Namen des Datenexportvorgangs an, der zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet werden kann. Der Standardname lautet „WriteFtp_1“, sofern es sich um den ersten Bildexportvorgang handelt, der dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. “WriteFtp_2”, “WriteFtp_3” usw.). Passen Sie den Vorgang an, indem Sie ihm beispielsweise einen Namen geben, der mit seiner Übertragungsbedingung in Zusammenhang steht.

Geschlossen Übertragungsbedingung

Legt fest, wann die Daten an den FTP-Server gesendet werden sollen. Dies kann beispielsweise dann geschehen, wenn ein bestimmtes Werkzeug ein „Gut“ oder „Schlecht“ ergibt oder ein Eingangssignal empfangen wird. Standardmäßig ist Keine ausgewählt. Dies bedeutet, dass bei ausgewähltem Kontrollkästchen Aktiviert bei jeder Aufnahme eines Bildes die Daten exportiert werden. Sollte das Kontrollkästchen Aktiviert nicht ausgewählt oder das verwiesene Werkzeug deaktiviert sein, wird der Exportvorgang nicht durchgeführt.

Geschlossen Gerät

Gibt den FTP-Server an, der auf der Registerkarte Einstellungen konfiguriert ist und die exportierten Daten empfängt. Standardmäßig ist Gerät 1 ausgewählt.

Geschlossen Dateityp

Legt das Dateiformat der Exportdatei fest: Text, HTML (Standard), XML oder CSV.

Geschlossen Speicherungsart (Überschreiben oder Anhängen)

Definiert, wie Daten in die Datei geschrieben werden.

  • Überschreiben: Überschreibt die in der Datei vorhandenen Daten.
  • Anhängen (Standard): Hängt die Datenzeichenfolge am Ende der Datei an.
Geschlossen Schaltfläche „Dateiinhalt/Format der Zeichenkette“

Hiermit legen Sie im Dialogfeld „FormatString“ fest, welche Daten in die Datei geschrieben werden.

Geschlossen Dateinamenvorschau

Zeigt den Namen der exportierten Bilddatei an. Der Standardname lautet Datei. Sie können den Dateinamen durch Konfigurieren der folgenden Parameter anpassen: Standarddateiname, Verbindung hinzufügen und Zeitstempel hinzufügen.

Hinweis:
  • Definieren Sie mindestens einen Parameter für die Datei. Wenn das Feld Standarddateiname leer bleibt und die Kontrollkästchen Verbindung hinzufügen und Zeitstempel hinzufügen deaktiviert sind, schlägt der Export fehl.
  • Die Reihenfolge der Parameter kann nicht geändert werden.
Geschlossen Standarddateiname

Bestimmt den Namen der exportierten Datei. Der Standardname ist Datei. Lange Dateinamen werden unterstützt.

Geschlossen Verbindung hinzufügen

Definiert, ob das ausgewählte Werkzeug verbunden und dem Namen der exportierten Bilddatei hinzugefügt wird. Dieses Kontrollkästchen ist standardmäßig deaktiviert.

Hinweis:
  • Der Exportvorgang schlägt fehl, wenn das ausgewählte Werkzeug mit einer Zeichenfolge verbunden wird, die eines der folgenden unzulässigen Zeichen enthält: <, >, :, ", /, \, |, ? or *.
  • Das Kontrollkästchen Verbindung hinzufügen ist nicht verfügbar, wenn EasyBuilder kein Werkzeug findet, das verbunden werden kann.
  • Wenn Sie das verbundene Werkzeug aus dem Job entfernen, wird das Kontrollkästchen Verbindung hinzufügen automatisch deaktiviert.
  • Ist das Kontrollkästchen Verbindung hinzufügen aktiviert, wählen Sie in der Dropdownliste nicht Nicht definiert aus, da sonst u. U. nicht definierte Ergebnisse auftreten.
Geschlossen Zeitstempel hinzufügen

Definiert, ob dem Namen der exportierten Bilddatei ein Zeitstempel hinzugefügt wird. Dieses Kontrollkästchen ist standardmäßig deaktiviert. Bei aktivierten Kontrollkästchen stehen in der Dropdownliste die folgenden Zeitstempelformate zur Auswahl: MMDDYY, YYYYMMDD_HHMMSS, DDMMYY_HHMMSS, MM-DD-YYYY_HH.MM.SS, HHMMSS, YYMMDD_HHMMSS oder YYDDMM_HHMMSS.

Hinweis: Sie können die Einstellungen für das Datum/die Uhrzeit des In-Sight Vision-Systems im Dialogfeld „Datums-/Zeiteinstellungen“ konfigurieren.
Geschlossen Schaltfläche „Hinzufügen“

Fügt der Liste einen neuen Exportvorgang hinzu.

Geschlossen Schaltfläche „Entfernen“

Entfernt einen Exportvorgang aus der Liste. Sie können jeweils nur einen Exportvorgang entfernen.

Registerkarte "Einstellungen"

Auf der Registerkarte „Einstellungen“ stehen Parameter für die Definition von zwei Zielgeräten zur Verfügung. Das Zielgerät kann ein In-Sight-Emulator oder ein anderer, im Netzwerk als FTP-Server eingesetzter Host sein.

Geschlossen Hostname

Gibt den Hostnamen (oder die IP-Adresse) des FTP-Servers für das Zielgerät an.

Hinweis:
  • Falls der angegebene Hostname ungültig ist, dauert es bis zu 30 Sekunden, bis das Zeitlimit für die Verbindung abläuft.

  • Verwenden Sie bei der Angabe des Hostnamens oder Benutzernamens vor und nach dem Namen keine Leerzeichen. Steht vor oder nach dem Hostnamen oder Benutzernamen ein Leerzeichen, wird das Bild beim Export nicht auf dem angegebenen Server gespeichert.

  • Sofern Sie über einen anderen PC verfügen, auf dem ein FTP-Server installiert ist, können Sie diesen als Speicherort festlegen. Beachten Sie, dass die Anwendung In-Sight Explorer ein FTP-Server ist. Falls Sie einen FTP-Server eines Drittanbieters verwenden, sollte In-Sight Explorer geschlossen werden. Sofern kein anderer FTP-Server aktiv ist, muss In-Sight Explorer ausgeführt werden. Bei Verwendung eines FTP-Servers eines Drittanbieters muss die IP-Adresse des PCs für den Parameter Hostname verwendet werden.
  • Die Anschlussnummer der FTP-Serververbindung kann geändert werden. Setzen Sie dazu hinter den Hostnamen (oder die IP-Adresse) einen Doppelpunkt (:) und die neue Anschlussnummer. Lautet der aktuelle Hostname beispielsweise FERTIGUNG1, und Sie möchten die Standardanschlussnummer (21) in Anschluss 34 ändern, dann setzen Sie den Parameter Hostname auf FERTIGUNG1:34.
Geschlossen Benutzername

Gibt den gültigen Benutzernamen für den FTP-Server des Zielgeräts an (maximal 255 Zeichen). Dieser Name muss nicht auf dem In-Sight Vision-System existieren, das die Bilddatei oder -daten exportiert.

Geschlossen Kennwort

Definiert das gültige Kennwort für den FTP-Server des Zielgeräts. Beim Kennwort muss die Groß-/Kleinschreibung beachtet werden und es darf nicht länger als 20 Zeichen sein.

Hinweis:
  • Aus Sicherheitsgründen wird das eingegebene Kennwort mit Sternchen (*) dargestellt.
  • Das Kennwort wird in verschlüsselter Form in der Jobdatei gespeichert.
Geschlossen Verbindungstyp

Definiert die Art der Bildexportverbindung: Standard-FTP (Standard), Sicheres FTP oder Mitsubishi GOT. Sicheres FTP bietet ein sicheres Übertragungsprotokoll für die Verwendung mit SFTP-Anwendungen, während Mitsubishi GOT die Anzeige von Bildern auf einem Mitsubishi GOT-Terminal unterstützt.

Hinweis: Falls der Parameter Verbindungstyp auf Mitsubishi GOT festgelegt ist, erzielen Sie die besten Anzeigeergebnisse, wenn Sie den Parameter Dateiformat auf der Registerkarte Bilder auf JPG einstellen.
Geschlossen Schaltfläche „FTP-Einstellungen“

Öffnet das Dialogfeld FTP-Einstellungen.

Hinweis: Normalerweise müssen die Standardeinstellungen für dedizierte lokale In-Sight-Netzwerke, bei denen alle FTP-Verbindungen zwischen In-Sight Vision-Systemen stattfinden, nicht geändert werden. Sollten jedoch FTP-Verbindungen zwischen In-Sight Vision-Systemen und anderen Netzwerkservern oder zwischen Vision-Systemen in anderen Netzwerken erforderlich sein, müssen Sie die FTP-Einstellungen möglicherweise ändern.
Geschlossen Letzter Netzwerkfehler

Zeigt die Ursache eines Fehlers an, sofern beim Exportvorgang einer aufgetreten ist. Damit dieses Feld aktualisiert wird, muss ein auf der Registerkarte „Datei“ unter „Übertragungsbedingung“ angegebenes Ereignis aufgetreten sein (z. B. das Triggern eines Bildes), oder Sie müssen das In-Sight Vision-System online geschaltet haben.


Exportieren von Bildern an SD-Karte

Sie können das In-Sight Vision-System so konfigurieren, dass es Bilder an die auf dem In-Sight Vision-System installierte SD-Karte exportiert. So können Sie aufgenommene Bilder (auf Basis eines Werkzeugs oder des Gut/Schlecht-Status eines Jobs) zu Archivierungszwecken speichern. Diese Bilder können dann überprüft werden, um mögliche Fertigungsprobleme zu diagnostizieren.

Hinweis: Diese Funktion wird nur in In-Sight Vision-Systemen unterstützt, auf denen die SD-Karte installiert ist.

So senden Sie Bilder an die SD-Karte:

  1. Wählen Sie im Gruppenfeld Kommunikation die Option SD-Karte aus.
  2. Wählen Sie die Registerkarte Bild aus.

  3. Klicken Sie auf die Schaltfläche Hinzufügen, um einen Eintrag hinzuzufügen und die Parameter für den Bildexport zu konfigurieren.

    Hinweis: Sie können einem Job mehrere Bildexportvorgänge hinzufügen.
  4. Schalten Sie das In-Sight Vision-System online. Das Vision-System muss für die Ausführung online sein. Andernfalls werden keine Bilder exportiert.

  5. Triggern Sie das Vision-System für die Aufnahme von Bildern. Für jedes aufgenommene Bild wird eine Bilddatei (BMP oder JPG, je nach Einstellung des Parameters Dateiformat) exportiert und auf der im Vision-System installierten SD-Karte gespeichert.

    Hinweis: Wenn Übertragungsbedingung auf Keine (Standard) gesetzt ist, wird bei jeder neuen Bildaufnahme eine Bilddatei exportiert. Wenn Übertragungsbedingung auf eine andere Option als Keine (Standard) gesetzt ist, wird bei jedem Auftreten des angegebenen Ereignisses eine Bilddatei exportiert. Beispiel: Wenn Übertragungsbedingung auf Job.Schlecht gesetzt ist, wird bei jedem fehlgeschlagenen Job eine Bilddatei exportiert und auf der SD-Karte gespeichert.

Steuerelemente

Geschlossen Kontrollkästchen „Aktiviert“

(Standardmäßig ausgewählt) Bestimmt, ob der Bildexportvorgang aktiv ist und ob er als EasyView-Element (beispielsweise WriteImageLocal_1.Werkzeug_aktiviert) angezeigt wird. Diese Elemente können auf der VisionView-Benutzeroberfläche dargestellt und vom Bediener bearbeitet werden.

Hinweis: Zum Aktivieren markieren Sie in der Tabelle das Kontrollkästchen Aktiviert. Dies ist der einzige konfigurierbare Parameter in der Tabelle.
Geschlossen Name

Gibt den Namen des Bildexportvorgangs an, der zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet werden kann. Der Standardname lautet „WriteImageLocal_1“, sofern es sich um den ersten Bildexportvorgang handelt, der dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. “WriteImageLocal_2”, “WriteImageLocal_3” usw.). Passen Sie den Vorgang an, indem Sie ihm beispielsweise einen Namen geben, der mit seiner Übertragungsbedingung in Zusammenhang steht.

Geschlossen Übertragungsbedingung

Legt fest, wann das Bild an die SD-Karte gesendet werden soll. Dies kann beispielsweise dann geschehen, wenn ein bestimmtes Werkzeug „Gut“ oder „Schlecht“ ergibt oder ein Eingangssignal empfangen wird. Standardmäßig ist Keine ausgewählt. Dies bedeutet, dass bei ausgewähltem Kontrollkästchen Aktiviert bei jeder Aufnahme eines Bildes ein Bild exportiert wird. Sollte das Kontrollkästchen Aktiviert nicht ausgewählt oder das verwiesene Werkzeug deaktiviert sein, wird der Bildexportvorgang nicht durchgeführt.

Hinweis: Falls die Übertragungsbedingung eines bestimmten Bildexportvorgangs oft auftritt (beispielsweise bei jeder Bildaufnahme), kann sich die Bildwarteschlange des In-Sight Vision-Systems füllen, sodass der Export weiterer Bildexportvorgänge verhindert wird. Dies hat zur Folge, dass ein Teil der Bilder nicht übertragen wird.
Geschlossen Dateiformat

Legt das Dateiformat des exportierten Bildes fest: BMP (Windows-Bitmapformat) oder JPG (JPEG-Standardformat). BMP ist standardmäßig ausgewählt.

Geschlossen Bildgröße

Legt die Auflösung des exportierten Bildes fest: Voll, Halb oder Viertel. Standardmäßig ist Voll ausgewählt.

Geschlossen Einschließlich Grafiken

Legt fest, ob eine SVG-Datei erstellt wird, die Overlay-Grafikdaten für unterstützte Positionswerkzeuge und Inspektionswerkzeuge enthält. Zum Anzeigen der SVG-Datei und Bilddatei öffnen Sie die SVG-Datei in einem Webbrowser, der den Dateityp SVG unterstützt (z. B. Microsoft Internet Explorer 9.0). Die SVG-Datei enthält eine interne Verknüpfung zu dem entsprechenden Bild. Wenn der Browser die SVG-Datei öffnet, wird mithilfe der Verknüpfung das aufgenommene Bild gemeinsam mit den Overlay-Grafiken angezeigt.

Hinweis:
  • >Zum Aktivieren markieren Sie im Gruppenfeld rechts das Kontrollkästchen Einschließlich Grafiken. Das Kontrollkästchen Einschließlich Grafiken in der Tabelle ist schreibgeschützt.
  • >Falls aktiviert, verwendet die SVG-Datei den mit dem Parameter Dateiname festgelegten Dateinamen.
  • >Wenn der Parameter „Hostname“ in der Registerkarte „Einstellungen“ auf einen In-Sight-Emulator gesetzt ist, werden die SVG-Dateien im Emulatorverzeichnis ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x) gespeichert und auf der Seite In-Sight-Dateien angezeigt.
  • >Wurde ein Positionswerkzeug und/oder Inspektionswerkzeug durch Ändern von Werkzeugoptionen im Dialogfeld Optionen zur Ergebnisanzeige zum Ausblenden seiner Overlay-Grafiken konfiguriert, werden die SVG-Grafiken nicht ausgegeben. Standardmäßig zeigen alle Werkzeuge ihre Overlay-Grafiken an.
  • >Da die Grafiken von einer Drittanbieteranwendung wie einem Webbrowser gerendert werden, stimmen die Overlay-Grafikdaten nicht exakt Pixel für Pixel überein.
  • >Die In-Sight-Firmware garantiert nicht die Übertragung jedes SVG-Datei-Bilddatei-Paars. Ist das In-Sight-Vision-System überlastet, überspringt es u. U. die Übertragung der SVG-Datei und/oder Bilddatei, um sicherzustellen, dass keine Inspektionen und/oder Bildaufnahmen ausfallen.
Geschlossen Dateinamenvorschau

Zeigt den Namen der exportierten Bilddatei an. Der Standardname lautet Image999. Passen Sie den Dateinamen durch Konfigurieren der folgenden Parameter an: Standarddateiname, Verbindung hinzufügen, Zeitstempel hinzufügen und Zähler hinzufügen.

Hinweis:
  • Definieren Sie mindestens einen Parameter für die Bilddatei. Wenn das Feld Standarddateiname leer bleibt und die Kontrollkästchen Verbindung hinzufügen, Zeitstempel hinzufügen und Zähler hinzufügen deaktiviert sind, schlägt der Export fehl.
  • Die Reihenfolge der Parameter kann nicht geändert werden.
  • Bei aktiviertem Parameter Zähler hinzufügen wird in der Dateinamenvorschau immer der maximale Wert des Zählers angezeigt.
Geschlossen Standarddateiname

Bestimmt den Namen der exportierten Bilddatei. Der Standardname ist Bild. Lange Dateinamen werden unterstützt.

Geschlossen Verbindung hinzufügen

Definiert, ob das ausgewählte Werkzeug verbunden und dem Namen der exportierten Bilddatei hinzugefügt wird. Dieses Kontrollkästchen ist standardmäßig deaktiviert.

Hinweis:
  • Der Exportvorgang schlägt fehl, wenn das ausgewählte Werkzeug mit einer Zeichenfolge verbunden wird, die eines der folgenden unzulässigen Zeichen enthält: <, >, :, ", /, \, |, ? or *.
  • Das Kontrollkästchen Verbindung hinzufügen ist nicht verfügbar, wenn EasyBuilder kein Werkzeug findet, das verbunden werden kann.
  • Wenn Sie das verbundene Werkzeug aus dem Job entfernen, wird das Kontrollkästchen Verbindung hinzufügen automatisch deaktiviert.
  • Ist das Kontrollkästchen Verbindung hinzufügen aktiviert, wählen Sie in der Dropdownliste nicht Nicht definiert aus, da sonst u. U. nicht definierte Ergebnisse auftreten.
Geschlossen Zeitstempel hinzufügen

Definiert, ob dem Namen der exportierten Bilddatei ein Zeitstempel hinzugefügt wird. Dieses Kontrollkästchen ist standardmäßig deaktiviert. Bei aktivierten Kontrollkästchen stehen in der Dropdownliste die folgenden Zeitstempelformate zur Auswahl: MMDDYY, YYYYMMDD_HHMMSS, DDMMYY_HHMMSS, MM-DD-YYYY_HH.MM.SS, HHMMSS, YYMMDD_HHMMSS oder YYDDMM_HHMMSS.

Hinweis: Sie können die Einstellungen für das Datum/die Uhrzeit des In-Sight Vision-Systems im Dialogfeld „Datums-/Zeiteinstellungen“ konfigurieren.
Geschlossen Zähler hinzufügen

Definiert, ob dem Namen der exportierten Bilddatei ein Zähler hinzugefügt wird oder nicht (Standard = aktiviert). Wenn aktiviert, kann der maximale Wert des Zählers festgelegt werden (0 bis 9999999; Standard = 999). Der Zählerwert erhöht sich mit jeder exportierten Bilddatei. Der Zähler wird automatisch zurückgesetzt, wenn der den Maximalwert erreicht. Vorhandene Bilddateien werden mit Dateien mit gleichem Namen überschrieben.

Geschlossen Schaltfläche „Hinzufügen“

Fügt der Liste einen neuen Exportvorgang hinzu.

Geschlossen Schaltfläche „Entfernen“

Entfernt einen Exportvorgang aus der Liste. Sie können jeweils nur einen Exportvorgang entfernen.

Geschlossen Schaltfläche „Alle Zähler zurücksetzten“

Setzt den Wert, der dem Bilddateinamen für jeden Bildexportvorgang in der Liste hinzugefügt wird, auf 000 zurück.


Exportieren einer Datendatei oder Anhängen einer Datenzeichenfolge an eine Datei auf einer SD-Karte

Sie können Ihr In-Sight Vision-System so konfigurieren, dass eine Datendatei exportiert oder einer Datei auf einer SD-Karte eine Datenzeichenfolge angehängt wird. Mit dieser Funktion können Sie die in einer Datei angezeigten Datenergebnisse protokollieren.

Hinweis: Diese Funktion wird nur in In-Sight Vision-Systemen unterstützt, auf denen die SD-Karte installiert ist.

So exportieren Sie Daten oder hängen eine Datenzeichenfolge an eine Datei auf einer SD-Karte an:

  1. Wählen Sie im Gruppenfeld Kommunikation die Option SD-Karte aus.
  2. Wählen Sie die Registerkarte Datei aus.

  3. Klicken Sie auf die Schaltfläche Hinzufügen, um einen Eintrag hinzuzufügen und die Parameter auf der Registerkarte „Datei“ zu konfigurieren.

    Hinweis: Sie können einem Job mehrere Dateiexportvorgänge hinzufügen.
  4. Schalten Sie das In-Sight Vision-System online. Das Vision-System muss für die Ausführung online sein. Andernfalls werden keine Daten exportiert.

  5. Triggern Sie das Vision-System. Für jeden Trigger wird eine Datendatei exportiert oder einer Datei eine Datenzeichenfolge angehängt und auf der im Vision-System installierten SD-Karte gespeichert.

    Hinweis: Wenn Übertragungsbedingung auf Keine (Standard) gesetzt ist, wird bei jeder neuen Bildaufnahme eine Datendatei exportiert oder einer Datei eine Datenzeichenfolge angehängt. Wenn Übertragungsbedingung auf eine andere Option als Keine (Standard) gesetzt ist, wird einer Datei bei jedem Auftreten des angegebenen Ereignisses eine Datenzeichenfolge angehängt. Beispiel: Wenn Übertragungsbedingung auf Job.Schlecht gesetzt ist, wird bei jedem fehlgeschlagenen Job eine Datendatei exportiert und einer Datei eine Datenzeichenfolge angehängt und auf der SD-Karte gespeichert.

Steuerelemente

Geschlossen Kontrollkästchen „Aktiviert“

(Standardmäßig ausgewählt) Bestimmt, ob der Exportvorgang aktiv ist und ob er als EasyView-Element (beispielsweise WriteLocal_1.Werkzeug_aktiviert) angezeigt wird. Diese Elemente können auf der VisionView-Benutzeroberfläche dargestellt und vom Bediener bearbeitet werden.

Hinweis: Zum Aktivieren markieren Sie in der Tabelle das Kontrollkästchen Aktiviert. Dies ist der einzige konfigurierbare Parameter in der Tabelle.
Geschlossen Name

Gibt den Namen des Datenexportvorgangs an, der zur Konfiguration der Ergebnisse (Eingänge/Ausgänge und Kommunikation) verwendet werden kann. Der Standardname lautet „WriteLocal_1“, sofern es sich um den ersten Bildexportvorgang handelt, der dem Job hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. “WriteLocal_2”, “WriteLocal_3” usw.). Passen Sie den Vorgang an, indem Sie ihm beispielsweise einen Namen geben, der mit seiner Übertragungsbedingung in Zusammenhang steht.

Geschlossen Übertragungsbedingung

Legt fest, wann die Daten an die SD-Karte gesendet werden sollen. Dies kann beispielsweise dann geschehen, wenn ein bestimmtes Werkzeug „Gut“ oder „Schlecht“ ergibt oder ein Eingangssignal empfangen wird. Standardmäßig ist Keine ausgewählt. Dies bedeutet, dass bei ausgewähltem Kontrollkästchen Aktiviert bei jeder Aufnahme eines Bildes die Daten exportiert werden. Sollte das Kontrollkästchen Aktiviert nicht ausgewählt oder das verwiesene Werkzeug deaktiviert sein, wird der Exportvorgang nicht durchgeführt.

Geschlossen Dateityp

Legt das Dateiformat der Exportdatei fest: Text, HTML (Standard), XML oder CSV.

Geschlossen Speicherungsart (Überschreiben oder Anhängen)

Definiert, wie Daten in die Datei geschrieben werden.

  • Überschreiben: Überschreibt die in der Datei vorhandenen Daten.
  • Anhängen (Standard): Hängt die Datenzeichenfolge am Ende der Datei an.
Geschlossen Schaltfläche „Dateiinhalt/Format der Zeichenkette“

Hiermit legen Sie im Dialogfeld „FormatString“ fest, welche Daten in die Datei geschrieben werden.

Geschlossen Dateinamenvorschau

Zeigt den Namen der exportierten Bilddatei an. Der Standardname lautet Datei. Sie können den Dateinamen durch Konfigurieren der folgenden Parameter anpassen: Standarddateiname, Verbindung hinzufügen und Zeitstempel hinzufügen.

Hinweis:
  • Definieren Sie mindestens einen Parameter für die Datei. Wenn das Feld Standarddateiname leer bleibt und die Kontrollkästchen Verbindung hinzufügen und Zeitstempel hinzufügen deaktiviert sind, schlägt der Export fehl.
  • Die Reihenfolge der Parameter kann nicht geändert werden.
Geschlossen Standarddateiname

Bestimmt den Namen der exportierten Datei. Der Standardname ist Datei. Lange Dateinamen werden unterstützt.

Geschlossen Verbindung hinzufügen

Definiert, ob das ausgewählte Werkzeug verbunden und dem Namen der exportierten Bilddatei hinzugefügt wird. Dieses Kontrollkästchen ist standardmäßig deaktiviert.

Hinweis:
  • Der Exportvorgang schlägt fehl, wenn das ausgewählte Werkzeug mit einer Zeichenfolge verbunden wird, die eines der folgenden unzulässigen Zeichen enthält: <, >, :, ", /, \, |, ? or *.
  • Das Kontrollkästchen Verbindung hinzufügen ist nicht verfügbar, wenn EasyBuilder kein Werkzeug findet, das verbunden werden kann.
  • Wenn Sie das verbundene Werkzeug aus dem Job entfernen, wird das Kontrollkästchen Verbindung hinzufügen automatisch deaktiviert.
  • Ist das Kontrollkästchen Verbindung hinzufügen aktiviert, wählen Sie in der Dropdownliste nicht Nicht definiert aus, da sonst u. U. nicht definierte Ergebnisse auftreten.
Geschlossen Zeitstempel hinzufügen

Definiert, ob dem Namen der exportierten Bilddatei ein Zeitstempel hinzugefügt wird. Dieses Kontrollkästchen ist standardmäßig deaktiviert. Bei aktivierten Kontrollkästchen stehen in der Dropdownliste die folgenden Zeitstempelformate zur Auswahl: MMDDYY, YYYYMMDD_HHMMSS, DDMMYY_HHMMSS, MM-DD-YYYY_HH.MM.SS, HHMMSS, YYMMDD_HHMMSS oder YYDDMM_HHMMSS.

Hinweis: Sie können die Einstellungen für das Datum/die Uhrzeit des In-Sight Vision-Systems im Dialogfeld „Datums-/Zeiteinstellungen“ konfigurieren.
Geschlossen Schaltfläche „Hinzufügen“

Fügt der Liste einen neuen Exportvorgang hinzu.

Geschlossen Schaltfläche „Entfernen“

Entfernt einen Exportvorgang aus der Liste. Sie können jeweils nur einen Exportvorgang entfernen.


Geräte-Setup

Bevor Daten von anderen Geräten oder auf andere Geräte (z. B. Roboter oder programmierbare Steuerung/Bewegungssteuerung) übertragen werden können, müssen zuerst die Einstellungen für das Netzwerk und die serielle Kommunikation des In-Sight-Sensors definiert werden.

  • Kommunikation mit einer programmierbaren Steuerung/Bewegungssteuerung
  • Kommunikation mit einem Roboter
  • Kommunikation mit Mitsubishi-Geräten
  • Kommunikation über ModBus/TCP
  • Kommunikation über TCP/IP
  • Kommunikation über UDP
  • Kommunikation über POWERLINK
  • Eingeben von Daten für Identifizierungswerkzeuge
  • Formatieren von Ausgabedaten
Hinweis: Wenn die Ausgabe eines Positions- oder Inspektionswerkzeugs ungültig ist, wird Standardwert für das Werkzeug im Ausgabedatenpuffer platziert. Wenn beispielsweise ein Positionswerkzeug Muster kein übereinstimmendes Muster findet, sind die X- und Y-Daten für das Werkzeug ungültig und werden standardmäßig auf den Wert 0 gesetzt, der anschließend ausgegeben wird. Beim Konfigurieren eines Geräts zum Senden von Ausgabedaten wird empfohlen, neben dem Senden der Ergebnisse eines Werkzeugs auch den Bestanden-/Fehlerstatus des Werkzeugs zu senden, um so die Gültigkeit der Daten des Werkzeugs zu gewährleisten. Zum Ändern des Standardwerts im Ausgabepuffer bei einem ungültigen Ergebnis eines Werkzeugs senden Sie die folgenden In-Sight Native Mode-Befehle: Für Daten: EV SetSystemConfig(„FormatOutputBufferErrData“,-1111), wo „-1111“ einen bekannten Fehler darstellt. Für Ausgabezeichenfolgen: EV SetSystemConfig(„FormatOutputBufferErrString“,„Error“), wob „Error“ die Fehlerzeichenfolge darstellt.

Unterstützte Protokolle

Es können bis zu zwei Protokolle zu einem Job hinzugefügt werden. Wenn Sie zwei Protokolle hinzufügen, können Sie ein „primäres“ und ein „sekundäres“ Protokoll hinzufügen. Beispiel: Klicken Sie nach dem Hinzufügen des SLMP-Scanner-Protokolls (primär) erneut auf die Schaltfläche Gerät hinzufügen, und fügen Sie das TCP/IP Protokoll (sekundär) hinzu.

Hinweis: Sie können nicht zwei „primäre“ oder zwei „sekundäre“ Protokolle zu einem Job hinzufügen.

In-Sight-Firmwareversion 4.x.x

 | Primär oder Sekundär | Micro 1000-Serie | 5000-Serie (ausgenommen 5705 & 5705C) | 70xx-74xx-Serie
CC-Link | Primär | X | X | X
Ethernet Native | Primär | X | X | X
Ethernet Native Roboter | Primär | X | X | X
Ethernet Native-Zeichenfolge | Primär | X | X | X
Ethernet/IP | Primär | X | X | X
Modbus-TCP-Server | Primär | X | X | X
POWERLINK | Primär |  |  | X
PROFINET | Primär | X | X | X
Kuka (seriell) | Primär | X | X | X
Motoman (seriell) | Primär | X | X | X
Native (seriell) | Primär | X | X | X
Serieller Native Roboter | Primär | X | X | X
Serielle Native-Zeichenfolge | Primär | X | X | X
Text (seriell) | Primär | X | X | X
SLMP | Primär | X | X | X
SLMP-Scanner | Primär | X | X | X
TCP/IP | Sekundär | X | X | X
UDP | Sekundär | X | X | X

In-Sight Explorer 5.x.x.

 | Primär oder Sekundär | 2000-Serie | 5705 und 5705C | 7000 Gen2-Serie | 8000-Serie | 9000-Serie
CC-Link IE Field Basic | Primär | X | X | X | X | X
Ethernet Native | Primär |  | X | X | X | X
Ethernet Native Roboter | Primär |  | X | X | X | X
Ethernet Native-Zeichenfolge | Primär |  | X | X | X | X
Ethernet/IP | Primär | X | X | X | X | X
Modbus-TCP-Server | Primär | X | X | X | X | X
PROFINET | Primär | X | X | X | X | X
Kuka (seriell) | Primär |  | X | X | X | X
Motoman (seriell) | Primär |  | X | X | X | X
Native (seriell) | Primär | X (Basic) | X | X | X | X
Serieller Native Roboter | Primär |  | X | X | X | X
Serielle Native-Zeichenfolge | Primär |  | X | X | X | X
Text (seriell) | Primär | X | X | X | X | X
SLMP | Primär | X | X | X | X | X
SLMP-Scanner | Primär | X | X | X | X | X
TCP/IP | Sekundär | X | X | X | X | X
UDP | Sekundär | X | X | X | X | X

Kommunikation mit einer SPS

Kommunikation mit einem Roboter

Kommunikation mit Mitsubishi-Geräten

Kommunikation über ModBus/TCP

Kommunikation über TCP/IP

Kommunikation über UDP

Kommunikation über POWERLINK

Eingeben von Daten für Identifizierungswerkzeuge

Formatieren von Ausgabezeichenfolgen


Kommunikation mit einer programmierbaren Steuerung/Bewegungssteuerung

Führen Sie zur Kommunikation mit einer SPS/Bewegungssteuerung zunächst folgende Schritte aus:

  1. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.
  2. Wählen Sie aus dem Dropdown Gerät im Gruppenfeld Gerät einrichten die Option SPS/Bewegungssteuerung aus.
  3. Wählen Sie im Dropdown-Menü Hersteller den Hersteller der SPS/Bewegungssteuerung. Falls der Hersteller der SPS/Bewegungssteuerung nicht in der Liste enthalten ist, wählen Sie Andere.

  4. Wählen Sie im Dropdown Protokoll das verwendete Kommunikationsprotokoll aus. Die aufgelisteten Kommunikationsprotokolle sind durch die Auswahl von Hersteller bedingt.

    Hinweis: DeviceNet ist nur in In-Sight Vision-Systemen mit In-Sight Firmware 4.x.x verfügbar und nicht in In-Sight Vision-Systemen mit In-Sight Firmware 5.1.0 und höher. Beachten Sie die Firmwareversionen für eine vollständige Liste aller Modelle und unterstützter Firmwareversionen.
  5. Klicken Sie auf die Schaltfläche OK.
  6. Klicken Sie optional erneut auf die Schaltfläche Gerät hinzufügen, um dem Job ein weiteres „sekundäres“ Protokoll hinzuzufügen. Weitere Informationen finden Sie im Abschnitt „Unterstützte Protokolle“ unter Geräte-Setup.

Nachdem diese Einstellungen aktiviert sind, konfigurieren Sie die Registerkarten, die im Einstellbereich angezeigt werden.

Zur Verfügung stehende PLC/Bewegungssteuerung-Protokolle

Hinweis: Bezüglich einer kompletten Liste der unterstützten Protokolle siehe Geräte-Setup.

  • Modbus-TCP-Server
  • CC-Link
  • SLMP
  • SLMP-Scanner
  • Ethernet/IP
  • PROFINET
  • DeviceNet

Kommunikation über ModBus/TCP

CC-Link-Kommunikation

SLMP-Kommunikation

SLMP-Scanner-Kommunikation

Serielle Anschlusseinstellungen für DeviceNet


Kommunikation über ModBus/TCP

Ihr In-Sight-Sensor kann für andere vernetzten Modbus TCP-Geräte als Modbus-Server agieren.

So konfigurieren Sie den In-Sight-Sensors als Modbus-Server:

  1. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.

  2. IM Gruppenfeld Geräte-Setup, wählen Sie entweder SPS oder Andere aus der Dropdownliste Gerät aus.

    Hinweis: Bei Verwendung von SPS wählen Sie in der Dropdownliste Hersteller entweder den Hersteller der programmierbaren Steuerung oder die Option Andere, um in der Dropdownliste Protokoll Modbus-TCP-Server als Option zu aktivieren.
  3. Wählen Sie in der Dropdownliste Protokoll die Option Modbus-TCP-Server aus.
  4. Klicken Sie auf die Schaltfläche OK.
  5. Standardmäßig wird zuerst die Registerkarte Formatausgabedaten angezeigt. Die Steuerelemente beider Registerkarten sind identisch und werden aktiviert, nachdem die Daten hinzugefügt wurden.

  6. Klicken Sie auf die Schaltfläche Hinzufügen, um das Dialogfeld Eingabedaten auswählen bzw. Ausgabedaten auswählen (abhängig von der Auswahl der Registerkarte) zu öffnen. Das Dialogfeld Eingabedaten auswählen oder Ausgabedaten auswählen enthält die Daten aller dem Job hinzugefügten Positions- oder Inspektionswerkzeuge sowie die Gesamtergebnisse des Jobs (nur Ausgabe). Wählen Sie im Dialogfeld die entsprechenden Daten aus, die dem Modbus-Master bereitgestellt werden sollen, und klicken Sie auf OK.

  7. Nachdem Sie die Daten hinzugefügt haben, werden sie in der Tabelle mit dem Namen, dem Datentyp, der Größe, dem Wert und der ersten Registernummer der ausgewählten Daten angezeigt (die Befehle „Read“ und „Write“ des Modbus-Clients verweisen auf diese Nummer und sie definiert, welches Signal in welchem Register ist.) Rechts neben der Tabelle befindet sich das Vorschaufenster eines Modbus-Registers, in dem die Daten in Modbus-Registern formatiert angezeigt werden.

  8. Sie können den Standarddatentyp durch Auswahl eines anderen Datentyps in der Dropdownliste Datentyp anpassen.

    Hinweis:
    • Wenn Sie in der Dropdownliste Datentyp die OptionZeichenfolge oder Byteaustausch-Zeichenfolge auswählen, wird das Steuerelement Gesamtgröße (Wörter) aktiviert, und Sie können die Zeichenfolgenlänge durch Auswahl der korrekten Anzahl von Wörtern festlegen.
    • Die EasyBuilder-Implementierung des Modbus-TCP-Protokolls unterstützt keine 8-Bit-Datentypen oder vorzeichenlosen Datentypen.

  9. Sie können auch die Bytereihenfolge von 32-Bit-Floats und Ganzzahlen anpassen, indem Sie durch Deaktivieren des standardmäßig aktivierten Kontrollkästchens High-Byte/Low-Byte die Reihenfolge Low-Byte/High-Byte festlegen. Sie können die Wortreihenfolge von 32-Bit-Floats und Ganzzahlen anpassen, indem Sie durch Deaktivieren des standardmäßig aktivierten Kontrollkästchens High-Word/Low-Word die Reihenfolge Low-Word/High-Word festlegen. Alle durchgeführten Änderungen werden im Vorschaufenster des Modbus-Registers aktualisiert.

    Hinweis: Alle Änderungen der Byte- und Wortreihenfolge beeinflussen die Datensignale auf den Registerkarten Formateingabedaten und Formatausgabedaten.
  10. Sie können die Reihenfolge der zu sendenden oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und mit den Schaltflächen Nach oben oder Nach unten die gewünschte Reihenfolge festlegen.
  11. Nach der Konfiguration des In-Sight Vision-Systems müssen Sie den Modbus-Client zum Senden der Befehle „Read“ und „Write“ an das In-Sight Vision-System konfigurieren, um dem System das Lesen und Schreiben von Daten zu ermöglichen.
Hinweis: Klicken Sie optional erneut auf die Schaltfläche Gerät hinzufügen, um dem Job ein weiteres „sekundäres“ Protokoll hinzuzufügen. Weitere Informationen finden Sie im Abschnitt „Unterstützte Protokolle“ unter Geräte-Setup.


CC-Link-Kommunikation

CC-Link ist nur in In-Sight Vision-Systemen mit In-Sight Firmware 4.x.x verfügbar und nicht in In-Sight Vision-Systemen mit In-Sight Firmware 5.1.0 und höher. Beachten Sie die Firmwareversionen für eine vollständige Liste aller Modelle und unterstützter Firmwareversionen.

Das CC-Link-Protokoll dient zur Übertragung von Daten zwischen In-Sight-Vision-Systemen, die mit dem In-Sight CIO-Micro-CC-E/A-Modul und einem SPS/Bewegungssteuerung von Mitsubishi verbunden sind. Die CC-Link-Kommunikation wird zwischen der CC-Link-Verbindung im In-Sight CIO-Micro-CC-E/A-Modul und der CC-Link-Verbindung in der SPS/Bewegungssteuerung von Mitsubishi hergestellt.

Hinweis: Die Aktivierung der CC-Link-Kommunikation setzt voraus, dass das In-Sight-Vision-System mit dem In-Sight CIO-Micro-CC-E/A-Modul verbunden ist.

Die Konfiguration eines In-Sight-Vision-Systems für die Kommunikation mit einer SPS/Bewegungssteuerung von Mitsubishi über CC-Link umfasst das Festlegen der Parameter auf der Registerkarte CC-Link-Einstellungen und das anschließende Konfigurieren der Daten, die zwischen der SPS/Bewegungssteuerung von Mitsubishi und dem In-Sight-Vision-System übertragen werden.

  • Konfigurieren der Registerkarte „CC-Link-Einstellungen“
  • Konfigurieren der Registerkarten für Eingabe-Bitdaten/Wortdaten und Ausgabe-Bitdaten/Wortdaten

Konfigurieren der Registerkarte „CC-Link-Einstellungen“

Konfigurieren der Registerkarten für Eingabe-Bitdaten/Wortdaten und Ausgabe-Bitdaten/Wortdaten


SLMP-Kommunikation

SLMP wird zur Datenübertragung zwischen einer SPS/Bewegungssteuerung/Robotiksteuerung von Mitsubishi und In-Sight-Vision-Systemen verwendet.

Konfigurieren Sie zuerst die Parameter auf der Registerkarte SLMP – Einstellungen. Hier werden der Controller-Typ, die IP-Adresse, die Portnummer sowie die Quell- und Zielregister der SPS/Bewegungssteuerung/Robotiksteuerung von Mitsubishi sowie Zeitlimits festgelegt.

Konfigurieren Sie dann die Registerkarten Formateingabedaten und Formatausgabedaten. Auf diesen Registerkarten werden die Werkzeug- oder Jobdaten definiert, die zwischen der SPS/Bewegungssteuerung und dem System übertragen werden.

Hinweis: In-Sight Vision-Sensoren der 2000-Serie unterstützen die Robotiksteuerung nicht.
  • Konfigurieren der Registerkarte „SLMP – Einstellungen“
  • Konfigurieren der Registerkarten „Formatausgabedaten“ und „Formateingabedaten“

Konfigurieren der Registerkarte „SLMP/MC-Protokolleinstellungen“

Konfigurieren der Registerkarten „Formatausgabedaten“ und „Formateingabedaten“


SLMP-Scanner-Kommunikation

Der SLMP-Scanner wird zur Datenübertragung zwischen einer SPS/Bewegungssteuerung/Robotiksteuerung von Mitsubishi und einem In-Sight-Vision-System verwendet.

Konfigurieren Sie zuerst die Parameter auf der Registerkarte Einstellungen . Hier werden die Informationen festgelegt, die für die Verbindung mit der SPS/Bewegungssteuerung/Robotiksteuerung von Mitsubishi erforderlich sind.

Konfigurieren Sie anschließend die Registerkarte Geräteadresse . Hier werden die Geräteadressen der SPS/Bewegungssteuerung bzw. Robotiksteuerung sowie die Größe der unterschiedlichen, an die SPS/Bewegungssteuerung bzw. Robotiksteuerung zu übertragenden Datenblöcke definiert.

Konfigurieren Sie dann die Registerkarten Formateingabedaten und Formatausgabedaten . Auf diesen Registerkarten werden die Werkzeug- oder Jobdaten definiert, die zwischen der SPS/Bewegungssteuerung bzw. der Robotiksteuerung und dem System übertragen werden.

Hinweis:
  • In-Sight Vision-Sensoren der 2000-Serie unterstützen die Robotiksteuerung nicht.
  • Cognex empfiehlt, das In-Sight-Vision-System neu zu starten, sobald die Einstellungen für den SLMP-Scanner konfiguriert oder geändert wurden.

Konfigurieren der Registerkarte „Einstellungen“

Konfigurieren der Registerkarte „Geräteadresse“

Konfigurieren der Registerkarten „Formatausgabedaten“ und „Formateingabedaten“


Serielle Anschlusseinstellungen für DeviceNet

EasyBuilder legt automatisch die standardmäßigen seriellen Anschlusseinstellungen der DeviceNet-Steuerung als Standard fest. Wenn von der Steuerung andere Einstellungen verwendet werden, klicken Sie auf die Registerkarte Serielle Anschlusseinstellungen, und konfigurieren Sie das In-Sight-Vision-Systems für die Verwendung der gleichen seriellen Anschlusseinstellungen. Die Einstellungen für serielle Ports werden im In-Sight-Vision-System gespeichert, wenn Sie den Schritt Kommunikation verlassen.

Hinweis:
  • DeviceNet ist nur in In-Sight Vision-Systemen mit In-Sight Firmware 4.x.x verfügbar und nicht in In-Sight Vision-Systemen mit In-Sight Firmware 5.1.0 und höher. Beachten Sie die Firmwareversionen für eine vollständige Liste aller Modelle und unterstützter Firmwareversionen.
  • Die Einstellungen für DeviceNet erfordern einen RS-232-an-DeviceNet-Gatewayadapter eines Drittanbieters. Diese Einstellungen sind für ältere Installationen verfügbar und sollten nicht mit neuen Anwendungen verwendet werden, es sei denn der RS-232-an-DeviceNet-Gatewaywandler wurde ausreichend auf seine Kompatibilität mit der Anwendung gestestet.

  • Die Optionen in Serielle Anschlusseinstellungen variieren je nach In-Sight-Modell und dem entsprechenden E/A-Modul. Wenn mit einem unterstützten E/A-Modul verbunden, klicken Sie zuerst auf die Schaltfläche E/A-Modul für das Öffnen des Dialogfelds E/A-Modulkonfiguration und konfigurieren Sie das E/A-Modul.

  • In-Sight Micro 1000-Vision-Systeme unterstützen serielle Kommunikation nur, wenn sie mit dem E/A-Modul CIO-MICRO-CC verbunden sind.

  • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.
  • Ist das Vision-System der In-Sight 70xx-74xx-Serie für die Verwendung mit dem E/A-Modul CIO-MICRO oder CIO-MICRO-CC konfiguriert, sind die Pins des RS-232-Ausgangs und des RS-232-Eingangs am Strom- und E/A-Breakout-Kabel deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.
  • In-Sight Micro-Vision-Systeme der 8000-Serie unterstützen serielle Kommunikation nur, wenn sie mit dem E/A-Modul des CIO-Micro verbunden sind.

  • Das CIO-WENET-E/A-Modul unterstützt keine serielle Kommunikation.


Kommunikation mit einem Roboter

Für visuell gesteuerte Roboteranwendungen beschleunigt EasyBuilder die Entwicklung, indem die Anwendung automatisch geprüft und die Ausgabedaten anhand einer Vorrichtung (oder der Ausgabe eines anderen Positions- oder Inspektionswerkzeugs, das Positionsdaten zurückgibt) in einem Hersteller/Protokoll-spezifischen Format formatiert werden. Nachdem die Zeichenfolge formatiert wurde, kann die Robotiksteuerung die Daten anfordern, indem er einen einzelnen In-Sight Native Mode-Befehl sendet, der alle in der Zeichenfolge formatierten Daten zurückgibt.

Führen Sie zur Kommunikation mit einer Robotiksteuerung zunächst folgende Schritte aus:

  1. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.
  2. Wählen Sie im Gruppenfeld Geräte-Setup in der Dropdownliste Gerät die Option Roboter aus.
  3. Wählen Sie in der Dropdownliste Hersteller den Hersteller des Roboters. Falls der Hersteller des Roboters nicht in der Liste enthalten ist, wählen Sie Andere.
  4. Wählen Sie im Dropdown Protokoll das verwendete Kommunikationsprotokoll aus. Die angezeigten Kommunikationsprotokolle sind durch die Auswahl von Hersteller bedingt.
  5. Klicken Sie auf die Schaltfläche OK.
  6. Klicken Sie optional erneut auf die Schaltfläche Gerät hinzufügen, um dem Job ein weiteres „sekundäres“ Protokoll hinzuzufügen. Weitere Informationen finden Sie im Abschnitt „Unterstützte Protokolle“ unter Geräte-Setup.

Nachdem diese Einstellungen aktiviert sind, können Sie die Daten definieren.

  • Ethernet Native-Kommunikation für Roboter
  • Serielle Native-Kommunikation für Roboter
  • Serielle Kuka-Roboter-Kommunikation
  • Serielle Motoman-Roboter-Kommunikation
  • Robot Ethernet IP Communications (FANUC Robotiksteuerung)

Ethernet Native-Kommunikation für Roboter

Serielle Native-Kommunikation für Roboter

Serielle Kuka-Roboter-Kommunikation

Serielle Motoman-Roboter-Kommunikation

Robot Ethernet IP Communications (FANUC)


Ethernet Native-Kommunikation für Roboter

Hinweis: Diese Schritte gelten nur, wenn Roboter als Gerät und Ethernet Native als Protokoll im Gruppenfeld Geräte-Setup ausgewählt sind.
  1. Nachdem Ethernet Native als Protokoll ausgewählt wurde, sucht EasyBuilder automatisch in Ihrem Job nach Positions- oder Inspektionswerkzeugen, die einen Bezugspunkt für den Lageausgleich definieren und eine Datenzeichenfolge generieren, die diesen Bezugspunkt darstellt.
  2. Auf der Registerkarte Formatausgabezeichenfolge werden alle Werkzeuge, die einen Bezugspunkt für den Lageausgleich generieren, in der Dropdownliste Positionsname aufgelistet. Enthält der Job nur ein Werkzeug, das Positionsdaten zurückgibt, wird es standardmäßig ausgewählt. Wählen Sie andernfalls in der Dropdownliste Positionsname das Werkzeug aus, dessen Ausgabezeichenfolge Sie senden möchten. Die formatierte Zeichenfolge und die Anzahl der Zeichen in der Zeichenfolge werden zu Referenzzwecken angezeigt.
  3. Nachdem die Zeichenfolge formatiert wurde, kann die Robotiksteuerung die Daten mit dem In-Sight Native Mode-Befehl EV GetCellValue("Job.Robot.FormatString") anfordern. Der Befehl "EV GetCellValue("Job.Robot.FormatString")" gibt alle formatierten Daten in der Zeichenfolge zurück. Weitere Informationen finden Sie in der In‑Sight® Explorer-Hilfe.
Hinweis: Wenn im Job kein Bezugspunkt für den Lageausgleich definiert ist, Sie eine benutzerdefinierte Zeichenfolge erstellen oder das Format der Zeichenfolge anpassen möchten, klicken Sie auf die Schaltfläche Benutzerdefiniertes Format..., um das Dialogfeld Formatzeichenfolge zu öffnen. In diesem Dialogfeld können Sie eine andere Zeichenfolge hinzufügen, die Zeichenfolgen bearbeiten und/oder die Reihenfolge der gesendeten Daten ändern, indem Sie die Daten in der Liste auswählen und die gewünschte Reihenfolge mit den Schaltflächen Nach oben oder Nach unten festlegen. Klicken Sie auf OK, nachdem Sie die gewünschten Änderungen an der Zeichenfolge vorgenommen haben.


Serielle Native-Kommunikation für Roboter

Hinweis: Diese Schritte gelten nur wenn Roboter als Gerät und Native (seriell) als Protokoll im Abschnitt Kommunikation ausgewählt wurde.
  1. Nachdem Native (seriell) als Protokoll ausgewählt wurde, sucht EasyBuilder automatisch in Ihrem Job nach Positions- oder Inspektionswerkzeugen, die eine Vorrichtung definieren und eine Datenzeichenfolge generieren, die die Vorrichtung darstellt.
  2. Auf der Registerkarte Formatausgabezeichenfolge werden alle Werkzeuge, die einen Bezugspunkt für die Vorrichtung generieren, in der Dropdownliste Positionsname aufgelistet. Enthält der Job nur ein Werkzeug, das Positionsdaten zurückgibt, wird es standardmäßig ausgewählt. Wählen Sie andernfalls in der Dropdownliste Positionsname das Werkzeug aus, dessen Ausgabezeichenfolge Sie senden möchten. Die formatierte Zeichenfolge und die Anzahl von Zeichen in der Zeichenfolge werden zu Referenzzwecken angezeigt.

  3. Klicken Sie ggf. auf die Registerkarte Serielle Anschlusseinstellungen, um die Einstellungen für die serielle Kommunikation zu definieren. EasyBuilder bestimmt das Protokoll für den seriellen Modus automatisch anhand der Einstellungen unter Geräte-Setup. Die Einstellungen für serielle Ports werden im Vision-System gespeichert, wenn Sie den Schritt Kommunikation verlassen.

    Hinweis:

    • Die Optionen in Serielle Anschlusseinstellungen variieren je nach In-Sight-Modell und dem entsprechenden E/A-Modul. Wenn mit einem unterstützten E/A-Modul verbunden, klicken Sie zuerst auf die Schaltfläche E/A-Modul für das Öffnen des Dialogfelds E/A-Modulkonfiguration und konfigurieren Sie das E/A-Modul.

    • In-Sight Micro 1000-Vision-Systeme unterstützen serielle Kommunikation nur, wenn sie mit dem E/A-Modul CIO-MICRO-CC verbunden sind.

    • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.
    • Ist das Vision-System der In-Sight 70xx-74xx-Serie für die Verwendung mit dem E/A-Modul CIO-MICRO oder CIO-MICRO-CC konfiguriert, sind die Pins des RS-232-Ausgangs und des RS-232-Eingangs am Strom- und E/A-Breakout-Kabel deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.
    • In-Sight Micro-Vision-Systeme der 8000-Serie unterstützen serielle Kommunikation nur, wenn sie mit dem E/A-Modul des CIO-Micro verbunden sind.

    • Das CIO-WENET-E/A-Modul unterstützt keine serielle Kommunikation.

  4. Nachdem die Zeichenfolge formatiert wurde, kann die Robotiksteuerung die Daten mit dem In-Sight Native Mode-Befehl EV GetCellValue("Job.Robot.FormatString") anfordern. Der Befehl EV GetCellValue("Job.Robot.FormatString") gibt alle formatierten Daten in der Zeichenfolge zurück.
Hinweis: Wenn im Job kein Bezugspunkt für den Lageausgleich definiert ist, Sie eine benutzerdefinierte Zeichenfolge erstellen oder das Format der Zeichenfolge anpassen möchten, klicken Sie auf die Schaltfläche Benutzerdefiniertes Format..., um das Dialogfeld Formatzeichenfolge zu öffnen. In diesem Dialogfeld können Sie eine andere Zeichenfolge hinzufügen, die Zeichenfolgen bearbeiten und/oder die Reihenfolge der gesendeten Daten ändern, indem Sie die Daten in der Liste auswählen und die gewünschte Reihenfolge mit den Schaltflächen Nach oben oder Nach unten festlegen. Klicken Sie auf OK, nachdem Sie die gewünschten Änderungen an der Zeichenfolge vorgenommen haben.


Serielle Kuka-Roboter-Kommunikation

Kuka-Robotiksteuerungen kommunizieren über serielle RS-232-Anschlüsse unter Verwendung eines komplexen, aber sehr robusten Fehlerprüfprotokolls mit anderen Geräten. Wenn das In-Sight-Sensor-Vision-System für die serielle Kuka-Kommunikation konfiguriert ist, versteht es dieses Protokoll und kann auf die Befehle antworten, die es von der Kuka-Steuerung empfängt.

Hinweis:
  • Der Kuka-Roboter muss für die Kommunikation mit einem In-Sight-Vision-System im P3964R-Modus arbeiten, und das Vision-System muss wie unten beschrieben in den Modus Kuka (seriell) geschaltet werden.
  • In-Sight-Vision-Systeme sind zur Verwendung der Standardprotokolleinstellungen von Kuka konfiguriert (d.h., der Kuka-Roboter besitzt für Transaktionen hohe Priorität, und das Vision-System besitzt niedrige Priorität).

  1. Nachdem Kuka (seriell) als Protokoll ausgewählt wurde, sucht EasyBuilder automatisch in Ihrem Job nach Positions- oder Inspektionswerkzeugen, die eine Vorrichtung definieren und eine Datenzeichenfolge generieren, die die Vorrichtung definiert. Jedes Werkzeug, das eine Vorrichtung generiert, wird in der Dropdownliste Positionsname angezeigt. Enthält der Job nur ein Werkzeug, das Positionsdaten zurückgibt, wird es standardmäßig ausgewählt. Wählen Sie andernfalls in der Dropdownliste Positionsname das Werkzeug aus, dessen Ausgabezeichenfolge Sie senden möchten. Die formatierte Zeichenfolge und die Anzahl von Zeichen in der Zeichenfolge werden zu Referenzzwecken angezeigt. Im Feld Codierte Position werden Daten angezeigt, auf die die Kuka-Robotiksteuerung bei der Ausgabe vom In-Sight Native Mode-Befehl GV[EncodedLocation] verweist:

    Hinweis: Wenn im Job kein Bezugspunkt für den Lageausgleich definiert ist, Sie eine benutzerdefinierte Zeichenfolge erstellen oder das Format der Zeichenfolge anpassen möchten, klicken Sie auf die Schaltfläche Benutzerdefiniertes Format..., um das Dialogfeld Formatzeichenfolge zu öffnen. In diesem Dialogfeld können Sie eine andere Zeichenfolge hinzufügen, die Zeichenfolgen bearbeiten und/oder die Reihenfolge der gesendeten Daten ändern, indem Sie die Daten in der Liste auswählen und die gewünschte Reihenfolge mit den Schaltflächen Nach oben oder Nach unten festlegen. Klicken Sie auf OK, nachdem Sie die gewünschten Änderungen an der Zeichenfolge vorgenommen haben.

  2. EasyBuilder legt automatisch die standardmäßigen seriellen Anschlusseinstellungen der Kuka-Steuerung als Standard fest. Werden von der Steuerung andere Einstellungen verwendet, klicken Sie auf die Registerkarte Serielle Anschlusseinstellungen, und konfigurieren Sie das Vision-System für die Verwendung der gleichen seriellen Anschlusseinstellungen. Die Einstellungen für serielle Ports werden im Vision-System gespeichert, wenn Sie den Schritt Kommunikation verlassen.

    Hinweis:
    • Die Robotiksteuerungen Kuka KR C2 und KR C2 Edition 2005 werden unterstützt.

    • Die Optionen in Serielle Anschlusseinstellungen variieren je nach In-Sight-Modell und dem entsprechenden E/A-Modul. Wenn mit einem unterstützten E/A-Modul verbunden, klicken Sie zuerst auf die Schaltfläche E/A-Modul für das Öffnen des Dialogfelds E/A-Modulkonfiguration und konfigurieren Sie das E/A-Modul.

    • In-Sight Micro 1000-Vision-Systeme unterstützen serielle Kommunikation nur, wenn sie mit dem E/A-Modul CIO-MICRO-CC verbunden sind.

    • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.
    • Ist das Vision-System der In-Sight 70xx-74xx-Serie für die Verwendung mit dem E/A-Modul CIO-MICRO oder CIO-MICRO-CC konfiguriert, sind die Pins des RS-232-Ausgangs und des RS-232-Eingangs am Strom- und E/A-Breakout-Kabel deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.
    • In-Sight Micro-Vision-Systeme der 8000-Serie unterstützen serielle Kommunikation nur, wenn sie mit dem E/A-Modul des CIO-Micro verbunden sind.

    • Das CIO-WENET-E/A-Modul unterstützt keine serielle Kommunikation.

  3. Die Kuka-Robotiksteuerung initiiert die gesamte Datenkommunikation zwischen sich und dem Vision-System, indem sie In-Sight Native Mode-Befehle sendet. Der Befehl GV[CodiertePosition] gibt die in den Schritten konfigurierte Zeichenfolge zurück und sollte mit allen in EasyBuilder entwickelten Jobs verwendet werden.

Kuka (seriell) ist eine Erweiterung der Native Mode-Kommunikation von In-Sight. Da Kuka (seriell) auf dem Native Mode basiert, kann ein In-Sight-Vision-System-Job nur dann im Native Mode entwickelt, getestet und anschließend auf Kuka (seriell) umgestellt werden, wenn die tatsächliche Robotiksteuerung mit dem Vision-System verbunden ist. Weitere Änderungen am Job sind nicht erforderlich.

Geschlossen Unterstützte In-Sight Native Mode-Befehle für die Kommunikation mit Kuka (seriell):
Native Mode-Befehl | Syntax
Get Job | GJ
Get Online | GO
Wert abrufen | GV[CodiertePosition]
Wert abrufen | GV[Symbolischer Name]
Datei laden | LF[Dateiname]
Set Event | SE[Ganze Zahl]
Store File | TF[Dateiname]
Set Float | SF[Symbolischer Name][Float-Wert]
Set Integer | SI[Symbolischer Name][Ganzzahl-Wert]
Set Job | SJ[ID]
Set Online | SO[Ganzzahlwert]
Set String | SS[Symbolischer Name][Zeichenfolge]


Serielle Motoman-Roboter-Kommunikation

Die Motoman-Robotiksteuerungen MRC, MRC-II und XRC kommunizieren über serielle RS-232-Anschlüsse unter Verwendung eines komplexen, aber sehr robusten Fehlerprüfprotokolls mit anderen Geräten. Wenn das In-Sight-Sensor-Vision-System für die serielle Motoman-Kommunikation konfiguriert ist, versteht es dieses Protokoll und kann auf die Befehle antworten, die es von der Motoman-Steuerung empfängt.

Hinweis:
  • Die Motoman-Steuerung muss für die Kommunikation im DCI-Modus konfiguriert werden. Von einem In-Sight-Vision-System initiierte Kommunikation mit einer Motoman-Robotiksteuerung im Host-Modus wird zurzeit nicht unterstützt.
  • Obwohl in Motoman-Steuerungen für die Flusssteuerung die Einstellung "Keine" verwendet wird, erfordern In-Sight-Vision-Systeme bei der Kommunikation mit einer Motoman-Steuerung eine "Hardware"-Flusssteuerung (Hardware-Handshaking).
  • Es wurden nur Motoman-Steuerungen vom Typ XRC getestet.
  • Da Motoman (seriell) auf dem Native Mode basiert, kann ein In-Sight-Job nur dann im Native Mode entwickelt, getestet und anschließend auf Motoman (seriell) umgestellt werden, wenn die tatsächliche Robotiksteuerung mit dem Vision-System verbunden ist. Weitere Änderungen am Job sind nicht erforderlich.

  1. Nachdem Motoman (seriell) als Protokoll ausgewählt wurde, sucht EasyBuilder automatisch in Ihrem Job nach Positions- oder Inspektionswerkzeugen, die eine Vorrichtung (Fixture) definieren und eine Datenzeichenfolge generieren, die die Vorrichtung darstellt.

    Hinweis:Wenn im Job kein Bezugspunkt für den Lageausgleich definiert ist, Sie eine benutzerdefinierte Zeichenfolge erstellen oder das Format der Zeichenfolge anpassen möchten, klicken Sie auf die Schaltfläche Benutzerdefiniertes Format..., um das Dialogfeld Formatzeichenfolge zu öffnen. In diesem Dialogfeld können Sie eine andere Zeichenfolge hinzufügen, die Zeichenfolgen bearbeiten und/oder die Reihenfolge der gesendeten Daten ändern, indem Sie die Daten in der Liste auswählen und die gewünschte Reihenfolge mit den Schaltflächen Nach oben oder Nach unten festlegen. Klicken Sie auf OK, nachdem Sie die gewünschten Änderungen an der Zeichenfolge vorgenommen haben.

  2. Auf der Registerkarte Formatausgabezeichenfolge werden alle Werkzeuge, die einen Bezugspunkt für die Vorrichtung generieren, in der Dropdownliste Positionsname aufgelistet. Enthält der Job nur ein Werkzeug, das Positionsdaten zurückgibt, wird es standardmäßig ausgewählt. Wählen Sie andernfalls in der Dropdownliste Positionsname das Werkzeug aus, dessen Ausgabezeichenfolge Sie senden möchten. Die formatierte Zeichenfolge und die Anzahl von Zeichen in der Zeichenfolge werden zu Referenzzwecken angezeigt.
  3. Im Feld Codierte Position werden die CC + RRR-Daten angezeigt, die die Motoman-Robotiksteuerung verwendet, um Daten vom Vision-System abzurufen.

  4. EasyBuilder legt automatisch die standardmäßigen seriellen Anschlusseinstellungen der Motoman-Steuerung als Standard fest. Werden von der Steuerung andere Einstellungen verwendet, klicken Sie auf die Registerkarte Serielle Anschlusseinstellungen, und konfigurieren Sie das Vision-System für die Verwendung der gleichen seriellen Anschlusseinstellungen. Die Einstellungen für serielle Ports werden im Vision-System gespeichert, wenn Sie den Schritt Kommunikation verlassen.

    Hinweis:

    • Die Optionen in Serielle Anschlusseinstellungen variieren je nach In-Sight-Modell und dem entsprechenden E/A-Modul. Wenn mit einem unterstützten E/A-Modul verbunden, klicken Sie zuerst auf die Schaltfläche E/A-Modul für das Öffnen des Dialogfelds E/A-Modulkonfiguration und konfigurieren Sie das E/A-Modul.

    • In-Sight Micro 1000-Vision-Systeme unterstützen serielle Kommunikation nur, wenn sie mit dem E/A-Modul CIO-MICRO-CC verbunden sind.

    • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.
    • Ist das Vision-System der In-Sight 70xx-74xx-Serie für die Verwendung mit dem E/A-Modul CIO-MICRO oder CIO-MICRO-CC konfiguriert, sind die Pins des RS-232-Ausgangs und des RS-232-Eingangs am Strom- und E/A-Breakout-Kabel deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.
    • In-Sight Micro-Vision-Systeme der 8000-Serie unterstützen serielle Kommunikation nur, wenn sie mit dem E/A-Modul des CIO-Micro verbunden sind.

    • Das CIO-WENET-E/A-Modul unterstützt keine serielle Kommunikation.

  5. Die Motoman-Robotiksteuerung initiiert die gesamte Datenkommunikation zwischen sich und dem Vision-System, indem sie In-Sight Native Mode-Befehle sendet. Der Befehl GV[CodiertePosition] gibt die in den Schritten konfigurierte Zeichenfolge zurück und sollte mit allen in EasyBuilder entwickelten Jobs verwendet werden.

Motoman (seriell) ist eine Erweiterung der Native Mode-Kommunikation von In-Sight. Motoman-Robotiksteuerungen senden nur numerische Zeichen über ihre RS-232-Anschlüsse. Die standardmäßigen Native Mode-Befehle von In-Sight können nicht gesendet werden. Stattdessen muss die Motoman-Steuerung eine numerische Darstellung der Native Mode-Befehle, an die bei Bedarf weitere Parameter angehängt werden, an das Vision-System senden.


Robot Ethernet IP Communications (FANUC)

Ein In-Sight-Vision-System kann zur Kommunikation mit einer FANUC-Robotiksteuerung über EtherNet/IP (EIP) konfiguriert werden.

  1. Nach der Auswahl von Roboter als Gerät, FANUC als Hersteller und Ethernet IPRobot als Protokoll durchsucht EasyBuilder automatisch Ihren Job nach Positions- oder Inspektionswerkzeugen, die eine Vorrichtung definieren und eine Datenzeichenfolge generieren, die die Vorrichtung darstellt.

    Hinweis:
    • Zum Konfigurieren der Ethernet IP-Robotikkommunikation für eine FANUC-Robotiksteuerung müssen Sie in der Dropdownliste „Hersteller“ FANUC wählen. Wenn Sie in der Dropdownliste "Hersteller" Andere wählen, zeigt EasyBuilder die Ethernet/IP-Einstellungen für andere Geräte an.
    • Wenn Sie mit dem Ethernet Native Robot- oder Serial Native Robot-Protokoll mit der FANUC-Robotiksteuerung kommunizieren, schlagen Sie entweder unter Ethernet Native-Kommunikation für Roboter oder unter Serielle Native-Kommunikation für Roboter nach.
  2. Auf der Registerkarte Formatausgabedaten werden alle Werkzeuge, die einen Bezugspunkt für den Lageausgleich generieren, in der Dropdownliste Positionsname aufgelistet. Enthält der Job nur ein Werkzeug, das Positionsdaten zurückgibt, wird es standardmäßig ausgewählt. Wählen Sie andernfalls in der Dropdownliste Positionsname das Werkzeug aus, dessen Ausgabezeichenfolge Sie senden möchten. Zu Referenzzwecken werden die Ausgabepufferzeichenkette sowie die Meldungsgröße in Byte angezeigt.
Hinweis: Weitere Informationen über die FANUC-Robotiksteuerung finden Sie unter Roboterkommunikation – FANUC-Robotiksteuerung in der Hilfe zum In-Sight® Explorer.


Kommunikation mit Mitsubishi-Geräten

SPS/Bewegungssteuerung von Mitsubishi: CC-Link, CC-Link IE Field Basic, SLMP und SLMP-Scanner.

Führen Sie zur Kommunikation mit einer SPS/Bewegungssteuerung von Mitsubishi zunächst folgende Schritte aus:

  1. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.
  2. Wählen Sie im Gruppenfeld Geräte-Setup in der Dropdownliste Gerät die Option SPS/Bewegungssteuerung.
  3. Wählen Sie in der Dropdownliste Hersteller die Option Mitsubishi aus.

  4. Wählen Sie in der Dropdownliste Protokoll das verwendete Kommunikationsprotokoll aus: CC-Link, CC-Link IE Field Basic, SLMP oder SLMP-Scanner.

    Hinweis: CC-Link ist nur in In-Sight Vision-Systemen mit In-Sight Firmware 4.x.x verfügbar und nicht in In-Sight Vision-Systemen mit In-Sight Firmware 5.1.0 und höher. Beachten Sie die Firmwareversionen für eine vollständige Liste aller Modelle und unterstützter Firmwareversionen.
  5. Klicken Sie auf die Schaltfläche OK.
  6. Klicken Sie optional erneut auf die Schaltfläche Gerät hinzufügen, um dem Job ein weiteres „sekundäres“ Protokoll hinzuzufügen. Weitere Informationen finden Sie im Abschnitt „Unterstützte Protokolle“ unter Geräte-Setup.

Nachdem diese Einstellungen aktiviert wurden, können Sie die Einstellungen für die Kommunikation mit SPS/Bewegungssteuerungen von Mitsubishi konfigurieren:

  • CC-Link
  • CC-Link IE Field Basic
  • SLMP
  • SLMP-Scanner
Hinweis: Wird ein In-Sight-Vision-System zum Kommunizieren mit einer SPS/Bewegungssteuerung per SLMP, SLMP-Scanner oder CC-Link konfiguriert, unterstützen die Protokolle ausschließlich die Datenübertragung zwischen dem Vision-System und der SPS/Bewegungssteuerung.

Mitsubishi-Robotiksteuerung – Ethernet Native-Zeichenfolge, Serielle Native-Zeichenfolge, SLMP und SLMP-Scanner.

Hinweis: In-Sight Vision-Sensoren der 2000-Serie unterstützen die Robotiksteuerung nicht.

Führen Sie zur Kommunikation mit einer Robotiksteuerung von Mitsubishi zunächst folgende Schritte aus:

  1. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.
  2. Wählen Sie im Gruppenfeld Geräte-Setup in der Dropdownliste Gerät die Option Roboter aus.
  3. Wählen Sie in der Dropdownliste Hersteller die Option Mitsubishi aus.
  4. Wählen Sie in der Dropdownliste Protokoll das verwendete Kommunikationsprotokoll aus: Ethernet Native-Zeichenfolge, Serielle Native-Zeichenfolge, SLMP oder SLMP-Scanner.
  5. Klicken Sie auf die Schaltfläche OK.
  6. Klicken Sie optional erneut auf die Schaltfläche Gerät hinzufügen, um dem Job ein weiteres „sekundäres“ Protokoll hinzuzufügen. Weitere Informationen finden Sie im Abschnitt „Unterstützte Protokolle“ unter Geräte-Setup.

Nach der Aktivierung dieser Einstellungen können die Daten konfiguriert werden, die zwischen dem In-Sight-Vision-System und dem Roboter ausgetauscht werden:

  • Konfigurieren der Ethernet Native-Kommunikation für Zeichenfolgen (Mitsubishi)
  • Konfigurieren der seriellen Native-Kommunikation für Zeichenfolgen (Mitsubishi)
  • SLMP
  • SLMP-Scanner

CC-Link-Kommunikation

Kommunikation per CC-Link IE Field Network Basic

SLMP/MC-Protokoll-Kommunikation

SLMP/MC-Scanner-Protokoll-Kommunikation

Konfigurieren der Ethernet Native-Roboter-Kommunikation für Zeichenfolgen (Mitsubishi)

Konfigurieren der seriellen Native-Roboter-Kommunikation für Zeichenfolgen (Mitsubishi)


Konfigurieren der Registerkarte "CC-Link-Einstellungen"

Die Registerkarte CC-Link-Einstellungen dient zum Konfigurieren des In-Sight CIO-Micro-CC-E/A-Moduls für die Kommunikation im CC-Link-Netzwerk.

Hinweis: Wenn Sie nicht mit einem In-Sight CIO-Micro-CC-E/A-Modul verbunden sind, sind alle Steuerelemente deaktiviert, bis diese Verbindung wieder hergestellt wird.
Geschlossen Aktivieren

Bestimmt, ob die CC-Link-Schnittstelle im In-Sight CIO-Micro-CC-E/A-Modul aktiviert oder deaktiviert ist. In der Standardeinstellung ist das Kontrollkästchen Aktivieren aktiviert, und die CC-Link-Schnittstelle im In-Sight CIO-Micro-CC-E/A-Modul ist aktiviert. Deaktivieren Sie das Kontrollkästchen Aktivieren, um bei Bedarf Probleme mit der CC-Link-Verbindung zu diagnostizieren und zu beheben.

Geschlossen Version

Gibt die Kompatibilität mit der CC-Link-Spezifikation an (V1 oder V2). In der Standardeinstellung ist V1 ausgewählt.

Geschlossen Baudrate

Gibt die CC-Link-Baudrate des CC-Link-Netzwerks an (10 MBit/s, 5 MBit/s, 2,5 MBit/s, 625 KBit/s oder 156 KBit/s). In der Standardeinstellung ist 10 MBit/s ausgewählt.

Geschlossen Stationsnummer

Gibt die Stationsnummer des CC-Link-Slaves an (1 bis 64). In der Standardeinstellung ist 1 ausgewählt.

Hinweis: Die Werte der Parameter Stationsnummer und Anzahl von Stationen dürfen nicht größer als 64 sein.
Geschlossen Anzahl von Stationen

Gibt die Anzahl von Stationen an, die das In-Sight CIO-Micro-CC-E/A-Modul im CC-Link-Netzwerk belegt (1 bis 4). In der Standardeinstellung ist 1 ausgewählt.

Hinweis: Die Werte der Parameter Stationsnummer und Anzahl von Stationen dürfen nicht größer als 64 sein.
Geschlossen Erweiterungszyklen

Gibt die Anzahl von Erweiterungszyklen an, die das In-Sight CIO-Micro-CC-E/A-Modul im CC-Link-Netzwerk verwendet (1X (deaktiviert), 2X, 4X oder 8X). In der Standardeinstellung ist 1X (deaktiviert) ausgewählt.

Hinweis: Diese Option ist nur verfügbar, wenn der Parameter Version auf V2 festgelegt ist.
Geschlossen Eingänge

Zeigt die in den Eingabe-Bit- und Eingabe-Wortpuffern verfügbare Anzahl von Bits bzw. Wörtern an.

So ermitteln Sie die im Eingabepuffer verfügbare Anzahl von Bits:

  • Wenn der Parameter Version auf V1 festgelegt ist: 32 x (Anzahl von Stationen) - 16
  • Wenn der Parameter Version auf V2 und der Parameter Erweiterungszyklen auf 1X (deaktiviert) festgelegt ist: 32 x (Anzahl von Stationen) - 16
  • Wenn der Parameter Version auf V2 festgelegt und der Parameter Erweiterungszyklen aktiviert ist: 32 x (Anzahl von Stationen) x (Erweiterungszyklen) - 16 x (Erweiterungszyklen) - 16

So ermitteln Sie die im Eingabepuffer verfügbare Anzahl von Wörtern:

  • Wenn der Parameter Version auf V1 festgelegt ist: 4 x (Anzahl von Stationen)
  • Wenn der Parameter Version auf V2 und der Parameter Erweiterungszyklen auf 1X (deaktiviert) festgelegt ist: 4 x (Anzahl von Stationen)
  • Wenn der Parameter Version auf V2 festgelegt und der Parameter Erweiterungszyklen aktiviert ist: 4 x (Anzahl von Stationen) x (Erweiterungszyklen)
Geschlossen Ausgänge

Zeigt die in den Ausgabe-Bit- und Ausgabe-Wortpuffern verfügbare Anzahl von Bits bzw. Wörtern an.

So ermitteln Sie die im Ausgabepuffer verfügbare Anzahl von Bits:

  • Wenn der Parameter Version auf V1 festgelegt ist: 32 x (Anzahl von Stationen) - 16
  • Wenn der Parameter Version auf V2 und der Parameter Erweiterungszyklen auf 1X (deaktiviert) festgelegt ist: 32 x (Anzahl von Stationen) - 16
  • Wenn der Parameter Version auf V2 festgelegt und der Parameter Erweiterungszyklen aktiviert ist: 32 x (Anzahl von Stationen) x (Erweiterungszyklen) - 16 x (Erweiterungszyklen) - 16

So ermitteln Sie die im Ausgabepuffer verfügbare Anzahl von Wörtern:

  • Wenn der Parameter Version auf V1 festgelegt ist: 4 x (Anzahl von Stationen)
  • Wenn der Parameter Version auf V2 und der Parameter Erweiterungszyklen auf 1X (deaktiviert) festgelegt ist: 4 x (Anzahl von Stationen)
  • Wenn der Parameter Version auf V2 festgelegt und der Parameter Erweiterungszyklen aktiviert ist: 4 x (Anzahl von Stationen) x (Erweiterungszyklen)


Konfigurieren der Registerkarten für Eingabe-Bitdaten/Wortdaten und Ausgabe-Bitdaten/Wortdaten

Nach dem Konfigurieren der Registerkarte CC-Link-Einstellungen müssen Sie die Registerkarten Eingabe-Bitdaten, Eingabe-Wortdaten, Ausgabe-Bitdaten und Ausgabe-Wortdaten konfigurieren. Auf diesen Registerkarten werden die Werkzeug- oder Jobdaten definiert, die zwischen der programmierbaren Steuerung/Bewegungssteuerung von Mitsubishi und dem In-Sight-Vision-System über das CC-Link-Netzwerk übertragen werden.

Geschlossen Konfigurieren der Registerkarte „Eingabe-Bitdaten“

Die Registerkarte Eingabe-Bitdaten wird verwendet, um Bit Offsets den booleschen Datentypen zuzuordnen, die von den Ergebnissen der Positions- oder Inspektionswerkzeuge, Aufnahmedaten oder Eingängen zurückgegeben werden. Pro Job können maximal 32 Eingaben definiert werden.

  1. Klicken Sie auf die Registerkarte Eingabe-Bitdaten, um mit der Konfiguration der Daten zu beginnen, die von der programmierbaren Steuerung/Bewegungssteuerung zum In-Sight-Vision-System übertragen werden.
  2. Klicken Sie auf Hinzufügen, um das Dialogfeld Eingabedaten auswählen zu öffnen. Dieses Dialogfeld enthält Daten aus dem Job, z.B. Positions- oder Inspektionswerkzeuge des Jobs, Aufnahmedaten und Eingänge. Wählen Sie die Daten aus, die von der programmierbaren Steuerung/Bewegungssteuerung in das In-Sight-Vision-System übertragen werden sollen, und klicken Sie auf OK.
  3. Nachdem Sie die Daten hinzugefügt haben, werden die Daten in der Tabelle angezeigt und zeigen die Geräteadresse, den Namen der Eingabe, deren Datentyp, Größe und Wert.
  4. Sie können die Reihenfolge der zu sendenden oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und mit den Schaltflächen Nach oben oder Nach unten die gewünschte Reihenfolge festlegen.
Geschlossen Konfigurieren der Registerkarte „Eingabe-Wortdaten“

Die Registerkarte Eingabe-Wortdaten wird verwendet, um Eingaben für das In-Sight Vision-System zu definieren, die von den Ergebnissen der Positions- oder Inspektionswerkzeuge, Aufnahmedaten oder Eingängen zurückgegeben werden. Pro Job können maximal 32 Eingaben definiert werden.

Hinweis: Die Anzahl der Wörter darf den Grenzwert nicht überschreiten, der von den auf der Registerkarte CC-Link-Einstellungen konfigurierten Parametern festgelegt wird.
  1. Klicken Sie auf die Registerkarte Eingabe-Wortdaten, um mit der Konfiguration der Daten zu beginnen, die von der programmierbaren Steuerung/Bewegungssteuerung zum In-Sight-Vision-System übertragen werden.
  2. Klicken Sie auf Hinzufügen, um das Dialogfeld Eingabedaten auswählen zu öffnen. Dieses Dialogfeld enthält Daten aus dem Job, z.B. Positions- oder Inspektionswerkzeuge des Jobs, Aufnahmedaten und Eingänge. Wählen Sie die Daten aus, die von der programmierbaren Steuerung/Bewegungssteuerung in das In-Sight-Vision-System übertragen werden sollen, und klicken Sie auf OK.
  3. Nachdem Sie die Daten hinzugefügt haben, werden die Daten in der Tabelle angezeigt und zeigen die Geräteadresse (der Beginn der Adresse ist das Feld „Offset“ in Worten), den Namen der Eingabe, deren Datentyp, Größe und Wert.

  4. Sie können den Standarddatentyp durch Auswahl eines anderen Datentyps in der Dropdownliste Datentyp anpassen.

    Hinweis:
    • Wenn Sie in der Dropdownliste Datentyp die Option Zeichenfolge auswählen, wird das Steuerelement Gesamtgröße (Wörter) aktiviert, sodass Sie die Zeichenfolgenlänge durch Auswahl der korrekten Anzahl von Wörtern festlegen können (maximal 128).
    • Die EasyBuilder-Implementierung des CC-Link unterstützt keine 8-Bit-Datentypen oder vorzeichenlosen Datentypen.
  5. Sie können die Reihenfolge der zu sendenden oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und mit den Schaltflächen Nach oben oder Nach unten die gewünschte Reihenfolge festlegen.
Geschlossen Konfigurieren der Registerkarte „Ausgabe-Bitdaten“

Die Registerkarte Ausgabe-Bitdaten wird verwendet, um Bit Offsets den booleschen Datentypen zuzuordnen, die von den Ergebnissen der Positions- oder Inspektionswerkzeuge, Aufnahmedaten oder Jobergebnissen zurückgegeben werden. Es dürfen mindestens 64 Ausgaben pro Job definiert werden (weitere können hinzugefügt werden; die Höchstgrenze hängt von der Größe des Jobs ab).

  1. Klicken Sie auf die Registerkarte Ausgabe-Bitdaten, um mit der Konfiguration der Daten zu beginnen, die vom In-Sight-Vision-System an die programmierbare Steuerung/Bewegungssteuerung übertragen werden.

  2. Klicken Sie auf die Schaltfläche Hinzufügen, um das Dialogfeld Ausgabedaten auswählen zu öffnen, das Daten aus dem Job enthält, wie zum Beispiel z.B. jegliche Positions- oder Inspektionswerkzeuge, die Ihrem Job hinzugefügt wurden, Aufnahmedaten und die Gesamtergebnisse vom Job. Wählen Sie die Daten aus, die vom In-Sight-Vision-System in das programmierbare Steuerung/Bewegungssteuerung übertragen werden sollen, und klicken Sie auf OK.

    Hinweis: Das Datensymbol Job.Inspection_Count wird der Ausgabedatentabelle automatisch hinzugefügt. Durch dieses Symbol wird die programmierbare Steuerung/Bewegungssteuerung darüber informiert, dass das In-Sight-Vision-System ein neues Bild aufgenommen hat und ein neuer Inspektionsergebnissatz eingegangen ist. Dieses Symbol kann entfernt werden, wenn es nicht benötigt wird.
  3. Nachdem Sie die Daten hinzugefügt haben, werden sie mit dem Namen, dem Datentyp, der Größe, dem Wert und der ersten Registernummer der ausgewählten Daten in der Tabelle angezeigt. Rechts neben der Tabelle befindet sich das Registervorschaufenster, in dem die Daten in Registern der programmierbaren Steuerung/Bewegungssteuerung formatiert angezeigt werden.
  4. Sie können die Reihenfolge der zu sendenden oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und mit den Schaltflächen Nach oben oder Nach unten die gewünschte Reihenfolge festlegen.
Geschlossen Konfigurieren der Registerkarte „Ausgabe-Wortdaten“

Die Registerkarte Ausgabe-Wortdaten wird verwendet, um Ausgaben für das In-Sight Vision-System zu definieren, die von den Ergebnissen der Positions- oder Inspektionswerkzeuge, Aufnahmedaten oder Jobergebnissen zurückgegeben werden. Es dürfen mindestens 32 Ausgaben pro Job definiert werden (weitere können hinzugefügt werden; die Höchstgrenze hängt von der Größe des Jobs ab).

  1. Klicken Sie auf die Registerkarte Ausgabe-Bitdaten, um mit der Konfiguration der Daten zu beginnen, die vom In-Sight-Vision-System an die programmierbare Steuerung/Bewegungssteuerung übertragen werden.

  2. Klicken Sie auf die Schaltfläche Hinzufügen, um das Dialogfeld Ausgabedaten auswählen zu öffnen, das Daten aus dem Job enthält, wie zum Beispiel z.B. jegliche Positions- oder Inspektionswerkzeuge, die Ihrem Job hinzugefügt wurden, Aufnahmedaten und die Gesamtergebnisse vom Job. Wählen Sie die Daten aus, die vom In-Sight-Vision-System in das programmierbare Steuerung/Bewegungssteuerung übertragen werden sollen, und klicken Sie auf OK.

    Hinweis: Das Datensymbol Job.Inspection_Count wird der Ausgabedatentabelle automatisch hinzugefügt. Durch dieses Symbol wird die programmierbare Steuerung/Bewegungssteuerung darüber informiert, dass das In-Sight-Vision-System ein neues Bild aufgenommen hat und ein neuer Inspektionsergebnissatz eingegangen ist. Dieses Symbol kann entfernt werden, wenn es nicht benötigt wird.
  3. Nachdem Sie die Daten hinzugefügt haben, werden sie mit dem Namen, dem Datentyp, der Größe, dem Wert und der ersten Registernummer der ausgewählten Daten in der Tabelle angezeigt (der Anfang der Adresse ist das Feld „Offset“ in Worten). Rechts neben der Tabelle befindet sich das Registervorschaufenster, in dem die Daten in Registern der programmierbaren Steuerung/Bewegungssteuerung formatiert angezeigt werden.

  4. Sie können den Standarddatentyp durch Auswahl eines anderen Datentyps in der Dropdownliste Datentyp anpassen.

    Hinweis:
    • Wenn Sie in der Dropdownliste Datentyp die Option Zeichenfolge auswählen, wird das Steuerelement Gesamtgröße (Wörter) aktiviert, sodass Sie die Zeichenfolgenlänge durch Auswahl der korrekten Anzahl von Wörtern festlegen können (maximal 128).
    • Die EasyBuilder-Implementierung des CC-Link unterstützt keine 8-Bit-Datentypen oder vorzeichenlosen Datentypen.
  5. Sie können die Reihenfolge der zu sendenden oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und mit den Schaltflächen Nach oben oder Nach unten die gewünschte Reihenfolge festlegen.


Kommunikation per CC-Link IE Field Network Basic

CC-Link IE Field Basic ist ein Protokoll, mit dem Ethernet-Geräte in Mitsubishi Automation Controller integriert werden können. Im Gegensatz zum vorhandenen SLMP (MC-Protokoll) dient der Mitsubishi Automation Controller als Master, der die Kommunikation mit den Slave-Geräten über UDP-Standardnachrichten vornimmt. Die Kommunikation unterstützt 64 Bit und 32 16-Bit-Wörter Daten pro Station in jede Richtung; jeder Slave unterstützt 4 Stationen. Die Daten werden über die Mitsubishi-Einrichtungswerkzeuge (GXWorks 2/3) in den Controller-Arbeitsspeicher abgebildet.

Hinweis: Weitere Informationen finden Sie in der In‑Sight® Explorer-Hilfe. Weitere detaillierte Informationen sind im Referenzhandbuch „CC-Link IE Field Network Basic Reference Manual“ von Mitsubishi verfügbar.
  • Konfigurieren der Registerkarten „Eingabe-Bitdaten/Wortdaten formatieren“ und „Ausgabe-Bitdaten/Wortdaten formatieren“ (CC-Link IE Field Basic)

Konfigurieren der Registerkarten „Eingabe-Bitdaten/Wortdaten formatieren“ und „Ausgabe-Bitdaten/Wortdaten formatieren“ (CC-Link IE Field Basic)


Konfigurieren der Registerkarten „Eingabe-Bitdaten/Wortdaten formatieren“ und „Ausgabe-Bitdaten/Wortdaten formatieren“ (CC-Link IE Field Basic)

Auf den Registerkarten Eingabe-Bitdaten formatieren, Eingabe-Wortdaten formatieren, Ausgabe-Bitdaten formatieren und Ausgabe-Wortdaten formatieren werden die Werkzeug- oder Jobdaten definiert, die zwischen der SPS/Bewegungssteuerung von Mitsubishi und dem In-Sight-Vision-System über das CC-Link IE Field Basic-Protokoll übertragen werden.

Hinweis:
  • In diesem Hilfethema bezeichnet „Eingabe“ eine Eingabe in das Vision-System und „Ausgabe“ eine Ausgabe vom In-Sight Vision-System.
  • Weitere Informationen finden Sie in der In‑Sight® Explorer-Hilfe.
Registerkarte | SPS-Arbeitsspeicherposition | Start-Offset | Größenbeschränkung (wenn 1 Station besetzt ist) | Datentyp
Eingabe-Bitdaten formatieren | RY | 32 | 32 | Bits
Eingabe-Wortdaten formatieren | RWw | 2 | 30 | 16-Bit-Wörter
Ausgabe-Bitdaten formatieren | RX | 32 | 32 | Bits
Ausgabe-Wortdaten formatieren | RWr | 5 | 27 | 16-Bit-Wörter
Geschlossen Konfigurieren der Registerkarte „Eingabe-Bitdaten formatieren“

Mit der Registerkarte Eingabe-Bitdaten formatieren werden Bit-Offsets den booleschen Datentypen zugeordnet, die von den Ergebnissen der Positions- oder Inspektionswerkzeuge, Aufnahmedaten oder Eingängen zurückgegeben werden. Pro Job können maximal 32 Eingaben definiert werden.

  1. Klicken Sie auf die Registerkarte Eingabe-Bitdaten formatieren, um mit der Konfiguration der Daten zu beginnen, die von der SPS/Bewegungssteuerung an das In-Sight-Vision-System übertragen werden.
  2. Klicken Sie auf Hinzufügen, um das Dialogfeld Eingabedaten auswählen zu öffnen. Dieses Dialogfeld enthält Daten aus dem Job, z. B. Positions- oder Inspektionswerkzeuge des Jobs, Aufnahmedaten und Eingänge. Wählen Sie die Daten aus, die von der SPS/Bewegungssteuerung in das In-Sight-Vision-System übertragen werden sollen, und klicken Sie auf OK.
  3. Nachdem Sie die Daten hinzugefügt haben, werden die Daten in der Tabelle angezeigt und zeigen die Geräteadresse, den Namen der Eingabe, deren Datentyp, Größe und Wert.
  4. Sie können die Reihenfolge der gesendeten oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und mit den Schaltflächen Nach oben oder Nach unten die gewünschte Reihenfolge festlegen.
Geschlossen Konfigurieren der Registerkarte „Eingabe-Wortdaten formatieren“

Mit der Registerkarte Eingabe-Wortdaten formatieren werden Eingaben für das In-Sight Vision-System definiert, die von den Ergebnissen der Positions- oder Inspektionswerkzeuge, Aufnahmedaten oder Eingängen zurückgegeben werden. Pro Job können maximal 30 Eingaben definiert werden.

  1. Klicken Sie auf die Registerkarte Eingabe-Wortdaten formatieren, um mit der Konfiguration der Daten zu beginnen, die von der SPS/Bewegungssteuerung an das In-Sight-Vision-System übertragen werden.
  2. Klicken Sie auf Hinzufügen, um das Dialogfeld Eingabedaten auswählen zu öffnen. Dieses Dialogfeld enthält Daten aus dem Job, z. B. Positions- oder Inspektionswerkzeuge des Jobs, Aufnahmedaten und Eingänge. Wählen Sie die Daten aus, die von der SPS/Bewegungssteuerung in das In-Sight-Vision-System übertragen werden sollen, und klicken Sie auf OK.
  3. Nachdem Sie die Daten hinzugefügt haben, werden die Daten in der Tabelle angezeigt und zeigen die Geräteadresse (der Beginn der Adresse ist das Feld „Offset“ in Worten), den Namen der Eingabe, deren Datentyp, Größe und Wert.

  4. Sie können den Standarddatentyp durch Auswahl eines anderen Datentyps in der Dropdownliste Datentyp anpassen.

    Hinweis:
    • Wenn Sie in der Dropdownliste Datentyp die Option Zeichenfolge auswählen, wird das Steuerelement Gesamtgröße (Wörter) aktiviert, sodass Sie die Zeichenfolgenlänge durch Auswahl der korrekten Anzahl von Wörtern festlegen können (maximal 128).
    • Die EasyBuilder-Implementierung des CC-Link unterstützt keine 8-Bit-Datentypen oder vorzeichenlosen Datentypen.
  5. Sie können die Reihenfolge der gesendeten oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und mit den Schaltflächen Nach oben oder Nach unten die gewünschte Reihenfolge festlegen.
Geschlossen Konfigurieren der Registerkarte „Ausgabe-Bitdaten formatieren“

Mit der Registerkarte Ausgabe-Bitdaten formatieren werden die Bit-Offsets den booleschen Datentypen zugeordnet, die von den Ergebnissen der Positions- oder Inspektionswerkzeuge, Aufnahmedaten oder Jobergebnissen zurückgegeben werden. Pro Job können maximal 32 Ausgaben definiert werden.

  1. Klicken Sie auf die Registerkarte Ausgabe-Bitdaten formatieren, um mit der Konfiguration der Daten zu beginnen, die vom In-Sight-Vision-System an die SPS/Bewegungssteuerung übertragen werden.

  2. Klicken Sie auf die Schaltfläche Hinzufügen, um das Dialogfeld Ausgabedaten auswählen zu öffnen, das Daten aus dem Job (z. B. alle Positions- oder Inspektionswerkzeuge, die Ihrem Job hinzugefügt wurden), Aufnahmedaten und die Gesamtergebnisse vom Job enthält. Wählen Sie die Daten aus, die vom In-Sight-Vision-System in die SPS/Bewegungssteuerung übertragen werden sollen, und klicken Sie auf OK.

    Hinweis: Das Datensymbol Job.Inspection_Count wird der Ausgabedatentabelle automatisch hinzugefügt. Durch dieses Symbol wird die SPS/Bewegungssteuerung darüber informiert, dass das In-Sight-Vision-System ein neues Bild aufgenommen hat und ein neuer Inspektionsergebnissatz eingegangen ist. Dieses Symbol kann entfernt werden, wenn es nicht benötigt wird.
  3. Nachdem Sie die Daten hinzugefügt haben, werden sie mit dem Namen, dem Datentyp, der Größe, dem Wert und der ersten Registernummer der ausgewählten Daten in der Tabelle angezeigt. Rechts neben der Tabelle befindet sich das Registervorschaufenster, in dem die Daten in Registern der SPS/Bewegungssteuerung formatiert angezeigt werden.
  4. Sie können die Reihenfolge der gesendeten oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und mit den Schaltflächen Nach oben oder Nach unten die gewünschte Reihenfolge festlegen.
Geschlossen Konfigurieren der Registerkarte „Ausgabe-Wortdaten formatieren“

Mit der Registerkarte Ausgabe-Wortdaten formatieren werden die Ausgaben für das In-Sight Vision-System definiert, die von den Ergebnissen der Positions- oder Inspektionswerkzeuge, Aufnahmedaten oder Jobergebnissen zurückgegeben werden. Pro Job können maximal 27 Ausgaben definiert werden.

  1. Klicken Sie auf die Registerkarte Ausgabe-Bitdaten formatieren, um mit der Konfiguration der Daten zu beginnen, die vom In-Sight-Vision-System an die SPS/Bewegungssteuerung übertragen werden.

  2. Klicken Sie auf die Schaltfläche Hinzufügen, um das Dialogfeld Ausgabedaten auswählen zu öffnen, das Daten aus dem Job (z. B. alle Positions- oder Inspektionswerkzeuge, die Ihrem Job hinzugefügt wurden), Aufnahmedaten und die Gesamtergebnisse vom Job enthält. Wählen Sie die Daten aus, die vom In-Sight-Vision-System in die SPS/Bewegungssteuerung übertragen werden sollen, und klicken Sie auf OK.

    Hinweis: Das Datensymbol Job.Inspection_Count wird der Ausgabedatentabelle automatisch hinzugefügt. Durch dieses Symbol wird die SPS/Bewegungssteuerung darüber informiert, dass das In-Sight-Vision-System ein neues Bild aufgenommen hat und ein neuer Inspektionsergebnissatz eingegangen ist. Dieses Symbol kann entfernt werden, wenn es nicht benötigt wird.
  3. Nachdem Sie die Daten hinzugefügt haben, werden sie mit dem Namen, dem Datentyp, der Größe, dem Wert und der ersten Registernummer der ausgewählten Daten in der Tabelle angezeigt (der Anfang der Adresse ist das Feld „Offset“ in Worten). Rechts neben der Tabelle befindet sich das Registervorschaufenster, in dem die Daten in Registern der SPS/Bewegungssteuerung formatiert angezeigt werden.

  4. Sie können den Standarddatentyp durch Auswahl eines anderen Datentyps in der Dropdownliste Datentyp anpassen.

    Hinweis:
    • Wenn Sie in der Dropdownliste Datentyp die Option Zeichenfolge auswählen, wird das Steuerelement Gesamtgröße (Wörter) aktiviert, sodass Sie die Zeichenfolgenlänge durch Auswahl der korrekten Anzahl von Wörtern festlegen können (maximal 128).
    • Die EasyBuilder-Implementierung für CC-Link IE Field Basic unterstützt 8-Bit-Datentypen oder vorzeichenlose Datentypen nicht.
  5. Sie können die Reihenfolge der gesendeten oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und mit den Schaltflächen Nach oben oder Nach unten die gewünschte Reihenfolge festlegen.


Konfigurieren der Registerkarte „SLMP – Einstellungen“

Auf der Registerkarte „SLMP – Einstellungen“ können Sie den Controllertyp und die IP-Adresse der SPS/Bewegungssteuerung bzw. der Robotiksteuerung, die TCP-Portnummer, Zeitlimits sowie die Quell- und Zielpfade für die Register der SPS/Bewegungssteuerung/Robotiksteuerung konfigurieren.

Hinweis:

Die verfügbaren Controllertypen in der Registerkarte „Einstellungen“ hängen davon ab, welches Gerät im Gruppenfeld „Geräte-Setup“ ausgewählt wurde. Weitere Informationen finden Sie unter Kommunikation mit Mitsubishi-Geräten.

Ausgewähltes Gerät (Gruppenfeld „Geräte-Setup“) Verfügbare Controllertypen (Registerkarte „Einstellungen“)
SPS/Bewegungssteuerung
  • iQ-R/Q/L-Serie (3E-Frame)
  • iQ-F-Serie (3E-Frame)
  • FX-Serie (1E-Frame)
Robotiksteuerung
  • CR-800D-Serie (3E-Frame)
Geschlossen Controllertyp

Gibt den Typ der SPS/Bewegungssteuerung/Robotiksteuerung von Mitsubishi an, mit der kommuniziert werden soll.

  • SPS/Bewegungssteuerung: iQ-R/Q/L-Serie (3E-Frame), iQ-F-Serie (3E-Frame) oder FX-Serie (1E-Frame). Standard: iQ-R/Q/L-Serie (3E-Frame).

    Hinweis: Die Option iQ-F-Serie (3E-Frame) steht auf In-Sight-Vision-Systemen unter In-Sight Firmwareversion 4.x.x nicht zur Verfügung.
  • Robotiksteuerung: CR800-D Serie (3E-Frame)
Geschlossen IP-Adresse

Legt die IP-Adresse der SPS/Bewegungssteuerung bzw. Robotiksteuerung von Mitsubishi fest. Geben Sie die IP-Adresse der SPS/Bewegungssteuerung bzw. der Robotiksteuerung von Mitsubishi ein, die mit dem In-Sight-Vision-System verbunden wird.

Geschlossen Hostanschluss

Legt die TCP-Portnummer der SPS/Bewegungssteuerung/Robotiksteuerung von Mitsubishi im Dezimalformat (Dez) bzw. Hexadezimalformat (Hex) fest (1 – 65535 im Dezimalformat, 1 – 0xFFFF im Hexadezimalformat; Standard = 12288 im Dezimalformat).

Geschlossen Zeitüberschreitung (ms)

Legt die Zeitüberschreitung für Lese- und Schreibvorgänge fest (5 bis 30.000 Millisekunden; Standardwert: 1.000 ms).

Hinweis: Mit diesem Parameter wird unter Umständen der Job verlängert; wenn sowohl der Lese- als auch der Schreibvorgang fehlschlägt, verlängert sich der Job um das Doppelte des Werts unter Zeitüberschreitung, da die Werte für beide Vorgänge addiert werden.
Geschlossen Quellgerät
Hinweis: Löschen Sie alle Werkzeugeigenschaften auf der Registerkarte „Formateingabedaten“, bevor Sie den Parameter „Quellgerät“ ändern. Wenn der Parameter „Quellgerät“ auf <Keine> gesetzt wird und gleichzeitig noch Werkzeugeigenschaften auf der Registerkarte „Formateingabedaten“ vorhanden sind, werden die Werkzeuge in einen Fehlerzustand versetzt. Außerdem wird die Schaltfläche „Entfernen“ deaktiviert und die Werkzeuge, die auf der Registerkarte „Formateingabedaten“ verblieben sind, schlagen fehl oder werden nicht ausgeführt, bis sie entfernt werden.
Geschlossen Geräteadresse für Eingabedaten

Legt fest, aus welchem Geräteregister der SPS/Bewegungssteuerung bzw. der Robotiksteuerung von Mitsubishi gelesen werden soll:

Gerätetyp | Format | SPS/Bewegungssteuerung | Roboter
iQ-R/Q/L-Serie (3E-Frame) | iQ-F-Serie (3E-Frame) | FX-Serie (1E-Frame) | CR800-D Serie (3E-Frame)
X – Eingangsrelais | Bit | X | X | X (Okt)
Y – Ausgangsrelais | Bit | X | X | X (Okt)
M - Internes Relais | Bit | X | X | X
L – Latch-Relais | Bit | X
F – Signalgeber | Bit | X | X
B – Link-Relais | Bit | X
D – Datenregister | Wort | X | X | X | X
W – Link-Register | Wort | X
R – Dateiblockregister | Wort | X
ZR – Dateiregister | Wort | X
TN - Timerwert | Wort | X | X
CN - Zählerwert | Wort | X | X
R – Erweiterungsregister | Wort | X
S - Statusrelais | Bit | X
Hinweis: Mit dem Format des Gerätetyps wird festgelegt, welche Optionen für den Datentyp in der Registerkarte Formateingabepuffer zur Verfügung stehen. Wenn als Format des Gerätetyps die Option Bit ausgewählt wird, können auf der Registerkarte Formateingabepuffer nur Bit-Datentypen eingegeben werden.
Geschlossen Offset

Der Zahlenbereich der Datentabelle der SPS/Bewegungssteuerung bzw. Robotiksteuerung, mit dem definiert wird, wo der Lesevorgang beginnt.

Geschlossen Ziel
Geschlossen Geräteadresse für Ausgabedaten

Legt fest, in welches Geräteregister der SPS/Bewegungssteuerung bzw. der Robotiksteuerung von Mitsubishi ausgelesen werden soll:

Gerätetyp | Format | SPS/Bewegungssteuerung | Roboter
iQ-R/Q/L-Serie (3E-Frame) | iQ-F-Serie (3E-Frame) | FX-Serie (1E-Frame) | CR800-D Serie (3E-Frame)
X – Eingangsrelais | Bit | X | X | X (Okt)
Y – Ausgangsrelais | Bit | X | X | X (Okt)
M - Internes Relais | Bit | X | X | X
L – Latch-Relais | Bit | X
F – Signalgeber | Bit | X | X
B – Link-Relais | Bit | X
D – Datenregister | Wort | X | X | X | X
W – Link-Register | Wort | X
R – Dateiblockregister | Wort | X
ZR – Dateiregister | Wort | X
TN - Timerwert | Wort | X | X
CN - Zählerwert | Wort | X | X
R – Erweiterungsregister | Wort | X
S - Statusrelais | Bit | X
Hinweis: Mit dem Format des Gerätetyps wird festgelegt, welche Optionen für den Datentyp in der Registerkarte Formatausgabepuffer zur Verfügung stehen. Wenn als Format des Gerätetyps die Option Bit ausgewählt wird, können auf der Registerkarte Formatausgabepuffer nur Bit-Datentypen eingegeben werden.
Geschlossen Offset

Der Zahlenbereich der Datentabelle der SPS/Bewegungssteuerung bzw. Robotiksteuerung, mit dem definiert wird, wo der Schreibvorgang beginnt.


Konfigurieren der Registerkarten „Formatausgabedaten“ und „Formateingabedaten“ (SLMP)

Nach dem Konfigurieren der Registerkarte SLMP-Einstellungen müssen Sie die Registerkarten Formateingabedaten und Formatausgabedaten konfigurieren. Auf diesen Registerkarten werden die Werkzeug- oder Jobdaten definiert, die zwischen der SPS/Bewegungssteuerung bzw. der Robotiksteuerung von Mitsubishi und dem In-Sight-Vision-System übertragen werden.

Geschlossen Konfigurieren der Registerkarte „Formateingabedaten“

Auf der Registerkarte Formateingabedaten werden die in das In-Sight-Vision-System eingegebenen Daten definiert. Pro Job können maximal 32 Eingänge definiert werden.

  1. Klicken Sie auf die Registerkarte Formateingabedaten, um mit der Konfiguration der Daten zu beginnen, die von der SPS/Bewegungssteuerung/Robotiksteuerung an das In-Sight-Vision-System übertragen werden.

  2. Klicken Sie auf Hinzufügen, um das Dialogfeld Eingabedaten auswählen zu öffnen. Dieses Dialogfeld enthält Daten aus dem Job, z. B. Positions- oder Inspektionswerkzeuge des Jobs, Aufnahmedaten und Eingänge. Wählen Sie die Daten aus, die von der SPS/Bewegungssteuerung bzw. der Robotiksteuerung auf das In-Sight-Vision-System übertragen werden sollen, und klicken Sie auf die Schaltfläche OK.

    Hinweis: Die Einstellung Quellgerät auf der Registerkarte SLMP-Einstellungen wirkt sich auf die Datentypen aus, die hinzugefügt werden können. Wenn die Einstellung Quellgerät für ein Bit-Gerät konfiguriert ist, können Sie für jede Bit-Adresse boolesche Datentypen hinzufügen und diese einem bestimmten Bit zuweisen. Wenn die Einstellung Quellgerät für ein Wort-Gerät konfiguriert ist, kann Datentyp konfiguriert werden, und als Startadresse werden Geräteadresse für Eingabedaten und der Wert des Felds "Offset" (in Worten) verwendet.
  3. Nachdem Sie die Daten hinzugefügt haben, werden die Daten in der Tabelle angezeigt und zeigen die Geräteadresse, den Namen der Eingabe, deren Datentyp, Größe und Wert.

  4. Sie können den Standarddatentyp durch Auswahl eines anderen Datentyps in der Dropdownliste Datentyp anpassen.

    Hinweis:
    • Die verfügbaren Optionen für Datentyp hängen von der Einstellung Quellgerät auf der Registerkarte SLMP-Einstellungen ab. Wenn die Einstellung Quellgerät für ein Bit-Gerät konfiguriert ist, enthält das Dropdown Datentyp nur die Option Bit. Wenn die Einstellung Quellgerät für ein Wortgerät konfiguriert ist, enthält das Dropdown Datentyp nur die folgenden Optionen: Bit, 16-Bit-Ganzzahl, 16-Bit-Ganzzahl ohne Vorzeichen, 32-Bit-Ganzzahl, 32-Bit Fließpunkt und Zeichenfolge.
    • Wenn Sie in der Dropdownliste Datentyp die Option Zeichenfolge auswählen, wird das Steuerelement Gesamtgröße (Wörter) aktiviert, sodass Sie die Zeichenfolgenlänge durch Auswahl der korrekten Anzahl von Wörtern festlegen können. Wenn als Controllertyp die Option iQ-R/Q/L-Serie (3E-Frame), iQ-F-Serie (3E-Frame) oder CR800-D-Serie (3E-Frame) ausgewählt ist, darf die Meldung maximal 960 Wörter beinhalten. Wenn als Controllertyp die Option FX-Serie (1E-Frame) ausgewählt ist, darf die Meldung maximal 64 Wörter beinhalten.
    • Wenn als Controllertyp die Option iQ-R/Q/L-Serie (3E-Frame), iQ-F-Serie (3E-Frame) oder CR800-D-Serie (3E Frame) ausgewählt ist, dürfen die Eingabedaten maximal 1920 Byte umfassen. Wenn als Controllertyp die Option FX-Serie (1E-Frame) ausgewählt ist, dürfen die Eingabedaten maximal 128 Byte umfassen. Die Größe der Eingabedaten wird im Feld Meldungsgröße (Byte) angezeigt.
    • Die Schaltfläche Datentypen zurücksetzen setzt alle Datentypen auf die Standardeinstellungen zurück.
    • Die EasyBuilder-Implementierung des SLMP-Protokolls unterstützt keine 8-Bit-Datentypen oder vorzeichenlosen Datentypen.
  5. Sie können die Reihenfolge der zu sendenden oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und mit den Schaltflächen Nach oben oder Nach unten die gewünschte Reihenfolge festlegen.
Geschlossen Konfigurieren der Registerkarte „Formatausgabedaten“

Auf der Registerkarte Formatausgabedaten werden die vom In-Sight-Vision-System ausgegebenen Daten definiert. Pro Job können maximal 128 Ausgänge definiert werden.

  1. Klicken Sie auf die Registerkarte Formatausgabedaten, um mit der Konfiguration der Daten zu beginnen, die vom In-Sight-Vision-System an die SPS/Bewegungssteuerung oder die Robotiksteuerung übertragen werden.

  2. Klicken Sie auf die Schaltfläche Hinzufügen, um das Dialogfeld Ausgabedaten auswählen zu öffnen, das Daten aus dem Job (z. B. alle Positions- oder Inspektionswerkzeuge, die Ihrem Job hinzugefügt wurden), Aufnahmedaten und die Gesamtergebnisse vom Job enthält. Wählen Sie die Daten aus, die von der SPS/Bewegungssteuerung bzw. der Robotiksteuerung in das In-Sight-Vision-System übertragen werden sollen, und klicken Sie auf OK.

    Hinweis:
    • Das Datensymbol Job.Inspection_Count wird der Ausgabedatentabelle automatisch hinzugefügt. Durch dieses Symbol wird die SPS/Bewegungssteuerung bzw. die Robotiksteuerung darüber informiert, dass das In-Sight-Vision-System ein neues Bild aufgenommen hat und ein neuer Inspektionsergebnissatz eingegangen ist. Dieses Symbol kann entfernt werden, wenn es nicht benötigt wird.
    • Die Einstellung Zielgerät auf der Registerkarte SLMP-Einstellungen wirkt sich auf die Datentypen aus, die hinzugefügt werden können. Wenn die Einstellung Ziel für ein Bit-Gerät konfiguriert ist, können Sie für jede Bit-Adresse boolesche Datentypen hinzufügen und diese einem bestimmten Bit zuweisen. Wenn die Einstellung Ziel für ein Wort-Gerät konfiguriert ist, kann Datentyp konfiguriert werden, und als Startadresse werden Geräteadresse für Ausgabedaten und der Wert des Felds „Offset“ (in Worten) verwendet.
  3. Nachdem Sie die Daten hinzugefügt haben, werden sie mit dem Namen, dem Datentyp, der Größe, dem Wert und der ersten Registernummer der ausgewählten Daten in der Tabelle angezeigt. Rechts neben der Tabelle befindet sich das Registervorschaufenster, in dem die Daten in Registern der SPS/Bewegungssteuerung bzw. der Robotiksteuerung formatiert angezeigt werden.

  4. Sie können den Standarddatentyp durch Auswahl eines anderen Datentyps in der Dropdownliste Datentyp anpassen.

    Hinweis:
    • Die verfügbaren Optionen für Datentyp hängen von der Einstellung Zielgerät auf der Registerkarte SLMP-Einstellungen ab. Wenn die Einstellung Zielgerät für ein Bit-Gerät konfiguriert ist, enthält das Dropdown Datentyp nur die Option Bit. Wenn die Einstellung Ziel für ein Wortgerät konfiguriert ist, enthält das Dropdown Datentyp nur die folgenden Optionen: Bit, 16-Bit-Ganzzahl, 16-Bit-Ganzzahl ohne Vorzeichen, 32-Bit-Ganzzahl, 32-Bit Fließpunkt und Zeichenfolge.
    • Wenn Sie in der Dropdownliste Datentyp die Option Zeichenfolge auswählen, wird das Steuerelement Gesamtgröße (Wörter) aktiviert, sodass Sie die Zeichenfolgenlänge durch Auswahl der korrekten Anzahl von Wörtern festlegen können. Wenn als Controllertyp die Option iQ-R/Q/L-Serie (3E-Frame), iQ-F-Serie (3E-Frame) oder CR800-D-Serie (3E-Frame) ausgewählt ist, darf die Meldung maximal 960 Wörter beinhalten. Wenn als Controllertyp die Option FX-Serie (1E-Frame) ausgewählt ist, darf die Meldung maximal 64 Wörter beinhalten.
    • Wenn als Controllertyp die Option iQ-R/Q/L-Serie (3E-Frame), iQ-F-Serie (3E-Frame) oder CR800-D-Serie (3E Frame) ausgewählt ist, dürfen die Ausgabedaten maximal 1.920 Byte umfassen. Wenn als Controllertyp die Option FX-Serie (1E-Frame) ausgewählt ist, dürfen die Ausgabedaten maximal 128 Byte umfassen. Die Größe der Ausgabedaten wird im Feld Meldungsgröße (Byte) angezeigt.
    • Die Schaltfläche Datentypen zurücksetzen setzt alle Datentypen auf die Standardeinstellungen zurück.
    • Die EasyBuilder-Implementierung des SLMP unterstützt keine 8-Bit-Datentypen oder vorzeichenlosen Datentypen.
  5. Sie können die Reihenfolge der zu sendenden oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und mit den Schaltflächen Nach oben oder Nach unten die gewünschte Reihenfolge festlegen.


Konfigurieren der Registerkarte „Einstellungen“ (SLMP-Scanner)

Die Registerkarte „Einstellungen“ des SLMP-Scanners dient zum Festlegen der Informationen, die für die Verbindung mit der programmierbaren Steuerung/Bewegungssteuerung von Mitsubishi erforderlich sind.

Hinweis:

Die verfügbaren Controllertypen in der Registerkarte „Einstellungen“ hängen davon ab, welches Gerät im Gruppenfeld „Geräte-Setup“ ausgewählt wurde. Weitere Informationen finden Sie unter Kommunikation mit Mitsubishi-Geräten.

Ausgewähltes Gerät (Gruppenfeld „Geräte-Setup“) Verfügbare Controllertypen (Registerkarte „Einstellungen“)
SPS/Bewegungssteuerung
  • iQ-R/Q/L-Serie (3E-Frame)
  • iQ-F-Serie (3E-Frame)
  • FX-Serie (1E-Frame)
Robotiksteuerung
  • CR-800D-Serie (3E-Frame)
Geschlossen Controllertyp

Gibt den Typ der SPS/Bewegungssteuerung/Robotiksteuerung von Mitsubishi an, mit der kommuniziert werden soll.

  • SPS/Bewegungssteuerung: iQ-R/Q/L-Serie (3E-Frame), iQ-F-Serie (3E-Frame) oder FX-Serie (1E-Frame). Standard: iQ-R/Q/L-Serie (3E-Frame).

    Hinweis: Die Option iQ-F-Serie (3E-Frame) steht auf In-Sight-Vision-Systemen unter In-Sight Firmwareversion 4.x.x nicht zur Verfügung.
  • Robotiksteuerung: CR800-D Serie (3E-Frame)
Geschlossen IP-Adresse

Legt die IP-Adresse der SPS/Bewegungssteuerung bzw. Robotiksteuerung von Mitsubishi fest. Geben Sie die IP-Adresse der SPS/Bewegungssteuerung bzw. der Robotiksteuerung von Mitsubishi ein, die mit dem In-Sight-Vision-System verbunden wird.

Geschlossen Hostanschluss

Legt die TCP-Portnummer der SPS/Bewegungssteuerung/Robotiksteuerung von Mitsubishi im Dezimalformat (Dez) bzw. Hexadezimalformat (Hex) fest (1 – 65535 im Dezimalformat, 1 – 0xFFFF im Hexadezimalformat; Standard = 12288 im Dezimalformat).

Hinweis:
  • Dieser Wert muss mit der Einstellung Hostanschluss am SLMP-Port der SPS/Bewegungssteuerung/Robotiksteuerung von Mitsubishi übereinstimmen.
  • Das Format der Host-Anschlussnummer wird beim Schließen von In-Sight Explorer auf dezimal (Dec) zurückgesetzt.
Geschlossen Zeitüberschreitung (ms)

Legt die Zeitüberschreitung für Lese- und Schreibvorgänge fest (5 bis 30.000 Millisekunden; Standardwert: 1.000 ms).

Hinweis: Mit diesem Parameter wird unter Umständen der Job verlängert; wenn sowohl der Lese- als auch der Schreibvorgang fehlschlägt, verlängert sich der Job um das Doppelte des Werts unter Zeitüberschreitung, da die Werte für beide Vorgänge addiert werden.
Geschlossen Abfrageintervall (ms)

Definiert die Zeit (5 Millisekunden bis 30.000; Standard ist 1.000 ms) zwischen aufeinanderfolgenden Abfragen des Vision-Steuerelementeblocks der SPS/Bewegungssteuerung bzw. Robotiksteuerung von Mitsubishi.

Geschlossen Verbindung mit externer Station herstellen
  • Wenn dieses Kontrollkästchen aktiviert wird und unter Controllertyp die Option iQ-R/Q/L-Serie (3E-Frame), iQ-F-Serie (3E-Frame) oder CR800-D-Serie (3E Frame) ausgewählt ist, werden die Steuerelemente für Netzwerknummer, PC-Nummer und Zielmodul aktiviert.
  • Wenn dieses Kontrollkästchen aktiviert wird und unter Controllertyp die Option FX-Serie (1E-Frame) ausgewählt ist, wird das Steuerelement für die PC-Nummer aktiviert.

Dieses Kontrollkästchen ist in der Standardeinstellung deaktiviert; das In-Sight Vision-System ist dann direkt über ein Ethernet-Modul, das durch die angegebene IP-Adresse spezifiziert wird, mit der SPS/Bewegungssteuerung bzw. Robotiksteuerung verbunden.

Geschlossen Netzwerknummer

Definiert die SLMP-Netzwerknummer für die Kommunikation (0 bis 239, Standard ist 0 = lokales Netzwerk). Diese Option ist aktiviert, wenn das Kontrollkästchen Verbindung mit externer Station herstellen aktiviert ist.

Geschlossen PC-Nummer (Hex)

Legt die Stations-ID im angegebenen Netzwerk des Zielmoduls (als Hexadezimalzahl) fest. Diese Option ist aktiviert, wenn das Kontrollkästchen Verbindung mit externer Station herstellen aktiviert ist.

Hex | Beschreibung
0xFF (Standard) | Direkte Verbindung zur lokalen Station.
0x7E | Masterstation auf dem CC-Link IE Field.
0x1 - 0x78 | Station auf dem CC-Link IE Field-Netzwerkadapter.
Geschlossen Zielmodul

Legt die Modul-ID des Geräts fest, zu dem eine Verbindung hergestellt werden soll. Diese Option ist aktiviert, wenn das Kontrollkästchen Verbindung mit externer Station herstellen aktiviert ist.

Modultyp
03ff - Lokale Station (Standard)
0x3d0 – Steuerungssystem-CPU
0x3d1– Standby-System-CPU
0x3d2 – System-A-CPU
0x3d3 – System-B-CPU
0x3e0 – CPU 1
0x3e1 – CPU 2
0x3e2 – CPU 3
0x3e3 – CPU 4
Geschlossen Schaltfläche "Zurücksetzen"

Setzen Sie alle Einstellungen auf die Standardeinstellungen zurück.

Geschlossen Schaltfläche "Verbindung testen"

Startet die Verbindung zur SPS/Bewegungssteuerung bzw. zur Robotiksteuerung von Mitsubishi zu Testzwecken.


Konfigurieren der Registerkarte „Geräteadresse“ (SLMP-Scanner)

Die Registerkarte „Geräteadresse“ des SLMP-Scanners dient dazu, die Geräteadressen der SPS/Bewegungssteuerung bzw. Robotiksteuerung sowie die Größe der unterschiedlichen, an die SPS/Bewegungssteuerung bzw. Robotiksteuerung zu übertragenden Datenblöcke festzulegen. Der Gerätetyp und die Größe der Datenblöcke ist jeweils vom Controllertyp (iQ-R/Q/L-Serie, iQ-F-Serie, FX-Serie oder CR800-D-Serie) abhängig, der auf der Registerkarte Einstellungen angegeben wurde.

Geschlossen Name

Name des Datenblocks, der an die bzw. von der SPS/Bewegungssteuerung bzw. Robotiksteuerung von Mitsubishi gesendet wird.

Geschlossen Ausgewähltes Gerät

Legt die SPS/Bewegungssteuerung bzw. Robotiksteuerung von Mitsubishi fest, die zum Lesen oder Schreiben des Datenblocks verwendet wird. Das Dropdown enthält die folgenden Optionen:

Gerätetyp | Format | SPS/Bewegungssteuerung |  |  | Robotiksteuerung
 |  | iQ-R/Q/L-Serie (3E-Frame) | iQ-F-Serie (3E-Frame) | FX-Serie (1E-Frame) | CR800-D Serie (3E-Frame)
X – Eingangsrelais* | Bit | X | X | X |
Y – Ausgangsrelais* | Bit | X | X | X |
M – Internes Relais* | Bit | X | X | X |
L – Latch-Relais* | Bit | X |  |  |
F – Signalgeber* | Bit | X | X |  |
B – Link-Relais* | Bit | X |  |  |
D – Datenregister | Wort | X | X | X | X
W – Link-Register | Wort | X |  |  |
R – Dateiblockregister | Wort | X |  |  |
ZR – Dateiregister | Wort | X |  |  |
R – Erweiterungsregister | Wort |  |  | X |
S – Statusrelais* | Bit |  |  | X |
*Wird nur von den Datenblöcken Steuerung und Status unterstützt.
Hinweis:
  • Wenn „Ausgewähltes Gerät“ auf Keine gesetzt wird, starten Sie das In-Sight-Vision-System neu, sobald die Einstellungen für den SLMP-Scanner konfiguriert oder geändert wurden.
  • Falls Keine ausgewählt ist, wird der Datenblock nicht übertragen.
  • Die Geräte Zeitwert und Zählerwert werden nicht unterstützt.
Geschlossen Offset

Legt den Offset innerhalb der Gerätetabelle zum Lesen oder Schreiben des Datenblocks fest. Der Offset-Wert muss je nach ausgewähltem Gerätetyp als Dezimal-, Hexadezimal- oder Oktalzahl eingegeben werden.

Gerätetyp | Value | SPS/Bewegungssteuerung |  |  | Robotiksteuerung
 |  | iQ-R/Q/L-Serie (3E-Frame) | iQ-F-Serie (3E-Frame) | FX-Serie (1E-Frame) | CR800-D Serie (3E-Frame)
X – Eingangsrelais* | Hex | X | X | X |
Y – Ausgangsrelais* | Hex | X | X | X |
M – Internes Relais* | Dezimal | X | X | X |
L – Latch-Relais* | Dezimal | X |  |  |
F – Signalgeber* | Dezimal | X | X |  |
B – Link-Relais* | Hex | X |  |  |
D – Datenregister | Dezimal | X | X | X | X
W – Link-Register | Hex | X |  |  |
R – Dateiblockregister | Dezimal | X |  |  |
ZR – Dateiregister | Dezimal | X |  |  |
R – Erweiterungsregister | Dezimal |  |  | X |
S – Statusrelais* | Dezimal |  |  | X |
*Wird nur von den Datenblöcken Steuerung und Status unterstützt.
Geschlossen Anzahl von Geräten

Definiert die Größe des Datenblocks, der an die SPS/Bewegungssteuerung bzw. Robotiksteuerung von Mitsubishi übertragen wird. Die Größe wird in der Einheit der SPS/Bewegungssteuerung bzw. Robotiksteuerung (Wörter oder Bits) angegeben. Die maximal zulässige Datengröße für Eingangsblock, Ausgangsblock, Befehl und Befehlsergebnis hängt vom ausgewählten Controllertyp (iQ-R/Q/L-Serie, iQ-F-Serie, FX-Serie oder CR800-D-Serie) ab.

Blockname | Anzahl von Geräten
 | iQ-R/Q/L-Serie, iQ-F-Serie, CR800-D-Serie | FX-Baureihe
Steuerung | 32 Bit (schreibgeschützt)
Status | 32 Bit (schreibgeschützt)
Eingangsblock | 4 + Eingabedatenlänge (maximal 960 Wörter) | 4 + Eingabedatenlänge (maximal 64 Wörter)
Ausgangsblock | 12 + Ausgabedatenlänge (maximal 960 Wörter) | 12 + Ausgabedatenlänge (maximal 64 Wörter)
Befehl | 0 - 960 Wörter | 0 - 64 Wörter
Befehlsergebnis | 0 - 960 Wörter | 0 - 64 Wörter
Hinweis:

Von der iQ-R/Q/L-Serie, iQ-F-Serie und CR800-D-Serie können nahezu alle derzeit gängigen Meldungsframeformate verarbeitet werden (3E-Frame). Von der FX-Serie kann dagegen nur die erste Generation des Protokollmeldungsframes (1E-Frame) verarbeitet werden; die Datenmenge, die innerhalb eines Pakets übertragen werden kann, ist begrenzt.

 | Maximale Datengröße
 | iQ-R/Q/L-Serie, iQ-F-Serie, CR800-D-Serie | FX-Serie
Stapel (lesen) – Bits | 7904 Bits | 256 Bits
Stapel (lesen) – Wörter | 960 Wörter | 64 Wörter
Stapel (schreiben) – Bits | 7904 Bits | 160 Bits
Stapel (schreiben) – Wörter | 690 Wörter | 64 Wörter
Geschlossen Beschreibung

Eine Textbeschreibung des Datenblocks.


Konfigurieren der Registerkarten „Formatausgabedaten“ und „Formateingabedaten“ (SLMP-Scanner)

Nach dem Konfigurieren der Registerkarten Einstellungen und Geräteadressen müssen Sie die Registerkarten Formateingabedaten und Formatausgabedaten konfigurieren. Auf diesen Registerkarten werden die Werkzeug- oder Jobdaten definiert, die zwischen der SPS/Bewegungssteuerung/Robotiksteuerung von Mitsubishi und dem In-Sight-Vision-System übertragen werden.

Geschlossen Konfigurieren der Registerkarte „Formateingabedaten“

Auf der Registerkarte Formateingabedaten werden die in das In-Sight-Vision-System eingegebenen Daten definiert. Pro Job können maximal 32 Eingänge definiert werden.

  1. Klicken Sie auf die Registerkarte Formateingabedaten, um mit der Konfiguration der Daten zu beginnen, die von der SPS/Bewegungssteuerung/Robotiksteuerung an das In-Sight-Vision-System übertragen werden.
  2. Klicken Sie auf Hinzufügen, um das Dialogfeld Eingabedaten auswählen zu öffnen. Dieses Dialogfeld enthält Daten aus dem Job, z. B. Positions- oder Inspektionswerkzeuge des Jobs, Aufnahmedaten und Eingänge. Wählen Sie die Daten aus, die von der SPS/Bewegungssteuerung bzw. der Robotiksteuerung auf das In-Sight-Vision-System übertragen werden sollen, und klicken Sie auf die Schaltfläche OK.
  3. Nachdem Sie die Daten hinzugefügt haben, werden die Daten in der Tabelle angezeigt und zeigen die Geräteadresse, den Namen der Eingabe, deren Datentyp, Größe und Wert.

  4. Sie können den Standarddatentyp durch Auswahl eines anderen Datentyps in der Dropdownliste Datentyp anpassen.

    Hinweis:
    • Wenn Sie in der Dropdownliste Datentyp die Option Zeichenfolge oder Byteaustausch-Zeichenfolge auswählen, wird das Steuerelement Gesamtgröße (Wörter) aktiviert, und Sie können die Zeichenfolgenlänge durch Auswahl der korrekten Anzahl von Wörtern festlegen.
    • Wenn als Controllertyp die Option iQ-R/Q/L-Serie (3E-Frame), iQ-F-Serie (3E-Frame) bzw. CR800-D-Serie (3E-Frame) ausgewählt ist, darf die Meldung maximal 960 Wörter beinhalten. Wenn als Controllertyp die FX-Serie (1E-Frame) ausgewählt ist, kann die Meldung maximal 64 Wörter beinhalten.
    • Wenn als Controllertyp die Option iQ-R/Q/L-Serie (3E-Frame), iQ-F-Serie (3E-Frame) oder CR800-D-Serie (3E Frame) ausgewählt ist, dürfen die Eingabedaten insgesamt maximal 1.920 Byte umfassen. Wenn als Controllertyp die Option FX-Serie (1E-Frame) ausgewählt ist, dürfen die Eingabedaten insgesamt maximal 128 Byte umfassen. Die Größe der Eingabedaten wird im Feld Meldungsgröße (Byte) angezeigt.
    • Die Schaltfläche Datentypen zurücksetzen setzt alle Datentypen auf die Standardeinstellungen zurück.
    • Die EasyBuilder-Implementierung des SLMP-Scanners unterstützt keine 8-Bit-Datentypen.

  5. Sie können auch die Bytereihenfolge anpassen, indem Sie durch Deaktivieren des standardmäßig aktivierten Kontrollkästchens High-Byte/Low-Byte die Reihenfolge Low-Byte/High-Byte festlegen (standardmäßig für alle Protokolle außer PROFINET deaktiviert). Sie können die Wortreihenfolge anpassen, indem Sie durch Deaktivieren des standardmäßig deaktivierten Kontrollkästchens High-Word/Low-Word die Reihenfolge Low-Word/High-Word festlegen.

    Hinweis: Alle Änderungen der Byte- und Wortreihenfolge beeinflussen die Datensignale auf den Registerkarten Formateingabedaten und Formatausgabedaten.

  6. Sie können die Reihenfolge der zu sendenden oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und mit den Schaltflächen Nach oben oder Nach unten die gewünschte Reihenfolge festlegen.

Geschlossen Konfigurieren der Registerkarte „Formatausgabedaten“

Auf der Registerkarte Formatausgabedaten werden die vom In-Sight-Vision-System ausgegebenen Daten definiert. Pro Job können maximal 128 Ausgänge definiert werden.

  1. Klicken Sie auf die Registerkarte Formatausgabedaten, um mit der Konfiguration der Daten zu beginnen, die vom In-Sight-Vision-System an die SPS/Bewegungssteuerung oder die Robotiksteuerung übertragen werden.
  2. Klicken Sie auf die Schaltfläche Hinzufügen, um das Dialogfeld Ausgabedaten auswählen zu öffnen, das Daten aus dem Job (z. B. alle Positions- oder Inspektionswerkzeuge, die Ihrem Job hinzugefügt wurden), Aufnahmedaten und die Gesamtergebnisse vom Job enthält. Wählen Sie die Daten aus, die von der SPS/Bewegungssteuerung bzw. der Robotiksteuerung in das In-Sight-Vision-System übertragen werden sollen, und klicken Sie auf OK.
  3. Nachdem Sie die Daten hinzugefügt haben, werden sie mit dem Namen, dem Datentyp, der Größe, dem Wert und der ersten Registernummer der ausgewählten Daten in der Tabelle angezeigt. Rechts neben der Tabelle befindet sich das Registervorschaufenster, in dem die Daten in Registern der SPS/Bewegungssteuerung bzw. der Robotiksteuerung formatiert angezeigt werden.

  4. Sie können den Standarddatentyp durch Auswahl eines anderen Datentyps in der Dropdownliste Datentyp anpassen.

    Hinweis:
    • Wenn Sie in der Dropdownliste Datentyp die Option Zeichenfolge oder Byteaustausch-Zeichenfolge auswählen, wird das Steuerelement Gesamtgröße (Wörter) aktiviert, und Sie können die Zeichenfolgenlänge durch Auswahl der korrekten Anzahl von Wörtern festlegen.
    • Wenn als Controllertyp die Option iQ-R/Q/L-Serie (3E-Frame), iQ-F-Serie (3E-Frame) oder CR800-D-Serie (3E-Frame) ausgewählt ist, darf die Meldung maximal 960 Wörter beinhalten. Wenn als Controllertyp die Option FX-Serie (1E-Frame) ausgewählt ist, darf die Meldung maximal 64 Wörter beinhalten.
    • Wenn als Controllertyp die Option iQ-R/Q/L-Serie (3E-Frame), iQ-F-Serie (3E-Frame) oder CR-800-D-Serie (3E-Frame) ausgewählt ist, dürfen die Ausgabedaten maximal 1.920 Byte umfassen. Wenn als Controllertyp die Option FX-Serie (1E-Frame) ausgewählt ist, dürfen die Ausgabedaten insgesamt maximal 128 Byte umfassen. Die Größe der Ausgabedaten wird im Feld Meldungsgröße (Byte) angezeigt.
    • Die Schaltfläche Datentypen zurücksetzen setzt alle Datentypen auf die Standardeinstellungen zurück.
    • Die EasyBuilder-Implementierung des SLMP-Scanners unterstützt keine 8-Bit-Datentypen.
  5. Sie können auch die Bytereihenfolge anpassen, indem Sie durch Deaktivieren des standardmäßig aktivierten Kontrollkästchens High-Byte/Low-Byte die Reihenfolge Low-Byte/High-Byte festlegen (standardmäßig für alle Protokolle außer PROFINET deaktiviert). Sie können die Wortreihenfolge anpassen, indem Sie durch Deaktivieren des standardmäßig deaktivierten Kontrollkästchens High-Word/Low-Word die Reihenfolge Low-Word/High-Word festlegen. Alle durchgeführten Änderungen werden im Vorschaufenster aktualisiert.
  6. Sie können die Reihenfolge der zu sendenden oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und mit den Schaltflächen Nach oben oder Nach unten die gewünschte Reihenfolge festlegen.


Konfigurieren der Ethernet Native-Kommunikation für Zeichenfolgen (Mitsubishi)

Daten aus EasyBuilder-Jobs, z. B. einzelne Werkzeug- oder Job-Ergebnisse können über die Robotiksteuerung übertragen werden. Nachdem Daten ausgewählt und als Zeichenfolge formatiert wurden, kann die Robotiksteuerung die Daten anfordern, indem sie einen einzelnen In-Sight Native Mode-Befehl (GetValue (GVJob.Robot.FormatString)) sendet, der alle in der Zeichenfolge formatierten Daten zurückgibt.

Hinweis: In-Sight Vision-Sensoren der 2000-Serie unterstützen die Robotiksteuerung nicht.

So formatieren Sie die Daten als Zeichenfolge für Native Mode-Übertragungen:

Hinweis: Das In-Sight Vision-System muss Offline geschaltet sein, damit diese Steuerelemente zur Verfügung stehen.
  1. Klicken Sie auf Hinzufügen, um das Dialogfeld Ausgabedaten auswählen zu öffnen. Dieses Dialogfeld enthält Daten von beliebigen Positions- oder Inspektionswerkzeugen, die dem Job hinzugefügt wurden, sowie zusätzliche Jobdaten, z. B. Aufnahme- oder Eingabedaten.
  2. Wählen Sie im Dialogfeld Ausgabedaten auswählen die Daten aus, die vom In-Sight-Vision-System gesendet werden sollen, und klicken Sie auf OK. Für eine Zeichenfolge können maximal 40 Datenelemente ausgewählt werden.
  3. Nach dem Hinzufügen der Daten kann die Reihenfolge der zu sendenden Daten durch Auswählen von Datenelementen in der Liste und Klicken auf die Schaltflächen Nach oben oder Nach unten Ihren Anforderungen entsprechend geändert werden. Sie können auch die Schaltfläche Entfernen verwenden, um unerwünschte Elemente zu löschen.
  4. Weist eines der Datenelemente einen Fließpunkt-Datentyp auf, wird das Steuerelement für die Dezimalstellen aktiviert, und die Anzahl der Dezimalstellen für Fließpunktwerte kann festgelegt werden (0 bis 6, standardmäßig = 3).
  5. Im Fenster rechts neben der Datenliste werden zu Referenzzwecken die formatierte Zeichenfolge und die Zeichenfolgenlänge (Anzahl der Zeichen einer Zeichenfolge) angezeigt. Zur Begrenzung der Werte innerhalb der Zeichenfolge wird automatisch ein Komma eingefügt.
  6. Sobald die Zeichenfolge formatiert wurde, kann die Robotiksteuerung die Datenzeichenfolge durch Senden des einzelnen In-Sight Native Mode-Befehls GetValue (GVJob.Robot.FormatString) anfordern.


Konfigurieren der seriellen Native-Kommunikation für Zeichenfolgen (Mitsubishi)

Daten aus EasyBuilder-Jobs, z. B. einzelne Werkzeug- oder Job-Ergebnisse können über die Robotiksteuerung übertragen werden. Nachdem Daten ausgewählt und als Zeichenfolge formatiert wurden, kann die Robotiksteuerung die Daten anfordern, indem sie einen einzelnen In-Sight Native Mode-Befehl (GetValue (GVJob.Robot.FormatString)) sendet, der alle in der Zeichenfolge formatierten Daten zurückgibt.

Hinweis: In-Sight Vision-Sensoren der 2000-Serie unterstützen die Robotiksteuerung nicht.

So formatieren Sie die Daten als Zeichenfolge für Native Mode-Übertragungen:

Hinweis: Das In-Sight Vision-System muss Offline geschaltet sein, damit diese Steuerelemente zur Verfügung stehen.
  1. Klicken Sie auf Hinzufügen, um das Dialogfeld Ausgabedaten auswählen zu öffnen. Dieses Dialogfeld enthält Daten von beliebigen Positions- oder Inspektionswerkzeugen, die dem Job hinzugefügt wurden, sowie zusätzliche Jobdaten, z. B. Aufnahme- oder Eingabedaten.
  2. Wählen Sie im Dialogfeld Ausgabedaten auswählen die Daten aus, die vom In-Sight-Vision-System gesendet werden sollen, und klicken Sie auf OK. Für eine Zeichenfolge können maximal 40 Datenelemente ausgewählt werden.
  3. Nach dem Hinzufügen der Daten kann die Reihenfolge der zu sendenden Daten durch Auswählen von Datenelementen in der Liste und Klicken auf die Schaltflächen Nach oben oder Nach unten Ihren Anforderungen entsprechend geändert werden. Sie können auch die Schaltfläche Entfernen verwenden, um unerwünschte Elemente zu löschen.
  4. Weist eines der Datenelemente einen Fließpunkt-Datentyp auf, wird das Steuerelement für die Dezimalstellen aktiviert, und die Anzahl der Dezimalstellen für Fließpunktwerte kann festgelegt werden (0 bis 6, standardmäßig = 3).
  5. Im Fenster rechts neben der Datenliste werden zu Referenzzwecken die formatierte Zeichenfolge und die Zeichenfolgenlänge (Anzahl der Zeichen einer Zeichenfolge) angezeigt. Zur Begrenzung der Werte innerhalb der Zeichenfolge wird automatisch ein Komma eingefügt.
  6. Sobald die Zeichenfolge formatiert wurde, kann die Robotiksteuerung die Datenzeichenfolge durch Senden des einzelnen In-Sight Native Mode-Befehls GetValue (GVJob.Robot.FormatString) anfordern.

  7. Klicken Sie ggf. auf die Registerkarte Serielle Anschlusseinstellungen, um die Einstellungen für die serielle Kommunikation zu definieren. EasyBuilder bestimmt das Protokoll für den seriellen Modus automatisch anhand der Einstellungen unter Geräte-Setup. Die Einstellungen für den seriellen Anschluss werden im In-Sight-Vision-System gespeichert, wenn Sie den Schritt Kommunikation verlassen.

    Hinweis:

    • Die Optionen in Serielle Anschlusseinstellungen variieren je nach In-Sight-Modell und dem entsprechenden E/A-Modul. Wenn mit einem unterstützten E/A-Modul verbunden, klicken Sie zuerst auf die Schaltfläche E/A-Modul für das Öffnen des Dialogfelds E/A-Modulkonfiguration und konfigurieren Sie das E/A-Modul.

    • In-Sight Micro 1000-Vision-Systeme unterstützen serielle Kommunikation nur, wenn sie mit dem E/A-Modul CIO-MICRO-CC verbunden sind.

    • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.
    • In-Sight Micro-Vision-Systeme der 8000-Serie unterstützen serielle Kommunikation nur, wenn sie mit dem E/A-Modul des CIO-Micro verbunden sind.

    • Das CIO-WENET-E/A-Modul unterstützt keine serielle Kommunikation.


Kommunikation über TCP/IP

Ein In-Sight-Sensor kann als TCP/IP Client-Gerät definiert werden, das für den Austausch von Daten über das Netzwerk eine Verbindung zwischen dem In-Sight Sensor und einem anderen TCP/IP-Gerät öffnet. Nachdem die TCP/IP-Verbindung eingerichtet ist, beginnt EasyBuilder die Kommunikation mit einem anderen TCP/IP-Gerät im Netzwerk.

So konfigurieren Sie einen In-Sight-Sensor für den TCP/IP-Dienst des Client-Geräts:

  1. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.
  2. Wählen Sie im Gruppenfeld Geräte-Setup die Option Andere in der Dropdownliste Gerät aus.
  3. Wählen Sie aus der Dropdownliste Protokoll die Option TCP/IP aus.
  4. Klicken Sie auf die Schaltfläche OK.
  5. Klicken Sie auf die Registerkarte TCP/IP-Einstellungen und geben Sie den Namen des TCP/IP-Dienstgeräts, mit dem die Verbindung hergestellt werden soll, in das Feld Server-Hostname ein.

  6. Geben Sie die Portnummer des TCP/IP-Servers, bei dem die Verbindung zwischen den TCP/IP-Geräten eingerichtet wird, in das Feld Port ein. Die eingegebene Portnummer muss auch auf dem Server zugewiesen sein.

    Hinweis: Eine gültige Portzuweisung ist, mit Ausnahme der für In-Sight-Kommunikationen verwendeten Ports, jede nicht verwendete Nummer zwischen 1 und 65535. Benutzer von In-Sight-Emulatoren sollten immer Portnummern ab 3000 (Standard) zuweisen, um potenzielle Konflikte mit Ports zu vermeiden, die für Dienste auf dem PC reserviert sind.
  7. Geben Sie im Feld Timeout die Anzahl der Millisekunden (100 bis 15000; Standard = 1000) ein, die auf das Einrichten der TCP/IP-Verbindung gewartet werden soll, bevor der Verbindungsversuch abgebrochen wird.

  8. Wählen Sie aus der Dropdownliste „Abschlusszeichen“ eine Zeichenfolge mit Kunden-Abschlusszeichen aus, um ein ASCII-Zeichen (0 bis 255) anzugeben.

    Geschlossen Beschreibungen der Kunden-Abschlusszeichen für Zeichenfolgen
    Abschlusszeichen | Beschreibung
    Zeichenfolge CR+LF (Standard) | Die ASCII-Zeichen 13 (Zeilenumschaltung) und 10 (Zeilenvorschub) werden an die Datenzeichenfolge angehängt.
    Zeichenfolge CR (13) | Das ASCII-Zeichen 13 (Zeilenumschaltung) wird an die Datenzeichenfolge angehängt.
    Zeichenfolge LF (10) | Das ASCII-Zeichen 10 (Zeilenvorschub) wird an die Datenzeichenfolge angehängt.
    Zeichenfolge Nullchar (0) | Das ASCII-Zeichen 0 (Nullchar) wird an die Datenzeichenfolge angehängt.
  9. Nachdem die TCP/IP-Einstellungen eingerichtet sind, klicken Sie auf die Registerkarte Formatausgabezeichenfolge, um die zu übertragenden Daten auszuwählen und zu formatieren.
Hinweis: Das TCP/IP-Protokoll ist ein „sekundäres“ Protokoll und kann einem Job zusätzlich zu einem „primären“ Protokoll hinzugefügt werden. Weitere Informationen finden Sie im Abschnitt „Unterstützte Protokolle“ unter Geräte-Setup.


Kommunikation über UDP

Ein In-Sight-Vision-System kann als UDP-Server oder Client-Gerät konfiguriert werden, das für den Austausch von Daten über das Netzwerk eine Verbindung zwischen dem Vision-System und einem anderen UDP-Gerät öffnet.

User Datagram Protocol (UDP), eine Alternative zu TCP, ist eine verbindungslose Kommunikationsübertragungsmethode, die einen eingeschränkten Dienst bereitstellt, wenn Nachrichten über das Internetprotokoll ausgetauscht werden. Anders als TCP leistet UDP keine Bestätigungen und garantiert nicht die Zustellung. Es werden auch keine Paketsequenzierung bereitgestellt.

So konfigurieren Sie ein Vision-System als Client- oder Server-Gerät für einen UDP-Dienst:

  1. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.
  2. Wählen Sie im Gruppenfeld Geräte-Setup die Option Andere in der Dropdownliste Gerät aus.
  3. Wählen Sie aus der Dropdownliste Protokoll die Option UDP aus.
  4. Klicken Sie auf die Schaltfläche OK.
  5. Jetzt müssen Sie die Registerkarte UDP-Einstellungen konfigurieren und eine Eingabezeichenfolge (falls erforderlich) und eine Ausgabezeichenfolge (falls erforderlich) auswählen.
Geschlossen Registerkarte „UDP-Einstellungen“
Geschlossen Modus

Definiert, ob das In-Sight Vision-System als Client oder Server konfiguriert wird (Client, Client mit Antwort, Server oder Server ohne Antwort; Standard = Client). Im UDP-Kommunikationsmodell ist ein Client ein System, das auf einen Remote-Dienst auf einem anderen Computersystem (dem Server) über ein Netzwerk zugreift, und ein Server ist ein Netzwerkgerät, das Anforderungen für Daten von einem anderen Netzwerkgerät verarbeitet.

  • Client: Das Vision-System überträgt Daten an den angegebenen Server.
  • Client mit Antwort: Das Vision-System überträgt Daten an den angegebenen Server und wartet dann, basierend auf dem im Parameter Timeout festgelegten Zeitlimit, auf eine Antwortnachricht vom Server.
  • Server: Das Vision-System empfängt Daten als der angegebene Server.
  • Server mit Antwort: Das Vision-System empfängt Daten als der angegebene Server und sendet dann eine Antwortnachricht zurück an das Client-Gerät.
Geschlossen Server-Hostname

Definiert den Hostnamen oder die IP-Adresse des UDP-Servers. Wenn der Parameter Modus auf Server oder Server mit Antwort festgelegt ist, wird dieser Parameter deaktiviert.

Geschlossen Port

Definiert die Kommunikations-Portnummer zwischen dem UDP-Server und dem UDP-Gerät. Wenn das In-Sight Vision-System als Server konfiguriert wird und ein Server-Hostname eingegeben wurde, weist der Parameter Port die Portnummer zu diesem Gerät zu. Wenn das Vision-System als Client konfiguriert wird, muss die Portnummer die gleiche sein wie die Portnummer des UDP-Servers.

Geschlossen Timeout

Definiert die Zeit in Millisekunden (100 bis 15000; Standard = 1000), die erforderlich ist, um eine Antwort vom Server-Gerät zu erhalten, wenn eine Nachricht vom Client-Gerät gesendet wird.

Hinweis: Der Parameter Timeout ist nur aktiviert, wenn der Parameter Modus auf Client mit Antwort festgelegt ist.
Geschlossen Registerkarte „Eingabezeichenfolge“

Auf der Registerkarte „Eingabezeichenfolge“ können Sie eine Zeichenfolge definieren, bei der es sich um eine Eingabe von einem anderen Gerät in eine Zeichenfolgeneingabe des EasyBuilder-Werkzeugs handelt, wie z. B. ein Suchzeichenkette-Parameter eines Identifizierungswerkzeugs ID-Codes lesen, 1D-Code lesen, 1D-Codes lesen (1-20), 2D-Code lesen, 2D-Codes lesen (1-20), Postleitzahl lesen oder Text lesen im Schritt Teil inspizieren.

Hinweis: Die Registerkarte Eingabezeichenfolge ist deaktiviert, wenn der Parameter Modus auf Client festgelegt ist.
Geschlossen Eingabename

Wählen Sie im Dropdownmenü die EasyBuilder-Job- oder Werkzeugeigenschaft aus, die eingegeben wird.

Hinweis: Informationen zur Eingabe einer Textzeichenfolge zur Verwendung mit einem Identifizierungswerkzeug über ein externes Gerät wie eine SPS oder einen PC finden Sie im Thema: Eingeben von Daten für Identifizierungswerkzeuge.
Geschlossen Formatausgabezeichenfolge

Auf der Registerkarte „Formatausgabezeichenfolge“ können Sie die Daten definieren, die an den UDP-Server gesendet werden, wenn der Parameter Modus als Client, Client mit Antwort oder Server mit Antwort konfiguriert ist.

Hinweis: Die Registerkarte Formatausgabezeichenfolge ist deaktiviert, wenn der Parameter Modus auf Server festgelegt ist.
Geschlossen Formatzeichenfolge
  1. Klicken Sie auf der Registerkarte Formatausgabezeichenfolge auf die Schaltfläche Formatzeichenfolge. Daraufhin wird das Dialogfeld Formatzeichenfolge geöffnet, in dem Sie die Reihenfolge der gesendeten Daten hinzufügen, anpassen und ändern können.
  2. Klicken Sie im Dialogfeld Formatzeichenkette auf die Schaltfläche Hinzufügen, um das Dialogfeld Select Output Data zu öffnen.
  3. Die Dialogfelder Ausgabedaten auswählen beinhalten die Daten von allen Positions- oder Inspektionswerkzeugen, die Ihrem Job hinzugefügt wurden, und die allgemeinen Job-Ergebnisse. Wählen Sie im Dialogfeld die entsprechenden Daten aus, die vom In-Sight-Sensor gesendet werden sollen, und klicken Sie auf die Schaltfläche OK.
  4. Nachdem Sie die Daten im Dialogfeld Select Output Data ausgewählt haben, wird wieder das Dialogfeld „Formatzeichenkette“ angezeigt.
  5. Sie können die Zeichenfolgen bearbeiten und/oder die Reihenfolge der zu sendenden Daten ändern, indem Sie die Daten in der Liste auswählen und die gewünschte Reihenfolge mit den Schaltflächen Nach oben oder Nach unten festlegen. Klicken Sie auf OK, nachdem Sie die gewünschten Änderungen an der Zeichenfolge vorgenommen haben.
  6. Nachdem die Zeichenfolge formatiert wurde, werden die Ausgabedaten gesendet, sobald die Jobausführung vom Sensor abgeschlossen wird.
Hinweis: Das UDP-Protokoll ist ein „sekundäres“ Protokoll und kann einem Job zusätzlich zu einem „primären“ Protokoll hinzugefügt werden. Weitere Informationen finden Sie im Abschnitt „Unterstützte Protokolle“ unter Geräte-Setup.


Kommunikation über POWERLINK

Dieses Protokoll ist nur in In-Sight Vision-Systemen mit In-Sight Firmware 4.x.x verfügbar und nicht in In-Sight Vision-Systemen mit In-Sight Firmware 5.1.0 und höher. Beachten Sie die Firmwareversionen für eine vollständige Liste aller Modelle und unterstützter Firmwareversionen.

Ein In-Sight-Vision-System kann zur Kommunikation mit dem POWERLINK-Netzwerk konfiguriert werden.

Führen Sie zur Kommunikation über POWERLINK zunächst folgende Schritte aus:

  1. Fahren Sie mit dem Anwendungsschritt Kommunikation fort. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.
  2. Wählen Sie im Gruppenfeld Geräte-Setup in der Dropdownliste Gerät die Option SPS.
  3. Wählen Sie aus der Dropdownliste Hersteller die Option B&R aus.
  4. Wählen Sie aus der Dropdownliste Protokoll die Option POWERLINK aus.
  5. Klicken Sie auf die Schaltfläche OK.

Nachdem Sie diese Einstellungen aktiviert haben, können die Registerkarten für Einstellungen, Formateingabedaten und Formatausgabedaten konfiguriert werden.

  • Geschlossen POWERLINK Registerkarte „Einstellungen“

    Aktiviert: Aktiviert POWERLINK auf dem In-Sight-Vision-System (Standard = deaktiviert).

    Knoten-ID: Definiert die Knoten-ID (1-239; Standard = 1) für das In-Sight-Vision-System im POWERLINK-Netzwerk. Dieses Steuerelement ist aktiviert, wenn das Kontrollkästchen Aktiviert markiert ist. Die Knoten-ID kann gemeinsam mit der NAT-IP-Adresse des POWERLINK-Netzwerks verwendet werden, um mit anderen Geräten außerhalb des POWERLINK-Netzwerks zu kommunizieren. Beispiel: Die Standard NAT-IP-Adresse lautet 192.168.101.0. Zum Kommunizieren mit einem In-Sight-Vision-System mit der Konten-ID 26 kombinieren Sie die NAT-IP-Adresse mit der Knoten-ID: 192.168.101.26.

    Hinweis: Das In-Sight-Vision-System muss zum Aktivieren des POWERLINK-Protokolls neu gestartet werden.
  • Registerkarte Eingang/Ausgang formatieren
Hinweis:
  • Weitere Informationen finden Sie in der In‑Sight® Explorer-Hilfe.
  • Klicken Sie optional erneut auf die Schaltfläche Gerät hinzufügen, um dem Job ein weiteres „sekundäres“ Protokoll hinzuzufügen. Weitere Informationen finden Sie im Abschnitt „Unterstützte Protokolle“ unter Geräte-Setup.


Eingeben von Daten für Identifizierungswerkzeuge

Gehen Sie folgendermaßen vor, um eine Zeichenfolge zur Verwendung mit einem Identifizierungswerkzeug über ein externes Gerät wie eine SPS oder einen PC einzugeben:

  1. Fügen Sie ein ID-Codes lesen, 1D-Code lesen, 1D-Codes lesen (1-20), 2D-Code lesen, 2D-Codes lesen (1-20), Postleitzahl lesen oder ein Text lesen Identifizierungswerkzeug im Schritt Teil inspizieren hinzu.
  2. In der Registerkarte Einstellungen des ID-Codes lesen, 1D-Code lesen, 1D-Codes lesen (1-20), 2D-Code lesen, 2D-Codes lesen (1-20), Postleitzahl lesen oder Text lesen Werkzeugs, stellen Sie Modus auf Übereinstimmende Zeichenfolge; im Falle des Text lesen Werkzeugs, stellen Sie den Modus auf Überprüfen oder Lesen und überprüfen.
  3. Wählen Sie den Anwendungsschritt Kommunikation.
  4. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.
  5. Wählen Sie im Gruppenfeld Geräte-Setup die Option Andere in der Dropdownliste Gerät aus.
  6. Wählen Sie in der Dropdownliste Protokoll die Option Text (seriell) aus.
  7. Klicken Sie auf die Schaltfläche OK.
  8. Klicken Sie auf die Registerkarte Eingabezeichenfolge.
  9. Wählen Sie in der Dropdownliste Eingabename die Eingabe Übereinstimmende Zeichenfolge des gewünschten Werkzeugs aus. EasyBuilder durchsucht den Job automatisch und schließt alle im Job definierten Werkzeug-Ergebnisse vom Typ Übereinstimmende Zeichenfolge ein.

  10. Klicken Sie auf die Registerkarte Serielle Anschlusseinstellungen, und passen Sie ggf. die Einstellungen für Ihre Anwendung an.

    Hinweis:

    • Die Optionen in Serielle Anschlusseinstellungen variieren je nach In-Sight-Modell und dem entsprechenden E/A-Modul. Wenn mit einem unterstützten E/A-Modul verbunden, klicken Sie zuerst auf die Schaltfläche E/A-Modul für das Öffnen des Dialogfelds E/A-Modulkonfiguration und konfigurieren Sie das E/A-Modul.

    • In-Sight Micro 1000-Vision-Systeme unterstützen serielle Kommunikation nur, wenn sie mit dem E/A-Modul CIO-MICRO-CC verbunden sind.

    • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.
    • In-Sight Micro-Vision-Systeme der 8000-Serie unterstützen serielle Kommunikation nur, wenn sie mit dem E/A-Modul des CIO-Micro verbunden sind.

    • Das CIO-WENET-E/A-Modul unterstützt keine serielle Kommunikation.

  11. Klicken Sie auf die Registerkarte Formatausgabezeichenfolge und anschließend auf Formatzeichenfolge. Daraufhin wird das Dialogfeld Formatzeichenfolge geöffnet, in dem das Ergebnis Ihres Werkzeugs ausgewählt und formatiert werden kann.

    Hinweis: Solange die zu überprüfende Zeichenfolge nicht über das externe Gerät eingegeben wurde, führt ID-Codes lesen oderText lesen zu einem Schlechtteil, und im Feld Übereinstimmende Zeichenfolge wird TRIG angezeigt.
  12. Klicken Sie im Dialogfeld Formatzeichenkette auf die Schaltfläche Hinzufügen, um das Dialogfeld Select Output Data zu öffnen.
  13. Die Dialogfelder Ausgangsdaten auswählen beinhalten die Daten von allen Positions- oder Inspektionswerkzeugen, die Ihrem Job hinzugefügt wurden und die allgemeinen Job-Ergebnisse. Wählen Sie im Dialogfeld die entsprechenden Daten aus, die vom In-Sight-Sensor gesendet werden sollen, und klicken Sie auf die Schaltfläche OK.
  14. Nachdem Sie die Daten im Dialogfeld Select Output Data ausgewählt haben, wird wieder das Dialogfeld "Formatzeichenkette" angezeigt.
  15. Sie können die Zeichenfolgen bearbeiten und/oder die Reihenfolge der zu sendenden Daten ändern, indem Sie die Daten in der Liste auswählen und die gewünschte Reihenfolge mit den Schaltflächen Nach oben oder Nach unten festlegen. Klicken Sie auf OK, nachdem Sie die gewünschten Änderungen an der Zeichenfolge vorgenommen haben.
  16. Nachdem die Zeichenfolge formatiert wurde, werden die Ausgabedaten gesendet, sobald die Jobausführung vom Sensor abgeschlossen wird.
  17. Sobald der In-Sight-Sensor Online geschaltet wird, empfängt das Werkzeug die Eingabezeichenfolge, und es wird versucht, die Zeichenfolge im Bild zu lesen und/oder zu überprüfen.


Formatieren von Ausgabezeichenfolgen

  1. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.
  2. Wählen Sie im Gruppenfeld Geräte-Setup in der Dropdownliste Gerät die Option Andere: aus.
  3. Wählen Sie aus der Dropdownliste Protokoll entweder Ethernet Native, Native (seriell), Text (seriell) oder TCP/IP aus.
  4. Klicken Sie auf der Registerkarte Formatausgabezeichenfolge auf die Schaltfläche Formatzeichenfolge. Daraufhin wird das Dialogfeld Formatzeichenfolge geöffnet, in dem Sie die zu sendenden Daten hinzufügen, anpassen und neu anordnen können.
  5. Klicken Sie im Dialogfeld Formatzeichenfolge auf die Schaltfläche Hinzufügen, um das Dialogfeld Ausgabedaten auswählen zu öffnen.
  6. Das Dialogfeld Ausgabedaten auswählen enthält die Daten aus allen dem Job hinzugefügten Positions- oder Inspektionswerkzeugen und die Gesamtergebnisse von Jobs. Wählen Sie im Dialogfeld die Daten aus, die vom In-Sight-Sensor gesendet werden sollen, und klicken Sie auf OK.
  7. Nachdem Sie die Daten im Dialogfeld Ausgabedaten auswählen ausgewählt haben, wird das Dialogfeld Formatzeichenfolge angezeigt.
  8. Sie können die Zeichenfolgen bearbeiten und/oder die Reihenfolge der zu sendenden Daten ändern, indem Sie die Daten in der Liste auswählen und die gewünschte Reihenfolge mit den Schaltflächen Nach oben oder Nach unten festlegen. Klicken Sie auf OK, nachdem Sie die gewünschten Änderungen an der Zeichenfolge vorgenommen haben.
  9. Nachdem die Zeichenfolge formatiert wurde, werden die Ausgabedaten gesendet, sobald die Jobausführung vom Sensor abgeschlossen wird.


Kommunikation mit einer Rockwell ControlLogix SPS

Dieser Abschnitt beschreibt, wie die Daten zwischen einem Vision-System und einer ControlLogix oder CompactLogix SPS auf einem EtherNet/IP-Netzwerk mit Rockwell RSLogix 5000 Software übermittelt werden können.

Einrichten des In-Sight-Vision-Systems in der E/A-Struktur von RSLogix

Konfigurieren von In-Sight-Vision-Systemen für die SPS-Kommunikation

In-Sight-Vision-System – Beispiel für das Laden eines Jobs von der RSLogix-SPS


Einrichten des In-Sight Vision-Systems in der E/A-Struktur von RSLogix

Die Schritte für das Konfigurieren einer impliziten Verbindung und Datenübertragung hängen von der auf dem Vision-Sensor installierten Firmwareversion und der Version der RSLogix 5000-Software. Ausführliche Informationen erhalten Sie unter Kommunikation mit einer Rockwell ControlLogix SPS in der Hilfe zum In-Sight® Explorer.

Integration von In-Sight-Vision-Systemen in RSLogix 5000 v14-16

Integration von In-Sight-Vision-Systemen in RSLogix 5000 v17-19

Integration von In-Sight-Vision-Systemen in RSLogix 5000 v20

In-Sight-Vision-System – Ein- und Ausgangs-Montageobjekte


Integration von In-Sight Vision-Systemen in RSLogix 5000 v14-16

Dieser Abschnitt beschreibt die Integration von In-Sight Vision-Systemen mit In-Sight 5.2.0 oder höherer Firmware in RSLogix 5000 Version 14-16. Diese Versionen von RSLogix 5000 unterstützen die EDS-Dateien nicht, es muss stattdessen ein generisches ETHERNET-MODUL verwendet werden. Der In-Sight Explorer beinhaltet L5X-Dateien, die zum Kopieren der SPS Controller Tag-Daten nach/von benutzerfreundlichen Programm-Tags verwendet werden können, die Signale in den Vision-Sensoren mit Firmware In-Sight 5.2.x oder höher darstellen.

  1. Öffnen Sie die RSLogix 5000 und laden Sie das Projekt der SPS.

    Hinweis: Die SPS muss Offline sein, damit in RSLogix 5000 Verbindungen hinzugefügt werden können.

  2. Fügen Sie Ihrer Ethernet Kommunikationskarte eine Verbindung hinzu. Unter dem Knoten I/O Configuration, wählen Sie Ethernet Node unter dem Ethernet-Modul, klicken Sie auf das Symbol und wählen Sie die Option New Module aus dem Menü aus.

  3. Wählen Sie aus dem Dialogfeld Select Module Type in der Registerkarte "Catalog" den Module Type Category Filter Communication, Allen-Bradley, wählen Sie den Module Type Vendor Filter ETHERNET-MODULE (Generisches Ethernet-Modul) und klicken Sie dann auf die Schaltfläche Erstellen.

  4. Geben Sie folgendes im Dialogfeld New Module ein:

    • Name und IP-Adresse des In-Sight Vision-Sensors.
    • Die Verbindungsparameter. Bei In-Sight Vision-Sensoren mit Firmwareversion 5.x.x definiert der Abschnitt Objekte Ein-/Ausgangsbaugruppe die Baugruppeninstanz, die konfiguriert werden sollte. Weitere Informationen finden Sie im Thema Rockwell ControlLogix SPS – Firmware In-Sight 5.x.x in der Hilfe zum In-Sight® Explorer.

  5. Nachdem der Vision-Sensor zum RSLogix-Projekt hinzugefügt wurde, kann die L5X-Stufenimport-Datei für das Erstellen der strukturierten Daten für die Verbindung verwendet werden. Gehen Sie zur MainRoutine. Diese ist unter Tasks > MainTask > MainProgram-Ordner im Controller-Organizer-Bereich zu finden.

    Hinweis: Wenn dies ein neues Kontaktplan ist, kann die leere Stufe Null verwendet werden. Soll der Vision-Sensor in ein bereits existierendes Programm integriert werden, empfehlen wir, oben eine Stufe im Kontaktplan hinzuzufügen, damit sichergestellt werden kann, dass aktualisierte Daten aus den Ein- und Ausgangsbaugruppen des Sensors gelesen bzw. dorthin geschrieben werden können, bevor der Rest des Kontaktplans ausgeführt wird.

    1. Klicken Sie innerhalb des Hauptprogramms mit der rechten Maustaste auf eine leere Stufe und wählen Sie die Option Import Rungs... .

    2. Navigieren Sie zur .L5X-Datei; die Dateien befinden sich am folgenden Speicherort: C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

      Importieren Sie die Datei InSightGenEth_11_CopyRung.L5X. Nachdem Sie die Datei ausgewählt haben, klicken Sie auf die Schaltfläche Importieren....

  6. Das Dialogfeld Konfiguration importieren wird für die Änderung der Namen der erstellten Tags verwendet, damit diese mit der Konfiguration übereinstimmen. Das generische Modul erstellt ein einziges Array mit rohen, unstrukturierten Daten für sowohl den Eingang als auch den Ausgang vom Modul. Die Eingangsbaugruppe wird ein zusammenhängendes Array sein, das aus dem Statusblock und dem Array der Inspektionsergebnisse besteht. Die Ausgangsbaugruppe wird ein zusammenhängendes Array sein, das aus dem Steuerungsblock und dem Array der Anwenderdaten besteht. Keine der beiden werden ID-Tags haben. Keine der beiden werden ID-Tags haben.

    Nachdem das Projekt auf die SPS geladen wurde und die Stufe mit den Kopier-Instruktionen zum ersten Mal ausgeführt wird, werden zwei neue Arrays mit den Tags erstellt.

    1. Die generischen Namen der Tags müssen geändert werden. Die oberen zwei Zeilen sind mit einem X markiert und der Name von diesen muss geändert werden.

    2. Durch Klicken im weißen Bereich neben dem Feld Name erscheint ein Pfeil, der ein Dropdown-Menü öffnet, das andere Optionen für die Standardstruktur Name bereitstellt. Die Liste sollte Namen enthalten, die mit dem Namen, der im 4. Schritt angegeben wurde, übereinstimmen - den Namen des In-Sight Vision-Sensors also. Da im unterem Beispiel der gegebene Name In-Sight 2000 war, sollte die Liste In-Sight 2000:I und In-Sight 2000:O enthalten.

      Ersetzen Sie die zwei generischen Namen mit den Optionen im Dropdown-Menü.

    3. Die unteren zwei Zeilen müssen auch bearbeitet werden. Klicken Sie auf den Text des Namens, so dass das Cursor-Symbol erscheint, und ersetzen Sie dann den Text vor "_In" bw. _Out" mit dem Namen des generischen Moduls oder mit einem anderen einfach zu identifizierenden Namen (z.B. "In-Sight 2000" in diesem Beispiel, da es nur einen Vision-Sensor gibt).

      Hinweis: Der in dieser Instanz gegebene Name sollte für jeden Vision-Sensor, der zur E/A-Konfiguration hinzugefügt wird, eindeutig sein. Wenn mehrere Vision-Sensoren eingesetzt werden, müssen diese Schritte für jeden Vision-Sensor befolgt werden, da jede Instanz der erstellten Kopierstufen auf einen spezifischen Vision-Sensor zeigen wird. Deswegen sollten Sie, für eine spätere Fehlerbehebung, Namen verwenden, die man einfach identifizieren kann.

    4. Nachdem der Standardwert jedes Tags geändert wurde, klicken Sie die Schaltfläche OK.

  7. Eine neue, leere Stufe wurde unter der addierten Stufe der MainRoutine hinzugefügt (die leere Stufe kann gelöscht werden).

  8. Das Projekt kann jetzt auf die SPS geladen werden und die SPS kann in Run-Modus gestellt werden.

  9. Nachdem die Stufen, die die Kopier-Instruktionen enthalten, ausgeführt worden sind, werden die neuen Tags in der Controller Tags Tabelle erstellt.

    In diesem Beispiel sind die Tags In-Sight 2000:I und In-Sight 2000:O die rohen Ein- und Ausgangsbaugruppen vom Vision-System, und In-Sight 2000_In und In-Sight 2000_Out werden sowohl die Steuerungs- und Status-Blöcke als auch die Arrays Benutzerdaten und Inspektionsergbenisse beinhalten.


Integration von In-Sight Vision-Systemen in RSLogix 5000 v17-19

Dieser Abschnitt beschreibt die Integration von In-Sight Vision-Systemen mit In-Sight 5.2.0 oder höherer Firmware in RSLogix 5000 Version 17-19. Diese Versionen von RSLogix 5000 unterstützen die EDS-Dateien nicht, es muss stattdessen ein generisches ETHERNET-MODUL verwendet werden. Der In-Sight Explorer beinhaltet L5X-Dateien, die zum Kopieren der SPS Controller Tag-Daten nach/von benutzerfreundlichen Programm-Tags verwendet werden können, die Signale in den Vision-Sensoren mit Firmware In-Sight 5.2.x oder höher darstellen.

  1. Öffnen Sie die RSLogix 5000 und laden Sie das Projekt der SPS.

    Hinweis: Die SPS muss Offline sein, damit in RSLogix 5000 Verbindungen hinzugefügt werden können.

  2. Fügen Sie Ihrer Ethernet Kommunikationskarte eine Verbindung hinzu. Unter dem Knoten I/O Configuration, wählen Sie Ethernet Node unter dem Ethernet-Modul, klicken Sie auf das Symbol und wählen Sie die Option New Module aus dem Menü aus.

  3. Wählen Sie aus dem Dialogfeld Select Module Type in der Registerkarte "Catalog" den Module Type Category Filter Communication, Allen-Bradley, wählen Sie den Module Type Vendor Filter ETHERNET-MODULE (Generisches Ethernet-Modul) und klicken Sie dann auf die Schaltfläche Erstellen.

  4. Geben Sie folgendes im Dialogfeld New Module ein:

    • Name und IP-Adresse des In-Sight Vision-Sensors.
    • Die Verbindungsparameter. Bei In-Sight Vision-Sensoren mit Firmwareversion 5.x.x definiert der Abschnitt Objekte Ein-/Ausgangsbaugruppe die Baugruppeninstanz, die konfiguriert werden sollte. Weitere Informationen finden Sie im Thema Rockwell ControlLogix SPS – Firmware In-Sight 5.x.x in der Hilfe zum In-Sight® Explorer.

  5. Nachdem der Vision-Sensor zum RSLogix-Projekt hinzugefügt wurde, kann die L5X-Stufenimport-Datei für das Erstellen der strukturierten Daten für die Verbindung verwendet werden. Gehen Sie zur MainRoutine. Diese ist unter Tasks > MainTask > MainProgram-Ordner im Controller-Organizer-Bereich zu finden.

    Hinweis: Wenn dies ein neues Kontaktplan ist, kann die leere Stufe Null verwendet werden. Soll der Vision-Sensor in ein bereits existierendes Programm integriert werden, empfehlen wir, oben eine Stufe im Kontaktplan hinzuzufügen, damit sichergestellt werden kann, dass aktualisierte Daten aus den Ein- und Ausgangsbaugruppen des Sensors gelesen bzw. dorthin geschrieben werden können, bevor der Rest des Kontaktplans ausgeführt wird.

    1. Klicken Sie innerhalb des Hauptprogramms mit der rechten Maustaste auf eine leere Stufe und wählen Sie die Option Import Rungs... .

    2. Navigieren Sie zur .L5X-Datei; die Dateien befinden sich am folgenden Speicherort: C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

      Importieren Sie die Datei InSightGenEth_11_CopyRung.L5X. Nachdem Sie die Datei ausgewählt haben, klicken Sie auf die Schaltfläche Importieren....

  6. Das Dialogfeld Konfiguration importieren wird für die Änderung der Namen der erstellten Tags verwendet, damit diese mit der Konfiguration übereinstimmen. Das generische Modul erstellt ein einziges Array mit rohen, unstrukturierten Daten für sowohl den Eingang als auch den Ausgang vom Modul. Die Eingangsbaugruppe wird ein zusammenhängendes Array sein, das aus dem Statusblock und dem Array der Inspektionsergebnisse besteht. Die Ausgangsbaugruppe wird ein zusammenhängendes Array sein, das aus dem Steuerungsblock und dem Array der Anwenderdaten besteht. Keine der beiden werden ID-Tags haben. Keine der beiden werden ID-Tags haben.

    Nachdem das Projekt auf die SPS geladen wurde und die Stufe mit den Kopier-Instruktionen zum ersten Mal ausgeführt wird, werden zwei neue Arrays mit den Tags erstellt.

    1. Die generischen Namen der Tags müssen geändert werden. Die oberen zwei Zeilen sind mit einem X markiert und der Name von diesen muss geändert werden.

      Durch Klicken im weißen Bereich neben dem Feld Name erscheint ein Pfeil, der ein Dropdown-Menü öffnet, das andere Optionen für die Standardstruktur Name bereitstellt. Die Liste sollte Namen enthalten, die mit dem Namen, der im 4. Schritt angegeben wurde, übereinstimmen - den Namen des In-Sight Vision-Sensors also. Da im unterem Beispiel der gegebene Name In-Sight 2000 war, sollte die Liste In-Sight 2000:I und In-Sight 2000:O enthalten.

      Ersetzen Sie die zwei generischen Namen mit den Optionen im Dropdown-Menü.

    2. Die unteren zwei Zeilen müssen auch bearbeitet werden. Klicken Sie auf den Text des Namens, so dass das Cursor-Symbol erscheint, und ersetzen Sie dann den Text vor "_In" bw. _Out" mit dem Namen des generischen Moduls oder mit einem anderen einfach zu identifizierenden Namen (z.B. "In-Sight 2000" in diesem Beispiel, da es nur einen Vision-Sensor gibt).

      3. Hinweis: Der in dieser Instanz gegebene Name sollte für jeden Vision-Sensor, der zur E/A-Konfiguration hinzugefügt wird, eindeutig sein. Wenn mehrere Vision-Sensoren eingesetzt werden, müssen diese Schritte für jeden Vision-Sensor befolgt werden, da jede Instanz der erstellten Kopierstufen auf einen spezifischen Vision-Sensor zeigen wird. Deswegen sollten Sie, für eine spätere Fehlerbehebung, Namen verwenden, die man einfach identifizieren kann.

    3. Nachdem all die Standard-Tagnamen verändert wurden, muss angegeben werden, wo die Tags erstellt werden sollen. Um die Tags in der Controller Tag-Tabelle zu platzieren, klicken Sie mit der rechten Maustaste in en leeren Kasten (hervorgehoben unten) und wählen Sie die Option "Toggle Tag Scope" aus.

    4. Nachdem der Standardwert jedes Tags geändert wurde, klicken Sie die Schaltfläche OK.

  7. Eine neue, leere Stufe wurde unter der addierten Stufe der MainRoutine hinzugefügt (die leere Stufe kann gelöscht werden).

  8. Das Projekt kann jetzt auf die SPS geladen werden und die SPS kann in Run-Modus gestellt werden.

  9. Nachdem die Stufen, die die Kopier-Instruktionen enthalten, ausgeführt worden sind, werden die neuen Tags in der Controller Tags Tabelle erstellt.

    In diesem Beispiel sind die Tags In-Sight 2000:I und In-Sight 2000:O die rohen Ein- und Ausgangsbaugruppen vom Vision-System, und In-Sight 2000_In und In-Sight 2000_Out werden sowohl die Steuerungs- und Status-Blöcke als auch die Arrays Benutzerdaten und Inspektionsergbenisse beinhalten.


Integration von In-Sight Vision-Systemen in RSLogix 5000 v20

Dieser Abschnitt beschreibt die Integration von In-Sight Vision-Systemen mit In-Sight 5.2.0 oder höherer Firmware in RSLogix 5000, Version 20 und höher. Diese Versionen von RSLogix 5000 unterstützen EDS-Dateien. In-Sight Explorer beinhaltet L5X-Dateien, die Tag-Daten in benutzerfreundliche, Programm-Tags speichern, die Signale in den Vision-Sensoren mit Firmware In-Sight 5.2.x oder höher darstellen. Die InSight_11_CopyRung.L5X-Datei wird für Sensoren mit Firmware 5.X verwendet.

  1. Erstellen und fügen Sie ein EDS-Modul in RSlogix5000 hinzu

    1. EDS-Dateien werden mit dem In-Sight Explorer am folgenden Speicherort installiert: C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.2.3\Factory Protocol Description\EDS
    2. Führen Sie das EDS-Installationstool aus dem Dropdown-Menü Tools in RSLogix5000 aus, um die EDS-Datei für den In-Sight 2000 zu installieren.
    3. Im Abschnitt "IO Configuration" in der RSLogix5000, klicken Sie auf den Netzwerk-Knoten und wählen Sie "New Module" aus dem Menü.

    4. Im Dialogfeld "Select Module", öffnen Sie den Knoten "Communications", wählen Sie den In-Sight 2000-xxx aus der Liste und klicken Sie OK.

      Das Dialogfeld wird mit dem Dialogfeld "New Module configuration" ersetzt.

      Geben Sie den Namen des Vision-Sensors, seine IP-Adresse und seine Verbindungsparameter ein, wie oben dargestellt. Sollte es mehrere Vision-Sensoren geben, sollte jeder einen eindeutigen Namen haben. In diesem Beispiel haben wir nur einen Vision-Sensor zu konfigurieren.

      Tipp: Schauen Sie sich die In-Sight Explorer-Hilfedateien bezüglich des EtherNet/IP Objektmodells (Ein- und Ausgangs-Assembly-Bits) an, die mit der Firmwareversion des Vision-Sensors übereinstimmen.

  2. Import Rung

    1. Gehen Sie zur "Main Routine". Diese ist unter Tasks > Main Task > Main Program-Ordner im "Controller Organizer"-Bereich zu finden. Wenn dies ein neuer Kontaktplan ist, kann die leere Stufe Null verwendet werden. Soll der Vision-Sensor in ein bereits existierendes Programm integriert werden, empfehlen wir, oben eine Stufe im Kontaktplan hinzuzufügen, damit sichergestellt werden kann, dass aktualisierte Daten aus den Ein- und Ausgangsbaugruppen des Sensors gelesen bzw. dorthin geschrieben werden können, bevor der Rest des Kontaktplans ausgeführt wird.

    2. Sobald es eine leere Stufe oben im Kontaktplan gibt, klicken Sie mit der rechten Maustaste auf jene Stufe und wählen Sie "Import Rung" im Menü.

    3. Verwenden Sie das Dialogfeld von "Import Rung" für das Durchsuchen des Speicherortes, wo sich dieses Dokument und die zwei zu importierenden Stufen-Dateien befinden. Da der InSight 2000 die Firmware 5.X hat, werden wir die Datei InSight_11_CopyRung.L5X verwenden.

    4. Wenn die entsprechende Datei ausgewählt wurde, klicken Sie auf die Schaltfläche "Import".
    5. Das Dialogfeld "Import Configuration" erscheint mit generischen, zur Tag-Generierung zu verwendenden Namen.

  3. Umbenennen von Tags: Das generische Modul erstellt aus den rohen, unstrukturierten Daten ein einzelnes Array für den Eingang zum und vom Modell. In diesem Beispiel hat das generische Modul In-Sight 2000:I, In-Sight 2000:0 und In-Sight 2000:C (das nicht verwendet wird) erstellt. Die Eingangsbaugruppe wird ein kontinuierliches Array, bestehend aus dem "Status block" und dem "Inspection Results"-Array sein der Ausgangasbaugruppe ein zusammenhängendes Array, bestehend aus dem "Control Block"- und dem "User Data"-Array, beide ohne ID-Tags, sein. Nachdem das Projekt auf die SPS geladen wurde und die Stufe mit den Kopier-Instruktionen zum ersten Mal ausgeführt wird, werden zwei neue Arrays mit den Tags erstellt (und identisch mit den Tags, die Sie sehen würde, falls ein Add-on-profile-Modul zur Verfügung stünde).

      1. Die untersten zwei Zeilen mit einer Flagge links neben dem Tag müssen durch Klicken in den weißen Bereich des Namensfeldes bearbeitet werden. Diese Tags beinhalten die rohen, unstrukturierten Daten der E/A-Baugruppen auf einem In-Sight. Nach dem Klicken des weißen Bereichs wird ein Nach-unten-Pfeil erscheinen.

      2. Wenn Sie auf den Pfeil klicken, zeigt der Pfeil ein Dropdown-Menü mit alternativen Optionen für den Standardnamen an. In dieser Liste werden Sie Namen finden, die mit dem Namen des generischen Moduls übereinstimmen. In unserem Beispiel war der Name des generischen Moduls In-Sight 2000, deswegen erscheinen “In-Sight 2000:I” und “In-Sight 2000:O” in der Liste. Ersetzen Sie beide Zeilen mit dem entsprechenden Namen, der mit dem Namen des generischen Moduls übereinstimmt. Beachten Sie, dass In-Sight 2000:C nicht verwendet wird.

      3. Als nächstes, bearbeiten Sie die oberen zwei Zeilen in der Import Configuration. Klicken Sie auf den Text des Namens, damit der Cursor erscheint. Empfehlenswert ist, alles vor dem “_In” und dem “_Out” mit dem Namen des generischen Moduls oder mit einem einfach zu identifizierenden Namen zu ersetzen. Da dieses Beispiel nur einen Vision-Sensor verwendet, haben wir den Namen “In-Sight 2000” verwendet.

      4. Jetzt, da alle Standard-Tag-Namen verändert wurden, muss angegeben werden, wo die Tags erstellt werden sollen. Überspringt man diesen Schritt, werden die neuen Tags in der Programm-Tag-Tabelle über der Main Routine platziert.

        Um die Tags in der Controller Tag-Tabelle zu platzieren — wie es ein AOP tun würde, falls es zur Verfügung stehen würde — klicken Sie mit der rechten Taste auf das leere Feld neben Import Names, wo das Symbol Controller-Karte fehlt. Diese Bereiche sind in der unteren Bildaufnahme hervorgehoben. Wenn Sie mit der rechten Maustaste in diese Bereiche klicken, wird ein Dropdown-Menü angezeigt, wo "Toggle Tag Scope" ausgewählt werden kann. Dies hat zur Folge, dass in dem vorher noch leer stehenden Kasten jetzt das Symbol Controller-Karte erscheint.

      5. Klicken Sie nach jedem Namen, deren Standardwert geändert wurde, die Schaltfläche OK.

        Tipp: Die Namen In-Sight 2000_In und In-Sight 2000_Out könnten auch andere Namen sein, solang sie für jeden der E/A-Konfiguration hinzugefügten Vision-Sensor eindeutig sind. Wenn mehrere Sensoren eingesetzt werden, müssen diese Schritte für jeden Sensor befolgt werden, da jede Instanz der erstellten Kopie-Stufen, auf einen bestimmten Sensor zeigen wird. Es sollte darauf geachtet werden, dass die Namenswahl späteres Trouble Shooting einfacher machen und nicht für Verwirrung sorgen sollte. Als Beispiel, wenn mehr als ein Sensor eingesetzt wird, könnten die Namen so aussehen: “Leitung_Eins_In-Sight 2000_In” und “Leitung_Eins_In-Sight 2000_Out".

      6. Eine neue, leere Stufe wird der Main Routine hinzugefügt. Diese Stufe kann gelöscht werden.

  4. Laden auf die SPS

    1. Laden Sie das Projekt auf die SPS.

    2. Stellen Sie die SPS in Run-Modus. Nachdem die Stufen mit den Kopierinstruktionen ausgeführt worden sind, werden die neuen Tags in der Programm-Tag-Tabelle erstellt (genauso, wie es im Falle passieren würde, wenn das Add on Profile vorhanden wäre).

      In diesem Beispiel, sind In-Sight 2000:I und In-Sight 2000:O die rohen Ein- und Ausgangsbaugruppen vom Vision-Sensor, und MyCamera_In und MyCamera_Out beinhalten sowohl die Steuerungs- und Statusblock-Daten als auch die UserData- und InspectionResults-Arrays, wie es in der folgenden Tabelle zu sehen ist:


In-Sight Vision-System – Ein- und Ausgangs-Montageobjekte

Weitere Informationen finden Sie in der In‑Sight® Explorer-Hilfe.


Konfigurieren von In-Sight Vision-Systemen für die SPS-Kommunikation

Führen Sie zur Kommunikation mit SPS Steuerung zunächst folgende Schritte aus:

  1. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.
  2. Wählen Sie aus dem Dropdown Gerät im Gruppenfeld Gerät einrichten die Option SPS/Bewegungssteuerung aus.
  3. Wählen Sie im Dropdown-Menü Hersteller den Hersteller der SPS/Bewegungssteuerung. Falls der Hersteller der SPS/Bewegungssteuerung nicht in der Liste enthalten ist, wählen Sie Andere.
  4. Wählen Sie im Dropdown Protokoll das verwendete Kommunikationsprotokoll aus. Die aufgelisteten Kommunikationsprotokolle sind durch die Auswahl von Hersteller bedingt.
  5. Klicken Sie auf die Schaltfläche OK.

Danach können Sie folgendes ausführen:

Triggern über EtherNet/IP

Herstellen der Verbindung mithilfe von Add-On Profile

Abrufen von Daten aus einem In-Sight-Vision-System

Senden von Daten an ein In-Sight-Vision-System


Triggern über EtherNet/IP

Für das Konfigurieren des Triggers des Vision-Sensors der In-Sight 2000-Serie über EtherNet/IP:

  1. Melden Sie sich am Vision-Sensor an.
  2. Stellen Sie im Schritt Bild einrichten Triggertyp auf Industrial Ethernet.

  3. Im Schritt Kommunikation:

    1. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.
    2. Wählen Sie aus dem Dropdown Gerät im Gruppenfeld Gerät einrichten die Option SPS/Bewegungssteuerung aus.
    3. Wählen Sie im Dropdown-Menü Hersteller den Hersteller der SPS/Bewegungssteuerung. Falls der Hersteller der SPS/Bewegungssteuerung nicht in der Liste enthalten ist, wählen Sie Andere.
    4. Wählen Sie im Dropdown Protokoll das verwendete Kommunikationsprotokoll aus. Die aufgelisteten Kommunikationsprotokolle sind durch die Auswahl von Hersteller bedingt.
    5. Klicken Sie auf die Schaltfläche OK.

  4. Schalten Sie das In-Sight-Vision-System Online.

  5. In den E/A-Baugruppen-Tags auf der SPS, stellen Sie das Trigger Enable-Bit auf Hoch und stellen Sie das Trigger-Bit auf Hoch zum Triggern (referenzierte Bits sind in gelb hervorgehoben).


Herstellen der Verbindung mithilfe von Add-On Profile

Wenn in Ihrem RSLogix-Projekt bereits ein Vision-System mit der EDS-Datei eingerichtet wurde, können Sie das EDS-Profil mit dem neuen AOP-Profil aktualisieren.Weitere Informationen finden Sie in der In‑Sight® Explorer-Hilfe.


Daten empfangen von In-Sight Vision-Sensoren der 2000-Serie

Abrufen von Daten aus einem In-Sight Vision-System

Einrichten der Kommunikation zwischen dem In-Sight-Vision-System und SPS:

  1. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.
  2. Wählen Sie im Gruppenfeld Geräte-Setup in der Dropdownliste Gerät die Option SPS/Bewegungssteuerung.
  3. Wählen Sie in der Dropdownliste Hersteller den Hersteller der SPS/Bewegungssteuerung. Falls der Hersteller der SPS/Bewegungssteuerung nicht in der Liste enthalten ist, wählen Sie Andere.
  4. Wählen Sie in der Dropdownliste Protokoll das verwendete Kommunikationsprotokoll aus. Die aufgelisteten Kommunikationsprotokolle sind durch die Auswahl von Hersteller bedingt.
  5. Klicken Sie auf die Schaltfläche OK.

Einrichten der Daten für die Kommunikation:

Daten aus EasyBuilder-Jobs wie individuelle Toolergebnisse oder Ergebnisse ganzer Jobs (nur Ausgang) können über Ethernet/IP übertragen werden. Eingangsdaten werden gelesen, nachdem der Sensor ein Bild aufgenommen hat, und die Ausgangsdaten werden gesendet, nachdem der Sensor die Jobausführung abgeschlossen hat.

  6. Klicken Sie entweder auf die Registerkarte Formateingabedaten oder Formatausgabedaten.
  7. Klicken Sie auf die Schaltfläche Hinzufügen, um das Dialogfeld Select Input Data bzw. Select Output Data zu öffnen.
  8. Das Dialogfeld Eingabedaten auswählen oder Ausgabedaten auswählen enthält die Daten aller dem Job hinzugefügten Positions- oder Inspektionswerkzeuge und die Gesamtergebnisse des Jobs (nur Ausgang). Wählen Sie im Dialogfeld die entsprechenden Daten aus, die vom (oder an den) In-Sight-Sensor gesendet werden sollen, und klicken Sie auf OK.
  9. Nachdem Sie die Daten hinzugefügt haben, können Sie den Standarddatentyp der gewählten Daten durch Auswahl eines anderen Datentyps im Dropdown Datentyp ändern.

    10. Hinweis: Wenn Sie im Dropdown Datentyp die Option Zeichenfolge auswählen, wird das Steuerelement Gesamtgröße (Byte) aktiviert, sodass Sie die Zeichenfolgenlänge durch Auswahl der korrekten Anzahl von Byte festlegen können.

  10. Sie können die Reihenfolge der zu sendenden oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und die gewünschte Reihenfolge mit den Schaltflächen Nach oben oder Nach unten festlegen.
  11. Schalten Sie das In-Sight-Vision-System Online.
  12. Triggern Sie das System.

  13. Die Daten sollten jetzt im Knoten Controller -> Program Tags von RSLogix 5000 angezeigt werden.


Daten senden an In-Sight Vision-Sensoren der 2000-Serie

Senden von Daten an ein In-Sight Vision-System

Einrichten der Kommunikation zwischen dem In-Sight-Vision-System und SPS:

  1. Klicken Sie im Gruppenfeld Kommunikation auf die Schaltfläche Gerät hinzufügen.
  2. Wählen Sie im Gruppenfeld Geräte-Setup in der Dropdownliste Gerät die Option SPS/Bewegungssteuerung.
  3. Wählen Sie in der Dropdownliste Hersteller den Hersteller der SPS/Bewegungssteuerung. Falls der Hersteller der SPS/Bewegungssteuerung nicht in der Liste enthalten ist, wählen Sie Andere.
  4. Wählen Sie in der Dropdownliste Protokoll das verwendete Kommunikationsprotokoll aus. Die aufgelisteten Kommunikationsprotokolle sind durch die Auswahl von Hersteller bedingt.
  5. Klicken Sie auf die Schaltfläche OK.

Daten aus EasyBuilder-Jobs wie individuelle Toolergebnisse oder Ergebnisse ganzer Jobs (nur Ausgang) können über Ethernet/IP übertragen werden. Eingangsdaten werden gelesen, nachdem der Sensor ein Bild aufgenommen hat, und die Ausgangsdaten werden gesendet, nachdem der Sensor die Jobausführung abgeschlossen hat.

So formatieren Sie die Daten:

  1. Klicken Sie entweder auf die Registerkarte Formateingabedaten oder Formatausgabedaten.
  2. Klicken Sie auf die Schaltfläche Hinzufügen, um das Dialogfeld Select Input Data bzw. Select Output Data zu öffnen.
  3. Das Dialogfeld Eingabedaten auswählen oder Ausgabedaten auswählen enthält die Daten aller dem Job hinzugefügten Positions- oder Inspektionswerkzeuge und die Gesamtergebnisse des Jobs (nur Ausgang). Wählen Sie im Dialogfeld die entsprechenden Daten aus, die vom (oder an den) In-Sight-Sensor gesendet werden sollen, und klicken Sie auf OK.

  4. Nachdem Sie die Daten hinzugefügt haben, können Sie den Standarddatentyp der gewählten Daten durch Auswahl eines anderen Datentyps im Dropdown Datentyp ändern.

    Hinweis: Wenn Sie im Dropdown Datentyp die Option Zeichenfolge auswählen, wird das Steuerelement Gesamtgröße (Byte) aktiviert, sodass Sie die Zeichenfolgenlänge durch Auswahl der korrekten Anzahl von Byte festlegen können.
  5. Sie können die Reihenfolge der zu sendenden oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und die gewünschte Reihenfolge mit den Schaltflächen Nach oben oder Nach unten festlegen.
  6. Schalten Sie das In-Sight-Vision-System Online.
  7. Öffnen Sie in RSLogix 5000 das Dialogfeld „Program Tags“, und ändern Sie den Wert der Tags InSight_Top:O.Data[1] und InSight_Top:O.Data[2].

  8. Ermitteln Sie, ob ein Handshake für die Benutzerdaten erforderlich ist. Wenn das Umgehen der Benutzerdaten aktiviert ist, entspricht der Datenaustausch den Kameras der Version 4.x.x. Bei deaktivierter Umgehung der Benutzerdaten (Standard) fügt dieses neue Bit den zwischen SPS und In-Sight Vision-Sensor ausgetauschten Daten einen zusätzlichen Handshake hinzu. Zum Anzeigen der Daten in der Tabelle sind weitere Schritte erforderlich.

    1. Wenn das Umgehen der Benutzerdaten im Dialogfeld mit den Netzwerkeinstellungen für die Kamera aktiviert ist, werden die Werte in EasyBuilder unmittelbar aktualisiert.

    2. Wenn das Umgehen der Benutzerdaten im Dialogfeld mit den Netzwerkeinstellungen für die Kamera NICHT aktiviert ist:

      1. Legen Sie den Tag für Benutzerdaten fest. Das SetUserData-Bit ist ein benanntes Tag, in diesem Beispiel „InSight_Top:O.Control.SetUserData“.
      2. Löschen Sie das oben angegebene Tag für Benutzerdaten nach Erhalt des Bits für die Bestätigung der Benutzerdaten. Das SetUserData-Bit ist ein benanntes Tag, in diesem Beispiel: InSight_Top:I.Status. SetUserDataAck.


In-Sight Vision-System – Beispiel für Job laden von der RSLogix SPS

Weitere Informationen finden Sie in der In‑Sight® Explorer-Hilfe.


Integration von Universal Robots – TCP/IP

Cognex 2D-Vision-Systeme werden mit dem Plug-In „Cognex In-Sight 2D Robot Guidance“ in Universal Robots-Controller integriert. Dieses Plug-In wird im Programm „Universal Robots PolyScope“ installiert. Mit diesem Plug-In können Sie die Hand-Auge-Kalibrierung einrichten und die Positionsdaten (Stellungsdaten) vom Vision-System abrufen, damit der Roboter in die richtige Zielposition fährt und das Objekt greifen kann. Sie können Antworten vom Vision-System programmieren, z. B. wenn ein Job besteht oder fehlschlägt. Sie können auch eine Referenzstellung für den Roboter einrichten, wenn das Vision-System auf dem Roboterarm angebracht ist.

Cognex 2D-Vision-Systeme kommunizieren über eine TCP/IP-Verbindung mit dem Universal Robots-Controller. Das Vision-System hostet den TCP-Server und der Roboter ist der Client. Diese Geräte müssen sich im gleichen Netzwerk befinden.

Hinweis: Diese Funktion wird auf Vision-Sensoren der In-Sight 2000-Serie nicht unterstützt.

Die folgenden Universal Robots-Modelle werden unterstützt:

  • UR3
  • UR5
  • UR10
  • e-Serie

Das Plug-In „Cognex In-Sight 2D Robot Guidance“ wird nur in Universal Robots PolyScope ab Version 3.5.1 unterstützt.

Zur Hand-Auge-Kalibrierung und zur Einrichtung der Roboterführungsanwendung müssen folgende Aufgaben ausgeführt werden:

  1. Installation des Plug-Ins „Cognex In-Sight 2D Robot Guidance“
  2. Einlernen des Tool Center Points (TCP) des Roboters
  3. Konfiguration des Vision-Systems für die Kalibrierung
  4. Verbindungsherstellung zum Vision-System und Durchführung der Hand-Auge-Kalibrierung
  5. Erstellung eines Bauteil-Jobs und Import der Kalibrierung
  6. Einrichtung der Vision-System-Stellung
  7. Programmierung des Universal Robots-Roboters

Installation des URCap-Cognex-Plug-Ins

Einlernen des Tool Center Points (TCP) des Roboters

Konfiguration des Vision-Systems für die Kalibrierung

Verbindungsherstellung zum Vision-System und Durchführung der Hand-Auge-Kalibrierung

Erstellung eines Bauteil-Jobs und Import der Kalibrierung

Einrichtung der Vision-System-Stellung

Programmierung des Universal Robots-Roboters


Installation des URCap-Cognex-Plug-Ins

Installation des Plug-Ins „Cognex In-Sight 2D Robot Guidance“

  1. Laden Sie unter cognex.com/urcaps die Datei Cognex URCaps v1.3.0.urcap herunter.
  2. Kopieren Sie die Datei auf einen USB-Stick.
  3. Öffnen Sie das PolyScope-Programm. Das Hauptmenü wird angezeigt:

  4. Schließen Sie den USB-Stick rechts an das Universal Robots Teach Pendant an.
  5. Öffnen Sie im Hauptmenü Setup Robot > URCaps (Roboter einrichten > URCaps). Klicken Sie auf die Schaltfläche (+), um die URCap-Cognex-Plug-In-Datei hinzuzufügen. Diese Datei wird als Cognex In-Sight Robot Guidance (Cognex In-Sight-Roboterführung) angezeigt.

Mit dem Plug-In „Cognex In-Sight 2D Robot Guidance“ werden folgende Funktionen zu PolyScope hinzugefügt:

  • Menüelement Cognex auf der Registerkarte „Programm“ (Program > Structure > URCaps > Cognex Camera Pose – Programm > Struktur > URCaps > Cognex-Kamerastellung).
  • Menüelement Cognex auf der Registerkarte „Installation“.
  • Knoten CGX_result:=CameraPose in der Baumstruktur für das Roboterprogramm.
  • Neue Variable CGX_result auf der Registerkarte Program > Command (Programm > Befehl). Mit dieser Variablen werden die Stellungsdaten für das Vision-System, die während des Triggerns vom Vision-System gesendet werden, gespeichert.


Einlernen des Tool Center Points (TCP) des Roboters

Der Tool Center Point (TCP, „Werkzeugmittelpunkt“) ist der Teil des Roboters, der mit dem Werkteil in Berührung kommt. Der TCP muss eingelernt werden, damit der Roboter sich aus verschiedenen Winkeln („Wegpunkten“) in die gleiche Position bringen kann.

Der TCP muss sich im Sichtfeld des Vision-Systems befinden.

Hinweis: Dieses Verfahren läuft im Rahmen von PolyScope ab und wurde der Bequemlichkeit halber in dieses Dokument aufgenommen.
  1. Öffnen Sie PolyScope.
  2. Öffnen Sie im Hauptmenü Program Robot (Roboter programmieren). Das Fenster „New Program“ (Neues Programm) wird geöffnet.

  3. Klicken Sie auf Pick and Place (Greifen und positionieren).

  4. Klicken Sie auf Installation > TCP Configuration (Installation > TCP-Konfiguration).

  5. Zum Einlernen des TCP können Sie ihn auf verschiedene Arten manuell messen:

    • Wenn sich der TCP direkt auf der Z-Achse befindet: Messen Sie den Abstand zwischen dem TCP und dem Mittelpunkt des Werkzeugflanschs (in Millimetern) für die Z-Achse. Geben Sie die Abmessung in das Feld Z ein.
    • Wenn sich der TCP NICHT direkt auf der Z-Achse befindet: Messen Sie den Abstand zwischen dem TCP und dem Mittelpunkt des Werkzeugflanschs (in Millimetern) für die X-, die Y- und die Z-Achse. Geben Sie die Abmessung in das Feld X, Y bzw. Z ein.

    6. Weitere Informationen können Sie dem PolyScope-Handbuch entnehmen. Sie können dieses Handbuch auf der Website von Universal Robots herunterladen.


Konfiguration des Vision-Systems für die Kalibrierung

Mit diesem Verfahren wird:

  • das Muster des Roboter-TCP trainiert, damit es vom Vision-System gefunden wird,
  • ein Roboter-Werkzeug hinzugefügt,
  • ein Name für die .CXD-Kalibrierungsdatei eingegeben. Diese Datei wird nach dem Abschluss der Kalibrierung durch das Plug-In „Cognex In-Sight 2D Robot Guidance“ mit Kalibrierungsdaten befüllt.
  1. Stellen Sie in EasyBuilder eine Verbindung zum Vision-System her und erstellen Sie einen neuen Job.
  2. Klicken Sie auf Bild einrichten. Überprüfen Sie, dass sich der TCP im Sichtfeld des Vision-Systems befindet.
  3. Stellen Sie unter „Aufnahmeeinstellungen bearbeiten“ den Trigger auf Manuell.

  4. Passen Sie die Bildeinstellungen so an, dass ein scharfes und gut belichtetes Bild erzielt wird.
  5. Klicken Sie auf Teil suchen und fügen Sie die gewünschten Werkzeuge für die Suche des TCP am Robotergreifarm hinzu.
  6. Markieren Sie das Werkzeug PatMax-Muster und klicken Sie auf Einstellungen.
  7. Stellen Sie das Fadenkreuz des Werkzeugs mit den Einstellungen Horizontaler Versatz und Vertikaler Versatz so ein, dass es sich mittig auf dem TCP befindet.

  8. Klicken Sie anschließend auf Teil inspizieren > Kalibrierungswerkzeuge > Roboter, um das Kalibrierungswerkzeug „Roboter“ hinzuzufügen.

  9. Klicken Sie auf Hinzufügen.
    Hinweis: Dieses Werkzeug verwendet auch Smart Features. Sie können daher andere Funktionen (z. B. Kreise) zur Verknüpfung mit dem Kalibrierungswerkzeug „Roboter“ verwenden.
  10. Klicken Sie im Bild auf das Fadenkreuz für das Werkzeug, mit dem der TCP definiert wird. Klicken Sie anschließend auf OK. Das Roboter-Werkzeug wird auf der Registerkarte „Ergebnisse“ der Palette angezeigt. Es ist mit dem Muster-Werkzeug verknüpft.

  11. Wählen Sie das Kalibrierungswerkzeug Roboter in der Werkzeugpalette aus (Standardname: Calib_1).
  12. Klicken Sie unter „Werkzeug bearbeiten“ auf die Registerkarte Einstellungen.

  13. Geben Sie einen Dateinamen für die .CXD-Kalibrierungsdatei ein. Aktivieren Sie das Kontrollkästchen Datum/Uhrzeit anhängen, wenn das aktuelle Datum und die aktuelle Uhrzeit an den Dateinamen angehängt werden sollen. Im Feld Vollständiger Name wird der vollständige Dateiname angezeigt.
  14. Schalten Sie das Vision-System online. Dies ist notwendig, damit das Vision-System mit dem Roboter kommunizieren kann.
  15. Speichern Sie den Job mit einem Namen, aus dem hervorgeht, dass es sich um einen Kalibrierungsjob handelt. Wenn die Kalibrierung im Plug-In „Cognex In-Sight 2D Robot Guidance“ wiederholt werden muss, können Sie den Job wiederverwenden.


Verbindungsherstellung zum Vision-System und Durchführung der Hand-Auge-Kalibrierung

Die Hand-Auge-Kalibrierung wird mit dem Plug-In „Cognex In-Sight 2D Robot Guidance“ durchgeführt. Hiermit wird der Arbeitsbereich im Sichtfeld des Vision-Systems bestimmt, durch den der Bereich festgelegt wird, in dem der Roboter ein Objekt greifen wird. Mit dem Plug-In wird eine Kalibrierungsdatei (.CXD) erstellt, die später in den Hauptjob importiert wird.

Legen Sie am Anfang der Kalibrierung drei Punkte fest, durch die die Höhe und die Breite des Arbeitsbereichs bestimmt wird.

  1. Öffnen Sie im PolyScope-Hauptmenü Program > Robot > Installation > Cognex (Programm > Roboter > Installation > Cognex). Das Cognex-Fenster wird geöffnet.
  2. Geben Sie unter Connection (Verbindung) im Feld IP Address (IP-Adresse) die IP-Adresse des Vision-Systems ein. Der Name des Vision-Systems wird unter dieser Adresse angezeigt.

    Beachten Sie folgende Hinweise zur Fehlerbehebung, wenn die Verbindung fehlschlägt:

    Angezeigter Fehler | Abhilfemaßnahme
    Make sure the camera is online and the proper job file is loaded. (Ist die Kamera online und die richtige Job-Datei geladen?) | Überprüfen Sie in In-Sight Explorer, dass die Kamera online ist.
    The format of the IP address is invalid (example address: 192.168.0.1). (Das Format der IP-Adresse ist ungültig; Beispieladresse: 192.168.0.1) | Überprüfen Sie in der Roboter-Software, dass die richtige IP-Adresse für die Kamera angegeben wurde.
    Timeout reached. Make sure the network adapter is enabled in Setup Robot Network. (Zeitüberschreitung. Überprüfen Sie, dass die Netzwerkkarte in der Einrichtung des Roboternetzwerks aktiviert ist.) | Überprüfen Sie in der Roboter-Software, dass sich der Roboter im richtigen Netzwerk befindet.
  3. Betrachten Sie den Arbeitsbereich, in dem sich das vom Roboter zu greifende Objekt befinden wird, und notieren Sie die Größe des Bereichs. Die Abbildung unten zeigt Beispielpunkte für Breite und Höhe.
    Hinweis: In Schritt 4 bis 6 unten können Sie vor dem Klicken auf OK prüfen, dass das Vision-System den TCP immer noch sehen kann, indem manuell ein Bild in In-Sight EasyBuilder ausgelöst wird.

  4. Zuerst wird die Breite des Arbeitsbereichs definiert. Klicken Sie neben „(1) Work Plane Corner“ (Arbeitsbereichsecke) auf die Schaltfläche Set Point (Punkt festlegen). Die Registerkarte Move (Bewegen) wird angezeigt. Bewegen Sie den Roboter mit der Steuerung in die erste Ecke des Arbeitsbereichs und klicken Sie auf OK. Neben der ersten Schaltfläche Set Point (Punkt festlegen) im Cognex-Fenster wird ein grüner Haken angezeigt.

  5. Klicken Sie neben „(2) Work Plane Corner“ (Arbeitsbereichsecke) auf die Schaltfläche Set Point (Punkt festlegen). Die Registerkarte Move (Bewegen) wird erneut angezeigt. Bewegen Sie den Roboter mit der Steuerung in die zweite Ecke des Arbeitsbereichs und klicken Sie auf OK. Neben der zweiten Schaltfläche Set Point (Punkt festlegen) im Cognex-Fenster wird ein grüner Haken angezeigt.

  6. Als nächstes wird mit dem dritten Punkt die Höhe definiert. Klicken Sie neben „(3) Work Plane Edge“ (Arbeitsbereichskante) auf die Schaltfläche Set Point (Punkt festlegen). Die Registerkarte Move (Bewegen) wird erneut angezeigt. Bewegen Sie den Roboter mit der Steuerung zur gegenüberliegenden Kante des Arbeitsbereichs und klicken Sie auf OK. Neben der dritten Schaltfläche Set Point (Punkt festlegen) im Cognex-Fenster wird ein grüner Haken angezeigt. Width (Breite) und Height (Höhe) werden angezeigt.

    Die Schaltfläche Start Calibration (Kalibrierung starten) ist jetzt aktiv.

  7. Überprüfen Sie vor dem Beginn der Kalibrierung Höhe und Breite erneut auf Richtigkeit.
  8. Klicken Sie zum Start der Kalibrierung auf Start Calibration (Kalibrierung starten). Nach dem Abschluss der Kalibrierung wird folgende Meldung angezeigt: Calibration has finished (Kalibrierung wurde abgeschlossen).
  9. Klicken Sie auf Start Program (Programm starten) oder Continue (Fortfahren), um das Fenster zu schließen.

Während der Kalibrierung geschieht Folgendes:

  • Das Roboterprogramm bewegt den Roboter zu 15 Punkten im Sichtfeld und überträgt die Koordinaten an das Vision-System.
  • Das Vision-System nimmt ein Bild auf und bestimmt die TCP-Position.
  • Das Roboterprogramm bildet die TCP-Koordinaten auf die Pixelkoordinaten des Vision-Systems ab.

Nach dem Abschluss der Kalibrierung führt das Plug-In „Cognex In-Sight 2D Robot Guidance“ folgende Schritte aus:

  • Es wird eine Meldung an das Roboter-Werkzeug des Kalibrierungsjobs, den Sie vorher erstellt haben, gesendet.
  • Eine Kalibrierungsdatei mit dem Dateinamen, den Sie im Kalibrierungsjob eingegeben haben, und der Dateiendung .CXD wird erstellt. Diese Kalibrierung wird in den Hauptjob importiert. Dort wird auch das Greifen des Objekts durch den Roboter trainiert.
Hinweis: Wenn das Vision-System auf dem Roboterarm angebracht ist, darf das trainierte Objekt erst dann bewegt werden, wenn die Referenzstellung für den Roboter eingestellt wurde. Die Referenzstellung des Roboters wird eingestellt, nachdem die Stellung des Vision-Systems festgelegt wurde.


Erstellung eines Bauteil-Jobs und Import der Kalibrierung

Erstellen Sie einen Hauptjob, um das vom Roboter zu greifende Teil zu trainieren und die Kalibrierung zu importieren, die mit dem Plug-In „Cognex In-Sight 2D Robot Guidance“ erstellt wurde.

  1. Erstellen Sie einen neuen Job und stellen Sie eine Verbindung zum Vision-System her. Überprüfen Sie, dass sich das zu greifende Teil im Sichtfeld des Vision-Systems befindet.
  2. Klicken Sie auf Bild einrichten.
  3. Stellen Sie unter „Aufnahmeeinstellungen bearbeiten“ den Trigger auf Manuell.

  4. Wählen Sie unter „Kalibrierungstyp“ Importieren aus.

  5. Wählen Sie unter Dateiname die .CXD-Datei des Kalibrierungsjobs aus.

  6. Klicken Sie auf Teil suchen und fügen Sie die gewünschten Werkzeuge für die Suche nach dem Teil hinzu.
  7. Richten Sie den Job bei Bedarf genauer ein.
  8. Klicken Sie auf Teil inspizieren.
  9. Klicken Sie auf Mathematik- und Logikwerkzeuge > Roboterführung.

  10. Klicken Sie auf Hinzufügen, klicken Sie auf das Fadenkreuz des Teils und anschließend auf OK. Das Werkzeug Roboterführung wird auf der Registerkarte „Ergebnisse“ der Palette angezeigt. Es ist mit dem Muster-Werkzeug verknüpft.

  11. Mit „Werkzeug bearbeiten“ können Sie bei Bedarf den Werkzeugnamen und andere Einstellungen ändern. Passen Sie das Werkzeug an. Legen Sie dazu einen Werkzeugnamen fest, der mit einer bestimmten Anwendung in Zusammenhang steht.
  12. Schalten Sie das Vision-System online.


Einrichtung der Vision-System-Stellung

Die Stellung des Vision-Systems wird eingerichtet, damit im Roboterprogramm die richtige Position des Vision-Systems enthalten ist.

  1. Öffnen Sie das PolyScope-Programm, dass Sie erstellt haben. Das Hauptmenü wird angezeigt:

  2. Öffnen Sie im PolyScope-Hauptmenü Program Robot (Roboter programmieren). Eine Liste mit Registerkarten wird angezeigt.

  3. Klicken Sie auf Empty Program (Leeres Programm).

  4. Klicken Sie auf die Registerkarte Structure (Struktur). Der Programm-Struktur-Editor wird angezeigt.

  5. Klicken Sie auf URCaps. Die Schaltfläche Cognex Camera Pose (Cognex-Kamerastellung) wird angezeigt. Damit wird das Plug-In „Cognex In-Sight 2D Robot Guidance“ geöffnet.

  6. Klicken Sie auf die Schaltfläche Cognex Camera Pose (Cognex-Kamerastellung) und anschließend auf die Registerkarte Command (Befehl). Die Struktur links mit dem Roboterprogramm enthält jetzt den Knoten CGX_result;=CameraPose und drei weitere Knoten: Job Pass (Job gut), Job Fail (Job schlecht) und No Response (Keine Antwort).

    Eine Datei mit dem Namen CGX_result wird erstellt, in der die Stellung des Vision-Systems gespeichert wird. Die Stellung entspricht der Position des Objekts, das vom Vision-System gefunden wurde.

  7. Sperren Sie alle Position, die vom Vision-System nicht gelesen werden sollen. Wenn keine der Drehungen gesperrt wird, ist die Drehung des Roboters relativ zur aktuellen Drehung am Robotergreifarm, d. h. der Drehung, die eingestellt ist, wenn das Programm den Knoten CGX_result;=CameraPose erreicht. Aktivieren Sie das jeweilige Kontrollkästchen, um eine Position zu sperren.
  8. Speichern Sie das Programm.
Hinweis: Wenn das Vision-System auf dem Roboterarm angebracht ist, muss eine Referenzstellung für den Roboter eingestellt werden. Weitere Informationen finden Sie unter Einstellung einer Referenzstellung für den Roboter.

Einstellung einer Referenzstellung für den Roboter


Einstellung einer Referenzstellung für den Roboter

Hinweis: Diese Aufgabe muss nur durchgeführt werden, wenn das Vision-System auf dem Roboterarm angebracht ist (andernfalls ist sie optional).

Sie können die Referenzstellung für den Roboter einstellen, damit der Robotergreifarm auf das eingelernte Objekt ausgerichtet ist.

  1. Wählen Sie in PolyScope in der Baumstruktur für das Roboterprogramm den Knoten CGX_result;=CameraPose aus. Das Fenster „Cognex Camera Pose“ (Cognex-Kamerastellung) wird angezeigt.

  2. Klicken Sie auf Set Reference Pose (Referenzstellung einrichten). Das Werkzeug Move (Bewegen) wird angezeigt.

  3. Bewegen Sie den Greifarm mit diesem Werkzeug so, dass er auf das eingelernte Objekt ausgerichtet ist.
  4. Klicken Sie anschließend auf OK.
  5. Aktivieren Sie das Kontrollkästchen Robot Mounted (Am Roboter angebracht), wenn das Vision-System auf dem Roboterarm angebracht ist.

    Wenn das Vision-System nicht auf dem Roboterarm angebracht ist, muss das Kontrollkästchen deaktiviert bleiben.

  6. Speichern Sie das Programm, um die Referenzstellung zu speichern.


Programmierung des Universal Robots-Roboters

Nachdem Sie die Roboterkalibrierung und den In-Sight-Job eingerichtet haben, können Sie den Roboter für die Bestückungsanwendung mit MoveL und anderen Roboterbefehlen programmieren. Sie können auch die entsprechenden Aktionen programmieren, wenn ein Job besteht, fehlschlägt oder keine Antwort vom Vision-System eingeht. Das Plug-In „Cognex In-Sight 2D Robot Guidance“ stellt für den Anfang folgende Optionen bereit:

Nach dem Abschluss der Programmierung und dem Ausführen der Anwendung geschieht Folgendes, wenn das Programm den Knoten CGX_result:=CameraPose erreicht:

  1. Der Roboter ruft die Position des trainierten Teils von der Kamera ab.
  2. Das Vision-System triggert und gibt die Stellung zurück, die der Position des Teils entspricht.
  3. Die Stellung wird in der Variable CGX_result im Programm-Struktur-Editor in PolyScope gespeichert.

Ein Beispiel für eine Programmstruktur:


Bildstreifen

Mit dem Schritt Bildstreifen konfigurieren Sie ein Vision-System oder einen Emulator für die Wiedergabe von auf dem PC gespeicherten Bildern und zum Prüfen von Bildern und Ergebnissen, die auf dem Vision-System gespeichert sind. Der PC-Bildstreifen wird bei einer Verbindung mit einem PC normalerweise für die vorübergehende Einrichtung und Überwachung von bekannten Bildern verwendet, die fehlerfrei bzw. fehlerhaft sind. Der Sensorbildstreifen wird normalerweise für die Laufzeitüberwachung und -fehlerbehebung eingesetzt.

Hinweis: Wenn der Bildstreifen nicht angezeigt wird, klicken Sie im Menü "Ansicht“ auf Bildstreifen, oder klicken Sie auf die Schaltfläche Bildstreifen [image] in der EasyBuilder Symbolleiste.

Sensoreinstellungen

PC-Einstellungen


Sensoreinstellungen

Befindet sich das Vision-System im Onlinemodus und werden Bilder aufgezeichnet, kann der Sensorbildstreifen zur Überwachung der Ausführung eines Jobs verwendet werden. Während der Bildaufzeichnung werden die Jobergebnisse, das aufgezeichnete Bild und die zugehörigen Jobdaten im Arbeitsspeicher des Vision-Systems gespeichert. Beim Speichern der Ergebnisse im Vision-System wird dem Bildstreifen eine Bestanden-/Fehlergrafik hinzugefügt. Je nach Auflösung und Größe des verfügbaren Arbeitsspeichers des Vision-Systems können bis zu 20 Ergebnisse gespeichert werden.

Beispiel für die Überwachung von Bildstreifenergebnissen in einem Vision-System im Onlinemodus

Geschlossen Konfigurieren der Sensoreinstellungen
Hinweis: Da die Aktivierung des Sensorbildstreifens ggf. die Jobausführungszeit verlängern kann, sollten Sie sicherstellen, dass die längere Zeit für Ihre Anwendung akzeptabel ist. Ist dies nicht der Fall, wählen Sie im Dropdownmenü Warteschlange die Option Deaktiviert aus.

Im Gruppenfeld Sensoreinstellungen können Sie die Sensorbildstreifeneinstellungen konfigurieren:

Geschlossen Warteschlange

Gibt an, welche Ergebnisse gespeichert werden sollen; Deaktiviert (keine Ergebnisse werden gespeichert), Bestandenergebnisse, Fehlerergebnisse oder Bestanden- und Fehlerergebnisse und Separate Bestanden- und Fehlerergebnisse. (Standard = Deaktiviert)

Hinweis:
  • Wenn Separate Bestanden- und Fehlerergebnisse gewählt wird:
    • Die Dropdownliste Warteschlangengröße ist deaktiviert.
    • Die Dropdownlisten Bestanden-Größe und Nicht bestanden-Größe sind aktiviert.
    • Die Schaltfläche Bestanden-Ergebnisse und Fehler-Ergebnisse werden neben dem Bildstreifen angezeigt; schalten Sie diese Schaltflächen um, um die Bestanden- und/oder Fehler-Ergebnisse im Bildstreifen anzuzeigen.

Geschlossen Größe Warteschlangen

Legt die zu speichernde Anzahl von Ergebnissen fest. Je nach Auflösung und Größe des verfügbaren Arbeitsspeichers des Vision-Systems können bis zu 20 Ergebnisse gespeichert werden. Wenn die angegebene Warteschlangengröße den verfügbaren Arbeitsspeicher des Vision-Systems überschreitet, wird dem Vision-System automatisch die größtmögliche Anzahl von Ergebnissen zugeordnet.

Hinweis: Wenn Separate Bestanden- und Fehlerergebnisse in der Dropdownliste Warteschlange ausgewählt wird, ist diese Option deaktiviert.

Geschlossen Größe Bestanden

Die Anzahl der Bestandenergebnisse, die am Vision-System gespeichert werden sollen. Die summierte Bestanden- und Fehler-Größe wird die unterstützte dem Vision-System allozierte Größe der Warteschlange nicht überschreiten. Diese Option wird nur dann aktiviert, wenn im Dropdown-Menü Warteschlange Separate Bestanden- und Fehler-Ergebnisse ausgewählt wurde. (Minimum = 1)

Geschlossen Größe Fehler

Die Anzahl der Fehlerergebnisse, die am Sensor gespeichert werden sollen. Die summierte Bestanden- und Fehler-Größe wird die unterstützte dem Vision-System allozierte Größe der Warteschlange nicht überschreiten. Diese Option wird nur dann aktiviert, wenn im Dropdown-Menü Warteschlange Separate Bestanden- und Fehler-Ergebnisse ausgewählt wurde. (Minimum = 1)

Geschlossen Warteschlangentyp

Legt fest, ob nur das erste Ergebnis (Nur erste) oder die letzten X Ergebnisse (Letzte) gespeichert werden sollen. X ist dabei die Warteschlangengröße. (Standard = Letzte)

Geschlossen Beim Platzieren im Onlinemodus löschen

Wenn diese Option aktiviert ist (Standard), wird die Warteschlange jedes Mal gelöscht, wenn das Vision-System online geschaltet wird.

Geschlossen Anzeigemodus

Legt für den Bildstreifen als Reaktion auf ein Fehlerergebnis Stopp bei Fehler, Pause bei Fehler oder keine Reaktion (Normal) fest. (Standard = Normal)

Geschlossen Verzögerungszeit

Legt die Pausendauer in Sekunden fest, wenn als Anzeigemodus die Einstellung Pause bei Fehler ausgewählt wurde. (1–120; Standard = 5)

Geschlossen LED-Stil

Zeigt die Bestanden- und Fehlerergebnisse im Bildstreifen als geometrische Formen an (grüner Kreis [image] und rotes Rechteck [image]), grün OK [image] und rot unbrauchbar [image] oder grünes Häkchen [image] und rotes X [image].

Geschlossen Pfad speichern

Gibt den Speicherort für Bildstreifenbilder an. Der Benutzer muss über Schreibberechtigung für den angegebenen Speicherort verfügen.

Geschlossen Überwachen der Ergebnisse vom Sensor

Der Bildstreifen kann zur Onlineüberwachung oder Online- bzw. Offlineüberprüfung der Ergebnisse eines Jobs verwendet werden.

  1. Klicken Sie auf der Symbolleiste auf die Schaltfläche Online [image], um das Vision-System online zu schalten.
  2. Aktivieren Sie die Bildaufnahme im Vision-System. Bei der Aufzeichnung werden die Bilder im Vision-System gespeichert und dem Filmstreifen gemäß den im Gruppenfeld Sensoreinstellungen festgelegten Warteschlangeneinstellungen hinzugefügt.
  3. Zeigen Sie die aktualisierten Statusgrafiken, die die gut/schlecht-Ergebnisse darstellen, im Bildstreifen an. Tritt eines der folgenden Ereignisse ein, bleibt das Vision-System zwar weiterhin im Onlinemodus, aber der Bildstreifen wird nicht mehr aktualisiert und wird eingefroren (angezeigt durch einen gelben Balken oben im Anzeigebereich):
    • Ein Ergebnis ist fehlerhaft und im Gruppenfeld Sensoreinstellungen ist Stopp bei Fehler oder Pause bei Fehler angegeben.

    • Im Bildstreifen ist eine Statusgrafik ausgewählt, eine Navigationsschaltfläche wird angeklickt oder die Schaltfläche Einfrieren wird angeklickt.

    Im Modus „Eingefroren“ können Sie durch die Ergebnisse im Bildstreifen navigieren oder Bilder vom Vision-System auf dem PC speichern. Alle Anwendungsschritte werden deaktiviert, um eine versehentliche Änderung der Jobparameter zu verhindern. In der Zwischenzeit wird der Job weiterhin ausgeführt, aber der Warteschlange wird nichts hinzugefügt. In den folgenden Situationen nimmt der Bildstreifen die Aktualisierung wieder auf, und alle Anwendungsschritte werden aktiviert:

    • Die angegebene Verzögerungszeit verstreicht.
    • Die Schaltfläche Weiter wird angeklickt.
    • Die Schaltfläche Warteschlange löschen wird angeklickt.
  4. Wenn Sie die Überwachung der Ergebnisse abgeschlossen haben, klicken Sie erneut auf die Symbolleistenschaltfläche Online, um das Vision-System offline zu schalten.
Geschlossen Bilder vom Sensor auf dem PC speichern

Sie können die Bilder von einem Vision-System im Online- oder Offline-Modus in einem beliebigen Ordner auf dem PC speichern, für den Sie Schreibberechtigungen besitzen, und die Bilder anschließend im PC-Wiedergabemodus wiedergeben.

Geschlossen Prüfen des Speicherpfads
  1. Schalten Sie das Vision-System offline.

  2. Klicken Sie neben dem Feld Pfad speichern auf die Schaltfläche „Durchsuchen“.

  3. Geben Sie im angezeigten Dialogfeld Ordner suchen den gewünschten Zielordner an, und klicken Sie auf OK. Der ausgewählte Ordnerpfad wird jetzt im Feld Pfad speichern angezeigt.
Geschlossen Speichern der Ergebnisse von einem Vision-System im Online- oder Offlinemodus auf einem PC
  1. Wählen Sie ein Ergebnis im Bildstreifen aus, oder klicken Sie auf die Schaltfläche Einfrieren, um den Modus „Eingefroren“ zu aktivieren. Dieser Modus wird durch einen gelben Balken über dem Anzeigebereich angezeigt. Alle Anwendungsschritte werden deaktiviert, um eine versehentliche Änderung der Jobparameter zu verhindern. In der Zwischenzeit wird der Job weiterhin ausgeführt, aber der Warteschlange wird nichts hinzugefügt.

  2. Klicken Sie im Bildstreifen auf die Schaltfläche Auf PC speichern.

  3. Um weitere Bilder zum Zielordner hinzuzufügen, verlassen Sie den Modus „Eingefroren“, indem Sie im Bildstreifen entweder auf die Schaltfläche Weiter oder auf Warteschlange löschen klicken. Nachdem der Warteschlange weitere Ergebnisse hinzugefügt wurden, wiederholen Sie die Schritte 1 und 2.


PC-Einstellungen

Durch Klicken auf die Schaltfläche Wiedergabe wird das Dialogfeld Optionen für Aufzeichnen/Wiedergabe geöffnet, in dem Sie Aufzeichnungs- und Wiedergabeoptionen für individuelle Vision-Systeme und Emulatoren konfigurieren können. Mit dem PC-Wiedergabemodus, auf den im Online- und Offlinemodus zugegriffen werden kann, können Sie zu Validierungszwecken bis zu 10 000 Bilder wiedergeben. Das Bild wird zum Vision-System gesendet, und der Job wird für das wiedergegebene Bild ausgeführt.

Beispiel für den Bildstreifen während der Wiedergabe vom PC

Geschlossen Konfigurieren der Aufzeichnungseinstellungen
Hinweis: Werden Farbbilder auf dem PC gespeichert, werden sie als 16- und nicht als 24-Bit-Bilder gespeichert. Sollen Farbbilder zum Testen von Farbwerkzeugen verwendet werden, können Sie die Bilder per FTP exportieren (durch Hinzufügen eines FTP-Geräts im Anwendungsschritt Kommunikation), um die Bilder zu speichern und die volle Farbtiefe beizubehalten.
  1. Klicken Sie im Gruppenfeld für die PC-Einstellungen auf Wiedergabe.
  2. Klicken Sie anschließend im Dialogfeld Optionen für Aufzeichnen/Wiedergabe auf die Registerkarte für die Aufzeichnung.
  3. Wählen Sie den gewünschten Ordner für die Aufzeichnung aus, und konfigurieren Sie die übrigen Aufzeichnungsparameter.
  4. Nachdem Sie alle Aufzeichnungseinstellungen festgelegt haben, klicken Sie auf OK, um das Dialogfeld für die Aufzeichnungs- und Wiedergabeoptionen zu schließen.
Geschlossen Aufzeichnen von Bildern
  1. Klicken Sie im Bildstreifen auf die Schaltfläche PC.
  2. Klicken Sie auf der EasyBuilder-Symbolleiste auf die Schaltfläche zum Aufzeichnen.
  3. Aktivieren Sie die Bildaufnahme im Vision-System. Während der Aufzeichnung werden die fehlerfreien und fehlerhaften Bilder automatisch sortiert und in den angegebenen Ordnern gespeichert.
  4. Klicken Sie noch einmal auf die Schaltfläche für die Aufzeichnung, um die Aufzeichnung zu beenden.
Geschlossen Konfigurieren der Wiedergabeeinstellungen
  1. Klicken Sie im Gruppenfeld für die PC-Einstellungen auf Wiedergabe.
  2. Klicken Sie anschließend im Dialogfeld Optionen für Aufzeichnen/Wiedergabe auf die Registerkarte für die Wiedergabe.

  3. Wählen Sie den gewünschten Ordner für die Wiedergabe aus, und konfigurieren Sie die übrigen Wiedergabeparameter.

    Hinweis: Der Ordner Wiedergabe verweist standardmäßig auf den Ordner mit den EasyBuilder-Beispiel-Parametersätzen. Die EasyBuilder-Beispiel-Parametersätze veranschaulichen eindrucksvoll die Nützlichkeit der Aufzeichnungs- und Wiedergabeoptionen. Mithilfe der Aufzeichnungs- und Wiedergabeoptionen können Sie eine Serie zuvor aufgenommener Bilder der Reihe nach durchlaufen und erhalten so sofortiges Feedback zu den Werkzeugergebnissen. Dies ermöglicht eine schnelle Konfiguration von Schwellen- und Grenzwerten.
  4. Nachdem Sie alle Wiedergabeeinstellungen festgelegt haben, klicken Sie auf OK, um das Dialogfeld für die Aufzeichnungs- und Wiedergabeoptionen zu schließen.
Geschlossen Wiedergabe von Bildern von einem PC
Hinweis: Zur Wiedergabe von Bildern im Onlinemodus des Vision-Systems muss im Anwendungsschritt Bild einrichten der Parameter „Trigger“ auf Extern, Manuell oder Netzwerk festgelegt werden.

  1. Klicken Sie im Bildstreifen auf die Schaltfläche PC.

  2. Ist der Parameter „Trigger“ (im Anwendungsschritt Bild einrichten) auf Kamera oder Kontinuierlich festgelegt, wechseln Sie im Vision-System zum Offlinemodus, um Bilder wiederzugeben. Das Vision-System kann zur Wiedergabe von Bildern weiterhin im Onlinemodus betrieben werden, wenn der Parameter „Trigger“ auf Extern, Manuell oder Netzwerk festgelegt ist.
  3. Klicken Sie zur Wiedergabe der Bilder im Bildstreifen auf die Schaltfläche Abspielen, oder klicken Sie auf die Navigationsschaltflächen (siehe unten), um manuell durch die Bilder zu blättern.

    4. Abspielen | Pause
Erste auswählen | Vorherige auswählen
Nächste auswählen | Letzte auswählen
  4. Klicken Sie auf den Anwendungsschritt Job ausführen, um die Ergebnistabelle anzuzeigen. Alternativ können Sie auch auf der Palette auf die Registerkarte für die Ergebnisse klicken.


Job speichern

Dieser Schritt ermöglicht das Ausführen verschiedener Dateiverwaltungs- und Sensorwartungsaufgaben.

Hinweis: Ist im Dialogfeld Benutzer das Kontrollkästchen Speichern von Onlinejob zulassen aktiviert, können Benutzer mit Vollzugriff oder geschütztem Zugriff Jobs im Onlinestatus speichern. Ist das Kontrollkästchen Speichern von Onlinejob zulassen nicht aktiviert, muss das Vision-System offline sein, um Jobs speichern zu können.

Speichern eines Jobs (oder als Job)

Konfigurieren von Starteinstellungen

Sicherung einer Archivkopie

Wiederherstellen einer Archivkopie


Speichern eines Jobs (oder als Job speichern)

Beim Speichern eines Jobs werden nur die Werkzeugeinstellungen und jobspezifischen Informationen gespeichert.

Hinweis: Jobs können zwar in vorherigen EasyBuilder-Schritten gespeichert werden, dennoch ist der Schritt "Job speichern" eine wichtige Komponente. EasyBuilder bietet keine Funktion zur automatischen Speicherung. Folglich gehen nicht gespeicherte Änderungen bei Unterbrechung der Stromzufuhr des Sensors verloren.

Wurde ein Job zuvor nicht gespeichert, entspricht die Funktion "Speichern" der Funktion "Speichern unter". Bei Auswahl dieser Funktion wird das Dialogfeld "Speichern unter" geöffnet.

Geschlossen Speichen eines nicht gespeicherten Jobs (oder als Job)

  1. Drücken Sie STRG+S, oder klicken Sie im Gruppenfeld Job speichern auf Speichern oder Speichern unter, um das Dialogfeld Speichern unter zu öffnen.
  2. Navigieren Sie im Dialogfeld zum gewünschten Speicherort.
  3. Benennen Sie den Job.
  4. Klicken Sie im Dialogfeld auf Speichern.

Geschlossen Zum Speichern eines bereits gespeicherten Jobs haben Sie zwei Möglichkeiten:
  • Klicken Sie im Gruppenfeld Job speichern auf Speichern.
  • Drücken Sie STRG+S.
Hinweis: Klicken Sie zum Speichern des aktuellen Jobbilds im Menü "Datei" auf Bild speichern unter.... Sichern Sie zum Speichern von Sensoreinstellungen sowie allen Bildern Ihren In-Sight-Sensor bzw. -Emulator.


Konfigurieren von Starteinstellungen

Mit den Steuerelementen im Gruppenfeld Startoptionen können Aufgaben festgelegt werden, die automatisch ablaufen, wenn ein In-Sight-Vision-System/Sensor oder Emulator eingeschaltet wird, etwa das Laden eines Standardjobs oder Onlineschalten des Vision-Systems/Sensors.

Hinweis: Nur Benutzer mit vollen Zugangsrechten können die Starteinstellungen konfigurieren. Weitere Informationen finden Sie unter Dialogfeld „Einstellungen für den Benutzerzugriff“.

Startjob auswählen

  1. Klicken Sie auf die Schaltfläche [image]. Das Dialogfeld „Starten“ wird angezeigt.
    1. Aktivieren Sie im Dialogfeld das Kontrollkästchen „Job bei Start laden“. Die Liste wird aktiviert und zeigt die Jobs an, die in dem verbundenen Vision-System/Sensor, der auf dem verbundenen Vision-System installierten SD-Karte oder dem Emulator gespeichert sind.

    2. Wenn der Jobserver aktiviert ist, klicken Sie im Dialogfeld auf das Kontrollkästchen „Externen Job bei Start laden“. Die Liste wird aktiviert und zeigt die auf dem Jobserver gespeicherten Jobs an. Weitere Informationen finden Sie unter Dialogfeld „Jobservereinstellungen“.

      Hinweis:
      • Der Jobserver ist standardmäßig deaktiviert. Verwenden Sie das Dialogfeld „Jobservereinstellungen“ zum Aktivieren und Konfigurieren des Jobservers.
      • Wenn der Jobserver aktiviert ist, können nur Jobs ausgewählt werden, die auf dem Jobserver gespeichert sind. Wenn ein Job, der auf einem Vision-System gespeichert ist, beim Start geladen werden soll, deaktivieren Sie den Jobserver.
  2. Wählen Sie den Job aus, den Sie beim Start automatisch laden möchten.
  3. Klicken Sie auf OK. Das Dialogfeld wird geschlossen.

  4. Im Textfeld „Job“ wird der ausgewählte Startjob angezeigt.

    Hinweis:
    • Wenn ein auf der SD-Karte gespeicherter Job ausgewählt wird, zeigt das Textfeld „Job“ den Text „SDCARD/xxx.job“ an.
    • Das Textfeld „Job“ ist schreibgeschützt. Um den Startjob zu ändern, klicken Sie auf die Schaltfläche [image].
  5. Wenn Sie die Auswahl des Startjobs aufheben und mit einem leeren Job beginnen möchten, klicken Sie erneut auf die Schaltfläche [image] und deaktivieren Sie das Kontrollkästchen „Job bei Start laden“ oder „Externen Job bei Start laden“.

Sensor online starten

  1. Aktivieren Sie das Kontrollkästchen „Sensor im Onlinemodus starten“, um den aktuellen Sensor beim Start automatisch im Onlinemodus zu starten.

    Hinweis: Sie können diese Einstellung auch über das Dialogfeld „Starten“ aktivieren.


Sicherung einer Archivkopie

Mit der Schaltfläche „Sichern“ können Benutzer mit vollständigem oder geschützten Zugriff eine Archivkopie der Jobs, Bilder und Sensoreinstellungen eines In-Sight-Systems/Sensors oder Emulators auf der Festplatte ihres PCs speichern.

Vor dem Sichern eines Vision-Systems/Sensors oder Emulators auf dem PC klicken Sie im Menü „System“ auf Optionen, um sicherzustellen, dass der Zielordner bzw. das Sicherungsverzeichnis für die archivierten Daten korrekt definiert ist.

Sichern des aktuellen Sensors oder Emulators:

  1. Klicken Sie im Gruppenfeld Sensorwartung auf Sichern.
Tipp: Mithilfe des Dialogfelds „Sichern“ (System > Sichern) können Sie Sicherungen verschiedener Vision-Systeme/Sensoren/Emulatoren auf dem PC oder auf der im Vision-System installierten SD-Karte speichern. Weitere Informationen finden Sie im Thema zum Dialogfeld „Sichern“.


Wiederherstellen einer Archivkopie

Über die Schaltfläche „Wiederherstellen“ können Benutzer mit vollständigem oder geschütztem Zugriff eine Archivkopie der Jobs, Bilder und Sensoreinstellungen von ihrem lokalen PC abrufen, um sie auf das ursprüngliche In-Sight Vision-System/den Sensor oder Emulator zurückzusetzen; die Kopie muss auf dem PC gesichert werden, bevor die Dateien im Dialogfeld angezeigt werden.

Wiederherstellen einer Archivkopie auf den aktuellen Sensor oder Emulator:

  1. Klicken Sie im Gruppenfeld Sensorwartung auf Wiederherstellen.

Tipp: Mit dem Dialogfeld „Wiederherstellen“ oder dem Dialogfeld „Wiederherstellen von“ (System > Wiederherstellen von) können Sie eine Archivkopie auf einem anderen Vision-System/Sensor/Emulator wiederherstellen, bzw. eine Sicherungskopie, die auf der SD-Karte des Vision-Systems gespeichert war. Weitere Informationen finden Sie im Thema zum Dialogfeld „Wiederherstellen“ oder im Thema zum Dialogfeld „Wiederherstellen von“.


Ausführen eines Jobs

Sobald alle Jobparameter festgelegt wurden, können Sie den Job ausführen, die Ergebnisse überprüfen und bei Bedarf die Einstellungen ändern oder austesten. Außerdem können Sie den Job testen, um sicherzustellen, dass alle Parameter innerhalb der Grenzen liegen und das In-Sight-Vision-System Bilder korrekt aufnimmt.

Ausführen des Jobs mittels Sensor

Ändern oder Drucken der Ergebnistabelle

Anzeigen der Ergebnistabelle

Joboptimierung und Fehlerbehebung

Prüfen Ihres Jobs mit TestRun™


Ausführen des Jobs mittels Sensor

Wenn ein Job mittels Sensor ausgeführt wird, muss der Sensor einfach online geschaltet werden.

Hinweis: Wenn für eine Eingangs- oder Ausgangsleitung im Anwendungsschritt „Eingänge/Ausgänge“ „ein“ oder „aus“ erzwungen wird, wird eine Warnung im Gruppenfeld Jobstatus angezeigt. Stellen Sie in diesem Fall sicher, dass kein Schaden eintreten kann, wenn das Gerät an das Stromnetz angeschlossen bzw. davon getrennt wird, bevor der Sensor online oder offline geschaltet wird.

Online- oder Offline-Schalten des Sensors:

  • So schalten Sie den Sensor online: Klicken Sie auf die Schaltfläche Online im Einstellungsbereich. Die Schaltfläche ist ein Umschalter und wird orange, um den Online-Status anzugeben.
    Aussehen der Schaltfläche wenn offline
  • So schalten Sie den Sensor offline: Klicken Sie auf die orangefarbene Schaltfläche Online im Einstellungsbereich. Die Schaltfläche erhält wieder ihre ursprüngliche Farbe, um den Offline-Status anzugeben.
    Aussehen der Schaltfläche wenn online


Ändern oder Drucken der Ergebnistabelle

Klicken Sie im Einstellungsfenster auf Optionen, um das Dialogfeld "Optionen zur Ergebnisanzeige" zu öffnen, in dem die Ergebnistabelle geändert werden kann.

Das Dialogfeld "Optionen zur Ergebnisanzeige" enthält die folgenden Steuerelemente:

  • Optionen anzeigen Geschlossen : Hiermit können Sie die automatische Einstellung der Spaltenbreiten deaktivieren/aktivieren, die Gut/Schlecht-Raten als Prozentsatz oder Anzahl anzeigen und das Werkzeugsymbol, Werkzeugabhängigkeitsgrafiken sowie Spalten für "Zeit", "Ergebnisse", "Gut/schlecht" und "Werkzeug aktiviert" in der Ergebnistabelle ein- oder ausblenden

    In der Spalte "Werkzeug aktiviert" wird der Aktivierungsstatus eines Werkzeugs ("Ein", "Aus" oder zugehöriger Eingang) angezeigt, der in den Schritten Teil suchen und Teil inspizieren festgelegt wurde.
  • Werkzeugoptionen Geschlossen : Hiermit können Sie die Grafiküberlagerungen eines Werkzeugs im Bildfeld (Spalte "Grafik anzeigen") und das Profil eines Werkzeugs in der Ergebnistabelle (Spalte "Werkzeug anzeigen") ein- oder ausblenden.

    Wenden Sie diese Einstellungen auf einzelne Werkzeuge an, indem Sie die Kontrollkästchen aktivieren oder deaktivieren, oder klicken Sie im Abschnitt "Änderungsoptionen" auf die Schaltfläche Alle oder Keine, um die Einstellungen für alle bzw. keine Werkzeuge zu übernehmen.

    In der Standardeinstellung sind alle Kontrollkästchen deaktiviert.
  • Standardeinstellungen wiederherstellen Geschlossen : Hebt die Sortierung auf und setzt die Ergebnistabelle auf die Standardeinstellungen zurück. Zu den Standardspalten zählen die Anzeige von gut/schlecht (bestanden/Fehler), Werkzeugabhängigkeitsgrafiken, das Werkzeugsymbol, "Name", "Ergebnis", "Gut/schlecht" (angezeigt als Anzahl) und "Zeit". Die Breite der Spalten wird automatisch an die Breite der EasyBuilder-Ansicht angepasst.

Weitere Steuerelemente im Einstellungsfenster, die die Ergebnistabelle betreffen:

  • Drucken Geschlossen : Öffnet das Fenster "Seitenansicht". Hier können Sie alle Seiten drucken, die Anzeige in voreingestellten prozentualen Zoom-Stufen vergrößern oder verkleinern, die Anzahl gleichzeitig angezeigter Seiten festlegen und eine bestimmte Seite zur Ansicht auswählen. Sie können auch das Dialogfeld "Seite einrichten" öffnen und dort das Papierformat, die Quelle und Ausrichtung, Seitenränder und den Drucker auswählen.
  • Gut/schlecht löschen Geschlossen : Setzt die Gut/Schlecht-Anzahl auf 0 zurück und nimmt die Zählung wieder auf.


Anzeigen der Ergebnistabelle

Die Ergebnistabelle im Einstellungsfenster beinhaltet ein Profil zu jedem Werkzeug des Jobs. Klicken Sie zum Sortieren der Tabelle nach Spalte auf den Spaltentitel. Klicken Sie zum Umkehren der Sortierreihenfolge erneut auf den Spaltentitel. Zum Wiederherstellen der Standardsortierung klicken Sie ein drittes Mal auf den Spaltentitel. Ordnen Sie die Werkzeuge in der Tabelle neu, indem Sie sie mittels Drag&Drop in die gewünschte Reihenfolge bringen.

Hinweis: Ordnen Sie die Werkzeuge in der Tabelle Ergebnisse neu, indem Sie sie mittels Drag&Drop in die gewünschte Reihenfolge bringen. Das Neuordnen ist in der Tabelle mit den Ergebnissen zu Job ausführen und in der Tabelle mit den Palettenergebnissen möglich und wird in beiden Tabellen übernommen. Das Sortieren mittels Drag&Drop ist nur aktiviert, wenn die Spalte Werkzeugabhängigkeitsgrafiken ausgewählt ist (diese Spalte ist standardmäßig ausgewählt). Wählen Sie die Spalte ein zweites Mal aus, um die Reihenfolge umzukehren. Das Neuordnen ist nicht möglich, wenn der Job nahe am Jobumfanglimit liegt.

In der Ergebnistabelle werden standardmäßig die folgenden Spalten (von links nach rechts) angezeigt:

  • Bestanden/Nicht bestanden-Anzeige: Beinhaltet einen grünen Kreis [image], sowie ein rotes Rechteck [image] zur Angabe des Erfolgs bzw. Fehlschlags. Gut/Schlecht-Kriterien werden in den Schritten Teil suchenund Teil inspizieren festgelegt.

  • Werkzeugabhängigkeitsgrafiken: Zeigt die Werkzeugreihenfolge und die Abhängigkeiten zwischen dem ausgewählten Werkzeug (orange hervorgehoben) und anderen Werkzeugen an. Wählen Sie diese Spalte, um die Werkzeuge in der Reihenfolge zu sortieren, in der sie dem Job hinzugefügt wurden. Wenn Sie mit dieser Spalte sortieren, können Sie auch die Werkzeuge mittels Drag&Drop in die gewünschte Reihenfolge bringen. Die Werkzeuge in einem Mathematik- und Logikwerkzeug können der Gruppe hinzugefügt oder daraus entfernt werden, indem Sie das Werkzeug erweitern und das gewünschte Werkzeug in die Gruppe oder aus der Gruppe ziehen.

    Hinweis: Gruppenwerkzeuge können nicht unter anderen Gruppenwerkzeugen abgelegt werden, und einem Gruppenwerkzeug können keine Werkzeuge hinzugefügt werden, die eine Endlosschleife verursachen.

    Eine Abhängigkeit besteht, wenn ein Werkzeug auf ein anderes Werkzeug verweist. Jede Abhängigkeit besteht aus zwei Teilen: einem vorangehenden Teil und einem abhängigen Teil, der durch eine Linie mit dem vorangehenden Teil verbunden ist. Der vorangehende Teil bezieht sich auf die Quelle der Daten (d.h. das Werkzeug, von dem die Eingabe stammt) und wird durch einen Kreis dargestellt. Der abhängige Teil ist das Ziel der Daten (d.h. das Werkzeug, das die Ausgabe empfängt) und wird durch einen Pfeil dargestellt. Blaue Abhängigkeitsgrafiken zeigen an, dass das ausgewählte Werkzeug das Ziel ist. Bei grünen Grafiken ist das ausgewählte Werkzeug die Quelle.

  • Werkzeugsymbol: Zeigt den verwendeten Werkzeugtyp an (z. B. An-/Abwesenheitswerkzeug "Kante", Identifizierungswerkzeug "Text lesen" oder Zählwerkzeug "Blobs").
  • Name: Gibt den Namen des Werkzeugs an. Der Standardname kann in Schritt Teil suchen oder Teil inspizieren geändert werden.

  • Ergebnis: Listet die Datenergebnisse für das Werkzeug auf, die auch auf den Registerkarten Einstellungen oder Bereichsbeschränkungen im Einstellungsfenster Teil suchen oder Teil inspizieren angezeigt werden.

    In-Sight-Modelle | Ergebnisse

    Vision-Sensoren In-Sight 2000-110 und 2000-120/120C

             Nur bei Bestanden/Nicht bestanden-Status.
    Vision-Sensoren In-Sight 2000-130/130C

    Messungs- und Zähl-Inspektionswerkzeuge: Standardergebnisse (numerische Daten)
    An-/Abwesenheitswerkzeug "Muster": Gut/Schlecht-Status und Mustergüte
    Andere Werkzeuge: Nur bei Bestanden/Nicht bestanden-Status.
    In-Sight-Vision-Systeme (alle Modelle) und Vision-Sensoren der In-Sight 2000-Serie 23x (23M, 230) | Standardergebnisse (keine Einschränkungen)
  • Bestanden: Zeigt die "Gut"-Rate (Bestanden) für das Werkzeug als Anzahl der "Gut"-Ergebnisse/gesamten Ergebnisse (Standardeinstellung) oder als Prozentsatz an.
  • Nicht bestanden: Zeigt die "Schlecht"-Rate (Fehler) für das Werkzeug als Anzahl der "Schlecht"-Ergebnisse/gesamten Ergebnisse (Standardeinstellung) oder als Prozentsatz an.

    • Hinweis: Wenn ein Werkzeug deaktiviert ist, bleiben seine Symbole in ihrem letzten Status . Wenn das Werkzeug ein Nicht bestanden geliefert hat, wenn es deaktiviert wurde, Bestanden wird 0 und Nicht bestanden 1 sein. Ob jedoch der ganze Job ein Bestanden/ Nicht bestanden zurückgibt, wird durch das Bestanden/Nicht bestanden-Ergbenis des deaktivierten Werkzeugs nicht beeinflusst.

  • Zeit (ms): Gibt die zur Ausführung des Werkzeugs benötigte Zeit in Millisekunden an.

  • Typ: Zeigt den Werkzeugtyp an. Als Beispiel wird "PatMax RedLine™-Muster (1-10)" für das Positionswerkzeug "PatMax RedLine™-Muster (1-10)" und "PatMax®-Muster(1-10)" für das Positionswerkzeug "PatMax® Muster (1-10)" angezeigt.

    Hinweis: Um die Spalte Typ auszublenden, klicken Sie mit der rechten Maustaste und auf Spalte Typ anzeigen.

Das Gruppenfeld Jobstatus links neben der Tabelle Ergebnisse enthält die gesamte "Gut"-Rate (Rate) für alle angezeigten Bilder seit dem letzten Löschen der Gut/Schlecht-Anzahl und die Jobzeit (Zeit) für das aktuelle Bild.

  • Ändern oder Drucken der Ergebnistabelle


Joboptimierung und Fehlerbehebung

Mithilfe dieser Informationen lassen sich Fehler in den Jobeinstellungen beheben bzw. Jobeinstellungen optimieren.

Im Folgenden werden einige Beispiele zur Verwendung der Ergebnistabelle für die Fehlerbehebung angeführt:

  • Anzahl von "gut/schlecht": Ermöglicht die Identifizierung von fehlerhaften Werkzeugen.
  • Werkzeugabhängigkeitsgrafiken: Anhand der Werkzeugbeziehungen in diesen Grafiken können Sie feststellen, ob ein Werkzeugfehler auf den Fehler eines anderen Werkzeugs zurückzuführen ist.
  • Ergebniszeichenfolgen: Ermöglichen die Ermittlung der außerhalb der Spezifikation liegenden Werkzeuge.

Die Optimierung des Jobs umfasst oftmals die Verringerung der Verarbeitungszeit. Diese variiert in Abhängigkeit der Funktionen einzelner In-Sight-Sensoren. Die Joboptimierung ist nur für zeitkritische Anwendungen (beispielsweise Anwendungen mit hoher Fördergeschwindigkeit) wichtig.

Bei der Ausführung eines EasyBuilder-Jobs sind folgende Phasen am zeitintensivsten:

  • Aufnahmezeit: Belichtungszeit + Übertragungszeit des CCD-Sensors (CCD, charge-coupled device)
  • Werkzeugvorgang: Summe der Verarbeitungszeit für alle Werkzeuge und Funktionen

Die folgenden allgemeinen Richtlinien können Ihnen helfen, die Jobausführungszeit zu verringern:

  • Verringern Sie die Belichtungszeit.
  • Machen Sie eine Teilaufnahme.
  • Legen Sie einen kleineren Aufnahmebereich fest.
  • Minimieren Sie die Drehung des Bilds.

Kehren Sie ggf. zum Schritt Bild einrichten, Teil suchen oder Teil inspizieren zurück, um die Parameter entsprechend zu bearbeiten.

Die relativen Geschwindigkeiten der primären Positions- und Inspektionswerkzeuge sind (höchste Geschwindigkeit bis niedrigste Geschwindigkeit):

  • Kante
  • Blob
  • Muster

Verwenden Sie demzufolge das Werkzeug "Kante", sofern die Werkzeuge "Kante" und "Muster" dasselbe Ergebnis aufweisen.

Hinweis: Die tatsächliche Laufzeit ist aufgrund der potenziellen Überlappung von Aufnahme- und Verarbeitungsfunktionen möglicherweise kürzer als die Laufzeit des Schritts "Job ausführen".


Prüfen Ihres Jobs mit TestRun™

TestRun™ prüft das In-Sight-Vision-System und vergleicht die Prüfergebnisse mit den erwarteten Werten. TestRun umfasst die folgenden Prüfungen für ein In-Sight-Vision-System:

  • Grenzprüfungen: Prüfung einer Reihe von Parametern und Feststellung, ob der aktuelle Wert innerhalb der Ober- und Untergrenzen liegt, die für diesen Parameter festgelegt wurden. Diese Parametereinstellungen sind von den Benutzern direkt im Job konfigurierbar. Diskrete Eingangsinformationen werden in den Job gelesen, oder Werte werden von einem externen Gerät über ein Kommunikationsprotokoll gesendet.
  • Bildprüfungen: Bei diesen Prüfungen wird eine Reihe von Bildern in bekannter Qualität ("gut" und "schlecht") an ein Vision-System gesendet, und es wird festgestellt, ob die Ergebnisse des aktuellen Jobs mit den erwarteten Ergebnissen für jedes Bild übereinstimmen.
  • Hardwaretests: Vergleichen die Bildqualität eines aktuellen Bilds vom Vision-System mit der erwarteten Bildqualität, um festzustellen, ob sich die Kameraposition, die Brennweite, Beleuchtung usw. geändert hat.

Vor der Verwendung von TestRun

Hinweis: TestRun steht nur Benutzern mit Vollzugriff zur Verfügung.

TestRun geht von Folgendem aus:

  • Die Vision-Anwendung wurde bereits entwickelt und auf einem In-Sight-Vision-System als .job-Datei gespeichert.
  • Mit dem Schritt Verbindung herstellen wurde eine Verbindung zum Vision-System hergestellt und die .job-Datei geladen.
  • Eine Bilddatenbank mit den in der Anwendung verwendeten Bildern wurde erstellt.
Hinweis: Im Idealfall enthält die Datenbank Beispiele "guter" Bilder (Bilder, die das Ergebnis "Bestanden" ergeben) und "schlechter" Bilder (Bilder, die das Ergebnis "Fehler" ergeben). TestRun ist mit verschiedenen Dateistrukturen der Bilddatenbank kompatibel, allerdings wird der Vorgang vereinfacht, wenn die Bilder vor dem Starten von TestRun in verschiedenen "gut"- und "schlecht"-Ordnern geordnet werden.

Verwenden von TestRun

Nach dem Herstellen einer Verbindung zum gewünschten In-Sight-Vision-System und Laden der entsprechenden .job-Datei ins Vision-System kann die TestRun-Konfiguration beginnen. TestRun wird mit dem Dialogfeld für das TestRun-Setup konfiguriert, in dem TestRun anhand mehrerer Bildschirme programmiert wird. Links neben dem Dialogfeld befindet sich ein Navigationsfenster, in dem Sie jeden Setupbildschirm auswählen können.

Hinweis: Nach der Erstkonfiguration von TestRun können Sie zu jedem der Schritte zurückkehren, indem Sie einfach den Schritt im Navigationsfenster auswählen.

Konfigurieren von TestRun

  1. Klicken Sie in der Palette auf die Registerkarte TestRun.
Hinweis: Ist die Palette nicht sichtbar, wählen Sie im Menü "Ansicht" den Befehl "Palette".
  2. Klicken Sie auf die Schaltfläche Konfigurieren, um das Dialogfeld für das TestRun-Setup zu öffnen.
  3. Führen Sie die Schritte in den Bildschirmen aus, um TestRun zu konfigurieren. Weitere Informationen zum Konfigurieren von TestRun finden Sie in der In-Sight Explorer-Hilfe.


Rechtliche Hinweise

Die hierin beschriebene Software wird unter Lizenz bereitgestellt und darf lediglich entsprechend den Lizenzbestimmungen verwendet oder kopiert werden. Dabei ist stets der auf dieser Seite vorgegebene Urheberrechtsvermerk anzubringen. Die Software, dieses Handbuch oder Kopien davon dürfen ausschließlich dem Lizenznehmer übergeben oder dem Lizenznehmer anderweitig zugänglich gemacht werden. Eigentumstitel und -rechte verbleiben bei der Cognex Corporation bzw. bei deren Lizenzgeber. Die Cognex Corporation übernimmt keine Haftung für die Verwendung oder Zuverlässigkeit ihrer Software in Verbindung mit Geräten, die nicht von der Cognex Corporation geliefert wurden. Die Cognex Corporation übernimmt weder ausdrückliche noch konkludente Gewährleistung für die genannte Software, deren Eignung für den gewöhnlichen Gebrauch oder für einen bestimmten Zweck und die Nichtverletzung von Rechten.

Der Inhalt dieses Handbuchs kann ohne Vorankündigung geändert werden und ist nicht als verbindliche Zusage seitens der Cognex Corporation auszulegen. Die Cognex Corporation schließt die Haftung für Fehler in dieser Dokumentation oder in der Software aus.

Die in den Beispielen verwendeten Firmen, Namen und Daten sind rein fiktiv, sofern nichts Anderslautendes angegeben ist. Die Reproduktion, Übertragung oder Übersetzung einzelner Teile dieses Dokuments ohne schriftliche Genehmigung der Cognex Corporation ist untersagt. Diese Beschränkung gilt unabhängig vom Format oder den verwendeten Mitteln (elektronisch oder mechanisch) und unabhängig vom Zweck.

2022 August 22 06:32

Revision: 5.9.0.2

Copyright © 2008 - 2020. Cognex Corporation. Alle Rechte vorbehalten.

Teile der von Cognex bereitgestellten Hard- und Software können durch mindestens ein US-amerikanisches und ausländisches Patent sowie durch beantragte US-amerikanische und ausländische Patente geschützt sein, die auf der folgenden Cognex Webseite aufgeführt sind: http://www.cognex.com/patents.

Folgende Handelsmarken sind eingetragene Handelsmarken der Cognex Corporation:

Cognex, 2DMAX, Advantage, AlignPlus, Assemblyplus, Check it with Checker, Checker, Cognex Vision for Industry, Cognex VSOC, CVL, DataMan, DisplayInspect, DVT, EasyBuilder, Hotbars, IDMax, In‑Sight, Laser Killer, MVS‑8000, OmniView, PatFind, PatFlex, PatInspect, PatMax, PatQuick, SensorView, SmartView, SmartAdvisor, SmartLearn, UltraLight, Vision Solutions, VisionPro, VisionView

Folgende Handelsmarken sind Handelsmarken der Cognex Corporation:

Das Cognex Logo, 1DMax, 3D‑Locate, 3DMax, BGAII, CheckPoint, Cognex VSoC, CVC‑1000, FFD, iLearn, In‑Sight (Kennzeichen mit Fadenkreuz‑), In‑Sight 2000, InspectEdge, Inspection Designer, MVS, NotchMax, OCRMax, PatMax RedLine, ProofRead, SmartSync, ProfilePlus, SmartDisplay, SmartSystem, SMD4, VisiFlex, Xpand

Andere hier erwähnte Produkte und Handelsmarken von Unternehmen sind Handelsmarken ihrer jeweiligen Besitzer.


OPC-Tags zu einer Job-Datei hinzufügen

Auf allen In-Sight-Vision-Systemen/-Sensoren, die OPC UA unterstützen, wurden System-Tags für OPC-UA-Clients vordefiniert. Diese Tags machen jedoch wahrscheinlich nicht alle Daten sichtbar, auf die Sie über den OPC-UA-Client zugreifen möchten. Daher können Job-Tags zu EasyBuilder-Inspektions- und Jobergebnissen hinzufügt werden, durch die die Werte für die Clients verfügbar werden.

  1. Wählen Sie im Gruppenfeld „Kommunikation“ die Option OPC aus.
  2. Klicken Sie im Abschnitt „Ausgewählte OPC-Tags“ auf die Schaltfläche Hinzufügen , um das Dialogfeld „OPC-Tags auswählen“ zu öffnen.
  3. Das Dialogfeld „OPC-Tags auswählen“ beinhaltet die Daten aus den jeweiligen Positions- oder Inspektions-Werkzeugen, die Ihrem Job hinzugefügt wurden, sowie die Gesamtergebnisse. Wählen Sie im Dialogfeld die entsprechenden Daten aus, die Sie aktivieren möchten.
  4. Klicken Sie nach der Auswahl der gewünschten Daten auf OK , um die Änderungen zu übernehmen. Die OPC-Tags werden nun im Abschnitt „Ausgewählte OPC-Tags“ angezeigt.
  5. Konfigurieren Sie den OPC-Server.
    • Informationen zum Einsatz von OPC UA Server finden Sie unter OPC-UA.
    • Informationen zu Einsatz von In-Sight OPC Classic Server finden Sie in der Hilfe zu In-Sight® OPC Classic Server .


OPC-UA-Server aktivieren

Wenn OPC UA verwendet wird, muss zuerst der In-Sight OPC UA Server auf dem Vision-System/‑Sensor aktiviert werden. Anschließend können Sie über den OPC-UA-Client eine Verbindung damit herstellen.

Tipp: Wenn die Zeitsynchronisierung für OPC-UA-Tag-Zeitstempel konfiguriert werden muss, verwenden Sie den erweiterten Native-Mode-Befehl „SetSystemConfig OPCUA.TimeSync“, bevor der OPC-UA-Server aktiviert wird. Weitere Informationen finden Sie unter SetSystemConfig: Zeitsynchronisierung für OPC UA.
  1. Wählen Sie im Gruppenfeld „Kommunikation“ die Option OPC aus.

  2. Aktivieren Sie das Kontrollkästchen OPC-UA-Server aktivieren .

  3. Klicken Sie auf OK.
  4. Klicken Sie in der Aufforderung auf Ja, um das Vision-System/den Vision-Sensor neu zu starten. Nach dem Neustart wird der OPC-UA-Server initialisiert und ist betriebsbereit. Der Erkennungsendpunkt ist für Anfragen des OPC-UA-Clients empfangsbereit.
  5. Öffnen Sie den OPC-UA-Client.

  6. Im OPC-UA-Client muss die Endpunkt-URL eingegeben werden, um eine Verbindung zum OPC-UA-Server herzustellen. Die Endpunkt-URL muss in folgendem Format angegeben werden. <IP-Adresse> ist hierbei die IP-Adresse des Vision-Systems/-Sensors:

    opc.tcp://<IP-Adresse>:4840

    Beispiel: opc.tcp://192.168.0.8:4840


OPC-UA

Open Platform Communications – Unified Architecture (OPC UA) ist ein modernes Kommunikationsprotokoll, das von der OPC Foundation entwickelt wurde und eine plattformunabhängige, sichere Lösung mit offener Architektur für Industriegeräte und ‑systeme bereitstellt. Für In-Sight dient das Vision-System bzw. der Vision-Sensor als OPC-UA-Server, der direkt mit einem OPC-UA-Client kommunizieren kann. Dadurch ist keine zusätzliche Hardware notwendig.

In-Sight OPC UA Server und In-Sight OPC Classic Server werden auf folgenden Modellen unterstützt. Weitere Informationen zum In-Sight OPC Classic Server finden Sie in der Hilfe zu In-Sight® OPC Classic Server .

Vision-System/-Sensor | Unterstützung für In-Sight OPC UA Server | Unterstützung für In-Sight OPC Classic Server
In-Sight Micro 1000-Serie | Nicht unterstützt | Firmware 4.x.x
In-Sight 2000-Serie | Firmware ab 5.8.0 | Nicht unterstützt
Serien In-Sight 5400 und 5600 | Nicht unterstützt | Firmware 4.x.x
In-Sight 5705 und 5705C | Nicht unterstützt | Firmware 5.x.x
In-Sight 7000-Serie | Nicht unterstützt | Firmware 4.x.x
In-Sight 7000 Gen2-Serie | Firmware ab 5.8.0 | Firmware 5.x.x
In-Sight 8000-Serie | Firmware ab 5.8.0 | Firmware 5.x.x
In-Sight 9000-Serie | Firmware ab 5.8.0 | Firmware 5.x.x
Emulatoren | Nicht unterstützt | Unterstützt

Der OPC-UA-Client kann auf folgende Daten von In-Sight-Vision-Systemen/‑Sensoren zugreifen:

  • Anzahl der Aufnahmen
  • Name des aktiven Jobs
  • Online-Status (mit Native Online, Discrete Online und GUI Online)
  • Status des Live-Video-Modus

Zusätzlich zum Abruf der Daten können OPC-UA-Clients mit In-Sight OPC UA Server folgende Vorgänge ausführen:

  • aktiven Job speichern
  • Job laden
  • Aufnahmeereignisse triggern
  • Online-Modus umschalten
  • Live-Video-Modus umschalten
Hinweis: Es liegt im Verantwortungsbereich des Designers der benutzerdefinierten Anwendung, den Zugriff auf die sichtbaren Tags des Servers (z. B. Schreiben neuer Job-Dateien, Schreiben von Zellwerten und Umschalten des Online-/Offline-Status) auf dem Vision-System/‑Sensor einzuschränken.

Außerdem kann der OPC-Client so konfiguriert werden, dass Änderungen an Werten für AddressSpace-Knoten („überwachte Elemente“) überwacht werden. Statt diese Werte konstant auf Änderungen abzufragen, können Sie Abonnements für Knoten erstellen, mit denen diese Elemente überwacht werden. Wenn eine Änderung erkannt wird, wird im Rahmen des Abonnements eine Benachrichtigung erstellt und an den OPC-UA-Client geschickt. Die Anzahl der unterstützten Sitzungen, Clients und Knoten für die überwachten Elemente hängt vom Vision-System/‑Sensor ab:

Vision-System/-Sensor | Anzahl der Sitzungen/Clients | AddressSpace-Knoten
In-Sight 2000-Serie | Eine Sitzung auf einem OPC-UA-Client. | 50 Knoten in 20 Abonnements pro Sitzung/Client.
In-Sight 7000 Gen2-Serie | Zwei Sitzungen auf zwei OPC-UA-Clients. | 250 Knoten in 20 Abonnements pro Sitzung/Client.
In-Sight 8000-Serie | Zwei Sitzungen auf zwei OPC-UA-Clients. | 250 Knoten in 20 Abonnements pro Sitzung/Client.
In-Sight 9000-Serie | Zwei Sitzungen auf zwei OPC-UA-Clients. | 250 Knoten in 20 Abonnements pro Sitzung/Client.


OPC-Tags

Ein OPC-Tag ist ein symbolischer Name, der auf die EasyBuilder-Inspektionsergebnisse eines unterstützten In-Sight-Vision-Systems/-Sensors angewendet werden kann. Das OPC-Tag ist für OPC-UA-Clients sichtbar, sodass diese auf die In-Sight-Job-Daten zugreifen können. Im Kontext der In-Sight-OPC-UA-Implementierung gibt es zwei Arten von OPC-Tags: Job-Tags und System-Tags.

Ein OPC-Tag kann für folgende Datentypen stehen:

  • Boolescher Wert: Für Tags, die nur boolesche Werte enthalten.
  • Fließpunkt: Für Tags, die nur Fließpunktwerte enthalten.
  • Ganzzahl: Für Tags, die nur Ganzzahlen enthalten.

  • Textzeichenfolge: Für Tags, die nur Textzeichenfolgen enthalten.

    Hinweis:
    • Bei Textzeichenfolgen werden maximal 256 Zeichen unterstützt.
    • Textzeichenfolgen werden als Unicode an den OPC-Client geschickt.

Für OPC-Tags gibt es die Zugriffsstufen „Lesen“ oder „Lesen/Schreiben“. Ob OPC-UA-Clients Daten aus der In-Sight-Job-Datei lesen oder in diese schreiben können, hängt von der Zugriffsstufe des OPC-Tags ab.

  • Lesen: Die Tag-Werte können vom OPC-UA-Client nur abgerufen werden.
  • Lesen/Schreiben: Die Tag-Werte können vom OPC-UA-Client abgerufen und geändert werden.


Job-Tags

OPC-UA-Job-Tags sind Tags, die vom Benutzer konfiguriert werden können und die einen Wert repräsentieren, der in der In-Sight-Job-Datei gespeichert ist; sie können von den OPC-UA-Clients eingesehen werden. Job-Tags werden in der Job-Datei gespeichert.


Fehlerbehebung

Problem Lösung

Wenn UaExpert als Client verwendet wird, reagiert das Vision-System nach 14 bis 16 Sitzungs-Zeitüberschreitungen mit einer Länge von 30 Sekunden nicht mehr auf OPC-UA-Anfragen, und die UaExpert-Clients können keine Verbindung mit dem Vision-System herstellen.

In diesem Fall erhalten neue Clients sowie die Clients, bei denen die Zeitüberschreitungen aufgetreten sind, folgenden Fehler beim Verbindungsversuch:

„Error 'BadTimeout' was returned during OpenSecureChannel“ (Fehler „Zeitüberschreitungsfehler“ wurde während OpenSecureChannel zurückgegeben).

Hinweis: In diesem Zustand funktioniert alles andere wie erwartet. Sie können die Anzahl der eingetretenen Sitzungs-Zeitüberschreitungen in der Sensorstatusansicht im In-Sight Explorer (Fenster > Sensorstatusansicht anzeigen) überprüfen.

Für UaExpert:

  • SecureChannelLifetime: Legt fest, wie lang der Kanal aktiv bleiben soll. (Standard = eine Stunde. Minimum = 5 Minuten.)
  • SessionTimeout: Legt fest, wie lange gewartet werden soll, bis die Verbindung zu einer nicht reagierenden Sitzung getrennt wird. Beachten Sie, dass der sichere Kanal auch nach einer Zeitüberschreitung aktiv bleibt. (Standard = 20 Minuten. Minimum = 30 Sekunden.)
  1. Warten Sie eine Stunde, bis SecureChannelLifetime zurückgesetzt wird.
  2. Starten Sie das Vision-System/den Vision-Sensor neu, wenn die SecureChannelLifetime sehr lang ist und in diesem Zeitraum viele Sitzungs-Zeitüberschreitungen auftreten.


Formatieren von Eingabe-/Ausgabedaten

Daten aus EasyBuilder-Jobs, wie individuelle Werkzeugergebnisse oder Gesamtergebnisse von Jobs (nur Ausgabe), können über Ethernet/IP, DeviceNet, ModBus-TCP, PROFINET und POWERLINK übertragen werden. Formatierte Eingabedaten werden gelesen, nachdem der Sensor ein Bild aufgenommen hat, und die Ausgabedaten werden gesendet, nachdem der Sensor die Jobausführung abgeschlossen hat.

Hinweis: DeviceNet, POWERLINK und CC-Link stehen nur auf In-Sight Vision-Systemen mit In-Sight Firmwareversion 4.x.x und nicht auf In-Sight Vision-Systemen mit In-Sight Firmwareversion 5.1.0 und höher zur Verfügung . Für eine komplette Liste der Modelle und der unterstützten Firmwareversionen siehe das Thema Firmwareversionen.

So formatieren Sie die Daten:

  1. Klicken Sie entweder auf die Registerkarte Formateingabedaten oder Formatausgabedaten.
  2. Klicken Sie auf die Schaltfläche Hinzufügen, um das Dialogfeld Select Input Data bzw. Select Output Data zu öffnen.
  3. Das Dialogfeld Eingabedaten auswählen oder Ausgabedaten auswählen enthält die Daten aller dem Job hinzugefügten Positions- oder Inspektionswerkzeuge und die Gesamtergebnisse des Jobs (nur Ausgang). Wählen Sie im Dialogfeld die entsprechenden Daten aus, die vom (oder an den) In-Sight-Sensor gesendet werden sollen, und klicken Sie auf OK.

  4. Nachdem Sie die Daten hinzugefügt haben, können Sie den Standarddatentyp der gewählten Daten durch Auswahl eines anderen Datentyps im Dropdown Datentyp ändern.

    Hinweis:
    • Wenn Sie in der Dropdownliste Datentyp die Option Zeichenfolge oder Byteaustausch-Zeichenfolge auswählen, wird das Steuerelement Gesamtgröße (Byte) aktiviert, und Sie können die Zeichenfolgenlänge durch Auswahl der korrekten Anzahl von Bytes festlegen.
    • Bei Verwendung von PROFINET beträgt die maximale Länge für Ein- und Ausgabedaten 4000 Byte. Bei Verwendung von POWERLINK beträgt die maximale Länge für Ein- und Ausgabedaten 256 Byte.

  5. Sie können auch die Bytereihenfolge anpassen, indem Sie durch Deaktivieren des standardmäßig aktivierten Kontrollkästchens High-Byte/Low-Byte die Reihenfolge Low-Byte/High-Byte festlegen (standardmäßig für alle Protokolle außer PROFINET deaktiviert). Sie können die Wortreihenfolge anpassen, indem Sie durch Deaktivieren des standardmäßig deaktivierten Kontrollkästchens High-Word/Low-Word die Reihenfolge Low-Word/High-Word festlegen. Alle an der Registerkarte „Formatausgabedaten“ vorgenommenen Änderungen werden im Vorschaufenster aktualisiert.

    Hinweis: Alle Änderungen der Byte- und Wortreihenfolge beeinflussen die Datensignale auf den Registerkarten Formateingabedaten und Formatausgabedaten.
  6. Sie können die Reihenfolge der zu sendenden oder empfangenen Daten ändern, indem Sie die Daten in der Liste auswählen und die gewünschte Reihenfolge mit den Schaltflächen Nach oben oder Nach unten festlegen.


Tabelle der Standardeingangsleitungen

Geschlossen In-Sight Micro 1000-Serie
Leitung | Direktes E/A | CIO-MICRO | CIO-MICRO-CC | CIO-WENET
0 | Deaktiviert | Leitung 0 | Leitung 0 | Leitung 0
1 | Deaktiviert | Leitung 1 | Leitung 1 | Leitung 1
2 | Deaktiviert | Zeile 2 | Zeile 2 | Zeile 2
3 | Deaktiviert | Leitung 3 | Leitung 3 | Leitung 3
4 | Deaktiviert | Leitung 4 | Leitung 4 | Leitung 4
5 | Deaktiviert | Leitung 5 | Leitung 5 | Leitung 5
6 | Deaktiviert | Leitung 6 | Leitung 6 | Leitung 6
7 | Deaktiviert | Leitung 7 | Leitung 7 | Leitung 7
8 | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
9 | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
10 | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
11 | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
Geschlossen In-Sight 2000-Serie
Leitung | Direktes E/A | CIO-1400
0 | IN 01 | Deaktiviert
1 | Deaktiviert | Leitung 1
2 | Deaktiviert | Zeile 2
3 | Deaktiviert | Leitung 3
4 | Deaktiviert | Leitung 4
5 | Deaktiviert | Leitung 5
6 | Deaktiviert | Leitung 6
7 | Deaktiviert | Leitung 7
8 | Deaktiviert | Deaktiviert
9 | Deaktiviert | Deaktiviert
10 | Deaktiviert | Deaktiviert
11 | Deaktiviert | Deaktiviert
1Integrierter Eingang, direkt vom In-Sight-Vision-Sensor.
Hinweis: Direkte (integrierte) Eingänge von Vision-Systemen der In-Sight 2000-Serie werden nur unterstützt, wenn das Vision-System mit dem Netz- und E/A-Breakoutkabel verbunden ist.
Geschlossen In-Sight 5000-Serie
Leitung | Direct/CIO-1350 | CIO-1400 | CIO-1450 | CIO-1460 | CIO-MICRO | CIO-MICRO-CC
0 | Deaktiviert | Deaktiviert | Leitung 0 | Leitung 0 | Leitung 0 | Leitung 0
1 | Deaktiviert | Leitung 1 | Leitung 1 | Leitung 1 | Leitung 1 | Leitung 1
2 | Deaktiviert | Zeile 2 | Zeile 2 | Zeile 2 | Zeile 2 | Zeile 2
3 | Deaktiviert | Leitung 3 | Leitung 3 | Leitung 3 | Leitung 3 | Leitung 3
4 | Deaktiviert | Leitung 4 | Leitung 4 | Leitung 4 | Leitung 4 | Leitung 4
5 | Deaktiviert | Leitung 5 | Leitung 5 | Leitung 5 | Leitung 5 | Leitung 5
6 | Deaktiviert | Leitung 6 | Leitung 6 | Leitung 6 | Leitung 6 | Leitung 6
7 | Deaktiviert | Leitung 7 | Leitung 7 | Leitung 7 | Leitung 7 | Leitung 7
8 | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
9 | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
10 | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
11 | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
Geschlossen In-Sight 7000-Serie
Hinweis:
  • Das Vision-System der In-Sight 70xx-74xx-Serie unterstützt den gleichzeitigen Anschluss des Breakout-Kabels und des CIO-MICRO- oder CIO-MICRO-CC E/A-Moduls.

  • Direkte (integrierte) Eingänge werden nur unterstützt, wenn das Vision-System mit dem Breakout-Kabel verbunden ist.

  • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.
  • Ist das Vision-System der In-Sight 70xx-74xx-Serie für die Verwendung mit dem E/A-Modul CIO-MICRO oder CIO-MICRO-CC konfiguriert, sind die Pins des RS-232-Ausgangs und des RS-232-Eingangs am E/A-Breakout-Kabel deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.
Vorsicht:
  • Beim Anschließen des Vision-Systems In-Sight der Serie 70xx-74xx an das E/A-Modul CIO-MICRO oder CIO-MICRO-CC werden der E/A-Port (DB15) und die Anschlussklemmen TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 und HS COMMON des E/A-Moduls nicht unterstützt. Verbinden Sie niemals die Drähte von Remotegeräten mit diesen Anschlussklemmen.
  • Beim Anschließen des Vision-Systems In-Sight 7000 an das CIO-MICRO- oder CIO-MICRO-CC-E/A-Modul wird der E/A-Port (DB15) des E/A-Moduls nicht unterstützt. Verwenden Sie diesen Anschluss nicht.
Leitung | Direktes E/A | CIO-MICRO | CIO-MICRO-CC
0 | Deaktiviert | Leitung 0 | Leitung 0
1 | IN 11/Seriell Empfangen | Leitung 1 | Leitung 1
2 | IN 21 | Zeile 2 | Zeile 2
3 | IN 31 | Leitung 3 | Leitung 3
4 | Deaktiviert | Leitung 4 | Leitung 4
5 | Deaktiviert | Leitung 5 | Leitung 5
6 | Deaktiviert | Leitung 6 | Leitung 6
7 | Deaktiviert | Leitung 7 | Leitung 7
8 | Deaktiviert | Deaktiviert | Deaktiviert
9 | Deaktiviert | IN 11 | IN 11
10 | Deaktiviert | IN 21 | IN 21
11 | Deaktiviert | IN 31 | IN 31
1Integrierte Eingänge, direkt vom In-Sight-Vision-System. |  |  |
Geschlossen In-Sight 8000-Serie
Leitung | Direktes E/A | CIO-MICRO
0 | Deaktiviert | Leitung 0
1 | Deaktiviert | Leitung 1
2 | Deaktiviert | Zeile 2
3 | Deaktiviert | Leitung 3
4 | Deaktiviert | Leitung 4
5 | Deaktiviert | Leitung 5
6 | Deaktiviert | Leitung 6
7 | Deaktiviert | Leitung 7
8 | Deaktiviert | Deaktiviert
9 | Deaktiviert | Deaktiviert
10 | Deaktiviert | Deaktiviert
11 | Deaktiviert | Deaktiviert


Anzahl der Eingänge

Die Anzahl der direkten (integrierten) Eingänge variiert je nach In-Sight-Vision-System wie folgt:

In-Sight Vision-System | Direkte (integrierte) Eingänge1
In-Sight Micro 1000-Serie | Keine
In-Sight 2000-Serie | 1 Allzweckeingang
In-Sight 5000-Serie | Keine
In-Sight 7000-Serie | 2 Allzweckeingänge
In-Sight 8000-Serie | Keine
1 In-Sight Vision-Systeme besitzen einen fest zugeordneten Aufnahmetriggereingang im Vision-System. Weitere Informationen finden Sie im Vision-System Installationshandbuch, das in der In-Sight Explorer Software enthalten ist.

Mit einem E/A-Modul können zusätzliche diskrete Eingänge zur Verfügung gestellt werden. Die Anzahl der diskreten Eingänge variiert je nach entsprechendem E/A-Modul wie folgt:

E/A-Modul- | Unterstütztes In-Sight Vision-System | Diskrete Eingänge
CIO-14002 | In-Sight 5000-Serie (außer 5604), In-Sight 2000-Serie | 7 Allzweckeingänge
CIO-MICRO23 | In-Sight Micro 1000-Serie, In-Sight 5000-Serie, In-Sight 7000-Serie, In-Sight 8000-Serie | 8 Allzweckeingänge
CIO-MICRO-CC3 | In-Sight Micro 1000-Serie, In-Sight 5000-Serie (ausser 5705, 5705C und 5715), In-Sight 7000-Serie | 8 Allzweckeingänge
CIO-14504 | In-Sight 5000-Serie (außer 5604, 5705, 5705C und 5715) | 8 Allzweckeingänge
CIO-14604 | In-Sight 5000-Series (außer 5604, 5605, 5705, 5705C und 5715) | 8 Allzweckeingänge
CIO-WENET4 | In-Sight Micro 1000-Serie | 8 Allzweckeingänge

1 Das E/A-Modul CIO-1400 unterstützt die Vision-Sensoren der In-Sight 2000-Serie mit Firmwareversion 5.3.0 und höher.

2 Das E/A-Modul CIO-MICRO unterstützt die Vision-Systeme 5705, 5705C, 5715 und die Vision-Systeme der In-Sight 8000-Serie mit Firmwareversion 5.3.0 und höher.

3 Von den CIO-MICRO- und CIO-MICRO-CC-E/A-Modulen werden nur die In-Sight-Vision-Systeme der Serien 5100 und 5400 mit mindestens 128 MB nicht flüchtigem Flashspeicher unterstützt. Die Modelle sind anhand der Typnummer erkennbar (821-xxxx-xx). Die Typnummer befindet sich auf dem am Vision-System befestigten Etikett. Eine vollständige Liste mit Modellen sowie Angaben zu Typnummer nicht-flüchtigem Flashspeicher finden Sie hier.

4 Die Module CIO-1450, CIO-1460 und CIO-WENET I/O sind veraltet und werden nicht mehr zum Kauf angeboten. Sie werden jedoch weiterhin im In-Sight Explorer unterstützt, sind allerdings nur abwärtskompatibel.
Vorsicht:
  • Beim Anschließen des Vision-Systems In-Sight der Serie 70xx-74xx an das E/A-Modul CIO-MICRO oder CIO-MICRO-CC werden der E/A-Port (DB15) und die Anschlussklemmen TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 und HS COMMON des E/A-Moduls nicht unterstützt. Verbinden Sie niemals die Drähte von Remotegeräten mit diesen Anschlussklemmen.
  • Beim Anschließen des Vision-Systems In-Sight 7000 an das CIO-MICRO- oder CIO-MICRO-CC-E/A-Modul wird der E/A-Port (DB15) des E/A-Moduls nicht unterstützt. Verwenden Sie diesen Anschluss nicht.
Hinweis:
  • Das Vision-System der In-Sight 70xx-74xx-Serie unterstützt den gleichzeitigen Anschluss des Breakout-Kabels und des CIO-MICRO- oder CIO-MICRO-CC E/A-Moduls.

  • Direkte (integrierte) Eingänge werden nur unterstützt, wenn das Vision-System mit dem Breakout-Kabel verbunden ist.

  • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.
  • Ist das Vision-System der In-Sight 70xx-74xx-Serie für die Verwendung mit dem E/A-Modul CIO-MICRO oder CIO-MICRO-CC konfiguriert, sind die Pins des RS-232-Ausgangs und des RS-232-Eingangs am E/A-Breakout-Kabel deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.


Caliperarray

Caliperarrays werden verwendet, um Kanten in einem Bildbereich mithilfe der Kantenmodellmethode zu isolieren. Dabei werden Kantenspitzen innerhalb einzelner Caliper unter Verwendung eines 1D-Kernels erkannt. Das Caliperarray erzeugt eine 1D-Darstellung des Bildbereichs, das die zu isolierenden Kanten enthält. Dieses 1D-Bild zeigt nicht nur die zu isolierenden Kanten, sondern auch alle anderen durch Rauschen und andere unerwünschte Informationen verursachten Kanten im Originalbild. Wenn auf der Registerkarte Kanten der Werkzeuge, die das Caliperarray verwenden, die Parameter Caliper-Größe, Kantenbreite und Mindestkontrast auf das 1D-Bild angewendet werden, werden die zu analysierenden Kanten verstärkt, während gleichzeitig das Bildrauschen reduziert wird.

Jedes Caliper im Array wird einzeln bewertet, und die enthaltenen Kantenkandidaten werden ausgewertet, um die Kantenauswahl festzuglegen. Für Positionsfehler wird basierend auf jeder gefundenen Kante eine eingepasste Linie erzeugt. Fehler werden durch den Vergleich der gefundenen Kante und der eingepassten Linie festgestellt und Abweichungen von den angegebenen Toleranzen ermittelt. Für Breitenfehler wird der Abstand zwischen den beiden Kanten im Caliper berechnet. Fehler werden durch den Vergleich des Abstands mit dem erwarteten Bereich ermittelt.

Das Caliperarray innerhalb des Bereichs legt die Größe der erkennbaren Fehler und/oder Zwischenräume fest. Die Größe des ermittelten Fehlers oder Zwischenraums wird durch die Anzahl der erkennbaren Kanten ermittelt, die wiederum durch die Anzahl der entlang der Kante platzierten Caliper festgelegt wird. Die Caliper werden innerhalb des Bereichs als rote Rechtecke angezeigt, wenn das Kontrollkästchen Alle Caliper anzeigen aktiviert ist (standardmäßig deaktiviert).

Hinweis: Je mehr Caliper im Bereich angewendet werden, desto schneller ist die Werkzeugausführung.


Hinzufügen und Bearbeiten von Farbmodellen

Ein Farbmodell ist eine Zusammenstellung von Farben, die zur Definition eines Objekts und eines Hintergrunds in einem Bild verwendet werden. Jedes Farbmodell stellt ein 3D-Farbspektrum dar, in dem die RGB-Werte der Farben des Objekts und des Hintergrunds hinzugefügt und subtrahiert werden können.

Geschlossen Hinzufügen eines Farbmodells
  1. Wählen Sie auf der Registerkarte „Einstellungen“ die Farbbibliothek aus, auf die vom Dropdownmenü Farbbibliothek verwiesen werden soll. Standardmäßig ist die erste Farbbibliothek (ExtractColorLibrary_1) ausgewählt.
  2. Klicken Sie auf die Schaltfläche Farbe einlernen, um das Dialogfeld ExtractColor – Einlernen zu öffnen.
  3. Klicken Sie im Dialogfeld „ExtractColor – Einlernen“ im Gruppenfeld Farbmodelle auf die Schaltfläche Neues Modell, um der Farbbibliothek ein neues Farbmodell hinzuzufügen. Der Standardname lautet „Model_1“, wenn dies das erste Farbmodell ist, das der Farbbibliothek hinzugefügt wird. Andernfalls werden fortlaufende Nummern an den Namen angehängt, z. B. „Model_2“, „Model_3“ usw.).
  4. Geben Sie dem Farbmodell ggf. einen Namen, der speziell auf Ihre Anwendung zugeschnitten ist. Dies empfiehlt sich besonders, wenn mehrere Farbmodelle vorhanden sind. Ein Farbmodell kann jederzeit umbenannt werden, indem Sie das Farbmodell markieren und über dem Verzeichnis Farbbibliothek auf die Schaltfläche Umbenennen klicken.
  5. Farbmodelle werden entfernt, indem Sie das Farbmodell auswählen und auf die Schaltfläche Modell löschen klicken.
Geschlossen Hinzufügen und Subtrahieren von Farben im Farbmodell
Geschlossen Hinzufügen oder Subtrahieren einer einzelnen Farbe von bzw. zu einem Farbmodell
  1. Wählen Sie das Farbmodell, das geändert werden soll.
  2. Wählen Sie im Gruppenfeld für das Einlernen Dominanteste Farbe (Standardeinstellung) aus.
  3. Wählen Sie im Gruppenfeld für das Einlernen den Typ des Bereichs aus, der zur Definition der Farbe verwendet werden soll: Bereich, Kreis, Annulus, Polygon oder Freihand.
  4. Klicken Sie auf die Schaltfläche Neue Farbe hinzufügen oder Neue Farbe subtrahieren, und konfigurieren Sie den Bereich innerhalb des Bilds so, dass er nur die RGB-Werte enthält, die hinzugefügt oder subtrahiert werden sollen.
  5. Klicken Sie entweder doppelt auf den Bereich, oder klicken Sie nach der Konfiguration des Bereichs auf der Symbolleiste zur Bearbeitung von Jobs auf die Schaltfläche OK.
  6. Beim Hinzufügen enthält die Farbe, die dem Farbmodell hinzugefügt wird, die RGB-Höchstwerte des Bereichs. Diese Werte werden dem kumulativen Farbmodell hinzugefügt.
  7. Beim Subtrahieren enthält die Farbe, die dem Farbmodell hinzugefügt wird, die RGB-Höchstwerte des Bereichs. Diese Werte werden vom kumulativen Farbmodell subtrahiert.
  8. Farben in der Liste der Farbmodelle können innerhalb der Liste verschoben werden, wodurch die Farbe geändert werden kann, mit der der Vorgang beginnt oder endet. Die erste Farbe, die auf die Inspektion angewendet wird, wird zuerst aufgeführt.
Geschlossen Hinzufügen oder Subtrahieren mehrerer Farben von bzw. zu einem Farbmodell
  1. Wählen Sie das Farbmodell, das geändert werden soll.
  2. Wählen Sie im Gruppenfeld für das Einlernen die Option Mehrere Farben aus.
  3. Wählen Sie im Gruppenfeld für das Einlernen den Typ des Bereichs aus, der zur Definition der Farbe verwendet werden soll: Bereich, Kreis, Annulus, Polygon oder Freihand.
  4. Klicken Sie auf die Schaltfläche Neue Farbe hinzufügen oder Neue Farbe subtrahieren, und konfigurieren Sie den Bereich innerhalb des Bilds so, dass er nur die RGB-Werte enthält, die hinzugefügt oder subtrahiert werden sollen.
  5. Klicken Sie entweder doppelt auf den Bereich, oder klicken Sie nach der Konfiguration des Bereichs auf der Symbolleiste zur Bearbeitung von Jobs auf die Schaltfläche OK.
  6. Beim Hinzufügen enthält die Farbe, die dem Farbmodell hinzugefügt wird, die RGB-Höchstwerte des Bereichs. Diese Werte werden dem kumulativen Farbmodell hinzugefügt.
  7. Beim Subtrahieren enthält die Farbe, die dem Farbmodell hinzugefügt wird, die RGB-Höchstwerte des Bereichs. Diese Werte werden vom kumulativen Farbmodell subtrahiert.
  8. Farben in der Liste der Farbmodelle können innerhalb der Liste verschoben werden, wodurch die Farbe geändert werden kann, mit der der Vorgang beginnt oder endet. Die erste Farbe, die auf die Inspektion angewendet wird, wird zuerst aufgeführt.
Geschlossen Anpassen der Farbtoleranz einer Farbe

Durch die Verwendung der Steuerelemente zur Bildmarkierung mit den Steuerelementen für die Farbtoleranz kann festgelegt werden, wie viel vom Objekt erkannt wird. Passen Sie im Dialogfeld ExtractColor – Einlernen im Gruppenfeld Farbtoleranz die Steuerelemente (Dunkler, Heller, Aufhellungen und Farbtöne) an, um die Empfindlichkeit des Werkzeugs zu erhöhen oder zu verringern.

Tipp: Positionieren Sie bei der Konfiguration der Steuerelemente für die Farbtoleranz das Dialogfeld „ExtractColor – Einlernen“ so, dass das Bild bequem betrachtet werden kann. Das Bild spiegelt gemäß des ausgewählten Typs der Bildmarkierung die Änderungen wider, die mittels der Steuerelemente vorgenommen wurden.
Geschlossen Steuerelemente für Farbtoleranz
Geschlossen Dunkler

Durch das Erhöhen dieses Einstellungswerts wird der Farbe mehr Raum Richtung Schwarz hinzugefügt (0, 0, 0).

Geschlossen Heller

Durch das Erhöhen dieses Einstellungswerts wird der Farbe mehr Raum Richtung Weiß hinzugefügt (255, 255, 255).

Geschlossen Aufhellungen

Durch das Erhöhen dieses Einstellungswerts wird der Farbe von der Position der ursprünglichen Farbe mehr Raum Richtung Weiß hinzugefügt (255, 255, 255).

Geschlossen Farbton

Durch das Erhöhen dieses Einstellungswerts wird der 3D-„Raum“ der ursprünglichen Farbe in drei Dimensionen innerhalb des Farbspektrums erweitert.

Geschlossen Steuerelemente zur Bildmarkierung

Mit den Schaltflächen zur Bildmarkierung wird festgelegt, welche Bereiche des Bilds beim Hinzufügen/Subtrahieren von Farbe(n) und Farbmodellen hervorgehoben werden.

Geschlossen Ergebnisse für gesamte Gruppe markieren

Alle Farben des Farbmodells werden im Bild markiert.

Geschlossen Ergebnisse bis zur ausgewählten Farbe markieren

Bei Auswahl der zweiten Farbe aus einer Auflistung von drei Farben werden die erste und die zweite Farbe im Bild markiert.

Geschlossen Nur ausgewählte Farben markieren

Nur die ausgewählte Farbe wird im Bild markiert.

Geschlossen Bearbeiten eines Farbmodells
  1. Wählen Sie auf der Registerkarte „Einstellungen“ die Farbbibliothek aus, auf die vom Dropdownmenü Farbbibliothek verwiesen werden soll.
  2. Klicken Sie auf die Schaltfläche Farbe einlernen, um das Dialogfeld ExtractColor – Einlernen zu öffnen.
  3. Wählen Sie das zu ändernde Farbmodell, und verwenden Sie die Steuerelemente im Dialogfeld, um das Farbmodell zu bearbeiten.


Hinzufügen und Bearbeiten von Farben

Farben werden nach einem Bereich definiert und speichern die durchschnittlichen RGB- und HSI-Werte, die zum Zeitpunkt des Einlernens im Bereich enthalten sind. Die Bibliothek kann bis zu 100 verschiedene Farben enthalten, die sich aus den RGB/HSI-Werten des geprüften Objekts zusammensetzen.

Geschlossen Hinzufügen einer Farbe
  1. Wählen Sie auf der Registerkarte „Einstellungen“ die Farbbibliothek aus, die vom Dropdownmenü Farbbibliothek aus referenziert werden soll. Standardmäßig ist die erste Farbbibliothek (MatchColorLibrary_1) ausgewählt.
  2. Klicken Sie auf die Schaltfläche Farben einlernen, um das Dialogfeld „MatchColor einlernen“ zu öffnen.
  3. Wählen Sie im Gruppenfeld Einlernen den Typ des Bereichs aus, der zum Definieren der Farbe verwendet wird: Bereich, Kreis, Ring, Polygon, Freihand oder Punkt.
  4. Klicken Sie auf die Schaltfläche Neue Farbe hinzufügen, und konfigurieren Sie den Bereich innerhalb des Bilds, sodass nur die RGB-Werte eingeschlossen werden, die Sie hinzufügen oder subtrahieren möchten.
  5. Doppelklicken Sie entweder auf den Bereich oder auf die Schaltfläche OK in der Symbolleiste „Job bearbeiten“, nachdem Sie den Bereich konfiguriert haben.
  6. Benennen Sie auf Wunsch die Farbe mit einem Namen um, der besser zu Ihrer Anwendung passt, vor allem, wenn Sie mehrere Farben verwenden möchten. Eine Farbe kann jederzeit umbenannt werden, indem Sie die Farbe markieren und auf die Schaltfläche Umbenennen über dem Verzeichnis Farbbibliothek klicken.
  7. Farben können aus der Liste entfernt werden, indem Sie die Farbe auswählen und auf die Schaltfläche Modell löschen klicken.
Geschlossen Anpassen der Fabtoleranz einer Farbe

Mit den Farbtoleranz-Steuerungen können Sie festlegen, wie viel Ihres Objekts erkannt wird, und Sie können die Farbtoleranz-Steuerungen anpassen, um die Empfindlichkeit des Werkzeugs zu erhöhen oder zu verringern, indem Sie die Einstellungen im Gruppenfeld Farbtoleranz im Dialogfeld „MatchColor einlernen“ verwenden.

Tipp: Positionieren Sie beim Konfigurieren der Farbtoleranz-Steuerungen das Dialogfeld „MatchColor einlernen“ so, dass Sie das Bild leicht sehen können. Während Sie die Steuerungen anpassen, wird das Bild aktualisiert, um den Änderungen zu entsprechen.
Geschlossen Dunkler

Gibt die „Grenze dunkler“ an (0 bis 1,0; Standard = 1,0). Wenn das Farbspektrum auf RGB festgelegt ist, erweitert „Grenze dunkler“ die eingelernte Farbe proportional niedriger entlang einer Linie von (0,0,0) bis zum RGB-Wert der eingelernten Farbe. Wenn das Farbspektrum auf HSI festgelegt ist, erweitert „Grenze dunkler“ den Intensitätswert der eingelernten Farbe nach unten.

Geschlossen Heller

Gibt die „Grenze heller“ an (1,0 bis 10,0; Standard = 1,0). Wenn das Farbspektrum auf RGB festgelegt ist, erweitert „Grenze heller“ die eingelernte Farbe proportional nach oben entlang einer Linie von (0,0,0) bis zum RGB-Wert der eingelernten Farbe. Wenn das Farbspektrum auf HSI festgelegt ist, erweitert „Grenze heller“ den Intensitätswert der eingelernten Farbe nach oben.

Geschlossen Bearbeiten eines Farbmodells
  1. Wählen Sie auf der Registerkarte „Einstellungen“ die Farbbibliothek aus, die vom Dropdownmenü Farbbibliothek aus referenziert werden soll.
  2. Klicken Sie auf die Schaltfläche Farben einlernen, um das Dialogfeld „ExtractColor einlernen“ zu öffnen.
  3. Wählen Sie das zu ändernde Farbmodell aus und nutzen Sie die Steuerungen im Dialogfeld zum Bearbeiten des Farbmodells.


Kantenkandidaten

Bei der Verwendung eines Werkzeugs, das Caliperarrays enthält, werden Kantenkandidaten anhand kleiner, farbcodierter Kreise angezeigt.

Geschlossen Beispiel – bestandene eingepasste gerade Linie

Geschlossen Beispiel – fehlerhafte eingepasste gerade Linie

Geschlossen Beispiel – fehlerhafte eingepasste Kreislinie


An-/Abwesenheitswerkzeug „Schärfe“ – Registerkarte „Einstellungen“

Geschlossen Glattheit

Dient zum Angeben eines Bildglättungsvorgangs (0 - 2; Standard = 0) zur Beseitigung von Hochfrequenzrauschen, das möglicherweise in dem Bereich vorliegt. Wird der Wert auf „0“ festgelegt, erfolgt keine Glättung. Diese Einstellung bietet die höchste Leistung. Bei Verwendung des Werts „1“ erfolgt eine Glättung, durch die sehr hochfrequentes Rauschen innerhalb des Bereichs beseitigt wird. Bei Verwendung des Werts „2“ erfolgt eine umfangreichere Glättung, durch die hochfrequentes sowie sehr hochfrequentes Rauschen innerhalb des Bereichs beseitigt wird.


Konfigurieren einer Ausgangsleitung

  1. Klicken Sie auf die Schaltfläche E/A-Modul, um das Dialogfeld E/A-Modulkonfiguration zu öffnen.
  2. Konfigurieren Sie das E/A-Modul, und klicken Sie auf OK, um das Dialogfeld „E/A-Modulkonfiguration“ zu schließen. Nach dem ersten erfolgreichen Verbindungsaufbau zwischen dem Vision-System und dem E/A-Modul wird in der Liste neben dem Modul der Hinweis „(angefügt)“ angezeigt. Nachdem Sie eine Verbindung zu einem E/A- Modul hergestellt haben, können Sie mit dem Anpassen der Leitungen beginnen.
  3. Wählen Sie eine zu konfigurierende Ausgangsleitung aus. Die Anzahl verfügbarer Ausgänge variiert abhängig vom In-Sight-Modell und dem entsprechenden E/A-Modul. Weitere Informationen finden Sie in dieser Tabelle.
  4. Sie können den Namen der Standardleitung anpassen, indem Sie einen neuen, für Ihre Anwendung spezifischen Namen eingeben. Der Name kann bis zu 15 Zeichen lang sein und dient nur zu Referenzzwecken. Er hat keinen Einfluss auf die Funktionalität der Leitung, und es kann nicht auf ihn verwiesen werden.

  5. Definieren Sie anschließend einen Signaltyp für die ausgewählte Leitung. Jede Leitung kann für eine der folgenden Funktionen konfiguriert werden:

    Signaltyp | Beschreibung
    Jobergebnis (Standard) | Ermöglicht die Steuerung des Status dieser Ausgangsleitung durch das Ergebnis eines Positions- oder Inspektionswerkzeugs. Entweder gepulster oder steter Status.
    High (Hoch) | Zwingt den Ausgang auf HIGH (1).
    Low (Niedrig) | Zwingt den Ausgang auf LOW (0).
    Acquisition Start (Start Bildaufnahme)

    Signalisiert, dass das Vision-System eine Bildaufnahme initiiert hat. Immer gepulst.

    Hinweis: Beim Vision-System In-Sight 8405, wird bei der Belichtung der ersten Pixelzeile das Signal Start Bildaufnahme gepulst. Weitere Informationen finden Sie in den Hinweisen zum Betrieb des Rolling-Shutter.
    Acquisition End (Ende Bildaufnahme)

    Signalisiert das Ende der Vision-Systemaufnahme. Immer gepulst.

    Hinweis: Beim Vision-System In-Sight 8405 wird das Signal Ende Bildaufnahme gepulst, wenn das ganze Bild eingelesen wurde. Weitere Informationen finden Sie in den Hinweisen zum Betrieb des Rolling-Shutter.
    Job Completed (Parametersatz beendet) | Signalisiert den Abschluss jeder Aktualisierung durch EasyBuilder. Immer gepulst.
    System Busy (System in Betrieb) | HIGH, wenn das Vision-System einen Job ausführt oder auf eine Benutzereingabe reagiert, LOW bei Leerlauf des Vision-Systems.
    Job Load OK (Parametersatz geladen) | Signalisiert das erfolgreiche Laden eines Parametersatzes. Immer gepulst.
    Job Load Fail (Parametersatz nicht geladen) | Signalisiert einen Fehler beim Laden eines Jobs. Immer gepulst.
    FEHLER: Bild verpasst

    Zeigt an, dass ein Aufnahmetrigger empfangen wurde, bevor ein Signal zum Aufnahmeende gesendet wurde; oder dass kein Bild-Zwischenspeicher für die Bildaufnahme zur Verfügung stand, als der Aufnahmetrigger empfangen wurde. Immer gepulst.

    Hinweis: Der Parameter "Trigger" im Gruppenfeld "Aufnahmeeinstellungen bearbeiten" des Schrittes "Bild einrichten" muss auf Kamera eingestellt werden, wenn Sie das Ausgangssignal FEHLER: Bild verpasst verwenden
    FEHLER: Überlauf | Signalisiert, dass EasyBuilder nach dem erwarteten Zeitpunkt ein verzögertes diskretes Ausgangssignal ausgegeben hat. Immer gepulst.
    FEHLER: Erkennungswarteschlange voll | Signalisiert, dass EasyBuilder ein verzögertes diskretes Ausgangssignal für eine Leitung ausgegeben hat, für die zuvor eine andere Ausgabe zum gleichen Zeitpunkt geplant war. Immer gepulst.
    Online/Offline | HIGH (1), wenn das Vision-System online ist, LOW (0), wenn das Vision-System offline ist.
    Abtastimpuls | Mit der steigenden oder fallenden Flanke des Signals kann ein Abtastimpuls getriggert werden.
    Lichtsteuerung
    (Nur CIO-1460)     		Mit der steigenden oder fallenden Flanke des Signals kann eine Beleuchtung getriggert werden.
    I/O Module Standby (I/O-Modul bereit)
    (Nur CIO-1460 und CIO-1450)

    ON bedeutet, dass das E/A-Modul einen Kommunikationsfehler zwischen dem Vision-System und dem E/A-Modul erkannt hat und versucht, die Kommunikation wiederherzustellen. Die Leitung wird deaktiviert (OFF), wenn das E/A-Modul erkennt, dass der Fehler behoben wurde.

    Hinweis: Dieser Ausgangstyp ist nur für die Leitungen 0 bis 7 beim Konfigurieren des CIO-1450 oder CIO-1460 gültig.
    Funktionalität OK
    [Nur CIO-MICRO und CIO-MICRO-CC]     		HIGH, wenn das In-Sight Micro-Vision-System mit dem CIO-MICRO oder dem CIO-MICRO-CC verbunden ist. LOW, wenn die Verbindung mit dem Vision-System fehlschlägt.
    Wellenform

    Aktiviert die Wellenformfunktion WriteWaveformPulseTrain oder WriteWaveformClocked zum Steuern des Status dieser Ausgangsleitung.

    Hinweis: Diese Option erfordert Zugriff auf die Arbeitsblattansicht.
    Seriell Übertragen

    Konfiguriert die Leitung als eine serielle Übertragungsleitung.

    Hinweis:
    • Dieser Signaltyp ist nur bei Verbindung eines Vision-Systems der In-Sight 70xx-74xx-Serie mit In-Sight Explorer 4.7.1 oder höher und In-Sight 4.7.1-Firmware oder höher verfügbar.
    • Dieser Ausgangstyp ist für Leitung 1 nur gültig, wenn Direktes E/A ausgewählt ist.
    • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.
    • Ist das Vision-System der In-Sight 70xx-74xx-Serie für die Verwendung mit dem E/A-Modul CIO-MICRO oder CIO-MICRO-CC konfiguriert, sind die Pins des RS-232-Ausgangs und des RS-232-Eingangs am E/A-Breakout-Kabel deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.
  6. Klicken Sie auf die Schaltfläche Details, um das Dialogfeld Output Details für die ausgewählte Ausgangsleitung anzuzeigen, wenn detaillierte Einstellungen für den festgelegten Signaltyp des Ausgangs verfügbar sind.

  7. Aktivieren Sie ggf. das Kontrollkästchen Deaktiviert die Ausgabe im Offlinezustand, um die Ausgänge zu deaktivieren, während das Vision-System offline ist.

    Hinweis: Wenn das Kontrollkästchen Deaktiviert die Ausgabe im Offlinezustand markiert ist und am CIO-MICRO- oder CIO-MICRO-CC E/A-Modul eine Ausgangsleitung als Signaltyp Funktionalität OK konfiguriert ist, wird, wenn das verbundene Vision-System auf Offline gestellt wird, die Leitung auf HIGH bleiben.
  8. Änderungen an den Einstellungen werden automatisch im Vision-System (nicht in der Job-Datei) gespeichert, wenn Sie den Schritt verlassen. Klicken Sie auf Übernehmen, um die Änderungen zu speichern und den Status auf der Registerkarte I/O der Palette anzuzeigen, ohne den Schritt zu verlassen.


Tabelle der Standardausgangsleitungen

Geschlossen In-Sight Micro 1000-Serie
Leitung | Direktes E/A | CIO-MICRO | CIO-MICRO-CC | CIO-WENET
0 | HSOUT 01 | Leitung 0 | Leitung 0 | Leitung 0
1 | HSOUT 11 | Leitung 1 | Leitung 1 | Leitung 1
2 | Deaktiviert | Zeile 2 | Zeile 2 | Zeile 2
3 | Deaktiviert | Leitung 3 | Leitung 3 | Leitung 3
4 | Grüne LED | Leitung 4 | Leitung 4 | Leitung 4
5 | Rote LED | Leitung 5 | Leitung 5 | Leitung 5
6 | Deaktiviert | Leitung 6 | Leitung 6 | Leitung 6
7 | Deaktiviert | Leitung 7 | Leitung 7 | Leitung 7
8 | Deaktiviert | HSOUT 01 | HSOUT 01 | HSOUT 01
9 | Deaktiviert | HSOUT 11 | HSOUT 11 | HSOUT 11
10 | Deaktiviert | Grüne LED | Grüne LED | Grüne LED
11 | Deaktiviert | Rote LED | Rote LED | Rote LED
12 | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
13 | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
1Direkte Hochgeschwindigkeitsausgänge vom Vision-System.
Geschlossen In-Sight 2000-Serie
Leitung | Direktes E/A | CIO-1400
0 | HSOUT 01 | HSOUT 01
1 | HSOUT 11 | HSOUT 11
2 | HSOUT 21 | Zeile 2
3 | HSOUT 31 | Leitung 3
4 | Grüne LED2 | Leitung 4
 | Rote LED2 | Leitung 5
5 | Gelbe LED | Leitung 6
7 | Deaktiviert | Leitung 7
8 | Deaktiviert | Grüne LED
9 | Deaktiviert | Rote LED
10 | Deaktiviert | Gelbe LED
11 | Deaktiviert | Deaktiviert
12 | Deaktiviert | Deaktiviert
1Hochgeschwindigkeitsausgänge direkt vom Vision-Sensor. 2 Ein einziger LED-Ausgang, der sowohl rote als auch grüne Statusse hat, die der Anwender konfigurieren kann.
Geschlossen In-Sight 5000-Serie
Leitung | Direct/CIO-1350 | CIO-1400 | CIO-1450 | CIO-1460 | CIO-MICRO | CIO-MICRO-CC
0 | HSOUT 01 | HSOUT 01 | Leitung 0 | Leitung 0 | Leitung 0 | Leitung 0
1 | HSOUT 11 | HSOUT 11 | Leitung 1 | Leitung 1 | Leitung 1 | Leitung 1
2 | Deaktiviert | Zeile 2 | Zeile 2 | Zeile 2 | Zeile 2 | Zeile 2
3 | Deaktiviert | Leitung 3 | Leitung 3 | Leitung 3 | Leitung 3 | Leitung 3
4 | Grüne LED | Leitung 4 | Leitung 4 | Leitung 4 | Leitung 4 | Leitung 4
5 | Rote LED | Leitung 5 | Leitung 5 | Leitung 5 | Leitung 5 | Leitung 5
6 | Deaktiviert | Leitung 6 | Leitung 6 | Leitung 6 | Leitung 6 | Leitung 6
7 | Deaktiviert | Leitung 7 | Leitung 7 | Leitung 7 | Leitung 7 | Leitung 7
8 | Deaktiviert | Grüne LED | HSOUT 01 | HSOUT 01 | HSOUT 01 | HSOUT 01
9 | Deaktiviert | Rote LED | HSOUT 11 | HSOUT 11 | HSOUT 11 | HSOUT 11
10 | Deaktiviert | Deaktiviert | Grüne LED | Grüne LED | Grüne LED | Grüne LED
11 | Deaktiviert | Deaktiviert | Rote LED | Rote LED | Rote LED | Rote LED
12 | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
13 | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert | Deaktiviert
1Direkte Hochgeschwindigkeitsausgänge vom Vision-System.
Geschlossen In-Sight 7000-Serie
Hinweis:
  • Das Vision-System der In-Sight 70xx-74xx-Serie unterstützt den gleichzeitigen Anschluss des Breakout-Kabels und des CIO-MICRO- oder CIO-MICRO-CC E/A-Moduls.
  • Hochgeschwindigkeitsausgänge von Vision-Systemen der In-Sight 70xx-74xx-Serie werden nur unterstützt, wenn das Vision-System mit dem Breakout-Kabel verbunden ist.
  • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.
  • Ist das Vision-System der In-Sight 70xx-74xx-Serie für die Verwendung mit dem E/A-Modul CIO-MICRO oder CIO-MICRO-CC konfiguriert, sind die Pins des RS-232-Ausgangs und des RS-232-Eingangs am E/A-Breakout-Kabel deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.
Vorsicht:
  • Beim Anschließen des Vision-Systems In-Sight der Serie 70xx-74xx an das E/A-Modul CIO-MICRO oder CIO-MICRO-CC werden der E/A-Port (DB15) und die Anschlussklemmen TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 und HS COMMON des E/A-Moduls nicht unterstützt. Verbinden Sie niemals die Drähte von Remotegeräten mit diesen Anschlussklemmen.
  • Beim Anschließen des Vision-Systems In-Sight 7000 an das CIO-MICRO- oder CIO-MICRO-CC-E/A-Modul wird der E/A-Port (DB15) des E/A-Moduls nicht unterstützt. Verwenden Sie diesen Anschluss nicht.
Leitung | Direktes E/A | CIO-MICRO oder CIO-MICRO-CC
0 | HSOUT 01 | Leitung 0
1 | HSOUT 11/Seriell übertragen | Leitung 1
2 | HSOUT 21 | Zeile 2
3 | HSOUT 31 | Leitung 3
4 | Grüne LED | Leitung 4
5 | Rote LED | Leitung 5
6 | Deaktiviert | Leitung 6
7 | Deaktiviert | Leitung 7
8 | Deaktiviert | HSOUT 01
9 | Deaktiviert | HSOUT 11
10 | Deaktiviert | HSOUT 21
11 | Deaktiviert | HSOUT 31
12 | Deaktiviert | Grüne LED
13 | Deaktiviert | Rote LED
1Direkter Hochgeschwindigkeitsausang vom Vision-System, wenn das Netz- und E/A-Breakoutkabel angeschlossen ist.
Geschlossen In-Sight 8000-Serie
Leitung | Direktes E/A | CIO-MICRO
0 | HSOUT 01 | Leitung 0
1 | HSOUT 11 | Leitung 1
2 | Deaktiviert | Zeile 2
3 | Deaktiviert | Leitung 3
4 | Grüne LED | Leitung 4
5 | Rote LED | Leitung 5
6 | Deaktiviert | Leitung 6
7 | Deaktiviert | Leitung 7
8 | Deaktiviert | HSOUT 01
9 | Deaktiviert | HSOUT 11
10 | Deaktiviert | Grüne LED
11 | Deaktiviert | Rote LED
12 | Deaktiviert | Deaktiviert
13 | Deaktiviert | Deaktiviert
1Direkte Hochgeschwindigkeitsausgänge vom Vision-System.


Anzahl von Ausgängen

Die Anzahl der direkten (integrierten) Ausgänge variiert je nach In-Sight-Vision-System wie folgt:

In-Sight Vision-System | Direkte (integrierte) Ausgänge
In-Sight Micro 1000-Serie | 2 Hochgeschwindigkeitsausgänge 2 benutzerkonfigurierbare LEDs (1 grün, 1 rot)
In-Sight 2000-Serie | 4 Hochgeschwindigkeitsausgänge 2 benutzerkonfigurierbare LEDs (1 grün oder rot , 1 rot)
In-Sight 5000-Serie | 2 Hochgeschwindigkeitsausgänge 2 benutzerkonfigurierbare LEDs (1 grün, 1 rot)
In-Sight 7000-Serie | 4 Hochgeschwindigkeitsausgänge 2 benutzerkonfigurierbare LEDs (1 grün, 1 rot)
In-Sight 8000-Serie | 2 Hochgeschwindigkeitsausgänge 2 benutzerkonfigurierbare LEDs (1 grün, 1 rot)

Mit einem E/A-Modul können zusätzliche diskrete Ausgänge zur Verfügung gestellt werden. Die Anzahl der diskreten Ausgänge variiert je nach E/A-Modul wie folgt:

E/A-Modul- | Unterstütztes In-Sight Vision-System | Diskrete Ausgänge
CIO-14002 | In-Sight 5000-Serie (außer 5604), In-Sight 2000-Serie | 6 Allzweckausgänge
CIO-MICRO23 | In-Sight Micro 1000-Serie, In-Sight 5000-Serie, In-Sight 7000-Serie, In-Sight 8000-Serie | 8 Allzweckausgänge
CIO-MICRO-CC3 | In-Sight Micro 1000-Serie, In-Sight 5000-Serie (ausser 5705, 5705C und 5715), In-Sight 7000-Serie | 8 Allzweckausgänge
CIO-14504 | In-Sight 5000-Serie (außer 5604, 5705, 5705C und 5715) | 8 Allzweckausgänge
CIO-14604 | In-Sight 5000-Series (außer 5604, 5605, 5705, 5705C und 5715) | 8 Allzweckausgänge
CIO-WENET4 | In-Sight Micro 1000-Serie | 8 Allzweckausgänge

1 Das E/A-Modul CIO-1400 unterstützt die Vision-Sensoren der In-Sight 2000-Serie mit Firmwareversion 5.3.0 und höher.

2 Das E/A-Modul CIO-MICRO unterstützt die Vision-Systeme 5705, 5705C, 5715 und die Vision-Systeme der In-Sight 8000-Serie mit Firmwareversion 5.3.0 und höher.

3 Von den CIO-MICRO- und CIO-MICRO-CC-E/A-Modulen werden nur die In-Sight-Vision-Systeme der Serien 5100 und 5400 mit mindestens 128 MB nicht flüchtigem Flashspeicher unterstützt. Die Modelle sind anhand der Typnummer erkennbar (821-xxxx-xx). Die Typnummer befindet sich auf dem am Vision-System befestigten Etikett. Eine vollständige Liste mit Modellen sowie Angaben zu Typnummer nicht-flüchtigem Flashspeicher finden Sie hier.

4 Die Module CIO-1450, CIO-1460 und CIO-WENET I/O sind veraltet und werden nicht mehr zum Kauf angeboten. Sie werden jedoch weiterhin im In-Sight Explorer unterstützt, sind allerdings nur abwärtskompatibel.
Vorsicht:
  • Beim Anschließen des Vision-Systems In-Sight der Serie 70xx-74xx an das E/A-Modul CIO-MICRO oder CIO-MICRO-CC werden der E/A-Port (DB15) und die Anschlussklemmen TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 und HS COMMON des E/A-Moduls nicht unterstützt. Verbinden Sie niemals die Drähte von Remotegeräten mit diesen Anschlussklemmen.
  • Beim Anschließen des Vision-Systems In-Sight 7000 an das CIO-MICRO- oder CIO-MICRO-CC-E/A-Modul wird der E/A-Port (DB15) des E/A-Moduls nicht unterstützt. Verwenden Sie diesen Anschluss nicht.
Hinweis:
  • Das Vision-System der In-Sight 70xx-74xx-Serie unterstützt den gleichzeitigen Anschluss des Breakout-Kabels und des CIO-MICRO- oder CIO-MICRO-CC E/A-Moduls.
  • Hochgeschwindigkeitsausgänge von Vision-Systemen der In-Sight 70xx-74xx-Serie werden nur unterstützt, wenn das Vision-System mit dem Breakout-Kabel verbunden ist.
  • Es gibt zwei Optionen, um am In-Sight Vision-System der 70xx-74xx-Serie serielle Kommunikation zu ermöglichen: mit dem Breakout-Kabel oder durch Verwenden der E/A-Module CIO-MICRO oder CIO-MICRO-CC. Bei einer Verbindung mit dem Breakout-Kabel (ohne verbundenes E/A-Modul) ermöglicht das Vision-System die Konfiguration einer diskreten Eingangsleitung und einer diskreten Ausgangsleitung, jeweils für den seriellen Empfang und für die serielle Übertragung. Weitere Informationen finden Sie unter So ermöglichen Sie die serielle Kommunikation mit dem Vision-System der In-Sight 70xx-74xx-Serie.
  • Ist das Vision-System der In-Sight 70xx-74xx-Serie für die Verwendung mit dem E/A-Modul CIO-MICRO oder CIO-MICRO-CC konfiguriert, sind die Pins des RS-232-Ausgangs und des RS-232-Eingangs am E/A-Breakout-Kabel deaktiviert. Verwenden Sie für den Anschluss an ein serielles Gerät den RS-232 OUT-Port (DB9) des E/A-Moduls.
  • Wenn gepulste diskrete Ausgaben von einem CIO-1450 E/A-Modul gesendet werden, können die Impulse 10 Millisekunden länger sein als angegeben.
  • Beim Aus- und Einschalten eines CIO-1460 E/A-Moduls sind diskrete Ausgänge während der Initialisierung ca. 250 Mikrosekunden lang aktiv.