建立连接

欢迎使用可提供逐步生成机器视觉应用程序或作业的EasyBuilder®。建立连接步骤用于连接In-Sight视觉系统、视觉传感器以及/或模拟器，配置它们的设置并开始建立作业的过程。

注意:
  • 生成作业时，请按 CTRL+S 定期保存作业。如果在用户对话框中的允许在线作业保存复选框被启用，拥有完全或受保护访问权的用户将被允许在线保存作业。如果允许在线作业保存复选框未被启用，视觉系统必须在脱机状态保存作业。
  • 根据您的访问级别、当前执行的任务或您是否连接到视觉系统或模拟器的具体情况，EasyBuilder 应用程序步骤可能被禁用。

EasyBuilder 帮助

EasyBuilder 帮助文档提供两种格式：选择板帮助以及在线帮助。EasyBuilder 选择板帮助位于选择板的帮助选项卡中 ，EasyBuilder 在线帮助是含有搜索功能的 CHM 格式帮助系统。要启用 EasyBuilder 在线帮助文档，可以在键盘上按 F1 键，在选择板的帮助选项卡中点击“帮助” [image] 按钮，或在帮助菜单中选择 EasyBuilder 帮助。

连接到 In-Sight 传感器或模拟器

启动或打开 EasyBuilder 作业

版权所有 © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder 帮助 | 06/28/2022 | Revision: 5.9.0.3


连接到 In-Sight 传感器或模拟器

选择 In-Sight 传感器或仿真器组框中列出了可用的 In-Sight 视觉系统/传感器和仿真器。一次只能连接一个视觉系统/传感器或仿真器; 连接的视觉系统/传感器（名称、型号等）的信息将显示在传感器信息组框中。

如果您未连接到列表中所需的视觉系统/传感器或仿真器，请执行以下操作之一：

  • 双击列表中所需的视觉系统/传感器或仿真器。
  • 在列表中选择所需的视觉系统/传感器或仿真器，然后单击连接按钮。

如果要断开与所连接的传感器或仿真器的连接，请单击断开连接按钮。

设置窗格还包含作以下用途的其它控件：

  • 添加传感器到列表
  • 更改本地模拟器模式
注意:
  • 如果另一个用户已经登录到所需的视觉系统/传感器/仿真器，则会显示一条警告消息。单击确定以断开其他用户与目标系统的连接，并继续登录过程。单击否以取消登录并返回到 EasyBuilder。
  • 如果您无权连接到所需的视觉系统/传感器/仿真器，则会出现登录/退出登录对话框。
  • 如果您无法连接到您的视觉系统/传感器或网络，则可能是网卡的问题。
  • 在 In-Sight 2000 系列视觉传感器上启用连续触发类型时，由于传感器的 CPU 负载很重，因此 In-Sight Explorer 与传感器之间的通信可能会失败。在这种情况下，请选择不同的触发类型或调整触发间隔。
  • 当连接到 In-Sight 视觉系统/传感器时，某些视觉系统型号类型的位置和检测工具可能不可用。

添加传感器到列表

更改本地模拟器模式


将视觉系统添加到列表

如果所需的视觉系统已以物理方式连接到本地网络但没有显示在列表中，可单击刷新或添加按钮，取决于视觉系统的网络设置。

  • 刷新按钮可更新列表，以显示所有连接到本地子网的 In-Sight 视觉系统。这些视觉系统的网络设置与子网兼容，使您能够与它们通信。
  • 添加按钮会打开“将视觉系统/设备添加到网络”对话框，具有“完全”访问权限的用户可以通过该对话框重新配置本地网络中与本地子网不兼容的视觉系统网络设置。更正后，视觉系统即会自动添加到子网中，此时便可与其进行通信。

如果所需的视觉系统位于另外的子网上，可从“系统”菜单中，选择浏览器主机表以打开“浏览器主机表设置”对话框。


更改本地模拟器模式

  1. 在选择 In-Sight 视觉系统或模拟器组框中单击列表中的所需模拟器，选择该模拟器。
  2. 按模拟器按钮启动模拟器选项对话框，该对话框包含所有支持的 In-Sight 视觉系统和可在这些视觉系统上使用的工具。
  3. 从模型下拉列表中选择要进行仿真的 In-Sight 视觉系统模型。默认情况下选择标准。标准可提供大部分 In-Sight 视觉视觉系统的核心功能，图像分辨率为 640 x 480。
  4. 选择完之后，按确定按钮即可更改仿真设置。
注意:单击完确定按钮后，EasyBuilder 断开与前一个模拟器的连接并启动新的模拟器会有一个延迟。


启动或打开 EasyBuilder 作业

已关闭 启动新作业
  1. 确认视觉系统状态为离线。
  2. 在加载作业部分单击新作业按钮或按 CTRL+N，这两种方式都会打开新作业对话框。
  3. 在新作业对话框中，点击是，从当前作业中清除所有数据。（如果你想要保存数据，在对话框中点击否，然后在开始新的作业前，按下 CTRL+S 并完成保存步骤。）

新作业的名称不会在当前作业中显示（在传感器信息组框中的区域），直到作业被保存且重新命名。

已关闭 打开当前作业
  1. 确认视觉系统状态为离线。
  2. 在加载作业组框中点击打开作业，或按 CTRL+O，这两种方式都可以启动打开对话框。
  3. 从该对话框中导航到作业。
  4. 双击该作业，或选择该作业后单击打开。
  5. 加载文件对话框会显示；在该对话框中，点击是，从当前作业中清除所有数据。（如果你想要保存数据，在对话框中点击否，然后在打开新的作业前，按下 CTRL+S 并完成保存步骤。）

已打开的作业的名称会在当前作业区域显示。

注意:
  • 在 In-Sight 2000 系列视觉传感器上创建的作业文件与在任何其他 In-Sight 模型中创建的作业文件不兼容。
  • 仅支持 EasyBuilder 的视觉系统无法打开在电子表格视图中编辑过的 EasyBuilder 作业。
  • EasyBuilder 无法编辑在 In-Sight 浏览器电子表格视图中创建的作业。如果打开了一个基于电子表格的作业，则其他的应用步骤会被禁用。不过，您可以单击 EasyBuilder“视图”菜单中的电子表格选项以在 In-Sight 浏览器内对作业进行操作。
  • 如果使用 In-Sight 4.7.3 或更早版本创建的 Easybuilder 作业在运行 In-Sight 5.x.x 固件的视觉系统上打开，则作业中的symbolic 标签 (EasyBuilder 标签)可能会被删除。


设置图像

设置图像步骤用于采集或加载图像、调整 In-Sight 传感器的采集设置以及在应用程序需要实际单位（如毫米或英寸）的结果时，您可以校准图像的像素坐标。

采集或加载图像

调整采集设置

根据实际单位校准图像


采集或加载图像

你可以使用采集/加载图像组框从视觉传感器立即采集图像、显示视觉传感器的实时图像或加载先前从 PC 采集的图像。

In-Sight 2000 系列传感器

  • 采集或加载图像

In-Sight 视觉系统

  • 采集或加载图像

In-Sight 2000 系列视觉传感器

In-Sight 视觉系统

版权所有 © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder 帮助 | 06/28/2022 | Revision: 5.9.0.3


采集或加载图像

注意:该主题介绍了与 In-Sight 2000 系列视觉传感器连接时的用户界面。如果你的系统连接的是 In-Sight 视觉系统，请参阅采集或加载图像。
已关闭 触发

触发按钮用于从视觉传感器中采集单个图像。点击触发按钮来采集单个图像。或者，你也可以使用键盘上的 F5 按钮或在 EasyBuilder 工具栏里点击 [image] 按钮（触发必须设置为手动）。

已关闭 实时图像

实况图像按钮会激活视觉传感器连续输出图像，让你可以对连接到视觉传感器的镜头进行焦距调整，同时还能调整光圈以达到最佳图像亮度。当图像对焦清晰并且亮度已平衡到使对比度最大化时，应用程序将以最佳状态运行。

注意:
  • 你也可以通过在图像菜单中选择实时图像选项或在 EasyBuilder 工具栏里点击 [image] 按钮以进入实时图像模式。实时图像选项在所有应用程序步骤中都可使用。
  • 你可以在实时图像模式中调节自动/手动曝光、曝光（毫秒）、最佳曝光、光控模式以及图像放大模式等设置。

聚焦衡量标尺提供了以下图像以帮助你确定图像聚焦的得分。该分数显示了图像或图像的某个区域在一个“场景”中包含的可分辨特征的程度。

注意:
  • 当连接到 In-Sight 2000 系列视觉传感器时，聚焦衡量标尺的最小值，最大值和聚焦值将被隐藏。
  • 在实时图像中，通过点击在 EasyBuilder 工具栏里的聚焦衡量标尺 [image] 图标，聚焦衡量标尺可以被关闭。你也可以通过在视图菜单中选择聚焦衡量标尺来关闭该功能。
已关闭 调整焦点

  1. 点击实时图像按钮。或者，您可以按 EasyBuilder 工具栏中的 [image] 按钮。

    注意:视觉传感器必须处于脱机状态。
  2. 如果使用 In-Sight 2000 Mini 系列视觉传感器，则可以使用自动对焦按钮自动对焦镜头。或者，也可以使用焦点距离（％）滑块控制手动调整焦点，以使要被检查的特征的细节清晰并具有高度对比。
  3. 如果使用其它 In-Sight 2000 系列视觉传感器，请手动调整连接到视觉传感器的灯光模块，以使要检查的特征的细节清晰且具有高度对比。
  4. 一旦图像达到了你满意的程度，再次点击实时视频按钮。
已关闭 调整亮度
  1. 点击实时图像按钮。或者，您可以按 EasyBuilder 工具栏中的 [image] 按钮。

  2. 在 EasyBuilder 工具栏中，点击亮度反馈。图像中过暗的区域会以蓝色突出显示，同时图像中过度饱和（过亮）的区域会以红色突出显示。

    注意:你也可以通过在图像菜单中选择显示亮度反馈来激活亮度反馈。
  3. 您可以通过以下方式之一调整图像的亮度：
  • 手动调整与视觉传感器连接的镜头的光圈，直到图像的红色和蓝色区域都最小化。
  • 调整曝光控制滑块直到图像的红色和蓝色区域最小化。有关详情，请参阅曝光。
  • 选择自动曝光。有关详情，请参阅自动曝光。

  4. 在图像质量达到你的要求后，点击亮度反馈 [image] 图标以关闭亮显示。

    注意:你也可以通过在图像菜单中选择显示亮度反馈来关闭亮度反馈。
已关闭 从 PC 加载图像

从 PC 加载图像会启动记录/回放选项对话框，通过该对话框可配置各个视觉传感器和模拟器的记录与回放设置。配置完该对话框的设置后，可以将采集的图像保存到录制文件夹，并回放存储于 PC 的回放文件夹中的已采集图像。

注意:
  • 对于运行时的监视和调试，可将图像存储到视觉传感器（而不是 PC）；并使用幻灯片应用程序步骤来配置传感器设置。
    • 将彩色图像记录到 PC 时，图像将被保存为 16 位图像，而不是 24 位图像。需要使用彩色图像测试颜色工具时，可通过 FTP（通过在通信应用程序步骤中添加 FTP 设备）导出图像以保存图像并保留完整的色彩深度。
已关闭 回放选项卡

播放选项卡的配置设置完成后，点击播放按钮（在 PC 幻灯中），保存在 PC 指定回放文件夹中的图像会被发送到视觉传感器且会运行回放图像的作业。默认情况下，回放文件夹指的是 EasyBuilder 样本作业文件夹。

已关闭 录制选项卡

录制选项卡的设置配置完成后，且图像已采集完毕，按录制按钮（在 EasyBuilder 工具栏中），会录制通过和失败的图像并将这些图像保存到 PC 上指定的录制文件夹中。你可以将这些图像从处于联机或脱机状态的视觉传感器保存到任何具有“写入”权限的文件夹中。最多可将 10,000 张图像保存到 PC。


采集或加载图像

利用采集/加载图像组框可立即采集视觉系统的图像、显示视觉系统的当前实况视频或加载先前从 PC 采集的图像。

已关闭 触发

触发按钮用于从视觉系统采集单个图像。点击触发按钮来采集单个图像。或者，您可以使用键盘上的 F5 按钮或者点击 EasyBuilder 工具栏上的 [image] 按钮（编辑采集设置组中的触发控制必须设置为手动）。

已关闭 实时图像

实时图像按钮会激活视觉系统连续输出图像但不会采集它们，从而可以对连接到视觉系统的镜头进行调焦，同时还可针对曝光和亮度进行补偿。当图像对焦清晰并且亮度已平衡到使对比度最大化时，应用程序将以最佳状态运行。

图像下面提供的聚焦衡量可以帮助你确定图像聚焦得分，该得分表明了图像或图像的某个区域（使用聚焦区域按钮定义）在“场景”（即图像中所捕捉的对象及其背景）中包含最小可分辨特征的程度。

注意:
  • 要提供相关数据，应将该聚焦衡量得分与完全相同场景（两个场景一样）中的另一个聚焦衡量得分进行比较。
  • 在实时图像中，可以通过在 EasyBuilder工具栏中点击聚焦衡量 [image] 图标来关闭聚焦衡量。
已关闭 调整焦点
已关闭 In-Sight 5000 Series, In-Sight Micro Series, In-Sight 7000 Series and In-Sight 8000 Series Vision System with C-Mount Lens

  1. 按实况图像按钮。或者，您可以按 EasyBuilder 工具栏中的 [image] 按钮。

    注意:视觉系统必须处于脱机状态。
  2. 手动调整与视觉系统连接的镜头的对焦环，以使要检查的特征的细节清晰可见且对比度较高，并且聚焦衡量得分在可接受范围。
  3. 在对图像质量及其得分感到满意之后，再次按实况图像按钮。
  4. 在按实况图像按钮之后所采集的最后一个图像将会显示。
已关闭 带自动对焦 M12 镜头的 In-Sight 7000系列视觉系统
注意:对于 In-Sight 70xx - 74xx 系列视觉系统，聚焦控制只能在运行 In-Sight Explorer 4.7.3 或更高版本、In-Sight 4.7.3 固件或更高固件版本的视觉系统上可用。
  1. 按实况图像按钮。或者，您可以按 EasyBuilder 工具栏中的 [image] 按钮。
注意:视觉系统必须处于脱机状态。
  2. 按自动聚焦按钮或手动调整“聚焦位置”滑块，以使要检查的特征细节清晰且对比度较高，而且聚焦衡量的得分可接受。
注意:当按了自动聚焦按钮后，“聚焦位置”滑块和保存聚焦按钮会被禁用。
  3. 在按了自动聚焦按钮后，聚焦位置值会被更新，且会显示一个新的图像。
  4. 在对图像质量及其得分感到满意之后，按保存聚焦按钮。当前的聚焦位置会被作为默认聚焦位置保存，且在下次启动视觉系统时镜头会被自动移到该位置。
已关闭 调整亮度
  1. 按实况图像按钮。或者，您可以按 EasyBuilder 工具栏中的 [image] 按钮。
  2. 在 EasyBuilder 工具栏中，按亮度反馈图标。过暗的图像区域会以蓝色突出显示，同时，过亮的图像区域会以红色突出显示。
  3. 您可以通过以下方式之一调整图像的亮度：
  • 手动调整与视觉系统连接的镜头的光圈，直到图像的红色和蓝色区域都最小化。
  • 在编辑采集设置组框中，增加曝光控制，直到图像的红色和蓝色区域都最小化。
  • 从编辑采集设置组框中，通过从自动曝光下拉菜单中选择连续或单次，来激活视觉系统的自动曝光控制。连续激活视觉系统以根据光线条件自动调整每次图像采集的曝光。单次会根据首次图像采集调整视觉系统的曝光度；对于后续的每次图像采集，均会沿用该曝光设置。
  4. 在对图像质量满意之后，再次点击亮度反馈 [image] 图标以关闭显示。
已关闭 从 PC 加载图像

从 PC 加载图像会启动记录/回放选项对话框，通过该对话框可配置各个视觉系统和模拟器的记录与回放设置。配置完该对话框的设置后，可以将采集的图像保存到录制文件夹，并回放存储于 PC 的回放文件夹中的已采集图像。

注意:
  • 对于运行时监视和调试，可将图像存储到视觉系统（而不是 PC）；使用幻灯片应用程序步骤可配置传感器设置。
  • 将彩色图像记录到 PC 时，图像将被保存为 16 位图像，而不是 24 位图像。需要使用彩色图像测试颜色工具时，可通过 FTP（通过在通信应用程序步骤中添加 FTP 设备）导出图像以保存图像并保留完整的色彩深度。
已关闭 回放选项卡

配置完“回放”选项卡的设置后，如果按播放按钮（在 PC 胶片中），存储在 PC 上指定的回放文件夹中的图像将被发送到视觉系统，而且作业会相对于回放的图像运行。默认情况下，回放文件夹指的是 EasyBuilder 样本作业文件夹。

注意:默认情况下，回放文件夹是指 EasyBuilder 样本作业文件夹。EasyBuilder 样本作业就记录/回放选项的实用性进行了内容丰富的演示。利用记录/回放选项，可以循环浏览一系列先前采集的图像，提供工具结果的即时反馈，从而得以快速配置阈值和限制。
已关闭 录制选项卡

配置完“记录”选项卡的设置后，按记录按钮（在 EasyBuilder 工具栏中）且图像已采集完成时，会记录通过和失败图像并将这些图像保存到 PC 上指定的记录文件夹中。可以将这些图像从处于联机或脱机状态的视觉系统保存到任何具有“写入”权限的文件夹。最多可将 10,000 张图像保存到 PC。


调整采集设置

设置图像应用设置程序步骤可以让你调整采集触发控制、对曝光和亮度进行补偿以及控制 In-Sight 视觉系统的光源。

In-Sight 2000 系列传感器

  • 图像设置

In-Sight 视觉系统

  • 触发控制
  • 曝光控制
  • 视觉系统传输控制
  • 光源控制
  • 高动态范围 (HDR)
  • 白平衡
  • 聚焦区域
  • 聚焦控制
  • 灯光设置
  • 线扫描设置

In-Sight 2000 系列视觉传感器

In-Sight 视觉系统

版权所有 © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder 帮助 | 06/28/2022 | Revision: 5.9.0.3


图像设置

注意:该主题介绍了与 In-Sight 2000 系列视觉传感器连接时的用户界面。 如果连接到 In-Sight 视觉系统，请参阅 In-Sight 视觉系统的调整采集设置部分。

触发

触发控制、类型、延迟和间隔时间允许你自定义该如何以及何时采集图像并执行检测。

注意: 在 In-Sight 2000 系列视觉传感器上启用连续触发类型时，由于传感器的 CPU 负载很重，因此 In-Sight Explorer 与传感器之间的通信可能会失败。在这种情况下，请选择不同的触发类型或调整触发间隔。
已关闭 类型

该下拉菜单可以在 In-Sight 视觉传感器在线时，让你指定图像采集触发源。

相机 | 启用在视觉系统指定的触发输入端口检测到的上升沿的图像采集。
连续 （默认） | 启动自由运行（尽可能快的）图像采集。
手动 | 按 F5 时启动图像采集。 注意:您可以通过按下视觉传感器上的 TRG 按钮手动触发传感器。
工业以太网 | 允许从工业以太网协议触发，例如 EtherNet / IP、PROFINET、SLMP 扫描或 CC-Link IE Field Basic。有关更多信息，请参阅 In-Sight® 浏览器帮助文件。
已关闭 延迟 (msec)

该控制允许你指定在接收到触发信号和 In-Sight 视觉传感器开始采集之间的延迟，以毫秒为单位（0 至10,000）。 触发类型必须被设置为相机。

注意:
  • 该延时会精确到 1 毫秒，加上或减去最大线曝光时间，即 64 微秒。
  • 如果采集开始是在输入/输出步骤中所指定的信号类型，这些输出将会根据指定的时间而延时。
已关闭 间隔时间 (msec)

当类型控制被设置为连续时，该控制可以让你指定采集之间的间隔时间，单位为毫秒（0 至 10,000；默认值为 0）。

注意:此延迟取决于作业完成图像处理所需的时间。 例如，如果间隔时间设置为 500 毫秒，而作业可以在 500 毫秒内完成图像处理，In-Sight 视觉传感器将每隔 500 毫秒采集一个图像。 若不设置间隔时间，作业一完成图像处理，In-Sight 视觉系统就会采集图像。

对焦（仅限具有自动对焦功能的In-Sight 2000视觉传感器）

聚焦选项卡用于通过自动聚焦镜头或将镜头移动到特定的聚焦位置在具有自动聚焦功能的In-Sight 2000系列视觉传感器上控制镜头的聚焦位置。

已关闭 自动对焦区域

指定用于自动对焦镜头的图像区域。 点击自动对焦区域按钮来配置区域。

已关闭 自动聚焦按钮

自动对焦镜头，以最大限度地提高区域内的图像清晰度。

已关闭 在加载作业时自动对焦
  • 未选中（=默认）：当前对焦距离（％）将与作业一起保存。
  • 选中：作业加载时，视觉传感器会自动对焦镜头。
已关闭 聚焦距离（％）

手动调整聚焦位置（0 - 100％； 默认值：6.2mm 镜头= 66％，16mm 镜头= 69.2％）。 当试图聚焦靠近视觉传感器的物体时，将滑块向左移动（往 0％ 方向）。 当试图聚焦远离视觉传感器的物体时，将手柄向右移动（往100％ 方向）。 无论实况视频模式的状态如何，您都可以移动滑块。

注意:0％ 表示最近的聚焦平面。 例如，当一个物体放在距视觉传感器非常近的地方时，你会看到 0％。 100％ 代表可能达到的最远的聚焦平面，这基本上是“无限的焦点”。

灯光

注意:在某些情况下，使用自动对焦的 In-Sight 2000 Mini 系列视觉照明可能比其他 In-Sight 2000 系列视觉传感器更暗。
已关闭 自动曝光

自动确定每次采集之后的曝光时间。 该选项可以对例如闪亮金属表面的反射、多重阴影以及背景光线变化等不协调的光线条件进行补偿。 默认情况下自动曝光被禁用。

已关闭 手动曝光

为每次图像采集设置固定的曝光值。 默认情况下使用的是手动曝光。 要禁用该设置，可以选择自动曝光选项。

已关闭 目标图像亮度

目标亮度允许你通过调整操纵杆或在编辑框中输入数值来指定需要的亮度级别（0 - 100；默认值 = 50）。 亮度级别的数值指的是曝光区域允许的饱和度的像素百分比（例如：白色）。 white).

提示:您还可以使用箭头键（上、下、左、右）来移动手柄。
已关闭 曝光（毫秒）

该选项决定采集图像时的曝光时间（0.000 - 1000.000；默认值 = 0.250）。 曝光时间越长，采集到的图像越亮。 当自动曝光被选择时，该选项会被禁用。

已关闭 光源强度
注意:In-Sight 2000 Mini 系列视觉传感器不支持光源强度滑块条。

该选项允许你通过调整操纵杆或在编辑框内输入数值来指定有效的 LED 光强度 [(0 至 100)； 默认值 = 70； 关闭 = 0]。 光源强度会和作业一起保存。

提示:您还可以使用箭头键（上、下、左、右）来移动手柄。

蓝色背景显示了可用于当前设置的最大光强度。 最大光强度值根据其它图像设置（如目标图像亮度、曝光、图像区域高度或图像放大模式）而变化。

注意:将鼠标悬停在滑块控件上时会显示最大值。
已关闭 曝光区域按钮（设置区域）

指定在自动计算曝光时所使用的区域。

  1. 点击曝光区域按钮。
  2. 将区域设置在图像周围区域以便传感器确定下次采集图像所需的自动曝光。
  3. 点击确定按钮。

将根据当前曝光范围内的图像区域的的亮度来自动计算曝光值。例如，如果当前在曝光范围内的图像区域比其它的图像亮，则下一张采集到的图像就会变暗。

定义曝光区域 | 下一次采集的图像
注意:点击重置默认区域以重回默认设置。
已关闭 优化曝光

自动优化曝光值。 相同的曝光值会被用于之后的每次图像采集。

已关闭 光源控制模式

开启（曝光）可使环形灯仅在曝光期间（默认）开启。 当禁用（关闭）时，LED 灯将关闭，传感器将依靠室内环境（房间）灯光照明。

白平衡（仅适用于 In-Sight 2000 彩色视觉传感器）

已关闭 白平衡区域和设置白平衡

通过计算图像的红色、绿色和蓝色（RGB）值并对其进行校正，从而消除彩色图像中的色偏。 因此，如果物体在真实世界中是白色的，则将在图像中显示白色。

创建新作业时，最近执行的白平衡将生效。 白平衡设置将与作业一起保存，并在加载作业时恢复。

注意:
  • 使用手动曝光时必须配置白平衡设置。

  • 为了确保在图像中再现最准确的颜色，建议每次在对光强度进行大幅调整后进行白平衡。

  1. 将 In-Sight 视觉传感器对准一个平坦的测试对象，例如一张白色无光纸，并调整照明控制以确保图像不过度曝光。

  2. 单击白平衡区域，并包围图像中仅包含亮像素的区域，但不包含“热点”。

    注意:点击重置为默认区域来重置区域以包括整个图像。
  3. 单击设置白平衡。 所有后续的图像采集将开始使用此设置。
白平衡前的图像 | 白平衡 | 白平衡后的图像

图像

已关闭 图像区域高度

当图像中的关注区域总是在有限的行数范围内时，指定需要采集的图像行数以缩短图像采集的时间。 你可以通过移动左 （起始行）和右（结束行）控制手柄或在相应的编辑框内输入数字来指定范围值。

提示:您还可以使用箭头键（上、下、左、右）来移动手柄。
In-Sight 型号 | 分辨率 | 开始行的值 | 结束行的值
2000-110 | 640 x 480 | 0 - 479 (默认值 = 0) | 0 - 479 (默认值 = 479)
2000-120/120C | 640 x 480 | 0 - 479 (默认值 = 0) | 0 - 479 (默认值 = 479)
2000-130/130C1 2000-230/230C1 | 640 x 480 (默认) | 0 - 479 (默认值 = 0) | 0 - 479 (默认值 = 479)
 | 800 x 600 | 0 - 599 (默认值 = 0) | 0 - 599 (默认 = 599)
2000-23M1 | 640 x 480 | 0 - 479 (默认值 = 0) | 0 - 479 (默认值 = 479)
 | 800 x 600 (默认) | 0 - 599 (默认值 = 0) | 0 - 599 (默认 = 599)
2001-230/230C1 | 640 x 480 | 0 - 479 (默认值 = 0) | 0 - 479 (默认值 = 479)
 | 800 x 600 | 0 - 599 (默认值 = 0) | 0 - 599 (默认值 = 599)
 | 1280 x 960 (默认) | 0 - 959 (默认值 = 0) | 0 - 959 (默认值 = 959)
1分辨率可以在图像设置对话框中配置。 有关更多信息，请参阅图像设置对话框。
已关闭 图像放大模式

启用图像放大模式。 启用该模式时，FOV 大小会减少 50% 但镜头的分辨率会提高 200%。

In-Sight 型号 | 分辨率 | 图像放大模式
2000-110 | 640 x 480 | 不支持
2000-120/120C | 640 x 480 | 可以启用或禁用该功能
2000-130/130C1 2000-230/230C1 | 640 x 480 (默认) | 可以启用或禁用该功能
 | 800 x 600 | 始终启用该功能
2000-23M1 | 640 x 480 | 可以启用或禁用该功能
 | 800 x 600 (默认) | 始终启用该功能
2001-230/230C1 | 640 x 480 | 可以启用或禁用该功能
 | 800 x 600 | 始终启用该功能
 | 1280 x 960 (默认) | 始终启用该功能
1分辨率可以在图像设置对话框中配置。 有关更多信息，请参阅图像设置对话框。
图像放大模式 禁用 | 图像放大模式 已启用
已关闭 校准工具

允许您将检测工具从像素转换或校准到真实世界的实际测量单位。 有两个选项：视野或导入。

注意:
  • In-Sight 2000-110 和 2000-120/120C 视觉传感器不提供视野选项。
  • 导入选项仅适用于 In-Sight 2000-23M 视觉传感器。
已关闭 视野

将测量工具的结果从像素转换为真实世界的测量单位（毫米，厘米和/或英寸）。

视野（宽度）= 640 像素 / 125 毫米
  1. 从校准类型下拉菜单中选择视野（宽度）。
  2. 从下拉菜单中选择要使用的真实世界测量单位（毫米，厘米或英寸）。 像素为默认选择，并且该值不能被更改。
  3. 在选定的测量单位中尽可能准确地测量视野的宽度，然后输入测量值。

  4. 转换后的测量结果将马上被应用。 例如，如果视野（宽度）设置为 125 毫米，两个边缘之间的测量距离为 490 像素，则测量结果将返回为 95.703 mm。

    注意:
    • 以下是示例中使用的公式和实际计算：
      • 视野（真实世界单位）/视野（像素）* 测量（像素）=结果（真实世界单位）
      • 125/640*490 = 95.703mm
已关闭 导入

导入校准类型用于加载由 N 点校准工具创建的校准文件，并导出到 In-Sight 视觉传感器的本地文件系统。 导入的校准文件一旦加载就会自动校准当前作业。

注意:在选择导入作为校准类型之前，首先添加并配置 N 点校准工具，然后将校准文件导出到 In-Sight 视觉传感器的本地文件系统。

N 点校准工具会创建一个 2D 转换，以在像素坐标系和现实世界坐标系之间进行转换。 该工具将执行以下转换：

  • 二维转换（使用 2 个或更多个配对点）。
  • 围绕三个轴旋转（使用 4 个或更多个配对点）。
  • 进行二维缩放（使用 2 个或更多个配对点）。
  • 视觉变形（使用 4 个或更多配对点）。
  • 平行四边形或倾斜（使用 4 个或更多的配对点）。

操作方法

  1. 从校准类型下拉菜单中选择导入。
  2. EasyBuilder 将自动检查您的作业是否有由 N 点校准工具生成的校准文件，并加载该校准文件。 如果您创建了多个校准文件，请从“文件名”下拉菜单中选择所需的文件。
  3. 从“度量单位”下拉菜单中，选择定义校准的真实度量单位：微米，毫米（默认），厘米或英寸。
  4. 选择此选项并且配置值后，校准将立即生效。


触发控制

触发控制、触发、触发延时和触发间隔允许您自定义采集图像的方式和时间。

  • 触发：定义视觉系统在线时图像采集触发的来源。

    • 相机（默认）：在视觉系统的专用采集触发输入端检测到的上升沿启用图像采集。
    • 连续：启用自由运行，尽可能快地采集图像。

    • 外部：在串行命令或上升沿上启用图像采集，应用于配置为采集触发的离散输入位。

      注意:
      • 使用视觉系统的内置采集触发输入（通过将采集图像函数的触发参数设置为相机）与使用配置为采集触发的通用输入线路触发视觉系统（通过将采集图像函数的触发参数设置为外部触发）相比，可以实现更快的触发速率。
      • 如果采集图像函数的触发参数设置为外部触发，且错过了采集，则错过采集错误信息的离散输出不会从视觉系统发送。 仅当采集图像函数的触发参数设置为相机时，才会发送错误信息：错过采集信号。
    • 手动：按 F5 时启动图像采集。
    • 工业以太网：支持从工业以太网协议触发，如 EtherNet / IP，POWERLINK，Profinet，SLMP扫描或 CC-Link IE Field Basic。
    • 时间戳：当通过EtherNet / IP从PLC发送时间戳触发到视觉系统时，启动图像采集。时间戳选项仅在以下视觉系统上受支持：

      • In-Sight 5000系列视觉系统，具有128MB非易失性闪存且运行固件版本4.5.0或更高版本

        注意:不支持In-Sight 5605视觉系统（硬件型号821-0032-1R），In-Sight 5705视觉系统以及In-Sight 5705C 视觉系统。
      • In-Sight 7000 Gen2系列视觉系统
      • In-Sight 9000 系列视觉系统

  • 触发延迟：指定接收触发时间与视觉系统开始采集之间的延迟，以毫秒为单位（0到10,000）。

    注意:
    • 触发控制必须设置为相机或网络才能启用此功能。
    • 此延时会精确到请求的毫秒数，加上或减去最大线曝光时间，即 64 微秒。
    • 如果采集开始或脉冲是在输入/输出步骤中所指定的信号类型，这些输出将会根据指定的时间而延时。

  • 触发间隔：当触发控件设置为连续时，指定采集之间的间隔，以毫秒为单位（0到10,000；默认值为500）。

    注意:此延时取决于作业完成图像处理所花的总时间。例如，如果触发间隔设置为5,000毫秒，视觉系统将每5,000毫秒获取一个图像，前提是该作业在5,000毫秒内完成其图像处理。若不设置，作业一完成图像处理，In-Sight 视觉系统就会采集图像。


曝光控制

曝光控制允许自定义应用程序以更好地处理不协调的光线和平衡亮度，从而在检查中体现最大的特色细节。

已关闭 曝光

曝光控制允许你指定曝光时间。当 In-Sight 视觉系统接收到触发器信号时，光源会在指定的时间内集成到视觉传感器阵列中。

注意:
  • 对于以下视觉系统/传感器，可以在“图像设置”对话框中配置分辨率：In-Sight Micro 1500, In-Sight 2000-130, 2000-130C, 2000-230, 2000-230C, 2000-23M, 2001-230, 2001-230C, In-Sight 7500, 7500C, 7600, 7600C, 7800, 7800C, 7900, 7900C, 7802, 7802C, 7902, 7902C.
  • 对于 5604 和 5614 线扫描视觉系统，可以在线扫描设置对话框中配置图像高度。
  • 对于 9902L 线扫描视觉系统，可以在线扫描设置对话框中配置 1K 分辨率（低光模式）和最大图像高度值。
  • 当连接到 In-Sight 5604,5614 或 9902L 线扫描视觉系统时，曝光时间以微秒为单位。
  • 如果在 In-Sight 8405 视觉系统中使用脉冲触发，建议将全帧图像捕获的最小曝光值设置为72ms，以确保在脉冲触发时所有像素行都会曝光。 有关详细信息，请参阅卷动快门操作。

  • 尽管曝光可以被设置成 0，但具体曝光时间与 In-Sight 视觉系统有关。选定视觉系统后，曝光时间 0 会默认设置为所选视觉系统的最小曝光时间（毫秒或微秒）。

In-Sight 型号 | 分辨率 | 传感器类型 | 曝光时间 (ms)
Micro 1020, 1050, 1100, 1110, 1100C, 1400, 1410, 1400C | 640 x 480 | CCD, 全域快门 | 0.016 到 1000
Micro 1402, 1412 | 1280 x 1024 | CMOS, 全域快门 | 0.016 到 950
Micro 1403, 1413, 1403C | 1600 x 1200 | CCD, 全域快门 | 0.052 到 1000
Micro 1500 | 640 x 480 | CMOS, 全域快门 | 0.004 到 500
 | 800 x 600 | CMOS, 全域快门 | 0.005 到 500
2000-110, 2000-120, 2000-120C, 2000-130, 2000-130C, 2000-230, 2000-230C, 2000-23M, 2001-230, 2001-230C | 640 x 480 | CMOS, 全域快门 | 0.001 到 1000
2000-130, 2000-130C, 2000-230, 2000-230C, 2000-23M, 2001-230, 2001-230C | 800 x 600 | CMOS, 全域快门 | 0.001 到 1000
2001-230, 2001-230C | 1280 x 960 | CMOS, 全域快门 | 0.001 到 1000
5100, 5110, 5100C, 5400, 5410, 5400C, 5600, 5610 | 640 x 480 | CCD, 全域快门 | 0.016 到 1000
5403, 5413, 5603, 5613 | 1600 x 1200 | CCD, 全域快门 | 0.027 到 1000
5604 & 5614 线扫描 | 1024 x 8192 | CCD, 全域快门 | 1.33 微秒到 1000 微秒
5605, 5615, 5705, 5715 | 2448 x 2048 | CCD, 全域快门 | 0.014 到 1000
5705C | 2448 x 2048 | CCD, 全域快门 | 0.016 到 1000
7010, 7010C, 7020, 7050, 7200, 7210, 7230, 7200C, 7400, 7410, 7430, 7400C | 800 x 600 | CMOS, 全域快门 | 0.016 到 950
7402, 7412, 7432, 7402C | 1280 x 1024 | CMOS, 全域快门 | 0.016 到 950
7500, 7500C, 7600, 7600C, 7800, 7800C, 7900, 7900C | 800 x 600 | CMOS, 全域快门 | 0.014 到 550
 | 640 x 480 | CMOS, 全域快门 | 0.014 到 520
7501, 7501C, 7801, 7801C, 7901, 7901C | 1280 x 1024 | CMOS, 全域快门 | 0.017 到 750
7802, 7802C, 7902, 7902C | 1600 x 1200 | CMOS, 全域快门 | 0.020 到 940
 | 800 x 600（低光模式） | CMOS, 全域快门 | 0.020 到 940
7802P, 7902P | 1920 x 1200 | CMOS, 全域快门 | 0.021 到 1000
7905, 7905C | 2448 x 2048 | CMOS, 全域快门 | 0.021 到 1000
8100, 8100C, 8200, 8200C, 8400, 8400C | 640 x 480 | CMOS, 全域快门 | 0.014 到 520
8101, 8101C, 8401, 8401C | 1280 x 1024 | CMOS, 全域快门 | 0.0174 到 750
8402, 8402C | 1600 x 1200 | CMOS, 全域快门 | 0.020 到 940
8405 | 2592 x 1944 | CMOS, 滚动快门 | 0.032 到 1000
8505P | 2448 x 2048 | CMOS, 全域快门 | 0.021 到 1000
9902L 线扫描 | 2048 x 16384 | CMOS, 全域快门 | 2.00 微秒到 1000 微秒
 | 1024 x 16384
9912, 9912C | 4096 x 3000 | CMOS, 全域快门 | 0.021 到 1000
已关闭 自动曝光

自动曝光控制允许 In-Sight 视觉系统自动确定曝光度。此控制可帮助对不协调的光线条件进行补偿，例如发亮金属表面的反射、偏移的阴影和背景光线变化。

  • 连续：激活视觉系统，在每次获取图像时，根据光线条件自动调整曝光。

    注意:在“连续”模式下，两次采集间的时间会增加。
  • 单次：单次会根据首次图像采集调整视觉系统的曝光度；对于后续的每次图像采集，均会沿用该曝光设置。
    • 首次采集：如果视觉系统脱机，则会使用首次采集来确定曝光度，并且会存储曝光值，直到禁用单次为止。如果在视觉系统处于脱机状态时未进行采集，则当它进入联机状态时，会使用首次采集来确定曝光度。
    • 后继采集：视觉系统将会使用在首次采集时计算的曝光值采集图像。
    注意:
    • 如果视觉系统或视觉传感器不支持此功能，则不会显示。
    • 选择不同的自动曝光模式将会重置曝光值。在重新设置曝光值之后，首次采集将会用于确定新的曝光值。
已关闭 “曝光区域”按钮

指定在自动计算曝光时所使用的区域。

注意:要启用这项功能，需要从自动曝光下拉菜单中选择 连续或单次。
  1. 点击曝光区域按钮。
  2. 将区域设置在图像周围区域以便传感器确定下次采集图像所需的自动曝光。
  3. 点击确定按钮。

将根据当前曝光范围内的图像区域的的亮度来自动计算曝光值。例如，如果当前在曝光范围内的图像区域比其它的图像亮，则下一张采集到的图像就会变暗。

定义曝光区域 | 下一次采集的图像
已关闭 最长曝光时间

允许在确定适当曝光时指定所使用的最长曝光时间。

已关闭 目标图像亮度

用于指定所需的亮度级（0 到 100）。

注意:要启用这项功能，需要从自动曝光下拉菜单中选择 连续或单次。


视觉系统传输控制

视觉系统传输控制允许你定义从图像传感器（CCD 或 CMOS）的哪一行开始传输图像以及图像传感器中的多少行数会被用来组成图像。

In-Sight 视觉系统使用异步重置和进程扫描来捕捉所有图像；灰度 In-Sight 视觉系统会产生 8 位图像，而彩色 In-Sight 视觉系统则会产生 24 位图像。对于所有视觉系统，图像采集过程在大约 250 µs 内开始，然后按如下所述进行：

  1. 图像传感器通过在曝光控制中所指定的时间内进行曝光。
  2. 并逐行将图像传感器中累积的图像传输到串行移位寄存器中。
  3. 对于每行传输，视觉系统均会从图像传感器中逐个像素地对移位寄存器进行定时。
  4. 传输开始于“开始行”，然后继续进行指定的“行数”。
已关闭 开始行

定义要从图像传感器传输到 In-Sight 视觉系统上的内存中的第一行：

分辨率 | 有效的“开始行”值
640 x 480 | 0 至 479
800 x 600 | 0 至 599
1024 x 768 | 0 至 767
1280 x 1024 | 0 至 1023
1600 x 1200 | 0 至 1199
2448 x 2048 | 0 至 2047
2592 x 1944 | 0 至 1943
已关闭 行数

定义要传输到 In-Sight 视觉系统内存中的行数：

分辨率 | 有效的行数
640 x 480 | 1 至 480
800 x 600 | 1 至 600
1024 x 768 | 1 至 768
1280 x 1024 | 1 至 1024
1600 x 1200 | 1 至 1200
2448 x 2048 | 1 至 2048
2592 x 1944 | 1 至 1944
注意:如果将要连接到模拟器，并且想要从已在启用部分图像采集参数的情况下采集了图像的 In-Sight 视觉系统查看图像，请将模拟器的开始行和行数参数设置为与 In-Sight 视觉系统上的设置相同。


光源控制

光源控制选项允许您配置 In-Sight 视觉系统的的 LED 排灯和环形灯。

注意:要启用这项功能，需要从自动曝光下拉菜单中选择 连续或单次。
已关闭 光源控制模式（仅限 In-Sight 5000 系列和 In-Sight 70xx - 74xx 系列）

光源控制模式选项指定了 In-Sight 5000 系列或 70xx - 74xx 系列视觉系统的环形灯是仅在指定曝光期间亮起，还是一直亮着。开启（曝光）使环形灯仅在曝光期间亮起。开启（连续）使环形灯始终处于开启状态，通过在不曝光图像时保持 LED 以 50％ 亮度点亮来降低闪光效果。

已关闭 光源控制（仅限 In-Sight 5000 系列）

在 In-Sight 视觉系统上最多可控制四个 (4) LED 排灯。

已关闭 示例 - 带环形灯的 In-Sight 5000 系列视觉系统

  • 水平方向可启用两个水平 LED 排灯。
  • 垂直方向可启用两个垂直 LED 排灯。
  • 所有可启用两个水平和垂直的 LED 排灯。
已关闭 光强度（仅限 In-Sight 70xx - 74xx 系列）

控制 LED 灯的有效强度。光源强度会和作业一起保存。

  • In-Sight 70xx - 74xx 系列视觉系统：0 至 100；默认值 =1；关 = 0。
已关闭 增益（仅限 In-Sight 7000 系列和 9912）

控制在模拟至数字转换之前的放大阶段的增益。

In-Sight 型号 | 增益设置
70xx - 74xx 系列 | 0 到 7；默认值 = 0
7500, 7501, 7600, 7600C, 7800, 7800C, 7801, 7801C, 7802, 7802C , 7900, 7900C, 7901, 7901C, 7902, 7902C | 0 到 6；默认值 = 0
7802P, 7902P, 7905, 7905C | 0 到 240；默认值 = 60
9912, 9912C | 0 到 255；默认值 = 60


高动态范围 (HDR)

HDR（高动态范围）为图像的较暗区域提供更好的对比度和更高的亮度。 这种效果可在一次采集中完成。

注意:只有 In-Sight 7802P、7902P、7905、8505P 和 9912 单色视觉系统支持 HDR。

  • HDR 模式：： 指定要使用的 HDR 方法。
    • 已禁用（默认）：不使用 HDR。
    • HDR +：通过考虑相邻像素（取决于内核大小设置）来调整每个像素灰度值。 与 HDR 相比，这在黑暗（曝光不足）和明亮（曝光过度）区域提供了更多的对比度。
    • HDR：分别调整每个像素灰度值。 这为输入图像上的暗（曝光不足）区域提供了更多对比度。
  • HDR 内核大小：指定与 HDR + 同时处理的像素数。
    • 小：121 像素（11x11网格）
    • 大：484 像素（22x22网格）


白平衡（仅限 In-Sight 彩色视觉系统）

注意:本主题介绍连接到 In-Sight 彩色视觉系统时的白平衡功能。如果连接到 In-Sight 2000 系列彩色视觉传感器，请参阅图像设置的白平衡主题。

白平衡按钮仅可用于彩色 In-Sight 视觉系统和支持彩色的模拟器，它通过计算图像的红、绿和蓝色 (RGB) 值并根据存储在 In-Sight 作业中的色彩表对其进行纠正来移除彩色图像中的偏色。因此，实际图像如果是白色的项目，则将在图像中显示白色。

白平衡前的图像 | 白平衡 | 白平衡后的图像

通过采集“中性”参照图像（即具有相等 RGB 值的图像，例如 18-18-18）来创建色彩表，同时确保图像不会趋于饱和 (255-255-255)。按下白平衡按钮后，EasyBuilder 会生成每个颜色通道（红、绿和蓝）的直方图并“均衡”颜色值，方法是将最高值视为基准并将其除以每个颜色值得到比例因子，然后用其创建色表（例如，200-100-50 的 RGB 将得出 1-2-4 的比例因子）。

当前视觉系统设置的颜色表会保存在作业文件中。要确保应用正确的白平衡信息，请在加载或采集图像之前加载作业。

要使用白平衡功能：

  1. 将 In-Sight 传感器对准一个平坦的测试对象，例如一张黑色白纸，并相应地设置目标图像亮度。

    注意:白平衡区域按钮用于指定在计算图像白平衡时将要使用的区域。按白平衡区域按钮指定区域。
  2. 替换平面文字对象，插入另一个对象，例如空白的白纸。第二个对象应以原始对象相同的方式拟合在视图字段。

  3. 按白平衡按钮。

  4. EasyBuilder 会将这些设置即刻存储在作业文件中，而且所有后继图像采集均将使用此色彩平衡设置。

    注意:对于 In-Sight 彩色视觉系统，白平衡设置存储在作业文件中，而不是 In-Sight 视觉系统中。创建新作业时，您需要重复这些步骤以执行该作业文件的白平衡设置。EasyBuilder 将不允许白平衡设置保留在视觉系统上。


聚焦区域

聚焦区域按钮用于指定在进行实时模式焦点衡量计算图像焦点时将要使用的图像区域。点击聚焦区域按钮即可配置区域。


聚焦控制

聚焦控制用于在支持的 In-Sight 7000 系列视觉系统上通过自动对焦镜头或将镜头移动到特定对焦位置来控制镜头的对焦位置。

注意:
  • 对于 In-Sight 70xx - 74xx 系列视觉系统，聚焦控制只能在运行 In-Sight Explorer 4.7.3 或更高版本、In-Sight 4.7.3 固件或更高固件版本的视觉系统上可用。
  • 聚焦控制仅在视觉系统离线时可用。
  • 自动对焦和保存对焦按钮也可以从电子表格视图和 EasyBuilder 视图中的实况图像模式访问。
已关闭 聚焦控制

定义“聚焦控制”是否被启用。 默认情况下，如果传感器具有有效的默认聚焦位置，则启用聚焦控制; 如果聚焦位置尚未建立，则聚焦控制将被禁用。

已关闭 自动聚焦按钮

自动聚焦镜头并最大化区域内图像的清晰度。

已关闭 自动聚焦偏移（仅限 In-Sight 70xx - 74xx 系列）

定义了在自动聚焦结束之后需调整的镜头聚焦位置偏移值（-100 至 100； 默认 = 0）。

注意:In-Sight 7000 Gen2 系列视觉系统不支持此设置。
已关闭 聚焦位置

将镜头移动到特定的对焦位置并获取新图像。

  • In-Sight 70xx - 74xx 系列：0 - 100；默认 = 0。
  • In-Sight 7000 Gen2 系列：0 - 250；默认= 0。
已关闭 保存聚焦位置与作业

定义了聚焦位置是否会和作业一起保存并在作业重新加载时应用到镜头。 默认情况下，保存聚焦位置与作业复选框已被选中。


线扫描控制

线扫描控件允许您配置 In-Sight 5604 或 9902L 线扫描视觉系统的设置。当目标对象在其下方经过时，线扫描视觉系统会逐行扫描组成图像。该过程可以构造圆柱形物体的完整的未包裹图像或表面切分的连续图像。使用用户提供的编码器，线扫描视觉系统提供高精度图像，尽管目标速度可变。

注意:
  • 您必须连接到 In-Sight 5604 或 9902L 线扫描视觉系统或模拟器才能启用这些控件。
  • 用户必须将其访问级别设置为“完全访问权限”才能配置设置。
  • 线扫描视觉系统必须处于脱机状态。

  • 触发：定义线扫描视觉系统处于在线状态时图像的采集触发源。

    • 相机（默认）：在视觉系统的专用采集触发输入端检测到的上升沿启用图像采集。
    • 连续：启用自由运行，尽可能快地采集图像。

    • 外部：在串行命令或上升沿上启用图像采集，应用于配置为采集触发的离散输入位。

      注意:
      • 使用视觉系统的内置采集触发输入（通过将采集图像函数的触发参数设置为相机）与使用配置为采集触发的通用输入线路触发视觉系统（通过将采集图像函数的触发参数设置为外部触发）相比，可以实现更快的触发速率。
      • 如果采集图像函数的触发参数设置为外部触发，且错过了采集，则错过采集错误信息的离散输出不会从视觉系统发送。 仅当采集图像函数的触发参数设置为相机时，才会发送错误信息：错过采集信号。
    • 手动：按 F5 时启动图像采集。
    • 工业以太网：支持从工业以太网协议触发，如 EtherNet / IP，POWERLINK，Profinet，SLMP扫描或 CC-Link IE Field Basic。
    • 时间戳：当通过EtherNet / IP从PLC发送时间戳触发到视觉系统时，启动图像采集。时间戳选项仅在以下视觉系统上受支持：

      • In-Sight 5000系列视觉系统，具有128MB非易失性闪存且运行固件版本4.5.0或更高版本

        注意:不支持In-Sight 5605视觉系统（硬件型号821-0032-1R），In-Sight 5705视觉系统以及In-Sight 5705C 视觉系统。
      • In-Sight 7000 Gen2系列视觉系统
      • In-Sight 9000 系列视觉系统

  • 线延迟（线）：定义在开始图像采集之前相机触发后延迟的线数。

    注意:必须将触发参数设置为相机才能启用此控件。
  • 触发间隔：定义触发控制设置为连续时（0到10,000;默认值为500）图像采集之间的间隔（以毫秒为单位）。此延迟取决于作业完成图像处理所需的时间。例如，如果触发间隔设置为 5,000 毫秒，则 In-Sight 视觉系统每 5,000 毫秒采集一个图像，前提是作业在 5,000 毫秒内完成图像处理。如果不设置，则 In-Sight 在完成图像处理后将立即采集图像。

  • 曝光（μsec）：定义曝光时间，以微秒为单位（0 到 1000 微秒；默认值为 8 微秒）。当视觉系统接收到触发器信号时，光源会在指定的时间内集成到视觉传感器阵列中。

    注意:
    • 对于 5604，虽然此参数在技术上可以设置为 0，但无论定义的曝光值如何，任何低于1.33微秒的值都将曝光1.33微秒。
    • 对于 9902L，虽然此参数在技术上可以设置为 0，但无论定义的曝光值如何，任何低于2.00微秒的值都将曝光2.00微秒。
  • 线触发类型：定义编码器类型：软件编码器或硬件编码器。您必须连接到 In-Sight 5604 或 9902L 才能启用此控制; 线扫模拟器禁用此控件。
    • 硬件编码器：指定使用每行步数设置和外部硬件编码器来驱动线路触发。硬件编码器是一种通过在每次目标移动指定方向或距离时提供信号转换来数字化目标对象位置的设备。In-Sight 5604 和 In-Sight 9902L 支持两种不同类型的硬件编码器：单编码器或正交编码器。这可以在行扫描设置对话框中指定。
    • 软件编码器（默认）：指定行周期 设置将用作时钟以定义间隔驱动线路触发。软件编码器是硬件编码器的软件模拟，以定义的速率获取扫描行。该方法主要用于设置和故障排除，因为该方法容易受到目标速度（低频加速和高频抖动）的影响，这可能导致产生垂直图像伪影。
  • 行数：定义从行扫描视觉系统构建图像时将获取的行数。
    • 默认情况下，In-Sight 5604 以 1024 x 2048 分辨率生成标准区域图像。宽度无法调整。按编码器设置按钮可以调整最大图像高度以启动线扫描设置对话框。线数值的范围可以从1到最大图像高度。
    • 默认情况下，In-Sight 9902L 以 2048 x 4096 分辨率生成标准区域图像。可以通过点击编码器设置按钮启动线扫描设置对话框来调整宽度和最大图像高度。如果选中1K分辨率（低光模式）复选框，则宽度将减小到1024，从而提高光敏感度。线数值的范围可以从1到最大图像高度。
    In-Sight 型号 | 最大分辨率 | 最小 | 最大 | 默认
    In-Sight 5604 | 1024 x 8192 | 1 | 8192 | 2048
    In-Sight 9902L | 2048 x 16384 | 1 | 16384 | 4096
    1024 x 16384
    注意:
    • 如果获取旋转目标的图像，则线数值应小于任何两帧触发之间的线数，以避免丢失图像触发。
    • 虽然此参数在技术上可以设置为1，但任何低于8的值都会导致图像采集失败。

  • 每线步数：当线触发类型设置为硬件编码器时，定义每个图像行的编码器步数。当使用正交硬件编码器时，“步”是编码器信号或信号的完整周期。对于单线硬件编码器，相当于两个信号转换，对于正交硬件编码器，相当于四个信号转换。

    In-Sight 型号 | 每线步数
    In-Sight 5604 | 0.250 到 256.000；默认 = 40.000
    In-Sight 9902L | 0.250 到 8191.000；默认 = 40.000
    注意:
    • 对于单线硬件编码器，每线步数值应增加0.5，对于正交硬件编码器，应增加0.25。
    • 对于 5604，为防止缺失线路触发，必须配置每线步数值，以使任意两条线之间的最短时间比“曝光”设置（最小值为1.33微秒）大21.47微秒。
    • 对于9902L，为防止缺失线触发，必须配置每线步数值，以使任意两行之间的最短时间比曝光设置大3微秒或15微秒，以较大者为准。
    已关闭 每线硬件编码器时序图的步骤

  • 线周期（μsec）：当线触发类型设置为软件编码器时，定义每个图像行的时间（以微秒为单位）。

    In-Sight 型号 | 线周期
    In-Sight 5604 | 21.000 到 1000000.000；默认 = 40.000
    In-Sight 9902L | 21.000 到 1000000.000；默认 = 40.000
    In-Sight 模拟器 | 10.000 到 1000000.000；默认 = 40.000
    注意:
    • 对于 5604，为防止缺失线路触发，必须配置线路周期值，以使任意两条线路之间的最短时间比“曝光”设置（最小值为1.33微秒）大21.47微秒。
    • 对于9902L，为防止缺失线触发，必须配置线周期值，以便任意两条线之间的最短时间比曝光设置大3微秒或15微秒，以较大者为准。
  • 剪辑模式：如果收到图像采集触发，但尚未获取指定的线数，则定义一个操作。
    • 无剪辑（默认值）：指定将忽略图像触发并生成采集错误的事件。
    • 填充黑色：指定剩余的线数将填充黑色像素，并立即启动新图像。采集错误事件将不会被生成。

    • 缩小图像行：指定将当前图像缩小为当前采集的行数，并立即启动新图像。

    注意:
    • 选择填充黑色或缩小图像行时：
      • 将触发类型设置为相机以正确剪辑图像。对于任何其他触发类型，如果在获取图像时触发信号到达，则不会剪辑当前图像并会错过触发。
      • 如果发送设置事件本机模式命令以触发采集并在获取图像时触发信号到达，则不会剪辑当前图像并会错过触发。
    • 对于时间要求严格的应用程序，请选择减少图像行选项。或者，如果使用填充黑色选项，请将填充保持在几百行之下。
      • 对于 5604，填充黑色选项每行填充大约需要 2 微秒（例如，对于 100 行，需要 0.2 毫秒）。
      • 对于9902L，填充黑色选项每条填充线需要大约3微秒（例如，对于100条线，为0.3毫秒）。
  • 采集持续时间：指定当“剪辑模式”参数设置为“填充黑色”或“减少图像线数”时，何时结束图像采集。当相机为选定的触发类型时，该选项仅支持In-Sight 9902L视觉系统。
    • 0 =下一个触发（默认）：图像采集从触发脉冲的前沿开始，并在下一个触发信号的开始处结束。
    • 1 = 触发结束：图像采集从触发脉冲的前沿开始，并在触发脉冲的后沿结束。图像采集将在以下任何一种情况发生下完成：
      • 即使触发脉冲的后沿尚未到达，也已获取指定的行数。

      • 脉冲的后沿到达并在获取指定的行数之前终止采集。

        注意:选择触发结束选项后，将禁用延迟参数，并且不会对采集应用延迟。

线扫描设置


线扫描设置

线扫描设置对话框可用来配置In-Sight 5604和9902L线扫描视觉系统的硬件编码器设置，并显示视觉系统的诊断信息。

注意:使用正交硬件编码器时，如果视觉系统开始采集图像并且正交编码器信号正在相反方向移动并移过帧触发的开始，则生成的图像不正确且无法使用。如果发生这种情况，请在正交编码器发出正向反转信号时将视觉系统置于离线状态。一旦正交编码器发出正在恢复其先前方向的信号，就将视觉系统重新置于在线状态。

  • 最大图像高度：指定用于线扫描视觉系统的构建图像的最大行数和最大图像缓冲区数：

    视觉系统 最大图像高度
    In-Sight 5604

    2048（默认）

    4096

    8192
    In-Sight 9902L

    2048

    4096（默认）

    8192

    12288

    16384
    注意:
    • 调整线扫描视觉系统的最大图像高度设置需要重新启动视觉系统，并从非易失性闪存中删除所有作业和设置文件。请在继续之前保存或备份您的工作。
    • 启动时分配给视觉系统的默认图像缓冲区数量取决于视觉系统的分辨率和RAM大小。调整最大图像高度设置可能会增加或减少视觉系统可用的最大图像缓冲区数量。如果需要，使用图像缓冲区对话框修改启动时分配给视觉系统的图像缓冲区数。

    • 使用线扫描视觉系统时，区域的定位或检测工具宽度有最大限制。如果需要将区域宽度设置为更高的值，则必须访问电子表格视图并在公式栏中手动输入区域值，或者创建单独的控件或结构函数，并引用它来代替工具的区域参数。

      视觉系统 | 分辨率 | 最大图像高度 | 属性表中的最大宽度
      In-Sight 5604 | 1024 x 8192 | 8192 | 3072
      In-Sight 9902L 2048 x 16384

      8192 以及更高

               6144
      1024 x 16384 | 4096 以及更高 | 3072
  • 硬件编码器
    注意:要修改编码器类型或方向，必须将设置图像应用程序步骤中的线触发类型参数设置为硬件编码器，线扫描视觉系统必须处于脱机状态，并且用户必须具有完全访问权限。

    • 编码器类型：指定用于触发线路采集的硬件编码器类型：单线（默认）或正交。

      注意:
      • 当编码器类型设置为单线时，单线编码器必须连接到第一个编码器输入; 将线连接到第二个输入则无效。
      • 正交编码器提供方向信息，需要两个高速输入。

    • 方向：指定将哪个方向视为正交编码器的正向：正（默认）或负。线扫描视觉系统使用方向来确定正确的操作方向。反向的步骤被视为无效且会导致当前帧被中止。

      注意:当编码器类型设置为单线时，将禁用此控件。
  • 诊断
    • 编码器计数：显示硬件编码器步数（或软件编码器的微秒）。
    • 线计数：显示自上次重置计数器以来获取的线数的总计。
    • 线数溢出计数：显示由于编码器速率过高而丢失的线数。
    • 缓冲区溢出计数：显示线扫描视觉系统用完图像缓冲区的次数。
    • 每秒帧数：显示每秒采集的帧数。

    • 每秒步数：显示每秒从外部硬件编码器传达的步数。

      注意:如果使用软件编码器，则显示的值是每秒的微秒数。

    • 重置按钮：将所有诊断统计信息重置为零。

      注意:单击重置按钮或将线扫描视觉系统置于联机或脱机时，将重置所有诊断统计信息。
  • 1K分辨率（低光模式）：通过降低分辨率来提供增强的光线灵敏度。此选项仅在In-Sight 9902L视觉系统上受支持。


根据实际单位校准图像

注意:本主题介绍了连接到 In-Sight 视觉系统时的校准功能。 如果连接到 In-Sight 2000-130/130C 或 In-Sight 2000 系列 23X 视觉传感器，请参阅图像设置的视野（宽度）部分。

通过根据实际单位校准图像组框可校准位置和检测工具的结果，使其以实际测量单位（微米、毫米、厘米和/或英寸）而非像素值显示。

对于 In-Sight 视觉系统，校准是指在图像中的特征与已知的实际测量单位之间建立关系来“映射”图像区域的过程。在此过程中，二维 (2D) 变换会从数学上将点从图像的像素坐标映射为实际坐标。图像校准完成后，“位置”和“检查”工具将以校准（实际）单位报告其结果。

有七种不同的校准类型（具有不同精确度）用于校准 In-Sight 视觉系统：X/Y 缩放、边缘到边缘、X/Y 边缘到边缘、圆、网格、导入或 9 个基准点。

要为作业分配校准，请从校准类型下拉菜单中选择一个校准选项：

  • 无（默认）
  • X/Y 缩放
  • 边缘到边缘
  • X/Y 边缘到边缘
  • 9 个基准点
  • 圆
  • 网格
  • 导入
注意:
  • X/Y 缩放、边缘到边缘、X/Y 边缘到边缘、圆、导入和 9 个基准点校准选项各自要依赖于 1 到 16 个用户在图像中指定的点，以与要检查对象的实际测量关联。这些校准选项只能补偿线性和非线性失真。要获得最高精确度，请使用网格校准选项。
  • 当校准类型为默认校准类型无时，则所有工具的结果会以像素坐标返回。
  • 选中典型方向复选框可查看与传统电子表格视图坐标 (Y/X) 一致的校准结果。
  • 应用校准时，校准和运行时操作的物理和光学设置（镜头、视觉系统以及视觉系统与采集场景之间的物理关系）必须相同。如果更改了这些项目中的任何一项，必须重新校准系统。因此，建议使用相同的视觉系统和镜头来校准和处理运行时图像。视觉系统和镜头还必须保持原始设置和校准设置不变。例如，更改采集格式（通过更改分辨率）或移动视觉系统将使计算的 2D 变换（用于将像素映射到实际坐标）无效。

X/Y 缩放、边缘到边缘、X/Y 边缘到边缘和圆校准类型

9 个基准点校准类型

网格校准

导入校准类型


X/Y 缩放、边缘到边缘、X/Y 边缘到边缘和圆校准类型

如果应用程序检测一个部件或对象，并且知道该部件或对象的实际测量值，则 X/Y 缩放、边缘到边缘、X/Y 边缘到边缘和圆校准选项十分有用。

注意:缩放校准选项不会考虑镜头失真，因此，要达到最高精确度，请确保垂直于检查表面安装 In-Sight 视觉系统。否则，考虑使用网格校准以消除失真，同时更精确地校准图像。
已关闭 X/Y 缩放

在知道 X 和 Y 缩放值时使用该选项来计算简单校准。

注意:此选项不考虑失真。
  1. 从校准类型下拉菜单中选择 X/Y 缩放。
  2. 从单位下拉菜单中，选择实际单位（微米、毫米、厘米或英寸）。
  3. 在水平缩放比例参数中，输入水平缩放比例值（0 至 9,999,999）。
  4. 在垂直缩放比例参数中，输入垂直缩放比例值（0 至 9,999,999）。
  5. 选择此选项并配置完值后，便会立即应用校准。
已关闭 边缘到边缘

知道两个边缘特征之间的距离时使用。

  1. 从校准类型下拉菜单中选择边缘到边缘。
  2. 按选择边缘按钮；EasyBuilder 将检查图像并提供自动检测到的智能特征选择（以青色突出显示）。
  3. 首先从可用特征中通过单击选择一个智能特征，在此位置颜色会改变为洋红，且线条会从该特征延伸出来。

  4. 然后，选择第二个智能特征。

    注意:如果您想使用的特征 EasyBuilder 没有自动找到，取消选中智能特征复选框，然后根据您想定义的特征定位区域。
  5. 按确定按钮定义特征。
  6. 从单位下拉菜单中，选择实际单位（微米、毫米、厘米或英寸）。
  7. 将已知的特征实际测量值输入到尺寸字段中。
  8. 按校准按钮以完成校准过程。位置和检测工具的结果会即刻以实际单位显示。
已关闭 X/Y 边缘到边缘

知道两个边缘对（一个在水平方向，另一个在垂直方向）的间距时使用。将水平测量值和尺寸与垂直测量值和尺寸合并可创建两个独立的缩放。

  1. 从校准类型下拉菜单中选择 X/Y 边缘到边缘。
  2. 按定义水平测量按钮；EasyBuilder 将检查图像并提供自动检测到的智能特征选择（以青色突出显示）。
  3. 首先从可用特征中通过单击选择一个智能特征，在此位置颜色会改变为洋红，且线条会从该特征延伸出来。

  4. 然后，选择第二个智能特征。

    注意:如果您想使用的特征 EasyBuilder 没有自动找到，取消选中智能特征复选框，然后根据您想定义的特征定位区域。
  5. 按确定按钮定义特征。
  6. 按定义垂直测量按钮；EasyBuilder 将检查图像并提供自动检测到的智能特征选择（以青色突出显示）。
  7. 首先从可用特征中通过单击选择一个智能特征，在此位置颜色会改变为洋红，且线条会从该特征延伸出来。
  8. 然后，选择第二个智能特征。
  9. 按确定按钮定义特征。
  10. 从单位下拉菜单中，选择实际单位（微米、毫米、厘米或英寸）。
  11. 将已知的特征实际水平尺寸输入到水平尺寸字段中。
  12. 将已知的特征实际垂直尺寸输入到垂直尺寸字段中。
  13. 按校准按钮以完成校准过程。位置和检测工具的结果会即刻以实际单位显示。
已关闭 圆

知道圆形特征的直径时使用。

  1. 从校准类型下拉菜单中选择圆。
  2. 按选择圆按钮；EasyBuilder 将检查图像并提供自动检测到的智能特征选择（以青色突出显示）。

  3. 从可用特征中选择一个智能特征（只需单击该特征即可，在此位置颜色将变为洋红）。

    注意:如果您想使用的特征 EasyBuilder 没有自动找到，取消选中智能特征复选框，然后根据您想定义的特征定位区域。
  4. 按确定按钮定义特征。
  5. 从单位下拉菜单中，选择实际单位（微米、毫米、厘米或英寸）。
  6. 将已知的特征实际测量值输入到尺寸字段中。
  7. 按校准按钮以完成校准过程。位置和检测工具的结果会即刻以实际单位显示。


9 个基准点校准类型

9 个基准点校准选项在需要为机器视觉创建正确坐标空间的机器视觉应用中非常有用。该校准选项依赖于一个圆形的目标，如下图所示。理想情况下，校准面应该包含 9 个在网格参照图形中间隔平均的目标。在开始校准过程之前应先测量目标之间的水平和垂直距离。

注意:
  • 在 9 个目标中心的的目标会被作为机器视觉坐标系原点 (0,0)。
  • 水平目标间的空间必须一致且相等。同样，垂直目标间的空间也必须一致且相等。然而，水平目标和垂直目标间的空间不需要相等。
  • 每个目标都必须含有 25 个像素的最小圆直径。
已关闭 示例 - 单个目标

已关闭 示例 - 9 个目标

注意:坐标不应出现在实际图像中；它们仅作为说明用途被插入。
注意:9 个基准点校准选项不会考虑镜头失真，因此，要达到最高精确度，请确保垂直于检查表面安装 In-Sight 视觉系统。

在开始校准过程之前，需采集一个含有 9 个间隔均匀目标的校准面图像。

  1. 从校准类型下拉菜单中选择 9 个基准点选项。

  2. 点击编辑模型按钮，并配置区域使其包括中间的目标。然后点击 OK 按钮。在围绕中间目标配置区域的时候，请确保区域与圆之间至少有 3 至 4 个像素的距离。同时请尽量将目标放置在区域的中间位置。

    已关闭 示例

  3. 配置模型后，EasyBuilder 会自动检测图像中的所有目标，并会在检测到的目标上显示一个绿色的十字图标。

    注意:如果检测到目标的基准但却没有检测到基准周围的圆，红色的十字图标会显示。请重新训练模型或重新采集图像以解决该问题。
  4. 从单位下拉菜单中，选择实际单位（微米、毫米、厘米或英寸）。
  5. 在 X 尺寸输入框中，输入同一行中两个目标之间水平距离的实际坐标尺寸（从每个目标的中心开始测量）。
  6. 在 Y 尺寸输入框中，输入同一列中两个目标之间竖直距离的实际坐标尺寸（从每个目标的中心开始测量）。
  7. 按校准按钮以完成校准过程。位置和检测工具的结果会即刻以实际单位显示。


网格校准

在其部署环境中，In-Sight 视觉系统可能会捕获呈现了由某些设置条件（如镜头和透视失真）引起的失真图像。某些镜头可能产生桶形或枕形径向失真图形，导致实际的直线在图像中显示为曲线。当无法垂直于检查区安装 In-Sight 视觉系统时，会产生透视失真。在这些情况下，图像中的特征可能会被拉伸或拉长显示（具体取决于在视场中的位置），从而导致结果不准确。

网格校准选项可通过采集点或棋盘方格的网格图形的图像，来创建一个图像区域的"映射"。然后，此选项会将找到的网格特征（点或方格的交点）与网格图形中用户指定的网格间距相关联。此过程可创建一个高准确度的计算法，可在随后用于将失真的特征变换成正确的形状。

通过校准 In-Sight 视觉系统可以更准确地定位图像边缘的对象，并提供更好的安装灵活性，包括能与检查表面呈 45° 安装 In-Sight 视觉系统。

提示:如果应用程序需要网格校准，可以使用"变换"图像过滤工具查看未失真结果并让其它检查工具引用其工具图像输出。
  1. 从校准类型下拉菜单中选择网格。
  2. 按校准按钮，将启动 CalibrateGrid 对话框。有关更多信息，请参阅 In-Sight® 浏览器帮助文件。


导入校准类型

导入校准类型用于加载已由 N 点或序列 N 点校准工具创建，并已导出到 In-Sight 视觉系统的本地文件系统中的校准文件。只要导入的校准文件完成加载，它就会自动校准当前作业。

注意:在选择导入作为校准类型之前，请首先添加并配置 N 点或序列 N 点校准工具，然后将校准文件导出到 In-Sight 视觉系统的本地文件系统。

N 点和序列 N 点校准工具会创建 2D 变换以在像素与实际坐标系之间转换。在此过程中，这两个工具会考虑到线性和非线性失真，并且在使用五个或更多点对时，提供比 X/Y 缩放、边缘到边缘、X/Y 边缘到边缘或圆 校准方式更高的精确度。该工具执行以下变换：

  • 二维转换（使用 2 个或更多点对）。
  • 绕三个轴旋转（使用 4 个或更多点对）。
  • 二维缩放（使用 2 个或更多点对）。
  • 透视失真（使用 4 个或更多点对）。
  • 平行四边形或倾斜（使用 4 个或更多点对）。
已关闭 导入
  1. 从校准类型下拉菜单中选择导入。
  2. EasyBuilder 会自动检查作业中由 N 点或序列 N 点校准工具生成的校准文件，并加载该校准文件。如果创建了多个校准文件，请从文件名下拉菜单中选择所需的文件。
  3. 从单位下拉菜单中，选择定义校准的实际测量单位：微米、毫米（默认）、厘米或英寸。
  4. 选择此选项并配置完值后，便会立即应用校准。


定位部件

定位工具用于定义提供位置数据的图像中的特征。 定位工具创建一个定位特征，用于快速可靠地定位图像中的零件，即使被检测的零件旋转或出现在图像的不同位置。 有关更多信息，请参阅定位特征。

注意:
  • 如果您的作业不需要位置数据，或者您的部件将在每张图像的相同位置呈现给 In-Sight 传感器，请参阅检测部件。
  • In-Sight 2000-110和120/120C 视觉传感器允许您仅为作业添加一个定位特征。
  • In-Sight 2000 系列视觉传感器不支持链接选项卡。

位置工具报告以下结果：

In-Sight 型号 | 结果
In-Sight 2000-110 and 2000-120/120C 视觉传感器 | 仅限通过/失败状态
In-Sight 2000-130/130C 视觉传感器 | 图形定位工具：通过/失败状态和图形分数 其它定位工具：仅限通过/失败状态
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 标准结果（位置数据和通过/失败状态）。 该工具以像素为单位报告结果，除非在设置图像中将图像校准为真实世界单位。

添加、删除和编辑位置工具

选择一个定位工具

创建定位和检测工具之间的链接


添加、删除和编辑定位工具

已关闭 添加工具

要向作业添加工具，请从添加工具组中选择合适的工具，然后按添加按钮，或者双击该工具。然后你会被提示指定图像中的特征。你可以通过 EasyBuilder 智能特征选项调整图像的区域图形来进行定义，也可以通过定位几何参考图形来进行定义。

最初的定义特征完成后，你可通过调整各项参数来精细调整工具的控制。

注意:你可以通过使用工具搜索框来动态搜索工具。
已关闭 删除工具

要从作业中删除工具，只需执行以下操作之一：

  • 在结果表（位于“选择板”的结果选项卡中）中选择该工具，然后按键盘的 Delete 键。
  • 在结果表（位于“选择板”的结果选项卡中）中选择该工具，然后按标准工具栏中的删除图标。
  • 在结果表（位于“选择板”的结果选项卡中）中右键单击该工具，然后选择菜单中的删除选项。
已关闭 编辑工具

要从 EasyBuilder 的任意步骤编辑工具，只需执行以下操作之一：

  • 在结果表（位于“选择板”的结果选项卡）中双击该工具。
  • 在结果 表中右键单击该工具，然后从菜单中选择转到此工具并编辑选项。

要在定位部件或检测部件步骤中编辑工具，只需执行以下操作之一：

  • 在图像中选择该工具的区域图形。
  • 在结果表（位于“选择板”的结果选项卡）中双击该工具。
  • 在结果 表中右键单击该工具，然后从菜单中选择转到此工具并编辑选项。
  • 在运行作业应用程序步骤中双击“结果表”中的工具。
注意:
  • 如果 In-Sight 视觉系统支持访问 In-Sight Explorer 的电子表格编程环境，则会出现右键单击菜单选项在电子表格中转到此工具的选项。建议您仅在熟悉电子表格编程环境并且了解其操作时，才访问此环境。在继续进行之前，请参阅 EasyBuilder 作业和电子表格 In-Sight Explorer 联机帮助文件主题。
  • 通过将工具拖拉到需要的顺序，可以在结果表格中重新排列工具。该操作可以在运行作业结果表格和选择板结果选项卡中进行。无论在哪个表格中进行的修改，结果将同时会在两张表格中更新。拖拉排序仅在表格的工具顺序和附属图形栏被选择的情况下才能启用(默认情况下，该栏会被选择)。如需颠倒顺序，重新选择该栏。如果作业大小已经接近作业的最大极限，则该功将不能使用。
注意:如作业中没有足够空间，无法添加更多工具，则退出定位或检查部件应用程序步骤，从传感器菜单中，选择作业大小限制。使用该对话框调整作业大小，使其能容纳更多工具。要调整 In-Sight 视觉系统的作业大小限制，需要给视觉系统重新加电，并将删除非易失性闪存中的所有作业和设置文件。请先保存或备份作业再继续。

特性

区域

定位特征


特征

在机器视觉中，特征是指“图像中的关注对象”，而视觉检查是围绕图像中发现的特征类型而设计的。

定位部件步骤中包括以下类型的特征：

已关闭 边

亮像素和暗像素之间的线性转换区域。部件的末端、电路板上的针脚或螺丝上的螺纹等均属于边。检查期间，边是可较快检测到的特征类型之一，但将其用作定位器时，它们只能在一个方向（水平或垂直）上运动，且必须具有高对比度。

已关闭 边定位器示例

本例中，空气清新剂喷射器没有出现在各个图像的同一位置上；它们出现在同一垂直平面内，但是沿水平方向移动。两个“边位置”工具用作定位器；左边的“边位置”工具定位喷射器下部分机架的外部边，并且定向左侧的其它检查工具的区域，而右边的“边位置”工具则定向右侧的工具。

已关闭 圆

圆实质上是由定义其几何形状的亮像素和暗像素之间的转换定义的边和区域。只要它们的对比度很高，圆也是可较快识别的特征类型之一，但用作定位器时，圆不提供任何角度方向数据。

已关闭 圆定位器示例

本例中，两个定位器均投入使用。第一个定位器是一个“斑点位置”工具，定位管的外部，而第二个定位器是一个“圆位置”工具，在发现的斑点中定位管的基本圆形状。由于应用程序的要求，螺丝的长度通过测量相关点到已发现形状之间的距离来确定，并且所有螺丝的长度必须相同。

已关闭 图形

图形可以是任何事物，从一组简单的重复形状到徽标或标签之类的复杂图形均属于图形。图形是用作定位器的最可靠的特征类型，它允许最大范围的位置旋转、移动和缩放变化，但通常需要最长的检查时间。

已关闭 图形定位器示例

本例中，二维代码出现在各个图像中不同的位置和方向上。“PatMax 图形位置”工具用于创建定位器和定向“读取 ID 代码识别”工具的搜索。“PatMax 图形位置”工具可用于定位复杂的图形，同时提供多个位置、方向和缩放。

已关闭 斑点

一组深色或浅色的连通像素，例如，黑色背景上的白色油漆污点，或白色传送带上的黑色螺丝。斑点的检测速度在边和图形之间。与图形相比，斑点允许斑点特征的形状和大小具有更大的变化，但在用作定位器时，其角度方向值受限制。

已关闭 斑点定位器示例

本例中，两个定位器均投入使用，因为被检查的特征（螺丝）位于对象（管）内部，该对象的方向以及垂直和水平位置在各图像之间可能会发生变化。管的法兰创建了一个不规则形状，所以使用“斑点位置”工具创建一个定位器以将管定位在视场内。


区域

区域定义定位工具或检查工具将要执行操作的图像区域，也称为“关注区”。

根据使用的工具类型，EasyBuilder 中有多种不同的区域类型供定位工具和检查工具使用。EasyBuilder 使用的区域类型如下：

  • 矩形
  • 圆形
  • 环形
  • 多边形

环形区域

圆形区域

多边形区域

矩形区域


环形区域

环形区域用于定义圆形边特征。环形区域具有内外半径，可用于定义圆形边特征而忽略圆心。

已关闭 环形区域鼠标操作

 | 控制 | 说明
1 | 移动 | 将鼠标光标放置在内外半径之间，鼠标光标图标将自动变换，允许将区域拖动到图像内的任何位置。
2 | 调整大小 | 将鼠标光标放置在环形区域的内半径或外半径上方，鼠标光标图标将自动变换，允许拖动内半径或外半径以调整其大小（必须单独调整内外半径的大小）。
已关闭 环形区域扫描方向

环形区域从内半径到外半径扫描圆形特征。

已关闭 环形区域颜色代码

 | 说明
1 | 已新增、未选择的环形区域。
2 | 已选择、未确认的环形区域。
3 | 已选择、已配置并通过的环形区域。
4 | 未选择、已配置并通过的环形区域。
5 | 已选择、已配置但失败的环形区域。
6 | 未选择、已配置但失败的环形区域。


圆形区域

圆形区域用于定义圆周特征。圆形区域捕获圆内的一切。要定义圆周特征而忽略圆心，请使用环形区域。

已关闭 圆形区域鼠标操作

 | 控制 | 说明
1 | 移动 | 将鼠标光标放置在区域内，鼠标光标图标将自动变换，允许将区域拖动到图像内的任何位置。
2 | 调整大小 | 将鼠标光标放置在圆形区域的边界上，鼠标光标图标将自动变换，允许拖动区域以调整其大小。
已关闭 圆形区域扫描方向

圆形区域扫描从圆心到外半径的特征。

已关闭 圆形区域颜色代码

 | 说明
1 | 已新增、未选择的圆形区域。
2 | 已选择、未确认的圆形区域。
3 | 已选择、已配置并通过的圆形区域。
4 | 未选择、已配置并通过的圆形区域。
5 | 已选择、已配置但失败的圆形区域。
6 | 未选择、已配置但失败的圆形区域。


多边形区域

多边形区域用于通过构造超出线段的形状来定义不规则特征。必须将多边形区域配置为需要的形状。

已关闭 多边形区域图例

 | 控制 | 说明
1 | 可调整大小的端点边界 | 定义多边形区域的初始三个端点（一个多边形区域最多可以创建 100 个点）。单击某个端点边界可通过其一个角调整区域大小。
2 | 旋转柄 | 允许将区域旋转 360°。
已关闭 多边形区域鼠标操作

将鼠标光标放在区域的各个部分上，光标将会自动变换，允许执行以下操作：

鼠标图标 | 说明
 | 允许在图像内的任意位置拖动整个多边形区域。
 | 允许水平或垂直缩放整个区域。
 | 允许将整个区域以其当前方向旋转 360°。
 | 允许移动多边形区域的一个可调整大小的端点边界点。
 | 允许将可调整大小的端点边界点添加到多边形区域。
已关闭 多边形区域扫描方向

 | 控制 | 说明
1 | 顶部 | 指示扫描方向为水平方向。
2 | 侧面 | 指示扫描方向为垂直方向。
已关闭 多边形区域颜色代码

 | 说明
1 | 已新增、未选择的多边形区域。
2 | 已选择、未确认的多边形区域。
3 | 已选择、已配置并通过的多边形区域。
4 | 未选择、已配置并通过的多边形区域。
5 | 已选择、已配置但失败的多边形区域。
6 | 未选择、已配置但失败的多边形区域。


矩形区域

矩形区域是定义检测的最常用方式。它们可以被调整为弧形或环形区域，以更好地满足特殊应用的需要。

已关闭 矩形区域图例

 | 控制 | 说明
1 | 可调整大小的端点边界 (x4) | 定义矩形区域的四个角。单击某个端点边界可通过其一个角调整区域大小。
2 | 扫描方向指示器 (x2) | 定义矩形区域扫描特征的方向。
3 | 弯曲柄 | 允许将矩形区域弯曲为弧或环形。
4 | 旋转柄 | 允许将区域旋转 360°。
已关闭 矩形区域鼠标操作

 | 控制 | 说明
1 | 移动 | 将鼠标光标放置在区域内，鼠标光标图标将自动变换，允许将区域拖动到图像内的任何位置。
2 | 弯曲 | 将光标放置在弯曲柄上，鼠标光标图标将自动变换，允许将矩形区域调整为弧或圆环形状。例如，可随后将该形状的四条侧边调整为圆形。
3 | 调整大小 | 将光标放置在四个端点边界的任何一个上或沿四条侧边中的任意一条放置，鼠标光标图标将自动变换，允许拖动区域以调整其大小。
4 | 旋转 | 通过将光标放在旋转手柄上，鼠标光标图标将自动变换，允许将区域从当前方向旋转 360°。
已关闭 矩形区域扫描方向

 | 控制 | 说明
1 | 顶部 | 指示扫描方向为水平方向。
2 | 侧面 | 指示扫描方向为垂直方向。
已关闭 矩形区域颜色代码

 | 说明
1 | 已新增、未选择的矩形区域。
2 | 已选择、未确认的矩形区域。
3 | 已选择、已配置并通过的矩形区域。
4 | 未选择、已配置并通过的矩形区域。
5 | 已选择、已配置但失败的矩形区域。
6 | 未选择、已配置但失败的矩形区域。


定位特征

定位部件步骤中的“定位工具”可创建一个称为定位特征的输出，该输出用作其它视觉检测工具的参照点。

创建定位特征时，查看图像中的部件，并确定哪种特征类型（图形、边、圆或斑点）可以被最轻松快速地识别，且存在于部件的每个图像中。然后根据部件中特征的类型，选择适当的定位工具定义特征。

在检查期间，如果一个特征被用作定位特征，则 In-Sight 视觉系统会先搜索该特征；定位到该特征后，特征的位置会用作其它视觉检查工具的参照点，这些视觉检查工具将使用该特征的位置定位其区域。

已关闭 示例 - 有图形定位特征的作业

已关闭 示例 - 无定位特征的作业

注意:
  • 在 In-Sight 视觉系统的每个图像中，如果部件将出现在完全相同的位置，则无需使用定位特征。
  • 一个作业中可创建和使用多个定位特征，且定位特征可彼此链接。
  • 下列检测工具生成的定位特征输出可由其它工具使用：“边存在/不存在”工具、“PatMax 图形存在/不存在”工具、“图形存在/不存在”工具、“读取 ID 代码”识别工具、“PatMax 图形”识别工具、“图形”识别工具、“角度”测量工具、“距离”测量工具、“圆同心度”测量工具、“圆直径”测量工具、“点到点的中点”几何工具和“由 N 个点构成的圆”几何工具。


选择一个定位工具

检查您的零件并确定哪种类型的特征符合您的应用要求。

定位工具 | In-Sight 视觉系统 (5.x.x 固件版本) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
PatMax RedLine Pattern 1 | X |  |  |  |  |
PatMax® 图形 | X |  |  |  |  |
图形 | X | X | X | X | X | X
PatMax RedLine™ Patterns (1-10) 1 | X |  |  |  |  |
PatMax® Patterns (1-10) | X |  |  |  |  |
Patterns (1-10) | X |  |  |  | X |
Edge | X |  |  | X | X | X
Edge Intersection | X |  |  | X | X | X
Blob 2 | X |  |  |  | X |
Blobs (1-10) 2 | X |  |  |  | X |
Color Blob 3 | X |  |  |  | X |
Color Blobs (1-10) 3 | X |  |  |  | X |
Circle | X |  |  | X | X | X
Compute Fixture | X |  |  |  |  | X
1 仅适用于 In-Sight 5.x.x 固件版本。 2仅适用于黑白型号。 3仅适用于彩色型号。

PatMax RedLine 图案、PatMax 图案、PatMax RedLine 图案 (1 - 10) 以及 PatMax 图案 (1 - 10)

图案和图案 (1-10)

边缘

边缘交点

斑点和斑点 (1-10)

彩色斑点和彩色斑点 (1-10)

圆

计算定位原点


定位工具 - PatMax RedLine 图形、PatMax 图形、PatMax RedLine 图形 (1 - 10) 以及 PatMax 图形 (1 - 10)

注意:
  • 从 In-Sight 固件版本 5.5.0 开始，该工具的算法已被更改，以在某些情况下返回更准确的结果并缩短执行时间。
  • 由于此更改，如果试图将在 In-Sight 固件 5.5.0 或更高版本中设置该工具的作业加载到运行固件版本 5.4.x 或更低版本的 In-Sight 视觉系统时，会显示错误消息。
  • PatMax RedLine 图形定位工具和 PatMax RedLine 图形 (1-10) 定位工具仅在运行 In-Sight 固件版本 5.2.0 和更高版本的 In-Sight 视觉系统上可用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

PatMax RedLine 图形定位工具、PatMax 图形定位工具、PatMax RedLine 图形 (1-10) 定位工具和 PatMax 图形 (1-10) 定位工具用于根据图形的已训练表示形式（称为模型），采用 PatMax RedLine 或 PatMax 算法来定位该图形特征的位置。PatMax RedLine 图形和 PatMax 图形工具用于定位单个图形，而 PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 工具用于定位多达 10 个图形。

注意:该工具会以像素为单位报告 X、Y 坐标，除非已在设置图像中将图像校准为真实世界的实际单位。

这些工具在需要准确定位的应用中十分有用，如视觉引导的机器人应用。这些工具作为其他视觉工具的定位特征也十分有用，可在图像内定位其搜索。

设置工具

调整工具参数


设置 PatMax RedLine 图形、PatMax 图形、PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 定位工具

添加该工具之后，需要选择并配置将定义图形的区域类型（模型区域），以及将在其中查找图形的图像中的区域（搜索区域）。

  1. 从模型下拉菜单中，选择区域的类型：矩形（默认）、圆形、环形或多边形。然后将模型区域放置在将用于训练模型的图形上；请确保模型区域只覆盖图形的重要特征。添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 从搜索下拉菜单选择区域类型：矩形（默认）、圆形、环形或多边形。然后定位搜索区域，使其覆盖图像中您希望图形出现的区域。为了帮助提高工具的性能，请创建较小的搜索区域。搜索区域越大，执行检查所需的时间越长。

  3. 按确定按钮确认区域（按取消按钮不将该工具添加到作业）。

  4. 模型区域将被 [image] 图标取代，表示已找到图形的位置和角定向。
  5. 在初始配置该工具的情况下，根据需要加载几个图像并调整工具参数，以补偿预期的变化范围。
  6. 最后，如需要，可以使用工具的输入/输出属性表以在其他工具和/或其他外部设备之间共享工具数据。

选择图案特征

PatMax RedLine 图案、PatMax 图案以及图案


选择图形特征

选择要用于检查的图形时，为确保获得最佳结果，可考虑以下指导原则：

  • 图形始终出现在每个图像中。
  • 图形应尽可能多地包含独特和一致的现有特征，而组成图形的特征的外观和相对几何形状应彼此一致，且能够清楚分辨。
  • 如果可能，选择较大的图形；较大的图形通常意味图形中具有更独特的特征，可使检测更加一致和精确。


PatMax RedLine 图形、PatMax 图形和图形

注意:PatMax RedLine 图形定位工具和 PatMax RedLine 图形 (1-10) 定位工具仅在运行 In-Sight 固件版本 5.2.0 和更高版本的 In-Sight 视觉系统上可用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

PatMax RedLine 图形、PatMax 图形和图形可定位已训练的图形模型，且在定位和检测工具中提供最高准确性。然而，PatMax RedLine 图形和 PatMax 图形比图形的功能更强大，以应对灯光条件和图形位置的更大变化。它们还提供对图形比例和旋转变化、图形元素遮挡以及由于灯光条件导致的图形外观变化的出色识别。

PatMax RedLine 图形和 PatMax 图形之间的主要差别是速度；PatMax RedLine 图形采用最新图形匹配算法，可在 5 百万像素图像中以高出 PatMax 图形多达 7 倍的速度定位已训练特征。因此，PatMax RedLine 图形适用于高分辨率视觉系统。

图形（在大多数情况下）比 PatMax 快，但某些情况需要 PatMax RedLine 或 PatMax 版本的准确性和可靠性：

  • 当灯光和反射变化难以控制时。例如，金属部件可在任意方向反射光线。
  • 当要检查的图形与背景中的某些元素的形状或阴影类似，或图形与图像中的其他对象重叠或被其部分遮挡时。
  • 当希望从其他类似图形中准确识别一种图形类型时。
  • 当部署环境条件对于图形工具的一致且可靠执行过于苛刻时。


调整 PatMax RedLine 图形、PatMax 图形、PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 定位工具参数

在设置完工具的区域后，你可以开始为应用程序优化工具。

PatMax RedLine 图形、PatMax 图形、PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 定位工具的设置窗格包括以下选项卡：

  • 常规选项卡
  • 设置选项卡
  • 模型和搜索选项卡
  • 已训练图像选项卡
  • 表选项卡
注意:表格选项卡仅对 PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 定位工具启用。
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

模型和搜索选项卡

已训练图像选项卡

表格选项卡


PatMax RedLine 图形、PatMax图形、PatMax RedLine 图形（1-10）以及 PatMax 图形（1-10）位置工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Pattern_1”（如果该工具是添加到作业的第一个图形工具，之后名称将递增，如“Pattern_2”、“Pattern_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


PatMax RedLine 图形、PatMax 图形、PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 定位工具 - 设置选项卡

已关闭 要查找的数目

定义要检测的模型图形的实例数（1-10；默认值为 1）。大多数应用仅需要单个定位特征，然而，可对模型图形的多个实例进行定位，这在图像中存在多个部件或对象的应用中十分有用。要求工具识别的已训练实例越多，工具的执行时间越长。

已关闭 合格阈值

定义模型图形和已找到图形之间必须存在的相似度（0-100；默认值 = 50）。超过或等于设置的已找到图形被视为匹配。此工具在设置较高的情况下执行速度也较快，这也需要模型和已找到图形之间存在更高的相似度。设置较低产生精确度较低结果的可能性更大，如检测类似于（但不是）模型图形的图形。

已关闭 对比度阈值

定义已找到图形中必须存在的最小可接受对比度；已找到图形的对比度必须大于要视为有效实例的对比度阈值。PatMax RedLine 图形的默认值为 0，有效参数范围为 0-100。PatMax 图形的默认值为 10，有效参数范围为 0-255。低对比度阈值用于低对比度图像，而高对比度阈值用于高对比度图像。

注意:PatMax RedLine 图形对比度是已训练图形中的特征与搜索图像中的匹配特征之间的对比度变化的“相对”程度，以百分比表示。因此，如果特征对比度类似于或高于图形对比度，报告的对比度将约为 100。如果特征对比度低于图形对比度，报告的对比度将 <100。PatMax RedLine 图形的对比度不同于 PatMax 图形的对比度，后者是搜索 ROI 的“绝对”图像对比度，以灰度级表示。
已关闭 Rotation Tolerance（旋转公差）

定义可从模型图形的位置旋转已找到图形并仍将其视为有效图形的限度（± 0-180°；默认值 =15°）。允许更大的图形旋转变化范围将增加工具的执行时间。

已关闭 Scale Tolerance（比例公差）

定义已找到图形和模型图形之间允许的缩放百分比（尺寸变化）（0-50；默认值为 0）。此值为正或负百分比，例如，值 5 将启用工具以查找介于模型图形尺寸的 95% 至 105% 之间的图形。允许更大的图形比例变化范围将增加工具的执行时间。

已关闭 Find Mode（查找模式）

定义用于训练和识别图形的搜索模式（PatMax 或 PatQuick）。默认情况下，选择 PatMax。PatMax 提供的精确度比 PatQuick 高，但执行所需的时间较长，而 PatQuick 提供的精确度比 PatMax 低，但执行所需的时间较短。

已关闭 Strict Scoring（严格评分）

定义已找到图形的缺少或遮挡特征是否将影响分数（默认值 = Off（关），取消选中）。当应用 Strict Scoring（严格评分）（On（开），选中）时，如果图形的特征不存在或被阻挡，则已找到图形的分数将降低。

已关闭 忽略极性

定义所找到的图形是否可以包含与模型图形反色的匹配特征（默认值 = 关，取消选中）。应用忽略极性（开，选中）时，如果检测到的图形具有反色特征（例如与模型图形中的白色/黑色相对的黑色/白色），该图形将被归类为与模型图形匹配。

已关闭 Sort By（排序方式）

定义已找到图形的排序方式，分数（默认值）、X 或 Y。当选择分数时，会根据分数对已找到的图形进行排序，首先列出获得最高分数的图形，后面的图形以降序排列。选择 X 时，根据与 X 轴的距离排序已找到的图形，从最近到最远以降序排列。选择 Y 时，根据与 Y 轴的距离排序已找到的图形，从最近到最远以降序排列。

已关闭 Horizontal Offset（水平偏移）

定义距离已找到图形的中心的水平偏移位置（以像素为测量单位），相对于已训练模型图形。这允许您分配偏离模型图形中心的坐标，对于在视觉引导的机器人应用中定义拾取点，这十分有用。

已关闭 Vertical Offset（垂直偏移）

定义距离已找到图形的中心的垂直偏移位置（以像素为测量单位），相对于已训练模型图形。这允许您分配偏离模型图形中心的坐标，对于在视觉引导的机器人应用中定义拾取点，这十分有用。

已关闭 Timeout（超时）
定义工具搜索图形的时间，以毫秒为单位（0 至 30,000）。超过该设定时间，操作会停止并返回错误信息。默认情况下，此参数设置为 5000。
已关闭 结果

显示已找到图形的中心的 X、Y 坐标及其角定向，以及其相当于模型图形的分数。如果应用水平和/或垂直偏移，则将按照偏移字段中指定的量调整 X、Y 坐标。

注意:如果要查找的数量参数设置为大于 1，则显示的结果将始终为所找到的得分最高的图形，除非已将排序方式参数设置为 X 或 Y。
注意:
  • PatMax RedLine 图形和 PatMax RedLine 图形 (1-10) 定位工具不包含Find Mode（查找模式）参数。
  • 要查找的数目（要查找数量）和 Sort By（排序方式）参数仅受 PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 定位工具的支持。


PatMax RedLine 图形、PatMax图形、PatMax RedLine 图形（1-10）以及 PatMax 图形（1-10）位置工具 - 模型和搜索选项卡

模型和搜索选项卡用于为工具的模型和搜索区域配置复合区域。复合区域是添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为“遮掩”）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 在模型选项卡中，仅在按模型区域按钮后才能启用复合区域。
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


PatMax RedLine 图形、PatMax 图形、PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 定位工具 - 已训练图像选项卡

训练图像选项卡中显示的图像是模型图形的缩略图。按模型区域按钮可调整模型区域的大小或移动该区域，然后按训练按钮重新训练模型图形。


PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 定位工具 - 表选项卡

在表格选项卡中创建的表格会发布已找到图形的结果：

已关闭 索引

指已找到图形的顺序；1 至 10（在 EasyBuilder 中的序号基于 0=1）。

已关闭 X

参照已找到图形 X 坐标的中心。如果应用水平偏移，则将按照指定的量调整 X 坐标。

已关闭 Y

参照已找到图形 Y 坐标的中心。如果应用垂直偏移，则将按照指定的量调整 Y 坐标。

已关闭 角度

参照已找到图形的角度，相对于模型图形。

已关闭 得分

参照已找到图形与模型图形的相似度。

已关闭 比例

参照已找到图形的比例。


定位工具 - 图形与图形 (1-10)

图形定位工具和图形（1-10）定位工具用于根据该图形的训练结果（称为模型）来定位图形特征的位置。 图形工具可以被用来定位单个图形，而图形（1 - 10）工具可以被用来定位最多 10 个图形。

图形定位工具与图形 (1-10) 定位工具对要求精确定位的应用程序（如视觉引导的自动应用程序）十分有用。 此工具还经常用作其它视觉工具的定位，在图像中定位其搜索。

提示:
  • 有关如何选择图形定位特征的更多信息，请参阅选择图形特征。
  • 有关图形定位工具的更多信息，请参阅PatMax RedLine 图形、PatMax 图形和图形。

该工具将报告以下结果：

In-Sight 型号 | 结果
In-Sight 2000-110 and 2000-120/120C 视觉传感器 | 仅限通过/失败状态
In-Sight 2000-130/130C 视觉传感器 | 通过/失败状态和图形分数
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | X / Y坐标*、角度方向、得分和通过/失败状态。
*该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置单个图形与多个图形 (1-10) 定位工具

添加该工具之后，需要配置将定义图形的图像中的区域（模型区域），以及将在其中查找图形的图像中的区域（搜索区域）。

  1. 将模型区域置于将用作训练模型的图形之上，确保模型区域仅覆盖图形的重要特征。

  2. 决定搜索区域的位置，使其覆盖图像中您希望图形出现的区域。为了帮助提高工具的性能，请创建较小的搜索区域。搜索区域越大，执行检查所需的时间越长。

    注意:模型和搜索区域无法弯曲为弧或圆环形状。

  3. 按确定按钮确认区域（按取消按钮不将该工具添加到作业）。

  4. 模型区域将由 [image] 图标替代，指示所找到图形的位置和角度方向。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整图形与图形 (1-10) 定位工具参数

在设置完工具的区域后，你可以开始优化应用程序工具。

In-Sight 2000 系列传感器

图形工具

  • 编辑工具组框

图形 (1-10) 工具

  • 常规选项卡
  • 设置选项卡
  • 已训练图像选项卡
  • 表格选项卡

In-Sight 视觉系统

图形与图形 (1-10) 定位工具的设置栏包含以下选项卡：

  • 常规选项卡
  • 设置选项卡
  • 已训练图像选项卡
  • 表格选项卡
注意:表格选项卡仅对图形（1-10）定位工具启用。
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

In-Sight 2000 系列视觉传感器

In-Sight 视觉系统

版权所有 © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder 帮助 | 06/28/2022 | Revision: 5.9.0.3


调整图形定位工具参数

注意:
  • 本主题描述连接到 In-Sight 2000 系列视觉传感器时的图形定位工具用户界面。 如果连接到 In-Sight 视觉系统或使用图形（1-10）定位工具，请参阅的 In-Sight 视觉系统的调整图形与图形 (1-10) 定位工具参数。
  • 当尝试将包含在 In-Sight 固件5.7.0 或更高版本上配置的该工具的作业加载到运行固件版本 5.6.x 或更早版本的 In-Sight 视觉系统时，将显示错误消息，并且作业加载将失败。

在设置完工具的区域后，你可以开始优化应用程序工具。

已关闭 通过/失败指示

通过显示绿色边框 [image] 或红色边框 [image] 来表示通过或失败结果。

已关闭 旋转公差

指定找到的图形可从“模型”图形位置处旋转而仍可被识别为有效图形的最大角度（± 0 到 180, 默认 = ±45°）。允许较大的图形旋转偏差范围会增加该工具的执行时间。左边手柄被用来设置负角度旋转值，右边手柄被用来设置正角度旋转值。你可以通过调整手柄或在相应的编辑框内输入数字来调整旋转角度值。

提示:您还可以使用箭头键（上、下、左、右）来移动手柄。
已关闭 部件查找度量

部件查找度量显示了工具寻找特征的精确程度，并设置最小可接受阈值。你可以通过调整手柄或在相应的编辑框内输入数值来手动设置最小可接受阈值（0-100; 默认 = 50）。

提示:您还可以使用箭头键（上、下、左、右）来移动手柄。

如果度量值超过阈值，则工具会认为部件已被找到且度量会变成绿色。如果值小于阈值，则工具会认为部件没有被找到且度量会消失。如果工具检测到不是部件的目标，或检测到错误的特征，你可以将手柄往右适当调整。如果工具没有找到任何部件，可以将手柄向左适当调整（或创建一个新的模型区域）。设置的值较低会得到更多精确度较低的相似结果，如检测到与模型图形相似但不是模型图形本身的图形。

通过
失败
注意:当鼠标悬停在控制滑块上时会显示结果以及阈值。
已关闭 ±10% 缩放公差

指定工具在找到的图形和模型图形间是否允许 ±10% 的大小差异。

已训练的图形 | 已找到图形：+10% | 已找到图形：-10%
OFF（默认） | （失败） | （失败）
ON | （通过） | （通过）
已关闭 使用手动超时

定义是否应用超时设置

  • 关闭（默认）：禁用超时设置（无超时设置）。

  • 打开：启用超时设置。您可以使用编辑框手动定义以毫秒为单位的超时值（0 到 30000）。

    注意:将值设置为 0 将禁用该设置，且不会应用超时。
已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 名称

指定检测工具的名称。 默认名为 ““Pattern_1” （如果这是第一个添加到该作业的图形工具，之后的名称将依次顺延，例如 “Pattern_2”,、“Pattern_3” 等）。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 已启用

定义检测工具何时运行，或是否运行（默认设置为“开”）。

  • 如果你想要禁用该工具，请选择“关”。
  • 如果希望将该工具与特定的离散输入线路连接，请选择一条输入线，这时该工具可被“开启”或“关闭”（高电平信号 (1) 为“开”，低电平信号 (0) 为“关”）。将该工具与一个输入线路连接允许控制系统（如 PLC）来指定哪些工具可以运行以及何时运行。
已关闭 定位

为工具选择一个定位选项。当定位控制被启用时，定位按钮会变成橙色。

注意:只有在已经添加了用于定位的另一个工具时才能启用此控制。
已关闭 训练输入

定义是否训练输入线上的模型模式（默认设置为“关”，禁用）。

  • 输入：在输入线上训练模型图形。选定的输入线路将被用作训练信号。

    注意:
    • 当 In-Sight 视觉系统没有离散输入时（例如使用直接 I / O 的 In-Sight 8000 系列视觉系统），此选项不会显示。
    • 所选输入线的信号类型必须在输入/输出应用步骤中设置为事件触发。
    • 模型图形的训练将使用由视觉系统/传感器采集的最新图像。不需要为了训练重新触发视觉系统/传感器。
    • 有关详情，请参阅 输入：在输入线上训练模型图形
已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

已关闭 模型区域

该图像是一个模型图形的小图像。按模型区域按钮可调整模型区域的大小或移动该区域，然后按训练按钮重新训练模型图形。


图形与图形 (1-10) 定位工具–常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Pattern_1”（如果该工具是添加到作业的第一个图形工具，之后名称将递增，如“Pattern_2”、“Pattern_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


图形与图形 (1-10) 定位工具 – 设置选项卡

已关闭 训练输入

定义是否训练输入线上的模型模式（默认设置为“关”，禁用）。

  • 输入：在输入线上训练模型图形。选定的输入线路将被用作训练信号。

    注意:
    • 当 In-Sight 视觉系统没有离散输入时（例如使用直接 I / O 的 In-Sight 8000 系列视觉系统），此选项不会显示。
    • 所选输入线的信号类型必须在输入/输出应用步骤中设置为事件触发。
    • 模型图形的训练将使用由视觉系统/传感器采集的最新图像。不需要为了训练重新触发视觉系统/传感器。
    • 有关详情，请参阅 输入：在输入线上训练模型图形
已关闭 要查找的数目

定义要检测的模型图形的实例数量（0-10；默认值 = 1）。虽然多数应用程序只需要一个定位特征，但可以定位多个模型图形对在图像中有多个部件或对象的应用程序很有用。要求工具识别的训练实例越多，该工具的执行时间就越长。

已关闭 合格阈值

定义模型图形与所找到图形之间必须存在的相似程度（0-100；默认值 = 50）。大于或等于设置值的所发现图形视为匹配。设置值越高，该工具的执行速度越快，这也需要模型与所找到图形之间具有更大的相似度。设置的值较低会得到更多精确度较低的相似结果，如检测到与模型图形相似但不是模型图形本身的图形。

已关闭 旋转公差

定义找到的图形可从“模型”图形位置处旋转而仍被识别为有效图形的最大角度（± 0-180°；默认值 =15°）。允许较大的图形旋转偏差范围会增加该工具的执行时间。

已关闭 缩放公差

指定工具在找到的图形和模型图形间所允许的缩放比例（±10% 的尺寸变化）。默认情况下，此设置为关闭（未选中），该设置将禁用缩放比例调整。在这种操作模式下，工具仍然可以找到在 ±10％ 范围内的图形，但是特征的得分会随着变化比例的增加而降低。

已关闭 按...排序

定义如何对已找到的模型排序：按照分数（默认）排序、或按照 X 或 Y 排序。当选择分数时，找到的模型将根据各自的得分进行排序。模型得分最高的排在第一，之后的模型按分数以降序排列。当选择 X 时，找到的模型将根据其与 X 轴的距离进行排序。从最近到最远，按降序排列。当选择 Y 时，找到的模型将根据其与 Y 轴的距离进行排序。从最近到最远，按降序排列。

已关闭 水平偏移

定义距离所找到图形中心相对于已训练模型的水平偏移位置（以像素为单位）。该设置允许你使用远离模型图形中心的坐标，这对指定视觉引导机器人应用的拾取点非常有用。

已关闭 垂直偏移

定义距离所找到图形中心相对于已训练模型的垂直偏移位置（以像素为单位）。该设置允许你使用远离模型图形中心的坐标，这对指定视觉引导机器人应用的拾取点非常有用。

已关闭 模型类型

定义工具如何构造模型图形；区域模型或边模型（默认）。区域模型根据模型区域中一致的灰度值采样来创建模型图形。边模型根据在“模型”区域内检测到的图形特征的边（明/暗转换）来创建模型图形。

已关闭 精确度

定义工具将如何在准确性/可靠性和执行速度之间取得平衡；准确, 中度(默认)以及快速。准确表明读取结果含有很高的准确性/可靠性，可是读取速度会比较慢；快速表明读取的准确性/可靠性会比较低可是读取速度比较快；中度则表明在准确性/可靠性和速度中间取一个平衡值。

已关闭 超时

定义以毫秒为单位的时间量（0 到 30,000），工具搜索图形超过此时间量后将停止执行并返回“失败”。

已关闭 结果

显示所找到图形的中心的 X、Y 坐标及其角度方向，以及该图形相对于模型图形的得分。如果使用了水平和/或垂直偏移，则 X、Y 坐标将根据在偏移设置中指定的值进行调整。

注意:如果要查找的数量参数设置为大于 1，则显示的结果将始终为所找到的得分最高的图形，除非已将排序方式参数设置为 X 或 Y。
注意:图形定位工具不包含要查找的数量 或排序方式参数。


图形 (1-10) 定位工具 – 表格选项卡

表格选项卡中创建的表发布了所找到图形的结果：

已关闭 索引

表示所找到图形的顺序；1 至 10（EasyBuilder 中的数字排序基于 0=1）。

已关闭 X

表示所找到图形的 X 坐标的中心。

已关闭 Y

表示所找到图形的 Y 坐标的中心。

已关闭 角度

表示所找到图形相对于“模型”图形的角度。

已关闭 得分

表示所找到图形与“模型”图形的相似程度。


单个图形与多个图形 (1-10) 定位工具 – 训练选项卡

训练图像选项卡中显示的图像是模型图形的缩略图。按模型区域按钮可调整模型区域的大小或移动该区域，然后按训练按钮重新训练模型图形。


定位工具 - 边缘

边定位工具用于定位符合指定参数的线形边特征。

边位置工具是较快的工具之一，其识别边特征的速度比图案定位工具快得多。 当边特征具有高对比度、仅在一个方向上运动（水平方向或垂直方向）且旋转不超过 10° 时，此工具也可用作其它视觉工具的定位器。

该工具将报告以下结果：

In-Sight 型号 | 结果
In-Sight 2000 系列 1XX 视觉传感器 (110, 120, 130) | 仅限通过/失败状态
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 所找到边缘中点的 X，Y 坐标*、角度方向以及通过/失败状态。
*该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置边定位工具

添加该工具之后，需要定义将用作定位特征的边特征：

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 从可用特征中选择一个边（只需单击该边即可，这时其颜色将变为洋红色）。

  3. 按确定按钮来确认该选择（按取消按钮不将该工具添加到作业）。EasyBuilder 会围绕已选的边特征自动创建一个边区域，并插入 [image] 图标以指示所找到边的位置和方向。

    注意:如有必要，可旋转或重新调整检测边周围的区域。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整边定位工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

边位置工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 图形
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

图形


边缘定位工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Edge_1”（如果该工具是添加到作业的第一个边缘工具，之后名称将递增，如“Edge_2”、“Edge_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


边缘定位工具 - 设置选项卡

已关闭 边缘对比

指定找到的边的最小可接受边对比度分数（1-100；默认=“智能设置”，在检测到边缘之前自动递减）。该设置决定了工具的边缘检测灵敏度，即区分特征和背景的能力；将此设置与工具的 图形 结合使用来设置可接受的范围。

注意:如果该参数设置为0，则工具可能会找出未预计到的边。
已关闭 标准化得分

定义是否通过该区域的灰度直方图来标准化边缘分数。此参数对于查找低对比度区域中的边缘非常有用。如果要检测的边缘仅为高对比度，请禁用此参数。

  • 选中（默认）：标准化得分。
  • 未选中：不要将分数标准化。
已关闭 边缘过渡

定义边缘的过渡（从暗到亮、从亮到暗或两者；默认=两者）。该区域上的 扫描方向箭头 表示 EasyBuilder 将扫描边缘的方向；为了提高准确性和速度，请指定过渡类型。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 50；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 查找依据

定义如果存在多个边缘时工具如何区分找到的边缘（默认 = 最佳分数）。

  • 最佳得分 = 具有最佳定义边缘（最高对比度）的边缘特征。
  • 第一边 = 最靠近区域扫描方向开始的边缘特征。
  • 最后的边 = 距离区域扫描方向开始最远的边缘特征。
已关闭 角度范围

定义找到的边所允许的最大角度变化范围（0-10°；默认值= 10°）。允许角度偏差越高，工具执行所需的时间越长。

已关闭 结果

显示找到的边的中点的 X/Y 坐标，以及找到的边的角度方向。


边缘定位工具 - 图形

图形是区域中所包含灰度值的一阶导数的表示；波峰和波谷表示主要边转换。

对于检测边的工具（“边”和“圆”工具），得分轴表示所发现边与已定义参数的符合程度：

  • 正得分表示由深到浅的边转换；
  • 负得分表示由浅到深的边转换；
  • 得分为 0 表示未检测到边。

偏移轴指示定义边特性的区域，其中 0 代表区域的开始边界，而其它值代表区域的最大宽度（以像素为单位）。沿偏移轴的波峰或波谷的顶点指示所发现边的位置。

注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


定位工具 - 边缘交叉

边缘交叉定位工具可以被用来确定两条边特征交叉点的位置。

该工具将报告以下结果：

In-Sight 型号 | 结果
In-Sight 2000 系列 1XX 视觉传感器 (110, 120, 130) | 仅限通过/失败状态
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 交点的 X，Y坐标*、两边之间的二等分角以及通过/失败状态。
*该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置边缘交叉定位工具

添加该工具之后，需要定义将相交的边特征：

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 首先，从可用特征中选择一个特征（只需单击该特征即可，这时其颜色将变为洋红，且该特征中会延伸出一条直线）。
  3. 接着，选择将相交的边特征。
  4. 在选择第二个特征之后，EasyBuilder 将自动确定直线的交点，并插入 [image] 图标以指示所发现点的位置和方向。EasyBuilder 还将为先前未定义的所有边特征自动插入边存在/不存在工具。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整边缘交点定位工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

边缘交点定位工具的设置窗格包含以下内容：

已关闭 “常规”选项卡
已关闭 工具名称

定义检查工具的名称，在配置结果（输入、输出和通信）时会利用该名称。默认名称为“Intersect_1”（如果该工具是添加到作业的第一个“边缘交点位置”工具或“圆与直线的交点”几何工具或“直线交点”几何工具，之后名称将递增，如“Intersect_2”、“Intersect_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。


定位工具 - 斑点与斑点 (1-10)

斑点定位工具和斑点（1-10）定位工具用来定位在指定参数范围内的斑点特征。 该工具会报告找到的斑点的中心的 X，Y 坐标，以及斑点中心的角度。 斑点工具用于定位单个斑点，而斑点（1-10）工具用于定位最多 10 个符合检测标准的斑点。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

斑点和斑点（1-10）定位工具的性能介于边/圆工具和图形工具之间，能够比图形定位工具更快地定位斑点特征，但通常需要比边或圆工具更长的执行时间。 例如，当您尝试将检测锚定到无法分类的形状（例如白色背景上的黑色油漆斑点）或形状更改超出图形工具的限制时，这些工具可以为其他视觉工具提供特征定位。

设置工具

调整工具参数


设置一个斑点与多个斑点 (1-10) 定位工具

选择工具后，需要选择区域类型，然后在您希望在其中检测斑点特征的图像中配置它：

  1. 从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。定位和配置 blob 预计会出现的区域。为了提高该工具的性能，请创建较小的区域；区域越大，执行检查所需的时间越长。在选择 Blob 作为定位特征时，请选择在每个图像中都会在大致相同的位置出现的 Blob。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 区域被接受之后，斑点质心上将插入一个 [image] 图标，指示所找到特征的位置和方向。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整斑点与斑点 (1-10)定位工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

斑点位置工具和斑点（1-10）位置工具的设置栏由以下选项卡组成：

  • 常规选项卡
  • 设置选项卡
  • 表格选项卡
  • 直方图选项卡
  • 组合区域选项卡
注意:表格选项卡仅适用于斑点（1-10）位置工具。
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

表

复合区域选项卡

直方图


斑点与斑点 (1-10) 定位工具– 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Blob_1”（如果该工具是添加到作业的第一个斑点工具，之后名称将递增，如“Blob_2”、“Blob_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


“斑点”与“斑点 (1-10)”位置工具 -“设置”选项卡

已关闭 阈值模式

定义用于从背景中分离斑点的灰度值的模式。当选择“自动”（默认值 = 自动）时，每次采集图像工具均会针对不同图像间的亮度变化进行调整。当选择“手动”时，需要手动输入和调整该值。

已关闭 斑点阈值

定义用于从背景中分离斑点的灰度值（启用时为 0 - 255）。默认情况下此控制为“关”，要启用该控制，需要将“阈值模式”设置为“手动”。使用直方图设置应用程序的最佳值。

已关闭 斑点颜色

定义斑点的颜色（黑色、白色、黑色或白色；默认=黑色或白色）。

  • 黑色或白色 = 对斑点颜色没有要求
  • 黑色 = 只返回斑点阈值以下的斑点。
  • 白色 = 只返回斑点阈值以上的斑点。
已关闭 边界

定义如何处理与斑点区域边界相交的斑点（默认=关，未选中）

  • 未选中 - 不包括与区域边界相交的斑点；斑点必须完全位于要检查的区域内部。
  • 选中 - 包括与区域边界相交的斑点；只要斑点符合其它条件，就会被检测到。
已关闭 最小区域

以像素数为单位（0 到 16777216；默认值 = 100）为所有检测的斑点定义最小面积限制；将只识别面积大于“最小面积”的斑点。

已关闭 最大区域

以像素数为单位（0 到 16777216；默认值 = 100000）为所有检测的斑点定义最大面积限制；将只识别面积小于“最大面积”的斑点。

已关闭 忽略角度

定义是否考虑斑点质心的角度方向（默认值 = 开，选中）。

注意:斑点通常会提供有限的角度方向值，因此默认情况下此参数为“开”。
已关闭 要查找的数量

定义应检测到的斑点数量（1-10；默认 = 1）。多数应用程序只需要单个定位特征，但可以定位多个斑点，这在图像中有多个部件或对象的应用程序中很有用。要求工具识别的斑点越多，该工具的执行时间越长。

已关闭 排序方式

定义工具将如何测量和排序所找到的斑点（面积、行、列；网格：行，然后列，相对定位特征；网格：列，然后行，相对定位特征；相对定位特征的距离；相对固定行轴逆时针旋转的角度；角距离。默认 = 区域）：

  • 面积 = 按所找到斑点的面积从最大到最小排序。
  • 行 = 按与图像行轴之间的距离从最近到最远降序排列。
  • 列 = 按与图像列轴之间的距离从最近到最远降序排列。
  • 网格：行，然后列，相对定位特征 = 首先按相对定位特征的图像行轴的距离，然后按相对图像列轴的距离，从最近到最远降序排列。
  • 网格：列，然后行，相对定位特征 = 首先按相对定位特征的图像列轴的距离，然后按相对图像行轴的距离，从最近到最远降序排列。
  • 相对定位特征的距离 = 按定位特征与斑点质心之间的距离从最近到最远降序排列。
  • 相对固定行轴逆时针旋转的角度 = 按所测量的从定位特征的图像行轴到线段（由斑点质心和定位特征定义）之间的角度（0 到 360°），从最近到最远降序排列。
  • 角距离 = 按所测量的从定位特征的图像行轴到线段（由斑点质心和定位特征定义）之间的角度（-180° 到 180°）的绝对值，从最近到最远排序。
已关闭 结果

显示所发现斑点质心的 X、Y 坐标和角度（始终报告为 90°，除非禁用了忽略角度复选框），及其得分。

注意:如果要查找的数量参数设置为大于 1，则显示的结果将始终为所找到的得分最高的图形，除非已将排序方式参数设置为 X 或 Y。
注意:斑点位置工具不包含要查找的数量参数。


斑点 (1-10) 定位工具 - 表格

注意:
  • 斑点定位工具不支持表选项卡，该选项卡只能用于斑点 (1-10) 定位工具。
  • 当 排序方式参数被设置为除 区域以外的任何选项时，像素行 和 像素列 栏将被添加到表格中。像素行 和 像素列 指的是以 In-Sight 视觉系统图像传感器（行和列数组）二维网格为基础的图像坐标。该坐标 (Y/X) 与现实世界中的坐标 (X/Y)相反。

  • 如果在设置图像步骤的根据实际单位校准图像组框中启用（选中）了典型方向，则 X 和 Y 坐标将与图像坐标 (Y/X) 位于同一坐标空间。

表格选项卡根据设置选项卡中的要查找的数量参数发布所找到斑点的结果：

已关闭 索引

表示所找到斑点的顺序。基于“设置”选项卡中的排序方式参数，1 至 10（EasyBuilder 中的数字排序基于 0=1）。

已关闭 X

返回所找到斑点的质心的 X 坐标。除非已在设置图像中将图像校准为实际单位，否则工具将以像素为单位报告结果。

已关闭 Y

返回所找到斑点的质心的 Y 坐标。除非已在设置图像中将图像校准为实际单位，否则工具将以像素为单位报告结果。

已关闭 角度

返回所找到斑点的质心相对于区域中心的角度。

已关闭 面积

返回所找到斑点的面积（以像素为单位测量）。

已关闭 像素行

返回所找到斑点的质心的图像行 (X) 坐标。

已关闭 像素列

返回所找到斑点的质心的图像列 (Y) 坐标。


斑点与斑点 (1-10)定位工具–复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


斑点与斑点 (1-10)定位工具 - 直方图

直方图以图形方式显示区域内像素的灰度值。

  • 图形的 X 轴表示灰度值的总数（0 到 255，或总计 256 个灰度级）。
  • 图形的 Y 轴表示给定灰度值的像素数，通过显示具有最大像素数的灰度值建立标度。
  • 蓝色的垂直线指示用于将图像区域区分为黑色和白色像素的阈值；线左侧的值被视为黑色，而线右侧的值被视为白色。
注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


定位工具 -彩色斑点与彩色斑点 (1-10)

彩色斑点和彩色斑点（1-10）定位工具用来定位在指定参数范围内的彩色斑点特征。 该工具会报告找到的斑点的中心的 X，Y 坐标，以及斑点中心的角度。 彩色斑点工具用于定位单个斑点，而彩色斑点（1-10）工具则用于定位最多 10 个符合检测标准的斑点。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

彩色斑点和彩色斑点（1-10）工具引用经过训练的颜色模型库，然后确定区域中与训练库中选定和训练的颜色模型匹配的像素数。 该工具随后会创建一个二进制灰度输出图像，其中与活动颜色模型匹配的每个像素均设置为白色 (255)，而其它所有像素均设置为黑色 (0)。 使用此二进制输出图像，该工具然后在图像中搜索由活跃颜色模型创建的斑点特征。

设置工具

调整工具参数


设置彩色斑点与彩色斑点 (1-10) 定位工具

选择工具后，需要选择区域类型，然后在您希望在其中检测斑点特征的图像中配置它：

  1. 从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。定位和配置 blob 预计会出现的区域。为了提高该工具的性能，请创建较小的区域；区域越大，执行检查所需的时间越长。在选择 Blob 作为定位特征时，请选择在每个图像中都会在大致相同的位置出现的 Blob。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 配置搜索区域后，需要配置该工具的颜色库并激活相应的颜色模型：

    • 如果这是首次添加颜色工具（“彩色斑点”与“彩色斑点 (1-10)”定位工具、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”与“彩色斑点面积 (1-10)”测量工具、“彩色斑点”计数工具、“颜色模型”识别工具或“颜色转为二进制”图像过滤工具），需要首先定义颜色库及其颜色模型。

    • 如果先前已添加另一个颜色工具，并且想要利用现有颜色库及其训练的颜色模型，请转到“设置”选项卡并选择所需的颜色库，然后在“库”选项卡中选中所需颜色模型以将其激活。

    • 默认情况下，工具将自动产生“失败”，直至定义颜色库。如果已定义颜色库，则工具将自动使用该库并激活其包含的所有颜色模型。

  4. 设置颜色模型和颜色库后，该工具将处理图像，搜索区域内与所选颜色模型匹配的所有像素都会变为白色 (255)，而与颜色模型不匹配的像素则会变为黑色 (0)。

  5. 区域被接受之后，斑点质心上将插入一个 [image] 图标，指示所找到特征的位置和方向。

  6. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  7. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整彩色斑点与彩色斑点 (1-10) 定位工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

彩色斑点和彩色斑点 (1-10) 定位工具的设置窗格包含以下选项卡：

  • 常规选项卡
  • 设置选项卡
  • 颜色库选项卡
  • 表格选项卡
  • 组合区域选项卡
注意:仅对彩色斑点 (1-10) 定位工具启用表格选项卡。
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

复合区域选项卡

表格选项卡

库


彩色斑点定位工具 -常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“ColorBlob_1”（如果该工具是添加到作业的第一个彩色斑点工具，之后名称将递增，如“ColorBlob_2”、“ColorBlob_3”等等）。可以通过给一个与特定应用程序相关联的名字来自定义你的工具。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


“颜色斑点”与“颜色斑点 (1-10)”定位工具 -“设置”选项卡

已关闭 训练颜色

启动“ExtractColor 训练”对话框，用于定义所选颜色库的颜色模型。

已关闭 颜色库

定义工具将引用的颜色库。从下拉列表中，选择要修改的颜色库，然后按训练颜色按钮启动“ExtractColor 训练”对话框。每个颜色库最多可包含 100 种不同的由各个颜色组成的颜色模型。

EasyBuilder 作业最多可包含 5 个颜色库，可在下列工具之间共享颜色库：

  • 彩色斑点定位工具
  • 彩色斑点 (1-10) 定位工具
  • 颜色像素计数存在/不存在工具
  • 彩色斑点面积测量工具
  • 彩色斑点面积 (1-10) 测量工具
  • 彩色斑点计数工具
  • 颜色模型识别工具
  • 颜色转为二进制图像过滤工具
已关闭 边界

定义如何处理与斑点区域边界相交的斑点（默认=关，未选中）

  • 未选中 - 不包括与区域边界相交的斑点；斑点必须完全位于要检查的区域内部。
  • 选中 - 包括与区域边界相交的斑点；只要斑点符合其它条件，就会被检测到。
已关闭 最小区域

以像素数为单位（0 到 16777216；默认值 = 100）为所有检测的斑点定义最小面积限制；将只识别面积大于“最小面积”的斑点。

已关闭 最大区域

以像素数为单位（0 到 16777216；默认值 = 100000）为所有检测的斑点定义最大面积限制；将只识别面积小于“最大面积”的斑点。

已关闭 忽略角度

定义是否考虑斑点质心的角度方向（默认值 = 开，选中）。

注意:斑点通常会提供有限的角度方向值，因此默认情况下此参数为“开”。
已关闭 要查找的数量

定义应检测的颜色斑点数量（1-10；默认 = 1）。多数应用程序只需要单个固定原点，但可以定位多个斑点，这在图像中有多个部件或对象的应用程序中很有用。要求工具识别的斑点越多，该工具的执行时间越长。

注意:此控件仅对颜色斑点 (1-10) 位置工具可用。
已关闭 排序方式

定义工具将如何测量和排序所找到的斑点（面积、行、列；网格：行，然后列，相对定位特征；网格：列，然后行，相对定位特征；相对定位特征的距离；相对固定行轴逆时针旋转的角度；角距离。默认 = 区域）：

  • 面积 = 按所找到斑点的面积从最大到最小排序。
  • 行 = 按与图像行轴之间的距离从最近到最远降序排列。
  • 列 = 按与图像列轴之间的距离从最近到最远降序排列。
  • 网格：行，然后列，相对定位特征 = 首先按相对定位特征的图像行轴的距离，然后按相对图像列轴的距离，从最近到最远降序排列。
  • 网格：列，然后行，相对定位特征 = 首先按相对定位特征的图像列轴的距离，然后按相对图像行轴的距离，从最近到最远降序排列。
  • 相对定位特征的距离 = 按定位特征与斑点质心之间的距离从最近到最远降序排列。
  • 相对固定行轴逆时针旋转的角度 = 按所测量的从定位特征的图像行轴到线段（由斑点质心和定位特征定义）之间的角度（0 到 360°），从最近到最远降序排列。
  • 角距离 = 按所测量的从定位特征的图像行轴到线段（由斑点质心和定位特征定义）之间的角度（-180° 到 180°）的绝对值，从最近到最远排序。
已关闭 平滑因子

定义平滑图像的平滑值 (0 至 25; 默认 = 1)。如不需要平滑图像，则可将该值设置为 0。

已关闭 显示原始图像
  • 取消选中（默认）：所选区域显示二进制灰度输出图像。
  • 已选中：所选区域显示原始输入图像。
已关闭 结果

显示所发现斑点质心的 X、Y 坐标和角度（始终报告为 90°，除非禁用了忽略角度复选框），及其得分。


彩色斑点与彩色斑点 (1-10)定位工具–复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


彩色斑点 (1-10) 定位工具 - 表格选项卡

注意:
  • 彩色斑点定位工具不支持表选项卡，该选项卡只能用于彩色斑点 (1-10) 定位工具。
  • 当 排序方式参数被设置为除 区域以外的任何选项时，像素行 和 像素列 栏将被添加到表格中。像素行 和 像素列 指的是以 In-Sight 视觉系统图像传感器（行和列数组）二维网格为基础的图像坐标。该坐标 (Y/X) 与现实世界中的坐标 (X/Y)相反。

  • 如果在设置图像步骤的根据实际单位校准图像组框中启用（选中）了典型方向，则 X 和 Y 坐标将与图像坐标 (Y/X) 位于同一坐标空间。

表格选项卡根据设置选项卡中的要查找的数量参数发布所找到斑点的结果：

已关闭 索引

表示所找到斑点的顺序。基于“设置”选项卡中的排序方式参数，1 至 10（EasyBuilder 中的数字排序基于 0=1）。

已关闭 X

返回所找到斑点的质心的 X 坐标。除非已在设置图像中将图像校准为实际单位，否则工具将以像素为单位报告结果。

已关闭 Y

返回所找到斑点的质心的 Y 坐标。除非已在设置图像中将图像校准为实际单位，否则工具将以像素为单位报告结果。

已关闭 角度

返回所找到斑点的质心相对于区域中心的角度。

已关闭 面积

返回所找到斑点的面积（以像素为单位测量）。

已关闭 像素行

返回所找到斑点的质心的图像行 (X) 坐标。

已关闭 像素列

返回所找到斑点的质心的图像列 (Y) 坐标。


彩色斑点与彩色斑点 (1-10) 定位工具 - 库

已关闭 颜色模型列表

显示所选颜色库中包含的颜色模型的只读列表。通过选中或取消选中颜色模型名称旁边的复选框来激活或禁用颜色模型。

已关闭 颜色表

显示所选颜色模型中颜色的只读排序表。

已关闭 颜色名称

显示所选颜色模型中颜色的名称。

已关闭 RGB

显示所选颜色模型中颜色的 RGB 值。

已关闭 运算

显示所选颜色模型中颜色的运算（加或减）。


位置工具 - 圆

圆定位工具用于定位符合指定参数的圆特征。

圆位置工具是较快的工具之一，其识别边缘特征的速度比图案位置工具快得多。 在检查圆形对象或者不旋转的部件或对象时，这些工具也可用作其它视觉工具的定位。

该工具将报告以下结果：

In-Sight 型号 | 结果
In-Sight 2000 系列 1XX 视觉传感器 (110, 120, 130) | 仅限通过/失败状态
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 找到的圆的 X，Y 坐标（其中心）、直径* 以及通过/失败状态。
* 该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置圆定位工具

添加该工具之后，需要在图像中配置将定义圆形边的区域：

  1. 将圆形区域置于圆形边的特征之上，确保调整圆形区域的大小以匹配圆形特征的大小和尺寸。选择一个圆作为定位特征时，要确保它在每个图像中出现在大致相同的位置，并在亮像素和暗像素之间具有高对比度。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. EasyBuilder 会围绕该圆形边特征自动创建圆环边区域，并插入 [image] 图标以指示所发现圆的位置和角度方向。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整圆定位工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

圆定位工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 图形
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

图形


圆定位工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Circle_1”（如果该工具是添加到作业的第一个圆工具，之后名称将递增，如“Circle_2”、“Circle_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


圆定位工具 - 设置选项卡

已关闭 边缘对比

定义发现的圆形边缘所容许的最小边缘对比度得分（1-100；默认值为“智能设置”，该值会自动递减，直至检测到圆形边缘）。该设置决定了工具的边缘检测灵敏度，即区分特征和背景的能力；将此设置与工具的 图形 结合使用来设置可接受的范围。

注意:如果该参数设置为0，则工具可能会找出未预计到的边。
已关闭 标准化得分

定义是否通过该区域的灰度直方图来标准化边缘分数。此参数对于查找低对比度区域中的边缘非常有用。如果要检测的边缘仅为高对比度，请禁用此参数。

  • 选中（默认）：标准化得分。
  • 未选中：不要将分数标准化。
已关闭 边缘过渡

定义边缘的过渡（从暗到亮、从亮到暗或两者；默认=两者）。环状 区域 扫描从内环区域到外环区域的边缘过渡；为了提高准确性和速度，请指定过渡类型。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 50；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 查找依据

定义存在多个圆形边时，该工具如何区别找到的圆形边（默认值 = 最佳得分）。

  • 最佳得分 = 将选择具有最佳定义边（最高对比度和亮度）的圆形边特性。
  • 最小圆 = 将选择具有最小直径的圆形边特性。
  • 最大圆 = 将选择具有最大直径的圆形边特征。
已关闭 结果

显示找到的圆的 X，Y 坐标（从其中心报告）和直径。


圆定位工具 - 图形

图形是区域中所包含灰度值的一阶导数的表示；波峰和波谷表示主要边转换。

对于检测边的工具（“边”和“圆”工具），得分轴表示所发现边与已定义参数的符合程度：

  • 正得分表示由深到浅的边转换；
  • 负得分表示由浅到深的边转换；
  • 得分为 0 表示未检测到边。

偏移轴指示定义边特性的区域，其中 0 代表区域的开始边界，而其它值代表区域的最大宽度（以像素为单位）。沿偏移轴的波峰或波谷的顶点指示所发现边的位置。

注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


定位工具 - 计算定位特征

计算定位特征工具可用于根据与其他定位和/或检测工具输出的相关数学表达式来计算定位特征位置。 该工具会报告计算定位特征的 X、Y 坐标和角度。

注意:
    该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。
  • 如果该工具与网格校准结合使用，如果校准中的角度值发生变化，则可能会生成不准确的结果。 在这些情况下，可以使用边到边、圆形或一个导入的校准。

如果您想利用定位和/或检测工具生成的特定点、线或角度数据来计算定位特征，则计算定位特征工具将非常有用; 例如，如果您想基于两条边，它们的交点和产生的二分角来构造一个定位特征。 在这种情况下，可以使用两个边存在/不存在工具来定义边缘，并使用对分角几何工具来定义 X、Y和角度值。 然后，计算定位特征工具会使用对分角几何工具输出的数据作为 X（Bisect_1.Point.X）、Y（Bisect_1.Point.Y）和 Angle（Bisect_1.Angle）表达式的输入。

设置工具

调整工具参数


设置计算定位特征工具

添加了工具之后，您需要构建 X、Y 和角度值的表达式。

注意:此工具需要使用其它位置和/或检测工具作为输入。在添加此工具之前，请组建将用作此工具输入的其它位置和/或检测工具，否则，将无法构造表达式，并且必须添加必需的位置和/或检测工具，然后在配置完其它工具后返回到该工具。
  1. 通过从设置窗格左侧选择并输入数学函数，和/或从右侧选择并输入值（工具和作业数据）来构建每个表达式。如要在表达式公式编辑器中输入一个函数或值，选择函数或值，然后按 Enter 键，双击函数或值或按 Insert（插入）按钮。
  2. 构建了所有三个表达式之后，工具将在图像中插入一个 [image] 图标，指示计算得出的定位特征的位置和方向。
  3. 在初始配置该工具的情况下，根据需要加载几个图像并调整工具参数，以补偿预期的变化范围。
  4. 最后，如需要，可以使用工具的输入/输出属性表以在其他工具和/或其他外部设备之间共享工具数据。


调整计算定位特征定位工具的参数

在将工具添加到作业之后，即可开始针对应用程序自定义和微调工具。

计算定位特征定位工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • X、Y和角度选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

X、Y 和角度选项卡


计算定位特征定位工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Fixture_1”（如果该工具是添加到作业中的第一个计算定位特征工具，之后名称将递增，如“Fixture_2”、“Fixture_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


计算定位特征定位工具 - 设置选项卡

已关闭 结果

显示计算出的 X、Y 和角度值。

已关闭 颜色

指定计算的定位特征位置的颜色：默认（=绿色）、深红色、深绿色、深黄色、深蓝色、深红色、深蓝色、红色、绿色、黄色、蓝色、洋红色、青色、深灰色、灰色、黑色或白色。


计算定位特征定位工具 - X、Y 和角度选项卡

X、Y 和角度选项卡用于建立数学公式，以定义定位特征的 X、Y 和角度坐标。

注意:当 In-Sight 视觉系统处于联机状态时会禁用这些控制。
已关闭 表达式

表达式文本框用于构造处理工具结果和数据的数学公式。可通过使用键盘键入数学函数的名称或作业/工具数据来输入数据，也可以利用左侧的视觉工具树、数学树、文本树和/或视觉数据访问树以及右侧的作业和工具数据符号树组合公式。可以通过双击项目输入项目，也可以通过突出显示项目并按插入按钮输入项目。

注意:
  • 如果表达式引用已删除的工具，则在公式中，该引用将自动替换为“Job.MissingArg”。该工具将返回“失败”，直到更正该引用。
  • 当生成表达式时，EasyBuilder 不能正确地分析开头的单元格地址（如 A3_MyTool 或 P10_SortTool）。如果表达式需要为这些工具配置，请在创建公式前重新命名这些工具。
已关闭 视觉工具

视觉工具树包含可用于构造表达式的附加边函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开边树，选择所需函数，然后按插入按钮。
  • 展开边树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 数学函数树

数学函数树包含可用于构造表达式的数学函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开数学树，选择所需函数，然后按插入按钮。
  • 展开数学树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 文本函数树

文本函数树中包含的函数用于设置字母数字数据的格式以进行显示和通信，并可用于构造表达式。可通过以下三种方法之一将函数添加到表达式：

  • 展开文本树，选择所需函数，然后按插入按钮。
  • 展开文本树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 视觉数据访问

视觉数据访问树包含可用于构造表达式的>附加数据（默认不可用）。可通过以下三种方法之一将函数添加到表达式：

  • 展开视觉数据访问树，选择所需函数，然后按插入按钮。
  • 展开视觉数据访问树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:
  • 可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
  • EasyBuilder 仅支持斑点、边和图形视觉数据访问函数。
已关闭 作业和工具数据符号树

作业和工具数据符号树包含定位和/或检测工具输出的数据，以及输入行和作业数据（如图像采集参数）。作业和工具数据是对其所含值的符号引用。符号可以通过以下三种方式中的一种被添加到表达式中：

  • 展开树型结构，选择所需符号引用，然后按插入按钮。
  • 展开树型结构，然后双击所需符号引用。
  • 使用键盘直接在表达式的文本框中输入所需符号的引用名称。
注意:可用符号列表取决光标在表达式中的位置。如果光标位于表达式中禁止添加符号的位置，则这些符号将不可用，直到光标位于可添加符号的位置。
已关闭 插入按钮

插入按钮用于将数学函数和符号放入表达式。选择所需数学函数或符号，然后按插入按钮将函数或符号添加到表达式。

注意:此控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用插入按钮。
已关闭 左括号、逗号、右括号按钮

左括号、逗号及右括号按钮用于构造数学公式。按相应按钮即可将这些符号添加到公式。

注意:这些控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用这些按钮。


在定位工具与检查工具之间创建链接

在定位工具和/或检查工具添加到作业之后，可使用选择板中的链接选项链接其属性（其输入参数和输出结果）。链接选项卡允许将工具的输出结果用作另一个工具的输入参数。

已关闭 使用链接选项卡

选择板中的链接选项卡以树状视图显示作业中当前加载的所有定位工具和/或检查工具。这些工具的属性（输入参数和输出结果）通过符号标记（属性中所含值的符号引用）来引用。其值具有相关的数据类型（操作、浮点数、整型或字符串）。

工具属性分为输入和输出属性，而链接只能采用从输出属性到输入属性的方式建立。输出属性可以链接到多个独立的输入属性，而输入属性只能接受一个与其链接的输出属性。

要选择显示的工具属性以及可在链接选项卡中配置的工具属性，请右键单击工具属性，打开选择属性对话框。选择属性对话框以树状视图列出作业中的所有工具，其中包括其所有相关的工具属性：输入和输出属性。您可以通过选择显示哪些工具属性（使用添加/删除按钮添加或删除多个选中的属性），自定义要在“链接”选项卡中显示的工具属性。

已关闭 链接选项卡控制
链接选项卡控制
打开作业中包含的所有工具属性。
选择作业中包含的所有工具属性。

按下可在三个工具属性显示选项之间切换：

  • 默认：只显示从“选择属性”菜单选择的工具属性。
  • 显示标准属性：显示更小子集的工具属性，Description、Include_In_Job_Pass、Error_Count、Execution_Time、Fail_Count、Pass_Count、Tool_Enabled_Status 和 Invert 属性会自动隐藏。
  • 显示所有属性：显示所有工具属性。

按下可在三个排序选项之间切换：

  • 默认：以工具加入作业的顺序显示它们，第一个加入的工具显示在列表的顶部。
  • 字母顺序：根据工具名称，以字母升序显示工具。
  • 相依性顺序：根据相依性显示工具，输入属性排在输出属性上方。
注意:
  • 如果删除链接到其它工具的工具，这些链接也会自动删除。
  • 如果在作业中复制并粘贴链接了输入和输出属性的工具，则只会保留输入属性。
已关闭 在工具之间创建链接

可在工具的输出属性与输入属性之间创建链接，方法如下：将输出属性节点拖到适当的输入属性节点，或者右键单击输入属性并从链接自上下文菜单选择适当的输出属性。

注意:使用拖放方式链接属性时，将会显示快捷方式图标，并且带箭头的深蓝色线附有光标。如果属性无法链接，光标将会显示中断图标。

绑定工具属性后，输入属性将呈灰色而不可用，且右边显示链接图标 [image] 。将光标停留在链接图标上将会显示指出链接来源的工具提示，右键单击链接图标则会打开上下文菜单以断开链接。

注意:要撤消创建的链接，请按 EasyBuilder 工具栏中的撤消按钮（或使用 CTRL+Z）。
已关闭 删除工具之间的链接

输入属性与输出属性之间的链接可通过以下方法删除：选择具有输入链接的属性，然后按 DELETE 键或从右键菜单中选择“断开链接”。

注意:要撤消链接删除操作，请按 EasyBuilder 工具栏中的“撤消”按钮（或使用 CTRL+Z）。
已关闭 示例
已关闭 链接读取 ID 代码识别工具与读取文本识别工具

读取文本识别工具用于验证读取 ID 代码识别工具返回的文本是否准确。读取文本工具使用预期的匹配字符串配置，且模式参数设置为验证。通过将读取 ID 代码工具的字符串输出结果链接到读取文本工具的 Match_String 输入参数，读取文本工具将会验证读取 ID 代码工具检测的代码是否包含正确的文本。


检测部件

检测部件步骤用于装配和配置在构建作业时将要使用的检测工具。 检查要检测的部件或对象，确定哪种类型的特征最适合您的应用要求，哪种检测工具最适合解决您的问题。 有关更多信息，请参阅特征。

注意:In-Sight 2000 系列视觉传感器不支持链接选项卡。

检测工具将返回以下结果：

In-Sight 型号 | 结果
In-Sight 2000-110 and 2000-120/120C 视觉传感器 | 仅限通过/失败状态
In-Sight 2000-130/130C 视觉传感器 | 测量和计数检测工具：标准结果（数字数据） 存在/不存在图形工具：通过/失败状态和图形分数 其它工具：仅限通过/失败状态
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 标准结果（无限制）

添加、删除和编辑“检测部件”工具

选择检测部件工具

创建定位和检测工具之间的链接


添加、删除和编辑检查部件工具

已关闭 添加工具

要向作业添加工具，请从添加工具组中选择合适的工具，然后按添加按钮，或者双击该工具。然后你会被提示指定图像中的特征。你可以通过 EasyBuilder 智能特征选项调整图像的区域图形来进行定义，也可以通过定位几何参考图形来进行定义。

最初的定义特征完成后，你可通过调整各项参数来精细调整工具的控制。

注意:你可以通过使用工具搜索框来动态搜索工具。
已关闭 删除工具

要从作业中删除工具，只需执行以下操作之一：

  • 在结果表（位于“选择板”的结果选项卡中）中选择该工具，然后按键盘的 Delete 键。
  • 在结果表（位于“选择板”的结果选项卡中）中选择该工具，然后按标准工具栏中的删除图标。
  • 在结果表（位于“选择板”的结果选项卡中）中右键单击该工具，然后选择菜单中的删除选项。
已关闭 编辑工具

要从 EasyBuilder 的任意步骤编辑工具，只需执行以下操作之一：

  • 在结果表（位于“选择板”的结果选项卡）中双击该工具。
  • 在结果 表中右键单击该工具，然后从菜单中选择转到此工具并编辑选项。

要在定位部件或检测部件步骤中编辑工具，只需执行以下操作之一：

  • 在图像中选择该工具的区域图形。
  • 在结果表（位于“选择板”的结果选项卡）中双击该工具。
  • 在结果 表中右键单击该工具，然后从菜单中选择转到此工具并编辑选项。
  • 在运行作业应用程序步骤中双击“结果表”中的工具。
注意:
  • 如果 In-Sight 视觉系统支持访问 In-Sight Explorer 的电子表格编程环境，则会出现右键单击菜单选项在电子表格中转到此工具的选项。建议您仅在熟悉电子表格编程环境并且了解其操作时，才访问此环境。在继续进行之前，请参阅 EasyBuilder 作业和电子表格 In-Sight Explorer 联机帮助文件主题。
  • 通过将工具拖拉到需要的顺序，可以在结果表格中重新排列工具。该操作可以在运行作业结果表格和选择板结果选项卡中进行。无论在哪个表格中进行的修改，结果将同时会在两张表格中更新。拖拉排序仅在表格的工具顺序和附属图形栏被选择的情况下才能启用(默认情况下，该栏会被选择)。如需颠倒顺序，重新选择该栏。如果作业大小已经接近作业的最大极限，则该功将不能使用。
注意:如作业中没有足够空间，无法添加更多工具，则退出定位或检查部件应用程序步骤，从传感器菜单中，选择作业大小限制。使用该对话框调整作业大小，使其能容纳更多工具。要调整 In-Sight 视觉系统的作业大小限制，需要给视觉系统重新加电，并将删除非易失性闪存中的所有作业和设置文件。请先保存或备份作业再继续。

特性

区域

EasyBuilder 智能选项


特征

在机器视觉中，特征是指“图像中的关注对象”，而视觉检查是围绕图像中发现的特征类型而设计的。

检查部件步骤中包括以下类型的特征：

已关闭 边缘

沿水平方向或垂直方向，或者呈圆周或圆弧形的亮像素和暗像素之间的转换区域。零件的末端、电路板上的针脚、螺丝上的螺纹、瓶子的底部或弹簧的簧圈等均属于边缘。通常情况下，此特征类型是最快且最容易检测到的。

已关闭 边缘示例

已关闭 圆、线和点

可用于计算测量的标准几何参照。

已关闭 圆、线和点示例

已关闭 图形

图形可以是任何事物，从一组简单的重复形状到徽标或标签之类的复杂图形均属于图形。图形是最可靠的特征类型，它允许最大范围的位置旋转、移动和缩放变化，但通常需要最长的检查时间。

已关闭 图形示例

已关闭 斑点

一组深色或浅色的连通像素，例如，黑色背景上的白色油漆污点，或白色传送带上的黑色螺丝。它也是进行查找的较快功能之一，并可考虑到斑点特征的形状和大小变化，但是对角度方向值有所限制。

已关闭 斑点示例

已关闭 文本

字母数字文本字符串。

已关闭 文本示例

已关闭 代码

一维条码和二维矩阵代码及包含字母数字数据字符串的符号。

已关闭 代码示例

已关闭 珠体

珠体是一对连续但不一定封闭的边缘，它定义在具有不同像素值的两个区域间存在的边界，由宽度值加以定义。例如，金属焊接轨迹、粘胶剂轨迹或密封剂轨迹都可被称为“珠体”轨迹。

已关闭 珠体示例


区域

区域定义定位工具或检查工具将要执行操作的图像区域，也称为“关注区”。

根据使用的工具类型，EasyBuilder 中有多种不同的区域类型供定位工具和检查工具使用。EasyBuilder 使用的区域类型如下：

  • 矩形
  • 圆形
  • 环形
  • 多边形
  • 已遮蔽的区域
  • 折线路径

环形区域

圆形区域

掩膜区域

多边形区域

折线路径区域

矩形区域


遮蔽区域

遮蔽区域用于定义将进行边缘分析的图像面积。这一区域与卡尺数组结合使用后可进行准确的边缘检测。

已关闭 遮蔽区域图例

 | 控制 | 说明
1 | 可调整大小的端点边界 (x4) | 定义矩形区域的四个角。单击某个端点边界可通过其一个角调整区域大小。
2 | 蒙板 | 定义“不”进行 图像分析的图像面积。蒙板可在区域内移动并调整大小。最多可以为一个区域添加 99 个蒙板。添加蒙板时，将添加到区域的起始位置（在没有添加其它蒙板的情况下），或者添加到前一个已添加蒙板的后面。 注意:蒙板不得重叠。如果配置时将其重叠，系统将自动插入一个单像素缓冲区，以防止蒙板重叠。
3 | 扫描方向指示器 (x2) | 定义在遮蔽区域内扫描特征的方向。
4 | 边缘检测指示器 | 定义区域内将用于检测边缘转换的面积；同时启用向区域添加新蒙板的功能。
5 | 旋转柄 | 允许将区域旋转 360°。
6 | 弯曲柄 | 允许将矩形区域弯曲为弧或环形。
已关闭 遮蔽区域鼠标操作

将鼠标光标放在区域的各个部分上，光标将会自动变换，允许执行以下操作：

鼠标图标 | 说明
 | 允许在图像内的任意位置拖动整个遮蔽区域。
 | 可以水平或垂直缩放整个区域；还用于调整蒙板的大小。
 | 允许进行两项不同的操作，取决于鼠标光标放置的位置。如果鼠标光标位于旋转柄，可以将区域从当前方向旋转 360°。如果鼠标光标位于弯曲柄，可以将区域调整为弧或圆环形状，以便检测圆形边缘特征。
 | 允许在区域内拖动蒙板。
 | 允许从区域中添加或删除蒙板。出现这个图标时，右键单击鼠标打开菜单，内含两个选项：添加蒙板或删除蒙板。


折线路径区域

折线路径区域是用来定义一个将进行边缘分析的图像区域。该区域用来与卡尺阵列结合来进行精确的边缘检测。

注意:
  • 在图形编辑中，有一个右击菜单，它允许你添加一个路径分段或删除一个路径分段。
  • EasyBuilder 工具栏里的区域最大化按钮在折线路径区域中被禁用。
已关闭 折线路径区域图例

 | 控制 | 说明
1 | 折线路径顶点(x3) | 定义折线片段路径。点击一个顶点来定位折线。
2 | 扫描方向指示器 (x2) | 定义折线路径区域扫描特征的方向。
3 | 折线路径 | 图形显示折线图。
4 | 旋转柄 | 允许将区域旋转 360°。
已关闭 折线路线区域鼠标操作

将鼠标光标放置在区域内的不同部件上，它会自动转换，激活以下操作：

鼠标图标 | 说明
 | 允许你在图像内任意拖动整个折线路径区域。
 | 允许你将整个区域水平或垂直缩放，也可用来调整遮蔽区域的大小。
 | 允许你在当前位置将区域旋转360°。
 | 允许你在区域内删除折线路径。
 | 允许你将一个新点添加到折线。最多可添加99个点到折线。如果已经添加了99个点到折线，则该功能会被禁用。


EasyBuilder 智能选项

EasyBuilder 的智能选项（智能特征、智能限制和智能设置）可根据工具和您应用程序的要求，通过自动确定智能的默认阈值来帮助您加速应用程序的部署。

注意:在 EasyBuilder 中开发应用程序时，通过使用您部件或对象中的合格图像，EasyBuilder 会为您的应用程序设置合适的默认阈值。
  • 智能特征
  • 智能限制
  • 智能设置

智能特征

智能限制

智能设置


智能特征

某些位置和检查工具会根据已选工具，从图像中自动提取相关特征，从而允许您在检查过程中使用指向并单击的方式来选择合适的特征。

将其中的某个工具添加到作业后，该工具会自动检查您的图像并确定哪些特征符合工具的要求。例如，“边位置”工具只返回水平或垂直的边特征，而圆直径和“圆同心度测量”工具只返回圆形特征。

已关闭 示例
已关闭 智能特征 - 边

已关闭 智能特征 - 圆

如果某特征之前尚未定义，则以淡蓝色突出显示，而现有特征（如通过其它定位部件或检查部件工具定义的图形、斑点质心、距离、边或圆）以绿色突出显示。

已关闭 示例

智能特征 – 新检测的和之前定义的

如果您想使用某个特征，单击该特征即可；如果该特征尚未定义，EasyBuilder 将自动创建合适的区域。

注意:

如果您所需的特征不是以“智能特征”选项的形式出现，请执行以下操作之一：

  • 选择一个可用的“智能特征”，然后将其自动创建的区域重新定位在您想使用的特征之上。然后调整工具的参数，直到正确检测到所需特征。
  • 首先用合适的“存在/不存在工具”或“几何工具”定义您想使用的特征。然后重新添加该工具并选择您已经定义的特征。


智能限制

带有范围限制选项卡的检查部件工具会自动确定最大和最小限制。

注意:使用带“智能限制”的工具时，为获得最佳结果，可首先在您的“通过”图像上练习使用这些工具。

将带范围限制选项卡的工具添加到您的作业时，该工具会自动检查您的图像并根据该工具要求确定合适的最大和最小限制。例如，距离和“角度测量”工具的最大和最小范围限制分别是距离和角度值的 ±5%，而计数工具范围限制则根据初始图像中发现的特征数量来确定。


智能设置

定义“圆”和“边”的定位部件和检查部件工具会自动增加对比度参数，直到发现边特征，因而您可以快速设置基于应用程序的阈值。

注意:使用带智能限制的工具时，为获得最佳效果，可首先在您的“通过”图像上练习使用这些工具。

将“圆”或“边”的“定位”或“检查”工具添加到作业时，该工具会自动检查您的图像并确定合适的对比度设置，然后将对比度降低两级以设置阈值。默认的对比度设置是 25，最小值是 5。


选择检测部件工具

检测部件工具按检查类型分组：

已关闭 存在/不存在工具

存在/不存在工具用于判定某特征在图像中存在还是不存在。

存在/不存在工具 | In-Sight 视觉系统 (5.x.x 固件版本) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Brightness | X |  | X | X | X | X
Contrast | X |  | X | X | X | X
PatMax RedLine Pattern 1 | X |  |  |  |  |
PatMax Pattern | X |  |  |  |  |
Pattern | X | X | X | X | X | X
Pixel Count 2 | X |  | X | X | X | X
Color Pixel Count 3 | X |  | X | X | X |
Blob 1 | X |  |  |  | X |
Color Blob 2 | X |  |  |  | X |
Edge | X |  |  | X | X | X
Circle | X |  |  | X | X | X
Sharpness | X |  |  |  | X |
1仅适用于 In-Sight 5.x.x 固件版本。 2仅适用于黑白相机型号。 3仅适用于彩色型号。
已关闭 测量工具

测量工具用于测量图像中特征的距离、直径、角度和面积。

测量工具 | In-Sight 视觉系统 | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Distance | X |  |  | X | X | X
Angle | X |  |  | X | X | X
Blob Area 1 | X |  |  |  | X |
Blob Areas (1-10) 1 | X |  |  |  | X |
Color Blob Area 2 | X |  |  |  | X |
Color Blob Areas (1-10) 2 | X |  |  |  | X |
Circle Diameter | X |  |  | X | X | X
Circle Concentricity | X |  |  |  |  | X
Measure Radius | X |  |  |  | X | X
Min/Max Points | X |  |  |  |  |
1仅适用于黑白型号。 2仅适用于彩色型号。
已关闭 计数工具

计数工具用于对图像中的各种特征进行计数。

计数工具 | In-Sight 视觉系统 | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Blobs 1 | X |  |  |  | X |
Color Blobs 2 | X |  |  |  | X |
Edges | X |  |  | X | X | X
Edge Pairs | X |  |  |  |  |
PatMax RedLine Patterns 3 | X |  |  |  |  |
PatMax Patterns | X |  |  |  |  |
Patterns | X |  |  | X | X | X
1仅适用于黑白型号。 2仅适用于彩色型号。 3仅适用于 In-Sight 5.x.x 固件版本。
已关闭 识别工具

识别工具用于识别和检验图像中的一维及二维代码和符号、字母数字文本、图案特征和颜色。

识别工具 | In-Sight 视觉系统 (5.x.x 固件版本) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Read 1D Code | X |  |  |  |  |
Read 1D Codes (1-20) | X |  |  |  |  |
Read 2D Code | X |  |  |  |  |
Read 2D Codes (1-20) | X |  |  |  |  |
Read Postal Code | X |  |  |  |  |
Read ID Codes 1 |  |  |  |  |  |
Read Text 1 |  |  |  |  |  |
Read Text (OCRMax) | X |  |  |  | X |
PatMax RedLine Patterns (1-10) 2 | X |  |  |  |  |
PatMax Patterns (1-10) | X |  |  |  |  |
Patterns (1-10) | X |  |  |  | X |
Color 3 | X |  |  |  |  |
Color Model 2 | X |  |  |  |  |
1读取 ID 代码和读取文本工具在运行 In-Sight Explorer 4.7.0 及更高版本的系统上不受支持。 2仅适用于 In-Sight 5.x.x 固件版本。 3仅适用于彩色型号。
已关闭 几何工具

几何工具用于在图像中创建几何参照，其它检查工具（如数学和逻辑工具和测量工具）可以利用这些参照。

几何工具 | In-Sight 视觉系统 | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Point-to-Point: Line | X |  |  |  | X | X
Point-to-Point: Mid-Point | X |  |  |  | X | X
Point-to-Point: Dimension | X |  |  |  | X | X
Perpendicular Line | X |  |  |  |  | X
Line Intersection | X |  |  |  | X | X
Bisect Angle | X |  |  |  |  | X
Line From N Points | X |  |  |  |  | X
Circle From N Points | X |  |  |  |  | X
Circle-Line Intersection | X |  |  |  |  | X
User-Defined Point | X |  |  |  |  | X
User-Defined Line | X |  |  |  |  | X
Circle Fit | X |  |  |  |  |
Line Fit | X |  |  |  |  |
已关闭 数学和逻辑工具

数学和逻辑工具用于根据工具及作业数据有条件地将工具链接起来、对工具输出执行数学运算、处理工具的统计数据、将工具组合起来以及针对操作顺序创建步骤。

数学和逻辑工具 | In-Sight 视觉系统 | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Math | X |  |  |  | X | X
Logic | X | X | X | X | X | X
Trend | X |  |  |  |  | X
Statistics | X |  |  |  |  | X
Group | X |  |  | X | X | X
Sequence | X |  |  |  |  |
Compute Point | X |  |  |  |  | X
Variables | X |  |  |  | X | X
Robot Guidance | X |  |  |  |  |
已关闭 Plot Tools

图形工具用于根据数学表达式来计算图像中的图形。

图形工具 | In-Sight 视觉系统 | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Plot Arc | X |  |  |  | X | X
Plot Circle | X |  |  |  | X | X
Plot Cross | X |  |  |  | X | X
Plot Line | X |  |  |  | X | X
Plot Point | X |  |  |  | X | X
Plot Region | X |  |  |  | X | X
Plot String | X |  |  |  | X | X
已关闭 图像过滤工具

图像过滤工具用于增强图像或图像区域以进一步对图像进行分析。

图像过滤工具 | In-Sight 视觉系统 (5.x.x 固件版本) | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Filter | X |  |  |  | X |
Neighbor 1 |  |  |  |  |  |
Scene Correction 1 |  |  |  |  |  |
Point 1 |  |  |  |  |  |
Color to Greyscale 2 | X |  |  |  |  |
Color to Binary 2 | X |  |  |  |  |
Transform | X |  |  |  |  |
Compare | X |  |  |  |  |
1仅在运行固件版本 4.x.x 的 In-Sight 视觉系统上受支持。 2仅支持彩色型号。
已关闭 瑕疵检测工具

缺陷检验工具用于确定生产的部件或对象是否有缺陷，例如裂缝、皱折、凹陷、缺口、刻痕或刮擦。

注意:只有 In-Sight 视觉系统支持缺陷检测工具。
  • Surface Flaw
  • Edge
  • Edge Pair
  • Edge Width
  • Bead Finder
  • Bead Tracker
已关闭 校准工具

校准工具用于构造可在作业间共享的校准文件。

校准工具 | In-Sight 视觉系统 | In-Sight 2000-110 | In-Sight 2000-120/120C | In-Sight 2000-130/130C | In-Sight 2000-230/230C In-Sight 2001-230/230C | In-Sight 2000-23M
Robot | X |  |  |  |  |
N Point | X |  |  |  |  | X
Sequence N Point | X |  |  |  |  |

存在/不存在工具

测量工具

计数工具

识别工具

几何工具

数学和逻辑工具

标绘工具

图像筛选工具

校准工具


存在/不存在工具 - 亮度

亮度存在/不存在工具被用来确定在指定区域内基于平均灰度值（例如，亮度）的特征是否存在。 brightness) value of the pixels in the region, and reports that value.

该工具将返回以下结果：

In-Sight 型号 | 结果
In-Sight 2000 系列 1XX 视觉传感器 (110, 120, 130) | 仅限通过/失败状态
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 标准结果（无限制）

亮度存在/不存在工具在正确部件上的特征比错误部件上的特征更暗或更亮的情况下非常有用。 特征亮度的增加或减少是部件或对象存在或不存在的最好指示。 例如，根据区域中的亮度可快速测量出暗色或浅色瓶盖是否存在。

提示:有关如何选择特征的更多信息，请参阅选择特征。

设置工具

调整工具参数


设置亮度存在/不存在工具

添加该工具之后，需要选择区域类型，然后在图像中进行配置以分隔特征：

  1. 从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。将区域置于特征之上，并确保区域的边界覆盖特征。应将边界配置为仅包含您想要检测的特征 - 如果该区域比特征大很多，则可能产生不准确的结果，因为背景中的像素将被一并计算。为了提高该工具的性能，请创建较小的区域；区域越大，执行检测所需的时间越长。如果不使用定位特征，请确保特征将会出现在每个图像中大致相同的位置，或者该区域足够大以包括该特征的预期移动。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。

选择特征


选择特征

选择要用于检测的特征时，为确保获得最佳结果，可考虑以下指导原则：

  • 如果没有使用定位特征，请确保特征在每个图像中出现在大致相同的位置，或具有足够大的区域考虑预期的特征运动。
  • “亮度”工具在被检测的特征存在时为总体一个灰度值（例如，黑色）的应用程序中有用，不存在时反之亦然。
已关闭 示例


调整亮度存在/不存在工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

In-Sight 2000 系列传感器

  • 编辑工具组框

In-Sight 视觉系统

亮度存在/不存在工具设置栏包含以下内容：

  • 常规选项卡
  • 范围限制选项卡
  • 直方图选项卡
  • 组合区域选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

In-Sight 2000 系列视觉传感器

In-Sight 视觉系统

版权所有 © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder 帮助 | 06/28/2022 | Revision: 5.9.0.3


调整亮度存在/不存在工具的参数

注意:该主题介绍了与 In-Sight 2000 系列视觉传感器连接时的用户界面。如果连接到 In-Sight 视觉系统，请参阅 In-Sight 视觉系统的调整亮度存在/不存在工具的参数。

在设置完工具的区域后，你可以开始优化应用程序工具。

已关闭 通过/失败指示

通过显示绿色边框 [image] 或红色边框 [image] 来表示通过或失败结果。

已关闭 亮度测量计和通过范围滑块控制

设置最小和最大亮度级别。 你可以通过调整手柄或在相应的编辑框内输入数字来手动设置该值。

提示:您还可以使用箭头键（上、下、左、右）来移动手柄。
  • 左手柄：设置可接受的最小平均灰度值 (0 - 255)。
  • 右手柄：设置可接受的最大平均灰度值 (0 - 255)。
  • 结果指示：显示在区域内的平均像素灰度值。如果结果在左边和右边操作手柄的中间，则工具通过且结果会以绿色显示。否则，工具失败且结果指示以红色显示。
通过
失败
注意:将鼠标悬停在滑块控件上时，将显示结果和通过范围值。
已关闭 自动按钮

自动将范围限制值设置为最新工具结果，工具结果最大值的 +/- 10%。例如，如果最大结果值为 255 且最新的工具结果值为 150，那么自动按钮会将最小范围值设置为 125 (=150 - 25)，最大范围值设置为 175 (=150 + 25)。

已关闭 反转结果

启用后，如果结果在指定的范围内失败，那么该工具也会显示失败。(默认 = Off)

通过/失败 | （反转） | 通过/失败
通过/失败 | （反转） | 通过/失败
已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 名称

指定亮度工具的名称。 默认名为 “Brightness_1” （如果这是第一个添加到该作业的图案工具，之后的名称依次顺延，例如 “Brightness_2”,、“Brightness_3” 等）。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 已启用

定义检测工具何时运行，或是否运行（默认设置为“开”）。

  • 如果你想要禁用该工具，请选择“关”。
  • 如果希望将该工具与特定的离散输入线路连接，请选择一条输入线，这时该工具可被“开启”或“关闭”（高电平信号 (1) 为“开”，低电平信号 (0) 为“关”）。将该工具与一个输入线路连接允许控制系统（如 PLC）来指定哪些工具可以运行以及何时运行。
已关闭 定位

为工具选择一个定位选项。当定位控制被启用时，定位按钮会变成橙色。

注意:只有在已经添加了用于定位的另一个工具时才能启用此控制。
已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


亮度存在/不存在工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Brightness_1”（如果该工具是添加到作业的第一个亮度工具，之后名称将递增，如“Brightness_2”、“Brightness_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


亮度存在/不存在工具 - 范围限制选项卡

已关闭 最小值

定义最小可接受平均灰度值（0 到 255）；该工具将根据图像创建“智能限制”默认设置，这样可定义来满足应用程序的需要。

已关闭 亮度

报告已在区域中所发现的像素平均灰度值（0 到 255）；正好位于或在最大和最小设置之间的值归类为“通过”。

已关闭 最大值

定义最大可接受平均灰度值（0 到 255）；该工具将根据图像创建“智能限制”默认设置，这样可定义来满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，例如，在此函数被检测时工具结果为“通过”且位于范围限制内。
  • 选中 - 反向结果，例如，在此函数被检测时工具结果为“失败”且位于范围限制内。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


“亮度存在/不存在”工具 - 直方图选项卡

直方图选项卡以直方图的方式显示区域内像素的灰度值。

  • 图形的 X 轴表示灰度值的总数（0 到 255，或总计 256 个灰度级）。
  • 图形的 Y 轴表示给定灰度值的像素数，通过显示具有最大像素数的灰度值建立标度。
  • 三条蓝色垂直线分别表示“最小”、“亮度”和“最大”像素灰度值。
注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


亮度存在/缺失工具 - 复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


存在/不存工具 - 对比度

对比度存在/不存在工具可确定特征是否存在，这取决于区域中像素特征间的对比度值（大于阈值的平均灰度值和小于阈值的平均灰度值之间的差异），并会报告该值。

该工具将返回以下结果：

In-Sight 型号 | 结果
In-Sight 2000 系列 1XX 视觉传感器 (110, 120, 130) | 仅限通过/失败状态
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 标准结果（无限制）

对比度存在/不存在工具在部件特征具有极明显的亮和/或暗区域（相对于不理想的部件）的情况下很有用。 例如，验证白色标签上是否存在暗点。

提示:有关如何选择特征的更多信息，请参阅选择特征。

设置工具


设置对比度存在/不存在工具

添加该工具之后，需要选择区域类型，然后在图像中进行配置以分隔特征：

  1. 从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。将区域置于特征之上，并确保区域的边界覆盖特征。应将边界配置为仅包含您想要检测的特征 - 如果该区域比特征大很多，则可能产生不准确的结果，因为背景中的像素将被一并计算。为了提高该工具的性能，请创建较小的区域；区域越大，执行检测所需的时间越长。如果不使用定位特征，请确保特征将会出现在每个图像中大致相同的位置，或者该区域足够大以包括该特征的预期移动。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。

选择特征

调整工具参数


选择特征

选择要用于检测的特征时，为确保获得最佳结果，可考虑以下指导原则：

  • 如果没有使用定位特征，请确保特征在每个图像中出现在大致相同的位置，或具有足够大的区域考虑预期的特征运动。
  • “对比度”工具在检测的特征包含混合的灰度值（在存在时）和一致的灰度值（在不存在时）应用中很有用。
  • 如果应用程序要求在亮度和对比度之间具有更加细微的差异，可考虑使用“像素计数”工具，这在测量差异方面比“对比度”工具更精确。
已关闭 示例


调整对比度存在/不存在工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

In-Sight 2000 系列传感器

  • 编辑工具组框

In-Sight 视觉系统

对比度存在/不存在工具的设置栏包含以下内容：

  • 常规选项卡
  • 范围限制选项卡
  • 直方图选项卡
  • 组合区域选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

In-Sight 2000 系列视觉传感器

In-Sight 视觉系统

版权所有 © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder 帮助 | 06/28/2022 | Revision: 5.9.0.3


调整对比度存在/不存在工具的参数

注意:该主题介绍了与 In-Sight 2000 系列视觉传感器连接时的用户界面。如果连接到 In-Sight 视觉系统，请参阅 In-Sight 视觉系统的调整对比度存在/不存在工具的参数。

在设置完工具的区域后，你可以开始优化应用程序工具。

已关闭 通过/失败指示

通过显示绿色边框 [image] 或红色边框 [image] 来表示通过或失败结果。

已关闭 对比度测量计和通过范围滑块控制

设置最小和最大对比度级别。 你可以通过调整手柄或在相应的编辑框内输入数字来手动设置该值。

提示:您还可以使用箭头键（上、下、左、右）来移动手柄。
  • 左手柄：设置可接受的最小平均灰度值 (0 - 255)。
  • 右手柄：设置可接受的最大平均灰度值 (0 - 255)。
  • 结果指示：显示在区域内的平均像素灰度值。如果结果在左边和右边操作手柄的中间，则工具通过且结果会以绿色显示。否则，工具失败且结果指示以红色显示。
通过
失败
注意:将鼠标悬停在滑块控件上时会显示结果。
已关闭 自动按钮

自动将范围限制值设置为最新工具结果，工具结果最大值的 +/- 10%。例如，如果最大结果值为 255 且最新的工具结果值为 150，那么自动按钮会将最小范围值设置为 125 (=150 - 25)，最大范围值设置为 175 (=150 + 25)。

已关闭 反转结果

启用后，如果结果在指定的范围内失败，那么该工具也会显示失败。(默认 = Off)

通过/失败 | （反转） | 通过/失败
通过/失败 | （反转） | 通过/失败
已关闭 名称

指定检测工具的名称。 默认名为 ““Contrast_1” （如果这是第一个添加到该作业的图案工具，之后的名称依次顺延，例如 “Contrast_2”,、“Contrast_3” 等）。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 已启用

定义检测工具何时运行，或是否运行（默认设置为“开”）。

  • 如果你想要禁用该工具，请选择“关”。
  • 如果希望将该工具与特定的离散输入线路连接，请选择一条输入线，这时该工具可被“开启”或“关闭”（高电平信号 (1) 为“开”，低电平信号 (0) 为“关”）。将该工具与一个输入线路连接允许控制系统（如 PLC）来指定哪些工具可以运行以及何时运行。
已关闭 定位

为工具选择一个定位选项。当定位控制被启用时，定位按钮会变成橙色。

注意:只有在已经添加了用于定位的另一个工具时才能启用此控制。
已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


对比度存在/不存在工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Contrast_1”（如果该工具是添加到作业的第一个对比度工具，之后名称将递增，如“Contrast_2”、“Contrast_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


对比度存在/不存在工具 - 范围限制选项卡

已关闭 最大值

定义最大可接受对比值 (0 - 255)；该工具将根据图像创建“智能限制”默认设置，这样可定义来满足应用程序的需要。

已关闭 对比度

报告大于和低于通过工具创建的“智能”阈值的平均灰度值之间的差异（在区域中发现）；正好位于或在最大和最小设置之间的值归类为“通过”。

已关闭 最小值

定义最小可接受对比值 (0 - 255)；该工具将根据图像创建“智能限制”默认设置，这样可定义来满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，例如，在此函数被检测时工具结果为“通过”且位于范围限制内。
  • 选中 - 反向结果，例如，在此函数被检测时工具结果为“失败”且位于范围限制内。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


“对比度存在/不存在”工具 - 直方图选项卡

直方图选项卡以直方图的方式显示区域内像素的灰度值。

  • 图形的 X 轴表示灰度值的总数（0 到 255，或总计 256 个灰度级）。
  • 图形的 Y 轴表示给定灰度值的像素数，通过显示具有最大像素数的灰度值建立标度。
  • 三条蓝色垂直线分别表示小于阈值的平均灰度值、阈值和大于阈值的平均灰度值。
注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


“对比度存在/缺失”工具 - 复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


存在/不存在工具 - PatMax RedLine 图形和 PatMax 图形

注意:
  • 从 In-Sight 固件版本 5.5.0 开始，该工具的算法已被更改，以在某些情况下返回更准确的结果并缩短执行时间。
  • 由于此更改，如果试图将在 In-Sight 固件 5.5.0 或更高版本中设置该工具的作业加载到运行固件版本 5.4.x 或更低版本的 In-Sight 视觉系统时，会显示错误消息。
  • PatMax RedLine 图形定位工具和 PatMax RedLine 图形 (1-10) 定位工具仅在运行 In-Sight 固件版本 5.2.0 和更高版本的 In-Sight 视觉系统上可用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

PatMax RedLine 图形工具和 PatMax 图形存在/不存在工具用于根据图形的已训练表示形式（称为模型），采用 PatMax RedLine 或 PatMax 算法来确定该图形特征存在或不存在。

这些工具在合格部件上的特征具有不良部件上不存在的可识别图形时（反之亦然）十分有用。例如，如果您需要验证在机械安装中是否存在十字头螺丝图形。

设置工具

调整工具参数


设置 PatMax RedLine 图形和 PatMax 图形存在/不存在工具

添加该工具之后，需要选择并配置将定义图形的区域类型（模型区域），以及将在其中查找图形的图像中的区域（搜索区域）。

  1. 从模型下拉菜单中，选择区域的类型：矩形（默认）、圆形、环形或多边形。然后将模型区域放置在将用于训练模型的图形上；请确保模型区域只覆盖图形的重要特征。添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 从搜索下拉菜单选择区域类型：矩形（默认）、圆形、环形或多边形。然后定位搜索区域，使其覆盖图像中您希望图形出现的区域。为了帮助提高工具的性能，请创建较小的搜索区域。搜索区域越大，执行检查所需的时间越长。
  3. 按确定按钮确认区域（按取消按钮不将该工具添加到作业）。
  4. 在初始配置该工具的情况下，根据需要加载几个图像并调整工具参数，以补偿预期的变化范围。
  5. 最后，如需要，可以使用工具的输入/输出属性表以在其他工具和/或其他外部设备之间共享工具数据。

PatMax RedLine 图案、PatMax 图案以及图案

选择图案特征


PatMax RedLine 图形、PatMax 图形和图形

注意:PatMax RedLine 图形存在/不存在工具仅在运行 In-Sight 固件版本 5.2.0 和更高版本的 In-Sight 视觉系统上可用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

PatMax RedLine 图形、PatMax 图形和图形可定位已训练的图形模型，且在定位和检测工具中提供最高准确性。然而，PatMax RedLine 图形和 PatMax 图形比图形的功能更强大，以应对灯光条件和图形位置的更大变化。它们还提供对图形比例和旋转变化、图形元素遮挡以及由于灯光条件导致的图形外观变化的出色识别。

PatMax RedLine 图形和 PatMax 图形之间的主要差别是速度；PatMax RedLine 图形采用最新图形匹配算法，可在 5 百万像素图像中以高出 PatMax 图形多达 7 倍的速度定位已训练特征。因此，PatMax RedLine 图形适用于高分辨率视觉系统。

图形（在大多数情况下）比 PatMax 快，但某些情况需要 PatMax RedLine 或 PatMax 版本的准确性和可靠性：

  • 当灯光和反射变化难以控制时。例如，金属部件可在任意方向反射光线。
  • 当要检查的图形与背景中的某些元素的形状或阴影类似，或图形与图像中的其他对象重叠或被其部分遮挡时。
  • 当希望从其他类似图形中准确识别一种图形类型时。
  • 当部署环境条件对于图形工具的一致且可靠执行过于苛刻时。


选择图形特性

选择要用于检测的图形时，为确保获得最佳结果，可考虑以下指导原则：

  • 图形始终出现在每个图像中。
  • 图形应尽可能多地包含独特和一致的现有特性，而组成图形的特性的外观和相对几何形状应彼此一致，且能够清楚分辨。
  • 如果可能，选择较大的图形；较大的图形通常意味图形中具有更独特的特性，可使检测更加一致和精确。


调整 PatMax RedLine 图形和 PatMax 图形存在/不存在工具参数

在设置完工具的区域后，你可以开始为应用程序优化工具。

PatMax RedLine 图形和 PatMax 图形存在/不存在工具的设置窗格包括以下选项卡：

  • 常规选项卡
  • 设置选项卡
  • 模型和搜索选项卡
  • 已训练图像选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

模型和搜索选项卡

已训练图像选项卡


PatMax RedLine 图形和 PatMax 图形存在/缺失工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Pattern_1”（如果该工具是添加到作业的第一个图形工具，之后名称将递增，如“Pattern_2”、“Pattern_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


PatMax RedLine 图形以及PatMax 图形存在/不存在工具 - 设置选项卡

已关闭 合格阈值

定义模型图形与所找到图形之间必须存在的相似程度（0-100；默认值 = 50）。所找到的图形大于或等于该设置值将视为匹配。设置值越高，该工具的执行速度越快，这也需要模型与所找到图形之间具有更大的相似度。设置的值较低会得到更多精确度较低的相似结果，如检测到与模型图形相似但不是模型图形本身的图形。

已关闭 对比度阈值

定义已找到图形中必须存在的最小可接受对比度；已找到图形的对比度必须大于要视为有效实例的对比度阈值。PatMax RedLine 图形的默认值为 0，有效参数范围为 0-100。PatMax 图形的默认值为 10，有效参数范围为 0-255。低对比度阈值用于低对比度图像，而高对比度阈值用于高对比度图像。

注意:PatMax RedLine 图形对比度是已训练图形中的特征与搜索图像中的匹配特征之间的对比度变化的“相对”程度，以百分比表示。因此，如果特征对比度类似于或高于图形对比度，报告的对比度将约为 100。如果特征对比度低于图形对比度，报告的对比度将 <100。PatMax RedLine 图形的对比度不同于 PatMax 图形的对比度，后者是搜索 ROI 的“绝对”图像对比度，以灰度级表示。
已关闭 角度公差

定义找到的图形可从“模型”图案位置处旋转而仍被识别为有效图形的最大角度（± 0-180°；默认值 =15°）。允许较大的图形旋转偏差范围会增加该工具的执行时间。

已关闭 缩放公差

定义已找到图形和模型图形之间允许的缩放百分比（尺寸变化）（0-50；默认值为 0）。此值为正或负百分比，例如，值 5 将启用工具以查找介于模型图形尺寸的 95% 至 105% 之间的图形。允许更大的图形比例变化范围将增加工具的执行时间。

已关闭 查找模式

定义用于训练和识别图案的搜索模式，PatMax 或 PatQuick。默认情况下会选择 PatMax。PatMax 的精确度比 PatQuick 高，但是需要更多的执行时间，而 PatQuick 的精确度比 PatMax 低，但是需要较少的执行时间。

已关闭 严格评分

定义找到图形的缺失或遮挡特征是否会影响分数（默认=关闭，未选中）。应用严格评分时（开启，选中），如果图形的特征缺失或被锁定，则会降低所发现图形的得分。

已关闭 严格评分

定义找到图形的缺失或遮挡特征是否会影响分数（默认=关闭，未选中）。应用严格评分时（开启，选中），如果图形的特征缺失或被锁定，则会降低所发现图形的得分。

已关闭 忽略极性

定义所找到的图形是否可以包含与模型图形反色的匹配特征（默认值 = 关，取消选中）。应用忽略极性（开，选中）时，如果检测到的图形具有反色特征（例如与模型图形中的白色/黑色相对的黑色/白色），该图形将被归类为与模型图形匹配。

已关闭 倒置
定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 超时
定义工具搜索图形的时间，以毫秒为单位（0 至 30,000）。超过该设定时间，操作会停止并返回错误信息。 默认情况下，该参数设置为 5,000。
已关闭 结果

显示工具的结果：如果检测到模式特征则显示存在，并显示找到的图形与模型图形有多相似的分数；如果未检测到或者检测到多个图形实例，则显示不存在。 显示等于Boolean 值 1（通过）; 不显示等于 Boolean 值 0（失败）。

注意:PatMax RedLine 图形不包含 Find Mode（查找模式）参数。


PatMax RedLine 图形和 PatMax 图形存在/缺失工具 - 模型和搜索选项卡

模型和搜索选项卡用于为工具的模型和搜索区域配置复合区域。复合区域是添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为“遮掩”）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 在模型选项卡中，仅在按模型区域按钮后才能启用复合区域。
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


PatMax RedLine 图形和 PatMax 图形存在/不存在工具 - 已训练图像选项卡

训练图像选项卡中显示的图像是模型图形的缩略图。按模型区域按钮可调整模型区域的大小或移动该区域，然后按训练按钮重新训练模型图形。


存在/不存在工具 - 图形

图形存在/不存在工具用于根据训练后的图形（也称为模型）来决定图形特征的存在/不存在的情况。

图形存在/不存在工具在好的部件上含有错误部件上不存在的可识别图形特征的情况下很有用，反之亦然。 例如，如果您需要验证在机械安装中是否存在十字头螺丝。

该工具将返回以下结果：

In-Sight 型号 | 结果
In-Sight 2000-110 and 2000-120/120C 视觉传感器 | 仅限通过/失败状态
In-Sight 2000-130/130C 视觉传感器 | 通过/失败状态和图形分数
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 标准结果（无限制）

设置工具

调整工具参数


设置参照图形存在/不存在工具

添加该工具之后，需要配置将定义图形的图像中的区域（模型区域），以及将在其中查找图形的图像中的区域（搜索区域）。

  1. 将模型区域置于将用作训练模型的图形之上，确保模型区域仅覆盖图形的重要特征。

  2. 决定搜索区域的位置，使其覆盖图像中您希望图形出现的区域。为了帮助提高工具的性能，请创建较小的搜索区域。搜索区域越大，执行检查所需的时间越长。

    注意:模型和搜索区域无法弯曲为弧或圆环形状。
  3. 按确定按钮确认区域（按取消按钮不将该工具添加到作业）。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整图形存在/不存在工具参数

在设置完工具的区域后，你可以开始为应用程序优化工具。

In-Sight 2000 系列传感器

  • 编辑工具组框

In-Sight 视觉系统

图形存在/不存在工具的设置栏包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 已训练图像选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

In-Sight 2000 系列视觉传感器

In-Sight 视觉系统

版权所有 © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder 帮助 | 06/28/2022 | Revision: 5.9.0.3


调整图形存在/不存在工具参数

注意:
  • 该主题介绍了与 In-Sight 2000 系列视觉传感器连接时的用户界面。如果连接到In-Sight视觉系统，请参阅In-Sight 视觉系统部分调整图形与图形 (1-10) 定位工具参数。
  • 当尝试将包含在 In-Sight 固件5.7.0 或更高版本上配置的该工具的作业加载到运行固件版本 5.6.x 或更早版本的 In-Sight 视觉系统时，将显示错误消息，并且作业加载将失败。

在设置完工具的区域后，你可以开始优化应用程序工具。

已关闭 通过/失败指示

通过显示绿色边框 [image] 或红色边框 [image] 来表示通过或失败结果。

已关闭 旋转公差

指定找到的图形可从“模型”图形位置处旋转而仍可被识别为有效图形的最大角度（± 0 到 180, 默认 = ±45°）。允许较大的图形旋转偏差范围会增加该工具的执行时间。左边手柄被用来设置负角度旋转值，右边手柄被用来设置正角度旋转值。你可以通过调整手柄或在相应的编辑框内输入数字来调整旋转角度值。

提示:您还可以使用箭头键（上、下、左、右）来移动手柄。
已关闭 部件查找度量

部件查找度量显示了工具寻找特征的精确程度，并设置最小可接受阈值。你可以通过调整手柄或在相应的编辑框内输入数值来手动设置最小可接受阈值（0-100; 默认 = 50）。

提示:您还可以使用箭头键（上、下、左、右）来移动手柄。

如果度量值超过阈值，则工具会认为部件已被找到且度量会变成绿色。如果值小于阈值，则工具会认为部件没有被找到且度量会消失。如果工具检测到不是部件的目标，或检测到错误的特征，你可以将手柄往右适当调整。如果工具没有找到任何部件，可以将手柄向左适当调整（或创建一个新的模型区域）。设置的值较低会得到更多精确度较低的相似结果，如检测到与模型图形相似但不是模型图形本身的图形。

通过
失败
注意:当鼠标悬停在控制滑块上时会显示结果以及阈值。
已关闭 反转结果

启用后，如果结果在指定的范围内失败，那么该工具也会显示失败。(默认 = Off)

通过/失败 | （反转） | 通过/失败
通过/失败 | （反转） | 通过/失败
已关闭 ±10% 缩放公差

指定工具在找到的图形和模型图形间是否允许 ±10% 的大小差异。

已训练的图形 | 已找到图形：+10% | 已找到图形：-10%
OFF（默认） | （失败） | （失败）
ON | （通过） | （通过）
已关闭 使用手动超时

定义是否应用超时设置

  • 关闭（默认）：禁用超时设置（无超时设置）。

  • 打开：启用超时设置。您可以使用编辑框手动定义以毫秒为单位的超时值（0 到 30000）。

    注意:将值设置为 0 将禁用该设置，且不会应用超时。
已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 名称

指定检测工具的名称。 默认名为 ““Pattern_1” （如果这是第一个添加到该作业的图形工具，之后的名称将依次顺延，例如 “Pattern_2”,、“Pattern_3” 等）。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 已启用

定义检测工具何时运行，或是否运行（默认设置为“开”）。

  • 如果你想要禁用该工具，请选择“关”。
  • 如果希望将该工具与特定的离散输入线路连接，请选择一条输入线，这时该工具可被“开启”或“关闭”（高电平信号 (1) 为“开”，低电平信号 (0) 为“关”）。将该工具与一个输入线路连接允许控制系统（如 PLC）来指定哪些工具可以运行以及何时运行。
已关闭 定位

为工具选择一个定位选项。当定位控制被启用时，定位按钮会变成橙色。

注意:只有在已经添加了用于定位的另一个工具时才能启用此控制。
已关闭 训练输入

定义是否训练输入线上的模型模式（默认设置为“关”，禁用）。

  • 输入：在输入线上训练模型图形。选定的输入线路将被用作训练信号。

    注意:
    • 当 In-Sight 视觉系统没有离散输入时（例如使用直接 I / O 的 In-Sight 8000 系列视觉系统），此选项不会显示。
    • 所选输入线的信号类型必须在输入/输出应用步骤中设置为事件触发。
    • 模型图形的训练将使用由视觉系统/传感器采集的最新图像。不需要为了训练重新触发视觉系统/传感器。
    • 有关详情，请参阅 输入：在输入线上训练模型图形
已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

已关闭 模型区域

该图像是一个模型图形的小图像。按模型区域按钮可调整模型区域的大小或移动该区域，然后按训练按钮重新训练模型图形。


图形存在/不存在工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Pattern_1”（如果该工具是添加到作业的第一个图形工具，之后名称将递增，如“Pattern_2”、“Pattern_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


图形存在/不存在工具 - 设置选项卡

已关闭 训练输入

定义是否训练输入线上的模型模式（默认设置为“关”，禁用）。

  • 输入：在输入线上训练模型图形。选定的输入线路将被用作训练信号。

    注意:
    • 当 In-Sight 视觉系统没有离散输入时（例如使用直接 I / O 的 In-Sight 8000 系列视觉系统），此选项不会显示。
    • 所选输入线的信号类型必须在输入/输出应用步骤中设置为事件触发。
    • 模型图形的训练将使用由视觉系统/传感器采集的最新图像。不需要为了训练重新触发视觉系统/传感器。
    • 有关详情，请参阅 输入：在输入线上训练模型图形
已关闭 合格阈值

定义模型图形与所找到图形之间必须存在的相似程度（0-100；默认值 = 50）。大于或等于设置值的所发现图形视为匹配。设置值越高，该工具的执行速度越快，这也需要模型与所找到图形之间具有更大的相似度。设置的值较低会得到更多精确度较低的相似结果，如检测到与模型图形相似但不是模型图形本身的图形。

已关闭 旋转公差

定义找到的图形可从“模型”图形位置处旋转而仍被识别为有效图形的最大角度（± 0-180°；默认值 =15°）。允许较大的图形旋转偏差范围会增加该工具的执行时间。

已关闭 缩放公差

定义工具对图形尺寸变化所能接受的范围，在训练图形尺寸的 ±10％ 范围内。默认情况下，此设置为关闭（未选中），该设置将禁用缩放比例调整。在这种操作模式下，工具仍然可以找到在 ±10％ 范围内的图形，但是特征的得分会随着变化比例的增加而降低。

已关闭 反转结果
定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 模型类型

定义工具如何构造模型图形；区域模型或边模型（默认）。区域模型根据模型区域中一致的灰度值采样来创建模型图形。边模型根据在“模型”区域内检测到的图形特征的边（明/暗转换）来创建模型图形。

已关闭 精确度

定义工具将如何在准确性/可靠性和执行速度之间取得平衡；准确, 中度(默认)以及快速。准确表明读取结果含有很高的准确性/可靠性，可是读取速度会比较慢；快速表明读取的准确性/可靠性会比较低可是读取速度比较快；中度则表明在准确性/可靠性和速度中间取一个平衡值。

已关闭 超时

定义以毫秒为单位的时间量（0 到 30,000），工具搜索图形超过此时间量后将停止执行并返回“失败”。

已关闭 结果

显示工具的结果：如果检测到模式特征则显示存在，并显示找到的图形与模型图形相似度的分值；如果未检测到或者检测到多个图形实例，则显示不存在。存在等于布尔值 1（通过）; 不存在等于布尔值 0（失败）。


参照图形存在/不存在工具 - 训练图像选项卡

训练图像选项卡中显示的图像是模型图形的缩略图。按模型区域按钮可调整模型区域的大小或移动该区域，然后按训练按钮重新训练模型图形。


存在/不存在工具 - 像素计数

像素计数存在/不存在工具可根据白色或黑色像素数目来确定指定区域内的特征是否存在，并报告该值。

该工具可计算区分白色和黑色像素图像的最佳灰度阈值（0 到 255），然后计算低于或高于该阈值的像素（根据设置）。

像素计数存在/不存在工具可用于根据区域中的白色或黑色像素数来确定特征是否存在的情况。 例如，验证已在电路板周围分布的确切焊接数，或验证在标签上存在打印完全的文本字符串。

该工具将返回以下结果：

In-Sight 型号 | 结果
In-Sight 2000 系列 1XX 视觉传感器 (110, 120, 130) | 仅限通过/失败状态
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 标准结果（无限制）

设置工具

调整工具参数


设置像素计数存在/不存在工具

添加该工具之后，需要选择区域类型，然后在图像中进行配置以分隔特征：

  1. 从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。将区域置于特征之上，并确保区域的边界覆盖特征。应将边界配置为仅包含您想要检测的特征 - 如果该区域比特征大很多，则可能产生不准确的结果，因为背景中的像素将被一并计算。为了提高该工具的性能，请创建较小的区域；区域越大，执行检测所需的时间越长。如果不使用定位特征，请确保特征将会出现在每个图像中大致相同的位置，或者该区域足够大以包括该特征的预期移动。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。

选择特征


选择特征

选择要用于检测的特征时，为确保获得最佳结果，可考虑以下指导原则：

  • 如果没有使用定位特征，请确保特征在每个图像中出现在大致相同的位置，或具有足够大的区域考虑预期的特征运动。
  • 像素计数工具在检测的特征包含混合的灰度值（在存在时）和一致的灰度值（在不存在时）应用中很有用。
  • 像素计数工具能够区分亮度和对比度之间的细微差异，并且在测量这些差异方面比亮度或对比度“存在/不存在”工具更精确。
已关闭 示例


调整像素计数存在/不存在工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

In-Sight 2000 系列传感器

  • 编辑工具组框

In-Sight 视觉系统

像素计数存在/不存在工具的设置栏包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 范围限制选项卡
  • 直方图选项卡
  • 组合区域选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

In-Sight 2000 系列视觉传感器

In-Sight 视觉系统

版权所有 © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder 帮助 | 06/28/2022 | Revision: 5.9.0.3


调整像素计数存在/不存在工具的参数

注意:该主题介绍了与 In-Sight 2000 系列视觉传感器连接时的用户界面。如果连接到 In-Sight 视觉系统，请参阅 In-Sight 视觉系统的调整像素计数存在/不存在工具的参数。

在设置完工具的区域后，你可以开始优化应用程序工具。

已关闭 通过/失败指示

通过显示绿色边框 [image] 或红色边框 [image] 来表示通过或失败结果。

已关闭 像素选择

指定工具该如何将图像分割成黑色像素和白色像素区域。 默认情况下，该工具会计算黑色像素且在区域内的黑色像素会以黄色高亮显示。

原始图像
所选的像素颜色 = 黑色

左边的选择手柄被用来设置低阈值（0 - 255），右边的选择手柄被用来设置高阈值 （0 - 255）。 你可以通过调整手柄或在相应的编辑框内输入数字来手动设置该值。

提示:您还可以使用箭头键（上、下、左、右）来移动手柄。

如需计算白色像素，可以点击 [image] 。 现在白色的像素在所选的区域内以黄色高亮显示。

所选的像素颜色 = 白色
已关闭 自动按钮

自动将范围限制值设置为最新工具结果，工具结果最大值的 +/- 10%。例如，如果最大结果值为 255 且最新的工具结果值为 150，那么自动按钮会将最小范围值设置为 125 (=150 - 25)，最大范围值设置为 175 (=150 + 25)。

已关闭 像素计数度量和通过范围

指定区域内可以接受的像素数目。 操作手柄可以用来设置决定工具通过或失败的区域内所必须包含的最小和最大黑色或白色像素数目。

通过
失败

如果最后的结果在左边和右边操作手柄中间，则工具结果会通过且度量尺的边框会以绿色显示。 如果不通过，则工具结果会显示失败且度量尺的边框会以红色显示。

你可以通过调整手柄或在相应的编辑框内输入数字来手动设置该值。

提示:您还可以使用箭头键（上、下、左、右）来移动手柄。
注意:将鼠标悬停在滑块控件上时，将显示结果（在区域中找到的像素数）和通过范围值。
已关闭 反转结果

启用后，如果结果在指定的范围内失败，那么该工具也会显示失败。(默认 = Off)

通过/失败 | （反转） | 通过/失败
通过/失败 | （反转） | 通过/失败
已关闭 显示细节

定义所计数的像素是否总是在图像区域（突出显示黄色）显示。

提示:要在 VisionView 上显示计数的像素，请在通信应用程序步骤中的 EasyView 中选择 Show_Details，然后选中 VisionView 应用程序中的 Show_Details 复选框。有关如何在 VisionView 上显示数据的详情，请参阅配置 EasyView。
  • 打开（ [image] = 默认）：除非正在编辑其它定位或检测工具，否则计数的像素总是显示在图像区域中。

  • 关闭（ [image] ）：只有在编辑该工具时，计算的像素才会显示在图像区域中。

已关闭 反转所选像素

更改要进行计数的像素颜色 - 黑色 [image] 或白色 [image] （默认= 黑色）。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 名称

指定检测工具的名称。 默认名为 ““Pixels_1” （如果这是第一个添加到该作业的图案工具，之后的名称依次顺延，例如 “Pixels_2”,、“Pixels_3” 等）。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 已启用

定义检测工具何时运行，或是否运行（默认设置为“开”）。

  • 如果你想要禁用该工具，请选择“关”。
  • 如果希望将该工具与特定的离散输入线路连接，请选择一条输入线，这时该工具可被“开启”或“关闭”（高电平信号 (1) 为“开”，低电平信号 (0) 为“关”）。将该工具与一个输入线路连接允许控制系统（如 PLC）来指定哪些工具可以运行以及何时运行。
已关闭 定位

为工具选择一个定位选项。当定位控制被启用时，定位按钮会变成橙色。

注意:只有在已经添加了用于定位的另一个工具时才能启用此控制。
已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


像素计数存在/不存在工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Pixels_1”（如果该工具是添加到作业的第一个像素计数工具，之后名称将递增，如“Pixels_2”、“Pixels_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


“像素计数存在/不存在”工具 - 设置选项卡

已关闭 阈值模式

针对将图像区域划分为黑色和白色像素的灰度值，定义确定该灰度值的模式。如果选择自动（默认值 = 自动），每次采集图像时，该工具会根据图像创建默认“智能设置”，不断地调整从图像到图像的亮度变化。当选择手动时，需要手动输入和调整两个阈值。

已关闭 Low Threshold（低阈值）

定义区分黑色像素和白色像素的灰度值（0 - 255，启用时）。如果高阈值大于 ≥ 低阈值，白色像素定义为低阈值 ≤ 值 ≤ 高阈值；如果高阈值 < 低阈值，则白色像素定义为值 ≤ 高阈值或低阈值 ≤ 值。默认情况下此控制为“关”，需要将阈值模式设置为手动才能启用。使用直方图选项卡中的图形设置应用的最佳值。

  • 低阈值 ≤ 高阈值：两个阈值之间的每个值都视为“白色” ，无论实际灰度值如何。两个阈值之外的每个值都视为“黑色”，无论实际灰度值如何。
  • 高阈值 ≤ 低阈值：两个阈值之间的每个值都视为“黑色” ，无论实际灰度值如何。两个阈值之外的每个值都视为“白色”，无论实际灰度值如何。
已关闭 High Threshold（高阈值）

定义区分黑色像素和白色像素的灰度值（0 - 255，启用时）。如果高阈值大于 ≥ 低阈值，白色像素定义为低阈值 ≤ 值 ≤ 高阈值；如果高阈值 < 低阈值，则白色像素定义为值 ≤ 高阈值或低阈值 ≤ 值。默认情况下此控制为“关”，需要将阈值模式设置为手动才能启用。使用直方图选项卡中的图形设置应用的最佳值。

  • 低阈值 ≤ 高阈值：两个阈值之间的每个值都视为“白色” ，无论实际灰度值如何。两个阈值之外的每个值都视为“黑色”，无论实际灰度值如何。
  • 高阈值 ≤ 低阈值：两个阈值之间的每个值都视为“黑色” ，无论实际灰度值如何。两个阈值之外的每个值都视为“白色”，无论实际灰度值如何。
已关闭 极性

定义要计数的像素颜色 - “黑色”或“白色”（默认值为“白色”）。


像素计数存在/不存在工具 - 范围限制选项卡

已关闭 最大值

定义区域中像素的最大可接受数；该工具将根据图像创建“智能限制”默认设置，这样可定义来满足应用程序的需要。

已关闭 像素

报告在区域中找到的像素数（值的范围为 0 到区域的最大面积）；正好位于或在最大和最小设置之间的值归类为“通过”。

已关闭 最小值

定义区域中像素的最小可接受数；该工具将根据图像创建“智能限制”默认设置，这样可定义来满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，例如，在此函数被检测时工具结果为“通过”且位于范围限制内。
  • 选中 - 反向结果，例如，在此函数被检测时工具结果为“失败”且位于范围限制内。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


“像素计数存在/不存在”工具 - 直方图选项卡

直方图选项卡以直方图的方式显示区域内像素的灰度值。

  • 图形的 X 轴表示灰度值的总数（0 到 255，或总计 256 个灰度级）。
  • 图形的 Y 轴表示给定灰度值的像素数，通过显示具有最大像素数的灰度值建立标度。
  • 蓝色的垂直线指示用于将图像区域区分为黑色和白色像素的阈值；线左侧的值被视为黑色，而线右侧的值被视为白色。
注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


像素计数存在/不存在工具 - 复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


存在/不存在工具 - 颜色像素计数

颜色像素计数存在/缺失工具将根据与颜色表（In-Sight 2000 系列彩色视觉传感器）中所训练的颜色匹配的像素数或出现在该区域中的在训练库（In-Sight 彩色视觉系统）中所选的颜色模型来确认特征是否存在，并报告该值。

该工具将返回以下结果：

In-Sight 型号 | 结果
In-Sight 2000 系列 1XX 视觉传感器 (110, 120, 130) | 仅限通过/失败状态
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 标准结果（无限制）

设置工具

调整工具参数


设置颜色像素计数存在/不存在工具

添加该工具之后，需要选择区域类型，然后在图像中进行配置以分隔特征：

In-Sight 2000 系列彩色传感器

In-Sight 彩色视觉系统

In-Sight 2000 系列彩色传感器

  1. 从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。将区域置于特征之上，并确保区域的边界覆盖特征。应将边界配置为仅包含您想要检测的特征 - 如果该区域比特征大很多，则可能产生不准确的结果，因为背景中的像素将被一并计算。为了提高该工具的性能，请创建较小的区域；区域越大，执行检测所需的时间越长。如果不使用定位特征，请确保特征将会出现在每个图像中大致相同的位置，或者该区域足够大以包括该特征的预期移动。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 一旦区域被配置，您就可以训练工具的颜色设置。

    注意:默认情况下，如果未选择颜色，则工具将自动产生“失败”结果。
  4. 点击训练颜色按钮。将显示颜色训练内容栏。
  5. 点击 [image] 以添加颜色。
  6. 将光标移动到图像区域。在内容栏中，将显示一个放大镜以帮助您找到颜色。

  7. 点击以选择所需的颜色。点击后，颜色将被添加到下面的颜色表中，并且区域中与所选颜色匹配的所有像素将变为黄色。

    添加颜色之前 选择颜色 添加颜色之后
  8. 重复步骤 6 和 7，直到颜色表包含所有必需的颜色。
  9. 要减去颜色，请单击 [image] 并重复步骤 6 至 8。
  10. 单击完成颜色选择按钮以返回到内容栏。
  11. 在初始配置该工具时，根据需要加载一些调整工具参数，以补偿预期的变化范围。
  12. 最后，如果需要，可使用工具的输入/输出属性在其他外部设备之间共享工具数据。

In-Sight 彩色视觉系统

颜色像素计数存在/缺失工具引用颜色模型的训练库，然后确定在训练库中匹配所选择和训练的颜色模型区域中存在的像素的数量。该工具随后会创建一个二进制灰度输出图像，其中与活动颜色模型匹配的每个像素均设置为白色 (255)，而其它所有像素均设置为黑色 (0)。利用此二进制输出图像，该工具随后会搜索图像并记录与活动颜色模型相匹配的像素数。

  1. 从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。将区域置于特征之上，并确保区域的边界覆盖特征。应将边界配置为仅包含您想要检测的特征 - 如果该区域比特征大很多，则可能产生不准确的结果，因为背景中的像素将被一并计算。为了提高该工具的性能，请创建较小的区域；区域越大，执行检测所需的时间越长。如果不使用定位特征，请确保特征将会出现在每个图像中大致相同的位置，或者该区域足够大以包括该特征的预期移动。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 配置搜索区域后，需要配置该工具的颜色库并激活相应的颜色模型：

    • 如果这是首次添加颜色工具（“彩色斑点”与“彩色斑点 (1-10)”定位工具、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”与“彩色斑点面积 (1-10)”测量工具、“彩色斑点”计数工具、“颜色模型”识别工具或“颜色转为二进制”图像过滤工具），需要首先定义颜色库及其颜色模型。

    • 如果先前已添加另一个颜色工具，并且想要利用现有颜色库及其训练的颜色模型，请转到“设置”选项卡并选择所需的颜色库，然后在“库”选项卡中选中所需颜色模型以激活它们。

    • 默认情况下，工具将自动产生“失败”，直至定义颜色库。如果已定义颜色库，则工具将自动使用该库并激活其包含的所有颜色模型。

  4. 设置颜色模型和颜色库后，该工具将处理图像，搜索区域内与所选颜色模型匹配的所有像素都会变为白色 (255)，而与颜色模型不匹配的像素则会变为黑色 (0)。
  5. 在初始配置该工具时，根据需要加载一些调整工具参数，以补偿预期的变化范围。
  6. 最后，如需要可以使用工具的输入/输出属性表来设置与其它工具及设备间的数据分享。


调整“颜色像素计数存在/不存在”工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

In-Sight 2000 系列传感器

  • 编辑工具组框

In-Sight 视觉系统

颜色像素计数存在/缺失工具的设置栏由以下选项卡组成：

  • 常规选项卡
  • 设置选项卡
  • 范围限制选项卡
  • 颜色库选项卡
  • 组合区域选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

In-Sight 2000 系列视觉传感器

In-Sight 视觉系统

版权所有 © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder 帮助 | 06/28/2022 | Revision: 5.9.0.3


调整彩色像素计数存在/不存在工具的参数

注意:该主题介绍了与 In-Sight 2000 系列视觉传感器连接时的用户界面。如果连接到 In-Sight 视觉系统，请参阅 In-Sight 视觉系统的调整像素计数存在/不存在工具的参数。

在设置完工具的区域后，你可以开始优化应用程序工具。

通用内容栏

已关闭 通过/失败指示

通过显示绿色边框 [image] 或红色边框 [image] 来表示通过或失败结果。

已关闭 训练颜色

打开颜色训练内容栏。

已关闭 颜色块

显示在选练颜色内容栏中通过选择所需添加的颜色 [image] 按钮所添加的前 5 个颜色。 您可以通过点击颜色块以转到颜色训练内容栏。

已关闭 像素计数度量和通过范围

指定区域内可以接受的像素数目。 操作手柄可以用来设置决定工具通过或失败区域内所必须包含的最小和最大像素数目。

通过
失败

如果最后的结果在左边和右边操作手柄中间，则工具结果会通过且度量尺的边框会以绿色显示。 如果不通过，则工具结果会显示失败且度量尺的边框会以红色显示。

你可以通过调整手柄或在相应的编辑框内输入数字来手动设置该值。

提示:您还可以使用箭头键（上、下、左、右）来移动手柄。
注意:将鼠标悬停在滑块控件上时，将显示结果（在区域中找到的像素数）和通过范围值。
已关闭 自动按钮

自动将范围限制值设置为最新工具结果，工具结果最大值的 +/- 10%。例如，如果最大结果值为 255 且最新的工具结果值为 150，那么自动按钮会将最小范围值设置为 125 (=150 - 25)，最大范围值设置为 175 (=150 + 25)。

已关闭 反转结果

启用后，如果结果在指定的范围内失败，那么该工具也会显示失败。(默认 = Off)

通过/失败 | （反转） | 通过/失败
通过/失败 | （反转） | 通过/失败
已关闭 显示细节

定义所计数的像素是否总是在图像区域（突出显示黄色）显示。

提示:要在 VisionView 上显示计数的像素，请在通信应用程序步骤中的 EasyView 中选择 Show_Details，然后选中 VisionView 应用程序中的 Show_Details 复选框。有关如何在 VisionView 上显示数据的详情，请参阅配置 EasyView。
  • 打开（ [image] = 默认）：除非正在编辑其它定位或检测工具，否则计数的像素总是显示在图像区域中。

  • 关闭（ [image] ）：只有在编辑该工具时，计算的像素才会显示在图像区域中。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 名称

指定检测工具的名称。 默认名称为“ColorPixels_1”（如果它是添加到作业的第一个图案工具，之后的名称依次顺延，例如 “ColorPixels_2”、“ColorPixels_3” 等）。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 已启用

定义检测工具何时运行，或是否运行（默认设置为“开”）。

  • 如果你想要禁用该工具，请选择“关”。
  • 如果希望将该工具与特定的离散输入线路连接，请选择一条输入线，这时该工具可被“开启”或“关闭”（高电平信号 (1) 为“开”，低电平信号 (0) 为“关”）。将该工具与一个输入线路连接允许控制系统（如 PLC）来指定哪些工具可以运行以及何时运行。
已关闭 定位

为工具选择一个定位选项。当定位控制被启用时，定位按钮会变成橙色。

注意:只有在已经添加了用于定位的另一个工具时才能启用此控制。
已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

颜色训练内容栏

已关闭 选择要添加的颜色并选择要除去的颜色按钮。

  • 选择要添加的颜色：将“要添加的颜色”添加到颜色表中。 当确定区域中存在的像素数量的时候，将包括由此按钮所选择的颜色像素。 选择要添加的颜色后，区域内与选定颜色所匹配的所有像素将变为黄色。

    注意:此按钮选择的前 5 种颜色将在常规上下文窗格中显示为颜色图块。
    添加颜色之前 添加颜色之后
  • 选择要减去的颜色：将“要减去的颜色”添加到颜色表中。 当确定区域中存在的像素数量的时，将排除由此按钮所选择的颜色像素。

一旦点击了选择要添加的颜色或选择要除去的颜色按钮，并且光标移动到图像区域，则图像放大镜将在内容栏中显示，以帮助您找到要选择的颜色。

图像放大
已关闭 颜色表

  • 颜色：显示由选择要添加的颜色按钮和选择要除去的颜色按钮添加的颜色。

    注意:将鼠标悬停在滑块控件上时会显示 RGB 值。

  • 公差：定义颜色的公差设置（0 - 10；默认值 = 2）。 您可以增加/减少公差以包括更多/更少训练颜色的色调。

    注意:将鼠标悬停在滑块控件上时会显示公差值。
    原始图像

    公差 = 0.5

             公差 = 2（默认） 公差 = 7
  • 操作：
    • 更改为除去颜色：该颜色在区域中以黄色突出显示，并在确定区域中存在的像素数目时包括。 该按钮是一个切换按钮；要更改为除去颜色，请单击此按钮。
    • 更改为添加颜色：在确定区域中的像素数目时，不包括该颜色。 该按钮是一个切换按钮；要更改为添加颜色，请单击此按钮。

    • 上移/下移：更改表中颜色的操作顺序。 颜色操作将从上到下执行。

    • 删除颜色：从表中删除颜色。
已关闭 忽略亮度

当选中忽略亮度复选框（默认）时，将计算比训练的颜色更深/更浅的更多数量的像素。 如果图像强度在视野中不均匀时，该选项可以帮助提高该工具的性能。 但是，如果除了训练的颜色之外还需要计算黑色和/或白色像素时，则应取消选中此选项。

已关闭 完成颜色选择

返回一般内容栏

颜色操作示例

已关闭 示例

在此示例中，您要在图像中选择“蓝色”和“绿色”部分。

示例 1

  1. 使用选择要添加的颜色 [image] 按钮在图像中选择“蓝色”和“绿色”。

    原始图像 选择“蓝色（添加）”和“绿色（添加）”

  2. 结果，紫色部分也会被部分突出显示，因为这些颜色（蓝色，绿色和紫色）非常相似。 “紫色”来自“蓝色”（见下图）; 如果选择蓝色（或深青色）颜色，与紫色相似的颜色也会被选择。

  3. 现在需要从图像中减去“紫色”。 使用选择要减去的颜色 [image] 按钮从紫色突出显示区域中选择“紫色”。

    选择“紫色（去除）”
  4. 现在你就成功地选择了蓝色和绿色的部分。

示例 2

在这个例子中，你需要在图像中选择“蓝色”和“绿色”区域；但是，你可能无法达到所需的结果，因为颜色操作的顺序不同。

  1. 使用选择要添加的颜色 [image] 按钮在图像中选择“蓝色”。

  2. 使用选择要除去的颜色 [image] 按钮选择“紫色”。

    选择“蓝色（添加）”和“紫色（去除）”

  3. 使用选择要添加的颜色 [image] 按钮在图像中选择“绿色”。

    选择“绿色（添加）”
  4. 结果，紫色被部分突出显示，因为“绿色”和“紫色”非常相似。 如果选择绿色，也将选择紫色中与之相似颜色。
  5. 要从图像中去除“紫色”，请使用向下移动 [image] 按钮将紫色操作移动到底部。 或者，您可以在“绿色”之后使用选择要去除的颜色 [image] 按钮添加第二个紫色操作。


彩色像素计数存在/不存在工具 -常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Pixels_1”（如果该工具是添加到作业的第一个像素计数工具，之后名称将递增，如“Pixels_2”、“Pixels_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


颜色像素计数存在/不存在工具 - 设置选项卡

已关闭 训练颜色

启动“ExtractColor 训练”对话框，用于定义所选颜色库的颜色模型。

已关闭 颜色库

定义工具将引用的颜色库。从下拉列表中，选择要修改的颜色库，然后按训练颜色按钮启动“ExtractColor 训练”对话框。每个颜色库最多可包含 100 种不同的由各个颜色组成的颜色模型。

EasyBuilder 作业最多可包含 5 个颜色库，可在下列工具之间共享颜色库：

  • 彩色斑点定位工具
  • 彩色斑点 (1-10) 定位工具
  • 颜色像素计数存在/不存在工具
  • 彩色斑点面积测量工具
  • 彩色斑点面积 (1-10) 测量工具
  • 彩色斑点计数工具
  • 颜色模型识别工具
  • 颜色转为二进制图像过滤工具


颜色像素计数存在/不存在工具 - 范围限制选项卡

已关闭 最大值

定义区域中像素的最大可接受数；该工具将根据图像创建“智能限制”默认设置，这样可定义来满足应用程序的需要。

已关闭 像素

报告在区域中找到的像素数（值的范围为 0 到区域的最大面积）；正好位于或在最大和最小设置之间的值归类为“通过”。

已关闭 最小值

定义区域中像素的最小可接受数；该工具将根据图像创建“智能限制”默认设置，这样可定义来满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


颜色像素计数存在/不存在工具 - 颜色库选项卡

已关闭 颜色模型列表

显示所选颜色库中包含的颜色模型的只读列表。通过选中或取消选中颜色模型名称旁边的复选框来激活或禁用颜色模型。

已关闭 颜色表

显示所选颜色模型中颜色的只读排序表。

已关闭 颜色名称

显示所选颜色模型中颜色的名称。

已关闭 RGB

显示所选颜色模型中颜色的 RGB 值。

已关闭 运算

显示所选颜色模型中颜色的运算（加或减）。


“颜色像素计数存在/不存在”工具 - 复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


存在/不存在工具 - 斑点

斑点存在/不存在工具用于确定斑点特征是否存在。 如果检测到斑点，则工具报告斑点存在，工具的结果为通过。 如果未检测到斑点，或检测到的斑点超出指定的限制，则工具结果为失败。

斑点存在/不存在工具是速度更快的工具之一，该工具比图形存在/不存在工具能更快地定位斑点特征。 在您尝试验证是否存在由连接像素组成的特征时，该工具非常有用。 例如，验证金属部件上是否存在冲压孔。

设置工具

调整工具参数


设置斑点存在/不存在工具

选择工具后，需要选择区域类型，然后在您希望在其中检测斑点特征的图像中配置它：

  1. 从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。定位并配置图像中预计会出现斑点的区域；请确保该区域的边界覆盖斑点及其可能出现的位置。为了提高工具的性能，请创建较小的区域；区域越大，执行检测所需的时间就越长。如果不使用定位特征，请确保斑点在每个图像中出现在大致相同的位置，或该区域足够大以包括特征的预期移动位置。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整斑点存在/不存在工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

斑点存在/不存在工具的设置栏由以下选项卡组成：

  • 常规选项卡
  • 设置选项卡
  • 直方图选项卡
  • 组合区域选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

直方图选项卡

复合区域选项卡


斑点存在/不存在工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Blob_1”（如果该工具是添加到作业的第一个斑点工具，之后名称将递增，如“Blob_2”、“Blob_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


斑点存在/不存在工具 - 设置选项卡

已关闭 阈值模式

定义确定用于从背景中分离斑点的灰度值的模式。当选择“自动”（默认值 = 自动）时，每次采集图像工具均会针对不同图像间的亮度变化进行调整。当选择“手动”时，需要手动输入和调整该值。

已关闭 斑点阈值

定义用于从背景中分离斑点的灰度值（启用时为 0 - 255）。默认情况下此控制为“关”，要启用该控制，需要将“阈值模式”设置为“手动”。使用图形为应用程序设置最佳值。

已关闭 斑点颜色

定义斑点的颜色（黑色、白色或二者之一；默认值 = 二者之一）。

  • 二者之一 = 对斑点颜色没有要求。
  • 黑色 = 只返回斑点阈值以下的斑点。
  • 白色 = 只返回斑点阈值以上的斑点。
已关闭 边界

定义管理与斑点区域边界相交的斑点的两种方法之一（默认值 = 关，未选中）：

  • 未选中 – 不包括与区域边界相交的斑点。即，斑点必须完全位于要检测的区域内部。
  • 选中 – 包括与区域边界相交的斑点。即，只要相交的斑点符合其它条件，就会对其进行检测。
已关闭 最小区域

为所有检测的斑点定义最小区域限制，以像素数为单位（0 到 900000；默认值 = 100）,将只识别区域大于“最小区域”的斑点。

已关闭 最大区域

为所有检测的斑点定义最大区域限制，以像素数为单位（0 到 900000；默认值 = 100000），将只识别区域小于“最大区域”的斑点。

已关闭 结果

显示工具的结果：存在，如果检测到斑点特征；不存在，如果未检测到该特征，或找到的斑点超出了指定的限制范围。存在等同于布尔型值 1（通过）；不存在等同于布尔型值 0（失败）。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。


斑点存在/不存在工具 - 直方图选项卡

直方图以图形方式显示区域内像素的灰度值。

  • 图形的 X 轴表示灰度值的总数（0 到 255，或总计 256 个灰度级）。
  • 图形的 Y 轴表示给定灰度值的像素数，通过显示具有最大像素数的灰度值建立标度。
  • 蓝色的垂直线指示用于将图像区域区分为黑色和白色像素的阈值；线左侧的值被视为黑色，而线右侧的值被视为白色。
注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


斑点存在/不存在工具 - 复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


存在/不存在工具 - 颜色斑点

颜色斑点存在/不存在工具可以用来确定颜色斑点特征是否存在。

颜色斑点工具引用经过训练的颜色模型库，然后确定区域中与训练库中选定和训练的颜色模型匹配的像素数。 该工具随后会创建一个二进制灰度输出图像，其中与活动颜色模型匹配的每个像素均设置为白色 (255)，而其它所有像素均设置为黑色 (0)。 使用此二进制输出图像，该工具然后在图像中搜索由活跃颜色模型创建的斑点特征。

设置工具

调整工具参数


设置彩色斑点存在/不存在工具

选择工具后，需要选择区域类型，然后在您希望在其中检测斑点特征的图像中配置它：

  1. 从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。定位并配置图像中预计会出现斑点的区域；请确保该区域的边界覆盖斑点及其可能出现的位置。为了提高工具的性能，请创建较小的区域；区域越大，执行检测所需的时间就越长。如果不使用定位特征，请确保斑点在每个图像中出现在大致相同的位置，或该区域足够大以包括特征的预期移动位置。添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 配置搜索区域后，需要配置该工具的颜色库并激活相应的颜色模型：

    • 如果这是首次添加颜色工具（“彩色斑点”与“彩色斑点 (1-10)”定位工具、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”与“彩色斑点面积 (1-10)”测量工具、“彩色斑点”计数工具、“颜色模型”识别工具或“颜色转为二进制”图像过滤工具），需要首先定义颜色库及其颜色模型。
    • 如果先前已添加另一个颜色工具，并且想要利用现有颜色库及其训练的颜色模型，请转到“设置”选项卡并选择所需的颜色库，然后在“库”选项卡中选中所需颜色模型以将其激活。

    • 默认情况下，工具将自动产生“失败”，直至定义颜色库。如果已定义颜色库，则工具将自动使用该库并激活其包含的所有颜色模型。

  4. 设置颜色模型和颜色库后，该工具将处理图像，搜索区域内与所选颜色模型匹配的所有像素都会变为白色 (255)，而与颜色模型不匹配的像素则会变为黑色 (0)。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整彩色斑点存在/不存在工具

在设置完工具的区域后，你可以开始优化应用程序工具。

彩色斑点存在/不存在工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 颜色库选项卡
  • 组合区域选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

复合区域选项卡

颜色库


彩色斑点存在/不存在工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Pixels_1”（如果该工具是添加到作业的第一个像素计数工具，之后名称将递增，如“Pixels_2”、“Pixels_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


“颜色斑点存在/不存在”工具 -“设置”选项卡

已关闭 训练颜色

启动“ExtractColor 训练”对话框，用于定义所选颜色库的颜色模型。

已关闭 颜色库

定义工具将引用的颜色库。从下拉列表中，选择要修改的颜色库，然后按训练颜色按钮启动“ExtractColor 训练”对话框。每个颜色库最多可包含 100 种不同的由各个颜色组成的颜色模型。

EasyBuilder 作业最多可包含 5 个颜色库，可在下列工具之间共享颜色库：

  • 彩色斑点定位工具
  • 彩色斑点 (1-10) 定位工具
  • 颜色像素计数存在/不存在工具
  • 彩色斑点面积测量工具
  • 彩色斑点面积 (1-10) 测量工具
  • 彩色斑点计数工具
  • 颜色模型识别工具
  • 颜色转为二进制图像过滤工具
已关闭 边界

定义如何处理与斑点区域边界相交的斑点（默认=关，未选中）

  • 未选中 - 不包括与区域边界相交的斑点；斑点必须完全位于要检查的区域内部。
  • 选中 - 包括与区域边界相交的斑点；只要斑点符合其它条件，就会被检测到。
已关闭 最小区域

以像素数为单位（0 到 16777216；默认值 = 100）为所有检测的斑点定义最小面积限制；将只识别面积大于“最小面积”的斑点。

已关闭 最大区域

以像素数为单位（0 到 16777216；默认值 = 100000）为所有检测的斑点定义最大面积限制；将只识别面积小于“最大面积”的斑点。

已关闭 平滑因子

定义平滑图像的平滑值 (0 至 25; 默认 = 1)。如不需要平滑图像，则可将该值设置为 0。

已关闭 显示原始图像
  • 取消选中（默认）：所选区域显示二进制灰度输出图像。
  • 已选中：所选区域显示原始输入图像。
已关闭 反转结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 结果

显示工具的结果：存在，如果检测到斑点特性；不存在，如果没有检测到，或发现的斑点在指定的范围之外。 显示等于Boolean 值 1（通过）; 不显示等于 Boolean 值 0（失败）。


“彩色斑点存在/不存在”工具 - 复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


彩色斑点存在/不存在工具 - 颜色库

已关闭 颜色模型列表

显示所选颜色库中包含的颜色模型的只读列表。通过选中或取消选中颜色模型名称旁边的复选框来激活或禁用颜色模型。

已关闭 颜色表

显示所选颜色模型中颜色的只读排序表。

已关闭 颜色名称

显示所选颜色模型中颜色的名称。

已关闭 RGB

显示所选颜色模型中颜色的 RGB 值。

已关闭 运算

显示所选颜色模型中颜色的运算（加或减）。


存在/不存在工具 - 边

边存在/不存在工具用于确定位于指定参数范围内线的边特征存在或不存在。

边存在/不存在工具是较快的工具之一，其识别边特征的速度比图案存在/不存在工具快得多。

该工具将返回以下结果：

In-Sight 型号 | 结果
In-Sight 2000 系列 1XX 视觉传感器 (110, 120, 130) | 仅限通过/失败状态
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 标准结果（无限制）

设置工具

调整工具参数


使用边存在/不存在工具

添加该工具之后，需要选择区域类型，然后在图像中进行配置以分隔特征：

  1. 沿边特征定位线区域。

    已关闭 示例

    沿边特征定位线区域。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. EasyBuilder 将自动在选定的边特征周围创建边缘区域。

    已关闭 示例

    自动创建的区域。

  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整边存在/不存在工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

边位置工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 图形
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

图形


边存在/不存在工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Edge_1”（如果该工具是添加到作业的第一个边工具，之后名称将递增，如“Edge_2”、“Edge_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


边缘存在/不存在工具 - 设置选项卡

已关闭 边缘对比

定义发现的边所容许的最小边缘对比度得分（1-100；默认值为智能设置，该值会自动递减，直到检测到边）。此设置确定该工具的边检测灵敏度，即区别特征和背景的能力；将此设置与工具的图形连用，可设置容许的范围。

注意:如果该参数设置为0，则工具可能会找出未预计到的边。
已关闭 标准化得分

定义是否通过该区域的灰度直方图来标准化边缘分数。此参数对于查找低对比度区域中的边缘非常有用。如果要检测的边缘仅为高对比度，请禁用此参数。

  • 选中（默认）：标准化得分。
  • 未选中：不要将分数标准化。
已关闭 边缘过渡

定义边的转换（“由深到浅”、“由浅到深”或“两者”；默认值 =“两者”）。为了增加精确度和速度，可指定转换的类型。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 50；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 查找依据

定义存在多个边时，该工具如何区别找到的边（默认值 =“最佳得分”）。

  • 最佳得分 = 具有最高对比度边的边特征。
  • 第一条边 = 最接近区域扫描方向起点的边特征。
  • 最后的边 = 最远离区域扫描方向起点的边特征。
已关闭 角度范围

定义找到的边所允许的最大角度变化范围（0-10°；默认值= 10°）。允许角度偏差越高，工具执行所需的时间越长。

已关闭 结果

显示工具的结果： 存在 如果检测到边缘特征； 不存在 如果未检测到或找到的边缘超出指定限制。 存在 等于布尔值 1（通过）： 不存在 等于布尔值 0（失败）。

已关闭 反转结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。


边存在/不存在工具 - 图形

图形是区域中所包含灰度值的一阶导数的表示；波峰和波谷表示主要边转换。

对于检测边的工具（“边”和“圆”工具），得分轴表示所发现边与已定义参数的符合程度：

  • 正得分表示由深到浅的边转换；
  • 负得分表示由浅到深的边转换；
  • 得分为 0 表示未检测到边。

偏移轴指示定义边特性的区域，其中 0 代表区域的开始边界，而其它值代表区域的最大宽度（以像素为单位）。沿偏移轴的波峰或波谷的顶点指示所发现边的位置。

注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


存在/不存在工具 - 圆

圆存在/不存在工具用于确定位于指定参数范围内圆边的特征是否存在。

圆位置工具是运行较快的工具之一，它识别边特征的速度要比图案存在/不存在工具快得多。

该工具将返回以下结果：

In-Sight 型号 | 结果
In-Sight 2000 系列 1XX 视觉传感器 (110, 120, 130) | 仅限通过/失败状态
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 标准结果（无限制）

设置工具

调整工具参数


设置圆存在/不存在工具

添加该工具之后，需要选择区域类型，然后在图像中进行配置以分隔特征：

  1. 将圆形区域直接定位在圆形边特征之上并进行配置，确保调整圆形区域的大小以匹配圆特征的大小和尺寸。

    已关闭 示例

    将圆形区域置于特征之上

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. EasyBuilder 会围绕该圆形边特征自动创建环形边区域。

    已关闭 示例

    围绕圆形边特征的环形区域

  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整圆存在/不存在工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

圆存在/不存在工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 图形
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

图形


圆存在/不存工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Circle_1”（如果该工具是添加到作业的第一个圆工具，之后名称将递增，如“Circle_2”、“Circle_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


圆存在/不存在工具 - 设置选项卡

已关闭 边缘对比

定义找到的边的最小可接受边对比度分数（1-100；默认=“智能设置”，在检测到边缘之前自动递减）。该设置决定了工具的边缘检测灵敏度，即区分特征和背景的能力；将此设置与工具的 图形 结合使用来设置可接受的范围。

注意:如果该参数设置为0，则工具可能会找出未预计到的边。
已关闭 标准化得分

定义是否通过该区域的灰度直方图来标准化边缘分数。此参数对于查找低对比度区域中的边缘非常有用。如果要检测的边缘仅为高对比度，请禁用此参数。

  • 选中（默认）：标准化得分。
  • 未选中：不要将分数标准化。
已关闭 边缘过渡

定义边的转换（“由深到浅”、“由浅到深”或“两者”；默认值 =“两者”）。为了增加精确度和速度，可指定转换的类型。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 50；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 查找依据

定义存在多个圆形边时，该工具如何区别找到的圆形边（默认值 = 最佳得分）。

  • 最佳得分 = 选择具有最高对比度的圆形边特征。
  • 最小圆 = 将选择具有最小直径的圆形边特性。
  • 最大圆 = 将选择具有最大直径的圆形边特征。
已关闭 结果

显示工具的结果： 存在 如果检测到圆形边缘特征； 不存在 如果未检测到或找到的圆形边缘超出指定限制。 存在 等于布尔值 1（通过）： 不存在 等于布尔值 0（失败）。

已关闭 反转结果
定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。


圆存在/不存在工具 - 图形

图形是区域中所包含灰度值的一阶导数的表示；波峰和波谷表示主要边转换。

对于检测边的工具（“边”和“圆”工具），得分轴表示所发现边与已定义参数的符合程度：

  • 正得分表示由深到浅的边转换；
  • 负得分表示由浅到深的边转换；
  • 得分为 0 表示未检测到边。

偏移轴指示定义边特性的区域，其中 0 代表区域的开始边界，而其它值代表区域的最大宽度（以像素为单位）。沿偏移轴的波峰或波谷的顶点指示所发现边的位置。

注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


存在/不存在工具 - 清晰度

清晰度存在/不存在工具会根据区域内的图像清晰度得分来确定图像是否正确聚焦。 该工具计算输入图像的相对焦点，作为重新聚焦 In-Sight 视觉系统镜头过程的一部分。

图像清晰度分数用来指示图像内的区域包括场景中的最小可分辨特征（即，在图像中捕获的对象及其背景）的程度。

设置工具

调整工具参数


设置清晰度存在/不存在工具

添加工具之后，需要在图像中配置区域：

  1. 将区域定位在图像内使其包围“场景”中重要的部件（即对象及其背景）。为了帮助提高该工具的性能，请创建较小的区域；区域越大，执行检查所需的时间越长。如果没有使用定位特征，请确保要测量的场景在每个图像中出现在相同的位置。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 添加工具后，图像清晰度值必须与另一从相同或同等场景（即对象及其背景相同、In-Sight视觉系统保持相同的方向和位置、灯光相同，等等）中取得的图像清晰度值比较。单个图像的清晰度值不能传达足够图像内区域的绝对清晰度信息。
  4. 转到设置图像步骤并输入实况视频模式。确保场景中没有东西被改变，并重新聚焦In-Sight视觉系统的镜头。
  5. 退出实况视频模式。该工具会计算一个新的图像清晰度值。
  6. 将新的值与之前的值相比较。值越高，聚焦越清晰。
  7. 重复步骤4到5，直至聚焦被视为接受。
注意:如果聚焦始终处于未被接受状态，可考虑更换镜头，调节镜头与对象之间的距离，或调整其它在“设置图像应用”步骤中的获取参数。


调整清晰度存在/不存在工具参数

在设置完工具的区域后，你可以开始优化应用程序工具。

清晰度存在/不存在工具设置窗格包含以下选项：

  • 常规选项卡
  • 范围限制选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

范围限制选项卡


清晰度存在/不存在工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Sharpness_1”（如果该工具是添加到作业的第一个清晰度工具，之后名称将递增，如“Sharpness_2”、“Sharpness_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


清晰度存在/不存在工具 - 范围限制选项卡

已关闭 最大

定义最大可接受图像清晰度值。该工具将根据图像创建“智能限制”默认设置，可对其进行自定义以满足应用程序的需要。

已关闭 清晰度

报告区域内的图像清晰度值。正好落在或介于最大值与最小值设置之间的值被归类为“通过”。

已关闭 最小

定义最小可接受的平均图像清晰度值。该工具将根据图像创建“智能限制”默认设置，可对其进行自定义以满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


测量工具 - 距离

距离测量工具被用来计算任意两个输入特征间的距离，并报告所计算出的距离。

注意:. 该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

距离测量工具在您需要精确测量部件或对象的情况下极为有用。 例如，确定部件末端之间的距离或两孔之间中心到中心的距离。

设置工具

调整工具参数


设置距离测量工具

添加该工具之后，需要定义将要测量的特征：

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 首先，从可用特征中选择一个特征（只需单击该特征即可，这时其颜色将变为洋红，且该特征中会延伸出一条直线）。
  3. 接着，选择第二个特征。
  4. 在选择第二个特征之后，EasyBuilder 将会自动计算特征间的距离。 EasyBuilder 还将为先前未定义的所有特征插入“边存在/不存在”工具和/或“圆存在/不存在”工具（根据工具和特征的类型）。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整距离测量工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

距离测量工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 范围限制选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

范围限制选项卡


距离测量工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Distance_1”（如果该工具是添加到作业的第一个距离工具，之后名称将递增，如“Distance_2”、“Distance_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


距离测量工具 - 设置选项卡

已关闭 测量

指定将会如何计算两个边特征间的距离：中点到直线（测量边片段间的垂直距离；默认设置）或中点到中点。

注意:

该控制仅当测量至少一个边特征间的距离时启用；否则会以下列方式自动计算此距离：

  • 圆到线：从圆心到边特征或参考线的垂直交点进行测量。
  • 点到线：从点到边特征或参考线的垂直交点进行测量。
  • 圆到点：从圆心到点进行测量。
  • 圆到圆：从一个圆心到另一个圆心进行测量。
  • 点到点：从两点测量。

点涉及到先前定义的特征、斑点、圆、边、图形或点，且通过如下方案识别：

  • 斑点：从斑点质心的 X,Y 坐标测量。
  • 圆：从圆的 X,Y 中心坐标测量。
  • 边：从边的 X,Y 中点坐标测量。
  • 图形：从模型图形的 X,Y 原点坐标测量。
  • 点：从点的 X,Y 坐标测量。


距离测量工具 - 范围限制选项卡

已关闭 最大值

定义最大可接受距离值；该工具将根据图像创建“智能限制”默认设置，这样可定义来满足应用程序的需要。

已关闭 距离

报告当前在两种特性间测量的距离；正好位于或在最大和最小设置之间的值归类为“通过”。

注意:该工具会以像素为单位报告测量，除非已在设置图像中为该图像分配了实际的单位。
已关闭 最小值

定义最小可接受距离值；该工具将根据图像创建“智能限制”默认设置，这样可定义来满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，例如，在此函数被检测时工具结果为“通过”且位于范围限制内。
  • 选中 - 反向结果，例如，在此函数被检测时工具结果为“失败”且位于范围限制内。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


测量工具 - 角度

角度测量工具用来计算两条边特征之间的角度。

角度测量工具在需要精确测量部件或对象的情况下非常有用。

设置工具

调整工具参数


设置角度测量工具

添加该工具之后，需要定义将要测量的输入特征。

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 首先，从可用特征中选择一个特征（只需单击该特征即可，这时其颜色将变为洋红，且该特征中会延伸出一条直线）。
  3. 接着，选择第二个特征。
  4. 当选择第二个特征之后，EasyBuilder 将自动计算特征间的角度，并在图像中绘制一个图形来表示两边相交处以及要测量的角度。 EasyBuilder 还将为先前未定义的所有特征插入“边存在/不存在”工具和/或“圆存在/不存在”工具（根据工具和特征的类型）。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整角度测量工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

角度测量工具的设置窗格包含以下内容：

  • 常规选项卡
  • 范围限制选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

范围限制选项卡


角度测量工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Angle_1”（如果该工具是添加到作业的第一个角度工具，之后名称将递增，如“Angle_2”、“Angle_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


角度测量工具 - 范围限制选项卡

已关闭 最大值

定义最大可接受角度值；该工具将根据图像创建“智能限制”默认设置，这样可定义来满足应用程序的需要。

已关闭 距离

报告当前在两种函数间测量的角度；正好位于或在最大和最小设置之间的值归类为“通过”。

注意:该工具会以像素为单位报告 X、Y 坐标，除非已在设置图像中为该图像分配了实际的单位。
已关闭 最小值

定义最小可接受角度值；该工具将根据图像创建“智能限制”默认设置，这样可定义来满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，例如，在此函数被检测时工具结果为“通过”且位于范围限制内。
  • 选中 - 反向结果，例如，在此函数被检测时工具结果为“失败”且位于范围限制内。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


测量工具 -“斑点面积”与“斑点面积 (1-10)”

斑点区域测量工具和斑点区域（1-10）测量工具测量找到的最大斑点特征的面积，并报告最大斑点的尺寸。 斑点区域工具用于测量单个斑点，而斑点区域（1-10）工具则用于测量最多10个斑点。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

斑点区域和斑点区域（1-10）测量工具在您尝试测量特征的预期区域或检测通孔堵塞的情况下将非常有用。

设置工具

调整工具参数


设置斑点面积和斑点面积 (1-10) 测量工具

选择工具后，需要选择区域类型，然后在您希望在其中检测斑点特征的图像中配置它：

  1. 从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。定位并配置图像中预计会出现斑点的区域；请确保该区域的边界覆盖斑点及其可能出现的位置。为了提高工具的性能，请创建较小的区域；区域越大，执行检测所需的时间就越长。如果不使用定位特征，请确保斑点在每个图像中出现在大致相同的位置，或该区域足够大以包括特征的预期移动位置。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整斑点面积和斑点面积 (1-10) 测量工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

斑点面积和斑点面积 (1-10) 测量工具的设置窗格包含以下选项卡：

  • 常规选项卡
  • 设置选项卡
  • 范围限制选项卡
  • 表选项卡
  • 直方图选项卡
  • 组合区域选项卡
注意:
  • 当使用该工具失败时，直方图将不会显示。
  • 仅对一个斑点面积 (1-10) 测量工具启用表格选项卡。
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

范围限制选项卡

表

直方图

复合区域选项卡


斑点面积与斑点面积 (1-10) 测量工具 – 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Blob_1”（如果该工具是添加到作业的第一个斑点工具，之后名称将递增，如“Blob_2”、“Blob_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


“斑点面积”与“斑点面积 (1-10)”测量工具 -“设置”选项卡

已关闭 阈值模式

定义用于从背景中分离斑点的灰度值的模式。当选择“自动”（默认=自动）时，每次采集图像，该工具会对每张图像的亮度进行自动调整。当选择“手动”时，需要手动输入和调整该值。

已关闭 斑点阈值

定义用于从背景中分离斑点的灰度值（启用时为 0 - 255）。默认情况下此控制为“关”，要启用该控制，需要将“阈值模式”设置为“手动”。使用直方图设置应用程序的最佳值。

已关闭 斑点颜色

定义斑点的颜色（黑色、白色、黑色或白色；默认=黑色或白色）。

  • 黑色或白色 = 对斑点颜色没有要求
  • 黑色 = 只返回斑点阈值以下的斑点。
  • 白色 = 只返回斑点阈值以上的斑点。
已关闭 边界

定义如何处理与斑点区域边界相交的斑点（默认=关，未选中）

  • 未选中 - 不包括与区域边界相交的斑点；斑点必须完全位于要检查的区域内部。
  • 选中 - 包括与区域边界相交的斑点；只要斑点符合其它条件，就会被检测到。
已关闭 最小面积限制

为检测斑点定义最小面积限制，以像素为单位（0 到 16777216；默认=50）；仅返回面积大于最小面积限制值的斑点。

注意: 范围限制选项卡中的最小参数将决定工具通过还是失败，而最小面积限制参数则决定是否报告所找到的斑点。
已关闭 最大面积限制

为检测斑点定义最大面积限制，以像素为单位（0 到 16777216；默认=307,200）；仅返回面积小于最大面积限制值的斑点。

注意: 范围限制选项卡中的最大参数将决定工具通过还是失败，而最大面积限制参数则决定是否报告所找到的斑点。
已关闭 要查找的数量

定义应检测到的斑点数量（1-10；默认 = 1）。多数应用程序只需要单个定位特征，但可以定位多个斑点，这在图像中有多个部件或对象的应用程序中很有用。要求工具识别的斑点越多，该工具的执行时间越长。

已关闭 排序方式

定义工具将如何测量和排序所找到的斑点（面积、行、列；网格：行，然后列，相对定位特征；网格：列，然后行，相对定位特征；相对定位特征的距离；相对固定行轴逆时针旋转的角度；角距离。默认 = 区域）：

  • 面积 = 按所找到斑点的面积从最大到最小排序。
  • 行 = 按与图像行轴之间的距离从最近到最远降序排列。
  • 列 = 按与图像列轴之间的距离从最近到最远降序排列。
  • 网格：行，然后列，相对定位特征 = 首先按相对定位特征的图像行轴的距离，然后按相对图像列轴的距离，从最近到最远降序排列。
  • 网格：列，然后行，相对定位特征 = 首先按相对定位特征的图像列轴的距离，然后按相对图像行轴的距离，从最近到最远降序排列。
  • 相对定位特征的距离 = 按定位特征与斑点质心之间的距离从最近到最远降序排列。
  • 相对固定行轴逆时针旋转的角度 = 按所测量的从定位特征的图像行轴到线段（由斑点质心和定位特征定义）之间的角度（0 到 360°），从最近到最远降序排列。
  • 角距离 = 按所测量的从定位特征的图像行轴到线段（由斑点质心和定位特征定义）之间的角度（-180° 到 180°）的绝对值，从最近到最远排序。
注意:斑点面积测量工具不包含要查找的数量参数。


斑点面积与斑点面积 (1-10) 测量工具 – 范围限制选项卡

已关闭 最大值

定义最大可接受斑点区域值。该工具将根据图像创建“智能限制”默认设置，可对其进行自定义以满足应用程序的需要。

已关闭 斑点区域

报告当前测量的斑点区域。正好落在或介于最大值与最小值设置之间的值被归类为“通过”。

注意:该工具会以像素为单位报告测量，除非已在设置图像中将该图像校准为实际的单位。
已关闭 最小值

定义最小可接受斑点区域值。该工具将根据图像创建“智能限制”默认设置，可对其进行自定义以满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


斑点面积 (1-10) 测量工具 - 表格

注意:
  • 斑点测量工具不支持表选项卡；该选项卡只能用于斑点 (1-10) 测量工具。
  • 当 排序方式参数被设置为除 区域以外的任何选项时，像素行 和 像素列 栏将被添加到表格中。像素行 和 像素列 指的是以 In-Sight 视觉系统图像传感器（行和列数组）二维网格为基础的图像坐标。该坐标 (Y/X) 与现实世界中的坐标 (X/Y)相反。

  • 如果在设置图像步骤的根据实际单位校准图像组框中启用（选中）了典型方向，则 X 和 Y 坐标将与图像坐标 (Y/X) 位于同一坐标空间。

表选项卡根据设置选项卡中的要查找的数量参数发布所找到斑点的结果：

已关闭 索引

表示所找到斑点的顺序，基于设置选项卡中的排序方式参数；1 至 10（EasyBuilder 中的数字排序基于 0=1）。

已关闭 面积

返回所找到斑点的面积（以像素为单位测量）。

已关闭 X

返回所找到斑点的质心的 X 坐标。除非已在设置图像中将图像校准为实际单位，否则工具将以像素为单位报告结果。

已关闭 Y

返回所找到斑点的质心的 Y 坐标。除非已在设置图像中将图像校准为实际单位，否则工具将以像素为单位报告结果。

已关闭 角度

返回所找到斑点的质心相对于区域中心的角度。

已关闭 错误

返回所找到斑点的错误结果（如果遇到错误）。

已关闭 像素行

返回所找到斑点的质心的图像行 (X) 坐标。

已关闭 像素列

返回所找到斑点的质心的图像列 (Y) 坐标。


斑点面积与斑点面积 (1-10)测量工具–直方图

直方图以图形方式显示区域内像素的灰度值。

  • 图形的 X 轴表示灰度值的总数（0 到 255，或总计 256 个灰度级）。
  • 图形的 Y 轴表示给定灰度值的像素数，通过显示具有最大像素数的灰度值建立标度。
  • 蓝色的垂直线指示用于将图像区域区分为黑色和白色像素的阈值；线左侧的值被视为黑色，而线右侧的值被视为白色。
注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


斑点面积与斑点面积 (1-10)测量工具– 复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


测量工具 -“颜色斑点面积”与“颜色斑点面积 (1-10)”

颜色斑点区域和颜色斑点区域（1-10）测量工具测量找到的最大斑点特征的面积，并报告最大斑点的大小。 颜色斑点区域工具用于测量单个斑点，而颜色斑点区域（1-10）工具用于测量最多10个斑点。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

颜色斑点区域和颜色斑点区域（1-10）工具引用经过训练的颜色模型库，然后确定区域中与图库中选定和训练的颜色模型匹配的像素数。 该工具随后会创建一个二进制灰度输出图像，其中与活动颜色模型匹配的每个像素均设置为白色 (255)，而其它所有像素均设置为黑色 (0)。 使用此二进制输出图像，该工具然后在图像中搜索由活跃颜色模型创建的斑点特征。

设置工具

调整工具参数


设置彩色斑点面积和彩色斑点面积 (1-10) 测量工具

选择工具后，需要选择区域类型，然后在您希望在其中检测斑点特征的图像中配置它：

  1. 从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。定位并配置图像中预计会出现斑点的区域；请确保该区域的边界覆盖斑点及其可能出现的位置。为了提高工具的性能，请创建较小的区域；区域越大，执行检测所需的时间就越长。如果不使用定位特征，请确保斑点在每个图像中出现在大致相同的位置，或该区域足够大以包括特征的预期移动位置。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 配置搜索区域后，需要配置该工具的颜色库并激活相应的颜色模型：

  4. 如果这是首次添加颜色工具（“彩色斑点”与“彩色斑点 (1-10)”定位工具、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”与“彩色斑点面积 (1-10)”测量工具、“彩色斑点”计数工具、“颜色模型”识别工具或“颜色转为二进制”图像过滤工具），需要首先定义颜色库及其颜色模型。

  5. 如果先前已添加另一个颜色工具，并且想要利用现有颜色库及其训练的颜色模型，请转到“设置”选项卡并选择所需的颜色库，然后在“库”选项卡中选中所需颜色模型以将其激活。

  6. 默认情况下，工具将自动产生“失败”，直至定义颜色库。如果已定义颜色库，则工具将自动使用该库并激活其包含的所有颜色模型。

  7. 设置颜色模型和颜色库后，该工具将处理图像，搜索区域内与所选颜色模型匹配的所有像素都会变为白色 (255)，而与颜色模型不匹配的像素则会变为黑色 (0)。
  8. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  9. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整彩色斑点面积和彩色斑点面积 (1-10) 测量工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

彩色斑点面积和彩色斑点面积 (1-10) 测量工具的设置窗格包含以下选项卡：

  • 常规选项卡
  • 设置选项卡
  • 范围限制选项卡
  • 颜色库选项卡
  • 表选项卡
  • 组合区域选项卡
注意:仅对彩色斑点面积 (1-10) 测量工具启用表选项卡。
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

范围限制选项卡

库选项卡

表格选项卡

复合区域选项卡


彩色斑点区域与彩色斑点区域 (1-10) 测量工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“ColorBlobAreas_1”（如果该工具是添加到作业的第一个彩色斑点区域工具，之后名称将递增，如“ColorBlobAreas_2”、“ColorBlobAreas_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


“颜色斑点面积”与“颜色斑点面积 (1-10)”测量工具 - 设置选项卡

已关闭 训练颜色

启动“ExtractColor 训练”对话框，用于定义所选颜色库的颜色模型。

已关闭 颜色库

定义工具将引用的颜色库。从下拉列表中，选择要修改的颜色库，然后按训练颜色按钮启动“ExtractColor 训练”对话框。每个颜色库最多可包含 100 种不同的由各个颜色组成的颜色模型。

EasyBuilder 作业最多可包含 5 个颜色库，可在下列工具之间共享颜色库：

  • 彩色斑点定位工具
  • 彩色斑点 (1-10) 定位工具
  • 颜色像素计数存在/不存在工具
  • 彩色斑点面积测量工具
  • 彩色斑点面积 (1-10) 测量工具
  • 彩色斑点计数工具
  • 颜色模型识别工具
  • 颜色转为二进制图像过滤工具
已关闭 边界

定义如何处理与斑点区域边界相交的斑点（默认=关，未选中）

  • 未选中 - 不包括与区域边界相交的斑点；斑点必须完全位于要检查的区域内部。
  • 选中 - 包括与区域边界相交的斑点；只要斑点符合其它条件，就会被检测到。
已关闭 排序方式

定义工具将如何测量和排序所找到的斑点（面积、行、列；网格：行，然后列，相对定位特征；网格：列，然后行，相对定位特征；相对定位特征的距离；相对固定行轴逆时针旋转的角度；角距离。默认 = 区域）：

  • 面积 = 按所找到斑点的面积从最大到最小排序。
  • 行 = 按与图像行轴之间的距离从最近到最远降序排列。
  • 列 = 按与图像列轴之间的距离从最近到最远降序排列。
  • 网格：行，然后列，相对定位特征 = 首先按相对定位特征的图像行轴的距离，然后按相对图像列轴的距离，从最近到最远降序排列。
  • 网格：列，然后行，相对定位特征 = 首先按相对定位特征的图像列轴的距离，然后按相对图像行轴的距离，从最近到最远降序排列。
  • 相对定位特征的距离 = 按定位特征与斑点质心之间的距离从最近到最远降序排列。
  • 相对固定行轴逆时针旋转的角度 = 按所测量的从定位特征的图像行轴到线段（由斑点质心和定位特征定义）之间的角度（0 到 360°），从最近到最远降序排列。
  • 角距离 = 按所测量的从定位特征的图像行轴到线段（由斑点质心和定位特征定义）之间的角度（-180° 到 180°）的绝对值，从最近到最远排序。
已关闭 要查找的数量

定义应检测到的斑点数量（1-10；默认 = 1）。要求工具识别的斑点越多，该工具的执行时间越长。

注意:此控件仅对颜色斑点面积 (1-10) 测量工具可用。
已关闭 最小面积限制

为检测斑点定义最小面积限制，以像素为单位（0 到 16777216；默认=100）；仅返回面积大于最小面积限制值的斑点。

注意: 范围限制选项卡中的最小参数将决定工具通过还是失败，而最小面积限制参数则决定是否报告所找到的斑点。
已关闭 最大面积限制

为检测斑点定义最大面积限制，以像素为单位（0 到 16777216；默认=100000）；仅返回面积小于最大面积限制值的斑点。

注意: 范围限制选项卡中的最大参数将决定工具通过还是失败，而最大面积限制参数则决定是否报告所找到的斑点。
已关闭 平滑因子

定义平滑图像的平滑值 (0 至 25; 默认 = 1)。如不需要平滑图像，则可将该值设置为 0。

已关闭 显示原始图像
  • 取消选中（默认）：所选区域显示二进制灰度输出图像。
  • 已选中：所选区域显示原始输入图像。


彩色斑点面积与彩色斑点面积 (1-10) 测量工具 - 范围限制选项卡

已关闭 最大值

定义最大可接受斑点面积值。该工具将根据图像创建“智能限制”默认设置，可对其进行自定义以满足应用程序的需要。

已关闭 斑点面积

报告当前测量的斑点面积。正好落在或介于最大值与最小值设置之间的值被归类为“通过”。

注意:该工具会以像素为单位报告测量，除非已在设置图像中将该图像校准为实际的单位。
已关闭 最小值

定义最小可接受斑点面积值。该工具将根据图像创建“智能限制”默认设置，可对其进行自定义以满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


彩色斑点面积与彩色斑点面积 (1-10) 测量工具 - 库选项卡

已关闭 颜色模型列表

显示所选颜色库中包含的颜色模型的只读列表。通过选中或取消选中颜色模型名称旁边的复选框来激活或禁用颜色模型。

已关闭 颜色表

显示所选颜色模型中颜色的只读排序表。

已关闭 颜色名称

显示所选颜色模型中颜色的名称。

已关闭 RGB

显示所选颜色模型中颜色的 RGB 值。

已关闭 运算

显示所选颜色模型中颜色的运算（加或减）。


彩色斑点面积 (1-10) 测量工具 - 表格选项卡

注意:
  • 彩色斑点面积测量工具不支持表选项卡；该选项卡只能用于彩色斑点面积 (1-10) 测量工具。
  • 当 排序方式参数被设置为除 区域以外的任何选项时，像素行 和 像素列 栏将被添加到表格中。像素行 和 像素列 指的是以 In-Sight 视觉系统图像传感器（行和列数组）二维网格为基础的图像坐标。该坐标 (Y/X) 与现实世界中的坐标 (X/Y)相反。

  • 如果在设置图像步骤的根据实际单位校准图像组框中启用（选中）了典型方向，则 X 和 Y 坐标将与图像坐标 (Y/X) 位于同一坐标空间。

表选项卡根据设置选项卡中的要查找的数量参数发布所找到斑点的结果：

已关闭 索引

表示所找到斑点的顺序，基于设置选项卡中的排序方式参数；1 至 10（EasyBuilder 中的数字排序基于 0=1）。

已关闭 面积

返回所找到斑点的面积（以像素为单位测量）。

已关闭 X

返回所找到斑点的质心的 X 坐标。除非已在设置图像中将图像校准为实际单位，否则工具将以像素为单位报告结果。

已关闭 Y

返回所找到斑点的质心的 Y 坐标。除非已在设置图像中将图像校准为实际单位，否则工具将以像素为单位报告结果。

已关闭 角度

返回所找到斑点的质心相对于区域中心的角度。

已关闭 错误

返回所找到斑点的错误结果（如果遇到错误）。

已关闭 像素行

返回所找到斑点的质心的图像行 (X) 坐标。

已关闭 像素列

返回所找到斑点的质心的图像列 (Y) 坐标。


“彩色斑点面积”与“彩色斑点面积 (1-10)”测量工具– 复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


测量工具 - 圆直径

圆直径测量工具测量圆形特征的直径。

注意: 该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置圆直径测量工具

添加该工具之后，需要选择将要测量的输入特征：

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 从可用特征中选择一个智能特征（只需单击该特征即可，这时其颜色将变为洋红色）。
  3. 通过按确定按钮确认选择（或按取消按钮撤消操作）。
  4. 在确认特征之后，EasyBuilder 将会自动计算特征的直径。 EasyBuilder 还将为先前未定义的所有特征插入“边存在/不存在”工具和/或“圆存在/不存在”工具（根据工具和特征的类型）。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整圆直径测量工具参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

圆直径测量工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 范围限制选项卡
  • 图形
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

范围限制选项卡

图形


圆直径测量工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Circle_1”（如果该工具是添加到作业的第一个圆工具，之后名称将递增，如“Circle_2”、“Circle_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


圆直径测量工具 - 设置选项卡

已关闭 边缘对比

定义找到的边的最小可接受边对比度分数（1-100；默认= 智能设置 ，在检测到边缘之前自动递减）。该设置决定了工具的边缘检测灵敏度，即区分特征和背景的能力；将此设置与工具的 图形 结合使用来设置可接受的范围。

注意:如果该参数设置为0，则工具可能会找出未预计到的边。
已关闭 标准化得分

定义是否通过该区域的灰度直方图来标准化边缘分数。此参数对于查找低对比度区域中的边缘非常有用。如果要检测的边缘仅为高对比度，请禁用此参数。

  • 选中（默认）：标准化得分。
  • 未选中：不要将分数标准化。
已关闭 边缘过渡

定义边的转换（“由深到浅”、“由浅到深”或“两者”；默认值 =“两者”）。为了增加精确度和速度，可指定转换的类型。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 50；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 查找依据

定义存在多个圆形边时，该工具如何区别找到的圆形边（默认值 = 最佳得分）。

  • 最佳得分 = 将选择具有最佳定义边（最高对比度和亮度）的圆形边特性。
  • 最小圆 = 将选择具有最小直径的圆形边特性。
  • 最大圆 = 将选择具有最大直径的圆形边特征。


圆直径测量工具 - 范围限制选项卡

已关闭 最大值

定义最大可接受直径值；该工具将根据图像创建智能限制默认设置，这样可进行自定义以满足应用程序的需要。

已关闭 直径

报告已发现圆形边特征的当前测量直径；介于最小和最大值设置（包括二者）之间的值归类为“通过”。

注意:该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
已关闭 最小值

定义最小可接受直径值；该工具将根据图像创建智能限制默认设置，这样可进行自定义以满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于范围限制内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于范围限制内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


“圆直径”测量工具 - 图形

图形是区域中所包含灰度值的一阶导数的表示；波峰和波谷表示主要边转换。

对于检测边的工具（“边”和“圆”工具），得分轴表示所发现边与已定义参数的符合程度：

  • 正得分表示由深到浅的边转换；
  • 负得分表示由浅到深的边转换；
  • 得分为 0 表示未检测到边。

偏移轴指示定义边特性的区域，其中 0 代表区域的开始边界，而其它值代表区域的最大宽度（以像素为单位）。沿偏移轴的波峰或波谷的顶点指示所发现边的位置。

注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


测量工具 - 同心圆

圆心测量工具用于测量两个圆特征中圆心之间的距离。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

该工具可用于验证圆标签是否在圆盖上居中或测量所加工的钻孔的圆心位置。

设置工具

调整工具参数


设置圆同心度测量工具

添加该工具之后，需要定义用于构造圆同心度测量的输入特征（圆特征或参考圆）。

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 首先，从可用特征中选择一个特征（只需单击该特征即可，这时其颜色将变为洋红，且该特征中会延伸出一条直线）。
  3. 接着，选择第二个特征。
  4. 在选择第二个特征之后，EasyBuilder 将会自动计算特征间的距离。 EasyBuilder 还将为先前未定义的所有特征插入“边存在/不存在”工具和/或“圆存在/不存在”工具（根据工具和特征的类型）。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整圆同心度测量工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

圆同心度测量工具的设置窗格包含以下内容：

  • 常规选项卡
  • 范围限制选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

范围限制选项卡


圆心测量工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Concentricity_1”（如果该工具是添加到作业的第一个圆心测量工具，之后名称将递增，如“Concentricity_2”、“Concentricity_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


圆同心度测量工具 - 范围限制选项卡

已关闭 距离

报告在两个发现的圆形边特性中心点之间的当前测量距离；正好位于或在 0 到最大值设置之间的值归类为“通过”。

注意:该工具会以像素为单位报告测量，除非已在设置图像中为该图像分配了实际的单位。
已关闭 最大值

定义最大可接受距离值；该工具将根据图像创建“智能限制”默认设置，这样可定义来满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，例如，在此函数被检测时工具结果为“通过”且位于范围限制内。
  • 选中 - 反向结果，例如，在此函数被检测时工具结果为“失败”且位于范围限制内。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


测量工具 - 测量半径

测量半径测量工具用于定义曲边特征，并生成代表曲线轴的参照线和参照点。 该工具会报告曲线的半径。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


使用测量半径测量工具

添加该工具之后，需要在图像中配置将定义曲边特征的区域：

  1. 将区域定位在曲边特征上方。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 随后，EasyBuilder 将自动计算曲线的半径，并构造表示曲线的轴的参照线和参照点。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整测量半径测量工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

测量半径测量工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 范围限制选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

范围限制选项卡


测量半径测量工具 - 常规选项卡

已关闭 工具名称

定义检查工具的名称，在配置结果（输入、输出和通信）时会使用该名称；默认名称为“Curve_1”（针对该工具是添加到作业的第一个测量半径测量工具的情况，之后名称将递增，如“Curve_2”、“Curve_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


测量半径测量工具 - 设置选项卡

已关闭 边缘对比

定义发现的边所容许的最小边缘对比度得分（1-100；默认值为智能设置，该值会自动递减，直到检测到边）。此设置确定该工具的边检测灵敏度，即区别特征和背景的能力；将此设置与工具的图形连用，可设置容许的范围。

注意:如果该参数设置为0，则工具可能会找出未预计到的边。
已关闭 标准化得分

定义是否通过该区域的灰度直方图来标准化边缘分数。此参数对于查找低对比度区域中的边缘非常有用。如果要检测的边缘仅为高对比度，请禁用此参数。

  • 选中（默认）：标准化得分。
  • 未选中：不要将分数标准化。
已关闭 边缘过渡

定义边的转换（“由深到浅”、“由浅到深”或“两者”；默认值 =“两者”）。为了增加精确度和速度，可指定转换的类型。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 50；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 查找依据

定义存在多个边时，该工具如何区别找到的边（默认值 =“最佳得分”）。

  • 最佳得分 = 具有最高对比度边的边特征。
  • 第一条边 = 最接近区域扫描方向起点的边特征。
  • 最后的边 = 最远离区域扫描方向起点的边特征。


测量半径测量工具 - 范围限制选项卡

已关闭 最大值

定义最大可接受半径值；该工具将根据图像创建智能限制默认设置，从而可进行自定义以满足应用程序的需要。

已关闭 半径（单位）

报告发现的曲边特征的当前测量半径；介于最小和最大值设置（包括二者）之间的值归类为“通过”。

注意:该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
已关闭 最小值

定义最小可接受半径值；该工具将根据图像创建智能限制默认设置，从而可进行自定义以满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


测量工具 - 最小/最大点

最小/最大点测量工具测量边缘的位置，并确定距离找到边缘或定义边缘的区域最近和最远的那些边缘点。该工具使用边缘分析卡尺数组精确定位边缘特征。边缘一经识别，该工具就会在边缘特征上构造最佳拟合线或圆（取决于边缘特征中是否存在曲线）。随后，工具会报告距离最佳拟合线或圆最近和最远的边缘点。

注意:
  • 该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
  • 无论工具是否校准到实际单位，所有输入值均以像素为单位。

在想要确保部件或对象的所有边缘特征都不偏离预期位置时，最小/最大点测量工具非常有用。例如，如果您希望确保叶片边缘不存在任何裂口或凹痕，或者任何边缘刺，则可以使用这一工具。

设置工具

调整工具参数


设置最小/最大点测量工具

添加该工具之后，需要在图像中配置遮蔽区域，使其位于想要检查的边缘特征之上：

  1. 对边缘特征图像内的区域进行定位和配置。定位区域时，请确保边缘与区域的搜索方向平行，并且区域包含尽可能多的边缘特征，同时排除区域中不必要或不想要的噪音。

    注意: 遮蔽区域内的黄色虚线定义该区域内将检测到边缘转换的范围。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 确认区域后，选择边缘、边缘评分和拟合等各个选项卡，然后根据需要调整参数和区域，以确保工具将检测正确的边缘候选项并且创建正确的最佳拟合线或圆。初始设置工具时，使用包含理想边缘特征的图像。之后，后续图像采集将包含边缘候选项，将对这些边缘候选项进行检查，以确定是否存在缺陷或间距等偏差。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的范围和偏差。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整最小/最大点测量工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

最小/最大点测量工具的设置窗格包含以下选项卡：

  • 常规选项卡
  • 边选项卡
  • 边评分选项卡
  • 拟合选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

边缘选项卡

边缘得分选项卡

匹配选项卡


最少/最多点测量工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“MinMaxPoints_1”（如果该工具是添加到作业的第一个最少/最多点测量工具，之后名称将递增，如“MinMaxPoints_2”、“MinMaxPoints_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


最小/最大点测量工具 - 边缘选项卡

选择边缘选项卡后，该工具将以暗绿色轮廓显示区域内所有检测到的边缘。您可以根据需要调整卡尺尺寸、卡尺间距、边缘宽度和最小对比度参数，以隔离所需边缘。

也可通过启用显示所有卡尺参数来查看所有卡尺。

在此选项卡中也可以选择和调整区域。

已关闭 卡尺尺寸

定义将沿着检测方向进行分析的每个卡尺的像素数量（1 - 639；默认值 = 5）。

已关闭 卡尺间距

以像素为单位，定义在一个卡尺末尾与下一个卡尺起点间的距离（-1 - 639；默认值 = 0）。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 10；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 最小对比度

定义将被认定为边缘的最小灰度对比度转换（1 - 255；默认值 = 10）。

已关闭 卡尺计数

显示区域内卡尺的总数。

已关闭 卡尺索引

定义要隔离和显示的各个卡尺。

已关闭 显示所有卡尺

定义是否总是显示区域内的所有卡尺；默认情况下，卡尺为隐藏状态。


最小/最大点测量工具 - 边缘评分选项卡

选择边缘评分选项卡后，该工具将显示区域（可以选择和调整）中所有检测到的边缘候选项（以带有颜色编码的小圆圈标示）以及最佳拟合线或园结果。边缘候选项表示构造最佳拟合线或圆时可能会考虑的边缘；调整参数可隔离所需边缘候选项。

如检测到任何缺陷和间距，也会一并显示。

已关闭 查找边缘方向

定义相对于区域工具尝试检测边缘的方向（“左到右”或“右到左”；默认值 =“左到右”）。

已关闭 边缘转换

定义边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 规则：第一条边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑第一个检测到的边缘（默认情况下启用此设置）。

已关闭 规则：最强边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑具有最强对比度转换的边缘（默认情况下启用此设置）。

已关闭 得分阈值

定义评分阀值，将分数（0 - 255；默认值 = 10）低于这个值的边缘过滤掉。


最小/最大点测量工具 - 拟合选项卡

选定拟合选项卡后，该工具将显示在区域中找到的所有边缘候选项以及最佳拟合线或圆结果。边缘候选项表示构造最佳拟合线或圆时可能会考虑的边缘，边缘候选项由小圆圈标示。

已关闭 线拟合

定义要用找到的边缘构造的最佳拟合线的类型（无、直线拟合、曲线拟合、自动调整或区域；默认值 = 自动调整）。

  • 选择无时，工具不会创建最佳拟合线，仅相对于区域的中心测量所找到边缘的位置。
  • 选择直线拟合时，工具会根据检测到的边缘创建一条最佳拟合直线，然后相对于最佳拟合线测量所找到边缘的位置。
  • 选择曲线拟合时，工具会根据检测到的边缘创建一条最佳拟合曲线，然后相对于最佳拟合线测量所找到边缘的位置。
  • 选择自动调整时，工具会根据检测到的边缘创建一条最佳拟合直线或曲线，然后相对于最佳拟合线测量所找到边缘的位置。
  • 选择区域时，工具会根据检测到的边缘自动创建一条最佳拟合直线或曲线，然后相对于区域的侧边来测量所找到边缘的位置。
已关闭 过滤异常值

定义该工具是否将从最佳拟合线中删除超出“拟合距离过滤器”参数所定义距离的点（默认情况下，已禁用此参数）。

已关闭 拟合距离过滤器

以像素定义边缘距重新拟合计算中所使用的原始最佳拟合线的距离（1 - 1920；默认值 = 2）。这一参数有助于防止缺陷对线拟合造成影响。

注意:必须选中（启用）“过滤异常值”参数才能使用此参数。
已关闭 最远点过滤距离

定义一旦超出后，将不使用边缘确定最小和最大距离的异常值距离（1 - 1920；默认值 = 1000）；大于这个值的所有边缘均将被忽略。

已关闭 重新评分

定义是否会对检测到的边缘重新评分，以确保能够正确过滤检测到的原本被丢弃的边缘（默认情况下启用此参数）。

已关闭 重新拟合

定义边缘重新评分后该工具是否将重新拟合最佳拟合线（默认情况下启用此参数）。

注意:启用此参数后该工具的精确度会更高，但它会增加处理时间。
已关闭 结果

显示图像中的最佳拟合线，然后报告距离最佳拟合线最近和最远的点的位置。


计数工具 - 斑点

斑点计数工具用于计算出现在图像区域的斑点特征的实例个数。

斑点计数工具是较快的工具之一，其查找斑点特征的速度比图形存在/不存在工具快得多。此工具在许多计数应用中都很有用，例如，检验连接器上的引脚数量是否正确，或计算饼干中的巧克力碎片数量。

设置工具

调整工具参数


设置斑点计数工具

选择工具后，需要选择区域类型，然后在您希望在其中检测斑点特征的图像中配置它：

注意:在选择将要用于检测的斑点时，请尽量选择在明暗像素之间具有较高对比度的斑点。

  1. 从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。定位并配置图像中预计会出现斑点的区域；请确保该区域的边界覆盖斑点及其可能出现的位置。为了提高工具的性能，请创建较小的区域；区域越大，执行检测所需的时间就越长。如果不使用定位特征，请确保斑点在每个图像中出现在大致相同的位置，或该区域足够大以包括特征的预期移动位置。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 在初始配置该工具时，根据需要加载一些调整工具参数，以补偿预期的变化范围。
  4. 最后，如需要可以使用工具的输入/输出属性表来设置与其它工具及设备间的数据分享。


调整斑点计数工具参数

在设置完工具的区域后，你可以开始优化应用程序工具。

斑点计数工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 范围限制选项卡
  • 直方图选项卡
  • 组合区域选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

范围限制选项卡

直方图选项卡

复合区域选项卡


斑点计数工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Blob_1”（如果该工具是添加到作业的第一个校准工具，之后名称将递增，如“Blob_2”、“Blob_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


斑点计数工具 - 设置选项卡

已关闭 阈值模式

定义确定用于从背景中区分斑点的灰度值的模式。在选择“自动”（默认 = 自动）时，每次采集图像时，工具会对图像到图像的亮度变动进行调整。如果选择“手动”，需要手动输入和调整该值。

已关闭 斑点阈值

定义用于从背景中区分斑点的灰度值（启用时为 0 - 255）。默认情况下此控制为“关”，要启用该控制，需要将“阈值模式”设置为“手动”。使用图形设置应用程序的最佳值。

已关闭 斑点颜色

定义斑点的颜色（黑色、白色或二者之一；默认值 = 二者之一）。

  • 二者之一 = 对斑点颜色没有要求。
  • 黑色 = 只返回斑点阈值以下的斑点。
  • 白色 = 只返回斑点阈值以上的斑点。
已关闭 边界

定义管理与斑点区域边界相交的斑点的两种方法之一（默认值 = 关，未选中）：

  • 未选中 – 不包括与区域边界相交的斑点；即，斑点必须完全位于要检测的区域内部。
  • 选中 – 包括与区域边界相交的斑点；即，只要符合其它条件，则检测与边界相交的斑点。
已关闭 最小区域

为所有检测的斑点定义最小区域限制，以像素数为单位（0 到 900000；默认值 = 100）；将只识别其面积大于“最小区域”的斑点。

已关闭 最大区域

为所有检测的斑点定义最大区域限制，以像素数为单位（0 到 900000；默认值 = 100000）；将只识别其面积小于“最大区域”的斑点。


斑点计数工具 - 范围限制选项卡

已关闭 最大值

定义检测斑点的最大可接受数；该工具将根据图像创建智能限制默认设置，这样可进行自定义以满足应用程序的需要。

已关闭 斑点计数

报告当前检测的斑点数（图像中的计数斑点基于 0 = 1 的数字顺序）；介于最小和最大设置之间（包括二者）的值归类为“通过”。

已关闭 最小值

定义检测斑点的最小可接受数；该工具将根据图像创建智能限制默认设置，这样可进行自定义以满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


斑点计数工具 - 直方图选项卡

直方图以图形方式显示区域内像素的灰度值。

  • 图形的 X 轴表示灰度值的总数（0 到 255，或总计 256 个灰度级）。
  • 图形的 Y 轴表示给定灰度值的像素数，通过显示具有最大像素数的灰度值建立标度。
  • 蓝色的垂直线指示用于将图像区域区分为黑色和白色像素的阈值；线左侧的值被视为黑色，而线右侧的值被视为白色。
注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


斑点计数工具 - 复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


计数工具 - 彩色斑点

彩色斑点计数工具用于计算出现在图像区域的斑点特征的实例个数。

彩色斑点计数工具是较快的工具之一，其查找斑点特征的速度比图形存在/不存在工具快得多。此工具在许多计数应用中都很有用，例如，检验连接器上的引脚数量是否正确，或计算饼干中的巧克力碎片数量。

设置工具

调整工具参数


设置彩色斑点计数工具

选择工具后，需要选择区域类型，然后在您希望在其中检测斑点特征的图像中配置它：

  1. 从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。定位并配置图像中预计会出现斑点的区域；请确保该区域的边界覆盖斑点及其可能出现的位置。为了提高工具的性能，请创建较小的区域；区域越大，执行检测所需的时间就越长。如果不使用定位特征，请确保斑点在每个图像中出现在大致相同的位置，或该区域足够大以包括特征的预期移动位置。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 配置搜索区域后，需要配置该工具的颜色库并激活相应的颜色模型：

  4. 如果这是首次添加颜色工具（“彩色斑点”与“彩色斑点 (1-10)”定位工具、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”与“彩色斑点面积 (1-10)”测量工具、“彩色斑点”计数工具、“颜色模型”识别工具或“颜色转为二进制”图像过滤工具），需要首先定义颜色库及其颜色模型。

  5. 如果先前已添加另一个颜色工具并且想要使用现有颜色库及其训练的颜色模型，请转到“设置”选项卡并选择所需的颜色库，然后在“库”选项卡中选中所需颜色模型以将其激活。

  6. 默认情况下，工具将自动产生“失败”，直至定义颜色库。如果已定义颜色库，则工具将自动使用该库并激活其包含的所有颜色模型。

  7. 设置颜色模型和颜色库后，该工具将处理图像，搜索区域内与所选颜色模型匹配的所有像素都会变为白色 (255)，而与颜色模型不匹配的像素则会变为黑色 (0)。
  8. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  9. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整彩色斑点计数工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

彩色斑点计数工具的设置窗格包含以下元素：

  • “常规”选项卡
  • “设置”选项卡
  • “范围限制”选项卡
  • “颜色库”选项卡
  • “组合区域”选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

范围限制选项卡

颜色库选项卡

复合区域选项卡


彩色斑点计数工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Blob_1”（如果该工具是添加到作业的第一个斑点工具，之后名称将递增，如“Blob_2”、“Blob_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


颜色斑点计数工具 -“设置”选项卡

已关闭 训练颜色

启动“ExtractColor 训练”对话框，用于定义所选颜色库的颜色模型。

已关闭 颜色库

定义工具将引用的颜色库。从下拉列表中，选择要修改的颜色库，然后按训练颜色按钮启动“ExtractColor 训练”对话框。每个颜色库最多可包含 100 种不同的由各个颜色组成的颜色模型。

EasyBuilder 作业最多可包含 5 个颜色库，可在下列工具之间共享颜色库：

  • 彩色斑点定位工具
  • 彩色斑点 (1-10) 定位工具
  • 颜色像素计数存在/不存在工具
  • 彩色斑点面积测量工具
  • 彩色斑点面积 (1-10) 测量工具
  • 彩色斑点计数工具
  • 颜色模型识别工具
  • 颜色转为二进制图像过滤工具
已关闭 边界

定义如何处理与斑点区域边界相交的斑点（默认=关，未选中）

  • 未选中 - 不包括与区域边界相交的斑点；斑点必须完全位于要检查的区域内部。
  • 选中 - 包括与区域边界相交的斑点；只要斑点符合其它条件，就会被检测到。
已关闭 最小区域

以像素数为单位（0 到 16777216；默认值 = 100）为所有检测的斑点定义最小面积限制；将只识别面积大于“最小面积”的斑点。

已关闭 最大区域

以像素数为单位（0 到 16777216；默认值 = 100000）为所有检测的斑点定义最大面积限制；将只识别面积小于“最大面积”的斑点。

已关闭 平滑因子

定义平滑图像的平滑值 (0 至 25; 默认 = 1)。如不需要平滑图像，则可将该值设置为 0。

已关闭 显示原始图像
  • 取消选中（默认）：所选区域显示二进制灰度输出图像。
  • 已选中：所选区域显示原始输入图像。


彩色斑点计数工具 - 范围限制选项卡

已关闭 最大值

定义要检测的斑点的最大可接受数。该工具将根据图像创建一个智能限制默认设置，您可以对其进行自定义以满足自身的应用需要。

已关闭 斑点计数

报告当前检测的斑点数（图像中的计数斑点基于数字顺序，其中，0 = 1）。正好等于最小值和最大值设置或介于两者之间的值被归类为“通过”。

已关闭 最小值

定义要检测的斑点的最小可接受数。该工具将根据图像创建一个智能限制默认设置，您可以对其进行自定义以满足自身的应用需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


彩色斑点计数工具 - 颜色库选项卡

已关闭 颜色模型列表

显示所选颜色库中包含的颜色模型的只读列表。通过选中或取消选中颜色模型名称旁边的复选框来激活或禁用颜色模型。

已关闭 颜色表

显示所选颜色模型中颜色的只读排序表。

已关闭 颜色名称

显示所选颜色模型中颜色的名称。

已关闭 RGB

显示所选颜色模型中颜色的 RGB 值。

已关闭 运算

显示所选颜色模型中颜色的运算（加或减）。


彩色斑点计数工具 - 复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


计数工具 - 边

边计数工具计算出现在图像区域内的边特征的数量。

此工具在计算例如螺丝上的螺纹数量等应用案例上非常有用。

设置工具

调整工具参数


使用边计数工具

添加工具之后，需要在图像中配置将定义检测边缘所在位置的区域：

  1. 将区域置于边特征区域之上并进行配置，确保区域的边界覆盖边及其可能的位置。请特别注意区域的扫描方向箭头，以确保该区域的定位能够优化所需边的检测。

    为了帮助提高该工具的性能，请创建较小的区域。区域越大，执行检查所花费的时间越长。如果没有使用定位特征，请确保边在每个图像中出现在大致相同的位置，或具有足够大的区域考虑预期的特征运动。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整边计数工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

边计数工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 范围限制选项卡
  • 图形
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

范围限制选项卡

图形


“边缘计数”工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Edges_1”（如果该工具是添加到作业中的第一个定义边缘的工具，之后名称将递增，如“Edges_2”、“Edges_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


边计数工具 - 设置选项卡

已关闭 边缘对比

定义找到的边的最小可接受边对比度分数（1-100；默认=“智能设置”，在检测到边缘之前自动递减）。该设置决定了工具的边缘检测灵敏度，即区分特征和背景的能力；将此设置与工具的 图形 结合使用来设置可接受的范围。

注意:如果该参数设置为0，则工具可能会找出未预计到的边。
已关闭 标准化得分

定义是否通过该区域的灰度直方图来标准化边缘分数。此参数对于查找低对比度区域中的边缘非常有用。如果要检测的边缘仅为高对比度，请禁用此参数。

  • 选中（默认）：标准化得分。
  • 未选中：不要将分数标准化。
已关闭 边缘过渡

定义边的转换（“由深到浅”、“由浅到深”或“两者”；默认值 =“两者”）。为了增加精确度和速度，可指定转换的类型。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 50；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 角度范围

定义找到的边所允许的最大角度变化范围（0-10°；默认值= 10°）。允许角度偏差越高，工具执行所需的时间越长。


边计数工具 - 范围限制选项卡

已关闭 最大值

定义要检测边的最大可接受数目；该工具将根据图像创建“智能限制”默认设置，可对其进行自定义以满足应用程序的需要。

已关闭 边缘

报告当前检测到的边数（图像中计数的边基于 0 = 1 情况下的数字顺序）；正好落在或介于最大值与最小值设置之间的值被归类为“通过”。

已关闭 最小值

定义要检测边的最小可接受数目；该工具将根据图像创建“智能限制”默认设置，可对其进行自定义以满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


“边计数”工具 - 图形

图形是区域中所包含灰度值的一阶导数的表示；波峰和波谷表示主要边转换。

对于检测边的工具（“边”和“圆”工具），得分轴表示所发现边与已定义参数的符合程度：

  • 正得分表示由深到浅的边转换；
  • 负得分表示由浅到深的边转换；
  • 得分为 0 表示未检测到边。

偏移轴指示定义边特性的区域，其中 0 代表区域的开始边界，而其它值代表区域的最大宽度（以像素为单位）。沿偏移轴的波峰或波谷的顶点指示所发现边的位置。

注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


计数工具 - 边缘对

边缘对计数工具用于计算出现在图像区域的直线边缘对的实例个数。

边缘对计数工具不同于边计数工具，因为边缘对计数工具允许在边缘对间设置预期的宽度，这一点很有用，例如，计算齿轮的齿数，或计算计算机芯片上的导线数。

设置工具

调整工具参数


设置边缘对计数工具

添加工具之后，需要在图像中配置将定义检测边缘所在位置的区域：

  1. 将区域置于边特征区域之上并进行配置，确保区域的边界覆盖边及其可能的位置。

    区域的扫描方向、“设置”选项卡中的参数和配置的范围限制在确定所检测的边缘对数量时起着重要作用：

    已关闭 示例 1

    已关闭 示例 2

    已关闭 示例 3

    为了帮助提高该工具的性能，请创建较小的区域。区域越大，执行检查所花费的时间越长。如果没有使用定位特征，请确保边在每个图像中出现在大致相同的位置，或具有足够大的区域考虑预期的特征运动。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整边缘对计数工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

边对计数工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 范围限制选项卡
  • 图形
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

范围限制选项卡

图形


“边缘对计数”工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“EdgePairs_1”（如果该工具是添加到作业的第一个边缘对计数工具，之后名称将递增，如“EdgePairs_2”、“EdgePairs_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


边缘对计数工具 - 设置选项卡

已关闭 边缘对比

定义找到的边的最小可接受边对比度分数（1-100；默认= 智能设置， 在检测到边缘之前自动递减）。该设置确定工具的边缘检测灵敏度，即区分特征和背景的能力。

注意:如果该参数设置为0，则工具可能会找出未预计到的边。
已关闭 标准化得分

定义是否通过该区域的灰度直方图来标准化边缘分数。此参数对于查找低对比度区域中的边缘非常有用。如果要检测的边缘仅为高对比度，请禁用此参数。

  • 选中（默认）：标准化得分。
  • 未选中：不要将分数标准化。
已关闭 第一条边的过渡

定义第一条边的过渡（从暗到亮，从亮到暗或两者；默认=两者）。要提高准确性和速度，请指定过渡类型。

已关闭 第二条边的过渡

定义第二条边的过渡（从暗到亮，从亮到暗或两者；默认=两者）。要提高准确性和速度，请指定过渡类型。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 50；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 角度范围

定义找到的边所允许的最大角度变化范围（0-10°；默认值= 10°）。允许角度偏差越高，工具执行所需的时间越长。

已关闭 最小距离

指定所有检测到的边缘对之间的最小距离，以像素为单位（0 到 900000；默认值= 10），只有距离大于最小距离的边缘对会被识别。

已关闭 最大距离

指定所有检测到的边缘对之间的最大距离，以像素为单位（0 到 900000；默认值= 50），只有距离小于最大距离的边缘对会被识别。


边缘对计数工具 - 范围限制选项卡

已关闭 最大值

定义要检测边缘对的最大可接受数目；该工具将基于图像创建“智能限制”默认设置，可对其进行自定义以满足应用程序的需要。

已关闭 边缘对

报告当前检测到的边缘对数（图像中计数的边缘对基于 0 = 1 情况下的数字顺序）；正好落在或介于最大值与最小值设置之间的值被归类为“通过”。

已关闭 最小值

定义要检测边缘对的最小可接受数目；该工具将基于图像创建“智能限制”默认设置，可对其进行自定义以满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


边缘对计数工具 - 图形

图形是区域中所包含灰度值的一阶导数的表示；波峰和波谷表示主要边转换。

对于检测边的工具（“边”和“圆”工具），得分轴表示所发现边与已定义参数的符合程度：

  • 正得分表示由深到浅的边转换；
  • 负得分表示由浅到深的边转换；
  • 得分为 0 表示未检测到边。

偏移轴指示定义边特性的区域，其中 0 代表区域的开始边界，而其它值代表区域的最大宽度（以像素为单位）。沿偏移轴的波峰或波谷的顶点指示所发现边的位置。

注意:无论在线/离线状态和工具的通过/失败的状态如何，都将显示图形。然而，如果工具运行失败，则图形可能不会被更新。


计数工具 - PatMax RedLine 图形和 PatMax 图形

注意:
  • 从 In-Sight 固件版本 5.5.0 开始，该工具的算法已被更改，以在某些情况下返回更准确的结果并缩短执行时间。
  • 由于此更改，如果试图将在 In-Sight 固件 5.5.0 或更高版本中设置该工具的作业加载到运行固件版本 5.4.x 或更低版本的 In-Sight 视觉系统时，会显示错误消息。
  • PatMax RedLine 图形计数工具仅在运行 In-Sight 固件版本 5.2.0 和更高版本的 In-Sight 视觉系统上可用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

PatMax RedLine 图形工具和 PatMax 图形计数工具用于根据图形的已训练表示形式（称为模型），采用 PatMax RedLine 或 PatMax 算法来计算该图形特征的数目。

这些工具对于例如计算机械装配中的螺栓数或计算托盘中的试剂瓶数之类的应用中十分有用。

设置工具

调整工具参数


设置 PatMax RedLine 图形和 PatMax 图形计数工具

添加该工具之后，需要选择并配置将定义图形的区域类型（模型区域），以及将在其中查找图形的图像中的区域（搜索区域）。

  1. 从模型下拉菜单中，选择区域的类型：矩形（默认）、圆形、环形或多边形。然后将模型区域放置在将用于训练模型的图形上；请确保模型区域只覆盖图形的重要特征。添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 从搜索下拉菜单选择区域类型：矩形（默认）、圆形、环形或多边形。然后定位搜索区域，使其覆盖图像中您希望图形出现的区域。为了帮助提高工具的性能，请创建较小的搜索区域。搜索区域越大，执行检查所需的时间越长。
  3. 按确定按钮确认区域（按取消按钮不将该工具添加到作业）。
  4. 在初始配置该工具的情况下，根据需要加载几个图像并调整工具参数，以补偿预期的变化范围。
  5. 最后，如需要，可以使用工具的输入/输出属性表以在其他工具和/或其他外部设备之间共享工具数据。

选择图案特征

PatMax RedLine 图案、PatMax 图案以及图案


PatMax RedLine 图形、PatMax 图形和图形

注意:PatMax RedLine 图形计数工具仅在运行 In-Sight 固件版本 5.2.0 和更高版本的 In-Sight 视觉系统上可用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

PatMax RedLine 图形、PatMax 图形和图形可定位已训练的图形模型，且在定位和检测工具中提供最高准确性。然而，PatMax RedLine 图形和 PatMax 图形比图形的功能更强大，以应对灯光条件和图形位置的更大变化。它们还提供对图形比例和旋转变化、图形元素遮挡以及由于灯光条件导致的图形外观变化的出色识别。

PatMax RedLine 图形和 PatMax 图形之间的主要差别是速度；PatMax RedLine 图形采用最新图形匹配算法，可在 5 百万像素图像中以高出 PatMax 图形多达 7 倍的速度定位已训练特征。因此，PatMax RedLine 图形适用于高分辨率视觉系统。

图形（在大多数情况下）比 PatMax 快，但某些情况需要 PatMax RedLine 或 PatMax 版本的准确性和可靠性：

  • 当灯光和反射变化难以控制时。例如，金属部件可在任意方向反射光线。
  • 当要检查的图形与背景中的某些元素的形状或阴影类似，或图形与图像中的其他对象重叠或被其部分遮挡时。
  • 当希望从其他类似图形中准确识别一种图形类型时。
  • 当部署环境条件对于图形工具的一致且可靠执行过于苛刻时。


调整 PatMax RedLine 图形和 PatMax 图形计数工具参数

在设置完工具的区域后，你可以开始为应用程序优化工具。

PatMax RedLine 图形和 PatMax 图形计数工具的设置窗格包括：

  • 常规选项卡
  • 设置选项卡
  • 范围限制选项卡
  • 模型和搜索选项卡
  • 已训练图像选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

范围限制选项卡

模型和搜索选项卡

已训练图像选项卡


PatMax RedLine 图形和 PatMax 图形计数工具 - 通用选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Pattern_1”（如果该工具是添加到作业的第一个图形工具，之后名称将递增，如“Pattern_2”、“Pattern_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


PatMax RedLine 图形和 PatMax 图形计数工具 - 设置选项卡

已关闭 合格阈值

定义模型图形与所找到图形之间必须存在的相似程度（0-100；默认值 = 50）。所找到的图形大于或等于该设置值将视为匹配。设置值越高，该工具的执行速度越快，这也需要模型与所找到图形之间具有更大的相似度。设置的值较低会得到更多精确度较低的相似结果，如检测到与模型图形相似但不是模型图形本身的图形。

已关闭 对比度阈值

定义已找到图形中必须存在的最小可接受对比度；已找到图形的对比度必须大于要视为有效实例的对比度阈值。PatMax RedLine 图形的默认值为 0，有效参数范围为 0-100。PatMax 图形的默认值为 10，有效参数范围为 0-255。低对比度阈值用于低对比度图像，而高对比度阈值用于高对比度图像。

注意:PatMax RedLine 图形对比度是已训练图形中的特征与搜索图像中的匹配特征之间的对比度变化的“相对”程度，以百分比表示。因此，如果特征对比度类似于或高于图形对比度，报告的对比度将约为 100。如果特征对比度低于图形对比度，报告的对比度将 <100。PatMax RedLine 图形的对比度不同于 PatMax 图形的对比度，后者是搜索 ROI 的“绝对”图像对比度，以灰度级表示。
已关闭 角度公差

定义找到的图形可从“模型”图案位置处旋转而仍被识别为有效图形的最大角度（± 0-180°；默认值 =15°）。允许较大的图形旋转偏差范围会增加该工具的执行时间。

已关闭 缩放公差

定义已找到图形和模型图形之间允许的缩放百分比（尺寸变化）（0-50；默认值为 0）。此值为正或负百分比，例如，值 5 将启用工具以查找介于模型图形尺寸的 95% 至 105% 之间的图形。允许更大的图形比例变化范围将增加工具的执行时间。

已关闭 查找模式

定义用于训练和识别图案的搜索模式，PatMax 或 PatQuick。默认情况下会选择 PatMax。PatMax 的精确度比 PatQuick 高，但是需要更多的执行时间，而 PatQuick 的精确度比 PatMax 低，但是需要较少的执行时间。

已关闭 严格评分

定义找到图形的缺失或遮挡特征是否会影响分数（默认=关闭，未选中）。应用严格评分时（开启，选中），如果图形的特征缺失或被锁定，则会降低所发现图形的得分。

已关闭 忽略极性

定义所找到的图形是否可以包含与模型图形反色的匹配特征（默认值 = 关，取消选中）。应用忽略极性（开，选中）时，如果检测到的图形具有反色特征（例如与模型图形中的白色/黑色相对的黑色/白色），该图形将被归类为与模型图形匹配。

已关闭 超时
定义工具搜索图形的时间，以毫秒为单位（0 至 30,000）。超过该设定时间，操作会停止并返回错误信息。 默认情况下，此参数设置为 5,000。
注意:PatMax RedLine 图形不包含 Find Mode（查找模式）参数。


PatMax RedLine 图形和 PatMax 图形计数工具 - 范围限制选项卡

已关闭 最大值

定义要检测的最大可接受图形数；此工具将根据您的图像创建“智能限制”默认设置，您可根据应用需要自定义此设置。

已关闭 图形

报告当前检测到的图形数（图像中计数的图形基于序号，其中 0 = 1）；恰好是“最小值”和“最大值”设置或介于其之间的值被分类为“通过”。

已关闭 最小值

定义要检测的最小可接受图形数；此工具将根据您的图像创建“智能限制”默认设置，您可根据应用需要自定义此设置。

已关闭 反向

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


PatMax RedLine 图形和 PatMax 图形计数工具 - 模型和搜索选项卡

模型和搜索选项卡用于为工具的模型和搜索区域配置复合区域。复合区域是添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为“遮掩”）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 在模型选项卡中，仅在按模型区域按钮后才能启用复合区域。
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


PatMax RedLine 图形和 PatMax 图形计数工具 - 已训练图像选项卡

训练图像选项卡中显示的图像是模型图形的缩略图。按模型区域按钮可调整模型区域的大小或移动该区域，然后按训练按钮重新训练模型图形。


计数工具 - 图形

图形计数工具用于根据经训练后的显示图形（称为模型）来计算该图形特征的实例个数。

图形计数工具在许多应用领域都很有用，例如，计算机械装配件上的螺钉数量，或计算托盘中的玻璃瓶数量。

设置工具

调整工具参数


设置参照图形计数工具

添加该工具之后，需要配置将定义图形的图像中的区域（模型区域），以及将在其中查找图形的图像中的区域（搜索区域）。

  1. 将模型区域置于将用作训练模型的图形之上，确保模型区域仅覆盖图形的重要特征。

  2. 决定搜索区域的位置，使其覆盖图像中您希望图形出现的区域。为了帮助提高工具的性能，请创建较小的搜索区域。搜索区域越大，执行检查所需的时间越长。

    模型和搜索区域无法弯曲为弧或圆环形状。

  3. 按确定按钮确认区域（按取消按钮不将该工具添加到作业）。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。

选择图案特征


选择参照图形特征

选择要用于检测的图形时，为确保获得最佳结果，可考虑以下指导原则：

  • 图形始终出现在每个图像中。
  • 图形应尽可能多地包含独特和一致的现有特性，而组成图形的特性的外观和相对几何形状应彼此一致，且能够清楚分辨。
  • 如果可能，选择较大的图形；较大的图形通常意味图形中具有更独特的特性，可使检测更加一致和精确。


调整参照图形计数工具参数

在设置完工具的区域后，你可以开始为应用程序优化工具。

图形计数工具的设置窗格包含以下元素：

  • “常规”选项卡
  • “设置”选项卡
  • “范围限制”选项卡
  • “训练图像”选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

范围限制选项卡

已训练图像选项卡


图形计数工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Pattern_1”（如果该工具是添加到作业的第一个图形工具，之后名称将递增，如“Pattern_2”、“Pattern_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


图形计数工具 - 设置选项卡

已关闭 训练输入

定义是否训练输入线上的模型模式（默认设置为“关”，禁用）。

  • 输入：在输入线上训练模型图形。选定的输入线路将被用作训练信号。

    注意:
    • 当 In-Sight 视觉系统没有离散输入时（例如使用直接 I / O 的 In-Sight 8000 系列视觉系统），此选项不会显示。
    • 所选输入线的信号类型必须在输入/输出应用步骤中设置为事件触发。
    • 模型图形的训练将使用由视觉系统/传感器采集的最新图像。不需要为了训练重新触发视觉系统/传感器。
    • 有关详情，请参阅 输入：在输入线上训练模型图形
已关闭 合格阈值

定义模型图形与所找到图形之间必须存在的相似程度（0-100；默认值 = 50）。大于或等于设置值的所发现图形视为匹配。设置值越高，此工具执行速度越快，这也需要模型与所找到图形之间具有更大的相似度。设置的值较低会得到更多精确度较低的相似结果，如检测到与模型图形相似但不是模型图形本身的图形。

已关闭 旋转公差

定义找到的图形可从“模型”图形位置处旋转而仍被识别为有效图形的最大角度（± 0-180°；默认值 =15°）。允许较大的图形旋转偏差范围会增加该工具的执行时间。

已关闭 缩放公差

定义工具对图形尺寸变化所能接受的范围，在训练图形尺寸的 ±10％ 范围内。默认情况下，此设置为关闭（未选中），该设置将禁用缩放比例调整。在这种操作模式下，工具仍然可以找到在 ±10％ 范围内的图形，但是特征的得分会随着变化比例的增加而降低。

已关闭 模型类型

定义工具如何构造模型图形；区域模型或边模型（默认）。区域模型根据模型区域中一致的灰度值采样来创建模型图形。边模型根据在“模型”区域内检测到的图形特征的边（明/暗转换）来创建模型图形。

已关闭 精确度

定义工具将如何在准确性/可靠性和执行速度之间取得平衡；准确, 中度(默认)以及快速。准确表明读取结果含有很高的准确性/可靠性，可是读取速度会比较慢；快速表明读取的准确性/可靠性会比较低可是读取速度比较快；中度则表明在准确性/可靠性和速度中间取一个平衡值。

已关闭 超时

定义以毫秒为单位的时间量（0 到 30,000），工具搜索图形超过此时间量后将停止执行并返回“失败”。


参照图形计数工具 - 范围限制选项卡

已关闭 最大值

定义要检测图形的最大可接受数目；该工具将根据图像创建“智能限制”默认设置，可对其进行自定义以满足应用程序的需要。

已关闭 图形

报告当前检测到的图形数（图像中计数的图形基于 0 = 1 情况下的数字顺序）；正好落在或介于最大值与最小值设置之间的值被归类为“通过”。

已关闭 最小值

定义要检测图形的最大可接受数目；该工具将根据图像创建“智能限制”默认设置，可对其进行自定义以满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


参照图形计数工具 - 训练图像选项卡

训练图像选项卡中显示的图像是模型图形的缩略图。按模型区域按钮可调整模型区域的大小或移动该区域，然后按训练按钮重新训练模型图形。


/ 识别工具 - 读取一维代码和读取多个一维代码（1-20 个）

读取一维代码和读取多个一维代码（1-20 个）识别工具使用 ReadIDMax® 算法，可解码和/或验证一维和/或堆叠式条码。该工具报告解码信息，如果代码被成功解码并且在规定的阈值范围内，则报告合格。

读取一维代码识别工具可用于读取和/或验证区域内的单个代码，而读取多个一维代码（1-20 个）识别工具可用于读取和/或验证区域内最多 20 个代码。

设置工具

调整工具参数


/ 设置读取一维代码和读取多个一维代码 (1-20) 识别工具

添加工具之后，需要在图像中配置区域：

  1. 对于读取一维代码识别工具，将区域置于代码/符号之上，并确保区域的边界将所有代码/符号都包含在内。对于读取多个一维代码（1-20 个）识别工具，将区域置于您希望显示代码/符号的位置上，并确保区域的边界将所有想要进行解码的代码/符号都包含在内。为了提高工具的性能，可尝试创建较小的区域。区域越大，执行检查所需的时间越长。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 确认区域后，需要在以下项中定义参数：设置选项卡：

    1. 模式参数可定义工具的工作模式：读取或匹配字符串（默认情况下，模式被设置为读取）。
    2. 对于读取多个一维代码（1-20 个）识别工具，还需要定义最大结果数参数，该参数定义要进行解码的代码/符号数量（默认情况下设置为 1）。
  4. 该工具将围绕已解码的代码/符号绘制一个不可编辑的界限框，并 插入一个 [image] 图标以指示根据已解码的代码/符号创建的定位特征。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，如果需要，可使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


/ 调整读取一维代码和读取多个一维代码 (1-20) 识别工具参数

在设置完工具的区域后，你可以开始优化应用程序工具。

读取一维代码和读取多个一维代码（1-20 个）识别工具的设置窗格包含以下选项卡：

  • 常规选项卡
  • 设置选项卡
  • 一维代码选项卡
  • 堆叠式选项卡
  • 结果选项卡
  • 表
注意:
  • 结果选项卡仅用于读取一维代码识别工具。
  • 表仅用于读取多个一维代码（1-20 个）识别工具。
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

1D 选项卡

堆叠选项卡

结果选项卡

表


/ 读取 1D 代码和读取 1D 代码 (1-20) 识别工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“IDCode_1”（如果该工具是添加到作业的第一个读取 1D 代码、读取 1D 代码 (1-20) 、读取 2D 代码、读取 2D 代码 (1-20) 或读取邮政编码识别工具，之后名称将递增，如“IDCode_2”、“IDCode_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


/ 读取 1D 代码和读取 1D 代码 (1-20) 识别工具 - 设置选项卡

已关闭 Maximum Results（最大结果数）

定义要读取的代码/符号的最大数量（1 - 20；默认值 = 1）。

注意:如果指定的最大结果数值超过视野 (FOV) 中的代码/符号数量，该工具将继续搜索，以得到指定数量的代码/符号。如果 FOV 中的代码/符号数量发生变化，则可通过调整超时参数的值来减少工具的执行时间。
已关闭 Trained（已训练）

显示该工具是否已对某一特定代码/符号进行过训练；已训练显示 1，未训练则显示 0。

已关闭 训练

训练代码/符号读取的模型；已训练的信息将保留直至按下未训练按钮。要重新训练某一代码/符号，请按未培训按钮，显示新代码/符号后，再按培训按钮。通过在工具中设定要解码的代码/符号类型，训练可帮助提高工具的速度和性能。使用读取多个一维代码（1-20 个）识别工具或读取多个二维代码（1-20 个）识别工具并进行训练时，先配置单个代码/符号周围的区域，再按训练按钮。对代码/符号进行训练后，可调整区域，以在视场 (FOV) 中的更大范围搜索多个代码/符号。仅可对区域中的单个代码/符号进行训练。如果对区域中的多个代码/符号按下训练按钮，则无法指明训练哪个代码/符号。 训练之前，确保在 1D 和堆叠选项卡中选择正确的代码类型。

已关闭 未训练

撤消对已训练过的模型代码/符号的训练。要重新训练某一符号，请按未培训按钮，显示新代码后，再按培训按钮。

已关闭 Mode（模式）

定义工具的运行模式（读取或匹配字符串；默认值 = 读取）。

  • 读取 = 用于代码/符号中的信息未知的情况。该工具将会自动解码包含在代码/符号中的信息，并在字符串参数中显示解码的信息。
  • 匹配字符串 = 用于验证已知的代码/符号是否存在和可读取。该工具将解码代码/符号中包括的信息，并会将解码的信息与在匹配字符串参数中输入的信息进行比较。
已关闭 Match String（匹配字符串）

定义预期要读取的字符串（仅在模式参数设为匹配字符串时启用）。输入该工具要解码的预期信息。

注意:匹配的字符串可从另一个设备输入。当您运行此作业时，该识别工具可从输入设备读取文本字符串并将其与已识别 ID 代码/符号进行比较。在从外部设备输入匹配 字符串之前，该工具会“失败”，且匹配字符串字段显示 TRIG。
已关闭 Match Mode（匹配模式）

定义区域中所有已解码的代码/符号是否应与匹配字符串参数中定义的字符串匹配方可通过。要启用此选项，必须配置匹配字符串。

  • 全部匹配 = 所有已解码的代码/符号必须都与匹配字符串参数中定义的字符串匹配。
  • 任一匹配 = 至少一个解码的代码/符号必须与匹配字符串参数中定义的字符串匹配。
已关闭 Checksum（校验和）

定义是否使用错误检测算法验证代码/符号，以确保可靠性（默认情况下，此设置被禁用）。校验和仅适用于包含可选校验和算法的代码/符号；每个代码/符号均具有其唯一的校验和算法。所用校验和类型取决于选定的代码/符号。

注：使用校验和验证 Code 128、Code 93、RSS、UPC 和 EAN 条码，无需考虑参数选择。如果针对任何其它条码启用校验和，且检验和未编码，则读取会失败。

已关闭 Sort Mode（排序模式）

定义返回结果（如果有结果）的顺序（无，上到下，左到右，字母顺序或字符串长度；默认=无）。

  • 无 = 根据第一个解码的结果排序。任何未解码的结果会排在解码的结果后。
  • 上到下 = 根据上升的X坐标定位特征值排序。
  • 左到右 = 根据上升的Y坐标定位特征值排序。
  • 字母顺序 = 根据结果的字母顺序排序。
  • 字符串长度 = 根据字符串的长度排序（最短至最长）。
  • 行 = 将符号分组到行，然后在每一行内从左到右排列结果。
  • 列 = 将符号分组到列，然后在每一列内从上到下排列结果。
已关闭 Allow Identical 1D Symbols（允许相同 1D 符号）

定义工具是否应解码区域内的所有符号（即使相同）。如果两个符号具有相同的长度、条码字符类型和解码的字符串，则视为相同（默认情况下，禁用此设置）。

已关闭 Verify（验证）

指定是否执行打印质量测试（默认情况下，此设置被禁用）。

已关闭 扩展 UPC-E

定义解码的符号是否返回 6 位数 UPC-E 字符串或扩展的 11 位数 UPC-A 等效字符串（默认情况下，启用此设置）。

注意:扩展 UPC-E 参数仅在运行固件版 4.10.1 及更高版本的 In-Sight Micro 1000 系列、In-Sight 5000 系列和 In-Sight 70xx - 74xx 系列视觉系统上受支持。
已关闭 超时

定义时间量，以毫秒为单位（0 - 30000；默认值 = 0），工具在搜索有效代码/符号的时间超过该值后将停止执行并返回“失败”。

已关闭 Number Decoded（已解码编号）

定义已解码的代码/符号数量。

注意:Maximum Results（最大结果数）、Match Mode（匹配模式）、Sort Mode（排序模式）、Allow Identical 1D Symbols（允许相同 1D 符号）和 Number Decoded（已解码编号）参数仅对读取 1D 代码 (1-20) 识别工具可用。


/ 读取 1D 代码和读取 1D 代码 (1-20) 识别工具 - 1D 选项卡

此选项卡定义要尝试解码的代码/符号。默认情况下，所有代码/符号类型均启用。可同时选择并读取多个符号。

已关闭 Code 128

定义工具是否将尝试读取 Code 128。

已关闭 Code 39

定义工具是否将尝试读取 Code 39（也称为“Code 3 of 9”和“BC39”）。

已关闭 Interleaved 2 of 5

定义工具是否将尝试读取 ITF-14。

已关闭 Pharmacode

定义工具是否将尝试读取 PharmaCode。

已关闭 UPC/EAN

定义工具是否将尝试读取 UPC（通用产品代码）和 EAN（欧洲商品编码）。UPC 支持 A 版本（常规版本）和 E 版本（零抑制版本）UPC 条码，以及两位和五位字符组成的补充编码。EAN 支持 EAN-8 和 EAN-13 条码，以及两位和五位字符组成的补充编码。

已关闭 Code 93

定义工具是否将尝试读取 Code 93。

已关闭 Codabar

定义工具是否将尝试读取 Codabar（也称为“USD-4”和“Code 2 of 7”）。


/ 读取一维代码和读取多个一维代码 (1-20) 识别工具 - 堆叠式选项卡

此选项卡定义要尝试解码的代码/符号。默认情况下，所有代码/符号类型均启用。可同时选择并读取多个符号。

已关闭 PDF 417

定义该工具是否尝试进行 PDF 417 读取。

已关闭 数据条

定义该工具是否尝试进行数据条读取。

已关闭 有限数据条

定义该工具是否尝试进行有限数据条读取。

已关闭 数据条已扩展

定义该工具是否尝试进行数据条已扩展读取。

已关闭 EAN.UCC 组合

定义该工具是否尝试进行 EAN.UCC 组合读取。


读取一维代码识别工具 - 结果选项卡

结果选项卡显示已解码代码/符号的下列相关信息：

已关闭 字符串

返回已解码的代码/符号中包含的字符串。

已关闭 符号

返回已解码的符号类型。

已关闭 等级

返回已解码的代码/符号的指定等级。


读取多个一维代码 (1-20) 识别工具 - 表格

表报告每个已解码代码/符号的下列信息：

已关闭 索引

表示已解码的代码/符号的顺序，基于排序模式参数；1 至 20（EasyBuilder 中的数字排序基于 0=1）。

已关闭 字符串

返回已解码的代码/符号中包含的字符串。

已关闭 符号

返回已解码的符号类型。

已关闭 X

返回已解码代码/符号定位特征输出的 X 坐标。

已关闭 Y

返回已解码代码/符号定位特征输出的 Y 坐标。

已关闭 角度

返回已解码代码/符号定位特征输出的角度值。

已关闭 等级

返回已解码的代码/符号的指定等级。


/ 识别工具 - 读取二维代码和读取多个二维代码 (1-20)

读取二维代码和读取多个二维代码（1-20 个）识别工具使用 ReadIDMax® 算法，可解码和/或验证 QR 码和/或数据矩阵符号。该工具报告解码信息，如果代码被成功解码并且在规定的阈值范围内，则报告合格。

读取二维代码识别工具可用于读取和/或验证区域内的单个符号，而读取多个二维代码（1-20 个）识别工具可用于读取和/或验证区域内最多 20 个符号。

设置工具

调整工具参数


/ 设置读取二维代码和读取多个二维代码 (1-20) 识别工具

添加工具之后，需要在图像中配置区域：

  1. 对于读取二维代码识别工具，将区域置于代码/符号之上，并确保区域的边界将所有代码/符号都包含在内。对于读取多个二维代码（1-20 个）识别工具，将区域置于您希望显示代码/符号的位置上，并确保区域的边界将所有想要进行解码的代码/符号都包含在内。为了提高工具的性能，可尝试创建较小的区域。区域越大，执行检查所需的时间越长。

    注意:当读取二维代码时，考虑代码和区域间的“空白区”很重要。“空白区”意味着代码边缘和定义代码的区域之间至少存在 3 个像素间距。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 确认区域后，需要在以下项中定义参数：设置选项卡：

    1. 符号组参数，将符号类型定义为数据矩阵或 QR 码（默认情况下，符号设置为数据矩阵）。
    2. 模式参数可定义工具的工作模式：读取或匹配字符串（默认情况下，模式被设置为读取）。
    3. 对于读取多个二维代码（1-20 个）识别工具，还需要定义最大结果数参数，该参数定义要进行解码的代码/符号数量（默认情况下设置为 1）。
  4. 该工具将围绕已解码的代码/符号绘制一个不可编辑的界限框，并 插入一个 [image] 图标以指示根据已解码的代码/符号创建的定位特征。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


/ 调整读取二维代码和读取多个二维代码 (1-20) 识别工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

读取二维代码识别工具和读取多个二维代码 (1-20) 识别工具 的设置栏由以下选项卡组成：

  • 常规选项卡
  • 设置选项卡
  • 结果选项卡
  • 表
注意:
  • 结果选项卡只在读取二维代码识别工具时启用。
  • 表选项卡只在 读取二维代码(1-20)工具时启用。
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

结果选项卡

表


/ 读取 2D 代码和读取 2D 代码 (1-20) 识别工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“IDCode_1”（如果该工具是添加到作业的第一个读取 1D 代码、读取 1D 代码 (1-20) 、读取 2D 代码、读取 2D 代码 (1-20) 或读取邮政编码识别工具，之后名称将递增，如“IDCode_2”、“IDCode_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


/ 读取 2D 代码和读取 2D 代码 (1-20) 识别工具 - 设置选项卡

已关闭 符号组

指定要尝试解码的符号系统类型（Data Matrix 或 QR 码；默认值=Data Matrix）。

注意:选择 QR 码时，该工具将尝试解码所有 QR 码类型（QR 模型 1/2，微型 QR 和 QR 模型1/2）。
已关闭 最大结果

定义要读取的代码/符号的最大数量（1 - 20；默认值 = 1）。

注意:如果指定的最大结果数值超过视野 (FOV) 中的代码/符号数量，该工具将继续搜索，以得到指定数量的代码/符号。如果 FOV 中的代码/符号数量发生变化，则可通过调整超时参数的值来减少工具的执行时间。
已关闭 已训练

显示该工具是否已对某一特定代码/符号进行过训练；已训练显示 1，未训练则显示 0。

已关闭 训练

训练代码/符号读取的模型；已训练的信息将保留直至按下未训练按钮。要重新训练某一代码/符号，请按未培训按钮，显示新代码/符号后，再按培训按钮。通过在工具中设定要解码的代码/符号类型，训练可帮助提高工具的速度和性能。使用读取多个一维代码（1-20 个）识别工具或读取多个二维代码（1-20 个）识别工具并进行训练时，先配置单个代码/符号周围的区域，再按训练按钮。对代码/符号进行训练后，可调整区域，以在视场 (FOV) 中的更大范围搜索多个代码/符号。仅可对区域中的单个代码/符号进行训练。如果对区域中的多个代码/符号按下训练按钮，则无法指明训练哪个代码/符号。在训练之前，请确保在符号系统组参数中选择正确的符号组（Data Matrix 或 QR）。

已关闭 未训练

撤消对已训练过的模型代码/符号的训练。要重新训练某一符号，请按未培训按钮，显示新代码后，再按培训按钮。

已关闭 读取角度

为 Data Matrix 符号系统指定解码设置（无读取角度，读取角度或训练读取角度;默认=无读取角度）。符号组参数必须设置为 Data Matrix 才能启用此参数。

  • 无读取角度=对没有读取角度失真的 Data Matrix 符号进行解码。
  • 读取角度=对具有读取角度失真的 Data Matrix 符号进行解码; 在模型训练和运行时间期间独立地估计读取角度失真。

  • 训练读取角度=对已知的读取角度失真的 Data Matrix 符号进行解码。当使用符号的训练模型时，读取视角会与其他属性一起训练。在运行时，符号会在输入图像中使用训练属性来弥补读取角度失真的空间中搜索。该选项要求运行时的符号被放置在与训练时符号相同的平面上。此选项允许您使用已知的读取角度失真值来解码严重损坏的符号。

    提示:建议将 In-Sight 视觉系统以不大于40度的角度（传感器光轴与所提供的符号平面线矢量之间的夹角）安装，符号的分辨率为每个单元至少 5 个像素。
已关闭 模式

定义工具的运行模式（读取或匹配字符串；默认值 = 读取）。

  • 读取 = 用于代码/符号中的信息未知的情况。该工具将会自动解码包含在代码/符号中的信息，并在字符串参数中显示解码的信息。
  • 匹配字符串 = 用于验证已知的代码/符号是否存在和可读取。该工具将解码代码/符号中包括的信息，并会将解码的信息与在匹配字符串参数中输入的信息进行比较。
已关闭 匹配字符串

定义预期要读取的字符串（仅在模式参数设为匹配字符串时启用）。输入该工具要解码的预期信息。

注意:匹配的字符串可从另一个设备输入。当您运行此作业时，该识别工具可从输入设备读取文本字符串并将其与已识别 ID 代码/符号进行比较。在从外部设备输入匹配 字符串之前，该工具会“失败”，且匹配字符串字段显示 TRIG。
已关闭 匹配模式

定义区域中所有已解码的代码/符号是否应与匹配字符串参数中定义的字符串匹配方可通过。要启用此选项，必须配置匹配字符串。

  • 全部匹配 = 所有已解码的代码/符号必须都与匹配字符串参数中定义的字符串匹配。
  • 任一匹配 = 至少一个解码的代码/符号必须与匹配字符串参数中定义的字符串匹配。
已关闭 排序模式

定义返回结果（如果有结果）的顺序（无，上到下，左到右，字母顺序或字符串长度；默认=无）。

  • 无 = 根据第一个解码的结果排序。任何未解码的结果会排在解码的结果后。
  • 上到下 = 根据上升的X坐标定位特征值排序。
  • 左到右 = 根据上升的Y坐标定位特征值排序。
  • 字母顺序 = 根据结果的字母顺序排序。
  • 字符串长度 = 根据字符串的长度排序（最短至最长）。
  • 行 = 将符号分组到行，然后在每一行内从左到右排列结果。
  • 列 = 将符号分组到列，然后在每一列内从上到下排列结果。
已关闭 检验

指定是否执行打印质量测试（默认情况下，此设置被禁用）。

已关闭 允许二进制结果

指定是否将函数解码为十六进制 ASCII DataMatrix 符号，编码为基本 256 二进制数据（默认情况下，此设置被禁用）。

已关闭 超时

指定时间值，以毫秒（0 - 30000；默认值 = 5000）。工具将在停止执行并且工具失败之前搜索有效的代码/符号。

已关闭 解码数量

定义已解码的代码/符号数量。

注意:最大结果，匹配模式，排序模式以及解码数目参数只在读取 2D 代码 (1-20) 识别工具时有效。


读取二维代码识别工具 - 设置选项卡

结果选项卡显示已解码代码/符号的下列相关信息：

已关闭 字符串

返回已解码的代码/符号中包含的字符串。

已关闭 条码字符

返回已解码的符号类型。

已关闭 等级

返回已解码的代码/符号的指定等级。


读取 2D 代码 (1-20) 识别工具 - “表”选项卡

表报告每个已解码代码/符号的下列信息：

已关闭 索引

表示已解码的代码/符号的顺序，基于排序模式参数；1 至 20（EasyBuilder 中的数字排序基于 0=1）。

已关闭 字符串

返回已解码的代码/符号中包含的字符串。

已关闭 条码字符

返回已解码的符号类型。

已关闭 X

返回已解码代码/符号定位特征输出的 X 坐标。

已关闭 Y

返回已解码代码/符号定位特征输出的 Y 坐标。

已关闭 角度

返回已解码代码/符号定位特征输出的角度值。

已关闭 等级

返回已解码的代码/符号的指定等级。


识别工具 - 读取 ID 代码

读取 ID 代码识别工具用于自动解码并验证包含在一维条码和二维矩阵符号中的信息。

设置工具

调整工具参数


设置读取 ID 代码识别工具

添加该工具之后，需要选择区域类型，然后在图像中进行配置：

  1. 将区域置于您希望显示代码或符号的位置上，并确保区域的边界将所有代码或符号都包含在内。为了提高工具的性能，可尝试创建较小的区域。区域越大，执行检查所需的时间越长。

    注意:读取二维代码时，请务必在代码和区域间酌留一个“空白区”。“空白区”意味着代码边缘和定义代码的区域之间至少存在 3 个像素间距。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 在确定区域之后，您将需要定义操作模式：读取或匹配字符串（默认情况下，模式被设置为读取）。此设置在设置选项卡中配置。
  4. 该工具将记住代码类型并在运行操作期间搜索该特定的代码类型。如果代码类型改变，请在设置选项卡中按学习按钮，以使工具可识别新的代码类型并随后搜索该代码类型。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。

支持的 ID 代码


支持的 ID 代码

读取 ID 代码识别工具支持以下代码和符号类型：

Code 39 | Code 128
Code I2of5 | UPC
EAN | PharmaCode
POSTNET | PLANET
RSS-14 及其堆叠式 | RSS 限制型
Codabar (NW-7) | Code 93
UPU 4-State | 澳大利亚邮政 4-State
日本邮政 4-State | USPS OneCode 4-State
Data Matrix | QR
RSS CC-A | RSS CC-B
PDF 417 |


调整读取 ID 代码识别工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

读取 ID 代码识别工具的设置窗格包含四个选项卡：

  • 常规选项卡
  • 设置选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡


读取 ID 代码识别工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“IDCode_1”（如果该工具是添加到作业的第一个读取 ID 代码识别工具，之后名称将递增，如“IDCode_2”、“IDCode_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


读取 ID 代码识别工具 - 设置选项卡

已关闭 学习按钮

定义一个新的代码类型或符号。可在为工具添加新代码或符号时使用学习按钮。为工具添加新代码或符号后，按学习按钮，工具将自动尝试解码。成功解码新代码类型或符号后，工具在今后将仅读取或检验该类型的代码或符号。

已关闭 代码

显示已解码代码或符号的类型。

已关闭 模式

定义工具的运行模式：读取或匹配字符串。

当代码或符号中的信息未知时可使用读取模式（模式的默认设置）。该工具将会自动解码包含在代码或符号中的信息，并在字符串参数中显示此解码的信息。

匹配字符串用于验证已知的条码或符号是否存在和可读取。该工具将解码条码或符号中包括的信息，并会将解码的信息与在匹配字符串参数中输入的信息进行比较。

注意:

此工具有两种状态：通过或失败。当工具的模式控制设置为匹配字符串时，在以下两种不同情况下，工具将返回“失败”：读取失败，或者读取成功但解码的信息与匹配字符串参数中输入的文本字符串不匹配。

在后一种情况中，工具会输出不匹配数据（Mismatch 和 Mismatch_Count），可供 EasyView 和其它通信设备在通信应用程序步骤中使用。可从选择 EasyView 项目对话框、选择 OPC 标记对话框或选择输入/输出数据对话框中选择不匹配数据。

当用户需要确定工具是否无法读取代码，或者可读取代码但读出的解码信息与定义的匹配字符串不匹配时，不匹配数据非常有用。例如，工具无法读取代码时，可能是标签打印过程或视觉系统设置存在问题。当代码读取成功但解码的信息与定义的匹配字符串不匹配时，可打印错误标签。

已关闭 匹配字符串

定义预期要读取的字符串（仅在模式参数设为匹配字符串时启用）。输入该工具要解码的预期信息。

注意:匹配的字符串可从另一个设备输入。当您运行此作业时，该识别工具可从输入设备读取文本字符串并将其与已识别 ID 代码进行比较。在从外部设备输入匹配字符串之前，“读取 ID 代码”工具会“失败”，且匹配字符串字段显示 TRIG。
已关闭 超时

定义以毫秒为单位的时间量（0 到 30,000），工具搜索代码超过此时间量后将停止执行并返回“失败”。

已关闭 字符串

显示解码的信息。


识别工具 - 颜色

颜色识别工具用于确定已训练颜色库中与图像中颜色最匹配的颜色。

此工具在许多应用场合中都很有用。例如，如果想要基于部件或对象的颜色来确保生产线上运行的是正确的产品，或者想要识别哪个产品正在运行并将该信息传达给其它工厂车间设备。

设置工具

调整工具参数


设置颜色识别工具

添加该工具之后，需要选择区域类型，然后在图像中进行配置：

  1. 在模型下拉菜单中，选择区域类型：矩形（默认）、 圆形、环形或多边形。在图像中定位和配置您希望颜色出现的区域; 确保该区域的边界覆盖颜色及其可能出现的位置。为提高工具的性能，可以创建较小的区域；较大的区域需要更长的检测时间。如果你没有使用定位原点, 请确保每个图像中的颜色大致位于同一位置，或者该区域足够大以包括预期颜色可能会出现的移动。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 配置完搜索区域之后，需要配置工具的颜色库并激活相应的颜色：

    • 如果是首次添加颜色识别工具，则需要先定义颜色库及其颜色。
    • 如果先前已添加另一个颜色识别工具，并且想要使用现有颜色库及其训
    • 练的颜色，请转到“设置”选项卡并选择所需的颜色库，然后在“库”选项卡中选中所需颜色以将其激活。
    • 默认情况下，如果尚未定义颜色库，工具将自动产生“失败”结果。如果已定义颜色库，则工具将自动使用该库并激活其中所包含的所有颜色。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。

像素的颜色组成


像素的颜色成分

每种颜色均由三种单独的颜色成分组成。这些成分可表现为红、绿和蓝色 (RGB) 或者色调、饱和度与亮度 (HSI) 的组合。对于 RGB 和 HIS，每种像素成分都会转化为 0 到 255 之间的值。

已关闭 RGB

RGB 颜色由红 (255, 0, 0)、绿 (0, 255, 0) 和蓝 (0, 0, 255) 以不同比例组合的图形阴影创建。此组合会为每个像素制出特定的颜色。

已关闭 HSI

对于 HIS，颜色的色调与电磁辐射频谱的可视部分范围的位置相呼应。

颜色的饱和度是颜色与灰色或白色混合的程度。完全饱和的颜色为纯色；当颜色由灰色或白色混合时，其饱和度降低。

颜色的亮度是对其明亮度的测量。颜色亮度被定义为红、绿和蓝成分所组成的颜色的平均值。色调、饱和度和亮度混合后可为每种像素调和出正确的颜色。

已关闭 RGB 和 HSI 值比较

RGB 值 = 255, 0, 0

HSI 值 = 0, 255, 85

RGB 值 = 0, 255, 0

HSI 值 = 85, 255, 85

RGB 值 = 0, 0, 255

HSI 值 = 170, 255, 85


调整颜色识别工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

颜色识别工具的设置窗格包含以下元素：

  • 常规选项卡
  • 设置选项卡
  • 表选项卡
  • 库选项卡
  • 组合区域选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

表格选项卡

颜色库选项卡

复合区域选项卡


颜色识别工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“ColorID_1”（如果该工具是添加到作业的第一个颜色识别工具，之后名称将递增，如“ColorID_2”、“ColorID_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


颜色识别工具 - 设置选项卡

已关闭 训练颜色

启动“MatchColor 训练”对话框，用于定义所选的颜色库颜色。

已关闭 颜色库

定义工具将引用的颜色库。从下拉列表中，选择要修改的颜色库，然后按训练颜色按钮以启动“MatchColor 训练”对话框。EasyBuilder 作业可以包含 5 个匹配颜色库。每个颜色库最多可包含 100 种不同颜色，这些颜色由所检查对象的 RGB/HSI 值组成。

已关闭 颜色空间

定义该工具会将哪些值用于其比较计算中：RGB（默认）或 HSI。每种颜色像素均由三种单独的成分组成。这些成分可表现为红、绿和蓝色 (RGB) 或者色调、饱和度与强度 (HSI) 的组合。RGB 和 HSI 都会将每个像素成分转换成介于 0 到 255 之间的值。

已关闭 模式

定义工具的运行模式：识别（默认）或匹配。

  • 识别：用于图像中颜色未知的情况。如果所选颜色库中有多个处于活动状态的颜色模型，该工具将确定哪个颜色模型与图像中的颜色最匹配，并根据像素计数对结果进行排序和分级。
  • 匹配：用于验证预期颜色模型是否存在于图像中。该工具将处理图像并确定图像中的颜色是否与指定颜色模型中匹配颜色参数所预期的颜色相匹配。
已关闭 匹配颜色

定义要检测的预期颜色。仅当模式参数设置为匹配时才会启用该字段。在该字段中输入预计要检测的颜色的名称。

已关闭 合格阈值

定义颜色和所找到颜色之间必须具有的相似度（0-100；默认值 = 90）。

已关闭 结果

显示所找到的颜色的名称。


颜色识别工具 - 表格选项卡

表选项卡显示所找到颜色的只读列表，该表按照颜色的排名和得分依次列出 10 个最佳匹配项。

已关闭 分级

按从 1 到 10 的顺序显示与检测标准最匹配的颜色的数字排名。

已关闭 颜色名称

显示所找到的颜色的名称。

已关闭 得分

显示所找到的颜色的得分。


颜色识别工具 - 颜色库选项卡

已关闭 颜色名称

显示所选匹配颜色库中颜色的只读列表。通过选中或取消选中颜色名称旁边的复选框来激活或取消激活各颜色。

注意:默认情况下，首次添加工具时，将自动激活（选中）匹配颜色库中预先存在的颜色。针对引用所选颜色库的每个工具必须手动取消激活（取消选中）颜色。如果没有为所选颜色库训练任何颜色，则该列表将为空。
已关闭 RGB

显示所选匹配颜色库中颜色的 RGB 平均值的只读列表。

已关闭 HSI

显示所选匹配颜色库中颜色的 HSI 平均值的只读列表。


颜色识别工具 - 复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


识别工具 - 读取邮政编码

读取邮政编码识别工具使用 ReadIDMax® 算法，可解码和/或验证某一区域内的单一邮政堆叠符号。该工具报告解码信息，如果代码/符号被成功解码并且在规定的阈值范围内，则报告合格。

设置工具

调整工具参数


设置读取邮政编码识别工具

添加工具之后，需要在图像中配置区域：

  1. 将区域置于代码/符号之上，并确保区域的边界将所有代码/符号都包含在内。为了提高工具的性能，可尝试创建较小的区域。区域越大，执行检查所需的时间越长。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 确认区域后，需要在以下项中定义参数：设置选项卡：模式参数可定义工具的工作模式：读取或匹配字符串（默认情况下，模式被设置为读取）。
  4. 该工具将围绕已解码的代码/符号绘制一个不可编辑的界限框，并 插入一个 [image] 图标以指示根据已解码的代码/符号创建的定位特征。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整读取邮政编码识别工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

读取邮政编码识别工具的设置窗格包含以下元素：

  • 常规选项卡
  • 设置选项卡
  • 邮政编码选项卡
  • 结果选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

邮编选项卡

结果选项卡


读取邮政编码识别工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“IDCode_1”（如果该工具是添加到作业的第一个读取 1D 代码、读取 1D 代码 (1-20) 、读取 2D 代码、读取 2D 代码 (1-20) 或读取邮政编码识别工具，之后名称将递增，如“IDCode_2”、“IDCode_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


读取邮政编码识别工具 - 设置选项卡

已关闭 模式

定义工具的运行模式（读取或匹配字符串；默认值 = 读取）。

  • 读取 = 用于代码/符号中的信息未知的情况。该工具将会自动解码包含在代码/符号中的信息，并在字符串参数中显示解码的信息。
  • 匹配字符串 = 用于验证已知的代码/符号是否存在和可读取。该工具将解码代码/符号中包括的信息，并会将解码的信息与在匹配字符串参数中输入的信息进行比较。
已关闭 匹配字符串

定义预期要读取的字符串（仅在模式参数设为匹配字符串时启用）。输入该工具要解码的预期信息。

注意:匹配的字符串可从另一个设备输入。当您运行此作业时，该识别工具可从输入设备读取文本字符串并将其与已识别 ID 代码/符号进行比较。在从外部设备输入匹配 字符串之前，该工具会“失败”，且匹配字符串字段显示 TRIG。
已关闭 匹配模式

定义区域中所有已解码的代码/符号是否应与匹配字符串参数中定义的字符串匹配方可通过。要启用此选项，必须配置匹配字符串。

  • 全部匹配 = 所有已解码的代码/符号必须都与匹配字符串参数中定义的字符串匹配。
  • 任一匹配 = 至少一个解码的代码/符号必须与匹配字符串参数中定义的字符串匹配。
已关闭 检验

指定是否执行打印质量测试（默认情况下，此设置被禁用）。

已关闭 超时

定义时间量，以毫秒为单位（0 - 30000；默认值 = 0），工具在搜索有效代码/符号的时间超过该值后将停止执行并返回“失败”。

已关闭 非定向

定义工具是否会尝试用非定向模式寻找条码（默认情况下，这个设置被禁用）。这个设置指定了扫描线（如1D符号，条码被分成最多10条间隔相等的线，也就是垂直方向扫过条码的扫描线。）在区域内投射的方向，以便检测条码内的所有元素。至少有一条扫描线必须投射穿过条码的每个元素以确保成功的正确解码。当该功能被禁用时，扫描线会投射在一个方向以检测和区域平行的条码。当该功能被启用时，扫描线会投射在不同的角度以检测相对于该区域来说旋转的条码。


读取邮政编码识别工具 - 邮政选项卡

此选项卡定义要尝试解码的代码/符号。默认情况下，所有代码/符号类型均启用。可同时选择并读取多个符号。

已关闭 POSTNET

定义该工具是否尝试进行 POSTNET 读取。

已关闭 PLANET

定义该工具是否尝试进行 PLANET 读取。

已关闭 日本邮政

定义该工具是否尝试进行日本邮政读取。

已关闭 澳大利亚邮政

定义该工具是否尝试进行澳大利亚邮政读取。

已关闭 UPU

定义该工具是否尝试进行 UPU 读取。

已关闭 智能邮件条码

定义该工具是否尝试进行智能邮件条码读取。


读取邮政编码识别工具 - 结果选项卡

结果选项卡显示已解码代码/符号的下列相关信息：

已关闭 字符串

返回已解码的代码/符号中包含的字符串。

已关闭 符号

返回已解码的符号类型。

已关闭 等级

返回已解码的代码/符号的指定等级。


识别工具 - 读取文本 (OCRMax)

读取文本(OCRMax)识别工具用于在训练和创建用户自定义字符字集后，读取和/或验证区域内的文本字符串。

读取文本识别(OCRMax)工具通过分段和分类的过程来实行光学字符识别(OCR)。首先进行分段并使用阈值技术来识别包含有文本行的图像区域。当文本被分段为字符后，字符会被训练并作为字集数据库被存储。在运行时，会执行分类。该过程负责”读取“任何在执行分类函数后找到的文本。并通过比较分段后字符的图像与字集中经过训练的字符来分类。

设置工具

调整工具参数


设置读取文本 (OCRMax) 识别工具

读取文本 (OCRMax) 识别工具的操作包括两个阶段：训练时间和运行时间。

  • 训练时间包括加载要读取的多个字符图像，从图像中提取字符图像，进行分割，然后创建字符的训练字集数据库。
  • 运行时间包括使 In-Sight 视觉系统联机，采集图像，以及根据训练的字集数据库提取字符并进行分类。
注意:开始设置工具前，应先加载训练图像。训练字集数据库时，Cognex 建议从最能代表字符效果的图像开始启动处理流程（即，首先使用最佳图像），按从最好到最差的顺序进行处理。
已关闭 训练读取文本 (OCRMax) 识别工具
  1. 加载第一个训练图像。
  2. 将读取文本 (OCRMax) 识别工具添加到作业。

  3. 添加工具之后，需要在图像中配置区域。将工具的区域置于待读取的文本行之上：

    • 区域的 X 轴应与文本基线平行，Y 轴应与字符的垂直笔画平行；如无倾斜，则 Y 轴垂直于 X 轴。
    • X 轴的正向对应于读取方向。
    • 区域中应该仅包含一个待读取的文本行以及部分周边背景。背景可以有干扰，并可存在明显的背景渐变/阴影。
    • 在含有文本、打印清晰且干扰很少的图像中，区域可能明显比文本行大。
    • 对于存在干扰的图像，文本行周围的区域应相对紧凑。
    • 区域应尽可能地在各个方向均大于文本行至少半个字符的宽度（即，除非如此大的边界可能导致其它特征也含在区域中，否则均应留出这个范围），这几乎已成为经验法则。
    注意:
    • 文本基线在图像中可以呈任何角度 (0-360)，前提是区域以大约相同的角度定向。
    • 除文本行外，区域不应包含图像中的任何其它重要特征。例如，区域不应部分包含邻近的其它文本行，或标记的边缘。
    • 如果区域是弯曲的，该工具会自动将区域解开成拉直的输出区域，并加上“弯曲区域位置”标签。它可以被重新定位到图像中以用于显示。

  4. 工具将根据分割选项卡中的默认设置，自动在其认定为字符的“文本”周围创建字符区域。

  5. 如果该功能没有在文本周围正确绘制字符区域，则可使用以下两个方法：

    • 使用“自动调整”对话框，并允许读取文本 (OCRMax) 识别工具自动计算最佳的分割设置。“自动调整”对话框会将分割和训练阶段合并为一个步骤。按照“自动调整”对话框主题中的说明，成功分割和训练字集数据库。
    • 转到分割选项卡，调整参数，直至文本正确包含到各个字符区域中。按照分割流程，在训练前成功分割图像数据库中的所有字符。
    注意:
    • 对于噪音图像以及难以读取的文本，可使用高级选项卡参数调整这种难以处理的情况。
    • 如字符间存在空格，则应转到空格选项卡，调整参数以补偿空格。
已关闭 分割后手动训练“读取文本 (OCRMax) 识别”工具

完成文本分割后，即可准备训练字符并将其添加到字集。首先，转到设置选项卡，从字集库参数中选择一个字集，从而可以选择字集数据库。

  • 如果创建新的自定义字集，则转到训练选项卡，输入待训练的准确文本字符串，然后按下全部训练按钮。字符将被添加并存储到选定的自定义字集中。

要向现有自定义字集添加更多字符，应采集或加载含有待训练字符的其它图像。如有必要，可重新配置区域和分割参数，确保对字符进行正确分割，然后按下训练选项卡中的训练新字符或训练选定字符按钮。

注意:自定义字集可作为作为以 OCRMax 数据文件 (*.ocm) 格式从训练选项卡中导入或导出。
  • 如果使用预定义的 OCRA 或 OCRB 字集，则只需将工具区域置于待读取的文本上，系统将根据定义的分割和高级参数设置，自动分割区域中的字符。
注意:不能编辑预定义的 OCRA 或 OCRB 字集。
已关闭 运行时操作

获得训练的字集数据库后，工具即准备执行运行时操作。

  1. 设置工具的运行时检查模式，确定工具是仅读取其区域中的文本，还是读取并验证是否读取了正确的字符串。
  2. 在运行时过程中，In-Sight 视觉系统将处于联机状态，按作业定义采集图像。采集图像后，该图像中的文本字符串将根据分割参数自动分割，并将对照字符的已训练实例比较字符。


调整读取文本 (OCRMax) 识别工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

读取文本 (OCRMax) 识别工具的设置窗格包含以下选项卡：

  • 常规选项卡
  • 设置选项卡
  • 分割选项卡
  • 高级选项卡
  • 空格选项卡
  • 可变长度选项卡
  • 训练选项卡
  • 字”选项卡
  • 诊断选项卡
  • 结果选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

分段选项卡

高级选项卡

空格选项卡

变量长度选项卡

训练选项卡

自定义字段选项卡

诊断选项卡

结果选项卡


读取文本识别(OCRMax)工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Text_1”（如果该工具是添加到作业的第一个读取文本识别(OCRMax)工具，之后名称将递增，如“Text_2”、“Text_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


读取文本 (OCRMax) 识别工具 - 设置选项卡

已关闭 字集库

定义工具引用的字集数据库。从四个预定义字集（OCRA 或 OCRB，黑底白字或白底黑字）中选择，或通过训练字符创建自定义字集数据库（每项作业最多可创建八个自定义字集数据库）。

注意:四个 OCRA 和 OCRB 字集为只读，不能重新训练、清除或重命名。
  • 选择其中一个预定义字集时，只需将该工具的区域置于要读取的文本上，该工具将自动分割该区域中的字符。
  • 选择自定义字集时，在首次构建自定义字集数据库时，应按照设置读取文本 (OCRMax) 识别工具主题中介绍的步骤进行操作。如果对现有的自定义字集进行修改，则使用同一自定义字集的任何其它“读取文本 (OCRMax)”工具也将受到影响。
已关闭 检查模式

定义工具的运行模式：读取（默认）或读取/验证。

  • 读取：工具将根据字符的已训练实例，尝试读取区域中的字符。
  • 读取/验证：工具将根据字符的已训练实例，先尝试读取区域中的字符，然后再验证读取的字符是否与匹配字符串参数中指定的文本字符串相对应。
已关闭 匹配字符串

定义在读取/验证检查模式中必须正确匹配的文本字符串。

已关闭 合格阈值

定义每个字符可以接受的最小匹配分数（0 到 100；默认值 = 80）。匹配分数低于合格阈值的任何字符均为失败。

已关闭 混淆阈值

定义分数最高的字符与分数第二高的字符在匹配分数上所要求的最小差异（0 到 40；默认值 = 0）。

已关闭 使用子采样

定义是否启用图像子采样，子采样将降低字符分辨率以提高功能的读取速度。

已关闭 超时

定义以毫秒为单位的时间量（0 到 30000；默认值 = 5000），工具搜索字符超过此时间量后将中止执行并报告“失败”。将这个值设置为 0 将禁用该设置，也不会应用超时。

已关闭 显示字符

定义是否在其它应用程序步骤中，或仅在定位部件和检查部件步骤中显示字符及其字符区域（默认情况下，此设置处于启用状态）。

已关闭 字符标记位置

定义字符标记相对于字符区域的放置位置：字符上方（默认）、字符右侧、字符下方或字符左侧。


读取文本 (OCRMax) 识别工具 -分割选项卡

分割选项卡用于调整和修改在区域中分割字符的设置。一般情况下，默认值和设置可以读取大多数文本，不过，在更具挑战性的情况下，可能需要调整部分参数值。在这种情况下，指定字符最小宽度、最大宽度和/或最小间距（即字符到字符的距离，例如，从一个字符的左边缘到其后字符左边缘的距离）,一般就可以解决问题。在遇到难以处理的情况时，为了加快字集数据库的创建，可使用自动调整按钮调出“自动调整”对话框，使工具自动计算最佳的分割设置。

已关闭 分割准则
  • 含有纹理清晰的背景和/或含有大量图像噪音以致字符混合到背景中的图像将很难分割。
  • 区域中应该仅包含要读取的字符，而不应包含任何无关的鲜明特征，如其它字符或标签边缘。
  • 在两个字符粘连的情况下，很有可能需要调整参数。对于固定宽度的粘连字符，可通过指定字符宽度加以补偿；不过，带粘连字符的非等宽字集会很难处理，其对应的功能可以正确处理部分问题，但也有一部分问题无法解决。
  • 对于涉及较短文本行（例如，只有三个字符或更少字符）或存在大量行抖动的相对较短的文本行的情况，指定预期的角度范围有助于该功能适当补偿确定短文本行定向过程中存在的固有不确定性。
  • 字符行中的所有字符在定向和倾斜上必须一致。
  • 对于分隔清晰的点阵打印（例如，点没有粘连），可能需要调整最小字符片段等参数以正确分割字符。
  • 字符笔画宽度必须大于或等于两个像素。
  • 较大字符（一般为字母数字字符）最小为 8 x 8 像素。较小字符（如句点）最小为 2 x 2 像素。
已关闭 自动调整

调出“自动调整”对话框，与“读取文本 (OCRMax) 识别”工具结合使用，对工具的分割参数进行配置，并通过构建“自动调整记录”创建“自动调整模型”，从而训练字集数据库。“自动调整记录”包含图像、训练字符串以及用户在图像中验证的字符位置。“自动调整模型”包含一项或多项“自动调整记录”，以及能够对“自动调整记录”中的所有图像进行最佳分割的设置。

注意:
  • Cognex 建议，在使用“自动调整”对话框时，应在 In-Sight 模拟器而非 In-Sight 视觉系统上执行分割调整。读取文本 (OCRMax) 工具的“自动调整”算法需要使用大量计算资源，在模拟器上的执行效果要比在视觉系统上好。
  • 在训练字集数据库并使用“自动调整”对话框分割字符时，Cognex 建议从最能代表字符效果的图像开始启动处理流程（即，首先使用最佳图像），按从最好到最差的顺序进行处理。这样有利于读取文本 (OCRMax) 工具的“自动调整”算法调整得更加成功。
已关闭 字符极性

在输入图像中定义字符极性：白底黑字、黑底白字或自动（默认）。

注意:如需提高工具性能，应定义文本极性。
  • 白底黑字：文本极性为白色背景、黑色文本。
  • 黑底白字：文本极性为黑色背景、白色文本。
  • 自动：工具将自动确定文本和背景的极性。
已关闭 字符宽度类型

定义字集中的字符宽度应如何变化：自动（默认）、固定或可变。

注意:字符宽度是指字符矩形的宽度，而非区域的宽度。
  • 自动：字符宽度未知；字集可能采用固定宽度或成比例宽度。
  • 固定：字集中的所有字符矩形宽度均相同。
  • 可变：字集中的字符可能具有宽度不同的字符矩形。
已关闭 最小字符宽度

以像素为单位定义最小字符矩形宽度（1 - 1000；默认值 = 3），出现这个宽度时，必须对字符进行报告。

已关闭 最小字符高度

以像素为单位定义最小字符矩形高度（1 - 1000；默认值 = 3），出现这个高度时，必须对字符进行报告。

已关闭 使用最大字符宽度

定义工具是否应考虑允许的最大字符矩形宽度（默认情况下，此参数处于禁用状态）。

注意:启用此参数后，宽度大于指定值的字符将被拆分成不太宽的段。
已关闭 最大字符宽度

以像素为单位定义最大字符矩形宽度（1 - 5000；默认值 = 100），出现这个宽度时，必须对字符进行报告。

已关闭 使用最大字符高度

定义工具是否应占有最大的字符矩形高度（默认情况下，此参数处于禁用状态）。

注意:这个值的使用方式有两种：第一种，在查找行时，将这个值作为一个整体使用，例如，用于拒绝垂直相邻的噪音和/或其它垂直相邻的字符行。第二种，高度超过这个值的单个字符将被修剪到这个高度。
已关闭 最大字符高度

以像素为单位定义最大字符矩形高度（1 - 5000；默认值 = 100），出现这个高度时，必须对字符进行报告。

已关闭 使用最小字符纵横比

定义功能是否应考虑允许的最小字符纵横比，其中纵横比定义为整个字符行的高度除以字符矩形宽度（默认情况下，此参数处于启用状态）。

注意:启用后，纵横比小于这个值的字符（即宽度过大）将被拆分为不太宽的段。
已关闭 最小字符纵横比

定义允许的最小字符纵横比（0-500；默认值 = 80）。

已关闭 角度范围

以度为单位定义角度搜索范围（0 - 45；默认值 = 0）。

注意:任何大于0的值将增加分段过程的执行时间。
已关闭 倾斜范围

以度为单位定义倾斜搜索范围（0 - 45；默认值 = 0）。

注意:任何大于0的值将增加分段过程的执行时间。
已关闭 显示诊断

定义是否在图像上显示图形诊断数据。启用后，将围绕保留字符（绿色）、拒绝字符（红色）、保留片段（青色）、拒绝片段（黄色）、文本主线（蓝色）以及文本扩展主线（品红）绘制“区域”。


读取文本识别(OCRMax)工具 - 高级选项卡

已关闭 字符片段合并模式

定义了在分段过程形成字符时，该工具应如何合并字符片段：要求重叠（默认），设置字符间最小间距或设置字符间最小间距/最大字符内间距。

  • 要求重叠：字符片段必须平行重叠至少一个像素以被合并。
  • 设置字符间最小间距：中间有一个平行间距的字符片段可以被合并来形成字符。任何两个片段间距小于在“设置字符间最小间距”参数中定义的值都将被合并。
  • 设置字符间最小间距/最大字符内间距: 中间有一个平行间距的字符片段可以被合并来形成字符。两个字符合并的决定将由在字符间最小间距和最大字符内间距参数中定义的值来决定。
已关闭 最小字符片段重叠

定义了两个字符片段必须在X方向互相重叠的最小分数（0 - 100；默认 = 0），以使两个片段被视为同一字符的一部份。

已关闭 最大字符内间隙

定义了能在单个字符（即使是破损的字符）间存在的最大间距，以像素为单位（0 - 1000；默认 = 5）。

已关闭 字符间最小间距

定义了能在两个字符间存在的最小间距，以像素为单位（0 - 1000；默认 = 0）。间距的测量从一个字符的字符矩形右边缘开始到下一个字符的字符矩形左边缘结束。如果两个片段间的间距小于该值，则片段必须被视为是同一字符的一部分。除非合并后的字符将太宽（由最大字符宽度和/或最小字符长宽比率参数所指定）。

已关闭 最小字符片段大小

定义为了被视为可能列入字符的一个片段所必需的最小前景数（即文本）像素（0 - 1000；默认 = 15）。一个字符片段就是一个在二值化图像中的对象。

已关闭 最小字符大小

定义为了被报告一个字符所必需的最小前景数（即文本）像素（0 - 5000；默认 = 30）。

已关闭 标准化模式

定义了用于标准化图像的模式：无、全局、本地或本地高级（默认）。

注意:该设置应该与培训和运行时间相同；在培训后更改该设置可能会导致分类问题。
  • 无：将不会执行任何标准化。
  • 全局：全局标准化已执行，请使用所有区域内的信息，不要使用本地变量。
  • 本地：本地标准化已执行，请使用区域内有关本地字符矩形的信息来标准化图像。
  • 本地高级：本地标准化已执行，请使用区域内有关本地字符矩形的信息来标准化图像，这不仅包括调整背景，还包括调整前景对比度。
已关闭 使用笔画宽度过滤

定义了是否要从标准化图像中删除所有不包含与其余图像相同笔画宽度的部分（默认情况下，该设置已被启用）。该设置在诸如字符间的相互连接显示混乱等情况非常有帮助。然而，使用此设置也可能会错误地删除正确字符，如果它们的笔画宽度不一致。

注意:该设置应该与培训和运行时间相同；在培训后更改该设置可能会导致分类问题。
已关闭 忽略边界片段

定义了函数是否完全忽略任何与边界区域接触的片段（在默认情况下，该设置已被启用）。忽略这些片段在诸如可能包括在区域内的标签的边缘等非文本特性的情况非常有帮助。

注意:如果一个片段从字符矩形的边缘延伸至文本的主线，这个片段将被视为一个字符。在参数被启用的情况下，该片段如需被排除，则必须不能延伸到文本的主线内。
已关闭 二值化阈值

定义了二值化前景和背景的标准化图像中用于计算二值化阈值百分比范围的调整（0 - 100；默认　= 50）。

已关闭 字符片段对比度阈值

定义为了被视为可能包含在一个字符内，相对于二值化阈值一个片段所必须拥有的最小对比度［标准化图像灰度级别（0 - 255；默认 = 30）］。

已关闭 距离主线的最大片段

定义了可能从“主线”在文本内平行运行中删除的片段，以像素为单位(0 - 1000; 默认 = 0)

已关闭 段分析模式

定义了用于确定最佳字符分割而运行的字符分析模式的类型：最小或标准（默认）。

  • 最小：根据分段参数来运行直接分割，。
  • 标准：对行作为整体进行分析（包括字符空间）以确定最佳分段。
已关闭 最小节距离(pitch)

定义了能在两个字符间出现的，根据字符节距（pitch）位置参数来计算的最小节距（pitch），以像素为单位(0 - 1000；默认 = 0)。如果两个片段间的节距小于该值，则片段必须被视为是同一字符的一部分。除非合并后的字符将太宽（由最大字符宽度和/或最小字符长宽比率参数所指定）。节距（pitch）被定义为相邻的字符的对应点（大约）之间的距离，而不是从一个字符结束到下一个字符开始之间的距离（这被称为字符间间距）。

已关闭 字符节距（pitch）位置

定义了如何测量字符间的节距（pitch）：自动（默认）、 左到左、中心到中心或右到右。

注意:
  • 如果分段分析模式 参数被设置成 最小，那么该参数将被禁用。
  • 术语“左”和“右”与区域定义的坐标轴相对应。例如：“右”相当于 X 的正方向。
  • 自动：指定了一个未知度量标准正在被使用；适当的节距（pitch）可能是任何其它节距（pitch）位置，或者没有一个恒定的节距（pitch）（可能是一个比例节距（pitch）字集）。
  • 左到左：指定了节距（pitch）将从字符的字符矩形左侧开始到相邻的字符的字符矩形左侧进行测量。
  • 中心到中心：指定了节距（pitch）将从字符的字符矩形中心开始到相邻的字符的字符矩形中心进行测量。
  • 右到右：指定了节距（pitch）将从字符的字符矩形右侧开始到相邻的字符的字符矩形右侧进行测量。
已关闭 字符节距（pitch）类型

定义了用来定义字符间空间的度量标准：自动（默认）、固定、按比例或变量。

注意:如果分段分析模式 参数被设置成 最小，那么该参数将被禁用。
  • 自动: 指定了节距（pitch）类型是未知，但是节距（pitch）类型预计将是固定或按比例，且不是变量。
  • 固定：指定节距（pitch）是固定的，也就是在任何一对字符间的节距（pitch）是恒定的（不论字符的字符矩形有多宽）。节距（pitch）将基于字符节距（pitch）位置参数来测量。

  • 按比例：指定节距（pitch）是按比例的，也就是在任何一对字符间的节距（pitch）取决于特定的字符。

    注意:
    • 尽管没有节距（pitch）的测量在字符串中是恒定的，往往字符间的间距，也就是从字符的字符矩形右侧到相邻字符的字符矩形左侧的距离是大约恒定的。
    • 术语“左”和“右”与区域定义的坐标轴相对应。例如：“右”相当于 X 的正方向。

  • 变量：指定没有字符到字符的距离度量标准在字符串中是始终一致的，即字符位置是不稳定的、且节距（pitch）既不是固定的也不是按比例的。

    注意:变量节距（pitch）与自动是不同的。因为自动假设节距（pitch）是固定的或按比例的，但这并不可知。
已关闭 跳过附加字符验证

定义工具是否要在分类过程中进行附加字符验证（默认情况下，该参数被禁用）。当该功能关闭时，工具将在分类过程中进行附加字符验证，这将降低误读的几率（例如错误地接受一个字符）。

已关闭 输出图像图表

定义了应该被显示的输出图像类型：输入图像（默认）、 标准化图像或二值图像。

  • 输入图像：当前的输入图像将被显示。
  • 标准化图像：标准化版本的图像将被显示。
  • 二值图像：二值版本的图像将被显示。


读取文本识别(OCRMax) 工具 - 空格选项卡

空格选项卡是用来指定工具该如何计算字符间的空间。读取文本识别(OCRMax)工具将以用户自定义的方式通过分类空格字符来处理字符间间距。

已关闭 查找空格

定义工具该如何处理插入字符间间距的空格字符：无空格(默认)、插入单个空格或插入多个空格。

  • 无空格：该工具不会插入一个空格字符，不论字符间间距有多大。
  • 插入单个空格：该工具会在每个字符间间距插入一个空格字符，不论字符间间距有多大。
  • 插入多个空格：该工具会在每个字符间间距插入x个（0个或更多个）空格字符。
已关闭 空格记分模式

定义了函数该如何计算空格的分值：总是得分100(默认)或在杂波基础上计分.

  • 总是得分100：空格字符将永远得分100。
  • 在杂波基础上计分：空格字符的得分基于背景像素的分数；一个由完全背景像素构成的空格字符将得分100。
已关闭 空格最小宽度

定义空格字符的最小宽度，以像素为单位(0 - 1000；默认 = 10)。

已关闭 空格最大宽度

定义空格字符的最大宽度，以像素为单位(0 - 1000；默认 = 100)。


读取文本识别 (OCRMax) 工具 - 变量长度选项卡

变量长度选项卡是用来提供有关字符预期在字符串中哪个不同位置出现的信息。

注意:这些参数仅在自定义字段选项卡参数被启用和配置后才能使用。
已关闭 字符串长度

定义自定义字段是运行固定长度（默认）模式还是可变长度模式。

  • 变量：该工具会在可变长度模式下运行。
  • 固定该工具会在固定长度模式下运行。
已关闭 最大字符串长度

定义最大可接受字符串长度，以像素为单位(0 - 100；默认 = 15)。

注意:如果字符串长度参数设置为 固定，该参数会被禁用。
已关闭 最小字符串长度

定义最小可接受字符串长度，以像素为单位(0 - 100；默认 = 5)。

注意:如果字符串长度参数设置为 固定，该参数会被禁用。
已关闭 最后分段最大指引

定义要考虑的自定义字段子序列，它开始的位置必须不能大于这个指引值(0 - 100; 默认 = 100)。

注意:如果字符串长度参数设置为 固定，该参数会被禁用。
已关闭 第一分段最小指引

定义要考虑的自定义字段子序列，它开始的位置必须不能小于这个指引值(0 - 100; 默认 = 0)。

注意:如果字符串长度参数设置为 固定，该参数会被禁用。


读取文本识别 (OCRMax) 工具 - 训练选项卡

训练选项卡能被用来训练、预览、重命名以及删除字符。该选项卡被分成两个组：训练组，其中定义了字符训练参数；字符组，其中管理训练过的字集。

注意:
  • 在训练选项卡中，区域能被调整且分割图形（字符矩形）在区域被修改时会被更新。
  • 不支持多字节字符的名称（如汉字）。多字节字符可以训练，但字符的名称必须是单字节的名称。
已关闭 训练控制
注意:在字符可以训练之前，它们必须被正确分段。
  • 训练字符串:指定需要被训练的文本字符串。在训练字符串文本输入框中的字符数必须与被分段的字符数匹配。最多可训练50个字符。
  • 训练所有字符：指定在区域内所有需要被训练的字符。需要被训练的字符要在点击训练所有按钮前输入训练字符串文本输入框。在训练字符串文本输入框中的字符数必须与被分段的字符数匹配。
  • 训练新字符：指定只训练在区域内的新字符。需要被训练的字符要在点击训练按钮前输入训练字符串文本输入框。在训练字符串文本输入框中的字符数必须与被分段的字符数匹配。
  • 训练所选择的字符：指定区域内特定的需要被选练的字符。当选择了该选项，训练字符串文本输入框会被禁用且训练所选择的字符按钮会启动添加选择的字符到字集对话框。该对话框包含了区域内解开的图像以及在每个分段的字符下有一个标签和文本输入框。标签是现在与该字符相关的符号（"?"“表示一个未知或未训练的字符）。在标签下的是一个文本输入框。在文本输入框中为每个分过段的字符输入一个标签；如不再训练字符，保留文本输入框为空。按训练按钮来关闭对话框。
已关闭 字符控制

训练之后，每个训练过的字符会在树形结构中显示，其中字符会被指定一个文件夹和标签并组合在一起（如果字符有匹配的标签）。

  • 在右边显示栏里选择主字集文件夹（root Font folder）来显示字集里所有的字符。字符将以图标显示，且有一个标签在字符下。
  • 在右边显示栏里选择一个字符文件夹来显示关于该字符的所有训练实例。字符将以图标显示，且有一个标签在字符下。

  • 选择一个字符的训练实例来显示该字符，缩放该字符使其适合右边的显示栏。

    提示:在运行期间使用多次训练实例工具来读取字符能让函数更好的区分相似的字符类型。然而，训练相同字符的多个实例有优点和缺点。训练多个实例的优点在于它能更好的执行分类，尤其是在读取比较容易被误分类的文本（如 8 和 B）。训练多个实例的缺点在于它会缩短函数执行的时间。且因为训练多个实例不仅会提高最高的分值，也会提高第二高的分值，所以置信度分值可能会降低。同时还存在训练无效字符的可能。
  • 导入：启动打开对话框，被保存为 OCRMax 数据文件(*.ocm)的字集会被导入。
  • 导出：启动另存为对话框，字集会被作为OCRMax 数据文件(*.ocm)来保存。

  • 重命名：在选择需要重新命名的条目后点击该按钮。任何在树形结构或右边列表栏中的项目都可以被重命名。

    注意:重命名一组字符会给该组内所有的字符分配一个新的标签。重命名一个字符会单给这个字符分配一个新的标签；而该字符会被移到树形结构下新的或不同的组。
  • 删除：选择需要从字集中被删除的条目，然后点击该按钮。任何在树形结构或右边列表栏中的项目都可以被重命名。
注意:删除字集文件夹会清除字集。所有字符会被删除。删除一组字符会删除所有其它与该组内标签匹配的字符。


读取文本识别 (OCRMax) 工具 - 自定义字段选项卡

自定义字段选项卡为创建和编辑读取文本识别(OCRMax)工具中的字段字符串以及字段定义参数提供了图形化手段。由此产生的值将作为字符串常值插入到工具中。

自定义字段提供了验证和修正字符串的功能，并返回最佳匹配的有效字符串。自定义字段有两种主要用法：

  • 可进行OCR结果验证，其中被返回的字符串将根据字段字符串以及字段定义参数来确定正确与否。
  • 可进行OCR结果修正，其中被返回的字符串将不在可接受的结果列表中，且试图找到一个被与返回字符串最接近的字段允许的可接受字符串。

自定义字段的一个典型用例为：当字符串含有前缀和/或后缀字符时，自定义字段会被用来忽略这些前缀/后缀字符。在这种情况下，字段字符串和字段定义将决定在区域内的字符串位移位置。

已关闭 字段字符串

指定字符串中包含的字符数。字段字符串 entry can be any alphanumeric character found in the text entry dialog, including (A to Z), (a to z), (0 to 9), dashes (-), dots (.), and spaces ( ).

字段字符串中的每个字符对应 0 到 31 之间的检索位置。字段字符串必须和需要读取识别的字符串包含至少相同数目的字符位置。（例如：如果当前有10个字符，但是字段字符串仅指定了9个字符，那么最佳匹配的9个字符将被返回。然而，如果当前有8个 字符，而字段字符串定义了9个字符，则函数会返回#ERR）。默认情况下，任何字段字符串中的位置都由星号(*)字符或字母数字“通配符”表示。这意味着任何字符在字符串的任何位置都有效。

然而，字段字符串中的个别位置能被限制为只被认为是该位置可能字符的一个子集。这将增加整体运行性能和可靠性，因为不在一个位置的字符将不在读取时被考虑。

预先定义的字段字符串条目有：

字段字符串条目 | 说明 | 有效的字符
* | 通配符 | 字集中任何训练过的字符。
N | 数字 | 0123456789
A | 大写字母 | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | 小写字母 | abcdefghijklmnopqrstuvwxyz
H | 十六进制、大写字母和数字 | 0123456789ABCDEF
h | 十六进制、小写字母和数字 | 0123456789abcdef
O | 八进制 | 01234567
注意:
  • 要限制一个字符在字段字符串中的位置，只需输入该字符。字符必须在字集中被训练过，且不能是以上预先定义的字段字符串条目中的一个。除非字符在字段定义参数中被重新设置。
  • 要读取一个包含有空格的字符串，请在字段字符串中也包含一个空格。“读取文本”将不会读取空格如果在那个位置相应的字段字符串条目是(*)。
已关闭 字段字符串示例1

如果字段字符串是**********AN，则字集中任何在字符串前10个字段字符串位置的字符都有效。但在第11个位置，仅大写的字母字符在读取时会被考虑。且在第12个位置，仅数字字符会被考虑。

已关闭 字段字符串示例2

字集中仅包含数字字符 0-9和 /。如果字段字符串是NN/NN/NN，在第一和第二、第四和第五以及第七和第八个位置，仅数字字符会被考虑。在第三和第六个位置，仅(/)字符会被考虑。

但是，如果字段字符串是NN/NN/AA，则读取会返回#ERR，因为字集中不含有任何字母字符。

已关闭 忽略未分段的字符

在每个字符位置定义是否包含一个仅包括在字符自定义字段中指定的字符的结果。当启用时，字集中所有其它的字符将被忽略，不论它们的分类得分。

已关闭 字段定义

（可选的）字段定义设置能被用来创建字段字符串用户自定义条目。当字段字符串中包含这些条目时，这些条目限制了字符在被插入位置的有效字符列表。有几个预先定义的字段定义以及用户自定义的字段定义能被添加。预先定义的字段定义文本显示为灰色，且不能被删除或编辑。仅能选择启用或禁用。用户自定义的字段定义文本显示为黑色，能被添加，删除或编辑。如需添加一个字段定义，点击添加新定义按钮，为字符指定一个标识，然后为字符指定定义。

在字段定义条目中列出的字符必须是包含在字集中的。例如：如果1、2和3包含在用户训练字集中，那么#=123就是有效的。如果1、2和3不包含在用户训练字集中，那么#=123就将会无效。

注意:使用以下任一在字段定义参数中预定义的条目(*, A, a, N, H, h, O)将会导致在新定义中重新设置有效字符列表。
已关闭 字段定义示例1

如果字段定义的值是#=123;$=3456;%=789且字段字符串是#$%*******，那么在第一个位置有效的字符只能是 1、2或者3。在第二个位置有效的字符只能是3、4、5或者6。在第三个位置，只有7、8或者9会有效。从第四到第十个位置，任何字集中的字符都有效。

已关闭 字段定义示例2

如果字段定义的值是#=123;$=3456;%=789, A=A且字段字符串是#$%******A，那么在第一个位置有效的字符只能是 1、2或者3。在第二个位置有效的字符只能是3、4、5或者6。在第三个位置，只有7、8或者9会有效。从第四到第九个位置，任何字集中的字符都有效。在第十个位置，仅字符A会被考虑，因为字段定义A=A 重新设置了在字段字符串条目中的预定义。


“读取文本 (OCRMax) 识别”工具 -“诊断”选项卡

“诊断”选项卡显示有关“读取文本 (OCRMax)”工具如何在区域中分割字符的信息。此数据可用于确定需要调整哪些参数，以及在字符和/或字符片段未正确分割的情况下，需要调整多少参数。结合使用此选项卡和显示诊断参数，以图形显示诊断数据。

已关闭 主线角度

以度为单位显示测量的字符区域相对于区域的角方向。

已关闭 字符倾斜

以度为单位显示测量的字符区域相对于区域的角倾斜。

已关闭 字符间间隔

以像素为单位显示测量的最小和最大字符间间隔。

已关闭 字符内间隔

以像素为单位显示测量的最小和最大字符内间隔。

已关闭 字符间距

以像素为单位显示测量的最小和最大字符间距。

已关闭 已接受片段大小

以像素为单位显示测量的最小和最大已接受片段。

已关闭 已接受片段对比度

以百分比显示测量的最小和最大已接受片段对比度。

已关闭 已接受片段到主线的距离 (%)

以主线高度的百分比显示所有已接受片段的最大 Y 距离。

已关闭 被拒绝片段大小

以像素为单位显示测量的最小和最大被拒绝片段。

已关闭 被拒绝片段对比度

以百分比显示测量的最小和最大被拒绝片段对比度。

已关闭 被拒绝片段到主线的距离 (%)

以主线高度的百分比显示所有被拒绝片段的最大 Y 距离。

已关闭 已接受字符宽度

以像素为单位显示测量的最小和最大已接受字符宽度。

已关闭 已接受字符高度

以像素为单位显示测量的最小和最大已接受字符高度。

已关闭 已接受字符大小

以像素为单位显示测量的最小和最大已接受字符。

已关闭 被拒绝字符宽度

以像素为单位显示测量的最小和最大被拒绝字符宽度。

注意:如果没有被拒绝字符，将显示 #ERR。
已关闭 被拒绝字符高度

以像素为单位显示测量的最小和最大被拒绝字符高度。

注意:如果没有被拒绝字符，将显示 #ERR。
已关闭 被拒绝字符大小

以像素为单位显示测量的最小和最大被拒绝字符。

注意:如果没有被拒绝字符，将显示 #ERR。


读取文本识别 (OCRMax) 工具 - 结果选项卡

已关闭 字符

显示在该位置读取的字符。

已关闭 状态

显示读取字符的状态(坏读取、好读取、忽略、混淆、不匹配、混淆不匹配、无读取或验证失败)。

  • 坏读取：没有分值高于接受阈值能被认为好读取的字符。
  • 好读取：该工具成功地读取了在该位置的字符。
  • 忽略：当自定义字段启用时，如果一个字段字符串被指定且短于被函数读取的字符串，在字符串起始和结束位置的字符会被分段（以黄色显示），但不会被包含在总体结果中。例如，自定义字段是ABC且被函数读取的字符串是"12ABC34"，则字符"1234"会被忽略。
  • 混淆：该工具定义了成功读取一个字符需要的分值(高于接受阈值参数值)，然而一个不同的字符和其有非常近似的分值时(在混淆阈值参数下的值)，[混淆 = (主要得分 - 次要得分)/置信度阈值]。
  • 不匹配：该工具会找到与自定义字段不匹配的字符，该字符的分值远远高于其它任何与自定义字段不匹配的字符。很可能一个与自定义字段不匹配的字符被打印在这个位置上。要返回这个状态，自定义字段必须被启用。
  • 混淆不匹配：该函数会找到一个同时符合混淆和不匹配的字符。
  • 无读取:该工具对少于在字段字符串中指定的字符数分段。要返回这个状态，自定义字段必须被启用。
  • 验证失败：如果“跳过附加字符验证”参数被禁用，该函数会在一个附加验证步骤中对字符进行分析以确保该函数不会产生错误的读取。
已关闭 得分

显示一个测量读取字符与在字集数据库中训练过的字符有多相近的分值。

已关闭 混淆

显示下一个最佳匹配字符。

已关闭 混淆度得分

在与下一个最佳匹配比较时，显示函数对所选择的匹配确定性的测量。


识别工具 - 读取文本

读取文本识别工具用于读取和/或验证字母数字文本字符串（使用训练的字符模式）。

注意:从 In-Sight 浏览器 4.7.0 开始，读取文本识别工具仅在不支持 OCRMax 的 In-Sight 视觉系统上可用，在运行 In-Sight 固件 5.1.0 及更高版本的 In-Sight 视觉系统上不可用。

设置工具

调整工具参数


设置读取文本识别工具

添加该工具之后，需要选择区域类型，然后在图像中进行配置：

  1. 将区域定位在文本上方，并确保区域的边界覆盖文本（有关详细信息，请参阅选择要读取的文本主题）。为了提高工具的性能，请尽量创建较小的区域。区域越大，工具执行检查所需的时间越长。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 区域被接受后，需要定义操作模式（读取、检验或读取和检验），选择字集类型（OCR-A 白底黑字、OCR-A 黑底白字、OCR-B 白底黑字、OCR-B 黑底白字或自定义），并根据模式在“设置”选项卡中的字段字符串或匹配字符串参数中指定字符数。
  4. 如果选择读取作为操作模式，并选择 OCR-A 或 OCR-B 作为字集类型，则在字段字符串参数中指定字符数，并按调整按钮以设置适当的缩放比例。

  5. 如果选择检验或读取和检验作为操作模式，选择 OCR-A 或 OCR-B 作为字集类型，则在匹配字符串参数中输入字符数，并按调整按钮以设置适当的缩放比例。

    注意:如果使用任意 OCR-A 或 OCR-B 字集，则图像中字符的像素值必须介于 15 到 60 之间。按调整按钮以适当缩放字符。如果字符小于 15 个像素或大于 60 个像素，您将需要创建自定义字集
    • 如果选择自定义作为字集类型，则先按训练字集按钮并创建字集库。创建完字集库后，请选择操作模式。若选择读取模式，则在字段字符串参数中指定字符数；若选择检验或读取和检验模式，则在匹配字符串参数中指定字符数。
    • 单个作业中最多可使用四个自定义字集（例如，“Custom_1”、“Custom_2”、“Custom_3”和“Custom_4”），当有一个以上的自定义字集添加到作业时，已训练字集可以在读取文本识别工具之间共享。
  6. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  7. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。

创建自定义字集

选择要读取的文本


创建自定义字集

  1. 要定义自定义的字集，可单击设置选项卡并按训练字集按钮。这将会启动训练字集对话框，您可在此对话框中配置应用程序的文本。

    注意:单个作业中最多可使用四个自定义字集（如“Custom_1”、“Custom_2”、“Custom_3”和“Custom_4”）。
  2. 在训练选项卡下，根据需要输入字集的自定义名称（如果您有多个字集库，这一点尤为重要）。

  3. 设置字符的极性：如果您将训练的字符比其周边的背景明亮，则选择暗底浅色字，否则请选择亮底深色字。

    在单击添加到字集之前请确保设置了正确的字符极性；一旦将字符模型添加到字集后就无法更改极性。

  4. 输入预期的文本字符串。确保预期的文本字串大小写与模型字符（大小写）匹配，如果在模型中存在空格，则可将空格添加到预期字符串中。

  5. 在输入文本字符串后，单击片段按钮。确保每个字符都具有单独的区域和标识符；如果没有，请使用片段调整执行以下操作：

    • 按修改按钮以调整特定字符实例周边的区域。
    • 按重新标记按钮以将新名称指定到字符实例中。
    • 按删除按钮以删除字符实例。
  6. 如果您对字符的标识满意，可单击添加到字集按钮。则字集将即刻包含从预期字符串中识别的各个字符的实例。
  7. 字集会立即包含七个字符模型，各模型可能包含多个实例。包含空格和标点符号在内的所有字符均会被分段并提供字符模型。

  8. 此时，您可以浏览字符模型并添加、删除、编辑和重命名或启用/禁用任何特殊字符模型或字符实例。

    注意:当有多个自定义字集添加到作业时，已训练字集可以在“读取文本标识”工具之间共享。
  9. 在对训练的字集满意后，按确定按钮。


选择要读取的文本

以下指导原则和需要考虑的事项有助于您取得一致的结果：

已关闭 字集
  • 使用针对 OCR/OCV 应用程序而设的特殊字集。
  • 确保字符每种笔划宽度至少 5 个像素。目的是让字符尽可能填满与图像一样大。每个字符的像素越大，工具的精确度就越高，然而执行时间将可能会略微长些。
  • 如果您在图像中有多种字集类型，对于每种字集类型请使用单独的“读取文本识别”工具。
  • 如果您在图像中有多种字集大小，对于每种字集大小请使用单独的“读取文本识别”工具。
已关闭 专用的 OCR/OCV 字集

已关闭 字符模型和实例
  • 使用高分辨率字符创建清晰的字符模型。
  • 单个“读取文本识别”工具最多支持 255 个字符模型，且每个字符模型基于达到 8 个字符模型的训练实例。训练其它字符模型的实例可增加在字符模型中工具的变化公差。如果应用程序不容许太大的公差，可只根据一个较好的示例训练字符模型。如果应用程序需要承受变化，可对照以可能多的实例训练字符模型。
  • 在训练字符模型的实例时，请确保字符的印刷以可能达到一致，由于字符形状和大小的明显变化会创建较差的字符模型并在运行时发生失败。
已关闭 训练实例

良好的字符模型训练实例。

无效的字符模型训练实例。


调整读取文本识别工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

读取文本识别工具的设置窗格包含四个选项卡：

  • 常规选项卡
  • 设置选项卡
  • 字符模型表
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

字符模型表


读取文本识别工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Text_1”（如果该工具是添加到作业的第一个读取文本识别工具，之后名称将递增，如“Text_2”、“Text_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


读取文本识别工具 - 设置选项卡

已关闭 训练字集按钮

启动训练字集对话框，您可在此对话框定义和编辑字集（字符模型和其实例）。

已关闭 模式

定义工具的运行模式：读取、检验或读取和检验。

  • 读取：该工具根据训练的字符模型解码文字字符串。解码的文本字符串必须与字段字符串参数中所定义的字符数匹配。
  • 检验：该工具根据在匹配字符串参数中定义的文本字符串解码文本字符串。
  • 读取和检验：该工具解码文本字符串并将已解码字符串与在匹配字符串参数中定义的字符串进行比较。已解码文本字符串必须与在匹配字符串参数中定义的字符串相匹配，方可归类为“通过”。
注意:此工具有两种状态：通过或失败。当工具的模式控制设置为检验或读取和检验时，在以下两种不同情况下，工具将返回“失败”：读取失败，或者读取成功但与匹配字符串参数中输入的文本字符串不匹配。

在后一种情况中，选择读取和检验模式时，工具会输出不匹配数据（Mismatch 和 Mismatch_Count），可供 EasyView 和其它通信设备在通信应用程序步骤中使用。可从选择 EasyView 项目对话框、选择 OPC 标记对话框或选择输入/输出数据对话框中选择不匹配数据。

当用户需要确定工具是否无法读取文本，或者可读取文本但与定义的匹配字符串不匹配时，不匹配数据非常有用。例如，工具无法读取文本时，可能是文本打印过程或视觉系统设置存在问题。当文本读取成功但与定义的匹配字符串不匹配时，可打印错误文本。

已关闭 字集

定义字集类型。您可以选择预先定义的字体类型（OCR-A 或 OCR-B，黑底白字或是白底黑字），或通过训练字符模型创建自定义字集。

注意:单个作业中最多可使用四个自定义字集（如“Custom_1”、“Custom_2”、“Custom_3”和“Custom_4”）。
已关闭 字段字符串

针对读取操作定义文本字符串中包含的字符数。字段字符串中的每个字符对应 0 到 31 之间的检索位置（最大字符数）。“字段字符串”中的位置数必须等于文本字符串中的字符数。

字段字符串输入可能包括大写或小写文本、数字、破折号、点和空格。默认情况下，字段字符串中的每个位置均表示为“*”（字母数字“通配符”），这就意味着在此文本字符串中的那个位置处任意字符均有效。

在此字段字符串中的个别位置可能会被定义，因此该工具仅考虑在那个位置的可能字符串的子集，从而增加此工具的整体性能和可靠性。

字段字符串输入 | 说明 | 有效的字符
* | 通配符 | 字集中任意训练的字符。
N | 数字 | 0123456789
A | 大写字母 | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | 小写字母 | abcdefghijklmnopqrstuvwxyz
H | 十六进制、大写字母和数字 | 0123456789ABCDEF
h | 十六进制、小写字母和数字 | 0123456789abcdef
O | 八进制 | 01234567
已关闭 匹配字符串

定义预期要读取的字符串（仅在模式参数设置为检验或读取和检验时启用）。输入该工具要解码的预期信息。

注意:匹配的字符串可从另一个设备输入。当您运行此作业时，该识别工具可从输入设备读取文本字符串，并将其与识别的文本进行比较。在从外部设备输入匹配字符串之前，“读取文本”工具会“失败”，且匹配字符串字段显示 TRIG。
已关闭 调整按钮

计算图像中的字符与字集库的训练字符模型之间的缩放差异（50% 至 200%）。“调整”按钮将仅在字符模型的大小和文本字符串中的字符之间的差异超过 ±5% 时可用。

已关闭 接受阈值

为文本字符串中的各个字符定义最小可接受的分数（0-100；默认 = 70）。如果文本字符串中的任意字符低于“接受阈值”，则整个文本字符串将失败。

已关闭 读取模式

定义文本读取算法模式：速度或精确度。速度模式（默认为读取模式）在要求快速工具执行时间内处理良好、高对比度的图像时效果较好，而精确模式在不要求快速执行的工具处理困难较大、低对比度的图像时效果较好。

已关闭 差异接受

定义在字符的最高和第二高分数之间所要求的最小可接受的差异值（0-20；默认 = 0）。如果差异分数等于或低于差异接受值，则整个文本字符串将失败。

已关闭 混淆背景

在与文本字符串混淆的图像中补充额外的特性（默认情况下，此选项为“关”或未选中）。在启用混淆背景时，工具的执行时间会略微增加。当区域中的其它功能在文本字符串的开始发生错误时，此选项尤其有用。

已关闭 缩放容差

允许在字符缩放中进行变化（默认情况下，此选项为“关”或未选中）。

已关闭 超时

定义以毫秒为单位的时间量（0 到 30,000），工具搜索文本超过此时间量后将停止执行并返回“失败”。

已关闭 结果

显示从文本字符串中解码或验证的信息。


读取文本识别工具 - 字符模型表

已关闭 索引

表示文本字符串中字符的位置。

已关闭 字符

通过最高分数显示模型字符（例如，最匹配文本字符串中字符的模型字符）。

已关闭 得分

通过最高分数表示模型字符中的信心级别。如果返回的值等于或低于接受阈值，则整个文本字符串将失败。

已关闭 通过

根据分数和字符差异列中的值分别是等于或低于（失败）、或高于（通过）接受阈值和差异接受参数，显示字符是失败还是通过。

已关闭 第二个字符

通过第二高分数显示模型字符（例如，接近于最佳匹配文本字符串中字符的模型字符）。

已关闭 第二个得分

通过第二高分数表示模型字符中的信心级别。

已关闭 字符差异

显示最高和第二高分数之间的差异。如果该值等于或低于差异接受参数，则整个文本字符串将失败。


识别工具 - PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10)

注意:
  • 从 In-Sight 固件版本 5.5.0 开始，该工具的算法已被更改，以在某些情况下返回更准确的结果并缩短执行时间。
  • 由于此更改，如果试图将在 In-Sight 固件 5.5.0 或更高版本中设置该工具的作业加载到运行固件版本 5.4.x 或更低版本的 In-Sight 视觉系统时，会显示错误消息。
  • PatMax RedLine 图形识别工具仅在运行 In-Sight 固件版本 5.2.0 和更高版本的 In-Sight 视觉系统上可用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

PatMax RedLine 图形工具和 PatMax 图形识别工具用于使用 PatMax RedLine 或 PatMax 算法训练图形特征，然后验证或识别图像中的特殊图形特征。

这些工具在下述应用中十分有用：例如，希望根据图标、标签或部件确保在产品生产线上输送正确的产品，或识别所输送的产品并将其信息传送给其他设备。

设置工具

调整工具参数


设置 PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 识别工具

添加该工具之后，需要选择并配置将定义图形的区域类型（模型区域），以及将在其中查找图形的图像中的区域（搜索区域）。

PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 识别工具允许创建一个多达 10 个不同模型图形的库。必须使用单独的图像训练每种模型图形；该工具可搜索所训练图形的个别情况的图像，但不能识别此图像中图形的多种情况。

  1. 从模型下拉菜单中，选择区域的类型：矩形（默认）、圆形、环形或多边形。然后将模型区域放置在将用于训练模型的图形上；请确保模型区域只覆盖图形的重要特征。添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。

  2. 从搜索下拉菜单选择区域类型：矩形（默认）、圆形、环形或多边形。然后定位搜索区域，使其覆盖图像中您希望图形出现的区域。为了帮助提高工具的性能，请创建较小的搜索区域。搜索区域越大，执行检查所需的时间越长。

  3. 按确定按钮确认区域（按取消按钮不将该工具添加到作业）。该模型区域将由训练图形的绿色略图所取代。

  4. 如要定义其他模型图形，则加载或获取具有新图形的新图像，从表中选择未训练的图形（已训练列中标记“未训练”），然后按模型区域按钮并重复步骤 1 至 3。
  5. 在初始配置该工具的情况下，根据需要加载几个图像并调整工具参数，以补偿预期的变化范围。
  6. 最后，如需要，可以使用工具的输入/输出属性表以在其他工具和/或其他外部设备之间共享工具数据。

选择图案特征

PatMax RedLine 图案、PatMax 图案以及图案


选择参照图形特征

选择要用于检测的图形时，为确保获得最佳结果，可考虑以下指导原则：

  • 图形始终出现在每个图像中。
  • 图形应尽可能多地包含独特和一致的现有特征，而组成图形的特征的外观和相对几何形状应彼此一致，且能够清楚分辨。
  • 如果可能，选择较大的图形；较大的图形通常意味图形中具有更独特的特征，可使检测更加一致和精确。


PatMax RedLine 图形、PatMax 图形和图形

注意:PatMax RedLine 图形识别工具仅在运行 In-Sight 固件版本 5.2.0 和更高版本的 In-Sight 视觉系统上可用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

PatMax RedLine 图形、PatMax 图形和图形可定位已训练的图形模型，且在定位和检测工具中提供最高准确性。然而，PatMax RedLine 图形和 PatMax 图形比图形的功能更强大，以应对灯光条件和图形位置的更大变化。它们还提供对图形比例和旋转变化、图形元素遮挡以及由于灯光条件导致的图形外观变化的出色识别。

PatMax RedLine 图形和 PatMax 图形之间的主要差别是速度；PatMax RedLine 图形采用最新图形匹配算法，可在 5 百万像素图像中以高出 PatMax 图形多达 7 倍的速度定位已训练特征。因此，PatMax RedLine 图形适用于高分辨率视觉系统。

图形（在大多数情况下）比 PatMax 快，但某些情况需要 PatMax RedLine 或 PatMax 版本的准确性和可靠性：

  • 当灯光和反射变化难以控制时。例如，金属部件可在任意方向反射光线。
  • 当要检查的图形与背景中的某些元素的形状或阴影类似，或图形与图像中的其他对象重叠或被其部分遮挡时。
  • 当希望从其他类似图形中准确识别一种图形类型时。
  • 当部署环境条件对于图形工具的一致且可靠执行过于苛刻时。


调整 PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 识别工具参数

在设置完工具的区域后，你可以开始为应用程序优化工具。

PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 识别工具的设置窗格包括以下选项卡：

  • 常规选项卡
  • 设置选项卡
  • 模型和搜索选项卡
  • 表选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

模型和搜索选项卡

表格选项卡


PatMax RedLine 图形（1-10）和 PatMax 图形（1-10）识别工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“ProductID_1”（如果该工具是添加到作业的第一个 PatMax 图形识别工具，之后名称将递增，如“ProductID_2”、“ProductID_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10)识别工具参数 - 设置选项卡

已关闭 模式

定义工具的操作模式：识别或验证。

当被检测图形模型为未知时，使用识别模式（默认模式）。该工具将自动检测图像（基于您的区域），并确定哪个在已训练过的图形模型库中的模型会被显示，并在结果参数中报告该信息。

验证模式用于验证正确的图形模型是否存在。该工具将检查指定图形模形的图像，并将找到的图形模型与图形模型参数中指定的模型进行比较。

已关闭 图形模型

定义要验证已训练的图形模型（要启用此设置，必须将模式设置为验证）。在已训练的图形模型中选择。

已关闭 合格阈值

定义样板模型与已找到的图形模型之间所必须存在的相似度（0-100;默认值= 65）。所找到的图形大于或等于该设置值将视为匹配。设置值越高，该工具的执行速度越快，这也需要样板模型与所找到图形之间具有更大的相似度。设置的值较低会得到更多精确度较低的相似结果，如检测到与模型图形相似但不是样板模型本身的图形。

已关闭 对比度阈值

定义已找到图形中必须存在的最小可接受对比度；已找到图形的对比度必须大于要视为有效实例的对比度阈值。PatMax RedLine 图形的默认值为 0，有效参数范围为 0-100。PatMax 图形的默认值为 10，有效参数范围为 0-255。低对比度阈值用于低对比度图像，而高对比度阈值用于高对比度图像。

注意:PatMax RedLine 图形对比度是已训练图形中的特征与搜索图像中的匹配特征之间的对比度变化的“相对”程度，以百分比表示。因此，如果特征对比度类似于或高于图形对比度，报告的对比度将约为 100。如果特征对比度低于图形对比度，报告的对比度将 <100。PatMax RedLine 图形的对比度不同于 PatMax 图形的对比度，后者是搜索 ROI 的“绝对”图像对比度，以灰度级表示。
已关闭 角度公差

定义找到的图形可从“模型”图案位置处旋转而仍被识别为有效图形的最大角度（± 0-180°；默认值 =15°）。允许较大的图形旋转偏差范围会增加该工具的执行时间。

已关闭 缩放公差

定义已找到图形和模型图形之间允许的缩放百分比（尺寸变化）（0-50；默认值为 0）。此值为正或负百分比，例如，值 5 将启用工具以查找介于模型图形尺寸的 95% 至 105% 之间的图形。允许更大的图形比例变化范围将增加工具的执行时间。

已关闭 差异接受

定义所找到的图形与任何已训练样板模型之间可能存在的分数的允许差异（0-20;默认值= 0）。该值是任何两个已训练的样板模型之间的分数差异，例如，值为5将确保该工具所找到的图形的分数至少比任何其他样板图形的分数高5。

已关闭 查找模式

定义用于训练和识别图案的搜索模式，PatMax 或 PatQuick。默认情况下会选择 PatMax。PatMax 的精确度比 PatQuick 高，但是需要更多的执行时间，而 PatQuick 的精确度比 PatMax 低，但是需要较少的执行时间。

已关闭 严格评分

定义找到图形的缺失或遮挡特征是否会影响分数（默认=关闭，未选中）。应用严格评分时（开启，选中），如果图形的特征缺失或被锁定，则会降低所发现图形的得分。

已关闭 超时
定义工具搜索图形的时间，以毫秒为单位（0 至 30,000）。超过该设定时间，操作会停止并返回错误信息。默认情况下，该参数的设置为1,000。
已关闭 结果

显示已识别的图形模型的名称。

注意:PatMax RedLine 图形不包含 Find Mode（查找模式）参数。


PatMax RedLine 图形（1-10）和 PatMax 图形（1-10）识别工具 - 模型和搜索选项卡

模型和搜索选项卡用于为工具的模型和搜索区域配置复合区域。复合区域是添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为“遮掩”）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 在模型选项卡中，仅在按模型区域按钮后才能启用复合区域。
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


PatMax RedLine 图形 (1-10) 和 PatMax 图形 (1-10) 识别工具 - 表选项卡

表选项卡包含已训练图形的表格以及已训练图形的图像缩略图。

已关闭 表选项卡

名称：此字段定义已训练图形的名称。通过指定一个与特殊应用相关联的名称来自定义工具。

已训练：此字段指示图形是否已训练。如果图形已训练，此字段将报告“已训练”，如果尚未训练，将报告“未训练”。

分数：此字段报告找到的已训练图形的分数。

注意:
  • 要从工具中删除图形，在表选项卡中右键单击该图形并从菜单中选择删除选项。
  • 表设置窗格具有三种视图选项：大图标、详细信息（默认）和平铺。要为设置窗格选择其它显示选项，请右键单击表中的任意位置，然后从“视图”子菜单中选择所需选项。
已关闭 模型区域按钮

此按钮启动图形训练。

已关闭 重新命名按钮

从表格中选择一个已训练图形，然后按此按钮将图形重命名为与特殊应用相关联的名称。

已关闭 已训练图像缩略图

模型区域按钮下方显示的图像为模型图形的缩略图。按模型区域按钮调整模型区域的大小或使其移动，然后按训练按钮重新训练模型图形。


识别工具 - 参照图形

参照图形识别工具用于训练存在的图形特征，然后验证并识别图像中存在的特殊图形特征。

此工具在许多应用场合中都很有用，例如，如果想要根据徽标、标签或部件来确保在生产线上运作的是正确的产品，或识别哪个产品正在运作并将该信息传达给其它工厂车间设备。

设置工具

调整工具参数


设置参照图形识别工具

添加该工具之后，需要配置将定义图形的图像中的区域（模型区域），以及将在其中查找图形的图像中的区域（搜索区域）。

图形 (1-10) 识别工具可以创建最多由 10 种不同的模型图形组成的库。必须使用单独的图像训练每种模型图形；该工具可搜索所训练图形的个别情况的图像，但不能识别此图像中图形的多种情况。

  1. 将模型区域置于将用作最初训练模型的第一个图形之上；确保模型区域仅覆盖图形的重要特性。

  2. 定位搜索区域，使其覆盖图像中希望图形出现的区域。为了帮助加速该工具的性能，请创建较小的搜索区域。搜索区域越大，该工具执行检查所需的时间越长。

    注意:模型和搜索区域无法弯曲为弧或圆环形状。
  3. 按确定按钮确认区域（按取消按钮不将该工具添加到作业）。该模型区域将由训练图形的绿色略图所取代。
  4. 要定义另一个模型图形，可加载或采集具有新图形的新图像，并从该表中选择一个未训练的产品（在已训练列中标记为“未训练”），然后按模型区域按钮，重复执行步骤 1 至步骤 3。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整参照图形 (1-10) 识别工具参数

在设置完工具的区域后，你可以开始为应用程序优化工具。

图形 (1-10) 识别工具的设置窗格包含以下选项卡：

  • 常规选项卡
  • 设置选项卡
  • 表选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

表格选项卡


图形识别工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“PatternID_1”（如果该工具是添加到作业的第一个图形识别工具，之后名称将递增，如“PatternID_2”、“PatternID_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


参照图形 (1-10) 识别工具 – 设置选项卡

已关闭 模式

定义工具的运行模式：识别或验证。

识别（默认模式）在被检测的图形为未知时使用。该工具将会自动检查图像（根据区域）并从图形训练库中确定哪种图像要选择，而且会在“结果”参数中报告那方面的信息。

验证常用于验证正确的图形是否存在。该工具将会检查特定图形的图像，并相对于在图形参数中指定的图形来比较所发现的图形。

已关闭 图形

定义要验证哪些训练图像（若要启用此设置，该模式必须设为验证）。从所训练的图形中进行选择。

已关闭 接受阈值

定义模型图形和所发现图形之间必须存在的相似程度（0-100；默认值 = 50）。大于或等于设置值的所发现图形视为匹配。设置值越高，此工具执行速度越快，这也需要模型和发现的图形之间具有更大的相似度。设置值较低可以得到更多精确度较低的相似结果，如，检测到与模型图形相似但不是模型图形本身的图形。

已关闭 旋转公差

定义容许发现的图形相对于“模型”图形的位置旋转、但仍可被识别为有效图形的最大角度（± 0-180°；默认值 =15°）。允许较大的图形旋转偏差范围会增加该工具的执行时间。

已关闭 缩放公差

定义在图形的缩放中变动的工具公差，且限制在 ±10% 的训练图形的大小内。默认情况下，此设置为关（未选中），即禁用缩放比例调整。在此运行模式下，该工具仍会查找大小变化在 ±10% 范围内的图形，但特性的得分会随缩放百分比的增加而减少。

已关闭 差异接受

定义在所发现图形和任意训练的模型图形之间可能存在的分数方面所允许的差异（1-20；默认值 = 0）。该值为任意两个训练的模型图形之间的分数差异，例如值为 5 则将确保该工具找到分数比任意其它模型图形分数至少大 5 的图形。

已关闭 准确性

定义工具将如何在准确性/可靠性和执行速度之间取得平衡；准确, 中度(默认)以及快速。准确表明读取结果含有很高的准确性/可靠性，可是读取速度会比较慢；快速表明读取的准确性/可靠性会比较低可是读取速度比较快；中度则表明在准确性/可靠性和速度中间取一个平衡值。

已关闭 模型类型

定义工具如何构造模型图形；区域模型或边模型（默认）。区域模型根据模型区域中一致的灰度值采样来创建模型图形。边模型根据在“模型”区域内检测到的图形特征的边（明/暗转换）来创建模型图形。

已关闭 超时

定义以毫秒为单位的时间量（0 到 30,000），工具搜索图形超过此时间量后将停止执行并返回“失败”。

已关闭 结果

显示所识别图形的名称。


参照图形 (1-10) 识别工具 – 表格选项卡

表选项卡包含训练的图形表和训练的图形的图像缩略图。

已关闭 表选项卡

名称：该字段定义训练的图形名称。通过为工具分配与特定应用程序关联的名称来自定义工具。

已训练：该字段指明图形是否已被训练。该字段在图形已训练时会报告“已训练”，在图形没未训练时报告“未训练”。

得分：该字段报告所发现的训练图形的分数。

注意:
  • 要从工具中删除图形，在表选项卡中右键单击该图形并从菜单中选择删除选项。
  • 表设置窗格具有三种视图选项：大图标、详细信息（默认）和平铺。要为设置窗格选择其它显示选项，请右键单击表中的任意位置，然后从“视图”子菜单中选择所需选项。
已关闭 “模型区域”按钮

此按钮会启动图形训练。

已关闭 “重命名”按钮

从该表中选择训练的图形，然后按这个按钮以将此图形重命名为与特定应用程序关联的名称。

已关闭 “训练图像”缩略图

在模型区域按钮下方显示的图像是模型图形的缩略图。按模型区域按钮可调整模型区域的大小或移动该区域，然后按训练按钮重新训练模型图形。


识别工具 - 颜色模型

颜色模型识别工具用于确定颜色模型库中与图像中的颜色最匹配的颜色模型，并返回匹配的颜色模型的名称。

颜色模型工具引用已训练的颜色模型库，然后确定区域中与库中所选的已训练颜色模型相匹配的像素数量。根据工具的运行模式（识别（默认设置）或匹配），工具将返回与检测标准最匹配的颜色模型的名称。工具还会创建一个二进制灰度输出图像，将其中与处于活动状态的颜色模型匹配的所有像素都设置为“白色 (255)”，而其它所有像素设置为“黑色 (0)”。

设置工具

调整工具参数


设置颜色模型识别工具

添加该工具之后，需要选择区域类型，然后在图像中进行配置：

  1. 在模型下拉菜单中，选择区域类型：矩形（默认）、 圆形、环形或多边形。在图像中定位和配置您希望颜色出现的区域; 确保该区域的边界覆盖颜色及其可能出现的位置。为提高工具的性能，可以创建较小的区域；较大的区域需要更长的检测时间。如果你没有使用定位原点, 请确保每个图像中的颜色大致位于同一位置，或者该区域足够大以包括预期颜色可能会出现的移动。

    注意:添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 配置搜索区域后，需要配置该工具的颜色库并激活相应的颜色模型：

  • 如果这是首次添加颜色工具（“彩色斑点”与“彩色斑点 (1-10)”定位工具、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”与“彩色斑点面积 (1-10)”测量工具、“彩色斑点”计数工具、“颜色模型”识别工具或“颜色转为二进制”图像过滤工具），需要首先定义颜色库及其颜色模型。

  • 如果先前已添加另一个颜色工具，并且想要使用现有颜色库及其训练的颜色模型，请转到“设置”选项卡并选择所需的颜色库，然后在“库”选项卡中选中所需颜色模型以将其激活。

  • 默认情况下，工具将自动产生“失败”，直至定义颜色库。如果已定义颜色库，则工具将自动使用该库并激活其包含的所有颜色模型。

  4. 设置颜色模型和颜色库后，该工具将处理图像，搜索区域内与所选颜色模型匹配的所有像素都会变为白色 (255)，而与颜色模型不匹配的像素则会变为黑色 (0)。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整颜色模型识别工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

颜色模型识别工具的设置窗格包含以下元素：

  • 常规选项卡
  • 设置选项卡
  • 表选项卡
  • 颜色库选项卡
  • 组合区域选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

颜色库

表格选项卡

复合区域选项卡


颜色模型识别工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“ColorModelIdentification_1”（如果该工具是添加到作业的第一个颜色模型识别工具，之后名称将递增，如“ColorColorModelIdentification_2”、“ColorColorModelIdentification_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


颜色模型识别工具 - 设置选项卡

已关闭 训练颜色

启动“ExtractColor 训练”对话框，用于定义所选颜色库的颜色模型。

已关闭 颜色库

定义工具将引用的颜色库。从下拉列表中，选择要修改的颜色库，然后按训练颜色按钮启动“ExtractColor 训练”对话框。每个颜色库最多可包含 100 种不同的由各个颜色组成的颜色模型。

EasyBuilder 作业最多可包含 5 个颜色库，可在下列工具之间共享颜色库：

  • 彩色斑点定位工具
  • 彩色斑点 (1-10) 定位工具
  • 颜色像素计数存在/不存在工具
  • 彩色斑点面积测量工具
  • 彩色斑点面积 (1-10) 测量工具
  • 彩色斑点计数工具
  • 颜色模型识别工具
  • 颜色转为二进制图像过滤工具
已关闭 模式

定义工具的运行模式：识别（默认）或匹配。

  • 识别：用于图像中颜色未知的情况。如果所选颜色库中有多个处于活动状态的颜色模型，该工具将确定哪个颜色模型与图像中的颜色最匹配，并根据像素计数对结果进行排序和分级。
  • 匹配：用于验证预期颜色模型是否存在于图像中。该工具将处理图像并确定图像中的颜色是否与指定颜色模型中匹配颜色参数所预期的颜色相匹配。
已关闭 匹配颜色

定义要检测的预期颜色模型。仅当模式参数设置为匹配时才会启用该字段。在该字段中输入预计要检测的颜色模型的名称。

已关闭 最小像素计数

定义最小像素计数阈值（0 到 9,999,999；默认值 = 1000）以确定是否将某颜色模型视为匹配项。例如，在识别模式下，如果阈值设置为 1,000，则所返回的像素计数低于 1,000 个像素的所有颜色模型都将被自动排除；在匹配模式下，如果预期颜色模型产生少于 1,000 个匹配像素，则工具将返回失败。

已关闭 结果

显示所找到的颜色模型的名称。


颜色模型识别工具 - 颜色库

已关闭 颜色模型列表

显示所选颜色库中包含的颜色模型的只读列表。通过选中或取消选中颜色模型名称旁边的复选框来激活或禁用颜色模型。

已关闭 颜色表

显示所选颜色模型中颜色的只读排序表。

已关闭 颜色名称

显示所选颜色模型中颜色的名称。

已关闭 RGB

显示所选颜色模型中颜色的 RGB 值。

已关闭 运算

显示所选颜色模型中颜色的运算（加或减）。


颜色模型识别工具 - 表格选项卡

表选项卡显示所找到的颜色模型的只读列表，该表按照颜色模型的排名和得分依次列出 10 个最佳匹配项。

已关闭 分级

按从 1 到 10 的顺序显示与检测标准最匹配的颜色模型的数字排名。

已关闭 名称

显示所找到的颜色模型的名称。

已关闭 像素计数

显示所找到的颜色模型的像素计数。


颜色模型识别工具 - 复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


几何工具 - 点到点的直线

点到点：直线几何工具用于在任意两个输入特征（点、固定原点或圆形特征的中心）之间生成一条参考线，并报告所生成直线的两个端点的 X、Y 坐标。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置点到点：直线几何工具

添加工具之后，您需要定义将用于构造参考线的输入特征（点、定位特征或圆形特征的中心）：

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 首先，从可用特征中选择一个特征（只需单击该特征即可，这时其颜色将变为洋红，且该特征中会延伸出一条直线）。
  3. 接着，选择第二个特征。
  4. 在选择第二个特征之后，EasyBuilder 将会自动在两个特征之间构造一条直线。 EasyBuilder 还将为先前未定义的所有特征插入“边存在/不存在”工具和/或“圆存在/不存在”工具（根据工具和特征的类型）。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整点到点直线几何工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

点到点的直线几何工具的设置窗格包含以下内容：

已关闭 常规选项卡
已关闭 工具名称

定义检查工具的名称，在配置结果（输入、输出和通信）时会利用该名称。默认名称为“Line_1”（该工具是添加到作业的第一个定义直线的工具，之后名称将递增，如“Line_2”、“Line_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。


几何工具 - 点到点：中点

点到点：中点几何工具用于计算两个输入特征（点、固定原点或圆形特征的中心）之间的中点，在两个特征之间生成参考线，并报告中点相对于固定原点的角度及中点的 X、Y 坐标。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置点到点：中点几何工具

添加工具之后，您需要定义将用于构造参考线的输入特征（点、定位特征或圆形特征的中心）：

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。

  2. 首先，从可用特征中选择一个特征（只需单击该特征即可，这时其颜色将变为洋红，且该特征中会延伸出一条直线）。

  3. 接着，选择第二个特征。

  4. 在选择第二个特征之后，EasyBuilder 将自动在两个特征之间构造一条直线，并在中点位置放置一个 [image] 。 EasyBuilder 还将为先前未定义的所有特征插入“边存在/不存在”工具和/或“圆存在/不存在”工具（根据工具和特征的类型）。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整点到点：中点几何工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

点到点的中点几何工具的设置窗格包含以下内容：

已关闭 常规选项卡
已关闭 工具名称

定义检查工具的名称，在配置结果（输入、输出和通信）时会利用该名称。默认名称为“Point_1”（该工具是添加到作业的第一个定义点的工具，之后名称将递增，如“Point_2”、“Point_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

已关闭 设置选项卡
已关闭 中点

报告两个输入特征之间的中点的 X,Y 坐标，以及中点相对于定位特征的角度方向。

注意:该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。


几何工具 - 点到点的距离

点到点的距离几何工具用于计算两个输入特征（点、固定原点或圆形特征的中心）的中点之间相对于边或直线的距离，并生成一条参考线以表示所计算的距离，同时报告计算出的距离。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

点到点的距离几何工具在需要测量组件对齐的精确度时很有用。

设置工具

调整工具参数


设置点到点：尺寸几何工具

添加工具之后，您需要定义将用于构造参考线的输入特征（点、定位特征或圆形特征的中心）：

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 首先，从可用特征中选择一个特征（只需单击该特征即可，这时其颜色将变为洋红，且该特征中会延伸出一条直线）。
  3. 接着，选择第二个特征。
  4. 在选择第二个特征之后，EasyBuilder 将再次自动检查图像，并列出一组可用作测量参照线的边或直线智能特征供选择。选择要参考的边或直线特征。
  5. 随后，EasyBuilder 会从特征的中点投影垂直于所选参考边或参考线的参考线，并根据投影的垂直参考线与所选参考边或参考线之间的关系计算距离。 EasyBuilder 还将为先前未定义的所有特征插入“边存在/不存在”工具和/或“圆存在/不存在”工具（根据工具和特征的类型）。
  6. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  7. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整点到点：尺寸几何工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

点到点的尺寸几何工具的设置窗格包含以下内容：

  • 常规选项卡
  • 范围限制选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

范围限制选项卡


点到点：尺寸几何工具 - 常规选项卡

已关闭 工具名称

定义检查工具的名称，在配置结果（输入、输出和通信）时会利用该名称；默认名称为“Dimension_1”（如果该工具是添加到作业的第一个“点到点的尺寸”几何工具，之后名称将递增，如“Dimension_2”、“Dimension_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


点到点：尺寸几何工具 - 范围限制选项卡

已关闭 最大值

定义最大可接受距离值；该工具将根据图像创建智能限制默认设置，这样可进行自定义以满足应用程序的需要。

已关闭 距离

报告两个特征中点相对于参考边或参考线的垂直投影参考线之间的当前测量距离；介于最小和最大值设置（包括二者）之间的值归类为“通过”。

注意:该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
已关闭 最小值

定义最小可接受距离值；该工具将根据图像创建智能限制默认设置，这样可进行自定义以满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


几何工具 - 垂直线

垂直线几何工具用于生成垂直于另一条直线或边特征的直线，并报告所生成直线端点的 X、Y 坐标。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置垂直线几何工具

添加该工具之后，需要定义要查找哪些直线或边特征的垂直线：

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 从可用特征中选择直线或边特征（只需单击该直线或特征即可），这时 EasyBuilder 将自动确定垂直线与选定直线或边特征的交点，并插入一条参考线来定义该交点，还将为先前未定义的所有边特征插入边存在/不存在工具。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整垂直线几何工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

垂直线几何工具的设置窗格包含以下内容：

已关闭 常规选项卡
已关闭 工具名称

定义检查工具的名称，在配置结果（输入、输出和通信）时会利用该名称。默认名称为“Line_1”（该工具是添加到作业的第一个定义直线的工具，之后名称将递增，如“Line_2”、“Line_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。


几何工具 - 直线交点

直线交点几何工具用于确定两条边特征和/或两条线相交的交点，并报告交点的 X、Y 坐标。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置直线交点几何工具

添加该工具之后，需要定义将相交的边特征和/或直线：

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 首先，从可用特征中选择一个特征（只需单击该特征即可，这时其颜色将变为洋红，且该特征中会延伸出一条直线）。
  3. 接着，选择将相交的边特征或直线。
  4. 在选择第二个特征之后，EasyBuilder 将自动确定直线的交点，并插入一个点来定义相交。 EasyBuilder 还将为先前未定义的所有特征插入“边存在/不存在”工具和/或“圆存在/不存在”工具（根据工具和特征的类型）。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整直线交点几何工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

“直线交点”几何工具的设置窗格包含以下内容：

已关闭 “常规”选项卡
已关闭 工具名称

定义检查工具的名称，在配置结果（输入、输出和通信）时会利用该名称。默认名称为“Intersect_1”（如果该工具是添加到作业的第一个“圆与直线的交点”或“直线交点”几何工具，之后名称将递增，如“Intersect_2”、“Intersect_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。


几何工具 - 平分角

平分角几何工具用于构造一条定义两条边特征或两条直线之间平分角的参考线，并报告平分角和两条直线末端的 X、Y 坐标。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

平分角几何工具在需要确定部件上两个特征之间的平分角时非常有用。例如，在使用平分角作为其它测量的参考点时。

设置工具

调整工具参数


设置平分角几何工具

添加该工具之后，需要定义将用于构造平分参照线的边特征或直线：

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 首先，从可用特征中选择一个特征（只需单击该特征即可，这时其颜色将变为洋红色）。
  3. 接下来选择将用于定义要平分的区域的第二条边或直线，单击该边或直线即可。
  4. 随后，EasyBuilder 将自动从选定的边特征或直线构造一条参照线。 EasyBuilder 还将为先前未定义的所有特征插入“边存在/不存在”工具和/或“圆存在/不存在”工具（根据工具和特征的类型）。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整平分角几何工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

“平分角”几何工具的设置窗格包含以下内容：

已关闭 “常规”选项卡
已关闭 工具名称

定义检查工具的名称，在配置结果（输入、输出和通信）时会利用该名称。默认名称为“Bisect_1”（如果该工具是添加到作业的第一个“平分角”几何工具，之后名称将递增，如“Bisect_2”、“Bisect_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。


几何工具 - 由 N 个点构成的直线

由 N 个点构成直线几何工具可以用来构造一条由 2 到 10 个输入特征（点、特征原点或圆形特征的中心），并报告所构成直线两端的 X，Y 坐标。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

由 N 个点构成的直线几何工具在需要从图像中现有的特征生成直线时很有用。

设置工具

调整工具参数


设置由 N 个点构成的直线几何工具

添加工具之后，您需要定义将用于构造参考线的输入特征（点、定位特征或圆形特征的中心）：

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 首先，从可用特征中选择一个特征（只需单击该特征即可，这时其颜色将变为洋红色）。
  3. 接着，选择将用于定义直线的其余特征。最少选择两个输入特征，最多可选择十个输入特征。
  4. 选择需要的所有特征后，按确定按钮来确认该选择（按取消按钮不将该工具添加到作业）。
  5. 随后，EasyBuilder 将自动基于选定的输入特征构造一条参考直线。 EasyBuilder 还将为先前未定义的所有特征插入“边存在/不存在”工具和/或“圆存在/不存在”工具（根据工具和特征的类型）。
  6. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  7. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整由 N 个点构成的直线几何工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

由 N 个点构成的直线几何工具的设置窗格包含以下内容：

已关闭 常规选项卡
已关闭 工具名称

定义检查工具的名称，在配置结果（输入、输出和通信）时会利用该名称。默认名称为“Line_1”（该工具是添加到作业的第一个定义直线的工具，之后名称将递增，如“Line_2”、“Line_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。


几何工具 - 由 N 个点生成圆

由 N 个点组成的圆几何工具用于创建由 3 到 10 个输入特征（点、固定原点或圆形特征的中心）组成的圆，并报告所创建的圆的直径。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

由 N 个点生成圆几何工具在你需要使用图像中现有的要素来创建圆的情况下非常有用。

设置工具

调整工具参数


设置由 N 个点构成的圆几何工具

添加该工具之后，需要定义将用于构造参照圆的输入特征（点、定位特征或圆特征的中心）：

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 首先，从可用特征中选择一个特征（只需单击该特征即可，这时其颜色将变为洋红色）。
  3. 接着，选择将用于定义圆的其余特征。最少选择三个输入特征，最多可选择十个输入特征。
  4. 选择需要的所有特征后，按确定按钮来确认该选择（按取消按钮则不将该工具添加到作业）。
  5. 随后，EasyBuilder 将自动基于选定的输入特征构造一个参照圆。 EasyBuilder 还将为先前未定义的所有特征插入“边存在/不存在”工具和/或“圆存在/不存在”工具（根据工具和特征的类型）。
  6. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  7. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整由 N 个点构成的圆几何工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

“由 N 个点构成的圆”几何工具的设置窗格包含以下内容：

  • 常规选项卡
  • 范围限制选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

范围限制选项卡


由 N 个点构成的圆几何工具 - 常规选项卡

已关闭 工具名称

定义检查工具的名称，在配置结果（输入、输出和通信）时会利用该名称。默认名称为“Circle_1”（如果该工具是添加到作业的第一个定义圆的工具，之后名称将递增，如“Circle_2”、“Circle_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。


由 N 个点构成的圆几何工具 - 范围限制选项卡

已关闭 最大值

定义最大可接受直径值；该工具将根据图像创建智能限制默认设置，这样可进行自定义以满足应用程序的需要。

已关闭 直径

报告所构造圆的当前测量直径；介于最小和最大值设置之间（包括二者）的值归类为“通过”。

注意:该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
已关闭 最小值

定义最小可接受直径值；该工具将根据图像创建智能限制默认设置，这样可进行自定义以满足应用程序的需要。

已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。


几何工具 - 圆与直线的交点

圆与直线的交点几何工具用于确定直线与圆在圆上的交点，并报告圆与直线交点的 X、Y 坐标。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

圆与直线的交点几何工具在验证圆特征与边特征之间是否准确对齐时很有用。

设置工具

调整工具参数


设置圆与直线的交点几何工具

添加该工具之后，需要定义将与圆相交的圆和边特征或直线：

  1. 在添加工具后，EasyBuilder 将检测您的图像，并列出自动检测到的智能特征（以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）供您选择。
  2. 首先，从可用特征中选择一个圆特征（只需单击该特征即可），这时其颜色将变为洋红色，并且会从该特征中延伸出一条直线。
  3. 接着，选择将与圆相交的边特征或直线。
  4. 在选择第二个特征之后，EasyBuilder 将自动确定圆与直线的交点，并插入两个点来定义相交。 EasyBuilder 还将为先前未定义的所有特征插入“边存在/不存在”工具和/或“圆存在/不存在”工具（根据工具和特征的类型）。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整圆与直线的交点几何工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

“圆与直线的交点”几何工具的设置窗格包含以下内容：

已关闭 “常规”选项卡
已关闭 工具名称

定义检查工具的名称，在配置结果（输入、输出和通信）时会利用该名称。默认名称为“Intersect_1”（如果该工具是添加到作业的第一个“圆与直线的交点”或“直线交点”几何工具，之后名称将递增，如“Intersect_2”、“Intersect_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

已关闭 “设置”选项卡
已关闭 反向结果

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。


几何工具 - 用户定义的点

用户定义的点几何工具用于在图像中的任何位置绘制参考点，并报告该点的 X、Y 坐标。

用户定义的点几何工具在您需要以正在检查的部件或对象之外的特征作为参考点进行测量时很有用。

注意:
  • 该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。
  • 该工具的点也可被用来作为其它工具的定位特征，但是该点不能提供任何角度信息。

设置工具

调整工具参数


设置用户定义的点几何工具

  1. 添加该工具之后，图像上将出现一幅洋红色的十字准线点图。
  2. 将十字准线点图置于图像中的所需位置，按确定按钮接受此位置。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。

  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。

    注意:该工具的点也可被用来作为其它工具的定位特征，但是该点不能提供任何角度信息。


调整用户定义的点几何工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

用户定义的点几何工具的设置窗格包含以下内容：

已关闭 常规选项卡
已关闭 工具名称

定义检查工具的名称，在配置结果（输入、输出和通信）时会利用该名称。默认名称为“Point_1”（该工具是添加到作业的第一个定义点的工具，之后名称将递增，如“Point_2”、“Point_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。


几何工具 - 用户定义的直线

用户定义的直线几何工具用于在图像中的任何位置绘制参考线，并报告该线段端点的 X、Y 坐标。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

用户定义的直线几何工具在需要以正在检查的部件或对象之外的特征作为参考线进行测量时很有用。

设置工具

调整工具参数


设置用户定义的直线几何工具

  1. 添加该工具之后，图像上将出现一条洋红色的直线。
  2. 将该直线置于图像中的所需位置，按确定按钮接受此位置。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整用户定义的直线几何工具的参数

在设置并接受工具的输入后，即可开始针对应用程序自定义和微调工具。

用户定义的直线几何工具的设置窗格包含以下内容：

已关闭 常规选项卡
已关闭 工具名称

定义检查工具的名称，在配置结果（输入、输出和通信）时会利用该名称。默认名称为“Line_1”（该工具是添加到作业的第一个定义直线的工具，之后名称将递增，如“Line_2”、“Line_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

已关闭 设置选项卡
已关闭 线

报告所构造线段的端点 X,Y 坐标。

注意:该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。


几何工具 - 圆拟合

圆拟合几何工具根据检测到的边缘构造最佳拟合圆。该工具使用边缘分析卡尺数组精确定位边缘特征。边缘一经识别，该工具就会在边缘特征上构造最佳拟合圆。然后，工具会报告最佳拟合圆的半径及其中点。

注意:
  • 该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
  • 无论工具是否校准到实际单位，所有输入值均以像素为单位。

圆拟合几何工具在您希望确保部件或对象具有相同形状的情况下非常有用。与由 N 个点构成的圆几何工具相比，这一工具能够创建更加准确（尽管较慢）的最佳拟合圆。

设置工具

调整工具参数


设置圆拟合几何工具

添加该工具之后，需要在图像中配置遮蔽区域，使其位于想要检查的边缘特征之上：

  1. 在边缘特征之上，对图像内的环形遮蔽区域进行定位和配置；可以同时调整环形的内外半径，以确保其能够检测正确边缘。定位和配置区域时，请确保边缘与区域的搜索方向平行，并且区域包含尽可能多的边缘特征，同时排除区域中不必要或不想要的噪音。

    注意: 遮蔽区域内的黄色虚线定义该区域内将检测到边缘转换的范围。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 确认区域后，选择边缘、边缘评分和拟合等各个选项卡，然后根据需要调整参数和区域，以确保工具将检测正确的边缘候选项并且创建正确的最佳拟合线或圆。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的范围和偏差。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整圆拟合几何工具参数

在设置完工具的区域后，你可以开始优化应用程序工具。

圆拟合几何工具的设置窗格包含以下内容：

  • 常规选项卡
  • 边选项卡
  • 边评分选项卡
  • 拟合选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

匹配选项卡

边缘选项卡

边缘得分选项卡


圆匹配几何工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“CircleFit_1”（如果该工具是添加到作业的第一个圆匹配几何工具，之后名称将递增，如“CircleFit_2”、“CircleFit_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


圆拟合几何工具 - 拟合选项卡

当选择了拟合选项卡时, 工具会显示区域内及最佳圆拟合线内找到的所有 边缘候选项 。边缘候选项代表了在构建最佳圆拟合线时可能被考虑的边缘。边缘候选项由小的颜色代码圆圈来指示。

已关闭 过滤异常值

定义该工具是否将从最佳拟合线中删除超出“拟合距离过滤器”参数所定义距离的点（默认情况下，已启用此参数）。

已关闭 拟合距离过滤器

以像素定义边缘距重新拟合计算中所使用的原始最佳拟合线的距离（1 - 1920；默认值 = 2）。这一参数有助于防止缺陷对线拟合造成影响。

注意:必须选中（启用）“过滤异常值”参数才能使用此参数。
已关闭 最远点过滤距离

定义一旦超出后，将不使用边缘确定最小和最大距离的异常值距离（1 - 1920；默认值 = 1000）；大于这个值的所有边缘均将被忽略。

已关闭 重新评分

定义是否会对检测到的边缘重新评分，以确保能够正确过滤检测到的原本被丢弃的边缘（默认情况下启用此参数）。

已关闭 重新拟合

定义边缘重新评分后该工具是否将重新拟合最佳拟合线（默认情况下启用此参数）。

注意:启用此参数后该工具的精确度会更高，但它会增加处理时间。
已关闭 结果

显示图像中的最佳拟合线并报告最佳圆拟合的半径及它的中心点。


圆拟合几何工具 - 边缘选项卡

选择边缘选项卡后，该工具将以暗绿色轮廓显示区域内所有检测到的边缘。您可以根据需要调整卡尺尺寸、卡尺间距、边缘宽度和最小对比度参数，以隔离所需边缘。

也可通过启用显示所有卡尺参数来查看所有卡尺。

在此选项卡中也可以选择和调整区域。

已关闭 卡尺尺寸

定义将沿着检测方向进行分析的每个卡尺的像素数量（1 - 639；默认值 = 5）。

已关闭 卡尺间距

以像素为单位，定义在一个卡尺末尾与下一个卡尺起点间的距离（-1 - 639；默认值 = 0）。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 10；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 最小对比度

定义将被认定为边缘的最小灰度对比度转换（1 - 255；默认值 = 10）。

已关闭 卡尺计数

显示区域内卡尺的总数。

已关闭 卡尺索引

定义要隔离和显示的各个卡尺。

已关闭 显示所有卡尺

定义是否总是显示区域内的所有卡尺；默认情况下，卡尺为隐藏状态。


圆拟合几何工具 - 边缘评分选项卡

选择边缘评分选项卡后，该工具将显示区域（可以选择和调整）中所有检测到的边缘候选项（以带有颜色编码的小圆圈标示）以及最佳拟合线或园结果。边缘候选项表示构造最佳拟合线或圆时可能会考虑的边缘；调整参数可隔离所需边缘候选项。

如检测到任何缺陷和间距，也会一并显示。

已关闭 查找边缘方向

定义相对于区域工具尝试检测边缘的方向（“左到右”或“右到左”；默认值 =“左到右”）。

已关闭 边缘转换

定义边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 规则：第一条边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑第一个检测到的边缘（默认情况下启用此设置）。

已关闭 规则：最强边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑具有最强对比度转换的边缘（默认情况下启用此设置）。

已关闭 得分阈值

定义评分阀值，将分数（0 - 255；默认值 = 10）低于这个值的边缘过滤掉。


几何工具 - 线拟合

线拟合几何工具根据检测到的边缘构造最佳拟合线。该工具使用边缘分析卡尺数组精确定位边缘特征。边缘一经识别，该工具就会在边缘特征上构造最佳拟合线。然后，工具会报告线段起点和终点的 X/Y 坐标。

注意:
  • 该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
  • 无论工具是否校准到实际单位，所有输入值均以像素为单位。

线拟合几何工具在您希望确保部件或对象具有相同形状的情况下非常有用。与由 N 个点构成的直线几何工具相比，这一工具能够创建更加准确（尽管较慢）的最佳拟合线。

设置工具

调整工具参数


设置线拟合几何工具

添加该工具之后，需要在图像中配置遮蔽区域，使其位于想要检查的边缘特征之上：

  1. 对边缘特征图像内的区域进行定位和配置。定位区域时，请确保边缘与区域的搜索方向平行，并且区域包含尽可能多的边缘特征，同时排除区域中不必要或不想要的噪音。

    注意: 遮蔽区域内的黄色虚线定义该区域内将检测到边缘转换的范围。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 确认区域后，选择边缘、边缘评分和拟合等多个选项卡，然后根据需要调整参数和区域，以确保工具将检测正确的边缘候选项并且创建正确的最佳拟合线或圆。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的范围和偏差。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整线拟合几何工具

在设置完工具的区域后，你可以开始优化应用程序工具。

线拟合几何工具的设置窗格包含以下内容：

  • 常规选项卡
  • 边选项卡
  • 边评分选项卡
  • 拟合选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

匹配选项卡

边缘选项卡

边缘得分选项卡


线匹配几何工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“LineFit_1”（如果该工具是添加到作业的第一个线匹配几何工具，之后名称将递增，如“LineFit_2”、“LineFit_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


线拟合几何工具 - 拟合选项卡

当选择了拟合选项卡时, 工具会显示区域内及最佳线拟合结果内的所有 边缘候选项 。边缘候选项代表了在构建最佳线拟合时可能被考虑的边缘。边缘候选项由小的颜色代码圆圈来指示。

已关闭 过滤异常值

定义该工具是否将从最佳拟合线中删除超出“拟合距离过滤器”参数所定义距离的点（默认情况下，已启用此参数）。

已关闭 拟合距离过滤器

以像素定义边缘距重新拟合计算中所使用的原始最佳拟合线的距离（1 - 1920；默认值 = 2）。这一参数有助于防止缺陷对线拟合造成影响。

注意:必须选中（启用）“过滤异常值”参数才能使用此参数。
已关闭 最远点过滤距离

定义一旦超出后，将不使用边缘确定最小和最大距离的异常值距离（1 - 1920；默认值 = 1000）；大于这个值的所有边缘均将被忽略。

已关闭 重新评分

定义是否会对检测到的边缘重新评分，以确保能够正确过滤检测到的原本被丢弃的边缘（默认情况下启用此参数）。

已关闭 重新拟合

定义边缘重新评分后该工具是否将重新拟合最佳拟合线（默认情况下启用此参数）。

注意:启用此参数后该工具的精确度会更高，但它会增加处理时间。
已关闭 结果

显示图像中的最佳拟合线并报告线段在X，Y坐标的开始和终止点。


线拟合几何工具 - 边缘选项卡

选择边缘选项卡后，该工具将以暗绿色轮廓显示区域内所有检测到的边缘。您可以根据需要调整卡尺尺寸、卡尺间距、边缘宽度和最小对比度参数，以隔离所需边缘。

也可通过启用显示所有卡尺参数来查看所有卡尺。

在此选项卡中也可以选择和调整区域。

已关闭 卡尺尺寸

定义将沿着检测方向进行分析的每个卡尺的像素数量（1 - 639；默认值 = 5）。

已关闭 卡尺间距

以像素为单位，定义在一个卡尺末尾与下一个卡尺起点间的距离（-1 - 639；默认值 = 0）。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 10；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 最小对比度

定义将被认定为边缘的最小灰度对比度转换（1 - 255；默认值 = 10）。

已关闭 卡尺计数

显示区域内卡尺的总数。

已关闭 卡尺索引

定义要隔离和显示的各个卡尺。

已关闭 显示所有卡尺

定义是否总是显示区域内的所有卡尺；默认情况下，卡尺为隐藏状态。


线拟合几何工具 - 边缘评分选项卡

选择边缘评分选项卡后，该工具将显示区域（可以选择和调整）中所有检测到的边缘候选项（以带有颜色编码的小圆圈标示）以及最佳拟合线或园结果。边缘候选项表示构造最佳拟合线或圆时可能会考虑的边缘；调整参数可隔离所需边缘候选项。

如检测到任何缺陷和间距，也会一并显示。

已关闭 查找边缘方向

定义相对于区域工具尝试检测边缘的方向（“左到右”或“右到左”；默认值 =“左到右”）。

已关闭 边缘转换

定义边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 规则：第一条边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑第一个检测到的边缘（默认情况下启用此设置）。

已关闭 规则：最强边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑具有最强对比度转换的边缘（默认情况下启用此设置）。

已关闭 得分阈值

定义评分阀值，将分数（0 - 255；默认值 = 10）低于这个值的边缘过滤掉。


数学逻辑工具 - 数学

数学数学逻辑工具可以使用标准数学运算符、逻辑、统计和三角函数构造数学公式以处理工具和作业数据。

数学数学逻辑工具在一些情况下很有用，例如，想要从两个工具添加缺陷计数或返回测量工具的平均值时。

设置工具

调整工具参数


设置数学 & 逻辑工具

注意:此工具需要使用其它位置和/或检测工具作为输入。在添加此工具之前，请组建将用作此工具输入的其它位置和/或检测工具，否则，将无法构造表达式，并且必须添加必需的位置和/或检测工具，然后在配置完其它工具后返回到该工具。

添加了工具之后，您需要构建表达式。

  1. 通过从设置窗格左侧选择并输入数学函数，以及从右侧选择并输入值（工具和作业数据）来构建表达式。如要在表达式公式编辑器中输入一个函数或值，选择函数或值，然后按 Enter 键，双击函数或值或按 Insert（插入）按钮。

  2. 构建了表达式之后，通过单击范围限制选项卡定义工具的范围限制。默认情况下，最大值设置为 9,999,999，最小值设置为 -9,999,999，允许您根据应用需要自定义限制。

    注意:如果表达式的结果返回文本字符串，则将禁用最大值和最小值限制。
  3. 在初始配置该工具的情况下，根据需要加载几个图像并调整工具参数，以补偿预期的变化范围。
  4. 最后，如需要，可以使用工具的输入/输出属性表以在其他工具和/或其他外部设备之间共享工具数据。


调整数学逻辑工具的参数

在将工具添加到作业之后，即可开始针对应用程序自定义和微调工具。

数学数学逻辑工具的设置窗格包含以下内容：

  • 常规选项卡
  • 范围限制选项卡
  • 表达式
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

表达式

范围限制选项卡


数学-数学和逻辑工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Math_1”（如果该工具是添加到作业的第一个数学-数学 & 逻辑组工具，之后名称将递增，如“Math_2”、“Math_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


“数学”数学 & 逻辑工具 - 表达式

注意:当 In-Sight 视觉系统处于联机状态时会禁用这些控制。
已关闭 表达式

表达式文本框用于构造处理工具结果和数据的数学公式。可通过使用键盘键入数学函数的名称或作业/工具数据来输入数据，也可以利用左侧的视觉工具树、数学树、文本树和/或视觉数据访问树以及右侧的作业和工具数据符号树组合公式。可以通过双击项目输入项目，也可以通过突出显示项目并按插入按钮输入项目。

注意:
  • 如果表达式引用已删除的工具，则在公式中，该引用将自动替换为“Job.MissingArg”。该工具将返回“失败”，直到更正该引用。
  • 当生成表达式时，EasyBuilder 不能正确地分析开头的单元格地址（如 A3_MyTool 或 P10_SortTool）。如果表达式需要为这些工具配置，请在创建公式前重新命名这些工具。
提示:

确定某个文本字符串是否与另一个字符串匹配时，请使用 Exact 函数。对值进行比较时会使用 If 函数；如果 If 函数试图对比字符串，EasyBuilder 会返回错误。

示例：

  • 需要将读取 ID 代码识别工具所使用的文本字符串与读取文本识别工具所使用的字符串进行比较，以确保它们相匹配。在表达式中可构造以下公式：Exact(IDCode_1.String,Text_1.Result)。
已关闭 视觉工具

视觉工具树包含可用于构造表达式的附加边函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开边树，选择所需函数，然后按插入按钮。
  • 展开边树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 数学函数树

数学函数树包含可用于构造表达式的数学函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开数学树，选择所需函数，然后按插入按钮。
  • 展开数学树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 文本函数树

文本函数树中包含的函数用于设置字母数字数据的格式以进行显示和通信，并可用于构造表达式。可通过以下三种方法之一将函数添加到表达式：

  • 展开文本树，选择所需函数，然后按插入按钮。
  • 展开文本树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 视觉数据访问

视觉数据访问树包含可用于构造表达式的>附加数据（默认不可用）。可通过以下三种方法之一将函数添加到表达式：

  • 展开视觉数据访问树，选择所需函数，然后按插入按钮。
  • 展开视觉数据访问树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:
  • 可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
  • EasyBuilder 仅支持斑点、边和图形视觉数据访问函数。
已关闭 作业和工具数据符号树

作业和工具数据符号树包含定位和/或检测工具输出的数据，以及输入行和作业数据（如图像采集参数）。作业和工具数据是对其所含值的符号引用。符号可以通过以下三种方式中的一种被添加到表达式中：

  • 展开树型结构，选择所需符号引用，然后按插入按钮。
  • 展开树型结构，然后双击所需符号引用。
  • 使用键盘直接在表达式的文本框中输入所需符号的引用名称。
注意:可用符号列表取决光标在表达式中的位置。如果光标位于表达式中禁止添加符号的位置，则这些符号将不可用，直到光标位于可添加符号的位置。
已关闭 插入按钮

插入按钮用于将数学函数和符号放入表达式。选择所需数学函数或符号，然后按插入按钮将函数或符号添加到表达式。

注意:此控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用插入按钮。
已关闭 左括号、逗号、右括号按钮

左括号、逗号及右括号按钮用于构造数学公式。按相应按钮即可将这些符号添加到公式。

注意:这些控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用这些按钮。


数学 & 逻辑工具 - 范围限制选项卡

已关闭 最大值

设置公式的最大可接受数字；默认情况下，工具会分配最大值 9,999,999。您必须为您的应用自定义此值。

已关闭 结果

报告表达式的结果；恰好是“最小值”和“最大值”设置或介于其之间的值被分类为“通过”。

已关闭 最小值

设置公式的最小可接受数字；默认情况下，工具会分配最小值 -9,999,999。您必须为您的应用自定义此值。

已关闭 反向

定义工具的通过/失败逻辑是否将反向（默认 = 关，未选中）：

  • 未选中 - 应用标准结果，即如果此特征经过检测且位于指定设置内，则工具结果为“通过”。
  • 选中 - 反向结果，即如果此特征经过检测且位于指定设置内，则工具结果为“失败”。
已关闭 自动限制按钮

根据智能限制设置来定义限制。当参数被更改并需要调整限制，或者添加了工具但未定义限制时，该按钮会非常有用。

注意:如果表达式的结果返回文本字符串，则将禁用最大值和最小值限制。


数学和逻辑工具 - 逻辑

逻辑-数学和逻辑工具允许你使用标准逻辑操作来处理通过和失败数据。

该工具将返回以下结果：

In-Sight 型号 | 结果
In-Sight 2000 系列 1XX 视觉传感器 (110, 120, 130) | 仅限通过/失败状态
In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 标准结果（无限制）

设置工具

调整工具参数


设置逻辑-数学和逻辑工具

注意:此工具需要使用其它位置和/或检测工具作为输入。在添加此工具之前，请组建将用作此工具输入的其它位置和/或检测工具，否则，将无法构造表达式，并且必须添加必需的位置和/或检测工具，然后在配置完其它工具后返回到该工具。

添加工具后，需要构造表达式。表达式文本框可以用来构建工具通过或失败的逻辑公式。

In-Sight 2000 系列传感器

  1. 通过添加工具的通过或失败结果来构建表达式。要在表达公式编辑器中输入通过或失败结果，可以选择并双击结果，或选择结果然后点击插入按钮。
  2. （可选）构建完表达式后，可以反转通过/失败工具的逻辑。
  3. 在最初配置该工具时，可以根据需要加载一些图像和调整工具参数，以补偿预期结果。
  4. 最后，如需要可以使用工具的输入/输出属性表来设置与其它工具及/或其它设备间的数据分享。

In-Sight 视觉系统

  1. 通过添加工具的通过或失败结果来构建表达式。要在表达公式编辑器中输入通过或失败结果，可以选择并双击结果，或选择结果然后点击插入按钮。
  2. （可选）构建完表达式后，可以在设置选项卡中反转通过/失败工具的逻辑。
  3. 在最初配置该工具时，可以根据需要加载一些图像和调整工具参数，以补偿预期结果。
  4. 最后，如需要可以使用工具的输入/输出属性表来设置与其它工具及/或其它设备间的数据分享。


调整逻辑-数学和逻辑工具参数

在将工具添加到作业之后，即可开始针对应用程序自定义和微调工具。

In-Sight 2000 系列传感器

  • 编辑工具组框

In-Sight 视觉系统

逻辑-数学逻辑工具的设置栏包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 表达式
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

In-Sight 2000 系列视觉传感器

In-Sight 视觉系统

版权所有 © 2008 - 2020 | Cognex Corporation | All Rights Reserved.

EasyBuilder 帮助 | 06/28/2022 | Revision: 5.9.0.3


调整逻辑-数学和逻辑工具参数

注意:该主题介绍了与 In-Sight 2000 系列视觉传感器连接时的用户界面。如果连接到 In-Sight 视觉系统，请参阅 In-Sight 视觉系统的调整逻辑-数学和逻辑工具参数部分。
已关闭 表达式

表达式文本框用于建立工具通过和失败结果的逻辑公式。使用作业和工具数据符号树组合公式。您可以通过双击项目，或突出显示它们然后按 Insert（插入）按钮来输入项目。

注意:如果表达式引用已删除的工具，则引用将在公式中自动替换为“作业.缺少参数”。工具将返回错误信息，直到纠正引用。
已关闭 作业和工具数据符号树

作业和工具数据符号树包含了由定位以及/或检测工具所输出的工具通过和失败结果。作业和工具数据是对其所含值的符号引用。符号可以通过以下两种方式中的一种被添加到表达式中：

  • 展开树，选择所需符号引用，然后按插入按钮。
  • 展开树，然后双击所需符号引用。
注意:可用符号列表取决于光标在表达式中的位置。如果光标在表达式内位于禁止添加符号的位置，则这些符号不可用，直到光标位于可添加符号的位置。
已关闭 插入按钮

Insert（插入）按钮用于将符号置于表达式中。选择所需符号，然后按 Insert（插入）按钮将符号添加到表达式中。

已关闭 左括号、逗号、右括号、 AND、OR 以及 NOT 按钮

左括号、逗号、右括号、AND、OR 和 NOT 按钮用于建立公式。按相应的按钮将它们添加到公式中。

已关闭 删除按钮

删除按钮可以用来删除在表达式中高亮选中的词或符号。高亮选中需要删除的词或符号，然后点击删除。

已关闭 反转结果

启用后，如果结果在指定的范围内失败，那么该工具也会显示失败。(默认 = Off)

通过/失败 | （反转） | 通过/失败
通过/失败 | （反转） | 通过/失败
已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 名称

指定检测工具的名称。默认名为 “Logic_1”（如果这是第一个添加到该作业的图形工具，之后的名称依次顺延，例如 “Logic_2”,、“Logic_3” 等）。

已关闭 已启用

定义检测工具何时运行，或是否运行（默认设置为“开”）。

  • 如果你想要禁用该工具，请选择“关”。
  • 如果希望将该工具与特定的离散输入线路连接，请选择一条输入线，这时该工具可被“开启”或“关闭”（高电平信号 (1) 为“开”，低电平信号 (0) 为“关”）。将该工具与一个输入线路连接允许控制系统（如 PLC）来指定哪些工具可以运行以及何时运行。
已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


“逻辑”数学 & 逻辑工具 - 常规选项卡

已关闭 工具名称

指定检测工具的名称。默认名为 “Logic_1”（如果这是第一个添加到该作业的图形工具，之后的名称依次顺延，例如 “Logic_2”,、“Logic_3” 等）。 您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


“逻辑”数学 & 逻辑工具 - 表达式

注意:当 In-Sight 视觉系统处于联机状态时会禁用这些控制。
已关闭 表达式

表达式文本框用于建立工具通过和失败结果的逻辑公式。使用作业和工具数据符号树组合公式。您可以通过双击项目，或突出显示它们然后按 Insert（插入）按钮来输入项目。

注意:
  • 如果表达式引用已删除的工具，则引用将在公式中自动替换为“作业.缺少参数”。工具将返回错误信息，直到纠正引用。
  • 当建立公式时，EasyBuilder 不会正确解析以单元格地址（例如，A3_MyTool 或 P10_SortTool）开头的工具名称。如果需要为这些工具创建表达式，在创建公式前重命名工具。
已关闭 作业和工具数据符号树

作业和工具数据符号树按位置和/或检测工具包含工具通过和失败结果输出。作业和工具数据是对其中所含值的符号引用。可通过以下三种方法之一将符号添加到表达式中：

  • 展开树，选择所需符号引用，然后按 Insert（插入）按钮。
  • 展开树并双击所需符号引用。
  • 使用键盘直接在表达式的文本框中键入所需符号引用的名称。
注意:可用符号列表取决于光标在表达式中的位置。如果光标在表达式内位于禁止添加符号的位置，则这些符号不可用，直到光标位于可添加符号的位置。
已关闭 Insert（插入）按钮

Insert（插入）按钮用于将符号置于表达式中。选择所需符号，然后按 Insert（插入）按钮将符号添加到表达式中。

已关闭 左括号、逗号、右括号、AND、OR 和 NOT 按钮

左括号、逗号、右括号、AND、OR 和 NOT 按钮用于建立公式。按相应的按钮将它们添加到公式中。

已关闭 Delete（删除）按钮

删除按钮可以用来删除在表达式中高亮选中的词或符号。高亮选中需要删除的词或符号，然后点击删除。


逻辑-数学和逻辑工具 - 设置选项卡

已关闭 结果

报告表达式结果。

已关闭 反向

指定工具的通过和失败结果是否反向。

  • 未选择（默认）：通过和失败结果不反向。
  • 选择：通过和失败结果反向。


数学和逻辑工具 - 趋势

数学和逻辑趋势工具用于在重置之前针对指定样本数返回定位工具或检查工具值或输入线的最大值、最小值、平均值、样本及标准偏差统计数据。

数学和逻辑趋势工具在某些情况下很有用，例如，您想要在一个作业执行时期内累计有关特定工具结果的统计信息以对制造过程进行分析。

设置工具

调整工具参数


设置趋势数学逻辑工具

添加该工具之后，需要定义将要处理的值并配置工具的参数。

  1. 在常规选项卡中配置这些设置，以适合应用程序。
  2. 单击设置选项卡，定义要累计统计数据的值。添加该工具之后，EasyBuilder 将检查应用程序，并列出可能在最后的值参数中引用的值。选择一个值，然后在该选项卡中配置其它参数。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整趋势数学逻辑工具的参数

在将工具添加到作业之后，即可开始针对应用程序自定义和微调工具。

趋势数学逻辑工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 表选项卡
  • 值选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

数值选项卡

表格选项卡


数学和逻辑趋势工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Trend_1”（如果该工具是添加到作业的第一个数学和逻辑趋势工具，之后名称将递增，如“Trend_2”、“Trend_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


趋势数学逻辑工具 - 设置选项卡

已关闭 最后的值

定义该工具将计算哪个值；默认情况下会选择“未定义”，且不会累计任何统计数据。选择作业中的工具或输入所返回的值，以累计该工具或输入值的统计数据。

已关闭 最大样本数

定义在累计该工具统计数据时要使用的最大样本数；默认情况下，会使用100 个样本。样本的大小范围最小为2，最大为5,000。一旦工具达到其最大样本数，就会在累计新值时舍弃最旧的值。

已关闭 显示

定义将显示哪个计算值：最后的值、最小值、最大值、平均值或StdDev（标准偏差）。默认情况下，会选择最后的值。

已关闭 结果

显示“显示”参数中所定义的当前计算值。

已关闭 重置按钮

将累计数据重置为0。

已关闭 在线重置

定义该工具是否在In-Sight视觉系统每次在线时自动重置累计数据；默认情况下会取消选中该设置，从而需要手动重置。

已关闭 作业加载重置

定义该工具是否在In-Sight视觉系统每次加载包含该工具的作业时自动重置数据累计；默认情况下会取消选中此设置，从而需要手动重置。


趋势数学逻辑工具 - 值选项卡

以图表形式显示值的图形表示。


趋势数学逻辑工具 - 表格选项卡

趋势数学逻辑工具表按照在设置选项卡的最大样本数参数中所定义的样本数，显示针对最后的值参数中所定义的值累计的结果。


数学逻辑工具 - 统计

数学和逻辑统计工具用于返回定位工具或检测工具的值或输入线路的最大值、最小值、平均值、样本及标准偏差统计数据。

数学和逻辑统计工具在某些情况下很有用，例如，您想要累计有关特定工具结果的统计信息以对制造过程进行分析。

设置工具

调整工具参数


设置统计数学逻辑工具

添加该工具之后，需要定义将要处理的值并配置工具的参数。

  1. 在常规选项卡中配置这些设置，以适合应用程序。
  2. 单击设置选项卡，定义要累计统计数据的值。添加该工具之后，EasyBuilder 将检查应用程序，并列出可能在最后的值参数中引用的值。选择一个值，然后在该选项卡中配置其它参数。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整统计数学逻辑工具的参数

在添加了工具之后，即可开始针对应用程序自定义和微调工具。

统计数学逻辑工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 表
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

表


数学和逻辑统计工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Stats_1”（如果该工具是添加到作业的第一个数学和逻辑统计工具，之后名称将递增，如“Stats_2”、“Stats_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


统计数学逻辑工具 - 设置选项卡

已关闭 最后的值

定义该工具将计算哪个值；默认情况下会选择“未定义”，因而不会累计任何统计数据。选择作业中的工具或输入所返回的值，以累计该工具或输入的值的统计数据。

已关闭 显示

定义将显示哪个计算值：“最后的值”、“最小值”、“最大值”、“平均值”或 StdDev（标准偏差）。默认情况下会选择“最后的值”。

已关闭 结果

显示“显示”参数中所定义的当前计算值。

已关闭 脱机时计数

定义结果是否应包括在 In-Sight 视觉系统脱机时进行的采集；默认情况下会选中此设置，因而在视觉系统脱机时也会累计统计数据。取消选中该复选框，以仅在 In-Sight 视觉系统联机时累计统计数据。

已关闭 “重置”按钮

将数据累计重置为 0。

已关闭 联机重置

定义该工具是否将在 In-Sight 视觉系统每次进入联机状态时自动重置数据累计；默认情况下会取消选中此设置，从而需要手动重置。

已关闭 作业加载重置

定义该工具是否将在 In-Sight 视觉系统每次加载包含该工具的作业时自动重置数据累计；默认情况下会取消选中此设置，从而需要手动重置。


统计数学逻辑工具 - 表格

统计数学逻辑工具表显示针对设置选项卡的最后的值参数中所定义的值累计的结果。


数学逻辑工具 - 组工具

组数学逻辑工具将定位工具和/或检查工具合并成一组，并且在组中创建工具之间的共享启用状态，从而将它们的执行结合在一起。

组数学逻辑工具在一些情况下很有用，例如，对于需要多次采集的作业或包含大量工具的作业，会使用多个工具来确定单个产品特征是否通过。

设置工具

调整工具参数


设置组数学逻辑工具

注意:此工具需要使用其它位置和/或检测工具作为输入。在添加此工具之前，请组建将用作此工具输入的其它位置和/或检测工具，否则，将无法构造表达式，并且必须添加必需的位置和/或检测工具，然后在配置完其它工具后返回到该工具。

添加该工具之后，需要定义哪些工具将成为组的一部分。

  1. 添加该工具之后，EasyBuilder 会检查作业，并在工具组选项卡的左列中列出作业中的所有工具。
  2. 选择要放入组中的工具（按住 CTRL 键逐个选择多个工具，或按住 SHIFT 键选择若干连续的工具），然后按添加按钮。
  3. 完成组后，即可选择启用表达式选项卡，可在此构造用于提供控制组执行的逻辑的自定义表达式。默认情况下，表达式设置为 1，表示始终启用该组。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整组数学逻辑工具的参数

在将工具添加到作业之后，即可开始针对应用程序自定义和微调工具。

组数学逻辑工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 工具组选项卡
  • 启用表达式选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

工具组选项卡

启用表达式选项卡


数学 & 逻辑组工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Group_1”（如果该工具是添加到作业的第一个数学 & 逻辑组工具，之后名称将递增，如“Group_2”、“Group_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

注意:如果已将启用表达式选项卡配置为使用表达式，则必须将启用工具参数设置为“表达式”才能正常工作。
已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


组数学逻辑工具 - 设置选项卡

已关闭 组 ID

组 ID 编号用于在“组”数学逻辑工具中的工具失败时指示失败。当工具等于“通过”时，“组”数学逻辑工具返回 0，而当工具等于“失败”时，则返回“组 ID”编号。“组 ID”范围为 1 到 9,999,999。默认情况下，“组 ID”设置为 10，并且在添加新的“组”数学逻辑工具时不会递增。


组数学逻辑工具 - 工具组选项卡

工具组选项卡允许您将工具添加到所选“组”数学逻辑工具以及从中删除工具。

左侧的列表显示组中未包括的工具，而右侧的列表则显示组中所包括的工具。默认情况下，右侧的列表为空。

已关闭 添加按钮

在左侧选择工具会启用添加按钮。

  • 可以选择一个工具并按添加按钮来逐个添加工具。
  • 要选择多个不连续的工具，请按住 CTRL 键并突出显示这些工具，然后按添加按钮。
  • 要选择多个连续的工具，请按住 SHIFT 键并突出显示列表中的第一个工具，再突出显示最后一个工具，然后按添加按钮。
已关闭 移除按钮

在右侧选择工具会启用移除按钮。

  • 可以选择一个工具并按移除按钮来逐个移除工具。
  • 要选择多个不连续的工具，请按住 CTRL 键并突出显示这些工具，然后按移除按钮。
  • 要选择多个连续的工具，请按住 SHIFT 键并突出显示列表中的第一个工具，再突出显示最后一个工具，然后按移除按钮。
注意:
  • 一个工具只能属于一个“组”数学逻辑工具。要将某个工具从一个“组”数学逻辑工具添加到另一个“组”数学逻辑工具，必须先将该工具从第一个“组”数学逻辑工具中移除，然后才能将其添加到另一个“组”数学逻辑工具。
  • 一个“组”数学逻辑工具不能包含另一个“组”数学逻辑工具。
  • 在复制和粘贴“组”数学逻辑工具时，也会复制和粘贴该“组”数学逻辑工具中包括的所有工具。
  • 在删除“组”数学逻辑工具时，首先会对您进行提示；删除“组”数学逻辑工具时，也会删除该工具中包括的所有工具。如果不想将该组中的工具删除，则在删除“组”数学逻辑工具之前，首先要从组中移除这些工具。


数学 & 逻辑组工具 - 启用表达式选项卡

注意:当 In-Sight 视觉系统处于联机状态时会禁用这些控制。

启用表达式选项卡用于建立确定工具执行操作的数学公式；默认情况下，表达式设置为 1，代表工具将始终在采集触发时执行操作。若要激活此控制，常规选项卡中的启用的工具控件必须设置为表达式。

In-Sight 2000-130/130C 视觉传感器

已关闭 表达式

表达式文本框用于建立工具通过和失败结果的逻辑公式。使用作业和工具数据符号树组合公式。您可以通过双击项目，或突出显示它们然后按 Insert（插入）按钮来输入项目。

注意:如果表达式引用已删除的工具，则引用将在公式中自动替换为“作业.缺少参数”。工具将返回错误信息，直到纠正引用。
已关闭 作业和工具数据符号树

作业和工具数据符号树包含了由定位以及/或检测工具所输出的工具通过和失败结果。作业和工具数据是对其所含值的符号引用。符号可以通过以下两种方式中的一种被添加到表达式中：

  • 展开树型结构，选择所需符号引用，然后按插入按钮。
  • 展开树型结构，然后双击所需符号引用。
注意:可用符号列表取决于光标在表达式中的位置。如果光标在表达式内位于禁止添加符号的位置，则这些符号不可用，直到光标位于可添加符号的位置。
已关闭 插入按钮

Insert（插入）按钮用于将符号置于表达式中。选择所需符号，然后按 Insert（插入）按钮将符号添加到表达式中。

已关闭 左括号、逗号、右括号、 AND、OR 以及 NOT 按钮

左括号、逗号、右括号、AND、OR 和 NOT 按钮用于建立公式。按相应的按钮将它们添加到公式中。

已关闭 删除按钮

删除按钮可以用来删除在表达式中高亮选中的词或符号。高亮选中需要删除的词或符号，然后点击删除。

In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。

注意:如要限制数学 & 逻辑组工具和数学 & 逻辑序列工具的执行，数学 & 逻辑组工具的表达式必须设置为数学 & 逻辑序列工具（例如，“Sequence_1.Current_Step=1”）且常规选项卡中的启用的工具控件必须设置为表达式。
已关闭 表达式

表达式文本框用于构造处理工具结果和数据的数学公式。可通过使用键盘键入数学函数的名称或作业/工具数据来输入数据，也可以利用左侧的视觉工具树、数学树、文本树和/或视觉数据访问树以及右侧的作业和工具数据符号树组合公式。可以通过双击项目输入项目，也可以通过突出显示项目并按插入按钮输入项目。

注意:
  • 如果表达式引用已删除的工具，则在公式中，该引用将自动替换为“Job.MissingArg”。该工具将返回“失败”，直到更正该引用。
  • 当生成表达式时，EasyBuilder 不能正确地分析开头的单元格地址（如 A3_MyTool 或 P10_SortTool）。如果表达式需要为这些工具配置，请在创建公式前重新命名这些工具。
已关闭 视觉工具

视觉工具树包含可用于构造表达式的附加边函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开边树，选择所需函数，然后按插入按钮。
  • 展开边树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 数学函数树

数学函数树包含可用于构造表达式的数学函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开数学树，选择所需函数，然后按插入按钮。
  • 展开数学树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 文本函数树

文本函数树中包含的函数用于设置字母数字数据的格式以进行显示和通信，并可用于构造表达式。可通过以下三种方法之一将函数添加到表达式：

  • 展开文本树，选择所需函数，然后按插入按钮。
  • 展开文本树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 视觉数据访问

视觉数据访问树包含可用于构造表达式的>附加数据（默认不可用）。可通过以下三种方法之一将函数添加到表达式：

  • 展开视觉数据访问树，选择所需函数，然后按插入按钮。
  • 展开视觉数据访问树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:
  • 可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
  • EasyBuilder 仅支持斑点、边和图形视觉数据访问函数。
已关闭 作业和工具数据符号树

作业和工具数据符号树包含定位和/或检测工具输出的数据，以及输入行和作业数据（如图像采集参数）。作业和工具数据是对其所含值的符号引用。符号可以通过以下三种方式中的一种被添加到表达式中：

  • 展开树型结构，选择所需符号引用，然后按插入按钮。
  • 展开树型结构，然后双击所需符号引用。
  • 使用键盘直接在表达式的文本框中输入所需符号的引用名称。
注意:可用符号列表取决光标在表达式中的位置。如果光标位于表达式中禁止添加符号的位置，则这些符号将不可用，直到光标位于可添加符号的位置。
已关闭 插入按钮

插入按钮用于将数学函数和符号放入表达式。选择所需数学函数或符号，然后按插入按钮将函数或符号添加到表达式。

注意:此控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用插入按钮。
已关闭 左括号、逗号、右括号按钮

左括号、逗号及右括号按钮用于构造数学公式。按相应按钮即可将这些符号添加到公式。

注意:这些控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用这些按钮。


数学逻辑工具 - 序列

序列数学逻辑工具用于定义在装配过程中需要多个图像采集或阶段的作业的步骤数。此工具与组数学逻辑工具结合使用，以控制组中各工具的顺序执行。

序列数学逻辑工具在您想要根据装配/制造过程的序列同步图像采集或检查工具执行时很有用。例如，您要制造某个部件，并想要在装配的不同阶段检查该部件，以根据装配过程中某个特定序列的结果来确定是否要继续制造。

设置工具

调整工具参数


设置序列数学逻辑工具

添加该工具之后，需要配置工具的参数。

  1. 在常规选项卡中配置这些设置，以适合应用程序。

  2. 单击设置选项卡，然后配置参数，以适合应用程序。

    注意:要将组数学逻辑工具的执行与序列数学逻辑工具的执行结合起来，必须使用序列数学逻辑工具的 Current_Step 符号构造组数学逻辑工具的表达式：例如，Group_1.Enable=Sequence_1.Current_Step=1
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整序列数学逻辑工具的参数

在将工具添加到作业之后，即可开始针对应用程序自定义和微调工具。

序列数学逻辑工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡


数学 & 逻辑序列工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Step_1”（如果该工具是添加到作业的第一个数学 & 逻辑序列工具，之后名称将递增，如“Step_2”、“Step_3”等等）。可以通过给一个与特定应用程序相关联的名字来自定义你的工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


序列数学逻辑工具 - 设置选项卡

已关闭 步骤

定义由工具控制的步骤数；默认情况下使用 4 个步骤。

已关闭 重置步骤按钮

重置为 0 并重新启动序列，下次采集时从初始步骤开始。

已关闭 下一步已启用

定义是否由外部设备控制下一步参数；默认情况下会取消选中此设置，因而不能由外部设备进行控制。激活此参数时，从外部设备发送到该工具的步骤号将在下次采集时变成当前步骤。在这种安排下，不必按顺序执行步骤，而可以跳过某些步骤，具体取决于输入的步骤号（例如，如果步骤数是 6，而该工具当前处于步骤 2，则当收到 5 作为下一步输入时，就会跳过步骤 3 和 4）。

已关闭 下一步

定义哪个步骤应开始序列中的下一步；默认情况下会选择 1。仅当激活“下一步”已启用参数时才会启用此控制。要从外部设备（如 PLC 或 VisionView® 操作员界面面板）重置该工具，请选中“下一步”已启用复选框，然后在通信步骤中配置下一步参数的 Next_Step 数据类型。

已关闭 当前步骤

报告活动步骤；默认情况下会显示 1.000，并将其定义为当前步骤。


数学和逻辑工具 - 计算点

数学和逻辑计算点工具用于根据其它定位工具和/或检测工具输出相关的数学表达式来计算图像中的点，该点可以被其它工具引用。 该工具可报告计算后点的 X、Y 坐标。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

相对于在图像中固态定义一个点（例如，使用用户定义的点几何工具）的情况，数学和逻辑计算点工具在想要以编程方式确定图像中可被其它工具引用的点的情况，非常有用。 例如，如果希望根据某个数学函数的结果或者特定工具的结果在图像中放置点（例如通过边存在/不存在工具找到的边的中点），数学和逻辑的计算点工具就可以使用这些工具的结果作为输入以计算该点以及该点在图像中位置的变化以对应被引用工具的输出。 数学和逻辑-数学工具也可以使用计算出的点，并根据该点做出其它逻辑决策。

设置工具

调整工具参数


设置“计算点”数学 & 逻辑工具

注意:此工具需要使用其它位置和/或检测工具作为输入。在添加此工具之前，请组建将用作此工具输入的其它位置和/或检测工具，否则，将无法构造表达式，并且必须添加必需的位置和/或检测工具，然后在配置完其它工具后返回到该工具。

添加了工具之后，您需要构建 X 和 Y 值的表达式。

  1. 通过从设置窗格左侧选择并输入数学函数，和/或从右侧选择并输入值（工具和作业数据）来构建每个表达式。如要在表达式公式编辑器中输入一个函数或值，选择函数或值，然后按 Enter 键，双击函数或值或按 Insert（插入）按钮。
  2. 构建了表达式之后，工具将在图像中插入一个点图标，指示计算得出的点的位置。
  3. 在初始配置该工具的情况下，根据需要加载几个图像并调整工具参数，以补偿预期的变化范围。
  4. 最后，如需要，可以使用工具的输入/输出属性表以在其他工具和/或其他外部设备之间共享工具数据。


调整计算点数学逻辑工具参数

在将工具添加到作业之后，即可开始针对应用程序自定义和微调工具。

计算点数学逻辑工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • X 和 Y 选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

X 和 Y 选项卡


数学和逻辑计算点工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Point_1”（如果该工具是添加到作业中的第一个数学和逻辑计算点工具，之后名称将递增，如“Point_2”、“Point_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。.

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


计算点数学逻辑工具 - 设置选项卡

已关闭 结果

显示计算 X 和 Y 表达式的结果。


“计算点”数学 & 逻辑工具 - X、Y 选项卡

注意:当 In-Sight 视觉系统处于联机状态时会禁用这些控制。

X 和 Y 选项卡用于建立将定义点的 X 和 Y 坐标的数学公式。

已关闭 表达式

表达式文本框用于构造处理工具结果和数据的数学公式。可通过使用键盘键入数学函数的名称或作业/工具数据来输入数据，也可以利用左侧的视觉工具树、数学树、文本树和/或视觉数据访问树以及右侧的作业和工具数据符号树组合公式。可以通过双击项目输入项目，也可以通过突出显示项目并按插入按钮输入项目。

注意:
  • 如果表达式引用已删除的工具，则在公式中，该引用将自动替换为“Job.MissingArg”。该工具将返回“失败”，直到更正该引用。
  • 当生成表达式时，EasyBuilder 不能正确地分析开头的单元格地址（如 A3_MyTool 或 P10_SortTool）。如果表达式需要为这些工具配置，请在创建公式前重新命名这些工具。
已关闭 视觉工具

视觉工具树包含可用于构造表达式的附加边函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开边树，选择所需函数，然后按插入按钮。
  • 展开边树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 数学函数树

数学函数树包含可用于构造表达式的数学函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开数学树，选择所需函数，然后按插入按钮。
  • 展开数学树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 文本函数树

文本函数树中包含的函数用于设置字母数字数据的格式以进行显示和通信，并可用于构造表达式。可通过以下三种方法之一将函数添加到表达式：

  • 展开文本树，选择所需函数，然后按插入按钮。
  • 展开文本树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 视觉数据访问

视觉数据访问树包含可用于构造表达式的>附加数据（默认不可用）。可通过以下三种方法之一将函数添加到表达式：

  • 展开视觉数据访问树，选择所需函数，然后按插入按钮。
  • 展开视觉数据访问树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:
  • 可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
  • EasyBuilder 仅支持斑点、边和图形视觉数据访问函数。
已关闭 作业和工具数据符号树

作业和工具数据符号树包含定位和/或检测工具输出的数据，以及输入行和作业数据（如图像采集参数）。作业和工具数据是对其所含值的符号引用。符号可以通过以下三种方式中的一种被添加到表达式中：

  • 展开树型结构，选择所需符号引用，然后按插入按钮。
  • 展开树型结构，然后双击所需符号引用。
  • 使用键盘直接在表达式的文本框中输入所需符号的引用名称。
注意:可用符号列表取决光标在表达式中的位置。如果光标位于表达式中禁止添加符号的位置，则这些符号将不可用，直到光标位于可添加符号的位置。
已关闭 插入按钮

插入按钮用于将数学函数和符号放入表达式。选择所需数学函数或符号，然后按插入按钮将函数或符号添加到表达式。

注意:此控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用插入按钮。
已关闭 左括号、逗号、右括号按钮

左括号、逗号及右括号按钮用于构造数学公式。按相应按钮即可将这些符号添加到公式。

注意:这些控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用这些按钮。


数学逻辑工具 - 变量

变量数学逻辑工具用于定义可以从外部设备输入到作业的整数值、浮点值或字符串值，随后其它定位工具或检查工具或外部设备（如 PLC 或 VisionView® 操作员界面面板）就可以引用这些值。

变量数学逻辑工具在有些情况下很有用，例如，您想要从外部设备（如 PLC）将某个值输入到定位工具或检查工具，或是输入作为数学数学逻辑工具或组数学逻辑工具 表达式中的值。例如，如果您想要在某个应用程序中为读取文本识别工具输入一个文本字符串，输入一个整数值来控制斑点计数工具搜索的斑点数，输入一个浮点值作为组数学逻辑工具的执行公式的一部分，则可以在变量数学逻辑工具中创建这些值，然后它们便可被其它工具或在通信步骤中以符号形式引用。

设置工具

调整工具参数


设置“变量”数学 & 逻辑工具

添加了工具之后，您需要定义将用作输入变量的值。

  1. 配置常规选项卡中的设置以适合您的应用。
  2. 在设置窗格中，常规选项卡的旁边是输入变量表。如果您的值是布尔逻辑值，则按 Add Boolean（添加布尔值）按钮；如果您的值是整数，则按 Add Integer（添加整数）按钮；如果您的值为浮点值，则按 Add Floating Point（添加浮点值）按钮；如果您的值是文本字符串，则按 Add String（添加字符串）按钮。
  3. 添加了输入变量之后，可根据您的具体应用自定义它们。
  4. 在初始配置该工具的情况下，根据需要加载几个图像并调整工具参数，以补偿预期的变化范围。

  5. 最后，如需要，可以使用工具的输入/输出属性表以在其他工具和/或其他外部设备之间共享工具数据。

    注意:要从列表中删除变量，选中变量旁边的复选框，然后按 Remove（删除）按钮（必须选中复选框才能启用 Remove（删除）按钮）。


调整变量数学逻辑工具的参数

在将工具添加到作业之后，即可开始针对应用程序自定义和微调工具。

变量数学逻辑工具的设置窗格包含以下内容：

  • 常规选项卡
  • 输入变量表
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

输入变量表


数学和逻辑变量工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Variables_1”（如果该工具是添加到作业的第一个数学和逻辑变量工具，之后名称将递增，如“Variables_2”、“Variables_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


变量数学逻辑工具 - 输入变量表

变量数学逻辑工具的“输入变量表”用于添加、编辑和移除输入变量。每个变量数学逻辑工具最多可以创建 32 个输入变量。

已关闭 添加整数按钮

如果值为整数，则按添加整数按钮。默认情况下，添加的整数为 0，指定的名称为“Integer0”（该值是添加到工具的第一个整数值，之后名称将递增，如“Integer1”、“Integer2”等等）。通过给值指定与特定应用程序相关联的名称来对其进行自定义。整数范围为 9,999,999 到 -9,999,999。

已关闭 添加浮点数按钮

如果值为浮点值，则按添加浮点数按钮。默认情况下，添加的浮点数为 0，指定的名称为“Float0”（该值是添加到工具的第一个浮点值，之后名称将递增，如“Float1”、“Float2”等等）。通过给值指定与特定应用程序相关联的名称来对其进行自定义。浮点值范围为 9,999,999 到 -9,999,999。

已关闭 添加字符串按钮

如果值为文本字符串，则按添加字符串按钮。默认情况下会将文本字符串文本框留空，且指定的名称为“String0”（该值是添加到工具的第一个文本字符串值，之后名称将递增，如“String1”、“String2”等等）。通过给值指定与特定应用程序相关联的名称来对其进行自定义。文本字符串的长度最多可以为 32 个字符。

已关闭 移除按钮

按移除按钮可从表中删除值。要从列表中删除变量，请选中变量旁的复选框，然后按移除按钮（必须选中该复选框方可启用移除按钮）。


数学和逻辑工具 - 机器人向导

数学和逻辑工具 - 机器人引导

机器人引导数学和逻辑工具允许视觉系统将部件的位置传达给机器人。

设置工具

调整工具参数


设置机器人向导工具

设置机器人引导工具

提示:进行校准后，建议保存作业文件。对于后续的校准，可以简单地加载校准作业，采集图像，然后将更新的校准文件导出到所有引用此校准文件的作业。

添加工具后，您需要定义将用于构建校准的输入特征（点，定位特征的原点或圆形特征的中心）：

  1. 在添加工具后，EasyBuilder 将检测图像，并列出自动检测到的智能特征（包括点、定位特征或圆形特征的中心，以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）以供选择。EasyBuilder 将自动为先前未定义的所有圆特征插入“圆存在/不存在”工具。

  2. 通过单击在可选特征选择其中一个特征，此时颜色将更改为洋红色。

  3. 选择完特征后，点击OK按钮（按取消按钮则不会把工具添加到作业中）。

  4. 保存作业文件。
  5. 最初配置工具后，可根据需要调整工具的参数。
  6. 最后，如需要可以使用工具的输入/输出属性表来设置与其它工具及外部设备间的数据分享。


调整机器人向导工具参数

调整机器人引导工具参数

在将工具添加到作业之后，即可开始针对应用程序自定义和微调工具。

机器人引导校准工具的设置栏包含以下内容：

  • 常规选项卡

常规选项卡


机器人向导工具 - 常规选项卡

机器人引导工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，该名称将用于配置结果（设置图像，输入/输出和通信）; 默认名称为“Guidance_1。”您可通过为工具指定与特定应用程序相关联的名称来自定义工具。您只能为作业添加一个机器人引导工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


绘图工具 - 绘制弧

绘制弧绘图工具用于根据所定义的弧的中心 X、中心 Y、半径、起始角度和跨度值的数学表达式在图像上绘制圆弧图形。 该工具将在图像上绘图并返回弧的值。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置绘制弧绘图工具

添加该工具之后，需要构造将定义图形的表达式。

  1. 通过从设置窗格左侧选择并输入数学函数和从右侧选择并输入值（工具和作业数据）来构造将用于定义图形的数学表达式。要在表达式公式编辑器中输入函数或值，请选择函数或值并按 Enter 键、双击函数或值或者按插入按钮。
  2. 在构造将定义图像中绘图的表达式之后，EasyBuilder 会处理数据并创建图形。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整绘制弧绘图工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

绘制弧绘图工具的设置窗格包含以下内容：

  • 常规和设置选项卡
  • 中心 X、中心 Y、半径、起始角度和跨度表达式选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规和设置选项卡

X 中心、Y 中心、半径、起始角和跨度表达式选项卡


绘制弧绘图工具 - 常规和设置选项卡

已关闭 常规选项卡
已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Arc_1”（如果该工具是添加到作业的第一个绘制弧工具，之后名称将递增，如“Arc_2”、“Arc_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

已关闭 设置选项卡
已关闭 颜色

定义所显示的图形的颜色，默认颜色是作业中其它工具当前使用的颜色。

已关闭 结果

报告工具的表达式选项卡的结果；显示弧的 X、Y、半径、开始角度和跨度值。


Arc 标绘工具 - X 中心、Y 中心、半径、起始角和跨度表达式选项卡

Arc 标绘工具 由以下表达式选项卡（全部共享相同控制）组成以构建绘制的图形：X 中心、Y 中心、半径、起始角和跨度表达式选项卡。如有任何表达式选项卡处于错误状态 (#ERR)，则图形不会在图像中绘制，且会返回表示表达式选项卡出错的错误消息。

注意:当 In-Sight 视觉系统处于联机状态时会禁用这些控制。
已关闭 表达式

表达式文本框用于构造处理工具结果和数据的数学公式。可通过使用键盘键入数学函数的名称或作业/工具数据来输入数据，也可以利用左侧的视觉工具树、数学树、文本树和/或视觉数据访问树以及右侧的作业和工具数据符号树组合公式。可以通过双击项目输入项目，也可以通过突出显示项目并按插入按钮输入项目。

注意:
  • 如果表达式引用已删除的工具，则在公式中，该引用将自动替换为“Job.MissingArg”。该工具将返回“失败”，直到更正该引用。
  • 当生成表达式时，EasyBuilder 不能正确地分析开头的单元格地址（如 A3_MyTool 或 P10_SortTool）。如果表达式需要为这些工具配置，请在创建公式前重新命名这些工具。
已关闭 视觉工具

视觉工具树包含可用于构造表达式的附加边函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开边树，选择所需函数，然后按插入按钮。
  • 展开边树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 数学函数树

数学函数树包含可用于构造表达式的数学函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开数学树，选择所需函数，然后按插入按钮。
  • 展开数学树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 文本函数树

文本函数树中包含的函数用于设置字母数字数据的格式以进行显示和通信，并可用于构造表达式。可通过以下三种方法之一将函数添加到表达式：

  • 展开文本树，选择所需函数，然后按插入按钮。
  • 展开文本树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 视觉数据访问

视觉数据访问树包含可用于构造表达式的>附加数据（默认不可用）。可通过以下三种方法之一将函数添加到表达式：

  • 展开视觉数据访问树，选择所需函数，然后按插入按钮。
  • 展开视觉数据访问树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:
  • 可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
  • EasyBuilder 仅支持斑点、边和图形视觉数据访问函数。
已关闭 作业和工具数据符号树

作业和工具数据符号树包含定位和/或检测工具输出的数据，以及输入行和作业数据（如图像采集参数）。作业和工具数据是对其所含值的符号引用。符号可以通过以下三种方式中的一种被添加到表达式中：

  • 展开树型结构，选择所需符号引用，然后按插入按钮。
  • 展开树型结构，然后双击所需符号引用。
  • 使用键盘直接在表达式的文本框中输入所需符号的引用名称。
注意:可用符号列表取决光标在表达式中的位置。如果光标位于表达式中禁止添加符号的位置，则这些符号将不可用，直到光标位于可添加符号的位置。
已关闭 插入按钮

插入按钮用于将数学函数和符号放入表达式。选择所需数学函数或符号，然后按插入按钮将函数或符号添加到表达式。

注意:此控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用插入按钮。
已关闭 左括号、逗号、右括号按钮

左括号、逗号及右括号按钮用于构造数学公式。按相应按钮即可将这些符号添加到公式。

注意:这些控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用这些按钮。


绘图工具 - 绘制圆

绘制圆绘图工具用于根据所定义的圆的 X、 Y 和半径值的数学表达式在图像上绘制圆图形。 该工具将在图像上绘图并返回圆的值。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置绘制圆绘图工具

添加该工具之后，需要构造将定义图形的表达式。

  1. 通过从设置窗格左侧选择并输入数学函数和从右侧选择并输入值（工具和作业数据）来构造将用于定义图形的数学表达式。要在表达式公式编辑器中输入函数或值，请选择函数或值并按 Enter 键、双击函数或值或者按插入按钮。
  2. 在构造将定义图像中绘图的表达式之后，EasyBuilder 会处理数据并创建图形。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整绘制圆绘图工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

绘制圆绘图工具的设置窗格包含以下内容：

  • 常规和设置选项卡
  • X、Y和半径表达式选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规和设置选项卡

X、Y 和半径表达式选项卡


绘制圆绘图工具 - 常规和设置选项卡

已关闭 常规选项卡
已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Circle_1”（如果该工具是添加到作业的第一个绘制圆工具，之后名称将递增，如“Circle_2”、“Circle_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

已关闭 设置选项卡
已关闭 颜色

定义所显示的图形的颜色，默认颜色是作业中其它工具当前使用的颜色。

已关闭 结果

报告工具表达式选项卡的结果; 显示圆的 X、Y和半径值。


圆标绘工具 - X、Y 和半径表达式选项卡

圆标绘工具由以下表达式选项卡（全部共享相同控制）组成以构建绘制的图形：X、Y 和半径表达式选项卡。如有任何表达式选项卡处于错误状态 (#ERR)，则图形不会在图像中绘制，且会返回表示表达式选项卡出错的错误消息。

注意:当 In-Sight 视觉系统处于联机状态时会禁用这些控制。
已关闭 表达式

表达式文本框用于构造处理工具结果和数据的数学公式。可通过使用键盘键入数学函数的名称或作业/工具数据来输入数据，也可以利用左侧的视觉工具树、数学树、文本树和/或视觉数据访问树以及右侧的作业和工具数据符号树组合公式。可以通过双击项目输入项目，也可以通过突出显示项目并按插入按钮输入项目。

注意:
  • 如果表达式引用已删除的工具，则在公式中，该引用将自动替换为“Job.MissingArg”。该工具将返回“失败”，直到更正该引用。
  • 当生成表达式时，EasyBuilder 不能正确地分析开头的单元格地址（如 A3_MyTool 或 P10_SortTool）。如果表达式需要为这些工具配置，请在创建公式前重新命名这些工具。
已关闭 视觉工具

视觉工具树包含可用于构造表达式的附加边函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开边树，选择所需函数，然后按插入按钮。
  • 展开边树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 数学函数树

数学函数树包含可用于构造表达式的数学函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开数学树，选择所需函数，然后按插入按钮。
  • 展开数学树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 文本函数树

文本函数树中包含的函数用于设置字母数字数据的格式以进行显示和通信，并可用于构造表达式。可通过以下三种方法之一将函数添加到表达式：

  • 展开文本树，选择所需函数，然后按插入按钮。
  • 展开文本树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 视觉数据访问

视觉数据访问树包含可用于构造表达式的>附加数据（默认不可用）。可通过以下三种方法之一将函数添加到表达式：

  • 展开视觉数据访问树，选择所需函数，然后按插入按钮。
  • 展开视觉数据访问树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:
  • 可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
  • EasyBuilder 仅支持斑点、边和图形视觉数据访问函数。
已关闭 作业和工具数据符号树

作业和工具数据符号树包含定位和/或检测工具输出的数据，以及输入行和作业数据（如图像采集参数）。作业和工具数据是对其所含值的符号引用。符号可以通过以下三种方式中的一种被添加到表达式中：

  • 展开树型结构，选择所需符号引用，然后按插入按钮。
  • 展开树型结构，然后双击所需符号引用。
  • 使用键盘直接在表达式的文本框中输入所需符号的引用名称。
注意:可用符号列表取决光标在表达式中的位置。如果光标位于表达式中禁止添加符号的位置，则这些符号将不可用，直到光标位于可添加符号的位置。
已关闭 插入按钮

插入按钮用于将数学函数和符号放入表达式。选择所需数学函数或符号，然后按插入按钮将函数或符号添加到表达式。

注意:此控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用插入按钮。
已关闭 左括号、逗号、右括号按钮

左括号、逗号及右括号按钮用于构造数学公式。按相应按钮即可将这些符号添加到公式。

注意:这些控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用这些按钮。


绘图工具 - 绘制交叉

绘制交叉绘图工具用于根据所定义的交叉的 X、 Y 和半径值的数学表达式在图像上绘制交叉图形。 该工具将在图像上绘图并返回交叉图形的值。

注意:
  • 该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。
  • 绘制交叉绘图工具的输出可以作为定位特征被其它工具使用。

设置工具

调整工具参数


设置绘制交叉图形绘图工具

添加该工具之后，需要构造将定义图形的表达式。

  1. 通过从设置窗格左侧选择并输入数学函数和从右侧选择并输入值（工具和作业数据）来构造将用于定义图形的数学表达式。要在表达式公式编辑器中输入函数或值，请选择函数或值并按 Enter 键、双击函数或值或者按插入按钮。
  2. 在构造将定义图像中绘图的表达式之后，EasyBuilder 会处理数据并创建图形。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整绘制交叉图形绘图工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

绘制交叉图形绘图工具的设置窗格包含以下内容：

  • 常规和设置选项卡
  • X、Y和角度表达式选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规和设置选项卡

X、Y 和角度表达式选项卡


绘制交叉绘图工具 - 常规和设置选项卡

已关闭 常规选项卡
已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Cross_1”（如果该工具是添加到作业的第一个绘制交叉工具，之后名称将递增，如“Cross_2”、“Cross_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

已关闭 设置选项卡
已关闭 颜色

定义所显示的图形的颜色，默认颜色是作业中其它工具当前使用的颜色。

已关闭 结果

报告工具表达式选项卡的结果; 显示交叉的 X、Y 和角度值。


标绘交叉工具 - X、Y 和角度表达式选项卡

标绘交叉工具由以下表达式选项卡（全部共享相同控制）组成以构建绘制的图形：X、Y 和角度表达式选项卡。如有任何表达式选项卡处于错误状态 (#ERR)，则图形不会在图像中绘制，且会返回表示表达式选项卡出错的错误消息。

注意:当 In-Sight 视觉系统处于联机状态时会禁用这些控制。
已关闭 表达式

表达式文本框用于构造处理工具结果和数据的数学公式。可通过使用键盘键入数学函数的名称或作业/工具数据来输入数据，也可以利用左侧的视觉工具树、数学树、文本树和/或视觉数据访问树以及右侧的作业和工具数据符号树组合公式。可以通过双击项目输入项目，也可以通过突出显示项目并按插入按钮输入项目。

注意:
  • 如果表达式引用已删除的工具，则在公式中，该引用将自动替换为“Job.MissingArg”。该工具将返回“失败”，直到更正该引用。
  • 当生成表达式时，EasyBuilder 不能正确地分析开头的单元格地址（如 A3_MyTool 或 P10_SortTool）。如果表达式需要为这些工具配置，请在创建公式前重新命名这些工具。
已关闭 视觉工具

视觉工具树包含可用于构造表达式的附加边函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开边树，选择所需函数，然后按插入按钮。
  • 展开边树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 数学函数树

数学函数树包含可用于构造表达式的数学函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开数学树，选择所需函数，然后按插入按钮。
  • 展开数学树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 文本函数树

文本函数树中包含的函数用于设置字母数字数据的格式以进行显示和通信，并可用于构造表达式。可通过以下三种方法之一将函数添加到表达式：

  • 展开文本树，选择所需函数，然后按插入按钮。
  • 展开文本树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 视觉数据访问

视觉数据访问树包含可用于构造表达式的>附加数据（默认不可用）。可通过以下三种方法之一将函数添加到表达式：

  • 展开视觉数据访问树，选择所需函数，然后按插入按钮。
  • 展开视觉数据访问树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:
  • 可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
  • EasyBuilder 仅支持斑点、边和图形视觉数据访问函数。
已关闭 作业和工具数据符号树

作业和工具数据符号树包含定位和/或检测工具输出的数据，以及输入行和作业数据（如图像采集参数）。作业和工具数据是对其所含值的符号引用。符号可以通过以下三种方式中的一种被添加到表达式中：

  • 展开树型结构，选择所需符号引用，然后按插入按钮。
  • 展开树型结构，然后双击所需符号引用。
  • 使用键盘直接在表达式的文本框中输入所需符号的引用名称。
注意:可用符号列表取决光标在表达式中的位置。如果光标位于表达式中禁止添加符号的位置，则这些符号将不可用，直到光标位于可添加符号的位置。
已关闭 插入按钮

插入按钮用于将数学函数和符号放入表达式。选择所需数学函数或符号，然后按插入按钮将函数或符号添加到表达式。

注意:此控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用插入按钮。
已关闭 左括号、逗号、右括号按钮

左括号、逗号及右括号按钮用于构造数学公式。按相应按钮即可将这些符号添加到公式。

注意:这些控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用这些按钮。


绘图工具 - 绘制线

绘制线绘图工具用于根据所定义的线的起点 X、起点 Y 、终点 X 和终点 Y 值的数学表达式在图像上绘制线。 该工具将在图像上绘图，并返回线开始和结束 X / Y 的值。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置绘制直线绘图工具

添加该工具之后，需要构造将定义图形的表达式。

  1. 通过从设置窗格左侧选择并输入数学函数和从右侧选择并输入值（工具和作业数据）来构造将用于定义图形的数学表达式。要在表达式公式编辑器中输入函数或值，请选择函数或值并按 Enter 键、双击函数或值或者按插入按钮。
  2. 在构造将定义图像中绘图的表达式之后，EasyBuilder 会处理数据并创建图形。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整绘制直线绘图工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

绘制直线绘图工具的设置窗格包含以下内容：

  • 常规和设置选项卡
  • 起始 X、起始 Y、终止 X和终止 Y 表达式选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规和设置选项卡

X 起始、Y 起始、X 结束和 Y 结束表达式选项卡


绘制线绘图工具 - 常规和设置选项卡

已关闭 常规选项卡
已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Line_1”（如果该工具是添加到作业的第一个绘制线工具，之后名称将递增，如“Line_2”、“Line_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

已关闭 设置选项卡
已关闭 颜色

定义所显示的图形的颜色，默认颜色是作业中其它工具当前使用的颜色。

已关闭 结果

报告工具表达式选项卡的结果; 显示线的起点和终点 X 和 Y 的值。


线标绘工具 - X 起始、Y 起始、X 结束和 Y 结束表达式选项卡

线标绘工具由以下表达式选项卡（全部共享相同控制）组成以构建绘制的图形：X 起始、Y 起始、X 结束和 Y 结束表达式选项卡。如有任何表达式选项卡处于错误状态 (#ERR)，则图形不会在图像中绘制，且会返回表示表达式选项卡出错的错误消息。

注意:当 In-Sight 视觉系统处于联机状态时会禁用这些控制。
已关闭 表达式

表达式文本框用于构造处理工具结果和数据的数学公式。可通过使用键盘键入数学函数的名称或作业/工具数据来输入数据，也可以利用左侧的视觉工具树、数学树、文本树和/或视觉数据访问树以及右侧的作业和工具数据符号树组合公式。可以通过双击项目输入项目，也可以通过突出显示项目并按插入按钮输入项目。

注意:
  • 如果表达式引用已删除的工具，则在公式中，该引用将自动替换为“Job.MissingArg”。该工具将返回“失败”，直到更正该引用。
  • 当生成表达式时，EasyBuilder 不能正确地分析开头的单元格地址（如 A3_MyTool 或 P10_SortTool）。如果表达式需要为这些工具配置，请在创建公式前重新命名这些工具。
已关闭 视觉工具

视觉工具树包含可用于构造表达式的附加边函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开边树，选择所需函数，然后按插入按钮。
  • 展开边树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 数学函数树

数学函数树包含可用于构造表达式的数学函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开数学树，选择所需函数，然后按插入按钮。
  • 展开数学树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 文本函数树

文本函数树中包含的函数用于设置字母数字数据的格式以进行显示和通信，并可用于构造表达式。可通过以下三种方法之一将函数添加到表达式：

  • 展开文本树，选择所需函数，然后按插入按钮。
  • 展开文本树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 视觉数据访问

视觉数据访问树包含可用于构造表达式的>附加数据（默认不可用）。可通过以下三种方法之一将函数添加到表达式：

  • 展开视觉数据访问树，选择所需函数，然后按插入按钮。
  • 展开视觉数据访问树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:
  • 可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
  • EasyBuilder 仅支持斑点、边和图形视觉数据访问函数。
已关闭 作业和工具数据符号树

作业和工具数据符号树包含定位和/或检测工具输出的数据，以及输入行和作业数据（如图像采集参数）。作业和工具数据是对其所含值的符号引用。符号可以通过以下三种方式中的一种被添加到表达式中：

  • 展开树型结构，选择所需符号引用，然后按插入按钮。
  • 展开树型结构，然后双击所需符号引用。
  • 使用键盘直接在表达式的文本框中输入所需符号的引用名称。
注意:可用符号列表取决光标在表达式中的位置。如果光标位于表达式中禁止添加符号的位置，则这些符号将不可用，直到光标位于可添加符号的位置。
已关闭 插入按钮

插入按钮用于将数学函数和符号放入表达式。选择所需数学函数或符号，然后按插入按钮将函数或符号添加到表达式。

注意:此控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用插入按钮。
已关闭 左括号、逗号、右括号按钮

左括号、逗号及右括号按钮用于构造数学公式。按相应按钮即可将这些符号添加到公式。

注意:这些控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用这些按钮。


绘图工具 - 绘制点

绘制点绘图工具用于根据所定义的点的 X 和 Y 值的数学表达式在图像上绘制点图形。 该工具将在图像上绘图并返回点的值。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置绘制点绘图工具

添加该工具之后，需要构造将定义图形的表达式。

  1. 通过从设置窗格左侧选择并输入数学函数和从右侧选择并输入值（工具和作业数据）来构造将用于定义图形的数学表达式。要在表达式公式编辑器中输入函数或值，请选择函数或值并按 Enter 键、双击函数或值或者按插入按钮。
  2. 在构造将定义图像中绘图的表达式之后，EasyBuilder 会处理数据并创建图形。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整绘制点绘图工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

绘制点绘图工具的设置窗格包含以下内容：

  • 常规和设置选项卡
  • X 和 Y 表达式选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规和设置选项卡

X 和 Y 表达式选项卡


绘制点绘图工具 - 常规和设置选项卡

已关闭 常规选项卡
已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Point_1”（如果该工具是添加到作业的第一个绘制点工具，之后名称将递增，如“Point_2”、“Point_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

已关闭 设置选项卡
已关闭 颜色

定义所显示的图形的颜色，默认颜色是作业中其它工具当前使用的颜色。

已关闭 结果

报告工具表达式选项卡的结果; 显示点的 X 和 Y 的值。


点标绘工具 - X 和 Y 表达式选项卡

点标绘工具由以下表达式选项卡（全部共享相同控制）组成以构建绘制的图形：X 和 Y 表达式选项卡。如有任何表达式选项卡处于错误状态 (#ERR)，则图形不会在图像中绘制，且会返回表示表达式选项卡出错的错误消息。

注意:当 In-Sight 视觉系统处于联机状态时会禁用这些控制。
已关闭 表达式

表达式文本框用于构造处理工具结果和数据的数学公式。可通过使用键盘键入数学函数的名称或作业/工具数据来输入数据，也可以利用左侧的视觉工具树、数学树、文本树和/或视觉数据访问树以及右侧的作业和工具数据符号树组合公式。可以通过双击项目输入项目，也可以通过突出显示项目并按插入按钮输入项目。

注意:
  • 如果表达式引用已删除的工具，则在公式中，该引用将自动替换为“Job.MissingArg”。该工具将返回“失败”，直到更正该引用。
  • 当生成表达式时，EasyBuilder 不能正确地分析开头的单元格地址（如 A3_MyTool 或 P10_SortTool）。如果表达式需要为这些工具配置，请在创建公式前重新命名这些工具。
已关闭 视觉工具

视觉工具树包含可用于构造表达式的附加边函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开边树，选择所需函数，然后按插入按钮。
  • 展开边树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 数学函数树

数学函数树包含可用于构造表达式的数学函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开数学树，选择所需函数，然后按插入按钮。
  • 展开数学树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 文本函数树

文本函数树中包含的函数用于设置字母数字数据的格式以进行显示和通信，并可用于构造表达式。可通过以下三种方法之一将函数添加到表达式：

  • 展开文本树，选择所需函数，然后按插入按钮。
  • 展开文本树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 视觉数据访问

视觉数据访问树包含可用于构造表达式的>附加数据（默认不可用）。可通过以下三种方法之一将函数添加到表达式：

  • 展开视觉数据访问树，选择所需函数，然后按插入按钮。
  • 展开视觉数据访问树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:
  • 可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
  • EasyBuilder 仅支持斑点、边和图形视觉数据访问函数。
已关闭 作业和工具数据符号树

作业和工具数据符号树包含定位和/或检测工具输出的数据，以及输入行和作业数据（如图像采集参数）。作业和工具数据是对其所含值的符号引用。符号可以通过以下三种方式中的一种被添加到表达式中：

  • 展开树型结构，选择所需符号引用，然后按插入按钮。
  • 展开树型结构，然后双击所需符号引用。
  • 使用键盘直接在表达式的文本框中输入所需符号的引用名称。
注意:可用符号列表取决光标在表达式中的位置。如果光标位于表达式中禁止添加符号的位置，则这些符号将不可用，直到光标位于可添加符号的位置。
已关闭 插入按钮

插入按钮用于将数学函数和符号放入表达式。选择所需数学函数或符号，然后按插入按钮将函数或符号添加到表达式。

注意:此控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用插入按钮。
已关闭 左括号、逗号、右括号按钮

左括号、逗号及右括号按钮用于构造数学公式。按相应按钮即可将这些符号添加到公式。

注意:这些控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用这些按钮。


绘图工具 - 绘制区域

绘制区域绘图工具用于根据所定义的区域的 X、 Y 、高度、宽度、角度和弯曲度值的数学表达式在图像上绘制区域。 该工具将在图像上绘图，并返回指定区域位置、形状和大小的值。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置绘制区域绘图工具

添加该工具之后，需要构造将定义图形的表达式。

  1. 通过从设置窗格左侧选择并输入数学函数和从右侧选择并输入值（工具和作业数据）来构造将用于定义图形的数学表达式。要在表达式公式编辑器中输入函数或值，请选择函数或值并按 Enter 键、双击函数或值或者按插入按钮。
  2. 在构造将定义图像中绘图的表达式之后，EasyBuilder 会处理数据并创建图形。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整绘制区域绘图工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

绘制区域绘图工具的设置窗格包含以下内容：

  • 常规和设置选项卡
  • X、Y、高度、宽度、角度和曲线表达式选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规和设置选项卡

X、Y、高度、宽度、角度以及弯度表达式选项卡


绘制区域绘图工具 - 常规和设置选项卡

已关闭 常规选项卡
已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Region_1”（如果该工具是添加到作业的第一个绘制范围工具，之后名称将递增，如“Region_2”、“Region_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

已关闭 设置选项卡
已关闭 颜色

定义所显示的图形的颜色，默认颜色是作业中其它工具当前使用的颜色。

已关闭 结果

报告工具的表达式选项卡的结果；显示范围的 X、Y、高度、宽度、角度和弯曲度的值。


范围标绘工具 - X、Y、高度、宽度、角度以及弯度表达式选项卡

区域标绘工具由以下表达式选项卡（全部共享相同控制）组成以构建绘制的图形：X、Y、高度、宽度以及弯度表达式选项卡。X 表达式选项卡定义区域的第一个顶点的位置；Y 表达式选项卡定义区域的其他顶点；高度表达式选项卡定义沿正 X 轴的区域尺寸；宽度表达式选项卡定义沿正 Y 轴的区域尺寸；角度表达式选项卡定义从正 X 轴到区域的第一个边界的区域角度（以度为单位）；弯度表达式选项卡定义区域的两个侧面边界之间的角度（以度为单位）。如有任何表达式选项卡处于错误状态 (#ERR)，则图形不会在图像中绘制，且会返回表示表达式选项卡出错的错误消息。

注意:当 In-Sight 视觉系统处于联机状态时会禁用这些控制。
已关闭 表达式

表达式文本框用于构造处理工具结果和数据的数学公式。可通过使用键盘键入数学函数的名称或作业/工具数据来输入数据，也可以利用左侧的视觉工具树、数学树、文本树和/或视觉数据访问树以及右侧的作业和工具数据符号树组合公式。可以通过双击项目输入项目，也可以通过突出显示项目并按插入按钮输入项目。

注意:
  • 如果表达式引用已删除的工具，则在公式中，该引用将自动替换为“Job.MissingArg”。该工具将返回“失败”，直到更正该引用。
  • 当生成表达式时，EasyBuilder 不能正确地分析开头的单元格地址（如 A3_MyTool 或 P10_SortTool）。如果表达式需要为这些工具配置，请在创建公式前重新命名这些工具。
已关闭 视觉工具

视觉工具树包含可用于构造表达式的附加边函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开边树，选择所需函数，然后按插入按钮。
  • 展开边树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 数学函数树

数学函数树包含可用于构造表达式的数学函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开数学树，选择所需函数，然后按插入按钮。
  • 展开数学树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 文本函数树

文本函数树中包含的函数用于设置字母数字数据的格式以进行显示和通信，并可用于构造表达式。可通过以下三种方法之一将函数添加到表达式：

  • 展开文本树，选择所需函数，然后按插入按钮。
  • 展开文本树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 视觉数据访问

视觉数据访问树包含可用于构造表达式的>附加数据（默认不可用）。可通过以下三种方法之一将函数添加到表达式：

  • 展开视觉数据访问树，选择所需函数，然后按插入按钮。
  • 展开视觉数据访问树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:
  • 可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
  • EasyBuilder 仅支持斑点、边和图形视觉数据访问函数。
已关闭 作业和工具数据符号树

作业和工具数据符号树包含定位和/或检测工具输出的数据，以及输入行和作业数据（如图像采集参数）。作业和工具数据是对其所含值的符号引用。符号可以通过以下三种方式中的一种被添加到表达式中：

  • 展开树型结构，选择所需符号引用，然后按插入按钮。
  • 展开树型结构，然后双击所需符号引用。
  • 使用键盘直接在表达式的文本框中输入所需符号的引用名称。
注意:可用符号列表取决光标在表达式中的位置。如果光标位于表达式中禁止添加符号的位置，则这些符号将不可用，直到光标位于可添加符号的位置。
已关闭 插入按钮

插入按钮用于将数学函数和符号放入表达式。选择所需数学函数或符号，然后按插入按钮将函数或符号添加到表达式。

注意:此控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用插入按钮。
已关闭 左括号、逗号、右括号按钮

左括号、逗号及右括号按钮用于构造数学公式。按相应按钮即可将这些符号添加到公式。

注意:这些控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用这些按钮。


绘图工具 - 绘制字符串

绘制字符串绘图工具用于根据所定义的字符串的 X 和 Y 位置值的数学表达式在图像上绘制字符串图形。 该工具将在图像上绘图并返回字符串 X/Y 位置的值。

注意:该工具以像素为单位返回结果，除非在设置图像应用程序步骤中将图像校准为真实世界单位（In-Sight 视觉系统）或视野（宽度）设置为真实世界单位（In-Sight 2000 系列视觉传感器） 。

设置工具

调整工具参数


设置绘制字符串绘图工具

添加该工具之后，需要构造将定义图形的表达式。

  1. 通过从设置窗格左侧选择并输入数学函数和从右侧选择并输入值（工具和作业数据）来构造将用于定义图形的数学表达式。要在表达式公式编辑器中输入函数或值，请选择函数或值并按 Enter 键、双击函数或值或者按插入按钮。
  2. 在构造将定义图像中绘图的表达式之后，EasyBuilder 会处理数据并创建图形。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整绘制字符串绘图工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

绘制字符串绘图工具的设置窗格包含以下内容：

  • 常规和设置选项卡
  • 表达式选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规和设置选项卡

X、Y 和弦表达式选项卡


绘制字符串绘图工具 - 常规和设置选项卡

已关闭 常规选项卡
已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“String_1”（如果该工具是添加到作业的第一个绘制字符串工具，之后名称将递增，如“String_2”、“String_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。

已关闭 设置选项卡
已关闭 结果

报告工具表达式选项卡的结果; 显示字符串的 X 和 Y 的值。

已关闭 颜色

定义所显示的图形的颜色，默认颜色是作业中其它工具当前使用的颜色。

已关闭 字体名称

定义将用于字符串图形的字体类型；默认选择 Arial。

已关闭 字体样式

定义用于字符串图形的字体样式（常规、斜体、粗体或粗斜体）；默认情况下，字体样式为常规字体。

已关闭 字体大小

定义用于字符串图形的字体大小；默认设置为 9 磅。


字符串标绘工具 - X、Y 和字符串表达式选项卡

字符串标绘工具由以下表达式选项卡（全部共享相同控制）组成以构建绘制的图形：X、Y 和字符串表达式选项卡。如有任何表达式选项卡处于错误状态 (#ERR)，则图形不会在图像中绘制，且会返回表示表达式选项卡出错的错误消息。

注意:当 In-Sight 视觉系统处于联机状态时会禁用这些控制。
已关闭 表达式

表达式文本框用于构造处理工具结果和数据的数学公式。可通过使用键盘键入数学函数的名称或作业/工具数据来输入数据，也可以利用左侧的视觉工具树、数学树、文本树和/或视觉数据访问树以及右侧的作业和工具数据符号树组合公式。可以通过双击项目输入项目，也可以通过突出显示项目并按插入按钮输入项目。

注意:
  • 如果表达式引用已删除的工具，则在公式中，该引用将自动替换为“Job.MissingArg”。该工具将返回“失败”，直到更正该引用。
  • 当生成表达式时，EasyBuilder 不能正确地分析开头的单元格地址（如 A3_MyTool 或 P10_SortTool）。如果表达式需要为这些工具配置，请在创建公式前重新命名这些工具。
已关闭 视觉工具

视觉工具树包含可用于构造表达式的附加边函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开边树，选择所需函数，然后按插入按钮。
  • 展开边树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 数学函数树

数学函数树包含可用于构造表达式的数学函数。可通过以下三种方法之一将函数添加到表达式：

  • 展开数学树，选择所需函数，然后按插入按钮。
  • 展开数学树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 文本函数树

文本函数树中包含的函数用于设置字母数字数据的格式以进行显示和通信，并可用于构造表达式。可通过以下三种方法之一将函数添加到表达式：

  • 展开文本树，选择所需函数，然后按插入按钮。
  • 展开文本树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
已关闭 视觉数据访问

视觉数据访问树包含可用于构造表达式的>附加数据（默认不可用）。可通过以下三种方法之一将函数添加到表达式：

  • 展开视觉数据访问树，选择所需函数，然后按插入按钮。
  • 展开视觉数据访问树，然后双击所需函数。
  • 使用键盘直接在表达式文本框中键入所需函数的名称。
注意:
  • 可用函数列表视光标在表达式中的放置位置而定。如果光标位于表达式中禁止添加数学函数的位置，则这些函数不可用，直到光标位于可以添加数学函数的位置。
  • EasyBuilder 仅支持斑点、边和图形视觉数据访问函数。
已关闭 作业和工具数据符号树

作业和工具数据符号树包含定位和/或检测工具输出的数据，以及输入行和作业数据（如图像采集参数）。作业和工具数据是对其所含值的符号引用。符号可以通过以下三种方式中的一种被添加到表达式中：

  • 展开树型结构，选择所需符号引用，然后按插入按钮。
  • 展开树型结构，然后双击所需符号引用。
  • 使用键盘直接在表达式的文本框中输入所需符号的引用名称。
注意:可用符号列表取决光标在表达式中的位置。如果光标位于表达式中禁止添加符号的位置，则这些符号将不可用，直到光标位于可添加符号的位置。
已关闭 插入按钮

插入按钮用于将数学函数和符号放入表达式。选择所需数学函数或符号，然后按插入按钮将函数或符号添加到表达式。

注意:此控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用插入按钮。
已关闭 左括号、逗号、右括号按钮

左括号、逗号及右括号按钮用于构造数学公式。按相应按钮即可将这些符号添加到公式。

注意:这些控制与数学函数树及作业和工具数据符号树协同工作；只要任一列表中的所选项目对于光标在表达式文本框中的特定位置有效，就会启用这些按钮。


图像过滤工具 - 过滤

注意:此工具仅适用于运行 In-Sight 固件 5.1.0 及更高版本的 In-Sight 视觉系统。 有关型号和支持的固件版本的完整列表，请参阅固件版本。

图像过滤工具过滤通过本地和全局图像优化技巧来过滤图像区域 ；输出可由其它位置或检测工具引用的工具图像。

图像过滤工具是个多功能工具，可以用来生成用来优化图像中低对比度以及/或曝光特征的彩色或灰度输出图像。 该工具可以帮助突出所需的特征并最大限度地减少不需要的特征。 如果能有效地使用该工具，它可以使检测应用更可靠和可复制。

图像过滤工具提供本地和全局图像优化技巧；图像优化技巧可以通过选择过滤类型来定义。

设置工具

调整工具参数


设置图像过滤工具

添加工具之后，需要配置将定义要增强的图像区的区域。

  1. 定位区域以使其边界只包含过滤的图像区 - 如果该区域包含您不想过滤的区域，则可能会产生不正确的结果。为了帮助提高该工具的性能，请创建较小的区域。区域越大，执行检查所花费的时间越长。如果没有使用定位特征，请确保要过滤的图像区在每个图像中出现在大致相同的位置。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 在初始配置该工具时，根据需要加载一些调整工具参数，以补偿预期的变化范围。
  4. 最后，如需要可以使用工具的输入/输出属性表来设置与其它工具及设备间的数据分享。


调整图像过滤工具参数

在设置完工具的区域后，你可以开始优化应用程序工具。

图像过滤工具的设置框包含以下内容：

  • 常规选项卡
  • 设置选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡


图像过滤工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Filter_1”（如果该工具是添加到作业中的第一个图像过滤工具，之后名称将递增，如“Filter_2”、“Filter_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


图像过滤工具 - 设置选项卡

已关闭 筛选类型

定义将应用于该区域的图像增强技术。图像增强技术产生的结果将会在该区域内自动更新。

筛选类型 | 说明
二进制化（默认值）

根据灰度阈值将图像过滤成白色 (255) 或黑色 (0)；在输出图像中，输入像素值等于或高于阈值时为白色，低于阈值时为黑色。

注意:在使用彩色输入图像时，输出图像将会是灰度图像。
底帽（Bottom Hat）

过滤掉除小于“筛选大小”的暗特征之外的所有内容；输出的图像在暗背景上将暗特征显示为亮像素。

注意:该操作将激活内核行和内核列参数。内核必须从整数的奇数值上开始建立。
剪断

通过将各个像素的灰度值与最小及最大灰度值进行比较来过滤图像；在输出图像中会消除灰度光谱的极端，以使特征更加一致。
关闭

过滤掉小于“筛选大小”的暗特征；输出图像的总体亮度级略有增加。

注意:该操作将激活内核行和内核列参数。内核必须从整数的奇数值上开始建立。
扩大

增大亮特征而缩小暗特征；输出图像的浅色像素区域变大。此过滤对于移除暗点或暗斑很有用。

注意:该操作将激活内核行和内核列参数。内核必须从整数的奇数值上开始建立。
边大小

过滤深色及浅色特征；在输出图像中边表现为浅色像素。此操作作用于对角方向的边，而速度比“全部梯度”操作慢。

注意:该操作将激活内核行和内核列参数。内核必须从整数的奇数值上开始建立。
使均衡 | 根据直方图均衡来进行过滤，其中会对最频繁出现的灰度值进行均衡以创建更均匀的分布；输出图像的对比度增加。
蚀刻

增大暗特征而缩小亮特征；输出图像的暗像素区域变大。此滤波器对于移除亮点或亮斑很有用。

注意:该操作将激活内核行和内核列参数。内核必须从整数的奇数值上开始建立。
填充深色孔 | 将浅色像素所包围的深色像素转换为浅色像素；在输出图像中会填充深色孔。
填充浅色孔 | 将深色像素所包围的浅色像素转换为深色像素；在输出图像中会填充浅色孔。
完全梯度 | 过滤垂直及水平边特征；在输出图像中以浅色像素表示垂直及水平方向的边。此操作对对角方向的边不起作用，但速度比“边大小”操作快。
水平梯度 | 过滤水平边特征；在输出图像中水平方向的边表现为浅色像素。
垂直梯度 | 过滤垂直边特征；在输出图像中垂直方向的边表现为浅色像素。
灰度距离

根据每个输出像素的灰度值过滤为每个输入像素的灰度值与阈值级别的差值；例如，在输出图像中，如果输入像素值为 100，阈值为 25，则输出像素值为 75。
高通

过滤边特征并抑制其它特征；在输出图像中会相对于区域以更加一致的灰度梯度增强边。

注意:该操作将激活内核行和内核列参数。内核必须从整数的奇数值上开始建立。
反向 | 根据像素值的灰度反向进行过滤；输出图像是输入图像的“负片”。
本地中位数

指定在内核附近的像素值中计算中值像素值的操作，然后使用此结果作为输出图像的像素值。

注意:该操作将激活内核行和内核列参数。内核必须从整数的奇数值上开始建立。
标准化本地中位数

指定要减去的图像的背景的方式；该操作会从输入图像中减去输入图像的局部平均值，将结果往右移一位，然后加上 128 以产生输出像素的值。

注意:该操作将激活内核行和内核列参数。内核必须从整数的奇数值上开始建立。
低通

过滤边特征并将边与其它特征相混；在输出图像中会对边进行“平滑”或模糊处理。

注意:该操作将激活内核行和内核列参数。内核必须从整数的奇数值上开始建立。
最大（顶部值/底部值）

指定使用最大 Top Hat 和 Bottom Hat 操作的操作。

注意:该操作将激活内核行和内核列参数。内核必须从整数的奇数值上开始建立。
打开

过滤掉小于“筛选大小”的浅色特征；输出图像的总体亮度级略有降低。

注意:该操作将激活内核行和内核列参数。内核必须从整数的奇数值上开始建立。
光密度

根据对数刻度上像素值的反向来进行过滤，在输出图像中通过测量穿过对象和特征的光线量来展现其密度。密度较高的对象和特征在输出图像中以较浅的像素表示。
锐化

指定用于提升边缘“锐度”的操作。该操作计算相邻像素间的对比度，并在对比度高的时候提高对比度。相邻像素之间拥有大的对比度通常代表边缘，但此操作不能被用来定位边缘。该操作是否有用将取决于图像的内容和分辨率。

  • 增益参数规定了锐化的强度，在锐化过程中指定忽略过滤一些像素间的差异，以使得轻纹理的区域不会被过度锐化。
拉伸 | 通过线性比例缩放或“拉伸”灰度值来进行过滤，输出图像的对比度增加。
阈值范围

根据二进制（黑色和白色）阈值进行过滤，该操作会将每个输入像素与两个阈值（最小值和最大值）进行比较来确定输出像素是白色还是黑色。在输出图像中，如果输入像素值小于等于最小值或大于等于最大值，则输出像素为白色；如果输入像素值在最小值和最大值范围之内，则输出像素为黑色。
Top Hat

过滤掉除小于“筛选大小”的浅色特征之外的所有内容；输出的图像在暗背景上将浅色特征显示为亮像素。

注意:该操作将激活内核行和内核列参数。内核必须从整数的奇数值上开始建立。
已关闭 内核行

指定内核的行数(1–25; 默认 = 3)。内核是一个数字的矩形阵列，该数字矩形阵列规定了在图像每个像素位置执行操作的处理区域。像素相邻的灰度值指定了在输出图像中该像素位置的灰度值。

注意:

  • 内核未加权。

  • 内核必须从整数的奇数值上开始建立。典型的内核大小为 3 x 3，但尺寸可以是任意的。

当过滤类型被设置为以下任何一种时，该参数会被激活。

  • 底帽（Bottom Hat）
  • 关闭
  • 扩大
  • 边大小
  • 蚀刻
  • 高通
  • 本地中位数
  • 标准化本地中位数
  • 低通
  • 最大（顶部值/底部值）
  • 打开
  • 顶帽（Top Hat）
已关闭 内核列

指定内核的列数(1–25; 默认 = 3)。内核是一个数字的矩形阵列，该数字矩形阵列规定了在图像每个像素位置执行操作的处理区域。像素相邻的灰度值指定了在输出图像中该像素位置的灰度值。

注意:

  • 内核未加权。

  • 内核必须从整数的奇数值上开始建立。典型的内核大小为 3 x 3，但尺寸可以是任意的。

当过滤类型被设置为以下任何一种时，该参数会被激活。

  • 底帽（Bottom Hat）
  • 关闭
  • 扩大
  • 边大小
  • 蚀刻
  • 高通
  • 本地中位数
  • 标准化本地中位数
  • 低通
  • 最大（顶部值/底部值）
  • 打开
  • 顶帽（Top Hat）
已关闭 阈值模式

指定当过滤类型被设置成二进制化、灰度距离或阈值范围时是否自动计算阈值等级。

  • 手动：启用阈值参数并手动指定阈值等级。
  • 自动（默认）:
    • 当过滤类型被设置成二进制时，工具会自动根据指定范围内的灰度值来计算阈值等级。
    • 当过滤类型被设置成灰度距离时，工具会自动根据指定范围内的中间灰度值来计算阈值等级。
    • 当过滤类型被设置为阈值范围时，将自动执行以下操作：
      • 如果像素值小于最小参数设置，或像素值大于最大参数设置，像素值会被设置成背景像素值。
      • 当像素值在最小和最大参数设置范围内时，像素值会被设置为前景像素值。
已关闭 阈值

当过滤类型被设置为二进制、灰度距离或阈值范围时，指定阈值等级（0 至 255；默认 = 128）。

已关闭 最小

当过滤类型被设置为剪切、拉伸或阈值范围时定义最小灰度值（0 至 255；默认 = 128）。

已关闭 最大

当过滤类型被设置为剪切、拉伸或阈值范围时定义最大灰度值（0 至 255；默认 = 128）。

已关闭 增益

当过滤类型被设置为锐化时定义增益值（0 至 10；默认 = 1）。该参数规定了会被用来控制优化边缘对比度量的锐化强度。在边缘附近的像素会被修改为它们的最大或最小值以创建一个更清晰的边缘外观。

已关闭 平滑度

当过滤类型被设置为锐化时定义内部高斯曲线（用于识别边缘）的平滑度值（1 至 4；默认 = 1）。平滑度被用来控制内部高斯曲线的标准偏差；更高的平滑度值会导致可以在更宽的“光圈”上进行平滑操作以帮助锐化功能。

注意:高斯曲线指的是一个在 ROI 中对像素进行平均加权的钟型的曲线。


图像过滤工具 - 点

注意:该工具仅在运行 In-Sight 固件版本 4.x.x 版本的 In-Sight 视觉系统上可用，但不能在运行 In-Sight 固件版本 5.1.0 或更新版本的 In-Sight 视觉系统上使用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

点图像过滤工具采用逐像素“全局”图像增强技术对图像区域进行过滤，如阈值设定、反向、均衡、裁剪或拉伸。输出可由其它定位工具或检查工具引用的工具图像。

全局图像增强操作包括根据工具区域中像素的各个灰度值为输出像素分配灰度值。

点图像过滤工具在一些情况下很有用，例如，需要增强图像的某个区域以便更好地检测特征来进行检查，如裁剪表面的热点以便更好读取 OCR 字符，或拉伸部件的特征以获得增强的对比度。

设置工具

调整工具参数


设置点图像过滤工具

添加工具之后，需要配置将定义要增强的图像区的区域。

  1. 定位区域以使其边界只包含过滤的图像区 - 如果该区域包含您不想过滤的区域，则可能会产生不正确的结果。为了帮助提高该工具的性能，请创建较小的区域。区域越大，执行检查所花费的时间越长。如果没有使用定位特征，请确保要过滤的图像区在每个图像中出现在大致相同的位置。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。

图像筛选工具和颜色工具 - 工具图像


图像过滤工具和颜色工具 - 工具图像

图像过滤工具(过滤、邻域、点、场景校正、颜色到灰度、颜色到二进制、转换以及比较)和颜色工具(彩色斑点和彩色斑点(1-10) 定位工具、计算颜色像素以及彩色斑点存在/不存在工具、单个彩色斑点区域和彩色斑点区域(1-10) 测算工具、彩色斑点计数工具、颜色模型确认工具或颜色到二进制图像过滤工具）的输出图像，该图像可以被用来作为图像工具在定位和检测工具中的输入。

将输出工具图像的工具添加到作业后，在所有接受除采集图像以外图像的工具的常规选项卡中可找到工具图像设置；或者在添加输出工具图像的工具后，该设置作为添加工具时方向设置栏中的下拉选项。

当位置或检测工具的工具图像参数设置为可输出工具图像（图像滤波工具也可使用另一个图像滤波工具作为输入）的工具时，这些工具使用过滤后的图像执行检测，并且它们的区域必须始终保持在输出工具图像区域的工具的边界之内。

要将工具的工具图像参数设置为图像滤波工具，首先添加图像滤波工具，然后返回到前一个工具的常规选项卡，并将工具图像参数设置为新添加的图像滤波工具。

注意:在产生输出图像工具的图像过滤工具或颜色工具被添加到作业后，每次添加支持使用除采集图像以外图像的新工具时，系统都会提示在设置栏的方向组框中设置工具的输入图像。默认选择是当前采集的未经过滤的图像。


调整点图像过滤工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

点滤波图像过滤工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 之前/之后选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

之前/之后选项卡


点图像过滤工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Filter_1”（如果该工具是添加到作业中的第一个图像过滤工具，之后名称将递增，如“Filter_2”、“Filter_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


点图像过滤工具 - 设置选项卡

已关闭 操作

定义将应用于该区域的图像增强技术。图像增强技术产生的结果将会在该区域内自动更新。

操作 | 说明
二进制化（默认值） | 根据灰度阈值将图像过滤成白色 (255) 或黑色 (0)；在输出图像中，输入像素值等于或高于阈值时为白色，低于阈值时为黑色。
剪切 | 通过将各个像素的灰度值与最小及最大灰度值进行比较来过滤图像；在输出图像中会消除灰度光谱的极端，以使特征更加一致。
使均衡 | 根据直方图均衡来进行过滤，其中会对最频繁出现的灰度值进行均衡以创建更均匀的分布；输出图像的对比度增加。
灰度距离 | 根据每个输出像素的灰度值过滤为每个输入像素的灰度值与阈值级别的差值；例如，在输出图像中，如果输入像素值为 100，阈值为 25，则输出像素值为 75。
反向 | 根据像素值的灰度反向进行过滤；输出图像是输入图像的“负片”。
阈值范围 | 根据二进制（黑色和白色）阈值进行过滤，该操作会将每个输入像素与两个阈值（最小值和最大值）进行比较来确定输出像素是白色还是黑色。在输出图像中，如果输入像素值小于等于最小值或大于等于最大值，则输出像素为白色；如果输入像素值在最小值和最大值范围之内，则输出像素为黑色。
光密度 | 根据对数刻度上像素值的反向来进行过滤，在输出图像中通过测量穿过对象和特征的光线量来展现其密度。密度较高的对象和特征在输出图像中以较浅的像素表示。
拉伸 | 通过线性比例缩放或“拉伸”灰度值来进行过滤，输出图像的对比度增加。
已关闭 最小值

定义“裁剪”和“阈值范围”操作的最小灰度值（0 至 255）。仅当选择了这两个操作之一时才会启用此控制。

已关闭 最大值

定义“剪切”和“阈值范围”操作的最大灰度值（0 至 255）。仅当选择了这两个操作之一时才会启用此控制。

已关闭 阈值模式

当操作被设置为二进制、灰度距离或阈值范围时，定义确定将图像区域划分为黑色和白色像素的灰度值的模式。如果选择“自动”（默认值 = 自动），每次采集图像时，该工具会根据图像创建默认“智能设置”，不断地调整从图像到图像的亮度变化。当选手动时，需要手动输入和调整该值。

已关闭 阈值

为二进制化、灰度距离和阈值范围操作定义将黑色像素与白色像素分开的灰度值（0 - 255，如果启用）；低于阈值的像素值被归类为黑色，高于阈值的像素值被归类为白色。默认情况下此控制为“关”，要启用该控制，需要将“阈值模式”设置为“手动”。使用图形设置应用程序的最佳值。


点图像过滤工具 – 之前/之后选项卡

之前/之后选项卡显示区域中像素灰度值的直方图表示。之前选项卡显示图像区域在处理之前的直方图，而之后选项卡则显示区域处理后的直方图。

  • 图形的 X 轴表示灰度值的总数（0 到 255，或总计 256 个灰度级）。
  • 图形的 Y 轴表示给定灰度值的像素数，通过显示具有最大像素数的灰度值来建立标度。
  • 绿色的垂直线指示用于将图像区域分成黑色和白色像素的阈值；线左侧的值被视为黑色，而右侧的值则被视为白色。


图像过滤工具 - 邻域

注意:该工具仅在运行 In-Sight 固件版本 4.x.x 版本的 In-Sight 视觉系统上可用，但不能在运行 In-Sight 固件版本 5.1.0 或更新版本的 In-Sight 视觉系统上使用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

邻域图像过滤工具采用逐像素“邻域”图像增强技术对图像区域进行过滤，如收缩、扩大、填充、平滑或边缘增强。输出可由其它定位工具或检查工具引用的工具图像。

邻域图像增强操作包括根据工具区域中的“邻域”像素的灰度值为输出像素分配灰度值。“邻域区”的大小由“过滤行”及“过滤列”参数确定。

邻域图像过滤工具在一些情况下很有用，例如，需要增强图像的某个区域以便更好地检测特征来进行检查，如缩小金属表面的眩光以便更好读取点喷代码，或是在读取 OCR 字符时扩大灰度光谱的浅色端以移除暗斑。

设置工具

调整工具参数


设置邻域图像过滤工具

添加工具之后，需要配置将定义要增强的图像区的区域。

  1. 定位区域以使其边界只包含过滤的图像区 - 如果该区域包含您不想过滤的区域，则可能会产生不正确的结果。为了帮助提高该工具的性能，请创建较小的区域。区域越大，执行检查所花费的时间越长。如果没有使用定位特征，请确保要过滤的图像区在每个图像中出现在大致相同的位置。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整邻域图像过滤工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

邻域滤波器图像过滤工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡


邻域图像过滤工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Filter_1”（如果该工具是添加到作业中的第一个图像过滤工具，之后名称将递增，如“Filter_2”、“Filter_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


邻域图像过滤工具 – 设置选项卡

已关闭 操作

定义将应用于该区域的图像增强技术。图像增强技术产生的结果将会在该区域内自动更新。

操作 | 说明
底帽（Bottom Hat） | 过滤掉除小于“筛选大小”的暗特征之外的所有内容；输出的图像在暗背景上将暗特征显示为亮像素。
关闭 | 过滤掉小于“筛选大小”的暗特征；输出图像的总体亮度级略有增加。
扩大 | 增大亮特征而缩小暗特征；输出图像的浅色像素区域变大。此滤波器对于移除暗点或暗斑很有用。
边大小 | 过滤深色及浅色特征；在输出图像中边表现为浅色像素。此操作作用于对角方向的边，而速度比“全部梯度”操作慢。
蚀刻 | 增大暗特征而缩小亮特征；输出图像的暗像素区域变大。此滤波器对于移除亮点或亮斑很有用。
填充深色孔 | 将浅色像素所包围的深色像素转换为浅色像素；在输出图像中会填充深色孔。
填充浅色孔 | 将深色像素所包围的浅色像素转换为深色像素；在输出图像中会填充浅色孔。
垂直梯度 | 过滤垂直边特征；在输出图像中垂直方向的边表现为浅色像素。
水平梯度 | 过滤水平边特征；在输出图像中水平方向的边表现为浅色像素。
全部梯度 | 过滤垂直及水平边特征；在输出图像中以浅色像素表示垂直及水平方向的边。此操作对对角方向的边不起作用，但速度比“边大小”操作快。
高通 | 过滤边特征并抑制其它特征；在输出图像中会相对于区域以更加一致的灰度梯度增强边。
低通（默认值） | 过滤边特征并将边与其它特征相混；在输出图像中会对边进行“平滑”或模糊处理。
打开 | 过滤掉小于“筛选大小”的浅色特征；输出图像的总体亮度级略有降低。
顶帽（Top Hat） | 过滤掉除小于“筛选大小”的浅色特征之外的所有内容；输出的图像在暗背景上将浅色特征显示为亮像素。
已关闭 过滤行

指定图像处理邻域区在水平方向的大小。

已关闭 过滤列

指定图像处理邻域区在垂直方向的大小。


图像过滤工具 - 场景纠正

注意:该工具仅在运行 In-Sight 固件版本 4.x.x 版本的 In-Sight 视觉系统上可用，但不能在运行 In-Sight 固件版本 5.1.0 或更新版本的 In-Sight 视觉系统上使用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

图像过滤场景纠正工具使用“平均强度”逐像素临近图像优化的技术过滤图像中的区域；并输出一个工具图像，该图像可以被其它的位置或检测工具所使用。

平均强度图像优化技术以在处理过程中的临近区域像素中的像素强度为基础来过滤图像。该选项可在行数和列数参数中被定义。该过滤工具通过将每个像素的强度值与处理过程中临近区域的像素平均强度值对比来模拟过滤图像中不均匀的照明或阴影。图像中没有或只有很少变化的区域，不论原来的强度如何都会被转换成自然灰色。比周围像素深的像素会被转化成比中性灰色更深的颜色，像素变深的程度将由这些像素比周围像素深的程度而决定。同样的，比周围像素浅的像素和会被转化为比自然灰色更浅的颜色。类似于“高通过”操作，边缘或突变将被保留。

图像过滤场景纠正工具对于那些光照不均匀或含有阴影的图像操作来说非常有用。

设置工具

调整工具参数


设置图像过滤场景纠正工具

添加工具之后，需要配置将定义要增强的图像区的区域。

  1. 定位区域以使其边界只包含过滤的图像区 - 如果该区域包含您不想过滤的区域，则可能会产生不正确的结果。为了帮助提高该工具的性能，请创建较小的区域。区域越大，执行检查所花费的时间越长。如果没有使用定位特征，请确保要过滤的图像区在每个图像中出现在大致相同的位置。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 在初始配置该工具时，根据需要加载一些调整工具参数，以补偿预期的变化范围。
  4. 最后，如需要可以使用工具的输入/输出属性表来设置与其它工具及设备间的数据分享。


调整图像过滤场景纠正工具参数

在设置完工具的区域后，你可以开始优化应用程序工具。

图像过滤场景纠正工具的设置栏包含以下内容：

  • 常规选项卡
  • 设置选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡


场景纠正图像过滤工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Filter_1”（如果该工具是添加到作业中的第一个图像过滤工具，之后名称将递增，如“Filter_2”、“Filter_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


图像过滤场景纠正工具 - 设置选项卡

已关闭 行数

指定在水平方向处理图像相邻区域的大小。(1 - 图像高度最大值；默认 = 11)。

注意:
  • 最大值将根据 In-Sight 视觉系统图像区域的大小来定义（例如：640 x 480, 1024 x 768 or 1600 x 1200）等。
  • 仅奇数数值可以被用来定义图像处理过程相邻区域的大小；如果输入了一个偶数数值，则该数值将被自动下舍入。
已关闭 列数

指定在垂直方向处理图像相邻区域的大小。(1 - 图像宽度最大值；默认 = 11)。

注意:
  • 最大值将根据 In-Sight 视觉系统图像区域的大小来定义（例如：640 x 480, 1024 x 768 or 1600 x 1200）等。
  • 仅奇数数值可以被用来定义图像处理过程相邻区域的大小；如果输入了一个偶数数值，则该数值将被自动下舍入。
已关闭 超时

指定工具计算图像强度的时间，以毫秒为单位(0 至 30000; 默认 = 0)。超过该设定时间，操作会自动停止并返回错误信息。将该值设置为 0 意味着禁用该参数。


图像过滤工具 - 颜色转为灰度

颜色转为灰度图像过滤工具根据指定的操作，将区域中的每个颜色像素转换为灰度值来过滤图像的区域。输出可由其它定位工具或检查工具引用的工具图像。

颜色转为灰度工具依据简单的单颜色参数滤波器，将区域中的每个颜色像素转换为灰度值：“纯”红色、绿色或蓝色 (RGB)；色调、饱和度或亮度 (HSI)；照度；或 RGB 成分加权平均值插值法。

设置工具

调整工具参数


设置颜色转为灰度图像过滤工具

添加工具之后，需要配置将定义要增强的图像区的区域。

  1. 定位区域以使其边界只包含过滤的图像区 - 如果该区域包含您不想过滤的区域，则可能会产生不正确的结果。为了帮助提高该工具的性能，请创建较小的区域。区域越大，执行检查所花费的时间越长。如果没有使用定位特征，请确保要过滤的图像区在每个图像中出现在大致相同的位置。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整颜色转为灰度图像过滤工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

颜色转为灰度图像过滤工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡


彩色转为灰度图像过滤工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“ColorFilter_1”（如果该工具是添加到作业的第一个二进制到彩色图像过滤工具，之后名称将递增，如“ColorFilter”、“ColorFilter_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


颜色转为灰度图像过滤工具 - 设置选项卡

已关闭 操作
操作 | 说明
照度（默认） | 输出照度的图像。照度在概念上与亮度紧密相关，是特定区域发射或反射的光量的测量值；输入图像中像素发射出的光越多，则它在输出图像中就越亮。
红色 | 输出的图像将过滤掉像素中除红色 (255,0,0) 组分外的所有组分。输入图像中像素的“红色”值越高，则它在输出图像中就会越亮。
绿色 | 输出的图像将过滤掉像素中除绿色 (0,255,0) 组分外的所有组分。输入图像中像素的“绿色”值越高，则它在输出图像中就会越亮。
蓝色 | 输出的图像将过滤掉像素中除蓝色 (0,0,255) 组分外的所有组分。输入图像中像素的“蓝色”值越高，则它在输出图像中就会越亮。
色调 | 输出的图像将过滤掉像素中除“色调”组分外的所有组分。输入图像中像素的“色调”值越高，则它在输出图像中就会越亮。
饱和度 | 输出的图像将过滤掉像素中除“饱和度”组分外的所有组分。输入图像中像素的“饱和度”值越高，则它在输出图像中就会越亮。
亮度 | 输出的图像将过滤掉像素中除“亮度”组分外的所有组分，并确定像素 RGB 组分的平均亮度。输入图像中像素的“亮度”值越高，则它在输出图像中就会越亮。
插值法 | 输出使用“插值法”（像素中红色、绿色和蓝色 (RGB) 组分的加权平均值）的图像过滤。与“亮度”操作相同，结果是将过滤掉像素中除“亮度”组分外的所有组分。输入图像中像素的“亮度”值越高，则它在输出图像中就会越亮。但是，“插值法”确定 RGB 组分的加权平均亮度，是非标准的转换滤波器。


图像过滤工具 - 颜色转为二进制

颜色转为二进制图像过滤工具通过将与活动颜色模型匹配的像素转换为白色，并将其它所有像素转为黑色来过滤图像的区域；输出可由其它定位工具或检查工具引用的工具图像。

颜色转为二进制工具会引用颜色模型的训练库，然后确定区域中与库中选择的训练颜色模型相匹配的像素数量。该工具随后会创建一个二进制灰度输出图像，其中与活动颜色模型匹配的每个像素均设置为白色 (255)，而其它所有像素均设置为黑色 (0)。

设置工具

调整工具参数


设置颜色转为二进制图像过滤工具

添加工具之后，需要配置将定义要增强的图像区的区域。

  1. 定位区域以使其边界只包含过滤的图像区 - 如果该区域包含您不想过滤的区域，则可能会产生不正确的结果。为了帮助提高该工具的性能，请创建较小的区域。区域越大，执行检查所花费的时间越长。如果没有使用定位特征，请确保要过滤的图像区在每个图像中出现在大致相同的位置。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 配置搜索区域后，需要配置该工具的颜色库并激活相应的颜色模型：

  • 如果这是首次添加颜色工具（“彩色斑点”与“彩色斑点 (1-10)”定位工具、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”与“彩色斑点面积 (1-10)”测量工具、“彩色斑点”计数工具、“颜色模型”识别工具或“颜色转为二进制”图像过滤工具），需要首先定义颜色库及其颜色模型。

  • 如果先前已添加另一个颜色工具，并且想要利用现有颜色库及其训练的颜色模型，请转到“设置”选项卡并选择所需的颜色库，然后在“库”选项卡中选中所需颜色模型以将其激活。

  • 默认情况下，工具将自动产生“失败”，直至定义颜色库。如果已定义颜色库，则工具将自动使用该库并激活其包含的所有颜色模型。

  4. 设置颜色模型和颜色库后，该工具将处理图像，搜索区域内与所选颜色模型匹配的所有像素都会变为白色 (255)，而与颜色模型不匹配的像素则会变为黑色 (0)。

  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整颜色转为二进制图像过滤工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

“颜色转为二进制”图像过滤工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 颜色库选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

颜色库选项卡


二进制到彩色图像过滤工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“ColorFilter_1”（如果该工具是添加到作业的第一个二进制到彩色图像过滤工具，之后名称将递增，如“ColorFilter_2”、“ColorFilter_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


颜色转为二进制图像过滤工具 - 设置选项卡

已关闭 训练颜色

启动“ExtractColor 训练”对话框，用于定义所选颜色库的颜色模型。

已关闭 颜色库

定义工具将引用的颜色库。从下拉列表中，选择要修改的颜色库，然后按训练颜色按钮启动“ExtractColor 训练”对话框。每个颜色库最多可包含 100 种不同的由各个颜色组成的颜色模型。

EasyBuilder 作业最多可包含 5 个颜色库，可在下列工具之间共享颜色库：

  • 彩色斑点定位工具
  • 彩色斑点 (1-10) 定位工具
  • 颜色像素计数存在/不存在工具
  • 彩色斑点面积测量工具
  • 彩色斑点面积 (1-10) 测量工具
  • 彩色斑点计数工具
  • 颜色模型识别工具
  • 颜色转为二进制图像过滤工具


颜色转为二进制图像过滤工具 - 颜色库选项卡

已关闭 颜色模型列表

显示所选颜色库中包含的颜色模型的只读列表。通过选中或取消选中颜色模型名称旁边的复选框来激活或禁用颜色模型。

已关闭 颜色表

显示所选颜色模型中颜色的只读排序表。

已关闭 颜色名称

显示所选颜色模型中颜色的名称。

已关闭 RGB

显示所选颜色模型中颜色的 RGB 值。

已关闭 运算

显示所选颜色模型中颜色的运算（加或减）。


图像过滤工具 - 变换

变换图像过滤工具用于过滤图像区域中的线性、非线性和/或镜头失真，并在实际单位与设置图像步骤中通过网格校准，校准像素之间的应用变换，输出可由其它定位工具和检查工具引用的工具图像。

在设置图像步骤中，“变换”图像过滤工具与网格校准结合使用，以补偿和更正光学失真并返回高度精确的测量值，同时将像素单位转换为实际测量单位，如毫米或英寸。通过此工具和网格校准可以更精确地在图像边缘定位对象，并提供更好的安装灵活性，包括能与检查表面呈 45° 安装 In-Sight 视觉系统。

设置工具

调整工具参数


设置变换图像过滤工具

注意:添加该工具之前，请确保已在设置图像步骤中使用网格校准校准图像。

添加工具之后，需要配置将定义要增强的图像区的区域。

  1. 定位区域以使其边界只包含过滤的图像区 - 如果该区域包含您不想过滤的区域，则可能会产生不正确的结果。为了帮助提高该工具的性能，请创建较小的区域。区域越大，执行检查所花费的时间越长。如果没有使用定位特征，请确保要过滤的图像区在每个图像中出现在大致相同的位置。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整变换图像过滤工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

变换图像过滤工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡


转换图像过滤工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Transform_1”（如果该工具是添加到作业中的第一个转换图像过滤工具 ，之后名称将递增，如“Transform_2”、“Transform_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


变换图像过滤工具 - 设置选项卡

已关闭 图像缩放比例

定义变换图像的显示缩放比例（0.01 到 10；默认 = 1.0）。

已关闭 参考中心

定义变换的参考点原点、图像中心（默认值，用于定义参考点为图像的中心）或区域中心（用于定义参考点为区域的中心）。

已关闭 显示图像

定义是否显示变换的图像而不显示采集图像。默认情况下，此参数为选中状态（已启用），将始终显示变换的图像。

注意:其它位置和检测工具仍可以对采集图像执行其检测，而无需应用变换滤波器。但是，它们的图形重叠显示可能会超出与所显示的变换图像相关的上下文。通过取消选中工具的显示图形选项，可以在运行作业中隐藏这些工具的图形重叠。


图像过滤工具 - 比较

比较图像过滤工具依据模板图像过滤图像以生成灰度输出图像，其中每个像素表示标准化差异；输出可由其它定位工具或检查工具引用的工具图像。

“比较”图像增强过程包括将像素从模板图像映射到输入图像以进行比较并生成灰度输出图像，其中与模板图像不匹配的像素将显示为白色像素。

当想要在制造过程中检测部件或对象的瑕疵时，比较图像过滤工具非常有用。例如，对没有瑕疵的部件或对象训练比较图像过滤工具，该工具随后将针对每个后续采集图像运行该训练图像。然后其它工具（如斑点计数工具）以斑点计数工具的反向逻辑对由比较图像过滤工具输出的工具图像执行检测，以便工具在未检测到任何斑点时通过，而在检测到斑点时失败。

设置工具

调整工具参数


设置比较图像过滤工具

添加工具之后，需要配置将定义要增强的图像区的区域。

注意:当图像中的背景噪音很少或几乎没有，并且每个图像几乎相同，即，部件或对象出现在相同位置并且瑕疵明显且较大（如果有）时，该工具性能最佳。如果图像中存在噪音，可考虑使用配置为二进制化操作的点滤波器图像过滤工具删除图像中的灰度差异。
  1. 定位区域以使其边界只包含过滤的图像区 - 如果该区域包含您不想过滤的区域，则可能会产生不正确的结果。为了帮助提高该工具的性能，请创建较小的区域。区域越大，执行检查所花费的时间越长。如果没有使用定位特征，请确保要过滤的图像区在每个图像中出现在大致相同的位置。
  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。
  3. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  4. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整比较图像过滤工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

比较图像过滤工具的设置窗格包含以下内容：

  • 常规选项卡
  • 设置选项卡
  • 训练图像选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

已训练图像选项卡


比较图像过滤工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Filter_1”（如果该工具是添加到作业中的第一个图像过滤工具，之后名称将递增，如“Filter_2”、“Filter_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


比较图像过滤工具 - 设置选项卡

已关闭 像素比较

定义将模板映射到输入图像时将执行的像素比较的类型：最近邻域或双线性插值法。

最近邻域（默认设置）执行的图像映射操作为：将模板中的每个像素与在输入图像中最邻近的像素进行比较，来计算每个像素的标准化灰度差异。这种图像映射方法速度较快，但准确度较低。

双线性插值法执行的图像映射操作为：将模板中的每个像素与加权的平均值（表示输入图像中四个最邻近像素的灰度值）进行比较，来计算每个像素的标准化灰度差异。这种图像映射方法准确度较高，但速度较慢。

已关闭 边范围

定义图像比较期间边周围所容许的像素数（0-24；默认 = 3）。该数值越大，则越不可能将输出图像中不完全匹配的边表示为差异。


比较图像过滤工具 - 训练图像选项卡

训练图像选项卡中显示的图像是模型模板图像的缩略图。按模型区域按钮可调整模型区域的大小或移动该区域，然后按训练按钮重新训练模型模板图像。


缺陷检测工具 - 外观瑕疵

外观瑕疵检测工具可以根据像素的强度变化来检测小瑕疵。该工具可用来在灰度或彩色图像上检测划痕、刻痕、破损、污渍或小缺口等瑕疵。

外观瑕疵检测工具是为检测局部强度和颜色变化区域而设计的瑕疵检测工具。在执行斑点分析以确定瑕疵是否存在之前，该工具使用一个内部的过滤操作，首先以突然的颜色或灰度变化加亮突出边缘和区域。该工具最适合应用于那些含有均匀分布区域的待检测部件，因此在该部件上发生的任何突然强度变化都能被归类为缺陷。

如需要，“外观瑕疵”工具还可以提供内置的图像掩膜来提亮需要被检测图像中的区域，同时排除不相关区域。

设置工具

调整工具参数


设置表面瑕疵检测工具

设置此工具将包括建立将用于确定是否存在缺陷的阈值。在开始之前，应当通过从 PC 加载图像，来加载要被检查部件（在其通过和未通过状态中）图像的数据库。

  1. 首先，在其无错状态下加载零件的图像。然后，添加表面瑕疵工具。

  2. 配置图像中的区域。从区域类型下拉菜单中，选择区域类型：矩形（默认），圆形，环形或多边形。定位和配置图像中您预计会出现瑕疵的区域; 确保该区域的边界覆盖瑕疵及其可能出现的位置。

    注意:
    • 为了提高工具的性能，可以尝试创建较小的区域; 较大的区域需要较长的检测时间。如果不使用定位特征，请确保缺陷存在于每个图像中大致相同的位置，或者该区域足够大以包括特征的预期移动。
    • 添加工具后，您可以通过右键单击图像中的区域并从将区域更改到选项中选择所需的形状来更改区域类型。
  3. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  4. 在零件处于无错状态时，调整工具的参数，以确保工具不会识别任何瑕疵。使用瑕疵候选项选项卡中的显示图像参数可显示参数调整如何影响工具结果的视觉反馈。将显示图像参数设置为瑕疵候选项作为开始，以使任何检测到的缺陷都包含在红色边框内。

    注意:可以选择创建一个图像掩膜来突出显示要检查的图像区域，同时排除其他区域。（可选）当配置涉及到文本、标签或其他应被忽略的特征检查时，图像掩膜非常有用。
  5. 当调整参数时，从工具的区域开始，以确保关注区域正确地包括要检查的区域：该设置不包含无关的特征，例如标签、字符或徽标的边缘。如果检测将包括部件的边缘，则该区域必须平行于边缘定位（同样适用于圆形区域，其中圆形区域弧平行于部件的边缘）。
  6. 接下来，尝试调整采样因子和平滑因子参数。当尝试检测低阶瑕疵或具有低对比度的大瑕疵时，增加采样参数。增加平滑因子参数以帮助去除小的，假的缺陷。
  7. 调整这些参数后，使用检测类型、检测大小和检测轴参数的不同选项。对于大多数应用，检测类型参数可设置为快速，检测大小为1。对于需要轻度瑕疵、深色瑕疵或浅色和深色瑕疵的应用程序，检测尺寸参数必须设置为大于要检测的缺陷半径的尺寸。如果将区域配置为与边缘平行，则检测轴必须设置为与区域平行运行。
  8. 然后调整最小瑕疵面积，最大瑕疵面积和最小对比度参数。
  9. 一旦工具在其无错误状态下可以正确检查零件，则可以开始加载包含瑕疵的零件的图像。再次，通过调整参数的过程，直到工具可以正确识别预期的瑕疵。加载更多含有零件瑕疵的图像，并根据需要调整参数以识别额外的瑕疵。
  10. 在识别出瑕疵之后，重新加载无错误状态的零件图像，并确保它仍然被能被正确检测为不包含瑕疵。一旦配置完成，该工具就可以进行运行时的检测了。
  11. 最后，如需要可以使用工具的输入/输出属性表来设置与其它工具及设备间的数据分享。

设置工具掩膜


设置外观瑕疵缺陷检测工具掩膜

在“外观瑕疵缺陷检测工具”被添加后，你可以创建一个内部掩膜来高亮显示被检测区域，并排除其它区域。

  1. 在掩膜选项卡中，选中“激活掩膜”选择框以使用掩膜。
  2. 决定如何生成掩膜：最大分割区域或边缘。默认情况下（“掩膜方式”参数被默认设置为“边缘掩膜”），边缘将会被用来根据边缘强度来生成图像掩膜。使用该图像掩膜，仅边缘的像素会被掩盖，其它的像素会显示。如果选择最大分割区域，那么被检测的区域会成为最大的分割区域，以此来排除不需被检测的背景。
  3. 将“显示掩膜图像”参数设置到你想要生成的掩膜类型以通过显示索引和颜色编码后的分割区域高亮显示掩膜。
  4. 调整“掩膜平滑因子”来确保图像的边缘被高亮显示。
  5. 接着，调整“最大填孔尺寸”、“核心面积中位数”以及“掩膜侵蚀计数”参数。这些参数可以被用来填孔，平滑边界以及/或在图像掩膜中移除窄条。如果选择了“边缘掩膜”，“最大填孔尺寸”参数应该被设置为 0。
  6. 一旦掩膜在排除其它特征的同时可以正确地高亮显示部件上所需的特征，点击”训练“按钮以设置掩膜。
注意:除了区域参数，所有参数的改变都会更新掩膜并迫使重新训练掩膜。如果区域被移动或大小被重置，必须重新点击训练按钮以更新掩膜。


调整外观瑕疵缺陷检测工具参数

在设置完工具的区域后，你可以开始优化应用程序工具。

外观瑕疵缺陷检测工具 的设置面板包含了以下选项卡：

  • 常规选项卡
  • 掩膜选项卡
  • 瑕疵检测选项卡
  • 数据、瑕疵以及组合区域选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

掩膜选项卡

缺陷检测选项卡

统计数据、缺陷以及复合区域选项卡


表面瑕疵检测工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“SurfaceFlaw_1”（如果该工具是添加到作业的第一个表面瑕疵检测工具，之后名称将递增，如“SurfaceFlaw_2”、“SurfaceFlaw_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


外观瑕疵缺陷检测工具 - 掩膜选项卡

已关闭 启用掩膜

定义是否使用掩膜 (默认 = 关闭)。

已关闭 训练掩膜

定义会根据当前配置的参数设置来训练掩膜。

已关闭 掩膜模式

定义工具将如果建立掩膜 (最大分割区域或边缘掩膜; 默认 = 边缘掩膜)。

  • 最大分割区域：该工具会使用最大分割区域来产生掩膜。
  • 边缘掩膜：该工具会使用边缘来生成掩膜（“最小边缘对比”参数决定了哪个边缘将被使用）。
已关闭 显示掩膜图像

定义显示的输出图像（输入图像、边缘图像、分割图像或掩膜图像；默认 = 掩膜图像）。

  • 输入图像：显示一个当前采集的图像。
  • 边缘图像：显示一个有边缘强度的图像。
  • 分割图像：显示一个经过颜色编码和分割的图像。
  • 掩膜图像：显示一个在掩膜分割和生成过程后创建的掩膜图像（在计算定位特征输入后）。255 像素值 = 考虑像素值；0 像素值 = 不考虑像素值。
注意:该图像仅限于显示，不能被用作其它功能的输入图像。
已关闭 掩膜平滑因子

定义用来平滑图像的 sigma 因子 (0 至 100; 默认值 = 1)。

已关闭 最小边缘对比

定义用来检测边缘的最小对比度 (1 至100; 默认值 = 1)。

注意:该参数仅在“掩膜方式”参数被设置为“边缘掩膜”时才可被启用。
已关闭 最小分割区域

定义分割区域被提取所必需的最小区域 (1 至 50000; 默认值 = 1000)，以像素为单位。

已关闭 最大填孔区域

定义需要被填的孔（不被看作是个孔）的最大区域 (0 至 1000; 默认值 = 100)。

已关闭 核心面积中位值

定义用来平滑掩膜图像边缘的核心面积大小中位值 (0 至 50000; 默认值 = 0)。

已关闭 侵蚀掩膜计数

定义生成的掩膜将被侵蚀的次数 (-100 至 100; 默认值 = 0)。该值可以为正或负；负值将使图像扩大。

已关闭 反转

定义是否反转图像，例如白色转成黑色或黑色转成白色。


表面瑕疵检测工具 - 瑕疵检测选项卡

已关闭 检测类型

定义应用于图像以确定瑕疵是否存在的图像处理类型(快速、浅色瑕疵、深色瑕疵或浅色和深色瑕疵；默认=快速)。

  • 快速：该选项适用于检测部件表面类似于边缘的强度转换，例如条纹或划痕。该选项通过应用侵蚀扩张操作，提亮显示缺陷的边缘。该选项最节省操作时间，但是在报告瑕疵时，该选项仅报告瑕疵的周长，但不报告瑕疵的区域。
  • 浅色瑕疵：该选项适用于检测部件表面在深色背景上类似于斑点的瑕疵，并根据它们的区域像素大小来检测瑕疵。该选项通过应用 “top hat” 过滤操作，过滤出所有比检测尺寸参数小的明亮特征来检测可能存在的瑕疵。
  • 深色瑕疵：该选项适用于检测部件表面在浅色背景上类似于斑点的瑕疵，并根据它们的区域像素大小来检测瑕疵。该选项通过应用 “button hat” 过滤操作，过滤出所有比检测尺寸参数小的深色特征来检测可能存在的瑕疵。
  • 浅色和深色瑕疵：该选项适用于检测部件表面在深色或浅色背景上类似于斑点的瑕疵，并根据它们的区域像素大小来检测瑕疵。该选项通过应用 “top hat” 和 “button hat” 过滤操作，并使用两个操作的最大结果。
注意:如果浅色瑕疵、深色瑕疵或浅色和深色瑕疵是所选的缺陷检测操作类型，“检测尺寸”参数必须被设置为所检测到的最大瑕疵值。
已关闭 显示图像

定义了所需显示的图像（输入图像、取样图像、瑕疵候选或瑕疵图像；默认＝瑕疵图像）。

  • 输入图像：显示当前采集的图像。
  • 取样图像：显示经过平滑和取样的图像。如果一个有角度或弯曲的区域被用来作为输入区域，除了显示平滑和取样的效果，还会显示变换和拉直过的版本。
  • 瑕疵候选：显示可能的瑕疵。可能的瑕疵会以与背景对比的方式显示。
  • 瑕疵图像：显示瑕疵。瑕疵会以白色显示，而所有其它区域会以黑色显示。该显示选项包括在外部的瑕疵以及被定义过的瑕疵（最小瑕疵区域和最大瑕疵区域）。
注意:该图像仅限于显示，不能被用作其它功能的输入图像。
已关闭 取样因子

定义需要取样的输入图像数量　(1 至 99999; 默认值 = 1)，以降低分辨率。“取样”被用来减少工具运行的时间，但含有较低的精确度。当确定合适的取样值时，数值 1 表明“不取样”。例如，该输入图像会以原来的分辨率被使用。高数值表明低清晰度和低分辨率，但是操作时间会比较快。

已关闭 自动平滑

定义函数是否会为平滑图像确定最佳的平滑因子 (默认 = 关闭)。允许函数选择最佳的平滑因子通常会使操作表现更好。

注意:默认情况下，自动平滑参数为禁用。如需激活该参数，取样因子的参数必须被设置成大于 1 的值。如果取样因子的参数被设置为一个大于1的值且不需要使用自动平滑，可以禁用该参数并设置相应的“平滑因子”参数值。
已关闭 平滑因子

定义平滑图像的平滑值 (0 至 99999; 默认 = 0)。当确定最佳平滑值时，从在“取样因子”参数中设置的相似的值开始。如不需要平滑图像，则可将该值设置为 0。

注意:如果“自动平滑”参数已被激活，则该参数将会被禁用。如果自动平滑参数被激活，可以将“取样因子”参数设置为任何大于 1 的值，然后禁用“自动平滑”参数。然后就可以增加平滑因子参数的值。
已关闭 检测轴

定义检测可能出现瑕疵的轴 (X、Y、 以及 X 和 Y; 默认 = X 和 Y)。

已关闭 检测区域大小

定义检测区域的大小 (1 至 99999; 默认 = 1)，以像素为单位。该参数被用来建立“瑕疵检测操作”参数的相邻执行区域或核心区域。对于除了快速之外的所有的“瑕疵检测操作”，该区域尺寸必须至少大于可能被检测到瑕疵的长度和宽度。

已关闭 最小瑕疵对比度

定义用于检测瑕疵的强度阈值（1 到 255，默认值= 20）。对于一个可能被检测到的缺陷，其强度必须与背景中得到的值有所差别。

已关闭 最小瑕疵区域

定义检测瑕疵的最小区域值 (1 至 99999; 默认值 = 30)，以像素为单位。

注意:即使作业在设置图像步骤中被设置为使用实际测量单位校准，但该值将一直以像素为单位。
已关闭 最大瑕疵面积

定义检测瑕疵的最大区域值 (1 至 99999; 默认值 = 99999)，以像素为单位。

注意:即使作业在设置图像步骤中被设置为使用实际测量单位校准，但该值将一直以像素为单位。
已关闭 超时

定义工具搜索瑕疵的时间，以毫秒为单位(0 至 30,000; 默认 = 5000)。超过该设定时间，操作会自动停止并返回错误信息。

已关闭 瑕疵总数

显示检测到的瑕疵的总数。


表面缺陷缺陷检测工具 - 统计、缺陷和复合区域选项卡

已关闭 统计选项卡

统计选项卡显示有关缺陷总数及其累积大小的数据。

已关闭 缺陷选项卡

缺陷选项卡中的表格报告了前 10 个检测到的缺陷，按区域排序，从最大到最小。该表格显示图像中的缺陷位置（X / Y坐标）、面积、周长、圆度和强度。

已关闭 复合区域选项卡

复合区域选项卡用于配置复合区域，即添加到区域（该区域将被包含在图像分析中）或从区域中去除（该区域将从图像分析中排除；也被称为掩膜）的子区域（矩形、环形、圆形或多边形）。

注意:
  • 最多 32 个子区域可用于构建复合区域。
  • 在与图像中的区域交互时，可使用右击菜单。该操作允许您更改所选子区域的形状、添加或删除子区域或更改所选子区域的操作（添加或去除）。
已关闭 组合区域表

显示组成组合区域的子区域的类型，及其操作（添加或去除）。选择子区域以启用删除、上移或下移按钮。按删除按钮从列表中删除所选的子区域; 按上移按钮在列表中向上移动所选子区域；按下移按钮在列表中向下移动所选子区域。

注意:

组合区域是基于其在列表中的子区域序列构建的。通过以特定顺序放置子区域及其添加或去除操作，可以突出显示图像的某部分而忽略其他区域。下图显示了如何正确排列子区域以排除图像的一部分并同时关注其他区域。在第一组中，配置具有添加操作的矩形，然后在中间设置要进行去除操作的圆。然后，在圆的中间配置要进行添加操作的较小矩形。圆的区域排除了图像的一部分，而较小的矩形区域则将图像一部分添加回图像分析。在第二组中，在添加圆之前添加较小的矩形，并且圆的区域遮盖住较小的矩形区域，将其从图像分析中排除。

已关闭 形状

显示所选子区域的形状（矩形、圆形、环形或多边形）。要更改形状，请从下拉菜单中选择所需的区域类型。

已关闭 操作

在区域内指定所选子区域的操作：添加或去除。添加表示子区域将包括在图像分析中，而去除则表示子区域将从图像分析中排除（也称为“遮掩”）。

已关闭 矩形

将矩形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 环形

将环形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 圆

将圆形子区域插入组合区域。根据需要配置区域的形状和大小。

已关闭 多边形

将多边形子区域插入组合区域。根据需要配置区域的形状和大小。


缺陷检测工具 - 边缘

边缘对缺陷检测工具使用边缘分析卡尺数组精确定位边缘特征，构造最佳拟合线或圆。识别出边缘后，该工具通过边缘特征构造最佳拟合线或圆（取决于边缘特征中是否有曲线），确定边缘中是否存在偏差（如缺陷或间距），并报告遇到的缺陷和/或间距的数量。

注意:
  • 该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
  • 无论工具是否校准到实际单位，所有输入值均以像素为单位。

在想要确保部件或对象的所有边缘特征都没有偏差（如缺陷或间距）时，边缘缺陷检测工具非常有用。例如，确定部件/对象的外侧是否保持相同的形状，并没有任何小的凹痕或裂口。

设置工具

调整工具参数


设置边缘缺陷检测工具

添加该工具之后，需要在图像中配置遮蔽区域，使其位于想要检查的边缘特征之上：

  1. 对边缘特征图像内的区域进行定位和配置。定位区域时，请确保边缘与区域的搜索方向平行，并且区域包含尽可能多的边缘特征，同时排除区域中不必要或不想要的噪音。

    注意: 遮蔽区域内的黄色虚线定义该区域内将检测到边缘转换的范围。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 确认区域后，选择边缘、边缘评分、拟合、缺陷和间距等各个选项卡，并根据需要调整参数和区域，以确保工具将检测正确的边缘候选项并且创建正确的最佳拟合线或圆。初始设置工具时，使用包含理想边缘特征的图像。之后，后续图像采集将包含边缘候选项，将对这些边缘候选项进行检查，以确定是否存在缺陷或间距等偏差。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的范围和偏差。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整边缘缺陷检测工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

边缘缺陷检测工具的设置窗格包含以下选项卡：

  • 常规选项卡
  • 边选项卡
  • 边缘评分选项卡
  • 拟合选项卡
  • 缺陷选项卡
  • 间距选项卡
  • 缺陷和间距表选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

边缘选项卡

边缘得分选项卡

匹配选项卡

缺陷选项卡

间隙选项卡

缺陷和间隙表格选项卡


边缘缺陷检测工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“EdgeDefect_1”（如果该工具是添加到作业的第一个边缘缺陷检测工具，之后名称将递增，如“EdgeDefect_2”、“EdgeDefect_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


边缘缺陷检测工具 - 边缘选项卡

选择边缘选项卡后，该工具将以暗绿色轮廓显示区域内所有检测到的边缘。您可以根据需要调整卡尺尺寸、卡尺间距、边缘宽度和最小对比度参数，以隔离所需边缘。

也可通过启用显示所有卡尺参数来查看所有卡尺。

在此选项卡中也可以选择和调整区域。

已关闭 卡尺尺寸

定义将沿着检测方向进行分析的每个卡尺的像素数量（1 - 639；默认值 = 5）。

已关闭 卡尺间距

以像素为单位，定义在一个卡尺末尾与下一个卡尺起点间的距离（-1 - 639；默认值 = 0）。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 10；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 最小对比度

定义将被认定为边缘的最小灰度对比度转换（1 - 255；默认值 = 10）。

已关闭 卡尺计数

显示区域内卡尺的总数。

已关闭 卡尺索引

定义要隔离和显示的各个卡尺。

已关闭 显示所有卡尺

定义是否总是显示区域内的所有卡尺；默认情况下，卡尺为隐藏状态。


边缘缺陷检测工具 - 边缘评分选项卡

选择边缘评分选项卡后，该工具将显示区域（可以选择和调整）中所有检测到的边缘候选项（以带有颜色编码的小圆圈标示）以及最佳拟合线或园结果。边缘候选项表示构造最佳拟合线或圆时可能会考虑的边缘；调整参数可隔离所需边缘候选项。

如检测到任何缺陷和间距，也会一并显示。

已关闭 查找边缘方向

定义相对于区域工具尝试检测边缘的方向（“左到右”或“右到左”；默认值 =“左到右”）。

已关闭 边缘转换

定义边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 规则：第一条边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑第一个检测到的边缘（默认情况下启用此设置）。

已关闭 规则：最强边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑具有最强对比度转换的边缘（默认情况下启用此设置）。

已关闭 得分阈值

定义评分阀值，将分数（0 - 255；默认值 = 10）低于这个值的边缘过滤掉。


珠体跟踪器缺陷检测工具 - 拟合选项卡

选择拟合选项卡后，该工具将显示在区域中找到的所有边缘候选项以及最佳拟合圆或线结果。边缘候选项表示构造最佳拟合圆或线时可能会考虑的边缘，边缘候选项由带颜色编码的小圆圈来标示。

在此选项卡中也可以选择和调整区域。

已关闭 过滤异常值

定义该工具是否将从最佳拟合线中删除超出“拟合距离过滤器”参数所定义距离的点（默认情况下，已启用此参数）。

已关闭 拟合距离过滤器

以像素定义边缘距重新拟合计算中所使用的原始最佳拟合线的距离（1 - 1920；默认值 = 2）。这一参数有助于防止缺陷对线拟合造成影响。

注意:必须选中（启用）“过滤异常值”参数才能使用此参数。
已关闭 最远点过滤距离

定义一旦超出后，将不使用边缘确定最小和最大距离的异常值距离（1 - 1920；默认值 = 1000）；大于这个值的所有边缘均将被忽略。

已关闭 重新评分

定义是否会对检测到的边缘重新评分，以确保能够正确过滤检测到的原本被丢弃的边缘（默认情况下启用此参数）。

已关闭 重新拟合

定义边缘重新评分后该工具是否将重新拟合最佳拟合线（默认情况下启用此参数）。

注意:启用此参数后该工具的精确度会更高，但它会增加处理时间。


边缘缺陷检测工具 - 缺陷选项卡

选择缺陷选项卡后，该工具将显示最佳拟合圆或线结果以及所有检测到的缺陷或间距。“缺陷”由相对于最佳拟合线或圆的边缘偏差表示。

在此选项卡中也可以选择和调整区域。

已关闭 最小距离

以像素为单位，指定只要与边缘和最佳拟合线或圆之间的距离小于这个值（0.001 - 1920；默认值 = 4），则不将其视为缺陷。

已关闭 最大距离

以像素为单位，指定只要与边缘和最佳拟合线或圆之间的距离大于这个值（0.001 - 1920；默认值 = 1000），则不将其视为缺陷。

已关闭 已启用尺寸

定义该工具是否考虑尺寸缺陷（考虑边缘的长度），默认情况下启用此参数。

注意:在已启用尺寸和已启用面积均为开时，则仅显示同时不满足这两个条件的缺陷。
已关闭 最小尺寸

以像素为单位定义最小缺陷尺寸（0.001 - 1920；默认值 = 10），与最佳拟合线或圆之间距离小于这一值的连续偏差不会被认定为缺陷。

已关闭 最大尺寸

以像素为单位定义最大缺陷尺寸（0.001 - 1920；默认值 = 1000），与最佳拟合线或圆之间距离大于这一值的连续偏差不会被认定为缺陷。

已关闭 已启用面积

定义该工具是否考虑面积缺陷；默认情况下，禁用此参数。面积缺陷取决于最佳拟合线或圆的长度以及缺陷边缘与最佳拟合线或圆之间的距离。

注意:在已启用尺寸和已启用面积均为开时，则仅显示同时不满足这两个条件的缺陷。
已关闭 最小面积

以像素为单位定义最小面积缺陷（0.001 - 1000000；默认值 = 10），小于这一默认值的面积将不会被认定为缺陷。

已关闭 最大面积

以像素为单位定义最大面积缺陷（0.001 - 1000000；默认值 = 1000000），大于这一默认值的面积将不会被认定为缺陷。

已关闭 缺陷过滤器

定义是否基于缺陷的位置筛选缺陷，该位置相对于线拟合（没有过滤器、忽略线拟合左侧、忽略线拟合右侧，默认值 = 无过滤器）。


边缘缺陷检测工具 - 间距选项卡

选择间距选项卡后，该工具将显示最佳拟合圆或线结果以及所有检测到的缺陷或间距。“间距”以相对于最佳拟合线或圆的边缘偏差表示。

在此选项卡中也可以选择和调整区域。

已关闭 查找间距

定义该工具是否考虑所找到边缘中的间距；默认情况下，禁用此参数。

已关闭 最小间距

以像素为单位定义最小间距（0.001 - 1920；默认值 = 3）；小于这个值的间距不会被认定为间距。

已关闭 最大间距

以像素为单位定义最大间距（0.001 - 1920；默认值 = 1000）；大于这个值的间距不会被认定为间距。

已关闭 忽略端点间距

定义工具是否考虑在区域开端和结尾处检测到的间距；默认情况下禁用此参数。

已关闭 结果

显示检测到的缺陷和/或间距的总数。


边缘缺陷检测工具 - 缺陷和间距表格选项卡

缺陷和间距表选项卡报告检测到的前 10 个缺陷/间距，按边缘的位置排序。

已关闭 索引

表示检测到的缺陷/间距的顺序；按边缘的位置排序；1 至 10（EasyBuilder 中的数字排序基于 0=1）。

已关闭 X

返回缺陷/间距界限矩形的 X 坐标（针对选择“校准单位”并且已在设置图像步骤中校准图像的情况，否则将以像素值进行报告）。

已关闭 Y

返回缺陷/间距界限矩形的 Y 坐标（针对选择“校准单位”并且已在设置图像步骤中校准图像的情况，否则将以像素值进行报告）。

已关闭 面积

返回缺陷/间距界限矩形的面积。

已关闭 尺寸

返回边缘处缺陷/间距的尺寸（长度）。

已关闭 卡尺

返回缺陷/间距跨越的卡尺范围。

已关闭 校准单位/像素

定义表是否以实际坐标（校准单位）或像素（像素）显示结果。

注意:该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。


缺陷检测工具 - 边缘对

边缘对缺陷检测工具使用边缘分析卡尺数组精确定位边缘特征，构造一对最佳拟合线或圆。识别出边缘后，该工具通过边缘特征构造一对最佳拟合线或圆（取决于边缘特征中是否有曲线），确定边缘中是否存在偏差（如缺陷或间距），并报告遇到的缺陷和/或间距的数量。

注意:
  • 该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
  • 无论工具是否校准到实际单位，所有输入值均以像素为单位。

在想要确保部件或对象的所有边缘特征都没有偏差（如缺陷或间距）时，边缘对缺陷检测工具非常有用。例如，确定部件/对象的边缘是否保持其形状，以及边缘中是否有任何凹痕或裂口。

设置工具

调整工具参数


设置边缘对缺陷检测工具

添加该工具之后，需要在图像中配置遮蔽区域，使其位于想要检查的边缘特征之上：

  1. 对边缘特征图像内的区域进行定位和配置。定位区域时，请确保边缘与区域的搜索方向平行，并且区域包含尽可能多的边缘特征，同时排除区域中不必要或不想要的噪音。

    注意: 遮蔽区域内的黄色虚线定义该区域内将检测到边缘转换的范围。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 确认区域后，选择边缘、边缘评分、拟合、缺陷和间距等各个选项卡，并根据需要调整参数和区域，以确保工具将检测正确的边缘候选项并且创建正确的最佳拟合线或圆。初始设置工具时，使用包含理想边缘特征的图像。之后，后续图像采集将包含边缘候选项，将对这些边缘候选项进行检查，以确定是否存在缺陷或间距等偏差。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的范围和偏差。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整边缘对缺陷检测工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

边缘对缺陷检测工具的设置窗格包含以下选项卡：

  • 常规选项卡
  • 边选项卡
  • 边缘评分选项卡
  • 拟合选项卡
  • 缺陷选项卡
  • 间距选项卡
  • 边缘 0 缺陷、边缘 1 缺陷和间距表选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

边缘选项卡

边缘得分选项卡

匹配选项卡

缺陷选项卡

间隙选项卡

边缘 0 缺陷、边缘 1 缺陷和间隙表格选项卡


边缘对缺陷检测工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“EdgePairDefect_1”（如果该工具是添加到作业的第一个边缘对缺陷检测工具，之后名称将递增，如“EdgePairDefect_2”、“EdgePairDefect_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


边缘对缺陷检测工具 - 边缘选项卡

选择边缘选项卡后，该工具将以暗绿色轮廓显示区域内所有检测到的边缘。您可以根据需要调整卡尺尺寸、卡尺间距、边缘宽度和最小对比度参数，以隔离所需边缘。

也可通过启用显示所有卡尺参数来查看所有卡尺。

在此选项卡中也可以选择和调整区域。

已关闭 卡尺尺寸

定义将沿着检测方向进行分析的每个卡尺的像素数量（1 - 639；默认值 = 5）。

已关闭 卡尺间距

以像素为单位，定义在一个卡尺末尾与下一个卡尺起点间的距离（-1 - 639；默认值 = 0）。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 10；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 最小对比度

定义将被认定为边缘的最小灰度对比度转换（1 - 255；默认值 = 10）。

已关闭 卡尺计数

显示区域内卡尺的总数。

已关闭 卡尺索引

定义要隔离和显示的各个卡尺。

已关闭 显示所有卡尺

定义是否总是显示区域内的所有卡尺；默认情况下，卡尺为隐藏状态。


边缘对缺陷检测工具 - 边缘评分选项卡

选择边缘评分选项卡后，该工具将显示区域（可以选择和调整）中所有检测到的边缘候选项（以带有颜色编码的小圆圈标示）以及最佳拟合线或园结果。边缘候选项表示构造最佳拟合线或圆时可能会考虑的边缘；调整参数可隔离所需边缘候选项。

如检测到任何缺陷和间距，也会一并显示。

已关闭 查找边缘方向

定义相对于区域工具尝试检测边缘的方向（“左到右”、“右到左”、“中心向外”或“由外向内”；默认值 =“左到右”）。

已关闭 Edge0 转换

定义第一个检测边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 Edge1 转换

定义第二个检测边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 规则：第一条边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑第一个检测到的边缘（默认情况下启用此设置）。

已关闭 规则：最强边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑具有最强对比度转换的边缘（默认情况下启用此设置）。

已关闭 规则：对尺寸

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑检测到的尺寸最接近“对尺寸”参数的边缘对（默认情况下禁用此设置）。

已关闭 对尺寸

定义达到最高分的边缘对尺寸（1 - 1920；默认值 = 5）。启用这一参数后，检测到大于或小于这个值的边缘对时会根据这个值按比例记分。例如，如果将“对尺寸”设置为 10，检测到两个边缘对候选项，值分别为 8 和 14，那么将选择值为 8 的边缘对，因为它比第二个边缘对更接近限定值。规则：对尺寸参数必须为“开”状态才能启用这一参数。

已关闭 得分阈值

定义评分阀值，将分数（0 - 255；默认值 = 10）低于这个值的边缘过滤掉。


边缘对缺陷检测工具 - 拟合选项卡

选择拟合选项卡后，该工具将显示在区域中找到的所有边缘候选项以及最佳拟合圆或线结果。边缘候选项表示构造最佳拟合圆或线时可能会考虑的边缘，边缘候选项由带颜色编码的小圆圈来标示。

在此选项卡中也可以选择和调整区域。

已关闭 过滤异常值

定义该工具是否将从最佳拟合线中删除超出“拟合距离过滤器”参数所定义距离的点（默认情况下，已启用此参数）。

已关闭 拟合距离过滤器

以像素定义边缘距重新拟合计算中所使用的原始最佳拟合线的距离（1 - 1920；默认值 = 2）。这一参数有助于防止缺陷对线拟合造成影响。

注意:必须选中（启用）“过滤异常值”参数才能使用此参数。
已关闭 最远点过滤距离

定义一旦超出后，将不使用边缘确定最小和最大距离的异常值距离（1 - 1920；默认值 = 1000）；大于这个值的所有边缘均将被忽略。

已关闭 重新评分

定义是否会对检测到的边缘重新评分，以确保能够正确过滤检测到的原本被丢弃的边缘（默认情况下启用此参数）。

已关闭 重新拟合

定义边缘重新评分后该工具是否将重新拟合最佳拟合线（默认情况下启用此参数）。

注意:启用此参数后该工具的精确度会更高，但它会增加处理时间。


边缘对缺陷检测工具 - 缺陷选项卡

选择缺陷选项卡后，该工具将显示最佳拟合圆或线结果以及所有检测到的缺陷或间距。“缺陷”由相对于最佳拟合线或圆的边缘偏差表示。

在此选项卡中也可以选择和调整区域。

已关闭 最小距离

以像素为单位，指定只要与边缘和最佳拟合线或圆之间的距离小于这个值（0.001 - 1920；默认值 = 4），则不将其视为缺陷。

已关闭 最大距离

以像素为单位，指定只要与边缘和最佳拟合线或圆之间的距离大于这个值（0.001 - 1920；默认值 = 1000），则不将其视为缺陷。

已关闭 已启用尺寸

定义该工具是否考虑尺寸缺陷（考虑边缘的长度），默认情况下启用此参数。

注意:在已启用尺寸和已启用面积均为开时，则仅显示同时不满足这两个条件的缺陷。
已关闭 最小尺寸

以像素为单位定义最小缺陷尺寸（0.001 - 1920；默认值 = 10），与最佳拟合线或圆之间距离小于这一值的连续偏差不会被认定为缺陷。

已关闭 最大尺寸

以像素为单位定义最大缺陷尺寸（0.001 - 1920；默认值 = 1000），与最佳拟合线或圆之间距离大于这一值的连续偏差不会被认定为缺陷。

已关闭 已启用面积

定义该工具是否考虑面积缺陷；默认情况下，禁用此参数。面积缺陷取决于最佳拟合线或圆的长度以及缺陷边缘与最佳拟合线或圆之间的距离。

注意:在已启用尺寸和已启用面积均为开时，则仅显示同时不满足这两个条件的缺陷。
已关闭 最小面积

以像素为单位定义最小面积缺陷（0.001 - 1000000；默认值 = 10），小于这一默认值的面积将不会被认定为缺陷。

已关闭 最大面积

以像素为单位定义最大面积缺陷（0.001 - 1000000；默认值 = 1000000），大于这一默认值的面积将不会被认定为缺陷。

已关闭 缺陷过滤器

定义是否基于缺陷的位置筛选缺陷，该位置相对于线拟合（没有过滤器、忽略线拟合左侧、忽略线拟合右侧，默认值 = 无过滤器）。


边缘对缺陷检测工具 - 间距选项卡

选择间距选项卡后，该工具将显示最佳拟合圆或线结果以及所有检测到的缺陷或间距。“间距”以相对于最佳拟合线或圆的边缘偏差表示。

在此选项卡中也可以选择和调整区域。

已关闭 查找间距

定义该工具是否考虑所找到边缘中的间距；默认情况下，禁用此参数。

已关闭 最小间距

以像素为单位定义最小间距（0.001 - 1920；默认值 = 3）；小于这个值的间距不会被认定为间距。

已关闭 最大间距

以像素为单位定义最大间距（0.001 - 1920；默认值 = 1000）；大于这个值的间距不会被认定为间距。

已关闭 忽略端点间距

定义工具是否考虑在区域开端和结尾处检测到的间距；默认情况下禁用此参数。

已关闭 结果

显示检测到的缺陷和/或间距的总数。


边缘对缺陷检测工具 - 边缘 0 缺陷、边缘 1 缺陷和间距表选项卡

边缘0缺陷、边缘1缺陷 和 间距 表选项卡报告前10个检测到的缺陷/间距，并按照距离边缘的位置来排序。边缘0 表示边缘对中第一个被检测到的边缘，边缘1 则表示第二个被检测到的边缘。

已关闭 索引

表示检测到的缺陷/间距的顺序；按边缘的位置排序；1 至 10（EasyBuilder 中的数字排序基于 0=1）。

已关闭 X

返回缺陷/间距界限矩形的 X 坐标（针对选择“校准单位”并且已在设置图像步骤中校准图像的情况，否则将以像素值进行报告）。

已关闭 Y

返回缺陷/间距界限矩形的 Y 坐标（针对选择“校准单位”并且已在设置图像步骤中校准图像的情况，否则将以像素值进行报告）。

已关闭 面积

返回缺陷/间距界限矩形的面积。

已关闭 尺寸

返回边缘处缺陷/间距的尺寸（长度）。

已关闭 卡尺

返回缺陷/间距跨越的卡尺范围。

已关闭 校准单位/像素

定义表是否以实际坐标（校准单位）或像素（像素）显示结果。

注意:该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。


缺陷检测工具 - 边缘宽度

边缘宽度缺陷检测工具测量并验证边缘对的厚度是否在公差范围内。该工具使用边缘分析卡尺数组精确定位边缘特征，以确定边缘中是否有偏差（如缺陷或间距），并报告遇到的缺陷和/或间距的数量。

注意:
  • 该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
  • 无论工具是否校准到实际单位，所有输入值均以像素为单位。

在想要确保部件或对象的所有边缘特征都没有偏差（如缺陷或间距）时，边缘宽度缺陷检测工具非常有用。例如，确定焊缝是否每一次都保持适当的宽度。

设置工具

调整工具参数


设置边缘宽度缺陷检测工具

添加该工具之后，需要选择区域类型，然后在图像中进行配置，使其位于想要检查的边缘特征之上：

  1. 从区域类型下拉菜单中选择区域：遮蔽区域或折线路径。对边缘特征图像内的区域进行定位和配置。定位区域时，请确保边缘与区域的搜索方向平行，并且区域包含尽可能多的边缘特征，同时排除区域中不必要或不想要的噪音。

    注意: 遮蔽区域内的黄色虚线定义该区域内将检测到边缘转换的范围。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 确认区域后，选择边缘、边缘评分、异常值、缺陷和间距等各个选项卡，并根据需要调整参数和区域，确保该工具将检测正确的边缘候选项。初始设置工具时，使用包含理想边缘特征的图像。之后，后续图像采集将包含边缘候选项，将对这些边缘候选项进行检查，以确定是否存在缺陷或间距等偏差。

    注意:如果启用异常值选项卡的重新评分参数，该工具将创建一个最佳拟合线或圆。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的范围和偏差。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整边缘宽度缺陷检测工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

边缘宽度缺陷检测工具的设置窗格包含以下选项卡：

  • 常规选项卡
  • 边缘选项卡
  • 边缘评分选项卡
  • 异常值选项卡
  • 缺陷选项卡
  • 间距选项卡
  • 宽度缺陷和间距表选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

边缘选项卡

边缘得分选项卡

离群值选项卡

缺陷选项卡

间隙选项卡

边缘宽度和间隙表格选项卡


边宽度缺陷检测工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“EdgeWidth_1”（如果该工具是添加到作业的第一个边宽度缺陷检测工具，之后名称将递增，如“EdgeWidth_2”、“EdgeWidth_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 区域类型

定义工具用来检测边缘特征的区域类型（屏蔽区域或多线段路径；默认=掩蔽区域）。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


边缘宽度缺陷检测工具 - 边缘选项卡

选择边缘选项卡后，该工具将以暗绿色轮廓显示区域内所有检测到的边缘。您可以根据需要调整卡尺尺寸、卡尺间距、边缘宽度和最小对比度参数，以隔离所需边缘。

也可通过启用显示所有卡尺参数来查看所有卡尺。

在此选项卡中也可以选择和调整区域。

已关闭 卡尺尺寸

定义将沿着检测方向进行分析的每个卡尺的像素数量（1 - 639；默认值 = 5）。

已关闭 卡尺间距

以像素为单位，定义在一个卡尺末尾与下一个卡尺起点间的距离（-1 - 639；默认值 = 0）。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 10；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 最小对比度

定义将被认定为边缘的最小灰度对比度转换（1 - 255；默认值 = 10）。

已关闭 卡尺计数

显示区域内卡尺的总数。

已关闭 卡尺索引

定义要隔离和显示的各个卡尺。

已关闭 显示所有卡尺

定义是否总是显示区域内的所有卡尺；默认情况下，卡尺为隐藏状态。


边缘宽度缺陷检测工具 - 边缘评分选项卡

选择边缘评分选项卡后，该工具将显示在区域（可以选择和调整该区域）中找到的所有边缘候选项，由带颜色编码的小圆圈来标示。调整参数以隔离所需的边缘候选项。

注意:如果启用异常值选项卡的重新评分参数，该工具将创建一个最佳拟合线或圆。

还将显示所有检测到的缺陷和间距以及边缘的最小和最大宽度，这些都由黄色线表示。

已关闭 查找边缘方向

定义相对于区域工具尝试检测边缘的方向（“左到右”、“右到左”、“中心向外”或“由外向内”；默认值 =“左到右”）。

已关闭 Edge0 转换

定义第一个检测边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 Edge1 转换

定义第二个检测边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 规则：第一条边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑第一个检测到的边缘（默认情况下启用此设置）。

已关闭 规则：最强边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑具有最强对比度转换的边缘（默认情况下启用此设置）。

已关闭 对比度上限

定义将被认定为边缘的边缘对比度转换的上限（2 - 255；默认值 = 255）；边缘对比度转换超过此上限值的边缘将具有相同的最高分数。

已关闭 规则：对尺寸

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑检测到的尺寸最接近“对尺寸”参数的边缘对（默认情况下禁用此设置）。

已关闭 对尺寸

定义达到最高分的边缘对尺寸（1 - 1920；默认值 = 5）。启用这一参数后，检测到大于或小于这个值的边缘对时会根据这个值按比例记分。例如，如果将“对尺寸”设置为 10，检测到两个边缘对候选项，值分别为 8 和 14，那么将选择值为 8 的边缘对，因为它比第二个边缘对更接近限定值。规则：对尺寸参数必须为“开”状态才能启用这一参数。

已关闭 得分阈值

定义评分阀值，将分数（0 - 255；默认值 = 10）低于这个值的边缘过滤掉。


边缘宽度缺陷检测工具 - 异常值选项卡

选择异常值选项卡后，该工具将显示在区域中找到的所有边缘候选项以及最佳拟合线或圆结果。边缘候选项表示构造最佳拟合线或圆时可能会考虑的边缘，边缘候选项由带颜色编码的小圆圈来标示。

在此选项卡中也可以选择和调整区域。

还将显示所有检测到的缺陷和间距以及边缘的最小和最大宽度，这些都由黄色线表示。

已关闭 重新评分

定义边缘重新评分后该工具是否将重新拟合最佳拟合线（默认情况下，已禁用此参数）。

注意:启用此参数后该工具的精确度会更高，但它会增加处理时间。
已关闭 线拟合

定义要用检测到的边缘构造的最佳拟合线的类型（自动调整、直线拟合或曲线拟合；默认情况下为自动调整）。

注意:必须选中（启用）“重新评分”参数才能使用此参数。
已关闭 过滤异常值

定义该工具是否将从最佳拟合线中删除超出“拟合距离过滤器”参数所定义距离的点（默认情况下，已禁用此参数）。

已关闭 拟合距离过滤器

以像素定义边缘距重新拟合计算中所使用的原始最佳拟合线的距离（1 - 1920；默认值 = 2）。这一参数有助于防止缺陷对线拟合造成影响。

注意:必须选中（启用）“过滤异常值”参数才能使用此参数。


边缘宽度缺陷检测工具 - 缺陷选项卡

选择缺陷选项卡后，该工具将（使用黄色线）显示检测到的边缘对的最小和最大厚度以及检测到的所有缺陷或间距。

在此选项卡中也可以选择和调整区域。

已关闭 最小宽度

以像素为单位，指定只要检测到的边缘对之间的宽度距离小于这个值（0.001 - 1920；默认值 = 3），则不将其视为缺陷。

已关闭 最大宽度

以像素为单位，指定只要检测到的边缘对之间的宽度距离大于这个值（0.001 - 1920；默认值 = 1000），则不将其视为缺陷。

已关闭 已启用尺寸

定义该工具是否考虑尺寸缺陷（考虑边缘的长度），默认情况下启用此参数。

注意:在已启用尺寸和已启用面积均为开时，则仅显示同时不满足这两个条件的缺陷。
已关闭 最小尺寸

以像素为单位定义最小缺陷尺寸（0.001 - 1920；默认值 = 10），与最佳拟合线或圆之间距离小于这一值的连续偏差不会被认定为缺陷。

已关闭 最大尺寸

以像素为单位定义最大缺陷尺寸（0.001 - 1920；默认值 = 1000），与最佳拟合线或圆之间距离大于这一值的连续偏差不会被认定为缺陷。

已关闭 已启用面积

定义该工具是否考虑面积缺陷；默认情况下，禁用此参数。面积缺陷取决于最佳拟合线或圆的长度以及缺陷边缘与最佳拟合线或圆之间的距离。

注意:在已启用尺寸和已启用面积均为开时，则仅显示同时不满足这两个条件的缺陷。
已关闭 最小面积

以像素为单位定义最小面积缺陷（0.001 - 1000000；默认值 = 10），小于这一默认值的面积将不会被认定为缺陷。

已关闭 最大面积

以像素为单位定义最大面积缺陷（0.001 - 1000000；默认值 = 1000000），大于这一默认值的面积将不会被认定为缺陷。


边缘宽度缺陷检测工具 - 间距选项卡

选择间距选项卡后，该工具将显示最佳拟合圆或线结果（如果已启用）以及所有检测到的缺陷或间距。“间距”由相对于最佳拟合线或圆的边缘偏差表示。

在此选项卡中也可以选择和调整区域。

已关闭 查找间距

定义该工具是否考虑所找到边缘中的间距；默认情况下，禁用此参数。

已关闭 最小间距

以像素为单位定义最小间距（0.001 - 1920；默认值 = 3）；小于这个值的间距不会被认定为间距。

已关闭 最大间距

以像素为单位定义最大间距（0.001 - 1920；默认值 = 1000）；大于这个值的间距不会被认定为间距。

已关闭 忽略端点间距

定义工具是否考虑在区域开端和结尾处检测到的间距；默认情况下禁用此参数。

已关闭 结果

显示检测到的缺陷和/或间距的总数。


边缘宽度缺陷检测工具 -　宽度缺陷和间距表选项卡

边缘宽度缺陷 和 间距表选项卡报告前10个检测到的缺陷/间距，并按照距离边缘的位置来排序。

已关闭 索引

表示检测到的缺陷/间距的顺序；按边缘的位置排序；1 至 10（EasyBuilder 中的数字排序基于 0=1）。

已关闭 X

返回缺陷/间距界限矩形的 X 坐标（针对选择“校准单位”并且已在设置图像步骤中校准图像的情况，否则将以像素值进行报告）。

已关闭 Y

返回缺陷/间距界限矩形的 Y 坐标（针对选择“校准单位”并且已在设置图像步骤中校准图像的情况，否则将以像素值进行报告）。

已关闭 面积

返回缺陷/间距界限矩形的面积。

已关闭 尺寸

返回边缘处缺陷/间距的尺寸（长度）。

已关闭 卡尺

返回缺陷/间距跨越的卡尺范围。

已关闭 校准单位/像素

定义表是否以实际坐标（校准单位）或像素（像素）显示结果。

注意:该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。


缺陷检测工具 - 珠体探测器

珠体探测器缺陷检测工具可识别珠体特征（由一对边缘进行定义），不考虑形状，方法是通过检测珠体中心并创建可用于检查珠体宽度的区域。该工具使用边缘分析卡尺数组精确定位边缘特征。识别出珠体特征之后，该工具将绘制珠体图形并报告可分类为缺陷或间距的公差范围以外的任何珠体厚度变化。

注意:
  • 该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
  • 无论工具是否校准到实际单位，所有输入值均以像素为单位。

在想要识别和检验珠体特征（如偶然出现在视野 (FOV) 中的胶粘珠体）的厚度时，珠体探测器缺陷检测工具非常有用。

设置工具

调整工具参数


设置珠体探测器缺陷检测工具

添加该工具之后，需要选择区域类型，然后在图像中进行配置，使其位于想要检查的边缘特征之上：

  1. 从区域类型下拉菜单中选择区域：遮蔽区域或折线路径。对边缘特征图像内的区域进行定位和配置。定位区域时，请确保边缘与区域的搜索方向平行，并且区域包含尽可能多的边缘特征，同时排除区域中不必要或不想要的噪音。

    注意: 遮蔽区域内的黄色虚线定义该区域内将检测到边缘转换的范围。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 确认区域后，选择查找珠体、边缘、边缘评分、缺陷和间距等各个选项卡，然后根据需要调整参数和区域，以确保工具将检测正确的边缘候选项并且创建正确的折线。初始设置工具时，使用包含理想边缘特征的图像。之后，后续图像采集将包含边缘候选项，将对这些边缘候选项进行检查，以确定是否存在缺陷或间距等偏差。
  4. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的范围和偏差。
  5. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整珠体探测器缺陷检测工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

珠体探测器缺陷检测工具的设置窗格包含以下选项卡：

  • 常规选项卡
  • 查找珠体
  • 边缘选项卡
  • 边缘评分选项卡
  • 缺陷选项卡
  • 间距选项卡
  • 统计、宽度缺陷和间距表选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

查找焊珠选项卡

边缘选项卡

边缘得分选项卡

缺陷选项卡

间隙选项卡

统计、宽度缺陷和间隙表格选项卡


查找胶珠瑕疵检测工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“BeadFinder_1”（如果该工具是添加到作业的第一个寻找胶珠缺陷检测工具，之后名称将递增，如“BeadFinder_2”、“BeadFinder_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 区域类型

指定所分析图像面积的区域类型：遮蔽区域（默认）或折线路径。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


珠体探测器缺陷检测工具 - 查找珠体选项卡

选择查找珠体选项卡后，该工具将显示与定位珠体特征有关的图形。该工具将用暗绿色轮廓显示所有检测到的边缘；并显示区域（可以选择和调整）内的选定边缘候选项（以带有颜色编码的小圆圈标示）；并将珠体的位置显示为蓝色折线。

可以调整参数以隔离用于构造折线路径（此折线路径描绘珠体特征的轮廓）的所需边缘和边缘候选项。

已关闭 查找珠体卡尺尺寸

定义将沿着检测方向进行分析的每个卡尺的像素数量，以找到珠体特征（1 - 639；默认值 = 8）。

已关闭 查找珠体卡尺间距

以像素为单位，定义在一个卡尺末尾与下一个卡尺起点间的距离（-1 - 639；默认值 = 0）。

已关闭 查找珠体边缘宽度

定义边缘转换所跨越的像素距离（1 - 10；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 查找珠体最小对比度

定义将被认定为边缘的最小灰度对比度转换（1 - 255；默认值 = 10）。

已关闭 查找珠体边缘方向

定义相对于区域工具尝试检测边缘的方向（“左到右”、“右到左”、“中心向外”或“由外向内”；默认值 =“左到右”）。

已关闭 查找珠体 Edge0 转换

定义第一个检测边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 查找珠体 Edge1 转换

定义第二个检测边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 查找珠体规则：第一条边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑第一个检测到的边缘（默认情况下启用此设置）。

已关闭 查找珠体规则：最强边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑具有最强对比度转换的边缘（默认情况下启用此设置）。

已关闭 查找珠体对比度上限

定义将被认定为边缘的边缘对比度转换的上限（2 - 255；默认值 = 255）；边缘对比度转换超过此上限值的边缘将具有相同的最高分数。

已关闭 查找珠体规则：对大小

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑检测到的尺寸最接近“对尺寸”参数的边缘对（默认情况下禁用此设置）。

已关闭 查找珠体得分阈值

定义评分阀值，将分数（0 - 255；默认值 = 10）低于这个值的边缘过滤掉。

已关闭 查找珠体卡尺

显示区域内卡尺的总数。

已关闭 查找珠体卡尺索引

定义要隔离和显示的各个卡尺。

已关闭 查找珠体显示所有卡尺

定义是否总是显示区域内的所有卡尺；默认情况下，卡尺为隐藏状态。


珠体探测器缺陷检测工具 - 边缘选项卡

选择边缘选项卡后，该工具将以蓝色显示珠体轨迹的位置，以绿色显示所有检测到的边缘，以及以浅绿色显示定义折线路径（从珠体轨迹的位置生成）的卡尺。以浅绿色标示的卡尺只能通过折线宽度参数进行调整。您可以根据需要调整折线宽度、卡尺尺寸、卡尺间距和最小对比度参数，以隔离所需边缘。

已关闭 折线宽度

定义用于定义折线的卡尺宽度（1 - 1920；默认值 = 25）。

已关闭 卡尺尺寸

定义将沿着检测方向进行分析的每个卡尺的像素数量（1 - 639；默认值 = 5）。

已关闭 卡尺间距

以像素为单位，定义在一个卡尺末尾与下一个卡尺起点间的距离（-1 - 639；默认值 = 0）。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 10；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 最小对比度

定义将被认定为边缘的最小灰度对比度转换（1 - 255；默认值 = 10）。

已关闭 卡尺计数

显示区域内卡尺的总数。

已关闭 卡尺索引

定义要隔离和显示的各个卡尺。

已关闭 显示所有卡尺

定义是否总是显示区域内的所有卡尺；默认情况下，卡尺为隐藏状态。


珠体探测器缺陷检测工具 - 边缘评分选项卡

选择边缘评分选项卡后，该工具将显示区域内检测到的所有边缘候选项（以带有颜色编码的小圆圈标示）；检测到的边缘（暗绿色轮廓）；珠体的位置（蓝色折线）；珠体的最小和最大宽度（黄线）；以及任何找到的缺陷或间距。

已关闭 查找边缘方向

定义相对于区域工具尝试检测边缘的方向（“左到右”、“右到左”、“中心向外”或“由外向内”；默认值 =“由外向内”）。

已关闭 Edge0 转换

定义第一个检测边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 Edge1 转换

定义第二个检测边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 规则：第一条边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑第一个检测到的边缘（默认情况下启用此设置）。

已关闭 规则：最强边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑具有最强对比度转换的边缘（默认情况下启用此设置）。

已关闭 对比度上限

定义将被认定为边缘的边缘对比度转换的上限（2 - 255；默认值 = 255）；边缘对比度转换超过此上限值的边缘将具有相同的最高分数。

已关闭 规则：对尺寸

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑检测到的尺寸最接近“对尺寸”参数的边缘对（默认情况下禁用此设置）。

已关闭 对尺寸

定义达到最高分的边缘对尺寸（1 - 1920；默认值 = 5）。启用这一参数后，检测到大于或小于这个值的边缘对时会根据这个值按比例记分。例如，如果将“对尺寸”设置为 10，检测到两个边缘对候选项，值分别为 8 和 14，那么将选择值为 8 的边缘对，因为它比第二个边缘对更接近限定值。规则：对尺寸参数必须为“开”状态才能启用这一参数。

已关闭 得分阈值

定义评分阀值，将分数（0 - 255；默认值 = 10）低于这个值的边缘过滤掉。


珠体探测器缺陷检测工具 - 缺陷选项卡

选择缺陷选项卡后，该工具将显示与识别和/或分类部件或对象中的错误相关的图形。该工具将以蓝色折线显示珠体的位置，以黄线显示珠体的最小和最大厚度，并显示任何检测到的缺陷和/或间距。

已关闭 最小宽度

以像素为单位，指定只要检测到的边缘对之间的宽度距离小于这个值（0.001 - 1920；默认值 = 3），则不将其视为缺陷。

已关闭 最大宽度

以像素为单位，指定只要检测到的边缘对之间的宽度距离大于这个值（0.001 - 1920；默认值 = 1000），则不将其视为缺陷。

已关闭 已启用尺寸

定义该工具是否考虑尺寸缺陷（考虑边缘的长度），默认情况下启用此参数。

注意:在已启用尺寸和已启用面积均为开时，则仅显示同时不满足这两个条件的缺陷。
已关闭 最小尺寸

以像素为单位定义最小缺陷尺寸（0.001 - 1920；默认值 = 3），与折线之间距离小于这一值的连续偏差不会被认定为缺陷。

已关闭 最大尺寸

以像素为单位定义最大缺陷尺寸（0.001 - 1920；默认值 = 1000），与折线之间距离大于这一值的连续偏差不会被认定为缺陷。

已关闭 已启用面积

定义该工具是否考虑面积缺陷；默认情况下，启用此参数。面积缺陷取决于折线长度以及缺陷边缘与折线之间的距离。

注意:在已启用尺寸和已启用面积均为开时，则仅显示同时不满足这两个条件的缺陷。
已关闭 最小面积

以像素为单位定义最小面积缺陷（0.001 - 1000000；默认值 = 10），小于这一默认值的面积将不会被认定为缺陷。

已关闭 最大面积

以像素为单位定义最大面积缺陷（0.001 - 1000000；默认值 = 1000000），大于这一默认值的面积将不会被认定为缺陷。


珠体探测器缺陷检测工具 - 间距选项卡

选择间距选项卡后，该工具将显示与识别和/或分类部件或对象中的错误相关的图形。该工具将以蓝色折线显示珠体的位置，以黄线显示珠体的最小和最大厚度，并显示任何检测到的缺陷和/或间距。

已关闭 查找间距

定义该工具是否考虑所找到边缘中的间距；默认情况下，已禁用此参数。

已关闭 最小间距

以像素为单位定义最小间距（0.001 - 1920；默认值 = 3）；小于这个值的间距不会被认定为间距。

已关闭 最大间距

以像素为单位定义最大间距（0.001 - 1920；默认值 = 1000）；大于这个值的间距不会被认定为间距。

已关闭 忽略端点间距

定义工具是否考虑在区域开端和结尾处检测到的间距；默认情况下禁用此参数。

已关闭 结果

显示检测到的缺陷和/或间距的总数。


珠体探测器缺陷检测工具 - 缺陷和间距表选项卡

统计表选项卡记录工具在一段时间内的运行状况数据。宽度缺陷和间距表选项卡报告前 10 个缺陷/间距。

已关闭 索引

表示检测到的缺陷/间距的顺序；按边缘的位置排序；1 至 10（EasyBuilder 中的数字排序基于 0=1）。

已关闭 X

返回缺陷/间距界限矩形的 X 坐标（针对选择“校准单位”并且已在设置图像步骤中校准图像的情况，否则将以像素值进行报告）。

已关闭 Y

返回缺陷/间距界限矩形的 Y 坐标（针对选择“校准单位”并且已在设置图像步骤中校准图像的情况，否则将以像素值进行报告）。

已关闭 面积

返回缺陷/间距界限矩形的面积。

已关闭 尺寸

返回边缘处缺陷/间距的尺寸（长度）。

已关闭 卡尺

返回缺陷/间距跨越的卡尺范围。

已关闭 校准单位/像素

定义表是否以实际坐标（校准单位）或像素（像素）显示结果。

注意:该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。


缺陷检测工具 - 珠体跟踪

珠体跟踪器缺陷检测工具检测珠体特征（由边缘对定义）的位置、形状和宽度。根据由用户创建的珠体特征边缘模型，该工具使用边缘分析卡尺数组精确定位边缘特征。珠体特征模型创建完毕后，在运行时操作过程中，工具会将采集图像中的珠体特征与珠体模型进行对比，以确定珠体位置是否正确，珠体中是否存在缺陷或间距等偏差，并且对发现的缺陷和/或间距的数量进行报告。

注意:
  • 该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。
  • 无论工具是否校准到实际单位，所有输入值均以像素为单位。

珠体跟踪器缺陷检测工具在希望确保焊接珠体等珠体特征处于相同位置，并且珠体形状或厚度没有变化的情况下非常有用。

设置工具

调整工具参数


设置珠体跟踪缺陷检测工具

添加该工具之后，需要选择区域类型，然后在图像中进行配置，使其位于想要检查的边缘特征之上：

  1. 从区域类型下拉菜单中选择区域：遮蔽区域或折线路径。 对边缘特征图像内的区域进行定位和配置。定位区域时，请确保边缘与区域的搜索方向平行，并且区域包含尽可能多的边缘特征，同时排除区域中不必要或不想要的噪音。初始设置工具时，使用包含理想边缘特征的图像。之后，后续图像采集将包含边缘候选项，将对这些边缘候选项进行检查，以确定是否存在缺陷或间距等偏差。

    注意: 遮蔽区域内的黄色虚线定义该区域内将检测到边缘转换的范围。

  2. 按确定按钮确认区域（按取消按钮则不会将该工具添加到作业）。

  3. 确认区域后，选择训练珠体、边缘、边缘评分、缺陷、间距和位置等各个选项卡，然后根据需要调整参数和区域，以确保工具将检测正确的边缘候选项并且创建正确的折线。
  4. 对区域和参数进行适当调整后，转到训练珠体选项卡，按下训练按钮创建珠体边缘模型。随后，系统将对后续图像采集与经过训练的珠体边缘模型进行对比。
  5. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿预期的范围和偏差。
  6. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整珠体跟踪缺陷检测工具的参数

在设置完工具的区域后，你可以开始优化应用程序工具。

珠体跟踪器缺陷检测工具的设置窗格包含以下选项卡：

  • 常规选项卡
  • 训练珠体
  • 边缘选项卡
  • 边缘评分选项卡
  • 缺陷选项卡
  • 间距选项卡
  • 位置选项卡
  • 统计、宽度缺陷、间距和位置缺陷表选项卡
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

训练焊珠选项卡

边缘选项卡

边缘得分选项卡

缺陷选项卡

位置选项卡

统计、宽度瑕疵、间隙和位置瑕疵表格选项卡

间隙选项卡


胶珠追踪瑕疵检测工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“BeadTracker_1”（如果该工具是添加到作业的第一个胶珠追踪瑕疵检测工具，之后名称将递增，如“BeadTracker_2”、“BeadTracker_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具图像

定义工具执行检测将利用的图像，未经过滤的采集图像（默认设置）还是图像过滤工具或颜色工具（“彩色斑点”和“彩色斑点 (1-10)”定位工具）、“颜色像素计数”和“彩色斑点存在/不存在”工具、“彩色斑点面积”和“彩色斑点面积 (1-10)”测量工具、彩色斑点计数工具、颜色模型识别工具或“颜色转为二进制”图像过滤工具）的输出图像。仅当已添加图像过滤工具或颜色工具时，才会启用此控制。

已关闭 工具定位特征

定义工具的定位特征。只有在已添加了用于定义定位特征的另一个工具时，才启用此控制。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 区域类型

指定所分析图像面积的区域类型：遮蔽区域（默认）或折线路径。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


珠体跟踪缺陷检测工具 - 训练珠体选项卡

选择训练珠体选项卡后，该工具将显示与定位珠体特征有关的图形。该工具将显示区域内所有找到的边缘候选项（以带有颜色编码的小圆圈标示），并会将珠体的位置显示为蓝色折线，也可以对区域进行调整。

已关闭 “训练”按钮

定义珠体边缘模型。训练按钮用于配置珠体边缘模型。配置完工具的参数和区域后，按下训练按钮，以强调珠体边缘模型的相关特征。珠体边缘模型训练完毕后，工具会将采集图像中的珠体特征与经过训练的珠体边缘模型进行对比，以确定是否存在缺陷或间距等偏差。

注意:直至珠体边缘模型训练结束前，工具将一直得到“失败”结果。
已关闭 训练珠体卡尺尺寸

定义将沿着检测方向进行分析的每个卡尺的像素数量，以找到珠体特征（1 - 639；默认值 = 8）。

已关闭 训练珠体卡尺间距

以像素为单位，定义在一个卡尺末尾与下一个卡尺起点间的距离（-1 - 639；默认值 = 0）。

已关闭 训练珠体边缘宽度

定义边缘转换所跨越的像素距离（1 - 10；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 训练珠体最小对比度

定义将被认定为边缘的最小灰度对比度转换（1 - 255；默认值 = 10）。

已关闭 训练珠体边缘方向

定义相对于区域工具尝试检测边缘的方向（“左到右”、“右到左”、“中心向外”或“由外向内”；默认值 =“左到右”）。

已关闭 训练珠体 Edge0 转换

定义第一个检测边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 训练珠体 Edge1 转换

定义第二个检测边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 训练珠体规则：第一条边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑第一个检测到的边缘（默认情况下启用此设置）。

已关闭 训练珠体规则：最强边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑具有最强对比度转换的边缘（默认情况下启用此设置）。

已关闭 训练珠体对比度上限

定义将被认定为边缘的边缘对比度转换的上限（2 - 255；默认值 = 255）；边缘对比度转换超过此上限值的边缘将具有相同的最高分数。

已关闭 训练珠体规则：对尺寸

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑检测到的尺寸最接近“对尺寸”参数的边缘对（默认情况下禁用此设置）。

已关闭 训练珠体得分阈值

定义评分阀值，将分数（0 - 255；默认值 = 10）低于这个值的边缘过滤掉。

已关闭 训练珠体卡尺

显示区域内卡尺的总数。

已关闭 训练珠体卡尺索引

定义要隔离和显示的各个卡尺。

已关闭 训练珠体显示所有卡尺

定义是否总是显示区域内的所有卡尺；默认情况下，卡尺为隐藏状态。


珠体跟踪缺陷检测工具 - 边缘选项卡

选择边缘选项卡后，该工具将以蓝色显示珠体轨迹的位置，以绿色显示所有检测到的边缘，以及以浅绿色显示定义折线路径（从珠体轨迹的位置生成）的卡尺。以浅绿色标示的卡尺只能通过折线宽度参数进行调整。您可以根据需要调整折线宽度、卡尺尺寸、卡尺间距和最小对比度参数，以隔离所需边缘。

已关闭 折线宽度

定义用于定义折线的卡尺的宽度（1 - 1920；默认值 = 25）。

已关闭 卡尺尺寸

定义将沿着检测方向进行分析的每个卡尺的像素数量（1 - 639；默认值 = 5）。

已关闭 卡尺间距

以像素为单位，定义在一个卡尺末尾与下一个卡尺起点间的距离（-1 - 639；默认值 = 0）。

已关闭 边缘宽度

定义边缘转换所跨越的像素距离（1 - 10；默认值 = 3）。这一设置有助于过滤图像噪音。

已关闭 最小对比度

定义将被认定为边缘的最小灰度对比度转换（1 - 255；默认值 = 10）。

已关闭 卡尺计数

显示区域内卡尺的总数。

已关闭 卡尺索引

定义要隔离和显示的各个卡尺。

已关闭 显示所有卡尺

定义是否总是显示区域内的所有卡尺；默认情况下，卡尺为隐藏状态。


珠体跟踪缺陷检测工具 - 边缘评分选项卡

选择边缘评分选项卡后，该工具将显示区域内检测到的所有边缘候选项（以带有颜色编码的小圆圈标示）；检测到的边缘（暗绿色轮廓）；珠体的位置（蓝色折线）；珠体的最小和最大宽度（黄线）；以及任何找到的缺陷或间距。

已关闭 查找边缘方向

定义相对于区域工具尝试检测边缘的方向（“左到右”、“右到左”、“中心向外”或“由外向内”；默认值 =“由外向内”）。

已关闭 Edge0 转换

定义第一个检测边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 Edge1 转换

定义第二个检测边缘的转换（“由深到浅”、“由浅到深”或“二者之一”；默认值 =“二者之一”）。为了增加精确度和速度，可指定转换的类型。

已关闭 规则：第一条边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑第一个检测到的边缘（默认情况下启用此设置）。

已关闭 规则：最强边缘

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑具有最强对比度转换的边缘（默认情况下启用此设置）。

已关闭 对比度上限

定义将被认定为边缘的边缘对比度转换的上限（2 - 255；默认值 = 255）；边缘对比度转换超过此上限值的边缘将具有相同的最高分数。

已关闭 规则：对尺寸

定义在确定边缘候选项是否满足边缘认定标准时，是否会最先考虑检测到的尺寸最接近“对尺寸”参数的边缘对（默认情况下禁用此设置）。

已关闭 对尺寸

定义达到最高分的边缘对尺寸（1 - 1920；默认值 = 5）。启用这一参数后，检测到大于或小于这个值的边缘对时会根据这个值按比例记分。例如，如果将“对尺寸”设置为 10，检测到两个边缘对候选项，值分别为 8 和 14，那么将选择值为 8 的边缘对，因为它比第二个边缘对更接近限定值。规则：对尺寸参数必须为“开”状态才能启用这一参数。

已关闭 得分阈值

定义评分阀值，将分数（0 - 255；默认值 = 10）低于这个值的边缘过滤掉。


珠体跟踪缺陷检测工具 - 缺陷选项卡

选择缺陷选项卡后，该工具将显示与识别和/或分类部件或对象中的错误相关的图形。该工具将以蓝色折线显示珠体的位置，以黄线显示珠体的最小和最大厚度，并显示任何检测到的缺陷和/或间距。

已关闭 最小宽度

以像素为单位，指定只要检测到的边缘对之间的宽度距离小于这个值（0.001 - 1920；默认值 = 3），则不将其视为缺陷。

已关闭 最大宽度

以像素为单位，指定只要检测到的边缘对之间的宽度距离大于这个值（0.001 - 1920；默认值 = 1000），则不将其视为缺陷。

已关闭 已启用尺寸

定义该工具是否考虑尺寸缺陷（考虑边缘的长度），默认情况下启用此参数。

注意:在已启用尺寸和已启用面积均为开时，则仅显示同时不满足这两个条件的缺陷。
已关闭 最小尺寸

以像素为单位定义最小缺陷尺寸（0.001 - 1920；默认值 = 10），与折线之间距离小于这一值的连续偏差不会被认定为缺陷。

已关闭 最大尺寸

以像素为单位定义最大缺陷尺寸（0.001 - 1920；默认值 = 1000），与折线之间距离大于这一值的连续偏差不会被认定为缺陷。

已关闭 已启用面积

定义该工具是否考虑面积缺陷；默认情况下，启用此参数。面积缺陷取决于折线长度以及缺陷边缘与折线之间的距离。

注意:在已启用尺寸和已启用面积均为开时，则仅显示同时不满足这两个条件的缺陷。
已关闭 最小面积

以像素为单位定义最小面积缺陷（0.001 - 1000000；默认值 = 10），小于这一默认值的面积将不会被认定为缺陷。

已关闭 最大面积

以像素为单位定义最大面积缺陷（0.001 - 1000000；默认值 = 1000000），大于这一默认值的面积将不会被认定为缺陷。


珠体跟踪缺陷检测工具 - 位置选项卡

选定位置选项卡后，该工具将显示与识别和/或分类部件或对象中的位置错误相关的图形。该工具将以蓝色折线显示珠体的最后训练位置，以黄线显示珠体的最小和最大厚度，并显示任何检测到的缺陷和/或间距。

已关闭 启用位置缺陷

定义是否考虑位置缺陷（默认情况下，启用此参数）。

已关闭 最小位置缺陷距离

以像素为单位，定义边缘候选项与珠体边缘模型的中心之间，不会被认定为错误的最小距离值（0.001 到 1920；默认值 = 3）。

已关闭 启用位置缺陷尺寸

定义是否还使用尺寸标准定义位置错误（默认情况下启用此参数）。在边缘长度处发现尺寸错误。

注意:在已启用尺寸和已启用面积均为开时，则仅显示同时不满足这两个条件的缺陷。
已关闭 最小位置缺陷尺寸

以像素为单位定义最小缺陷尺寸（0.001 - 1920；默认值 = 3），与折线之间距离小于这一值的连续偏差不会被认定为缺陷。

已关闭 最大位置缺陷尺寸

以像素为单位定义最大缺陷尺寸（0.001 - 1920；默认值 = 1000），与折线之间距离大于这一值的连续偏差不会被认定为缺陷。

已关闭 启用位置缺陷面积

定义该工具是否考虑面积缺陷；默认情况下，启用此参数。面积缺陷取决于折线长度以及缺陷边缘与折线之间的距离。

注意:在已启用尺寸和已启用面积均为开时，则仅显示同时不满足这两个条件的缺陷。
已关闭 最小位置缺陷面积

以像素为单位定义最小面积缺陷（0.001 - 1000000；默认值 = 10），小于这一默认值的面积将不会被认定为缺陷。

已关闭 最大位置缺陷面积

以像素为单位定义最大面积缺陷（0.001 - 1000000；默认值 = 1000000），大于这一默认值的面积将不会被认定为缺陷。

已关闭 结果

显示检测到的缺陷、间距和/或位置错误的总数。


珠体跟踪缺陷检测工具 - 统计、宽度缺陷、间距和位置缺陷表选项卡

统计表选项卡记录工具在一段时间内的运行状况数据。 宽度缺陷、间距和位置缺陷表选项卡报告前 10 个缺陷/间距和位置错误。

已关闭 索引

表示检测到的缺陷/间距的顺序；按边缘的位置排序；1 至 10（EasyBuilder 中的数字排序基于 0=1）。

已关闭 X

返回缺陷/间距界限矩形的 X 坐标（针对选择“校准单位”并且已在设置图像步骤中校准图像的情况，否则将以像素值进行报告）。

已关闭 Y

返回缺陷/间距界限矩形的 Y 坐标（针对选择“校准单位”并且已在设置图像步骤中校准图像的情况，否则将以像素值进行报告）。

已关闭 面积

返回缺陷/间距界限矩形的面积。

已关闭 尺寸

返回边缘处缺陷/间距的尺寸（长度）。

已关闭 卡尺

返回缺陷/间距跨越的卡尺范围。

已关闭 校准单位/像素

定义表是否以实际坐标（校准单位）或像素（像素）显示结果。

注意:该工具会以像素为单位报告结果，除非已在设置图像中为该图像分配了实际的单位。


珠体跟踪缺陷检测工具 - 间距选项卡

选择间距选项卡后，该工具将显示与识别和/或分类部件或对象中的错误相关的图形。该工具将以蓝色折线显示珠体的位置，以黄线显示珠体的最小和最大厚度，并显示任何检测到的缺陷和/或间距。

已关闭 查找间距

定义该工具是否考虑所找到边缘中的间距；默认情况下，禁用此参数。

已关闭 最小间距

以像素为单位定义最小间距（0.001 - 1920；默认值 = 3）；小于这个值的间距不会被认定为间距。

已关闭 最大间距

以像素为单位定义最大间距（0.001 - 1920；默认值 = 1000）；大于这个值的间距不会被认定为间距。

已关闭 忽略端点间距

定义工具是否考虑在区域开端和结尾处检测到的间距；默认情况下禁用此参数。

已关闭 结果

显示检测到的缺陷和/或间距的总数。


校准工具 - 机器人

该工具用于连结视觉工具与机器人校准函数，并将像素坐标转换为机器人位姿，并在EasyBuilder中自动创建校准文件。

设置工具

调整工具参数


设置机器人校准工具

提示:进行校准后，建议保存作业文件。对于后续的校准，可以简单地加载校准作业，采集图像，然后将更新的校准文件导出到所有引用此校准文件的作业。

添加工具后，您需要定义将用于构建校准的输入特征（点，定位特征的原点或圆形特征的中心）：

  1. 在添加工具后，EasyBuilder 将检测图像，并列出自动检测到的智能特征（包括点、定位特征或圆形特征的中心，以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）以供选择。EasyBuilder 将自动为先前未定义的所有圆特征插入“圆存在/不存在”工具。

  2. 通过单击在可选特征选择其中一个特征，此时颜色将更改为洋红色。

  3. 选择特征后，点击OK按钮（按取消按钮则不会将工具添加到作业中）。

  4. 保存作业文件。
  5. 最初配置工具后，可根据需要调整工具的参数。
  6. 最后，如需要可以使用工具的输入/输出属性表来设置与其它工具及外部设备间的数据分享。


调整机器人校准工具参数

在将工具添加到作业之后，即可开始针对应用程序自定义和微调工具。

机器人校准工具的设置栏包含以下内容：

  • 常规选项卡
  • 设置选项卡

常规选项卡

设置选项卡


机器人校准工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，该名称将用于配置结果（设置图像，输入/输出和通信）; 默认名称为“Calib_1”您可通过为工具指定与特定应用程序相关联的名称来自定义工具。您只能为作业添加一个机器人工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


机器人校准 - 设置选项卡

已关闭 文件名称

定义机器人校准文件名（默认名为“默认”）。

已关闭 全名

显示机器人校准文件的全名，扩展名为.CXD。

已关闭 附加日期/时间

如果要在文件名中包含当前日期和时间，请选中此复选框。


校准工具 - N 点

N 点校准工具用于使用 2 到 16 个输入特征及其关联的实际坐标来构造校准文件。此校准文件可以导出并作为一种校准类型应用于设置图像步骤中，也可以用于其它作业。

提示:进行校准后，建议保存作业文件。对于后续的校准，可以简单地加载校准作业，采集图像，然后将更新的校准文件导出到所有引用此校准文件的作业。

如果部件或对象的实际尺寸是已知的（例如，基于某 CAD 绘图），并且要将这些值用作校准值，那么在这种情况下，该工具非常有用。在这种应用中，使用 In-Sight 视觉系统采集部件或对象的图像，并将实际值与图像的像素坐标相关联。这些数据将存储在视觉系统的本地文件系统中，从而使最终所得的校准值可应用于其它作业。

注意:
  • 此工具需要使用其它位置和/或检测工具作为输入以定义校准点。在添加该工具之前，请组建将用作输入的必要位置和/或检测工具。
  • 使用 N 点或序列 N 点校准工具时，校准和运行时操作的物理和光学设置（镜头、视觉系统以及视觉系统与采集场景之间的物理关系）必须相同。如果更改了这些项目中的任何一项，必须重新校准系统。因此，建议使用相同的视觉系统和镜头来校准和处理运行时图像。视觉系统和镜头还必须保持原始设置和校准设置不变。例如，更改采集格式（通过更改分辨率）或移动视觉系统将使计算的 2D 变换（用于将像素映射到实际坐标）无效。

设置工具

调整工具参数


设置 N 点校准工具

提示:进行校准后，建议保存作业文件。对于后续的校准，可以简单地加载校准作业，采集图像，然后将更新的校准文件导出到所有引用此校准文件的作业。

添加该工具之后，需要定义用于构造校准文件的输入特征（点、固定原点或圆形特征的中心）：

  1. 在添加工具后，EasyBuilder 将检测图像，并列出自动检测到的智能特征（包括点、定位特征或圆形特征的中心，以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）以供选择。EasyBuilder 将自动为先前未定义的所有圆特征插入“圆存在/不存在”工具。

  2. 首先，从可用特征中选择一个特征（只需单击该特征即可，这时其颜色将变为洋红色）。

  3. 接下来，选择将用于定义校准文件的其余特征。最少选择两个输入特征，最多可选择十六个输入特征。

  4. 选择需要的所有特征后，按确定按钮来确认该选择（按取消按钮不将该工具添加到作业）。

  5. 成功添加工具并定义输入特征之后，需要为每个输入特征定义实际测量值。在点表中选择一个点，然后在场景 X 坐标和场景 Y 坐标字段中输入与其关联的实际测量值（手动输入数字或递增/递减控制）。
  6. 保存作业文件。
  7. 在“设置”选项卡中按下导出按钮，将校准文件放置在 In-Sight 视觉系统的本地文件系统中。这还使得在“设置图像”步骤的校准类型设置中可选择该校准作为导入选项。
  8. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  9. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整 N 点校准工具参数

在将工具添加到作业之后，即可开始针对应用程序自定义和微调工具。

N 点校准工具的设置窗格包含以下元素：

  • 常规选项卡
  • 设置选项卡
  • 点表
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

点表格


N 点校准工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（设置图像、输入/输出和通信）时会用到该名称。默认名称为“Calib_1”（如果该工具是添加到作业的第一个校准工具，之后名称将递增，如“Calib_2”、“Calib_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


N 点校准工具 - 设置选项卡

已关闭 文件名

定义校准文件的名称（默认名称为 Default）。

已关闭 全名

当校准类型配置为导入时，在设置图像步骤中将显示校准文件的全名。在设置图像步骤中显示该文件之前必须将其导出。

已关闭 导出

将校准文件导出到 In-Sight 视觉系统的本地文件系统。

已关闭 自动导出

指定在加载作业文件或获取图像后是否应在第一次触发时自动导出校准文件。当启用（选中）时，在加载作业文件或获取图像后（默认情况下，此设置被禁用/取消选中），工具将在第一次触发时自动导出其校准文件。

注意:如果启用自动导出，必须先保存包含校准数据的作业文件，然后才能导出校准文件。如果在保存作业文件后，校准文件未显示在 In-Sight 文件栏中，请单击另一个 In-Sight 视觉系统或模拟器，然后返回并重新选择所需的视觉系统。该文件现在应该会出现。


N 点校准工具 - 点表格

像素和实际坐标点表用于显示和定义用于校准的实际坐标值。

已关闭 点

显示所找到点的只读索引列表，1 至 16（EasyBuilder 中的数字排序基于 0=1）。

已关闭 像素行

显示点的像素行 (X) 位置。

已关闭 像素列

显示点的图像列 (X) 坐标。

已关闭 场景 X 坐标

显示点的实际 X 坐标值。

已关闭 场景 Y 坐标

显示点的实际 Y 坐标值。

已关闭 场景 X 坐标

定义所选点的实际 X 坐标值。

已关闭 场景 Y 坐标

定义所选点的实际 Y 坐标值。

已关闭 选择点

允许选择点形式的输入特征。按此按钮后，EasyBuilder 将检测图像，并列出自动检测到的智能特征（包括点、定位特征或圆形特征的中心，以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）以供选择。从可用特征中选择一个特征（只需单击该特征即可），这时它的颜色将变为紫红色。


校准工具 - 序列 N 点

序列 N 点校准工具用于使用某个输入特征及其关联的实际坐标在顺序图像采集期间构造校准文件。此校准文件可以导出并作为一种校准类型应用于设置图像步骤中，也可以用于其它作业。

提示:进行校准后，建议保存作业文件。对于后续的校准，可以简单地加载校准作业，采集图像，然后将更新的校准文件导出到所有引用此校准文件的作业。

此工具对于校准 In-Sight 视觉系统和机器人的坐标系统非常有用。在这种应用中，机器人控制器在不同位置向视觉系统呈现对象，每次在一个位置采集一次图像。每次采集图像时，都会向校准表中相应添加一个点。待机器人访问完所有位置并已保存每个点后，可将校准文件导出并保存作业文件。

注意:
  • 此工具需要使用其它位置和/或检测工具作为输入以定义校准点。在添加该工具之前，请组建将用作输入的必要位置和/或检测工具。
  • 使用 N 点或序列 N 点校准工具时，校准和运行时操作的物理和光学设置（镜头、视觉系统以及视觉系统与采集场景之间的物理关系）必须相同。如果更改了这些项目中的任何一项，必须重新校准系统。因此，建议使用相同的视觉系统和镜头来校准和处理运行时图像。视觉系统和镜头还必须保持原始设置和校准设置不变。例如，更改采集格式（通过更改分辨率）或移动视觉系统将使计算的 2D 变换（用于将像素映射到实际坐标）无效。

设置工具

调整工具参数


设置序列 N 点校准工具

提示:进行校准后，建议保存作业文件。对于后续的校准，可以简单地加载校准作业，采集图像，然后将更新的校准文件导出到所有引用此校准文件的作业。

添加该工具之后，需要定义用于构造校准文件的输入特征（点、定位特征或圆形特征的中心）：

  1. 在添加工具后，EasyBuilder 将检测图像，并列出自动检测到的智能特征（包括点、定位特征或圆形特征的中心，以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）以供选择。EasyBuilder 将自动为先前未定义的所有圆特征插入“圆存在/不存在”工具。
  2. 从可用特征中选择一个特征（只需单击该特征即可），这时它的颜色将变为洋红色。
  3. 选择所需的特征后，按确定按钮来确认该选择（按取消按钮则不将该工具添加到作业）。
  4. 在“设置”选项卡中，指定有多少个点/采集项将定义校准，从而定义点数参数。
  5. 将机器人控制器移至下一个位置，并在其新位置采集点的图像。持续执行此过程，直至采集完所有点。
  6. 成功添加这些点之后，需要定义点的实际测量值。在点表中选择一个点，然后在场景 X 坐标和场景 Y 坐标字段中输入与其关联的实际测量值（手动输入数字或递增/递减控制）。
  7. 按设置选项卡中的导出按钮，将校准文件放置在 In-Sight 视觉系统的本地文件系统中。这还使得在“设置图像”步骤的校准类型设置中可选择该校准作为导入选项。
  8. 初始配置工具后，根据需要加载多幅图像和调整工具参数，以补偿您预期的变化范围。
  9. 最后，根据需要使用工具的输入/输出属性在其它工具和/或其它外部设备之间共享工具数据。


调整序列 N 点校准工具参数

在将工具添加到作业之后，即可开始针对应用程序自定义和微调工具。

序列 N 点校准工具的设置窗格包含以下元素：

  • 常规选项卡
  • 设置选项卡
  • 点表
提示:使用 TestRun 测试您的作业。TestRun 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。这样便可以查看作业的运行是否符合预期，或是否需要针对允许的变化调整特定参数。

常规选项卡

设置选项卡

点表格


序列 N 点校准工具 - 常规选项卡

已关闭 工具名称

定义检测工具的名称，在配置结果（输入/输出和通信）时会用到该名称。默认名称为“Calib_1”（如果该工具是添加到作业的第一个校准工具，之后名称将递增，如“Calib_2”、“Calib_3”等等）。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。

已关闭 工具已启用

定义检查工具何时以及是否运行（默认设置为“开”）。如果要禁用该工具，请选择“关”；如果要将工具的执行与表达式的结果联系起来，请选择“表达式”（仅对提供“表达式”参数的工具才会启用此控制）；如果要将工具与特定的离散输入行联系起来，请选择“输入”，此时可将该工具开启或关闭（高信号 1 为“开”，低信号 0 为“关”）。通过将工具与输入联系起来，控制系统（如 PLC）便可确定应该运行哪些工具。

已关闭 包括在作业通过中

定义是否应将工具的通过/失败状态包括在作业的总体通过/失败状态中。默认情况下会将其选中，因而会将其包括在作业的总体通过/失败状态中。取消选中该复选框可将工具的通过/失败状态与作业中的其它工具分开。如果料到某个工具会失败，则应取消选中此控制。例如，如果使用两个“PatMax 图形”识别工具来确定部件是右侧部件还是左侧部件，则可料到每次都会有其中一个工具失败。在这种情况下，假如选中该复选框，不管识别出哪一侧的部件，都会导致作业每次都失败。

已关闭 执行时间 (ms)

显示该工具执行检查所需的时间量，以毫秒为单位。根据图像中画面的复杂性，以及图像内特征的位置和参数中允许的变化量，此时间可能有所不同。

已关闭 说明

描述工具用途的注释（默认情况下，该字段为空）。可以使用多达 255 个字母数字字符或 127 种亚洲语言字符。


序列 N 点校准工具 - 设置选项卡

已关闭 点数

定义要采集的点数（2 到 16；默认值为 12）。

已关闭 重置

将采集计数重置为 0。

已关闭 联机重置

定义在 In-Sight 视觉系统被置于联机状态时是否重置采集计数。默认情况下，此选项被禁用（取消选中状态）。

已关闭 作业加载重置

定义在加载作业文件时是否重置采集计数。默认情况下，此选项被启用（选中状态）。

已关闭 文件名

定义校准文件的名称（默认名称为 Default）。

已关闭 全名

当校准类型配置为导入时，在设置图像步骤中将显示校准文件的全名。在设置图像步骤中显示该文件之前必须将其导出。

已关闭 导出

将校准文件导出到 In-Sight 视觉系统的本地文件系统。

已关闭 自动导出

指定在加载作业文件或获取图像后是否应在第一次触发时自动导出校准文件。当启用（选中）时，在加载作业文件或获取图像后（默认情况下，此设置被禁用/取消选中），工具将在第一次触发时自动导出其校准文件。

注意:如果启用自动导出，必须先保存包含校准数据的作业文件，然后才能导出校准文件。如果在保存作业文件后，校准文件未显示在 In-Sight 文件栏中，请单击另一个 In-Sight 视觉系统或模拟器，然后返回并重新选择所需的视觉系统。该文件现在应该会出现。
已关闭 结果

显示工具的“通过/失败”状态。


序列 N 点校准工具 - 点表格

像素和实际坐标点表用于显示和定义用于校准的实际坐标值。

已关闭 点

显示所找到点的只读索引列表，1 至 16（EasyBuilder 中的数字排序基于 0=1）。

已关闭 像素行

显示点的像素行 (X) 位置。

已关闭 像素列

显示点的图像列 (X) 坐标。

已关闭 场景 X 坐标

显示点的实际 X 坐标值。

已关闭 场景 Y 坐标

显示点的实际 Y 坐标值。

已关闭 场景 X 坐标

定义所选点的实际 X 坐标值。

已关闭 场景 Y 坐标

定义所选点的实际 Y 坐标值。

已关闭 选择点

允许选择点形式的输入特征。按此按钮后，EasyBuilder 将检测图像，并列出自动检测到的智能特征（包括点、定位特征或圆形特征的中心，以青色突出显示）以及先前已通过其它工具定义的特征（以绿色突出显示）以供选择。从可用特征中选择一个特征（只需单击该特征即可），这时它的颜色将变为紫红色。


输入/输出

输入/输出步骤用于定义支持的 In-Sight 视觉系统和 I / O 模块的离散输入和输出线路的设置。您可以自定义线路的名称，设置信号类型，选择信号的边沿转换和工具结果，并强制输入或输出来测试应用程序。

注意:
  • 在使用模拟器时会禁用此应用程序步骤。
  • 在配置输入或输出线路之前，请注意输出设备是否为 PNP（拉电流源）或 NPN（灌电流），并确保设备与 In-Sight 传感器或 I / O 模块正确连接。有关详细信息，请查阅适用的 In-Sight 视觉系统或 I/O 模块安装手册。

配置输入和输出线路

输入：加载作业文件

输入：打开和关闭位置和检查工具

输入：触发图像采集

输入：在输入线上训练模型图形

输出：发出错过图像采集信号

输出：为图像采集触发光源

输出：将一条线路设置为定位或检测工具结果


配置输入和输出线路

  1. （可选）按 I / O 模块按钮打开 I / O 模块配置对话框。 配置 I/O模块，然后按确定按钮关闭 “I/O 模块配置”对话框。在视觉系统与 I/O 模块首次连接成功后，“（已连接）”消息会在列表中该 I/O 模块的旁边显示。在成功连接到 I/O 模块之后，即可开始自定义线路。
  2. 选择要配置的输入或输出行。 可访问的输入和输出的数量因 In-Sight 模型和适用的 I / O 模块而异。 有关更多信息，请参阅此主题。
  3. 仅支持 In-Sight 7000 Gen2 系列和 9912：如果线路支持双向 I/O，请从方向下拉菜单中选择输入或输出。
  4. 您可以通过输入特定于应用程序的新名称来自定义默认行名称。该名称最多可以包括 15 个字节，且仅供参考；它不会改变线路的功能且无法被引用。

  5. 接下来，定义所选输入行的信号类型。 任何一行都可以配置为以下任一种功能：

    输入信号类型 说明
    用户数据

    通用输入线; 用于打开或关闭位置和检查工具。
    重设计数器

    将 EasyBuilder 计数器（Job.Fail_Count，Job.Inspection_Count，Job.Pass_Count，<Tool>.Error_Count，<Tool> .Fail_Count 和<Tool> .Pass_Count）重置为 0。

    注意:
    • 该信号类型仅在视觉系统在线时可用。
    • 仅有一条输入线路可以被配置为重置计数器。
    • 当将某个输入线设置为重置计数器后再创建新作业时，新作业会自动将输入线重置为事件触发（使用 In-Sight 2000 系列视觉传感器时该设置为空白）。

    事件触发

    通过电子表格视图中创建的逻辑触发事件。 对于更新电子表格的 Event 触发，电子表格必须包含一个 Event 结构，其触发参数设置为此离散输入线路号。有关更多信息，请参阅Event。

    注意:
    • 该信号类型仅在视觉系统在线时可用。
    • 该选项需要访问电子表格视图；除非用于在一条输入线上训练模型图形。

    作业 ID 编号

    提供一位的作业 ID 编号，该编号会在含有作业加载开关类型的不同输入线路状态为开启时加载。

    注意:
    • 要使用“作业 ID 编号”功能，必须以 0 到 127 的数字前缀保存要加载的作业。
    • 作业 ID 号的最低有效位对应于 I/O 模块上最低编号的离散输入线。

    联机/脱机

    强制 In-Sight 视觉系统离线或在线（0 =离线，1 =在线）。 此输入类型不能同时用于多个输入线。

    注意:当信号类型设置为在线时，如果已在 In-Sight Explorer 用户界面中手动设置为脱机，或者已发出让视觉系统进入脱机状态的本机模式设置在线命令 SO0，则视觉系统可能仍处于脱机状态。有关更多信息，请参阅SetOnline。

    采集触发
    （不支持In-Sight 2000系列传感器或CIO-1400）

    触发视觉系统以采集图像。 此输入类型不能同时用于多个输入线。

    注意:
    • 编辑采集设置组框中的触发参数必须设置为外部触发才能使用采集触发输入，且单独的信号线必须物理连接到 In-Sight 视觉系统的输入端才能使用采集触发输入。
    • 使用视觉系统的内置采集触发输入（通过将触发设置为相机）与使用配置为采集触发的通用输入线路触发视觉系统（通过将触发设置为外部触发）相比，可以实现更快的触发速率。
    • 如果触发参数设置为外部触发，且错过了采集，则错误信息：错过采集输出不会从视觉系统发送; 仅当触发参数设置为相机时，才会发送错误信息：错过采集。

    作业加载开关

    ON 读取所有作业 ID 号线路并加载指定的作业。 此输入类型不能同时用于多个输入线。

    注意:视觉系统必须处于离线状态。

    更改作业（脉冲）

    （仅支持使用直接I / O的In-Sight 2000系列传感器）

    根据脉冲的不同宽度，基于检测到的输入脉冲来启动作业更改。 脉冲由外部设备（例如PLC）生成，并发送到 In-Sight 2000 传感器。 首先，外部设备发出启动脉冲。 接着，外部设备发出计数脉冲，每个计数脉冲之间含有一个脉冲间隙。 最后，外部设备发出停止脉冲。

    脉冲类型 | 脉冲长度
    起始脉冲 | 20ms (±2ms)
    脉冲计数 | 10ms (±1ms)
    脉冲间隔 | 10ms (± 1ms)
    停止脉冲 | 20ms (±2ms)

    当所有脉冲和脉冲间隙与指定的脉冲长度匹配时，作业更改请求成功，并且作业将加载到传感器。 如果任何条件失败（即，不正确的脉冲或不正确的脉冲间隔定时），则作业改变请求失败，并且不发生作业改变。

    注意:
    • 该信号类型仅在视觉系统在线时可用。
    • 要使用作业更改（脉冲）功能，您必须至少保存一个作业，并且必须使用＃jobfilename.job格式的数字前缀0到31保存作业（例如，1PinInspection.job）。 发出的计数脉冲数必须与要加载的作业的数字前缀相对应。
    • SetSystemConfig（“PulseJobChangeTiming”）本机模式命令可用于配置起始脉冲、计数脉冲、脉冲间隙和停止脉冲的脉冲宽度。
    • 你也可以选择将离散输出线配置为作业加载确定或作业加载失败类型以脉冲输出，并报告作业更改请求的成功或失败。

    串行接收
    （仅限于直接 I/O）

    将该线路配置为串行接收。

    注意:
    • 此信号类型仅在选择直接 I / O 时对输入线 1 有效。
    • In-Sight 70xx - 74xx 系列视觉系统的串行通信有两种选择：使用分接电缆或使用 CIO-MICRO 或 CIO-MICRO-CC I / O 模块。当连接到分线电缆（并且没有连接到 I / O 模块）时，视觉系统允许一个离散输入线和一个离散输出线分别配置为串行接收和串行发送。有关详细信息，请参阅如何启用 In-Sight 70xx - 74xx 视觉系统的串行通信。
    • 如果将 In-Sight 70xx - 74xx 系列视觉系统配置为与 CIO-MICRO 或CIO-MICRO-CC I / O 模块一起使用，则分接电缆上的 RS-232 TRANSMIT 和 RS-232 RECEIVE 管脚将被禁用。使用 I/O 模块的 RS-232 OUT 端口 (DB9) 与串行设备连接。

  6. 为所选输入线路选择边类型，该边类型将控制输入线路脉冲沿过渡的灵敏度。

    • 上升沿：在脉冲上升沿改变输入线的状态。
    • 下降沿：在脉冲下降沿改变输入线的状态。
    • 上升沿和下降沿：在脉冲上升沿和下降沿改变输入线的状态。 此选项仅在事件触发为选定类型时可用。

  7. 接下来，定义所选输出线的信号类型。 任何一行都可以配置为以下任一种功能：

    输出信号类型 | 说明
    作业结果（默认） | 启用位置或检测工具的结果以控制此输出线的状态。 脉冲或恒态。
    高 | 强制输出为 HIGH（1）。
    低 | 强制输出为 LOW（0）。
    采集开始

    视觉系统发起采集的信号。 始终为脉冲信号。

    注意:对于 n-Sight 8405 视觉系统，当第一个像素行曝光时，采集开始信号会发出脉冲。 有关详细信息，请参阅卷动快门操作。
    采集结束

    指示视觉系统采集已完成。 始终为脉冲信号。

    注意:对于 In-Sight 8405 视觉系统，当总图像数读取完成时，采集结束信号会发出脉冲。 有关详细信息，请参阅卷动快门操作。
    作业已完成 | EasyBuilder 每次完成更新的信号。 始终为脉冲信号。
    系统忙 | 当视觉系统正在运行作业或响应用户输入时为 HIGH，当视觉系统空闲时为 LOW。.
    作业加载成功 | 表示作业成功加载。 始终为脉冲信号。
    作业加载失败 | 指示作业加载失败。 始终为脉冲信号。
    错误：错过采集

    在发送采集结束信号之前采集触发器收到的信号，或在收到采集触发信号时图像采集没有图像缓冲可用而发出的信号。始终为脉冲信号。 有关更多信息，请参阅图像缓冲对话框。

    注意:在“设置图像”步骤中的“编辑采集设置”组框下的“触发”参数必须被设置为相机以使用错误：错过采集输出。
    错误：跟踪超时运行

    指示 EasyBuilder 在预期时间后的某个时间发出延时离散输出信号。 始终为脉冲信号。

    注意:CIO-1400 和 CIO-MICRO 不支持此信号。
    错误：跟踪队列已满 | EasyBuilder 对之前计划同时出现的不同输出行发出延时离散输出的信号。 始终为脉冲信号。
    联机/脱机 | 当视觉系统处于在线状态时为 HIGH（1），当视觉系统处于离线状态时为 LOW（0）。
    选通脉冲 | 信号的上升或下降沿可被用来触发频闪脉冲。
    光源控制
    （仅限 CIO-1460）     		信号的上升沿或下降沿可用来触发光源。
    备用 I/O 模块
    （仅限 CIO-1450 和 CIO-1460）

    ON 表示 I/O 模块检测到视觉系统和 I/O模块之间的通信错误，并且正在尝试重新建立通信。 当 I/O 模块检测到错误条件已得到纠正时，该线路变为 OFF。

    注意: 该输出类型仅在配置 CIO-1450 或 CIO-146 时对线路 0 到 7 有效。
    Lifeline
    （仅限 CIO-MICRO 和 CIO-MICRO-CC）     		视觉系统主动连接到 CIO-MICRO 或 IO-MICRO-CC 时为 HIGH。 与视觉系统连接失败时为 LOW。
    波形

    启用电子表格中的 Waveform 函数、WriteWaveformPulseTrain 或 WriteWaveformClocked 以控制此输出线的状态。

    注意:该选项要求访问电子表格视图。
    串行发送

    将此线配置为串行传输线。

    注意:
    • 串行传输仅在使用 In-Sight Explorer 4.7.1 或更高版本连接到 In-Sight 70xx-74xx 系列视觉系统并使用 In-Sight 4.7.1 或更高版本固件时可用。
    • 当选择直接 I/O时，此输出类型仅对输出线路 1 有效。
    • In-Sight 70xx - 74xx 系列视觉系统的串行通信有两种选择：使用分接电缆或使用 CIO-MICRO 或 CIO-MICRO-CC I / O 模块。当连接到分线电缆（并且没有连接到 I / O 模块）时，视觉系统允许一个离散输入线和一个离散输出线分别配置为串行接收和串行发送。有关详细信息，请参阅如何启用 In-Sight 70xx - 74xx 视觉系统的串行通信。
    作业通过/失败（仅限 In-Sight 7000 Gen2 系列和 In-Sight 9000 系列） | 当选择时，根据总体作业通过/失败状态的当前状态，视觉系统通过/失败 LED 和指示灯环亮起绿色（通过）或红色（失败）。
  8. 如果详细设置对指定输出信号类型可用，点击详细信息按钮针对所选输出线打开输出详细信息对话框。

  9. 也可以选择检查离线时断电输出复选框，以在视觉系统处于离线状态时断开输出电源。

    注意:如果选中离线时断开电源输出复选框，并且 CIO-MICRO 或 CIO-MICRO-CC I/O 模块的输出线路配置为 LifeLine 信号类型，则当连接的视觉系统处于离线状态时，线路将保持高电平。
  10. （可选）在部署之前或之后，可使用强制选项来测试或调试应用程序。 强制选项将覆盖定义的线路设置，允许您强制打开输入或输出线路，以便在 In-Sight 传感器处于联机状态时测试结果。
    1. 选择你想要测试的线路
    2. 将强制设置设定为开。 此操作将“强制”线路执行其配置的操作。
    3. 将视觉系统设置为在线并触发视觉系统。

    4. 完成线路测试后，将视觉系统设置为脱机并将强制设置设置为关或无。

    注意:
    • 对于输出线，强制功能不会产生实际的输出。 它只改变输出的值。
    • 如果您只想测试输出线上的电路连接，最好将输出线设置为“高”或“低”，而不是使用强制，然后将视觉系统设置为在线。 只要视觉系统切换到在线模式，这将保持输出信号为高或低。 然后，您可以使用仪表来确定您的电路路径是否按预期运行。
  11. 当您离开此步骤时，对这些设置所做的任何更改将自动保存到视觉系统（而不是 .job 文件中）。

I/O 模块配置

输入和输出线数

默认输入和输出线路

输出详细信息对话框控制


I/O 模块配置

已关闭 配置 CIO-1400、CIO-1450 或 CIO-1460
  1. 从 In-Sight Explorer 连接到支持的视觉系统。
  2. 打开 I / O 模块配置对话框。
  3. 从选择 I / O 模块下拉列表中选择 CIO-1400、CIO-1450 或 CIO-1460。
  4. 单击确定关闭对话框。
已关闭 配置 CIO-MICRO 或 CIO-MICRO-CC
  1. 从 In-Sight Explorer 连接到支持的视觉系统。
  2. 打开 I / O 模块配置对话框。
  3. 从选择 I / O 模块下拉列表中选择 CIO-MICRO 或 CIO-MICRO-CC。

  4. 从连接到下拉列表中选择相应的 I/O 模块。

    注意:如果列表中没有显示 I / O 模块的主机名，请选择<IP 地址连接>，并手动输入 I / O 模块的 IP 地址。

  5. 在更新时间字段中，指定 In-Sight Micro 视觉系统和 CIO-MICRO 或 CIO-MICRO-CC I / O 模块之间的输入和输出同步（1ms - 500ms; 默认= 20ms）所需的时间间隔。

    注意:如果超出输出信号延迟有问题，请减少更新时间。但是，应针对具体应用根据需要尽量少地减少更新时间。随着更新时间的减少，作业执行时间可能会增加。
  6. 还可以单击更改设置... 按钮配置 I/O 模块的网络设置。

    • 默认情况下，In-Sight CIO-MICRO 和 CIO-MICRO-CC I / O 模块在启动时由 DHCP 服务器动态配置。可以分配新的主机名，但禁用对话框中的所有其他字段。

      注意:如果没有 DHCP 服务器可用，则 I / O 模块超时并绑定到本地链路 IP 地址。
    • 取消选中使用 DHCP 服务器复选框并在“IP 地址”、“子网掩码”、“默认网关”、“DNS 服务器”和“域名”字段中设置相应的网络设置，可对 CIO-MICRO 和 CIO-MICRO-CC 使用静态 IP 地址。
  7. 单击确定关闭对话框。
已关闭 配置 CIO-WENET

首先需要给 CIO-WENET I/O 模块分配 IP 地址，然后才能在 In-Sight Explorer 中配置该模块。给该模块分配 IP 地址后，便可在 In-Sight Explorer 中对其进行配置：

  1. 从 In-Sight Explorer 连接到支持的视觉系统。
  2. 打开 I / O 模块配置对话框。
  3. 从选择 I/O 模块下拉列表中选择 CIO-WENET。
  4. 在 IP 地址字段中，指定先前分配给 CIO-WENET 的 IP 地址。

  5. 在更新时间字段中，指定 In-Sight Micro 视觉系统和 CIO-WENET I / O 模块之间的输入和输出同步（1ms - 500ms; 默认= 20ms）所需的时间间隔。

    注意:
    • 如果有输出信号延时过长的问题，请减少更新时间。但是，应针对具体应用根据需要尽量少地减少更新时间。随着更新时间的减少，作业执行时间可能会增加。
    • 对于 CIO-WENET，同步时间比更新时间长 3ms。
  6. 单击确定关闭对话框。


输入和输出线数

不同的 In-Sight 视觉系统有不同的的直接（内置）输出数，如下所示：

In-Sight 视觉系统 | 直接（内置）输入 | 直接（内置）输出
In-Sight Micro 1000 系列 | 无 | 2 个高速输出 2 个用户可配置 LED（1 个绿色，1 个红色）
In-Sight 2000 系列 | 1 个通用输入 | 4 个高速输出 2 个用户可配置 LED（1 个绿色或红色、1 个黄色）
In-Sight 5000 系列 | 无 | 2 个高速输出 2 个用户可配置 LED（1 个绿色，1 个红色）
In-Sight 70xx - 74xx 系列 | 3 个通用输入 | 4 个高速输出 2 个用户可配置 LED（1 个绿色，1 个红色）
In-Sight 76xx - 79xx 系列 | 最多 3 个通用输入 | 最多 4 个高速输出 2 个用户可配置的 LED（1 个绿色或红色，1 个红色）
In-Sight 8000 系列 | 无 | 2 个高速输出 2 个用户可配置 LED（1 个绿色，1 个红色）
In-Sight 9902L | 1 个通用输入 | 2 个高速输出 2 个用户可配置的 LED（1 个绿色或红色，1 个红色）
In-Sight 9912 | 最多 3 个通用输入 | 最多 4 个高速输出 2 个用户可配置的 LED（1 个绿色或红色，1 个红色）
注意:
  • In-Sight 视觉系统上有一个专用的采集触发输入口。有关详细信息，请参阅包含在 In-Sight 浏览器软件中的视觉系统安装手册。
  • 当连接到分接电缆时，In-Sight 76xx-79xx系列和9912视觉系统支持HS OUT 2 / IN 2和HS OUT 3 / IN 3的双向高速输出和通用输入。这些线路的默认配置为输出。

I / O 模块可用于提供额外的离散输入和输出。离散输入和输出的数量因适用的 I / O 模块而异，如下所示：

I/O 模块 | 支持的 In-Sight 视觉系统 | 离散输入 | 离散输出
CIO-1400 | In-Sight 2000系列，In-Sight 5000系列（5604除外），In-Sight 76xx - 79xx系列，In-Sight 9000系列 | 7 个通用输入 | 6 个通用输出
CIO-MICRO | In-Sight Micro 1000系列，In-Sight 5000系列，In-Sight 70xx - 79xx系列，In-Sight 8000系列，In-Sight 9000系列 | 8 个通用输入 | 8 个通用输出
CIO-MICRO-CC | In-Sight Micro 1000 系列、In-Sight 5000 系列（5705、5705C 和 5715 除外）、In-Sight 70xx - 74xx 系列 | 8 个通用输入 | 8 个通用输出
CIO-1450 | In-Sight 5000 系列（5604、5705、5705C 和 5715 除外） | 8 个通用输入 | 8 个通用输出
CIO-1460 | In-Sight 5000 系列（5604、5605、5705、5705C 和 5715 除外） | 8 个通用输入 | 8 个通用输出
CIO-WENET | In-Sight Micro 1000 系列 | 8 个通用输入 | 8 个通用输出
注意:
  • CIO-1400 I / O 模块支持固件版本为 5.3.0 及更高版本的 In-Sight 2000 系列视觉传感器。
  • CIO-1400 I / O模块支持使用In-Sight Explorer 5.4.0及更高版本的In-Sight 76xx-79xx系列视觉系统。如果您使用早期版本的 In-Sight Explorer 登录到视觉系统并连接到 CIO-1400 I / O 模块且配置 I / O 线路，所作的更改将不会被保留。
  • CIO-MICRO I / O 模块支持固件版本为 5.3.0 及更高版本的 In-Sight 5705、5705C、5715 和 In-Sight 8000 系列视觉系统。
  • CIO-MICRO 和 CIO-MICRO-CC I / O 模块支持使用 128MB 非易失性闪存或更高内存的 In-Sight 5100 系列和 5400 系列视觉系统。型号可根据产品类型编号 (821-xxxx-xx) 来识别。类型编号位于贴在视觉系统表面的黄色标签上 。有关所有型号、类型编号和非易失性闪存列表，请单击此处。
  • CIO-1450、CIO-1460 和 CIO-WENET I/O 模块不再可供购买。In-Sight 浏览器仍然支持这些模块以方便向后兼容。


默认输入和输出线路

已关闭 In-Sight Micro 1000 系列
注意:
  • HS OUT 0和HS OUT 1是内置的高速输出，直接来自视觉系统。
  • 视觉系统支持在HSOUT 1线路上使用脉冲信号类型。

Direct I/O

输出 | 名称
0 | HSOUT 0
1 | HSOUT 1
4 | 绿色 LED
5 | 红色 LED

CIO-MICRO 或者 CIO-MICRO-CC

输入 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
输出 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
8 | HSOUT 0
9 | HSOUT 1
10 | 绿色 LED
11 | 红色 LED

CIO-WENET

输入 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
输出 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
8 | HSOUT 0
9 | HSOUT 1
10 | 绿色 LED
11 | 红色 LED
已关闭 In-Sight 2000 系列
注意:
  • IN 0 是内置输入，直接来自视觉传感器。

  • HS OUT 0，HS OUT 1，HS OUT 2和HS OUT 3是内置的高速输出，直接来自视觉传感器。

  • 视觉传感器支持HSOUT 1线的Strobe信号类型。
  • 绿色LED /红色LED是单个LED输出，具有您可以配置的红色和绿色状态。

直接 I/O

输入 | 名称
0 | IN 0
输出 | 名称
0 | HSOUT 0
1 | HSOUT 1
2 | HSOUT 2
3 | HSOUT 3
4 | 绿色 LED
 | 红色 LED
5 | 黄色 LED

CIO-1400

输入 | 名称
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
输出 | 名称
0 | HSOUT 0
1 | HSOUT 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
 | 线路 5
5 | 线路 6
7 | 线路 7
8 | 绿色 LED
9 | 红色 LED
10 | 黄色 LED
11 | 禁用
12 | 禁用
已关闭 In-Sight 5000 系列

Direct / CIO-1350

输出 | 名称
0 | HSOUT 0
1 | HSOUT 1
4 | 绿色 LED
5 | 红色 LED

CIO-1400

输入 | 名称
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
输出 | 名称
0 | HSOUT 0
1 | HSOUT 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
8 | 绿色 LED
9 | 红色 LED

CIO-1450

注意:当从 CIO-1450 I/O 模块发送脉冲离散输出时，脉冲宽度可能比指定的长10毫秒。
输入 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
输出 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
8 | HSOUT 0
9 | HSOUT 1
10 | 绿色 LED
11 | 红色 LED

CIO-1460

注意:当对 CIO-1460 I/O 模块重新插电时，离散输出在启动过程中可能会触发约 250 微秒。
输入 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
输出 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
8 | HSOUT 0
9 | HSOUT 1
10 | 绿色 LED
11 | 红色 LED
12 | 禁用
13 | 禁用

CIO-MICRO/CIO-MICRO-CC

注意:
  • CIO-MICRO I/O 模块支持固件版本为 5.3.0 及更高版本的 In-Sight 5705、5705C、5715。
  • CIO-MICRO 和 CIO-MICRO-CC I / O 模块支持使用 128MB 非易失性闪存或更高内存的 In-Sight 5100 系列和 5400 系列视觉系统。 型号可根据产品类型编号 (821-xxxx-xx) 来识别。 类型编号位于贴在视觉系统表面的黄色标签上 。 有关型号和支持的固件版本的完整列表，请参阅固件版本。
输入 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
输出 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
8 | HSOUT 0
9 | HSOUT 1
10 | 绿色 LED
11 | 红色 LED
已关闭 In-Sight 70xx - 74xx 系列
注意:
  • In-Sight 70xx-74xx 系列视觉系统支持同时连接分接电缆和 CIO-MICRO 或 CIO-MICRO-CC I/O 模块。
  • IN 1、IN 2 和 IN 3 是内置输入，直接来自视觉系统。 仅当视觉系统连接到分接电缆时，才支持直接（内置）输入。
  • HS OUT 0，HS OUT 1，HS OUT 2和HS OUT 3是内置的高速输出，直接来自视觉系统。 仅当视觉系统连接到分接电缆时，才支持 70xx - 74xx 系列视觉系统中的高速输出。
  • 视觉系统支持 HSOUT 0 线的 Strobe 信号类型。
  • 如果将外部灯光设备连接到 In-Sight 70xx-74xx 系列视觉系统的外部光缆，请使用灯光设置对话框来配置外部灯光设置。
  • In-Sight 70xx - 74xx 系列视觉系统的串行通信有两种选择：使用分接电缆或使用 CIO-MICRO 或 CIO-MICRO-CC I / O 模块。当连接到分线电缆（并且没有连接到 I / O 模块）时，视觉系统允许一个离散输入线和一个离散输出线分别配置为串行接收和串行发送。有关详细信息，请参阅如何启用 In-Sight 70xx - 74xx 视觉系统的串行通信。

Direct I/O

输入 | 名称
1 | IN 1/Serial Receive
2 | IN 2
3 | IN 3
输出 | 名称
0 | HS OUT 0
1 | HS OUT 1/Serial Transmit
2 | HS OUT 2
3 | HS OUT 3
4 | 绿色 LED
5 | 红色 LED

CIO-MICRO/CIO-MICRO-CC

注意:
  • 当视觉系统与分接电缆连接并已与 CIO-MICRO I/O 模块建立起以太网连接时：
    • 不支持 I/O模块的 I/O 端口（DB15）和 TRIGGER +，TRIGGER-，HS OUT 0，HS OUT 1 和 HS COMMON 端口。 请勿将远程设备的导线连接到这些端口。
    • 不支持 I/O 模块的 I/O 端口（DB15）。 请勿连接到此端口。
    • 分接电缆上的 RS-232 TRANSMIT 和 RS-232 RECEIVE 引脚被禁用。 使用 I/O 模块的 RS-232 OUT 端口（DB9）连接到串行设备。
输入 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
9 | IN 1
10 | IN 2
11 | IN 3
输出 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
8 | HS OUT 0
9 | HS OUT 1
10 | HS OUT 2
11 | HS OUT 3
12 | 绿色 LED
13 | 红色 LED
已关闭 In-Sight 7000 Gen2 系列
注意:
  • 视觉系统支持同时连接分接电缆和 CIO-MICRO I/O 模块。有关支持的硬件 I / O 配置，请参阅 In-Sight 7000 Gen2 硬件I / O 配置。
  • IN 1、IN 2 和 IN 3 是内置输入，直接来自视觉系统。 仅当视觉系统连接到分接电缆时，才支持直接（内置）输入。
  • HS OUT 0，HS OUT 1，HS OUT 2和HS OUT 3是内置的高速输出，直接来自视觉系统。
  • 视觉系统支持在HSOUT 1线路上使用脉冲信号类型。
  • 如果将外部频闪设备连接到 In-Sight 7000 Gen2 系列视觉系统的外部光缆或将照明配件连接到视觉系统面板，请使用灯光设置对话框配置灯光设置。

Direct I/O

注意:视觉系统支持 IN 2 / HS OUT 2 和 IN 3 / HS OUT 3 的双向高速输出和通用输入。 这些线路的默认配置为输出。
输入 | 说明 | 名称
1 | 固定输入 | IN 1
2 | 输入 | IN 2
3 | 输入 | IN 3
输出 | 说明 | 名称
0 | 固定输出 | HSOUT 0
1 | 固定输出 | HSOUT 1
2 | 输出 | HSOUT 2
3 | 输出 | HSOUT 3
4 | 固定输出 | 通过/失败 LED
5 | 固定输出 | 错误 LED

CIO-MICRO

注意:
  • 当视觉系统与分接电缆连接并已与 CIO-MICRO I/O 模块建立起以太网连接时：
    • 视觉系统支持 IN 2 / HS OUT 2 和 IN 3 / HS OUT 3 的双向高速输出和通用输入。 这些线路的默认配置为输出。
    • 不支持 CIO-MICRO I/O 模块的 TRIGGER +、TRIGGER-、HS OUT 0、HS OUT 1 和 HS COMMON 端子。 请不要将引线从远程设备连接到这些端口。
    • 分接电缆上的 RS-232 TRANSMIT 和 RS-232 RECEIVE 引脚被禁用。 使用 I/O 模块的 RS-232 OUT 端口（DB9）连接到串行设备。
  • 当视觉系统通过 I/O 模块电缆连接到 CIO-MICRO I/O 模块时：
    • TRIGGER +、TRIGGER-、HS OUT 0、HS OUT 1 和 HS COMMON 通过 CIO-MICRO I/O 模块端子连接。 仅当视觉系统连接到分接电缆时，才支持这些线路。
    • TRIGGER +、TRIGGER-、HS OUT 0、HS OUT 1 和 HS COMMON 通过 CIO-MICRO I/O 模块端子连接。
    • 不支持连接到视觉系统面板或 LIGHT 连接口的照明附件。 如果连接了这些照明附件，则必须使用分接电缆为视觉系统供电，并且仅与通过以太网建立的 I/O 模块连接。
输入 | 说明 | 名称
0 | 固定输入 | 线路 0
1 | 固定输入 | 线路 1
2 | 固定输入 | 线路 2
3 | 固定输入 | 线路 3
4 | 固定输入 | 线路 4
5 | 固定输入 | 线路 5
6 | 固定输入 | 线路 6
7 | 固定输入 | 线路 7
9 | 固定输入 | IN 1
10 | 输入 | IN 2
11 | 输入 | IN 3
输出 | 说明 | 名称
0 | 固定输出 | 线路 0
1 | 固定输出 | 线路 1
2 | 固定输出 | 线路 2
3 | 固定输出 | 线路 3
4 | 固定输出 | 线路 4
5 | 固定输出 | 线路 5
6 | 固定输出 | 线路 6
7 | 固定输出 | 线路 7
8 | 固定输出 | HSOUT 0
9 | 固定输出 | HSOUT 1
10 | 输出 | HSOUT 2
11 | 输出 | HSOUT 3
12 | 固定输出 | 通过/失败 LED
13 | 固定输出 | 错误 LED

CIO-1400

注意:
  • 连接到 CIO-1400 I/O 模块时，不支持视觉系统的 IN 1、IN 2、IN 3、HS OUT 2 和 HS OUT 3 线路。
  • CIO-1400 I/O 模块支持使用 In-Sight Explorer 5.4.0 及更高版本的 In-Sight 7000 Gen2 系列视觉系统。 如果您使用早期版本的 In-Sight Explorer 登录到视觉系统并连接到 CIO-1400 I/O 模块且配置 I/O 线路，所作的更改将不会被保留。
输入 | 名称
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
输出 | 名称
0 | HSOUT 0
1 | HSOUT 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
8 | 通过/失败 LED
9 | 错误 LED
已关闭 In-Sight 8000 系列
注意:
  • HS OUT 0和HS OUT 1是内置的高速输出，直接来自视觉系统。
  • 视觉系统支持在HSOUT 1线路上使用脉冲信号类型。
  • 如果在 In-Sight 8405 视觉系统中使用脉冲触发，建议将全帧图像捕获的最小曝光值设置为72ms，以确保在脉冲触发时所有像素行都会曝光。 有关详细信息，请参阅卷动快门操作。

直接 I/O

输出 | 名称
0 | HSOUT 0
1 | HSOUT 1
4 | 绿色 LED
5 | 红色 LED

CIO-MICRO

注意:
  • CIO-MICRO I/O 模块支持固件版本为 5.3.0 及更高版本的 In-Sight 8000 系列视觉系统。
  • In-Sight 8505P 视觉系统 必须连接到最低额定功率为 12.95 瓦的 0、3 或 4 类 PoE 电源。CIO-MICRO I / O模块是 2 类 PoE 设备，因此不能用于通过 I/O 模块的 PoE 端口为 In-Sight 8505P 视觉系统 供电。而是将 视觉系统 的以太网电缆连接到 0、3 或 4 类 PoE 电源，并使用 In-Sight Explorer 通过局域网建立与 I/O 模块的连接。
输入 | 名称
0 | 线 0
1 | 线 1
2 | 线 2
3 | 线 3
4 | 线 4
5 | 线 5
6 | 线 6
7 | 线 7
输出 | 名称
0 | 线 0
1 | 线 1
2 | 线 2
3 | 线 3
4 | 线 4
5 | 线 5
6 | 线 6
7 | 线 7
8 | HSOUT 0
9 | HSOUT 1
10 | 绿色 LED
11 | 红色 LED
已关闭 In-Sight 9902L线扫描视觉系统
注意:
  • 视觉系统支持同时连接分接电缆和 CIO-MICRO I/O 模块。有关支持的硬件I / O配置，请参阅 In-Sight 9902L 硬件 I / O 配置
  • IN 1、IN 2 和 IN 3 是内置输入，直接来自视觉系统。 仅当视觉系统连接到分接电缆时，才支持直接（内置）输入。
  • HS OUT 0和HS OUT 1是内置的高速输出，直接来自视觉系统。
  • 视觉系统支持在HSOUT 1线路上使用脉冲信号类型。
  • 如果使用In-Sight 9902L线扫描视觉系统的脉冲：
    • 选通脉冲应使用PNP接线配置且选通脉冲/灯控触发应设置为上升沿。
    • 当视觉系统接收到采集触发信号时，输出线路会发送脉冲并且频闪脉冲在曝光时间内闪烁。一旦曝光完成，在接收到下一个采集触发或选通脉冲可能无法正常工作之前，必须至少有100μs 时间。

Direct I/O

输入 | 名称
1 | IN 1
输出 | 名称
0 | HSOUT 0
1 | HSOUT 1
4 | 通过/失败 LED
5 | 错误 LED

CIO-MICRO

注意:
  • 当视觉系统与分接电缆连接并已与 CIO-MICRO I/O 模块建立起以太网连接时：
    • 不支持 CIO-MICRO I/O 模块的 TRIGGER +、TRIGGER-、HS OUT 0、HS OUT 1 和 HS COMMON 端子。 请不要将引线从远程设备连接到这些端口。
    • 分接电缆上的 RS-232 TRANSMIT 和 RS-232 RECEIVE 引脚被禁用。 使用 I/O 模块的 RS-232 OUT 端口（DB9）连接到串行设备。
  • 当视觉系统通过I / O模块电缆连接到CIO-MICRO I / O模块时：
    • 不支持视觉系统 ENCODER A INPUT 和 ENCODER B INPUT。

    • 虽然视觉系统的 IN 1 线路会在 Discrete I/O 设置对话框中显示，但该线路不受支持。 只有当视觉系统与分接电缆连接时才支持 IN 1。

    • TRIGGER +、TRIGGER-、HS OUT 0、HS OUT 1 和 HS COMMON 通过 CIO-MICRO I/O 模块端子连接。
输入 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
9 | IN 1
输出 | 名称
0 | 线路 0
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
8 | HSOUT 0
9 | HSOUT 1
10 | 通过/失败 LED
11 | 错误 LED

CIO-1400

注意:连接到 CIO-1400 I/O 模块时，不支持视觉系统的 ENCODER A INPUT，ENCODER B INPUT 和 IN 1 线路。
输入 | 名称
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
输出 | 名称
0 | HSOUT 0
1 | HSOUT 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
8 | 通过/失败 LED
9 | 错误 LED
已关闭 In-Sight 9912
注意:
  • 视觉系统支持同时连接分接电缆和 CIO-MICRO I/O 模块。有关支持的硬件 I / O 配置，请参阅 In-Sight 9912 硬件 I / O 配置。
  • IN 1、IN 2 和 IN 3 是内置输入，直接来自视觉系统。 仅当视觉系统连接到分接电缆时，才支持直接（内置）输入。
  • HS OUT 0，HS OUT 1，HS OUT 2和HS OUT 3是内置的高速输出，直接来自视觉系统。
  • 视觉系统支持在HSOUT 1线路上使用脉冲信号类型。
  • 如果将外部频闪设备连接到 In-Sight 9912 视觉系统的外部光缆，请使用灯光设置对话框配置灯光设置。

Direct I/O

注意:视觉系统支持 IN 2 / HS OUT 2 和 IN 3 / HS OUT 3 的双向高速输出和通用输入。 这些线路的默认配置为输出。
输入 | 说明 | 名称
1 | 固定输入 | IN 1
2 | 输入 | IN 2
3 | 输入 | IN 3
输出 | 说明 | 名称
0 | 固定输出 | HSOUT 0
1 | 固定输出 | HSOUT 1
2 | 输出 | HSOUT 2
3 | 输出 | HSOUT 3
4 | 固定输出 | 通过/失败 LED
5 | 固定输出 | 错误 LED

CIO-MICRO

注意:
  • 当视觉系统与分接电缆连接并已与 CIO-MICRO I/O 模块建立起以太网连接时：
    • 视觉系统支持 IN 2 / HS OUT 2 和 IN 3 / HS OUT 3 的双向高速输出和通用输入。 默认情况下，这些线路会被配置为输出。
    • 不支持 CIO-MICRO I/O 模块的 TRIGGER +、TRIGGER-、HS OUT 0、HS OUT 1 和 HS COMMON 端子。 请不要将引线从远程设备连接到这些端口。
    • 分接电缆上的 RS-232 TRANSMIT 和 RS-232 RECEIVE 引脚被禁用。 使用 I/O 模块的 RS-232 OUT 端口（DB9）连接到串行设备。
  • 当视觉系统通过 I/O 模块电缆连接到 CIO-MICRO I/O 模块时：
    • TRIGGER +、TRIGGER-、HS OUT 0、HS OUT 1 和 HS COMMON 通过 CIO-MICRO I/O 模块端子连接。 仅当视觉系统连接到分接电缆时，才支持这些线路。
    • TRIGGER +、TRIGGER-、HS OUT 0、HS OUT 1 和 HS COMMON 通过 CIO-MICRO I/O 模块端子连接。
    • 不支持连接到视觉系统 LIGHT 连接口的照明附件。 如果连接了这些照明附件，则必须使用分接电缆为视觉系统供电，并且仅与通过以太网建立的 I/O 模块连接。
输入 | 说明 | 名称
0 | 固定输入 | 线路 0
1 | 固定输入 | 线路 1
2 | 固定输入 | 线路 2
3 | 固定输入 | 线路 3
4 | 固定输入 | 线路 4
5 | 固定输入 | 线路 5
6 | 固定输入 | 线路 6
7 | 固定输入 | 线路 7
9 | 固定输入 | IN 1
10 | 输入 | IN 2
11 | 输入 | IN 3
输出 | 说明 | 名称
0 | 固定输出 | 线路 0
1 | 固定输出 | 线路 1
2 | 固定输出 | 线路 2
3 | 固定输出 | 线路 3
4 | 固定输出 | 线路 4
5 | 固定输出 | 线路 5
6 | 固定输出 | 线路 6
7 | 固定输出 | 线路 7
8 | 固定输出 | HSOUT 0
9 | 固定输出 | HSOUT 1
10 | 输出 | HSOUT 2
11 | 输出 | HSOUT 3
12 | 固定输出 | 通过/失败 LED
13 | 固定输出 | 错误 LED

CIO-1400

注意:连接到 CIO-1400 I/O 模块时，不支持视觉系统的 IN 1、IN 2、IN 3、HS OUT 2 和 HS OUT 3 线路。
输入 | 名称
1 | 线路 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
输出 | 名称
0 | HSOUT 0
1 | HSOUT 1
2 | 线路 2
3 | 线路 3
4 | 线路 4
5 | 线路 5
6 | 线路 6
7 | 线路 7
8 | 通过/失败 LED
9 | 错误 LED


输出详细信息对话框控制

  • 脉冲：当选中此复选框时，输出将以脉冲发出。清除此复选框以进行稳态输出。当采集延时大于 0 时，输出必须以脉冲发出。

  • 脉冲长度（ms）：输出脉冲的持续时间。

    视觉系统/视觉传感器 | 最小脉冲长度 | 最大脉冲长度 | 默认脉冲长度
    通用输出 | 高速输出
    In-Sight Micro 1000 系列（除 1402、1412 和 1500 外） | 10ms | 10ms | 1000ms | 10ms
    In-Sight Micro 1402、1412 和 1500 | 10ms | 1ms | 1000ms | 10ms
    In-Sight 2000 系列 | 10ms | 1ms | 1000ms | 10ms
    In-Sight 5000 系列 | 10ms | 10ms | 1000ms | 10ms
    In-Sight 70xx - 74xx 系列 | 10ms | 1ms | 1000ms | 10ms
    In-Sight 76xx - 79xx 系列 | 10ms | 1ms | 1000ms | 10ms
    In-Sight 8000 系列 | 10ms | 1ms | 1000ms | 10ms
    In-Sight 9902L | 1ms | 1ms | 1000ms | 10ms
    In-Sight 9912 | 1ms | 1ms | 1000ms | 10ms
    注意:
    • 将CIO-Micro或CIO-Micro-CC I / O模块与支持的视觉系统一起使用时，通用输出的最小脉冲长度受I / O模块配置对话框中更新时间设置的限制。例如，如果更新时间为20ms，则最小脉冲长度不能设置为低于30ms。有关详情，请参阅I / O模块配置对话框。
    • 对于In-Sight In-Sight 76xx-79xx系列和8000系列视觉系统，仅使用In-Sight固件版本5.5.0及更高版本的视觉系统支持最小脉冲长度1ms。如果使用之前的固件版本，则最小脉冲长度为 10ms。

  • 采集延时 (N)：采集或跟踪脉冲数 (0 至 1000)，以在输出线收到信号脉冲后延迟输出。如果采集延时 = 0，则 In-Sight 视觉系统会在评估 EasyBuilder 作业时立即更新输出线。如果采集延时 > 0，则输出线路总是以脉冲发出。

    注意:采集延时和触发后时间不能同时使用；二者必须单独使用，例如，如果启用采集延时，则触发后时间将被禁用，反之亦然。

  • 触发后时间（ms）: 选中此复选框后，将在指定的时间值（0 到 10000 毫秒）后触发输出。

    注意:采集延时和触发后时间不能同时使用；二者必须单独使用，例如，如果启用采集延时，则触发后时间将被禁用，反之亦然。
  • 频闪/灯光控制触发：信号的上升沿或下降沿可用于触发频闪灯或灯光控制。
    • NPN 配置：如果设置为上升沿，在图像传感器曝光时，信号为“高”，否则，信号为“低”。如果设置为下降沿，在图像传感器曝光时，信号为“低”，否则，信号为“高”。曝光过程中始终发出脉冲信号。 曝光时间必须比外部选通脉冲设备上指定的选通脉冲持续时间长 0.50 ms。

    • PNP 配置：如果设置为上升沿，在图像传感器曝光时，信号为“低”，否则，信号为“高”。如果设置为下降沿，在图像传感器曝光时，信号为“高”，否则，信号为“低”。曝光过程中始终发出脉冲信号。 曝光时间必须比外部选通脉冲设备上指定的选通脉冲持续时间长 0.50 ms。

      注意:
      • 对于In-Sight 5600系列，5705，5705C，5715和9902L视觉系统，选通脉冲行为是反转的（即，对于NPN布线配置，上升沿和下降沿的行为类似于PNP配置）。
      • 如果使用In-Sight 9902L线扫描视觉系统的脉冲：
        • 选通脉冲应使用PNP接线配置且选通脉冲/灯控触发应设置为上升沿。
        • 当视觉系统接收到采集触发信号时，输出线路会发送脉冲并且频闪脉冲在曝光时间内闪烁。一旦曝光完成，在接收到下一个采集触发或选通脉冲可能无法正常工作之前，必须至少有100μs 时间。
  • 选通脉冲开始位置：指定选通脉冲的时间。In-Sight 9902L视觉系统不支持该选项。
    • 采集开始：指定视觉系统在开始采集图像时，脉冲会发出。除了In-Sight 8405 支持所有其它的视觉系统型号。
    • 相机触发：规定在接收到相机触发事件后再发出脉冲。除了In-Sight 8405 支持所有其它的视觉系统型号。

    • 曝光所有行：规定仅在所有像素行被曝光后再发出脉冲。仅支持 In-Sight 8405 视觉系统。

      注意:如果在 In-Sight 8405 视觉系统上使用选通脉冲，建议最小要使用72ms 的曝光设置来采集整幅图像。这样可以确保在脉冲发出时，所有的像素行都可以被曝光。有关详细信息，请参阅滚动快门操作 。

  • 三色 LED：配置三色 LED 线路。（关闭/绿色，关闭/红色，红色/绿色；默认=关闭/绿色）此选项仅在线路支持三色 LED 时可用。

    注意:In-Sight 76xx - 79xx系列和In-Sight 9000系列视觉系统支持此选项应用于通过/失败LED，但如果通过/失败作业单元格是选定的信号类型，则不可用。


输入：加载作业文件

In-Sight 2000 系列传感器

为了使用此功能，您必须至少保存一个作业，作业必须以数字前缀 0 至 3 1保存，格式为＃jobfilename.job（例如，2PinInspection.job）。

  1. 选择输入线 0，并将信号类型设置为作业更改（脉冲）。

  2. 要将 2PinInspection.job 加载到传感器，外部设备（例如PLC）会向 In-Sight 2000 传感器发出一系列脉冲。

    脉冲类型 | 脉冲长度
    起始脉冲 | 20ms (±2ms)
    脉冲计数 | 10ms (±1ms)
    脉冲间隔 | 10ms (± 1ms)
    停止脉冲 | 20ms (±2ms)
    1. 外部设备发出一个开始脉冲，随后是一个脉冲间隙。
    2. 然后外部设备发出三个计数脉冲。每个计数脉冲与最后一个计数脉冲之后的脉冲间隙之间存在一个脉冲间隙。发出的计数脉冲数必须与要加载的作业的数字前缀相对应（例如，加载2PinInspection.job需要两个计数脉冲）。
    3. 外部设备发出停止脉冲。当所有脉冲和脉冲间隙与指定的脉冲长度匹配时，作业更改请求成功，并将 2PinInspection.job 加载到传感器。如果任何条件失败（即，不正确的脉冲或不正确的脉冲间隙时间），则作业改变请求将失败并且不会发生作业更改。
    注意:
    • SetSystemConfig（“PulseJobChangeTiming”）本机模式命令可用于配置起始脉冲、计数脉冲、脉冲间隙和停止脉冲的脉冲宽度。
    • （可选）离散输出线可以配置为作业加载成功或作业加载失败类型来进行脉冲输出，并报告作业更改请求的成功或失败。如果未使用指定的输入脉冲长度，则输出不会产生脉冲以显示作业负载故障。

In-Sight 视觉系统

为使用此功能，必须至少保存一项作业，且要加载的作业必须使用 0 至 127 的数字前缀（如 1PinInspection.job）保存。

  1. 选择要配置的输入线，并将信号类型设置为作业加载开关。加载的作业文件由设置为作业 ID 号的任何其他输入线路的状态（0 或 1）来指示。
  2. 至少将另一条输入线的信号类型设置为作业 ID 号。
  3. 一个设置为作业 ID 编号的输入表示二进制数的一位。设置为作业 ID 编号的后续行输入表示该二进制数的其它位。完整的二进制数表示保存在以下格式的作业文件的数字前缀（十进制＃）：＃jobfilename.job。

示例 1

三个离散输入设置为作业 ID 编号，表示一个 3 位二进制数。这三个输入的状态分别为 0、1 和 0 时，二进制数 010 表示要加载前缀为 2（十进制形式为 010）的 .job 文件。

示例 2

有三个不同的 .job 文件，名称分别为 3inspection.job、6inspection.job 和 9inspection.job。您想要指定：传感器收到来自 PLC 的 HIGH 信号时加载名为 6inspection.job 的 .job 文件。目前使用离散输入 1 作为图像采集触发。

  1. 将输入线 1 连接到 PLC。
  2. 将输入线 1 的信号类型设置为作业加载开关。
  3. 由于 .job 文件名前缀的范围为 3 到 9，您需要将 4 个输入设置为作业 ID 编号。（9 的二进制形式为 1001。）

  4. 当“作业 ID 编号”行的状态分别为 1、1、0 和 0（6 的二进制形式为 1100），且输入行 2 的状态为 HIGH (1) 时，将加载名为 6inspection.job 的作业。

    注意:如果 In-Sight 传感器中存储了具有相同数字前缀的多个作业，将加载按字母数字顺序排在最前面的文件。


输入：打开和关闭位置和检查工具

位置和检查工具可能将其工具执行绑定于输入线路。将该工具设置为绑定输入信号将允许控制系统（如 PLC）指定要运行哪些工具。

  1. 选择输入行，并将信号类型设置为用户数据。
  2. 转到想要控制的“位置”或“检测”工具，然后转到此工具的启用工具控制。从下拉列表中，选择在以上步骤中定义的输入数。
  3. 现在可以通过控制系统将该工具打开或关闭（高电平信号（1）为开，低电平信号 0 为关闭）。


输入：触发图像采集

要将 In-Sight 视觉系统配置为通过 PLC、光线或其他设备的输入线路接收采集触发信号，请完成以下步骤。

  1. 单击设置图像步骤。

  2. 在编辑采集设置组框中，在触发下拉菜单中选择外部。

    注意:
    • In-Sight 2000 系列视觉传感器不支持外部触发。
    • 使用视觉系统的内置采集触发输入（通过将采集图像函数的触发参数设置为相机）与使用配置为采集触发的通用输入线路触发视觉系统（通过将采集图像函数的触发参数设置为外部触发）相比，可以实现更快的触发速率。
    • 如果采集图像函数的触发参数设置为外部触发，且错过了采集，则错过采集错误信息的离散输出不会从视觉系统发送。 仅当采集图像函数的触发参数设置为相机时，才会发送错误信息：错过采集信号。
  3. 返回到输入/输出步骤。

  4. 选择输入线，并将信号类型设置为采集触发。

    注意:CIO-1400 I / O 模块不支持采集触发。
  5. 将信号的边缘类型设置为上升沿或下降沿。
  6. 将输入设备的电线连接到 In-Sight 视觉系统触发输入端口的分接电缆或 I / O 模块。有关详情，请查阅适用的 In-Sight 视觉系统或 I/O模块安装手册。


输入：在输入线上训练模型图形

要配置 In-Sight 视觉系统以通过输入线训练模型图形，请完成以下步骤。

  1. 在图形/图形（1 - 10）定位工具，图形存在/缺少工具或图形计数工具中，从训练输入下拉列表中选择一条输入线路作为训练信号。

    注意:当连接到 In-Sight 视觉系统或 In-Sight 2000-23M 视觉传感器时，训练输入下拉列表将包含在设置选项卡中。
  2. 返回到输入/输出应用程序步骤。
  3. 将所选输入线的信号类型设置为事件触发。
  4. 将信号的边缘类型设置为上升沿、下降沿或上升和下降沿。

  5. 将 In-Sight 视觉系统/传感器设置到在线状态。

    注意:模型模式的训练将使用视觉系统/传感器采集的最新图像。不需要为了训练重新触发视觉系统/传感器。

  6. 所选边缘类型的边缘会触发模型图形的训练。


输出：发出错过图像采集信号

要发出错过图像采集信号：

  1. 单击设置图像步骤。
  2. 在编辑采集设置组框中，从触发下拉菜单中选择相机。
  3. 返回到输入/输出步骤。
  4. 选择一条输出线，并将信号类型设置为采集结束。通过点击详细信息按钮指定脉冲宽度。
  5. 选择另一条输出线，并将信号类型设置为 ERR：错过采集。这表示在采集结束信号发送之前接收到采集触发，或者当接收到采集触发时没有图像缓冲可用于图像采集。
  6. 通过点击详细信息按钮指定脉冲宽度。


输出：为图像采集触发光源

已关闭 触发选通脉冲

信号的上升或下降沿可被用来触发脉冲。

发送信号以触发选通脉冲：

  1. 在设置图像步骤中定义采集触发设置。确保曝光时间比外部选通脉冲设备指定的选通脉冲持续时间长 0.50 ms。
  2. 将输出线路的信号类型设置为频闪脉冲。
  3. 按详细信息按钮，并指定是否由信号的上升沿或下降沿触发选通脉冲。
    • NPN 配置：如果设置为上升沿，在图像传感器曝光时，信号为“高”，否则，信号为“低”。如果设置为下降沿，在图像传感器曝光时，信号为“低”，否则，信号为“高”。曝光过程中始终发出脉冲信号。 曝光时间必须比外部选通脉冲设备上指定的选通脉冲持续时间长 0.50 ms。

    • PNP 配置：如果设置为上升沿，在图像传感器曝光时，信号为“低”，否则，信号为“高”。如果设置为下降沿，在图像传感器曝光时，信号为“高”，否则，信号为“低”。曝光过程中始终发出脉冲信号。 曝光时间必须比外部选通脉冲设备上指定的选通脉冲持续时间长 0.50 ms。

      注意:
      • 对于In-Sight 5600系列，5705，5705C，5715和9902L视觉系统，选通脉冲行为是反转的（即，对于NPN布线配置，上升沿和下降沿的行为类似于PNP配置）。
      • 如果使用In-Sight 9902L线扫描视觉系统的脉冲：
        • 选通脉冲应使用PNP接线配置且选通脉冲/灯控触发应设置为上升沿。
        • 当视觉系统接收到采集触发信号时，输出线路会发送脉冲并且频闪脉冲在曝光时间内闪烁。一旦曝光完成，在接收到下一个采集触发或选通脉冲可能无法正常工作之前，必须至少有100μs 时间。
  4. 指定选通脉冲起始位置。In-Sight 9902L视觉系统不支持该选项。
    • 采集开始：指定视觉系统在开始采集图像时，脉冲会发出。除了In-Sight 8405 支持所有其它的视觉系统型号。
    • 相机触发：规定在接收到相机触发事件后再发出脉冲。除了In-Sight 8405 支持所有其它的视觉系统型号。
    • 曝光所有行：规定仅在所有像素行被曝光后再发出脉冲。仅支持 In-Sight 8405 视觉系统。
注意:
  • In-Sight 视觉和照明设备必须连接到相同的地线，照明设备方可正常工作。
  • In-Sight Micro 1000系列，In-Sight 5000系列（5604除外），In-Sight 76xx-79xx系列，In-Sight 8000系列和In-Sight 9000系列视觉系统支持HSOUT 1线的Strobe信号类型。
  • In-Sight 70xx-74xx系列视觉系统支持在HSOUT 0线路上使用脉冲信号类型。
  • 对于 In-Sight 8405 视觉系统来说，脉冲起始位置设置固定为“所有行曝光”，且输出信号仅在所有像素行被曝光后才会发出。如果在 In-Sight 8405 视觉系统上使用选通脉冲，建议最小要使用72ms 的曝光设置来采集整幅图像。这样可以确保在脉冲发出时，所有的像素行都可以被曝光。有关详细信息，请参阅滚动快门操作 。
已关闭 触发外部光源（仅适用于 CIO-1460）

信号下降沿的上升可用来触发外部光源。

要发送信号以触发外部光源：

  1. 登录 In-Sight 5000 系列视觉系统并连接到 CIO-1460 I / O 模块。
  2. 在设置图像步骤中定义采集触发设置。确保曝光时间比外部选通脉冲设备指定的选通脉冲持续时间长 0.50 ms。
  3. 将 HSOUT1 的信号类型设为光源控制。
  4. 按详细信息按钮，并指定是否由信号的上升沿或下降沿触发选通脉冲。
注意:
  • In-Sight 视觉和照明设备必须连接到相同的地线，照明设备方可正常工作。
  • 在为 In-Sight 5000 系列传感器配置 CIO-1460 I/O 模块时，该输出类型仅对高速输出线路 1 (HSOUT 1) 有效。


输出：将一条线路设置为定位或检测工具结果

要根据位置或检测工具的结果发送信号：

  1. 选择输出线并将信号类型设置为作业结果。
  2. 从作业结果下拉菜单中选择要输出的工具结果。列出的工具结果（如 Text_1、Pattern_1 等）表示个别工具的整体通过/失败。作业结果是所有工具的累积通过/失败。当工具结果为“通过”时，信号将是 HIGH (1)，而当工具结果为“失败”时，信号为 LOW (0)。
  3. 按详细信息按钮以指定脉冲宽度和采集延时。如果没有指定这些设置，将不会通过脉冲发出信号。


通信

通信步骤用于为开放式数据访问和交换 (OPC) 定义检测结果、为 VisionView® 操作员界面面板配置 EasyView、通过 FTP 或 SD 卡导出图像，以及定义 In-Sight 视觉系统的网络和串行通信设置，从而使它们能够与其它设备（如机器人或可编程逻辑控制器 (PLC)/Motion Controller (MC)）进行数据通信。

注意:
  • In-Sight 传感器必须处于脱机状态才能启用通信步骤。
  • 可使用模拟器配置和保存作业的通信协议，然后在 In-Sight 视觉系统上加载以进行运行时部署。但是，即使可以选择 ProfiNET 及 CC-Link 协议，也不能在仿真器上对其进行模拟。这些协议要求在连接到 ProfiNET 或 CC-Link 网络的 In-Sight 视觉系统上开发和保存作业的通信协议。

支持的协议

最多可以将两个协议添加到作业中。 添加两个协议时，可以添加一个“主”协议和一个“辅助”协议。 例如，添加 SLMP 扫描仪协议（主）后，再次单击添加设备按钮并添加 TCP / IP 协议（辅助）。

注意:您不能向作业添加两个主协议或两个辅助协议。

In-Sight 固件版本 4.x.x

 | 主协议或 辅助协议 | Micro 1000 系列 | 5000 系列 （除了 5705 和 5705C） | 70xx - 74xx 系列
CC-Link | 主协议 | X | X | X
以太网本机 | 主协议 | X | X | X
以太网本机机器人 | 主协议 | X | X | X
以太网本机字符串 | 主协议 | X | X | X
EtherNet/IP | 主协议 | X | X | X
Modbus TCP 服务器 | 主协议 | X | X | X
POWERLINK | 主协议 |  |  | X
PROFINET | 主协议 | X | X | X
串行 Kuka | 主协议 | X | X | X
串行 Motoman | 主协议 | X | X | X
串行本机 | 主协议 | X | X | X
串行本机机器人 | 主协议 | X | X | X
串行本机字符串 | 主协议 | X | X | X
串行文本 | 主协议 | X | X | X
SLMP | 主协议 | X | X | X
SLMP 扫描 | 主协议 | X | X | X
TCP/IP | 辅助协议 | X | X | X
UDP | 辅助协议 | X | X | X

In-Sight 固件版本 5.x.x

 | 主协议或 辅助协议 | 2000 系列 | 5705 & 5705C | 7000 Gen2 系列 | 8000 系列 | 9000 系列
CC-Link IE Field Basic | 主协议 | X | X | X | X | X
以太网本机 | 主协议 |  | X | X | X | X
以太网本机机器人 | 主协议 |  | X | X | X | X
以太网本机字符串 | 主协议 |  | X | X | X | X
EtherNet/IP | 主协议 | X | X | X | X | X
Modbus TCP 服务器 | 主协议 | X | X | X | X | X
PROFINET | 主协议 | X | X | X | X | X
串行 Kuka | 主协议 |  | X | X | X | X
串行 Motoman | 主协议 |  | X | X | X | X
串行本机 | 主协议 | X（基本） | X | X | X | X
串行本机机器人 | 主协议 |  | X | X | X | X
串行本机字符串 | 主协议 |  | X | X | X | X
串行文本 | 主协议 | X | X | X | X | X
SLMP | 主协议 | X | X | X | X | X
SLMP 扫描 | 主协议 | X | X | X | X | X
TCP/IP | 辅助协议 | X | X | X | X | X
UDP | 辅助协议 | X | X | X | X | X

通过 OPC Server 共享数据

配置 EasyView

通过 FTP 导出图像

导出数据文件或通过 FTP 将数据字符串附加到文件

将图像导出到 SD 卡

导出数据文件或将数据字符串附加到 SD 卡上的文件

设备设置

与 Rockwell ControlLogix PLC 通信

与 Universal Robots 集成 - TCP / IP


通过 OPC Server 共享数据

如果您的应用程序涉及使用 OPC 服务器进行通信的其他设备，则可以启用检查结果（或输入数据）以将数据传输到 In-Sight OPC UA Server 或 In-Sight OPC Classic Server。

以下型号支持 In-Sight OPC UA Server 和 In-Sight OPC Classic Server

视觉系统/传感器 | In-Sight OPC UA Server 支持 | In-Sight OPC Classic Server 支持
In-Sight Micro 1000 系列 | 不支持 | 4.x.x 固件
In-Sight 2000 系列 | 5.8.0 固件及更高版本 | 不支持
In-Sight 5400 和 5600 系列 | 不支持 | 4.x.x 固件
In-Sight 5705 和 5705C | 不支持 | 5.x.x 固件版本
In-Sight 7000 系列 | 不支持 | 4.x.x 固件
In-Sight 7000 Gen2 系列 | 5.8.0 固件及更高版本 | 5.x.x 固件版本
In-Sight 8000 系列 | 5.8.0 固件及更高版本 | 5.x.x 固件版本
In-Sight 9000 系列 | 5.8.0 固件及更高版本 | 5.x.x 固件版本
模拟器 | 不支持 | 支持

OPC 标签

将 OPC 标记添加到作业文件

OPC UA


OPC 标签

OPC 标签是一个符号名称，可应用于支持的 In-Sight 视觉系统/传感器的 EasyBuilder 检查结果。OPC 标签对 OPC UA 客户端可见，因此它们可以访问 In-Sight 的作业数据。在 In-Sight OPC UA 实施的背景中，存在两种类型的 OPC 标签：作业标签和系统标签。

OPC 标签可以表示以下数据类型：

  • 布尔型：用于表示仅包含布尔值的标签。
  • 浮点：用于表示仅包含浮点值的标签。
  • 整数:用于表示仅包含整数值的标签。

  • 文本字符串：用于表示仅包含文本字符串值的标签。

    注意:
    • 文本字符串最多支持 256 个字符。
    • 文本字符串以文本的 Unicode 表示形式发送到 OPC 客户端。

OPC 标签可以具有读或读/写的访问级别。OPC UA 客户端可以从 In-Sight 作业文件读取数据或将数据写入作业文件的能力取决于 OPC 标签访问级别。

  • 读取：标签值只能从 OPC UA 客户端检索。
  • 读/写：标签的值可以由 OPC UA 客户端检索或设置。


将 OPC 标记添加到作业文件

尽管每个支持 OPC UA 的 In-Sight 视觉系统/传感器都有预定义的系统标签供 OPC UA 客户端使用，但这些标签很可能不会暴露您希望从 OPC UA 客户端访问的所有内容。因此，可以将作业标签添加到 EasyBuilder 检查和作业结果中，以便客户端可以使用该值。

  1. 从通信组框中，选择 OPC。
  2. 在已选的 OPC 标签中，点击添加按钮以启动选择 OPC 标签对话框。
  3. ”选择 OPC 标签“对话框包含任何已添加到作业中的位置或检测工具以及整体的作业结果。在该对话框中，选择您想启用的数据。
  4. 在选择了所需的数据后，单击确定按钮以接受更改。OPC 标签就会在已选的 OPC 标签部分显示。
  5. 配置 OPC Server。
    • 如果使用 OPC UA Server，请参见OPC UA。
    • 如果使用 OPC Classic Server，请参阅 In-Sight® OPC Classic Server 帮助


OPC UA

开放平台通信 - 统一架构 (OPC UA) 是由 OPC 基金会开发的现代通信协议，旨在为工业设备和系统提供独立于平台的安全开放架构的解决方案。对于 In-Sight 而言，视觉系统或视觉传感器充当 OPC UA Server，并且可以直接与 OPC UA 客户端通信，从而无需额外硬件。

以下型号支持 In-Sight OPC UA Server 和 In-Sight OPC Classic Server如需了解更多有关 In-Sight OPC Classic Server 的信息，请参阅In-Sight®OPC Classic Server 帮助文件。

视觉系统/传感器 | In-Sight OPC UA Server 支持 | In-Sight OPC Classic Server 支持
In-Sight Micro 1000 系列 | 不支持 | 4.x.x 固件
In-Sight 2000 系列 | 5.8.0 固件及更高版本 | 不支持
In-Sight 5400 和 5600 系列 | 不支持 | 4.x.x 固件
In-Sight 5705 和 5705C | 不支持 | 5.x.x 固件版本
In-Sight 7000 系列 | 不支持 | 4.x.x 固件
In-Sight 7000 Gen2 系列 | 5.8.0 固件及更高版本 | 5.x.x 固件版本
In-Sight 8000 系列 | 5.8.0 固件及更高版本 | 5.x.x 固件版本
In-Sight 9000 系列 | 5.8.0 固件及更高版本 | 5.x.x 固件版本
模拟器 | 不支持 | 支持

OPC UA 客户端可以从 In-Sight 视觉系统/传感器访问以下数据：

  • 采集计数
  • 活动作业名称
  • 联机状态（包括总是联机、间断联机和 GUI 联机）
  • 实时视频模式状态

除了检索数据外，In-Sight OPC UA Server 还允许 OPC UA 客户端：

  • 保存活动作业
  • 加载作业
  • 触发采集事件
  • 切换联机模式
  • 切换实况视频模式
注意:自定义应用程序设计者的责任是限制对服务器公开标签的访问，例如写入新作业文件、写入单元格值或切换视觉系统/传感器的联机/脱机状态。

此外，可以将 OPC 客户端配置为监视 AddressSpace 节点（或“受监视项目”）值的更改。您可以为节点创建订阅以监视这些项目，而不是不断轮询这些值更改。检测到更改时，将生成通知并通过订阅将其传输到 OPC UA 客户端。受监控项目的支持会话、客户端和节点的数量取决于视觉系统/传感器：

视觉系统/传感器 | 会话/客户端数 | AddressSpace 节点
In-Sight 2000 系列 | 一个 OPC UA 客户端上的一个会话。 | 每个会话/客户端 20 个订阅中的 50 个节点。
In-Sight 7000 Gen2 系列 | 两个 OPC UA 客户端的两个会话。 | 每个会话/客户端 20 个订阅中的 250 个节点。
In-Sight 8000 系列 | 两个 OPC UA 客户端的两个会话。 | 每个会话/客户端 20 个订阅中的 250 个节点。
In-Sight 9000 系列 | 两个 OPC UA 客户端的两个会话。 | 每个会话/客户端 20 个订阅中的 250 个节点。

启用 OPC UA Server

OPC UA 作业标签和系统标签

OPC UA 方法

SetSystemConfig：OPC UA 时间同步

故障排除


启用 OPC UA Server

如果使用 OPC UA，则必须首先在视觉系统/传感器上启用 In-Sight OPC UA Server，然后从 OPC UA 客户端将其连接。

提示:如果需要为OPC UA 标签时间戳配置时间同步，请在启用 OPC UA Server 之前使用 SetSystemConfig OPCUA.TimeSync 扩展本机命令。有关更多信息，请参阅 SetSystemConfig：OPC UA 时间同步。
  1. 从通信组框中，选择 OPC。

  2. 勾选启用 OPC UA Server复选框。

  3. 点击确定。
  4. 出现提示时，单击是重新启动视觉系统/传感器。重新启动后，OPC UA Server 将初始化并运行，并且发现端点侦听 OPC UA 客户端请求。
  5. 启动 OPC UA 客户端。

  6. 从 OPC UA 客户端，您必须输入端点 URL 才能连接到 OPC UA Server。端点 URL 必须采用以下格式，其中 <IP address> 是视觉系统/传感器的 IP 地址：

    opc.tcp://<IP 地址>:4840

    例如： opc.tcp://192.168.0.8:4840


OPC UA 作业标签和系统标签

作业标签是用户可配置的标签，表示存储在您可以向 OPC UA 客户端公开的 In-Sight 作业文件中的值。作业标签保存在作业文件中。

系统标签是默认标签，在支持 OPC UA Server 的任何视觉系统/传感器上始终可用，并且可以添加到您的配置中。系统标签不存储在作业文件中。

系统标签

可访问性

数据类型

说明

AcquisitionCount

只读

整数

返回自视觉系统/传感器开机以来的采集次数。

DiscreteOnline

只读

布尔型

如果离散输入行（配置为联机/脱机类型）设置为低 (0)，则返回 False。否则，返回 True。

GuiOnline

只读

布尔型

如果 In-Sight 浏览器 GUI 设置为联机模式（传感器菜单 > 联机），则返回 True。

JobName

只读

字符串

如果已保存活动作业，则返回视觉系统/传感器上加载的活动作业的名称。

注意:由于作业名称标签为只读，因此可以使用“作业另存为”方法重命名作业文件。有关更多信息，请参阅 OPC UA 方法。

LiveMode

读/写

布尔型
  • 读取：如果系统/传感器处于实况视频模式，则返回 True。否则，返回 False。
  • 写入：将任何非零值写入 LiveMode 标签将使视觉系统/传感器进入实况视频模式。将零写入 LiveMode 标签将退出“实况视频”模式。
注意:如果将值 True 写入 LiveMode 标签后，在 In-Sight 浏览器中打开视觉系统/传感器的作业视图，则 In-Sight 浏览器不显示实时图像，作业视图状态栏不指示实况视频模式。

NativeOnline

读/写

布尔型
  • 读取：如果已向视觉系统/传感器发出本机模式设置联机命令“SO0”，则返回 False。否则，返回 True。
  • 写入：将任何非零值写入 NativeOnline 标签会通过本机模式将视觉系统/传感器置于脱机状态（相当于发出本机模式设置联机命令“SO0”）。将零写入 NativeOnline 标签允许视觉系统/传感器联机（相当于发出本机模式设置联机命令“SO1”）。

联机

只读

布尔型

返回以下内容的逻辑“AND”：(DiscreteOnline AND NativeOnline AND GuiOnline)。


OPC UA 方法

以下默认方法在任何支持 OPC UA Server 的视觉系统/传感器上始终可用，并且可以添加到您的配置中。方法不存储在作业文件中。

方法

可访问性

数据类型

说明
LoadJob（文件名） 读/写 字符串

将指定的作业名称加载到视觉系统。

注意:

  • 指定的作业名称必须作为文件存在于视觉系统/传感器上。否则，返回错误。

  • 如果加载大型作业文件时发生以下任一错误，请考虑更改默认超时值以反映加载作业所需的时间量。
    • LoadJob 方法的默认超时为 10 秒。如果超过默认超时，OPC UA 客户端中将显示方法超时错误。作业仍将加载，通信仍将正常工作。
    • 连接看门狗超时的默认超时为 5 秒。加载作业时，视觉系统/传感器不更新 OPC UA 客户端。如果此状态持续存在，并且超过默认超时，则 OPC UA 客户端中显示连接警告看门狗超时错误。加载作业后，连接将自动重新建立，通信将自动恢复。
SaveJobAs（文件名） 读/写 字符串

将活动作业文件另存为指定的字符串。

注意:视觉系统/传感器必须脱机才能调用 SaveJobAs 方法。否则，返回错误。
TriggerManualAcquisition 读/写 N/A

在视觉系统/传感器上触发手动采集。
TriggerSoftEvent（索引） 读/写 整数

在视觉系统上启动软触发器。将 0 到 7 的整数值写入 TriggerSoftEvent 方法，这将将在电子表格中触发相应的“soft n”触发事件，其中 n 是写入的整数值。


SetSystemConfig：OPC UA 时间同步

配置 OPC UA 标签时间戳的时间同步。

注意:In-sight 2000 视觉传感器支持此扩展本机模式命令。

输入

Syntax: EV SetSystemConfig("OPCUA.TimeSync",[TimeSyncFrequency],[InitialTimeoutSec],[TimeSyncFrequencySec],[WriteProcSet])

参数

 说明

"OPCUA.TimeSync"

参考 OPC UA 时间同步设置。

TimeSyncFrequency
  • 0= 仅在系统启动期间同步一次日期/时间。（默认）
  • 1=根据 TimeSyncFrequencySec 参数值连续同步日期/时间。建议使用此设置进行高精度时间同步。
InitialTimeoutSec

指定 OPC UA Server 等待日期/时间更改生效的时间量（以秒为单位）。（默认值=15 秒）

注意:
  • 在指定的 InitialTimeoutSec 时间过后，OPC UA Server 才会启动。
  • 如果已手动配置视觉系统/传感器的日期/时间设置，并且在视觉系统/传感器重新开机时未找到为精确时间协议 (PTP) 配置的 SNTP 服务器或外部设备，则初始日期/时间将重置为 1970 年 1 月 1 日星期四和 12:00:00 AM在这种情况下，增加 InitialTimeoutSec，在视觉系统/传感器开机后，手动配置日期/时间设置。
TimeSyncFrequencySec

指定 TimeSyncFrequency 参数值设置为 1 时的时间同步频率。（默认值= 1 秒）

WriteProcSet
  • 0= 设置不保存在 proc.set 文件中。如果 In-Sight 视觉系统/传感器重新开机，则设置不会持续。 （默认）
  • 1= 设置保存在 proc.set 文件中。In-Sight 视觉系统/传感器重新开机后，设置仍保持不变。

输出

返回状态代码，后跟结果的字符数（以字节为单位），然后是 XML 格式的结果。状态代码：

状态代码 | 说明
1 | 命令顺利执行。
0 | 命令无法识别。
-2 | 无法执行该命令。
-6 | 用户没有执行该命令的完全权限。


故障排除

问题 分辨率

如果使用 UaExpert 作为客户端，则在十四到十六个 30 秒会话超时后，视觉系统停止响应任何 OPC UA 请求，并且 UaExpert 客户端无法连接到视觉系统。

发生这种情况时，新的和以前的超时客户端在尝试连接时会收到以下错误：

“错误 'BadTimeout' 在 OpenSecureChannel 期间返回”

注意:当处于这种状态时，其他一切都按预期工作。您可以使用 In-Sight 浏览器的传感器状态视图（Window > 显示传感器状态视图）验证发生了多少次会话超时。

对于 UaExpert：

  • SecureChannelLifetime：确定通道保持活动状态的时间。（默认值 = 一个小时。（最小值 = 5 分钟。）
  • 会话超时：确定断开无响应会话之前等待的时间。请注意，安全通道在超时后仍保持活动状态。（默认值= 20 分钟。最小值= 30 秒。)
  1. 等待一小时，让 SecureChannelLifetime 重置。
  2. 如果 SecureChannelLifetime 非常长，并且在此期间多次会话超时，请重新启动视觉系统/传感器。


配置 EasyView

如果使用 HMI 应用程序，你可以创建一个 EasyView 以自定义如何显示数据并决定操作员是否能编辑数据。首先，在 EasyBuilder 中创建 EasyView，然后将其与传感器作业一起保存。然后，使用 VisionView PC 演示应用或 Web HMI 应用预览以确认 EasyView 是否配置正确。

要配置 EasyView：

  1. 在通信组框中，选择 EasyView。
  2. 在已选的 EasyView 内容选项部分中，点击添加按钮来启动选择 EasyView 内容对话框。

  3. 选择 EasyView 内容对话框中包含来自添加到作业的任何位置或检查工具的数据，以及采集和作业设置。从该对话框中选择要在 EasyView 中显示的适用工具数据。你可以通过突出显示所需内容，然后按添加按钮，或是通过在 EasyView 复选框中选中该内容来选择。

    注意:
    • 要选择多个非连续项目，请按住 CTRL 键并突出显示这些内容。
    • 要选择多个连续内容，请按住 SHIFT 键并在列表中突出显示第一个内容，然后再突出显示最后一个内容。

  4. 在选择了所需的工具数据后，单击确定按钮以接受更改。现在，该工具数据已显示在选定的 EasyView 内容部分中。

    注意:
    • 要选择多个非连续项目，请按住 CTRL 键并突出显示这些内容。
    • 要选择多个连续项目，请按住 SHIFT 键并在列表中突出显示第一个内容，然后再突出显示最后一个内容。

  5. 在添加您的工具数据之后，可选择启用可编辑复选框，以使操作员能够从 VisionView 中修改这些工具数据。

    注意:要选择多个连续项目，请按住 SHIFT 键并在列表中突出显示第一个内容，然后再突出显示最后一个内容。
  6. 或者，点击插入标签按钮以创建标题标签。标签是对工具数据进行分组的一种有用方式。
  7. 标题是在 HMI 应用中显示的名称。您可以通过在工具数据或标签的标题字段中单击并输入描述性名称来修改默认标题。按 ENTER 键或单击标题字段的外部提交此更改；按 ESCAPE 键取消此更改。
  8. 通过从列表中选择工具数据，然后单击上或下按钮来设置所需的顺序，您可以重新排列工具数据和/或标签的显示方式。

  9. 保存作业文件。

    注意:在退出通信步骤时，也会自动将 EasyView 设置保存到 In-Sight 传感器。

  10. 如果需要预览 EasyView，启动 VisionView PC 演示应用或 Web HMI。

    注意:如果 VisionView PC 演示已经在你的 PC 上安装，则默认的安装路径为：C:/Program Files/Cognex/VisionView/PC Demo x.x.x。如果您的 PC 未安装 VisionView PC 演示，则可以从 VisionView 支持网站下载该应用程序。
  11. VisionView PC 演示或 Web HMI 启用后，在连接步骤中选择与传感器断开连接。

  12. 如果你使用的是 Web HMI，你可以在 EasyView 栏中预览 EasyView。

    如果你使用的是 VisionView PC 演示，将你的传感器添加到已选传感器列表，输入运行模式然后点击切换视图以预览 EasyView。

    注意:
    • 要预览 EasyView, 你必须先在HMI 视图选择对话框中选择 EasyView 选项。
    • VisionView PC 演示具有四十五分钟的自动超时设置。若要购买可提供完整功能且没有超时设置的授权版本，可安装 VisionView PC 软件，该软件可从 VisionView 支持站点下载。
    • VisionView PC 演示应用程序的界面风格将与 VisionView 操作员界面面板的界面风格略有不同。
    • 要在登录到模拟器上时预览 EasyView，您必须先手动将模拟器添加到 VisionView 应用程序的已选传感器列表中。


通过 FTP 导出图像

你可以配置你的 In-Sight 视觉系统以将图像导出到网络上的 FTP 服务器。该设置可以让你将所采集的图像（根据工具或作业的合格/不合格条件）存储到其它设备，以便进行归档。此后，可以查看这些图像来帮助您诊断在生产过程中可能遇到的问题。

要配置 FTP 连接：

  1. 从通信组框中，选择 FTP。
  2. 选择图像选项卡。

  3. 点击添加按钮添加一个条目并配置图像输出参数。

    注意:可以在作业中添加多个图像导出操作。
  4. 选择设置选项卡并配置 FTP 服务器设置。
  5. 将 In-Sight 视觉系统设置到在线状态。视觉系统必须处于“在线”状态才能执行；否则将不会导出图像。
  6. 触发视觉系统以采集图像。对于所采集的每个图像，均会导出一个图像文件（BMP 或 JPG，视文件格式参数而定），并将其存储在主机名参数中所指定的主机上。
注意:
  • 当传输条件设置为无（默认）时，每次采集新图像时都会导出图像文件。当传输条件设置为除了“无”以外的其它选项时，每次发生指定事件时都会导出图像文件。譬如，当传输条件被设置为Job.Fail，每次作业失败时都会将图像文件导出并存储在FTP服务器上。
  • 当使用In-Sight模拟器作为FTP服务器时，默认情况下，文件将写入模拟器文件夹（[ProgramData] \ Cognex \ In-Sight \ Emulators \ x.x.x）。同时，文档可以被写入用户自定义的目录 (已授权的 FTP 目录)。有关已授权的 FTP 目录的详情，请参阅可选对话框主题（模拟面板）。

图像选项卡

提供用于定义导出图像、图像格式、图像导出时间和图像导出位置的参数。

已关闭 启用复选框

定义是否可以执行图像导出操作（默认情况下会将其选中），以及是否要将其显示为 EasyView项目（例如，WriteImageFTP_1.Tool_Enabled），该项目可显示在 VisionView 操作员界面面板上，并且可由操作员进行编辑。

注意:如需启用该选项，选择表格中的启用选项框。这是你在表格中唯一能配置的参数。
已关闭 名称

定义图像导出操作的名称，在配置结果（输入/输出和通信）时会使用该名称；默认名称为“WriteImageFtp_1”（如果该操作是添加到作业的第一个图像导出操作，否则名称将递增，如“WriteImageFtp_2”、“WriteImageFtp_3”等等）。例如，通过给操作指定与其传输条件相关联的名称来对其进行自定义。

已关闭 传输条件

指定何时将数据发送到FTP服务器，例如特定工具通过或失败时，或接收到输入信号时。默认情况下，选择“无”，这将确保每次获取图像时都会导出数据，此时“已启用”复选框处于选中状态。如果“已启用”复选框被禁用，或者引用的工具被禁用，则导出操作将不会执行。

已关闭 设备

定义将在设置选项卡中配置的FTP服务器，该服务器将接收导出的数据。默认情况下会选择设备 1。

已关闭 文件格式

定义导出图像的文件格式：BMP（Windows 位图格式）或 JPG（标准编码 JPEG 格式）。默认情况下会选择 BMP。

已关闭 图像大小

定义导出图像的分辨率：完全、一半或者四分之一。默认情况下会选择完全。

已关闭 包含图形

定义是否为受支持的位置和检测工具创建包含重叠图形数据的 SVG 文件。要查看 SVG 文件和图像文件，应使用支持 SVG 文件类型的 Web 浏览器（如 Microsoft Internet Explorer 9.0）打开 SVG 文件。SVG 文件包含一个与其相关的采集图像的内部链接，当浏览器打开 SVG 文件时，它会通过这个链接打开并显示采集图像和重叠图形。

注意:
  • 如需启用该选项，请在右手边的组框中选择包含图形选项框。包含图形选项框在表格中为只读选项。
  • 启用后，SVG 文件会使用在文件名参数中指定的名称。
  • 当主机名参数在设置选项卡中被设置为 In-Sight 模拟器，则 svg 文件将会被保存到模拟器目录（[ProgramData]\Cognex\In-Sight\Emulators\x.x.x）并在In-Sight 文件栏中显示。
  • 如通过修改显示结果选项对话框中的工具选项，对位置和/或检测工具进行配置，使其隐藏重叠图形，则将无法输出 SVG 图形。默认情况下，所有工具均显示其重叠图形。
  • 由于图形是通过 Web 浏览器等第三方应用程序显示，所以重叠图形数据无法达到准确的像素到像素匹配。
  • In-Sight 固件不能保证传输所有 SVG 和图像文件的匹配对。如果 In-Sight 视觉系统过载，它可能会跳过对 SVG和/或图像文件的传输，以确保不会错过检测和/或图像采集。
已关闭 文件名预览

预览输出图像文件的名称；默认情况下，会显示 Image999。文件名称可以通过配置以下参数来自定义：默认文件名、添加链接、添加时间戳以及添加计数器。

注意:
  • 为图像文件指定至少一个参数。如果默认文件名区域为空白且添加链接、添加时间戳和添加计数器选项框没有被选择，则导出文件操作会失败。
  • 参数的顺序不能被更改。
  • 当添加计数器参数被激活，计数器的最大值将会在文件名预览中显示。
已关闭 默认文件名

定义导出的图像文件的名称；默认名称为“Image”。支持长文件名。

已关闭 添加链接

指定所选的工具是否会被链接或添加到被导出文件的文件名中。默认情况下，该选项框被禁用。

注意:
  • 如果所选的工具与含有以下无效字符的字符串链接，则导出操作将会失败：<, >, :, ", /, \, |, ? 或 *。
  • 当 EasyBuilder 无法找到任何可以链接的工具时，添加链接选项框会变灰。
  • 如果链接的工具从作业中被删除，则添加链接选项框会被禁用。
  • 当添加链接选项框被启用，请不要在下拉菜单中选择未定义；该选项可能会产生未定义的结果。
已关闭 添加时间戳

指定时间戳是否会被添加到导出图像文件的文件名中。默认情况下，该选项框被禁用。当启用时，可以在下拉菜单中选择预先配置的时间戳格式：MMDDYY, YYYYMMDD_HHMMSS, DDMMYY_HHMMSS, MM-DD-YYYY_HH.MM.SS, HHMMSS, YYMMDD_HHMMSS 或 YYDDMM_HHMMSS。

注意:你可以在日期/时间设置对话框中设置 In-Sight 视觉系统的日期/时间设置。
已关闭 添加计数器

指定是否在导出的图像文件名中添加计数器（默认 = 启用）。启用后，可以设置计数器的最大值(0 至 9999999; 默认 = 999)。每次导出一个图像文件，计数器都会逐次递增。当该计数器的值等于最大值时，它就会自动重置；现有的图像文件将会被同名的新文件覆盖。

已关闭 添加按钮

将一个新的导出操作添加到列表。

已关闭 移除按钮

从列表中移除一个导出操作。一次只能移除一个导出操作。

已关闭 重置所有计数器按钮

将每次导出图像操作时添加到图像文件名中的值重置为 000。

设置选项卡

设置选项卡提供用于定义两个目标设备的参数。目标设备可以是 In-Sight 仿真器，也可以是网络上充当 FTP 服务器的任何其它主机。

已关闭 主机名

定义目标设备的 FTP 服务器的主机名（或 IP 地址）。

注意:
  • 如果指定无效的主机名，则连接可能会在最多 30 秒后超时。

  • 指定“主机名”或“用户名”时，不要在名称前后使用空格。如果“主机名”或“用户名”设置中指定的名称在名称之前或之后包含空格，则图像导出操作将无法将图像写入指定的服务器。

  • 如果还有另一台 PC 安装了 FTP 服务器，也可选择该计算机作为存储位置。请注意，In-Sight 浏览器软件被视为 FTP 服务器。如果要使用第三方 FTP 服务器，则应关闭 In-Sight 浏览器。如果无其它 FTP 服务器正在运行，则 In-Sight 浏览器必须处于运行状态。如果要使用第三方 FTP 服务器，则必须在“主机名”参数中使用该 PC 的 IP 地址。
  • 可通过在主机名（或 IP 地址）后面追加冒号 (:) 和新端口号来更改 FTP 服务器连接端口号。例如，如果当前“主机名”为 PRODUCTION1，则要将默认端口号 (21) 更改为端口 34，需将“主机名”参数更改为：PRODUCTION1:34。
已关闭 用户名

定义目标设备的 FTP 服务器的有效用户名（不得超过 255 个字符）。输出图像文件或数据的In-Sight视觉系统不必存留此名称。

已关闭 密码

定义目标设备的 FTP 服务器的有效密码。密码区分大小写，且长度不能超过 20 个字符。

注意:
  • 出于安全考虑，您输入的密码将在字段中以“*”显示。
  • 密码将以加密形式保存在作业文件中。
已关闭 连接类型

定义图像导出连接类型：标准 FTP（默认选择）、安全 FTP 或 Mitsubishi GOT。安全 FTP 提供安全传输协议，与 SFTP 应用程序配合使用，而 Mitsubishi GOT 则为在 Mitsubishi GOT 终端上显示图像提供支持。

注意:当连接类型参数设置为Mitsubishi GOT时，确保在图像选项卡中的文件格式参数设置为JPG以得到最好的显示结果。
已关闭 FTP 设置按钮

启动“FTP 设置”对话框。

注意:通常无需修改专用本地 In-Sight 网络上的默认设置，在这些网络中，所有 FTP 连接都将在 In-Sight 视觉系统之间进行。但是，如果In-Sight视觉系统与其他网络服务器之间或不同网络上的视觉系统之间需要FTP连接，则可能需要更改默认FTP设置。
已关闭 上次网络错误

显示在导出操作时遇到错误的原因。必须在“文件”选项卡 - 传输条件中指定事件，例如，触发图像，或者您必须将In-Sight视觉系统置于在线状态才能更新此字段。


导出数据文件或通过 FTP 将数据字符串附加到文件

你可以配置In-Sight视觉系统以导出数据文件或将数据字符串附加到网络上的FTP服务器上的文件中。使用该功能以记录您在文件中查看的数据结果。

要配置 FTP 连接：

  1. 从通信组框中，选择 FTP。
  2. 选择文件选项卡。

  3. 点击添加按钮添加一个条目并配置输出参数。

    注意:你可以将多个文件导出操作添加到作业。
  4. 选择设置选项卡并配置 FTP 服务器设置。
  5. 将 In-Sight 视觉系统设置到在线状态。视觉系统必须在线执行; 否则，将不会导出数据。
  6. 触发视觉系统。对于每个触发，数据文件会被导出或数据字符串会被附加到文件，并存储在设置选项卡中指定的FTP服务器上。
注意:
  • 当传输条件设置为无（默认）时，每次采集新图像时都会导出数据文件或将数据字符串附加到文件。当传输条件设置为除了“无”以外的其它选项时，每次发生指定事件时都会导出数据文件或将数据字符串附加到文件。譬如，当传输条件设置为Job.Fail，每次作业失败时都会将数据文件导出或将数据字符串附加到文件，并存储在FTP服务器上。
  • 当使用In-Sight模拟器作为FTP服务器时，默认情况下，文件将写入模拟器文件夹（[ProgramData] \ Cognex \ In-Sight \ Emulators \ x.x.x）。同时，文档可以被写入用户自定义的目录 (已授权的 FTP 目录)。有关已授权的 FTP 目录的详情，请参阅可选对话框主题（模拟面板）。

文件选项卡

提供用于定义导出数据、数据格式，数据导出时间和数据导出位置的参数。

已关闭 启用复选框

定义是否可以执行图像导出操作（默认情况下会将其选中），以及是否要将其显示为 EasyView项目（例如，WriteLocal_1.Tool_Enabled），该项目可显示在 VisionView 操作员界面面板上，并且可由操作员进行编辑。

注意:如需启用该选项，选择表格中的启用选项框。这是你在表格中唯一能配置的参数。
已关闭 名称

定义数据导出操作的名称，在配置结果（输入/输出和通信）时会使用该名称；默认名称为“WriteFtp_1”（如果该操作是添加到作业的第一个图像导出操作，否则名称将递增，如“WriteFtp_2”、“WriteFtp_3”等等）。例如，通过给操作指定与其“传输条件”相关联的名称来对其进行自定义。

已关闭 传输条件

指定何时将数据发送到FTP服务器，例如特定工具通过或失败时，或接收到输入信号时。默认情况下，选择“无”，这将确保每次获取图像时都会导出数据，此时“已启用”复选框处于选中状态。如果“已启用”复选框被禁用，或者引用的工具被禁用，则导出操作将不会执行。

已关闭 设备

定义将在设置选项卡中配置的FTP服务器，该服务器将接收导出的数据。默认情况下会选择设备 1。

已关闭 文件类型

指定导出文件的格式：Text、HTML（默认）、XML 或 CSV。

已关闭 写入类型（覆盖或附加）

指定数据写入文件的方式。

  • 覆盖：覆盖文件中的现有数据。
  • 附加（默认）：将数据字符串添加到文件末尾。
已关闭 文件内容/格式字符串按钮

使用格式化字符串对话框指定写入文件的数据。

已关闭 文件名预览

预览导出文件的名称; 默认情况下，显示“文件”。你可以通过配置以下参数来自定义文件名：默认文件名，添加链接和添加时间戳。

注意:
  • 为文件定义至少一个参数。如果默认文件名字段为空，并且未选中添加链接和添加时间戳复选框，则文件导出操作将失败。
  • 参数的顺序不能被更改。
已关闭 默认文件名

指定导出文件的名称; 默认名称为“文件”。支持长文件名。

已关闭 添加链接

指定所选的工具是否会被链接或添加到被导出文件的文件名中。默认情况下，该选项框被禁用。

注意:
  • 如果所选的工具与含有以下无效字符的字符串链接，则导出操作将会失败：<, >, :, ", /, \, |, ? 或 *。
  • 当 EasyBuilder 无法找到任何可以链接的工具时，添加链接选项框会变灰。
  • 如果链接的工具从作业中被删除，则添加链接选项框会被禁用。
  • 当添加链接选项框被启用，请不要在下拉菜单中选择未定义；该选项可能会产生未定义的结果。
已关闭 添加时间戳

指定时间戳是否会被添加到导出图像文件的文件名中。默认情况下，该选项框被禁用。当启用时，可以在下拉菜单中选择预先配置的时间戳格式：MMDDYY, YYYYMMDD_HHMMSS, DDMMYY_HHMMSS, MM-DD-YYYY_HH.MM.SS, HHMMSS, YYMMDD_HHMMSS 或 YYDDMM_HHMMSS。

注意:你可以在日期/时间设置对话框中设置 In-Sight 视觉系统的日期/时间设置。
已关闭 添加按钮

将一个新的导出操作添加到列表。

已关闭 移除按钮

从列表中移除一个导出操作。一次只能移除一个导出操作。

设置选项卡

设置选项卡提供用于定义两个目标设备的参数。目标设备可以是 In-Sight 仿真器，也可以是网络上充当 FTP 服务器的任何其它主机。

已关闭 主机名

定义目标设备的 FTP 服务器的主机名（或 IP 地址）。

注意:
  • 如果指定无效的主机名，则连接可能会在最多 30 秒后超时。

  • 指定“主机名”或“用户名”时，不要在名称前后使用空格。如果“主机名”或“用户名”设置中指定的名称在名称之前或之后包含空格，则图像导出操作将无法将图像写入指定的服务器。

  • 如果还有另一台 PC 安装了 FTP 服务器，也可选择该计算机作为存储位置。请注意，In-Sight 浏览器软件被视为 FTP 服务器。如果要使用第三方 FTP 服务器，则应关闭 In-Sight 浏览器。如果无其它 FTP 服务器正在运行，则 In-Sight 浏览器必须处于运行状态。如果要使用第三方 FTP 服务器，则必须在“主机名”参数中使用该 PC 的 IP 地址。
  • 可通过在主机名（或 IP 地址）后面追加冒号 (:) 和新端口号来更改 FTP 服务器连接端口号。例如，如果当前“主机名”为 PRODUCTION1，则要将默认端口号 (21) 更改为端口 34，需将“主机名”参数更改为：PRODUCTION1:34。
已关闭 用户名

定义目标设备的 FTP 服务器的有效用户名（不得超过 255 个字符）。输出图像文件或数据的In-Sight视觉系统不必存留此名称。

已关闭 密码

定义目标设备的 FTP 服务器的有效密码。密码区分大小写，且长度不能超过 20 个字符。

注意:
  • 出于安全考虑，您输入的密码将在字段中以“*”显示。
  • 密码将以加密形式保存在作业文件中。
已关闭 连接类型

定义图像导出连接类型：标准 FTP（默认选择）、安全 FTP 或 Mitsubishi GOT。安全 FTP 提供安全传输协议，与 SFTP 应用程序配合使用，而 Mitsubishi GOT 则为在 Mitsubishi GOT 终端上显示图像提供支持。

注意:当连接类型参数设置为Mitsubishi GOT时，确保在图像选项卡中的文件格式参数设置为JPG以得到最好的显示结果。
已关闭 FTP 设置按钮

启动“FTP 设置”对话框。

注意:通常无需修改专用本地 In-Sight 网络上的默认设置，在这些网络中，所有 FTP 连接都将在 In-Sight 视觉系统之间进行。但是，如果In-Sight视觉系统与其他网络服务器之间或不同网络上的视觉系统之间需要FTP连接，则可能需要更改默认FTP设置。
已关闭 上次网络错误

显示在导出操作时遇到错误的原因。必须在“文件”选项卡 - 传输条件中指定事件，例如，触发图像，或者您必须将In-Sight视觉系统置于在线状态才能更新此字段。


将图像导出到 SD 卡

您可以配置您的 In-Sight 视觉系统以将图像导出到安装到 In-Sight 视觉系统的 SD 卡上。该设置允许您存储采集的图像（基于工具或作业的通过/失败条件），以便进行存档。此后，可以查看这些图像来帮助您诊断在生产过程中可能遇到的问题。

注意:该功能仅在装有 SD 卡的 In-Sight 视觉系统上受支持。

将图像发送到 SD 卡：

  1. 从通讯组框中选择 SD 卡。
  2. 选择图像选项卡。

  3. 点击添加按钮添加一个条目并配置图像输出参数。

    注意:可以在作业中添加多个图像导出操作。
  4. 将 In-Sight 视觉系统设置到在线状态。视觉系统必须处于“在线”状态才能执行；否则将不会导出图像。

  5. 触发视觉系统以采集图像。对于所采集的每个图像，均会导出一个图像文件（BMP 或 JPG，视文件格式参数而定），并将其存储在视觉系统上的 SD 卡。

    注意:当传输条件设置为无（=默认）时，每次获取新图像时都会导出一个图像文件。当传输条件设置为除了“无”以外的其它选项时，每次发生指定事件时都会导出图像文件。例如，当传输条件被设置为 Job.Fail 时，每次作业失败时都会导出一个图像文件并将其存储到 SD 卡上。

控件

已关闭 启用复选框

定义是否可以执行图像导出操作（默认情况下会将其选中），以及是否要将其显示为 EasyView项目（例如，WriteImageLocal_1.Tool_Enabled），该项目可显示在 VisionView 操作员界面面板上，并且可由操作员进行编辑。

注意:如需启用该选项，选择表格中的启用选项框。这是你在表格中唯一能配置的参数。
已关闭 名称

定义图像导出操作的名称，在配置结果（输入/输出和通信）时会使用该名称；默认名称为“WriteImageLocal_1”（如果该操作是添加到作业的第一个图像导出操作，否则名称将递增，如“WriteImageLocal_2”、“WriteImageLocal_3”等等）。例如，通过给操作指定与其“传输条件”相关联的名称来对其进行自定义。

已关闭 传输条件

定义何时将图像发送到 SD 卡，例如特定工具通过或失败，或是接收到输入时。默认情况下会选择无，这样就确保在选中已启用复选框时，每次采集图像都会导出图像。如果禁用已启用复选框，或禁用所引用的工具，则不会执行导出图像操作。

注意:如果特定图像导出操作的传输条件发生频率很高，如每次图像采集，则 In-Sight 视觉系统的图像队列可能就会填满并阻止导出另外的图像导出操作，从而导致某些图像得不到传输。
已关闭 文件格式

定义导出图像的文件格式：BMP（Windows 位图格式）或 JPG（标准编码 JPEG 格式）。默认情况下会选择 BMP。

已关闭 图像大小

定义导出图像的分辨率：完全、一半或者四分之一。默认情况下会选择完全。

已关闭 包含图形

定义是否为受支持的位置和检测工具创建包含重叠图形数据的 SVG 文件。要查看 SVG 文件和图像文件，应使用支持 SVG 文件类型的 Web 浏览器（如 Microsoft Internet Explorer 9.0）打开 SVG 文件。SVG 文件包含一个与其相关的采集图像的内部链接，当浏览器打开 SVG 文件时，它会通过这个链接打开并显示采集图像和重叠图形。

注意:
  • 如需启用该选项，请在右手边的组框中选择包含图形选项框。包含图形选项框在表格中为只读选项。
  • 启用后，SVG 文件会使用在文件名参数中指定的名称。
  • 当主机名参数在设置选项卡中被设置为 In-Sight 模拟器，则 svg 文件将会被保存到模拟器目录（[ProgramData]\Cognex\In-Sight\Emulators\x.x.x）并在In-Sight 文件栏中显示。
  • 如通过修改显示结果选项对话框中的工具选项，对位置和/或检测工具进行配置，使其隐藏重叠图形，则将无法输出 SVG 图形。默认情况下，所有工具均显示其重叠图形。
  • 由于图形是通过 Web 浏览器等第三方应用程序显示，所以重叠图形数据无法达到准确的像素到像素匹配。
  • In-Sight 固件不能保证传输所有 SVG 和图像文件的匹配对。如果 In-Sight 视觉系统过载，它可能会跳过对 SVG和/或图像文件的传输，以确保不会错过检测和/或图像采集。
已关闭 文件名预览

预览输出图像文件的名称；默认情况下，会显示 Image999。文件名称可以通过配置以下参数来自定义：默认文件名、添加链接、添加时间戳以及添加计数器。

注意:
  • 为图像文件指定至少一个参数。如果默认文件名区域为空白且添加链接、添加时间戳和添加计数器选项框没有被选择，则导出文件操作会失败。
  • 参数的顺序不能被更改。
  • 当添加计数器参数被激活，计数器的最大值将会在文件名预览中显示。
已关闭 默认文件名

定义导出的图像文件的名称；默认名称为“Image”。支持长文件名。

已关闭 添加链接

指定所选的工具是否会被链接或添加到被导出文件的文件名中。默认情况下，该选项框被禁用。

注意:
  • 如果所选的工具与含有以下无效字符的字符串链接，则导出操作将会失败：<, >, :, ", /, \, |, ? 或 *。
  • 当 EasyBuilder 无法找到任何可以链接的工具时，添加链接选项框会变灰。
  • 如果链接的工具从作业中被删除，则添加链接选项框会被禁用。
  • 当添加链接选项框被启用，请不要在下拉菜单中选择未定义；该选项可能会产生未定义的结果。
已关闭 添加时间戳

指定时间戳是否会被添加到导出图像文件的文件名中。默认情况下，该选项框被禁用。当启用时，可以在下拉菜单中选择预先配置的时间戳格式：MMDDYY, YYYYMMDD_HHMMSS, DDMMYY_HHMMSS, MM-DD-YYYY_HH.MM.SS, HHMMSS, YYMMDD_HHMMSS 或 YYDDMM_HHMMSS。

注意:你可以在日期/时间设置对话框中设置 In-Sight 视觉系统的日期/时间设置。
已关闭 添加计数器

指定是否在导出的图像文件名中添加计数器（默认 = 启用）。启用后，可以设置计数器的最大值(0 至 9999999; 默认 = 999)。每次导出一个图像文件，计数器都会逐次递增。当该计数器的值等于最大值时，它就会自动重置；现有的图像文件将会被同名的新文件覆盖。

已关闭 添加按钮

将一个新的导出操作添加到列表。

已关闭 移除按钮

从列表中移除一个导出操作。一次只能移除一个导出操作。

已关闭 重置所有计数器按钮

将每次导出图像操作时添加到图像文件名中的值重置为 000。


导出数据文件或将数据字符串附加到 SD 卡上的文件

您可以配置 In-Sight 视觉系统以导出数据文件或将数据字符串附加到 SD 卡上的文件。使用该功能以记录您在文件中查看的数据结果。

注意:该功能仅在装有 SD 卡的 In-Sight 视觉系统上受支持。

要导出数据或将数据字符串附加到 SD 卡上的文件，请执行以下操作：

  1. 从通信组框中选择 SD 卡。
  2. 选择文件选项卡。

  3. 点击添加按钮添加一个条目并在文件选项卡中配置参数。

    注意:你可以将多个文件导出操作添加到作业。
  4. 将 In-Sight 视觉系统设置到在线状态。视觉系统必须在线执行; 否则，将不会导出数据。

  5. 触发视觉系统。对于每个触发，均会导出数据文件或将数据字符串附加到文件，并存储在安装到视觉系统的 SD 卡上。

    注意:当传输条件设置为无（默认）时，每次获取新图像时，都会导出数据文件或将数据字符串附加到文件。当传输条件设置为除了无以外的其它选项时，每次发生指定事件时都会导出数据文件或将数据字符串附加到文件。例如，当传输条件设置为 Job.Fail，每次作业失败时都会导出数据文件或将数据字符串附加到文件并存储到 SD 卡上。

控件

已关闭 启用复选框

定义是否可以执行图像导出操作（默认情况下会将其选中），以及是否要将其显示为 EasyView项目（例如，WriteLocal_1.Tool_Enabled），该项目可显示在 VisionView 操作员界面面板上，并且可由操作员进行编辑。

注意:如需启用该选项，选择表格中的启用选项框。这是你在表格中唯一能配置的参数。
已关闭 名称

定义图像导出操作的名称，在配置结果（输入/输出和通信）时会使用该名称；默认名称为“WriteLocal_1”（如果该操作是添加到作业的第一个图像导出操作，否则名称将递增，如“WriteLocal_2”、“WriteLocal_3”等等）。例如，通过给操作指定与其“传输条件”相关联的名称来对其进行自定义。

已关闭 传输条件

定义何时将数据发送到 SD 卡，例如特定工具通过或失败，或是接收到输入时。默认情况下，选择“无”，这将确保每次获取图像时都会导出数据，此时“已启用”复选框处于选中状态。如果“已启用”复选框被禁用，或者引用的工具被禁用，则导出操作将不会执行。

已关闭 文件类型

指定导出文件的格式：Text、HTML（默认）、XML 或 CSV。

已关闭 写入类型（覆盖或附加）

指定数据写入文件的方式。

  • 覆盖：覆盖文件中的现有数据。
  • 附加（默认）：将数据字符串添加到文件末尾。
已关闭 文件内容/格式字符串按钮

使用格式化字符串对话框指定写入文件的数据。

已关闭 文件名预览

预览导出文件的名称; 默认情况下，显示“文件”。你可以通过配置以下参数来自定义文件名：默认文件名，添加链接和添加时间戳。

注意:
  • 为文件定义至少一个参数。如果默认文件名字段为空，并且未选中添加链接和添加时间戳复选框，则文件导出操作将失败。
  • 参数的顺序不能被更改。
已关闭 默认文件名

指定导出文件的名称; 默认名称为“文件”。支持长文件名。

已关闭 添加链接

指定所选的工具是否会被链接或添加到被导出文件的文件名中。默认情况下，该选项框被禁用。

注意:
  • 如果所选的工具与含有以下无效字符的字符串链接，则导出操作将会失败：<, >, :, ", /, \, |, ? 或 *。
  • 当 EasyBuilder 无法找到任何可以链接的工具时，添加链接选项框会变灰。
  • 如果链接的工具从作业中被删除，则添加链接选项框会被禁用。
  • 当添加链接选项框被启用，请不要在下拉菜单中选择未定义；该选项可能会产生未定义的结果。
已关闭 添加时间戳

指定时间戳是否会被添加到导出图像文件的文件名中。默认情况下，该选项框被禁用。当启用时，可以在下拉菜单中选择预先配置的时间戳格式：MMDDYY, YYYYMMDD_HHMMSS, DDMMYY_HHMMSS, MM-DD-YYYY_HH.MM.SS, HHMMSS, YYMMDD_HHMMSS 或 YYDDMM_HHMMSS。

注意:你可以在日期/时间设置对话框中设置 In-Sight 视觉系统的日期/时间设置。
已关闭 添加按钮

将一个新的导出操作添加到列表。

已关闭 移除按钮

从列表中移除一个导出操作。一次只能移除一个导出操作。


设备设置

要与其它设备（如机器人或 PLC/MC）之间进行数据通信，必须先定义 In-Sight 传感器的网络和串行通信设置。

  • 与 PLC/Motion Controller 通信
  • 与机器人通信
  • 与 Mitsubishi 设备通信
  • 通过 Modbus TCP 通信
  • 通过 TCP/IP 通信
  • 通过 UDP 通信
  • 通过 POWERLINK 通信
  • 为识别工具输入数据
  • 格式化输出数据
注意:在 EasyBuilder 中，当位置或检测工具的输出无效时，该工具的默认值将被置于输出数据缓冲区中。例如，如果图形位置工具未找到匹配图形，则该工具的 X 和 Y 数据将无效，并被默认设置为 0，然后输出。配置设备以发送输出数据时，建议除发送工具结果外，还应发送工具的“通过/失败”状态，以确保工具的数据有效。要在工具结果无效的情况下更改输出缓冲的默认值，发送以下的 In-Sight 本机模式数据：对于数据，命令为 EV SetSystemConfig("FormatOutputBufferErrData",-1111)，其中“-1111”代表已知错误；对于输出字符串，命令为 EV SetSystemConfig("FormatOutputBufferErrString","Error")，其中“Error”代表错误字符串。

支持的协议

最多可以将两个协议添加到作业中。 添加两个协议时，可以添加一个“主”协议和一个“辅助”协议。 例如，添加 SLMP 扫描仪协议（主）后，再次单击添加设备按钮并添加 TCP / IP 协议（辅助）。

注意:您不能向作业添加两个主协议或两个辅助协议。

In-Sight 固件版本 4.x.x

 | 主协议或 辅助协议 | Micro 1000 系列 | 5000 系列 （除了 5705 和 5705C） | 70xx - 74xx 系列
CC-Link | 主协议 | X | X | X
以太网本机 | 主协议 | X | X | X
以太网本机机器人 | 主协议 | X | X | X
以太网本机字符串 | 主协议 | X | X | X
EtherNet/IP | 主协议 | X | X | X
Modbus TCP 服务器 | 主协议 | X | X | X
POWERLINK | 主协议 |  |  | X
PROFINET | 主协议 | X | X | X
串行 Kuka | 主协议 | X | X | X
串行 Motoman | 主协议 | X | X | X
串行本机 | 主协议 | X | X | X
串行本机机器人 | 主协议 | X | X | X
串行本机字符串 | 主协议 | X | X | X
串行文本 | 主协议 | X | X | X
SLMP | 主协议 | X | X | X
SLMP 扫描 | 主协议 | X | X | X
TCP/IP | 辅助协议 | X | X | X
UDP | 辅助协议 | X | X | X

In-Sight 固件版本 5.x.x

 | 主协议或 辅助协议 | 2000 系列 | 5705 & 5705C | 7000 Gen2 系列 | 8000 系列 | 9000 系列
CC-Link IE Field Basic | 主协议 | X | X | X | X | X
以太网本机 | 主协议 |  | X | X | X | X
以太网本机机器人 | 主协议 |  | X | X | X | X
以太网本机字符串 | 主协议 |  | X | X | X | X
EtherNet/IP | 主协议 | X | X | X | X | X
Modbus TCP 服务器 | 主协议 | X | X | X | X | X
PROFINET | 主协议 | X | X | X | X | X
串行 Kuka | 主协议 |  | X | X | X | X
串行 Motoman | 主协议 |  | X | X | X | X
串行本机 | 主协议 | X（基本） | X | X | X | X
串行本机机器人 | 主协议 |  | X | X | X | X
串行本机字符串 | 主协议 |  | X | X | X | X
串行文本 | 主协议 | X | X | X | X | X
SLMP | 主协议 | X | X | X | X | X
SLMP 扫描 | 主协议 | X | X | X | X | X
TCP/IP | 辅助协议 | X | X | X | X | X
UDP | 辅助协议 | X | X | X | X | X

与 PLC 通信

与机器人通信

与 Mitsubishi 设备通信

通过 Modbus TCP 通信

通过 TCP/IP 通信

通过 UDP 通信

通过 POWERLINK 通信

为识别工具输入数据

格式化输出字符串


与 PLC/Motion 控制器通信

若要与 PLC/MC 通信，首先要执行以下操作:

  1. 在通信组框中，点击添加设备按钮。
  2. 在设备设置组框中，从设备下拉列表中选择 PLC/Motion 控制器。
  3. 从制造商下拉列表中选择 PLC/MC 制造商。如果列表中没有列出您的 PLC/MC 制造商，请选择其它。

  4. 从协议下拉列表中，选择您的通信协议。列出的通信协议取决于所选的制造商。

    注意:DeviceNet 仅在运行 In-Sight 固件版本 4.x.x 版本的 In-Sight 视觉系统上可用，但不能在运行 In-Sight 固件版本 5.1.0 或更新版本的 In-Sight 视觉系统上使用。关于视觉系统型号和支持的固件版本，请参阅固件版本。
  5. 按确定按钮。
  6. （可选）再次点击添加设备按钮以将一个“辅助”协议添加到作业中。有关详情，请参阅设备设置中“支持的协议”部分。

启用这些设置后，配置在设置栏中显示的选项卡。

可用 PLC/Motion 控制器协议

注意:有关支持的协议的完整列表，请参阅设备设置。
  • Modbus TCP 服务器
  • CC-Link
  • SLMP
  • SLMP 扫描
  • EtherNet/IP
  • PROFINET
  • DeviceNet

通过 Modbus TCP 通信

CC-Link 通信

SLMP 通信

SLMP 扫描通信

DeviceNet 串行端口设置


通过 Modbus TCP 通信

您的 In-Sight 传感器可以充当另一个网络 Modbus TCP 设备的 Modbus 服务器。

要将 In-Sight 传感器配置为 Modbus 服务器：

  1. 在通信组框中，按添加设备按钮。
  2. 从设备设置组框中，从设备下拉列表中选择 PLC 或其他。
注意:如果选择 PLC，请从制造商下拉列表中选择 PLC 制造商或其他，以启用 Modbus TCP 服务器作为协议下拉列表中的选项。
  3. 在协议下拉列表中选择 Modbus TCP 服务器。
  4. 点击确认按钮。
  5. 默认情况下会首先显示格式化输出数据选项卡。两个选项卡的控制相同，添加完数据后即启用这些控制。

  6. 按添加按钮启动选择输入数据或选择输出数据对话框（取决于所选的选项卡）。选择输入数据或选择输出数据对话框包含来自添加到作业的任何位置或检测工具的数据以及整个作业结果（仅输出）。在对话框中，选择要通过 Modbus 公开的数据，然后按确定按钮。

  7. 添加数据后，数据将显示在表格中，该表格会显示所选数据的名称、数据类型、大小、值和起始寄存器编号（该数字由 Modbus 客户端的读取和写入命令引用，并指定哪个信号在哪个寄存器中）。表格右侧是 Modbus 寄存器预览窗口，它显示数据如何格式化到 Modbus 寄存器中。

  8. 可以从数据类型下拉列表中选择不同数据类型来自定义默认数据类型。

    注意:
    • 如果从数据类型下拉列表中选择字符串或字节交换字符串，则将启用元素大小（字）控制，您可以通过选择正确的字数来指定字符串长度。
    • Modbus TCP 协议的 EasyBuilder 应用不支持 8 位或无符号数据类型。

  9. 您也可以通过取消选中高字节/低字节复选框（默认情况下为未选中状态）指定低字节优先或高字节优先，来自定义 32 位浮点数和整数的字节顺序。您可以通过取消选中高字符/低字符复选框（默认情况下为未选中状态）指定低字符优先或高字符优先，来自定义 32 位浮点数和整数的字符顺序。任何更改都会在 Modbus 寄存器预览窗口中更新。

    注意:对字节或字的顺序作出的任何更改都将影响格式化输出数据和格式化输入数据选项卡中的所有数据信号。
  10. 通过在列表中选择数据，然后单击上或下按钮设置所需的顺序，可以调整要发送或接收的数据顺序。

  11. 完成 In-Sight 视觉系统的配置后，您需要配置 Modbus 客户端以发送读取和写入命令，这些命令将发送到 In-Sight 视觉系统以读取/写入数据。

    注意:（可选）再次点击添加设备按钮以将一个“辅助”协议添加到作业中。有关详情，请参阅设备设置中“支持的协议”部分。


CC-Link 通信

CC-Link 仅在运行 In-Sight 固件版本 4.x.x 版本的 In-Sight 视觉系统上可用，但不能在运行 In-Sight 固件版本 5.1.0 或更新版本的 In-Sight 视觉系统上使用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

CC-Link 协议用于从与 In-Sight CIO-Micro-CC I/O 模块和 Mitsubishi PLC/Motion Controller 连接的 In-Sight 视觉系统输入和输出数据。CC-Link 的通信将通过 In-Sight CIO-Micro-CC I/O 模块上的 CC-link 连接和 Mitsubishi PLC/MC 上的 CC-Link 连接而建立。

注意:要启用 CC-Link 通信，必须将 In-Sight 视觉系统连接到 In-Sight CIO-Micro-CC I/O 模块。

在将 In-Sight 视觉系统配置为通过 CC-Link 与 Mitsubishi PLC/MC 通信时，首先要在“CC-Link 设置”选项卡中设置参数，然后配置将要从 Mitsubishi PLC/MC 和 In-Sight 视觉系统中传送和接收的数据。

  • 配置 CC-Link 设置选项卡
  • 配置输入位/字数据选项卡和输出位/字数据选项卡

配置 CC-Link 设置选项卡

配置输入位/字数据选项卡和输出位/字数据选项卡


SLMP 通信

SLMP 协议用于从 Mitsubishi PLC/MC/Robot 控制器和 In-Sight 视觉系统传入和传出数据。

首先，在 SLMP设置选项卡中配置参数，该选项卡定义控制器类型，IP地址，端口号以及 Mitsubishi PLC / MC 或机器人控制器的源和目标寄存器，以及超时信息。

然后，对格式化输出数据和格式化输入数据选项卡进行配置，以定义将要从 PLC / MC 传输的工具或作业数据。

注意:In-Sight 2000 系列视觉传感器不支持机器人控制。
  • 配置 SLMP 设置选项卡
  • 配置格式化输出数据及格式化输入数据选项卡

配置 SLMP/MC 协议设置选项卡

配置“格式化输出数据”及“格式化输入数据”选项卡


SLMP 扫描通信

SLMP 扫描用于与 Mitsubishi PLC/运动控制器/机器人控制器和 In-Sight 视觉系统之间传输数据。

首先，在 设置 选项卡配置参数，该选项卡定义与 Mitsubishi PLC / MC 或机器人控制器建立连接所需的连接信息。

然后，配置 设备地址 选项卡，该选项卡定义要传送到 PLC / MC 或机器人控制器的各种数据块的 PLC / MC 或机器人控制器设备地址和大小。

最后，配置 格式化输出数据 和 格式化输入数据 以定义工具以及要从 PLC / 运动控制器或机器人控制器传入或传出的作业数据。

注意:
  • In-Sight 2000 系列视觉传感器不支持机器人控制。
  • Cognex 建议在配置或更改 SLMP 扫描设置后重新启动 In-Sight 视觉系统。

配置“设置”选项卡

配置设备寻址选项卡

配置“格式化输出数据”及“格式化输入数据”选项卡


DeviceNet 串行端口设置

EasyBuilder 会自动默认为标准的 DeviceNet 控制器串行端口设置。如果控制器使用不同的设置，请单击串行端口设置选项卡，然后将 In-Sight 视觉系统配置为使用相同的串行端口设置。在完成通信步骤后，串行端口设置将保存到 In-Sight 视觉系统。

注意:
  • DeviceNet 仅在运行 In-Sight 固件版本 4.x.x 版本的 In-Sight 视觉系统上可用，但不能在运行 In-Sight 固件版本 5.1.0 或更新版本的 In-Sight 视觉系统上使用。关于视觉系统型号和支持的固件版本，请参阅固件版本。
  • DeviceNet 设置需要使用第三方 RS-232-to-DeviceNet 网关适配器。这些设置可用于传统安装，但不应在新应用程序中使用，除非已对 RS-232-to-DeviceNet 网关转换器进行全面测试以检验其是否适用于新应用程序。

  • 串行端口设置选项因 In-Sight 型号和适用的 I / O 模块而异; 如果连接到支持的 I / O 模块，首先单击 I / O 模块按钮打开 I / O 模块配置对话框并配置 I / O 模块。

  • In-Sight Micro 1000 系列视觉系统仅在连接到 CIO-MICRO 或 CIO-MICRO-CC I / O 模块时才支持串行通信。

  • In-Sight 70xx - 74xx 系列视觉系统的串行通信有两种选择：使用分接电缆或使用 CIO-MICRO 或 CIO-MICRO-CC I / O 模块。当连接到分线电缆（并且没有连接到 I / O 模块）时，视觉系统允许一个离散输入线和一个离散输出线分别配置为串行接收和串行发送。有关详细信息，请参阅如何启用 In-Sight 70xx - 74xx 视觉系统的串行通信。
  • 如果将 In-Sight 70xx - 74xx 系列视觉系统配置为与 CIO-MICRO 或CIO-MICRO-CC I / O 模块一起使用，则电源和 I/O 分接电缆上的 RS-232 TRANSMIT 和 RS-232 RECEIVE 管脚将被禁用。使用 I/O 模块的 RS-232 OUT 端口 (DB9) 与串行设备连接。
  • In-Sight 8000 系列视觉系统仅在连接到 CIO-MICRO I / O 模块时才支持串行通信。

  • CIO-WENET I/O 模块不支持串行通信。


与机器人通信

对于视觉引导的机器人应用程序，EasyBuilder 可以通过自动检查应用程序并通过将定位特征（或返回位置数据的另一个定位或检测工具的输出）的输出数据格式化为制造商/协议特定的格式来加速开发过程。一旦字符串被格式化，机器人控制器就可以通过发送一个 In-Sight 本机模式命令来请求数据，该命令将返回字符串中格式化的所有数据。

若要与机器人控制器通信。首先要执行以下操作:

  1. 在通信组框中，按添加设备按钮。
  2. 在设备设置组框中，从设备下拉列表中选择机器人。
  3. 从制造商下拉列表中选择机器人制造商。如果您的机器人制造商没有列出，请选择其他。
  4. 从协议下拉列表中，选择您的通信协议。显示的通信协议取决于所选的制造商。
  5. 点击确认按钮。
  6. （可选）再次点击添加设备按钮以将一个“辅助”协议添加到作业中。有关详情，请参阅设备设置中“支持的协议”部分。

启用这些设置后，你就可以开始定义数据。

  • 机器人以太网本机通信
  • 机器人串行本机通信
  • 机器人串行 Kuka 通信
  • 机器人串行 Motoman 通信
  • 机器人以太网 IP 通信 (FANUC 机器人控制)

机器人以太网本机通信

机器人串行本机通信

机器人串行 Kuka 通信

机器人串行 Motoman 通信

机器人以太网 IP 通信 (FANUC)


机器人以太网本机通信

注意:这些步骤只在选择机器人作为设备，以及选择以太网本机作为设备设置组框中的协议时才适用。
  1. 选择以太网本机作为协议后，EasyBuilder 会自动在定义定位特征并生成代表定位特征的数据字符串的任何位置或检查工具中搜索您的作业。
  2. 在格式化输出字符串选项卡中，生成定位特征的任何工具都将在位置名称下拉列表中列出。如果作业只包含一个返回位置数据的工具，则在默认情况下将选择该工具。否则，从位置名称下拉列表中选择您想发送其输出字符串的工具。将显示格式化字符串以及字符串中的字符数，仅作参考。
  3. 由于已格式化了字符串，机器人控制器可能会通过发送 In-Sight 本机模式命令 EV GetCellValue("Job.Robot.FormatString") 请求数据。EV GetCellValue("Job.Robot.FormatString") 通过一个命令便返回在字符串中格式化的所有数据。有关更多信息，请参阅 In-Sight® 浏览器帮助文件。
注意:如果您未在作业中定义定位特征，或者想要创建自定义字符串或自定义字符串格式，则可按自定义格式...按钮，启动“FormatString”对话框。在该对话框中，您可以添加不同的字符串、修改字符串和/或通过从列表中选择数据，然后单击上或下按钮设置您所需的顺序来重新排列要发送的数据顺序。在完成字符串修改后，按确定按钮。


机器人串行本机通信

注意:这些步骤仅适用于选择机器人作为设备，并且在通信部分中选择串行本机作为协议时才适用。
  1. 选择串行本机 作为协议后，EasyBuilder 将自动搜索您的作业中指定定位特征的任何位置或检测工具，并生成代表定位特征的数据字符串。
  2. 在格式化输出字符串选项卡中，生成定位特征的任何工具都将在位置名称下拉列表中列出。如果你的作业只包含一个返回位置数据的工具，则在默认情况下将选择该工具。否则，在位置名称下拉列表中选择要发送输出字符串的工具。将显示格式化字符串以及字符串中的字符数，仅作参考。

  3. 如有必要，请单击串行端口设置选项卡以指定串行通信设置。EasyBuilder 会根据设备设置选项自动确定串行协议。在完成通信步骤后，串行端口设置将保存到视觉系统。

    注意:

    • 串行端口设置选项因 In-Sight 型号和适用的 I / O 模块而异; 如果连接到支持的 I / O 模块，首先单击 I / O 模块按钮打开 I / O 模块配置对话框并配置 I / O 模块。

    • In-Sight Micro 1000 系列视觉系统仅在连接到 CIO-MICRO 或 CIO-MICRO-CC I / O 模块时才支持串行通信。

    • In-Sight 70xx - 74xx 系列视觉系统的串行通信有两种选择：使用分接电缆或使用 CIO-MICRO 或 CIO-MICRO-CC I / O 模块。当连接到分线电缆（并且没有连接到 I / O 模块）时，视觉系统允许一个离散输入线和一个离散输出线分别配置为串行接收和串行发送。有关详细信息，请参阅如何启用 In-Sight 70xx - 74xx 视觉系统的串行通信。
    • 如果将 In-Sight 70xx - 74xx 系列视觉系统配置为与 CIO-MICRO 或CIO-MICRO-CC I / O 模块一起使用，则电源和 I/O 分接电缆上的 RS-232 TRANSMIT 和 RS-232 RECEIVE 管脚将被禁用。使用 I/O 模块的 RS-232 OUT 端口 (DB9) 与串行设备连接。
    • In-Sight 8000 系列视觉系统仅在连接到 CIO-MICRO I / O 模块时才支持串行通信。

    • CIO-WENET I/O 模块不支持串行通信。

  4. 既然已格式化了字符串，机器人控制器就可以通过发送 In-Sight 本机模式命令 EV GetCellValue("Job.Robot.FormatString") 来请求数据了。EV GetCellValue("Job.Robot.FormatString") 通过单个命令便返回在字符串中格式化的所有数据。
注意:如果您未在作业中定义定位特征，或者想要创建自定义字符串或自定义字符串格式，则可按自定义格式...按钮，启动“FormatString”对话框。在该对话框中，您可以添加不同的字符串、修改字符串和/或通过从列表中选择数据，然后单击上或下按钮设置您所需的顺序来重新排列要发送的数据顺序。在完成字符串修改后，按确定按钮。


机器人串行 Kuka 通信

Kuka 机器人控制器通过 RS-232 串行端口，使用复杂但功能强大的错误检查协议与其它设备进行通信。在为 Kuka 串行通信完成配置后，In-Sight 视觉系统能识别此协议，并且能够响应从 Kuka 控制器收到的命令。

注意:
  • Kuka 机器人必须为 P3964R 模式才能与 In-Sight 视觉系统通信，而且视觉系统必须为串行 Kuka 模式，如下所述。
  • In-Sight 视觉系统被配置为使用 Kuka 的默认协议设置（即，在执行操作时，Kuka 机器人为高优先级，而视觉系统为低优先级）。

  1. 选择 Serial Kuka 作为协议之后，EasyBuilder 将自动搜索您的作业中指定的定位特征的任何位置或检测工具，并生成代表定位特征的数据字符串。生成定位特征的任何工具都将出现在位置名称下拉列表中。如果你的作业只包含一个返回位置数据的工具，则在默认情况下将选择该工具。否则，在位置名称下拉列表中选择要发送输出字符串的工具。将显示格式化字符串以及字符串中的字符数，仅作参考。此外还包括编码位置字段，当发出 In-Sight 本机模式命令GV[EncodedLocation] 时，显示 Kuka 机器人控制器将要引用的数据。

    注意:如果您未在作业中定义定位特征，或者想要创建自定义字符串或自定义字符串格式，则可按自定义格式...按钮，启动“FormatString”对话框。在该对话框中，您可以添加不同的字符串、修改字符串和/或通过从列表中选择数据，然后单击上或下按钮设置您所需的顺序来重新排列要发送的数据顺序。在完成字符串修改后，按确定按钮。

  2. EasyBuilder 在默认情况下会自动使用标准的 Kuka 控制器串行端口设置。如果控制器使用不同的设置，请单击串行端口设置选项卡，然后将 In-Sight 视觉系统配置为使用相同的串行端口设置。在完成通信步骤后，串行端口设置将保存到 In-Sight 视觉系统。

    注意:
    • 支持 Kuka KR C2 和 KR C2 Edition 2005 机器人控制器。

    • 串行端口设置选项因 In-Sight 型号和适用的 I / O 模块而异; 如果连接到支持的 I / O 模块，首先单击 I / O 模块按钮打开 I / O 模块配置对话框并配置 I / O 模块。

    • In-Sight Micro 1000 系列视觉系统仅在连接到 CIO-MICRO 或 CIO-MICRO-CC I / O 模块时才支持串行通信。

    • In-Sight 70xx - 74xx 系列视觉系统的串行通信有两种选择：使用分接电缆或使用 CIO-MICRO 或 CIO-MICRO-CC I / O 模块。当连接到分线电缆（并且没有连接到 I / O 模块）时，视觉系统允许一个离散输入线和一个离散输出线分别配置为串行接收和串行发送。有关详细信息，请参阅如何启用 In-Sight 70xx - 74xx 视觉系统的串行通信。
    • 如果将 In-Sight 70xx - 74xx 系列视觉系统配置为与 CIO-MICRO 或CIO-MICRO-CC I / O 模块一起使用，则电源和 I/O 分接电缆上的 RS-232 TRANSMIT 和 RS-232 RECEIVE 管脚将被禁用。使用 I/O 模块的 RS-232 OUT 端口 (DB9) 与串行设备连接。
    • In-Sight 8000 系列视觉系统仅在连接到 CIO-MICRO I / O 模块时才支持串行通信。

    • CIO-WENET I/O 模块不支持串行通信。

  3. Kuka 机器人控制器通过发送 In-Sight 本机模式命令，在其自身和 In-Sight 视觉系统之间启动所有数据通信。GV[EncodedLocation] 命令将返回在这些步骤中所配置的字符串，且应与 EasyBuilder 中开发的所有作业一起使用。

Serial Kuka 是 In-Sight 本机模式通信的扩展。由于 Serial Kuka 基于本机模式，所以 In-Sight 视觉系统的作业可以在本机模式下开发和测试，然后仅当实际的机器人控制器连接到视觉系统时，才切换到 Serial Kuka。不需要对作业进行其它更改。

已关闭 支持 Serial Kuka 通信的 In-Sight 本机模式命令：
本机模式命令 | 语法
获取作业 | GJ
联机获取 | GO
获取值 | GV[EncodedLocation]
获取值 | GV [符号名称]
加载文件 | LF[Filename]
设置事件 | SE[Int]
存储文件 | TF[Filename]
设置浮点型 | SF [符号名称][浮动值]
设置整型 | SI [符号名称][整数值]
设置作业 | SJ[ID]
联机设置 | SO [整数值]
设置字符串 | SS [符号名称][字符串]


机器人串行 Motoman 通信

Motoman MRC、MRC-II 和 XRC 机器人控制器通过 RS-232 串行端口，使用复杂但功能强大的错误检查协议与其他设备进行通信。在配置为 Motoman 串行通信后，In-Sight 视觉系统能识别此协议，并且能够响应从 Motoman 控制器收到的命令。

注意:
  • Motoman 控制器必须配置以 DCI 模式进行通信。当前不支持从 In-Sight 视觉系统向在主机模式下运行的 Motoman 机器人控制器发起的通信。
  • 尽管 Motoman 控制器为流量控制指定了“无”，但在与 Motoman 控制器通信时，In-Sight 视觉系统仍需要“硬件”流量控制（硬件信息互换)。
  • 只有 Motoman XRC 控制器已经过测试。
  • 由于串行 Motoman 基于本机模式，因此 In-Sight 作业可以在本机模式下开发和测试，然后仅当实际的机器人控制器连接到视觉系统时，才切换到串行 Motoman。不需要对作业进行其它更改。

  1. 选择串行Motoman 作为协议后，EasyBuilder 将自动搜索您的作业中指定定位特征的任何位置或检测工具，并生成代表定位特征的数据字符串。

    注意:如果您未在作业中定义定位特征，或者想要创建自定义字符串或自定义字符串格式，则可按自定义格式...按钮，启动“FormatString”对话框。在该对话框中，您可以添加不同的字符串、修改字符串和/或通过从列表中选择数据，然后单击上或下按钮设置您所需的顺序来重新排列要发送的数据顺序。在完成字符串修改后，按确定按钮。
  2. 在格式化输出字符串选项卡中，生成定位特征的任何工具都将在位置名称下拉列表中列出。如果你的作业只包含一个返回位置数据的工具，则在默认情况下将选择该工具。否则，在位置名称下拉列表中选择要发送输出字符串的工具。将显示格式化字符串以及字符串中的字符数，仅作参考。
  3. 编码位置字段显示 Motoman 机器人控制器为检索视觉系统数据而使用的 CC + RRR 数据。

  4. EasyBuilder 会自动默认为标准的 Motoman 控制器串行端口设置。如果控制器使用不同的设置，请单击串行端口设置选项卡，然后将 In-Sight 视觉系统配置为使用相同的串行端口设置。在完成通信步骤后，串行端口设置将保存到 In-Sight 视觉系统。

    注意:

    • 串行端口设置选项因 In-Sight 型号和适用的 I / O 模块而异; 如果连接到支持的 I / O 模块，首先单击 I / O 模块按钮打开 I / O 模块配置对话框并配置 I / O 模块。

    • In-Sight Micro 1000 系列视觉系统仅在连接到 CIO-MICRO 或 CIO-MICRO-CC I / O 模块时才支持串行通信。

    • In-Sight 70xx - 74xx 系列视觉系统的串行通信有两种选择：使用分接电缆或使用 CIO-MICRO 或 CIO-MICRO-CC I / O 模块。当连接到分线电缆（并且没有连接到 I / O 模块）时，视觉系统允许一个离散输入线和一个离散输出线分别配置为串行接收和串行发送。有关详细信息，请参阅如何启用 In-Sight 70xx - 74xx 视觉系统的串行通信。
    • 如果将 In-Sight 70xx - 74xx 系列视觉系统配置为与 CIO-MICRO 或CIO-MICRO-CC I / O 模块一起使用，则电源和 I/O 分接电缆上的 RS-232 TRANSMIT 和 RS-232 RECEIVE 管脚将被禁用。使用 I/O 模块的 RS-232 OUT 端口 (DB9) 与串行设备连接。
    • In-Sight 8000 系列视觉系统仅在连接到 CIO-MICRO I / O 模块时才支持串行通信。

    • CIO-WENET I/O 模块不支持串行通信。

  5. Motoman 机器人控制器通过发送 In-Sight 本机模式命令，在其自身和视觉系统之间启动所有数据通信。GV[EncodedLocation] 命令将返回在这些步骤中所配置的字符串，且应与 EasyBuilder 中开发的所有作业一起使用。

串行 Motoman 是 In-Sight 本机模式通信的扩展。Motoman 机器人控制器只通过其 RS-232 端口发送数字文本; 无法发送标准 In-Sight Native 模式命令。相反，Motoman 控制器必须将本机模式命令的数字表示法发送至视觉系统，必要时可附加其它参数。


机器人以太网 IP 通信 (FANUC)

In-Sight 视觉系统可以配置成通过 EtherNet/IP (EIP) 与 FANUC 机器人控制器进行通信。

  1. 在选择机器人作为设备、FANUC 作为生产商以及以太网 IP 机器人作为协议之后，EasyBuilder 会自动在你的作业中搜索所有包含定位特征的定位或检测工具，并生成代表定位特征的数据字符串。

    注意:
    • 要为 FANUC 机器人控制器配置以太网 IP 机器人通信，你必须先从制造商下拉列表中选择 FANUC。 如果你在生产商下拉菜单中选择了其它，则 EasyBuilder 会显示其它设备的 Ethernet/IP 设置。
    • 如果使用以太网本机机器人或串行本机机器人协议与 FAUNC 机器人控制器通信，请参阅机器人以太网本机通信话题或机器人串行本机通信话题。
  2. 在格式化输出数据选项卡中，生成定位特征的任何工具都将在位置名称下拉列表中列出。 如果你的作业只包含一个返回位置数据的工具，默认情况下该工具将被选择。 否则，在位置名称下拉列表中选择要发送输出字符串的工具。 作为参考，会显示输出缓冲字符串以及消息的大小（以字节为单位）。
注意:有关 FANUC 机器人控制器的详细信息，请参阅 In-Sight® Explorer 帮助文件中的机器人通信 - FANUC 机器人控制器话题。


与 Mitsubishi 设备通信

Mitsubishi PLC/ Motion Controller (MC)：CC-Link、CC-Link IE Field Basic、SLMP 和 SLMP扫描

若要与 Mitsubishi PLC/MC 通信，首先要执行以下操作：

  1. 在通信组框中，按添加设备按钮。
  2. 在设备设置组框中，从设备下拉列表中选择 PLC/Motion 控制器。
  3. 从制造商下拉列表中选择 Mitsubishi。

  4. 从协议下拉列表中，选择您的通信协议：CC-Link、 CC-Link IE Field Basic、SLMP或SLMP扫描。

    注意:CC-Link 仅在运行 In-Sight 固件版本 4.x.x 版本的 In-Sight 视觉系统上可用，但不能在运行 In-Sight 固件版本 5.1.0 或更新版本的 In-Sight 视觉系统上使用。关于视觉系统型号和支持的固件版本，请参阅固件版本。
  5. 点击确认按钮。
  6. （可选）再次点击添加设备按钮以将一个“辅助”协议添加到作业中。有关详情，请参阅设备设置中“支持的协议”部分。

启用这些设置后，可以配置与 Mitsubishi PLC/MC 设备通信的设置：

  • CC-Link
  • CC-Link IE Field Basic
  • SLMP
  • SLMP 扫描
注意:当 In-Sight 视觉系统配置为通过 SLMP、SLMP 扫描或 CC-Link 与 PLC / MC 通信时，协议仅支持视觉系统和 PLC/MC 之间的数据传输。

Mitsubishi 机器人控制器 - 以太网本地字符串、串行本机字符串、SLMP 和 SLMP扫描

注意:In-Sight 2000 系列视觉传感器不支持机器人控制。

若要与 Mitsubishi 机器人通信。首先要执行以下操作:

  1. 在通信组框中，按添加设备按钮。
  2. 在设备设置组框中，从设备下拉列表中选择机器人。
  3. 从制造商下拉列表中选择 Mitsubishi。
  4. 从协议下拉列表中，选择您的通信协议：Ethernet Native String、Serial Native String、SLMP 或 SLMP 扫描。
  5. 点击确定按钮。
  6. （可选）再次点击添加设备按钮以将一个“辅助”协议添加到作业中。有关详情，请参阅设备设置中“支持的协议”部分。

启用这些设置后，就可以配置 In-Sight 视觉系统和机器人之间进行通信的数据：

  • 配置 Mitsubishi 以太网本机字符串通信
  • 配置 Mitsubishi 串行本机字符串通信
  • SLMP
  • SLMP 扫描

CC-Link 通信

CC-Link IE Field 网络基本通信

SLMP/MC 协议通信

SLMP/MC 扫描协议通信

配置 Mitsubishi 以太网本机字符串机器人通信

配置 Mitsubishi 串行本机字符串机器人通信


配置 CC-Link 设置选项卡

CC-Link 设置选项卡用于配置 In-Sight CIO-Micro-CC I/O 模块，以在 CC-Link 网络上进行通信。

注意:如果未连接到 In-Sight CIO-Micro-CC I/O 模块，则会禁用所有控制，直到此连接问题得以解决。
已关闭 启用

定义是启用还是禁用 In-Sight CIO-Micro-CC I/O 模块上的 CC-Link 接口。默认情况下会选中启用复选框，从而启用 In-Sight CIO-Micro-CC I/O 模块上的 CC-Link 接口。假如需要，可取消选中启用复选框以诊断和调试 CC-Link 连接。

已关闭 版本

定义 CC-Link 规范兼容性，V1 或 V2。默认情况下会选择 V1。

已关闭 波特率

定义 CC-Link 网络的 CC-Link 波特率，10M、5M、2.5M、625k、156k。默认情况下会选择 10M。

已关闭 工作站编号

定义 CC-Link 从站的编号，从 1 到 64。默认情况下会选择 1。

注意:在工作站编号和工作站数参数中分配的值不能超过 64。
已关闭 工作站数

定义 In-Sight CIO-Micro-CC I/O 模块在 CC-Link 网络上占用的工作站数，从 1 到 4。默认情况下会选择 1。

注意:在工作站编号和工作站数参数中分配的值不能超过 64。
已关闭 扩展周期

定义 In-Sight CIO-Micro-CC I/O 模块在 CC-Link 网络上利用的扩展周期数，1X（已禁用）、2X、4X 或 8X。默认情况下会选择 1X（已禁用）。

注意:仅当版本参数设置为 V2 时，此选项才可用。
已关闭 输入

分别显示输入位缓冲区和输入字缓冲区中可用的位数和字数。

要确定输入缓冲区中可用的位数：

  • 当版本参数设置为 V1 时：32 x (工作站数) - 16
  • 当版本参数设置为 V2 且扩展周期参数设置为 1X（已禁用）时：32 x (工作站数) - 16
  • 当版本参数设置为 V2 且扩展周期参数启用时：32 x (工作站数) x (扩展周期) - 16 x (扩展周期) - 16

要确定输入缓冲区中可用的字数：

  • 当版本参数设置为 V1 时：4 x (工作站数)
  • 当版本参数设置为 V2 且扩展周期参数设置为 1X（已禁用）时：4 x (工作站数)
  • 当版本参数设置为 V2 且扩展周期参数启用时：4 x (工作站数) x (扩展周期)
已关闭 输出

分别显示输出位缓冲区和输出字缓冲区中可用的位数和字数。

要确定输出缓冲区中可用的位数：

  • 当版本参数设置为 V1 时：32 x (工作站数) - 16
  • 当版本参数设置为 V2 且扩展周期参数设置为 1X（已禁用）时：32 x (工作站数) - 16
  • 当版本参数设置为 V2 且扩展周期参数启用时：32 x (工作站数) x (扩展周期) - 16 x (扩展周期) - 16

要确定输出缓冲区中可用的字数：

  • 当版本参数设置为 V1 时：4 x (工作站数)
  • 当版本参数设置为 V2 且扩展周期参数设置为 1X（已禁用）时：4 x (工作站数)
  • 当版本参数设置为 V2 且扩展周期参数启用时：4 x (工作站数) x (扩展周期)


配置输入位/字数据选项卡和输出位/字数据选项卡

在配置 CC-Link 设置选项卡之后，您将需要配置输入位数据、输入字数据、输出位数据及输出字数据选项卡，这些选项卡用于定义将通过 CC-Link 网络传输到 Mitsubishi PLC/MC 和 In-Sight 视觉系统以及从中传输的工具或作业数据。

已关闭 配置“输入位数据”选项卡

输入位数据选项卡用于将位偏移与被位置或检查工具结果、采集数据或输入所返回的布尔数据类型关联。每个作业最多可以定义 32 个输入。

  1. 单击输入位数据选项卡以开始配置将从 PLC/MC 传输到 In-Sight 视觉系统的数据。
  2. 按添加按钮以启动选择输入数据对话框，其中包含来自作业（如任何添加到作业的位置或检查工具）的数据、采集数据和输入。选择要从 PLC/MC 传输到 In-Sight 视觉系统中的数据，然后按确定按钮。
  3. 一旦添加了数据，该数据就会出现在表格中，显示设备地址、输入名称及其数据类型、大小和值。
  4. 通过从列表中选择数据，然后单击上或下按钮设置所需的顺序，可以调整要发送或接收的数据顺序。
已关闭 配置“输入字数据”选项卡

“输入字数据”选项卡用于定义由定位或检测工具结果、采集数据或输入返回的 In-Sight 视觉系统的输入。每个作业最多可以定义 32 个输入。

注意:字的数目不能超过在 CC-Link 设置选项卡中配置的参数所设置的限制。
  1. 单击输入字数据选项卡以开始配置将从 PLC/MC 传输到 In-Sight 视觉系统的数据。
  2. 按添加按钮以启动选择输入数据对话框，其中包含来自作业（如任何添加到作业的位置或检查工具）的数据、采集数据和输入。选择要从 PLC/MC 传输到 In-Sight 视觉系统中的数据，然后按确定按钮。
  3. 一旦添加了数据，该数据就会出现在表格中，显示设备地址（地址的开头为字段偏移，以字为单位）、输入名称及其数据类型、大小和值。

  4. 可以从数据类型下拉列表中选择不同数据类型来自定义默认数据类型。

    注意:
    • 如果从数据类型下拉列表中选择字符串，则会启用元素大小（字）控制，且您可以通过选择正确的字数（最大为 128）来指定字符串长度。
    • CC-Link 的 EasyBuilder 实现不支持 8 位或无符号数据类型。
  5. 通过从列表中选择数据，然后单击上或下按钮设置所需的顺序，可以调整要发送或接收的数据顺序。
已关闭 配置“输出位数据”选项卡

输出位数据选项卡用于将位偏移关联到位置或检查工具结果、采集数据或作业结果所返回的布尔数据类型。每个作业至少可定义 64 个输出（可以添加更多输出；最大限制取决于作业的大小）。

  1. 单击输出位数据选项卡以开始配置将从 In-Sight 视觉系统传输到 PLC/MC的数据。
  2. 点击添加按钮来启动选择输出数据对话框，该对话框中包含作业中的数据，例如添加到作业的任何位置或检测工具，采集数据以及整体作业结果。选择要从 PLC/MC传输到 In-Sight 视觉系统中的数据，然后按确定按钮。
注意:默认情况下会自动将 Job.Inspection_Count 数据符号添加到输出数据表。此符号会提醒 PLC/MC，In-Sight 视觉系统已采集了新图像并且已有一组新的检查结果到来。如果该符号对于应用程序不是必需的，可将其移除。
  3. 一旦添加了数据，该数据就会出现在表格中，显示名称、数据类型、大小、值以及所选数据的起始寄存器编号。表格右侧是寄存器预览窗口，它显示如何将数据格式化到PLC/MC寄存器中。
  4. 通过从列表中选择数据，然后单击上或下按钮设置所需的顺序，可以调整要发送或接收的数据顺序。
已关闭 配置“输出字数据”选项卡

输出字数据选项卡用于定义被位置或检查工具结果、采集数据或作业结果返回的In-Sight视觉系统中的输出。每个作业至少可定义32个输出（可以添加更多输出；最大限制取决于作业的大小）。

  1. 单击输出位数据选项卡以开始配置将从 In-Sight 视觉系统传输到 PLC/MC的数据。
  2. 点击添加按钮来启动选择输出数据对话框，该对话框中包含作业中的数据，例如添加到作业的任何位置或检测工具，采集数据以及整体作业结果。选择要从 PLC/MC传输到 In-Sight 视觉系统中的数据，然后按确定按钮。
注意:默认情况下会自动将 Job.Inspection_Count 数据符号添加到输出数据表。此符号会提醒 PLC/MC，In-Sight 视觉系统已采集了新图像并且已有一组新的检查结果到来。如果该符号对于应用程序不是必需的，可将其移除。
  3. 一旦添加了数据，该数据就会出现在表格中，显示名称、数据类型、大小、值以及所选数据的起始寄存器编号（地址的开头为字段偏移，以字为单位）。表格右侧是寄存器预览窗口，它显示如何将数据格式化到PLC/MC寄存器中。

  4. 可以从数据类型下拉列表中选择不同数据类型来自定义默认数据类型。

    注意:
    • 如果从数据类型下拉列表中选择字符串，则会启用元素大小（字）控制，且您可以通过选择正确的字数（最大为 128）来指定字符串长度。
    • CC-Link 的 EasyBuilder 实现不支持 8 位或无符号数据类型。
  5. 通过从列表中选择数据，然后单击上或下按钮设置所需的顺序，可以调整要发送或接收的数据顺序。


CC-Link IE Field 网络基本通信

CC-Link IE Field Basic 是为了将以太网设备集成到Mitsubishi自动化控制器中而设计的协议。与现有的 SLMP（MC 协议）不同，Mitsubishi自动化控制器将作为主设备，通过标准UDP消息与子设备进行通信。该通信在每个子设备上支持4个站，每个站上的每个方向支持64位和32位、16位字节的数据。该数据通过Mitsubishi设置工具（GXWorks 2/3）对应到控制器存储器中。

注意:有关更多信息，请参阅 In-Sight® 浏览器帮助文件。详细信息也可在Mitsubishi的CC-Link IE Field 网络基本参考手册中找到。
  • 配置格式化输入位/字数据选项卡和格式化输出位/字选项卡（CC-Link IE Field Basic）

配置格式化输入位/字数据选项卡和格式化输出位/字选项卡（CC-Link IE Field Basic）


配置格式化输入位/字数据选项卡和格式化输出位/字选项卡（CC-Link IE Field Basic）

格式化输入位数据，格式化输入字数据，格式化输出位数据和格式化输出字数据选项卡用于定义通过CC-Link IE Field Basic协议在Mitsubishi PLC / MC和In-Sight视觉系统间传输或接收的工具或作业数据 。

注意:
  • 在本主题中，输入指的是输入到In-Sight视觉系统，输出指的是从视觉系统的输出。
  • 有关更多信息，请参阅 In-Sight® 浏览器帮助文件。
选项卡 | PLC存储空间 | 开始偏移值 | 大小限制 （当占用站1时） | 数据类型
格式化输入位数据 | RY | 32 | 32 | 位
格式化输入字数据 | RWw | 2 | 30 | 64 位字
格式化输出位数据 | RX | 32 | 32 | 位
格式化输出字数据 | RWr | 5 | 27 | 64 位字
已关闭 配置格式化输入位数据选项卡

格式化输入位数据选项卡用于将位偏移值和由定位或检测工具结果、采集数据或输入返回的波尔数据类型相关联。每个作业最多可以定义32个输入。

  1. 点击格式化输入位数据选项卡以开始配置将从PLC / MC传输到In-Sight视觉系统的数据。
  2. 按添加按钮启动选择输入数据对话框，该对话框中包含作业中的数据，例如添加到作业的任何位置或检测工具、采集数据和输入。选择要从PLC/MC传输到In-Sight视觉系统的数据，然后点击确认按钮。
  3. 添加数据后，数据将显示在表格中。该表格会显示所选数据的设备地址、输入名称、数据类型、大小和值。
  4. 通过在列表中选择数据，然后单击上或下按钮设置所需的顺序，可以调整要发送或接收的数据顺序。
已关闭 配置格式化输入字数据类型选项卡

格式化输入字数据选项卡可被用来定义由定位或检测工具结果、采集数据或输入返回的In-Sight视觉系统的输入。每个作业最多可以定义30个输入。

  1. 点击格式化输入字数据选项卡以开始配置将从PLC / MC传输到In-Sight视觉系统的数据。
  2. 按添加按钮启动选择输入数据对话框，该对话框中包含作业中的数据，例如添加到作业的任何位置或检测工具、采集数据和输入。选择要从PLC/MC传输到In-Sight视觉系统的数据，然后点击确认按钮。
  3. 添加数据后，数据将显示在表格中。该表格会显示设备地址（地址的开头是字段偏移值、以字为单位），输入名称，数据类型，大小和值。

  4. 可以从数据类型下拉列表中选择不同数据类型来自定义默认数据类型。

    注意:
    • 如果从数据类型下拉列表中选择字符串，则会启用元素大小（字）控制，且您可以通过选择正确的字数（最大为 128）来指定字符串长度。
    • CC-Link 的 EasyBuilder 应用不支持8位或未指定数据类型。
  5. 通过在列表中选择数据，然后单击上或下按钮设置所需的顺序，可以调整要发送或接收的数据顺序。
已关闭 配置格式化输出字数据选项卡

格式化输出位数据选项卡用于将位偏移值与定位或检测工具结果、采集数据或作业结果返回的布尔数据类型相关联。每个作业最多可以定义32个输出。

  1. 单击格式输出位数据选项卡以开始配置将从In-Sight视觉系统传输到PLC / MC的数据。
  2. 点击添加按钮来启动选择输出数据对话框，该对话框中包含作业中的数据，例如添加到作业的任何位置或检测工具，采集数据以及整体作业结果。选择要从In-Sight视觉系统传输到PLC/MC的数据，然后点击确认按钮。
注意:默认情况下，Job.Inspection_Count数据符号会被自动添加到输出数据表中。此符号会提醒 PLC/MC，In-Sight 视觉系统已采集了新图像并且已有一组新的检查结果到来。如果该符号对于应用程序不是必需的，可将其移除。
  3. 添加数据后，数据将显示在表格中。该表格会显示所选数据的名称，数据类型，大小，值和起始寄存器编号。在表格的右侧是一个寄存器预览窗口，它将显示如何将数据格式化到 PLC / MC 寄存器的格式。
  4. 通过在列表中选择数据，然后单击上或下按钮设置所需的顺序，可以调整要发送或接收的数据顺序。
已关闭 配置格式化输出字数据选项卡

格式化输出字数据选项卡用于定义由定位或检测工具结果、采集数据或作业结果返回的In-Sight视觉系统的输出。每个作业最多可定义27个输出。

  1. 单击格式输出位数据选项卡以开始配置将从In-Sight视觉系统传输到PLC / MC的数据。
  2. 点击添加按钮来启动选择输出数据对话框，该对话框中包含作业中的数据，例如添加到作业的任何位置或检测工具，采集数据以及整体作业结果。选择要从In-Sight视觉系统传输到PLC/MC的数据，然后点击确认按钮。
注意:默认情况下，Job.Inspection_Count数据符号会被自动添加到输出数据表中。此符号会提醒 PLC/MC，In-Sight 视觉系统已采集了新图像并且已有一组新的检查结果到来。如果该符号对于应用程序不是必需的，可将其移除。
  3. 添加数据后，数据将显示在表格中。该表格会显示所选数据的名称、数据类型、大小、值和起始寄存器编号（地址的开头是字段偏移值、以字为单位）。在表格的右侧是一个寄存器预览窗口，它将显示如何将数据格式化到 PLC / MC 寄存器的格式。

  4. 可以从数据类型下拉列表中选择不同数据类型来自定义默认数据类型。

    注意:
    • 如果从数据类型下拉列表中选择字符串，则会启用元素大小（字）控制，且您可以通过选择正确的字数（最大为 128）来指定字符串长度。
    • CC-Link IE Field Basic 的 EasyBuilder 应用不支持8位或未指定数据类型。
  5. 通过在列表中选择数据，然后单击上或下按钮设置所需的顺序，可以调整要发送或接收的数据顺序。


配置 SLMP 设置选项卡

SLMP 设置选项卡用于配置 PLC / MC 或机器人控制器的控制器类型和 IP 地址、TCP 端口号、超时以及 PLC / MC 或机器人控制器的源和目标寄存器位置。

注意:

根据设备设置组框中的所选设备，设置选项卡中的可用控制器类型会有所不同。 有关更多信息，请参阅与 Mitsubishi 设备通信。

已选设备（设备设置组框） 可用控制器类型（设置选项卡）
PLC/Motion 控制器
  • iQ-R/Q/L 系列 (3E Frame)
  • iQ-F 系列 (3E Frame)
  • FX 系列 (1E Frame)
机器人控制器
  • CR-800D 系列 (3E Frame)
已关闭 控制器类型

指定要与之通信的 Mitsubishi PLC/MC 或机器人控制器的类型

  • PLC/MC：iQ-R / Q / L系列（3E机架），iQ-F系列（3E机架）或FX系列（1E机架）。 默认= iQ-R / Q / L系列（3E Frame）。

    注意:运行 In-Sight 4.x.x 固件的 In-Sight 视觉系统不提供 iQ-F 系列（3E机架）选项。
  • 机器人控制器：CR800-D系列（3E机架）
已关闭 IP 地址

指定 Mitsubishi PLC / MC 或机器人控制器的 IP 地址。 输入将连接到 In-Sight 视觉系统的 Mitsubishi PLC / MC 或机器人控制器的 IP 地址。

已关闭 主机端口

指定 Mitsubishi PLC/MC 或机器人控制器的十进制（Dec）或十六进制（Hex）格式的 TCP 端口号（十进制 1 - 65535、十六进制 1 - 0xFFFF; 默认值= 12288 十进制）。

已关闭 超时 (ms)

指定读取和写入操作超时的时间（5 毫秒到 30,000；默认为1,000毫秒）。

注意:此参数可能会增加作业的时间; 如果读取和写入操作都失败，则添加到作业的时间量将是超时值的两倍，因为两个操作的超时值会合并。
已关闭 源设备
注意:在更改源设备参数之前，请从格式化输入数据选项卡中删除所有工具属性。 如果源设备参数设置为<无>，而格式化输入数据选项卡中仍包含工具属性，则工具将处于错误状态。 此外，删除按钮将被禁用，格式化输入数据选项卡中保留的工具将执行失败或不能执行，直到这些工具被删除。
已关闭 输入数据设备地址

指定哪个 Mitsubishi PLC / MC 或机器人控制器的设备寄存器可以读取：

设备类型 | 规格 | PLC/MC | Robot
iQ-R/Q/L 系列 (3E Frame) | iQ-F 系列 (3E Frame) | FX 系列 (1E Frame) | CR800-D 系列 (3E Frame)
X - 输入继电器 | 位 | X | X | X (Oct)
Y - 输出继电器 | 位 | X | X | X (Oct)
M - 内部继电器 | 位 | X | X | X
L - 锁存继电器 | 位 | X
F - 信号器 | 位 | X | X
B - 连接继电器 | 位 | X
D - 数据寄存器 | 字 | X | X | X | X
W - 链接寄存器 | 字 | X
R - 文件模块寄存器 | 字 | X
ZR - 文件寄存器 | 字 | X
TN - 定时器值 | 字 | X | X
CN - 计数器值 | 字 | X | X
R - 扩展寄存器 | 字 | X
S - 状态继电器 | 位 | X
注意:设备类型的格式用来确定格式化输入缓冲选项卡中数据类型的可选类型。 如果设备类型的格式为位，则格式化输入缓冲选项卡将仅允许输入位数据类型。
已关闭 偏移值

PLC / MC 或机器人控制器数据表的数字部分，用于指定读取的开始位置。

已关闭 目标设备
已关闭 输出数据设备地址

指定哪个 Mitsubishi PLC / MC 或机器人控制器的寄存器可以读取：

设备类型 | 规格 | PLC/MC | Robot
iQ-R/Q/L 系列 (3E Frame) | iQ-F 系列 (3E Frame) | FX 系列 (1E Frame) | CR800-D 系列 (3E Frame)
X - 输入继电器 | 位 | X | X | X (Oct)
Y - 输出继电器 | 位 | X | X | X (Oct)
M - 内部继电器 | 位 | X | X | X
L - 锁存继电器 | 位 | X
F - 信号器 | 位 | X | X
B - 连接继电器 | 位 | X
D - 数据寄存器 | 字 | X | X | X | X
W - 链接寄存器 | 字 | X
R - 文件模块寄存器 | 字 | X
ZR - 文件寄存器 | 字 | X
TN - 定时器值 | 字 | X | X
CN - 计数器值 | 字 | X | X
R - 扩展寄存器 | 字 | X
S - 状态继电器 | 位 | X
注意:设备类型的格式用来确定格式化输出缓冲选项卡中数据类型的可选类型。 如果设备类型的格式为位，则格式化输出缓冲区选项卡将仅允许输入位数据类型。
已关闭 偏移值

PLC / MC 或机器人控制器数据表的数字部分，用于指定写入的开始位置。


配置格式化输出数据和格式化输入数据选项卡（SLMP）

配置 SLMP 设置选项卡后，你需要配置格式化输入数据和格式化输出数据选项卡以定义从 Mitsubishi PLC/MC 或机器人控制器以及 In-Sight 视觉系统传输的工具或作业数据。

已关闭 配置格式化输入数据选项卡

格式化输入数据选项卡用于定义 In-Sight 视觉系统的输入。每个作业最多可以定义 32 个输入。

  1. 单击格式化输入数据选项卡以开始配置将从 PLC/MC或机器人控制器传输到 In-Sight 视觉系统的数据。

  2. 点击添加按钮以启动选择输入数据对话框，该对话框中包含作业中的数据，例如添加到作业中的任何定位或检测工具、采集数据和输入。选择要从 PLC / MC 或机器人控制器传输到 In-Sight 视觉系统的数据，然后点击确认按钮。

    注意: SLMP 设置选项卡中的源设备设置会影响可以被添加的数据类型。 如果将源设备设置配置为位设备，则对于每个位地址，均可以添加布尔数据类型并将其分配给特定的位。 如果将源设备设置配置为字设备，则可配置数据类型，并且起始地址将是输入数据设备地址和字段偏移（以字为单位）。
  3. 添加数据后，数据将显示在表格中。该表格会显示所选数据的设备地址、输入名称、数据类型、大小和值。

  4. 可以从数据类型下拉列表中选择不同数据类型来自定义默认数据类型。

    注意:
    • 数据类型选项取决于 SLMP设置选项卡中的源设备设置。当源设备设置配置为位设备时，数据类型下拉列表将仅包含位选项。当源设备设置配置为字设备时，数据类型下拉列表将包括以下选项：位、16位整数、16位无符号整数、32位整数、32位浮点数和字符串。
    • 如果从数据类型下拉列表中选择字符串，则将启用元素大小（字）控件，您可以通过选择正确的字数来指定字符串长度。 当 iQ-R/Q/L 系列（3E Frame）、iQ-F 系列（3E Frame）或 CR800-D 系列（3E Frame）为所选的控制器类型时，最大消息大小为 960 个字。 当 FX 系列（1E Frame）为所选的控制器类型时，消息的最大长度为 64 个字。
    • 当 iQ-R/Q/L系列（3E Frame），iQ-F系列（3E Frame）或 CR800-D系列（3E Frame）为选定的控制器类型时，输入数据的最大长度为 1920 字节。当 FX 系列 （1E Frame）为选定的控制器类型时，输入数据的最大长度为 128 个字节。输入数据大小将显示在消息大小（字节）字段中。
    • 重置数据类型按钮将所有数据类型重置为其默认设置。
    • SLMP 协议的 EasyBuilder 实现不支持 8 位或无符号数据类型。
  5. 通过从列表中选择数据，然后单击上或下按钮设置所需的顺序，可以重新排列将要发送或接收的数据顺序。
已关闭 配置格式化输出数据选项卡

格式化输出数据选项卡用于定义 In-Sight 视觉系统的输出。每个作业最多可以定义 128 个输出。

  1. 单击格式化输出数据选项卡以开始配置将从 In-Sight 视觉系统传输到 PLC / MC 或机器人控制器的数据。

  2. 点击添加按钮来启动选择输出数据对话框，该对话框中包含作业中的数据，例如添加到作业的任何位置或检测工具，采集数据以及整体作业结果。 从 PLC / MC 或机器人控制器中选择要传输到 In-Sight 视觉系统的数据，然后按确认按钮。

    注意:
    • 默认情况下会自动将 Job.Inspection_Count 数据符号添加到输出数据表。 该符号会提醒 PLC / MC 或机器人控制器，In-Sight 视觉系统已获得新图像并且已有一组新的检测结果到来。 如果该符号对于应用程序不是必需的，可将其移除。
    • SLMP设置选项卡中的目标设备设置对可以被添加的数据类型有影响。 如果将目标设备设置配置为位设备，则可以为每个位地址添加布尔数据类型并将其分配给特定位。 如果目标设备设置配置为字设备，则可配置数据类型，起始地址将是输出数据设备地址和字段偏移（以字为单位）。
  3. 添加数据后，数据将显示在表格中。该表格会显示所选数据的名称，数据类型，大小，值和起始寄存器编号。 在表格的右侧是一个寄存器预览窗口，它显示数据如何格式化到 PLC / MC 或机器人控制器寄存器中。

  4. 可以从数据类型下拉列表中选择不同数据类型来自定义默认数据类型。

    注意:
    • 数据类型选择取决于SLMP设置选项卡中的目标设备设置。 当目标设备设置配置为位设备时，数据类型下拉列表将仅包括位选项。 如果将目标设备设置配置为字设备，数据类型下拉列表将包括以下选项：位、16 位整数、16 位无符号整数、32 位整数、32 位浮点 和字符串。
    • 如果从数据类型下拉列表中选择字符串，则将启用元素大小（字）控件，您可以通过选择正确的字数来指定字符串长度。 当 iQ-R/Q/L 系列（3E Frame）、iQ-F 系列（3E Frame）或 CR800-D 系列（3E Frame）为所选的控制器类型时，最大消息大小为 960 个字。 当 FX 系列（1E Frame）为所选的控制器类型时，消息的最大长度为 64 个字。
    • 当 iQ-R/Q/L系列（3E Frame）、iQ-F系列（3E Frame）或 CR800-D系列（3E Frame）为选定的控制器类型时，输出数据的最大长度为 1,920 字节。 当FX Series (1E Frame)被选为控制器类型时， 输出数据的最大长度为 128 字节。 输出数据大小显示在消息大小（字节）字段中。
    • 重置数据类型按钮将所有数据类型重置为其默认设置。
    • SLMP 的 EasyBuilder 应用不支持 8 位或无符号数据类型。
  5. 通过从列表中选择数据，然后单击上或下按钮设置所需的顺序，可以重新排列将要发送或接收的数据顺序。


配置设置选项卡（SLMP 扫描）

SLMP 扫描仪设置选项卡用于定义与 Mitsubishi PLC / MC 建立连接所需的连接信息。

注意:

根据设备设置组框中的所选设备，设置选项卡中的可用控制器类型会有所不同。 有关更多信息，请参阅与 Mitsubishi 设备通信。

已选设备（设备设置组框） 可用控制器类型（设置选项卡）
PLC/Motion 控制器
  • iQ-R/Q/L 系列 (3E Frame)
  • iQ-F 系列 (3E Frame)
  • FX 系列 (1E Frame)
机器人控制器
  • CR-800D 系列 (3E Frame)
已关闭 控制器类型

指定要与之通信的 Mitsubishi PLC/MC 或机器人控制器的类型

  • PLC/MC：iQ-R / Q / L系列（3E机架），iQ-F系列（3E机架）或FX系列（1E机架）。 默认= iQ-R / Q / L系列（3E Frame）。

    注意:运行 In-Sight 4.x.x 固件的 In-Sight 视觉系统不提供 iQ-F 系列（3E机架）选项。
  • 机器人控制器：CR800-D系列（3E机架）
已关闭 IP 地址

指定 Mitsubishi PLC/MC 或机器人控制器的 IP 地址。 输入将连接到 In-Sight 视觉系统的 Mitsubishi PLC / MC 或机器人控制器的 IP 地址。

已关闭 主机端口

指定 Mitsubishi PLC/MC 或机器人控制器的十进制（Dec）或十六进制（Hex）格式的 TCP 端口号（十进制 1 - 65535、十六进制 1 - 0xFFFF; 默认值= 12288 十进制）。

注意:
  • 该值应与在 Mitsubishi PLC/MC 或机器人控制器的 SLMP 端口上建立的主机端口设置相匹配。
  • 关闭 In-Sight Explorer 后，主机端口号的格式将被重置为十进制 (Dec) 格式。
已关闭 超时 (ms)

指定读取和写入操作超时的时间（5 毫秒到 30,000；默认为1,000毫秒）。

注意:此参数可能会增加作业的时间; 如果读取和写入操作都失败，则添加到作业的时间量将是超时值的两倍，因为两个操作的超时值会合并。
已关闭 轮询间隔（ms）

指定 Mitsubishi PLC/MC 或机器人控制器上的视觉控制块的连续轮询之间的时间（5 毫秒至 30,000；默认值为1,000毫秒）。

已关闭 连接到远程站点
  • 选中此复选框并且 iQ-R/Q/L 系列（3E Frame），iQ-F系列（3E Frame）或 CR800-D 系列（3E Frame）为选定的控制器类型时，网络号、PC 号和目标模块控件会被启用。
  • 当选中此复选框并且 FX Series（1E Frame）为所选的控制器类型时，将启用 PC 编号控制。

默认情况下，该复选框不会被选中，In-Sight 视觉系统将通过输入的 IP 地址指定的以太网模块直接连接到 PLC/MC 或机器人控制器。

已关闭 网络编号

定义与之通信的 SLMP 网络号（0 到 239；默认为 0 = 本地网络）。 当连接到远程站复选框被选中时，将启用此控制。

已关闭 PC 号（十六进制）

在目标模块的指定网络上以十六进制指定站点的标识符。 当连接到远程站复选框被选中时，将启用此控制。

十六进制 | 说明
0xFF（默认） | 直接连接到本地站。
0x7E | 主站在 CC-Link IE 字段。
0x1 - 0x78 | 站点在 CC-Link IE 区域网络适配器上。
已关闭 目标模块

指定要连接的设备的模块标识符。 当连接到远程站复选框被选中时，将启用此控制。

模块类型
03ff - 本地站（默认）
0x3d0 - 控制系统 CPU
0x3d1 - 备用系统 CPU
0x3d2 - 系统 A CPU
0x3d3 - 系统 B CPU
0x3e0 - CPU 1
0x3e1 - CPU 2
0x3e2 - CPU 3
0x3e3 - CPU 4
已关闭 重置按钮

将所有设置重置为默认设置。

已关闭 测试连接按钮

启动与 Mitsubishi PLC/MC 或机器人控制器的连接以进行测试。


配置设备寻址选项卡（SLMP 扫描）

SLMP 扫描设备寻址选项卡用于定义 PLC / 运动控制器或机器人控制器设备地址以及要传送到 PLC /运动控制器或机器人控制器的各种数据块的大小。根据在设置选项卡中定义的控制器类型（iQ-R/Q/L 系列、 IQ-F 系列，FX 系列 或者 CR800-D 系列）， 设备类型 和数据块的大小会有所不同。

已关闭 名称

可以与 Mitsubishi PLC/ 运动控制器或 机器人控制器进行通信的数据块的名称。

已关闭 已选设备

指定用于读取或写入数据块的 Mitsubishi PLC/运动控制器或机器人控制器设备。下拉列表包括以下选项：

设备类型 | 规格 | PLC/MC |  |  | 机器人控制器
 |  | iQ-R/Q/L 系列 (3E Frame) | iQ-F 系列 (3E Frame) | FX Series (1E Frame) | CR800-D 系列 (3E Frame)
X - 输入继电器* | 位 | X | X | X |
Y - 输出继电器* | 位 | X | X | X |
M - 内部继电器* | 位 | X | X | X |
L -闭锁继电器* | 位 | X |  |  |
F - 信号器* | 位 | X | X |  |
B - 链路继电器* | 位 | X |  |  |
D - 数据寄存器 | 字 | X | X | X | X
W - 链接寄存器 | 字 | X |  |  |
R - 文件块寄存器 | 字 | X |  |  |
ZR - 文件寄存器 | 字 | X |  |  |
R - 扩展寄存器 | 字 |  |  | X |
S - 状态继电器* | 位 |  |  | X |
*仅受 控制 和 状态 数据块支持。
注意:
  • 当所选设备设置为 无时，配置或更改 SLMP 扫描仪设置后，重新启动视觉系统。
  • 如果选择 无 ，则不会传送数据块。
  • 不支持 时间值 和 计数器值 设备。
已关闭 偏移

定义在读取或写入数据块设备表中的偏移。偏移值应以十进制、十六进制或八进制输入，具体取决于 已选设备 类型。

设备类型 | 值 | PLC/MC |  |  | 机器人控制器
 |  | iQ-R/Q/L 系列 (3E Frame) | iQ-F 系列 (3E Frame) | FX Series (1E Frame) | CR800-D 系列 (3E Frame)
X - 输入继电器* | 十六进制 | X | X | X |
Y - 输出继电器* | 十六进制 | X | X | X |
M - 内部继电器* | 十进制 | X | X | X |
L -闭锁继电器* | 十进制 | X |  |  |
F - 信号器* | 十进制 | X | X |  |
B - 链路继电器* | 十六进制 | X |  |  |
D - 数据寄存器 | 十进制 | X | X | X | X
W - 链接寄存器 | 十六进制 | X |  |  |
R - 文件块寄存器 | 十进制 | X |  |  |
ZR - 文件寄存器 | 十进制 | X |  |  |
R - 扩展寄存器 | 十进制 |  |  | X |
S - 状态继电器* | 十进制 |  |  | X |
*仅受 控制 和 状态 数据块支持。
已关闭 设备数目

指定与 Mitsubishi PLC /运动控制器或机器人控制器通信的数据块的大小。数据块大小可在 PLC/运动控制器或机器人控制器"设备"（字或位）单元指定。最大输入块、输出块、命令以及命令结果数据大小变化取决于所选择的 控制器类型 （IQ-R/Q/L 系列、 iQ-F 系列、 FX 系列 或者 CR800-D 系列）。

块名称 | 设备数目
 | iQ-R/Q/L 系列、iQ-F 系列、CR800-D 系列 | FX 系列
控制 | 32 位（标记为只读）
状态 | 32 位（标记为只读）
输入块 | 4 + 输入数据长度（最大值：960 字） | 4 + 输入数据长度（最大值：64 字）
输出块 | 12 + 输出数据长度（最大值：960 字） | 12 + 输出数据长度（最大值：64 字）
命令 | 0 - 960 字 | 0 - 64 字
命令结果 | 0 - 960 字 | 0 - 64 字
注意:

iQ-R/Q/L 系列、iQ-F 系列和 CR800-D 系列可以处理目前可用的多数消息帧格式（3E 帧）。但是， FX 系列 只能处理第一代协议消息帧（1E 帧），并且可以在分组中传输的数据量有限。

 | 最大数据大小
 | iQ-R/Q/L 系列、iQ-F 系列、CR800-D 系列 | FX 系列
批读位 | 7904 位 | 256 位
批读字 | 960 字 | 64 字
批写位 | 7904 位 | 160 位
批写字 | 690 字 | 64 字
已关闭 说明

数据块的文本说明。


配置格式化输出数据和格式化输入数据选项卡（SLMP 扫描）

配置设置和设备寻址选项卡后，需要配置格式化输入数据和格式化输出数据选项卡，这些选项卡用于定义要在 Mitsubishi PLC/MC/Robot Controller 和 In-Sight 视觉系统之间传输的工具或作业数据。

已关闭 配置格式化输入数据选项卡

格式化输入数据选项卡用于定义 In-Sight 视觉系统的输入。每个作业最多可以定义 32 个输入。

  1. 单击格式化输入数据选项卡以开始配置将从 PLC/MC或机器人控制器传输到 In-Sight 视觉系统的数据。
  2. 点击添加按钮以启动选择输入数据对话框，该对话框中包含作业中的数据，例如添加到作业中的任何定位或检测工具、采集数据和输入。选择要从 PLC/MC 或机器人控制器传输到 In-Sight 视觉系统的数据，然后点击确认按钮。
  3. 添加数据后，数据将显示在表格中。该表格会显示所选数据的设备地址、输入名称、数据类型、大小和值。

  4. 可以从数据类型下拉列表中选择不同数据类型来自定义默认数据类型。

    注意:
    • 如果从数据类型下拉列表中选择字符串或字节交换字符串，则将启用元素大小（字）控制，您可以通过选择正确的字数来指定字符串长度。
    • 当 Q-R/Q/L 系列（3E Frame）、iQ-F 系列（3E Frame）或 CR800-D 系列（3E Frame）是所选的控制器类型时，消息最大为 960 个字。当 FX 系列（ 1E Frame）是选定的控制器类型时，消息最大为 64 个字。
    • 当 iQ-R/Q/L 系列（3E Frame）、iQ-F 系列（33E Frame）或 CR800-D 系列（3E Frame）为选定的控制器类型时，输入数据的总最大长度为 1,920 字节。当 FX 系列（1E Frame）为选定的控制器类型，输入数据的总最大长度为 128 字节。输入数据大小显示在消息大小（字节）字段中。
    • 重置数据类型按钮将所有数据类型重置为其默认设置。
    • SLMP 扫描器的 EasyBuilder 应用不支持 8 位数据类型。

  5. 你可以通过取消选中高字节/低字节复选框（默认情况下，除 PROFINET 以外所有协议中该选项均为未选中），指定低字节优先或高字节优先来自定义字节顺序。或者，也可以通过取消选中高字节/低字节复选框（默认情况下为未选中状态）指定低字节优先或高字节优先，来自定义字节顺序。

    注意:对字节或字的顺序作出的任何更改都将影响格式化输出数据和格式化输入数据选项卡中的所有数据信号。

  6. 通过从列表中选择数据，然后单击上或下按钮设置所需的顺序，可以重新排列将要发送或接收的数据顺序。

已关闭 配置格式化输出数据选项卡

格式化输出数据选项卡用于定义 In-Sight 视觉系统的输出。每个作业最多可以定义 128 个输出。

  1. 单击格式化输出数据选项卡以开始配置将从 In-Sight 视觉系统传输到 PLC / MC 或机器人控制器的数据。
  2. 点击添加按钮来启动选择输出数据对话框，该对话框中包含作业中的数据，例如添加到作业的任何位置或检测工具，采集数据以及整体作业结果。 从 PLC / MC 或机器人控制器中选择要传输到 In-Sight 视觉系统的数据，然后按确认按钮。
  3. 添加数据后，数据将显示在表格中。该表格会显示所选数据的名称，数据类型，大小，值和起始寄存器编号。 在表格的右侧是一个寄存器预览窗口，它显示数据如何格式化到 PLC / MC 或机器人控制器寄存器中。

  4. 可以从数据类型下拉列表中选择不同数据类型来自定义默认数据类型。

    注意:
    • 如果从数据类型下拉列表中选择字符串或字节交换字符串，则将启用元素大小（字）控制，您可以通过选择正确的字数来指定字符串长度。
    • 当 iQ-R/Q/L 系列（3E Frame）、iQ-F 系列（3E Frame）或 CR800-D 系列（3E Frame）为所选的控制器类型时，最大消息大小为 960 个字。 当 FX 系列（1E Frame）为所选的控制器类型时，消息的最大长度为 64 个字。
    • 当 iQ-R/Q/L Series (3E Frame)，iQ-F 系列（3E Frame）或 CR-800D 系列（3E Frame）是选定的控制器类型时，输出数据的总最大长度为 1,920 字节。 当 FX 系列（1E帧）为所选的控制器类型时，输出数据的最大长度为128字节。 输出数据大小显示在消息大小（字节）字段中。
    • 重置数据类型按钮将所有数据类型重置为其默认设置。
    • SLMP 扫描器的 EasyBuilder 应用不支持 8 位数据类型。
  5. 你可以通过取消选中高字节/低字节复选框（默认情况下，除 PROFINET 以外所有协议中该选项均为未选中），指定低字节优先或高字节优先来自定义字节顺序。或者，也可以通过取消选中高字节/低字节复选框（默认情况下为未选中状态）指定低字节优先或高字节优先，来自定义字节顺序。任何更改都会在预览窗口中更新。
  6. 通过从列表中选择数据，然后单击上或下按钮设置所需的顺序，可以重新排列将要发送或接收的数据顺序。


配置 Mitsubishi 以太网本机字符串机器人通信

EasyBuilder 作业中的数据，例如单个工具或作业结果可以通过机器人控制器传输。当选择了数据并将其格式化为字符串后，机器人控制器就可以通过发送单个 In-Sight 本机模式命令 GetValue（GVJob.Robot.FormatString）来请求数据，该命令会返回字符串中格式化后的所有数据。

注意:In-Sight 2000 系列视觉传感器不支持机器人控制。

要将数据格式化为字符串以进行本机模式通信：

注意:In-Sight 视觉系统必须处于离线状态才能启用这些控制。
  1. 按添加按钮以启动选择输出数据对话框，其中包含已添加到作业的所有位置或检查工具的数据，以及采集数据和输入数据等附加作业数据。
  2. 在选择输出数据对话框中，选择想要从 In-Sight 视觉系统中发送的数据，然后按确定按钮。最多可为一个字符串选择 40 个数据项。
  3. 添加数据后，可修改数据的发送顺序，方法为从列表中选择数据项，然后单击上或下按钮设置所需顺序。此外，还可以通过按删除按钮删除不需要的项。
  4. 如果某个数据项是浮点数数据类型，将启用小数点控制，并可设置浮点值的小数位数（0-6；默认值 = 3）。
  5. 在数据列表右侧的窗口中，将显示已格式化的字符串，以及字符串长度（字符串中的字符数量）以供参考。逗号会自动插入以分隔字符串内的值。
  6. 字符串格式化后，机器人控制器便可以通过发送单个 In-Sight 本机模式命令 GetValue (GVJob.Robot.FormatString) 来请求数据字符串。


配置 Mitsubishi 串行本机字符串机器人通信

EasyBuilder 作业中的数据，例如单个工具或作业结果可以通过机器人控制器传输。当选择了数据并将其格式化为字符串后，机器人控制器就可以通过发送单个 In-Sight 本机模式命令 GetValue（GVJob.Robot.FormatString）来请求数据，该命令会返回字符串中格式化后的所有数据。

注意:In-Sight 2000 系列视觉传感器不支持机器人控制。

要将数据格式化为字符串以进行本机模式通信：

注意:In-Sight 视觉系统必须处于离线状态才能启用这些控制。
  1. 按添加按钮以启动选择输出数据对话框，其中包含已添加到作业的所有位置或检查工具的数据，以及采集数据和输入数据等附加作业数据。
  2. 在选择输出数据对话框中，选择想要从 In-Sight 视觉系统中发送的数据，然后按确定按钮。最多可为一个字符串选择 40 个数据项。
  3. 添加数据后，可修改数据的发送顺序，方法为从列表中选择数据项，然后单击上或下按钮设置所需顺序。此外，还可以通过按删除按钮删除不需要的项。
  4. 如果某个数据项是浮点数数据类型，将启用小数点控制，并可设置浮点值的小数位数（0-6；默认值 = 3）。
  5. 在数据列表右侧的窗口中，将显示已格式化的字符串，以及字符串长度（字符串中的字符数量）以供参考。逗号会自动插入以分隔字符串内的值。
  6. 字符串格式化后，机器人控制器便可以通过发送单个 In-Sight 本机模式命令 GetValue (GVJob.Robot.FormatString) 来请求数据字符串。

如有必要，请单击串行端口设置选项卡以指定串行通信设置。EasyBuilder 会根据设备设置选项自动确定串行协议。在完成通信步骤后，串行端口设置将保存到 In-Sight 视觉系统。

注意:

  • 串行端口设置选项因 In-Sight 型号和适用的 I / O 模块而异; 如果连接到支持的 I / O 模块，首先单击 I / O 模块按钮打开 I / O 模块配置对话框并配置 I / O 模块。

  • In-Sight Micro 1000 系列视觉系统仅在连接到 CIO-MICRO 或 CIO-MICRO-CC I / O 模块时才支持串行通信。

  • In-Sight 70xx - 74xx 系列视觉系统的串行通信有两种选择：使用分接电缆或使用 CIO-MICRO 或 CIO-MICRO-CC I / O 模块。当连接到分线电缆（并且没有连接到 I / O 模块）时，视觉系统允许一个离散输入线和一个离散输出线分别配置为串行接收和串行发送。有关详细信息，请参阅如何启用 In-Sight 70xx - 74xx 视觉系统的串行通信。
  • In-Sight 8000 系列视觉系统仅在连接到 CIO-MICRO I / O 模块时才支持串行通信。

  • CIO-WENET I/O 模块不支持串行通信。


通过 TCP/IP 通信

In-Sight 传感器可配置为 TCP / IP 客户端设备，以在 In-Sight 传感器与另一个 TCP / IP 设备之间建立连接，通过网络共享数据。一旦建立了 TCP / IP 连接，EasyBuilder 将启动与网络上的另一个TCP / IP 设备的通信。

要为用户设备的 TCP/IP 服务配置 In-Sight 传感器：

  1. 在通信组框中，按添加设备按钮。
  2. 在设备设置组框中，从设备下拉列表中选择其它。
  3. 从协议下拉列表中选择 TCP/IP。
  4. 点击确认按钮。
  5. 单击 TCP / IP 设置选项卡，然后在服务器主机名区域中输入要与之建立连接的 TCP / IP 服务设备的名称。

  6. 在端口输入框中输入在 TCP / IP 设备之间建立连接的 TCP / IP 服务器的端口号。输入的端口号也必须在服务器上分配。

    注意:有效端口分配可以是 1 到 65535 之间的任何未使用的数字（用于 In-Sight 通信的端口除外）。In-Sight 模拟器用户应始终将端口号设置为 3000（默认值）或更高，以防止与 PC 上保留的服务端口冲突。
  7. 输入在超时中止连接尝试之前等待 TCP / IP 建立连接的毫秒数（100 到 15000；默认 = 1000）。

  8. 在终止下拉列表中选择一个带有自定义结束符的字符串来指定一个 ASCII 字符（0 到 255）。

    已关闭 带有自定义结束符的字符串说明
    结束符 | 说明
    字符串 CR+LF（默认） | ASCII 字符 13（回车）和 10（换行）将被附加到数据字符串。
    字符串 CR (13) | ASCII 字符 13（回车）将被附加到数据字符串。
    字符串 LF (10) | ASCII 字符 10（换行符）将被附加到数据字符串。
    字符串 Nullchar (0) | ASCII 字符 0（Nullchar）将被附加到数据字符串。
  9. 建立 TCP / IP 设置后，点击格式化输出字符串选项卡以选择和格式化将要传输的数据。
注意:TCP / IP 协议是“辅助”协议，可以作为“主要”协议之外的辅助协议被添加到作业中。有关详情，请参阅设备设置中“支持的协议”部分。


通过 UDP 通信

In-Sight 视觉系统可以被设置为 UDP 服务器或客户端设备，在视觉系统和另一个 UDP 设备之间建立连接，并通过网络共享数据。

用户数据协议（UDP）是 TCP 的替代方案，是一种无连接通信传输方法，当通过网络协议交换信息时，它提供有限的服务量。与 TCP 不同，UDP 不承认或保证传送，也不提供对数据包进行排序。

要将视觉系统配置为 UDP 服务的客户端或服务器设备：

  1. 在通信组框中，按添加设备按钮。
  2. 在设备设置组框中，从设备下拉列表中选择其它。
  3. 从协议下拉列表中选择 UDP。
  4. 点击确认按钮。
  5. 现在您将需要配置 UDP 设置选项卡，并选择输入字符串（如果需要）和输出字符串（如果需要）。
已关闭 UDP 设置选项卡
已关闭 模式

定义是否将 In-Sight 视觉系统配置为客户端或服务器（客户端、带响应的客户端、服务器或带响应的服务器；默认值 = 客户端）。在 UDP 通信范式中，客户端是通过网络访问另一计算机系统（服务器）上的远程服务的某个系统，而服务器是处理来自另一网络设备的数据请求的某个网络设备。

  • 客户端：视觉系统会将数据传输到指定的服务器。
  • 带响应的客户端：视觉系统会将数据传输到指定的服务器，然后根据超时参数中设置的时限，等待来自服务器的响应消息。
  • 服务器：视觉系统将作为指定的服务器来接收数据。
  • 带响应的服务器：视觉系统将作为指定的服务器来接收数据，然后向客户端设备发回一条响应消息。
已关闭 服务器主机名

定义 UDP 服务器的主机名或 IP 地址。如果模式参数设置为服务器或带响应的服务器，则将禁用此参数。

已关闭 端口

定义 UDP 服务器和 UDP 设备之间的通信端口号。如果 In-Sight 视觉系统被配置为服务器并且服务器主机名已经输入，则端口参数会将该端口号分配给此设备。如果视觉系统被配置为客户端，则该端口号必须与 UDP 服务器的端口号相同。

已关闭 超时

定义客户端设备发出消息后，接收来自服务器设备响应所需的时间（100 到 15000；默认值 = 1000），以毫秒为单位。

注意:仅当模式参数设置为带响应的客户端时才会启用超时参数。
已关闭 输入字符串选项卡

输入字符串选项卡用于定义从另一设备输入到 EasyBuilder 工具的字符串输入中的字符串，如检测部件步骤中的读取 ID 代码、读取一维代码、读取多个一维代码（1-20 个）、读取二维代码、读取多个二维代码（1-20 个）、读取邮政编码或读取文本识别工具的匹配字符串参数。

注意:如果模式参数设置为客户端，则会禁用输入字符串选项卡。
已关闭 输入名称

从下拉菜单中选择将要输入的 EasyBuilder 作业或工具属性。

注意:若要从外部设备（如 PLC 或 PC）输入文本字符串以便与识别工具配合使用，请参阅该主题：为识别工具输入数据。
已关闭 格式化输出字符串

当模式参数被配置为客户端、带响应的客户端或带响应的服务器时，“格式化输出字符串”选项卡可用于定义发送到 UDP 服务器的数据。

注意:如果模式参数设置为服务器，则会禁用格式化输出字符串选项卡。
已关闭 格式化字符串
  1. 从格式化输出字符串选项卡中，单击格式化字符串按钮，就会启动格式化字符串对话框，您可以在此对话框中添加、自定义和修改数据的发送顺序。
  2. 在格式化字符串对话框中，点击添加按钮，将会启动选择输出数据对话框。
  3. 选择输出数据对话框包含任何添加到作业的位置或检查工具的数据以及总体作业结果。在该对话框中，选择您想从 In-Sight 传感器中发送的数据，然后按确定按钮。
  4. 当在选择输出数据对话框中选择数据后，会再次出现FormatString对话框。
  5. 从列表中选择数据，然后单击上或下按钮设置所需顺序，可以修改字符串和/或重新排列将要发送的数据顺序。在完成字符串修改后，按确定按钮。
  6. 由于字符串已格式化，因此输出数据将在传感器完成其作业执行之后发送。
注意:UDP 协议是“辅助”协议，可以作为“主要”协议之外的辅助协议被添加到作业中。有关详情，请参阅设备设置中“支持的协议”部分。


通过 POWERLINK 通信

注意:该协议仅在运行 In-Sight 固件版本 4.x.x 版本的 In-Sight 视觉系统上可用，但不能在运行 In-Sight 固件版本 5.1.0 或更新版本的 In-Sight 视觉系统上使用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

In-Sight 视觉系统可配置为 与POWERLINK 网络进行通信。

要通过 POWERLINK 进行通信，请先执行以下操作：

  1. 进入“通信应用程序步骤”。在通信组框中，按添加设备按钮。
  2. 在设备设置组框中，从设备下拉列表中选择 PLC。
  3. 从制造商下拉列表中选择 B＆R。
  4. 从协议下拉列表中选择 POWERLINK。
  5. 点击确认按钮。

一旦启用这些设置，可以配置“设置和格式输入/输出”选项卡。

  • 已关闭 POWERLINK 设置选项卡

    启用：在 In-Sight 视觉系统上启用 POWERLINK（默认=未选中）。

    节点 ID：为 POWERLINK 网络上的 In-Sight 视觉系统定义节点 ID（1-239；默认= 1）。当启用复选框被选中时，该控制会被启用。节点 ID 与 POWERLINK 网络的 NAT IP 地址一起可用于与 POWERLINK 网络外的其他设备进行通信。例如，默认的 NAT IP 地址是 192.168.101.0。要与节点 ID 为 26 的 In-Sight 视觉系统进行通信，可以将 NAT IP 地址与节点 ID：192.168.101.26 一起使用。

    注意:必须重新启动 In-Sight 视觉系统才能启用 POWERLINK 协议。
  • 格式化输入/输出选项卡
注意:
  • 有关更多信息，请参阅 In-Sight® 浏览器帮助文件。
  • （可选）再次点击添加设备按钮以将一个“辅助”协议添加到作业中。有关详情，请参阅设备设置中“支持的协议”部分。


为识别工具输入数据

要从用于识别工具的外部设备（如PLC或PC）输入文本字符串，请按照下列步骤操作：

  1. 在检查零件步骤中添加了读取ID代码，读取1D代码，读取1D代码（1-20），读取2D代码，读取2D代码（1-20），读取邮政编码或读取文本标识工具。
  2. 在读取 ID 代码、1D 代码，读取 1D 代码（1-20），读取 2D 代码，读取 2D 代码（1-20）或读取邮政编码工具的的设置选项卡中，将模式设置为匹配字符串; 对于读取文本工具，将模式设置为验证或读取和验证。
  3. 单击通信应用程序步骤。
  4. 在通信组框中，按添加设备按钮。
  5. 在设备设置组框中，从设备下拉列表中选择其它。
  6. 从协议下拉列表中选择串行文本。
  7. 点击确认按钮。
  8. 点击输入字符串选项卡。
  9. 从输入名称下拉列表中，选择所需工具的匹配字符串输入。EasyBuilder 将会自动检查作业，并包括在作业中定义的任何工具的匹配字符串输入。

  10. 如有必要，单击串行端口设置选项卡，根据应用程序调整设置。

    注意:

    • 串行端口设置选项因 In-Sight 型号和适用的 I / O 模块而异; 如果连接到支持的 I / O 模块，首先单击 I / O 模块按钮打开 I / O 模块配置对话框并配置 I / O 模块。

    • In-Sight Micro 1000 系列视觉系统仅在连接到 CIO-MICRO 或 CIO-MICRO-CC I / O 模块时才支持串行通信。

      In-Sight 70xx - 74xx 系列视觉系统的串行通信有两种选择：使用分接电缆或使用 CIO-MICRO 或 CIO-MICRO-CC I / O 模块。当连接到分线电缆（并且没有连接到 I / O 模块）时，视觉系统允许一个离散输入线和一个离散输出线分别配置为串行接收和串行发送。有关详细信息，请参阅如何启用 In-Sight 70xx - 74xx 视觉系统的串行通信。
    • In-Sight 8000 系列视觉系统仅在连接到 CIO-MICRO I / O 模块时才支持串行通信。

    • CIO-WENET I/O 模块不支持串行通信。

  11. 单击格式化输出字符串选项卡并点击格式化字符串，就会启动对话框，你可以在此选择并格式化工具的输出结果。

    注意:在从外部设备输入匹配字符串前，读取 ID 代码或读取文本会导致失败，并且匹配字符串字段将显示 TRIG。
  12. 在 FormatString 对话框中，点击添加按钮，将会启动选择输出数据对话框。
  13. 选择输出数据对话框包含任何添加到作业的位置或检查工具的数据以及总体作业结果。在该对话框中，选择您想从 In-Sight 传感器中发送的数据，然后按确定按钮。
  14. 当在选择输出数据对话框中选择数据后，会再次出现FormatString对话框。
  15. 从列表中选择数据，然后单击上或下按钮设置所需顺序，可以修改字符串和/或重新排列将要发送的数据顺序。在完成字符串修改后，按确定按钮。
  16. 由于字符串已格式化，因此输出数据将在传感器完成其作业执行之后发送。
  17. 在 In-Sight 传感器处于联机状态后，该工具将会接收输入字符串并尝试读取和/或检验图像中的字符串。


格式化输出字符串

  1. 在通信组框中，按添加设备按钮。
  2. 在设备设置组框中，从设备下拉列表中选择其它。
  3. 从协议下拉列表中，选择以太网本机、串行本机、串行文本或 TCP/IP。
  4. 从格式化输出字符串选项卡中，单击格式化字符串按钮，就会启动格式化字符串对话框，您将可以在此对话框中添加、自定义和修改数据的发送顺序。
  5. 在 格式化字符串 对话框中，按添加按钮，将会启动选择输出数据对话框。
  6. 选择输出数据对话框包括来自于添加到您作业和整体作业结果中的任何位置或检查工具的数据。从此对话框中，选择您想从 In-Sight 视觉系统中发送的适当数据，然后按确定按钮。
  7. 当在选择输出数据对话框中选择数据后，会再次出现格式化字符串对话框。
  8. 通过从列表中选择数据，然后单击上或下按钮以设置您所需的顺序，您可以修改字符串和/或重新排列要发送的数据顺序。在完成字符串修改后，按确定按钮。
  9. 由于字符串已格式化，因此输出数据将在视觉系统完成其作业执行之后发送。


与 Rockwell ControlLogix PLC 通信

该部分介绍了如何在 EtherNet/IP 网络上使用 Rockwell RSLogix 5000 软件在 In-Sight 视觉系统和 ControlLogix 或 CompactLogix PLC 之间进行数据传输。

在 RSLogix 的 I/O 结构中设置 In-Sight 视觉系统

配置 In-Sight 视觉系统的 PLC 通信

从 RSLogix PLC 加载 In-Sight 视觉系统作业示例


在 RSLogix 的 I/O 结构中设置 In-Sight 视觉系统

配置隐式连接和数据传输的步骤取决于视觉传感器上安装的固件版本以及 RSLogix 5000 软件的版本。有关详细信息，请参阅 In-Sight®Explorer 帮助文件中的 与 Rockwell ControlLogix PLC 通信主题。

将 In-Sight 视觉系统集成到 RSLogix 5000 v14-16

将 In-Sight 视觉系统集成到 RSLogix 5000 v17-19

将 In-Sight 视觉系统集成到 RSLogix 5000 v20

In-Sight 视觉系统输入和输出模块对象


将 In-Sight 视觉系统集成到 RSLogix 5000 v14-16 中

本主题介绍了在 RSLogix 5000,14-16 版本中集成运行 In-Sight 5.2.0 或更高版本固件的 In-Sight 视觉系统。这些版本的 RSLogix 5000 不支持 EDS 文件，必须使用通用 ETHERNET-MODULE。In-Sight Explorer 包括了在运行 In-Sight 5.2.x 或更高版本固件的视觉传感器中代表信号的 .L5X 文件，可用于将 PLC 控制器标签数据复制到用户友好程序标签或从用户友好程序标签复制。

  1. 打开 RSLogix 5000 并加载 PLC 项目。

    注意:要在 RSLogix 5000 中添加连接，PLC 必须先被设置为离线。

  2. 将连接添加到以太网通信卡。在 I/O 配置节点下，选择以太网模块下的以太网节点，右键单击图标，然后从菜单中选择新建模块。

  3. 从目录选项卡中的选择模块类型对话框中，选择通信模块类型类别，选择 Allen-Bradley 作为模块类型供应商，选择 ETHERNET-MODULE（通用以太网模块），然点击创建按钮。

  4. 在新建模块对话框中，输入以下内容：

    • In-Sight 视觉传感器的名称和 IP 地址。
    • 连接参数。 对于运行 5.x.x 固件的 In-Sight 视觉传感器，输入/输出装配对象部分指定了应配置的装配实例。 有关更多信息，请参阅 In-Sight® Explorer 帮助文件中的 Rockwell ControlLogix PLC - In-Sight 5.x.x 固件版本主题。

  5. 将视觉传感器添加到 RSLogix 项目后，L5X rung 导入文件可被用来为连接创建结构化数据。可以通过选择控制器整理栏中的任务>主任务>主程序来访问主程序。

    注意:如果这是一个新的梯形程序，可以使用空 rung 0。如果视觉传感器被集成到现有程序中，Cognex 建议在梯形程序的顶部添加一个 rung，以确保在执行梯形程序的其余部分之前更新的数据可以从传感器的输入和输出组件中读取和写入。

    1. 在主程序中，右键单击一个空 rung，然后选择导入 Rungs...选项。

    2. 找到 .L5X 文件; 该文件位于以下位置：C：\ Program Files（x86）\ Cognex \ In-Sight \ In-Sight Explorer 5.x.x \Factory Protocol Description\ RSLogix

      导入 InSightGenEth_11_CopyRung.L5X 文件。选择文件后，单击导入...按钮。

  6. 之后，导入配置对话框会被用来更改已创建标记的名称以匹配设置。通用模块将为模块的输入和输出创建一个原始的非结构化数据数组。输入数据将是由状态组和检查结果数组组成的一个连续数组。输出数据将是一个由控制组和用户数据数组组成的连续数组。它们中的任何一个都没有任何标识标签。

    一旦项目下载到 PLC 并且带有复制指令的 rung 第一次执行，将会创建两个包含变量的新数组。

    1. 需要修改标签的通用名称。顶部的两行在它们旁边有一个 X，每个的名称都需要修改。

    2. 单击名称字段的空白处，将出现一个箭头并提供一个下拉菜单，其中将包含默认名称结构的替换选项。该列表应包含与步骤 4 中给出的名称匹配的名称（In-Sight视觉传感器的名称；在本示例中，名称为 In-Sight 2000，因此列表包含 In-Sight 2000：I 和 In- Sight 2000：O）。

      将两个通用名称更换为下拉菜单中的选项。

    3. 底部的两行也需要编辑。单击名称的文本，以使鼠标图标出现，然后将“_In”和_Out“之前的文本替换为通用模块的名称或一些其他容易识别的名称（例如，本示例中的”In-Sight 2000“ ，因为只有一个视觉传感器）。

      注意: 此实例中给出的名称对于添加到 I / O 配置的每个视觉传感器都是唯一的。如果要部署多个视觉传感器，则对于每个视觉传感器都必须遵循这些步骤，因为所创建的 rungs 拷贝的每个实例将指向特定的视觉传感器。因此，为了以后的故障排除，请确保使用的名称容易识别。

    4. 一旦所有标签都已从其默认值更新，点击 OK 按钮。

  7. 一个新的 rung 将被添加到所添加的 rung 下面的主程序中（空 rung 可以被删除）。

  8. 该项目现在可以被下载到 PLC，并且 PLC 可以设置成运行模式。

  9. 一旦运行了保存复制指令的 rungs，新标签将在控制器标签表格中创建。

    在本例中，In-Sight 2000：I 和 In-Sight 2000：O 标签是视觉系统的原始输入和输出数据，In-Sight 2000_In 和 In-Sight 2000_Out 将包含控制和状态组以及用户数据和检验结果数组。


将 In-Sight 视觉系统集成到 RSLogix 5000 v17-19 中

本主题介绍了如何在 RSLogix 5000 17-19 版中集成运行 5.2.0 或更高版本固件的 In-Sight 视觉系统。这些版本的 RSLogix 5000 不支持 EDS 文件，必须使用通用 ETHERNET-MODULE。In-Sight Explorer 包括了在运行 In-Sight 5.2.x 或更高版本固件的视觉传感器中代表信号的 .L5X 文件，可用于将 PLC 控制器标签数据复制到用户友好程序标签或从用户友好程序标签复制。

  1. 打开 RSLogix 5000 并加载 PLC 项目。

    注意:要在 RSLogix 5000 中添加连接，PLC 必须先被设置为离线。

  2. 将连接添加到以太网通信卡。在 I/O 配置节点下，选择以太网模块下的以太网节点，右键单击图标，然后从菜单中选择新建模块。

  3. 从目录选项卡中的选择模块类型对话框中，选择通信模块类型类别，选择 Allen-Bradley 作为模块类型供应商，选择 ETHERNET-MODULE（通用以太网模块），然点击创建按钮。

  4. 在新建模块对话框中，输入以下内容：

    • In-Sight 视觉传感器的名称和 IP 地址。
    • 连接参数。 对于运行 5.x.x 固件的 In-Sight 视觉传感器，输入/输出装配对象部分指定了应配置的装配实例。 有关更多信息，请参阅 In-Sight® Explorer 帮助文件中的 Rockwell ControlLogix PLC - In-Sight 5.x.x 固件版本主题。

  5. 将视觉传感器添加到 RSLogix 项目后，L5X rung 导入文件可被用来为连接创建结构化数据。可以通过选择控制器整理栏中的任务>主任务>主程序来访问主程序。

    注意:如果这是一个新的梯形程序，可以使用空 rung 0。如果视觉传感器被集成到现有程序中，Cognex 建议在梯形程序的顶部添加一个 rung，以确保在执行梯形程序的其余部分之前更新的数据可以从传感器的输入和输出组件中读取和写入。

    1. 在主程序中，右键单击一个空 rung，然后选择导入 Rungs...选项。

    2. 找到 .L5X 文件; 该文件位于以下位置：C：\ Program Files（x86）\ Cognex \ In-Sight \ In-Sight Explorer 5.x.x \Factory Protocol Description\ RSLogix

      导入 InSightGenEth_11_CopyRung.L5X 文件。选择文件后，单击导入...按钮。

  6. 之后，导入配置对话框会被用来更改已创建标记的名称以匹配设置。通用模块将为模块的输入和输出创建一个原始的非结构化数据数组。输入数据将是由状态组和检查结果数组组成的一个连续数组。输出数据将是一个由控制组和用户数据数组组成的连续数组。它们中的任何一个都没有任何标识标签。

    一旦项目下载到 PLC 并且带有复制指令的 rung 第一次执行，将会创建两个包含变量的新数组。

    1. 需要修改标签的通用名称。顶部的两行在它们旁边有一个 X，每个的名称都需要修改。

      单击名称字段的空白处，将出现一个箭头并提供一个下拉菜单，其中将包含默认名称结构的替换选项。该列表应包含与步骤 4 中给出的名称匹配的名称（In-Sight视觉传感器的名称；在本示例中，名称为 In-Sight 2000，因此列表包含 In-Sight 2000：I 和 In- Sight 2000：O）。

      将两个通用名称更换为下拉菜单中的选项。

    2. 底部的两行也需要编辑。单击名称的文本，以使鼠标图标出现，然后将“_In”和_Out“之前的文本替换为通用模块的名称或一些其他容易识别的名称（例如，本示例中的”In-Sight 2000“ ，因为只有一个视觉传感器）。

      注意: 此实例中给出的名称对于添加到 I / O 配置的每个视觉传感器都是唯一的。如果要部署多个视觉传感器，则对于每个视觉传感器都必须遵循这些步骤，因为所创建的 rungs 拷贝的每个实例将指向特定的视觉传感器。因此，为了以后的故障排除，请确保使用的名称容易识别。

    3. 一旦更改了默认标签名称，就需要指定标签的创建位置。要将标签放置在控制器标签表中，请在空白框中右键单击（如下所示），然后选择 Toggle Tag Scope。

    4. 一旦所有标签都已从其默认值更新，点击 OK 按钮。

  7. 一个新的 rung 将被添加到所添加的 rung 下面的主程序中（空 rung 可以被删除）。

  8. 该项目现在可以被下载到 PLC，并且 PLC 可以设置成运行模式。

  9. 一旦运行了保存复制指令的 rungs，新标签将在控制器标签表格中创建。

    在本例中，In-Sight 2000：I 和 In-Sight 2000：O 标签是视觉系统的原始输入和输出数据，In-Sight 2000_In 和 In-Sight 2000_Out 将包含控制和状态组以及用户数据和检验结果数组。


将 In-Sight 视觉系统集成到 RSLogix 5000 v20 中

本主题介绍了如何在 RSLogix 5000 版本 20 及更高版本中集成运行 In-Sight 5.2.0 或更高版本固件的 In-Sight 视觉系统。这些版本的 RSLogix 5000 支持 EDS 文件。In-Sight Explorer 包括 .L5X 文件，该文件将标签数据放置在用户友好的程序标签中，用来表示运行 In-Sight 5.2.x 或更高固件版本的视觉传感器中的信号。InSight_11_CopyRung.L5X 文件将用于运行 5.X 固件的传感器。

  1. 在 RSlogix5000 中创建并添加 EDS 模块

    1. EDS 文件随 Insight Explorer 软件一起安装在以下位置：C：\ Program Files（x86）\ Cognex \ In-Sight \ In-Sight Explorer 5.2.3 \ Factory Protocol Description \ EDS
    2. 在 RSLogix5000 的“工具”下拉菜单中，运行 EDS 安装工具，为 In-Sight 2000 安装EDS文件。
    3. 从 RSLogix5000 的“IO配置”部分，右键单击网络节点，然后从菜单中选择“新建模块”。

    4. 从“选择模块”对话框中，打开“通信”节点，然后从列表中选择“In-Sight 2000-xxx”，然后单击“确定”。

      对话框将被替换为新建模块配置对话框。

      输入视觉传感器的名称、IP 地址及其连接参数，如上所示。如果有多个视觉传感器，每个都应该有一个唯一的名称。在该示例中，只对一个视觉传感器进行配置。

      提示:有关与视觉传感器上运行的固件版本相对应的 EtherNet/IP 对象模型（输入和输出装配位）的详细信息，请参阅 In-Sight Explorer 帮助文件。

  2. 导入 Rung

    1. 访问主程序，该程序可以在控制器管理器栏中的任务>主任务>主程序文件夹中找到。如果这是一个新的梯形程序，可以使用空 rung 0。如果将视觉传感器集成到现有程序中，建议在梯形图顶部添加一个 rung，以确保更新的数据在梯形图执行之前被读取并写入传感器的输入和输出组件。

    2. 梯形程序顶部有一个空的 rung，右键单击该 rung，然后从菜单中选择导入 Rung。

    3. 使用导入 Rung 对话框浏览到包含此文档和两个导入 rung 文件的文件夹的位置。由于 Insight 2000 使用的是 5.X 固件，因此将使用 InSight_11_CopyRung.L5X 文件。

    4. 选择适当的文件后，单击导入按钮。

    5. 导入配置对话框将显示用于生成标签的通用名称。

  3. 重命名标签：通用模块将为模块的输入创一个原始的非结构化数据数组。在该示例中 - 通用模块创建 In-Sight 2000：I，In-Sight 2000：0和In-Sight 2000：C（未使用）。输入组件是由状态块和检查结果数组组成的一个连续阵列，输出组件将是由控制块和用户数据阵列组成的连续阵列，无需任何标识标签。一旦将项目下载到 PLC，并且第一次执行带有复制指令的 rung，将会创建两个包含标记的新数组（且与附加文档模块（如果存在附加文档模块）的标签相似）。

    1. 需要通过单击“名称”字段的空白处编辑其左侧有标志的底部两行。这些标签包含了 In-Sight 上的 I / O 组件的原始非结构化数据。点击空格后会出现一个向下箭头。

    2. 单击箭头将生成一个下拉菜单，其中包含默认名称的替换选项。在这个列表中，将有与通用模块的名称相匹配的名称。在此示例中，通用模块命名为 In-Sight 2000，因此“In-Sight 2000：I”和“In-Sight 2000：O”将出现在列表中。将两行都替换为与通用模块的名称相匹配的相应名称。请注意，In-Sight 2000：C 没有被使用。

    3. 下一步，编辑导入配置中的前两行。点击名称的文本，使光标出现。最好的做法是将“_In”和“_Out”替换为通用模块的名称或其他一些易于识别的名称。由于该示例仅使用一个视觉传感器，因此使用了名称“In-Sight 2000”。

    4. 现在，所有的默认标签名称都已更改，因此需要指定标签的创建位置。跳过此步骤将新的标签放在主程序上方的程序标签表中。

      要将标签输入到控制器标签表中 - 如 AOP 所示，可以使用 - 右键单击每个输入名称旁控制器卡图标缺失的空白框。这些空白处已在下面的截图中突出显示。在此空格处右键单击将产生一个可供选择切换标签范围的下拉菜单。这将把控制器卡图标放置到之前空的框中。

    5. 把所有名称从其默认值更改后，单击确定按钮。

      提示:名称 In-Sight 2000_In 和 In-Sight 2000_Out 可以是任何名称，只要它对于添加到 IO 配置的每个视觉传感器来说是唯一的名称。如果要部署多个传感器，则必须对每个传感器执行这些步骤，因为创建的 rungs 拷贝的每个实例都将指向特定的传感器。选择名称时应考虑到未来排除故障的容易程度，以避免混淆。例如，如果存在多个传感器，则名称可以是“Line_One_In-Sight 2000_In”和“Line_One_In-Sight 2000_Out”。

    6. 一个新的空 rung 将被添加到主程序。该 rung 将被删除。

  4. 下载到 PLC。

    1. 将项目下载到PLC。

    2. 将 PLC 置于运行模式。在保持拷贝指令的 rung 运行之后，新的标签将在“程序标签”表中创建（与在附加文档中添加的情况相似）。

      在本示例中，In-Sight 2000：I＆In-Sight 2000：O 是来自视觉传感器的原始输入和输出程序集，MyCamera_In 和MyCamera_Out 将包含控件和状态块以及 UserData 和InspectionResults 数组（如下表所示）：


In-Sight 视觉系统输入和输出模块对象

有关更多信息，请参阅 In-Sight® 浏览器帮助文件。


配置 In-Sight 视觉系统的 PLC 通信

要与 PLC 通信，请执行以下操作：

  1. 在通信组框中，点击添加设备按钮。
  2. 在设备设置组框中，从设备下拉列表中选择 PLC/Motion 控制器。
  3. 从制造商下拉列表中选择 PLC/MC 制造商。如果列表中没有列出您的 PLC/MC 制造商，请选择其它。
  4. 从协议下拉列表中，选择您的通信协议。列出的通信协议取决于所选的制造商。
  5. 按确定按钮。

接下来，您可以执行以下操作：

通过 EtherNet / IP 触发

使用 Add-On Profile 建立连接

从 In-Sight 视觉系统取数据

将数据发送到 In-Sight 视觉系统


通过 EtherNet/IP 触发

配置 In-Sight 2000 视觉传感器以通过 EtherNet/IP 进行触发：

  1. 登录到视觉传感器。
  2. 在设置图像步骤中，将触发类型设置为工业以太网。

  3. 在通信步骤中：

    1. 在通信组框中，点击添加设备按钮。
    2. 在设备设置组框中，从设备下拉列表中选择 PLC/Motion 控制器。
    3. 从制造商下拉列表中选择 PLC/MC 制造商。如果列表中没有列出您的 PLC/MC 制造商，请选择其它。
    4. 从协议下拉列表中，选择您的通信协议。列出的通信协议取决于所选的制造商。
    5. 按确定按钮。

  4. 将 In-Sight 视觉传感器设置为在线。

  5. 在 PLC 上的 I/O 组合标签中，将 Trigger Enable 位设置为“高”，然后再将 Trigger 位设置为“高”以进行触发（参考位以黄色突出显示）。


使用 Add-On Profile 建立连接

如果已在 RSLogix 项目中使用 EDS 文件设置了视觉系统，你可以使用新的 AOP Profile 来更新 EDS Profile。有关更多信息，请参阅 In-Sight® 浏览器帮助文件。


从 In-Sight 2000 视觉传感器获取数据

从 In-Sight 视觉系统获取数据

在 In-Sight 视觉系统和 PLC 之间建立通信：

  1. 在通信组框中，点击添加设备按钮。
  2. 在设备设置组框中，从设备下拉列表中选择 PLC/Motion 控制器。
  3. 在制造商下拉列表中选择 PLC/MC 制造商。如果列表中没有列出您的 PLC/MC 制造商，请选择其它。
  4. 在协议下拉列表中，选择您的通信协议。列出的通信协议取决于所选的制造商。
  5. 按确定按钮。

为通信设置数据

来自 EasyBuilder 作业的数据可以通过 EtherNet/IP 传送，例如单独的工具结果或总体作业结果（仅输出）。在传感器获取图像后，将读取输入数据，并在传感器完成其作业执行后发送输出数据。

  6. 单击格式化输入数据或格式化输出数据选项卡。
  7. 按添加按钮启动选择输入数据或选择输出数据对话框。
  8. 选择输入数据或选择输出数据对话框包含来自添加到作业的任何位置或检测工具的数据以及整个作业结果（仅输出）。在此对话框中，选择您想从 In-Sight 传感器中发送（或发送至）的适当数据，然后按确定按钮。

  9. 在添加数据之后，您可以通过在数据类型下拉列表中选择不同数据类型来修改所选数据的默认数据类型。

    注意:如果从数据类型下拉列表中选择字符串，元素大小（字节）控制会被启用，而且您可以通过选择正确的字节数来指定字符串长度。
  10. 通过从列表中选择数据，然后单击上或下按钮以设置您所需的顺序，您可以重新排列要发送或接收的数据顺序。
  11. 将 In-Sight 视觉传感器设置为在线。
  12. 触发系统。

  13. 数据应显示在 RSLogix 5000 的 Controller - > Program Tags 节点中。


将数据发送到 In-Sight 2000 视觉传感器

将数据发送到 In-Sight 视觉系统

在 In-Sight 视觉系统和 PLC 之间建立通信：

  1. 在通信组框中，点击添加设备按钮。
  2. 在设备设置组框中，从设备下拉列表中选择 PLC/Motion 控制器。
  3. 在制造商下拉列表中选择 PLC/MC 制造商。如果列表中没有列出您的 PLC/MC 制造商，请选择其它。
  4. 在协议下拉列表中，选择您的通信协议。列出的通信协议取决于所选的制造商。
  5. 按确定按钮。

来自 EasyBuilder 作业的数据可以通过 EtherNet/IP 传送，例如单独的工具结果或总体作业结果（仅输出）。在传感器获取图像后，将读取输入数据，并在传感器完成其作业执行后发送输出数据。

如何格式化数据：

  1. 单击格式化输入数据或格式化输出数据选项卡。
  2. 按添加按钮启动选择输入数据或选择输出数据对话框。
  3. 选择输入数据或选择输出数据对话框包含来自添加到作业的任何位置或检测工具的数据以及整个作业结果（仅输出）。在此对话框中，选择您想从 In-Sight 传感器中发送（或发送至）的适当数据，然后按确定按钮。

  4. 在添加数据之后，您可以通过在数据类型下拉列表中选择不同数据类型来修改所选数据的默认数据类型。

    注意:如果从数据类型下拉列表中选择字符串，元素大小（字节）控制会被启用，而且您可以通过选择正确的字节数来指定字符串长度。
  5. 通过从列表中选择数据，然后单击上或下按钮以设置您所需的顺序，您可以重新排列要发送或接收的数据顺序。
  6. 将 In-Sight 视觉传感器设置为在线。
  7. 在 RSLogix 5000 中，打开“程序标签”对话框并更改 InSight Top：OData [1] 和 InSight Top：OData [2] 标签的值。

  8. 确定用户数据交互是否需要。如果用户数据分流被启用；交换数据会模仿 4.x.x 相机。如果用户数据分流未被启用（默认状态），该新的数据位会在 PLC 和 In-Sight 视觉传感器数据交换中添加额外的数据交互。你需要执行额外的步骤以在电子表格中显示数据。

    1. 如果在网络设置对话框中为相机启用了启用用户数据分流，则 EasyBuilder 中的数值会马上更新。

    2. 如果启用用户数据分流没有在网络设置对话框中启用：

      1. 设置 User Data 标签，SetUserData 位是一个已命名标签，在这个例子中它将是 InSight_Top：O.Control.SetUserData。
      2. 当接收到 User Data Ack 位时，清除 User Data 标签。SetUserDataAck 位是一个已命名标签，在这个例子中，它将是 InSIght_Top:I.Status。SetUserDataAck.


从 RSLogix PLC 加载 In-Sight 视觉系统作业示例

有关更多信息，请参阅 In-Sight® 浏览器帮助文件。


与 Universal Robots 集成 - TCP / IP

Cognex 2D视觉系统使用Cognex In-Sight 2D机器人引导插件与Universal Robot控制器集成，您可以将其安装在Universal Robot PolyScope软件中。使用此插件来设置手眼校准并从视觉系统中检索位置（位姿）信息，以便机器人可以移动到正确的目标位置并拾取零件。您可以对视觉系统的响应进行编程，例如作业通过或失败时。如果视觉系统安装在机器臂上，您还可以为机器人设置参考位姿。

Cognex 2D视觉系统使用 TCP / IP 连接与 Universal Robot 控制器进行通信。视觉系统托管TCP服务器，机器人是客户端。这些设备必须位于同一网络上。

注意:In-Sight 2000 视觉传感器不支持该功能。

支持以下 Universal Robots：

  • UR3
  • UR5
  • UR10
  • e 系列

Cognex In-Sight 2D机器人引导插件仅在 Universal Robots PolyScope 软件版本3.5.1及更高版本中受支持。

设置手眼校准和机器人引导应用程序包含以下任务：

  1. 安装Cognex In-Sight 2D机器人引导插件
  2. 设置机器人工具中心点（TCP）
  3. 配置视觉系统校准
  4. 连接视觉系统并执行手眼校准
  5. 创建部件作业并导入校准
  6. 设置视觉系统位姿
  7. 为 Universal Robot 编程

安装URCap Cognex插件

设置机器人工具中心点（TCP）

配置视觉系统校准

连接视觉系统并执行手眼校准

创建部件作业并导入校准

设置视觉系统位姿

为 Universal Robot 编程


安装URCap Cognex插件

安装Cognex In-Sight 2D机器人引导插件

  1. 前往cognex.com/urcaps并下载Cognex URCaps v1.3.0.urcap文件。
  2. 将文件传输到USB。
  3. 启动PolyScope程序。主菜单显示：

  4. 将USB插入Universal Robot教学器的右侧。
  5. 在主菜单上，选择Setup Robot>URCaps。单击加号按钮（+）以添加URCap Cognex插件文件，该文件显示名为Cognex In-Sight Robot Guidance。

Cognex In-Sight 2D机器人引导插件将以下内容添加到PolyScope软件中：

  • 程序选项卡上的Cognex菜单项（Program > Structure > URCaps > Cognex Camera Pose）。
  • 安装选项卡上的Cognex菜单项。
  • 机器人程序树中的一个叫做CGX_result：= CameraPose的节点。
  • 一个名为CGX_result的新变量将被添加到Program> Command选项卡中。该变量用于存储在触发期间从视觉系统发送的视觉系统位姿信息。


设置机器人工具中心点（TCP）

工具中心点（TCP）是机器人与工作部件接触的部分。您需要设置TCP，以便机器人可以从多个角度（称为“航路点”）移动到相同的位置。

TCP必须位于视觉系统的视野范围内。

注意:该过程是PolyScope软件固有的，为方便起见，本文档中也包含此过程。
  1. 启动 PolyScope 软件。
  2. 在主菜单中，选择 Program Robot。新建程序窗口打开。

  3. 选择 Pick and Place。

  4. 选择 Installation> TCP Configuration。

  5. 要指定 TCP，您可以通过以下方式手动测量它们：

    • 如果 TCP 直接位于Z轴上，则测量 TCP 与工具法兰盘中心之间在Z轴上的距离（以毫米为单位）。在Z输入框中输入测量值。
    • 如果 TCP 不直接位于Z轴上，则测量 TCP 与工具法兰中心之间在X、Y和Z轴上的距离（以毫米为单位）。然后分别在X、Y和Z输入框中输入测量值。

    6. 有关详细说明，请参阅 PolyScope 手册。该手册可以从 Universal Robots 网站下载。


配置视觉系统校准

在该过程中，你将：

  • 训练机器人TCP的模式以使其可以由视觉系统定位。
  • 添加机器人工具。
  • 输入.CXD校准文件的名称。完成校准后，该文件将由Cognex In-Sight 2D机器人引导插件填入校准信息。
  1. 在EasyBuilder中，连接到视觉系统，然后创建一个新的作业。
  2. 选择设置图像。确保工具中心点位于视觉系统的视野范围内。
  3. 在编辑采集设置下，将触发设置为手动.

  4. 调整图像设置以获得聚焦清晰且照明均匀的图像。
  5. 选择定位部件并添加可用于在机器人抓手上定位TCP的工具。
  6. 高亮显示 Patmax 图形工具并选择设置。
  7. 使用水平偏移和垂直偏移设置来调整工具上的十字准线，使其在TCP上居中。

  8. 然后，选择检测部件>校准工具>机器人来添加机器人校准工具。

  9. 选择添加。
    注意:该工具还可使用智能功能，以您可以使用其他功能（例如圆）与机器人校准工具关联。
  10. 在图像上，单击与用于定义TCP工具关联的十字准线，然后单击确定。机器人工具显示在选择板的结果选项卡中，并与图形模式工具连接。

  11. 在工具选择板中选择机器人校准工具（默认名称为Calib_1）。
  12. 在编辑工具中，选择设置选项卡。

  13. 输入.CXD校准文件的文件名。要选择在文件名中包含当前日期和时间，请选中附加日期/时间复选框。全名区域将显示完整的文件名。
  14. 将视觉系统设置为在线。这是视觉系统与机器人通信所必需的。
  15. 使用表示这是校准作业的名称来保存作业。如果你需要在Cognex In-Sight 2D机器人引导插件中重新运行校准，您可以重复使用该作业。


连接视觉系统并执行手眼校准

你可以使用Cognex In-Sight 2D机器人引导插件执行手眼校准。这将在视觉系统的视野内建立工作平面，该工作平面确定了机器人可以操作部件的区域。该插件会创建一个校准文件（.CXD），稍后你需要将该文件导入到你的作业。

通过定义三个设定点来开始校准，这三个设定点将决定工作平面的高度和宽度。

  1. 在 PolyScope 主菜单中，选择Program> Robot> Installation> Cognex。这将会打开 Cognex 窗口。
  2. 在Connection下方，输入视觉系统的IP Address。视觉系统名称会显示在该地址下方。

    如果连接失败，请参阅以下信息进行故障排除：

    如果显示以下错误： 请执行下列操作：
    确保相机处于联机状态并且已加载正确的作业文件。 | 在 In-Sight Explorer 中，检查相机是否在线。
    IP 地址格式无效（示例地址：192.168.0.1） | 在机器人软件中，检查是否输入了该摄像机的正确 IP 地址。
    达到超时。确保在设置机器人网络中启用了网络适配器。 | 在机器人软件中，检查机器人是否在正确的网络上。
  3. 建立并记录工作平面的大小，该工作平面将包括机器人拾取的部件。以下图例显示了宽度和高度的示例点。
    注意:在下面的步骤4到6中，在单击OK之前，您可以通过在In-Sight EasyBuilder中手动触发图像来验证视觉系统是否能看到TCP。

  4. 首先，你需要定义工作平面的宽度。选择（1）Work Plane Corner的Set Point按钮。Move选项卡会显示。使用控件将机器人移动到工作平面的第一个角点，然后选择OK。绿色勾号标记将会显示在Cognex窗口的第一个Set Point按钮旁边。

  5. 选择（2）Work Plane Corner的Set Point按钮。Move选项卡会再次显示。使用控件将机器人移动到工作平面的第二个角，然后选择OK。绿色勾号标记将会显示在Cognex窗口的第二个Set Point按钮旁边。

  6. 接下来，你需要使用第三个设定点定义高度。选择（3）Work Plane Edge的Set Point按钮。Move选项会再次显示。使用控件将机器人移动到与工作平面的远边缘对齐，然后选择OK。绿色勾号标记将会显示在Cognex窗口的第三个Set Point按钮旁边。Width和Height会显示。

    现在Start Calibration按钮会被激活。

  7. 在开始校准之前，请再次检查宽度和高度，以确保它们令人满意。
  8. 要开始校准，选择Stat Calibration。校准完成后，将显示以下消息：Calibration has finished。
  9. 选择Start Program或Continue以关闭窗口。

校准期间，会发生以下情况：

  • 机器人程序将引导机器人移动到视野内的15个点，并将坐标发送到视觉系统。
  • 视觉系统获取图像并确定TCP位置。
  • 机器人程序将TCP坐标与视觉系统像素坐标对应。

校准完成后，Cognex In-Sight 2D机器人引导插件将执行以下操作：

  • 向先前创建的校准作业的机器人工具发送消息。
  • 使用在校准作业中输入的文件名创建校准文件，以及.CXD扩展名。将此校准导入到作业，同时训练机器人将要拾取的部件。
注意:如果视觉系统安装在机器臂上，在为机器人设置参考位姿之前，请勿移动受过训练的部件。设置视觉系统位姿后，你可以设置机器人的对应位姿。


创建部件作业并导入校准

创建作业以训练机器人拾取部件并导入由Cognex In-Sight 2D机器人引导插件创建的校准。

  1. 创建一个新作业并连接到视觉系统。确保拾取的部件位于视觉系统的视野范围内。
  2. 选择设置图像。
  3. 在编辑采集设置下，将触发设置为手动.

  4. 在校准类型中，选择导入。

  5. 在文件名中，选择你在校准作业中输入的.CXD名称。

  6. 选择定位部件并选择所需的用于定位部件的工具。
  7. 如需要，执行其它作业设置。
  8. 选择检测部件。
  9. 选择数学和逻辑工具>机器人引导。

  10. 选择添加，单击部件上的十字准线，然后选择OK。机器人引导工具显示在选择板的结果选项卡中，并与图形模式工具连接。

  11. 在编辑工具中，可根据需要更改工具名称和任何设置。您可通过为工具指定与特定应用程序相关联的名称来自定义工具。
  12. 将视觉系统设置为在线。


设置视觉系统位姿

您可以设置视觉系统位姿选项，以便机器人程序包含视觉系统的正确位置。

  1. 启动你创建的PolyScope程序。主菜单显示：

  2. 在PolyScope主菜单中，选择Program Robot。显示选项卡列表。

  3. 选择Empty Program。

  4. 选择Structure选项卡。程序结构编辑器页面会显示。

  5. 选择URCaps。Cognex Camera Pose按钮会显示，该按钮代表Cognex In-Sight 2D机器人引导插件。

  6. 选择Cognex Camera Pose按钮，然后选择命令选项卡。左侧的机器人程序树现在包含CGX_result; = CameraPose节点和另外三个节点：Job Pass、Job Fail和No Response。

    创建名为CGX_result的文件，该文件将用于存储视觉系统位姿。该位姿对应于视觉系统所找到的部件的位置。

  7. 锁定任何你不希望视觉系统获得的位置。如果将所有旋转都解锁，机器人旋转将相对于机器人抓手的当前旋转，这是当程序到达CGX_result; = CameraPose节点时设置的旋转。要锁定位置，请选中相应的复选框。
  8. 保存程序。
注意:如果视觉系统安装在机器人手臂上，请为机器人设置参考位姿。请参阅设置机器人参考位姿。

设置机器人参考位姿


设置机器人参考位姿

注意:仅当视觉系统安装在机器人手臂上时才需要执行此任务（如果视觉系统未安装到机器人手臂，则可选）。

你可以为机器人设置参考位姿，以使机器人抓手与受过训练的部件对齐。

  1. 在PolyScope的机器人程序树中，选择CGX_result; = CameraPose节点。Cognex 相机位姿窗口显示。

  2. 选择Set Reference Pose。Move工具会显示。

  3. 使用此工具移动抓手，使其与训练过的部件对齐。
  4. 完成后，选择OK。
  5. 如果视觉系统安装在机器人手臂上，请选择Robot Mounted复选框。

    如果视觉系统未安装到机器人手臂上，请不用选择此复选框。

  6. 要保存参考位姿，请保存程序。


为 Universal Robot 编程

设置机器人校准和In-Sight作业后，你可以使用MoveL以及其他机器人命令为机器人的拾取和放置应用程序编程。你还可以决定在作业通过、失败或视觉系统没有响应时该采取何种操作。Cognex In-Sight 2D机器人引导插件提供以下框架：

完成编程并运行应用程序后，当程序到达CGX_result：= CameraPose节点时，会发生以下情况：

  1. 机器人与相机通信以获得训练部件的位置。
  2. 视觉系统触发并返回表示部件位置的位姿。
  3. 位姿存储在PolyScope的程序结构编辑器中的CGX_result变量中。

以下是示例程序结构：


幻灯片

胶片步骤用于配置视觉系统或模拟器，以回放存储到 PC 的图像或审核存储到视觉系统的图像和结果。连接到 PC 后，PC 胶片通常用于短期设置和监视已知的通过和失败图像。

注意:如果幻灯片不能显示，请在视图菜单中点击幻灯片或在 EasyBuilder 工具栏中点击幻灯片按钮 [image] 。

传感器设置

PC 设置


传感器设置

当视觉系统处于联机状态并采集图像时，传感器胶片可用来监视作业表现。采集图像时，作业结果（包括采集的图像和附带的作业数据）将存储到视觉系统的 RAM 中。由于结果被存储到视觉系统中，因此会向胶片添加通过或失败图形。根据视觉系统的分辨率和可用的 RAM，最多可保存 20 个结果。

查看来自联机视觉系统的胶片结果示例

已关闭 配置传感器设置
注意:启用传感器胶片可能会增加作业执行时间; 确保增加的时间对于您的应用程序是可接受的。如果不能接受，可在队列下拉菜单中选择已禁用。

传感器设置组框可用于配置传感器胶片设置：

已关闭 队列

指定要存储的结果; 禁用（未存储结果）、通过结果、失败结果、通过和失败结果或单独的通过和失败结果。（默认 = 已禁用）

注意:
  • 选择单独通过和失败结果时：
    • 队列大小下拉列表被禁用。
    • 启用通过尺寸和失败尺寸下拉列表。
    • 合格结果和失败结果按钮显示在幻灯片旁边; 切换这些按钮以在幻灯片中显示通过和/或失败结果。

已关闭 队列大小

指定要存储的结果数。根据视觉系统的分辨率和可用的 RAM，最多可保存 20 个结果。如果指定的队列大小超出视觉系统的可用 RAM，则会为视觉系统自动分配最大可能的结果数。

注意:当从队列下拉列表中选择单独通过和失败结果时，将禁用此选项。

已关闭 通过尺寸

存储到视觉系统的通过结果的数量。通过大小和失败大小合起来将不会超过分配给视觉系统所支持队列的大小。 此选项仅在从队列下拉列表中选择单个通过和失败结果时才被启用。 （最小值 = 1）

已关闭 失败尺寸

存储到视觉系统的失败结果的数量。通过大小和失败大小合起来将不会超过分配给视觉系统所支持队列的大小。 此选项仅在从队列下拉列表中选择单个通过和失败结果时才被启用。 （最小值 = 1）

已关闭 队列类型

指定是保存仅第一还是最近结果数 (X)，此处 X = 队列大小。（默认 = 最近）

已关闭 置于联机模式时清除

启用（默认）时，每次将视觉系统置于联机状态时都会清除队列。

已关闭 显示模式

指定胶片应该是因失败冻结、因失败暂停还是对失败结果不做任何回应（正常）。（默认 = 正常）

已关闭 暂停延时

如果选择因失败暂停作为显示模式，请指定暂停持续时间（以秒为单位）。（1–120；默认 = 5）

已关闭 LED 样式

在幻灯片中以几何形状显示通过和失败的结果（绿色圆圈 [image] 和红色矩形 [image] ），绿色 OK [image] 和红色 NG [image] 或绿色复选标记 [image] 和红色 X [image] 。

已关闭 保存路径

指定幻灯片图像的保存位置。用户必须具有指定位置的“写入”权限。

已关闭 监视来自传感器的结果

幻灯片可用于作业结果的联机监视或联机/脱机审核。

  1. 单击 EasyBuilder 工具栏中的联机按钮 [image] 将视觉系统置于联机状态。
  2. 触发视觉系统上的图像采集。采集图像时，根据在传感器设置组框中指定的队列设置，图像将被保存到视觉系统并填充进胶片。
  3. 查看胶片上的更新状态图形，该图形表示通过/失败结果。如果发生下列任何一种情况，视觉系统仍会保持联机状态，但幻灯片会停止更新并进入“冻结”模式（通过显示区域顶部的黄色条指示）：
    • 某个结果接收到失败状态，且在传感器设置组框中指定因失败冻结或因失败暂停。

    • 在幻灯片中选择状态图形，单击导航按钮或单击冻结按钮。

    在“冻结”模式下，可以导航幻灯片中的结果，或将图像从视觉系统保存到 PC。所有应用程序步骤都被禁用，以防止无意中编辑作业参数。同时，作业会继续运行，但不会向队列添加任何内容。如果发生以下情况之一，幻灯片会恢复更新且所有应用程序步骤均会启用：

    • 指定的暂停延时终止。
    • 单击继续按钮。
    • 单击清除队列按钮。
  4. 完成监视结果后，再次单击工具栏中的在线按钮，将视觉系统设为离线。
已关闭 将图像从传感器保存到 PC

您可以将图像从联机或脱机视觉系统保存到 PC 上您有“写入”权限的任意文件夹，并使用 PC 回放模式回放图像。

已关闭 检验保存路径
  1. 确认视觉系统已处于脱机状态。

  2. 单击保存路径字段旁边的“浏览”按钮。

  3. 在出现的浏览查找文件夹对话框中，指定所需的目标文件夹，然后单击确定。所选文件夹路径会即刻显示在保存路径字段中。
已关闭 将图像从联机或脱机视觉系统保存到 PC
  1. 在幻灯片中选择一个结果，或单击冻结按钮进入“冻结”模式。此模式由显示区域顶部的黄色条指示。所有应用程序步骤都被禁用，以防止无意中编辑作业参数。同时，作业会继续运行，但不会向队列添加任何内容。

  2. 单击幻灯片中的保存到PC按钮。

  3. 要向目标文件夹添加更多图像，请通过单击幻灯片中的继续按钮或清除队列按钮退出“冻结”模式，同时允许将另一组结果添加到队列中并重复步骤 1 和 2。


PC 设置

回放按钮会启动记录/回放选项对话框，通过该对话框可配置各个视觉系统和模拟器的记录与回放设置。PC 回放模式（可在视觉系统处于联机或脱机状态时访问）允许回放多达 10,000 张图像以帮助验证作业；图像将被发送到视觉系统，而且作业会相对于回放的图像运行。

从 PC 回放时的胶片示例

已关闭 配置记录设置
注意:将彩色图像记录到 PC 时，图像将被保存为 16 位图像，而不是 24 位图像。需要使用彩色图像测试颜色工具时，可通过 FTP（通过在通信应用程序步骤中添加 FTP 设备）导出图像以保存图像并保留完整的色彩深度。
  1. 在 PC 设置组框中单击回放。
  2. 在出现的"记录/回放选项"对话框中，单击记录选项卡。
  3. 选择所需文件夹作为记录文件夹，然后配置其余的记录参数。
  4. 指定所有记录设置后，单击确定关闭"记录/回放选项"对话框。
已关闭 记录图像
  1. 在胶片中，单击 PC 按钮。
  2. 在 EasyBuilder 工具栏中单击记录按钮。
  3. 触发视觉系统上的图像采集。采集图像时，通过和失败图像将自动进行排序并存储到指定的文件夹中。
  4. 再次单击记录按钮停止记录。
已关闭 配置回放设置
  1. 在 PC 设置组框中单击回放。
  2. 在出现的记录/回放选项对话框中，单击回放选项卡。
  3. 选择所需文件夹作为回放文件夹，然后配置其余的回放参数。
注意:默认情况下，回放文件夹是指 EasyBuilder 样本作业文件夹。EasyBuilder 样本作业就记录/回放选项的实用性进行了内容丰富的演示。利用记录/回放选项，可以循环浏览一系列先前采集的图像，提供工具结果的即时反馈，从而得以快速配置阈值和限制。
  4. 指定所有回放设置后，单击确定关闭"记录/回放选项"对话框。
已关闭 回放来自 PC 的图像
注意:要在视觉系统处于联机模式时允许图像回放，必须将设置图像应用程序步骤中的"触发器"参数设置为外部、手动或网络。

  1. 在胶片中，单击 PC 按钮。

  2. 如果已将"触发器"参数（在设置图像应用程序步骤中）设置为照相机或连续，请将视觉系统置于脱机状态以回放图像。如果已将"触发器"参数设置为外部、手动或网络，视觉系统可以保持联机状态回放图像。
  3. 在胶片中，单击播放按钮回放图像，或单击导航按钮（显示如下）手动循环图像。

    4. 播放 | 暂停
选择第一个 | 选择上一个
选择下一个 | 选择最后一个
  4. 单击运行作业应用程序步骤显示结果表（或单击选择板中的结果选项卡）。


保存作业

该步骤允许您实施各种文件管理和传感器维护任务。

注意:如果在用户对话框中的允许在线作业保存复选框被启用，拥有完全或受保护访问权的用户将被允许在线保存作业。如果允许在线作业保存复选框未被启用，视觉系统必须在脱机状态保存作业。

保存（或另存为）作业

配置启动设置

备份归档副本

恢复归档副本


保存（或另存为）作业

保存作业时，只会保存该作业特有的工具设置和信息。

注意:虽然可以在之前的 EasyBuilder 步骤中保存作业，但“保存作业”步骤仍会起到重要的提醒作用。EasyBuilder 未提供任何“自动保存”功能，因此重新启动视觉系统电源后所有未保存的更改都会丢失。

如果之前未保存作业，则“保存”功能的作用将与可打开另存为对话框的“另存为”功能完全相同。

已关闭 保存（或另存为）未保存的作业：

  1. 按 CTRL+S，或单击保存作业组框中的保存或另存为都可打开另存为对话框。
  2. 如果需要，在该对话框中导航到所需的位置。
  3. 指定作业的名称。
  4. 单击对话框中的保存。

已关闭 保存之前保存的作业需要执行以下操作之一：
  • 单击保存作业组框中的保存。
  • 按 CTRL+S。
注意:要保存作业的当前图像，请单击“文件”菜单中的图像另存为...。要保存视觉系统设置和所有图像，请备份 In-Sight 视觉系统或模拟器。


配置启动设置

启动选项部分中的控件指定了开启 In-Sight 视觉系统/传感器或模拟器时会自动运行的任务，包括加载默认作业以及将视觉系统/传感器设置为在线。

注意:只有具有完全访问权限的用户才能配置启动设置。有关更多信息，请参阅用户访问设置对话框。

选择启动作业

  1. 点击 [image] 按钮。 启动对话框将打开。
    1. 在对话框中，选中启动时加载作业复选框。 列表被启用，并显示存储在已连接的视觉系统/传感器上、安装到已连接的视觉系统的 SD 卡或模拟器上的作业。

    2. 如果已启用作业服务器，请选中对话框中的在启动时加载远程作业复选框。 该列表被启用，并显示存储在作业服务器上的作业。有关更多信息，请参阅作业服务器设置对话框。

      注意:
      • 默认情况下，作业服务器会被禁用。 使用作业服务器设置对话框启用和配置作业服务器。
      • 启用作业服务器后，只能选择保存在作业服务器中的作业。 如果需要在启动时加载保存在视觉系统上的作业，则需要先禁用作业服务器。
  2. 选择想在启动时自动加载的作业。
  3. 点击确定。 关闭对话框。

  4. 在作业文本框中显示所选的启动作业。

    注意:
    • 如果选择保存在 SD 卡上的作业，则作业文本框显示“SDCARD / xxx.job”。
    • 作业文本框为只读。 要更改启动作业，请单击 [image] 按钮。
  5. 如果要取消选择启动作业并开始一个空的作业，请再次单击 [image] 按钮并取消选中启动时加载作业或启动时加载远程作业复选框。

在线启动传感器

  1. 选择在线模式启动传感器复选框以在启动时将当前传感器自动设置到联机模式。

    注意:您也可以使用启动对话框来启用此设置。


备份归档副本

具有完全或受保护访问权限的用户，可通过“备份”功能将来自 In-Sight 视觉系统/传感器或模拟器的作业、图像和传感器设置的归档副本保存到用户本地 PC 的硬盘中。

在备份视觉系统/传感器或模拟器之前，请单击系统菜单中的选项，以确保已根据需要定义保存归档数据的目标文件夹或备份目录。

备份当前的传感器或模拟器：

  1. 在传感器维护组框中单击备份。
提示:使用备份拨号（系统>备份），可以将不同视觉系统/传感器/模拟器的备份存储到 PC 或安装到视觉系统的 SD 卡上。有关详情，请参阅备份对话框主题。


恢复归档副本

具有完全或受保护访问权限的用户可通过恢复功能将其本地 PC 中保存的作业、图像和视觉系统设置的归档副本恢复到原始 In-Sight 视觉系统/传感器或模拟器；必须先将副本备份到 PC，之后对话框中才会出现该副本的文件。

将档案副本恢复到当前传感器或模拟器：

  1. 在传感器维护组框中单击恢复。
提示:使用恢复对话框或从...恢复对话框（系统>从...恢复），可以将存档副本还原到不同的视觉系统/传感器/模拟器，或将存储在 SD 卡上的备份还原到视觉系统。有关详情，请参阅恢复对话框主题或从...恢复对话框主题。


运行作业

在所有作业参数设置完成后，你可以运行作业，检查结果并修改或解决设置问题。如果需要的话，测试你的作业以确保参数值设置在范围之内且 In-Sight 视觉系统可以正常采集图像。

在传感器上运行作业

修改或打印结果表格

审核结果表

作业优化和故障排除

使用 TestRun™ 测试作业


在传感器上运行作业

在传感器上运行工作需要将传感器设置为在线。

注意:如果在输入/输出应用程序步骤中强制输入或输出线路处于“打开”或“关闭”状态，则会在作业状态组框中显示警告。在这种情况下，确保传感器在线或离线之前，设备的通电或断电不会造成危害。

将传感器设置为在线或离线：

  • 设置为在线：单击设置选项卡中的在线按钮。该按钮是一个切换，并会变成橙色以显示其联机状态。
    离线时按钮显示的状态
  • 设置为离线：单击设置选项卡中橙色的在线按钮。该按钮将恢复为其原始颜色以显示其离线状态。
    在线时的按钮显示的状态


修改或打印结果表

在设置栏中单击选项以打开“结果显示选项”对话框，可让您修改结果表。

结果显示选项”话框包含以下控制：

已关闭 视图选项

可让您禁用/启用列宽的自动尺寸监控；以百分比或计数显示通过/失败率；并从结果表删除/添加工具图标、时间、结果、工具相依性图形、通过/失败及工具启用状态列。工具启用状态列将显示工具的启用（开启、关闭或相关的输入行）状态，可在定位部件和检测部件步骤中设置。

已关闭 工具选项

可让您在显示区域中隐藏/显示工具的图形重叠（显示图形列），并在结果表中隐藏/显示工具的配置信息（显示工具列）。通过选中或取消复选框将这些设置应用到单独的工具；通过在工具选项组框中单击全部或无按钮将其应用到作业中的所有工具或不应用到任何工具。默认情况下，所有复选框会被选中。

已关闭 恢复为默认值

清除排序，并将结果表重设为默认值。默认列包括通过/失败显示、工具相依性图形、工具图标、名称、结果、通过/失败（显示为计数）和时间。这些列会自动调整以适应 EasyBuilder 视图的宽度。

设置栏中的其它结果表相关的控制：

已关闭 打印

打开打印预览窗口，您可以在该窗口中打印所有页面，使用预设的百分比进行缩放，选择一次性查看的页数，并且可以选择要查看的特定页。您还可以打开页面设置对话框，选择纸张尺寸、来源和方向、页边距及打印机。

已关闭 清除通过/失败

将通过/失败计数恢复为 0，然后重新计数。


审核结果表

设置窗格中的“结果表”显示作业中各个工具的配置信息。要按列为表格排序，请单击列标题；要反转排序顺序，请再次单击列标题。要恢复默认排序，请再次（第三次）点击列标题。同时也可以通过在表格内将工具拖拉到指定的位置来进行排序。

注意:通过将工具拖拉到需要的顺序，可以在结果表格中重新排列工具。该操作可以在运行作业结果表格和选择板结果选项卡中进行。无论在哪个表格中进行的修改，结果将同时会在两张表格中更新。拖拉排序仅在表格的工具顺序和附属图形栏被选择的情况下才能启用(默认情况下，该栏会被选择)。如需颠倒顺序，重新选择该栏。如果作业大小已经接近作业的最大极限，则该功将不能使用。

“结果表”显示下列默认列（从左至右）：

  • 合格/不合格指示：使用绿色圆圈 [image] 和红色矩形 [image] 来分别代表合格和不合格。合格/不合格标准可以在定位部件和检测部件步骤中指定。

  • 工具顺序和相依性图表：显示选定工具的顺序以及所选工具（以橙色突出显示）和其它工具之间的相依性。选择该栏以对添加到作业中的工具进行排序。同时也可通过拖拉工具的方式进行排序。在数学 & 逻辑组工具中的工具可以通过扩展工具或拖拉工具的方式在组中添加或删除工具。

    注意:组工具不能被拖拉到另外一组工具中，且会导致循环引用的工具不能被添加到组工具中。

    当一个工具参考另一个工具时，存在相依性。每组相依关系含有两个部分：先例和依赖，用线连接。先例表示数据来源（即提供输入的工具），用圆表示；依赖是数据目的地（即接收输出的工具），用箭头表示。蓝色相依性图形表示选定的工具是目的地；绿色表示选定的工具为来源。

  • 工具图标：视觉上表示使用的工具类型（例如，存在/不存在边缘、产品识别读取文本、斑点计数）。
  • 名称：列出工具的名称，可以对定位部件或检查部件步骤中工具的默认名称进行更改。

  • 结果：列出工具的数据结果，也会在“定位部件”的“设置”或“范围限制”选项卡窗格或“检查部件”设置空格中显示。

    In-Sight 型号 | 结果

    In-Sight 2000-110 and 2000-120/120C 视觉传感器

             仅限通过/失败状态
    In-Sight 2000-130/130C 视觉传感器

    测量和计数检测工具：标准结果（数字数据）
    存在/不存在图形工具：通过/失败状态和图形分数
    其它工具：仅限通过/失败状态
    In-Sight 视觉系统（所有型号）和 In-Sight 2000 系列 23X 视觉传感器（23M，230）。 | 标准结果（无限制）
  • 通过：以通过结果/总结果（默认）的数目或以百分比显示工具的通过率。

  • 不通过：以未通过结果/总结果（默认）的数目或以百分比显示工具的通过率。

    注意:当某个工具被禁用时，其信号将保持其最后状态。如果工具在被禁用时失败，通过将为 0，失败将为 1。但是，总体作业通过/失败不会受禁用工具的通过/失败影响。
  • 时间（毫秒）：列出运行工具所需的时间。

  • 类型：显示工具类型。例如，PatMax RedLine™图形（1-10）位置工具会显示 PatMax RedLine™图形（1-10），PatMax® 图形（1 - 10）位置工具会显示 PatMax® 图形（1-10）。

    注意:如需隐藏类型列，请右键单击并选择显示类型列。

结果表左侧的作业状态组框显示自上次清除通过/失败计数以来所查看的所有图像的总通过率（Rate），以及当前图像的作业时间（Time）。

  • 修改或打印结果表格


作业优化和故障排除

你可使用这些信息来优化或更正作业设置。

“结果表”可以帮助您排除故障的部分示例包括：

  • 合格/不合格计数：用于确定哪些工具失败。
  • 工具相依性图表：用于通过查看工具间的依赖关系来确定某个工具的失败是否与另一工具的失败有关。
  • 结果字符串：用于确定哪些工具不符合规范。

优化作业往往涉及减少处理时间，这会因各个 In-Sight 传感器的功能而异。只有对于时间性要求高的应用（例如，那些涉及高线路速度的应用），作业优化才有重要意义。

运行 EasyBuilder 作业时，以下阶段最为耗时：

  • 采集时间：采集时间曝光时间 + 到 CCD（电荷耦合器件）的传输时间
  • 工作运行：工具运行所有工具和函数的处理时间总和

以下是一些减少作业执行时间的一般性指导原则：

  • 减少曝光时间。
  • 执行部分采集。
  • 指定较小的关注区域。
  • 最大限度减少图像的旋转。

需要时可以返回设置图像、定位部件或检测部件步骤以相应地修改参数。

此外，主要“位置”和“检测部件”工具的相对速度为（按从快到慢顺序）：

  • 边缘
  • 斑点
  • 图形

因此，如果“边”和“图形”工具提供相同的结果，请使用“边”工具。

注意:由于采集和处理函数可能会重叠，生产中的实际运行时间可能比“运行作业”步骤期间的运行时间短。


使用 TestRun™ 测试作业

TestRun™ 将在 In-Sight 视觉系统上执行测试，并将这些测试结果与期望值进行比较。TestRun 由以下 In-Sight 视觉系统测试组成：

  • 限制测试：查看参数列表并确定当前值是否在为参数配置的上限和下限之间。用户可以直接在作业中配置这些参数设置，也可在读取到作业中的离散输入或由外部设备通过通信协议发送的值中配置。
  • 图像测试：向视觉系统发送一系列质量已知的图像（“良好”和“不良”），并确定当前作业的结果是否与每个图像的期望结果相匹配。
  • 硬件测试：将来自视觉系统的当前图像的质量与期望的图像质量进行对比，确定照相机位置、焦点、光照条件等是否发生了改变。

使用 TestRun 之前的注意事项

注意:TestRun 仅对具有完全访问权限的用户可用。

TestRun 假设以下情形：

  • 已经开发出机器视觉应用程序并作为 .job 文件保存在 In-Sight 视觉系统中。
  • 在已连接步骤中，已经建立了到视觉系统的连接并载入了 .job 文件。
  • 包含应用程序中所用图像的图像数据库已经创建。
注意:在理想情况下，图像数据库将包含“良好”图像（图像结果为“通过”）和“不良”图像（图像结果为“失败”）范例。TestRun 可以运行图像数据库的多种文件组织结构，但是，在启动 TestRun 之前将图像划分到分离的“良好”和“不良”文件夹可以简化流程。

使用 TestRun

连接到所需的 In-Sight 视觉系统并将适用的 .job 文件载入视觉系统后，即可开始 TestRun 配置。使用 TestRun 安装对话框配置 TestRun，该对话框可以提供设定 TestRun 的一系列步骤画面。将在对话框左侧提供导航面板，可以从中选择任一设置画面。

注意:完成 TestRun 的初始配置之后，选择导航窗格中的步骤即可重新访问任一步骤。

配置 TestRun

  1. 在“选择板”中单击 TestRun 选项卡。
注意:如果看不到“选择板”，请在“视图”菜单中选择“选择板”。
  2. 按下配置按钮启动 TestRun 设置对话框。
  3. 按照详细的步骤说明画面配置 TestRun。有关更多信息，请参阅 In-Sight® 浏览器帮助文件。


法律声明

本文档所述软件按照许可提供，仅可根据该许可的条款使用或复制，并须包含本页所示版权声明。该软件、本文档或其任何副本均不得向该被许可方以外的任何人提供或供其使用。该软件的权益和所有权属于 Cognex Corporation 及其许可方。若在非 Cognex Corporation 提供的设备上使用此软件，Cognex Corporation 不对其使用情况或可靠性负责。Cognex Corporation 对于所述软件及其适销性、不侵权性或任何特定目的适用性不作出任何明示或暗示保证。

本文中的信息可能随时更改，恕不另行通知，且不应视作 Cognex Corporation 的承诺。Cognex Corporation 对于可能出现在本文或相关软件中的任何错误概不负责。

除非另有说明，本文示例所用的公司、名称和数据均为虚构。未经 Cognex Corporation 书面许可，不得出于任何目的以任何形式或任何方式（电子或机械）复制或传播本文任何部分，也不得转换为任何其他介质或语言。

06/28/2022 5:48

Revision: 5.9.0.3

版权所有 © 2008 - 2020. Cognex Corporation。保留所有权利。

Cognex 提供的部分硬件和软件可能受到 Cognex 网站列出的一项或多项美国和外国专利、以及未决专利的保护：http://www.cognex.com/patents.

以下为 Cognex Corporation 的注册商标：

Cognex、2DMAX、Advantage、AlignPlus、Assemblyplus、Check it with Checker、Checker、Cognex Vision for Industry、Cognex VSOC、CVL、DataMan、DisplayInspect、DVT、EasyBuilder、Hotbars、IDMax、In‑Sight、Laser Killer、MVS‑8000、OmniView、PatFind、PatFlex、PatInspect、PatMax、PatQuick、SensorView、SmartView、SmartAdvisor、SmartLearn、UltraLight、Vision Solutions、VisionPro、VisionView

以下为 Cognex Corporation 的商标：

Cognex 徽标、1DMax、3D‑Locate、3DMax、BGAII、CheckPoint、Cognex VSoC、CVC‑1000、FFD、iLearn、In‑Sight（带十字准线的设计标志）、In‑Sight 2000、InspectEdge、Inspection Designer、MVS、NotchMax、OCRMax、PatMax RedLine、ProofRead、SmartSync、ProfilePlus、SmartDisplay、SmartSystem、SMD4、VisiFlex、Xpand

本文涉及的其他产品和公司商标是其各自所有者的商标。


格式化输入/输出数据

来自 EasyBuilder 作业的数据，如个别工具结果或整体作业结果（仅对输出），均可通过以太网/IP、DeviceNet、Modbus TCP 和 PROFINET 和 POWERLINK 进行通信。格式化的输入数据将在传感器采集图像之后读取，而输出数据将在传感器完成其作业执行之后发送。

注意: DeviceNet、POWERLINK 和 CC-Link 仅在使用 In-Sight 固件版本 4.x.x 的 In-Sight 视觉系统上可用，在运行 In-Sight 固件版本 5.1.0 和更高版本的 In-Sight 视觉系统上不可用。关于视觉系统型号和支持的固件版本，请参阅固件版本。

如何格式化数据：

  1. 单击格式化输入数据或格式化输出数据选项卡。
  2. 按添加按钮启动选择输入数据或选择输出数据对话框。
  3. 选择输入数据或选择输出数据对话框包含来自添加到作业的任何位置或检测工具的数据以及整个作业结果（仅输出）。在此对话框中，选择您想从 In-Sight 传感器中发送（或发送至）的适当数据，然后按确定按钮。

  4. 在添加数据之后，您可以通过在数据类型下拉列表中选择不同数据类型来修改所选数据的默认数据类型。

    注意:
    • 如果从数据类型下拉列表中选择字符串或字节交换字符串，则将启用元素大小（字节）控制，您可以通过选择正确的字节数来指定字符串长度。
    • 在使用 PROFINET 时，最大输入和输出数据长度是 4,000 字节。在使用 POWERLINK 时，最大输入和输出数据长度是 256 字节。

  5. 你可以通过取消选中高字节/低字节复选框（默认情况下，除 PROFINET 以外所有协议中该选项均为未选中），指定低字节优先或高字节优先来自定义字节顺序。或者，也可以通过取消选中高字节/低字节复选框（默认情况下为未选中状态）指定低字节优先或高字节优先，来自定义字节顺序。在“格式化输出数据”选项卡上所做的任何更改都将在预览窗口中更新。

    注意:对字节或字的顺序作出的任何更改都将影响格式化输出数据和格式化输入数据选项卡中的所有数据信号。
  6. 通过从列表中选择数据，然后单击上或下按钮以设置您所需的顺序，您可以重新排列要发送或接收的数据顺序。


卡尺数组

卡尺数组用于使用边缘模型方法隔离图像区域中的边缘，该区域中的边缘波峰可以使用一维核心在单个卡尺中检测出来。卡尺数组生成包含关注边缘的图像部分的一维表示。此一维图像不但包含关注边缘，而且包含由原始图像中的噪音和其它不需要的信息导致的其它边缘。将利用卡尺数组的工具的边缘选项卡中的卡尺尺寸、边缘宽度和最小对比度参数应用到该一维图像以增加关注边缘的强度，同时减少图像噪音。

数组中的每个卡尺都单独计算，并对其中的边缘候选项进行评分以确定应该选择哪个边缘。对于位置缺陷，将根据每个找到的边缘创建一条最佳拟合线，并通过比较找到的边缘与最佳拟合线的差异是否符合指定的公差来确定缺陷。对于宽度缺陷，计算在卡尺中找到的两条边缘之间的距离以确定它们的距离，并通过比较该距离与预期范围来确定缺陷。

区域中的卡尺数组定义可检测缺陷和/或间距的尺寸。可检测缺陷或间距的尺寸由可以检测的边缘数确定，而可以检测的边缘数由沿边缘放置的卡尺数确定。启用显示所有卡尺复选框后（默认为已禁用），区域中的卡尺将显示为红色矩形。

注意:在区域中应用多个卡尺将增加工具的执行时间。


添加和编辑颜色模型

颜色模型是用来定义图像中的对象和背景的颜色集合。每个颜色模型代表一个 3D 颜色空间，在该空间内可以对所采集对象和背景的颜色的 RGB 值进行加减运算。

已关闭 添加颜色模型
  1. 在“设置”选项卡下的颜色库下拉菜单中选择要引用的颜色库。默认情况下，第一个颜色库 (ExtractColorLibrary_1) 处于选中状态。
  2. 按训练颜色按钮以启动“ExtractColor 训练”对话框。
  3. 在“ExtractColor 训练”对话框的颜色模型组框中，按新建模型按钮向颜色库中添加一个新颜色模型。默认名称为“Model_1”（如果该模型是添加到颜色库的第一个颜色模型；否则，名称将采用递增形式，如“Model_2”、“Model_3”等等）。
  4. 如果需要，可针对您的应用场合将颜色模型重命名为更明确具体的名称，尤其是有多个颜色模型时更是如此。可以随时对颜色模型重命名，突出显示该颜色模型并按颜色库目录上方的重命名按钮即可。
  5. 可通过选中颜色模型并按删除模型按钮将颜色模型从列表中删除。
已关闭 在颜色模型中加减颜色
已关闭 在颜色模型中加减单颜色
  1. 选择要修改的颜色模型。
  2. 在训练组框中，选择最显著的颜色（默认设置）。
  3. 在训练组框中，选择将用于定义颜色的区域的类型：区域、圆、圆环、多边形或徒手画。
  4. 按加上新颜色或减去新颜色按钮，并配置图像内的区域以使其仅包含想要加上或减去的 RGB 值。
  5. 配置完区域后，双击该区域或按“作业编辑”工具栏中的确定按钮。
  6. 对于加运算，添加到颜色模型的颜色包含来自区域内的波峰 RGB 值，这些值将被加到累积颜色模型中。
  7. 对于减运算，添加到颜色模型的颜色包含来自区域内的波峰 RGB 值，这些值将从累积颜色模型中减去。
  8. 可以在颜色模型列表内移动其中的颜色，以对哪个颜色开始或结束运算进行修改。第一个应用于检测的颜色列在首位。
已关闭 在颜色模型中加减多种颜色
  1. 选择要修改的颜色模型。
  2. 在训练组框中，选择多种颜色。
  3. 在训练组框中，选择将用于定义颜色的区域的类型：区域、圆、圆环、多边形或徒手画。
  4. 按加上新颜色或减去新颜色按钮，并配置图像内的区域以使其仅包含想要加上或减去的 RGB 值。
  5. 配置完区域后，双击该区域或按“作业编辑”工具栏中的确定按钮。
  6. 对于加运算，添加到颜色模型的颜色包含来自区域内的波峰 RGB 值，这些值将被加到累积颜色模型中。
  7. 对于减运算，添加到颜色模型的颜色包含来自区域内的波峰 RGB 值，这些值将从累积颜色模型中减去。
  8. 可以在颜色模型列表内移动其中的颜色，以对哪个颜色开始或结束运算进行修改。第一个应用于检测的颜色列在首位。
已关闭 调整颜色公差

通过结合使用图像标记控制和颜色公差控制，可确定对象被检测的程度，并可通过使用“ExtractColor 训练”对话框中颜色公差组框里的增暗、增亮、突出显示和色调设置来调整颜色公差控制以提高或降低工具的灵敏度。

提示:配置颜色公差控制时，将“ExtractColor 训练”对话框放置在能够使您轻松查看图像的位置。根据所选的图像标记类型，在您调整控制的同时，图像会随之更新以反映更改。
已关闭 颜色公差控制
已关闭 增暗

如果增大此设置，颜色会随着空间的增加变深，直至变为黑色 (0, 0, 0)。

已关闭 增亮

如果增大此设置，颜色会随着空间的增加变浅，直至变为白色 (255, 255, 255)。

已关闭 突出显示

如果增大此设置，可从初始的颜色位置开始增加颜色空间，使颜色越变越浅，直至变为白色 (255, 255, 255)。

已关闭 色调

增大此设置可在颜色空间内从三个维度增大初始颜色的 3D“盒”。

已关闭 图像标记控制

图像标记按钮用于确定在对颜色和颜色模型执行加减运算时突出显示图像中的哪些元素。

已关闭 标记整个组的结果

在图像中标记颜色模型内的所有颜色。

已关闭 标记上至所选颜色的结果

如果在包含三个颜色的列表中选择第二个颜色，则在图像中标记第一个和第二个颜色。

已关闭 仅标记所选颜色

在图像中仅标记所选的颜色。

已关闭 编辑颜色模型
  1. 在“设置”选项卡下的颜色库下拉菜单中选择要引用的颜色库。
  2. 按训练颜色按钮以启动“ExtractColor 训练”对话框。
  3. 选择要修改的颜色模型，然后利用对话框中的控制编辑颜色模型。


添加和编辑颜色

颜色由区域定义，并在训练时存储区域中所包含的 RGB 值和 HSI 值的平均值。颜色库最多可包含 100 种不同颜色，这些颜色由所检查对象的 RGB/HSI 值组成。

已关闭 添加颜色
  1. 在设置选项卡的颜色库下拉菜单中选择要使用的颜色库。默认情况下，第一个颜色库 (MatchColorLibrary_1) 处于选中状态。
  2. 点击训练颜色按钮以启动MatchColor 训练对话框。
  3. 在训练组框中，选择将用于定义颜色的区域类型：区域、圆、圆环、多边形、手动画出的区域或点。
  4. 点击添加新颜色按钮，并配置图像内的区域以使其仅包含想要加上或减去的 RGB 值。
  5. 配置完区域后，双击该区域或点击作业编辑工具栏中的确定按钮。
  6. 如果需要，可针对您的应用程序将颜色重命名为更明确具体的名称。在您有多个颜色时该方法会非常有用。可以随时对颜色重命名，突出显示该颜色并点击颜色库目录上方的重命名按钮即可。
  7. 颜色也可通过选中颜色并点击删除模型按钮将其从列表中删除。
已关闭 调整颜色公差

利用颜色公差控制，可确定对象被检测的程度，并可通过使用 MatchColor 训练对话框的颜色公差组框中的设置来调整颜色公差控制以提高或降低工具的灵敏度。

注意:配置颜色公差控制时，将 MatchColor 训练对话框放置在能够使您轻松查看到图像的位置。在调整控制的同时，图像会随之更新并显示更改。
已关闭 变暗

指定变暗限制（0 到 1.0；默认值 = 1.0）。当颜色空间设置为 RGB 时，变暗限制会将比例上较低的已训练颜色沿着一条从 (0,0,0) 开始的线一直扩大到该颜色的 RGB 值。当颜色空间设置为 HSI 时，变暗限制将扩大较低的已训练颜色的强度值。

已关闭 变亮

指定变亮限制（1.0 到 10.0；默认值 = 1.0）。当颜色空间设置为 RGB 时，变亮限制会将比例上较高的已训练颜色沿着一条从 (0,0,0) 开始的线一直扩大到该颜色的 RGB 值。当颜色空间设置为 HSI 时，变亮限制将扩大较高的已训练颜色的强度值。

已关闭 编辑颜色模型
  1. 在设置选项卡的颜色库下拉菜单中选择要使用的颜色库。
  2. 点击训练颜色按钮以启动 ExtractColor 训练对话框。
  3. 选择要修改的颜色模型，然后利用对话框中的控制编辑颜色模型。


边缘较准

当使用含有卡尺数组的工具时，边缘候选项将通过小的颜色编码圆圈来显示。

已关闭 示例 - 合格的最佳拟合直线

已关闭 示例 - 不合格的最佳拟合直线

已关闭 示例 - 不合格的最佳拟合曲线